Microsoft BizTalk Server 2002 について

従来、企業内のアプリケーションを統合するのは難しい作業でした。それを外部の顧客やサプライヤと統合するのは、さらに難しいことでした。しかし、Microsoft® BizTalk™ Server 2002 を使用すると、企業内やインターネットを介した統合のすべての課題を、簡単に、しかも効率的に、解決することができます。下の図は、内部アプリケーションから企業間のビジネス プロセスまでの会社の業務のオーケストレーションの例を示しています。

BizTalk Server 2002 は、内部アプリケーションから企業間のビジネスプロセスまでの会社の業務のオーケストレーションを支援します。

Microsoft® NET Enterprise Servers 製品群の一製品の Microsoft BizTalk Server 2002 は、この 1 つの製品で、 エンタープライズ アプリケーション インテグレーション (EAI) と Business-to-Business (B2B) インテグレーションを実現します。ユーザーの会社が電子商取引のサプライヤであるか、ディストリビュータであるか、アグリゲータであるかに関わりなく、BizTalk Server は会社のすべての業務 (内部アプリケーションから企業間ビジネス プロセスまで) のオーケストレーションを支援します。

BizTalk Server による統合の支援

BizTalk Server に関心をお持ちの方は、何らかのかたちで統合に関わっていることと思われます。会社の補充発注システムとほかの内部アプリケーションの統合に関わっている方もいるかもしれません。新しい Web 商取引システムとバックエンドの製造および配送システムとを統合するという問題に取り組んでいる方もいるかもしれません。また、インターネットを使用して自社のビジネス プロセスを主要なサプライヤやディストリビュータのビジネス プロセスに統合する方法を思案している方もいることでしょう。

BizTalk Server は、XML、HTTP、HTTPS、SMTP、SSL、S/MIME、および x509v3 証明書を強力にサポートし、インターネット標準のテクノロジを適用することによって統合の問題を解決する非常に有力な手段となります。

この概要について

この概要は、BizTalk Server 2002 についての高度な情報を提供しています。ここには、BizTalk Server 2002 を使用してユーザーの会社または組織に固有の電子商取引の問題を解決する方法を理解しやすいように、多くの図やリンク、定義が含まれています。

このセクションでは、次のトピックについて説明しています。

  • 概要

  • BizTalk Server 2002 ヘルプの使用

Copyright © 1999–2001 Microsoft Corporation.
All rights reserved.


概要

Microsoft® BizTalk™ Server 2002 は、企業からインターネットへの疎結合、長時間ビジネス プロセスを統合する、強力な Web ベースの開発環境および実行環境を提供します。BizTalk Server では、数分や数時間ではなく、何週間も何ヶ月も続くようなトランザクションを処理できます。

BizTalk Server 2002 の機能としては、XLANG スケジュールの作成と活用、既存のアプリケーションの統合、ドキュメント仕様と仕様変換の定義、および実行時の利用状況の監視とログの記録があります。

BizTalk Server は、インターネットを利用したドキュメントの送受信のための標準ゲートウェイを提供すると同時に、データの整合性、配信、および安全性を確保する種々のサービスや、BizTalk フレームワークおよびその他の主要なドキュメント書式 (Extensible Markup Language (XML)、電子データ交換 (EDI) など)、およびフラット ファイルをサポートするサービスなど、さまざまなサービスを提供します。

BizTalk フレームワーク 2.0 の詳細、およびコミュニティ サービス、スキーマのライブラリ、およびホワイト ペーパーなどの BizTalk Server 製品の参考情報については、Microsoft BizTalk Server の Web サイト (www.microsoft.com/japan/biztalkserver) を参照してください。

BizTalk Server を使用する理由

BizTalk Server は困難な問題の解決を容易にします。BizTalk Server は、オーケストレーションとメッセージングという 2 つの重要な機能を 1 つの製品に統合しています。強力なメッセージ エンジンがメッセージ転送とマッピングを処理し、BizTalk オーケストレーション サービスが種々のコンポーネントから成るビジネス プロセスと、BizTalk メッセージ サービスを使用して送受信したメッセージのオーケストレーションを処理します。

たとえば、BizTalk Server では次のことが可能です。

  • ダイナミックなビジネス プロセスの作成 : BizTalk Server の基盤を活用して、組織内または組織間の種々のアプリケーションの間でビジネス ドキュメントを交換することによって、ダイナミックなビジネス プロセスをすばやく統合、管理、および自動化できます。BizTalk Server は、ビジネス プロセスのオーケストレーションに必要なすべてのツールによって、複数のアプリケーションや複数の業務にわたるプロセスをインターネット上で構築するのを支援します。

  • アプリケーションと取引先の統合 : BizTalk Server によって、開発者はアプリケーションとビジネスを簡単に統合できます。ビジネス アナリストおよびアプリケーション開発者は、ビジネス ドキュメントのための スキーマの構築、スキーマ変換の実行、取引先との関係の確立、およびデータの追跡と解析のために、一連の豊富なグラフィカル ツールを活用できます。BizTalk Server は、XML および標準のインターネット テクノロジをサポートすることによって、従来の電子商取引および EDI の機能を電子商取引業界全体に拡大します。

  • 公開標準の使用によるインターオペラビリティの確保 : BizTalk Server は、XML、EDI、Hypertext Transfer Protocol (HTTP、HTTPS) などの公開標準および仕様と、公開キー暗号化、デジタル署名などのセキュリティ標準の広範なサポートによって、アプリケーションと取引先との間で高度のインターオペラビリティおよびセキュリティを確保します。

BizTalk Server は、ビジネス ドキュメントのデータおよび構造の定義のために XML を内部的に使用し、またドキュメントを宛先へ配信するために HTTP や SMTP (Simple Mail Transfer Protocol) などの標準インターネット プロトコルを使用します。そのため、いかなる環境で稼動しているアプリケーションであっても、そのアプリケーションがインターネット標準をサポートする限り、相互運用を実現できます。ユーザーは、ドキュメントを XML、EDI、またはフラット ファイルとして BizTalk Server に送ることができます。

BizTalk Server が解決する問題

内部および外部の統合に関連する問題

企業は従来、種々のベンダからさまざまなエンタープライズ アプリケーションを購入してきました。そのため、種々のプラットフォーム上でさまざまなアプリケーションが実行するようになっています。それぞれのアプリケーションは在庫管理や顧客関係管理 (CRM) などの特定の作業のために設計されていたため、ほかのアプリケーションとの統合は一般的には行われていませんでした。その結果、企業内のアプリケーションを統合しようとすると、膨大な費用と時間がかかりました。

統合に関連して、よく次のような問題が指摘されます。

  • アプリケーションがばらばらである :「会社の中で使われているまったく異なるアプリケーションを統合するのはむずかしい。」

  • プログラミングが膨大な量になる :「会社の企業リソース計画のための統合的ソリューションを開発するのに時間がかかりすぎる。」

  • レポートに統一性がない :「データがいろいろなところに保管されているので、いろいろなアプリケーションから統合的なレポートをタイムリーに生成することができない。」

  • 変更が難しい :「内部アプリケーションを統合した後、それを変更するのが面倒で、コストがかかる。」

  • 決まった手順がない :「社内でクリティカルなビジネス プロセスを導入する一貫した方法がない。」

  • 取引先の問題 :「自社のビジネス プロセスを取引先のビジネス プロセスと統合するのが非常に難しい。」

  • 取引先の変更 :「別の企業から有利な取引を提示された場合でも、そのために必要な IT 基盤を考えると、そのような機会を活用するのが難しい。」

今日では、World Wide Web の普及に伴って、電子商取引、すなわちインターネット上でのビジネスが現実的になってきました。しかし、企業内でのアプリケーションの統合が難しいだけでなく、オンライン トランザクションに関連して多くのセキュリティや信頼性の問題があるため、インターネットを通じて顧客やサプライヤと取り引きするのは一層難しいことです。BizTalk Server はこれらの問題を解決するために設計されています。BizTalk Server では、 BizTalk オーケストレーション デザイナや BizTalk エディタなどのグラフィカルなツールを使用して、ビジュアルな設計環境で企業独自のビジネス プロセスを設計できます。次に BizTalk Server は、ビジュアル ダイアグラムを実行し、ビジネス プロセスのための迅速なアプリケーション開発 (RAD) を支援します。

チュートリアル

このマニュアルに含まれているチュートリアルを学習することによって、BizTalk Server 2002 を実際に練習することができます。

  • 「BizTalk Server 2002 の理解」は、BizTalk エディタ、BizTalk マッパー、BizTalk メッセージ マネージャ、BizTalk 管理コンソール、およびBizTalk オーケストレーション デザイナを使用して、ビジネス間の自動調達プロセスを実行する方法についての理解を助けます。

  • 「BizTalk Server 2002 チュートリアル」は、BizTalk Server プロセスを構成する方法をステップごとに説明しています。

  • 「電子調達サンプル」は、BizTalk Server、インターネット、および関連付けを使用して電子調達の全プロセスを実行するサンプルで、これによって会社とサプライヤの間の調達プロセスを自動化する方法を理解できます。

サンプル

BizTalk Server 2002 には、BizTalk Server の多くの機能について説明するための 20 種類以上のサンプルが含まれています。BizTalk Server ソフトウェア開発キット (SDK) に含まれているサンプルは、インストール先ドライブのフォルダ \Program Files\Microsoft BizTalk Server\SDK に置かれています。

BizTalk Server のサンプルは、2 つの分野に分かれています。

  • BizTalk Messaging Services Code Samples

  • BizTalk Orchestration Services Code Samples

このセクションの内容

このセクションでは、次のトピックについて説明しています。

  • BizTalk Server 2002の新しい機能

  • BizTalk Server の対象

  • BizTalk Server の動作

  • BizTalk Server の機能

  • BizTalk Server のアプリケーション モデル

  • BizTalk Server の管理モデル

Copyright © 1999-2001 Microsoft Corporation.
All rights reserved.

このトピックは役立ちましたか。ドキュメントやサンプル、製品全般に関するご意見、ご要望についてはこちらにお送りください。BizTalk Server に関するマイクロソフトへのフィードバック


BizTalk Server 2002 の新機能

Microsoft® BizTalk™ Server 2002 Enterprise Edition では、次のような機能が強化されています。

  • 企業内での BizTalk Server オブジェクトの展開 : BizTalk Server 2002 では、BizTalk Server レプリケーション ドライバがサポートされ、Microsoft Application Center 2000 を使用できることにより、企業内での展開についての機能が強化されました。Application Center 2000 は、異種環境間で BizTalk Server オブジェクトを自動的に移行および同期化することにより、展開を容易にします。Application Center 2000 では、次の 2 種類の展開手法を利用できます。
    • 開発環境から、準備環境を経て運用環境へ展開する

    • 運用サーバー全体に展開する
  • 取引先向けにドキュメント インターフェイスを公開することによる、企業間の展開とテストの期間を短縮 : BizTalk Server 2002 での SEED パッケージの採用によって、企業間での展開の効率が向上します。SEED パッケージには、企業 (ハブ) が取引先 (スポーク) との間で送受信するドキュメントのスキーマと関連情報が格納されます。SEED パッケージは、一回作成すれば多数の取引先で展開できます。取引先で SEED パッケージを開き、取引先の組織独自の構成に対する要求を入力します。構成情報は自動的に作成され、取引先の環境でローカルにテストされます。その次に、リモート サーバーに対してテストされます。構成のテストが終われば、その構成を運用環境に移動できます。BizTalk SEED ウィザードは、取引先でのセットアップ時間や、SEED パッケージのハブでのテスト時間を削減します。

  • 詳細な監視とイベント管理 : BizTalk Server 2002 に導入されている Windows Management Instrumentation (WMI) の新しいイベントや強化されたイベントによって、ビジネス プロセスの管理が可能になります。BizTalk Server 2002 には、このイベント管理の拡張を利用できるように、Microsoft Operations Manager (MOM) に対応する専用の管理パックが収められています。BizTalk Server 2002 Enterprise Edition Management Pack を使うことで、定義済みの警告や規則のセットから選んでアプリケーションに取り入れることができ、単独または複合的イベントから、必要な情報を適宜取得できます。MOM と新しい BizTalk Custom Counters WMI クラスを使うことで、専用の監視アプリケーションを作成することができ、BizTalk Server の内部処理を詳細に確認できるようになります。

  • XML Web サービスのサポートの追加 : アプリケーションが多くの異なるシステム (Web サービスを含む) で作成されるのに伴って、アプリケーションをビジネス プロセスに加えて管理する必要が増しています。BizTalk Server 2002 には、SOAP Toolkit 2.0 Service Pack 2 (SP2) が同梱されており、それによって XML Web サービスを含むビジネス プロセスを連携させることができます。SOAP Toolkit 2.0 SP2 は、Microsoft BizTalk Server 2002 インストール CD-ROM の WebServices ディレクトリに保存されています。

  • リモート管理 : BizTalk Server 管理コンソールは、ツールのみのインストールでインストールされるようになりました。管理コンソールは、BizTalk Server が実行されていないリモート コンピュータにインストールできます。また、環境内の任意のリモート BizTalk Server にアクセスでき、容易で自由度の高い管理機能を提供します。

  • HTTP 受信機能 : BizTalk Server には、新たに高性能な ISAPI HTTP 受信機能が追加されています。この機能は、直接 BizTalk Server 管理コンソールから管理および構成できます。

  • BizTalk オーケストレーション デザイナ内での独立したトランザクション処理と例外処理 : BizTalk オーケストレーション デザイナには、例外処理へのトランザクションの使用を指定するオプションが追加されています。これによってデータベースの読み取りおよび書き込み処理が減り、パフォーマンスが向上します。

  • 統合 SQL セキュリティ : BizTalk Server 2002 では、Microsoft Windows® の統合セキュリティを使用して Microsoft SQL Server™ にアクセスします。つまり、BizTalk Server は、SQL の資格情報を使用するのではなく、Windows 2000 ユーザーの資格情報を使用して SQL での権限を判定します。

  • データベース管理 : 追跡データベースや XLANG ステータス保存データベースの管理に役立つさまざまな新しいユーティリティやスクリプトが追加されました。

  • XLANG の関連付け : ビジネス プロセスを開始すると、複数のスケジュール インスタンスから 1 つのメッセージ キューを使用できるようになります。そして、ビジネス プロセスを継続するために、このキューにある受信メッセージを特定のインスタンスに関連付けることができます。さらに、実行中のビジネス プロセスへの関連付けの処理が容易になります。

  • XLANG スケジュールのプール : "スケジュールのプール" を指定できるようになりました。これは、同時にメモリを使用できるスケジュール インスタンスの最大数を表します。これによりコンピュータのリソースを詳細なレベルまで制御でき、特にハードウェアに制限がある場合に便利です。BizTalk Server 2002 は、パフォーマンスの最適化のために COM+ オブジェクトのプールを利用しています。

  • BizTalk マッパーの強化 : BizTalk マッパーには、次の機能が追加されています。
    • 混在 XML コンテンツをサポートするようになりました。

    • BizTalk マッパーから直接ネイティブ ドキュメント インスタンス (XML および非 XML を含む) のインスタンス テストを実行できるようになりました。

    • グリッドの範囲が、複数のページに対応するように拡張されています。

    • ドラッグアンドドロップの機能が追加されています。

    • Microsoft JScript® を使用して Functoid スクリプトを記述できるようになりました。また、Microsoft Visual C#™ .NET と Microsoft Visual Studio® .NET を使用して、カスタム Functoid アセンブリを記述できます。
  • BizTalk エディタの強化 : BizTalk エディタには、次の機能が追加されています。
    • ネイティブ ドキュメント インスタンスを作成できるようになりました。

    • 混在 XML コンテンツをサポートするようになりました。

    • ドラッグアンドドロップの機能が追加されています。

    • 仕様に対するドキュメント インスタンスの検証が可能になりました。

    • レコード データの入力がサポートされるようになりました。

    • XSD スキーマを BizTalk エディタから直接エクスポートできるようになりました。
  • ドキュメントの充実 : BizTalk Server ヘルプには、次の情報を含む 500 ページ以上の新しいページが追加されています。
    • 新しい「概要」のセクションには、「BizTalk Server の対象」、「BizTalk Server の動作」、および「BizTalk Server ソリューションの構築」のトピックが含まれています。

    • 「BizTalk Server 2002 の理解」には、BizTalk Server に関連する基本的な概念を説明する 7 つのレッスンがあります。また、このレッスンでは、BizTalk Server を使ったソリューションの構築を始めるために必要なツールや処理の理解に役立つ情報を提供しています。

    • 電子調達サンプルは、BizTalk Server 2002、インターネット、および関連付けコンポーネントを使用するサンプルで、自社とサプライヤの間の調達処理の自動化方法を示します。

    • 拡張されたBizTalk Server Developer's Toolboxは、BizTalk Server 2002 を使用または拡張する C++ や Microsoft Visual Basic® プログラミング言語のプログラマに必要なすべての情報を提供しています。
  • そのほかのサンプル : BizTalk Server 2002 には、20 個を超える新しいサンプルが追加されています。これらのサンプルによってこのプログラムの新しい機能を紹介しています。これには、以下の項目を行う方法についてのサンプルも含まれています。
    • WebDAV に格納されているすべての BizTalk メッセージ オブジェクトの更新。「Refresh Messaging Manager」を参照してください。

    • デバッグのための XLANG スケジュールのトレースとログ出力。「XLANG Trace」を参照してください。

    • BizTalk オーケストレーション サービスへの4 MB を超えるドキュメントの送信。「Message Queuing 4 MB Limit」を参照してください。

    • BizTalk メッセージ サービスへのマルチパート MIME (Multipurpose Internet Mail Extensions) 添付ファイルの送付。「Multi-Part MIME Attachment」を参照してください。

    • 複数のドキュメントの XLANG スケジュールへの同期的送付と、クエリへの非同期的送付。「XLANG Submit Synchronously and Query Asynchronously」を参照してください。

    • セルフルーティング ドキュメントの送信。「Self-Routing」を参照してください。

    • 保留キューの監視。「Suspended Queue Monitoring」を参照してください。

    • 信頼できるメッセージの使用。「Reliable Messaging」を参照してください。

    • XLANG スケジュールのプールの使用。「XLANG Schedule Pooling」を参照してください。

    • カスタム カウンタの使用。「Custom Counters」を参照してください。

    • 電子データ交換 (EDI) と EDI 受信確認の使用。「EDI and Receipts」を参照してください。

    • 位置指定フラット ファイルおよび区切りフラット ファイルの使用。「Flat-File Positional」と「Flat-File Delimited」を参照してください。

    さらに、BTConfigAssistant が受信機能をサポートするように強化されています。BTConfigAssistant は、スクリプトによる BizTalk Server メッセージ構成情報の展開をサポートします。

  • 利用可能なビジネス アダプタ : パッケージ化されたアダプタによって、独立したシステムを相互に接続し、異種データ ストアにアクセスすることが可能になりました。これらのアダプタを使うことで、さまざまなシステムやデータへアクセスできるようになり、手動による接続ツールの実装に必要な膨大な量のコーディングを大幅に削減できるか、多くの場合完全になくすことができます。アダプタによって、BizTalk Server 2002 を次のサードパーティ製のアプリケーションやデータに接続できます。
    • データベース

    • ファイル転送プロトコル (FTP)

    • ERP (統合業務パッケージ) アプリケーション

    • CRM (顧客関係管理) アプリケーション

    現在利用できる Microsoft とパートナーの BizTalk Server 用アダプタの完全な一覧については、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。


BizTalk Server の対象

BizTalk Server 2002 は、広範囲の取引先を統合管理するという重要課題を解決します。少数の取引先とのやり取りで生計をたてる小規模な商店から、数百の取引先との関係を存続し、秒単位で数十万のドキュメントを処理する大規模な製造業の会社までさまざまな規模の企業に対応します。

小規模な企業では、BizTalk Server を一対一の接続に使用することもありますが、大企業では、このやり方は効率的ではありません。大規模な企業では、複数の BizTalk Server のグループを分散型の統合バスの形に結合することができます。一般に、大規模な組織は、自主的で独立した事業部門として編成され、独自のシステムを構築して管理します。このような事業部門では、ほかの事業部門で管理されているアプリケーションとデータを共有する必要があり、さらに、外部の取引先と情報交換を行う必要があります。

次の図は、必要時に個別に統合アーキテクチャを構築してきた企業では、どのようにデータが共有されるかを示しています。右側の図は、BizTalk Server 2002 を利用すれば、データ交換がより組織的、効率的に行われることを示しています。

BizTalk Server によってシームレスで効率的なデータ統合が可能になります

既にシステムが確立されている企業では、BizTalk Server を利用することで既存システムを効果的に運用でき、企業間の電子商取引用に既存アーキテクチャを再構築できます。新たにシステムを構築する企業では、最初から BizTalk Server を周囲との主要なリンクとして利用することで、新しいシステムを社内の業務に統合できます。

以下に、実際の業界での使用例を示します。

  • ある健康管理製品メーカーでは、さまざまな電子商取引 プラットフォームとデータを交換するために BizTalk Server を使用しています。

  • 国際的な企業金融市場向けに企業間電子商取引 ソリューションやプロセス オートメーション ソリューションを構築および販売している株式非公開の企業では、データの統合をシームレスに、低費用で効率よく実現するインフラストラクチャの構築に BizTalk Server のテクノロジを利用しています。

  • ある PC メーカーでは、BizTalk Server を使うことで、データやドキュメントをすばやく配信し、サプライ チェーンの関係を統合管理できるようになっています。これにより、サプライ チェーンを改善し、効率化を図り、スムーズでトラブルのない顧客への対応を実現しています。

  • デジタル市場の企業では、インターネット ハブの構築に Microsoft Windows 2000、インターネット インフォメーション サービス (IIS)、および BizTalk Server を使用しています。このインターネット ハブは、将来性のある学生、高校の指導員、大学の採用および入学担当事務局に向けたワンストップショッピングを提供しています。

  • 小中規模の企業向けの財務会計サービスを提供する事業所では、XML と BizTalk Server の利用によって、内部の SAP R/3 アプリケーション スイートを活用した Web サービスを構築しています。

ここには次のトピックが含まれます。

  • BizTalk Server を組織の IT インフラストラクチャに組み込む方法

  • .NET プラットフォームに BizTalk Server を組み込む方法


BizTalk Server を組織の IT インフラストラクチャに組み込む方法

あなたの会社のテクニカル インフラストラクチャはどのような構成ですか? 1 つの Windows プラットフォームまたは UNIX プラットフォームで構築されていますか? おそらくそうではないはずです。ほとんどの大企業ではさまざまなシステムを混在して実行しています。"標準" のプラットフォームが存在する場合でも、企業のビジネスの目標を達成するために、いくつかの異なるアプリケーションを所有し、異なる開発環境を同時に実行しています。

現在使用している構成は、会社の相当量の時間と経費が投資されている実証済みのシステムなので、新しいビジネスの問題を解決するためだけの目的で置き換えるべきではありません。一般に、古いシステムが置き換えられるのは、合理的なビジネス上の理由があるときです。

BizTalk Server は、集中的な、データ ドリブンの統合サーバーと、高度な生産性ツールおよびサービスを提供し、それによってエンタープライズ アプリケーション インテグレーション (EAI) や企業間 (B２B) トランザクションを実行するビジネス プロセスの構築や展開を可能にします。BizTalk Server は、複数のトランスポートとプロトコルのサポートによって、XML に対応する既存の IT 資産を有効活用したり、それを新しい電子商取引テクノロジに取り入れたりするために役立ちます。

次のサポートによって、これまでの IT への投資に XML を付け加え、いっそうその価値を高めます。

  • BizTalk マッパー。このグラフィカル データ マッピング ツールは、XML データと、さまざまな構造を持つ従来データ形式 (EDI、フラット ファイルなど) の間での変換を行います。

  • HTTP、HTTPS、SMTP、SSL、S/MIME、SOAP などの業界標準トランスポートおよびプロトコルのサポート。このサポートによって、既存 IT 資産と Web アプリケーションやサービスとの統合が可能になります。

  • 業界主要ベンダーが提供する標準アダプタを使った、ビジネス アプリケーションへのアクセス。詳細については、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

BizTalk Server は最小のハードウェアとソフトウェアの要件で、既存の IT インフラストラクチャにインストールできます。

XML ツール、BizTalk メッセージ マネージャ、および BizTalk SEED ウィザードなど、BizTalk Server の機能の詳細については、「BizTalk Server の機能」を参照してください。


.NET プラットフォームに BizTalk Server を組み込む方法

Microsoft® .NET プラットフォームには、業界標準やインターネット標準に準拠する総合的な .NET ベースの製品ファミリが含まれています。これにより、XML Web サービスの主要な側面である、開発 (ツール)、管理 (サーバー)、活用 (ブロック サービスとスマート クライアントの構築)、および操作性 (多彩なユーザー 向け機能) がサポートされます。

.NET Enterprise Servers は、電子商取引と全社的なインフラストラクチャの両方に対応します。Windows 2000 Server ファミリは、.NET Enterprise Servers や電子商取引 ビジネス アプリケーションを実行するための高いセキュリティと拡張性を備えた基盤です。

.NET Enterprise Servers には以下のコンポーネントが含まれています。

  • Application Center 2000 は、高い可用性と拡張性を備えた Web アプリケーションを展開、管理するために使用します。

  • BizTalk Server 2002 は、アプリケーションや組織で XML ベースのビジネス プロセスを構築するために使用します。

  • Commerce Server 2000 は、拡張性の高い電子商取引 ソリューションを構築するために使用します。

  • Content Management Server 2001 は、動的な e-ビジネス Web サイトのコンテンツを管理するために使用します。

  • Exchange 2000 Server は、メッセージングとコラボレーションのために使用します。

  • Host Integration Server 2000 は、従来のシステム内にあるデータやアプリケーションへのブリッジとして使用します。

  • Internet Security and Acceleration Server 2000 は、セキュリティ保護された高速なインターネット接続を実現します。

  • Mobile Information 2001 Server は、アプリケーションで携帯電話などのモバイル デバイスをサポートするために使用します。

  • SharePoint Portal Server 2001 は、ビジネス情報の検索、共有、および公開を行うために使用します。

  • SQL Server 2000 は、構造化 XML データの格納、取得、分析を行うために使用します。

Microsoft SQL Server が、データベースのビジネス ロジックを管理し、Microsoft Commerce Server が顧客とのフロントエンドのインターフェイスを処理します。

BizTalk Server は電子商取引を強化するバックエンド ソリューション、またはバックエンド エンタープライズ ソリューションとして利用できます。Microsoft Commerce Server などの購買アプリケーションによって顧客からの製品の発注が処理されると、以前では手動で行われていた購入処理を BizTalk Server が実行します。BizTalk Server は、サプライヤから製品を "購入" し、注文書のやり取りを管理し、さらに内部のエンタープライズ アプリケーション インテグレーション (EAI) を実行します。購入が承認されると、顧客のレコードを財務アプリケーションに送信します。財務アプリケーションは、注文票を配送プログラムに送信します。

さらに、Microsoft Host Integration Server とホスト システム アダプタによって、バックエンドのメインフレームやミニコンピュータに格納されているミッションクリティカル データへのアクセスがサポートされます。Host Integration Server は、メインフレームから取得したデータを展開して、BizTalk Server か Commerce Server に転送します。これにより、メインフレームのハードウェアやソフトウェアを変換または置き換えることなく、e-ビジネス全体の変更を終えることができます。

.NET Enterprise Servers の詳細については、Microsoft .NET Enterprise Servers Web サイト (www.microsoft.com/japan/servers/net/) を参照してください。

BizTalk フレームワーク 2.0 の詳細や、コミュニティ サービス、スキーマのライブラリ、ホワイト ペーパーなど、BizTalk Server 製品の参考情報については、Microsoft BizTalk Server の Web サイト (www.microsoft.com/japan/biztalkserver) を参照してください。

XML Web サービス

電子商取引が企業や消費者の間で拡大しているため、業界では新しいコンピューティング モデルに関心が集中しています。このモデルは、Web 上で情報に接続したり、情報を交換したりするアプリケーションやプロセスの構築を標準する手法です。この新しいインターネット ベースの統合手法は、XML Web サービスと呼ばれ、今までは不可能だった、アプリケーション、コンピュータ、およびビジネスの連携を可能にします。

次の図は、XML Web サービスをさまざまな組み合わせで利用することにより、ユーザー向けの機能を作成できることを示しています。

XML Web サーバによってアプリケーション、コンピュータ、ビジネスの提携が可能になります。

XML ベースのテクノロジである、SOAP はインターネットの標準プロトコルによってアプリケーションどうしの相互運用を可能にします。また、UDDI (Universal Description, Discovery, and Integration) は、標準化された方法でサービスの記述や自動接続を可能にします。これらのテクノロジの利用によって、XML を使って Web ベースのサービスを提供する新しいソフトウェアを作成できます (UDDI の詳細については、www.uddi.org の Web サイトを参照してください)。XML Web サービスは、異なる言語地域の異なるシステムを結合する自由度の高いテクノロジであり、個人のコンピューティング、大企業のコンピューティングおよび Web を統合します。XML Web サービスはプログラミングや再使用が可能です。インターネットのどこからでもアクセスできることを除けば、コンポーネント ソフトウェアとよく似ています。このモデルを使用するプログラムは、複数の Web サイトで実行でき、それぞれのサイトから情報を取得したり、サービスを受けたりできます。そして、取得した情報を結合し、任意の書式ですべてのデバイスに配信できます。

Microsoft .NET プラットフォームは、XML Web サービスの構築、展開、操作、および統合を可能にします。以下に、XML Web サービスの 4 つの原則を示します。

  1. システムはインターネット経由で接続すること : この原則は、インターネットが実現する高い可用性と低費用の接続性のおかげで、実現が容易な前提条件です。

  2. ビジネスに利用できるサービスをインターネット上で簡単に見つけることができる方法が存在すること : UDDI は、業界内の多くのベンダーが参加する取り組みで、いくつかの大企業も協賛しています。UDDI は、ほかの企業が提供しているサービスを検索および把握するための手段になります。

  3. 情報の共有のため、1 つの共通言語を使用すること : XML はこの原則を実現可能にする要素です。XML は、共通のデータ形式をサポートしますから、取引先や顧客にシステムと交信する際に、特定のプログラミング言語やアプリケーション、オペレーティング システムなどの使用を要求することなく、データや情報の利用を続けることができます。

  4. 実際にビジネスを実施する方法が存在すること : たとえば、サービスの呼び出し、予定の登録、パーツの注文、および情報の提供などが同じプロトコルで行うことができなければなりません。このプロトコルを SOAP と呼びます。SOAP は、システムがほかのシステムと交信したり、要求を作成したりするのを可能にします。SOAP は、インターネット ネイティブ インテグレーションの新しいモデルです。

以上の 4 つの原則によって、XML Web サービスを提供するためにシステム、アプリケーション、およびプロセスに対する接続、検索、変換、およびトランザクションを実行することが可能になります。

BizTalk マッパー、BizTalk エディタ、および BizTalk オーケストレーション デザイナなどのツールにグラフィカル インターフェイスを組み込むことで、BizTalk Server は、アプリケーションや組織全体にわたる XML ベース ビジネス プロセスの構築において中心的な役割を果たします。XML Web サービスと Microsoft .NET プラットフォームについての詳細は、www.microsoft.com/net または www.microsoft.com/japan/net の Web サイトを参照してください。


BizTalk Server の動作

Microsoft BizTalk Server 2002 は、2 つの主要なサービスで構成されています。ビジネス プロセス間でメッセージを送信するために使用する BizTalk メッセージ サービスと、ビジネス プロセスを作成するために使用する BizTalk オーケストレーション サービスです。

統合における問題

統合における問題については言うまでもありません。組織内でのアプリケーションの統合には、常に大きな痛みが伴います。さまざまなオペレーティング システムにさまざまなアプリケーションがインストールされ、それぞれ異なる言語で記述され、異なるプログラミング モデルをベースにしているなど、この問題については直接に体験しているでしょう。そして、あなたの仕事はそれらをすべて接続できるようにすることです。

しかし、電子商取引の分野では、統合の作業はいっそう複雑です。内部のシステムの統合だけでなく、内部のシステムの処理を外部の顧客や主要なサプライヤのシステムと統合する必要があります。これには、XML Web サービス、HTTP または SMTP による配信、および XML を利用したデータ形式の定義などの開放的なテクノロジが必要になります。そして、これらすべてをインターネット経由で実現する必要があります。

競争力を持ち続けるために、企業は内部や外部との統合で他社よりも優れた作業を行う必要があります。従来は、内部の統合と外部の統合の問題の相違は、ポイントツーポイント接続の方法の違いであると考えられていました。しかし、接続は目的のための手段にすぎません。本当の目的は、ビジネス プロセスを統合することです。

通常、企業の内部では専用のデータ形式を使用しています。また、従来は、同期リモート プロシージャ コール (RPC) のメカニズムを使用していました。しかし、統合する内部アプリケーションが増えるのに伴って、同期モデルの信頼性や可用性が心配になってきます。これを解決するために、現在多くの企業は、"同期非同期" という同期的に見える非同期モデルに移行しつつあります。

それでは、何から統合を始めるべきでしょうか? ビジネス プロセスの統合といえば聞こえはよいですが、この作業は、しばしば接続が正しく機能するためだけの目的に専任の仕事が必要になる場合があります。また、最後には、正しい情報を正しい場所へ正しい時刻に到着させることが仕事になってしまいます。

このような場合に BizTalk Server は大いに役立ちます。

BizTalk Server によるビジネス プロセスの統合

BizTalk Server を使うことで、ビジネス アナリスト、IT 技術者および開発者が同じ環境で作業できるようになります。これらの作業者は、すべてのアプリケーション、プラットフォーム、および組織で動作する統合アプリケーションの定義、設計および展開を迅速に行うことができます。

BizTalk Server によって、組織内や組織間で動的なビジネス プロセスを連携させるのが容易になります。

具体的には、BizTalk Server で、次の操作ができます。

  • アプリケーション統合が単純になります。アプリケーション、組織、および時間の限界を越えた、分散型のビジネス プロセスを簡単に作成、管理および追跡できます。

  • 製品化までの期間を短縮できます。短期間に顧客や主要取引先との間で、信頼性が高く、セキュリティで保護された企業間 (B2B) 取引の関係をインターネット経由で確立できます。

  • 既存 IT 資産を利用できます。既存の異種アプリケーションを、プラットフォームに依存せず、標準を使った費用効率の高い方法で統合できます。

ここには次のトピックが含まれます。

  • BizTalk メッセージ サービス

  • BizTalk オーケストレーション サービス

  • BizTalk Server ソリューションの構築

  • 管理性、信頼性、柔軟性

  • BizTalk サーバーのアクセラレータ


BizTalk メッセージ サービス

BizTalk メッセージ サービスには次のような機能があります。

  • 受信ドキュメントの受信

  • 特定の書式を判定するドキュメントの解析

  • キー識別子の抽出と特定の処理規則の識別

  • 送信先へのドキュメントの配信

  • ドキュメントの追跡

また、データ マッピング、受信確認の生成と関連付けなどのサービス、およびデータの整合性とセキュリティを維持するサービスなども含まれています。

BizTalk メッセージ サービスを使用するコード サンプルについては、「BizTalk Messaging Services Code Samples」を参照してください。

メッセージ構成の手法

BizTalk Server で取引先とのドキュメント交換や企業内でのアプリケーション統合を処理するために BizTalk メッセージ サービスを構成する方法は 2 つあります。それらは、次のとおりです。

  • BizTalk メッセージ マネージャ。メッセージ ウィザードを含むグラフィカル ユーザー インターフェイスです。

  • BizTalk メッセージ構成オブジェクト モデル。直接アクセスできるモデルです。

BizTalk メッセージ マネージャまたは BizTalk メッセージ構成オブジェクト モデルを使用すると、データ交換を処理するためのメッセージ ポートとチャネルを作成することができます。また、メッセージ ポートとチャネルの作成に使用する、ドキュメント定義、エンベロープ、および組織を作成できます。さらに、メッセージ ポートのグループである同報リストを作成することもできます。

メッセージ サービスの構成

次の図は、ドキュメント仕様の作成とメッセージ サービスの構成時に行う手順を示しています。

最初に、BizTalk エディタを使って、ドキュメント仕様をグラフィカルに作成します。ドキュメント仕様は、Extensible Markup Language (XML) ファイルの一種で、ドキュメントの構造、種類、およびバージョンを定義します。取引先が異なる書式のドキュメントを必要とする場合は、BizTalk マッパーを使用することによって、ドキュメントのデータを取引先で使用できる書式にマップできます。

メッセージ サービスを構成するには、作成した仕様を参照するドキュメント定義を設定する必要があります。この定義は、BizTalk メッセージ構成オブジェクト モデルへアクセスすることで設定できます。メッセージ構成オブジェクト モデルには、BizTalk メッセージ マネージャのグラフィカル インターフェイスを通じてアクセスするか、アプリケーション プログラミング インターフェイス (API) を使って直接にアクセスします。概念的には、XML 仕様と BizTalk ドキュメント定義は等価です。ただし、技術的には、作成方法や保存方法で大きく異なります。仕様は、BizTalk エディタで作成するドキュメントであり、XML ファイルとして WebDAV リポジトリに格納します。ドキュメント定義は、(BizTalk メッセージ マネージャか API を使って) BizTalk メッセージ構成オブジェクト モデルから作成するオブジェクトです。BizTalk Server が使用する SQL Server データベースの BizTalk メッセージ管理データベースに格納します。BizTalk Server ドキュメント定義は、オブジェクト形式に変換された XML 仕様と考えることができます。

ここには次のトピックが含まれます。

  • 受信機能

  • トランスポート サービス

  • データ パーサー

  • データ検証

  • 信頼できるメッセージ

  • セキュリティ

関連項目

BizTalk Messaging Services Code Samples

メッセージ サービスの概要

BizTalk メッセージ マネージャの使用


受信機能

BizTalk Server 2002 には、指定した場所にポストされたドキュメントをサーバーが監視できるようにする受信機能があります。BizTalk Server では次の受信機能をサポートしています。受信機能は BizTalk Server 管理コンソールを使用して構成します。

  • ファイル

  • HTTP

  • メッセージ キュー

BizTalk Server 2002 は次の受信プロトコルもサポートします。プロトコルは ASP ページまたは Microsoft Exchange スクリプトを使用して構成します。

  • .asp ページを使用する HTTP (Hypertext Transfer Protocol)

  • .asp ページを使用する HTTPS (Secure Hypertext Transfer Protocol)

  • Microsoft Exchange スクリプトを使用する SMTP (Simple Mail Transfer Protocol)

  • インターネット インフォメーション サービス(IIS) の FTP サービスとファイル受信機能を使用するファイル転送プロトコル (FTP)

関連項目

データ パーサー

データ検証

受信機能

信頼できるメッセージ

セキュリティ

トランスポート サービス


トランスポート サービス

BizTalk Server 2002 には、目的の場所にドキュメントを送信できるようにするトランスポート サービスがあります。BizTalk Server は次のトランスポート サービスをサポートします。

  • HTTP (Hypertext Transfer Protocol)

  • HTTPS (Secure Hypertext Transfer Protocol)

  • SMTP (Simple Mail Transfer Protocol)

  • ファイル

  • メッセージ キュー

  • アプリケーション統合コンポーネント (AIC)

  • ループバック

関連項目

データ パーサー

データ検証

受信機能

信頼できるメッセージ

セキュリティ

トランスポート サービス

Copyright © 1999-2001 Microsoft Corporation.
All rights reserved.

このトピックは役立ちましたか。ドキュメントやサンプル、製品全般に関するご意見、ご要望についてはこちらにお送りください。BizTalk Server に関するマイクロソフトへのフィードバック


データ パーサー

BizTalk Server 2002 は、ANSI X12、UN/EDIFACT、フラット ファイル、有効な整形式 XML など、さまざまな種類の業界ドキュメント標準に対するデータ パーサーをサポートします。また、ご利用の独自のカスタム パーサー コンポーネントを作成、登録および使用することができます。

BizTalk Server は BizTalk フレームワーク 2.0 もサポートします。BizTalk フレームワーク 2.0 の詳細については、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

関連項目

データ検証

受信機能

信頼できるメッセージ

BizTalk メッセージ サービスのスケール アウト

セキュリティ

トランスポート サービス


データ検証

BizTalk Server 2002 では、仕様に対応するドキュメントの各インスタンスを確認することによってデータを検証できます。ドキュメントが仕様の規則に従っていない場合、ドキュメントの分析を継続するか、自動的なエラー修正を行うために、保留キューに配置します。

関連項目

データ パーサー

受信機能

信頼できるメッセージ

セキュリティ

トランスポート サービス


信頼できるメッセージ

BizTalk Server 2002 では、BizTalk メッセージ サービスのプロパティを構成することで、信頼できるメッセージを使うことができます。プロパティには、ドキュメントを送信するためのサービス時間帯の設定、受信確認の送受信、再試行回数の設定、および再試行間隔の設定が含まれます。BizTalk Server は、信頼性の高いメッセージ機能を提供する BizTalk フレームワーク準拠のエンベロープをサポートします。BizTalk フレームワーク 2.0 の詳細については、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。また、BizTalk Server は、特定の場所のキューに集中的にドキュメントを入れます。サーバーに障害が発生した場合、ロールオーバー機構により、新しいサーバーがドキュメントの制御を引き継ぎ、処理を続けることができます。

関連項目

データ パーサー

データ検証

受信機能

セキュリティ

トランスポート サービス


セキュリティ

Microsoft BizTalk Server 2002 を使用することで、企業は取引先と安全にデータを交換できます。BizTalk Server では、Microsoft Windows 2000 セキュリティでサポートされている次のセキュリティ機能を活用しています。

  • Windows アカウント セキュリティとローカル ポリシー

  • Windows と Microsoft SQL Server™ の統合ログオン セキュリティ

  • Microsoft コンポーネント サービスのセキュリティとロール

  • 公開キー基盤 (PKI)

  • CryptoAPI

  • スマート カード

  • Kerberos プロトコル

BizTalk Server 2002 では、BizTalk Server 2002 のトランスポート サービスで転送されるすべてのドキュメントに対して、S/MIME (Secure Multipurpose Internet Mail Extensions) の証明書を利用した公開キー暗号化やデジタル署名がサポートされます。また、BizTalk Server は、受信するドキュメントの暗号解読と署名検証をサポートします。

関連項目

データ パーサー

データ検証

受信機能

信頼できるメッセージ

トランスポート サービス

セキュリティについて


BizTalk オーケストレーション サービス

BizTalk オーケストレーション サービスについての説明を始める前に、"オーケストレーション" という言葉について考えてみましょう。音楽を想像されたのではないでしょうか? オーケストラの指揮者は、数十人の演奏家を選出して、みごとに 1 つのハーモニーを創り出します。指揮者がいなければ、それぞれの演奏者は途方にくれてしまいます。40 人のそれぞれの演奏者が、演奏の前に楽器の練習をしているのを聞いたことがありませんか? それは、まさに無秩序です。しかし、名指揮者がひとたび指揮をとれば、40 名の演奏家のそれぞれの音がオーケストラのハーモニーの中に溶け込みます。

これが、BizTalk Server でのビジネス プロセスの処理方法に相当します。

ビジネス プロセスはアクションの論理的順序を決定

ビジネス プロセスの統合は、多くの場合各システムが公開している外部インターフェイスを把握することや、メッセージの転送に使用するメッセージ書式、仕様を把握することで進められます。また、セキュリティ、メッセージのエンコード、信頼できるメッセージなど、サービス品質の問題についても検討が必要になります。ただし、メッセージのアドレス指定や、送受信の処理だけでは、ビジネス プロセスの統合の全体的なソリューションとしては十分でありません。

元のメッセージをどのようにして作成しますか? また、どのようにメッセージを受信し、処理し、さらに応答しますか? もっとも単純な場合を除いて、これらの処理はビジネス プロセスです。ビジネス プロセスは、アクションの論理的順序と、対応するメッセージのフローを決定します。そして、各業務の担当者間でのメッセージ交換用プロトコルを定義します。

今日のビジネス プロセスのほとんどは、カスタム コードを使って作成されています。これは、ご使用のビジネス プロセスも同じではないでしょうか。結果的に、企業では、今日の急速な環境の変化の下で発展するビジネス ニーズに対応するために、短期間でビジネス プロセスの実装を変更しなければならなくなっています。BizTalk オーケストレーション サービスは、ビジネス プロセスの作成におけるカスタム コードの記述作業をなくすことでこの問題を解決します。これにより、環境が短期間で変更になります。

BizTalk Server によるビジネス プロセスの連携

BizTalk オーケストレーション サービスは、分散型ビジネス プロセスの設計、展開、管理を行うための新しい手法を提供します。BizTalk オーケストレーション サービスは、ビジネス ロジック全体を管理するビジネス プロセスを設計するために使用します。BizTalk Server は、実行時エンジンと設計時ツール BizTalk オーケストレーション デザイナを組み合わせることによって、ビジネス プロセスの連携を可能にします。BizTalk オーケストレーション デザイナを使えば、ビジネス間の連携をすべて Microsoft® Visio® グラフィカル インターフェイスの画面上で視覚的に行うことができます。そして、BizTalk Server が、XLANG スケジュールという実行ファイルにワークフローを保存します。XLANG スケジュールは、実行時エンジンがビジネス プロセスを実行するために使用します。各ビジネス プロセスをバインドするためのコード作成はありません。コーディングを行うのは特殊なビジネス ロジックの個々のコンポーネントに対してであり、それらの結合のために行われるのではありません。

BizTalk オーケストレーション サービスは、長期にわたって実行されてきたビジネス プロセスと、これを実行するアプリケーションを統合します。この統合は、XLANG スケジュールによって提供されます。その他のサービスにより、実行されている XLANG スケジュールのインスタンスに対する制御が提供されます。

BizTalk オーケストレーション サービスの鍵となる機能は、数分や数時間ではなく、何週間も何ヶ月も続くような複雑なトランザクションを処理できる能力にあります。BizTalk オーケストレーション サービスは、単一の XLANG スケジュール内に同時アクションを実装できます。さらに、BizTalk オーケストレーション サービスがビジネス プロセスの状態を管理するため、これを管理するカスタム コードを記述する必要がない利点もあります。

BizTalk オーケストレーション サービスを使用するコード サンプルについては、「BizTalk Orchestration Services Code Samples」を参照してください。

ここには次のトピックが含まれます。

  • XLANG スケジュール

  • 実装テクノロジ

  • XLANG 言語

関連項目

BizTalk Orchestration Services Code Samples

BizTalk オーケストレーションの設計


XLANG スケジュール

XLANG スケジュールは、プロセスの各ステップをそのステップを実行するテクノロジ コンポーネントまたはサービスに接続することによって実装されるビジネス プロセスです。そして、XLANG スケジュールは、XLANG スケジューラ エンジンと呼ばれるサービスによって実行されます。エンジンは、XLANG スケジュールのインスタンス作成、実行、ステータス退避、およびステータス復元、またはスケジュールの複数のインスタンスを制御します。

関連項目

実装テクノロジ

XLANG 言語

XLANG スケジュール

Copyright © 1999-2001 Microsoft Corporation.
All rights reserved.

このトピックは役立ちましたか。ドキュメントやサンプル、製品全般に関するご意見、ご要望についてはこちらにお送りください。BizTalk Server に関するマイクロソフトへのフィードバック


実装テクノロジ

BizTalk オーケストレーション サービスでは、次のような実装テクノロジがサポートされています。

  • BizTalk メッセージ サービス

  • COM コンポーネント

  • メッセージ キュー サービス

  • Windows スクリプト コンポーネント

  • コンポーネント オブジェクト モデル (COM) の相互運用性を利用した、Microsoft .NET ベースのコンポーネント

関連項目

ビジネス プロセスの実装

XLANG スケジュール

XLANG 言語


XLANG 言語

XLANG は、さまざまなテクノロジ コンポーネントまたはサービスを使用したビジネス プロセスの実装と、ビジネス プロセスの論理シーケンスを記述する言語です。XLANG 言語は Extensible Markup Language (XML) で表現されています。

関連項目

実装テクノロジ

XLANG スケジュール

XLANG インターフェイス


BizTalk Server ソリューションの構築

BizTalk Server ソリューションを構築するときには、あらかじめ方針を立てておく必要があります。つまりドキュメントが適切に配信されるようにするために、ソリューションが実行する方法を決定しておかなければなりません。

たとえば、次のような問題について検討する必要があります。

  • ドキュメントの配信、ドキュメントの受信、またはその両方を行う必要があるか?

  • どのドキュメントを転送する必要があるか?

  • ドキュメントはどこに転送する必要があるか?

  • ドキュメントをいつまでに到着させる必要があるか?

  • どのドキュメント形式を使用するか?

  • ドキュメントの転送にどのプロトコルを使用するか?

  • 新しい統合システムに接続しなければならない既存システムはないか?

  • その既存システムはどのようなファイルの種類を要求するか?

上記の問題やそのほかの問題を基にした決定は、従来はプロジェクトの設計段階で行われ、次に、プログラマのチームによって数週間から数か月の期間をかけて実装されていました。BizTalk Server では、視覚的な設計ツールの BizTalk オーケストレーション デザイナを使って、短期間でビジネス プロセスを構築できます。

2 つのサービスを統合する標準的な方法に、単独で実行されている XLANG スケジュール インスタンスにメッセージを関連付ける方法があります。すなわち、XLANG スケジュール インスタンスに内部アプリケーションや取引先へメッセージを送信させて、メッセージが返されることを期待します。たとえば、注文書を送信して、注文書の受信確認の返送を期待します。

BizTalk Server で XML ツールを使った場合には、開発工程が次の表に示されている順序になります。

開発作業 | 従来の方法 | BizTalk Server での方法
ビジネス プロセスの図式表現 | 紙またはホワイトボードにビジネス プロセスを書き出すか、CASE ツールを利用します。 | BizTalk オーケストレーション デザイナを使い、XLANG スケジュール フローチャートで図形や接続を結合します。
ビジネス プロセスの実装 | コードを手作業で記述し、目的のビジネス ロジックを表現します。 | XLANG スケジュールをコンポーネントにバインドして有効な実行コードをフローチャートに適用していきます。
ドキュメントの構造の設計 | ドキュメントの構造を決定し、その情報をプログラミング部門に渡します。次に、その部門で言語を選択し、手作業でコードを記述してドキュメント構造を表現します。 | ドキュメント仕様を BizTalk エディタで作成します。
自社のデータと取引先のデータの同期 | ドキュメント構造内で、データ形式を読み書きするコードを手作業で記述します。 | BizTalk マッパーを使って自社のデータ形式を取引先のデータ形式に視覚的にマップします。
自社と取引先との間の通信を構成 | ドキュメントやメッセージを送信および受信するコードを手作業で記述します。必要に応じて、メッセージキューや構成を実行するコードを記述します。 | チャネルとポートを BizTalk メッセージ マネージャを使って作成します。
ソリューションの展開 | 取引先からの新規ドキュメントを受信するように手動でシステムを構成します。そして、取引先のシステムから自社のシステムを利用できるように、取引先側で、システムを構成、展開するコードを記述してもらいます。 | Microsoft Application Centerを使用して自社内に展開します。次に、BizTalk SEED ウィザードを使用して、取引先用の構成と展開情報をパッケージ化します。
ドキュメントの監視。 | ドキュメントを監視および追跡するコードを手作業で記述します。パフォーマンスの統計値を作成し、カスタム コードによってレポートを作成します。 | Microsoft Operations Manager (MOM) と 追跡データベースを使って警告の通知を監視し、パフォーマンスの統計値を取得し、データベースを監視します。

ビジネス プロセス用の RAD

RAD (Rapid Application Development) の概念は、実装時にソリューションが陳腐にならないように、短期間でソフトウェア ソリューションを作成、展開するために生まれたものです。RAD の手法で実装を効率よく行えば、開発時間を短縮できるばかりでなく、開発にかかる費用も削減できます。

BizTalk Server は、BizTalk オーケストレーション デザイナ、BizTalk エディタ、およびBizTalk マッパーなどの強力な XML ツールのサポートによって RAD の概念を企業間のビジネス プロセスの開発に取り入れます。

BizTalk Server によって、短期間での重要な成功の条件を満たしつつ、長期的なインフラストラクチャの投資も有効に活用できます。

ここには次のトピックが含まれます。

全社的なアプリケーションの統合

企業間の統合

ビジネス プロセス オートメーション


全社的なアプリケーションの統合

それぞれのアプリケーションは、組織内で実証済みの効率化されたシステムです。今日、企業は、ビジネスの重要な業務、たとえば消耗品の発注、製造の計画、および顧客からの注文への対応などの実行をアプリケーションに頼っています。エンタープライズ アプリケーション インテグレーション (EAI) は、独立したアプリケーションどうしでのデータの電子的な共有を可能にします。

メッセージングの視点から見れば、EAI テクノロジは 1 対多および多対 1 のメッセージング関係を作るアプリケーションの統合手法に分類されます。このモデルでは、アプリケーションどうしがお互いを認識する必要がありません。データを BizTalk Server に渡して、適切なアプリケーションにルーティングさせることができます。この統合方法は、アプリケーションどうしを直接統合するのではなく、ビジネス領域のデータ配布インフラストラクチャによってアプリケーションを統合することに重点を置いています。EAI モデルでは、アプリケーションをビジネス ネットワーク データ バスに接続することができます。そして、システム間に強い依存性を作成することなく、アプリケーションをビジネス プロセスのフローに加えることができます。

BizTalk Server は、XML や、従来のファイル形式 (位置指定ファイル、区切りテキスト ファイルなど) のようなオープンな標準をサポートし、それによって、ほかのアプリケーションと統合できます。多くの場合、既製のアダプタによって、異種のシステムとの統合が簡単になります。アダプタは API の集合であり、BizTalk メッセージング エンジンを使用することで BizTalk Server とほかの特定のアプリケーションとの間でのトランザクションが可能になります。BizTalk Server は、現在さまざまなビジネス アプリケーションに対するアダプタをサポートしており、さらに作成中のアダプタも多数あります。単純化して言えば、アダプタはユーザーに代わって業務を行います。ユーザーはロー レベルの EAI コードの記述に時間を費やす代わりに、独自のビジネス プロセスの向上に集中することができます。現在利用できる Microsoft とパートナーの BizTalk Server 用アダプタの完全な一覧については、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

関連項目

企業間の統合

ビジネス プロセス オートメーション


企業間の統合

1990 年代のインターネットの普及は、企業間 (B2B) プロセスを生み出しました。企業は、B2B プロセスによって、主要取引先や顧客とデータを交換できるようになりました。自社のビジネス プロセスを取引先のビジネス プロセスと統合する場合には、当然のことながらデータの交換に使うドキュメント書式に互換性が要求されます。

BizTalk Server は、組織内や組織間で XML ベースのメッセージの形式にデータを変換してルーティングします。これには、異なるソフトウェアやハードウェア プラットフォームを使用する組織も対象となります。

ただし、B2B の統合は、エンタープライズ アプリケーション インテグレーション (EAI) と置き換わるものではありません。これらは、実際には相補的な関係にあります。一般に、企業間の各トランザクションには 2 つの EAI トランザクションが含まれています。1 つは、ドキュメントの取得で、もう 1 つはほかのコンピュータへのドキュメントの転送です。たとえば、注文書を自社のバックエンド システムからインターネット経由で取引先のバックエンド システムに転送する必要があるとします。B2B 統合は、企業間でのトランスポートを実現しますが、ユーザーの側で EAI の実装によって、注文書を社内のバックエンド システムからフロントエンド サーバーに移動する必要があります。

BizTalk Server は、全体の処理を連携させるのに役立ちます。

関連項目

ビジネス プロセス オートメーション

全社的なアプリケーションの統合


ビジネス プロセス オートメーション

ビジネス プロセス オートメーション (BPA) は、開発プロセスの全体像を示します。これは、全体の処理が統一されたビューで表現される点で重要です。従来は、一連の異種コンポーネントの操作が、紙の上でしか定義できない方法で行われていました。電子商取引の世界では、処理を一企業内に限定することはできなくなっており、多くの場合、いくつかの組織やシステムに処理範囲が広がることによって効率が向上します。BPA はプロジェクトの知的財産を取り出し、それをソフトウェア自身に組み込みます。これにより、既存のビジネス プロセスを短時間で理解し、必要に応じて変更できます。

関連項目

企業間の統合

全社的なアプリケーションの統合


管理性、信頼性、柔軟性

BizTalk Server では、管理しているビジネス プロセスの定義とメンテナンスを行うツールをサポートしています。また、Windows 2000 プラットフォームでサポートされている管理機能を利用しています。

ここには次のトピックが含まれます。

  • 管理性

  • 信頼性

  • 柔軟性


管理性

BizTalk Server に含まれるBizTalk メッセージ マネージャによって、社内と外部取引先との両方に対して、分散型のビジネス プロセスを定義したり、全アプリケーションの関係を管理したりできます。

さらに、BizTalk Server には次のようなサポートがあります。

  • BizTalk Server が使用している重要なサービスやキューの監視を行う Microsoft 管理コンソール (MMC) スナップイン。

  • イベント情報へのロー レベル アクセス用の Windows Management Instrumentation (WMI) プロバイダ。このプロバイダは、Windows イベント ログに適当なイベントを書き込みます。

  • 主要な属性のパフォーマンス カウンタによる公開。これによって、Windows 2000 環境に慣れた管理者は、サーバーの動作を監視および管理できます。

  • データ追跡および分析サブシステムの問い合わせ用の Web ベースのインターフェイス。これにより、BizTalk Server の実行したビジネス処理の結果を表すデータの検索やアクセスが可能になります。

また、BizTalk Server の動作を監視するために、Microsoft Operations Manager (MOM) 2000 や Microsoft Application Center 2000 を使用することができます。

Microsoft Operations Manager

Microsoft Operations Manager (MOM) 2002 は、Microsoft のサーバー オペレーティング システムやサーバー ベース アプリケーション用のイベント収集、パフォーマンス監視、およびレポート出力を行うツールです。MOM は主に、広範なリソースの監視、管理、セキュリティ保護を行い、予防的なリアルタイム システム監視をサポートすることによって Windows 2000 ネットワークとアプリケーションの可用性、パフォーマンス、セキュリティを向上させます。

MOM には次のような特長があります。

  • イベントドリブン処理監視

  • 自動展開型で拡張性の高いソリューション

  • 高度なセキュリティ ポリシーの強制と監視機能

  • システムの可用性とパフォーマンスの追跡の向上

  • さまざまなデータ表示およびレポート出力方法

Microsoft Application Center 2000

Microsoft Application Center を使用して、BizTalk Server の構成をある環境から別の環境に展開することができます。たとえば、構成をテスト環境から運用環境へ移動できます。Application Center を環境の展開に使うことで、構成を移動するために必要な時間と、移動に付随する手作業での操作量を大幅に削減できます

関連項目

Microsoft Operations Manager について

柔軟性

信頼性

Application Center 2000 の使用

Application Center を使った電子調達の展開


信頼性

BizTalk Server 2002 は、もっとも厳しい処理要求を扱うことができるように設計されています。特に、BizTalk Server では共有キューの概念に基づいて処理が実行されるため、複数のサーバーが中央にある処理キューから作業を取り出すことができます。処理されるすべての作業は、1 つのキューに送信されます (フォールト トレランスのために、このキューをバックエンド上でクラスタにすることができます)。このキューは、Microsoft SQL Server 上に置かれています。次に、1 台または複数台の処理サーバーによってこのキューから作業が取り出されます。

高い拡張性が要求される場合には、サーバーを処理のアレイに追加することができます。BizTalk Server をインストールするとき、共有キューをポイントすることによってそれをサーバーのグループに加えることができます。それによって高い拡張性を実現する "スケールアウト" の手法をとることができます。つまり、少量の処理負荷の場合は 1 台か 2 台のサーバーで負荷を処理し、1 日に数百万件のドキュメントを処理することが要求されるような場合には、要求に応じてサーバー アレイに 5 台、10 台またはそれ以上のサーバーを追加していくことができます。1 台のサーバーまたは複数の協調して動作するサーバー上で、より高いスケールアップを実現するために、Windows 2000 Datacenter Server では、システム上の BizTalk Server で 8 基までの CPU の使用をサポートしています。

組み込みの冗長性

冗長性サーバー (ローカル ハード ハードディスクにデータが格納されない) とデータが格納される通常のサーバーを区別する必要があります。BizTalk Server では、グループ内のすべてのサーバーから単一の BizTalk Server データベース サーバーにネットワーク経由でアクセスできるため、常に冗長性や拡張性を持たせることができます。グループ内の特定のサーバーに障害が発生した場合には、ほかのサーバーが処理を受け継いで、引き続きデータベース サーバーへアクセスできるようにします。これは、グループ内のどのサーバーもローカル ディスクに作業用データを格納していないために可能になります。ただし、リモートのデータベース サーバーが利用できなくなると、グループ内のすべてのサーバーが非アクティブになります。常時利用できる状態にするには、1 台のサーバーに障害が発生しても中央のデータベース サーバーを常に利用可能にする Microsoft クラスタ サービスを使用します。

クラスタ サービスの採用は、次の 2 つの要素を判断して決定します。

  • ローカル ディスクに重要なデータを格納しているサーバーが利用できなくなったときに、業務上許容できるダウン時間の長さ。

  • 冗長性を実現するハードウェアとソフトウェアの追加に使用できる予算

単純な冗長性を実現するにも、最低 2 台のサーバーが必要です。

関連項目

管理性

柔軟性


柔軟性

BizTalk Server は、統合にインターネット標準のテクノロジを適用する好例です。BizTalk Server は、以下の標準をサポートするように設計されています。

  • Extensible Markup Language (XML)

  • HTTP (Hypertext Transfer Protocol)

  • HTTPS (Secure Hypertext Transfer Protocol)

  • SMTP (Simple Mail Transfer Protocol)

  • SSL (Secure Sockets Layer)

  • S/MIME (Secure Multipurpose Internet Mail Extensions)

  • SOAP

  • x509v3 証明書

BizTalk Server は、プラグイン コンポーネントやソフトウェア開発キット (SDK) によって拡張することができます。さらに、BizTalk Server での主要な XML ベースの標準のサポートは、ほかのシステムのアプリケーションや、別のオペレーティング システム、プログラミング モデルまたはプログラミング言語との統合を可能にします。

アクセラレータとアダプタ

BizTalk Server では、XML のデータ形式や多数の非 XML データ形式をサポートしています。非 XML データ形式には、たとえば、電子データ交換 (EDI) やフラット ファイルなどがあります。ただし、内部的なファイル形式やエンベロープ形式は、カスタム シリアライザとパーサーの使用によってサポートされます。これらは、業界向けのアクセラレータの一部として入手するか、BizTalk Server Developer's Toolbox を使って作成できます。詳細については、「BizTalk サーバーのアクセラレータ」を参照してください。

BizTalk Server では、いくつかの既製のサードパーティ アダプタをサポートしており、異種システムの統合も簡単です。アダプタは API の集合であり、BizTalk メッセージング エンジンの使用することで BizTalk Server とほかの特定のアプリケーションとの間でトランザクションを利用できるようにします。現在利用できる Microsoft とパートナーの BizTalk Server 用アダプタの完全な一覧については、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

トランスポート プロトコル、Functoid、アーキテクチャ

BizTalk Server では、多くの有力なトランスポート プロトコルをサポートしています。それらには、DCOM,、メッセージ キュー、HTTP、HTTPS、SMTP、FTP などがあります。さらに、BizTalk Server では、Host Integration Server 2000 プラグインと MQSeries アダプタを利用することで MQSeries や SNA プロトコルを利用できます。

BizTalk Server では、Functoid という変換関数を使ってドキュメントを変換することができます。Functoid は作成や再使用が可能です。総合的な Functoid のセットが BizTalk マッパーでサポートされています。また、カスタム Functoid は、BizTalk Server Developer's Toolbox で作成することができます。

BizTalk Server のアーキテクチャでは、データベース サーバー、受信サーバー、処理サーバーを適切に組み合わせて、処理要求の処理に使用することができます。

XML と XML 関連のテクノロジ

BizTalk Server は、XML をサポートすることによって、さまざまなプラットフォームで動作するアプリケーションのオープンな統合を可能にします。

さらに、BizTalk Server には次のような特長があります。

  • XML を内部の既定フォーマットとして使用しています。

  • メモリ内に格納されたドキュメントへのアクセスに XML ドキュメント オブジェクト モデルを使用します。

  • XML ドキュメント ノードへのアクセスに XPath をサポートしています。

  • ドキュメント形式の変換用の標準として Extensible Stylesheet Language Transformation (XSLT) を使用します。

  • 明確なセマンティクスを実現するために XML 名前空間をサポートしています。

  • データの入力、名前空間のサポート、およびモデルの拡張性を高めるために、XML スキーマの機能的なサブセットである XML-Data Reduced (XDR) を通して XML スキーマ テクノロジを使用しています。

関連項目

管理性

信頼性


BizTalk Server のアクセラレータ

Microsoft は、特定の市場や業界において BizTalk Server 2002 の開発効率とパフォーマンスを大幅に向上するアクセラレータを提供しています。

現在、Microsoft は、以下の業界に向けた BizTalk Server のアクセラレータを提供しています。

  • 健康保険の標準 : BizTalk Accelerator for HIPAA

  • 複数のサプライ チャネル : BizTalk Accelerator for Suppliers

  • サプライ チェーンの標準 : BizTalk Server Accelerator for RosettaNet


BizTalk Accelerator for HIPAA

Microsoft BizTalk Accelerator for HIPAA は、医療取引の標準規定である Health Insurance Portability and Accountability Act of 1996 (HIPAA) に準拠するデータ交換用統合ソリューションの開発と展開を容易にします。HIPAA は、米国内の個人および団体に対する健康保険の適用範囲について、移行性と継続性の向上を主な目的として規定されたものです。HIPAA は、医療団体が情報を電子的に転送するとき、HIPAA に準拠するように規定しています。HIPAA の最終目的は、医療関係業者の業務に影響を与えることなく医療費を削減することにあります。今日、医療費負担についての HIPAA の取引だけで各種コンテンツに対して 400 種類以上の送信形式があります。HIPAA が導入された後 (2002 年 10 月 16 日に導入される予定) は、1 種類のコンテンツの集合と 1 つのフォーマットに集約され、すべての支払い者がこれを使用する必要があります。

Microsoft は、この分野を専門とし HIPAA の実装ガイド (www.wpc-edi.com/hipaa) を独占的に発行する Washington Publishing Company (WPC) と共同で、BizTalk Accelerator for HIPAA を提供しています。このアクセラレータは、健康保険業界で標準ベースのテクノロジ ソリューションを構築するのに役立ち、HIPAA の規定に準拠するために必要な経費や時間を削減します。HIPAA の適用対象となる医療関係の団体は、WPC の提供する HIPAA のリソースとともに BizTalk Server 2002 の統合機能を使用することができ、ビジネス プロセスの自動化や、統合ソリューションの短期間での構築が可能になります。これにより、医療関係の団体は、既存の IT 資産を利用しながら、連邦法に準拠できます。BizTalk HIPAA スキーマの結合による、BizTalk Server 2002 と医療関係団体の既存システムとの相互運用性は、HIPAA の規定に準拠するツールを生み出します。

BizTalk Accelerator for HIPAA の詳細については、Web サイト www.microsoft.com/biztalk/evaluation/hipaa/ を参照してください。


BizTalk Accelerator for Suppliers

Microsoft BizTalk Accelerator for Suppliers は、サプライヤが複数のオンライン チャネルを利用してより効率的に販売を行うための、拡張性の高いソフトウェア ソリューションとして利用できます。このアクセラレータは拡張性の高いアーキテクチャの上に構築されており、社外 (B2B) の取引先や社内の基幹ビジネス アプリケーションに接続できます。たとえば、ERP (統合業務パッケージ) システム、サプライ チェーン マネジメント システム、CRM (顧客関係管理) システムなどの社内システムに接続できます。既成の Web ページによって、リモート ショッピングの標準を利用しながら、簡単に独自の顧客向け Web ページを作成できます。

BizTalk Accelerator for Suppliers には、次のような利点があります。

  • 収入とビジネスの敏捷性を向上させます。Biztalk Accelerator for Suppliers を使えば、収入を増やし、既存の顧客との関係を強めることができます。さらに、非電子的な処理から発生する取引の経費を削減します。効率良く新しい市場に参入し、市場の変化にタイムリーに対応できるため、企業経営の機敏さを高めることができます。また、企業は、新しい販売チャネルにアクセスでき、アクセラレータでサポートされている、さまざまなテクノロジ、プロトコル、データ形式、およびビジネス プロセスなどをベースにした機能を利用できます。

  • 競争において自社を差別化するための手段となります。BizTalk Accelerator for Suppliers は、サプライヤの商品やブランドの利点を電子メディアで公開する能力を企業にもたらします。経費を削減し、新しい顧客を獲得するための業務を促進し、同時に既存顧客に対する業務を強化することができます。

  • 経費を削減し、既存資産を活用できるようにします。ERP、サプライ チェーン、CRM、物流、およびコラボレーションなど、既存のビジネス プロセスやテクノロジ資産を強化、補強します。

BizTalk Accelerator for Suppliers の詳細については、Web サイト www.microsoft.com/japan/biztalkserver/evaluation/suppliers/ を参照してください。


BizTalk Server Accelerator for RosettaNet

Microsoft BizTalk Server Accelerator for RosettaNet には、いくつかのアプリケーションが含まれています。これらのアプリケーションによって、RosettaNet の標準に準拠する Partner Interface Process (PIP) を実装した XLANG スケジュールを開発、管理、およびテストできます。さらに、スキーマ管理とメッセージ構成用に 2 つのアプリケーションが用意されています。このソリューションは、RosettaNet ベースのソリューションを構築するために必要なアプリケーション アダプタとサーバー プラットフォームをサポートしています。構築したソリューションによって、アプリケーションを統合し、取引先をサプライ チェーンに接続し、複雑なコラボレーティブ ビジネス プロセスを連携させることができます。

BizTalk Server 2002 と結合された BizTalk Server Accelerator for RosettaNet に含まれているアプリケーションによって、ユーザーはサプライ チェーンのビジネス慣行を効率化し、取引先やサプライヤとの間で RosettaNet 標準を利用したコラボレーションを行うことができます。BizTalk Server Accelerator for RosettaNet アプリケーションの概要を以下に示します。

  • PIP Administrator : このアプリケーションは、データベースのすべてのパスワード情報を含み、ユーザーから XLANG スケジュールの場所を指定できるようにします。

  • PIP XLANG Schedule Tester : このアプリケーションは、ユーザーでの XLANG スケジュールのテストを可能にします。

  • PIP Schema Manager : このアプリケーションは、ドキュメント仕様のマージに使用します。

  • Messaging Configuration Wizard : このアプリケーションによって、ユーザーは組織を取引先としてセットアップできます。このアプリケーションは構成スクリプトを生成し、生成されたスクリプトは、BizTalk メッセージ構成オブジェクトをプログラムから呼び出して、必要なポートやチャネルを作成、構成します。

BizTalk Server Accelerator for RosettaNet の詳細については、Webサイト www.microsoft.com/japan/biztalkserver/evaluation/rosettanet/ を参照してください。


BizTalk Server の機能

次の表は、BizTalk Server の機能とその用途を示しています。

機能 用途
管理
  • サーバーとアプリケーションの管理

  • BizTalk オーケストレーション サービス
  • サーバーとサーバー グループを作成および管理します。

  • 共有キュー データベースおよび追跡データベースの場所などのグローバル サーバー グループのプロパティを構成します。

  • サーバーの設定を構成します。

  • 受信機能を構成および管理します。

  • ドキュメント キューを表示および管理します。

  • XLANG スケジューラ システム マネージャ、グループ マネージャ、XLANG スケジュール インスタンス、および XLANG ポートにプログラムによってアクセスします。
ドキュメント トラッキング
  • ドキュメントの追跡
  • Microsoft BizTalk Server 2002 によって処理されるドキュメントの進行状況を追跡します。

  • BizTalk Server 2002 によって処理されるインターチェンジまたはドキュメントの完全なコピーを検索、表示、および保存します。

  • 追跡データベースから基本的な情報を見やすい形式で抽出するためのクエリを作成します。

  • ドキュメントから重要なユーザー定義データを抽出、保存、および解析します。
オーケストレーション デザイン
  • BizTalk オーケストレーションの設計
  • ビジネス プロセスを表すフローチャートを作成し、統合された設計環境でフローチャートをプログラムによって実装します。

  • XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルします。

  • ビジネス プロセスのメッセージ間のデータのフローを定義できます。
メッセージ
  • BizTalk メッセージ マネージャの使用

  • メッセージ サービスについて
  • BizTalk メッセージ マネージャを使用して、データの交換をローカルおよびリモートで管理します。

  • BizTalk メッセージ構成オブジェクト モデルを使用して、データの交換をプログラムで管理します。

  • チャネル、メッセージ ポート、ドキュメント定義、エンベロープ、および同報リストを作成および管理します。
XML ツール
  • BizTalk エディタの使用

  • BizTalk マッパーの使用
  • ドキュメントの仕様を作成および管理します。

  • レコードおよびフィールドを作成し、それらのプロパティを設定します。

  • 送信元仕様のレコードおよびフィールドを送信先仕様のレコードおよびフィールドにマップします。

  • Functoid を使用して、強力なデータ変換機能を実装します。
展開
  • BizTalk SEED ウィザード
  • SEED パッケージを利用して、インターネット経由で自社の構成を利用できるようにすることで、取引先のシステムを短期間で立ち上げます。


BizTalk Server のアプリケーション モデル

Microsoft BizTalk Server 2002 には、実行可能アプリケーションの作成用ツールやサービスがあり、取引先と業務用アプリケーション間のビジネス プロセスやデータ交換の管理に使う実行可能アプリケーションを作成できます。BizTalk Server 2002 でサポートされる機能の一覧については、「BizTalk Server の機能」を参照してください。

BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合することにより、取引先と複数のトランスポート サービスを使用する内部アプリケーションとの間のドキュメントおよびメッセージの交換を管理することができます。また、次の機能も提供します。

  • 複雑な長時間トランザクションとビジネス プロセスの制御

  • 信頼性の高いドキュメント配信およびメッセージ配信

  • 仕様に対する各ドキュメント インスタンスを確認することによるデータ検証

  • ドキュメントの構造および書式を変換するためのマップを使用したデータ マッピング

  • 暗号化証明書とデジタル署名証明書を使用したデータ セキュリティとデータ インテグリティ

  • 受信確認の生成と照合のサポート

受信確認を送信および受信するための BizTalk Server の構成については、「受信確認について」を参照してください。

BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合する方法の詳細については、「BizTalk サービスの統合」を参照してください。


BizTalk Server の管理モデル

次の表は、Microsoft BizTalk Server 2002 における管理の主要な 4 つの領域と、各領域に関連する管理機能を示しています。

管理の領域 管理機能の概要
サーバー管理
  • サーバー グループとサーバーを構成および管理します。

  • 受信機能を構成および管理します。

  • キューを管理します。
アプリケーション管理
  • XLANG スケジュールを提供する COM+ アプリケーションを構成および管理します。

  • 既定の XLANG スケジューラ アプリケーションを構成および管理します。
プログラムによる管理
  • XLANG システム マネージャ、XLANG グループ マネージャ、XLANG スケジュール インスタンス、および XLANG ポートを構成します。
データベース管理
  • 次のデータベースを構成、管理、および保守します。
    • BizTalk メッセージ管理

    • オーケストレーション データベース

    • 追跡

    • 共有キュー

サーバー管理

BizTalk Server 2002 では、サーバー管理にサーバー グループの管理と構成、サーバーの追加/削除/構成、受信機能の追加と構成、各サーバー グループの共有キューの管理などの作業が含まれます。次の表は、一般的なサーバー管理作業、その説明、および詳細の参照先を示しています。

管理作業 説明 詳細の参照先
サーバーおよびサーバー グループの構成
  • 追跡データベースおよび共有キュー データベースへの接続を構成します。

  • トランスポート サービスとパーサーの順序を構成します。

  • サーバーの設定を構成します。
  • サーバー グループの追加、削除、および構成

  • グループ内のサーバーの追加、削除、および構成
キューの管理
  • インターチェンジとドキュメントを削除および再送信します。

  • データおよびエラー メッセージを表示します。
  • キューの管理
受信機能の管理
  • 受信機能を構成します。
  • サーバー グループの受信機能の管理
トラブルシューティング
  • 問題のあるサーバーおよびドキュメントをトラブルシューティングします。
  • イベント ビューアの管理

  • BizTalk Server 管理のトラブルシューティング

アプリケーション管理

アプリケーション管理には、XLANG スケジュールを提供する COM+ アプリケーション、既定の XLANG スケジューラ アプリケーション、および BizTalk Server 2002 をインストールしたときに作成されるオーケストレーション データベースの構成と管理が含まれます。次の表は、一般的なアプリケーション管理作業、その説明、および詳細の参照先を示しています。

管理作業 説明 詳細の参照先
既定の XLANG スケジューラ アプリケーションの管理
  • XLANG スケジューラ アプリケーションの既定の設定を変更します。
  • 既定の XLANG スケジューラ アプリケーションおよびデータベースの管理
COM+ アプリケーションの管理
  • 特定の XLANG スケジュールを実行するための COM+ アプリケーションを作成します。
  • XLANG スケジュールをホストするそのほかの COM+ アプリケーションの管理

プログラムによる管理

サーバーとアプリケーションの管理は Microsoft BizTalk Server 2002 でプログラムによって行うことができます。次の表は、一般的なプログラム管理作業、その説明、および詳細の参照先を示しています。

管理作業 説明 詳細の参照先
XLANG スケジューラ システム マネージャ、グループ マネージャ、XLANG スケジュール インスタンス、および XLANG ポートの構成と管理
  • XLANG スケジューラ システム マネージャおよびグループ マネージャについての情報を開始、停止、および取得します。

  • グループに関連付けられているすべてのスケジュールについての情報を停止、中断、再開、および取得します。
  • BizTalk オーケストレーション サービス
アプリケーション統合コンポーネント (AIC) の作成
  • カスタム コンポーネントを作成します。

  • 基幹業務 (LOB) アプリケーションを統合します。

  • 暗号化、暗号解読、およびデジタル署名の機能を追加します。
  • BizTalk Custom Components
ドキュメントとインターチェンジの使用
  • 保留キューへアクセスします。

  • 追跡データベースを読み取ります。

  • ドキュメントを送信します。

  • インターチェンジおよびドキュメント データを表示します。
  • BizTalk Documents

  • ドキュメントと WMI

  • Displaying the Contents of a Document or an Interchange

  • WMI タスク
ファイル受信サービスの管理
  • 作成、削除、取得などのファイル受信機能を実行します。
  • 受信サービスと WMI

  • WMI タスク
キューの管理
  • キューのグループを取得します。

  • すべてのキューを取得します。
  • キューと WMI

  • WMI タスク
サーバー グループの管理
  • 作成、削除、取得などのサーバー グループの機能を実行します。
  • グループと WMI

  • WMI タスク
サーバーの管理
  • 作成、削除、開始、停止などのサーバー グループの機能を実行します。
  • サーバーと WMI

  • WMI タスク
BizTalk メッセージ管理データベースの管理
  • BizTalk メッセージ管理データベースを作成および取得します。
  • BizTalk メッセージ管理データベースと WMI

  • WMI タスク
取引先との関係の管理
  • データの交換用にメッセージ ポートとチャネルをセットアップします。

  • ドキュメント定義とエンベロープを作成します。

  • 組織のプロパティを設定します。
  • BizTalk メッセージ サービス

Windows Management Instrumentation (WMI) および WMI アプリケーション プログラミングの詳細については、MSDN Online Library (www.microsoft.com/japan/developer/library/default.asp) で「WMI アプリケーション プログラミングについて」を検索してください。

データベース管理

データ ファイルの圧縮やデータベースおよびトランザクション ファイル ログのバックアップなど、通常のデータベースのメンテナンスと管理に加え、BizTalk Server と Microsoft SQL Server の間の接続のメンテナンス、データベースの追加/削除/復元、新規データベースの構成など、データベースに関連するその他の作業も行う必要があります。次の表は、一般的なデータベース管理作業、その説明、および詳細の参照先を示しています。

管理作業 説明 詳細の参照先
データベースの管理
  • BizTalk メッセージ管理データベースを構成および変更します。

  • 新しい永続化データベースを作成および構成します。

  • 追跡データベースと共有キュー データベースを復元および手動削除します。
  • BizTalk メッセージ管理データベースの構成

  • サーバーの BizTalk メッセージ管理データベースの変更

  • 新しい空のステータス保存データベースの作成

  • サーバー グループのデータベースの管理
データベースへのトラフィックの監視
  • サーバーの設定を構成します。
  • サーバーのプロパティについて

  • サーバーのプロパティの最適化


BizTalk Server 2002 ヘルプの使用

ここでは Microsoft® BizTalk™ Server 2002 ヘルプについて説明します。

ここには次のトピックが含まれます。

  • BizTalk Server 2002 ヘルプの詳細については、「ヘルプについて」を参照してください。

  • ヘルプを使用する手順の詳細については、「ヘルプに関する作業を行う方法」を参照してください。


ヘルプについて

Microsoft BizTalk Server 2002 ヘルプは、情報の書式設定と表示に HTML を使用しています。ヘルプ ビューアには、総合目次、キーワード、および全文検索機能があり、これらを使用して情報を簡単に探し出せます。ブック アイコンを開くと、サブブックとトピックが表示されます。目次を展開し、ブック内のトピックを表示するには、ブック タイトルの横の展開記号 (+) をクリックします。折りたたみ記号 (-) をクリックすると、トピックが折りたたまれます。ヘルプ ビューアでは、ヘルプ トピックを表示したままで、目次、キーワード、または検索結果を表示することもできます。

ヘルプ ビューアには [お気に入り] タブがあり、これを使用してトピックにブックマークを設定することができます。これにより、頻繁に参照するトピックをすばやく表示できます。

BizTalk Server 2002 の詳細を確認するには、目次を使用してヘルプ全体の内容を参照できます。目次内のトピックをクリックすると、ヘルプ ウィンドウの内容ペインに情報が表示されます。

目次は、BizTalk Server 2002 の主な機能ごとに、ブック単位でまとめられています。それぞれのブックには、次の項目の一部またはすべてが含まれています。

  • 「<機能/関連概念> について」 : これらの章には、BizTalk Server 2002、その機能、および関連概念についての説明や一般情報が含まれています。

  • 「<機能名> に関する作業を行う目的」 : これらの章は、特定の作業を実行する目的についてのクイック リファレンスです。

  • 「<機能名> に関する作業を行う方法」 : これらの章には、手順と作業に関連する情報があります。

  • 「<機能名> のトラブルシューティング」 : これらの章には、問題を解決するためのヒントがあります。

プログラミング情報については、「BizTalk Server 2002 開発者ソリューション」を参照してください。

関連項目

ヘルプ トピックを検索する

ヘルプ ビューアのショートカット キー


ヘルプに関する作業を行う方法

ここで説明している方法によって、Microsoft BizTalk Server 2002 ヘルプで情報を見つけることができます。たとえば、ヘルプで検索を実行して情報を見つけ、その情報を [お気に入り] タブのトピックの一覧に追加することによって、その情報にブックマークを設定することができます。ヘルプの情報を別のドキュメントにコピーしたり、印刷したりすることができます。またフォント サイズを変更して、内容を読みやすくすることができます。

ここには次のトピックが含まれます。

  • ヘルプ トピックを検索する

  • ヘルプ トピックをコピーする

  • ヘルプ トピックを印刷する

  • フォント サイズを変更する

  • ヘルプ ビューアのショートカット キー


ヘルプ トピックを検索する

ヘルプ ビューアには、次の表示オプションと検索オプションのタブがあります。

  • [目次] タブ

  • [キーワード] タブ

  • [検索] タブ

  • [お気に入り] タブ

[目次] タブ

[目次] タブを使ってヘルプ内を移動し、BizTalk Server 2002 の詳細を確認することができます。

  1. 目次を参照するには、[目次] タブをクリックします。

  2. ブック アイコンをダブルクリックして、トピック エントリおよびサブブックを表示します。

  3. 目次エントリをクリックして、対応するトピックを表示します。

[キーワード] タブ

[キーワード] タブを使って、あるテーマに基づいてヘルプを検索し、対応するトピックを表示することができます。

  1. [キーワード] タブをクリックしてから、単語を入力するか、一覧をスクロールして、キーワード エントリの一覧を参照します。

    1 つのトピックが複数のエントリとして表されていることもあります。

  2. キーワード エントリをダブルクリックして、対応するトピックを表示します。

    または

    ネストしているエントリがある場合は、トップレベルのキーワード エントリをダブルクリックして、その単語を含んでいるすべてのトピックを表示します。

    [該当するトピック] ダイアログ ボックスが表示されます。

    表示するトピックをクリックし、[表示] をクリックします。

[検索] タブ

[検索] タブを使って、ある単語または句が含まれるすべてのトピックを見つけることができます。

  1. [検索] タブをクリックしてから、検索する単語または句を入力し、[検索開始] をクリックして、単語または句が含まれるすべての場所を検索します。

    次の表の検索パラメータを使って、検索結果を絞り込むことができます。

    パラメータ 検索対象 例
    AND、OR、NEAR、または NOT 複数の単語または句。これは単語の組み合わせを見つけます。また単語を除外することもできます。 メッセージ AND オーケストレーション

    注

    • [検索する単語の入力] ボックスの隣にある右矢印アイコンをクリックし、ドロップダウン リストからオプションを選択します。
    アスタリスク (*) アスタリスクの前にある文字で始まるすべての単語。後ろがことなる単語でも見るけることができます。 Admin*

    Specif*
    引用符 ("") 複数の単語を含む句または用語。これは、個々の単語と一致するものを除外します。たとえば、"BizTalk マッパー" と入力すると、"BizTalk" と "マッパー" を含むすべてのトピックを検索するのではなく、2 つの単語が続いて出てくるトピックのみを検索します。 "BizTalk マッパー"

    "delimited flat file"

    [検索] タブの下部にあるオプションを選択して、検索を絞り込むことができます。

    • [以前の結果から検索] : 検索結果ペインの現在の一覧を新しい検索パラメータで検索します。

    • [類似する文字に合致] : 検索される単語のすべての変化形を検索します。たとえば、"messaging" の検索は "messages" との一致も返します。このオプションは既定でオンになっています。

    • [タイトルのみ検索] : ブック、サブブック、およびトピックのタイトルだけを検索し、テキスト全体の検索を行いません。
  2. 検索結果のエントリをダブルクリックして、対応するトピックを表示します。

注

  • 検索対象の単語または句は、表示されるトピックのテキストでハイライト表示になります。[オプション] メニューで [検索ハイライト オフ] を選択して、この機能をオフにすることができます。

[お気に入り] タブ

[お気に入り] タブでは、ヘルプ トピックにブックマークを設定することによって、好みの、または頻繁に使うヘルプ トピックの一覧を作成することができます。

  1. トピックにブックマークを設定するには、[目次]、[キーワード]、[検索] のいずれかのタブを使用して、トピックを表示します。

  2. [お気に入り] タブをクリックし、[追加] をクリックして、トピック タイトルを [トピック] ボックスの一覧に追加します。

トピック タイトルが [トピック] ボックスの一覧に追加されます。後でこの一覧からブックマークをダブルクリックすると、トピックをすばやく表示できます。

注

  • [トピック] ボックスの一覧からブックマークを削除するには、ブックマークをクリックし、[削除] をクリックします。

関連項目

ヘルプ ビューアのショートカット キー


ヘルプ トピックをコピーする

  1. ヘルプ ビューアのトピック ペインで、コピーするトピック内を右クリックし、[すべて選択] をクリックします。

  2. トピック内でもう一度右クリックし、[コピー] をクリックします。

    トピックがクリップボードにコピーされます。

  3. トピックのコピー先のドキュメントを開きます。

  4. 情報を挿入するドキュメント内の場所をクリックします。

  5. [編集] メニューの [貼り付け] をクリックします。

注

  • トピックの一部だけをコピーする場合は、コピーする部分を選択してから、選択部分を右クリックし、[コピー] をクリックします。

  • 手順番号はクリップボードへはコピーされません。

関連項目

ヘルプ トピックを検索する

ヘルプ トピックを印刷する


ヘルプ トピックを印刷する

  1. [目次] タブでトピックを選択します。

  2. ツールバーの [印刷] をクリックします。

    [トピックの印刷] ダイアログ ボックスが表示されます。

  3. 単一のトピックを印刷する ［選択されたトピックの印刷］ をクリックし、[OK] をクリックします。

    または

    ブックのすべてのトピックを印刷する [選択された見出しおよびすべてのサブトピックを印刷] をクリックし、[OK] をクリックします。

    [印刷] ダイアログ ボックスが表示されます。

  4. [印刷] をクリックします。

重要

  • 印刷の向きを [縦] にすると、コードのサンプル、大きな図、および改行できないテキストを含むページが完全に印刷されない場合があるので、印刷の向きとして [横] を選択するようにしてください。[横] を選択するには、[印刷] ダイアログボックスで [レイアウト] タブをクリックし、[印刷の向き] で [横] をクリックします(タブの名称などは使用しているプリンタの種類によって異なります)。

関連項目

ヘルプ トピックを検索する

ヘルプ ビューアのショートカット キー


フォント サイズを変更する

テキストのフォント サイズを拡大して表示を見やすくしたり、縮小してページ全体のレイアウトを確認したりできます。

  • テキストのサイズを拡大または縮小するには、ツール バーの [フォント] ( フォント ボタン) をクリックします。

ヘルプ ファイルを閉じるときフォント サイズの変更が保持されるので、次にヘルプ ファイルを開くとき前回選択されたフォント サイズで表示されます。


ヘルプ ビューアのショートカット キー

BizTalk Server 2002 ヘルプ ビューアの操作は、ショートカット キーを使用しても実行できます。次の表は、ヘルプ ビューアで利用できるショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Microsoft® Windows® 2000 Server ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。または、Windows 2000 Professional ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。

ヘルプ ビューアのショートカット キー

ショートカット キー | 機能
Alt + Space | システム メニューを表示します。
Shift + F10 ヘルプ ビューアのショートカット メニューを表示します。

注

  • このショートカットは、トピック ペインにフォーカスがある場合に使用します。
Alt + Tab | ヘルプ ビューアと開いているほかのウィンドウとを切り替えます。
Alt + O | [オプション] メニューを表示します。
Alt + O、次に T | ナビゲーション ペインの表示と非表示を切り替えます。
↑ 目次、キーワード、または検索結果の一覧で、1 つ上のトピックに移動します。
↓ 目次、キーワード、または検索結果の一覧で、1 つ下のトピックに移動します。
PageUp | 目次、キーワード、または検索結果の一覧で、1 ページ上に移動します。
PageDown | 目次、キーワード、または検索結果の一覧で、1 ページ下に移動します。
F6 | ナビゲーション ペインとトピック ペインとの間でフォーカスを切り替えます。
Alt + O、次に R | トピック ペインに表示されるトピックを更新します。
↑または↓ トピックをスクロールします。
Ctrl + Home | トピックの先頭に移動します。
Ctrl + End | トピックの最後に移動します。
Ctrl + A | トピック ペインのすべてのテキストを強調表示します。
Alt + O、次に P | トピックを印刷します。
Alt + O、次に B | 前に表示したトピックに戻ります。
Alt + O、次に F | (前に表示した) 次のトピックに移動します。
Tab 関連するトピック間を移動します。

注

  • このショートカットは、トピック ペインにフォーカスがある場合に使用します。
Alt + F4 | ヘルプ ビューアを閉じます。

[目次] タブのショートカット キー

ショートカット キー | 機能
Alt + C | [目次] タブを表示します。
→ | ブックを開きます。
← | ブックを閉じます。
BackSpace | 前に開いたブックに戻ります。
↑または↓ | トピックを選択します。
Alt + ← | 前に表示したトピックに戻ります。
Alt + → | (前に表示した) 次のトピックに移動します。
Enter | 選択したトピックを表示します。

[キーワード] タブのショートカット キー

ショートカット キー | 機能
Alt + N | [キーワード] タブを表示します。
↑または↓ | 一覧内のキーワードを選択します。
Alt + D または Enter | 関連付けられたトピックを表示します。

[検索] タブのショートカット キー

ショートカット キー | 機能
Alt + S | [検索] タブを表示します。
Alt + L | 検索を開始します。
Alt + D または Enter | 選択したトピックを表示します。

[お気に入り] タブのショートカット キー

ショートカット キー | 機能
Alt + I | [お気に入り] タブを表示します。
Alt + A | [トピック] ボックスの一覧にトピックを追加します。
Alt + P [トピック] ボックスの一覧のトピックを選択します。

注

  • このショートカットは、トピック ペインにフォーカスがある場合に、[トピック] ボックスの一覧に移動するときに使用します。
Alt + R | [トピック] ボックスの一覧からトピックを削除します。
Alt + D | [トピック] ボックスの一覧のトピックを表示します。

関連項目

ヘルプについて


障害をお持ちの方のためのユーザー補助機能

マイクロソフトでは、すべてのユーザーにとって使いやすい製品を提供するために努力しています。Microsoft® BizTalk™ Server 2002 を使いやすくする機能については、次のトピックを参照してください。

  • ヘルプ ビューアのショートカット キー

  • BizTalk Server 管理コンソールのショートカット キー

  • BizTalk ドキュメント トラッキングのショートカット キー

  • BizTalk オーケストレーション デザイナのショートカット キー

  • BizTalk メッセージ マネージャのショートカット キー

  • BizTalk エディタのショートカット キー

  • BizTalk マッパーのショートカット キー

注

  • ユーザー補助機能のオプションの詳細については、Microsoft Windows® 2000 Server ヘルプの「Windows 2000 Server の紹介」ブックに含まれる「ユーザー補助機能」を参照してください。Windows 2000 Professional ヘルプの場合は、「特殊なニーズに合わせたユーザー補助の概要」を参照してください。

  • さまざまな Microsoft 製品のユーザー補助機能の詳細については、Microsoft ユーザー補助機能 Web サイト (www.microsoft.com/japan/enable/) を参照してください。


Microsoft 製品サポート サービスへのお問い合わせ

製品名 : Microsoft® BizTalk™ Server 2002

サポート オプション : サポート オプションに関する最新の情報については、Microsoft 製品サポート サービスの Web サイト (www.microsoft.com/japan/support/default.asp) を参照してください。

  • 条件 : Microsoft 製品サポート サービスは Microsoftの現行の価格および条件に基づいて提供されますが、価格および条件は予告なしに変更されることがあります。


BizTalk Server 2002 の使用方法の理解

このセクションでは 3 つの完結したシナリオを用意しています。これらのシナリオを進めていくことで、Microsoft® BizTalk™ Server 2002 のツールおよびサービスの使用方法を学習し、より深く理解することができます。

  • 「BizTalk Server 2002 チュートリアル」は従来からのチュートリアルで、企業間自動調達プロセスをひととおり構成するのに必要な手順を説明します。このチュートリアルは、BizTalk マッパー、BizTalk エディタ、BizTalk オーケストレーション デザイナ、BizTalk メッセージ マネージャ、および BizTalk Server 管理コンソールの使用方法の学習に重点を置いています。

  • 「BizTalk Server 2002 の理解」は、BizTalk Server を使用して企業間自動調達プロセスを構築するために必要なプロセスおよびタスクの基本的な概念を説明します。このチュートリアルを学習することによって、必要な設定を行うスクリプトを実行できるようになります。実際の経験を通じて、サービスとプロセスの仕組みを理解していくことができます。

  • 「電子調達サンプル」は、BizTalk Server の最新機能について説明する、完結したサンプルです。このサンプルでは、BizTalk SEED ウィザード、Application Center を利用した展開、および Microsoft Operations Manager (MOM) を使用した高度な監視機能の概要を示します。また、インスタンス キューではなく一般のキューを使用する新しい XLANG 関連付けについても説明します。


BizTalk Server 2002 チュートリアル

企業間自動調達

このチュートリアルでは、Microsoft® BizTalk™ Server 2002 を構成し、企業間自動調達プロセスを設定し、実行する方法について学習します。

さらに、BizTalk Server のコンポーネントとサービスの連携機能を活用し、企業内および企業間における、疎結合、長時間ビジネス プロセスを統合する方法についても学習します。

注

  • BizTalk Server 2002 チュートリアルは、Microsoft Word 形式でも提供しています。チュートリアルを印刷する場合は、Word バージョンをご利用ください。Word をインストールしていない場合は、ワードパッドや Microsoft Word 97/2000 ビューアで閲覧することができます。Tutorial.doc ファイルは、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Documentation フォルダにあります。

要件

このチュートリアルを完了するには、BizTalk Server 2002 と、そのすべての付属コンポーネントをインストールする必要があります。さらに、付録の一部のために Microsoft Visual Basic® 6.0 が必要になります。BizTalk Server 2002 のハードウェア要件およびソフトウェア要件の一覧については、「BizTalk Server 2002 のインストール」を参照してください。

シナリオ

このチュートリアルのシナリオでは、BizTalk Server 2002 の重要な要素について全般的に説明し、併せてBizTalk Server のツールやサービスの使い方について具体的に説明します。

このシナリオでは、Northwind Traders 社 (このチュートリアルでは購入者と言います) が BizTalk Server 2002 を使用して、Contoso 社 (このチュートリアルでは販売者と言います) との企業間自動調達プロセスを設計し、実装します。Northwind Traders 社によって注文要求が生成されるとき、それは一定の基準を満たさないと承認されません。注文要求が 1,000 ドル以下の場合は、注文が生成されて Contoso 社に送信されます。そうでない場合は、注文要求は拒否され、処理は終了します。Northwind Traders 社は、XLANG スケジュール を使用して自社システムでのメッセージのフローを制御することによって、この処理を自動化します。

注文要求が承認されると、購入者のシステムは BizTalk メッセージ サービスを使用して、注文を受信し、ルーティングし、Contoso 社の書式と一致するように変換し、そのうえでデータを抽出します。販売者 (Contoso 社) は注文に応え、請求書を購入者 (Northwind Traders 社) に送信します。購入者が請求書を受信すると、支払通知が発行され、販売者に送信されます。

この調達プロセスが、BizTalk Server 2002 のツールとサービスを使用して自動化されます。両者のシステムでは、BizTalk Server 2002 と連動する付属コンポーネントがこれ以外にも多数使用され、主要なデータ処理作業が実行されています。

次の図は、Northwind Traders 社と Contoso 社によって実装された企業間自動調達システムの相互関係を示しています。矢印は、各ロールおよびエンティティ間のデータ フローを示します。

重要

  • このシナリオの性質上、購入者と販売者の両方のシステムを単独の BizTalk Server 2002 に構成しています。

次の図は、購入者のシステムと販売者のシステムとの間におけるドキュメントの移動を示しています。またここには、XLANG スケジュール、BizTalk メッセージ サービス、および付属コンポーネント間のやりとりも示されています。このチュートリアルのモジュールでこの図をしばしば参照しているので、これを印刷して手元に用意しておくと便利です。

内容

モジュール 1 : ビジネス プロセスのモデル化

このモジュールでは、次のことについて学習します。

  • BizTalk オーケストレーション デザイナを使用して、Northwind Traders 社の調達プロセスを定義および実装した XLANG スケジュール フローチャートを作成する。詳細については、「BizTalk オーケストレーションの設計」を参照してください。

  • XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルする。詳細については、「XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル」を参照してください。

  • XLANG スケジュールを実行し、購入者のシステムにおけるメッセージの移動状況を確認する。

モジュール 2 : 仕様とマップの作成

このモジュールでは、次のことについて学習します。

  • BizTalk エディタを使用して、ドキュメント仕様を作成する。詳細については、「仕様の作成と検証」を参照してください。

  • BizTalk マッパーを使用して、マップを作成する。詳細については、「新しいマップの作成」を参照してください。

モジュール 3 : BizTalk メッセージ サービスの構成

このモジュールでは、次のことについて学習します。

  • BizTalk メッセージ マネージャを使用して、Contoso 社の BizTalk Server メッセージ サービスを構成する。詳細については、「BizTalk メッセージ マネージャの使用」を参照してください。

  • BizTalk Server 管理コンソールを使用して、Contoso 社向けのファイル受信機能を作成する。詳細については、「ファイル受信機能の追加」を参照してください。

モジュール 4 : XLANG スケジュールの完成

このモジュールでは、次のことについて学習します。

  • モジュール 3 において着手した BizTalk メッセージの実装によって、XLANG スケジュール フローチャートにポートを実装する。ポートとメッセージ ポートの違いについては、「ポート実装について」および「メッセージ ポートについて」を参照してください。

  • XLANG スケジュール フローチャートを完成させ、これを XLANG スケジュールにコンパイルする。

  • コンパイルした XLANG スケジュールを実行して、購入者と販売者の両システム間のメッセージのすべての動きを理解する。

ショートカット

  • このチュートリアルでは、いくつかのショートカットにより、既存の XLANG スケジュール、ドキュメント仕様、マップ、または構成スクリプトを利用して、時間と手間を省くことができます。ショートカットを使用すると、先の項目に進むことができます。

  • ショートカットを使用するには、すべてのコンポーネントをドライブ C にインストールする必要があります。別のドライブを使用すると、チュートリアルは実行できません。

「事前セットアップ」に進みます。


事前セットアップ

チュートリアルを開始する前に、次のものを作成する必要があります。

  • 4 つのサブフォルダを含むフォルダを 1 つ。

  • Active Server Pages (ASP) ファイルを含むローカル Web サイト フォルダを 2 つ。

  • 購入者のシステム用のメッセージ キューを 2 つ。

「フォルダの作成」に進みます。


フォルダの作成

ここでは、4 つのサブフォルダを含むフォルダを 1 つ作成します。購入者のシステムと販売者のシステムで送受信するメッセージの格納場所として、それぞれBuyer および Seller という名前の 2 つのサブフォルダを使用します。ほかの 2 つのサブフォルダは、購入者の Web サイトと販売者の Web サイトのコンテンツ フォルダになります。

フォルダを作成するには次の操作を行います。

  1. Windows® エクスプローラで C ドライブのルート ディレクトリを参照します。

    重要

    • 以下に説明するフォルダは、BizTalk Server 2002 をセットアップしたドライブに関わらず、必ず C ドライブに作成してください。別のドライブを使用すると、チュートリアルは実行できなくなります。
  2. C ドライブのルートに TutorialFiles というフォルダを新しく作成します。

  3. 新しく作成したフォルダ TutorialFiles をクリックします。サブフォルダを 4 つ作成し、それぞれに次の名前を付けます。
    • Buyer

    • Seller

    • SubmitPO

    • InvoiceToQueue

「ファイルのコピー」に進みます。


ファイルのコピー

ここでは、後の使用のためにマップを BizTalk Server のレポジトリにコピーし、購入者と販売者のそれぞれの Web コンテンツ フォルダに ASP ファイルをコピーします。

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps に移動し、POReqtoPO.xml をコピーします。

  2. このファイルを \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft に貼り付けます。

  3. 次の表に従って、ほかのファイルをコピーし、TutorialFiles サブフォルダに貼り付けます。
    コピー元 | コピー先
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\SubmitPO\Solution\SubmitNorthwindPO.asp | C:\TutorialFiles\SubmitPO
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\DropInvoicetoMSMQ.asp | C:\TutorialFiles\InvoiceToQueue
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\Global.asa | C:\TutorialFiles\InvoiceToQueue

「仮想 Web サイト ディレクトリの作成」に進みます。


仮想 Web サイト ディレクトリの作成

ここでは、インターネット インフォメーション サービス (IIS) で 2 つの仮想ディレクトリを作成し、それらが ASP ファイルをポイントするようにします。1 つは請求書受信用の購入者の Web サイトをシミュレートするディレクトリ、もう一つは販売者のシステム上の注文受信用の Web サイトをシミュレートするディレクトリです。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [管理ツール] をダブルクリックします。

  3. [インターネット サービス マネージャ] をダブルクリックします。

    インターネット インフォメーション サービス管理コンソールが表示されます。

  4. [インターネット インフォメーション サービス] コンソール ツリーで使用するコンピュータを展開します。次に、[既定の Web サイト] をクリックします。

  5. [操作] メニューの [新規作成] をポイントし、[仮想ディレクトリ] をクリックします。

    [仮想ディレクトリの作成ウィザード] が表示されます。

  6. [仮想ディレクトリの作成ウィザードへようこそ] ページで [次へ] をクリックします。

  7. [仮想ディレクトリ エイリアス] ページで、[エイリアス] ボックスに「SubmitPO」と入力し、[次へ] をクリックします。

  8. [Web サイトのコンテンツのディレクトリ パス] ページで [参照] をクリックします。

  9. C:\TutorialFiles\SubmitPO に移動し、[OK] をクリックします。それから [次へ] をクリックします。

  10. [アクセス許可] ページで [次へ] をクリックします。

  11. [完了] をクリックして [仮想ディレクトリの作成ウィザード] を終了します。

  12. [コンピュータの管理] コンソール ツリーで [既定の Web サイト] をクリックします。

  13. 購入者の Web サイトをシミュレートしたフォルダを作成するには、次の変更点に注意して手順 5. ～ 11. の操作を繰り返します。
    • 手順 7. では、[エイリアス] ボックスに「InvoiceToQueue」と入力します。

    • 手順 9. では、C:\TutorialFiles\InvoiceToQueue に移動します。

    [コンピュータの管理] コンソールは、次のようになります。

  14. [コンピュータの管理] コンソールを閉じます。

「メッセージ キューの作成」に進みます。


メッセージ キューの作成

ここでは、2 つのメッセージ キューを作成して購入者のシステムでメッセージの送受信ができるようにします。Northwind Traders 社は、アプリケーションを使って、注文要求を送信します。注文要求は ReceivePOReq に送信されて処理されます。Contoso 社が購入者のWeb サイトのASP ページを通じて請求書を送信すると、ASP ページは請求書を処理のために ReceiveInvoice キューに入れます。

注

  • この操作を実行するには、メッセージ キューをインストールしておく必要があります。メッセージ キューのインストールについては、「メッセージ キューのインストール」を参照してください。

メッセージ キューを作成するには次の操作を行います。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [管理ツール] をダブルクリックします。

  3. [コンピュータの管理] をダブルクリックします。

    [コンピュータの管理] コンソールが表示されます。

  4. [コンピュータの管理] コンソールで、[サービスとアプリケーション] を展開します。次に [メッセージ キュー] を展開し、[専用キュー] をクリックします。

  5. [操作] メニューの [新規作成] をポイントし、[専用キュー] をクリックします。

    [キューの名前] ダイアログ ボックスが表示されます。

  6. [名前] ボックスに「ReceivePOReq」と入力します。

  7. [トランザクション] チェック ボックスをオンにし、[OK] をクリックします。

  8. メッセージ キューをもう 1 つ作成するには、次の変更点に注意して手順 5. ～ 7. の操作を繰り返します。
    • 手順 6. では、[名前] ボックスに「ReceiveInvoice」と入力します。

    [コンピュータの管理] コンソールは、次のようになります。

  9. [コンピュータの管理] コンソールを閉じます。

「付属コンポーネントのインストール」に進みます。


付属コンポーネントのインストール

ここでは、次の付属コンポーネントをインストールします。

  • アプリケーション統合コンポーネント (AIC)。販売者のシステムにインストールし、購入者の注文データに基づいて請求書を生成するために使用します。

  • Windows スクリプト コンポーネント (WSC)。購入者のシステムにインストールし、ポートを XLANG スケジュールに実装するために使用します。注文要求に対する承認ステータスまたは拒否ステータスを XLANG スケジュールから受信します。

    重要

    • 上記のコンポーネントが既にコンピュータにインストールされている場合は、あらかじめアンインストールしておいてください。アンインストールの方法については、「付属コンポーネントのアンインストール」を参照してください。

    各国語対応に関する問題

    • BizTalk Server 2002 チュートリアルで、非 ASCII データは使用できません。非 ASCII データを使用する場合は、スクリプト コンポーネント (PORequestApproval.wsc) のコードを変更して、データを書くのに XML Document Object Model (DOM) を使用するようにします。

付属コンポーネントをインストールするには次の操作を行います。

  1. BizTalk Server をインストールしたドライブで \Program Files\Microsoft BizTalk Server\Tutorial\Setup に移動します。

  2. Install_POtoInvoice.vbs をダブルクリックします。

    コンポーネントが正しくインストールされたことを示すメッセージ ボックスが表示されます。

  3. \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution に移動し、PORequestApproval.wsc をクリックします。

  4. [ファイル] メニューの [登録] をクリックします。

    コンポーネントが正しく登録されたことを示すメッセージ ボックスが表示されます。

「モジュール 1 : ビジネス プロセスのモデル化」に進みます。


付属コンポーネントのアンインストール

注意

  • 前にインストールしたコンポーネントを削除する場合以外は、この操作を行わないでください。
  1. POtoInvoice コンポーネントを削除するには、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Setup に移動します。

  2. Remove_POtoInvoice.vbs をダブルクリックします。

    コンポーネントが正しくアンインストールされたことを示すメッセージ ボックスが表示されます。

  3. Windows スクリプト コンポーネントを削除するには、\Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution に移動し、PORequestApproval.wsc をクリックします。

  4. [ファイル] メニューの [登録解除] をクリックします。

    コンポーネントが正しく登録解除されたことを示すメッセージ ボックスが表示されます。

付属コンポーネントの再インストールの方法については、「付属コンポーネントのインストール」を参照してください。


モジュール 1 : ビジネス プロセスのモデル化

このモジュールでは、BizTalk オーケストレーション デザイナを使用して、Northwind Traders 社の自動調達プロセスを定義および実装した XLANG スケジュール フローチャートを作成します。さらにその XLANG スケジュール フローチャートを、購入者のシステムのメッセージ フローを制御する実行可能な XLANG スケジュールとしてコンパイルします。

目的

  • 自動調達プロセスを定義する XLANG スケジュール フローチャートを作成する。詳細については、「XLANG スケジュール フローチャートの作成」を参照してください。

  • ビジネス プロセスを定義する論理シーケンスのそれぞれのアクションを接続する。詳細については、「シェイプの接続」を参照してください。

  • アクションをポートに接続してビジネス プロセスを実装する。詳細については、「アクションとポート間の通信フローの確立」を参照してください。

  • 条件式を書き込んで、ビジネス プロセスに条件を追加する。詳細については、「条件の設計」を参照してください。

  • メッセージのデータ フローを定義する。詳細については、「通信シェイプ」を参照してください。

  • XLANG スケジュール フローチャートを保存し、XLANG スケジュールにコンパイルする。詳細については、「XLANG スケジュールのコンパイル」を参照してください。

  • XLANG スケジュールを実行し、BizTalk Server でメッセージを処理する。詳細については、「XLANG スケジュールの実行」を参照してください。

「購入者の XLANG スケジュールの作成」に進みます。

関連項目

BizTalk オーケストレーションの設計


購入者の XLANG スケジュールの作成

ここでは、Northwind Traders 社 (購入者) のビジネス プロセスを定義して実装し、XLANG スケジュールを作成して実行します。

XLANG スケジュールを作成するには、「購入者のアクションの作成」に進みます。

ショートカット

  • 既存の XLANG スケジュールを使用する場合は、「XLANG スケジュールの実行」に進みます。


購入者のアクションの作成

この自動調達プロセスを作成する最初のステップは、Northwind Traders が使用するビジネス プロセスを分析し、そのプロセスを記述する相互関係ダイアグラムを作成することです。ここでは、BizTalk オーケストレーション デザイナ を使用して、Northwind Traders 社のビジネス プロセスの表現を描きます。[フロ－チャート] シェイプを使用して、注文要求を受信したとき、注文要求が受け入れられた場合または拒否された場合に発生するアクションを定義します。

[フローチャート] シェイプの詳細については、「フローチャート シェイプ」を参照してください。ビジネス プロセスの詳細については、「ビジネス プロセスについて」を参照してください。

購入者のアクションを作成するには次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk オーケストレーション デザイナ] をクリックします。

  2. 左側の [フローチャート] ステンシルから [アクション] シェイプを [ビジネス プロセス] ページにドラッグします。

    そのシェイプを [開始] シェイプの下に配置します。

  3. [アクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [アクションのプロパティ] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに「Receive PO Request」と入力し、[OK] をクリックします。

    注意

    • このチュートリアルを正しく実行するために、名前はすべて示されているとおり正確に入力してください。チュートリアルのコンポーネントには、これらの名前が組み込まれています。
  5. [フローチャート] ステンシルの [判断] シェイプを [ビジネス プロセス] ページにドラッグします。

    このシェイプを [Peceive PO Request] アクションの下に配置します。

  6. [判断] シェイプを右クリックし、[条件の作成] をクリックします。

    [条件のプロパティ] ダイアログ ボックスが表示されます。

  7. [条件名] ボックスに「Denied」と入力し、[OK] をクリックします。

    [条件の説明] ボックスでの情報の入力は省略できます。

    [条件式] ボックスを空白のままにします。このモジュールでは、後に、メッセージおよびフィールド名を提供するスクリプト コンポーネントに [判断] シェイプをバインドし、判断規則を実装する条件式を追加します。

  8. 手順 2. ～ 4. の操作を繰り返して、次の 3 つのアクションを作成します。
    • 2 つ目の [アクション] シェイプを [判断] シェイプの右に配置します。このアクションには「Send Denial」という名前を付けます。

    • 3 つ目の [アクション] シェイプを [判断] シェイプの下に配置します。このアクションには「Send Approval」という名前を付けます。

    • 4 つ目の [アクション] シェイプを [Send Approval] アクションの下に配置します。このアクションには「Write PO Request to File」という名前を付けます。
  9. 左側の [フローチャート] ステンシルから [終了] シェイプを [ビジネス プロセス] ページにドラッグします。

    このシェイプは、[Send Denial] アクションの下に配置します。

    注文要求が承認されない場合、XLANG スケジュールは拒否メッセージを表示して終了します。

  10. 左側の [フローチャート] ステンシルから [終了] シェイプを [ビジネス プロセス] ページにドラッグします。

    このシェイプを、[Write PO Request to File] アクションの下に配置します。

    注文要求が承認された場合、XLANG スケジュールはその注文要求をファイル ディレクトリに書き込み、承認メッセージを表示して終了します。

「シーケンス内の購入者のアクションの接続」に進みます。


シーケンス内の購入者のアクションの接続

Northwind Traders 社のアクションを作成したら、[フローチャート] シェイプを接続してイベントのシーケンスを定義し、注文要求を受信したときビジネス プロセスが開始し、注文要求が受け入れらたかまたは拒否されたときにビジネス プロセスが終了するようにします。この表現をファイル拡張子 .skv の XLANG スケジュール フローチャートとして保存します。詳細については、「シェイプの接続」を参照してください。

購入者のアクションを接続するには次の操作を行います。

  1. [開始] シェイプをクリックして制御ハンドルを強調表示します。

    強調表示された [開始] シェイプ

    底部の制御ハンドルを [Receive PO Request] アクションの接続ポイントの上端までドラッグします。

    [Receive PO Request] アクションは、ビジネス プロセスの開始を表します。注文要求が受信されると、XLANG スケジュールは実行を開始します。

    注

    • 強調表示したシェイプ上の黄色のひし形は制御ハンドルを表します。アクションに接続するには制御ハンドルをドラッグします。

    • シェイプ上の青い X は接続ポイントを表します。

    • [アクション] シェイプの側面にある接続ポイントは、ポートに接続する場合に限って使用します。ほかの [アクション] シェイプに接続する場合は使用しません。
  2. 手順 1. の操作を繰り返して次のアクションの接続を作成します。
    • [Receive PO Request] アクションを [判断] シェイプに接続します。
  3. [判断] シェイプの [Denied] 条件をクリックし、その右側の制御ハンドルを [Send Denial] アクションの接続ポイントの上端までドラッグします。

  4. [判断] シェイプの [Else] 条件をクリックし、その左側の制御ハンドルを [Send Approval] アクションの接続ポイントの上端までドラッグします。

    注

    • [判断] シェイプの条件は、左右どちら側の制御ハンドルを使用しても [Send Approval] アクションと [Send Denial] アクションに接続できます。
  5. [Send Approval] アクションを [Write PO Request to File] アクションに接続します。

  6. [Write PO Request to File] アクションを、その下に配置した [終了] シェイプに接続します。

  7. [Send Denial] アクションを、その下に配置した [終了] シェイプに接続します。

  8. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [XLANG スケジュール フローチャートに名前を付けて保存] ダイアログ ボックスが表示されます。

    BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  9. [ファイル名] ボックスに「Buyer1」と入力し、[保存] をクリックします。

作成し、保存した XLANG スケジュール フローチャートは、次のようになります。

XLANG スケジュール フローチャート

「メッセージ キューでの注文要求の受信によるポートの実装」に進みます。


メッセージ キューでの注文要求の受信によるポートの実装

このチュートリアルの事前セットアップでは、ReceivePOReq メッセージ キューを作成しました。ここでは、[メッセージ キュー] シェイプを XLANG フローチャートに追加し、ReceivePOReq メッセージ キューにポートを実装します。

[メッセージ キュー] シェイプは、メッセージを送受信するために使用するメッセージ キュー サービスを表します。このサービスは、注文要求の ReceivePOReq メッセージ キューを監視するために構成します。注文要求がキューに入ったら、XLANG スケジュール が処理を開始します。詳細については、「メッセージ キュー シェイプの使用」を参照してください。

ポートおよびメッセージ ポートの使用方法の詳細については、「BizTalk サービスの統合」を参照してください。

ポートを実装するには次の操作を行います。

  1. 右側の [実装] ステンシルから [メッセージ キュー] シェイプを [ビジネス プロセス] ページにドラッグします。

    [メッセージ キュー] シェイプを [Receive PO Request] アクションと水平になるようにそろえて配置します。

    [メッセージ キュー バインド ウィザード] が表示されます。

  2. [メッセージ キュー バインド ウィザードへようこそ] ページで、[新しいポートの作成] がオンになっていることを確認します。

  3. [新しいポートの作成] ボックスに「ReceivePORequest」と入力し、[次へ] をクリックします。

  4. [静的または動的キューの情報] ページで [静的キュー] が選択されていることを確認し、[次へ] をクリックします。

  5. [キュー情報] ページで [すべてのインスタンスに対して既存のキューを使用する] をオンにします。

  6. [キュー名を入力してください] と表示されたボックスに「.\private$\ReceivePOReq」と入力し、[次へ] をクリックします。

  7. [ポート プロパティの詳細設定] ページで [完了] をクリックします。

    [ビジネス プロセス] ページに [ReceivePORequest] ポートとそれに関連付けられた実装メッセージ キューが表示されます。

注

  • 注文要求を配信する場所が明確で、それを受信するキューを既に作成しているので、動的キューでなく、静的キューを使用します。

「Receive PO Request アクションの通信フローの作成」に進みます。


Receive PO Request アクションの通信フローの作成

ここでは、XML 通信ウィザードを使用して、[アクション] シェイプのReceive PO Request とReceivePORequest ポートとの間で通信ができるようにします。XML 通信ウィザードによって、XLANG スケジューラ エンジンがキューから適切なメッセージを識別して取得するために使用する情報と仕様を与えます。さらに、データ依存のルーティングで使用されるメッセージ フィールドの POTtl を追加します。

  1. [Receive PO Request] アクションをクリックし、その右側の制御ハンドルを [ReceivePORequest] ポートの左側の接続ポイントまでドラッグします。

    [XML 通信ウィザード] が表示されます。

  2. [XML 通信ウィザードへようこそ] ページで [受信] をクリックし、[次へ] をクリックします。

  3. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認します。

  4. [メッセージ名] ボックスに「POReq」と入力し、[次へ] をクリックします。

  5. [XML 変換情報] ページで、[キューから XML メッセージを受信する] が選択されていることを確認し、[次へ] をクリックします。

  6. [メッセージの種類の情報] ページで、[メッセージの種類] ボックスに「POReq」と入力し、[次へ] をクリックします。

  7. [メッセージ仕様情報] ページで [参照] をクリックします。

    [仕様の参照] ダイアログ ボックスが表示されます。

  8. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps に移動します。

  9. POReq.xml をクリックし、[開く] をクリックします。

  10. [追加] をクリックします。

    [フィールドの選択] ダイアログ ボックスが表示されます。

  11. [ノードを選択してください] で、[Total] を展開します。次に [POTtl] をクリックし、[OK] をクリックします。

    [メッセージ フィールド] のメッセージ フィールド一覧に、POTtl が表示されます。

  12. [完了] をクリックします。

ポートを実装し、通信フローを作成すると、XLANG スケジュール フローチャートは次のようになります。

XLANG スケジュール フローチャート

「スクリプト コンポーネントを使用したポートの実装」に進みます。


スクリプト コンポーネントを使用したポートの実装

ここでは、このチュートリアルの事前セットアップでインストールし、登録している Windows スクリプト コンポーネント (WSC) の PORequestApproval.wsc を使用します。このスクリプト コンポーネントは、特定のアクションを XLANG スケジュール内部で実行できるようにします。ここでは、ApprovalComponent ポートを実装して、承認アクションと拒否アクションがポートと接続され、スクリプト コンポーネントにバインドされるようにします。詳細については、「スクリプト コンポーネント シェイプの使用」を参照してください。

このスクリプト コンポーネントは、次のアクションを XLANG スケジュール内部で実行できるようにします。

注文要求の合計が 1,000 ドルを超える場合は次のような処理が行われます。

  • [判断] シェイプはポートに拒否メッセージを送信します。

  • 拒否されたことをユーザーに知らせるメッセージが表示されます。

  • XLANG スケジュールが終了します。

注文要求の合計が 1,000 ドル以下の場合は次のような処理が行われます。

  • [判断] シェイプはポートに承認メッセージを送信します。

  • 承認されたことをユーザーに知らせるメッセージが表示されます。

  • スクリプト コンポーネントは、注文要求メッセージをローカル ファイル ディレクトリに書き込みます。

  • XLANG スケジュールが終了します。

ポートを実装するには次の操作を行います。

  1. 右側の [実装] ステンシルから [スクリプト コンポーネント] シェイプを [ビジネス プロセス] ページにドラッグします。

    このシェイプを [判断] シェイプと水平になるようにそろえて配置します。

    [スクリプト コンポーネント バインド ウィザード] が表示されます。

  2. [スクリプト コンポーネント バインド ウィザードへようこそ] ページの [新しいポートの作成] ボックスに、「ApprovalComponent」と入力し、[次へ] をクリックします。

  3. [静的または動的な通信] ページで [静的] が選択されていることを確認し、[次へ] をクリックします。

  4. [スクリプト ファイルの指定] ページで [参照] をクリックします。

  5. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution に移動します。

  6. PORequestApproval.wsc をクリックし、[開く] をクリックします。それから [次へ] をクリックします。

  7. [コンポーネントのインスタンス作成情報] ページで、[Prog ID "BTSTutorial.PORequestApproval" を使用] が選択されていることを確認し、[次へ] をクリックします。

  8. [メソッド情報] ページで、[すべて選択] をクリックし、[次へ] をクリックします。

  9. [ポート プロパティの詳細設定] ページで [完了] をクリックします。

「スクリプト コンポーネントのメッセージのプロパティの定義」に進みます。


スクリプト コンポーネントのメッセージのプロパティの定義

ここでは、メソッド通信ウィザードを使用して、[アクション] シェイプからスクリプト コンポーネントへのメッセージのフローを定義します。このプロセスの各手順の詳細については、「同期メッセージの送信と受信」を参照してください。

  1. [Send Denial] アクションをクリックし、その右側の制御ハンドルを Windows スクリプト コンポーネントの [ApprovalComponent] ポートまでドラッグします。

    [メソッド通信ウィザード] が表示されます。

  2. [メソッド通信ウィザードへようこそ] ページで、[同期メソッド呼び出しを開始する] が選択されていることを確認し、[次へ] をクリックします。

  3. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認し、[次へ] をクリックします。

  4. [メッセージ仕様情報] ページの [メソッド] ボックスの一覧で、[SendDenial] をクリックし、[完了] をクリックします。

  5. [Send Approval] アクションをクリックし、その右側の制御ハンドルを [ApprovalComponent] ポートまでドラッグします。

    [メソッド通信ウィザード] が表示されます。

  6. [メソッド通信ウィザードへようこそ] ページで、[同期メソッド呼び出しを開始する] が選択されていることを確認し、[次へ] をクリックします。

  7. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認し、[次へ] をクリックします。

  8. [メッセージ仕様情報] ページの [メソッド] ボックスの一覧で、[SendApproval] をクリックし、[完了] をクリックします。

  9. [Write PO Request to File] アクションをクリックし、その右側の制御ハンドルを [ApprovalComponent] ポートにドラッグします。

    [メソッド通信ウィザード] が表示されます。

  10. [メソッド通信ウィザードへようこそ] ページで、[同期メソッド呼び出しを開始する] が選択されていることを確認し、[次へ] をクリックします。

  11. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認し、[次へ] をクリックします。

  12. [メッセージ仕様情報] ページの [メソッド] の一覧で、[WriteToFile] が選択されていることを確認し、[完了] をクリックします。

「判断規則の条件式の書き込み」に進みます。


判断規則の条件式の書き込み

Northwind Traders 社のビジネス ルールでは、1,000 ドルを超える注文要求は拒否されます。メッセージは、このビジネス ルールに従ってルーティングされる必要があります。XLANG スケジュールは、注文要求の合計フィールド [POTtl] の値を [判断] シェイプに渡します。判断規則の条件式は、XLANG スケジュールのパスを分岐し、適切なメッセージを Windows スクリプト コンポーネントが使用されている実装ポートに送信します。拒否判断規則には、[判断] シェイプの動作を定義する条件式が含まれています。条件式は、TRUE と FALSE のいずれであるかを評価し、[判断] シェイプで使用される論理名および変数名も定義します。

条件式を書き込むには次の操作を行います。

  1. ページの下部にある [データ] タブをクリックします。

    [データ] ページが表示されます。

  2. POReq メッセージの中からフィールド名を探します。

    条件式を書き込むには、メッセージ名とフィールド名の両方が必要です。ここでは、メッセージ名が POReq で、フィールド名が POTtl です。

  3. ページの下部にある [ビジネス プロセス] タブをクリックします。

    [ビジネス プロセス] ページが表示されます。

  4. [判断] シェイプを右クリックし、[プロパティ] をクリックします。

    [判断のプロパティ] ダイアログ ボックスが表示されます。

  5. [Denied] が選択されていることを確認し、[編集] をクリックします。

    [条件のプロパティ] ダイアログ ボックスが表示されます。

  6. [条件式] ボックスに、「POReq.POTtl > 1000」と入力します。

    これは、注文要求の合計フィールドが 1,000 ドルを超えた場合、その要求が拒否されることを表す条件式です。

  7. [OK] をクリックして [条件のプロパティ] ダイアログ ボックスを閉じます。さらに [OK] をクリックして [判断のプロパティ] ダイアログ ボックスを閉じます。

XLANG スケジュール フローチャートは、次のようになります。

XLANG スケジュール フローチャート

「データ フローの定義」に進みます。


データ フローの定義

ビジネス プロセスのデータ フローを定義するには、[データ] ページで [メッセージ] シェイプの各フィールド間に接続を作成します。これらの接続によって、POReq のドキュメント フィールドに含まれているデータが SendDenial、SendApproval、および WriteToFile メッセージのドキュメント フィールドに渡されます。メッセージ間のデータ フローは、XLANG スケジュールのコンパイルの前に定義されている必要があります。データ ページの詳細については、「データ ページ」を参照してください。

データ フローを定義するには次の操作を行います。

  1. ページの下部にある [データ] タブをクリックします。

    [データ] ページが表示されます。

  2. [POReq] メッセージの [Document] フィールドをクリックし、その右側の制御ハンドルを [SendDenial_in] メッセージの [Document] フィールドの接続ポイントまでドラッグします。

  3. 手順 2. の操作を繰り返して、[POReq] メッセージの [Document] フィールドを次のフィールドに接続します。
    • [SendApproval_in] ボックスの [Document] フィールド

    • [WriteToFile_in] ボックスの [Document] フィールド

注

  • 制御ハンドルをほかのフィールドまでドラッグする場合は、先に [POReq] メッセージの [Document] フィールドをクリックしてください。

上記の操作が完了すると、[データ] ページは次のようになります。

「XLANG スケジュール フローチャートの保存」に進みます。


XLANG スケジュール フローチャートの保存

  • [ファイル] メニューの [Buyer1.skv の保存] をクリックします。

「XLANG スケジュールのコンパイル」に進みます。


XLANG スケジュールのコンパイル

ここでは、XLANG スケジュール フローチャートをコンパイルして、注文要求を受信したらアクティブになる XLANG スケジュールにします。XLANG スケジュール フローチャートをコンパイルするとき、フローチャートに問題があれば明示されます。XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイルの詳細については、「XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル」を参照してください。

  1. [ファイル] メニューの [XLANG Buyer1.skx の作成] をクリックします。

    [XLANG スケジュールに名前を付けて保存] ダイアログ ボックスが表示されます。

  2. XLANG スケジュールが BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab フォルダに保存されることを確認し、[保存] をクリックします。

  3. [ファイル] メニューの [終了] をクリックして BizTalk オーケストレーション デザイナを閉じます。

「XLANG スケジュールの実行」に進みます。


XLANG スケジュールの実行

ここでは、注文要求を ReceivePOReｑ キューに送信し、XLANG スケジュールをアクティブにするアプリケーションを実行します。このアプリケーションを2 回実行して、モジュール 1 で作成されたビジネス プロセスを表示します。最初は、注文要求が承認され、メッセージが送信され、注文要求がファイルに書き込まれます。2回目の実行では、注文要求が拒否され、メッセージが送信され、処理は停止しします。

XLANG スケジュールを実行するには次の操作を行います。

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動します。

  2. ExecuteTutorial.exe をダブルクリックします。

    このアプリケーションは、モニカで XLANG スケジュールをアクティブにする場合に使用します。

    ExecuteTutorial アプリケーションが起動します。

  3. [Browse for Schedule] をクリックします。

    ショートカット

    • BizTalk Server とそのすべてのコンポーネントが C ドライブにインストールされていると、既存の XLANG スケジュールを使用できます。\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動し、手順 5 に進みます。
  4. XLANG スケジュール Buyer1 を作成していれば、\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  5. XLANG スケジュール ファイル Buyer1.skx をクリックし、[開く] をクリックします。

  6. [Browse for Data File] クリックし、\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData に移動します。

  7. POReqAccept.xml をクリックし、[開く] をクリックします。

  8. [Start XLANG Schedule] をクリックします。

    合計が 1,000 ドル以下であるため、注文要求が承認されます。XLANG スケジューラ エンジンにデータが渡されたことを示すメッセージが表示されます。この時点でアプリケーションは終了しています。次に、注文要求が承認されたことを示すメッセージが表示されます。[OK] をクリックして、メッセージ ボックスを閉じます。

  9. [End] をクリックし、ExecuteTutorial アプリケーションを閉じます。

    重要

    • このアプリケーションの実行時にオートメーション エラーが発生した場合は、専用キューが正しく構成されているか、専用キューの名前が正しいかどうかを確認してください。
  10. C:\TutorialFiles\Buyer に移動します。

    ファイル名は POReqXXXXX.xml で、XXXXX は一意な数値のセットを表します。このファイルをダブルクリックして Microsoft Internet Explorer で開きます。このファイルは、アプリケーションからメッセージ キューにポストされた注文要求のコピーです。確認後、削除してください。

  11. 手順 1. ～ 5. の操作を繰り返して、ExecuteTutorial アプリケーションを再実行します。

  12. [Browse for Data File] クリックし、\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData に移動します。

  13. POReqDeny.xml をクリックし、[開く] をクリックします。

  14. [Start XLANG Schedule] をクリックします。

    合計が 1,000 ドルを超えているため、注文要求が拒否されます。アプリケーションが終了したことを示すメッセージが表示されます。次に、ドキュメント拒否を受信したことを示すメッセージが表示されます。[OK] をクリックして、メッセージ ボックスを閉じます。

  15. [End] をクリックし、ExecuteTutorial アプリケーションを閉じます。

次の図は、XLANG スケジュールを実行したときのデータのフローを示しています。

「モジュール 1 の概要」に進みます。


モジュール 1 の概要

このモジュールでは、次のことについて学習しました。

  • 自動調達プロセスを説明する XLANG スケジュール フローチャートを作成する。詳細については、「XLANG スケジュール フローチャートの作成」を参照してください。

  • ビジネス プロセスを説明する論理シーケンスのそれぞれのアクションを接続する。詳細については、「シェイプの接続」を参照してください。

  • アクションをポートに接続してビジネス プロセスを実装する。詳細については、「アクションとポート間の通信フローの確立」を参照してください。

  • 条件式を書き込んで、ビジネス プロセスに条件を追加する。詳細については、「条件の設計」を参照してください。

  • メッセージのデータ フローを定義する。詳細については、「通信シェイプ」を参照してください。

  • XLANG スケジュール フローチャートを保存し、XLANG スケジュールにコンパイルする。詳細については、「XLANG スケジュールのコンパイル」を参照してください。

  • XLANG スケジュールを 2 回実行して、BizTalk Server で注文要求を処理し、承認と拒否のプロセスを確認します。詳細については、「XLANG スケジュールの実行」を参照してください。

次の図で強調表示されている領域は、このモジュールで行った操作を示しています。

「モジュール 2 : 仕様とマップの作成」に進みます。

関連項目

BizTalk オーケストレーションの設計


モジュール 2 : 仕様とマップの作成

ビジネス プロセスの設計を終え、このモデル内での通信のフローの仕組みを理解できたら、次は送受信するビジネス ドキュメントの構造を定義する必要があります。ビジネス ドキュメントの構造は XML スキーマで定義されますが、これは仕様ともいいます。このモジュールでは、BizTalk エディタを使用して、購入者である Northwind Traders 社の支払仕様と注文書仕様を作成します。

Contoso 社は、Northwind Traders 社に送信する請求書で一般的なスキーマを使用します。Northwind Traders 社が請求書を受信すると、仕様は支払仕様に変換される必要があります。BizTalk マッパーを使用して、Northwind Traders 社のために作成する支払仕様のレコードおよびフィールドと Contoso 社が使用する CommonInvoice 仕様とのマップを作成します。

目的

  • 仕様を作成する。詳細については、「BizTalk エディタの使用」を参照してください。

  • 新しいレコードとフィールドを仕様に追加する。詳細については、「レコードへの新しいフィールドの追加」を参照してください。

  • マップを作成する。詳細については、「BizTalk マッパーの使用」を参照してください。

  • マップ内の各フィールド間にリンクを作成する。詳細については、「リンクの作成」を参照してください。

  • Functoid を使用して、マップ内の値の数値処理を行う。詳細については、「Functoid について」を参照してください。

  • 仕様とマップを Web Distributed Authoring and Versioning (WebDAV) レポジトリに保存します。詳細については、「仕様の格納」および「マップの格納」を参照してください。

「BizTalk エディタの使用」に進みます。

関連項目

仕様の作成とデータのマッピング


BizTalk エディタの使用

BizTalk エディタを使用して、仕様の作成、編集、および管理ができます。

BizTalk エディタで支払仕様を作成するには、「支払仕様の作成」に進みます。

ショートカット

  • 既存の支払仕様を使用する場合は、「既存の支払仕様の使用」に進みます。


既存の支払仕様の使用

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps から PaymentSpec.xml をコピーします。

  2. このファイルを \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft に貼り付けます。

BizTalk エディタで注文要求仕様を作成するには、「注文要求仕様の作成」に進みます。

ショートカット

  • BizTalk Server とそのすべてのコンポーネントが C ドライブにインストールされていると、既存の注文要求仕様を使用できます。「既存の注文要求仕様の使用」に進みます。


支払仕様の作成

ここでは、Northwind Traders 社が支払通知を Contoso 社に送信するとき使用する構造とデータを定義するXML スキーマである支払仕様を作成します。仕様の詳細については、「仕様について」を参照してください。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk エディタ] をクリックします。

  2. [ファイル] メニューの [新規作成] をクリックします。

    [新しいドキュメント仕様] ダイアログ ボックスが表示されます。

  3. [空の仕様] をクリックし、[OK] をクリックします。

  4. ルート ノードの [空の仕様] をクリックします。

  5. [宣言] プロパティ ページの [名前] 行の "値" フィールドをダブルクリックします。「Payment」と入力して Enter キーを押します。

  6. [モデル] 行の "値" フィールドをダブルクリックし、[オープン] をクリックします。そして Enter キーを押します。

「支払仕様の Payment ルート ノードへの新しいレコードの追加」に進みます。


支払仕様の Payment ルート ノードへの新しいレコードの追加

  1. [Payment] ルート ノードを右クリックし、[新しいレコード] をクリックします。

  2. 新しいレコードに PaymentHeader という名前を付け、Enter キーを押します。

  3. 手順 1. および 2. の操作を繰り返して、[Payment] ルート ノードの下にさらに 4 つのレコードを作成し、名前を付けます。

    この 4 つのレコードはいずれも [Payment] ルート ノードの子レコードです。それぞれに次の名前を付けます。

    • Seller

    • Buyer

    • Item

    • PaymentSummary

「支払仕様の既存のレコードへの新しいレコードの追加」に進みます。


支払仕様の既存のレコードへの新しいレコードの追加

  1. [Seller] レコードを右クリックし、[新しいレコード] をクリックします。

  2. このレコードに Address という名前を付け、Enter キーを押します。

  3. 手順 1. および 2. の操作を繰り返して、次の表に示すとおりに、親レコードに子レコードをそれぞれ作成します。
    親レコード | 子レコード名
    Seller | ContactInfo
    Buyer | Address
    Buyer | ContactInfo

「支払仕様の既存のレコードへの新しいフィールドの追加」に進みます。


支払仕様の既存のレコードへの新しいフィールドの追加

  1. [PaymentHeader] レコードを右クリックし、[新しいフィールド] をクリックします。

  2. 新しいフィールドに PONumber という名前を付け、Enter キーを押します。

  3. [宣言] プロパティ ページの [データ型] 行の "値" フィールドをダブルクリックします。[String] をクリックして Enter キーを押します。

  4. [宣言] プロパティ ページの [最小値] 行の "値" フィールドをダブルクリックします。「1」と入力して Enter キーを押します。

  5. [宣言] プロパティ ページの [最大値] 行の "値" フィールドをダブルクリックします。「22」と入力して Enter キーを押します。

  6. 手順 1. ～ 5. の操作を繰り返して、次の表に示すとおりに、レコードまたは子レコードのフィールドを作成します。

    各レコードには複数のフィールドが含まれます。

    販売者と購入者のレコードは互いに対応しているので、購入者のフィールドを作成する必要はありません。同じ名前のレコードにはすべて、同じレコード情報およびフィールド情報が含まれています。あるフィールドを Seller レコードの Address レコード、または Seller レコードの ContactInfo レコードに追加すると、自動的に Buyer レコードの Address レコードまたは Buyer レコードの ContactInfo レコードにも、そのフィールド情報が反映されます。

    親レコード | フィールド名 | データ型 | 最小値 | 最大値
    PaymentHeader | Date | Date | なし | なし
    Seller/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Seller/ContactInfo | Name | String | 1 | 60
    Number | String | 1 | 60
    Item | Quantity | Real (r4) | なし | なし
    Price | Real (r4) | なし | なし
    Description | String | 1 | 80
    ExtendedPrice | Real (r4) | なし | なし
    PaymentSummary | Total | Real (r4) | なし | なし

「WebDAV への支払仕様の格納」に進みます。


WebDAV への支払仕様の格納

ファイルを WebDAV に保存すると、それは、ローカル ドライブでなく、サーバーに格納されます。WebDAV はドキュメントをロックし、ユーザーによる不測の上書きを防止します。WebDAV はまた、作成ツールやプラットフォーム、またはファイルが格納されているWebサーバーの種類などに関係なく、複数のユーザーがサーバー ベースのドキュメントを共有し、作業を行えるようにします。ここでは、ドキュメント インスタンスの検証も行います。ドキュメント インスタンスが無効であると、[警告] プロパティ ページにそのことが示され、その原因を示すエラーが表示されます、

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

    [WebDAV に格納] ダイアログ ボックスが表示されます。

  2. [Microsoft] フォルダをダブルクリックします。

  3. [ファイル名] ボックスに「PaymentSpec」と入力し、[保存] をクリックします。

  4. [ツール] メニューの [インスタンスの検証] をクリックします。

    [ドキュメント インスタンスの検証] ダイアログ ボックスが表示されます。

  5. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動します。

  6. payment_valid.xml をクリックし、[開く] をクリックします。

    警告またはエラーは、存在する場合は [警告] ページに表示されます。エラーを解決するには、警告メッセージを選択します。

支払仕様は次のようになります。

BizTalk エディタで注文要求仕様を作成するには、「注文要求仕様の作成」に進みます。

ショートカット

  • BizTalk Server とそのすべてのコンポーネントが C ドライブにインストールされていると、既存の注文要求仕様を使用できます。「既存の注文要求仕様の使用」に進みます。


既存の注文要求仕様の使用

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps から POReq.xml をコピーします。

  2. このファイルを \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft に貼り付けます。

「BizTalk マッパーの使用」に進みます。


注文要求仕様の作成

ここでは、注文要求仕様のルート ノードを作成します。注文要求仕様は、Northwind Traders 社が注文要求を承認のために送信するとき使用する構造およびデータを定義します。

ルート ノードを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をクリックします。

    [新しいドキュメント仕様] ダイアログ ボックスが表示されます。

  2. [空の仕様] をクリックし、[OK] をクリックします。

  3. ルート ノードの [空の仕様] をクリックします。

  4. [宣言] プロパティ ページの [名前] 行の "値" フィールドをダブルクリックします。「POReq」と入力して Enter キーを押します。

  5. [モデル] 行の "値" フィールドをダブルクリックし、[オープン] をクリックします。そして Enter キーを押します。

「注文要求仕様のルート ノードへの新しいレコードの追加」に進みます。


注文要求仕様のルート ノードへの新しいレコードの追加

  1. [POReq] ルート ノードを右クリックし、[新しいレコード] をクリックします。

  2. 新しいレコードに Header という名前を付け、Enter キーを押します。

  3. 手順 1. および 2. の操作を繰り返して、[POReq] ルート ノードの下にさらに 5 つのレコードを作成し、名前を付けます。

    この 5 つのレコードはいずれも [POReq] ルート ノードの子レコードです。それぞれに次の名前を付けます。

    • EmployeeInfo

    • BillTo

    • ShipTo

    • Item

    • Total

「注文要求仕様の既存のレコードへの新しいレコードの追加」に進みます。


注文要求仕様の既存のレコードへの新しいレコードの追加

  1. [BillTo] レコードを右クリックし、[新しいレコード] をクリックします。

  2. このレコードに Address という名前を付け、Enter キーを押します。

  3. 手順 1. および 2. の操作を繰り返して、親レコード [ShipTo] に子レコードを作成し、Address という名前を付けます。

「注文要求仕様の既存のレコードへの新しいフィールドの追加」に進みます。


注文要求仕様の既存のレコードへの新しいフィールドの追加

  1. [Header] レコードを右クリックし、[新しいフィールド] をクリックします。

  2. 新しいフィールドに Date という名前を付け、Enter キーを押します。

  3. [宣言] プロパティ ページの [データ型] 行の "値" フィールドをダブルクリックします。[Date] をクリックして Enter キーを押します。

  4. [EmployeeInfo] レコードを右クリックし、[新しいフィールド] をクリックします。

  5. 新しいフィールドに EmpID という名前を付け、Enter キーを押します。

  6. [宣言] プロパティ ページの [データ型] 行の "値" フィールドをダブルクリックします。[String] をクリックして Enter キーを押します。

  7. [宣言] プロパティ ページの [最小値] 行の "値" フィールドをダブルクリックします。「1」と入力して Enter キーを押します。

  8. [宣言] プロパティ ページの [最大値] 行の "値" フィールドをダブルクリックします。「60」と入力して Enter キーを押します。

  9. 手順 4. ～ 8. の操作を繰り返して、次の表に示すとおりに、レコードまたは子レコードのフィールドを作成します。

    各レコードには複数のフィールドが含まれます。

    BillTo と ShipTo のレコードは互いに対応しているので、ShipTo のフィールドを作成する必要はありません。同じ名前のレコードにはすべて、同じレコード情報およびフィールド情報が含まれています。あるフィールドを BillTo レコードの Address レコードに追加すると、自動的に ShipTo レコードの Address レコードにも、そのフィールド情報が反映されます。

    親レコード | フィールド名 | データ型 | 最小値 | 最大値
    EmployeeInfo | LastName | String | 1 | 30
    FirstName | String | 1 | 30
    BillTo/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Item | Quantity | Real (r4) | なし | なし
    Price | Real (r4) | なし | なし
    Description | String | 1 | 80
    UnitofMeasure | String | 2 | 2
    ExtendedPrice | Real (r4) | なし | なし
    Total | LineItemTtl | Real (r4) | なし | なし
    QtyTtl | Real (r4) | なし | なし
    POTtl | Real (r4) | なし | なし

「注文要求仕様の保存」に進みます。


注文要求仕様の保存

前の「WebDAV への支払仕様の格納」と同じで、ローカルドライブでなく、WebDAV にファイルを格納することにします。

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

    [WebDAV に格納] ダイアログ ボックスが表示されます。

  2. [Microsoft] フォルダが開いていることを確認します。

  3. [ファイル名] ボックスに「POReq」と入力し、[保存] をクリックします。

  4. [ツール] メニューの [インスタンスの検証] をクリックします。

    [ドキュメント インスタンスの検証] ダイアログ ボックスが表示されます。

  5. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData に移動します。

  6. POReqAccept.xml をクリックし、[開く] をクリックします。

    警告またはエラーは、存在する場合は [警告] ページに表示されます。

    注文要求仕様は次のようになります。

  7. [ファイル] メニューの [終了] をクリックして BizTalk エディタを閉じます。

「BizTalk マッパーの使用」に進みます。


BizTalk マッパーの使用

ここでは、BizTalk マッパーを使用して、Contoso 社が使用する CommonInvoice 仕様に適合したメッセージのデータを、購入者である Northwind Traders 社のために作成された PaymentSpec 仕様に適合したメッセージのデータに変換するマップを作成します。

次のモジュールでは、BizTalk メッセージ サービスがチャネルの中にあるこのマップを使用して、特定の XML スキーマを使用しているドキュメントのデータを別の XML スキーマを使用するドキュメントに変換する方法を指示する仕組みについて説明しています。

このチュートリアルの最初にある概要図をプリントしていれば、このプロセスの視覚的な表現が "BizTalk メッセージ サービス" として図の下側に示されています。

BizTalk マッパーを使用してマップを作成するには、「InvoiceToPayment マップの作成」に進みます。

ショートカット

  • BizTalk Server とそのすべてのコンポーネントが C ドライブにインストールされていると、既存のマップを使用できます。「既存の InvoiceToPayment マップの使用」に進んでください。


既存の InvoiceToPayment マップの使用

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps から InvoiceToPayment.xml をコピーします。

  2. このファイルを \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft に貼り付けます。

「モジュール 3: BizTalk メッセージ サービスの構成」に進みます。


InvoiceToPayment マップの作成

マップを作成する前に、送信元仕様になる CommonInvoice.xml と送信先仕様になる PaymentSpec.xml を開く必要があります。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft BizTalk Server 2002] をポイントし、[BizTalk マッパー] をクリックします。

  2. [ファイル] メニューの [新規作成] をクリックします。

    [送信元仕様の種類の選択] ダイアログ ボックスが表示されます。

  3. [WebDAV ファイル] をクリックし、[OK] をクリックします。

    [送信元仕様の取得] ダイアログ ボックスが表示されます。

  4. [Microsoft] フォルダをダブルクリックします。

  5. CommonInvoice.xml をクリックし、[開く] をクリックします。

    [送信先仕様の種類の選択] ダイアログ ボックスが表示されます。

  6. [WebDAV ファイル] をクリックし、[OK] をクリックします。

  7. PaymentSpec.xml をクリックし、[開く] をクリックします。

「フィールド間のリンクの作成」に進みます。


フィールド間のリンクの作成

ここでは、送信元仕様のフィールドと送信先仕様のフィールドとの間にリンクを作成します。送信元仕様ツリーのレコードおよびフィールドから送信先仕様ツリーのレコードおよびフィールドへのデータ コピーの基本機能は、リンクによって実行されます。

フィールド間のリンクを作成するには次の操作を行います。

  1. [送信元仕様] ツリーで、[InvoiceHeader] レコードを展開して関連付けられているフィールドを表示します。

    詳細については、「ツリー項目の展開」を参照してください。

  2. [送信先仕様] ツリーで、[PaymentHeader] レコードを展開して関連付けられているフィールドを表示します。

  3. [送信元仕様] ツリーの [InvoiceHeader] レコードの [Date] フィールドを、[送信先仕様] ツリーの [PaymentHeader] レコードの [Date] フィールドまでドラッグします。

  4. 手順 1. ～ 3. の操作を繰り返して、次の表に示すとおりに、フィールド間のリンクを作成します。
    送信元レコード/フィールド | 送信先レコード/フィールド
    InvoiceHeader/Number | PaymentHeader/PONumber

    Seller/Address/Name | Seller/Address/Name
    Seller/Address/Address1 | Seller/Address/Address1
    Seller/Address/Address2 | Seller/Address/Address2
    Seller/Address/City | Seller/Address/City
    Seller/Address/State | Seller/Address/State
    Seller/Address/PostalCode | Seller/Address/Zip
    Seller/Address/Country | Seller/Address/Country

    Seller/ContactInfo/ContactName | Seller/ContactInfo/Name
    Seller/ContactInfo/ContactNumber | Seller/ContactInfo/Number

    Buyer/Address/Name | Buyer/Address/Name
    Buyer/Address/Address1 | Buyer/Address/Address1
    Buyer/Address/Address2 | Buyer/Address/Address2
    Buyer/Address/City | Buyer/Address/City
    Buyer/Address/State | Buyer/Address/State
    Buyer/Address/PostalCode | Buyer/Address/Zip
    Buyer/Address/Country | Buyer/Address/Country

    Buyer/ContactInfo/ContactName | Buyer/ContactInfo/Name
    Buyer/ContactInfo/ContactNumber | Buyer/ContactInfo/Number

    Item/ItemHeader/Quantity | Item/Quantity
    Item/ItemHeader/Price | Item/Price
    Item/ItemDescription/Description | Item/Description

    InvoiceSummary/InvoiceTotal/Amount PaymentSummary/Total

「Functoid を使用したリンクの作成」に進みます。


Functoid を使用したリンクの作成

ここでは、Functoid を使用して、送信元仕様内の [Quantity] フィールドを [Price] フィールドで乗算し、その値を送信先仕様の [ExtendedPrice] フィールドに配置します。

Functoid を使用してリンクを作成するには次の操作を行います。

  1. [表示] メニューの [Functoid パレット] をクリックします。

    [Functoid パレット] が表示されます。

  2. [数値演算] タブをクリックし、乗算 Functoid 乗算 Functoid をマッピング グリッドにドラッグします。そして [Functoid パレット] を閉じます。

  3. 送信元仕様ツリーで、[Item] レコード下の [ItemHeader] レコードの [Quantity] フィールドを配置した Functoid までドラッグします。

  4. 送信元仕様ツリーで、[Item] レコード下の [ItemHeader] レコードの [Price] フィールドをその Functoid までドラッグします。

  5. [乗算] Functoid を、送信先仕様ツリーの [Item] レコードの [ExtendedPrice] フィールドまでドラッグします。

「マップのコンパイル」に進みます。


マップのコンパイル

使用する前にマップをコンパイルし、警告やエラーがあれば、それらを解決する必要があります。

  1. [ツール] メニューの [マップのコンパイル] をクリックします。

  2. 下部ウィンドウの [出力] タブをクリックします。

    [出力] ページに、XSL マップが作成されたことが示されています。警告またはエラーは、存在する場合は [警告] ページに表示されます。

「WebDAV へのマップの格納」に進みます。


WebDAV へのマップの格納

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

    [WebDAV に格納] ダイアログ ボックスが表示されます。

  2. [Microsoft] フォルダをダブルクリックします。

  3. [ファイル名] ボックスに「InvoiceToPayment」と入力し、[保存] をクリックします。

    作成したマップは次のようになります。

  4. [ファイル] メニューの [終了] をクリックして BizTalk マッパーを閉じます。

「モジュール 2 の概要」に進みます。


モジュール 2 の概要

このモジュールでは、次のことについて学習しました。

  • 仕様を作成する。詳細については、「仕様について」を参照してください。

  • 新しいレコードとフィールドを仕様に追加する。詳細については、「レコードへの新しいフィールドの追加」を参照してください。

  • マップを作成する。詳細については、「BizTalk マッパーの使用」を参照してください。

  • マップ内の各フィールド間にリンクを作成する。詳細については、「リンクの作成」を参照してください。

  • Functoid を使用して、マップ内の値の数値処理を行う。詳細については、「Functoid について」を参照してください。

  • 仕様とマップを WebDAV リポジトリに保存する。詳細については、「仕様の格納」および「マップの格納」を参照してください。

次の図で強調表示されている領域は、このモジュールで行った操作を示しています。

「モジュール 3: BizTalk メッセージ サービスの構成」に進みます。

関連項目

仕様の作成とデータのマッピング


モジュール 3 : BizTalk メッセージ サービスの構成

チュートリアルのこの時点で、既にビジネス プロセスと通信フローを設計し、送受信するドキュメントの構造を定義しています。次の手順では、購入者と販売者のシステムで BizTalk メッセージ サービスを構成し、ドキュメントを送受信できるようにします。

ここでは、BizTalk メッセージ マネージャを使用して、販売者と購入者のシステムの組織、チャネル、およびメッセージ ポートを構成します。また、BizTalk Server 管理コンソールを使用して、ファイル受信機能を構成します。

目的

  • ドキュメント定義を作成する。詳細については、「ドキュメント定義の作成および管理」を参照してください。

  • 組織を作成する。詳細については、「組織の作成と管理」を参照してください。

  • メッセージ ポートを作成する。詳細については、「メッセージ ポートの作成および管理」および「BizTalk サービスの統合」を参照してください。

  • チャネルを作成する。詳細については、「チャネルの作成と管理」を参照してください。

  • チャネルのマップを使用して、ドキュメントを変換する。詳細については、「BizTalk マッパーの使用」を参照してください。

  • 受信機能を作成する。詳細については、「受信機能」を参照してください。

「購入者のシステムの構成」に進みます。

関連項目

BizTalk メッセージ マネージャの使用


購入者のシステムの構成

BizTalk メッセージ マネージャを使用して、取引先を表す組織を作成します。

BizTalk メッセージ マネージャを使用して Northwind Traders社のシステムを構成するには、「購入者のシステムの組織の作成」に進みます。

ショートカット

  • BizTalk Server とそのすべてのコンポーネントが C ドライブにインストールされていると、スクリプトを使用して Northwind Traders 社のシステムを構成できます。「構成スクリプトを使用した購入者のシステムの構成」に進みます。


構成スクリプトを使用した購入者のシステムの構成

このスクリプトは、次のものを構成します。

  • 購入者のシステム上の Northwind Traders on Buyer という名前の送信元組織。

  • 購入者のシステム上の Contoso on Buyer という名前の送信先組織。

  • CommonPO、CommonInvoice、PaymentSpec、および POReq の仕様を参照する 4 つのドキュメント定義。

  • ASP ファイルへの HTTP トランスポート サービスを使用して、購入者のシステムから販売者のシステムへの注文要求の移動を定義するメッセージ ポートおよびチャネル。販売者のシステムに構成します。

  • 購入者に送付され、支払通知ドキュメントに変換される請求書の動きを定義するメッセージ ポートおよびチャネル。販売者のシステムに構成します。

注意

  • BizTalk メッセージ マネージャおよび BizTalk Server 管理コンソールを使用して購入者のシステムを構成した場合は、構成スクリプトは実行しないでください。

購入者のシステムに BizTalk メッセージ サービスを構成するスクリプトを実行するには、次の操作を行います。

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Setup\MessagingConfigurationScript に移動します。

  2. ConfigureBuyer.VBS をダブルクリックします。

    正常に実行されたことを知らせるメッセージ ボックスが表示されます。

「販売者のシステムの構成」に進みます。


購入者のシステムの組織の作成

BizTalk メッセージ マネージャを使用して、BizTalk メッセージ サービスの構成によってドキュメントの交換を管理します。ドキュメントを処理する場合は、あらかじめ BizTalk メッセージ マネージャを使用して BizTalk メッセージ サービスを構成しておく必要があります。作成される組織が、チャネルの送信元またはメッセージ ポートの送信先になります。メッセージ ポートとチャンネルは、取引先間のドキュメントの動きを定義します。詳細については、「組織について」を参照してください。

ここでは、Northwind Traders 社のシステム上で送信元組織である Northwind Traders 社と送信先組織である Contoso 社を作成します。

重要

  • 構成スクリプトを使用した場合は、購入者のシステムを構成するのに BizTalk メッセージ マネージャおよび BizTalk Server 管理コンソールを使用しないでください。「販売者のシステムの構成」に進みます。

Northwind Traders 社のシステム上で組織を作成するには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [BizTalk メッセージ マネージャ] ダイアログ ボックスが表示された場合は [キャンセル] をクリックします。

  3. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。

    [新しい組織] ダイアログ ボックスが表示されます。

  4. [組織名] ボックスに「Contoso on Buyer」 と入力し、[OK] をクリックします。

  5. 手順 3. および 4. の操作を繰り返して、新しい組織に Northwind Traders on Buyer という名前を付けます。

「購入者および販売者のシステムのドキュメント定義の作成」に進みます。


購入者および販売者のシステムのドキュメント定義の作成

ここでは、CommonInvoice、CommonPO、PaymentSpec、および POReq の各ドキュメント仕様を参照する 4 つのドキュメント定義を作成します。購入者のシステムと販売者のシステムはこれらのドキュメント定義を共有するので、両方のシステムは双方の間で転送されるビジネス ドキュメントを理解します。ドキュメント定義は、チャネル 中の受信ドキュメントまたは送信ドキュメントの種類を表し、適切な仕様へのポインタになります。詳細については、「ドキュメント定義について」を参照してください。

ドキュメント定義を作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[ドキュメント定義] をクリックします。

    [新しいドキュメント定義] ダイアログ ボックスが表示されます。

  2. [ドキュメント定義名] ボックスに「Purchase Order」と入力します。

  3. [ドキュメント仕様] チェック ボックスをオンにし、[参照] をクリックします。

    [WebDAV リポジトリからのドキュメント仕様の選択] ダイアログ ボックスが表示されます。

  4. [Microsoft] フォルダをダブルクリックします。

  5. CommonPO.xml をクリックし、[開く] をクリックします。

  6. [OK] をクリックして [新しいドキュメント定義] ダイアログ ボックスを閉じます。

  7. 手順 1. ～ 6. の操作を繰り返し、次の変更点に注意して新しいドキュメント定義を作成します。
ドキュメント定義名 | ドキュメント仕様
Invoice | CommonInvoice.xml
Purchase Order Request | POReq.xml
Payment | PaymentSpec.xml

「購入者のシステムにおける Contoso 社へのメッセージ ポートの作成」に進みます。


購入者のシステムにおける Contoso 社へのメッセージ ポートの作成

ここでは、メッセージ ポート を購入者のシステムに作成します。メッセージ ポートはドキュメントの送信先を定義するものです。

このシナリオでは、注文要求が受け入れられると、BizTalk メッセージ サービスは適切なチャネルを見つけて、それを処理します。チャネルは、そのドキュメントを処理した後に、関連付けられたメッセージ ポートをサーバーに示します。これは、ドキュメントを指定された送信先にトランスポートするために必要な一連の手順をサーバーに指示します。ここで作成したメッセージ ポートの送信先組織は "Contoso on Buyer" になります。メッセージ ポートを作成してから、チャネルを作成します。

メッセージ ポートで指定するトランスポート プロパティは、ドキュメントを送信先組織に転送するために使用するトランスポート サービスと、ドキュメントを送信する特定のアドレスを決定します。このメッセージ ポートでは、Contoso のWeb サイトの ASP ファイルにドキュメントを配信するのに HTTP トランスポートを指定します。

メッセージ ポートを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[メッセージ ポート] をクリックします。次に [組織へ] をクリックします。

    新しいメッセージ ポート ウィザードが開きます。

  2. [名前] ボックスに「Port to Contoso via HTTP」と入力し、[次へ] をクリックします。

  3. [送信先組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  4. [Contoso on Buyer] をクリックし、[OK] をクリックします。

  5. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [トランスポートの種類] ボックスの一覧で [HTTP] をクリックします。

  7. [アドレス] ボックスで、プレフィックス http:// の後に使用しているコンピュータの名前を入力し、続けて「/SubmitPO/SubmitNorthwindPO.asp」と入力します。次に [OK] をクリックし、[次へ] をクリックします。

    たとえば、このメッセージを Contoso 社の Web サイト の ASP ページに配信する場合は、「http://ContosoLtd/SubmitPO/SubmitNorthwindPO.asp」と入力します。

    使用しているコンピュータの名前を検索するには、次の操作を行います。

    1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

    2. [管理ツール] をダブルクリックします。

    3. [コンピュータの管理] をダブルクリックします。

      [コンピュータの管理] コンソールが表示されます。

    4. [操作] メニューの [プロパティ] をクリックします。

      [コンピュータの管理 (ローカル) のプロパティ] ダイアログ ボックスが表示されます。

    5. [ネットワーク ID] タブをクリックします。

      使用しているコンピュータの名前が [コンピュータ名] フィールドに表示されます。

  8. [エンベロープ情報] ページで [次へ] をクリックします。

  9. [セキュリティ情報] ページで、[このメッセージ ポート用のチャネルの作成] チェック ボックスがオンになっていることを確認します。

  10. [チャネルの種類] ボックスの一覧で [組織から] をクリックし、[完了] をクリックします。

    新しいチャネル ウィザードが表示されます。

「購入者のシステムにおける Northwind Traders 社からのチャネルの作成」に進みます。


購入者のシステムにおける Northwind Traders 社からのチャネルの作成

メッセージ ポートを作成したら、このメッセージ ポートと関連付けられるチャネルを定義する必要があります。このチャネルでは、ドキュメントの送信元を "Northwind Traders on Buyer" として識別し、受信するドキュメントは注文要求であり、送信ドキュメントは注文書であると指定します。POReqtoPO.xml マップを使用して、ドキュメントを注文要求から注文書に変換します。詳細については、「チャネルについて」を参照してください。

このチュートリアルの最初にある概要図をプリントしていれば、ここで作成するチャネルとメッセージ ポートの視覚的な表現が示されています。

チャネルを作成するには次の操作を行います。

  1. [全般情報] ページの [名前] ボックスに「Channel for POReq to PO」と入力し、[次へ] をクリックします。

  2. [送信元組織] ページで [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. [Northwind Traders on Buyer] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  4. [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  5. [Purchase Order Request] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  6. [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  7. [Purchase Order] をクリックし、[OK] をクリックします。

  8. [受信ドキュメントを送信ドキュメントにマップする] チェック ボックスがオンになっていることを確認します。

  9. [マップ参照] ボックスの右側にある [参照] をクリックします。

    [WebDAV リポジトリからのマップの選択] ダイアログ ボックスが表示されます。

  10. [Microsoft] フォルダをダブルクリックします。

  11. POReqtoPO.xml をクリックし、[開く] をクリックします。そして [次へ] をクリックします。

  12. [ドキュメント ログ] ページで [次へ] をクリックします。

  13. [詳細構成] ページで [完了] をクリックします。

「購入者のシステム内で使用する Contoso 社へのメッセージ ポートの作成」に進みます。


購入者のシステム内で使用する Contoso 社へのメッセージ ポートの作成

ここでは、ファイルトランスポート サービスを使用する例を示します。購入者と販売者のシステムは両方とも同じコンピュータにあるので、販売者のシステム上の特定の場所へのファイルの送信をシミュレートできます。しかし、ほとんどの場合、購入者は、販売者のシステムにファイルを入れるアクセス許可を持っていません。一般に、取引先にドキュメントを送信するために、HTTP のような別のトランスポート メカニズムが使用されます。

ここで作成するメッセージ ポートは、ファイル トランスポート サービスを使用して、Northwind Traders 社のシステムによって処理されるドキュメントを Contoso 社のシステムへ送信します。ドキュメントは、メッセージ ポートの送信先アドレスで指定されるフォルダ (C:\TutorialFiles\Seller) に送信されます。

メッセージ ポートを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[メッセージ ポート] をクリックします。次に [組織へ] をクリックします。

    新しいメッセージ ポート ウィザードが開きます。

  2. [名前] ボックスに「Port to Contoso via Local File」と入力し、[次へ] をクリックします。

  3. [送信先組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  4. [Contoso on Buyer] をクリックし、[OK] をクリックします。

  5. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [トランスポートの種類] ボックスの一覧で [ファイル] をクリックします。

  7. [アドレス] ボックスで、file:// の後に「C:\TutorialFiles\Seller\payment%tracking_id%.xml」と入力します。

    例 : file://c:\TutorialFiles\Seller\payment%tracking_id%.xml

    注

    • ファイル トランスポート サービスの場合、既定のトランスポート コンポーネント設定では、指定されたディレクトリの既存のファイルに新しいファイルが追加されます。各ドキュメントのインスタンスに一意な名前の新しいファイルを作成するには、次のファイル パス書式を使用します。
      file://C:\dir\file%tracking_id%.xml
  8. [OK] をクリックして [プライマリ トランスポート] ダイアログ ボックスを閉じ、[次へ] をクリックします。

  9. [エンベロープ情報] ページで [次へ] をクリックします。

  10. [セキュリティ情報] ページで、[このメッセージ ポート用のチャネルの作成] チェック ボックスがオンになっていることを確認します。

  11. [チャネルの種類] ボックスの一覧で [組織から] をクリックし、[完了] をクリックします。

    新しいチャネル ウィザードが表示されます。

「購入者のシステムにおける Contoso 社からのチャネルの作成」に進みます。


購入者のシステムにおける Contoso 社からのチャネルの作成

ここで作成するチャネルは、Contoso 社から受信した請求書を処理し、マップを使用してその請求書を支払通知に変換します。このチャネルでは、ドキュメントの送信元を "Contoso on Buyer" として識別し、受信するドキュメントは請求書であり、送信ドキュメントは支払通知であると指定します。BizTalk メッセージ サービスは、InvoiceToPayment.xml マップを使用して、ドキュメントを請求書から支払通知に変換します。

このチュートリアルの最初にある概要図をプリントしていれば、このプロセスの視覚的な表現が示されています。

チャネルを作成するには次の操作を行います。

  1. [全般情報] ページの [名前] ボックスに「Channel for Invoice To Payment」と入力し、[次へ] をクリックします。

  2. [送信元組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. [Contoso on Buyer] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  4. [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  5. [Invoice] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  6. [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  7. [Payment] をクリックし、[OK] をクリックします。

  8. [受信ドキュメントを送信ドキュメントにマップする] チェック ボックスがオンになっていることを確認します。

  9. [マップ参照] ボックスの右側にある [参照] をクリックします。

    [WebDAV リポジトリからのマップの選択] ダイアログ ボックスが表示されます。

  10. [Microsoft] フォルダをダブルクリックします。

  11. InvoiceToPayment.xml をクリックし、[開く] をクリックします。そして [次へ] をクリックします。

  12. [ドキュメント ログ] ページで [次へ] をクリックします。

  13. [詳細構成] ページで [完了] をクリックします。

  14. [ファイル] メニューの [終了] をクリックして BizTalk メッセージ マネージャを閉じます。

「購入者のシステムのファイル受信機能の作成」に進みます。


購入者のシステムのファイル受信機能の作成

ここでは、ローカル ファイル ディレクトリから購入者の注文要求を取得し、それを BizTalk メッセージ サービスに送信するファイル受信機能を作成します。

受信機能によって、アプリケーションは、BizTalk Server 2002 が監視している特定の場所にファイルを送信できるようになります。ここでは、その場所を C:\TutorialFiles\Buyer と定義します。受信機能は、イベント ベースの監視によって、その場所にドキュメントが存在していることを認識します。受信機能がドキュメント データを受信すると、そのデータが BizTalk Server に送信されます。BizTalk Server に送信される各ドキュメントは、その処理方法に関する一連の規則を要求します。ここでは、"Channel for POReq to PO" を指定します。このチャネルには、サーバーがドキュメントを処理するために必要なすべての情報が含まれています。

次の図は、送信側業務用アプリケーション、ファイルが存在しているファイル システム、および受信機能の相関関係を示しています。

受信機能の詳細については、「受信機能とドキュメント ルーティングについて」を参照してください。

ファイル受信機能を作成するには次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

  2. [Microsoft BizTalk Server 2002] を展開し、[BizTalk Server グループ] を展開します。次に [受信機能] をクリックします。

  3. [操作] メニューの [新規作成] をポイントし、[ファイル受信機能] をクリックします。

    [ファイル受信機能の追加] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに「PORequest Receive Function at Northwind Traders」と入力します。

  5. [受信機能を実行するサーバー] ボックスの一覧で、BizTalk Server グループ内のサーバー名をクリックします。

  6. [ポーリングするファイルの種類] ボックスに「*.xml」と入力します。

  7. [ポーリングの場所] ボックスに「C:\TutorialFiles\Buyer」と入力します。

  8. [詳細設定] をクリックします。

    [受信機能の拡張オプション] ダイアログ ボックスが表示されます。

  9. [チャネル名] ボックスの一覧で、[Channel for POReq to PO] をクリックし、[OK] をクリックします。

  10. [OK] をクリックして [ファイル受信機能の追加] ダイアログ ボックスを閉じます。

  11. BizTalk Server 管理コンソールを閉じます。

「販売者のシステムの構成」に進みます。


販売者のシステムの構成

ここでは、BizTalk メッセージ マネージャを使用して、Contoso 社のシステム上で取引先を表す組織を作成します。また、Contoso 社のシステム上におけるドキュメントの動きを定義するメッセージ ポートとチャネルも構成します。

「販売者のシステムの組織の作成」に進みます。


販売者のシステムの組織の作成

ここでは、Contoso 社のシステム上でチャネルの送信元やメッセージ ポートの送信先になる組織を作成します。詳細については、「組織について」を参照してください。

注

  • このチュートリアルでは、購入者と販売者の両方のシステムを同じコンピュータ上で構成します。
  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [BizTalk メッセージ マネージャ] ダイアログ ボックスが表示された場合は [キャンセル] をクリックします。

  3. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。

    [新しい組織] ダイアログ ボックスが表示されます。

  4. [全般] プロパティ ページの [組織名] ボックスに「Contoso on Seller」と入力し、[OK] をクリックします。

  5. 手順 3. および 4. の操作を繰り返して、新しい組織に「Northwind Traders on Seller」という名前を付けます。

「販売者のシステムにおける Contoso 社へのメッセージ ポートの作成」に進みます。


販売者のシステムにおける Contoso 社へのメッセージ ポートの作成

ここでは、販売者のシステム上で注文書の送信先を定義するメッセージ ポートを作成します。このメッセージ ポートは、トランスポート サービスにアプリケーション統合コンポーネント (AIC) を使用して、Contoso 社のシステム内部でドキュメントを送信します。

通常、AIC は、BizTalk Server 2002 とバックエンド アプリケーションとの統合ポイントとして使用します。このシナリオでは、AIC をこの統合ポイントとして使用するほか、仮想のバックエンド アプリケーションとして使用します。メッセージ ポートは、注文を AIC に渡します。注文書が販売者に送信されると、請求書が生成される前にいくつかの追加的なビジネス プロセスが考えられます。しかし、このチュートリアルでは、AIC が、注文書を請求書に変換するために必要なすべての作業を実行し、販売者のシステム内の BizTalk メッセージ サービスの適切なチャネルにそれを送信することにします。

注文書は、チャネルのマップを使用して請求書に変換することもできます。しかし、このシナリオでは、別のトランスポート サービスの仕様を例示するために、AIC を使用してこの操作を行います。

メッセージ ポートを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[メッセージ ポート] をクリックします。次に [組織へ] をクリックします。

    新しいメッセージ ポート ウィザードが開きます。

  2. [名前] ボックスに「Port to Contoso via AIC」と入力し、[次へ] をクリックします。

  3. [送信先組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  4. [Contoso on Seller] をクリックし、[OK] をクリックします。

  5. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [トランスポートの種類] ボックスの一覧で、[アプリケーション統合コンポーネント] が選択されていることを確認し、[参照] をクリックします。

    [コンポーネントの選択] ダイアログ ボックスが表示されます。

  7. [POToINVAIC ConvertPOToInvoice] をクリックし、[OK] をクリックします。

  8. [OK] をクリックして [プライマリ トランスポート] ダイアログ ボックスを閉じ、[次へ] をクリックします。

  9. [エンベロープ情報] ページで [次へ] をクリックします。

  10. [セキュリティ情報] ページで、[このメッセージ ポート用のチャネルの作成] チェック ボックスがオンになっていることを確認します。

  11. [チャネルの種類] ボックスの一覧で [組織から] をクリックし、[完了] をクリックします。

    新しいチャネル ウィザードが表示されます。

「販売者のシステムにおける Northwind Traders 社からのチャネルの作成」に進みます。


販売者のシステムにおける Northwind Traders 社からのチャネルの作成

ここでは、メッセージ ポートのチャネルを作成します。

作成したチャネルの送信元組織は "Northwind Traders on Seller" になります。これは Contoso 社のシステム上の購入者を表します。このチャネルは、Northwind Traders 社から受信した注文を処理します。ドキュメント定義は受信、送信とも同じであるため、このチャネルではマップ参照は必要ありません。したがってドキュメント変換は行われません。

このチュートリアルの最初にある概要図をプリントしていれば、チャネル、メッセージ ポート、および AIC トランスポート プロセスによる注文書の処理の視覚的な表現が示されています。

チャネルを作成するには次の操作を行います。

  1. [全般情報] ページの [名前] ボックスに「Channel for PO」と入力し、[次へ] をクリックします。

  2. [送信元組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. [Northwind Traders on Seller] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  4. [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  5. [Purchase Order] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  6. [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  7. [Purchase Order] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  8. [ドキュメント ログ] ページで [次へ] をクリックします。

  9. [詳細構成] ページで [完了] をクリックします。

「販売者のシステムにおける Northwind Traders 社へのメッセージ ポートの作成」に進みます。


販売者のシステムにおける Northwind Traders 社へのメッセージ ポートの作成

ここでは、請求書の送信先を定義する、Contoso 社のシステム上のメッセージ ポートを作成します。このメッセージポートは、Contoso 社の請求書を購入者の Northwind Traders 社に送信します。HTTP をトランスポート サービスとして使用して、Northwind Traders 社の Web サーバー上の ASP ページに請求書を送信します。ASP ページは、受信した請求書を、購入者のシステム内の ReceiveInvoice メッセージ キューに入れます。

メッセージ ポートを作成するには次の操作を行います。

  1. [ファイル] メニューの [新規作成] をポイントし、[メッセージ ポート] をクリックします。次に [組織へ] をクリックします。

    新しいメッセージ ポート ウィザードが開きます。

  2. [全般情報] ページの [名前] ボックスに「Port to Northwind Traders via HTTP」と入力し、[次へ] をクリックします。

  3. [送信先組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  4. [Northwind Traders on Seller] をクリックし、[OK] をクリックします。

  5. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [トランスポートの種類] ボックスの一覧で [HTTP] をクリックします。

  7. [アドレス] ボックスで、プレフィックス http:// の後に使用しているコンピュータの名前を入力し、続けて「/InvoiceToQueue/DropInvoicetoMSMQ.asp」と入力します。次に [OK] をクリックし、[次へ] をクリックします。

    たとえば、このメッセージを Northwind Traders 社の Webサーバー上の ASP ページに送信する場合は、「http://NorthwindTraders/InvoiceToQueue/DropInvoicetoMSMQ.asp」と入力します。

    使用しているコンピュータの名前を検索するには、次の操作を行います。

    1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

    2. [管理ツール] をダブルクリックします。

    3. [コンピュータの管理] をダブルクリックします。

      [コンピュータの管理] コンソールが表示されます。

    4. [操作] メニューの [プロパティ] をクリックします。

      [コンピュータの管理 (ローカル) のプロパティ] ダイアログ ボックスが表示されます。

    5. [ネットワーク ID] タブをクリックします。

      使用しているコンピュータの名前が [コンピュータ名] フィールドに表示されます。

  8. [エンベロープ情報] ページで [次へ] をクリックします。

  9. [セキュリティ情報] ページで、[このメッセージ ポート用のチャネルの作成] チェック ボックスがオンになっていることを確認します。

  10. [チャネルの種類] ボックスの一覧で [組織から] をクリックし、[完了] をクリックします。

    新しいチャネル ウィザードが表示されます。

「販売者のシステムにおける Contoso 社からのチャネルの作成」に進みます。


販売者のシステムにおける Contoso 社からのチャネルの作成

ここで作成するチャネルの送信元組織は "Contoso on Seller" です。なぜなら、請求書は、注文書から変換されてから、内部の送信元から渡されるからです。このチャネルは、先に作成したメッセージ ポートである Port to Northwind Traders via HTTP の規則に従って、販売者のシステムの Northwind Traders 社に送信される請求書を処理します。

このチュートリアルの最初にある概要図をプリントしていれば、チャネル、メッセージ ポート、および HTTP トランスポート サービス プロセスによる請求書の処理の視覚的な表現が示されています。

チャネルを作成するには次の操作を行います。

  1. [全般情報] ページの [名前] ボックスに「Channel for Invoice」と入力し、[次へ] をクリックします。

  2. [送信元組織] ページの [組織] で [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. [Contoso on Seller] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  4. [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  5. [Invoice] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  6. [送信ドキュメント] ページで [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  7. [Invoice] をクリックし、[OK] をクリックします。そして [次へ] をクリックします。

  8. [ドキュメント ログ] ページで [次へ] をクリックします。

  9. [詳細構成] ページで [完了] をクリックします。

  10. [ファイル] メニューの [終了] をクリックして BizTalk メッセージ マネージャを閉じます。

「モジュール 3 の概要」に進みます。


モジュール 3 の概要

ここでは、購入者のシステムと販売者のシステム上でBizTalk メッセージ サービスを構成します。この作業の手順について注意してください。最初に、両方システム上で、それぞれ組織を作成して、取引先を構築し、次にそれぞれの組織が送受信するドキュメントを定義します。それから、逆の順序で、ドキュメントの送信先、ドキュメントの送信元、およびドキュメントを取得してBizTalk メッセージ サービスに送信する受信機能を構成します。

このモジュールでは、次の作業を行います。

  • 組織を作成する。詳細については、「組織の作成と管理」を参照してください。

  • ドキュメント定義を作成する。詳細については、「ドキュメント定義の作成および管理」を参照してください。

  • メッセージ ポートを作成する。詳細については、「メッセージ ポートの作成および管理」を参照してください。

  • チャネルを作成する。詳細については、「チャネルの作成と管理」を参照してください。

  • チャネルのマップを使用して、ドキュメントを変換する。詳細については、「BizTalk マッパーの使用」を参照してください。

  • ファイル受信機能を作成する。詳細については、「受信機能」を参照してください。

このモジュールで作成したドキュメント定義、組織、メッセージ ポート、チャネル、およびマップを表示するには、BizTalk メッセージ マネージャの [検索] ボタンを使用します。

次の図で強調表示されている領域は、このモジュールで行った操作を示しています。

「モジュール 4 : XLANG スケジュールの完成」に進みます。

関連項目

BizTalk メッセージ マネージャの使用


モジュール 4 : XLANG スケジュールの完成

Northwind Traders 社のビジネス プロセスの最初の表現は、注文承認プロセスだけを扱っています。注文と関連するビジネス プロセスは、承認された注文書の送信、請求書の受信、および支払通知の送信も含んでいます。

このモジュールでは、BizTalk オーケストレーション デザイナを使用して、請求のアクションと支払のアクションを含むように購入者の XLANG スケジュールを変更し、必要なポートを実装します。次に、完成した XLANG スケジュールをコンパイルし、実行します。

目的

  • 請求のアクションおよび支払のアクションを追加する。詳細については、「シェイプの追加」を参照してください。

  • BizTalk メッセージ サービスを使用して、ポートを実装する。詳細については、「BizTalk メッセージ シェイプの使用」を参照してください。

  • 完成した XLANG スケジュールをコンパイルし、実行する。詳細については、「XLANG スケジュールのコンパイル」および「XLANG スケジュールの実行」を参照してください。

XLANG スケジュールを完成させるには、「請求のアクションおよび支払のアクションの追加」に進みます。

ショートカット

  • BizTalk Server とそのすべてのコンポーネントが C ドライブにインストールされていると、既存の XLANG スケジュールを使用できます。「完成した XLANG スケジュールの実行」に進みます。

関連項目

BizTalk オーケストレーションの設計


請求のアクションおよび支払のアクションの追加

ここでは、BizTalk オーケストレーション デザイナで Northwind Traders 社のビジネス プロセスを変更し、購入者から請求書を受信するアクションと支払通知メッセージを Contoso 社に送信するアクションを追加します。

アクションを作成するには次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk オーケストレーション デザイナ] をクリックします。

  2. [ファイル] メニューの [開く] をクリックします。

    [XLANG スケジュール フローチャートを開く] ダイアログ ボックスが表示されます。

  3. 既存の Buyer1.skv ファイルを使用している場合は、[XLANG スケジュール フローチャートを開く] ダイアログ ボックスで、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動し、Buyer1.skv をクリックします。次に [開く] をクリックします。

    モジュール 1 で Buyer1.skv ファイルを作成した場合は、\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動し、Buyer1.skv をクリックします。次に [開く] をクリックします。

    注

    • BizTalk オーケストレーション デザイナで表示される空白のフローチャートは閉じてもかまいません。
  4. [Write PO Request to File] アクションと [終了] アクションの間の接続をクリックして強調表示し、Delete キーを押します。

  5. [終了] アクションを下方に移動し、新しいアクション シェイプ 2 つ分の空間を確保します。

  6. 左側の [フローチャート] ステンシルから [アクション] シェイプを [ビジネス プロセス] ページにドラッグします。

    このシェイプを [Write PO Request to File] アクションの下に配置します。

  7. [アクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [アクションのプロパティ] ダイアログ ボックスが表示されます。

  8. [名前] ボックスに「Receive Invoice」と入力し、[OK] をクリックします。

  9. 左側の [フローチャート] ステンシルから [アクション] シェイプを [ビジネス プロセス] ページにドラッグします。

    このシェイプを [Receive Invoice] アクションの下に配置します。

  10. [アクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [アクションのプロパティ] ダイアログ ボックスが表示されます。

  11. [名前] ボックスに「Send Payment」と入力し、[OK] をクリックします。

  12. [Write PO Request to File] アクションを [Receive Invoice] アクションに接続します。

  13. [Receive Invoice] アクションを [Send Payment] アクションに接続します。

  14. [Send Payment] アクションを [終了] シェイプに接続します。

「メッセージ キュー サービスのバインドおよび請求書の受信」に進みます。


メッセージ キュー サービスのバインドおよび請求書の受信

このチュートリアルの事前セットアップで、Northwind Traders 社が請求メッセージを受信できるようにする ReceiveInvoice メッセージ キューを作成しました。ここでは、[メッセージ キュー] シェイプを XLANG フローチャートに追加し、ReceiveInvoice メッセージ キューにポートを実装します。[メッセージ キュー] シェイプは、メッセージを送受信するために使用するメッセージ キュー サービスを表します。このサービスは、請求書のメッセージ キューを監視するために構成します。[Receive Invoice] アクションはメッセージ キュー サービスにバインドします。ReceiveInvoice メッセージ キューに請求書が送信されると、[Receive Invoice] アクションが有効になります。詳細については、「メッセージ キュー シェイプの使用」を参照してください。

このチュートリアルの最初にある概要図をプリントしている場合は、ASP ファイル、メッセージ キュー、および [Receive Invoice] アクションによるドキュメントの流れを視覚的に確認してください。

メッセージ キュー サービスをバインドするには次の操作を行います。

  1. 右側の [実装] ステンシルから [メッセージ キュー] シェイプを [ビジネス プロセス] ページにドラッグします。

    [メッセージ キュー] シェイプを [Receive Invoice] アクションと水平になるようにそろえて配置します。

    [メッセージ キュー バインド ウィザード] が表示されます。

  2. [メッセージ キュー バインド ウィザードへようこそ] ページで、[新しいポートの作成] が選択されていることを確認します。

  3. [新しいポートの作成] ボックスに「ReceiveInvoice」と入力し、[次へ] をクリックします。

  4. [静的または動的キューの情報] ページで [静的キュー] が選択されていることを確認し、[次へ] をクリックします。

  5. [キュー情報] ページで [すべてのインスタンスに対して既存のキューを使用する] をクリックします。

  6. [キュー名を入力します。] というボックスに「.\private$\ReceiveInvoice」と入力し、[次へ] をクリックします。

  7. [ポート プロパティの詳細設定] ページで [完了] をクリックします。

「Receive Invoice サービスのメッセージのプロパティの定義」に進みます。


Receive Invoice サービスのメッセージのプロパティの定義

ここでは、XML 通信ウィザードを使用して、[Receive Invoice] アクション シェイプとReceiveInvoice ポートとの間で通信ができるようにします。XML 通信ウィザードによって、XLANG スケジューラ エンジンがキューから適切なメッセージを識別して取得するために使用する情報と仕様を与えます。

  1. [Receive Invoice] アクションをクリックし、その右側の制御ハンドルを [ReceiveInvoice] ポートまでドラッグします。

    [XML 通信ウィザード] が表示されます。

  2. [XML 通信ウィザードへようこそ] ページで [受信] をクリックし、[次へ] をクリックします。

  3. [メッセージ情報] ページで [新しいメッセージの作成] が選択されていることを確認します。

  4. [メッセージ名] ボックスに「CommonInvoice」と入力し、[次へ] をクリックします。

  5. [XML 変換情報] ページで、[キューから XML メッセージを受信する] が選択されていることを確認し、[次へ] をクリックします。

  6. [メッセージの種類の情報] ページで、[メッセージの種類] ボックスに「CommonInvoice」と入力し、[次へ] をクリックします。

  7. [メッセージ仕様情報] ページで、[完了] をクリックします。

「BizTalk メッセージ サービスのバインド」に進みます。


BizTalk メッセージ サービスのバインド

ここでは、[BizTalk メッセージ] シェイプをフローチャートに追加し、BizTalk メッセージ バインド ウィザードを使用して、ポートに、このポートがドキュメントの受信用でなく、送信用であることを指定します。[BizTalk メッセージ] シェイプは、BizTalk オーケストレーション サービスと BizTalk メッセージ サービスとの間でメッセージを交換するために使用する BizTalk メッセージ サービスを表します。

ここでは、BizTalk メッセージ サービスを XLANG スケジュール フローチャートとバインドします。請求書を支払通知に変換するために使用する BizTalk メッセージ サービスのチャネルも特定します。詳細については、「BizTalk メッセージ シェイプの使用」を参照してください。

BizTalk メッセージ サービスをバインドするには次の操作を行います。

  1. 右側の [実装] ステンシルから [BizTalk メッセージ] シェイプを [ビジネス プロセス] ページにドラッグします。

    [BizTalk メッセージ] シェイプを [Send Payment] アクションと水平になるようにそろえて配置します。

    [BizTalk メッセージ バインド ウィザード] が表示されます。

  2. [BizTalk メッセージ バインド ウィザードへようこそ] ページで、[新しいポートの作成] が選択されていることを確認します。

  3. [新しいポートの作成] ボックスに「SendPayment」と入力し、[次へ] をクリックします。

  4. [通信の方向] ページで [送信] が選択されていることを確認し、[次へ] をクリックします。

  5. [静的または動的チャネルの情報] ページで、[静的チャネル] が選択されていることを確認します。

  6. [既存のチャネル名を入力してください] ボックスに「Channel for Invoice To Payment」と入力し、[完了] をクリックします。

    [Channel for Invoice To Payment] は、モジュール 3 で作成したものです。

「BizTalk メッセージ サービスのメッセージのプロパティの定義」に進みます。


BizTalk メッセージ サービスのメッセージのプロパティの定義

ここでは、XML 通信ウィザードを使用して、[Send Payment] アクションと [SendPayment] ポートとの間で通信ができるようにします。

  1. [Send Payment] アクションの右側の制御ハンドルを [SendPayment] ポートまでドラッグします。

    [XML 通信ウィザード] が表示されます。

  2. [XML 通信ウィザードへようこそ] ページで [次へ] をクリックします。

  3. [メッセージ情報] ページで [既存のメッセージに参照を追加] をクリックし、[CommonInvoice] をクリックします。そして [次へ] をクリックします。

  4. [XML 変換情報] ページで、[XML メッセージをキューに送信する] が選択されていることを確認し、[次へ] をクリックします。

  5. [メッセージの種類の情報] ページで [次へ] をクリックします。

  6. [メッセージ仕様情報] ページで、[完了] をクリックします。

「完成した XLANG スケジュール フローチャートの保存」に進みます。


完成した XLANG スケジュール フローチャートの保存

  1. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [XLANG スケジュール フローチャートに名前を付けて保存] ダイアログ ボックスが表示されます。

  2. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  3. [ファイル名] ボックスに「Buyer2」と入力し、[保存] をクリックします。

「完成した XLANG スケジュールのコンパイル」に進みます。


完成した XLANG スケジュールのコンパイル

XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイルの詳細については、「XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル」を参照してください。

  1. [ファイル] メニューの [XLANG Buyer2.skx の作成] をクリックします。

    [XLANG スケジュールに名前を付けて保存] ダイアログ ボックスが表示されます。

  2. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  3. [ファイル名] ボックスに「Buyer2」と入力し、[保存] をクリックします。

    完成した XLANG スケジュール フローチャートは、次のようになります。

    XLANG スケジュール フローチャート

  4. [ファイル] メニューの [終了] をクリックします。

「完成した XLANG スケジュールの実行」に進みます。


完成した XLANG スケジュールの実行

企業間自動調達ソリューションの構成が完了しました。次に、XLANG スケジュールを有効にするアプリケーションを実行します。

ここでは、監視されているメッセージ キューに注文要求を配信して、XLANG スケジュールをアクティブにする ExecuteTutorial アプリケーションを使用します。

XLANG スケジュールを実行するには次の操作を行います。

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動します。

  2. ExecuteTutorial.exe をダブルクリックします。このアプリケーションは、モニカで XLANG スケジュールを有効にする場合に使用します。

    ExecuteTutorial アプリケーションが起動します。

  3. [Browse for Schedule] をクリックします。

    ショートカット

    • BizTalk Server とそのすべてのコンポーネントが C ドライブにインストールされていると、既存の XLANG スケジュールを使用できます。\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に移動し、手順 5 に進みます。
  4. XLANG スケジュール Buyer2 を作成していれば、\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  5. XLANG スケジュール Buyer2.skx をクリックし、[開く] をクリックします。

  6. [Browse for Data File] クリックし、\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData に移動します。

  7. POReqAccept.xml をクリックし、[開く] をクリックします。

  8. [Start XLANG Schedule] をクリックします。

    合計が 1,000 ドル以下であるため、注文要求が承認されます。XLANG スケジューラ エンジンにデータが渡されたことを示すメッセージが表示されます。この時点でアプリケーションは終了しています。次に、注文要求が承認されたことを示すメッセージが表示されます。[OK] をクリックして、メッセージ ボックスを閉じます。

  9. [End] をクリックし、ExecuteTutorial アプリケーションを閉じます。

  10. C:\TutorialFiles\Seller に移動します。

    支払通知ファイルが表示されます。ファイル名は PaymentXXXX..xml で、XXXX は数字の一意な組み合わせです。このファイルをダブルクリックして Microsoft Internet Explorer で開きます。

注文要求の送信が完了しました。注文要求は承認され、販売者に送信されました。注文は応えられ、請求書が発行されました。請求書が受信されたら、支払通知が販売者のシステムに送信されました。

「モジュール 4 の概要」に進みます。


モジュール 4 の概要

このモジュールでは、次のことについて学習しました。

  • 請求のアクションおよび支払のアクションを追加する。詳細については、「シェイプの接続」を参照してください。

  • BizTalk メッセージ サービスを使用してメッセージ ポートを実装する。BizTalk メッセージ サービスによるメッセージ ポートの実装の詳細については、「BizTalk メッセージ シェイプの使用」を参照してください。

  • 完成した XLANG スケジュールをコンパイルし、実行する。詳細については、「XLANG スケジュールのコンパイル」および「XLANG スケジュールの実行」を参照してください。

次の図で強調表示されている領域は、このモジュールで行った操作を示しています。

「チュートリアルの概要」に進みます。

関連項目

BizTalk オーケストレーションの設計


チュートリアルの概要

このチュートリアルでは、Microsoft BizTalk Server 2002 を構成し、企業間自動調達のプロセスを設定し、実行しました。

次の図は、モジュール 4 の最後で XLANG スケジュール Buyer2 を実行したときの、BizTalk Server におけるデータ フローを示しています。

BizTalk Server のコンポーネントとサービスの連携機能を活用し、企業内および企業間における、疎結合、長時間ビジネス プロセスを統合する方法を学習しました。

さらに次の方法についても学習しました。

  • BizTalk オーケストレーション デザイナを使用し、XLANG スケジュール フローチャートを作成してビジネス プロセスをモデル化する。

  • BizTalk メッセージ マネージャを使用して、組織、チャネル、メッセージ ポート、およびドキュメント定義を作成する。

  • BizTalk エディタを使用して、仕様を作成する。

  • BizTalk マッパーを使用して、マップを作成する。

  • XLANG スケジュールをコンパイルし、実行する。

これでチュートリアルが完了しました。

参考資料

このチュートリアルで使用する付属コンポーネントの作成の詳細については、「付録 : 付属コンポーネントの作成」を参照してください。

BizTalk Server で企業間自動調達プロセスを構築するために必要なプロセスと作業に関する基本的コンセプトの概要については、「BizTalk Server 2002 の理解」を参照してください。

BizTalk Server 2002 で利用できる新しい機能のいくつかの包括的な使用例については、「電子調達サンプル」を参照してください。新しい機能は次のとおりです。

  • 短期間で取引先でのセットアップを実現する BizTalk SEED ウィザード

  • Application Center 展開機能

  • Microsoft Operations Manager (MOM) を使用する高度な監視機能

  • インスタンスごとのキューでなく、共通キューを使用する新しい XLANG 関連付け


付録 : 付属コンポーネントの作成

ここでは、データを処理するために Microsoft BizTalk Server 2002 と共に使用する付属コンポーネントの作成方法について説明します。コンポーネントの種類とそれぞれの役割および処理時の相関関係について、詳細に説明します。

重要

  • 付録の一部のために Microsoft Visual Basic 6.0 が必要になります。

作成するコンポーネントは次のものです。

  • XLANG スケジュールを有効にするアプリケーション。購入者のシステムに作成します。このアプリケーションは、購入者のシステムにおけるメッセージ フローを制御する XLANG スケジュールにバインドされているメッセージ キューに、注文 (PO) 要求を送信します。

  • Windows スクリプト コンポーネント (WSC)。購入者のシステムに作成します。注文要求に対する XLANG スケジュールからの承認ステータスまたは拒否ステータスを確定します。承認された場合、WSC は承認メッセージを表示し、注文要求をローカル ファイル ディレクトリに書き込みます。このローカル ディレクトリは、購入者の BizTalk メッセージ サービスで取得します。拒否された場合は、WSC は拒否メッセージを表示し、スケジュールを終了します。

  • アプリケーション統合コンポーネント (AIC)。販売者のシステムに作成します。購入者の注文データに基づいて請求書を生成します。

「アプリケーションの作成」に進みます。


アプリケーションの作成

ここでは、XLANG スケジュールを有効にし、注文要求をキューに送信するアプリケーションを作成します。このアプリケーションを使用して、XLANG スケジュールの実装のテストおよび BizTalk メッセージ マネージャの構成のテストを行います。

このテストを実行するには、サンプル プロジェクトのコードを変更します。対象となるコードは、XLANG スケジュールを有効にし、メッセージをキューに送信するコードです。補助コードが提供されています。

各手順は、それぞれコードのセグメントに対応しています。次の例のようなコメント ブロックを参照してください。

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'To Do:Step A
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

これに続くコードは、プレース ホルダーを示す疑問符 (?) がある行で、ここに変更を加える必要があります。テストを実行するには、この疑問符を適切なコードに置き換えてください。たとえば、次のようなコードがあるとします。

Private g_MSMTxDisp As ?

この場合は次のように変更します。

Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenser

注

  • これらのコード行はコメント アウトされています。変更対象の行の先頭にあるコメント マークは削除してください。ここでの手順は、コード ウィンドウどおりの順序になっているとは限りません。

「アプリケーションを開く」に進みます。


アプリケーションを開く

  1. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に移動します。

  2. ExecuteTutorial.vbp をダブルクリックします。

「アプリケーションへの必要な参照の追加」に進みます。


アプリケーションへの必要な参照の追加

ここでは、メッセージ キュー、XML、およびスクリプト ランタイムを使用するために必要な多くのダイナミック リンク ライブラリ (DLL) をアプリケーションに実装します。

  1. [プロジェクト] メニューの [参照設定] をクリックします。

  2. [Microsoft Message Queue 2.0 Object Library] を選択します。

    このタイプ ライブラリの完全なパスは、\WINNT\System32\MQOA.dll です。

  3. [Microsoft Scripting Runtime] を選択します。

    この DLL の完全なパスは、\WINNT\System32\Scrrun.dll です。

  4. [Microsoft XML, v 3.0] を選択します。

    この DLL の完全なパスは、\WINNT\System32\msxml3.dll です。

  5. [OK] をクリックします。

「メッセージ キュー オブジェクトの定義および初期化」に進みます。


メッセージ キュー オブジェクトの定義および初期化

ここでは、指定された種類のライブラリを使用するコードを追加します。ここでの手順は、コードの手順に対応しています。

  1. プロジェクト ウィンドウで [フォーム] を展開し、[Form1 (ExecuteTutorial.frm)] をクリックします。

  2. [表示] メニューの [コード] をクリックします。

  3. コードの Step A の一般宣言部で、メッセージ キュー オブジェクトを作成します。次の例を参照してください。
    Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenser
Private g_MSMQQueue As MSMQ.MSMQQueue
Private g_MSMQInfo As MSMQ.MSMQQueueInfo
  4. コードの Step B の Form_Load イベント部で、メッセージ キュー オブジェクトを初期化します。次の例を参照してください。
    Set g_MSMQInfo = CreateObject("MSMQ.MSMQQueueInfo")
Set g_MSMTxDisp = CreateObject("MSMQ.MSMQTransactionDispenser")

「データをキューに配置するコードの追加」に進みます。


データをキューに配置するコードの追加

ここでは、ExecuteMSMQ という新しいサブルーチンを追加します。これは cmdRunSked_Click イベントによって呼び出されるルーチンです。次の手順に従って、このサブルーチンを呼び出すコードを追加します。

  • Step C で、プロジェクトのコード ウィンドウの最後に次のコードを配置します。
    Public Sub ExecuteMSMQ(ByVal strQueuePath As String, DataToQueue As String)
    Dim QueueMsg As New MSMQMessage

    Dim strData As String
    Dim fSend As Boolean
    Dim txt As TextStream
    Dim mybyte() As Byte

    g_MSMQInfo.FormatName = strQueuePath
    Set g_MSMQQueue = g_MSMQInfo.Open(MQ_SEND_ACCESS, MQ_DENY_NONE)
    mybyte = StrConv(DataToQueue, vbFromUnicode)
    QueueMsg.Body = DataToQueue

    Set MSMQTx = g_MSMTxDisp.BeginTransaction
    QueueMsg.send g_MSMQQueue, MSMQTx
    MSMQTx.Commit

    Set QueueMsg = Nothing
    Set MSMQTx = Nothing

End Sub

「XLANG スケジュールをアクティブにし、ExecuteMSMQ を呼び出すコードの追加」に進みます。


XLANG スケジュールをアクティブにし、ExecuteMSMQ を呼び出すコードの追加

ここでは、XLANG スケジュールをアクティブにし、メッセージをキューに送信するコードを呼び出すコードを cmdRunSked_Click イベントに追加します。

  1. コードの Step D の cmdRunSked_Click イベント部で、ExecuteMSMQ を呼び出します。次のコードを参照してください。
    ExecuteMSMQ "DIRECT=OS:.\private$\ReceivePOReq", objfs.OpenTextFile(txtData.Text, ForReading).ReadAll
  2. コードの Step E の cmdRunSked_Click イベント部で、GetObject を呼び出して、モニカで XLANG スケジュールのインスタンスを作成します。次のコードを参照してください。
    Set SendPAQ = GetObject(txtSked.Text)

「アプリケーションの保存およびコンパイル」に進みます。


アプリケーションの保存およびコンパイル

ここでは、アプリケーションを保存し、コンパイルします。

  1. [ファイル] メニューの [プロジェクトの上書き保存] をクリックします。

  2. [ファイル] メニューの [ExecuteTutorial.exe の作成] をクリックします。

    [実行可能ファイルの作成] ダイアログ ボックスが表示されます。

  3. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab フォルダに移動し、[OK] をクリックします。

これでアプリケーションを実行して、モジュール 1 および 4 の購入者のスケジュールを実行できるようになりました。

「Windows スクリプト コンポーネント (WSC) の作成」に進みます。


Windows スクリプト コンポーネントの作成

ここでは、XLANG スケジュールにバインドする Windows スクリプト コンポーネント (WSC) を作成します。WSC は、注文要求の承認ステータスまたは拒否ステータスを示すメッセージ ボックスを表示するためのものです。承認された場合は、必要に応じて、注文をローカル ファイルに書き込むこともできます。

「コンポーネントを登録するスクリプトの追加」に進みます。


コンポーネントを登録するスクリプトの追加

ここでは、コンポーネントをファイルに登録するためのスクリプトを追加します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [アクセサリ] をポイントし、[メモ帳] をクリックします。

  2. 次のスクリプトを追加します。
    <?xml version="1.0"?>
<component>
<?component error="true" debug="true"?>
<registration
     description="PORequestApproval"
     progid="BTSTutorial.PORequestApproval"
     version="1.00"
     classid="{2938621b-40fc-48e2-827c-bed74e21a538}"
>
</registration>

    あらかじめ構成されているコンポーネントと同じクラス ID を使用しているため、古いコンポーネントはレジストリで上書きされます。

「メソッドを実装するスクリプトの追加」に進みます。


メソッドを実装するスクリプトの追加

このコンポーネントには 3 つのメソッドがあります。1 つ目は、ユーザーに表示するメッセージ ボックスの形式で承認ステータスを送信するメソッドです。2 つ目は、同じくユーザーに表示するメッセージ ボックスの形式で、拒否ステータスを送信するメソッドです。どちらのメソッドを呼び出すかの判断は、XLANG スケジュール フローチャートの判断規則に従って行われます。3 つ目は、注文要求が承認された場合に、その注文をローカル ファイルに書き込むメソッドです。

  1. 3 つのメソッドの署名をファイルの最後に追加します。
    <public>
     <method name="SendApproval">
          <PARAMETER name="Document"/>
     </method>
     <method name="SendDenial">
          <PARAMETER name="Document"/>
     </method>
     <method name="WriteToFile">
          <PARAMETER name="Document"/>
          <PARAMETER name="FileName"/>
     </method>
</public>
  2. メソッドを実装するスクリプトをファイルの最後に追加します。
    <implements type="Behavior" id="Behavior"/>

<script language="VBScript">
<![CDATA[

function SendApproval(Document)
     MsgBox "Scheduler Engine Accepted document :" + vbcrlf + + vbcrlf + Document, 0, "Document Approval Received"
end function

function SendDenial(Document)
     MsgBox "Scheduler Engine Denied document :" + vbcrlf + + vbcrlf + Document, 0, "Document Denied"
end function

function WriteToFile(Document, FileName)
     dim objFileSys, strTimeNow

     if FileName = "" then
            FileName = "c:\TutorialFiles\Buyer\POReq*.xml"
     end if

'Generate a Unique Number used to generate unique files using a mask
   strTimeNow = left(Replace(CStr(FormatDateTime(Now(), 3)),":",""), 6)

'Create File System Object
     Set objFileSys = CreateObject("Scripting.FileSystemObject")

'Create the Specified file, write the document data and close
     Set filestream = objFileSys.CreateTextFile(Replace(FileName, "*", strTimeNow), False)
     filestream.writeline Document
      filestream.close
end function

]]>
</script>

</component>
  3. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [名前を付けて保存] ダイアログ ボックスが表示されます。

  4. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab に移動します。

  5. [ファイル名] ボックスに「PORequestApproval.wsc」と入力します。

  6. [ファイルの種類] ボックスの一覧で [すべてのファイル] をクリックし、[保存] をクリックします。

  7. [メモ帳] を閉じます。

  8. \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab に移動します。

  9. [PORequestApproval.wsc] を右クリックし、[登録] をクリックします。

このコンポーネントは、モジュール 1 で使用された、構成済みの WSC と置き換えることができます。このコンポーネントを使用するには、スケジュールから既存の WSC バインドを削除し、このコンポーネントをポイントする新しい WSC バインドを作成します。

「WSC コンポーネントの削除」に進みます。


WSC コンポーネントの削除

ここでは、XLANG スケジュール フローチャート Buyer2 から WSC コンポーネントを削除します。前に作成したコンポーネントは再度バインドできます。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk オーケストレーション デザイナ] をクリックします。

  2. モジュール 4 で作成したフローチャートを使用する場合は、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab に保存した Buyer2.skv を開きます。

    作成済みの Buyer2 フローチャートを使用する場合は、\Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution にある Buyer2.skv を開きます。

  3. スクリプト コンポーネント シェイプをクリックし、Delete キーを押します。

  4. [データ] タブをクリックします。

  5. [SendApproval]、[SendDenial]、および [WritetoFile] メッセージをそれぞれ削除します。

これで、スケジュールに WSC コンポーネントを使用する準備ができました。次の操作を行います。

  1. WSC コンポーネントを使用して、Buyer2.skv にポートを実装します。

    詳細については、「スクリプト コンポーネントを使用したポートの実装」を参照してください。ただし、この手順のコンポーネントではなく、自分で作成したコンポーネントを使用します。

  2. ポート実装のメソッド通信を定義します。

    詳細については、「スクリプト コンポーネントのメッセージのプロパティの定義」を参照してください。

  3. ポートのデータ フローを定義します。

    詳細については、「データ フローの定義」を参照してください。

  4. XLANG ファイルを保存します。

    詳細については、「XLANG スケジュール フローチャートの保存」を参照してください。

  5. コンポーネントのテストをするには、BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution にある ExecuteTutorial アプリケーションを実行します。

「アプリケーション統合コンポーネント (AIC) の作成」に進みます。


アプリケーション統合コンポーネント (AIC) の作成

ここでは、MSXML DOM を使用して注文ドキュメントを請求ドキュメントに変換するアプリケーション統合コンポーネント POtoINVAIC を新規に作成します。

「AIC の ActiveX DLL プロジェクトの作成」に進みます。


AIC の ActiveX DLL プロジェクトの作成

  1. Microsoft Visual Basic 6.0 を起動します。

  2. [新しいプロジェクト] ダイアログ ボックスで [新規作成] タブをクリックし、[ActiveX DLL] をクリックします。次に [開く] をクリックします。

    使用しているコンポーネントのプロジェクト Project 1 が作成されます。

  3. プロジェクトおよびコントロールの名前をより理解しやすいものに変更するには、プロジェクト ツリー ウィンドウで [Project1] をクリックします。プロパティのウィンドウで "(オブジェクト名)" プロパティを [POtoInvAICLab] に変更します。

  4. プロジェクト ツリー ウィンドウで、[Class1(Class1)] をクリックします。プロパティのダイアログ ボックスで "(オブジェクト名)" プロパティを [ConvertPOtoInvoice] に変更します。

「AIC に必要な参照の追加」に進みます。


AIC に必要な参照の追加

ここでは、BizTalk Server 2002 に必要な多くのインターフェイスをコンポーネントに実装します。

  1. [プロジェクト] メニューの [参照設定] をクリックします。

  2. [Microsoft BizTalk Server Application Interface Components 1.0 Type Library] を選択します。

    このタイプ ライブラリの完全なパスは、\Program Files\Microsoft BizTalk Server\btscomplib.tlb です。

  3. [Microsoft BizTalk Server Interchange 1.0 Type Library] を選択します。

    このタイプ ライブラリの完全なパスは、\Program Files\Microsoft BizTalk Server\cisapi.tlb です。

  4. [Microsoft Scripting Runtime] を選択します。

    この DLL の完全なパスは、\WINNT\System32\Scrrun.dll です。このライブラリを使用して、ファイル システム オブジェクトを作成し、注文をディスクに書き込むために使用するテキスト ストリームを開きます。

  5. [Microsoft XML, v 3.0] を選択します。

    この DLL の完全なパスは、\WINNT\System32\msxml3.dll です。

  6. [OK] をクリックします。

「必要なインターフェイスの実装」に進みます。


必要なインターフェイスの実装

BizTalk Server にコンポーネントを AIC として認識させるには、2 つのインターフェイスのいずれか 1 つを実装します。このチュートリアルでの目標を達成するには、IBTSAppIntegration インターフェイスを実装します。

  1. プロジェクト ウィンドウで、[ConvertPOtoInvoice] クラス モジュールをクリックします。

  2. [表示] メニューの [コード] をクリックします。

  3. 次のコード行をコードの先頭に追加して、すべての変数に対して、明示的な宣言を強制するようにします。
    Option Explicit
  4. Option Explicit 文の後に次のコード行を追加して、必要なインターフェイスを実装します。
    Implements IBTSAppIntegration

「クラス オブジェクトの定義および初期化」に進みます。


クラス オブジェクトの定義および初期化

ここでは、コードを追加して、DOM を使用して XML ファイルを作成する MSXML クラス オブジェクトを定義します。注文を請求書に変換するプロジェクト スタイル シートをポイントする文字列変数を作成します。

  1. 次のコードを Implements IBTSAppIntegration 文の下に配置します。
    'Class Object Defines
Private m_DOMCommonPO As MSXML2.DOMDocument
Private m_DOMStylesheet As MSXML2.DOMDocument
Private m_objSubmit As BTSInterchangeLib.Interchange

'Embedded Project Stylesheet to Convert CommonPO to CommonInvoice
Private m_strStylesheet As String
  2. 次のコードを追加します。このコードは、注文を請求書に変換する XML DOM オブジェクトと、BizTalk Server に最終請求ドキュメントを送信する Interchange オブジェクトを初期化します。
    Private Sub Class_Initialize()
'Create DOM/Interchange Objects
    Set m_DOMCommonPO = New MSXML2.DOMDocument
    Set m_DOMStylesheet = New MSXML2.DOMDocument
    Set m_objSubmit = New BTSInterchangeLib.Interchange

'Configure DOM Objects to be Synchronous
    m_DOMCommonPO.async = False
    m_DOMStylesheet.async = False

'Fill Stylesheet Embedded String
    m_strStylesheet = m_strStylesheet + ""

End Sub

「インターフェイス メソッドの実装」に進みます。


インターフェイス メソッドの実装

IBTSAppIntegration インターフェイスの ProcessMessage メソッドは、BizTalk Server から送信された受信 XML 共通注文ドキュメントのデータを、XML 共通請求ドキュメントに変換します。この共通請求ドキュメントは、BizTalk Server に返送されます。この目的は、注文を受信するバック エンド システムをシミュレートし、最終的にその注文の請求書を戻すことです。

  1. 関数定義および次元変数を追加します。次のコードを参照してください。
    Private Function IBTSAppIntegration_ProcessMessage( _
                                ByVal bstrDocument As String) As String
    Dim bstrInvoiceDocument As String
    Dim objScripting As New Scripting.FileSystemObject
'Initialize ProcessMessage to null
    IBTSAppIntegration_ProcessMessage = ""
  2. 受信したデータを DOM オブジェクトに読み込み、そのデータの書式が正しいかどうかを検証するコードを追加します。これを行うには、IBTSAppIntegration_ProcessMessage の下に次のコードを追加します。
        m_DOMCommonPO.loadXML bstrDocument

    If m_DOMCommonPO.parseError.errorCode <> 0 Then 'The data was not valid XML
'Raised errors are not caught in the component, and will be sent back to BizTalk Server
        Err.Raise m_DOMCommonPO.parseError.errorCode, "AICSample.ConvertPOToInvoice Component", _
            "The provided document was not valid XML and could not be processed because:" + _
            vbCrLf + vbCrLf + m_DOMCommonPO.parseError.reason + vbCrLf + " on line: " + _
            CStr(m_DOMCommonPO.parseError.Line) + vbCrLf + "at position: " + _
            CStr(m_DOMCommonPO.parseError.linepos)
    End If
  3. 注文を請求書に変換する XSL コードが含まれるリソース ファイルを使用するコードを追加します。これを行うには、End If 文の下に次のコードを追加します。
        If m_strStylesheet = "" Then
        m_strStylesheet = StrConv(LoadResData(101, "CUSTOM"), vbUnicode)

    End If
    m_DOMStylesheet.loadXML m_strStylesheet
    bstrInvoiceDocument = m_DOMCommonPO.transformNode(m_DOMStylesheet)

    If bstrInvoiceDocument = "" Then ' Mapping Failed Raise an Error
        Err.Raise vbObjectError + 100, "AICSample.ConvertPOToInvoice Component", _
            "The provided CommonPO document could not be translated into a Common Invoice " + _
            "as the map produced blank output."
    End If
  4. 請求ドキュメントを BizTalk メッセージ サービスに送信するコードを追加します。これを行うには、End If 文の下に次のコードを追加します。
    IBTSAppIntegration_ProcessMessage = m_objSubmit.Submit(BIZTALK_OPENNESS_TYPE_NOTOPEN, bstrInvoiceDocument, , , "Contoso on Seller", , "Northwind Traders on Seller")

End Function

    送信呼び出しによって送信 ID が返されます。ただし、この場合、送信 ID は使用されません。

「クラス オブジェクトの終了」に進みます。


クラス オブジェクトの終了

クラスが終了したときにすべてのオブジェクトがメモリから解放されるようにするには、次のコードをプロジェクトの最後に追加します。

Private Sub Class_Terminate()
    Set m_DOMCommonPO = Nothing
    Set m_DOMStylesheet = Nothing
    Set m_objSubmit = Nothing
End Sub

「リソース ファイルの作成」に進みます。


リソース ファイルの作成

ここでは、注文を請求書に変換するための XSL を含むリソース ファイルを追加します。

  1. [アドイン] メニューをクリックし、[アドイン マネージャ] をクリックします。

    [アドイン マネージャ] ダイアログ ボックスが表示されます。

  2. [VB6 リソース エディタ] をクリックします。

  3. [ロード方法] で、[ロード/アンロード] をクリックしてリソース エディタをロードし、[起動時にロード] をクリックします。次に [OK] をクリックします。

  4. [ツール] メニューの [リソース エディタ] をクリックします。

  5. ツール バーの [カスタム リソースの追加] をクリックします。

    [カスタム リソースを開く] ダイアログ ボックスが表示されます。

  6. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動し、POtoINVAIC.txt をクリックし、次に [開く] をクリックします。

    注意

    • リソースの ID は 101 です。既定では、作成した最初のリソースの ID が 101 になります。ただし、この番号は、リソースを変更すると 1 ずつ増加します。リソース ID を 101 に変更するには、リソース ID を右クリックし、[プロパティ] をクリックします。[ID] ボックスに「101」と入力します。次に [OK] をクリックします。
  7. ツール バーの [上書き保存] をクリックします。

    [リソース ファイルを名前を付けて保存] ダイアログ ボックスが表示されます。

  8. \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動します。

  9. [ファイル名] ボックスに「POtoInvAICLab.RES」と入力し、[保存] をクリックします。

  10. リソース エディタを閉じます。

「コンポーネントの組み込みおよびバイナリ互換性の設定」に進みます。


コンポーネントの組み込みおよびバイナリ互換性の設定

新しいコンポーネントの作成中であるため、この時点でこのコンポーネントを組み込み、さらに新しく作成した DLL とのバイナリ互換性が得られるようにプロジェクトのプロパティを設定する必要があります。バイナリ互換性があると、DLL をコンパイルするたびに、新しいグローバル一意識別子 (GUID) を生成する必要がなくなります。

  1. [ファイル] メニューの [名前を付けてプロジェクトの保存] をクリックします。

    [名前を付けてファイルの保存] ダイアログ ボックスが表示されます。

  2. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動します。

  3. [ファイル名] ボックスに「ConvertPOtoInvoice.cls」と入力し、[保存] をクリックします。

    [名前を付けてプロジェクトの保存] ダイアログ ボックスが表示されます。

  4. \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動します。

  5. [ファイル名] ボックスに「POToInvAICLab」と入力し、[保存] をクリックします。

  6. [ファイル] メニューの [POToInvAICLab.dll の作成] をクリックします。

    [実行可能ファイルの作成] ダイアログ ボックスが表示されます。

  7. \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動し、[OK] をクリックします。

  8. [プロジェクト] メニューの [POToInvAICLab のプロパティ] をクリックします。

  9. [コンポーネント] タブをクリックします。

  10. [バイナリ互換] をクリックします。

  11. 参照ボタン (...) をクリックし、\Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab に移動します。

  12. POToInvAICLab.dll をクリックし、[開く] をクリックします。

  13. [OK] をクリックします。

「AIC の登録」に進みます。


AIC の登録

ここでは、AIC を登録して、BizTalk Server が認識できるようにします。BizTalk Server は、登録された COM コンポーネントの一覧を参照し、これらのコンポーネントに対してクエリを実行して、IBTSAppIntegration インターフェイスまたは IPipelineComponent インターフェイスのいずれかを実装するコンポーネントを決定します。この基準を満たすコンポーネントはすべて BizTalk メッセージ マネージャのコンポーネントの一覧に表示されます。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [管理ツール] をダブルクリックします。

  3. [コンポーネント サービス] をダブルクリックします。

    [コンポーネント サービス] コンソールが表示されます。

  4. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] をクリックします。

  5. [COM+ アプリケーション] を右クリックして [新規作成] をポイントし、[アプリケーション] をクリックします。

    [COM アプリケーション インストール ウィザード] が表示されます。

  6. [COM アプリケーション インストール ウィザードへようこそ] ページで、[次へ] をクリックします。

  7. [新しいアプリケーションのインストールまたは作成] ページで、[空のアプリケーションを作成する] をクリックします。

  8. [新しいアプリケーション名の入力] ボックスに「POToInvAICLab」と入力します。

  9. [アクティブ化の種類]で [サーバー アプリケーション] をクリックし、[次へ] をクリックします。

  10. [アカウント] で [対話ユーザー - 現在ログオンしているユーザー] をクリックし、[次へ] をクリックします。

  11. [完了] をクリックします。

  12. コンソール ツリーで [COM+ アプリケーション] を展開し、作成済みの新しいパッケージ POToInvAICLab を展開します。

  13. [コンポーネント] をクリックします。

  14. エクスプローラで BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab を参照します。

  15. POToInvAICLab.dll を [コンポーネント サービス] の [コンポーネント] フォルダにドラッグします。

  16. [コンポーネント サービス] を閉じます。

これで、新しい AIC を使用するポートを再構成する準備ができました。次の手順に従って構成します。

注

  • 現在のログオン ユーザーは、BizTalk Server Administrators グループのメンバである必要があります。また、このシナリオの実行中はログオンしたままでいてください。
  1. BizTalk メッセージ マネージャを開きます。

  2. [検索] 領域で [メッセージ ポート] をクリックし、[検索] をクリックします。

  3. [メッセージ ポート名] ボックスの一覧で、[Port to Contoso via AIC] をダブルクリックします。

  4. [全般情報] ページで、[次へ] をクリックします。

  5. [送信先組織] ページの [プライマリ トランスポート] で、[参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  6. [参照] をクリックします。

  7. [利用可能なコンポーネント] ボックスの一覧で [POToInvAICLab ConvertPOtoInvoice] をクリックし、[OK] をクリックします。

  8. [OK] をクリックして [プライマリ トランスポート] ダイアログ ボックスを閉じ、[完了] をクリックします。

  9. BizTalk Server をインストールしたドライブの \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution に保存された ExcecuteTutorial アプリケーションを実行して、コンポーネントのテストをします。


BizTalk Server 2002 の理解

Microsoft® BizTalk™ Server 2002 を使用すると、ビジネス パートナーとのさまざまなドキュメントの交換や、社内ビジネス プロセスとアプリケーションの統合を容易に行うことができます。このレッスンでは、そのしくみについて解説します。

このレッスンでは、BizTalk Server に関する基本的な概念と共に、BizTalk Server でソリューションを構築するために必要なツールとプロセスについて説明します。

注

  • BizTalk Server のプロセスを構成する方法についてのステップごとのチュートリアルは、「BizTalk Server 2002 チュートリアル」を参照してください。「BizTalk Server 2002 チュートリアル」では、BizTalk エディタ、BizTalk マッパー、BizTalk メッセージ マネージャ、BizTalk Server 管理コンソール、およびBizTalk オーケストレーション デザイナを使用して、企業間自動調達プロセスを実行する方法について説明しています。BizTalk Server の概要については、「Microsoft BizTalk Server 2002 について」を参照してください。

要件

このチュートリアルを使用するためには、BizTalk Server およびそのすべてのコンポーネントを C ドライブにインストールする必要があります。これらのファイルを他のドライブおよびディレクトリから実行することもできますが、そのためには、ソース ファイルに対して大幅な変更を加える必要があります。

このチュートリアルを実行する前に、LearnBizTalk ディレクトリも C ドライブにコピーする必要があります。

  1. \Program Files\Microsoft BizTalk Server\SDK\LearnBizTalk ディレクトリを C:\LearnBizTalk にコピーします。

  2. C:\LearnBizTalk\Documents に移動します。

  3. CTRL キーを押しながら、ReqToApprove.xml と ReqToDecline.xml をクリックします。

  4. 上記で選択したファイルを右クリックし、[プロパティ] をクリックします。

  5. [全般] タブの [属性] にある [読み取り専用] チェック ボックスをオフにします。

  6. [OK] をクリックします。

重要

  • C:\LearnBizTalk\Scripts ディレクトリにはいくつかのスクリプトがあります。これらのスクリプトを実行するには、スクリプト ファイルをダブルクリックします。これらのスクリプトは、レッスンを進めていく上で便利なように BizTalk Server の構成を変更します。これらのスクリプトの実行には数分かかることがあります。各スクリプトが完了すると、メッセージ ボックスが表示されます。

  • チュートリアルが終了したら、CleanUp.vbs スクリプトを実行してすべての変更を削除することができます。

内容

  • レッスン 1: BizTalk Server の概要

  • レッスン 2: BizTalk メッセージ サービスの構成

  • レッスン 3: BizTalk オーケストレーション サービスの設計

  • レッスン 4: 実装について

  • レッスン 5: BizTalk マッパーの使用

  • レッスン 6: ドキュメントの送受信

  • レッスン 7: トランザクションの実行


レッスン 1: BizTalk Server の概要

このレッスンでは、BizTalk Server の概要と、以降のレッスンを通して使用するシナリオについて説明します。

このレッスンには次のトピックが含まれます。

  • BizTalk Server とは何か

  • BizTalk Server を使用する理由

  • XML を使用する理由

  • ソリューションの統合

  • BizTalk Server のインストール

  • シナリオ

  • シナリオの実行


BizTalk Server とは何か

Microsoft BizTalk Server 2002 は、企業内、あるいは企業間におけるビジネス プロセスを連携するための開発および実行環境を提供します。BizTalk Server は、数週間あるいは数か月間継続するビジネス トランザクションも取り扱うことができます。

BizTalk Server 2002 は、ビジネス ドキュメントの仕様を定義する機能、アプリケーション間でドキュメントが交換される際の変換方法を定義する機能、およびサーバーの活動を監視して記録する機能をサポートします。

BizTalk Server 2002 は、インターネットを介してドキュメントを送受信したり、データの整合性、配信、およびセキュリティの保証といった豊富なサービスを提供する標準ゲートウェイとしても機能します。

「BizTalk Server を使用する理由」に進みます。


BizTalk Server を使用する理由

今日のビジネス環境では、ソリューションの構築は、一般的に受け入れられているプロトコルとドキュメント形式に基づいたものでなければなりません。また、自社のソリューションが多様なビジネス パートナーやアプリケーションと統合できるか、インターネット上でセキュリティは確保されるか、またビジネス ニーズの増大とともに拡張可能かを把握しておくことも重要です。Microsoft BizTalk Server 2002 は、これらの問題に答えるように設計されています。

今日のグローバル マーケットでは、1 日 24 時間、週 7 日、システムが効率的に稼動することが要求されています。顧客の要求もより高度化し、リアルタイムで情報を得られることを望んでいます。その結果、ビジネスの速度は加速し、よりすばやい意思決定が必要になっています。加えて、ビジネスにおける関係はいっそうダイナミックになってきており、新規の顧客や取引先はすばやい対応を求めてきます。

また、さまざまなプラットフォーム上の多数のアプリケーションをサポートしたり、インターネット、エクストラネット、企業間電子商取引、その他のリソースを通じてビジネス パートナーと統合する必要があります。既存の IT 資産も維持する必要があり、そのためにはレガシー システムおよび X12 や EDIFACT などの 電子データ交換 (EDI) ネットワークをサポートしていくことも必要です。そしておそらく最も重要なこととして、今日の市場で効率的に競争していくには、オープンなインターネット標準およびテクノロジを利用して最大の相互運用性を保証する新しいソリューションをすばやく構築する必要があるのです。詳細については、「標準のサポート」を参照してください。

BizTalk Server は、ビジネス ドキュメントのデータおよび構造の定義のために XML を内部的に使用し、またドキュメントを宛先へ配信するために Hypertext Transfer Protocol (HTTP) や Simple Mail Transfer Protocol (SMTP) などの標準インターネット プロトコルを使用します。そのため、いかなる環境で稼動しているアプリケーションであっても、そのアプリケーションがインターネット標準をサポートする限り、相互運用を実現できます。BizTalk Server に対しては、ドキュメントを Extensible Markup Language (XML)、EDI、またはフラット ファイルとして送信することができます。

「XML を使用する理由」に進みます。


XML を使用する理由

片方のみが使用している技術に依存せずにドキュメントを交換するためには、そのドキュメントを記述する「共通語」を選択する必要があります。Extensible Markup Language (XML) がこの共通語として利用されるようになってきています。

XML は、共通の情報形式を作成し、Web 上でその形式とデータを共有するための柔軟な方法です。XML で記述されたドキュメントは、任意のテキスト エディタを使って表示および編集でき、また一般的に理解も容易です。次の例では、Northwind Traders 社が Contoso 社にモニタを 2 台発注しようとしています。XML 形式で表された Northwind Traders 社内の注文要求を見てみましょう。

<NorthwindReq>
<Header reqNumber="IL0829" reqStatus="New" dateCreated="2000-10-24"/>
<Shipping
name="Brian H. Valentine"
addr1="1234 Main Street"
city="Anytown"
state="AL"
zip="12345"
country="USA"
phone="(555)555-0123" />
<Items count="2">
<Item partNo="270FS" description="27-inch flat screen monitor" qty="2" />
</Items>
</NorthwindReq>

このドキュメントは、スキーマという定義済みの形式に従っています。スキーマは、ほかの XML ドキュメントの形式を記述する XML ドキュメントです。ほかの XML ドキュメントとは異なり、スキーマはデータを含みません。スキーマは、対応する XML ドキュメントに現れるドキュメント要素の形式規則だけを含みます。

XML は、World Wide Web Consortium (W3C) による正式な標準化手続きを経ています。XML は現在、W3C が指定する最高レベルである「W3C 勧告」に指定されています。XML の勧告の詳細については、World Wide Web Consortium の Web サイトにある Extensible Markup Language (XML) のページ (www.w3.org/XML) を参照してください。

また、Microsoft BizTalk Server 2002 は XML-Data Reduced (XDR) と呼ばれる形式を使用してドキュメントを定義します。これは、W3C の XML スキーマに関する作業に基づく機能的なサブセットであり、XML スキーマの多くの利点を備えています。XML スキーマは最近になって「W3C 勧告」のレベルに到達しました。BizTalk Server の将来のバージョンでは XML スキーマをサポートし、既存の XDR にはスムーズな移行手段を提供する予定です。XML スキーマの詳細につていは、World Wide Web Consortium の Web サイト にある XML スキーマのページ (www.w3.org/XML/Schema) を参照してください。

「ソリューションの統合」に進みます。


ソリューションの統合

Microsoft BizTalk Server は、あらゆるドキュメント交換における 2 つの主要な側面であるメッセージ交換とオーケストレーションに対処します。

BizTalk メッセージ サービスは、ビジネス ドキュメントを安全かつ確実に送信する機能を提供します。このようなドキュメントの例として、サプライヤに送られる注文書や、ある製品の中での最低価格を採用するために複数のサプライヤに送られる見積依頼書などがあります。

BizTalk オーケストレーション サービスを使用することで、メッセージの作成に使用されるビジネス プロセスを定義し、高度に統合されたグラフィック環境を使用してビジネス プロセスを実装することができます。BizTalk オーケストレーション サービスを使って定義されたプロセスは、ビジネスに変化が生じても容易に修正が可能であり、ビジネスの変化に迅速に対応することができるという重要な特徴を持っています。

ほとんどのビジネス プロセスには、ドキュメントの送受信やそのプロセスに対するビジネス ルールの適用が伴います。そのため、BizTalk メッセージ サービスと BizTalk オーケストレーション サービスは連携して機能するように設計されており、統合されたソリューションの構築が可能になっています。

「BizTalk Server のインストール」に進みます。


BizTalk Server のインストール

以降のレッスンでは、Northwind Traders 社が Contoso 社からコンピュータ部品を購入するというサンプル シナリオに沿っていきます。プロセスの各ステップで何が発生するかを説明するとともに、BizTalk エディタを使用して XML でビジネス ドキュメントの形式を定義する方法や、BizTalk オーケストレーション デザイナを使用して内部ビジネス プロセスを記述する方法、およびそれらをお互いに結びつける方法について紹介します。BizTalk Server の統合に固有のコーディングはありませんが、ビジネスに固有のルールを作成する必要はあります。ただしこのレッスンでは、必要なコーディングは最小限にとどめられています。

このレッスンの中の例は、1 台のコンピュータにインストールして実行するように設計されていますが、同一のシナリオを 2 台以上のサーバーで構成することも可能です。

Microsoft BizTalk Server 2002 をインストールする前に、Readme.htm および Installation Guide.htm を必ず読み、以下の前提条件に従ってください。

  • Microsoft® Windows® 2000 と Service Pack 2 以降がインストールされたコンピュータが必要です (Windows 2000 Professional または Windows 2000 Server のいずれでも動作します)。Windows 2000 とともにインターネット インフォメーション サービス (IIS) および メッセージ キュー サービスがインストールされている必要があります。また、このコンピュータの管理者権限を持つアカウントが必要です。

  • SQL Server 7.0 と Service Pack 3、または SQL Server 2000 と Service Pack 1 が必要です。SQL Server を Windows 認証に構成する必要があります。

  • BizTalk Server をインストールするコンピュータには、Microsoft Visio® 2002 もインストールする必要があります。

  • [管理ツール] の [インターネット サービス マネージャ] で、[既定の Web サイトのプロパティ] ダイアログ ボックスの [Server Extensions] タブにある [作成を有効にする] チェック ボックスをオフにしておく必要があります。詳細については、「BizTalk Server 2002 用の IIS 設定の構成」 を参照してください。

  • レッスンでスクリプトを実行するためには、Windows 2000 のメッセージ キュー サービス コンポーネントをインストールしておく必要があります。

インストール処理の詳細については、「BizTalk Server 2002 のインストール」を参照してください。

「シナリオ」に進みます。


シナリオ

コンピュータ ハードウェアの小売り業者である Northwind Traders 社は、サプライヤの 1 つである Contoso 社にコンピュータ部品を発注しようとしています。Northwind Traders 社内の調達アプリケーションは、「XML を使用する理由」 で示したような注文要求を作成し、それをハード ディスクにファイルとして書き込みます。Microsoft BizTalk Server 2002 は、このファイルが置かれる場所を監視し、注文要求を検出するとこのファイルを Northwind Traders 自動発注承認プロセスに送ります。注文要求が却下された場合は、その情報が付加されてハード ディスクにファイルとして書き込まれます。承認された場合は、注文書が作成され、HTTP プロトコルを使って Contoso 社に送信されます。このシナリオでは、1,000 ドルを超えない注文要求は常に承認され、超える場合は却下されるものとします。

このシナリオでは、両社とも BizTalk Server を使用しています。BizTalk Server を実行しているサーバー同士の連携は容易ですが、BizTalk Server を使用していない企業との間でも、BizTalk Server を利用して連携することができます。

Contoso 社側の BizTalk Server が注文書を受信すると (このシナリオでは BizTalk Server の同一インスタンスを使用して両社のタスクを実行します)、その注文書を Contoso 社内のビジネス プロセスに送ります。そこで請求書が作成され、再び HTTP プロトコルを使用して Northwind Traders 社に配信されます。最後に、Northwind Traders 社側の BizTalk Server がその請求書を受け取り、それをハード ディスクにファイルとして書き込みます。

次の図は、上位レベルから見たこのプロセスの流れを示しています。

「BizTalk Server の理解」チュートリアルのプロセス概要

「シナリオの実行」に進みます。


シナリオの実行

重要

  • このチュートリアルを実行するためには、LearnBizTalk ディレクトリを C ドライブにコピーし、BizTalk Server のすべてのコンポーネントを C ドライブにインストールする必要があります。これらのファイルを他のドライブおよびディレクトリから実行することもできますが、そのためには、ソース ファイルに対して大幅な変更を加える必要があります。これらの要件の詳細については、「BizTalk Server 2002 の理解」を参照してください。

このチュートリアル用に BizTalk Server を構成するには、次の手順を実行します。

  1. C:\LearnBizTalk\Scripts に移動し、Setup.vbs をダブルクリックします。

    このスクリプト ファイルは、このレッスンでの使用のために BizTalk Server を構成します。ユーザーのサーバー環境によっては、スクリプトの完了に数分かかる場合があります。完了すると、メッセージ ボックスが表示されます。

  2. C:\LearnBizTalk\Documents に移動し、ReqToApprove.xml と ReqToDecline.xml をダブルクリックし、Microsoft Internet Explorer でそれぞれのファイルを開きます。

    reqStatus フィールドの設定が "New" になっていることを確認し、各ドキュメント内の totalPrice および reqNumber フィールドの値をメモしておきます。

BizTalk Server がドキュメントを処理する様子を見るには、次の手順を実行します。

  1. ファイル ReqToDecline.xml を C:\LearnBizTalk\Documents ディレクトリから C:\LearnBizTalk\Pickup ディレクトリにコピーします。

    注

    • ファイルを移動しないようにしてください。このファイルは BizTalk Server によって処理され \Pickup ディレクトリから削除されます。この注文要求の発注総額は 1,000 ドルを超えるため却下され、メッセージ ボックスが表示されます。
  2. ファイル ReqToApprove.xml を C:\LearnBizTalk\Documents ディレクトリから C:\LearnBizTalk\Pickup ディレクトリにコピーします。

    今度は注文要求が承認されます。そして、注文書が作成されて Contoso 社に送信されます。注文書が処理されて請求書が作成され、Northwind Traders 社に返信されます。最後に請求書が Northwind Traders 社で受信され、C:\LearnBizTalk\Output ディレクトリにファイルとして書き込まれます。

  3. \Output ディレクトリで ContosoInvoice.xml ファイルをダブルクリックし、Internet Explorer で開きます。

    referenceNumber フィールドの値が、元の reqNumber フィールドと同じになっています。

続くレッスンでは、このプロセスの各ステップをより詳しく見ていきます。また、必要な作業をすべて実行できるように BizTalk Server を構成する方法についても解説します。

「レッスン 2: BizTalk メッセージ サービスの構成」に進みます。


レッスン 2: BizTalk メッセージ サービスの構成

このレッスンでは、レッスン 1 で設定したシナリオのそれぞれのステップを検討します。ここからのレッスンでは、追加となるスクリプト ファイルを実行します。これらのスクリプトは、初めに設定した Microsoft BizTalk Server 2002 の構成に調整を加えます。それによって、レッスン 1 で示したプロセス全体ではなく、個々のステップの結果を見ることができます。

このレッスンには次のトピックが含まれます。

  • BizTalk メッセージ サービスの構成

  • ファイル受信機能の構成

  • メッセージ ポートとチャネルの構成

  • ドキュメント仕様の定義

  • シナリオの実行


BizTalk メッセージ サービスの構成

BizTalk メッセージ サービスは、社内アプリケーション間および外部のビジネス パートナーとの間でドキュメントを送受信する手段を提供します。BizTalk メッセージ サービスによって、ドキュメントの受信、処理、および宛先への配信方法を定義することができます。また、ドキュメント構造の検証、デジタル署名、暗号化、および転送の信頼性が低い場合の配信の保証といった重要な機能を提供します。

スクリプト ファイル L2Prep.vbs は BizTalk メッセージ サービスの構成を変更します。これによって、ドキュメントが BizTalk オーケストレーション サービスへ配信されるのではなく、ファイルとして作成されるようになり、このファイルの内容を確かめることができるようになります。

このスクリプトを実行するには

  • C:\LearnBizTalk\Scripts に移動し、L2Prep.VBS をダブルクリックします。

次の図は、ドキュメントがどのように処理されるかを示しています。

「ファイル受信機能の構成」に進みます。


ファイル受信機能の構成

ファイル受信機能によって、社内のアプリケーションによって作成されたファイルを BizTalk メッセージ サービスで使用できるようになります。出力ファイルによってデータの交換を行う利点の 1 つは、このファイルを作成する社内業務アプリケーションが BizTalk Server と通信する必要がないという点です。社内業務アプリケーションは、ドキュメントを含むファイルを作成し、それを BizTalk Server が監視している特定の場所に出力します。そして、BizTalk Server はそのファイルを取り出します。既存アプリケーションが出力ファイルを作成し、入力ファイルを受信できる場合は、そのアプリケーションを BizTalk Server とともに使用するにあたって、一切変更を行う必要がありません。

ファイル受信機能を使用するもう 1 つの重要な点は、非同期処理です。非同期とは 「同時ではない」 という意味で、ここでは相互に独立して実行される複数のプロセスにあてはまります。非同期処理は分散環境では重要な意味を持ちます。なぜならば、ソリューション内の各部分が独立的に機能し、障害や定期保守によってソリューションのほかの部分が一時的に使用不能になっても影響が及ばないためです。

たとえば、短時間のネットワーク障害が発生しても、社内業務アプリケーションで作成されたドキュメントはハード ディスクに蓄積されていくだけなので、アプリケーション全体としては影響を受けません。ネットワークが復旧すると、BizTalk Server は指定されたディレクトリ内にある全ファイルを取り出して処理します。また、1 台のサーバーで十分に処理できないほど大量のドキュメントが生成される場合には、BizTalk Server を追加し、同一ディレクトリのドキュメントを処理するように構成することができます。

ファイル受信機能がどのように構成されているかを確認するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

  2. [Microsoft BizTalk Server 2002] を展開し、BizTalk Server グループを展開します。次に [受信機能] を展開し、[ReceiveReq] を右クリックし、[プロパティ] をクリックします。

    [ReceiveReqのプロパティ] ダイアログ ボックスが表示されます。

  3. [全般] タブを参照した後、[サービス] タブをクリックします。

    次の図は、[サービス] タブの内容を示しています。この図は、機能がファイル受信機能として構成されており、ファイルのポーリングを行うディレクトリ、および取り出すファイルの種類が指定されていることを示しています。

    [ReceiveReqのプロパティ] ダイアログ ボックス

    [詳細設定] タブで、BizTalk Server が検出したファイルの配信先を指定します。ここでは、受信機能によるドキュメントの送信先として Channel To Approval という名前のチャネルを指定しています。チャネル、およびそれに関連するメッセージ ポートについては、次のセクションで説明します。詳細については、「受信機能の詳細プロパティについて」を参照してください。

  4. [ReceiveReqのプロパティ] ダイアログ ボックスを閉じます。

  5. BizTalk Server 管理コンソールを閉じます。

注

  • ドキュメントを BizTalk Server に送信する方法は、ファイル受信機能だけではありません。メッセージ キュー、電子メール (SMTP)、Web ページ (HTTP/HTTPS)、そしてユーザー アプリケーションのコンポーネント オブジェクト モデル (COM) からもドキュメントを受信することができます。詳細については、「利用可能な受信機能」を参照してください。

「メッセージ ポートとチャネルの構成」に進みます。


メッセージ ポートとチャネルの構成

ドキュメントを宛先に送信するためには、BizTalk メッセージ サービスで宛先を定義する必要があります。宛先は、BizTalk メッセージ サービスではメッセージ ポートと呼ばれます。メッセージ ポートの一連のプロパティでは、ドキュメントのセキュリティや宛先 (社内アプリケーションまたは外部ビジネス パートナー) への送信方法を指定することができます。

注

  • 複数のメッセージ ポートを同報リストとしてグループ化し、同一ドキュメントを複数の宛先 (ビジネス パートナーあるいは社内アプリケーションのいずれも可) に送信することができます。

セットアップ スクリプトを実行したときに定義したメッセージ ポートには、Req Approval Port という名前が付いています。これは、Northwind Traders 社内の注文要求の承認に関するビジネス プロセスに相当する内部アプリケーションへのメッセージ ポートです。

メッセージ ポートのプロパティを表示するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。[BizTalk メッセージ マネージャ] ダイアログ ボックスが表示された場合は [キャンセル] をクリックします。

  2. [メッセージ ポート] をクリックし、[検索] をクリックします。

  3. 右側のペインで [Req Approval Port] をダブルクリックします。

    [メッセージ ポートのプロパティ] ページが表示されます。

  4. [次へ] をクリックします。

    [送信先組織] ページが表示されます。

    次の図の [送信先組織] ページでは、このドキュメントがファイルに送信されることを示しています。

    メッセージ ポート プロパティ ウィザードの [送信先組織] ページ

レッスン 1 では、このメッセージ ポートのメッセージの送信先は、承認プロセスを実施する BizTalk オーケストレーション サービスの XLANG スケジュールでした。(BizTalk オーケストレーション サービスは次のレッスンで詳しく説明します。) このレッスンの開始時にスクリプトを実行してこれを変更したため、現在は出力を見ることができるようになっています。

ドキュメントを BizTalk オーケストレーション サービスまたはファイルに送信する以外にも、HTTP/HTTPS、SMTP、メッセージ キュー、およびカスタムのアプリケーション統合コンポーネント (AIC) などのサポートされているプロトコルを用いてドキュメントを送信するようにメッセージ ポートを構成することができます。

また、ドキュメントの暗号化や、デジタル署名といったセキュリティ強化の機能を利用するようにメッセージ ポートを構成することもできます。

次に、このドキュメントが送信されるチャネルを定義します。チャネルの一連のプロパティでは、ドキュメントの送信元にあたる組織、またはアプリケーションを指定します。また、そのチャネルと関連付けられているメッセージ ポートにドキュメントが送られる前に BizTalk Server が実行する特定のステップを定義します。次の図は、受信機能、チャネル、およびメッセージ ポートの関係を示しています。

Northwind Traders 社の承認プロセスに注文要求を送信するチャネルの設定を確認するには、次の手順を実行します。

  1. BizTalk メッセージ マネージャが開かれていない場合は、それを開きます。

  2. [チャネル] をクリックし、[検索] をクリックします。

  3. 右側のペインで [Channel To Approval] をダブルクリックします。

    [チャネルのプロパティ] ページが表示されます。

  4. [次へ] をクリックします。

    注

    • 別の方法として、[Channel To Approval] を右クリックし、メニューより [メッセージ ポートまたは同報リストの検索] をクリックして Req To Approval を検索することができます。この方法ですべてのチャネルを表示することができます。ここでは、Channel To Approval だけが Req To Approval に接続されたチャネルということになります。

    次の図は、このチャネルで処理されるドキュメントが内部の購買アプリケーションで生成されることを示しています。このドキュメントの形式は、Northwind Req という名前のドキュメント定義によって記述されたものになります。

    チャネルのプロパティ ウィザードの [送信元アプリケーション] ページ

  5. [キャンセル] をクリックし、[チャネルのプロパティ] ページを閉じます。

  6. BizTalk メッセージ マネージャを閉じます。

注

  • ドキュメントをあるドキュメント定義から別のドキュメント定義に変換するようにチャネルに指示することができます。また、チャネルがドキュメントを配信するときにどの情報を追跡目的として記録するかを指定することもできます。レッスン 5 では、BizTalk マッパーによるドキュメント変換について詳しく説明します。

メッセージ ポートとチャネルの詳細については、「メッセージ ポートについて」および「チャネルについて」を参照してください。

次のトピックでは、ドキュメント定義とは何か、またそれを作成する方法について説明します。

「ドキュメント仕様の定義」に進みます。


ドキュメント仕様の定義

レッスン 1 では、企業間で交換するドキュメントの記述に同一の言語を使用することがどれほど重要かについて説明しました。この共通語となるのが XML です。XML ドキュメントはテキスト形式で格納され、任意のテキスト エディタで開くことができますが、それらを手動で作成、修正することは手間がかかり、間違いも発生しやすくなります。BizTalk Server には、この作業を簡易化する BizTalk エディタというツールを備えています。

NorthwindReq.xml ファイルを開くには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk エディタ] をクリックします。

  2. [ファイル] メニューの [開く] をクリックします。

  3. C:\LearnBizTalk\Documents に移動し、NorthwindReq.xml をクリックして、[開く] をクリックします。

    BizTalk エディタでファイルが開き、次の図のように表示されます。

    BizTalk エディタで開かれた NorthwindReq.xml

BizTalk エディタでは、ドキュメントの形式が視覚化され、個々の要素や属性のデータ型の定義や、データ フィールドの必須および省略可の定義などが容易に行うことができます。このドキュメント スキーマは XML ドキュメントですが、BizTalk エディタは電子データ交換 (EDI) スキーマもフラット ファイル スキーマも同じように扱います。

BizTalk エディタがインストールされているどのワークステーションでも、ドキュメント仕様を編集することができます。よって、仕様を作成した後、それを BizTalk Server WebDAV リポジトリに追加して、どの BizTalk Server からも取得できるようにするすることが必要です。

注

  • World Wide Web Distributed Authoring and Versioning (WebDAV) は、Web 上の共同オーサリングに関する Internet Engineering Task Force (IETF) 標準です。これは、相互に離れた複数のユーザー間で、インターネット上での共同編集およびファイル管理を可能にします。WebDAV の詳細については、IETF Web サイトの "HTTP Extensions for Distributed Authoring -- WEBDAV" ドキュメント (ietf.org/rfc/rfc2518.txt) を参照してください。

ドキュメント定義を作成するには、BizTalk エディタで作成され WebDAV に格納された特定の XML 仕様を、BizTalk Server が使用する名前に関連付ける必要があります。

ドキュメント定義を作成するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [BizTalk メッセージ マネージャ] ダイアログ ボックスが表示された場合は [キャンセル] をクリックします。

  3. [ファイル] メニューの [新規作成] をポイントし、[ドキュメント定義] をクリックします。

    [新しいドキュメント定義] ダイアログ ボックスが表示されます。

  4. [ドキュメント定義名] ボックスにドキュメント定義の名前を入力します。

  5. [ドキュメント仕様] チェック ボックスをオンにし、[参照] をクリックします。

    [WebDAV リポジトリからのドキュメント仕様の選択] ダイアログ ボックスが表示されます。

  6. [Microsoft] フォルダをダブルクリックし、使用するスキーマをクリックし、次に [開く] をクリックします。

    このダイアログ ボックスでは、BizTalk Server WebDAV リポジトリに格納されている任意のスキーマを選択することができます。

  7. [OK] をクリックして新しいドキュメント定義を保存します。

  8. BizTalk メッセージ マネージャを閉じます。

注

  • 同じスキーマ ドキュメントに基づく複数のドキュメント定義を作成することができます。必要に応じて、作成した各ドキュメント定義に対してグローバル ドキュメント追跡オプションを定義することも可能です。詳細については、「ドキュメント定義について」を参照してください。

「シナリオの実行」に進みます。


シナリオの実行

重要

  • このチュートリアルを実行するためには、LearnBizTalk ディレクトリを C ドライブにコピーし、BizTalk Server のすべてのコンポーネントを C ドライブにインストールする必要があります。これらのファイルを他のドライブおよびディレクトリから実行することもできますが、そのためには、ソース ファイルに対して大幅な変更を加える必要があります。これらの要件の詳細については、「BizTalk Server 2002 の理解」を参照してください。

シナリオを実行するには、次の手順を実行します。

  1. ファイル ReqToApprove.xml を C:\LearnBizTalk\Documents ディレクトリから C:\LearnBizTalk\Pickup ディレクトリにコピーします。

    先に定義したファイル受信機能 ReceiveReq は、このファイルを受信し Channel To Approval チャネルを介して Req Approval Port メッセージ ポートに送信します。

  2. C:\LearnBizTalk\Output に移動し、NorthwindRequisition.xml ファイルをダブルクリックして Internet Explorer で開きます。

    このドキュメントは \Pickup ディレクトリにコピーしたドキュメントと同じであることを確認してください。このレッスンの初めに、L2Prep.VBS スクリプトを実行し、チャネルとメッセージ ポートの定義を修正しました。これによって、このメッセージ ポートは注文要求ドキュメントを BizTalk オーケストレーション サービスに送信するのではなく、\Output ディレクトリの NorthwindRequisition.xml というファイルにドキュメント内容を書き込みました。

  3. 今度は ReqToDecline.xml ファイルを使用して、上記のステップを再度実行します。\Output ディレクトリ内のファイルは、新たに送信された注文要求によって上書きされます。

このレッスンでは、BizTalk メッセージ サービスの基本的な機能ついて説明しました。サービスを構成するスクリプトを実行し、関係するプロパティを確認し、そしてファイル システムのディレクトリの中のファイルを取り出し、そのファイルを他のディレクトリに出力しました。基本概念と用語について理解できたところで、以降のレッスンではさらに別の機能について説明します。

次のレッスンでは、Northwind Traders 社の注文要求の承認プロセスを BizTalk オーケストレーション サービスを使用して定義する方法について説明します。

「レッスン 3: BizTalk オーケストレーション サービスの設計」に進みます。


レッスン 3: BizTalk オーケストレーション サービスの設計

このレッスンでは、Northwind Traders 社が BizTalk オーケストレーション サービスを使って注文要求の承認処理をどのように構成するのかについて説明します。次の図は、注文要求の承認プロセスを詳細に示しています。

レッスン 3 プロセスのプレビュー

ここには次のトピックが含まれます。

  • BizTalk オーケストレーション サービス

  • ビジネス プロセスの定義

  • ビジネス プロセスの実装

  • 通信フローの作成

  • シナリオの実行


BizTalk オーケストレーション サービス

Microsoft BizTalk Server 2002 は 2 つの問題を解決します。すなわち、BizTalk メッセージ サービスによってビジネス プロセス間でのメッセージ送信を行い、また BizTalk オーケストレーション サービス によってビジネス プロセスを作成します。前のレッスンでは、ビジネス ドキュメントを BizTalk メッセージ サービスに送信する方法について学習しました。このレッスンでは、ビジネス プロセスを定義し、BizTalk オーケストレーション サービスを使用してそれらを適用する方法について学習します。

BizTalk オーケストレーション サービスによって、ビジネス プロセスの詳細な表現を作成することも、また Microsoft Visio 2002 ベースの統合デザイン環境でビジネス プロセスをプログラム的に実装することも可能です。これまではビジネス プロセスの設計段階とその実装段階は別々に行われてきました。BizTalk オーケストレーション サービスの重要な特長の 1 つは、これまで別々のフェーズとして行われてきたものを統一されたグラフィック設計環境に統合したという点です。

ビジネス プロセスはグラフィック環境で定義されるため、各プロセスがビジネス レベルで変更されても、すぐに実装レベルに反映することができます。

設計と実装の統合に加え、BizTalk オーケストレーション サービスは、並列処理を含むプロセスの作成する機能や、同時に複数のタスクを実行できる機能、さまざまなアプリケーション、プラットフォーム、および組織にまたがる堅固な長期ビジネス プロセスの作成機能を提供します。

堅牢で長期的なビジネス プロセスを作成するために、BizTalk オーケストレーション サービスは長期のビジネス プロセス インスタンスを保存して一時中断します。これによりコンピューティング リソースを節約し、信頼性を高めることができます。その後、サーバーは長いオペレーションの終了を待って、中断された正確な時点からプロセスを再開します。途中でコンピュータの電源が切られた場合でも、中断されたプロセスはコンピュータの起動と同時に開始されます。長期オペレーションの例としては、請求書の支払い待ちを挙げることができ、通常は完了までに 20 ～ 30 日かかります。詳細については、「オーケストレーション サービスについて」を参照してください。

「ビジネス プロセスの定義」に進みます。


ビジネス プロセスの定義

このレッスンでは、Northwind Traders 社内の注文要求承認に関するビジネス プロセスを表す XLANG スケジュール フローチャートを開き、参照します。

Northwind Traders 社のビジネス プロセスを参照するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk オーケストレーション デザイナ] をクリックします。

  2. [ファイル] メニューの [開く] をクリックします。

    [XLANG スケジュール フローチャートを開く] ダイアログ ボックスが表示されます。

  3. C:\LearnBizTalk\Schedules に移動し、NorthWindApprovalL3.skv をクリックし、[開く] をクリックします。

注

  • BizTalk オーケストレーション デザイナで表示される空白のフローチャートは閉じてもかまいません。

次の図は、BizTalk オーケストレーション デザイナで作成された Northwind Traders 社の承認プロセス図です。

Northwind Traders の承認プロセス

Microsoft Visio を使用してダイアグラムを作成したことがある方は、BizTalk オーケストレーション デザイナの外観と操作方法にもすぐに慣れるでしょう。BizTalk オーケストレーション デザイナでは、ビジネス プロセスを定義するのにドキュメント、仕様、コンポーネント、メッセージなどの複雑な項目ではなく、[アクション]、[判断]、[繰り返し] などのフローチャート シェイプを使用します。ビジネス プロセスに含まれるステップの数や名前に制限はありません。さらに、[分岐] シェイプを使ってあるプロセスを複数の並列パスに分割することができます。たとえば複数のサプライヤに対して同じ見積もりを要求し、後に [結合] シェイプを使ってこれらのパスを再結合することができます。さらに、[トランザクション] シェイプを使って、必要であれば、プロセスの複数のステップを 1 つのトランザクションにまとめることもできます。詳細については、「フローチャート シェイプ」を参照してください。

「ビジネス プロセスの実装」に進みます。


ビジネス プロセスの実装

ビジネス プロセスを定義した後、それを実装するために、BizTalk Server をビジネス プロセスで定義した各作業を実行するように構成します。

次の図は、Northwind Traders 社の承認プロセスで使用する実装シェイプを示しています。

BizTalk オーケストレーション デザイナの実装シェイプ

[BizTalk メッセージ] シェイプ、[COM コンポーネント] シェイプ、および [メッセージ キュー] シェイプについては、使用方法を理解する必要があります。各ビジネス プロセスをバインドするためのコード作成はありません。コーディングを行うのは特殊なビジネス ロジックの個々のコンポーネントに対してであり、それらの結合のためには必要ありません。

たとえば、[BizTalk メッセージ] シェイプを図にドラッグすると、BizTalk メッセージ バインド ウィザードが開き、一連のページでメッセージ ポートと実装シェイプを関連付けることができます。メッセージ ポートは特定のドキュメントの宛先と関連付けられたプロパティの集まりですから、ビジネス プロセスをその宛先とすることもできます。詳細については、「実装シェイプ」を参照してください。

簡単な作業の場合は、Microsoft® Visual Basic® Scripting Edition (VBScript) などのスクリプト言語を使用してコンポーネントを作成することもできます。この XLANG スケジュール フローチャートでもこのようなコンポーネントが使用されています。このスクリプト コンポーネントは DeclineReq というメソッドを提供し、唯一の処理として注文要求が却下されたことをユーザーに伝えるメッセージ ボックスを表示します。詳細については、「スクリプト コンポーネントの作成」を参照してください。

NorthwindApprovalL3.skv XLANG スケジュールには、スクリプト コンポーネントが 2 つと [BizTalk メッセージ] シェイプが 1 つ含まれます。

ビジネス プロセスの特定部分が、内部データベースへのアクセスやメインフレーム システムとの連携といった特殊なタスクの実行をユーザーに要求する場合は、それらを COM コンポーネント内に実装し、そのメソッドを BizTalk オーケストレーション サービスから呼び出します。

次のレッスンでは、スクリプト コンポーネントを作成する手順について説明します。

「通信フローの作成」に進みます。


通信フローの作成

通信フローを作成するために、ビジネス フロー定義を実装と結合する必要があります。[フローチャート] ステンシルで使用する各フローチャート シェイプ、および [実装] ステンシルで使用する各実装シェイプには、制御ハンドル( 制御ハンドル) が付いています。左側のアクション シェイプを右側の実装シェイプに接続するためには、アクション シェイプのハンドルと実装ポートのシェイプのハンドル間に線を引きます。各シェイプが結合されると、XML 通信ウィザードが開きますので、いくつかの質問に答えて各シェイプ間の通信方式を決定します。詳細については、「XML 通信ウィザードの使用」を参照してください。

アクション シェイプと実装シェイプを接続したら、最後に [データ] ページで実際のビジネス ドキュメントをアクションから次のアクションにどのように渡すか定義します。BizTalk オーケストレーション デザイナの図の下部にある [データ] タブをクリックすると、[データ] ページを見ることができます。次のレッスンでは、[データ] ページについてさらに詳しく説明します。

「シナリオの実行」に進みます。


シナリオの実行

重要

  • このチュートリアルを実行するためには、LearnBizTalk ディレクトリを C ドライブにコピーし、BizTalk Server のすべてのコンポーネントを C ドライブにインストールする必要があります。これらのファイルを他のドライブおよびディレクトリから実行することもできますが、そのためには、ソース ファイルに対して大幅な変更を加える必要があります。これらの要件の詳細については、「BizTalk Server 2002 の理解」を参照してください。

シナリオをテストするには、次の手順を実行します。

  1. C:\LearnBizTalk\Scripts に移動し、L3Post.vbs をダブルクリックします。

    このスクリプトは XLANG スケジュール フローチャートを一時的に変更し、注文要求が Contoso 社に渡されないようにします。元の構成は後で復元します。ここでは、この変更された構成によって、処理手順を見ることができます。

  2. ReqToDecline.xml ファイルを C:\LearnBizTalk\Documents ディレクトリから C:\LearnBizTalk\Pickup ディレクトリにコピーします。

    ファイル受信機能はそのファイルを取り出して BizTalk メッセージ サービスに配信します。BizTalk メッセージ サービスは BizTalk オーケストレーション サービスを使って Northwind Traders 社の注文要求の承認プロセスを呼び出します。これは、このビジネス プロセスのために作成されたメッセージ ポートの宛先として XLANG スケジュールを定義してあるためです。最後に BizTalk オーケストレーション サービスはその注文要求を処理し、注文要求拒否を通知するメッセージ ボックスを表示します。

  3. ReqToApprove.xml ファイルを使用して、手順 2 を繰り返します。

    注文要求が承認されたことを示すメッセージ ボックスが表示されます。

レッスン 4 では、BizTalk オーケストレーション デザイナによる実装シェイプの構成、スクリプト コンポーネントの開発、およびドキュメントが各アクション間で正しく渡さるように [データ] ページで行う処理について詳しく説明します。

「レッスン 4: 実装について」に進みます。


レッスン 4: 実装について

レッスン 4 では、レッスン 3 の XLANG スケジュールを少し拡張し、Northwind Traders 社の注文要求の承認処理を実装する方法について考察します。

注文要求承認プロセスは BizTalk オーケストレーション サービスを使用して、XLANG スケジュールの形式で実装されています。このレッスンでは、いくつかの [実装] シェイプの構成パラメータを参照し、Windows スクリプト コンポーネントの作成手順について確認します。また、XLANG スケジュールとの間で正しく情報が流れるように、BizTalk オーケストレーション デザイナの [データ] ページで行うべき作業について説明します。

このレッスンには次のトピックが含まれます。

  • BizTalk オーケストレーション サービスでのドキュメントの送受信

  • メッセージ仕様へのフィールドの追加

  • COM コンポーネントの操作

  • スクリプト コンポーネントの作成

  • Northwind Traders 社のデータ ページ


BizTalk オーケストレーション サービスでのドキュメントの送受信

XLANG スケジュールは、ビジネス プロセスを実装する場所です。多くの場合、このプロセスは受信ドキュメントのさまざまなフィールドを調べて、その値に基づいてアクションを判断したり、実行したりする必要があります。このチュートリアルでは、注文要求ドキュメントの合計の値をチェックし、合計が 1,000 ドル未満の場合にのみ注文要求を承認します。これを行う前に、注文要求ドキュメントを承認プロセスに送信する必要があります。

このレッスンを始めるために、BizTalk オーケストレーション デザイナで NorthwindApproval.skv ファイルを開きます。このファイルはレッスン 3 で使用した NorthwindApprovalL3.skv ファイルと非常によく似ていますが、Windows スクリプト コンポーネントの 1 つが "Channel To Contoso" と記載された BizTalk メッセージ シェイプに置き換えられています。

BizTalk メッセージ シェイプ "Channel To Contoso"

XLANG スケジュール フローチャートのビジネス プロセスが定義され、実装が追加された後、その図は XLANG スケジュールに組み込まれます。そのスケジュールは、XLANG 言語で書かれたファイルです。XLANG 言語は、さまざまな技術を使用して、ビジネス プロセスの論理的な順序およびビジネス プロセスの実装を記述する言語です。XLANG 言語は XML で表現されます。XLANG スケジュールは、実行の必要な全ての手順、呼び出しの必要なコンポーネント、定義したプロセスを実行するために渡す必要があるデータを定義します。両方の立場の図が完成した後、BizTalk オーケストレーション デザイナの [ファイル] メニューから [XLANG <ファイル名>.skx…の作成] をクリックして XLANG スケジュール フローチャートを組み込むことができます。

前のレッスンでは、ビジネス ドキュメントを含むメッセージを BizTalk メッセージ サービスを使って送信する方法について学びました。このレッスンでは、メッセージとビジネス プロセスを結合します。

レッスン 2 ではメッセージ ポートを定義し、注文要求ドキュメントを XLANG スケジュールに配信するように構成しました。注文要求を処理するために BizTalk メッセージ サービスが開始する XLANG スケジュール (XLANG ファイル) の名前を指定しました。またスケジュール内で注文要求を受信するためのメッセージ ポートの名前も指定しました。このオーケストレーション ポートは BizTalk オーケストレーション デザイナの中で構成されなければなりません。なお、「ポート」という語は、2 つの異なる概念を表すことに注意してください。BizTalk メッセージ マネージャで定義されるメッセージ ポートと、BizTalk オーケストレーション デザイナで定義されるオーケストレーション ポートは同じものではありません。

BizTalk メッセージ実装の使用

[BizTalk メッセージ] シェイプは、BizTalk メッセージ サービスから BizTalk オーケストレーション サービスへドキュメントを送信するために使用します。

[BizTalkメッセージ] シェイプを XLANG スケジュール フローチャートの右側に加えると、BizTalk メッセージ バインド ウィザードが開きます。既存の BizTalk メッセージの実装を編集するには、[BizTalk メッセージ] シェイプをダブルクリックします。BizTalk メッセージ バインド ウィザードで、オーケストレーション ポートに名前を付けます (この名前は BizTalk メッセージ マネージャで指定した名前と一致しなければなりません)。またこのポートがドキュメントを受信するのかあるいは送信するのかを指定し、さらにビジネス プロセスを開始するために使用されるかどうかも指定します。

ドキュメントを BizTalk メッセージ サービスに送り返す必要がある場合、[BizTalk メッセージ] シェイプを XLANG スケジュール フローチャートの右側に追加して、そのドキュメントの送信先となるチャネルの名前を指定します。XLANG スケジュール フローチャートを作成する時点ではこのチャネルは存在しなくてもかまいませんが、そのスケジュールの実行時には必要です。

オーケストレーション ポートが作成されたら、[アクション] シェイプをこのポートに接続し、XML 通信ウィザードで、ドキュメントを XML と文字列のいずれで送信するのか、メッセージの種類の情報、およびドキュメントを検証するためのオプションの XML 仕様を指定します。これはドキュメントを BizTalk メッセージ サービスから受信するよう BizTalk オーケストレーション サービスを構成したときと似ています。詳細については、「BizTalk メッセージ シェイプの使用」を参照してください。

メッセージ キュー シェイプの使用

XLANG スケジュールでドキュメントを受け取るもう 1 つの方法は、[メッセージ キュー] シェイプを使用する方法です。このシェイプを図に加えると、メッセージ キュー バインド ウィザードが起動し、ドキュメントの送受信に使用されるプライベートまたはパブリック メッセージ キューの名前を指定するように指示されます。ただし、メッセージ キューを使用してドキュメントを受け取ることを選択した場合は、BizTalk メッセージ サービスからドキュメントを受け取る場合とは異なり、スケジュールは自動的に開始されません。ドキュメントがキューに入れられた後、別の方法でスケジュールを開始する必要があります。

ReceiveReq ポートの図の左側にある Receive Requisition アクション シェイプを接続するとXML 通信ウィザードが開きます。既存のメッセージ キュー実装を編集し、XML 通信ウィザードを開くには、Receive Requisition アクションと ReceiveReq ポートを接続する青い線をダブルクリックします。

XLANG スケジュールで表現されるオーケストレーション プロセスにドキュメントを提供するために使用するメッセージを作成するように指示されます。具体的には、このメッセージを [データ] ページの他のメッセージに接続し、ドキュメントをXML 形式で処理するかどうかを指定し、メッセージの種類を指定するように指示されます。ドキュメント仕様を含む XML ファイルの名前と場所を指定することもできます。BizTalk オーケストレーション サービスは各ドキュメントを処理する前に、この仕様に照らして検証することができます。

ドキュメントは、メッセージ キューを使って XLANG スケジュールから送信することもできます。この場合、チャネル名を指定する代わりに、ドキュメントの送信先となるプライベートまたはパブリック キューの名前を指定する必要があります。詳細については、「メッセージ キュー シェイプの使用」を参照してください。

XLANG スケジュール フローチャートのビジネス プロセスが定義され、実装が追加された後、その図は XLANG スケジュールに組み込まれます。詳細については、「XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル」を参照してください。XLANG スケジュールは、実行の必要な全ての手順、呼び出しの必要なコンポーネント、定義したプロセスを実行するために渡す必要があるデータを定義します。

ドキュメントを BizTalk メッセージ サービスとの間で送受信する方法を理解したところで、BizTalk オーケストレーション サービス内でのドキュメントに対する作業を見てみましょう。

「メッセージ仕様へのフィールドの追加」に進みます。


メッセージ仕様へのフィールドの追加

これまでに、メッセージに対して XML 通信を構成し、受信されるドキュメントをどの XML 仕様で表すかを示しました。これで BizTalk オーケストレーション サービスを使ってドキュメント内の各フィールドの値を検索し、情報を COM コンポーネントまたは別のメッセージに転送することができます。

  1. Receive Requisition アクションと ReceiveReq ポートを接続する青い線をダブルクリックして、ReceiveReq ポートの [XML 通信ウィザード] を開きます。

  2. [次へ] を 4 回クリックします。

    XML 通信ウィザードの [メッセージ仕様情報] ページが開きます。

  3. [メッセージ フィールド] には複数の項目が入っています。それらの項目の 1 つである [Document] は、XLANG スケジュールに渡されるドキュメント全体を表すフィールドです。[追加] をクリックします。[追加] をクリックします。

    [フィールドの選択] ダイアログ ボックスが表示されます。

    XLANG スケジュールに渡されるドキュメントは Northwind Requisition 仕様という名称の XML 仕様と一致するように指定したため、XPath と呼ばれる標準 XML クエリ言語を使って、このドキュメントから個々のフィールドを選択することができます。

    注

    • XPath は、XML ドキュメントのいくつかの部分を扱う言語であり、W3C によって管理される公開標準です。XPath の詳細については、W3C の Web サイトの XPath ページ (www.w3.org/TR/xpath.html) を参照してください。
  4. [Items] ノードを展開し、[totalPrice] をクリックします。

    そのノードに対する XPath が[ノード パス] ボックスに表示されます。次の図は totalPrice フィールドが選択された [フィールドの選択] ダイアログ ボックスを示しています。

    [フィールドの選択] ダイアログ ボックス

    同様に、仕様のほかのフィールドをユーザーのメッセージに加えることができます。このダイアログ ボックスで追加されたすべてのフィールドは、BizTalk オーケストレーション デザイナの [データ] ページで利用可能となります。したがってこれらを式で使用したり、パラメータとしてコンポーネントに渡したりすることができます。

  5. [キャンセル] をクリックして [フィールドの選択] ダイアログ ボックスを閉じます。

  6. [キャンセル] をクリックし、[XML 通信ウィザード] を閉じます。

  7. XLANG スケジュール フローチャートの左側で、[Decision] シェイプを右クリックし、[Properties] をクリックします。

    [判断のプロパティ] ダイアログ ボックスが表示されます。

  8. [編集] をクリックします。

    以下のようなダイアログ ボックスが表示されます。

    [条件のプロパティ] ダイアログ ボックス

    [条件式] は、MessageName.FieldName という表記を使って totalPrice フィールドの値をアクセスできることを示しています。この例では、Message_1.totalPrice を使って注文要求ドキュメントの Total Price 値を取得します。

「COM コンポーネントの操作」に進みます。


COM コンポーネントの操作

ドキュメントが XLANG スケジュール内に入ったところで、さまざまなビジネス コンポーネントを呼び出し、ドキュメントをパラメータの 1 つとして渡すことができます。これらのコンポーネントは、ビジネス ルールの処理、企業データベースのアクセス、電子メール メッセージの送信などの作業を実行できます。また、コンポーネントはドキュメント自体を修正し、その変更事項を XLANG スケジュールに戻して次のアクションに渡すこともできます。これを行うために、ビジネス ロジックを標準 COM コンポーネントとして実装し、それらを XLANG スケジュール フローチャートの右側に加え、呼び出すメソッドを選択する必要があります。

ここまでで、以下の作業が完了しました。

  • ハード ディスク上のファイルから注文要求ドキュメントを読み取り、それを (ファイル受信機能を使用して) BizTalk メッセージ サービスに渡しました。

  • この注文要求ドキュメントを (チャネルを使用して) XML 仕様に照らし検証し、それを BizTalk オーケストレーション サービスに渡しました。

  • その後、 XLANG スケジュールの中にドキュメントを受け取り、(XML 通信ウィザードを使用して) 特定のフィールドの値を検索しました。

  • 最後に [判断] シェイプで条件のプロパティを使用して値を評価し、ビジネス ロジックを構築しました。

ここまでは、ビジネス プロセスを構築および実装するためのプログラミングは必要ありませんでした。ただし、特定の企業固有のアクションを実装するためには (注文要求承認の検索をスタッフの特定メンバに制限するなど) ビジネス コンポーネントを記述しなければならない場合もあります。そのため次のトピックでは、Windows スクリプト コンポーネントを記述する方法について説明します。詳細については、「COM コンポーネント シェイプの使用」を参照してください。

「スクリプト コンポーネントの作成」に進みます。


スクリプト コンポーネントの作成

Microsoft Windows スクリプト コンポーネントは、Microsoft Visual Basic Scripting Edition (VBScript) や Microsoft® JScript® などのスクリプト言語の使用による、コンポーネント オブジェクト モデル (COM) コンポーネントの作成をサポートしています。COM をサポートするどのアプリケーションにおいても、ほかの COM コンポーネントと同じようにスクリプト コンポーネントを使用することができます。

スクリプト コンポーネントは実行時に解釈されるため、コンパイルされたコンポーネントとは性能が異なりますが、後ほど作成する COM コンポーネント用のインターフェイスを試作するために使用できます。

スクリプト コンポーネントの作成を直ちに始めることができるように、Microsoft は Windows Script Component Wizard をリリースしています。このウィザードは MSDN Web サイト (msdn.microsoft.com/scripting/) からダウンロードできます。コンポーネントのスケルトン コードの作成は簡単です。コンポーネントの名前を選択し、使用するスクリプト言語を決め、コンポーネントに与えるプロパティおよびメソッドを指定し、[Finish] をクリックします。ウィザードはコンポーネントに必要なすべてのコードを生成し、それを .wsc 拡張子を持つファイルに保存します。次に好みのエディタからこのファイルを開き、実際のコードをメソッドの後ろに加えます。

今回使用するコンポーネントには ApproveReq と DeclineReq という 2 つのメソッドがあり、メソッドはそれぞれ document というパラメータを 1 つ持ちます。次の図は、Windows Script Component Wizard の、これらのメソッドをスクリプト ファイルに加えるページを示しています。

Windows Script Component Wizard ステップ 4 / 6

以下のコードは Requisition Approval コンポーネントのコードです。

<?xml version="1.0"?>
<component>

<registration
   description="Req Approval"
   progid=" LearnBizTalk.ProcessReq"
   version="1.00"
   classid="{AD454A9F-58FE-4877-B7CD-F61BD45988F5}">
</registration>

<public>
   <method name="ApproveReq">
      <PARAMETER name="Document"/>
   </method>
   <method name="DeclineReq">
      <PARAMETER name="Document"/>
   </method>
</public>

<script language="VBScript">
<![CDATA[

function ApproveReq(Document)
MsgBox "Orchestration Engine Approved Requisition:" & vbCrLf & vbCrLf & Document, 64, "Requisition Approved"
end function

function DeclineReq(Document)
MsgBox "Orchestration Engine Declined Requisition:" & vbCrLf & vbCrLf & Document, 16, "Requisition Declined"
end function

]]>
</script>

</component>

太字で示されている ApproveReq および DeclineReq メソッドの実装コードを除き、このファイル内のすべてがウィザードによって作成されました。

ビジネス プロセスのフローは複雑であり、開発者が作成する COM コンポーネントはその作成とテストに数週間を要する場合があります。だからといって、これらのコンポーネントが完了する前に、XLANG スケジュール フローチャートの設計とテストを行うことができないというわけではありません。Windows Script Component Wizard を使用して、提示されるメソッドおよびプロパティを完備した複雑な COM コンポーネントのサンプル バージョンを作成し、実際の COM コンポーネントの代わりにそれらのスクリプト コンポーネントを XLANG スケジュール フローチャートで使用します。これで開発者がコーディングを完了するのを待たずに、XLANG スケジュール フローチャートを設計できます。詳細については、「スクリプト コンポーネント シェイプの使用」を参照してください。

また、スクリプト コンポーネントを使って、BizTalk メッセージ サービスと BizTalk オーケストレーション サービスの統合をテストすることができます。それを将来、別の言語で開発された COM コンポーネントと置き換えることも可能です。スクリプト コンポーネントを置き換える準備ができたら、XLANG スケジュールフロー チャートに [COM コンポーネント] シェイプを追加します。[COM コンポーネント バインド ウィザード] が開き、新規のオーケストレーション ポートを作成ために必要な情報の入力を要求します。次に、スクリプト コンポーネント ポート実装にこれまで接続されていた既存のアクション シェイプを切り離し、新しいオーケストレーション ポートに再び接続し、スケジュールを再コンパイルします。

「Northwind Traders 社のデータ ページ」に進みます。


Northwind Traders 社のデータ ページ

XLANG スケジュール フローチャートを作成し、すべての実装シェイプを対応するアクションに接続したら、BizTalk オーケストレーション サービスの [データ] ページを使用してプロセス内の 1 つのステップから次のステップへの流れを構成する必要があります。[データ] ページの完了前の姿は、次の図のようになります。

Northwind Traders 社のデータ ページ

なお、[データ] ページにはフィールドの複数のグループが示され、各グループには、オーケストレーション ポートとの間でドキュメントを送受信するメッセージに関連する名前が付けられています。

BizTalk オーケストレーション デザイナで NorthwindApproval.skv を開き、[表示] メニューの [データ ページ] をクリックします。Message_1 の Document フィールドが Message_2 および DeclineReq_in の Document フィールドにどのように接続されているかを見てください。Message_1 によって BizTalk メッセージ サービスから受信したドキュメントが DeclineReq_in メッセージ (スクリプト コンポーネントにドキュメントを送信するメッセージ) および Message_2 (同じドキュメントを BizTalk メッセージ サービスへ返送する) に渡されています。このページのメッセージを並べ替え、フローチャートをより簡単にわかりやすくすることができます。

データ ページを表示するには、デザイン ページの下部にある [Data] タブをクリックします。NorthwindApproval.skv の [データ] ページは、次の図のようになります。

Northwind Traders 社のデータ ページと接続

メッセージ間のデータの流れを定義したら、フローチャートを実行可能な XLANG スケジュールにコンパイルできます。

XLANG スケジュール フローチャートを保存およびコンパイルする方法

  1. [ファイル] メニューの [<ファイル名>.skv の保存] をクリックします。

  2. [ファイル] メニューの [XLANG <ファイル名>.skx の作成] をクリックします。

    [XLANG スケジュールに名前を付けて保存] ダイアログ ボックスが表示されます。

  3. XLANG スケジュールが保存される場所を確認し、[保存] をクリックします。

  4. [ファイル] メニューの [終了] をクリックして BizTalk オーケストレーション デザイナを閉じます。

    これで XLANG スケジュールは実行可能な状態となります。

詳細については、「XLANG スケジュールのコンパイル」を参照してください。

次のレッスンでは、ドキュメントのマップを使って変換し、取引先に配信するための作業について説明します。また、BizTalk メッセージ サービスでのこれらのマップを使用する方法について解説します。

「レッスン 5: BizTalk マッパーの使用」に進みます。


レッスン 5: BizTalk マッパーの使用

これまでのレッスンでは、Microsoft BizTalk Server 2002 が業務アプリケーションからどのようにドキュメントを受け取るのか、またそのドキュメントが BizTalk オーケストレーション サービスでどのように処理されるのかについて学びました。

このレッスンでは、注文要求ドキュメントを Contoso 社に渡すために行う処理と、このタスクを実行するための BizTalk メッセージ サービスでの各ステップを見ていきます。

このレッスンには次のトピックが含まれます。

  • マップの作成

  • マップの使用

  • シナリオの実行


マップの作成

これまで使用してきた注文要求ドキュメントは、Northwind Traders 社のアプリケーションで作成された社内の注文要求でした。この注文要求がビジネス プロセス (このシナリオでは BizTalk オーケストレーション サービスを使用して実装) による承認を得たら、注文書 (PO) を Contoso 社に送って実際に商品を購入します。

この時点では、注文書ドキュメントはなく、あるのは注文要求だけです。ただし、Contoso 社への注文書の構造、および品目リストや請求先住所などの注文書を作成するのに必要なほとんどのデータが、実際には注文要求に含まれています。注文要求ドキュメントに含まれている情報を Contoso 社が使用できる注文書に変換するために、BizTalk マッパーを使用します。BizTalk マッパーは XSL Transformation (XSLT) というインターネット標準を使用します。これは XML ドキュメントを、ある XML スキーマから別の XML スキーマへ変換するための言語です。

注

  • XSLT は、W3C 勧告です。XSLT の詳細については、W3C の Web サイト の XLST ページ (www.w3.org/TR/xslt.html) を参照してください。

BizTalk マッパーを使用するにあたって、XSLT に関する知識は必要ありません。BizTalk マッパーはとてもグラフィカルなツールであり、2 つの仕様を並べて表示し、仕様のフィールド間を線で結ぶだけで変換を定義することができます。詳細については、「マッピング仕様」を参照してください。

ドキュメント 1 のフィールド A がドキュメント 2 のフィールド B にそのままコピーされるというような単純な規則では不十分な場合には、BizTalk マッパーは Functoid と呼ばれる一連の強力な変換機能を提供します。BizTalk マッパーには 60 以上の Functoid があり、数値演算、論理、文字列、日付/時刻、関数、データベース、およびその他の操作を行うことができます。既存の Functoid の中に目的の操作に適したものがない場合のために、Microsoft Visual Basic Scripting Edition (VBScript) を使ってサブルーチンを作成するスクリプト Functoid もあります。完成した VBScript コードは、BizTalk マッパーが生成した XSLT に直接組み込まれます。詳細については、「Functoid について」を参照してください。

注

  • Functoid をカスケード接続することによって、より強力な処理を行うこともできます。これは、ある Functoid の実行結果を次の Functoid に入力として渡すものです。Visual Basic などの言語でカスタム Functoid を作成し、それをユーザーの Functoid パレットに加えて後で使用することもできます。

今回のビジネス シナリオのために、Northwind Traders 社の注文要求ドキュメントを Contoso 社への注文書に変換するマップを作成しています。このマップは C:\LearnBizTalk\Documents\ ディレクトリにある ContosoPOMap.xml というファイルに格納されています。BizTalk マッパーでこのマップを開くと、次の図で示すような画面が表示されます。

BizTalk マッパーで開いた ContosoPOMap.xml

Contoso 社に対する注文書ドキュメントを作成するために必要なフィールドのほとんどは、注文要求ドキュメント内に別の名前で既に存在しています。PO Number などの一部のフィールドは新しいものなので、その値を生成する必要があります。

このマップでは 3 つの Functoid を使用していることがわかります。

  • 注文要求内の 2 つのアドレス フィールドを注文書内の 1 つのフィールドに結合する文字列連結 Functoid

  • created フィールドに設定する現在のタイムスタンプを作成する日時 Functoid

  • PO 番号を生成するために特定のビジネス ルールを実装するスクリプト Functoid (この例では Functoid は PO 番号をランダムに生成しています)

宛先フィールドの値 (たとえば社名や会社の住所など) は長期間変わりませんから、使用する定数値を BizTalk マッパーで指定することができます。そのためには、定数値を入れるフィールドをクリックして強調表示し、[値] タブをクリックし、値を入力します。次の図は、[値] タブを示しています。

BizTalk マッパーの [値] タブ

注

  • 送信先定数値を持つノードにはリンクできません。

マップの作成方法の詳細については、「BizTalk Server 2002 チュートリアル」のモジュール 2 を参照してください。

「マップの使用」に進みます。


マップの使用

マップの作成が完了したところで、BizTalk メッセージ マネージャに戻って Channel To Contoso という名前のチャネルを構成します。これは、マップを使用して作成した注文書を Contoso 社に配信するために使用されます。

このチャネルは、レッスン 4 で注文要求ドキュメントを Contoso 社に配信するようにポートを構成したときに XLANG スケジュール フローチャートで指定したチャネルと同じものです。今回の XLANG スケジュールは、受信したものと同じ注文要求ドキュメントを出力し、BizTalk メッセージ サービスの内部で後ほど発生するドキュメント変換 (注文書への変換など) については一切関知しないことに注目してください。このように、注文要求の承認に関するビジネス プロセスと、ドキュメント形式の管理および配信メカニズムに関する技術的詳細とは相互に独立しているため、ソリューション全体が柔軟で容易に改変できるものとなっています。

ここで重要な点は、BizTalk オーケストレーション サービスはビジネス プロセスを作成するための技術であり、BizTalk メッセージ サービスは各ビジネス プロセス間における信頼性の高いドキュメントの受け渡しを可能にし、それらを統合する技術であるという点です。

将来 Contoso 社が注文書の形式を変更した場合は、Contoso 社への注文書の仕様を更新し、マップを更新して仕様変更を反映するだけで済み、ビジネス プロセス全体を作り直す必要はありません。

BizTalk メッセージ マネージャでチャネルを構成するときに、受信ドキュメント定義とは異なる送信ドキュメント定義を指定した場合は、それらの 2 つのドキュメント仕様間の変換を行うマップ ドキュメントを指定するように BizTalk メッセージ マネージャが自動的に要求します。次の図は、マップ ドキュメントが識別される方法を示しています。

チャネルのプロパティ ウィザードの [送信ドキュメント] ページ

Channel to Contoso を開きチャネルのプロパティを表示するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [BizTalk メッセージ マネージャ] ダイアログ ボックスが表示された場合は [キャンセル] をクリックします。

  3. [その他の項目を検索] の [チャネル] をクリックします。

  4. [検索] をクリックします。

[チャネル名] ボックスの一覧で [Channel to Contoso] をダブルクリックします。

  5. [次へ] を 3 回クリックして、[送信ドキュメント] ページに進みます。

「シナリオの実行」に進みます。


シナリオの実行

重要

  • このチュートリアルを実行するためには、LearnBizTalk ディレクトリを C ドライブにコピーし、BizTalk Server のすべてのコンポーネントを C ドライブにインストールする必要があります。これらのファイルを他のドライブおよびディレクトリから実行することもできますが、そのためには、ソース ファイルに対して大幅な変更を加える必要があります。これらの要件の詳細については、「BizTalk Server 2002 の理解」を参照してください。

シナリオを実行するには、次の手順を実行します。

  1. C:\LearnBizTalk\Scripts\ に移動し、L5Post.vbs をダブルクリックします。

    このスクリプトは、レッスン 3 の最後にオーケストレーション処理に加えた一時的変更を削除し、BizTalk オーケストレーション サービスがドキュメントを BizTalk メッセージ サービスに出力できるようにします。

  2. ReqToDecline.xml ファイルを C:\LearnBizTalk\Documents\ ディレクトリから C:\LearnBizTalk\Pickup\ ディレクトリにコピーします。

    以前と同様にこの注文要求は拒否され、それを通知するメッセージ ボックスが表示されます。

  3. ReqToApprove.xml ファイルを使用して、手順 2 を繰り返します。

    この注文要求は承認され、BizTalk オーケストレーション サービスによって BizTalk メッセージ サービスに送られます。

    チャネルはドキュメントを受信し、指定したマップを適用して Contoso 社の注文書に変換します。BizTalk メッセージ サービスは、変換されたドキュメントを ContosoPO.xml という名前で C:\LearnBizTalk\Output\ ディレクトリに書き込みます。

    注

    • このメッセージがファイルに書き込まれたとき、注文要求が承認されたというメッセージ ボックスは表示されません。
  4. C:\LearnBizTalk\Output\ に移動し、ContosoPO.xml をダブルクリックして Internet Explorer で開きます。

    スクリプト Functoid によってランダムに生成された PO Number フィールドの値、このファイルが作成されたときの時刻を保持する created フィールドの値、および文字列 Functoid によって元の addr1 と addr2 フィールドが連結された値を保持する address フィールドの値を見てください。

BizTalk マッパーを使用するにあたっての手順ごとの説明は、「BizTalk Server 2002 チュートリアル」の「モジュール 2」にあります。

次のレッスンでは、ドキュメントをビジネス パートナーに配信するための別のいくつかの方法と、ここでも標準インターネット プロトコルによってその作業が容易になることを学びます。

「レッスン 6: ドキュメントの送受信」に進みます。


レッスン 6: ドキュメントの送受信

このレッスンでは、Northwind Traders 社が注文書 (PO) を Contoso 社に送信するために使用するプロセスと、その注文書が Contoso 社によってどのように受信され、格納されるかについて学びます。

このレッスンには次のトピックが含まれます。

  • プロトコルの選択

  • HTTPでのドキュメントの受信

  • キューの使用

  • シナリオの実行


プロトコルの選択

注文書 (PO) ドキュメントを作成したら、処理するために Contoso 社に送信する必要があります。このタスクのトランスポート サービスを選択する際に、いくつかの重要な点を考慮する必要があります。

  • トランスポート サービスには標準プロトコルを使用しなければなりません — 取引先 (Contoso) が任意のプラットフォームで運用しているさまざまなソフトウェアを用いてドキュメントを受信できることを確認する必要があるためです。

  • トランスポート サービスは信頼できるものでなければなりません — ドキュメントが取引先によって確実に受信される必要があるためです。

  • トランスポート サービスは安全なものでなければなりません — 送信プロセス全体を暗号化してデータを保護できることを確認する必要があるためです。

このシナリオでは、HTTP (Hypertext Transfer Protocol) を使用するトランスポート サービスを選択します。HTTP は、Web サーバーからの情報の検索のためにインターネット ブラウザなどが使用する標準プロトコルです。企業のファイアウォール管理者の多くは、企業外部へ送信されるものが HTTP に基づくものであれば問題にはしません。これは適切なトランスポート サービスを選択するうえで重要な側面です。Microsoft BizTalk Server は、内部アプリケーション、データベース、およびレガシー システムとの相互通信が必要であり、そのためファイアウォールの内側になければなりません。同時に外部の取引先とのドキュメントのやり取りにはファイアウォールを通過できる一般的なプロトコルの使用が好まれるでしょう。

HTTP はトランスポート面から見て信頼性に優れています。これは、受信側において送信者にステータスを返すための標準的な方法を定義しているためです。ビジネス プロセスの観点からは、一時的なインターネット障害によって送信障害が生じたときに回復できると便利です。BizTalk Server は送信プロセスを監視し、事前に設定された回数だけドキュメントの送信を再試行し、送信が失敗した場合には管理者に警告できます。

また HTTP にはセキュリティの高いバリエーションとして HTTPS (Secure Hypertext Transfer Protocol) があります。HTTPS は、標準アルゴリズムを用いて伝送全体を暗号化することができます。HTTPS は取引先との通信ストリーム全体を暗号化し、また、ドキュメントの暗号化とデジタル署名を組み合わせてセキュリティをさらに高めることもできます。

注

  • ドキュメントを取引先に送信するもう 1 つの方法は、ファイル トランスポート サービスを使ってドキュメントをハード ディスク上のファイルに保存し、別のプロセスがそれらのファイルを取り出して、EDI-VAN ダイヤラまたは FTP プロセスを使って取引先に配信する方法です。

BizTalk Server 2002 で利用できるサービスの詳細については、「トランスポート サービス」を参照してください。

「HTTPでのドキュメントの受信」に進みます。


HTTP でのドキュメントの受信

HTTP を使用して BizTalk Server から送信されたドキュメントを受信するため、またはそれを処理するために、受信側は何をする必要があるかについて考えてみましょう。今回のシナリオでは、Contoso 社も注文書の受信と請求書の作成および送信に BizTalk Server を使用しているものと仮定します。

BizTalk Server は Internet Information Server (IIS) 5.0 を含むプラットフォームである Microsoft Windows 2000 Server で実行されているため、Contoso 社は Active Server Pages (ASP) スクリプトを使用して Northwind Traders 社の BizTalk Server からドキュメントを受け取り、それを Contoso 社側の BizTalk Server に送信することができます。

注

  • このレッスンでは、Northwind Traders 社と Contoso 社の両方の処理をシミュレートするために、BizTalk Server の単一のインスタンスを使用します。実際の運用環境では、それぞれの企業で別々のサーバーが使用されます。

ASP スクリプトは、ドキュメントの受信後、それに続く処理のために BizTalk Server にそのドキュメントを送り返さなければなりません。そのためにいくつかのオプションが利用できますが、フェイル セーフな方法でこの結果を達成することのできるソリューションを設計することが重要となります。

たとえば、Contoso 社のサーバーが定期保守やアップグレードのために一時的に停止したり、Contoso 社のサーバーに対する負荷が非常に高くなった場合に注文書の処理がリアルタイムに実行されなくなったりしますが、それによって Northwind Traders 社あるいはその他の取引先からの注文書ドキュメントの送信機能に影響が及ぶようであってはなりません。実際、Northwind Traders 社は、注文書が正常に送信されることを除いて、Contoso 社側で発生していることや使用されている技術については一切何も認識しません。したがって、BizTalk Server は COM を使用してドキュメントを受信する標準的な方法を提供しますが、この例ではそれが最適なアプローチであるとは言えません。

ソリューションのこの部分をより適切に構築する方法について考えてみましょう。ASP スクリプトは、転送されたドキュメントを受信した後、そのドキュメントをハードディスク上のファイルに保存し、ドキュメントが正常に受信されたことを通知して終了しなければなりません。一方 BizTalk Server は、格納されたドキュメントを取り出し、それを完全に非同期に処理します。レッスン 2 では、BizTalk メッセージ サービスのファイル受信機能と、それを使用してファイルを BizTalk Server が監視している特定の場所に送信する方法について学びました。それを前提にして、このシナリオでは、ASP スクリプトによってドキュメントをファイルに格納することができます。ファイルは後に、ファイル受信機能によって取り出されます。こうしたアーキテクチャによって、BizTalk Server がドキュメントを処理する正確な時期を決定したり、ビジネス ニーズの増大に伴って受信ドキュメントを処理する BizTalk Server の数を増やしたりするなど、柔軟性が高くなります。

次のトピックでは、ドキュメントをファイルに格納することなく、処理しやすい形で同じような信頼できる結果が得られるもう 1 つの方法について説明します。また、トランザクショナルであることの利点についても説明します。

「キューの使用」に進みます。


キューの使用

メッセージ キュー (MSMQ とも呼ばれます) は、Windows 2000 Server の標準コンポーネントの 1 つであり、今回設計しているような非同期ソリューションを作成するためのもう 1 つの容易で信頼性に優れた方法を提供します。

ドキュメントが ASP スクリプトによって受信されたら、ハード ディスク上のファイルにそれを格納するのではなく、メッセージとしてサーバー上のメッセージ キューに入れ、メッセージ キュー受信機能を使って BizTalk メッセージ サービスに配信することができます。この機能はファイル受信機能と似ています。ほとんどの構成で、信頼性を高めるために、メッセージ キューをトランザクション キューとしてセットアップできます。

次の図は、プロセス全体を示したものです。

レッスン 6 プロセスの概要

新しいメッセージ キュー受信機能を作成するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

  2. BizTalk Server グループを展開し、[受信機能] を右クリックします。次に[新規作成] をポイントし、[メッセージ キュー受信機能] をクリックします。

    [メッセージ キュー受信機能の追加] ダイアログ ボックスが表示されます。

  3. [名前] ボックスに機能の名前を入力し、[ポーリングの場所] ボックスにポーリング場所のキュー名を入力します。

  4. [詳細設定] をクリックします。

    [受信機能の拡張オプション] ダイアログ ボックスが表示されます。

  5. [チャネル名] ボックスのドロップダウン リストから、この機能によって受信されるドキュメントを処理するチャネルを選択します。

    注

    • ドキュメントを格納するためにプライベート メッセージ キューを使用する場合は、以下の形式でキュー名を入力します。DIRECT=OS:.\private$\<キュー名>

    • パブリック キューを使用する場合は、以下の形式でキュー名を入力します。DIRECT=OS:<サーバー名>\<キュー名>

セットアップ中に構成された ReceivePO メッセージ キュー受信機能のプロパティを見ることができます。この受信機能は、以前に説明した ASP スクリプトが受信した注文書ドキュメントを処理します。この機能は一時停止されているため、ドキュメントはキューに残り、ユーザーはそれらを調べることができます。このレッスンの最後にこの機能を再び実行可能に戻します。

次に、ContosoReceive.asp ファイル内のスクリプトを調べて、BizTalk Server が送信するデータを受信してメッセージ キューに入れるために実行される一連のステップを見てみましょう。このコードは最初に、ASP が提供する Request オブジェクトの BinaryRead メソッドを使用して、すべての送信データを読み出します。次に Microsoft Active Data Objects (ADO) を利用して、受信したデータをバイナリ形式からテキスト形式に変換します。最後にメッセージ キューの機能を使って新しいキュー メッセージを作成し、選択したプライベート キューに入れます。

C:\LearnBizTalk\ASP\ ディレクトリにある ContosoReceive.asp ファイル内のソース コード全体を見ることができます。

「シナリオの実行」に進みます。


シナリオの実行

重要

  • このチュートリアルを使用するためには、LearnBizTalk ディレクトリを C ドライブにコピーし、BizTalk Server のすべてのコンポーネントを C ドライブにインストールする必要があります。これらのファイルを他のドライブおよびディレクトリから実行することもできますが、そのためには、ソース ファイルに対して大幅な変更を行う必要があります。これらの要件の詳細については、「BizTalk Server 2002 の理解」を参照してください。

シナリオを実行するには、次の手順を実行します。

  1. C:\LearnBizTalk\Scripts\ に移動し、L6Post.vbs をダブルクリックします。

    このスクリプトは以前変更されたメッセージ ポート Port To Contoso の構成を復元し、レッスン 5 のようにファイルへ書き込むのではなく HTTP トランスポートを使ってドキュメントを Contoso 社に配信するようにします。

  2. ReqToApprove.xml ファイルを C:\LearnBizTalk\Documents\ から C:\LearnBizTalk\Pickup\ にコピーします。

    このファイルはファイル受信機能によって処理され、BizTalk メッセージ サービスから BizTalk オーケストレーション サービスへ渡されて承認処理を受けます。次に BizTalk メッセージ サービスに戻され、最後に HTTP プロトコルを使って Contoso 社に送信されます。

Contoso 社側をシミュレートする ASP スクリプトは、送信データを読み込んでドキュメントへと戻し、そのドキュメントをローカル プライベート キューに入れます。

その後、メッセージ キュー受信機能はキューからドキュメントを取り出し、BizTalk メッセージ サービスに引き渡します。ただし、この受信機能を一時的に使用停止にしてあるため、キューに入れられたドキュメントを調べることができます。

キュー上のメッセージを表示するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [管理ツール] をダブルクリックします。

  3. [コンピュータの管理] をダブルクリックします。

    [コンピュータの管理] コンソールが表示されます。

  4. [コンピュータの管理] コンソールで、[サービスとアプリケーション] を展開します。次に [メッセージ キュー] を展開し、[専用キュー] をクリックします。その次に [ContosoPOQueue] を展開します。

  5. 左側のペインで [キュー メッセージ] をクリックして、右側のペインに現在キューに入っているすべてのメッセージを表示します。

  6. 右側のペインにあるメッセージを右クリックし、[プロパティ]をクリックし、[本文] タブをクリックして、メッセージ本文の最初の部分を参照します。

メッセージを調べた後、左側のペインにある [キュー メッセージ] を右クリックし、次に [すべてのタスク] をポイントし [削除] をクリックすると、キューからメッセージが削除されます。

詳細については、「受信機能とドキュメント ルーティングについて」を参照してください。

次のレッスンでは、今回のシナリオにおける最終ステップ、すなわち Contoso 社による注文書の処理、請求書の作成、および Northwind Traders 社への配信について説明します。

「レッスン 7: トランザクションの実行」に進みます。


レッスン 7: トランザクションの実行

レッスン 7 では、Contoso 社がインターネットを介して Northwind Traders 社から送られた PO を受信する方法、BizTalk メッセージ サービスと BizTalk オーケストレーション サービスを使用してこの注文を処理する方法、請求書の作成方法、および Northwind 社への返送方法について学びます。最後に Northwind Traders 社がどのように請求書を受け取って格納するかについて考察し、この購入者とサプライヤの間の通信の例を完了します。

下図は本シナリオの残りの部分を示したものです。

レッスン 7 プロセスの概要

このレッスンには次のトピックが含まれます。

  • メッセージ キュー

  • 注文の処理

  • シナリオの実行


メッセージ キュー

レッスン 6 は、Contoso 社側の ASP スクリプトが受信した PO ドキュメントがメッセージ キューに配信されたところで終了しました。またメッセージ キューに入ってくるメッセージを監視し、それらを BizTalk オーケストレーション サービスに配信するメッセージ キュー受信機能の構成についても学びました。到着した PO はファイルに格納せずに、メッセージ キューに入れることにしましたが、これはメッセージ キューがトランザクションをサポートすることで信頼性が向上するためです。この機能はファイル システムには見られないものです。

メッセージ キュー受信機能は、キューからドキュメントを取り出した後、それをチャネルに渡します。チャネルはそのドキュメントを Contoso 社のビジネス プロセス用に作成されたメッセージ ポートに配信します。このメッセージ ポートは、ドキュメントを XLANG スケジュールに転送するように構成されており、レッスン 4 で Northwind traders 社の XLANG スケジュールに渡された Requisition ドキュメントと同様の方法で Contoso 社のビジネス プロセスを実行する XLANG スケジュールを起動します。

「注文の処理」に進みます。


注文の処理

実際の PO を処理するために実施すべき実際の作業は、企業によって異なります。今回のシナリオでは、簡単にするため、Contoso 社の XLANG スケジュール フローチャートに 1 つのアクション シェイプ (Do Some Work) だけを定義しました。これは在庫のチェックや倉庫に対する出荷指示など、実際のサプライヤが行うすべてのアクションを表すものでした。

アクション シェイプの実装はメッセージ ボックスを表示する簡単な Windows スクリプト コンポーネントの ProcessPO.wsc です。これは、PO が実行中であることをユーザーに知らせるメッセージ ボックスを表示します。ここでも Windows Script Component Wizard を使用してこのコンポーネントを作成しました。

もちろん実際のシステムでは BizTalk オーケストレーション サービスによってメッセージ ボックスが表示されることはありません。その理由は単純で、これらのメッセージを観察し承認する、現在サーバーにログオンしているユーザーがいないためです。ユーザーがこのメッセージ ボックスを終了するまで、スケジュールの実行は継続されず、望ましくない影響を招くおそれがあります。電子メール メッセージを送信するか、あるいはほかのアクションを起動する Windows イベント ログ エントリを作成する方が通信手段としては適しています。

Contoso 社の XLANG スケジュール フローチャートを開くには、C:\LearnBizTalk\Schedules\ に移動して ContosoInvoice.skv をダブルクリックします。下の図は、XLANG スケジュール フローチャートで定義されている Contoso 社の BizTalk オーケストレーション サービスを示しています。

Contoso 社の BizTalk オーケストレーション サービスのプロセス

この XLANG スケジュール フローチャートにおいても、XML 通信ウィザードを使用して一切コードを記述することなく、PO ドキュメントからフィールド (この場合は PONumber と Generated フィールド) の個々の値を抽出し、それらをパラメータとしてスクリプト コンポーネントに渡しました。これは、レッスン 4 で Requisition ドキュメントから RequisitionTotal フィールドの値を抽出した方法と同等のものです。

XLANG スケジュール フローチャートの [データ] ページで、これらのフィールドをスクリプト コンポーネントの DoWork メソッドの入力パラメータに接続しました。下図からわかるように、PO 全体ではなく、抽出した 2 つのフィールドだけがコンポーネントに渡されています。

ContosoInvoice データ ページ

このシナリオを実行し、スクリプト コンポーネントが表示するメッセージ ボックスの [OK] をクリックすると、XLANG スケジュールが PO を BizTalk メッセージ サービスに送り返します。PO はそこで別のマップを使って請求書に変換され、その後 HTTP 転送 (Northwind Traders 社が PO を Contoso 社に送るために使用したものと同じ転送方式) によって Northwind Tradoers 社に送信されます。

Northwind Tradors 社側の ASP スクリプトは、請求書を受信するとそれをファイルとして格納し、その後の処理に備えます。現実世界のシナリオでは、オリジナルの注文要求と PO との請求書の突き合わせや請求書情報に基づく社内システムの更新などがこうしたプロセスに含まれます。

「シナリオの実行」に進みます。


シナリオの実行

重要

  • このチュートリアルを使用するためには、LearnBizTalk ディレクトリを C ドライブにコピーし、BizTalk Server のすべてのコンポーネントを C ドライブにインストールする必要があります。これらのファイルを他のドライブおよびディレクトリから実行することもできますが、そうするには、ソース ファイルに対して大幅な変更を行う必要があります。これらの要件の詳細については、「BizTalk Server 2002 の理解」を参照してください。

シナリオの実行

  1. C:\LearnBizTalk\Scripts\ に移動し、L7Post.vbs をダブルクリックします。

    このスクリプトは、レッスン 6 で一時的に中断したメッセージ キュー受信機能をふたたび有効にします。

  2. 注文ドキュメントの ReqToApprove.xml を C:\LearnBizTalk\Documents ディレクトリから C:\LearnBizTalk\Pickup ディレクトリにコピーします。

以下はこのシナリオの流れの概略です。

  1. Northwind Traders 社のファイル受信機能は Pickup ディレクトリに置かれた ReqToApprove.xml というファイルを読み込み、それを BizTalk メッセージ サービスを使って Northwind Traders 社の BizTalk オーケストレーション サービスに送ります。

  2. XLANG スケジュールは RequisitionTotal フィールドの値を抽出し、それが 1,000 ドル未満なので注文要求を承認し、BizTalk メッセージ サービスにその旨を送り返します。

  3. BizTalk メッセージ サービスは BizTalk オーケストレーション サービスから注文要求を受け取り、マップを使用して PO ドキュメントを作成します。次にこのドキュメントは業界標準の HTTP プロトコルによって Contoso 社に送られます。

  4. Contoso 社側の ASP スクリプトはそれを受信し、ドキュメントを抽出し、プライベート メッセージ キューにメッセージとして送信します。

  5. メッセージ キュー受信機能は、キュー内の新しいドキュメントを検出すると、これを取得します。さらに、BizTalk メッセージ サービスを使用して BizTalk オーケストレーション サービスでの処理のために送信します。

  6. XLANG スケジュールは PONumber および Generated フィールドの値を抽出し、スクリプト コンポーネントのメソッドを呼び出します。すると PO の到着がメッセージ ボックスに表示されます。

  7. XLANG スケジュールが PO を BizTalk メッセージ サービスに送り返し、請求書が作成されます。

  8. BizTalk メッセージ サービスはマップを適用して PO を請求書に入れ、HTTP プロトコルを使って Northwind Traders 社に送信します。

  9. Northwind Traders 社の ASP スクリプトはそれを受け取り、ドキュメントを抽出して、C:\LearnBizTalk\Output\ContosoInvoice.xml というファイルとして保存します。

これによってサンプルとして取り上げた 2 つの企業、Northwind Traders 社と Contoso 社の間での内部ビジネス プロセスおよびアプリケーションの統合のプロセスが完了しました。下の図はこのプロセスの構成要素を示しています。これには 2 つの XLANG スケジュール、BizTalk メッセージ サービス、受信機能、ASP ページ、キュー、およびそれらの相関関係が含まれます。

ここで C:\LearnBizTalk\Output ディレクトリを開くと、ContosoInvoice.xml という名前のファイルがあり、その中には Northwind Traders 社が Contoso 社から受け取った請求書が含まれています。

「まとめ」に進みます。


まとめ

これまでの 7 つのレッスンを通じて、購入者とサプライヤとの間に完全な機能を備えた統合プロセスを作成することができました。

ここまでのレッスンを通じて、Microsoft BizTalk Server を理解し、また BizTalk Server によって B2B プロセスの統合に必要な作業が大幅に削減されることがおわかりいただけたと思います。

レッスン中に実行したスクリプトによって変更された BizTalk Server の構成を元に戻すには、C:\LearnBizTalk\Scripts\ ディレクトリにある Cleanup.vbs スクリプトを実行します。このスクリプトが終了したら (メッセージ ボックスにそのように表示されます)、C:\LearnBizTalk ディレクトリおよびそれに含まれているすべてのファイルを削除してかまいません。

BizTalk Server のプロセスを構成する方法についてのステップごとのチュートリアルについては、「BizTalk Server 2002 チュートリアル」を参照してください。「BizTalk Server Tutorial」では、BizTalk エディタ、BizTalk マッパー、BizTalk メッセージ マネージャ、BizTalk Server 管理コンソール、およびBizTalk オーケストレーション デザイナを使用して、企業間自動調達プロセスを実行する方法について説明しています。

BizTalk Server 2002 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。この Web サイトには、製品に関する技術情報、ホワイトペーパー、トレーニングおよびイベント、サードパーティー製品などの情報が掲載されています。


電子調達サンプル

このサンプルでは、Microsoft® BizTalk™ Server 2002 の以下の新しい機能について説明します。

  • BizTalk SEED ウィザード - 取引先との接続の迅速な設定、テストを支援するツール

  • Application Center 2000 の展開

  • Microsoft Operations Manager (MOM) を使用する高度な監視機能

  • インスタンスごとのキューではなく共通キューを使用する新しい XLANG 関連付け

  • HTTP 受信機能

このシナリオでは、企業が複数のサプライヤから製品を購入するビジネス状況を想定します。ここでは Microsoft BizTalk Server 2002、インターネット、および関連付けを使用して、自社とサプライヤの間で行われる調達プロセスを自動化するビジネス ソリューションをセットアップします。このソリューションを電子調達と呼びます。

このシナリオでは、自社のハブをセットアップします。サプライヤとの間で送受信するすべての注文書、請求書、および支払ドキュメントを処理します。このサンプルに付属する EprocSetup アプリケーションは、BizTalk Server、インターネット、および関連付けを使用してこれらのドキュメントを処理し、調達プロセスを完了するように、ハブと 1 つのサプライヤ システムを構成します。この構成が完了した後、DocumentGenerator.vbs スクリプトを実行して、注文書をサプライヤに送信し、サプライヤから請求書が返信され、ハブが支払通知を送信するトランザクションを開始します。最後に、サプライヤが入金確認を送信し、電子調達プロセスが完了します。次の図は、このサンプルで使用するビジネス トランザクションを示しています。

電子調達サンプルが正しく実行された後、Microsoft Application Center 2000 を使用してこの構成をほかのサーバーに展開し、この構成をテスト環境から運用環境に移行する方法について説明します。また、BizTalk SEED ウィザードを使用してサプライヤの構成をパッケージ化し、そのパッケージを自社の Web サイトからほかのサプライヤが簡単にピックアップして実装できるようにする方法について説明します。最後に、Microsoft Operations Manager (MOM) をハブで行われている作業を監視するようにセットアップする方法について説明します。

以降のトピックでは、このシナリオで作業するために必要なセットアップおよび構成について説明します。

  • ユーザーズ ガイド
    • 事前セットアップ

    • 電子調達サンプルの実行
  • プログラミングの注意点

  • オプションの監視および展開の手順
    • Application Center を使った電子調達の展開

    • SEED パッケージの作成

    • 電子調達サンプルのためのMOM カスタム カウンタの作成


ユーザーズ ガイド

このサンプルを実行する前に、関連付けデータベースをアタッチし、電子調達セットアップ プログラムを実行する必要があります。

重要

  • このサンプルの説明では、このサンプルと BizTalk Server 2002 が同じドライブにインストールされていることを前提としています。

  • 電子調達サンプル ファイルをドライブのルート レベルの eProcurementSample という名前のフォルダにコピーする必要があります。これらのサンプル ファイルは、BizTalk Server 2002 CD-ROM のルート レベルの eProcurementSample フォルダにあります。

  • ファイルをドライブにコピーした後、PaymentAckReceived という空のフォルダが ePprocurementSample フォルダのすぐ下にあることを確認します。PaymentAckReceived フォルダがない場合は作成します。

電子調達サンプルを準備して実行するには、次の手順を実行します。

  • 事前セットアップ

  • 電子調達サンプルの実行


事前セットアップ

ここでは、電子調達サンプルを実行するためにシステムを構成する方法について説明します。電子調達サンプルを実行する前に、関連付けデータベースをアタッチし、ハブとサプライヤ システムを構成する必要があります。このシナリオでは、ハブとサプライヤの両方が 1 つの BizTalk Server インストール上に構成されています。実際の運用環境では、ハブとサプライヤは、2 つの完全に独立したエンティティとなります。

前提条件

このサンプルでは、BizTalk Serverを実行しているコンピュータに次のプログラムがインストールされていることを前提としています。

  • Microsoft BizTalk Server 2002

  • Microsoft SQL Server™

  • メッセージ キュー (MSMQ とも呼ばれます)

注

  • このデモの Application Center のセクションを続けて実行する場合は、BizTalk Server をインストールする前に、Application Center をインストールしておく必要があります。

  • また、BizTalk Server のクリーン インストール上でサンプルを実行することをお勧めします。すべての BizTalk Server オブジェクト (ポート、チャネルなど) をすばやく削除する場合は、eProcurementSample ディレクトリにある CleanBTM.vbs スクリプトを実行します。

重要

  • スクリプト CleanBTM.vbs は、BizTalk メッセージ管理データベースからすべての構成情報を削除します。.このスクリプトは、テスト環境でのみ実行する必要があります。

データベースのアタッチ

この手順では、電子調達サンプルで使用する関連付けデータベースを Microsoft SQL Server 2000 を使ってセットアップします。Microsoft SQL Server 7.0 を使用している場合は、「データベースの作成」を参照してください。ハブ用とサプライヤ用の 2 つの関連付けデータベースがあります。これらのデータベースは、グローバル一意識別子 (GUID) および XLANG スケジュールの開始時に生成される TransactionID を取得して保持します。GUID と TransactionID は、このトランザクション中に送受信されるドキュメントを正しいXLANG スケジュールに関連付けるために使用されます。TransactionID は、注文書番号、請求書番号などの識別子です。

注

以下の説明では、SQL Server 2000 が BizTalk Server と同じコンピュータにインストールされていることを前提としています。SQL Server が別のコンピュータにインストールされている場合は、使用する環境に合わせてこれらの説明を変更する必要があります。この手順を開始する前に、CustomCorrelation_Data および SupplierCustomCorrelation_Data データベースのプロパティが読み取り専用に設定されていないことを確認してください。データベース ファイルは、eProcurementSample ディレクトリ内の Databases ディレクトリにあります。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

    SQL Server Enterprise Manager が表示されます。

  2. [Microsoft SQL Server] を展開し、[SQL Server グループ] を展開します。次に、データベースをアタッチするサーバーを展開します。

  3. [データベース] をクリックします。

  4. [操作] メニューの [すべてのタスク] をポイントし、[データベースのアタッチ] をクリックします。

    [データベースのアタッチ] ダイアログ ボックスが表示されます。

  5. 参照ボタン (...) をクリックします。

    [既存のファイルを参照] ダイアログボックスが表示されます。

  6. eProcurementSample ディレクトリ内の Databases ディレクトリに移動します。

  7. CustomCorrelation_Data.MDF をクリックし、[OK] をクリックします。

    処理が正常に完了したことを示すメッセージ ボックスが表示されます。

  8. 同じ手順で eProcurementSample ディレクトリ内の Databases ディレクトリにあるファイル SupplierCustomCorrelation_Data.MDF をアタッチします。

データベースの作成

BizTalk Server インストールで Microsoft SQL Server 7.0 を使用している場合は、次の手順を使用する必要があります。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server 7.0] をポイントし、[Enterprise Manager] をクリックします。

    SQL Server Enterprise Manager が表示されます。

  2. [Microsoft SQL Server] を展開し、[SQL Server グループ] を展開します。次に、データベースをアタッチするサーバーを展開します。

  3. [データベース] をクリックします。

  4. [操作] メニューの [新規データベース...] をクリックします。

    [データベースのプロパティ] メニューが表示されます。

  5. [名前] フィールドに、データベースの名前として「CustomCorrelation」を入力します。

  6. [OK] をクリックします。

  7. [操作] メニューの [新規データベース...] をクリックします。

  8. [データベースのプロパティ] メニューが表示されます。

  9. [名前] フィールドに、データベースの名前として「SupplierCustomCorrelation」を入力します。

  10. [OK] をクリックします。

  11. SQL Server Enterprise Manager を閉じます。

  12. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server 7.0] をポイントし、[クエリ アナライザ] をクリックします。

    [SQL Server の接続] メニューが表示されます。

  13. SQL Server に接続するための正しい情報が入力されていることを確認してください。[OK] をクリックします。

  14. メニュー バーの [DB] フィールドの値が CustomCorrelation であることを確認してください。そうでない場合は、[DB] ドロップダウン リスト ボックスをクリックし、[CustomCorrelation] を選択します。

  15. [ファイル] メニューの [開く] をクリックします。

  16. ディレクトリ内の Databases ディレクトリに移動します。

  17. CustomCorrelationTable.sql ファイルをクリックします。

  18. [クエリ] メニューの [実行] をクリックします。この操作によって、CustomCorrelationTable.sql ファイルが処理されます。SQL ファイルが実行された場合は、次のメッセージが表示されます。コマンドは正常に終了しました。

  19. SupplierCustomCorrelationTable.sql ファイルについても同じ手順を繰り返します。

  20. クエリ アナライザを閉じます。

電子調達の構成のセットアップ

ここでは、セットアップ アプリケーションを実行し、ハブおよびサプライヤの BizTalk Server を、電子調達サンプルを実行するように構成します。

電子調達セットアップ アプリケーションは、次の作業を実行します。

  • 次のメッセージ キューを作成します。

    .\private$\receiveinvoice

    .\private$\receivepayment

    .\private$\receivepaymentack

    .\private$\receivepo

    .\private$\receivepo2

    .\private$\supplierreceivepo

    .\private$\supplierreceivepo2

    キューは、実行中のハブおよびサプライヤの XLANG スケジュールによって表される取引先間のデータの転送に使用されます。

  • 仮想ディレクトリを作成します。

    仮想ディレクトリは、HTTP 受信機能で使用され、取引先がデータを BizTalk Server にデータを送信できるようにします。

    完了すると、仮想ディレクトリ構造は次のようになります。

    エイリアス | Web サイト構造 | ディレクトリ パス
    ハブ | Hub | \Program Files\Microsoft BizTalk Server\HTTP Receive
    入金確認 | hub/paymentack | \Program Files\Microsoft BizTalk Server\HTTP Receive
    サプライヤ | Supplier | \Program Files\Microsoft BizTalk Server\HTTP Receive
    支払通知 | supplier/payment | \Program Files\Microsoft BizTalk Server\HTTP Receive

    注

    • このサンプルで使用するすべての仮想ディレクトリの Application Protection 値は、[低 (IIS Process)] に 設定されます。既定値は、[中程度 (Pooled)] です。
  • チャネルおよびポートの作成

    各チャネルは、メッセージ ポートの既定値を上書きし、メッセージ ラベルを使用してそのメッセージを特定の XLANG スケジュール インスタンスと関連付けるように構成されます。

  • COM コンポーネントの登録

  • ドキュメント仕様の WebDAV フォルダへの移動

  • HTTP 受信機能の作成

  • BizTalk メッセージ管理データベースの構成

  • 必要な DLL の登録

セットアップ アプリケーションを実行する前に、上に挙げたメッセージ キューがどれも存在しないことを確認します。存在するキューがある場合、電子調達サンプルのセットアップは失敗する可能性があります。

電子調達サンプルをセットアップするには、次の手順を実行します。

  1. エクスプローラで、eProcurementSample ディレクトリ内の \COM Components\Setup ディレクトリに移動します。

  2. eProcSetup.exe をダブルクリックします。

    [eProcurement Setup] ダイアログ ボックスが表示されます。

  3. [eProcurement Setup] をクリックします。

    セットアップが正常に完了したことを示すダイアログ ボックスが表示されます。

「電子調達サンプルの実行」に進みます。


電子調達サンプルの実行

電子調達サンプルは、XLANG スケジュール内のユーザ定義フィールドを関連付ける方法を示します。これによって、ドキュメントを一意に識別するデータ値 (注文書番号など) を使用し、その識別子を実行中の XLANG スケジュール インスタンスと関連付けて、ドキュメントをビジネス トランザクションの手順に沿って処理することができます。

このサンプルを実行するには、次の手順を実行します。

  1. \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools にある XLANG Event Monitor を起動します。

  2. エクスプローラで、eProcurementSample ディレクトリに移動します。

  3. DocumentGenerator.vbs をダブルクリックします。

トランザクションが正常に完了したことを確認するには、eProcurementSample ディレクトリ内の PaymentAckReceived ディレクトリに移動します。このディレクトリには、次の命名規則に従った入金確認の XML ファイルが含まれているはずです。payack_{GUID}.xml

サンプルを実行し、ハブで注文書が拒否されるようにするには、PO.xml の [POTotal] の値を 1000 より大きい値に変更します。サンプルを実行し、注文先システムによって注文書が拒否されるようにするには、PO.xml の [POTotal] の 値を 300 未満の値に変更します。PO.xml ファイルは、eProcurementSample ディレクトリにあります。

注

  • 既定では、ハブおよびサプライヤ スケジュールは、C:\EprocurementSample\Script Components\Message.wsc にある Windows スクリプト コンポーネントにバインドされます。コンポーネントがこの場所にない場合、スケジュールは失敗します。この問題を解決するには、BizTalk オーケストレーション デザイナでスケジュールを開き、スクリプト コンポーネント バインド ウィザードを使用してスクリプト ファイルをコンポーネントの正しいドライブおよびパスにバインドし直します。

「プログラミングの注意点」に進みます。


プログラミングの注意点

電子調達 XLANG スケジュールのアクティブ化

このサンプルを実行すると、PO.xml が ReceivePO キューに入れられ、XLANG スケジュールがアクティブになり、電子調達処理が開始されます。HubReceivePO メッセージ ポートは、XLANG スケジュールの新しいインスタンス hub.skx をアクティブにしてから、 ReceivePO ポートにドキュメントを配信します。注文書は、承認された後、ハブに送信されます。ハブは、注文書をサプライヤに送信し、請求書の受信を待ちます。

注文書のサプライヤへの配信には、HTTP 受信機能が使用されます。サプライヤが注文書を受信した後、サプライヤ システムで XLANG スケジュールがアクティブになり、このシステム上で処理が開始されます。SupplierReceivePO メッセージ ポートは、XLANG スケジュールの新しいインスタンス supplier.skx をアクティブにしてから、ドキュメントを ReceivePOfromHub ポートに配信します。注文書が請求書に変換された後、ハブに返送されます。

請求書のハブへの配信には、HTTP 受信機能が使用されます。ハブは請求書を受信し、支払通知を送信します。再び、支払通知のサプライヤへの配信には、HTTP 受信機能が使用されます。サプライヤは支払通知を受信した後、確認メッセージを送信します。ハブで確認メッセージが受信され、\eProcurementSample\PaymentAckReceived にあるファイルに書き込まれると、トランザクションが完了します。

電子調達 XLANG スケジュールの関連付け

XLANG スケジュールのすべてのインスタンスに、XLANG スケジューラ エンジンによって GUID が割り当てられます。このサンプルで、GUID はメッセージから抽出され、関連付けデータベースに格納され、注文書番号や請求書番号などの TransactionID と関連付けられます。

具体的には、ハブが注文書を受信したときに GUID が抽出され、CustomCorrelation データベースに格納され、TransactionID と関連付けられます。サプライヤは注文書を受信する際にその TransactionID を確認しますが、SupplierCustomCorrelation データベースに格納されるサプライヤ独自の GUID および TransactionID も生成します。これらの値は、トランザクションが注文書から請求書に移り、請求書から支払通知に移り、入金確認によって完了する際に、送信メッセージおよび受信メッセージを正しい実行中のスケジュール インスタンスに関連付けるために使用されます。関連付けは実際にはハブが請求書を受信したときに開始し、請求書は正しい注文書および正しい XLANG スケジュールと関連付けられる必要があります。

関連付けの詳細については、次のトピックを参照してください。

XLANG スケジュールの関連付け

インスタンス管理

電子調達サンプルのアンインストール

セットアップ アプリケーションの実行によって作成されるファイルや BizTalk メッセージ構成オブジェクト (ポート、チャネルなど) を削除するためのスクリプトは用意されていません。次の一覧は、このサンプルで使用する BizTalk メッセージ構成オブジェクト、ファイル、フォルダ、およびライブリを示しています。これらは、サンプルの実行を終了したときに、手動で削除することができます。

組織

ハブ、サプライヤ

チャネル

HubReceivePO、HubSendPO、SupplierReceivePO、HubReceiveInvoice、SupplierSendInvoice、HubSendPayment、SupplierReceivePayment、SupplierSendPaymentAck、HubReceivePaymentAck、HubSendPayAckToFile

ドキュメント定義

EcommonInvoice、EcommonPayment、EcommonPO、EPaymentAck

メッセージ ポート

HubReceivePO、HubSendPO、SupplierReceivePO、HubReceiveInvoice、SupplierSendInvoice、HubSendPayment、SupplierReceivePayment、SupplierSendPaymentAck、HubReceivePaymentAck、HubSendPayAckToFile

受信機能 (BizTalk Server 管理コンソール):

HubReceiveInvoice、HubReceivePaymentAck、Receive PO、SupplierReceivePayment、SupplierReceivePO

専用メッセージ キュー (コンピュータの管理)

receiveinvoice、receivepayment、receivepaymentack、receivepo、receivepo2、supplierreceivepo、supplierreceivepo2

BizTalk Server リポジトリ ファイル (WebDAV)

ECommonInvoice.xml、eCommonPayment.xml、ECommonPO.xml、ePaymentAck.xml

登録されているライブラリ

Correlation.dll、HubTransformation.dll、PaymentTransformation.dll、SuppCorrelation.dll、Transformation.dll

\Microsoft BizTalk Server\HTTP Receive の中にあるフォルダ

Hub
Hub/PaymentAck
Supplier
Supplier/Payment

注

  • インターネット インフォメーション サービスの仮想ディレクトリは、これらのフォルダのいずれかと関連付けられます。


オプションの監視および展開の手順

先に進む前に、電子調達サンプルをセットアップし、実行する必要があります。ただし、次の手順は省略できます。

  • 監視および展開の前提条件は次のとおりです。

  • 展開手順を実行するには、Application Center 2000 を実行している必要があります。

  • Microsoft Operations Manager (MOM) セットアップ手順には、高度な監視機能のための MOM 構成が含まれています。この手順には、MOM 2000 および BizTalk Server 2002 Management Pack が必要です。

ここには次のトピックが含まれます。

  • Application Center を使った電子調達の展開

  • SEED パッケージの作成

  • 電子調達サンプルのための MOM カスタム カウンタの作成


Application Center を使った電子調達の展開

Application Center を利用することによって、BizTalk Server の構成を別の環境に展開することができます。たとえば、テスト環境から運用環境へ構成情報を移動する場合などに利用できます。Application Center を使用して環境を展開すれば、構成の移動にかかる時間と、付随する手動で行う設定の量を大幅に削減できます。

このシナリオでは、ハブが 1 つのサーバー (ソース) にあり、BizTalk Server 構成を組織内の別のサーバー (ターゲット) に展開します。この電子調達サンプルでは、ハブおよびサプライヤの構成は同じコンピュータにインストールされています。そのため、構成全体を別の環境に展開する場合は、ハブとサプライヤの両方が含まれます。運用環境では、ハブとサプライヤは別のコンピュータ上にあるため、サプライヤは展開には含まれません。

注

  • BizTalk Server をインストールする前に、Application Center をインストールする必要があります。

Application Center による展開の前提条件は次のとおりです。

  • Application Center によって電子調達を展開するには、2 台のコンピュータに Application Center 2000 をインストールする必要があります。1 台はソース コンピュータとして、もう 1台はターゲット コンピュータとして機能します。また、両方のコンピュータに BizTalk Server 2002 がインストールされ、実行している必要があります。さらに、電子調達サンプルがソース コンピュータにインストールされ、正しく実行している必要があります。

  • Application Center 2000 をインストールした後、Application Center 2000 SP1 をインストールする必要があります。Application Center 2000 SP1 は、BizTalk Server 2002 インストール CD-ROM の Application Center 2000 SP1 ディレクトリにあります。

  • コンピュータ上にまだクラスタが作成されていない場合は、ソース コンピュータおよびターゲット コンピュータの両方でクラスタを作成する必要があります。ソース コンピュータとターゲット コンピュータを別のクラスタに配置して、サンプルが別の環境への展開 (テスト環境から運用環境への展開など) をシミュレートできるようにすることが重要です。

ソースおよびターゲット コンピュータを正しく構成した後、Application Center を使用してソース コンピュータ クラスタ上にアプリケーションを作成します。詳細については、「Application Center 2000 の使用」を参照してください。

このクラスタのリソース タイプには次のものがあります。

  • ファイル システム パス
    • 電子調達サンプルのサイト (例 : \eProcurementSample)
  • Web サイトと仮想ディレクトリ
    • ハブ仮想ディレクトリ

    • サプライヤ仮想ディレクトリ
  • BizTalk
    • BizTalkPorts

    • BizTalkReceiveFunctions

Application Center アプリケーションを作成した後、そのアプリケーションをソース コンピュータからターゲット コンピュータに展開することができます。詳細については、「ターゲット サーバーへの Application Center アプリケーションの展開」を参照してください。

ターゲット コンピュータは別のクラスタの一部であるため、展開ウィザードの [展開ターゲットのオプション] ページで [コンテンツを現在のクラスタ外で展開する] を選択する必要があります。また、展開ウィザードは、展開できるアプリケーションを示すドロップダウン リスト ボックスを表示します。前にソース コンピュータで作成したアプリケーションを展開先に展開するように選択します。

展開が終了したら、ターゲット コンピュータでいくつかの細かな調整を行う必要があります。たとえば、電子調達サンプルで使用される関連付けデータベースが展開中に SQL Server によって使用される場合は、これらのデータベースを Application Center を通じてターゲット コンピュータにコピーすることはできません。

関連付けデータベースをターゲット コンピュータの SQL Server インスタンスに手動でコピーするには、電子調達サンプルの「事前セットアップ」に記載されている "データベースのアタッチ" 機能を使用します。また、SQL Server のデータ変換サービス (DTS) を使用することで、ターゲット コンピュータの SQL Server インスタンスにデータベースをエクスポートできます。

また、電子調達サンプルによって使用される DLL は Application Center を通じてターゲット コンピュータにコピーされますが、ターゲット コンピュータ上では登録されません。必要な DDL を登録するには、\eProcurementSample\Application Center ディレクトリにある RegisterDLLs.vbs スクリプト ファイルを実行します。初めてサンプルをターゲット コンピュータに展開した場合は、このコンピュータ上でメッセージ キューが作成されていない可能性が高くなります。必要なメッセージ キューを作成するには、\eProcurementSample\Application Center ディレクトリの CreateQueues.vbs スクリプト ファイルを実行します。

注

  • 電子調達サンプルによって使用されるすべての BizTalk 受信機能を有効にする必要があります。受信機能は、BizTalk Server 管理コンソール アプリケーションで有効にすることができます。メッセージ キューが作成される前に受信機能が作成されるため、この操作が必要となる場合があります。受信機能のポーリング場所 (ディレクトリ、メッセージ キューなど) にアクセスできない場合、BizTalk Server は自動的に受信機能を無効にします。

最後に、一次ポート アドレスがターゲット サーバーを指し示すように、ターゲット コンピュータの BizTalk ポートを変更する必要があります。Application Center は、BizTalk Server の構成をあるコンピュータからほかのコンピュータに展開する際に BizTalk のポートを変更しません。BizTalk のポートは、ソース サーバーを指し示したままです。次のポートを、ターゲット サーバーを指し示すように編集する必要があります。

  • HubSendPayment

  • HubSendPO

  • SupplierSendInvoice

  • SupplierSendPaymentAck

注

  • これらの変更が適用されるためには、BizTalk のサービスを停止および開始しなければならない場合があります。BizTalk のサービスは、BizTalk Server 管理コンソールで停止および開始することができます。


SEED パッケージの作成

この手順を完了するには、電子調達サンプルがこのサーバーにインストールされ、正しく実行している必要があります。

このサンプルは、ハブが SEED パッケージを作成する方法、サプライヤがSEED パッケージをインストールする方法、およびサプライヤによって SEED パッケージがテストされる方法を示しています。

このシナリオでは、ハブは、このサンプル内のサプライヤ組織と同様の取引先に送信される特定のドキュメント仕様を含む SEED パッケージを作成します。取引先は、SEED パッケージをインストールします。電子調達サンプルでは、1 台のコンピュータ上にハブとサプライヤの両方がセットアップされました。SEED パッケージは、2 つの完全に独立した環境で使用するように設計されています。

ここには次のトピックが含まれます。

  • SEED パッケージの事前セットアップ

  • SEED パッケージの作成


SEED パッケージの事前セットアップ

SEED パッケージを作成する前に、SEED パッケージの インターネット インフォメーション サービス (IIS) 仮想ディレクトリを作成し、必要な .asp ファイルをコピーする必要があります。これらのファイルは、ハブのテスト サイトで使用されます。

SEED パッケージの IIS 仮想ディレクトリの作成

  1. BizTalk Server に SEEDPackage という名前の新規ディレクトリを作成します。このディレクトリは、SEED パッケージ テスト ディレクトリとして機能します。

  2. SEEDPackage ディレクトリに、SeedTestSite、SeedDropSite、およびSeedReceiveSite という名前の 3 つの新しいディレクトリを作成します。

  3. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[インターネット サービス マネージャ] をダブルクリックします。一覧にある現在のコンピュータを展開します。

  4. [既定の Web サイト] を右クリックし、[新規作成] をポイントします。次に ［仮想ディレクトリ] をクリックします。[仮想ディレクトリの作成ウィザード] が表示されます。

  5. [次へ] をクリックします。仮想ディレクトリのエイリアスを要求する新しい画面が表示されます。[エイリアス] フィールドに「SeedTestSite」と入力し、[次へ] をクリックします。

  6. 仮想ディレクトリがポイントする場所を要求する新しい画面が表示されます。[参照] ボタンを使用して、前に作成した SeedTestSite ディレクトリ を探すか、または [ディレクトリ] フィールドに SeedTestSite ディレクトリのフル パスを入力します。[次へ] をクリックします。

  7. 仮想ディレクトリのアクセス許可を変更するための新しい画面が表示されます。既定の設定を使用し、[次へ] をクリックします。次の画面で [完了] をクリックします。

必要なファイルのコピー

\Program Files\Microsoft BizTalk Server\SEED にある SEED ディレクトリから次の .asp ファイルをコピーします。

  • LocalSubmit.asp

  • SlingBack.asp

  • Trigger.asp

これらのファイルを、前に作成した SeedTestSite ディレクトリに貼り付けます。SlingBack.asp および Trigger.asp ファイルは、受信ドキュメントと送信ドキュメントをリモート テストするためにハブによって使用されます。LocalSubmit.asp は、送信ドキュメントをリモート テストするためにサプライヤによって使用されます。これらの .asp ファイルの使用の詳細については、「SEED の ASP ページについて」を参照してください。

「SEED パッケージの作成」に進みます。


SEED パッケージの作成

SEED パッケージは、ハブによって作成され、サプライヤが使用することができます。ハブが新しいサプライヤとのパートナーシップをセットアップしたとき、新しいサプライヤは SEED パッケージをダウンロードし、インストールして、ハブのテスト サイトへのドキュメントの送信を開始します。問題がない場合は、サプライヤはこの構成を運用環境に統合し、ハブとの電子調達トランザクションを開始できます。次の手順では、SEED パッケージをセットアップ、インストール、およびテストする方法を示します。

注

  • この電子調達サンプルでは、1 台のコンピュータ上にハブとサプライヤの両方がセットアップされました。SEED パッケージは、2 つの独立した環境で使用するように設計されています。

SEED パッケージを使用するには、次の手順を実行します。

  • 共通の PO 仕様の追加

  • 共通の請求書仕様の追加

  • 共通の支払仕様の追加

  • 入金確認仕様の追加

  • SEED パッケージ作成の完了

  • SEED パッケージのインストール

  • SEED パッケージ仕様のテスト


共通の PO 仕様の追加

ハブによって作成される SEED パッケージには、CommonPO ドキュメント仕様が含まれます。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk SEED ウィザード] をクリックします。

  2. [BizTalk SEED ウィザード] が表示されます。既定では、[SEED パッケージを作成] が選択されています。[次へ] をクリックします。

  3. 組織名を入力するフィールドに「Hub」と入力し、[次へ] をクリックします。

  4. [パッケージの作成処理 – ドキュメントの仕様] ページが表示されます。[追加] をクリックします。

  5. [仕様] フィールドの隣の [参照] をクリックします。EProcurement ディレクトリをダブルクリックします。ECommonPO.xml ドキュメント仕様をダブルクリックします。これによって、自動的に [仕様] フィールドにスキーマ ファイルの場所が入力されます。

  6. [テスト インスタンス] フィールドの隣の [参照] をクリックします。eProcurementSample ディレクトリに移動します。eProcurementSample ディレクトリ内の Instances ディレクトリをダブルクリックします。Instances ディレクトリにある CommonPO_Instance.xml をダブルクリックします。これによって、[テスト インスタンス] フィールドにインスタンス ファイルの場所が入力されます。

  7. [ハブが送信] オプションが選択されていることを確認してください。

  8. [リモート テスト URL] フィールドのエントリは、前に作成した SEED パッケージ仮想ディレクトリ サイトと Trigger.asp ファイルを指定します。エントリは、http://<サーバー名>/SeedTestSite/Trigger.asp のようになります。Trigger.asp ファイルは、送信ドキュメントのリモート テストに使用されます。

  9. [OK] をクリックします。

「共通の請求書仕様の追加」に進みます。


共通の請求書仕様の追加

ハブによって作成される SEED パッケージには、CommonInvoice ドキュメント仕様も含まれます。

  1. [パッケージの作成処理 – ドキュメントの仕様] ページで [追加] をクリックします。これによって、テスト用として SEED パッケージに含まれるもう 1 つのドキュメントが追加されます。

  2. [仕様] フィールドの隣の [参照] をクリックします。EProcurement ディレクトリをダブルクリックします。eCommonPayment.xml ドキュメント仕様をダブルクリックします。

  3. [テスト インスタンス] フィールドの隣の [参照] をクリックします。eProcurementSample ディレクトリに移動します。eProcurementSample ディレクトリ内の Instances ディレクトリをダブルクリックします。Instances ディレクトリにある CommonInvoice_Instance.xml をダブルクリックします。

  4. [ハブが受信] オプションが選択されていることを確認してください。

  5. [リモート テスト URL] フィールドのエントリは、前に作成した SEED パッケージ仮想ディレクトリ サイトと SlingBack.asp ファイルを指定します。エントリは、http://<サーバー名>/SeedTestSite/SlingBack.asp のようになります。Slingback.asp ファイルは、受信ドキュメントのテストに使用されます。

  6. この練習はサンプルの SEED パッケージを作成する方法を示すことが目的のため、実際の運用サイトを指定しません。したがって、[運用 URL] フィールドには、[リモート テスト URL] フィールドの値をコピーしてください。実際の運用環境では、このフィールドに運用サイト情報を入力します。

  7. [OK] をクリックします。

「共通の支払仕様の追加」に進みます。


共通の支払仕様の追加

ハブによって作成される SEED パッケージには、CommonPayment ドキュメント仕様も含まれます。

  1. [パッケージの作成処理 – ドキュメントの仕様] ページで [追加] をクリックします。これによって、テスト用として SEED パッケージに含まれるもう 1 つのドキュメントが追加されます。

  2. [仕様] フィールドの隣の [参照] をクリックします。EProcurement ディレクトリをダブルクリックします。ePaymentAck.xml ドキュメント仕様をダブルクリックします。

  3. [テスト インスタンス] フィールドの隣の [参照] をクリックします。eProcurementSample ディレクトリに移動します。eProcurementSample ディレクトリ内の Instances ディレクトリをダブルクリックします。Instances ディレクトリにある CommonPayment_Instance.xml をダブルクリックします。

  4. [ハブが送信] オプションが選択されていることを確認してください。

  5. [リモート テスト URL] フィールドのエントリは、前に作成した SEED パッケージ仮想ディレクトリ サイトと Trigger.asp ファイルを指定します。エントリは、http://<サーバー名>/SeedTestSite/Trigger.asp のようになります。このファイルの詳細については、「SEED の ASP ページについて」を参照してください。

  6. [OK] をクリックします。

「入金確認仕様の追加」に進みます。


入金確認仕様の追加

ハブによって作成される SEED パッケージには、Payment Acknowledgement ドキュメント仕様も含まれます。

  1. [パッケージの作成処理 – ドキュメントの仕様] ページで [追加] をクリックします。これによって、テスト用として SEED パッケージに含まれるもう 1 つのドキュメントが追加されます。

  2. [仕様] フィールドの隣の [参照] をクリックします。EProcurement ディレクトリをダブルクリックします。EPaymentAck.xml ドキュメント仕様をダブルクリックします。

  3. [テスト インスタンス] フィールドの隣の [参照] をクリックします。eProcurementSample ディレクトリに移動します。eProcurementSample ディレクトリ内の Instances ディレクトリをダブルクリックします。Instances ディレクトリにある PaymentAck_Instance.xml をダブルクリックします。

  4. [ハブが受信] オプションが選択されていることを確認してください。

  5. [リモート テスト URL] フィールドのエントリは、前に作成した SEED パッケージ仮想ディレクトリ サイトと SlingBack.asp ファイルを指定します。エントリは、http://<サーバー名>/SeedTestSite/SlingBack.asp のようになります。Slingback.asp ファイルは、受信ドキュメントのテストに使用されます。このファイルの詳細については、「SEED の ASP ページについて」を参照してください。

  6. この練習はサンプルの SEED パッケージを作成する方法を示すことが目的のため、実際の運用サイトを指定しません。したがって、[運用 URL] フィールドには、[リモート テスト URL] フィールドの値をコピーしてください。実際の運用環境では、このフィールドに運用サイト情報を入力します。

  7. [OK] をクリックします。

「SEED パッケージ作成の完了」に進みます。


SEED パッケージ作成の完了

  1. [パッケージの作成処理 - ドキュメントの仕様] メニューで [次へ] をクリックします。

  2. [参照] をクリックして、前に作成した SEEDPackage ディレクトリに移動します。SEED パッケージに SamplePackage.xml という名前を付けます。

  3. [完了] をクリックします。SEED パッケージが正常に作成されたことを示すメッセージ ボックスが表示されます。[OK] をクリックします。

「SEED パッケージのインストール」に進みます。


SEED パッケージのインストール

ハブは、SEED パッケージをハブの Web サイトに配置して、サプライヤがダウンロードできるようにします。サプライヤは、SEED パッケージをダウンロードし、BizTalk SEED ウィザードを使用して構成を完了します。この SEED サンプルは、1 台のコンピュータ上で作成、インストール、および展開されるように設計されています。実際のシナリオでは、SEED パッケージは、作成したコンピュータとは別のコンピュータにインストールされます。

SEED パッケージをサプライヤ システムにインストールすると、必要なポート、チャネル、ドキュメント定義、および受信機能が作成されます。それぞれのポート、チャネル、ドキュメント定義、および受信機能のタイトルは、SEED パッケージの名前で始まります。この名前付け方式によって、SEED パッケージ オブジェクトには一意な名前が付けられ、既存のオブジェクトを作成することが避けられます。また、この名前付け方式によって、これらのオブジェクトを BizTalk Server 上に既にインストールされている可能性があるその他の SEED パッケージ オブジェクトと区別することもできます。

この手順では、SEED パッケージがサーバーからアクセスできるリポジトリ内にあると想定しています。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk SEED ウィザード] をクリックします。

  2. [BizTalk SEED ウィザード] が表示されます。[SEED パッケージをインストール] オプションが選択されていることを確認してください。[次へ] をクリックします。

  3. [パッケージ ファイル] フィールドの隣の [参照] をクリックします。SEEDPackage ディレクトリに移動します。SamplePackage.xml ファイルをダブルクリックします。

  4. これにより、SEED パッケージ情報 (パッケージ ID、組織など) が表示されます。[次へ] をクリックします。[パッケージのインストール処理 - テストの情報] ページの設定を既定のままにして、[次へ] をクリックします。

  5. 次の画面に、SEED パッケージの一部であるドキュメントが表示されます。EcommonPO.xml 仕様を選択し、[設定] をクリックします。

  6. [運用 URL] フィールドに、「http://<サーバー名>/SeedTestSite/localsubmit.asp」と入力します。localsubmit.asp ファイルは、送信ドキュメントのリモート テストに使用されます。このファイルの詳細については、「SEED の ASP ページについて」を参照してください。

  7. [最終的な格納場所] フィールドの隣の [参照] をクリックします。前に作成した SEEDPackage ディレクトリ内の SeedDropSite ディレクトリに移動して [OK] をクリックします。SeedDropSite ディレクトリが選択されていることを確認してください。[OK] をクリックします。

  8. ECommonInvoice.xml 仕様を選択し、[設定] をクリックします。

  9. [場所] フィールドの隣の [参照] をクリックします。前に作成した SEEDPackage ディレクトリ内の SeedReceiveSite ディレクトリに移動して [OK] をクリックします。SeedReceiveSite ディレクトリが選択されていることを確認してください。[OK] をクリックします。

  10. [ポーリングするファイルの種類] フィールドに「CommonInvoice_Instance.xml」と入力します。

  11. [テスト用の格納場所] フィールドの隣の [参照] をクリックします。前に作成した SEEDPackage ディレクトリ内の SeedDropSite ディレクトリに移動して [OK] をクリックします。SeedDropSite ディレクトリが選択されていることを確認してください。[OK] をクリックします。

  12. [OK] をクリックします。

  13. eCommonPayment.xml 仕様を選択し、[設定] をクリックします。

  14. [運用 URL] フィールドに、「http://<サーバー名>/SeedTestSite/localsubmit.asp」と入力します。localsubmit.asp ファイルは、送信ドキュメントのリモート テストに使用されます。このファイルの詳細については、「SEED の ASP ページについて」を参照してください。

  15. [最終的な格納場所] フィールドの隣の [参照] をクリックします。前に作成した SEEDPackage ディレクトリ内の SeedDropSite ディレクトリに移動して [OK] をクリックします。SeedDropSite ディレクトリが選択されていることを確認してください。[OK] をクリックします。

  16. ePaymentAck.xml 仕様を選択し、[設定] をクリックします。

  17. [場所] フィールドの隣の [参照] をクリックします。前に作成した SEEDPackage ディレクトリ内の SeedReceiveSite ディレクトリに移動して [OK] をクリックします。SeedReceiveSite ディレクトリが選択されていることを確認してください。[OK] をクリックします。

  18. [ポーリングするファイルの種類] フィールドに「PaymentAck_Instance.xml」と入力します。

  19. [テスト用の格納場所] フィールドの隣の [参照] をクリックします。前に作成した SEEDPackage ディレクトリ内の SeedDropSite ディレクトリに移動して [OK] をクリックします。SeedDropSite ディレクトリが選択されていることを確認してください。[OK] をクリックします。

  20. [OK] をクリックします。

「SEED パッケージ仕様のテスト」に進みます。


SEED パッケージ仕様のテスト

この時点で、すべてのドキュメント仕様の状態が [設定 完了] になっている必要があります。この時点では、SEED アプリケーションは、まだ新しいオブジェクト (受信機能、ポート、チャネルなど) を作成していません。サプライヤは、次の手順を実行して、SEED パッケージをテストする必要があります。

  1. ECommonPO.xml 仕様を選択します。[作成] をクリックします。SEED アプリケーションによって必要なオブジェクトが作成された後、仕様の状態は [作成 成功] に変わる必要があります。このプロセスは、残りのすべての仕様に対して繰り返されます。各仕様が作成された後、[ローカル テスト] ボタンが有効になります。

  2. ECommonPO.xml 仕様を選択します。[ローカル テスト] をクリックします。仕様がローカル テストに成功した後、その状態が [ローカル テスト 成功] に変わり、[リモート テスト] ボタンが有効になります。SEED アプリケーションはローカル テストを実行するときに、特定の仕様のインスタンスを作成し、それを検証のために対応するチャネルに直接送信します。この場合、チャネルは SamplePackage_ECommonPO です。これによって、ドキュメントの形式が正しいことが確認されます。インスタンスの形式が正しい場合、SEED パッケージ内の仕様のステータスが更新されます。このプロセスは、残りのすべての仕様に対して繰り返されます。受信ドキュメントのローカル テスト処理は異なります。SEED のローカル テストの詳細については、「SEED の ASP ページについて」を参照してください。

  3. ECommonPO.xml 仕様を選択します。[リモート テスト] をクリックします。仕様がリモート テストに成功した後、その状態が [リモート テスト 成功] に変わり、[展開] ボタンが有効になります。送信仕様では、[展開] ボタンは有効になりません。SEED アプリケーションはリモート テストを実行するときに、特定の仕様のインスタンスを作成し、それを SEED パッケージの作成時に指定された、ハブ上にある trigger.asp ページへのリモート テスト URL に HTTP Post を介して送信します。trigger.asp ページは、そのインスタンスをサプライヤに返送し、サプライヤでドキュメント形式が検証されます。インスタンスの形式が正しい場合、SEED パッケージ内の仕様のステータスが更新されます。このプロセスは、残りのすべての仕様に対して繰り返されます。受信ドキュメントのリモート テスト処理は異なります。SEED のリモート テストの詳細については、「SEED の ASP ページについて」を参照してください。

  4. ECommonInvoice.xml 仕様を選択します。[展開] をクリックします。仕様が展開テストに成功した後、その状態は [展開 成功] に変わります。ePaymentAck.xml 仕様について、この手順を繰り返します。

  5. 両方の仕様を展開した後、[次へ] をクリックします。[完了] をクリックします。

注

  • この手順で SEED によって作成されるポートおよびチャネルは、電子調達サンプルの一部ではありません。電子調達サンプルでは、ポートおよびチャネルは既に構成されています。ここで説明する SEED 手順は、例示のみを目的としています。

    実際のシナリオでは、顧客はこの時点で、SEED が提供するメッセージ構成を基にして自分のスケジュールを作成します。電子調達のシナリオでは、サプライヤ スケジュールは、ハブとのビジネスを行うために必要なメッセージ構成を基に既に開発されています。


電子調達サンプルのための MOM カスタム カウンタの作成

ハブ システムの管理者は、サプライヤとのトランザクションを監視することができます。Microsoft Operations Manager (MOM)を使用すると、ハブ コンピュータの管理者は、サプライヤとの間で送受信されるドキュメントをカウントするための規則をセットアップできます。サンプルのこの部分では、サプライヤから受信した CommonInvoice ドキュメントを追跡するための MOM 規則を作成するために必要な操作について詳しく説明しています。

以下の手順は、高度な監視機能のために MOM および BizTalk Server 2002 Management Pack がインストールされている場合にのみ実行できます。MOM の結果を読み取るには、電子調達サンプルが構成され、実行されている必要があります。

MOM でカスタム カウンタを作成して使用するには、次の手順を実行します。

  • カスタム カウンタのセットアップ

  • MOM 規則の作成

  • Agent への規則の配布

  • MOM での結果の読み取り


カスタム カウンタのセットアップ

次の手順によって、CommonInvoice ドキュメント用の BizTalk Server Windows Management Instrumentation (WMI) カスタム カウンタを作成します。作成されるカスタム カウンタは、追跡データベースを読み取り、最後の 300 秒間に処理された CommonInvoice ドキュメントの数を返します。

注

  • このスクリプトは、BizTalk Server および MOM Agent を実行しているコンピュータ上で実行される必要があります。

カスタム カウンタをセットアップするには、以下の手順を実行します。

  1. \eProcurementSample\Operations Manager を参照します。

  2. CustomCounter_eProcurement_CommonInvoice.vbs をダブルクリックします。

  3. 検証チェック メッセージ ボックスが表示されます。[OK] をクリックします。

「MOM 規則の作成」に進みます。


MOM 規則の作成

次の手順を実行するには、BizTalk Server 2002 Management Pack がインストールされていて、MOM の操作にある程度慣れている必要があります。

MOM 規則を作成するには、MOM 管理コンソールを起動する必要があります。すべての作業は、このコンソール内で行われます。

イベント収集規則グループの作成

Microsoft BizTalk Server という名前のProcessing Rule グループ フォルダには、最初は Computer グループ割り当ては含まれていません。割り当てがない場合、フォルダ内に配置される規則はどれも、MOM Agent に伝達されません。

  1. [MOM Administrator Console] で [Rules] を展開し、次に [Processing Rule Groups] を展開します。

  2. [Microsoft BizTalk Server] フォルダを右クリックし、[プロパティ] をクリックします。

    これにより、そのフォルダの [Processing Rule Group Properties] ダイアログ ボックスが表示されます。

  3. [Computer Groups] タブをクリックします。

    これにより、このフォルダに接続されているコンピュータ グループの一覧が表示されます。

  4. 一覧が空白の場合は、[Add] をクリックします。

    すべての MOM コンピュータ グループの一覧を含む [Select Item] ダイアログ ボックスが表示されます。

  5. [Microsoft BizTalk Server 2002 Enterprise Edition] を選択します。

  6. [OK] をクリックして、[Select Item] ダイアログ ボックスを閉じます。

  7. [OK] をクリックしてプロパティのダイアログ ボックスを閉じます。

MOM 警告処理規則の作成

  1. [MOM Administrator Console] で [Rules] を展開し、次に [Processing Rule Groups] を展開し、[Microsoft BizTalk Server] を展開します。

  2. [Performance Processing Rules] を右クリックし、[新規作成] をポイントします。次に [Performance Processing Rule] をクリックします。

    [Performance Processing Rule Type] ダイアログ ボックスが表示されます。

  3. [Compare Performance Data (Threshold)] をクリックします。

  4. [次へ] をクリックします。

    [Threshold Processing Rule Properties – Data Provider] ダイアログ ボックスが表示されます。

  5. [New] をクリックし、新しいデータ プロバイダを作成します。

    [Select Provider Type] ダイアログ ボックスが表示されます。

  6. [WMI Numeric Events] をクリックし、[OK] をクリックします。

    [WMI Numeric Provider Properties] ダイアログ ボックスが表示されます。

  7. 次のフィールドに情報を入力します。
    • [Provider name] : Custom Counter for CommonInvoice Documents

    • [WMI Namespace] : root\MicrosoftBiztalkServer

    • [Class of Object to be measured] : MSBTS_CustomCounter

    • [Object Instance Expression] : Name = "Custom Counter for CommonInvoice Documents"

    • [Numeric property to sample] : MatchCount

    • [Text Property to be Instances] : Name

    • [Sample Every] : 10 seconds

注

  • サンプルの間隔を小さな値に設定すると、MOM Consolidator として機能しているコンピュータと MOM Agent を実行しているコンピュータの両方のパフォーマンスに影響を与える場合があります。
  8. [次へ] をクリックします。

  9. [Synchronize at] チェック ボックスをオフにしたまま、[完了] をクリックしてこのダイアログ ボックスを閉じます。

  10. [Threshold Processing Rule Properties] ダイアログボックスの [次へ] をクリックします。

  11. [Specify optional schedule] のページで、既定の設定である [Always process data] を使用して、[次へ] をクリックします。

  12. [Select the properties that you would like to match] ページの既定の設定 (どのチェック ボックスもオンになっていない) を使用して、[次へ] をクリックします。

  13. [Specify the threshold value you would like to match] ページの既定の設定を使用します。

    これによって、カウンタが 0 を超えたときに MOM システムが警告を生成します。

  14. [次へ] をクリックします。

  15. [Specify whether a match to this rule generates an alert] ページで[Generate alert] をオンにして、[Alert severity] ボックスの一覧で [Success] をクリックし、[Owner] ボックスに「E-Procurement Sample」と入力します。その他のすべてのフィールドで、既定の設定を使用します。

  16. [次へ] をクリックします。

  17. 条件に一致するたびに警告を受け取るようにする場合は、[Define the handling of duplicate alerts] ページの [Suppress duplicate alerts] チェック ボックスをオフにします。チェック ボックスをオンにした場合は、警告を 1 回だけ受け取ります。

  18. [次へ] をクリックします。

  19. [Define any response actions] ページで、[次へ] をクリックします。

  20. [Company Knowledge Base] ページで [次へ] をクリックします。

  21. [Specify the Comments for the Knowledge Base Entry] ページで既定の設定を使用して、[次へ] をクリックします。このページは、MOM Knowledge Authorizing License がインストールされている場合にのみ表示されます。

  22. [Specify the advanced setting properties] ページで既定の設定を使用して、[次へ] をクリックします。このページは、MOM Knowledge Authorizing License がインストールされている場合にのみ表示されます。

  23. [Enter a name for the processing rule] ページで「eProcurement-CustomCounter for CommonInvoice」と入力し、[完了] をクリックします。

「Agent への規則の配布」に進みます。


Agent への規則の配布

この時点で規則が更新されますが、処理のために MOM Agent に発行されません。Agent に規則を配布するには、MOM Consoleの [Rules] を右クリックし、[Commit Configuration Change] をクリックします。MOM システムが規則を Agent に転送するのに数分かかる場合があります。

「MOM での結果の読み取り」に進みます。


MOM での結果の読み取り

電子調達サンプル スクリプトを実行するたびに、ハブ スケジュールで CommonInvoice ドキュメントが生成されます。たとえば、DocumentGenerator.vbs をすばやく 3 度実行した場合、MOM Agent は、CustomCounter の値をサンプリングし、警告をトリガします。

警告を表示するには、MOM Consoleの [Monitor] フォルダを展開し、[All Open Alerts] をクリックします。緑のチェック マークが付いた、重要度 [Success] の警告が少なくとも 1 つあるはずです。[Owner] 列には [e-procurement sample] と表示されています。


BizTalk Server 2002 の管理

Microsoft® BizTalk™ Server 2002 の管理は、次のように分割されています。

BizTalk Server 2002 のインストール

ここでは BizTalk Server 2002 のインストールについて説明します。ハードウェア要件とソフトウェア要件のガイドライン、およびサーバー、クライアント、カスタムの各インストールに関する指示が含まれています。詳細については、「BizTalk Server 2002 のインストール」を参照してください。

セキュリティについて

ここでは、BizTalk Server 2002 を使用する場合に、企業がどのようにしてデータを安全に交換するかを説明します。BizTalk Server は Microsoft Windows 2000 に含まれるセキュリティ機能を利用します。詳細については、「セキュリティについて」を参照してください。

パフォーマンスとスケーラビリティの強化

ここでは BizTalk Server のパフォーマンス強化とスケーラブルなソリューション構築について説明します。ここで取り扱う問題およびガイドラインには、潜在的な障害の認識、待ち時間、およびデータベース管理が含まれます。スケーラブルでハイパフォーマンスなソリューション構築の詳細については、「パフォーマンスとスケーラビリティの強化」を参照してください。

サーバーとアプリケーションの管理

ここではサーバーおよび XLANG に関連するアプリケーションの管理方法について説明します。ここで取り扱う内容には、複数のグループにあるサーバーの集中的な構成および管理、受信機能の構成と管理、共有キューの管理、および XLANG スケジュールを提供する COM+ アプリケーションの管理が含まれます。詳細については、「サーバーとアプリケーションの管理」を参照してください。

ドキュメントの追跡

ここでは BizTalk Server 2002 によって処理されるインターチェンジおよびドキュメントの追跡方法について説明します。ここで取り扱う内容には、クエリと高度なクエリの作成方法、インターチェンジ、ドキュメント、およびカスタム検索データの保存方法、インターチェンジ レコード、ドキュメント レコード、および受信確認の結果の概要が含まれます。詳細については、「ドキュメントの追跡」を参照してください。

ドキュメントの監視

ここでは、BizTalk Server 2002 Enterprise Edition Management Pack for Microsoft Operations Manager (MOM) について説明します。ここでは、この Management Pack で、BizTalk Server 固有のイベントの監視によって MOM 機能を強化するために利用できる、表示パフォーマンス カウンタ、Microsoft Windows NT® イベント ルール、ユーザー構成ルール、およびビューについて説明しています。詳細については、「ドキュメントの監視」を参照してください。

注

  • コンポーネント サービスや管理ツールなどのさまざまな Windows 2000 サービスおよびツールを開くファイル パスは、Windows 2000 Server か Windows 2000 Professional のどちらを使用しているかによって異なります。詳細については、「コンポーネント サービスを開く」を参照してください。

    Microsoft BizTalk Server 2002 ヘルプでは、これらのサービスおよびツールへのパスは Windows 2000 Server に基づいています。Windows 2000 Professional を使用している場合、利用するサービスおよびツールの開き方については、Windows 2000 Professional ヘルプを参照してください。

関連項目

BizTalk Server の管理モデル


BizTalk Server 2002 のインストール

『Microsoft® BizTalk™ Server 2002 インストール ガイド』へようこそ。ここでは、ハードウェアとソフトウェアの要件のガイドラインを示すと共に、次のインストール オプションについて詳細に説明します。

  • サーバー インストール : BizTalk Server 2002 のすべてのサービス、ツール、およびサンプルを完全にインストールできます。

  • クライアント インストール : BizTalk オーケストレーション デザイナ、BizTalk エディタ、BizTalk マッパー、BizTalk Server 管理コンソール用 Microsoft 管理コンソール (MMC) スナップイン、BizTalk Server 2002 ヘルプなど、BizTalk Server 2002 クライアントを完全にインストールできます。BizTalk Server 2002 のパーサー、シリアライザ、関連付けコンポーネント、およびランタイム コンポーネントはインストールされません。

  • カスタム インストール : BizTalk Server 2002 のツールとサービスそれぞれを任意に組み合わせたカスタム インストールを実行できます。

  • アップグレード インストール : BizTalk Server 2000 のツールとサービスを BizTalk Server 2002 のツールとサービスにアップグレードできます。

  • サイレント インストール : コマンド ラインからプロパティ値を指定することによって、BizTalk Server 2002 をサイレントに (常に対話や入力を求められることなく) インストールできます。

  • BizTalk Server 2002 の削除 : BizTalk Server 2002 のインストールを削除できます。

ここには次のトピックが含まれます。

  • インストールのチェックリスト

  • ハードウェアとソフトウェアの要件

  • インストールに関する説明


インストールのチェックリスト

このチェックリストは、Microsoft® BizTalk™ Server 2002 とすべてのコンポーネントの完全なインストールに必要なセットアップの手順を示しています。各項目には、実施すべき手順への参照が示されています。このチェックリストは、印刷してセットアップ時に参照することをお勧めします。

手順 | 参照情報
ハードウェアの要件を確認します。 | ハードウェアの最小要件
必要なソフトウェアを確認します。 | 必要なソフトウェア
最新情報を示すリリース ノートを参照します。 | リリース ノートは、BizTalk Server インストール CD のルート ディレクトリに保存されています。
Microsoft Windows® 2000 をインストールします。 | Windows 2000 の前提条件とインストール要件
メッセージ キューのインストール | メッセージ キューのインストール
インターネット インフォメーション サービス (IIS) をインストールします。 | インターネット インフォメーション サービス (IIS) のインストール
インターネット インフォメーション サービス (IIS) を構成します。 | BizTalk Server 2002 用の IIS 設定の構成
Windows 2000 のサービスパックをインストールします。 | Windows 2000 Service Pack 2 のインストール
ユーザー アカウントを Windows 2000 の Administrators グループに追加して、BizTalk Server のサービス アカウントを作成します。 | サービス アカウントの設定
Microsoft SQL Server™ をインストールします。 | SQL Server の前提条件とインストール要件
SQL Server のサービス パックをインストールします。 | SQL Server のサービス パックのインストール
SQL Server が実行中であることを確認します。 | SQL Server が実行中であることの確認
SQL Server のログイン アカウントを追加します (SQL Server のリモート インストール用)。 | SQL Server と BizTalk Server 2002 データベース間の相互作用
Microsoft Visio® 2002 をインストールします。 | Visio 2002 のインストール
Microsoft Application Center 2000 SP1 をインストールします。 | Application Center 2000 のインストール
BizTalk Server 2002 をインストールします。 | インストールに関する説明
SQL Server をリモート コンピュータにインストールする場合には、リモート データベースへのアクセス許可を作成します。 | SQL Server と BizTalk Server 2002 データベース間の相互作用
COM+ アプリケーションを対話型ユーザー以外で実行するように構成します。 | COM+ アプリケーションのアプリケーション ID の変更
World Wide Web Publishing Service を開始します。 | World Wide Web Publishing Service の開始
BizTalk ドキュメント トラッキング用に Internet Explorer を構成します。 | BizTalk ドキュメント トラッキングの構成


ハードウェアとソフトウェアの要件

ここでは、Microsoft BizTalk Server 2002 をインストールする場合のハードウェアの最小要件と構成のオプションについて説明します。また、BizTalk Server 2002 に必要なソフトウェアをインストールする方法も説明します。

ここには次のトピックが含まれます。

  • ハードウェアの最小要件

  • ドキュメント メッセージ処理のパフォーマンス最大化のための推奨構成

  • 必要なソフトウェア

  • Windows 2000 の前提条件とインストール要件

  • SQL Server の前提条件とインストール要件

  • Visio 2002 のインストール

  • Application Center 2000 のインストール


ハードウェアの最小要件

Microsoft BizTalk Server 2002 のサーバー インストールのハードウェア最小要件は次のとおりです。

  • 400 MHz 以上の Intel® Pentium® CPU または互換の CPU

  • 256 MB の RAM

  • 6 GB のハードディスク空き容量

  • CD-ROM ドライブ

  • ネットワーク アダプタ カード

  • VGA または Super VGA モニタ

  • Microsoft マウス、または互換性のあるポインティング デバイス

注

  • BizTalk Server 2002 のインストール時に、コンピュータ上のハードディスクの空き容量が確認されます。サーバー インストールには約 52 MB のハードディスク容量が必要です。ただし、これには BizTalk メッセージ管理データベース、追跡データベース、共有キュー データベース、およびオーケストレーション データベースに必要なハードディスク容量は含まれていません。クライアント インストールには約 30 MB のハードウェア容量が必要です。カスタム インストールには、インストールするサービスおよびツールに応じて、約 2 ～ 52 MB が必要です。ただし、これにはデータベースに必要なハードディスク容量は含まれていません。


ドキュメント メッセージ処理のパフォーマンス最大化のための推奨構成

ここでは、Microsoft BizTalk Server 2002 の最大のパフォーマンスを得るために役立つガイドラインを示します。

  • 3 台のコンピュータで構成します。3 台のコンピュータによる構成では、1 台目のコンピュータに BizTalk Server 2002、2 台目のコンピュータに追跡データベース、3 台目のコンピュータに BizTalk メッセージ管理データベースと共有キュー データベースをインストールします。

  • 1 台のサーバーですべての処理および受信機能を実行するよりも、BizTalk Server 2002 サーバー 2 台の構成にし、1 台を処理用、もう 1 台を受信用としたほうがパフォーマンスが改善されます。

  • 物理的にハード ディスクを複数搭載しているコンピュータに追跡データベースをインストールします。最適な構成は、4 台の SCSI II ハード ディスクと 1 台の SCSI II コントローラからなるものです。1 台目のハード ディスクは、ドキュメント トラッキング専用にします。2 台目のハード ディスクは、Microsoft Windows® 2000 システム ページ ファイル専用にします。3 台目のハード ディスクは、追跡トランザクション ログ専用にします。4 台目のハード ディスクは、分散トランザクション コーディネータ (DTC) ログ専用にします。

  • 受信機能のインスタンスを複数作成し、処理対象ドキュメントの複数の受信場所を監視します。ドキュメントの負荷を複数のサーバーに分散させるには、各コンピュータに受信機能を配置します。それぞれの監視場所は一意で、また独立した受信機能を持っている必要があります。特定の受信機能に過負荷がかかるのを回避するには、ドキュメントを送信する業務用アプリケーションがすべての監視場所にドキュメントを均等に分配するようにします。

重要

  • BizTalk メッセージ マネージャ ツール、インターネット インフォメーション サービス (IIS)、および BizTalk Server 構成データベースを 3 つの異なるサーバーにインストールしてはいけません。この構成にすると、認証上の問題が発生します。詳細については、「IIS、BizTalk メッセージ マネージャ ツール、および SQL Server が別々のコンピュータにある場合の認証問題」を参照してください。

  • BizTalk Server のパフォーマンスの強化については、「パフォーマンスとスケーラビリティの強化」を参照してください。


必要なソフトウェア

次の表は、Microsoft BizTalk Server 2002 を実行するためにインストールする必要があるソフトウェアを示しています。

サーバー インストール | クライアント インストール | カスタム インストール
Microsoft Windows 2000 Service Pack 2 (SP2)* および NTFS ファイル システム | Microsoft Windows 2000 Service Pack 2 (SP2)*、または Windows XP Professional 以降と NTFS ファイル システム | Microsoft Windows 2000 Service Pack 2 (SP2)* および NTFS ファイル システム
Microsoft Internet Explorer 5.5 以降 | Microsoft Internet Explorer 5.5 以降 | Microsoft Internet Explorer 5.5 以降
Microsoft Visio® 2002 (BizTalk オーケストレーション デザイナを使用するために必要) | Microsoft Visio 2002 (BizTalk オーケストレーション デザイナを使用するために必要) | Microsoft Visio 2002 (BizTalk オーケストレーション デザイナを使用するために必要)
Microsoft SQL Server 7.0 Service Pack 3 (SP3)、または SQL Server 2000 SP1 | Microsoft SQL Server 7.0 Service Pack 3 (SP3)、または SQL Server 2000 SP1
注
  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service を実行していないと使用できません。
 注
  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service を実行していないと使用できません。
 注
  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service を実行していないと使用できません。

*BizTalk Server 2002 のインストールには Windows 2000 システム コンソールを使用する必要があります。ターミナル サービスを使用した BizTalk Server のインストールはサポートされていません。

注

  • Microsoft SQL Server 2000 Personal Edition、Microsoft SQL Server 2000 Desktop Engine (MSDE)、および Microsoft SQL Server 2000 Win CE Edition は、サポートされません。Microsoft SQL Server 2000 Enterprise Edition 評価版は、評価用にのみサポートされます。なお、Microsoft SQL Server 2000 Enterprise Edition 評価版には、SP を適用することはできません。そのため、SP で修正されている高ストレス状態で発生する問題が起こる可能性があります。Microsoft SQL Server 2000 Enterprise Developer Edition は、開発用にのみサポートされます。

  • 評価版は、評価用にのみサポートされます。

    Microsoft Application Center 2000 評価版 + SP1
    Microsoft Visio 2002 評価版
    Microsoft Operations Manager (MOM) 2000 120 day Trial (英語評価版)
  • Microsoft Windows 2000、 Microsoft Windows XP Professional 、Microsoft Internet Explorer 5.5 以降、 Microsoft Visio 2002、 Microsoft SQL Server 7.0 または 2000、Microsoft Application Center 2000 は、日本語版のみに対応しています。

  • Microsoft Operations Manager (MOM) 2000 は、英語版のみ提供されています。英語版の対応条件に関してはリリース ノートをご覧ください。

  • カスタム インストールで Microsoft SQL Server が必要になるのは、BizTalk のコア サービスをインストールする場合だけです。クライアント インストールには Microsoft SQL Server は必要ありません。

  • Microsoft Application Center 2000 SP1 が必要になるのは、BizTalk Server 2002 の展開機能を利用する場合だけです。詳細については、「Application Center 2000 のインストール」を参照してください。

  • Microsoft Operations Manager (MOM) 2000 は、高度なモニタリング機能用の BizTalk Server 2002 Management Pack をインストールする場合にだけ必要になります。BizTalk Server 2002 Management Pack の詳細については、「BizTalk Server 2002 Management Pack のインポート」を参照してください。


Windows 2000 の前提条件とインストール要件

Microsoft Windows 2000 Service Pack 2 (SP2) は、すべての Microsoft BizTalk Server 2002 のインストールに必要です。BizTalk Server 2002 は Windows 2000 SP2 で徹底してテストされています。このインストール ガイドでは、BizTalk Server を使用する場合に Windows 2000 Server、Windows 2000 Advanced Server、および Windows 2000 Professional で必要な構成について説明します。また、Windows 2000 のインストールでは、メッセージ キューとインターネット インフォメーション サービス (IIS) をインストールする必要があります。詳細については、「メッセージ キューのインストール」と「インターネット インフォメーション サービス (IIS) のインストール」を参照してください。インストールする Windows 2000 に Service Pack 2 が含まれていない場合は、別途 Service Pack 2 をインストールする必要があります。詳細については、「Windows 2000 Service Pack 2 のインストール」を参照してください。

Windows 2000 をインストールしたら、ほかのソフトウェアをインストールする前に、Windows 2000 ユーザー アカウントを Administrators グループに追加する必要があります。

ここには次のトピックが含まれます。

  • Windows 2000 Server、Windows 2000 Advanced Server、またはWindows 2000 Professional のインストール

  • メッセージ キューのインストール

  • インターネット インフォメーション サービス (IIS) のインストール

  • BizTalk Server 2002 用の IIS 設定の構成

  • Windows 2000 Service Pack 2 のインストール

  • サービス アカウントの設定


Windows 2000 Server、Windows 2000 Advanced Server、またはWindows 2000 Professional のインストール

コンピュータに Windows 2000 Server、Windows 2000 Advanced Server、または Windows 2000 Professional がインストールされている場合には、ここで示されている要件を満たしているかを確認する必要があります。

Windows 2000 がコンピュータにインストールされていない場合には、Windows 2000 CD を CD-ROM ドライブに挿入して、画面に表示される指示に従ってください。セットアップ ウィザードが、Windows 2000 のインストールに必要な手順に導いてくれます。

次の条件を満たすようにしてください。

  • コンピュータ名には英数字だけを使用します。Microsoft SQL Server でサーバー コンピュータ名に使用できる文字セットには制限があるためです。

  • NTFS ファイル システムでパーティションをフォーマットします。

  • [Windows 2000 コンポーネント] ページの [コンポーネント] ボックスの一覧で [メッセージ キュー サービス] をオンにします。Windows 2000 Professional をインストールする場合は、[インターネット インフォメーション サービス (IIS)] をクリックし、[次へ] をクリックします。[メッセージ キューの種類] ページで [Active Directory へのアクセス モードを手動で選択する] チェック ボックスをオンにし、[次へ] をクリックします。

  • [メッセージ キュー サーバー] ページで [メッセージ キューでディレクトリ サービスにアクセスしない] をクリックし、[次へ] をクリックします。

  • [ネットワークの設定] ページで [標準設定] をクリックします。

注

  • セットアップ時に [Windows 2000 コンポーネント] ページの [メッセージ キュー サービス] をオンにしなかった場合は、Windows 2000 Service Pack をインストールする前にメッセージ キュー サービスをインストールする必要があります。詳細については、「メッセージ キューのインストール」を参照してください。

  • Windows 2000 Professional のセットアップ時に [Windows 2000 コンポーネント] ページの [インターネット インフォメーション サービス (IIS)] を選択しなかった場合は、Windows 2000 のサービス パックをインストールする前にインターネット インフォメーション サービスをインストールする必要があります。詳細については、「インターネット インフォメーション サービス (IIS) のインストール」を参照してください。

  • 使用環境に Service Pack 2 が含まれていない場合は、Service Pack 2 をインストールする必要があります。詳細については、「Windows 2000 Service Pack 2 のインストール」を参照してください。

  • Windows 2000 のパーティションは、最新バージョンの NTFS に変換する必要があります。現在のファイル システムが NTFS の古いバージョンである場合は、セットアップ時にこの更新が自動的に行われます。現在のパーティションが FAT または FAT32 である場合は、NTFS への変換を行うかどうかの選択を求めるメッセージが表示されます。メッセージが表示されたら、NTFS を選択してください。

  • Windows 2000 Server、Advanced Server、または Professionalをインストールしたら、ほかのソフトウェアをインストールする前に、Windows 2000 ユーザー アカウントを Administrators グループに追加する必要があります。


メッセージ キューのインストール

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [アプリケーションの追加と削除] をダブルクリックします。

    [アプリケーションの追加と削除] ダイアログ ボックスが表示されます。

  3. [Windows コンポーネントの追加と削除] をクリックします。

    [Windows コンポーネント ウィザード] が開きます。

  4. [コンポーネント] ボックスの一覧で [メッセージ キュー サービス] チェック ボックスをオンにし、[次へ] をクリックします。

  5. [メッセージ キューの種類] ページで [Active Directory へのアクセス モードを手動で選択する] チェック ボックスをオンにし、[次へ] をクリックします。

  6. [メッセージ キュー サーバー] ページで [メッセージ キューでディレクトリ サービスにアクセスしない] をクリックし、[次へ] をクリックします。

  7. [完了] をクリックしてウィザードを閉じます。

注

  • メッセージ キュー サービス コンポーネントをインストールするときは、既定の設定をそのまま使用します。


インターネット インフォメーション サービス (IIS) のインストール

注

  • Windows 2000 Professional のセットアップ時に [Windows 2000 コンポーネント] ページの [インターネット インフォメーション サービス (IIS)] を選択しなかった場合は、Windows 2000 のサービス パックをインストールする前にインターネット インフォメーション サービスをインストールする必要があります。Windows 2000 Professional では、以前のバージョンの Windows と Personal Web Server (PWS) からアップグレードした場合以外は、既定で IIS はインストールされません。

  • Microsoft Windows 2000 Server では既定で IIS がインストールされます。
  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [アプリケーションの追加と削除] をダブルクリックします。

    [アプリケーションの追加と削除] ダイアログ ボックスが表示されます。

  3. [Windows コンポーネントの追加と削除] をクリックします。

    [Windows コンポーネント ウィザード] が開きます。

  4. [コンポーネント] ボックスの一覧で [インターネット インフォメーション サービス (IIS)] チェック ボックスをオンにし、[次へ] をクリックします。

  5. [完了] をクリックしてウィザードを閉じます。


BizTalk Server 2002 用の IIS 設定の構成

BizTalk Server 2002 リポジトリへのアクセスや仕様の保存に関連する問題を回避するには、インターネット インフォメーション サービス (IIS) の [作成を有効にする] チェック ボックスをオフにする必要があります。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[インターネット サービス マネージャ] をダブルクリックします。

  2. ローカル IIS サーバーの展開記号 (+) をクリックします。

  3. [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [既定の Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  4. [Server Extensions] タブをクリックし、[作成を有効にする] チェック ボックスをオフにします。


Windows 2000 Service Pack 2 のインストール

  • Windows 2000 SP2 の CD を CD-ROM ドライブに挿入して、画面上の説明に従います。

    また、Microsoft Windows 2000 Web サイト (www.microsoft.com/japan/windows2000/) のダウンロード エリアにアクセスして Windows 2000 SP2 をダウンロードするか、その CD を注文できます。


サービス アカウントの設定

残りのソフトウェアをインストールするためには、インストールを実行するアカウントが、ソフトウェアのインストール先サーバーのローカルの Windows 2000 Administrators グループに属しているかを確認する必要があります。確認するサーバーには、リモートの SQL Server コンピュータもすべて含まれます。また、BizTalk Messaging Service のログオン用のサービス アカウントを作成する方法もあります。サービス アカウントを作成しない場合には、セットアップ時に BizTalk メッセージ サービスをローカル システムで実行できるように構成するオプションを選択できます。

注

  • BizTalk Server と SQL Server を 2 台の異なるコンピュータにインストールする場合には、BizTalk Server のサービス アカウントに SQL Server のコンピュータへアクセスできるアクセス許可を与える必要があります。詳細については、「SQL Server と BizTalk Server 2002 データベース間の相互作用」を参照してください。
  1. Administrator としてログオンします。

  2. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

    [コンピュータの管理] コンソールが表示されます。

  3. コンソール ツリーで [システム ツール] を展開し、[ローカル ユーザーとグループ] をクリックします。

  4. [ユーザー] をクリックし、詳細ウィンドウ内の任意の位置を右クリックして [新しいユーザー] をクリックします。

    [新しいユーザー] ダイアログ ボックスが表示されます。

  5. [ユーザー名] ボックスにサービス アカウントの名前を入力し、[パスワード] ボックスにパスワードを入力し、[パスワードの確認入力] ボックスに同じパスワードを入力します。

  6. [ユーザーは次回ログオン時にパスワードの変更が必要] チェック ボックスをオフにし、[作成] をクリックして [閉じる] をクリックします。

  7. [コンピュータの管理] ウィンドウを閉じます。

  8. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[ローカル セキュリティ ポリシー] をダブルクリックします。

    [ローカル セキュリティ設定] ダイアログ ボックスが表示されます。

  9. コンソール ツリーで [ローカル ポリシー] を展開し、[ユーザーの権利の割り当て] をクリックします。

  10. 詳細ウィンドウで、[オペレーティング システムの一部として機能] をダブルクリックし、[追加] をクリックします。一覧で作成したサービス アカウント名をクリックし、[追加] をクリックして [OK] をクリックします。

  11. [サービスとしてログオン] ポリシーに対しても手順 10. の操作を行います。

    重要

    • このアクセス許可は、コンピュータを再起動するまで適用されません。

Administrators グループに属するアカウントを使って BizTalk Server 2002 を既にインストールしている場合には、サービス アカウントを作成してから、次の操作を行います。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[サービス] をダブルクリックします。

  2. 詳細ウィンドウで [BizTalk Messaging Service] をダブルクリックします。

    [(ローカル コンピュータ) BizTalk Messaging Service のプロパティ] ダイアログ ボックスが表示されます。

  3. [ログオン] タブをクリックし、[アカウント] をクリックします。

  4. [参照] をクリックし、作成したサービス アカウントをダブルクリックします。

  5. [パスワード] ボックスに、サービス アカウント名に関連付けたパスワードを入力し、[パスワードの確認入力] ボックスにそのパスワードをもう一度入力して [OK] をクリックします。

  6. メッセージ ボックスが表示されます。[OK] をクリックします。

  7. コンピュータを再起動します。


SQL Server の前提条件とインストール要件

Microsoft BizTalk Server 2002 をインストールする前に、Microsoft SQL Server 7.0 Service Pack 3 (SP3)、または、Microsoft SQL Server 2000 Service Pack 1 (SP1) をインストールする必要があります。BizTalk Server 2002 をインストールするときには、SQL Server 内に 4 つの BizTalk Server 2002 のデータベースが作成されます。それらは、BizTalk メッセージ管理データベース、共有キューデータベース、追跡データベース、およびオーケストレーション データベースです。

重要

  • Microsoft Windows 2000 Professional を実行しているコンピュータに BizTalk Server 2002 をインストールする場合には、別のコンピュータに SQL Server のStandard Edition か Enterprise Edition をインストールする必要があります。そして、BizTalk Server 2002 のデータベースをインストールするときに、SQL Server をインストールしたコンピュータの名前を指定する必要があります。SQL Server の Standard Edition と Enterprise Edition は Windows 2000 Professional にインストールすることができません。

  • BizTalk Server と SQL Server を 2 台の異なるコンピュータにインストールする場合には、ログオン アカウントと BizTalk Server のサービス アカウントに両方のコンピュータへアクセスできるアクセス許可を与える必要があります。詳細については、「SQL Server と BizTalk Server 2002 データベース間の相互作用」を参照してください。

既定では、SQL Server 2000 をインストールすると、認証モードが Windows 2000 のみに設定されます。BizTalk Server 2002 は Windows 認証を使用して BizTalk メッセージ管理データベース、共有キュー データベース、追跡データベース、および BizTalk ドキュメント トラッキング Web アプリケーションにアクセスします。BizTalk Server 2002 をインストールする前に、SQL Server の認証モードが Windows に設定されていることを確認してください。詳細については、「SQL Server 2000 の SQL 認証モードの設定」を参照してください。

クラスタは複数のサーバーの集合で、単一のサーバーとして動作します。SQL Server をクラスタにインストールし、BizTalk Server 2002 を別のコンピュータにインストールする場合は、BizTalk Server 2002 のインストールされているコンピュータに SQL Server クライアント ツールをインストールする必要があります。詳細については、「SQL Server クライアント ツールのインストール」を参照してください。ツールのインストール作業が終了したら、クライアント ネットワーク ユーティリティを使用して、既定のネットワーク ライブラリを名前付きパイプから TCP/IP に変更します。詳細については、「既定のネットワーク ライブラリの TCP/IP への変更」を参照してください。

各国語対応に関する問題

  • SQL Server をインストールするには、正確な照合順序設定を使用することが重要です。照合順序とは、データの格納および比較の方法を決定する一連の規則です。文字データは、文字の正しい順序を定義する規則に従って並べ替えられます。この規則には、文字の区別、アクセント記号、カナ文字の種類、および文字幅を指定するオプションがあります。たとえば、日本語の文字を格納するには、SQL Server をセットアップするときに文字を区別する並べ替え順序を選択すると、日本語のひらがなとカタカナが区別できます。照合順序の設定の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server] または [Microsoft SQL Server 7.0] をポイントし、[Books Online] をクリックしてください。「SQL 照合順序の使用」と「Windows の照合順序並べ替えスタイル」を参照してください。

SQL Server がバイナリの並べ替え順に設定されている場合には、大文字と小文字が区別されます。

ここには次のトピックが含まれます。

  • SQL Server 7.0 または SQL Server 2000 のインストール

  • SQL Server Service Pack の確認

  • SQL Server のサービス パックのインストール

  • SQL Server クライアント ツールのインストール

  • 既定のネットワーク ライブラリの TCP/IP への変更

  • SQL Server 2000 の SQL 認証モードの設定

  • SQL Server が実行中であることの確認

  • SQL Server と BizTalk Server 2002 データベース間の相互作用


SQL Server 7.0 または SQL Server 2000 のインストール

SQL Server をインストールするには、Microsoft SQL Server の CD を CD-ROM ドライブに挿入して、画面上の説明に従います。セットアップ ウィザードが、SQL Server のインストールに必要な手順に導いてくれます。

次の条件を満たすようにしてください。

  • [セットアップの種類] ページで [標準] をクリックします。

  • [サービス アカウント] ページで、ドメイン ユーザー アカウント (ネットワークに接続されている場合) を使用します。

  • SQL Server 2000 をインストールする場合は、[認証モード] ページで [Windows 認証] をクリックします。

重要

  • SQL Server をインストールしたら、最新の SQL Server のサービス パックをインストールする必要があります。最新のサービス パックがインストールされているかどうかは、クエリ アナライザを使って確認できます。詳細については、「SQL Server Service Pack の確認」を参照してください。SQL Server のサービス パックのインストールについては、「SQL Server のサービス パックのインストール」を参照してください。


SQL Server Service Pack の確認

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[クエリ アナライザ] をクリックします。

    [SQL Server の接続] ダイアログ ボックスが表示されます。

  2. [有効にする] をクリックします。

    使用しているサーバー名が [SQL Server] ボックスに表示されていない場合は、そのサーバー名を入力して、[OK] をクリックします。

  3. [クエリ] ボックスに「SELECT @@VERSION」と入力します。

  4. [クエリ] メニューの [実行] をクリックします。

    クエリの戻り値の最初の行に、実行中の SQL Server のバージョンが示されます。


SQL Server のサービス パックのインストール

  1. SQL Service Service Pack の CD を CD-ROM ドライブに挿入します。

  2. SQL Server Service Pack のセットアップ プログラムを実行して、インストールの説明に従います。

    また、Microsoft SQL Server Web サイト (www.microsoft.com/japan/sql/) のダウンロード エリアにアクセスして SQL Server のサービス パックをダウンロードするか、またはその CD を注文することができます。


SQL Server クライアント ツールのインストール

重要

  • クラスタ環境を利用している場合で、SQL Server と BizTalk Server が異なるコンピュータにあるときには、SQL Server のクライアント ツールを BizTalk Server 2002 がインストールされているコンピュータにインストールする必要があります。

SQL Server のクライアント ツールをインストールするには、Microsoft SQL Server の CD を CD-ROM ドライブに挿入して、画面上の説明に従います。セットアップ ウィザードが、SQL Server のインストールに必要な手順に導いてくれます。

次の条件を満たすようにしてください。

  • [インストールの選択] ページで [SQL Server の新規インスタンスの作成またはクライアント ツールのインストール] をクリックします。

  • [インストールの定義] ページで [クライアント ツールのみ] をクリックします。


既定のネットワーク ライブラリの TCP/IP への変更

SQL Server のクライアント ユーティリティをインストールしているとき、SQL Server のセットアップによって名前つきパイプが既定のクライアント ネットワーク ライブラリとしてインストールされます。BizTalk Server は、SQL Server との通信に TCP/IP を使用するため、既定のネットワーク ライブラリを TCP/IP に手動で変更する必要があります。

SQL Server 7.0 では、次の手順で既定のネットワーク ライブラリを変更します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server 7.0] をポイントし、[クライアント ネットワーク ユーティリティ] をクリックします。

    [SQL クライアント設定ユーティリティ] ダイアログ ボックスが表示されます。

  2. [全般] タブの [既定のネットワーク ライブラリ] の一覧で [TCP/IP] をクリックします。

  3. [OK] をクリックします。

SQL Server 2000 では、次の手順で既定のネットワーク ライブラリを変更します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server] をポイントし、[クライアント ネットワーク ユーティリティ] をクリックします。

  2. [全般] タブで、[プロトコルが有効になる順序] の一覧に [TCP/IP] が入っていることを確認し、上矢印のボタンをクリックして TCP/IP がプロトコルの一覧の先頭になるように移動します。


SQL Server 2000 の SQL 認証モードの設定

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Servers]、[SQL Server グループ] の順に展開します。

  3. 使用しているサーバー名を右クリックし、[プロパティ] をクリックします。

    [SQL Server のプロパティ] ダイアログ ボックスが表示されます。

  4. [セキュリティ] タブの [Windows 認証] をオンにして、[OK] をクリックします。


SQL Server が実行中であることの確認

BizTalk Server 2002 をインストールする前に、使用しているサーバー上で SQL Server が実行中であることを確認します。この確認が必要なのは、BizTalk Server 2002 のインストール時に 4 つの SQL データベースが作成されるためです。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server] (SQL Server 2000 をインストールした場合) または [Microsoft SQL Server 7.0] (SQL Server 7.0 をインストールした場合) をポイントし、[サービス マネージャ] をクリックします。

    [SQL Server サービス マネージャ] ダイアログ ボックスが表示されます。

  2. [サーバー] ボックスのサーバー名が、使用しているコンピュータ名になっていることを確認します。

    そうでない場合は、ドロップダウン リストの下矢印をクリックして、利用できるサーバーの一覧を参照し、使用しているサーバーが表示されるまでスクロールします。

  3. [サービス] ボックスの一覧で [MSSQLServer] (SQL Server 7.0 の場合) または [SQL Server] (SQL Server 2000 の場合) をクリックします。

  4. MSSQLServer または SQL Server のサービスが実行中であることを確認します。

    ダイアログ ボックスの [開始/再開] ボタンが使用できない状態になっていれば、このサービスは実行中です。また、このダイアログ ボックスの一番下に、このサービスが実行中であることを示すメッセージが表示されています。たとえば、SQL Server 2000 では、"実行中 - \\<サーバー名> - MSSQLServer" と表示されます。

  5. このサービスが実行中でない場合は、[開始/再開] ボタンが使用できる状態になっているので、そのボタンをクリックしてサービスを開始します。


SQL Server と BizTalk Server 2002 データベース間の相互作用

ディスク容量の不要な割り当てを回避するには、Microsoft SQL Server 7.0 の場合は [チェックポイント時のログ切り捨て] チェック ボックスと [自動圧縮] チェック ボックスをオンにします。Microsoft SQL Server 2000 の場合は [設定] の [自動圧縮] チェック ボックスをオンにします。この機能を使用しないと、SQL Server ログに膨大なディスク容量が使用されることがあります。ただし、この操作を行うには、BizTalk Server 2002 をインストールする必要があります。詳細については、「ディスク容量の不要な割り当ての回避」を参照してください。BizTalk Server 2002 のインストールの詳細については、「インストールに関する説明」を参照してください。

BizTalk Server 2002 は Windows 認証を使用して BizTalk メッセージ管理データベース、共有キュー データベース、追跡データベース、および BizTalk ドキュメント トラッキング Web アプリケーションにアクセスします。BizTalk Server と SQL Server を 2 台の異なるコンピュータにインストールする場合には、使用するアカウントに BizTalk Server と SQL Server のコンピュータの管理権限を与える必要があります。

各国語対応に関する問題

  • BizTalk Server は、別の言語バージョンの BizTalk Server で作成されたデータベースにアクセスすることができません。

次の手順は、リモートの SQL Server へのアクセス許可と、BizTalk Server データベースに対応するリモート サーバーへのアクセス許可を作成するために必要です。

リモート SQL Server のログイン アカウント

注

  • SQL Server と BizTalk Server 2002 がローカル コンピュータにインストールされ、BizTalk Server メッセージ サービス アカウントがローカル コンピュータの Administrators グループに追加されている場合には、既定で SQL Server の管理権限が与えられるため、次の作業は必要なくなります。ただし、BizTalk Server と SQL Server を別のコンピュータにインストールする場合には、次の手順で BizTalk Server 2002 から SQL Server にアクセスできるようにする必要があります。
  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Server]、[SQL Server グループ] の順に展開します。さらに、SQL Server のログイン アカウントを追加するサーバーを展開し、[セキュリティ] を展開します。

  3. [ログイン] を右クリックして、[新規ログイン] をクリックします。

    [SQL Server ログイン プロパティ – 新規ログイン] ダイアログ ボックスが表示されます。

  4. [全般] タブの [名前] ボックスで、ドメインと Windows のアカウント名を指定します。

    たとえば、<ドメイン>\<サービス アカウント> の形式で、BizTalk メッセージ サービスで実行するアカウント名を指定します。

  5. [サーバー ロール] タブの [サーバー ロール] の一覧で、[System Administrators] チェック ボックスをオンにします。

注

  • 管理権限がなくても BizTalk メッセージ サービスのサービス アカウントは正常に実行できます。
  6. [OK] をクリックして、[SQL Server ログイン プロパティ] ページを閉じます。

リモート データベースへのアクセス許可の作成

BizTalk Server 2002 をインストールしたら、SQL Server ログイン アカウントからアクセス可能なデータベースを指定する必要があります。SQL Server ログイン アカウントのアクセス許可を BizTalk メッセージ管理データベース、共有キュー データベース、および追跡データベースに与えるために、次の手順を実行します。

注

  • この手順は、BizTalk Server をインストールするまで実行できません。
  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Servers] を展開し、[SQL Server グループ] を展開します。次に、BizTalk Server データベースを含むサーバーを展開し、[セキュリティ] を展開して、[ログイン] を展開します。

  3. 詳細ウィンドウで、BizTalk Server メッセージ サービス アカウント用に作成した SQL Server ログイン アカウントをダブルクリックします。

    [SQL Server のログイン プロパティ] ページが表示されます。

  4. [データベース アクセス] タブで [InterchangeBTM] チェック ボックスをオンにします。

    [ユーザー] ボックスに指定したアカウント名が表示されます。このタブ ページの下側には [データベース ロール内の権限] ボックスが表示されます。

  5. [データベース ロール内の権限] ボックスで [db_owner] と [dta_ui_role] チェック ボックスをオンにします。

  6. [InterchangeDTA] と [InterchangeSQ] データベースに対して手順 4. と 5. を繰り返し、[データベース ロール内の権限] ボックスで [db_owner] だけをオンにします。

    注

    • セットアップ時、BizTalk メッセージ管理データベース オブジェクト名は既定で InterchangeBTM に、追跡データベース オブジェクト名は既定で InterchangeDTA に、共有キュー データベース オブジェクト名は既定で InterchangeSQ になります。既定のデータベース オブジェクト名は、セットアップ時に変更できます。


Visio 2002 のインストール

BizTalk オーケストレーション デザイナは Microsoft Visio 2002を利用したユーザー インターフェイスなので、BizTalk オーケストレーション デザイナを使用するためには、コンピュータに Visio 2002 がインストールされている必要があります。BizTalk オーケストレーション デザイナは、Visio 2002 で完全にテスト済みです。

Visio 2002 Standard Edition のインストール

  1. Visio 2002 の CD を CD-ROM ドライブに挿入します。

  2. Visio 2002 のセットアップ プログラムを実行して、画面に表示される指示に従います。

詳細については、Microsoft Visio 2002 のドキュメントを参照してください。

各国語対応に関する問題

  • 言語によっては、一部の文字が BizTalk オーケストレーション デザイナに正しく表示されないことがあります。これを修正するために、Microsoft Visio 2002 では、必ずシステムの既定フォントを使用する必要があります。
    1. [スタート] メニューで、[プログラム] をポイントし、[Microsoft Visio] をクリックします。

    2. [ツール] メニューの [オプション] をクリックします。

    3. [地域別設定] タブをクリックし、[図面の基本フォント] エリアで [常にシステムの既定フォントを使用] をオンにします。

    4. Visio を閉じて、BizTalk オーケストレーション デザイナを開きます。


Application Center 2000 のインストール

Microsoft Application Center 2000 Service Pack 1 (SP1) が必要になるのは、BizTalk Server 2002 の展開機能を利用する場合だけです。

重要

  • Application Center は、BizTalk Server をインストールする前にインストールする必要があります。また、BizTalk Server と同じコンピュータにインストールする必要があります。

  • Application Center 2000 をMicrosoft Windows 2000 Datacenter Server が動作するコンピュータにインストールすることはできません。

Application Center 2000 のインストール

  1. Application Center 2000 の CD を CD-ROM ドライブに挿入します。

  2. Application Center 2000 のセットアップ プログラムを実行して、インストールの説明に従います。

重要

  • Application Center 2000 をインストールしたら、Application Center 2000 SP1 をインストールする必要があります。パッチのインストールについては、Application Center 2000 SP1 ディレクトリにあるリリース ノートを参照してください。

  • Application Center がインストールされていない状態で BizTalk Server をインストールすると、BizTalk Server インストール ディレクトリ内の AppCenter ディレクトリにドライバと列挙プログラムがインストールされますが、登録はされません。

    ドライバと列挙プログラムを登録するには

    1. Application Center 2000 と SP1 をインストールします。

    2. rdrvbts.dll と AcBtsEnm.dll を \Program Files\Microsoft BizTalk Server\AppCenter から、Application Center インストール ディレクトリにコピーします。

    3. GIF ファイルを \Program Files\Microsoft BizTalk Server\AppCenter\Images から、Application Center の Admin\Images フォルダにコピーします。

    4. コマンド ラインで、「regsvr32.exe rdrvbts.dll」と「regsvr32.exe AcBtsEnm.dll」を実行して、ドライバと列挙プログラムを登録します。ここでは、ダイナミック リンク ライブラリ (DLL) のフルパス名の指定が必要です。


インストールに関する説明

Microsoft BizTalk Server 2002 をインストールするには、インストール ウィザード (Microsoft BizTalk Server.msi) または Microsoft Windows インストーラ (Msiexec.exe) を使用します。インストール ウィザードを使用する場合は、順に操作を行って、操作ごとに特定のプロパティ値に対するオプションを選択します。Microsoft Windows インストーラを使用すると、コマンド ラインからプロパティ値を指定できます。この方法を使用すると、BizTalk Server 2002 をサイレントに (常に対話や入力を求められることなく) インストールを行うことができます。BizTalk Server 2002 のサイレント インストールは、テスト シナリオや、大規模なエンタープライズ環境への展開に使用するものとして理想的です。

どの種類のインストールを実行する場合にも、後の使用のために、次の情報を記録しておいてください。

  • BizTalk Server グループ名
    既定 : BizTalk Server グループ

  • Microsoft SQL Server 名
    既定 : SQL Server がインストールされているコンピュータの名前

  • BizTalk Server サービス アカウントのユーザー名とパスワード

  • BizTalk メッセージ管理データベース名
    既定 : InterchangeBTM

  • 追跡データベース名
    既定 : InterchangeDTA

  • 共有キュー データベース名
    既定 : InterchangeSQ

  • オーケストレーション データベース名
    既定 : XLANG

  • WebDAV リポジトリの URL
    既定 : \\localhost\BizTalkTracking

重要

  • BizTalk Server 2002 のインストール プログラムを実行する前に、コンピュータへのログオンに使っているアカウントに、ローカル コンピュータの管理権限と、構成するすべての SQL Server コンピュータの管理権限があるかを確認してください。リモート コンピュータの管理権限を持つ SQL Server のログイン アカウントの作成方法については、「SQL Server と BizTalk Server 2002 データベース間の相互作用」を参照してください。

  • BizTalk Server 2002 には、Microsoft XML Parser (MSXML) Version 3.0 Service Pack 1 (SP1) が必要です。現在のリリースの BizTalk Server 2002 は、MSXML 3.0 SP1 を自動的にインストールします。BizTalk Server 2002 を異なるバージョンの MSXML とともに使用すると予期しない結果になることがあります。MSXML 3.0 と 4.0 以降の共存インストールが必要な場合には、BizTalk Server 2002 をインストールする前に、MSXML 4.0 をアンインストールする必要があります。さらに、BizTalk Server をインストールした後に、MSXML 4.0を再インストールする必要があります。

  • BizTalk Server 2002 のインストールには Windows 2000 システム コンソールを使用する必要があります。ターミナル サービスを使用した BizTalk Server のインストールはサポートされていません。

注

  • BizTalk Server のセキュリティの問題については、「セキュリティ ガイドライン」を参照してください。

  • クラスタ環境に BizTalk Server 2002 を展開する方法については、BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver) にアクセスして「技術情報」にある「展開」のページを参照してください。

ここには次のトピックが含まれます。

  • サーバー インストール

  • クライアント インストール

  • カスタム インストール

  • アップグレード インストール

  • サイレント インストール

  • BizTalk Server 2002 の削除


サーバー インストール

ここでは、BizTalk のすべてのサービス、ツール、およびサンプルを含む Microsoft BizTalk Server 2002 のサーバー インストールを行う方法について説明します。

重要

  • BizTalk Server 2002 をインストールする前に、ハードウェアとソフトウェアの最小要件を満たすシステムを構築する必要があります。必要な前提条件が整っているかどうか確認するために、「インストールのチェックリスト」を参照してください。

  • BizTalk Server を正しくインストールするには、IIS を有効にする必要があります。このサービスは、BizTalk Server のインストール処理中に開始されます。

  • BizTalk Server 2002 は Windows 認証を使用して BizTalk メッセージ管理データベース、共有キュー データベース、追跡データベース、および BizTalk ドキュメント トラッキング Web アプリケーションにアクセスします。BizTalk Server 2002 をインストールする前に、Microsoft SQL Server の認証モードが Windows に設定されていることを確認してください。詳細については、「SQL Server 2000 の SQL 認証モードの設定」を参照してください。SQL Server がリモート コンピュータにインストールされている場合には、使用しているアカウントが SQL Server の Administrators グループのメンバかを確認します。詳細については、「SQL Server と BizTalk Server 2002 データベース間の相互作用」を参照してください。

  • BizTalk Server 2002 には、Microsoft XML Parser (MSXML) Version 3.0 Service Pack 1 (SP1) が必要です。現在のリリースの BizTalk Server 2002 は、MSXML 3.0 SP1 を自動的にインストールします。BizTalk Server 2002 を異なるバージョンの MSXML とともに使用すると予期しない結果になることがあります。MSXML 3.0 と 4.0 以降の共存インストールが必要な場合には、BizTalk Server 2002 をインストールする前に、MSXML 4.0 をアンインストールする必要があります。さらに、BizTalk Server をインストールした後に、MSXML 4.0を再インストールする必要があります。

BizTalk Server 2002 のサーバー インストールの実行

  1. Microsoft BizTalk Server 2002 の CD を CD-ROM ドライブに挿入して、インストール ウィザードを起動します。インストール ウィザードが、BizTalk Server 2002 のインストールに必要な手順に導いてくれます。以下の各手順に示される条件を満たすように作業を進めてください。

  2. [ユーザー情報] ページで、[ユーザー名] ボックスに名前を入力し、[組織] ボックスに会社名を入力して、[次へ] をクリックします。

  3. [インストール先フォルダ] ページで、既定のフォルダの「C:\Program Files\Microsoft BizTalk Server」に BizTalk Server 2002 をインストールする場合は [次へ] をクリックし、それ以外の場所へインストールする場合は [変更] をクリックします。

  4. [セットアップのタイプ] ページの [サーバー] をクリックし、[次へ] をクリックします。

  5. [BizTalk Server 管理者のアクセス権の構成] で既定のグループ名の [BizTalk Server Administrators] をそのまま使用するか、[グループ名] ボックスに使用するグループ名を入力します。次に、[次へ] をクリックします。

    重要

    • このグループ名を変更するときは、Windows レジストリの HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0\NTGroups にある "AdminGroupName" の値も修正する必要があります。BizTalk Server 2002 は、このレジストリ キーを使用してグループを検索します。

    注

    • グループ名を作成するときは、次のグループ命名規則に従ってください。

      グループ名は、コンピュータ上のほかのグループ名およびユーザー名とは異なるものにします。

      グループ名に ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | ; \ ; " ' < > , . および ? の文字を含めることはできません。

      グループ名をピリオド (..) またはスペースだけで構成することはできません。

  6. [グループの説明] ボックスに、グループ名の新しい説明を入力するか、または既定の説明をそのまま使用して、[次へ] をクリックします。

  7. [BizTalk Server サービス ログオン プロパティ] ページのサービス アカウントの指定に、[特定のアカウント] の既定設定をそのまま使います。このアカウントは、BizTalk Messaging Service を実行するアカウントになります。BizTalk メッセージング サービスが正しく動作するためには、このアカウントに SQL Server へのアクセス許可を与える必要があります。[パスワード] ボックスに有効なパスワードを入力します。

    セットアップ終了時に BizTalk サービスが自動的に開始しないようにするには、[セットアップ完了後にサービスを開始する] チェック ボックスをオフにします。BizTalk Service メッセージ サービスは自動的には開始しなくなります。次に、[次へ] をクリックします。

    注

    • BizTalk Server セットアップでは、[サービスとしてログオン] の権利と [オペレーティング システムの一部として機能] の権利が、[BizTalk サービス ログオン プロパティ] ページで指定されているアカウントに付与されます。

    • [特定のアカウント] を選択し、BizTalk Server の実装で公開キー証明書か秘密キー証明書を使用する場合には、ローカル コンピュータの Administrators グループにあるアカウントを指定する必要があります。BizTalk メッセージ マネージャを使って、S/MIME コンポーネントの証明書を構成する場合にも、Windows 2000 Administrators グループに属しているアカウントを使用してログオンする必要があります。
  8. [次へ] をクリックします。

  9. [プログラムのインストールの開始] ページの [インストール] をクリックします。

    BizTalk Server 2002 のインストールには数分かかることがあります。

  10. [Microsoft BizTalk Server 2002 メッセージ データベース セットアップ ウィザードへようこそ] ページが表示されたら、[次へ] をクリックします。

    BizTalk Server 2002 データベースのセットアップで、BizTalk メッセージ管理データベース、追跡データベース、および共有キュー データベースを構成するために、SQL Server コンピュータとデータベースの情報の入力を要求するメッセージが表示されます。

    注意

    • BizTalk メッセージ管理データベース、追跡データベース、および共有キュー データベースの、ストアド プロシージャやトリガなどのコードを変更しないでください。データベースに直接アクセスしないでください。ストアド プロシージャを直接呼び出さないでください。データベースを変更するときは、必ず BizTalk メッセージ構成オブジェクト モデルのメソッドおよびプロパティを使用してください。データベースの変更を直接行うと、BizTalk メッセージ構成オブジェクト モデルによる制約の多くが無視されることになり、サーバーの誤動作やデータベースの破損が発生します。
  11. [BizTalk メッセージ管理データベースを構成します] ページの [新しい BizTalk メッセージ管理データベースの作成] の既定設定をそのまま使用するか、[既存のデータベースの選択] をクリックし、対応するテキスト ボックスにサーバー名を入力します。

    重要

    • Microsoft Windows 2000 Professional を実行しているコンピュータに BizTalk Server 2002 をインストールする場合は、Microsoft SQL Server 7.0 または Microsoft SQL Server 2000 をインストールしているコンピュータの名前をサーバー名に指定する必要があります。

    • 同じサーバー上の既存のデータベースと同じ名前で新しくデータベースを作成する場合は、そのデータベースの内容を手動で削除してください。データベース内容の削除の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server] または [Microsoft SQL Server 7.0] をポイントし、[Books Online] をクリックしてください。BizTalk Server セットアップでは、データベースに必要なストアド プロシージャが存在するかどうかは確認されますが、データベースに必要なすべての変数が存在するかどうかは確認されません。ストアド プロシージャが存在する場合、BizTalk Server セットアップはそのデータベースを変更しません。ストアド プロシージャが存在しない場合は、そのデータベースは削除されます。次に、BizTalk メッセージ管理データベース テーブルが再初期化されます。この説明は、共有キュー データベースと追跡データベースにも当てはまります。

    • BizTalk Server を 1 つ以上セットアップして、それらを BizTalk メッセージ管理データベースで集中的に管理する場合には、BizTalk メッセージ管理データベースの変更に関する情報を参照することを強くお勧めします。詳細については、「BizTalk メッセージ管理データベースの変更」を参照してください。
  12. [次へ] をクリックします。

  13. [BizTalk Server グループの構成] ページで、BizTalk Server グループとして使用する名前を [グループ名] ボックスに入力するか、または既定のグループ名 (BizTalk Server グループ) をそのまま使用して、[次へ] をクリックします。

    ほかの BizTalk Server グループをセットアップしている場合には、[既存の BizTalk Server グループの選択] をクリックして、[グループ名] ボックスの一覧から名前を選択することもできます。

    重要

    • グループ名に ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | ; \ ; " ' < > , . および ? の文字を含めることはできません。

    • グループ内のすべてのサーバーには、同じバージョンおよび言語の BizTalk Server がインストールされていなければなりません。グループ内に異なるバージョンのBizTalk Server (BizTalk Server 2000、BizTalk Server 2000 SP1、BizTalk Server 2002 Enterprise Edition、または異なる言語バージョンの BizTalk Server など) がインストールされているサーバーがある場合、データベースは正常に機能しません。
  14. [追跡データベースの構成] ページで手順 11. の操作を繰り返して、[次へ] をクリックします。

  15. [共有キュー データベースの構成] ページで手順 11. の操作を繰り返して、[次へ] をクリックします。

  16. [BizTalk Server グループの確認] ページで、[BizTalk Server グループのプロパティ] ボックス内の情報が正確であることを確認して、[次へ] をクリックします。

  17. [Microsoft BizTalk Server 2002 メッセージ データベース セットアップ ウィザードの完了] ページで [完了] をクリックして、BizTalk メッセージ管理データベース、追跡データベース、および共有キュー データベースの構成を完了します。

  18. [Microsoft BizTalk Server 2002 オーケストレーション データベース セットアップ ウィザードへようこそ] ページで、[次へ] をクリックしてオーケストレーション データベースをインストールします。

    注

    • [キャンセル] をクリックすると、BizTalk Server 2002 はインストールされますが、オーケストレーション データベースとデータ ソース名 (DSN) はインストールされません。データベースと DSN は後でインストールできます。詳細については、「新しいステータス保存データベースの作成」、「XLANG スケジュールをホストするそのほかの COM+ アプリケーションの管理」、および「XLANG スケジュールをホストする COM+ アプリケーションの構成」を参照してください。
  19. [既定のオーケストレーション データベースの構成] ページの既定設定である [既定のオーケストレーション データベースを新しく作成する] をそのまま使用するか、[既存のデータベースの選択] をクリックして、SQL Server のコンピュータ名を選択し、対応するテキスト ボックスにデータベース情報を入力します。

    重要

    • [既定のオーケストレーション データベースを新しく作成する] をクリックして、同じサーバー上の既存のデータベースと同じ名前のデータベースを選択すると、そのデータベースの内容はすべて削除されます。

    • Microsoft Windows 2000 Professional を実行しているコンピュータに BizTalk Server 2002 をインストールする場合は、[サーバー名] に指定する名前が SQL Server をインストールしたコンピュータ名と同じである必要があります。

    注

    • オーケストレーション データベースは、現在のユーザーのログオン ID に基づいて作成されます。

    • SQL Server をリモートで使用するには、オーケストレーション データベースに対する適切なアクセス許可を付与されている必要があります。XLANG スケジューラ エンジンの ID を再構成していない場合は、BizTalk Server 2002 のインストール時にログオンしていたユーザーにアクセス許可が付与されます。自分で作成したサービス アカウント、またはほかの一意なユーザー アカウントに一致するように XLANG スケジューラ エンジンの ID を再構成した場合は、再構成した ID に対応するように SQL のアクセス許可を設定する必要があります。
  20. [完了] をクリックします。

  21. Microsoft BizTalk Server 2002 インストール ウィザードの最終ページで、[リリース ノートの表示] をクリックして BizTalk Server 2002 についての重要な最新情報を参照してから、[完了] をクリックします。

注意

  • COM+ アプリケーションの偽装レベルは変更しないでください。既定では [偽装する] に設定されています。このセキュリティのプロパティを [匿名]、[識別する]、または [委任する] に変更すると、インストール時に問題が発生することがあります。

  • BizTalk Server 2002 をコンピュータにインストールした後で、コンピュータ名を変更することはできません。BizTalk Server 2002 はこのコンピュータ名を内部的に使用しています。コンピュータ名を変更した場合には、BizTalk Server 2002 が異なる名前を検出して、エラー メッセージを生成します。コンピュータ名の変更が必要な場合には、BizTalk Server をアンインストールして、コンピュータ名を変更し、BizTalk Server を再インストールする必要があります。

重要

  • SQL Server がリモート コンピュータで実行されている場合には、SQL Server のログイン アカウントが、BizTalk メッセージ管理データベース、共有キュー データベース、および追跡データベースへアクセスできるようにアクセス許可を指定する必要があります。詳細については、「SQL Server と BizTalk Server 2002 データベース間の相互作用」を参照してください。

注

  • BizTalk オーケストレーション サービスのパフォーマンスを大きく向上させるには、エクスプローラで Program Files\Common Files\System\ado に移動し、adofre15.reg をダブルクリックします。確認を求めるダイアログ ボックスが表示されるので、[はい] をクリックし、[OK] をクリックします。この操作を行うと Microsoft® ActiveX® Data Objects (ADO) のスレッド モデルが "Apartment" から "Both" になります。これは ADO を利用するほかのアプリケーションに影響を及ぼす可能性があります。スレッドが安全でないプロバイダは使用できません。

インストール後に次の手順を実行する必要があります。

  • ディスク容量の不要な割り当ての回避

  • World Wide Web Publishing Service の開始

  • BizTalk ドキュメント トラッキングの構成


ディスク容量の不要な割り当ての回避

  1. [スタート] メニューの [プログラム] をポイントし、[Microsoft SQL Server 7.0] または [Microsoft SQL Server] をポイントします。次に、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Servers]、[SQL Server グループ] の順に展開し、さらに [<サーバー名>]、[データベース] を展開します。

  3. [メッセージ管理データベース] を右クリックし、[プロパティ] をクリックします。

    [<メッセージ管理データベース> プロパティ] ダイアログ ボックスが表示されます。

  4. [オプション] タブをクリックします。

  5. SQL Server 7.0 の場合は [チェックポイント時のログ切り捨て] チェック ボックスと [自動圧縮] チェック ボックスをオンにし、[OK] をクリックします。

    注

    • Microsoft SQL Server 2000 をインストールしている場合には、[自動圧縮] チェック ボックスをオンにして、[復旧] の [モデル] を [シンプル] に変更します。
  6. 追跡データベースおよび共有キュー データベースに対しても、手順 3. ～ 5. の操作を繰り返します。

注

  • セットアップ時に、BizTalk メッセージ管理データベース オブジェクト名は既定で InterchangeBTM に、追跡データベース オブジェクト名は既定で InterchangeDTA に、共有キュー データベース オブジェクト名は既定で InterchangeSQ になります。既定のデータベース オブジェクト名は、セットアップ時に変更できます。

重要

  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service を実行していないと使用できません。World Wide Web Publishing Service の詳細については、「World Wide Web Publishing Service の開始」を参照してください。


World Wide Web Publishing Service の開始

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [サービス (ローカル)] をクリックします。

  3. 詳細ウィンドウで [World Wide Web Publishing Service] を右クリックし、[開始] をクリックします。


BizTalk ドキュメント トラッキングの構成

BizTalk ドキュメント トラッキングを BizTalk Server 2002 の CD からインストールすると、BizTalk ドキュメント トラッキング Web アプリケーションにアクセスするショートカットが、ローカル コンピュータの Microsoft BizTalk Server 2002 のプログラム グループ内に作成されます。一方、BizTalk ドキュメント トラッキング Web アプリケーションにリモート コンピュータからアクセスする場合は、後から Web アプリケーションへアクセスするショートカットまたはお気に入りを手動で作成する必要があります。いずれの場合も、セキュリティに関する警告のダイアログ ボックスが表示されないようにするには、Web アプリケーションを信頼するように、使用しているブラウザの設定を手動で構成します。

Internet Explorer のセキュリティ設定の構成

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk ドキュメント トラッキング] をクリックします。

    注

    • Microsoft Internet Explorer で BizTalk ドキュメント トラッキングをお気に入りに追加すると、Internet Explorer から BizTalk ドキュメント トラッキング Web アプリケーションを開くことができます。

    • Windows コモン コントロールおよび BizTalk ドキュメント トラッキング コントロールがコンピュータにインストールされていない場合は、コンポーネントのインストールを求めるメッセージが表示されます。詳細については、「BizTalk ドキュメント トラッキングを初めて開く」を参照してください。
  2. BizTalk ドキュメント トラッキング サーバーの場所を Internet Explorer のアドレス バーからクリップボードにコピーします。

  3. [ツール] メニューの [インターネット オプション] をクリックします。

    [インターネット オプション] ダイアログ ボックスが表示されます。

  4. [セキュリティ] タブで [信頼済みサイト] をクリックし、[サイト] をクリックします。

    [信頼済みサイト] ダイアログ ボックスが表示されます。

  5. [次の Web サイトをゾーンに追加する] ボックスに、クリップボードの BizTalk ドキュメント トラッキング サーバーの場所を貼り付けます。

  6. [このゾーンのサイトにはすべてサーバーの確認 (https:) を必要とする] チェック ボックスをオフにします。

  7. [追加] をクリックし、[OK] を 2 回クリックしてダイアログ ボックスを閉じます。


クライアント インストール

Microsoft BizTalk Server 2002 のクライアント インストールでは、以下のコンポーネントだけがインストールされます。

  • BizTalk オーケストレーション デザイナ

  • BizTalk エディタ

  • BizTalk マッパー

  • BizTalk Server 管理コンソール用 Microsoft 管理コンソール (MMC) スナップイン

  • BizTalk Server 2002 ヘルプ

BizTalk Server 2002 のパーサー、シリアライザ、関連付け、およびランタイム コンポーネントはインストールされません。

BizTalk Server 2002 のクライアント インストールの実行

  1. Microsoft BizTalk Server 2002 の CD を CD-ROM ドライブに挿入して、インストール ウィザードを起動します。インストール ウィザードの説明に従って BizTalk Server 2002 のインストールに必要な操作を行います。このとき、以下の各手順で示される条件を満たすようにします。

  2. [ユーザー情報] ページで、[ユーザー名] ボックスに名前を入力し、[組織] ボックスに会社名を入力して、[次へ] をクリックします。

  3. [インストール先フォルダ] ページで、既定のフォルダ「C:\Program Files\Microsoft BizTalk Server」に BizTalk Server 2002 クライアントをインストールする場合は [次へ] をクリックし、それ以外の場所へインストールする場合は [変更] をクリックします。

  4. [セットアップのタイプ] ページの [クライアント] をクリックし、[次へ] をクリックします。

  5. [プログラムのインストールの開始] ページの [インストール] をクリックします。

  6. Microsoft BizTalk Server 2002 インストール ウィザードの最終ページで、[リリース ノートの表示] をクリックして BizTalk Server 2002 のこのリリースについての重要な最新情報を参照します。

  7. [完了] をクリックしてインストール処理を終了します。


カスタム インストール

Microsoft BizTalk Server 2002 のカスタム インストールのオプションを選択すると、BizTalk Server 2002 のすべての機能をインストールすることも、または必要な機能だけをインストールすることもできます。

注

  • BizTalk Server 2002 のサーバー コンポーネントをインストールする場合は、最初に Microsoft SQL Server をインストールする必要があります。詳細については、「SQL Server の前提条件とインストール要件」を参照してください。

注意

  • BizTalk メッセージ マネージャ ツール、インターネット インフォメーション サービス (IIS)、および BizTalk Server 構成データベースを 3 つの異なるサーバーにインストールしないでください。この構成方法では、認証上の問題が発生します。

BizTalk Server 2002 のカスタム インストールの実行

  1. Microsoft BizTalk Server 2002 の CD を CD-ROM ドライブに挿入して、インストール ウィザードを起動します。インストール ウィザードの説明に従って BizTalk Server 2002 のインストールに必要な操作を行います。このとき、以下の各手順で示される条件を満たすようにします。

  2. [ユーザー情報] ページで、[ユーザー名] ボックスに名前を入力し、[組織] ボックスに会社名を入力し、[次へ] をクリックします。

  3. [インストール先フォルダ] ページで、既定のフォルダ「C:\Program Files\Microsoft BizTalk Server」に BizTalk Server 2002 をインストールする場合は [次へ] をクリックし、それ以外の場所へインストールする場合は [変更] をクリックします。

  4. [セットアップのタイプ] ページの [カスタム] をクリックし、[次へ] をクリックします。

  5. [カスタム セットアップ] ページで、画面上の説明に従って、インストールする BizTalk Server 2002 コンポーネントを選択します。

    ほかの種類のインストールを実行するには、[戻る] をクリックします。続行する場合は、[次へ] をクリックします。選択したインストール コンポーネントによっては、追加情報を入力するためのページが表示されることもあります。

  6. [プログラムのインストールの開始] ページの [インストール] をクリックします。

    BizTalk Server 2002 カスタム インストールには数分かかることがあります。

  7. Microsoft BizTalk Server 2002 インストール ウィザードの最終ページで、[リリース ノートの表示] をクリックして Microsoft BizTalk Server 2002 のこのリリースについての重要な最新情報を参照します。

  8. [完了] をクリックしてインストール処理を終了します。

重要

  • BizTalk メッセージ マネージャは、World Wide Web Publishing Service を実行していないと使用できません。World Wide Web Publishing Service の詳細については、「World Wide Web Publishing Service の開始」を参照してください。

  • BizTalk オーケストレーション サービスのパフォーマンスを大きく向上させるには、エクスプローラで Program Files\Common Files\System\ado に移動し、adofre15.reg をダブルクリックします。確認を求めるダイアログ ボックスが表示されるので、[はい] をクリックし、[OK] をクリックします。この操作を行うと Microsoft® ActiveX® Data Objects (ADO) のスレッド モデルが "Apartment" から "Both" になります。これは ADO を利用するほかのアプリケーションに影響を及ぼす可能性があります。

  • ディスク容量の不要な割り当てを回避するには、Microsoft SQL Server 7.0 の場合は [チェックポイント時のログ切り捨て] チェック ボックスと [自動圧縮] チェック ボックスをオンにします。Microsoft SQL Server 2000 の場合は [設定] の [自動圧縮] チェック ボックスをオンにします。この機能を使用しないと、SQL Server ログに膨大なディスク容量が使用されることがあります。詳細については、「ディスク容量の不要な割り当ての回避」を参照してください。


アップグレード インストール

ここでは、Microsoft BizTalk Server 2002 のサービス、ツール、サンプルのアップグレード方法について説明します。

事前セットアップ

  • BizTalk Server 2002 をアップグレードする前に、現在のシステムの完全なバックアップを行うことをお勧めします。

  • BizTalk Server 2002 をアップグレードする前に、IISAdmin サービスを停止することをお勧めします。このサービスを停止しない場合には、アップグレード後に MscsCore.dll と MSCSAspHelp.dll の 2 つの DLL が存在しなくなる可能性があります。この問題が発生した場合には、この 2 つのダイナミック リンク ライブラリ (DLL) のファイルを BizTalk Server 2002 の CD から探し、Program Files\Common Files directory のディレクトリにコピーして、これらの DLL を登録します。

  • BizTalk Server 2002 へアップグレードするときには、ベータ版の Microsoft BizTalk Server をすべて削除しておく必要があります。

  • BizTalk Server 2002 は Windows 認証を使用して BizTalk メッセージ管理データベース、共有キュー データベース、追跡データベース、および BizTalk ドキュメント トラッキング Web アプリケーションにアクセスします。BizTalk Server 2002 をインストールする前に、SQL Server の認証モードが Windows に設定されていることを確認してください。詳細については、「SQL Server 2000 の SQL 認証モードの設定」を参照してください。SQL Server がリモート コンピュータにインストールされている場合には、使用しているアカウントが SQL Server Administrators グループのメンバかを確認します。詳細については、「SQL Server と BizTalk Server 2002 データベース間の相互作用」を参照してください。

注意

  • 既存のすべての BizTalk Server 製品のファイルはアップグレード処理中に削除されます。BizTalk Server 2000 Services と COM+ パッケージの構成は BizTalk Server 2002 にアップグレードするときに消失します。

重要

  • BizTalk Server 2002 には、Microsoft XML Parser (MSXML) Version 3.0 Service Pack 1 (SP1) が必要です。現在のリリースの BizTalk Server 2002 は、MSXML 3.0 SP1 を自動的にインストールします。BizTalk Server 2002 を異なるバージョンの MSXML とともに使用すると予期しない結果になることがあります。MSXML 3.0 と 4.0 以降の共存インストールが必要な場合には、BizTalk Server 2002 をインストールする前に、MSXML 4.0 をアンインストールする必要があります。さらに、BizTalk Server をインストールした後に、MSXML 4.0を再インストールする必要があります。

BizTalk Server 2002 のアップグレード インストールの実行

  1. Microsoft BizTalk Server 2002 の CD を CD-ROM ドライブに挿入して、インストール ウィザードを起動します。インストール ウィザードの説明に従って BizTalk Server 2002 のアップグレードに必要な操作を行います。以下の各手順で示される条件を満たすようにします。

  2. [ユーザー情報] ページで、[ユーザー名] ボックスに名前を入力し、[組織] ボックスに会社名を入力し、[次へ] をクリックします。

  3. [インストール先フォルダ] ページで、既定のディレクトリにある BizTalk Server をアップグレードする場合は [次へ] をクリックします。

  4. [セットアップのタイプ] ページの [サーバー]、[クライアント]、または [カスタム] をクリックし、[次へ] をクリックします。

    注

    • 既存のすべての BizTalk Server のファイルはアップグレード処理中に削除されます。選択した機能だけがインストールされます。
  5. [BizTalk Server 管理者のアクセス権の構成] で既定のグループ名の [BizTalk Server Administrators] をそのまま使用するか、[グループ名] ボックスに使用するグループ名を入力します。次に、[次へ] をクリックします。

    重要

    • このグループ名を変更するときは、Windows レジストリの HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0\NTGroups にある "AdminGroupName" の値も修正する必要があります。BizTalk Server 2002 は、このレジストリ キーを使用してグループを検索します。

    注

    • グループ名を作成するときは、次のグループ命名規則に従ってください。

      グループ名は、コンピュータ上のほかのグループ名およびユーザー名とは異なるものにします。

      グループ名に ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | ; \\ " ' < > , . および ? の文字を含めることはできません。

      グループ名をピリオド (..) またはスペースだけで構成することはできません。

  6. [BizTalk Server サービス ログオン プロパティ] ページのサービス アカウントの指定に、[特定のアカウント] の既定設定をそのまま使います。このアカウントは、BizTalk Messaging Service を実行するアカウントになります。BizTalk メッセージング サービスが正しく動作するためには、このアカウントに SQL Server へのアクセス許可を与える必要があります。[パスワード] ボックスに有効なパスワードを入力します。

    セットアップ終了時に BizTalk サービスが自動的に開始しないようにするには、[セットアップ完了後にサービスを開始する] チェック ボックスをオフにします。BizTalk Service メッセージ サービスは自動的に開始しません。次に、[次へ] をクリックします。

    注

    • BizTalk Server セットアップでは、[サービスとしてログオン] の権利と [オペレーティング システムの一部として機能] の権利が、[BizTalk サービス ログオン プロパティ] ページで指定されているアカウントに付与されます。

    • [特定のアカウント] を選択し、BizTalk Server の実装で公開キー証明書か秘密キー証明書を使用する場合には、ローカル コンピュータの Windows 2000 Administrators グループにあるアカウントを指定する必要があります。BizTalk メッセージ マネージャを使って、S/MIME コンポーネントの証明書を構成する場合にも、Windows 2000 Administrators グループに属しているアカウントを使用する必要があります。
  7. [プログラムのインストールの開始] ページの [インストール] をクリックします。

  8. [Microsoft BizTalk Server 2002 メッセージ データベース セットアップ ウィザードへようこそ] ページが表示されたら、[次へ] をクリックします。

  9. [BizTalk メッセージ管理データベースを構成します] ページで、[既存のデータベースの選択] または [新しい BizTalk メッセージ管理データベースの作成] をクリックします。

    注

    • BizTalk メッセージ管理データベース (InterchangeBTM)、追跡データベース (InterchangeDTA)、および共有キュー データベース (InterchangeSQ) は、アップグレード処理中に削除されることはありません。新しいデータベースを作成する場合には、データベース名を変更する必要があります。

    • 既存のデータベースを残しておく場合には、インストールを続行する前に、スキーマとストアド プロシージャをアップグレードするかどうかを確認するメッセージが表示されます。既存のデータベース スキーマとストアド プロシージャは、BizTalk Server 2002 と互換性がありません。[はい] をクリックして作業を続けます。
  10. [BizTalk Server グループの構成] ページで、BizTalk Server グループとして使用する名前を [グループ名] ボックスに入力するか、または既定のグループ名 (BizTalk Server グループ) をそのまま使用して、[次へ] をクリックします。

    重要

    • グループ内のすべてのサーバーには、同じバージョンおよび言語の BizTalk Server がインストールされていなければなりません。グループ内に異なるバージョンのBizTalk Server (BizTalk Server 2000、BizTalk Server 2000 SP1、BizTalk Server 2002 Enterprise Edition、または異なる言語バージョンの BizTalk Server など) がインストールされているサーバーがある場合には、データベースは正常に機能しません。
  11. [追跡データベースの構成] ページと [共有キュー データベースの構成] ページで、手順 9. の操作を繰り返して、[次へ] をクリックします。

  12. [BizTalk Server グループの確認] ページで、[BizTalk Server グループのプロパティ] ボックス内の情報が正確であることを確認して、[次へ] をクリックします。

  13. [Microsoft BizTalk Server 2002 メッセージ データベース セットアップ ウィザードの完了] ページで [完了] をクリックして、BizTalk メッセージ管理データベース、追跡データベース、および共有キュー データベースの構成を完了します。

  14. [Microsoft BizTalk Server 2002 オーケストレーション データベース セットアップ ウィザードへようこそ] ページで、[次へ] をクリックしてオーケストレーション データベースをインストールします。

  15. [既定のオーケストレーション データベースの構成] ページで、[既存のデータベースの選択] または [既定のオーケストレーション データベースを新しく作成する] をクリックします。

  16. [完了] をクリックしてアップグレード処理を終了します。

注意

  • BizTalk Server 2002 をコンピュータにインストールした後で、コンピュータ名を変更することはできません。BizTalk Server 2002 はこのコンピュータ名を内部的に使用しています。このコンピュータ名を変更した場合には、BizTalk Server 2002 が異なる名前を検出して、エラー メッセージを生成します。コンピュータ名の変更が必要な場合には、BizTalk Server をアンインストールして、コンピュータ名を変更し、BizTalk Server を再インストールする必要があります。


サイレント インストール

Microsoft Windows インストーラ (Msiexec.exe) は、パッケージを解釈して製品をインストールする実行プログラムです。Msiexec を使用すると、コマンド ラインからプロパティ値を指定できます。この方法を使用すると、Microsoft BizTalk Server 2002 をサイレントに (常に対話や入力を求められることなく) インストールを行うことができます。BizTalk Server 2002 のサイレント インストールは、テスト シナリオや、大規模なエンタープライズ環境への展開に使用するものとして理想的です。

BizTalk Server 2002 のサイレント インストールの実行

  1. [スタート] メニューをクリックし、[ファイル名を指定して実行] をクリックします。

  2. [名前] ボックスに「cmd」と入力し、[OK] をクリックします。

  3. コマンド プロンプトで次の構文を入力して BizTalk Server 2002 をサイレント インストールします。
    msiexec /I "\\server\folder\Microsoft BizTalk Server.msi"
/qb /Lv* "C:\Temp\install.log" INSTALLLEVEL=200
ALLUSERS=1
DSNCONFIG="C:\Temp\BizTalkInstall.ini"

重要

  • パラメータ ALLUSERS=1 を追加して、すべてのユーザーに対してインストールを実行する必要があります。また、このパラメータを追加すると、サービスからレジストリ設定を参照できるようになります。

  • 既定では、サイレント インストール処理にローカル システム アカウントが使用されます。SQL Server がリモート コンピュータにある場合には、このアカウントに SQL Server がインストールされているコンピュータへのアクセス許可を与える必要があります。そうでないと、サイレント インストールに失敗し、BizTalk メッセージ管理データベースにアクセスするときにエラーが発生します。

注

  • 手順 3 の Msiexec の実行では、次のコマンド ライン オプションを使用しています。
    • /I は、製品をインストールまたは構成するコマンド ラインです。

    • /qb は、基本ユーザー インターフェイス (進行状況バーのみ) を提供するコマンド ラインです。

    • /Lv* は、ログ ファイルを作成します。

    • INSTALLLEVEL=200 は、サーバーをインストールします。INSTALLLEVEL を指定しないと、既定値として 100 が設定されます。この値は、BizTalk Server 2002 のクライアント インストールを指定するものです。

    • DSNCONFIG="C:\Temp\BizTalkInstall.ini" は、セットアップ ウィザードにインストール情報を提供します。

BizTalk Server 2002 のインストール プロパティは、コマンド ラインでさまざまなオプションを指定して設定できます。値が指定されないプロパティには、既定値が適用されます。次の表は、BizTalk Server 2002 に固有のプロパティを示しています。

公開プロパティ | 値 | 説明
USERNAME (組み込みインストーラのプロパティ) | <名前> 既定 : {LogonUser} | インストールを実行するユーザーの名前です。[ユーザー情報] ダイアログ ボックスの [ユーザー名] ボックス。
COMPANYNAME (組み込みインストーラのプロパティ) | <組織> 既定 : {LogonCompany} | インストールを実行するユーザーの所属先の名前です。[ユーザー情報] ダイアログ ボックスの [組織] ボックス。
INSTALLLEVEL (組み込みインストーラのプロパティ) | <インストール レベル> 既定 : 100 | 機能インストール レベルです。BizTalk Server 2002 セットアップでは、100 = クライアント セットアップ、200 = サーバー セットアップ。
INSTALLDIR (組み込みインストーラのプロパティ) | <インストール パス> 既定 : "{ProgramFiles} \Microsoft BizTalk Server" | インストール先フォルダを示します。
BTS_GROUP_NAME (サーバー インストールのみ) | <グループ名> 既定 : "BizTalk Server Administrators" | BizTalk Server 2002 Windows NT® グループの名前です。[BizTalk Server 管理者のアクセス権の構成] ページの [グループ名] ボックス。
BTS_GROUP_DESCRIPTION (サーバー インストールのみ) | <グループの説明> 既定 : "メンバは Microsoft BizTalk Server を完全に管理できます" | BizTalk Server 2002 Windows NT グループの説明です。[BiｚTalk Server 管理者のアクセス権の構成] ページの [グループの説明] ボックス。
BTS_USERNAME (サーバー インストールのみ) | <ユーザー名> 既定 : "" | BizTalk Server 2002 サービスのログオン ドメイン名です。[BizTalk Server サービス ログオン プロパティ] ページの [ユーザー名] ボックス。
BTS_PASSWORD (サーバー インストールのみ) | <パスワード> 既定 : "" | BizTalk Server 2002 サービスのログオン パスワードです。[BiｚTalk Server サービス ログオン プロパティ] ページの [パスワード] ボックス。
BTS_SERVER (サーバー インストールとクライアント インストール) | <サーバー名> 既定 : "localhost" | リモートで管理する BizTalk Server の名前です。[BizTalk メッセージ管理データベースを構成します] ダイアログ ボックスの [サーバー名] ボックス。
BTS_SDK_SERVER (サーバー インストールとクライアント インストール) | <サーバー名> 既定 : "localhost" | DCOM 用に使用する BizTalk Server の名前です。[BizTalk Server SDK の DCOM の構成] ページの [サーバー名] ボックス。
DSNCONFIG (初期化ファイル) | <パス名> 既定 : "" | 使用するデータベース セットアップ ウィザード BTSsetupDB.exe および XLANGsetupDB.exeの初期化ファイルのパスです。

注

  • DSNCONFIG プロパティは、BizTalk Server 2002 のサイレント インストールを実行するために必要です。コマンド ラインで指定した初期化パス ファイルは、BTSsetupDB.exe および XLANGsetupDB.exe データベース セットアップ ウィザードに渡されます。次のコマンド ライン値のいずれか 1 つを使用します。
    • DSNCONFIG="<BTSsetupDB.exe および XLANGsetupDB.exe の .ini ファイルへの完全なパス>"

      または

    • BTSSETUPDB.INI="<BTSsetupDB.exe の .ini ファイルへの完全なパス>" および XLANGSETUPDB.INI="<XLANGsetupDB.exe の .ini ファイルへの完全なパス>"
  • データベース セットアップ ウィザードは、次の規則を使用して初期化ファイルの内容を処理します。
    • [<セクション>] と keys= はすべてオプションです。キーが指定されない場合は、サンプルの初期化ファイルに示されている既定値が使用されます。

    • 指定した BizTalk メッセージ管理データベースに GroupName の値がある場合は、そのグループが [InterchangeDTA] セクションと [InterchangeSQ] セクションを定義するので、これらのセクションの値は無視されます。

    • 指定したデータベースが指定したサーバー上にまだ存在しない場合は、それらのデータベースが作成されます。
  • BizTalk メッセージ管理データベース セットアップとオーケストレーション データベース セットアップは相互に独立しています。

  • インストールする機能に応じて、セットアップは、次のデータベースの一方だけを構成する場合と、どちらも構成する場合と、どちらも構成しない場合があります。
    • BizTalk メッセージ管理データベース : BizTalk メッセージ サービスと、関連するコンポーネントがインストールされている場合にだけ構成されます。

    • オーケストレーション データベース : BizTalk オーケストレーション サービスがインストールされている場合にだけ構成されます。
  • コマンド ラインでは次のプロパティを使用します。
    • DSNCONFIG : BTSsetupDB.exe および XLANGsetupDB.exe によって使用される .ini ファイルの場所を指定します。

      または

    • BTSSETUPDB.INI : BTSsetupDB.exe によって使用される .ini ファイルの場所を指定します。

    • XLANGSETUPDB.INI : XLANGsetupDB.exe によって使用される .ini ファイルの場所を指定します。

すべての [<セクション>]、keys=、および既定値が示されたサンプル初期化ファイル

次に、BizTalk Server 2002 のサイレント インストールに必要な .ini ファイルの書式の例を示します。これらのコマンド ライン プロパティは、Microsoft Windows インストーラを使用して BizTalk Server 2002 の最初の初期化を行うときに必要になります。

SetupDB.ini の例

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Messaging Management database
; Required section used by BTSsetupDB.exe only.
; Specify new or existing database.
;
[InterchangeBTM]
Server=localhost
Username=sa
Password=
Database=InterchangeBTM

;----------------------------------------------------------------------
; Name for BizTalk Server Group
; Required section used by BTSsetupDB.exe only.
; Specify new or existing server group.
;
[Group]
GroupName=BizTalkGroup

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Tracking database
; Required section used by BTSsetupDB.exe only.
; Optional if existing server group specified.
;
[InterchangeDTA]
Server=localhost
Username=sa
Password=
Database=InterchangeDTA

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Shared Queue database
; Required section used by BTSsetupDB.exe only.
; Optional if existing server group specified.
;
[InterchangeSQ]
Server=localhost
Username=sa
Password=
Database=InterchangeSQ

;----------------------------------------------------------------------
; SQL Server connection parameters for Orchestration database
; Required section used by XLANGsetupDB.exe only.
; Specify new or existing Orchestration database.
;
[Orchestration]
Server=localhost
Database=XLANG

次の表は、サンプルの BizTalkDB.ini 初期化ファイルのプロパティ、値について説明しています。

プロパティ | 値 | 説明
[InterchangeBTM] Server=BIZTALK この第 1 の SQL Server に、既定のユーザー名とパスワードでログオンします。
Database=BizTalkBTM

サーバー上にこの BizTalk メッセージ管理データベースがまだ存在しない場合は、作成します。
[Group] | GroupName=BizTalkServerGroup | このグループが既に存在している場合は、そのほかの値は無視されます。
[InterchangeDTA] Server=DTA-SERVER この第 2 の SQL Server に、既定のユーザー名とパスワードでログオンします。
Database=BizTalkDTA

サーバー上にこの追跡データベースがまだ存在しない場合は、作成します。
[InterchangeSQ] Server=SQ-SERVER この第 3 の SQL Server に、既定のユーザー名とパスワードでログオンします。
Database=BizTalkSQ

サーバー上にこの共有キュー データベースがまだ存在しない場合は、作成します。
[Orchestration] Server=localhost この第 4 の SQL Server に、既定のユーザー名とパスワードでログオンします。
Database=BizTalkXLANG

サーバー上にこのオーケストレーション データベースがまだ存在しない場合は、作成します。

Microsoft Windows インストーラのコマンド ライン オプション

Microsoft Windows インストーラ (Msiexec.exe) は、パッケージを解釈して製品をインストールするプログラムです。また、このプログラムは、戻り値として返す、Microsoft® Win32® エラー コードに対応したエラー レベルも設定します。次の表は、前の表に示したプロパティおよび値に追加して使用できる、このプログラムのコマンド ライン オプションを示しています。

オプション | パラメータ | 説明
/I | <パッケージ>|<製品コード> | 製品をインストールまたは構成します。
/f [p|o|e|d|c|a|u|m|s|v] <パッケージ>|<製品コード> 製品を修復します。このオプションは、コマンド ラインで入力されたプロパティ値を無視します。このオプションの既定の引数一覧は pecms です。このオプションは、REINSTALLMODE プロパティと同じ引数一覧を共用します。

p : ファイルがない場合にだけ再インストールを行います。

o : ファイルがないか、または古いバージョンである場合に再インストールを行います。

e : ファイルがないか、現在と同じバージョンか、または古いバージョンである場合に再インストールを行います。

d : ファイルがないか、またはバージョンが異なる場合に再インストールを行います。

c : ファイルがないか、または格納されているチェックサムが計算値と一致しない場合に再インストールを行います。File テーブルの Attributes 列に msidbFileAttributesChecksum が設定されているファイルだけを修復します。

a : すべてのファイルを強制的に再インストールします。

u : 必要なすべてのユーザー固有レジストリ エントリを再書き込みします。

m : 必要なすべてのコンピュータ固有レジストリ エントリを再書き込みします。

s : 既存のすべてのショートカットを上書きします。

v : ソースから実行し、ローカル パッケージを再キャッシュします。
/a | <パッケージ> | 管理インストールのオプションです。ネットワーク上で製品をインストールします。
/x | <パッケージ>|<製品コード> | 製品をアンインストールします。
/j [u|m]<パッケージ>

または

[u|m]<パッケージ> /t <変換一覧>

または

[u|m]<パッケージ> /g <言語 ID>

 製品を通知します。このオプションは、コマンド ラインで入力されたプロパティ値を無視します。

u : 現在のユーザーに通知します。

m : コンピュータのすべてのユーザーに通知します。

t : 通知されたパッケージに変換を適用します。

g : 言語 ID です。
/L [i|w|e|a|r|u|c|m|o|p|v|+|!]<ログ ファイル> ログ ファイルへのパスを指定します。フラグは、どの情報をログに記録するかを示します。

i : ステータス メッセージ

w : 致命的ではない警告

e : すべてのエラー メッセージ

a : アクションのスタートアップ

r : アクション固有のレコード

u : ユーザー要求

c : UI パラメータの初期値

m : メモリ不足または致命的な終了の情報

o : ディスク容量不足のメッセージ

p : ターミナル プロパティ

v : 詳細出力

+ : 既存のファイルに追加

! : 1 行ごとにログにフラッシュ

"*" : ワイルドカード。v オプション以外のすべての情報をログに記録。v オプションも含める場合は、"/l*v" と指定。
/m <ファイル名> Systems Management Server (SMS) のステータス .mif ファイルを作成します。インストール (-i)、削除 (-x)、管理インストール (-a)、または再インストール (-f) の各オプションと一緒に使用する必要があります。Ismif32.dll は SMS の一部としてインストールされているので、パス上に存在している必要があります。

ステータス .mif ファイルの各フィールドには、次の情報が格納されています。

  • Manufacturer : 作成者

  • Product : 改訂番号

  • Version : 件名

  • Locale : テンプレート

  • Serial Number : 設定されていません。

  • Installation : Ismif32.dll により "DateTime" に設定されます。

  • InstallStatus : "Success" または "Failed"。

  • Description : エラー メッセージが次の順序で格納されます。1} インストーラが生成したエラー メッセージ、2} インストールを開始できなかったか、ユーザーが終了した場合は、Msi.dll からのリソース、3} システム エラー メッセージ ファイル、4} 書式付きメッセージ。"Installer error %i"。%i は Msi.dll から返されたエラー。
/p <修正プログラム> 修正プログラムを適用します。インストールされている管理イメージに修正プログラムを適用するには、オプションを次のように組み合わせます。

/p <修正プログラム> /a <パッケージ>
/q n|b|r|f ユーザー インターフェイス (UI) レベルを設定します。

q、qn : UI なし

qb : 基本 UI

qr : インストールの最後にモーダル ダイアログ ボックスが表示される簡略 UI

qf : 最後にモーダル ダイアログ ボックスが表示される完全 UI

qn+ : 最後にモーダル ダイアログ ボックスが表示されることを除いて UI なし

qb+ : 最後にモーダル ダイアログ ボックスが表示される基本 UIユーザーがインストールをキャンセルすると、モーダル ダイアログ ボックスは表示されません。

qb- : モーダル ダイアログ ボックスが表示されない基本 UI/qb+- は、サポートされている UI レベルではありません。
/?

または

/h

   Windows インストーラの著作権情報を表示します。
/y <モジュール> システムの API DllRegisterServer を呼び出して、コマンド ラインで渡されたモジュールを自動登録します。たとえば、msiexec /y my_file.dll のように入力します。

このオプションは、.msi ファイルのレジストリ テーブルを使用して追加できないレジストリ情報に対してだけ使用します。
/z <モジュール> システムの API DllUnRegisterServer を呼び出して、コマンド ラインで渡されたモジュールの登録を解除します。たとえば、msiexec /z my_file.dll のように入力します。

このオプションは、.msi ファイルのレジストリ テーブルを使用して削除できないレジストリ情報に対してだけ使用します。

注

  • 上の表について説明します。
    • オプション /i、/x、/f[p|o|e|d|c|a|u|m|s|v]、/j[u|m]、/a、/p、/y、および /z は、一緒に使用しないでください。この規則の唯一の例外は管理インストールに修正プログラムを適用する場合で、/p と /a を一緒に使用します。

    • オプション /t および /g と一緒に使用できるのは、/j だけです。

    • オプション /l および /q は、/i、/x、/f[p|o|e|d|c|a|u|m|s|v]、/j[u|m]、/a、および /p と一緒に使用できます。

プロパティおよび値の構文規則

コマンド ラインを使用して変更できるのは、公開プロパティだけです。コマンド ラインで入力されるプロパティ名はすべて大文字として解釈されますが、値は大文字と小文字が区別されます。コマンド ラインに「MyProperty」と入力すると、インストーラは、Property テーブルの MyProperty という値ではなく MYPROPERTY という値を上書きします。PROPERTY を VALUE に設定して製品をインストールするには、コマンド ラインで次の構文を使用します。プロパティは、オプションとその引数との間を除いた任意の位置に入力できます。

正しい構文は次のようになります。

msiexec /i A:\Example.msi PROPERTY=VALUE

次の構文は正しくありません。

msiexec /i PROPERTY=VALUE A:\Example.msi

プロパティ値がリテラル文字列の場合は、引用符で囲む必要があります。引用符に囲まれた文字列には空白を含めることができます。

msiexec /i A:\Example.msi PROPERTY="Embedded White Space"

コマンド ラインを使用して公開プロパティを消去するには、その値を空の文字列に設定します。

msiexec /i A:\Example.msi PROPERTY=""

テキストの一部がリテラル引用符で囲まれている場合は、その部分をさらに引用符で囲んでください。

msiexec /i A:\Example.msi PROPERTY="Embedded ""Quotes"" White Space"

複雑なコマンド ラインの例を次に示します。

msiexec /i testdb.msi INSTALLLEVEL=3 /l* msi.log COMPANYNAME="Acme ""Widgets"" and ""Gizmos."""

通知オプションの例を次に示します。スイッチは大文字と小文字が区別されません。

msiexec /JM msisample.msi /T transform.mst /G langid /LIME logfile.txt

Microsoft Windows インストーラの詳細については、Microsoft® MSDN® Web サイト (msdn.microsoft.com/downloads/) を参照してください。


BizTalk Server 2002 の削除

Microsoft BizTalk Server 2002 を削除するには、Microsoft Windows 2000 の [アプリケーションの追加と削除] の機能を使用します。

注

  • BizTalk Server のアンインストール処理では、SQL データベースや、WebDAV に格納されたマップおよびスキーマは削除されません。BizTalk Server のディレクトリに追加されたファイルもすべて残されます。

  • クラスタ環境では、BizTalk Server 2002 をアンインストールする前に、使用するコンピュータと BizTalk Server データベースが置かれているコンピュータ、およびグループ内のそのほかの BizTalk Server との間でネットワーク接続が確立されていることを確認します。アンインストール中にエラーが発生した場合には、次の COM+ アプリケーションを手動で削除する必要があります。
    • BTS インターチェンジ

    • BTS 内部ユーティリティ

    • XLANG スケジューラ

    • XLANG 永続化ヘルパ

BizTalk Server 2002 の削除

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [アプリケーションの追加と削除] をダブルクリックします。

    [アプリケーションの追加と削除] ダイアログ ボックスが表示されます。

  3. [Microsoft BizTalk Server 2002] をクリックし、[削除] をクリックします。

  4. BizTalk Server 2002 の削除を確認するメッセージが表示されたら [はい] をクリックします。


セキュリティについて

Microsoft® BizTalk™ Server 2002 を使用すると、企業は Microsoft Windows® 2000 セキュリティによって提供されるセキュリティ機能を活用して取引先と安全にデータ交換を行うことができます。

BizTalk Server で使用するWindows 2000 のセキュリティ機能には、以下があります。

  • Windows アカウント セキュリティおよびローカル ポリシー

  • 統合 Windows および Microsoft SQL Server™ ログオン セキュリティ

  • Microsoft コンポーネント サービス セキュリティおよびロール

  • 公開キー基盤 (PKI)

  • CryptoAPI

  • スマート カード

  • Kerberos プロトコル

BizTalk Server は、ツール (たとえば、BizTalk Server 管理コンソール)、API (たとえば、Windows Management Instrumentation)、COM+ アプリケーション、またはその他のリソースへのアクセスを管理します。管理は特定のユーザー アカウントにリソースへのアクセス許可を付与することによって行われます。ユーザー アカウントに権限を付与する 1 つの方法は、BizTalk Server で作成された Windows グループにアカウントを追加することです。BizTalk Server がインストールされると、2 つのローカル Windows グループが作成されます。このグループは、BizTalk Server Administrators と BizTalk Server Report Users です。BizTalk Server コンピュータに作成されたこれらのグループにユーザー アカウントを追加すると、それらのアカウントに BizTalk Server へのいくつかの権限が付与されます。たとえば、そのコンピュータのBizTalk メッセージ マネージャまたは BizTalk Server 管理コンソールを開くには、ログオンして BizTalk Server Administrators グループにあるアカウントを使用する必要があります。

さらに、ある作業を行うには、オペレーティング システム レベルで特定のアクセス許可が付与される必要があります。たとえば、保留キューの Windows Management Instrumentation (WMI) イベントを生成するには、BizTalk Server メッセージ サービス アカウントに BizTalk Server Windows Management Instrumentation 名前空間への完全権限を付与する必要があります。

BizTalk Server は、SQL Server 統合セキュリティを活用して、SQL Server へのアクセスを管理します。SQL Server 統合セキュリティを使用すると、SQL Server は Windows 認証を信頼し、SQL リソースへのアクセス許可を付与します。既定では、BizTalk Server に必要な SQL Server データベースのどれか 1 つにアクセスする必要があるすべてのアカウントに SQL Server 統合ログオンが提供されていて、データベースへのアクセス許可が付与されている必要があります。詳細については、「SQL Server と BizTalk Server 2002 データベース間の相互作用」を参照してください。オーケストレーション データベースへの接続は例外として、BizTalk Server ツールや実行時サービスによるデータベース アクセスは、統合セキュリティ以外の方法では構成できません。

Windows 2000 の管理ツールの 1 つであるコンポーネント サービスでは、データの整合性を保護する自動トランザクション サポート、および簡潔で強力なロール ベースのセキュリティなど、総合的なコンポーネント機能を提供しています。

BizTalk Server は、PKI と S/MIME (Secure Multipurpose Internet Mail Extensions) を使用して取引先間のセキュリティを管理します。公開キー証明書と秘密キー証明書を交換して、取引先は互いを確認して、x.509 でデジタル署名されたメッセージと S/MIME (またはそれ自体のコンポーネントを使用するカスタム暗号化) を使用して通信を暗号化できます。詳細については、「証明書の概要」を参照してください。

BizTalk Server では、Windows 2000 の SSL (Secure Sockets Layer) を利用しているので、取引先は Web ページを作成および使用して、インターネットでデータを安全に交換できます。SSL とは、インターネット インフォメーション サービス (IIS) で実装されたプロトコルで、Web クライアントと Web サーバーとの間で秘密を保持できるように設計されたものです。SSL は相互に使用できる暗号アルゴリズムから使用するものを決定するハンドシェイク フェーズから始まり、公開キーと秘密キーを確認し、サーバーからクライアントへの認証を行います。ハンドシェイクが完了し、アプリケーション データの転送が開始されると、ハンドシェイク中に決定したセッション キーを使ってデータをすべて暗号化します。PKI 標準、および IPSec、L2TP、SSL/TLS、S/MIME などのセキュリティで保護されたプロトコルのサポートにより、ネットワークをサプライヤや取引先まで迅速に拡張でき、また、偽装 (なりすまし)、データの盗難、悪意のあるハッカーから防御することができます。

ここには次のトピックが含まれます。

  • ログオンのプロパティ

  • ローカル ポリシー

  • セキュリティ ガイドライン

  • BizTalk Server Administrators グループ

  • BizTalk メッセージ サービス

  • BizTalk Server インターチェンジ アプリケーション セキュリティ

  • XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

  • BizTalk Server Report Users グループ

  • トランスポート サービス

  • 証明書の概要

  • CryptoAPI

  • Collaboration Data Objects

  • ファイアウォールの構成

関連項目

管理者特権


ログオンのプロパティ

ログオンのプロパティは、BizTalk Server 2002 のセキュリティの第一層となります。これらのプロパティは、特定のコンピュータやドメインにログオンして、そのコンピュータやドメインで特定作業を行うユーザーの権限を管理します。ログオンのプロパティによって、ユーザーはファイル共有やメッセージ キューなどのリソースにアクセスする場合に、ユーザー名とパスワードを入力することを求められます。HTTP や SMTP で受信したメッセージでも、セキュリティにログオンのプロパティが使用されています。たとえば、HTTP で ASP ページにアクセスしたユーザーは、Web ページのコンテンツを表示する前にユーザー名とパスワードの入力を求められることがあります。

BizTalk Server はインターネット インフォメーション サービス (IIS) と ASP ページを使用して、ドキュメントを受信します。ASP ページ (実際はページの背後に隠されているコード) は、Secure Sockets Layer (SSL) からの署名を確認し、IIS を経由して証明書などの追加セキュリティを最大化することにより、BizTalk Server のセキュリティの層を提供しています。IIS セキュリティの詳細については、Windows 2000 のヘルプの「インターネット インフォメーション サービス」を参照してください。

関連項目

管理者特権


ローカル ポリシー

[ローカル セキュリティ設定] コンソールの [ローカル ポリシー] では、ユーザー アカウントまたはサービス アカウントのセキュリティ オプションを指定します。ローカル ポリシーは、ユーザーがログオンしているコンピュータと、そのコンピュータに対してユーザーが所有している権利を基にしています。ローカル ポリシーを設定するには、[スタート] ボタンをクリックし、[設定] をポイントします。次に、[コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。それから [ローカル セキュリティ ポリシー] をダブルクリックし、[ローカル ポリシー] フォルダを展開します。

ローカル ポリシーでは、BizTalk Server 2002 ユーザーの権限と権利を定義します。次のものを構成できます。

  • 監査ポリシー : コンピュータのセキュリティ ログに記録するセキュリティ イベント (試行の成功または失敗あるいはその両方) を指定します。セキュリティ ログは、イベント ビューアにあります。

  • ユーザーの権利の割り当て : コンピュータに対してログオン権限や操作権限を持つユーザーまたはグループを指定します。

  • セキュリティ オプション : データのデジタル署名、Administrator と Guest のアカウント名、フロッピー ドライブと CD-ROM へのアクセス、ドライバのインストール、ログオン画面など、コンピュータの各種セキュリティ設定を有効または無効にします。

[ローカル セキュリティ設定] コンソールにあるほかのポリシーを構成して、データの整合性を維持できます。たとえば、[アカウント ポリシー] では次のものを構成できます。

  • パスワードのポリシー : ローカル ユーザー アカウントに対して、パスワードの強制や有効期間などを設定します。

  • アカウント ロックアウトのポリシー : ローカル ユーザー アカウントに対して、ロックアウトの期間やロックアウトの対象を設定します。

重要

  • ローカル ポリシーは、定義上は、コンピュータに対してローカルとなります。ローカル ポリシーの設定を Active Directory のグループ ポリシー オブジェクトにインポートすると、そのグループ ポリシー オブジェクトが適用されるコンピュータのアカウントのローカル セキュリティ設定が影響を受けます。したがって、セキュリティ ポリシーの優先順位に注意することが重要です。ローカル レベルで設定されたポリシーは、グループ ポリシー (組織単位) に関連付けられたセキュリティ ポリシーによって上書きされます。また、ドメインのポリシーによっても上書きされます。いずれの場合も、ユーザー アカウントの権利は、ローカル ポリシーの設定で上書きされると、適用されなくなります。Microsoft Windows 2000 での動作は Microsoft Windows NT のものとまったく異なるため、注意が必要です。たとえば、ドメイン グループ ポリシーに既定のままのパスワード ポリシーを構成すると、このドメインのすべてのコンピュータにこのパスワード ポリシーが適用されます。つまり、このドメイン内の各ワークステーションのローカル アカウント データベースのパスワード ポリシーは、ドメインのパスワード ポリシーと同じになります。

注

  • 公開キーのローカル ポリシーは設定しないでください。公開キーにより、BizTalk Server のセキュリティが保護されています。公開キーは、データの暗号化と暗号解読に使う証明書のコンポーネントです。公開キーにポリシーを追加すると、BizTalk Server では関連付けられた証明書を使用できなくなります。

関連項目

管理者特権


セキュリティ ガイドライン

BizTalk Server 2002 は SQL Server 資格情報を使用するのでなく、統合 Windows NT セキュリティを使用して SQL Server へアクセスします。つまり、BizTalk Server は現在ログオンしているユーザーの資格情報を使用して SQL Server の特権を判断します。したがって、BizTalk Server 管理コンソール関連のコンポーネントをインストールおよび構成するときは、セキュリティ上のいくつかの問題を考慮する必要があります。

BizTalk Server 機能 | セキュリティ ガイドライン
BizTalk Server 管理コンソール
  • ユーザーは BizTalk Server Administrators グループのメンバである必要があります。詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。

  • ユーザーは共有キューとBizTalk メッセージ管理データベースへの完全なアクセス許可を持っていて、そのデータベースの db_owner ロールのメンバである必要があります。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。
BizTalk メッセージ マネージャ
  • ユーザーは BizTalk Server Administrators グループのメンバである必要があります。詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。

  • ユーザーは共有キューと BizTalk メッセージ管理データベースへの完全なアクセス許可を持っていて、そのデータベースの db_owner ロールのメンバである必要があります。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。
BizTalk メッセージ構成オブジェクト モデル
  • ユーザーは BizTalk Server Administrators グループのメンバである必要があります。詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。

  • ユーザーは共有キューと BizTalk メッセージ管理データベースへの完全なアクセス許可を持っていて、そのデータベースの db_owner ロールのメンバである必要があります。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。
BizTalk メッセージ サービス
  • BizTalk Server メッセージ サービスのアカウントには [サービスとしてログオン] セキュリティ ポリシーが割り当てられている必要があります。

  • BizTalk Server メッセージ サービス アカウントには、Windows Management Instrumentation (WMI) 名前空間 "Root\MicrosoftBizTalkServer" への完全なアクセス許可が付与されている必要があります。詳細については、「WMI 名前空間アクセス許可の Windows アカウントへの付与」を参照してください。

  • ユーザーは共有キュー、追跡、および BizTalk メッセージ管理のデータベースへの完全なアクセス許可を持っていて、そのデータベースの db_owner ロールのメンバである必要があります。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。

  • 受信機能のどれかにユーザー名/パスワードが指定されている場合、その受信機能ユーザー アカウントに [ローカル ログオン] および [オペレーティング システムの一部として機能する] セキュリティ ポリシーが付与される必要があります。

  • HTTP 受信機能が作成されている場合は、関連付けられたBizTalk ISAPI Extension が追加セキュリティ構成を要求します。詳細については、「IIS の保護レベルを利用したアクセス特権の設定」を参照してください。
BizTalk Server インターチェンジ アプリケーション (COM+)
  • アプリケーション ID アカウントに、WMI 名前空間 "Root\MicrosoftBizTalkServer" への完全なアクセス許可が付与されている必要があります。詳細については、「WMI 名前空間アクセス許可の Windows アカウントへの付与」を参照してください。

  • アプリケーション ID アカウントは、共有キュー、追跡、および BizTalk メッセージ管理のデータベースへの完全なアクセス許可を持っていて、そのデータベースの db_owner ロールのメンバである必要があります。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。
BizTalk Server ドキュメント トラッキングのユーザー インタフェース （UI）
  • ユーザー アカウントは、追跡データベースへの完全なアクセス許可を持っていて、そのデータベースの db_owner ロールのメンバである必要があリます。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。

  • ユーザー アカウントは、BizTalk Server Report Users グループのメンバである必要があります。
XLANG スケジューラ アプリケーション (COM+)
  • オーケストレーション データベースにアクセスするときのデータ ソース名 (DSN) が (既定として) Windows 認証で構成されている場合、XLANG スケジュール インスタンスを操作するユーザーの資格情報には、オーケストレーション データベースへの完全なアクセス許可があって、そのデータベースの db_owner ロールのメンバである必要があります。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。

  • DSN が SQL 認証で構成されている場合は、使用される SQL ログオンには、オーケストレーション データベースへの完全なアクセス許可があって、そのデータベースのdb_owner ロールのメンバである必要があります。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。

  • XLANG スケジュール インスタンスを操作するユーザーは、BizTalk XLANG スケジューラ アプリケーションの COM+ で構成された XLANG スケジュール ユーザー ロールのメンバである必要があります。詳細については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。
BizTalk SEED ウィザード
  • ユーザーは BizTalk Server Administrators グループのメンバである必要があります。詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。

  • ユーザーは BizTalk メッセージ管理データベースへの完全なアクセス許可を持っていて、そのデータベースの db_owner ロールのメンバである必要があります。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。
Application Center 2000 を使用した BizTalk の展開
  • ユーザーは BizTalk Server Administrators グループのメンバである必要があります。詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。

  • ユーザーは BizTalk メッセージ管理データベースへの完全アクセスな許可を持っていて、そのデータベースの db_owner ロールのメンバである必要があります。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。
XLANG モニタ
  • ユーザーはXLANG スケジュールと、XLANG スケジュールをホストする COM+ アプリケーションのXLANG スケジュール作成者ロールのメンバである必要があります。詳細については、「BizTalk Server インターチェンジ アプリケーションへのロールの追加」を参照してください。ただし、この操作を行うときは、BizTalk Server インターチェンジ アプリケーションを、XLANG スケジュールをホストする COM+ アプリケーションに置き換える必要があります。
アプリケーション デザイナ | セキュリティ要件はありません。
BizTalk エディタおよび BizTalk マッパー | セキュリティ要件はありません。

ここには次のトピックが含まれます。

  • SQL ログオンの作成およびデータベース アクセスの付与

  • WMI 名前空間アクセス許可の Windows アカウントへの付与


SQL ログオンの作成およびデータベース アクセスの付与

BizTalk Server で使用されるアカウントが SQL Server データベースにアクセスするには、このアカウントに明示的にアクセス許可を付与する必要があります。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Servers] を展開し、[SQL Server グループ] を展開します。次にBizTalk メッセージ管理および共有キューのデータベースを含む個々のサーバーを展開します。

  3. [セキュリティ] フォルダを展開し、[ログイン] を右クリックしてから、[新規ログイン] をクリックします。

    [SQL Server ログインのプロパティ – 新規ログイン] ページが表示されます。

  4. [名前] ボックスで、SQL ログオンを作成する Windows アカウントの名前を入力します。

  5. [認証] で、[Windows 認証] が選択されていることを確認して、Windows アカウントのドメインを入力します。[OK] をクリックします。

  6. [データベース アクセス] タブをクリックして、アクセス許可を変更するデータベースの [権限] をオンにします。次に、[データベース ロール内の権限] リストから [db_owner] を選択します。

  7. 共有キュー データベースの [権限] ボックスをクリックし、[データベース ロール内の権限] の一覧から [db_owner] をクリックしてから、[OK] をクリックします。


WMI 名前空間アクセス許可の Windows アカウントへの付与

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に、[コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

    [コンピュータの管理] コンソールが表示されます。

  2. [サービスとアプリケーション] を展開し、[WMI コントロール] を右クリックします。次に、[プロパティ] をクリックします。

    [WMI コントロールのプロパティ] ダイアログ ボックスが表示されます。

  3. [セキュリティ] タブをクリックし、[Root] ノードをダブルクリックします。次に、[MicrosoftBizTalkServer] 名前空間をクリックします。

  4. [セキュリティ] ボタンをクリックします。

    [セキュリティ ROOT\MicrosoftBizTalkServer] ダイアログ ボックスが表示されます。

  5. [追加] ボタンをクリックします。

    [ユーザー、コンピュータ、またはグループの選択] ダイアログ ボックスが表示されます。

  6. WMI 名前空間にアクセス許可を付与する Windows アカウントの名前を入力して、[OK] をクリックします。

  7. すべての [アクセス許可] に [許可] が選択されていることを確認します。

  8. [OK] をクリックします。

  9. [OK] をクリックして [WMI コントロールのプロパティ] ダイアログ ボックスを閉じます。


BizTalk Server Administrators グループ

インストール中に、BizTalk Server 2002 はローカル コンピュータに Windows グループを作成します。このとき、そのメンバには BizTalk Server への管理特権およびその他の特権が付与されます。既定では、このグループには BizTalk Server Administrators と名前が付けられています。セットアップを実行するユーザーは、この名前を変更することができます。ただし、インストール後にその名前を変更することはできません。インストール時に、BizTalk Server は組み込みローカル Administrators グループを追加して、現在ログオンしているユーザー アカウントをこのグループに追加します。

BizTalk Server Administrators グループの主要な目的は、ツールと BizTalk Server から提供されるアプリケーション プログラミング インターフェイス (API) へのアクセスを管理することです。ユーザーにこのグループのメンバであることを要求するリソースの詳細については、「セキュリティ ガイドライン」を参照してください。

注

  • BizTalk Server が正常に機能するにあたっては、BizTalk メッセージ サービスが実行されるサービス アカウントがこのグループのメンバである必要はありません。


BizTalk メッセージ サービス

BizTalk メッセージ サービスは、BizTalk メッセージの実行時機能の本質を提供する Windows サービスです。Windows サービスとして、BizTalk メッセージ サービスはそれ自体のセキュリティ コンテキスト (ローカル システムまたは BizTalk Server メッセージ サービス アカウントとして知られるユーザーに作成されたサービス アカウント) のもとで実行されます。サービス アカウントは Windows ユーザー アカウントであり、[オペレーティング システムの一部として機能する] と [サービスとしてのログオンする] という特別な権限が付与されています。セットアップ中、BizTalk Server は、BizTalk Server メッセージ サービス アカウントとしてユーザーが指定したアカウントにこれらの権限を付与します。詳細については、「インストールに関する説明」を参照してください。

Windows のローカルまたはドメイン サービス アカウントに対して、ローカル システムを使用する 2 つの理由は、主として次の 2 つの要因によって決定されます。

  1. SQL Server トポロジ : BizTalk Server メッセージ サービス アカウントには、それが機能するようにBizTalk Server で使用する SQL Server データベースへのアクセスが付与される必要があります。BizTalk Server が使用する SQL Server データベースのあるコンピュータで BizTalk Server を実行している場合は、どのアカウントでも使用できます。ただし、BizTalk Server が実行されているコンピュータと異なるコンピュータ上にある SQL Server を使用している場合、最も有用であるのは、BizTalk Server メッセージ サービス アカウントとして Windows ドメイン アカウントを使用することです。同一のドメイン アカウントを使用するように BizTalk Server を構成すると、そのドメイン アカウントにアクセス許可を付与することによって一度にすべてのBizTalk Server に SQL Server へのアクセス許可が付与されます。

  2. デジタル証明書の使用 : BizTalk Server のデジタル署名および暗号機能を利用する場合、BizTalk Server メッセージ サービス アカウントが、組み込みのローカル Windows Administrators グループのメンバである必要があります。これは、ローカル コンピュータのデジタル証明書ストアにアクセスするときに要求されます。

注

  • BizTalk Server を正常に機能させるとき、BizTalk Server メッセージ サービス アカウントが BizTalk Server Administrators グループのメンバである必要はありません。


BizTalk Server インターチェンジ アプリケーション セキュリティ

ドキュメントを BizTalk Server 2002 にプログラムを通して送信するために使用される COM+ インターフェイスは、BizTalk Server インターチェンジ アプリケーションという名前の COM+ アプリケーションの中にあります。これは、セットアップ時に BizTalk Server によって作成されます。既定では、このアプリケーションの ID は対話ユーザーとして構成されます。しかし、これが変更されないままだと、プログラムからの送信が行われるたびにユーザーのログオンが必要になります。明らかに、これではほとんどの目的に適していません。BizTalk Server インターチェンジ アプリケーションを構成して、特定のサービス アカウントで実行されるようにするには、「COM+ アプリケーションのアプリケーション ID の変更」を参照してください。

BizTalk Server インターチェンジ アプリケーション COM+ コンポーネントを適切に構成することによって、プログラムから IInterchange COM+ インターフェイスを介して作業項目を BizTalk Server に送信するためのユーザーの権限を管理することができます。プログラムから作業項目を送信するためのユーザーの権限を管理するには、初めに BizTalk Server インターチェンジ アプリケーションにロールを追加する必要があります。次にそのロールを Submit および SubmitSync メソッドと関連付け、最後にそのメソッドへのアクセス許可を付与するユーザー アカウントをロールに追加する必要があります。

ここには次のトピックが含まれます。

  • BizTalk Server インターチェンジ アプリケーションへのロールの追加

  • Submit メソッドおよび SubmitSync メソッドへの新しいロールの関連付け

関連項目

管理者特権


BizTalk Server インターチェンジ アプリケーションへのロールの追加

BizTalk Server インターチェンジ アプリケーションへ作業項目を送信する個々のユーザーの権限を管理するには、ロール メンバシップを作成する必要があります。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

    [コンポーネント サービス] コンソールが表示されます。

  2. [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に、[マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [BizTalk Server Interchange Application] を右クリックし、[プロパティ] をクリックします。

    [BizTalk Server Interchange Application のプロパティ] ダイアログ ボックスが表示されます。

  4. [詳細設定] タブをクリックして [許可] の [変更を許可しない] チェック ボックスをオフにし、[OK] をクリックします。次に、メッセージ ダイアログ ボックスで [はい] をクリックします。

  5. 手順 3. を繰り返します。

  6. [セキュリティ] タブをクリックし、[アクセス権限] の [このアプリケーションへのアクセス チェックを行う] チェック ボックスをオンにします。

  7. [セキュリティ レベル] で、[プロセスおよびコンポーネント レベルでのアクセス チェックを実行する。セキュリティのプロパティはオブジェクトのコンテキストに含まれます。COM+ セキュリティ呼び出しのコンテキストが利用できます]をクリックします。

  8. [OK] をクリックします。

  9. 確認ダイアログ ボックスで、[はい] をクリックします。

  10. [BizTalk Server Interchange Application] を展開します。

  11. [ロール] フォルダをダブルクリックし、このフォルダを右クリックします。次に、[新規作成] をポイントし、[ロール] をクリックします。

    [ロール] ダイアログ ボックスが表示されます。

  12. ロールに付ける名前を入力し、[OK] をクリックします。

  13. 確認ダイアログ ボックスで、[はい] をクリックします。

  14. 作成したロールを展開し、[ユーザー] フォルダをダブルクリックして、このフォルダを右クリックします。次に [新規作成] をポイントし、[ユーザー] をクリックします。

  15. [ユーザーまたはグループの選択] ボックスに、追加するユーザーのフル ネームを入力します。

  16. ユーザー アカウントをロールに追加したら、[OK] をクリックします。

注

  • ロールに割り当てられたユーザー アカウントまたはグループそれぞれのアイコンが [ユーザー] フォルダに表示されます。アプリケーションが起動すると、新しいロールのメンバシップは有効になります。

関連項目

BizTalk Server インターチェンジ アプリケーションのシャットダウン


Submit メソッドおよび SubmitSync メソッドへの新しいロールの関連付け

BizTalk Server インターチェンジ アプリケーションの新しいロールを作成したあと、そのロールを Submit メソッドと SubmitSync メソッドに関連付けることができます。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

    [コンポーネント サービス] コンソールが表示されます。

  2. [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に、[マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開し、[BizTalk Server Interchange Application] を展開します。さらに [コンポーネント] を展開し、[BizTalk.Interchange.1] を展開し、[インターフェイス] を展開します。[IInterchange] を展開し、[メソッド] を展開します。

  3. [Submit] を右クリックし、[プロパティ] をクリックします。

    [Submit のプロパティ] ダイアログ ボックスが表示されます。

  4. [セキュリティ] タブをクリックします。

  5. [選択された項目に明示的に設定されたロール] で、「BizTalk Server インターチェンジ アプリケーションへのロールの追加」の手順で作成したロールのチェック ボックスをオンにし、[OK] をクリックします。

  6. [SubmitSync] を右クリックし、[プロパティ] をクリックします。

    [SubmitSync のプロパティ] ダイアログ ボックスが表示されます。

  7. [セキュリティ] タブをクリックします。

  8. [選択された項目に明示的に設定されたロール] で、「BizTalk Server インターチェンジ アプリケーションへのロールの追加」の手順で作成したロールのチェック ボックスをオンにし、[OK] をクリックします。

関連項目

BizTalk Server インターチェンジ アプリケーションのシャットダウン


XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

BizTalk オーケストレーション サービスをインストールすると、次のことに対してセキュリティ レベルを設定できます。

  • 新しい XLANG スケジュール インスタンスの作成

  • 既存の XLANG スケジュール インスタンスの操作

  • XLANG スケジュール インスタンスに関連した管理機能

  • XLANG スケジュール インスタンスをホストするアプリケーション

XLANG スケジュール インスタンス用のホストであるアプリケーションでは、ロール ベースのセキュリティを使用します。このセキュリティは COM+ で提供される自動サービスです。ロール ベースのセキュリティを使用して、ユーザーは COM+ アプリケーションのアクセス制御ポリシーを作成および実施できます。ロール ベースのセキュリティは、柔軟性と拡張性に優れたセキュリティ構成モデルを採用しているため、コンポーネント内ですべてのセキュリティを実施場合と比較すると、多くの利点があります。既定の COM+ アプリケーションには、XLANG スケジューラと XLANG スケジューラ永続化ヘルパの 2 種類があります。この 2 つのアプリケーションは、BizTalk オーケストレーション サービスのインストール時に自動的に作成されます。既定で、これらのアプリケーションの ID は対話ユーザーとして構成されます。しかし、これが変更されないままだと、スケジュールが起動されたりスケジュールにアクセスされるたびにユーザーのログオンが必要になります。明らかに、これではほとんどの目的に適していません。BizTalk Server インターチェンジ アプリケーションを構成して、特定のサービス アカウントで実行されるようにするには、「COM+ アプリケーションのアプリケーション ID の変更」を参照してください。

XLANG スケジューラ COM+ アプリケーションには、4 つのロールがあります。これらのロールを使用して、スケジューラ インスタンスが実行される COM+ アプリケーションに関係なく、それらのスケジューラ インスタンスのセキュリティを確保できます。この 4 つのロールは次のとおりです。

  • XLANG スケジュール作成者 : このロールにより、指定されたユーザーは XLANG スケジュール インスタンスを作成できます。たとえば、XLANG スケジュール インスタンスを作成させるためには、管理者はユーザーをこのロールのメンバシップの一覧に追加します。このロールのメンバに登録されていないユーザーが XLANG スケジュール インスタンスを作成しようとすると、アクセスが拒否されたことを示すエラー メッセージが表示されます。また、アクセスが拒否されたことを示すエントリがイベント ログに記録されます。

  • XLANG スケジュール ユーザー : このロールにより、指定されたユーザーは XLANG スケジュール インスタンスを操作できます。たとえば、スケジュールのインスタンスをユーザーに操作させるためには、管理者はユーザーをこのロールのメンバシップの一覧に追加します。このロールのメンバに登録されていないユーザーがスケジュールのインスタンスを操作しようとすると、アクセスが拒否されたことを示すエラー メッセージが表示されます。また、アクセスが拒否されたことを示すエントリがイベント ログに記録されます。

  • XLANG スケジューラの管理者 : このロールは、次の作業の管理者権限を持つユーザーを指定するために使用します。
    • COM+ アプリケーションを XLANG スケジュール インスタンス用のホストとして機能できるようにするかどうかを指定する。

    • XLANG スケジュール インスタンス用のホストとする COM+ アプリケーションの DSN の種類、および COM+ アプリケーションでサポートする必要のある永続化レベルのステータス管理値を設定する。

    • すべての XLANG スケジュール インスタンスをシャットダウンする。

    • XLANG スケジュール インスタンスの中断、再開、終了を行う。
  • XLANG スケジューラ アプリケーション : このロールは、ユーザーが作成する COM+ アプリケーションを操作するために XLANG スケジューラで使用されます。したがって、このロールには、COM+ アプリケーションの実行に使用するのと同じ ID を指定する必要があります。

ここには次のトピックが含まれます。

  • COM+ アプリケーションをセキュリティで保護する方法

  • オーケストレーション データベースのセキュリティ保護

  • 送信元 ID の確認

関連項目

XLANG スケジュール


COM+ アプリケーションをセキュリティで保護する方法

ロールを使用することにより、管理者は管理を目的としてアプリケーションの認証ポリシーを作成し、どのリソースにどのユーザーがアクセスできるかを指定できます。この指定は、必要に応じてメソッド レベルで行うことができます。COM+ サーバー アプリケーションはすべての XLANG スケジュール用のホストであるため、インストールされている COM オブジェクトへのアクセスを制限するには、各ロールのセキュリティのプロパティを構成します。

重要

  • セキュリティのプロパティをコンポーネント レベルで追加すると、それぞれのレベルでのロールの設定に基づいたコンポーネント、インターフェイス、およびメソッドも制限されます。COM+ のセキュリティの詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/default.asp) で「Security in COM+」を検索してください。

COM+ アプリケーションのセキュリティに関する推奨事項

次の推奨事項は、主に展開済みアプリケーションをセキュリティで保護する場合に有効です。

  • 対話ユーザーとして COM+ アプリケーションを構成しない。対話ユーザーの ID を使用する COM+ アプリケーションは、アプリケーションが常駐するコンピュータにユーザーがログオンしている場合にだけ使用することができます。ログオンしているユーザーがいない場合は、COM+ アプリケーションを実行することはできません。また、ユーザーが対話ユーザーとして COM+ アプリケーションを作成すると、ステータス保存データベースとそのリソースへのアクセスを構成することが、より困難になります。

  • XLANG スケジューラの ID を再構成する。セットアップ中に、XLANG スケジューラの ID は、対話ユーザーとして自動的に構成されます。この構成は、多くの開発者にとって便利です。運用システムでは、XLANG スケジューラが一意なユーザー ID で動作するようにスケジューラの ID のプロパティを変更してください。この ID は、XLANG スケジューラが送信するすべてのメッセージで使用されます。

    注

    • Microsoft Windows 2000 ターミナル サービス クライアントを使用して XLANG スケジュールを開始する場合、XLANG スケジューラ エンジン用のホストである COM+ アプリケーションの ID は、Windows 2000 の有効なユーザー名またはグループ名に対して設定する必要があります。COM+ アプリケーションの ID は、そのアプリケーションのプロパティのダイアログ ボックスの [ID] タブで設定します。ターミナル サービスでホストされているセッションを通じて XLANG スケジューラ エンジンを使用している場合は、ID を対話的に設定することはできません。
  • 新しい COM+ アプリケーションを作成する場合は、XLANG スケジュール インスタンス用のホストにするアプリケーションごとに一意な ID を設定する。COM+ アプリケーションを作成する場合は、購買などのビジネス プロセスごとに一意なセキュリティ要件を設定します。これにより、アプリケーションごとにセキュリティ レベルを設定できるようになります。また、不安定なアプリケーション コードによって発生する大きな障害を防止でき、個々のアプリケーションの動作も監査しやすくなります。

  • アプリケーション固有のコンポーネントを関連ビジネス プロセスにインストールする。これにより、データは保護され、これらのコンポーネントへのアクセスが許可されていないアプリケーションは拒否されます。ただし、サーバー アプリケーションは適切に保護されます。

    注

    • 各 COM+ アプリケーションには、コンポーネントを少なくとも 1 つは組み込む必要があります。アプリケーション固有のコンポーネントがインストールされていない場合は、アプリケーションのプレースホルダ コンポーネントを作成し、インストールする必要があります。このようにしないとアプリケーションは利用できません。
  • XLANG スケジューラ ロールのメンバシップの一覧を既定の設定から変更して、セキュリティを強化する。BizTalk Server をインストールすると、XLANG スケジューラが作成され、次のような既定の設定を持つロールで構成されます。
    • XLANG スケジュール作成者。メンバシップのロールは、既定では Everyone です。

    • XLANG スケジュール ユーザー。メンバシップのロールは、既定では Everyone です。

    • XLANG スケジューラの管理者。メンバシップのロールは、既定では Administrators です。

    • XLANG スケジューラ アプリケーション。メンバシップのロールは、既定では Everyone です。

関連項目

既定のXLANG スケジューラ アプリケーションのアプリケーション ID の変更

XLANG スケジュールをホストする COM+ アプリケーションの作成

XLANG スケジュール


オーケストレーション データベースのセキュリティ保護

XLANG スケジュール インスタンス用のホストにする COM+ アプリケーションを作成したら、ステータス保存データベースをその COM+ アプリケーションに関連付ける必要があります。それには、まず Microsoft SQL Server にステータス保存データベースを作成します。データベースを作成した後で、XLANG COM+ アプリケーション データベースのデータ ソース名 (DSN) を構成して、統合セキュリティを使用する場合、ユーザーは SQL ログオンを作成して、XLANG スケジュール インスタンスをホストするために後で作成される COM+ アプリケーションの ID アカウントに db_owner 権限を付与する必要があります。COM+ アプリケーションには、テーブルを作成するアクセス許可と、そのテーブルに関連付けられたステータス保存データベースにプロシージャを作成するアクセス許可の両方を割り当ててください。既定では、BizTalk オーケストレーション サービスと既定の BizTalk Server オーケストレーション データベースの間の対話は、SQL Server ではなく Windows 2000 のセキュリティ モデルに基づいています。

関連項目

既定の XLANG スケジューラ アプリケーションの管理


送信元 ID の確認

スケジュールの作成時には、さまざまなシェイプを使用して、ビジネス プロセスのポートの実装に用いる実装テクノロジを記述できます。以下のシェイプはこれらのテクノロジを記述しています。

  • COM コンポーネント シェイプは、送受信される各メッセージへのメソッド呼び出しによってポートを実装する技術です。

  • [スクリプト コンポーネント] シェイプは、送受信されるメッセージごとにメソッド呼び出しを使用してポートを実装するテクノロジを表します。

  • メッセージ キュー シェイプは、ポートを実装するのに使用する技術です。メッセージ キュー トランスポート サービスは、メッセージの送受信に使用します。

これらの 3 つの技術のうちの 1 つを適用すると、メッセージを受信する前に必ず送信者の ID を確認するように設定できます。送信者の ID が要求されたとき、このコンポーネントを呼び出した者のWindows ユーザー アカウントの ID (ドメイン\ユーザー) は、メッセージの _Sender_ field にあります。

XLANG スケジュール用の COM コンポーネント、Windows スクリプト コンポーネント、およびメッセージ キューのセキュリティの詳細については、「COM コンポーネントを使用したポートの実装」、「Windows スクリプト コンポーネントを使用したポートの実装」、および「メッセージ キューを使用したポートの実装」を参照してください。

関連項目

COM コンポーネント シェイプの使用

メッセージ キュー シェイプの使用

スクリプト コンポーネント シェイプの使用


BizTalk Server Report Users グループ

インストール時に、BizTalk Server 2002 はローカル コンピュータに Windows グループを作成し、そのメンバには、BizTalk ドキュメント トラッキング ユーザー インターフェイスを使用して、追跡したドキュメントを表示する権限が付与されます。既定では、このグループには BizTalk Server Report Users と名前が付けられています。セットアップを実行するユーザーは、この名前を変更することができます。ただし、インストール後にその名前を変更することはできません。インストール時に、BizTalk Server は組み込みローカル Administrators グループを追加して、現在ログオンしているユーザー アカウントをこのグループに追加します。

また、インストール時に BizTalk Server は、このグループ、ローカル Administrators グループ、および現在ログオンしているユーザー グループに、Web ベース BizTalk ドキュメント トラッキング ユーザー インターフェイスが常駐しているファイル ディレクトリ、すなわち、\Program Files\Microsoft BizTalk Server\BizTalkTracking へのアクセス許可を付与します。

BizTalk ドキュメント トラッキング ユーザー インターフェイスを使用して、トラッキング ドキュメントを表示するためにアクセス許可を必要とするユーザーは、BizTalk Server Report Users グループに所属していて、追跡データベースへのアクセス許可を持っている必要があります。すなわち、追跡データベースをホストする SQL Server へのログオン許可を持っていて、そのデータベースの db_owner ロールのメンバでなければなりません。


トランスポート サービス

Microsoft BizTalk Server 2002 では、コア セットのトランスポート サービスをサポートしています。このトランスポート サービスにより、アプリケーションが Component Object Model (COM) インターフェイスを使ってサーバーと直接通信できるかどうかに関係なく、サーバーは組織またはアプリケーションにドキュメントを送信できます。BizTalk Server は、HTTP、HTTPS、および SMTP の各ネットワーク プロトコルと、メッセージ キューをサポートしています。

ここには次のトピックが含まれます。

  • HTTP と HTTPS

  • SMTP

  • メッセージ キュー 2.0

  • ファイル

関連項目

トランスポートの種類の選択

トランスポートのプロパティの設定


HTTP と HTTPS

HTTPS は、Hypertext Transfer Protocol (HTTP) で Web のコンテンツにアクセスする場合に、強力な認証機能を提供するために使用されます。Secure Hypertext Transfer Protocol (HTTPS) の最も一般的な用途は、認証された Web サーバーへの接続を暗号化することです。https:// で始まる URL の参照によって通常開始される HTTPS 接続をクライアントが確立しようとする場合、クライアントとサーバーは使用するセキュリティ プロトコルを共同でネゴシエートしてから、認証情報を交換します。

Microsoft Internet Explorer 5 以降では、HTTP トランザクション用に、セキュリティで保護された、次のような共通の通信プロトコルをサポートしています。

  • Transport Layer Security (TLS version 1.0)

  • Secure Sockets Layer (SSL version 2 と 3)

  • Private Communications Technology (PCT version 1.0)

上記の各プロトコルは、交換するデータの秘密保持用の暗号化サービスと、クライアントとサーバーの間の相互認証用の認証サービスを提供しています。組み込みの HTTPS トランスポート サービスで提供されている SSL のサポートによって、インターチェンジにはサーバー間の認証とトランスポート層の暗号化の機能が備えられています。

BizTalk Server と HTTPS を使用することにより、HTTP を介して組織内で、または取引先との間で、データを安全に交換できます。次に、HTTP と HTTPS を使用した BizTalk Server 2002 でのデータの送受信について、詳細に説明します。

送信

HTTP および HTTPS トランスポート サービスは、アプリケーションおよび取引先に送信されるデータを保護するために使用します。これらのトランスポート サービスのセキュリティは、証明書に依存します。

たとえば、HTTP でデータを送信する前に、BizTalk Server の管理者はクライアント証明書のコピーを取引先に送信します。取引先は、この証明書のコピーを BizTalk ストアで保持します。これ以降、この証明書はデータを送信する取引先を認証する場合に使用されます。取引先に証明書を送信またはエクスポートする場合は、一意な証明書マネージャを作成する必要があります。

受信

HTTP 上でデータを保護するために、BizTalk Server では Microsoft インターネット インフォメーション サービス (IIS) と ASP ページを使用しています。HTTPS を使用して IIS に接続する場合、クライアントとブラウザは、チャネルをセキュリティで保護するための共通のプロトコルをネゴシエートします。サーバーとクライアントに共通のプロトコルがいくつかある場合、IIS では、SSL などのサポートされているプロトコルを使用してチャネルをセキュリティで保護します。BizTalk Server が HTTP で受信したデータを保護する場合も、処理は同様です。ASP ページは、BizTalk Server にデータを送信する場合のゲートウェイとして機能します。データがセキュリティで保護されている場合、呼び出しのために ASP コードで Submit メソッドまたは SubmitSync メソッドが使用されていると、BizTalk Server はデータを受信します。

関連項目

トランスポートの種類の選択

トランスポートのプロパティの設定


SMTP

Simple Mail Transfer Protocol (SMTP) は、サーバー間で電子メール メッセージを送信するプロトコルです。これはインターネットでの電子メール送信によく使われているプロトコルです。電子メール クライアントでの電子メール メッセージの取得には、Post Office Protocol (POP) または Internet Message Access Protocol (IMAP) が使用されています。また、SMTP は、メール クライアントからメール サーバーへのメッセージ送信にも使用されています。電子メール アプリケーションを構成する場合は、POP サーバーまたは IMAP サーバーと、SMTP サーバーの両方を指定する必要があります。

SMTP を使用することにより、組織内で、または取引先との間で、データを安全に交換できます。BizTalk Server 2002 では、SMTP を使用して次の方法でデータの送受信を行います。

送信

BizTalk Server では、SMTP でデータを送信するためのトランスポート プロトコルを実装しています。SMTP では、少なくともデータを MIME エンコードする必要があります。このエンコード処理により、BizTalk Server では、データ セットの終了と、次のデータ セットの開始を識別できます。ただし、MIME エンコードにはセキュリティ機能がありません。S/MIME は、セキュリティで保護された MIME のバージョンです。組み込みの S/MIME エンコード コンポーネントを使用してエンコードされたドキュメントでは、ドキュメントの整合性の確保、送信元の認証、およびペイロードの暗号化が行われます。BizTalk Server で作成される S/MIME ドキュメントでは、その本文が暗号化メッセージになります。このセキュリティ機能を利用できるようにするには、MIME エンコード メッセージに証明書を関連付けます。MIME エンコードを指定できるのは、BizTalk メッセージ マネージャでメッセージ ポートを作成する場合です。また、BizTalk メッセージ マネージャでは、証明書も指定できます。

受信

Microsoft Exchange Server を使用して SMTP の受信側にセキュリティを実装するには、管理者が BizTalk Server 用の受信アカウントを作成します。アカウントが設定されると、取引先は公開キーを Exchange Server に送信し、そこで送信者 (取引先) の認証が行われます。公開キーは、Exchange Server の証明書ストアに保存されます。

Exchange Server がメッセージを受信すると、Submit メソッドによりデータが BizTalk Server に送信されます。BizTalk Server では証明書を公開キーと比較して確認し、一致する場合はデータを暗号解読してドキュメントを処理します。

関連項目

メッセージ ポートの要素

トランスポートの種類の選択

暗号化証明書の選択

トランスポートのプロパティの設定


メッセージ キュー 2.0

メッセージ キュー 2.0 では、次のものを使用して秘密保持とセキュリティをサポートしています。

  • アクセス制御

  • 監査

  • 暗号化

  • 認証

さらにメッセージ キューでは、Windows 2000 で利用できる Kerberos V5 セキュリティ プロトコルも利用しています。また、40 ビット暗号化だけでなく 128 ビット暗号化もサポートしています。また、メッセージ キューを使用すると、アプリケーションを統合し、プッシュ型のビジネス イベント配信環境をアプリケーション間に実装し、信頼性は高くなくてもコスト効率のよいネットワーク上に、信頼性の高いアプリケーションを実装できます。

メッセージ キューを使用することにより、組織内で、また取引先との間で、データを安全に交換できます。BizTalk Server 2002 では、メッセージ キューを使用して次の方法でデータの送受信を行います。

送信

メッセージ キューに対するセキュリティの第一層となるのは、ユーザー名とパスワードです。メッセージ キューに対してデータの格納または取得をするユーザーは、ユーザー名とパスワードを要求されます。また、メッセージ キューには、証明書が関連付けられたデータを格納することもできます。ユーザーは、BizTalk メッセージ マネージャを使用して、メッセージ キューに格納されているデータに証明書を指定できます。

受信

管理者がメッセージ キュー用のログオンのプロパティを作成すると、データを取得するためにはユーザー名とパスワードが必要になります。ログオンのプロパティの作成で、セキュリティの基盤が構築されます。取引先がデータに証明書を付けた場合、BizTalk Server でこのパッケージを処理するには、まずデータの暗号解読用の秘密キーのコピーを受信する必要があります。

関連項目

メッセージ キュー受信機能の追加

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

メッセージ キュー受信機能の構成 : [全般] タブ

メッセージ キュー受信機能の構成 : [サービス] タブ

トランスポートの種類の選択

トランスポートのプロパティの設定


ファイル

Microsoft Windows 2000 では、任意のファイルのアクセス制御を定義することにより、データとシステムを保護できます。BizTalk Server 2002 で必須となっている Windows NTFS ファイル システムを使用すると、重要なシステム ファイルやアプリケーション ファイルの損傷を防止できます。さらに NTFS では、アプリケーションのサポート ファイル用のセキュリティも強化されています。

ファイル記憶域を使用することにより、組織内で、また取引先との間で、データを安全に交換できます。また、ファイル記憶域を使用して、次の方法でデータの送受信ができます。

送信

ファイル記憶域のセキュリティの第一層となるのは、ユーザー名とパスワードです。フォルダに対してデータの格納または取得をするユーザーは、ユーザー名とパスワードを要求されます。また、フォルダには、証明書が関連付けられたデータを格納することもできます。この強化されたセキュリティの機能を利用するには、BizTalk メッセージ マネージャを使用して、フォルダに格納するデータに証明書を作成します。

受信

フォルダにログオンのプロパティが適用されている場合は、データを取得するためにはユーザー名とパスワードが必要になります。管理者は、読み取りや削除などのアクセス レベルを特定ユーザー用のファイル ディレクトリに指定することもできます。取引先がデータに証明書を付けた場合、BizTalk Server でこのパッケージを処理するには、まずデータの暗号解読用の秘密キーのコピーを受信する必要があります。受信ドキュメントにデジタル署名も付けると、送信元はドキュメントを送信したことを否定できなくなります。

関連項目

ファイル受信機能の追加

ファイル受信機能またはメッセージ キュー受信機能の詳細プロパティの構成

ファイル受信機能の構成 : [全般] タブ

ファイル受信機能の構成 : [サービス] タブ

トランスポートの種類の選択

トランスポートのプロパティの設定


証明書の概要

デジタル証明書は、暗号化キーをユーザーの 1 つまたは複数の属性と結合します。証明機関が発行した証明書により、ネットワーク メッセージの信頼性が確保され、インターネットが保護されます。この技術、およびその基盤となるデジタル署名により、インターネットでの電子商取引の普及が進んでいます。

ここには次のトピックと手順が含まれます。

  • 証明書について

  • BizTalk Server で必要な証明書

  • 証明書の名前の制限


証明書について

Microsoft BizTalk Server 2002 では、証明書によって提供されるセキュリティ機能に大いに依存しています。データを暗号化する公開キーと、データを暗号解読する秘密キーを使用することにより、BizTalk Server では信頼できるデータを送信し、処理するデータを安全なものにすることができます。Microsoft 管理コンソール (MMC) にある公開キーのポリシーを使用して、暗号化ファイル システム (EFS) 用の暗号化されたデータの回復エージェント、ドメイン全体のルート証明機関、信頼された証明機関などを構成できます。証明書にはデジタル署名も含まれます。この署名はドキュメントに適用され、また、BizTalk Server のデジタル署名のネイティブ サポートによって、受信ドキュメントで確認されます。

証明書は、インターネットなどのようにセキュリティで保護されていないネットワークでの情報交換を認証し、保護するために使用するものです。証明書は、ユーザー、コンピュータ、およびサービスごとに管理できます。Windows 2000 Server に組み込まれている X.509 ベースの公開キー証明書サーバーにより、組織では、商用の証明機関 (CA) のサービスに頼らずにユーザーに対し認証用の公開キー証明書を発行できます。

BizTalk Server では BizTalk メッセージ マネージャを使用して証明書をサポートしています。証明書により、データの暗号化、暗号解読、およびデジタル署名を容易に行うことができます。BizTalk Server トランスポート サービスを使用して送信されるすべてのドキュメントで、公開キー暗号化テクノロジがサポートされます。また、BizTalk Server は、受信するドキュメントの暗号解読と署名検証をサポートします。

注

  • BizTalk Server エンジンは、S/MIME メッセージを処理するときに、証明書が期限切れになっていないかどうかを調べます。しかし、実行時には、BizTalk Server は証明書が取り消されたかどうか、また、証明書が有効で、信頼されたルート証明機関によって証明されているかどうかを調べません。

MachineKey と UserKey

証明書を取得する場合、現在ログオンしているユーザーに関連付けられている UserKey より、コンピュータに関連付けられている MachineKey を使用することをお勧めします。現在サーバーにログオンしているユーザーが UserKey を使用して証明書を取得すると、証明書の UserKey にユーザーのログオン情報が含まれるため、そのユーザーしか証明書にアクセスできません。このため、BizTalk Server で UserKey を使用して証明書にアクセスする必要がある場合、そのユーザーで BizTalk Server を実行する必要があります。任意のユーザーが BizTalk Server にログオンしてキーにアクセスできるようにするには、証明書に MachineKey が必要です。

BizTalk Server が証明書 (ローカル コンピュータ) にアクセスできるようにするには、BizTalk Server が LocalSystem か Administrator で実行されるか、またはレジストリ キー HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates のセキュリティ設定を変更する必要があります。さらに、UserKeys が使用される場合、BizTalk Server はそのユーザーのコンテキストにおいて実行される必要があるか、または前述したレジストリ キーへのアクセス許可が付与されている必要があります。

BizTalk Server を実行するのに Administrator アカウントを使用せず、しかし証明書を使用する必要がある場合には、BizTalk メッセージ サービスが実行されるアカウントに、レジストリ キー HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates へのフル コントロール アクセス許可を付与します。

ここには次の手順が含まれます。

  • 証明書へのレジストリ許可の構成


証明書へのレジストリ許可の構成

Windows 2000 で証明書のレジストリ許可を変更するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に、「regedt32.exe」と入力します。

  2. [OK] をクリックします。

  3. 次のレジストリ キーを確認します。

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates

  4. [セキュリティ] メニューで、[アクセス許可]をクリックして、対象のアカウントにこのレジストリ キーへのフル コントロール アクセス許可を付与します。

警告

  • レジストリを編集する前に、問題が生じた場合の復元方法を必ず知っておく必要があります。詳細については、Windows 2000 ヘルプの「キーおよび値の変更」と「レジストリ情報の追加および削除」を参照してください。編集する前にレジストリのバックアップをとってください。Windows 2000 を実行している場合は、システム修復ディスク (ERD) も更新してください。

  • レジストリ エディタの使用を誤ると、オペレーティング システムの再インストールが要求されるような重大問題が生じることがあります。Microsoft は、レジストリ エディタの誤った使用によって生じた問題を解決できるかについては保証できません。レジストリ エディタは自らの責任で使用してください。


BizTalk Server で必要な証明書

証明書サーバーは、ユーザー単位およびコンピュータ単位で証明書を格納します。各ユーザーには証明書ストアが 1 つ、各コンピュータには専用の証明書ストアが複数あります。Windows 2000 では、ユーザーが作成した証明書はユーザーのものと見なされます。組織は、証明書マネージャの [証明書 (ローカル コンピュータ)] の下にある個人ストアに証明書を格納する必要があります。ただし、証明書の作成では、メッセージ ポートとチャネルを作成したら、証明書はすべてをユーザー自身ではなく、証明書マネージャの [証明書 (ローカル コンピュータ)] の下にある BizTalk ストアと関連付ける必要があります。

また、BizTalk メッセージ マネージャで取引先に対して暗号化や署名検証などのセキュリティを指定する場合、表示される証明書は、BizTalk ストアに格納されている取引先証明書です。SSL クライアントに対して検証済み暗号の解読や検証済み署名などのセキュリティを指定すると、BizTalk メッセージ マネージャは、証明書マネージャの [証明書 (ローカル コンピュータ)] の下にある個人ストアに格納されている証明書を表示します。証明書が格納される場所が重要なのは、実行時にユーザーが BizTalk Server でドキュメントを処理しようとするときに、コンピュータがバックグラウンド サービスとして動作していて、証明書にアクセスするのはこのサービスであるからです。

証明書の格納先をどこにするかという問題には、次の 2 通りの解決方法があります。

  • ユーザーが既に証明書を作成している場合は、Windows 2000 では証明書はユーザー ストアに格納されます。それらの証明書をユーザー ストアから [証明書 (ローカル コンピュータ)] の下にある対応するストアに移動する必要があります。この処理は証明書マネージャによって行われます。

  • ユーザーがサービス アカウントを作成した場合は、証明書はすべて、ユーザーではなくコンピュータに関連付けられます。

Windows 2000 による証明書の管理

BizTalk Server では、Microsoft Windows 2000 によって証明書が管理されています。Windows 2000 セキュリティ モデルに密接に統合された IIS 5.0 には、証明書サーバーが組み込まれています。これにより、組織ではインターネット標準の X 509 デジタル証明書の発行と管理を行うことができます。IIS 5.0 では、主な管理サービス以外にも、Microsoft 証明書サーバーがデジタル証明書の発行と管理を行うカスタマイズ可能なサービスを提供しています。証明書サーバーは、インターネット、企業イントラネット、およびセキュリティで保護されていないネットワークでの通信を安全なものにするソフトウェア セキュリティ システムの管理において、中心的な役割を果たしています。

ここには次の手順が含まれます。

  • BizTalk Server 用の証明書マネージャの作成

関連項目

送信の署名証明書の選択

受信ドキュメントの暗号解読を確認する証明書の選択

受信ドキュメントの署名を確認する証明書の選択

暗号化証明書の選択


BizTalk Server 用の証明書マネージャの作成

BizTalk Server では、すべての取引先の証明書をユーザー自身ではなく、証明書コンソールの [証明書 (ローカル コンピュータ)] の下にある BizTalk ストアと関連付ける必要があります。

  1. [スタート] ボタンをクリックし、[ファイル名を指定して実行] をクリックします。次に「mmc」と入力し、[OK] をクリックします。

    [コンソール1] が表示されます。

  2. [コンソール] メニューの [スナップインの追加と削除] をクリックします。

    [スナップインの追加と削除] ダイアログ ボックスが表示されます。

  3. [追加] をクリックします。

    [スタンドアロン スナップインの追加] ダイアログ ボックスが表示されます。

  4. [証明書] をクリックし、[追加] をクリックします。

    [証明書スナップイン] ダイアログ ボックスが表示されます。

  5. [コンピュータ アカウント] をクリックし、[次へ] をクリックし、[完了] をクリックします。

  6. [スタンドアロン スナップインの追加] ダイアログ ボックスで、[証明書] をクリックし、[追加] をクリックします。

    [証明書スナップイン] ダイアログ ボックスが表示されます。

  7. [ユーザー カウント] をクリックし、[次へ] をクリックし、[閉じる] をクリックします。それから [OK] をクリックしてダイアログ ボックスを閉じます。

  8. [コンソール] メニューの [名前を付けて保存] をクリックします。

    [名前を付けて保存] ダイアログ ボックスが表示されます。

  9. 証明書マネージャを保存する場所 (既定では [管理ツール] フォルダ) を選択し、証明書マネージャの名前を入力し、[保存] をクリックします。

注

  • この作業は BizTalk Server Administrators グループのメンバが行わなければなりません。

  • 既にユーザ アカウントのための証明書マネージャがある場合、証明書マネージャを開き、上記のステップ 2 ～ 6 を実行してコンピュータ アカウントを作成します。

  • 証明書の作成が完了したら、それをユーザ ストアから移動して、そのコンピュータ アカウントの証明書スナップインを追加する必要があります。

関連項目

証明書の概要


証明書の名前の制限

ログオンのプロパティは、BizTalk Server 2002 のセキュリティの第一層となります。同じ名前の証明書が複数存在する場合、BizTalk メッセージ マネージャでは、そのうちの 1 つの証明書だけが選択されます。たとえば、組織に同じ名前と参照を持つ証明書が 2 つあっても、両方の証明書を使用できるわけではありません。一方の証明書を使う場合、もう一方の証明書は、[チャネル] ウィザードの中の利用可能な証明書の一覧に表示されなくなります。


CryptoAPI

BizTalk Server 2002 は CryptoAPI を使用して、処理するデータをセキュリティで保護します。最近の暗号化テクノロジの発達により追加された用途として、ネットワーク上のユーザーの認証、送信した情報の整合性の確保、および送信元による送信メッセージの所有権否定の防止のための各種メカニズムがあります。

暗号化を使用し、また、証明書生成のために Microsoft Windows 2000 などの Microsoft 独自の暗号化を使用するアプリケーション、メッセージ、データなどでは、いずれも CryptoAPI が使用されています。BizTalk Server では、プリプロセッサ コンポーネントなど、独自に作成した COM+ コンポーネントを使用するときにユーザーが指定する受信機能に CryptoAPI を使用します。これによって BizTalk Server では独自の暗号化コンポーネントを扱えるようになります。


Collaboration Data Objects

Microsoft BizTalk Server 2002 は、データの送受信の両方で MIME エンコードをサポートします。Microsoft Windows 2000 に組み込まれているテクノロジのひとつの Collaboration Data Objects (CDO) を使用すると、BizTalk Server でデータをエンコードして処理ができます。たとえば、BizTalk Server で、テキストとグラフィックスを含むカタログを送信する場合は、まずデータ (グラフィックス) をバイナリから文字列に変換する必要があります。CDO は、テキストとグラフィックを文字列形式に変換し、BizTalk Server で処理できるようにします。


ファイアウォールの構成

ファイアウォールは内部ネットワークのセキュリティの保護に役立ちますが、待ち時間を発生させるほか、そこに障害が発生しただけでネットワーク全体に影響が及ぶ、単一点での障害が発生する可能性があります。負荷分散メカニズムを使用して、単一点での障害が発生する可能性を低くしたとしても、ファイアウォールはネットワークのパフォーマンスを低下させます。

ファイアウォールを備えた環境で BizTalk Server 2002 を構成する場合は、次の 2 とおりの構成方法があります。

  • 構成 1 : サーバーを社内ネットワークにインストールします。一部のサーバーを選んで取引先と通信するために、社内の境界ネットワーク (DMZ または非武装地帯とも呼ばれます) に配置します。社内ネットワークに対する不正アクセスの被害を受けることなく、独自のインターネット サービスをホストしたい企業は、境界ネットワークを使用しています。境界ネットワークは、インターネットと内部ネットワークの防衛線との間にある境界セグメントです。通常はファイアウォールと要塞ホストが組み合わせられており、内部ネットワークと外部ネットワークとのゲートウェイになっています。境界ネットワークにあるサーバーは、HTTP、メッセージ キュー、SMTP などのローカル トランスポート サービスを使用します。この環境では、すべての送受信トランザクションがファイアウォールを通過します。境界ネットワーク内のサーバーは、別のファイアウォールを通じて Microsoft SQL Server にドキュメントを送信します。この構成を採用すると、境界ネットワーク内の BizTalk Server は、内部ファイアウォールを通じて Microsoft SQL Server と通信できます。

  • 構成 2 : サーバーを社内ネットワークにインストールします。インターネットを通じてドキュメントを交換する取引先は境界ネットワーク (保護用の第 1 ファイアウォール) の SMTP サーバーを使用してデータを送信します。これらのサーバーは、第 2 のファイアウォールを通じて、データを社内ネットワークのサーバーに送信します。

構成 1 と構成 2 は、どちらもパフォーマンスに影響を与えます。パフォーマンスの大幅な低下を避けるには、ファイアウォールを構築するとき、組織と取引先との間でごく普通に行われる量のトランザクションを扱えるように構築します。


パフォーマンスとスケーラビリティの強化

Microsoft® BizTalk™ Server 2002 のさまざまなコンポーネントについて理解すると、スケーラブルでハイ パフォーマンスなソリューションを作成できるようになります。潜在的なボトルネックの発見、待ち時間の解消、データベースの管理など、BizTalk Server のパフォーマンスを向上させる方法はいくつかあります。ただし、最適なソリューションを得るための作業の量は、組織のシステム アーキテクチャの複雑さや、予算によって異なります。

次の BizTalk Server データベースを最適化することは、高いパフォーマンスを実現するために重要です。

  • BizTalk メッセージ管理データベース

  • 共有キュー データベース

  • 追跡データベース

  • オーケストレーション データベース

データベース最適化の詳細については、「データベースのスケール アップ」と「データベースのスケール アウト」を参照してください。

ここには次のトピックが含まれます。

  • パフォーマンスの最適化

  • BizTalk Server の拡張


パフォーマンスの最適化

トランザクションの要件を満たし、パフォーマンスを向上させるには、BizTalk Server 2002 を最適化します。パフォーマンスを強化するためには、BizTalk Server だけでなく、Microsoft® Windows 2000® とデータベース間の相互作用の最適化も必要です。

システムを構成したら、テストを行って結果を評価し、初期構成がトランザクションの要件を満たしているかどうかを確認します。パフォーマンスを最適化するには、アーキテクチャの再構成が必要です。再構成のたびにテストを行い、結果を評価してください。目標の結果が得られたら、メンテナンス計画を開始します。サーバー パフォーマンスは時間とともに変化するため、組織が処理するトランザクションの量や種類に変化が生じる場合があるからです。

ここには次のトピックが含まれます。

  • BizTalk Server アーキテクチャのパフォーマンスのチューニング

  • アーキテクチャの設計、テスト、および分析

  • パフォーマンスの維持


BizTalk Server アーキテクチャのパフォーマンスのチューニング

ここでは、システム設定を最適化するための一般的な推奨事項について説明し、BizTalk Server 2002 を最適化してパフォーマンスを向上させる方法についても説明します。

BizTalk Server のパフォーマンスとスケーラビリティをチューニングするときには、まず使用しているシステムの特性を把握する必要があります。多少の例外はあるものの、ボトルネックは多くの場合次の箇所のいずれかに存在します。

  • ディスク I/O

  • プロセッサの処理速度

  • ネットワーク I/O

  • 入力の速度 (ドキュメントが BizTalk Server に送信される速度)

  • カスタム コード (AIC、プリプロセッサ コンポーネント、発行中の ASP ページなど)

ここでは、これらの問題の解決に役立つ情報を提供します。まず、現在の構成のパフォーマンスを分析することで、問題の存在する箇所を特定する必要があります。システムの現在のパフォーマンスに満足している場合でも、システムのプロパティを分析、把握することは重要です。これにより、トラブルシューティングやアップグレードを行うときの時間を短縮できます。

次に、システムのパフォーマンスを分析するときに、最初に行うべき 5 つの推奨手順を示します。

  1. BizTalk Server 構成内のすべてのコンピュータでディスクの入出力を監視します。Windows システム モニタか Microsoft Operations Manager (MOM) を使って、パフォーマンス カウンタの %disk idle time を確認します。すべての BizTalk Server、SQL Server、およびアプリケーション統合コンポーネント (AIC) や HTTP ポストによって BizTalk Server と交信するそのほかのコンピュータで、このパフォーマンス カウンタを監視します。詳細については、「構成のパフォーマンスの評価」を参照してください。

  2. BizTalk Server 構成内のすべてのコンピュータでプロセッサの使用率を監視します。Windows システム モニタ ツールか MOM を使って、パフォーマンス カウンタの %processor utilization を確認します。プロセッサに、BizTalk Server の負荷が過剰にかかっている場合には、サーバー、チャネル、およびレジストリの設定を変更することでパフォーマンスを最適化できます。詳細については、「グループ内のサーバーの追加、削除、および構成」、「サーバー グループの追加、削除、および構成」、「レジストリ設定の最適化」および「BizTalk メッセージ サービスのスケール アウト」を参照してください。最適に構成された BizTalk Server システムでは、プロセッサ使用率だけがボトルネックの発生する箇所になります。

  3. すべてのサーバーを作業項目の処理に参加させないようにして、通常の使用状態にします。これにより、アイテムが作業キューに作成されます。この構成は、ドキュメントの受信速度を見極めるのに適しています。再度、最初の 2 つの手順で分析を行い、ほかの問題が隠れていないかを確認します。一般に、入力速度の低下が起こる問題の 1 つとして、ASP 送信呼び出しを使用している場合があります。Internet Information Services (IIS) が、十分な速度で要求を処理できず、BizTalk Server を最高性能で実行できないことがしばしばあります。ASP 送信呼び出しを使用しているときには、BizTalk Server の ISAPI ベースの受信機能に変更することを推奨します。これにより、パフォーマンスが大幅に向上します。最適に構成された BizTalk Server システムでは、プロセッサ使用率がドキュメントの受信のボトルネックになります。

  4. 受信機能をシャットダウンするか、Submit メソッドの呼び出しを停止して、サーバーを作業キュー内に既に存在しているアイテムに対しての作業項目の処理に参加できるようにします。この構成によって、ドキュメントの処理と転送がどこまで高速になるかを確認できます。再度、最初の 2 つの手順の分析を行い、プロセッサの使用率がボトルネックになるようにシステムをチューニングします。トランスポートがパフォーマンスを低下させている原因かどうかを判断する場合は、ポートのトランスポートの種類を変更することを勧めします。この方法は、AIC の使用時、AIC のパフォーマンスを最大にする必要がある場合に、どの程度の処理能力があるかを見極めるための良い方法です。

  5. システムの入力と出力がつり合うようにします。リソースのボトルネックをすべて取り除き、サーバーの CPU の使用率が 90% を超えた場合には、受信速度と送信速度がつり合うようにすることが重要です。これにより、作業キューは常時 40 ～ 100 のドキュメントを処理するようになります。詳細については、「受信と処理の平衡化」を参照してください。

ここには次のトピックが含まれます。

  • 受信と処理の平衡化

  • BizTalk オーケストレーション サービスの最適化

  • BizTalk メッセージ サービスの最適化

関連項目

BizTalk Server の拡張


受信と処理の平衡化

リソースのボトルネックをすべて取り除き、サーバーの CPU の使用率が 90% を超えた場合には、受信速度と送信速度がつり合うようにすることが重要です。これにより、作業キューは常時 40 ～ 100 のドキュメントを処理するようになります。次のガイドラインは、受信するドキュメントの数とシステムが処理するドキュメントの数を合わせるのに役立ちます。

  • 通常、受信するドキュメントよりも多くのドキュメントを処理することはできません。ドキュメントの受信速度が著しく遅い場合には、一定時間に処理できるドキュメントの数を制限します。ドキュメントの受信速度が遅いかどうかは、次の目安で確認できます。
    • 作業キューが、空になっていることが多い。

    • パフォーマンス カウンタの Documents Processed/sec を監視したとき、ドキュメント処理の件数が 0 まで低下することがある。
  • システムのドキュメントの受信を最適化する場合には、ドキュメントの処理に利用しているリソースを制限して、スループットを低下させることもできます。ドキュメントの処理に十分なリソースが割り当てられているかどうかは、次の目安で確認できます。
    • 作業キューのドキュメント数が、長い時間、継続的に上昇する。

    • システム モニタで、ドキュメントの処理数よりも受信するドキュメント数の方が多く表示されることがある。

    重要

    • 受信するそれぞれのドキュメントが、ただ 1 つのチャネルに一致する場合には、前述の目安で判断できます。現在の構成で、1 つのドキュメントが複数のチャネルと一致する場合には、比較結果を修正する必要があります。たとえば、現在の構成で、各受信ドキュメントが完全に 2 つのチャネルに一致する場合、最大のドキュメント スループットは、受信しているドキュメント数の 2 倍になります。


BizTalk オーケストレーション サービスの最適化

BizTalk オーケストレーション サービスを使用して、XLANG スケジュールとスケジュールのコンテンツを最適化できます。スケジュールでのメモリの使用方法、およびビジネス プロセス フローの構造がパフォーマンスに与える影響を理解すると、BizTalk オーケストレーション サービスのパフォーマンスを向上するスケジュールの作成が可能になります。BizTalk オーケストレーション サービスによってサポートされる実装テクノロジには、BizTalk メッセージ サービス、COM コンポーネント、メッセージ キュー サービス、および Windows スクリプト コンポーネントが含まれます。これらのコンポーネントやサービスを最適化すると、BizTalk オーケストレーション サービスのパフォーマンスがさらに向上します。

ここには次のトピックが含まれます。

  • XLANG スケジュールの最適化

  • XLANG スケジュールのコンテンツの最適化


XLANG スケジュールの最適化

XLANG スケジュールには、企業内部のビジネス プロセスを大量に格納することができます。ビジネス プロセスには、短時間トランザクションや長時間トランザクションが含まれています。BizTalk Server は、このようなプロセスのコンテンツを制御することはありませんが、XLANG スケジュール内のこれらプロセスを通じて、情報の流れを管理します。XLANG スケジュールを設計する場合は、それを短時間トランザクションと長時間トランザクションのどちらで構成するかにかかわらず、次の点を考慮する必要があります。

  • XLANG スケジュール インスタンスを起動すると、必ずメモリ上で実行されます。

  • 1 台のサーバーで複数の XLANG スケジュールが実行されることがあります。

  • 複数の異なる XLANG スケジュールが同時に実行され、複数の XLANG スケジュール インスタンスが実行されることがあります。

オーケストレーション データベースは、実行中の XLANG スケジュールによって使用されるメモリを制御するための、ステータス退避と呼ばれるメカニズムを提供します。ステータス退避は、XLANG スケジュール インスタンスがメッセージを待っている場合に、その XLANG スケジュールでほかの活動が何も実行されていないときに行われます。そのようなとき、XLANG スケジューラ エンジンによって XLANG スケジュール インスタンスのステータス退避が行われ、それによってパフォーマンスが向上します。XLANG スケジュール インスタンスのステータス退避では、インスタンス固有のステータスがすべてデータベースに保存され、インスタンスはメモリから削除されます。XLANG スケジューラ エンジンのメモリには、XLANG スケジュール インスタンスのほんの一部だけが残ります。その XLANG スケジュール インスタンス用のポートにメッセージが到着すると、インスタンスのステータス復元が行われます。XLANG スケジュール インスタンスのステータス復元では、データベースにあるインスタンスがメモリ上に復元されます。

XLANG スケジュール インスタンスは、ステータス復元が行われるか、管理者によって明示的に終了されるまで、ステータス退避された状態で保持されます。このような処理によって、長時間に渡って、ビジネス プロセスを高い信頼性を保ったまま実行することが可能になります。ステータス退避の構成の詳細については、「ステータス退避とステータス復元」を参照してください。ステータス退避とステータス復元によってメモリの消費は少なくなりますが、パフォーマンスは低下します。これは、ステータス退避とステータス復元ではオーケストレーション データベースにデータの読み書きを行う必要があり、ネットワークでの待ち時間の影響を受けるためです。

重要

  • BizTalk オーケストレーション サービスのパフォーマンスを大幅に向上させるには、エクスプローラで Program Files\Common Files\System\ADO を参照し、adofre15.reg をダブルクリックします。確認を求めるダイアログ ボックスが表示されるので、[はい] をクリックし、[OK] をクリックします。この操作を行うと ADO のスレッド モデルが "Apartment" から "Both" になりるため、Microsoft® ActiveX® Data Objects (ADO) を利用するほかのアプリケーションに影響を及ぼす可能性がある点に注意が必要です。


XLANG スケジュールのコンテンツの最適化

XLANG スケジュールは、ビジネス プロセスとそのプロセスのバインドについての情報を実装テクノロジに提供するものです。XLANG スケジュールのパフォーマンスは、通常はそこに含まれるアクションのパフォーマンス レベルを反映したものになります。XLANG スケジュールのコンテンツの最適化には、多くの項目が関係しています。これらの項目には、XLANG スケジュールに固有のものもあれば、分散アプリケーションの作成に関係するものもあります。

  • ステータス退避の値を再設定し、XLANG スケジュール用のメモリを確保します。既定の待ち時間は 0 秒です。この時間は変更することができます。180 秒以下の値を指定すると、XLANG スケジュールはステータス退避を行わなくなります。180 秒よりも大きい値を指定すると、XLANG スケジュールは直ちにステータス退避を行います。待ち時間と XLANG スケジュールのステータス退避の詳細については、「ステータス退避とステータス復元」および「同期通信と非同期通信」を参照してください。

  • 永続化コンポーネントを使用します。IPersistStream や IPersistStreamInit を実装するコンポーネントなどの永続化コンポーネントを使用すると、XLANG スケジューラ エンジンの XLANG スケジュールに対するステータス退避を柔軟に構成できます。

  • オーケストレーション データベースと同じサーバーで COM オブジェクトを実行します。このようにすると、XLANG スケジュールがネットワーク待ち時間の影響を受けなくなります。

  • COM+ パッケージをインプロセスで実行し、最大限のパフォーマンスを得ます。COM+ パッケージをインプロセスで実行すると、アプリケーションのコンポーネントで障害が発生した場合にアプリケーション全体で障害が発生するなど、COM+ アプリケーションの堅牢性に影響を与えますが、アプリケーションをアウトプロセスで実行する場合よりも処理速度が格段に速くなります。このような潜在的な不安定さを補うため、アプリケーションを運用環境に展開する前に、そのアプリケーションのコンポーネントの安定性を十分にテストしてください。

  • 作業を 1 つのトランザクションにまとめます。トランザクションの開始時と終了時に XLANG スケジュール インスタンスのステータスを保存するときは、コンピュータのリソースが大量に消費されます。作業項目を 1 つのトランザクションにまとめることで、このようなパフォーマンスへの影響は大幅に減少します。また、XLANG スケジュールは、Microsoft 分散トランザクション コーディネータ (MS DTC) のトランザクションの実行中はステータス退避を行えません。MS DTC トランザクションは高速に処理されますが、パフォーマンスを低下させます。短時間で完了するアクションが複数ある場合は、それらのアクションを 1 つの MS DTC トランザクションにまとめてください。

  • 長時間トランザクションは非同期で実行し、XLANG スケジュールは短時間で COM 呼び出しを完了するように設計します。非同期で実行した処理の結果は、メッセージ キューまたは COM 呼び出しを介して XLANG スケジュール インスタンスに戻されます。COM を利用すると、"応答" ポートの名前をモニカとして渡すことができます。モニカはコンピュータを再起動しても有効です。

関連項目

モニカの構文


BizTalk メッセージ サービスの最適化

BizTalk メッセージ サービスを最適化するには、サーバー グループにドキュメントを送信します。BizTalk Server グループによって、複数のサーバーに作業を分配します。BizTalk Server にデータを送信するには、次の操作を行います。

  • メッセージ キュー、HTTP、ファイルなどの受信機能を構成します。

  • BizTalk Server の Interchange オブジェクトの Submit メソッドを呼び出します。

受信機能を使用すれば、Submit メソッドを使用して Interchange オブジェクトを呼び出す場合よりも優れたパフォーマンスを得ることができます。受信機能では、受信のパフォーマンスを最適化するためにスレッド プールや一括処理を利用しています。IInterchange::Submit() を呼び出すクライアント コードで同様のパフォーマンスを実現するには、クライアント コンポーネントに、複数のスレッドがそれぞれ IInterchange への独立したポインタを持つマルチスレッド アパートメント コードを実装する必要があります。シングル スレッド アパートメント コードを使用している場合、メッセージが直列的に BizTalk Server に送信され、受信機能やメッセージ キューを使用したときのスループット パフォーマンスを実現することはできません。

Interchange オブジェクトは BizTalk Server プロセスの外部に作成する必要があるため、Interchange オブジェクトを呼び出して送信を行うと、受信機能を使用する場合よりも多くのリソースを消費します。ただし、Interchange オブジェクトを使用する場合は、グループ内のサーバーにデータを送信するときに 2 種類の方法を利用できます。

  • 送信全体の中の各部分がそれぞれグループ内の特定のサーバーに送信されるように、静的に構成します。ただし、BizTalk Server に静的にマップされたトランスポート サービスを持つサーバーで障害が発生した場合は、この方法ではフォールト トレランスがあまり得られません。

  • Microsoft Application Center 2000 のコンポーネント負荷分散 (CLB) 機能を使用し、パフォーマンスを向上させます。BizTalk Server グループを利用しても、ドキュメントの送信には負荷分散が提供されません。CLB を使用すると、負荷分散に加えてフォールト トレランスも提供されます。CLB の詳細については、「コンポーネント負荷分散」を参照してください。

ここには次のトピックが含まれます。

  • 仕様の作成と最適化

  • マップの作成と最適化

  • BizTalk Server グループのプロパティの最適化

  • サーバーのプロパティの最適化

  • レジストリ設定の最適化

  • 暗号化の最適化

  • 通信の最適化

  • ファイアウォールの構成


仕様の作成と最適化

既定のグローバル追跡設定を使用する場合、BizTalk Server 2002 では 20 MB までの XML Unicode 形式ドキュメントをサポートします。ANSI フラット ファイルなど、XML 以外のファイルは XML に変換する必要があるため、20 MB のファイル サイズはサポートされません。変換処理でデータに XML タグが追加されるため、BizTalk Server が処理するドキュメントのサイズが大きくなります。BizTalk Server のパフォーマンスを最高のレベルに維持するには、XML 以外の種類のファイルは 20 MB 未満にする必要があります。

XML に変換されたドキュメントの処理で必要なメモリの量は、そのドキュメントの元の構造によって異なります。グローバル追跡が有効に設定されている場合は、BizTalk Server のパフォーマンスに大きな影響を与えることなく、20 MB を超える XML Unicode 形式のドキュメントを処理できます。

注

  • インターチェンジ追跡のサイズ制限を超えると、BizTalk Server のパフォーマンスが低下します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。パフォーマンスは、ドキュメントのログ機能からも影響を受けます。ドキュメントのログ機能の詳細については、「ドキュメント ログのプロパティの設定」を参照してください。

仕様を設計するときは、仕様内に検証条件を構成できます。たとえば、あるフィールドに特定のデータ型 (文字列など) が格納されるように指定したり、さらに複雑な条件 (80 とおりの値一覧と比較して、フィールドを検証するなど) を指定したりできます。後者の場合は、データを 80 とおりの値と比較することを要求し、いずれとも一致しない場合は仕様の検証プロセスを通過できなかったことになります。BizTalk Server の仕様の検証は既定で有効になっており、パフォーマンスは低下しますが、送受信するデータの有効性が確認されます。検証を無効にするとパフォーマンスが向上します。BizTalk Server はデータ検証メカニズムをほかにもいくつか備えているため、無効にしてもデータの有効性にはそれほど影響しません。

たとえば、特定のデータ型と値が必要なマップがあり、仕様の検証が無効になっている場合、データは解析プロセスを通過することはできますが、シリアライズ フェーズでマップが適用されたときにエラーが発生します。ほかのメカニズム (有効なデータを前提にしたマップなど) を利用できる場合は、仕様の検証を無効にすることで、検証プロセスによるパフォーマンス低下の可能性を回避できます。また、取引先との間でデータ標準について合意が得られ、トランザクションの検証が行われている場合にも、仕様の検証を無効にすることができます。データの送信方法を完全に制御できている場合 (アプリケーション間トランザクションなど) も、仕様の検証を無効にできます。

検証を無効にするには NoValidation レジストリを設定することで可能です。仕様の検証が必要ない場合、たとえば、最小値/最大値、データ型、必要な値などの設定が仕様に適合しているかどうかについてドキュメントを検証しない場合は、これを 0 以外の値に設定するとデータが検証されなくなります。これにより、パフォーマンスは向上しますが、無効なデータが送信される可能性があります。仕様の検証を 0 以外の値に変更する設定は、組織がドキュメントの構造を制御している場合に、そのようなドキュメントを受信するサーバーに適しています。

レジストリの設定は、各サーバーで行います。仕様の検証が有効になっていると、そのサーバーで処理されるすべてのドキュメントについて、仕様に適合しているかどうかが検証されます。このため、サーバーの処理速度は仕様の検証が行われない場合よりも遅くなります。

ドキュメント サイズおよび仕様の最適化でお勧めする方法

BizTalk Serverのパフォーマンスを最適化するには、次のような方法があります。

  • 仕様には、必要以上のフィールドや属性を含めないようにします。余分なフィールドや属性があると、BizTalk Server で必要なメモリの量が増加します。仕様のサイズが大きくなると、それに比例して必要なメモリも増加します。たとえば、BizTalk Server に含まれる EDI 仕様は、EDI 標準に準拠しています。通常、EDI 仕様を使用するほとんどの組織で必要となるのは、仕様内部の約 10% です。そのため、組織とその取引先が 1 つの仕様の 10% しか使用していない場合は、不要なレコードとフィールドを削除して、トランザクションには変更後の仕様を使うことができます。

  • 仕様の検証が有効になっている場合、有効なデータが含まれているフィールドに対しては、仕様内で仕様の検証条件を指定しないでください。たとえば、あるフィールドに数値が含まれている場合でも、文字列として処理されることがあるため (電話番号など)、数値であることを要求しないようにしてください。既定のデータ型は文字列であるため、この場合にはデータ型を指定する必要はありません。このため、データ型フィールドは空白のままにしておきます。フィールドで使用可能な値を指定すると、データ型だけを検証する場合に比べて、検証に時間がかかります。


マップの作成と最適化

トランザクションの中でデータ変換を行うと、BizTalk Server 2002 のパフォーマンスが低下する場合があります。仕様のマッピングは CPU の負担となり、BizTalk Server のトランザクション処理能力が全般にわたって低下します。BizTalk Server サーバーに及ぶ影響の大きさは、変換に使用するマップの複雑さでほぼ決まります。たとえば、送信元仕様の productID というフィールドを送信先仕様の itemID というフィールドにマップしても、変換するデータに対して複雑な算術演算を実行する場合ほどは負担になりません。

マップの設計でお勧めする方法

  • Functoid を使用するのは、必要な場合だけにします。Functoid はスクリプトを使用するため、BizTalk Server がスクリプト エンジンを読み込む必要があります。これにより、ネイティブ XML の変換に比べてパフォーマンスが低下します。

  • データベース検索 Functoid を使用するのは、必要な場合だけにします。この Functoid を使用すると、BizTalk Server はそのたびにデータベース接続を確立し、データを照会し、レコード セットを格納して接続を閉じます。このような処理によって、BizTalk Server のパフォーマンスが低下することがあります。

  • Functoid スクリプト内の COM オブジェクトの呼び出しや、カスタム Functoid の使用は控えます。どちらのテクニックを使用した場合も、BizTalk Server によって COM オブジェクトのインスタンスが作成されます。その結果、動作のパフォーマンスが全般にわたって低下します。また、次の項目がどのようになっているかによって、COM オブジェクトのインスタンス作成のパフォーマンスが影響を受けます。
    • インプロセスか、アウトプロセスか?

    • プロジェクトはローカルか、リモートか?

    • オブジェクトの記述は適切か?

    • トランザクションを利用しているか?
  • マップを 1 つ 1 つ分析し、最大限のパフォーマンスを得る方法を特定します。たとえば、2 つの送信元フィールドを連結し、その結果得られた値を 2 つの異なる送信先フィールドに配置するときに使用できるテクニックは、2 種類あります。1 つ目の連結テクニックは、連結 Functoid を 1 つ使用し、その出力を 2 か所にマップするというものです。2 つ目は、2 つの Functoidを使用し、それぞれに送信先フィールドへの出力リンクを 1 つずつ作成します。最初のテクニックでは、Functoid の中で実行されるスクリプトが 1 回しか呼び出されないため、少し効率的です。両方をテストし、どちらのテクニックの方がパフォーマンスがより高いかを確認してください。


BizTalk Server グループのプロパティの最適化

BizTalk Server 管理コンソールの [BizTalk Server グループのプロパティ] ダイアログ ボックスでは、次のプロパティを指定できます。

  • [メッセージ管理オブジェクト キャッシュの更新間隔 (秒)] : このフィールドには、最大で 300 秒まで設定できます。BizTalk Server 2002 は、チャネル、メッセージ ポート、エンベロープ、ドキュメント定義などの構成をメモリ内にキャッシュすることで、データベースを毎回呼び出さないようにしています。これらのオブジェクトが定期的に変更されることがない場合は、値を 300 に設定すると、データベースでのデータの読み書き回数が減少します。BizTalk Server では管理オブジェクトを 5 分ごとに更新します。変更を直ちに反映するには、サービスを再開する必要があります。

  • [ドキュメント トラッキングを有効にする] : [追跡] タブでは、ドキュメント トラッキングを有効にするか、無効にするかを指定できます。トラッキング機能を使用しない場合は、このチェック ボックスをオフにすると、1 回のトランザクションにおけるデータベースへの読み書き回数を最小限に抑えることができます。このチェック ボックスをオンにすると、BizTalk Server はデータベースに接続し、データをログに記録します。トラッキング機能が不要でない限り、このチェック ボックスはオフにしないでください。ドキュメント トラッキングは、有効のままにしておくことを強くお勧めします。トラッキング機能のプロパティ設定の詳細については、「サーバー グループの追跡のプロパティの構成」を参照してください。

    注

    • インターチェンジの追跡にはサイズ上の制限があります。サイズの制限を超えると、BizTalk Server のパフォーマンスが低下します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。パフォーマンスは、ドキュメントのログ機能からも影響を受けます。ドキュメントのログ機能の詳細については、「ドキュメント ログのプロパティの設定」を参照してください。
  • [サーバーの呼び出し順序の整列] : グループで特定の種類のドキュメントを受信することが多い場合は、BizTalk Server のパーサーに優先順位を設定できます。BizTalk Server には 4 つのパーサーがあり、XML、EDIFACT、ANSI X12、およびフラット ファイルのデータ解析に使用されます。BizTalk Server は、ドキュメントを受信すると、これらのパーサーを一覧の順序どおりに使用してドキュメントを解析します。組織がおもに受信するドキュメントの種類が決まっている場合は、パーサーの順序を変更し、頻繁に受信するドキュメントの種類に合ったパーサーが先頭になるようにします。

関連項目

BizTalk メッセージ サービスのスケール アウト


サーバーのプロパティの最適化

BizTalk Server 管理コンソールでは、[<サーバー> のプロパティ] ダイアログ ボックスで次のプロパティを設定できます。

  • [作業項目の処理に参加する] : BizTalk Server は、取得するドキュメントの複数の受信機能をポーリングできるようになります。ドキュメントの負荷を複数のサーバーに分散させるには、各コンピュータに受信機能を配置します。各ポーリング場所は固有のものとし、それらの場所ごとに受信機能を配置する必要があります。いずれかの受信機能が過負荷になることを防ぐには、ドキュメントを送信する業務用アプリケーションが、すべてのポーリング場所にドキュメントを均等に分散させるようにします。

  • [使用可能な受信機能スレッドの最大数] : 受信機能のための、プロセッサ 1 基あたりの作業スレッドの数を指定できます。BizTalk Server は入出力ポートを占有するため、この値を小さくしすぎると、処理速度が低下します。この値を非常に大きくすると、重大な影響はありませんが、パフォーマンスが低下します。この値を調整し、最適な値を見つけてください。[使用可能な受信機能スレッドの最大数] の推奨値は 4 です。

  • [プロセッサごとの使用可能な作業スレッドの最大数] : 処理側のプロセッサ 1 基あたりの作業スレッド数を指定できます。作業スレッド数を適切な値に調整すると、パフォーマンスを向上させることができます。BizTalk Server 管理コンソールで、コンソール ツリーのサーバーを右クリックし、[プロパティ] をクリックします。[プロセッサごとの使用可能な作業スレッドの最大数] ボックスの既定値を変更します。既定値は 4 で、推奨される値は環境によって異なりますが、10 ～ 16 です。


レジストリ設定の最適化

BizTalk Server のパフォーマンスを向上させるには、次のようなレジストリ設定を適用します。

警告

  • レジストリ エディタを適切に使用しないと、オペレーティング システムの再インストールが必要になるなど、重大な問題が発生する可能性があります。Microsoft は、不適切なレジストリ エディタの使用によって発生した問題の解決については保証いたしかねます。レジストリ エディタは、お客様自身の責任で使用してください。

  • 詳細については、Windows 2000 ヘルプの「キーと値を変更する」と「レジストリの情報を追加または削除する」を参照してください。レジストリを編集するときには事前にバックアップを取得する必要があります。Windows 2000 を実行しているときには、システム修復ディスク (ERD) の更新も行ってください。

次のすべてのキーは、DWORD 値として \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSVC に追加します。

  • NoValidation : 仕様の検証を無効にするには、このレジストリ キーを使用します。仕様の検証が必要ない場合、たとえば、最小値/最大値、データ型、必要な値などの設定が仕様に適合しているかどうかについてドキュメントを検証しない場合は、これを 0 以外の値に設定するとデータが検証されなくなります。これにより、パフォーマンスは向上しますが、無効なデータが送信される可能性があります。仕様の検証を 0 以外の値に変更する設定は、組織が構造を制御しているドキュメントを受信するサーバーに適しています。

  • ParserRefreshInterval : 既定では、60,000 (60 秒) に設定されています。この値は、新しいパーサーが追加されたかどうかについて、BizTalk Server がデータベースを確認する頻度を表しています。サーバーの動作中に更新されるグループ レベルのプロパティは、これだけです。新しいパーサーを追加することがない場合は、この値を 0 に設定すると BizTalk Server はデータベースを確認しなくなります。この値は、追跡データベースのグループの設定が変更されたかどうかを確認するためや、パーサーの一覧が、パーサーの追加、削除または整列によって変更されたかどうかを確認するためにも使用します。

  • CacheSize : このレジストリ キーは、BizTalk Server 管理オブジェクト キャッシュの最大サイズを指定するために使用します。既定値は 20 です。BizTalk Server のオブジェクト キャッシュのチャネル、メッセージ ポート、エンベロープ、またはドキュメント定義の数が 20 を超えると、BizTalk Server はメモリから項目の一部を直ちに削除します。サーバーが大量のメモリを備えている場合は、この値を大きく設定すると (20 以上)、BizTalk Server はメモリにより多くの項目を保持できるようになります。これは、更新間隔には影響を与えません。BizTalk Server はキャッシュ オブジェクトを削除し、それらが期限切れになると再読み込みを行います。

  • BatchSize : この値は、メッセージ キューの受信機能だけで使用します。既定では、BatchSize は 20 に設定されています。パフォーマンスを向上させるため、BizTalk Server はキューから最大で 20 項目を同時に読み取り、その 20 項目をすべて 1 つのトランザクションで送信します。データベースへのデータ書き込み回数を減らすと、パフォーマンスが大幅に向上します。デッドロックが発生して BizTalk Server がトランザクションを終了した場合は、項目が再送信されます。BizTalk Server はドキュメントを紛失しません。20 を超える値については、テストが実施されていません。この値は 0 に設定しないでください。

また、レジストリ設定を最適化することで、BizTalk Server の HTTP 受信機能のパフォーマンスを向上させることができます。キーは、すべて DWORD 値として \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSVC\HTTPListener に追加します。パフォーマンスを向上させるには、次のようなレジストリ設定を適用します。

  • WorkerThreads : この値は、スレッド プール用のスレッドの数を変更するために使用します。WorkerThreads は既定で 6 に設定されています。HTTP 受信機能用のドキュメント スループットが非常に高速な場合には、WorkerThreads と次の QueueFactor の値を増やす必要があるかもしれません。次のエラー メッセージがイベント ログに記録される場合には、WorkerThreads キーの値を増やす必要があります。

    BizTalk HTTP 受信機能 <名前> によって、スレッド プールからスレッドを取得できませんでした。

  • QueueFactor : キュー サイズを決定するために、プール内のスレッドの数に乗算する係数。すなわち、QueueFactor はスレッド プールで使用されるキューのサイズに影響します。QueueFactor の既定値は 3 です。HTTP 受信機能用のドキュメント スループットが非常に高速な場合には、WorkerThreads と QueueFactor の値を増やす必要があるかもしれません。次のエラー メッセージがイベント ログに記録される場合には、QueueFactor パラメータの値を増やす必要があります。

    BizTalk HTTP 受信機能 <名前> は、作業アイテムをスレッド プールに送信できません。レジストリ キーの "QueueFactor" で、スレッド プール キューの長さを増やしてください。

  • AsyncBufferSize : この値は、IIS の非同期読み取りに使うバッファのサイズであり、オブジェクト指向プログラミング (OOP) 用として推奨されるバッファ サイズです。AsyncBufferSize の既定値は 4,096 バイトに設定されます。48 KB を超えるデータを受信したとき、48 KB を超える部分のデータは IIS によって非同期で読み取られます。

  • MaxSyncFileDropSize : この値は、同期的にファイルに書き込まれるデータの最大サイズであり、このサイズを上回るデータは小分けされてファイルに書き込まれます。この値よりも小さいサイズのデータが受信されると、メモリに読み込まれて、1 度にファイルに書き込まれます。この値よりも大きなデータは非同期で書き込まれます。そのため、大きなデータはメモリにロードされません。MaxSyncFileDropSize は既定で 1,048,576 に設定されています。MaxSyncFileDropSize の値を減らすことで、受信機能のパフォーマンスを向上させることができます。また、システムのメモリが限定されている場合には、この値を減らして、HTTP 受信機能によるメモリの使用量を減らすことができます。

  • MaxLargeAsyncBuffers : この値は、大きなデータ用に割り当てるバッファの数を変更するのに使用します。データが 48 KB を超え、さらにファイル 書き込みの MaxSyncFileDropSize の値を下回るとき、このバッファにキャッシュされます。このバッファが使用されるのは、データが直接 BizTalk Server に (同期または非同期で) 送信される場合か、または MaxSyncFileDropSize の値よりも小さなサイズのデータがファイルにドロップされる場合です。MaxLargeAsyncBuffers の値は既定では 18 です。この値を減らすことで、HTTP 受信機能が使用するメモリの量を制限できます。ただし、この変更はパフォーマンスの劣化につながります。

  • ConfigRefreshInt : この値は、BizTalk メッセージ管理データベースから構成データを取得する時間間隔をミリ秒単位で指定します。ConfigRefreshInt の値は既定では 60,000 ミリ秒です。BizTalk メッセージ管理データベースを更新する頻度に応じて、ConfigRefreshInt の値を増減させます。


暗号化の最適化

暗号化などのセキュリティ メカニズムを使用すると、BizTalk Server のパフォーマンスが低下します。暗号化を利用する場合は、次のような環境を整えることをお勧めします。

  • サーバーの台数を増やします。各 BizTalk Server コンポーネントを分離および最適化することで、パフォーマンスを向上できます。

  • 高速な CPU を使用します。処理速度を向上します。

  • BizTalk Server の機能を分離します。たとえば、送信機能と受信機能を別のサーバーに配置します。

  • ファイル、メッセージ キュー、または HTTP を使用する場合は、既存の仮想プライベート ネットワーク (VPN) を使用します。VPN を使用すると、データ転送がセキュリティで保護されます。取引先との間で行われるあらゆるデータ転送を VPN によってセキュリティで保護すると、BizTalk Server のトランザクションをセキュリティで保護する必要がなくなります。

  • 暗号化ハードウェア アクセラレータを購入します。アクセラレータ カードには専用のプロセッサが搭載されているため、サーバーの CPU に対する、暗号化と暗号解読によるパフォーマンスへの影響が軽減されます。アクセラレータ カードは、CPU を複数増設する場合に比べると安価です。


通信の最適化

BizTalk Server は、同期通信と非同期通信の両方を統合するメカニズムを提供します。BizTalk Server 2002 では、ドキュメントを受信する場合に COM 統合とサーバーの受信機能 (ファイル受信機能、メッセージ キュー受信機能、HTTP 受信機能) のどちらでも使用できます。

ドキュメントを BizTalk Server に送信する場合、そのドキュメントは通常は共有キュー データベースに格納されます。BizTalk Server はデータベースをポーリングした後、ドキュメントを処理します。この処理は、非同期通信メカニズムです。このとき、処理前のドキュメントを取得するキューとして Microsoft SQL Server データベースのチェック ポイント情報が使用されます。この抽象レイヤが追加されることで、ドキュメントの配信にどのようなトランスポート メカニズムが使用されていても、トランスポート サービスはドキュメントを BizTalk Server に送信することが可能になっています。

同期通信インターチェンジは、すべてのキューをバイパスし、呼び出し元スレッドのメッセージ ポートから要求されたコンポーネントをすべて処理します。同期通信プロトコルでは、利用可能な場合には、オプションの応答ドキュメントが返されます。この方法が有効なのは、一致するチャネルが 1 つしかない場合と、メッセージ ポート (同報リスト用ではない) が 1 つしかない場合だけです。

設定されたパラメータを用いた場合に複数のチャネルと一致したときは、同期通信で送信を行うと、同期通信の送信では複数のチャネルの一致が許可されていないというエラーが返されます。この方法を利用できるのは、単一のドキュメント インターチェンジの場合に限られます。送信に複数のドキュメントが含まれている場合に同期送信を行うと、複数のドキュメントを送信することはできないというエラーが返されます。この方法では、グループはサポートされません。

同期通信は拡張できません。同期通信は単一のスレッドを使用してトランザクションを処理します。このプロセスはドキュメントを送信したサーバー上で実行する必要があるため、グループ内のほかのサーバーとの間で負荷分散を行うことはできません。

同期通信では、ドキュメントを直ちに処理するために、BizTalk Server にドキュメントを直接送信します。BizTalk Server は、処理が完了するまで IInterchange::SubmitSync メソッドの呼び出し元への返信を阻止します。このメソッドは、呼び出し元に応答ドキュメントを配信します。このメカニズムを利用できるのは、COM ベースの統合メソッドに限られます。

同期通信と非同期通信の最適化でお勧めする方法

最大限のパフォーマンスとスケーラビリティを得るには、非同期通信を利用するようにします。非同期通信は非常にスケーラビリティが高く、良好なスループットを提供します。同期通信呼び出しでは、SubmitSync の呼び出しはそれぞれ別のスレッドで実行されます。このため、大量のトランザクションが発生する環境において、呼び出し元に対し、即時に近い応答を提供します。

ただし、多数の呼び出しが同時に行われると、1 台のサーバーで多数のスレッドが実行されることになり、BizTalk Server のパフォーマンスが全般にわたって低下します。Microsoft Windows 2000 はスレッド間で必ずコンテキストを切り替えるように設計されているため、BizTalk Server のパフォーマンス全般が低下する原因となります。また、次の条件下では同期通信の送信が失敗しますが、非同期通信の送信は失敗しません。

  • トランザクション条件が、複数のチャネルと一致する。

  • インターチェンジに複数のドキュメントが含まれている。


アーキテクチャの設計、テストおよび分析

BizTalk Server 2002 の主要コンポーネントは、BizTalk サービス、BizTalk Server データベース、およびトランスポート サービスです。構成が適切でないコンポーネントがあると、システム全体のパフォーマンスが低下します。

ここでは、BizTalk Server のアーキテクチャを定義、テスト、および調整し、最大限のパフォーマンスを得るための方法について説明します。

ここには次のトピックが含まれます。

  • アーキテクチャの設計

  • アーキテクチャのテストと分析

関連項目

BizTalk Server の拡張


アーキテクチャの設計

運用環境に BizTalk Server 2002 を導入するときには、事前にテスト環境を導入して、BizTalk Server の性能に影響するさまざな要因をテストすることを強く推奨します。これにより、企業のニーズに応じて最適な BizTalk Server アーキテクチャの構成を決定できます。パフォーマンス テストを成功させるには、プロセスの数を少なくしておきます。最初は変化する要素が少ない状態から始め、徐々に変化する要素を増やしていくことが大切です。このようにすると、パフォーマンスが低下し始めたときに、その原因を識別することができます。

組織に最適な BizTalk Server のアーキテクチャを決定するときには、次の要因について考慮することが重要です。これらの要因は、BizTalk Serverで処理できるドキュメント数に影響します。

  • 仕様の検証

  • アプリケーション統合コンポーネント (AIC)

  • トランスポート サービス

  • 暗号化

  • BizTalk オーケストレーション サービス

  • ファイアウォール

  • マップ

また、処理するドキュメントのサイズと、現在のサーバー構成も考慮する必要があります。

ここには次のトピックが含まれます。

  • トランザクション コンポーネントの開発

  • トランスポートの識別

  • 初期アーキテクチャ

関連項目

サーバーとアプリケーションの管理

BizTalk オーケストレーション サービス

Application Integration Components

仕様の作成とデータのマッピング

BizTalk マッパーの使用

XLANG スケジュールの実行

BizTalk オーケストレーション デザイナの使用


トランザクション コンポーネントの開発

トランザクション コンポーネントを作成するには、トランザクションを設計し、ビジネス プロセス用のトランザクション プロパティを設定する必要があります。トランザクションの設計とトランザクション プロパティの設定の詳細については、次のトピックを参照してください。

  • ビジネス プロセスの設計

  • トランザクションの設計

  • XLANG スケジュール フローチャートのトランザクション プロパティ

トランザクション コンポーネントを作成するには、処理対象となるトランザクションの種類をあらかじめ特定しておく必要があります。アプリケーション間や企業間の環境では、トランザクションに関するニーズと、トランザクションのプロファイルを特定する必要があります。たとえば、あるトランザクションでカスタム XML 書式の注文書を受信し、それを標準 EDI 書式の注文書にマップして、後でカスタム社内アプリケーションで処理する、といったシナリオがあります。

このシナリオでは、XML 書式による注文書用の仕様と、EDI 書式による注文書用の仕様を作成する必要があります。これらの仕様を作成するには、XML および EDI によるテンプレートが用意されている BizTalk エディタを使用します。テンプレートには、使用される可能性のあるレコードとフィールドがすべて含まれています。そのため、不要なレコードとフィールドを削除してから、最終的な仕様としてテンプレートを保存してください。設計時には、検証が必要となるフィールドが仕様に含まれている場合、BizTalk Server 2002 のパフォーマンス低下の原因となることに注意してください。仕様の最適化の詳細については、「仕様の作成と最適化」を参照してください。

仕様を作成する以外に、データのマップも行う必要があります。マップ ファイルにデータを変換する方法は、単純な XSLT 変換、Functoid、カスタム スクリプトの使用などいくつもありますが、すべてパフォーマンスに影響を及ぼすため、さまざまな変換方法をテストすることが重要です。データ変換方法をテストしてほかの方法と比較しておくと、マッピングによる BizTalk Server のパフォーマンスへの影響を軽減させることができます。詳細については、「マップの作成と最適化」を参照してください。

最も効率的なトランザクションの構成を特定するのに役立つテクニックについては、「構成のパフォーマンスの評価」を参照してください。

注

  • カスタム スクリプト機能内部で Microsoft XML Parser (MSXML) によって返されるエラーの一部は、サーバーに渡されないことがあります。保留キュー内のドキュメントに関連するエラーは、スクリプトで返されるエラーに反映されません。

関連項目

ビジネス プロセスの設計

トランザクションの設計

トランスポートの識別

XLANG スケジュール フローチャートのトランザクション プロパティ


トランスポートの識別

データの送信および受信方法を決定するには、次の機能を使用するかどうかについて検討する必要があります。

  • 企業間トランザクション

  • アプリケーション間トランザクション

  • トランスポート サービス (送信および受信)

  • 暗号化

  • HTTPS または S/MIME

処理するトランザクションの種類に合わせて異なるトランスポートを使用する必要があるかどうかについて、考慮してください。また、企業間トランザクションとアプリケーション間トランザクションに専用のトランスポートが必要かどうか、およびこの 2 種類のトランザクションに使用できるトランスポートがあるかどうかを把握しておきます。


初期アーキテクチャ

初期アーキテクチャを正しく計画するには、次の点を考慮に入れてください。

  • 処理するトランザクションの量が少ない場合は、Microsoft SQL Server と BizTalk Server がインストールされたサーバー 1 台だけで運用できます。

  • トランザクションの量が中程度の場合は、BizTalk Server と SQL Server を別のサーバーにインストールして使用します。

  • データの送受信には、既存の SMTP トランスポート サービスを使用できます。この種類のトランスポートを実行するサービスとして、別のサーバーを用意することをお勧めします。

  • HTTP、メッセージ キュー、またはファイル トランスポート サービスを使用すると、ローカルの BizTalk Server とは別のサーバーのディスク装置にデータを書き込むことができるので、BizTalk Server のパフォーマンスが向上します。

初期アーキテクチャでは、サーバー機能をできる限り分散させてください。たとえば、社内である人が SMTP サーバーとメッセージ キューを管理し、別の人がセキュリティ ポリシーを担当していることがあるためです。初期アーキテクチャの目標は、必要なサーバーの数と、それらのサーバーが担当する処理に必要なハードウェアを決定することです。必要なサーバー数が決まったら、初期アーキテクチャをテストします。

関連項目

アーキテクチャのテストと分析


アーキテクチャのテストと分析

アーキテクチャをテストする前に、次のことを行わねばなりません。

  • アーキテクチャのコンポーネントを定義します。

  • トランザクションに関するニーズとプロファイルを特定します。

  • 作成する必要のあるトランザクション コンポーネントを特定します。

  • 必要なトランスポート サービスを特定します。

最初に基本的な部分を作成しますが、それには次の作業が必要です。

  • トランザクションの処理に必要な BizTalk メッセージ サービス、組織、ドキュメント定義、チャネル、およびメッセージ ポートを構成します。

  • BizTalk オーケストレーション サービスを構成します。

  • XLANG スケジュールに必要な COM+ アプリケーション、BizTalk Server のチャネル、データベース、またはメッセージ キューをインストールあるいは構成します。

基本的な部分の構築が終わったら、BizTalk Server を使用してトランザクションを処理します。これによって、パフォーマンスに影響を与える要因を見極めることができます。

ここには次のトピックが含まれます。

  • 構成のパフォーマンスの評価

  • アーキテクチャの改良

関連項目

アーキテクチャの設計

BizTalk Server の拡張


構成のパフォーマンスの評価

BizTalk メッセージ サービスのパフォーマンスは、Microsoft Windows 2000 に用意されているパフォーマンス ツールを使用してテストできます。

パフォーマンス ツールを使用するには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[パフォーマンス] をクリックします。パフォーマンス ツールに含まれるシステム モニタには、カウンタ値の変化が常時グラフィカルに表示されます。さまざまなカウンタがあるため、監視対象のシステム コンポーネントに合わせて監視するカウンタを決める必要があります。Windows 2000、Internet Information Services (IIS)、SQL Server、およびメッセージ キューのパフォーマンスを監視する方法を説明したホワイト ペーパーは数多くあります。次の表は、監視対象となる主なオブジェクトおよびカウンタの一覧です。この表では、監視対象のオブジェクトおよびカウンタに関連した、BizTalk メッセージ サービスのパフォーマンスを評価するための情報も示しています。

オブジェクト | カウンタ | 監視する内容 | 関係するコンポーネント
Active Server Pages | Requests Queued | ピーク時間帯を除いて、大量のキューが発生していないことを確認します。 | .asp ページを使用する HTTP トランスポート サービス
 | Requests/Sec | HTTP トランスポート サービスが ASP を使用している場合に、受信している ASP 要求の量を示しています。ファイルが HTTP ページにポストされる場合は、このカウンタは正確な情報を提供しなくなります。 | .asp ページを使用する HTTP トランスポート サービス
 | Request Wait Time | 0 に近いことを確認します。 | .asp ページを使用する HTTP トランスポート サービス
Network Interface | Bytes Received/sec、Bytes Sent/sec | この数値が接続の容量限度に近くなり、プロセッサとメモリの使用率が中程度になっている場合は、接続によるパフォーマンスへの影響が発生します。 | すべて
Process | Private Bytes | メモリ リークが発生していないかどうか、サイズが利用可能な RAM の最大値に近づいていないかどうかを、これで監視します。 | HTTP トランスポート サービス
Memory | Available Bytes | 利用可能なバイト数が、10 MB 未満にならないようにします。10 MB を下回った場合は、メモリ使用率が一時的に増加したときにディスクへのページングが行われます。 | すべて
 | Page Faults/sec、Pages Input/sec、および Page Reads/sec | この数値が小さい場合は、サーバーは短時間で要求に応答します。数値が大きい場合は、サーバーのメモリ量を増やす必要があります。 | すべて
PhysicalDisk | Disk Reads/sec、Disk Writes/sec | この 2 つのカウンタの合計が、ディスク デバイスの最大容量よりもはるかに小さい値になっている必要があります。このカウンタを有効にするには、[スタート] メニューの [プログラム] をポイントし、[アクセサリ] をポイントして、[コマンド プロンプト] をクリックします。次に、コマンド プロンプトで「diskperf -y」と入力し、コンピュータを再起動します。 | SQL Server、メッセージ キュー、およびファイル トランスポート サービス
 | % Disk time | このカウンタは、100% をかなり下回っている必要があります。この値が 100% を超える場合 (1,000% まで上昇する可能性あり) は、物理ディスクを増設するか、またはデータベースの 1 つを別のサーバーに移動します。このカウンタの値は、使用している RAID の構成によって変化します。 | SQL Server、メッセージ キュー、およびファイル トランスポート サービス
 | % Idle time | このカウンタは、20% 以上になる必要があります。この値を下回る場合は物理ディスクを追加するか、データベースの 1 つをほかのサーバーに移動します。% Disk Idle time カウンタは、RAID の構成に影響されないため、% Disk utilization カウンタよりも優れた指標です。いずれかのディスクの負荷が過剰になっている場合には、ほかの物理ディスクに負荷の分配を回すか、過剰負荷のドライブにディスクを追加します。 | SQL Server、メッセージ キュー、およびファイル トランスポート サービス
 | Current Disk Queue Length | このカウンタは、パフォーマンス データの収集中に、ディスクに一時置かれた要求の数を示しています。この数値が平均で 2 未満であれば、パフォーマンスは良好です。 | BizTalk Server SQL Server
SQL Server | Transactions/sec | SQL Server が実際に実行したトランザクションの量を示しています。 | SQL Server
BizTalk Server | Documents Processed/sec | BizTalk Server 2002 が、どれほどの速さで作業キューからドキュメントをポーリングし、送信したかを示します。 | BizTalk メッセージ サービス
 | Documents Received/sec | BizTalk Server が、どれほどの速さでドキュメントを作業キューに送信したかを示しています。この数値は、BizTalk Server が受信したドキュメント数 (解析に失敗したドキュメントを含む) だけを表しており、BizTalk Server が共有キューのチェックポイントに格納したドキュメント数は含まれません。共有キューのチェックポイントに格納されたドキュメント数は、基本的に Documents Processed/sec カウンタと等しくなります。 | BizTalk メッセージ サービス
 | Synchronous Submissions/sec、Asynchronous Submissions/sec | Sumbit メソッドや SubmitSync メソッド呼び出しが、どれだけの速さで行われたかを示しています。インターチェンジに含まれるドキュメントの数は特に決まっていないため、このカウンタは処理されたドキュメント数の確認には役立ちません。パススルー送信 (インターチェンジを解析せずに処理する) のみが使用されている場合に受信パフォーマンスを確認するには、このカウンタを監視します。 | BizTalk メッセージ サービス
MSMQ Queue | Messages in queue | この数値があまり(50,000 以上) 大きくならないようにします。大きくなりすぎると、メッセージ キュー サーバーのメモリが大量に消費され、システムのパフォーマンスが全般にわたって低下します。 | メッセージ キュー トランスポート サービス
System | Processor Queue Length | システム内のすべてのプロセッサが共有しているキューで、実行されるのを待機しているスレッドの数を示しています。このカウンタの値が常に 2 または 3 スレッド以上ある場合は、プロセッサの速度が原因で、システムのパフォーマンスが全般にわたって低下しています。 | すべて
 | Context Switches/sec | BizTalk Server コンピュータでこの数値が高くなっている場合は、同じサーバーで送信機能と受信機能を実行していることが原因です。その場合は、送信機能と受信機能を別のサーバーに分離することを検討してください。 | すべて
Processor | %Processor Time | ネットワーク アダプタ カードとディスク入出力容量に余裕がある場合にこのカウンタの値が大きいときは、プロセッサがパフォーマンス低下の原因になっています。マルチ プロセッサ システムの場合は、このカウンタがアンバランスになっていないかどうかを調べてください。また、ピーク時の使用率は 100% になってもかまいませんが、通常時の使用率は 100% 未満になっている必要があります。サーバー機能は、すべて水平方向に拡張することが可能です。 | すべて
Web Service | Get Requests/sec Post Requests/sec | HTTP の get および post メソッドによって受信されているファイルの量を示しています。 | HTTP トランスポート サービス

入手可能な SMTP トランスポート サービス製品は数多くあるため、SMTP トランスポート サービス専用のカウンタは一覧に示していません。使用中の SMTP トランスポート サービスが何であるかにかかわらず、BizTalk Server との間で送受信されるメッセージの量を監視するようにしてください。この表に示したカウンタを監視すると、パフォーマンスの低下を確認することができます。システムの正常な動作は、すべてのコンポーネントが連携して動作することで保たれています。そのため、1 種類のパフォーマンスが低いという理由で、システム構成に大幅な変更を加えないでください。

パフォーマンスの監視によって得られたデータは、問題に発展し得る兆候を把握するうえでも役立ちます。たとえば、ディスク入出力の値が高い場合は、SQL Server がディスクに大量のデータを書き込んでいるか、システムによるディスクへのページングが頻繁に発生している可能性があります。ディスクへのページングが頻繁に行われるのは、ほとんどの場合、メモリの量が少なすぎることが原因です。このケースでは、ディスク入出力自体には問題はありませんが、ほかの問題を発見するきっかけになります。

関連項目

BizTalk Server の拡張


アーキテクチャの改良

パフォーマンスに影響を与えている部分がわかったら、システムのアーキテクチャを調整して、最大限のパフォーマンスが得られるようにします。たとえば、ハードウェアをアップグレードしたり、BizTalk Server のコンポーネントを別のサーバーに移動したりします。また、BizTalk Server の設定も調整する必要があります。設定の調整については、「サーバーのプロパティの最適化」を参照してください。

変更は計画的に行ってください。CPU の増設、設定の変更、別のサーバーへの機能の分離などの変更を実施したら、変更内容を文書化し、新しい構成をテストして、パフォーマンスが向上したかどうかを確認します。新しい構成でパフォーマンスが向上した場合は、構成をさらに変更します。一方、新しい構成でパフォーマンスが低下した場合は、システムの構成を前の状態に戻し、データを分析して問題の原因を確認してください。

関連項目

構成のパフォーマンスの評価


パフォーマンスの維持

パフォーマンスを維持するには、BizTalk Server の動作を正常な状態に保ち、将来にわたってパフォーマンスを確保するための、実務的なメンテナンス計画を作成します。BizTalk Server が処理するドキュメントの数は、しだいに増加していくのが普通です。BizTalk Server の初期アーキテクチャが正常に機能していても、トランザクションの数が増加していくと、システムのアーキテクチャや構成を変更しない限り同じレベルのパフォーマンスは維持できなくなります。ハードウェアの故障やメモリ不足も、システムのパフォーマンスに影響を与えます。

ここには次のトピックが含まれます。

  • パフォーマンスのメンテナンス計画の作成

  • Application Center 2000 の使用


パフォーマンスのメンテナンス計画の作成

監視計画には、次の項目を含めてください。

  • どのカウンタを監視するかを詳細に計画します。Windows 2000 のシステム モニタのカウンタには監視すべき有効なしきい値を含むものが数多くあり、またしきい値から導き出される問題の解釈も多数存在します。また、SQL Server のクエリが有効なデータまたはハードウェアの問題を返しているかどうかなど、アプリケーション レベルの問題も監視できます。

  • パフォーマンスにおける問題を解決するための手順を明確にします。たとえば、Windows 2000 イベント ログにメッセージを書き込む、電子メールによる通知を有効にする、カスタム プログラムによって一連のイベントを開始するなどがあります。

  • パフォーマンスしきい値がどの値に達した時点で通知を生成するのかを決めます。たとえば、CPU 使用率が 90% に達した時点で Windows 2000 イベント ログにイベントを書き込むように監視ツールを構成します。また、CPU 使用率が 90% 以上のまま 5 分間経過したときに、電子メール メッセージが送信されるようにします。使用する監視ツールの操作方法に従って、問題の重大度レベルごとに別のアクションを定義してください。

  • Windows 2000 イベント ログにイベントが書き込まれた場合に、それに対処する一連のアクションを定義します。Windows 2000、BizTalk Server 2002、SQL Server、およびメッセージ キューや HTTP などの組み込み Microsoft トランスポート サービスは、Windows 2000 イベント ログにイベントを書き込みます。イベント ログには、BizTalk Server システムを構成するサーバーのいずれかで問題が発生しそうになっていることを示す、有用な情報が含まれています。早めに対処しておくと、システムのパフォーマンスが全般にわたって低下するようなシステム障害を回避できます。計画では、ログの監視とアーカイブを行う頻度を定め、作業の担当者も決めておきます。Microsoft Operations Manager (MOM) を利用して複数のサーバーからログを収集し、それらをデータベースに書き込んで総合的に分析する方法もあります。Microsoft Operations Manager の詳細については、「Microsoft Operations Manager について」を参照してください。

  • パフォーマンスの監視に必要なツールを決定します。Windows 2000 に組み込まれたシステム モニタ ツールは、パフォーマンス カウンタを監視し、あらかじめ定義しておいた条件が満たされた場合に特定のアクションを実行できます。システム モニタ警告の構成の詳細については、Windows 2000 ヘルプの「監視の構成を設定する」を参照してください。また、Microsoft Application Center 2000 や多くのサード パーティ製ツールを利用すると、アクションの実行に加えて、データベースへのログ記録やアプリケーション レベルのテストなどの機能も実行できます。


Application Center 2000 の使用

Microsoft Application Center 2000 には、ヘルス モニタというツールが含まれています。ヘルス モニタは、Windows 2000 イベント ログおよびシステム モニタ ツールの代替ツールとして利用できます。ヘルス モニタを使用すると、管理者が監視対象を設定できるようになります。監視対象としては、TCP/IP、パフォーマンス モニタのカウンタのしきい値、イベント ログのエラー、および Windows Management Instrumentation (WMI) イベントのチェックなどがあります。監視対象に対して条件を構成することができ、CPU 使用率が 90% 以上に達するなど一定の条件を満たした場合に、サーバーをオフラインにするアクションや、管理者に電子メールを送信するアクションなどを実行できます。これらのツールを使用すると、BizTalk Server 2002 のパフォーマンスを予防的に監視し、維持することができます。

重要

  • XLANG スケジュールをホストする既定の XLANG スケジューラ アプリケーションや COM+ アプリケーションは、レプリケートしないでください。コンポーネント負荷分散 (CLB) を使用するときは、COM+ アプリケーションを必ずそれぞれのサーバーにインストールしてください。XLANG スケジュールにバインドされている COM コンポーネントは、レプリケートすることができます。


BizTalk Server の拡張

システムや BizTalk サーバーの設定を最適化することでパフォーマンスを最適化しても、依然として高いプロセッサ使用率がボトルネックになる場合があります。この場合には、高いパフォーマンスの実現に BizTalk Server ソリューションの拡張が必要になります。BizTalk Server の構成は 2 種類の方法で拡張できます。各サーバーで使用するプロセッサ数やメモリの容量を増やす垂直的 (スケール アップ) な拡張方法と、BizTalk Server の構成にサーバーを追加する水平的 (スケール アウト) な方法をとることができます。

主要なコンポーネントは、複数のサーバーに分散することが重要です。BizTalk Server 2002 の主要コンポーネントとしては、次のものが挙げられます。

  • BizTalk サービス : ここに含まれるサービスとしては、BizTalk メッセージ サービスやBizTalk オーケストレーション サービスなどがあります。詳細については、「BizTalk メッセージ サービス」と「BizTalk オーケストレーション サービス」を参照してください。

  • データベース : データベースとしては、BizTalk メッセージ管理、追跡、共有キュー、およびオーケストレーション データベースがあります。

  • トランスポート サービス : トランスポート サービスとしては、HTTP、ファイル、SMTP、メッセージ キューなどがあります。拡張のための要件は、コンポーネントごとに異なります。

ここには次のトピックが含まれます。

  • BizTalk Server の垂直方向拡張

  • BizTalk Server の水平方向拡張

関連項目

BizTalk Server データベースの管理

BizTalk メッセージ管理データベースの管理

永続化

トランスポートのプロパティの設定

共有キュー データベース

追跡データベース


BizTalk Server の垂直方向拡張

複数のプロセッサと大量のメモリを使用すると、BizTalk Server 2002 を垂直方向に拡張 (スケール アップ) できます。BizTalk Server を垂直方向に拡張すると、サーバーの数を減らし、サイト管理を簡略化することができますが、システムを水平方向に拡張したり、ソフトウェア アーキテクチャを改良するよりもコストがかかります。また、既存のハードウェアの容量を限界まで高めたら、次はシステムの水平方向拡張が必要になります。

ここには次のトピックが含まれます。

  • BizTalk Server のスケール アップ

  • データベースのスケール アップ

  • トランスポート サービスのスケール アップ


BizTalk Server のスケール アップ

BizTalk Server 2002 を垂直方向に拡張するには、次の手順に従います。

  • プロセッサを、大容量の L2 キャッシュを備えた Pentium III や、その派生プロセッサの Xeon などにアップグレードします。

  • 最大で 8 個までの CPU を備えた Symmetric Multipleprocessing (SMP) サーバーを使用します。

  • 高速なディスク システムを使用します。

  • ファイルの入出力やネットワークに関するボトルネックを解決します。詳細については「BizTalk Server アーキテクチャのパフォーマンスのチューニング」を参照してください。

BizTalk Server の垂直方向拡張でお勧めする方法

BizTalk Server で最適なパフォーマンスを得るための推奨環境は、次のとおりです。

  • CPU を 8 個までアップグレードできる、Pentium III Xeon マルチプロセッサ システム。クロック周波数が高いほどパフォーマンスが向上します。

  • 1 ～ 2 MB の L2 プロセッサ キャッシュ。解析のパフォーマンスが向上します。

  • 1 GB の RAM。組織でメガバイト (MB) 規模のドキュメントを複数処理する場合は、より多くの RAMを実装してください。

  • スループット 100 Mbps (メガビット/秒) 以上の複数のネットワーク カードを 100 Mbps (メガバイト/秒) スイッチのポートに接続し、ネットワークの入出力スループットを向上させます。

  • メッセージ キューと分散トランザクション コーディネータ (DTC) のファイルおよびログを扱うための、複数のディスクとディスク コントローラ。DTC のログを中央のリモート サーバーに書き込むことで、ローカルの BizTalk Server におけるファイル入出力の競合を削減します。

  • 共有キュー データベースとメッセージ キュー データベースのパフォーマンスを向上させるために、ディスクを RAID 0 と RAID 1 で構成します。

  • BizTalk Server で複数のネットワーク インターフェイス カード (NIC) を使用し、共有キュー データベースや BizTalk メッセージ管理データベースを処理する Microsoft® SQL Server™ プロセスと、HTTP プロセスを分離します。また、ネットワーク カードのトラフィックを削減するために、スイッチ ネットワークの使用も検討してください。

  • これらの推奨環境は、BizTalk Server のみがインストールされたサーバーで BizTalk Server を実行することを前提としています。BizTalk サービスが、ほかのアプリケーション サービスとサーバーを共有している場合は、ハードウェアをさらに強化することをお勧めします。


データベースのスケール アップ

データベースを垂直方向に拡張するには、ディスクの構成を決定する必要があります。ディスク構成を決定するには、スループット、フェールオーバー (障害復旧性)、およびコストについて考慮する必要があります。

次の表は、利用できる選択肢を示し、それらを互いに比較したものです。

RAID レベル | コスト | 実質的なディスク使用率 | 速度 | フォールト トレランス
0 (ストライピング) | 低 | 100 | 高速 | 低
1 (ミラーリング) | 高 | 50 | 中程度 | 高
5 (パリティ付きストライピング) | 中 | 実質的なディスク容量 : アレイを構成するディスクの台数から 1 台 (パリティ用) を引いた台数の、合計ディスク容量 | 低速 | 中 (ディスクに障害が発生しても、パフォーマンスが低下するのみ)
0 + 1 (ストライピング ディスクのアレイのミラーリング) | 高 | 50 | 高速 | 高

最高のパフォーマンスを得るには、高速な CPU と大容量の不揮発性 RAM を備えた、キャッシュ付き Redundant Array of Independent Disks (RAID) コントローラをインストールすることをお勧めします。また、複数の RAID レベルを組み合わせると、必要なパフォーマンスを得ることができます。たとえば、RAID 0 では最高のパフォーマンスが得られますが、フォールト トレランスは利用できません。RAID 1 では最高レベルのフォールト トレランスが得られますが、複数のディスクに同時にデータを書き込むのではなく、1 つのディスクに書き込むため、パフォーマンスは高くありません。最高のパフォーマンスを得るには、RAID 1 と RAID 0 を組み合わせます。そのためには、RAID 0 ディスクのアレイをミラーリングします。

注

  • 速度とコストに関しては、RAID 5 よりもほかの RAID レベルの方が優れています。RAID 5 には大きな利点がありますが、データの書き込みは RAID 0 および RAID 1 よりも低速です。

  • どのような方式を採用する場合でも、使用可能なディスク コントローラの数が重要な意味を持ちます。ディスク 1 台ごとにコントローラを 1 基ずつ使用すると、全体のパフォーマンスが大幅に向上します。ディスクを構成する場合は、ディスク チャネルを効率的に使用することも重要です。ディスク チャネルとは、1 つのコントローラを共有するディスクのことです。このようなディスクは、単一のディスクとして構成されることも、ディスク アレイの一部として動作するように構成されることもあります。たとえば、サーバーに 10 台のディスクがあり、2 つのアレイに 5 台ずつ配置され、各アレイはそれぞれ専用のコントローラに接続されているとします。この場合は、ディスク チャネルは 2 つになります。

理想的なのは、BizTalk メッセージ管理、共有キュー、追跡、およびオーケストレーション データベースを、それぞれ別のディスク チャネルに接続することです。この構成によって、各データベースへのアクセスが向上します。組織のシステム環境によっては、データベースをそれぞれ別のサーバーに展開しなければならない場合があります。展開を計画するには、各データベースの使用方法を理解しておくことが重要です。

  • BizTalk メッセージ管理データベースには、組織、サーバー グループ、サーバー、チャネル、メッセージ ポートなど、BizTalk Ssrver に関するすべての構成情報が格納されています。この情報は、読み取られると Microsoft SQL Server のメモリにキャッシュされます。このデータベースは 4 つのデータベースについて必要最小限の利用状況を受信するもので、必要に応じて、ほかの 3 つのデータベースのいずれか 1 つと同じディスク チャネルに配置できます。

  • 共有キュー データベースは、あらゆるキューのデータを管理します。非同期通信を使用するドキュメントは、すべて共有キュー データベースに送信され、格納されます。BizTalk Server でドキュメントを処理する準備が整うと、そのドキュメントは共有キュー データベースから削除され、処理されます。共有キュー データベースはあらゆるトランザクションを管理しているため、このデータベースに対しては、データの書き込みと読み取りが頻繁に行われます。

  • 追跡データベースは、サーバーをパススルーするドキュメントを個別の処理とバッチ処理の両方について追跡します。このデータベースには、データと、データのログ記録の両方が格納されます。このため、追跡データベースでは、データの書き込みは頻繁に発生しますが、読み取りはほとんど行われません。

  • オーケストレーション データベースには、XLANG スケジュールの構造とアクティブな XLANG スケジュール インスタンスの進行状況が格納されるほか、XLANG スケジュール インスタンスがトランザクションを開始または完了した場合や、システムがシャットダウンした場合、または XLANG スケジュール インスタンスがステータス退避を実行した場合に送受信されるメッセージも格納されます。

    注

    • 最も使用頻度が高いのは、追跡データベースと共有キュー データベースです。負荷分散の最適化を図るために、これらのデータベースは 2 つのサーバーに分散配置することをお勧めします。

データベースの垂直方向拡張の最適化でお勧めする事項

BizTalk Server データベースで最高のパフォーマンスを得るためには、次のような環境を整えることを検討してください。

  • CPU を 8 個までアップグレードできる、Pentium III Xeon マルチプロセッサ システム。クロック周波数が高いほどパフォーマンスが向上します。

  • 1 GB の RAM。組織でメガバイト (MB) 規模のドキュメントを複数処理する場合は、より多くの RAMを実装してください。

  • 一般的なデータベース管理方法に基づいて、基礎となる Microsoft SQL Server のデータベースとログを最適化します。SQL Server の詳細については、[スタート] メニューの [プログラム] をポイントし、[Microsoft SQL Server] をポイントして、[Books Online] をクリックしてください。

  • 最初は少数のトランザクションしか処理しないという計画を立てている場合は、複数のデータベースを同一のディスク入出力チャネルにインストールしてもかまいません。処理するトランザクションの量が増えたら、サーバーにディスクやコントローラを増設し、データベースをその新しいディスク入出力チャネルに移動します。また、各データベースを新しいサーバーに移動することも可能です。データベースの水平方向拡張については、「データベースのスケール アウト」を参照してください。

  • CPU の使用率が 80% を超える場合は、CPU を追加します。

  • ディスク キューの長さの平均が 1 を超える場合や、ディスク入出力使用率が 100% 近くになる場合は、ハード ディスクを追加します。

  • データベースを、専用のディスク入出力チャネルにインストールします。

  • アクセスが高速なディスク、およびスループットの高いコントローラを購入します。

  • フォールト トレランスを実装する場合は、RAID 0 およびミラーリングの導入を検討します。

BizTalk メッセージ管理データベースを最適化するには、次のような方法があります。

  • データベースを、専用のサーバーかディスク チャネルにインストールします。

  • 組織内に、処理対象のデータが大量にある場合は、このデータベースを専用のディスク入出力チャネルに配置し、共有キュー データベースまたは追跡データベースのパフォーマンスの低下を防ぎます。

追跡データベースを最適化するには、次のような方法があります。

  • ハード ディスクを増設し、共有キュー データベースで使用するディスク領域を現在よりも大きくします。

  • 単一のトランザクションにおける平均的なドキュメント サイズを見積もります。そのドキュメント サイズに、ドキュメントが追跡データベースのログに記録される回数を掛けます。この値は、1 つのドキュメントを追跡データベースに格納するために必要となる、ドキュメント格納領域の大きさを表します。ドキュメント格納領域の値に必要なスループットの値を掛けると、追跡データベースに必要な容量がわかります。追跡データベース用の領域として、平均的なサイズのドキュメントに関するログを格納できるだけの容量を確保してください。

  • このデータベースには大量のデータが書き込まれるため、専用のディスク入出力チャネルにインストールします。トランザクションの量が多い環境では、ディスクの入出力チャネルを分離することは特に重要です。

  • 追跡データベースにシステムで最低限必要な容量を割り当てます。

    注

    • インターチェンジとドキュメントの追跡にはサイズに制限があり、制限を超えると BizTalk Server のパフォーマンスに大きく影響します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

オーケストレーション データベースを最適化するには、次のような方法があります。

  • このデータベースではデータの書き込みと読み取りが頻繁に行われるため、専用のディスク入出力チャネルが必要です。可能な場合には必ず、アクセスが高速なディスク、およびスループットの高いコントローラを購入します。フォールト トレランスを実装する場合は、RAID 0 およびミラーリングの導入を検討します。

  • CPU の使用率が 80% を超える場合は、CPU を追加します。

  • ディスク キューの長さの平均が 1 を超える場合や、ディスク入出力使用率が 100% 近くになる場合は、ハード ディスクを追加します。

関連項目

BizTalk Server の拡張


トランスポート サービスのスケール アップ

BizTalk Server 2002 では、4 つのトランスポート サービスをサポートしています。これらのトランスポート サービスは、垂直方向に拡張することが可能です。

  • HTTP/HTTPS

  • ファイル

  • SMTP

  • メッセージ キュー

ここには次のトピックが含まれます。

  • HTTP/HTTPS のスケール アップ

  • ファイルのスケール アップ

  • SMTP のスケール アップ

  • メッセージ キューのスケール アップ


HTTP/HTTPS のスケール アップ

受信

HTTP 受信機能は、ドキュメントをファイル システムに送信するか、BizTalk Server インターチェンジ オブジェクトの IInterchange::Submit() または SubmitSync() を呼び出して、直接 BizTalk Server に送信します。HTTP 受信機能は、HTTP と HTTPS の両方のトランスポート プロトコルをサポートしています。HTTP 受信機能は、投稿されたドキュメントを処理するための構成可能スレッド プールを管理します。

大量のデータが処理される環境で、ドキュメントの受信に HTTPS (Secure Hypertext Transfer Protocol) を使用すると、暗号解読処理によってパフォーマンスが低下します。組織のセキュリティ ニーズに応じて、HTTPS を使用してデータを暗号化しなければならない場合もあります。このように、セキュリティ レベルを上昇させると BizTalk Server のパフォーマンスが影響を受けます。

送信

HTTP トランスポート サービスを使用してドキュメントを送信する場合も、HTTP 受信機能を使用してドキュメントを受信する場合と同様のセキュリティやパフォーマンス上の問題が発生します。

HTTP/HTTPS の垂直方向拡張の最適化でお勧めする事項

HTTP 受信機能と HTTP/HTTPS トランスポート サービスのパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • BizTalk Server での受信ドキュメントの増加に対応できるように、CPU をクロック周波数の高いものに交換し、CPU を増設して必要なレベルのパフォーマンスが得られるようにします。

  • HTTP/HTTPS サービスを利用した送信で ASP ページを使用する場合は、最良の方法について検討してください。ASP ページとインターネット インフォメーション サービスを最適化する方法については、インターネット インフォメーション サービスのヘルプ (localhost/iisHelp) で、[Active Server Pages ガイド] をクリックしてください。


ファイルのスケール アップ

受信

ファイル受信機能は、企業間のトランザクションで利用すると高いパフォーマンスを得ることができますが、インターネットをベースとしたトランザクションで利用するにはセキュリティ保護が不十分なため、あまり使用されません。ただし、社内のアプリケーション間トランザクションであればセキュリティ上の危険も少ないため、その優れたパフォーマンスを活用することができます。また、SMTP や HTTP などのほかの受信機能と組み合わせた場合には、外部の取引先との間で、セキュリティを低下させることなく使用できます。SMTP および HTTP 受信機能では、セキュリティ保護のために S/MIME または HTTPS を使用して取引先からドキュメントを受け取り、ファイルを内部のファイル システムのディレクトリに書き込みます。その後の BizTalk Server によるドキュメントの受信でファイル受信機能を使用することができます。このトランスポートの組み合わせでは、パフォーマンスは向上しませんが、柔軟性とセキュリティを高めることができます。

注

  • S/MIME を使用すると、BizTalk Server のパフォーマンスが大幅に低下します。

送信

ファイル受信機能で説明したセキュリティとパフォーマンスの関係は、ファイル トランスポート サービスを使用してドキュメントを送信する場合にも当てはまります。

ファイル受信機能およびファイル トランスポート サービスの垂直方向拡張の最適化でお勧めする方法

ファイル受信機能とファイル トランスポート サービスのパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • リモートのファイル ディレクトリではなくローカルのファイル ディレクトリを使用して、ネットワークの待ち時間を少なくします。

  • ディスク アレイを使用して、スループットを向上させます。ディスク アレイの速度と冗長性とのトレードオフについては、「データベースのスケール アップ」を参照してください。

  • ファイル受信機能を使用しているときには、読み取りキャッシュを有効にしてディスク コントローラを使用します。

  • ファイル転送サービスを使用しているときには、不揮発性書き込みキャッシュを有効にしてディスク コントローラを使用します。


SMTP のスケール アップ

受信

SMTP の受信機能は、BizTalk Server 2002 では標準でサポートされていません。SMTP 受信機能は、イベント ベースのメカニズムによってドキュメントを受信し、そのドキュメントを BizTalk Server に送信します。SMTP 受信機能を使用すると、MIME/SMIME エンコードされたドキュメントを受信し、前処理を行うことができます。

送信

S/MIME を利用した受信と HTTP/HTTPS を利用した送信で説明したセキュリティとパフォーマンスの関係は、SMTP をトランスポート サービスとしてドキュメントを送信した場合にも当てはまります。メッセージ ポートまたはポートのトランスポート サービスとして、チャネルで SMTP を使用している場合、処理サーバーはドキュメントを処理し、それを受信アプリケーションに送信します。

注

  • 送信ドキュメントを S/MIME エンコードするためにデジタル証明書が必要となる場合は、BizTalk Server のパフォーマンスが大幅に低下します。

SMTP の垂直方向拡張の最適化でお勧めする事項

SMTP のパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • 必要なレベルのパフォーマンスが得られるかどうかは、ドキュメントの受信で使用する SMTP サービスに大きく左右されます。組織には、通常は SMTP サービス機能を実行する SMTP サーバーが用意されています。SMTP サーバーを使用しない環境で Microsoft Exchange Server またはサード パーティ製のメッセージ システムを使用することにした場合、BizTalk Server が十分なレベルのパフォーマンスを維持するためには、BizTalk Server を実行するサーバーにかなりパフォーマンスの高いハードウェアを実装する必要があります。SMTP サーバーは、イベント ベースのメカニズムを呼び出すことで BizTalk Server にドキュメントを送信できるようになっている必要があります。

  • SMTP サーバー上で BizTalk Server を実行すると、CPU の処理能力が低下します。パフォーマンスの低下を抑えるには、高速な CPU を使用してください。

  • S/MIME (Secure Multipurpose Internet Mail Extensions) を使用すると、BizTalk Server のパフォーマンスが大幅に低下します。S/MIME による BizTalk Server の全体的なパフォーマンスへの影響を抑えるには、高速な CPU を使用してください。


メッセージ キューのスケール アップ

受信

一般に、メッセージ キューはメッセージの送受信で大量のディスク入出力を行います。メッセージ キューはトランザクションの形態をとるため、フォールト トレランスの向上に非常に役立ちます。ただし、トランザクションを利用するのはローカル サーバーの場合だけです。フォールト トレランスを向上させるためにメッセージ キューを使用する場合は、ディスク入出力の増加に応じて、各 BizTalk Server コンピュータに十分な数のディスクを設置する必要があります。

送信

メッセージ キューを使用してドキュメントを送信する場合も、メッセージ キューを使用してドキュメントを受信する場合と同様のセキュリティおよびパフォーマンス上の問題が発生します。

メッセージ キューの垂直方向拡張の最適化でお勧めする事項

メッセージ キューのパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • トランザクション キューと高速なディスク入出力チャネルを使用します。受信用のトランザクション キューには、リモート キューではなく、BizTalk Server 上のローカル キューを使用する必要があります。プライベート キューなら Microsoft® Active Directory™ を照会する必要はありませんが、 パブリック キューは Active Directory を照会する必要があります。したがって、プライベート メッセージ キューでデータの読み取りと書き込みを行うとパフォーマンスが向上します。非トランザクション プライベート キューを使用すると、パフォーマンスがさらに向上します。ただし、非トランザクション キューは、トランザクション キューほど信頼性が高くありません。

    注

    • メッセージ キューを使用するために必要なハードウェア環境については、Windows 2000 Server ヘルプの「メッセージ キュー サーバーのハードウェアを選択する」を参照してください。
  • メッセージ キューの最大サイズは 4 MB です。ドキュメントのサイズが 4 MB を超える場合は、メッセージ キュー トランスポート サービスを使用できません。オーケストレーションのデータベースでは、ドキュメントのサイズは 2 MB までという制限があります。

  • ジャーナルを使用すると、メッセージ キューによるデータベースへの負担が大きくなります。メッセージ キュー トランスポート サービスを設定する場合は、データベースを最適化する際の標準的な手順に従って、データベースを最適化しておいてください。

  • スループットを最大限まで高めるには、データとログを分離し、複数のディスクとコントローラを使用します。


BizTalk Server の水平方向拡張

BizTalk Server 2002 の実装では、サービスの最適化に垂直方向と水平方向 (スケール アウト) の両方の拡張を利用します。垂直方向の拡張では必要なサーバー数を最低限に抑えることができますが、水平方向の拡張には次のような利点があります。

  • パフォーマンスの向上 : 単一のサーバーによって得られるものを超えるパフォーマンスを、コスト効率よく得ることができます。

  • サーバーのフォールト トレランス : グループ内の複数のサーバーが作業負荷を共有することで、あるサーバーに障害が発生したとき、グループ内のほかのサーバーがその負荷を受け持つことができます。

  • さまざまなコンポーネントの分離と最適化 : BizTalk サービス、データベース、およびトランスポート サービスのパフォーマンスが向上します。

ハードウェアを水平方向に拡張すると、垂直方向に拡張する場合と比べてコストを節約できます。ただし、サイトの管理が複雑になるため、最初は垂直方向拡張から始めてください。

ここには次のトピックが含まれます。

  • BizTalk メッセージ サービスのスケール アウト

  • データベースのスケール アウト

  • トランスポート サービスのスケール アウト

関連項目

BizTalk Server の拡張


BizTalk メッセージ サービスのスケール アウト

BizTalk メッセージ サービスを水平方向に拡張するには、サーバー グループを使用します。サーバー グループとは、集中的に管理、構成、および監視されるサーバーの集合です。サーバー グループの追加と構成の詳細については、「グループとサーバー」を参照してください。

同じサーバー グループのメンバであるサーバーは、次のものを共有しています。

  • BizTalk Server ステータス エンジンの利用状況を監視する、共有キュー データベース

  • ドキュメントの利用状況をログに記録し、レポートを生成する追跡データベース

  • 構成情報が格納される BizTalk メッセージ管理データベース

  • 受信機能

  • トランスポート コンポーネントおよびアプリケーション統合コンポーネント (AIC)、データ変換、データ暗号化、署名など、実行時にサーバーが必要とするすべてのコンポーネント

BizTalk Server グループは、受信ドキュメントの受信および Distributed Component Object Model (DCOM) を使用したドキュメント送信における負荷分散メカニズムは提供しません。ただし、HTTP 受信機能には、ネットワーク負荷分散やコンポーネント負荷分散を使用して、サーバー間の作業負荷を分散することができます。BizTalk Server がサポートするのは、複数のサーバーによる分担処理です。ドキュメントが共有キュー データベースに送信されると、グループ内のどのサーバーでもそのドキュメントの処理、シリアライズ、および送信を行うことができます。この機能によって、グループ内のあるサーバーがドキュメントを処理し、それを別のサーバーが送信することが可能になります。

組織では、次の目的のために複数のサーバー グループを使用できます。

  • 類似したトランスポート サービス (HTTP またはファイル) のグループ化

  • セキュリティの強化

  • 取引先の分類

複数のサーバー グループを使用すると、組織、チャネル、およびメッセージ ポートの構成の重複を防ぐこともできます。サーバー グループ間では、データベースが共有されます。組織、グループ、チャネル、およびメッセージ ポートの構成情報は、BizTalk メッセージ管理データベースに格納されます。したがって、複数の BizTalk Server グループで 1 つの BizTalk メッセージ管理データベースを共有できます。

注

  • 複数の BizTalk Server グループで 1 つの BizTalk メッセージ管理データベースを共有する場合、グループのメンバが共有する共有キュー、追跡、およびオーケストレーション データベースは、そのグループ専用のものが必要です。

BizTalk Server の水平方向拡張でお勧めする方法

BizTalk Server のパフォーマンスを最適化するには、トランスポート サービスと受信機能を分離する方法や、パーサーの優先順位を設定する方法があります。

トランスポート サービスと受信機能の分離

BizTalk Server グループ用のトランスポート サービスと受信機能を分離すると、パフォーマンスが向上します。得られるパフォーマンス レベルは、処理中のドキュメントの数とサイズ、およびデータ変換の複雑さによって異なります。BizTalk Server は、データの受信および処理用にそれぞれ別のスレッド プールを提供します。トランスポート サービスと受信機能を分離すると、サーバーが送信処理と受信処理を切り替える必要がなくなるため、コンテキストの切り替えが減少します。

既定では、共有キュー データベースからの作業項目の取り出し、処理、チャネルで構成されているトランスポート サービスを使用した送信といったの作業項目の処理は、すべてのサーバーで行うことができます。この処理ではコンテキスト切り替えが必要なため、受信機能やトランスポート サービスを使用しているときにも CPU のパフォーマンスが全般にわたって低下します。複数のサーバーを使用する場合は、少なくとも 1 台のサーバーが受信サービスを実行するようにしておくと、このようなパフォーマンス低下を防止できます。受信サービスを実行するサーバーを構成するには、BizTalk Server 管理コンソールで [作業項目の処理に参加する] チェック ボックスをオフにし、そのサーバーに新しい受信機能を作成します。

[作業項目の処理に参加する] 機能の詳細については、「グループ内のサーバーの構成」を参照してください。ファイル受信機能の設定の詳細については、「ファイル受信機能の追加」を参照してください。メッセージ キュー受信機能の設定については、「メッセージ キュー受信機能の追加」を参照してください。HTTP 受信機能の設定の詳細については、「HTTP 受信機能の追加」を参照してください。

注

  • メッセージ キューでは、トランザクションによる読み取りはローカル キューからのみ可能なため、ローカル キューからの読み取りが可能なサーバーは 1 台だけです。

次のいずれかに当てはまっている場合は、BizTalk Server によってドキュメントが受信されます。

  • BizTalk Server がインストールされているサーバーで、受信機能が構成されている。

  • BizTalk Server がインストールされているサーバーで、すべてのプロセスが Submit メソッドを呼び出すように構成されている。

パーサーの優先順位の設定

パーサーの優先順位を設定すると、BizTalk Server のパフォーマンスを最適化できます。BizTalk Server には、4 つのデータ パーサーがあります。

  • XML

  • EDIFACT

  • ANSI X12

  • フラット ファイル

BizTalk Server は、ドキュメントを受信すると前の一覧にある順序でドキュメントを解析します。利用頻度の最も高いパーサーをリストの先頭に移動すると、BizTalk Server のパフォーマンスが向上します。パーサー順序の構成の詳細については、「サーバー グループのパーサー順序の構成」を参照してください。

ここには次のトピックが含まれます。

  • コンポーネント負荷分散


コンポーネント負荷分散

コンポーネント負荷分散 (CLB) は Microsoft Application Center 2000 の機能です。CLB を使用するには、Microsoft BizTalk Server 2002 をインストールしたサーバーに Application Center 2000 をインストールする必要があります。組織は、CLB を使用することにより COM+ サービス マネージャで BizTalk.Interchange.1 コンポーネントの負荷を分散できるようになります。CLB は COM コンポーネント用の負荷分散メカニズムです。BizTalk Server 環境で CLB を利用すると、HTTP トランスポートで Submit メソッドを使用することにより、単一のサーバーではなく数台のサーバーで構成されたクラスタを呼び出せるようになります。送信側のアプリケーションでは、Submit メソッドを使用したクラスタの呼び出しは、ノードへの送信として認識されます。

たとえば、カスタム アプリケーションを使用している場合に送信を 1 回行うと、クラスタ内のサーバーのいずれかに送信されます。CLB を使用しない場合は、3 台のサーバーのいずれか 1 台に送信されるように、カスタム アプリケーションを構成する必要があります。後者の場合は、カスタム アプリケーションを構成したサーバーが送信に失敗したとき、BizTalk Server グループの別のサーバーに送信するようにカスタム アプリケーションを再構成する必要があります。

重要

  • CLB は、XLANG スケジュールをアクティブ化するためだけに使用することができます。すべての XLANG スケジュールは、起動したサーバーで終了する必要があります。


データベースのスケール アウト

データベースを水平方向に拡張するには、各データベースを専用のサーバーにインストールします。大量のトランザクションが発生する環境では、データベースを専用サーバーにインストールすると、サーバーの CPU、ディスク入出力、およびメモリ リソースを適切なデータベースに割り当てることができます。

データベースの水平方向拡張の最適化でお勧めする方法

BizTalk Server のデータベースのパフォーマンスを最適化するには、次のような方法があります。

  • Pentium III プロセッサではなく、Xeon プロセッサを使用します。

  • データベースは、それぞれ高速の CPU を搭載した単独のサーバーにインストールします。BizTalk Server 2002 をインストールしたサーバーには、データベースをインストールしないようにします。

  • システム構成内の各サーバーにステータス保存データベースを 1 つインストールします。

  • スループット 100 Mbps (メガビット/秒) 以上の複数のネットワーク カード使用し、100 Mbps (メガバイト/秒) スイッチのポートに接続してネットワークの入出力スループットを向上させます。

  • 処理するドキュメント数が少ない組織では、データベースのアップグレードは容易です。処理量が増えてきた場合は、共有キュー データベース、追跡データベース、およびオーケストレーション データベースを専用のサーバーに移動します。

  • 追跡データベースを配置するサーバーには、BizTalk Server とこのデータベースの間で交換される大量の非圧縮データに対処するために、高速なネットワーク ハードウェアをインストールしてください。

  • これらのデータベースをスケール アウトすると、BizTalk メッセージ管理データベースの移動が難しくなります。メッセージ管理データベースには、BizTalk Server のすべての基本的な構成情報や受信機能用のサーバーが使用する情報、およびほかのデータベースの場所などが格納されています。BizTalk メッセージ管理データベースを移動するには、すべての情報を新しいデータベースに複製するカスタム プロセスの作成が必要になり、さらに新しい場所を指すように各サーバーの設定を手動で変更することが必要になります。このため、BizTalk メッセージ管理データベースを格納するサーバーには、ドキュメント処理量の増加に備えて、ディスク領域、および構成をキャッシュするためのメモリを十分に用意しておいてください。

関連項目

BizTalk Server の拡張


トランスポート サービスのスケール アウト

BizTalk Server は、4 種類のトランスポート サービスをサポートしています。これらのトランスポート サービスは、水平方向に拡張することが可能です。

  • HTTP

  • ファイル

  • SMTP

  • メッセージ キュー

ここには次のトピックが含まれます。

  • HTTP/HTTPSのスケールアウト

  • ファイルのスケール アウト

  • SMTP のスケール アウト

  • メッセージ キューのスケール アウト


HTTP/HTTPS のスケール アウト

受信

HTTP 受信機能を水平方向に拡張するには、Web クラスタを使用します。たとえば、取引先がドキュメントを 1 つのアドレスに送信するだけで、その送信内容がクラスタ内の任意のサーバーにルーティングされます。Web クラスタは、Microsoft Windows 2000 Advanced Server が備えているネットワーク負荷分散機能です。ネットワーク負荷分散の構成の詳細については、Windows 2000 Advanced Server ヘルプを参照してください。

BizTalk Server のパフォーマンスを向上するために、Web クラスタを構成して HTTP 受信機能を構成したサーバー間で入力ドキュメントを分散することができます。次に、HTTP 受信機能が送信メソッドを呼び出し、受信ドキュメントをファイル ディレクトリやメッセージ キューに格納します。

送信

送信 HTTP/HTTPS トランスポート サービスの水平方向拡張は、作業項目の処理に参加するように構成されたグループ内で、複数のサーバーを使用することによって実現できます。HTTP/HTTPS 送信機能は、作業項目の処理に参加するように構成されたグループ内の全サーバーで使用されるため、ドキュメントを処理する BizTalk Server から送信機能を分離することはできません。

HTTP/HTTPS の水平方向拡張の最適化でお勧めする方法

HTTP/HTTPS のパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • BizTalk Server の負荷分散グループを作成します。これにより、水平方向拡張の冗長性が得られるため、受信 HTTP/HTTPS トランスポートのパフォーマンスがさらに向上します。ネットワーク負荷分散を使用して Web クラスタを作成する方法の詳細については、Windows 2000 Advanced Server ヘルプを参照してください。

  • 取引先と協力して、HTTP/HTTPS サービスを利用した送信で ASP ページを使用するときの最良の方法について検討してください。ASP ページとインターネット インフォメーション サービスを最適化する方法については、インターネット インフォメーション サービスのヘルプ (localhost/iisHelp) で、[Active Server Pages ガイド] をクリックしてください。


ファイルのスケール アウト

受信

BizTalk Server をファイル受信機能専用にすると、ディスク入出力のパフォーマンスに与える影響を抑えることができますが、ファイルを受信するときのネットワークの待ち時間がパフォーマンスに影響するようになります。これは、高速なネットワーク カードを使ってネットワーク共有にファイルを格納することで解決できます。また、1 台のサーバーのローカル ディレクトリに書き込み、すべてのサーバーにそのファイルを呼び出すファイル受信機能を持たせることでも解決できます。

送信

水平方向拡張は、複数のサーバーから構成されるグループでドキュメントを処理し、それらのドキュメントをファイル トランスポート サービスに送信することで実現できます。パフォーマンスは、BizTalk Server を受信機能として使用するかどうか、および BizTalk Server が独立したサーバーとして構成されているかどうかで異なります。

ファイル受信機能およびファイル トランスポート サービスの水平方向拡張の最適化でお勧めする方法

ファイル受信機能とファイル トランスポート サービスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • 高速なネットワーク カードを使ってネットワーク共有にファイルを格納するか、または、1 台のサーバーのローカル ディレクトリに書き込んで、すべてのサーバーへそのファイルを呼び出すファイル受信機能を持たせます。

  • 受信機能の構成を同じファイル受信機能をポーリングするグループ内の全サーバーで実行されるようして、グループ内のすべてのサーバーがドキュメントを取得して処理するようにします。既定では、ファイル受信サービスはグループ内の 1 台のサーバーで実行されるように構成されます。このため、グループに 5 台のサーバーがあり、ファイル受信機能が 1 台のサーバーで実行されるように構成した場合は、ファイル受信機能が \\receiveserver\receivelocation でポーリングされると、5 台のうち 1 台のサーバーでのみファイルが取得され、処理が行われます。この場合は、ドキュメントを処理するサーバーがグループ全体で 1 台しかないことになります。残りの 4 台のサーバーは、受信機能からファイルを取得して解析することができません。詳細については、「ファイル受信機能の追加」を参照の上、説明の手順に従って、グループ内の各サーバーにファイル受信機能を作成してください。また、その際には、すべての受信機能が同じポーリングの場所を使用するようにしてください。

  • より多くのサーバーが作業項目の処理に参加できるようにします。ファイルの送信と受信はそれぞれ別の処理であるため、作業項目の処理に参加するように構成されたグループでは、すべてのサーバーがファイルを送信します。ファイル転送サービスの水平方向の拡張性は、作業項目の処理に参加するように構成されたグループ内の、サーバーの数のみに基づきます。


SMTP のスケール アウト

受信

SMTP を利用して BizTalk Server からドキュメントを受信することはできますが、BizTalk Server にファイルを送信することはできません。BizTalk Server にドキュメントを送信するには、ファイル受信機能やメッセージ キュー受信機能がドキュメントを処理できるようにするために SMTP ソリューションで Submit メソッドを使用する必要があります。このようなイベント ベースのメカニズムを提供する機能を備えた SMTP ホスト (Microsoft Exchange Server やサード パーティ製のメッセージ サーバー) は、一般に、大量のハードウェア リソースを消費します。このため、サーバーにこの機能を追加すると、サーバーのドキュメント処理能力が低下します。詳細については、SMTP ソリューションのマニュアルを参照してください。

送信

SMTP を利用したドキュメントの送信には、イベント ベースのメカニズムを持たない軽量の SMTP トランスポート サービスを使用できます。ドキュメントを送信する SMTP トランスポート ホストは、単なるリレー エージェントとして機能します。送信 SMTP ホストは、サーバー レベルではなく、グループ レベルで構成されます。したがって、グループ内の 1 台のサーバーに SMTP トランスポートが存在していると、SMTP トランスポート サービスを実装しているサーバーは、そのトランスポートを使用して送信ドキュメントを送信します。グループ内にあるほかのサーバーもすべて、SMTP 送信では SMTP トランスポートが存在するサーバーを利用します。

SMTP の水平方向拡張の最適化でお勧めする方法

SMTP を最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • SMTP ホストは、送受信機能用の BizTalk サービスを実行するサーバーとは別のサーバーで実行するように構成します。組織のネットワークには多くの場合 SMTP ホストが置かれているので、それを送受信機能用に利用することができます。


メッセージ キューのスケール アウト

受信

メッセージ キューの受信機能を BizTalk Server と同じサーバーで実行するか、または別のサーバーにインストールするかを決定する必要があります。トランザクション キューを使用している場合は、同じサーバー上でメッセージ キュー受信機能を実行する必要があります。トランザクション キューを使用していない場合は、メッセージ キュー受信機能を別のサーバーで実行することができます。また、ローカルの BizTalk Server によるディスク入出力と、複数のサーバーの通信によるネットワーク待ち時間のうち、どちらによるパフォーマンスへの影響を受けるかを決める必要があります。後者の場合は、ディスクに対する入出力は行われますが、ローカル サーバーではなくリモート サーバーで行われるだけです。メッセージ キュー サービスのハードウェア環境については、Windows 2000 Server ヘルプの「メッセージ キュー サーバーのハードウェアを選択する」を参照してください。

送信

メッセージ キューを使用してドキュメントを送信する場合も、メッセージ キューを使用してドキュメントを受信する場合と同様のセキュリティおよびパフォーマンス上の問題が発生します。ただし、リモート キューへのトランザクション書き込みは可能です。

メッセージ キューの水平方向拡張の最適化でお勧めする方法

メッセージ キューのパフォーマンスを最適化し、それによって BizTalk Server のパフォーマンスを向上させるには、次のような方法があります。

  • メッセージ キューはディスク消費の多い処理です。メッセージ キューを最適化するには、トランザクション化されていないキューを使用します。


サーバーおよびアプリケーションの管理

Microsoft® BizTalk™ Server 2002 の管理機能を使用すると、インストールされている BizTalk Server 2002 を効率的かつ効果的に管理できます。BizTalk Server 2002 の管理には、次の 4 つの領域があります。

  • サーバー管理

  • アプリケーション管理

  • プログラムによる管理

  • データベース管理

ここではサーバー管理とアプリケーション管理について説明します。プログラムによる管理およびデータベース管理の詳細については、「BizTalk Server の管理モデル」を参照してください。

BizTalk Server 管理コンソールは集中的なユーザー インターフェイス (UI) を提供します。これを使用して、次のことを行えます。

  • BizTalk Serverがインストールされたサーバーを、サーバー グループに追加し、管理する。

  • 共有キュー データベースと追跡データベースの場所などのサーバー グループのプロパティを構成する。

  • 受信機能を構成および管理する。

  • キューを表示し、管理する。

アプリケーション管理には、XLANG スケジュールを提供する COM+ アプリケーション、既定の XLANG スケジューラ アプリケーション、およびオーケストレーション データベースの構成と管理が含まれます。

ここには次のトピックが含まれます。

  • BizTalk Server 管理の詳細については、「BizTalk Server 管理コンソールについて」を参照してください。

  • 特定の作業を実行する理由については、「BizTalk Server の管理に関する作業を行う目的」を参照してください。

  • 作業を実行する手順の詳細については、「BizTalk Server の管理に関する作業を行う方法」を参照してください。

  • 問題を解決するためのヒントについては、「BizTalk Server 管理のトラブルシューティング」を参照してください。

関連項目

BizTalk Server の管理モデル

BizTalk オーケストレーション サービス


BizTalk サーバーの管理について

ここでは、BizTalk Server 管理コンソールを理解するうえで不可欠な概念について説明します。サーバー グループの作成、受信機能の定義、および Microsoft BizTalk Server 2002 でのドキュメントの利用状況を監視、表示、およびログに記録するためのデータベースの作成などの管理作業について説明します。

ここには次のトピックが含まれます。

  • グループとサーバー

  • BizTalk Server 管理コンソールの環境

  • 管理キャッシュ

  • BizTalk Server データベースの管理

  • サーバー エラーの処理

  • 受信機能

  • キューの使用

  • 管理者特権


グループとサーバー

多数のドキュメントの処理をサポートするデータ交換環境では、スケールアウト ソリューションの構築には複数のサーバーおよびデータベースが必要になることがあります。同時に、企業はソリューションを管理しやすくすることによって所有のコストを減らすために、ドキュメント交換を集中化し、管理するための方法が必要です。

Microsoft BizTalk Server 2002 は、サーバーをグループに分け、BizTalk Server 管理コンソールを使用してこれらのサーバー グループを管理および構成することによって、スケールアウトとドキュメントの集中化を実現します。

ここには次のトピックが含まれます。

  • BizTalk サーバー グループ

  • グループとサーバーの関係

  • グループ ステータス

  • BizTalk サーバー


BizTalk サーバー グループ

サーバー グループは BizTalk Server 管理コンソールの主要な構成要素です。サーバー グループとは、集中的に管理、構成、および監視されるサーバーの集合です。

BizTalk Server グループ内のサーバーは、次のものを共有しています。

  • 正常に処理されるまですべてのドキュメントを保存する共有キュー データベース

  • ドキュメントとインターチェンジの利用状況をログに記録し、レポートを作成するために使用する追跡データベース

  • 受信機能

  • トランスポート コンポーネントやアプリケーション統合コンポーネント (AIC) など、サーバーがドキュメントとインターチェンジの処理時に要求するすべてのコンポーネント

中央 BizTalk メッセージ管理データベースは複数のグループおよびサーバーを管理します。1 つの BizTalk Server の中で定義されているすべてのグループおよびサーバーが同じ構成情報を共有します。この構成情報は、サーバーのドキュメント処理定義を指定します。

管理コンソールから各サーバーとグループをリモートで管理できるように、各サーバー環境に対して同じ BizTalk メッセージ管理データベースを指定しなければなりません。また、スケーラビリティとより良いパフォーマンスのために複数のサーバー グループを設定する場合は、中央 BizTalk メッセージ管理データベースを 1 つだけ使用しなければなりません。複数のメッセージ管理データベースを使用すると、サーバーは同じ BizTalk メッセージ管理構成を共有することができません。

関連項目

サーバー グループの追加、削除、および構成

BizTalk サーバー

受信機能

グループとサーバーの関係

キューの使用


グループとサーバーの関係

BizTalk Server 2002 の各環境には、少なくとも 1 つのサーバー グループが必要です。グループとサーバーの関係を次に定義します。

  • 個々のサーバーは 1 つのサーバー グループにだけ属することができます。

  • グループ内のすべてのサーバーは、同じ共有キュー データベースを使用します。

  • グループ内のそれぞれの受信機能は、そのグループ内のどれかのサーバー上で実行しなければなりません。

  • グループ内のすべてのサーバーは、トランスポート コンポーネントやアプリケーション統合コンポーネント (AIC) などのコンポーネントを共有して、インターチェンジとドキュメントを処理します。

次の図は、BizTalk Server 2002のサーバ グループ間の関係を示しています。

サーバー 1 ～ 6 には BizTalk Server 2002 がインストールされています。サーバー A ～ D には Microsoft® SQL Server™ がインストールされていて、これらはデータベース管理専用になっています。サーバー A ～ D は追跡データベースまたは共有キュー データベースのいずれかの専用に使用されますが、BizTalk メッセージ管理データベースは、一般的には小さく、プロセッサにあまり負担をかけないため、いずれかのサーバーに格納することができます。最大のスループットを得られるように、共有キューおよび追跡データベースをそれぞれの機能の専用の 2 台の別々のサーバーに置くことを強くお勧めします。

重要

  • グループ内のすべてのサーバーには、同じバージョンおよび言語の BizTalk Server がインストールされていなければなりません。グループ内のサーバーで異なるバージョンのBizTalk Server (BizTalk Server 2000、BizTalk Server 2000 Service Pack 1a、BizTalk Server 2002 Enterprise Edition、または異なる言語バージョンの BizTalk Server など) がインストールされていると、データベースは正常に機能しません。

  • 新しいサーバーを BizTalk Server グループに追加するとき、この新しいサーバーには同じバージョンの BizTalk Server がインストールされていなければなりません。

関連項目

BizTalk Server データベースの管理


グループ ステータス

BizTalk Server 管理コンソールは、サーバー グループを列挙し、各グループが追跡データベースと共有キュー データベースの両方またはどちらか一方に接続できるかどうかを指定します。[Microsoft BizTalk Server 2002] をクリックすると、詳細ペインにグループ ステータスが表示されます。グループ ステータスは次のいずれかになります。

  • [接続済み] : グループが追跡データベースと共有キュー データベースに接続されていることを示します。

  • [追跡への接続に失敗しました] : グループが追跡データベースに接続されていないことを示します。

  • [共有キューへの接続に失敗しました] : グループが共有キュー データベースに接続されていないことを示します。

  • [追跡と共有キューへの接続に失敗しました] : グループが追跡データベースと共有キュー データベースに接続されていないことを示します。


BizTalk サーバー

BizTalk サーバーは、BizTalk Server がインストールされ、構成されているコンピュータです。サーバー グループ内の各サーバーは、データの変換、暗号化、デジタル署名、およびドキュメント トラッキングなどの適切な BizTalk メッセージ サービス機能を提供して、BizTalk サーバー グループの外部にあるほかのサーバーとアプリケーション間でのドキュメント交換を管理します。各サーバーは、ドキュメントを変換、シリアライズ、署名、暗号化、解読、およびトランスポートするために適切なコンポーネント オブジェクト モデル (COM) を呼び出して、共有キュー データベースに対して受信ドキュメントをキューに入れたり、送信ドキュメントをキューから取り出したりします。

必要に応じて、グループ内のすべてのサーバーをメッセージの受信および送受信の両方ができるように構成することができます。これにより、グループ内のサーバーがすべて同じ機能を実行しますから、サーバーを簡単に追加および削除することができます。また、最大のパフォーマンスを得るために、グループ内の一部のサーバーをドキュメント受信専用に構成し、他のサーバーをドキュメントの処理の専用に構成することもできます。

ここには次のトピックが含まれます。

  • サーバーのプロパティについて

  • サーバー ステータス

関連項目

BizTalk サーバー グループ

グループとサーバーの関係


サーバーのプロパティについて

グループ内のサーバーを構成する場合、スループットとサーバー パフォーマンスを最大化できるよう調整する必要があります。サーバーのプロパティの構成に影響を与える要素には、業務上のニーズ、サーバーの容量、ネットワーク帯域幅などがあります。インストール環境に最も適する構成を決定するために、運用環境をシミュレートするテスト設定でさまざまな構成を試すことを強くお勧めします。BizTalk Server 管理コンソール で次のサーバー プロパティを設定および変更することができます。

使用可能な受信機能スレッドの最大数

受信機能スレッドの最大数はプロセッサごとに設定します。このオプションの範囲は 1 から 128 です。この数値を調整して、サーバーで実行する受信機能のパフォーマンスを最適化します。ほとんどの場合、受信機能スレッドの数を増加させると、サーバーの受信機能のスループットが向上します。

作業項目の処理に参加する

[作業項目の処理に参加する] チェック ボックスがオンになっていると、サーバーは作業キュー内のドキュメントを処理します。このチェック ボックスをオフにすると、サーバーは作業キュー内のドキュメントを処理しません。

サーバーを作業項目処理に参加しないように構成する主な理由は、スループットの最適化のための全体的な戦略の中でそのサーバーをメッセージの受信の専用に使用することです。たとえば、BizTalk サーバー グループに 3 台のサーバーがあり、2 台が処理サーバーで 1 台が受信サーバーであるとします。このようにサーバー タスクを分担することによって、サーバー上の処理コンテクストや作業のタイプの数が最小限になるため、スループットが最適化されます。ベンチマーク テストによってこれがスループットの最適化のための効果的な方法であることが示されています。

プロセッサごとの使用可能な作業スレッドの最大数

作業スレッドの最大数はプロセッサごとに設定します。このオプションの範囲は 1 から 128 です。小さい値を設定すると、トラフィックの多い状況では、BizTalk Server に障害が発生することがあり、全体としてのスループットが低下します。この値が大きすぎると、未使用のスレッドのオーバーヘッドのために、最適のスループットが得られません。この設定を変えてスループットを測定することによって、ユーザーの BizTalk Server 環境に最適の設定を判断することが重要です。

[プロセッサごとの使用可能な作業スレッドの最大数] と [BizTalk Server スケジューラ呼び出しの間隔] の設定は、Microsoft SQL Server データベースへのトラフィック量に影響を与える要素です。[プロセッサごとの使用可能な作業スレッドの最大数] を小さい値に設定し、[BizTalk Server スケジューラ呼び出しの間隔] を大きい値に設定することによって、SQL Server データベースへのトラフィックを制限することができます。同様に、作業スレッドの最大数を大きくして、スケジューラ呼び出しの間隔の設定を小さくすることによって、データベースへのトラフィックを増加させることができます。

注

  • このサーバーで作業項目を処理しない場合は、[作業項目の処理に参加する] チェック ボックスをオフにします。[プロセッサごとの使用可能な作業スレッドの最大数] オプションを 0 に設定しないでください。

BizTalk Server スケジューラ呼び出しの間隔 (ミリ秒)

[BizTalk Server スケジューラ呼び出しの間隔] の範囲は、1 から 4,294,967,295 です。作業キュー内の利用可能な項目をポーリングするスレッドが存在します。[BizTalk Server スケジューラ呼び出しの間隔] は、そのスレッドが作業キューをポーリングする頻度を制御します。大量のデータを受信しない場合は、この値を大きくします。大量のデータを受信する場合は、この値を小さくする必要が生じることがあります。

関連項目

グループ内のサーバーの構成


サーバー ステータス

BizTalk Server 管理コンソールは、サーバー グループ内のサーバーを列挙し、サーバーの一覧を返します。BizTalk Server 管理コンソールは、詳細ペインに次のサーバー ステータスを返します。

  • [実行中] : サーバーが実行中であることを示します。

  • [アクセスは拒否されました] : サーバーの Microsoft® Windows® 2000 管理者特権がないことを示します。

  • [エラー] : サーバー グループに登録されたサーバーで BizTalk Server 2002 が削除されていることを示します。

  • [停止] : 管理者がサーバーを停止したことを示します。

  • [不明] : サーバー グループに登録されたサーバーが不明な理由で利用できないことを示します。この場合、サーバーとの接続が失われている可能性があります。

関連項目

管理者特権


BizTalk Server 管理コンソールの環境

ここには次のトピックが含まれます。

  • BizTalk Server 管理コンソールのユーザー インターフェイス

  • BizTalk Server 管理コンソールのショートカット キー

  • BizTalk Server クライアント インストールの管理機能


BizTalk Server 管理コンソールのユーザー インターフェイス

BizTalk Server 管理コンソール (単に管理コンソールともいいます) は、システム管理者が管理できる Microsoft BizTalk Server 2002 コンポーネントを視覚的に表現する、 Microsoft 管理コンソール (MMC) スナップインです。管理コンソールの左側はコンソール ツリーといい、サーバー グループなどのさまざまな項目を表すフォルダとサブフォルダから構成されています。管理コンソールの右側は詳細ペインといい、コンソール ツリーで選択した項目に関する情報が表示されます。

画面上では、BizTalk Server は管理コンソールの左側にコンソール ルートの下位項目として表示されます。BizTalk Server で構成される各サーバー グループは別々のサブフォルダに表示され、そのグループのキューおよび受信機能と、グループ内のサーバーの名前から構成されます。項目を右クリックすると、その項目を構成したり、新しい項目を作成することができます。

関連項目

BizTalk Server 管理コンソールを開く


BizTalk Server 管理コンソールのショートカット キー

BizTalk Server 管理コンソールのタスクは、ショートカット キーを使用しても実行できます。次の表は、Microsoft 管理コンソール (MMC) のショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。Windows 2000 Professional では、ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
F5 | BizTalk Server 管理コンソールを最新の情報に更新します。 このショートカット キーは、コンソール ツリーで強調表示されている現在の項目を更新します。
Alt + F4 | BizTalk Server 管理コンソールを閉じます。
Alt + マイナス記号 (-) | アクティブなコンソール ウィンドウのウィンドウ メニューを表示します。
Shift + F10 | 選択した項目の [操作] メニューを表示します。
Alt + A | 選択した項目の [操作] メニューを表示します。
Alt + V | [表示] メニューを表示します。
F1 | 選択した項目のオンライン ヘルプを表示します。
Alt + Enter | 選択した項目のプロパティがあれば、その [プロパティ] ダイアログ ボックスを表示します。

関連項目

BizTalk Server 管理コンソールを開く


BizTalk Server クライアント インストールの管理機能

クライアント インストール機能によって、BizTalk サーバーでないクライアント コンピュータにMicrosoft BizTalk Server 2002 Microsoft Management Console (MMC) スナップイン (管理コンソール) をインストールすることができます。クライアント コンピュータに BizTalk Server 2002 のクライアント インストールを行うと、サーバー インストールのコンピュータで利用できる機能とは異なる一部の管理コンソール機能が利用できます。

クライアント コンピュータにインストールすると、管理コンソールによって、同一のコンピュータおよびユーザー インターフェイスから 1 つまたは複数の BizTalk Server 構成データベースをリモートで管理することができます。

クライアントに管理コンソールを最初にインストールしたとき、クライアントによって管理される BizTalk メッセージ管理データベースはまだ決まっていません。したがって、インストール後に初めて管理コンソールを使用するとき、[BizTalk Server 2002] ノードを選択すると、[管理データベースの選択] ダイアログ ボックスが表示されます。このダイアログ ボックスで、SQL データベース名とそのデータベースが格納されている Microsoft SQL Server を指定して、リモートで管理される管理データベースを選択します。管理されるデータベースはいつでも変更することができます。詳細については、「クライアント インストールで管理される BizTalk メッセージ管理データベースの変更」を参照してください。

管理コンソールの [ツールのみ] のインストールと、完全な BizTalk Server 環境へのインストールでは次のような違いがあります。

  • ツールのみのインストールを行ったコンソール ツリーで [BizTalk Server 2002] ノードを選択したとき、[操作] メニューに [プロパティ] オプションは含まれていません。クライアント インストールでは、異なる BizTalk メッセージ管理データベースと異なる BizTalk サーバー グループを表示し、管理することができますが、元のデータベースに属しているすべての BizTalk サーバーが参照している BizTalk メッセージ管理データベースを変更することはできません。

  • 選択された BizTalk Server グループの [プロパティ] ダイアログ ボックスに、[パーサー] タブは表示されません。

  • クライアント インストールの管理コンソールから既存の受信機能を管理できますが、詳細プロパティの変更と新しい受信機能の作成はできません。

注

  • カスタム インストールでも、管理コンソールを選択することができます。クライアント インストールで利用できる機能は、カスタム インストールでも利用することができます。

  • カスタム インストールですべての機能を選択すると (これによってサーバー インストールになります)、管理コンソールの機能はサーバー インストールの場合と同じになります。


管理キャッシュ

Microsoft BizTalk Server 2002を起動すると、サーバー グループ、サーバー グループのプロパティ、受信機能、共有キュー データベースおよび追跡データベースへの接続など、BizTalk Server 管理コンソールのすべての項目が管理キャッシュに格納されます。既定では、キャッシュ内のすべての項目は、サーバー データベース接続とサーバーのプロパティを除いて、50 秒ごとに更新されます。つまり、SMTP ホストや信頼できるメッセージの返信先 URL などのサーバー グループの一般プロパティを変更すると、その変更は 50 秒で反映されます。

ただし、[プロセッサごとの使用可能な作業スレッドの最大数] などのサーバーのプロパティを変更した場合は、構成を変更したサーバーを停止してから再起動して、その変更をキャッシュに格納する必要があります。また、BizTalk メッセージ管理データベース、追跡データベース、または共有キュー データベースへの接続を変更した場合は、そのグループ内のサーバーを停止してから再起動して、BizTalk Server インターチェンジ アプリケーションをシャットダウンする必要があります。

関連項目

サーバー グループの全般プロパティの構成

BizTalk Server インターチェンジ アプリケーションのシャットダウン

グループ内のサーバーの起動

グループ内のサーバーの停止


BizTalk Server データベースの管理

BizTalk メッセージ サービスには、次の 3 つのデータベースが関連付けられています。

  • BizTalk メッセージ管理データベース

  • 追跡データベース

  • 共有キュー データベース

BizTalk オーケストレーション サービスには、次のデータベースが関連付けられています。

  • オーケストレーション データベース

BizTalk メッセージ管理データベースは、グループとサーバーの設定や受信機能を含むすべてのサーバー構成情報を格納します。これらの管理オブジェクトの構成は、BizTalk Server 管理コンソールにより、または BizTalk Server Windows Management Instrumentation (WMI) プロバイダを使用してプログラムにより処理することができます。BizTalk メッセージ管理データベースは、管理構成情報の他に、チャネル、メッセージ ポート、およびその他のメッセージ オブジェクトのすべてのメッセージ構成情報も格納します。オブジェクトの構成は BizTalk メッセージ マネージャを使用して処理されるか、または BizTalk メッセージ構成オブジェクト モデルを使用してプログラムにより処理されます。チャネル、メッセージ ポートなどの構成の詳細については、「BizTalk メッセージ マネージャの使用」または「メッセージ サービスの参照」を参照してください。

追跡データベースは、BizTalk メッセージ サービスによって処理されるすべてのインターチェンジ、ドキュメント、および受信確認のログを保持します。追跡データベースの詳細については、「追跡データベース」を参照してください。追跡設定を構成するには、「サーバー グループの追跡のプロパティの構成」を参照してください。特定のフィールドまたはドキュメント インスタンス データを追跡するには、「チャネルのプロパティの設定」を参照してください。

共有キュー データベースは、処理中または処理を待機している間にドキュメントを保持します。ドキュメントは処理が終わると削除されます。共有キュー データベースの詳細については、「共有キュー データベース」を参照してください。

BizTalk オーケストレーション データベースには、XLANG スケジュールの構造、アクティブな XLANG スケジュール インスタンス、および XLANG スケジュール インスタンスが実行中に送受信されるメッセージが格納されます。詳細については、「BizTalk オーケストレーション サービス」を参照してください。

ここには次のトピックが含まれます。

  • BizTalk メッセージ管理データベースの管理

  • BizTalk サーバー グループ データベースの管理


BizTalk メッセージ管理データベースの管理

ほとんどの業務用の用途では、1 つの中央 BizTalk メッセージ管理データベースを使用して、複数のサーバー グループ、サーバー、チャネル、メッセージ ポートなどを構成します。このガイドラインには例外があります。たとえばサードパーティのアプリケーション サービス プロバイダでは、顧客の固有の業務上のニーズに基づいて、顧客ごとに BizTalk メッセージ管理データベースが必要になることがあります。ただし、その他のほとんどの場合には、すべての BizTalk Server グループに対して 1 つの中央 BizTalk メッセージ管理データベースで十分に対応できます。

場合によっては、中央 BizTalk メッセージ管理データベースを変更する必要が生じることがあります。たとえば、BizTalk メッセージ管理データベースが格納されているサーバーのメンテナンスが必要な場合です。この場合、すべてのサーバー グループがレプリケートされた BizTalk メッセージ管理データベースを参照するようにして、BizTalk Server が停止しないようにする必要があります。また、BizTalk メッセージ管理データベース間でサーバーを移動する必要が生じることもあります。

たとえば、A、B、および C という 3 社の顧客を持つサードパーティ ベンダーのケースを検討してみましょう。顧客 A の業務が減少し、顧客 B と顧客 C の業務が増大するとき、顧客 A の BizTalk メッセージ管理データベースと関連付けられているサーバーを顧客 B と顧客 C と関連付けられているデータベースに移すことができます。

ここには次のトピックが含まれます。

  • BizTalk メッセージ管理データベースの変更

  • BizTalk メッセージ管理データベースからのサーバーの削除

  • BizTalk メッセージ管理データベース間でのサーバーの移動

  • BizTalk メッセージ管理データベース間でのリモート サーバーの移動

  • サービス アカウント パスワードの変更


BizTalk メッセージ管理データベースの変更

BizTalk メッセージ管理データベースを構成するには、2 つの方法があります。

  • インストール中に利用できる構成オプションを使用する。

  • BizTalk Server 管理コンソールを使用して、Microsoft BizTalk Server 2002 ノードでサーバーを変更する。

単一のサーバーからすべての BizTalk サーバーを集中的に管理するには、インストール時に中央 BizTalk メッセージ管理データベースを参照するようにすべてのサーバーを構成します。このように構成すると、任意の BizTalk サーバーで BizTalk Server 管理コンソールを開くたびに、Microsoft BizTalk Server 2002 ノードに一覧表示されているサーバーが同じ BizTalk メッセージ管理データベースを参照するため、集中的に管理することができます。サーバー グループが中央 BizTalk メッセージ管理データベースを参照していれば、通常、別の BizTalk メッセージ管理データベースを変更する必要はありません。

この例外として、メンテナンスのためにそのデータベースをオフラインにする場合があります。この場合、BizTalk Server 管理コンソールを使用して、Microsoft BizTalk Server 2002 ノードのすべてのサーバー グループを中央データベースのレプリケーションを参照するようにします。ほかのサーバー グループと関連付けられている別の中央 BizTalk メッセージ管理データベースを一時的に参照するようにしてはいけません。そのようにすると、元の BizTalk メッセージ管理データベースの構成に戻せなくなることがあります。

注

  • BizTalk メッセージ管理データベースを変更するには、BizTalk Server Administrators グループのメンバでなければなりません。

関連項目

BizTalk サーバー グループ

サーバーの BizTalk メッセージ管理データベースの変更

BizTalk メッセージ管理データベースの構成

BizTalk メッセージ管理データベース間でのサーバーの移動

セキュリティ ガイドライン


BizTalk メッセージ管理データベースからのサーバーの削除

BizTalk メッセージ管理データベースからすべての BizTalk サーバーを削除しても、そのデータベースの内容は失われません。同様に、システムに複数の BizTalk メッセージ管理データベースがあり、1 つの BizTalk メッセージ管理データベースからすべての BizTalk サーバーを削除しても、そのデータベースの内容は失われません。BizTalk Server 2002 データベース セットアップ ウィザードを実行し、[BizTalk メッセージ管理データベースを構成します] ページで既存のデータベースを選択することによって、BizTalk メッセージ管理データベースに新しい BizTalk サーバーを追加することができます。サーバーの BizTalk メッセージ管理データベースの追加または変更の詳細については、「サーバーの BizTalk メッセージ管理データベースの変更」を参照してください。

注

  • BizTalk メッセージ管理データベースからサーバーを削除するには、BizTalk Server Administrators グループのメンバでなければなりません。

関連項目

サーバーの BizTalk メッセージ管理データベースの変更

セキュリティ ガイドライン


BizTalk メッセージ管理データベース間でのサーバーの移動

BizTalk Server をある BizTalk メッセージ管理データベースから別のメッセージ管理データベースに一時的に移動する場合、ほかの BizTalk Server を少なくとも 1 つ、元のデータベース内のサーバー グループの 1 つに残す必要があります。これにより、その BizTalk Server を元のデータベースに簡単に復元することができます。BizTalk Server を残さないと、データベースに新しい BizTalk Server を追加するには、BizTalk Server データベース セットアップ ウィザードを実行して、[BizTalk メッセージ管理データベースを構成します] ページで既存のデータベースを選択する必要があります。サーバーの BizTalk メッセージ管理データベースの追加または変更の詳細については、「サーバーの BizTalk メッセージ管理データベースの変更」を参照してください。

注

  • BizTalk メッセージ管理データベース間でサーバーを移動するには、BizTalk Server Administrators グループのメンバでなければなりません。

関連項目

サーバーの BizTalk メッセージ管理データベースの変更

グループとサーバー

セキュリティ ガイドライン


BizTalk メッセージ管理データベース間でのリモート サーバーの移動

BizTalk メッセージ管理データベースにリモート サーバーを追加するとき、そのサーバーが既に別の中央 BizTalk メッセージ管理データベースに属していた場合、Windows イベント ログに次のエラー メッセージが表示されます。

WMI クラスの新しいインスタンス "MicrosoftBizTalkServer_Server" を BizTalk Server WMI プロバイダで作成できません :サーバー <サーバー名> が別の BizTalk Server インストールに属している可能性があります。

このエラーは、もともと別のデータベースに属していたリモート サーバーを追加しようとしたことを示します。BizTalk Server 管理コンソールでこの手順が実行された場合、管理コンソールはそのリモート サーバーがリモート データベースのグループにも属しているかどうかを判断しようとします。管理コンソールはリモート サーバーの Windows Management Instrumentation (WMI) プロバイダに問い合わせ、これを判断します。サーバーが別のデータベースのサーバー グループに属している場合、既に別のデータベースのグループに属しているリモート サーバーは追加できないことを示す管理コンソールからのエラー メッセージが表示されます。

注

  • BizTalk メッセージ管理データベース間でリモート サーバーを移動するには、BizTalk Server Administrators グループのメンバでなければなりません。

関連項目

リモート サーバーを別の BizTalk メッセージ管理データベースに移動するとエラーが発生する

セキュリティ ガイドライン

Windows Management Instrumentation (WMI) について


サービス アカウント パスワードの変更

データベースへのアクセスで Microsoft BizTalk Server 2002 がサポートするのは Microsoft® Windows® 統合認証だけです。このため、BizTalk Server 2002 サーバー上で実行する BizTalk メッセージ サービスは、BizTalk Server と SQL Server の両方の許可をもつアカウントで実行しなければなりません。ユーザー環境のすべてのサーバーにアクセスできるように適切に設定されているローカル コンピュータ アカウントを使用することもできますが、とくに SQL Server とBizTalk Server が異なるサーバーに格納されている場合に管理が簡単になるので、あらゆる状況のもとでドメイン アカウントの使用を強くお勧めします。

BizTalk Server には、BizTalk メッセージサービスで使用されるサービス アカウントのパスワードが変更されるたびに、そのパスワードを変更するためのコマンドライン ユーティリティがあるので、各サーバーのパスワードを変更する必要はありません。このコマンド ライン ユーティリティを使って、BizTalk メッセージ サービスが実行されるアカウントを変更することもできます。

このコマンド ラインの構文の書式は次のとおりです。

BTS_SvcPW {/?BTS_SvcPW {/? | {/s:<BTM SQL Server 名> /d:<BTM データベース名> {/u:<ドメイン>\<ユーザー名> [/n:<ドメイン>\<ユーザー名>] | /n:<ドメイン>\<ユーザー名>} /p:<新しいパスワード>}}

表記について

[] = 内容がオプションであることを示します。

<> = 変数文字列名を含んでいます。

| = OR 2 項演算子

次の表は、コマンド ラインで使用できるパラメータの動作について説明しています。

パラメータ | 機能
/? | このユーティリティの使用法のヘルプを表示します。 この場合、これが唯一の引数でなければなりません。
/s:<BTM SQL Server 名> | BizTalk メッセージ管理 (BTM) データベースが格納されている SQL Server の名前を入れます。このデータベースには、BizTalk サーバー メッセージ サービス アカウントやパスワードを変更するサーバーが含まれています。 これは、このコマンド ライン ユーティリティで必要な引数です。
/d:<BTM データベース名> | 指定された SQL Server に格納されている BizTalk メッセージ管理データベースの名前を指定します。 これは、このコマンド ライン ユーティリティで必要な引数です。
/u:<ドメイン>\<ユーザー名> | BizTalk メッセージ サービスが現在実行されているドメインとユーザー名を指定します。 このエントリは、このユーティリティに入力されたパスワードが現在のユーザーについて有効であることを検証するために必要です。パスワードが検証されるのは、ユーティリティが実行されるローカル サーバー上でだけです。 変更できるのは、このアカウントを使用している BizTalk メッセージ サービスだけです。 これは、このコマンド ライン ユーティリティの省略可能な引数です。
/n:<ドメイン>\<ユーザー名> | 次に起動するときに BizTalk メッセージ サービスが実行されるドメインとユーザー名を指定します。 この引数を使用すると、パスワードの検証は、BizTalk メッセージ サービスが現在使用しているアカウントでなく、ここで指定されたアカウントに対して行われます。 これは、このコマンド ライン ユーティリティの省略可能な引数です。
/p:<新しいパスワード> | 次に起動するときに BizTalk メッセージ サービスがログオンで使用する新しいパスワードを指定します。 これは、このコマンド ライン ユーティリティの省略可能な引数です。ただし、これが指定されていないと、新しいパスワードの入力が求められます。

/s 引数と /d 引数によって指定された BizTalk メッセージ管理データベースを使用すると、その構成を使用するすべてのサーバーが列挙されます。そのアカウントを使用する列挙されたサーバーのうち、/u 引数で指定されたサーバーについて、パスワードと (オプションとして) アカウントそのものが、コマンド ラインの他の引数に従って変更されます。

/u 引数が指定されていない場合、列挙されたすべてのサーバーが /n 引数と /p 引数によって更新されます。/n 引数は必須で、(/s 引数によって指定されている) BizTalk Server 構成データベース中のすべてのメッセージ サーバーは、新しいアカウントとパスワードを使用するように変更されます。

BizTalk Server メッセージ サービス アカウントを別のアカウントに変更するとき、それはSQL Server とBizTalk Server の両方に対するアクセス権をもつアカウントでなければなりません。データベースにアクセスする適切な特権をもたないアカウントに変更すると、エラー メッセージが表示されます。新しいアカウントに [サービスとしてログオン] の権利が付与されていることを確認します。このユーティリティを実行するたびに、パスワードを入力しなければなりません。コマンド ラインにパスワードがないと、ユーティリティはその入力を求めます。また、コマンド ラインに新しいパスワードがないと、その入力を求められます。

注

  • このユーティリティの構文規則に対する違反があると、使用法のヘルプが表示されます。

  • 引数修飾子の /s、/d、/u、/n、および /p は大文字と小文字を区別しません。

  • すべての変更は、変更された BizTalk メッセージ サービスが次に起動されたときに有効になります。

  • このコマンド ライン ユーティリティを初めて使用するときか、または元のログ ファイルが削除されときに、ログ ファイルが作成されます。ログ ファイルが作成されたあとは、このコマンド ライン ユーティリティを使用すると既存のログ ファイルに情報が書き込まれます。ログ ファイルは、\Program Files\Microsoft BizTalk Server\BTS_SvcPW.log に置かれます。


BizTalk サーバー グループ データベースの管理

各サーバー グループは、共有キュー データベースと追跡データベースの 2 つのデータベースを使用します。共有キュー データベースは、処理と送信のために Microsoft BizTalk Server 2002 に送信されるすべてのドキュメントとインターチェンジを保持します。追跡データベースは、監査、調整、および問題解決のために、受信インターチェンジと送信インターチェンジを追跡し、格納します。

複数の異なるグループのデータベースが同じ Microsoft SQL Server に格納されているとき、サーバーとグループの論理構成を整理するために、各サーバー グループと関連付けられた共有キュー データベースと追跡データベースに一意な名前を付けることが重要です。たとえば、Group1 と Group2 という 2 つのサーバー グループがあり、それらのデータベースが同じ SQL Server に格納されている場合は、最初のグループのデータベースに SharedQueue1 と Tracking1 という名前を付け、2 番目のグループのデータベースに SharedQueue2 と Tracking2 という名前を付けます。

注

  • BizTalk メッセージ管理データベースは、共有キュー データベースおよび追跡データベースとは異なるデータベースです。このデータベースは、複数のグループおよびサーバーの構成に関する情報と BizTalk メッセージ サービスの構成に関する情報を格納するために使用します。ドキュメントとインターチェンジの送信を処理したり、ドキュメントとインターチェンジの利用状況を追跡することはありません。

ここには次のトピックが含まれます。

  • 共有キュー データベース

  • 追跡データベース


共有キュー データベース

サーバー グループ内のすべてのサーバーは、単一の共有キュー データベースを共有します。グループ内のサーバーに送信されるすべてのドキュメントとインターチェンジは、BizTalk Server によって処理されるまで共有キュー データベースに格納されます。

共有キュー データベースは BizTalk Server 管理コンソールでは一連のキューとして視覚的に表示され、BizTalk Server でのインターチェンジまたはドキュメントの処理状況に関する情報を提供してます。インターチェンジとドキュメントは、BizTalk Server に処理されている間、次のいずれかのキューにあります。

  • 作業キュー : 現在 BizTalk Server に処理されているインターチェンジとドキュメントの一覧。

  • 送信待キュー : BizTalk Server によって処理され、サービス時間帯に従って送信を待機しているインターチェンジとドキュメントの一覧。サービス時間帯の詳細については、「ServiceWindowInfo Property」を参照してください。

  • 再送信キュー : 再送信されるインターチェンジおよびドキュメントと、受信確認を待機している信頼できるメッセージの一覧。

  • 保留キュー : 解析エラー、シリアライズ エラー、送信エラー、またはチャネル構成の間違いなど、さまざまな理由で処理が失敗したインターチェンジとドキュメントの一覧。

BizTalk Server がインターチェンジまたはドキュメントを処理している場合、次の条件を満たしているときに処理を停止し、共有キュー データベースをロールバックします。

  • BizTalk Server が共有キュー データベースにアクセスできない場合。たとえば、共有キュー データベースをホストするサーバーが失敗した場合に、BizTalk Server は共有キュー データベースとの接続を失います。

  • タイムアウト、トランザクションの中断、およびデッドロックなどの SQL Server エラーが発生した場合。

インターチェンジやドキュメントが送信されてから、BizTalk Server が処理を停止しても、トランザクションはロールバックされます。共有キュー データベースが再び利用できるようになると、"処理中" であるとマークされているすべてのドキュメントでラベルが削除されます。つまり、ドキュメントは保留キューに配置されるのではなく、再び処理されます。

トランザクション メッセージ キューまたは信頼できるメッセージ処理を使用すると、インターチェンジまたはドキュメントの配信は必ず 1 回だけになります。非トランザクション送信を使用すると、このトピックで説明している条件の下で、BizTalk Server 2002 は同じドキュメントを 2 回送信することがあります。

注

  • 共有キュー データベースに格納されているキューを管理するには、BizTalk Server Administrators グループのメンバでなければなりません。

関連項目

サーバー グループの接続のプロパティの構成

グループとサーバー

キューの管理

セキュリティ ガイドライン

ServiceWindowInfo Property

キューの使用


追跡データベース

サーバー グループ内のすべてのサーバーは単一の追跡データベースを共有します。追跡データベースは、BizTalk Server でのインターチェンジとドキュメントの処理状況に関連するすべての情報を格納します。追跡データベースは、サーバーを通過するインターチェンジまたはドキュメントのステータスを追跡するために使用します。たとえば、注文が取引先に送信されたかどうかを確認する場合、追跡データベースに対してクエリを実行します。このデータベースは、インターチェンジとドキュメントが BizTalk Server によって正しく送受信されたことを確認するために使用したり、送信時間または受信応答などのレポート情報を得るために使用することができます。

追跡データベースのドキュメント トラッキング パラメータとログ パラメータの定義

BizTalk Server 管理コンソールでは、インターチェンジおよびドキュメントを追跡するかどうかを選択することができます。サーバー グループの追跡設定を構成する方法の詳細については、「サーバー グループの追跡のプロパティの構成」を参照してください。追跡を有効にする場合、次のオプションを利用できます。

  • [受信インターチェンジを記録する] : この設定は、BizTalk Server によって受信されるドキュメントを追跡データベースに格納することを指定します。格納された受信ドキュメントは、問題解決のために利用状況の記録を提供します。このチェック ボックスは既定でオンになっています。

  • [送信インターチェンジを記録する] : この設定は、BizTalk Server によって送信されるドキュメントを追跡データベースに格納することを指定します。このチェック ボックスは既定でオンになっています。

  • [元の MIME エンコード メッセージを記録する] : この設定は、MIME エンコード ドキュメントをデコードされる前の元のメッセージ書式で追跡データベースに格納することを指定します。このチェック ボックスは既定でオフになっています。

関連項目

サーバー グループの接続のプロパティの構成

サーバー グループの追跡のプロパティの構成

セキュリティ ガイドライン

グループ内のサーバーの起動

グループ内のサーバーの停止

BizTalk ドキュメント トラッキングの使用


サーバー エラーの処理

BizTalk Server 管理コンソールに含まれている Windows 2000 イベント ビューアを使用して、サーバー レベルで Microsoft BizTalk Server 2002 のエラー処理を構成することができます。Windows 2000 イベント ビューアは、管理コンソールのコンソール ツリーに表示されます。

イベントのログ

Windows 2000 イベント ビューアは、ハードウェア、ソフトウェア、およびシステムの問題に関する情報を含むログを表示します。管理コンソールからイベント ビューアをカスタマイズして、BizTalk メッセージ サービスと XLANG スケジューラに固有なアプリケーション エラーを表示することができます。これにより、BizTalk Server のトラブルシューティングを効率的に行えます。BizTalk Server エラーと XLANG スケジューラ エラー用にイベント ビューアをカスタマイズする方法の詳細については、「イベント ビューアの管理」を参照してください。

イベント ビューアの詳細については、Windows 2000 Server ヘルプの「イベント ビューアを使う」を参照してください。

注

  • BizTalk Server 2002 に関連するすべてのアプリケーション エラーは、BizTalk Server エラーまたは XLANG スケジューラ エラーとして定義されます。

関連項目

イベント ビューアの管理


受信機能

受信場所からドキュメントを受信し、Microsoft BizTalk Server 2002 に送信する必要がある場合、そのデータを処理する受信機能を構成することができます。たとえば、COM インターフェイスを経由して BizTalk Server と直接通信することができない組織またはアプリケーションからドキュメントを受信する必要がある場合、受信機能を使用してドキュメントを BizTalk Server に送信することができます。または、メッセージ キューから受信する必要がある場合、受信機能を使用してドキュメントを BizTalk Server に送信することができます。BizTalk Server 2002 は、ファイル、メッセージ キュー、および HTTP の 3 種類の受信機能をサポートしています。

  • ファイル

  • メッセージ キュー

  • HTTP

管理コンソールで BizTalk Server 2002 の汎用受信機能を作成し、その受信機能の名前やドキュメント定義などを定義することができます。受信機能の構成の詳細については、「サーバー グループの受信機能の管理」を参照してください。受信機能の詳細プロパティの詳細については、「受信機能の詳細プロパティについて」を参照してください。

次の図は、送信側業務用アプリケーション、ファイル システム、および BizTalk Server の汎用受信機能間の相関関係を示しています。

送信側業務用アプリケーション、ファイル システム、および BizTalk Server の汎用受信機能間の相関関係

注

  • ドキュメントを受信し、それらを BizTalk に送信する送信呼び出しをプログラムによって構成することもできます。送信呼び出しの詳細については、「Submitting」または「BizTalk Documents」を参照してください。

ここには次のトピックが含まれます。

  • 利用可能な受信機能

  • 関連付けトークン

  • カスタム プリプロセッサ

  • 受信機能の複数のインスタンス

  • 受信機能とドキュメント ルーティングについて

  • 受信機能の詳細プロパティについて


利用可能な受信機能

BizTalk Server では、ファイル、メッセージ キュー、および HTTP の 3 種類の受信機能を利用できます。業務の習慣によって、使用する受信機能の種類と時期を決定します。

ファイル受信機能

ファイル受信機能は、受信機能が監視するディレクトリに利用状況がある場合にアクティブになります。ファイル受信機能を使用するには、そのディレクトリを変更できる必要があります。ファイル受信機能は、そのディレクトリからファイルを削除し、BizTalk Server 2002 に送信します。

メッセージ キュー受信機能

メッセージ キュー受信機能は、メッセージ キュー内の利用状況に基づいてアクティブになります。この受信機能は、キューからインターチェンジまたはドキュメントを抽出し、BizTalk Server 2002 に送信します。

メッセージ キューのポーリング場所を定義する場合、パスの代わりに書式名を使用します。BizTalk Server は変更されていないメッセージ キュー アプリケーション プログラミング インターフェイス (API) と共に動作するよう設計されており、API 呼び出しは書式名でのみ動作します。メッセージ キュー受信機能を構成する場合、次の書式名を使用します。

Direct=OS:<サーバー名>\<キュー名>

注

  • メッセージ キューと書式名の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「Message Queuing Services」を検索してください。

HTTP 受信機能

HTTP 受信機能は Internet Server Application Programming Interface (ISAPI) の拡張機能です。この拡張機能は、Web ページや新たなダイナミックリンク ライブラリ (DLL) の開発を必要とせず、最小限の構成によって Hypertext Transfer Protocol (HTTP) 経由でドキュメントを受信する out-of-the-box ユーティリティとして機能します。

HTTP 受信機能は、Submit メソッド、または SubmitSync メソッドの COM 呼び出しによって、ドキュメントをファイル システムまたは直接に BizTalk Server に送信します。

関連項目

ファイル受信機能の追加

HTTP 受信機能の追加

メッセージ キュー受信機能の追加

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

ファイル受信機能の構成 : [全般] タブ

ファイル受信機能の構成 : [サービス] タブ

メッセージ キュー受信機能の構成 : [全般] タブ

メッセージ キュー受信機能の構成 : [サービス] タブ

HTTP 受信機能の構成 : [全般] タブ

HTTP 受信機能の構成 : [サービス] タブ


関連付けトークン

HTTP 受信機能は、関連付けトークンを使って、非同期 BizTalk Server 送信で同期動作をエミュレートします。これがどのように実現されるかを示すものとして、境界ネットワーク (DMZ、非武装地帯、または遮蔽されたサブネットとも言われます) の ASP ページにドキュメントを送信する例があります。この ASP ページが HTTP 受信機能を使ってファイアウォールの向こう側にドキュメントを渡している場合、関連付けトークンを使用してドキュメントの処理の進行状況が監視され、このドキュメントをいつ送信元のクライアントに返すかが決定されます。関連付けトークンを使用しているとき、非同期プロセスがクライアントには同期プロセスであるかのように見えます。

注

  • HTTP 受信機能で使用される関連付けトークンは、オーケストレーションの関連付けプロセスとは無関係です。


カスタム プリプロセッサ

BizTalk Server に送信する前に処理する必要があるドキュメントがある場合、カスタム プリプロセッサを作成し、受信機能を構成して、そのプリプロセッサを呼び出すことができます。たとえば、圧縮データを送信し、BizTalk Server に送信する前に圧縮解凍する必要がある場合、カスタム プリプロセッサを呼び出すよう受信機能を構成して、データを圧縮解凍します。

関連項目

プリプロセッサの一覧にクラス識別子が表示される

IBTSCustomProcess

Preprocessing Documents in a Receive Function


受信機能の複数のインスタンス

受信機能の複数のインスタンスが存在することがあります。たとえば、BizTalk Server 2002 にドキュメントおよびインターチェンジを送信するために複数の業務用アプリケーションがファイル受信機能を使用する場合、ファイル受信機能の単一のインスタンスまたは複数のインスタンスのいずれかを構成することができます。

注

  • 作成する各受信機能に一意な名前が付いていることを確認してください。異なる受信機能に同じ名前を割り当てることはできません。

  • 同じサーバーで実行されるすべての HTTP 受信機能で、ただ 1 つのダイナミックリンク ライブラリ (DLL) または仮想ディレクトリを使用することをお勧めします。複数の DLL または仮想ディレクトリを使用すると、予期しない結果を招くことがあります。HTTP 受信機能の追加の詳細については、「HTTP 受信機能の追加」を参照してください。

関連項目

サーバー グループの受信機能の管理


受信機能とドキュメント ルーティングについて

受信機能を構成する場合、その受信機能によって受信されるドキュメントがセルフルーティングまたは非セルフルーティングのいずれであるかを決定します。セルフルーティング ドキュメントには必要なすべてのルーティング情報が含まれ、非セルフルーティング ドキュメントには、ルーティング情報の一部またはすべてが不足しています。

セルフルーティング ドキュメント

セルフルーティング ドキュメントには、送信元組織の識別子、送信先組織の識別子、およびドキュメント定義などのすべてのルーティング情報が含まれます。ルーティング情報は、ANSI X12 と EDIFACT の場合と同様に、ドキュメント仕様よって定義されるルーティング タグ、またはドキュメント内にハードコードされるルーティング タグで定義されます。BizTalk エディタで仕様を作成できるすべてのドキュメントは、セルフルーティング ドキュメントとして構成することができます。セルフルーティング ドキュメントの一般的な種類は、XML、X12、および EDIFACT です。ドキュメントがセルフルーティングの場合、ドキュメントで提供されているデータを上書きする場合を除き、受信機能で詳細プロパティを構成する必要はありません。

送信元組織の修飾子、送信先組織の修飾子、またはドキュメント定義がドキュメントに含まれていない場合、そのドキュメントは保留キューに配置されます。また、送信元組織または送信先組織の修飾子を指定しない場合、BizTalk Server は組織の修飾子として組織名の既定値を使用し、BizTalk メッセージ管理データベースに格納されている組織の名前を参照します。

非セルフルーティング ドキュメント

非セルフルーティング ドキュメントには、必要なルーティング情報のすべてまたは一部が不足しています。受信機能を構成する場合、受信機能のプロパティ ダイアログ ボックスの [詳細設定] タブまたは受信機能に提供するドキュメントで、次の情報を定義する必要があります。

  • 送信元組織識別子、送信先組織識別子、およびドキュメント定義

    または

  • チャネル

ドキュメントを送信するときに、BizTalk Server はドキュメントを処理するためのチャネルを検出します。これは、受信機能でチャネル名を指定するか、送信元組織識別子、送信先組織識別子、およびドキュメント定義を指定する、2 つの方法で行うことができます。これらの 3 つのプロパティは、BizTalk Server が正しいチャネルを検出するために使用されます。したがって、チャネルを選択する場合は、そのチャネルがドキュメントをルーティングするために必要なすべての情報を提供するため、ドキュメント定義、送信元の情報、および送信先の情報のオプションは利用できません。

非セルフルーティング ドキュメントの一般的な種類は、複数の送信元 (オープンな送信元) から受信するドキュメントまたは複数の送信先 (オープンな送信先) に送信するドキュメントです。

複数の送信元からのドキュメントを管理するための受信機能の構成

非セルフルーティング ドキュメントを処理する単一の受信機能を構成して、複数の送信元から特定の種類のドキュメントを受信することができます。これはオープンな送信元のシナリオです。送信元組織、送信先組織、およびドキュメント定義情報の場所は、ドキュメント内で指定するか、またはドキュメントと共に送信するパラメータで指定する必要があります。

たとえば、複数の顧客から購入注文を受信する予定があり、すべてを同じ送信先アプリケーションに送信する場合、受信機能でドキュメント定義と送信先組織識別子のプロパティを設定します。BizTalk Server は、ドキュメントを解析する場合、サプライヤの組織識別子を検出し、この情報を受信機能のパラメータと組み合わせて、正しいチャネルを見つけてから、ドキュメントを処理します。

関連項目

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

サーバー グループの受信機能の管理

送信元組織のプロパティの設定


受信機能の詳細プロパティについて

詳細プロパティを使用して、業務の習慣に基づいて特別な種類の受信機能を構成することができます。

たとえば、次のドキュメントを送信する受信機能を定義することができます。

  • [オープンな送信元] プロパティまたは [オープンな送信先] プロパティが設定されているドキュメント

  • [パススルー] プロパティが設定されているドキュメント

  • チャネル名を指定するドキュメント

  • その他の種類の非セルフルーティング ドキュメント

ドキュメントでのオープンネス プロパティの定義

次のオプションはドキュメントのオープンネスを定義します。

  • [開いていません] : 送信元と送信先の両方が受信機能またはドキュメント インスタンスで明示的に宣言されていることを指定します。

  • [オープンな送信先] : 送信先情報がメッセージ ポートで明示的に宣言されていないことを指定します。送信先はドキュメント インスタンスまたは送信パラメータで動的に指定します。BizTalk Server が正しいチャネルを検出するためには、受信機能またはドキュメント インスタンスでドキュメント定義と送信元組織識別子のプロパティを構成する必要があります。

  • [オープンな送信元] : 送信元情報がチャネルで明示的に定義されていないことを指定します。送信元はドキュメント インスタンスで動的に指定します。BizTalk Server が正しいチャネルを検出するためには、受信機能またはドキュメント インスタンスでドキュメント定義と送信先組織識別子のプロパティを構成する必要があります。

パススルーを使用する受信機能の構成

パススルーを使用するよう構成された受信機能は、BizTalk Server の解析、暗号解読、署名検証、変換、およびデコードの機能をバイパスします。Binary Large Object データまたは解析、暗号解読、およびデコードを要求しないその他のインターチェンジを送信する場合は、このオプションを選択します。[パススルー フラグを付けて送信する] チェック ボックスをオンにして受信機能を構成する場合は、チャネルを指定する必要があります。チャネルを指定しなければ、BizTalk Server はドキュメントを処理できません。

エンベロープ名

フラット ファイルで受信インターチェンジを受信する場合、受信機能でエンベロープ書式を指定します。エンベロープは、インターチェンジを開き、解釈する方法を BizTalk Server に指示する仕様を示します。単一のインターチェンジで複数のフラット ファイルを受信する場合、個々のフラット ファイルを接尾辞または接頭辞である区切り記号で区切る必要があります。挿入辞はサポートされていません。これは、解析プロパティを構成するときに、エンベロープ仕様およびドキュメント仕様のルート ノードで設定する必要があります。フラット ファイルの解析のプロパティを設定する方法の詳細については、「解析のプロパティの設定」の表、「標準 : [カスタム]、"構造" プロパティ : [区切り記号]」を参照してください。

チャネル名

BizTalk Server に送信される各インターチェンジまたはドキュメントは、その処理方法に関する一連の規則を要求します。チャネルには、サーバーがインターチェンジまたはドキュメントを処理するために必要なすべての情報が含まれています。BizTalk Server によって処理されるすべてのインターチェンジとドキュメントは、チャネルを経由する必要があります。チャネルは次のいずれかの方法で検出されます。

第 １ の方法として、インターチェンジまたはドキュメントが送信されるときにチャンネルが検出されます。BizTalk Server はドキュメントを解析し、その送信元識別子、送信先識別子、およびドキュメント定義を調べます。この情報がドキュメント インスタンスにない場合、BizTalk Server は受信機能を参照します。送信元識別子、送信先識別子、およびドキュメント定義が発見されると、BizTalk Server は受信ドキュメントと同じドキュメント定義、送信元識別子、および送信先識別子を持つチャネルを決定します。一致するチャネルが見つかると、そのドキュメント インスタンスが処理されます。

チャネルを検出する第 2 の方法では、受信機能でチャネルが指定されます。この場合、チャネルの検索がバイパスされ、受信ドキュメントの処理が早くなります。

ドキュメント定義、送信元組織識別子、および送信先組織識別子

非セルフルーティング ドキュメントを受信する場合、ドキュメント定義、送信元組織識別子、および送信先組織識別子のすべてまたは一部を構成することができます。受信したドキュメントに含まれているルーティング情報によって、どのプロパティを受信機能で定義するかが決まります。

たとえば、同じ送信元組織から複数の種類のドキュメントを受信し、常にこれらのドキュメントを同じ送信先に送信する場合、受信機能で送信元組織識別子と送信先組織識別子を構成し、ドキュメント インスタンスでドキュメント定義を動的に定義することができます。

関連項目

エンベロープの作成

エンベロープ情報のプロパティの設定

解析のプロパティの設定

チャネルについて

ドキュメント定義について

エンベロープについて

組織について

受信機能とドキュメント ルーティングについて

受信処理のためのエンベロープの使用


キューの使用

Microsoft BizTalk Server 2002 は、BizTalk Server 管理コンソールで共有キュー管理機能を提供します。BizTalk Server の管理者は、任意のキューから保留キューにドキュメントを移動することができます。ドキュメントの処理状態によって、ドキュメントを保留キューから削除、再送信、または表示することができます。BizTalk Server の管理者は、保留キュー内のドキュメントのエラー メッセージを並べ替えて、表示することができます。

次のキューは、BizTalk Server でさまざまなルーティング段階と処理段階にある受信ドキュメントおよび送信ドキュメントを格納するために使用します。

  • 作業キュー

  • 送信待キュー

  • 再送信キュー

  • 保留キュー

注

  • インターチェンジとドキュメントは "先入れ先出し" の順序で BizTalk Server 管理コンソールに表示されます。つまり、キューの最も古い項目が先頭に表示され、最新の項目は最後に表示されます。また、一度に最大 15,000 のインターチェンジとドキュメントが表示されます。15,000 を超える実際の項目がキューにある場合、新しい項目を表示できるように、キューの現在の項目を削除または再送信する必要があります。コンソール ツリーのキュー数 (キューの横にあるかっこ内の数) は、キューに存在する実際の項目数を表します。ドキュメントを再送信または削除して、キューから項目を削除することができます。

関連項目

キューの管理


作業キュー

作業キューには、現在 BizTalk Server によって処理されているドキュメントが格納されます。作業キューのトランザクションは、到着時に処理されるため、長い間キューに残ることはありません。BizTalk Server の管理者は、このキューにあるドキュメントを選択し、それを保留キューに移動することができます。

関連項目

保留キューへのドキュメントの移動

キューの使用


送信待キュー

送信待キューには、BizTalk Server によって処理され、サービス時間帯に基づいて送信を待機している作業項目が含まれます。BizTalk Server の管理者は、このキューにあるドキュメントを選択し、それを保留キューに移動することができます。サービス時間帯の詳細については、「IBizTalkServiceWindowInfo」インターフェイス オブジェクトを参照してください。

関連項目

IBizTalkServiceWindowInfo

保留キューへのドキュメントの移動

キューの使用


再送信キュー

再送信キューには、配信のために再送信されるドキュメントと信頼できるメッセージの受信機能を待機しているドキュメントが含まれます。送信の種類を区別することはできません。既定では、失敗した送信は 5 分ごと最大 3 回再試行され、その後保留キューに移動されます。これらの数値は、BizTalk メッセージ マネージャまたはプログラムによって変更することができます。再試行回数の変更の詳細については、「詳細構成のプロパティの設定」、または「RetryCount プロパティ」および「RetryInterval プロパティ」を参照してください。

BizTalk Server の管理者は、このキューにあるドキュメントを選択し、それを保留キューに移動することができます。

関連項目

保留キューへのドキュメントの移動

RetryCount プロパティ

RetryInterval プロパティ

詳細構成のプロパティの設定

キューの使用


保留キュー

保留キューには、解析エラー、シリアライズ エラー、送信の失敗、またはチャネル構成を見つけられないことなど、さまざまな理由で処理が失敗した作業項目が含まれます。BizTalk Server の管理者は、このキューにあるドキュメントを右クリックして、次のいずれかのオプションを選択することができます。

  • [エラーの説明の表示] : BizTalk Server の管理者は、ドキュメントが保留キューに送信された理由を示すエラーの説明を表示することができます。

  • [インターチェンジの表示] : BizTalk Server の管理者は、解析エラーや送信の失敗などのさまざまな理由で処理が失敗したインターチェンジの内容を表示することができます。[インターチェンジの表示] は、次のステータスの場合に表示されます。
    • 初期

    • カスタム コンポーネント

    • 解析

    • エンコード

    • 署名

    • 暗号化

    • 送信
  • [ドキュメントの表示] : BizTalk Server の管理者は、シリアライズ エラーやチャネルを見つけられないなど、さまざまな理由で処理が失敗したドキュメントの内容を表示することができます。[ドキュメントの表示] は、次のステータスの場合に表示されます。
    • ドキュメントの検証

    • チャネルの選択

    • フィールドの追跡

    • マッピング

    • 関連付け

    • シリアライズ
  • [削除] : BizTalk Server の管理者は、保留キューからエントリを完全に削除することができます。この操作は回復できません。ドキュメントを保留キューから削除した後に、そのドキュメントを取得することはできません。

  • [再送信] : BizTalk Server の管理者は、BizTalk Server にインターチェンジとドキュメントを再送信することができます。

保留キューのステータス

インターチェンジとドキュメントはさまざまな理由で保留キューに配置されます。次の表は、保留キューのステータス、それに関連するエラー メッセージ、および解決策として実行できる操作を示しています。

保留キューのステータス値 | エラー メッセージ | エラーの説明と操作例
[チャネルの選択] または [送信] | 予期しないエラー | 予期しない内部サーバー エラーが発生しました。 ドキュメントを再送信します。
[チャネルの選択] または [送信] | 不明 | そのインターチェンジまたはドキュメントは、アクティブでないサーバーによって "処理中" であるとマークされました。サーバーの再起動時に、この項目は自動的に保留キューに移動されました。処理元のサーバーでエラーが発生した可能性があります。詳細については、システム管理者に問い合わせてください。 問題を修正してから、ドキュメントまたはインターチェンジを再送信します。
[チャネルの選択] または [送信] | メモリ不足 | BizTalk Server を実行しているコンピュータのメモリが不足しています。 サーバーを再起動し、保留キュー内のすべてのインターチェンジとドキュメントを再送信します。
[解析] | 解析の失敗 | BizTalk Server はデータを解析できませんでした。 インターチェンジの内容を表示して、BizTalk Server が解析できなかった理由を調べます。IInterchange または受信機能を使用して、そのインターチェンジを再送信します。詳細については、「インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される」または「解析エラー」を参照してください。
[解析] | データ不足 | 受信データから抽出した情報には、チャネルの場所を特定するための情報が十分に含まれていませんでした。 インターチェンジを表示し、不足しているデータを見つけます。IInterchange または受信機能を使用して、そのインターチェンジを再送信します。詳細については、「インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される」または「解析エラー」を参照してください。
[解析] | タイムスタンプの有効期限切れ | BizTalk フレームワーク タイムスタンプ "expiresAt" による有効期限が切れました。 このドキュメントはもう有効ではありません。詳細については、「インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される」を参照してください。
[チャネルの選択] | チャネルが見つかりません | BizTalk Server は、このドキュメントに一致するチャネルを発見できませんでした。 そのドキュメント用のチャネルを作成するか、ドキュメントを修正してから再送信します。
[チャネルの選択] | チャネルは削除されました。 | このドキュメントに関連付けられているチャネルは、ドキュメントが作業キューに到達した後に削除されました。 チャネルを再構成するか、別のチャネル用にドキュメントを構成してから再送信します。 または ドキュメントを送信せず、保留キューからそのドキュメントを削除します。
[フィールドの追跡] または [初期] | チャネルが見つかりません | 受信機能または送信呼び出しによって指定されたチャネルが見つかりませんでした。 チャネルを構成するか、ドキュメントを再構成してから、再送信します。
[チャネルの選択] | 無効なチャネル | 送信呼び出しによって指定されたチャネルは、オープン チャネルでした。オープン チャネルは、パススルー送信呼び出しには使用できません。 チャネルを変更して、ドキュメントを再送信します。
[マッピング] | マップの失敗 | チャネルが参照しているマップの形式が正しくありません。 保留キューからそのドキュメントを削除し、マップを修正して、新しいドキュメントとしてドキュメントを送信します。
[シリアライズ] | シリアライズの失敗 | BizTalk Server は、このドキュメントをネイティブ形式に変換できませんでした。 ドキュメントを再送信します。
[エンコード] | エンコードの失敗 | BizTalk Server は、このインターチェンジをエンコードできませんでした。 インターチェンジを再送信します。
[署名] | 署名の失敗 | BizTalk Server は、このインターチェンジに署名できませんでした。 証明書の有効期限が切れている可能性があります。詳細については、Microsoft 管理コンソール (MMC) の証明書スナップインを参照してください。証明書スナップインを表示する方法の詳細については、Windows 2000 ヘルプの「証明書を管理する」の下にある「証明書スナップインを MMC コンソールに追加する」を参照してください。
[暗号化] | 暗号化の失敗 | BizTalk Server は、このインターチェンジを暗号化できませんでした。 証明書の有効期限が切れている可能性があります。詳細については、Microsoft 管理コンソール (MMC) の証明書スナップインを参照してください。証明書スナップインを表示する方法の詳細については、Windows 2000 ヘルプの「証明書を管理する」の下にある「証明書スナップインを MMC コンソールに追加する」を参照してください。
[送信] | 送信の失敗 | BizTalk Server は、このインターチェンジを配信できませんでした。 チャネルのトランスポート アドレスを確認します。問題を修正し、インターチェンジを再送信します。
[送信] | タイムアウトによる失敗 | BizTalk Server は、このインターチェンジの処理をタイムアウト前に完了できませんでした。送信に時間がかかりすぎたことが考えられます。 信頼性の低い送信手段を利用している場合は、再送信の前に、このインターチェンジの送信が完了していないかどうかを確認してください。
[送信] | ユーザーによる移動 | このドキュメントは BizTalk Server の管理者によって保留キューに移動されました インターチェンジを再送信します。
[送信] | タイムスタンプの有効期限切れ | BizTalk フレームワーク タイムスタンプ "receiptRequiredBy" の有効期限が切れました。このドキュメントはもう有効ではありません。
[ドキュメントの検証] | 無効なドキュメント | 仕様に対するこのドキュメントの検証が失敗しました。 詳細については、イベント ログでそのエラーを参照してください。スキーマを修正し、ドキュメントを再送信します。
[フィールドの追跡] | フィールドの追跡の失敗 | BizTalk Server は、ドキュメント内にある要求されたフィールドを追跡できませんでした。 ドキュメントを表示して追跡するフィールドが存在していることを確認するか、フィールドの追跡に関するチャネルの構成を変更します。次に、ドキュメントを再送信します。
[カスタム コンポーネント] | カスタム コンポーネントの実行失敗 | カスタム コンポーネントの実行に失敗しました。 カスタム コンポーネントまたはカスタム プリプロセッサのトラブルシューティングを行って、インターチェンジを送信します。
[関連付けています] | 関連付けの失敗 | この受信確認の関連付けに失敗しました。

注

  • 保留キューのエラー メッセージの確認に加えて、イベント ログで詳細を確認することもできます。イベント ログの詳細については、「イベント ビューアの管理」を参照してください。

  • 保留キューにあるすべてのドキュメントが再送信されるわけではありません。場合によっては、ドキュメントを削除してから、元のアプリケーションまたは組織から送信し直す必要があります。

関連項目

インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

イベント ビューアの管理

キューの管理

解析エラー

受信機能の詳細プロパティについて

受信機能とドキュメント ルーティングについて

キューの使用


管理者特権

BizTalk Server 管理コンソールを表示するには、BizTalk Server Administrators グループのメンバである必要があります。BizTalk Server Administrator 以外のユーザーとしてログオンした場合、Microsoft BizTalk Server 2002 フォルダ内の項目を表示することができません。BizTalk Server Administrators グループのメンバであり、Microsoft Windows 2000 Administrators グループのメンバではない場合は、次の作業だけ行うことができます。

  • サーバー グループの追加と削除

  • グループのプロパティの表示と変更

  • すべてのキューとそのエントリの管理

  • 受信機能の追加と削除

  • 受信機能のプロパティの表示と変更

また、たとえば Server_1、Server_2、および Server_3 の 3 つのサーバーを含むサーバー グループを管理している場合、3 つすべてのサーバーで Windows 2000 の管理者特権が必要です。Windows 2000 管理者特権が Server_1 で変更された場合、管理者特権が失われ、管理コンソールはグループと関連付けられた 3 つのサーバーすべての一覧を返し、各サーバーのステータスを一覧表示します。Server_1 については "アクセスは拒否されました" というステータスが返されます。

BizTalk Server Administrators グループと Windows 2000 Administrators グループの両方のメンバである場合は、さらに次の作業を行うことができます。

  • サーバー グループへのサーバーの追加とサーバー グループからのサーバーの削除

  • サーバーのプロパティの表示と変更

  • サーバーのステータスの表示

  • サーバー上のインターチェンジの解放

また、データベースにアクセスするためには、SQL Server Administrators グループのメンバでなければなりません。

BizTalk Server のインストールを実行しているユーザーは、セットアップ中に BizTalk Server Administrators グループに追加されます。ほかのユーザーを BizTalk Server Administrators グループに追加することもできます。詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。


BizTalk Server 管理コンソールに関する作業を行う目的

ここでは、BizTalk Server 管理コンソールで行う作業の目的についてのクイック リファレンスを示します。次の表は、主要な作業とそれらに付随する作業を示しており、各作業の目的と対応する手順へのリンクを明記しています。

作業 作業を行う目的
  • BizTalk Server 管理コンソールを開く
 大部分の管理作業を開始するため。
  • コンポーネント サービスを開く
 そのほかの管理作業を開始するため。
  • Active Directory への BizTalk Server 2002 の公開
 分散環境で BizTalk Server を利用できるように公開するため。
  • Active Directory からの BizTalk Server 2002 の削除
 BizTalk のサーバー コンピュータの登録を Active Directory から削除するため。これにより、Active Directory で照会したときには、BizTalk Server の動作するコンピュータだけが識別されるようになります。
  • BizTalk Server Administrators グループへのユーザーの追加
 BizTalk Server の管理用アクセス許可が必要なユーザーを追加するため。
  • BizTalk メッセージ管理データベースの構成
 メンテナンス時に BizTalk メッセージ管理データベースをオフラインにするため。
  • クライアント インストールで管理される BizTalk メッセージ管理データベースの変更
 クライアント コンピュータから管理している BizTalk メッセージ管理データベースを変更するため。
  • 管理コンソールの更新
 サーバー グループ、サーバー、受信機能、キュー内にある項目数などの現在の状態を表示するため。
サーバー グループの追加、削除、および構成 :
  • サーバー グループの追加
 追加のスケール アウトが必要になったときに、新しい BizTalk Server グループを追加するため。BizTalk Server グループは、BizTalk Server の拡張性を向上させるための重要な要因です。新しいサーバー グループを作成することで、より多くのコンピュータが含まれるように処理を分離してスループットを向上させることができます。
  • サーバー グループの全般プロパティの構成
  • BizTalk Server グループを使用する SMTP ホストを変更するため。

  • BizTalk Server グループが使用する、信頼できるメッセージの受信確認を取得するための URL を変更するため。

  • BizTalk メッセージ管理オブジェクト キャッシュの更新間隔を変更するため。

  • BizTalk Server グループが使用するプロキシ サーバーを追加、変更するため。
  • サーバー グループの接続のプロパティの構成
 BizTalk Server グループの接続している共有キュー データベースと追跡データベースを変更するため。通常、これらの構成の変更が必要になるのは、ほかのデータベースやデータベース サーバーへの変更が要求される場合だけです。すなわち、障害からの回復やバックアップ管理の部分的な作業として行います。
  • サーバー グループの追跡のプロパティの構成
 サーバー グループのさまざまなレベルのドキュメント トラッキングを有効にするため。また、トラッキングの有効と無効を切り替えるため。
  • サーバー グループのパーサー順序の構成
 パーサーの順序を変更するため。または、レジストリのパーサーの一覧を更新するため。パーサーの一覧の順序は変更可能です。たとえば、受信するすべてまたは大部分のドキュメントが、ある特定の種類の場合、スループットを最適化できます。一覧の最初に目的のドキュメントの種類に対応するパーサーを配置することで、BizTalk Server はこのドキュメントの解析をほかのパーサーに回さなくなるため、ドキュメントを早く処理するようになります。
  • サーバー グループの削除
 BizTalk Server グループ全体を削除するため。たとえば、全体のスループットの要求が緩和された場合に、1 つまたは複数のグループを削除して、ハードウェア リソースをほかの目的に使用するように開放できます。
グループ内のサーバーの追加、削除、および構成 :
  • グループへのサーバーの追加
 既存の BizTalk Server グループに新しいサーバーを追加するため。BizTalk Server の実装にグループを追加できるばかりでなく、各グループには、関連する任意の数のサーバーを登録できます。グループ内のデータベース サーバーの処理性能に対して、グループ内のサーバー数を最適化することで、スループットを最大化できます。
  • グループからのサーバーの削除
 BizTalk Server グループからサーバーを削除するため。サーバーをある BizTalk Server グループからほかのグループに移動するには、そのサーバーを現在属しているグループから削除して、次に、新しいグループに追加する必要があります。
  • グループ内のサーバーの構成
 サーバーの全般的なプロパティを変更するため。たとえば、使用できる受信機能スレッドの最大数や、作業項目の処理にサーバーを参加させるかどうかなどの構成を変更します。サーバーで動作する受信機能を作成し、そのサーバーを処理に加えないように構成することで、インターチェンジの受信用として最速にでき、全体のスループットの向上に役立てることができます。
  • サーバーの BizTalk メッセージ管理データベースの変更
 サーバーが使用する BizTalk メッセージ管理データベースを変更するため。通常、この作業はほかのデータベースに恒久的に変更するときだけ必要になります。つまり、障害から復旧するときや、既存データベース サーバーをほかのデータベース サーバーに置き換えるときなどです。
グループ内のサーバーの管理 :
  • グループ内のサーバーの起動
 BizTalk Server を開始するため。この作業によって、関連付けられたサーバーにある BizTalk Server の実行時サービスが起動されます。この BizTalk Server はインターチェンジの受信や処理に参加できるようになります。
  • グループ内のサーバーの停止
 BizTalk Server を停止するため。この作業によって、関連付けられたサーバーにある BizTalk Server の実行時サービスが停止されます。この BizTalk Server はインターチェンジの受信や処理から離脱します。
  • サーバーからのインターチェンジの解放
 サーバーからインターチェンジを解放するため。この作業によって、元のサーバーが停止したり、オフラインになっているときでも、インターチェンジをグループ内のほかのサーバーに再配布できます。
  • ディスク キャッシュの構成
 ディスク キャッシュを有効または無効にするため。ディスク キャッシュが無効になっているときには、電源障害などの致命的な障害時にもデータの消失を防ぐことができます。
キューの管理 :
  • 保留キューへのドキュメントの移動
 ドキュメントを作業キュー、送信待キュー、または再送信キューから、保留キューに移動するため。通常、この作業を行うのは、特定のメッセージまたはメッセージの集合を保留にしなければならない場合です。すなわち、ある種の問題や例外条件がメッセージ自身かシステムに発生し、保留にしないとあとでメッセージが送信されてしまう場合などです。
  • エラーの説明の表示
 ドキュメントが保留キューに入る原因となったエラーを確認するため。これは、問題解決時に最初に行うべき作業です。
  • インターチェンジの表示
 保留キューに入れられたインターチェンジを表示するため。これは、問題解決時に最初に行うべき作業です。
  • ドキュメントの表示
 保留キューに入れられたドキュメントを表示するため。これは、問題解決時に最初に行うべき作業です。
  • ドキュメントの再送信
 現在保留キューにあるドキュメントを再送信するため。通常、この作業を行うのは、保留になった原因を解決した後にメッセージを再送信するときです。たとえば、トランスポートの問題によって、いくつかのメッセージが保留になっている場合は、問題を解決した後に再送信することで、メッセージを正常に送信できるはずです。
  • ドキュメントの削除
 保留キューに入れられたドキュメントを削除するため。この作業は、メッセージが必要なくなったか、ユーザーによってメッセージが保存されていることが前提になります。
サーバー グループのデータベースの管理 :
  • BizTalk Server インターチェンジ アプリケーションのシャットダウン
 BizTalk メッセージ管理データベース、追跡データベース、または、共有キュー データベースへの接続を変更するため。
  • 追跡データベースと共有キュー データベースの削除
 追跡データベースと共有キュー データベースを削除するため。通常、この作業を行うのは、異なる追跡データベースや共有キュー データベースを使用するように BizTalk Server を構成したときだけです。異なるデータベースを使用するように BizTalk Server を構成することなく、これらのデータベースを削除した場合、BizTalk Server は正しく動作しなくなります。
  • 追跡データベースの手動による復元
 追跡データベースが破損した場合。この作業は、以前に作成したバックアップを利用してデータベースを復元できることが前提になります。
  • 共有キュー データベースの手動による復元
 共有キュー データベースが破損した場合。この作業は、以前に作成したバックアップを利用して復元できることが前提になります。
サーバー グループの受信機能の管理 :
  • ファイル受信機能の追加
 ファイル受信機能を作成するため。
  • ファイル受信機能の構成 : [全般] タブ
 ファイル受信機能の全般プロパティを構成するため。セキュリティ情報や、ファイル受信機能の有効化、無効化などを構成します。
  • ファイル受信機能の構成 : [サービス] タブ
 ファイル受信機能を実行しているサーバー、ポーリング情報、またはファイル受信機能が使用するプリプロセッサを変更するため。
  • メッセージ キュー受信機能の追加
 メッセージ キュー受信機能を作成するため。
  • メッセージ キュー受信機能の構成 : [全般] タブ
 メッセージ キュー受信機能の全般プロパティを構成するため。セキュリティ情報や、メッセージ キュー受信機能の有効化、無効化などを構成します。
  • メッセージ キュー受信機能の構成 : [サービス] タブ
 メッセージ キュー受信機能を実行しているサーバー、ポーリング情報、またはメッセージ キュー受信機能が使用するプリプロセッサを変更するため。
  • HTTP 受信機能の追加
 HTTP 受信機能を作成するため。受信トランスポートを正しく動作させるために、この作業の後に「IIS の保護レベルを利用したアクセス特権の構成」の作業を行う必要があります。
  • HTTP 受信機能の構成 : [全般] タブ
 HTTP 受信機能を有効または無効にするため。
  • HTTP 受信機能の構成 : [サービス] タブ
 HTTP 受信機能のサービスの構成を変更するため。たとえば、HTTP 受信機能を実行するサーバー、使用する仮想ディレクトリ、HTTP 受信機能の送信先、関連付けトークンの使用有無などの構成を変更します。
  • ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成
 受信機能の詳細プロパティを構成するため。詳細プロパティには、オープンネス レベル名、エンベロープ名、チャネル名や、送信元組織、送信先組織の情報などがあります。詳細プロパティは、受信機能の作成時か、必要時に構成できます。
  • IIS の保護レベルを利用したアクセス特権の構成
 この作業は、受信トランスポートを正しく機能させるため HTTP 受信機能を作成した後で実行する必要があります。
  • 受信機能の削除
 受信機能を恒久的に削除するため。
BizTalk サービスの管理 :
  • BizTalk サービスの開始
 関連付けられたサーバー上の BizTalk サービスを開始するため。サービスを開始することで、関連付けられたサーバーでのメッセージの処理が有効になります。サービスを開始できるのは、サーバーが停止状態になっているときだけです。
  • BizTalk サービスの停止
 関連付けられたサーバー上の BizTalk サービスを停止するため。サービスを停止することで、関連付けられたサーバーでのメッセージの処理が停止します。サービスを停止できるのは、サーバーが実行中の状態のときだけです。通常、サービスを停止するのは処理を一時的に停止するためで、構成を変更するときや、トラブルシューティングのときに利用します。
イベント ビューアの管理 :
  • BizTalk Server エラーのためのイベント ビューアの構成
 アプリケーション イベント ログに BizTalk Server イベントと XLANG スケジューラ イベントだけを表示するか、またはそのいずれかだけを表示するため。通常、この作業を行うのは、BizTalk Server 以外のイベントが多数あり、トラブルシューティングの際にほかのイベントを表示したくないときです。
  • イベント ビューアでのアプリケーションに関連するエラーの表示
 イベント ビューアに出力されたエラー メッセージを参照するため。
XLANG アプリケーションとデータベースの管理 :
  • ストアド プロシージャを使用したステータス保存データベースからのレコードの削除
 ステータス保存データベースから永続的に保存されている古いドキュメントを削除するため。
  • すべての XLANG アプリケーションのシャットダウン
 すべての XLANG COM+ アプリケーションに関連付けられた、すべての XLANG スケジュールに対してシャットダウンの制御を実行するため。これを実行すると、実行中の XLANG スケジュールのステータスが、すべてステータス保存データベースに保存されます。
  • すべての XLANG アプリケーションの再起動
 すべての XLANG COM+ アプリケーションに対して再起動の制御を実行するため。
既定の XLANG スケジューラ アプリケーションの管理 :
  • 既定の XLANG スケジューラ アプリケーションのアプリケーション ID の変更
 BizTalk Server を最初にインストールしたとき、XLANG スケジューラ COM＋ アプリケーションは、対話型ユーザーのアカウントを使って実行するように構成されます。XLANG スケジューラ エンジンは、対話ユーザーがログオンしていないときにだけ利用できます。したがって、XLANG スケジューラ COM+ アプリケーションは特定の Windows アカウントで実行するように構成する必要があります。
XLANG スケジュールをホストするそのほかの COM+ アプリケーションの管理 :
  • 新しい空のステータス保存データベースの作成
 新しいステータス保存データベースを既定設定で作成するため。
  • COM+ アプリケーションのアプリケーション ID の変更
 COM+ アプリケーションの既定の対話ユーザー アカウントを変更するため。
  • COM+ アプリケーションの DSN 設定の変更
 COM+ アプリケーションに対するデータ ソース名 (DSN) の設定を変更し、新しい空のステータス保存データベースの構造を作成するため。
  • XLANG スケジュールをホストする COM+ アプリケーションのシャットダウン
 特定の COM+ XLANG アプリケーションに関連付けられた、すべての XLANG スケジュールに対してシャットダウンの制御を実行するため。これを実行すると、XLANG スケジュールのステータスが、ステータス保存データベースに保存されます。
  • 実行中の XLANG スケジュールの監視
 このトピックでは、実行中の XLANG スケジュールの状態を監視するために利用できるツールについて説明します。


BizTalk Server 管理コンソールに関する作業を行う方法

ここでは、BizTalk Server 管理コンソールの使用について、作業ごとに説明します。「BizTalk Server 管理コンソールについて」を参照し、BizTalk Server 管理コンソールのすべての機能について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • BizTalk Server 管理コンソールを開く

  • コンポーネント サービスを開く

  • Active Directory への BizTalk Server 2002 の公開

  • Active Directory からの BizTalk Server 2002 の削除

  • BizTalk Server Administrators グループへのユーザーの追加

  • BizTalk メッセージ管理データベースの構成

  • クライアント インストールで管理される BizTalk メッセージ管理データベースの変更

  • 管理コンソールの更新

  • サーバー グループの追加、削除、および構成

  • グループ内のサーバーの追加、削除、および構成

  • グループ内のサーバーの管理

  • キューの管理

  • サーバー グループのデータベースの管理

  • サーバー グループの受信機能の管理

  • BizTalk サービスの管理

  • イベント ビューアの管理

  • XLANG アプリケーションとデータベースの管理


BizTalk Server 管理コンソールを開く

BizTalk Server の管理作業のほとんどは、BizTalk Server 管理コンソール用 Microsoft 管理コンソール (MMC) スナップインで実行します。

  • [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk Server 管理コンソール] をクリックします。


[コンポーネント サービス] を開く

いくつかの管理作業には、[コンポーネント サービス] を使用する必要があります。

  • [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。


Active Directory への BizTalk Server 2002 の公開

BizTalk Server 2002 をインストールすると、分散環境で BizTalk Server を検出して利用するためにMicrosoft® Active Directory™ に公開することができます。たとえば、どのコンピュータで BizTalk Server が実行されているかを把握する必要があります。BizTalk Server 2002 を Active Directory に公開することで、BizTalk Server の実行されているコンピュータを特定できるようになります。

  1. [スタート] メニューをクリックし、[ファイル名を指定して実行] をクリックします。

  2. [名前] ボックスに「cmd」と入力し、[OK] をクリックします。

  3. コマンド プロンプトで、BizTalk Server 2002 の Setup フォルダにディレクトリを変更します。

    例 : コマンド プロンプトで、「cd \Program Files\Microsoft BizTalk Server\Setup」と入力し Enter キーを押します。

  4. コマンド プロンプトで、「cscript AD_registration.vbs」と入力し、Enter キーを押します。

  5. 確認を求めるダイアログ ボックスが表示されたら、[OK] をクリックします。

  6. コマンド プロンプトで「exit」と入力し、Enter キーを押します。

注

  • AD_registration.vbs スクリプトは、リモート コンピュータで使用するように設計されていません。このスクリプトはローカル コンピュータで実行することを推奨します。リモート コンピュータの登録が必要になった場合には、次の変更が必要です。
    • AD_registration.vbs スクリプト内の ServerName 変数の値を、リモート コンピュータの名前に変更します。この変更によって、ローカル コンピュータは、登録するリモート コンピュータの Windows Management Instrumentation (WMI) プロバイダを呼び出します。リモート コンピュータの WMI プロバイダによって、対応するコードが実装されます。


Active Directory から BizTalk Server 2002 を削除する

コンピュータから BizTalk Server 2002 を削除するとき、BizTalk Server の登録は自動的に Active Directory から削除されません。BizTalk のサーバー コンピュータの登録は、Active Directory から削除する必要があります。これにより、Active Directory で照会したときに、BizTalk Server を実行するコンピュータだけが識別されるようになります。

  1. [スタート] メニューをクリックし、[ファイル名を指定して実行] をクリックします。

  2. [名前] ボックスに「cmd」と入力し、[OK] をクリックします。

  3. コマンド プロンプトで、BizTalk Server 2002 の Setup フォルダにディレクトリを変更します。

    例 : コマンド プロンプトで、「cd \Program Files\Microsoft BizTalk Server\Setup」と入力し Enter キーを押します。

  4. コマンド プロンプトで、「cscript AD_registration.vbs /u」と入力し、Enter キーを押します。

  5. 確認を求めるダイアログ ボックスが表示されたら、[OK] をクリックします。

  6. コマンド プロンプトで「exit」と入力し、Enter キーを押します。


BizTalk Server Administrators グループへのユーザーの追加

BizTalk Server Administrators グループにユーザーを追加するには、Windows 2000 のローカルでの Administrators グループのメンバである必要があります。Windows 2000 のローカルでの Administrators グループへのユーザーの追加の詳細については、Windows 2000 ヘルプの 「ユーザーをグループに追加する」を参照してください。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. [システム ツール] を展開し、[ローカル ユーザーとグループ] を展開します。次に、[グループ] フォルダをクリックします。

    詳細ウィンドウにフォルダの内容が表示されます。

  3. 詳細ウィンドウで [BizTalk Server Administrators] をクリックします。

  4. [操作] メニューの [すべてのタスク] をポイントし、[グループに追加] をクリックします。

    [BizTalk Server Administrators のプロパティ] ダイアログ ボックスが表示されます。

  5. [追加] をクリックします。

  6. [場所] ボックスの一覧で、ドメイン名またはコンピュータ名をクリックします。

  7. 手順 6. で選択したドメインまたはコンピュータと関連付けられたユーザーまたはコンピュータを含む一覧で、追加するユーザー アカウントをクリックし、[追加] をクリックします。次に [OK] をクリックします。

  8. [OK] をクリックして、[BizTalk Server Administrators のプロパティ] ダイアログ ボックスを閉じます。

関連項目

管理者特権


BizTalk メッセージ管理データベースの構成

BizTalk メッセージ管理データベースをメンテナンスの目的でオフラインにする場合に、この操作を行います。BizTalk メッセージ管理データベースのメンテナンス中に BizTalk Server の動作を停止することなく継続するには、BizTalk メッセージ管理データベースをレプリケートして、すべてのサーバーをこのレプリカにアクセスさせる必要があります。

注

  • サーバーを元のデータベースのレプリカ以外のデータベースにアクセスさせると、メンテナンスの終了後、元の BizTalk メッセージ管理データベースの構成に戻すことが困難になります。この方法は推奨できません。

データベースの変更の詳細については、「BizTalk メッセージ管理データベースの変更」を参照してください。

  1. Microsoft BizTalk Server 2002 ノードのすべてのサーバーを停止します。

    詳細については、「グループ内のサーバーの停止」を参照してください。

  2. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    [Microsoft BizTalk Server 2002 のプロパティ] ダイアログ ボックスが表示されます。

  4. [全般] プロパティ ページで、次のプロパティを変更することができます。
    • [SQL データベース名] : 元のデータベースがオフラインになっているときに、すべてのサーバー グループで使用する BizTalk メッセージ管理データベースのレプリカの名前を入力します。

    • [SQL Server 名] : Microsoft® SQL Server™ データベースのレプリカが格納されているサーバー名を入力します。
  5. [OK] をクリックします。

  6. BizTalk Server インターチェンジ アプリケーションをシャットダウンします。

    詳細については、「BizTalk Server インターチェンジ アプリケーションのシャットダウン」を参照してください。

  7. Microsoft BizTalk Server 2002 ノードのすべてのサーバーを再起動します。

    詳細については、「グループ内のサーバーの起動」を参照してください。

  8. BizTalk メッセージ サービスを再開します。

    詳細については、「BizTalk サービスの開始」を参照してください。

注

  • BizTalk メッセージ管理データベースを変更したり、別の Microsoft SQL Server にサーバー グループを指定すると、BizTalk メッセージ管理データベース内のすべての BizTalk Server サーバーは新しい情報で更新されます。

  • BizTalk Server インターチェンジ アプリケーションは、次にメッセージが IInterchange COM+ インターフェイスによって送信されたときに自動的に再起動されます。

  • Microsoft BizTalk Server 2002 では、SQL Server へのアクセスに Microsoft Windows® 統合認証を使用します。したがって、BizTalk サービスはSQL Server へのアクセスが許可されたドメイン アカウントかローカル アカウントによって実行する必要があります。BizTalk Server メッセージ サービス アカウントが使用するサービス アカウントのパスワードを変更する場合には、コマンド ライン ユーティリティを使って BizTalk Server メッセージ サービス アカウントのパスワードを変更する必要があります。サービス アカウントのパスワードの変更については、「サービス アカウント パスワードの変更」を参照してください。

関連項目

BizTalk メッセージ管理データベースの変更

BizTalk サービスの管理

BizTalk Server インターチェンジ アプリケーションのシャットダウン

グループ内のサーバーの起動

グループ内のサーバーの停止


クライアント インストールで管理される BizTalk メッセージ管理データベースの変更

ここで説明する手順では、クライアント コンピュータからBizTalk Server のクライアント インストールを使用して管理されている BizTalk メッセージ管理データベースを変更します。ただし、この手順では、BizTalk Server ランタイムがポイントする BizTalk メッセージ管理データベースは変更しません。BizTalk Server ラン タイムがポイントする BizTalk メッセージ管理データベースを変更する場合には、「BizTalk メッセージ管理データベースの構成」を参照してください。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] をクリックします。

  2. [操作] メニューの [構成データベースの選択] をクリックします。

    [管理データベースの選択] ダイアログ ボックスが表示されます。

  3. [SQL データベース名] ボックスに、クライアント コンピュータから管理する BizTalk メッセージ管理データベースの名前を入力します。

  4. [SQL Server 名] ボックスに、Microsoft SQL Server データベースを格納するサーバーの名前を入力します。この SQL Server データベースは、管理対象の BizTalk メッセージ管理データベースを格納するデータベースです。

  5. [OK] をクリックします。

注

  • この方法は、BizTalk Server のクライアント インストールでのみ利用できます。

関連項目

BizTalk Server クライアント インストールの管理機能


管理コンソールの更新

管理コンソールには自動更新の機能がないため、次の項目の現在のステータスを表示するにはここで説明する作業を行う必要があります。

  • Microsoft BizTalk Server 2002 ノード

  • サーバー グループ

  • サーバー

  • キュー

  • 受信機能
  1. BizTalk Server 管理コンソールで、[Microsoft BizTalk Server 2002] を展開します。更新する項目が表示されるまでコンソール ツリーの項目を展開していきます。

  2. 更新する項目を見つけるには、[サーバー グループ]、[キュー]、[受信機能]、および [サーバー] の展開が必要になる場合もあります。

  3. 更新する項目をクリックします。

  4. [操作] メニューの [最新の情報に更新] をクリックします。

注

  • この操作は、コンソール ツリーの任意の項目で実行することができます。ルートで管理コンソールを更新すると、管理コンソール内のすべての項目が更新されます。サーバー グループを更新すると、そのグループ内の項目だけが更新されます。

関連項目

グループとサーバー

受信機能

キューの使用


サーバー グループの追加、削除、および構成

サーバー グループとは、集中的に管理、構成、および監視されるサーバーの集合です。サーバー グループは、BizTalk Server の拡張性を向上させるための重要な手段です。新しいサーバー グループを作成することで、より多くのコンピュータが含まれるように処理を分離してスループットを向上させることができます。BizTalk Server グループ内のサーバーは、次のものを共有しています。

  • 正常に処理されるまですべてのドキュメントを保存する 共有キュー データベース。

  • ドキュメントとインターチェンジの利用状況をログに記録し、レポートを作成するために使用する追跡データベース。

  • 受信機能。

  • トランスポート コンポーネントやアプリケーション統合コンポーネント (AIC) など、サーバーがドキュメントとインターチェンジの処理時に要求するすべてのコンポーネント。

ここには次のトピックが含まれます。

  • サーバー グループの追加

  • サーバー グループの全般プロパティの構成

  • サーバー グループの接続のプロパティの構成

  • サーバー グループの追跡のプロパティの構成

  • サーバー グループのパーサー順序の構成

  • サーバー グループの削除

注

  • スケーラビリティやパフォーマンスを向上するために複数のサーバー グループを設定する場合は、BizTalk メッセージ管理データベースを 1 つだけ使用します。複数のメッセージ管理データベースを使用すると、サーバーは同じ BizTalk メッセージ管理構成を共有することができません。


サーバー グループの追加

ビジネスの変更が必要になったときなど、現在の要求に合わせてパフォーマンスを最適化するために BizTalk Server グループの再構築が必要になることがあります。これを実現するには、組織の管理を改善するために新しいサーバー グループを追加することが必要になる場合があります。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] をクリックします。

  2. [操作] メニューの [新規作成] をポイントし、[グループ] をクリックします。

    [新しいグループ] ダイアログ ボックスが表示されます。

  3. [グループ名] ボックスに新しいサーバー グループの名前を入力します。

  4. [追跡データベース] で次の操作を行います。
    • [追跡データベース名] ボックスに、このサーバー グループの追跡データベースの名前を入力します。

    • [追跡 SQL Server 名] ボックスに、このサーバー グループの追跡データベースが格納されているサーバーの名前を入力します。
  5. [共有キュー データベース] で次の操作を行います。
    • [共有キュー データベース名] ボックスに、このサーバー グループの共有キュー データベースの名前を入力します。

    • [共有キュー SQL Server 名] ボックスに、このサーバー グループの共有キュー データベースが格納されているサーバーの名前を入力します。
  6. [OK] をクリックします。

重要

  • サーバー グループの名前に次の文字を使用することはできません。

    ~ ` ! @ # $ % ^ & * ( ) + = [ ] { } | ;\" '< > , . ?.

    無効な文字の詳細については、「Windows Management Instrumentation (WMI)」を参照してください。

注

  • これはサーバー グループを作成するための操作です。設定を追加してサーバー グループを構成するには、「サーバー グループの全般プロパティの構成」を参照してください。

  • スケーラビリティやパフォーマンスを向上するために複数のサーバー グループを設定する場合は、中央 BizTalk メッセージ管理データベースを 1 つだけ使用します。複数のメッセージ管理データベースを使用すると、サーバーは同じ BizTalk メッセージ管理構成を共有することができません。

  • Microsoft BizTalk Server 2002 では、SQL Server へのアクセスに Microsoft Windows 統合認証を使用します。したがって、BizTalk サービスはSQL Server へのアクセスが許可されたドメイン アカウントかローカル アカウントによって実行する必要があります。BizTalk Server メッセージ サービス アカウントが使用するサービス アカウントのパスワードを変更する場合には、コマンド ライン ユーティリティを使って BizTalk Server メッセージ サービス アカウントのパスワードを変更する必要があります。サービス アカウントのパスワードの変更については、「サービス アカウント パスワードの変更」を参照してください。

関連項目

グループ内のサーバーの追加、削除、および構成

サーバー グループの全般プロパティの構成

グループとサーバー

BizTalk メッセージ管理データベースの管理

共有キュー データベース

追跡データベース

Windows Management Instrumentation (WMI) について


サーバー グループの全般プロパティの構成

この手順では、特定のサーバー グループの全般プロパティを構成します。これにより異なったサーバー グループで処理を分離させることができます。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、構成するサーバー グループをクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  3. [SMTP ホスト] ボックスに、このサーバー グループで使用する SMTP ホスト名を入力します。

    重要

    • [SMTP ホスト] フィールドは省略できます。ただし、BizTalk メッセージ マネージャでトランスポート サービスとして SMTP を使用する場合は、このフィールドを構成する必要があります。たとえば、ここで SMTP ホストを構成しないと、BizTalk メッセージ マネージャでプライマリ トランスポートまたはバックアップ トランスポートとして SMTP を選択することができません。
  4. [信頼できるメッセージの返信先 URL] ボックスに、URL を入力します。この URL は、サーバー グループがファイル、メッセージ キュー、HTTP、HTTP/S、SMTP のいずれかのサポートされているプロトコルを使用して、信頼できるメッセージの受信確認を受信するために使用するものです。
    トランスポートの種類 | 使用するプレフィックス
    ファイル | file://
    メッセージ キュー | queue://Direct=OS:<servername>\<queuename>
    HTTP (Hypertext Transfer Protocol) | http://
    HTTPS (Secure Hypertext Transfer Protocol) | https://
    SMTP (Simple Mail Transfer Protocol) | mailto:

    メッセージ キューを指定する場合は、書式名を使用します。また、書式名の前に「queue://」を付ける必要があります。書式名の詳細については、「利用可能な受信機能」を参照してください。

  5. [メッセージ管理オブジェクト キャッシュの更新間隔 (秒)] ボックスの一覧で、サーバー グループのキャッシュ更新間隔に設定する秒数をクリックします。

    この値の範囲は、1 ～ 300 秒です。既定では、サーバーは 50 秒ごとにこのキャッシュを更新します。

  6. プロキシ サーバーを経由してインターネットに接続するように BizTalk Server を構成する場合は、[プロキシ サーバー] で [プロキシ サーバーを使用] チェック ボックスをオンにします。

    使用するプロキシ サーバーのアドレス、ポート、ユーザー名:、およびパスワードを入力します。

  7. [OK] をクリックします。

  8. [プロキシ サーバー] に変更を加えた場合にのみ、次の操作を行います。
    • 一般プロパティを構成したグループ内の各サーバーを停止します。サーバーの停止の詳細については、「グループ内のサーバーの停止」を参照してください。

    • 一般プロパティを構成したグループ内の各サーバーを起動します。サーバーの起動の詳細については、「グループ内のサーバーの起動」を参照してください。

注

  • BizTalk Server で信頼できるメッセージ処理は、BizTalk フレームワーク2.0 に準拠しているものです。信頼できるメッセージ処理と BizTalk フレームワーク2.0 の詳細については、Microsoft の Web サイト (www.microsoft.com/japan/biztalkserver/) で「BizTalk フレームワーク2.0」を検索してください。

  • [信頼できるメッセージの返信先 URL] を構成する場合は、Active Server Pages (ASP) を利用したページ、または受信機能によって監視されるメッセージ キューを使用します。最初に独自の ASP ページを構成しない場合は、BizTalk Server に含まれる ReceiveStandard.asp ファイルを使用します。このサンプル ASP ページは \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts にあります。このページはポストを取得し、BizTalk Server に送信するためのものです。セキュリティで保護されたサイトの実装の詳細については、MSDN Online Library の Web サイト (www.msdn.microsoft.com/library/default.asp) にアクセスして、記事「Implementing a Secure Site with ASP」を検索してください。

  • [信頼できるメッセージの返信先 URL] ボックスに localhost を含む URL を指定すると、受信機能は正しく動作しません。このフィールドにローカル ホストを指定することはできません。

  • HTTP ポストへの応答はテキストにする必要があります。応答がバイナリ データを要求する場合は、MIME または Uuencode を使用してバイナリ データをエンコードします。

  • 信頼できるメッセージへの受信確認の返送には、Unicode を使用してエンコードする必要があります。

関連項目

管理キャッシュ

利用可能な受信機能

グループ内のサーバーの起動

グループ内のサーバーの停止


サーバー グループの接続のプロパティの構成

ここで説明する手順では、BizTalk Server グループが使用する追跡データベースと共有キュー データベースを変更します。通常、これらの構成の変更が必要になるのは、ほかのデータベースやサーバーへの変更が要求される場合です。すなわち、障害からの回復やエンジンのバックアップの部分的な作業として行います。

  1. 構成する BizTalk Server グループ内のすべてのサーバーを停止します。

    詳細については、「グループ内のサーバーの停止」を参照してください。

  2. BizTalk Server インターチェンジ アプリケーションをシャットダウンします。

    詳細については、「BizTalk Server インターチェンジ アプリケーションのシャットダウン」を参照してください。

  3. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、構成するサーバー グループをクリックします。

  4. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  5. [接続] タブをクリックします。

  6. [追跡データベース] で次の操作を行います。
    • [追跡データベース名] ボックスに、このサーバー グループで使用する追跡データベースの名前を入力します。

    • [追跡 SQL Server 名] ボックスに、このサーバー グループで使用する追跡データベースを格納している Microsoft SQL Server の名前を入力します。
  7. [共有キュー データベース] で次の操作を行います。
    • [共有キュー データベース名] ボックスに、このサーバー グループで使用する共有キュー データベースの名前を入力します。

    • [共有キュー SQL Server 名] ボックスに、このサーバー グループで使用する共有キュー データベースを格納している Microsoft SQL Server の名前を入力します。
  8. [OK] をクリックします。

  9. 構成した BizTalk Server グループ内のすべてのサーバーを再起動します。

    詳細については、「グループ内のサーバーの起動」を参照してください。

注

  • Microsoft BizTalk Server 2002 では、SQL Server へのアクセスに Microsoft Windows 統合認証を使用します。したがって、BizTalk サービスは SQL Server へのアクセスが許可されたドメイン アカウントかローカル アカウントによって実行する必要があります。BizTalk Server メッセージ サービス アカウントが使用するサービス アカウントのパスワードを変更する場合には、コマンド ライン ユーティリティを使って BizTalk Server メッセージ サービス アカウントのパスワードを変更する必要があります。サービス アカウントのパスワードの変更については、「サービス アカウント パスワードの変更」を参照してください。

  • [追跡データベース] の値を変更する場合は、Connection.vbs ファイルの接続文字列を新しい追跡データベース情報で更新する必要があります。Connection.vbs は、\Program Files\Microsoft BizTalk Server\BizTalkTracking\VBScripts フォルダにあります。接続文字列の Initial Catalog プロパティには、その追跡データベースの名前が含まれています。このプロパティを更新して、追跡データベース名を更新します。次に、Connection.vbs ファイルの接続文字列を示します。
    Const g_ConnectionString = "Provider=SQLOLEDB.1;
Persist Security Info=False;Integrated Security=SSPI;
Initial Catalog=<databasename>;
Data Source=<servername>;Connect Timeout=15"

    接続文字列の Data Source プロパティには、この追跡データベースをホストする SQL Server の名前が含まれています。このプロパティは、追跡データベースに対する正しい SQL Server 名を反映するように更新する必要があります。

関連項目

利用可能な受信機能

グループとサーバー

BizTalk Server インターチェンジ アプリケーションのシャットダウン

グループ内のサーバーの起動

グループ内のサーバーの停止


サーバー グループの追跡のプロパティの構成

サーバー グループの追跡設定では、インターチェンジの追跡を有効にするか無効にするかを指定します。Microsoft BizTalk Server 2002 をインストールすると、ドキュメント トラッキングが自動的に有効になり、[受信インターチェンジを記録する] および [送信インターチェンジを記録する] のオプションが選択され、インターチェンジのメタデータが追跡されます。次の手順では、追跡プロパティをカスタマイズします。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、構成するサーバー グループをクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  3. [追跡] タブをクリックします。

  4. [ドキュメント トラッキングを有効にする] チェック ボックスと、使用する次のいずれかのオプションのチェック ボックスをオンにします。
    • 受信インターチェンジをログに記録するには、[受信インターチェンジを記録する] チェック ボックスをオンにします。

    • 送信インターチェンジをログに記録するには、[送信インターチェンジを記録する] チェック ボックスをオンにします。

    • MIME エンコード メッセージをログに記録するには、[元の MIME エンコード メッセージを記録する] チェック ボックスをオンにします。
  5. [OK] をクリックします。

注意

  • [ドキュメント トラッキングを有効にする] チェック ボックスをオフにすると、ドキュメント トラッキングの機能を無効にすることができます。ただし、ドキュメント トラッキングを無効にすると、BizTalk Server 2002 の重要な機能を失うことになります。追跡の詳細については、「サーバー グループの追跡設定について」を参照してください。

注

  • [ドキュメント トラッキングを有効にする] チェック ボックスがオフになっている場合は、[受信インターチェンジを記録する] チェック ボックス、[送信インターチェンジを記録する] チェック ボックス、および [元の MIME エンコード メッセージを記録する] チェック ボックスは利用できません。

関連項目

グループとサーバー

サーバー グループの追跡設定について


サーバー グループのパーサー順序の構成

BizTalk Server は、ドキュメントを受信するとパーサーの一覧にある順序でドキュメントを解析します。パーサーの一覧の順序は変更することができ、最も使用するパーサーをパーサーの一覧の先頭に置くことで、スループットを最適化できます。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、パーサーの順序を構成するサーバー グループをクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  3. [パーサー] タブをクリックします。

    パーサーは [サーバーの呼び出し順序の整列] ボックスに、次の順序で一覧表示されます。

    • BizTalk.ParserXML.1

    • BizTalk.ParserEdifact.1

    • BizTalk.ParserX12.1

    • BizTalk.ParserFFile.1
  4. [サーバーの呼び出し順序の整列] ボックスで、移動するパーサーをクリックします。上矢印または下矢印のボタンをクリックして、選択したパーサーを上または下に移動します。

  5. パーサーを希望する順序に整列したら、[OK] をクリックします。

注

  • [最新の情報に更新] をクリックすると、ローカル レジストリに登録された新しいパーサーを取得できます。新しいパーサーを [サーバーの呼び出し順序の整列] ボックスに表示するには、そのパーサーが登録されているサーバーで [最新の情報に更新] をクリックします。

  • パーサーの一覧は、リモート サーバーから更新できません。カスタム パーサーを登録したとき、パーサーの一覧を更新できるのは登録を行ったサーバーだけです。

  • BizTalk Server のクライアント インストールだけをインストールしているコンピュータでは [パーサー] タブは使用可能になりません。

関連項目

Parsers


サーバー グループの削除

ビジネスの変更が必要になったときなど、現在の要求に合わせてパフォーマンスを最適化するために BizTalk Server グループの再構築が必要になることがあります。これには、一部のサーバー グループを削除して、それらのグループに属していたサーバーをより多くのリソースを必要としている運用システムのほかの領域に移動することが必要になる場合があります。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、削除するサーバー グループを展開します。

  2. 削除するサーバー グループにあるサーバーをクリックします。

  3. [操作] メニューの [停止] をクリックします。

    グループ内のサーバーそれぞれに対して手順 2. と 3. の操作を繰り返し、グループ内のすべてのサーバーを停止します。

  4. サーバー グループをクリックします。

  5. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  6. [はい] をクリックします。

注

  • 1 つ以上の実行中のサーバーを含むサーバー グループを削除することはできません。サーバーを停止し、サーバー グループを削除するには、グループ内のすべてのサーバーに対する Windows 2000 管理者特権が必要です。

  • サーバー グループに関連付けられた追跡データベースと共有キュー データベースは、グループを削除した後も Microsoft SQL Server 内に残ります。この追跡データベースと共有キュー データベースを削除するには、手動で削除します。これらのデータベースを削除する方法の詳細については、「追跡データベースと共有キュー データベースの削除」を参照してください。

関連項目

グループとサーバー

追跡データベースと共有キュー データベースの削除

グループ内のサーバーの停止


グループ内のサーバーの追加、削除、および構成

サーバー グループ内のサーバーは、サーバーのパフォーマンスを均等化して最大のスループットを得ることができるように構成します。ビジネスの変更が必要になったときなど、現在の要求に合わせてパフォーマンスを最適化するために BizTalk Server グループの再構築が必要になることがあります。これには、グループに新しいサーバーを追加したり、サーバーをあるグループからほかのグループに移動したり、BizTalk Server のインストール時に構成されたサーバーの設定を調整したりすることが必要になる場合があります。たとえば、より多くのドキュメントをより速く処理することが要求される場合があります。また、グループ内のサーバーをインターチェンジとドキュメントだけを受信するように構成することが必要になる場合もあります。

「BizTalk Server 管理コンソールについて」の「BizTalk サーバー」を参照し、BizTalk Server について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • グループへのサーバーの追加

  • グループからのサーバーの削除

  • グループ内のサーバーの構成

  • サーバーの BizTalk メッセージ管理データベースの変更

注

  • サーバーのプロパティを調整するときには、本番運用の BizTalk Server のプロパティを変更する前に、テスト環境でさまざまな組み合わせの設定を試してください。


グループへのサーバーの追加

この作業では、既に構成されている BizTalk Server グループへ BizTalk Server を追加します。各グループには、任意の数のサーバーを関連付けることができます。したがって、グループ内のサーバー数を最適化することで、データベースの置かれたサーバーの処理性能に関するスループットを最大化できます。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、サーバーを追加するサーバー グループをクリックします。

  2. [操作] メニューの [新規作成] をポイントし、[サーバー] をクリックします。

    [BizTalk Server の追加] ダイアログ ボックスが表示されます。

  3. [BizTalk Server 名] ボックスに、BizTalk Server 2002 のインストールを完了した既存のサーバーの名前を入力します。

  4. [OK] をクリックします。

重要

  • グループ内のすべてのサーバーには、同じバージョンおよび言語の BizTalk Server がインストールされていなければなりません。グループ内のサーバーで異なるバージョンのBizTalk Server (BizTalk Server 2000、BizTalk Server 2000 SP 1、BizTalk Server 2002 Enterprise Edition、または異なる言語バージョンの BizTalk Server など) がインストールされていると、データベースは正常に機能しません。

注

  • サーバーを追加したサーバー グループのプロパティ全体を表示するには、そのグループを右クリックし、[プロパティ] をクリックします。

  • 追加するサーバーにインストールされている BizTalk Server のバージョンは、サーバー グループに既に追加されているサーバーと同じでなければなりません。

関連項目

グループとサーバー

グループ内のサーバーの管理

サーバーのプロパティについて


グループからのサーバーの削除

ビジネスの変更が必要になったときなど、現在の要求に合わせてパフォーマンスを最適化するために BizTalk Server グループの再構築が必要になることがあります。これには、一部のサーバー グループを削除して、それらのグループに属していたサーバーをより多くのリソースを必要としている運用システムのほかの領域に移動することが必要になる場合があります。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、削除するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

    サーバーの現在のインターチェンジとドキュメントに対するすべての処理が終了します。

  3. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  4. [はい] をクリックします。

注

  • 受信機能がドキュメントの処理のためにポイントしているサーバーは、サーバー グループから削除することができません。ほかのサーバーをポイントするようにその受信機能を編集するか、今後使用しない場合はその受信機能を削除します。

関連項目

サーバーからのインターチェンジの解放

グループとサーバー

サーバー グループの受信機能の管理

グループ内のサーバーの管理


グループ内のサーバーの構成

ここで説明する手順では、特定のサーバーの [全般] プロパティを構成します。作業項目の処理に参加していないサーバーに受信機能を作成すると、BizTalk Server のスループットが向上します。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、構成するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

    サーバーが実行中のときは、構成を変更することはできません。

  3. [操作] メニューの [プロパティ] をクリックします。

    [<コンピュータ名> のプロパティ] ダイアログ ボックスが表示されます。

  4. [使用可能な受信機能スレッドの最大数] ボックスに、1 から 128 までの範囲の数値を入力します。

    既定値は 4 です。このオプションを構成する方法の詳細については、「サーバーのプロパティについて」を参照してください。

  5. サーバーで作業キュー内の項目を処理する場合は、[作業項目の処理に参加する] チェック ボックスをオンにします。

    このチェック ボックスがオンになっていると、サーバーは作業キュー内のドキュメントを処理します。サーバーで作業キュー内のドキュメントを処理しない場合は、このチェック ボックスをオフにします。このオプションを構成する方法の詳細については、「サーバーのプロパティについて」を参照してください。

  6. [プロセッサごとの使用可能な作業スレッドの最大数] ボックスに 1 から 128 までの範囲の数値を入力します。

    既定値は 4 です。このオプションを構成する方法の詳細については、「サーバーのプロパティについて」を参照してください。

  7. [BizTalk Server スケジューラ呼び出しの間隔 (ミリ秒)] ボックスに 1 から 4294967295 までの範囲の数値を入力します。

    既定値は 2000 です。このオプションを構成する方法の詳細については、「サーバーのプロパティについて」を参照してください。

  8. [OK] をクリックします。

  9. 構成したサーバーを右クリックし、[開始] をクリックします。

注

  • [作業項目の処理に参加する] チェック ボックスがオフになっている場合は、[プロセッサごとの使用可能な作業スレッドの最大数] チェック ボックスと [BizTalk Server スケジューラ呼び出しの間隔 (ミリ秒)] チェック ボックスは利用できません。

関連項目

グループとサーバー

グループ内のサーバーの管理

サーバーのプロパティについて


サーバーの BizTalk メッセージ管理データベースの変更

通常、サーバーが使用する BizTalk メッセージ管理データベースの変更が必要になるのは、障害からの回復やデータベースを配置するサーバーの変更など、ほかのデータベースへ恒久的に変更する場合だけです。

重要

  • サーバーを異なる BizTalk メッセージ管理データベースと関連付ける場合に、この操作を行います。BizTalk メッセージ管理データベース間でのサーバーの移動の詳細については、「BizTalk メッセージ管理データベース間でのサーバーの移動」を参照してください。サーバー グループの BizTalk メッセージ管理データベースの変更の詳細については、「BizTalk メッセージ管理データベースの変更」を参照してください。
  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、BizTalk メッセージ管理データベースを変更するサーバーが含まれたサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

  3. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  4. [はい] をクリックします。

  5. BizTalk Server 管理コンソールを閉じます。

  6. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[アクセサリ] をポイントし、[エクスプローラ] をクリックします。

  7. \Program Files\Microsoft BizTalk Server\Setup に移動します。

  8. BTSsetupDB.exe をクリックします。

  9. [ファイル] メニューの [開く] をクリックします。

    [Microsoft BizTalk Server 2002 メッセージ データベース セットアップ ウィザード] が表示されます。

  10. [Microsoft BizTalk Server 2002 メッセージ データベース セットアップ ウィザードへようこそ] ページで、[次へ] をクリックします。

  11. [BizTalk メッセージ管理データベースを構成します] ページで、[新しい BizTalk メッセージ管理データベースの作成] をクリックします。

    または

    [既存のデータベースの選択] をクリックします。

  12. [サーバー名] ボックスで、新しい、または既存の BizTalk メッセージ管理データベースがあるサーバーの名前をクリックします。

  13. [データベース] ボックスに、新しい、または既存の BizTalk メッセージ管理データベースの名前を入力します。

  14. [次へ] をクリックします。

  15. [BizTalk Server グループの構成] ページで、[新しい BizTalk Server グループの作成] をクリックします。

    [グループ名] ボックスに新しいグループの名前を入力し、[次へ] をクリックします。

    または

    [既存の BizTalk Server グループの選択] をクリックします。[グループ名] ボックスの一覧で既存のグループの名前をクリックし、[次へ] をクリックします。

    手順 11. で既存のデータベースを選択した場合にだけ、既存の BizTalk Server グループを選択できます。

  16. 必要に応じて、[新しい追跡データベースの作成] をクリックし、[次へ] をクリックします。

    または

    [既存のデータベースの選択] をクリックします。[サーバー名] ボックスの一覧で、サーバーをクリックして [次へ] をクリックします。

  17. 必要に応じて、[新しい共有キュー データベースの作成] をクリックし、[次へ] をクリックします。

    または

    [既存のデータベースの選択] をクリックします。[サーバー名] ボックスの一覧で、サーバーをクリックして [次へ] をクリックします。

  18. [BizTalk Server グループの確認] ページで、入力した情報を確認して [次へ] をクリックします。

  19. [Microsoft BizTalk Server 2002 メッセージ データベース セットアップ ウィザードの完了] ページで [完了] をクリックします。

  20. BizTalk Server 管理コンソールを開きます。

  21. [Microsoft BizTalk Server 2002] を展開し、BizTalk メッセージ管理データベースを変更したサーバーを含むサーバー グループを展開して、対象のサーバーをクリックします。

  22. [操作] メニューの [開始] をクリックします。

    関連項目

    BizTalk メッセージ管理データベースの変更

    BizTalk Server データベースの管理

    BizTalk メッセージ管理データベース間でのサーバーの移動


グループ内のサーバーの管理

ここでは、BizTalk Server グループ内のサーバーを管理する方法について説明します。「BizTalk Server 管理コンソールについて」の「BizTalk サーバー」を参照し、BizTalk Server について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • グループ内のサーバーの起動

  • グループ内のサーバーの停止

  • サーバーからのインターチェンジの解放

  • ディスク キャッシュの構成


グループ内のサーバーの起動

ここで説明する手順では、関連付けられたサーバーにある BizTalk Server の実行時サービスを起動します。この BizTalk Server はインターチェンジの受信や処理に参加できるようになります。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、起動するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [開始] をクリックします。

注

  • サーバー グループ内のサーバーを起動すると、そのサーバーの BizTalk メッセージ サービスも起動します。BizTalk メッセージ サービスが起動した後に、サーバーは Microsoft SQL Server データベースのキューに格納されたドキュメントの受信、送信、処理、および追跡を行うことができます。

  • [開始] はサーバーが停止している場合にのみ利用可能です。サーバーが実行中は利用できません。

関連項目

グループ内のサーバーの追加、削除、および構成

管理キャッシュ

グループとサーバー

グループ内のサーバーの停止


グループ内のサーバーの停止

ここで説明する手順では、関連付けられたサーバーにある BizTalk Server の実行時サービスを停止します。この BizTalk Server はインターチェンジの受信や処理から離脱します。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、停止するサーバーを含むサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

注

  • サーバー グループ内のサーバーを停止すると、そのサーバーの BizTalk メッセージ サービスも停止します。BizTalk メッセージ サービスが停止した後は、サーバーは Microsoft SQL Server データベースのキューに格納されているドキュメントの受信、送信、処理、または追跡を行うことができません。

  • 停止したサーバーに関連付けられているインターチェンジを再配布する場合には、「サーバーからのインターチェンジの解放」を参照してください。

関連項目

グループ内のサーバーの追加、削除、および構成

管理キャッシュ

サーバーからのインターチェンジの解放

グループとサーバー


サーバーからのインターチェンジの解放

ここでは、元のサーバーが停止したり、オフラインになっている場合に、インターチェンジをグループ内のほかのサーバーに再配布できるように、サーバーからインターチェンジを解放する方法について説明します。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、インターチェンジを解放するサーバーの含まれているサーバー グループを展開します。次に、対象のサーバーをクリックします。

  2. [操作] メニューの [停止] をクリックします。

  3. [操作] メニューの [すべてのタスク] をポイントし、[インターチェンジの解放] をクリックします。

  4. [操作] メニューの [開始] をクリックします。

注

  • この作業は、サーバーの状態が、実行中かアクセス拒否のいずれかのときには実行できません。

関連項目

グループ内のサーバーの追加、削除、および構成

グループとサーバー

グループ内のサーバーの停止


ディスク キャッシュの構成

この手順では、ディスク キャッシュを有効または無効にします。ディスク キャッシュが無効になっているときには、電源障害などのサービス上の障害時にもデータの消失を防ぐことができます。ただし、この構成は、BizTalk Server のパフォーマンスを低下させます。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. [コンピュータの管理] ツリーで、[デバイス マネージャ] を展開します。

  3. 右側のペインで、[ディスク ドライブ] をダブルクリックします。

  4. ディスク キャッシュを構成するドライブを右クリックして、[プロパティ] をクリックします。

    [<デバイス名> のプロパティ] 画面が表示されます。

  5. [ディスクのプロパティ] タブをクリックします。

  6. [書き込みキャッシュを有効にする] チェック ボックスをオフにします。

注

  • この手順は、1 台のコンピュータだけのディスク キャッシュ プロパティを変更します。

関連項目

グループ内のサーバーの追加、削除、および構成

グループとサーバー

グループ内のサーバーの停止


キューの管理

ここでは、BizTalk Server でキューを管理する方法について説明します。「キューの使用」を参照し、BizTalk Server キューについて十分に理解しておいてください。

ここには次のトピックが含まれます。

  • 保留キューへのドキュメントの移動

  • エラーの説明の表示

  • インターチェンジの表示

  • ドキュメントの表示

  • ドキュメントの再送信

  • ドキュメントの削除


保留キューへのドキュメントの移動

作業キュー、再送信キュー、または送信待キューにある任意のアイテムは、保留キューに移動できます。インターチェンジやドキュメントを保留キューに移動するのは、これらが処理されてしまうのを防ぐ場合のみです。インターチェンジやドキュメントを保留キューに移動すれば、削除や再送信を行うことができます。また、処理を完了するために作業キューに送信することもできます。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、移動するドキュメントの含まれたグループを展開します。次に、[キュー] を展開します。

  2. 移動するドキュメントを含むキューを展開し、対象のドキュメントをクリックします。

  3. [操作] メニューの [すべてのタスク] をポイントし、[保留キューに移動] をクリックします。

関連項目

保留キュー

キューの使用


エラーの説明の表示

この手順では、ドキュメントが保留キューに入る原因となったエラーの確認方法を示します。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、表示するドキュメントを含むグループを展開します。次に、[キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、表示するドキュメントをクリックします。

  3. [操作] メニューの [エラーの説明の表示] をクリックします。

関連項目

保留キュー

キューの使用

ドキュメントの表示

インターチェンジの表示


インターチェンジの表示

この操作は、解析エラーや転送エラーによって保留キューに置かれたインターチェンジの内容を別の表示ウィンドウを開いて参照するために使用します。この作業は、整合性の問題によって失敗したインターチェンジには無効になります。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、表示するインターチェンジの含まれたグループを展開します。次に [キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、表示するインターチェンジをクリックします。

  3. [操作] メニューの [インターチェンジの表示] をクリックします。

    [ドキュメントの内容] ダイアログ ボックスが表示されます。

注

  • 大きなインターチェンジを表示しようとすると、データが切り捨てられることがあります。[ドキュメントの内容] ダイアログ ボックスで表示できるデータのサイズの上限は 4MB です。

  • BizTalk Server がインターチェンジを解析できなかった場合に、[ドキュメントの内容] ダイアログ ボックスにバイナリ データが表示されることがあります。パーサー エラーの詳細については、「解析エラー」を参照してください。

  • 保留キューが次のステータスの場合、[インターチェンジの表示] を利用できます。
    • [カスタム コンポーネント]

    • [解析]

    • [エンコード]

    • [署名]

    • [暗号化]

    • [送信]
  • [操作] メニューに [インターチェンジの表示] と [ドキュメントの表示] が同時に表示されることはありません。

  • BizTalk Server のクライアント インストールだけをインストールしているコンピュータでは [インターチェンジの表示] は使用可能になりません。

関連項目

インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

保留キュー

キューの使用

ドキュメントの表示

エラーの説明の表示


ドキュメントの表示

この操作は、取引先との契約の問題によって保留キューに置かれたドキュメントの内容を別の表示ウィンドウを開いて参照するために使用します。この作業は、解析エラーや転送エラーによって失敗したドキュメントには無効になります。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、表示するドキュメントを含むグループを展開します。次に、[キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、表示するドキュメントをクリックします。

  3. [操作] メニューの [ドキュメントの表示] をクリックします。

    [ドキュメントの内容] ダイアログ ボックスが表示されます。

注

  • 大きなドキュメントを表示しようとすると、データが切り捨てられることがあります。[ドキュメントの内容] ダイアログ ボックスで表示できるデータのサイズの上限は 4MB です。

  • 保留キューが次のステータスの場合、[ドキュメントの表示] を利用できます。
    • [ドキュメントの検証]

    • [チャネルの選択]

    • [マッピング]

    • [関連付けています]

    • [シリアライズ]
  • [操作] メニューに [ドキュメントの表示] と [インターチェンジの表示] が同時に表示されることはありません。

  • BizTalk Server のクライアント インストールだけをインストールしているコンピュータでは [ドキュメントの表示] タブは使用可能になりません。

関連項目

インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

保留キュー

キューの使用

エラーの説明の表示

インターチェンジの表示


ドキュメントの再送信

この手順では、保留キューに置かれたドキュメントを作業キューに再送信します。通常、この作業は、送信の失敗の原因を解決した後に実行します。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、再送信するドキュメントの含まれたグループを展開します。次に、[キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、再送信するドキュメントをクリックします。

  3. [操作] メニューの [すべてのタスク] をポイントし、[再送信] をクリックします。

注

  • この手順は、ドキュメントを再転送するためにも使用できます。

  • 保留キューにあるすべてのドキュメントが再送信されるわけではありません。場合によっては、ドキュメントを削除してから、元のアプリケーションまたは組織から送信し直す必要があります。保留キューにあるドキュメントの詳細については、「保留キュー」を参照してください。

関連項目

保留キュー

キューの使用


ドキュメントの削除

この手順は、保留キューにあるドキュメントを削除するために使用します。通常、この作業は、メッセージが必要なくなったときか、メッセージを既に保存しているときに実行します。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、削除するドキュメントをの含まれたグループを展開します。次に、[キュー] を展開し、[保留キュー] をクリックします。

  2. 詳細ウィンドウで、削除するドキュメントをクリックします。

  3. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  4. [はい] をクリックします。

関連項目

保留キュー

キューの使用


サーバー グループのデータベースの管理

ここでは、BizTalk Server グループ用のデータベースを管理する方法について説明します。「BizTalk サーバー グループ データベースの管理」を参照し、BizTalk Server データベースについて十分理解しておいてください。

ここには次のトピックが含まれます。

  • BizTalk Server インターチェンジ アプリケーションのシャットダウン

  • 追跡データベースと共有キュー データベースの削除

  • 追跡データベースの手動による復元

  • 共有キュー データベースの手動による復元


BizTalk Server インターチェンジ アプリケーションのシャットダウン

BizTalk Server インターチェンジ アプリケーションは、BizTalk Server へのインターチェンジやドキュメントの送信権限を制限するロールをホストします。インターチェンジ アプリケーションは、BizTalk メッセージ管理データベース、追跡データベース、共有キュー データベースへの接続に変更があった場合にはシャット ダウンする必要があります。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に、[マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [BizTalk Server Interchange Application] をクリックします。

  4. [操作] メニューの [シャットダウン] をクリックします。

注

  • リモート サーバーから BizTalk Server インターチェンジ アプリケーションをシャットダウンすることができます。これを行うには、手順 2. で [マイ コンピュータ] の代わりにリモート コンピュータ名を展開します。

関連項目

管理キャッシュ

サーバー グループの接続のプロパティの構成

サーバー グループの追跡のプロパティの構成

グループとサーバー

コンポーネント サービスを開く

追跡データベース


追跡データベースと共有キュー データベースの削除

追跡データベースや共有キュー データベースを削除するのは、ほとんどの場合、ほかの追跡データベースや共有キュー データベースを使用するように BizTalk Server グループを構成したときです。別のデータベースを使用するように BizTalk Server グループを構成しないまま、追跡データベースと共有キュー データベースを削除すると、BizTalk Server は正しく動作しなくなります。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Servers] を展開し、[SQL Server グループ] を展開します。次に削除するデータベースを含む個々のサーバーを展開します。

  3. [データベース] フォルダを展開して、削除するデータベースをクリックします。

  4. [操作] メニューの [削除] をクリックします。

    [データベースの削除] ダイアログ ボックスが表示されます。

  5. データベースのバックアップと復元ヒストリを保存するには、[データベースのバックアップと復元ヒストリを削除する] チェック ボックスをオフにします。

  6. [はい] をクリックします。

注

  • 追跡データベースの既定の名前は、InterchangeDTA です。共有キュー データベースの既定の名前は、InterchangeSQ です。

関連項目

グループとサーバー

共有キュー データベース

グループ内のサーバーの停止

追跡データベース


追跡データベースの手動による復元

この手順は、追跡データベースが破損した場合に実行します。この手順は、バックアップが作成されていることが前提となります。

注意

  • 追跡データベースを手動で復元すると、すべてのデータが失われます。データを保持するには、追跡データベースを復元する前に、そのデータをバックアップしてください。
  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Server] を展開し、[SQL Server グループ] を展開します。次に、データベースを復元するサーバーを展開します。

  3. [データベース] をクリックします。

  4. [操作] メニューの [新規データベース] をクリックします。

    [データベースのプロパティ] ダイアログ ボックスが表示されます。

  5. [全般] プロパティ ページの [名前] ボックスに追跡データベースの名前を入力し、[OK] をクリックします。

  6. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[クエリ アナライザ] をクリックします。

    [SQL Server の接続] ダイアログ ボックスが表示されます。

  7. [SQL Server] ボックスで、復元するデータベースの置かれたサーバーを選択します。

  8. [接続に使用する認証] エリアで、SQL Server への接続に使用する認証方法のオプションをオンにします。

  9. [OK] をクリックします。

  10. Microsoft SQL Server 7.0 がインストールされている場合は、[クエリ] ウィンドウの [DB] のボックスの一覧で、新しい追跡データベースの名前をクリックします。手順 14 に進みます。

    または

    Microsoft SQL Server 2000 がインストールされている場合は、[オブジェクト ブラウザ] ウィンドウで新しい追跡データベースの名前をクリックします。

  11. [クエリ] メニューの [データベース変更] をクリックします。

  12. [<サーバー名> のデータベースの選択] ウィンドウで、新しい追跡データベースの名前をクリックします。

  13. [OK] をクリックします。

  14. [SQL スクリプトの読み込み] ボタン ( [SQL スクリプトの読み込み] ボタン) をクリックします。

  15. \Program Files\Microsoft BizTalk Server\Setup に移動します。

  16. [BTS_Tracking_Schema.sql] をクリックし、[開く] をクリックします。

  17. [クエリ実行] ボタンをクリックします。

  18. [SQL スクリプトの読み込み] ボタンをクリックします。

  19. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  20. BTS_Reporting.sql をクリックし、[開く] をクリックします。

  21. [クエリ実行] ボタンをクリックします。

  22. [SQL スクリプトの読み込み] ボタンをクリックします。

  23. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  24. BTS_Tracking_Logic.sql をクリックし、[開く] をクリックします。

  25. [クエリ実行] ボタンをクリックします。

  26. [SQL スクリプトの読み込み] ボタンをクリックします。

  27. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  28. BTS_WorkflowEvents_Logic.sql をクリックし、[開く] をクリックします。

  29. [クエリ実行] ボタンをクリックします。

  30. [SQL スクリプトの読み込み] ボタンをクリックします。

  31. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  32. BTS_WorkflowEvents_Schema.sql をクリックし、[開く] をクリックします。

  33. [クエリ実行] ボタンをクリックします。

  34. SQL クエリ アナライザと SQL Server Enterprise Manager を閉じます。

関連項目

共有キュー データベースの手動による復元


共有キュー データベースの手動による復元

この手順は、共有キュー データベースが破損した場合に実行します。この手順は、バックアップが作成されていることが前提となります。

注意

  • 共有キュー データベースを手動で復元すると、すべてのデータが失われます。データを保持するには、共有キュー データベースを復元する前に、そのデータをバックアップしてください。
  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Server] を展開し、[SQL Server グループ] を展開します。次に、データベースを復元するサーバーを展開します。

  3. [データベース] をクリックします。

  4. [操作] メニューの [新規データベース] をクリックします。

    [データベースのプロパティ] ダイアログ ボックスが表示されます。

  5. [全般] プロパティ ページの [名前] ボックスに共有キュー データベースの名前を入力し、[OK] をクリックします。

  6. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[クエリ アナライザ] をクリックします。

    [SQL Server の接続] ダイアログ ボックスが表示されます。

  7. [SQL Server] ボックスで、復元するデータベースの置かれたサーバーを選択します。

  8. [接続に使用する認証] エリアで、SQL Server への接続に使用する認証方法のオプションをオンにします。

  9. [OK] をクリックします。

  10. Microsoft SQL Server 7.0 がインストールされている場合は、[クエリ] ウィンドウの [DB] のボックスの一覧で、新しい共有キュー データベースの名前をクリックします。手順 14 に進みます。

    または

    Microsoft SQL Server 2000 がインストールされている場合は、[オブジェクト ブラウザ] ウィンドウで新しい共有キュー データベースの名前をクリックします。

  11. [クエリ] メニューの [データベース変更] をクリックします。

  12. [<サーバー名> のデータベースの選択] ウィンドウで、新しい共有キュー データベースの名前をクリックします。

  13. [OK] をクリックします。

  14. [SQL スクリプトの読み込み] ボタン ( [SQL スクリプトの読み込み] ボタン) をクリックします。

  15. \Program Files\Microsoft BizTalk Server\Setup に移動します。

  16. BTS_Core_Schema.sql をクリックし、[開く] をクリックします。

  17. [クエリ実行] ボタンをクリックします。

  18. [SQL スクリプトの読み込み] ボタンをクリックします。

  19. 作業中のフォルダが \Program Files\Microsoft BizTalk Server\Setup であることを確認します。

  20. BTS_Core_Logic.sql をクリックし、[開く] をクリックします。

  21. [クエリ実行] ボタンをクリックします。

  22. SQL クエリ アナライザと SQL Server Enterprise Manager を閉じます。

関連項目

追跡データベースの手動による復元


サーバー グループの受信機能の管理

受信機能は、BizTalk Server グループに設定し、特定のプロトコルの受信インターチェンジを処理する機能です。この機能は、受信ルーティング オブジェクトの Recive メソッドを呼び出します。

ここには次のトピックが含まれます。

  • ファイル受信機能の追加

  • ファイル受信機能の構成 : [全般] タブ

  • ファイル受信機能の構成 : [サービス] タブ

  • メッセージ キュー受信機能の追加

  • メッセージ キュー受信機能の構成 : [全般] タブ

  • メッセージ キュー受信機能の構成 : [サービス] タブ

  • HTTP 受信機能の追加

  • HTTP 受信機能の構成 : [全般] タブ

  • HTTP 受信機能の構成 : [サービス] タブ

  • ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

  • IIS の保護レベルを利用したアクセス特権の構成

  • 受信機能の削除

注

  • ユーザー名とパスワードを使用するように構成された受信機能をレプリケートする場合、無効なパスワードによって受信機能は無効になります。この問題を解決するには、各受信機能のプロパティ ページを開いて、パスワードを再入力し、受信機能を有効にする必要があります。


ファイル受信機能の追加

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、ファイル受信機能を追加するサーバーの含まれたサーバー グループを展開します。

  2. [受信機能] をクリックします。

  3. [操作] メニューの [新規作成] をポイントし、[ファイル受信機能] をクリックします。

    [ファイル受信機能の追加] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに、ファイル受信機能の名前を入力します。

  5. [コメント] ボックスに、簡単な説明を入力します (省略可)。

  6. [受信機能を実行するサーバー] ボックスの一覧で、そのグループ内のサーバーの名前をクリックします。

  7. [ポーリングするファイルの種類] ボックスに、BizTalk Server が受信するファイルの拡張子を入力します。

    ファイルの拡張子は、次の構文で記述する必要があります。

    *.ext

    例 : *.xml

  8. [ポーリングの場所] ボックスに、この受信機能がファイルの受信場所として使用するディレクトリへの論理パスまたは Universal Naming Convention (UNC) パスのいずれかを入力します。

  9. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサの名前をクリックします。

    カスタム プリプロセッサを使用しない場合は、空白のままにします。

  10. [ユーザー名] ボックスと [パスワード] ボックスに、ファイル受信場所に接続するための有効なユーザー名とパスワードを入力します (省略可)。

    これは、その受信場所が保護されており、サーバーに接続するために有効なユーザー名とパスワードが要求される場合にのみ必要です。

  11. 非セルフルーティング ドキュメント用に受信機能をカスタマイズしたり、オープンネスまたはパススルーのオプションを指定するには、[詳細設定] をクリックします。

    詳細設定オプションの詳細については、「ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成」を参照してください。

注

  • ここでは、既定の設定でファイル受信機能を作成します。ファイル受信機能に追加の設定を構成するには、「ファイル受信機能の構成 : [全般] タブ」を参照してください。

  • 複数の種類のファイルをポーリングする場合は、標準のワイルドカード書式を使用します。

    例 : *.* または *.x?l

  • 同じディレクトリを監視するために 1 つ以上のファイル受信機能を構成する場合は、3 文字のファイル拡張子を使用します。3 文字を超えるファイル拡張子を使用する場合は、最初の 3 文字が一意であることを確認します。

    例 : *.xml、*.1xml、*.12xml

  • ファイル受信機能は、読み取り専用ファイルを処理できません。

  • 作成する各受信機能に一意な名前が付いていることを確認してください。異なる受信機能に同じ名前を割り当てることはできません。

  • ユーザー名とパスワードを使用するように構成された受信機能をレプリケートする場合、無効なパスワードによって受信機能は無効になります。この問題を解決するには、各受信機能のプロパティ ページを開いて、パスワードを再入力し、受信機能を有効にする必要があります。

関連項目

利用可能な受信機能

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

ファイル受信機能の構成 : [全般] タブ

ファイル受信機能の構成 : [サービス] タブ

カスタム プリプロセッサ

受信機能


ファイル受信機能の構成 : [全般] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、ファイル受信機能を構成するサーバー グループを展開します。次に、[受信機能] を展開します。

  2. 構成するファイル受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [コメント] ボックスに、簡単な説明を入力します (省略可)。

  5. [セキュリティ] の [ユーザー名] ボックスと [パスワード] ボックスに、この受信機能に接続するための有効なユーザー名とパスワードを入力します。

    これは、その受信場所が保護されており、サーバーに接続するために有効なユーザー名とパスワードが要求される場合にのみ必要です。

  6. 受信機能をシャットダウンしたくない場合は、[受信機能を無効にする] チェック ボックスをオフにして、確認のダイアログ ボックスで [はい] をクリックします。

注

  • ファイル受信機能は、読み取り専用ファイルを処理できません。

  • ユーザー名とパスワードを使用するように構成された受信機能をレプリケートする場合、無効なパスワードによって受信機能は無効になります。この問題を解決するには、各受信機能のプロパティ ページを開いて、パスワードを再入力し、受信機能を有効にする必要があります。

関連項目

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

ファイル受信機能の構成 : [サービス] タブ


ファイル受信機能の構成 : [サービス] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、ファイル受信機能を構成するサーバー グループを展開します。次に、[受信機能] を展開します。

  2. 構成するファイル受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [サービス] タブをクリックします。

  5. [受信機能を実行するサーバー] ボックスの一覧で、サーバー名をクリックします。

  6. [ポーリングの場所] ボックスに、この受信機能がファイルの受信場所として使用するディレクトリへの論理パスまたは Universal Naming Convention (UNC) パスのいずれかを入力します。

  7. [ポーリングするファイルの種類] ボックスに、BizTalk Server が受信するファイルの拡張子を入力します。

    ファイルの拡張子は、次の構文で記述する必要があります。

    *.ext

    例 : *.doc

  8. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサの名前をクリックします。

    カスタム プリプロセッサを使用しない場合は、空白のままにします。

  9. [OK] をクリックします。

注

  • 複数の種類のファイルを受信する場合は、標準のワイルドカード書式を使用します。

    例 : *.*

  • 同じディレクトリを監視するために 1 つ以上のファイル受信機能を構成する場合は、3 文字のファイル拡張子を使用します。3 文字を超えるファイル拡張子を使用する場合は、最初の 3 文字が一意であることを確認します。

    例 : *.xml、*.1xml、*.12xml

  • ファイル受信機能は、読み取り専用ファイルを処理できません。

関連項目

利用可能な受信機能

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

カスタム プリプロセッサ


メッセージ キュー受信機能の追加

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、メッセージ キュー受信機能を追加するサーバー グループを展開します。

  2. [受信機能] をクリックします。

  3. [操作] メニューの [新規作成] をポイントし、[メッセージ キュー受信機能] をクリックします。

    [メッセージ キュー受信機能の追加] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに、メッセージ キュー受信機能の名前を入力します。

  5. [コメント] ボックスに、簡単な説明を入力します (省略可)。

  6. [受信機能を実行するサーバー] ボックスの一覧で、そのグループ内のサーバーの名前をクリックします。

  7. [ポーリングの場所] ボックスに、この受信機能が受信場所として使用するサーバー名とメッセージ キュー名を入力します。

    例 :

    Direct=OS:<サーバー名>\<キュー名>

    キューが格納されている処理サーバーを選択します。トランザクション メッセージは、ローカル キューだけでサポートされます。

  8. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサをクリックします。

    カスタム プリプロセッサを使用しない場合は、空白のままにします。

  9. [ユーザー名] ボックスと [パスワード] ボックスに、メッセージ キューに接続するための有効なユーザー名とパスワードを入力します。

    これは、受信場所がインターチェンジとドキュメントを処理するサーバー上にない場合にのみ必要です。

  10. 非セルフルーティング ドキュメント用に受信機能をカスタマイズしたり、オープンネスまたはパススルーのオプションを指定するには、[詳細設定] をクリックします。

    詳細設定オプションの詳細については、「ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成」を参照してください。

重要

  • [ポーリングの場所] ボックスで、<サーバー名>\<キュー名> に "queue://" のプレフィックスを付けないでください。これは "queue://" を使用するサーバー グループの一般プロパティとは異なります。メッセージ キュー構文の詳細については、「利用可能な受信機能」を参照してください。サーバー グループのプロパティの詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

注

  • メッセージ キュー受信機能は、パススルー送信を許可するように構成されません。

  • 作成する各受信機能に一意な名前が付いていることを確認してください。異なる受信機能に同じ名前を割り当てることはできません。

  • BizTalk Server の動作するサーバーに与えられたユーザー名とパスワードがキューに対して読み取りアクセス許可を持っていない場合は、メッセージ キュー受信機能は動作しません。

  • 信頼性を確保するには、トランザクション キューを使用します。非トランザクション キューを使用すると、メッセージが失われることがあります。トランザクション キューの詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「Message Queuing」を検索してください。

  • ユーザー名とパスワードを使用するように構成された受信機能をレプリケートする場合、無効なパスワードによって受信機能は無効になります。この問題を解決するには、各受信機能のプロパティ ページを開いて、パスワードを再入力し、受信機能を有効にする必要があります。

  • カスタム プリプロセッサの詳細については、「カスタム プリプロセッサ」を参照してください。

関連項目

利用可能な受信機能

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

メッセージ キュー受信機能の構成 : [全般] タブ

カスタム プリプロセッサ

受信機能


メッセージ キュー受信機能の構成 : [全般] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、メッセージ キュー受信機能を構成するサーバー グループを展開します。次に [受信機能] を展開します。

  2. 構成するメッセージ キュー受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [コメント] ボックスに、簡単な説明を入力します (省略可)。

  5. [セキュリティ] の [ユーザー名] ボックスと [パスワード] ボックスに、メッセージ キューに接続するための有効なユーザー名とパスワードを入力します。

    これは、その受信場所が処理サーバー上にない場合にのみ必要です。

  6. この受信機能を一時的にシャットダウンする場合は、[受信機能を無効にする] チェック ボックスをオンにして、確認のダイアログ ボックスで [はい] をクリックします。

注

  • ユーザー名とパスワードを使用するように構成された受信機能をレプリケートする場合、無効なパスワードによって受信機能は無効になります。この問題を解決するには、各受信機能のプロパティ ページを開いて、パスワードを再入力し、受信機能を有効にする必要があります。

関連項目

メッセージ キュー受信機能の構成 : [サービス] タブ

受信機能


メッセージ キュー受信機能の構成 : [サービス] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、メッセージ キュー受信機能を構成するサーバー グループを展開します。次に [受信機能] を展開します。

  2. 構成するメッセージ キュー受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [サービス] タブをクリックします。

  5. [受信機能を実行するサーバー] ボックスの一覧で、サーバー名をクリックします。

  6. [ポーリングの場所] ボックスに、この受信機能が受信場所として使用するサーバー名とメッセージ キュー名を入力します。

    例 :

    Direct=OS:<サーバー名>\<キュー名>

  7. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサをクリックします。

    カスタム プリプロセッサを使用しない場合は、このオプションを空白のままにします。

  8. [OK] をクリックします。

重要

  • [ポーリングの場所] ボックスで、<サーバー名>\<キュー名> に "queue://" のプレフィックスを付けないでください。これは "queue://" を使用するサーバー グループの一般プロパティとは異なります。メッセージ キュー構文の詳細については、「利用可能な受信機能」を参照してください。サーバー グループのプロパティの詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

注

  • カスタム プリプロセッサの詳細については、「カスタム プリプロセッサ」を参照してください。

関連項目

利用可能な受信機能

サーバー グループの全般プロパティの構成

カスタム プリプロセッサ


HTTP 受信機能の追加

ここでは、既定の設定で HTTP 受信機能を作成します。HTTP 受信機能をそのほかの設定で構成する場合は、「ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成」を参照してください。

この手順を行う前に、HTTP 受信機能を実行するサーバーで Internet Information Services (IIS) が実行されていることを確認してください。また、HTTP 受信機能を正しく動作させるために、実行アクセス権がある IIS 仮想ディレクトリを使用する必要があります。IIS 仮想ディレクトリの作成については、IIS 5.0 のマニュアルを参照してください。

クライアントの指定を仮想ディレクトリにしたときには、HTTP 受信機能を正しく動作させるために、データを HTTP (Hypertext Transfer Protocol) を使って HTTP 受信機能に送信する必要があります。クエリ文字列には、UTF-8 コードページを使用してエンコードされたマルチバイト文字列 (MBCS) を使用する必要があります。また、受信要求に Content-Type ヘッダーが設定されていない場合、HTTP 受信機能が USASCII に既定設定することも理解しておく必要があります。この場合、インスタンス データに2 バイト文字セット (DBCS) の文字が使用されているとインスタンス データは壊れてしまいます。詳細については、MSDN オンライン ライブラリ Web サイト (www.microsoft.com/japan/developer/library/default.asp) にアクセスして、「マルチバイト文字セット (MBCS) のサポート」を検索してください。

  1. Windows エクスプローラで、インストール ドライブの \Program Files\Microsoft BizTalk Server\HTTP Receive\BizTalkHTTPReceive.dll に移動します。

  2. IIS 仮想ディレクトリがポイントするディレクトリに BizTalkHTTPReceive.dll をコピーします。

  3. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、HTTP 受信機能を追加するサーバーの含まれたサーバー グループを展開します。

  4. [受信機能] をクリックします。

  5. [操作] メニューの [新規作成] をポイントし、[HTTP 受信機能] をクリックします。

    [HTTP 受信機能の追加] ダイアログ ボックスが表示されます。

  6. [名前] ボックスに、HTTP 受信機能の名前を入力します。

  7. [コメント] ボックスに、簡単な説明を入力します (省略可)。

  8. [受信機能を実行するサーバー] ボックスのドロップダウン リストから、追加先のサーバーの名前をクリックします。

  9. [仮想ディレクトリ] ボックスで、HTTP 受信機能により受信されたドキュメントがポストされる仮想ディレクトリの名前を入力します。通常、仮想ディレクトリは、HTTP 受信機能 DLL の名前とオプションのクエリ文字列を含んでいます。

    たとえば、仮想ディレクトリ名は次のようになります。

    /<仮想ディレクトリ>/BizTalkHTTPReceive.dll

    /<仮想ディレクトリ>/BizTalkHTTPReceive.dll?Purchase%20Order

    注

    • [仮想ディレクトリ] ボックスにサーバー名を指定しないでください。サーバーは、[受信機能を実行するサーバー] ボックスで既に指定しています。

    • 仮想ディレクトリが、仮想ディレクトリ DLL の名前で既定のドキュメントとして構成されている場合、そのダイナミック リンク ライブラリ (DLL) を仮想ディレクトリ名の一部に含める必要があります。

    • [仮想ディレクトリ] ボックスに入力する値には、"http://" の文字列を削除する必要があります。

    • 同じ仮想ディレクトリを使用する複数の受信機能を作成するには、クエリ文字列を使用する必要があります。

    • [仮想ディレクトリ] ボックスで使用するクエリ文字列は、URLEncode メソッドを使用してエンコードする必要があります。スペースを挿入するには、文字列 "%20" を使用する必要があります。
  10. [送信先] ボックスで、HTTP 受信機能からのドキュメントの送信先 ([BizTalk]/[ファイル]) と送信方法 ([同期]/[非同期]) を選択します。

    [BizTalk - 同期] を選択し、応答ドキュメントを受け取る場合には、[返すコンテンツの種類] ボックスに返送するコンテンツの種類を入力します。[返すコンテンツの種類] ボックスに入力する値は、HTTP 仕様で規定されている HTTP の Content-Type と一致している必要があります。HTTP 仕様の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    または

    [ファイル] を選択した場合には、受信ドキュメントの書き込まれるパスとファイル名を [ファイルのパスと名前] ボックスに入力します。入力するファイル名には、実行時に置き換える変数を指定することもできます。サポートされている変数は、%guid%、%server%、および %datetime% の 3 つです。たとえば、ファイル名とパスは D:\Directory\File name%guid%.xml のように指定します。

    重要

    • HTTP 受信機能がファイルを送信しているときにエラーが発生した場合には、保留キューにメッセージは保存されません。
  11. 関連付けトークンをドキュメントの送信元に返す場合には [関連付けトークンを返す] チェック ボックスをオンにします。

    ドキュメントが BizTalk Server に送信されるとき、関連付けトークンには送信 GUID が与えられます。ドキュメントがファイルに送信されるとき、関連付けトークンにはファイル名が与えられます。たとえば、関連付けトークンは次のようになります。

    <BizTalkHttpReceive><CorrelationToken TokenType= SUBMIT>{1a3e5678-a2c9-12d4-a8cd-12a456e89012}</CorrelationToken></BizTalkHttpReceive>

  12. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサの名前をクリックします。

    注

    • カスタム プリプロセッサを使用しない場合は、空白のままにします。

    詳細については、「Preprocessing Documents in a Receive Function」を参照してください。

  13. 非セルフルーティング ドキュメント用に受信機能をカスタマイズしたり、オープンネスまたはパススルーのオプションを指定するには、[詳細設定] をクリックします。

    詳細設定オプションの詳細については、「ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成」を参照してください。

作成した HTTP 受信機能を動作させるためには、Internet Information Services (IIS) のさまざな保護レベルの影響を受ける COM+ パッケージに正しいアクセス許可を与えることが重要です。

「IIS の保護レベルを利用したアクセス特権の構成」も参照してください。

注

  • 作成する各受信機能に、クエリ文字列を含む一意な仮想ディレクトリ名が付いていることを確認してください。異なる受信機能に同じ名前を割り当てることはできません。

  • 異なる仮想ディレクトリに対応する複数のダイナミック リンク ライブラリ (DLL) は同じサーバーに置くことができます。また、複数のディレクトリが同じ DLL をポイントすることもできます。ただし、パフォーマンスを向上させるには、1 つの DLL だけを使用することを推奨します。

  • クライアントは、HTTP 受信機能に /VirtualDirectory の URL を使用して送信します。IIS 5.0 と Windows 2000 Service Pack 2 (SP2) を使用している場合には、DLL も所定の URL (/VirtualDirectory/BizTalkHTTPreceive.dll) に含める必要があります。

  • HTTP 受信機能を作成すると、基本的な送信の種類 ([BizTalk]/[ファイル]) は変更できなくなります。

  • [送信先] ボックスで [BizTalk - 同期] を選択し、さらに [関連付けトークンを返す] を選択したとき、関連付けトークンは応答ドキュメントが空のときにだけ送信されます。

  • HTTP 受信機能で仕様される関連付けトークンは、オーケストレーションの関連付けとは無関係です。詳細については、「関連付けトークン」を参照してください。

  • HTTP 受信機能がドキュメントを同期で送信し、チャネルがメッセージ キューのポートからメッセージを送信した場合、「無効なトランザクションの使用方法です。」というエラーメッセージが表示される場合があります。このエラーは HTTP 受信機能が非トランザクションで、メッセージ キューがトランザクションであるために発生します。このエラーを解決するには、チャンネルに対するトランザクション レベルのオプションに単一メッセージを選択する必要があります。チャネルの詳細プロパティの詳細については、「メッセージ ポート既定値の変更」を参照してください。

関連項目

利用可能な受信機能

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

HTTP 受信機能の構成 : [全般] タブ

HTTP 受信機能の構成 : [サービス] タブ

カスタム プリプロセッサ

受信機能


HTTP 受信機能の構成 : [全般] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、HTTP 受信機能を構成するサーバー グループを展開します。次に、[受信機能] を展開します。

  2. 構成する HTTP 受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [全般] プロパティ ページの [コメント] ボックスに簡単な説明を入力します (省略可)。

  5. この受信機能を一時的にシャットダウンする場合は、[受信機能を無効にする] チェック ボックスをオンにして、確認のダイアログ ボックスで [はい] をクリックします。

関連項目

HTTP 受信機能の構成 : [サービス] タブ

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成


HTTP 受信機能の構成 : [サービス] タブ

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、HTTP 受信機能を構成するサーバー グループを展開します。次に、[受信機能] を展開します。

  2. 構成する HTTP 受信機能をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  4. [サービス] タブをクリックします。

  5. [受信機能を実行するサーバー] ボックスの一覧で、サーバー名をクリックします。

  6. [仮想ディレクトリ] ボックスで、ドキュメントの送信先となる HTTP 受信機能の仮想ディレクトリの名前を入力します。

    たとえば、仮想ディレクトリ名は次のようになります。

    /<仮想ディレクトリ>/BizTalkHTTPReceive.dll

    /<仮想ディレクトリ>/BizTalkHTTPReceive.dll?Purchase%20Order

    注

    • [仮想ディレクトリ] ボックスにサーバー名を指定しないでください。サーバーは、[受信機能を実行するサーバー] ボックスで既に指定しています。

    • 仮想ディレクトリが、HTTP 受信機能 DLL の名前とともに既定のドキュメントの 1 つとして構成されている場合、そのダイナミック リンク ライブラリ (DLL) を仮想ディレクトリ名の一部に含める必要があります。

    • [仮想ディレクトリ] ボックスに入力する値には、"http://" の文字列を削除する必要があります。

    • 同じ仮想ディレクトリを使用する複数の受信機能を作成するには、クエリ文字列を使用する必要があります。

    • [仮想ディレクトリ] ボックスで使用するクエリ文字列は、URLEncode メソッドを使用してエンコードする必要があります。スペースを挿入するには、文字列 "%20" を使用する必要があります。
  7. HTTP 受信機能が BizTalk Server に送信する場合は、[送信先] ボックスで送信方法 ([同期] または [非同期]) を選択します。

    [BizTalk - 同期] を選択した場合は、[返すコンテンツの種類] ボックスに返送するコンテンツの種類を入力します。[返すコンテンツの種類] ボックスに入力する値は、HTTP 仕様で規定されている HTTP の Content-Type と一致している必要があります。HTTP 仕様の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    各国語対応に関する問題

    • 受信要求に Content-Type ヘッダーが設定されていない場合、HTTP 受信機能により USASCII に既定設定されます。この場合、インスタンス データに 2 バイト文字セット (DBCS) の文字が使用されているとインスタンス データは壊れてしまいます。
  8. [プリプロセッサ] ボックスの一覧で、カスタム プリプロセッサの名前をクリックします。

    注

    • カスタム プリプロセッサを使用しない場合は、空白のままにします。

    詳細については、「Preprocessing Documents in a Receive Function」を参照してください。

  9. HTTP 受信機能がファイルに送信する場合は、受信ドキュメントの書き込まれるパスとファイル名を [ファイルのパスと名前] ボックスに入力します。入力するファイル名には、実行時に置き換える変数を指定することもできます。サポートされている変数は、%guid%、%server%、および %datetime% の 3 つです。たとえば、ファイル名とパスは D:\Directory\File name%guid%.xml のように指定します。

  10. 関連付けトークンをドキュメントの送信元に返す場合には [関連付けトークンを返す] チェック ボックスをオンにします。

    ドキュメントが BizTalk Server に送信されるとき、関連付けトークンには送信 GUID が与えられます。ドキュメントがファイルに送信されるとき、関連付けトークンにはファイル名が与えられます。たとえば、関連付けトークンは次のようになります。

    <BizTalkHttpReceive><CorrelationToken TokenType= SUBMIT>{1a3e5678-a2c9-12d4-a8cd-12a456e89012}</CorrelationToken></BizTalkHttpReceive>

  11. [OK] をクリックします。

注

  • BizTalk Server のクライアント インストールは、管理コンソールによる HTTP 受信機能の作成をサポートしていません。

  • 関連付けトークンは、オーケストレーションの関連付けとは無関係です。詳細については、「関連付けトークン」を参照してください。

  • HTTP 受信機能を作成すると、基本的な送信の種類 ([BizTalk]/[ファイル]) は変更できなくなります。

  • [送信先] ボックスで [BizTalk - 同期] を選択し、さらに [関連付けトークンを返す] を選択したとき、関連付けトークンは応答ドキュメントが空のときにだけ送信されます。

  • クライアントは、HTTP 受信機能に /VirtualDirectory の URL を使用して送信します。ただし、IIS 5.0 と Windows 2000 Service Pack 2 (SP2) を使用している場合には、DLL も所定の URL (/VirtualDirectory/BizTalkHTTPreceive.dll) でアクセスできる必要があります。

  • 同じ仮想ディレクトリを使用する複数の受信機能を作成するには、クエリ文字列を使用する必要があります。

関連項目

利用可能な受信機能

ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

カスタム プリプロセッサ


ファイル受信機能、メッセージ キュー受信機能、または HTTP 受信機能の詳細プロパティの構成

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、受信機能を構成するサーバー グループを展開します。次に [受信機能] を展開し、構成する受信機能をクリックします。

  2. [操作] メニューの [プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

  3. [詳細設定] タブをクリックします。

  4. [オープンネス] ボックスの一覧で、次のいずれかを選択できます。
    • [開いていません] : 送信元と送信先の両方が受信機能またはドキュメント インスタンスで明示的に宣言されている場合は、このオプションをクリックします。BizTalk Server は、送信元と送信先を決定するためにドキュメントを解析する必要がありません。

    • [オープンな送信先] : 送信先情報がメッセージ ポートで明示的に宣言されていない場合は、このオプションをクリックします。送信先はドキュメント インスタンスまたは送信パラメータで動的に指定します。

    • [オープンな送信元] : 送信元情報がチャネルで明示的に宣言されていない場合は、このオプションをクリックします。送信元はドキュメント インスタンスまたは送信パラメータで動的に指定します。
  5. デコード、暗号解読、署名検証、解析などのすべての処理を省略し、インターチェンジのトランスポートだけを行う場合は、[パススルー フラグを付けて送信する] チェック ボックスをオンにします。

    [パススルー フラグを付けて送信する] チェック ボックスをオンにする場合は、チャネルを選択する必要があります。

  6. [エンベロープ名] ボックスの一覧で、エンベロープ定義の名前をクリックします。

    フラット ファイルを受信する場合は、エンベロープを選択します。そうでない場合は、このオプションを空白のままにします。

  7. [チャネル名] ボックスの一覧で、チャネルの名前をクリックします。

  8. [ドキュメント定義名] ボックスの一覧で、ドキュメント定義の名前をクリックします。

  9. [送信元と送信先] の [選択した送信元] で、[参照] をクリックします。

    [送信元の選択] ダイアログ ボックスが表示されます。

  10. [組織の修飾子] ボックスの一覧で、送信元組織の修飾子の種類をクリックします。

  11. [組織の識別子値] ボックスの一覧で、送信元組織の識別子の値をクリックし、[OK] をクリックします。

  12. [送信元と送信先] の [選択した送信先] で、[参照] をクリックします。

    [送信先の選択] ダイアログ ボックスが表示されます。

  13. [組織の修飾子] ボックスの一覧で、送信先組織の修飾子の種類をクリックします。

    同報リストにドキュメントを送信する場合は、[組織の修飾子] ボックスの一覧で [GROUP] を選択する必要があります。

  14. [組織の識別子値] ボックスの一覧で、送信先組織の識別子の値をクリックし、[OK] をクリックします。

  15. [OK] をクリックします。

重要

  • 受信機能の詳細プロパティとして次の一覧のいずれかのオブジェクトを割り当てる前に、そのオブジェクトを作成する必要があります。これらのオブジェクトは、BizTalk メッセージ マネージャで作成するか、プログラムによって作成され、BizTalk メッセージ管理データベースに格納されます。
    • エンベロープ

    • チャネル

    • ドキュメント定義

    • 送信元の修飾子

    • 送信元組織の識別子の値

    • 送信先の修飾子

    • 送信先組織の識別子の値

注

  • [オープンネス] ボックスの一覧で、[オープンな送信元] または [オープンな送信先] をクリックした場合は、[パススルー フラグを付けて送信する] チェック ボックスは利用できません。

  • [パススルー フラグを付けて送信する] チェック ボックスをオンにした場合、利用できるボックスの一覧は [チャネル] だけです。

  • 同報リストにドキュメントを送信する場合は、[送信先の選択] ダイアログ ボックスの [組織の修飾子] ボックスの一覧で [GROUP」を選択する必要があります。

  • 受信機能の詳細プロパティはすべて省略可能で、空白のままにすることができます。ドキュメントの送信の詳細については、「ルーティング」または「受信機能とドキュメント ルーティングについて」を参照してください。

  • パススルー送信は、BizTalk Server 2002 の解析、暗号解読、およびデコードの機能を省略します。パススルー フラグを付けてドキュメントを送信する方法の詳細については、「受信機能の詳細プロパティについて」を参照してください。送信の詳細については、「Submitting」を参照してください。

  • [詳細設定] タブは、ファイルに送信する HTTP 受信機能では利用できません。

  • BizTalk Server のクライアント インストールだけをインストールしているコンピュータでは受信機能の [詳細設定] タブを利用できません。

関連項目

受信機能

ルーティング

Submitting

受信機能の詳細プロパティについて

受信機能とドキュメント ルーティングについて


IIS の保護レベルを利用したアクセス特権の設定

HTTP 受信機能を追加したら、仮想ディレクトリの分離レベルに基づいて COM+ パッケージを構成することが重要です。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. [コンピュータの管理] ツリーで [サービスとアプリケーション]、[インターネット インフォメーション サービス] の順に展開し、HTTP 受信機能が使用する仮想ディレクトリの格納された Web サイトの名前を展開します (既定では [既定の Web サイト] です)。

  3. 仮想ディレクトリの名前を右クリックし、[プロパティ] をクリックします。

  4. [仮想ディレクトリ] プロパティ ページで、[アプリケーション保護] のレベルを確認します。

    アプリケーションの保護レベルが、[低 (IIS プロセス)] の場合は手順 5 に進みます。

    アプリケーションの保護レベルが、[中 (プール)] の場合は手順 7 に進みます。

    アプリケーションの保護レベルが、[高 (分離プロセス)] の場合は手順 9 に進みます。

  5. アプリケーションの保護レベルが [低 (IIS 分離)] に構成されている場合は、[コンポーネント サービス] を開いて、[サービス] をダブルクリックし、[World Wide Web Publishing Service] を右クリックして、[プロパティ] を選択します。

  6. [ログオン] プロパティ ページの [ログオン] プロパティを BizTalk メッセージ管理データベース、BizTalk Server インターチェンジ アプリケーション、および BizTalk Server 内部ユーティリティにアクセス可能なセキュリティ資格情報を持つユーザーに設定します。

  7. 仮想ディレクトリのアプリケーション保護レベルが [中 (プール)] に構成されている場合は、[コンポーネント サービス] を開いて、[COM+ アプリケーション] を展開し、[IIS Out-of-Process Pooled Applications] を右クリックして [プロパティ] をクリックします。

  8. [ID] プロパティ ページで、[アカウント] プロパティを BizTalk メッセージ管理データベース、BizTalk Server インターチェンジ アプリケーション、および BizTalk Server 内部ユーティリティにアクセス可能なセキュリティ資格情報を持つユーザーに設定します。

  9. 仮想ディレクトリのアプリケーション保護レベルが [高 (分離プロセス)] に構成されている場合は、[コンポーネント サービス] を開き、[COM+ アプリケーション] を展開し、[IIS_{Default Web Site//root/virtual directory name}] を右クリックして [プロパティ] を選択します。

  10. [ID] プロパティ ページで、[アカウント] プロパティを BizTalk メッセージ管理データベース、BizTalk Server インターチェンジ アプリケーション、および BizTalk Server 内部ユーティリティにアクセス可能なセキュリティ資格情報を持つユーザーに設定します。

関連項目

HTTP 受信機能の追加


受信機能の削除

この作業では、受信機能のインスタンスを削除します。ただし、実際の処理では、管理データベースから管理オブジェクトのインスタンスが削除されるだけです。このインスタンスに関連付けられた実際のコンポーネントやスクリプトには影響しません。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、受信機能を削除するサーバー グループを展開します。次に [受信機能] を展開します。

  2. 削除する受信機能をクリックします。

  3. [操作] メニューの [削除] をクリックします。

    [ユーザー操作の確認] ダイアログ ボックスが表示されます。

  4. [はい] をクリックします。

関連項目

受信機能


BizTalk サービスの管理

データベース名の変更や、Web サーバー、ファイアウォールの追加など BizTalk Server の基本的な構成を変更するとき、実行中のサービスは古い構成のパラメータの使用を継続している場合があります。すべてのサービスを新しい構成に同期させるには、変更の適用対象となる BizTalk のサービスを停止して再開することが重要です。

ここには次のトピックが含まれます。

  • BizTalk サービスの開始

  • BizTalk サービスの停止


BizTalk サービスの開始

この手順では、特定のサーバーに関連付けられている BizTalk サービスを開始します。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002]、[BizTalk Server グループ] の順に展開し、開始するBizTalk サービスの置かれたサーバーを選択します。

  2. [操作] メニューの [開始] をクリックします。

関連項目

BizTalk サービスの停止

グループ内のサーバーの起動

グループ内のサーバーの停止


BizTalk サービスの停止

この手順では、特定のサーバーに関連付けられている BizTalk サービスを停止します。通常、BizTalk のサービスの停止は、構成を変更するときや、トラブルシューティングを行うときなど、処理を一時的に中止するために行います。

  1. BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002]、[BizTalk Server グループ] の順に展開し、開始するBizTalk サービスの置かれたサーバーを選択します。

  2. [操作] メニューの [停止] をクリックします。

関連項目

BizTalk サービスの開始

グループ内のサーバーの起動

グループ内のサーバーの停止


イベント ビューアの管理

BizTalk Server 管理コンソールに含まれているイベント ビューアを使用して、サーバーとドキュメント処理に関する問題をトラブルシューティングすることができます。イベント ビューアは、BizTalk Server 管理コンソールのコンソール ツリーに表示されます。BizTalk Server 2002 のアプリケーションに関連するエラーにはすべて、BizTalk Server エラーというラベルが付きます。XLANG スケジュールに関連するエラーにはすべて、XLANG スケジューラ エラーというラベルが付きます。

ここには次のトピックが含まれます。

  • BizTalk Server エラーのためのイベント ビューアの構成

  • イベント ビューアでのアプリケーションに関連するエラーの表示

注

  • カスタム スクリプト機能の内部で Microsoft XML Parser (MSXML) によって返されるエラーの一部は、イベント ビューアに表示されないことがあります。保留キュー内のドキュメントに関連するエラーは、スクリプトで返されるエラーを反映しない可能性があります。


BizTalk Server エラーのためのイベント ビューアの構成

この手順では、イベント ビューアに BizTalk Server と XLANG スケジューラのイベント、またはそれらのいずれかのイベントだけが表示されるように構成します。通常、この操作を行うのは、ほかのプログラムのエラーが多数あり、トラブルシューティングの際にこれらのイベントを表示したくないときです。

  1. BizTalk Server 管理コンソールで、[イベント ビューア] を展開します。

  2. [アプリケーション] をクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    [アプリケーションのプロパティ] ダイアログ ボックスが表示されます。

  4. [フィルタ] タブをクリックします。

  5. [イベント ソース] ボックスの一覧で、次のいずれかをクリックします。
    • [BizTalk Server] : このオプションは BizTalk メッセージ サービスに関連するエラー メッセージのイベント ソースをフィルタ処理します。

    • [XLANG Scheduler] : このオプションは、BizTalk オーケストレーション サービスに関連するエラー メッセージのイベント ソースをフィルタ処理します。
  6. [OK] をクリックして、[アプリケーションのプロパティ] ダイアログ ボックスを閉じます。


イベント ビューアでのアプリケーションに関連するエラーの表示

  1. BizTalk Server 管理コンソールで、[イベント ビューア] を展開します。

  2. [アプリケーション] をクリックします。

    詳細ウィンドウに、アプリケーション エラー メッセージが一覧表示されます。

  3. 詳細ウィンドウでメッセージをクリックします。

  4. [操作] メニューの [プロパティ] をクリックします。

注

  • ここでは、BizTalk Server エラーと XLANG スケジューラ エラーだけを表示するように、イベント ビューアが構成されていると想定しています。BizTalk Server エラーと XLANG スケジューラ エラーを表示する方法の詳細については、「BizTalk Server エラーのためのイベント ビューアの構成」を参照してください。


XLANG アプリケーションとデータベースの管理

ここでは、BizTalk Server 2002 のインストール時に作成される既定の XLANG スケジューラ アプリケーションの管理方法について説明します。また、この説明には XLANG スケジュール インスタンスをホストする新しい COM+ アプリケーションと、XLANG スケジュール ステータス情報を格納するための新しいステータス保存データベースを作成する方法についての情報も含まれます。

ここには次のトピックが含まれます。

  • ストアド プロシージャを使用したステータス保存データベースからのレコードの削除

  • すべての XLANG アプリケーションのシャットダウン

  • すべての XLANG アプリケーションの再起動

  • 既定の XLANG スケジューラ アプリケーションの管理

  • XLANG スケジュールをホストするそのほかの COM+ アプリケーションの管理

  • 実行中の XLANG スケジュールの監視

注意

  • BizTalk Server 2002 は、XLANG 永続化ヘルパという COM+ アプリケーションを提供します。これは、XLANG スケジュール インスタンスをホストするすべての COM+ アプリケーションによって使用されます。セットアップが終了した後に、XLANG 永続化ヘルパの構成を変更しないでください。

注

  • Microsoft SQL Server の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックして [プログラム] をポイントします。次に [Microsoft SQL Server] をポイントし、[Books Online] をクリックします。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

関連項目

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行


ストアド プロシージャを使用したステータス保存データベースからのレコードの削除

ステータス保存データベースには、実行中と実行が終了した XLANG スケジュールのすべての永続的な情報が格納されます。実行の終了した XLANG スケジュールのデータは、ステータス保存データベースから削除されないため、このデータベースの容量は増加し続けます。次のストアド プロシージャを使用することで、ステータス保存データベースからレコードを削除できます。

sp_CleanDoneInstances @CompletedBefore='<GMT の日付と時刻>'

sp_CleanDoneInstances ストアド プロシージャは、終了または停止した XLANG スケジュール インスタンスをすべて削除します。次のコードは、このストアド プロシージャを使用した例です。

exec sp_CleanDoneInstances @CompletedBefore='2000-10-25 19:34:49.000'

注

  • 時刻にはグリニッジ標準時を使用します。これは、すべての日付と時刻の情報がオーケストレーション データベースにこの形式で記録されるためです。

  • 終了時刻は、ルートレベルのスケジュールだけに適用されます。

sp_CleanDoneModuleInstances @CompletedBefore='<GMT の日付と時刻>', @ModuleGUID='<グローバル一意識別子>'

sp_CleanDoneModuleInstances ストアド プロシージャは、特定のスケジュールの種類の終了または停止した XLANG スケジュール インスタンスをすべて削除します。次のコードは、このストアド プロシージャを使用した例です。

exec sp_CleanDoneModuleInstances @CompletedBefore='2000-10-25 19:34:49.000',
@ModuleGUID='4C5842DA-40E5-40B8-AF03-BC5DD4B7E037'

注

  • 時刻にはグリニッジ標準時の形式を使用します。これは、すべての日付と時刻の情報がオーケストレーション データベースにこの形式で記録されるためです。

  • 終了時刻は、ルートレベルのスケジュールだけに適用されます。

  • @ModuleGUID はスケジュールの ModuleID です。

    ModuleID は、XLANG スケジュールの種類を特定する一意的な参照です。@ModuleGUID パラメータは、XLANG スケジュールの種類をフィルタするために使うことができます。@CompletedBefore パラメータは、指定時刻以前に終了した XLANG スケジュール インスタンスをフィルタします。@ModuleGUID パラメータは、特定の種類の XLANG スケジュールをフィルタします。XLANG Monitor は、ある XLANG スケジュールの ModuleID を調べるために使うことができます。ModuleID は、ScheduleStart、ScheduleDone、ContextEnter、ContextLeave、TransactionBegin、TransactionEnd に対するイベントのプロパティの 1 つです。また、XLANG スケジュール インスタンス のパブリック インターフェイスである、IWFWorkflowInstance::ModuleId Property を使って、ModuleID を取得することもできます。

sp_CleanInstance@InstanceID='{<グローバル一意識別子>}'

sp_CleanInstance ストアド プロシージャは、終了または停止した XLANG スケジュール インスタンスとそのスケジュールの子インスタンスをすべて削除します。この削除は、トランザクション的に処理されます。このストアド プロシージャにおいて、@InstanceID はルート XLANG スケジュールのインスタンス識別子であるグローバル一意識別子 (GUID) になります。BizTalk Server 2002 はこのストアド プロシージャを使用します。このストアド プロシージャは直接呼び出す必要はありません。その代わりに、XLANG データベースの削除の手順を実施する必要があります。

注

  • SQL Server エージェント ジョブを作成すれば、これらのストアド プロシージャを定期的に使用することができます。詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft SQL Server] または [Microsoft SQL Server 7.0] をポイントし、[Books Online] をクリックします。


すべての XLANG アプリケーションのシャットダウン

この手順では、すべての COM+ アプリケーションに対するシャットダウンの制御を実行します。この操作を使えば、すべての実行中の XLANG スケジュールの状態をステータス保存データベースに保存することによって、これらをシャットダウンできます。詳細については、「永続化」を参照してください。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [XLANG Scheduler] をクリックします。

  4. [操作] メニューの [プロパティ] をクリックします。

    [XLANG Scheduler のプロパティ] ダイアログ ボックスが表示されます。

  5. [XLANG] プロパティ ページの [シャットダウンの制御] で、[すべての XLANG アプリケーション] をクリックします。

注意

  • COM+ アプリケーションを右クリックして、[シャットダウン] をクリックしないでください。次のいずれかの問題が発生することがあります。
    • 実行中の XLANG スケジュールのすべてがトランザクションの場合は、制御されないシャットダウンによって、実行中のトランザクションが中断します。

    • 実行中の XLANG スケジュールのすべてがトランザクションではない場合は、スケジュール内で処理中のデータが失われます。

重要

  • データ ソース名 (DSN) を利用できない場合または構成が正しくない場合は、ステータス退避済みの XLANG スケジュールを再起動することはできません。既定の XLANG スケジューラ アプリケーションの DSN を構成する方法については、「既定の XLANG スケジューラ アプリケーションのアプリケーション ID の変更」を参照してください。

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

関連項目

既定の XLANG スケジューラ アプリケーションのアプリケーション ID の変更

すべての XLANG アプリケーションの再起動

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行

XLANG スケジュールをホストする COM+ アプリケーションのシャットダウン


すべての XLANG アプリケーションの再起動

この手順では、すべての COM+ アプリケーションに対する再起動の制御を実行します。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [XLANG Scheduler] をクリックします。

  4. [操作] メニューの [プロパティ] をクリックします。

    [XLANG Scheduler のプロパティ] ダイアログ ボックスが表示されます。

  5. [XLANG] プロパティ ページの [ステータス退避済み XLANG アプリケーションを再起動] で、[すべての XLANG アプリケーション] をクリックします。

重要

  • データ ソース名 (DSN) を利用できない場合または構成が正しくない場合は、ステータス退避済みの XLANG スケジュールを再起動することはできません。データ ソース名 (DSN) と COM+ アプリケーションは、同じである必要があります。たとえば、XLANG スケジューラ エンジンをホストしている COM+ アプリケーションの名前が "XLANG Scheduler" である場合は、DSN の名前も "XLANG Scheduler" にします。

  • ステータス退避済みアプリケーションを再起動すると、ステータス退避済みスケジュールのステータス復元が非同期的に開始されます。ステータス復元処理には時間がかかります。ステータス復元処理の完了時間を特定するには、XLANG Event Monitor を使用します。XLANG Event Monitor ツールの詳細については、ツールに付属のリリース ノートを参照してください。Microsoft BizTalk Server 2002 セットアップ ウィザードによってインストールされる XLANG Event Monitor (XLANGMon.exe) とリリース ノートは、インストール ディレクトリの \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools にあります。

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

関連項目

既定のXLANG スケジューラ アプリケーションのアプリケーション ID の変更

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行

XLANG スケジュールをホストする COM+ アプリケーションのシャットダウン

すべての XLANG アプリケーションのシャットダウン


既定の XLANG スケジューラ アプリケーションの管理

既定の XLANG スケジューラ アプリケーションには、BizTalk Server 2002 のインストール時に作成された XLANG スケジューラ エンジンの既定のインスタンスが配置されます。運用システムや Microsoft Terminal Server の実行されているシステムでは、このアプリケーションのために、既定の識別情報を変更する必要があります。

既定の XLANG スケジューラ アプリケーションの既定の設定を変更する上でのセキュリティとパフォーマンスに関する問題については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

ここには次のトピックが含まれます。

  • 既定のXLANG スケジューラ アプリケーションのアプリケーション ID の変更

注

  • Microsoft SQL Server の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックして [プログラム] をポイントします。次に [Microsoft SQL Server] をポイントし、[Books Online] をクリックします。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

関連項目

XLANG スケジュールをホストする COM+ アプリケーションの作成

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行


既定の XLANG スケジューラ アプリケーションのアプリケーション ID の変更

既定の XLANG スケジューラ アプリケーションの既定の対話型ユーザー アカウントは、サービス アカウントに変更することを推奨します。対話型ユーザー アカウントを使用しているときは、ユーザーがログオンしていないとアプリケーションが動作しません。対話アカウントをサービス アカウントに変更することで、特定のユーザーが常時ログオンしていなくて動作するようになります。サービス アカウントとは、特定のプロパティを備えたユーザー アカウントで、オペレーティング システムの一部として機能することができます。既定の XLANG スケジューラ アプリケーションの既定の設定を変更する上でのセキュリティとパフォーマンスに関する問題については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。サービス アカウントのセットアップについては、「サービス アカウントの設定 」を参照してください。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [XLANG Scheduler] をクリックします。

  4. [操作] メニューの [プロパティ] をクリックします。

    [XLANG Scheduler のプロパティ] ダイアログ ボックスが表示されます。

  5. [詳細設定] プロパティ ページの [許可] で [変更を許可しない] チェック ボックスをオフにし、[OK] をクリックします。

    次のメッセージが表示されます :

    アプリケーションは 1 つ以上の外部プロダクトから作成されました。それらの外部プロダクトは、保存しようとしている変更内容をサポートしますか?

  6. [はい] をクリックします。

    [XLANG Scheduler のプロパティ] ダイアログ ボックスが閉じます。

  7. [XLANG Scheduler] をクリックします。

  8. [操作] メニューの [プロパティ] をクリックします。

    [XLANG Scheduler のプロパティ] ダイアログ ボックスが表示されます。

  9. [ID] プロパティ ページの [アカウント] で [このユーザー] をクリックします。

  10. 使用するアカウントの情報を入力します。

  11. [OK] をクリックします。

    次のメッセージが表示されます :

    アプリケーションは 1 つ以上の外部プロダクトから作成されました。それらの外部プロダクトは、保存しようとしている変更内容をサポートしますか?

  12. [はい] をクリックします。

注

  • Microsoft Terminal Server 経由で [XLANG Scheduler のプロパティ] にアクセスしている場合で、XLANG Scheduler アカウントが [対話ユーザー] ([ID] タブ) に設定され、ホストの BizTalk Server に現在ユーザーがログオンしていない場合には [XLANG] タブは表示されません。前述の手順を行えばこの問題は解決されます。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

関連項目

COM+ アプリケーションの DSN 設定の変更

新しい空のステータス保存データベースの作成

インスタンス作成アプリケーションの作成

すべての XLANG アプリケーションの再起動

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行

すべての XLANG アプリケーションのシャットダウン


XLANG スケジュールをホストするそのほかの COM+ アプリケーションの管理

既定の XLANG スケジューラ アプリケーションを使用して XLANG スケジュールを実行することもできますが、通常は、セキュリティ、展開および構成上の理由により、新しい COM+ アプリケーションを作成して XLANG スケジュール インスタンスを実行した方が便利です。

処理の負荷を分散するために、XLANG スケジュールの実行専用インスタンスをホストする新しい COM+ アプリケーションの作成が必要になることがあります。また、ある XLANG スケジュール インスタンスを実行するアプリケーションを、別のアプリケーションを使用するほかの XLANG スケジュールや、別の ID で実行される XLANG スケジュールから分離することが必要になる場合もあります。アプリケーションとスケジュールに対するセキュリティとパフォーマンスの必要性も考慮する必要があります。詳細については、「XLANG スケジュールの実行 (操作方法)」と「XLANG スケジュールの実行 (概念)」を参照してください。

XLANG スケジュールをホストする新しい COM+ アプリケーションを作成するには、まず新しい COM+ アプリケーションを関連付けるステータス保存データベースを作成する必要があります。次に、新しい COM+ アプリケーションを作成し、既定のアプリケーション ID 設定を変更し、COM+ アプリケーションのデータ ソース名 (DSN) の設定を構成します。最後に、新しいステータス保存データベースのテーブルを初期化します。新しい COM+ アプリケーションの作成については、「XLANG スケジュールをホストする COM+ アプリケーションの作成」を参照してください。

ここには次のトピックが含まれます。

  • 新しい空のステータス保存データベースの作成

  • COM+ アプリケーションのアプリケーション ID の変更

  • COM+ アプリケーションの DSN 設定の変更

  • XLANG スケジュールをホストする COM+ アプリケーションのシャットダウン

注

  • Microsoft SQL Server の詳細については、Books Online を参照してください。Books Online を表示するには、[スタート] ボタンをクリックして [プログラム] をポイントします。次に [Microsoft SQL Server] をポイントし、[Books Online] をクリックします。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。


新しい空のステータス保存データベースの作成

XLANG スケジュールの実行中のインスタンスだけをホストする COM+ アプリケーションにスケジュール情報を格納するために、新しいステータス保存データベースを作成することが必要になる場合があります。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Server] を展開し、[SQL Server グループ] を展開します。次に、新しいデータベースを追加するサーバーを展開し、[データベース] を展開します。

  3. [データベース] をクリックします。

  4. [操作] メニューの [新規データベース] をクリックします。

    [データベースのプロパティ] ダイアログ ボックスが表示されます。

  5. [全般] プロパティ ページの [名前] ボックスに新しいデータベースの名前を入力し、[OK] をクリックします。

この操作によって、既定値のセットで新しいデータベースが作成されます。これらの既定値は変更することができます。

注

  • SQL Server の詳細については、[スタート] メニューの [プログラム] をポイントし、[Microsoft SQL Server] をポイントして、[Books Online] をクリックしてください。

関連項目

既定のXLANG スケジューラ アプリケーションのアプリケーション ID の変更

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


COM+ アプリケーションのアプリケーション ID の変更

XLANG スケジュールをホストする新しい COM+ アプリケーションを作成したら、ユーザー情報を変更する必要があります。XLANG スケジュールをホストする新しい COM+ アプリケーションの作成については、「XLANG スケジュールをホストする COM+ アプリケーションの作成」を参照してください。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. ID を変更する COM+ アプリケーションをクリックし、[操作] メニューの [プロパティ] をクリックします。

    選択した COM+ アプリケーションの プロパティ ダイアログ ボックス表示されます。

  4. [詳細設定] プロパティ ページの [許可] で、[変更を許可しない] チェック ボックスがオフになっていることを確認し、[OK] をクリックします。

    プロパティ ダイアログ ボックスが閉じます。

  5. COM+ アプリケーションを再度右クリックし、[プロパティ] をクリックします。

    選択した COM+ アプリケーションの プロパティ ダイアログ ボックス表示されます。

  6. [ID] プロパティ ページの [アカウント] で [このユーザー] をクリックします。

  7. 使用するアカウントの情報を入力します。

  8. [OK] をクリックします。

    次のメッセージが表示されます :

    アプリケーションは 1 つ以上の外部プロダクトから作成されました。それらの外部プロダクトは、保存しようとしている変更内容をサポートしますか?

  9. [はい] をクリックします。

注

  • XLANG スケジュールをホストする COM+ アプリケーションのアプリケーション ID の設定に関する問題については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

関連項目

既定のXLANG スケジューラ アプリケーションのアプリケーション ID の変更

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


COM+ アプリケーションの DSN 設定の変更

空の新しいステータス保存データベースを作成したら、XLANG スケジュールをホストする COM+ アプリケーションのデータ ソース名 (DSN) の設定を作成して、XLANG スケジュールが新しいステータス保存データベースに関連付けられるように構成します。さらに、データベース テーブルを初期化します。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. DSN 設定を変更する COM+ アプリケーションをクリックします。

  4. [操作] メニューの [プロパティ] をクリックします。

    選択した COM+ アプリケーションの プロパティ ダイアログ ボックス表示されます。

  5. [XLANG] プロパティ ページで、[ファイル DSN を使用] チェック ボックスをオンにします。

  6. [DSN の作成] をクリックします。

    [ODBC データ ソース アドミニストレータ] ダイアログ ボックスが表示されます。

  7. [必要なデータベース] メッセージ ボックスの情報を確認して、[OK] をクリックします。

    [データソースの新規作成] ページが表示されます。

  8. 使用するデータソースの種類を選択します。[次へ] をクリックします。

  9. [セットアップするデータ ソースのドライバを選択してください] の一覧で [SQL Server] をクリックし、[次へ] をクリックします。

  10. データ ソースの名前が XLANG スケジュールをホストする COM+ アプリケーションと同じであることを確認して、[次へ] をクリックし、[完了] をクリックします。

    重要

    • DSN と COM+ アプリケーションは同じ名前を使用する必要があります。たとえば、COM+ アプリケーションの名前が "XLANG Scheduler1" である場合は、DSN の名前も "XLANG Scheduler1" にします。

    [SQL Server に接続するための新規データソースを作成する] ページが表示されます。

  11. COM+ アプリケーションに関連付ける新しいステータス保存データベースの置かれたサーバーを選択して、[次へ] をクリックします。

  12. [ネットワークへのログイン ID で、Windows NT の認証メカニズムを使う] チェックボックスをオンにして、[次へ] をクリックします。

  13. [既定のデータベースを以下のものに変更する] チェックボックスをオンにして、この COM+ アプリケーションをホストする新しい空のステータス データベースを選択します。

  14. [次へ] をクリックし、[完了] をクリックします。

  15. [XLANG] プロパティ ページの [テーブルの初期化] をクリックします。

    注意

    • この手順は、空の新しいステータス保存データベースを使用することを前提としています。既存のステータス保存データベースを使用している場合には、[テーブルの初期化] をクリックしないでください。これを行うと、既存のデータベースにあるデータが破棄されます。
  16. [データベースの初期化の確認] メッセージ ボックスで、[はい] をクリックします。

注

  • ユーザー DSN とシステム DSN に同じ名前を使うことは可能です。ただし、2 つの DSN に同じ名前を使用すると、XLANG アプリケーションのプロパティ ページでこれらを区別できなくなります。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

  • DSN の構成とデータ ソース (ODBC) の使用の詳細については、[ODBC データ ソース アドミニストレータ] ダイアログ ボックスの [ヘルプ] をクリックし、その内容を参照してください。

関連項目

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュールをホストする COM+ アプリケーションのシャットダウン

この手順では、特定の COM+ アプリケーションをシャットダウンします。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. シャットダウンする XLANG スケジュールをホストする COM+ アプリケーションをクリックします。

  4. [操作] メニューの [プロパティ] をクリックします。

    選択した COM+ アプリケーションの プロパティ ダイアログ ボックスが表示されます。

  5. [XLANG] プロパティ ページの [シャットダウンの制御] で、[この XLANG アプリケーション] をクリックします。

注意

  • COM+ アプリケーションを右クリックして、[シャットダウン] をクリックしないでください。次のいずれかの問題が発生することがあります。
    • 実行中の XLANG スケジュールのすべてがトランザクションの場合は、制御されないシャットダウンによって、すべての失敗時エラー処理プロセスと補正エラー処理プロセスが発生します。

    • 実行中の XLANG スケジュールのすべてがトランザクションではない場合は、スケジュール内で処理中のデータが失われます。

重要

  • データ ソース名 (DSN) を利用できない場合または構成が正しくない場合は、ステータス退避済みの XLANG スケジュールを再起動することはできません。XLANG スケジュールをホストする COM+ アプリケーションの DSN の構成の詳細については、「XLANG スケジュールをホストする COM+ アプリケーションの構成」を参照してください。

注

  • XLANG スケジュールをホストする COM+ アプリケーションを作成する場合は、[ステータス退避済み XLANG アプリケーションを再起動] オプションは利用できません。ステータス退避済みアプリケーションを再起動する方法の詳細については、「すべての XLANG アプリケーションの再起動」を参照してください。

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

関連項目

XLANG スケジュールの実行 (概念)

XLANG スケジュールの実行

すべての XLANG アプリケーションのシャットダウン


実行中の XLANG スケジュールの監視

XLANG Event Monitor または Windows 2000 イベント ビューアのいずれかを使用して、実行中の XLANG スケジュールを監視することができます。

  • XLANG Event Monitor : XLANG スケジューラ エンジンは、XLANG スケジュールを実行するときにスケジュール インスタンスの進行状況を示すさまざまな種類のイベントを生成します。XLANG Event Monitor を使用して XLANG スケジュール イベントを監視し、スケジュール インスタンスの進行状況を確認できます。既定の XLANG スケジューラ アプリケーションや XLANG スケジュールをホストするために作成したカスタム COM+ アプリケーションなど、すべての XLANG スケジューラ アプリケーションを監視することができます。XLANG Event Monitor は、任意の数のローカル コンピュータまたは分散コンピュータ上のホスト アプリケーションによって発行されたすべてのイベントに対して監視することができます。XLANG Event Monitor は、後の分析用に、これらのイベントをファイルに保存することもできます。

    XLANG Event Monitor の使用の詳細については、ツールに付属のリリース ノートを参照してください。Microsoft BizTalk Server 2002 セットアップ ウィザードによってインストールされる XLANG Event Monitor (XLANGMon.exe) とリリース ノートは、インストール ディレクトリの \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools にあります。

  • Windows 2000 イベント ビューア : Windows 2000 イベント ビューアは、XLANG スケジュールに関連するイベント メッセージを発行します。エラー メッセージを表示するためのイベント ビューアの使用の詳細については、次の関連項目を参照してください。
    • XLANG スケジュールのエラー メッセージをフィルタ処理するためのイベント ビューアの構成については、「BizTalk Server エラーのためのイベント ビューアの構成」を参照してください。

    • イベント ビューアの一般情報については、Windows 2000 Server ヘルプの「イベント ビューアを使う」を参照してください。

関連項目

Orchestration Services Error Messages


BizTalk Server 管理のトラブルシューティング

ここでは、BizTalk Server 管理コンソールのトラブルシューティングについて説明します。操作中にエラー メッセージが表示された場合、まずここで解決策を探してください。

この Microsoft® BizTalk™ Server 2002 ドキュメントがリリースされた後で明らかになった問題については、\Program Files\Microsoft BizTalk Server\Documentation フォルダの下にあるリリース ノートに補足説明が入ります。

ここには次のトピックが含まれます。

  • BizTalk Server 管理 MMC、BizTalk メッセージ マネージャ、または BizTalk メッセージ構成オブジェクト モデルへのアクセス時に許可拒否エラーが発生する

  • データベースからすべてのグループを取得できない

  • インターチェンジとドキュメントのサイズ制限

  • コンポーネント サービスと BizTalk Server 2002 とのトランザクション タイムアウトの不一致

  • BizTalk メッセージ サービスが開始しない

  • サーバーがメモリ不足のとき、BizTalk メッセージ サービスがシャットダウンしない

  • 保留キューから大量のドキュメントを削除するとパフォーマンスが低下する

  • 出力の検証に失敗する

  • サーバーがフラット ファイル インターチェンジ内のすべてのドキュメントを返さない

  • プリプロセッサの一覧にクラス識別子が表示されない

  • インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

  • BizTalk Server がドキュメントの処理を停止した

  • 受信機能でドキュメントが削除されない

  • HTTP 送信によってドキュメントが複製される

  • HTTP 受信機能が作動しない

  • クラスタ サーバーにインストールされた SQL Server に接続できない

  • 受信機能がドキュメントの処理を停止した

  • リモート サーバーを別の BizTalk メッセージ管理データベースに移動するとエラーが発生する

  • 解析エラー

  • IIS、BizTalk メッセージ マネージャ ツール、および SQL Server が別々のコンピュータにある場合の認証問題

  • BizTalk Server 2002 がクラスタ上の SQL Server と通信していると、セットアップとメッセージ サービスが失敗する

  • DBCS データが SMTP メッセージ ポート経由で送信されると文字が壊れる

  • ドキュメントが冗長または同時再送信されると重複インスタンスが作成される

注

  • 保留キュー内のエラー メッセージを確認すると、トラブルシューティングの詳細がわかります。保留キュー、エラー メッセージ、およびエラー処理の詳細については、「保留キュー」を参照してください。

  • エラー メッセージや警告メッセージなどの詳細をイベント ログで確認することもできます。イベント ログの詳細については、「イベント ビューアの管理」を参照してください。


BizTalk Server 管理 MMC、BizTalk メッセージ マネージャ、または BizTalk メッセージ構成オブジェクト モデルへのアクセス時に許可拒否エラーが発生する

原因 : BizTalk Server 2002 のセットアップ プログラムは、BizTalk Server Administrators グループにローカル グループ BUILTIN\Administrators を追加します。しかし、Administrators グループに属していて BizTalk Server Administrators グループに明示的に属していないユーザーが、BizTalk Server 管理コンソールの Microsoft 管理コンソール (MMC)、BizTalk メッセージ マネージャ、または BizTalk メッセージ構成オブジェクト モデルにアクセスしようとすると、許可拒否エラーが発生します。

解決策 : [コンピュータの管理] コンソールを使用して、個別のユーザーを BizTalk Server Administrators グループに明示的に追加します。


データベースからすべてのグループを取得できない

原因 1 : 次のメッセージが表示された場合、BizTalk メッセージ管理データベースがオフラインになっています。

Microsoft BizTalkServer_Group のインスタンスを列挙できません : BizTalk メッセージ管理データベースに接続できませんでした。

解決策 : サーバーがオフラインになっている原因を究明し、サーバーがオンラインになったら接続を再試行します。たとえば、BizTalk メッセージ管理データベースを格納しているサーバーがメンテナンスのためにオフラインになっている場合、このメッセージが表示されます。

原因 2 : BizTalk Server メッセージ サービス アカウントには Microsoft® SQL Server™ へのアクセス権がありません。

解決策 : BizTalk Server メッセージ サービス アカウントに SQL Serverへのアクセス権が付与されるようにします。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。


インターチェンジとドキュメントのサイズ制限

BizTalk Server に送信できるドキュメントの最大サイズは 20 MB です。BizTalk Server に送信できるインターチェンジの最大サイズは 20 MB です。

20 MB を超える XML UNICODE 形式のインターチェンジを受信する場合は、グローバル追跡の設定をオフにしておくことをお勧めします。7 ～ 10 MB を超える ANSI フラット ファイル インターチェンジを受信する場合は、インターチェンジ本体とドキュメント本体の追跡機能、およびチャネル構成のドキュメントのログ機能をオフにしておくことをお勧めします。サーバー グループの追跡の設定を構成する方法の詳細については、「サーバー グループの追跡のプロパティの設定」を参照してください。チャネル ドキュメントのログ機能のプロパティの詳細については、「ドキュメント ログのプロパティの設定」を参照してください。

20 MB を超える XML UNICODE 形式のドキュメント インスタンスを受信する場合は、BizTalk メッセージ マネージャのドキュメント ログの設定をオフにしておくことをお勧めします。7 ～ 10 MB を超える ANSI フラット ファイルを受信する場合は、BizTalk メッセージ マネージャのドキュメント ログの設定をオフにしておくことをお勧めします。特定のドキュメント インスタンスのコピーを格納する方法については、「ドキュメント ログのプロパティの設定」を参照してください。

関連項目

サーバー グループの追跡のプロパティの構成

ドキュメント ログのプロパティの設定


コンポーネント サービスと BizTalk Server 2002 とのトランザクション タイムアウトの不一致

コンポーネント サービスと BizTalk Server 2002 との間には、ファイル タイムアウトの不一致があります。BizTalk Server 2002 で既定のトランザクション タイムアウト値 (60 秒) を超えてファイルを送信すると、BizTalk Server 2002 はそのトランザクションを送信済みとして記録し、受信側のサーバーがファイルを受信する場合にエラーは発生しません。コンポーネント サービスはトランザクションを中断したものとして記録します。トランザクションはロールバックできません。


BizTalk メッセージ サービスが開始しない

原因 : BizTalk Server メッセージ サービス アカウントには、SQL Server へのアクセス権がありません。BizTalk メッセージ管理データベースに格納されている SQL サーバーに BizTalk Server が接続できない場合、BizTalk メッセージ サービスは開始されません。

解決策 : BizTalk Server が BizTalk メッセージ管理データベースに接続されているかを確認します。Microsoft SQL Server が正しく実行されているかを確認します。BizTalk Server を実行するためのサービス アカウントを作成する必要がある場合があります。サービス アカウント作成の詳細については、Microsoft® Windows® 2000 ヘルプの「サービスがログオン時に使うユーザー アカウントを選択するには」を参照してください。BizTalk Server メッセージ サービス アカウントに SQL Serverへのアクセス権が付与されるようにします。詳細については、「SQL ログオンの作成およびデータベース アクセスの付与」を参照してください。


サーバーがメモリ不足のとき、BizTalk メッセージ サービスがシャットダウンしない

原因 : BizTalk Server がインストールされているサーバーがメモリ不足の場合でも、BizTalk メッセージ サービスはドキュメントを処理しようとします。すべてのドキュメントが保留キューに置かれます。

解決策 : BizTalk メッセージ サービスを再起動します。


保留キューから大量のドキュメントを削除するとパフォーマンスが低下する

原因 : 保留キューから大量のドキュメントを削除すると、パフォーマンスが低下することがあります。

解決策 : 保留キューからすべてのドキュメントを削除する必要がある場合、この目的のために提供されている Microsoft® Visual Basic® サンプル スクリプト、PurgeBizTalkSuspendedQueue.vbs を使用することができます。BizTalk Server 2002 をインストールすると、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Miscellaneous フォルダにこのスクリプトが格納されます。

注意

  • 特定の BizTalk Server グループの保留キューに含まれるすべての内容を永久に削除する場合以外は、このサンプル スクリプトを使用しないでください。


出力の検証に失敗する

原因 1 : 送信元仕様のフィールドのデータ型がリンク先となる送信先仕様のフィールドのデータ型と一致していません。このエラーはイベント ビューアに記録されます。

解決策 : 送信元仕様または送信先仕様のいずれかのデータ型を修正します。送信元仕様と送信先仕様の詳細については、「仕様の作成と検証」を参照してください。

原因 2 : Functoid が送信先仕様のフィールドにリンクされていて、フィールドのデータ型のプロパティが文字列ではありません。

解決策 : 送信先仕様のフィールドのデータ型を String に変更します。それから、処理するドキュメントを BizTalk Server に送信します。データ型の詳細については、「宣言のプロパティの設定」を参照してください。

原因 3 : 送信先仕様のフィールドに、そのフィールドに既に割り当てられているデータ型以外のデータ型の定数値が割り当てられています。

解決策 : 送信先仕様のフィールドに関連付けられたデータ型を変更します。それから、処理するドキュメントを BizTalk Server に送信します。データ型の詳細については、「宣言のプロパティの設定」を参照してください。

原因 4 : EDIFACT データにリリース インジケータが含まれています。フィールドの物理的な最大文字制限を検証する場合、論理文字数にリリース文字が含まれます。このエラーはイベント ビューアに記録されます。

解決策 : EDIFACT データにリリース インジケータを使用しないようにします。BizTalk Server が、必要なときに自動的にリリース インジケータを送信データに挿入します。

関連項目

仕様の作成と検証

宣言のプロパティの設定


サーバーがフラット ファイル インターチェンジ内のすべてのドキュメントを返さない

原因 : インターチェンジ内のいずれかのドキュメントがドキュメント仕様を満たしていません。たとえば、ドキュメントに必須入力フィールドがありません。

解決策 : 仕様を満たしていないドキュメントを修正し、インターチェンジを再送信します。エラーが返されるのは仕様を満たしていないドキュメントについてですが、BizTalk Server はインターチェンジ内のすべてのドキュメントを処理できません。フラット ファイル構造はオープンな書式で、冗長検査を実装するようには設計されていません。


プリプロセッサの一覧にクラス識別子が表示されない

原因 : カスタム プリプロセッサが適切に登録されていません。

解決策 : カスタム プリプロセッサを再登録するか、一覧からほかのプリプロセッサを選択します。

関連項目

ファイル受信機能の構成 : [サービス] タブ

カスタム プリプロセッサ

受信機能でのドキュメントの処理


インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

原因 1 : BizTalk Server がインターチェンジまたはドキュメントを解析できませんでした。

解決策 : 保留キューからドキュメントを削除します。受信インターチェンジまたはドキュメントが、BizTalk Server で処理できる書式 (XML、X12、EDIFACT、またはフラット ファイル)であることを確認します。それから、インターチェンジまたはドキュメントを送信元の組織またはアプリケーションから BizTalk Server に再送信します。

BizTalk Server がドキュメントを解析できない場合、BizTalk Server がそのドキュメントを正しく読み取り、処理するための十分な情報がないため、ドキュメントはバイナリ データとして保留キューに表示されます。解析エラーの詳細については、「解析エラー」を参照してください。

原因 2 : BizTalk Server がインターチェンジまたはドキュメントを解析できましたが、データ コンテンツが有効ではありませんでした。タイムスタンプ "expiresAt" の期限が切れ、ドキュメントが有効でなくなっています。このエラーは、expiredAt フィールドが使用されている BizTalk フレームワーク ドキュメントで発生します。

解決策 : 保留キューからドキュメントを削除します。このドキュメントはもう有効ではありません。ドキュメントが有効でない原因を調べます。

原因 3 : ドキュメントのスキーマが正しくないため、BizTalk Server がドキュメントを解析できませんでした。受信したファイルがフラット ファイルで、ドキュメント仕様のコード ページが UTF-8 に設定されている場合、BizTalk Server は UTF-8 をサポートしないため、このドキュメントを解析できません。

解決策 : フラット ファイルを受信した場合、ドキュメント仕様が正しいかどうかを確認します。ドキュメント仕様のコード ページが UTF-8 に設定されている場合、BizTalk Server はドキュメントを処理できません。保留キューからドキュメントを削除します。詳細については、「参照のプロパティの設定」を参照してください。

関連項目

解析エラー

参照のプロパティの設定

保留キュー


BizTalk Server がドキュメントの処理を停止した

原因 1 : BizTalk メッセージ管理データベース、追跡データベース、または共有キュー データベースのいずれかへの接続が切断された場合、またはそのほかの理由でこれらのデータベースにアクセスできない場合、BizTalk Server はドキュメントの処理を続行できません。Microsoft SQL Server が Enterprise Manager からシャットダウンされたか、または 一時停止された場合に、このような状況が発生することがあります。BizTalk Server 2002 にこのエラーが発生した場合、BizTalk メッセージ サービスが正常にシャットダウンされ、エラー発生時の処理状態と整合性が正しく保存されます。サービスがシャットダウンされる原因になったエラーの詳細がイベント ビューアに記録されます。

解決策 : このエラーを使用することによって、ページャー通知または電子メールによるステータス配信を通じて、システム管理者に BizTalk Server がオフラインであることを通知することができます。このような通知を受信したら、管理者は Microsoft 管理コンソール （MMC） スナップインのサービスを使用して、BizTalk メッセージ サービスを手動で再開し、再びイベント ログを調べてエラーが解消されているかどうかを確認します。エラーがまだ解消されていない場合は、管理者は BizTalk Server が SQL Server サービスを利用できるかを確認します。BizTalk メッセージ サービスの開始方法については、「BizTalk サービスの開始」を参照してください。

原因 2 : BizTalk Server 2002 がインストールされているサーバーにウィルス対策ソフトウェアが導入されている場合、メッセージ ポートの既定の設定では正しくない可能性があります。

解決策 : ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。メッセージ ポートで既定の設定になっているファイル トランスポートの種類を使用し、BizTalk Server 2002 がインストールされているサーバーでウィルス対策ソフトウェアを使用していて、正確に同じ名前の複数のファイルを同じファイル位置に同時に送信すると、BizTalk Server 2002 が応答しなくなることがあり、その場合再起動する必要があります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。この問題は、メッセージ ポートのファイル パス形式 (file://C:\dir\file%tracking_id%.xml) を使用して処理されるドキュメント インスタンスごとに一意なファイルを作成することで解決することもできます。詳細については、「トランスポート アドレスの指定」を参照してください。サーバーを再起動する必要がある場合は、「グループ内のサーバーの起動」を参照してください。

関連項目

トランスポート アドレスの指定

BizTalk サービスの開始

グループ内のサーバーの起動


受信機能でドキュメントが削除されない

原因 : 再試行の間隔が、生成されたドキュメント数に対して必要な処理能力より低く設定されている可能性があります。

解決策 : 再試行の間隔を 2 倍にして、BizTalk Server にドキュメントを再送信します。再試行の間隔を構成する方法については、「詳細構成のプロパティの設定」を参照してください。


HTTP 送信によってドキュメントが複製される

原因 : BizTalk サーバーが HTTP トランスポート サービスを使用してメッセージを送信している場合、送信が正常に完了しても BizTalk Server がエラーの通知を受信することがあります。たとえば、送信タイムアウトが通知されます。タイムアウトが発生したときは、HTTP サーバーが要求を正常に処理した場合でも、HTTP サーバーとの接続が中断されてエラーが報告されます。エラーが発生すると、BizTalk は送信を再試行します。これは、最初の送信が失敗するためで、ドキュメントは複製される可能性があります。

解決策 : HTTP など、トランザクション プロトコル以外での送信が一度だけ行われるようにするには、信頼できるメッセージを使用します。詳細については、「信頼できるメッセージを使用した受信確認処理」を参照してください。


HTTP 受信機能が作動しない

原因 1 : HTTP 受信機能を作成する前に、BizTalkHTTPReceive.dll ファイルが適切に展開されていませんでした。

解決策 : HTTP 受信機能を作成する前に BizTalkHTTPReceive.dll ファイルを展開します。HTTP 受信機能の追加方法の詳細については、「HTTP 受信機能の追加」を参照してください。

原因 2 : BizTalkHTTPReceive.dll を含む IIS 仮想ディレクトリの分離レベルが低に設定されていると、BizTalk Server のセキュリティ資格情報を持つユーザーのアカウントで実行されるように Internet Information Services (IIS) が構成されない場合があります。

解決策 : BizTalk Server SQL データベースおよび BizTalk COM+ アプリケーション (BizTalk Server インターチェンジ アプリケーションと BizTalk メッセージ内部ユーティリティ) の両方にアクセス権を持つユーザーのアカウントで実行されるように IIS を構成し、次に IIS サービスを終了して再開します。

原因 3 : クライアントが正しい URL フォーマットを使用していないか、Hypertext Transfer Protocol (HTTP) が HTTP 受信機能にデータを転送する際に使用する仮想ディレクトリのエンコードを行っていません。

解決策 : クライアントの指定を URL にしたときには、HTTP 受信機能を正しく動作させるために、HTTP 経由でデータを HTTP 受信機能に転送する必要があります。クエリ文字列には、UTF-8 コードページを使ってエンコードされたマルチバイト文字列 (MBCS) を使用する必要があります。詳細については、MSDN オンライン ライブラリ Web サイト (www.microsoft.com/japan/developer/library/default.asp) にアクセスして、「マルチバイト文字セット (MBCS) のサポート」を検索してください。


クラスタ サーバーにインストールされたSQL Server に接続できない

原因 1 : Microsoft SQL Server がクラスタ サーバーにインストールされている場合、SQL Server は TCP/IP を使用して接続するクライアントだけをサポートします。

解決策 : SQL Server クライアント ツールをインストールして、既定のネットワーク ライブラリを TCP/IP に変更します。SQL Server クライアント ツールのインストールの詳細については、「SQL Server クライアント ツールのインストール」を参照してください。既定のネットワーク ライブラリの変更については、「既定のネットワーク ライブラリの TCP/IP への変更」を参照してください。

原因 2 : BizTalk Server のアカウントには SQL Server へのアクセス権がありません。

解決策 : BizTalk Server メッセージ サービス アカウントに SQL Server へのアクセス権が付与されるようにします。詳細については、「セキュリティ ガイドライン」を参照してください。

各国語対応に関する問題

原因 3 : Microsoft SQL Server がインストールされていないコンピュータに BizTalk Server をインストールして、異なる既定の言語バージョンの SQL Server を実行するリモート SQL Server コンピュータ上で BizTalk Server データベースをセットアップしようとするとエラーが発生します。BizTalk Server 2002 データベース セットアップ ウィザードの実行中に、次のエラー メッセージが表示されます。

ログイン <データベース名> で要求されたデータベースを開けません。ログインは失敗しました。

解決策 : この問題が発生しないようにするには、BizTalk Server をインストールする前にサンプルのユーザー データ ソース名 (DSN) を作成します。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に、[コントロール パネル] をクリックし、[管理ツール] をダブルクリックして [データ ソース (ODBC)] をダブルクリックします。

    [ODBC データ ソース アドミニストレータ] ダイアログ ボックスが表示されます。

  2. [ユーザー DSN] タブをクリックし、[追加] をクリックします。

    [データ ソースの新規作成] ダイアログ ボックスが表示されます。

  3. [名前] ボックスの一覧で [SQL Server] をクリックし、[完了] をクリックします。

    SQL Server に接続するための新規データ ソースを作成するウィザードが開きます。

  4. SQL Server に接続するための新規データ ソースを作成するウィザードを完了して、サンプルのユーザー DSN を作成します。

関連項目

既定のネットワーク ライブラリの TCP/IP への変更

SQL Server クライアント ツールのインストール


受信機能がドキュメントの処理を停止した

原因 1 : 1 台のリモート サーバーが同時にサポートできる受信機能は 50 までです。

解決策 : 複数の受信機能のサポートの詳細については、Microsoft 製品サポート サービスの Web サイト (http://search.support.microsoft.com/kb/c.asp?lng=jpn&sa=per) で、サポート技術情報の次の記事を検索してください。

  • 「IIS がリモートの UNC パスに接続すると PRC でエラーが発生する」 (JP221790)

詳細については、サポート技術情報の次の記事を参照してください。

  • 「Windows NT のローカル システム アカウントと Null セッション 」(JP132679)

  • 「システム アカウントで実行されているサービスがネットワークにアクセスできない」(JP124184)

  • 「[PRB] サービスから名前付きパイプを開こうとするとアクセス拒否」(JP126645)

  • 「[NT]FindFirstChangeNotification がすべてのプロセスには通知しない」(J045160)

原因 2 : ファイル受信機能を使用していて、ほかの処理が BizTalk Server と同時にファイルを使用している場合は、1 つ以上のファイル受信機能がドキュメントの処理を停止し、利用できなくなることがあります。これは、BizTalk Server がファイルを正常に処理しているが、そのファイルがほかのアプリケーションによってアクセスされているために削除できない場合に発生します。ほかのアプリケーションがそのファイルの使用を停止した場合にデータが再度処理されることがないよう、ファイル受信機能は無効にされます。

解決策 : この問題が発生しないようにするには、ファイル受信機能によって監視されているフォルダの中のファイルが、ほかのアプリケーションによって使用されていないことを確認します。これには、受信ファイルを監視するウィルス保護ソフトウェアも含まれます。

原因 3 : メッセージ キュー受信機能が、パススルー送信として送信されたドキュメントを受信した場合は、受信機能がシャットダウンして次のエラー メッセージが表示されます。

受信機能を変更してパススルー送信を受け入れるようにするか、キューからパススルー ドキュメントを削除してください。

解決策 : メッセージ キュー受信機能がパススルー送信を許可するように構成されていません。キューでメッセージの AppSpecific プロパティについて調べて、パススルー送信として受信されたドキュメントを特定するアプリケーションを作成します。そのドキュメントを削除し、受信機能を再開します。


リモート サーバーを別の BizTalk メッセージ管理データベースに移動するとエラーが発生する

原因 : BizTalk メッセージ管理データベースにリモート サーバーを追加するとき、そのサーバーが既に別の中央 BizTalk メッセージ管理データベースに属していた場合、Windows イベント ログに次のエラー メッセージが表示されます。

WMI クラスの新しいインスタンス "MicrosoftBizTalkServer_Server" を BizTalk Server WMI プロバイダで作成できません :サーバー <サーバー名> が別の BizTalk Server インストールに属している可能性があります。

このエラーは、もともと別のデータベースに属していたリモート サーバーを追加しようとしたことを示します。BizTalk Server 管理コンソールでこの手順が実行された場合、管理コンソールはそのリモート サーバーがリモート データベースのグループにも属しているかどうかを判断しようとします。管理コンソールはリモート サーバーの Windows Management Instrumentation (WMI) プロバイダに問い合わせ、これを判断します。サーバーが別の中央データベースのグループに属している場合、既に別の中央データベースのグループに属しているリモート サーバーは追加できないことを示す管理コンソールからのエラー メッセージが表示されます。

解決策 : まず、前のデータベースからサーバーを削除し、次にそれを現在のデータベースに追加します。

関連項目

Windows Management Instrumentation (WMI) について


解析エラー

原因 1 : 信頼できるメッセージを送信する場合、ポートの既定の設定では正しくない可能性があります。ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。既定の設定のファイル トランスポートの種類を選択し、メッセージ ポートで Reliable エンベロープ書式のエンベロープを選択して、複数のファイルを同時に同じファイル位置に送信すると、予期しない解析結果を生じることがあります。

解決策 : この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで 、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。ポートの既定の設定の変更については、「メッセージ ポート既定値の変更」を参照してください。

その他の原因 : さまざまな原因により BizTalk Server がドキュメントを解析できません。一般的な原因として次のものがあります。

  • BizTalk Server が解析不能な書式のインターチェンジまたはドキュメントが存在する。

  • ドキュメントのスキーマが正しくない。

  • フラット ファイル インターチェンジのスキーマが正しくないか無効である。

  • フラット ファイル インターチェンジに無効な文字が含まれている。

  • フラット ファイル インターチェンジに文字がない。

  • フラット ファイル インターチェンジに区切り記号がない。

  • BizTalk フレームワーク 2.0 ドキュメントに、ポートまたはチャネルに一覧表示される無効なエイリアスが含まれている。

  • カスタム XML ヘッダーにドキュメント コンテナ ノードがない。

  • カスタム XML ドキュメントに属性がない。

  • EDI ドキュメント仕様がエンベロープと一致しない。

解決策 : インターチェンジ データまたはドキュメント データを表示して、BizTalk Server がインターチェンジまたはドキュメントを解析できない原因を調べます。インターチェンジ データまたはドキュメント データを表示するには、次の方法を使用できます。

  • インターチェンジ データまたはドキュメント データの最初の 512 バイトを表示します。データの表示方法の詳細については、「インターチェンジの表示」または「ドキュメントの表示」を参照してください。

  • BizTalk ドキュメント トラッキングでインターチェンジ レコード内のインターチェンジ データを表示します。BizTalk ドキュメント トラッキングでのインターチェンジの表示方法の詳細については、「日付によるインターチェンジとドキュメントの情報の検索」、「組織によるインターチェンジとドキュメントの情報の検索」、「ドキュメント型によるインターチェンジとドキュメントの情報の検索」、または「クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索」を参照してください。

  • Windows Management Instrumentation (WMI) レイヤを使用してインターチェンジ データを表示します。WMI アプリケーション プログラミングの詳細については、MSDN オンライン ライブラリの Web サイト (www.microsoft.com/japan/developer/library/default.asp) で 「WMI アプリケーション プログラミングについて」を検索してください。

BizTalk Server がドキュメントを解析できない原因が判明したら、原因となった問題を修正し、IInterchange または受信機能を使用してインターチェンジまたはドキュメントを再送信してください。

関連項目

インターチェンジまたはドキュメントがバイナリ データとして保留キューに表示される

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索

クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

保留キュー

ドキュメントの表示

インターチェンジの表示


IIS、BizTalk メッセージ マネージャ ツール、および SQL Server が別々のコンピュータにある場合の認証問題

原因 : BizTalk メッセージ マネージャ ツール、インターネット インフォーメーション サービス (IIS)、および Microsoft SQL Server を別々のコンピュータにインストールすると、認証問題が発生することがあります。認証の問題は、ダブル ホップのために発生します。つまり、最初のホップでは、リモート クライアント コンピュータ A 上の BizTalk メッセージ マネージャ ツールから、コンピュータ B 上の BizTalk Server と IIS に認証が送信されます。一方 2 番目のホップでは、IIS は、コンピュータ C 上の SQL Server 構成データベースにその認証を送信することができません。

解決策 : BizTalk メッセージ マネージャ ツール (リモート クライアント)、IIS、および SQL Server を 3 つのコンピュータではなく 2 つのコンピュータに構成します。以下の構成がサポートされています。

  • BizTalk メッセージ マネージャ ツールと IIS を同じコンピュータにインストールし、SQL Server を別のコンピュータにインストールする。

  • BizTalk メッセージ マネージャ ツールを 1 台のコンピュータ (リモート コンピュータ) に、IIS と SQL Server をもう 1 台のコンピュータにインストールする。

IIS 認証の詳細については、Microsoft 製品サポート サービスの Web サイト（http://search.support.microsoft.com/kb/c.asp?lng=jpn&sa=per）で、サポート技術情報の記事「INFO: How IIS Authenticates Browser Clients」(Q264921) を検索してください。

注意

  • BizTalk Server と IIS は同じコンピュータにインストールする必要があります。

注

  • BizTalk メッセージ マネージャ ツールと SQL Server 構成データベースが同じコンピュータにインストールされていて、BizTalk Server と IIS がもう 1 台のコンピュータにインストールされている場合も、このダブル ホップ認証の問題が発生します。この構成はサポートされていないことに注意してください。


BizTalk Server 2002 がクラスタ上の SQL Server と通信していると、セットアップとメッセージ サービスが失敗する

BizTalk Server 2002 がスタンドアロン コンピュータにインストールされていて、Microsoft のクラスタ サービス クラスタ上で SQL Server データベースを実行している場合は、BizTalk メッセージ管理データベースのセットアップ中にセットアップ プログラムでエラーが発生し、次のようなエラー メッセージが生成されます。

BizTalk Server は、データベース接続情報を使用して、<SQL サーバー> サーバー上の <BizTalk メッセージ管理データベース名> データベースにアクセスできませんでした。

これは、MDAC 2.6 の SQLOLEDB プロバイダの問題です。この問題を解決するには、MDAC 2.7 が公開されたらそれにアップグレードしてください。


DBCS データが SMTP メッセージ ポート経由で送信されると文字が壊れる

各国語対応に関する問題

原因 : Microsoft Data Access Components (MDAC) 2.5をインストールし、SMTP メッセージ ポートに Multipurpose Internet Mail Extensions (MIME) エンコードを行うように構成した場合、そのポートから 2 バイト文字セット (DBCS) データを送信するとデータが壊れます。MDAC 2.5は、Windows 2000 Service Pack のすべてのバージョンに含まれています。

解決策 : この問題を回避するには、MDAC 2.6 をインストールします。以下のいずれかの方法で MDAC 2.6 をインストールできます。

  • MDAC 2.6 を直接インストールするには、ブラウザを開き、Microsoft Universal Data Access Web のサイト (www.microsoft.com/japan/developer/data/) に移動し、ダウンロードします。

  • MDAC 2.6 が含まれている SQL Server 2000 クライアント ユーティリティをインストールします。

現時点では、MDAC 2.5 および MDAC 2.6 の両方で動作する修正プログラムはありません。


ドキュメントが冗長または同時再送信されると重複インスタンスが作成される

原因 : 複数のユーザーまたは BizTalk Server 管理コンソールの複数のインスタンスが同じドキュメントのバッチを同時に再送信している場合は、作業キューに重複インスタンスが作成されます。

解決策 : 複数のインスタンスから同時に同じドキュメントのグループを再送信しないようにします。


ドキュメントの追跡

BizTalk ドキュメント トラッキングは、Microsoft® BizTalk™ Server 2002 のドキュメント処理状況を表示するスタンドアロンの Web アプリケーションです。クエリまたは高度なクエリを作成し、追跡データベースから重要な情報を、見やすい形式に抽出できます。BizTalk ドキュメント トラッキングを使って、ドキュメントの送信元と送信先、ドキュメント名とドキュメント型、および関連する日付と時刻のパラメータに関して記録された情報を表示できます。標準検索およびカスタム検索フィールドを表示するクエリを作成して、業務運用結果を分析することもできます。たとえば、サプライヤに送信した注文ごとに注文金額合計フィールドを記録することができます。そしてこのデータを使用して、一定期間にわたる仕入金額の合計を分析し、サプライヤに報告できます。

また、BizTalk ドキュメント トラッキングでは、インターチェンジとドキュメントのレコードを個々にまたは一括して表示するように構成することもできます。さらに、BizTalk ドキュメント トラッキングを使用して、受信ドキュメント インスタンスおよび送信ドキュメント インスタンスの完全なコピーを表示、閲覧、保存し、後で確認することもできます。

ここには次のトピックが含まれます。

  • BizTalk ドキュメント トラッキングの詳細については、「BizTalk ドキュメント トラッキングについて」を参照してください。

  • 各作業の目的をまとめたクイック リファレンスについては、「BizTalk ドキュメント トラッキングに関する作業を行う目的」を参照してください。

  • 作業を実行する手順の詳細については、「BizTalk ドキュメント トラッキングに関する作業を行う方法」を参照してください。

  • 問題を解決するためのヒントについては、「BizTalk ドキュメント トラッキングのトラブルシューティング」を参照してください。

重要

  • BizTalk ドキュメント トラッキングへのアクセスは、Web アプリケーションと同様に Microsoft Internet Explorer で行うため、Microsoft BizTalk Server 2002 ヘルプへのアクセス方法も異なり、ヘルプで利用できる機能が一部制限されています。[目次]、[キーワード]、[検索]、および [お気に入り] の各タブは利用できません。すべてのトピックには、開始ページからのリンク、関連項目のリンクを通してアクセスすることができます。ブラウザの [戻る] ボタンも使用できます。

    特定のヘルプ トピックを検索したり、BizTalk Server 2002 のほかの機能やサービスに関する情報にアクセスするには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk Server ドキュメント] をクリックします。[スタート] ボタンからヘルプを利用できるようにするには、そのコンピュータ上に BizTalk Server 2002 をインストールする必要があります。

  • BizTalk ドキュメント トラッキングでは Microsoft ActiveX® コントロールが使用されるため、選択時またはクエリ送信時に ActiveX コントロールのダウンロード ダイアログ ボックスが表示されることがあります。表示された場合は、[はい] をクリックして作業を続行してください。

注

  • 選択時またはクエリ送信時に、次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。[信頼済みのサイト] の一覧へのWeb アプリケーションの追加の詳細については、「BizTalk Server 2002 用の IIS 設定の構成」を参照してください。


BizTalk ドキュメント トラッキングについて

ここでは、ドキュメントの追跡および利用状況の監視を理解するうえで不可欠な概念について説明します。

ここには次のトピックが含まれます。

  • BizTalk ドキュメント トラッキングの環境

  • BizTalk ドキュメント トラッキングの使用

  • 追跡データベース スキーマについて

  • インターチェンジとその関連ドキュメントの検索方法について

  • クエリ結果について

  • インターチェンジ用の統合 XLANG スケジュール ステータスについて

注

  • 選択時またはクエリ送信時に、ダイアログ ボックスに次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。[信頼済みのサイト] の一覧へのWeb アプリケーションの追加の詳細については、「BizTalk Server 2002 用の IIS 設定の構成」を参照してください。


BizTalk ドキュメント トラッキングの環境

ここには次のトピックが含まれます。

  • BizTalk ドキュメント トラッキングのユーザー インターフェイス

  • BizTalk ドキュメント トラッキングのショートカット キー


BizTalk ドキュメント トラッキングのユーザー インターフェイス

BizTalk ドキュメント トラッキングは、Microsoft BizTalk Server で追跡対象として構成したインターチェンジとドキュメントの表示に使用するスタンドアロンの Web アプリケーションです。メイン ページは、次の部分から構成されています。

  • [日付の範囲]

  • [送信元の選択]

  • [送信先の選択]

  • [高度なクエリ]

  • [並べ替えの指定]

  • [ドキュメント型の選択]

クエリ パラメータは、[日付の範囲]、[送信元の選択]、[送信先の選択]、および [ドキュメント型の選択] で構成できます。

このページの左下部には、[高度なクエリ] および [並べ替えの指定] の領域があります。特定の情報またはカスタム検索フィールドを検索するには、[高度なクエリ] でパラメータを構成します。[クエリ結果] ページの並べ替え順を指定するには、[並べ替えの指定] でオプションを構成します。

メイン ページの [クエリ] をクリックすると、[クエリ結果] ページが表示されます。追跡データベースのレコードがクエリ パラメータと一致すると、インターチェンジ レコードが一覧表示されます。次の表は、[クエリ結果] ページで利用できるアイコンとその説明の一覧です。

アイコン | 機能
[データ] アイコン | インターチェンジまたはドキュメント インスタンス データにアクセスします。インターチェンジ レコードの [データ] アイコンをクリックすると、インターチェンジ データが表示されます。ドキュメント インスタンス レコードの [データ] アイコンをクリックすると、ドキュメント データが表示されます。
[展開記号] アイコン | インターチェンジ レコードを展開し、ドキュメント インスタンス レコードを表示します。
[折りたたみ] アイコン | インターチェンジ レコードを折りたたみ、ドキュメント インスタンス レコードを非表示にします。
[XLANG スケジュール] アイコン | インターチェンジに関する XLANG スケジュール ステータスを表示します。
[受信確認] アイコン | 新しい [クエリ結果] ページで、受信確認の内容を表示します。受信確認の結果の詳細については、「受信確認の結果について」を参照してください。
[カスタム検索] アイコン | カスタム検索データを表示します。


BizTalk ドキュメント トラッキングのショートカット キー

BizTalk ドキュメント トラッキングでは、ショートカット キーを使用して作業を行うことができます。次の表は、メイン ページで利用できるショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。または、Windows 2000 Professional ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Alt + N | [高度なクエリ ビルダ] ページを表示します。
Alt + B | [高度なクエリ] ページを表示します。
Alt + C | 現在のクエリ セッションから高度なクエリを消去します。
Alt + S | [送信元の選択] ボックスの一覧で、すべての組織およびアプリケーションを選択します。
Alt + R | [送信元の選択] ボックスの一覧を消去します。
Alt + E | [送信先の選択] ボックスの一覧で、すべての組織およびアプリケーションを選択します。
Alt + A | [送信先の選択] ボックスの一覧を消去します。
Alt + W | [ドキュメント型の選択] ボックスの一覧で、すべてのドキュメント型を表示します。
Alt + T | [ドキュメント型の選択] ボックスの一覧で、すべてのドキュメント型を選択します。
Alt + L | [ドキュメント型の選択] ボックスの一覧を消去します。
Alt + Q | [クエリ結果] ページを表示します。
Alt + O | BizTalk ドキュメント トラッキングを終了します。
Alt + H | オンライン ヘルプを表示します。
Alt + フィールド名の下線付き文字または数字 | 特定のフィールドにフォーカスを移動します。たとえば、Alt キーを押しながら 1 キーを押すと、[並べ替え順 1] にフォーカスが移動します。

次の表は、[クエリ結果] ページで利用できるショートカット キーの一覧です。[クエリ結果] ページを表示するには、Alt キーを押しながら Q キーを押します。

ショートカット キー | 機能
Alt + C | [クエリ結果] ページを閉じます。
Alt + H | オンライン ヘルプを表示します。
Space | アイコンを開く、または閉じます。開くまたは閉じるアイコンにフォーカスを移動する場合は、Tab キーを使用してください。たとえば、インターチェンジ レコードを展開する場合は、対象のインターチェンジ レコードの [展開] アイコン (+) にフォーカスが移動するまで繰り返し Tab キーを押します。次に、Space キーを押します。

次の表は、[高度なクエリ ビルダ] ページで利用できるショートカット キーの一覧です。[高度なクエリ ビルダ] ページを表示するには、メイン ページで、Alt キーを押しながら N キーを押します。

ショートカット キー | 機能
Alt + N | 高度なクエリ式に条件を追加します。
Alt + E | 条件を編集します。
Alt + R | 高度なクエリ式から条件を削除します。
Alt + S | クエリ式を保存します。
Alt + O | クエリ式の適用対象を現在のクエリ セッションに限定します。
Alt + C | [高度なクエリ ビルダ] ページを閉じます。
Alt + H | オンライン ヘルプを表示します。
Alt+ フィールド名の下線付き文字 | 特定のフィールドにフォーカスを移動します。たとえば、Alt キーを押しながら V キーを押すと、[値] フィールドにフォーカスが移動します。

注

  • フォーカスを [クエリ] に移動し、そこに条件が複数あるときは、↑キーまたは↓キーを使用して目的の条件を選択します。

次の表は、[高度なクエリ] ページで利用できるショートカット キーの一覧です。[高度なクエリ] ページを表示するには、メイン ページで、Alt キーを押しながら B キーを押します。

ショートカット キー | 機能
Alt + E | 既存のクエリ式を編集します。
Alt + N | [高度なクエリ ビルダ] ページを表示します。
Alt + D | クエリ式を削除します。
Alt + O | 現在のクエリにクエリ式を追加します。
Alt + C | 変更を保存しないで [高度なクエリ] ページを閉じます。
Alt + H | オンライン ヘルプを表示します。


BizTalk ドキュメント トラッキングの使用

BizTalk ドキュメント トラッキングを使用すると、次のことを行うことができます。

  • Microsoft BizTalk Server 2002 によって処理されるインターチェンジとその関連ドキュメントを追跡します。

  • 電子ビジネス トランザクションのすべてのコピーを保存するための法律または標準に関する条件を満たします。

  • 顧客からの問い合わせに迅速かつ容易に回答します。たとえば、「取引先 A に請求書を送ったのはいつでしたか」という問い合わせがあると、日付、時刻、さらに取引先から受信確認が送られてきたかどうかを検索できます。

  • トラブルシューティングに役立てることができます。

  • 争議の解決に役立てることができます。

ドキュメントの追跡は、一括してまたは単一トランザクションとして行うことができます。BizTalk ドキュメント トラッキングでは、送信元と送信先の情報、ドキュメント型、日時パラメータなど、インターチェンジに関連付けられたメタデータを自動的に格納します。メタデータは自動的に格納されますが、注文日付または注文金額合計などの詳細なフィールドが取得されるのは、このような情報を BizTalk メッセージ構成オブジェクト モデルまたは BizTalk メッセージ マネージャで取得できるように構成した場合だけです。目的のフィールドを追跡対象として構成することについては、「チャネルのプロパティの設定」および「受信ドキュメントの追跡のプロパティの設定」を参照してください。

すべての追跡情報 (メタデータまたは追跡対象として構成したフィールドのいずれも) は、インストール時またはサーバー グループの構成時に構成した追跡データベースに自動的に格納されます。BizTalk ドキュメント トラッキングのユーザー インターフェイス (UI) を使用すると、特定のサーバー グループに関連付けられた追跡データベースに格納されているデータにアクセスできます。追跡データベースに格納されているデータは、このユーザー インターフェイスからすべて利用できるわけではありませんが、追跡対象として構成したメタデータとフィールドは簡単に利用できます。たとえば、購買アプリケーション C が注文書を取引先 D に送ったのはいつか、またこの取引先 D から注文書に対する返答があったかどうか、それはいつかといった情報を追跡する必要がある場合、BizTalk ドキュメント トラッキングを使用することで、こうした追跡を行うことができます。

ここには次のトピックが含まれます。

  • サーバー グループの追跡設定について

  • BizTalk メッセージ マネージャの追跡設定について

注

  • 「信頼できるメッセージ受信確認」は、BizTalk ドキュメント トラッキングのユーザー インターフェイスに表示されません。

関連項目

チャネルのプロパティの設定

受信ドキュメントの追跡のプロパティの設定

追跡データベース


サーバー グループの追跡設定について

サーバー グループの追跡設定では、インターチェンジの追跡を有効にするか無効にするかを指定します。このグローバル追跡設定は、BizTalk Server 管理コンソールで構成します。サーバー グループの追跡の設定を構成する方法の詳細については、「サーバー グループの追跡のプロパティの構成」を参照してください。[ドキュメント トラッキングを有効にする] チェック ボックスがオンの場合は、受信インターチェンジ、送信インターチェンジ、または元の MIME エンコード メッセージ、あるいはこれらすべてをログに記録するように BizTalk Server を構成できます。

Microsoft BizTalk Server 2002 をインストールすると、ドキュメント トラッキングが自動的に有効になり、受信インターチェンジのログ記録および送信インターチェンジのログ記録のオプションが選択され、次のようなインターチェンジのメタデータが追跡されます。

  • 送信元組織の情報

  • 送信先組織の情報

  • ドキュメント型

  • インターチェンジが BizTalk Server で処理された日時

  • ドキュメント数

  • エラー情報

  • コントロール ID

インターチェンジの追跡だけでなく、注文金額合計や請求金額合計など特定のフィールドを BizTalk Server で追跡できるように構成することもできます。特定フィールドの追跡の詳細については、「BizTalk メッセージ マネージャの追跡設定について」を参照してください。否認防止および商法上の問題に備えて、インターチェンジのコピーを元の書式で保存する必要がある場合は、グローバル追跡設定を使用します。社内用の監査記録を作成する、またはドキュメント単位でデータに簡単にアクセスできるようにする場合は、BizTalk メッセージ構成オブジェクト モデルまたは BizTalk メッセージ マネージャで追跡設定を構成します。ただし、これにより追跡データベースのサイズが短期間に肥大化する可能性があり、データが重複して格納されることもあります。

BizTalk ドキュメント トラッキングの設定を無効にする

ドキュメントを追跡する必要がない場合は、BizTalk ドキュメント トラッキングを無効にすることができます。ただし、ドキュメント トラッキングを無効にすると、重要な機能が使用できなくなります。たとえば、ドキュメント トラッキングを無効にすると、次のことができなくなります。

  • BizTalk Server 2002 で処理されるインターチェンジとその関連ドキュメントを追跡する。

  • 電子ビジネス トランザクションのすべてのコピーを保存するための法律または標準に関する要件を満たす。

  • 顧客からの問い合わせに迅速かつ簡単に回答する。たとえば、「取引先 A に請求書を送ったのはいつでしたか」という問い合わせがあったとき、日付、時刻、さらに受信確認が送られてきたかどうかを検索する。

  • トラブルシューティングに役立てる。

  • 争議の解決に役立てる。

ドキュメント トラッキングを有効または無効にする、あるいはグローバル追跡設定を変更するには、BizTalk Server 管理コンソールを使用します。サーバー グループの追跡の設定を構成する方法の詳細については、「サーバー グループの追跡のプロパティの構成」を参照してください。

注

  • BizTalk Server 管理コンソールを開くには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

  • インターチェンジとドキュメントの追跡には、サイズの制限があります。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

関連項目

サーバー グループの追跡のプロパティの構成

インターチェンジとドキュメントのサイズ制限

BizTalk Server 管理コンソールを開く

BizTalk メッセージ マネージャの追跡設定について


BizTalk メッセージ マネージャの追跡設定について

次のことを行う必要がある場合は、BizTalk メッセージ マネージャで追跡設定を構成してください。

  • 受信ドキュメント インスタンスと送信ドキュメント インスタンスの完全なコピーを格納する。

  • 注文金額合計や注文日など、特定のフィールドを取得対象として構成する。

サーバー グループの追跡のプロパティとは異なり、特定のフィールドの追跡またはドキュメント インスタンスのコピーの格納の機能が自動的に有効になることはありません。これらのオプションは、BizTalk メッセージ マネージャで適切なチャネルやドキュメント定義を構成する際に構成する必要があります。

受信ドキュメント インスタンスまたは送信ドキュメント インスタンスのコピーを格納する方法の詳細については、「ドキュメント ログのプロパティの設定」を参照してください。特定フィールドの追跡の詳細については、「チャネル内の仕様フィールドの選択」を参照してください。

注

  • BizTalk メッセージ マネージャを開くには、[スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  • ドキュメントの追跡と格納にはサイズの制限があります。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

  • 仕様フィールドを整数、実数、日付、またはテキストのいずれかのデータ型として追跡する場合、79 文字を超える仕様フィールド名は切り捨てられます。

    これらの仕様フィールドはカスタム データ型として追跡します。その際、フィールド名はフィールド値と共に SQL の ntext 型の列に格納されます。ntext 型の最大長は 2^30 - 1 (1,073,741,823) 文字です。

  • ドキュメントの詳細と受信確認状態が確認できない場合は、BizTalk サーバー管理コンソールで [ドキュメント トラッキングを有効にする] チェック ボックスがオンになっていない可能性があります。このチェック ボックスがオンになっていない場合は、受信確認の関連付けを行えません。

    ドキュメント ログを有効にするには、次の操作を行います。

    1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

    2. BizTalk Server 管理コンソールで、Microsoft BizTalk Server 2002 を展開して、ドキュメント トラッキング設定を変更する BizTalk Server グループを右クリックします。次に [プロパティ] をクリックします。

    3. [追跡] プロパティ ページで、[ドキュメント トラッキングを有効にする] チェック ボックスをオンにします。

    使用するその他のオプションを選択します。

各国語対応に関する問題

  • システム ロケールによっては、XML データの数値が追跡データベースに整数の追跡フィールドとして記録される際に、BizTalk Server によって誤って解釈されることがあります。たとえば、ドイツ語のロケールで、XML 数値 4.0 は 40 として追跡データベースにログされます。小数点 (.) が数字グループ化記号として誤って解釈されるからです。

    この問題については、2 つの回避策があります。1 つめは、要素または属性に小数が格納されることが前もってわかっている場合は、XML の要素または属性のデータ型を Real (r4) または Double Real (r8) に変更します。2 つめは、Number 型の要素または属性を整数ではなく実数として記録するように、ドキュメント定義またはチャネルを構成します。

関連項目

インターチェンジとドキュメントのサイズ制限

チャネル内の仕様フィールドの選択

ドキュメント ログのプロパティの設定

サーバー グループの追跡設定について


追跡データベース スキーマについて

サーバー グループ内のすべてのサーバーは単一の追跡データベースを共有します。追跡データベースは、Microsoft BizTalk Server 2002 でのインターチェンジとドキュメントの処理状況に関連するすべての情報を格納します。追跡データベースは、サーバーを通過するインターチェンジまたはドキュメントのステータスを追跡するために使用します。追跡データベースには、次の 3 つの主要なテーブルがあります。

  • dta_interchange_details

  • dta_outdoc_details

  • dta_indoc_details

これらをサポートするテーブルには次のものがあります。

  • dta_group_details

  • dta_interchange_data

  • dta_document_data

  • dta_debugdoc_data

  • dta_routing_details

  • dta_custom_field_names

  • dta_MIME_data

次の図は、追跡データベースのデータベース スキーマ全体を示しています。わかりやすいように、この図ではテーブル名だけを表示します。テーブル間をつなぐ線は、外部キー フィールドでテーブルがどのように接続しているかを示しています。これらのキー フィールド、およびそれらとほかのテーブルとの関係については、「メタデータ コア テーブルの構造」および「セカンダリ テーブルの構造」を参照してください。

ここには次のトピックが含まれます。

  • メタデータ コア テーブル

  • セカンダリ テーブル

  • メタデータ コア テーブルの構造

  • セカンダリ テーブルの構造

  • 関連テーブル

  • インターチェンジとドキュメントをログに記録する方法

  • 受信確認をログに記録する方法

  • ルーティング情報をログに記録する方法

  • 追跡データベースでの XLANG スケジュール イベントの追跡


メタデータ コア テーブル

コア テーブルには、BizTalk Server で処理されるインターチェンジのメタデータが格納されます。メタデータには、送信元組織および送信先組織の情報、ドキュメント型、インターチェンジの処理日時、ドキュメント数、エラー情報、コントロール ID が含まれます。

追跡データベースのメタデータの核を形成するテーブルは、次の 3 つです。

  • dta_indoc_details

  • dta_outdoc_details

  • dta_interchange_details

次の表は、これらのコア テーブルそれぞれの機能を示しています。

テーブル名 | 説明
dta_indoc_details | BizTalk Server に送信されるドキュメントごとにレコードを 1 つ作成します。
dta_outdoc_details | BizTalk Server で生成されるドキュメントごとにレコードを 1 つ作成します。BizTalk Server に送信されるドキュメント 1 つから、1 つまたは複数のドキュメントが生成され、それぞれの送信先に配信されることもあります。複数のチャネルやポート グループに送り先が該当することがあるためです。受信ドキュメントと送信ドキュメントを 2 つのテーブルに区別することにより、この 1 対他の関係を物理的に表現することができます。
dta_interchange_details | BizTalk Server で処理されるインターチェンジごとにレコードを 1 つ作成します。このテーブルの方向フラグにより、送信の方向が区別されます。

関連項目

メタデータ コア テーブルの構造


セカンダリ テーブル

メタデータ コア テーブルをサポートするセカンダリ テーブルは、次の 7 つです。

  • dta_document_data

  • dta_debugdoc_data

  • dta_interchange_data

  • dta_routing_details

  • dta_group_details

  • dta_custom_field_names

  • dta_MIME_data

これらのテーブルには、ドキュメント データ、ルーティング情報、カスタム検索情報などのサポート情報が格納されます。次の表は、これらのテーブルそれぞれの機能を示しています。

テーブル名 | 説明
dta_document_data | BizTalk Server で送受信されるドキュメントごとにレコードを 1 つ作成します。
dta_debugdoc_data | 中間 XML 形式を記録するためにメッセージ チャネル オブジェクトに構成される受信ドキュメントまたは送信ドキュメントの項目ごとに、行を 1 つ作成します。
dta_interchange_data | BizTalk Server で送受信されるインターチェンジごとに行を 1 つ作成します。このテーブルにも、呼び出し側アプリケーション IInterchange::SubmitSync に返される応答ドキュメントが格納されます。
dta_routing_details | BizTalk メッセージ管理データベースにおけるデータベースの相互依存をなくすために、メッセージ ポートのミラーとして機能します。特に、処理するドキュメントに関連する送信元と送信先の情報を追跡するために必要です。BizTalk メッセージ管理データベースからのこの情報は、新しい置き換えが検出されるたびに、ここで繰り返し処理されます。
dta_group_details | インターチェンジ内で同じ型のドキュメント グループ (ANSI X12 や EDIFACTなど) を用いるドキュメント形式に、拡張コンポーネント (パーサー、シリアライザ、および受信確認の関連付け) を提供します。このテーブルには、これらのコンポーネントによって解析またはシリアライズされたグループごとに、行を 1 つ作成します。
dta_custom_field_names | BizTalk Server で検出された、それぞれの追跡ログ対象フィールド ノード名とデータ型の組ごとに行を 1 つ作成します。このテーブルは dta_outdoc_details テーブルのための、外部キーに対するフィールド名取得用クロス リファレンスです。dta_indoc_details テーブルへは、dta_outdoc_details テーブルを経由し、dta_outdoc_details テーブルに対応する、dta_indoc_details テーブル内の親レコードをポイントする外部キーによって、このテーブル (data_custom_field_names) のフィールド名が間接的に関連付けられています。
dta_MIME_data | BizTalk Server に送信される MIME エンコード インターチェンジごとに行を 1 つ作成します。このテーブルは、添付ドキュメントを含む MIME データを追跡する方法を提供するものです。

関連項目

セカンダリ テーブルの構造


メタデータ コア テーブルの構造

メタデータ コア テーブルは相互にリンクし、追跡設定が構成されている場合、BizTalk Server で処理するすべてのインターチェンジのメタデータを格納します。サーバー グループの追跡設定を構成する方法については、「サーバー グループの追跡設定について」を参照してください。

dta_indoc_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_outdoc_details

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_group_details

  • dta_interchange_details

  • dta_error_message

  • dta_validity_values

このテーブルは、次のテーブルと 1 対 1 の関係を持っています。

  • dta_debugdoc_data

  • dta_document_data

dta_indoc_details テーブルには、BizTalk Server に送信されたドキュメントごとに、行が 1 つ作成されます。次の表は、dta_indoc_details テーブルのフィールドを示しています。

フィールド名 | 説明
nInDocKey | プライマリ キー、一意なレコード識別子です。
nDocumentDataKey | dta_document_data テーブルへの外部キーです。
nDebugDocDataKey | 受信ドキュメントの XML 形式の dta_debugdoc_data テーブルへの外部キーです。受信ドキュメントが XML である場合も例外ではありません。
nGroupKey | dta_group_details テーブルへの外部キーです。
nInterchangeKey | dta_interchange_details テーブルへの外部キーです。
uidTrackingGUID | グローバル一意識別子 (GUID) に基づいたマスタ トラッキング キーです。
dtProcessedTimeStamp | レコードが作成された時刻です。
nvcSyntax | ドキュメントの構文 (XML、ANSI X12、EDIFACT、HL7 など) のコードです。解析エラーのために構文が認識されない場合やパススルー送信のときは、このフィールドの値は "UNKNOWN" になります。
nvcVersion | 構文のバージョンです。
nvcRelease | バージョンのリリースです。
nvcDocType | ドキュメント型またはトランザクション セット識別子です。
nvcControlID | 電子データ交換 (EDI) ドキュメントとファンクショナル グループの一意な制御番号です。
nlsValid | 検証結果を示すコードです。値は、0 (無効)、1 (有効)、または 2 (パススルー) のいずれかです。
nError | エラーの発生を示すコードです。これは dta_error_message テーブルへの外部キーで、このテーブルにエラー メッセージの説明が含まれます。

dta_outdoc_details

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_indoc_details

  • dta_interchange_details

  • dta_group_details

  • dta_debugdoc_data

  • dta_routing_details

  • dta_error_message

  • dta_ack_status

  • dta_data_level_values

  • dta_validity_values

このテーブルは、次のテーブルと 1 対 1 の関係を持っています。

  • dta_document_data

このテーブルは、次のテーブルと多対多の関係を持っています。

  • dta_custom_field_names

  • dta_ack_status_values

dta_outdoc_details テーブルには、BizTalk Server によって送信されたドキュメントごとに、行が 1 つ作成されます。次の表は、dta_outdoc_details テーブルのフィールドを示しています。

フィールド名 | 説明
nOutDocKey | プライマリ キー、一意なレコード識別子です。
nInDocKey | dta_indoc_details 親レコードへの外部キーです。
nDocumentDataKey | dta_document_data テーブルへの外部キーです。
nDebugDocDataKey | 受信ドキュメントの XML 形式の dta_debugdoc_data テーブルへの外部キーです。受信ドキュメントが XML である場合も例外ではありません。送信ドキュメントがメッセージ ポート グループに送信される場合は、dta_debugdoc_data レコードのコピーが 1 つだけ格納されます。結果として得られる dta_outdoc_details レコードはすべて、それをポイントします。
nGroupKey | dta_group_details テーブルへの外部キーです。
nInterchangeKey | dta_interchange_details テーブルへの外部キーです。
uidTrackingGUID | グローバル一意識別子 (GUID) に基づいたマスタ トラッキング キーです。
dtProcessedTimeStamp | レコードが作成された時刻です。
nvcSyntax | ドキュメントの構文 (XML、ANSI X12、EDIFACT、HL7 など) のコードです。解析エラーのために構文が認識されない場合やパススルー送信のときは、このフィールドの値は "UNKNOWN" になります。
nvcVersion | 構文のバージョンです。
nvcRelease | バージョンのリリースです。
nvcDocType | ドキュメント型またはトランザクション セット識別子です。
nvcControlID | EDI ドキュメントおよびファンクショナル グループの一意な制御番号です。
nlsValid | 検証結果を示すコードです。値は、0 (無効)、1 (有効)、または 2 (パススルー) のいずれかです。
nError | エラーの発生を示すコードです。これは dta_error_message テーブルへの外部キーで、このテーブルにエラー メッセージの説明が含まれます。
nAckStatus | 受信確認状況のコードです。これは dta_ack_status_values テーブルへの外部キーで、このテーブルに受信確認状況の説明が含まれます。
nRoutingKey | dta_routing_details テーブルへの外部キーです。
nReceiptFlag | どのテーブルに受信確認が関連付けられているかを示すフラグです。値は、1 (インターチェンジ)、2 (グループ)、4 (受信ドキュメント)、8 (送信ドキュメント) のいずれかです。受信確認の詳細については、「受信確認をログに記録する方法」を参照してください。
nReceiptKey | 受信確認を示す一意な番号です。受信確認の詳細については、「受信確認をログに記録する方法」を参照してください。
dtReceiptDueBy | 受信確認の最終期限のタイムスタンプで、処理タイムスタンプとして算出されます。
nRealName1 | dta_custom_field_names テーブルへの外部キーです。
rlRealValue1 | 実数の追跡ログ対象フィールド 1 です。このフィールドの値は 8 バイトの実数である必要があります。
nRealName2 | dta_custom_field_names テーブルへの外部キーです。
rlRealValue2 | 実数の追跡ログ対象フィールド 2 です。このフィールドの値は 8 バイトの実数である必要があります。
nIntName1 | dta_custom_field_names テーブルへの外部キーです。
nIntValue1 | 整数の追跡ログ対象フィールド 1 です。
nIntName2 | dta_custom_field_names テーブルへの外部キーです。
nIntValue2 | 整数の追跡ログ対象フィールド 2 です。
nDateName1 | dta_custom_field_names テーブルへの外部キーです。
dtDateValue1 | 日付型の追跡ログ対象フィールド 1 です。
nDateName2 | dta_custom_field_names テーブルへの外部キーです。
dtDateValue2 | 日付型の追跡ログ対象フィールド 2 です。
nStrName1 | dta_custom_field_names テーブルへの外部キーです。
nvcStrValue1 | 文字列型の追跡ログ対象フィールド 1 です。
nStrName2 | dta_custom_field_names テーブルへの外部キーです。
nvcStrValue2 | 文字列型の追跡ログ対象フィールド 2 です。
nvcCustomSearch | XML としての連結文字列型の取得対象の Binary Large Object です。

dta_interchange_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_indoc_details

  • dta_outdoc_details

  • dta_group_details

  • dta_interchange_data

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_direction_values

  • dta_error_message

  • dta_transport_type_values

dta_interchange_details テーブルには、BizTalk Server で処理されたインターチェンジごとに、行が 1 つ作成されます。次の表は、dta_interchange_details テーブルのフィールドを示しています。

フィールド名 | 説明
nInterchangeKey | プライマリ キー、一意なレコード識別子です。
nInterchangeDataKey | dta_interchange_data テーブルへの外部キーです。
nResponseDocDataKey | 送信トランスポートの受信者によって返される応答ドキュメントの dta_document_data テーブルへの外部キーです。
uidInterchangeGUID | インターチェンジのグローバル一意識別子 (GUID) です。
uidSubmissionGUID | 親送信のグローバル一意識別子 (GUID) です。ここでは、BizTalk オーケストレーション サービスによって提供される、またはそれに対して付与される関連付け識別子 (correlationID) が保持されます。レコードが BizTalk オーケストレーション サービスによらない受信インターチェンジのものである場合は、このフィールドは空です。受信インターチェンジに対して、このフィールドには、BizTalk オーケストレーション サービスからインターチェンジが送信される場合のみ、値が格納されます。送信インターチェンジに対しては、このフィールドには常に値が格納されます。
dtProcessedTimeStamp | レコードが作成された時刻です。
nvcSyntax | ドキュメントの構文 (XML、ANSI X12、EDIFACT、HL7 など) のコードです。解析エラーのために構文が認識されない場合やパススルー送信のときは、このフィールドの値は "UNKNOWN" になります。
nvcVersion | 構文のバージョンです。
nvcControlID | 電子データ交換 (EDI) インターチェンジの一意な制御番号、または BizTalk の信頼できるメッセージの識別子です。
nDirection | インターチェンジが受信か送信かを示すフラグです。値は 0 (送信) または 1 (受信) のいずれかです。これは dta_direction_values テーブルへの外部キーで、このテーブルに方向を表す値が含まれます。
dtTimeSent | 正常に行われた送信のタイムスタンプです。
nError | エラーの発生を示すコードです。これは dta_error_message テーブルへの外部キーで、このテーブルにエラー メッセージの説明が含まれます。
nTestMode | テストか本番運用かを示します。このフィールドは予備で、使用されていません。
nvcSrcAliasQualifer | 送信インターチェンジから抽出される送信者修飾子の値です。
nvcSrcAliasId | 送信インターチェンジから抽出される送信者識別子の値です。
nvcSrcAppName | 送信インターチェンジから抽出される送信元アプリケーション用のインターチェンジ レベル識別子です。
nvcDestAliasQualifier | 送信インターチェンジから抽出される受信者修飾子です。
nvcDestAliasID | 送信インターチェンジから抽出される受信者識別子の値です。
nvcDestAppName | 送信インターチェンジから抽出される送信先アプリケーション用のインターチェンジ レベル識別子です。
nAckStatus | 受信確認状況のコードです。これは dta_ack_status_values テーブルへの外部キーで、このテーブルに受信確認状況の説明が含まれます。
nvcSMTPMessageID | SMTP トランスポート メッセージ識別子 (EDIINT 用) です。このフィールドは予備で、使用されていません。
nDocumentsAccepted | インターチェンジが受けたドキュメントの数です。
nDocumentsRejected | インターチェンジが拒絶したドキュメントの数です。
nTransportType | 転送プロトコル識別コードです。これは dta_transport_type_values テーブルへの外部キーです。
nvcTransportAddress | トランスポート先のアドレスです。
nvcServerName | インターチェンジを処理したサーバーです。
nNumberOfBytes | バイト単位で表したインターチェンジのサイズです。このフィールドでは、関連する dta_interchange_data レコードでの追跡対象を表します。実際に送信されるものと異なる場合があります。サイズは、送信中に行われる追加のエンベロープ処理や書式変換により、増える場合があります。
nNumOfTransmitAttempts | 送信の試行回数カウンタです。

関連項目

サーバー グループの追跡設定について


セカンダリ テーブルの構造

セカンダリ テーブルは、追跡データベースのコア テーブルのサポート データを格納します。セカンダリ テーブルで格納する情報には、次のようなものがあります。

  • カスタム フィールド検索データ

  • ルーティング情報

  • インターチェンジ データ

  • ドキュメント データ

データ型

float および real データ型は近似データ型として知られています。float および real データ型の動作は近似数値データ型に関する IEEE 754 仕様に準拠しています。近似数値データ型は、多くの数字に対して指定された正確な値を格納しません。その値にきわめて近い近似値を格納します。多くのアプリケーションでは、指定された値と格納された近似値とのわずかな違いは認識されません。ただし、違いは常に明瞭です。float および real データ型のこの近似性のため、正確な数値動作が要求される場合 (財務アプリケーション、四捨五入などの演算、または等価チェックなど) は、これらのデータ型を使用しないようにしてください。代わりに、integer、decimal、money、または smallmoney データ型を使用します。

BizTalk Server では、Number データ型を整数データ型として追跡することができます。ドキュメント内の Number データ型の数値が整数データ型のサイズを超えると、警告メッセージが表示されます。この警告メッセージには、追跡できなかった値が含まれます。

Number データ型を整数データ型として追跡する場合は、整数データ型のサイズを超えないようにしてください。

各国語対応に関する問題

  • システム ロケールによっては、XML データの数値が追跡データベースに整数の追跡フィールドとして記録される際に、BizTalk Server によって誤って解釈されることがあります。たとえば、ドイツ語のロケールで、XML 数値 4.0 は 40 として追跡データベースにログされます。小数点 (.) が数字グループ化記号として誤って解釈されるからです。

    この問題については、2 つの回避策があります。1 つめは、要素または属性に小数が格納されることが前もってわかっている場合は、XML の要素または属性のデータ型を Real (r4) または Double Real (r8) に変更します。2 つめは、Number 型の要素または属性を整数ではなく実数として記録するように、ドキュメント定義またはチャネルを構成します。

  • 日時選択コントロール、一覧表示、およびツリー表示では Unicode 文字を表示できません。そのため、混在する言語のサポートには限界があります。たとえば、英語のコンピュータが 2 バイト文字セット (DBCS) を含む BizTalk ドキュメント トラッキングの Web ページおよびデータを含む BizTalk Server にアクセスした場合、英語のクライアントにはこれらの文字が疑問符 (?) として表示されます。

dta_document_data

このテーブルは、次のテーブルと 1 対 1 の関係を持っています。

  • dta_indoc_details

  • dta_outdoc_details

dta_document_data テーブルは、ドキュメント格納領域のための中心的なリポジトリです。次の表は、dta_document_data テーブルのフィールドを示しています。

フィールド名 | 説明
nDocumentDataKey | プライマリ キー、一意なレコード識別子です。
nCodePage | 文字コードにエンコードされた格納データのシステム コード ページ (1200-Unicode、65001-UTF-8 など) です。データに関するコード ページ情報が BizTalk Server にない場合は、このフィールドの値は -1 になります。この場合、nBLOBType フィールドの値によって、データの解釈方法に関する情報を得られることがあります。
nBLOBType | imgDocumentData フィールドに格納されているデータ型を示すフラグです。値は 0 (不明) または 1 (XMLDOM 読み込み可能) のいずれかです。XMLDOM 読み込み可能である場合、MSXML DOMDocument オブジェクトへの読み込み、それによる操作が可能なデータであることを示します。このフィールドは、dta_blobtype_values テーブルへの外部キーです。
imgDocumentData | ドキュメントの格納領域で、Binary Large Object です。
nNumberOfBytes | バイト単位で表したドキュメントのサイズです。
nNumberOfRecords | ドキュメントに含まれるレコードまたはセグメントです。

dta_debugdoc_data

このテーブルは、次のテーブルと 1 対 1 の関係を持っています。

  • dta_indoc_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_outdoc_details

このテーブルは、デバッグ ドキュメント格納領域のための中心的なリポジトリです。次の表は、dta_debugdoc_data テーブルのフィールドを示しています。

フィールド名 | 説明
nDebugDocDataKey | プライマリ キー、一意なレコード識別子です。
ntxtDocumentData | ドキュメントの格納領域で、Binary Large Object です。常に Unicode です。
nNumberOfBytes | バイト単位で表したドキュメントのサイズです。
dtProcessedTimeStamp | レコードが作成された時刻です。

dta_interchange_data

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_interchange_details

dta_interchange_data テーブルは、インターチェンジ格納領域のための中心的なリポジトリで、ここには、システムで処理されたインターチェンジごとに、レコードが 1 つ作成されます。BizTalk Server に送信されるインターチェンジについてのみ、nlsFile フィールドでは、格納されているデータがもともとファイル システムから受信したものかどうかを示します。フラグが設定されている場合、nvcOriginalFileName フィールドには、データがもともと存在していたファイル システムの場所への Universal Naming Convention (UNC) パスが格納されます。imgInterchangeData フィールドには、その元の場所に関係なく、送信されたデータが保持されます。

フィールド名 | 説明
nInterchangeDataKey | プライマリ キー、一意なレコード識別子です。
nCodePage | 文字コードにエンコードされた格納データのシステム コード ページ (1200-Unicode、65001-UTF-8 など) です。データに関するコード ページ情報が BizTalk Server にない場合、またはデータがパススルー送信の結果として追跡される場合は、このフィールドの値は -1 になります。この場合、nBLOBType フィールドの値によって、データの解釈方法に関する情報を得られることがあります。
nlsFile | ファイルをベースとしたデータ送信を示すフラグです。値は 0 (非ファイル ベース) または 1 (ファイル ベース) のいずれかです。
nvcOriginalFileName | nlsFile フィールドの値が 1 である場合は、ファイルへの Universal naming convention (UNC) パスです。
nBLOBType | imgDocumentData フィールドに格納されているデータ型を示すフラグです。値は 0 (不明) または 1 (XMLDOM 読み込み可能) のいずれかです。XMLDOM 読み込み可能である場合、MSXML DOMDocument オブジェクトへの読み込み、それによる操作が可能なデータであることを示します。このフィールドは、dta_blobtype_values への外部キーです。
imgInterchangeData | インターチェンジの格納領域で、Binary Large Object です。

dta_group_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_indoc_details

  • dta_outdoc_details

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_interchange_details

  • dta_direction_values

dta_groug_details テーブルには、電子データ交換 (EDI) 用の拡張コンポーネントで処理されたグループごとに、行が 1 つ作成されます。次の表は、dta_group_details テーブルのフィールドを示しています。

フィールド名 | 説明
nGroupKey | プライマリ キー、一意なレコード識別子です。
nInterchangeKey | dta_interchange_details テーブルへの外部キーです。
dtProcessedTimeStamp | レコードが作成された時刻です。
nvcSyntax | ドキュメントの構文 (XML、ANSI X12、EDIFACT、HL7 など) のコードです。解析エラーのために構文が認識されない場合やパススルー送信のときは、このフィールドの値は "UNKNOWN" になります。
nvcVersion | 標準のバージョンです。
nvcRelease | バージョンのリリースです。
nvcFunctionalGroupID | グループのドキュメント型のコードです。
nvcControlID | EDI ドキュメントおよびファンクショナル グループの一意な制御番号です。
nvcSrcAppName | 送信元アプリケーションのグループ レベル識別子です。
nvcDestAppName | 送信先アプリケーションのグループ レベル識別子です。
nAckStatus | 受信確認状況のコードです。これは dta_ack_status_values テーブルへの外部キーで、このテーブルに受信確認状況の説明が含まれます。
nDirection | グループが受信か送信かを示すフラグです。値は 0 (送信) または 1 (受信) のいずれかです。これは dta_direction_values テーブルへの外部キーです。
nDocumentsAccepted | グループが受けたトランザクションの数です。
nDocumentsRejected | グループが拒絶したトランザクションの数です。
nNumberOfBytes | バイト単位で表したインターチェンジのサイズです。

dta_routing_details

このテーブルは、次のテーブルと 1 対多の関係を持っています。

  • dta_outdoc_details

dta_routing_details テーブルには、異なる送信元または送信先の情報の組ごとに、行が 1 つ作成されます。組織またはアプリケーションのレベルで、2 つのドキュメントのルーティング フィールドに同じ値が含まれている場合があります。この場合、これらのドキュメントは、ドキュメント型またはより下位のレベルのフィルタによって区別されます。このような場合、dta_routing_details テーブルに含まれる行は、それぞれの親メッセージ ポート以外は同じ値を持っています。この親メッセージ ポートへのリンクは、BizTalk メッセージ マネージャのユーザー インターフェイス機能と追跡機能との接続のために使用されます。次の表は、dta_routing_details テーブルのフィールドを示しています。

フィールド名 | 説明
nRoutingKey | プライマリ キー、一意なレコード識別子です。
nvcSrcOrgName | 送信元組織の名前です。親チャネル オブジェクトで指定されています。
nvcSrcAppName | 送信元アプリケーションの名前です。親チャネル オブジェクトで指定されています。
nvcDestOrgName | 送信先組織の名前です。親メッセージ ポート オブジェクトで指定されています。
nvcDestAppName | 送信先アプリケーションの名前です。親メッセージ ポート オブジェクトで指定されています。
nvcDistributionName | 同報リストの名前です。
uidChannelGUID | グローバル一意識別子 (GUID) に基づいた親チャネルの一意なキーです。BizTalk メッセージ管理データベースに対するチャネル関連付けキーとして使用されます。
uidPortGUID | GUID に基づいた親メッセージ ポートの一意なキーです。BizTalk メッセージ管理データベースに対するメッセージ ポート関連付けキーです。

dta_custom_field_names

このテーブルは、次のテーブルと多対 1 の関係を持っています。

  • dta_outdoc_details

dta_custom_field_names テーブルには、取得されたノード名とデータ型の異なる組ごとに、行が 1 つ作成されます。次の表は、dta_custom_field_names テーブルのフィールドを示しています。

フィールド名 | 説明
nNameKey | プライマリ キー、一意なレコード識別子です。
nvcName | ノード名のテキストです。たとえば、/CommonPO/Total/@POTotal です。
nDataType | ノード名に含まれるデータ型です。

dta_MIME_data

dta_MIME_data テーブルには、BizTalk Server で処理された受信 MIME データが格納されます。このテーブルは、添付ドキュメントを含む MIME データを追跡する方法を提供するものです。次の表は、dta_MIME_data テーブルのフィールドを示しています。

フィールド名 | 説明
nMIMEDataKey | プライマリ キー、一意なレコード識別子です。
uidSubmissionGUID | 親送信のグローバル一意識別子 (GUID) です。
nCodePage | imgMIMEData フィールド内の、文字コードにエンコードされた格納データのシステム コード ページです。MIME データの場合、値は 1252 (ASCII) または 1200 (Unicode) のいずれかです。
imgMIMEData | ドキュメントの格納領域で、Binary Large Object です。


関連テーブル

追跡データベースには、さらに 13 のテーブルがあり、コア テーブルやセカンダリ テーブルをサポートしています。これらのテーブルには、グループやインターチェンジの関連付けキー、受信確認状況の値、データ レベルの値などの情報が格納されます。次の表は、それぞれのテーブルとその機能を示しています。

テーブル名 | 用途
dta_ack_status_values | 受信確認状況の値を格納します。値は、"なし"、"待ち"、"返信期限切れ"、"受信済"、"受信済 (エラー)"、"受信拒否" のいずれかです。
dta_blobtype_values | Binary Large Object の種類を格納します。値は 0 (不明) または 1 (読み込み可能 XMLDOM) のいずれかです。
dta_data_level_values | BizTalk Server で使用されるデータ レベルの値を格納します。値は、"インターチェンジ"、"グループ"、"受信ドキュメント"、"送信ドキュメント" のいずれかです。
dta_direction_values | インターチェンジの方向の情報を格納します。値は、"受信" または "送信" のいずれかです。
dta_error_message BizTalk ドキュメント トラッキングで使用されるエラー メッセージを格納します。値は次のいずれかです。
  • エラーなし。

  • カスタム コンポーネントを呼び出すことができませんでした。

  • インターチェンジを解析できませんでした。

  • 指定されたチャネルは存在しません。

  • インターチェンジをシリアライズできませんでした。

  • インターチェンジをエンコードできませんでした。

  • インターチェンジに署名できませんでした。

  • インターチェンジを暗号化できませんでした。

  • 送信の試行に失敗しました (再試行は待ち状態)。

  • 前回の送信試行は失敗しました。

  • ドキュメントを解析できませんでした。

  • ドキュメントを検証できませんでした。

  • 有効なチャネルが見つかりませんでした。

  • ドキュメントをマッピングできませんでした。

  • 有効なメッセージ ポートが見つかりませんでした。

  • ドキュメントをシリアライズできませんでした。
dta_group_correlation_keys | グループの関連付けキーを格納します。受信確認の関連付けのときに、対象のグループを示す値が動的に生成されます。
dta_interchange_correlation_keys | インターチェンジの関連付けキーを格納します。受信確認の関連付けのときに、対象のグループを示す一意な値が動的に生成されます。
dta_transport_type_values | トランスポートの種類の値を格納します。値は、"なし"、"HTTP"、"SMTP"、"DCOM"、"アプリケーション統合"、"メッセージ キュー"、"ファイル"、"HTTPS"、"オープンな送信先"、"ループバック"、"オーケストレーション アクティベーション" のいずれかです。
dta_ui_codepage_charset | 文字コードにエンコードされたデータのシステム コード ページを格納します。
dta_ui_user_queries | 個々のユーザーが作成して保存した高度なクエリを格納します。
dta_validity_values 検証結果の値を格納します。値は、"無効"、"有効"、"パススルー" のいずれかです。

パススルーの値が返された場合は、ドキュメントが解析されず、検証が行われなかったことを示します。パススルーの詳細については、「受信機能の詳細プロパティについて」を参照してください。
dta_wf_EventData | XLANG スケジュールによって発生する監視対象の COM+ イベントに関連してログに記録されるプロパティごとに、レコードを 1 つ格納します。このテーブルの複数の行のセットで、dta_wf_WorkFlowEvent テーブル中の共通の親を共有しています。
dta_wf_WorkFlowEvent | XLANG スケジュールによって発生する監視対象の COM+ イベントごとに、レコードを 1 つ格納します。


インターチェンジとドキュメントをログに記録する方法

オープンな送信元、オープンな送信先、パススルーなど、処理シナリオが違うと、追跡データベースのログに記録される方法はそれぞれ異なります。共通の処理シナリオは、"非オープン"、"オープンな送信元"、"オープンな送信先"、"ループバック"、"パススルー" および "受信確認を要求し、受信確認を生成する" の 6 つです ("受信確認を要求する" と "受信確認を生成する" は 1 つのシナリオと見なされています)。"受信確認を要求する" と "受信確認を生成する" のシナリオについては、「受信確認をログに記録する方法」を参照してください。次の表は、そのほかの処理シナリオについて説明しています。

処理シナリオ | 説明
非オープン | 送信元と送信先の両方が受信機能、ドキュメント インスタンス、Submit メソッド、または SubmitSync メソッドで明示的に宣言されている場合に発生します。
オープンな送信元 | 送信元情報がチャネルで明示的に定義されていない場合に発生します。チャネルはオープンな送信元として設定されている必要があります。また、送信呼び出しや受信機能で、送信元のオープンネスを指定する必要があります。
オープンな送信先 | 送信先情報がメッセージ ポートで明示的に定義されていない場合に発生します。送信先はドキュメント インスタンス、Submit メソッド、または SubmitSync メソッドで動的に指定されます。メッセージ ポートはオープンな送信先として設定されている必要があります。また、送信呼び出しや受信機能で、送信先のオープンネスを示す必要があります。
ループバック | チャネルで指定されているトランスポートがループバックである場合に発生します。ループバックは、SubmitSync メソッドを使用して受信ドキュメントを送信したビジネス アプリケーション、コンポーネント、または XLANG スケジュールに、チャネルの送信ドキュメントを返します。このトランスポートは、アプリケーションに接続されているメッセージ ポートで、SubmitSync メソッドを用いる場合にのみ使用できます。
パススルー | 受信機能で [パススルー フラグを付けて送信する] オプションを選択するか、Submit メソッドや SubmitSync メソッドで PassThrough パラメータに "True" を指定する場合に発生します。BizTalk Server はドキュメントを処理しません。たとえば、ドキュメントの解析、署名、解読、検証は行われません。ドキュメントは BizTalk Server で伝送のみ行われます。

次の表は、追跡データベースのログに記録される送信レコードを示しています。

処理シナリオ | dta_interchange_details (送信) | dta_outdoc_details | 応答ドキュメント
非オープン | X | X | X
オープンな送信元 | X | X | X
オープンな送信先 | X | X | X
ループバック | X | X |
パススルー | X | X | X

注

  • 応答ドキュメントが生成されるのは、Hypertext Transfer Protocol (HTTP)、Secure Hypertext Transfer Protocol (HTTPS)、またはアプリケーション統合コンポーネント (AIC) のトランスポートを使用したときのみです。また、受信者のアドレスを応答データに記録する必要があります。

  • パススルー シナリオの場合、dta_outdoc_details テーブルのログに記録されるレコードは、空のレコードです。nlsValid フィールドの値は 2 で、このレコードはパススルー ドキュメントに関連付けられています。nSyntax フィールドの値は "UNKNOWN" です。BizTalk Server ではドキュメントを処理しないため、このテーブルのフィールドのほとんどに、関連するデータを格納できません。

次の表は、追跡データベースのログに記録される受信レコードを示しています。

処理シナリオ | dta_interchange_details (受信) | dta_indoc_details | 応答ドキュメント
非オープン | X | X | X
オープンな送信元 | X | X | X
オープンな送信先 | X | X | X
ループバック | X | X |
パススルー | X | X | X

注

  • 応答ドキュメントが生成されるのは、HTTP、HTTPS、AIC のトランスポートを使用したときのみです。また、受信者のアドレスを応答データに記録する必要があります。

  • パススルー シナリオの場合、dta_indoc_details テーブルのログに記録されるレコードは、空のレコードです。nlsValid フィールドの値は 2 で、このレコードはパススルー ドキュメントに関連付けられています。nSyntax フィールドの値は "UNKNOWN" です。BizTalk Server ではドキュメントを処理しないため、このテーブルのフィールドのほとんどに、関連するデータを格納できません。

関連項目

受信確認をログに記録する方法


受信確認をログに記録する方法

次の図は、Microsoft BizTalk Server 2002 での受信確認フローを示しています。

このシナリオの状況は次のとおりです。

  • 送信元システムおよび送信先システムでは、BizTalk Server を使用しています。

  • 送信元システムは、送信先システムに注文を送信し、その注文に対する受信確認が返されます。

  • どちらのシステムも、受信確認を要求し、生成するように構成されています。

注文が送信元システムで処理され、送信先システムに送信されると、1 つのレコードが dta_outdoc_details テーブルのログに記録されます。次の表は、そのレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nOutDocKey | 1 | レコードを示す一意な番号です。
nAckStatus | 1 | ドキュメントの受信確認が待ち状態であることを示します。
nReceiptFlag |  | 現時点では値が格納されていません。
nReceiptKey |  | 現時点では値が格納されていません。

送信先システムが注文を受信し、処理すると、1 つのレコードが dta_indoc_details テーブルのログに記録され、2 つのレコードが dta_outdoc_details テーブルのログに記録されます。dta_indoc_details テーブルのレコードは注文に関連する情報を記録します。dta_outdoc_details テーブルの 1 番目のレコードは注文に関連する情報を記録し、2 番目のレコードは注文に対する受信確認に関連する情報を記録します。

次の表は、dta_indoc_details テーブルのレコードの注文に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nInDocKey | 1 | レコードを示す一意な番号です。
nDocType | CommonPO | 受信ドキュメントの型を示します。

dta_outdoc_details テーブルのログに記録される 1 番目のレコードは、BizTalk Server で処理される注文に関連するものです。次の表は、そのレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nOutDocKey | 10 | レコードを示す一意な番号です。
nInDocKey | 1 | レコードを dta_indoc_details テーブルの親レコードにリンクします。

dta_outdoc_details テーブルのログに記録される 2 番目のレコードは、注文によって生成される受信確認に関連するものです。次の表は、そのレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nOutDocKey | 2 | レコードを示す一意な番号です。
nInDocKey | 1 | レコードを dta_indoc_details テーブルの親レコードにリンクします。
nAckStatus | 0 | 受信確認の応答として受信確認を返す必要がないことを示します。
nReceiptFlag | 4 | 受信確認が dta_indoc_details テーブルのレコードに関連付けられていることを示します。
nReceiptKey | 1 | 受信確認レコードを示す一意な番号です。

送信元システムが、送信先システムによって生成された受信確認を受信し、レコードが dta_indoc_details テーブルのログに記録されると、dta_outdoc_details テーブルのログに記録された元のレコードが更新されます。次の表は、dta_indoc_details テーブルのレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nInDocKey | 9 | レコードを示す一意な番号です。
nDocType | 997 | 受信ドキュメントの型を示します。

次の表は、dta_outdoc_details テーブルの更新されたレコードの受信確認に関連するフィールドがどのようなものになるかを示しています。

フィールド名 | サンプルの値 | 説明
nOutDocKey | 1 | レコードを示す一意な番号です。
nAckStatus | 3 | 受信確認が受信されたことを示します。
nReceiptFlag | 4 | 受信確認が dta_indoc_details テーブルのレコードに関連付けられていることを示します。
nReceiptKey | 9 | 受信確認レコードを示す一意な番号です。

関連項目

インターチェンジとドキュメントをログに記録する方法


ルーティング情報をログに記録する方法

追跡データベースのログに記録されるルーティング情報の内容は、ドキュメントが受信と送信のどちらであるか、または BizTalk Server でデータをどのように処理するかによって異なります。受信インターチェンジの場合、BizTalk Server はドキュメントを受信すると、ドキュメント インスタンスの中でルーティング情報を探します。次に BizTalk Server は、受信機能または IInterchange::Submit で指定されたルーティング パラメータを確認します。ルーティング情報が受信機能または IInterchange::Submit で検出された場合、これらのパラメータはドキュメント インスタンスをルーティングするために使用されます。ドキュメント インスタンスに格納されているルーティング情報は、追跡データベースの dta_routing_details テーブルのログに記録されます。

送信インターチェンジの場合、送信元と送信先のルーティング情報は常にチャネルから得て、dta_routing_details テーブルのログに記録されます。

これにより、BizTalk ドキュメント トラッキングのユーザー インターフェイスに、エイリアスに関するどんな情報が表示されるかが変わってきます。これは、どのように BizTalk Server で送信される複数のインターチェンジが単一データ フロー インスタンスとして相互に関連しているかには影響を与えません。


追跡データベースでの XLANG スケジュール イベントの追跡

BizTalk メッセージ サービスと BizTalk オーケストレーション サービスとの間で交換され、XLANG スケジュールによって処理されるメッセージに関連するアクション イベントは、追跡データベースのテーブルで追跡できます。このアクション イベントは、BizTalk ドキュメント トラッキングを使用して表示できます。ただし、XLANG スケジュールによって処理されるメッセージに関連するアクション イベントの追跡と表示の機能は、BizTalk Server 2002 をインストールしたときに自動的に有効になりません。この機能を有効にするには、次の操作を行います。

  1. サンプルのダイナミック リンク ライブラリ (.DLL) ファイル WorkFlowAudit.dll を登録します。

    このサンプル ファイルは \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\bin にあります。

  2. WorkFlowAuditClient.exe を実行し、WorkFlowAudit.dll をアクティブにします。

    このサンプル アプリケーションは \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient にあります。

    補足情報としてのドキュメント (Readme.txt) は、\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\Docs にあります。

  3. WorkFlowAuditClient アプリケーションの [Start] ボタンをクリックして、追跡データベースの XLANG スケジュールに関連するアクション イベントのログを開始します。

重要

  • レコードが dta_wf_EventData テーブルおよび dta_wf_WorkFlowEvent テーブルのログに記録されるのは、WorkFlowAuditClient アプリケーションが起動している場合のみです。WorkFlowAuditClient アプリケーションを起動するには、ここで説明した 3 つの操作を完了している必要があります。WorkFlowAuditClient が停止している場合は、レコードは dta_wf_EventData テーブルおよび dta_wf_WorkFlowEvent テーブルのログに記録されません。

これらの操作を行うと、BizTalk オーケストレーション サービスと BizTalk メッセージ サービスとの間で交換されるメッセージに対し、レコードが dta_wf_EventData テーブルおよび dta_wf_WorkFlowEvent テーブルのログに記録されます。dta_wf_EventData テーブルの nvcName フィールドのログに記録される値は、dta_wf_EventData テーブルおよび dta_wf_WorkFlowEvent テーブルと、追跡データベースのコア テーブルである dta_interchange_details テーブルとの間のリンクとして機能します。コア テーブルの詳細については、「メタデータ コア テーブルの構造」を参照してください。

BizTalk オーケストレーション サービスから BizTalk メッセージ サービスに送信されるメッセージ

BizTalk オーケストレーション デザイナでの BizTalk メッセージのポート実装を使用して BizTalk オーケストレーション サービスから BizTalk メッセージ サービスに送信されるメッセージはすべて、関連付け識別子 (correlationID) と呼ばれるグローバル一意識別子 (GUID) によって識別されます。メッセージが BizTalk オーケストレーション サービスから BizTalk メッセージ サービスに送信される場合、correlationID が dta_interchange_details テーブルの uidSubmissionGUID フィールドのログに記録されます。さらに、レコードが dta_wf_EventData テーブルと dta_wf_WorkFlowEvent テーブルのログに記録されます。これにより、BizTalk ドキュメント トラッキングを使用して、XLANG スケジュールで処理されるメッセージに関連するアクション イベントを表示することができます。

BizTalk メッセージ サービスから BizTalk オーケストレーション サービスに送信されるドキュメント

BizTalk メッセージ サービスに送信されるドキュメントはすべて、送信ハンドル (SubmissionHandle) と呼ばれる GUID によって識別されます。送信ハンドルの詳細については、「Submit Method」を参照してください。ドキュメントが BizTalk メッセージ サービスから BizTalk オーケストレーション サービスに送信される場合、dta_interchange_details テーブルの uidSubmissionGUID フィールドに送信ハンドルが記録されます。さらに、ドキュメントが BizTalk メッセージ サービスから BizTalk オーケストレーション サービスに送信されると、次の 2 つのイベントが発生します。

  • BizTalk オーケストレーション サービスに送信されるドキュメントの correlationID プロパティに、送信ハンドルが挿入されます。

  • レコードが、dta_wf_EventData テーブルと dta_wf_WorkFlowEvent テーブルのログに記録されます。ドキュメントが BizTalk メッセージ サービスから送信されるため、送信ハンドルは、dta_wf_EventData テーブルの nvcName フィールドの correlationID としてログに記録されます。

アクション イベントの表示

BizTalk ドキュメント トラッキングを使用して、XLANG スケジュールによって処理されるメッセージに関連するアクション イベントを表示するには、BizTalk ドキュメント トラッキングでクエリを作成してクエリ結果ページを表示します。そして、そのページ内にある XLANG スケジュールのアイコンをクリックします。クエリの作成方法と XLANG スケジュール イベントの表示方法の詳細については、「クエリを使用したインターチェンジ データとドキュメント データの検索と並べ替え」を参照してください。

dta_wf_EventData テーブル

次に示すテーブルには、XLANG スケジュールによって生成される監視対象の COM+ イベントに関連してログに記録されるプロパティごとに、レコードが 1 つ作成されます。このテーブルの複数の行のセットで、dta_wf_WorkFlowEvent テーブル中の共通の親を共有しています。

フィールド名 | 説明
nEventDataId | 自動的に加算される整数キー フィールドです。
nWorkFlowEventId | dta_wf_EventData テーブルの親イベント レコードへの外部キーです。
nvcName | 関連付け識別子 (correlationID) です。
nvcValue | 任意の値です。通常は、GUID に基づいています。

dta_wf_WorkFlowEvent テーブル

次のテーブルは dta_wf_EventData テーブルの親になっていて、このテーブルには、XLANG スケジュールによって生成される監査対象の COM+ イベントごとにレコードが 1 つ作成されます。

フィールド名 | 説明
nWorkFlowEventId | 自動的に加算される整数キー フィールドです。
nvcEventId | イベントの種類です。
nvcEventName | イベントの名前です。
nProcessId | 送信元イベントのプロセス識別子です。
nvcApplicationId | XLANG スケジュールの識別子です。
nvcInstanceId | スケジュールの特定のインスタンスの識別子です。
nEventTime | 1970 年 1 月 1 日の午前 0 時から経過した秒数で表した、イベントの世界標準時 (UTC) の時刻です。
nEventSubTime | ITime 引数に追加されるマイクロ秒単位の秒数です。時刻をマイクロ秒単位で算出するために使用します。
nEventTick | イベント発生時の高精度パフォーマンス カウンタの値です。
nvcServerName | イベントが検出されたサーバーです。
dtDateEntered | イベントの日付です。

関連項目

BizTalk サービスの統合

メタデータ コア テーブルの構造

Submit Method

インターチェンジ用の統合 XLANG スケジュール ステータスについて


インターチェンジとその関連ドキュメントの検索方法について

BizTalk ドキュメント トラッキングでは、クエリ パラメータを指定すると、すべてのインターチェンジとドキュメントを表示できます。検索結果を最大にし、サーバーの負荷を最小にするには、クエリとその使い方について理解することが重要です。パラメータをほとんど指定せずにクエリを作成した場合、返されるインターチェンジ レコードの数が大変多くなることがあります。この場合には、長い処理時間が必要となり、サーバーの処理能力にも負担がかかります。複数のユーザーが同時にデータベースにクエリを実行すると、状況は悪化します。

BizTalk Server には、2 レベルのクエリがあります。クエリと高度なクエリです。クエリには、クエリ結果の絞り込みに一般的に使用される条件を指定します。高度なクエリでは、特定データを検索するクエリ式を使用することにより、より詳細なクエリ結果を得ることができます。

ここには次のトピックが含まれます。

  • クエリについて

  • 高度なクエリについて


クエリについて

BizTalk ドキュメント トラッキングにある 3 つの標準クエリ パラメータは、日付の範囲とタイム ゾーン、送信元識別子と送信先識別子、およびドキュメント型です。この条件の 1 つまたは複数をクエリで指定して、インターチェンジとドキュメントのレコードを検索できます。たとえば、指定されたデータ範囲ですべてのドキュメント型を検索したり、特定のドキュメント型のインターチェンジやドキュメント、また選択した送信元組織や送信先組織に一致するインターチェンジやドキュメントを検索することができます。

日付の範囲とタイム ゾーン

BizTalk ドキュメント トラッキングに一覧表示されている日時は、ドキュメントが BizTalk Server で処理されたときのものです。クエリには任意の日付範囲を指定できます。既定では、BizTalk ドキュメント トラッキングの日付範囲は、現在の日付の 7 日前からとなります。[送信元の選択]、[送信先の選択]、および [ドキュメント型の選択] ボックスの一覧とは異なり、BizTalk ドキュメント トラッキングでは、任意の日時のドキュメントを検索する場合に、日付の範囲を空白にすることはできません。

ローカル時刻と世界標準時 (UTC) のどちらで日時を表示するかを指定することもできます。インターチェンジとドキュメントは、ローカル時刻で表示する場合がほとんどです。ただし、取引先が異なるタイム ゾーンにある場合は、ドキュメントの送信または受信の日時を指定する共通の条件を作成するために、UTC を使用する必要があります。

注

  • BizTalk ドキュメント トラッキングの日時選択コントロールは短い形式のみをサポートするため、長い日時形式を使用すると切り捨てられることがあります。

    日時形式で問題が生じた場合は、コントロール パネルの [地域のオプション] をクリックして、コンピュータが使用する形式を変更できます。

送信元組織と送信先組織

インターチェンジとドキュメントは、送信元組織または 送信先組織、あるいはその両方を基にして検索することができます。また、クエリを作成する場合、ドキュメントを 1 つまたは複数の組織、あるいはすべての組織でフィルタ処理をして取得することができます。組織に関連付けられているアプリケーションで作成されたインターチェンジとドキュメントを検索することもできます。たとえば、送信元組織 A の表計算アプリケーションが送信先組織 B のデータベース アプリケーションに対し、データを送信した場合、いつデータが送受信されたのかを特定することができます。

ドキュメント型

注文書または請求書など、特定のドキュメント型を持つインターチェンジやドキュメントを検索することができます。クエリでは、ドキュメント型の条件を送信元識別子や送信先識別子と組み合わせて、取引先との間で送受信したインターチェンジとドキュメントを検索できます。このようなクエリを使用すると、取引先との関係の分析に役立ちます。

並べ替えの指定

[クエリ結果] ページでの列の並べ替え順の指定方法には 6 通りあります。クエリの既定の並べ替え順は、次のとおりです。

  • 送信元組織名 : ドキュメントの送信元組織の名前です。

  • 送信元アプリケーション名 : ドキュメントが作成されたアプリケーションの名前です。

  • 送信先組織名 : ドキュメントの送信先組織の名前です。

  • 送信先アプリケーション名 : ドキュメントを送信する先のアプリケーションの名前です。

  • ドキュメント型 : ドキュメントの型です。

  • 処理時間 : BizTalk Server でドキュメントが処理された時刻です。

[関連するインターチェンジのグループ化] チェック ボックスによって、関連送信インターチェンジでグループ化された受信インターチェンジが [クエリ結果] ページに表示されるようになります。関連する送信インターチェンジと共に受信インターチェンジを表示しない場合は、このチェック ボックスをオフにします。

関連項目

高度なクエリについて


高度なクエリについて

クエリによって返されるインターチェンジとドキュメント レコードが多すぎる場合は、クエリ式を使用して検索を絞り込むことができます。[高度なクエリ] ダイアログ ボックスの [高度なクエリ ビルダ] で、新しいクエリ式の作成、または既に保存されているクエリ式の一覧の参照を行うことができます。このクエリ式は、クエリに追加した条件句の作成によって構成された SQL 文です。高度なクエリの作成に役立つオプションは、次のとおりです。

  • 送信元の選択 : 検索対象のフィールドの一覧です。BizTalk メッセージ マネージャでは、カスタム フィールドを追跡するためにチャネルやドキュメント定義を構成すると、これらのフィールドが [送信元の選択] ボックスの一覧に表示されるようになります。フィールドの追跡を行うように BizTalk メッセージ マネージャを構成していない場合は、[送信元の選択] ボックスの一覧には "<カスタム検索>" だけが表示されます。特定フィールドの追跡の詳細については、「ドキュメント ログのプロパティの設定」および「チャネル内の仕様フィールドの選択」を参照してください。

  • 演算子 : 利用可能な演算子の一覧です。たとえば、>、<、=、!=、[次のものが含まれています]、[次のものが含まれていません] があります。

  • 値 : このボックスに値を入力すると、高度なクエリの境界値を指定できます。

  • AND/OR : 検索条件の結合に使用するグループ化演算子 (AND と OR) を含む一覧です。

  • クエリ : 作成したクエリの一覧です。

  • 論理グループ : AND グループ演算子または OR グループ化演算子を使用して、作成済み検索条件を結合する場合の記述です。クエリに句を追加する場合、グループ化演算子に関する説明が、この [論理グループ] ボックスに表示されます。たとえば、[論理グループ] ボックスに、次のように表示される場合があります。

    1 AND 2 AND (3 OR 4)

    この例では、条件 1 および条件 2 が適用され、かつ、条件 3 または条件 4 が、条件 1 および条件 2 と結合されます。

注

  • 同じ名前のクエリを複数作成することができます。

  • 仕様フィールドを整数、実数、日付、またはテキストのいずれかのデータ型として追跡する場合、79 文字を超える仕様フィールド名は切り捨てられます。

    これらの仕様フィールドはカスタム データ型として追跡します。その際、フィールド名はフィールド値と共に SQL の ntext 型の列に格納されます。ntext 型の最大長は 2^30 - 1 (1,073,741,823) 文字です。

  • ドキュメントの詳細と受信確認状況が確認できない場合は、BizTalk Server 管理コンソールで [ドキュメント トラッキングを有効にする] チェック ボックスがオンになっていない可能性があります。このチェック ボックスがオンになっていない場合は、受信確認の関連付けを行えません。

    ドキュメント ログを有効にするには、次の操作を行います。

    1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

    2. BizTalk Server 管理コンソールで、Microsoft BizTalk Server 2002 を展開し、ドキュメント トラッキング設定を変更する BizTalk Server グループを右クリックします。次に [プロパティ] をクリックします。

    3. [追跡] プロパティ ページで、[ドキュメント トラッキングを有効にする] チェック ボックスをオンにします。

    使用するその他のオプションを選択します。

各国語対応に関する問題

  • システム ロケールによっては、XML データの数値が追跡データベースに整数の追跡フィールドとして記録される際に、BizTalk Server によって誤って解釈されることがあります。たとえば、ドイツ語のロケールで、XML 数値 4.0 は 40 として追跡データベースにログされます。小数点 (.) が数字グループ化記号として誤って解釈されるからです。

    この問題については、2 つの回避策があります。1 つめは、要素または属性に小数が格納されることが前もってわかっている場合は、XML の要素または属性のデータ型を Real (r4) または Double Real (r8) に変更します。2 つめは、Number 型の要素または属性を整数ではなく実数として記録するように、ドキュメント定義またはチャネルを構成します。

関連項目

クエリについて


クエリ結果について

[クエリ結果] ページでは、クエリ結果はインターチェンジ レコードおよびドキュメント レコードの 2 つのレベルで構成されます。構成の最上位レベルにあるのがインターチェンジ レコードです。インターチェンジ レコードは、BizTalk Server 2002 で送受信したインターチェンジを表しています。インターチェンジ レコードは、ドキュメント インスタンス レコードの親レコードであり、ドキュメント インスタンス レコードを意味のある方法で構成するのに役立ちます。インターチェンジ レコードに含まれるフィールドの詳細については、「インターチェンジ レコードの結果について」を参照してください。インターチェンジ レコードはデータ フィールドの行の集合として表示され、各行の左には [展開記号 (+)] が表示されます。

[展開記号 (+)] をクリックすると、ドキュメント インスタンス レコードが表示されます。ドキュメント インスタンス レコードもまた、データ フィールドの行として表示されます。インターチェンジ レコードごとに、通常 1 つのドキュメント インスタンス レコードがあります。ただし、単一のインターチェンジで複数のドキュメント型が送信される場合は、インターチェンジで送信されたドキュメント型ごとに 1 つのドキュメント レコードがあります。ドキュメント インスタンス レコードに含まれるフィールドの詳細については、「ドキュメント インスタンス レコードの結果について」を参照してください。

ここには次のトピックが含まれます。

  • 追跡データベース スキーマの基本

  • インターチェンジ レコードの結果について

  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について

  • 送信の失敗の結果について


追跡データベース スキーマの基本

[クエリ結果] ページに表示される項目を理解するには、追跡データベース スキーマの基本を知っていることが重要です。追跡データベースには、BizTalk Server で処理されるインターチェンジおよびドキュメントごとに、メタデータ (送信元組織と送信先組織の識別子、日時、ドキュメント型など) を格納するコア テーブルが 3 つあります。このデータベース テーブルとは次の 3 つです。

  • dta_interchange_details

  • dta_indoc_details

  • dta_outdoc_details

dta_interchange_details

dta_interchange_details テーブルは、インターチェンジに関連したデータをすべて格納し、dta_indoc_details テーブルおよび dta_outdoc_details テーブルの親テーブルとなっています。BizTalk Server で処理されたインターチェンジごとに、テーブルに 1 つのレコードが格納されています。[クエリ結果] ページのインターチェンジ レコードのフィールドには、このテーブルのデータが表示されています。このテーブルのフィールドでは、インターチェンジが受信と送信のどちらであるかを示します。たとえば、インターチェンジを受信した場合、[クエリ結果] ページでは、受信インターチェンジ レコードとして表されます。インターチェンジを送信した場合は、[クエリ結果] ページには、送信インターチェンジ レコードとして表されます。dta_interchange_details テーブルの詳細については、「メタデータ コア テーブル」または「メタデータ コア テーブルの構造」を参照してください。

dta_indoc_details

dta_indoc_details テーブルには、BizTalk Server に送信された各ドキュメントのデータがすべて格納されています。このテーブルは、主キーによって dta_interchange_details テーブルにリンクされています。[クエリ結果] ページにある、受信インターチェンジ レコードに関連付けられているドキュメント インスタンス レコードのフィールドには、このテーブルのレコードが表示されています。たとえば、ドキュメントを送信する場合で、そのドキュメントの追跡情報を [クエリ結果] ページで表示するには、まず、該当する送信インターチェンジ レコードを検索します。次に、このレコードを展開すると、ドキュメント インスタンス レコードが表示されます。このドキュメント インスタンス レコードは dta_indoc_details テーブルに関連付けられており、追跡対象として構成したフィールドのデータがこのレコードに表示されます。dta_indoc_details テーブルの詳細については、「メタデータ コア テーブル」または「メタデータ コア テーブルの構造」を参照してください。

dta_outdoc_details

dta_outdoc_details テーブルには、BizTalk Server で生成された各ドキュメントのデータがすべて格納されています。dta_indoc_details テーブルの 1 つのレコードに対応する dta_outdoc_details テーブルのレコードが複数存在する場合があります。これは、単一の送信から複数のドキュメントの生成が可能なためです。たとえば、BizTalk Server に送信されたドキュメントが、10 メッセージ ポートで構成されている同報リストに送信されるような場合です。この場合、dta_indoc_details テーブルのログに 1 つのレコードが記録され、dta_outdoc_details テーブルのログには 10 個のレコードが記録されます。したがって、1 つの送信インターチェンジ レコードが、関連したドキュメント インスタンス レコードと共に [クエリ結果] ページに表示されます。ドキュメント インスタンス レコードのフィールドには、dta_outdoc_details テーブルのデータが表示されます。dta_outdoc_details テーブルの詳細については、「メタデータ コア テーブル」または「メタデータ コア テーブルの構造」を参照してください。

関連項目

インターチェンジとドキュメントをログに記録する方法

メタデータ コア テーブル

メタデータ コア テーブルの構造

ドキュメント インスタンス レコードの結果について

インターチェンジ レコードの結果について

受信確認の結果について

送信の失敗の結果について

追跡データベース スキーマについて


インターチェンジ レコードの結果について

指定したクエリ パラメータを基に、クエリ条件との一致が見つかると、1 つまたは複数のインターチェンジ レコードが返されます。1 つのインターチェンジ レコードでは、Microsoft BizTalk Server 2002 で送信または受信される 1 つのインターチェンジを表します。

次の表は、インターチェンジに格納されている情報の一覧です。

インターチェンジの列見出し | 説明
データ | インターチェンジ データをネイティブ形式で表示するためのリンクを示します。
スケジュール 利用できる場合は、個々のインターチェンジに対応する XLANG スケジュール ステータス情報へのリンクを示します。インターチェンジに関連付けられている XLANG スケジュール ステータス情報がない場合は、次のメッセージが表示されます。

このインターチェンジは、利用可能な XLANG スケジュール情報がありません。
方向 | インターチェンジを BizTalk Server に送られた (着信)、または BizTalk Server から送る (発信)、のどちらであるかを示します。
エラー ドキュメントに関連付けられたエラーがあるかどうかを示します。

表示される可能性のあるメッセージは次のとおりです。

  • エラーなし。

  • カスタム コンポーネントを呼び出すことができませんでした。

  • インターチェンジを解析できませんでした。

  • 指定されたチャネルは存在しません。

  • インターチェンジをシリアライズできませんでした。

  • インターチェンジをエンコードできませんでした。

  • インターチェンジに署名できませんでした。

  • インターチェンジを暗号化できませんでした。

  • 送信の試行に失敗しました (再試行は待ち状態)。

  • 前回の送信試行は失敗しました。

  • ドキュメントを解析できませんでした。

  • ドキュメントを検証できませんでした。

  • 有効なチャネルが見つかりませんでした。

  • ドキュメントをマッピングできませんでした。

  • 有効なメッセージ ポートが見つかりませんでした。

  • ドキュメントをシリアライズできませんでした。
送信元組織 | 送信元組織の名前を示します。
送信元アプリケーション | ドキュメントが作成されたアプリケーションの名前を示します。
送信先組織 | 送信先組織の名前を示します。
送信先アプリケーション | ドキュメントの送信先アプリケーションを示します。
ドキュメント型 | ドキュメントの型を示します。1 つのインターチェンジに複数のドキュメント型がある場合は、"<複数>" がこのフィールドに表示されます。
ドキュメント数 | インターチェンジ内のドキュメントの数を示します。
コントロール ID | 電子データ交換 (EDI) の一意な制御番号、または BizTalk の「信頼できるメッセージ」の識別子を示します。
受信確認状況 | 受信確認状況を示します。受信確認状況の値は、"なし"、"待ち"、"返信期限切れ"、"受信済"、"受信済 (エラー)"、"受信拒否" のいずれかです。
処理時間 | インターチェンジが処理された時刻を示します。ドキュメント トラッキング レコードが作成されたときの時刻が設定されます。このフィールドは、いったん設定されると更新されません。
転送時間 | インターチェンジの送信が成功した場合に送信時刻を示します。送信が成功しなかった場合は、NULL になります。受信の場合は、このフィールドは常に NULL になります。
送信元 ID の修飾子 | 送信元組織の修飾子の種類を示します。BizTalk Server で内部的に使用される修飾子です。
送信元の識別子 | 送信元組織の識別子値を示します。データ内に示された識別子で、ドキュメントのルーティングに使用されます。送信元 ID の修飾子とは異なります。ルーティングの詳細については、「ルーティング情報をログに記録する方法」を参照してください。
送信先 ID の修飾子 | 送信先組織の修飾子の種類を示します。
送信元の識別子 | 送信先組織の識別子値を示します。ルーティングの詳細については、「ルーティング情報をログに記録する方法」を参照してください。

関連項目

追跡データベース スキーマの基本

ドキュメント インスタンス レコードの結果について

インターチェンジとその関連ドキュメントの検索方法について


ドキュメント インスタンス レコードの結果について

インターチェンジのドキュメント インスタンス レコードは、ドキュメント情報を示すフィールドの行として表示されます。

次の表は、ドキュメント インスタンス レコードの結果情報の一覧です。

ドキュメントの列見出し | 説明
データ | ドキュメント インスタンスにあるデータをネイティブ形式および XML 形式で表示するためのリンクを示します。
トラッキング ID | グローバル一意識別子 (GUID) に基づいたトラッキング キーを示します。
ドキュメント型 | ドキュメントの型を示します。1 つのインターチェンジに複数のドキュメントがある場合、このフィールドにドキュメント型が示されます。このフィールドに、複数のドキュメント型が示されることはありません。ほかにもドキュメント型がある場合は、別のドキュメント インスタンス レコードとして示されます。
コンプライアンス | ドキュメントが有効かどうかを示します。コンプライアンスの値は、有効か無効のいずれかです。
エラー ドキュメントに関連付けられたエラーがあるかどうかを示します。表示される可能性のあるメッセージは次のとおりです。
  • エラーなし。

  • カスタム コンポーネントを呼び出すことができませんでした。

  • インターチェンジを解析できませんでした。

  • 指定されたチャネルは存在しません。

  • インターチェンジをシリアライズできませんでした。

  • インターチェンジをエンコードできませんでした。

  • インターチェンジに署名できませんでした。

  • インターチェンジを暗号化できませんでした。

  • 送信の試行に失敗しました (再試行は待ち状態)。

  • 前回の送信試行は失敗しました。

  • ドキュメントを解析できませんでした。

  • ドキュメントを検証できませんでした。

  • 有効なチャネルが見つかりませんでした。

  • ドキュメントをマッピングできませんでした。

  • 有効なメッセージ ポートが見つかりませんでした。

  • ドキュメントをシリアライズできませんでした。
受信確認 | 受信確認情報へのリンクを示します。

次の表は、送信ドキュメントだけに適用されるフィールドの一覧です。

受信確認状況 | 受信確認状況を示します。受信確認状況の値は、"なし"、"待ち"、"返信期限切れ"、"受信済"、"受信済 (エラー)"、"受信拒否" のいずれかです。
実数 1、実数 2 | ドキュメントの内容から実数として取得されたデータを示します。実数を示すフィールドは 2 つあります。
整数 1、整数 2 | ドキュメントの内容から整数値として取得されたデータを示します。整数を示すフィールドは 2 つあります。
日付 1、日付 2 | ドキュメントの内容から日付値として取得されたデータを示します。日付を示すフィールドは 2 つあります。
文字列 1、文字列 2 | ドキュメントの内容から文字列値として取得されたデータを示します。文字列を示すフィールドは 2 つあります。
カスタム検索 | 文字列値として取得された追加のデータを示します。このフィールドの制限値は 2 GB です。

注

  • 送信ドキュメントで追跡の対象とする情報を構成する方法については、「ドキュメント定義内の仕様フィールドの選択」または「チャネル内の仕様フィールドの選択」を参照してください。

  • ドキュメント定義で、整数、実数、文字列、日付、カスタム フィールドなどのフィールドをオプションとして構成し、これらのフィールドを追跡対象として構成しても、送信されたドキュメント インスタンスにこれらのフィールドがない場合は、これらのフィールドはクエリ結果に表示されません。BizTalk ドキュメント トラッキングでは、省略可能なフィールドにデータがないことを示すエラー メッセージや警告メッセージは表示されません。

  • 仕様フィールドを整数、実数、日付、またはテキストのいずれかのデータ型として追跡する場合、79 文字を超える仕様フィールド名は切り捨てられます。

    これらの仕様フィールドはカスタム データ型として追跡します。その際、フィールド名はフィールド値と共に SQL の ntext 型の列に格納されます。ntext 型の最大長は 2^30 - 1 (1,073,741,823) 文字です。

各国語対応に関する問題

  • システム ロケールによっては、XML データの数値が追跡データベースに整数の追跡フィールドとして記録される際に、BizTalk Server によって誤って解釈されることがあります。たとえば、ドイツ語のロケールで、XML 数値 4.0 は 40 として追跡データベースにログされます。小数点 (.) が数字グループ化記号として誤って解釈されるからです。

    この問題については、2 つの回避策があります。1 つめは、要素または属性に小数が格納されることが前もってわかっている場合は、XML の要素または属性のデータ型を Real (r4) または Double Real (r8) に変更します。2 つめは、Number 型の要素または属性を整数ではなく実数として記録するように、ドキュメント定義またはチャネルを構成します。

関連項目

チャネル内の仕様フィールドの選択

ドキュメント定義内の仕様フィールドの選択

追跡データベース スキーマの基本

インターチェンジとその関連ドキュメントの検索方法について

インターチェンジ レコードの結果について


受信確認の結果について

次の図は、BizTalk ドキュメント トラッキングでの受信確認フローを示しています。図のドキュメント 1 は、BizTalk Server A で最初に処理され、受信確認を要求するフラグが設定されています (ドキュメント 1、受信確認要求フラグ設定)。次に、BizTalk Server B は受信機能を使用してこのドキュメントを受信し (ドキュメント 1、受信確認生成フラグ設定)、ドキュメントを処理して、受信確認を生成します [ドキュメント 1 の受信確認 (送信)]。次に、BizTalk Server A はこの受信確認を受信します [ドキュメント 1 の受信確認 (受信)]。

"ドキュメント 1、受信確認要求フラグ設定" の受信確認を表示する場合、まず、[クエリ結果] ページで、"ドキュメント 1、受信確認要求フラグ設定" に対応している適切なインターチェンジ レコードを探します。[受信] 列の [受信確認] アイコンをクリックすると、新しい [クエリ結果] ページが表示されます。このページには、BizTalk Server A が "ドキュメント 1、受信確認要求フラグ設定" を処理したときに生成したインターチェンジ レコードが示されます。[データ] 列の [データ] アイコンをクリックしたときに表示されるデータは、受信確認の実際の内容です。上の図で、この最後の段階は、"ドキュメント 1 の受信確認 (受信)" に対応しています。

"ドキュメント 1、受信確認生成フラグ設定" の受信確認を表示する場合、まず、[クエリ結果] ページで "ドキュメント 1、受信確認生成フラグ設定" に対応している適切なインターチェンジ レコードを探します。[受信] 列の [受信確認] アイコンをクリックすると、新しい [クエリ結果] ページが表示されます。このページには、BizTalk Server B が "ドキュメント 1、受信確認生成フラグ設定" を処理したときに生成したインターチェンジ レコードが示されます。インターチェンジ レコードを展開し、ドキュメント インスタンス の詳細を表示します。[データ] 列の [データ] アイコンをクリックしたときに表示されるデータは、受信確認の実際の内容です。上の図で、この最後の段階は、"ドキュメント 1 の受信確認 (送信)" に対応しています。

注

  • 受信確認の送信と受信は、受信確認を処理できるパーサーでのみ行われます。受信確認の詳細については、「受信確認について」を参照してください。

  • 「信頼できるメッセージ受信確認」は、BizTalk ドキュメント トラッキングのユーザー インターフェイスに表示されません。

関連項目

受信確認をログに記録する方法

追跡データベース スキーマの基本


送信の失敗の結果について

送信に失敗すると、失敗は追跡データベースのログに記録されます。ただし、追跡データベースのログに記録されるエラーがすべて BizTalk ドキュメント トラッキングのユーザー インターフェイスに表示されるわけではありません。エラーがユーザー インターフェイスに表示されるのは、レコードが dta_outdoc_details テーブルのログに記録された場合だけです。コア テーブルの詳細については、「追跡データベース スキーマの基本」または「メタデータ コア テーブル」を参照してください。

注

  • EDI インターチェンジ内のインターチェンジ トレーラが誤っている場合、追跡データベースはインターチェンジ解析エラーをログしません。インターチェンジに有効なドキュメントが含まれているが、インターチェンジ トレーラに誤った情報が格納されている場合、パーサーはこれを非致命的エラーとして認識して、ドキュメントを処理のために BizTalk Server に送信します。エラーはイベント ビューアにログされますが、追跡データベースにはエラーはログされません。追跡データベースは致命的エラーと非致命的エラーを区別しないためです。

次の表は、表示される可能性のあるエラー メッセージ、および追跡データベースのコア テーブルのログにレコードが記録されるかどうかの一覧です。

エラー メッセージ | ログに記録されるレコード | 説明
エラーなし | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | 該当するフィールドが 3 つのコア テーブルのログに記録されます。
カスタム コンポーネントを呼び出すことができませんでした。 | なし | このエラー メッセージが表示されるのは、カスタム プリプロセッサが受信機能に関連付けられている場合だけです。レコードは、追跡データベースのログには記録されません。
インターチェンジを解析できませんでした。 | dta_interchange_details (受信) | 解析エラーが発生した場合は、インターチェンジとデータがログに記録されます。
指定されたチャネルは存在しません。 | dta_indoc_details dta_interchange_details (受信) | なし。
インターチェンジをシリアライズできませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | 空のレコードが、dta_interchange_details (送信) テーブルのログに記録されます。インターチェンジが再送信され、これが成功すると、レコードは更新されます。
インターチェンジをエンコードできませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | なし。
インターチェンジに署名できませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | なし。
インターチェンジを暗号化できませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | なし。
送信の試行に失敗しました (再試行は待ち状態)。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | なし。
前回の送信試行は失敗しました。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | なし。
ドキュメントを解析できませんでした。 | dta_indoc_details dta_interchange_details (受信) | なし。
ドキュメントを検証できませんでした。 | dta_indoc_details dta_interchange_details (受信) | なし。
有効なチャネルが見つかりませんでした。 | dta_indoc_details dta_interchange_details (受信) | なし。
ドキュメントをマッピングできませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | ログ エラーは dta_outdoc_details テーブルのレコードのログに記録され、空のレコードが、dta_interchange_details (送信) テーブルのログに記録されます。
有効なメッセージ ポートが見つかりませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | ポートが見つからないエラーは dta_outdoc_details テーブルのレコードのログに記録され、空のレコードが、dta_interchange_details (送信) テーブルのログに記録されます。
ドキュメントをシリアライズできませんでした。 | dta_indoc_details dta_interchange_details (受信) dta_interchange_details (送信) dta_outdoc_details | dta_indoc_details テーブルと dta_outdoc_details テーブルのレコードに、シリアライズ エラーが記録されます。

関連項目

サーバー グループの追跡のプロパティの構成

保留キュー

追跡データベース スキーマの基本

追跡データベース スキーマについて


インターチェンジの統合 XLANG スケジュール ステータスについて

BizTalk ドキュメント トラッキングでは、関連する XLANG スケジュールのステータスを追跡できます。サーバーにあるスケジュールのアクションは監視され、追跡データベース内の適切なテーブルに格納されます。このとき、これらのアクションと特定のメッセージ インスタンスとを関連付ける識別子が与えられます。追跡データベースの格納スキーマと関連付けは、Microsoft BizTalk Server 2002 の機能の一部ですが、BizTalk Server 2002 のインストール時にイベント サブスクリプション機能は実装されません。ただし、追跡インテグレーションを実行するためのサンプルが用意されています。BizTalk Server 2002 をインストールすると、\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit フォルダにこのサンプルのソース コードが格納されます。また、bin サブフォルダにはダイナミックリンク ライブラリ (WorkFlowAudit.dll) が、Docs サブフォルダには、このサンプルのドキュメント (Readme.txt) が格納されています。サンプルのクライアント アプリケーションは、\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient にあります。


BizTalk ドキュメント トラッキングに関する作業を行う目的

ここでは、特定のドキュメント トラッキング作業の目的についてのクイック リファレンスを示します。次の表は、主要な作業とそれらの従属作業を示しており、各作業の目的とそれぞれ対応する操作へのリンクを記載しています。

作業 作業を実行する目的
  • BizTalk ドキュメント トラッキングを初めて開く
 Microsoft BizTalk Server 2002 のドキュメントの処理状況を表示します。クエリまたは高度なクエリを作成し、追跡データベースから重要な情報を、見やすい形式に抽出できます。
  • BizTalk Server Report Users グループへのユーザーの追加
 BizTalk ドキュメント トラッキング ユーザーのインタフェースを表示して、高度なクエリの式を保存します。これらの作業を行うには、BizTalk Server Report Users グループのメンバである必要があります。
追跡データベースの保守 :
  • アーカイブ追跡データベースの作成
 保管する古いインターチェンジおよびドキュメント インスタンスのレコードが挿入されるレポジトリを作成します。アーカイブ追跡データベースの作成は、追跡データベースを保守するためのユーティリティをインストールする際に順次実行する必要がある 4 つの手順のうちの最初の手順です。
  • アーカイブ追跡データベースのスキーマの作成
 アーカイブ追跡データベースを使用するには、そのスキーマを作成する必要があります。アーカイブ追跡データベースのスキーマの作成は、追跡データベースを保守するためのユーティリティをインストールする際に順次実行する必要がある 4 つの手順のうちの 2 番目の手順です。
  • SQL リンク サーバーの追跡データベースの構成
 追跡データベースをアーカイブし、それをアーカイブ追跡データベースにリンクします。両方が異なるデータベース上にある場合は、両方のデータベースを構成する必要があります。追跡データベースの構成は、追跡データベースを保守するためのユーティリティをインストールする際に順次実行する必要がある 4 つの手順のうちの 3 番目の手順です。
  • 追跡データベースへのストアド プロシージャのインストール
 古いインターチェンジとドキュメント インスタンスのレコードをアーカイブまたは削除するには、追跡データベースに特定のストアド プロシージャをインストールする必要があります。追跡データベースへのストアド プロシージャのインストールは、追跡データベースを保守するためのユーティリティをインストールする際に順次実行する必要がある 4 つの手順のうちの最後の手順です。
  • 追跡データベースのアーカイブ/削除ストアド プロシージャの使用法
 古いインターチェンジとドキュメント インスタンス のレコードをアーカイブまたは削除するには、追跡データベースに特定のストアド プロシージャを使用する必要があります。
クエリを使用したインターチェンジ データとドキュメント データの検索と並べ替え :
  • 日付によるインターチェンジとドキュメントの情報の検索
 クエリを使用して、日付などの標準検索条件でインターチェンジとドキュメント インスタンスのレコード、および関連データを検索、表示、保存します。
  • 組織によるインターチェンジとドキュメントの情報の検索
 クエリを使用して、送信元組織などの標準検索条件でインターチェンジとドキュメント インスタンスのレコード、および関連データを検索、表示、保存します。
  • ドキュメント型によるインターチェンジとドキュメントの情報の検索
 クエリを使用して、ドキュメント情報などの標準検索条件でインターチェンジとドキュメント インスタンスのレコード、および関連データを検索、表示、保存します。
  • クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索
 単一クエリ セッションで、送信元の選択と送信先の選択、ドキュメント型、および日時といったクエリ パラメータを組み合わせて、インターチェンジとドキュメント インスタンスのレコード、および関連データを検索、表示、保存します。
  • 組織とドキュメント型の検索条件のクリア
 すべての検索条件をクリアして、すべての送信元組織と送信先組織、およびすべてのドキュメント型を検索する既定の検索に戻ります。
  • [クエリ結果] ページのカスタマイズ
 関連送信インターチェンジと共にグループ化された受信インターチェンジを表示して並べ替えます。
  • [クエリ結果] ページの検索パラメータの表示
 日付の範囲、タイム ゾーン、式の名前、並べ替え順序、組織の選択、およびドキュメント型の選択といった検索パラメータとその関連値を表示します。
高度なクエリの使用 :
  • 高度なクエリの作成
 特定の注文書番号が付けられたドキュメント インスタンスなど、特定のデータを検索します。
  • 既存の高度なクエリの選択
 前に作成して保存した既存の高度なクエリを読み込んで再使用します。
  • 既存の高度なクエリの編集
 特定の条件を追加、修正、または削除して、ドキュメント検索を絞り込みます。
  • 既存の高度なクエリのクリア
 既存の高度なクエリをクリアするには、現在の式を削除する必要があります。
  • 既存の高度なクエリの削除
 作成済みの高度なクエリが必要なくなった場合は、そのクエリを選択して削除し、既存の高度クエリの一覧を短くします。
インターチェンジ データ、ドキュメント データ、およびカスタム検索データの保存 :
  • インターチェンジ データの保存
 データをオフラインで表示します。これにより、特定の状況のトラブルシューティングや業務遂行方法の分析を行うことができます。
  • ドキュメント インスタンス データの保存
 データをオフラインで表示します。これにより、特定の状況のトラブルシューティングや業務遂行方法の分析を行うことができます。
  • カスタム フィールド検索データの保存
 データをオフラインで表示します。これにより、特定の状況のトラブルシューティングや業務遂行方法の分析を行うことができます。


BizTalk ドキュメント トラッキングに関する作業を行う方法

ここでは、インターチェンジとドキュメント インスタンスのレコード、および関連データの検索、表示、および検索結果の保存を行う方法を作業ごとに説明します。「BizTalk ドキュメント トラッキングについて」を参照し、検索機能とそのクエリ結果について十分に理解しておいてください。

BizTalk ドキュメント トラッキングには、2 種類の検索機能があります。クエリと高度なクエリです。送信元組織など、標準の検索条件を使用してドキュメントを検索する場合は、クエリを使用します。注文金額合計など、ドキュメントの特定のデータを検索する場合は、高度なクエリを使用します。

ここには次のトピックが含まれます。

  • BizTalk ドキュメント トラッキングを初めて開く

  • BizTalk ドキュメント トラッキングを開く

  • BizTalk Server Report Users グループへのユーザーの追加
  • 追跡データベースの保守

  • クエリを使用したインターチェンジ データとドキュメント データの検索と並べ替え

  • 高度なクエリの使用

  • インターチェンジ データ、ドキュメント データ、およびカスタム検索データの保存


BizTalk ドキュメント トラッキングを初めて開く

Windows コモン コントロールおよび BizTalk ドキュメント トラッキング コントロールがコンピュータにインストールされていない場合は、BizTalk ドキュメント トラッキングを初めて開いたときに、コンポーネントのインストールを求めるメッセージが表示されます。これらのコンポーネントがコンピュータにインストールされている場合は、「BizTalk ドキュメント トラッキングを開く」を参照してください。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk ドキュメント トラッキング] をクリックします。

    次のコンポーネントのインストールを求める [Web ページ ダイアログ] ダイアログ ボックスが表示されます。

    • Windows コモン コントロール

    • BizTalk ドキュメント トラッキング インストール コントロール
  2. [続行] をクリックして Windows コモン コントロールをインストールします。

    セキュリティに関する警告が表示されます。

  3. [はい] をクリックして BizTalk ドキュメント トラッキング インストール コントロールをインストールします。

注

  • 選択時またはクエリ送信時に、次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。[信頼済みのサイト] の一覧へのWeb アプリケーションの追加の詳細については、「BizTalk Server 2002 用の IIS 設定の構成」を参照してください。

関連項目

BizTalk Server 2002 用の IIS 設定の構成

BizTalk ドキュメント トラッキングを開く


BizTalk ドキュメント トラッキングを開く

  • [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk ドキュメント トラッキング] をクリックします。

    または

    Microsoft Internet Explorer で BizTalk ドキュメント トラッキングをお気に入りに追加すると、Internet Explorer から BizTalk ドキュメント トラッキングを開くことができます。

注

  • 選択時またはクエリ送信時に、次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。[信頼済みのサイト] の一覧へのWeb アプリケーションの追加の詳細については、「BizTalk Server 2002 用の IIS 設定の構成」を参照してください。

関連項目

BizTalk Server 2002 用の IIS 設定の構成

BizTalk ドキュメント トラッキングを初めて開く


BizTalk Server Report Users グループへのユーザーの追加

BizTalk ドキュメント トラッキングのユーザー インターフェイスを表示し、高度なクエリの式を保存するには、BizTalk Server Report Users グループのメンバになっている必要があります。さらに、ユーザー ログイン アカウントが SQL Server ログイン アカウントと、追跡データベース (InterchangeDTA) に指定された公開、db_owner、および dta_ui_roleのロールに追加される必要があります。SQL Server ログイン アカウントの設定およびデータベースへのアクセス許可の設定の詳細については、「SQL Server と BizTalk Server 2002 データベース間の相互作用.」を参照してください。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンピュータの管理] をダブルクリックします。

  2. [システム ツール] を展開し、[ローカル ユーザーとグループ] を展開します。次に、[グループ] フォルダをクリックします。

  3. 詳細ウィンドウで、[BizTalk Server Report Users] をクリックします。

  4. [操作] メニューの [すべてのタスク] をポイントし、[グループに追加] をクリックします。

    [BizTalk Server Report Users のプロパティ] ダイアログ ボックスが表示されます。

  5. [追加] をクリックします。

  6. [場所] ボックスの一覧で、ドメイン名またはコンピュータ名をクリックします。

  7. 手順 6. で選択したドメインまたはコンピュータと関連付けられたユーザーまたはコンピュータを含む一覧で、追加するユーザー アカウントをクリックし、[追加] をクリックします。次に [OK] をクリックします。

  8. [OK] をクリックして [BizTalk Server Report Users のプロパティ] ダイアログ ボックスを閉じます。


追跡データベースの保守

BizTalk Server には、追跡データベースを保守するためのユーティリティが組み込まれています。BizTalk Server をインストールすると、該当するファイルが \Program Files\Microsoft BizTalk Server\Setup フォルダにコピーされます。ただし、ユーティリティを有効にするには、ここに記載されている手順を実行する必要があります。

注

  • BizTalk Server インストールでインターチェンジとドキュメントを追跡しない場合、または追跡データベースをアーカイブして削除する際に BizTalk Server に含まれている SQL スクリプトを使用しない場合は、ここに記載されている手順を実行する必要はありません。

追跡データベースを保守するためのユーティリティをインストールするには、次の手順を記載された順序で実行する必要があります。

ここには次のトピックが含まれます。

  • アーカイブ追跡データベースの作成

  • アーカイブ追跡データベースのスキーマの作成

  • SQL リンク サーバーの追跡データベースの構成

  • 追跡データベースへのストアド プロシージャのインストール
  • 追跡データベースのアーカイブ/削除ストアド プロシージャの使用法

重要

  • 次の手順を完了できない場合は、Microsoft® SQL Server™ を実行しているサーバーに接続するために使用しているユーザー アカウントに、ストアド プロシージャと SQL Server エージェント ジョブを作成するための十分なアクセス許可があるかどうかを確認してください。

  • 追跡データベースの既定の名前は、InterchangeDTA です。追跡データベースの名前が異なる場合は、BTS_Tracking_Archive_Purge_Script.sql スクリプト内の文字列「InterchangeDTA」をすべて自分の追跡データベースの名前に変更する必要があります。

注

  • ディスク容量が不必要に割当てられないようにするには、[チェックポイント時のログ切り捨て] チェック ボックスを有効にすることをお勧めします。このオプションを構成する方法の詳細については、「ディスク容量の不要な割り当ての回避」を参照してください。

  • 追跡データベース ユーティリティを保守するストアド プロシージャの詳細については、「追跡データベースのアーカイブ/削除ストアド プロシージャの使用法」を参照してください。


アーカイブ追跡データベースの作成

アーカイブ追跡データベースをホストするサーバー上で、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[Enterprise Manager] をクリックします。

  2. [Microsoft SQL Server] を展開し、[SQL Server グループ] を展開します。次に、アーカイブ追跡データベースを作成するサーバーをクリックします。

  3. [操作] メニューの [新規作成] をポイントし、[データベース] をクリックします。

  4. [データベースのプロパティ] ダイアログ ボックスで、アーカイブ追跡データベースの名前を入力して、[OK] をクリックします。


アーカイブ追跡データベースのスキーマの作成

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft SQL Server] をポイントし、[クエリ アナライザ] をクリックします。

  2. [SQL Server] ボックスの一覧で、「アーカイブ追跡データベースの作成」で作成したアーカイブ追跡データベースをホストする SQL Server の名前をクリックします。次に適切なログイン情報を入力して [OK] をクリックします。

  3. Microsoft SQL Server 7.0 がインストールされている場合は、[DB] ボックスの一覧で、アーカイブ追跡データベースの名前をクリックし、手順 5 に進みます。

    または

    Microsoft SQL Server 2000 がインストールされている場合は、[クエリ] メニューで [データベースの変更] をクリックします。

  4. アーカイブ追跡データベースの名前をクリックして、[OK] をクリックします。

  5. [ファイル] メニューの [開く] をクリックします。

  6. [クエリ ファイルを開く] ダイアログ ボックスの [場所] ボックスの一覧で、\Program Files\Microsoft BizTalk Server\Setup に移動します。

  7. BTS_Tracking_ArchiveDB_Schema.sql をクリックし、[開く] をクリックします。

  8. [クエリ] メニューの [実行] をクリックします。


SQL リンク サーバーの追跡データベースの構成

追跡データベースをホストする SQL Server 上で、次の手順を実行します。

  1. クエリ アナライザが開いていることを確認します。

  2. [ファイル] メニューの [接続解除] をクリックします。

  3. [ファイル] メニューの [接続] をクリックします。

  4. [SQL Server] ボックスの一覧で、アーカイブする追跡データベースをホストする SQL Server の名前をクリックします。次に適切なログイン情報を入力して [OK] をクリックします。

  5. Microsoft SQL Server 7.0 がインストールされている場合は、[DB] ボックスの一覧で、アーカイブする追跡データベースの名前をクリックし、手順 7 に進みます。

    たとえば、次の名前をクリックします。InterchangeDTA

    または

    Microsoft SQL Server 2000 がインストールされている場合は、[クエリ] メニューの [データベースの変更] をクリックします。

  6. 追跡データベースの名前をクリックして、[OK] をクリックします。

    たとえば、次の名前をクリックします。InterchangeDTA

    注

    • アーカイブ追跡データベースではなく、必ず追跡データベースを選択してください。
  7. SQL リンク サーバーとしてのアーカイブ追跡データベースの構成

    次の例は、リンク サーバーを構成するためのサンプル SQL ステートメントです。この例では、"Seattle2" というリモート データベース サーバーがローカル SQL Server のリンク サーバーです。

    EXEC sp_addlinkedserver N'Seattle2',
 N'SQL Server'
  8. 必要に応じて、ローカルのリンク SQL Server へのログインとリモートのリンク SQL Server へのログインの間でマッピングを構成します。

    次の例は、システム管理者 (sa) によるローカルのリンク SQL Server へのログインとリモートのリンク SQL Server へのログインとの間でマッピングを作成するためのサンプル SQL ステートメントです。このサンプルでは、リモート システム管理者のログイン パスワードを "abc123" としています。

    EXEC sp_addlinkedsrvlogin '<Name of remote SQL Server>',EXEC sp_addlinkedsrvlogin '<リモート SQL Server の名前>',
 'FALSE', 'sa', 'sa', 'abc123''FALSE', 'sa', 'sa', 'abc123'

重要

  • 追跡データベースとアーカイブ追跡データベースの両方が同じ SQL Server 上に存在する場合は、リンク サーバーをセットアップする必要はありません。両データベースが異なる SQL Server にセットアップされる場合は、追跡データベースとアーカイブ追跡データベースをリンク サーバーとして構成する必要があります。この場合、古いレコードをリモート アーカイブ追跡データベースにアーカイブ (INSERT) するために、リンク サーバーはストアド プロシージャ dta_purge_old_records に対してセットアップされる必要があります。レコードの削除のみを行う場合は、サーバーのリンクは不要です。

  • 追跡データベースの既定の名前は、InterchangeDTA です。追跡データベースの名前が異なる場合は、BTS_Tracking_Archive_Purge_Script.sql スクリプト内の文字列 InterchangeDTA をすべて自分の追跡データベースの名前に変更する必要があります。

注

  • システム管理者アカウントにパスワードがない場合は、空の文字列 ('') を使用する必要があります。セキュリティ上の理由から、この構成はお勧めできません。


追跡データベースへのストアド プロシージャのインストール

追跡データベースをホストする SQL Server 上で、次の手順を実行します。これは、前の手順で構成したサーバーと同じサーバーである必要があります。

  1. クエリ アナライザが開いていることを確認します。

  2. [ファイル] メニューの [開く] をクリックします。

  3. [クエリ ファイルを開く] ダイアログ ボックスの [場所] ボックスの一覧で、\Program Files\Microsoft BizTalk Server\Setup に移動します。

  4. BTS_Tracking_Archive_Purge_Script.sql をクリックして、[開く] をクリックします。

  5. [クエリ] メニューの [実行] をクリックします。

    スクリプトは、dta_purge_old_records という名前のストアド プロシージャを作成します。スクリプトは "Archive and Purge BizTalk Tracking database: <追跡データベース名>" という名前の SQL Server エージェント ジョブを作成します。既定では、SQL Server エージェント ジョブは有効になっていません。

  6. 必要に応じて、[Enterprise Manager] を開きます。

  7. [Microsoft SQL Servers] を展開し、[SQL Server グループ] を展開して、追跡データベースをホストするサーバーを展開します。次に、[管理] を展開し、[SQL Server エージェント] を展開して、[ジョブ] をクリックします。

  8. 詳細ペインで、Archive and Purge BizTalk Tracking database: <追跡データベース名> をクリックします。

  9. [操作] メニューの [プロパティ] をクリックします。

  10. [ステップ] タブで、[dtaStep_execute_stored_proc] が選択されていることを確認し、[編集] をクリックします。

  11. [ジョブ ステップの編集] ダイアログ ボックスの [全般] タブで、[コマンド] ボックスに入力パラメータを設定します。

    以下は、ストアド プロシージャ dta_purge_old_records に渡される入力パラメータの構成に関する例です。ストアド プロシージャの構文および引数の詳細については、「追跡データベースのアーカイブ/削除ストアド プロシージャの使用法」を参照してください。

    • ある日付より前に完全に処理されたすべてのインターチェンジおよびドキュメントを削除するが、アーカイブは行わないようにするには、次のようにジョブを編集します。
      USE InterchangeDTA
EXEC dta_purge_old_records 1, 24, 1,0
    • 最新の 1,000 件の インターチェンジを除き、完全に処理されたかどうかに関係なく、すべてのインターチェンジをアーカイブして削除するには、次のようにジョブを編集します。
      USE InterchangeDTA
EXEC dta_purge_old_records 2, 1000, 0, 1,
 N'<Name of a SQL Server>',N'<SQL Server の名前>',
 N'<Name of the archive Tracking database>'N'<アーカイブ追跡データベースの名前>'
  12. [OK] をクリックします。

  13. [スケジュール] タブで、[BizTalk Archive and Purge Schedule.] が選択されていることを確認し、[編集] をクリックします。

  14. [ジョブ スケジュールの編集] ダイアログ ボックスで、[スケジュールの種類] ボックスの [変更] をクリックします。

  15. [定期ジョブのスケジュール編集] ダイアログ ボックスで、SQL Server エージェント ジョブの間隔、頻度、および期間を必要な数値に変更して、[OK] をクリックします。

  16. [全般] タブで、[有効] チェック ボックスをオンにして [OK] をクリックします。

    変更は保存され、SQL Server エージェント ジョブが有効になります。

注

  • この手順は、BizTalk Server 2002 のインストール フォルダが \Program Files\Microsoft BizTalk Server であると想定しています。BizTalk Server 2002 を異なるフォルダにインストールした場合は、フォルダ パスがここに記載されているものとは異なることがあります。


追跡データベースのアーカイブ/削除ストアド プロシージャの使用法

このトピックでは、追跡データベースの SQL スクリプトの構文と引数について説明します。

構文

次のコードは、ストアド プロシージャ、dta_purge_old_records で使用される構文です。

[ @nPurgeType = ] nPurgeType,
[ @nPurgeValue = ] nPurgeValue,
[ @nCompletedInterchangesOnly = ] nCompletedInterchangesOnly,
[ @nArchiveFlag = ] nArchiveFlag
[ , [ @nvcArchiveDBServer = ] N'nvcArchiveDBServer' ]
[ , [ @nvcArchiveDBName = ] N'nvcArchiveDBName' ]

引数

以下は、構文で使用される引数です。

[ @nPurgeType = ] nPurgeType

引数 [ @nPurgeType = ] nPurgeType は、削除するインターチェンジをタイムスタンプによって選択するか、それとも行カウントによって選択するかを示す整数値です。nPurgeType が 1 のとき、レコードはタイプスタンプによって削除されます。nPurgeType が 2 のとき、レコードは行カウントによって削除されます。

[ @nPurgeValue = ] nPurgeValue

引数 [ @nPurgeValue = ] nPurgeValue は整数値です。この引数の意味は、nPurgeType の値によって異なります。

nPurgeType の値が 1 のとき、nPurgeValue は、特定の日時より古いインターチェンジをアーカイブする方法を決定するために、CURRENT_TIMESTAMP から差し引く時間を表します。たとえば、nPurgeValue として 96 を指定すると、96 時間 (4 日) より前のインターチェンジがアーカイブされます。

nPurgeType の値が 2 のとき、nPurgeValue は、レコードがデータベースからアーカイブされ削除された後にデータベースに残されるインターチェンジの数を表します。たとえば、25,000 と指定すると、上部の 25,000 行より下のインターチェンジがすべてアーカイブされます。

[ @nCompletedInterchangesOnly = ] nCompletedInterchangesOnly

引数 [ @nCompletedInterchangesOnly = ] nCompletedInterchangesOnly は、追加処理を必要とするインターチェンジがデータベースから削除されるかどうかを構成する整数値です。たとえば、一部のインターチェンジまたはドキュメントは、確認のために待機する、または再送信される必要があることがあります。

nCompletedInterchangesOnly を 0 と等価になるように構成すると、削除ジョブは、追加処理が必要かどうかにかかわらず、インターチェンジとドキュメントを削除します。この引数を 0 に設定すると、フィルタが減少するので、削除ジョブの完了が早くなります。

nCompletedInterchangesOnly を 1 と等価になるように設定すると、削除ジョブは、追加処理が必要なインターチェンジとドキュメントを削除しません。この引数を 1 に設定すると、フィルタが増加するので、削除ジョブの完了が遅くなります。

[ @nArchiveFlag = ] nArchiveFlag

引数 [ @nArchiveFlag = ] nArchiveFlag は、ストアド プロシージャがインターチェンジとドキュメントのレコードを削除の前にアーカイブするかどうかを示す整数値です。nArchiveFlag の値が 0 のとき、ストアド プロシージャはインターチェンジまたはドキュメント レコードを一切アーカイブしません。nArchiveFlag の値が 1 のとき、ストアド プロシージャは、データベースから削除される前にインターチェンジとドキュメントのレコードをアーカイブします。

[ @nvcArchiveDBServer = ] nvcArchiveDBServer

引数 [ @nvcArchiveDBServer = ] nvcArchiveDBServer はオプション引数です。nArchiveFlag が 1 と等価になるように設定する場合に、この引数を構成します。この引数は nvarchar(128) のデータ型であり、ストアド プロシージャがインターチェンジとドキュメントのレコードをアーカイブするデータベース サーバーの名前を指定します。

[ @nvcArchiveDBName = ] nvcArchiveDBName

引数 [ @nvcArchiveDBServer = ] nvcArchiveDBServer はオプション引数です。nArchiveFlag が 1 と等価になるように設定する場合に、この引数を構成します。この引数は nvarchar(128) のデータ型であり、ストアド プロシージャがインターチェンジとドキュメントのレコードをアーカイブするデータベースの名前を指定します。


クエリを使用したインターチェンジ データとドキュメント データの検索と並べ替え

ドキュメント型や送信元組織などの標準検索条件でクエリを使用して、インターチェンジとドキュメント インスタンスのレコード、および関連データの検索、表示、保存を行うことができます。

ここには次のトピックが含まれます。

  • 日付によるインターチェンジとドキュメントの情報の検索

  • 組織によるインターチェンジとドキュメントの情報の検索

  • ドキュメント型によるインターチェンジとドキュメントの情報の検索

  • クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

  • 組織とドキュメント型の検索条件のクリア

  • [クエリ結果] ページのカスタマイズ

  • [クエリ結果] ページの検索パラメータの表示

注

  • クエリ パラメータを選択するときは、できるだけ具体的なものにしてください。そうすることにより、サーバーの負荷が減り、クエリ結果が返される時間が短縮されます。

  • 選択時またはクエリ送信時に、次のようなメッセージが表示される場合があります。

    このページは別のドメインにあるデータにアクセスします。このアクセスを許可してもよろしいですか?

    Internet Explorer でこのメッセージが表示されないようにするには、[インターネット オプション] ダイアログボックスの [セキュリティ] タブで、[信頼済みサイト ゾーン] にセキュリティで保護された Web サイトを追加します。

    この Web アプリケーションがブラウザで信頼されるように手動で構成するには、Internet Explorer の [信頼済みのサイト] の一覧に追加します。[信頼済みのサイト] の一覧への Web アプリケーションの追加の詳細については、「BizTalk Server 2002 用の IIS 設定の構成」を参照してください。

  • コントロール パネルの [地域のオプション] ダイアログ ボックスで日付、数値、時刻、通貨などに対して標準以外の形式を構成すると、新規クエリを保存したり、保存した高度なクエリを表示できない場合があります。詳細については、「高度なクエリの使用」を参照してください。

    既存の高度なクエリを表示するには、[地域のオプション] の一覧で使用可能なオプションのみを選択します。たとえば、[日付] タブの [短い形式] ボックスの一覧で、オプションを選択します。[短い形式] ボックスの一覧にほかの形式を入力したり、ほかの形式を切り取って貼り付けたりしないようにしてください。


日付によるインターチェンジとドキュメントの情報の検索

  1. BizTalk ドキュメント トラッキングの [日付の範囲] で、[日付の表示] ボックスの一覧の [ローカル時刻] または [世界標準時] をクリックして、表示日付のタイム ゾーンを指定します。

  2. [開始日] ボックスの一覧に追跡期間の開始日を入力するか、矢印をクリックしてカレンダーを表示し、日付を選択します。

    時刻を変更するには、[開始日] ボックスの一覧の隣にあるボックスに開始時刻を入力するか、上矢印または下矢印をクリックして指定します。

  3. [終了日] ボックスの一覧に追跡期間の終了日を入力するか、矢印をクリックしてカレンダーを表示し、日付を選択します。

    時刻を変更するには、[終了日] ボックスの一覧の隣にあるボックスに終了時刻を入力するか、上矢印または下矢印をクリックして指定します。

  4. [クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

  5. インターチェンジ データを表示するには、表示するデータが格納されているインターチェンジ レコードを検索して、データ列の [データ] アイコンをクリックします。

    [インターチェンジ データの表示] ページが表示されます。

  6. インターチェンジの XLANG スケジュール ステータスを表示するには、[スケジュール] 列の [スケジュール] アイコンをクリックします。

    [XLANG スケジュールの概要の表示] ページが表示されます。

  7. インターチェンジに関連付けられたドキュメント インスタンス レコードを表示するには、対象のドキュメント インスタンス レコードが格納されているインターチェンジの隣の [展開記号 (+)] をクリックします。

  8. ドキュメント インスタンスに関連付けられたデータを表示するには、[データ] 列の [データ] アイコンをクリックします。

    [ドキュメント インスタンス データの表示] ページが表示されます。

  9. データをネイティブ形式で表示するには [ネイティブ形式の表示] を、XML 形式で表示するには [XML 形式の表示] をクリックします。

  10. ドキュメント インスタンスに関連付けられた受信確認データを表示するには、[受信] 列の [受信確認] アイコンをクリックします。

    新しい [クエリ結果] ページが表示されます。

  11. インターチェンジの隣の [展開記号 (+)] をクリックし、データ フィールドの [データ] アイコンをクリックします。

  12. ドキュメント インスタンスのカスタム検索フィールド データを表示するには、データを表示するドキュメントを検索し、水平スクロール バーを使用してカスタム検索フィールドを表示し、[カスタム検索] アイコンをクリックします。

    [カスタム検索フィールド データの表示] ページが表示されます。

注

  • [日付の表示] ボックスの一覧で選択する値によって、検索時刻と表示結果が異なります。たとえば、[日付の表示] ボックスの一覧で [世界標準時] を選択し、時刻フィールドで 8:00:00 を指定した場合、世界標準時 (UTC) の 8 時以後に処理されたすべてのデータが検索対象となります。これは、ローカル時刻の 8:00:00 とは異なります。

  • 既定の日付は、現在の日付の 7 日前に設定されています。

  • 表示日付は、BizTalk Server で生成されて、ドキュメント インスタンスとインターチェンジのメタデータに付けられるタイムスタンプです。実際のドキュメント内容の日付ではありません。実際のドキュメント日付を基にしてドキュメントを検索するには、[高度なクエリ] で式を作成してください。高度なクエリの詳細については、「高度なクエリの作成」を参照してください。

  • クエリで日付の範囲だけを指定すると、BizTalk ドキュメント トラッキングでは、すべての送信元組織と送信先組織、およびすべてのドキュメント型を検索します。このような単一検索パラメータは使用しないでください。最適な検索結果を得るために、具体的なパラメータを持つクエリを常に作成して、[クエリ結果] ページに返されるインターチェンジ レコードの数を制限してください。

  • XLANG スケジュール ステータスには、最後に検出されたイベント、処理の開始時刻と終了時刻などがあります。

  • コンピュータに Microsoft Internet Explorer 5 がインストールされていると、ドキュメント インスタンス データを表示したときに、ポインタが矢印やパイプ記号ではなく砂時計として表示されることがあります。砂時計として表示されていても、[ネイティブ形式の表示] や [XML 形式の表示] を選択したり、[名前を付けて保存] や [閉じる] ボタンをクリックすることができます。Microsoft Internet Explorer 5.5 にアップグレードすると、ポインタは矢印またはパイプ記号として表示されます。

関連項目

高度なクエリの作成

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索

クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

ドキュメント インスタンス レコードの結果について

インターチェンジ レコードの結果について

クエリについて


組織によるインターチェンジとドキュメントの情報の検索

  1. BizTalk ドキュメント トラッキングの [送信元の選択] ボックスの一覧で、インターチェンジとドキュメントを表示する組織をクリックします。送信元組織に関連付けられているアプリケーションを選択するには、組織の隣の [展開記号 (+)] をクリックし、対象のアプリケーションをクリックします。すべての送信元組織を選択するには、[すべて選択] をクリックします。

    または

    BizTalk ドキュメント トラッキングの [送信先の選択] ボックスの一覧で、インターチェンジとドキュメントを表示する組織をクリックします。送信先組織に関連付けられているアプリケーションを選択するには、組織の隣の [展開記号 (+)] をクリックし、対象のアプリケーションをクリックします。すべての送信先組織を選択するには、[すべて選択] をクリックします。

    同じクエリに対して、[送信元の選択] および [送信先の選択] ボックスの一覧で、組織とアプリケーションを選択できます。

  2. [クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。クエリ条件と一致するインターチェンジの一覧がここに表示されます。

  3. インターチェンジ データを表示するには、表示するデータが格納されているインターチェンジ レコードを検索して、データ列の [データ] アイコンをクリックします。

    [インターチェンジ データの表示] ページが表示されます。

  4. インターチェンジの XLANG スケジュール ステータスを表示するには、[スケジュール] 列の [スケジュール] アイコンをクリックします。

    [XLANG スケジュールの概要の表示] ページが表示されます。

  5. インターチェンジに関連付けられたドキュメント インスタンス レコードを表示するには、対象のドキュメント インスタンス レコードが格納されているインターチェンジの隣の [展開記号 (+)] をクリックします。

  6. ドキュメント インスタンスに関連付けられたデータを表示するには、[データ] 列の [データ] アイコンをクリックします。

    [ドキュメント インスタンス データの表示] ページが表示されます。

  7. データをネイティブ形式で表示するには [ネイティブ形式の表示] を、XML 形式で表示するには [XML 形式の表示] をクリックします。

  8. ドキュメント インスタンスに関連付けられた受信確認データを表示するには、[受信] 列の [受信確認] アイコンをクリックします。

    新しい [クエリ結果] ページが表示されます。

  9. インターチェンジの隣の [展開記号 (+)] をクリックし、[データ] 列の [データ] アイコンをクリックします。

  10. ドキュメント インスタンスのカスタム検索フィールド データを表示するには、データを表示するドキュメントを検索し、水平スクロール バーを使用してカスタム検索フィールドを表示し、[カスタム検索] アイコンをクリックします。

    [カスタム検索フィールド データの表示] ページが表示されます。

注

  • 送信元組織と送信先組織を特定しない場合は、すべての送信元組織と送信先組織のインターチェンジ レコードおよびドキュメント レコードが返されます。[すべてクリア] および [すべて選択] のどちらのオプションを使用しても、[クエリ結果] ページに同じ結果が返されます。最適な検索結果を得るために、具体的なパラメータを持つクエリを常に作成して、[クエリ結果] ページに返されるインターチェンジ レコードの数を制限してください。

  • XLANG スケジュール ステータスには、最後に検出されたイベント、処理の開始時刻と終了時刻などがあります。

  • コンピュータに Microsoft Internet Explorer 5 がインストールされていると、ドキュメント インスタンス データを表示したときに、ポインタが矢印やパイプ記号ではなく砂時計として表示されることがあります。砂時計として表示されていても、[ネイティブ形式の表示] や [XML 形式の表示] を選択したり、[名前を付けて保存] や [閉じる] ボタンをクリックすることができます。Microsoft Internet Explorer 5.5 にアップグレードすると、ポインタは矢印またはパイプ記号として表示されます。

関連項目

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

ドキュメント インスタンス レコードの結果について

インターチェンジ レコードの結果について

クエリについて


ドキュメント型によるインターチェンジとドキュメントの情報の検索

  1. BizTalk ドキュメント トラッキングの [ドキュメント型の選択] で、[ドキュメントの表示] をクリックします。

  2. [ドキュメント型の選択] ボックスの一覧で、検索するドキュメント型をクリックします。すべてのドキュメント型を選択するには、[すべて選択] をクリックします。

  3. [クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

  4. インターチェンジ データを表示するには、表示するデータが格納されているインターチェンジ レコードを検索して、データ列の [データ] アイコンをクリックします。

    [インターチェンジ データの表示] ページが表示されます。

  5. インターチェンジの XLANG スケジュール ステータスを表示するには、[スケジュール] 列の [スケジュール] アイコンをクリックします。

    [XLANG スケジュールの概要の表示] ページが表示されます。

  6. インターチェンジに関連付けられたドキュメント インスタンス レコードを表示するには、対象のドキュメント インスタンス レコードが格納されているインターチェンジの隣の [展開記号 (+)] をクリックします。

  7. ドキュメント インスタンスに関連付けられたデータを表示するには、[データ] 列の [データ] アイコンをクリックします。

    [ドキュメント インスタンス データの表示] ページが表示されます。

  8. データをネイティブ形式で表示するには [ネイティブ形式の表示] を、XML 形式で表示するには [XML 形式の表示] をクリックします。

  9. ドキュメント インスタンスに関連付けられた受信確認データを表示するには、[受信] 列の [受信確認] アイコンをクリックします。

    新しい [クエリ結果] ページが表示されます。

  10. インターチェンジの隣の [展開記号 (+)] をクリックし、[データ] 列の [データ] アイコンをクリックします。

  11. ドキュメント インスタンスのカスタム検索フィールド データを表示するには、データを表示するドキュメントを検索し、水平スクロール バーを使用してカスタム検索フィールドを表示し、[カスタム検索] アイコンをクリックします。

    [カスタム検索フィールド データの表示] ページが表示されます。

注

  • 1 つまたは複数のドキュメント型を指定せずに検索を絞り込まない場合は、クエリによって一覧のすべてのドキュメント型が返されます。最適な検索結果を得るために、具体的なパラメータを持つクエリを常に作成して、[クエリ結果] ページに返されるインターチェンジ レコードの数を制限してください。

  • XLANG スケジュール ステータスには、最後に検出されたイベント、処理の開始時刻と終了時刻などがあります。

  • コンピュータに Microsoft Internet Explorer 5 がインストールされていると、ドキュメント インスタンス データを表示したときに、ポインタが矢印やパイプ記号ではなく砂時計として表示されることがあります。砂時計として表示されていても、[ネイティブ形式の表示] や [XML 形式の表示] を選択したり、[名前を付けて保存] や [閉じる] ボタンをクリックすることができます。Microsoft Internet Explorer 5.5 にアップグレードすると、ポインタは矢印またはパイプ記号として表示されます。

関連項目

日付によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索

クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

ドキュメント インスタンス レコードの結果について

インターチェンジ レコードの結果について

クエリについて


クエリ パラメータの組み合わせによるインターチェンジとドキュメントの情報の検索

  1. BizTalk ドキュメント トラッキングでは、単一クエリ セッションで次のクエリ パラメータを組み合わせると、インターチェンジ レコードとドキュメント インスタンス レコード、および関連データの検索と表示を行うことができます。
    • 送信元の選択 : "送信元の選択" パラメータを使用したクエリの作成については、「組織によるインターチェンジとドキュメントの情報の検索」を参照してください。

    • 送信先の選択 : "送信先の選択" パラメータを使用したクエリの作成については、「組織によるインターチェンジとドキュメントの情報の検索」を参照してください。

    • ドキュメント型 : "ドキュメント型" パラメータを使用したクエリの作成については、「ドキュメント型によるインターチェンジとドキュメントの情報の検索」を参照してください。

    • 日時 : "日時" パラメータを使用したクエリの作成については、「日付によるインターチェンジとドキュメントの情報の検索」を参照してください。
  2. [クエリ] ボタンをクリックします。


組織とドキュメント型の検索条件のクリア

  • BizTalk ドキュメント トラッキングで、[送信元の選択]、[送信先の選択]、または [ドキュメント型の選択] ボックスの一覧の下の [すべてクリア] をクリックします。

注

  • [すべてクリア] をクリックすると、BizTalk ドキュメント トラッキングの検索対象は、すべての送信元組織と送信先組織、およびすべてのドキュメント型という既定の設定に戻ります。最適な検索結果を得るために、具体的なパラメータを持つクエリを常に作成して、[クエリ結果] ページに返されるインターチェンジ レコードの数を制限してください。


[クエリ結果] ページのカスタマイズ

  1. BizTalk ドキュメント トラッキングの [並べ替えの指定] で、[関連するインターチェンジのグループ化] チェック ボックスをオンにします。

    この操作により、関連送信インターチェンジでグループ化された受信インターチェンジが [クエリ結果] ページに表示されるようになります。関連する送信インターチェンジと共に受信インターチェンジを表示しない場合は、このチェック ボックスをオフにします。

  2. [並べ替えの指定] の [並べ替え順 1] ボックスの一覧で、最初に使用する並べ替え順をクリックします。並べ替え順のボックスの一覧それぞれに対してこの操作を繰り返し、[クエリ結果] ページでのドキュメントの並べ替え順を構成します。

    [並べ替え順] ボックスの一覧には、次の選択肢があります。

    • [送信元組織名]

    • [送信元アプリケーション名]

    • [送信先組織名]

    • [送信先アプリケーション名]

    • [ドキュメント型]

    • [処理時間]


[クエリ結果] ページの検索パラメータの表示

  1. クエリのパラメータを定義して、[クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

    クエリまたは高度なクエリの作成の詳細については、次のトピックを参照してください。

    • 日付によるインターチェンジとドキュメントの情報の検索

    • 組織によるインターチェンジとドキュメントの情報の検索

    • ドキュメント型によるインターチェンジとドキュメントの情報の検索

    • 高度なクエリの作成
  2. [検索パラメータ] バーの [表示] アイコンをクリックします。

    次の検索パラメータと、その値が、[検索パラメータ] に一覧表示されます。

    • [日付の範囲]

    • [タイム ゾーン]

    • [クエリ式名]

    • [並べ替え順]

    • [送信元の選択]

    • [送信先の選択]

    • [ドキュメント型の選択]

関連項目

高度なクエリの作成

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索


高度なクエリの使用

特定の注文番号が付いたドキュメント インスタンスなど、特定のデータを検索する必要がある場合に、情報の検索に高度なクエリを使用できます。

ここには次のトピックが含まれます。

  • 高度なクエリの作成

  • 既存の高度なクエリの選択

  • 既存の高度なクエリの編集

  • 既存の高度なクエリのクリア

  • 既存の高度なクエリの削除

注

  • コントロール パネルの [地域のオプション] ダイアログ ボックスで日付、数値、時刻、通貨などに対して標準以外の形式を構成すると、新規クエリを保存したり、保存した高度なクエリを表示できないことがあります。詳細については、「高度なクエリの使用」を参照してください。

    既存の高度なクエリを表示するには、[地域のオプション] の一覧で使用可能なオプションのみを選択します。たとえば、[日付] タブの [短い形式] ボックスの一覧で、オプションを選択します。[短い形式] ボックスの一覧にほかの形式を入力したり、ほかの形式を切り取って貼り付けたりしないようにしてください。

  • float および real データ型は近似データ型として知られています。float および real データ型の動作は近似数値データ型に関する IEEE 754 仕様に準拠しています。近似数値データ型は、多くの数字に対して指定された正確な値を格納しません。その値にきわめて近い近似値を格納します。多くのアプリケーションでは、指定された値と格納された近似値とのわずかな違いは認識されません。ただし、違いは常に明瞭です。float および real データ型のこの近似性のため、正確な数値動作が要求される場合 (財務アプリケーション、四捨五入などの演算、または等価チェックなど) は、これらのデータ型を使用しないようにしてください。代わりに、integer、decimal、money、または smallmoney データ型を使用します。

  • BizTalk Server では、Number データ型を整数データ型として追跡することができます。ドキュメント内の Number データ型の数値が整数データ型のサイズを超えると、警告メッセージが表示されます。この警告メッセージには、追跡できなかった値が含まれます。

    Number データ型を整数データ型として追跡する場合は、整数データ型のサイズを超えないようにしてください。

各国語対応に関する問題

  • システム ロケールによっては、XML データの数値が追跡データベースに整数の追跡フィールドとして記録される際に、BizTalk Server によって誤って解釈されることがあります。たとえば、ドイツ語のロケールで、XML 数値 4.0 は 40 として追跡データベースにログされます。小数点 (.) が数字グループ化記号として誤って解釈されるからです。

    この問題については、2 つの回避策があります。1 つめは、要素または属性に小数が格納されることが前もってわかっている場合は、XML の要素または属性のデータ型を Real (r4) または Double Real (r8) に変更します。2 つめは、Number 型の要素または属性を整数ではなく実数として記録するように、ドキュメント定義またはチャネルを構成します。


高度なクエリの作成

  1. BizTalk ドキュメント トラッキングの [高度なクエリ] で、[新規] をクリックします。

    [高度なクエリ ビルダ] ページが表示されます。

  2. [送信元の選択] ボックスの一覧で、オプションをクリックして送信元の選択条件を指定します。

    これは、検索対象であるフィールドから取得された名前です。

  3. [演算子] ボックスの一覧で演算子をクリックします。

  4. [値] ボックスに、値を入力します。

  5. [AND/OR] ボックスの一覧で、使用する条件とほかの条件を結合するには [AND] を、比較するには [OR] をクリックします。この手順は省略できます。

  6. [作成] をクリックします。

  7. 必要な条件をすべて追加するまで、手順 2. ～ 6. の操作を繰り返します。

  8. 次のいずれかの操作を行います。
    • [OK] をクリックして、この式の適用対象を現在のクエリ セッションに限定します。

    • [保存] をクリックして、これ以降のクエリ セッションで使用するために式を保存します。[BizTalk ドキュメント トラッキング] ダイアログ ボックスで、[クエリ式名の入力] ボックスに 50 文字以内で式名を入力し、[OK] をクリックします。

注意

  • クエリには一意で、大文字と小文字を区別した名前を選択したことを確認してください。その名前が大文字と小文字を区別しない比較によって既存エントリやデータ型と一致する場合、追跡フィールドに対する新規レコードは作成されません。BizTalk ドキュメント トラッキングでは同じ名前の複数のクエリを入力できますが、これらのクエリを区別するには各クエリを開く必要があるため、有用性が最も小さくなります。

  • 必ず、カスタム フィールドについては、追跡されているドキュメントに表示される名前を正確に入力してください。

注

  • 高度なクエリで作成した 1 つまたは複数の条件の集合をクエリ式と呼びます。

  • [送信元の選択] ボックスの一覧にフォーカスを設定し、ボタンをクリックした場合は、有効化するためにボタンのクリックが再度必要になる場合があります。

  • BizTalk メッセージ マネージャでは、カスタム フィールドを追跡するためにチャネルやドキュメント定義を構成すると、これらのフィールドが [送信元の選択] ボックスの一覧に表示されるようになります。フィールドの追跡を行うように BizTalk メッセージ マネージャを構成していない場合は、[送信元の選択] ボックスの一覧には "<カスタム検索>" だけが表示されます。特定フィールドの追跡の詳細については、「ドキュメント ログのプロパティの設定」および「チャネル内の仕様フィールドの選択」を参照してください。

  • カスタム検索フィールドを使用してインターチェンジまたはドキュメントを追跡し、値を照会する場合、[クエリの結果] ページに表示されるのは、カスタム検索フィールドから追跡したインターチェンジまたはドキュメントのみです。

関連項目

既存の高度なクエリのクリア

既存の高度なクエリの削除

既存の高度なクエリの編集

既存の高度なクエリの選択


既存の高度なクエリの選択

  1. BizTalk ドキュメント トラッキングの [高度なクエリ] で、[参照] をクリックします。

    [高度なクエリ] ダイアログ ボックスが表示されます。

  2. 既存のクエリを選択し、[OK] をクリックします。

注

  • [送信元の選択] ボックスの一覧にフォーカスを設定し、ボタンをクリックした場合は、有効化するためにボタンのクリックが再度必要になる場合があります。

関連項目

高度なクエリの作成

既存の高度なクエリのクリア

既存の高度なクエリの削除

既存の高度なクエリの編集


既存の高度なクエリの編集

  1. BizTalk ドキュメント トラッキングの [高度なクエリ] で、[参照] をクリックします。

    [高度なクエリ] ダイアログ ボックスが表示されます。

  2. 編集する既存のクエリを選択し、[編集] をクリックします。

    [高度なクエリ ビルダ] ダイアログ ボックスが表示されます。

  3. 次のうち、必要な操作を行います。
    • [新規] をクリックして条件を追加します。4 つのフィールドにそれぞれ条件を指定し、[作成] をクリックします。

    • 既存の条件をクリックし、[編集] をクリックします。次に、4 つのフィールドのうち任意のものを変更し、[作成] をクリックします。

    • 既存の条件を選択し、[削除] をクリックします。
  4. [保存] をクリックします。

    [高度なクエリ] ダイアログ ボックスが表示されます。

  5. 編集したクエリを選択し、[OK] をクリックします。

注

  • [送信元の選択] ボックスの一覧にフォーカスを設定し、ボタンをクリックした場合は、有効化するためにボタンのクリックが再度必要になる場合があります。

関連項目

高度なクエリの作成

既存の高度なクエリのクリア

既存の高度なクエリの削除

既存の高度なクエリの選択


既存の高度なクエリのクリア

  • BizTalk ドキュメント トラッキングの [高度なクエリ] で、[クリア] をクリックして、[クエリ式名] ボックスから現在の式をクリアします。

注

  • Internet Explorer の [更新] ボタンをクリックしても、高度なクエリは [クエリ式名] ボックスからクリアされません。

関連項目

高度なクエリの作成

既存の高度なクエリの削除

既存の高度なクエリの編集

既存の高度なクエリの選択


既存の高度なクエリの削除

  1. BizTalk ドキュメント トラッキングの [高度なクエリ] で、[参照] をクリックします。

    [高度なクエリ] ダイアログ ボックスが表示されます。

  2. クエリを選択し、[削除] をクリックします。

  3. 作業が完了したら、[高度なクエリ] ダイアログ ボックスを閉じます。

注

  • [送信元の選択] ボックスの一覧にフォーカスを設定し、ボタンをクリックした場合は、有効化するためにボタンのクリックが再度必要になる場合があります。

関連項目

高度なクエリの作成

クエリからの既存の高度なクエリのクリア

既存の高度なクエリの編集

既存の高度なクエリの選択


インターチェンジ データ、ドキュメント データ、およびカスタム検索データの保存

受信インターチェンジおよび送信インターチェンジとそのドキュメントを格納するように、BizTalk メッセージ マネージャ、BizTalk メッセージ構成オブジェクト モデル、および BizTalk Server 管理コンソールを構成すると、インターチェンジ、ドキュメント データ、およびカスタム フィールド検索データを保存して、オフラインで表示することができます。これにより、特定の状況のトラブルシューティングや業務遂行方法の分析を行うことができます。

ここには次のトピックが含まれます。

  • インターチェンジ データの保存

  • ドキュメント インスタンス データの保存

  • カスタム フィールド検索データの保存


インターチェンジ データの保存

  1. クエリのパラメータを定義して、[クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

    クエリまたは高度なクエリの作成の詳細については、次のトピックを参照してください。

    • 日付によるインターチェンジとドキュメントの情報の検索

    • 組織によるインターチェンジとドキュメントの情報の検索

    • ドキュメント型によるインターチェンジとドキュメントの情報の検索

    • 高度なクエリの作成
  2. 保存するインターチェンジ データが格納されているインターチェンジ レコードを検索し、データ フィールドの [データ] アイコンをクリックします。

    [インターチェンジ データの表示] ページが表示されます。

  3. [名前を付けて保存] をクリックします。

  4. [ファイル名] ボックスにファイルの名前を入力し、[保存] をクリックします。

関連項目

高度なクエリの作成

カスタム フィールド検索データの保存

ドキュメント インスタンス データの保存

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索


ドキュメント インスタンス データの保存

  1. クエリのパラメータを定義して、[クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

    クエリまたは高度なクエリの作成の詳細については、次のトピックを参照してください。

    • 日付によるインターチェンジとドキュメントの情報の検索

    • 組織によるインターチェンジとドキュメントの情報の検索

    • ドキュメント型によるインターチェンジとドキュメントの情報の検索

    • 高度なクエリの作成
  2. 保存するドキュメント インスタンス データが格納されているインターチェンジ レコードを検索し、このインターチェンジの左の [展開記号 (+)] をクリックします。

  3. データ フィールドの [データ] アイコンをクリックします。

    [ドキュメント インスタンス データの表示] ページが表示されます。

  4. [名前を付けて保存] をクリックします。

  5. [ファイル名] ボックスに、ファイルに付ける名前と拡張子 (.xml ファイル拡張子またはドキュメント本来のファイル拡張子) を入力し、[保存] をクリックします。

関連項目

高度なクエリの作成

カスタム フィールド検索データの保存

インターチェンジ データの保存

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索


カスタム フィールド検索データの保存

  1. クエリのパラメータを定義して、[クエリ] ボタンをクリックします。

    [クエリ結果] ページが表示されます。

    クエリまたは高度なクエリの作成の詳細については、次のトピックを参照してください。

    • 日付によるインターチェンジとドキュメントの情報の検索

    • 組織によるインターチェンジとドキュメントの情報の検索

    • ドキュメント型によるインターチェンジとドキュメントの情報の検索

    • 高度なクエリの作成
  2. 表示するドキュメントが格納されているインターチェンジ レコードの左の [展開記号 (+)] をクリックします。

  3. 水平スクロール バーを使用して、表示するドキュメントのカスタム検索フィールドを表示し、[カスタム検索] アイコンをクリックします。

    [カスタム検索フィールド データの表示] ページが表示されます。

  4. [名前を付けて保存] をクリックします。

  5. [ファイル名] ボックスにファイルの名前を入力し、[保存] をクリックします。

関連項目

高度なクエリの作成

ドキュメント インスタンス データの保存

インターチェンジ データの保存

日付によるインターチェンジとドキュメントの情報の検索

ドキュメント型によるインターチェンジとドキュメントの情報の検索

組織によるインターチェンジとドキュメントの情報の検索


BizTalk ドキュメント トラッキングのトラブルシューティング

ここでは、BizTalk ドキュメント トラッキングのトラブルシューティングについて、一般的な情報を提供します。

ここには次のトピックが含まれます。

  • BizTalk ドキュメント トラッキングのユーザー インターフェイスの表示に関する問題

  • インターチェンジが格納されない

  • ドキュメントが格納されない

  • クエリ結果に何も表示されない

  • クエリ結果に追跡フィールドが表示されない

  • 検索引数が多すぎる


BizTalk ドキュメント トラッキングのユーザー インターフェイスの表示に関する問題

原因 : Microsoft Office Web コンポーネントがインストールされていません。

解決策 : Microsoft Office Web コンポーネントをインストールします。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に、[コントロール パネル] をクリックします。

  2. [アプリケーションの追加と削除] をダブルクリックします。

    [アプリケーションの追加と削除] ダイアログ ボックスが表示されます。

  3. [Microsoft Office 2000 SR-1 Premium] をクリックします。

  4. [変更] をクリックします。

  5. [機能の追加/削除] をクリックします。

  6. [Office ツール] の隣の展開記号 (+) をクリックします。

  7. [Office Web コンポーネント] をクリックし、環境に適したオプションをクリックします。

  8. [完了] をクリックします。


インターチェンジが格納されない

原因 : BizTalk Server 管理コンソールで追跡機能が無効になっています。

解決策 : BizTalk Server 管理コンソールで追跡機能を有効にします。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk Server 管理コンソール] をクリックします。

  2. [Microsoft BizTalk Server 2002] を展開し、ドキュメントが格納されないサーバー グループをクリックします。

  3. [操作] メニューの [プロパティ] をクリックします。

    [BizTalk Server グループのプロパティ] ダイアログ ボックスが表示されます。

  4. [追跡] タブをクリックします。

  5. [ドキュメント トラッキングを有効にする] チェック ボックスをオンにします。

  6. 次の 1 つまたは複数のチェック ボックスをオンにします。
    • [受信インターチェンジを記録する]

    • [送信インターチェンジを記録する]

    • [元の MIME エンコード メッセージを記録する]
  7. [OK] をクリックします。

関連項目

サーバー グループの追跡のプロパティの構成


ドキュメントが格納されない

原因 : ドキュメント ログのプロパティが、BizTalk メッセージ マネージャのチャネルの構成で適切に設定されていません。

解決策 : チャネルの構成で適切なドキュメント ログのオプションをオンにします。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. チャネル ウィザードの [ドキュメント ログ] ページの [受信ドキュメントの記録] で、適切なチェック ボックスをオンにします。

  3. [ネイティブ形式] : チャネルの受信ドキュメントを元の形式で保存します。これは既定の設定です。

  4. [XML 形式] : チャネルの受信ドキュメントを XML 形式で保存します。

  5. [送信ドキュメントの記録] で適切なチェック ボックスをオンにします。

  6. [ネイティブ形式] : チャネルの送信ドキュメントを元の形式で保存します。

  7. [XML 形式] : チャネルの送信ドキュメントを XML 形式で保存します。

  8. 新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

  9. 既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。

  10. 変更が完了したら、[完了] をクリックします。


クエリ結果に何も表示されない

原因 1 : 日時の範囲が正しくありません。

解決策 : 日時の範囲が正しいことを確認します。たとえば、5 分前にドキュメントを送信したのに、10 分前より以前のドキュメントを検索するように時刻の範囲が設定されていると、追跡対象のドキュメントはクエリ結果に表示されません。

原因 2 : データベースからデータが削除された可能性があります。

解決策 : 詳細については、データベース管理者に問い合わせてください。

関連項目

日付によるインターチェンジとドキュメントの情報の検索


クエリ結果に追跡フィールドが表示されない

原因 : BizTalk Server でデータを変換できなかったか、演算オーバーフローのエラーが発生しています。

解決策 : イベント ログで、次のエラー メッセージを参照してください。

<パスとファイル名>:送信用の <グローバル一意識別子> の追跡項目をログに記録できませんでした :

追跡フィールド : <フィールド名>

仕様フィールド名 : <仕様フィールド名>/DTADataTypeTest/String/@_String

実際の値 : <フィールドの実際の値>

ドキュメントまたはチャネルの構成で、追跡フィールドの設定の確認および修正を行います。

関連項目

チャネル内の仕様フィールドの選択

ドキュメント ログのプロパティの設定


検索引数が多すぎる

原因 : [送信元の選択] ボックスの一覧や [送信先の選択] ボックスの一覧で指定したオプションの数が多すぎます。

解決策 : クエリをできるだけ具体的なものにしてください。[送信元の選択] ボックスの一覧や [送信先の選択] ボックスの一覧で指定するオプションの数を減らし、[クエリ] をクリックします。

関連項目

クエリを使用したインターチェンジ データとドキュメント データの検索と並べ替え


ドキュメントの監視

Microsoft® BizTalk™ Server 2002 の監視には、Windows Management Instrumentation (WMI) と Microsoft Operations Manager (MOM) 2000 を使用することができます。これら 2 つの管理ツールによって、以下の操作が可能になります。

  • 標準およびカスタムの警告通知を使った監視。

  • ツールのガイドラインを利用した、BizTalk Server に関する Microsoft Windows NT® イベント ログ エントリの取得と使用。

  • スクリプトを使わない、XLANG スケジューラのパフォーマンス統計情報の作成。

  • 基本的な BizTalk Server のコンポーネントの監視。たとえば、BizTalk Server のデータベースやデータベース テーブル、各インスタンスのキュー、サービスなどの監視が可能です。

ここには次のトピックが含まれます。

  • Windows Management Instrumentation (WMI) について

  • Microsoft Operations Manager について


Windows Management Instrumentation (WMI) について

Windows Management Instrumentation (WMI) は、Microsoft® Windows® 2000 に含まれるデータ管理レイヤです。Microsoft BizTalk Server 2002 では、WMI レイヤを使用して管理機能をカプセル化しています。BizTalk Server 管理コンソールを使って、グループ、サーバー、およびキューの設定を変更した場合、新しい値は、BizTalk Server WMI プロバイダ経由で BizTalk メッセージ管理データベースに格納されます。BizTalk Server 2002 において、WMI プロバイダは、管理オブジェクトの格納に Microsoft SQL Server™ データベースを使用します。WMI は、統一スクリプト アプリケーション プログラミング インターフェイス (API) をサポートします。この API は、ローカル コンピュータまたはリモート コンピュータ上の WMI プロバイダへのアクセスをアプリケーションとスクリプトに提供するものです。WMI の使用方法やサンプルについては、「BizTalk の管理と監視」を参照してください。

注

  • WMI には、WMI オブジェクト パスに使用できる構文と有効な文字に制限があります。以下は使用できない文字の一覧です。

    ~` ! @ # $ % ^ & * ( ) + = [ ] { } | ;\" '< > , . ?

    サーバー グループ名を作成する場合、これらの文字を使用してはいけません。

  • すべてのタイムスタンプは、SQL Server のローカル時刻を使用して作成されます。ただし、WMI プロバイダは世界標準時 (UTC) のタイムスタンプを参照します。その後、管理コンソールは、表示するためにタイムスタンプをローカル時刻に変換します。

  • プログラムによって WMI データベース レイヤにアクセスするには、\Program Files\Microsoft BizTalk Server\Setup フォルダにある InterchangeProvSchema.mof ファイルを使用します。このファイルには、[管理] オブジェクトに対応する WMI クラスが含まれています。WMI アプリケーション プログラミングの詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で「WMI アプリケーション プログラミングについて」を検索してください。

  • Microsoft Operations Manager (MOM) から WMI クエリを実行するには、そのクエリが実行されるサーバー上の BizTalk Server Administrators グループのメンバである必要があります。また、サーバーの root/MicrosoftBizTalkServer WMI名前空間に対するすべてのアクセス許可を BizTalk Server Administrators グループに承認する必要があります。WMI でのユーザー承認の詳細については、Windows 2000 ヘルプおよび「WMI 名前空間アクセス許可の Windows アカウントへの付与」を参照してください。

ここには次のトピックが含まれます。

  • カスタム カウンタの概要

  • 保留キューの概要

関連項目

BizTalk の管理と監視

Windows Management Instrumentation (WMI)


カスタム カウンタの概要

カスタム カウンタは、追跡データベースへの高度なクエリの実行によって、カスタム ビルトの Windows Management Instrumentation (WMI) クラスのインスタンスをプログラムから定義する手法です。このクエリは、次の所定の属性で構成することができます。

  • 時刻の範囲

  • ドキュメントの送信元

  • ドキュメントの送信先

  • ドキュメント型

これらの属性は、正規表現を使って指定できます。各クエリは条件と一致するドキュメントの数を返します。またクエリ結果の並べ替え方法を指定できます。さらに、条件のセット (クエリ) を Microsoft Operations Manager (MOM) によって使用される新しいクラス インスタンスとして指定して、警告が MOM 規則の一部として設定されるようにすることができます。

WMI クラスを使用すると、次のことを行うことができます。

  • 特定の追跡クエリを定義する WMI クラスの新しいインスタンスを作成する。

  • ドキュメント送信元とドキュメント送信先について、新しい WMI クラス インスタンスで作成された追跡クエリを検証する。

  • 新しい WMI クラス インスタンスで定義されたクエリを実行し、このクエリと一致する追跡データベース内のドキュメントの数を取得する。

詳細については、「Custom Counters」を参照してください。

関連項目

Creating a Custom Counter Using WMI

Custom Counter Query Properties

Validating the Custom Counter


保留キューの概要

保留キューには、解析エラー、シリアライズ エラー、送信の失敗、またはチャネル構成を見つけられないことなど、さまざまな理由で処理が失敗した作業項目が含まれます。BizTalk Server 管理コンソールによって、または BizTalk Server Windows Management Instrumentation (WMI) プロバイダを介してプログラムによって、保留キューのドキュメントを表示および取得することができます。WMI クエリは、次の所定の属性で構成することができます。

  • 送信先

  • 送信元

  • ドキュメント名

  • State

  • チャネル ハンドル

  • ポート ハンドル

  • 文字列保留 GUID

  • 理由

管理コンソールによる保留キューの表示の詳細については、「保留キュー」を参照してください。WMI プロバイダによる保留キューの表示の詳細については、「Accessing the Suspended Queue」を参照してください。

関連項目

Accessing the Suspended Queue

MicrosoftBizTalkServer_SuspendedQueue

Suspended Queue Monitoring


Microsoft Operations Manager について

Microsoft Operations Manager (MOM) 2000 は、Microsoft サーバー オペレーティング システムおよびサーバー ベース アプリケーション向けのイベント収集ツール、パフォーマンス監視ツール、およびレポート ツールが収められたものです。MOM は、積極的なリアルタイム システムの監視によって、さまざまなリソースの監視、管理、およびセキュリティ化を集中的に行い、Windows 2000 ネットワークとアプリケーションの可用性、パフォーマンス、およびセキュリティを強化します。MOM によって、重大なネットワークの問題を速やかに識別でき、施した対策の効果を追跡できます。また、組織内のほかの部門で利用できる、対策についての情報を提供することができるようになります。

また MOM では、Windows Management Instrumentation (WMI) を使用してネットワークのパフォーマンスを監視できます。パフォーマンスしきい値を追跡し、傾向分析のためのサンプル データを収集することができます。サンプル データのグラフを作成および表示し、その情報を容量計画に使用することができます。

MOM には次の機能があります。

  • イベント ドリブンの運用監視

  • 自己展開型のスケーラブルなソリューション

  • 高度なセキュリティ ポリシーの実施および監査機能

  • 強化されたシステム可用性およびパフォーマンス追跡

  • データを表示およびレポートするための多数の方法

  • 信頼性と可用性の向上

MOM は、BizTalk Server を実行しているサーバーから、パフォーマンス カウンタ、WMI カウンタ、イベント、Windows NT イベントなどのさまざまなデータを利用します。MOM は、このデータをプロバイダ、サーバー グループ、および規則を作成する際に利用します。プロバイダはデータの個別のソースで、データ ソース （つまり型）、個別のプロバイダ名、およびデータ ソースに固有のその他の属性を指定することによって定義されます。たとえば、"myQueue" という名前のキューのキュー サイズ (バイト単位) を監視するためのプロバイダは次のようになります。

Provider = Windows NT Performance Counter – MSMQ Queue-Bytes in Queue-myQueue-15.0-Minutes

注

  • サンプリング レートは、Windows NT パフォーマンス カウンタのデータ ソースに対応するプロバイダ定義の一部です。

プロバイダを作成したら、プロバイダからのデータを処理する規則を作成できます。規則は、MOM 内の 3 種類の処理規則グループのいずれかに含まれます。

  • Event Processing Rules （イベント処理規則）: この規則は、サーバー上で発生する各種イベントを処理できます。また、イベントに応じて所定のアクションを実行できます。イベントには、Windows NT イベント ログやそのほかの標準的なログ ファイルのインスタンス (インターネット インフォメーション サービス (IIS) の生成する IIS W3C ログ ファイルなど)、および WMI イベントがあります。アクションには、警告の表示、電子メールの送信、スクリプトの実行などがあります。

  • Performance Processing Rules (パフォーマンス処理規則): この規則は、パフォーマンスや容量のカウンタを扱います。このパフォーマンスの規則は、測定の規則やしきい値の規則として使用できます。測定の規則はレポート用の統計情報を収集するだけですが、しきい値の規則は警告を出すことができます。これは、測定規則としきい値規則のプロバイダがまったく同一の場合でも変わりません。

  • Alert Processing Rules （警告処理規則）: イベント規則とパフォーマンス規則は警告に応答するようには使用せず、別の警告規則を作成することで、イベントまたはパフォーマンス規則から出された警告に対応します。警告処理規則によって、1 つのグローバルな応答を、共通する多数の警告に 関連付けることができます。

各国語対応に関する問題

  • Microsoft Operations Manager (MOM) 2000 は英語版だけが利用可能です。次の一覧は、Microsoft BizTalk Server 2002 で MOM を使用する場合にサポートされる使用方法と制限を示しています。
    • 英語と日本語のどちらの BizTalK Server でも管理できます。

    • MOM サーバーは英語または日本語に対応していますが、単一の言語で使用する必要があります。

    • MOM は Microsoft SQL Server 2000 を使用します。MOM サーバーには英語または日本語の SQL Server をインストールできます。

    • Web コンソールは、英語以外の構成ではサポートされていません。ただし、Microsoft Management Console (MMC) コンソールは英語以外の構成でサポートされています。

    • MOM セットアップは英語のみをサポートします。ドメイン名とコンピュータ名はすべて英語である必要があります。

    • MOMは言語が混在した環境をサポートしていません。すべての MOM インフラストラクチャ サーバーのオペレーティング システムの言語は、監視されるコンピュータのオペレーティング システムの言語と同じである必要があります。ただし、例外として、フランス語またはドイツ語のシステムを監視する場合は、すべての MOM インフラストラクチャ サーバーが英語である必要があります。これは、BizTalk Server が、フランス語またはドイツ語にローカライズされたインフラストラクチャ サーバー上で実行している英語の MOM をサポートしていないためです。BizTalk Server は、日本語の管理対象コンピュータでの英語の MOM インフラストラクチャ サーバーをサポートしていません。

    • フォントの問題のため、すべてのプロパティ ページで、シングル ライン編集フィールドは日本語文字などの 2 バイト文字を表示できません。不足している情報は、右側のペインの説明フィールドまたはマルチ ライン編集フィールドに表示されます。

MOM の詳細については、Microsoft Operations Manager のヘルプを参照してください。

ここには次のトピックが含まれます。

  • BizTalk Server 2002 Enterprise Edition Management Pack

注

  • MOM は、BizTalk Server を実行しているコンピュータまたはシステム監視専用のコンピュータのいずれにもインストールできます。

  • MOM は、BizTalk Server 2002 CD-ROM に含まれていません。MOM は別途入手する必要があります。MOM の詳細については、Microsoft Operations Manager の Web サイト (www.microsoft.com/mom/) を参照してください。

  • MOM から WMI クエリを実行するには、そのクエリを実行しているサーバーの BizTalk Server Administrators グループのメンバである必要があります。

関連項目

Windows Management Instrumentation (WMI) について


BizTalk Server 2002 Enterprise Edition Management Pack

Microsoft Operations Manager (MOM) の監視機能をさらに強化するために、BizTalk Server 2002 Enterprise Edition Management Pack モジュールには、コンピュータのグループ化および処理規則や、BizTalk Server 2002 に固有のイベントを監視できるようにするためのその他の情報が含まれています。BizTalk Server 2002 Management Pack をインポートすると、現在の構成グループ内のコンピュータを監視することができます。BizTalk Server 2002 Management Pack には、すべてのメッセージ エラー メッセージとオーケストレーション エラー メッセージを含む規則とカウンタの初期セット、BizTalk Server データベース、Windows NT イベント、およびキューが用意されています。監視上のニーズを反映し、組織が監視しようとする領域のより詳しい情報を取得するように、Management Pack をカスタマイズすることができます。

BizTalk Server 2002 Management Pack には、次のものを含め、さまざまな種類の 900 以上の規則が用意されています。

  • BizTalk メッセージおよびBizTalk オーケストレーションから生成可能なすべての Windows Application イベントに対する処理イベント規則。

  • BizTalk Server 2002 のパフォーマンス カウンタおよびデータベース ファイル サイズ用のパフォーマンス測定規則。これらの規則は、BizTalk Server 固有のManagement Pack の 20 種類のパフォーマンス表示をサポートしています。

  • BizTalk Server 2002 のパフォーマンス カウンタおよびデータベース ファイル サイズ用のパフォーマンスしきい値規則 (エラー重要度に対する規則と警告重要度に対する規則)。

  • カスタム カウンタ、保留キュー、および特定の BizTalk Server 2002 実装向けにカスタマイズされた規則を構築する方法を示すその他 3 種類のサンプル規則。

これらの規則を使用して、システム管理者は次のことについて通知を受けることができます。

  • BizTalk メッセージ サービスが停止したとき、またはサービスが稼動していた時間。

  • BizTalk メッセージまたは BizTalk オーケストレーションから Windows イベントが生成されたとき。

  • 重要な顧客向けのドキュメントが保留されているかどうか、また特定の期間内に重要な顧客向けに正しく送信されたドキュメントの数。

  • BizTalk Server データベースがあまりにも大きくなったとき。

  • 単位時間あたりの失敗したスケジュール数があまりにも大きくなったとき。

ここには次のトピックが含まれます。

  • BizTalk Server 2002 を監視するための MOM の構成

  • BizTalk Server 2002 Management Pack のインポート

  • Notification Groups

  • ビュー

  • 完全構成された規則

  • ユーザー定義された規則

注

  • BizTalk Server 2002 Enterprise Edition Management Pack をインポートする前に、MOM 2000 をインストールする必要があります。


BizTalk Server 2002 を監視するための MOM の構成

次の手順は、Microsoft Operations Manager (MOM) をセットアップしてBizTalk Server 2002 コンピュータの監視を開始するために行う必要がある作業のガイドラインです。手順の詳細については、Microsoft Operations Manager のヘルプに記載されています。

  1. BizTalk Server 構成の監視に使用されるコンピュータに MOM 2000 をインストールします。詳細については、MOM インストール CD-ROM の Documentation フォルダにある『Microsoft Operations Manager Installation Guide』を参照してください。

    注

    • MOM が必要とする Consolidator/Agent Manager ドメイン アカウントは、BizTalk Server が使用する SQL Server データベースをホストするサーバーを含め、監視する予定の BizTalk Server コンピュータそれぞれに対して Windows 管理者権限を持っている必要があります。これを行うには、各サーバーの Windows 管理者グループにそのアカウントを追加するか、またはローカル管理者グループのメンバであるドメイン グループ (ドメイン管理者グループなど) にそのアカウントを追加します。
  2. BizTalk Server 2002 Enterprise Edition Management Pack を MOM にインポートします。詳細については、「BizTalk Server 2002 Management Pack のインポート」および Microsoft Operations Manager のヘルプの「Importing a Management Pack Module」を参照してください。

    注

    • BizTalk Server 2002 Enterprise Edition Management Pack は、BizTalk Server 2002 インストール CD-ROM の MOM フォルダに入っています。

    • BizTalk Server 2002 Management Pack をインポートするとき、MOM には次の 3 つのオプションが用意されています。

      [Merge, and retain changes that my company has made to rules.]

      [Merge, and always use the rules defined in the Management Pack. Preserve my company's knowledge base comments.]

      [Replace existing rule groups with those of the imported Management Pack.]

      初めて BizTalk Server Management Pack をインポートするときは、どのオプションも選択できます。ただし、以降のインポートでは、目的の動作に対応するオプションを選択することが重要です。

    • BizTalk Server 2002 Enterprise Edition Management Pack には、Microsoft BizTalk Server 2002 Enterprise Edition というコンピュータ グループが含まれています。このグループには、MOM によって管理され、HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0 というレジストリ キーを含むすべてのコンピュータが含まれます。
  3. MOM を正常にインストールできたら、MOM を使って新しい BizTalk Server のインストールを見つけるために、監視およびポーリングするコンピュータのグループを指定します。詳細については、Microsoft Operations Manager のヘルプの「Understanding Agents」、「Install Agents」、「Configuring Agent Manager Properties」、「Configuring Agent Deployment」、および「Agent Managers Window」を参照してください。

    注

    • (前に参照した MOM ドキュメントの記載に従って) 管理されるコンピュータの規則を設定し、これらの規則と一致するコンピュータを調べることにより、監視するコンピュータのグループを MOM に対して指定します。このコンピュータ グループには、監視する BizTalk Server 2002 サーバーおよび関連付けられている SQL Server がすべて含まれている必要があります。これにより、LocalSystem として動作する One Point というローカル サービスがインストールされます。
  4. 指定した規則に対象となるコンピュータが実際に含まれていることを確認するには、次の手順を行います。
    1. 管理されるコンピュータの規則が最後に変更された後で MOM がコンピュータの検査を行ったことを確認します。これを確認する最も効果的な方法は、この検査を手動で実際に起動することです。MOM の詳細については、Microsoft Operations Manager のヘルプの「Scanning Managed Computers」を参照してください。

      注意

      エージェント マネージャに対して定義した管理されるコンピュータの規則が非常に多数のコンピュータと一致する場合は、検査が予想以上に長い時間がかかることがあります。

    2. 管理されるコンピュータの一覧をチェックします。この一覧を表示する方法については、Microsoft Operations Manager のヘルプの「Viewing the Managed Computers List for an Agent Manager」を参照してください。
  5. BizTalk Server によって使用される SQL Server データベースをホストするが、BizTalk Server 2002 はインストールされていないすべての個別のサーバーを含めるように、Microsoft BizTalk Server 2002 Enterprise Edition コンピュータ グループを構成します。詳細については、Microsoft Operations Manager のヘルプの「Excluding or Including Computers in a Computer Group」を参照してください。

    注

    • BizTalk Server 2002 Enterprise Edition Management Pack は、Microsoft BizTalk Server 2002 Enterprise Edition というコンピュータ グループを作成します。このグループには、MOM によって管理されるすべてのコンピュータが含まれます。すなわち、HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0 というレジストリ キーを含むすべてのコンピュータがこのグループに含まれます。BizTalk Server 2002 のインストールされていない独立したサーバーに、ほかの BizTalk Server が使用する SQL Server データベースが置かれている場合には、このサーバーの名前を指定してコンピュータ グループに追加する必要があります。

以上の手順がすべて正常に完了した後、MOM はBizTalk Server 2002 を監視するように完全に構成されます。監視対象のコンピュータがすべて BizTalk Server 2002 Enterprise Edition コンピュータ グループに追加されたことを確認するには、次の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft Operations Manager] をポイントし、[MOM Administration Console] をクリックします。

    [MOM Administration Console] が表示されます。

  2. [Microsoft Operations Manager] をダブルクリックし、[Monitor] をダブルクリックします。次に [All Computer Groups] をクリックします。

  3. 右側のペインで [Microsoft BizTalk Server 2002 Enterprise Edition] をダブルクリックします。

  4. MOM によってこのコンピュータ グループに含まれていると判断されるすべてのコンピュータが一覧表示されます。

    注

    • MOM がグループのすべてのコンピュータを見つけるのに、数分以上かかることがあります。適度な時間 (検査されるコンピュータの数やその他の要因によって異なります) が経過しても、監視対象のコンピュータがコンピュータ グループに表示されない場合は、エージェント マネージャとコンピュータ グループに対する規則を調べて、目的のコンピュータが含まれていることを確認してください。


BizTalk Server 2002 Management Pack のインポート

BizTalk Server を監視するには、Microsoft Operations Manager (MOM) がインストールされているコンピュータに BizTalk Server 2002 Management Pack をインポートする必要があります。

  1. [スタート] メニューで [プログラム] をポイントします。次に [Microsoft Operations Manager] をポイントし、[MOM Administrator Console] をクリックします。

  2. 左側のペインで、[Microsoft Operations Manager (default)] を展開し、[Rules] を展開します。次に [Processing Rule Groups] をクリックします。

  3. [操作] メニューの [Import Management Pack] をクリックします。

  4. [Import Management Pack] ダイアログ ボックスが表示されます。[Management Pack] で Microsoft BizTalk Server 2002 CD-ROM を参照します。次に、[MOM] フォルダを参照し、[BizTalk2002.akm] を選択します。

  5. [開く] をクリックします。

  6. [Import] をクリックします。

注

  • BizTalk Server 2002 Management Pack は BizTalk Server 2002 CD-ROM に含まれています。ただし、BizTalk Server 2002 Management Pack を使用するには、あらかじめ MOM をインストールしておく必要があります。MOM の詳細については、Microsoft Operations Manager の Web サイト (www.microsoft.com/mom/) を参照してください。

  • MOM のインストールの詳細については、Microsoft Operations Manager のヘルプを参照してください。


Notification Groups

Microsoft Operations Manager (MOM) の Notification Groups は、通知構成の適用先となる定義済みのロールです。Notification Groups の構成では、そのロールのメンバが通知を受けるメカニズム (電子メール、ポケベル、インスタント メッセージなど) および各ロールの特定のメンバを定義します。警告規則が作成され、通知が定義されると、Notifiaction Groups が警告通知の対象として指定されます。

独自の Notification Groups を定義することが可能ですが、Microsoft Operations Manager には次の Notification Groups が既定で用意されています。

  • IT Administrators : このグループは、システムの稼動を技術的なレベルで維持する責任を持つ運用・ IT 管理技術者を含みます。

  • Database Administrators : このグループは、データベースの保守に対する特定の責任とスキルを持つ IT 管理者専用のグループです。

  • Business Administrators : このグループは、技術の最上部に実装されたビジネス プロセスを理解し、ビジネス レベルのシステム動作の監視業務を委ねられた個人を含みます。

注

  • 規則が機能するためには、"Operator/User" を Notification Groups に追加する必要があります。詳細については、Microsoft Operations Manager のヘルプの「Adding an Operator to a Notification Group」を参照してください。


ビュー

システムの全体的な正常な動作を監視し、保守作業を容易にするために、Microsoft Operations Manager (MOM) ではデータベースから特定の情報を表示することができます。これらのビューは 15 分ごとに更新されます。BizTalk Server 2002 Management Pack は、Management Pack に含まれている次のパフォーマンス カウンタと関連するビューを提供します。

  • Activated Schedule Instances

  • Asynchronous Submissions

  • Completed Schedule Instances

  • Database File Size:BTM

  • Database File Size:DTA

  • Database File Size:SQ

  • Database File Size:XLANG

  • Database Log Size:BTM

  • Database Log Size:DTA

  • Database Log Size:SQ

  • Database Log Size:XLANG

  • Dehydrated Schedule Instances

  • Documents Processed

  • Documents Received

  • Failed Schedule Instances

  • Interchanges Received

  • Items Suspended

  • Messaging Uptime

  • Synchronous Submissions

  • Transactions Aborted

これらのカウンタの詳細については、｢パフォーマンス カウンタ｣を参照してください。

Microsoft Operations Manager (MOM) は、ビューの表示方法を 2 つ提供します。

  • 既定のビューは、ビューが関連付けられているパフォーマンス カウンタとプロバイダの一覧を表示します。

  • グラフィカルなビューでは、選択されているパフォーマンス カウンタまたはプロバイダを時間の経過と共にプロットすることによってシステムのパフォーマンスを表示して、2 時間前からのカウンタや規則の値を示し、これらの値を 15 分ごとに更新することができます。

MOM で利用できる既定のビューと追加のビューの作成の詳細については、Microsoft Operations Manager のヘルプを参照してください。

ここには次のトピックが含まれます。

  • BizTalk Server のビューへのアクセス


BizTalk Server のビューへのアクセス

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft Operations Manager] をポイントし、[MOM Administrator Console] をクリックします。

  2. 左側のペインで [Microsoft Operations Manager (default)] を展開し、[Monitor] を展開します。次に、[Public Views] を展開し、[Microsoft BizTalk Server] を展開して、[Microsoft BizTalk Server 2002 Enterprise Edition] を展開します。

  3. アクセスするビューをクリックします。

MOM のビューの使用の詳細については、Microsoft Operations Manager のヘルプを参照してください。


完全構成された規則

Microsoft Operations Manager (MOM) の監視機能をさらに強化するために、BizTalk Server 2002 Management Pack には、BizTalk Server に固有のすべての Windows NT アプリケーション イベントとBizTalk Server パフォーマンス カウンタに対する完全構成された基本的な規則が既定で含まれています。

ここには次のトピックが含まれます。

  • Windows NT イベント規則

  • パフォーマンス カウンタ

関連項目

ユーザー定義された規則


Windows NT イベント規則

BizTalk Server 2002 Management Pack に含まれている完全に構成された規則の 1 つに、Windows NT Event Log 監視規則があります。BizTalk Server 固有のすべての Windows NT アプリケーション イベントは、基本的な規則として Microsoft Operations Manager (MOM) にインポートされます。監視される Windows NT イベントは、次の規則のいずれかに分類されます。

  • 警告を出す必要があったり、個別の応答を必要とする。

  • フィルタとして使用されるイベント。

  • ほかの同様のイベントと統合されるイベント。

MOM コンソール ツリーで、これらの規則はMicrosoft BizTalk Server 2002 ノードの下にある 3 種類の MOM 規則に分けられます。

  • Event Processing Rules

  • Alert Processing Rules

  • Performance Processing Rules

MOM 規則の詳細については、Microsoft Operations Manager のヘルプを参照してください。

イベント ID

通常、イベント ログ内の各エラー メッセージには、一意のエラー ID があります。ただし、エラー メッセージが相互に関連していることがあります。たとえば、ログイン エラーによって BizTalk メッセージ管理データベースへのアクセスが失敗した後、受信機能がメッセージを送信できないためにエラー メッセージが大量に作成される場合があります。このような場合、メッセージ エラーについて、BizTalk Server は、1 つのイベント ID での複数のエラーを要約するエラー ログを 1つだけ作成します。イベント ログでエラーの記述を調べると、大量に作成されたエラー メッセージがすべて示されていて、各イベント ID がエントリの最初に記載されていることがわかります。

Microsoft Operations Manager (MOM) は、イベント記述内部で個別のエラー メッセージのイベント ID によって各エラー メッセージを一意に識別します。

注

  • 要約されたエラー ログが作成されるのは、メッセージ エラーの場合だけです。オーケストレーションでは、エラーが前のエラーが原因で発生したかどうかに関係なく、各エラーはイベント ログに個別にログ記録されます。

関連項目

Windows NT イベント規則

Copyright © 1999-2001 Microsoft Corporation.
All rights reserved.

このトピックは役立ちましたか。ドキュメントやサンプル、製品全般に関するご意見、ご要望についてはこちらにお送りください。BizTalk Server に関するマイクロソフトへのフィードバック


パフォーマンス カウンタ

BizTalk Server 2002 Management Pack には、次の パフォーマンス カウンタ用のプロバイダと規則が含まれています。

  • メッセージ関連 : メッセージに関連するパフォーマンス カウンタは、BizTalk メッセージ サービス イベントを監視します。

  • XLANG 関連 : XLANG 関連のパフォーマンス カウンタは、BizTalk オーケストレーション サービス イベントを監視します。

パフォーマンス カウンタの値は、測定規則によって定期的に収集されます。測定規則は、パフォーマンス カウンタからの数値の収集を指定するパフォーマンス規則の 1 種です。

次の表に、パフォーマンス カウンタとその簡単な説明を示します。

メッセージのパフォーマンス カウンタ

パフォーマンス カウンタ | 説明
Asynchronous Submissions | BizTalk メッセージ サービスの最後の起動以降に完了した送信呼び出しの数を示す整数。
Documents Processed | BizTalk メッセージ サービスの最後の起動以降に処理された、つまり作業キューから引き出されてポート送信先アドレスに送信されたドキュメントの数を示す整数。
Documents Received | BizTalk Server が受信したドキュメントの総数を示す整数。これには、作業キューに入ったすべてのドキュメントおよび失敗した可能性があるドキュメントが含まれます。
Interchanges Received | メッセージ エンジンが受信したインターチェンジの数を示す整数。
Items Suspended | 保留キューに保留されている項目の数を示す整数。
Messaging Uptime | BizTalk メッセージ サービスが最後に起動されてから稼動している時間を示す整数。
Synchronous Submissions | 同期送信の数を示す整数。

XLANG 関連のパフォーマンス カウンタ

パフォーマンス カウンタ | 説明
Activated Schedule Instances | XLANG COM+ プロセスの最後の起動以降にアクティブになったスケジュール インスタンスの数を示す整数。
Completed Schedule Instances | 指定されたサーバーに対する XLANG COM＋ プロセスの最後の起動以降、正常に完了した XLANG スケジュール インスタンスの数を示す整数。
Dehydrated Schedule Instances | ステータス退避済みスケジュール インスタンスの総数を示す整数。
Failed Schedule Instances | 指定されたサーバーに対して失敗した XLANG スケジュール インスタンスの数を示す整数。
Transactions Aborted | XLANG COM+ プロセスの最後の起動以降、このプロセスに対して中断されたトランザクションの数を示す整数。

注

  • XLANG 関連のすべてのパフォーマンス カウンタは、指定されたサーバー上のすべての XLANG プロセスの累積カウントを表します。

データベース関連のパフォーマンス カウンタ

規則カウンタ | 説明
Database File Size : BTM | BizTalk メッセージ管理データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、関連するビューを作成するために使用します。
Database File Size – Error : BTM | BizTalk メッセージ管理データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、エラー応答を生成するために使用します。
Database File Size – Warning : BTM | BizTalk メッセージ管理データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、警告応答を生成するために使用します。
Database File Size : SQ | BizTalk Server 共有キュー データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、関連するビューを作成するために使用します。
Database File Size – Error : SQ | BizTalk Server 共有キュー データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、エラー応答を生成するために使用します。
Database File Size – Warning : SQ | BizTalk Server 共有キュー データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、警告応答を生成するために使用します。
Database File Size : DTA | BizTalk Server 追跡データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、関連するビューを作成するために使用します。
Database File Size – Error : DTA | BizTalk Server 追跡データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、エラー応答を生成するために使用します。
Database File Size – Warning : DTA | BizTalk Server 追跡データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、警告応答を生成するために使用します。
Database File Size : XLANG | オーケストレーション データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、関連するビューを作成するために使用します。
Database File Size – Error : XLANG | オーケストレーション データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、エラー応答を生成するために使用します。
Database File Size – Warning : XLANG | オーケストレーション データベース内のデータ ファイルのサイズ (KB)。 このカウンタは、警告応答を生成するために使用します。
Database Log Size : BTM | BizTalk メッセージ管理データベースのログ ファイルのサイズ (KB)。 このカウンタは、関連するビューを作成するために使用します。
Database Log Size – Error : BTM | BizTalk メッセージ管理データベースのログ ファイルのサイズ (KB)。 このカウンタは、エラー応答を生成するために使用します。
Database Log Size – Warning : BTM | BizTalk メッセージ管理データベースのログ ファイルのサイズ (KB)。 このカウンタは、警告応答を生成するために使用します。
Database Log Size : SQ | BizTalk Server 共有キュー データベースのログ ファイルのサイズ (KB)。 このカウンタは、関連するビューを作成するために使用します。
Database Log Size – Error : SQ | BizTalk Server 共有キュー データベースのログ ファイルのサイズ (KB)。 このカウンタは、エラー応答を生成するために使用します。
Database Log Size – Warning : SQ | BizTalk Server 共有キュー データベースのログ ファイルのサイズ (KB)。 このカウンタは、警告応答を生成するために使用します。
Database Log Size : DTA | BizTalk Server 追跡データベースのログ ファイルのサイズ (KB)。 このカウンタは、関連するビューを作成するために使用します。
Database Log Size – Error : DTA | BizTalk Server 追跡データベースのログ ファイルのサイズ (KB)。 このカウンタは、エラー応答を生成するために使用します。
Database Log Size – Warning : DTA | BizTalk Server 追跡データベースのログ ファイルのサイズ (KB)。 このカウンタは、警告応答を生成するために使用します。
Database Log Size : XLANG | オーケストレーション データベースのログ ファイルのサイズ (KB)。 このカウンタは、関連するビューを作成するために使用します。
Database Log Size – Error : XLANG | オーケストレーション データベースのログ ファイルのサイズ (KB)。 このカウンタは、エラー応答を生成するために使用します。
Database Log Size – Warning : XLANG | オーケストレーション データベースのログ ファイルのサイズ (KB)。 このカウンタは、警告応答を生成するために使用します。

注

  • BizTalk Server 2002 インストール時に、BizTalk メッセージ管理データベース オブジェクト名は既定で InterchangeBTM に、追跡データベース オブジェクト名は既定で InterchangeDTA に、共有キュー データベース オブジェクト名は既定で InterchangeSQ に、オーケストレーション データベース オブジェクト名は既定で XLANG になります。これらの既定のデータベースオブジェクト名を変更した場合は、正しいデータベースを指し示すようにデータベース パフォーマンス カウンタを変更する必要があります。
規則カウンタ | 説明
Suspended Queue Size (Measure) | 特定の時点での BizTalk Server 保留キューのサイズ。 このカウンタは、警告応答を生成するために使用します。

関連項目

完全構成された規則

ユーザー定義された規則


ユーザー定義された規則

BizTalk Server 2002 Management Pack には、BizTalk Server 2002 を監視するための完全構成された規則の包括的なセットが用意されていますが、BizTalk Server 2002 Management Pack には用意されていない、システム構成固有のイベントを監視する必要がある場合があります。このような場合、独自のユーザー定義された規則を作成できます。「Suspended Queue Monitoring」のサンプルに、BizTalk Server 監視用のユーザー定義された規則を作成する方法についての情報が記載されています。

ユーザー定義された規則の作成の詳細については、Microsoft Operations Manager のヘルプを参照してください。

関連項目

完全構成された規則

Suspended Queue Monitoring


BizTalk Server 2002 のアプリケーション開発

Microsoft® BizTalk™ Server 2002 には、取引先と業務用アプリケーションとの間のビジネス プロセスおよびデータ交換を管理するための実行可能アプリケーションを作成できるツールおよびサービスがあります。

ここには次のトピックが含まれます。

  • BizTalk SEED ウィザード

  • BizTalk Server リソース アプリケーションの展開

  • BizTalk オーケストレーションの設計

  • BizTalk メッセージ サービスの構成

  • 仕様の作成とデータのマッピング

  • BizTalk サービスの統合


BizTalk SEED ウィザード

BizTalk SEED ウィザードによって、企業は独自の Microsoft® BizTalk™ Server 2002 構成を SEED パッケージにまとめ、それをインターネット経由で取引先に渡すことができます。その場合でも、SEED パッケージを作成する企業は、ドキュメントを受信するように BizTalk Server を手動で構成する必要があります。ただし、SEED パッケージの作成によって、取引先は、BizTalk Server の構成や、その構成のテストを行うことができるようになり、さらに SEED パッケージを作成したハブ企業とのドキュメント交換を始められるようになります。SEED パッケージによって、企業は取引先とのビジネスを速やかに開始することができます。SEED パッケージには、次のものが含まれます。

  • パッケージを作成するハブ企業の名前

  • テスト Uniform Resource Locator (URL) と運用 URL 情報

  • 仕様とインスタンス データへの参照

SEED パッケージが作成されたら、取引先 (スポーク) はそのファイルをダウンロードしてインストールし、次のような情報を追加して構成することができます。

  • ポート情報 (テスト用の格納場所を含む)

  • 受信用の格納場所

取引先との関係はそれぞれ異なるため、スポークはこれらの一意な属性を指定する必要があります。

ここには次のトピックが含まれます。

  • BizTalk SEED ウィザードの詳細については、「BizTalk SEED ウィザードについて」を参照してください。

  • 特定の作業を実行する目的については、「BizTalk SEED ウィザードに関する作業を行う目的」を参照してください。

  • 作業を実行する手順の詳細については、「BizTalk SEED に関する作業を行う方法」を参照してください。

  • 問題を解決するためのヒントについては、「BizTalk SEED ウィザードのトラブルシューティング」を参照してください。


BizTalk SEED ウィザードについて

BizTalk SEED ウィザードによって、企業 (ウィザードではハブと呼ばれます) は SEED パッケージを作成し、それを取引先 (ウィザードではスポークと呼ばれます) に渡すことができます。 スポークは、SEED パッケージを開き、それを構成してテストし、展開元のハブのテスト サイトへドキュメントの送信を始めることができます。スポークがそのサイトとのドキュメントのテストに成功すると、展開元のハブでは SEED パッケージ構成を運用環境に統合し、スポークとのトランザクションを開始することができます。

次の表は、迅速な展開プロセスに含まれる作業の一覧です。

作業 | 作業の実行者
SEED パッケージの作成 | ハブ
送信する SEED パッケージの選択 | ハブ
SEED パッケージの送信または格納 | ハブ
スポークの BizTalk Server システムの構成 | スポーク
スポークのシステム上での構成のローカル テスト | スポーク
リモート接続のテスト | スポーク
構成の運用 (送信) 環境への移行 | ハブ
構成の運用 (受信) 環境への移行 | スポーク

スポークが SEED パッケージを構成した後、SEED パッケージはスポークのシステム上で適切なポートを自動的に構成して、スポークがハブ企業とのトランザクションのテストを開始できるようにします。ポートは、パッケージ ベースでなく、ドキュメントごとに作成されます。ポートが作成されるのは、スポークが構成を完了し、特定のドキュメント用のプロセスを作成した後です。

ここには次のトピックが含まれます。

  • SEED パッケージの開始

  • SEED パッケージの受信

  • ハブとスポークの関係の例

  • SEED の ASP ページについて


SEED パッケージの開始

SEED パッケージはハブによって SEED ウィザードを使って作成され、スポークは Web サイトまたはファイルの共有場所を介してそのパッケージを利用できます。一般的なシナリオは、1 つの企業とその企業と取引する同種の複数の取引先から構成されます。軸となる企業はハブと呼ばれ、取引先はスポークと呼ばれます。

ハブがスポークとの新しい関係を確立する場合、または既存のスポークからの新しいドキュメントの取り扱いを開始する場合、ハブは BizTalk ウィザードを使って SEED パッケージを作成します。SEED パッケージには次のものが含まれています。

  • ハブ名 : 接続を開始する企業の名前。この項目はすべての SEED パッケージに含まれます。ただし、以下の項目はドキュメントごとに異なります。

  • テスト URL : http://test.<ハブ名>/invoice (これは、リモート テストの段階でスポークがドキュメントを送信する宛先のテスト サイトです。)

  • 運用 URL : http://www.<ハブ URL>/b2b/invoices

  • 仕様 : c:\specification\invoice.xml

  • データ : 仕様に対する Extensible Markup Language (XML) インスタンス データ。

関連項目

SEED パッケージの作成


SEED パッケージの受信

スポークは、SEED パッケージを別の企業から受信するか、またはその企業の Web サイトからダウンロードする可能性があります。SEED パッケージを自社のコンピュータに保存したら、BizTalk SEED ウィザードを使って、構成を完了し、ドキュメントの受信および送信プロセスをテストすることができます。

SEED パッケージをコンピュータにインストールすると、必要なポート、チャネル、ドキュメント定義、および受信機能が作成されます。それぞれのポート、チャネル、ドキュメント定義、および受信機能のタイトルは、SEED パッケージの名前で始まります。この名前付け方式によって、SEED パッケージ オブジェクトには一意の名前が付けられます。また、この名前付け方式によって、これらのオブジェクトを BizTalk Server 上に既にインストールされている可能性があるその他の SEED パッケージ オブジェクトと区別することもできます。

BizTalk SEED ウィザードの [パッケージのインストール処理 - パッケージの選択] ページには、SEED パッケージに関する次の情報が表示されます。

  • [パッケージ ID] : これは生成された Global Unique Identification (GUID) 番号です。

  • [組織] : これは、SEED パッケージを作成したハブ企業によって指定された名前です。

  • [ドキュメント数] : SEED パッケージ内のドキュメント数を示します。

  • [推奨される操作] : パッケージの構成、作成、およびテストに関連する作業を示します。表示されるステータスは次のとおりです。
    • 構成する必要があるドキュメントが少なくとも 1 つあります。

    • インストールする必要があるドキュメントが少なくとも 1 つあります。

    • ローカルでテストを行う必要があるドキュメントが少なくとも 1 つあります。

    • リモートでテストする必要があるドキュメントが少なくとも 1 つあります。

    • 運用に切り替える必要があるドキュメントが少なくとも 1 つあります。

    • パッケージ全体がインストールされ、現在運用中です。

さらに、SEED ウィザードの [パッケージのインストール処理 ‐ ドキュメントの展開] ページには、SEED パッケージと関連付けられているドキュメントがすべて表示されます。各ドキュメントに対し、次の作業を実行して、構成を確認し、展開します。

  • [設定] : このプロセスは、ポートのプロパティ情報を設定します。ステータスは、[設定 完了] または [設定 未完] のいずれかです。

  • [作成] : このプロセスは、必要なオブジェクト (受信機能、ポート、チャネルなど) を作成します。ステータスは、オブジェクトが作成されたことを意味する [作成 成功] か、またはオブジェクトが作成されなかったことを意味する [作成 失敗] のいずれかです。

  • [ローカル テスト] : ウィザードがローカル テストを実行すると、仕様に対するインスタンス データが受信ドキュメントの受信場所として指定されているディレクトリに格納されるか、または送信ドキュメント用のリモート URL に同期的に送信されます。受信とマークされているドキュメントについて、BizTalk Server はそのファイルをピックアップし、ローカル テストの検証のために [テスト用の格納場所] に入れます。このインスタンスは BizTalk SEED ウィザードによってピックアップされ、形式と内容の両方について検証され、仕様のステータスが SEED パッケージ内で更新されます。これによって、ドキュメントの形式が正しいことが確認されます。インスタンスの形式が正しい場合、SEED パッケージ内の仕様のステータスが更新されます。送信とマークされているドキュメントには、SubmitSync が呼び出されます。続いて BizTalk Server はドキュメントを処理し、[最終的な格納場所] に格納します。次に BizTalk SEED ウィザードはそのドキュメントを [最終的な格納場所] からピックアップし、データを検証します。表示される可能性があるステータスは次のとおりです。
    • [ローカル テスト 処理中] : インスタンスのテスト中です。

    • [ローカル テスト 成功] : インスタンスが検証されました。

    • [ローカル テスト 失敗] : インスタンスが検証されませんでした。
  • [リモート テスト] : ウィザードが受信ドキュメントに対してリモート テストを実行するとき、SEED パッケージ内でトランスポート アドレスがハブのテスト用 URL である TestUｒｌ に更新されます。次に、ドキュメントは同期的に BizTalk Server に送信されます。続いて、ハブの Web サイトはドキュメントを HTTP 応答の一部として返します。BizTalk SEED ウィザードは応答を確認します。送信とマークされているドキュメントの場合、その日付は Extensible Markup Language (XML) ヘッダーにラップされていますが、このヘッダーには、ドキュメントの処理に使用されるスポークの運用 URL およびチャネルが含まれています。このページは指定されたチャネルを使用して Submit メソッドを呼び出し、Submit メソッドはドキュメントをハブの Web サイトの運用 URL (localsubmit.asp) に戻します。このドキュメントは次に [最終的な格納場所] に格納されます。この場所では、ドキュメントが BizTalk SEED ウィザードによってピックアップされて検証されます。このプロセスは、残りのすべての仕様に対して繰り返されます。.asp ページの詳細については、「SEED の ASP ページについて」を参照してください。

  • [展開] : 展開できるのは、受信とマークされているドキュメントだけです。ステータスは、構成が展開されたことを意味する [展開 成功]、または構成が展開されなかったことを意味する [展開 失敗] のいずれかです。

関連項目

SEED パッケージのインストール


ハブとスポークの関係の例

SEED パッケージを作成するコンポーネントを理解するには、まずハブとスポークの関係を理解する必要があります (この例では、2 つの架空の企業をハブとスポークとして使用するシナリオにについて説明します)。標準的なシナリオには、ハブ (この例では Northwind Traders 社) と 1 つ以上のスポーク (この例ではContoso 社) があります。Northwind Traders 社の調達部門 (この展開シナリオのハブ) は、さまざまなメンテナンス要求発注に対する請求書を複数の取引先 (スポーク) から受信します。

調達部門は Web サイトを持っていて、そこでサプライヤ (スポーク) からの請求書を受信します。この場所に送信されるドキュメントは、BizTalk エディタの仕様に従っている Invoice.xml という名前の Extensible Markup Language (XML) ファイルです。ドキュメントは、この場所とスポークのテスト場所で受信時に検証されます。

Northwind Traders 社もまた、ドキュメントを受信し、それらを仕様に照らして検証するためのテスト サイトをセットアップしています。ドキュメントが仕様と一致する場合、データはスポークに送信されます。このテスト サイトは、すべてのスポークがファイルをハブの運用サイトに送り返す前にトランザクションをテストするための場所として使用されます。トランザクションがエラーなしで処理されるようになるまで、スポークはハブのテスト サイトにトランザクションを送信します。この手順によって、運用サイトを介して交換されるトランザクションの成功が確実になります。

Northwind Traders 社は SEED パッケージを作成し、そのパッケージを自社の Web サイトに配置し、スポークがダウンロードできるようにします。スポークである Contoso 社はその SEED パッケージをダウンロードし、BizTalk SEED ウィザードを使用して構成を完了しますが、この際、ポートおよび場合によっては受信機能情報が必要となります。

Contoso 社が SEED パッケージを構成した後、BizTalk SEED ウィザードは適切なチャネルとポートを作成して、ハブのテスト サイトと通信するようにスポークのサイトを構成します。Contoso 社はチャネル (およびチャネルにバインドされているポート) に送信することによってサンプル インスタンスをテストし、チャネルはこのインスタンスをテスト ASP ページに送信します。

テストが正常に完了した後、Contoso 社は実際の運用を行うことができます。

関連項目

SEED パッケージの開始

SEED パッケージの受信


SEED の ASP ページについて

BizTalk SEED ウィザードには、slingback.asp、trigger.asp、および localsubmit.asp の 3 つの Active Server Pages (ASP) が含まれています。これらの ASP ページは、\Program Files\Microsoft Biztalk Server\SEED フォルダにあります。SEED パッケージを作成する前に、Web サイトをセットアップし、そのサイトに Slingback.asp、Trigger.asp、および Localsubmit.asp の 3 つのファイルを配置する必要があります。これらのページは、ポストを取得するように設計されています。セキュリティで保護されたサイトの実装の詳細については、MSDN Online Library の Web サイト (www.msdn.microsoft.com/library/default.asp) にアクセスして、記事「Implementing a Secure Site with ASP」を検索してください。

BizTalk SEED ウィザードによるこれらのページの使用方法について説明します。

  • Slingback.asp : この ASP は、受信ドキュメントのリモート テストに使用されます。SEED パッケージを作成するとき、ハブではこのページまたは同じ機能を備えたページを [リモート テスト URL] ボックスで使用する必要があります。スポークで [リモート テスト] ボタンをクリックすると、ドキュメントは slingback.asp を介して BizTalk Server へ同期的に送信されます。次に、このドキュメントのコピーがスポークへ戻され、戻ってきたドキュメントが送信したものと一致することが BizTalk SEED ウィザードによって確認されます。

  • Trigger.asp : この ASP は、送信ドキュメントのリモート テストに使用されます。SEED パッケージを作成する際、ハブでは送信ドキュメントの [リモート テスト URL] ボックスに「trigger.asp」と入力する必要があります。ドキュメントは trigger.asp ページに送信されますが、このページはスポークの運用 URL とスポークがドキュメントを処理するために使用したチャネルが含まれていて、これらはすべてExtensible Markup Language (XML) ファイルにラップされています。trigger.asp ページ (ハブ側) 上で、スポークの運用 URL (通常は localsubmit.asp) をトランスポート アドレスとして、オープンな送信先への送信が呼び出されます。

  • Localsubmit.asp : この ASP は、送信ドキュメントのリモート テストに使用されます。スポークは、localsubmit.asp を運用 URL として使用します。localsubmit.asp がドキュメントを受信すると、チャネルが XML ファイルから取得され、ドキュメントは指定したチャネルを使って BizTalk Server に送信されます。

関連項目

SEED パッケージの作成


BizTalk SEED ウィザードに関する作業を行う目的

ここでは、BizTalk SEED ウィザードで行う作業の目的についてのクイック リファレンスを示します。次の表は、主要な作業を示しており、各作業の目的と対応する手順へのリンクを明記しています。

作業 作業を行う目的
  • SEED パッケージの作成
 自分の組織内のチームまたは取引先がデータ交換処理を開始するために利用することができる BizTalk Server 2002 構成 (送信および受信ドキュメント用) を含む Extensible Markup Language (XML) パッケージを作成します。
  • SEED パッケージのインストール
 運用環境内でビジネスを行う前にトランザクション プロセスをテストするために使用できるハブの BizTalk Server 2002 構成 (送信および受信ドキュメント用) を含む XML パッケージをインストールします。


BizTalk SEED ウィザードに関する作業を行う方法

ここでは、SEED パッケージの作成およびインストール方法を作業ごとに説明します。

ここには次のトピックが含まれます。

  • SEED パッケージの作成

  • SEED パッケージのインストール


SEED パッケージの作成

SEED パッケージを作成する前に、Web サイトをセットアップし、そのサイトに Slingback.asp、Trigger.asp、および Localsubmit.asp の 3 つのファイル (これらのファイルは \Program Files\Microsoft BizTalk Server\SEED フォルダにあります) を配置する必要があります。これらのページは、ポストを取得するように設計されています。セキュリティで保護されたサイトの実装の詳細については、MSDN Online Library の Web サイト (www.msdn.microsoft.com/library/default.asp) にアクセスして、記事「Implementing a Secure Site with ASP」を検索してください。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk SEED ウィザード] をクリックします。

    BizTalk SEED ウィザードが表示されます。

  2. [BizTalk SEED ウィザードへようこそ] ページで [SEED パッケージを作成] をクリックし、[次へ] をクリックします。

  3. [パッケージの作成処理 ‐ 組織の情報] ページのボックスに自分の組織の名前を入力します。

    または

    必要に応じて、[参照] をクリックして、既存の SEED パッケージを使用します。[開く] ダイアログ ボックスが表示されます。使用する SEED パッケージを選択し、[開く] をクリックします。

    重要

    • 既存の SEED パッケージを変更すると、[参照] ボタンは無効になります。つまり、[パッケージの作成処理 ‐ 組織の情報] ページに戻って、SEED パッケージを再度読み込むことができなくなります。変更を加えた後で SEED パッケージを再度読み込むには、[キャンセル] をクリックしてウィザードを終了します。再び [BizTalk SEED ウィザード] を開き、[パッケージの作成処理 - 組織の情報] ページで同じ SEED パッケージを参照します。
  4. [次へ] をクリックします。

  5. [パッケージの作成処理 - ドキュメントの仕様] ページで [追加] をクリックします。

    [ドキュメントの構成] ダイアログ ボックスが表示されます。

  6. [仕様] ボックスの隣にある [参照] をクリックして、仕様を探します。

    [WebDAV リポジトリからのドキュメント仕様の選択] ダイアログ ボックスが表示されます。

  7. 仕様の場所を参照し、ファイルを選択し、次に [開く] をクリックします。

  8. [テスト インスタンス] ボックスの隣にある [参照] をクリックして、ドキュメント インスタンスを探します。

    [開く] ダイアログ ボックスが表示されます。

  9. ドキュメント インスタンスの場所を参照し、ファイルを選択し、[開く] をクリックします。

  10. [ハブが受信] または[ハブが送信] のいずれかを選択します。

  11. 手順 10. で [ハブが受信] を選択した場合は、Slingback.asp ページが含まれているサーバーのパスを [リモート テスト URL] ボックスに入力し、手順 10. で [ハブが送信] を選択した場合は、Trigger.asp ページが含まれているサーバーのパスを [リモート テスト URL] ボックスに入力します。次に、手順 10. で [ハブが送信] を選択した場合は [OK] をクリックします。手順 10. で [ハブが受信] を選択した場合は、手順 12. に進みます。

    注

    • [OK] をクリックすると、[パッケージの作成処理 - ドキュメントの仕様] ページが表示されます。必要な場合は手順 13. を完了します。必要ない場合は手順 14. に進みます。
  12. [ハブが受信] を選択した場合は、[運用 URL] ボックスに自分の組織の運用サーバーのパスを入力し、[OK] をクリックします。

    [パッケージの作成処理 - ドキュメントの仕様] ページが表示されます。必要な場合は手順 13. を完了します。必要ない場合は手順 14. に進みます。

  13. ドキュメントの構成を編集する必要がある場合は、次の手順を行います。
    1. [ドキュメント] の一覧で仕様を選択し、[編集] をクリックします。

      [ドキュメントの構成] ダイアログ ボックスが表示されます。

    2. 手順 3. から手順 9. に従って、オプションを変更します。

    [ドキュメント] の一覧から仕様を削除する場合は

    • [ドキュメント] の一覧から仕様を選択し、[削除] をクリックします。
  14. [次へ] をクリックします。

  15. [BizTalk SEED ウィザードの完了] ページで、必要に応じて、[参照] をクリックして SEED パッケージの場所を指定し、[完了] をクリックして、[SEED パッケージのパス] ボックスに指定されている場所にパッケージをインストールします。

    [BizTalk SEED ウィザード メッセージ] ボックスが表示されます。

  16. [OK] をクリックします。

関連項目

ハブとスポークの関係の例

SEED パッケージの開始

SEED パッケージのインストール

SEED の ASP ページについて


SEED パッケージのインストール

まだインストールしていない場合は、すべてのファイル (Localsubmit.asp を除く) を適当なディレクトリにインストールします。SEED パッケージに含まれている送信ドキュメントの構成中にアクセスできる仮想ディレクトリに Localsubmit.asp ファイルをインストールします。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk SEED ウィザード] をクリックします。

    BizTalk SEED ウィザードが表示されます。

  2. [BizTalk SEED ウィザードへようこそ] ページで [SEED パッケージをインストール] をクリックし、[次へ] をクリックします。

  3. [パッケージのインストール処理 - パッケージの選択] ページで [参照] をクリックし、SEED パッケージを探します。

    [ファイルを開く] ダイアログ ボックスが表示されます。

  4. SEED パッケージの場所を参照し、ファイルを選択し、[開く] をクリックします。

  5. [次へ] をクリックします。

  6. [パッケージのインストール処理 - テストの情報] ページの [タイムアウト] ボックスに数値を入力し、[間隔] ボックスに数値を入力して、[次へ] をクリックします。

    重要

    • SEED パッケージに大きなドキュメントが含まれていると、テスト結果のステータスが [タイムアウト] または[失敗] になる場合があります。

    • [タイムアウト] ボックスの値は、BizTalk Server グループ設定で指定されている管理キャッシュの値に加算されます。
  7. [パッケージのインストール処理 - ドキュメントの展開] ページの [ドキュメント] ボックスで仕様を選択し、[設定] をクリックします。

    重要

    • ドキュメントが作成処理中に [ハブが受信] として構成されている場合は、[受信ドキュメント (ハブが受信) の構成] ボックスが表示されます。手順 8. に進みます。

    • ドキュメントが作成処理時に [ハブが送信] として構成されている場合は、[送信ドキュメント (ハブが送信) の構成] ボックスが表示されます。手順 14. に進みます。
  8. [受信ドキュメント (ハブが受信) の構成] ダイアログ ボックスで、[場所] ボックスの隣にある [参照] をクリックして、受信機能のポーリング場所を指定します。

    [フォルダの参照] ダイアログ ボックスが表示されます。

    注

    • 指定する場所は、[テスト用の格納場所] ボックスで指定する場所とは異なるものである必要があります。
  9. 受信機能の場所を選択し、[OK] をクリックします。

  10. [ポーリングするファイルの種類] ボックスに、検索するファイルの種類を入力します。

    注

    • ファイルの種類を変更する場合は、SEED パッケージ内の既定のファイルの種類が確実に含まれるようにしてください。
  11. [テスト インスタンス] ボックスの隣にある [参照] をクリックして、ドキュメント インスタンスを探します。

    [フォルダの参照] ダイアログ ボックスが表示されます。

    注

    • 指定する場所は、[受信機能] の [場所] ボックスで指定する場所とは異なるものである必要があります。
  12. テスト用の格納場所を選択し、[OK] をクリックします。

    [パッケージのインストール処理 - ドキュメントの展開] ページが表示されます。

  13. ドキュメントが [受信ドキュメント (ハブが受信) の構成] オプションを使用して構成された場合は、手順 16. に進みます。

  14. [送信ドキュメント (ハブの送信) の構成] ダイアログ ボックスの [運用 URL] ボックスに、localsubmit.asp ページの場所を入力します。

  15. [最終的な格納場所] ボックスで、[参照] をクリックしてテスト用送信ドキュメントの最終的な格納場所を指定し、[OK] をクリックします。

  16. [作成] をクリックします。

    注

    • 作成処理が完了すると、[作成] ボタンは [削除] ボタンに変わります。
  17. [ローカル テスト] をクリックして、ローカル構成のみを確認します。

  18. [リモート テスト] をクリックして、ハブへのリモート接続を確認します。

    ドキュメントの [ハブ] フィールドに [送信] と表示されている場合は、手順 20. に進みます。

  19. [展開] をクリックします。

    [展開] ボタンが有効になるのは、ドキュメントの [ハブ] フィールドに [受信] と表示されている場合のみです。

  20. [次へ] をクリックします。

    [BizTalk SEED ウィザードの完了] ページが表示されます。

  21. [完了] をクリックします。

  22. [OK] をクリックして、[BizTalk SEED ウィザード メッセージ] ボックスを閉じます。

関連項目

ハブとスポークの関係の例

SEED パッケージの受信


BizTalk SEED ウィザードのトラブルシューティング

ここでは、SEED パッケージのトラブルシューティングについて説明します。

ここには次のトピックが含まれます。

  • ローカル テストまたはリモート テストの失敗またはタイムアウト


ローカル テストまたはリモート テストの失敗またはタイムアウト

原因 : 送信ドキュメントの [ローカル テスト] または [リモート テスト] オプションがタイムアウトを示しています。

解決策 :

  1. イベント ログをチェックします。問題のファイルに関するエラーがログ記録されていない場合は、[パッケージのインストール処理 - テストの情報] ページの [タイムアウト] ボックスで指定する時間を長くします。

  2. イベント ログに問題のファイルに関するエラーがある場合は、イベント ログ情報に従ってエラーを解決します。

  3. SEED パッケージに含まれているドキュメント インスタンスと同じ名前のファイルがテスト用の格納場所にある場合、BizTalk Server は SEED パッケージに含まれているドキュメント インスタンスをテスト用の格納場所に含まれているファイルに追加します。その結果、ドキュメント インスタンスは、SEED パッケージに含まれているサンプル インスタンスと一致しなくなります。テスト用の場所にあるファイルの名前を変更するか、またはそのファイルを削除してから、[ローカル テスト] または [リモート テスト] をクリックします。

原因 : 受信ドキュメントの [リモート テスト] オプションに問題があります。

解決策 :

  1. イベント ログをチェックします。問題のファイルに関するエラーがログ記録されていない場合は、[パッケージのインストール処理 - テストの情報] ページの [タイムアウト] ボックスで指定する時間を長くします。

  2. イベント ログに問題のファイルに関するエラーがある場合は、イベント ログ情報に従ってエラーを解決します。

  3. SEED パッケージに含まれているドキュメント インスタンスと同じ名前のファイルがテスト用の格納場所にある場合、BizTalk Server は SEED パッケージに含まれているドキュメント インスタンスをテスト用の格納場所に含まれているファイルに追加します。その結果、ドキュメント インスタンスは、SEED パッケージに含まれているサンプル インスタンスと一致しなくなります。テスト用の場所にあるファイルの名前を変更するか、またはそのファイルを削除してから、[ローカル テスト] または [リモート テスト] をクリックします。

  4. ハブのシステムが応答しないことが問題の原因である場合は、しばらく待ってから、[リモート テスト] をクリックします。


BizTalk Server リソース アプリケーションの展開

Microsoft® Application Center 2000 を利用することによって、Microsoft BizTalk™ Server 2002 の構成を別のサーバーに展開することができます。たとえば、テスト環境から運用環境へ構成情報を移動する場合などに利用できます。Application Center を使用して環境を展開すれば、構成の移動にかかる時間と、付随する手動で行う設定の量を大幅に削減できます。

BizTalk Server レプリケーション ドライバは、Application Center を拡張することによって BizTalk のリソースをクラスタのすべてのメンバにレプリケートしたり、クラスタ間でレプリケートできるようにします。このドライバは、Application Center の既存のレプリケーション サポートを利用しています。

BizTalk Server レプリケーション ドライバは、以前の展開方法であった BizTalk Server 2000 の BTConfigAssistant に代わるものです。BTConfigAssistant は、BizTalk Server の初期のリリースに収められていた Microsoft Visual Basic® サンプル アプリケーションで、構成情報を抽出することでアプリケーションの展開を可能にしていました。この方法は BizTalk Server 2002 でも用いることができますが、アプリケーションの展開方法としては、Application Center を利用することをお勧めします。

ここには次のトピックが含まれます。

  • 展開の詳細については、「BizTalk Server の展開について」を参照してください。

  • 各作業の目的をまとめたクイック リファレンスについては、「BizTalk Server の展開に関する作業を行う理由」を参照してください。

  • 詳しい作業手順については、「BizTalk Server の展開に関する作業を行う方法」を参照してください。

  • 問題を解決するためのヒントについては、「BizTalk Server の展開のトラブルシューティング」を参照してください。


BizTalk Server の展開について

Microsoft Application Center 2000 は、.NET Enterprise Servers の 1 つで、BizTalk Server のさまざまなリソースの展開をサポートしています。たとえば、ポート (ならびにチャネルなど、ポートにバインドされたすべてのオブジェクト) やポート グループ、さらにファイル、COM+ アプリケーション、レジストリ キー、Web サイトと仮想ディレクトリ、およびデータ ソースなどの展開がサポートされます。

通常、BizTalk Server の運用環境は、運用に必要なメッセージ構成情報を格納する BizTalk メッセージ管理データベースと、メッセージ処理の構成を共有するアプリケーション サーバーの集合で構築されます。クラスタ内の各サーバーには、XLANG スケジュール、XLANG スケジュールに関連付けられた COM+ アプリケーション、およびアプリケーションを展開する際にどの BizTalk メッセージ管理データベースを使用するかに関する情報が置かれています。

1 つだけの中央の WebDAV リポジトリしかサポートされていないため、アプリケーションを展開するときには、ソースとターゲット　コンピュータの双方で BizTalk メッセージ管理データベースを利用可能にしておく必要があります。

重要

  • Microsoft® SQL Server™ がリモートにあるとき、Application Center ドライバがエラーになるのを防ぐために、ローカル システム アカウント (system\<コンピュータ名>) をリモートの SQL Server に追加する必要があります。Application Center クラスタから BizTalk メッセージ管理データベース (InterchangeBTM) にアクセスするには、BizTalk メッセージ管理データベースが Application Center のクラスタ コントローラ上に存在するか、または Application Center クラスタの外部に存在する必要があります。BizTalk メッセージ管理データベースが Application Center クラスタのメンバに置かれている場合、BizTalk Server レプリケーション ドライバはこれにアクセスできない可能性があります。

Application Center の BizTalk Server レプリケーション ドライバには、次の 2 つの主要な機能があります。

  1. ローカル リソースの移動 : この作業では、ソース サーバーがローカルのリソースを参照し、そのリソースをターゲット サーバーに複製することが必要になります。この機能では自動レプリケーションがサポートされています。

  2. 共有リソースの移動 : この作業では、BizTalk メッセージ管理データベースから対応する情報を収集して、それらを保存し、ターゲット サーバーに送信することが必要になります。この機能では、自動レプリケーションはサポートされていません。

共有リソースを移動するにあたっては、移動元サーバー上の Application Center (ならびに BizTalk Server レプリケーション ドライバ) は、BizTalk メッセージ構成オブジェクト モデルを使用して、BizTalk メッセージ管理データベースにアクセスします。直接 SQL Server データベースからデータを読み込むのではありません。この方法によって、将来 BizTalk Server の構成が変更されても対応可能になり、また、オブジェクト モデルの制約も遵守することになります。

以下に 3 つのシステム構成のシナリオと、そこでの共有情報の転送処理を示します。

Two clusters that share the same configuration database.

この図には、2 つのクラスタが示されています。クラスタ内の各メンバは同じ BizTalk メッセージ管理データベースを参照します。したがって、いずれかのクラスタ内のメンバどうしでデータを同期するときには、構成情報を転送する必要がありません。しかし、アプリケーションを展開するときには、それぞれのクラスタが独自の BizTalk メッセージ管理データベースを持っているため構成情報を転送する必要があります。

Clusters that share one BizTalk Messaging Management database

上の図は、BizTalk メッセージ管理データベースを共有するクラスタ内にアプリケーションを展開する方法を示しています。このシナリオでは、クラスタ外への展開でも共有リソースの転送は必要ありません。

Clusters that use different BizTalk Messaging Management databases

この図では、クラスタ内の各メンバが異なる BizTalk メッセージ管理データベースを使用しています。各クラスタ メンバに対して複数のデータベースが存在するため、すべての同期処理でそれぞれの BizTalk メッセージ管理データベースのローカル情報と共有情報の転送が必要になる可能性があります。

重要

  • 最後のシナリオは、現在のバージョンの Application Center と BizTalk Server ではサポートされていません。しかし、このシステム構成も正しく機能するはずであり、アプリケーションの展開が可能です。

どのようなシステム構成のシナリオを利用しているかに関係なく、データベース間での共有情報の転送には次の手順が当てはまります。

  1. ソース サーバーにある BizTalk Server レプリケーション ドライバは、どのデータの更新が必要かを決定するため、ソース サーバーにある共有リソースの名前を含む要求をターゲット データベースに送信します。

  2. ソース サーバーにあるレプリケーション ドライバは、共有リソースの同期に必要な追加、更新、削除の情報を含むアクション リストを返します。

  3. ソース サーバーは、BizTalk メッセージ構成オブジェクト モデルを使用してデータベースから情報を読み取り、転送に必要な項目の構成 XML を作成します。

  4. ソース サーバーの BizTalk Server レプリケーション ドライバは、Application Center ファイル システム レプリケーション ドライバに構成 XML を渡し、ターゲット サーバーへの転送を依頼します。

  5. ソース サーバーの Application Center ファイル システム レプリケーション ドライバは、ターゲット サーバーに、適用すべき変更項目を含む更新一覧を送信します。この一覧には、ターゲット サーバーに伝える構成 XML への参照が含まれます。この一覧には、送信先サーバーに伝える目録への参照が含まれます。

  6. 送信先サーバーでは、BizTalk Server レプリケーション ドライバが 構成 XML を読み取り、対応する BizTalk メッセージ管理データベースに適切な変更を行います。

新規または既存アプリケーションを展開する基本手順は次のようになります。

  1. 必要に応じて、展開元のコンピュータと展開先のコンピュータでクラスタを編成します。また、BizTalk Server グループに対応する Application Center クラスタの定義と、このクラスタのコントローラとなるコンピュータを定義する必要があります。

  2. Application Center で新しいアプリケーションを作成するか、または既存アプリケーションを選択します。

  3. BizTalk リソースと、ファイル、COM+ アプリケーション、レジストリ キーなどのそのほかのリソースを必要に応じて追加します。

  4. アプリケーションをソース コンピュータからターゲット コンピュータに展開します。

ここには次のトピックが含まれます。

  • クラスタについて

  • 新しいアプリケーションの作成

  • リソースの追加

  • アプリケーションの展開


クラスタについて

Microsoft Application Center を使用すると、複数のクラスタを 1 台のコンピュータから管理することができます。Application Center を使用することで、次の作業が可能です。

  • クラスタの作成

  • 既存クラスタへの参加

  • クラスタへのメンバの追加と削除

  • 新しいコンテンツの展開

  • 負荷分散の構成

  • クラスタのパフォーマンスの監視

さらに、クラスタにインストールされているコンテンツの統一された単一のイメージを提供します。こうしたコンテンツの管理を行うため、Application Center では、新規クラスタウィザードなどのクラスタの作成と管理、およびコンテンツの展開手順を簡素化するウィザードが提供されています。

Application Center クラスタは、企業のイントラネットのクライアントやインターネット外部のクライアントへサービスを提供できます。クライアント ソフトウェアには、軽量クライアント (Web ブラウザなど) や本格的なクライアント アプリケーション (Microsoft Visual Basic プログラムなど) を利用できます。Application Center クラスタは、HTTP クライアントにサービスを提供する Web 層と、DCOM (Distributed Component Object Model) のトラフィックを処理するビジネス ロジック層の両方を管理できるように設計されています。

重要

  • Microsoft Application Center は Microsoft® Windows® 認証を使用して、Application Center クラスタから BizTalk メッセージ管理データベース (InterchangeBTM) にアクセスします。Application Center クラスタから BizTalk メッセージ管理データベース (InterchangeBTM) にアクセスするには、BizTalk メッセージ管理データベースが Application Center クラスタ コントローラ上に存在するか、または Application Center クラスタの外部に存在する必要があります。BizTalk メッセージ管理データベースが Application Center クラスタの外部にある場合には、Application Center ドライバでエラーが発生しないように、リモートの SQL Server にローカル システム アカウントを追加する必要があります。BizTalk メッセージ管理データベースが入っている SQL Server が、Application Center クラスタのメンバにあり、クラスタ コントローラにない場合、この BizTalk メッセージ管理データベースにアクセスすることができない場合があります。SQL Server のログイン アカウントの追加方法については、「SQL Server と BizTalk Server 2002 データベース間の相互作用」の「リモートにある SQL Server のログイン アカウント」を参照してください。

注

  • Application Center は、スタンド アロン (非クラスタ) サーバーや Web サイトを実行していないサーバーでの可用性の向上やアプリケーションの展開にも使用することができます。この場合、Application Center は、スタンドアロン サーバーを 1 台で構成されたクラスタとして扱います。


新しいアプリケーションの作成

Microsoft Application Center においては、アプリケーションとはクラスタ内で同期する、またはクラスタに展開するリソースを一覧にした構成 XML の事を指します。アプリケーションは、リソースへの参照の一覧を持つことでリソースを所有します。したがって、複数のアプリケーションが同じリソースの一覧を持つことができます。Application Center アプリケーションを同期または展開するときには、アプリケーションが一覧として持つリソースも同期または展開されます。

新規に Application Center アプリケーションを作成することにより、BizTalk リソースなどのリソースの同期と展開を管理できます。新規 Application Center アプリケーションの作成については、Application Server 2000 のヘルプを参照してください。このようにアプリケーションを使用することによって、同期または展開するリソースの指定や、そのタイミングをより詳細に管理できます。さらに、既定のアプリケーションのサブセットの一覧を持つアプリケーションや、既定のアプリケーションの一覧にないリソースを持つアプリケーションを作成することができます。


リソースの追加

Microsoft Application Center を使用することによって、リソースをアプリケーションに追加することができます。BizTalk リソースは、一意的な名前と一連のプロパティを持つオブジェクトと見なすことができます。ポート、ポート グループ、カスタム カウンタ、受信機能などの BizTalk リソースは、Microsoft BizTalk Server を利用する特定のアプリケーションの構成を表しています。展開するアプリケーションに関連付けるリソースを指定します。

重要

  • リソース名には、プラス記号 (+) を使用することはできません。これは、サーバー上では .asp ファイルの中で空白に変換されるためです。たとえば、"BizTalkorg+port" は "BizTalkorg port" に変換されます。リソース名にプラス記号を含んだアプリケーションを展開しても、構成 XML は生成されず、ファイルは送信されません。しかし、Application Center はアプリケーションが正しく展開されたと通知します。名前にプラス記号を含んだリソースがある場合には、クライアント コンピュータで、プラス記号を %2B に置き換えてください。

次の表では、アプリケーションに追加できる BizTalk リソースの種類と、自動的に追加されるアイテムについて説明します。

BizTalk リソース 自動的に追加されるアイテム 注
ポート すべての関連するアイテム。
  • チャネル

  • ドキュメント定義

  • 組織

  • エンベロープ
  • ポートにリンクされているすべての要素が展開されます。ただし、ドキュメントやエンベロープなどのバインドされていないアイテムは自動的に移動されません。この例の中には、受信したフラット ファイルの解析に使うエンベロープやエンベロープのドキュメント、および受信確認の解析に使用するドキュメントなどが含まれます。
ポート グループ

(同報リスト)

 グループ内のすべてのポート。

ポート グループの各ポートに追加されたすべてのアイテム。
  • ポート グループにリンクされたすべての要素が展開されます。ただし、ドキュメントやエンベロープなどのバインドされていないアイテムは自動的に移動されません。この例の中には、受信したフラット ファイルの解析に使うエンベロープやエンベロープのドキュメント、および受信確認の解析に使用するドキュメントなどが含まれます。
受信機能 追加されるアイテムはありません。
  • 必要に応じて、受信機能が使用するファイル システム リソースを手動で追加したり、移動先のサーバーにメッセージ キュー (MSMQ とも呼びます) を作成する必要があります。
カスタム カウンタ 追加されるアイテムはありません。
  • カスタム カウンタに関しては、プロパティや制限についてさまざま考慮しなければならない点があります。詳細については、「カスタム カウンタ」、「WMI を使用するカスタム カウンタの作成」、および「カスタム カウンタのクエリ プロパティ」を参照してください。

Application Center では、BizTalk リソースのほかにも、次のリソースを追加できます。

  • ファイル システム パス

  • レジストリ キー

  • Web サイトと仮想ディレクトリ

  • COM+ アプリケーション

  • データ ソース

ファイル システム パス

ファイル システム フォルダのレプリケーションを表示します。たとえば、ファイル システム パス リソースは、XLANG スケジュールの展開や、受信機能やファイル トランスポートが使用するディレクトリの展開に使用することができます。

重要

  • 展開するアプリケーションに XLANG スケジュール (.skx ファイル) を追加するには、ファイル システム パス リソースを使う必要があります。XLANG スケジュールは、これを実行するコンピュータ上に格納する必要があります。

レジストリ キー

レジストリへのアクセスに使います。クラスタ間の全レジストリを同期すると、クラスタ メンバに重大な競合がおこる可能性があります。したがって、これはお勧めできません。

Web サイトと仮想ディレクトリ

インターネット インフォメーション サービス (IIS) の利用可能な Web サイトと仮想ディレクトリの一覧を提供します。この一覧には、ファイル、証明書、証明書信頼リスト、およびサイトまたは仮想ディレクトリによって参照される ISAPI フィルタも含まれます。このリソースを指定すると、追加する必要があるのは Web サイトと仮想ディレクトリだけになります。Web サイトや仮想ディレクトリを構成する物理ディレクトリやファイルを明示的に指定する必要はありません。たとえば、HTTP 受信機能や取引先の応答先となる Web サイトなどがこれにあてはまります。

注

  • Application Center は、ローカル ファイル システム上に指定されたリソースだけを同期し、UNC パスで指定されたリソースやリムーバブル メディア上のリソースは同期しません。

COM+ アプリケーション

利用可能なすべての COM+ アプリケーション、プロキシ、コンポーネントを表示します。このリソースを使用することによって、アプリケーション統合コンポーネント (AIC) やスケジュール内のコンポーネント (COM+ アプリケーションに限る) を移動できます。詳細については、Application Center 2000 のヘルプを参照してください。

重要

  • 展開するアプリケーションの XLANG スケジュールとバインドされた COM+ アプリケーションを追加するには、COM+ アプリケーション リソースを使用する必要があります。

  • COM+ アプリケーションは、それを実行するコンピュータ上に、ローカル サーバー上のコンポーネント サービスとともに適切に登録された場合のみ、追加することができます。Application Center スナップインに COM+ アプリケーションが表示されない場合には、その COM+ アプリケーションは Application Center のアプリケーションに追加できません。COM コンポーネントをアプリケーションの一覧に追加するには、その COM コンポーネントを COM+ アプリケーションにインストールする必要があります。

データ ソース

利用可能なシステムのデータ ソース名 (DSN) を指定します。アプリケーションに追加できるのは、ローカル サーバーの DSN だけです。リモート サーバーにある DSN は、ローカル サーバーに作成しない限り利用できません。


アプリケーションの展開

展開とは、元の Microsoft Application Center アプリケーションのイメージを、あるクラスタからほかのクラスタにコピーする処理を言います。通常、展開は準備用のクラスタから実際に使用されるコンテンツを持つ運用クラスタに対して行います。展開時、アプリケーションのイメージは、スポークのクラスタのクラスタ コントローラにコピーされます。

ここには次のトピックが含まれます。

  • 展開の計画

  • 展開前のチェックリスト

  • 展開後のチェックリスト

  • 展開またはレプリケートされないアイテム

  • BizTalk リソースの同期


展開の計画

アプリケーションを展開する前に、BizTalk アプリケーションを構成するリソースを確認します。リソースには次のようなものがあります。

  • 構成情報 (BizTalk メッセージ管理データベースに格納されています)。これには次のようなものがあります。
    • ポート (関連するチャネル、ドキュメント定義、エンベロープ、組織も自動的に含まれます)

    • 同報リスト

    • 受信機能

    • カスタム カウンタ
  • 外部コンポーネント。これには次のようなものがあります。
    • ファイル

    • レジストリ キー

    • アプリケーション統合コンポーネント (AIC)

    • 証明書

    • メッセージ キュー (MSMQ)

    • XLANG スケジュール (.skx ファイル)

    • カスタム コンポーネント (暗号化、エンコード、シリアライズ)

リソースを確認したら、それらを Application Center アプリケーションとしてグループ分けします。


展開前のチェックリスト

BizTalk リソースのアプリケーションを展開する前に、次の項目について対処されているかを確認します。

ソース クラスタ

  • BizTalk メッセージ管理データベースにアクセスできることを確認します。

  • WebDAV リポジトリにアクセスできることを確認します。

  • トランスポート アドレスのような変数の自動マッピングは使用しません。これは、この種類の変数が環境によって異なるためです。トランスポート アドレスは手動で変更する必要があります。

  • XLANG スケジュール (.skx ファイル) は、アプリケーションを展開するクラスタに直接コピーする必要があります。

  • すぐにキャッシュを展開する必要がある場合には、アプリケーションを展開する前または後にサービスの開始と停止を完了しておく必要があります。詳細については、「グループ内のサーバーの起動」または「グループ内のサーバーの停止」を参照してください。サーバーの更新間隔を調整する方法については、「サーバー グループの全般プロパティの構成」を参照してください。

  • BizTalk リソースを含んだ展開済みのアプリケーションを更新する前に、すべての長時間トランザクションが終了していることを確認します。

ターゲット クラスタ

  • BizTalk メッセージ管理データベースにアクセスできることを確認します。

  • SMTP (Simple Mail Transfer Protocol) ホストが、各 BizTalk Server グループ、および信頼できるメッセージの返信先 URL に設定されていることを確認します。BizTalk Server 管理コンソールを使用します。

  • 必要な証明書が存在することを確認します。証明書は自動的に展開されません。

  • WebDAV リポジトリにアクセスできることを確認します。アクセスできない場合には、ドキュメント定義やエンベロープをレプリケートできない場合があります。

  • アプリケーション統合コンポーネント (AIC) をターゲット サーバーに登録します。

  • メッセージ キュー受信機能に必要なメッセージ キューを作成します。

  • 処理サーバーを停止します。


展開後のチェックリスト

アプリケーションを展開し、ターゲット コンピュータに正しく追加されたら、展開作業を完了するため、いくつかの変更を手動で行う必要があります。ここでは、展開したアプリケーションに関連付けられているリソースごとに、確認の必要な項目を説明します。

データベース

展開が終了したら、ターゲット コンピュータでいくつかの細かな調整を行う必要があります。たとえば、アプリケーションが関連付けデータベースを使用している場合、この関連付けデータベースをターゲット コンピュータの SQL Server のインスタンスに手動でコピーする必要があります。この作業の詳細な手順については、「電子調達サンプル」の「事前セットアップ」の中の「データベースのアタッチ」を参照してください。また、SQL Server のデータ変換サービス (DTS) を使用することで、ターゲット コンピュータの SQL Server インスタンスにデータベースをエクスポートできます。

受信機能

アプリケーションが使用するすべての BizTalk 受信機能を有効にする必要があります。受信機能は、BizTalk Server 管理コンソールで有効にするか、BizTalk Server の Windows Management Instrumentation (WMI) プロバイダを使用したプログラムによって有効にすることができます。受信機能は手動で作成するメッセージ キューよりも前に作成されるため、この作業が必要となります。受信機能のポーリング場所 (ディレクトリなど) にアクセスできない場合、BizTalk Server は自動的に受信機能を無効にします。

受信機能の処理サーバーも更新しなければならない場合があります。それぞれの受信機能は、処理サーバーに関連付けられます。ソース クラスタにある処理サーバーの名前は、ターゲット サーバーの名前にマップされます。通常、マップされるサーバーは、ターゲット クラスタのクラスタ コントローラです。受信機能の処理サーバーは、BizTalk Server 管理コンソールか、WMI プロバイダを使用したプログラムによって更新できます。

ユーザー名とパスワードを使用するように構成された受信機能をレプリケートする場合、そのパスワードが存在しないため、受信機能は停止します。この問題を解決するには、各受信機能のプロパティ ページを開いて、パスワードを再入力し、受信機能を有効にする必要があります。

ポート

BizTalk ポートを含む Application Center アプリケーションを展開した場合、プライマリ ポートとセカンダリ ポートのアドレスが正しい場所を参照するように、ターゲット コンピュータのポートを更新する必要があります。たとえば、http://TestAURL を http://ProductionAURL のように変更する必要があるでしょう。Application Center が BizTalk Server の構成をあるコンピュータからほかのコンピュータに展開する際に、BizTalk のポートは変更しません。

注

  • これらの変更が適用されるためには、BizTalk のサービスを停止および開始しなければならない場合があります。BizTalk のサービスは、BizTalk Server 管理コンソールで停止および開始することができます。詳細については、「BizTalk サービスの開始」と「BizTalk サービスの停止」を参照してください。

処理サーバー

アプリケーションを展開した後で、処理サーバーを起動する必要があります。


展開またはレプリケートされないアイテム

ポートにバインドされていないドキュメントとエンベロープは展開されません。この例の中には、受信したフラット ファイルの解析に使うエンベロープやエンベロープのドキュメント、および受信確認の解析に使用するドキュメントなどが含まれます。ポートとチャネルが暗号化、暗号解読、署名で使用する証明書はレプリケートされません。これらは、アプリケーションを展開するクラスタに直接コピーする必要があります。これは、証明書など、そのほかのレプリケートされないオブジェクトについても同じです。

アプリケーションを展開するにあたって、レプリケートされないオブジェクトは、ターゲット サーバーに事前に置いておく必要があります。たとえば、あるアプリケーション統合コンポーネント (AIC) を使用するチャネルがあり、そのチャネルを含む Application Center アプリケーションを展開する場合、この AIC を参照するチャネルが作成される前に、この AIC を含む COM+ アプリケーションが作成される保証はありません。

受信機能のファイル階層、およびメッセージ キューにおけるキューもレプリケートされません。これは、受信機能およびメッセージ キューにおけるキューが、特定の BizTalk Server の処理サーバーに関連付けられていて、これらの処理サーバーが名前で識別されるためです。たとえば、テスト環境でコンピュータ Test1 と Test2 に関連付けられている受信機能 R1 と R2 は、運用環境では、コンピュータ ProdA と ProdB に関連付ける必要があるでしょう。スケジュールにバインドされたメッセージ キューは、アプリケーションを展開するクラスタに直接コピーする必要があります。


BizTalk リソースの同期

BizTalk のリソースは、そのほかの Application Center のリソースと違って自動的に同期されません。したがって、既に展開された Application Center アプリケーションの BizTalk リソースを変更した場合、Application Center アプリケーションを再度展開する必要があります。BizTalk リソースを含む Application Center アプリケーションの展開方法については、「ターゲット サーバーへの Application Center アプリケーションの展開」を参照してください。


BizTalk Server の展開に関する作業を行う目的

ここでは、BizTalk Server の展開に関する作業を行う目的についてのクイック リファレンスを示します。次の表は、主要な作業とそれらに付随する作業を示しており、各作業の目的と対応する手順へのリンクを明記しています。

作業 作業を実行する目的
  • BizTalk リソースを含む Application Center アプリケーションの作成
 ポート、アプリケーション統合コンポーネント (AIC)、XLANG スケジュール、および BizTalk アプリケーションを展開可能なユニットにするそのほかのリソースなどの BizTalk の構成情報を論理的にグループ化する場合。
  • ターゲット サーバーへの Application Center アプリケーションの展開
 新規に開発した BizTalk アプリケーションを、開発環境からテスト環境や運用環境に移動する場合。
  • ターゲット サーバーからの BizTalk リソースの削除
 未使用のリソースや古いリソースを削除する場合。


BizTalk Server の展開に関する作業方法

ここでは、新規 Application Center アプリケーションの作成、BizTalk リソースを含む既存の Application Center アプリケーションの変更、およびターゲット コンピュータへの Applicaiton Center アプリケーションの展開について作業ごとに説明します。

ここには次のトピックが含まれます。

  • BizTalk リソースを含む Application Center アプリケーションの作成

  • ターゲット サーバーへの Application Center アプリケーションの展開

  • ターゲット サーバーからの BizTalk リソースの削除


BizTalk リソースを含む Application Center アプリケーションの作成

リソースの展開は、リソースを含むフォルダ単位で追加するのではなく、それぞれのリソースを個別に展開することを推奨します。フォルダを選択する方法でリソースを展開し、後からリソースの 1 つを削除することが必要になった場合、ターゲット のコンピュータからすべてのリソースを完全に削除する必要があります。リソースの削除については、「ターゲット サーバーからの BizTalk リソースの削除」を参照してください。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[Application Center] をクリックします。

    Microsoft Application Center 2000 が開きます。

  2. [Application Center] を展開し、Application Center アプリケーションを追加するクラスタを展開して、［アプリケーション］ をクリックします。

  3. [アプリケーション] ペインで、[新規] をクリックします。または、[名前] 列で既存の Applicaiton Center アプリケーションを選択することもできます。

    [新しいアプリケーションを作成します - Web ページ ダイアログ] ダイアログ ボックスが表示されます。

  4. [名前] ボックスに作成する Application Center アプリケーションの名前を入力して、[OK] をクリックします。

    作成した Application Center アプリケーションの名前が、[アプリケーション] ペインの [名前] 列に表示されます。

  5. 作成した Application Center アプリケーションを選択し、BizTalk リソースを追加するため [コンテンツ] ペインの [リソース タイプ] の一覧から [BizTalk] をクリックし、次に [追加] をクリックします。

    [リソースの追加 - Web ページ ダイアログ] ダイアログ ボックスが表示されます。

  6. BizTalk のリソース タイプにすべてのリソースを追加するには、リソースの種類を選択して [追加] をクリックします。リソースを個別に選択するには、追加するリソース (BizTalkCustomCounters、BizTalkPortGroups、BizTalkPorts、または BizTalkReceiveFunctions) をダブルクリックします。

    [リソースの追加 - Web ページ ダイアログ] ダイアログ ボックスが表示されます。

    注

    • BizTalk メッセージ マネージャの同報リストは BizTalkPortGroups リソース タイプに相当します。
  7. 追加するリソースを選択し、[追加] をクリックします。

  8. 必要なリソースをすべて追加するまで、手順 6. ～ 7. を繰り返します。リソースを個別に追加している場合は、必要なリソースをすべて追加した後に [閉じる] をクリックします。

  9. XLANG スケジュールを追加するには、[コンテンツ] ペインの [リソース タイプ] の一覧で [ファイル システム パス] をクリックします。

    [リソースの追加 - Web ページ ダイアログ] ダイアログ ボックスが表示されます。

  10. スケジュール ファイルの場所に移動して、ファイルを選択し、[追加] をクリックします。必要なスケジュール ファイルをすべて追加するまでこの手順を繰り返し、[閉じる] をクリックします。


ターゲット サーバーへの Application Center アプリケーションの展開

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[Application Center] をクリックします。

    Microsoft Application Center 2000 が開きます。

  2. [Application Center] を展開し、展開する Application Center アプリケーションが含まれているクラスタを右クリックして、［新規展開］ をクリックします。

    [新規展開ウィザード] が表示されます。

  3. [次へ] をクリックします。

  4. [展開ターゲットのオプション] ページで、[展開の名前] ボックスに名前を入力するか、既定の名前をそのまま使用します。

  5. [コンテンツを現在のクラスタの外で展開する] をクリックして、[次へ] をクリックします。

  6. [展開ターゲットの認証] ページで、[ユーザー名]、[パスワード]、および [ドメイン] ボックスに適切な資格情報を入力して、[次へ] をクリックします。

  7. [展開のターゲット] ページの [ターゲット] ボックスに、Application Center アプリケーションを展開するコンピュータ名を入力します。または、[参照] をクリックしてそのコンピュータの位置を参照します。

    注

    • BizTalk リソースは、Application Center コントローラだけに展開します。
  8. [追加] をクリックします。

  9. [コンテンツの展開] ページで、[すべてのアプリケーションと関連するクラスタの構成を展開する] または [1 つ以上のアプリケーションを展開する] のいずれかをクリックします。

    [1 つ以上のアプリケーションを展開する] オプションをクリックした場合は、展開する Application Center アプリケーションを一覧から選択します。複数のアイテムを選択するには、Ctrl キーを押したまま各アイテムをクリックします。

  10. [次へ] をクリックします。

  11. [展開のオプション] ページで適切なチェック ボックスをオンにします。必要に応じて、[フォルダとファイルのアクセス許可を展開する (NTFS のみ)] チェック ボックスをオフにします。

  12. [次へ] をクリックします。

  13. [新規展開ウィザードの完了] ページで [完了] をクリックします。

重要

  • ユーザー名とパスワードを使用するように構成された受信機能をレプリケートする場合、そのパスワードが存在しないため、受信機能は停止します。パスワードは再入力する必要があります。セキュリティ維持のため BizTalk Server レプリケーション ドライバはパスワードをレプリケートしません。この問題を解決するには、各受信機能のプロパティ ページを開いて、パスワードを再入力し、受信機能を有効にする必要があります。


ターゲット サーバーからの BizTalk リソースの削除

既に Application Center アプリケーションをターゲット サーバーに展開済みで、その Application Center アプリケーションに関連付けられたリソースを削除する場合には、次の手順に従います。

  1. ターゲット コンピュータから削除しようとするリソースを個別に追加して、アプリケーションを展開します。詳細については、「ターゲット サーバーへの Application Center アプリケーションの展開」を参照してください。

  2. BizTalk リソースを Application Center アプリケーションを展開するために使用していたコンピュータから削除します。次の表は、特定のリソースを削除するために使用するツールの一覧です。
    削除するリソース | 使用するツール | 関連情報
    BizTalkPortGroups リソース (同報リスト) | BizTalk メッセージ マネージャまたは BizTalk メッセージ構成オブジェクト モデル (Microsoft Visual Basic Scripting Edition (VBScript) にてアクセス可能) | 詳細については、「同報リストの削除」を参照してください。
    BizTalkPorts リソース | BizTalk メッセージ マネージャまたは BizTalk メッセージ構成オブジェクト モデル (VBScript にてアクセス可能) | 詳細については、「メッセージ ポートの削除」を参照してください。
    BizTalkReceiveFunctions リソース | BizTalk Server 管理コンソールまたは BizTalk Server の Windows Management Instrumentation (WMI) プロバイダ (VBScript にてアクセス可能) | 詳細については、「受信機能の削除」を参照してください。
    スケジュール ファイル リソース | Windows エクスプローラ | 詳細については、Windows 2000 のヘルプを参照してください。
    BizTalkCustomCounters リソース | BizTalk Server 管理コンソールまたは BizTalk Server の WMI プロバイダ | なし。

  3. ターゲット コンピュータから削除するリソースを含む Application Center アプリケーションを再度展開します。詳細については、「ターゲット サーバーへの Application Center アプリケーションの展開」を参照してください。


BizTalk Server の展開のトラブルシューティング

ここでは、BizTalk リソースを含む Microsoft Application Center 2000 アプリケーションの展開に関連するトラブルシューティングについて説明します。Application Center アプリケーションの展開で問題が発生した場合には、まずここで解決策を探してください。

ここには次のトピックが含まれます。

  • 展開済み Application Center アプリケーションには更新されたリソースが必要

  • エラー メッセージに管理権限を持つ資格情報が必要と表示される


展開済み Application Center アプリケーションには更新されたリソースが必要

原因 : Application Center アプリケーションの一部として展開された BizTalk ドキュメントの Web Distributed Authoring and Versioning (WebDAV) リポジトリ参照 URL またはファイル名 (BizTalk メッセージ マネージャの [新しいドキュメント定義] タブを参照) が変更されています。

解決策 : リソースをターゲット コンピュータから削除し、Application Center アプリケーションを再度展開します。そのためには、次の操作を行います。

  1. Application Center アプリケーションを展開するために使用していたコンピュータから、リソースを削除します。次の表は、特定のリソースを削除するために使用するツールの一覧です。
    削除するリソース | 使用するツール | 関連情報
    BizTalkPortGroups リソース (同報リスト) | BizTalk メッセージ マネージャまたは BizTalk メッセージ構成オブジェクト モデル (Microsoft Visual Basic Scripting Edition (VBScript) にてアクセス可能) | 詳細については、「同報リストの削除」を参照してください。
    BizTalkPorts リソース | BizTalk メッセージ マネージャまたは BizTalk メッセージ構成オブジェクト モデル (VBScript にてアクセス可能) | 詳細については、「メッセージ ポートの削除」を参照してください。
    BizTalkReceiveFunctions リソース | BizTalk Server 管理コンソールまたは BizTalk Server の Windows Management Instrumentation (WMI) プロバイダ (VBScript にてアクセス可能) | 詳細については、「受信機能の削除」を参照してください。
    スケジュール ファイル リソース | Windows エクスプローラ | 詳細については、Windows 2000 のヘルプを参照してください。
    BizTalkCustomCounters リソース | BizTalk Server 管理コンソールまたは BizTalk Server の WMI プロバイダ | なし。

  2. Application Center アプリケーションを再度展開します。詳細については、「ターゲット サーバーへの Application Center アプリケーションの展開」を参照してください。

  3. ドキュメントの WebDAV リポジトリ参照 URL またはファイル名を変更します。

  4. ドキュメントのポートとチャネルを作成します。詳細については、「メッセージ ポートの作成」および「チャネルの作成」を参照してください。

  5. 変更したドキュメントを含む Application Center アプリケーションを再度展開します。詳細については、「ターゲット サーバーへの Application Center アプリケーションの展開」を参照してください。


エラー メッセージに管理権限を持つ資格情報が必要と表示される

原因 : BizTalk リソース を含む Application Center アプリケーションをほかのコンピュータ (ターゲット サーバー) に展開しているときに、管理権限を持つ資格情報が必要というエラー メッセージが通知されます。ターゲット クラスタのコントローラのイベント ログにエラー メッセージが表示されます。

解決策 : ターゲット サーバーの BizTalk Server の管理者特権を構成し、再度 Application Center アプリケーションを展開します。

注

  • ユーザーは BizTalk Server Administrators グループの管理者としての特権は必要としませんが、ターゲット サーバーの管理者としての特権は必要とします。


BizTalk オーケストレーションの設計

Microsoft® BizTalk™ オーケストレーション デザイナは Microsoft Visio® 2000 を基にした設計ツールで、XLANG スケジュールとしてコンパイルおよび実行できるビジネス プロセス フローチャートを作成できます。XLANG は XML を基にした言語です。 XLANG スケジュールには、ビジネス プロセスおよびそのプロセスのアプリケーション サービスへのバインドを記述します。

BizTalk オーケストレーション デザイナを使用すると、疎結合、長時間実行可能なビジネス プロセスを記述するフローチャートを作成することができます。一般的に、フローチャートには、注文要求などの特定のプロセスを完了する間に実行される対話や手順を記述します。通常、ビジネス プロセスには時間の制限がありません。また、ビジネス プロセス内のステップ間は疎結合されています。ビジネス プロセスの記述は、プロセスを実行するために使用される実装ロジックとシーケンスから切り離されています。

ここには次のトピックが含まれます。

  • BizTalk オーケストレーション デザイナの詳細については、「BizTalk オーケストレーション デザイナについて」を参照してください。

  • 特定の作業を実行する理由については、「BizTalk オーケストレーション デザイナに関する作業を行う目的」を参照してください。

  • 作業を実行する手順の詳細については、「BizTalk オーケストレーション デザイナに関する作業を行う方法」を参照してください。


BizTalk オーケストレーション デザイナについて

ここでは、BizTalk オーケストレーション デザイナを理解するうえで不可欠な概念について説明します。ここには次のトピックが含まれます。

  • BizTalk オーケストレーション サービス

  • XLANG スケジュール フローチャートの作成

  • XLANG スケジュールのコンパイル

  • XLANG スケジュールのデバッグ

  • XLANG スケジュールの実行 (概念)

  • XLANG スケジュールのプール

  • セッション ステータスの管理

  • XLANG スケジュールの更新

注

  • 「BizTalk オーケストレーション デザイナに関する作業を行う方法」を参照し、BizTalk オーケストレーション デザイナの作業ごとの使用方法について十分に理解しておいてください。


BizTalk オーケストレーション サービス

BizTalk オーケストレーション サービスは、確立された情報交換テクノロジの機能をさらに拡張します。これによって、ビジネス プロセスを詳細な表現で作成し、統合された設計環境でソフトウェア的な実装をすることができます。

ビジネス プロセスの設計と実装は、これまで、図式を利用した設計フェーズとコーディング フェーズの 2 つの異なるフェーズで実行されていました。一般的に、図式を利用した設計フェーズでは、既存のビジネス プロセス (調達など) を分析し、プロセスを記述するワークフロー ダイアグラムまたは相互関係ダイアグラムを作成します。通常、コーディング フェーズは別に進められます。ここでは、図式を利用した抽象的なビジネス プロセスのモデルを構築し、そのモデルを実装フレームワークにマップします。

BizTalk オーケストレーションの重要な機能の 1 つに、今まで別々になっていたこれらのフェーズを 1 つの設計環境に統合する機能があります。この設計環境では、柔軟性の高いフローチャート作成機能と、多機能な実装ツールのセットを提供します。BizTalk オーケストレーションで、次の操作ができます。

  • ビジネス プロセスを実現する XLANG スケジュール フローチャートを作成できます。

  • フローチャートの特定のアクションを、メッセージを送受信する場所を表すポートに接続することによって、ビジネス プロセスを実装できます。ポートとは、名前付きの場所です。メッセージとは、アクションとポートの間で送受信されるデータを表します。

  • ビジネス プロセスのメッセージ間のデータのフローを定義できます。

  • XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルできます。XLANG スケジュールとは、フローチャートに含まれる情報を実行可能な Extensible Markup Language (XML) で表現したものです。

設計と実装を統合する機能のほかに、BizTalk オーケストレーションは重要な追加機能を提供します。この機能により、複数の組織、プラットフォーム、およびアプリケーションにまたがって、堅固な、疎結合、長時間ビジネス プロセスを作成できます。非同期で疎結合、長時間ビジネス プロセスでは、たとえば、インターネットで注文された製品を在庫部品から組み立てる必要があるとして、これらの部品は、たまたま在庫切れになっている可能性もあり、ビジネス プロセス全体が完了するまでに、数週間から数か月かかることもあります。これに対して、密結合ビジネス プロセスでは、メッセージの交換が同期されます。たとえば、銀行口座から現金を引き出すと、口座の借方に記入された直後に現金が支払われます。

BizTalk オーケストレーションで、次の操作ができます。

  • 図式を利用した表現で長時間ビジネス プロセスを作成できます。

  • 図式を利用して表現したアクションを特定のテクノロジで実装したポートに接続することにより、メッセージの交換を容易にします。

  • 完了したフローチャートを実行可能な XML 表現のフローチャートにコンパイルできます。

  • 完了までに数週間から数か月を要する可能性があるビジネス プロセスを確実に実行できます。

ここには次のトピックが含まれます。

  • ビジネス プロセスについて

  • BizTalk オーケストレーション デザイナの環境

  • XLANG スケジュール

関連項目

XLANG スケジュール フローチャートの作成

ビジネス プロセスについて


ビジネス プロセスについて

製造業にとって組み立てラインが重要であるように、ビジネス プロセスはビジネス管理にとって重要です。明確な一定形式のプロセスのセットに従うことによって、あらゆるビジネスで生産性を向上させ、コストを軽減することができます。ビジネス プロセスでは、各業務のすべての担当者間でメッセージ交換のプロトコルを定義します。ビジネス プロセスを定義するには、アクションの論理的な順序と、それに対応するメッセージのフローを決定する必要があります。ビジネス プロセスでは、これらのアクションを実行する各業務の担当者は定義しません。

一般的に、長時間ビジネス プロセスの一連の手順は非同期です。各手順は、独立した 1 人または複数の担当者が実行できるアクションです。これらのアクション間では、関連する作業を実行している、していないに関わらず、担当者間でメッセージを送受信することになります。各業務の担当者は、入力に対して応答する自動化されたプロセスであったり、完全に別のビジネス プロセスであったりします。ビジネス プロセスを理解するには、複雑で多様な相関関係や依存関係を図式を利用して目に見えるようにする必要があります。このような関係を目に見えるよう記述するために、ワークフロー ダイアグラムや相互関係ダイアグラムなどのビジネス プロセスをモデル化するツールが開発されています。

ここには次のトピックが含まれます。

  • ワークフロー ダイアグラム

  • 相互関係ダイアグラム


ワークフロー ダイアグラム

ワークフローは、組織内の手順を自動化し、向上させるビジネス プロセスの設計テクノロジです。これは、プロジェクトの完了に必要な手順、強固な依存関係、取らなければならない承認を描画するときに役立つテクノロジです。ワークフロー アプリケーションを使用して、作業を担当者に割り当て、個々の責任を定義し、担当者間の関係を表すことができます。また、ワークフロー アプリケーションを使用して、プロジェクトの完了や目標達成の期限を設定することもできます。しかし一般的に、ワークフロー テクノロジは高度に集中化されています。担当者には作業が割り当てられ、期限が指定されますが、ワークフロー エンジンは、ある担当者から次の担当者へと完了した作業項目の経路を選定し、スケジュールを進める責任があります。これに対して、BizTalk オーケストレーションの裁量範囲はもっと広く、担当者には自主性があり、ある担当者から別の担当者に作業項目の経路を選定する責任は、集中化されたアプリケーションではなく各担当者が決定します。

関連項目

相互関係ダイアグラム

ビジネス プロセスについて


相互関係ダイアグラム

相互関係ダイアグラムは、ビジネス プロセス内のデータ フローと、交換されるメッセージを表します。BizTalk オーケストレーションは、相互関係ダイアグラムに含めることができない、判断、同時実行アクション、トランザクション、補助的なアクションに対する定義と制御を提供することで、相互関係ダイアグラムの概念を拡張します。BizTalk オーケストレーションを使用してビジネス プロセスを設計すると、コンパイルされ、実行可能なビジネス プロセス (XLANG スケジュール) ができます。これに対して、相互関係ダイアグラムはビジネス プロセスの静的な表現です。

次の図は、一般的な自動化された調達システムの相互関係ダイアグラムを示しています。

関連項目

ビジネス プロセスについて

ワークフロー ダイアグラム


BizTalk オーケストレーション デザイナの環境

BizTalk オーケストレーション デザイナを使用して XLANG スケジュール フローチャートを作成できます。XLANG スケジュール フローチャートとは、ビジネス プロセスを表現したものです。XLANG スケジュール フローチャートは、Microsoft Visio 2000 のファイル形式をカスタマイズした .skv ファイルとして保存されます。その後で、XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルできます。XLANG スケジュールは、XLANG スケジューラ エンジンが理解できる XML 構造の .skx テキスト ファイルです。BizTalk オーケストレーション デザイナでは、次の特徴を含む XLANG スケジュール フローチャートを作成できます。

  • 視覚的なビジネス プロセスの記述 : この XLANG スケジュール フローチャートの一面は、ワークフロー ダイアグラムまたは相互関係ダイアグラムに似ています。

  • 視覚的な構成可能ポートの表現 : これは、XLANG スケジュール フローチャートの実装面です。

  • 視覚的なシェイプ間の接続の表現 : ビジネス プロセスのプロセス フローを表現するために、フローチャート シェイプを接続できます。ビジネス プロセスの通信のフローを表現するために、アクションをポートに接続できます。

  • 指定したメッセージ フィールド間の視覚的なフローの表現 : このXLANG スケジュール フローチャートの特徴により、あるメッセージのメッセージ フィールドと別のメッセージのメッセージ フィールドとの関係を決めることができます。これらの関係を関連付けることにより、データ依存のルーティングを実行できます。

XLANG スケジュール フローチャートは、ビジネス プロセスで実行される手順を表現したものです。XLANG スケジュール フローチャートでは、次の項目を定義できます。

  • 取引先が使用することに同意したメッセージ交換プロトコル

  • アクション発生の論理的な順序が記述された、メッセージの送受信時に使用されるアクション

  • ポートの実装、およびリンクされるアクション

  • メッセージ フィールド間のデータ フロー

ここには次のトピックが含まれます。

  • 設計ページ

  • フローチャート シェイプ

  • 実装シェイプ

  • 通信シェイプ

  • BizTalk オーケストレーション デザイナのショートカット キー


設計ページ

BizTalk オーケストレーション デザイナには、アクセス可能な 4 つの設計ページがあります。これらの設計ページを使用して、XLANG スケジュール フローチャートをいろいろな角度から作成できます。

  • [ビジネス プロセス] ページ : このページでは、[フローチャート] シェイプと [実装] シェイプを使用して、ビジネス プロセスを定義できます。これらのシェイプの使用方法については、「フローチャート シェイプ」と「実装シェイプ」を参照してください。

  • [データ] ページ : このページでは、[通信] シェイプを使用して、メッセージ フィールド間のデータ フローを制御できます。これらのシェイプは、BizTalk オーケストレーション デザイナが自動的に作成します。これらのシェイプの使用方法については、「通信シェイプ」を参照してください。

  • [<トランザクション> の失敗時] ページ : このページでは、[フローチャート] シェイプと [実装] シェイプを使用して、障害が発生したトランザクションに対して代わりのビジネス プロセスを設計できます。

  • [<トランザクション> の補正] ページ ; このページでは、[フローチャート] シェイプと [実装] シェイプを使用して、コミットされたネストしたトランザクションを元に戻すプロセスを設計できます。トランザクションの詳細については、「トランザクションの設計」を参照してください。

関連項目

例外処理


フローチャート シェイプ

BizTalk オーケストレーション デザイナには、[フローチャート] ステンシルに、8 つのフローチャート シェイプがあります。これらのシェイプを使用して、ビジネス プロセスを表現します。[フローチャート] ステンシルの 8 つのシェイプを使用して、XLANG スケジュールの構造と意味を表現できます。XLANG は、ビジネス プロセスの操作を表現する XML ベースの言語です。

次の表は、フローチャート シェイプの一覧と説明を示しています。

シェイプ名 説明
開始

[開始] シェイプは、[フローチャート] ステンシルにはありません。削除することも、別の [開始] シェイプを作成することもできません。[開始] シェイプは、XLANG スケジュール フローチャートの開始を表します。[開始] シェイプは、[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページで自動的に作成されます。[ビジネス プロセス] ページに表示される [開始] シェイプには、設定可能なプロパティがあります。[<トランザクション> の補正] ページと [<トランザクション> の失敗時] ページに表示される [開始] シェイプには、設定可能なプロパティはありません。[開始] シェイプをトランザクションで囲むことはできません。ビジネス プロセスは、フローチャートの中で、[開始] シェイプから最初の [フローチャート] シェイプに向かって流れる必要があります。
アクション

[アクション] シェイプは、メッセージをポートから受信する、またはメッセージをポートに送信するプロセスを表します。送信アクションまたは受信アクションは、同期の場合も非同期の場合もあります。どちらになるかは、ポートがバインドされるコンポーネントまたは実装によって決まります。
判断

[判断] シェイプは、1 つ以上の条件を順番に評価するプロセスを表します。

このシェイプには、1 つの受信フローと 1 つ以上の送信フローがあります。各送信フローは、TRUE または FALSE と評価される条件に関連付けられています。最初に TRUE と評価された条件によって、ビジネス プロセスで使用される送信フローが決まります。ビジネス プロセスでは、最初に TRUE と評価された条件からのフローが実行されます。TRUE と評価される条件がない場合は、ELSE フローが実行されます。

[判断] シェイプには、条件を少なくとも 1 つ設定します。各条件には、1 つの条件式を設定します。
繰り返し

[繰り返し] シェイプは、1 つの条件が含まれていて、繰り返すプロセスを表します。条件が TRUE と評価された場合は、条件からのフローが実行され、繰り返されます。条件が FALSE と評価された場合は、Continue フローが実行されます。ビジネス プロセス フローが [繰り返し] シェイプの条件から出たときには、単一の [終了] シェイプで完結する必要があります。

繰り返しループのステータスを保存するように構成することもできます。[繰り返し] シェイプを右クリックし、[プロパティ] をクリックすると、[繰り返しのプロパティ] ダイアログ ボックスが表示されます。[ステータスの永続化] で [はい] を選択すると、各ループの繰り返しで使用されたメッセージを XLANG スケジュール ステータスとして保存できます。繰り返しループが失敗したトランザクションに含まれている場合、ループの繰り返しが完了するたびに、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが呼び出されます。[いいえ] を選択すると、最後のループの繰り返しで使用されたメッセージだけが、XLANG スケジュール ステータスとして保存されます。繰り返しループが失敗したトランザクションに含まれている場合、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが 1 回だけ呼び出されます。

障害が発生したネストしたトランザクション内にある [繰り返し] シェイプに一連のビジネス プロセスが流れると、そのネストしたトランザクションの [<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページで作成されたメッセージとポートは、外側のトランザクションの [<トランザクション> の失敗時] ページで利用できなくなります。収集したメッセージをネストしたトランザクションの外に正常に流すには、失敗時に実行されるコードまたは補正コードをそのように設計します。
分岐

[分岐] シェイプを使用すると、ビジネス プロセスで同時実行ができます。分岐に入ることができるフローは 1 つで、最大で 64 個までのフローに分岐させることができます。分岐から出たフローは、同時に実行されます。1 つの [分岐] シェイプから流れ出たすべての一連のビジネス プロセスは、1 つの [結合] シェイプに接続するか、[終了] シェイプで終了する必要があります。
結合

[結合] シェイプは、ビジネス プロセスで同時実行されているフローを同期させます。[結合] シェイプには、最大で 64 個のフローが入ることができ、1 つのフローが出ることができます。フローの同期方法を指定するには、論理演算子の AND と OR を使用します。次の [結合] のプロパティを設定できます。
  • [OR] : 最初に到着したフローは続行します。その他のフローも実行を続けます。

  • [AND] : 出力フローを始める前に、すべての入力フローの同期をとります。
トランザクション

[トランザクション] シェイプは、すべてが実行されるアクション、またはまったく実行されないアクションのどちらかの集合を表します。トランザクションには次の 3 種類があります。
  • 短時間トランザクション

  • 長時間トランザクション

  • 長時間実行する定刻トランザクション

トランザクションを使用すると、アプリケーションの信頼性が向上し、大規模アプリケーションのエラー処理が単純化されます。

[トランザクション] シェイプの入力は 1 つのパスに制限され、出力も 1 つのパスだけです。[トランザクション] シェイプに [終了] シェイプを含めることはできません。長時間トランザクションにネストしたトランザクションを含めることはできますが、短時間トランザクションにネストしたトランザクションを含めることはできません。トランザクションの再試行ができるのは、短時間トランザクションだけです。ビジネス プロセスの一部を短時間 [トランザクション] シェイプで囲むと、トランザクションの "再試行の回数" プロパティを設定できます。短時間トランザクションに障害が発生すると、指定した回数再試行されます。

トランザクション プロパティを定義すると、[<トランザクション> の補正] ページ (ネストしたトランザクション用) または [<トランザクション> の失敗時] ページを利用可能にできます。どちらのページでも、特定のトランザクションのエラー処理プロセスをモデル化できます。

注

  • 内側の [トランザクション] シェイプの境界線が外側の [トランザクション] シェイプの境界線と重複していると、内側のトランザクションはネストされません。内側のトランザクションの境界線が外側のトランザクションの境界線と重複しないようにしてください。
終了

[終了] シェイプは、1 つの処理フローの完了を表します。フローチャートに [判断]、[繰り返し]、または [分岐] シェイプが含まれている場合は、1 つのフローチャートで複数の [終了] シェイプを使用できます。
中断

[中断] シェイプは、トランザクション グループの実行を強制終了します。これによって、[<トランザクション> の失敗時] エラー処理ページまたは [<トランザクション> の補正] エラー処理ページを有効にしたり、トランザクションを再試行します。

注

  • [<トランザクション> の補正] ページと [<トランザクション> の失敗時] ページのパラメータ <トランザクション> は、[ビジネス プロセス] ページの関連したトランザクションの名前に置き換えられます。

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • 1 バイト文字セットによるトランザクション名の長さは、16 文字以内にします。2 バイト文字セットによるトランザクション名の長さは、8 文字以内にします。

  • アクションには、最大の長さが 32 文字という点を除いて、命名規則による制限がありません。

  • 開始、終了、判断、繰り返し、分岐、結合、および中断の各シェイプには、名前を付けることができません。

  • 繰り返しループの後に、メッセージが存在するかどうかをテストしないでください。繰り返しループの後にシステム フィールド MessageName.[__Exists__] をテストすると、繰り返しループの中で使用されたパスが、使用した判断分岐のため、またはトランザクションの中断のためにメッセージを返さないときに、常に TRUE に評価されます。フロー制御をチェックするには、ステートフル コンポーネントを使用して繰り返しループの中で使用したパスを記録し、この情報をループ外のステートフル コンポーネントで使用します。

関連項目

通信シェイプ

トランザクションの設計

実装シェイプ


実装シェイプ

BizTalk オーケストレーション デザイナには、[実装] ステンシルに 4 つの実装シェイプがあります。これらのシェイプを使用して、ビジネス プロセスでポートを実装するために使用される実装テクノロジを記述します。

次の表は、実装シェイプの一覧と説明を示しています。

シェイプ名 | 説明
COM コンポーネント | COM コンポーネント シェイプは、送受信される各メッセージへのメソッド呼び出しによってポートを実装する技術です。このシェイプを境界バーの右側までドラッグすると、COM コンポーネント バインド ウィザードが表示されます。COM コンポーネント実装の詳細については、「COM コンポーネント シェイプの使用」を参照してください。
スクリプト コンポーネント | [スクリプト コンポーネント] シェイプは、送受信されるメッセージごとにメソッド呼び出しを使用してポートを実装するテクノロジを表します。このシェイプを境界バーの右側までドラッグすると、スクリプト コンポーネント バインド ウィザードが表示されます。スクリプト コンポーネント実装の詳細については、「スクリプト コンポーネント シェイプの使用」を参照してください。
メッセージ キュー | [メッセージ キュー] シェイプは、ポートを実装するテクノロジを表します。メッセージの送受信には、メッセージ キュー サービスが使用されます。このシェイプを境界バーの右側までドラッグすると、メッセージ キュー バインド ウィザードが表示されます。メッセージ キュー実装の詳細については、「メッセージ キュー シェイプの使用」を参照してください。
BizTalk メッセージ | [BizTalk メッセージ] シェイプは、ポートを実装するテクノロジを表します。メッセージの送受信には、BizTalk メッセージ サービスが使用されます。このシェイプを境界バーの右側までドラッグすると、BizTalk メッセージ バインド ウィザードが表示されます。BizTalk メッセージ実装の詳細については、「BizTalk メッセージ シェイプの使用」を参照してください。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。

関連項目

通信シェイプ

フローチャート シェイプ


通信シェイプ

BizTalk オーケストレーション デザイナには、メッセージにデータが流れる方向を示す [通信] シェイプがいくつかあります。[通信] シェイプは、BizTalk オーケストレーション デザイナが自動的に作成します。

[ポート参照] シェイプ、[定数] シェイプ、および [メッセージ] シェイプは、[データ] ページにあります。[データ] ページは、インスタンスが実行されているときに XLANG スケジュール インスタンスが使用するメッセージ間のデータのフローを表します。データのフローを設計するには、[データ] ページでシェイプのフィールドを接続します。

次の表は、通信シェイプの一覧と説明を示しています。

シェイプ名 | 説明
ポート | ポートは、メッセージが送受信される名前付きの場所です。境界バーを右クリックし、[新しいポートの追加] をクリックして未バインド ポートを追加します。または、実装シェイプを境界バーの右側にドラッグしてバインド済みポートを追加します。 各ポートには、[データ] ページに表示される [メッセージ] シェイプに対応するメッセージが含まれています。メッセージは、アクションで送受信されるデータを表します。メッセージのデータは、[データ] ページでフィールドの一覧に分かれて表示されます。
ポート参照 | [ポート参照] メッセージには、[ビジネス プロセス] ページで作成されたすべてのポートの一覧が含まれています。[ビジネス プロセス] ページで新しいポートが追加されるたびに、新しい参照がこの一覧に追加されます。[ポート参照] メッセージで、ポートの元の場所を指定できます。[ポート参照] メッセージには、ビジネス プロセスのポートごとに 1 つのポート フィールドが含まれています。
定数 | [定数] メッセージによって、XLANG スケジュールに初期データをセットできます。[定数] メッセージに定数を追加するには、[定数] メッセージをダブルクリックするか、[定数] メッセージのフィールドをダブルクリックして [定数メッセージのプロパティ] ダイアログ ボックスを開きます。
メッセージ | [メッセージ] シェイプには、メッセージで送受信されるデータに関する情報のフィールド一覧が含まれています。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。

    • メッセージ名をシステム フィールド名として使用することはできません。システム フィールドを次の表に示しています。

[データ] ページで定義される各メッセージには、XLANG スケジューラ エンジンがメッセージごとに自動的に作成し、管理する追加のシステム フィールドがあります。これらのフィールドで、メッセージに関する説明を参照できます。また、条件に対する条件式で使用することもできます。次の表は、自動的に作成されるシステム フィールドを要約しています。

システム フィールド 説明
__Exists__ このフィールドを使用して、メッセージが存在するかどうかをテストできます。メッセージが存在するかどうかは、メッセージが XLANG スケジューラ エンジンで受信または送信されたかどうかで決まります。

このフィールドは、[データ] ページのメッセージには表示されません。 [判断] シェイプと [繰り返し] シェイプでのみ使用されます。
__Sender__ このフィールドには、メッセージの送信者 ID がわかっている場合に、その ID が格納されます。

このフィールドは、[データ] ページのメッセージに表示されます。
__Status__ このフィールドには、COM コンポーネントにバインドされたポートでの COM メソッド呼び出しから返されたステータスが含まれています。このフィールドは、[データ] ページのメッセージに表示されます。

注

  • このシステム フィールドは、COM コンポーネントとスクリプト コンポーネントの実装でのみ使用されます。

  • 返されるステータスは、常に HRESULT です。
ドキュメント このフィールドには、送受信されたメッセージ本体を含む文字列が含まれています。常に、XML メッセージを参照します。

注

  • このシステム フィールドは、メッセージ キューと BizTalk メッセージの実装でのみ使用されます。

重要

  • XLANG スケジュール インスタンスから送信されるメッセージには、定義されたデータのフィールドごとに送信元が必要です。データのフィールドの送信元を定義するには、別のメッセージの別のフィールド、または定数からそのフィールドをポイントする接続が必要です。

注

  • XLANG スケジュールを作成するために使用されるコンパイル エンジンは、メッセージのすべての入力専用フィールドが定義されているかどうかを検証します。入力専用フィールドの一部が定義されていない場合、スケジュールはコンパイルされません。メソッドの引数は、入力、出力、入出力のどれでもかまいません。コンパイル エンジンは、入力と出力の両方に定義された引数の定義要件を無視します。入出力フィールドへの受信接続が定義されていない場合、メッセージのデータの定義がなくてもスケジュールはコンパイルされます。

関連項目

データ処理

フローチャート シェイプ

実装シェイプ


BizTalk オーケストレーション デザイナのショートカット キー

BizTalk オーケストレーション デザイナでは、ショートカット キーを使用して作業を実行できます。次の表は、これらのショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。Windows 2000 Professional では、ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Alt または F10 | メニュー バーをアクティブにします。
Alt + F4 | アクティブな項目を閉じます。または、プログラムを終了します。
Alｔ + F7 | ウィンドウを重ねて表示します。
Alt + Space | アクティブな項目のシステム メニューを表示します。
Alt + メニュー名の下線付き文字 | 対応するメニューを表示します。
方向キー | 選択したシェイプを方向キーの方向に移動します。
Ctrl キーを押しながら項目をドラッグ | 選択した項目をコピーします。
Ctrl + A | すべてを選択します。
Ctrl + C | 設計ページで選択した項目をコピーします。
Ctrl + F4 | アクティブなフローチャートを閉じます。
Ctrl + I | ウィンドウを原寸大に戻します。
Ctrl + N | 新しいフローチャートを作成します。
Ctrl + O | 既存のフローチャートを開きます。
Ctrl + P | [印刷] ダイアログ ボックスを開きます。
Ctrl + Q | プログラムを終了します。
Ctrl + Shift + 方向キー | スクロールします。
Ctrl + Shift + マウス左クリック | 拡大します。
Ctrl + Shift + マウス右クリック | 縮小します。
Ctrl + V | 選択した項目を設計ページに貼り付けます。
Ctrl + X | 設計ページで選択した項目を切り取ります。
Ctrl + Y | 操作を繰り返します。
Ctrl + Z | 操作を元に戻します。
Del | 設計ページで選択した項目を削除します。
Esc | 現在の作業を取り消します。
F1 | オンライン ヘルプを表示します。
F11 | テキスト プロパティ ダイアログ ボックスを開きます。
F8 | 選択したシェイプを整列します。
← | ダイアログ ボックスのタブにフォーカスがある場合、フォーカスを左に移動します。
→ | ダイアログ ボックスのタブにフォーカスがある場合、フォーカスを右に移動します。
Shift キーを押しながら項目をドラッグ | 項目を水平または垂直にまっすぐドラッグします。
Space | チェック ボックスのオン/オフを切り替えます。
開いたメニューのコマンド名の下線付き文字 | 対応するコマンドを実行します。


XLANG スケジュール

XLANG スケジュール フローチャートのコンパイルされたバージョンが、XLANG スケジュールです。XLANG スケジューラ エンジンは、このスケジュールを実行します。XLANG スケジューラ エンジンは、XLANG スケジュールに記述されているビジネス プロセスを、XLANG スケジュールに定義されているアクション、条件、およびエラー処理プロセスに基づいて監視し、制御します。

ここには次のトピックが含まれます。

  • XLANG の概要

  • インスタンス管理

  • 永続化

  • ステータス退避とステータス復元

  • データ処理


XLANG の概要

XLANG は、ビジネス プロセスの動作を記述する XML ベースの言語です。BizTalk オーケストレーション デザイナは、XLANG スケジュール フローチャートを XML 構造の XLANG スケジュール ファイルにコンパイルします。XLANG は XML ベースなので、XLANG スケジュールは整形式ドキュメントの XML 条件に従い、仕様または標準スキーマに準拠している必要があります。


インスタンス管理

XLANG スケジューラ エンジンがインスタンス管理を実行する方法を理解するには、ビジネス プロセスの抽象定義とビジネス プロセス定義の複数実行インスタンスの違いに注意する必要があります。BizTalk オーケストレーション デザイナでは、ビジネス プロセス定義を設計し、XLANG スケジュール フローチャート (.skv ファイル) として保存します。XLANG スケジュール フローチャートを作成した後、XLANG スケジュール (.skx ファイル) にコンパイルします。XLANG スケジュールを展開した後、多くの場合、スケジュールの複数のインスタンスが同時に実行しています。各 XLANG スケジュール インスタンスには、ほかのインスタンスの有効期間とは別に、独立した有効期間を設定できます。複数の XLANG スケジュール インスタンスをサポートするアプリケーションを設計するときは、次の事項に注意してください。

  • メッセージを受信するときは、XLANG スケジュールの新しいインスタンスをアクティブにします。新しい XLANG スケジュール インスタンスをアクティブにするアプリケーションを設計するには、メッセージを受信するたびに COM 関数 GetObject を使用します。たとえば、Active Server Page (ASP) を使用して発注要求または顧客サポートの要求が含まれているメッセージを受信する場合は、ASP で COM 関数 GetObject を使用して、XLANG スケジュールをアクティブにする必要があります。

    BizTalk メッセージ バインド ウィザードを使用して、メッセージが送信される先の名前付きの場所として機能するポート バインドを作成することもできます。BizTalk Server 2002 には、BizTalk メッセージにバインドされたポートがメッセージを受信したときに XLANG スケジュールのインスタンスをアクティブにする自動メカニズムが用意されています。BizTalk メッセージ バインド ウィザードの [XLANG スケジュールのアクティブ化情報] ページでは、BizTalk メッセージ サービスで、この XLANG スケジュールの新しいインスタンスをアクティブにしてから、このポートにメッセージを送信するようにチャネルが構成されていることを確認するように求めるメッセージが表示されます。この処理を完了するには、BizTalk メッセージ マネージャで新しいメッセージ ポート ウィザードを実行する必要があります。新しいメッセージ ポート ウィザードの [送信先アプリケーション] ページで、ポート名、および XLANG スケジュールの名前と場所を指定します。

  • メッセージと XLANG スケジュール インスタンスの関連付け : XLANG スケジュールの各インスタンスには、XLANG スケジューラ エンジンによってグローバル一意識別子 (GUID) が割り当てられます。このインスタンス ID を使用して、メッセージとスケジュール インスタンスを関連付けることができます。関連付けは以下の方法で実行できます。

    単一のキューの使用 : すべてのインスタンスに単一のキューを使用することによって、多くのインスタンスごとのキューを使用することによるオーバーヘッドを避けることができます。そのためには、スケジュール インスタンスの GUID またはインスタンス ID を使用します。メッセージを送信するときにスケジュールのインスタンス ID を保存し、メッセージを受信したときにそれを取得し、それを使用して受信メッセージを正しいスケジュール インスタンスに関連付けるためのメカニズムを作成しなければなりません。次のいずれかの方法で、これを実行することができます。

    • 関連付けのために使用できるメッセージ フィールドを識別します。このフィールドは、一意でなければなりません。これは、この目的のために作成されたフィールドでも、ドキュメント書式の中に既にあるフィールドでもかまいません。

      送信の場合は、インスタンス ID と関連付けフィールドの値を保存することができます。パイプライン コンポーネントを使用すると、Src_XLANG_InstanceID をディクショナリから取得し、それを関連付けフィールド値と合わせてローカル データベースに保存することができます。

      受信の場合は、受信メッセージから関連付けフィールドを抽出するカスタム コンポーネントを書き込み、データベースの中の対応するインスタンス ID を検索し、その値を使用してディクショナリの Dest_XLANG_InstanceID を設定することにより、後にメッセージを適当なインスタンスへ配信することができます。

    • インスタンス ID をメッセージ ラベルとして使用します。そのためには、アクションとポートをバインドしているときに、XML 通信ウィザードの [メッセージの種類の情報] ダイアログ ボックスの [メッセージ ラベルにインスタンス ID を使用] ボックスを選択します。詳細については、「XML 通信ウィザードの使用」を参照してください。

    インスタンスごとのキューの使用 : XLANG スケジュールの各実行インスタンスの各ポートには、一意なアドレスを指定できます。このアドレス指定機能により、特定の XLANG スケジュール インスタンスの特定のポートとの直接の通信が可能になるため、関連付けのためのカスタム コードを作成する必要はありません。スケジュール インスタンスから送信される最初のメッセージは、多くの場合、静的ポート (名前付きの場所) へのメッセージです。XLANG スケジュールがアクティブになると、このインスタンスは動的ポート (インスタンスごとの一意な場所) の場所を受信者に送信します。受信者は、そのポートに通信を戻す必要があります。これは、一意な返信先アドレス付きで送信された電子メール メッセージに対応します。次の一覧は、BizTalk Server バインド テクノロジごとの動的バインドのサポートの説明です。

    • COM コンポーネント バインド ウィザードまたはスクリプト コンポーネント バインド ウィザードの [静的または動的な通信] ページで [静的] を選択した場合、XLANG スケジューラ エンジンはコンポーネントの XLANG スケジュール インスタンスを作成します。[動的] を選択した場合は、コンポーネントのインスタンスを作成する前に、別のアプリケーションでインターフェイス ポインタまたはモニカを (メッセージのフィールドとして) 送信する必要があります。

    • [インスタンスを作成しない] を選択することもできます。コンポーネント インスタンスの作成の詳細については、「静的ポートと動的ポート」を参照してください。

    • メッセージ キュー バインド ウィザードの [静的または動的キューの情報] ページで [静的キュー] を選択し、[次へ] をクリックすると、[キュー情報] ページが表示されます。このページで、各 XLANG スケジュール インスタンスに対して個別にインスタンスごとのキューを作成するように指定することも、すべての実行インスタンスに対してキューを 1 つだけ使用するように指定することもできます。

    • メッセージ キュー バインド ウィザードの [静的または動的キューの情報] ページで [動的キュー] を選択した場合は、ポートを通じてメッセージを送受信する前に、別のアプリケーションでキュー名を (メッセージのフィールドとして) 送信する必要があります。

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで、チャネル情報を指定するか、チャネル情報が XLANG スケジュールで既に受信したメッセージ フィールドによって提供されていることを示すことができます。メッセージ交換の詳細については、「BizTalk サービスの統合」を参照してください。
  • アプリケーションの拡張 : メモリ上に置く必要がない XLANG スケジュール インスタンスは、ステータス退避してください。メッセージの到着を待つ間、XLANG スケジュール インスタンスを必ずしもメモリ上に置く必要はありません。

注

  • すべての [実装] シェイプでは、動的にバインドされ、実行時に定義される場所を示すシェイプの下にシャドウが表示されます。

  • 親インスタンスから分岐した子インスタンスには、親のインスタンス ID とは別の一意のインスタンス ID があります。同様に、繰り返しループ内のそれぞれの子インスタンス（ループを通る各パス上の）にも独自の一意なインスタンス ID があります。

関連項目

データ処理

ステータス退避とステータス復元

セッション ステータスの管理

永続化

XLANG スケジュールの関連付け


永続化

XLANG スケジューラ エンジンは、ステータス保存データベースに次の情報を格納します。

  • XLANG スケジュールの構造

  • アクティブな XLANG スケジュール インスタンスの進行状況

  • XLANG スケジュール インスタンスを実行している間に送受信されたメッセージ

XLANG スケジューラ エンジンが情報を永続化することによって、次のことができます。

  • 長時間のスケジュールのステータス退避とステータス復元ができます : 長時間トランザクションの途中で、システムに障害が発生することがあります。システムが再起動されたときに、XLANG スケジューラ エンジンはステータス保存データベースを参照して、スケジュールのどこから再開するかを判断します。

  • トランザクションに障害が発生したときに、スケジュール インスタンスのステータスを復元します : トランザクションの途中でシステムに障害が発生し、トランザクションが中断されることがあります。XLANG スケジューラ エンジンはステータス保存データベースを参照して、スケジュールのどこから再開するかを判断します。

  • 実行中のスケジュールのデバッグと監視をサポートします : デバッグ ツールと監視ツールを使用してステータス保存データベースに照会し、スケジュール インスタンスの進行状況に関する情報を表示できます。

トランザクションの開始前と完了後に XLANG スケジュールのステータスの永続化をサポートすることによって永続性が提供され、コミットされたすべての変更が恒久的にシステムに反映されます。また、障害が発生した場合にトランザクションを再試行することもできます。次の条件を満たしている場合に、実行中のスケジュール インスタンスのステータスは永続化されます。

  • トランザクションの開始時 : ビジネス プロセスがトランザクションの開始に入るときに、ステータス保存データベースのトランザクション再試行回数を更新する必要があります。これによって、トランザクションの途中でシステムに障害が発生した場合に、XLANG スケジューラ エンジンが再試行回数を追跡できます。

  • トランザクションの終了時 : ビジネス プロセスがトランザクションの外に出る場合、必要に応じて、ロールバックできるようにスケジュール ステータスを更新する必要があります。この更新は、データベースの永続性の原子性を保証するために、トランザクションのコンテキストで行われます。

関連項目

ステータス退避とステータス復元

インスタンス管理

セッション ステータスの管理


ステータス退避とステータス復元

XLANG スケジュールの複数のインスタンスを同時に長時間実行している場合、すべてのインスタンスをメモリ上に残しておくと非効率的になることがあります。この問題に対処するために、XLANG スケジューラ エンジンにはステータス退避とステータス復元の基盤が用意されています。

XLANG スケジュール インスタンスがメッセージを長時間待つことが予測される場合、そのスケジュールでほかの活動が何も実行されていなければ、XLANG スケジューラ エンジンは XLANG スケジュール インスタンスのステータスを退避できます。XLANG スケジュール インスタンスのステータス退避は、インスタンスに固有のすべてのステータスをステータス保存データベースに保存して永続化し、インスタンスをメモリから削除します。ステータス退避済み XLANG スケジュール インスタンス用のポート アドレスにメッセージが到着すると、インスタンスのステータス復元が行われます。XLANG スケジュール インスタンスのステータス復元では、データベースにあるインスタンスがメモリ上に復元されます。

XLANG スケジュール インスタンスは、ステータス復元が行われるか、管理者によって明示的に終了されるまで、ステータス退避された状態で保持されます。このような処理によって、長時間に渡って、ビジネス プロセスを高い信頼性を保ったまま実行することが可能になります。

XLANG スケジューラ エンジンの待ち時間の設定を使用して、アクションが非アクティブになってから XLANG スケジュール インスタンスをステータス保存データベースにステータス退避するまでの時間を決定できます。XLANG スケジューラ エンジンは、この待ち時間の設定を使用して、XLANG スケジュール インスタンスをステータス保存データベースにステータス退避し、メッセージが到着したときにステータス復元します。ただし、次のように、待ち時間の設定にかかわらず、スケジュールがステータス退避されない場合があります。

  • スケジュール インスタンスが休止ステータスではない場合 : これは、XLANG スケジュール インスタンスの現在の処理 フローの 1 つで、アクションの実行中に発生することがあります。XLANG スケジューラ エンジンが XLANG スケジュール インスタンスをステータス退避するには、スケジュール インスタンスのすべての処理 フローが同じステータスである必要があります。ステータス退避を実行するには、すべての保留中アクションの待ち時間が、指定されたしきい値を超える必要があります。

  • 保留中の DTC スタイル トランザクションがある場合 : DTC スタイルのトランザクションは一般的に短時間なので、DTC スタイルのトランザクションが実行中の場合、XLANG スケジューラ エンジンはスケジュールのステータス退避を行いません。

  • 永続化できない実行中ポートがある場合 : 実行中ポートとは、実装済みで、後でスケジュール インスタンスで使用される可能性があるポート オブジェクトまたはポートです。ポートの有効期間は、スケジュール インスタンスの実行にとって重要な問題です。ポートは COM インターフェイスなどの実装テクノロジにバインドされます。ポートがバインドされている実装テクノロジが永続化されずに、後で再使用されるステータス情報を保持している場合、インスタンスのステータス退避とステータス復元は行われません。ステータス保存データベースに障害が発生し、後で再実行した場合、ステータス情報は失われ、最後にステータス退避されたときのステータスからスケジュール インスタンスの実行を再開することはできません。

XLANG スケジューラ エンジンは、シャットダウンされるときに、トランザクション コンテキストにないすべての情報も含めて、可能な限り多くの情報をステータス保存データベースに保存します。

関連項目

インスタンス管理

セッション ステータスの管理

永続化

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


データ処理

XLANG では、すべてのデータは一意な名前のメッセージのセットに格納されています。アクションがメッセージを受信すると、新しいデータが XLANG スケジュール インスタンスに入力されます。

XLANG スケジュール フローチャートごとに、1 つの [データ] ページがあります。[データ] ページでは XLANG スケジュールのデータ フローを記述できます。あるメッセージ フィールドから別のメッセージ フィールドにデータが流れることを示すには、送信元メッセージ フィールドから送信先メッセージ フィールドに矢印を描画します。

[定数] メッセージを除いて、[データ] ページのメッセージのどのメッセージ フィールドにも、最初は値が含まれていません。[定数] メッセージは、[データ] ページで指定された値で初期化されます。新しい XLANG スケジュール インスタンスごとに、自動的に初期化されます。定数の使用方法については、「定数メッセージ」を参照してください。

表示されているほかのメッセージの値は、XLANG スケジュール インスタンスで各メッセージが送受信されたときに設定されます。1 つのメッセージを複数のアクションで受信することができます。メッセージが受信されるたびに、そのメッセージの値は上書きされます。メッセージが XLANG スケジュールの別のポイントで送信される場合でも、受信したメッセージへのデータのフローを使用して別の受信メッセージの値が設定されることはありません。排他的に送信されるメッセージは、そのメッセージのメッセージ フィールドに値を設定するように [データ] ページに表示されているデータ フローを使用します。送信されたすべてのメッセージのすべてのフィールドが指定されるまで、スケジュールはコンパイルされません。

[データ] ページのフィールドが、XML スキーマ内でオプションのノードをポイントしている XPath を参照する場合は、次のガイドラインを使用します。

  • オプションのノードが存在するときの受信メッセージ : このメッセージを受信したときに XML ドキュメントにオプションのノードが存在する場合、XPath フィールドはノードの値を格納します。

  • オプションのノードが存在しないときの受信メッセージ : このメッセージを受信したときにオプションのノードが存在しない場合、XPath フィールドは NULL 値を格納します。このフィールドで判断規則と Microsoft® Visual Basic® Scripting Edition (VBScript) 式 IsNull (Message.Field) を使用して、受信メッセージにオプションのノードが含まれているかどうかを判断する必要があります。このフィールドが別の送信メッセージへのデータ フローを提供する場合、値が存在するかどうかをテストしないと、XLANG スケジューラ エンジンが送信メッセージを作成しようとしたときにエラーが発生します。

  • オプションのノードが存在するときの送信メッセージ : このメッセージが (オプションの XML ノードをポイントする XPath ノードを使用して) 送信される場合、XLANG スケジューラ エンジンはデータ フローを使用してメッセージを作成します。ノードがメッセージのドキュメント フィールドに存在する場合、XLANG スケジューラ エンジンはこの値を XPath の値で上書きします。

  • オプションのノードが存在しないときの送信メッセージ : このメッセージが (オプションの XML ノードをポイントする XPath ノードを使用して) 送信される場合、XLANG スケジューラ エンジンはデータ フローを使用してメッセージを作成します。ノードが指定されたドキュメント フィールドに存在しない場合、XLANG スケジューラ エンジンは上書きするノードを作成しません。これが原因でエラーが発生することがあります。

メッセージ キューとの間で送受信されるメッセージの場合は、次のガイドラインを使用します。

  • 受信メッセージ : アクションが非 XML メッセージをメッセージ キューから受信する場合は、XML 通信ウィザードの [XML 変換情報] ページの [キューから文字列メッセージを受信する] を選択する必要があります。このように構成すると、[データ] ページの [メッセージ] シェイプに、新しい StringData フィールドが表示されます。この StringData フィールドに、キューから受信した非 XML メッセージが格納されます。メッセージのドキュメント フィールドには、XLANG スケジューラ エンジンの標準 XML ラッパーで囲まれた StringData フィールドが格納されます。

  • 送信メッセージ : アクションが非 XML メッセージをメッセージ キューに送信する場合は、XML 通信ウィザードの [XML 変換情報] ページの [メッセージをキューに文字列として送信する] を選択する必要があります。このように構成すると、[データ] ページの [メッセージ] シェイプに、新しい StringData フィールドが表示されます。この構成を完了するには、[データ] ページの [定数] メッセージで、XLANG スケジューラ エンジンの標準 XML ラッパーを含む新しい定数を作成する必要があります。この定数名は任意ですが、データ型は string である必要があり、定数の値は、<?xml version="1.0" ?> <StringData> </StringData> にする必要があります。この新しい定数を作成した後で、[定数] メッセージの新しい定数から [メッセージ] シェイプのドキュメント フィールドへのデータ フロー接続を描画する必要があります。非 XML 文字列を含むフィールドから [メッセージ] シェイプの新しい StringData フィールドへのデータ フロー接続も描画する必要があります。

注

  • データ フローの方向とメッセージ フローの方向は、互いに独立しています。メッセージ フローは、メッセージの送信または受信を示します。

  • コンポーネントのインスタンスを作成しないで、メソッド呼び出しを使用して XLANG スケジュールでデータを受信できるようにするには、COM コンポーネント バインド ウィザードまたはスクリプト コンポーネント バインド ウィザードの [静的または動的な通信] ページの [インスタンスを作成しない] を選択します。[インスタンスを作成しない] を選択すると、コンポーネントはインスタンスを作成せず、メソッド呼び出しのコードも実行されません。代わりに、XLANG スケジュールがメソッド要求の情報をインターセプトすると、この情報をメソッド応答として返します。メソッド呼び出しが回避されます。

  • メッセージが繰り返しループの本体でのみ使用される場合、ループの各繰り返しではメッセージの値は初期化されません。メッセージが繰り返しループの本体の内側と外側の両方で使用される場合、メッセージの値はループの各繰り返しを通じて保持されます。メッセージの値は、一連のビジネス プロセスが [繰り返し] シェイプに流れる前と流れた後を通じて保持されていることもあります。

  • 繰り返しループの中の [<トランザクション> の処理の補正] または [<トランザクション> の処理の失敗時] でメッセージが初期化された場合、そのメッセージの値はループの外側では利用できません。

  • データ型が char の XML メッセージのフィールド (定数メッセージを含む) がメソッド メッセージ フィールドにデータ フローを提供する場合、フィールドはメソッド用に integer に変換されます。メソッド メッセージ フィールドのデータ型が string の場合、文字列には整数値が格納されます。文字は格納されません。この問題が発生した場合、送信元フィールドが定数メッセージの一部であれば、定数フィールドのデータ型を string に変更してください。送信元フィールドが XML メッセージの一部である場合は、char データ型を string に型変換するコンポーネントを使用する必要があります。

ここには次のトピックが含まれます。

  • データ ページ

  • 定数メッセージ

  • ポート参照メッセージ

  • フィールド データ型

  • システム フィールド

  • ノード パス フィールド


データ ページ

XLANG スケジュール フローチャートごとに、1 つの [データ] ページがあります。[データ] ページには、次の情報が表示されます。

  • XLANG スケジュールのメッセージごとに 1 つのメッセージ シェイプ

  • 1 つの [定数] メッセージ

  • XLANG スケジュール フローチャートのポートごとに、ポート フィールドを含む 1 つの [ポート参照] メッセージ

  • メッセージ フィールド間のデータのフローを示す接続図

メッセージは、一意な名前のフィールドのセットで構成されています。各フィールドには、特定のデータ型のデータ項目が 1 つ含まれています。XLANG スケジュールの各メッセージは、[データ] ページに表形式で表示されます。各表には、メッセージの名前、およびフィールド名とそれに対応するデータ型の一覧が表示されます。データ フローを必要としないシステム フィールドは、黄色の背景色で表示されます。ユーザー フィールドとデータ フローが必要なシステム フィールドは、白の背景色で表示されます。

[データ] ページの接続は、送信元メッセージ フィールドの右側から送信先メッセージ フィールドの左側をポイントします。この接続は、送信元メッセージ フィールドが送信先メッセージ フィールドにデータを提供することを示します。実行時に送信先メッセージが作成されると、XLANG スケジューラ エンジンが送信元メッセージ フィールドから送信先メッセージ フィールドにデータをコピーします。送信元メッセージがまだ到着していない場合、実行時エラーが発生します。

注

  • [データ] ページでは、次のデータ型はサポートされていません。
    • BinHex

    • BinBase64

    • I8

    • UI8

データ型が BinHex、BinBase64、I8、または UI8 の XML ドキュメントにノードがあり、[データ] ページでこのノードへの XPath を使用して、ノードを XLANG スケジューラ エンジンの範囲に入るように指定した場合、ノードは文字列に変換されます。

  • XLANG スケジュールでは、すべてのフィールドの名前は 100 文字以内にする必要があります。

関連項目

定数メッセージ

データ処理

フィールド データ型

ノード パス フィールド

ポート参照メッセージ

システム フィールド


定数メッセージ

[定数] メッセージを使用して、XLANG スケジュール インスタンスをデータで初期化することができます。XLANG スケジューラ エンジンの中で、[定数] メッセージは特異な機能を実行します。このメッセージは、送信も受信もされません。新しい XLANG スケジュール インスタンスごとに、自動的に初期化されます。[定数] メッセージに定数を追加するには、[定数] メッセージをダブルクリックするか、[定数] メッセージのフィールドをダブルクリックして [定数メッセージのプロパティ] ダイアログ ボックスを開きます。次に、[定数メッセージのプロパティ] ダイアログ ボックスの [追加] をクリックして、[定数のプロパティ] ダイアログ ボックスを開きます。[定数のプロパティ] ダイアログ ボックスで、定数に名前を付けたり、定数のデータ型を選択したり、定数に値を割り当てることができます。

各国語対応に関する問題

  • XML は、日付の書式設定をする Windows ロケールの設定を処理しません。ローカライズされた書式の日付を定数に割り当てるには、定数のデータ型を string に設定します。この定数が date データ型のフィールドにデータを提供すると、XLANG スケジューラ エンジンは、文字列をローカライズされた書式に準拠した日付であると解釈します。

関連項目

データ処理

データ ページ

フィールド データ型

ノード パス フィールド

ポート参照メッセージ

システム フィールド


ポート参照メッセージ

[ポート参照] メッセージには、[ビジネス プロセス] ページで作成されたすべてのポートの一覧が含まれています。[ビジネス プロセス] ページで新しいポートが追加されるたびに、新しい参照がこの一覧に追加されます。[ポート参照] メッセージで、ポートの元の場所を指定できます。[ポート参照] メッセージには、XLANG スケジュール フローチャートのポートごとに 1 つのポート フィールドが含まれています。

XLANG スケジュールのポートが、設計時にはわからないことがあります。このような状況は、メッセージの送信先または作成元がほかのメッセージのコンテンツで決まる場合に発生します。たとえば、メッセージを作成した取引先に対して、受信確認を使用してメッセージに応答する必要があるアクションの状況を記述するビジネス プロセスがあるとします。この例で受信するメッセージには、通常、メッセージ作成元のアドレスが含まれている返信先アドレス フィールドがあります。XLANG スケジュールは、返信先アドレス フィールドのコンテンツを受信確認メッセージの送信先アドレスに関連付ける必要があります。[ポート参照] メッセージと受信確認メッセージを使用して、[データ] ページでこのシナリオを実装できます。メッセージ交換の詳細については、「BizTalk サービスの統合」を参照してください。

関連項目

定数メッセージ

データ処理

フィールド データ型

ノード パス フィールド

システム フィールド


フィールド データ型

BizTalk オーケストレーション デザイナでは、XML データ型名と共にすべてのデータ型が表示されます。次の表は、表示される XML データ型名と等価な OLE Automation、Visual Basic、および C プログラムの型の一覧です。

XML UI 表示 | OLE Automation | Visual Basic | C
単純型 |  |  |
boolean | VT_BOOL | Boolean | VARIANT_BOOL
string | VT_BSTR | String | BSTR
cy | VT_CY | Currency | CURRENCY
date | VT_DATE | Date [日付] | DATE
dispatch | VT_DISPATCH | オブジェクト | IDispatch
error | VT_ERROR |  | SCODE
i1 | VT_I1 |  | signed char
i2 | VT_I2 | Integer | SHORT
i4 | VT_I4 | Long | LONG
int | VT_INT |  | INT
r4 | VT_R4 | Single | FLOAT
r8 | VT_R8 | Double | DOUBLE
ui1 | VT_UI1 | Byte | BYTE
ui2 | VT_UI2 |  | USHORT
ui4 | VT_UI4 |  | ULONG
uint | VT_UINT |  | UINT
unknown | VT_UNKNOWN | オブジェクト | IUnknown
variant | VT_VARIANT | Variant | VARIANT

関連項目

定数メッセージ

データ処理

データ ページ

ノード パス フィールド

ポート参照メッセージ

システム フィールド


システム フィールド

各メッセージには、XLANG スケジューラ エンジンが自動的に作成したシステム フィールドのセットが含まれていることもあります。

システム フィールド名 | このシステム フィールドが表示されるタイミング | 説明
__Status__ | COM またはスクリプト バインドにバインドされているポートからメッセージを受信したとき。 | メソッド呼び出しの HRESULT。
__Sender__ | 任意のポートとの間でメッセージを送受信したとき。 | メッセージを受信した場合、メッセージ キューまたは COM が提供する SenderID を含む文字列。メッセージが送信された場合、値は NULL。
ドキュメント | メッセージ キューまたは BizTalk メッセージにバインドされているポートとの間でメッセージを送受信したとき。 | 送受信されたメッセージ本体が含まれている文字列。

関連項目

定数メッセージ

データ処理

フィールド データ型

ノード パス フィールド

ポート参照メッセージ


ノード パス フィールド

メッセージ キューまたは BizTalk メッセージにバインドされているポートが XML ドキュメントを受信したとき、特定のドキュメント ノードを XLANG スケジューラ エンジンのデータ範囲に入れることができます。特定のノードが選択されていない場合、XLANG スケジューラ エンジンは XML ドキュメントをドキュメント システム フィールドに入力される不定形の文字列として扱います。

ドキュメント ノードを XLANG スケジューラ エンジンのデータ範囲に入れるには、XML 通信ウィザードの [メッセージ仕様] ページを使用します。XML 仕様を指定すると、[追加] と [削除] が有効になります。

関連項目

定数メッセージ

データ処理

フィールド データ型

ポート参照メッセージ

システム フィールド

XML 通信ウィザードの使用


XLANG スケジュール フローチャートの作成

XLANG スケジュールを設計するときに実行する必要がある作業は、次の 5 つです。

  • XLANG スケジュールが実行するビジネス プロセスの表現を描画します。[フローチャート] シェイプを使用して、ビジネス プロセスのフローを設計ページの左側に記述します。主となるビジネス プロセスは、[ビジネス プロセス] ページで描画します。代替のビジネス プロセスは、[<トランザクション> の補正] ページと [<トランザクション> の失敗時] ページで描画します。

  • 判断の分岐条件と、ビジネス プロセスで繰り返し発生するプロセスを定義します。次に、同時に実行されるプロセスを定義し、ビジネス プロセスに必要なトランザクションと下位トランザクションを設計します。

  • ビジネス プロセスに必要なポート実装を作成します。4 つの実装テクノロジが利用できます。すわなち、COM コンポーネント、Windows スクリプト コンポーネント、メッセージ キュー サービス、および BizTalk メッセージ サービスです。

  • データとメッセージの間のフローを定義します。データとメッセージの間のすべてのフローを [データ] ページで描画します。

  • トランザクションに障害が発生した場合に必要になるビジネス プロセスを描画します。代替のビジネス プロセスを [<トランザクション> の補正] ページと [<トランザクション> の失敗時] ページで描画します。

注

  • [フローチャート] シェイプと [実装] シェイプは、[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページに追加できます。これらのシェイプは、[データ] ページでは利用できません。

ここには次のトピックが含まれます。

  • ビジネス プロセスの設計

  • 例外処理

  • ビジネス プロセスの実装


ビジネス プロセスの設計

BizTalk オーケストレーション デザイナの [ビジネス プロセス] ページの左側は、ビジネス プロセスを設計するための領域です。境界バーによって、[ビジネス プロセス] ページは左側のビジネス プロセス設計領域と右側の実装領域に分割されます。

ここには次のトピックが含まれます。

  • アクションの設計

  • 条件の設計

  • 同時実行の設計

  • トランザクションの設計


アクションの設計

ビジネス プロセスは、XLANG スケジュール フローチャートの [開始] シェイプから最初の [フローチャート] シェイプに向かって流れる必要があります。一般的に、XLANG スケジュール フローチャートの最初の [フローチャート] シェイプは [アクション] シェイプになります。

[開始] シェイプには、2 つの構成可能プロパティがあります。[開始のプロパティ] ダイアログ ボックスで "トランザクション モデル" プロパティを構成して、XLANG スケジュール インスタンスで [トランザクション] シェイプをサポートするか、XLANG スケジュールをトランザクションの COM コンポーネントの中からアクティブにするかを決定できます。最初のオプションは、[トランザクション] シェイプのサポートを有効にします。2 番目のオプションは、[トランザクション] シェイプのサポートを無効にします。

[開始のプロパティ] ダイアログ ボックスで "トランザクションのアクティブ化" プロパティと "XLANG ID" プロパティを構成することもできます。トランザクションのアクティブ化の詳細については、「トランザクションの設計」を参照してください。

XLANG ID は、読み取り専用プロパティです。このプロパティには、XLANG スケジュール フローチャートのバージョンを、生成された XLANG スケジュールに関連付けるために使用されるグローバル一意識別子 (GUID) が含まれています。新しいフローチャートが作成されると自動的に GUID が生成され、XLANG スケジュール フローチャートが変更されるたびに新しい GUID が生成されます。

[アクション] シェイプで唯一の構成可能なプロパティは、アクションの名前です。アクションの名前は最大 32 文字です。アクション名は XLANG スケジュールの動作に影響を与えません。

関連項目

同時実行の設計

条件の設計

トランザクションの設計

フローチャート シェイプ


条件の設計

条件は、Microsoft Visual Basic Scripting Edition (VBScript) 式で記述し、[判断] シェイプおよび [繰り返し] シェイプで使用します。条件には、次の項目を含めることができます。

  • Date や Time などの組み込み VBScript 式

  • メッセージ フィールドのデータを評価する式

  • メッセージが存在するかどうかを判断できる式

条件には、シェイプの動作を定義する次のプロパティが含まれています。

  • [条件名] : XLANG スケジュール フローチャートでその条件を使用するシェイプの中に表示される必須プロパティです。条件名によって、条件は一意に識別されます。一意な名前を付けた単一の条件を、複数の [判断] シェイプと [繰り返し] シェイプで使用できます。条件を使用する [判断] シェイプまたは [繰り返し] シェイプの幅は、そのシェイプに含まれている最も名前の長い条件によって決まります。

  • [条件の説明] : 省略できるプロパティです。条件を説明します。

  • [条件式] : メッセージに含まれているデータを参照する必須の VBScript 式です。式は、TRUE または FALSE に評価される必要があります。

XLANG スケジュール フローチャートを設計するときに条件を作成し、条件名と条件の説明を指定します。[実装] シェイプをフローチャートに追加するときに、条件式を追加します。

注

  • "条件式" プロパティの要件は、XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルするときにだけ適用されます。

  • [データ] ページのメッセージには表示されませんが、__Exists__ フィールドというメッセージ フィールドがあります。このフィールドを使用して、メッセージが存在するかどうかをテストできます。メッセージが存在するかどうかは、メッセージが XLANG スケジューラ エンジンで受信または定義されたかどうかで決まります。

関連項目

条件の作成

アクションの設計

同時実行の設計

トランザクションの設計

フローチャート シェイプ

判断条件の設定


同時実行の設計

BizTalk オーケストレーション デザイナは、同時に実行されるアクションをサポートします。[分岐] シェイプと [結合] シェイプを使用して、XLANG スケジュールで同時に実行される処理フローを実装します。[分岐] シェイプを使用して、同時に実行される処理フローを作成します。[結合] シェイプを使用して、同時に実行される処理フローのうち [終了] シェイプで終了しないフローを同期させます。

結合のプロパティ

[結合] シェイプには、設定可能な 2 つのプロパティがあります。これらのプロパティは、次の論理演算子で表されます。

  • [AND] : XLANG スケジュールは、すべての処理フローが結合に到着するまで待機してから、ビジネス プロセスの次のアクションを続行します。

  • [OR] : XLANG スケジュールは、最初の処理フローが結合に到着するまで待機してから、ビジネス プロセスの次のアクションを続行します。

    同じ分岐シェイプのほかの分岐のアクションはプロセスを完了しますが、OR 結合は完了するまで待機しません。OR 結合から出る処理フローに、その OR 結合に入る分岐からのデータ フローを必要とするアクションが含まれている場合、結合の外のアクションが実行されるときまでに分岐のアクションが完了していないと、エラーが発生します。

有効な分岐および結合処理フロー

ビジネス プロセスで同時に実行されるフローを設計するときは、次のガイドラインに従います。

  • 分岐したすべてのフローは、[終了] シェイプで終了するか、[結合] シェイプで同期をとって 1 つのフローにする必要があります。

  • 分岐したフローのアクションは、互いに通信できません。たとえば、ある分岐のアクションがキューからのメッセージの受信を待機しているときに、別の分岐のアクションがこのキューにメッセージを送信することはできません。

    注意

    • 異なる分岐のアクション間の通信を適切にサポートするように XLANG スケジュール フローチャートが設計されていない場合、エラー メッセージは表示されませんが、実行時に XLANG スケジュール インスタンスの障害が発生することがあります。
  • 1 つの結合を使用して複数の分岐からのフローの同期をとることはできません。[結合] シェイプを使用して同期をとれるのは、対応する分岐からのフローだけです。[分岐] シェイプと [結合] シェイプの使用には、1 対 1 の対応があります。

    次の図は、2 つの分岐を使用して同時実行フローを作成し、1 つの結合を使用してこれらのフローの同期をとろうとする例です。この接続は無効です。このような接続をしようとすると、XLANG スケジュールをコンパイルするときにエラー メッセージが表示されます。

    次の 2 つの図は、有効な結合の例です。

    次の図では、2 つの分岐が 2 つの結合に対応しています。2 番目の分岐と結合の組が、最初の分岐と結合の組の中にネストされています。

    次の図では、2 つの分岐が 2 つの結合に対応しています。2 番目の分岐と結合の組が、最初の分岐と結合の組の中にネストされています。2 番目の分岐と結合の組の間にある同時実行フローの 1 つが [終了] シェイプで終了する場合も、もう 1 つの同時実行フローの同期を対応する結合でとってから、最初の分岐と結合の組からの同時実行フローと同期をとる必要があることに注意してください。

  • 複数の同時実行フローの同期を OR 結合でとる場合、結合に入る各処理フローにはアクションを 1 つだけ含めることができます。複数のアクションが含まれているフローは無効です。

    次の図は、複数の同時実行フローの同期をとる OR 結合です。各フローには、アクションが 1 つだけ含まれています。

重要

  • 1 つの分岐シェイプの異なる分岐のアクションは、互いに通信できません。たとえば、ある分岐のアクションがキューからのメッセージの受信を待機しているときに、別の分岐のアクションがこのキューにメッセージを送信することはできません。異なる分岐のアクション間のあらゆる通信を適切にサポートするように XLANG スケジュール フローチャートが設計されていない場合、エラーは表示されませんが、実行時に XLANG スケジュール インスタンスの障害が発生することがあります。

関連項目

アクションの設計

条件の設計

トランザクションの設計

フローチャート シェイプ

同時実行のプロパティの設定


トランザクションの設計

BizTalk オーケストレーション デザイナは、エラー処理や障害が発生したトランザクションからの回復など、トランザクション指向のプログラミング モデルを提供します。BizTalk オーケストレーション デザイナで、[<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページの 2 種類の追加ページを作成するように [トランザクション] シェイプを構成できます。これら 2 つのページを使用して、ビジネス プロセスが失敗したトランザクションから回復できるようにします。[<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページには、追加の [<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページを参照する [トランザクション] シェイプを含めることができます。[<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページは、[ビジネス プロセス] ページに表示される同じ [ポート] シェイプと [実装] シェイプを使用できます。

BizTalk オーケストレーション デザイナで設計される短時間トランザクションには、4 つの ACID 属性があります。ACID とは、次のプロパティで構成される略語です。

  • (原子性) : トランザクションは、作業の最も小さな単位を表します。トランザクションのすべての変更が実行されるか、またはまったく実行されないかのどちらかです。

  • (一貫性) : コミットされるときに、トランザクションはシステム内のデータの一貫性を保つ必要があります。トランザクションの開始前に内部の一貫性がとれていたデータベースのデータを変更する場合は、そのトランザクションがコミットされるときにも、データベースの内部の一貫性がとれている必要があります。このプロパティを保証することは、主にアプリケーション開発者の責任です。

  • (独立性) : 同時に実行されるトランザクションによる変更は、ほかの同時に実行されるトランザクションによる変更から独立している必要があります。同時に実行される独立したトランザクションは、これらのトランザクションが連続して実行された場合と同じく、内部データベースの一貫性を保つように変更を実行します。

  • (持続性) : トランザクションがコミットされると、すべての変更は既定で恒久的にシステムに反映されます。システム障害が発生した場合にも、変更は永続化します。

これに対して、長時間トランザクションでは、完了までに長時間を必要とする操作を処理できるように独立性が犠牲になっています。

注

  • トランザクションの結果をテストするには、トランザクション失敗時処理中に作成されたメッセージを使用します。トランザクションの結果をテストするために、トランザクションで使用されたメッセージが存在するかどうかをテストしても意味がありません。このメッセージは変更されている場合もされていない場合もあります。

  • XLANG スケジューラ エンジンの COM コンポーネントで COM+ Bring Your Own Transaction (BYOT) 機能を使用するときは、ラッパー コンポーネントを作成して、COM アプリケーションに書き込み、インストールします。コンポーネントへのすべてのメソッド呼び出しは、ラッパー コンポーネントから転送されます。BYOT コンポーネントが COM+ アプリケーションにインポートされている場合、従来の COM コンポーネントの起動ができなくなります。これは、この機能を提供するコンポーネントが COM+ アプリケーションとしてではなく従来の COM コンポーネントとして登録されるからです。

ここには次のトピックが含まれます。

  • XLANG スケジュール フローチャートのトランザクション プロパティ

  • 特定のトランザクション シェイプのトランザクション プロパティ

  • ポート実装のトランザクション プロパティ

  • 長時間トランザクション

  • 短時間トランザクション

関連項目

アクションの設計

同時実行の設計

条件の設計

フローチャート シェイプ

トランザクション プロパティの設定


XLANG スケジュール フローチャートのトランザクションのプロパティ

[ビジネス プロセス] ページの [開始] シェイプを右クリックし、[プロパティ] をクリックすると、[開始のプロパティ] ダイアログ ボックスが表示されます。[開始のプロパティ] ダイアログ ボックスで、次のプロパティを構成できます。

  • [トランザクション モデル] : このプロパティの既定の設定は、[XLANG スケジュールにトランザクションを含める] です。
    • XLANG スケジュール フローチャートで、グループ化したアクションの集合を [トランザクション] シェイプで囲む場合は、[XLANG スケジュールにトランザクションを含める] を選択します。このオプションを選択すると、"トランザクションのアクティブ化" プロパティは無効になります。

    • COM+ コンポーネントによって XLANG スケジュールを COM+ トランザクション コンテキストの中でアクティブにするには、[XLANG スケジュールを COM+ コンポーネントとして扱う] を選択します。このオプションを選択すると、トランザクションを XLANG スケジュール フローチャートに含めることができなくなり、[分岐] シェイプを使用した同時実行の実装が制限されます。[分岐] シェイプを使用する場合は、COM+ コンポーネント呼び出しが含まれているすべてのアクションを、単一の送信分岐に入れる必要があります。この制限は、XLANG スケジュール フローチャートのアクションに COM コンポーネント呼び出しが含まれている場合には適用されません。また、すべてのトランザクションの変更を、単一の送信分岐で実行する必要があります。

      このオプションを選択すると、"トランザクションのアクティブ化" プロパティが有効になります。

  • [トランザクションのアクティブ化] : このプロパティの既定の設定は、[サポートしない] です。
    • [サポートしない] : XLANG スケジュールがトランザクションをサポートしない場合は、これを選択します。

    • [サポートする] : XLANG スケジュールが COM+ トランザクションに参加する可能性がある場合は、これを選択します。

    • [必要] : XLANG スケジュールに COM+ トランザクションが必要な場合は、これを選択します。

    • [新しいトランザクションを要求する] : XLANG スケジュールが新しいトランザクションに参加する必要がある場合は、これを選択します。この設定が有効な場合、XLANG スケジューラ エンジンは呼び出し元のトランザクションと異なる新しいトランザクションを自動的に開始します。
  • [XLANG ID] : "XLANG ID" プロパティの詳細については、「フローチャート シェイプ」を参照してください。

関連項目

トランザクションの設計

長時間トランザクション

短時間トランザクション

ポート実装のトランザクション プロパティ

特定のトランザクション シェイプのトランザクション プロパティ


特定のトランザクション シェイプのトランザクション プロパティ

[ビジネス プロセス] ページの [トランザクション] シェイプを右クリックし、[プロパティ] をクリックすると、[トランザクションのプロパティ] ダイアログ ボックスが表示されます。[トランザクションのプロパティ] ダイアログ ボックスで、次のプロパティを構成できます。

  • [種類] : このプロパティは、選択した [トランザクション] シェイプで使用されるトランザクションの種類を決定します。このプロパティの既定の設定は、[短時間の DTC スタイル] です。
    • ACID トランザクションの 4 つのプロパティを持つ作業の単一論理単位として実行されるアクションの集合をトランザクションでグループ化する場合は、[短時間の DTC スタイル] を選択します。ACID トランザクションの詳細については、「トランザクションの設計」を参照してください。[短時間の DTC スタイル] トランザクションは、設計ページに灰色の影付きで表示されます。このオプションは、ネストしたトランザクションとスタンドアロン トランザクションで利用できます。ネストしたトランザクションが含まれている外側のトランザクションでこのオプションを選択することはできません。

    • 無期限にメッセージを送受信するアクションの集合をトランザクションでグループ化する場合は、[長時間] を選択します。[長時間] トランザクションを構成してネストしたトランザクションの集合をグループ化することもできますが、トランザクションのネストのレベルは 1 段階に制限されます。[長時間] トランザクションは、設計ページに黄色の影付きで表示されます。このオプションは、すべてのトランザクションで利用できます。

    • 指定した時間内に完了しない場合に [長時間] トランザクションを中断するには、[定刻トランザクション] を選択します。[定刻トランザクション] は、設計ページに青色の影付きで表示されます。[定刻トランザクション] オプションは、すべてのトランザクションで利用できます。
  • [スケジュールのステータスを永続化] : このプロパティでは、スケジュール ステータスをオーケストレーション データベースに保存するかどうかを指定します。このオプションは、[定刻トランザクション] と [長時間] で利用できます。保存状態の情報を必要としない場合は、このプロパティをオフにすればスループットが向上します。

  • [タイムアウト] : このプロパティは、トランザクションを中断するまでの実行時間を秒単位で決定します。このオプションは、[定刻トランザクション] と [短時間の DTC スタイル] のトランザクションで利用できます。

  • [再試行の回数] : このプロパティは、[短時間の DTC スタイル] トランザクションのプロセスが完了しなかった場合に、トランザクションのプロセスを実行する回数を決定します。再試行するたびに、アプリケーションのステータスはトランザクションのプロセスの開始ポイントにリセットされます。

  • [バックオフの時間] : このプロパティは、トランザクションを再試行する間隔を決定します。バックオフの時間は再試行の回数値と共に使用され、次にトランザクションが再試行を行うまでの待機時間が決定されます。バックオフ値は指数になっています。バックオフ値が 2 秒の場合、再試行の間隔は 2 秒、4 秒、8 秒、16 秒のようになります。計算式は B**R (B の R 乗) です。ここで、B はバックオフの時間、R は現在の再試行の回数を示します。あるトランザクション再試行のバックオフの時間が 180 秒よりも大きい場合、その XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。

  • [分離レベル] : 分離レベルは、同時に実行されるトランザクションのデータが、どの程度互いにアクセスできるかを決定します。このオプションは、[短時間の DTC スタイル] トランザクションでのみ利用できます。次の中から選択します。
    • [Serializable] を選択すると、選択したトランザクションが完了するまで同時に実行されるトランザクションはデータを変更できなくなります。これは、4 つの分離レベルの中で最も制限されたレベルです。

    • [Read Uncommitted] を選択すると、選択したトランザクションが完了する前に、同時に実行されるトランザクションがデータを変更できるようになります。これは、4 つの分離レベルの中で最も制限されないレベルです。

    • [Read Committed] を選択すると、同時に実行されるトランザクションのデータ変更がコミットされるまで、選択したトランザクションはこのデータにアクセスできなくなります。このオプションは Microsoft® SQL Server™ の既定の設定です。

    • [Repeatable Read] を選択すると、選択したトランザクションが完了するまで読み取りがロックされます。
  • [失敗時] : [<トランザクション> の失敗時] ページを有効にするには、[コードの追加] をクリックし、[有効にする] チェック ボックスをオンにして [OK] をクリックします。これによって、[<トランザクション> の失敗時] ページを使用して、選択したトランザクションの障害を処理する代替のビジネス プロセスを設計できます。このオプションは、すべてのトランザクションで利用できます。

  • [補正] : [<トランザクション> の補正] ページを有効にするには、[コードの追加] をクリックし、[有効にする] チェック ボックスをオンにして [OK] をクリックします。これによって、[<トランザクション> の補正] ページを使用して、既にコミットされたネストしたトランザクションで実行された作業の論理単位を元に戻す代替のビジネス プロセスを設計できます。このオプションは、ネストしたトランザクションでのみ利用できます。

注

  • ネストしたトランザクションを中断しても、外側のトランザクションが自動的に中断されることはありません。これによって、ネストしたトランザクションの障害から回復できるように外側のトランザクションを設計できます。しかし、ネストしたトランザクションの [<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが外側のトランザクションを中断するように設計されていると、ネストしたトランザクションの障害によって外側のトランザクションの障害が発生します。

関連項目

トランザクションの設計

長時間トランザクション

短時間トランザクション

XLANG スケジュール フローチャートのトランザクション プロパティ

ポート実装のトランザクション プロパティ


ポート実装のトランザクション プロパティ

COM コンポーネント バインド ウィザードとスクリプト コンポーネント バインド ウィザードの [ポート プロパティの詳細設定] ページで、COM コンポーネントと Windows スクリプト コンポーネントのトランザクション プロパティを構成できます。[ポート プロパティの詳細設定] ページは、コンポーネントのメソッドからエラーが返されたときに現在のトランザクションを中断するオプションを提供します。[ポート プロパティの詳細設定] ページで、次のトランザクションのプロパティを構成できます。

  • [トランザクションのサポート] : "トランザクションのサポート" プロパティは、コンポーネントがトランザクションを必要とするか、サポートするか、または無視するかどうかを指定します。
    • [無効] : このオプションを選択すると、コンポーネントは COM トランザクション管理を無視します。

    • [サポートしない] : このオプションを選択すると、コンポーネントはトランザクションに参加せず、ほかのコンポーネントのトランザクションを伝達しません。

    • [サポートする] : このオプションを選択すると、コンポーネントがバインドされているポートに接続するアクションが、トランザクションに含まれている場合に、そのコンポーネントがトランザクションに含まれます。そうでない場合は、コンポーネントにはトランザクションがありません。

    • [必要] : このオプションを選択すると、コンポーネントがバインドされているポートに接続するアクションが、トランザクションに含まれている場合に、そのコンポーネントがトランザクションに含まれます。コンポーネントがバインドされているポートに接続するアクションが、トランザクションに含まれていない場合は、コンポーネント用に新しいトランザクションが作成されます。

    • [新しいトランザクションを要求する] : このオプションを選択すると、コンポーネント用に新しいトランザクションが常に作成されます。

重要

  • BizTalk オーケストレーション デザイナは、XLANG スケジュール フローチャートで使用されている実装テクノロジのトランザクションの動作に依存します。XLANG スケジュール フローチャートに [トランザクション] シェイプが含まれている場合は、ビジネス プロセスのトランザクションの動作を提供したり強制することはありません。COM コンポーネント、メッセージ キュー、またはスクリプト コンポーネントがトランザクションでない場合は、XLANG スケジュール フローチャートで操作されたデータがトランザクションの場合のように変更されることはありません。

注

  • "トランザクション モデル" プロパティを設定して、XLANG スケジュールを COM+ コンポーネントとして扱う場合は、XLANG スケジュール フローチャートで [トランザクション] シェイプを使用しないでください。[トランザクション] シェイプを使用して、XLANG スケジュール フローチャートを XLANG スケジュールにコンパイルしようとすると、コンパイル処理が動作しなくなります。コンパイルする前に、XLANG スケジュール フローチャートからすべての [トランザクション] シェイプを削除する必要があります。

  • 複数のトランザクションで COM コンポーネントを使用する場合は、COM コンポーネントでステータスを保持しないようにするか、ステータスを保持して永続的にサポートする必要があります。

  • 複数のアクションが COM コンポーネントまたはスクリプト コンポーネントにバインドされているポートと通信する場合、これらのアクションが互いにネストしていない複数のトランザクション内にあると、コンポーネント インスタンスは新しいトランザクション コンテキストに入る前に破棄されてから再びインスタンス化されます。コンポーネントがステータスを保持し、永続的にサポートしている場合は、再アクティブ化されたときにステータスが復元されます。コンポーネントがステータスを保持し、永続的にサポートしていない場合は、ステータスが失われます。コンポーネントが別のアプリケーションでインスタンス化された場合に XLANG スケジューラ エンジンがコンポーネントを再アクティブ化できるのは、そのコンポーネントが永続化できるときだけです。永続化できないコンポーネントが別のアプリケーションでインスタンス化された場合、XLANG スケジューラ エンジンでコンポーネントを再びインスタンス化することはできません。XLANG スケジュールでエラーが発生します。

関連項目

トランザクションの設計

長時間トランザクション

短時間トランザクション

XLANG スケジュール フローチャートのトランザクション プロパティ

特定のトランザクション シェイプのトランザクション プロパティ


長時間トランザクション

長時間トランザクションは、「トランザクションの設計」で説明した 4 つの ACID 属性の 1 つである独立をサポートしません。長時間トランザクションのデータはロックされないので、ほかのプロセスまたはアプリケーションでデータを変更できます。データの一貫性を保つ必要がある場合は、ACID トランザクションを排他的に使用する必要があります。しかし、待ち時間が長い環境で ACID トランザクションを使用すると重大なスケーラビリティの問題が発生するため、XLANG スケジュール フローチャートでは長時間トランザクションをサポートしています。長時間トランザクションによって、データベースを長時間ロックする必要がなくなります。長時間トランザクションの間、メッセージは無期限に送受信されます。XLANG スケジュール フローチャートで記述されたビジネス プロセスの要件によっては、ビジネス プロセス全体 ([開始] シェイプと [終了] シェイプ以外) を長時間トランザクションで囲むことができます。

通常、長時間トランザクションには複数のネストした短時間トランザクションが含まれます。たとえば、単純な電信送金の場合、長時間トランザクションにネストした短時間トランザクションが含まれ、その中に次のアクションが含まれます。

  • 銀行口座からの現金引き出し

  • 電信送金処理の開始

次の図は、Wire transfer という長時間トランザクションの中でネストしている Send money という短時間トランザクションです。ネストしたトランザクションには単純な電信送金の 2 つのアクションが含まれています。Initiate the wire transfer アクションが完了すると、ビジネス プロセスはネストしたトランザクションの外に流れます。このときに、ネストしたトランザクションはコミットされ、銀行口座から現金が引き出されて送信先に送金されます。この時点で、ビジネス プロセスは外側のトランザクションの Wait for acknowledgement アクションに流れます。

このシナリオで、Wire transfer トランザクションは [定刻トランザクション] として構成されています。指定された時間内に送信者が現金受領の受信確認を受信しなければ、外側のトランザクションは中断されます。このとき、ビジネス プロセスはネストしたトランザクションの [Send money の補正] ページに流れます。ネストしたトランザクションは既にコミットされているので、送信者の口座に振り込めるアクションを代替のビジネス プロセスで記述する必要があります。[Send money の補正] ページに記述されたビジネス プロセスが実行されると、ビジネス プロセスは外側のトランザクションの [Wire transfer の失敗時] ページに流れます。このページには、外側のトランザクションの例外処理を記述するビジネス プロセスを含める必要があります。この例の場合、電子メールを担当者に送信して送金のステータスを通知するビジネス プロセスが考えられます。

関連項目

トランザクションの設計

フローチャート シェイプ

短時間トランザクション


短時間トランザクション

短時間トランザクションは、作業の単一論理単位として実行されるグループ化されたアクションの集合です。この作業の論理単位には、ACID トランザクションの 4 つのプロパティがあります。ACID トランザクションの詳細については、「トランザクションの設計」を参照してください。

関連項目

トランザクションの設計

フローチャート シェイプ

長時間トランザクション


例外処理

XLANG スケジューラ エンジンは、システム エラーをトラップできます。BizTalk オーケストレーション デザイナで、実行時の XLANG スケジュール エラーに対応する XLANG スケジュールを設計できます。ビジネス プロセスの一部を [トランザクション] シェイプで囲むと、エラーが発生した場合または要件を満たさない場合に実行される代替のビジネス プロセスを設計できます。

ここには次のトピックが含まれます。

  • システム エラー

  • アプリケーション エラー

関連項目

エラー処理プロパティの設定


システム エラー

XLANG スケジューラ エンジンの実行中に発生する可能性があるシステム エラーは、重要度のレベルによって 3 段階に分けられます。3 段階のレベルを重要度の低い順に示します。

  • XLANG スケジュールでトラップできるエラー

  • XLANG スケジュール インスタンスを終了させるエラー

  • XLANG スケジューラ エンジンの障害を発生させるエラー

ここには次のトピックが含まれます。

  • XLANG スケジュールでトラップできるエラー

  • XLANG スケジュール インスタンスを終了させるエラー

  • XLANG スケジューラ エンジンの障害を発生させるエラー


XLANG スケジュールでトラップできるエラー

XLANG スケジューラ エンジンは、次のシステム エラーをトラップできます。

  • 失敗を示す HRESULT を発生させる COM エラー。たとえば、アクセス許可が適切でない場合に XLANG スケジュールからメソッドが呼び出されると、COM はアクセス拒否のメッセージを返します。これは、COM バインドまたはスクリプト バインドに適用されます。

  • 登録されているサービスによるトランザクションの中断。たとえば、データベースへの接続が失われたときに、分散トランザクション コーディネータ (DTC) はトランザクションを中断します。また、メッセージ キュー サービスがメッセージをキューに入れることができないときに、メッセージ キュー サービスはトランザクションを中断します。

論理分岐を使用して失敗を示す HRESULT を処理するには、メソッド呼び出しから送信される _out メッセージを判断規則でテストする必要があります。HRESULT 値は _out メッセージの __Status__ フィールドに格納されています。

トランザクション障害プロセスを使用して失敗を示す HRESULT を処理するには、COM コンポーネント バインド ウィザードまたはスクリプト コンポーネント バインド ウィザードの最後のページで [メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] プロパティをオンにする必要があります。このプロパティは、アクションがトランザクションの中にある場合にだけ設定できます。

重要

  • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用するトランザクションを中断するかどうかを指定します。このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

メッセージ キューまたはBizTalk メッセージにおける実装テクノロジのエラー処理は、トランザクションの障害プロセスだけで実行できます。実行するには、メッセージ キュー バインド ウィザードの最後のページで [このキューはトランザクションを必要とする] チェック ボックスをオンにする必要があります(これは BizTalk メッセージでは自動的に行われます)。

注

  • メッセージ キューが正常な戻り値を返すアクションを送信した場合、メッセージが正常にキューに配置されたことを示します。メッセージが配信されたことを示すものではありません。

関連項目

アプリケーション エラー

XLANG スケジューラ エンジンの障害を発生させるエラー

XLANG スケジュール インスタンスを終了させるエラー

例外処理

システム エラー


XLANG スケジュール インスタンスを終了させるエラー

XLANG スケジュール インスタンスの障害を発生させるシステム エラーのうち、XLANG スケジュールでトラップできないエラーには、次のものがあります。

  • 送信待キューが存在しない。

  • スケジュールされたチャネルが存在しない。

  • メッセージからのデータ フローが、まだ到着していない。

関連項目

アプリケーション エラー

XLANG スケジュールでトラップできるエラー

XLANG スケジューラ エンジンの障害を発生させるエラー

例外処理

システム エラー


XLANG スケジューラ エンジンの障害を発生させるエラー

XLANG スケジューラ エンジンでトラップできないシステム エラーは、XLANG スケジューラ エンジンの障害を発生させ、同じ COM+ アプリケーションで実行されているすべての XLANG スケジュール インスタンスを巻き込むことがあります。これらのシステム エラーには、XLANG スケジューラ エンジンのプロセス領域で実行されているコンポーネントによるアクセス違反があります。XLANG スケジューラ エンジンはこれらのエラーをトラップしようとしますが、多くの場合、トラップできません。このようなエラーを起こしやすいコンポーネントがある場合、これを回避するために、そのコンポーネントを別の COM+ アプリケーションに配置できます。

関連項目

アプリケーション エラー

XLANG スケジュールでトラップできるエラー

XLANG スケジュール インスタンスを終了させるエラー

例外処理

システム エラー


アプリケーション エラー

XLANG スケジュール エラーの原因になるエラーを処理するには、次の 3 つの方法があります。

  • 論理分岐を使用する。

  • トランザクション中断プロセスを使用する。

  • タイムアウトを使用する。


論理分岐

判断と条件を使用して、あらゆるプロセス ページ ([ビジネス プロセス] ページ、[<トランザクション> の失敗時] ページ、または [<トランザクション> の補正] ページ) の処理フローを分岐させることができます。次の図は、メソッド実行の単純なテストです。

この例では、Clear_out メッセージに __Status__ というシステム フィールドがあります。条件 HRESULT Success の条件式は Clear_out.[__Status__] >= 0 です。負の HRESULT は失敗を示し、0 または正の HRESULT は成功を示します。このように判断と条件を使用して、任意のメッセージの任意のデータ フィールドの例外を、任意の条件の VBScript 式でテストできます。テストの対象は、HRESULT に限りません。

関連項目

例外処理

タイムアウト

トランザクション中断プロセス


トランザクション中断プロセス

BizTalk オーケストレーション デザイナでは、トランザクションを使用して、作業の単一論理単位として実行されるアクションの集合をグループ化できます。これによって、グループの中のすべてのアクションを完了させるか、どのアクションも完了させないようにします。ビジネス プロセスをトランザクションにグループ化することによって、BizTalk オーケストレーション デザイナは最高レベルの構造化と信頼性を提供します。

トランザクションの処理フローは、トランザクションが完了するか、中断イベントが発生するまで、通常どおりに実行されます。中断イベントは、次のような場合に発生する可能性があります。

  • 処理フローに [中断] シェイプが出現した場合。

  • ポート バインドで中断を発生させるように指定されている、失敗を示す HRESULT が返される場合。

  • あらゆるバインド テクノロジで、トランザクションを中断する障害イベントがシステム レベルで発生する可能性があります。たとえば、メッセージ キューがメッセージをキューに入れることができない場合があります。

  • XLANG スケジューラ エンジンにエラーが発生し、指定されたインスタンスのトランザクションが中断されることがあります。たとえば、DTC エラーがあります。

  • スケジュールを一時停止するときに、場合によっては、そのスケジュールのすべてのトランザクションを中断する必要があります。

  • トランザクション プロパティのタイムアウトが経過した場合。

中断が発生した場合、トランザクション グループの "再試行の回数" プロパティに設定された値に応じて、トランザクションを最初から再試行できます。指定された回数、トランザクションを再試行しても障害が回復しなければ、[<トランザクション> の失敗時] ビジネス プロセスが呼び出されます。この [<トランザクション> の失敗時] コードは、トランザクションの障害を処理するための構造化された場所を提供します。

[<トランザクション> の失敗時] コードでトランザクションの作業を元に戻す必要はありません。ポートがトランザクションのリソースにバインドされている場合は、分散トランザクション コーディネータがトランザクションに登録されているすべてのアクションをロールバックします。非トランザクションのリソースは、ロールバックされません。トランザクションが外側のトランザクションの中にネストされていて、このネストしたトランザクションが既にコミットされている場合、一連のビジネス プロセスはネストしたトランザクションの [<トランザクション> の補正] ビジネス プロセスに流れます。[<トランザクション> の補正] ビジネス プロセスは、[<トランザクション> の補正] ページに記述します。この代替のビジネス プロセスには、ネストしたトランザクションの作業を元に戻すアクションを含める必要があります。

[<トランザクション> の補正] コードまたは [<トランザクション> の失敗時] コードが完了すると、一連のビジネス プロセスは [ビジネス プロセス] ページの [トランザクション] シェイプの一番下から外に流れます。トランザクションの後で発生する一連のビジネス プロセスのアクションは、トランザクションが完了、または中断されたかどうかを明示的に示すものを受信しません。明示的に示すには、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページのメッセージ フィールドでフラグを設定します。

関連項目

例外処理

論理分岐

タイムアウト


タイムアウト

トランザクションのアクションが、予測されるメッセージを取引先から受信しない場合、この障害はアプリケーション エラーとして処理されます。このエラーをテストするには、定刻トランザクションを使用します。

たとえば、単純な電信送金の場合、定刻トランザクションにネストしたトランザクションが含まれ、その中に次のアクションが含まれます。

  • 銀行口座からの現金引き出し

  • 電信送金処理の開始

次の図は、Wire transfer という時間制限付きのトランザクションの中でネストしている Send money というトランザクションです。ネストしたトランザクションには単純な電信送金の 2 つのアクションが含まれています。Initiate the wire transfer アクションが完了すると、ビジネス プロセスはネストしたトランザクションの外に流れます。このときに、ネストしたトランザクションはコミットされ、銀行口座から現金が引き出されて送信先に送金されます。この時点で、ビジネス プロセスは外側のトランザクションの Wait for acknowledgement アクションに流れます。

このシナリオで、Wire transfer トランザクションは時間制限付きのトランザクションとして構成されています。指定された時間内に送信者が現金受領の受信確認を受信しなければ、外側のトランザクションは中断されます。このとき、ビジネス プロセスはネストしたトランザクションの [Send money の補正] ページに流れます。ネストしたトランザクションは既にコミットされているので、送信者の口座に振り込めるアクションを代替のビジネス プロセスで記述する必要があります。[Send money の補正] ページに記述されたビジネス プロセスが実行されると、ビジネス プロセスは外側のトランザクションの [Wire transfer の失敗時] ページに流れます。このページには、外側のトランザクションの例外処理を記述するビジネス プロセスを含める必要があります。この例の場合、電子メールを担当者に送信して送金のステータスを通知するビジネス プロセスが考えられます。

関連項目

例外処理

論理分岐

トランザクション中断プロセス


ビジネス プロセスの実装

[実装] ステンシルには、ビジネス プロセスにポートを実装するために使用できるテクノロジに対応する 4 つのシェイプが含まれています。各アクションはメッセージをポートに送信するか、メッセージをポートから受信するので、メッセージ送受信のセマンティックな意味は特定の実装テクノロジによって異なります。

[実装] シェイプの使用には、2 つの異なるプロセスが含まれます。最初のプロセスで、ポートを実装テクノロジにバインドします。概念的には、ポートはメッセージが送受信される抽象的な場所です。ポートを実装にバインドすることによって、ポートがバインドされる場所の種類が定義されます。2 番目のプロセスで、アクションをポートに接続します。このプロセスで、ポートとの間で送受信されるメッセージのスキーマが定義されます。

BizTalk オーケストレーション デザイナは、4 つの実装テクノロジをサポートします。

  • COM コンポーネント : このテクノロジを使用すると、同期通信ができます。

  • Windows スクリプト コンポーネント : このテクノロジを使用すると、同期通信ができます。

  • メッセージ キュー サービス : このテクノロジを使用すると、非同期通信ができます。

  • BizTalk メッセージ サービス : このテクノロジを使用すると、非同期通信ができます。

境界バーによって、BizTalk オーケストレーション デザイナの設計ページは左側のビジネス プロセス設計領域と右側の実装領域に分割されます。ポート バインド ウィザードを開くには、[実装] シェイプの 1 つを設計ページの境界バーの右側にドラッグします。この作業は、[ビジネス プロセス] ページ、[<トランザクション> の失敗時] ページ、および [<トランザクション> の補正] ページで実行できます。

注

  • BizTalk オーケストレーション デザイナではエンベロープを構成できません。そのため、フラット ファイルを BizTalk オーケストレーションに送信するには、BizTalk エディタを使用してフラット ファイルのコンテンツを XML に変換します。次に、この XML ファイルを BizTalk オーケストレーションに送信します。

ここには次のトピックが含まれます。

  • ポート実装について

  • 同期通信と非同期通信


ポート実装について

ポートとは、特定の実装を使用する名前付きの場所です。XLANG スケジュールでは、ポートは、同期通信と非同期通信をサポートし、XLANG スケジュールから、またはXLANG スケジュールへ、メッセージを渡すのに使用されます。

BizTalk オーケストレーション デザイナでは、メッセージが送信される場所またはメッセージが受信される場所、および通信アクションを実装するために使用されるテクノロジによって、ポートが定義されます。ポートは、XLANG スケジュールのビジネス プロセス フローのアクションの左側にあるアクションにバインドされ、必要なアクションを容易にするために使用される右側の実装テクノロジにバインドされます。場所はポートの名前によって一意に識別されます。

ポートの場所は、ポートを実装するために使用されるテクノロジによって多少異なります。次の表は、利用できるポート実装と、それぞれのポート実装に関連付けられている場所です。

ポート実装 | ポートの場所
COM コンポーネント | アクティブ化されたオブジェクトのインスタンスへのポインタ
Windows スクリプト コンポーネント | アクティブ化されたオブジェクトのインスタンスへのポインタ
メッセージ キュー | メッセージ キューへのキュー パス名
BizTalk メッセージ | 特定の BizTalk メッセージ チャネルのチャネル名

ポートは、次の 2 つの方法で記述できます。

  • 静的ポート : 静的ポートは、設計時にポートの場所と実装に関するすべての情報を XLANG スケジュールに提供する必要があります。XLANG スケジュールを作成するデザイナは、メッセージの送信先や受信側だけでなく、通信アクションを実装するためのテクノロジも知っておく必要があります。

  • 動的ポート : 動的ポートは、実行時に特定の場所の情報を XLANG スケジュールに提供する必要があります。動的ポート用の実装は設計時に選択しますが、このポートの場所は XLANG スケジュールが実行されるまでわかりません。動的ポートの場所は、ポートを参照する場所情報に渡されるメッセージによって提供されます。このメッセージは、このポート実装を使用する通信が使用される前に、XLANG スケジュールの処理フローのポイントに到着している必要があります。

    動的ポートを通信に使用する場合、XLANG スケジュールがそのアクションを完了しようとする前にポートへの参照が含まれているメッセージを受信しないと、エラーが生成されます。

静的ポートと動的ポートは両方とも同期通信と非同期通信のオプションを提供しますが、これらの通信のポート実装はポートを実装するために使用するテクノロジによって異なります。

どのポートも、静的ポートまたは動的ポートのどちらにもなりますが、すべてのポートが同期通信と非同期通信の両方を実装できるわけではありません。同期通信アクションを作成するには、COM コンポーネント ポート実装またはスクリプト コンポーネント ポート実装を使用する必要があります。非同期通信アクションを作成するには、メッセージ キュー ポート実装または BizTalk メッセージ ポート実装を使用する必要があります。

ここには次のトピックが含まれます。

  • 静的ポートと動的ポート

  • COM コンポーネント シェイプの使用

  • スクリプト コンポーネント シェイプの使用

  • メッセージ キュー シェイプの使用

  • BizTalk メッセージ シェイプの使用

注

  • XLANG スケジュールが、メッセージ キューまたは BizTalk メッセージによって実装されたポートから、非 XML テキスト ドキュメントを受信した場合、ドキュメントから復帰文字 (CR) が削除されます。MIME エンコード メッセージがスケジュールに送信され、そのスケジュールがのちにそのデータを送信するか別のところで使用しなければならない場合、スケジュールによって送信されるドキュメントは CR 文字を含まず、有効なMIME エンコード ドキュメントではないように見えます。これを避けるためには、ドキュメントに CR 文字を復元するためのカスタム コンポーネントを作成して、それをスケジュールから呼び出すようにします。

関連項目

同期通信と非同期通信


静的ポートと動的ポート

静的ポートと動的ポートの動作は、使用する実装の種類によって異なります。

COM コンポーネントまたは スクリプト コンポーネントを使用するポート実装

COM コンポーネントまたはスクリプト コンポーネントを使用するポート実装の場合、静的プロパティと動的プロパティは、コンポーネントのインスタンスを作成する方法を表します。

  • [静的] : 静的ポートを使用する XLANG スケジュールでは、XLANG スケジューラ エンジンがこのポート実装用に定義されているコンポーネントのインスタンスを作成します。

  • [動的] : 動的ポートを使用する XLANG スケジュールでは、XLANG スケジューラ エンジンはコンポーネントのインスタンスを作成しません。XLANG スケジュールは、別のアプリケーションがコンポーネントのインスタンスを作成するまで待機します。オブジェクト インスタンスは、メッセージ内のフィールドとして XLANG スケジュールに送信される必要があります。[データ] ページでは、そのメッセージ フィールドと、この実装を使用するポートのポート参照との間に、接続を描画する必要があります。XLANG スケジュールは、コンポーネントからのメソッド要求とメソッド応答の両方をインターセプトします。

[静的] と [動的] のほかに、3 番目の選択肢があります。

  • [インスタンスを作成しない] : インスタンスの作成をしないポートを使用する XLANG スケジュールでは、コンポーネントのインスタンスは作成されず、メソッド呼び出しのコードも実行されません。代わりに、XLANG スケジュールがメソッド要求の情報をインターセプトすると、この情報をメソッド応答として返します。メソッド呼び出しが回避されます。

メッセージ キューを使用するポート実装

メッセージ キューを使用するポート実装の場合、静的プロパティと動的プロパティは、静的キューと動的キューを表します。

  • [静的キュー] : 静的ポートは、既存のキューである静的キューを使用します。このキューは設計時に割り当てることができます。

    静的キューを使用する場合は、変更されない既存のキューを使用するか、XLANG スケジュールを実行するたびに同じキューの新しいインスタンスを作成するかのいずれかを選択できます。インスタンスごとのキューは、キューの名前に追加される一意な ID によって識別されます。

  • [動的キュー] : 動的ポートは、設計時にはわからない動的キューを使用します。動的キューの情報は、実行時にメッセージ フィールドで提供する必要があります。[データ] ページで、メッセージ フィールドからこのポートのポート参照へのリンクを作成する必要があります。キュー名を含むメッセージが到着すると、XLANG スケジュールは割り当てられたキューを使用できるようになります。キュー名を含むメッセージは、このポート実装を使用する通信が使用される前に到着する必要があります。

BizTalk メッセージを使用するポート実装

BizTalk メッセージを使用するポート実装の場合、静的プロパティと動的プロパティは、静的チャネルと動的チャネルを表します。動的チャネルは、メッセージを送信するときにだけ使用できます。動的チャネルを使用してメッセージを受信することはできません。

  • [静的チャネル] : 静的ポートは、既存のチャネルである静的チャネルを使用します。このチャネルは設計時に割り当てることができ、変更できません。

  • [動的チャネル] : 動的ポートは、ドキュメントを設計時にはわからない送信先に送信します。この送信先の値は、実行時にメッセージ フィールドで指定しなければなりません。[データ] ページで、メッセージ フィールドからこのポートのポート参照へのリンクを作成する必要があります。送信先の値があるメッセージが到着すると、XLANG スケジュールはそのドキュメントを、オープンな送信先ポートに関連付けられているメッセージ チャネルに送信します。次に、このポートはメッセージを実行時に指定される送信先の値に送信します。メッセージ チャネルを [既定の組織] に設定し、送信するメッセージと同じドキュメント定義を指定しなければなりません。送信先の値を含むメッセージは、このポート実装を使用する通信が使用される前に到着する必要があります。

動的チャネルを使用するポートによって、XLANG スケジュールはメッセージの送信先を実行時に決定できるため、設計時に送信先を定義することは要求されません。このプロパティは、XLANG スケジュールがメッセージを BizTalk メッセージ サービスに渡すときに使用するチャネルを定義します。

動的チャネルと、BizTalk メッセージ マネージャで構成するオープン チャネルを混同しないでください。オープン チャネルを使用すると、ドキュメントの情報またはドキュメントで送信されるパラメータで送信元組織を実行時に決定できます。このプロパティは、ドキュメントの送信元を定義します。オープン チャネルの詳細については、「チャネルについて」を参照してください。

動的チャネルを使用するポートに渡されるメッセージは、チャネル情報を BizTalk メッセージ サービスに渡すときに、オープン チャネルとオープンでないチャネルのどちらでも指定できます。

注

  • 動的チャネルを使用している場合は、アドレス検証またはカスタム エラー処理を実行するためのアクションをスケジュールに追加することをお勧めします。こうすることによって、無効なアドレス形式 (たとえば、間違ったアドレスや、HTTP、HTTPS、SMTP 以外のプロトコルのアドレス) によってデータが失われる可能性をなくすことができます。

関連項目

ポートの実装

同期通信と非同期通信

チャネルについて

BizTalk メッセージ シェイプの使用

COM コンポーネント シェイプの使用

メッセージ キュー シェイプの使用

スクリプト コンポーネント シェイプの使用


COM コンポーネント シェイプの使用

[COM コンポーネント] シェイプを使用すると、既存のコンポーネントまたはアプリケーションで XLANG スケジュールのアクションを実行できます。COM テクノロジは同期をとるため、アクションが実行されるときは、常に双方向のメッセージのフローがあります。これに対して、非同期テクノロジのメッセージのフローは、一方向です。

XLANG スケジューラ エンジンは、[アクション] シェイプを使用してメッセージの送受信をサポートします。BizTalk オーケストレーション デザイナでポートを COM コンポーネントにバインドするときに、ポートはシステムに登録されている COM コンポーネントで実装されたインターフェイスにバインドされます。

ポートに接続された送信アクションは、XLANG スケジューラ エンジンによる特定のメソッド呼び出しの起動を表します。<入力> パラメータと <入出力> パラメータがポートに送信されます。戻り値として、メソッド呼び出しの <入出力> パラメータと <出力> パラメータで定義されたスキーマのメッセージをポートから受信します。メソッド呼び出しは、ポートにバインドされたインターフェイスでサポートされます。

ポートに接続された受信アクションは、外部アプリケーションがポートに対するメソッド呼び出しを作成するまで待機します。<入力> パラメータと <入出力> パラメータでポートが受信するメッセージのスキーマを定義し、<入出力> パラメータと <出力> パラメータでポートから送信するメッセージのスキーマを定義します。

ポートに接続されて COM コンポーネントにバインドされたアクションごとに、2 つのメッセージが交換されます。メッセージによって、起動されたインターフェイスのメソッドが識別されます。メッセージのスキーマは、メソッドの署名の <入力> パラメータと <入出力> パラメータ (および、<入出力> パラメータと <出力> パラメータ) に対応します。コンポーネントのタイプ ライブラリにアクセスできるので、BizTalk オーケストレーション デザイナは、ユーザーに情報を問い合わせずに、自動的にこれらのメッセージのスキーマを構築できます。

重要

  • 長時間のビジネス プロセスを実装するときは、COM コンポーネントの使用に注意が必要です。ステータスを保持するコンポーネントを XLANG スケジュールで使用する場合は、IPersistStream インターフェイスまたは IPersistStreamInit インターフェイスのいずれかを使用して保存できるコンポーネントを使用することをお勧めします。これによって、XLANG スケジュールはスケジュールのステータスと共にコンポーネントのステータスも格納できます。XLANG スケジュールは、ステータスを保持し、信頼性の高い状態で長時間実行できる必要があります。ステータスを保持しないコンポーネントを使用する場合は、XLANG スケジュールがステータス復元されるたびに、コンポーネントの新しいインスタンスが作成されます。ただし、ステータスを保持しないコンポーネントを使用する場合は、スケジュールの出力に影響を与えないようにする必要があります。

バインドは、ポートを実装するテクノロジを指定する処理です。COM コンポーネント バインド ウィザードは、以下のページで構成されています。

[COM コンポーネント バインド ウィザードへようこそ]

[COM コンポーネント バインド ウィザードへようこそ] ページで、実装を定義するポートを作成し、名前を付けることができます。

[静的または動的な通信]

[静的または動的な通信] ページで、コンポーネントのインスタンスを作成する方法を定義できます。次の表は、静的通信と動的通信の設定の一覧と説明を示しています。

[静的または動的な通信] | 説明
[静的] | XLANG スケジューラ エンジンに対して、実装を完了させるために必要なすべての情報を設計時に指定できる場合は、このオプションを選択します。
[動的] | 実行時に実装を完了するための追加の情報が必要な場合は、このオプションを選択します。
[インスタンスを作成しない] | コンポーネントをアクティブにしないで、メソッド呼び出しを使用して XLANG スケジュールがデータを受信できるようにするには、このオプションを選択します。[インスタンスを作成しない] を選択すると、このコンポーネントへのメソッド呼び出しはインターセプトされ、XLANG スケジューラ エンジンは引数を格納し、呼び出しは呼び出し元に戻ります。コンポーネントはインスタンスを作成しません。

[クラス情報]

[クラス情報] ページで、登録済みコンポーネントの一覧またはモニカからクラスを選択できます。

[インターフェイス情報]

[インターフェイス情報] ページで、使用するインターフェイスを選択できます。このページは、選択したクラスに複数のインターフェイスが含まれている場合にだけ表示されます。Visual Basic コンポーネントのインターフェイスは、常に 1 つです。

[メソッド情報]

[メソッド情報] ページで、使用するメソッドを選択できます。このページは、選択したクラスに複数のメソッドが含まれている場合にだけ表示されます。

[ポート プロパティの詳細設定]

[ポート プロパティの詳細設定] ページで、セキュリティ、トランザクションのサポート、ステータス管理のサポート、およびエラー処理を構成できます。

[COM コンポーネント] シェイプのステータス管理のサポート プロパティによって、次のことができます。

  • が開始する前とトランザクションが完了した後に、XLANG スケジュールのステータスを永続化します。これによって永続性が提供され、コミットされたすべての変更が恒久的にシステムに反映されます。また、障害が発生した場合にトランザクションを再試行することもできます。

  • メッセージの到着を待機している間、XLANG スケジューラ エンジンは XLANG スケジュールのステータス退避を実行し、その後ステータス復元を実行することができるので、インスタンス管理が最適化されます。

[COM コンポーネント] シェイプを使用して、受信したメッセージの認証済みユーザー情報を要求できます。

[セキュリティ]

次の表は、送信者 ID の確認設定の一覧と説明を示しています。

送信者 ID の確認 | 説明
[必要なし] | XLANG スケジュールが送信者の ID を確認せずにメッセージを受信できるようにする場合は、このオプションを選択します。
[省略可] | コンポーネントがメッセージを受信したときに、XLANG スケジューラ エンジンが送信者を識別するようにする場合は、このオプションを選択します (情報が利用可能な場合)。
[必須] | XLANG スケジューラ エンジンが送信者を識別できないメッセージを受信しないようにする場合は、このオプションを選択します。

[トランザクションのサポート]

次の表は、トランザクションのサポート設定の一覧と説明を示しています。

[トランザクションのサポート] | 説明
[無効] | すべての非 COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントは COM トランザクション管理を無視します。
[サポートしない] | すべての COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントはトランザクションに参加せず、ほかのコンポーネントのトランザクションを伝達しません。
[サポートする] | すべての COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントがバインドされているポートにトランザクションが関連付けられている場合に、そのコンポーネントがトランザクションに含まれます。そうでない場合は、コンポーネントにはトランザクションがありません。
[必須] | すべての COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントがバインドされているポートにトランザクションが関連付けられている場合に、そのコンポーネントがトランザクションに含まれます。コンポーネントがバインドされているポートに関連付けられているトランザクションがない場合は、コンポーネント用に新しいトランザクションが作成されます。
[新しいトランザクションを要求する] | すべての COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネント用に新しいトランザクションが常に作成されます。

[ステータス管理のサポート]

次の表は、ステータス管理のサポート設定の一覧と説明を示しています。

[ステータス管理のサポート] | 説明
[ステータスを保持しない] | XLANG スケジューラ エンジンは、コンポーネント インスタンスがステータス退避されると、そのコンポーネント インスタンスを終了します。この設定を選択した場合は、スケジュールがステータス復元されるときに、XLANG スケジューラ エンジンは必要に応じて新しいコンポーネント インスタンスを作成します。
[ステータスを保持し、永続的にサポートしない] | XLANG スケジューラ エンジンに対し、コンポーネント インスタンスの実行を継続するように要求します。アプリケーションがステータス退避されている間にシステムに障害が発生すると、このコンポーネントに保持されていたステータスはすべて失われます。
[ステータスを保持し、永続的にサポートする] | XLANG スケジューラ エンジンは、コンポーネント インスタンスをメモリから削除し、ステータス退避中にコンポーネントの IPersistStream または IPersistStreamInit のいずれかを呼び出すことでメモリに復元します。ステータス復元中に、もう一度メモリに復元します。

[エラー処理]

コンポーネントのメソッドからエラーが返されたときに、XLANG スケジューラ エンジンでトランザクションを中断する場合は、[エラー処理] の [メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンにします。

注

  • アクションが COM コンポーネントにバインドされているポートと通信し、指定されたメソッドがコンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

  • BizTalk オーケストレーション デザイナは、IDispatch から派生したパラメータを含む COM コンポーネント メソッドへのバインドをサポートしません。しかし、BizTalk オーケストレーション デザイナは、IDispatch 型のパラメータを含む COM コンポーネントメソッドへのバインドはサポートします。

  • 名前の衝突が起こる可能性があるので、システム フィールドの名前を COM コンポーネントのパラメータ名として使用してはいけません。詳細については、「システム フィールド」を参照してください。

  • アプリケーションに、IUnknown インターフェイスを使用した XLANG スケジュールの COM コンポーネントへの参照がある場合、XLANG スケジュール インスタンスがステータス退避およびステータス復元されると、その参照は無効になります。永続化できるすべての COM コンポーネントは、ステータス退避されたときと同じステータスに正しくステータス復元されます。しかし、インターフェイスは新しいアドレスに割り当てられます。これは、正常な動作です。1 つの XLANG スケジュール インスタンスの複数のメッセージ フィールドに、同じ COM コンポーネントへのポインタが含まれていて、そのスケジュールがステータス退避される場合は、ステータス復元された後、これらのメッセージ フィールドには 1 つの COM コンポーネントへのポインタが含まれます。しかし、この COM コンポーネントは、ステータス退避の前のコンポーネントと同じではありません。ステータス退避の前に存在していた COM コンポーネントに似た、新しい COM コンポーネントが作成されます。元の COM コンポーネントが永続化できる場合は、新しい COM コンポーネントのステータスは、ステータス退避の前の元の COM コンポーネントのステータスと同じです。

  • コンポーネントの一意性は、繰り返しループを超えると維持されません。繰り返しループの中のあるメッセージに COM コンポーネントへのポインタを持つフィールドが含まれていて、その繰り返しループの外の別のメッセージに同じ COM コンポーネントへのポインタを持つフィールドが含まれている場合、ステータス退避とステータス復元の後でこれら 2 つのメッセージ フィールドに格納されるポインタは 1 つの COM コンポーネントへのポインタではなくなります。2 つのメッセージ フィールドに格納されるポインタは、元の COM コンポーネントに似た別の 2 つの COM コンポーネントへのポインタです。元の COM コンポーネントが永続化できる場合は、2 つの新しい COM コンポーネントは、ステータス退避の前の元の COM コンポーネントのステータスと同じステータスを保持します。

  • ポートを Microsoft Visual Basic のコンポーネントとバインドするときは、Visual Basic がデバッグ モードでないことを確認してください。Visual Basic がデバッグ モードであるときは、コンポーネントは COM コンポーネント バインド ウィザードにリストされません。

関連項目

静的ポートと動的ポート

同期通信と非同期通信

BizTalk メッセージ シェイプの使用

メッセージ キュー シェイプの使用

メソッド通信ウィザードの使用

スクリプト コンポーネント シェイプの使用


スクリプト コンポーネント シェイプの使用

[スクリプト コンポーネント] シェイプを使用すると、既存の Windows スクリプト コンポーネントで XLANG スケジュールのアクションを実行できます。[スクリプト コンポーネント] は同期をとるため、アクションが実行されるときは、常に双方向のメッセージのフローがあります。これに対して、非同期テクノロジのメッセージのフローは、一方向です。

ポートに接続された送信アクションは、XLANG スケジューラ エンジンによる特定のメソッド呼び出しの起動を表します。<入力> パラメータと <入出力> パラメータがポートに送信されます。戻り値として、メソッド呼び出しの <入出力> パラメータと <出力> パラメータで定義されたスキーマのメッセージをポートから受信します。メソッド呼び出しは、ポートにバインドされたインターフェイスでサポートされます。

ポートに接続された受信アクションは、外部アプリケーションがポートに対するメソッド呼び出しを作成するまで待機します。<入力> パラメータと <入出力> パラメータでポートが受信するメッセージのスキーマを定義し、<入出力> パラメータと <出力> パラメータでポートから送信するメッセージのスキーマを定義します。

ポートに接続されてスクリプト コンポーネントにバインドされたアクションごとに、2 つのメッセージが交換されます。メッセージによって、起動されたインターフェイスのメソッドが識別されます。メッセージのスキーマは、メソッドの署名の <入力> パラメータと <入出力> パラメータ (および、<入出力> パラメータと <出力> パラメータ) に対応します。コンポーネントのタイプ ライブラリにアクセスできるので、BizTalk オーケストレーション デザイナは、ユーザーに情報を問い合わせずに、自動的にこれらのメッセージのスキーマを構築できます。

XLANG スケジューラ エンジンは、メソッドが戻るまで待機してからビジネス プロセスを続行します。メッセージを送信するために、XLANG スケジューラ エンジンは指定された Windows スクリプト コンポーネントのメソッドを起動します。

新しいスクリプト コンポーネント バインドを作成するには、BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [スクリプト コンポーネント] シェイプを境界バーの右側にドラッグします。既存のスクリプト コンポーネントを編集するには、[スクリプト コンポーネント] シェイプを右クリックし、[プロパティ] をクリックします。どちらの操作でも、スクリプト コンポーネント バインド ウィザードが起動します。バインドは、ポートを実装するテクノロジを指定する処理です。スクリプト コンポーネント バインド ウィザードは、以下のページで構成されています。

[スクリプト コンポーネント バインド ウィザードへようこそ]

[スクリプト コンポーネント バインド ウィザードへようこそ] ページで、実装を定義するポートを作成し、名前を付けることができます。

[静的または動的な通信]

[静的または動的な通信] ページで、コンポーネントのインスタンスを作成する方法を定義できます。次の表は、静的通信と動的通信の設定の一覧と説明を示しています。

[静的または動的な通信] | 説明
[静的] | XLANG スケジューラ エンジンに対して、実装を完了させるために必要なすべての情報を設計時に指定できる場合は、このオプションを選択します。
[動的] | 実行時に実装を完了するための追加の情報が必要な場合は、このオプションを選択します。
[インスタンスを作成しない] | コンポーネントをアクティブにしないで、メソッド呼び出しを使用して XLANG スケジュールがデータを受信できるようにするには、このオプションを選択します。[インスタンスを作成しない] を選択すると、このコンポーネントへのメソッド呼び出しはインターセプトされ、XLANG スケジューラ エンジンは引数を格納し、呼び出しは呼び出し元に戻ります。コンポーネントはインスタンスを作成しません。

[スクリプト ファイルの指定]

[スクリプト ファイルの指定] ページで、使用する Windows スクリプト コンポーネント (.wsc) ファイルへのパスを入力できます。

[コンポーネントのインスタンス作成情報]

[コンポーネントのインスタンス作成情報] ページで、XLANG スケジューラ エンジンがモニカまたは Prog ID のどちらかを使用してスクリプト コンポーネントのインスタンスを作成することを指定できます。

[メソッド情報]

[メソッド情報] ページで、選択したクラスに属するメソッドを選択できます。

[ポート プロパティの詳細設定]

[ポート プロパティの詳細設定] ページで、セキュリティ、トランザクションのサポート、およびエラー処理を構成できます。[スクリプト コンポーネント] シェイプを使用して、受信したメッセージの認証済みユーザー情報を要求できます。

[セキュリティ]

次の表は、送信者 ID の確認設定の一覧と説明を示しています。

送信者 ID の確認 | 説明
[必要なし] | XLANG スケジュールが送信者の ID を確認せずにメッセージを受信できるようにする場合は、このオプションを選択します。
[省略可] | コンポーネントがメッセージを受信したときに、XLANG スケジューラ エンジンが送信者を識別するようにする場合は、このオプションを選択します (情報が利用可能な場合)。
[必須] | XLANG スケジューラ エンジンが送信者を識別できないメッセージを受信しないようにする場合は、このオプションを選択します。

[トランザクションのサポート]

次の表は、トランザクションのサポート設定の一覧と説明を示しています。

[トランザクションのサポート] | 説明
[無効] | すべての非 COM+ コンポーネントで使用します。このオプションを選択すると、コンポーネントは COM トランザクション管理を無視します。
[サポートしない] | コンポーネントが COM+ コンポーネントとしてインストールされている場合にのみ使用できます。このオプションを選択すると、コンポーネントはトランザクションに参加せず、ほかのコンポーネントのトランザクションを伝達しません。
[サポートする] | コンポーネントが COM+ コンポーネントとしてインストールされている場合にのみ使用できます。このオプションを選択すると、コンポーネントがバインドされているポートにトランザクションが関連付けられている場合に、そのコンポーネントがトランザクションに含まれます。そうでない場合は、コンポーネントにはトランザクションがありません。
[必須] | コンポーネントが COM+ コンポーネントとしてインストールされている場合にのみ使用できます。このオプションを選択すると、コンポーネントがバインドされているポートにトランザクションが関連付けられている場合に、そのコンポーネントがトランザクションに含まれます。コンポーネントがバインドされているポートに関連付けられているトランザクションがない場合は、コンポーネント用に新しいトランザクションが作成されます。
[新しいトランザクションを要求する] | コンポーネントが COM+ コンポーネントとしてインストールされている場合にのみ使用できます。このオプションを選択すると、コンポーネント用に新しいトランザクションが常に作成されます。

[エラー処理]

コンポーネントのメソッドからエラーが返されたときに、XLANG スケジューラ エンジンで中断プロセスを起動する場合は、[エラー処理] の [メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンにします。[<トランザクション> の失敗時] ページと [<トランザクション> の補正] ページを使用するには、XLANG スケジューラ エンジンのこのオプションをオンにする必要があります。このオプションがオフの場合は、どちらのページで定義されたエラー回復プロセスも実行されません。

重要

  • Windows スクリプト コンポーネントを使用する場合、そのコンポーネントは次の規則に従っている必要があります。
    • 引数宣言は、値ではなく参照で行う必要があります。

    • Visual Basic スクリプトのサブルーチンはサポートされていません。関数だけがサポートされています。

    • 1 つの .wsc ファイル内で複数のコンポーネントは使用できません。

注

  • アクションがスクリプト コンポーネントにバインドされているポートと通信し、指定されたメソッドがスクリプト コンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

  • XLANG スケジューラ エンジンで実行されているスクリプト コンポーネントは、XLANG スケジューラ エンジンと Windows スクリプト ホストの両方がシャットダウンされるまで変更できません。

関連項目

静的ポートと動的ポート

同期通信と非同期通信

BizTalk メッセージ シェイプの使用

COM コンポーネント シェイプの使用

メッセージ キュー シェイプの使用

メソッド通信ウィザードの使用


メッセージ キュー シェイプの使用

[メッセージ キュー] シェイプを使用すると、XLANG スケジュールは、キューを使用して疎結合されている別の XLANG スケジュール (またはアプリケーション) と通信できます。XLANG スケジュールとアプリケーションの間で通信できるようにするには、メッセージをキューに送信してから読み出します。1 つの XLANG スケジュールでは、[メッセージ キュー] シェイプにバインドされた複数のポートを使用できます。

ポートは [メッセージ キュー] シェイプにバインドされるときに、メッセージ キューにもバインドされます。ポートは、名前付きキューまたはインスタンスごとのキューにバインドできます。ポートがインスタンスごとのキューにバインドされた場合は、この XLANG スケジュールのインスタンスごとに一意なキューが作成され、使用されます。インスタンスごとのキューは、XLANG スケジュールが XLANG スケジュール インスタンスごとに別のキューを使用するための便宜的な方法です。

メッセージ キューにバインドされたポートにアクションが接続されるときに、そのアクションによって送信または受信されるメッセージが定義されていなければなりません。キューには複数の種類のメッセージを格納できるので、メッセージの種類はアクションが受信するメッセージの種類を識別するときに役立ちます。[送信] アクションの間に、メッセージがキューに書き込まれると、メッセージのラベル プロパティにメッセージの種類のマークが付けられます。

[メッセージ キュー] シェイプは、メッセージを送受信するために使用するメッセージ キュー サービスを表します。メッセージを受信するために、XLANG スケジューラ エンジンは、使用するキューの名前とそのメッセージに含まれる XML スキーマのルート要素名を必要とします。メッセージを送信するには、メッセージの送信に使用するキューの名前が必要です。

メッセージ キューを使用してメッセージを受信するように XLANG スケジュール インスタンスを構成した場合は、XML 通信ウィザードを使用して送信先書式を XML または文字列として指定できます。

新しいメッセージ キュー バインドを作成するには、BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [メッセージ キュー] シェイプを境界バーの右側にドラッグします。既存のメッセージ キュー実装を編集するには、[メッセージ キュー] シェイプを右クリックし、[プロパティ] をクリックします。どちらの操作でも、メッセージ キュー バインド ウィザードが起動します。バインドは、ポートを実装するテクノロジを指定する処理です。メッセージ キュー バインド ウィザードは、以下のページで構成されています。

[メッセージ キュー バインド ウィザードへようこそ]

[メッセージ キュー バインド ウィザードへようこそ] ページで、実装を定義するポートを作成し、名前を付けることができます。または、既存の未バインド ポートを選択することができます。

[静的または動的キューの情報]

[静的または動的キューの情報] ページで、メッセージ キューを設計時または実行時に定義するように指定できます。次のオプションのいずれかを選択します。

  • 設計時にキュー情報を指定できる場合は、[静的キュー] を選択します。

  • XLANG スケジューラ エンジンが外部の送信元から実行時に情報を取得してキュー名を決定する場合は、[動的キュー] を選択します。

[キュー情報]

[キュー情報] ページで、新しいキューを作成するか、既存のキューを指定することができます。次のオプションのいずれかを選択します。

  • XLANG スケジューラ エンジンで、XLANG スケジュール インスタンスごとにインスタンスごとのキューを作成する場合は、[すべてのインスタンスごとに新しいキューを作成する] を選択します。

  • XLANG スケジューラ エンジンで既存のキューを使用する場合は、[すべてのインスタンスに対して既存のキューを使用する] を選択します。

[ポート プロパティの詳細設定]

[ポート プロパティの詳細設定] ページで、セキュリティを構成し、トランザクションのサポートを有効にするかどうかを選択できます。[メッセージ キュー] シェイプを使用して、受信したメッセージの認証済みユーザー情報を要求できます。

[セキュリティ]

次の表は、送信者 ID の確認設定の一覧と説明を示しています。

送信者 ID の確認 | 説明
[必要なし] | XLANG スケジュールが送信者の ID を確認せずにメッセージを受信できるようにする場合は、このオプションを選択します。
[省略可] | コンポーネントがメッセージを受信したときに、XLANG スケジューラ エンジンが送信者を識別するようにする場合は、このオプションを選択します (情報が利用可能な場合)。
[必須] | XLANG スケジューラ エンジンが送信者を識別できないメッセージを受信しないようにする場合は、このオプションを選択します。

[Windows のグループ名またはユーザー名を使用して、キューを制御する] チェック ボックスのオンとオフを切り替えることもできます。このチェックボックスをオンにした場合は、キューへのメッセージの書き込みを許可するユーザーまたはグループの名前を入力します。このオプションを使用できるのは、静的キューを使用している場合だけです。

[トランザクションのサポート]

[トランザクションのサポート] の [このキューはトランザクションを必要とする] チェック ボックスをオンにすると、トランザクションのサポートが有効になります。

注

  • 現在サポートされているキューの名前形式では、別のコンピュータ上のキューにリモート アクセスできません。XLANG スケジュールが別のコンピュータ上のアプリケーションと通信する場合、プライベート キューの代わりにパブリック キューを使用してください。

  • アクションがメッセージ キューにバインドされているポートと通信し、バインドに指定されたキューがスクリプト コンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

  • XLANG スケジューラ エンジンが、キューがトランザクション用かどうかを判断できることは重要です。トランザクション コンテキストのキューにメッセージが送信される場合、XLANG スケジューラ エンジンはトランザクションを使用してキューと通信するかどうかを認識する必要があります。[このキューはトランザクションを必要とする] チェック ボックスをオンにしてポート バインドを構成した場合、実行時にキューがトランザクション用でないと判断されると、XLANG スケジューラ エンジンは出力して終了します。

関連項目

静的ポートと動的ポート

同期通信と非同期通信

BizTalk メッセージ シェイプの使用

COM コンポーネント シェイプの使用

スクリプト コンポーネント シェイプの使用

XML 通信ウィザードの使用


BizTalk メッセージ シェイプの使用

[BizTalk メッセージ] シェイプは、BizTalk オーケストレーション サービスと BizTalk メッセージ サービスとの間でメッセージを交換するために使用する BizTalk メッセージ サービスを表します。メッセージを受信するために、XLANG スケジューラ エンジンは、BizTalk メッセージ サービスがドキュメントを受信するために使用する HTTP URL アドレス、チャネルの名前、および送信ドキュメント定義のメッセージの種類を必要とします。ドキュメントを受信して XLANG スケジュールをアクティブにするには、ドキュメント定義のメッセージの種類だけが必要です。メッセージを送信するには、チャネルの名前と、受信ドキュメント定義のメッセージの種類が必要です。BizTalk オーケストレーション サービスと BizTalk メッセージ サービス間のメッセージ交換の詳細については、「BizTalk サービスの統合」を参照してください。

重要

  • メッセージを受信したときに新しい XLANG スケジュールがアクティブになるようにポートを構成する場合、次の制限を考慮する必要があります。
    • メッセージを受信したときに XLANG スケジュールをアクティブにするために使用できるポートは、1 つのスケジュール内で 1 つだけです。

    • このポートで受信できるアクションは 1 つだけです。

    • この 1 つのアクションは、ループ本体に含められません。

    • このポートのポート参照からスケジュール内のほかのメッセージへのデータ フローの接続は、描画できません。

新しい BizTalk メッセージ バインドを作成するには、BizTalk オーケストレーション設計ページで、[実装] ステンシルの [BizTalk メッセージ] シェイプを境界バーの右側にドラッグします。既存の BizTalk メッセージ実装を編集するには、[BizTalk メッセージ] シェイプを右クリックし、[プロパティ] をクリックします。どちらの操作でも、BizTalk メッセージ バインド ウィザードが起動します。バインドは、ポートを実装するテクノロジを指定する処理です。BizTalk メッセージ バインド ウィザードは、次のページで構成されています。

[BizTalk メッセージ バインド ウィザードへようこそ]

[BizTalk メッセージ バインド ウィザードへようこそ] ページで、実装を定義するポートを作成し、名前を付けることができます。または、既存の未バインド ポートを選択することができます。

[通信の方向]

[通信の方向] ページで、ポートをメッセージを送信または受信するように構成することを指定できます。

[静的または動的チャネルの情報]

[静的または動的チャネルの情報] ページは、[BizTalk メッセージ バインド ウィザードへようこそ] ページで [送信] を選択した場合にだけ表示されます。[静的または動的チャネルの情報] ページで、XLANG スケジューラ エンジンが設計時に定義される [静的チャネル]、または実行時に定義される [動的チャネル] を使用することを指定できます。

[XLANG スケジュールのアクティブ化情報]

[XLANG スケジュールのアクティブ化情報] ページで、この受信アクションで XLANG スケジュール インスタンスがアクティブになるかどうかを指定します。[はい] を選択すると、BizTalk メッセージ バインド ウィザードは終了します。[いいえ] を選択すると、[チャネル情報] ページが表示されます。

[チャネル情報]

[チャネル情報] ページで、チャネルの名前と、BizTalk メッセージ サービスがドキュメントを受信するために使用する HTTP URL アドレスを指定できます。

注

  • アクションが BizTalk メッセージにバインドされているポートと通信し、バインドの指定されたチャネルがスクリプト コンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

  • 単一のトランザクションに送信受信別々の BizTalk メッセージ バインドを含めると、デッドロック状態になりトランザクションが失敗する場合があります。

  • BizTalk メッセージ サービスで送受信される XLANG スケジュールによって処理されるメッセージに関連するアクション イベントは、追跡データベースで追跡できます。詳細については、「追跡データベースでの XLANG スケジュール イベントの追跡」を参照してください。

関連項目

静的ポートと動的ポート

同期通信と非同期通信

COM コンポーネント シェイプの使用

メッセージ キュー シェイプの使用

スクリプト コンポーネント シェイプの使用

XML 通信ウィザードの使用


同期通信と非同期通信

COM コンポーネント実装またはスクリプト コンポーネント実装へのすべての通信は同期です。COM コンポーネントまたはスクリプト コンポーネントの実装を使用するポートへの通信フローを作成する場合は、メソッド通信ウィザードを使用する必要があります。

未バインド ポート、メッセージ キュー実装、または BizTalk メッセージ実装へのすべての通信は、非同期です。メッセージ キューまたは BizTalk メッセージの実装を使用するポートへの通信フローを作成する場合、および未バインド ポートへの通信フローを作成する場合は、XML 通信ウィザードを使用する必要があります。

次の図と文字は、発生する可能性がある 4 つの通信アクションに対する XLANG スケジュールの動作を説明しています。

  1. 同期受信アクション
    1. XLANG スケジュールは、別のアプリケーションがメソッド要求を送信し、コンポーネントのインスタンスを作成するまで待機します。

    2. メソッド要求をインターセプトします。

    3. コンポーネントがメソッド応答を返すまで待機します。

    4. メソッド応答をインターセプトします。

    5. ビジネス プロセス フローの次のアクションを続行します。
  2. 同期送信アクション
    1. XLANG スケジュールは、メソッド要求を開始し、コンポーネントのインスタンスを作成します。

    2. コンポーネントがメソッド応答を返すまで待機します。

    3. メソッド応答を受信します。

    4. ビジネス プロセス フローの次のアクションを続行します。
  3. 非同期受信アクション
    1. XLANG スケジュールは、別のアプリケーションがメッセージ キューまたは BizTalk メッセージ チャネルにメッセージを送信するまで待機します。

    2. メッセージ キューまたはチャネルからメッセージを受信します。

    3. ビジネス プロセス フローの次のアクションを続行します。
  4. 非同期送信アクション
    1. XLANG スケジュールは、メッセージ キューまたは BizTalk メッセージ チャネルにメッセージを送信します。

    2. ビジネス プロセス フローの次のアクションを続行します。

    3. 別のアプリケーションが、メッセージ キューまたは BizTalk メッセージ チャネルからメッセージを受信します。

注

  • 同期受信アクションには、特別な事例があります。COM コンポーネント バインド ウィザードまたはスクリプト コンポーネント バインド ウィザードの [インスタンスを作成しない] を選択すると、コンポーネントのインスタンスは作成されず、メソッド呼び出しのコードも実行されません。代わりに、XLANG スケジュールがメソッド要求の情報をインターセプトすると、この情報をメソッド応答として返します。メソッド呼び出しが回避されます。静的ポートと動的ポート、および COM コンポーネント バインド ウィザードとスクリプト コンポーネント バインド ウィザードの詳細については、次のトピックを参照してください。
    • 静的ポートと動的ポート

    • ポートの実装

    • COM コンポーネント シェイプの使用

    • スクリプト コンポーネント シェイプの使用
  • BizTalk メッセージ サービスで送受信される XLANG スケジュールによって処理されるメッセージに関連するアクション イベントは、追跡データベースで追跡できます。詳細については、「追跡データベースでの XLANG スケジュール イベントの追跡」を参照してください。

ここには次のトピックが含まれます。

  • メソッド通信ウィザードの使用

  • 同期通信

  • XML 通信ウィザードの使用

  • 非同期通信

関連項目

ポートの実装

静的ポートと動的ポート

COM コンポーネント シェイプの使用

スクリプト コンポーネント シェイプの使用


メソッド通信ウィザードの使用

[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページでは、メソッド通信ウィザードを使用して、[アクション] シェイプと [COM コンポーネント] シェイプまたは [スクリプト コンポーネント] シェイプの間のメッセージのフローを定義できます。メッセージを送信する場合、XLANG スケジュールは _in メッセージでメソッドを呼び出し、コンポーネントから _out メッセージを受信するまで待機します。メッセージを受信する場合、XLANG スケジュールは、一方のアプリケーションがポートのメソッドを呼び出して _in メッセージをメソッドに送信するまで待機し、コンポーネントからの _out メッセージがもう一方のアプリケーションに送信されるまで待機します。

注

  • Visual Basic プログラムの場合、ByVal パラメータを使用できるのは _in メッセージだけです。ほかのすべてのパラメータは、_in メッセージと _out メッセージの両方で使用できます。

  • C 言語プログラムの場合、IN パラメータは _in メッセージでのみ、OUT パラメータは _out メッセージでのみ使用できます。IN,OUT パラメータは、両方のメッセージで使用できます。

  • Visual Basic プログラムと C 言語プログラムで、同じパラメータが _in メッセージと _out メッセージの両方にある場合、_in メッセージにはメソッドに送信されたコンテンツが含まれ、_out メッセージにはメソッドから返されたコンテンツが含まれます。

メソッド通信ウィザードを起動するには、[アクション] シェイプの右の制御ハンドル ( 制御ハンドル) を [COM コンポーネント] シェイプまたは [スクリプト コンポーネント] シェイプにバインドされているポートの接続ポイント ( 接続ポイント) までドラッグします。メソッド通信ウィザードは、以下のページで構成されています。

[メソッド通信ウィザードへようこそ]

[メソッド通信ウィザードへようこそ] ページで、XLANG スケジューラ エンジンがメソッドを呼び出す、またはメソッド呼び出しを待機するように指定できます。XLANG スケジューラ エンジンがメソッド呼び出しを待機するように指定した場合は、メッセージが到着するまで待機する必要があると予測される時間を秒単位で指定し、待ち時間の値を設定できます。この値が 180 秒以下の場合、XLANG スケジュール インスタンスはステータス保存データベースにステータス退避されません。この値が 180 秒を超えている場合は、XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。既定では、待ち時間の値は 0 に設定されています。これは、メッセージがすぐに到着すると予測されていることを示します。

XLANG スケジュール インスタンスが、アクションが待機しているメッセージの到着以外の理由でステータス復元された場合 (および、XLANG スケジュール インスタンスが休止ステータスに入った場合)、指定された待ち時間の値を使用して、XLANG スケジュール インスタンスをすぐにステータス退避するかどうかが決定されます。これは、同時に実行される分岐が待機していたメッセージを受信したときや、コンピュータが再起動してすべての XLANG スケジュール インスタンスがステータス復元されたときなどに発生します。このとき、待ち時間の値は、XLANG スケジュール インスタンスが休止ステータスに入ったポイントから評価されます。XLANG スケジューラ エンジンの元の待機時間の開始から経過した時間が (待ち時間の値と合わせて)、XLANG スケジューラ エンジンがステータス復元の後で休止ステータスに入ったときから 180 秒を超えている場合、XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。XLANG スケジュール インスタンスのこのポイントは、XLANG スケジューラ エンジンがメッセージの到達の監視を開始してから長時間経過した後で発生することがあります。

[メッセージ情報]

[メッセージ情報] ページで、新しいメッセージと既存のメッセージへの参照のどちらを作成するかを指定できます。既存のメッセージへの参照を作成するように指定した場合は、メソッドとの間で送受信されたり、[メッセージ] シェイプと関連付けられている、以前に作成されたメッセージの一覧から選択できます。使用したいメッセージが一覧にない場合は、新しいメッセージを作成するように指定し、新しいメッセージのデータ フローを定義する必要があります。

[メッセージ仕様情報]

[メッセージ仕様情報] ページでは、[メッセージ情報] ページで作成または参照したメッセージのメッセージ仕様を選択できます。

関連項目

非同期通信

ステータス退避とステータス復元

永続化

同期通信と非同期通信

同期通信

XML 通信ウィザードの使用


同期通信

同期通信で使用できるメソッドは、ポート実装用に選択したメソッドに限られます。ほかのポート実装のメソッドは使用できません。また、非同期通信フローの XML メッセージも使用できません。利用可能なメソッドを変更するには、適切なバインド ウィザードをもう一度起動し、ほかのメソッドを選択します。

<入力> および <出力> パラメータは、選択したメソッドのパラメータ条件から自動的に決まります。どちらのパラメータ一覧にも、パラメータの名前とデータ型が含まれています。メッセージには、メソッドに関連付けられているパラメータのほかに、必要なシステム フィールドも含まれています。同期メッセージには、次のシステム フィールドが常に含まれています。

  • __Sender__

    このシステム フィールドは、同期メッセージで使用されるメソッドの必須 <入力> パラメータです。

  • __Status__

    このシステム フィールドは、同期メッセージで使用されるメソッドの必須 <出力> パラメータです。

同期メッセージ

同期通信を作成すると、[データ] ページにメッセージが作成されます。このメッセージは、その通信フローで使用されるメソッドとパラメータに対応しています。メッセージには、そのメソッドに対するすべての <入力> パラメータと、そのメソッドに対するすべての <出力> パラメータが含まれています。

メソッドにパラメータを含めないことは可能ですが、メッセージには入力必須のシステム フィールドが必ず含まれます。次に [メッセージ] スキーマの例を示します。

Method name_inMethod name_in
__Sender__   string
   parameter 1   Data type 1
   parameter 2   Data type 2
   parameter n   Data type n
Method name_outMethod name_out
__Status__   string
   Parameter 1   Data type 1
   Parameter 2   Data type 2
   Parameter n   Data type n

次の図は、システム フィールド __Sender__ と __Status__、およびメソッド呼び出しの <入力> パラメータと <出力> パラメータが含まれている同期メッセージの組を示しています。

関連項目

ステータス退避とステータス復元

永続化

同期通信と非同期通信

メソッド通信ウィザードの使用


XML 通信ウィザードの使用

[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページでは、XML 通信ウィザードを使用して、[アクション] シェイプと [メッセージ キュー] シェイプ、 [BizTalk メッセージ] シェイプ、または未バインド ポートの間のメッセージのフローを定義できます。XML 通信ウィザードを起動するには、[アクション] シェイプの右の制御ハンドル ( 制御ハンドル) を未バインド ポートまたは [メッセージ キュー] シェイプか [BizTalk メッセージ] シェイプにバインドされているポートの接続ポイント ( 接続ポイント) までドラッグします。XML 通信ウィザードは、以下のページで構成されています。

[XML 通信ウィザードへようこそ]

[XML 通信ウィザードへようこそ] ページで、ポートがアクションにメッセージを送信するか、アクションからメッセージを受信するかを指定できます。[BizTalk メッセージ] シェイプを使用して実装されたポートとアクションの間の通信を作成する場合、通信方向は既に構成されています。この構成は、BizTalk メッセージ バインド ウィザードを使用してポート バインドを作成したときに行われます。

メッセージを受信するようにポートが構成されている場合は、メッセージが到達するまで XLANG スケジューラ エンジンが待機する時間を秒単位で指定できます。この値が 180 秒以下の場合、XLANG スケジュール インスタンスはステータス保存データベースにステータス退避されません。この値が 180 秒を超えている場合は、XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。既定では、待ち時間は 0 秒に設定されています。これは、メッセージがすぐに到達すると予測されていることを示します。

XLANG スケジュール インスタンスが、アクションが待機しているメッセージの到達以外の理由でステータス復元された場合 (および、XLANG スケジュール インスタンスが休止ステータスに入った場合)、指定された待ち時間の値を使用して、XLANG スケジュール インスタンスをすぐにステータス退避するかどうかが決定されます。これは、同時に実行される分岐が待機していたメッセージを受信したときや、コンピュータが再起動してすべての XLANG スケジュール インスタンスがステータス復元されたときなどに発生します。このとき、待ち時間の値は、XLANG スケジュール インスタンスが休止ステータスに入ったポイントから評価されます。XLANG スケジューラ エンジンの元の待機時間の開始から経過した時間が (待ち時間の値と合わせて)、XLANG スケジューラ エンジンがステータス復元の後で休止ステータスに入ったときから 180 秒を超えている場合、XLANG スケジュール インスタンスはすぐにステータス保存データベースにステータス退避されます。XLANG スケジュール インスタンスのこのポイントは、XLANG スケジューラ エンジンがメッセージの到達の監視を開始してから長時間経過した後で発生することがあります。

[メッセージ情報]

[メッセージ情報] ページで、新しいメッセージと既存のメッセージへの参照のどちらを作成するかを指定できます。新しいメッセージを作成するように指定した場合は、新しいメッセージのデータ フローを定義します。データ フローの詳細については「データ処理」を参照してください。メッセージの "ラベル" プロパティを使用して、次の方法でスケジュールのパフォーマンスを最適化します。

  • メッセージの "ラベル" プロパティが、新しい [メッセージ] シェイプを作成したときに指定した [XML ルートの要素] と同一である場合、XLANG スケジューラ エンジンはメッセージを取得します。

  • "ラベル" プロパティが [XML ルートの要素] で指定した値と一致しない場合、XLANG スケジューラ エンジンはメッセージのコンテンツを調べます。新しい [メッセージ] シェイプを作成したときに指定した XML ルートの要素の値が実際の XML ルートの要素と一致する場合、XLANG スケジューラ エンジンはメッセージを取得します。一致しない場合は、XLANG スケジューラ エンジンはメッセージをキューに残し、次のメッセージを確認します。

[XML 変換情報]

[XML 変換情報] ページで、XML 形式のデータとテキスト文字列のうち、どちらのメッセージをキューとの間で送受信するかを指定できます。メッセージをテキスト文字列として送信するように選択した場合、XLANG スケジューラ エンジンの標準 XML ラッパーがメッセージから削除されます。

[メッセージの種類の情報]

[メッセージの種類の情報] ページで、定義した種類のメッセージを識別するために XLANG スケジューラ エンジンで使用するラベルを指定できます。入力したテキストは、メッセージ キューから受信するメッセージを正しく識別するために使用されます。2 つの異なるメッセージに対して同じメッセージの種類を選択する場合は、フィールド名、フィールドの種類、および XPath の問い合わせが正確に一致することを確認してください。同じポートの同じメッセージの種類のメッセージの間に矛盾があると、XLANG スケジューラ エンジンはエラーを報告します。[メッセージの種類の情報] ページの [メッセージの種類] ボックスで、メッセージのラベル指定を入力します。XLANG スケジューラ エンジンは、指定した情報に基づいて次の操作を行います。

  • XLANG スケジューラ エンジンは、メッセージの種類の情報をキュー内にあるメッセージ ラベルと照合し、一致するものを探します。メッセージの種類が一致しないと、メッセージは無視され、XLANG スケジューラ エンジンは一致する次の受信メッセージを見つけるために検索を続行します。これによって、複数のアクションが 1 つのメッセージ キューから複数の種類のメッセージを受信できます。

  • アクティブ化のために BizTalk メッセージ シェイプを使用するとき、XLANG スケジューラ エンジンは、アクティブ化チャネルの送信ドキュメント定義の名前を、メッセージをキューに配信するときのメッセージ ラベルとして使用します。同様に、このメッセージを使用するアクションは、アクティブ化チャネルの送信ドキュメント定義の名前をそのメッセージの種類として使用します。

  • キュー内にあるメッセージが XML 形式である場合、XLANG スケジューラ エンジンはメッセージの種類の情報をキュー内にあるメッセージの XML ルートの要素と照合し、一致するものを探します。

[メッセージ ラベルにインスタンス ID を使用] チェックボックスをオンにすることによって、インスタンス ID - スケジュール インスタンスのグローバル一意識別子 (GUID) －をメッセージのラベルとして使用することもできます。これは、単一のキューによってスケジュールのすべてのインスタンスのメッセージを処理したい場合の関連付けのメカニズムとして利用できます。この問題についての詳細は、「インスタンス管理」のメッセージの交換と XLANG スケジュール インスタンスの関連付けについての説明を参照してください。

[メッセージ仕様情報]

[メッセージ仕様情報] ページで、使用するメッセージ仕様 (.xml) ファイルへのパスを入力するか、参照することができます。選択したメッセージ仕様が、BizTalk エディタを使用して作成したものである場合は、XLANG スケジューラ エンジンのデータ範囲にフィールドを追加できます。[仕様に対してメッセージを検証] チェック ボックスをオンにすると、仕様に対してメッセージを検証できます。[メッセージ仕様情報] ページの [参照] をクリックすると、[仕様の参照] ダイアログ ボックスが表示されます。[仕様の参照] ダイアログ ボックスで、使う仕様を検索できます。

仕様を選択していない場合、[メッセージ仕様情報] ページの [作成] をクリックすると、BizTalk エディタを開くことができます。既に仕様を選択している場合は、[メッセージ仕様情報] ページの [編集] をクリックすると、選択した仕様で BizTalk エディタを開くことができます。

[メッセージ仕様情報] ページの [追加] をクリックすると、[フィールドの選択] ダイアログ ボックスが表示されます。[フィールドの選択] ダイアログ ボックスの [ノードを選択してください] ツリーで使用するノードを展開し、追加するフィールドをクリックします。[フィールドの選択] ダイアログ ボックスで、選択したポートのメッセージ シェイプに追加するフィールドの名前とノード パスを編集できます。データ型フィールドは、表示されますが編集はできません。

注

  • 検証ができるのは、メッセージを受信するときに限られます。メッセージを送信する場合、検証チェック ボックスは無視されます。

  • 対応する OLE Automation 型がない、列挙や数値などのＸＭＬ データ型は、BizTalk オーケストレーション デザイナーおよび XLANG で文字列型に変換されます。このような型のフィールドは、検証を文字列として通過します。OLE Automation 型の完全なリストについては「フィールド データ型」を参照してください。

  • [ノードを選択してください] ツリーのフィールドをクリックすると、[フィールド名] ボックスにフィールド名が自動的に追加されます。

  • [ノードを選択してください] ツリーのフィールドをクリックすると、[ノード パス] ボックスにそのフィールドへのノード パスが自動的に追加されます。

  • メッセージ フィールドを追加するとき、追加項目は BizTalk エディタで作成またはインポートしたスキーマだけから選択できます。

  • フィールドの中から特定のデータを抽出するときは、ノード パスを手動で編集すると便利です。たとえば、フィールドに配列が含まれている場合は、配列全体ではなく配列の項目を 1 つだけ取得する必要があります。ただし、メッセージ仕様のノード パスは手動で編集しないでください。

  • ノードを選択して [メッセージ フィールド] ボックスの一覧に追加することはできません。選択できるのはフィールドだけです。フィールドは、リーフ ノードとも呼ばれます。たとえば、[Seller] ノードおよび [Address] ノードにはリーフ ノードが含まれているため、選択できません。[Name] フィールドと [Address] フィールドにはほかのノードが含まれていないので、選択できます。

  • メッセージ キューからのメッセージ受信を待機している間に、無効な XML メッセージや不十分な認証などの問題が発生すると、配信不能メッセージ キューが動的に作成されます。配信不能メッセージ キューは、COM+ アプリケーションごとに固有です。配信不能メッセージ キューには、.\private$\ApplicationName.DeadLetter という名前が付けられます。たとえば、無効な XML を含むメッセージがキューに到達した場合、XLANG スケジューラ エンジンが XML メッセージをキューから受信するように XML 通信ウィザードの [XML 変換情報] ページで指定されていると、無効な XML メッセージは .\private$\ApplicationName.DeadLetter に移動されます。

  • 同じメッセージ キューから別々にメッセージを受け取るように 2 つの XLANG スケジュールを設計すると、メッセージが間違った XLANG スケジュール インスタンスによって処理される可能性があります。この問題を回避するには、XLANG スケジュール インスタンスによって受信されるメッセージの各種類に対して 1 つのメッセージ キューを使用します。

関連項目

非同期通信

同期通信と非同期通信

同期通信

メソッド通信ウィザードの使用


非同期通信

非同期メッセージはメッセージ キューまたは BizTalk メッセージ チャネルに配置され、XLANG スケジュールは処理を続行します。応答を待機することはありません。

非同期通信で使用可能なメッセージは、XML メッセージだけです。すべての XML メッセージが使用可能で、複数のポートに対して指定できます。[メソッド通信ウィザード] を使用して作成した同期メッセージの組は、すべて使用できません。

非同期メッセージ

非同期通信を構成すると、[データ] ページにメッセージが作成されます。このメッセージは、その通信フローで送信または受信される情報に対応しています。メッセージには、入力必須のシステムフィールドと、必要な追加仕様フィールドが含まれます。

次に [メッセージ] スキーマの例を示します。

Message nameメッセージ名
__Sender__   string
Document   string
   Field 1   Data type 1
   Field 2   Data type 2
   Field n   Data type n

次の図は、Message_1 というメッセージを示しています。システム フィールド __Sender__ と Document は自動的に提供されるもので、すべての非同期メッセージに存在します。このメッセージには、ユーザーが選択した 2 つの仕様フィールドも含まれています。

2 つのシステムによって追加されたフィールドと、2 つのユーザによって選択された仕様フィールドを含むメッセージ

XML 通信ウィザードの [フィールドの選択] ダイアログ ボックスを使用して、仕様フィールドを追加できます。[フィールドの選択] ダイアログ ボックスの [ノードを選択してください] ツリーのノードをクリックすると、仕様フィールドを選択できます。ノードをクリックすると、ノード パスが [ノード パス] ボックスの一覧に追加されます。リーフ ノードを選択する必要があります。リーフ ノードは子を持たないノードです。次の図で、ノード Name はリーフ ノードですが、ノード Address はリーフ ノードではありません。

ノード パスは、XPath とも呼ばれます。選択したノード パスをそのまま使用することも、パスに対する追加の基準を入力することもできます。たとえば、配列が含まれているノードを選択する場合、配列全体を取得するのではなく、配列内の特定のインデックスを指定して取得することができます。

注

  • XML メッセージを文字列として送信または受信する場合は、このメッセージの [データ] ページに作成された [メッセージ] シェイプに、StringData という名前のフィールドが含まれている必要があります。また、このメッセージには仕様フィールドを追加できません。

次の図は、[フィールドの選択] ダイアログ ボックスを示しています。

[フィールドの選択] ダイアログ ボックス

注

  • 仕様フィールドの選択とノード パスの使用の詳細については、次のトピックを参照してください。
    • 仕様の作成と検証

    • ノード パス フィールド

    • 非同期メッセージの送信と受信

    • XML 通信ウィザードの使用

関連項目

仕様の作成と検証

ステータス退避とステータス復元

ノード パス フィールド

永続化

非同期メッセージの送信と受信

同期通信と非同期通信

XML 通信ウィザードの使用


XLANG スケジュールのコンパイル

XLANG スケジュール フローチャートが完成したら、フローチャートを実行可能な XLANG スケジュールにコンパイルできます。フローチャートをコンパイルする前に、[データ] ページで定義したメッセージ間のデータのフローを確認します。XLANG スケジュールは、ビジネス プロセスと、そのプロセスのバインドについての情報を実装テクノロジに提供するものです。

BizTalk オーケストレーション デザイナは、コンパイルのプロセスで XLANG スケジュールの問題が発見されたときに、できるだけ多くの役立つ情報を提供するように設計されています。BizTalk オーケストレーション デザイナは、エラーを検出すると、エラーが含まれているシェイプを強調表示し、エラー メッセージを表示し、XLANG スケジュールのコンパイルを取り消します。

コンパイル中に、BizTalk オーケストレーション デザイナは、各シェイプが完了していて正しいかどうかを確認します。XLANG スケジューラ エンジンは、[ビジネス プロセス] ページの [開始] シェイプを最初に処理します。次に、再帰的にフローチャート全体を下方向に処理します。XLANG スケジューラ エンジンがエラーを検出した場合、そのエラーは一般的に、ビジネス プロセスが深くネストした位置のシェイプに流れるときに発生します。エラーを報告するために、XLANG スケジューラ エンジンは適切なエラー メッセージを構築します。そして、XLANG スケジューラ エンジンが上方向にスタックを戻るときに、各メソッドは元のエラー メッセージにメソッド自体のエラー メッセージを結合します。元のエラー メッセージにエラー メッセージを結合したメソッドがない場合は、最上位のコンパイル メソッドが次の一般エラー メッセージを追加します。

XLANG スケジュールは処理できませんでした。

コンパイルされた XLANG スケジュールには、[開始] シェイプの XLANG ID プロパティと一致するグローバル一意識別子 (GUID) が含まれます。この ID を使用して、XLANG スケジュール フローチャートのバージョンと、そのフローチャートを生成した XLANG スケジュールを関連付けることができます。

注

  • 「BizTalk オーケストレーション デザイナに関する作業を行う方法」 を参照し、BizTalk オーケストレーション デザイナを使用して XLANG スケジュール フローチャートを作成し、実行可能な XLANG スケジュールにコンパイルする方法について、作業ごとに十分に理解しておいてください。

関連項目

XLANG スケジュールのコンパイルとデバッグ

XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

XLANG スケジュールのデバッグ


XLANG スケジュールのデバッグ

XLANG Event Monitor は、実行中の XLANG スケジュール インスタンスを監視するために使用するツールです。XLANG Event Monitor の使用方法の詳細については、付属のリリース ノートを参照してください。Microsoft BizTalk Server 2002 セットアップ ウィザードによってインストールされる XLANG Event Monitor (XLANGMon.exe) とリリース ノートは、インストール ディレクトリの \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools にあります。

XLANG Event Monitor には、次の機能があります。

  • XLANG スケジューラ エンジンの動作をリアル タイムに表示します。

  • 実行中のスケジュールを最初に列挙した後、イベントを監視します。XLANG Event Monitor を使用して、実行中のインスタンスを中断したり停止できます。

  • マルチドキュメント インターフェイス (MDI) に似たユーザー インターフェイスによって、同時に複数のインスタンス トレースを表示できます。

  • 選択したアプリケーションを複数のコンピュータで同時に監視できます。

  • 記録と表示で別のフィルタを使用できます。

関連項目

XLANG スケジュールのコンパイルとデバッグ

XLANG スケジュールのコンパイル

実行中の XLANG スケジュールの監視

Orchestration Services Error Messages


XLANG スケジュールの実行

BizTalk オーケストレーション デザイナをインストールすると、XLANG スケジューラ COM+ アプリケーションなど、いくつかの COM+ アプリケーションがインストールされ、Microsoft Windows 2000 コンポーネント サービス内に構成されます。このアプリケーションは、XLANG スケジューラ エンジンの既定のインスタンスをホストするものです。コンポーネント サービスに作成された新しい COM+ アプリケーションのプロパティを表示するダイアログ ボックスには、[XLANG] プロパティ ページが表示されます。ここでは、新しい COM+ アプリケーションが XLANG スケジューラ エンジンをホストするように設定できます。新しい XLANG スケジュールを実行する COM+ アプリケーションは、XLANG スケジュールのインスタンスをアクティブにするために使われる、モニカ構文で決定することもできます。

XLANG スケジューラ エンジンは、実行中の XLANG スケジュール インスタンスのアクティブ化、実行、ステータス退避、およびステータス復元を制御します。XLANG スケジュールをアクティブにするには、XLANG スケジュールのモニカを XLANG スケジューラ エンジンに渡す小さなアプリケーションを作成します。XLANG スケジューラ エンジンは、XLANG スケジュール内のアクションを実行し、XLANG スケジュールのステータス退避が必要になるまでビジネス プロセスを順序どおり続行していきます。XLANG スケジュールのステータス退避は、XLANG スケジューラ エンジンがメッセージを受信するまでの待機時間が、3 分を超えると予測される場合に発生します。メッセージが到着すると、XLANG スケジューラ エンジンによって XLANG スケジュール インスタンスのステータスが復元され、スケジュールが完了するまで、または XLANG スケジューラ エンジンが別のメッセージを待機する必要が生じるまで、ビジネス プロセスのアクションの実行が続けられます。ステータス退避をサポートするには、ステータス保存データベースを構成する必要があります。推奨されるネットワーク ライブラリは TCP/IP です。

Microsoft Windows 2000 コンポーネント サービスの情報を表示するには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. 使用する COM+ アプリケーションを右クリックし、[プロパティ] をクリックします。

    プロパティのダイアログ ボックスが表示されます。

[プロパティ] ダイアログボックスの [XLANG] プロパティ ページに以下のオプションが表示されます。

  • [このアプリケーションを XLANG スケジュール インスタンスのホストにする] : このチェック ボックスをオンにすると、この COM+ アプリケーションが XLANG スケジュールのインスタンスをアクティブにできるようになります。特定の COM+ アプリケーションにスケジュール インスタンスのアクティブ化を指示するには、アプリケーション名が含まれているモニカ書式を使用します。このチェック ボックスは、このアプリケーションを XLANG スケジューラ エンジンのホストとして使用する場合にオンにします。

  • [永続性] : このグループ ボックスでは、長時間にわたるビジネス プロセスのステータス退避とステータス復元をサポートするための、Microsoft SQL Server の構成を行うことができます。
    • [DSN の作成] は、XLANG スケジューラ エンジンをホストする COM+ アプリケーションの ODBC データ ソース名 (DSN) を作成します。ファイル DSN は、データベース接続に関する情報をファイルに格納するものです。ファイルの拡張子は .dsn で、既定では \Program Files\Common Files\ODBC\Data Sources ディレクトリに格納されます。[DSN の作成] をクリックすると DSN ウィザードが起動します。

    • [DSN の構成] をクリックすると、ODBC データ ソース アドミニストレータが起動します。この COM+ アプリケーションにおける XLANG スケジュールのデータ送信元を管理できます。

    • [テーブルの初期化] は、定義した SQL Server データベース内に、永続性をサポートするために必要なテーブルを作成します。

    重要

    • [XLANG Scheduler のプロパティ] ダイアログ ボックスで構成するデータ ソース名は、COM+ アプリケーションの名前と同じものにする必要があります。
  • [シャットダウンの制御] : このグループ ボックスにあるボタンで、XLANG スケジュール インスタンスをホストしている COM+ アプリケーションをシャットダウンできます。
    • [すべての XLANG アプリケーション] をクリックすると、実行中の XLANG スケジュール インスタンスをホストしているすべての COM+ アプリケーションがシャットダウンされます。

    注

    • 既定のアプリケーション以外のアプリケーションを選択した場合は、[この XLANG アプリケーション] というボタンが表示されます。
  • [ステータス退避済み XLANG アプリケーションを再起動] : このグループ ボックスにあるボタンで、ステータス退避済み XLANG アプリケーションを管理できます。
    • [すべての XLANG アプリケーション] をクリックすると、XLANG スケジュール インスタンスをホストしているすべての COM+ アプリケーションのステータスが退避され、可能であれば実行が続けられます。

重要

  • COM+ アプリケーションを右クリックして実行中の XLANG スケジュール インスタンスをシャットダウンすることはやめてください。COM コンポーネントがメモリに読み込まれたまま残り、正しくアンロードされません。その方法ではなく、[XLANG Scheduler] COM+ アプリケーションのプロパティを表示するダイアログ ボックスで、[XLANG] タブの [シャットダウンの制御] ボックスにあるボタンを使用してください。

注

  • Microsoft Windows 2000 ターミナル サービスのクライアントを使用して XLANG スケジュールを開始する場合は、XLANG スケジューラ エンジンをホストする COM+ アプリケーションの ID を、有効な Windows 2000 ユーザー名またはグループ名に設定する必要があります。COM+ アプリケーションの ID は、そのアプリケーションのプロパティのダイアログ ボックスの [ID] プロパティ ページで設定します。ターミナル サービスでホストされているセッションを通じて XLANG スケジューラ エンジンを使用している場合は、ID を対話的に設定することはできません。

  • XLANG スケジュールを実行する作業ごとの詳細については、「XLANG スケジュールの実行 (操作方法)」を参照してください。

ここには次のトピックが含まれます。

  • モニカの構文

  • インスタンス作成アプリケーションの作成


モニカの構文

モニカは、新しい XLANG スケジュール インスタンスを作成したり、既存の XLANG スケジュール インスタンスを参照したりするために使用します。どちらの場合にも、スケジュール インスタンスの特定のポートを参照できます。モニカによって、XLANG スケジューラ エンジンをホストする COM+ アプリケーションが決定されます。

XLANG スケジュールの新しいインスタンスを作成するには、XLANG スケジュールのモニカを COM+ アプリケーションに渡す必要があります。COM+ アプリケーションは、モニカを XLANG ネーム サービスに渡すことで、名前を解決すると共に XLANG スケジューラ エンジンのインスタンスを使って XLANG スケジュール インスタンスをアクティブにします。次のコード サンプルは、モニカの一般的な構文です。

sked://[HostName][!GroupManager][/FilePath][/PortName]

モニカの構文にある各セグメントは、インスタンス化するオブジェクトの種類によっては省略できます。次の表は、モニカの構文セグメントの一覧と説明を示しています。

モニカの構文セグメント | 説明 | 構文の例
<HostName> | XLANG スケジューラ エンジンを実行しているコンピュータのホスト名です。XLANG システム マネージャとも呼ばれます。省略した場合は、既定値として localhost が使用されます。この名前では、大文字と小文字は区別されません。 | sked:// sked://MyServer
<GroupManager> | XLANG スケジュール インスタンスを管理するために使用される XLANG スケジューラ エンジン グループ マネージャです。グループ マネージャの名前は、XLANG ホストとして指定した COM+ アプリケーションと同じものです。省略すると、既定値として XLANG Scheduler が使用されます。この名前では大文字と小文字が区別され、名前に空白を含めることができます。 | sked:/// sked://AnotherServer!/ sked://AnotherServer!MyGroup/
<FilePath> | アクティブにする XLANG スケジュール ファイル (.skx) へのパスです。この値では、大文字と小文字は区別されません。 | sked://host1!MyGrp/C:\basic.skx sked:///C:\basic.skx
<PortName> | XLANG スケジュールの COM コンポーネントまたは Windows スクリプト コンポーネントにバインドするポートの名前です。この名前では、大文字と小文字が区別されます。 | sked:///C:\basiccom.skx/portA

モニカの構文を使用すると、既存の XLANG スケジュール インスタンスを参照したり、XLANG スケジュールを起動したりできるほか、新しい XLANG スケジュール インスタンスの特定のポートとの通信チャネルを確立できます。

XLANG スケジュール インスタンスを参照するモニカは、XLANG スケジューラ エンジンで作成します。その後、[ポート参照] シェイプと、XLANG スケジュールで送信されるメッセージとの間に接続を作成すると、利用できるようになります。ポート参照の正確な形式は、ポートがバインドされている実装テクノロジと、対象のメッセージ フィールドのデータ型によって異なります。メッセージ キューまたは BizTalk メッセージ サービスにバインドされているポートは、データ型が String のフィールドにのみ接続できます。対象のフィールドには、キューの名前、または現在の XLANG スケジュール インスタンスでポートにバインドされているメッセージ エンドポイントの名前が含まれます。

COM コンポーネントにバインドされているポートは、データ型が String、Object、または Unknown のフィールドにのみ接続できます。対象のフィールドのデータ型が String の場合は、現在の XLANG スケジュール インスタンスのポートを参照するモニカが作成されます。このモニカは永続的です。このモニカは GetObject 関数を使用して解決することができ、システムを再起動した後も有効です。対象のフィールドのデータ型が Object または Unknown の場合は、ポート インスタンスへの COM 参照がメッセージ シェイプに渡されます。この種類の参照が外部コンポーネントに渡された場合、システムが再起動した後は無効になります。

実行中の XLANG スケジュール インスタンスを参照するためのモニカは、次の Microsoft Visual Basic コードで示すように、XLANG スケジュール インスタンス オブジェクトから取得できます。

Dim oSchedule as IWFWorkflowInstance
Set oSchedule = GetObject("sked:///C:\temp\myschedule.skx")
dim sMoniker as string
sMoniker = oSchedule.FullyQualifiedName

関連項目

インスタンス作成アプリケーションの作成

XLANG スケジュールの実行 (概念)


インスタンス作成アプリケーションの作成

インスタンス作成アプリケーションは、COM 関数 GetObject を使用して、完了した XLANG スケジュール ファイルのモニカを XLANG スケジューラ エンジンに渡します。次の Microsoft Visual Basic コードは、その方法を示しています。

Dim objExecute As object
Dim strURL as string

strURL = "sked:///c:\temp\myschedule.skx"

' This instantiates an XLANG schedule and enables the XLANG Scheduler' This instantiates an XLANG schedule and enables the XLANG Scheduler
' Engine to execute the XLANG schedule.
Set objExecute = GetObject(strURL)

モニカでポートを指定しなかった場合は、GetObject 関数で返されるオブジェクトの Port プロパティによって、COM コンポーネントにバインドされているポートへの参照を取得できます。同様に、FullPortName プロパティによって、実装テクノロジにバインドされたポートの完全で永続的な名前を取得できます。

次のコードは、COM ポートまたはスクリプト ポートへのプロキシを取得する方法を示しています。このコード例は、前のコード例からの続きです。

Dim oPort as Object
Set oPort = objExecute.Port("SchedulePortName")
Call oPort.ComponentMethodName(arg1,arg2,...argN)

注

  • ポートが、デュアル インターフェイスをサポートしない COM オブジェクトにバインドされている場合は、<oPort> 変数を適切なクラスと共に宣言する必要があります。

関連項目

モニカの構文

XLANG スケジュールの実行 (概念)


XLANG スケジュールのプール

トラフィックが多く、同時に多数のスケジュール インスタンスがアクティブになっているときは、スケジュールをプールすることによって、使用可能なリソースを効率的に利用することができます。BizTalk サーバーでは、COM オブジェクト プールを利用して、アクティブなスケジュール インスタンスの数を制限できます。オブジェクトのプールで次のプロパティを設定できます。

  • プールでのスケジュール インスタンスの最大数を設定できます。この最大数に達したとき、スケジュールが完了するか退避されるまで、そのプールを使用するスケジュールの別のインスタンスは作成されません。既定値の最大数は 25 インスタンスです。

  • プールのタイムアウト時間も設定できます。これは、保留中のスケジュール インスタンスのアクティブ化が、スロットがそのプールで使用可能になるのを待つ時間の長さです。タイムアウト時間の既定値は、30,000 ミリ秒 (30 秒) です。

  • 最小のプール サイズを設定することによってパフォーマンスを向上させることができます。最小サイズによってメモリ内に保持されるプール オブジェクトの数が決まるので、そのプール内でスケジュール インスタンスがアクティブ化されるたびにプール オブジェクトを要求に応じて作成する必要はありません。最小値の既定値は、 1 オブジェクトです。

これらの設定は、1 つ以上のプールにとって最適でない場合があります。プールを効率的に利用するためには、プールの設定を具体的なニーズに合わせて構成しなければなりません。たとえば、大量のトラフィックがある短時間のスケジュールは、一般的にインスタンスの最大数が比較的大きいオブジェクト プールで実行するように構成します。最小数を比較的大きく設定するのも効果的です。トラフィック量が安定している場合は、あらかじめいくつかのオブジェクトを作成しておくとパフォーマンスが向上します。この場合、タイムアウトは短く、メッセージ再試行回数は多く設定します。トラフィック量が少ない長時間のスケジュールの場合は、タイムアウトを長くし、インスタンスの最小数と最大数を小さくし、メッセージ再試行回数を少なくします。

注

  • 1 つまたは複数のスケジュールを 1 つのプールに割り当てることは可能ですが、その場合は、プールの設定が、そのプールに割り当てられているすべてのスケジュールのニーズに適合していることを確認してください。

  • プールでは、下位互換性の問題は起こりません。プールされたプロパティが設定されていないスケジュールは、プールの影響を受けません。

  • ユーザが参照しているプールされたスケジュール インスタンスの実行が完了した後も、そのインスタンスは参照が範囲外になるまで、または以下のサンプル コードに示す方法で明示的に解放されるまで、プール内に残ります。
    Set FSO = CreateObject("Scripting.FileSystemObject")
CurrentDirPath = FSO.GetAbsolutePathName(".")
SkedMoniker = "sked://localhost/" & CurrentDirPath & "\PoolingSample.skx"
While '(some condition)
    Set Sked = GetObject(SkedMoniker)
    '(some action)
    Set Sked = Nothing
Wend

関連項目

XLANG スケジュールのプール

Copyright © 1999-2001 Microsoft Corporation.
All rights reserved.

このトピックは役立ちましたか。ドキュメントやサンプル、製品全般に関するご意見、ご要望についてはこちらにお送りください。BizTalk Server に関するマイクロソフトへのフィードバック


セッション ステータスの管理

COM コンポーネント バインド ウィザードの [ポート プロパティの詳細設定] ページで、COM コンポーネントがサポートする永続性レベルに対して、ステータス管理のための値を選択できます。[ステータス管理のサポート] ボックスで、次のオプションのいずれか 1 つを選択します。

  • [ステータスを保持しない] : XLANG スケジューラ エンジンは、スケジュール インスタンスがステータス退避された場合、そのコンポーネント インスタンスを終了します。この設定を選択した場合は、スケジュールがステータス復元されるときに、XLANG スケジューラ エンジンは必要に応じて新しいコンポーネント インスタンスを作成します。

  • [ステータスを保持し、永続的にサポートしない] : XLANG スケジューラ エンジンに対し、コンポーネント インスタンスの実行を、スケジュール実行の中でその必要がなくなるまで継続するように要求します。スケジュール インスタンスがステータス退避されている間にシステムに障害が発生すると、このコンポーネントに保持されていたステータスはすべて失われます。

  • [ステータスを保持し、永続的にサポートする] : XLANG スケジューラ エンジンは、コンポーネント インスタンスをメモリから削除し、ステータス退避中にコンポーネントの IPersistStream または IPersistStreamInit のいずれかを呼び出すことでメモリに復元します。ステータス復元中に、もう一度メモリに復元します。

関連項目

インスタンス管理


XLANG スケジュールの更新

XLANG スケジュールを更新するには、2 つの方法があります。元の XLANG スケジュールに上書きすることも、元の XLANG スケジュールと同時に実行される新しい XLANG スケジュールを追加することもできます。

元の XLANG スケジュールに上書きするには、BizTalk オーケストレーション デザイナを使用して新しい XLANG スケジュール フローチャートを作成し、元の XLANG スケジュールと同じ名前の XLANG スケジュールとして XLANG スケジュール フローチャートをコンパイルします。XLANG スケジュール フローチャートは、Microsoft Visio 2000 ファイル形式のカスタム バージョンである .skv ファイルとして保存されます。その後は、XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにすることができます。XLANG スケジュールは、XLANG スケジューラ エンジンが認識できる、.skx という拡張子を持つ XML 構造のテキスト ファイルです。元の XLANG スケジュールを更新するには、新しい .skx ファイルを元の .skx ファイルにコピーします。

元の XLANG スケジュールと同時に実行される新しい XLANG スケジュールを追加するには、BizTalk オーケストレーション デザイナを使用して新しい XLANG スケジュール フローチャートを作成し、新しい名前の XLANG スケジュールとして XLANG スケジュール フローチャートをコンパイルします。新しい XLANG スケジュールを正しくアクティブにするには、XLANG スケジュール インスタンスをアクティブにするメカニズムに変更を加え、古い .skx ファイルではなく新しい .skx ファイルをポイントするようにする必要があります。この作業を完了すると、XLANG スケジュールに新しい要求が出されたときは、新しい XLANG スケジュール インスタンスが作成されるようになります。

XLANG スケジュールとそのコンポーネントは、通常はすべてインスタンス単位で動作するので、実行中の元のスケジュールを処理する XLANG スケジュール インスタンスは、完了するまで実行されます。永続化されている XLANG スケジュール インスタンスも、元のスケジュールのソース コードが保存されているので、完了するまで実行されます。この場合、実行パスは元のビジネス プロセスに従います。XLANG スケジュールに新しい要求が出されると、新しい XLANG スケジュール インスタンスが作成されます。

注

  • XLANG スケジュールが使用しているオブジェクトのインターフェイスが変更された場合は、BizTalk オーケストレーション デザイナで XLANG スケジュール フローチャート (.skv ファイル) を読み込み、新しい .skx ファイルをコンパイルします。これによって .skx ファイルのバインド情報が更新され、コンポーネントのタイプ ライブラリとの同期がとれるようになります。


BizTalk オーケストレーション デザイナに関する作業を行う目的

ここでは、BizTalk オーケストレーション デザイナに関する作業を行う目的についてのクイック リファレンスを示します。次の表は、主要な作業とそれらに付随する作業を示しており、各作業の目的と対応する手順へのリンクを明記しています。

作業 作業を行う目的
  • BizTalk オーケストレーション デザイナの使用
 コンパイルして、XLANG スケジュールとして実行できるビジネス プロセスのフローチャートを作成します。
  • XLANG スケジュール フローチャートを開く、および保存する
 ビジネス プロセスの XLANG スケジュール フローチャートを作成する、開く、または保存します。
ページ、シェイプ、およびステンシルの表示
設計ページの表示 :
  • ビジネス プロセス ページの表示
 ビジネス プロセスの概念を示すフローチャートを表示します。
  • データ ページの表示
 メッセージ フィールド、ポート フィールド、定数、およびそれらの間のデータの流れを表示します。
  • ビジネス プロセス ページとデータ ページの表示
 ビジネス プロセス ページと データ ページの両方を同時に表示します。
  • トランザクションの補正ページの表示
 ネストしたトランザクションの結果をロールバックするコードを表示します。
  • トランザクションの失敗時ページの表示
 失敗したトランザクションに関連するエラー処理コードを表示します。
シェイプの表示 :
  • フローチャート シェイプの表示
 ビジネス プロセスを記述するフローチャート シェイプだけを表示します。
  • フローチャート シェイプと通信シェイプの表示
 ビジネス プロセスと、その間の接続を記述するフローチャート シェイプを表示します。
  • フローチャート シェイプ、通信シェイプ、および実装シェイプの表示
 ビジネス プロセスを記述するフローチャート シェイプ、ポートを記述する実装シェイプ、およびその間の関係を表示します。
ステンシルの表示 :
  • フローチャート ステンシルの表示
 ビジネス プロセスを記述するために使用できるシェイプを表示します。
  • 実装ステンシルの表示
 ビジネス プロセス間の通信ポートを実装するために使用できるシェイプを表示します。
  • 複数のウィンドウの使用
 XLANG スケジュールの異なるページ、または同じページの異なる部分を同時に表示するために、ウィンドウを開く、並べて表示する、重ねて表示する、またはウィンドウのフォーカスを切り替えます。
  • コメントの使用
 ビジネス プロセスに関する記述的なメモを作成するためにコメントを追加、編集または書式設定します。
  • XLANG スケジュール フローチャートのプレビュー、印刷、およびサイズ変更
 XLANG スケジュール フローチャートを印刷したり、印刷前にプレビューしたり、サイズ変更したりできます。
  • シェイプの追加、削除、および接続
 XLANG スケジュール フローチャートにアクションを表すシェイプを置き、論理的に接続します。
  • シェイプの選択
 シェイプを選択すると、シェイプのプロパティを編集したり、そのシェイプの切り取り、貼り付け操作を行ったり、シェイプ間の関係を作成したりできます。
  • 2 つのシェイプの接続
 アクションをほかのアクション、またはポートに接続することによって、プロセスおよび通信フローを表します。
  • コネクタ ツールの使用
 このツールは、アクション間の接続を記述する便宜的な方法として使用します。
  • シェイプの縦軸方向または横軸方向の整列
 スケジュール フローチャートの外観とわかりやすさを改善するために、シェイプを垂直方向または水平方向に整列します。
条件付きシェイプのプロパティの設定 :
  • 判断条件の設定
 判断シェイプに条件を追加するか、または条件を評価する順序を決定します。
  • 繰り返しループの状態の設定
 繰り返しループの実行を続けるかどうかを決定する条件を追加します。
  • 繰り返しループのステータスの保持
 保存した XLANG スケジュール ステータスに、各ループ繰り返しに使用したメッセージを含めるかどうかを指定します。
条件の作成 :
  • 条件の作成
 ビジネス プロセスの中の、判断と繰り返しループ内の条件を評価します。
  • の使用
 条件の中の条件式にメッセージおよびフィールドの名前を追加します。
  • 条件への定数の追加
 条件式の中で、データ ページからの定数を使用する。
同時実行のプロパティの設定 :
  • 同時実行フローの作成
 ビジネス プロセスの中に、独立しているが同時実行する論理フローまたはフォークを作成する。
  • 結合の種類プロパティの設定
 続けて次のアクションを開始する前にすべての同時実行プロセスの実行が完了する必要があるかどうかを指定します。
  • 同時実行フローの結合
 同時実行アクションの同期を取って、1 つの共通のアクションにします。
  • 同時実行フローの終了
 1 つの同時実行フローを終了して、ほかのフローと結合しないようにする。
トランザクション プロパティの設定
XLANG スケジュールに対するトランザクション プロパティの設定 :
  • トランザクション モデルの設定
 XLANG スケジュールの中でのトランザクションを許可するか、スケジュールを COM+ コンポーネントとして扱うかを指定します。後者の場合には、スケジュールを COM+ トランザクションのコンテクストの中に置くことができます。
  • トランザクションのアクティブ化プロパティの設定
 XLANG スケジュールの COM+ トランザクションのコンテキストの中での動作を指定します。スケジュールが COM+ トランザクションを無視するか、COM+ トランザクションの中に置かれるかを指定できます。また、スケジュールが常にトランザクションの中で実行するか、常に実行するための新規のトランザクションを作成するように設定できます。
トランザクション プロパティの個別設定 :
  • トランザクション内のグループ アクションとフロー
 シェイプまたはフローを トランザクション シェイプの中に置き、1 つのトランザクションとして扱います。
  • ネストしたトランザクションの設計
 トランザクションの中に別のトランザクションを含めます。
  • トランザクションに入出力されるフローの作成
 トランザクションを開始および終了するフローを指定し、対応するポート間のアクションを接続します。
  • トランザクションの名前設定
 トランザクションの名前プロパティに値を割り当てる。
  • トランザクションの種類プロパティの設定
 トランザクションが定刻トランザクション、短時間の DTC スタイル トランザクション、または長時間トランザクションかを指定します。
  • タイムアウト プロパティの設定
 トランザクションの実行が許可される時間 (秒) を設定します。この時間を過ぎるとトランザクションは中断します。
  • 再試行回数プロパティの設定
 短時間の DTC スタイルのトランザクションのプロセスが完了しなかった場合にそのプロセスを再実行する回数を設定します。
  • バックオフの時間プロパティの設定
 トランザクションの再試行の時間間隔を設定します。
  • 分離レベル プロパティの設定
 同時実行する短時間の DTC スタイルのトランザクションの中のデータが相互に利用可能である度合を指定します。
  • スケジュールのステータスを永続化プロパティの設定
 トランザクションの開始前にスケジュールのステータスを永続化するかどうかを指定します。
コンポーネントおよびメッセージ キュー トランザクションのサポートについて :
  • COM コンポーネント内でのトランザクションのサポート レベルについて
 COM コンポーネントのトランザクションのサポートを、無効、サポートしない、サポートする、必要、新しいトランザクションを要求するのいずれかに指定します。
  • Windows スクリプト コンポーネント内でのトランザクションのサポート レベルについて
 Windows スクリプト コンポーネントのトランザクションのサポートを、無効、サポートしない、サポートする、必要、新しいトランザクションを要求するのいずれかに指定します。
  • メッセージ キューが提供するトランザクションのサポートについて
 このキューでトランザクションが必要とされるかどうかを指定します。
エラー処理プロパティの設定 :
  • 処理フローの中断
 条件の適用の結果、予期しない、または正しくない値が返された場合、プロセスのフローの中断を選択できます。
トランザクション エラー処理の有効化 :
  • 失敗時エラー処理の有効化
 これを有効化すると、XLANG スケジュールがトランザクションの失敗時コードを実行して、トランザクション内の失敗を適切に処理することができます。
  • 補正エラー処理の有効化
 これを有効化すると、XLANG スケジュールがトランザクションの補正コードを実行して、ネストされたトランザクションの結果をロールバックできます。
コンポーネント エラー処理の有効化 :
  • COM コンポーネントが失敗を返した場合のトランザクションの中断
 COM コンポーネントへのメソッド呼び出しで、失敗を表す HRESULT が返された場合にトランザクションを中断するかどうかを指定します。
  • Windows スクリプト コンポーネントが失敗を返した場合のトランザクションの中断
 Windows スクリプト コンポーネントへのメソッド呼び出しで、失敗を表す HRESULT が返された場合にトランザクションを中断するかどうかを指定します。
ポートの実装 :
  • XLANG スケジュール フローチャートへの未バインド ポートの追加
 ポートの実装の詳細を決定する前に、ポートをスケジュールに追加できます。
  • XLANG スケジュール フローチャートへのバインド済みポートの追加
 ポート実装を直接にスケジュールに追加します。
  • COM コンポーネントを使用したポートの実装
 既存の COM コンポーネントまたはアプリケーションを使用してアクションを実行します。
  • Windows スクリプト コンポーネントを使用したポートの実装
既存の Windows スクリプト コンポーネントを使用してアクションを実行します。
  • メッセージ キューを使用したポートの実装
 スケジュールが、疎結合されている別のスケジュールまたはアプリケーションと通信できるようにします。
  • BizTalk メッセージを使用したポートの実装
 スケジュールがBizTalk メッセージ サービスを使用して通信できるようにします。
  • ポート実装のプロパティの変更
 ユーザーの実装の種類と動作を決定するさまざまなプロパティを変更します。
メッセージの送信と受信 :
  • アクションとポート間の通信フローの確立
 自社のビジネス プロセス内のアクションと外部ビジネス プロセスの間の通信のフローを作成します。
  • 同期メッセージの送信と受信
 自社のビジネス プロセス内のアクションと外部ビジネス プロセスの間の通信の同期フローを指定します。
  • 非同期メッセージの送信と受信
 自社のビジネス プロセス内のアクションと外部ビジネス プロセスの間の通信の非同期フローを指定する。
  • アクションとポート間の通信フローの変更
 通信フローが同期か非同期かを指定します。
  • メッセージ間のデータ フローの記述
 メッセージ、フィールドおよびポートを選択し、その間のデータのフローを記述することによってデータの相互関係を記述できます。
  • 定数の使用
 データ ページで指定されている定数を使用して、メッセージ フィールドのデータを提供します。
XLANG スケジュールの実行
XLANG スケジュールのコンパイルとデバッグ :
  • XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル
 ビジネス プロセスの XLANG スケジュール フローチャートから対応する実行可能 XLANG スケジュールを作成します。
  • XLANG スケジュールの実行 (操作方法)
 ビジネス プロセス (BizTalk Server の基本アクション) を実行する。
  • XLANG スケジュールのプール
 リソースの利用を最適化するために、メモリの中で同時にアクティブ化できる XLANG スケジュールのインスタンスの数を制御します。
  • コンパイルされた Visual Basic コンポーネントのデバッグ
 Microsoft Visual Basic で作成されたコンポーネントにブレークポイントを設定し、コードを表示し、デバッグします。
  • メソッド署名の更新
 利用可能なメソッド呼び出しのパラメタを変更した場合、この手順を使用してスケジュールでこのメソッド パラメタを利用できるようにします。
  • 実行中のすべての XLANG スケジュールのシャットダウン
 スケジュールが使用する COM コンポーネントを変更します。スケジュール インスタンスが実行中の場合、COM コンポーネントを含むファイルはロックされます。
XLANG スケジュール ホスト アプリケーションの作成と構成 :
  • XLANG スケジュールをホストする COM+ アプリケーションの作成
 セキュリティ、配置または公正の問題がある場合、スケジュールを COM+ アプリケーション内から実行すると便利です。
  • XLANG スケジュールをホストする COM+ アプリケーションの構成
 ホスト アプリケーションのパフォーマンスおよび動作に影響を及ぼすさまざまな COM+ アプリケーション プロパティを設定または変更します。


BizTalk オーケストレーション デザイナでの作業方法

ここでは、BizTalk オーケストレーション デザイナを使用して XLANG スケジュール フローチャートを作成し、それをコンパイルして実行可能な XLANG スケジュールにする方法を作業ごとに説明します。また、XLANG スケジュールの実行方法についても説明します。「BizTalk オーケストレーション デザイナについて」を参照し、BizTalk オーケストレーション デザイナのすべての機能について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • BizTalk オーケストレーション デザイナの使用

  • XLANG スケジュールの実行

注

  • 次の規則はトランザクション、ポート、メッセージ、条件、キューおよびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。


BizTalk オーケストレーション デザイナの使用

ここでは、BizTalk オーケストレーション デザイナを使用して XLANG スケジュール フローチャートを設計し、それをコンパイルして XLANG スケジュールにする方法について説明します。

ここには次のトピックが含まれます。

  • XLANG スケジュール フローチャートを開く、および保存する

  • ページ、シェイプ、およびステンシルの表示

  • シェイプの追加、削除、および接続

  • 条件付きシェイプのプロパティの設定

  • 同時実行のプロパティの設定

  • トランザクション プロパティの設定

  • エラー処理プロパティの設定

  • ポートの実装

  • メッセージの送信と受信

  • メッセージ間のデータ フローの記述

注

  • VBA フォルダの中の 1 つ以上のファイルが正しく登録されていないか、破損した場合、BizTalk オーケストレーション デザイナを開けなくなります。Microsoft Office をアンインストールした時にこの問題が発生する場合があります。
    • Office がインストールされていない場合、Microsoft Office CD 上の Vba6.msi を見つけ、右クリックしてから [インストール] をクリックします。

    • Office がインストールされている場合、Microsoft Access を開き、空白のデータベースを作成し、それを保存して Access を閉じます。
  • Microsoft Visio の使用中に標準ツールバーを非表示にしている場合、オーケストレーション デザイナを開いた時にはこのバーは表示されません。このバーを表示するには、以下の手順を実行します。
    1. [ファイル] メニューの [終了] を選択して BizTalk オーケストレーション デザイナを閉じます。[スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft Visio] をクリックします。

    2. [表示] メニューの [ツールバー] をポイントし、[標準] をクリックします。

    3. [ファイル] メニューの [終了] を選択して Visio を閉じます。

    4. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk オーケストレーション デザイナ] をクリックします。

      ツールバーが表示されます。

  • BizTalk オーケストレーション デザイナを使用した後、Visio を開いた時に一部のメニューおよびツールバーがアクセスできなくなります。Visio のコンテキスト メニューを使用してツールバーやメニューをカスタマイズして、必要な項目をアクティブにすることができます。

各国語対応に関する問題

  • 言語によっては BizTalk オーケストレーション デザイナで一部の文字が正しく表示されないことがあります。これを修正するには、Microsoft 2002 が常にシステムの既定フォントを使用するように指定します。
    1. BizTalk オーケストレーション デザイナを閉じます。

    2. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Microsoft Visio] をクリックします。

    3. [ツール] メニューの [オプション] をクリックします。

      [オプション] ダイアログ ボックスが表示されます。

    4. [地域のオプション] タブをクリックし、[図面の基本フォント] の [常にシステムの既定フォントを使用] を選択します。

    5. Visio を閉じ、BizTalk オーケストレーション デザイナを開きます。


XLANG スケジュール フローチャートを開く、および保存する

ここには次のトピックが含まれます。

  • 新しい XLANG スケジュール フローチャートの作成

  • 既存の XLANG スケジュール フローチャートを開く

  • XLANG スケジュール フローチャートの保存


新しい XLANG スケジュール フローチャートの作成

この手順では、デザイナ ウィンドウ内に新しい XLANG スケジュール フローチャートが開きます。既定の設計開始ページは [ビジネス プロセス] ページです。また、新しいフローチャートを開始すると、[フローチャート ステンシル] および [実装ステンシル] も既定で開きます。

  • BizTalk オーケストレーション デザイナで、[ファイル] メニューの [新規作成] をクリックします。

注

  • XLANG スケジュール フローチャートのファイル拡張子は .skv です。

関連項目

既存の XLANG スケジュール フローチャートを開く

XLANG スケジュール フローチャートの保存


既存の XLANG スケジュール フローチャートを開く

  1. BizTalk オーケストレーション デザイナで、[ファイル] メニューの [開く] をクリックします。

    [XLANG スケジュール フローチャートを開く] ダイアログ ボックスが表示されます。

  2. XLANG スケジュール フローチャートを参照し、目的のフローチャートをクリックします。次に、[開く] をクリックします。

注

  • XLANG スケジュール フローチャートのファイル拡張子は .skv です。

  • XLANG スケジュールのファイル拡張子は .skx です。BizTalk オーケストレーション デザイナでは、.skx ファイルを開くことはできません。.skx ファイルを変更または更新するには、ソースの .skv ファイルを開いて変更した後、その .skv ファイルを .skx ファイルに再コンパイルします。

関連項目

新しい XLANG スケジュール フローチャートの作成

XLANG スケジュール フローチャートの保存


XLANG スケジュール フローチャートの保存

  • BizTalk オーケストレーション デザイナで、[ファイル] メニューの [<ファイル> の保存] をクリックします。

注

  • ファイル名のパラメータ <ファイル> は、保存するファイル名に置き換えられます。

  • XLANG スケジュール フローチャートを保存する場合、フローチャートは既定で <図面 X>.skv という名前で保存されます。ここで、X はフローチャート名に付加された番号です。これ以外の名前に変更して保存することもできます。

  • [ファイル] メニューの [名前を付けて保存] をクリックする方法もあります。その場合、[XLANG スケジュール フローチャートに名前を付けて保存] ダイアログ ボックスが表示され、次のことを行うことができます。
    • ファイル名を別の名前に変更する。

    • ファイルを別の場所に保存する。
  • XLANG スケジュール フローチャートのファイル拡張子は .skv です。

  • XLANG スケジュールのファイル拡張子は .skx です。BizTalk オーケストレーション デザイナでは、.skx ファイルを開くことはできません。.skx ファイルを変更または更新するには、ソースの .skv ファイルを開いて変更した後、その .skv ファイルを .skx ファイルに再コンパイルします。

関連項目

新しい XLANG スケジュール フローチャートの作成

既存の XLANG スケジュール フローチャートを開く


ページ、シェイプ、およびステンシルの表示

BizTalk オーケストレーション デザイナには、フローチャート領域を最大化したり、特定のシェイプまたはデータの関係を表示するための、いくつかの表示オプションがあります。

ここには次のトピックが含まれます。

  • 設計ページの表示

  • シェイプの表示

  • ステンシルの表示

  • 複数のウィンドウの使用

  • コメントの使用

  • XLANG スケジュール フローチャートのプレビュー、印刷、およびサイズ変更


設計ページの表示

ここには次のトピックが含まれます。

  • ビジネス プロセス ページの表示

  • データ ページの表示

  • ビジネス プロセス ページとデータ ページの表示

  • トランザクションの補正ページの表示

  • トランザクションの失敗時ページの表示

  • ページの表示

関連項目

複数のウィンドウの使用

シェイプの表示

ステンシルの表示


ビジネス プロセス ページの表示

  • [表示] メニューの [ビジネス プロセス ページ] をクリックします。

注

  • 設計ページの下部にある [ビジネス プロセス] タブをクリックする方法もあります。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの補正ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

データ ページの表示


データ ページの表示

  • [表示] メニューの [データ ページ] をクリックします。

注

  • 設計ページの下部にある [データ] タブをクリックする方法もあります。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの補正ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

ビジネス プロセス ページの表示


ビジネス プロセス ページとデータ ページの表示

  • [表示] メニューの [ビジネス プロセス ページとデータ ページ] をクリックします。

注

  • この表示オプションを選択すると、1 つの XLANG スケジュールに対して、[ビジネス プロセス] ウィンドウと [データ] ウィンドウの 2 つのウィンドウが開きます。この機能は、[新しいウィンドウを開く] オプションの動作に似ています。複数のウィンドウを開く方法については、「複数のウィンドウの使用」を参照してください。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの補正ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページの表示

データ ページの表示


トランザクションの補正ページの表示

  • 設計ページの下部で、表示するページの [<トランザクション> の補正] タブをクリックします。

注

  • ページ名のパラメータ <トランザクション> は、エラー処理プロセスが関連付けられているトランザクション名に置き換えられます。

  • [<トランザクション> の補正] ページを XLANG スケジュール フローチャートに追加する方法については、「補正エラー処理の有効化」を参照してください。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

ビジネス プロセス ページの表示

データ ページの表示


トランザクションの失敗時ページの表示

  • 設計ページの下部で、表示するページの [<トランザクション> の失敗時] タブをクリックします。

注

  • ページ名のパラメータ <トランザクション> は、エラー処理プロセスが関連付けられているトランザクション名に置き換えられます。

  • [<トランザクション> の失敗時] ページを XLANG スケジュール フローチャートに追加する方法については、「失敗時エラー処理の有効化」を参照してください。

関連項目

複数のウィンドウの使用

ページの表示

トランザクションの補正ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

ビジネス プロセス ページの表示

データ ページの表示


ページの表示

  • 表示するページのタブをクリックします。

注

  • 各ページのタブは、設計ページの下部にあります。

関連項目

複数のウィンドウの使用

トランザクションの補正ページの表示

トランザクションの失敗時ページの表示

シェイプの表示

ステンシルの表示

ビジネス プロセス ページとデータ ページの表示

ビジネス プロセス ページの表示

データ ページの表示


シェイプの表示

ここには次のトピックが含まれます。

  • フローチャート シェイプの表示

  • フローチャート シェイプと通信シェイプの表示

  • フローチャート シェイプ、通信シェイプ、および実装シェイプの表示

関連項目

ステンシルの表示

設計ページの表示


フローチャート シェイプの表示

このオプションを使用した場合、設計ページには、フローチャート シェイプおよびその相互の接続だけが表示されます。すべてのポート、ポート メッセージ、実装、およびポートとアクションまたはポートと実装との間の接続は表示されません。

  • [表示] メニューの [フローチャート シェイプ] をクリックします。

注

  • この表示オプションは、[データ] ページでは使用できません。

関連項目

フローチャート シェイプと通信シェイプの表示

フローチャート シェイプ、通信シェイプ、および実装シェイプの表示

ステンシルの表示

設計ページの表示


フローチャート シェイプと通信シェイプの表示

このオプションを使用した場合、設計ページには、フローチャート シェイプおよびその相互の接続だけが表示されます。ポート、ポート メッセージ、およびポートとアクションとの間の接続も表示されます。すべての実装、およびポートと実装との間の接続は表示されません。

  • [表示] メニューの [フローチャート シェイプと通信シェイプ] をクリックします。

注

  • この表示オプションは、[データ] ページでは使用できません。

関連項目

フローチャート シェイプ、通信シェイプ、および実装シェイプの表示

フローチャート シェイプの表示

ステンシルの表示

設計ページの表示


フローチャート シェイプ、通信シェイプ、および実装シェイプの表示

  • [表示] メニューの [フローチャート シェイプ、通信シェイプ、および実装シェイプ] をクリックします。

注

  • すべてのシェイプと、その相互の接続が表示されます。

  • この表示オプションは、[データ] ページでは使用できません。

関連項目

フローチャート シェイプと通信シェイプの表示

フローチャート シェイプの表示

ステンシルの表示

設計ページの表示


ステンシルの表示

ここには次のトピックが含まれます。

  • フローチャート ステンシルの表示

  • 実装ステンシルの表示

関連項目

シェイプの表示

設計ページの表示


フローチャート ステンシルの表示

  • [表示] メニューの [ステンシル] をポイントし、[フローチャート] をクリックすると、フローチャート ステンシルの表示と非表示が切り替わります。

関連項目

シェイプの表示

設計ページの表示

実装ステンシルの表示


実装ステンシルの表示

  • [表示] メニューの [ステンシル] をポイントし、[実装] をクリックすると、実装ステンシルの表示と非表示が切り替わります。

関連項目

シェイプの表示

設計ページの表示

フローチャート ステンシルの表示


複数のウィンドウの使用

ここには次のトピックが含まれます。

  • 新しいウィンドウを開く

  • ウィンドウを並べて表示

  • ウィンドウを重ねて表示

  • ウィンドウのフォーカスの切り替え

関連項目

設計ページの表示


新しいウィンドウを開く

  • [ウィンドウ] メニューの [新しいウィンドウを開く] をクリックします。

注

  • 複数のウィンドウで、同じ XLANG スケジュールを追加して表示すると、次のことを行うことができます。
    • 同じ XLANG スケジュールの異なるページを同時に表示できます。たとえば、[ビジネス プロセス] ページ、[データ] ページ、および [<トランザクション> の補正] ページを開いて表示することができます。

    • XLANG スケジュールの同じページの異なる部分を同時に表示できます。たとえば、一方で XLANG スケジュールの特定のシェイプのセットを見るために拡大して表示し、もう一方でスケジュール全体を見るために縮小して表示することができます。

関連項目

ウィンドウを重ねて表示

ウィンドウのフォーカスの切り替え

ウィンドウを並べて表示

設計ページの表示


ウィンドウを並べて表示

ウィンドウを並べて表示すると、複数のウィンドウを同時に見ることができます。

  • [ウィンドウ] メニューの [並べて表示] をクリックします。

注

  • 複数のウィンドウで、同じ XLANG スケジュールを追加して表示すると、次のことを行うことができます。
    • 同じ XLANG スケジュールの異なるページを同時に表示できます。たとえば、[ビジネス プロセス] ページ、[データ] ページ、および [<トランザクション> の補正] ページを開いて表示することができます。

    • XLANG スケジュールの同じページの異なる部分を同時に表示できます。たとえば、一方で XLANG スケジュールの特定のシェイプのセットを見るために拡大して表示し、もう一方でスケジュール全体を見るために縮小して表示することができます。

関連項目

ウィンドウを重ねて表示

ウィンドウのフォーカスの切り替え

新しいウィンドウを開く

設計ページの表示


ウィンドウを重ねて表示

ウィンドウを重ねて表示すると、1 つのウィンドウを画面の手前に表示できます。別のウィンドウのタイトル バーをクリックすると、そのウィンドウが画面の手前に表示されます。

  • [ウィンドウ] メニューの [重ねて表示] をクリックします。

注

  • 複数のウィンドウで、同じ XLANG スケジュールを追加して表示すると、次のことを行うことができます。
    • 同じ XLANG スケジュールの異なるページを同時に表示できます。たとえば、[ビジネス プロセス] ページ、[データ] ページ、および [<トランザクション> の補正] ページを開いて表示することができます。

    • XLANG スケジュールの同じページの異なる部分を同時に表示できます。たとえば、一方で XLANG スケジュールの特定のシェイプのセットを見るために拡大して表示し、もう一方でスケジュール全体を見るために縮小して表示することができます。

関連項目

ウィンドウのフォーカスの切り替え

新しいウィンドウを開く

ウィンドウを並べて表示

設計ページの表示


ウィンドウのフォーカスの切り替え

  • [ウィンドウ] メニューで、フォーカスを設定するウィンドウの名前をクリックします。

注

  • ウィンドウの名前は、XLANG スケジュールの名前にデザイン ページの名前を付加した名前です (たとえば、Schedule1.skv:Business Process あるいは Schedule1.skv:Data のようになります)。

  • 複数のウィンドウで、同じ XLANG スケジュールを追加して表示すると、次のことを行うことができます。
    • 同じ XLANG スケジュールの異なるページを同時に表示できます。たとえば、[ビジネス プロセス] ページ、[データ] ページ、および [<トランザクション> の補正] ページを開いて表示することができます。

    • XLANG スケジュールの同じページの異なる部分を同時に表示できます。たとえば、一方で XLANG スケジュールの特定のシェイプのセットを見るために拡大して表示し、もう一方でスケジュール全体を見るために縮小して表示することができます。

関連項目

ウィンドウを重ねて表示

新しいウィンドウを開く

ウィンドウを並べて表示

設計ページの表示


コメントの使用

ここには次のトピックが含まれます。

  • コメントの追加

  • コメントの編集

  • コメント内のテキストの書式設定

  • コメントの削除


コメントの追加

  1. BizTalk オーケストレーション デザイナで、ツール バーの [テキスト ツール] ( テキスト ツール) をクリックします。

  2. コメントを作成する領域を、マウス ポインタでドラッグします。

  3. コメントを入力します。

注

  • [テキスト ツール] をオフにするには、ツール バーの [オブジェクト選択ツール] ( オブジェクト選択ツール) ボタンをクリックします。

  • BizTalk オーケストレーション デザイナはカスタマイズされた Microsoft Visio インターフェイスを使用しているため、[テキスト ツール] ボタンには 2 つのオプションがあります。これらの 2 つのボタンの機能は同じです。
    • [テキスト ツール] ( テキスト ツール) ボタン

    • [テキストブロック ツール] ( テキストブロック ツール) ボタン

関連項目

コメントの削除

コメントの編集

コメント内のテキストの書式設定


コメントの編集

  1. BizTalk オーケストレーション デザイナで、ツール バーの [テキスト ツール] ( テキスト ツール) をクリックします。

  2. 編集するコメントをクリックします。

  3. コメントを編集します。

注

  • [テキスト ツール] をオフにするには、ツール バーの [オブジェクト選択ツール] ( オブジェクト選択ツール) ボタンをクリックします。

  • BizTalk オーケストレーション デザイナはカスタマイズされた Microsoft Visio インターフェイスを使用しているため、[テキスト ツール] ボタンには 2 つのオプションがあります。これらの 2 つのボタンの機能は同じです。
    • [テキスト ツール] ( テキスト ツール) ボタン

    • [テキストブロック ツール] ( テキストブロック ツール) ボタン

関連項目

コメントの追加

コメントの削除

コメント内のテキストの書式設定


コメント内のテキストの書式設定

  1. BizTalk オーケストレーション デザイナの設計ページで、書式設定するコメントを 1 つ以上選択します。

  2. [書式] メニューの [テキスト] をクリックします。

    [テキスト] ダイアログ ボックスが表示されます。このダイアログ ボックスには、テキストのサイズ、フォント、およびスタイルに関するオプションがいくつかあります。

  3. 使用するオプションを選択し、[OK] をクリックします。

注

  • これらのオプションは、XLANG スケジュール フローチャート内で強調表示しているコメント、およびこれから作成するすべての新しいコメントに適用されます。

  • コメントを選択するには、そのコメントをクリックします。複数のコメントを選択するには、Shift キーを押しながら、選択するコメントをクリックします。

関連項目

コメントの追加

コメントの削除

コメントの編集


コメントの削除

  • BizTalk オーケストレーション デザイナの設計ページで、削除するコメントをクリックし、Delete キーを押します。

注

  • XLANG スケジュール フローチャートからコメントを削除するには、[テキスト ツール] をオフにしておく必要があります。

関連項目

コメントの追加

コメント内のテキストの書式設定


XLANG スケジュール フローチャートのプレビュー、印刷、およびサイズ変更

ここには次のトピックが含まれます。

  • 印刷プレビューの使用

  • XLANG スケジュール フローチャートの印刷

  • XLANG スケジュール フローチャートのサイズ変更


印刷プレビューの使用

  • [ファイル] メニューの [印刷プレビュー] をクリックします。

注

  • [印刷の向き] オプションを [横] から [縦] に変更すると、次のメッセージが表示されます。

    1 つまたは複数の図面ページが印刷のページ設定とは異なる向きに設定されています。複数ページに渡って印刷するには [OK] をクリックします。向きを揃えるには、印刷ページの向きを変更します。

    [OK] をクリックして変更を適用すると、印刷プレビューは次のような表示になります。

    • [次の印刷面] をクリックして次のページへ進んでから、[前の印刷面] をクリックして前のページに戻ると、印刷プレビューには、一部のシェイプがそのページに存在しないかのように表示されます。この表示は問題ありません。実際の XLANG スケジュールでは、複数ページに渡って正しく印刷されます。

関連項目

XLANG スケジュール フローチャートの印刷

XLANG スケジュール フローチャートのサイズ変更


XLANG スケジュール フローチャートの印刷

  1. [ファイル] メニューの [印刷] をクリックします。

    [印刷] ダイアログ ボックスが表示されます。

  2. 希望するオプションを選択して [印刷] をクリックします。

注

  • XLANG スケジュール フローチャートの印刷を開始する前にプリンタがインストールされていることを確認してください。

関連項目

XLANG スケジュール フローチャートのサイズ変更

印刷プレビューの使用


XLANG スケジュール フローチャートのサイズ変更

  1. BizTalk オーケストレーション デザイナで、[表示] メニューの [ページ全体を表示] をクリックします。

  2. Ctrl キーを押しながら、マウス ポインタをページ枠に移動します。

    ページ枠でマウス ポインタの形が双方向矢印に変わります。

  3. ページ枠をクリックしてドラッグすると、サイズを変更できます。

関連項目

XLANG スケジュール フローチャートの印刷

印刷プレビューの使用


シェイプの追加、削除、および接続

ここには次のトピックが含まれます。

  • シェイプの追加

  • シェイプの名前設定

  • シェイプの削除

  • 未使用のポートおよびメッセージの削除

  • シェイプの接続


シェイプの追加

  • フローチャート シェイプを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

  • BizTalk オーケストレーション デザイナの [フローチャート] ステンシルで、シェイプをクリックし、設計ページまでドラッグします。

注

  • XLANG スケジュール フローチャートへの [実装] シェイプの追加方法については、「ポートの実装」を参照してください。

  • [データ] ページにはシェイプを追加できません。アクションをポートに接続するたびに、[データ] ページに新しいメッセージが自動的に作成されます。

関連項目

シェイプの接続

シェイプの削除

未使用のポートおよびメッセージの削除

シェイプの名前設定

フローチャート ステンシルの表示


シェイプの名前設定

  1. BizTalk オーケストレーション デザイナの設計ページで、シェイプを右クリックし、[プロパティ] をクリックします。

    [<シェイプ> のプロパティ] ダイアログ ボックスが表示されます。

  2. [名前] ボックスに、名前を入力します。

注

  • 各シェイプの "名前" プロパティには、たとえば [アクション 1] のように、そのシェイプの名前に番号を加えたものが、既定値として表示されます。この既定値は必要に応じて変更できます。

  • 開始、終了、判断、繰り返し、分岐、結合、および中断の各シェイプには、名前を付けることができません。

  • 名前を付けることができるのは、アクション、トランザクション、ポート、メッセージ、および条件の各シェイプです。

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • 1 バイト文字セットによるトランザクション名の長さは、16 文字以内にします。2 バイト文字セットによるトランザクション名の長さは、8 文字以内にします。

  • アクションには、最大の長さが 32 文字という点を除いて、命名規則による制限がありません。

関連項目

シェイプの追加

シェイプの接続

シェイプの削除

未使用のポートおよびメッセージの削除


シェイプの削除

  • 削除するシェイプをクリックし、Delete キーを押します。

注

  • 接続をクリックし、Delete キーを押すと、2 つのシェイプ間の接続を削除できます。

  • 複数のシェイプと接続しているシェイプを削除すると、それらの接続もすべて削除されます。

  • トランザクションを削除すると、そのトランザクションに含まれているシェイプもすべて削除されます。

  • BizTalk メッセージ、またはメッセージ キューの実装を削除しても、その実装の接続先のポートは削除されません。

  • COM コンポーネント、または Windows スクリプト コンポーネントの実装を削除すると、その実装の接続先のポートも削除されます。

  • ポートに含まれたメッセージをクリックし、Delete キーを押すと、メッセージを削除できます。[データ] ページ上の、関連付けられたメッセージが削除されます。

    [データ] ページからメッセージを削除することもできます。詳細については、「メッセージの削除」を参照してください。

  • この削除の手順では、条件を削除できません。条件の削除については、次のトピックを参照してください。
    • 判断条件の削除

    • 繰り返しループ条件の削除

    • 未使用の条件の削除

関連項目

シェイプの追加

シェイプの接続

メッセージの削除

判断条件の削除

繰り返しループ条件の削除

未使用のポートおよびメッセージの削除

未使用の条件の削除

シェイプの名前設定


未使用のポートおよびメッセージの削除

この手順では、未使用のすべてのポート、およびそのポートに含まれるすべてのメッセージが、XLANG スケジュール フローチャートから削除されます。[データ] ページ上の、対応するメッセージも削除されます。

  • BizTalk オーケストレーション デザイナで、[ツール] メニューの [未使用のポートとメッセージの削除] をクリックします。

関連項目

シェイプの追加

シェイプの接続

シェイプの削除

シェイプの名前設定


シェイプの接続

ここには次のトピックが含まれます。

  • シェイプの選択

  • 2 つのシェイプの接続

  • コネクタ ツールの使用

  • シェイプの縦軸方向または横軸方向の整列

関連項目

シェイプの追加

シェイプの削除

未使用のポートおよびメッセージの削除

シェイプの名前設定


シェイプの選択

シェイプを選択することによって次のことができます。

  • 制御ハンドル ( 制御ハンドル) をシェイプ間でドラッグする。

  • 利用可能なシェイプ プロパティを編集する。

  • シェイプを切り取り、コピー、貼り付け、消去、複製する。

  • 行うことができる操作は、シェイプによって異なります。

  • BizTalk オーケストレーション デザイナの設計ページで、選択するシェイプをクリックします。

    選択したシェイプは、緑の点線で囲まれます。また、そのシェイプで利用可能なすべての制御ハンドル ( 制御ハンドル) が有効になります。

注

  • [ポート] シェイプに接続された [アクション] シェイプをコピーすると、そのコピーされたアクションも同じポートに接続されます。

関連項目

シェイプの追加

2 つのシェイプの接続

シェイプの削除

コネクタ ツールの使用


2 つのシェイプの接続

  1. 2 つのシェイプを接続するには、一方のシェイプを選択します。

    選択したシェイプは、緑の点線で囲まれます。また、そのシェイプで利用可能なすべての制御ハンドル ( 制御ハンドル) が有効になります。

  2. 接続する制御ハンドルを、もう一方のシェイプの接続ポイント ( 接続ポイント) までドラッグします。

  3. 接続ポイントが赤い四角形 ( アクティブ接続ポイント) で強調表示されたら、マウス ボタンを離して接続を設定します。

注

  • 処理フローは、シェイプの上部と下部の接続ポイント、および制御ハンドルから接続されます。

  • 通信フローは、アクション シェイプの右側の制御ハンドルから、ポート シェイプの左側の接続ポイントへ接続されます。

  • シェイプの接続には、コネクタ ツールも使用できます。詳細については、「コネクタ ツールの使用」を参照してください。

関連項目

シェイプの追加

シェイプの削除

シェイプの選択

コネクタ ツールの使用


コネクタ ツールの使用

  1. ツール バーの [コネクタ ツール] ( コネクタ ツール)) ボタンをクリックします。

  2. 作成する接続の接続元となるシェイプの制御ハンドル ( 制御ハンドル) をポイントします。

    制御ハンドルが赤い四角形で囲まれ、ドラッグ可能になったことが示されます。

  3. マウス ボタンを押しながら、そのシェイプから作成する接続の接続先となるシェイプの接続ポイント ( 接続ポイント) まで、制御ハンドルをドラッグします。

  4. 接続先シェイプの接続ポイントが赤い四角形 ( アクティブ接続ポイント) で囲まれたら、マウス ボタンを離して接続を確立します。

注

  • コネクタ ツールをオフするには、ツール バーの [オブジェクト選択ツール] ( オブジェクト選択ツール) ボタンをクリックします。

  • [アクション] シェイプを [ポート] シェイプに接続するには、オブジェクト選択ツールを使用することをお勧めします。コネクタ ツールを使用して COM またはスクリプト コンポーネントにバインドされたアクションとポートの間の接続を作成した場合、後で対応するコンポーネント バインド ウィザードを起動したときに、プロパティが変更されていない場合も接続を再作成することを要求されます。

  • コネクタ ツールが有効になっているときは、ページにシェイプを追加したり、そのほかの操作を行うことができます。ただし、エラー メッセージが表示される場合があります。このエラー メッセージは無効なため、問題ありません。この誤ってエラーが表示される問題は、Microsoft Visio の今後のリリースで修正される予定です。このエラー メッセージが表示された場合は、[OK] をクリックして先に進んでください。メッセージの内容は次のとおりです。

    Visio 内部エラー #-1

    アクション 1246: ページへドロップ

    ファイルを一度閉じてから再度開いてみてください。症状が変わらない場合は Visio を再起動してみてください。

関連項目

シェイプの追加

2 つのシェイプの接続

シェイプの削除

シェイプの選択


シェイプの縦軸方向または横軸方向の整列

  1. BizTalk オーケストレーション デザイナの設計ページで、軸に揃えて整列させるシェイプの周囲をマウス ポインタでドラッグします。

  2. ツール バーの [シェイプの整列] ( シェイプの整列) ボタンをクリックします。

    [シェイプの整列] ダイアログ ボックスが表示されます。

  3. 次のどこかで、使用する整列をクリックします。
    • [上下の整列] の次のいずれかのボタンをリックします。

      水平上揃えボタン 水平上揃え

      水平中心線揃えボタン 水平中心線揃え

      水平下揃えボタン 水平下揃え

    • [左右の整列] の次のいずれかのボタンをクリックします。

      垂直左揃えボタン 垂直左揃え

      垂直中心線揃えボタン 垂直中心線揃え

      垂直右揃えボタン 垂直右揃え

注

  • 設計ページでシェイプを選択しないと、[シェイプの整列] ボタンが有効になりません。

  • シェイプは、1 つの軸だけに揃えて整列することを推奨します。両方の軸に揃えてシェイプを整列すると、シェイプが重なって表示される場合があります。誤って変更した場合は、Ctrl キーを押しながら Z キーを押すと元に戻ります。

  • [図形の整列] ダイアログ ボックスで、選択を解除するボタン ( 選択解除ボタン) をクリックすると、整列の選択が消去されます。

  • [新規ガイドを作成し、図形を揃える] チェック ボックスは、常に使用できません。

  • Shift キーを押しながらシェイプをクリックすると、複数のシェイプを選択できます。


条件付きシェイプのプロパティの設定

ここには次のトピックが含まれます。

  • 判断条件の設定

  • 繰り返しループの状態の設定

  • 条件の作成

関連項目

条件の設計


判断条件の設定

ここには次のトピックが含まれます。

  • 判断条件の追加

  • 判断条件の編集

  • 判断条件の削除

  • 条件の評価順序の決定

関連項目

条件の作成

条件の設計


判断条件の追加

  1. BizTalk オーケストレーション デザイナの設計ページで、条件を追加する [判断] シェイプを右クリックし、[条件の作成] をクリックします。

    [条件の作成] ダイアログ ボックスが表示されます。

  2. 次のオプションのいずれかをクリックします。
    • [新しい条件の作成]

      [OK] をクリックします。[条件のプロパティ] ダイアログ ボックスが表示されます。

      条件の作成の詳細については、「条件の作成」を参照してください。

    • [既存の条件の追加]

      [利用可能な条件] ボックスの一覧で、追加する条件をクリックし、[OK] をクリックします。

      [条件の作成] ダイアログ ボックスが閉じ、条件が判断に追加されます。

注

  • XLANG スケジュール フローチャートに初めて条件を追加するときは、[条件の作成] をクリックすると [条件のプロパティ] ダイアログ ボックスが表示されます。[条件の作成] ダイアログ ボックスが表示されるのは、判断に追加可能な条件が、既に 1 つまたは複数作成されている場合だけです。[条件のプロパティ] ダイアログ ボックスの詳細については、「条件の作成」を参照してください。

  • [判断] シェイプを右クリックし、[プロパティ] をクリックしてから [追加] をクリックしても、判断に条件を追加できます。

関連項目

条件の作成

判断条件の削除

条件の設計

条件の評価順序の決定

判断条件の編集


判断条件の編集

  1. BizTalk オーケストレーション デザイナの設計ページで、[判断] シェイプを右クリックし、[プロパティ] をクリックします。

    [判断のプロパティ] ダイアログ ボックスが表示されます。

  2. 編集する条件をクリックし、[編集] をクリックします。

    [条件のプロパティ] ダイアログ ボックスが表示されます。

  3. 変更を行って、[OK] をクリックします。

    [条件のプロパティ] ダイアログ ボックスの詳細については、「条件の作成」を参照してください。

  4. 別の条件を編集するには、その条件をクリックし、[編集] をクリックします。

    – または –

    [判断のプロパティ] ダイアログ ボックスを閉じるには、[OK] をクリックします。

注

  • [判断のプロパティ] ダイアログ ボックスでは、[追加] をクリックすると条件を追加できます。

  • [判断] シェイプに含まれる条件を右クリックし、[プロパティ] をクリックしても、条件を編集できます。この操作では、[条件のプロパティ] ダイアログ ボックスが表示されます。

関連項目

判断条件の追加

条件の作成

判断条件の削除

条件の設計

条件の評価順序の決定


判断条件の削除

  1. BizTalk オーケストレーション デザイナの設計ページで、条件を削除する [判断] シェイプを右クリックし、[プロパティ] をクリックします。

    [判断のプロパティ] ダイアログ ボックスが表示されます。

  2. 削除する条件をクリックし、[削除] をクリックします。

関連項目

判断条件の追加

条件の作成

条件の設計

条件の評価順序の決定

判断条件の編集


条件の評価順序の決定

  1. BizTalk オーケストレーション デザイナの設計ページで、[判断] シェイプを右クリックし、[プロパティ] をクリックします。

    [判断のプロパティ] ダイアログ ボックスが表示されます。

  2. 評価順序を変更する条件をクリックします。

  3. [順序] で、上矢印または下矢印をクリックして条件を移動し、一覧に表示される順序を変更します。

注

  • 条件の順序は、優先順位の高いものから順に設定することをお勧めします。条件は条件の 1 つが TRUE と評価されるまで、順番に実行されます。次に、最初に TRUE と評価された条件に対する処理フローが実行されます。TRUE と評価される条件がない場合は、ELSE 処理フローが実行されます。

関連項目

判断条件の追加

条件の作成

判断条件の削除

条件の設計

判断条件の編集


繰り返しループの状態の設定

ここには次のトピックが含まれます。

  • 繰り返しループ条件の追加

  • 繰り返しループ条件の編集

  • 繰り返しループ条件の削除

  • 繰り返しループのステータスの保持

関連項目

条件の作成

条件の設計


繰り返しループ条件の追加

  1. BizTalk オーケストレーション デザイナの設計ページで、条件を追加する [繰り返し] シェイプを右クリックし、[条件の作成] をクリックします。

    [条件の作成] ダイアログ ボックスが表示されます。

  2. 次のオプションのいずれかをクリックします。
    • [新しい条件の作成]

      [OK] をクリックします。[条件のプロパティ] ダイアログ ボックスが表示されます。

      条件の作成の詳細については、「条件の作成」を参照してください。

    • [既存の条件の追加]

      [利用可能な条件] ボックスの一覧で、追加する条件をクリックし、[OK] をクリックします。

      [条件の作成] ダイアログ ボックスが閉じ、条件が繰り返しループに追加されます。

注

  • XLANG スケジュール フローチャートに初めて条件を追加するときは、[条件の作成] をクリックすると [条件のプロパティ] ダイアログ ボックスが表示されます。[条件の作成] ダイアログ ボックスが表示されるのは、繰り返しループに追加可能な条件が、既に 1 つまたは複数作成されている場合だけです。[条件のプロパティ] ダイアログ ボックスの詳細については、「条件の作成」を参照してください。

  • 繰り返しループに追加できる条件は 1 つだけです。

関連項目

条件の作成

繰り返しループ条件の削除

条件の設計

繰り返しループ条件の編集

繰り返しループのステータスの保持


繰り返しループ条件の編集

  1. BizTalk オーケストレーション デザイナの設計ページで、[繰り返し] シェイプに含まれた条件を右クリックし、[プロパティ] をクリックします。

    [条件のプロパティ] ダイアログ ボックスが表示されます。

  2. 変更を行って、[OK] をクリックします。

    [条件のプロパティ] ダイアログ ボックスの詳細については、「条件の作成」を参照してください。

関連項目

繰り返しループ条件の追加

条件の作成

繰り返しループ条件の削除

条件の設計

繰り返しループのステータスの保持


繰り返しループ条件の削除

  • BizTalk オーケストレーション デザイナの設計ページで、条件を削除する [繰り返し] シェイプを右クリックし、[条件の削除] をクリックします。

関連項目

繰り返しループ条件の追加

条件の作成

条件の設計

繰り返しループ条件の編集

繰り返しループのステータスの保持


繰り返しループのステータスの保持

  1. BizTalk オーケストレーション デザイナの設計ページで、[繰り返し] シェイプを右クリックし、[プロパティ] をクリックします。

    [繰り返しのプロパティ] のダイアログ ボックスが表示されます。

  2. [ステータスの永続化] で、次のオプションのいずれかをクリックします。
    • [あり]

      各ループで繰り返し使用されるメッセージが、XLANG スケジュール ステータスとして保存されます。そのループが失敗したトランザクションに含まれている場合、ループの繰り返しが完了するたびに、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが表示されます。

    • [なし]

      最後のループの繰り返しで使用されたメッセージだけが、XLANG スケジュール ステータスとして保存されます。そのループが失敗したトランザクションに含まれている場合、[<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが 1 回だけ表示されます。

関連項目

繰り返しループ条件の追加

条件の作成

繰り返しループ条件の削除

条件の設計

繰り返しループ条件の編集


条件の作成

ここには次のトピックが含まれます。

  • 条件の作成

  • 式アシスタントの使用

  • 条件への定数の追加

  • 未使用の条件の削除

関連項目

条件の設計

判断条件の設定

繰り返しループの状態の設定


条件の作成

ビジネス プロセスの条件を評価するような条件を作成することができます。条件は、XLANG スケジュールの判断および繰り返しループ内で使用されます。判断シェイプまたは繰り返しシェイプに条件を追加するときは、[条件のプロパティ] ダイアログ ボックスが表示されます。

  1. [条件のプロパティ] ダイアログ ボックスで、[条件名] ボックスに条件の名前を入力します。

    このフィールドは必須です。

  2. [条件の説明] ボックスに、その条件の詳しい説明を入力します。

    このフィールドは省略できます。

  3. [条件式] ボックス内にカーソルを置くと、式アシスタントが有効になります。

    使用する条件式を入力するか、式アシスタントを使用します。式アシスタントの使用方法および条件式の作成方法については、「式アシスタントの使用」を参照してください。

重要

  • XML では大文字と小文字が区別されるため、条件式ではメッセージおよびそのフィールドと同じように大文字と小文字を区別して使用する必要があります。

  • 式アシスタントを有効にするには、[条件式] ボックスにカーソルを置く必要があります。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。
  • 開始、終了、判断、繰り返し、分岐、結合、および中断の各シェイプには、名前を付けることができません。

  • その条件が使用されている判断シェイプおよび繰り返しシェイプの幅は、条件名の長さによって決まります。

  • 式を追加する場所にカーソルを置くと、[条件式] ボックスの任意の場所に条件式を追加できます。

  • ポート実装およびアクションとポート間のメッセージ通信を作成しない限り、条件式を作成できません。

  • XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにする前に、そのスケジュール内のすべての条件の条件式を完成する必要があります。

関連項目

条件への定数の追加

条件の設計

判断条件の設定

繰り返しループの状態の設定

式アシスタントの使用


式アシスタントの使用

  1. [条件のプロパティ] ダイアログ ボックスで、[式アシスタント] の [メッセージ] ボックスの一覧からメッセージをクリックします。

  2. [式アシスタント] の [フィールド] ボックスの一覧からフィールドをクリックします。

  3. [挿入] をクリックします。

  4. [条件式] ボックスで、式を完成します。

    式アシスタントは、選択されたメッセージおよびフィールドだけを追加します。条件式を評価するには、その条件に論理式を定義する必要があります。たとえば、次のように記述できます。

    PORequest.Total < 500

    式を組み合わせて、さらに複雑な論理式を指定することもできます。たとえば、次のように記述できます。

    PORequest.Total < 500 AND PORequest.Quantity < 20

重要

  • XML では大文字と小文字が区別されるため、条件式ではメッセージおよびそのフィールドと同じように大文字と小文字を区別して使用する必要があります。

  • 式アシスタントを有効にするには、[条件式] ボックスにカーソルを置く必要があります。

  • [フィールド] ボックスの一覧で使用可能なフィールドは、[メッセージ] ボックスの一覧で選択したメッセージによって異なります。そのメッセージに含まれているフィールドだけが使用可能になります。

注

  • [メッセージ] ボックスの一覧には、[データ] ページで使用可能なすべてのメッセージ、および定数の一覧が含まれています。

  • 条件では、[データ] ページにあるシステム フィールドを使用できます。条件内で使用した場合、システム フィールドは必ずかっこで囲まれます。たとえば、次のように記述できます。

    Message1.[__Exists__]

    システム フィールドの詳細については、「データ処理」を参照してください。

  • 条件内では、Date や Time など、Microsoft® Visual Basic® の関数を使用できます。

  • 条件の中ですべての Visual Basic Scripting Edition (VBScript) 式比較演算子を使用できます。

  • 式を追加する場所にカーソルを置くと、[条件式] ボックスの任意の場所に条件式を追加できます。

  • XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにする前に、そのスケジュール内のすべての条件の条件式を完成する必要があります。

関連項目

条件への定数の追加

条件の作成

条件の設計

判断条件の設定

繰り返しループの状態の設定


条件への定数の追加

条件内の条件式には、定数を追加できます。定数を使用するには、その前に定数を使用可能にしておく必要があります。

  1. 使用可能な定数がない場合は、[データ] ページで [定数] ボックスの一覧に定数を追加します。

    定数の使用方法と [定数] ボックスの一覧への追加方法については、「定数の使用」を参照してください。

  2. [条件のプロパティ] ダイアログ ボックスで、[メッセージ] ボックスの一覧から [定数] をクリックします。

  3. [フィールド] ボックスの一覧から使用する定数をクリックし、[挿入] をクリックします。

注

  • [データ] ページの [定数] ボックスの一覧にあるすべての定数が使用可能で、条件内でも使用できます。

関連項目

条件の作成

条件の設計

判断条件の設定

繰り返しループの状態の設定

式アシスタントの使用


未使用の条件の削除

  • [ツール] メニューの [未使用の条件の削除] をクリックします。

注

  • ここでは、XLANG スケジュール フローチャート内の判断および繰り返しループにある、未使用のすべての条件が削除されます。

  • XLANG スケジュール フローチャートから削除されるのは、繰り返しシェイプおよび判断シェイプ内で現在使用されていない条件だけです。繰り返しシェイプおよび判断シェイプ内で使用中の条件は、そのシェイプが現在ほかのシェイプに接続されていなくても削除されません。

関連項目

条件への定数の追加

条件の作成

式アシスタントの使用


同時実行のプロパティの設定

ここには次のトピックが含まれます。

  • 同時実行フローの作成

  • 結合の種類プロパティの設定

  • 同時実行フローの結合

  • 同時実行フローの終了

重要

  • 同時実行 プロセスの詳細については、「同時実行の設計」も必ずお読みください。


同時実行フローの作成

  1. BizTalk オーケストレーション デザイナの設計ページで、[分岐] シェイプをクリックします。

  2. 分岐シェイプ下部の制御ハンドル ( 制御ハンドル) を、ビジネス プロセスのフロー内にある後続のシェイプの、上部の接続ポイント ( 接続ポイント) に接続します。

  3. 手順 1. と 2. を繰り返し、同時実行フローをすべて作成します。

重要

  • 同時実行プロセスの詳細については、「同時実行の設計」も必ずお読みください。

注

  • 上部の接続ポイントから分岐シェイプに入力できるフローは 1 つだけです。

  • 同時実行プロセスを実行するために分岐シェイプから出力できるフローは、最大 64 個です。

  • フローを記述するたびに、[分岐] シェイプをクリックして選択し、制御ハンドルをアクティブにする必要があります。

    – または –

    複数の同時実行フローを作成する場合は、コネクタ ツールを使用するとフローを簡単に追加できます。コネクタ ツールの詳細については、「コネクタ ツールの使用」を参照してください。

  • フローチャート シェイプを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

2 つのシェイプの接続

同時実行フローの終了

同時実行フローの結合

シェイプの選択

結合の種類プロパティの設定

コネクタ ツールの使用


結合の種類プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[結合] シェイプを右クリックし、[プロパティ] をクリックします。

    [結合のプロパティ] ダイアログ ボックスが表示されます。

  2. [結合の種類] で、次のオプションのいずれかをクリックします。
    • [AND]

    • [OR]

重要

  • 同時実行プロセスの詳細については、「同時実行の設計」も必ずお読みください。

注

  • 結合オプションとして [OR] を選択した場合、その結合に入力されるすべてのフローが持つアクションは、そのフローに関連付けられたアクション 1 つだけになります。

関連項目

同時実行フローの作成

同時実行フローの終了

同時実行フローの結合


同時実行フローの結合

  1. BizTalk オーケストレーション デザイナの設計ページで、同時実行プロセスを実行しているビジネス プロセス内のシェイプをクリックします。

  2. シェイプの下部の制御ハンドル ( 制御ハンドル) を、結合シェイプの上部の接続ポイント ( 接続ポイント) に接続します。

  3. この結合を再結合するすべての同時実行フローに対して、手順 1. と 2. を繰り返します。

重要

  • 同時実行プロセスの詳細については、「同時実行の設計」も必ずお読みください。

注

  • 結合オプションとして [OR] を選択した場合、その結合に入力されるすべてのフローが持つアクションは、そのフローに関連付けられたアクション 1 つだけになります。

  • 上部の接続ポイントから結合シェイプに入力できるフローは、最大 64 個です。

  • 結合シェイプの下部の接続ポイントから出力できるフローは 1 つだけです。

  • 複数の同時実行フローを結合する場合は、コネクタ ツールを使用するとフローを簡単に結合できます。コネクタ ツールの詳細については、「コネクタ ツールの使用」を参照してください。

  • フローチャート シェイプを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

2 つのシェイプの接続

同時実行フローの作成

同時実行フローの終了

シェイプの選択

結合の種類プロパティの設定

コネクタ ツールの使用


同時実行フローの終了

  1. BizTalk オーケストレーション デザイナの設計ページで、同時実行プロセスを実行しているビジネス プロセス内のシェイプをクリックします。

  2. シェイプの下部の制御ハンドル ( 制御ハンドル) を、終了シェイプの上部の接続ポイント ( 接続ポイント) に接続します。

    この同時実行プロセスが終了します。XLANG スケジュール内のほかのフローは再結合されません。

重要

  • 同時実行プロセスの詳細については、「同時実行の設計」も必ずお読みください。

注

  • フローチャート シェイプを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

2 つのシェイプの接続

同時実行フローの作成

同時実行フローの結合

シェイプの選択

結合の種類プロパティの設定

コネクタ ツールの使用


トランザクション プロパティの設定

ここには次のトピックが含まれます。

  • XLANG スケジュールに対するトランザクション プロパティの設定

  • トランザクション プロパティの個別設定

  • コンポーネントおよびメッセージ キュー トランザクションのサポートについて

関連項目

トランザクションの設計


XLANG スケジュールに対するトランザクション プロパティの設定

ここには次のトピックが含まれます。

  • トランザクション モデルの設定

  • トランザクションのアクティブ化プロパティの設定

関連項目

トランザクションの設計


トランザクション モデルの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[開始] シェイプを右クリックし、[プロパティ] をクリックします。

    [開始のプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクション モデル] で、次のオプションのいずれかをクリックします。
    • [XLANG スケジュールにトランザクションを含める]

      このオプションを選択すると、XLANG スケジュールでトランザクションを使用できるようになります。

    • [XLANG スケジュールを COM+ コンポーネント として扱う]

      このオプションを選択すると、XLANG スケジュールに対するトランザクション サポートが無効になります。そして、COM+ トランザクションのコンテキスト内で、COM コンポーネントが XLANG スケジュールをアクティブにできるようになります。

注

  • "トランザクション モデル" プロパティを [XLANG スケジュールを COM+ コンポーネントとして扱う] に設定すると、[トランザクションのアクティブ化] ボックスの一覧が有効になります。

  • "トランザクション モデル" プロパティを [XLANG スケジュールを COM+ コンポーネント として扱う] に設定した場合は、XLANG スケジュール フローチャートにトランザクションを追加しないでください。XLANG スケジュール フローチャートがコンパイルできなくなり、エラー メッセージが表示されます。

  • XLANG ID のプロパティは、XLANG スケジュール フローチャート インスタンスのバージョンを識別するために使用される一意な ID です。この ID は読み取り専用であり、変更することはできません。XLANG スケジュール フローチャートを更新すると、そのたびに ID も更新されます。

    XLANG ID プロパティを使用すると、XLANG スケジュール フローチャート (.skv) と、それをコンパイルした XLANG スケジュール (.skx) とを対応付けられます。

  • 開始シェイプが使用できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページでは開始シェイプを使用できません。

関連項目

コンポーネントおよびメッセージ キュー トランザクションのサポートについて

トランザクションの設計

トランザクションのアクティブ化プロパティの設定


トランザクションのアクティブ化プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[開始] シェイプを右クリックし、[プロパティ] をクリックします。

    [開始のプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクション モデル] ボックスの一覧で、[XLANG スケジュールを COM+ コンポーネントとして扱う] をクリックします。

    このオプションを有効にすると、コンポーネント サービスが XLANG スケジュールを COM+ コンポーネントとして扱うようになります。このオプションを選択すると、XLANG スケジュールに対するトランザクション サポートが無効になります。そして、COM+ トランザクションのコンテキスト内で、COM コンポーネントが XLANG スケジュールをアクティブにできるようになります。

  3. [トランザクションのアクティブ化] ボックスの一覧で、次のオプションのいずれかをクリックします。
    • [サポートしない]

      スケジュール作成者の COM+ オブジェクト コンテキストにトランザクションがあっても、XLANG スケジュールはそのトランザクションを無視します。そのトランザクションの範囲内にあるスケジュールのアクションは、まったく実行されません。

    • [サポートする]

      スケジュール作成者の COM+ オブジェクト コンテキストにトランザクションが存在する場合、XLANG スケジュールは COM+ トランザクションに参加します。

    • [必須]

      XLANG スケジュールは、トランザクションの範囲内で実行する必要があります。スケジュール作成者の COM+ オブジェクト コンテキストにトランザクションが存在しない場合、トランザクションが自動的に作成され、XLANG スケジューラ エンジンによって使用されます。

    • [新しいトランザクションを要求する]

      XLANG スケジュールは、新しいトランザクションの範囲内で実行する必要があります。XLANG スケジューラ エンジンは、作成者の COM+ オブジェクト コンテキストに存在するすべてのトランザクションと異なる新しいトランザクションを、スケジュールに対して自動的に作成します。

注

  • XLANG ID のプロパティは、XLANG スケジュール フローチャート インスタンスのバージョンを識別するために使用される一意な ID です。この ID は読み取り専用であり、変更することはできません。XLANG スケジュール フローチャートを更新すると、そのたびに ID も更新されます。

    XLANG ID プロパティを使用すると、XLANG スケジュール フローチャート (.skv) と、それをコンパイルした XLANG スケジュール (.skx) とを対応付けられます。

  • 開始シェイプが使用できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページでは開始シェイプを使用できません。

関連項目

コンポーネントおよびメッセージ キュー トランザクションのサポートについて

トランザクションの設計

トランザクション モデルの設定


トランザクション プロパティの個別設定

ここには次のトピックが含まれます。

  • トランザクション内のグループ アクションとフロー

  • ネストしたトランザクションの設計

  • トランザクションに入出力されるフローの作成

  • トランザクションの名前設定

  • トランザクションの種類プロパティの設定

  • タイムアウト プロパティの設定

  • 再試行回数プロパティの設定

  • バックオフの時間プロパティの設定

  • 分離レベル プロパティの設定

  • スケジュールのステータスを永続化プロパティの設定

関連項目

トランザクションの設計


トランザクション内のグループ アクションとフロー

  1. BizTalk オーケストレーション デザイナの設計ページで、[フローチャート] ステンシルの [トランザクション] シェイプを境界バーの左側にドラッグします。

  2. [トランザクション] シェイプのサイズを変更して、シェイプがトランザクションで囲まれるようにします。

注

  • トランザクションの境界内にあるシェイプおよびフローは、すべてそのトランザクションに含まれていると見なされます。

  • トランザクション内のシェイプを選択するには、そのシェイプをクリックします。

  • 境界内にシェイプを含むトランザクションを削除すると、そこに含まれているすべてのシェイプも削除されます。

  • トランザクションの種類は、次の色で示されます。
    • 青 : この色は、定刻トランザクションを示します。

    • ベージュ : この色は、長時間トランザクションを示します。

    • 灰色 : この色は、短時間の DTC スタイルのトランザクションを示します。
  • フローチャート シェイプを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

トランザクションに入出力されるフローの作成

トランザクションの設計

ネストしたトランザクションの設計

トランザクションの名前設定


ネストしたトランザクションの設計

  1. BizTalk オーケストレーション デザイナの設計ページで、[フローチャート] ステンシルの [トランザクション] シェイプをドラッグし、現在のトランザクションの境界内に配置します。

  2. [トランザクション] シェイプのサイズを変更して、シェイプがトランザクションで囲まれるようにします。

重要

  • ネストしたトランザクションを作成すると、外側のトランザクションの一部のプロパティが無効になります。
    • [短時間の DTC スタイル] のトランザクションは使用できなくなります。

    • [トランザクションのオプション] にあるすべてのオプションが使用できなくなります。

    • [タイムアウト] プロパティはアクティブですが、ネストしたトランザクションを作成すると、トランザクションの種類を [定刻トランザクション] に変えるまで変更できなくなります。

注

  • トランザクションの境界内にあるシェイプおよびフローは、すべてそのトランザクションに含まれていると見なされます。

  • トランザクション内のシェイプを選択するには、そのシェイプをクリックします。

  • 境界内にシェイプを含むトランザクションを削除すると、そこに含まれているすべてのシェイプも削除されます。

  • トランザクションの種類は、次の色で示されます。
    • 青 : この色は、定刻トランザクションを示します。

    • ベージュ : この色は、長時間トランザクションを示します。

    • 灰色 : この色は、短時間の DTC スタイルのトランザクションを示します。
  • 内側のトランザクションに完全に含まれていないフローチャート シェイプは、外側のトランザクションに含まれていると見なされます。

  • 外側のトランザクションに含まれているフローチャート シェイプは、内側のトランザクションと部分的に重複し、内側のトランザクションに完全に含まれていない場合、部分的に表示されないことがあります。この場合は、シェイプを選択し、移動して、重複しないようにしてください。

  • フローチャート シェイプを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

トランザクションに入出力されるフローの作成

トランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定


トランザクションに入出力されるフローの作成

  1. BizTalk オーケストレーション デザイナの設計ページで、ビジネス プロセスのフローにあるトランザクションの前のシェイプをクリックします。

  2. そのシェイプの下部の制御ハンドル ( 制御ハンドル) を、トランザクション シェイプの上部の接続ポイント ( 接続ポイント) に接続します。

  3. [トランザクション] シェイプをクリックし、選択します。

  4. その [トランザクション] シェイプの上部の制御ハンドルを、トランザクション フローの開始を示す、トランザクション内にある最初のシェイプの上部の接続ポイントに接続します。

  5. そのシェイプから、トランザクション内の次のシェイプにフローを接続します。

  6. トランザクション内のすべてのフローを接続し、すべてのアクションを、通信フローを作成するポートに接続します。

  7. トランザクション内にある最後のシェイプの下部の制御ハンドルから、[トランザクション] シェイプの下部の接続ポイントへフローを接続します。

  8. [トランザクション] シェイプをクリックし、選択します。

  9. [トランザクション] シェイプの下部の制御ハンドルを、そのトランザクションの外側にあるビジネス プロセスのフロー内の、次のシェイプの上部の接続ポイントに接続します。

注

  • トランザクション内のシェイプを選択するには、そのシェイプをクリックします。

  • フローチャート シェイプを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではフローチャート シェイプを使用できません。

関連項目

シェイプの追加、削除、および接続

2 つのシェイプの接続

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

コネクタ ツールの使用


トランザクションの名前設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [名前] ボックスに、そのトランザクションの名前を入力します。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。
  • 1 バイト文字セットによるトランザクション名の長さは、16 文字以内にします。2 バイト文字セットによるトランザクション名の長さは、8 文字以内にします。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

スケジュールのステータスを永続化プロパティの設定

バックオフの時間プロパティの設定

分離レベル プロパティの設定

再試行回数プロパティの設定

タイムアウト プロパティの設定

トランザクションの種類プロパティの設定


トランザクションの種類プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [種類] で、次のオプションのいずれかをクリックします。
    • [定刻トランザクション]

    • [短時間の DTC スタイル]

    • [長時間]

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

スケジュールのステータスを永続化プロパティの設定

バックオフの時間プロパティの設定

分離レベル プロパティの設定

再試行回数プロパティの設定

タイムアウト プロパティの設定


タイムアウト プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクションのオプション] の [タイムアウト] ボックスに、時間を秒単位で入力します。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

スケジュールのステータスを永続化プロパティの設定

バックオフの時間プロパティの設定

分離レベル プロパティの設定

再試行回数プロパティの設定

トランザクションの種類プロパティの設定


再試行回数プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクションのオプション] の [再試行の回数] ボックスに、トランザクションが失敗と見なされるまでに再試行できる回数を入力します。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

スケジュールのステータスを永続化プロパティの設定

バックオフの時間プロパティの設定

分離レベル プロパティの設定

タイムアウト プロパティの設定

トランザクションの種類プロパティの設定


バックオフの時間プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクションのオプション] の [バックオフの時間] に、時間を秒単位で入力します。

注

  • バックオフの時間プロパティによって、トランザクションの再試行の間隔が決まります。このオプションを使用できるのは、短時間の DTC スタイルのトランザクションだけです。バックオフの時間は再試行の回数値と共に使用され、次にトランザクションが再試行を行うまでの待機時間が決定されます。バックオフ値は指数になっています。バックオフ値が 2 秒の場合、再試行の間隔は 2 秒、4 秒、8 秒、16 秒のようになります。計算式は BR (B の R 乗) です。ここで、B はバックオフの時間、R は現在の再試行の回数を示します。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

スケジュールのステータスを永続化プロパティの設定

分離レベル プロパティの設定

再試行回数プロパティの設定

タイムアウト プロパティの設定

トランザクションの種類プロパティの設定


分離レベル プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクションのオプション] の [分離レベル] ボックスの一覧から、次のオプションのいずれかをクリックします。
    • [Serializable]

    • [Read Uncommitted]

    • [Read Committed]

    • [Repeatable Read]

注

  • このプロパティを設定できるのは、短時間の DTC スタイルのトランザクションだけです。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

スケジュールのステータスを永続化プロパティの設定

バックオフの時間プロパティの設定

再試行回数プロパティの設定

タイムアウト プロパティの設定

トランザクションの種類プロパティの設定


スケジュールのステータスを永続化プロパティの設定

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [トランザクションのオプション] で [スケジュールのステータスを永続化] チェックボックスをオンまたはオフにします。

注

  • このプロパティは短時間の DTC スタイルのトランザクション用には設定できません。短時間の DTC スタイルの場合は常に永続化されます。

関連項目

トランザクションの設計

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

トランザクションの名前設定

分離レベル プロパティの設定

バックオフの時間プロパティの設定

再試行回数プロパティの設定

タイムアウト プロパティの設定

トランザクションの種類プロパティの設定


コンポーネントおよびメッセージ キュー トランザクションのサポートについて

ここには次のトピックが含まれます。

  • COM コンポーネント内でのトランザクションのサポート レベルについて

  • Windows スクリプト コンポーネント内でのトランザクションのサポート レベルについて

  • メッセージ キューが提供するトランザクションのサポートについて

関連項目

トランザクションの設計

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


COM コンポーネント内でのトランザクションのサポート レベルについて

COM コンポーネントに対するトランザクションのサポートは、[COM コンポーネント バインド ウィザード] で設定します。

  1. [COM コンポーネント バインド ウィザード] を開きます。

    このウィザードの詳細については、「COM コンポーネントを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、次のオプションのいずれかをクリックします。
    • [無効]

      このポート実装で使用される COM+ コンポーネントに対するトランザクションのサポートが無効になります。

    • [サポートしない]

      このポート実装で使用される COM+ コンポーネントは、トランザクションをサポートしません。

    • [サポートする]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぎます。

    • [必須]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぐか、または新しいトランザクションを使用することができます。

    • [新しいトランザクションを要求する]

      このポート実装で使用される COM+ コンポーネントは、使用する新しいトランザクションを要求します。

関連項目

XLANG スケジュール フローチャートへのバインド済みポートの追加

トランザクションの設計

COM コンポーネントを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


Windows スクリプト コンポーネント内でのトランザクションのサポート レベルについて

Windows スクリプト コンポーネントに対するトランザクションのサポートは、[スクリプト コンポーネント バインド ウィザード] で設定します。

  1. [スクリプト コンポーネント バインド ウィザード] を開きます。

    このウィザードの詳細については、「Windows スクリプト コンポーネントを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、次のオプションのいずれかをクリックします。
    • [無効]

      このポート実装で使用される COM+ コンポーネントに対するトランザクションのサポートが無効になります。

    • [サポートしない]

      このポート実装で使用される COM+ コンポーネントは、トランザクションをサポートしません。

    • [サポートする]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぎます。

    • [必須]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぐか、または新しいトランザクションを使用することができます。

    • [新しいトランザクションを要求する]

      このポート実装で使用される COM+ コンポーネントは、使用する新しいトランザクションを要求します。

関連項目

XLANG スケジュール フローチャートへのバインド済みポートの追加

トランザクションの設計

Windows スクリプト コンポーネントを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


メッセージ キューが提供するトランザクションのサポートについて

メッセージ キューに対するトランザクションのサポートは、[メッセージ キュー バインド ウィザード] で設定します。

  1. [メッセージ キュー バインド ウィザード] を開きます。

    このウィザードの詳細については、「メッセージ キューを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、[このキューはトランザクションを必要とする] チェックボックスをオンまたはオフにします。

関連項目

XLANG スケジュール フローチャートへのバインド済みポートの追加

トランザクションの設計

メッセージ キューを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


エラー処理プロパティの設定

ここには次のトピックが含まれます。

  • 処理フローの中断

  • トランザクション エラー処理の有効化

  • コンポーネント エラー処理の有効化

関連項目

例外処理


処理フローの中断

  1. BizTalk オーケストレーション デザイナの [フローチャート] ステンシルで、[中断] シェイプをクリックし、設計ページまでドラッグします。

  2. [判断] シェイプから出力される論理分岐から [中断] シェイプの接続ポイント ( 接続ポイント) まで、処理フローを接続します。

重要

  • 中断シェイプは、論理分岐内のビジネス プロセスの中断に使用されます。判断シェイプと組み合わせて使用されます。

    中断シェイプを使用するかどうかは、ビジネス プロセスの必要性によって決まります。判断内に含まれた条件が TRUE と評価されるまで、順番に評価されます。条件が TRUE と評価されると、処理フローは次のアクションに進みます。TRUE と評価される条件がない場合は、処理フローを中断します。

    次の図は、条件が TRUE と評価されると処理フローはアクション 3 へ進むという、判断条件を示しています。TRUE と評価される条件がない場合、処理フローは中断されます。

関連項目

コンポーネント エラー処理の有効化

トランザクション エラー処理の有効化

例外処理

論理分岐


トランザクション エラー処理の有効化

ここには次のトピックが含まれます。

  • 失敗時エラー処理の有効化

  • 補正エラー処理の有効化

関連項目

処理フローの中断

例外処理


失敗時エラー処理の有効化

  1. BizTalk オーケストレーション デザイナの設計ページで、[トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [失敗時] の [コードの追加] をクリックします。

  3. [失敗時] の [有効にする] チェック ボックスをオンにします。

注

  • [コードの追加] をクリックすると、このトランザクションに関連付けられたトランザクションの [<トランザクション> の失敗時] ページが作成されます。ページ名のパラメータ <トランザクション> は、エラー処理プロセスが関連付けられているトランザクション名に置き換えられます。

  • [有効にする] チェック ボックスをオンにすると、XLANG スケジュールがこのトランザクションに対して失敗時に実行されるコードを実行するようになります。このチェック ボックスをオンにしなかった場合、失敗時のプロセスを設計することはできますが、XLANG スケジュールの実行中に実行することはできません。

関連項目

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

例外処理


補正エラー処理の有効化

  1. BizTalk オーケストレーション デザイナの設計ページで、ネストしたトランザクション グループの内側にある [トランザクション] シェイプを右クリックし、[プロパティ] をクリックします。

    [トランザクションのプロパティ] ダイアログ ボックスが表示されます。

  2. [補正] の [コードの追加] をクリックします。

  3. [補正] の [有効にする] チェック ボックスをオンにします。

注

  • [コードの追加] をクリックすると、このトランザクションに関連付けられた [<トランザクション> の失敗時] ページまたは [<トランザクション> の補正] ページが作成されます。

  • [有効にする] チェック ボックスをオンにすると、XLANG スケジュールがこのトランザクションに対して失敗時に実行されるコードまたは補正コードを実行するようになります。このチェック ボックスをオンにしなかった場合でも、失敗時のプロセスまたは補正プロセスを設計することはできますが、XLANG スケジュールの実行中に実行することはできません。

  • ページ名のパラメータ <トランザクション> は、エラー処理プロセスが関連付けられているトランザクション名に置き換えられます。

  • トランザクションの種類は、次の色で示されます。
    • 青 : この色は、定刻トランザクションを示します。

    • ベージュ : この色は、長時間トランザクションを示します。

    • 灰色 : この色は、短時間の DTC スタイルのトランザクションを示します。

関連項目

ネストしたトランザクションの設計

トランザクション内のグループ アクションとフロー

例外処理


コンポーネント エラー処理の有効化

ここには次のトピックが含まれます。

  • COM コンポーネントが失敗を返した場合のトランザクションの中断

  • Windows スクリプト コンポーネントが失敗を返した場合のトランザクションの中断

関連項目

処理フローの中断

例外処理


COM コンポーネントが失敗を返した場合のトランザクションの中断

COM コンポーネントに対するトランザクションのサポートは、[COM コンポーネント バインド ウィザード] で設定します。

  1. [COM コンポーネント バインド ウィザード] を開きます。

    このウィザードの詳細については、「COM コンポーネントを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [エラー処理] で、[メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンにします。

重要

  • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用する短時間の DTC スタイルのトランザクションを中断するかどうかを指定します。

    このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

関連項目

Windows スクリプト コンポーネントが失敗を返した場合のトランザクションの中断

XLANG スケジュール フローチャートへのバインド済みポートの追加

例外処理

COM コンポーネントを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


Windows スクリプト コンポーネントが失敗を返した場合のトランザクションの中断

Windows スクリプト コンポーネントに対するトランザクションのサポートは、[スクリプト コンポーネント バインド ウィザード] で設定します。

  1. [スクリプト コンポーネント バインド ウィザード] を開きます。

    このウィザードの詳細については、「Windows スクリプト コンポーネントを使用したポートの実装」を参照してください。

  2. ウィザードの手順に従って、[ポート プロパティの詳細設定] ページまで設定します。

  3. [ポート プロパティの詳細設定] ページの [エラー処理] で、[メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンにします。

重要

  • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用するトランザクションを中断するかどうかを指定します。

    このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

関連項目

COM コンポーネントが失敗を返した場合のトランザクションの中断

XLANG スケジュール フローチャートへのバインド済みポートの追加

例外処理

Windows スクリプト コンポーネントを使用したポートの実装

ポート実装のプロパティの変更

トランザクションのアクティブ化プロパティの設定

トランザクション モデルの設定


ポートの実装

BizTalk オーケストレーション デザイナには、ポート通信の実装に使用可能な技術を表す、4 種類の実装シェイプが用意されています。これらのシェイプについて、次の表に示します。

シェイプ名 | 説明
COM コンポーネント | [COM コンポーネント] シェイプは、送受信される各メッセージへのメソッド呼び出しによってポートを実装する技術です。このシェイプを境界バーの右側までドラッグすると、COM コンポーネント バインド ウィザードが表示されます。
スクリプト コンポーネント | [スクリプト コンポーネント] シェイプは、送受信されるメッセージごとにメソッド呼び出しを使用してポートを実装するテクノロジを表します。このシェイプを境界バーの右側までドラッグすると、スクリプト コンポーネント バインド ウィザードが表示されます。
メッセージ キュー | [メッセージ キュー] シェイプは、ポートを実装するテクノロジを表します。メッセージの送受信には、メッセージ キュー サービスが使用されます。このシェイプを境界バーの右側までドラッグすると、メッセージ キュー バインド ウィザードが表示されます。
BizTalk メッセージ | [BizTalk メッセージ] シェイプは、ポートを実装するテクノロジを表します。メッセージの送受信には、BizTalk メッセージ サービスが使用されます。ポートの実装には、BizTalk Server メッセージ ポートまたはメッセージ チャネルを使用できます。このシェイプを境界バーの右側までドラッグすると、BizTalk メッセージ バインド ウィザードが表示されます。

ここには次のトピックが含まれます。

  • XLANG スケジュール フローチャートへの未バインド ポートの追加

  • XLANG スケジュール フローチャートへのバインド済みポートの追加

  • COM コンポーネントを使用したポートの実装

  • Windows スクリプト コンポーネントを使用したポートの実装

  • メッセージ キューを使用したポートの実装

  • BizTalk メッセージを使用したポートの実装

  • ポート実装のプロパティの変更

関連項目

通信シェイプ

フローチャート シェイプ

実装シェイプ

ビジネス プロセスの実装

メッセージとポートの対応付け

メッセージの送信と受信

ポート実装について

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


XLANG スケジュール フローチャートへの未バインド ポートの追加

  • BizTalk オーケストレーション デザイナの設計ページで、境界バーを右クリックし、[新しいポートの追加] をクリックします。

注

  • ポートを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポートを使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • 未バインド ポートは、メッセージ キューまたは BizTalk メッセージを使用して実装できます。このような実装をページに追加する場合、使用可能な未バインド ポートを実装ウィザードで選択できます。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

メッセージの送信と受信


XLANG スケジュール フローチャートへのバインド済みポートの追加

  • BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [実装] シェイプを境界バーの右側にドラッグし、ウィザードの手順に従って実装を行います。

注

  • ポートを追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポートを使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

メッセージの送信と受信


COM コンポーネントを使用したポートの実装

  1. BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [COM コンポーネント] シェイプを境界バーの右側にドラッグします。

    [COM コンポーネント バインド ウィザード] が表示されます。

  2. [COM コンポーネント バインド ウィザードへようこそ] ページで、作成するポートの名前を入力して、[次へ] をクリックします。

    BizTalk オーケストレーション デザイナでは、新しいポート実装が追加されるごとに、既定でポート名に番号が追加されます。この名前は変更できます。

  3. [静的または動的な通信] ページで、次のオプションのいずれかをクリックします。
    • [静的]

      XLANG スケジューラ エンジンが、このコンポーネントのインスタンスを作成します。

      [静的] をクリックすると、XLANG スケジュール インスタンスが終了したときに、このコンポーネントが自動的に破棄されます。

      [次へ] をクリックします。手順 4. に進みます。

    • [動的]

      このオプションを選択すると、別のアプリケーションがコンポーネントのインスタンスを作成します。オブジェクト インスタンスへのモニカまたはポインタを、メッセージ内のフィールドとして XLANG スケジュールに返す必要があります。[データ] ページでは、そのメッセージ フィールドと、この実装を使用するポートのポート参照との間に、接続を描画する必要があります。メッセージを特定のポートへ送信する方法については、「メッセージとポートの対応付け」を参照してください。

      [次へ] をクリックします。手順 5. に進みます。

    • [インスタンスを作成しない]

      データの受信だけが目的の場合、このオプションを選択します。このオプションでは、メソッドを使用してデータを XLANG スケジュールに渡しますが、そのメソッド呼び出しに関連するコードは実行しないことが指定されます。詳細については、「データ処理」を参照してください。

      [次へ] をクリックします。手順 5. に進みます。

    静的な通信および動的な通信の詳細については、次のトピックを参照してください。

    • 静的ポートと動的ポート

    • インスタンス管理

    • スクリプト コンポーネント シェイプの使用
  4. [クラス情報] ページで、次のオプションのいずれかをクリックします。
    • [登録されたコンポーネントから]

      ツリー制御には、コンピュータに登録されているすべてのコンポーネントが表示されます。使用するクラスのフォルダを展開し、クラスをクリックします。

      [次へ] をクリックします。

    • [モニカから]

      標準の COM モニカの名前を入力し、インスタンスを作成する COM コンポーネントの場所を指定します。このオプションを使用すると、XLANG スケジュールのトランザクション内で実行される通信に、COM コンポーネントを使用できなくなります。

      [次へ] をクリックします。

  5. [インターフェイス情報] ページで、使用するインターフェイスをクリックし、[次へ] をクリックします。

    注

    • COM コンポーネントにインターフェイスが 1 つしかない場合、このページは表示されません。

    • Microsoft Visual Basic で作成された COM コンポーネントの場合、そのコンポーネントに含まれるクラスごとに、そのクラスと同じ名前のインターフェイスが 1 つあります。各インターフェイス名の前には、アンダースコア (_) が付きます。
  6. [メソッド情報] ページで、使用するメソッドを選択し、[次へ] をクリックします。

    注

    • COM コンポーネントにメソッドが 1 つしかない場合、このページは表示されません。

    • 最低 1 つのメソッドを選択する必要があります。

    • 複数のメソッドを選択したり、すべてのメソッドを選択することもできます。[すべて選択] または [すべて取り消し] を使用すると、すべてのメソッドを選択したり、選択解除することができます。
  7. [ポート プロパティの詳細設定] ページの [セキュリティ] で、次のオプションのいずれかをクリックします。
    • [必要なし]

      送信者の ID は確認されません。

    • [オプション]

      XLANG スケジューラ エンジンによって送信者の ID が要求されます。ID が利用可能かどうかにかかわらず、XLANG スケジュールは継続して実行されます。

    • [必要]

      XLANG スケジューラ エンジンによって送信者の ID が要求されます。送信者 ID は必須です。ID が利用できない場合、XLANG スケジュールはメッセージを無視します。

    注

    • ID が必要にもかかわらず利用できないため、XLANG スケジュールが受信メソッド呼び出しを拒否した場合、エラー コード「E_ACCESSDENIED」が呼び出し元に返されます。
  8. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、次のオプションのいずれかをクリックします。
    • [無効]

      このポート実装で使用される COM+ コンポーネントに対する、トランザクションのサポートが無効になります。

    • [サポートしない]

      このポート実装で使用される COM+ コンポーネントは、トランザクションをサポートしません。

    • [サポートする]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぎます。

    • [必要]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぐか、または新しいトランザクションを使用することができます。

    • [新しいトランザクションを要求する]

      このポート実装で使用される COM+ コンポーネントは、使用する新しいトランザクションを要求します。

  9. [ポート プロパティの詳細設定] ページの [ステータス管理のサポート] で、次のオプションのいずれかをクリックします。
    • [ステータスを保持しない]

      このポート実装で使用されるコンポーネントは、メソッド呼び出し間でステータスを保持しません。

    • [ステータスを保持し、永続的にサポートしない]

      このポート実装で使用されるコンポーネントは、そのコンポーネントの存続期間の間ステータスを保持しますが、そのコンポーネントは永続的ではありません。

    • [ステータスを保持し、永続的にサポートする]

      このポート実装で使用されるコンポーネントは、IPersistStream インターフェイスまたは IPersistStreamInit インターフェイスのいずれかを使用して保存できるステータスを保持します。これらのインターフェイスを使用すると、その後のインスタンス作成に備えてコンポーネントのステータスを保存し、その保存されたステータスを使用してコンポーネントを再作成できます。

  10. [ポート プロパティの詳細設定] ページの [エラー処理] で、[メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンまたはオフにします。

    重要

    • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用するトランザクションを中断するかどうかを指定します。

      このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

  11. [完了] をクリックします。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • ポート実装を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • COM コンポーネントの実装で使用するための新しいポートが必ず作成されます。

  • 既存のポート実装を編集する場合、実装ウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

関連項目

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

ポート実装について

COM コンポーネント シェイプの使用

メソッド通信ウィザードの使用


Windows スクリプト コンポーネントを使用したポートの実装

  1. BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [スクリプト コンポーネント] シェイプを境界バーの右側にドラッグします。

    [スクリプト コンポーネント バインド ウィザード] が表示されます。

  2. [スクリプト コンポーネント バインド ウィザードへようこそ] ページで、作成するポートの名前を入力して、[次へ] をクリックします。

    BizTalk オーケストレーション デザイナでは、新しいポート実装が追加されるごとに、既定でポート名に番号が追加されます。この名前は変更できます。

  3. [静的または動的な通信] ページで、次のオプションのいずれかをクリックし、[次へ] をクリックします。
    • [静的]

      XLANG スケジューラ エンジンが、このコンポーネントのインスタンスを作成します。

      [静的] をクリックすると、XLANG スケジュール インスタンスが終了したときに、このコンポーネントが自動的に破棄されます。

    • [動的]

      このオプションを選択すると、別のアプリケーションがコンポーネントのインスタンスを作成します。オブジェクト インスタンスへのモニカまたはポインタを、メッセージ内のフィールドとして XLANG スケジュールに返す必要があります。[データ] ページでは、そのメッセージ フィールドと、この実装を使用するポートのポート参照との間に、接続を描画する必要があります。メッセージを特定のポートへ送信する方法については、「メッセージとポートの対応付け」を参照してください。

    • [インスタンスを作成しない]

      データの受信だけが目的の場合、このオプションを選択します。このオプションでは、メソッドを使用してデータを XLANG スケジュールに渡しますが、そのメソッド呼び出しに関連するコードは実行しないことが指定されます。

    静的な通信および動的な通信の詳細については、次のトピックを参照してください。

    • 静的ポートと動的ポート

    • インスタンス管理

    • スクリプト コンポーネント シェイプの使用
  4. [スクリプト ファイルの指定] ページで [参照] をクリックします。

    [スクリプト ファイルの選択] ダイアログ ボックスが表示されます。

  5. 使用する .wsc ファイルの場所に移動して、目的のファイルをクリックします。次に、[開く] をクリックします。

  6. [次へ] をクリックし、次のいずれかに従って進みます。
    • 手順 3. で [静的] を選択した場合は、手順 7. に進みます。

    • 手順 3. で [動的] または [インスタンスを作成しない] を選択した場合は、手順 8. に進みます。
  7. [コンポーネントのインスタンス作成情報] ページで、次のいずれかをクリックし、[次へ] をクリックします。
    • [スクリプト ファイルのモニカを使用]

      スクリプト ファイルのパスと名前が、モニカとして自動的に与えられます。

    • [ProgID <ProgID> を使用]

      ProgID が自動的に与えられ、Windows スクリプト コンポーネント ファイルの XML から抽出されます。スクリプト ファイルのパスはハード コーディングされていないため、これを推奨します。

  8. [メソッド情報] ページで、使用するメソッドを選択し、[次へ] をクリックします。

    注

    • Windows スクリプト コンポーネントにメソッドが 1 つしかない場合、このページは表示されません。

    • 最低 1 つのメソッドを選択する必要があります。

    • 複数のメソッドを選択したり、すべてのメソッドを選択することもできます。[すべて選択] または [すべて取り消し] を使用すると、すべてのメソッドを選択したり、選択解除することができます。
  9. [ポート プロパティの詳細設定] ページの [セキュリティ] で、次のオプションのいずれかをクリックします。
    • [必要なし]

      送信者の ID は確認されません。

    • [オプション]

      XLANG スケジューラ エンジンによって送信者の ID が要求されます。ID が利用可能かどうかにかかわらず、XLANG スケジュールは継続して実行されます。

    • [必要]

      XLANG スケジューラ エンジンによって送信者の ID が要求されます。送信者 ID は必須です。ID が利用できない場合、XLANG スケジュールはメッセージを無視します。

    注

    • ID が必要にもかかわらず利用できないため、XLANG スケジュールが受信メソッド呼び出しを拒否した場合、エラー コード「E_ACCESSDENIED」が呼び出し元に返されます。
  10. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、次のオプションのいずれかをクリックします。
    • [無効]

      このポート実装で使用される COM+ コンポーネントに対する、トランザクションのサポートが無効になります。

    • [サポートしない]

      このポート実装で使用される COM+ コンポーネントは、トランザクションをサポートしません。

    • [サポートする]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぎます。

    • [必要]

      このポート実装で使用される COM+ コンポーネントは、既存のトランザクションを引き継ぐか、または新しいトランザクションを使用することができます。

    • [新しいトランザクションを要求する]

      このポート実装で使用される COM+ コンポーネントは、使用する新しいトランザクションを要求します。

  11. [ポート プロパティの詳細設定] ページの [エラー処理] で、[メソッドが失敗を示す HRESULT を返した場合は、トランザクションを中断する] チェック ボックスをオンまたはオフにします。

    重要

    • このオプションは、コンポーネントへのメソッド呼び出しが、失敗を示す HRESULT を返す場合に、コンポーネントを使用するトランザクションを中断するかどうかを指定します。

      このオプションを設定できるのは、このポートを使用する通信アクションが、トランザクションの処理フロー内に存在する場合だけです。

  12. [完了] をクリックします。

重要

  • Windows スクリプト コンポーネントを使用する場合、そのコンポーネントは次の規則に従っている必要があります。
    • 引数宣言は、値ではなく参照で行う必要があります。

    • Microsoft Visual Basic スクリプトのサブルーチンはサポートされていません。関数だけがサポートされています。

    • 1 つの .wsc ファイル内で複数のコンポーネントは使用できません。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • ポート実装を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • Windows スクリプト コンポーネントの実装で使用するための新しいポートが必ず作成されます。

  • 既存のポート実装を編集する場合、実装ウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

  • Windows スクリプト コンポーネント ファイルで使用されるファイル拡張子は .wsc です。Windows スクリプト コンポーネントの詳細については、Windows Scripting Technologies の Web サイト (www.microsoft.com/japan/developer/scripting/) にある Windows スクリプト コンポーネントのページを参照してください。

  • XLANG スケジューラ エンジンで実行されている Windows スクリプト コンポーネントは、XLANG スケジューラ エンジンと Windows スクリプト ホストの両方がシャットダウンされるまで変更できません。

関連項目

COM コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

ポート実装について

スクリプト コンポーネント シェイプの使用

メソッド通信ウィザードの使用


メッセージ キューを使用したポートの実装

  1. BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [メッセージ キュー] シェイプを境界バーの右側にドラッグします。

    [メッセージ キュー バインド ウィザード] が表示されます。

  2. [メッセージ キュー バインド ウィザードへようこそ] ページで、次のオプションのいずれかをクリックし、[次へ] をクリックします。
    • [新しいポートの作成]

      BizTalk オーケストレーション デザイナでは、新しいポート実装が追加されるごとに、既定でポート名に番号が追加されます。この名前は変更できます。

    • [既存の未バインド ポート]

      [既存の未バインド ポート] ボックスの一覧で、使用するポートをクリックします。

      [既存の未バインド ポート] ボックスの一覧には、未バインド ポートの名前だけが表示されます。未バインド ポートには、定義済みの実装がありません。

  3. [静的または動的キューの情報] ページで、次のオプションのいずれかをクリックします。
    • [静的キュー]

      静的キューとは、既存のキューです。このキューは、設計時に存在している必要があります。

      [次へ] をクリックします。手順 4. に進みます。

    • [動的キュー]

      このオプションを選択する場合、メッセージ フィールドからこのポートのポート参照へのリンクを、[データ] ページで作成する必要があります。

      このポート実装を使用して通信アクションが実行される前に、メッセージ キューの名前を別のメッセージで指定する必要があります。特定のメッセージとポートの対応付けについては、「メッセージとポートの対応付け」を参照してください。

      [次へ] をクリックします。手順 5. に進みます。

      静的キューと動的キューの詳細については、「静的ポートと動的ポート」を参照してください。

  4. [キュー情報] ページで、次のオプションのいずれかをクリックし、[次へ] をクリックします。
    • [すべてのインスタンスごとに新しいキューを作成する]

      キューにはプレフィックスを付ける必要があります (例 : ".\Private$\PrivateQueuePrefix" または ".\PublicQueuePrefix" など)。作成する新しいキューごとに、一意な ID がプレフィックスに追加されます。

      キューのプレフィックスは既定で割り当てられます。この既定のプレフィックスは変更できます。

      ほかからこのポートに返信できるようにするには、このポートへの参照をメッセージに含めて送信する必要があります。それには、[すべてのインスタンスごとに新しいキューを作成する] をオンにし、ルート キュー名を入力します。実行時には、各インスタンスに対してこのルート名を持った新しいキューが XLANG スケジューラ エンジンによって作成され、作成された各キューのルート名にインスタンスの GUID が追加されます。インスタンスが終了すると、このキューは削除されます。

      このポートへの参照を送信しない場合は、インスタンスごとにキューを作成する必要がありません。すべてのインスタンスで使用されるキューを 1 つ作成するだけでかまいません。

    • [すべてのインスタンスに対して既存のキューを使用する]

      既存のキュー名を入力します。(例、".\private$\queuename")。

  5. [ポート プロパティの詳細設定] ページの [セキュリティ] で、次のオプションのいずれかをクリックします。
    • [必要なし]

      送信者の ID は確認されません。XLANG スケジュールは、メッセージが認証されたかどうかにかかわらず、空の __Sender__ フィールドを持ったメッセージを必ず受信します。

    • [オプション]

      XLANG スケジューラ エンジンによって、送信者の ID の確認要求が送信されます。メッセージが認証されたかどうかにかかわらず、XLANG スケジュールはメッセージを受信します。メッセージが認証された場合は、__Sender__ フィールドにメッセージ キューのメッセージの SenderID プロパティが格納されます。

    • [必要]

      XLANG スケジューラ エンジンによって、送信者の ID の確認要求が送信されます。送信者 ID の確認は必須です。メッセージが認証された場合、XLANG スケジュールはメッセージを受信し、__Sender__ フィールドにメッセージ キュー メッセージの SenderID プロパティが格納されます。

      メッセージが認証されなかった場合、アプリケーションのイベント ログが作成され、.\private$\<アプリケーション名>.DeadLetter という名前で作成された新しいキューにメッセージが移動されます。

  6. [ポート プロパティの詳細設定] ページの [セキュリティ] で、[Windows のグループ名またはユーザー名を使用して、キューを制御する] チェック ボックスをオンまたはオフにします。

    このチェックボックスをオンにした場合は、キューへのメッセージの書き込みを許可するユーザーまたはグループの名前を入力します。このオプションを使用できるのは、静的キューを使用している場合だけです。

  7. [ポート プロパティの詳細設定] ページの [トランザクションのサポート] で、[このキューはトランザクションを必要とする] チェックボックスをオンまたはオフにします。

  8. [完了] をクリックします。

注

  • ポート実装を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • 既存のポート実装を編集する場合、実装ウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装

メッセージとポートの対応付け

ポート実装のプロパティの変更

ポート実装について

メッセージ キュー シェイプの使用

XML 通信ウィザードの使用


BizTalk メッセージを使用したポートの実装

  1. BizTalk オーケストレーション デザイナの設計ページで、[実装] ステンシルの [BizTalk メッセージ] シェイプを境界バーの右側にドラッグします。.

    [BizTalk メッセージ バインド ウィザード] が表示されます。

  2. [BizTalk メッセージ バインド ウィザードへようこそ] ページで、次のオプションのいずれかをクリックし、[次へ] をクリックします。
    • [新しいポートの作成]

      BizTalk オーケストレーション デザイナでは、新しいポート実装が追加されるごとに、既定でポート名に番号が追加されます。この名前は変更できます。

    • [既存の未バインド ポート]

      [既存の未バインド ポート] ボックスの一覧で、使用するポートをクリックします。

      [既存の未バインド ポート] ボックスの一覧には、未バインド ポートの名前だけが表示されます。未バインド ポートには、定義済みの実装がありません。

  3. [通信の方向] ページで、次のオプションのいずれかをクリックします。
    • 送信

      [次へ] をクリックします。手順 4. に進みます。

    • 受信

      [次へ] をクリックします。手順 5. に進みます。

    注

    • [受信] を選択した場合、HTTP URL 送信先を使用するか、XLANG スケジュールからメッセージを受信するように BizTalk メッセージ マネージャを使ってメッセージ ポートを構成して XLANG スケジュールをインスタンス化するようにし、そのスケジュール内の特定のポートにメッセージを送信させることで、メッセージを受信できます。HTTP URL によるメッセージ受信の詳細については、「BizTalk サービスの統合」を参照してください。BizTalk メッセージ マネージャによるメッセージ ポートの構成の詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。
  4. [静的または動的なチャネル情報] ページで、次のオプションのいずれかをクリックし、[完了] をクリックします。
    • [静的チャネル]

      既存のチャネルの名前を入力します。

    • [動的チャネル]

      このオプションを選択した場合は、BizTalk メッセージ サービスで実行時に必要になるデータを提供するためのポートを構成する必要があります。このデータによって、メッセージを処理するための適切なチャネルを特定します。

      以前に受信したメッセージ フィールドからこのポートのポート参照へのリンクを、[データ] ページで作成する必要があります。メッセージ フィールドは送信先アドレスを含んでいなければなりません。このアドレスは、そのチャネルに関連付けられているオープンなメッセージ ポート用の送信先アドレスとして BizTalk メッセージ サービスが使用します。詳細については、「BizTalk サービスの統合」を参照してください。

      アクションからこのポートへの通信フローを確立するには、XML 通信ウィザードを使用します。[メッセージの種類の情報] ページの [メッセージの種類] ボックスに、チャネルの受信ドキュメント定義の名前を入力します。BizTalk メッセージ サービスは、このデータを使用して、メッセージを処理するためのチャネルを識別します。詳細については、「Identification」を参照してください。

    重要

    • 指定した受信ドキュメント定義を使うチャネルが、少なくとも 1 つ BizTalk メッセージ サービスで構成されている必要があります。アクションが BizTalk メッセージにバインドされているポートと通信し、バインドの指定されたチャネルがスクリプト コンポーネントに存在しない場合は、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。

    • 指定した受信ドキュメント定義を使用するチャネルは、BizTalk メッセージ サービスで 1 つだけ構成し、XLANG スケジュールを送信元として構成してください。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。そのチャネルは、オープンなメッセージ ポートと関連付ける必要もあります。アクションが BizTalk メッセージにバインドされているポートと通信した場合に、バインド用のチャネルが複数存在していたときには、XLANG スケジュール インスタンスはイベント ログ エントリを出力して終了します。
  5. [XLANG スケジュールのアクティブ化情報] ページで、次のオプションのいずれかをクリックします。
    • [あり]

      このポートは、ループ内の複数の受信アクションまたは 1 つの受信アクションで使用できません。

      [完了] をクリックします。

    • [なし]

      [次へ] をクリックします。

  6. [チャネル情報] ページの [チャネル名] ボックスに、使用するチャネルの名前を入力します。チャネルの詳細については、「チャネルについて」および「チャネルの検索」を参照してください。

  7. [チャネル情報] ページの [BizTalk メッセージ サービスがドキュメントを受信する HTTP URL アドレス] ボックスに、BizTalk Server がこのチャネルのドキュメントを受信する、受信側の URL アドレスを入力します。

  8. [完了] をクリックします。

重要

  • メッセージを受信したときに新しい XLANG スケジュールがアクティブになるようにポートを構成する場合、次の制限を考慮する必要があります。
    • メッセージを受信したときにスケジュールをアクティブにするために使用できるポートは、1 つのスケジュール内で 1 つだけです。

    • このポートで受信できるアクションは 1 つだけです。

    • この 1 つのアクションは、ループ本体に含められません。

    • このポートのポート参照からスケジュール内のほかのメッセージへのデータ フローの接続は、描画できません。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • ポート実装を追加できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • 既存のポート実装を編集する場合、実装ウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

各国語対応に関する問題

  • 非アクティブ化受信確認チャネルの名前に非 ASCII 文字が含まれている場合、HTTP でのドキュメントの送信は失敗します。チャネル名は URL のクエリ文字列で渡され、非 ASCII 文字はクエリ文字列ではサポートされていません。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

メッセージ キューを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装

BizTalk サービスの統合

メッセージとポートの対応付け

ポート実装のプロパティの変更

チャネルの検索

チャネルについて

ポート実装について

BizTalk メッセージ シェイプの使用

XML 通信ウィザードの使用


ポート実装のプロパティの変更

  1. BizTalk オーケストレーション デザイナの設計ページで、変更する [実装] シェイプを右クリックします。

  2. [プロパティ] をクリックします。

    その実装シェイプのウィザードが表示されます。

  3. ウィザードの手順に従って、目的のプロパティを変更します。

注

  • ポート実装を変更できるのは [ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページではポート実装を使用できません。

  • [データ] ページにはシェイプを追加できません。新しいポートを作成するたびに、[データ] ページにポート参照が自動的に作成されます。

  • 実装のウィザードの最初のページで [現在のポートの名前を変更] を使用すると、ポートの名前を変更できます。

関連項目

COM コンポーネントを使用したポートの実装

Windows スクリプト コンポーネントを使用したポートの実装

BizTalk メッセージを使用したポートの実装

メッセージ キューを使用したポートの実装

実装シェイプ

ビジネス プロセスの実装


メッセージの送信と受信

BizTalk オーケストレーション デザイナには 2 つの形式の通信が用意されており、XLANG スケジュールはそれを使用することで、メッセージの送信と受信を行うことができます。

  • 同期通信 : メソッド呼び出しを使用して、同期メッセージの組が送信および受信されます。

  • 非同期通信 : XML メッセージを使用して、非同期メッセージが送信および受信されます。

詳細については、「同期通信と非同期通信」を参照してください。

ここには次のトピックが含まれます。

  • アクションとポート間の通信フローの確立

  • 同期メッセージの送信と受信

  • 非同期メッセージの送信と受信

  • アクションとポート間の通信フローの変更

関連項目

同期通信と非同期通信

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


アクションとポート間の通信フローの確立

  1. BizTalk オーケストレーション デザイナの設計ページで、[アクション] シェイプをクリックし、選択します。

  2. [アクション] シェイプの右側の制御ハンドル ( 制御ハンドル) を、[ポート] シェイプの接続ポイント ( 接続ポイント) にドラッグします。

    通信ウィザードが表示されます。

  3. 作成する通信フローの種類に応じて、次のいずれかの手順に進みます。
    • COM コンポーネントまたはスクリプト コンポーネント実装を使用するポートへの同期通信フローを作成する場合は、[メソッド通信ウィザード] を使用します。「同期メッセージの送信と受信」へ進んでください。

    • メッセージ キューまたは BizTalk メッセージの実装を使用するポートへの非同期通信フローを作成する場合、および未バインド ポートへの非同期通信フローを作成する場合は、[XML 通信ウィザード] を使用します。「非同期メッセージの送信と受信」へ進んでください。

注

  • シェイプの接続には、コネクタ ツールも使用できます。詳細については、「コネクタ ツールの使用」を参照してください。

  • アクションとポート間の通信フローを確立できるのは、[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページでは、アクションおよびポートを使用できません。

  • [データ] ページにはシェイプを追加できません。アクションをポートに接続するたびに、[データ] ページに新しいメッセージが自動的に作成されます。


同期メッセージの送信と受信

BizTalk オーケストレーション デザイナで、アクションとポートとの間に同期通信用の通信フローを作成すると、[メソッド通信ウィザード] が表示されます。通信フロー作成の詳細については、「アクションとポート間の通信フローの確立」を参照してください。

  1. [メソッド通信ウィザードへようこそ] ページで、次のオプションのいずれかをクリックします。
    • [同期メソッド呼び出しを開始する]

      XLANG スケジューラ エンジンによって、同期メソッド呼び出しが開始されます。

      この場合、XLANG スケジューラ エンジンがコンポーネントへメソッド呼び出しを送信し、コンポーネントからの応答を待って、応答を受信します。

      [次へ] をクリックします。手順 3. に進みます。

    • [同期メソッド呼び出しを待つ]

      XLANG スケジューラ エンジンは、ほかのアプリケーションによって開始されたメソッド呼び出しの受信を待ちます。

      この場合、XLANG スケジューラ エンジンは、ほかのアプリケーションがメソッド呼び出しを開始するのを待ちます。そのアプリケーションがメソッド呼び出しをコンポーネントに送信し、XLANG スケジューラ エンジンはそのコンポーネントからの応答を待って、アプリケーションに応答を返します。XLANG スケジュールは、メソッド要求とメソッド応答の両方をインターセプトします。

      手順 2. に進みます。

  2. XLANG スケジュールの実行を最適化するには、[メソッド通信ウィザードへようこそ] ページで、XLANG スケジューラ エンジンがメッセージの受信を待つ時間を秒単位で入力し、[次へ] をクリックします。

    既定の待ち時間は 0 秒です。この時間は変更することができます。180 秒以下の値を指定すると、XLANG スケジュールはステータス退避を行わなくなります。180 秒よりも大きい値を指定すると、XLANG スケジュールは直ちにステータス退避を行います。待ち時間と XLANG スケジュールのステータス退避の詳細については、「ステータス退避とステータス復元」および「メソッド通信ウィザードの使用」を参照してください。

  3. [メッセージ情報] ページで、次のオプションのいずれかをクリックします。
    • [新しいメッセージの作成]

      このメッセージの名前は、このウィザードの次のページで選択するメソッドによって自動的に決定されます。新しいメッセージのデータ フローは、[データ] ページのほかのメッセージに接続されている必要があります。

      [次へ] をクリックします。手順 4. に進みます。

    • [既存の同期メッセージ ペアに参照を追加]

      既に構成済みのメッセージの組への参照が、この通信フローに追加されます。このようなメッセージの組は、同じポート内に限って再利用できます。ほかのポート実装では使用できません。

      [完了] をクリックします。

  4. [メッセージ仕様情報] ページの [メソッド] ボックスの一覧で、使用するメソッドをクリックします。この一覧から選択できるメソッドは 1 つだけです。

    メソッドを選択することで、この通信フローに対するメッセージが定義されます。<入力> および <出力> パラメータは、選択したメソッドのパラメータ条件から自動的に決まります。どちらのパラメータ一覧にも、パラメータの名前とデータ型が含まれています。

    通信フローで使用されるメッセージの定義については、「同期通信」を参照してください。

  5. [完了] をクリックします。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • [同期メソッド呼び出しを待つ] をクリックしない限り、待ち時間プロパティは有効になりません。

  • 同期通信の使用中に利用できるメソッドは、ポート実装に対して選択されたものだけです。ほかのポート実装のメソッドは使用できません。また、非同期通信フローの XML メッセージも使用できません。利用可能なメソッドを変更するには、ポート実装のウィザードをもう一度起動し、ほかのメソッドを選択します。

  • 同期通信を作成すると、[データ] ページにメッセージが作成されます。このメッセージは、その通信フローで使用されるメソッドとパラメータに対応しています。メッセージには、メソッドに対するすべての <入力> パラメータが含まれています。

    メソッドにパラメータを含めないことは可能ですが、メッセージには入力必須のシステム フィールドが必ず含まれます。同期通信で使用されるメッセージの定義については、「同期通信」を参照してください。

関連項目

ステータス退避とステータス復元

アクションとポート間の通信フローの確立

ポートの実装

非同期メッセージの送信と受信

同期通信

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


非同期メッセージの送信と受信

  1. [XML 通信ウィザードへようこそ] ページで、次のオプションのいずれかをクリックします。
    • 送信

      メッセージが非同期で送信されます。

      [次へ] をクリックします。手順 3. に進みます。

    • 受信

      XLANG スケジューラ エンジンは、メッセージの受信を待ってから XLANG スケジュールを続行します。

      手順 2. に進みます。

  2. XLANG スケジュールの実行を最適化するには、[XML 通信ウィザードへようこそ] ページで、XLANG スケジューラ エンジンがメッセージの受信を待つ時間を秒単位で入力し、[次へ] をクリックします。

    既定の待ち時間は 0 秒です。この時間は変更することができます。180 秒以下の値を指定すると、XLANG スケジュールはステータス退避を行わなくなります。180 秒よりも大きい値を指定すると、XLANG スケジュールは直ちにステータス退避を行います。待ち時間と XLANG スケジュールのステータス退避の詳細については、「ステータス退避とステータス復元」および「XML 通信ウィザードの使用」を参照してください。

  3. [メッセージ情報] ページで、次のオプションのいずれかをクリックします。
    • [新しいメッセージの作成]

      [メッセージ名] ボックスに、メッセージの名前を入力します。既定のメッセージ名はメッセージに数字を追加した名前です。この名前は変更できます。

      新しいメッセージのデータ フローは、[データ] ページのほかのメッセージに接続されている必要があります。

    • [既存のメッセージに参照を追加]

      既に構成済みのメッセージへの参照が、この通信フローに追加されます。

  4. [次へ] をクリックし、次のいずれかの手順に進みます。
    • [XML 通信ウィザードへようこそ] ページで [送信] をクリックした場合は、手順 5. へ進みます。

    • [XML 通信ウィザードへようこそ] ページで [受信] をクリックした場合は、手順 8. へ進みます。
  5. [XML 変換情報] ページで、次のオプションのいずれかをクリックし、[次へ] をクリックします。
    • [XML メッセージをキューに送信する]

    • [メッセージをキューに文字列として送信する]

      XLANG スケジューラ エンジンは、この文字列から標準 XML ラッパーを削除する必要があります。

    XLANG スケジューラ エンジン内のデータ フローは、XML を使用して処理されます。スケジューラ エンジンは標準で、XML メッセージをメッセージ キューに送信します。スケジューラ エンジンは、メッセージから標準 XML ラッパーを削除し、文字列として送信することもできます。データ フローでは、このアクションに対する正しい仕様書式でメッセージが配信される必要があります。

    XML メッセージを文字列として送信または受信する場合は、このメッセージの [データ] ページに作成された [メッセージ] シェイプに、StringData という名前のフィールドが含まれている必要があります。また、このメッセージには仕様フィールドを追加できません。

  6. [メッセージの種類の情報] ページの [メッセージの種類] ボックスで、メッセージのラベル指定を入力します。

    入力したテキストは、メッセージがキューに送信されるときにメッセージのラベルとして使用されます。

  7. 次のいずれかの手順に進みます。
    • [XML 変換情報] ページで [XML メッセージをキューに送信する] をクリックした場合は、[次へ] をクリックします。手順 10. に進みます。

    • [XML 変換情報] ページで [メッセージをキューに文字列として送信する] をクリックした場合は、[完了] をクリックします。
  8. [XML 変換情報] ページで、次のオプションのいずれかをクリックし、[次へ] をクリックします。
    • [キューから XML メッセージを受信する]

    • [キューから文字列メッセージを受信する]

      XLANG スケジューラ エンジンは、エンジンの標準 XML ラッパーの文字列をラップする必要があります。

    XLANG スケジューラ エンジン内のデータ フローは、XML を使用して処理されます。スケジューラ エンジンは標準で、XML メッセージをメッセージ キューから受信します。スケジューラ エンジンは、メッセージを文字列として受信し、それを XML でラップすることもできます。

  9. [メッセージの種類の情報] ページの [メッセージの種類] ボックスで、メッセージのラベル指定を入力します。

    入力したテキストは、メッセージ キューから受信するメッセージを正しく識別するために使用されます。

    最初に、XLANG スケジューラ エンジンはメッセージの種類の情報をキュー内にあるメッセージ ラベルと照合し、一致するものを探します。

    次に、キュー内にあるメッセージが XML 形式である場合、XLANG スケジューラ エンジンはメッセージの種類の情報をキュー内にあるメッセージの XML ルートの要素と照合し、一致するものを探します。

  10. 次のいずれかの手順に進みます。
    • [XML 変換情報] ページで [キューから XML メッセージを受信する] をクリックした場合は、[次へ] をクリックします。手順 11. に進みます。

    • [XML 変換情報] ページで [キューから文字列メッセージを受信する] をクリックした場合は、[完了] をクリックします。
  11. [メッセージ仕様情報] ページで [参照] をクリックします。

    [仕様の参照] ダイアログ ボックスが表示されます。

  12. 使用する仕様に移動し、その仕様をクリックします。次に、[開く] をクリックします。

    選択した仕様のファイル パスとファイル名が、[メッセージ仕様情報] ページの [メッセージ仕様] ボックスに入力されます。

    注

    • 既存の仕様を参照しない場合は、[作成] をクリックします。この操作によって BizTalk エディタが起動し、このメッセージで使用する仕様を選択したり、必要に応じて変更することができます。新しい仕様を作成することもできます。

    • 仕様を参照して選択した場合は、[作成] ボタンが [編集] という名前になります。[編集] をクリックすると、選択した仕様を変更できます。
  13. 仕様に対してメッセージを検証する場合は、[メッセージ仕様情報] ページの [仕様に対してメッセージを検証] チェック ボックスをオンにします。

    注

    • 検証する仕様を選択しないと、このチェック ボックスは有効になりません。
  14. [メッセージ仕様情報] ページの [メッセージ フィールド] ボックスの一覧にフィールドを追加する場合は、[追加] をクリックします。

    重要

    • このメッセージ仕様の追加フィールドを選択する場合は、BizTalk エディタを使用して作成した仕様を使用する必要があります。標準またはスキーマを BizTalk エディタにインポートしてから BizTalk Server 仕様として保存すると、それらを適合させることができます。詳細については、「仕様の作成と検証」を参照してください。
  15. [フィールドの選択] ダイアログ ボックスの [ノードを選択してください] ツリーで必要なノードを展開し、追加するフィールドをクリックして、[OK] をクリックします。

    注

    • [ノードを選択してください] ツリーのフィールドをクリックすると、[フィールド名] ボックスにフィールド名が自動的に追加されます。

    • [ノードを選択してください] ツリーのフィールドをクリックすると、[ノード パス] ボックスにノード パスが自動的に追加されます。このパスは、手動で編集できます。詳細については、「ノード パス フィールド」を参照してください。

    • レコード ノードを選択して、[メッセージ フィールド] の一覧に追加することはできません。選択できるのはフィールドだけです。詳細については、「ノード パス フィールド」を参照してください。

    • [メッセージ フィールド] ボックスの一覧に複数のフィールドを追加したい場合は、[フィールドの選択] ダイアログ ボックスでフィールドを選択し、[OK] をクリックします。[メッセージ仕様情報] ページで [追加] をクリックし、この手順を繰り返してほかのフィールドを追加します。
  16. [メッセージ フィールド] ボックスの一覧からフィールドを削除する場合は、[メッセージ仕様情報] ページで一覧のフィールドをクリックし、[削除] をクリックします。

    注

    • 入力必須フィールドは削除できません。入力必須フィールドは、[メッセージ フィールド] ボックスの一覧で背景が黄色に表示されます。
  17. [完了] をクリックします。

注

  • シェイプ名は命名規則に従っている必要があります。次の規則はトランザクション、ポート、メッセージ、条件、およびフィールドに適用されます。
    • 名前は、有効な XML トークン名にします。XML の詳細については、W3C の Web サイト (www.w3.org) を参照してください。

    • 名前をアンダースコア (__) で始めることはできません。

    • 名前にはコロン (:) を含めることはできません。

    • 名前の長さは 32 文字以内にします。

    • 定数名およびメッセージ名は、数字で始めることはできません。
  • [受信] をクリックしないと、待ち時間プロパティは有効になりません。

  • 非同期通信で使用可能なメッセージは、XML メッセージだけです。すべての XML メッセージが使用可能で、複数のポートに対して指定できます。[メソッド通信ウィザード] を使用して作成した同期メッセージの組は、すべて使用できません。

  • この通信フローを、BizTalk メッセージを使用して実装したポートに接続する場合、通信の方向 (送信または受信) はポート実装によって決まります。[XML 通信ウィザード] では設定できません。ウィザードの最初のページの [送信] および [受信] オプションは自動的に選択され、利用できません。通信フローの構成を終了するには、[次へ] をクリックして次のページに進む必要があります。

  • 非同期通信を構成すると、[データ] ページにメッセージが作成されます。このメッセージは、その通信フローで送信または受信される情報に対応しています。メッセージには、入力必須のシステムフィールドと、必要な追加仕様フィールドが含まれます。非同期メッセージ通信で使用されるメッセージの定義については、「非同期通信」を参照してください。

関連項目

非同期通信

仕様の作成と検証

仕様の作成とデータのマッピング

ステータス退避とステータス復元

アクションとポート間の通信フローの確立

ノード パス フィールド

同期メッセージの送信と受信

XML 通信ウィザードの使用


アクションとポート間の通信フローの変更

  1. BizTalk オーケストレーション デザイナの設計ページで、アクションとポート間の通信フローを右クリックします。

    通信ウィザードが表示されます。

  2. ウィザードの手順に従って、目的のプロパティを変更します。

  3. 作成する通信フローの種類に応じて、次のいずれかの手順に進みます。
    • COM コンポーネントまたはスクリプト コンポーネントの実装を使用するポートへの同期通信フローを作成する場合は、メソッド通信ウィザードを使用します。「同期メッセージの送信と受信」へ進んでください。

    • メッセージ キューまたは BizTalk メッセージの実装を使用するポートへの非同期通信フローを作成する場合、および未バインド ポートへの非同期通信フローを作成する場合は、XML 通信ウィザードを使用する必要があります。「非同期メッセージの送信と受信」へ進んでください。

注

  • アクションとポート間の通信フローを確立できるのは、[ビジネス プロセス] ページ、[<トランザクション> の補正] ページ、および [<トランザクション> の失敗時] ページです。[データ] ページでは、アクションおよびポートを使用できません。

  • [データ] ページにはシェイプを追加できません。アクションをポートに接続するたびに、[データ] ページに新しいメッセージが自動的に作成されます。

関連項目

アクションとポート間の通信フローの確立

非同期メッセージの送信と受信

同期メッセージの送信と受信

メソッド通信ウィザードの使用

XML 通信ウィザードの使用


メッセージ間のデータ フローの記述

ここには次のトピックが含まれます。

  • メッセージの選択

  • メッセージ内のフィールドの選択

  • メッセージ間のフローの記述

  • メッセージの削除

  • メッセージとポートの対応付け

  • 定数の使用

関連項目

シェイプの追加、削除、および接続

データ処理


メッセージの選択

  • BizTalk オーケストレーション デザイナの [データ] ページで、選択するメッセージのグレーのヘッダ フィールドをクリックします。

    選択したメッセージ全体が、緑の点線で囲まれます。

注

  • [定数] ボックスの一覧、[ポート参照] ボックスの一覧、または [メッセージ] を選択できます。

  • メッセージ全体を選択すると、ドラッグすることでページ上を移動できます。メッセージを移動すると、メッセージ間に記述されたデータ フローを明確にすることができます。

関連項目

シェイプの追加、削除、および接続

データ処理

メッセージの削除

メッセージ間のフローの記述

メッセージとポートの対応付け

メッセージ内のフィールドの選択

定数の使用


メッセージ内のフィールドの選択

  • BizTalk オーケストレーション デザイナの [データ] ページで、メッセージ内の選択するフィールドをクリックします。

    選択したフィールドは、緑の点線で囲まれます。そのフィールドで使用可能なすべての制御ハンドル ( 制御ハンドル) が有効になります。

関連項目

シェイプの追加、削除、および接続

データ処理

メッセージの削除

メッセージ間のフローの記述

メッセージとポートの対応付け

メッセージの選択

定数の使用


メッセージ間のフローの記述

  1. BizTalk オーケストレーション デザイナの [データ] ページで、メッセージ内のフィールドをクリックし、制御ハンドル ( 制御ハンドル) を有効にします。

  2. 制御ハンドルを、接続先となる別のメッセージにあるフィールドの接続ポイント ( 接続ポイント) までドラッグします。

  3. 接続ポイントが赤い四角形 ( アクティブ接続ポイント) で強調表示されたら、マウス ボタンを離して接続を設定します。

注

  • 複数のデータ フローを作成する場合は、コネクタ ツールを使用するとフローを簡単に追加できます。コネクタ ツールの詳細については、「コネクタ ツールの使用」を参照してください。

関連項目

シェイプの追加、削除、および接続

データ処理

メッセージの削除

メッセージとポートの対応付け

メッセージ内のフィールドの選択

メッセージの選択

定数の使用


メッセージの削除

  • BizTalk オーケストレーション デザイナの [データ] ページで、削除するメッセージのグレーのヘッダ フィールドをクリックし、Delete キーを押します。

注

  • [ポート参照] ボックスの一覧は削除できません。

  • [定数] ボックスの一覧は削除できません。

  • メッセージ内のフィールドを 1 つだけ選択し、Delete キーを押すと、そのフィールドだけではなくメッセージ全体が削除されます。

関連項目

シェイプの追加、削除、および接続

データ処理

メッセージ間のフローの記述

メッセージ内のフィールドの選択

メッセージの選択


メッセージとポートの対応付け

  1. [ポート参照] ボックスの一覧で、参照先のポートの名前を含んだフィールドをクリックします。

  2. 制御ハンドル ( 制御ハンドル) を、そのフィールドから、ポートへの参照を渡すメッセージ内のフィールドの接続ポイント ( 接続ポイント) までドラッグします。

重要

  • メッセージとポート参照の関連付けの詳細については、次のトピックを参照してください。
    • インスタンス管理

    • データ処理

    • ポート実装について

関連項目

データ処理

メッセージの削除

メッセージ間のフローの記述

ポートの実装

インスタンス管理

メッセージ内のフィールドの選択

メッセージの選択

ポート実装について

定数の使用


定数の使用

ここには次のトピックが含まれます。

  • 定数の追加

  • 定数の編集

  • 定数の削除

関連項目

データ処理

フィールド データ型

データ型とデータ型値の概要


定数の追加

  1. BizTalk オーケストレーション デザイナの [データ] ページで、[定数] の一覧を右クリックし、[プロパティ] をクリックします。

    [定数メッセージのプロパティ] ダイアログ ボックスが表示されます。

  2. [追加] をクリックします。

    [定数のプロパティ] ダイアログ ボックスが表示されます。

  3. [名前] ボックスに、定数の名前を入力します。

  4. [データ型] ボックスの一覧で、その定数のデータ型をクリックします。

  5. [値] ボックスに、その定数の値を入力します。

  6. [OK] をクリックし、もう一度 [OK] をクリックします。

注

  • 既定では、作成した定数に数字を追加した名前が与えられます。この名前は変更できます。

  • [データ型の説明] には、選択したデータ型に関する情報が読み取り専用で表示されます。場合によっては、そのデータ型の書式の例や、有効な値の範囲なども表示されます。

関連項目

データ処理

定数の削除

定数の編集

フィールド データ型

データ型とデータ型値の概要


定数の編集

  1. BizTalk オーケストレーション デザイナの [データ] ページで、[定数] の一覧を右クリックし、[プロパティ] をクリックします。

    [定数メッセージのプロパティ] ダイアログ ボックスが表示されます。

  2. [定数] ボックスの一覧で、編集する定数をクリックします。

  3. [編集] をクリックします。

    [定数のプロパティ] ダイアログ ボックスが表示されます。

  4. 変更が必要な定数のプロパティを編集し、[OK] をクリックします。

注

  • [定数のプロパティ] ダイアログ ボックスで利用可能なプロパティの詳細については、「定数の追加」を参照してください。

  • 既定では、作成した定数に数字を追加した名前が与えられます。この名前は変更できます。

  • [データ型の説明] には、選択したデータ型に関する情報が読み取り専用で表示されます。場合によっては、そのデータ型の書式の例や、有効な値の範囲なども表示されます。

関連項目

定数の追加

データ処理

定数の削除

フィールド データ型

データ型とデータ型値の概要


定数の削除

  1. BizTalk オーケストレーション デザイナの [データ] ページで、[定数] の一覧を右クリックし、[プロパティ] をクリックします。

    [定数メッセージのプロパティ] ダイアログ ボックスが表示されます。

  2. [定数] ボックスの一覧で、削除する定数をクリックします。

  3. [削除] をクリックします。

関連項目

定数の追加

データ処理

定数の編集

フィールド データ型

データ型とデータ型値の概要


XLANG スケジュールの実行

ここでは、XLANG スケジュールのコンパイルおよびデバッグの方法、および XLANG スケジュールを有効にし、実行する方法について説明します。XLANG スケジュールを実行するには、専用のスケジュール インスタンスをホストする COM+ アプリケーションも作成するとよいでしょう。

ここには次のトピックが含まれます。

  • XLANG スケジュールのコンパイルとデバッグ

  • XLANG スケジュール ホスト アプリケーションの作成と構成

関連項目

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュールのコンパイルとデバッグ

XLANG スケジュールを作成したら、そのスケジュールをコンパイル、実行、テスト、およびデバッグします。 BizTalk オーケストレーション デザイナは、これを支援するための機能を提供します。

BizTalk オーケストレーション デザイナで利用可能なオプションは、次のとおりです。

  • コンパイル

  • メソッドの署名の更新

  • 実行中の XLANG スケジュールのインスタンスのシャットダウン

これらのオプション以外に、XLANG スケジュールのテストとデバッグに役立つツールが 2 つあります。

  • XLANG Event Monitor : このツールを使用すると、実行中の XLANG スケジュール インスタンスを監視できます。このツールの使用方法の詳細については、付属のリリース ノートを参照してください。Microsoft BizTalk Server 2002 セットアップ ウィザードによってインストールされる XLANG Event Monitor (XLANGMon.exe) とリリース ノートは、インストール ディレクトリの \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools にあります。

  • Windows 2000 イベント ビューア : このツールを使用すると、XLANG スケジュール エラーを表示できます。詳細については、次のトピックを参照してください。
    • イベント ビューアの管理

    • 実行中の XLANG スケジュールの監視

    • イベント ビューアの詳細については、Windows 2000 Server ヘルプの「イベント ビューアを使う」を参照してください。

ここには次のトピックが含まれます。

  • XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

  • XLANG スケジュールの実行 (操作方法)

  • XLANG スケジュールのプール

  • コンパイルされた Visual Basic コンポーネントのデバッグ

  • メソッド署名の更新

  • 実行中のすべての XLANG スケジュールのシャットダウン

関連項目

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

  1. BizTalk オーケストレーション デザイナで、[ファイル] メニューの [XLANG <フローチャート X>.skx の作成] をクリックします。

    [XLANG スケジュールに名前を付けて保存] ダイアログ ボックスが表示されます。

  2. [XLANG スケジュールに名前を付けて保存] ボックスの一覧で、XLANG スケジュールを保存する場所を参照します。

  3. [ファイル名] ボックスの一覧で、ファイル名を変更することもできます。

  4. [保存] をクリックします。

注

  • XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにするときに、コンパイル エラーが発生する場合があります。エラー メッセージにはフローチャート内の問題が示され、影響を受けたシェイプは緑の点線で囲まれて強調表示されます。

  • XLANG スケジュール フローチャートをコンパイルして XLANG スケジュールにする場合、フローチャートは既定の <フローチャートX>.skx という名前でコンパイルされます。ここで、X はスケジュール名に付加された番号です。このファイル名は、フローチャートのコンパイル時に変更できます。

  • XLANG スケジュールのファイル拡張子は .skx です。.skx ファイルは、XLANG 言語で記述された XML ファイルです。BizTalk オーケストレーション デザイナでは、.skx ファイルを開くことはできません。.skx ファイルを変更または更新するには、ソースの .skv ファイルを開いて変更した後、その .skv ファイルを .skx ファイルに再コンパイルします。

  • XLANG スケジュール フローチャートのファイル拡張子は .skv です。

  • Microsoft® Visual InterDev® がスクリプト デバッガとして設定され、"ジャストインタイム" デバッグがオンになっている場合、オブジェクトを参照するスクリプトを含むスケジュールをコンパイルする時、デバッガが起動することがあります。次のメッセージが返され、応答を求められます。

    アプリケーションをデバッグしますか？

    [いいえ] をクリックします。これによってスクリプトはデバッガを省略し、スケジュールを通常の方法でコンパイルできます ([はい] をクリックするとデバッガが起動します。これを停止するには、すべてのプロセスをデタッチするか、デバッグを取り消さなければならず、そうすると Microsoft Visio がシャットダウンし、保存していないスケジュールが失われます)。この問題を避けるには、レジストリで HKEY_CURRENT_USER\Software\Microsoft\Windows Script\Settings\JITDebug を 1 に設定することによって "ジャストインタイム" デバッグをオフにします。

関連項目

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

コンパイルされた Visual Basic コンポーネントのデバッグ

XLANG アプリケーションとデータベースの管理

XLANG スケジュール フローチャートを開く、および保存する

メソッド署名の更新

XLANG スケジュールの実行 (操作方法)

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

実行中のすべての XLANG スケジュールのシャットダウン


XLANG スケジュールの実行

XLANG スケジュールを実行するには、XLANG スケジュールを有効にするための手段を作成する必要があります。

そのためのおもな方法は 2 つあります。

  • XLANG スケジュールを有効化および実行するように、BizTalk オーケストレーション サービスおよび BizTalk メッセージ サービスを構成します。

    詳細については、次のトピックを参照してください。

    • BizTalk サービスの統合

    • 送信先アプリケーションのプロパティの設定
  • ASP ページなどのインスタンス作成アプリケーションを作成し、プログラム上で XLANG スケジュールをアクティブにします。

    詳細については、次のトピックを参照してください。

    • XLANG スケジュールの実行 (概念)

    • インスタンス作成アプリケーションの作成

    • モニカの構文

関連項目

XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

コンパイルされた Visual Basic コンポーネントのデバッグ

XLANG アプリケーションとデータベースの管理

モニカの構文

メソッド署名の更新

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

実行中のすべての XLANG スケジュールのシャットダウン


XLANG スケジュールのプール

トラフィックが多く、たくさんのスケジュール インスタンスが同時にアクティブになっているとき、リソースを効率的に活用するためにスケジュールをプールすることができます。スケジュールにオブジェクト プールを割り当てるには、以下の手順を実行します。

  1. [開始] シェイプを右クリックし、[プロパティ] をクリックします。

    [開始のプロパティ] ダイアログ ボックスが表示されます。

  2. [プール] ボックスで、ドロップダウン リストからプールを選択します。

オブジェクト プールにプロパティを設定するには、以下の手順を実行します。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. [XLANG Schedule Pool] を右クリックし、次に [プロパティ] をクリックします。

    [XLANG Schedule Pool のプロパティ] ダイアログ ボックスが表示されます。

  4. [詳細設定] タブをクリックします。

  5. [許可] の [変更を許可しない] チェックボックスをオフにし、次に [OK] をクリックします。

  6. ツリーで [XLANG Schedule Pool] を展開し、[コンポーネント] を展開し、[SimpleSkedPool.SimplePoolN.1] を右クリックします。ここでは、N は前の手順でドロップダウン リストから選択したプールの番号です。次に [プロパティ] をクリックします。

    [SimpleSkedPool.SimplePoolN.1 のプロパティ] ダイアログ ボックスが表示されます。

  7. [アクティブ化] タブをクリックします。

  8. [オブジェクト プール] で、以下の指定を行います。
    • [最小プール サイズ] : 最小プール サイズを変更して、メモリに置くオブジェクトの最少数を指定します。

    • [最大プール サイズ] : 最大プール サイズを変更して、同時にアクティブにできるスケジュール インスタンスの最大数を指定します。

    • [タイムアウトの作成 (ミリ秒)] : タイム アウトの作成を変更して、スケジュール インスタンスがアクティブ化を待つ時間 (ミリ秒) を指定します。
  9. [OK] をクリックして、[SimpleSkedPool.SimplePoolN.1 のプロパティ] ダイアログ ボックスを閉じます。

注

  • プールの詳細については、「XLANG スケジュールのプール」を参照してください。


コンパイルされた Visual Basic コンポーネントのデバッグ

Microsoft Visual Basic で作成されたコンポーネントを、コンパイル後にデバッグしなければならない場合があります。

  1. Visual Basic 6.0 で、デバッグする Visual Basic プロジェクトを開きます。

  2. [ファイル] メニューの [<プロジェクト>.dll の作成] をクリックします。

    [実行可能ファイルの作成] ダイアログ ボックスが表示されます。

  3. [オプション] をクリックします。

    プロジェクトのプロパティ ダイアログ ボックスが表示されます。

  4. [プロジェクト プロパティ] ダイアログ ボックスの [コンパイル] タブで、[ネイティブ コード コンパイル] と [最適化なし] をクリックし、[シンボリック デバッグ情報を作成] チェック ボックスをオンにします。

  5. [OK] をクリックし、もう一度 [OK] をクリックして、プロジェクトをコンパイルします。

  6. Visual Basic の .dll プロジェクトを開きます。

  7. 使用するブレークポイントを設定します。

  8. [実行] メニューの [開始] をクリックします。

次回、XLANG スケジュールが Visual Basic コンポーネントを呼び出すと、Visual Basic デバッガがブレークポイントで停止します。

重要

  • Visual Basic の .dll は、[シンボリック デバッグ情報を作成] チェック ボックスがオンになった状態で作成する必要があります。

  • XLANG スケジューラ エンジンが、まだ .dll を読み込んでいないことを確認してください。既に .dll が読み込まれている場合は、XLANG スケジューラ エンジンをシャットダウンしてからやり直してください。

注

  • コンポーネントのデバッグや、コンポーネント サービス、および COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」のページを参照してください。


メソッドの署名の更新

XLANG スケジュールの作成と同時に COM+ コンポーネントを作成し、使用可能な任意のメソッド呼び出しのメソッド パラメータのいずれかを変更する場合に、このオプションを使用します。このオプションによって、XLANG スケジュールで使用可能なメソッド パラメータが、最新の状態に更新されます。

  • BizTalk オーケストレーション デザイナで、[ツール] メニューの [メソッドの署名を更新] をクリックします。

注

  • XLANG スケジュールをコンパイルするときは、[メソッドの署名を更新] が自動的に実行されます。

関連項目

XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

コンパイルされた Visual Basic コンポーネントのデバッグ

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (操作方法)

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ

実行中のすべての XLANG スケジュールのシャットダウン


実行中のすべての XLANG スケジュールのシャットダウン

  • BizTalk オーケストレーション デザイナで、[ツール] メニューの [すべての実行中の XLANG スケジュール インスタンスのシャットダウン] をクリックします。

注

  • XLANG スケジュール インスタンスの実行中は、その XLANG スケジュールで使用されている COM コンポーネントを変更できません。このオプションによって、そのスケジュールで実行中のすべてのインスタンスがシャットダウンされ、コンポーネントが格納されたファイルがロック解除されるため、変更できるようになります。

関連項目

XLANG スケジュール フローチャートから XLANG スケジュールへのコンパイル

XLANG スケジュール ホスト アプリケーションの作成と構成

インスタンス作成アプリケーションの作成

コンパイルされた Visual Basic コンポーネントのデバッグ

XLANG アプリケーションとデータベースの管理

メソッド署名の更新

XLANG スケジュールの実行 (操作方法)

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュール ホスト アプリケーションの作成と構成

ここでは、XLANG スケジュールをアクティブにし、実行する方法について説明します。既定の XLANG スケジューラ アプリケーションを使用して XLANG スケジュールを実行することもできますが、通常は、新しい COM+ アプリケーションを作成してスケジュール インスタンスを実行した方が便利です。

セキュリティ、配置、および構成という問題があるため、XLANG スケジュールをホストするほとんどの COM+ アプリケーションは、XLANG スケジュールを開発するときに作成する必要があります。アプリケーションとスケジュールに対するセキュリティとパフォーマンスの必要性も考慮する必要があります。スケジュール実行の専用のインスタンスをホストする新しい COM+ アプリケーションを作成したり、あるスケジュール インスタンスを実行するアプリケーションを、別のアプリケーションを使用するほかの XLANG スケジュールから分離する場合もあります。

XLANG スケジュール、およびスケジュールをホストする COM+ アプリケーションの作成に関する、セキュリティおよびパフォーマンスの問題の詳細については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

COM+ アプリケーションを作成後に管理する方法については、「XLANG アプリケーションとデータベースの管理」を参照してください。

ここには次のトピックが含まれます。

  • XLANG スケジュールをホストする COM+ アプリケーションの作成

  • XLANG スケジュールをホストする COM+ アプリケーションの構成

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

関連項目

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュールをホストする COM+ アプリケーションの作成

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーの [コンポーネント サービス]、[コンピュータ]、[マイ コンピュータ] を順に展開し、[COM+ アプリケーション] をクリックして選択します。

    最初に、[COM+ アプリケーション] を選択して右クリックする必要があります。これを最初に選択しないと、[新規作成] オプションを使用できません。

  3. [COM+ アプリケーション] を右クリックして [新規作成] をポイントし、[アプリケーション] をクリックします。

    [COM アプリケーション インストール ウィザード] が表示されます。

  4. [COM アプリケーション インストール ウィザードへようこそ] ページで、[次へ] をクリックします。

  5. [新しいアプリケーションのインストールまたは作成] ページで、[空のアプリケーションを作成する] をクリックします。

  6. [空のアプリケーションを作成] ページで、アプリケーションの名前を入力し、[サーバー アプリケーション] が選択されていることを確認して、[次へ] をクリックします。

  7. [アプリケーション ID の設定] ページで、適切なアカウントにアプリケーション ID を設定します。

    XLANG スケジュールをホストする COM+ アプリケーションに対して、サービス アカウントを作成するようにしてください。

    アプリケーション ID の作成に関するセキュリティとパフォーマンスの問題については、「XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ」を参照してください。

  8. [次へ] をクリックし、[完了] をクリックします。

  9. 新しく作成した COM+ アプリケーションを右クリックし、[プロパティ] をクリックします。

  10. [XLANG] タブで、[このアプリケーションを XLANG スケジュール インスタンスのホストにする] チェック ボックスをオンにします。

  11. COM+ アプリケーションを構成するには、「XLANG スケジュールをホストする COM+ アプリケーションの構成」に進んでください。

重要

  • COM+ アプリケーションに 1 つ以上の COM コンポーネントをインストールしなければなりません。

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

  • XLANG スケジュールは専用のプロセスでのみホストすることをお勧めします。スケジュールをホストする COM+ アプリケーションは、ほかの処理を行ってはいけません。

  • XLANG スケジュールをホストする COM+ アプリケーションを作成する場合は、[ステータス退避済み XLANG アプリケーションを再起動] オプションは利用できません。ステータス退避済みアプリケーションを再起動する方法の詳細については、「すべての XLANG アプリケーションの再起動」を参照してください。

関連項目

XLANG スケジュールをホストする COM+ アプリケーションの構成

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


XLANG スケジュールをホストする COM+ アプリケーションの構成

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックして [管理ツール] をダブルクリックし、[コンポーネント サービス] をダブルクリックします。

  2. コンソール ツリーで [コンポーネント サービス] を展開し、[コンピュータ] を展開します。次に [マイ コンピュータ] を展開し、[COM+ アプリケーション] を展開します。

  3. 構成する COM+ アプリケーションを右クリックし、[プロパティ] をクリックします。

    XLANG スケジュールをホストする COM+ アプリケーションを管理するための、サービス アカウントを必ず作成するようにしてください。COM+ アプリケーションを作成するときに、[COM アプリケーション インストール ウィザード] で既定の設定を変更しなかった場合は、ここで設定を変更できます。詳細については、「COM+ アプリケーションのアプリケーション ID の変更」を参照してください。

  4. COM+ アプリケーションの DSN 設定を構成します。

    詳細については、「COM+ アプリケーションの DSN 設定の変更」を参照してください。

  5. COM+ アプリケーションで使用するデータベースを構成します。

    次の構成が可能です。

    • 既存のデータベースの指定。詳細については、「COM+ アプリケーションの DSN 設定の変更」を参照してください。

      – または –

    • 新しいデータベースの作成と構成。詳細については、「新しい空のステータス保存データベースの作成」および「COM+ アプリケーションの DSN 設定の変更」を参照してください。

注意

  • COM+ アプリケーションで使用する新しいデータベースを作成および構成する場合、COM+ アプリケーションのデータ ソース名 (DSN) 設定の構成後に、データベース テーブルを初期化する必要があります。

    DSN の構成方法、およびデータ ソース (ODBC) の使用方法の詳細については、[ODBC データ ソースの管理者] ダイアログ ボックスの [ヘルプ] をクリックしてください。

    構成した COM+ ホスト アプリケーション用に新しいデータベース テーブルを初期化する方法は、次のとおりです。

    1. COM+ アプリケーションを右クリックし、[プロパティ] をクリックします。

    2. [XLANG] タブをクリックします。

    3. [テーブルの初期化] をクリックします。
  • 既存のデータベース用に COM+ ホスト アプリケーションと DSN を構成しているときは、[テーブルの初期化] をクリックしないでください。それを行うと、既存のデータベースにあるデータが破棄されます。

注

  • コンポーネント サービスのヘルプを表示するには、[スタート] ボタンをクリックして [設定] をポイントします。次に [コントロール パネル] をクリックし、[管理ツール] をダブルクリックします。そして [コンポーネント サービス] をダブルクリックします。コンソール ツリーで、[コンポーネント サービス] を右クリックし、[ヘルプ] をクリックします。

  • コンポーネント サービスと COM+ の詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「コンポーネント サービス」を検索してください。

関連項目

COM+ アプリケーションのアプリケーション ID の変更

COM+ アプリケーションの DSN 設定の変更

XLANG スケジュールをホストする COM+ アプリケーションの作成

新しい空のステータス保存データベースの作成

インスタンス作成アプリケーションの作成

XLANG アプリケーションとデータベースの管理

XLANG スケジュールの実行 (概念)

XLANG スケジュール インスタンスをホストするアプリケーションのセキュリティ


BizTalk メッセージ サービスの構成

Microsoft® BizTalk™ Server 2002 で取引先とのドキュメント交換や企業内でのアプリケーション統合を処理するために BizTalk メッセージ サービスを構成する方法には、2 とおりあります。グラフィカル ユーザー インターフェイス (GUI) である BizTalk メッセージ マネージャを使用するか、または BizTalk メッセージ構成オブジェクト モデルに直接アクセスします。

BizTalk メッセージ マネージャまたは BizTalk メッセージ構成オブジェクト モデルを使用すると、データ交換を処理するためのメッセージ ポートとチャネルを作成することができます。また、メッセージ ポートとチャネルの作成に使用する、ドキュメント定義、エンベロープ、および組織を作成できます。さらに、メッセージ ポートのグループである同報リストを作成することもできます。

セキュリティの要件

BizTalk メッセージ マネージャを使用するには、次の条件を満たしていることが必要です。

  • ユーザー アカウントが BizTalk Server Administrators グループに属している。このグループは BizTalk Server 2002 のインストール時に作成されます。このグループには、必要に応じてユーザーを追加することができます。ユーザー アカウントの追加の詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。

  • BizTalk メッセージ管理データベース (InterchangeBTM) への完全なデータベース アクセス権限がある。つまり、ログインでき、データベース ロール db_owner を与えられている必要があります。詳細については、Microsoft SQL Server のオンライン マニュアルの「Windows ユーザーまたはグループに対してデータベースへのアクセスを許可する方法」を参照してください。

BizTalk メッセージ マネージャ、または BizTalk メッセージ構成オブジェクト モデル API を使用しますか？

BizTalk メッセージ マネージャによって、グラフィカル ユーザー インターフェイスを通じて BizTalk メッセージ構成オブジェクトをアクセスできます。このインターフェイスを使用するかどうかは、データベースで使用できる情報の量と種類によります。BizTalk メッセージ構成オブジェクト モデル アプリケーション プログラミング インターフェイス (API) を使用すると、個別のエンティティごとに BizTalk メッセージ マネージャにデータを入力するのでなく、構成プロセスのすべて、または一部を自動化できます。一般的に、取引相手が増えるにつれて、メッセージ サービスの構成に API を使用することの効果が大きくなります。

たとえば、大きな製造企業 (ハブとスポークの関係ではハブにあたる) が 1000 のサプライヤと取り引きしていて、各サプライヤに関する情報を扱うデータベースを保持しているとします。「組織の作成」の段階では、次のようなコードを書くと比較的迅速、簡単にできます。

  • データベースから情報を抽出する

  • BizTalk メッセージ構成オブジェクト モデルを使用して、BizTalk メッセージ管理データベースに入っているこれらの 1,000 の企業をプログラムによって作成する

これに対して、BizTalk メッセージ マネージャを使用して 1000 のオブジェクトを 1 つずつ作成すると、かなりの時間がかかります (同じウィザードを 1000 回実行することを想像してください)。しかも、これは組織を作成するだけで、ドキュメント定義、チャンネル、メッセージ ポートの作成は含みません。

しかし、ごく少数の取引相手とだけ関係を維持している小さなサプライヤ企業 (スポークにあたります) では、時間をかけて特別のコードを作成する代わりに、BizTalk メッセージ マネージャを使用してメッセージ システム全体を構成するでしょう。

BizTalk メッセージ構成オブジェクト モデルを API から直接にアクセスする方法については、「メッセージ サービスの概要」を参照してください。

ここには次のトピックが含まれます。

  • BizTalk メッセージ マネージャの使用


BizTalk メッセージ マネージャの使用

Microsoft® BizTalk™ メッセージ マネージャはグラフィカル ユーザー インターフェイス (UI) の 1 つで、BizTalk メッセージ サービスを構成することによりドキュメントの交換を管理できます。BizTalk メッセージ サービスは、BizTalk 構成オブジェクト モデル API を使用して、プログラムに基づいて構成することもできます。詳細については、「メッセージ サービスの概要」を参照してください。

注意

  • ドキュメントを処理する場合は、あらかじめ BizTalk メッセージ マネージャを使用して BizTalk メッセージ サービスを構成しておく必要があります。Microsoft BizTalk Server 2002 でドキュメントを処理している最中に、使用中のオブジェクトへのアクセスおよび変更を行うと、予期しない結果を招く場合があります。

ドキュメントは取引先とご使用の業務用アプリケーションとの間で交換できます。BizTalk メッセージ マネージャは、BizTalk Server 2002 をインストールしたコンピュータからローカルで使用することも、クライアント アプリケーションとしてリモートで使用することもできます。これによりシステム管理者は、セキュリティを確保し、サーバーを一元管理すると同時に、リモート ユーザーに BizTalk メッセージ マネージャへのアクセスを許可できます。

BizTalk Server 2002 のヘルプには、次の BizTalk メッセージ マネージャ オブジェクトを作成および管理する方法に関する情報が記載されています。

  • チャネル

  • メッセージ ポート

  • ドキュメント定義

  • エンベロープ

  • 組織

また、BizTalk Server 2002 のヘルプには、同報リストの使用方法についての情報も記載されています。

BizTalk メッセージ マネージャ オブジェクト

次の図は、BizTalk メッセージ マネージャで作成できるオブジェクト間の関係を示しています。

BizTalk メッセージ マネージャの概要

次に、BizTalk メッセージ マネージャで作成できるオブジェクトの概要について説明します。オブジェクト間の関係についても説明します。各オブジェクトの詳細については、それぞれの説明の最後にあるリンクをクリックして、該当するオブジェクトのヘルプ トピックを参照してください。

チャネル

チャネルは BizTalk メッセージ マネージャの主要オブジェクトです。BizTalk メッセージ マネージャのその他すべてのオブジェクトの目的は、チャネルを作成するかチャネルの動作をサポートすることです。チャネルは、ドキュメントの送信元が組織、業務で使用するアプリケーション、 XLANG スケジュールのいずれであるかを識別します。ドキュメント定義を使用することにより、受信ドキュメントと送信ドキュメントも識別します。詳細については、「チャネルについて」を参照してください。

メッセージ ポート

メッセージ ポートは、チャネルが処理するドキュメントの送信先を識別します。送信先は、組織、業務で使用するアプリケーション、XLANG スケジュールのいずれかです。メッセージ ポートは、ドキュメントの送信先アドレス、そのアドレスへのトランスポート方法、およびセキュリティによる保護とエンベロープ化が行われているかどうかを指定し、行われている場合はその方法を指定します。詳細については、「メッセージ ポートについて」を参照してください。

組織

組織は、ドキュメントを交換する取引先を表します。既定の組織という特殊な組織は、自分の会社を表します。既定の組織用にアプリケーションを作成でき、それは自分の会社で使用する内部アプリケーションを表します。組織およびアプリケーションは、チャネルの送信元またはメッセージ ポートの送信先として機能します。詳細については、「組織について」を参照してください。

ドキュメント定義

ドキュメント定義は、BizTalk Server 2002 で処理する特定の種類のドキュメントを表し、仕様へのポインタになります。仕様は、ドキュメントの構造、種類、およびバージョンを定義します。チャネルは受信および送信ドキュメント定義を指定し、サーバーで処理されるドキュメントを示します。ドキュメント定義は任意の数のチャネルで使用できます。詳細については、「ドキュメント定義について」を参照してください。

エンベロープ

エンベロープは、オープンな受信インターチェンジまたは送信インターチェンジを作成するために必要な情報を BizTalk Server 2002 に提供します。エンベロープはメッセージ ポート内で選択でき、サーバーに送信インターチェンジの作成を指示します。エンベロープはメッセージ ポートに関係なく、BizTalk Server 2002 によってオープンな受信インターチェンジにも使用できます。詳細については、「エンベロープについて」を参照してください。

同報リスト

同報リストとはメッセージ ポートの集まりで、これを使用するとさまざまな取引先組織または内部アプリケーションのグループに同じドキュメントを送信できます。個々のメッセージ ポートにチャネルを作成する場合と同様に、同報リストには最低 1 つのチャネルを作成する必要があります。詳細については、「同報リストについて」を参照してください。

注

  • BizTalk メッセージ マネージャを使用して作成できるオブジェクトは、BizTalk メッセージ構成オブジェクト モデルを使用してプログラムに基づいて作成することもできます。詳細については、「メッセージ サービスについて」を参照してください。

  • BizTalk メッセージ マネージャを使用して作成できるオブジェクトは、BizTalk メッセージ サービスのほかのユーザー インターフェイスを使用して作成できるオブジェクトも使用します。チャネルで使用されるマップは、BizTalk マッパーで作成します。ドキュメント定義ではドキュメント仕様が、エンベロープではエンベロープ仕様が使用されます。仕様は BizTalk エディタで作成します。

ここには次のトピックが含まれます。

  • BizTalk メッセージ マネージャの全般的な情報については、「BizTalk メッセージ マネージャについて」を参照してください。

  • メッセージ マネージャでの作業目的に関するクイック リファレンスについては、「BizTalk メッセージ マネージャに関する作業を行う目的」を参照してください。

  • 作業の実施方法に関する詳細な手順については、「BizTalk メッセージ マネージャに関する作業を行う方法」を参照してください。


BizTalk メッセージ マネージャについて

ここでは、Microsoft BizTalk メッセージ マネージャを理解するうえで不可欠な概念について説明します。ここには次のトピックが含まれます。

  • BizTalk メッセージ マネージャの環境

  • チャネルについて

  • メッセージ ポートについて

  • 組織について

  • ドキュメント定義について

  • エンベロープについて

  • 受信確認について

  • 同報リストについて


BizTalk メッセージ マネージャの環境

ここには次のトピックが含まれます。

  • BizTalk メッセージ マネージャのオプションの構成

  • BizTalk メッセージ マネージャのユーザー インターフェイス

  • BizTalk メッセージ マネージャのショートカット キー

  • セキュリティ

注意

  • ドキュメントを処理する場合は、あらかじめ BizTalk メッセージ マネージャを使用して BizTalk メッセージ サービスを構成しておく必要があります。Microsoft BizTalk Server 2002 でドキュメントを処理している最中に、使用中のオブジェクトへのアクセスおよび変更を行うと、予期しない結果を招く場合があります。


BizTalk メッセージ マネージャのオプションの構成

ここでは、BizTalk メッセージ マネージャのオプションを変更する方法について説明します。次のオプションがあります。

  • 新しいメッセージ ポートまたはチャネルを構成する。

  • 以前に構成したメッセージ ポートまたはチャネルを管理する。

  • 検索の戻り値を設定する。

  • サーバー接続を設定する。

  • サーバーのタイムアウト値を設定する。

ここには次のトピックが含まれます。

  • BizTalk メッセージ マネージャの構成オプションの選択

  • サーバー接続のオプションの設定

注

  • BizTalk メッセージ マネージャのツール バーの位置は変更できます。ただし、アプリケーションを再起動すると、ツール バーの位置は元に戻ります。


BizTalk メッセージ マネージャの構成オプションの選択

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

    [BizTalk メッセージ マネージャ] ダイアログ ボックスが表示されます。

  2. [構成オプション] で、次のオプションのいずれかを選択します。
    • 組織への新しいメッセージ ポートを作成および構成する場合は、[組織への新しいメッセージ ポートの構成] をクリックし、[OK] をクリックします。

      組織への新しいメッセージ ポートの作成および構成の詳細については、「メッセージ ポートの作成」を参照してください。

    • アプリケーションへの新しいメッセージ ポートを作成および構成する場合は、[アプリケーションへの新しいメッセージ ポートの構成] をクリックし、[OK] をクリックします。

      アプリケーションへの新しいメッセージ ポートの作成および構成の詳細については、「メッセージ ポートの作成」を参照してください。

    • 既存のメッセージ ポートを管理する場合は、[以前に構成したメッセージ ポートの管理] をクリックし、[OK] をクリックします。

      既存のメッセージ ポートの管理の詳細については、「メッセージ ポートの編集」を参照してください。

    • 既存のチャネルを管理する場合は、[以前に構成したチャネルの管理] をクリックし、[OK] をクリックします。

      既存のチャネルの管理の詳細については、「チャネルの編集」を参照してください。

注

  • BizTalk メッセージ マネージャを開いたときにこのダイアログ ボックスが表示されないようにするには、[次回からこのダイアログ ボックスを表示しない] チェック ボックスをオンにします。再び表示されるよう設定するには、[ツール] メニューの [オプション] をクリックし、[スタートアップ ダイアログ ボックスの表示] チェック ボックスをオンにします。

関連項目

メッセージ ポートの作成

チャネルの編集

メッセージ ポートの編集


サーバー接続のオプションの設定

  1. BizTalk メッセージ マネージャで [ツール] メニューの [オプション] をクリックします。

    [オプション] ダイアログ ボックスが表示されます。

  2. [検索結果の最大件数] ボックスで次の手順のいずれかを実行します。
    • 検索で返される件数を入力します。

    • 上矢印または下矢印をクリックして、値を増減します。
  3. [接続する BizTalk Server 名] ボックスに、BizTalk Server 2002 がインストールされているサーバーの名前を入力します。

  4. [サーバー タイムアウト (秒)] ボックスで次の手順のいずれかを実行します。
    • サーバー接続がタイムアウトするまでの秒数を入力します。

    • 上矢印または下矢印をクリックして、値を増減します。
  5. BizTalk メッセージ マネージャを起動したときのダイアログ ボックスの表示/非表示を切り替えるには、[スタートアップ ダイアログ ボックスの表示] チェック ボックスをオンまたはオフにします。

  6. すべてのプロパティを設定したら、[OK] をクリックします。

注

  • 接続するサーバーによって、BizTalk メッセージ マネージャを使用して新しいオブジェクトを検索、編集、または作成する BizTalk メッセージ管理データベースが決定されます。既定の接続先サーバーは、最後に接続したサーバーです。ドキュメント、マップ、およびエンベロープなどの仕様を格納し、取得するための WebDAV リポジトリをホストするサーバーは、ここでの設定とは別に、仕様を選択するために使用するエディタやマッパーなどのダイアログ ボックスから個別に設定します。既定の接続先 WebDAV は、最後に接続した WebDAV です。

  • 検索結果として返される件数の既定の数は 500 です。

  • サーバー接続がタイムアウトするまでの既定の秒数は 20 です。

  • 接続中のサーバーは、BizTalk メッセージ マネージャの左側にある検索ペインの上に表示されます。

  • Internet Explorer 5.5 Service Pack 1 (SP1) を使用している場合には、[応答ドキュメントが無効です。] というエラー メッセージが表示される場合があります。この問題を解決するには、[接続する BizTalk Server 名] ボックスに完全修飾ドメイン名を入力してください。次に、Internet Explorer 5.5 SP1 で、プロキシの設定の例外にドメイン名を指定するか ([ツール] メニューの [インターネット オプション] をクリックし、[接続] タブをクリックします)、または信用済みサイトとして追加します ([ツール] メニューの [インターネット オプション] をクリックし、[セキュリティ] タブをクリックします)。詳細については、Internet Explorer 5.5 SP1 のドキュメントを参照してください。


BizTalk メッセージ マネージャのユーザー インターフェイス

BizTalk メッセージ マネージャのユーザー インターフェイスには、左右 2 つのメイン ペインがあります。

左側のペインには次の項目が表示されます。

  • BizTalk メッセージ マネージャが接続しているサーバーの名前

  • 検索可能なオブジェクトの一覧

  • 検索対象を絞り込むための検索条件

BizTalk メッセージ マネージャを使用して作成したあらゆるオブジェクトを検索できます。検索するオブジェクトの種類を選択するには、[その他の項目を検索] にある名前をクリックします。検索条件は選択するオブジェクトの種類によって異なります。

右側のペインには次の項目が表示されます。

  • 検索で返された項目の詳細

項目の詳細は検索するオブジェクトの種類によって異なります。

検索結果ペインの項目を昇順または降順に並べ替えるには、列のヘッダーをクリックします。並べ替えは、一度に 1 つの列に基づいてのみ実行できます。

注

  • 検索する特定の種類のオブジェクトが多い場合は、すべての件数が返るまでに数分かかる場合があります。検索条件を指定することにより、検索で返される件数の数を減らすことができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

関連項目

BizTalk メッセージ マネージャのショートカット キー

チャネルの検索

同報リストの検索

ドキュメント定義の検索

エンベロープの検索

メッセージ ポートの検索

組織の検索


BizTalk メッセージ マネージャのショートカット キー

BizTalk メッセージ マネージャでは、ショートカット キーを使用して作業できます。次の表は、これらのショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。Windows 2000 Professional では、ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Ctrl + A | すべてを選択します。
Ctrl + C | テキストをコピーします。
Ctrl + X | テキストを切り取ります。
Ctrl + V | テキストを貼り付けます。
Ctrl + Z | テキストの操作を取り消します。
Ctrl + R | 組織への新しいメッセージ ポートを作成します。
Ctrl + Shift + R | アプリケーションへの新しいメッセージ ポートを作成します。
Ctrl + L | 組織から新しいチャネルを作成します。
Ctrl + Shift + L | アプリケーションから新しいチャネルを作成します。
Ctrl + T | 新しい同報リストを作成します。
Ctrl + D | 新しいドキュメント定義を作成します。
Ctrl + G | 新しい組織を作成します。
Del | 選択した項目またはテキストを削除します。
Shift + F10 | 選択した項目のショートカット メニューを表示します。
Shift + 任意の方向キー | ウィンドウ内の複数の項目を選択、またはテキストを選択します。
Tab | ボタンやフィールド間でフォーカスが移動します。
Shift + Tab | ボタンやフィールド間でフォーカスが移動します。
Space | チェック ボックスをオンまたはオフにします。ボタンにフォーカスがある場合、マウスのクリックと同様な動作になります。
Alt + Space | アクティブなウィンドウのシステム メニューを表示します。
Alt + メニュー名の下線付き文字 | 対応するメニューを表示します。
開いたメニューのコマンド名の下線付き文字 | 対応するコマンドを実行します。
Alt + ↓ | アクティブになっているリスト ボックスのドロップダウン リストを表示します。
Enter | アクティブなオプションまたはボタンのコマンドを実行します。
Esc | 現在の作業を取り消します。
F1 | オンライン ヘルプを表示します。
Alt + F4 | アクティブなウィンドウを閉じるかアクティブなプログラムを終了します。
← | タブのフォーカスを左に移動します。
→ | タブのフォーカスを右に移動します。
任意の方向キー | ダイアログ ボックスのメイン ウィンドウにあるフォルダまたはファイルを強調表示します。この機能は、[WebDAV リポジトリからのドキュメント仕様の選択]、[WebDAV リポジトリからのエンベロープ仕様の選択]、および [WebDAV リポジトリからのマップの選択] ダイアログ ボックスで実行されます。詳細については、「ドキュメント仕様の選択」、「エンベロープ仕様の選択」、および「マップの選択」を参照してください。

関連項目

BizTalk メッセージ マネージャのユーザー インターフェイス


セキュリティ

BizTalk メッセージ マネージャを使用してオブジェクトをアクセスまたは作成するためには、次の条件が必要です。

  • ユーザー アカウントが BizTalk Server Administrators グループに属している必要があります。このグループは BizTalk Server 2002 のインストール時に作成されます。このグループには、必要に応じてユーザーを追加することができます。ユーザー アカウントの追加の詳細については、「BizTalk Server Administrators グループへのユーザーの追加」を参照してください。

  • BizTalk メッセージ管理データベース (InterchangeBTM) への完全なデータベース アクセス権限がある。つまり、ログインでき、データベース ロール db_owner を与えられていなければなりません。詳細については、Microsoft SQL Server のマニュアルの「Windows ユーザーまたはグループに対してデータベースへのアクセスを許可する方法」を参照してください。


チャネルについて

チャネルとは、BizTalk メッセージ サービスを構成して、受信したドキュメントを処理するために使用するプロパティのセットです。チャネルはメッセージ ポートまたは同報リスト用に作成することができます。チャネルがドキュメントを処理すると、そのドキュメントは関連付けられたメッセージ ポートまたは関連付けられた同報リスト内のメッセージ ポートで指定された送信先にトランスポートされます。1 つのメッセージ ポートまたは同報リスト用に 1 つ以上のチャネルを作成することができます。

チャネルでは、ドキュメントの送信元を指定します。これは、送信元組織または送信元アプリケーションにすることができます。チャネルの送信元としてアプリケーションを指定するには、既定の組織のアプリケーションを作成する必要があります。これは、自分の会社での実際の内部アプリケーションを表します。また、チャネルの送信元として XLANG スケジュールを指定することもできます。BizTalk オーケストレーション デザイナを使用して XLANG スケジュールを作成することができます。詳細については、「BizTalk オーケストレーションの設計」を参照してください。BizTalk メッセージ サービスと BizTalk オーケストレーション サービスの統合の詳細については、「BizTalk サービスの統合」を参照してください。

チャネルでオープンな送信元を明示的に宣言することもできます。この場合は、ドキュメントを送信するときに、ドキュメント内またはパラメータのいずれかで送信元を指定する必要があります。これは、オープン チャネルといいます。詳細については、「Submitting」を参照してください。

内部アプリケーションまたは取引先組織からの受信ドキュメントを表す、受信ドキュメント定義も指定します。また、指定した送信先に配信するドキュメントを表す、送信ドキュメント定義も指定します。ドキュメント定義の詳細については、「ドキュメント定義について」を参照してください。

送信ドキュメントの書式または構造が受信ドキュメントの書式または構造と異なる場合は、チャネルのマップを指定する必要があります。マップは元の受信ドキュメントの書式または構造を送信先の組織またはアプリケーションによって要求される送信ドキュメントの書式または構造に変換します。たとえば、会計アプリケーションが区切りフラット ファイル書式で発注書を生成し、取引先が X12 書式の発注書を要求する場合は、マップを使用してドキュメントの書式を変換することができます。マップの詳細については、「BizTalk マッパーの使用」を参照してください。

メッセージ ポートまたは同報リスト用に、それぞれに異なる構成で 1 つ以上のチャネルを作成することができます。たとえば、異なる書式で発注書を生成する 2 つの内部会計アプリケーションがあり、別の書式で発注書を受け取ることを希望している取引先があるとします。この場合は、その取引先用に単一のメッセージ ポートを作成してから、そのポート用に各アプリケーションからチャネルを作成することができます。両方のチャネルの送信ドキュメント定義は同じになり、取引先の書式と一致します。ただし、各チャネルにはアプリケーションからの受信ドキュメントの書式を変換するための異なるマップがあります。単一のメッセージ ポートに接続される異なるチャネルを作成できるため、すべての発注書を同じ書式で送信することができます。

また、次の目的のためにチャネルでほかのプロパティを設定することができます。

  • 受信ドキュメント定義で追跡する仕様フィールドを指定します。指定するフィールドは、ドキュメント定義で指定されるグローバル追跡項目の代わりに、この特定のチャネルを使用して処理される各ドキュメント インスタンス用の追跡データベースに記録されます。グローバル追跡項目の詳細については、「ドキュメント データ フィールドの追跡」を参照してください。

  • 処理中のドキュメント内の 1 つ以上のフィールドの値に基づいて、BizTalk Server 2002 がチャネルを呼び出すかどうかを決定するチャネル フィルタ式を作成します。

  • 受信確認を構成します。送信したドキュメントの送信先から受信確認を要求し、受信したドキュメントの送信元のために受信確認を生成することができます。受信確認の処理の詳細については、「受信確認について」を参照してください。

  • セキュリティ プロパティを構成します。サーバーが受信ドキュメントの暗号と署名を確認したり、送信ドキュメントにデジタル署名を行うことを指定できます。

  • ドキュメントのログ オプションを指定します。受信ドキュメントと送信ドキュメントの両方をそれぞれのネイティブ形式、中間 XML 形式、または両方で格納することができます。

  • 詳細なプロパティを構成します。EDI 書式でドキュメントのグループ制御番号を指定し、サーバーがドキュメントを再送信するために使用する回数と間隔を設定して、メッセージ ポートまたは同報リストのトランスポート コンポーネント プロパティとエンベロープ プロパティを上書きすることができます。

BizTalk メッセージ マネージャを使用して、受信確認チャネルを作成することもできます。受信確認チャネルは特別な種類のチャネルで、BizTalk メッセージ サービスで受信したドキュメントの送信元に受信確認を返すのに使用されます。受信確認を要求する受信ドキュメントを処理するためのチャネルを作成する場合は、受信確認を処理するサーバーが使う受信確認チャネルを指定できます。このため、受信確認を要求するドキュメントを処理するために、メッセージ ポートとチャネルを作成する前に、メッセージ ポートと関連付けた受信確認チャネルを作成してください。受信確認の処理の詳細については、「受信確認について」を参照してください。

注意

  • 受信確認チャネルを作成する場合、受信ドキュメント定義と送信ドキュメント定義は既定で "BizTalk 既定受信" になり、どちらもマップを使用して変換することはできません。送信の受信確認に別の書式を使用するには、WebDAV リポジトリ内の既定受信仕様を参照する送信ドキュメント定義を作成し、選択します。送信の受信確認のために必要な書式の仕様を参照する送信ドキュメント定義と、受信確認の書式を変換するマップも作成する必要があります。

BizTalk Server 2002 は、ドキュメントを受信すると、そのドキュメントの処理方法をサーバーに指示する適切なチャネルを検出します。次に、サーバーはそのチャネルと関連付けられているメッセージ ポートまたは同報リストを検出します。メッセージ ポートは、指定された送信先にドキュメントをトランスポートするために必要な一連の手順をサーバーに指示します。チャネルが同報リストと関連付けられている場合は、サーバーは同報リストの各メッセージ ポートのプロパティを使用して、指定された送信先にドキュメントをトランスポートします。

ここには次のトピックが含まれます。

  • チャネルの要素

  • 有効なチャネルとメッセージ ポートの組み合わせ


チャネルの要素

チャネルは次の要素から構成されます。

送信元組織または送信元アプリケーション

チャネルを作成する場合は、ドキュメントの送信元としてアプリケーションまたは組織のいずれかを指定します。送信元アプリケーションは、常に既定の組織の業務用アプリケーションを表します。これには会計アプリケーション、注文入力システム、または基幹業務アプリケーションなどがあります。ドキュメントの送信元として、XLANG スケジュールを指定することもできます。BizTalk オーケストレーション デザイナを使用して XLANG スケジュールを作成することができます。送信元組織は、常に外部の取引先を表します。

チャネルは、メッセージ ポートまたは同報リストのどちらかで使用するために作成するものです。チャネルの送信元から受信するドキュメントの送信先は、そのチャネルが作成されたメッセージ ポートまたは同報リストのメッセージ ポートで指定します。

受信ドキュメント定義と送信ドキュメント定義

チャネルのドキュメント定義は、BizTalk Server 2002 によって処理される受信ドキュメントと送信ドキュメントを表し、そのドキュメントを定義する仕様へのポインタになります。仕様は、ドキュメントの構造、種類、およびバージョンを定義します。詳細については、「ドキュメント定義について」を参照してください。

BizTalk Server 2002 は、ドキュメントを受信したときに、そのドキュメントを処理するために適切なチャネルを検出します。サーバーは受信ドキュメント定義の仕様を使って、受信ドキュメントを中間 XML 形式に変換します。サーバーは、必要があれば、受信ドキュメントの書式または構造を、送信ドキュメントの書式または構造にマップします。次に、サーバーは送信ドキュメントの仕様を使って、送信ドキュメントを送信先アプリケーションまたは送信先組織が認識し、使用することができる書式または構造に変換します。

データ書式のマッピング

受信ドキュメントの書式または構造は、送信ドキュメントに要求される書式または構造とは異なる場合があります。この場合は、受信ドキュメントの書式を送信ドキュメントの書式に変換するために、マップを使用することができます。

たとえば、カンマ区切りフラット ファイル書式で請求書を生成する会計アプリケーションがあり、取引先が X12 書式で請求書を受信する必要がある場合は、チャネルのマップを使用して、書式を変換することができます。

マップは、同じ書式を使用しているドキュメントの内容と構造を変換することもできます。詳細については、「BizTalk マッパーの使用」を参照してください。

追跡プロパティとフィルタ プロパティ

チャネルの受信ドキュメント定義のために、追跡データベースのログに記録する仕様フィールドを指定することができます。チャネルで指定する仕様フィールドは、このチャネルを使用して処理される各ドキュメント インスタンス用の追跡データベースのログに記録されます。指定したフィールドは、受信ドキュメント定義で指定するグローバル追跡項目の代わりにログに記録されます。送信ドキュメント定義で指定したグローバル追跡項目は無視されます。詳細については、「ドキュメント データ フィールドの追跡」を参照してください。

チャネル フィルタ式は、BizTalk Server 2002 がドキュメントを受信したときに呼び出すチャネルを決定するためのもう 1 つの方法です。チャネル フィルタ式の場合、ドキュメント インスタンス内の指定された 1 つ以上のフィールドの値に基づいて、チャネルが決定されます。

サーバーがドキュメントを処理する場合、指定された各フィールドの値は、チャネル フィルタ式の値で評価されます。式が真であると、チャネルが呼び出されます。式が偽であると、チャネルは呼び出されません。たとえば、1000 を超える発注書の総数を確認するためにチャネル フィルタ式を作成し、ドキュメントの PO Total フィールドが 1500 の場合、そのチャネルは呼び出されます。

ドキュメントのログ プロパティ

BizTalk Server 2002 は、非 XML 受信ドキュメントを処理するために、元のネイティブ形式から中間 Unicode XML 形式に変換します。BizTalk Server 2002 は、送信ドキュメントを中間 Unicode XML 形式から指定された送信先で要求される書式に変換します。各受信ドキュメントと送信ドキュメントのデータをいずれかの書式または両方の書式で格納することを選択できます。

関連項目

チャネルの作成と管理

チャネルについて

有効なチャネルとメッセージ ポートの組み合わせ


有効なチャネルとメッセージ ポートの組み合わせ

Microsoft BizTalk Server 2002 で有効に使用できる特定のチャネル (送信元) とメッセージ ポート (送信先) の組み合わせだけを作成することができます。

次の有効なビジネス シナリオは、データを正しくルーティングするために、正しい送信先でメッセージ ポートを構成し、正しい送信元でチャネルを構成する方法を示しています。

シナリオ 1 : 取引先から内部アプリケーションへ

このシナリオでは、既定の組織のアプリケーションを送信先としてメッセージ ポートを作成します。次に、取引先組織を送信元ととして、このメッセージ ポートのチャネルを作成します。

シナリオ 2 : 内部アプリケーションから取引先へ

このシナリオでは、取引先組織を送信先としてメッセージ ポートを作成します。次に、既定の組織のアプリケーションを送信元として、このメッセージ ポートのチャネルを作成します。

シナリオ 3 : 内部アプリケーションから内部アプリケーションへ

このシナリオでは、既定の組織のアプリケーションを送信先としてメッセージ ポートを作成します。次に、既定の組織の別のアプリケーションを送信元として、このメッセージ ポートのチャネルを作成します。

シナリオ 4 : 内部アプリケーションから同報リストへ

このシナリオでは、組織またはアプリケーションへの既存のメッセージ ポートのグループを含む同報リストを作成します。次に、既定の組織のアプリケーションを送信元として同報リストのチャネルを作成します。

シナリオ 5 : 内部アプリケーションからオープンな送信先へ

このシナリオでは、オープンなメッセージ ポートとして指定するメッセージ ポートを作成します。次に、既定の組織のアプリケーションを送信元として、このメッセージ ポートのチャネルを作成します。

シナリオ 6 : オープンな送信元から内部アプリケーションへ

このシナリオでは、既定の組織のアプリケーションを送信先としてメッセージ ポートを作成します。次に、オープン チャネルとして指定するこのメッセージ ポートのチャネルを作成します。

注

  • オープン チャネルとして指定するチャネルは、オープンなメッセージ ポートとして指定したメッセージ ポート用に作成することはできません。

シナリオ 7 : 取引先から中間送信先を経由して取引先へ

このシナリオでは、中間送信先として自社の BizTalk Server を経由して、ある取引先が別の取引先にドキュメントを送信します。一方の取引先組織を送信先としてメッセージ ポートを作成します。次に、別の取引先を送信元として、このメッセージ ポート用のチャネルを作成します。

関連項目

チャネルの要素

チャネルについて


メッセージ ポートについて

メッセージ ポートとは、指定したトランスポート サービスを使用して、BizTalk メッセージ サービスを構成し、指定した送信先にドキュメントをトランスポートするために使用できる一連のプロパティです。メッセージ ポートがトランスポートするドキュメントは、関連付けられたチャネルで指定した送信元から送信されます。多数の送信元から同じ送信先にドキュメントを送信するために、単一のメッセージ ポートに対して複数のチャネルを作成することができます。

メッセージ ポートは、指定された送信先組織、XLANG スケジュール、または送信先アプリケーションにドキュメントを送信するように構成することができます。

組織にメッセージ ポートを構成するときには、送信先として特定の取引先を指定するか、オープンな送信先を宣言することができます。これはオープンなメッセージ ポートといいます。オープンなメッセージ ポートは、取引先組織だけにドキュメントをトランスポートするために使用することができます。オープンなメッセージ ポートの送信先組織情報は、そのドキュメント内に指定するか、そのドキュメントを BizTalk Server 2002 に送信するときにパラメータで指定する必要があります。ドキュメントの送信の詳細については、「Submitting」を参照してください。オープンなメッセージ ポートの詳細については、「Openness」を参照してください。

オープンなメッセージ ポートに対して指定されたアドレスが SMTP アドレスの場合は、サーバーには既定の組織の From アドレスが必要です。このアドレスを取得するには、サーバーは "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の、既定の組織の特別な組織識別子に指定された値を使用します。この組織識別子を構成する方法の詳細については、「既定の組織の構成」を参照してください。

アプリケーションへのメッセージ ポートを構成するときには、送信先として XLANG スケジュールまたは既定の組織のアプリケーションのいずれかを指定できます。既定の組織の詳細については、「組織について」を参照してください。

XLANG スケジュールへのメッセージ ポートは、指定された XLANG スケジュールの新しいインスタンスをアクティブにしてから、そのスケジュールの指定されたメッセージ ポートにドキュメントを配信するように構成できます。この場合、指定されたスケジュールには、BizTalk Messaging Service にバインドされたメッセージ ポートが含まれている必要があります。スケジュールを指定する場合は、メッセージ ポートの名前も指定します。XLANG スケジュールの実行インスタンスにドキュメントを配信するようにメッセージ ポートを構成することもできます。この場合、ドキュメントには、そのドキュメントを配信し、配信先スケジュールによって監視されるキュー名を含む必要があります。BizTalk メッセージ サービスと BizTalk オーケストレーション サービスの統合の詳細については、「BizTalk サービスの統合」を参照してください。

さらに、メッセージ ポートのプロパティを使用して、ドキュメントを送信する特定のアドレス、ドキュメントをその場所に配信するためのトランスポートの種類、およびトランスポートの前にドキュメントをエンベロープに格納してセキュリティで保護する方法を指定します。

BizTalk Server 2002 は、ドキュメントを受信したときに、そのドキュメントを処理するために適切なチャネルを検出します。チャネルは、そのドキュメントを処理した後に、関連付けられたメッセージ ポートまたは同報リストをサーバーに示します。これらは、ドキュメントをエンベロープに格納してセキュリティで保護し、指定された送信先にトランスポートするために必要な一連の手順をサーバーに指示します。

ここには次のトピックが含まれます。

  • メッセージ ポートの要素

  • オープンなメッセージ ポート


メッセージ ポートの要素

メッセージ ポートは次の要素から構成されます。

送信先

メッセージ ポートの送信先は、取引先組織、XLANG スケジュール、または既定の組織のアプリケーションにすることができます。

組織へのメッセージ ポートは、送信先組織を明示的に指定するか、オープンなメッセージ ポートとして宣言することができます。オープンなメッセージ ポートでは、送信先組織はメッセージ ポートがドキュメントを処理するときに決定されます。送信先組織の情報はドキュメント内に指定するか、そのドキュメントを送信するときにパラメータで指定する必要があります。詳細については、「Submitting」を参照してください。

XLANG スケジュールへのメッセージ ポートは、2 つの方法で構成できます。第 1 に、XLANG スケジュールへのパスを指定して、XLANG の新しいインスタンスをアクティブにするようにメッセージ ポートを構成することができます。メッセージ ポートは、ドキュメントを処理するときに、このスケジュールをアクティブにしてから、メッセージ ポート プロパティで指定したスケジュール内のメッセージ ポートにドキュメントを配信します。または、アクティブな XLANG スケジュールにドキュメントを配信するようにメッセージ ポートを構成することもできます。この方法は、取引先にメッセージを送信し、取引先が専用に構成された ASP ページにメッセージを HTTP トランスポートを使って返信するときにだけ使用します。詳細については、「BizTalk サービスの統合」を参照してください。BizTalk オーケストレーション デザイナを使用して XLANG スケジュールを作成することができます。詳細については、「BizTalk オーケストレーションの設計」を参照してください。

メッセージ ポートは、既定の組織の送信先アプリケーションにドキュメントをトランスポートすることもできます。メッセージ ポートの送信先としてアプリケーションを指定する前に、既定の組織にそのアプリケーションを追加する必要があります。詳細については、「アプリケーションの追加」を参照してください。

トランスポート プロパティ

メッセージ ポートで指定するトランスポート プロパティは、ドキュメントを送信先組織または送信先アプリケーションに転送するために使用するトランスポート サービスと、ドキュメントを送信する特定のアドレスを決定します。

メッセージ ポートで設定したトランスポート プロパティは、そのメッセージ ポートと関連付けられたすべてのチャネルに適用されます。BizTalk Server 2002 がドキュメントを処理するためにチャネルを呼び出した後に、サーバーはそのチャネルと関連付けられたメッセージ ポートのプロパティを参照します。サーバーはメッセージ ポートで指定されたトランスポートの種類を使用して、メッセージ ポートで指定されたアドレスにドキュメントを送信します。

ドキュメントをトランスポートできる特定の時間の範囲を指定するサービス時間帯を指定することもできます。サービス時間帯の時間は、サーバー上の時間を表しており、世界標準時 (UTC) 形式で示されます。

エンベロープ情報

エンベロープとは、トランスポートするドキュメントにプレフィックスを付けたり、カプセル化するために使用するヘッダー (場合によってはフッター) です。エンベロープのヘッダーには、そのエンベロープに格納される 1 つ以上のドキュメントに関する情報と、そのドキュメントをルーティングする方法に関する情報が含まれます。その内容は、送信元の組織識別子、送信先の組織識別子、および格納される 1 つ以上のドキュメントの種類に関する情報です。

BizTalk Server 2002 は、複数のドキュメントとドキュメントのグループを含むインターチェンジを受信し、処理することができます。エンベロープを使用しているドキュメントをトランスポートする場合に、BizTalk Server は各ドキュメントを個別のインターチェンジに格納します。

エンベロープは省略できます。ただし、エンベロープを使用することを選択した場合、メッセージ ポートで指定するエンベロープの書式は、格納される 1 つ以上のドキュメントの書式と一致している必要があります。ドキュメントの書式は、関連付けられたチャネルの送信ドキュメント定義で参照される仕様によって決定されます。たとえば、メッセージ ポートに X12 書式のエンベロープを選択する場合は、X12 仕様を示すチャネルの送信ドキュメント定義を選択する必要があります。反対に、チャネルの送信ドキュメント定義を選択する場合は、そのチャネルと関連付けられたメッセージ ポートには、対応する書式のエンベロープが必要です。たとえば、X12 書式の仕様を持つ送信ドキュメント定義を選択する場合は、メッセージ ポートで X12 エンベロープを指定してください。

セキュリティ プロパティ

メッセージ ポートで指定するセキュリティ プロパティは、そのメッセージ ポートと関連付けられたすべてのチャネルに適用されます。たとえば、メッセージ ポートで S/MIME (Secure Multipurpose Internet Mail Extensions) 暗号を指定する場合、そのメッセージ ポートと関連付けられたチャネルによって処理されるすべてのドキュメントは、指定した暗号を使用して暗号化されます。

異なる暗号を使用してセキュリティで保護する必要があるドキュメント、または暗号化する必要がないドキュメントがある場合は、別のメッセージ ポートを作成して、これらのドキュメントに適切なセキュリティ プロパティを指定する必要があります。

BizTalk Server 2002 は、MIME (Multipurpose Internet Mail Extensions) エンコードをサポートします。

MIME メッセージ書式規格には、メッセージの書式設定方法が規定されています。クライアント プログラムでは、この規格にしたがって、複雑なメッセージ本文をデコードし表示することができるようになり、メッセージ本文に、リッチ テキスト、複数の文字セット、および画像、音声、スプレッドシートなどのバイナリ添付ドキュメントを含めることができます。MIME は uuencode よりも優れた柔軟なテクノロジであり、メッセージ内のコンテンツに一般的で柔軟なメカニズムを提供します。MIME 書式では、次のことを実行できます。

  • 各本体部分に対して、代替コンテンツのエンコード メカニズムを指定します。

  • 複数のコンテンツ部分のグループをメッセージ内に関連付けます。

  • 本体部分とメッセージ ヘッダー フィールドに US-ASCII 文字セット以外の文字セットを使用します。

  • コンテンツ部分 (たとえば、インラインまたは添付ドキュメント) の処理方法を指定します。

BizTalk Server 2002 は、S/MIME (Secure Multipurpose Internet Mail Extensions) 証明書に基づく公開キー暗号化をサポートしています。

暗号化は取引先に送信するビジネス データに適用することができます。データをセキュリティで保護するために暗号化証明書を使用することによって、意図された受信者だけが情報にアクセスできるようにすることができます。

ビジネス データを暗号化するには、送信元組織には、送信先組織の暗号化証明書の公開キーのコピーが必要です。送信元組織はこの公開キー証明書を使用してビジネス データを暗号化してから、その暗号化データを送信先組織に転送します。送信先組織は、その暗号化証明書の秘密キーを使用して、そのビジネス データを解読することができます。

オープンなメッセージ ポートでは、送信先組織が不明なため、暗号化セキュリティ プロパティは無効になっています。

BizTalk Server 2002 は S/MIME (Secure Multipurpose Internet Mail Extensions) 証明書に基づく公開キー デジタル署名をサポートしています。証明書の詳細については、「証明書について」を参照してください。

デジタル署名は、データの送信元の信頼性とデータが変更されていないことを確認し、データの送信元によるメッセージの否認を防止するために使用することができます。

署名証明書は、データを認証するデジタル署名を作成するために使用します。データの署名によってデータは変更されませんが、データとバンドルされるか、別に送信されるデジタル署名文字列が生成されます。

ドキュメントにデジタル署名を行うには、データを処理してメッセージ ダイジェストを作成します。メッセージ ダイジェストは、メッセージを元に作成される短い文字列です。次に、送信元組織の秘密キーを使用して、メッセージ ダイジェストを暗号化し、デジタル署名を生成します。このデータは、デジタル署名と共に受信者に送信されます。

デジタル署名を確認するには、受信者には送信者の署名証明書からの公開キーのコピーが必要です。受信者側では、送信されたデジタル署名からダイジェストを解読し、メッセージ ダイジェストを個別に計算します。2 つのダイジェストの結果を比較し、両者が同じ場合はその情報は改ざんされていません。

注

  • MIME エンコードのデータを SMTP を使用して送信した場合には、システムの生成したファイル名が出力メッセージの本文に記載され、データが添付ファイルとして表示されます。

  • 証明書の詳細については、「証明書の概要」を参照してください。

関連項目

メッセージ ポートの作成および管理

オープンなメッセージ ポート

メッセージ ポートについて


オープンなメッセージ ポート

オープンなメッセージ ポートとは、特定の送信先組織を明示的に宣言していない組織へのメッセージ ポートです。オープンなメッセージ ポートでは、その送信先をアプリケーションにすることはできません。

オープンなメッセージ ポートでは、送信先情報とトランスポート情報は、そのドキュメント内に指定するか、そのドキュメントを Microsoft BizTalk Server 2002 に送信するときにパラメータで指定する必要があります。送信パラメータを使用する場合は、ドキュメントに含まれる送信先情報とトランスポート情報が上書きされます。ドキュメントの送信の詳細については、「Submitting」を参照してください。

オープンなメッセージ ポートのチャネルを作成し、送信先の情報がドキュメントで提供される場合、そのチャネルの受信ドキュメント定義は適切に構成された仕様を参照する必要があります。オープンなメッセージ ポートのドキュメントを処理するためのドキュメント仕様を構成する方法については、「ディクショナリ プロパティの設定」を参照してください。

オープンなメッセージ ポートでは、送信先組織が不明なため、暗号化セキュリティ プロパティは無効になっています。暗号化プロパティを設定するには、特定の既知の送信先組織からの証明書を指定する必要があります。暗号化証明書は、特定の送信先組織にトランスポートするドキュメントを暗号化するために使用します。

オープンなメッセージ ポートを使用すると、送信先ごとにメッセージ ポートを作成せずに、現在または将来のさまざまな取引先組織に 1 つ以上の標準化されたドキュメントを送信することができます。すべてのドキュメントは、そのメッセージ ポートで設定された同じエンベロープ、セキュリティ、およびトランスポート プロパティを共有します。

オープンなメッセージ ポートは、次の点で同報リストとは異なります。

  • オープンなメッセージ ポートでは、チャネルからの各ドキュメントは 1 つの送信先だけに配信されます。同報リストでは、チャネルからの各ドキュメントは複数の送信先に配信することができます。

  • オープンなメッセージ ポートでは、異なる取引先組織に情報を送信するためにメッセージ ポートのプロパティを変更する必要はありません。同報リストでは、異なる取引先組織に対して情報を送信するために、メッセージ ポートを追加する必要があります。

重要

  • メッセージ ポートをオープンなメッセージ ポートとして宣言する場合は、X12 仕様または EDIFACT 仕様の送信ドキュメント定義を持つメッセージ ポートにチャネルを作成しないでください。X12 または EDIFACT のエンベロープを構築するには、送信元の組織識別子と送信先の組織識別子がサーバーに必要です。オープンなメッセージ ポートでは、送信先の組織識別子が指定されません。また、オープンなメッセージ ポートのドキュメントはドキュメント内に送信先アドレスが必要ですが、X12 および EDIFACT のドキュメントにはこの情報は含まれません。

関連項目

メッセージ ポートの作成および管理

メッセージ ポートの要素

メッセージ ポートについて


組織について

BizTalk メッセージ マネージャを使用して作成する組織は、ドキュメントを交換する取引先を表します。既定の組織という特殊な組織は、自分の会社を表します。

既定の組織

BizTalk メッセージ マネージャは、自動的に既定の組織を作成します。既定の組織を構成するときに、自分の会社として識別しやすいように、その名前を変更することができます。既定の組織は 1 つだけ存在し、削除することはできません。

メッセージ ポートまたはチャネルで、ドキュメントの送信元または送信先として既定の組織を指定することはできません。既定の組織のアプリケーションだけは、自分の会社内のドキュメントの送信元または送信先として指定することができます。たとえば、自分の会社が送信するドキュメントの送信先として取引先組織を指定するメッセージ ポートを作成するとします。次に、そのメッセージ ポート用のチャネルを作成する場合に、送信元として既定の組織を指定する代わりに、そのドキュメントが生成された自分の会社にある特定の内部アプリケーションを指定します。また、チャネルでドキュメントの送信元として既定の組織の 1 つのアプリケーションを指定し、メッセージ ポートで送信先として別のアプリケーションを指定することもできます。

既定の組織のアプリケーション

既定の組織にアプリケーションを追加すると、Microsoft BizTalk Server 2002 と自分の会社にある実際の内部アプリケーション間でドキュメントの流れを識別し、追跡することができます。ただし、アプリケーションを作成して、BizTalk メッセージ マネージャで送信元または送信先として指定するだけでは、実際の内部アプリケーションとの間でドキュメントの流れを制御したり、有効にすることはできません。内部アプリケーションを BizTalk Server 2002 と統合し、そのアプリケーションとの間でドキュメントの流れを指示するには、さらにサーバーを構成する必要があります。

送信元アプリケーションから BizTalk サーバーへドキュメントを送信するには、いくつかの方法があります。ドキュメントをサーバーへ送信するためのアプリケーションを統合するために必要な構成は、完全に BizTalk メッセージ マネージャの外で行わなければなりません。詳細については、「Submitting」を参照してください。

BizTalk Server から内部アプリケーションにドキュメントを配信するには、BizTalk メッセージ マネージャの内部と外部の両方で構成が必要になることがあります。メッセージ ポートで指定するトランスポートの種類とアドレスによって、ドキュメントを配信する特定の場所を決定することができます。次に、送信先アプリケーションの場所で受信されたドキュメントを取得するように、アプリケーションまたは別のコンポーネントを構成する必要があります。または、メッセージ ポートのトランスポート プロパティで、アプリケーションにドキュメントを直接に配信することができるアプリケーション統合コンポーネントを指定することができます。詳細については、「メッセージ ポートについて」を参照してください。

取引先組織

BizTalk メッセージ マネージャで作成するすべてのほかの組織は、外部の取引先または取引先の組織単位を表します。任意の数の組織を作成することができます。チャネルでドキュメントの送信元として、またはメッセージ ポートでドキュメントの送信先として取引先組織を指定することができます。

1 つの取引先をチャネルでドキュメントの送信元として指定し、別の取引先をメッセージ ポートでドキュメントの送信先として指定することもできます。この場合、自分の会社は 2 つの取引先間でサード パーティの中間送信先としての役割を果たします。

アプリケーションの場合と同様に、組織を作成して、BizTalk メッセージ マネージャで送信元または送信先として指定するだけでは、組織間でのドキュメントの流れは有効になりません。取引先組織と BizTalk Server 2002 との間でドキュメントの流れを制御し、指示するには、さらにサーバーを構成する必要があります。

送信元組織である外部の取引相手が内部の BizTalk サーバーへドキュメントを送信するには、いくつかの方法があります。このために必要な構成は、サーバーにドキュメントをトランスポートするためのアプリケーションを統合する方法と似ており、この構成もすべて BizTalk メッセージ マネージャの外部で実行されます。詳細については、「Submitting」を参照してください。

BizTalk Server から送信先組織として外部の取引先にドキュメントを配信するには、BizTalk メッセージ マネージャの内部と外部の両方で構成が必要になることがあります。メッセージ ポートで指定するトランスポートの種類とアドレスによって、ドキュメントを配信する特定の場所を決定することができます。次に、この場所にアクセスできる送信先組織は、その場所で受信されたドキュメントを処理するように、自分の会社の BizTalk Server、内部アプリケーションの 1 つ、または別のコンポーネントを構成することができます。メッセージ ポートの構成の詳細については、「メッセージ ポートについて」を参照してください。

ここには次のトピックが含まれます。

  • 組織識別子


組織識別子

Microsoft BizTalk Server 2002 とほかの取引先は、組織識別子を使用して、組織を一意に識別します。組織は複数の組織識別子を持つことができますが、各識別子はその組織に一意なものにする必要があります。たとえば、電話番号、URL、またはD-U-N-S (Data Universal Numbering System) 番号は、それぞれ組織を一意に識別することができます。ただし、2 つの組織が組織識別子として同じ電話番号を使用することはできません。

組織識別子は、名前、修飾子、および値の 3 つの別個の要素から構成されます。たとえば、ある会社は自社を一意に識別するために電話番号を使用することがあります。この例では、識別子の名前は "電話番号"、その識別子を電話番号として識別する修飾子は番号 12、実際の電話番号の値は (801-555-1079) になります。各組織の識別子の名前は、その識別子の種類を示すために名前の代わりに使用される一意な修飾子を持ちます。たとえば、電話番号識別子の標準修飾子は 12 です。BizTalk Server 2002 は、ドキュメントを処理するときに、組織を識別するために修飾子と値だけを使用します。

各組織には少なくとも 1 つの識別子が必要です。組織を作成するときに、BizTalk メッセージ マネージャは "組織" という名前で識別子を作成します。この識別子の修飾子は OrganizationName で、その値は組織に付けた名前になります。この識別子は既定の識別子としても設定されます。つまり、ほかの識別子が指定されていない場合には、この識別子が使用されます。追加の識別子を作成して、任意の識別子を既定の識別子として指定することができます。OrganizationName の識別子、または指定した既定の識別子を削除することはできません。既定の識別子は、メッセージ ポートまたはチャネルで異なる識別子を選択して上書きしない限り、組織を識別するために使用されます。

BizTalk Server 2002 はドキュメントを処理し、トランスポートするときに、エンベロープ ヘッダーに送信先組織と送信元組織の組織識別子を挿入します。BizTalk Server 2002 は、ドキュメントを受信したときに、送信元組織と送信先組織の識別子のデータを検索します。次に、サーバーはその識別子とドキュメント定義名を使用して、そのドキュメントを処理するために使用するチャネルを決定します。

EDI 書式のインターチェンジには、組織識別子に対する制限があります。X12 エンベロープで組織識別子を使用する場合は、"既定の組織" という名前の組織識別子、3 文字以上の修飾子を持つ識別子、または 16 文字以上の値を持つ識別子は使用しないでください。EDIFACT エンベロープで組織識別子を使用する場合は、"既定の組織" という名前の組織識別子、5 文字以上の修飾子を持つ識別子、または 36 文字以上の値を持つ識別子は使用しないでください。

注

  • サーバーで EDIFACT 形式の受信ドキュメントを処理する場合に、空の修飾子と空でない値が検出されたときは、空の修飾子がダッシュ (-) に変換されます。空の修飾子を持つ EDIFACT 形式の受信ドキュメント、または空の修飾子を持つ送信エンベロープを処理する場合は、1 個のダッシュ (-) を修飾子にしたカスタム組織識別子を作成する必要があります。EDIFACT 送信ドキュメントの場合は、このダッシュが空の修飾子に変換されます。

  • サーバーで EDIFACT 以外の形式の受信ドキュメントを処理する場合に、空の修飾子と空でない値が検出されたときは、空の修飾子が OrganizationName に変換されます。

関連項目

組織の作成と管理

組織について


ドキュメント定義について

ドキュメント定義は、Microsoft BizTalk Server 2002 によって処理される特定の種類のドキュメントを表します。ドキュメント定義は、チャネルの受信ドキュメントまたは送信ドキュメントの種類を表し、ドキュメント仕様へのポインタになります。ドキュメント仕様は、ドキュメントの構造、種類、およびバージョンを定義します。任意の数のドキュメント定義で同じドキュメント仕様を使ったり、同じドキュメント定義を任意の数のチャネルで使用することができます。

チャネルの受信ドキュメントと送信ドキュメントの書式と構造が同じ場合は、両方に対して同じ仕様を使うことができます。同じではない場合は、受信ドキュメントの書式または構造を送信ドキュメントの書式または構造に変換するためにサーバーが使用するマップを指定する必要があります。

BizTalk Server 2002 は、ドキュメントを受信したときに、受信ドキュメント定義と一致する適切なチャネルを 1 つ以上識別します。各チャネルの受信ドキュメント定義は、仕様を示します。サーバーはその仕様を使って、非 XML 受信ドキュメントを元の書式から中間 XML 形式に変換し、そのドキュメントの構造を検証します。そのチャネルの送信ドキュメント定義も、仕様を示します。サーバーは、その送信ドキュメント仕様を使って、送信ドキュメントのデータ構造を検証します。必要があれば、サーバーはその仕様を使って、送信ドキュメントを XML 形式から、送信先組織または送信先アプリケーションが認識し、使用することができる書式に変換することもできます。送信先は、チャネルと関連付けられたメッセージ ポートで指定します。

ドキュメント定義のドキュメント仕様は省略できますが、ほとんどの場合は選択する必要があります。仕様を選択しない場合は、処理するデータが以下の制約を受けます。

  • データは、受信側で XML に変換されないか、または送信側で XML から変換されません。

  • データに誤りがないことを確認するための検証が行われません。

  • チャネル内でマップを使用してデータの構成または書式を変換することはできません。

  • グローバル追跡項目または選択条件を指定することができません。

Unicode XML 形式ではないデータのパススルー送信でドキュメント定義を使用する場合は、ドキュメント仕様は必要ありません。たとえば、データをまったく変換せずに、BizTalk Server 2002 を経由して送信先にバイナリ データを送信する場合があります。この場合、パススルー送信で使用するチャネルの受信ドキュメント定義または送信ドキュメント定義のいずれに対しても、ドキュメント仕様を選択しないでください。

ここには次のトピックが含まれます。

  • ドキュメント データ フィールドの追跡

  • 選択条件について

関連項目

ドキュメント定義の作成および管理

BizTalk エディタの使用

マッピング仕様

チャネルについて


ドキュメント データ フィールドの追跡

ドキュメント定義では追跡データベースのログに記録する仕様のフィールドを指定することができます。ドキュメント定義で指定するフィールドは、受信ドキュメント定義としてそのドキュメント定義を使用するチャネルによって処理されるすべてのドキュメント インスタンスで追跡されます。これらのフィールドはすべてのチャネルで追跡されるため、グローバル追跡項目と呼ばれます。

チャネルの受信ドキュメント定義を選択するときに、追跡するチャネルの仕様フィールドを指定することができます。チャネルで指定した仕様フィールドは、特定のチャネルによって処理されるドキュメントで、グローバル追跡項目の代わりに追跡されます。

ドキュメント定義またはチャネルで追跡のために指定したフィールドは、そのチャネルの受信ドキュメント定義専用の追跡データベースのログに記録されます。チャネルの送信ドキュメント定義で追跡のために指定されたフィールドは追跡されません。

処理されているドキュメントの追跡データで、操作に関する情報を分析することができます。たとえば、取引先に送信するすべての請求書について、請求書の合計フィールドを追跡することができます。次に、特定の期間にすべての取引先に送信された請求書の総額を決定したり、個々の取引先に対する請求書の総額を決定することができます。

関連項目

ドキュメント定義の作成および管理

BizTalk ドキュメント トラッキングの使用


選択条件について

選択条件とは、Microsoft BizTalk Server 2002 が EDI ドキュメントを処理するためだけに使用する、名前と値の一意な組です。受信 ANSI X12 ドキュメントまたは受信 EDIFACT ドキュメントでは、個々の EDI ドキュメントで利用できるドキュメント定義名がないため、サーバーは選択条件を使用してドキュメント定義を一意に識別し、選択します。

送信 X12 ドキュメントまたは送信 EDIFACT ドキュメントでは、エンベロープにファンクショナル グループ ヘッダー情報を作成するために選択条件を使用します。

ここには次のトピックが含まれます。

  • 受信ドキュメントでの選択条件の使用

  • 送信ドキュメントでの選択条件の使用


受信ドキュメントでの選択条件の使用

受信ドキュメントを処理するために、BizTalk Server 2002 は受信ドキュメント定義の名前を要求します。サーバーは、通常受信ドキュメントのフィールドまたはドキュメントと共に送信されるパラメータのいずれかから受信ドキュメント定義の名前を取得します。詳細については、「Submitting」を参照してください。

X12 と EDIFACT の受信インターチェンジでは、ドキュメントはファンクショナル グループ ヘッダーまたはインターチェンジ ヘッダーに格納されることがあります。BizTalk Server 2002 は、これらのグループとインターチェンジに格納されているドキュメントを個々に処理します。各ドキュメントのドキュメント関連情報は、ファンクショナル グループ ヘッダーまたはインターチェンジ ヘッダーに格納されているため、サーバーは個々のドキュメントからドキュメント定義名を取得することはできません。また、インターチェンジには異なる種類のドキュメントの複数のグループが含まれることがあるため、ドキュメント定義を識別するために、サーバーへの送信パラメータとして単一のドキュメント定義名を提供することはできません。

このような場合、BizTalk Server 2002 はファンクショナル グループ ヘッダー (X12 インターチェンジの GS ヘッダーと EDIFACT インターチェンジの UNG ヘッダー) から関連データを抽出することができます。ファンクショナル グループのない EDIFACT インターチェンジでは、インターチェンジ ヘッダーからドキュメント関連データを抽出することができます。このデータの値をドキュメント定義で指定される選択条件の値と一致させることによって、サーバーは適切なドキュメント定義を一意に識別することができます。

BizTalk Server 2002 で選択基準の値を受信インターチェンジの対応するヘッダー要素 (エレメント) と一致させるためには、次の表に示されるとおりに選択条件を入力する必要があります。

X12 ヘッダー要素 (エレメント)

名前 | 要件 | GS 要素 (エレメント)
functional_identifier | 必須 | GS01
application_sender_code | 必須 | GS02
application_receiver_code | 必須 | GS03
standards_version | 必須 | GS08

EDIFACT ヘッダー要素 (エレメント)

名前 | 要件 | UNH 要素 (エレメント) | UNG 要素 (エレメント)
functional_identifier | 必須 | S009、0065 | 0038
application_sender_code | 省略可 | 未使用 | S006、0040
application_receiver_code | 省略可 | 未使用 | S007、0044
standards_version_type | 必須 | S009、0052 | S008、0052
standards_version_value | 必須 | S009、0054 | S008、0054

関連項目

ドキュメント定義の作成および管理

選択条件について

送信ドキュメントでの選択条件の使用


送信ドキュメントでの選択条件の使用

送信 X12 ドキュメントまたは送信 EDIFACT ドキュメントを処理するために、BizTalk Server 2002 は適切な書式の有効なエンベロープに各ドキュメントを配置します。エンベロープを作成するために、サーバーは選択条件の値データをグループ ヘッダーとメッセージ ヘッダーの対応するフィールドに挿入します。ヘッダーを構築するために、サーバーはチャネルの送信ドキュメント定義に含まれる選択条件の値を使用します。

たとえば、選択条件の 1 つとして functional_identifier/ORDERS という名前と値の組を持つドキュメント定義を作成するとします。次に、これをチャネルの送信ドキュメント定義として使用した場合は、functional_identifier という名前の選択条件に対応するグループ ヘッダー フィールドの値が、エンベロープ ヘッダーで ORDERS に設定されます。

BizTalk Server 2002 で対応するヘッダー要素 (エレメント) に選択条件の値を挿入するには、次の表に示されるとおりに選択条件を入力する必要があります。

X12 ヘッダー要素 (エレメント)

名前 | 要件 | GS 要素 (エレメント)
functional_identifier | 必須 | GS01
application_sender_code | 必須 | GS02
application_receiver_code | 必須 | GS03
standards_version | 必須 | GS08

EDIFACT ヘッダー要素 (エレメント)

名前 | 要件 | UNH 要素 (エレメント) | UNG 要素 (エレメント)
functional_identifier | 必須 | S009、0065 | 0038
application_sender_code | 省略可 | 未使用 | S006、0040
application_receiver_code | 省略可 | 未使用 | S007、0044
standards_version_type | 必須 | S009、0052 | S008、0052
standards_version_value | 必須 | S009、0054 | S008、0054

関連項目

ドキュメント定義の作成および管理

選択条件について

受信ドキュメントでの選択条件の使用


エンベロープについて

エンベロープはトランスポートのために電子ビジネス データをカプセル化します。エンベロープは、通常ヘッダー情報とフッター情報、またはヘッダー情報だけから構成されます。指定するエンベロープ プロパティは、受信インターチェンジを開いたり、送信インターチェンジを作成するために必要な情報を Microsoft BizTalk Server 2002 に提供します。エンベロープを作成する場合は、エンベロープ書式を指定します。特定の種類の書式では、エンベロープ仕様を選択することもできます。

BizTalk Server 2002 によってサポートされているエンベロープ書式は、カスタム XML、ANSI X12、EDIFACT、(可変長 (区切り文字) および固定長) フラット ファイル、カスタム、および Reliable 書式があります。Reliable 書式では、BizTalk フレームワークに準拠するエンベロープが処理されます。BizTalk フレームワーク 2.0 の詳細については、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。カスタム エンベロープ書式を指定する場合は、受信エンベロープ処理用のカスタム パーサー コンポーネントと、送信エンベロープ処理用のカスタム シリアライザ コンポーネントを作成し、登録する必要があります。詳細については、「Parsers」および「Serializers」を参照してください。

カスタム XML 書式とフラット ファイル書式

BizTalk Server 2002 でカスタム XML 形式またはフラット ファイル書式の受信インターチェンジを処理できるようにするには、対応する書式でエンベロープを作成する必要があります。BizTalk Server でカスタム書式の受信インターチェンジを処理できるようにするには、カスタム パーサー コンポーネントを作成し、登録します。BizTalk Server は、BizTalk メッセージ マネージャで作成したエンベロープを使用しなくても、ANSI X12 書式、UN/EDIFACT 書式、または Reliable 書式で受信インターチェンジを処理することができます。

任意の書式で送信ドキュメントを処理するには、エンベロープを作成して、メッセージ ポートでそのエンベロープを選択し、必要なエンベロープ書式とヘッダー情報でインターチェンジを作成する必要があります。BizTalk Server は、各送信インターチェンジにドキュメントを 1 つだけ配置します。

X12 書式と EDIFACT 書式

メッセージ ポートで X12 書式または EDIFACT 書式のエンベロープを選択した場合は、区切り記号とインターチェンジ制御番号も指定する必要があります。これらの EDI プロパティは、そのメッセージ ポートで使用するために選択されたエンベロープだけに適用されます。カスタム書式のエンベロープを選択する場合は、区切り記号とインターチェンジ制御番号は省略することができ、カスタム パーサーまたはカスタム シリアライザ コンポーネントの要件に依存します。X12、EDIFACT、またはカスタム エンベロープを使用するメッセージ ポート用にチャネルを作成する場合は、そのチャネルとメッセージ ポートの組み合わせによって処理されるドキュメントだけに適用するファンクショナル グループ制御番号を指定することができます。

メッセージ ポートで選択するエンベロープの書式は、そのエンベロープに含まれる送信ドキュメントの書式と一致する必要があります。送信ドキュメントの書式は、チャネルの送信ドキュメント定義で参照される仕様によって決定されます。たとえば、メッセージ ポートに対して X12 書式のエンベロープを選択した場合は、そのメッセージ ポート用にチャネルを作成するときに、X12 書式を持つ仕様をポイントする送信ドキュメント定義を選択する必要があります。

メッセージ ポートを作成するときにエンベロープを指定しない場合は、データはヘッダーのない XML 形式で送信されます。

DBCS 文字の処理

各国語対応に関する問題

EDIFACT のUNOX 構文識別子は、マルチ バイト文字に対応するためのコード拡張手法です。ただし、一部の国では、UNOX 構文が作成される前に独自の標準が既に定義されていました。たとえば韓国では、KEDIFACT という名称の標準によって、UNO* ではなく KECA を使用してデータをマーク付けしています (UNO* の構文は ISO 9735 EDIFACT シンタックス ルールで規定されています)。BizTalk Server によって受信された EDIFACT データは、UNOA となるような変更されたヘッダーを持ちますが、2 バイト文字セット (DBCS) はそのまま残されます。UNOA は、大文字の ASCII 文字のみで構成され、DBCS 文字を正しく変換しません。

この問題を解決するため、EDIFACT パーサーとシリアライザがアップデートされました。ヘッダーが UNOA 文字であると、EDIFACT パーサーとシリアライザは、既定のコードページ以外にデータを変換するコードページを定義するためのレジストリ キーを受け取ります。BizTalk Server で定義される値のセットには、EDIFACTUNOACodepage というレジストリ値が追加されています。このレジストリ値の既定値は 0 で、0 に設定されていると、前述の BizTalk Server の動作が適用されます。レジストリ値がその他の値に設定されている場合は、その値が、結果として得られた KEDIFACT データの変換に使用されるコードページの値となります。

このコードページの変更は処理全体に適用されます。その BiｚTalk Server を通過するすべての EDIFACT データは、EDIFACTUNOACodepage で示されたコードページに従ってデータを処理します。

重要

  • UNOX または UNOY 構文識別子が使用されている EDIFACT ドキュメントは、BizTalk Server 2002 ではサポートされません。

注

  • ドキュメントの送信後で、そのドキュメントが BizTalk Server の作業キューから削除されていないときに致命的な障害が発生した場合には、制御番号がスキップすることがあります。すべてのスレッドでシリアライズが発生するのを避けるために、BizTalk Server データベースから制御番号を取得し、COM＋ トランザクション外で、なおかつローカルの専用の SQL トランザクション内において、１ ずつ増加させます。したがって、制御番号が使用されるのは 1 回限りですが、1000 の制御番号を取得したスレッドがこの番号を取得した後にエラーとなるようにすることがあり得ます。このとき、トランスポートがトランザクション処理されると、送信はロール バックされます。トランザクションが行われない場合には、エラーが発生した時点でメッセージは送信されないかもしれません。いずれの場合も、そのドキュメントに関連付けられた制御番号はスキップされ、再利用されません。

  • BizTalk フレームワーク 2.0 に準拠するエンベロープを処理する場合、有効期間に関しては、BizTalk Server 2002 はエンドポイントと考えることができます。アプリケーションまたは取引先から、BizTalk フレームワーク 2.0 に準拠したドキュメントが BizTalk Server 2002 に送信された場合、次のフィールドが存在しているときは上書きされ、存在しないときは作成されます。
    • プロパティ サブセクション :

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • 受信情報サブセクション :

      <sendTo>

      <address>

      <sendReceiptBy>

ここには次のトピックが含まれます。

  • 受信処理のためのエンベロープの使用

  • 送信処理のためのエンベロープの使用

関連項目

エンベロープの作成および管理

メッセージ ポートについて


受信処理のためのエンベロープの使用

Microsoft BizTalk Server 2002 は、BizTalk メッセージ マネージャを使用して作成されるエンベロープを使用しなくても、X12 書式または EDIFACT 書式で、受信インターチェンジを処理することができます。

BizTalk Server 2002 でフラット ファイル書式の受信インターチェンジを処理するには、BizTalk メッセージ マネージャを使用して、エンベロープを作成する必要があります。そのエンベロープは、サーバーが使用できる仕様を示し、インターチェンジを解釈して開く必要があります。エンベロープの名前は、処理のためにインターチェンジが送信されるときにサーバーに提供する必要があります。詳細については、「Submitting」を参照してください。

BizTalk Server 2002 でカスタム XML 形式の受信インターチェンジを処理するには、BizTalk メッセージ マネージャを使用して、エンベロープを作成する必要があります。ただし、サーバーは送信時に提供されるエンベロープの名前がなくても、インターチェンジを解釈して開く必要があるカスタム XML エンベロープを検出することができます。送信時にエンベロープの名前をサーバーに提供することはできますが、これは必須ではありません。詳細については、「Submitting」を参照してください。

BizTalk Server 2002 でカスタム書式の受信インターチェンジを処理するには、インターチェンジを開くためにカスタム パーサーを作成する必要があります。詳細については、「Parsers」を参照してください。

受信インターチェンジを処理するために作成するエンベロープは、サーバーによって使用されるメッセージ ポートで選択する必要はありません。送信インターチェンジを処理するために使用するエンベロープだけをメッセージ ポートで選択する必要があります。

関連項目

エンベロープの作成および管理

エンベロープについて

送信処理のためのエンベロープの使用


送信処理のためのエンベロープの使用

メッセージ ポートは、Microsoft BizTalk Server 2002 から指定された送信先へのデータの送信フローを規定します。メッセージ ポートを作成するときに、そのメッセージ ポートによって処理されるドキュメントのエンベロープを選択することができます。エンベロープを選択する場合は、エンベロープ書式はそのエンベロープに含まれるドキュメントの書式と一致する必要があります。ドキュメントの書式は、チャネルの送信ドキュメント定義で参照される仕様によって決定されます。BizTalk メッセージ マネージャを使用してエンベロープを作成したら、任意の数のメッセージ ポートでそのエンベロープを使用することができます。

BizTalk Server 2002 が送信ドキュメントを処理する場合に、サーバーはメッセージ ポートで選択されたエンベロープのプロパティを使用して、ドキュメントをカプセル化したり、プレフィックスを付けることによって、インターチェンジを作成します。メッセージ ポートにエンベロープを指定しない場合は、データはヘッダーまたはフッターのない XML 形式で送信されます。カスタム XML 形式を指定し、エンベロープ仕様を選択しなかった場合、データは既定では Reliable 書式で送信されます。Reliable 書式では、BizTalk フレームワーク 2.0 に準拠するエンベロープが処理されます。BizTalk フレームワーク 2.0 の詳細については、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

BizTalk Server 2002 でカスタム書式の送信インターチェンジを処理するには、インターチェンジを作成するために、カスタム シリアライザを作成する必要があります。詳細については、「Serializers」を参照してください。

X12 書式または EDIFACT 書式でエンベロープを選択する場合は、インターチェンジ制御番号と区切り記号を指定する必要があります。インターチェンジ制御番号は、メッセージ ポートを使用して処理されるドキュメントを識別し、追跡するために使用します。インターチェンジ制御番号は、エンベロープとメッセージ ポートが使用されるたびに、1 つずつ増加します。区切り記号は、エンベロープとエンベロープに含まれるドキュメントのレコードとフィールドを分けるために使用します。カスタム書式のエンベロープでは、インターチェンジ制御番号と区切り記号は省略できます。

重要

  • メッセージ ポートのエンベロープ書式は、関連付けられたチャネルの送信ドキュメント定義によって参照される仕様のドキュメント型の書式と一致させる必要があります。たとえば、メッセージ ポートに X12 書式のエンベロープを選択する場合は、X12 仕様を示すチャネルの送信ドキュメント定義を選択する必要があります。

関連項目

エンベロープの作成および管理

エンベロープについて

受信処理のためのエンベロープの使用


受信確認について

取引先とドキュメントを交換する場合に、送信するドキュメントに対して受信確認を受け取ること、または取引先が自分の会社に送信するドキュメントに対して受信確認を生成することが、ビジネス プロセスで要求される場合があります。

BizTalk メッセージ サービスには、インターチェンジのために受信確認を処理する 2 つの方法があります。X12 パーサーまたは EDIFACT パーサー、受信確認を要求するカスタム パーサーを使用するインターチェンジでは、チャネル プロパティを使用するように BizTalk メッセージ マネージャを構成して、受信確認を処理することができます。XML パーサーを使用するインターチェンジでは、データの信頼できる配信を保証するために、受信確認を自動的に処理する、信頼できるメッセージを使用するオプションがあります。

ここには次のトピックが含まれます。

  • チャネルを使用した受信確認処理

  • 信頼できるメッセージを使用した受信確認処理


チャネルを使用した受信確認処理

ここでは、チャネル プロパティを使用して受信確認の処理を制御するように、BizTalk メッセージ サービスを構成する方法について説明します。送信先のシステムは、送信元のシステムに受信確認を生成 (送信) するように構成されています。送信元のシステムは送信先システムに受信確認を要求し、受信確認を受け取ります。その後、受け取った受信確認を元のインターチェンジと照合します。この構成は、X12 パーサー、EDIFACT パーサー、または受信確認を要求するカスタム パーサーを使用するインターチェンジを処理する場合にのみ適用されます。カスタム パーサーの作成の詳細については、「Parsers」を参照してください。XML パーサーを使用するインターチェンジを処理する場合は、「信頼できるメッセージを使用した受信確認処理」を参照してください。

カスタム パーサーを使用し、元のインターチェンジと受信確認を照合する場合は、カスタム関連付けコンポーネントを作成する必要があります。

送信元のシステムが受信確認を受信するには、送信先のシステムも、受信確認を送信するように構成する必要があります。受信確認を要求するように送信元システムのチャネルを構成するだけでは、受信確認を受信するために十分ではありません。

次の図は、受信確認を処理するためにチャネル プロパティを使用する送信元システムと送信先システムの構成を示しています。

ここには次のトピックが含まれます。

  • チャネル受信確認のための送信元システムの構成

  • チャネル受信確認のための送信先システムの構成


チャネル受信確認のための送信元システムの構成

ここでは、インターチェンジを取引先に送信し、チャネル プロパティを使用して受信確認を処理するように BizTalk メッセージ サービスを構成する方法について説明します。

インターチェンジを処理し、送信先システムにトランスポートするには、チャネルとメッセージ ポートを作成する必要があります。送信先システムが返す受信確認を処理するためにチャネルとメッセージ ポートを作成する必要はありません。ただし、返されたときに受信確認を検証するためにサーバーが使用するドキュメント定義を作成する必要があります。

送信先システムにインターチェンジを送信し、チャネル プロパティを使用して受信確認を処理するように BizTalk メッセージ サービスを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • インターチェンジのために元のドキュメントの受信ドキュメント定義と送信ドキュメント定義の仕様を作成します。受信したときに受信確認を検証するためにサーバーが使用する、ドキュメント定義の仕様も作成する必要があります。
  • 仕様の作成と検証

    注

    • チャネルの送信ドキュメント定義では、X12 などの送信先システムによって要求される書式を使う仕様を作成する必要があります。

    送信先システムの BizTalk メッセージ サービスがインターチェンジを処理する場合に、パーサーは受信確認を要求したとき、次の処理を行います。

    • インターチェンジからヘッダー要素 (エレメント) を抽出します。

    • 既定受信を生成します。

    • ヘッダー要素 (エレメント) を既定受信に挿入します。

    インターチェンジの処理に使われる、チャネルの送信ドキュメント定義用の仕様は、送信元システムにおける処理のために、次のフィールドを含んでいる必要があります。このフィールドは、受信確認を検証するためのドキュメント定義用の仕様にも含まれていなければなりません。送信元システムはこれらの要素 (エレメント) を使用して、受信確認と元のインターチェンジとを照合します。

    次に X12 ヘッダー要素 (エレメント) を示します。

    • functional_identifier

    • standards_version

    次に EDIFACT ヘッダー要素 (エレメント) を示します。

    • functional_identifier

    • standards_version_type

    • standards_version_value
BizTalk メッセージ マネージャ
  • 受信確認のチャネルとドキュメント定義を作成するために、受信ドキュメント定義と送信ドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • ドキュメント定義では、上で作成した仕様を選択する必要があります。詳細については、「ドキュメント仕様の選択」を参照してください。

    • 受信確認のドキュメント定義も作成する必要があります。
  • 送信元システムに受信確認をトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • はじめに受信確認を処理するために、メッセージ ポートおよび関連付けられた受信確認チャネルを作成する必要があります。元のインターチェンジを処理するためにチャネルを作成するときに、受信確認チャネルを指定する必要があります。
  • 送信先システムにインターチェンジをトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成
  • 取引先からの元のインターチェンジを処理するためにチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページまたは [送信元組織] ページで、[受信確認を要求する] チェック ボックスをオンにします。

    • [受信確認を要求する] の [受信間隔 (分)] ボックスで、元のインターチェンジを再送信する前に、受信確認を受信するために待機する時間を設定します。詳細については、「送信元アプリケーションのプロパティの設定」または「送信元組織のプロパティの設定」を参照してください。
BizTalk ドキュメント トラッキング
  • 元のインターチェンジは追跡データベースのログに記録され、受信状況フィールド (nACKStatus) は "待ち" に設定されます。追跡データベースの受信状態は、後に受信確認処理の状態を反映して変更されます。
  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について

送信元システムでの受信確認の送信

受信確認は、ほかのドキュメントと同じ方法で BizTalk メッセージ サービスに送信されます。受信確認が送信されると、X12 パーサーと EDIFACT パーサーは、ほかのドキュメントから受信確認を区別し、受信確認を元のインターチェンジと照合することをサーバーに指示します。

重要

  • 受信確認は、送信パラメータを使用せずに、BizTalk メッセージ サービスに送信する必要があります。


チャネル受信確認のための送信先システムの構成

ここでは、取引先から受信したインターチェンジを処理する方法、およびBizTalk メッセージ サービスを、チャネル プロパティを使用して、受信確認を生成するように構成する方法について説明します。まず、送信インターチェンジを処理し、それを送信先システムにトランスポートするためのチャネルとメッセージ ポートを作成する必要があります。送信先システムが返す受信確認を処理するためにチャネルまたはメッセージ ポートを作成する必要はありません。パーサーは、ドキュメント定義のみを使用して受信確認を処理します。

送信元システムからのインターチェンジを処理し、チャネル プロパティを使用して受信確認を送信するように BizTalk メッセージ サービスを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 受信確認チャネルを作成するために使用する受信ドキュメント定義と送信ドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • 受信確認チャネルの受信ドキュメント定義では、既定受信仕様を使います。この仕様は WebDAV リポジトリにあります。

    • 受信確認チャネルの送信ドキュメント定義では、ビジネス プロセスによって要求される書式を使う仕様を作成する必要があります。

    送信先システムの BizTalk メッセージ サービスが受信インターチェンジを処理する場合に、パーサーは受信確認を要求したとき、次の処理を行います。

    • グループのヘッダー要素 (エレメント) を抽出します。

    • 既定受信を生成します。

    • ヘッダー要素 (エレメント) を既定受信に挿入します。

    受信確認チャネル用の送信ドキュメント仕様には、これらのヘッダー要素 (エレメント) のためのフィールドが含まれている必要があります。送信元システムは、ヘッダー要素 (エレメント) を使用して受信確認と元のインターチェンジとを照合します。

    次に X12 ヘッダー要素 (エレメント) を示します。

    • functional_identifier

    • standards_version

    次に EDIFACT ヘッダー要素 (エレメント) を示します。

    • functional_identifier

    • standards_version_type

    • standards_version_value
  • チャネルを作成して、送信元システムからの元のインターチェンジを処理するために使用する受信ドキュメント定義と送信ドキュメント定義の仕様を作成します。
  • 仕様の作成と検証
BizTalk マッパー
  • 受信確認チャネルのマップを作成します。
  • 新しいマップの作成

    注

    • 受信確認チャネルを作成する場合は、マップを指定する必要があります。マップは、既定受信を送信ドキュメント用の適切なドキュメント型に変換するために使用されます。

    • 使用するビジネス プロセスで必要なドキュメント型と一致している場合は、BizTalk Server 2002 に用意されているマップを使用できます。これらのマップは WebDAV リポジトリから取得することができます。

      – または –

      既定受信仕様とビジネス プロセスで要求されるドキュメント型と一致する仕様を使って、独自のマップを作成することができます。
BizTalk メッセージ マネージャ
  • 受信確認チャネルと元のインターチェンジを処理するために使用するチャネルのドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • ドキュメント定義では、上で作成した仕様を選択する必要があります。詳細については、「ドキュメント仕様の選択」を参照してください。

    • 元のインターチェンジの処理に使われるチャネルのためのドキュメント定義も作成する必要があります。これらの仕様の構成は、ビジネス プロセスによって異なります。
  • 送信元システムに受信確認をトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • 元のインターチェンジのために使用されるメッセージ ポートと受信確認チャネルを作成する前に、受信確認を処理するためのメッセージ ポートと、それに関連付けられた受信確認チャネルを作成してください。元のインターチェンジを処理するためにチャネルを作成するときに、受信確認チャネルを指定する必要があります。
  • 受信確認を処理するために、アプリケーションからの受信確認チャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [全般情報] ページで、[受信確認チャネルとして使用する] チェック ボックスをオンにします。

    • チャネル ウィザードの [送信元アプリケーション] ページで、[名前] ボックスの一覧からアプリケーションを選択します。

      既定の組織用のアプリケーションを作成して、パーサーによって生成される受信確認を指定するために使うこともできます。

    • チャネル ウィザードの [受信ドキュメント] ページで、[参照] をクリックし、以前に作成した、既定受信仕様を使うドキュメント定義を参照します。

    • チャネル ウィザードの [送信ドキュメント] ページで、[参照] をクリックし、以前に作成した、ビジネス プロセスに必要なドキュメント型で仕様を使っているドキュメント定義を参照します。
  • 元のインターチェンジに含まれるドキュメントを意図される送信先にトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • このメッセージ ポートは、受信確認を処理するために特別な構成を要求しません。
  • 取引先からの元のインターチェンジを処理するためにチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元組織] ページで、[受信確認を生成する] チェック ボックスをオンにします。

    • [受信確認を生成する] で [参照] をクリックし、その受信確認を処理するために作成した受信確認チャネルを選択します。詳細については、「送信元組織のプロパティの設定」を参照してください。

    • チャネル ウィザードの [詳細構成] ページの [再試行のオプション] ボックスで、再試行の回数と間隔を設定することができます。詳細については、「詳細構成のプロパティの設定」を参照してください。
BizTalk ドキュメント トラッキング
  • 元のインターチェンジと受信確認は、追跡データベースのログに記録されます。
  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について


信頼できるメッセージを使用した受信確認処理

ここでは、BizTalk フレームワーク 2.0 に準拠するインターチェンジを作成する信頼できるメッセージ エンベロープを使用して、受信確認を送受信するように BizTalk メッセージ サービスを構成する方法について説明します。信頼できるメッセージを使用すると、データの信頼できる配信を確保するために、受信確認を自動的に処理することができます。BizTalk フレームワーク 2.0 の詳細については、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。X12、EDIFACT、またはカスタム パーサーを使用するインターチェンジを送受信する場合は、「チャネルを使用した受信確認処理」を参照してください。

BizTalk メッセージ マネージャを使用して、送信インターチェンジで Reliable エンベロープ書式を使用するようにメッセージ ポートを構成することができます。信頼できるメッセージ書式を使用するエンベロープのヘッダーには、常に返信先 URL アドレスを含む必要があります。返信先アドレスは、送信先システムによって使用され、受信確認をインターチェンジ送信者システムに送信します。

ここには次のトピックが含まれます。

  • 信頼できるメッセージ受信確認のための送信元システムの構成

  • 信頼できるメッセージ受信確認のための送信先システムの構成


信頼できるメッセージ受信確認のための送信元システムの構成

送信先システムにインターチェンジを送信し、信頼できるメッセージを使用して受信確認を処理するように BizTalk メッセージ サービスを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk Server 管理コンソール
  • [信頼できるメッセージの返信先 URL] ボックスに入力します。
  • サーバー グループの全般プロパティの構成

    注

    • BizTalk Server 管理コンソールで [Microsoft BizTalk Server 2002] を展開し、構成するサーバー グループをクリックします。

    • [操作] メニューの [プロパティ] をクリックします。

    • [BizTalk Server グループのプロパティ] ダイアログ ボックスの [信頼できるメッセージの返信先 URL] ボックスに、信頼できるメッセージ配信の受信確認を受信するためにこのサーバー グループが使用する URL を入力します。

      信頼できるメッセージ エンベロープを使用する送信インターチェンジを作成する場合は、サーバーはこの [信頼できるメッセージ返信先 URL] の内容をその送信インターチェンジのヘッダーに自動的に挿入します。また、サーバーは再送信キューに元のインターチェンジを配置します。サーバーはチャネルで指定された再試行のオプションを使用して、受信確認が受信されるまで元のインターチェンジを再送信する回数を決定します。
BizTalk メッセージ マネージャ
  • Reliable エンベロープ書式を使用するエンベロープを作成します。
  • エンベロープの作成

    注

    • [新しいエンベロープ] ダイアログ ボックスの [エンベロープ書式] ボックスの一覧で、[RELIABLE] をクリックします。
  • 送信先システムに元のインターチェンジをトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • 新しいメッセージ ポート ウィザードの [エンベロープ情報] ページで、先ほど作成したエンベロープを選択します。詳細については、「エンベロープ情報のプロパティの設定」を参照してください。
  • 元のインターチェンジを処理するためのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページまたは [送信元組織] ページでは、受信確認に関するチェック ボックスは何もオンにしないでください。

    • チャネル ウィザードの [詳細構成] ページの [再試行のオプション] ボックスで、再試行の回数と間隔を設定することができます。詳細については、「詳細構成のプロパティの設定」を参照してください。
BizTalk ドキュメント トラッキング
  • 送信元システムで、元の送信インターチェンジは追跡データベースのログに記録されます。ただし、返される受信確認は記録されません。
  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について


信頼できるメッセージ受信確認のための送信先システムの構成

送信先システムのためのBizTalk メッセージ サービスが、信頼できるメッセージ書式のインターチェンジを受信した場合、BizTalk メッセージ サービスは特別なドキュメント定義、チャネル、およびメッセージ ポートを使用して、受信確認の処理および送信元システムへのトランスポートを行います。これらの特別なシステム オブジェクトは、BizTalk メッセージ マネージャでは表示されず、予約済みシステム名を使用して類似のオブジェクトを作成することはできません。

サーバーは、受信確認の送信先アドレスとして、受信インターチェンジのヘッダーに含まれる返信先アドレスを使用します。

送信元システムで信頼できるメッセージ返信先 URL として SMTP アドレスを指定している場合を除いて、送信先の BizTalk メッセージ サービスを、信頼できるメッセージ エンベロープで送信されたインターチェンジに対して受信確認を返すようにさらに構成する必要はありません。SMTP アドレスに受信確認を送信するには、その受信確認のヘッダーに From アドレスを挿入するようにサーバーを構成する必要があります。

BizTalk Server 2002 をインストールしたときに、既定の組織用に特別な組織識別子が作成されます。この識別子の名前は "信頼できるメッセージ受信確認 SMTP 送信元アドレス" です。この識別子を削除することはできません。SMTP アドレスに信頼できるメッセージ受信確認を送信する場合は、サーバーはこの組織識別子に対して指定した値を From アドレスとしてインターチェンジ ヘッダーに挿入します。

BizTalk メッセージ サービスを、SMTP の信頼できるメッセージ返信先 URL を使用して送信元システムへ受信確認を送信するように構成するには、次の表に示した手順に従ってください。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk メッセージ マネージャ
  • 既定の組織の、信頼できるメッセージ受信確認 SMTP 送信元アドレスの組織識別子を構成します。
  • 既定の組織の構成

    注

    • 既定の組織を開きます。

    • [組織のプロパティ] ダイアログ ボックスの [識別子] タブをクリックします。

    • [組織の識別子] ボックスの一覧で、[信頼できるメッセージ受信確認 SMTP 送信元アドレス] をクリックし、[編集] をクリックします。

    • [組織のプロパティ] ダイアログ ボックスで、[値] ボックスに識別子の値を入力します。詳細については、「組織識別子の編集」を参照してください。

    重要

    • この識別子の名前と修飾子は変更せず、値のみ変更してください。
  • 送信先システムに元のインターチェンジをトランスポートするために、メッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • このメッセージ ポートに特別な構成は必要ありません。
  • 元のインターチェンジを処理するためのチャネルを作成します。
  • チャネルの作成

    注

    • このメッセージ ポートに特別な構成は必要ありません。
BizTalk ドキュメント トラッキング
  • 送信先システムでは、受信インターチェンジは追跡データベースのログに記録されますが、受信確認は記録されません。
  • ドキュメント インスタンス レコードの結果について

  • 受信確認の結果について


同報リストについて

同報リストとは、複数の異なる取引先組織または内部アプリケーションに同じドキュメントを送信することができるメッセージ ポートのグループです。

同報リストを使用すると、複数の取引先組織または既定の組織の内部アプリケーションに同時に同じデータを送信することができます。たとえば、Microsoft BizTalk Server 2002 に情報を 1 回だけ送信することによって、複数の取引先組織に同じカタログ、価格リスト、またはニュースレターを送信することができます。

はじめに、データを受信する取引先組織または内部アプリケーションごとにメッセージ ポートを作成してから、そのメッセージ ポートを同報リストに追加する必要があります。オープンなメッセージ ポートは、同報リストに追加できません。追加の取引先組織または内部アプリケーション用に新しいメッセージ ポートを作成してから、そのメッセージ ポートを既存の同報リストに追加することができます。詳細については、「メッセージ ポートの作成」を参照してください。

同報リストごとに少なくとも 1 つのチャネルを作成しなければ、その同報リストは動作しません。詳細については、「チャネルの作成」を参照してください。

BizTalk Server 2002 は、同報リストに関連するチャネルを呼び出す場合、データを処理するために同報リストと関連付けられたチャネルだけを呼び出します。同報リストの個々のメッセージ ポートと関連付けられたチャネルは呼び出されません。サーバーは、各メッセージ ポートのプロパティを連続的に使用して、メッセージ ポートで指定された送信先にデータをトランスポートします。

同報リストは、次の点でオープンなメッセージ ポートとは異なります。

  • 同報リストでは、チャネルからの各ドキュメントは複数の送信先に配信することができます。オープンなメッセージ ポートでは、チャネルからの各ドキュメントは 1 つの送信先だけに配信されます。

  • 同報リストでは、異なる取引先組織に対して情報を送信するために、メッセージ ポートを追加する必要があります。オープンなメッセージ ポートでは、異なる取引先組織に情報を送信するためにメッセージ ポートのプロパティを変更する必要はありません。

関連項目

同報リストの使用


BizTalk メッセージ マネージャでの作業の目的

ここでは、BizTalk メッセージ マネージャで行う作業の目的についてのクイック リファレンスを示します。次の表は、主要な作業とそれらの従属作業を示しており、各作業の目的とそれぞれ対応する操作へのリンクを記載しています。

作業 作業を実行する目的
チャネルの作成と管理
  • チャネルの作成
 BizTalk メッセージ サービスを通じて受信したドキュメントの処理。
  • チャネルのプロパティの設定
  • 受信ドキュメント定義で追跡する仕様フィールドの指定。

  • 処理中のドキュメント内の 1 つ以上のフィールドの値に基づいて、BizTalk Server 2002 がチャネルを呼び出すかどうかを決定するチャネル フィルタ式を作成する。

  • 受信確認、セキュリティ、プロパティ、ドキュメントのログ オプションの構成。

  • 電子データ交換 (EDI) 書式でドキュメントのグループ制御番号を指定し、サーバーがドキュメントを再送信するために使用する回数と間隔を設定して、メッセージ ポートまたは同報リストのトランスポート コンポーネント プロパティとエンベロープ プロパティを上書きすることができます。
メッセージ ポートの作成および管理
  • メッセージ ポートの作成
 BizTalk メッセージ サービスを通じて受信したドキュメントの、指定送信先へのトランスポート。
  • メッセージ ポートのプロパティの設定
  • ドキュメントを配信するアドレスの指定。

  • ドキュメントを送信先へ送信するためのトランスポートの種類の設定。

  • トランスポートの前にドキュメントにエンベロープを付け、セキュリティ保護する方法の指定。
組織の作成と管理
  • 既定の組織の構成
  • BizTalk メッセージ マネージャによって指定された既定の組織の名前の変更。

  • 既定組織識別子 (既定の組織を一意に識別するために使用するプロパティ) の値の変更。

  • BizTalk Server と業務で使用する内部アプリケーションとの間で交換されるドキュメントの流れを把握し、追跡するためのアプリケーション プロパティの設定。
  • 組織の作成
 自社と取引先との間のドキュメント交換。既定の組織はユーザーの企業を表すもので、BizTalk メッセージ マネージャによって自動的に作成されます。ほかのすべての組織は、外部の取引先または取引先の組織単位を表します。
  • 組織のプロパティの設定
  • 組織識別子 (組織を一意に識別するために使用するプロパティ) の設定。

  • 自社と取引相手との間で交換されるドキュメントの流れを把握し、追跡するためのアプリケーション プロパティの設定。
ドキュメント定義の作成および管理
  • ドキュメント定義の作成
 BizTalk Server によって処理されるドキュメントの種類の指定。
  • ドキュメント定義のプロパティの設定
  • ドキュメントの構造、種類、バージョンを定義するドキュメント仕様の作成。任意の数のドキュメント定義で同じドキュメント仕様を使ったり、同じドキュメント定義を任意の数のチャネルで使用することができます。

  • 追跡データベースによってドキュメントを追跡するためのグローバル追跡プロパティの設定。

  • 選択基準 (BizTalk Server が EDI ドキュメントを処理するために使用する、名前と値の一意な組み合わせ) の設定。
エンベロープの作成および管理
  • エンベロープの作成
 トランスポートのための電子ビジネス データのカプセル化。指定するエンベロープ プロパティは、受信インターチェンジを開いたり、送信インターチェンジを作成するために必要な情報を BizTalk Server に提供します。
  • エンベロープ仕様の選択
 エンベロープ書式への仕様の適用。
同報リストの使用
  • 同報リストの作成
 複数の取引相手、組織または内部アプリケーションへの同じドキュメントの送信。


BizTalk メッセージ マネージャ タスクでの作業方法

ここでは、BizTalk メッセージ マネージャを使用する方法を作業ごとに説明します。「BizTalk メッセージ マネージャについて」を参照のうえ、BizTalk メッセージ マネージャを使用して作成する各オブジェクト間の関係について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • チャネルの作成と管理

  • メッセージ ポートの作成および管理

  • 組織の作成と管理

  • ドキュメント定義の作成および管理

  • エンベロープの作成および管理

  • 同報リストの使用


チャネルの作成と管理

ここでは、チャネルを作成し、管理する方法を作業ごとに説明します。「チャネルについて」を参照し、チャネルについて十分に理解しておいてください。

ここには次のトピックが含まれます。

  • チャネルの作成

  • チャネルの検索

  • チャネルの編集

  • チャネルの削除

  • チャネルのプロパティの設定


チャネルの作成

チャネルを作成する前に、メッセージ ポートまたは同報リストを作成する必要があります。詳細については、「メッセージ ポートの作成」または「同報リストの作成」を参照してください。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [その他の項目を検索] の [メッセージ ポート] または [同報リスト] をクリックし、[検索] をクリックします。

  3. [メッセージ ポート名] で、チャネルを作成するメッセージ ポートをクリックします。

    – または –

    [同報リスト名] で、チャネルを作成する同報リストをクリックします。

  4. BizTalk メッセージ マネージャで、[ファイル] メニューの [新規作成] をポイントし、[チャネル] をポイントしてから、次のどちらかの手順を実行します。
    • 組織からチャネルを作成するには、[組織から] をクリックします。

    • アプリケーションからチャネルを作成するには、[アプリケーションから] をクリックします。

    新しいチャネル ウィザードが表示されます。

  5. [全般情報] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「チャネル情報の全般的なプロパティの設定」を参照してください。

  6. 次の手順のいずれかを行ってください。
    • 組織からチャネルを作成する場合は、[送信元組織] ページでプロパティを設定し、[次へ] をクリックします。詳細については、「送信元組織のプロパティの設定」を参照してください。

    • アプリケーションからチャネルを作成する場合は、[送信元アプリケーション] ページでプロパティを設定し、[次へ] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。
  7. [受信ドキュメント] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「受信ドキュメントのプロパティの設定」を参照してください。

  8. [送信ドキュメント] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「送信ドキュメントのプロパティの設定」を参照してください。

  9. [ドキュメント ログ] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「ドキュメント ログのプロパティの設定」を参照してください。

  10. [詳細構成] ページでプロパティを設定します。

    詳細については、「詳細構成のプロパティの設定」を参照してください。

  11. チャネルのすべてのプロパティを設定したら、[詳細構成] ページの [完了] をクリックして、新しいチャネル ウィザードを閉じます。

注

  • 予約済みのシステム名である [信頼できるメッセージ受信確認チャネル] を使用してチャネルに名前を付けることはできません。

  • この手順で作成できるのは、標準チャネルか受信確認チャネルのいずれかです。ここでの手順には、受信確認チャネルを作成する場合には使用できないチャネルのプロパティについての注意事項が示してあります。

  • データのパススルー送信に使用するメッセージ ポートとチャネルを作成する場合、使用できるのは、サービス時間帯、チャネルの再試行回数機能と再試行の間隔の機能、およびチャネルに関連付けられたメッセージ ポートのトランスポート機能だけです。デコードまたは暗号解読の検証、フィルタ、ドキュメント トラッキング、およびマッピングの各チャネルの機能は使用できません。

  • インターネット ファイアウォールによって保護されているローカル ネットワークの外側にあるマップを参照するチャネルを保存すると、ファイアウォールの構成のためにエラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

チャネルの削除

チャネルの編集

チャネルの検索

チャネルのプロパティの設定

チャネルについて


チャネルの検索

  1. BizTalk メッセージ マネージャで、[その他の項目を検索] の [チャネル] をクリックします。

  2. すべてのチャネルを検索するには、検索条件をすべて消去し、[検索] をクリックします。

  3. 次の操作を 1 つ以上行ってください。
    • 特定の名前のチャネルを検索するには、[チャネルの検索] でそのチャネルの名前を [チャネル名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 特定の種類の送信元からのチャネルを検索するには、[送信元] ボックスの一覧で送信元の種類をクリックし、[検索] をクリックします。

    • 特定のメッセージ ポートまたは同報リストに関連付けられたチャネルを検索するには、[メッセージ ポートまたは同報リストに関連] ボックスにメッセージ ポート名または同報リスト名を入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 特定のドキュメント定義を使用するチャネルを検索するには、[ドキュメント定義の使用] ボックスにドキュメント定義名を入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

注

  • [検索] をクリックする前に、複数の検索条件を設定することができます。

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 特定のメッセージ ポートまたは同報リストに関連付けられたチャネルを検索する場合、メッセージ ポートまたは同報リストを右クリックし、[チャネルの検索] をクリックしても検索できます。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件には、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

チャネルの削除

チャネルの編集

チャネルのプロパティの設定

チャネルについて


チャネルの編集

  1. BizTalk メッセージ マネージャの [チャネル名] ボックスの一覧で、編集するチャネルをクリックします。

    チャネルの検索については、「チャネルの検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    チャネルのプロパティ ウィザードが表示されます。

  3. [全般情報] ページで、適切なプロパティを編集します。

    詳細については、「チャネル情報の全般的なプロパティの設定」を参照してください。

    プロパティの編集を終了したら、[完了] をクリックしてチャネルのプロパティ ウィザードを閉じるか、[次へ] をクリックして別のチャネルのプロパティを編集します。

  4. 次の手順のいずれかを行ってください。
    • 組織からのチャネルを編集する場合は、[送信元組織] ページで適切なプロパティを編集します。詳細については、「送信元組織のプロパティの設定」を参照してください。

    • アプリケーションからのチャネルを編集する場合は、[送信元アプリケーション] ページで適切なプロパティを編集します。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。
  5. [受信ドキュメント] ページで、適切なプロパティを編集します。

    詳細については、「受信ドキュメントのプロパティの設定」を参照してください。

  6. [送信ドキュメント] ページで、適切なプロパティを編集します。

    詳細については、「送信ドキュメントのプロパティの設定」を参照してください。

  7. [ドキュメント ログ] ページで、適切なプロパティを編集します。

    詳細については、「ドキュメント ログのプロパティの設定」を参照してください。

  8. [詳細構成] ページで、適切なプロパティを編集します。

    詳細については、「詳細構成のプロパティの設定」を参照してください。

注

  • 予約済みのシステム名である [信頼できるメッセージ受信確認チャネル] を使用してチャネルに名前を付けることはできません。

  • ローカル ドメインの外側にあるマップを参照するチャネルを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

チャネルの作成

チャネルの削除

チャネルの検索

チャネルのプロパティの設定

チャネルについて


チャネルの削除

  1. BizTalk メッセージ マネージャの [チャネル名] ボックスの一覧で、削除するチャネルをクリックします。

    チャネルの検索については、「チャネルの検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • 受信確認チャネルは、その受信確認チャネルを参照しているすべてのチャネルを削除してからでなければ削除できません。

関連項目

チャネルの作成

チャネルの編集

チャネルの検索

チャネルのプロパティの設定

チャネルについて


チャネルのプロパティの設定

ここでは、チャネルのプロパティを構成する方法を作業ごとに説明します。ここには次のトピックが含まれます。

  • チャネル情報の全般的なプロパティの設定

  • 送信元組織のプロパティの設定

  • 送信元アプリケーションのプロパティの設定

  • 受信ドキュメントのプロパティの設定

  • 送信ドキュメントのプロパティの設定

  • ドキュメント ログのプロパティの設定

  • 詳細構成のプロパティの設定

  • 送信元組織の選択

  • 受信確認チャネルの選択

  • 受信ドキュメント定義の選択

  • 受信ドキュメントの暗号解読を確認する証明書の選択

  • 受信ドキュメントの署名を確認する証明書の選択

  • 送信ドキュメント定義の選択

  • マップの選択

  • 送信の署名証明書の選択

  • メッセージ ポート既定値の変更

  • 同報リスト既定値の変更

  • 受信ドキュメントの追跡のプロパティの設定

  • チャネル フィルタのプロパティの設定


チャネル情報の全般的なプロパティの設定

  1. チャネル ウィザードの [全般情報] ページで、[名前] ボックスにチャネル名を入力します。

  2. [コメント] ボックスに、チャネルに関するコメントを入力します。

  3. 受信確認チャネルを作成する場合は、[受信確認チャネルとして使用する] チェック ボックスをオンにします。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

注

  • オープンなメッセージ ポートまたは同報リストの受信確認チャネルは作成できません。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

受信確認について


送信元組織のプロパティの設定

  1. チャネル ウィザードの [送信元組織] ページで、次のいずれかの手順を実行します。
    • オープン チャネルを作成するには、[オープンな送信元] をクリックし、[次へ] をクリックします。オープン チャネルは、ドキュメント内のデータ、またはドキュメントとともに送信されたパラメータによって送信元が指定されることを示します。

      ドキュメントの送信の詳細については、「Submitting」を参照してください。

    • 取引先の組織を送信元として指定するには、[組織] をクリックし、手順 2. へ進みます。
  2. [組織] の [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. 組織をクリックし、[OK] をクリックします。

    詳細については、「送信元組織の選択」を参照してください。

  4. 送信元組織の既定の組織識別子を上書きする場合は、[組織の識別子] ボックスの一覧で別の識別子をクリックします。

  5. メッセージ ポートに指定した送信先からの受信確認が必要な場合は、[受信確認を要求する] チェック ボックスをオンにして、[受信間隔 (分)] ボックスに値を入力するか、上矢印または下矢印をクリックして値を増減します。

    既定値は 120 分です。受信確認の詳細については、「受信確認について」を参照してください。

  6. 送信元への受信確認を生成する場合は、[受信確認を生成する] チェック ボックスをオンにして、[参照] をクリックし、受信確認チャネルを選択します。

    詳細については、「受信確認チャネルの選択」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

注

  • X12 エンベロープで使用する送信元組織の識別子を選択する場合、"既定の組織" という組織識別子、3 文字以上の修飾子を持つ識別子、または 16 文字以上の値を持つ識別子は選択しないでください。

  • EDIFACT エンベロープで使用する送信元組織の識別子を選択する場合、"既定の組織" という組織識別子、5 文字以上の修飾子を持つ識別子、または 36 文字以上の値を持つ識別子は選択しないでください。

  • 特定の組織からのチャネルを編集する場合、[オープンな送信元] オプションは使用できず、送信元組織は変更できません。オープン チャネルを編集する場合、[組織] オプションは使用できません。

  • 受信確認チャネルを編集または作成する場合、[受信確認を要求する] チェック ボックスおよび [受信確認を生成する] チェック ボックスは使用できません。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

受信確認について


送信元アプリケーションのプロパティの設定

  1. チャネル ウィザードの [送信元アプリケーション] ページで、次のいずれかの手順を実行します。
    • 送信元が XLANG スケジュールであることを指定するには、[XLANG スケジュール] をクリックし、[次へ] をクリックします。

      オープンなメッセージ ポートのためのチャネルを作成する場合は、この操作を行わないでください。BizTalk メッセージ サービスと BizTalk オーケストレーション サービスの統合の詳細については、「BizTalk サービスの統合」を参照してください。

    • 既定の組織のアプリケーションを送信元として指定するには、[アプリケーション] をクリックし、手順 2. へ進みます。
  2. [名前] ボックスの一覧でアプリケーションをクリックします。

  3. 既定の組織の既定の組織識別子を上書きする場合は、[組織の識別子] ボックスの一覧で別の識別子をクリックします。

  4. 送信先からの受信確認が必要な場合は、[受信確認を要求する] チェック ボックスをオンにして、[受信間隔 (分)] ボックスに値を入力するか、上矢印または下矢印をクリックして値を増減します。

    既定値は 120 分です。受信確認の詳細については、「受信確認について」を参照してください。

  5. 送信元への受信確認を生成する場合は、[受信確認を生成する] チェック ボックスをオンにして、[参照] をクリックし、受信確認チャネルを選択します。

    詳細については、「受信確認チャネルの選択」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

注

  • BizTalk オーケストレーション デザイナを使用して XLANG スケジュールを作成することができます。

  • 受信確認チャネル、または XLANG スケジュールが送信元として指定されているチャネルを作成および編集する場合、[受信確認を要求する] チェック ボックスおよび [受信確認を生成する] チェック ボックスは使用できません。

関連項目

チャネルの作成

チャネルの編集

BizTalk サービスの統合

チャネルのプロパティの設定

受信確認について


受信ドキュメントのプロパティの設定

  1. チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  2. ドキュメント定義をクリックし、[OK] をクリックします。

    詳細については、「受信ドキュメント定義の選択」を参照してください。

  3. 受信ドキュメントの暗号解読を確認する場合は、[受信ドキュメントの暗号解読証明書の確認] チェック ボックスをオンにして、[暗号解読確認の証明書] ボックスの右にある [参照] をクリックします。

    [暗号解読を確認する証明書の選択] ダイアログ ボックスが表示されます。

  4. 証明書を選択します。

    詳細については、「受信ドキュメントの暗号解読を確認する証明書の選択」を参照してください。

  5. 受信ドキュメントのデジタル署名を確認する場合は、[受信ドキュメントの署名証明書の確認] チェック ボックスをオンにして、[署名確認の証明書] ボックスの右にある [参照] をクリックします。

    [署名を確認する証明書の選択] ダイアログ ボックスが表示されます。

  6. 署名証明書を選択します。

    詳細については、「受信ドキュメントの署名を確認する証明書の選択」を参照してください。

  7. 受信ドキュメントのフィールドを追跡する場合は、[受信ドキュメントの追跡] チェック ボックスをオンにし、[追跡] をクリックします。

    [受信ドキュメントの追跡] ダイアログ ボックスが表示されます。

  8. 追跡のプロパティを設定します。

    詳細については、「受信ドキュメントの追跡のプロパティの設定」を参照してください。

  9. 受信ドキュメントのチャネル フィルタ式を作成する場合は、[受信ドキュメントのフィルタ] チェック ボックスをオンにし、[フィルタ] をクリックします。

    [チャネル フィルタ式] ダイアログ ボックスが表示されます。

  10. フィルタのプロパティを設定します。

    詳細については、「チャネル フィルタのプロパティの設定」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

注

  • 既定の "BizTalk 既定受信" を受信ドキュメント定義として使用する受信確認チャネルを作成する場合、[追跡] と [フィルタ] の各チェック ボックスは使用できません。

  • オープンなメッセージ ポートのチャネルを作成し、送信先の情報がドキュメントで提供される場合、そのチャネルの受信ドキュメント定義は適切に構成された仕様を参照する必要があります。オープンなメッセージ ポートのドキュメントを処理するためのドキュメント仕様を構成する方法については、「ディクショナリ プロパティの設定」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

ディクショナリ プロパティの設定

受信確認について


送信ドキュメントのプロパティの設定

  1. チャネル ウィザードの [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  2. ドキュメント定義をクリックし、[OK] をクリックします。

    詳細については、「送信ドキュメント定義の選択」を参照してください。

  3. マップを指定する場合は、[受信ドキュメントを送信ドキュメントにマップする] チェック ボックスをオンにして、[マップ参照] ボックスの右側にある [参照] をクリックします。

    [WebDAV リポジトリからのマップの選択] ダイアログ ボックスが表示されます。

  4. マップの仕様を選択します。

    詳細については、「マップの選択」を参照してください。

  5. 送信ドキュメントにデジタル署名を付ける場合は、[送信ドキュメントに署名] チェック ボックスをオンにして、[署名証明書] ボックスの右にある [参照] ボタンをクリックします。

    [セキュリティ情報] ページの [署名] が [S/MIME] に設定されているメッセージ ポートのためのチャネルを作成している場合、[送信ドキュメントに署名] チェック ボックスは自動的にオンになります。

    [署名証明書の選択] ダイアログ ボックスが表示されます。

  6. 署名証明書を選択します。

    詳細については、「送信の署名証明書の選択」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

重要

  • メッセージ ポートに指定するエンベロープの書式は、エンベロープが格納されるドキュメントの書式と一致する必要があります。ドキュメント形式は、関連付けられたチャネルの送信ドキュメント定義で参照される仕様によって決定されます。たとえば、メッセージ ポートに X12 書式のエンベロープを選択する場合は、X12 仕様を示すチャネルの送信ドキュメント定義を選択する必要があります。

  • オープンなメッセージ ポートであることを宣言する場合は、X12 または EDIFACT 仕様の送信ドキュメント定義を持つポートにチャネルを作成しないでください。X12 または EDIFACT のエンベロープを構築するには、送信元組織識別子と送信先組織識別子がサーバーに必要です。オープンなメッセージ ポートでは、送信先の組織識別子が指定されません。また、オープンなメッセージ ポートのドキュメントはドキュメント内に送信先アドレスが必要ですが、X12 および EDIFACT のドキュメントにはこの情報は含まれません。

  • WebDAV リポジトリのダイアログ ボックスを最初に開いたときは、BizTalk メッセージ マネージャがリモート サーバーのデータベースに接続されていても、ローカル サーバーの WebDAV リポジトリが選択されます。リモート サーバーの WebDAV リポジトリを参照すると、新しい WebDAV リポジトリを選択するまで、そのサーバーが既定に変更されます。すべての [WebDAV リポジトリ] ダイアログ ボックスの既定のサーバーは、接続が行われた最後のサーバーです。

注

  • マップは受信ドキュメントの書式を送信ドキュメントの書式に変換するのに使用します。受信ドキュメントの仕様参照が送信ドキュメントの仕様参照と一致する場合、マップは必要ありません。既定では、[受信ドキュメントを送信ドキュメントにマップする] チェック ボックスはオンになりません。マップは BizTalk マッパーで作成できます。マップの詳細については、「BizTalk マッパーの使用」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

受信確認について


ドキュメント ログのプロパティの設定

  1. チャネル ウィザードの [ドキュメント ログ] ページの [受信ドキュメントの記録] で、適切なチェック ボックスをオンにします。
    • [ネイティブ形式]: チャネルの受信ドキュメントを元の形式で保存します。これは既定の設定です。

    • [XML 形式]: チャネルの受信ドキュメントを XML 形式で保存します。
  2. [送信ドキュメントの記録] で適切なチェック ボックスをオンにします。
    • [ネイティブ形式]: チャネルの送信ドキュメントを元の形式で保存します。

    • [XML 形式]: チャネルの送信ドキュメントを XML 形式で保存します。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

注

  • ログ機能を使用するドキュメントにはサイズの制限があり、この制限を超えると BizTalk Server のパフォーマンスに大きく影響します。サイズの制限の詳細については、「インターチェンジとドキュメントのサイズ制限」を参照してください。

  • BizTalk Server では、非 XML 受信ドキュメントは元のネイティブ形式から処理用に XML 形式に変換され、送信ドキュメントは XML 形式から送信先で必要なネイティブ形式に変換されます。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定


詳細構成のプロパティの設定

  1. X12 または EDIFACT のエンベロープ書式を指定するメッセージ ポートのチャネルを作成している場合は、チャネル ウィザードの [詳細構成] ページで [グループ制御番号] ボックスにゼロ以外の値を入力します。

  2. [再試行のオプション] の [再試行の回数] ボックスに、受信確認が受信されなかった場合にサーバーがドキュメントを再送信する回数を入力し、[間隔 (分)] ボックスに、再試行の間隔を入力します。

    受信確認の詳細については、「受信確認について」を参照してください。

  3. メッセージ ポートまたは同報リストのトランスポートまたはエンベロープ コンポーネントの設定を上書きする場合は、[詳細設定] をクリックします。
    • メッセージ ポートのチャネルを作成または編集している場合は、[メッセージ ポート既定値の変更] ダイアログ ボックスが表示されます。詳細については、「メッセージ ポート既定値の変更」を参照してください。

    • 同報リストのチャネルを作成または編集している場合は、[同報リスト既定値の変更] ダイアログ ボックスが表示されます。詳細については、「同報リスト既定値の変更」を参照してください。

新しいチャネルを作成する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの作成」に進んでください。

既存のチャネルを編集する場合は、[次へ] をクリックします。次の手順を完了する方法については、「チャネルの編集」に進んでください。

  • 変更が完了したら、[完了] をクリックします。

関連項目

チャネルの作成

チャネルの編集

再送信キュー

チャネルのプロパティの設定

受信確認について


送信元組織の選択

  1. チャネル ウィザードの [送信元組織] ページで、[名前] ボックスの右側の [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  2. [利用可能な組織] ボックスの一覧で組織をクリックし、[OK] をクリックします。

送信元組織のプロパティの設定を続けるには、「送信元組織のプロパティの設定」に進んでください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

送信元組織のプロパティの設定


受信確認チャネルの選択

  1. チャネル ウィザードの [送信元アプリケーション] ページまたは [送信元組織] ページで、[受信確認を生成する] チェック ボックスをオンにし、[参照] をクリックします。

    [受信確認チャネルの選択] ダイアログ ボックスが表示されます。

  2. [利用可能な受信確認チャネル] ボックスの一覧で受信確認チャネルをクリックし、[OK] をクリックします。

送信元組織のプロパティの設定を続けるには、「送信元組織のプロパティの設定」に進んでください。

送信元アプリケーションのプロパティの設定を続けるには、「送信元アプリケーションのプロパティの設定」に進んでください。

注

  • [利用可能な受信確認チャネル] ボックスの一覧には、作成しているチャネルの送信元と同じ送信先を持つメッセージ ポートに関連付けられた受信確認チャネルだけが表示されます。受信確認チャネルが指定されているチャネルを BizTalk Server が呼び出す場合、サーバーは指定された受信確認チャネルを使用して、そのドキュメントの元の送信元に受信確認を返します。受信確認の詳細については、「受信確認について」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

送信元アプリケーションのプロパティの設定

送信元組織のプロパティの設定

受信確認について


受信ドキュメント定義の選択

  1. チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  2. [利用可能なドキュメント定義] ボックスの一覧でドキュメント定義をクリックし、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

注

  • 受信確認チャネルを作成する場合、受信ドキュメント定義と送信ドキュメント定義は既定で "BizTalk 既定受信" になり、どちらもマップを使用して変換することはできません。送信の受信確認に別の書式を使用するには、WebDAV リポジトリ内の既定受信仕様を参照する送信ドキュメント定義を作成し、選択します。送信の受信確認のために必要な書式の仕様を参照する送信ドキュメント定義と、受信確認の書式を変換するマップも作成する必要があります。受信確認の詳細については、「受信確認について」を参照してください。

関連項目

チャネルの作成

ドキュメント定義の作成

チャネルの編集

チャネルのプロパティの設定

受信ドキュメントのプロパティの設定

受信確認について


受信ドキュメントの暗号解読を確認する証明書の選択

  1. チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメントの暗号解読証明書の確認] チェック ボックスをオンにして、[暗号解読確認の証明書] ボックスの右にある [参照] をクリックします。

    [暗号解読を確認する証明書の選択] ダイアログ ボックスが表示されます。

  2. [証明書名] ボックスの一覧から証明書名をクリックし、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

注

  • 証明書は、すべてローカル コンピュータのストアに格納されます。BizTalk メッセージ マネージャを使用して S/MIME コンポーネントの証明書を構成するには、ユーザーが Windows 2000 Administrators グループのユーザー アカウントに属しており、かつ、BizTalk メッセージ サービスがローカル システム アカウントまたは Windows 2000 Administrators グループのユーザー アカウントとして実行中である必要があります。

  • 適切なチャネルを識別するのに必要なデータをサーバーが取得できるように、ドキュメントは BizTalk Server に受信された時点で暗号解読されます。暗号解読が正しく実行されたかどうかは、チャネルに指定する証明書によって確認されます。

  • 証明書には一意な名前を付ける必要があります。同じ名前の証明書がある場合、そのうち 1 つだけが選択されます。一度選択されると、同じ名前を持つそれ以外の証明書は、それ以降一覧に表示されません。

    証明書の詳細については、「証明書の概要」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

受信ドキュメントのプロパティの設定


受信ドキュメントの署名を確認する証明書の選択

  1. チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメントの署名証明書の確認] チェック ボックスをオンにして、[署名確認の証明書] ボックスの右にある [参照] をクリックします。

    [署名を確認する証明書の選択] ダイアログ ボックスが表示されます。

  2. [証明書名] ボックスの一覧から証明書名をクリックし、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

注

  • 証明書は、すべてローカル コンピュータのストアに格納されます。BizTalk メッセージ マネージャを使用して S/MIME コンポーネントの証明書を構成するには、ユーザーが Windows 2000 Administrators グループのユーザー アカウントに属しており、かつ、BizTalk メッセージ サービスがローカル システム アカウントまたは Windows 2000 Administrators グループのユーザー アカウントとして実行中である必要があります。

  • 証明書には一意な名前を付ける必要があります。同じ名前の証明書がある場合、そのうち 1 つだけが選択されます。一度選択されると、同じ名前を持つそれ以外の証明書は、それ以降一覧に表示されません。

    証明書の詳細については、「証明書の概要」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

受信ドキュメントのプロパティの設定


送信ドキュメント定義の選択

  1. チャネル ウィザードの [送信ドキュメント] ページで、[送信ドキュメント定義名] ボックスの右側の [参照] をクリックします。

    [ドキュメント定義の選択] ダイアログ ボックスが表示されます。

  2. [利用可能なドキュメント定義] ボックスの一覧でドキュメント定義をクリックし、[OK] をクリックします。

送信ドキュメントのプロパティの設定を続けるには、「送信ドキュメントのプロパティの設定」に進んでください。

注

  • 受信確認チャネルを作成する場合、受信ドキュメント定義と送信ドキュメント定義は既定で "BizTalk 既定受信" になり、どちらもマップを使用して変換することはできません。送信の受信確認に別の書式を使用するには、WebDAV リポジトリ内の既定受信仕様を参照する送信ドキュメント定義を作成し、選択します。送信の受信確認のために必要な書式の仕様を参照する送信ドキュメント定義と、受信確認の書式を変換するマップも作成する必要があります。受信確認の詳細については、「受信確認について」を参照してください。

関連項目

チャネルの作成

ドキュメント定義の作成

チャネルの編集

チャネルのプロパティの設定

送信ドキュメントのプロパティの設定

受信確認について


マップの選択

  1. チャネル ウィザードの [送信ドキュメント] ページで、[受信ドキュメントを送信ドキュメントにマップする] チェック ボックスをオンにし、[マップ参照] ボックスの右側の [参照] をクリックします。

    [WebDAV リポジトリからのマップの選択] ダイアログ ボックスが表示されます。

  2. サーバーを変更する場合は、[サーバー] ボックスで次のどちらかの操作を行います。
    • 一覧に表示されているサーバーをクリックします。

    • サーバーの名前を入力し、Enter キーを押します。
  3. 使用するマップが格納されているフォルダをダブルクリックし、マップをクリックして、[開く] をクリックします。

送信ドキュメントのプロパティの設定を続けるには、「送信ドキュメントのプロパティの設定」に進んでください。

重要

  • WebDAV リポジトリのダイアログ ボックスを最初に開いたときは、BizTalk メッセージ マネージャがリモート サーバーのデータベースに接続されていても、ローカル サーバーの WebDAV リポジトリが選択されます。リモート サーバーの WebDAV リポジトリを参照すると、新しい WebDAV リポジトリを選択するまで、そのサーバーが既定に変更されます。すべての [WebDAV リポジトリ] ダイアログ ボックスの既定のサーバーは、接続が行われた最後のサーバーです。

注

  • サーバーとして http://localhost を選択すると、BizTalk メッセージ マネージャはそれを自動的にローカル コンピュータ名に変換します。

  • ローカル ドメイン以外にあるマップを参照するチャネルを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

チャネルの作成

チャネルの編集

BizTalk マッパーの使用

チャネルのプロパティの設定

送信ドキュメントのプロパティの設定


送信の署名証明書の選択

  1. チャネル ウィザードの [送信ドキュメント] ページで、[送信ドキュメントに署名] チェック ボックスをオンにし、[署名証明書] ボックスの右側の [参照] をクリックします。

    [署名証明書の選択] ダイアログ ボックスが表示されます。

  2. [証明書名] ボックスの一覧から証明書名をクリックし、[OK] をクリックします。

送信ドキュメントのプロパティの設定を続けるには、「送信ドキュメントのプロパティの設定」に進んでください。

注

  • 証明書は、すべてローカル コンピュータのストアに格納されます。BizTalk メッセージ マネージャを使用して S/MIME コンポーネントの証明書を構成するには、ユーザーが Windows 2000 Administrators グループのユーザー アカウントに属しており、かつ、BizTalk メッセージ サービスがローカル システム アカウントまたは Windows 2000 Administrators グループのユーザー アカウントとして実行中である必要があります。

  • 証明書には一意な名前を付ける必要があります。同じ名前の証明書がある場合、そのうち 1 つだけが選択されます。一度選択されると、同じ名前を持つそれ以外の証明書は、それ以降一覧に表示されません。

    証明書の詳細については、「証明書の概要」を参照してください。

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

送信ドキュメントのプロパティの設定


メッセージ ポート既定値の変更

  1. チャネル ウィザードの [詳細構成] ページで [詳細設定] をクリックします。

    メッセージ ポートのチャネルを作成または編集している場合は、[メッセージ ポート既定値の変更] ダイアログ ボックスが表示されます。

  2. [プライマリ トランスポート] タブの [プロパティ] をクリックします。

    該当する BizTalk コンポーネントのプロパティのダイアログ ボックスが表示されます。

  3. 上書きするトランスポート コンポーネントのプロパティを変更し、[OK] をクリックします。

  4. メッセージ ポートにエンベロープがあり、そのエンベロープの設定を変更する場合は、[エンベロープ] タブをクリックし、[プロパティ] をクリックします。

    該当する BizTalk コンポーネントのプロパティのダイアログ ボックスが表示されます。

  5. 上書きするエンベロープ コンポーネントのプロパティを変更し、[OK] をクリックします。

詳細なプロパティの設定を続けるには、「詳細構成のプロパティの設定」に進んでください。

重要

  • メッセージ ポートのトランスポートとエンベロープのプロパティの変更は、高度な機能です。これらのダイアログ ボックスにあるトランスポート コンポーネントとエンベロープ コンポーネントのプロパティを十分に理解していない場合は、変更しないでください。

  • メッセージ ポートでカスタム書式のエンベロープを指定した場合は、詳細構成のプロパティを使用して、カスタム シリアライザ コンポーネントを構成する必要があります。

注

  • チャネルのメッセージ ポートのプロパティを変更する場合、変更はそのチャネルにだけ適用されます。

  • メッセージ ポートに設定されたトランスポート アドレスは変更できません。

  • HTTP トランスポート コンポーネントの既定の設定は、HTTP プロキシ サーバーを使用するようになっています。これは、企業のファイアウォールの外部にある Web サイトにデータをトランスポートするのに適した設定です。企業のファイアウォールの内部にある (つまり、イントラネット内の) Web サイトにデータをトランスポートするには、この手順で既定の設定を変更します。

  • HTTPS トランスポート コンポーネントの場合は、クライアント認証用に指定されている証明書だけを使用します。汎用として指定されている証明書は、この一覧には表示されません。

  • ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。メッセージ ポートで既定の設定になっているファイル トランスポートの種類を使用し、BizTalk Server がインストールされているサーバーでウィルス対策ソフトウェアを使用していて、正確に同じ名前の複数のファイルを同じファイル位置に同時に送信すると、BizTalk Server が応答しなくなることがあり、その場合再起動する必要があります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。この問題は、メッセージ ポートのファイル パス形式 (file://C:\dir\file%tracking_id%.xml) を使用して処理されるドキュメント インスタンスごとに一意なファイルを作成することで解決することもできます。詳細については、「トランスポート アドレスの指定」を参照してください。

  • ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。既定の設定のファイル トランスポートの種類を選択し、メッセージ ポートで Reliable エンベロープ書式のエンベロープを選択して、複数のファイルを同時に同じファイル位置に送信すると、予期しない解析結果を生じることがあります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。

  • メッセージ ポートに指定したエンベロープがカスタム書式で、カスタム シリアライザ コンポーネントを作成および登録してある場合は、この手順でカスタム シリアライザ コンポーネントのプロパティを構成できます。

  • EDIFACT エンベロープの既定の構文識別子は UNOA (大文字のラテン文字) です。データに別の構文が必要な場合は、この手順で異なる構文識別子を選択します。

  • EDIFACT リリース インジケータを使用する場合、データ内にリリース インジケータ文字を含めないでください。リリース インジケータ文字を含めると、データがフィールドに設定された文字物理サイズを超過することがあります。

関連項目

チャネルの作成

チャネルの編集

詳細構成のプロパティの設定

チャネルのプロパティの設定


同報リスト既定値の変更

  1. チャネル ウィザードの [詳細構成] ページで [詳細設定] をクリックします。

    同報リストのチャネルを作成または編集している場合は、[同報リスト既定値の変更] ダイアログ ボックスが表示されます。

  2. [メッセージ ポートの選択] ボックスの一覧で上書きするメッセージ ポートを選択し、[上書き] をクリックします。

    [メッセージ ポート既定値の変更] ダイアログ ボックスが表示されます。

  3. 選択したメッセージ ポートのトランスポート コンポーネントとエンベロープ コンポーネントのプロパティを変更します。

    詳細については、「メッセージ ポート既定値の変更」を参照してください。

  4. 上書きするメッセージ ポートを変更したら、[閉じる] をクリックします。

詳細なプロパティの設定を続けるには、「詳細構成のプロパティの設定」に進んでください。

関連項目

チャネルの作成

チャネルの編集

メッセージ ポート既定値の変更

詳細構成のプロパティの設定

チャネルのプロパティの設定


受信ドキュメントの追跡のプロパティの設定

[受信ドキュメントの追跡] ダイアログ ボックスには、受信ドキュメントの仕様フィールドと、ドキュメント定義で選択されているグローバル追跡項目の一覧が表示されます。

このダイアログ ボックスを使用して仕様フィールドを選択すると、このチャネルにおいてのみ、グローバル追跡項目がそれらの仕様フィールドによって上書きされます。チャネルで選択するフィールドは、処理されるドキュメント インスタンスごとに、グローバル追跡項目ではなく追跡データベースに記録されます。

ここでは、チャネルで受信ドキュメントの仕様フィールドを選択または削除する方法について説明します。

ここには次のトピックが含まれます。

  • チャネル内の仕様フィールドの選択

  • チャネルでの仕様フィールドの削除

関連項目

チャネルの作成

チャネルの編集

チャネルのプロパティの設定

グローバル追跡プロパティの設定

受信ドキュメントのプロパティの設定


チャネル内の仕様フィールドの選択

  1. チャネル ウィザードの [受信ドキュメント] ページで [受信ドキュメントの追跡] チェック ボックスをオンにし、[追跡] をクリックします。

    [受信ドキュメントの追跡] ダイアログ ボックスが表示されます。

  2. [仕様フィールド] ボックスの一覧にあるツリーで、項目をダブルクリックして展開します。

  3. [追跡するフィールド] ボックスの一覧で追加する仕様フィールドをクリックし、次の手順のいずれかを実行します。
    追加するフィールドのデータ型 | 実行する手順
    Integer | [整数] をクリックします。整数型のフィールドを 2 つ追加できます。
    実数 | [実数] をクリックします。実数型のフィールドを 2 つ追加できます。
    Date [日付] | [日付] をクリックします。日付型のフィールドを 2 つ追加できます。
    テキスト | [テキスト] をクリックします。テキスト型のフィールドを 2 つ追加できます。
    カスタム | [カスタム] をクリックします。カスタム データ型のフィールドをいくつでも追加できます。これらのフィールドは、フィールドごとにタグの付いた XML 連結文字列として格納されます。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

重要

  • このダイアログ ボックスを使用して仕様フィールドを選択すると、このチャネルにおいてのみ、グローバル追跡項目がそれらの仕様フィールドによって上書きされます。チャネルで選択するフィールドは、処理されるドキュメント インスタンスごとに、グローバル追跡項目ではなく追跡データベースに記録されます。

注

  • 整数、実数、日付のいずれかのデータ型として追跡する仕様フィールドを選択するには、仕様の中でそのデータ型がフィールドに割り当てられている必要があります。仕様フィールドへのデータ型の割り当ての詳細については、「宣言のプロパティの設定」を参照してください。

  • 仕様フィールドのデータ型が、仕様内で割り当てられているデータ型でない場合は、そのフィールドはテキスト型またはカスタム データ型としてのみ追跡できます。

  • 追跡する仕様フィールドが文字データ型である場合は、そのフィールドはカスタム データ型としてのみ追跡できます。

  • 特定のデータ型の仕様フィールドは 2 つだけ選択できます。カスタム データ型として選択できるフィールド数には、制限はありません。

関連項目

チャネルの作成

チャネルの編集

チャネルでの仕様フィールドの削除

チャネルのプロパティの設定

グローバル追跡プロパティの設定

受信ドキュメントの追跡のプロパティの設定

ドキュメント データ フィールドの追跡


チャネルでの仕様フィールドの削除

  1. チャネル ウィザードの [受信ドキュメント] ページで [受信ドキュメントの追跡] チェック ボックスをオンにし、[追跡] をクリックします。

    [受信ドキュメントの追跡] ダイアログ ボックスが表示されます。

  2. [追跡するフィールド] ボックスの一覧で、削除する仕様フィールドをクリックし、[削除] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

注

  • 追跡するフィールドの一覧からフィールドを削除しても、そのフィールドはこのチャネルの一覧から削除されるだけで、仕様からは削除されません。

関連項目

チャネルの作成

チャネルの編集

チャネル内の仕様フィールドの選択

チャネルのプロパティの設定

グローバル追跡プロパティの設定

受信ドキュメントの追跡のプロパティの設定

ドキュメント データ フィールドの追跡


チャネル フィルタのプロパティの設定

チャネル フィルタ式は XPath 式であり、ドキュメント内で指定されたフィールドの値に基づいてチャネルが呼び出されるかどうかを判定するのに使用できます。BizTalk Server がドキュメントを処理する場合、各ドキュメント内で指定されたフィールドの値がチャネル フィルタ式に対して評価されます。式が真であると、チャネルが呼び出されます。式が偽であると、チャネルは呼び出されません。

ここには次のトピックが含まれます。

  • チャネル フィルタ式の追加

  • チャネル フィルタ式の編集

  • チャネル フィルタ式の削除

関連項目

受信ドキュメントのプロパティの設定


チャネル フィルタ式の追加

  1. チャネル ウィザードの [受信ドキュメント] で [受信ドキュメントのフィルタ] チェック ボックスをオンにし、[フィルタ] をクリックします。

    [チャネル フィルタ式] ダイアログ ボックスが表示されます。

  2. [フィールドの選択] ボックスの一覧にあるツリーで、ノードをダブルクリックして展開します。

  3. フィルタ式の作成に使用する仕様フィールドをクリックし、[追加] をクリックします。

    [式のプロパティ] ダイアログ ボックスが表示されます。

  4. [演算子] ボックスの一覧で演算子をクリックします。
    演算子 記号
    等しい (既定) =
    等しくない !=
    より小さい <
    以下 <=
    より大きい >
    以上 >=

  5. [値] ボックスに式の値を入力し、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

重要

  • チャネル フィルタ式は有効な XPath 式でなければなりません。[追加] ボタンを使用すると、仕様フィールドを含む句を作成して、その句を式に挿入できますが、有効な XPath 式に必要な正しい構文は生成されません。XPath 式の詳細については、「チャネル フィルタ」を参照してください。また、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で XPath という語を検索対象にして検索してください。

注

  • 式は [式] ボックスの一覧に直接入力できます。

  • チャネル フィルタ式の仕様フィールドを選択するには、そのフィールドのデータ型は仕様で割り当てられているデータ型でなければなりません。フィールドへのデータ型の割り当ての詳細については、「宣言のプロパティの設定」を参照してください。

  • 式の作成に使用する仕様フィールドがブール型である場合、式の値に "true" または "false" のテキスト文字列を使用することはできません。代わりに、真の場合は "-1"、偽の場合は "0" の数値を使用します。

  • 式の作成に使用する仕様フィールドが日付型である場合、ハイフンも含めて YYYY-MM-DD の形式で値を入力します。

  • 日付/時刻型 (dateTime、dateTime.tz、time、time.tz) のフィルタを使用する場合には、XPath 式に手動で記述する必要があります。たとえば、self::node()[@ATTDATETIME = "2000-03-15T10:10:10"] と記述します。この式の ATTDATETIME は日付/時刻書式の型です。

関連項目

チャネルの作成

チャネル フィルタ式の編集

チャネルの編集

チャネル フィルタ式の削除

チャネル フィルタのプロパティの設定

チャネルのプロパティの設定


チャネル フィルタ式の編集

  1. チャネル ウィザードの [受信ドキュメント] で [受信ドキュメントのフィルタ] チェック ボックスをオンにし、[フィルタ] をクリックします。

    [チャネル フィルタ式] ダイアログ ボックスが表示されます。

  2. [式] ボックスの一覧で式を編集し、[OK] をクリックします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

重要

  • チャネル フィルタ式は有効な XPath 式でなければなりません。XPath 式の詳細については、「チャネル フィルタ」を参照してください。また、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で XPath という語を検索対象にして検索してください。

関連項目

チャネル フィルタ式の追加

チャネル フィルタ式の削除

チャネル フィルタのプロパティの設定


チャネル フィルタ式の削除

  • チャネル ウィザードの [受信ドキュメント] ページで、[受信ドキュメントのフィルタ] チェック ボックスをオフにします。

受信ドキュメントのプロパティの設定を続けるには、「受信ドキュメントのプロパティの設定」に進んでください。

関連項目

チャネル フィルタ式の追加

チャネルの作成

チャネル フィルタ式の編集

チャネルの編集

チャネル フィルタのプロパティの設定

チャネルのプロパティの設定


メッセージ ポートの作成および管理

ここでは、メッセージ ポートを作成し、管理する方法を作業ごとに説明します。「メッセージ ポートについて」を参照し、メッセージ ポートについて十分に理解しておいてください。

ここには次のトピックが含まれます。

  • メッセージ ポートの作成

  • メッセージ ポートの検索

  • メッセージ ポートの編集

  • メッセージ ポートの削除

  • メッセージ ポートのプロパティの設定


メッセージ ポートの作成

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [ファイル] メニューの [新規作成] をポイントし、[メッセージ ポート] をポイントします。次に、下のいずれかの操作を行います。
    • 取引先組織へのメッセージ ポートを作成する場合は、[組織へ] をクリックします。

    • 内部アプリケーションへのメッセージ ポートを作成する場合は、[アプリケーションへ] をクリックします。

    新しいメッセージ ポートのプロパティ ウィザードが表示されます。

  3. [全般情報] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「メッセージ ポート情報の全般的なプロパティの設定」を参照してください。

  4. 次の手順のいずれかを行ってください。
    • 特定の組織へのメッセージ ポートを作成する場合は、[送信先組織] ページでプロパティを設定し、[次へ] をクリックします。詳細については、「送信先組織のプロパティの設定」を参照してください。

    • オープンなメッセージ ポートを作成する場合は、[オープンな送信先] をクリックし、[次へ] をクリックします。

      オープンなメッセージ ポートの場合は、ドキュメントまたはドキュメントで送信するパラメータにトランスポート情報および送信先情報を指定する必要があります。詳細については、「Submitting」を参照してください。

    • 特定のアプリケーションへのメッセージ ポートを作成する場合は、[送信先アプリケーション] ページでプロパティを設定し、[次へ] をクリックします。詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。
  5. [エンベロープ情報] ページでプロパティを設定し、[次へ] をクリックします。

    詳細については、「エンベロープ情報のプロパティの設定」を参照してください。

  6. [セキュリティ情報] ページでプロパティを設定します。

    詳細については、「セキュリティ情報のプロパティの設定」を参照してください。

  7. チャネル ウィザードに直接進まずにチャネルを作成する場合は、[このメッセージ ポート用のチャネルの作成] チェック ボックスをオフにします。チャネル ウィザードに直接進む場合は、[チャネルの種類] ボックスの一覧から次のいずれかのチャネルの種類を選択します。
    • [組織から]

    • [アプリケーションから]
  8. すべてのメッセージ ポートのプロパティを設定し終わったら、[セキュリティ情報] ページの [完了] をクリックして新しいメッセージ ポートのプロパティ ウィザードを閉じます。

重要

  • オープンなメッセージ ポートであることを宣言する場合は、X12 または EDIFACT 仕様の送信ドキュメント定義を持つポートにチャネルを作成しないでください。X12 または EDIFACT のエンベロープを構築するには、送信元および送信先の組織識別子を指定する必要があります。オープンなメッセージ ポートでは、送信先の組織識別子が指定されません。また、オープンなメッセージ ポートのドキュメントはドキュメント内に送信先アドレスが必要ですが、X12 および EDIFACT のドキュメントにはこの情報は含まれません。

注

  • 予約済みのシステム名である [信頼できるメッセージ受信確認ポート] を使用してメッセージ ポートに名前を付けることはできません。

  • データのパススルー送信に使用するメッセージ ポートとチャネルを作成する場合、使用できるのは、サービス時間帯、チャネルの再試行回数機能と再試行の間隔の機能、およびチャネルに関連付けられたメッセージ ポートのトランスポート機能だけです。デコードまたは暗号解読の検証、フィルタ、ドキュメント トラッキング、およびマッピングの各チャネルの機能は使用できません。

関連項目

チャネルの作成と管理

メッセージ ポートの削除

メッセージ ポートの編集

メッセージ ポートの検索

メッセージ ポートのプロパティの設定

メッセージ ポートについて


メッセージ ポートの検索

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [その他の項目を検索] の [メッセージ ポート] をクリックします。

  3. 次の操作を 1 つ以上行ってください。
    • すべてのメッセージ ポートを検索するには、検索条件をすべて消去し、[検索] をクリックします。

    • 特定の名前のメッセージ ポートを検索するには、そのメッセージ ポートの名前を [メッセージ ポート名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 特定の種類の送信先へのメッセージ ポートを検索するには、[送信先] ボックスの一覧から送信先の種類をクリックし、[検索] をクリックします。

注

  • [検索] をクリックする前に、複数の検索条件を設定することができます。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索条件には、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

メッセージ ポートの削除

メッセージ ポートの編集

メッセージ ポートについて


メッセージ ポートの編集

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [メッセージ ポート名] の一覧で、編集するメッセージ ポートをクリックします。

    メッセージ ポートの検索については、「メッセージ ポートの検索」を参照してください。

  3. [ファイル] メニューの [編集] をクリックします。

    メッセージ ポートのプロパティ ウィザードが表示されます。

  4. [全般情報] ページで、適切なプロパティを編集します。

    詳細については、「メッセージ ポート情報の全般的なプロパティの設定」を参照してください。

    プロパティを編集し終わったら、[完了] をクリックしてメッセージ ポートのプロパティ ウィザードを閉じるか、[次へ] をクリックして別のメッセージ ポートのプロパティを編集します。

  5. 次の手順のいずれかを行ってください。
    • 組織へのメッセージ ポートを編集する場合は、[送信先組織] ページで必要なプロパティを編集し、[次へ] をクリックします。詳細については、「送信先組織のプロパティの設定」を参照してください。

    • アプリケーションへのメッセージ ポートを編集する場合は、[送信先アプリケーション] ページで必要なプロパティを編集し、[次へ] をクリックします。詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。
  6. [エンベロープ情報] ページで必要なプロパティを編集し、[次へ] をクリックします。

    詳細については、「エンベロープ情報のプロパティの設定」を参照してください。

  7. [セキュリティ情報] ページで、必要なプロパティを編集します。

    詳細については、「セキュリティ情報のプロパティの設定」を参照してください。

  8. チャネル ウィザードに直接進まずにチャネルを作成する場合は、[このメッセージ ポート用のチャネルの作成] チェック ボックスをオフにします。チャネル ウィザードに直接進む場合は、[チャネルの種類] ボックスの一覧から次のいずれかのチャネルの種類を選択します。
    • [組織から]

    • [アプリケーションから]
  9. すべてのメッセージ ポートのプロパティを設定し終わったら、[完了] をクリックしてメッセージ ポートのプロパティ ウィザードを閉じます。

注

  • 予約済みのシステム名である [信頼できるメッセージ受信確認ポート] を使用してメッセージ ポートに名前を付けることはできません。

関連項目

チャネルの作成と管理

メッセージ ポートの作成

メッセージ ポートの削除

メッセージ ポートのプロパティの設定

メッセージ ポートについて


メッセージ ポートの削除

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [メッセージ ポート名] の一覧で、削除するメッセージ ポートをクリックします。

    メッセージ ポートの検索については、「メッセージ ポートの検索」を参照してください。

  3. [ファイル] メニューの [削除] をクリックします。

注

  • チャネルが作成されているメッセージ ポートは、そのチャネルを削除しない限り削除できません。

  • メッセージ ポートに関連付けられているチャネルを検索するには、そのメッセージ ポートを右クリックし、[チャネルの検索] をクリックします。

関連項目

チャネルの作成と管理

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートについて


メッセージ ポートのプロパティの設定

ここでは、メッセージ ポートのプロパティを構成する方法を作業ごとに説明します。

ここには次のトピックが含まれます。

  • メッセージ ポート情報の全般的なプロパティの設定

  • 送信先組織のプロパティの設定

  • 送信先アプリケーションのプロパティの設定

  • エンベロープ情報のプロパティの設定

  • セキュリティ情報のプロパティの設定

  • 送信先組織の選択

  • 暗号化証明書の選択

  • トランスポートのプロパティの設定

  • エンベロープの区切り記号の設定


メッセージ ポート情報の全般的なプロパティの設定

  1. メッセージ ポートのプロパティ ウィザードの [全般情報] ページで、[名前] ボックスにメッセージ ポート名を入力します。

  2. [コメント] ボックスに、メッセージ ポートに関するコメントを入力し、[次へ] をクリックします。

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

関連項目

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定


送信先組織のプロパティの設定

  1. メッセージ ポートのプロパティ ウィザードの [送信先組織] ページで、次のいずれかの手順を実行します。
    • オープンなメッセージ ポートを作成する場合は、[オープンな送信先] をクリックし、[次へ] をクリックします。

      オープンなメッセージ ポートの場合は、ドキュメントまたはドキュメントで送信するパラメータにトランスポート情報および送信先情報を指定する必要があります。詳細については、「Submitting」を参照してください。

    • 特定の取引先組織を送信先に指定する場合は、手順 2. に進みます。
  2. [組織] の [参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  3. 組織をクリックし、[OK] をクリックします。

    詳細については、「送信先組織の選択」を参照してください。

  4. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  5. プライマリ トランスポートのプロパティを設定します。

    詳細については、「トランスポートのプロパティの設定」を参照してください。

  6. ドキュメントのトランスポート可能時間を限定するには、[プライマリ トランスポート] の [サービス時間帯] チェック ボックスをオンにします。

    [開始] および [終了] ボックスで時間をクリックして値を入力するか、上矢印または下矢印で値を増減します。

  7. セカンダリ トランスポートを指定する場合は、[バックアップ トランスポート] の [参照] をクリックします。

    [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  8. バックアップ トランスポートのプロパティを設定します。

    詳細については、「トランスポートのプロパティの設定」を参照してください。

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

重要

  • オープンなメッセージ ポートであることを宣言する場合は、X12 または EDIFACT 仕様の送信ドキュメント定義を持つメッセージ ポートにチャネルを作成しないでください。X12 または EDIFACT のエンベロープを構築するには、送信元および送信先の組織識別子を指定する必要があります。オープンなメッセージ ポートでは、送信先の組織識別子が指定されません。また、オープンなメッセージ ポートのドキュメントはドキュメント内に送信先アドレスが必要ですが、X12 および EDIFACT のドキュメントにはこの情報は含まれません。

注

  • サービス時間帯の時間は、サーバー上の時間を表しており、世界標準時 (UTC) 形式で示されます。

関連項目

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定


送信先アプリケーションのプロパティの設定

  1. メッセージ ポートのプロパティ ウィザードの [送信先アプリケーション] ページで、次のいずれかの手順を実行します。
    • 特定の XLANG スケジュールの新しいインスタンスのポートを送信先に指定する場合は、[新しい XLANG スケジュール] をクリックします。[スケジュール モニカ] ボックスに、指定されたスケジュールのモニカを 入力するか、[参照] をクリックしてそのパスを設定します。[ポート名] ボックスに、このスケジュールにあるドキュメントに関する特定の送信先ポートの名前を入力します。

      スケジュール モニカの構文は次のとおりです。

      sked://[localhost][!GroupManager][/FilePath][/PortName]

      XLANG スケジュールは、ローカル コンピュータでのみアクティブにできます。

      モニカの詳細については、「モニカの構文」を参照してください。

    • アクティブな XLANG スケジュール インスタンスを送信先に指定する場合は、[実行中の XLANG スケジュール] をクリックします。この方法は、取引先がメッセージを HTTP トランスポートを用いる特別に構成された ASP ページに返信する場合に、アクティブな XLANG スケジュールにメッセージをトランスポートするためにのみ利用します。詳細については、「BizTalk サービスの統合」を参照してください。

    • 既定の組織のアプリケーションを送信先に指定する場合は、[名前] ボックスの一覧にあるアプリケーションをクリックします。
  2. アプリケーションを送信先として選択した場合は、手順 3. ～ 5. を実行します。アプリケーション以外を送信先として選択した場合は、[次へ] をクリックします。

  3. [プライマリ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスが表示されます。

  4. プライマリ トランスポートのプロパティを設定します。

    詳細については、「トランスポートのプロパティの設定」を参照してください。

  5. ドキュメントのトランスポート可能時間を限定するには、[プライマリ トランスポート] の [サービス時間帯] チェック ボックスをオンにします。

    [開始] および [終了] ボックスで時間をクリックして値を入力するか、上矢印または下矢印で値を増減します。

  6. セカンダリ トランスポートを指定する場合は、[バックアップ トランスポート] の [参照] をクリックします。

    [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  7. バックアップ トランスポートのプロパティを設定します。

    詳細については、「トランスポートのプロパティの設定」を参照してください。

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

重要

  • [新しい XLANG スケジュール] オプションを選択した場合は次の点に注意してください。
    • ポートに名前を付ける場合は、指定されたスケジュールの BizTalk メッセージにポートをバインドする必要があります。その際、メッセージが受信されると新しいスケジュールのインスタンスがアクティブになるようにバインドを構成する必要があります。

    • メッセージが受信されると新しいスケジュールのインスタンスがアクティブになる構成のポートは、1 スケジュールにつき 1 つとし、この動作がスケジュールの最初のアクションになるようにします。詳細については、「BizTalk メッセージを使用したポートの実装」を参照してください。

注

  • XLANG スケジュールをポートの送信先に選択した場合、そのポートで処理できるドキュメントの大きさの限度は 2 MB になります。

  • XLANG スケジュールの作成には BizTalk オーケストレーション デザイナを使用します。

  • サービス時間帯の時間は、サーバー上の時間を表しており、世界標準時 (UTC) 形式で示されます。

関連項目

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定


エンベロープ情報のプロパティの設定

  1. メッセージ ポートのプロパティ ウィザードで、[エンベロープ情報] ページの [エンベロープ情報] にある一覧からエンベロープを選択します。

    X12 書式または EDIFACT 書式のエンベロープを選択した場合は、次の手順を実行する必要があります。カスタム書式のエンベロープを選択した場合は、次の手順を省略できます。

    1. [区切り記号] をクリックし、区切り記号のプロパティを設定します。

      詳細については、「エンベロープの区切り記号の設定」を参照してください。

    2. [インターチェンジ制御番号] ボックスに、インターチェンジ制御番号を入力します。
  2. 送信先組織の既定の組織識別子を上書きする場合は、[組織の識別子] ボックスの一覧で別の識別子をクリックします。

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

重要

  • Reliable 書式のエンベロープを選択した場合は、[BizTalk Server グループのプロパティ] ダイアログ ボックスの [信頼できるメッセージの返信先 URL] アドレスも構成する必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

  • メッセージ ポートに指定するエンベロープの書式は、エンベロープが格納されるドキュメントの書式と一致する必要があります。ドキュメント形式は、関連付けられたチャネルの送信ドキュメント定義で参照される仕様によって決定されます。たとえば、メッセージ ポートに X12 書式のエンベロープを選択する場合は、X12 仕様を示すチャネルの送信ドキュメント定義を選択する必要があります。

注

  • BizTalk フレームワーク 2.0 に準拠するエンベロープを処理する場合、有効期間に関しては、BizTalk Server 2002 はエンドポイントと考えることができます。アプリケーションまたは取引先から、BizTalk フレームワーク 2.0 に準拠したドキュメントが BizTalk Server 2002 に送信された場合、次のフィールドが存在しているときは上書きされ、存在しないときは作成されます。
    • プロパティ サブセクション :

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • 受信情報サブセクション :

      <sendTo>

      <address>

      <sendReceiptBy>

  • アプリケーションへのメッセージ ポートの場合、[組織の識別子] ボックスの一覧から選択できる組織識別子は既定の組織の場合と同じです。

  • ループバック トランスポートを使用した場合、Reliable 書式のエンベロープは選択できません。

  • X12 エンベロープで使用する送信先組織識別子を選択する場合、"組織" という名前の組織識別子、3 文字以上の修飾子を持つ識別子、または 16 文字以上の値を持つ識別子は選択しないでください。

  • EDIFACT エンベロープで使用する送信先組織識別子を選択する場合、"組織" という名前の組織識別子、5 文字以上の修飾子を持つ識別子、および 36 文字以上の値を持つ識別子は選択しないでください。

  • EDIFACT 書式のエンベロープを選択した場合、既定の構文識別子は UNOA (大文字のラテン文字) です。別の構文を使用する場合は、チャネル ウィザードでメッセージ ポートの既定値を上書きして別の構文識別子を選択します。詳細については、「メッセージ ポート既定値の変更」を参照してください。

関連項目

エンベロープの作成

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定

エンベロープについて


セキュリティ情報のプロパティの設定

  1. メッセージ ポートのプロパティ ウィザードの [セキュリティ情報] ページで、[エンコード] の [種類] ボックスの一覧から、次のいずれかをクリックします。
    • [(なし)] : エンコードは指定されません。これは既定の設定です。

    • [MIME] : MIME (Multipurpose Internet Mail Extensions) を使用するエンコードが指定されます。

    • [カスタム] : カスタム エンコード コンポーネントを使用するエンコードが指定されます。

    注

    • カスタム エンコード/暗号化/署名コンポーネントを指定し、クラス識別子 (CLSID) を構成する場合は、BizTalk メッセージ構成オブジェクト モデルを使用します。BizTalk メッセージ マネージャがエンコーディング/暗号化/署名の [種類] ボックスの一覧に [カスタム] ボタンを表示するのは、カスタム コンポーネントが指定されているメッセージ ポートを編集している場合だけです。

    • 添付ドキュメントがない場合、Reliable 書式のエンベロープ、またはエンベロープ仕様が指定されていないカスタム XML 書式のエンベロープを指定すると、MIME エンコードを指定したときでも出力は MIME エンコードされません。

    • 受信ドキュメントが MIME エンコードされたシフト JIS データであるとき、ドキュメントの本文に "encoding=Shift_jis" を指定しないでください。代わりに、MIME ヘッダーに "charset=shift-jis" を指定してください。
  2. [暗号化] の [種類] ボックスの一覧から、次のいずれかをクリックします。
    • [(なし)] : 暗号化は指定されません。これは既定の設定です。

    • [S/MIME] : S/MIME (Secure Multipurpose Internet Mail Extensions) を使用するエンコードが指定されます。

    • [カスタム] : カスタム暗号化コンポーネントを使用するエンコードが指定されます。

    注

    • カスタム暗号化コンポーネントを指定し、クラス識別子 (CLSID) を構成する場合は、BizTalk メッセージ構成オブジェクト モデルを使用します。
  3. S/MIME 暗号化を選択した場合は、[暗号化] の [参照] をクリックします。

    [暗号化証明書の選択] ダイアログ ボックスが表示されます。

  4. 暗号化証明書を選択します。

    詳細については、「暗号化証明書の選択」を参照してください。

  5. [署名] の [種類] ボックスの一覧から、次のいずれかをクリックします。
    • [(なし)] : 署名は指定されません。これは既定の設定です。

    • [S/MIME] : S/MIME (Secure Multipurpose Internet Mail Extensions) を使用する署名が指定されます。

    • [カスタム] : カスタム署名コンポーネントを使用するエンコードが指定されます。

    注

    • カスタム署名コンポーネントを指定し、クラス識別子 (CLSID) を構成する場合は、BizTalk メッセージ構成オブジェクト モデルを使用します。
  6. チャネル ウィザードに直接進まずにチャネルを作成する場合は、[このメッセージ ポート用のチャネルの作成] チェック ボックスをオフにします。チャネル ウィザードに直接進む場合は、[チャネルの種類] ボックスの一覧から次のいずれかのチャネルの種類を選択します。
    • [組織から]

    • [アプリケーションから]

新しいメッセージ ポートを作成する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの作成」に進んでください。

既存のメッセージ ポートを編集する場合は、[次へ] をクリックします。以降の手順については、「メッセージ ポートの編集」に進んでください。

変更が完了したら、[完了] をクリックします。

関連項目

チャネルの作成

メッセージ ポートの作成

メッセージ ポートの編集

メッセージ ポートのプロパティの設定


送信先組織の選択

  1. メッセージ ポートのプロパティ ウィザードの [送信先組織] ページで、[組織] をクリックし、[参照] をクリックします。

    [組織の選択] ダイアログ ボックスが表示されます。

  2. [利用可能な組織] ボックスの一覧で組織をクリックし、[OK] をクリックします。

送信先組織のプロパティの設定を続けるには、「送信先組織のプロパティの設定」に進んでください。

関連項目

メッセージ ポートの作成

送信先組織のプロパティの設定

メッセージ ポートのプロパティの設定


暗号化証明書の選択

  1. メッセージ ポートのプロパティ ウィザードの [セキュリティ情報] ページで、[暗号化] の [種類] ボックスの一覧から [S/MIME] をクリックし、[参照] をクリックします。

    [暗号化証明書の選択] ダイアログ ボックスが表示されます。

  2. [証明書名] ボックスの一覧から証明書名をクリックし、[OK] をクリックします。

セキュリティのプロパティの設定を続けるには、「セキュリティ情報のプロパティの設定」に進んでください。

注

  • 証明書には一意な名前を付ける必要があります。同じ名前の証明書がある場合、そのうち 1 つだけが選択されます。一度選択されると、同じ名前を持つそれ以外の証明書は、それ以降一覧に表示されません。

    証明書の詳細については、「証明書の概要」を参照してください。

関連項目

メッセージ ポートの作成

メッセージ ポートのプロパティの設定

セキュリティ情報の設定


トランスポートのプロパティの設定

トランスポートのプロパティにはトランスポートの種類が含まれます。トランスポートの種類では、メッセージ ポートに指定された送信先に Microsoft BizTalk Server 2002 でドキュメントを送信する際に使用するトランスポート サービスを指定します。トランスポートのプロパティには、データの送信先アドレスを含めることもできます。このアドレスのプロパティは、選択したトランスポートの種類によって異なります。

ここでは、メッセージ ポートのプライマリ トランスポートとバックアップ トランスポートを設定する方法を説明します。

ここには次のトピックが含まれます。

  • トランスポートの種類の選択

  • トランスポート アドレスの指定

  • アプリケーション統合コンポーネントの選択

  • SMTP Subject の既定値の変更


トランスポートの種類の選択

  1. メッセージ ポートのプロパティ ウィザードの [送信先アプリケーション] または [送信先組織] のページで、[プライマリ トランスポート] または [バックアップ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスまたは [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  2. [トランスポートの種類] ボックスの一覧から、次のトランスポートのいずれかをクリックします。
    • [アプリケーション統合コンポーネント] : BizTalk Server 2002 に登録したアプリケーション統合コンポーネント (AIC) を使用するトランスポートが指定されます。

    • [ファイル] : SendLocalFile コンポーネントを使用するトランスポートが指定されます。

    • [HTTP] : Hypertext Transfer Protocol を使用するトランスポートが指定されます。

    • [HTTPS] : Secure Hypertext Transfer Protocol を使用するトランスポートが指定されます。

    • [ループバック] : 送信同期呼び出しで受信ドキュメントを送信する業務用アプリケーション、コンポーネント、または XLANG スケジュールに、チャネルの送信ドキュメントを戻すトランスポートが指定されます。このトランスポートが使用できるのは、アプリケーションにドキュメントを送信するメッセージ ポートのみです。

    • [メッセージ キュー] : メッセージ キュー サービスを使用するトランスポートが指定されます。

    • [SMTP] : Simple Mail Transfer Protocol を使用するトランスポートが指定されます。
  3. 次の手順のいずれかを行ってください。
    • トランスポートの種類にアプリケーション統合コンポーネントを選択する場合は、「アプリケーション統合コンポーネントの選択」を参照してください。

    • トランスポートの種類にループバックを選択する場合、トランスポートのアドレスは必要ありません。

    • アプリケーション統合コンポーネントおよびループバック以外のトランスポートの種類を選択する場合は、「トランスポート アドレスの指定」を参照してください。

注

  • トランスポートの種類としてメッセージ キューを選択し、かつエンベロープを使用しない場合、そのメッセージ ポートで処理できるドキュメントの大きさの限度は 2 MB になります。

  • トランスポートの種類としてメッセージ キューを選択し、かつエンベロープを使用する場合、そのメッセージ ポートで処理できるドキュメントの大きさの限度は 4 MB になります。

  • SMTP トランスポートの種類を選択する場合は、あらかじめ BizTalk Server 管理コンソールで SMTP ホストを構成しておく必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

  • HTTP トランスポート コンポーネントの既定の設定は、HTTP プロキシ サーバーを使用するようになっています。これは、企業のファイアウォールの外部にある Web サイトにデータをトランスポートするのに適した設定です。会社のファイアウォールの内部にある (つまりイントラネット内の) Web サイトにデータをトランスポートするには、チャネルの既定の設定を変更します。詳細については、「メッセージ ポート既定値の変更」を参照してください。

  • ループバック トランスポートは、受信ドキュメントを別の書式にマップした上で、セキュリティ (エンコード、暗号化、デジタル署名) をエンベロープ化または適用し、呼び出し元に同時に送信ドキュメントが戻されるようにする場合に使用します。

  • ループバック トランスポートを選択した場合、Reliable 書式のエンベロープは使用できません。

関連項目

メッセージ ポートの作成

アプリケーション統合コンポーネントの選択

メッセージ ポートのプロパティの設定

トランスポートのプロパティの設定

トランスポート アドレスの指定

SMTP Subject の既定値の変更


トランスポート アドレスの指定

  1. メッセージ ポートのプロパティ ウィザードの [送信先アプリケーション] または [送信先組織] のページで、[プライマリ トランスポート] または [バックアップ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスまたは [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  2. [トランスポートの種類] ボックスの一覧で、ループバックおよびアプリケーション統合コンポーネント以外のトランスポートの種類をクリックします。

  3. [アドレス] ボックスに、送信先のアドレスを入力します。

  4. SMTP トランスポートを選択した場合は、[差出人電子メール アドレス] にアドレスを入力します。

    送信ヘッダーの送信元アドレスと、差出人電子メールの送信先にはここで入力したアドレスが使用されます。

送信先組織のプロパティの設定を続けるには、「送信先組織のプロパティの設定」に進んでください。

重要

  • ファイル トランスポートの場合、既定のトランスポート コンポーネントの設定では、指定されたディレクトリの既存のファイルに新しいファイルが追加されます。

  • ファイル トランスポートで同一名の複数のファイルを同じディレクトリに送信する場合、ファイルのドキュメント書式やコード ページが異なっていると内部のデータが破損します。

  • 各ドキュメントのインスタンスに新しいファイルを作成する場合は、次のファイル パス書式を使用する必要があります。

    file://C:\dir\file%tracking_id%.xml

注

  • メッセージ キュー以外のトランスポートでは、アドレスのプレフィックスが自動的に作成されます。このプレフィックスは必須であり削除できません。

  • メッセージ キュー トランスポートの場合、アドレスを有効にするには次の条件を満たす必要があります。
    • アドレスにプレフィックス queue:// は使用しないでください。

    • パスではなく書式名を使用します。有効な書式名を次に示します。

      DIRECT=OS:<サーバー名>\<キュー名>

      PUBLIC=<キュー名 GUID>

      DIRECT=TCP:<IP アドレス\キュー名>

      「PUBLIC= 書式名」 を使用する場合には、メッセージ キューのグローバル一意識別子 (GUID) にかっこを使用しないでください。

      メッセージ キューの詳細については、MSDN Online Library の Web サイト (www.microsoft.com/japan/developer/library/default.asp) で、「Message Queuing」を検索してください。

  • ファイル トランスポートの場合、アドレスを有効にするには次の条件を満たす必要があります。
    • 存在するファイル パスを指定する必要があります。ファイル パスは自動的に作成されないため、ファイル パスが存在しないことを知らせる警告を受け取りません。

    • ファイル名は拡張子付きで指定する必要があります。

      有効なファイル パスの例を示します。

      file://C:\dir\file.xml

  • ファイル トランスポートの場合、文字や記号を組み込んで動的にファイル名を変更できます。サーバーで作成されたファイル名には、[アドレス] ボックスに入力した静的な文字のほか、記号の値が含まれています。たとえば、[アドレス] ボックスに「file://C:\Orders\Invoice_%tracking_id%.xml」と入力すると、ファイル名は C:\Orders\Invoice_{12345678-90AB-CDEF-1234-567890ABCDEF} のようになります。

    ファイル トランスポートで使用できる記号を次の表に示します。

    記号 | 説明 | 一意なファイル名
    %datetime% | ファイル作成の日時 (ミリ秒単位)。ローカル時間ではなくグリニッジ標準時 (GMT) が使用されます。 | [なし]
    %document_name% | ソース ファイルの処理に使用するドキュメント定義の名前。 | [なし]
    %server% | ドキュメントを処理したサーバーの名前。 | [なし]
    %src_filename% | 処理するために送信中のファイルの名前。 | [なし]
    %tracking_id% | 一意なグローバル追跡番号。 | [あり]
    %uid% | 時間の経過に従って増加するカウンタ (ミリ秒単位)。この数値はサーバーを再起動するとリセットされます。 | [なし]

  • ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。メッセージ ポートで既定の設定になっているファイル トランスポートの種類を使用し、BizTalk Server 2002 がインストールされているサーバーでウィルス対策ソフトウェアを使用していて、正確に同じ名前の複数のファイルを同じファイル位置に同時に送信すると、BizTalk Server 2002 が応答しなくなることがあり、その場合再起動する必要があります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。この問題は、メッセージ ポートのファイル パス形式 (file://C:\dir\file%tracking_id%.xml) を使用して処理されるドキュメント インスタンスごとに一意なファイルを作成することで解決することもできます。チャネルの詳細なプロパティでファイル トランスポート コンポーネントの追加設定を変更する方法の詳細については、「メッセージ ポート既定値の変更」を参照してください。

  • ファイル トランスポート コンポーネントの既定の設定は、ファイルを追加するようになっています。既定の設定のファイル トランスポートの種類を選択し、メッセージ ポートで Reliable エンベロープ書式のエンベロープを選択して、複数のファイルを同時に同じファイル位置に送信すると、予期しない解析結果を生じることがあります。この問題を解決するには、[BizTalk SendLocalFile のプロパティ] ダイアログ ボックスで、ファイル トランスポート コンポーネントの既定の設定を [ファイルに追加] から [ファイルの上書き] に変更します。チャネルの詳細なプロパティでファイル トランスポート コンポーネントの追加設定を変更する方法の詳細については、「メッセージ ポート既定値の変更」を参照してください。

  • トランスポートのディクショナリにはワイルドカードの %src_filepath% も存在しますが、これを利用することはできません。

関連項目

メッセージ ポートの作成

アプリケーション統合コンポーネントの選択

トランスポートの種類の選択

メッセージ ポートのプロパティの設定

トランスポートのプロパティの設定

用語の対応


アプリケーション統合コンポーネントの選択

  1. メッセージ ポートのプロパティ ウィザードの [送信先アプリケーション] または [送信先組織] のページで、[プライマリ トランスポート] または [バックアップ トランスポート] の [参照] をクリックします。

    [プライマリ トランスポート] ダイアログ ボックスまたは [バックアップ トランスポート] ダイアログ ボックスが表示されます。

  2. [トランスポートの種類] ボックスの一覧で、[アプリケーション統合コンポーネント] をクリックします。

  3. [コンポーネント名] ボックスの右側にある [参照] をクリックします。

    [コンポーネントの選択] ダイアログ ボックスが表示されます。

  4. [利用可能なコンポーネント] ボックスの一覧で、コンポーネントをクリックし、[OK] をクリックします。

送信先組織のプロパティの設定を続けるには、「送信先組織のプロパティの設定」に進んでください。

注

  • アプリケーション統合コンポーネント (AIC) が [利用可能なコンポーネント] ボックスの一覧に表示されるようにするには、BizTalk Server 2002 に登録する必要があります。詳細については、「カスタム コンポーネントの登録」を参照してください。

関連項目

メッセージ ポートの作成

トランスポートの種類の選択

メッセージ ポートのプロパティの設定

トランスポートのプロパティの設定

トランスポート アドレスの指定

用語の対応


SMTP Subject の既定値の変更

SMTP (Simple Mail Transfer Protocol) Subject の既定値は、<document_name>-<Tracking_ID> です。この値を利用することで、ドキュメント定義名を使ったドキュメントのルーティングが可能になります。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk メッセージ マネージャ] をクリックします。

  2. [その他の項目を検索] の [チャネル] をクリックして [検索] をクリックします。

  3. [チャネル名] の一覧で、表示しようとする SMTP Subject のチャネルをクリックし、Enter キーを押します。

    チャネルのプロパティ ウィザードが表示されます。

  4. ウィザードの [詳細構成] のページが表示されるまで、[次へ] をクリックします。

  5. [詳細構成] ページで [詳細設定] をクリックします。

  6. [メッセージ ポート既定値の変更] ダイアログ ボックスで、[プロパティ] をクリックします。

  7. [件名] ボックスに、新しい既定値を入力して [OK] を 2 回クリックします。

  8. [完了] をクリックします。

    変更が保存されます。

注

  • オープンな送信先のメッセージ ポートを作成している場合には、[メッセージ ポート既定値の変更] ダイアログ ボックスは利用できません。オープンな送信先のドキュメントおよびインターチェンジのトランスポート サービスとして SMTP を使用する場合には、トラッキング ID とドキュメント定義名を使ってドキュメントをルーティングできます。


エンベロープの区切り記号の設定

区切り記号のプロパティには、エンベロープ内のデータやインターチェンジのドキュメントを区切る際に使用する文字を指定します。区切り記号が必要になるのは、X12 書式および EDIFACT 書式のエンベロープのみです。カスタム書式のエンベロープの場合は、区切り記号を省略できます。

エンベロープの区切り記号は、メッセージ ポートにエンベロープを選択した場合に設定されます。 あるメッセージ ポート用に設定された区切り記号は、そのメッセージ ポートにのみ適用されます。同じエンベロープでも使用されるメッセージ ポートが異なる場合は、それぞれに異なる区切り記号が設定できます。ここでは、区切り記号のプロパティを設定する方法について説明します。

ここには次のトピックが含まれます。

  • X12 区切り記号の設定

  • EDIFACT 区切り記号の設定

  • Custom 区切り記号の設定

  • 用語の対応


X12 区切り記号の設定

  1. メッセージ ポートのプロパティ ウィザードで、[エンベロープ情報] ページの [エンベロープ情報] から X12 書式のエンベロープを選択し、[区切り記号] をクリックします。

    [X12 区切り記号] ダイアログ ボックスが表示されます。

  2. [文字] ボックスまたは [16 進変換] ボックスのいずれかに区切り記号値を入力し、[OK] をクリックします。

X12 区切り記号の説明を次の表に示します。

区切り記号 | 説明
コンポーネント要素 (エレメント) の区切り記号 (セパレーター) | 複合データ フィールドのデータのコンポーネントを区切る際に使用する文字を指定します。複合データ フィールドは、複数のサブフィールドで構成されるフィールドです。
要素 (エレメント) 区切り記号 (セパレーター) | レコードのデータ フィールドを区切る際に使用する文字を指定します。
セグメント終端記号 (ターミネーター) | レコードの終わりを示す際に使用する文字を指定します。

送信先組織のプロパティの設定を続けるには、「エンベロープ情報のプロパティの設定」に進んでください。

注

  • 各区切り記号には、 [文字] ボックスに 1 つの文字または [16 進変換] ボックスに 2 つの文字のいずれかを入力できます。[16 進変換] ボックスは、Enter キーなどの非印刷文字の区切り記号を入力するのに使用できます。

関連項目

メッセージ ポートの作成

Custom 区切り記号の設定

EDIFACT 区切り記号の設定

エンベロープの区切り記号の設定

エンベロープ情報のプロパティの設定

メッセージ ポートのプロパティの設定

用語の対応


EDIFACT 区切り記号の設定

  1. メッセージ ポートのプロパティ ウィザードで、[エンベロープ情報] ページの [エンベロープ情報] から EDIFACT 書式のエンベロープを選択し、[区切り記号] をクリックします。

    [EDIFACT 区切り記号] ダイアログ ボックスが表示されます。

  2. [文字] ボックスまたは [16 進変換] ボックスのいずれかに区切り記号値を入力し、[OK] をクリックします。

EDIFACT 区切り記号の説明を次の表に示します。

区切り記号 | 説明
コンポーネント要素 (エレメント) の区切り記号 (セパレーター) | 複合データ フィールドのデータのコンポーネントを区切る際に使用する文字を指定します。複合データ フィールドは、複数のサブフィールドで構成されるフィールドです。
要素 (エレメント) 区切り記号 (セパレーター) | レコードのデータ フィールドを区切る際に使用する文字を指定します。
リリース インジケータ (リソース キャラクター) | 次に続く文字を区切り記号として評価しないことを示す際に使用する文字を指定します。
セグメント終端記号 (ターミネーター) | レコードの終わりを示す際に使用する文字を指定します。

注

  • EDIFACT リリース インジケータを使用する場合、データ内にリリース インジケータ文字を含めないでください。リリース インジケータ文字を含めると、データがフィールドに設定された文字物理サイズを超過することがあります。

  • 各区切り記号には、 [文字] ボックスに 1 つの文字または [16 進変換] ボックスに 2 つの文字のいずれかを入力できます。[16 進変換] ボックスは、Enter キーなどの非印刷文字の区切り記号を入力するのに使用できます。

  • EDIFACT の小数点記号 (デシマル マーク） は使用できません。

送信先組織のプロパティの設定を続けるには、「エンベロープ情報のプロパティの設定」に進んでください。

関連項目

メッセージ ポートの作成

Custom 区切り記号の設定

エンベロープの区切り記号の設定

エンベロープ情報のプロパティの設定

メッセージ ポートのプロパティの設定

X12 区切り記号の設定

用語の対応


Custom 区切り記号の設定

  1. メッセージ ポートのプロパティ ウィザードで、[エンベロープ情報] ページの [エンベロープ情報] からカスタム書式のエンベロープを選択し、[区切り記号] をクリックします。

    [Custom 区切り記号] ダイアログ ボックスが表示されます。

  2. [文字] ボックスまたは [16 進変換] ボックスのいずれかに区切り記号値を入力し、[OK] をクリックします。

Custom 区切り記号の説明を次の表に示します。

区切り記号 | 説明
サブフィールド | マルチパート データ フィールドのデータのコンポーネントを区切る際に使用する文字を指定します。
フィールド | レコードのデータ フィールドを区切る際に使用する文字を指定します。
エスケープ文字 | 次に続く文字を区切り記号として評価しないことを示す際に使用する文字を指定します。
レコード | レコードの終わりを示す際に使用する文字を指定します。

注

  • 各区切り記号には、 [文字] ボックスに 1 つの文字または [16 進変換] ボックスに 2 つの文字のいずれかを入力できます。[16 進変換] ボックスは、Enter キーなどの非印刷文字の区切り記号を入力するのに使用できます。

送信先組織のプロパティの設定を続けるには、「エンベロープ情報のプロパティの設定」に進んでください。

関連項目

メッセージ ポートの作成

EDIFACT 区切り記号の設定

エンベロープの区切り記号の設定

エンベロープ情報のプロパティの設定

メッセージ ポートのプロパティの設定

X12 区切り記号の設定

用語の対応


用語の対応

BizTalk Server では、各種区切り記号やエスケープ文字に対して、X12/EDIFACT 標準と異なる用語を使用しています。次の表に、同じ意味を持ちながら、XML ツール (BizTalk エディタなど) と BizTalk メッセージ マネージャ コンポーネントで異なる名称が付けられている用語を示します。

XML ツール | BizTalk メッセージ マネージャ
レコード区切り記号 | セグメント終端記号 (ターミネーター)
フィールド区切り記号 | 要素 (エレメント) 区切り記号 (セパレーター)
サブフィールド区切り記号 | コンポーネント要素 (エレメント) の区切り記号 (セパレーター)
エスケープ文字 | リリース インジケータ (リソース キャラクター)

関連項目

メッセージ ポートの作成

Custom 区切り記号の設定

EDIFACT 区切り記号の設定

エンベロープの区切り記号の設定

エンベロープ情報のプロパティの設定

メッセージ ポートのプロパティの設定

X12 区切り記号の設定


組織の作成と管理

ここでは、組織を作成し、管理する方法を作業ごとに説明します。「組織について」を参照し、組織について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • 既定の組織の構成

  • 組織の作成

  • 組織の検索

  • 組織の編集

  • 組織の削除

  • 組織のプロパティの設定


既定の組織の構成

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. [組織の検索] の [既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

  3. [組織名] ボックスの一覧の [既定の組織] をダブルクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  4. [全般] タブで、組織の全般的なプロパティを設定します。

    詳細については、「組織の全般的なプロパティの設定」を参照してください。

  5. [識別子] タブをクリックし、組織識別子のプロパティを設定します。

    詳細については、「組織識別子のプロパティの設定」を参照してください。

  6. [アプリケーション] タブをクリックし、アプリケーションのプロパティを設定します。

    詳細については、「アプリケーションのプロパティの設定」を参照してください。

  7. 既定の組織の必要なプロパティをすべて設定し終わったら、[OK] をクリックして [組織のプロパティ] ダイアログ ボックスを閉じます。

重要

  • "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の組織識別子が、既定の組織に対して自動的に作成されます。この識別子は削除できません。この識別子の名前または修飾子は変更できませんが、値は変更することができます。SMTP トランスポート プロトコルを使用する信頼できるメッセージ受信確認を送信する場合は、この識別子に指定された値が送信元アドレスとして使用されます。信頼できるメッセージ受信確認の詳細については信頼できるメッセージを使用した受信確認処理」を参照してください。

  • オープンなメッセージ ポートに指定されたアドレスが SMTP アドレスの場合は、組織識別子に指定された値 (信頼できるメッセージ受信確認 SMTP 送信元アドレス) は、送信元アドレスとしても使用されます。詳細については、「Openness」を参照してください。

注

  • 既定の組織の名前は、いつでも任意の名前に変更できます。

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションを追加できます。

関連項目

組織の編集

組織の検索

アプリケーションのプロパティの設定

組織のプロパティの設定

組織について


組織の作成

  1. BizTalk メッセージ マネージャで、[ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。

    [新しい組織] ダイアログ ボックスが表示されます。

  2. [全般] タブで、組織の全般的なプロパティを設定します。

    詳細については、「組織の全般的なプロパティの設定」を参照してください。

  3. [識別子] タブをクリックし、組織識別子のプロパティを設定します。

    詳細については、「組織識別子のプロパティの設定」を参照してください。

  4. 必要なプロパティをすべて設定し終わったら、[OK] をクリックして [新しい組織] ダイアログ ボックスを閉じます。

関連項目

既定の組織の構成

組織の削除

組織の編集

組織の検索

組織のプロパティの設定

組織について


組織の検索

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. 次の操作を 1 つ以上行ってください。
    • すべての組織を検索するには、検索条件をすべて消去し、[検索] をクリックします。

    • 特定の名前の組織を検索するには、[組織の検索] でその組織の名前を [組織名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 既定の組織のみを検索するには、[既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

注

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件には、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

組織の削除

組織の編集

組織について


組織の編集

  1. BizTalk メッセージ マネージャの [組織名] ボックスの一覧で、編集する組織をクリックします。

    組織の検索については、「組織の検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  3. [全般] タブで、変更が必要なプロパティを編集します。

    詳細については、「組織の全般的なプロパティの設定」を参照してください。

  4. [識別子] タブをクリックし、変更が必要な組織識別子のプロパティを編集します。

    詳細については、「組織識別子のプロパティの設定」を参照してください。

  5. 既定の組織を編集する場合は、[アプリケーション] タブをクリックし、変更が必要なアプリケーション プロパティを編集します。

    詳細については、「アプリケーションのプロパティの設定」を参照してください。

  6. 変更が必要なプロパティを編集し終わったら、[OK] をクリックして [組織のプロパティ] ダイアログ ボックスを閉じます。

重要

  • "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の組織識別子が、既定の組織に対して自動的に作成されます。この識別子は削除できません。この識別子の名前または修飾子は変更できませんが、値は変更することができます。SMTP トランスポート プロトコルを使用する信頼できるメッセージ受信確認を送信する場合は、この識別子に指定された値が送信元アドレスとして使用されます。信頼できるメッセージ受信確認の詳細については信頼できるメッセージを使用した受信確認処理」を参照してください。

  • オープンなメッセージ ポートに指定されたアドレスが SMTP アドレスの場合は、組織識別子に指定された値 (信頼できるメッセージ受信確認 SMTP 送信元アドレス) は、送信元アドレスとしても使用されます。詳細については、「Openness」を参照してください。

注

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションを追加できます。

関連項目

組織の作成

組織の削除

組織の検索

組織について


組織の削除

  1. BizTalk メッセージ マネージャの [組織名] ボックスの一覧で、削除する組織をクリックします。

    組織の検索の詳細については、「組織の検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • メッセージ ポートまたはチャネルで使用されている組織は削除できません。あらかじめ、その組織が使用されているチャネルおよびメッセージ ポートをすべて削除しておく必要があります。

  • 既定の組織は削除できません。

関連項目

組織の作成

組織の編集

組織の検索

組織について


組織のプロパティの設定

ここでは、組織のプロパティを構成する方法を作業ごとに説明します。

ここには次のトピックが含まれます。

  • 組織の全般的なプロパティの設定

  • 組織識別子のプロパティの設定

  • アプリケーションのプロパティの設定


組織の全般的なプロパティの設定

  1. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。または、[組織名] ボックスの一覧で組織をダブルクリックします。

    [組織] ダイアログ ボックスが表示されます。

  2. [全般] タブの [組織名] ボックスに、組織の一意な名前を入力します。

  3. [コメント] ボックスに、組織に関するコメントを入力します。

関連項目

既定の組織の構成

組織の作成

組織の編集

組織のプロパティの設定


組織識別子のプロパティの設定

組織識別子は組織を一意に識別するために使用されます。組織には複数の組織識別子を設定できますが、各識別子はその組織に固有のものにする必要があります。

新しい組織を作成すると、"組織" という名前の組織識別子が自動的に作成されます。この識別子の修飾子は OrganizationName で、値は組織に付けた名前になります。追加の識別子を作成し、そのうちの 1 つを既定の識別子に指定しない限り、"組織" が既定の識別子として使用されます。

ここには次のトピックが含まれます。

  • 組織識別子の追加

  • 組織識別子の編集

  • 組織識別子の削除

関連項目

既定の組織の構成

組織の作成

組織の編集

組織識別子

組織のプロパティの設定


組織識別子の追加

  1. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。または、[組織名] ボックスの一覧で組織をダブルクリックします。

    [組織] ダイアログ ボックスが表示されます。

  2. [識別子] タブをクリックし、[追加] をクリックします。

    [新しい識別子] ダイアログ ボックスが表示されます。

  3. [名前] で次のいずれかの操作を行います。
    • [標準] をクリックし、一覧にある名前を 1 つクリックします。

    • [カスタム] をクリックし、ボックスに一意な名前を入力します。名前を入力したら、[修飾子] ボックスに識別子の修飾子を入力します。
  4. [値] ボックスに識別子の値を入力します。

  5. この識別子を組織の既定の識別子に設定する場合は、[既定値として設定] チェック ボックスをオンにします。既定の識別子に設定しない場合、このチェック ボックスはオフにしてください。

  6. [OK] をクリックして [新しい識別子] ダイアログ ボックスを閉じます。

重要

  • "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の組織識別子が、既定の組織に対して自動的に作成されます。この識別子は削除できません。この識別子の名前または修飾子は変更できませんが、値は変更することができます。SMTP トランスポート プロトコルを使用する信頼できるメッセージ受信確認を送信する場合は、この識別子に指定された値が送信元アドレスとして使用されます。詳細については、「信頼できるメッセージを使用した受信確認処理」を参照してください。

  • オープンなメッセージ ポートに指定されたアドレスが SMTP アドレスの場合は、組織識別子に指定された値 (信頼できるメッセージ受信確認 SMTP 送信元アドレス) は、送信元アドレスとしても使用されます。詳細については、「Openness」を参照してください。

注

  • 組織の既定の識別子は 1 つしか指定できません。チャネルまたはメッセージ ポートに別の組織識別子を指定しない限り、組織の識別では既定の識別子が使用されます。

  • 新しい組織を作成すると、"組織" という名前の組織識別子が自動的に作成されます。この識別子の修飾子は OrganizationName で、値は組織の名前になります。追加の識別子を作成することはできますが、この識別子は変更も削除もできません。

  • EDIFACT エンベロープで使用する組織識別子を作成する場合、修飾子は 4 文字以下、値は 35 文字以下にする必要があります。

  • ANSI X12 エンベロープで使用する組織識別子を作成する場合、修飾子は 2 文字以下、値は 15 文字以下にする必要があります。

関連項目

既定の組織の構成

組織の作成

組織識別子の編集

組織の編集

組織識別子

組織識別子の削除

組織識別子のプロパティの設定


組織識別子の編集

  1. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。または、[組織名] ボックスの一覧で組織をダブルクリックします。

    [組織] ダイアログ ボックスが表示されます。

  2. [識別子] タブをクリックします。

  3. [組織の識別子] ボックスの一覧で、編集する組織識別子をクリックし、[編集] をクリックします。

    [識別子のプロパティ] ダイアログ ボックスが表示されます。

  4. [名前] で次のいずれかの操作を行います。
    • [標準] をクリックし、一覧にある名前を 1 つクリックします。

    • [カスタム] をクリックし、ボックスに一意な名前を入力します。名前を入力したら、[修飾子] ボックスに識別子の修飾子を入力します。
  5. [値] ボックスに識別子の値を入力します。

  6. この識別子を組織の既定の識別子に設定する場合は、[既定値として設定] チェック ボックスをオンにします。既定の識別子に設定しない場合、このチェック ボックスはオフにしてください。

  7. [OK] をクリックして [識別子のプロパティ] ダイアログ ボックスを閉じます。

重要

  • "信頼できるメッセージ受信確認 SMTP 送信元アドレス" という名前の組織識別子が、既定の組織に対して自動的に作成されます。この識別子の名前または修飾子は変更できませんが、値は変更することができます。この識別子は削除できません。SMTP トランスポート プロトコルを使用する信頼できるメッセージ受信確認を送信する場合は、この識別子の値が送信元アドレスとして使用されます。詳細については、「信頼できるメッセージを使用した受信確認処理」を参照してください。

  • オープンなメッセージ ポートに指定されたアドレスが SMTP アドレスの場合は、組織識別子に指定された値 (信頼できるメッセージ受信確認 SMTP 送信元アドレス) は、送信元アドレスとしても使用されます。詳細については、「Openness」を参照してください。

注

  • 組織の既定の識別子は 1 つしか指定できません。チャネルまたはメッセージ ポートに別の組織識別子を指定しない限り、組織の識別では既定の識別子が使用されます。

  • 新しい組織を作成すると、"組織" という名前の組織識別子が自動的に作成されます。この識別子の修飾子は OrganizationName で、値は組織の名前になります。追加の識別子を作成することはできますが、この識別子は変更も削除もできません。

  • EDIFACT エンベロープで使用する組織識別子を作成する場合、修飾子は 4 文字以下、値は 35 文字以下にする必要があります。

  • ANSI X12 エンベロープで使用する組織識別子を作成する場合、修飾子は 2 文字以下、値は 15 文字以下にする必要があります。

関連項目

組織識別子の追加

既定の組織の構成

組織の作成

組織の編集

組織識別子

組織識別子の削除

組織識別子のプロパティの設定


組織識別子の削除

  1. [ファイル] メニューの [新規作成] をポイントし、[組織] をクリックします。または、[組織名] ボックスの一覧で組織をダブルクリックします。

    [組織] ダイアログ ボックスが表示されます。

  2. [識別子] タブをクリックします。

  3. [組織の識別子] ボックスの一覧で、削除する組織識別子をクリックし、[削除] をクリックします。

注

  • 既定として指定した組織識別子は、別の識別子を既定に指定しない限り削除できません。

  • 新しい組織を作成すると、"組織" という組織識別子が自動的に作成されます。この組織識別子は削除できません。

関連項目

組織識別子の追加

既定の組織の構成

組織の作成

組織識別子の編集

組織の編集

組織識別子

組織識別子のプロパティの設定


アプリケーションのプロパティの設定

BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションを追加できます。作成したアプリケーションを利用して、BizTalk Server 2002 と業務で使用する既存の内部アプリケーションとの間で交換されるドキュメントの流れを把握し、追跡することができます。既定の組織のアプリケーションはチャネルに送信元アプリケーションとして、またはメッセージ ポートに送信先アプリケーションとして指定できます。

既定の組織には任意の数のアプリケーションを割り当てることができます。各アプリケーションの名前は、一意なものにする必要があります。

ここには次のトピックが含まれます。

  • アプリケーションの追加

  • アプリケーションの編集

  • アプリケーションの削除

関連項目

既定の組織の構成

組織の編集

組織のプロパティの設定


アプリケーションの追加

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. [組織の検索] の [既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

  3. [組織名] ボックスの一覧の [既定の組織] をダブルクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  4. [アプリケーション] タブの [追加] をクリックします。

    [新しいアプリケーション] ダイアログ ボックスが表示されます。

  5. [アプリケーション名] ボックスにアプリケーションの一意な名前を入力し、[OK] をクリックします。

注

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションの追加、編集、および削除ができます。

関連項目

既定の組織の構成

アプリケーションの編集

組織の編集

アプリケーションの削除

アプリケーションのプロパティの設定


アプリケーションの編集

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. [組織の検索] の [既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

  3. [組織名] ボックスの一覧の [既定の組織] をダブルクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  4. [アプリケーション] タブの [アプリケーション] のボックスの一覧で、編集するアプリケーションをクリックし、[編集] をクリックします。

    [アプリケーションのプロパティ] ダイアログ ボックスが表示されます。

  5. [アプリケーション名] ボックスにアプリケーションの一意な名前を入力し、[OK] をクリックします。

注

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションの追加、編集、および削除ができます。

関連項目

アプリケーションの追加

既定の組織の構成

組織の編集

アプリケーションの削除

アプリケーションのプロパティの設定


アプリケーションの削除

  1. BizTalk メッセージ マネージャで、 [その他の項目を検索] の [組織] をクリックします。

  2. [組織の検索] の [既定の組織] チェック ボックスをオンにし、[検索] をクリックします。

  3. [組織名] ボックスの一覧の [既定の組織] をダブルクリックします。

    [組織のプロパティ] ダイアログ ボックスが表示されます。

  4. [アプリケーション] プロパティ ページの [アプリケーション] ボックスの一覧で、削除するアプリケーションをクリックし、[削除] をクリックします。

注

  • BizTalk メッセージ マネージャでは、既定の組織に対してのみ、アプリケーションの追加、編集、および削除ができます。

関連項目

アプリケーションの追加

既定の組織の構成

組織の編集

アプリケーションのプロパティの設定


ドキュメント定義の作成および管理

ここでは、ドキュメント定義を作成し、管理する方法を作業ごとに説明します。「ドキュメント定義について」を参照し、ドキュメント定義について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • ドキュメント定義の作成

  • ドキュメント定義の検索

  • ドキュメント定義の編集

  • ドキュメント定義の削除

  • ドキュメント定義のプロパティの設定


ドキュメント定義の作成

  1. BizTalk メッセージ マネージャの [ファイル] メニューの [新規作成] をポイントし、[ドキュメント定義] をクリックします。

    [新しいドキュメント定義] ダイアログ ボックスが表示されます。

  2. [全般] タブで全般プロパティを設定します。

    詳細については、「ドキュメント定義の全般プロパティの設定」を参照してください。

  3. [グローバル追跡] タブをクリックし、追跡プロパティを設定します。

    詳細については、「グローバル追跡プロパティの設定」を参照してください。

  4. [選択条件] タブをクリックし、選択条件プロパティを設定します。

    詳細については、「選択条件プロパティの設定」を参照してください。

  5. 必要なプロパティをすべて設定してから、[OK] をクリックして [新しいドキュメント定義] ダイアログ ボックスを閉じます。

注

  • 追跡項目は、BizTalk エディタで作成またはインポートしたスキーマだけから選択できます。

  • ドキュメント定義の [信頼できるメッセージ受信確認チャネル] と [BizTalk 既定受信] はどちらも予約システム名なので指定できません。

  • 仕様を選択しないと、ドキュメントに対するグローバル追跡項目を指定できません。

  • チャネル内のドキュメント定義を選択する場合は、追跡する仕様フィールドとして、そのチャネルに対するグローバル追跡項目とは異なるフィールドを選択することにより、そのグローバル追跡項目を無効にできます。詳細については、「チャネル内の仕様フィールドの選択」を参照してください。

  • ローカル ドメインの外部にある仕様を参照するドキュメント定義を保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/default.asp) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

ドキュメント定義の削除

ドキュメント定義の編集

ドキュメント定義の検索

ドキュメント定義について


ドキュメント定義の検索

  1. BizTalk メッセージ マネージャの [その他の項目を検索] で [ドキュメント定義] をクリックします。

  2. すべてのドキュメント定義を検索するには、検索条件をすべて消去し、[検索] をクリックします。

    – または –

    特定の名前のドキュメント定義を検索するには、検索するドキュメント定義の名前を [ドキュメント定義の検索] の [ドキュメント定義名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

注

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件では、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

ドキュメント定義の削除

ドキュメント定義の編集

ドキュメント定義について


ドキュメント定義の編集

  1. BizTalk メッセージ マネージャの [ドキュメント定義名] ボックスの一覧で、編集するドキュメント定義をクリックします。

    ドキュメント定義の検索の詳細については、「ドキュメント定義の検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    [ドキュメント定義のプロパティ] ダイアログ ボックスが表示されます。

  3. [全般] タグで全般プロパティを編集します。

    詳細については、「ドキュメント定義の全般プロパティの設定」を参照してください。

  4. [グローバル追跡] タブをクリックし、追跡プロパティを編集します。

    詳細については、「グローバル追跡プロパティの設定」を参照してください。

  5. [選択条件] タブをクリックし、選択条件プロパティを設定します

    詳細については、「選択条件プロパティの設定」を参照してください。

  6. 変更が必要なプロパティを編集し終わったら、[OK] をクリックして [ドキュメント定義のプロパティ] ダイアログ ボックスを閉じます。

注

  • ドキュメント定義の [信頼できるメッセージ受信確認チャネル] と [BizTalk 既定受信] はどちらも予約システム名なので指定できません。

  • 仕様を選択しないと、ドキュメントに対するグローバル追跡項目を指定できません。

  • ローカル ドメインの外部にある仕様を参照するドキュメント定義を保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/default.asp) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

ドキュメント定義の作成

ドキュメント定義の削除

ドキュメント定義の検索

ドキュメント定義について


ドキュメント定義の削除

  1. BizTalk メッセージ マネージャの [ドキュメント定義名] ボックスの一覧で、削除するドキュメント定義をクリックします。

    ドキュメント定義の検索の詳細については、「ドキュメント定義の検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • チャネル内でドキュメント定義を使用する場合は、そのドキュメント定義を削除できません。ドキュメント定義を使用するすべてのチャネルを最初に削除する必要があります。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義の検索

ドキュメント定義について


ドキュメント定義のプロパティの設定

ここでは、ドキュメント定義のプロパティを構成する方法を作業ごとに説明します。

ここには次のトピックが含まれます。

  • ドキュメント定義の全般プロパティの設定

  • ドキュメント仕様の選択

  • グローバル追跡プロパティの設定

  • 選択条件プロパティの設定


ドキュメント定義の全般プロパティの設定

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [全般] タブをクリックします。

  2. [ドキュメント定義名] ボックスに一意なドキュメント定義名を入力します。

  3. [ドキュメント仕様] チェック ボックスをオンにします。

  4. [参照] をクリックし、ドキュメント仕様を選択します。

    詳細については、「ドキュメント仕様の選択」を参照してください。

注

  • ドキュメント仕様は選択することも、選択しないこともできますが、ほとんどの場合は仕様を選択することをお勧めします。仕様を選択しない場合は、処理するデータが以下の制約を受けます。
    • データは、受信側で XML に変換されないか、または送信側で XML から変換されません。

    • データに誤りがないことを確認するための検証が行われません。

    • チャネル内でマップを使用してデータの構成または書式を変換することはできません。

    • ドキュメント定義に対するグローバル追跡項目を指定できません。
  • バイナリ ファイルのような、上記の変換や検証を行うことが適切でないデータを処理する場合は、ドキュメント仕様を選択しないことをお勧めします。

  • 非 BizTalk Server ドキュメント仕様を入力した場合には、[グローバル追跡] タブで追跡項目を選択することはできません。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義のプロパティの設定

ドキュメント定義について


ドキュメント仕様の選択

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [全般] タブをクリックします。

  2. [ドキュメント仕様] チェック ボックスをオンにし、[参照] をクリックします。

    [WebDAV リポジトリからのドキュメント仕様の選択] ダイアログ ボックスが表示されます。

  3. サーバーを変更する場合は、[サーバー] ボックスで次のどちらかの操作を行います。
    • 一覧に表示されているサーバーをクリックします。

    • サーバーの名前を入力し、Enter キーを押します。
  4. 目的の仕様が格納されているフォルダをダブルクリックし、その仕様のファイルをダブルクリックします。

重要

  • [WebDAV リポジトリ] ダイアログ ボックスを初めて開くときには、BizTalk メッセージ マネージャがリモート サーバー上のデータベースに接続されている場合でも、ローカル サーバー上の WebDAV リポジトリが選択されます。リモート サーバーの WebDAV リポジトリを参照すると、新しい WebDAV リポジトリを選択するまで、そのサーバーが既定に変更されます。すべての [WebDAV リポジトリ] ダイアログ ボックスの既定のサーバーは、接続が行われた最後のサーバーです。

注

  • サーバーとして http://localhost を選択すると、BizTalk メッセージ マネージャはそれを自動的にローカル コンピュータ名に変換します。

  • ドキュメント定義がオープンなメッセージ ポートに対するチャネル内の受信ドキュメント定義として使用され、そのドキュメント内で送信先情報が指定される場合は、そのドキュメント定義の参照先の仕様が適切に構成されている必要があります。オープンなメッセージ ポートのドキュメントを処理するためのドキュメント仕様を構成する方法については、「ディクショナリ プロパティの設定」を参照してください。

  • ドキュメント仕様は選択することも、選択しないこともできますが、ほとんどの場合は仕様を選択することをお勧めします。仕様を選択しない場合は、処理するデータが以下の制約を受けます。
    • データは、受信側で XML に変換されないか、または送信側で XML から変換されません。

    • データに誤りがないことを確認するための検証が行われません。

    • チャネル内でマップを使用してデータの構成または書式を変換することはできません。

    • ドキュメント定義に対するグローバル追跡項目を指定できません。
  • パススルー送信でドキュメント定義を使用する場合は、ドキュメント仕様は必要ありません。

  • BizTalk エディタかBizTalk マッパーによって、ドキュメント仕様、エンベロープ仕様、またはマップを変更し、リポジトリに保存した場合には、変更した仕様またはマップを BizTalk メッセージ マネージャに再ロードする必要があります。これにより、サーバーは変更を検出できるようになり、データベースの内容も更新可能になります。

  • リモート サーバー上の WebDAV に初めて接続するときには、多少の遅延が生じることがあります。

  • ローカル ドメインの外部にある仕様を参照するドキュメント定義を保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/default.asp) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義のプロパティの設定

ドキュメント定義について


グローバル追跡プロパティの設定

[グローバル追跡項目] タブの [仕様フィールド] ボックスの一覧には、ドキュメント定義に対して選択した仕様のツリーが表示されます。この一覧を展開して仕様内のフィールドを表示することと、ログに記録するフィールド数の制限値を追跡データベースに指定することができます。

ドキュメント定義をチャネルに対する受信ドキュメント定義として選択すると、そのチャネルが処理するインスタンスごとに、これらのフィールドが追跡されます。これらのフィールドは、グローバル追跡項目と呼ばれます。チャネル内のドキュメント定義を選択する場合は、そのチャネルだけが処理するドキュメント インスタンスごとに、追跡する仕様フィールドとして、グローバル追跡項目とは異なるフィールドを選択することにより、そのグローバル追跡項目を無効にできます。

ここでは、ドキュメント定義の仕様フィールドを選択する方法を説明します。

ここには次のトピックが含まれます。

  • ドキュメント定義内の仕様フィールドの選択

  • ドキュメント定義内の仕様フィールドの削除

関連項目

ドキュメント データ フィールドの追跡

ドキュメント定義について


ドキュメント定義内の仕様フィールドの選択

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [グローバル追跡] タブをクリックします。

  2. [仕様フィールド] ボックスの一覧で、レコードの隣にある拡大インジケータ (+) をクリックするか、レコードをダブルクリックして、表示を拡大します。

  3. [追跡するフィールド] ボックスの一覧に追加する仕様フィールドをクリックし、次の手順のいずれかを実行します。
    追加するフィールドのデータ型 | 実行する手順
    Integer | [整数] をクリックします。整数型のフィールドを 2 つ追加できます。
    実数 | [実数] をクリックします。実数型のフィールドを 2 つ追加できます。
    Date [日付] | [日付] をクリックします。日付型のフィールドを 2 つ追加できます。
    テキスト | [テキスト] をクリックします。テキスト型のフィールドを 2 つ追加できます。
    カスタム | [カスタム] をクリックします。カスタム データ型のフィールドをいくつでも追加できます。これらのフィールドは、フィールドごとにタグの付いた XML 連結文字列として格納されます。

注

  • 整数、実数、日付のいずれかのデータ型として追跡する仕様フィールドを選択するには、仕様の中でそのデータ型がフィールドに割り当てられている必要があります。仕様フィールドへのデータ型の割り当ての詳細については、「宣言のプロパティの設定」を参照してください。

  • 仕様フィールドのデータ型が、仕様内で割り当てられているデータ型でない場合は、そのフィールドはテキスト型またはカスタム データ型としてのみ追跡できます。

  • 追跡する仕様フィールドが文字データ型である場合は、そのフィールドはカスタム データ型としてのみ追跡できます。

  • チャネル内のドキュメント定義を選択する場合は、追跡する仕様フィールドとして、そのチャネルに対するグローバル追跡項目とは異なるフィールドを選択することにより、そのグローバル追跡項目を無効にできます。詳細については、「チャネル内の仕様フィールドの選択」を参照してください。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義内の仕様フィールドの削除

ドキュメント定義のプロパティの設定

グローバル追跡プロパティの設定

ドキュメント データ フィールドの追跡

ドキュメント定義について


ドキュメント定義内の仕様フィールドの削除

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [グローバル追跡] タブをクリックします。

  2. [追跡するフィールド] ボックスの一覧で、削除する仕様フィールドをクリックし、[削除] をクリックします。

注

  • 追跡するフィールドの一覧からフィールドを削除しても、そのフィールドはこのドキュメント定義の一覧から削除されるだけで、仕様からは削除されません。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

ドキュメント定義内の仕様フィールドの選択

ドキュメント定義のプロパティの設定

グローバル追跡プロパティの設定

ドキュメント データ フィールドの追跡

ドキュメント定義について


選択条件プロパティの設定

選択条件とは、BizTalk Server が EDI ドキュメントを処理するためにだけ使用する、名前と値の一意な組み合わせです。受信 X12 または EDIFACT ドキュメントに対して、サーバーは選択条件を使用して、ドキュメント定義を一意に識別し選択します。それは、個々の EDI ドキュメント内ではドキュメント定義名を使用できないからです。

送信 X12 ドキュメントまたは送信 EDIFACT ドキュメントでは、グループ ヘッダー情報を作成するために選択条件を使用します。

ここには次のトピックが含まれます。

  • 選択条件の追加

  • 選択条件の編集

  • 選択条件の削除

関連項目

ドキュメント定義について

選択条件について


選択条件の追加

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [選択条件] タブをクリックし、[追加] をクリックします。

    [新しい名前と値] ダイアログ ボックスが表示されます。

  2. [名前] ボックスに選択条件の名前を入力します。

  3. [値] ボックスに選択条件の値を入力し、[OK] をクリックします。

重要

  • BizTalk Server 2002 が選択条件の値を受信インターチェンジの対応するヘッダー要素 (エレメント) と照合し、それらの値を送信インターチェンジのヘッダー要素 (エレメント) に正確に挿入するには、次の表に示されるとおりに選択条件を入力する必要があります。

    X12 ヘッダー要素 (エレメント)
    名前 | 要件 | GS 要素 (エレメント)
    functional_identifier | 必須 | GS01
    application_sender_code | 必須 | GS02
    application_receiver_code | 必須 | GS03
    standards_version | 必須 | GS08

    EDIFACT ヘッダー要素 (エレメント)
    名前 | 要件 | UNH 要素 (エレメント) | UNG 要素 (エレメント)
    functional_identifier | 必須 | S009, 0065 | 0038
    application_sender_code | 省略可 | 未使用 | S006, 0040
    application_receiver_code | 省略可 | 未使用 | S007, 0044
    standards_version_type | 必須 | S009, 0052 | S008, 0052
    standards_version_value | 必須 | S009, 0054 | S008, 0054

  • 送信 EDIFACT インターチェンジに対して、メッセージ ヘッダー (UNH) が必ず作成されます。application_sender_code と application_receiver_code を指定する場合は、グループ ヘッダー (UNG) も作成されます。

  • 各ドキュメント定義に対して使用する選択条件の名前と値の組み合わせは、ドキュメント定義全体にわたって一意である必要があります。

関連項目

ドキュメント定義の作成

ドキュメント定義の編集

選択条件の編集

選択条件の削除

ドキュメント定義のプロパティの設定

選択条件プロパティの設定

ドキュメント定義について

選択条件について


選択条件の編集

  1. [新しいドキュメント定義] または [ドキュメント定義のプロパティ] ダイアログ ボックスの [選択条件] タブをクリックします。

  2. [選択条件] ボックスの一覧で、編集する選択基準をクリックし、[編集] をクリックします。

    [新しい名前と値のプロパティ] ダイアログ ボックスが表示されます。

  3. [名前] ボックスに選択条件の名前を入力します。

  4. [値] ボックスに選択条件の値を入力し、[OK] をクリックします。

重要

  • BizTalk Server 2002 が選択条件の値を受信インターチェンジの対応するヘッダー要素 (エレメント) と照合し、それらの値を送信インターチェンジのヘッダー要素 (エレメント) に正確に挿入するには、次の表に示されるとおりに選択条件を入力する必要があります。

    X12 ヘッダー要素 (エレメント)
    名前 | 要件 | GS 要素 (エレメント)
    functional_identifier | 必須 | GS01
    application_sender_code | 必須 | GS02
    application_receiver_code | 必須 | GS03
    standards_version | 必須 | GS08

    EDIFACT ヘッダー要素 (エレメント)
    名前 | 要件 | UNH 要素 (エレメント) | UNG 要素 (エレメント)
    functional_identifier | 必須 | S009, 0065 | 0038
    application_sender_code | 省略可 | 未使用 | S006, 0040
    application_receiver_code | 省略可 | 未使用 | S007, 0044
    standards_version_type | 必須 | S009, 0052 | S008, 0052
    standards_version_value | 必須 | S009, 0054 | S008, 0054

  • 送信 EDIFACT インターチェンジに対して、メッセージ ヘッダー (UNH) が必ず作成されます。application_sender_code と application_receiver_code を指定する場合は、グループ ヘッダー (UNG) も作成されます。

  • 各ドキュメント定義に対して使用する選択条件の名前と値の組み合わせは、ドキュメント定義全体にわたって一意である必要があります。

関連項目

選択条件の追加

選択条件の削除

選択条件プロパティの設定

ドキュメント定義について

選択条件について


選択条件の削除

  1. [ドキュメント定義のプロパティ] ダイアログ ボックスの [選択条件] タブをクリックします。

  2. [選択条件] ボックスの一覧で、削除する選択基準をクリックし、[削除] をクリックします。

関連項目

選択条件の追加

選択条件の編集

選択条件プロパティの設定

ドキュメント定義について

選択条件について


エンベロープの作成および管理

ここでは、エンベロープを作成し、管理する方法を作業ごとに説明します。「エンベロープについて」を参照し、エンベロープについて十分に理解しておいてください。

ここには次のトピックが含まれます。

  • エンベロープの作成

  • エンベロープの検索

  • エンベロープの編集

  • エンベロープの削除

  • エンベロープ仕様の選択


エンベロープの作成

  1. BizTalk メッセージ マネージャで、[ファイル] メニューの [新規作成] をポイントし、[エンベロープ] をクリックします。

    [新しいエンベロープ] ダイアログ ボックスが表示されます。

  2. [エンベロープ名] ボックスに一意なエンベロープ名を入力します。

  3. [エンベロープ書式] ボックスの一覧で、次のいずれかのエンベロープ書式をクリックします。
    • CUSTOM XML

      カスタム XML 形式の受信インターチェンジを BizTalk Server 2002 で処理できるようにするには、カスタム XML 形式と仕様参照を持つエンベロープを作成します。ただし、カスタム XML インターチェンジを送信する場合は、Submit 関数のパラメータにそのエンベロープ名を指定する必要はありません。BizTalk Server 2002 では、名前の指定がなくても適切なエンベロープを見つけることができます。

    • ANSI X12

      X12 書式のエンベロープを作成しなくても、X12 書式の受信インターチェンジを BizTalk Server 2002 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

    • EDIFACT

      EDIFACT 書式のエンベロープを作成しなくても、EDIFACT 書式の受信インターチェンジを BizTalk Server 2002 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

    • FLATFILE

      フラット ファイル書式の受信インターチェンジを BizTalk Server 2002 で処理できるようにするには、フラット ファイル書式のエンベロープを作成します。フラット ファイルの受信ドキュメントを送信する場合は、Submit 関数のパラメータにエンベロープ名を指定する必要があります。詳細については、「Submitting」を参照してください。

    • CUSTOM

      カスタム書式 (BizTalk Server で直接にはサポートされない書式) の受信インターチェンジを BizTalk Server 2002 で処理できるようにするには、カスタム パーサー コンポーネントを作成します。エンベロープを作成する必要があるのは、カスタム パーサーにエンベロープが必要な場合だけです。詳細については、「Parsers」を参照してください。

      カスタム書式の送信インターチェンジを BizTalk Server で処理できるようにするには、カスタム書式のエンベロープを作成し、メッセージ ポートでそのエンベロープを選択します。カスタム シリアライザ コンポーネントも作成し、登録する必要があります。詳細については、「Serializers」を参照してください。チャネルのカスタム シリアライザは、チャネル ウィザードの [詳細構成] ページで構成できます。詳細については、「詳細構成のプロパティの設定」を参照してください。

    • RELIABLE

      Reliable 書式のエンベロープを作成しなくても、Reliable 書式の受信インターチェンジを BizTalk Server 2002 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

      Reliable 書式では、BizTalk フレームワーク 2.0 に準拠するエンベロープが処理されます。BizTalk フレームワーク 2.0 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

      Reliable 書式を選択する場合は、[BizTalk Server グループのプロパティ] ダイアログ ボックスで [信頼できるメッセージの返信先 URL] のアドレスも構成する必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

  4. カスタム XML、フラット ファイル、またはカスタムのいずれかの書式を選択する場合は、エンベロープの仕様を選択できます。詳細については、「エンベロープ仕様の選択」を参照してください。

注

  • すべての書式の送信インターチェンジを BizTalk Server 2002 で処理できるようにするには、エンベロープを作成します。

  • カスタム XML 書式を選択し、仕様を選択しない場合、エンベロープの書式は既定で Reliable 書式になります。

  • BizTalk フレームワーク 2.0 に準拠するエンベロープを処理する場合、有効期間に関しては、BizTalk Server 2002 はエンドポイントと考えることができます。アプリケーションまたは取引先から、BizTalk フレームワーク 2.0 に準拠したドキュメントが BizTalk Server 2002 に送信された場合、次のフィールドが存在しているときは上書きされ、存在しないときは作成されます。
    • プロパティ サブセクション :

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • 受信情報サブセクション :

      <sendTo>

      <address>

      <sendReceiptBy>

  • エンベロープの書式を変更する場合、既にその仕様が選択されているときは、エンベロープの書式を変更後、もう一度選択し直さなければならないことがあります。

  • ローカル ドメイン以外にある仕様を参照するエンベロープを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

エンベロープの削除

エンベロープの編集

エンベロープの検索

エンベロープについて


エンベロープの検索

  1. BizTalk メッセージ マネージャで、[その他の項目を検索] の [エンベロープ] をクリックします。

  2. 次の操作を 1 つ以上行ってください。
    • すべてのエンベロープを検索するには、すべての検索条件を消去し、[検索] をクリックします。

    • 特定の名前のエンベロープを検索するには、[エンベロープの検索] でそのエンベロープの名前を [エンベロープ名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 特定の書式のエンベロープを検索するには、[書式] ボックスの一覧で書式をクリックし、[検索] をクリックします。

注

  • [検索] をクリックする前に、複数の検索条件を設定することができます。

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件では、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

エンベロープの削除

エンベロープの編集

エンベロープについて


エンベロープの編集

  1. BizTalk メッセージ マネージャの [エンベロープ名] ボックスの一覧で、編集するエンベロープをクリックします。

    エンベロープの検索の詳細については、「エンベロープの検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    [エンベロープのプロパティ] ダイアログ ボックスが表示されます。

  3. [エンベロープ名] ボックスに一意なエンベロープ名を入力します。

  4. [エンベロープ書式] ボックスの一覧で、次のいずれかのエンベロープ書式をクリックします。
    • CUSTOM XML

      カスタム XML 形式の受信インターチェンジを BizTalk Server 2002 で処理できるようにするには、カスタム XML 形式と仕様参照を持つエンベロープを作成します。ただし、カスタム XML インターチェンジを送信する場合は、Submit 関数のパラメータにそのエンベロープ名を指定する必要はありません。BizTalk Server では、名前の指定がなくても適切なエンベロープを見つけることができます。

    • ANSI X12

      X12 書式のエンベロープを作成しなくても、X12 書式の受信インターチェンジを BizTalk Server 2002 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

    • EDIFACT

      EDIFACT 書式のエンベロープを作成しなくても、EDIFACT 書式の受信インターチェンジを BizTalk Server 2002 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

    • FLATFILE

      フラット ファイル書式の受信インターチェンジを BizTalk Server 2002 で処理できるようにするには、フラット ファイル書式のエンベロープを作成します。フラット ファイルの受信ドキュメントを送信する場合は、Submit 関数のパラメータにエンベロープ名を指定する必要があります。詳細については、「Submitting」を参照してください。

    • CUSTOM

      カスタム書式 (BizTalk Server 2002 で直接にはサポートされない書式) の受信インターチェンジを BizTalk Server で処理できるようにするには、エンベロープを作成しなければならない場合があります。これらのインターチェンジを処理するためには、カスタム パーサー コンポーネントを作成する必要があり、このカスタム パーサー コンポーネントにエンベロープが必要な場合があります。詳細については、「Parsers」を参照してください。

      カスタム書式の送信インターチェンジを BizTalk Server で処理できるようにするには、カスタム書式のエンベロープを作成し、メッセージ ポートでそのエンベロープを選択します。カスタム シリアライザ コンポーネントも作成し、登録する必要があります。詳細については、「Serializers」を参照してください。チャネルのカスタム シリアライザは、チャネル ウィザードの [詳細構成] ページで構成できます。詳細については、「詳細構成のプロパティの設定」を参照してください。

    • RELIABLE

      Reliable 書式のエンベロープを作成しなくても、Reliable 書式の受信インターチェンジを BizTalk Server 2002 で処理できます。Submit 関数のパラメータにエンベロープ名を指定する必要もありません。

      Reliable 書式では、BizTalk フレームワーク 2.0 に準拠するエンベロープが処理されます。BizTalk フレームワーク 2.0 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

      Reliable 書式を選択する場合は、[BizTalk Server グループのプロパティ] ダイアログ ボックスで [信頼できるメッセージの返信先 URL] のアドレスも構成する必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

  5. カスタム XML、フラット ファイル、またはカスタムのいずれかの書式を選択する場合は、エンベロープの仕様を選択できます。詳細については、「エンベロープ仕様の選択」を参照してください。

重要

  • Reliable 書式のエンベロープを作成し、ポートでそのエンベロープを選択する場合は、[BizTalk Server グループのプロパティ] ダイアログ ボックスで [信頼できるメッセージの返信先 URL] のアドレスも構成する必要があります。詳細については、「サーバー グループの全般プロパティの構成」を参照してください。

注

  • すべての書式の送信インターチェンジを BizTalk Server 2002 で処理できるようにするには、エンベロープを作成します。

  • カスタム XML 書式を選択し、仕様を選択しない場合、エンベロープの書式は既定で Reliable 書式になります。

  • BizTalk フレームワーク 2.0 に準拠するエンベロープを処理する場合、有効期間に関しては、BizTalk Server 2002 はエンドポイントと考えることができます。アプリケーションまたは取引先から、BizTalk フレームワーク 2.0 に準拠したドキュメントが BizTalk Server 2002 に送信された場合、次のフィールドが存在しているときは上書きされ、存在しないときは作成されます。
    • プロパティ サブセクション :

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • 受信情報サブセクション :

      <sendTo>

      <address>

      <sendReceiptBy>

  • エンベロープの書式を変更する場合、既にその仕様が選択されているときは、エンベロープの書式を変更後、もう一度選択し直さなければならないことがあります。

  • ローカル ドメイン以外にある仕様を参照するエンベロープを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

エンベロープの作成

エンベロープの削除

エンベロープの検索

エンベロープについて


エンベロープの削除

  1. BizTalk メッセージ マネージャの [エンベロープ名] ボックスの一覧で、削除するエンベロープをクリックします。

    エンベロープの検索の詳細については、「エンベロープの検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • エンベロープがメッセージ ポートで使用されている場合は、そのエンベロープは削除できません。そのエンベロープを使用しているすべてのメッセージ ポートを先に削除する必要があります。

関連項目

エンベロープの作成

エンベロープの編集

エンベロープの検索

エンベロープについて


エンベロープ仕様の選択

  1. [新しいエンベロープ] ダイアログ ボックスまたは [エンベロープのプロパティ] ダイアログ ボックスで、[エンベロープ仕様] チェック ボックスをオンにして、[参照] をクリックします。

    [WebDAV リポジトリからのエンベロープ仕様の選択] ダイアログ ボックスが表示されます。

  2. サーバーを変更する場合は、[サーバー] ボックスで次のどちらかの操作を行います。
    • 一覧に表示されているサーバーをクリックします。

    • サーバーの名前を入力し、Enter キーを押します。
  3. 目的の仕様が格納されているフォルダをダブルクリックし、仕様をクリックします。次に [開く] をクリックします。

重要

  • WebDAV リポジトリのダイアログ ボックスを最初に開いたときは、BizTalk メッセージ マネージャがリモート サーバーのデータベースに接続されていても、ローカル サーバーの WebDAV リポジトリが選択されます。リモート サーバーの WebDAV リポジトリを参照すると、新しい WebDAV リポジトリを選択するまで、そのサーバーが既定に変更されます。すべての [WebDAV リポジトリ] ダイアログ ボックスの既定のサーバーは、接続が行われた最後のサーバーです。

注

  • サーバーとして http://localhost を選択すると、BizTalk メッセージ マネージャはそれを自動的にローカル コンピュータ名に変換します。

  • カスタム XML 書式を選択する場合は、エンベロープの仕様を選択できます。仕様を選択しなかった場合は、BizTalk フレームワーク 2.0 に準拠する Reliable 書式が、既定でそのエンベロープの書式になります。BizTalk フレームワーク 2.0 の詳細については、Microsoft BizTalk Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

  • フラット ファイル書式を選択する場合は、エンベロープの仕様を選択できます。受信インターチェンジを開くためにエンベロープが使用される場合は、仕様を選択する必要があります。送信インターチェンジの作成にエンベロープが使用される場合は、仕様は必要ありません。

  • BizTalk エディタかBizTalk マッパーによって、ドキュメント仕様、エンベロープ仕様、またはマップを変更し、リポジトリに保存した場合には、変更した仕様またはマップを BizTalk メッセージ マネージャに再ロードする必要があります。

  • カスタム書式を選択する場合は、エンベロープの仕様を選択できます。仕様が必要かどうかは、作成するカスタム パーサーまたはカスタム シリアライザによって決まります。

    カスタム書式を使用するには、さらに次の操作を行う必要があります。

    • そのカスタム書式の受信インターチェンジを開くためのカスタム パーサー コンポーネントを作成する。詳細については、「Parsers」を参照してください。

    • そのカスタム書式の送信インターチェンジを作成するためのカスタム シリアライザ コンポーネントを作成および構成する。詳細については、「Serializers」を参照してください。

    • メッセージ ポート上書きプロパティを使用するカスタム シリアライザ コンポーネントをチャネル ウィザードで構成する。詳細については、「メッセージ ポート既定値の変更」を参照してください。
  • ローカル ドメイン以外にある仕様を参照するエンベロープを保存すると、エラーが表示されることがあります。エラーが表示される場合は、WinHTTP proxy ユーティリティをダウンロードし、構成します。ユーティリティをダウンロードするには、Microsoft MSDN Web サイト (msdn.microsoft.com/downloads/) の「WinHTTP Proxy Configuration Utility」のページを参照してください。これは、「Web Development」の「XML」の下にあります。

関連項目

エンベロープの作成

エンベロープの編集

エンベロープの検索

エンベロープについて


同報リストの使用

ここでは、同報リストを使用する方法を作業ごとに説明します。「同報リストについて」を参照し、同報リストについて十分に理解しておいてください。

ここには次のトピックが含まれます。

  • 同報リストの作成

  • 同報リストの検索

  • 同報リストの編集

  • 同報リストの削除


同報リストの作成

  1. BizTalk メッセージ マネージャの [ファイル] メニューの [新規作成] をポイントし、[同報リスト] をクリックします。

    [新しい同報リスト] ダイアログ ボックスが表示されます。

  2. [同報リスト名] ボックスに一意な同報リスト名を入力します。

  3. [利用可能なメッセージ ポート] ボックスの一覧で選択するメッセージ ポートをクリックし、[追加] をクリックします。

    選択したメッセージ ポートが [選択されたメッセージ ポート] ボックスの一覧に追加されます。

  4. [選択されたメッセージ ポート] ボックスの一覧に不要なメッセージ ポートがある場合は、そのメッセージ ポートをクリックし、[削除] をクリックします。

  5. 必要なプロパティをすべて設定してから、[OK] をクリックして [新しい同報リスト] ダイアログ ボックスを閉じます。

注

  • 同報リストからメッセージ ポートを削除しても、そのポートは同報リストから削除されるだけで、データベースからは削除されません。

  • 同報リストには少なくとも 1 つのメッセージ ポートが含まれている必要があります。

  • オープンなメッセージ ポートは、同報リストに追加できません。

  • 同報リストが機能するには、少なくとも 1 つのチャネルが必要です。チャネルの詳細については、「チャネルの作成と管理」を参照してください。

関連項目

同報リストの削除

同報リストの編集

同報リストの検索

同報リストについて


同報リストの検索

  1. BizTalk メッセージ マネージャの [その他の項目を検索] で [同報リスト] をクリックします。

  2. 次の操作を 1 つ以上行ってください。
    • すべての同報リストを検索するには、検索条件をすべて消去し、[検索] をクリックします。

    • 特定の名前の同報リストを検索するには、[同報リストの検索] でその同報リストの名前を [同報リスト名] ボックスに入力し、[検索] をクリックします。完全な名前を入力しなくても、その名前のエントリと一致する有効な名前がすべて返されます。

    • 特定のメッセージ ポートを含む同報リストを検索するには、そのメッセージ ポートの名前を [含まれるメッセージ ポート] ボックスに入力し、[検索] をクリックします。

注

  • 検索条件および検索結果をクリアするには、[検索条件のクリア] をクリックします。

  • 検索する対象が多数ある場合、結果が出るまで数分かかることがあります。選択条件を指定することにより、検索結果から対象を絞ることができます。

  • 検索結果として返される既定の件数は 500 です。この値は変更可能です。詳細については、「サーバー接続のオプションの設定」を参照してください。

  • 検索条件では、次のワイルドカード文字を使用できます。
    ワイルドカード文字 | 説明 | 例
    % 0 文字以上の文字列 「%open%」というエントリは、「open」という文字列が含まれるすべての名前を検索します。
    _ (アンダースコア) | 任意の 1 文字 | 「_ean」というエントリは、「ean」で終わる 4 文字の名前を検索します (Dean、Sean など)。
    [ ] 指定された範囲内 ([a-f]) またはセット内 ([abcdef]) の 1 文字 「[C-P]arsen」というエントリは、「arsen」で終わり、C から P の間の 1 文字で始まる名前を検索します (Carsen、Larsen など)。
    [^] 指定された範囲内 ([^a-f]) またはセット内 ([^abcdef]) にない 1 文字 「de[^s]%」というエントリは、「de」で始まり、それに続く文字が「s」でないすべての名前を検索します。

関連項目

同報リストの作成

同報リストの削除

同報リストの編集

同報リストについて


同報リストの編集

  1. BizTalk メッセージ マネージャの [同報リスト名] ボックスの一覧で、編集する同報リストをクリックします。

    同報リストの検索については、「同報リストの検索」を参照してください。

  2. [ファイル] メニューの [編集] をクリックします。

    [同報リストのプロパティ] ダイアログ ボックスが表示されます。

  3. [同報リスト名] ボックスに一意な同報リスト名を入力します。

  4. [利用可能なメッセージ ポート] ボックスの一覧で選択するメッセージ ポートをクリックし、[追加] をクリックして、それらのポートを [選択されたメッセージ ポート] ボックスの一覧に追加します。

  5. [選択されたメッセージ ポート] ボックスの一覧に不要なメッセージ ポートがある場合は、そのメッセージ ポートをクリックし、[削除] をクリックします。

  6. 必要なプロパティをすべて設定してから、[OK] をクリックして [同報リストのプロパティ] ダイアログ ボックスを閉じます。

注

  • 同報リストからメッセージ ポートを削除しても、そのポートは同報リストから削除されるだけで、データベースからは削除されません。

  • 同報リストには少なくとも 1 つのメッセージ ポートが含まれている必要があります。

  • オープンなメッセージ ポートは、同報リストに追加できません。

関連項目

同報リストの作成

同報リストの削除

同報リストの検索

同報リストについて


同報リストの削除

  1. BizTalk メッセージ マネージャの [同報リスト名] ボックスの一覧で、削除する同報リストをクリックします。

    同報リストの検索の詳細については、「同報リストの検索」を参照してください。

  2. [ファイル] メニューの [削除] をクリックします。

注

  • 同報リストに関連付けられているすべてのチャネルを削除するまで、その同報リストは削除できません。

  • 同報リストを右クリックし、[チャネルの検索] をクリックすることにより、その同報リストに関連付けられているチャネルを検索できます。

関連項目

同報リストの作成

同報リストの検索

同報リストについて


仕様の作成とデータのマッピング

Microsoft® BizTalk™ Server 2002 では、ドキュメントの構造を定義し、異なる書式間でデータをマップするために使用できるツールが提供されています。これらのツールを使用して、アプリケーション統合サーバーに必要な基本的なデータ交換情報を作成できます。これらのツールは Extensible Markup Language (XML)、そして Extensible Stylesheet Language (XSL) Transformation (XSLT) などの各種標準に基づいています。

BizTalk エディタを使用すると、業界標準や共通のスキーマに基づいた仕様を作成することも、組織独自の仕様を作成することもできます。

BizTalk マッパーを使用すると、2 つの異なる仕様のレコードやフィールドの間にマップを作成することができます。サーバーはこのマップを使用してデータを処理し、社内で、または取引先との間で共有できる書式にデータを変換します。

ここには次のトピックが含まれます。

  • BizTalk エディタの使用

  • BizTalk マッパーの使用

  • BizTalk エディタと BizTalk マッパーのトラブルシューティング


BizTalk エディタの使用

Microsoft® BizTalk™ エディタは、仕様を作成、編集、および管理することができるツールです。BizTalk エディタは XML-Data Reduced (XDR) 構文を使用します。この構文は、構文、データベース、および概念のスキーマ間で共有する部分を処理するための共通の語彙を提供します。

BizTalk エディタは、ファイルに含まれているレコードとフィールドのプロパティを解釈することによって仕様を作成します。仕様は、オリジナル フォーマットに関わらず、あらゆる構造化データを Extensible Markup Language (XML) で表したものです。また、BizTalk エディタで作成または修正する仕様は、BizTalk マッパーでデータを別の書式に変換するときに使えるように、共通のデータ記述で提供されます。仕様は、ビジネス プロセスにまたがるデータの移植性を提供します。BizTalk エディタでは、次の形式に基づいた仕様を作成できます。

  • 整形式 XML

  • XDR ベースのドキュメント テンプレート

  • XDR スキーマ

  • ドキュメント型定義 (DTD)

  • XML として格納された Microsoft ActiveX® データ オブジェクト (ADO) レコード セット

  • 電子データ交換 (EDI) (X12 および EDIFACT)

  • 区切りフラット ファイルおよび位置指定フラット ファイルなどのフラット ファイル (たとえば、SAP IDOC)、または区切りおよび位置指定のフラットファイル

  • 構造化ドキュメント書式

BizTalk エディタでは、構造が何も含まれていない空の仕様から作成することも、既存のスキーマまたは仕様をインポートすることもできます。たとえば、DTD をインポートできます。DTD は、要素と属性が記述された構造化ファイルで、要素と属性の順序、頻度、および内容に関する制約も含まれています。新しい仕様の作成には、XML、ANSI X12、または EDIFACT などの標準仕様も使用できます。

ドキュメントのインスタンスがインポートされると、BizTalk エディタはドキュメントの構造を解釈し、ドキュメントの XDR で表現した仕様を作成します。BizTalk エディタの仕様ツリーに表示されたレコードとフィールドを必要に応じて編集し、その構造を仕様として保存することができます。インポートできるファイルの種類は、次のとおりです。

  • XDR スキーマ

  • 整形式の XML

  • DTD

各仕様では、特定のタグ セットを利用して、ファイルの構造が記述されます。BizTalk エディタは、注文書、請求書、および事前出荷通知などの一般的なドキュメントの仕様を作成する場合に、ひな形として利用できるテンプレートもいくつか提供しています。

BizTalk Server 2002 によるドキュメント処理では、BizTalk マッパーで作成されたマップを使用して、送信データおよび受信データの仕様書式を別の仕様書式に変換します。

ここには次のトピックが含まれます。

  • BizTalk エディタの詳細については、「BizTalk エディタについて」を参照してください。

  • 特定の作業を実行する理由については、「BizTalk エディタに関する作業を行う目的」を参照してください。

  • 作業を実行する手順の詳細については、「BizTalk エディタに関する作業を行う方法」を参照してください。

  • 問題を解決するためのヒントについては、「BizTalk エディタと BizTalk マッパーのトラブルシューティング」を参照してください。


BizTalk エディタについて

BizTalk エディタは、組織間や取引先間のトランザクションのためのデータを読み取りと書き込みを行う Microsoft BizTalk Server 2002 の一部の初期化で使用される仕様を定義するためのグラフィカル ツールです。ここでは、BizTalk エディタを理解するうえで不可欠な概念について説明します。

ここには次のトピックが含まれます。

  • 仕様について

  • BizTalk エディタの環境

  • ファイルのインポート

  • ファイルのエクスポート

  • レコード、フィールド、およびプロパティ

  • 汎用トリガ

  • 名前空間のサポート

  • SQL コメントの追加

  • XML インスタンスとネイティブ インスタンスの作成

  • インスタンスと仕様の検証


仕様について

仕様とは、BizTalk エディタによって作成される BizTalk Server 固有の Extensible Markup Language (XML) スキーマのことです。仕様は、業界標準 ( XML、EDIFACT、ANSI X12) に基づいて作成することも、非業界標準 (区切りフラット ファイル、 位置指定フラット ファイル、区切りフラット ファイルと位置指定フラット ファイルを組み合わせたファイル、空の仕様、既存のファイル) に基づいて作成することもできます。

業界標準

業界標準によって、企業間でデータを電子的に交換するための共通のデータ交換方法が提供されます。共通のビジネス言語を使用することにより、組織内やほかの企業のコンピュータとの間で通信を行うことができます。業界標準には電子ビジネス トランザクションの形式とデータの内容が指定されています。業界標準に基づいた仕様は、標準のサブセットと見なされます。ユーザーのニーズを満たす仕様を作成するには、業界標準をベースラインにして仕様を作成し、その後で不要なレコードやフィールドを削除します。残したレコードやフィールドのプロパティを変更する場合もあります。

電子データ交換 (EDI) は、一般に利用されている業界標準仕様です。BizTalk エディタは、EDI ドキュメント仕様のサブセットと関連 EDI コード一覧データベースを提供します。これらの仕様は、X12 および EDIFACT 標準の正式に認められた発行者から提供されるデータから直接生成されます。これらの仕様を使用するプロセスを運用環境に実装する前に作成された仕様に対して EDI インスタンスを検証することを強くお勧めします。EDI 仕様および標準の詳細とアップデートについては、Microsoft BizTalk Server Web サイト (www.microsoft.com/japan/biztalkserver/) を参照してください。

非業界標準

非業界標準に基づいた仕様では、BizTalk エディタを使用してドキュメントの構造を定義する必要があります。位置指定フラットファイル、区切りフラット ファイル、位置指定フラット ファイルと区切りフラット ファイルを組み合わせたファイルなど、各種の非業界標準に基づいた仕様の作成に BizTalk エディタを使用できます。フラット ファイルの操作について理解するには、BizTalk Server 2002 に含まれているサンプルを参照してください。区切りフラット ファイルのサンプルは、\Program\FilesMicrosoft BizTalk Server\SDK\Messaging Samples\ の Flat-FileDelimited フォルダにあります。位置指定フラット ファイルのサンプルは、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ の Flat-FilePositional フォルダにあります。

フラット ファイルが区切られて位置指定されている場合は、[解析] プロパティ ページで、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。追加のレコード プロパティは、その属性によって [区切り記号] または [位置指定] のいずれかに設定されます。

フラット ファイルの詳細については、「位置指定フラット ファイルと区切りフラットファイルの操作」を参照してください。

空の仕様

空の仕様は、ルート ノード要素だけを含む仕様です。空の仕様を基にする場合は、仕様構造全体を構築する必要があります。ルート要素の名前を変更し、必要に応じて、ヘッダー情報に属する仕様のルート要素のプロパティ値を変更します。その後、ビジネス プロセスの必要に応じて、レコードやフィールド、それらのプロパティを追加します。

既存の BizTalk Server 2000 ファイル

BizTalk Server 2000 のスキーマは、BizTalk Server 2002 と互換性があります。BizTalk Server 2000 で作成した仕様をBizTalk Server 2002 で開いて、保存すると、ファイル形式が変更されてしまうため、BizTalk Server 2000 を使って再び開くことができなくなります。

ここには次のトピックが含まれます。

  • 仕様構造

  • 標準のサポート

  • 付属 EDI ベースのドキュメントの概要一覧

  • 位置指定フラット ファイルと区切りフラット ファイルの操作

  • XML 名に使用できない文字

  • 無効な文字の範囲

関連項目

フラット ファイルに基づいた仕様の作成

空のテンプレートに基づいた仕様の作成

既存の仕様に基づいた仕様の作成

標準に基づいた仕様の作成

レコード、フィールド、およびプロパティ

位置指定フラット ファイルと区切りフラット ファイルの操作


仕様構造

BizTalk エディタで作成する仕様は、整形式 XML です。仕様構造は、作成の基礎として選択したファイルの種類によって異なります。仕様の基本構造は、種類とは関係なくすべて同じです。たとえば、すべての仕様は <?xml version=""?> タグで始まり、ファイル名や名前空間データなどのヘッダー情報が続きます。残りの構造は、仕様内のレコードやフィールド、およびそのレコードやフィールドに関連付けられた属性に基づいています。仕様の基本コードを表示するには、Microsoft Internet Explorer 5 以降で仕様を開きます。

BizTalk エディタで、特定のBizTalk コメントを付けた XML-Data Reduced (XDR) スキーマを作成することができます。コメントを削除するには、[ツール] メニューの [XDR スキーマのエクスポート] を使用します。詳細については、「XDR スキーマのエクスポート」を参照してください。

[ツール] メニューの [XDR スキーマのエクスポート] を使用すると、XDR スキーマから Extensible (XML) Structure Definitions (XSD) スキーマを作成できます。詳細については、「XSD スキーマのエクスポート 」を参照してください。

関連項目

仕様の作成と検証

XDR スキーマのエクスポート

XSD スキーマのエクスポート


標準のサポート

EDIFACT、ANSI X12 などの電子データ交換 (EDI) 標準には、ビジネス ドキュメントに必要なファイル構造を構成するときに使用できる多数のセグメントとエレメントが定義されています (EDI 標準では、データ フィールドのことを一般にエレメントと表現しています。XML では、要素と表現します)。BizTalk エディタを使って仕様を作成するときは、これらの構造を基本としてまず仕様を作成し、その後で不要なセグメントやエレメントを削除します。最終構造は、取引先との間または同じ組織の社員同士でビジネス データを交換する方法として用いられる標準のサブセットです。

EDIFACT ドキュメントまたは ANSI X12 ドキュメントにノードを作成したり、ノードを移動する場合は、ドキュメント標準を [Custom] に設定してください。また、"区切り記号の種類" プロパティを、変更後の構造がドキュメントの残りの部分と互換性を持つように設定してください。ドキュメント標準の設定を [Custom] から [EDIFACT] または [X12] に戻すと、"区切り記号の種類" プロパティの設定がすべて消失します。塔Jスタム� プロパティの設定の詳細については、「参照のプロパティの設定」を参照してください。"区切り記号の種類" プロパティの設定の詳細については、「解析のプロパティの設定」を参照してください。

BizTalk エディタは X12 構文規則もサポートしています。X12 構文規則は、1 つのレコードについて 2 つ以上のデータ要素間に存在する関係条件です。仕様に構文規則が含まれる場合は、仕様を検証するときに、サーバー実行時プロセスで構文規則が適用されます。

構文規則には次の 5 種類があります。

  • すべて

    TXI08 が存在する場合は、次のノードが存在が存在する必要があります。

    • TXI03
  • グループ化

    次のノードのいずれかが存在する場合は、両方が存在する必要があります。

    • TXI04

    • TXI05
  • 任意

    次のノードのうちの 1 つ以上が存在する必要があります。

    • TXI02

    • TXI03

    • TXI06
  • 1 つ

    次のノードのうちの 1 つだけ存在できます。

    • TXI02

    • TXI03

    • TXI06
  • 任意 (条件付き）

    PO413 が存在する場合は、次のノードのうちの 1 つ以上が存在する必要があります。

    • PO410

    • PO411

    • PO412

関連項目

仕様の作成と検証

メモの編集と構文規則の表示

参照のプロパティの設定

付属 EDI ベースのドキュメントの概要一覧


付属 EDI ベースのドキュメントの概要一覧

BizTalk エディタは EDI ベースのドキュメントをサポートしています。次の表は、標準に基づいた新しい仕様を作成するとき使用できる EDI ベースのドキュメントの標準、バージョン、およびドキュメント標準を一覧表示しています。詳細については、「標準に基づいた仕様の作成」を参照してください。

標準 バージョン ドキュメント標準
ANSI X12
  • 2040

  • 3010

  • 3060

  • 4010
  • 810

  • 832

  • 846

  • 850

  • 852 (2040 以外のすべてのバージョンで利用可能)

  • 855

  • 856

  • 861

  • 864

  • 867

  • 940 (3060 と 4010 バージョンのみで利用可能)

  • 944 (3060 と 4010 バージョンのみで利用可能)

  • 997
EDIFACT
  • D93A

  • D95A

  • D95B

  • D97B

  • D98A

  • D98B
  • APERAK (D93A 以外のすべてのバージョンで利用可能)

  • CONTRL (D98A と D98B バージョンのみで利用可能)

  • DESADV

  • INVOIC

  • INVRPT

  • ORDERS

  • ORDRSP

  • PARTIN

  • PAYEXT

  • PRICAT

  • PRODAT (D97B、D98A、D98B バージョンのみで利用可能)

  • RECADV (D97B、D98A、D98B バージョンのみで利用可能)

  • SLSRPT
XML
  • なし
  • BTF1 Envelope

  • CanonicalReceipt

  • CommonAdvancedShipNotice

  • CommonInventoryAdvice

  • CommonInvoice

  • CommonPartnerProfile

  • CommonPO

  • CommonPOAcknowledgment

  • CommonPriceCatalog

  • CommonShippingAdvice

  • CommonShippingOrder

  • Simple SOAP Envelope

関連項目

標準に基づいた仕様の作成


位置指定フラット ファイルと区切りフラット ファイルの操作

BizTalk エディタは、位置指定フラット ファイル、区切りフラット ファイル、位置指定と区切りを組み合わせたファイル構造の仕様を作成しやすいように設計されています。ここでは、これらのファイル構造について説明します。

位置指定フラット ファイル

位置指定フラット ファイルは、同じ固定長を持つ複数のフィールドと、共通のレコード終端記号を持つ複数のレコードで構成されます。受信ファイルの構造は送信元仕様で定義するレコードとフィールドから成り、フィールドの位置情報を設定する必要があります。したがって、送信元仕様のドキュメント構造を定義する前に、必要なレコードとフィールドのレイアウトを取得してください。

次の表は、固定形式の例を示しています。

名前 | 住所 | 市区町村 | 電話番号
Xxxxxxxxxx | Aaaaaaaaaa | Ccccccccccccccc | xxx-xxx-xxxx
Yyyyyyyyyy | Bbbbbbbbbb | Ddddddddddddd | xxx-xxx-xxxx

"名前" フィールドは 10 文字以下、"住所" フィールドは 10 文字以下、"市区町村" フィールドは 15 文字以下、"電話番号" フィールドは 12 文字以下に、それぞれ固定されています。レコード区切り記号は、復帰文字 CR または改行文字 LF、あるいはその両方 CRLF です。

BizTalk エディタを使用して、連続するレコードやフィールドを作成できます。複数の種類のレコードを作成し、親レコードにそれぞれ異なる区切り記号を割り当てることができます。複数の種類のレコードを含む構造の場合は、それらの種類とレコード区切り記号 の仕様も、ドキュメント内の出現順に指定する必要があります。フィールドについては、開始位置、長さ、およびデータ型を指定します。

仕様を位置指定ファイル構造から区切りファイル構造に変更した場合は、[参照] タブで指定した元の開始位置と終了位置が、コンパイル後の仕様に含まれます。ただし、BizTalk Server 2002 によって仕様が解析されるときは、パーサーはこの情報を無視し、仕様を区切りファイルとして処理します。

位置指定レコードは、常に区切られたレコードの子になっている必要があります。親の区切られたレコードに指定された区切り記号は、子の位置指定レコードのデータに表示されることはありません。子の位置指定フィールドのデータで、親の区切られたレコードの区切り記号をエスケープすることはできません。区切り記号とエスケープ記号の詳細については、「解析のプロパティの設定」を参照してください。

位置指定フラット ファイルの操作を理解するには、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ の Flat-FilePositional フォルダのサンプルを参照してください。

注

  • フラット ファイルが区切られて位置指定されている場合は、[解析] プロパティ ページで、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。追加のレコード プロパティは、その属性によって [区切り記号] または [位置指定] のいずれかに設定されます。

区切りフラット ファイル

区切りフラット ファイルには、区切り記号で区切られた 1 つ以上のレコードが含まれます。BizTalk エディタでは区切り記号はデータとして読み取られません。ただし、区切り記号文字をデータとして使用する場合は、データと区切り記号が区別できるようにデータの書式を設定します。たとえば、区切り記号文字を含むフィールドを引用符で囲むことによって、その区切り記号文字を区切り記号としてではなくデータとして処理する必要があることを示すことができます。

BizTalk エディタでは、個々のフィールドと、それらのフィールドに関連付ける区切り記号を選択できます。レコード区切り記号を指定することもできます。区切りフラット ファイルを使用できるようにするため、BizTalk エディタでは次のものがサポートされています。

  • 複数のレコード グループから成る構造

  • レコードの種類タグで定義された複数のレコードの種類

  • レコード区切り記号

  • フィールド データと区切り記号値とを区別する、囲み文字とエスケープ文字

  • フィールドの開始位置、長さ、および種類の値

  • フィールドのコンテンツ タグと記述

  • フラット ファイルを、BizTalk マッパーで処理できる仕様に変換する機能

区切りフラット ファイルの操作を理解するには、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ の Flat-FileDelimited フォルダのサンプルを参照してください。

注

  • フラット ファイルが区切られて位置指定されている場合は、[解析] プロパティ ページで、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。追加のレコード プロパティは、その属性によって [区切り記号] または [位置指定] のいずれかに設定されます。

関連項目

フラット ファイルに基づいた仕様の作成


XML 名に使用できない文字

xF900 ～ xFFFE の Unicode 文字は Extensible Markup Language (XML) 名に使用できません。XML 名に無効な Unicode 文字を使用した場合、仕様ツリーでその XML 名が表示されるとき、無効な文字はエスケープされた数値エンティティに変換されます。エスケープされた数値エンティティは _xHHHH_ のようにエンコードされます。HHHH は 4 桁の 16 進数 Unicode コードです。たとえば、注文書仕様の中の Ship To という名前にはスペース文字が使用されていますが、仕様ツリーでは Ship_x0020_To と表示されます。エンコードされた Unicode 文字が含まれるノードの上にマウス ポインタを移動すると、エンコードされていない Unicode 文字を含むノード名が ToolTip に表示されます。これは、BizTalk エディタまたは BizTalk マッパーで仕様ツリーを表示したときに発生します。

関連項目

仕様の作成と検証

ドキュメント インスタンスの検証


無効な文字の範囲

BizTalk Server 2002 で特定の文字または文字範囲を出力しないようにすることができます。それには、BizTalk エディタで、送信先仕様として使う仕様を開きます。［無効な文字コード範囲] ダイアログ ボックスを開き、出力しないようにする文字または文字範囲を入力します。出力仕様の [無効な文字コード範囲] ダイアログ ボックスで指定した文字を BizTalk Server が処理しようとすると、処理が停止し、エラー メッセージが表示されます。

注

  • 文字範囲の出力を抑止できるのは、非 Extensible Markup Language (XML) ドキュメントに対してだけです。

関連項目

無効文字範囲の追加

無効文字範囲の削除

無効文字範囲の編集

BizTalk マッパーの使用


BizTalk エディタの環境

BizTalk エディタ を開いた時に表示されるグラフィカル ユーザー インタフェースによって、仕様の作成と操作を簡単に行うことができます。

ここには次のトピックが含まれます。

  • BizTalk エディタのユーザー インターフェイス

  • BizTalk エディタのメニュー

  • BizTalk エディタのツール バーのボタン


BizTalk エディタのユーザー インターフェイス

BizTalk エディタのユーザー インターフェイスには 3 つのメイン ウィンドウがあります。左側のウィンドウには、仕様をグラフィカルに表現した仕様ツリーが表示されます。仕様ツリー内のトップ ノードはルート ノードであり、ブック アイコン [image] で表されます。仕様階層のルート ノードの下にレコードとフィールドが表示されます。レコードは緑色の横線のあるドキュメント アイコン レコード ノード で表されます。フィールドは青色の縦線のあるドキュメント アイコン フィールド ノード で表されます。レコードとフィールドの詳細については、「レコード、フィールド、およびプロパティ」を参照してください。仕様ツリー内のノードは、左側にある展開記号 (+) または折りたたみ記号 (-) をクリックすることにより、展開したり、折りたたむことができます。

右側のウィンドウには、[宣言]、[参照]、[解析]、[名前空間]、[ディクショナリ]、[コード一覧] という 6 つのタブが表示されます。これらのプロパティ ページを使用して、仕様内のノードのプロパティ値、名前空間、ディクショナリのプロパティ、コード一覧を設定できます。これらのプロパティ ページの詳細については、「レコードとフィールドのプロパティの指定」を参照してください。

下のウィンドウには、[出力] と [警告] というタブが表示されます。[出力] プロパティ ページには、BizTalk エディタの [XML インスタンスの作成] コマンドを使用して作成された Extensible Markup Language (XML) ドキュメント インスタンスか、または [ネイティブ インスタンスの作成] コマンドを使用して作成されたフラット ファイルが表示されます。仕様から XML ドキュメント インスタンスを作成する方法の詳細については、「ドキュメント インスタンスの作成」または「ネイティブ インスタンスの作成」を参照してください。[警告] タブには、仕様に対するドキュメント インスタンスの検証が成功したかどうかが表示され、失敗したドキュメント検証に関する警告が表示されます。詳細については、「ドキュメント インスタンスの検証」を参照してください。

関連項目

ドキュメント インスタンスの作成

ネイティブ インスタンスの作成

レコードとフィールドのプロパティの指定

ドキュメント インスタンスの検証


BizTalk エディタのメニュー

BizTalk エディタのメニューは、コマンドを論理的にまとめることで、作業を簡単に実行できるようになっています。たとえば、[表示] メニューのコマンドを使用して、仕様ツリー内のすべてのレコードとフィールドを表示したり、折りたたむことができます。

BizTalk エディタのメニューは次のとおりです。

  • [ファイル] : 仕様を作成する、開く、保存する、および閉じることができます。

  • [編集] : 仕様内のレコードやフィールドの切り取り、コピー、貼り付け、挿入、名前の変更、および削除を行うことができます。

  • [表示] : このメニューを使用して、次の操作を行います。
    • ユーザー インタフェースの右側のウィンドウのビューを選択する。

    • ユーザー インタフェースの下側のウィンドウのビューを選択する。

    • BizTalk エディタ画面に表示するテキスト サイズを選択する。

    • [無効な文字コード表] ダイアログ ボックスを表示する。

    • 仕様ツリーを展開または折りたたむ。

    • [警告] プロパティ ページで次の警告を強調表示にする。。
  • [ツール] : このメニューを使用して、次の操作を行います。
    • 仕様を検証する。

    • 仕様に対してドキュメント インスタンスを検証する。

    • 仕様から Extensible Markup Language (XML) ドキュメント インスタンスまたはネイティブ インスタンスを作成する。

    • ファイルをインポートする。

    • XML-Data Reduced (XDR) スキーマまたは XSD スキーマをエクスポートする。

    • BizTalk エディタのオプションを表示する。
  • [ヘルプ] : BizTalk エディタの概念についての説明、このエディタでのさまざまな作業の意義、およびエディタ使用上の手順を表示することができます。

関連項目

BizTalk マッパーのメニュー


BizTalk エディタのツール バーのボタン

BizTalk エディタには、メニュー バーを補うためのツール バーが用意されています。ツール バーのすべてのボタンは、それが実行する作業を表すグラフィックで表示されます。左から右へ、次の順序で並んでいます。

  • [新規作成]

  • [開く]

  • [保存]

  • [WebDAV から取得]

  • [WebDAV に格納]

  • [仕様ノードの切り取り]

  • [仕様ノードのコピー]

  • [仕様ノードの貼り付け]

  • [仕様ノードの削除]

  • [新しいレコード]

  • [新しいフィールド]

  • [レコードの挿入]

  • [フィールドの挿入]

  • [折りたたみ]

  • [展開]


ファイルのインポート

BizTalk エディタでファイルをインポートすることができます。インポートによりファイル構造が作成されますが、すべてのレコードとフィールドのプロパティ値を割り当てる必要があります。BizTalk エディタにインポートできるのは、以下のファイルの種類です。

  • 整形式 XML インスタンス

  • ドキュメント型定義 (DTD)

  • XML-Data Reduced (XDR) スキーマ

  • 整形式 XML のインポート モジュールを使用した Microsoft Office ファイル

しかし、別のファイルに対する外部参照を含んでいるファイルをインポートすることはできません。BizTalk エディタが整形式 XML インスタンス、DTD、XDR スキーマ、または Microsoft Office ファイルをインポートすると、インポートしたファイルに基づく構造が作成され、レコードとフィールドのセットが表示されます。しかし、インポートするファイルに含まれている要素が、「コンテンツが含まれている」、「インスタンス データで繰り返されている」、「子がない」という 3 つの条件を満たしている場合は、BizTalk エディタは構造をインポートするときに、この要素をレコードではなくフィールドとして作成します。BizTalk エディタでファイルを保存すると、そのファイルは仕様になります。この仕様は適切なヘッダー情報を持ち、指定された構造に従っています。

BizTalk エディタは、ルート ノードにする要素を特定することができます。しかし、適切なルート ノード要素の特定が自動的に行われない場合は、ダイアログ ボックスが表示されるので、ここでルート ノードになる要素を指定します。ただし、<スキーマ> ノードが name="a_name" 属性を持っていると、BizTalk エディタはこの要素名をルート ノードとして使用し、たとえ複数の候補があったり、または name によって指示されるルートが循環と関係していても、ルート ノードの選択は求められません。ルート ノードを選択できるようにするには、XDR ファイルを開いて、name="a_name" 属性を削除しなければなりません。その上でファイルをインポートすると、BizTalk エディタからルート要素の選択を求められます。

ここには次のトピックが含まれます。

  • 整形式 XML のインポート

  • DTDのインポート

  • XDR スキーマのインポート

  • Microsoft OfficeXP ファイルのインポート

関連項目

インポート ファイルに基づいた仕様の作成


整形式 XML のインポート

整形式 Extensible Markup Language (XML) は、インポートされる任意のMicrosoft Office ファイルを含みます。XDR スキーマを含んでいる整形式 XML インスタンスをインポートすることはできません。整形式 XML ファイルをインポートするとき、BizTalk エディタはデータ型パラメータとフィールド長パラメータを解釈できません。BizTalk エディタは、整形式 XML ファイルをインポートしてから、循環参照に関する警告を表示することがあります。その場合は、警告に従って処置を行い、仕様を保存してから処理を続行することを強くお勧めします。

ルート ノードの名前空間を含む整形式 XML ファイルをインポートすると、名前空間は対象の名前空間になり、仕様のほかの部分では無視されます。対象の名前空間の詳細については、「参照のプロパティの設定」を参照してください。

関連項目

インポート ファイルに基づいた仕様の作成


DTD のインポート

ドキュメント型定義 (DTD) をインポートするとき、BizTalk エディタはデータ型パラメータとフィールド長パラメータを解釈できません。データ型が独特なかたちで処理される特殊な場合があります。次の表はそのようなケースの一部です。

存在するデータ型 | DTD ファイルの処理
"entity" および "entities" | ファイルをインポートできますが、データ型が削除されます。
"nmtoken" および "nmtokens" | ファイルをインポートできますが、データ型が削除されます。
"notation" | ファイルをインポートできますが、データ型は列挙型としてインポートされます。

DTD の最終行がエンティティ参照 ("%xx" など) になっている場合は、BizTalk エディタにインポートできません。しかし、行終端文字がある DTD の最後に新しい行を作成すると、BizTalk エディタにインポートできるようになります。

DTD に複数のルートがあるとき、BizTalk エディタはインポート中にあらゆる置換について必ず警告を出すとはかぎりません。

また、要素内にコメントを含んでいる DTD はインポートできません。これらの DTD を正常にインポートするには、当該ファイルを編集して、要素内のすべてのコメントを削除します。

関連項目

インポート ファイルに基づいた仕様の作成


XDR スキーマのインポート

XML-Data Reduced (XDR) スキーマをインポートするとき、一部のデータ型は BizTalk エディタによって独特なかたちで処理されます。次の表はそのようなデータ型の一部です。

存在するデータ型 | XDR スキーマ ファイルの処理
"entity" および "entities" | ファイルをインポートできません。
"nmtoken" および "nmtokens" | ファイルをインポートできますが、データ型が削除されます。
"notation" | ファイルをインポートできません。

型 IDREFS の属性の既定値が属性宣言で指定されていると、XDR スキーマはインポートできません。たとえば、次のようなコードがあるとします。

<AttributeType name="Field1" d:type="idrefs" default="a1 a2"> </AttributeType>
<attribute type="Field1" required="no"></attribute>

この問題の解決策は、XDR スキーマを BizTalk エディタにインポートする前に、その属性参照の既定値を次のコードのように移動することです。

<AttributeType name="Field1" d:type="idrefs"> </AttributeType>
<attribute type="Field1" required="no" default="a1 a2"></attribute>

関連項目

インポート ファイルに基づいた仕様の作成


Microsoft Office XP ファイルのインポート

BizTalk エディタは ss Microsoft Office XP 名前空間を削除しますが、ほかのカスタム名前空間は削除されません。しかし、カスタム名前空間のプレフィックスは置換されます。たとえば、0:abc は 0_abc になります。Microsoft Excel スプレッドシート (XML ファイルとして保存されている) が次の情報を含んでいるものとします。

<Workbook xmlns="urn:schemas-microsoft-com:office:spreadsheet"
 xmlns:o="urn:schemas-microsoft-com:office:office"
 xmlns:x="urn:schemas-microsoft-com:office:excel"
 xmlns:ss="urn:schemas-microsoft-com:office:spreadsheet"
 xmlns:html="http://www.w3.org/TR/REC-html40">

この場合、BizTalk エディタは、対象の名前空間 xmlns がプレフィックス付きの名前空間 xmlns:ss と同じであると認識します。したがって、BizTalk エディタは、スキーマ全体を通じで ss プレフィックスを重複的に使用せず、ss プレフィックスがあると、それを省略します。というのも、それは対象の名前空間として定義されているものとまったく同じ名前空間であるからです。

関連項目

インポート ファイルに基づいた仕様の作成


ファイルのエクスポート

新規および既存の仕様は、BizTalk エディタで開いているときにだけエクスポートできます。仕様をエクスポートすると、構造から BizTalk エディタ固有のコメントが削除され、残った構造は、ほかのアプリケーションで使用できる一般的なスキーマとして保存されます。XML-Data Reduced (XDR) スキーマと Extensible (XML) Structure Definitions (XSD) スキーマの両方をエクスポートできます。

また、BizTalk Server 2002 のサーバー インストールで提供される変換スクリプトによって、XDR スキーマから XSD スキーマを作成できます。

関連項目

XDR スキーマのエクスポート

XSD スキーマのエクスポート


レコード、フィールド、およびプロパティ

BizTalk エディタでは、仕様のレコードとフィールドは、所定の順序でツリー形式で表示されます。この構造内で、レコードとフィールドを使用して親子関係を作成できます。レコードにはほかのレコードやフィールドを含めることができますが、フィールドにはほかのフィールドやレコードを含めることができません。レコードは常に要素ですが、フィールドは要素、属性のどちらでもかまいません。

レコードとフィールドをレコードに追加および挿入することも、またレコードとフィールドをフィールドに挿入することもできます。レコードまたはフィールドをフィールドに追加することはできません。次の図は、ツリー中の特定のノードとの関係でレコードとフィールドがどのような配置されるかを示しています。

[空の仕様] を選択して、[新しいレコード] ボタンをクリックすると [レコード1] が作成され、[新しいフィールド] ボタンをクリックすると [フィールド1] が作成されますこれは、図の A の部分として表されています。[レコード1] を選択して、[新しいレコード] ボタンをクリックすると [レコード2] が作成され、[新しいフィールド] ボタンをクリックすると [フィールド1] ([レコード2] の下にあるフィールド) が作成されます。これは、図の B の部分として表されています。[レコード1] を選択して、[レコードの挿入] ボタンをクリックすると [レコード3] が作成され、[フィールドの挿入] ボタンをクリックすると [フィールド3] が作成されますこれは、図の C の部分として表されています。

仕様ツリーはレコードとフィールドをノードとして表したものです。仕様ツリーを使用すると、仕様内のすべてのレコードとフィールドの表示、作成、編集、削除を容易に行うことができます。仕様ツリー内のノードはそれぞれ、プロパティ定義のセットを持っています。プロパティ定義は、BizTalk エディタのメイン ウィンドウの [宣言]、[参照]、[解析]、[名前空間]、[ディクショナリ]、[コード一覧] という 6 つのプロパティ ページに表示されます。これらのプロパティ ページに表示されるデータは、BizTalk エディタを使用してドキュメントを元の形式から Extensible Markup Language (XML) に変換するために必要です。これらのプロパティで、ドキュメントの構造、ドキュメントが位置指定ファイルか区切りファイルか、データの順序と長さ、およびデータの形式を定義します。

ここには次のトピックが含まれます。

  • レコードとそのプロパティ

  • サポートされている X12 の時刻書式

  • 混在したコンテンツのサポート

  • フィールドとそのプロパティ

  • フィールド位置の計算

  • 文字数の制限

  • コード一覧の値と説明

  • 埋め込み文字

  • プロパティの範囲

  • 循環参照

  • 既定値の統合

  • データ型とデータ型値の概要


レコードとそのプロパティ

作成する仕様の種類によっては、レコードの追加や削除が必要になる場合があります。仕様にレコードを追加したら、プロパティの指定が必要です。レコードを削除すると、そのレコードのプロパティ、およびそのレコードの子レコードとフィールドもすべて削除されます。

X12 または EDIFACT に基づいた仕様を作成する場合は、追加できるのはその標準にある種類のレコードだけですが、どんな種類のレコードでも削除できます。空の仕様に基づいた仕様を作成する場合は、レコードを追加する必要があります。既存の仕様に基づいて新しい仕様を作成するときなど、場合によっては、レコードの追加や削除が必要なこともあります。

レコードを追加または挿入する場合は、その場でレコードの名前を変更できます。既存のレコードの名前とそのプロパティを編集するには、対象のレコードを選択し、編集します。

既存のレコードと同じ名前のレコードを仕様に貼り付けると、貼り付けたレコードの名前の終わりに数字が付加されます。

既存のレコードの新しいインスタンスを作成する方法の詳細については、「既存のレコードの新しいインスタンスの作成」を参照してください。循環参照を作成する方法の詳細については、「循環参照の作成」を参照してください。

関連項目

既存のレコードの新しいインスタンスの作成

循環参照の作成

プロパティの範囲

レコードとフィールドのプロパティの指定


サポートされている X12 の時刻書式

BizTalk エディタでサポートされている X12 構文の時刻書式 (スキーマのルート ノードの [参照] プロパティ ページで standard=X12 として示される) は HHMMSSDD で、次のようになっています。

  • HH は時間を表します。有効な入力は 00 から 23 までです。

  • MM は分を表します。有効な入力は 00 から 59 までです。

  • SS は秒の整数部分を表します。有効な入力は 00 から 59 までです。

  • DD は秒の少数部分を表します。秒の小数部分の表現には、次の 2 つの書式があります。
    • D は 10 分の 1 秒を表します。有効な入力は 0 から 9 までです。

    • DD は 100 分の 1 秒を表します。有効な入力は 00 から 99 までです。

      時刻を 10 分の 1 秒または 100 分の 1 秒の精度で表す場合は、「カスタム日付/時刻書式プロパティの適用」で説明している [カスタム日付/時刻書式] データ型を使用してください。

    この書式では、前に示している入力範囲制限を満たすデータは、4 桁、6 桁、7 桁、または 8 桁の長さになります。つまり、HHMMSSDD の時刻書式で指定するとき、インスタンス データは HHMM、HHMMSS、HHMMSSD、またはHHMMSSDD のいずれかと一致しなければなりません。

  • XML は 10 分の 1 秒や 100 分の 1 秒をサポートしていないので、HHMMSSDD カスタム書式を利用するすべての時刻フィールドは文字列として扱われます。[ネイティブ インスタンスの作成] は HHMMSSDD カスタム書式を作成しません。


混在したコンテンツのサポート

BizTalk エディタは、XDR スキーマをネイティブに使用する組織のために、混在したコンテンツをサポートしています。スキーマが混在したコンテンツを持っていると、要素はテキスト コンテンツとサブ要素の両方を含んでいることになります。[宣言] プロパティ ページの [コンテンツ] 値として [混合] を選択することによって、スキーマのコンテンツを混在として指定することができます。この属性が適用されるのは Extensible Markup Language (XML) ドキュメント型に対してだけです。またこの属性を指定できるのはスキーマのレコード レベルに対してだけであり、フィールド レベルでは指定できません。

次の例は、”混合” プロパティ値をもつスキーマのサンプルです。

<ElementType name="ProgramManager" content="mixed">
<element  type="Name" >
<element type="OfficeNumber" >
</ElementType>

次の例は、XML インスタンスを表すスキーマのサンプルです。

<ProgramManager>
A program manager named <Name>Mike Hines</Name> works in office <OfficeNumber>2234</OfficeNumber>.
</ProgramManager>

前の例で、<Program Manager> 要素のコンテンツが BizTalk マッパーの送信元仕様ツリーから送信先仕様のレコードに対してリンクされると、その結果は次のようになります。

A program manager named Mike Hines works in office 2234.

関連項目

宣言のプロパティの設定


フィールドとそのプロパティ

作成する仕様の種類によっては、レコードの追加や削除が必要になる場合があります。フィールドは、電子データ交換 (EDI) の要素に対応しています。EDI ドキュメントなどの仕様にフィールドを追加したら、プロパティ値の指定が必要です。

X12 または EDIFACT に基づいた仕様を作成する場合は、追加できるのはその標準にある種類のフィールドだけですが、どんな種類のフィールドでも削除できます。空の仕様に基づいた仕様を作成する場合は、フィールドを追加する必要があります。ドキュメント型に関係なく、すべてのフィールドのプロパティを変更できます。

仕様に新しいフィールドを追加または挿入すると、既定では、[宣言] プロパティ ページにある "種類" プロパティが [属性] に設定されます。すべてのフィールドに対して、この値を手動で [要素] に変更できます。新しいフィールドを作成し、"種類" プロパティを既定で [要素] に設定する方法の詳細については、「新しいフィールドを要素として作成」を参照してください。

フィールドを追加または挿入する場合は、その場でフィールドの名前を変更できます。既存のフィールドの名前とそのプロパティを編集するには、対象のフィールドを選択し、編集します。

既存の要素フィールドと同じ名前の要素フィールドを仕様に貼り付けると、貼り付けたフィールドの名前の終わりに数字が付加されます。既存の兄弟フィールドと名前も "種類" プロパティ値も同じフィールドを仕様に貼り付けると、貼り付けたフィールドの名前の終わりに数字が付加されます。"種類" プロパティ値の詳細については、「宣言のプロパティの設定」を参照してください。既存の要素フィールドの新しいインスタンスを作成する方法の詳細については、「既存の要素フィールドの新しいインスタンスの作成」を参照してください。

関連項目

新しいフィールドを要素として作成

既存の要素フィールドの新しいインスタンスの作成

プロパティの範囲

宣言のプロパティの設定

レコードとフィールドのプロパティの指定


フィールド位置の計算

BizTalk エディタでは、位置指定レコード (ルート ノードの [参照] プロパティ ページの "標準" プロパティが [Custom] で、[解析] プロパティ ページの "構造" プロパティが [位置指定] であるレコード、または、ルート ノードの [参照] プロパティ ページの "標準" プロパティが [Custom] で、[解析] プロパティ ページの "構造" プロパティが [区切り記号] で、レコードの [解析] プロパティ ページの "構造" プロパティが [位置指定] であるレコード) 内のすべてのフィールドの開始位置と終了位置が、自動的に計算されます。まず、位置指定レコード内の各フィールドについて、[宣言] プロパティ ページの [データ型] と [最大値] の値を設定します。次に、位置指定レコードを右クリックし、ショートカット メニューの [フィールド位置の計算] をクリックします。レコードにあるフィールドの開始位置と終了位置が自動的に計算されます。詳細については、「フィールド位置の自動計算」を参照してください。

レコードのフィールド位置は、レコード内の最初のフィールドから最後のフィールドまで順次計算されます。"最大値" プロパティの値が設定されていないフィールドが検出された場合は、そのフィールド、および同一レコード内のすべての後続フィールドの開始位置と終了位置は計算されません。[最大値] が 1 に設定されているフィールドの開始位置と終了位置は同じです。兄弟レコードが検出された場合は、その兄弟レコードのすべての後続フィールドの開始位置と終了位置は計算されません。

位置指定レコード内のフィールドの開始位置と終了位置が指定されている場合は、フィールド位置の計算を行うと、最初のフィールドの開始位置を除くすべての位置が上書きされます。フィールド位置の計算を行うと、既に設定されている場合を除き、位置指定レコード内の最初のフィールドの [開始位置] は 1 に設定されます。位置指定レコード内の最初のフィールドの [開始位置] が既に設定されている場合は、その値から計算が開始されます。また、位置指定レコードのフィールド位置の計算では、すべての子孫レコードに含まれるフィールドの位置も計算されます。レコードの前の兄弟フィールドの位置は計算されますが、レコードの後ろの兄弟フィールドの位置は計算されません。

フィールド位置の計算では、[送信元のタグ識別子] も考慮に入れられます。たとえば、位置指定レコードのプロパティが次のように設定されているとします。

  • [送信元のタグ識別子] は "TAG" です。

  • [送信元のタグ位置] は 10 です。

  • [最大値] の値が 2、5、8、および 6 の 4 つのフィールドがあります。

  • 最初のフィールドの [開始位置] の値はありません。

4 つのフィールドの開始位置と終了位置は、次のようになります。

  • フィールド 1 = 1, 2

  • フィールド 2 = 3, 7

  • 未使用 = 8, 9

  • TAG = 10, 12

  • フィールド 3 = 13, 20

  • フィールド 4 = 21, 26

[送信元のタグ位置] が 1 であれば、"TAG" の開始位置と終了位置の値は 1 と 3 になり、フィールド カウントは位置 4 から開始されます。

関連項目

フィールド位置の自動計算


文字数の制限

名前やプロパティ値に使用できる文字数には制限があります。次の表は、BizTalk エディタでの文字数の制限を示しています。

名前またはプロパティ値 | 最大文字数
ノード名 (ルート ノード名、レコード名、フィールド名) | 255
名前空間プレフィックス | 64
文字列プロパティ値 | 1024
LONG プロパティ値 | 11
ULONG プロパティ値 | 10
CHAR プロパティ値 | 1
電子データ交換 (EDI) 書式プロパティ値 (EDI 固有の書式プロパティの値。たとえば、EDI ベースの仕様内のフィールドの [解析] プロパティ ページの [カスタム日付/時刻書式]) | 15
対象の名前空間 | 255
仕様名 | 255

関連項目

宣言のプロパティの設定

参照のプロパティの設定

解析のプロパティの設定

名前空間の宣言

ディクショナリ プロパティの設定


コード一覧の値と説明

[コード一覧] プロパティ ページに ANSI X12 または EDIFACT のコード値とその説明が表示されます。ANSI X12 標準または EDIFACT 標準に基づいた仕様だけがコード一覧を持っています。説明で各コードの意味を定義しています。たとえば、多くの標準ドキュメント仕様の 棟Z所修飾子� フィールド に表示されているコード値 ST は、出荷先アドレスの情報です。一覧内のコードは変更も削除もできません。コードをフィールドに関連付けるかどうかだけを選択できます。

ANSI X12 または EDIFACT に基づいた仕様のすべてのフィールドに対してコードが関連付けられているわけではありません。フィールドがコード一覧参照を持っている場合は、そのフィールドで利用可能なコードの完全な一覧が [コード一覧] プロパティ ページに表示されます。コードの横の [値] 列のチェック ボックスがオンになっている場合は、そのフィールドに対してコードが有効です。[説明] 列に、コードに関する説明が表示されます。コードをフィールドに関連付ける場合は、[宣言] プロパティ ページの "種類" プロパティの値を [属性] に設定する必要があります。

フィールドに関連付けられたコードを有効にするには、[コード一覧] プロパティ ページのコードの横の [値] 列のチェック ボックスをオンにし、コードを無効にするにはチェック ボックスをオフにします。コードは数値または英字値、または数値と英字値の組み合わせで一覧表示されます。値は特定の説明を表しています。コード値を仕様ツリー内の任意のフィールドに関連付けることができます。たとえば、注文書 ANSI X12 850 の BEG02 フィールドでコード OS を選択すると、このフィールドに特定のオーダー情報が含まれることを示す属性が追加されます。

カスタム構造がコード一覧に与える影響

ANSI X12 または EDIFACT に基づいた仕様の構造をカスタムに変更し、その後、再び ANSI X12 または EDIFACT に基づいた構造に戻した場合は、[コード一覧] プロパティ ページから特定のフィールドのコード一覧の表示が消失することがあります。このような場合は、仕様を保存して、再び開いてください。そのフィールドのコード一覧が [コード一覧] プロパティ ページに再び表示されます。

コード一覧データベースの場所

BizTalk Server 2002 で提供される EDI ベースの仕様テンプレートのコード一覧の値と説明は、Microsoft Access データベース ファイルにあります。ファイルの場所は、\Program Files\Microsoft BizTalk Server\XML Tools\Databases\CodeLists\CodeListsX12a.mdb です。このデータベースに、新しい仕様テンプレートで新しくテーブルを作成する場合、そのテーブル名は <標準>_<バージョン> の書式をとります。たとえば、仕様テンプレートが D99A EDIFACT である場合、対応するテーブル名は EDIFACT_D99A になります。

重要

  • CodeListsX12a.mdb データベースで新しいテーブルを作成する場合は、無効な Extensible Markup Language (XML) 文字 (F900 から FFFE の Unicode 文字) をテーブルの [値] 列に使用しないでください。保存した仕様が、コード一覧のある値が選択されたフィールドを含んでいて、そのコード一覧の値が、無効な XML 文字を持つテーブルの値に関連付けられている場合、保存した仕様は開くことができません。

関連項目

コードの消去

コードの選択

レコードとフィールドのプロパティの指定


埋め込み文字

BizTalk エディタでは、必要な出力を得られるよう区切りドキュメントの埋め込み文字を管理できます。BizTalk Server 2002 で処理する区切りドキュメントは、マッピングの前に Extensible Markup Language (XML) に変換する必要があるので、ドキュメント仕様の中で、区切りドキュメント インスタンスの埋め込み文字の処理方法を指示する必要があります。たとえば、区切りドキュメント インスタンス内に次のようなフィールドがあるとします。

Green*****

フィールドのデータ コンテンツは Green、フィールドは左揃え、データ コンテンツの右側に埋め込み文字が 5 つあり、埋め込み文字はアスタリスク (*) です。

ドキュメント インスタンス内のフィールドに対応する仕様内のフィールドに埋め込み文字を定義しなかった場合は、5 つのアスタリスクはフィールドのデータ コンテンツの一部であると解釈されます。このフィールドの埋め込み文字が正しく処理されるようにするには、[解析] プロパティ ページでこのフィールドのプロパティを次の表に示すとおりに設定します。

プロパティ | 値
位置揃え | [左揃え]
埋め込み文字 | *
埋め込み文字を含めた最小値 | 出力インスタンスのこのフィールドの長さを特定の長さ以上にする場合は、このプロパティ値を設定してください。フィールドに埋め込み文字が挿入され、出力インスタンスのフィールドの最小値が変更されます。

"埋め込み文字" プロパティを使用して、BizTalk Server に送信されたドキュメント インスタンスからフィールド内の埋め込み文字を削除できます。"埋め込み文字を含めた最小値" プロパティの値を設定すると、必要に応じて、出力インスタンス内のフィールドに埋め込み文字が挿入されます。"位置揃え" プロパティを使用して、フィールド データ コンテンツのどちら側で埋め込み文字の削除 (入力ドキュメント インスタンスから) または挿入 (出力インスタンスへ) を行うかを指定できます。左揃えに設定したフィールドでは、末尾の埋め込み文字が追加または削除され、右揃えに設定したフィールドでは、先頭の埋め込み文字が追加または削除されます。フィールドの "埋め込み文字" プロパティが設定されていない場合は、そのフィールドに対して埋め込み文字の追加や削除は行われません。

関連項目

解析のプロパティの設定


プロパティの範囲

仕様内の 1 つのレコードに 2 つ以上のインスタンスがある場合、あるプロパティの値は、これらのどのインスタンスでも等しくなっている必要があります。つまり、これらのプロパティの範囲はグローバルです。フィールド プロパティも範囲をグローバルにできますが、グローバルにできるのは、そのフィールドの "種類" プロパティの値が [要素] に設定されている場合に限ります。一方、フィールドの "種類" プロパティの値が [属性] に設定されている場合は、そのフィールドの範囲は常にローカルです。

たとえば、[宣言] プロパティ ページと [解析] プロパティ ページに表示されるすべてのプロパティは、1 つのレコードまたはフィールドの複数のインスタンスで同じです。1 つのレコードまたはフィールドのインスタンスのうちの 1 つについて [宣言] プロパティ ページまたは [解析] プロパティ ページのプロパティを変更すると、そのレコードまたはフィールドのほかのすべてのインスタンスについてもプロパティが自動的に変更されます。ただし、[参照] プロパティ ページと [ディクショナリ] プロパティ ページに表示されるプロパティの範囲はグローバルではないので、これらのプロパティの値は、レコードまたはフィールドのインスタンスごとに個別に設定できます。コード一覧はフィールドだけに適用され、範囲はグローバルではありません。

注

  • BizTalk エディタでは、[宣言] プロパティ ページの "種類" プロパティの値が [要素] に設定されている場合に限り、範囲がグローバルです。"種類" プロパティの値が [属性] に設定されたグローバル範囲の宣言が含まれるスキーマを BizTalk エディタにインポートし、仕様として保存した場合は、その宣言は、"種類" プロパティが [要素] に設定された宣言内では自動的に範囲がローカルになります。

関連項目

宣言のプロパティの設定

解析のプロパティの設定


循環参照

レコードをそのレコードの子孫として作成すると、仕様内で循環参照が発生します。循環参照が発生するのは、[参照] プロパティ ページの "標準" プロパティの値が [XML] に設定されている場合だけです。循環参照は、カーブした矢印が付いたレコードのアイコン 循環参照アイコン で表示されます。

次の図は、BizTalk エディタでの循環参照の表示を示しています。

[宣言] プロパティ ページに "循環回数" プロパティが表示されます。このプロパティは循環ノードだけに適用されます。既定値は 7 です。循環回数は、基本レコードより下位のレベルで循環できる回数を示します。たとえば、前の図の Record1 には、循環回数 3 の 3 つと基本レコードの 1 つの合計 4 つのレベルがあります。BizTalk マッパーでこの仕様を開くと、Record1 の 4 つのレベルがすべて表示されます。各 Record1 について Field1 と Record2 も表示されます。どの循環レベルのノードにでもリンクを接続できます。

循環ノードから派生したフィールドにはディクショナリ プロパティ値を設定できません。たとえば、前の図の Root/Record1/Field1 にはディクショナリ プロパティ値を設定できますが、Root/Record1/Record1 より下位のレベルで循環する 3 つの Field1 参照には、ディクショナリ プロパティ値を設定できません。

循環参照には次の制限が適用されます。

  • 循環パス上のノード (循環参照内の最初のレコードと最後のレコードの間にあるノード) は、その仕様内のほかのどの場所にも出現できません。

  • 循環パス上の要素は、ドラッグ アンド ドロップ操作やカット アンド ペースト操作のソースとターゲットのどちらとしても使用できません。

  • 循環は重複できません。

  • 仕様のルート ノードを循環参照の基本レコードにすることはできません。

重要

  • 循環参照ノードの [参照] プロパティ ページの "最小発生数" プロパティは、0 に設定する必要があります。1 に設定すると、無限ループが発生します。

  • 循環参照が含まれるスキーマをインポートした場合は、循環参照が有効かどうかの確認は自動的に実行されません。

関連項目

循環参照の作成

プロパティの範囲


既定値の統合

送信元仕様に "種類" プロパティの値が [属性] に設定されたフィールドが含まれ、その送信元仕様に基づいた受信ドキュメント インスタンスにそのフィールドが含まれない場合は、仕様でそのフィールドに既定値を適用する必要があります。

受信ドキュメント インスタンスにそのフィールドが含まれない場合は、そのフィールドの既定値が使用されます。受信ドキュメント インスタンスにそのフィールドが含まれる場合は、既定値が無視されます。

関連項目

宣言のプロパティの設定


データ型とデータ型値の概要

次の一覧は、[宣言] プロパティ ページの "データ型" プロパティの値を指定するときに参考になる説明と例を示しています。[データ型] ボックスの一覧からデータ型を選択し、[データ型値] ボックスで値を指定する必要があります。

データ型

Character [文字]

1 文字分の長さの文字列を含みます。

String [文字列]

任意のテキストを含みます。

Number [数値]

複数の桁を含み、先頭符号、小数部、および指数を含むことができます。標準英語句読法に従います。たとえば、15、3.14、-123.456E+10 になります。

Integer (int) [整数]

数字を含み、符号 (省略可) を含むことができます。小数や指数を含むことはできません。たとえば、1、58502、-13 になります。

Float [浮動小数]

数字を含みます。桁数の制限はありません。先頭符号、小数部、指数を含むことができます。

Fixed Point (14.4) [固定小数]

Number [数値] と同じですが、小数点の左側の桁数は 14 桁以下、小数点の右側の桁数は 4 桁以下である必要があります。たとえば、12.0044 になります。このデータ型は通貨値に使用できます。

Boolean [ブール値 (Yes/No)]

TRUE (1) または FALSE (0) のどちらかに評価される式を含みます。

Date [日付]

時間情報のない ISO 8601 形式のサブセットのデータを含みます。たとえば、1988-04-07 になります。

Date Time [日時]

時間情報 (省略可) はあるが、タイム ゾーン情報 はない ISO 8601 形式のサブセットのデータを含みます。秒数の精度はナノ秒までです。たとえば、1988-04-07T18:39:09 になります。

Date Time.tz [日時 (タイム ゾーン指定可)]

時間情報 (省略可) とタイム ゾーン情報 (省略可) のある ISO 8601 形式のサブセットのデータを含みます。秒数の精度はナノ秒までです。たとえば、1988-04-07T18:39:09-08:00 になります。

Time [時刻]

日付情報とタイム ゾーン情報のない ISO 8601 形式のサブセットのデータを含みます。たとえば、08:15:27 になります。

Time.tz [時刻 (タイムゾーン指定可)]

日付情報がなくタイム ゾーン情報 (省略可) のある ISO 8601 形式のサブセットのデータを含みます。たとえば、08:15:27-05:00 になります。

Byte (i1) [バイト]

数字、およびマイナス記号 (-) などの符号 (省略可) を含みます。小数や指数を含むことはできません。たとえば、1、127、-128 になります。

Word (i2) [ワード]

数字、およびマイナス記号 (-) などの符号 (省略可) を含みます。小数や指数を含むことはできません。たとえば、1、703、-32768 になります。

Integer (i4) [整数]

数字、およびマイナス記号 (-) などの符号 (省略可) を含みます。小数や指数を含むことはできません。たとえば、1、703、-32768、148343、-1000000000 になります。

Double Integer (i8) [倍精度整数]

数字、およびマイナス記号 (-) などの符号 (省略可) を含みます。小数や指数を含むことはできません。たとえば、1、703、-32768、148343、-1000000000 になります。

Unsigned Byte (ui1) [符号なしバイト]

数字を含みます。符号、小数、および指数を含むことはできません。たとえば、1、255 になります。

Unsigned Word (ui2) [符号なしワード]

数字を含みます。符号、小数、および指数を含むことはできません。たとえば、1、255、65535 になります。

Unsigned Integer (ui4) [符号なし整数]

数字を含みます。符号、小数、および指数を含むことはできません。たとえば、1、703、3000000000 になります。

Double Unsigned Integer (ui8) [倍精度符号なし整数]

数字を含みます。符号、小数、および指数を含むことはできません。たとえば、1、703、3000000000 になります。

Real (r4) [実数]

1.17549435E-38F ～ 3.40282347E+38F の範囲の数字を含みます。たとえば、3.14285718E+2 になります。

Double Real (r8) [倍精度実数]

2.2250738585072014E308 ～ 1.7976931348623157E+308 の範囲の数字を含みます。たとえば、314159265358979E+1 になります。

Universal Unique Identifier (uuid) [ユニバーサル固有識別子]

埋め込みハイフン (省略可で無視できる) 付きのオクテットを表す 16 進数を含みます。たとえば、333C7BC4-460F-11D0-BC04-0080C7055A83 になります。

Uniform Resource Identifier (uri) [統一リソース識別子]

統一リソース名 (URI) を含みます。

Binary (base64) [バイナリ (base64)]

バイナリ テキストをバイナリ エンコードした文字を含みます。たとえば、Graphic Interchange Format (GIF) 画像をテキスト表現に変換したものです。

Binary (hex) [バイナリ (hex)]

オクテットを表すバイナリ 16 進数を含みます。たとえば、0x0ffaa になります。

ID [識別子]

フィールドを ID として指定します。

IDREF [識別子参照属性値]

ID 値を含むフィールドがフィールドに参照されることを示します。

IDREFS [複数識別子参照属性値]

ID の一覧がフィールドにあることを示します。各 ID はスペースで区切られています。

Enumeration [列挙]

一連の値に順序を割り当てます。たとえば、Monday、Tuesday、Wednesday を 1 2 3 のように列挙できます。

注

  • Fixed Point (14.4) [固定小数] は通貨値に使用できます。

  • 日付/時刻型 (dateTime、dateTime.tz、time、time.tz) のフィルタを使用する場合には、XPath 式に手動で入力する必要があります。例えば、ATTDATETIME が日付/時刻書式型の場合、self::node()[@ATTDATETIME = "2000-03-15T10:10:10"] と入力します。

関連項目

宣言のプロパティの設定


汎用トリガ

BizTalk エディタは、Microsoft® BizTalk™ Accelerator for HIPAA スキーマのあらゆる種類のセグメントのトリガ フィールドを識別する "トリガ フィールド" というプロパティを [解析] プロパティ ページで提供します。トリガ フィールドは、基本的にコンテンツ修飾タグの 1 つの形式です。既存の [列挙 [Enumeration]] データ型と [値] 属性が、トリガを識別させる 1 つまたは複数の値を指定します。パーサーは解析中にこのトリガ フィールドを解釈し、対応する 1 つまたは複数のトリガ値を含んでいるスキーマのノードとインスタンス コンテンツを照合します。

トリガフィールドを使用して、意味をさらに細かく定義する 11 種類のセグメントがあります。次の表は、これらのセグメントの種類とそれぞれ対応するトリガ フィールドです。

セグメント | トリガ フィールド
AMT | AMT01
CRC | CRC01
DTM | DTM01
DTP | DTP01
ENT | ENT02
HI | HI01:01 (01 は複合している最初のサブフィールドです)
N1 | N101
NM1 | NM01
NTE | NTE01
REF | REF01
RMR | RMR01

BizTalk エディタは、互いに排他的な値を持つトリガ フィールドを使用するピアの複製に対応しています。つまり、複製するピアにあいまいさが発生する場合、ピアの複製はできません。

トリガ セグメント (トリガ フィールドを含んでいるセグメント) は常にループの最初のセグメントなので、トリガのループ解釈も可能です。トリガはまた、ループではなくネストになっているセグメントでもサポートされます。

BizTalk エディタは、列挙が同じ送信元のタグ識別子のトリガ値とオーバラップしないことを、検証できません。プロパティを編集し、オーバラップを作成すると、実行時エラーが発生します。セグメントのネストをサポートするために追加されたコメントは、仕様の保存に際して失われません。

前の表で示したセグメントの種類とは別に、特殊なケースとして Hierarchical Level (HL) セグメントがあります。このセグメントの詳細については、「HL セグメントの特殊ケース」を参照してください。

重要

  • トリガ フィールドは、トリガされるレコードまたはループの属性にしかなれません。その理由は、X12 スキーマのすべてのフィールドが属性を使って表されるからです。

ここには次のトピックが含まれます。

  • トリガ フィールドの検証

  • HL セグメントの特殊ケース

  • インスタンス構造の制限

  • HLの検証

関連項目

解析のプロパティの設定


トリガ フィールドの検証

設計時に BizTalk エディタが検証するのは、指定されたトリガ フィールドが存在し、それが属性であることの確認だけです。それ以外のすべての検証は実行時に行われます。提供されている HIPAA スキーマはすべて実行時に検証されます。検証の条件は次のとおりです。

  • 同じ送信元のタグ識別子を持つピア要素ノードは、同じ構造を持たねばならず、それぞれ対応する階層において同じトリガ フィールドを指定しなければなりません。

  • 各ピア要素ノードは、共通のトリガ フィールドについて互いに排他的な列挙値を定義しなければなりません。

  • 可能な構造のトリガ値のどれとも一致しないインスタンス データは、インスタンスで見つかった予期しないデータとしてフラグが設定されます。これは送信元のタグ識別子がスキーマで見つからないことと同じようなことです。

  • スキーマにネストになったトリガがあり、トリガされるループの最初の子レコードもトリガされる場合、その子レコードは繰り返せません。

  • 同じく、すべてのピア トリガ セグメントで、最小/最大発生数の設定は、1/1 が最初であり、次に 1/* で、その次に 0/[1|*] になります。この要件を満たさないと、解析エラーになります。

関連項目

解析のプロパティの設定


HL セグメントの特殊ケース

Hierarchical Level (HL) セグメントの使用はトリガ フィールドの特殊なケースです。なぜなら、これは、トリガ フィールド値の解釈だけでなく、親子関係の追跡も要求するからです。HL セグメントは、次のフィールドを以下の順序で含んでいます。

  1. ドキュメントの最上部から最下部までの連続した数値の IDで、その最初は "1" です。

  2. 親の連続した ID

  3. トリガ フィールドのレベル インジケータ (たとえば、22=Subscriber、23=Dependent)

  4. 子インジケータ (0=No; 1=Yes)

パーサーは、これらのフィールドを使用して、検出された HL セグメントの階層を構築します。この階層はスキーマと明示的に矛盾しませんが、HL セグメントのコンテンツのために、パーサーは構造を異なるかたちで解釈します。

また HL セグメントに対してのシリアライザの意味もあります。BizTalk Server 2002 マッピング プロセスで、(前に示している) フィールド 1 とフィールド 2 のコンテンツを作成しないようにすべきです。これらのフィールドのコンテンツを作成すると、シリアライザがそれらに上書きします。

関連項目

解析のプロパティの設定


インスタンス構造の制限

X12 パーサーは、Hierarchical Level (HL) セグメントとの関係でインスタンス構造置換に 2 種類の制限を強制します。

  • スキップなし : このスキーマ制限のために、親 HL がある場合、あらゆる HL セグメント/ループはその親 HL セグメント・ループよりもルートから 1 レベルだけ深くなければなりません。たとえば、HL1/N1/HL2 はサポートされていません。つまり、"x" 段階ネストしている HL のシーケンスは、ツリーで厳密に "x" 段階の深さにならなければなりません。次の図は、認められる場合と認められない場合の HL セグメント/ループ シナリオの例を示しています。

    認められる場合と認められない場合の HL セグメント/ループ シナリオ

  • ジャンプなし : このデータ制限は、順序の乱れた階層の指定を禁じます。親 HL を参照する HL があるとき、親 HL とそれを参照する HL の間に、インスタンス データ ストリームの順序でほかの HL は入れることはできません。これを "ジャンプなし" と言います。というのも、ファミリ ツリーになぞらえると、禁じられているアクションは、1 つの分岐から別の分岐へジャンプし、その上で HL 階層の順序に戻ることと同じことだからです。次の表は、この "ジャンプなし" 制限を示しています。
    ID | 親
    1 -
    2 | 1
    3 | 2
    4 | 3
    5 | 1
    6 | 4

    パーサー データ ストリームで検出される順番にHL を順次的に下降してゆくと、#5 に到達するまでは各 HL は前の HL の子になっていて、#5 は #2 の繰り返しになっています。これは認められています。次は #6 になり、これは #4 の子になろうとしていますが、これは認められません。なぜなら、順序的には #6 とそれが親にしようとしている HL (#4) との間に #5 が入っているからです。

注

  • Microsoft BizTalk Accelerator for HIPAA で提供される HIPAA 固有のスキーマを BizTalk エディタで変更できます。スキーマを変更する際、HIPAA 実装ガイドのさまざまな側面とのコプライアンスから外れないようにするために、十分に注意してください。

関連項目

解析のプロパティの設定


HL 検証

トリガ フィールドの検証で説明しているトリガ フィールドの検証のほかに、Hierarchical Level (HL) セグメントの検証もあります。次の検証が実行時に行われます。

  • スキップなし/ジャンプなし : これらの制限に対する違反が見つかったスキーマは、実行時エラーになります。

  • すべての HL スキーマ フィールドは属性でなければならない : 実行時にチェックされ、違反があれば、エラーになります。

  • HL02 は省略可能でなければならない : すべての HL が親を持つわけではないので (たとえばトップ レベルの HL の場合)、このことが要求されます。スキーマで、構文規則がこのフィールドの存在を強制します。

  • HL04 は "0" または "1" でなければならない : このフィールドで [列挙 [Enumeration]] のデータ型の使用が強制され、値は 0 または 1 になります。

  • データ順不同HL セグメントは、適切な階層を維持していなければなりません。これは "ジャンプなし" 制限と同じものです。ファミリ ツリーの分岐はそれらの最後まで続いていなければならず、(階層的見地からして) 途中に別のツリーを介入させてはなりません。また、分岐の変更があると復帰はありません。

関連項目

解析のプロパティの設定


名前空間のサポート

BizTalk エディタは名前空間をサポートしています。Extensible Markup Language (XML) 名前空間は、XML ドキュメントで要素名や属性名として使用できる名前の集合です。名前空間は、要素名を一意的に限定し、同一のドキュメントに存在する同じ名前の要素間の衝突を回避します。名前空間は、一部のUniversal Resource Identifier (URI) によって Uniform Resource Locator (URL) または統一リソース名 (URN) として識別されます。

非 XML データ書式では、XDR スキーマに名前空間に属する要素と属性によるコメントが付けられます。要素と属性を限定する名前空間は、EDI やフラット ファイル ドキュメントなどの非 XML 書式を処理して、BizTalk Server が変換、記録、および追跡で使用することができる XML 表現に再フォーマットするための情報を含んでいます。

ここには次のトピックが含まれます。

  • 名前空間宣言

  • インポートしたファイルの名前空間の保存


名前空間宣言

仕様内で宣言された名前空間は、BizTalk エディタの [名前空間] プロパティ ページに表示されます。次の表は、BizTalk エディタで仕様を開いたときに、既定で [名前空間] プロパティ ページに表示されるプレフィックスと名前空間を示しています。これらのプレフィックスと名前空間は編集できません。

プレフィックス | 名前空間
(既定) | urn:schemas-microsoft-com:xml-data
b | urn:schemas-microsoft-com:BizTalkServer
d | urn:schemas-microsoft-com:datatypes

注

  • BizTalk Server 2002 では次の名前空間はサポートされていません。

    SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"

仕様内でカスタム名前空間を宣言するには、[名前空間] プロパティ ページの [プレフィックス] 列に名前空間プレフィックスを入力し、[統一リソース名 (URN)] 列に名前空間を入力します。[統一リソース名 (URN)] に入力した名前空間は BizTalk エディタによって検証されません。

任意のレコードやフィールドに対してカスタム コメントを追加することもできます。カスタム コメントは、プレフィックスと名前の組および関連値で構成されます。次はプレフィックスと名前の組の構文の例です。

prefix:name

[宣言] プロパティ ページまたは [参照] プロパティ ページの [プロパティ] 列にプレフィックスと名前の組を入力し、[値] 列に値を入力します。[宣言] プロパティ ページに入力したプロパティの値の範囲はグローバルであり、[参照] プロパティ ページに入力したプロパティの値の範囲はローカルです。グローバル範囲とローカル範囲の詳細については、「プロパティの範囲」を参照してください。カスタム コメントの追加の詳細については、「カスタム コメントの追加」を参照してください。

関連項目

カスタム コメントの追加

名前空間の宣言

インポートしたファイルの名前空間の保存

プロパティの範囲


インポートしたファイルの名前空間の保存

BizTalk エディタにインポートできるファイルは、XML-Data Reduced (XDR) スキーマ、整形式 XML インスタンス、ドキュメント型定義 (DTD) の 3 種類です。BizTalk エディタでは、既存の名前空間およびプレフィックスと名前の組の処理方法は、ドキュメント型によって異なります。

XDR スキーマのインポート

XDR スキーマをインポートした場合は、既存の名前空間は次のように処理されます。

  • 名前空間宣言がカスタム名前空間として保存され、[名前空間] プロパティ ページの既定の名前空間の下に表示されます。

  • カスタム名前空間プレフィックス ("名前"プロパティと "種類" プロパティに関連付けられている名前空間プレフィックスを除く) は、関連付けられている名前空間が宣言されている場合だけ保存されます。

注

  • 名前空間プレフィックスが "名前"プロパティや "種類" プロパティに関連付けられている XDR スキーマはインポートできません。

整形式 XML インスタンスのインポート

整形式 XML ドキュメント インスタンスをインポートすると、ドキュメントから名前空間宣言が削除され、プレフィックスと名前を区切る区切り記号がコロン (:) からアンダースコア (_) に変わり、元の名前空間プレフィックスの意図が保持されます。例 :

prefix_name

重要

  • 名前空間プレフィックスと名前の組を持つ整形式 XML ドキュメント インスタンスをインポートして、インポートしたインスタンスを仕様として保存した場合、新しい仕様に対する元のドキュメント インスタンスの検証を行うと、そのインスタンスの検証は失敗します。新しい仕様で、プレフィックスと名前の組を含んでいるノードを削除します。([宣言] プロパティ ページ上の) このノードの親レコードについて、”モデル” プロパティで [オープン] をクリックし、仕様を保存します。この仕様に対するドキュメント インスタンスの検証を行います。

注

  • 関連付けられた名前空間がドキュメント内で宣言されていない場合は、名前空間プレフィックスが含まれるドキュメントをインポートできません。

DTD のインポート

プレフィックスと名前の組が含まれる DTD をインポートすると、区切り記号がコロン (:) からアンダースコア (_) に変わります。これは、プレフィックス表記そのものがサポートされなくなっても、構造全体の中の配置という点から元のプレフィックスの意図を保持するための処理です。例 :

prefix_name

関連項目

名前空間宣言


SQL コメントの追加

仕様内の任意のノードに SQL コメントを指定できます。[宣言] プロパティ ページで SQL コメントを指定すると、範囲がグローバルなコメントが作成されます。コメントは仕様内の "種類" プロパティの値が [要素] または [属性] に設定された宣言に保存されます。[参照] プロパティ ページで SQL コメントを指定すると、範囲がローカルなコメントが作成されます。コメントは仕様内の [要素] の参照または [属性] の参照に保存されます。

仕様内のノードの、[宣言] プロパティ ページまたは [参照] プロパティ ページのいずれかの [プロパティ] 列の空のフィールドをダブルクリックすると SQL コメント一覧が表示され、この一覧で SQL コメントを選択できます。[値] 列の対応するフィールドに SQL コメントの値を入力します。sql:relationship と sql:xpath-query を除き、すべての SQL コメントの値は普通の文字列データです。SQL コメントとそのほかのカスタム コメントの追加の詳細については、「カスタム コメントの追加」を参照してください。

次の一覧は、BizTalk エディタで使用できる SQL コメントを示しています。

  • sql:datatype

  • sql:field

  • sql:id

  • sql:id-prefix

  • sql:is-constant

  • sql:key-fields

  • sql:limit-field

  • sql:limit-value

  • sql:map-field

  • sql:is-mapping-schema

  • sql:overflow-field

  • sql:relation

  • sql:relationship

  • sql:target-namespace

  • sql:url-encode

  • sql:use-cdata

  • sql:xpath-query

値 sql:relationship は 1 つ以上の名前と値の組であり、名前と値の組の中の名前は、key、key-relation、foreign-key、foreign-relation の 4 つの名前のうちのいずれかである必要があります。値 sql:xpath-query は 2 つの部分から成ります。最初の部分は、属性を構成する 1 つ以上の名前と値の組で、2 番目の部分は sql:xpath-query のコンテンツで、"content=..." によって表されます。これらの 2 つの部分はシャープ記号 (#) で区切られています。

次の表は、SQL コメントの sql:relationship と sql:xpath-query の有効な例を示しています。

SQL コメント | 例
sql:relationship | key="CustomerID"
sql:relationship | key-relation="Cust"
sql:relationship | foreign-key="CustomerID"
sql:relationship | foreign-relation="Orders"
sql:xpath-query | mapping-schema="Schema.xml" #content=Employees

注

  • BizTalk エディタでは、現在のコンテキストで適切な SQL コメントだけではなく、それ以外の SQL コメントも選択できます。たとえば、sql:relationship と xpath-query の使用は [参照] プロパティ ページに制限されていますが、[宣言] プロパティ ページにもこれらの SQL コメントは表示されます。

  • SQL コメントを指定すると、[名前空間] プロパティ ページでプレフィックス "sql" が付いた名前空間とそれに対応する統一リソース名 (URN) 値が自動的に宣言されます。

  • [参照] プロパティ ページで SQL コメントが指定されているノードを仕様内のほかの場所にコピーしたり切り取って貼り付けると、コピー先の新しいノードでは SQL コメントが消失します。

関連項目

カスタム コメントの追加

名前空間宣言

プロパティの範囲


XML インスタンスとネイティブ インスタンスの作成

運用環境での Microsoft BizTalk Server 2002 の成功を確保するために、BizTalk エディタは、組織で実際に使用する前に仕様をテストするメカニズムを用意しています。インスタンス操作では、仕様に対するインスタンスのテストが行われるか、またはBizTalk エディタで作成された仕様に基づくインスタンスが生成されます。

BizTalk エディタによって、Extensible Markup Language (XML) インスタンスとネイティブ インスタンスのどちらかを作成することができます。位置指定フラット ファイルと区切りフラット ファイルのどちらで作業を行う場合にも、区切り記号情報を入れる必要はありません。しかし、EDI ドキュメントの場合は、使用する区切り記号を指定する必要があります。

関連項目

ドキュメント インスタンスの作成

ネイティブ インスタンスの作成


インスタンスと仕様の検証

BizTalk エディタで、ドキュメント インスタンスを検証することができます。標準 が X12、EDIFACT、または Custom に設定されている場合は、ドキュメント インスタンスのドキュメント構造が仕様の標準に準拠している必要があります。たとえば、ANSI X12 のドキュメント インスタンスは、ANSI X12 の仕様に対してだけ検証できます。

空白の属性値 ("") を持つフィールドが含まれているドキュメント インスタンスは、そのフィールドの "最小値" プロパティに値が設定されている仕様に対しても正常に検証されます。たとえば、"最小値" プロパティの値が 4 に設定されているフィールドがある仕様に対して、対応するフィールドの属性値が空白であるドキュメント インスタンスを検証しても、この不一致が原因で検証が失敗することはありません。これは、検証エンジンの基本となっている MSXML パーサーが、空白の値を持つ属性を、属性が指定されていないものとして扱うためです。この問題は、BizTalk Server の次のリリースで修正される予定です。

ドキュメントの区切り記号

BizTalk エディタで、インスタンスと仕様の検証中に区切り記号を指定することができます。[ドキュメントの区切り記号] プロパティ ページで、検証中に使用する既定の区切り記号を指定することができ、またドキュメント インスタンスを検証するたびに [ドキュメントの区切り記号] ダイアログ ボックスを自動的に表示するかどうかを指定することもできます。区切り文字を一度だけ設定するか、または BizTalk エディタがインスタンスのテストごとに区切り記号の入力を要求するようにできます。

区切り記号の既定値のリストを次の表に示します。

区切り記号 | 値
レコード区切り記号 | ~ (0x7)
フィールド区切り記号 | * (0x2a)
サブフィールド区切り記号 | > (0x3e)
エスケープ | ? (0x3f)

エンベロープ情報

区切り記号を指定しなくてもよい場合があります。たとえば、区切り記号情報を含んでいるエンベロープ情報がインスタンスに含まれていると、BizTalk エディタは使用すべき正しい区切り記号を自動的に決定することができます。しかし、検証される EDI インスタンスでヘッダー情報が見つからないと、BizTalk エディタによって [ドキュメントの区切り記号] ダイアログボックスが表示されるので、そこで区切り記号を指定することができます。

インターチェンジの中間のドキュメントの検証

BizTalk エディタでは、複数のドキュメントを含むドキュメント インスタンスの最初のドキュメントしか検証されません。しかし、インターチェンジの中間に存在するドキュメント、すなわちインターチェンジの最初のものでないドキュメントを検証することができます。そのためには、ヘッダー情報を削除し、さらに検証しようとするドキュメントよりも前にあるすべてのドキュメントを削除します。

レコード内の省略可能で空のフィールド

使用しているドキュメント インスタンスのレコードの中に、省略可能で空のフィールドがある場合、レコード区切り記号の前にフィールド区切り記号を追加しなければなりません。たとえば、次のドキュメント インスタンスにはレコード区切り記号としてチルダ (~) が含まれています。しかし、最初のレコードのフィールド区切り記号としてプラス記号 (+) も使用されています。このためには、[ドキュメントの区切り記号] ダイアログ ボックスの [レコードの区切り記号] を "~" に設定し、[フィールド区切り記号] を "+" に設定しなければなりません。

次の仕様に対して前のドキュメント インスタンスを検証すると、次のエラー メッセージが表示されます。

While parsing record "Record1", the parser could not find the required leading delimiter: "+" (0x002b).
The parser failed to convert the document due to processing errors. See the following messages for details.

この問題を解決するためには、ドキュメント インスタンスの中の "TTT" と "~" の間に "+" を追加します。

  • 本番運用環境でドキュメント インスタンスを使用する前に、送信元仕様に対してそのインスタンスを検証し、[警告] プロパティ ページに表示された問題を修正するようにしてください。

Microsoft BizTalk Accelerator for HIPAA スキーマ

BizTalk エディタには、BizTalk Accelerator for HIPAA スキーマについて subdocument_creation_break を "yes" に設定するオプションがあります。このインスタンスでは、パーサーは、元のペイロードに含まれている複数の XML ドキュメント インスタンスを生成します。これらの検証は、EDI検証の場合と同じです。たとえば、インターチェンジは分割され、スキーマの検証は分割されたドキュメントのうちの最初のドキュメントに対して行われます。


BizTalk エディタに関する作業を行う目的

ここでは、BizTalk エディタに関する作業を行う目的についてのクイック リファレンスを示します。次の表は、主要な作業とそれらに付随する作業を示しており、各作業の目的と対応する手順へのリンクを明記しています。

作業 作業を実行する目的
  • BizTalk エディタのオプションの変更
 新しいフィールドを要素として作成する場合に対応します。または、インスタンス テストで既定のドキュメントの区切り記号を使用するように指定します。さらに、この手順ではドキュメント インスタンスの検証のたびに [ドキュメントの区切り文字] ダイアログ ボックスを自動的に表示する方法についても説明します。
仕様の作成と検証 :
  • 標準に基づいた仕様の作成
 取引先との取引の必要性から、X12 または EDIFACT のような標準を使用して仕様を作成する場合に対応します。

また、取引先と合意はされていないが、公開されている標準を使用する必要性に備えます。たとえば、自分の組織を Web サービスとしてセットアップする場合などです。
  • フラット ファイルに基づいた仕様の作成
 フラット ファイルを使用しているレガシー システムを取り扱う場合に対応します。または、自社で SAP (もしくはフラット ファイルの使用を標準としている同様のアプリケーション) を使用するか、このようなアプリケーションを使用する取引先がある場合に対応します。
  • 空のテンプレートに基づいた仕様の作成
 組織内のエンタープライズ アプリケーション インテグレーション (EAI) が主要な目的の場合、この種のテンプレートが適しています。このテンプレートを使用することよって、単一のルート ノードから、必要な構造を新たに構築することができます。
  • 既存の仕様に基づいた仕様の作成
 EAI または企業間インテグレーション タスクを初めて行う場合、既存の仕様を利用することができます。または、変更が容易な既存の仕様を利用している組織とデータを交換し、時間と労力を節約することができます。
  • インポート ファイルに基づいた仕様の作成
 既存の仕様を使用して作業する必要がある場合に対応します。
  • Microsoft Office ファイルに基づいた仕様の作成
 組織内または取引先との間で Microsoft Excel のようなアプリケーションを使用して作業をしている場合に対応します。たとえば、経費報告書がマクロを含んでいて、従業員がこのマクロを使用して経費を入力し、入力されたデータに対応する仕様を作成するような場合などです。
  • 仕様の検証
 仕様で定義したレコードとフィールドが有効であることを確認します。BizTalk エディタはユーザーの操作が有効かどうかについてフィードバックしますが、無効な構造を含んでいるファイルをインポートすることがあります。構造の有効性について警告が発せられるのは、仕様を検証する場合だけです。
仕様を開く、保存する、エクスポートする :
  • ローカル ドライブの既存の仕様を開く
 仕様のローカル コピーを使用する場合に対応します。たとえば、仕様を部分的に変更しテストを行いたいが、WebDAV (Web Distributed Authoring and Versioning) に格納されている、共同で使用される仕様は変更したくない場合などです。
  • WebDAV から既存の仕様を開く
 ほかの人もアクセスして変更できる、共同で使用している仕様を使って作業する必要がある場合に対応します。これは、BizTalk メッセージ マネージャがトランザクションを処理するときに使用するファイルです。
  • フォルダから既存の仕様を開く
 仕様のローカル コピーを使用する場合に対応します。たとえば、仕様を部分的に変更し、それをテストしたいが、WebDAV に格納されている、共同で使用される仕様は変更したくない場合などです。
  • 新しい仕様の保存
 作成した仕様のローカル コピーを保存する場合に対応します。たとえば、WebDAV に格納されている、共同で使用する仕様に影響を与えることなく、新たに作成した仕様を保存しようとする場合などです。
  • 既存の仕様の保存
 変更した仕様のローカル コピーを保存する場合に対応します。たとえば、WebDAV に格納されている、共同で使用する仕様に影響を与えることなく、修正した仕様を保存しようとする場合などです。
  • XDR スキーマの WebDAV への格納
 純粋な XML-Data Reduced (XDR) スキーマ (非 BizTalk Serverスキーマ) を、BizTalk エディタを使って WebDAV に直接保存することはできません。保存する必要がある場合は、BizTalk メッセージ マネージャがWebDAV を通して XDR スキーマを利用できるようにします。またこれによって、そのファイルはほかの人も利用できるようになります。
  • 仕様の格納
 BizTalk メッセージ マネージャが、仕様を WebDAV を通して利用できるようする必要がある場合に対応します。これによって、そのファイルはほかの人も利用できるようになります。
  • XDR スキーマのエクスポート
 BizTalk Server を導入していない取引先に BizTalk Server の仕様を送る必要がある場合に対応します。BizTalk Server の仕様のコメントはエクスポート処理中に削除され、取引先が最終的なスキーマを容易に使用できるようになります。
  • XSD スキーマのエクスポート
 Extensible (XML) Structure Definitions (XSD) を利用している取引先に、仕様を記述するデータを送る必要がある場合に対応します。
レコードとフィールドの管理 :
  • ルート ノードへの新しいレコードの追加

  • ルート ノードへの新しいフィールドの追加

  • 既存のレコードへの新しいレコードの追加

  • レコードへの新しいフィールドの追加

  • レコードの挿入

  • フィールドの挿入
 仕様に新しい構造を作成したり、既存の構造を変更します。
  • 新しいフィールドを要素として作成
 新たに追加するすべてのフィールドを繰り返す必要があったり、または構造を持たせる必要がある場合に対応します。
  • フィールドを属性から要素に変更
 繰り返す必要があったり、または構造を持たせる必要がある既存のフィールドがある場合に対応します。要素には構造がありますが、属性にはありません。
  • フィールドを要素から属性に変更
 フィールドに構造を持たせたくない場合に対応します。
  • 仕様の中でのレコードの移動

  • 仕様の中でのフィールドの移動

  • 別の仕様へのレコードの移動

  • 別の仕様へのフィールドの移動
 1 つまたは複数の仕様の構造を変更します。レコードやフィールドをある仕様から別の仕様に移動することで、それらを新たに追加したり、それらのプロパティを追加することに比べ、時間が節約されます。
  • 仕様の中でのレコードのコピー

  • 仕様の中でのフィールドのコピー

  • 別の仕様へのレコードのコピー

  • 別の仕様へのフィールドのコピー
 1 つまたは複数の仕様の構造を変更します。レコードやフィールドをコピーすることで、それらを新たに作成する場合に比べ、時間が節約されます。
  • 循環参照の作成
 BizTalk Server が処理するデータに再帰的 (すなわち、あるノードがそれ自身を子孫として含んでいる) 構造がある場合に対応します。多数のコンポーネントとサブコンポーネントを持つ項目を扱うときには、再帰的構造は珍しくありません。
  • 既存のレコードの新しいインスタンスの作成
 既存のレコードと同じ構造を速やかに再作成したい場合に対応します。
  • 既存の要素フィールドの新しいインスタンスの作成
 既存のフィールドと同じ構造を速やかに再作成したい場合に対応します。
レコードとフィールドのプロパティの指定 :
  • ドキュメントの区切り記号の設定
 区切り構造があり、ドキュメントの区切り記号を設定する必要がある場合に対応します。設定されていなと、BizTalk Server はデータを処理できません。
  • 宣言のプロパティの設定
 データ構造のプロパティをグローバル レベルで制御します。
  • 参照のプロパティの設定
 データ構造のプロパティをローカル レベルで制御する場合に対応します。
  • 解析のプロパティの設定
 非 XML データを変換する方法についての指示を与えます。
  • 名前空間の宣言
 仕様のさまざまな部分にコメントを付加します。これは、仕様と関連している可能性のある既定の名前空間の使用を無効にします。
  • カスタム コメントの追加
 仕様を特定の指示でマークアップします。たとえば、カスタム パーサーを使用する場合は、カスタム コメントを追加することが考えられます。コメントは名前空間の一部でなければなりません。
  • ディクショナリ プロパティの設定
 BizTalk Server のすべての作業項目には、その作業項目を記述するプロパティの集合があります。この集合に内容を追加するには、ディクショナリ プロパティを設定する必要があります。ルーティングまたはエンベロープ関連のプロパティをプロパティの集合に追加する場合が多くあります。
  • カスタム ディクショナリ プロパティの追加
 カスタム ディクショナリ プロパティを設定します。前述の「ディクショナリ プロパティの設定」についての説明を参照してください。
  • コードの選択
 仕様が X12 または EDIFACT 構造に基づいている場合、コードを選択して、フィールドの [データ型] プロパティに [Enumeration] を設定し、[データ型値] に有効なコードを設定する必要がある場合があります。
  • コードの消去
 フィールドに追加されたコードを削除します。
  • フィールド位置の自動計算
 仕様が位置構造を持ち、すべての [最大値] の値が定義済みである場合、この機能を使うと各フィールドの開始位置と終了位置が自動的に計算されます。
メモと構文規則の編集 :
  • レコード メモの入力
 自分自身、またはほかの人がこの仕様を利用することを考慮して、ドキュメントを記述します。
  • 構文規則の表示
 ここで適用されるのは、X12 構造に基づく仕様のみです。X12 仕様に対して、または X12 仕様からマッピングする必要があり、仕様が標準構文規則に違反しないようにしたい場合に、この機能を使用します。
  • フィールド メモの入力
 自分自身、またはほかの人がこの仕様を利用することを考慮して、ドキュメントを記述します。
ドキュメント インスタンスの管理 :
  • ドキュメント インスタンスの作成
 仕様を XML または非 XML データ インスタンスに対してテストします。
  • ネイティブ インスタンスの作成
 仕様を非 XML データ インスタンスに対してテストする場合に対応します。
  • ドキュメント インスタンスの検証
 仕様が、その仕様を通じて受け渡されるデータと互換性を持っているかどうかを確認します。
  • 無効な文字コード表の管理
 アプリケーションが取り扱う文字の種類について制限がある場合、無効な文字を指定することがあります。
表示の管理とショートカット キーの使用 :
  • ツリー項目の展開
 ルート ノード以下の、またはあるレコード以下のすべてのレコードとフィールドを表示します。
  • ツリー項目の折りたたみ
 ルート ノード レコードと親レコードの一方だけ、またはその両方を表示します。
  • プロパティ値の表示
 [宣言]、[参照] 、[解析] 、[名前空間] 、または[コード一覧] タブにある、レコードまたはフィールドのプロパティを表示します。
  • テキストのサイズの変更
 BizTalk エディタのテキストのフォント サイズを大きくしたり、小さくしたりします。
  • BizTalk エディタのショートカット キー
 マウスではなく、ショートカット キーを使って作業を実行します。


BizTalk エディタに関する作業を行う方法

ここでは、仕様を作成する方法を作業ごとに説明します。「BizTalk エディタについて」を参照し、レコードとフィールドの関係、および作成する仕様の種類に応じたプロパティの指定方法について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • BizTalk エディタのオプションの変更

  • 仕様の作成と検証

  • 仕様を開く

  • 仕様を保存する、エクスポートする、閉じる

  • レコードとフィールドの管理

  • レコードとフィールドのプロパティの指定

  • メモの編集と構文規則の表示

  • ドキュメント インスタンスの管理

  • 無効な文字コード表の管理

  • 表示の管理

  • BizTalk エディタのショートカット キー


BizTalk エディタのオプションの変更

  1. [BizTalk エディタのオプション] ダイアログ ボックスでオプションを表示または変更するには、[ツール] メニューの [オプション] をクリックします。

  2. [全般] プロパティ ページの [新しいフィールドを要素として作成] チェック ボックスをオンにします。

    このタブの詳細については、「新しいフィールドを要素として作成」を参照してください。

  3. [ドキュメントの区切り記号] タブで、インスタンス テスト中に使用する既定の区切り記号を指定することができます。また、ドキュメント インスタンスを検証するたびに [ドキュメントの区切り記号] ダイアログ ボックスを自動的に表示するかどうかを指定することもできます。

    このタブの詳細については、「ドキュメントの区切り記号の設定」を参照してください。

関連項目

新しいフィールドを要素として作成

ドキュメントの区切り記号の設定


仕様の作成と検証

ここでは、使用中のデータの型に対応する仕様を作成する方法について説明します。たとえば、区切りフラット ファイルを扱う場合は、フラット ファイルに基づく仕様を作成する必要があります。仕様を操作する際は、Extensible Markup Language (XML) 名に使用できない文字について理解しておくことが重要です。この問題は、XML 名で無効な Unicode 文字を使用すると、仕様ツリーで無効な文字を表示した場合に、その文字はエスケープされた数値エンティティに変換されるために発生します。詳細については、「XML 名に使用できない文字」を参照してください。

ここには次のトピックが含まれます。

  • 標準に基づいた仕様の作成

  • フラット ファイルに基づいた仕様の作成

  • 空のテンプレートに基づいた仕様の作成

  • 既存の仕様に基づいた仕様の作成

  • インポート ファイルに基づいた仕様の作成

  • Microsoft Office ファイルに基づいた仕様の作成

  • 仕様の検証


標準に基づいた仕様の作成

  1. [ファイル] メニューの [新規作成] をクリックします。

    [新しいドキュメント仕様] ダイアログ ボックスが表示されます。

  2. [XML]、[X12]、または [EDIFACT] をクリックし、[OK] をクリックします。

    EDIFACT または X12 を選択する場合は、バージョンも選択する必要があります。作成するバージョンのフォルダをクリックし、[OK] をクリックします。

  3. 仕様の種類をクリックし、[OK] をクリックします。

  4. 必要に応じて、レコードの削除をします。

  5. 必要に応じて、フィールドの削除をします。

  6. 必要に応じて、コードの消去をします。

  7. 新しい仕様の保存をします。

重要

  • BizTalk Server インストールに含まれている X12 テンプレートを BizTalk エディタで使用すると、次のようなエラー メッセージが表示される場合があります。

    "ITD05" フィールド ("") の長さが無効です。長さを 48 から -1 までで設定してください。このドキュメントは拒否されます。

    X12 テンプレートは、10 進数データ型 Nx を暗黙的に使用します。入力データが小数点を含んでいると、出力は N カスタム データ型 (これは小数点を含みません) と一致せず、中間 XML ファイルに無効なインスタンスが作成されます。このリリースの BizTalk Server では、シリアライザは、中間 XML ファイルがデータ型 N の出力で小数点を含んでいるかどうかを検出しない場合があります。この問題を解決するには、X12 テンプレートで暗黙的に使用される 10 進数データ型をほかの数値データ型に手動で変更する必要があります。

注

  • X12 パーサーでサポートされているインスタンス構造置換には、Hierarchy Level (HL) セグメントに階層の飛び越えがあってはならないという制限があります。この制限のために、親 HL がある場合、あらゆる HL セグメント/ループはその親 HL セグメント/ループよりもルートから 1 レベル深くなければなりません。たとえば、HL/NM1/HL はサポートされていません。つまり、‘x’ 段階ネストしている HL の特定のシーケンスは、ツリーで厳密に ‘x’ 段階の深さに及ぶ必要があります。

関連項目

レコードとフィールドの管理

レコードとフィールドのプロパティの指定

仕様について


フラット ファイルに基づいた仕様の作成

  1. [ファイル] メニューの [新規作成] をクリックします。

    [新しいドキュメント仕様] ダイアログ ボックスが表示されます。

  2. [空の仕様] をクリックし、[OK] をクリックします。

  3. ルート ノードを強調表示し、[参照] タブをクリックします。

  4. [標準] 行の "値" フィールドをダブルクリックします。

  5. [標準] ボックスで [Custom] をクリックします。

  6. Enter キーを押します。

  7. [はい] をクリックして変更を確認します。

  8. ルート ノードへの新しいレコードの追加をします。

  9. 既存のレコードへの新しいレコードの追加をします。

  10. ルート ノードへの新しいフィールドの追加をします。

  11. レコードへの新しいフィールドの追加をします。

  12. レコードとフィールドのプロパティの指定をします。

  13. 新しい仕様の保存をします。

注

  • フラット ファイルが区切られて位置指定されている場合は、[解析] プロパティ ページで、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。必要に応じて、追加のレコード プロパティを [区切り記号] または [位置指定] に設定します。詳細については、「位置指定フラット ファイルと区切りフラットファイルの操作」を参照してください。

  • 区切りフラット ファイル解析と同じようなデータが位置指定フラット ファイルに含まれない場合は、位置指定フラット ファイルは省略可能な要素を抑制しません。また、値を持たない要素はマッピングの結果に影響を及ぼします。

  • UTF8 コード ページに基づいたフラット ファイルは、BizTalk エディタではサポートされていません。

各国語対応に関する問題

  • 位置指定フラット ファイルには、ひとつのコード ページに対して2 バイト文字または 1 バイト文字を含めることができます。位置指定 (固定長) フラット ファイルをサポートするアプリケーションの大部分では、文字列データは、文字でなく、バイトで揃えられることになっています。このため、位置指定フラット ファイルで文字列データを処理するときに問題が発生します。この問題を解決するには、位置指定フラット ファイル内に 2 バイト文字セット (DBCS) 文字か、1 バイト文字セット (SBCS) 文字のどちらか一方のみを使用します。または位置指定フラット ファイルの代わりに区切りフラット ファイルを使用します。

関連項目

レコードとフィールドの管理

レコードとフィールドのプロパティの指定

仕様について

位置指定フラット ファイルと区切りフラット ファイルの操作


空のテンプレートに基づいた仕様の作成

  1. [ファイル] メニューの [新規作成] をクリックします。

    [新しいドキュメント仕様] ダイアログ ボックスが表示されます。

  2. [空の仕様] をクリックし、[OK] をクリックします。

  3. ルート ノードへの新しいレコードの追加をします。

  4. 既存のレコードへの新しいレコードの追加をします。

  5. ルート ノードへの新しいフィールドの追加をします。

  6. レコードへの新しいフィールドの追加をします。

  7. レコードとフィールドのプロパティの指定をします。

  8. 新しい仕様の保存をします。

関連項目

レコードとフィールドの管理

レコードとフィールドのプロパティの指定

仕様について


既存の仕様に基づいた仕様の作成

  1. [ファイル] メニューの [開く] をクリックします。

    [ドキュメント仕様を開く] ダイアログ ボックスが表示されます。

  2. 既存の使用を含んでいるフォルダを参照します。

  3. 一覧でファイルをクリックし、[開く] をクリックします。

  4. 必要に応じて、仕様を変更します。

  5. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [ドキュメント仕様に名前を付けて保存] ダイアログ ボックスが表示されます。

  6. [ファイル名] ボックスに仕様の名前を入力します。

  7. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    仕様を ASCII 文字に関連付けて作成する場合は、[エンコード] ボックスの一覧の [UTF-8] をクリックします。仕様を 2 バイト文字に関連付けてエクスポートする場合は、[エンコード] ボックスの一覧の [UTF-8] または [Unicode] をクリックします。

  8. レコードとフィールドの管理をします。

  9. 新しい仕様の保存をします。

関連項目

コード一覧の値と説明

レコードとフィールドの管理


インポート ファイルに基づいた仕様の作成

  1. [ツール] メニューの [インポート] をクリックします。

    [インポート モジュールの選択] ダイアログ ボックスが表示されます。

  2. [整形式 XML インスタンス] 、[Document Type Definition]、または [XDR スキーマ] をクリックし、[OK] をクリックします。

    重要

    • XDR スキーマを含む整形式 XML インスタンスをインポートすることはできません。

    • Microsoft Office のファイルをインポートするときは、[整形式 XML インスタンス] をクリックします。

    • XML-Data Reduced (XDR) ファイルをインポートする場合は、[XDR スキーマ] をクリックします。
  3. [<インポートするモジュール名> のインポート] ダイアログ ボックスで、インポートするファイルが含まれているフォルダを参照します。そのファイルをクリックし、[開く] をクリックします。

    重要

    • ルート ノードにする要素の特定が自動的に行われない場合は、[ルート要素の選択] ダイアログ ボックスが表示されます。[ルート要素] ボックスの一覧からルート要素を選択し、[OK] をクリックします。詳細については、「ファイルのインポート」を参照してください。

    • BizTalk エディタで非 BizTalk Server XDR スキーマを開く場合、要素グループまたは名前空間の一方、あるいは両方がスキーマ内に存在していれば、エラーまたは警告メッセージが表示されます。
  4. ルート ノードへの新しいレコードの追加をします。

  5. 既存のレコードへの新しいレコードの追加をします。

  6. ルート ノードへの新しいフィールドの追加をします。

  7. レコードへの新しいフィールドの追加をします。

  8. レコードとフィールドのプロパティの指定をします。

  9. 新しい仕様の保存をします。

重要

  • "x-schema:" で始まる名前空間の統一リソース名 (URN) を含むスキーマは、BizTalk エディタで開けない場合があります。"x-schema" 参照を削除してから、ファイルを BizTalk エディタにインポートする必要があります。

  • BizTalk エディタでは、ルート ノードを持つ循環参照が含まれているドキュメント型定義 (DTD) や XML-Data Reduced (XDR) スキーマをインポートすることはできません。ルート ノードを持つ循環参照が含まれている整形式 XML ドキュメントをインポートすることはできますが、循環参照にドキュメントのルート ノードを含めることはできないという警告が表示されます。循環参照の詳細については、「循環参照」を参照してください。

  • ファイルをインポートし、混在したコンテンツのサポートが必要な場合は、インポートされるインスタンスが混在したコンテンツを含んでいる必要があります。そのインスタンスに混在したコンテンツが含まれていないと、[宣言] プロパティ ページの [コンテンツ] の値は [混合] に設定されません。

関連項目

ファイルのインポート

レコードとフィールドの管理

レコードとフィールドのプロパティの指定


Microsoft Office ファイルに基づいた仕様の作成

  1. [ツール] メニューの [インポート] をクリックします。

    [インポート モジュールの選択] ダイアログ ボックスが表示されます。

  2. [整形式 XML インスタンス] をクリックし、[OK] をクリックします。

  3. [<インポートするモジュール名> のインポート] ダイアログ ボックスで、インポートするファイルが含まれているフォルダを参照します。そのファイルをクリックし、[開く] をクリックします。

    重要

    • ルート ノードにする要素の特定が自動的に行われない場合は、[ルート要素の選択] ダイアログ ボックスが表示されます。[ルート要素] ボックスの一覧からルート要素を選択し、[OK] をクリックします。詳細については、「ファイルのインポート」を参照してください。
  4. ルート ノードへの新しいレコードの追加をします。

  5. 既存のレコードへの新しいレコードの追加をします。

  6. ルート ノードへの新しいフィールドの追加をします。

  7. レコードへの新しいフィールドの追加をします。

  8. レコードとフィールドのプロパティの指定をします。

  9. 新しい仕様の保存をします。

関連項目

ファイルのインポート

レコードとフィールドの管理

レコードとフィールドのプロパティの指定


仕様の検証

  1. 仕様を開くか、スキーマをインポートします。

    詳細については、「仕様を開く」または「インポート ファイルに基づいた仕様の作成」を参照してください。

  2. [ツール] メニューの [仕様の検証] をクリックします。

[警告] プロパティ ページに、仕様の構造に問題がある可能性を示す警告が表示されます。警告をダブルクリックすると、レコードまたはフィールド、および関連付けられたプロパティが上のペインに赤く表示されます。

関連項目

インポート ファイルに基づいた仕様の作成

仕様を開く


仕様を開く

ここには次のトピックが含まれます。

  • ローカル ドライブの既存の仕様を開く

  • WebDAV から既存の仕様を開く

  • フォルダから既存の仕様を開く


ローカル ドライブの既存の仕様を開く

  1. [ファイル] メニューの [開く] をクリックします。

    [ドキュメント仕様を開く] ダイアログ ボックスが表示されます。

  2. 開く仕様が含まれているフォルダを参照し、仕様をクリックします。次に、[開く] をクリックします。

注

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成した仕様を開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

WebDAV から既存の仕様を開く


WebDAV から既存の仕様を開く

  1. [ファイル] メニューの [WebDAV から取得] をクリックします。

    [WebDAV から取得] ダイアログ ボックスが表示されます。

  2. [サーバー] ボックスにサーバー名を入力し、Enter キーを押します。

    ボックスの一覧でサーバー名を選択することもできます。

    重要

    • 80 でないプロキシ サーバー ポートでは、WebDAV に格納されているファイルにアクセスする場合に、[サーバー] ボックスに「http://<サーバー名>:<ポート番号>」の形式で入力する必要があります。

    • 保護されているサーバーでファイルを取得することはできません。たとえば、https://<サーバー名>/biztalkserverrepository であるサーバーでは、いかなるファイルにもアクセスできません。
  3. 開く仕様が含まれているフォルダを参照し、仕様をクリックします。次に、[開く] をクリックします。

重要

  • WebDAV から既存の仕様を開こうとして、"BizTalk Server リポジトリが http://<サーバー名>/BizTalkServerRepository/DocSpecs に見つかりませんでした。" というエラー メッセージが表示された場合は、msdaipp.dll を再登録して、コンピュータを再起動してください。msdaipp.dll の再登録方法については、「WebDAV における仕様の取得または格納を目的とした msdaipp.dll の再登録」を参照してください。

  • 注

  • セッション中に初めてリモート WebDAV サーバーに接続するとき、遅延が発生することがあります。

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成した仕様を開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

ローカル ドライブの既存の仕様を開く

BizTalk エディタと BizTalk マッパーのトラブルシューティング


フォルダから既存の仕様を開く

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[アクセサリ] をポイントし、[エクスプローラ] をクリックします。

  2. BizTalk エディタで表示するファイルに移動します。

    必要に応じて、BizTalk エディタ ウィンドウを見ることができるようにするために、[元のサイズに戻す] をクリックし、ウィンドウのサイズを縮小します。

  3. 仕様ツリー ウィンドウにファイルをドラッグします。

注

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成した仕様を開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。


仕様を保存する、エクスポートする、閉じる

ここには次のトピックが含まれます。

  • 新しい仕様の保存

  • 既存の仕様の保存

  • XDR スキーマの WebDAV への格納

  • 仕様の格納

  • XDR スキーマのエクスポート

  • XSD スキーマのエクスポート

  • 仕様を閉じる


新しい仕様の保存

  1. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [ドキュメント仕様に名前を付けて保存] ダイアログ ボックスが表示されます。

  2. [ファイル名] ボックスにファイルの名前を入力します。

  3. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字に関連付けられた仕様を保存する場合は、[エンコード] ボックスの一覧の [UTF-8] をクリックします。2 バイト文字に関連付けられた仕様を保存する場合は、[エンコード] ボックスの一覧の [UTF-8] または [Unicode] をクリックします。

注

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成した仕様を開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。


既存の仕様の保存

  • [ファイル] メニューの [保存] をクリックします。

注

  • ファイルを保存すると、ファイルはハード ディスクに格納されます。ファイルを WebDAV に保存するには、サーバーにファイルを格納するためのアクセス許可が必要です。

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成した仕様を開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

仕様の格納


XDR スキーマの WebDAV への格納

BizTalk エディタを使って、純然たる XDR スキーマ (非 BizTalk Server スキーマ) をWebDAV に直接に格納することはできません。格納するには、次の手順を実行する必要があります。

  1. 新しい仕様の保存または既存の仕様の保存の操作を行います。

  2. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[アクセサリ] をポイントし、[エクスプローラ] をクリックします。

  3. ファイルを格納する WebDAV の場所を参照します。

  4. 純粋な XDR スキーマを保存した場所を参照します。

  5. XDR ファイルの保存してある場所から WebDAV フォルダにドラッグします。

多国環境での問題

  • ファイルは、WebDAV リポジトリに Unicode エンコードでのみ保存できます。ただし、WebDAV レポジトリでは、異なるコード ページの名前のファイルを格納することはできません。

  • WebDAV では、ファイル名に Unicode 文字を使用できません。

  • システム ロケールが適切な言語に設定されていることを確認してください。たとえば、英語バージョンの Windows が稼動しているコンピュータ上で英語バージョンの BizTalk Server 2002 をインストールしている多国環境のユーザーが、Latin I コード ページ (英語を含む Windows 1252) でサポートされていない文字をファイル名に使用する場合は、システム ロケールをユーザーのロケールに設定する必要があります。

  • ロケール設定が正しくない場合は、2 バイト文字セット (DBCS) のファイル名でファイルを格納できません。この問題を解決するには、「???.xml が WebDAV ダイアログ ボックスに表示される」を参照してください。


仕様の格納

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

    [WebDAV に格納] ダイアログ ボックスが表示されます。

  2. [サーバー] ボックスにサーバー名を入力し、Enter キーを押します。

    ボックスの一覧でサーバー名を選択することもできます。

    重要

    • プロキシ サーバー ポートが 80 でない場合、WebDAV に格納されているファイルにアクセスするときに [サーバー] ボックスに「http://<サーバー名>:<ポート番号>」の形式で入力する必要があります。

    • 保護されているサーバーでファイルを保存することはできません。たとえば、https://<サーバー名>/biztalkserverrepository であるサーバーでは、いかなるファイルも格納できません。
  3. 仕様を格納するフォルダを参照します。

  4. [ファイル名] ボックスにファイルの名前を入力します。

  5. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    仕様を ASCII 文字に関連付けて格納する場合は、[エンコード] ボックスの一覧の [UTF-8] をクリックします。仕様を 2 バイト文字に関連付けて保存する場合は、[エンコード] ボックスの一覧の [UTF-8] または [Unicode] をクリックします。

多国環境での問題

  • ファイルは、WebDAV リポジトリに Unicode エンコードでのみ保存できます。ただし、WebDAV レポジトリでは、異なるコード ページの名前のファイルを格納することはできません。

  • WebDAV では、ファイル名に Unicode 文字を使用できません。

  • システム ロケールが適切な言語に設定されていることを確認してください。たとえば、英語バージョンの Windows が稼動しているコンピュータ上で英語バージョンの BizTalk Server 2002 をインストールしている多国環境のユーザーが、Latin I コード ページ (英語を含む Windows 1252) でサポートされていない文字をファイル名に使用する場合は、システム ロケールをユーザーのロケールに設定する必要があります。

  • ロケール設定が正しくない場合は、2 バイト文字セット (DBCS) のファイル名でファイルを格納できません。この問題を解決するには、「???.xml が WebDAV ダイアログ ボックスに表示される」を参照してください。

重要

  • WebDAV に仕様を格納しようとして、"BizTalk Server リポジトリが http://<サーバー名>/BizTalkServerRepository/DocSpecs に見つかりませんでした。" というエラー メッセージが表示された場合は、msdaipp.dll を再登録して、コンピュータを再起動してください。msdaipp.dll の再登録方法については、「WebDAV におけるファイルの取得または格納を目的とした msdaipp.dll の再登録」を参照してください。

注

  • リモート WebDAV サーバーに初めて接続する場合は、時間がかかることがあります。

  • ファイルを WebDAV に格納すると、ファイルはサーバーに格納されます。ファイルをハード ディスクに保存するには、[ファイル] メニューの [名前を付けて保存] をクリックします。

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成した仕様を開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

既存の仕様の保存

新しい仕様の保存

BizTalk エディタと BizTalk マッパーのトラブルシューティング


XDR スキーマのエクスポート

  1. [ツール] メニューの [XDR スキーマのエクスポート] をクリックします。

    [次の形式で XDR スキーマをエクスポートします] ダイアログ ボックスが表示されます。

  2. XML-Data Reduced (XDR) ファイルをエクスポートする場所を参照します。

  3. [ファイル名] ボックスにファイルの名前を入力します。

  4. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字に関連付けられた仕様をエクスポートする場合は、[エンコード] ボックスの一覧の [UTF-8] をクリックします。2 バイト文字に関連付けられた仕様をエクスポートする場合は、[エンコード] ボックスの一覧の [UTF-8] または [Unicode] をクリックします。

関連項目

仕様を開く

XSD スキーマのエクスポート


XSD スキーマのエクスポート

Extensible (XML) Structure Definitions (XSD) スキーマをエクスポートする前に、ファイルを保存する必要があります。

  1. [ツール] メニューの [XSD スキーマのエクスポート] をクリックします。

    [XSD スキーマのエクスポート] ダイアログ ボックスが表示されます。

  2. XSD ファイルをエクスポートする場所を参照します。

  3. [ファイル名] ボックスにファイルの名前を入力し、[保存] をクリックします。

注

  • 仕様が対象の名前空間を含んでいて、[XSD のエクスポート] 機能を使用してそのファイルをエクスポートすると、エクスポートされた XSD スキーマには対象の名前空間が含まれません。この問題を解決するには、エクスポートされた XSD ファイルをメモ帳で開き、対象の名前空間を手動で追加します。

  • エクスポートされた XSD ファイルは、既定では UTF-16 形式になっています。

関連項目

仕様を開く

XDR スキーマのエクスポート


仕様を閉じる

  • [ファイル] メニューの [閉じる] をクリックします。


レコードとフィールドの管理

ここには次のトピックが含まれます。

  • ルート ノードへの新しいレコードの追加

  • ルート ノードへの新しいフィールドの追加

  • 既存のレコードへの新しいレコードの追加

  • レコードへの新しいフィールドの追加

  • レコードの挿入

  • フィールドの挿入

  • 新しいフィールドを要素として作成

  • フィールドを属性から要素に変更

  • フィールドを要素から属性に変更

  • 仕様の中でのレコードの移動

  • 仕様の中でのフィールドの移動

  • 別の仕様へのレコードの移動

  • 別の仕様へのフィールドの移動

  • 仕様の中でのレコードのコピー

  • 仕様の中でのフィールドのコピー

  • 別の仕様へのレコードのコピー

  • 別の仕様へのフィールドのコピー

  • 単一レコードの名前の変更

  • 単一フィールドの名前の変更

  • 同じ名前を持つすべてのレコードの名前の変更

  • レコードの削除

  • フィールドの削除

  • 循環参照の作成

  • 既存のレコードの新しいインスタンスの作成

  • 既存の要素フィールドの新しいインスタンスの作成


ルート ノードへの新しいレコードの追加

  1. ルート ノードをクリックします。

  2. [編集] メニューの [新しいレコード] をクリックします。

    仕様ツリーの最後のノードの後ろに子レコードが挿入されます。

  3. レコードの名前を入力し、Enter キーを押します。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティを入力して非 XML ソース ファイルのタグを識別することができます。

  • 兄弟のレコードを同じ名前にすることはできません。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

レコードとフィールドのプロパティの指定


ルート ノードへの新しいフィールドの追加

  1. ルート ノードをクリックします。

  2. [編集] メニューの [新しいフィールド] をクリックします。

    仕様ツリーの最後のノードの後ろに子フィールドが挿入されます。

  3. フィールドの名前を入力し、Enter キーを押します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

フィールドを要素から属性に変更

新しいフィールドを要素として作成

レコードとフィールドのプロパティの指定


既存のレコードへの新しいレコードの追加

  1. レコードをクリックします。

  2. [編集] メニューの [新しいレコード] をクリックします。

    選択したレコードの直後、または選択したレコードの最後の子ノードの後ろに、子レコードが挿入されます。

  3. レコードの名前を入力し、Enter キーを押します。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティを入力して非 XML ソース ファイルのタグを識別することができます。

  • 兄弟のレコードを同じ名前にすることはできません。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

レコードとフィールドのプロパティの指定


レコードへの新しいフィールドの追加

  1. レコードをクリックします。

  2. [編集] メニューの [新しいフィールド] をクリックします。

    選択したレコードの直後、または選択したレコードの最後の子ノードの後ろに、子フィールドが挿入されます。

  3. フィールドの名前を入力し、Enter キーを押します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

フィールドを要素から属性に変更

新しいフィールドを要素として作成

レコードとフィールドのプロパティの指定


レコードの挿入

  1. レコードをクリックします。

  2. [編集] メニューの [レコードの挿入] をクリックします。

    選択したレコードの直後、または選択したレコードの最後の子ノードの後ろに、兄弟レコードが挿入されます。

  3. レコードの名前を入力し、Enter キーを押します。

注

  • 兄弟のレコードを同じ名前にすることはできません。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

レコードとフィールドのプロパティの指定


フィールドの挿入

  1. フィールドを挿入する位置の前にあるレコードまたはフィールドをクリックします。

  2. [編集] メニューの [フィールドの挿入] をクリックします。

    選択したレコードの直後、または選択したレコードの最後の子ノードの後ろに、兄弟フィールドが挿入されます。

  3. フィールドの名前を入力し、Enter キーを押します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

フィールドを要素から属性に変更

新しいフィールドを要素として作成

レコードとフィールドのプロパティの指定


新しいフィールドを要素として作成

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk エディタのオプション] ダイアログ ボックスが表示されます。

  2. [新しいフィールドを要素として作成] チェック ボックスをオンにし、[OK] をクリックします。

注

  • このチェック ボックスがオフの場合は、フィールドは属性として作成されます。[新しいフィールドを要素として作成] チェック ボックスをオンにすると、すべての新しいフィールドは要素として作成されます。

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

関連項目

フィールドを要素から属性に変更


フィールドを属性から要素に変更

  1. 仕様ツリーのフィールドをクリックします。

  2. [宣言] プロパティ ページの [種類] 行の "値" フィールドをダブルクリックします。

    現在の設定は [属性] です。

  3. [種類] ボックスの一覧の [要素] をクリックし、Enter キーを押します。

  4. [はい] をクリックして変更を確認します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

関連項目

フィールドを要素から属性に変更

新しいフィールドを要素として作成


フィールドを要素から属性に変更

  1. 仕様ツリーのフィールドをクリックします。

  2. [宣言] プロパティ ページの [種類] 行の "値" フィールドをダブルクリックします。

    現在の設定は [要素] です。

  3. [種類] ボックスの一覧の [属性] をクリックし、Enter キーを押します。

  4. [はい] をクリックして変更を確認します。

注

  • 兄弟のフィールドを同じ名前にするには、一方のフィールドの "種類" プロパティを [属性] に設定し、他方のフィールドの "種類" プロパティを [要素] に設定する必要があります。

関連項目

フィールドを属性から要素に変更


仕様の中でのレコードの移動

  1. ルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. 移動するレコードをクリックし、ツリーの中の別のノードにドラッグします。

    マウスのボタンを離したときに、マウス ポインタが強調表示されたノード テキストの中心より上の位置にあると、フィールドはそのノードの上に兄弟として挿入されます。マウス ポインタが強調表示されたノード テキストの中心より下の位置にあると、フィールドはそのノードの下に兄弟として挿入されます。マウス ポインタが強調表示されたノード テキストの右にあると、レコードは強調表示されたレコードの下に子として挿入されます。

関連項目

別の仕様へのレコードのコピー

仕様の中でのレコードのコピー

別の仕様へのレコードの移動


仕様の中でのフィールドの移動

  1. ルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. 移動するフィールドをクリックし、ツリーの中の別のノードにドラッグします。

    マウスのボタンを離したときに、マウス ポインタが強調表示されたノード テキストの中心より上の位置にあると、フィールドはそのノードの上に兄弟として挿入されます。マウス ポインタが強調表示されたノード テキストの中心より下の位置にあると、フィールドはそのノードの下に兄弟として挿入されます。マウス ポインタが強調表示されたノード テキストの右にあると、フィールドはそのレコードの下に子として挿入されます。

関連項目

別の仕様へのフィールドのコピー

仕様の中でのフィールドのコピー

別の仕様へのフィールドの移動


別の仕様へのレコードの移動

  1. 移動するレコードが含まれている仕様のルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. 移動するレコードをクリックし、[編集] メニューの [切り取り] をクリックします。

  4. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk エディタ] をクリックします。

    別の仕様を開くには、BizTalk エディタの 2 番目のインスタンスを開きます。

  5. [ファイル] メニューの [開く] をクリックします。

    [ドキュメント仕様を開く] ダイアログ ボックスが表示されます。

  6. レコードを移動する仕様を含むフォルダを参照します。

  7. 一覧のファイルをクリックし、[開く] をクリックします。

  8. 仕様のルート ノードをクリックします。

  9. [表示] メニューの [ツリー項目の展開] をクリックします。

  10. レコードを挿入する位置の前にあるルート ノード、レコード、またはフィールドをクリックします。

  11. [編集] メニューの [貼り付け] をクリックします。

注

  • 既存のレコードと同じ名前のレコードを移動すると、レコード名の末尾に数値が自動的に追加されます。

関連項目

別の仕様へのレコードのコピー

仕様の中でのレコードのコピー

仕様の中でのレコードの移動


別の仕様へのフィールドの移動

  1. 移動するフィールドが含まれている仕様のルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. 移動するフィールドをクリックし、[編集] メニューの [切り取り] をクリックします。

  4. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk エディタ] をクリックします。

    別の仕様を開くには、BizTalk エディタの 2 番目のインスタンスを開きます。

  5. [ファイル] メニューの [開く] をクリックします。

    [ドキュメント仕様を開く] ダイアログ ボックスが表示されます。

  6. レコードを移動する仕様を含むフォルダを参照します。

  7. 一覧のファイルをクリックし、[開く] をクリックします。

  8. フィールドの移動先である仕様のルート ノードをクリックします。

  9. [表示] メニューの [ツリー項目の展開] をクリックします。

  10. フィールドを挿入する位置の前にあるルート ノード、レコード、またはフィールドをクリックします。

  11. [編集] メニューの [貼り付け] をクリックします。

注

  • 既存のフィールドと同じ名前のフィールドを移動すると、フィールド名の末尾に数値が自動的に追加されます。

関連項目

別の仕様へのフィールドのコピー

仕様の中でのフィールドのコピー

仕様の中でのフィールドの移動


仕様の中でのレコードのコピー

  1. ルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. コピーするレコードをクリックし、[編集] メニューの [コピー] をクリックします。

  4. レコードを挿入する位置の前にあるノードをクリックし、[編集] メニューの [貼り付け] をクリックします。

    選択したノードがレコードの場合は、選択したノードの直後に子レコードが挿入されます。選択したノードがフィールドの場合は、選択したノードの直後に兄弟レコードが挿入されます。

重要

  • ルート ノード レコードをコピーしようとすると、子レコードと子フィールドはすべてコピーされますが、ルート ノード レコードそのものはコピーされません。ルート ノード レコードを仕様に含める場合は、手動で作成する必要があります。

関連項目

別の仕様へのレコードのコピー

別の仕様へのレコードの移動

仕様の中でのレコードの移動


仕様の中でのフィールドのコピー

  1. ルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. コピーするフィールドをクリックし、[編集] メニューの [コピー] をクリックします。

  4. フィールドを挿入する位置の前にあるノードをクリックし、[編集] メニューの [貼り付け] をクリックします。

    選択したノードがレコードの場合は、選択したノードの直後に子フィールドが挿入されます。選択したノードがフィールドの場合は、選択したノードの直後に兄弟フィールドが挿入されます。

関連項目

別の仕様へのフィールドのコピー

別の仕様へのフィールドの移動

仕様の中でのフィールドの移動


別の仕様へのレコードのコピー

  1. コピーするレコードが含まれている仕様のルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. コピーするレコードをクリックし、[編集] メニューの [コピー] をクリックします。

  4. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk エディタ] をクリックします。

    別の仕様を開くには、BizTalk エディタの 2 番目のインスタンスを開きます。

  5. [ファイル] メニューの [開く] をクリックします。

    [ドキュメント仕様を開く] ダイアログ ボックスが表示されます。

  6. レコードのコピー先である仕様が含まれているフォルダを参照します。

  7. 一覧のファイルをクリックし、[開く] をクリックします。

  8. レコードのコピー先である仕様のルート ノードをクリックします。

  9. [表示] メニューの [ツリー項目の展開] をクリックします。

  10. レコードを挿入する位置の前にあるルート ノード、レコード、またはフィールドをクリックし、[編集] メニューの [貼り付け] をクリックします。

    選択したノードがレコードの場合は、選択したノードの直後に子レコードが挿入されます。選択したノードがフィールドの場合は、選択したノードの直後に兄弟レコードが挿入されます。

重要

ルート ノード レコードをコピーしようとすると、子レコードと子フィールドはすべてコピーされますが、ルート ノード レコードそのものはコピーされません。ルート ノード レコードを仕様に含める場合は、手動で作成する必要があります。

注

  • 既存のレコードと同じ名前のレコードをコピーすると、レコード名の末尾に数値が自動的に追加されます。

関連項目

仕様の中でのレコードのコピー

別の仕様へのレコードの移動

仕様の中でのレコードの移動


別の仕様へのフィールドのコピー

  1. コピーするフィールドが含まれている仕様のルート ノードをクリックします。

  2. [表示] メニューの [ツリー項目の展開] をクリックします。

  3. コピーするフィールドをクリックし、[編集] メニューの [コピー] をクリックします。

  4. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[Microsoft BizTalk Server 2002] をポイントし、[BizTalk エディタ] をクリックします。

    別の仕様を開くには、BizTalk エディタの 2 番目のインスタンスを開きます。

  5. [ファイル] メニューの [開く] をクリックします。

    [ドキュメント仕様を開く] ダイアログ ボックスが表示されます。

  6. フィールドを移動する仕様を含むフォルダを参照します。

  7. 一覧のファイルをクリックし、[開く] をクリックします。

  8. フィールドのコピー先である仕様のルート ノードをクリックします。

  9. [表示] メニューの [ツリー項目の展開] をクリックします。

  10. レコードを挿入する位置の前にあるルート ノード、レコードまたはフィールドをクリックし、[編集] メニューの [貼り付け] をクリックします。

    選択したノードがレコードの場合は、選択したノードの直後に子フィールドが挿入されます。選択したノードがフィールドの場合は、選択したノードの直後に兄弟フィールドが挿入されます。

注

  • 既存のフィールドと同じ名前のフィールドをコピーすると、フィールド名の末尾に数値が自動的に追加されます。

関連項目

仕様の中でのフィールドのコピー

別の仕様へのフィールドの移動

仕様の中でのフィールドの移動


単一レコードの名前の変更

  1. 名前を変更するレコードをクリックします。

  2. [編集] メニューの [名前の変更] をクリックします。

  3. レコードの新しい名前を入力し、Enter キーを押します。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

同じ名前を持つすべてのレコードの名前の変更

単一フィールドの名前の変更


単一フィールドの名前の変更

  1. 名前を変更するフィールドをクリックします。

  2. [編集] メニューの [名前の変更] をクリックします。

  3. フィールドの新しい名前を入力し、Enter キーを押します。

注

  • 要素であるフィールドに、既存のレコードと同じ名前を付けることはできません。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

同じ名前を持つすべてのレコードの名前の変更

単一レコードの名前の変更


同じ名前を持つすべてのレコードの名前の変更

  1. 変更する名前を持つレコードのうちの 1 つをクリックします。

  2. [編集] メニューの [すべての同一レコード名の変更 <レコード名>] をクリックします。

  3. レコードの新しい名前を入力します。

    同じ名前を持つすべてのレコードの名前が変更されます。

注

  • このコマンドが [編集] メニューで利用できるのは、同じ名前のレコードが 2 個以上ある場合だけです。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

単一フィールドの名前の変更

単一レコードの名前の変更


レコードの削除

  1. 削除するレコードをクリックします。

  2. [編集] メニューの [削除] をクリックします。

  3. 確認ダイアログ ボックスで [はい] をクリックします。

注意

  • レコードを削除すると、すべての子レコードと子フィールドも削除されます。

関連項目

フィールドの削除


フィールドの削除

  1. 削除するフィールドをクリックします。

  2. [編集] メニューの [削除] をクリックします。

  3. 確認ダイアログ ボックスで [はい] をクリックします。

関連項目

レコードの削除


循環参照の作成

  1. 循環参照を作成する位置の前にあるレコードを選択します。

    これが基本のレコードです。

  2. [編集] メニューの [新しいレコード] をクリックします。

  3. 新しいレコードに基本のレコードと同じ名前を付け、Enter キーを押します。

    循環参照 循環参照アイコン が作成されます。

  4. [宣言] プロパティ ページの [循環回数] 行の "値" フィールドをダブルクリックします。

  5. 1 から 7 までの数字を入力し、Enter キーを押します。

重要

  • 循環参照ノードの [参照] プロパティ ページの "最小発生数" プロパティは、0 に設定する必要があります。1 に設定すると、無限ループが発生します。

注

  • 非 XML 仕様では、循環参照を使用できません。XMLの仕様を使用していることを確認してください。

関連項目

循環参照


既存のレコードの新しいインスタンスの作成

  1. 既存のレコードの新しいインスタンスを作成するノードをクリックします。

  2. [編集] メニューの [新しいレコード] または [レコードの挿入] をクリックします。

    注

    • 手順 1. でフィールドを選択した場合は、[編集] メニューの [新しいレコード] は利用できません。
  3. 新しいレコードに既存のレコードと同じ名前を付け、Enter キーを押します。

    同じレコードのインスタンスが 2 つ作成されます。

重要

  • 新しいレコード インスタンスに、兄弟レコードと同じ名前を付けることはできません。

  • 新しいレコードに親レコードと同じ名前を付けると、既存のレコードの新しいインスタンスではなく、循環参照が作成されます。循環参照の詳細については、「循環参照」を参照してください。

注

  • [新しいレコード] をクリックすると、新しいレコード インスタンスは選択したレコードの子孫として挿入されます。

  • [レコードの挿入] をクリックすると、新しいレコード インスタンスは選択したレコードまたはフィールドの兄弟として挿入されます。

  • 1 つのレコードが持つすべてのインスタンスで、下位のノード構造は同一です。レコードのあるインスタンスに対してノードを削除または追加すると、その変更はレコードのほかのすべてのインスタンスに自動的に反映されます。レコード インスタンスのプロパティには、同一のものと、インスタンスごとに個別に設定できるものがあります。すべてのレコード インスタンスで同一のプロパティと、異なるプロパティの詳細については、「プロパティの範囲」を参照してください。

  • 既存のレコードに、別の既存のレコードと同じ名前を付けることはできません。

  • 既存のレコードの新しいインスタンスを作成するには、新しいレコード インスタンスを挿入する位置の上にあるノードの右に、既存のレコードを Ctrl キーを押しながらドラッグする方法もあります。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

循環参照

プロパティの範囲


既存の要素フィールドの新しいインスタンスの作成

  1. 要素フィールドの新しいインスタンスを作成するノードを選択します。

    注

    • 複数のインスタンスを作成できるフィールドは、[宣言] プロパティ ページで種類が [要素] と指定されているフィールドだけです。種類が [属性] のフィールドには、複数のインスタンスを作成できません。同じ名前で 2 つ以上の属性フィールドを作成すると、それぞれのフィールドは完全に独立した状態で残ります。
  2. [編集] メニューの [新しいフィールド] または [フィールドの挿入] をクリックします。

    注

    • 手順 1. でフィールドを選択した場合は、[編集] メニューの [新しいフィールド] は利用できません。
  3. 新しいフィールドに既存のフィールドと同じ名前を付け、Enter キーを押します。

    同じフィールドのインスタンスが 2 つ作成されます。

重要

  • 新しい要素フィールド インスタンスに、兄弟要素フィールド インスタンスと同じ名前を付けることはできません。

注

  • [新しいフィールド] をクリックすると、新しいフィールド インスタンスは選択したレコードの子孫として挿入されます。

  • [フィールドの挿入] をクリックすると、新しいフィールド インスタンスは選択したレコードまたはフィールドの兄弟として挿入されます。

  • フィールド インスタンスのプロパティには、同一のものと、インスタンスごとに個別に設定できるものがあります。すべてのフィールド インスタンスで同一のプロパティと、異なるプロパティの詳細については、「プロパティの範囲」を参照してください。

  • 既存のフィールドに、別の既存のフィールドと同じ名前を付けることはできません。ただし、一方のフィールドの "種類" プロパティが [属性] に、もう一方のフィールドの "種類" プロパティが [要素] に設定されている場合は、それらに同じ名前を付けることができます。

  • 既存の要素フィールドの新しいインスタンスを作成するには、新しいフィールド インスタンスを挿入する位置の上にあるノードの右に、既存の要素フィールドを Ctrl キーを押しながらドラッグする方法もあります。

各国語対応に関する問題

  • Input Method Editor (IME) を使用してレコード名またはフィールド名を韓国語文字で入力する場合、レコードまたはフィールドの名前を既存の名前に変更しようとすると、エラー メッセージが表示されます。それにもかかわらず、BizTalk エディタでは名前の重複が有効になっています。また BizTalk エディタでは、韓国語の IME を使用した場合に、それ以外では認められない無効なレコード名やフィールド名を入力することができます。この問題を解決するには、無効なレコードまたはフィールドを削除します。

関連項目

循環参照

プロパティの範囲


レコードとフィールドのプロパティの指定

ここでは、次の内容について説明します。

  • ドキュメントの区切り記号の設定

  • 宣言のプロパティの設定

  • 参照のプロパティの設定

  • 解析のプロパティの設定

  • 名前空間の宣言

  • カスタム コメントの追加

  • カスタム コメントの編集

  • カスタム コメントの削除

  • ディクショナリ プロパティの設定

  • カスタム ディクショナリ プロパティの追加

  • カスタム ディクショナリ プロパティの名前の変更

  • ディクショナリ プロパティの消去

  • カスタム ディクショナリ プロパティの削除

  • コードの選択

  • コードの消去

  • [値] 列のフィールドのプロパティの消去

  • フィールド位置の自動計算


ドキュメントの区切り記号の設定

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk エディタのオプション] ダイアログ ボックスが表示されます。

  2. [ドキュメントの区切り記号] タブをクリックします。

  3. 次のボックスの一覧でそれぞれのオプションをクリックします。
    • [レコード区切り記号]

    • [フィールド区切り記号]

    • [サブフィールド区切り記号]

    • [エスケープ文字]

    重要

    • 独自の区切り記号を指定する場合は、Unicode 文字値を使用します。有効な文字の一覧については、Microsoft Global Software Development Web サイト (www.microsoft.com/globaldev/reference/wincp.asp)) にあるグローバル コードページのページを参照してください。先頭に 2 つのゼロがあることを除いて、ANSI 文字コードが Unicode 文字コードと同じである場合は、ANSI 文字コードを使用することができます。
  4. 一意なドキュメントの区切り記号を指定できるように、ドキュメントのインスタンスを検証するごとに [ドキュメントの区切り記号] タブを表示させる場合は、[インスタンス テスト時に区切り記号を要求] チェックボックスをオンにします。

重要

  • [インスタンス テスト時に区切り記号を要求] チェック ボックスがオンになっているためにインスタンス テスト中に区切り記号の確認を求められる場合は、指定する区切り記号だけがそのインスタンスのテストに使用されます。[ドキュメントの区切り記号] タブで指定した区切り記号が、既定の区切り記号になります。

  • NULL 終端記号 (区切り記号) はサポートされていません。フラット ファイルから NULL 区切り記号を削除してください。

注

  • 複数のドキュメントとエンベロープ情報 (ヘッダー/トレーラ) がインスタンスに含まれている場合、[ドキュメントの区切り記号] タブで指定されているドキュメントの区切り記号が検証されるのは最初のドキュメントだけです。


宣言のプロパティの設定

  1. 仕様のツリーで、プロパティを設定するルート ノード、レコード、またはフィールドをクリックし、[宣言] タブをクリックします。

  2. 設定するプロパティと関連付けられている [値] 列のフィールドをダブルクリックします。

  3. フィールドにデータを入力するか、下向き矢印をクリックして、一覧から利用可能なオプションを選択します。

  4. Enter キーを押して変更を適用します。

次の表は、[宣言] プロパティ ページに含まれているプロパティを一覧表示しています。選択するプロパティは、ルート ノード、レコード、またはフィールドのうち、選択したノードに対して設定されます。

[宣言] プロパティ ページ : ルート ノードのプロパティ

プロパティ | 値
名前 ルート ノードの名前です。

注

  • [宣言] プロパティ ページの [名前] の値を変更すると、これと一致するように、仕様ツリーのルート ノードの名前が自動的に変更されます。新しく作成された仕様では、[宣言] プロパティ ページの [名前] の値を変更すると、[参照] プロパティ ページの [仕様名] の値も変更されます。ただし、仕様名はルート ノードの名前と異なる可能性があるので、[仕様名] の値を変更しても [名前] の値または仕様ツリーのルート ノードの名前は変更されません。いったん [仕様名] の値を編集すると、[名前] の値またはルート ノードの名前を変更しても [仕様名] の値は変更されなくなります。
説明 | 仕様の説明です。
種類 | レコードの種類です。この値は、ルート ノードに対して自動的に [要素] に設定されます。
モデル [クローズド] : ドキュメント インスタンスに含まれているデータと仕様構造が一致していることを示します。

[オープン] : ドキュメント インスタンスに含まれているデータが、仕様構造と一致しない可能性があることを示します。

重要

  • [コンテンツ] 値を [テキストのみ] から [要素のみ] に変更し、[モデル] 値を [クローズド] から [オープン] に変更した場合、[ディクショナリ] プロパティ ページは仕様と関連付けられたままですが、ファイルは BizTalk Server エンジンを正常に通過しなくなります。

注

  • このプロパティ値が空白の場合、既定値は [オープン] です。
コンテンツ [要素のみ] : レコードに含められるのは要素だけであることを示します。レコードに子レコードが含まれている場合の既定値です。

[混合] : ルート ノードにテキスト情報と下位要素が混在したコンテンツを含めることができることを示します。これを利用できるのは、[標準] が [XML] になっているときだけです。

重要

  • ルート ノードは子レコードを含むため、[コンテンツ] 値は [要素のみ] と [混合] だけになります。

  • 要素には、名前付き要素とテキストを混在して含めることができます。[混合] は既定の設定です。コンテンツの属性の値が混合であると、子要素の数が指定された範囲内に収まっていない場合でも、[最小発生数] 属性と [最大発生数] 属性による検証エラーが発生することはありません。

  • たとえば子要素を内包するデータなどの混在したコンテンツが要素に含まれている場合に、BizTalk マッパーで [値のコピー (既定)] を選択すると、コピーされるコンテンツは最初の子要素よりも上部のコンテンツだけになります。たとえば、次のようなコードがあるとします。
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    結果は、Item がコピーされます。

  • たとえば子要素を内包するデータなどの混在したコンテンツが要素に含まれている場合に、BizTalk マッパーで [テキストとサブコンテンツ値をコピー] を選択すると、子要素を含むすべてのコンテンツがコピーされます。たとえば、次のようなコードがあるとします。
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    結果は、Item1121314Number がコピーされます。

注

  • [混合] を選択する場合は、"順序" プロパティの値に [複数] を選択する必要があります。
順序 [構造] が [XML] である場合は、次の値のいずれかを選択します。
  • [複数] : 0 個以上の構成要素を任意の順序または組み合わせで使用できることを示します。

  • [単数] : 使用できる構成要素が 1 つだけで、省略できないことを示します。

  • [連続] : 指定された順序で構成要素を使用する必要があることを示します。

注

  • [複数] を選択すると、子レコードのすべての [最小発生数] および [最大発生数] 値は無視されます。

[宣言] プロパティ ページ : レコードのプロパティ

プロパティ | 値
名前 | レコードの名前です。
説明 | レコードの説明です。
種類 | レコードの種類です。
データ型 有効なデータ型です。すべての有効なデータ型の一覧と説明については、「データ型とデータ型値の概要」を参照してください。

重要

  • [コンテンツ] の種類プロパティが [テキストのみ] の場合には、"データ型" プロパティを指定できます。
データ型値 [データ型] ボックスの一覧で [Enumeration] をクリックした場合は、既定でデータ型値 "a b c" が [データ型値] ボックスに表示されます。既定値は、スペースで区切られたカスタム値で置き換えることができます。

ANSI X12 ドキュメントまたは EDIFACT ドキュメントの場合、特定のフィールドに関連付けられたコードを含めると、これらのコードが [データ型値] ボックスに自動的に表示され、[データ型] ボックスに自動的に [Enumeration] が表示されます。

重要

  • [コンテンツ] の種類プロパティが [テキストのみ] である場合は、"データ型値" プロパティを指定できます。

  • シャープ記号 (#)、アンパサンド (&)、またはコロン (:) 文字を [データ型値] として使用することはできません。
モデル [クローズド] : ドキュメント インスタンスに含まれているデータと仕様構造が一致していることを示します。

[オープン] : ドキュメント インスタンスに含まれているデータが、仕様構造と一致しない可能性があることを示します。

重要

  • [コンテンツ] 値を [テキストのみ] から [要素のみ] に変更し、[モデル] 値を [クローズド] から [オープン] に変更した場合、[ディクショナリ] プロパティ ページは仕様と関連付けられたままですが、ファイルは BizTalk Server エンジンを正常に通過しなくなります。

注

  • このプロパティ値が空白の場合、既定値は [オープン] です。
コンテンツ [要素のみ] : レコードに含められるのは要素だけであることを示します。レコードに子レコードが含まれている場合の既定値です。

[なし] : レコードに下位要素を含められないことを示します。

[テキストのみ] : レコードに含められるのはテキストだけで、下位要素は含められないことを示します。

[混合] : ルート ノードにテキスト情報と下位要素が混在したコンテンツを含めることができることを示します。

重要

  • 子レコードを持つレコードが含むことができる [コンテンツ] 値は、[要素のみ] と [混合] だけです。レコードに子レコードがない場合は、一覧の [なし] と [テキストのみ] を利用することもできます。

  • 要素には、名前付き要素とテキストを混在して含めることができます。[混合] は既定の設定です。コンテンツの属性の値が混合であると、子要素の数が指定された範囲内に収まっていない場合でも、[最小発生数] 属性と [最大発生数] 属性による検証エラーが発生することはありません。

  • [コンテンツ] 値を [テキストのみ] から [要素のみ] に変更し、[モデル] 値を [クローズド] から [オープン] に変更した場合、[ディクショナリ] プロパティ ページは仕様と関連付けられたままですが、ファイルは BizTalk Server エンジンを正常に通過しなくなります。

  • たとえば子要素を内包するデータなどの混在したコンテンツが要素に含まれている場合に、BizTalk マッパーで [値のコピー (既定)] を選択すると、コピーされるコンテンツは最初の子要素よりも上部のコンテンツだけになります。たとえば、次のようなコードがあるとします。
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    結果は、Item がコピーされます。

  • たとえば子要素を内包するデータなどの混在したコンテンツが要素に含まれている場合に、BizTalk マッパーで [テキストとサブコンテンツ値をコピー] を選択すると、子要素を含むすべてのコンテンツがコピーされます。たとえば、次のようなコードがあるとします。
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    結果は、Item1121314Number がコピーされます。

注

  • [テキストのみ] を選択すると、[データ型] プロパティと [データ型値] プロパティを指定できます。

  • [混合] を選択する場合は、"順序" プロパティの値で [複数] を選択する必要があります。
順序 [構造] が [XML] である場合は、次の値のいずれかを選択します。
  • [複数] : 0 個以上の構成要素を任意の順序または組み合わせで使用できることを示します。

  • [単数] : 使用できる構成要素が 1 つだけで、省略できないことを示します。

  • [連続] : 指定された順序で構成要素を使用する必要があることを示します。

注

  • [複数] を選択すると、子レコードのすべての [最小発生数] および [最大発生数] 値は無視されます。
循環回数 基本のレコードの下で利用する循環回数を入力します。循環参照の詳細については、「循環参照」を参照してください。

注

  • このプロパティ フィールドは、循環参照を作成したときにだけ表示されます。既定値は 7 です。

[宣言] プロパティ ページ : フィールドのプロパティ

プロパティ | 値
名前 | フィールドの名前です。
説明 | フィールドの説明です。
種類 次の値のいずれかを選択します。
  • [要素]

  • [属性]

注

  • 仕様の構造が位置指定である場合は、[種類] 値に [要素] を指定しないでください。指定すると、検証が失敗します。
モデル [クローズド] : ドキュメント インスタンスに含まれているデータと仕様構造が一致していることを示します。

[オープン] : ドキュメント インスタンスに含まれているデータが、仕様構造と一致しない可能性があることを示します。

注

  • このプロパティ値が空白の場合、既定値は [オープン] です。

  • "モデル" プロパティは、"種類" フィールドが "要素" に設定されている場合のみ構成できます。
コンテンツ [テキストのみ] : フィールドに含められるのはテキストだけで、下位要素は含められないことを示します。

注

  • "コンテンツ" プロパティは、"種類" フィールドが "要素" に設定されている場合のみ構成できます。

  • "テキストのみ" は、フィールドの "コンテンツ" プロパティに対してのみ設定できる値です。
データ型 有効なデータ型です。すべての有効なデータ型の一覧と説明については、「データ型とデータ型値の概要」を参照してください。

重要

  • [参照] プロパティ ページの "標準" プロパティの値が [X12]、[EDIFACT]、または [Custom] に設定されている場合は、[解析] プロパティ ページで [カスタム データ型] の値を割り当てることができます。[カスタム データ型] の値を指定すると、データ型の値は [カスタム データ型] で選択した値と一致するように自動的に変更されます。

  • "データ型" プロパティを [識別子参照属性値 [IDREF]] または [複数識別子参照属性値 [IDREFS]] に設定したフィールドを仕様で作成する場合は、[データ型] を [識別子 [ID]] に設定した別のフィールドをその仕様で作成する必要があります。

  • BizTalk メッセージ マネージャのチャネル フィルタ式で追跡または使用するフィールドを選択するには、仕様でそのフィールドにデータ型を割り当てる必要があります。
データ型値 [データ型] ボックスの一覧で [Enumeration] をクリックした場合は、既定でデータ型値 "a b c" が [データ型値] ボックスに表示されます。既定値は、スペースで区切られたカスタム値で置き換えることができます。

ANSI X12 ドキュメントまたは EDIFACT ドキュメントの場合、特定のフィールドに関連付けられたコードを含めると、これらのコードが [データ型値] ボックスに自動的に表示され、[データ型] ボックスに自動的に [列挙 [Enumeration]] が表示されます。

重要

  • シャープ記号 (#) またはアンパサンド (&) 文字を [データ型値] として使用することはできません。
最小値 フィールドに含めることができる最小文字数です。

注

  • "最小値" プロパティを設定できるのは、[データ型] の値が [文字列 [String]]、[数値 [Number]]、[バイナリ (base64) [Binary (base64)]]、および [バイナリ (hex) [Binary (hex)]] のフィールドだけです。

  • "カスタム データ型" プロパティに 10 進数を暗黙的に指定する場合は、[最小値] を指定しないでください。[最小値] を指定する必要がある場合は、その値は "Nx" 未満でなければなりません。ここで "x" は 1 から 9 までの数です。"Nx" 値は "カスタム データ型" プロパティの一覧で指定できます。
最大値 フィールドに含めることができる最大文字数です。

注

  • "最小値" プロパティを設定できるのは、[データ型] の値が [文字列 [String]]、[数値 [Number]]、[バイナリ (base64) [Binary (base64)]]、および [バイナリ (hex) [Binary (hex)]] のフィールドだけです。
既定値 数字を入力します。詳細については、「既定値の統合」を参照してください。

注

  • "既定値" プロパティが仕様に表示されるのは、ルート ノードの [参照] プロパティ ページの "標準" プロパティが [XML] に設定され、フィールドの [宣言] プロパティ ページの "種類" プロパティが [属性] に設定されている場合だけです。

  • 次の文字を使用することはできません。
    • アクセント記号 (`)

    • アポストロフィ (')

    • アスタリスク (*)

    • 円記号 (\)

    • ブレース ({ })

    • 角かっこ ([ ])

    • 脱字記号 (^)

    • コロン (:)

    • カンマ (,)

    • ドル記号 ($)

    • 等号記号 (=)

    • 感嘆符 (!)

    • パーセント記号 (%)

    • ピリオド (.)

    • パイプ (|)

    • プラス記号 (+)

    • 疑問符 (?)

    • セミコロン (;)

    • スラッシュ (/)

    • チルダ (~)

関連項目

チャネル フィルタ式の追加

文字数の制限

循環参照

既定値の統合

チャネル内の仕様フィールドの選択

ドキュメント定義内の仕様フィールドの選択

データ型とデータ型値の概要


参照のプロパティの設定

  1. 仕様ツリーで、プロパティを設定するルート ノード、レコード、またはフィールドをクリックし、[参照] タブをクリックします。

  2. 設定するプロパティと関連付けられている [値] 列のフィールドをダブルクリックします。

  3. [値] 列のフィールドにデータを入力するか、下向き矢印をクリックして、一覧から利用可能なオプションを選択します。

次の表は、[参照] プロパティ ページに含まれているプロパティを一覧表示しています。選択するプロパティは、ルート ノード、レコード、またはフィールドのうち、選択したノードに対して設定されます。

[参照] プロパティ ページ : ルート ノードのプロパティ

プロパティ | 値
仕様名 | 仕様の名前です。この名前は、仕様の <Schema> タグの値に対応します。
標準 次の値のいずれかを選択します。
  • [XML] : Extensible Markup Language (XML) に基づいた仕様を作成する場合に選択します。

  • [X12] : ANSI X12 に基づいた仕様を作成する場合に選択します。

  • [EDIFACT] : EDIFACT に基づいた仕様を作成する場合に選択します。

  • [Custom] : フラット ファイルに基づいた仕様を作成する場合、またはカスタム パーサーで解析するカスタム仕様を作成する場合に選択します。

重要

  • たとえばフラット ファイルについて "標準" プロパティの値を [X12] から [Custom] に変更し、次にフィールドを選択し、[解析] プロパティ ページの [カスタム データ型] の値を [Number (N)] または [Number (Nx)] (x は 1 から 9 までの数) に設定すると、フィールドの [解析] プロパティ ページの [カスタム最大値] プロパティは表示されません。そのため、仕様を暗黙的に指定される 10 進数形式との間で変換する場合は、解析結果やシリアライズの出力に対応するために、[宣言] プロパティ ページの [最大値] の値を大きくする必要はありません。
標準バージョン | ANSI X12 バージョン 4010 など、仕様が基づく標準のバージョンです。
ドキュメント型 | 850 など、仕様が基づくドキュメント型です。
バージョン | 仕様が基づくドキュメント標準のバージョン番号です。
既定のレコード区切り記号 [解析] プロパティ ページの [区切り記号の種類] プロパティが "既定のレコード区切り記号" に設定されているすべてのノードで区切り記号として使用される文字を、入力または選択します。

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。
既定のフィールド区切り記号 [解析] プロパティ ページの "区切り記号の種類" プロパティが [既定のフィールド区切り記号] に設定されているすべてのノードで区切り記号として使用される文字を、入力または選択します。

重要

  • ANSI X12 バージョン 4030 以降で一般的なフィールド レベルの区切り記号の繰り返しは、サポートされていません。

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。
既定のサブフィールド区切り記号 [解析] プロパティ ページの "区切り記号の種類" プロパティが [既定のサブフィールド区切り記号] に設定されているすべてのノードで区切り記号として使用される文字を、入力または選択します。

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。
既定のエスケープ文字 [解析] プロパティ ページの "エスケープの種類" プロパティが [既定のエスケープ文字] に設定されているすべてのノードでエスケープ文字として使用される文字を、入力または選択します。

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。
コード ページ 次の値のいずれかを選択します。
  • アラビア語 (1256)

  • バルト語 (1257)

  • 中央ヨーロッパ言語 (1250)

  • キリル文字 (1251)

  • ギリシャ語 (1253)

  • ヘブライ語 (1255)

  • 日本語 (Shift-JIS) (932)

  • 韓国語 (949)

  • Little-Endian-UTF16 (1200)

  • 簡体字中国語 (936)

  • タイ語 (874)

  • 繁体字中国語 (950)

  • トルコ語 (1254)

  • ベトナム語 (1258)

  • 西ヨーロッパ言語 (1252)

注

  • このプロパティは、ルート ノードで [参照] プロパティ ページの "標準" フィールドが [Custom] に設定されている場合にのみ表示されます。

  • UTF7 (65000) と UTF8 (65001) は、BizTalk Server ではサポートされていません。

  • [コード ページ] 値が空白の場合、既定値は [西ヨーロッパ言語 (1252)] です。
受信確認 次のオプションのいずれかを選択します。
  • [はい] : 仕様を、受信される受信確認ドキュメントとして使用することを示します。関連付けコンポーネント ([X12]、[EDIFACT]、または [Custom]) は、受信ドキュメントと受信確認対象の送信ドキュメント (既に受信ドキュメントの送信者に送信済みのドキュメント) を関連付けます

  • [いいえ] : 仕様を、受信される受信確認ドキュメントとして使用しないことを示します。

注

  • 受信の値が空白の場合、既定値は [いいえ] です。

  • CanonicalReceipt に基づいた仕様の場合、および CanonicalReceipt がマップ済みの仕様の場合は、"受信" プロパティを [いいえ] に設定する必要があります (どちらも、送信される受信確認ドキュメントを生成する場合に使用されます)。
エンベロープ 次のオプションのいずれかを選択します。
  • [はい] : 仕様をインターチェンジ仕様として使うことを示します。

  • [いいえ] : 仕様をインターチェンジ仕様として使わないことを示します。

注

  • このプロパティは、エンベロープのフラット ファイルと XML ファイルでのみ使用されます。

  • フィールドが空白の場合、値は [いいえ] であると見なされます。
対象の名前空間 BizTalk フレームワーク インスタンスを使用していて、インスタンスで名前空間を指定した場合は、インスタンスで使用される対応する名前空間を入力する必要があります。

注

  • インスタンスの対象の名前空間の値に "x-schema" を使用すると、BizTalk マッパーでそのインスタンスをテストするときにエラーが発生することがあります。

[参照] プロパティ ページ : レコードのプロパティ

プロパティ 値
最小発生数 ノード階層の所定の位置にレコードが出現できる最小回数です。指定できる値は 0 または 1 です。

注

  • このプロパティ値が空白の場合、既定値は 1 です。
最大発生数 ノード階層の所定の位置にレコードが出現できる最大回数です。指定できる値は 1 とアスタリスク (*) です。

注

  • アスタリスク (*) を入力すると、レコードはループ レコードと見なされます。この仕様を BizTalk マッパーで使用すると、このレコードはループとしてコンパイルされます。1 を入力すると、BizTalk マッパーはこのレコードをループ レコードと見なしません。

  • このプロパティ値が空白の場合、既定値は 1 です。

[参照] プロパティ ページ : フィールドのプロパティ

プロパティ 値
[必須] 次のオプションのいずれかを選択します。
  • [はい] : 必須フィールドであることを示します。

  • [いいえ] : 必須フィールドではないことを示します。

注

  • このプロパティ値が空白の場合、既定値は [いいえ] です。
開始位置 レコードでのフィールドの開始位置を示す数値です。

注

  • このプロパティ フィールドは、親レコードの構造が位置指定の場合にだけ表示されます。
終了位置 レコードでのフィールドの終了位置を示す数値です。

注

  • このプロパティ フィールドは、親レコードの構造が位置指定の場合にだけ表示されます。

関連項目

フィールド位置の計算

文字数の制限

受信確認について


解析のプロパティの設定

  1. 仕様ツリーで、プロパティを設定するルート ノード、レコード、またはフィールドをクリックし、[解析] タブをクリックします。

  2. 設定するプロパティと関連付けられている [値] 列のフィールドをダブルクリックします。

  3. フィールドにデータを入力するか、下向き矢印をクリックして、一覧から利用可能なオプションを選択します。

次の表は、[解析] プロパティ ページに含まれているプロパティを一覧表示しています。利用できるプロパティは、使用する標準 (ANSI X12、EDIFACT、または Custom) と構造のプロパティによって異なります。既定では、空の仕様に基づいた新しい仕様は、Extensible Markup Language (XML) の標準のプロパティを持っています。必要に応じて、各プロパティに値を入力します。選択するプロパティは、ルート ノード、レコード、またはフィールドのうち、選択したノードに対して設定されます。

標準 : XML

[解析] プロパティ ページ : ルート ノード、レコード、およびフィールドのプロパティ

これらのプロパティは表示されません。

標準 : X12 または EDIFACT

重要

  • レコードとその子フィールドの [囲み文字]、[埋め込み文字]、[エスケープ文字]、および [区切り記号] の値は、互いに排他である必要があります。

[解析] プロパティ ページ : ルート ノードまたはレコードのプロパティ

プロパティ 値
構造 この値の既定値は、自動的にルート ノードの [区切り記号] になります。

注

  • 仕様のルート ノードの [参照] プロパティ ページの "標準" プロパティの値が [X12] または [EDIFACT] に設定されている場合は、ルート ノードとすべてのレコードの [解析] プロパティ ページで "構造" プロパティの値を編集できません。"構造" プロパティの値を編集するには、標準を [Custom] に変更します。
送信元のタグ識別子 送信元のタグ識別子の名前です。これは、データを持つレコードと一致させるために使用されるタグ名です。

重要

  • ループ レコードがあり、そのデータ インスタンスがループ構造を含んでいないとき (すなわち構造が暗黙的であって、明示的でないとき)、[送信元のタグ認識子] の値が空白であることを確認してください。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティを入力して元のファイルに存在するタグを識別することができます。[送信元のタグ認識子] に <、>、"、および & の文字を含めることはできません。

  • "送信元のタグ識別子" プロパティでは、大文字と小文字が区別されます。
フィールド順 次のオプションのいずれかを選択します。
  • [接頭辞] : 接頭辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの前に付けます。たとえば、* が区切り記号である場合、a*a*b*c になります。

  • [接尾辞] : 接尾辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの後ろに付けます。たとえば、* が区切り記号である場合、a*a*b*c* になります。

  • [挿入辞] : 挿入辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの間に付けます。たとえば、* が区切り記号である場合、a*a*b*c になります。

注

  • 通常、XML ファイル以外のほとんどのファイルでは、ルート ノードの [フィールド順] を [接尾辞] に設定し、ループ レコード ノードを [挿入辞] に設定する必要があります。その例として、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ にある Flat-FileDelimited フォルダと Flat-FilePositional フォルダに入っているサンプルを参照してください。

  • [フィールド順] の値が空白の場合、既定値は [接頭辞] です。
区切り記号の種類 次のオプションのいずれかを選択して、現在のノードの直下の子ノードの区切り記号を選択します。
  • [既定のレコード区切り記号] : 区切り記号が、ドキュメント インスタンスで定義されている "既定のレコード区切り記号" プロパティの値であることを示します。

  • [既定のフィールド区切り記号] : 区切り記号が、ドキュメント インスタンスで定義されている "既定のフィールド区切り記号" プロパティの値であることを示します。

  • [既定のサブフィールド区切り記号] : 区切り記号が、ドキュメント インスタンスで定義されている "既定のサブフィールド区切り記号" プロパティの値であることを示します。
エスケープの種類

(リリース文字とも呼ばれます)

 次のオプションのいずれかを選択して、現在のノードの直下の子ノードのエスケープ文字を選択します。
  • [既定のエスケープ文字] : エスケープ文字が、ドキュメント インスタンスで定義されている値であることを示します。

エスケープ文字は、フィールド データに含まれている文字が、フィールドの親ノードの区切り記号文字としても使用されている場合に役立ちます。たとえば、フィールド データが次のようになっていて、このフィールドを含むノードの区切り記号値としてカンマを使用している場合、"Browne" の後ろのカンマは、フィールド データの一部ではなく、区切り記号として解釈されます。

Brown,Robert,1231,yes

この問題を解決するには、フィールド データに含める区切り記号文字の直前にエスケープ文字を置きます。たとえば、エスケープ文字として円記号を指定した場合は、次の例のように区切り記号文字の直前に円記号を置きます。

Brown\,Robert,1231,yes

BizTalk エディタでは、円記号の後ろのカンマは、区切り記号文字ではなく、フィールド データとして解釈されます。

注

  • [エスケープの種類] プロパティは、X12 仕様では利用できません。
改行の追加 次のオプションのいずれかを選択します。
  • [はい] : シリアライザがレコード区切り記号に達したときに、改行 (LF、0x0A) を自動的に追加することを示します。

  • [いいえ] : シリアライザがレコード区切り記号に達したときに、次のレコードの処理を同じ行で継続することを示します。

注

  • [改行の追加] の値が空白の場合、既定値は [いいえ] です。
復帰文字のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の復帰文字 (CR) の値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の CR 値をスキップしないようにパーサーに通知します。

注

  • [復帰文字のスキップ] の値が空白の場合、既定値は [はい] です。
改行のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の改行 (LF) 値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の LF 値をスキップしないようにパーサーに通知します。

注

  • [改行のスキップ] の値が空白の場合、既定値は [はい] です。
レコード数の無視 次のオプションのいずれかを選択します。
  • [はい] : 仕様のレコード総数をカウントするときに、このレコードをカウントしないよう、パーサーまたはシリアライザに通知します。

  • [いいえ] : 仕様のレコード総数をカウントするときに、このレコードをカウントするよう、パーサーまたはシリアライザに通知します。

注

  • ドキュメント インスタンスが BizTalk Server に送信されたときに、ドキュメント インスタンスのレコード数が仕様で算出されたレコード数と一致しない場合、解析は失敗します。詳細については、「解析エラー」を参照してください。

  • [レコード数の無視] の値が空白の場合、既定値は [はい] です。
トリガ フィールド 一覧からオプションを選択します。オプションは、利用できるトリガ フィールドを反映しています。

重要

  • このプロパティを利用できるのは、[標準] が [X12] に設定されているときだけです。

注

  • トリガ フィールドの詳細については、「汎用トリガ」を参照してください。
トリガ値 この値は、トリガ フィールドのデータ型の値を表します。

重要

  • このプロパティを利用できるのは、[標準] が [X12] に設定されているときだけです。

注

  • HIPAA スキーマで Microsoft® BizTalk™ Accelerator を使用する場合は、トリガ プロパティの値を変更しないでください。
サブドキュメント作成の中断 次のオプションのいずれかを選択します。
  • [はい] : パーサーまたはシリアライザに対して、レコードよりも上部の親階層をすべてレプリケートする新しいインスタンスを作成するように指示します。

  • [いいえ] : パーサーまたはシリアライザに対して、レコードよりも上部の親階層をすべてレプリケートする新しいインスタンスを作成しないように指示します。

重要

  • このプロパティが表示されるのは、スキーマに含まれているときだけです。

  • このプロパティを利用できるのは、[標準] が [X12] に設定されているときだけです。

注

  • [はい] を指定しない場合は、[サブドキュメント作成の中断] の値が既定で [いいえ] になり、パーサーまたはシリアライザに対して、レコードよりも上部の親階層をすべてレプリケートする新しいインスタンスを作成しないように指示します。

[解析] プロパティ ページ : フィールドのプロパティ

プロパティ | 値
カスタム データ型 次のオプションのいずれかを選択します。
  • String (AN) [文字列] : AN は英数字フィールドを示します。

  • Binary Hexadecimal (B) [バイナリ 16 進数] : B はバイナリ フィールドを示します。

  • Date (CY) [日付] : CY は 4 桁の日付フィールドを示します。

  • Number (D0-4) [数値] : D0 から D4 は 10 進数フィールドです。1 桁の数字は、小数点以下の桁数を表します。

  • Date (DT) [日付] : DT は日付フィールドを示します。

  • String (ID) [文字列] : ID は識別フィールドを示します。

  • Number (N) [数値] : N は整数フィールドを示します。

  • Number (N1-9) [数値] : N1 から N9 は 10 進数フィールドとして暗黙的に使用されます。10 進数字はデータに表示されません。1 桁の数字は、小数点以下の桁数を表します。

    注

    • 仕様を、暗黙的に指定される 10 進数形式との間で変換する場合は、[最大値] の値が解析結果やシリアライズの出力を処理できるかどうか確認する必要があります。たとえば、[カスタム データ型] の値が [N2] に設定されている場合は、[カスタム最大値] は少なくとも 3 である必要があります。これは、解析中にパーサーによって 10 進数が挿入され、さらにシリアライザによって 10 進数が除去されてから、小数点以下の数が検証されるためです。

    • たとえばフラット ファイルについて、[参照] プロパティ ページで "標準" プロパティの値を [X12] から [Custom] に変更し、次に [Number (N)] または [Number (Nx)] (x は 1 から 9 までの数) を選択すると、[カスタム最大値] プロパティは表示されません。そのため、仕様を暗黙的に指定される 10 進数形式との間で変換する場合は、解析結果やシリアライズの出力に対応するために、[宣言] プロパティ ページの [最大値] の値を大きくする必要はありません。
  • Number (R) [数値] : R は数値フィールドを示します。

  • Time (TM) [時刻] : TM は時刻フィールドを示します。

重要

  • [カスタム データ型] の値を指定すると、[宣言] プロパティ ページの [データ型] の値は [カスタム データ型] で選択した値と一致するように自動的に変更されます。たとえば、[解析] プロパティ ページの [カスタム データ型] の値を [Date (CY)] に変更すると、[宣言] プロパティ ページの [データ型] の値は自動的に [Date] に変更されます。

注

  • "カスタム データ型" プロパティに [Date (DT)]、[Date (CY)]、または [Time (TM)] を指定した場合は、"カスタム日付/時刻書式" プロパティの値も設定する必要があります。

  • "標準" プロパティが [X12] に設定されている仕様では、これらのすべてのカスタム データ型の値がサポートされます。"標準" プロパティが [EDIFACT] に設定されている仕様でサポートされるカスタム データ型の値は、[String (AN)] と [Number (N)] です。
カスタム日付/時刻書式 "カスタム データ型" プロパティとして [Date (DT)]、[Date (CY)]、または [Time (TM)] を設定した場合は、一覧のオプションをクリックします。詳細については、「カスタム日付/時刻書式プロパティの適用」を参照してください。サポートされている時刻書式の詳細については、「サポートされている X12 の時刻書式」を参照してください。

注

  • このプロパティ フィールドは、[カスタム データ型] を [Date (DT)]、[Date (CY)]、または [Time (TM)] に設定した場合にだけ利用できます。

重要

  • BizTalk Server のパーサーは、受信ドキュメント インスタンス内のユリウス日付書式を認識しません。ユリウス日付書式は、日を示す 3 桁の数字 (DDD) を含みます。BizTalk エディタでユリウス日付書式を使用する仕様を作成することはできますが、この機能を利用できるのは、ユリウス日付書式を使用したドキュメント インスタンスを認識するカスタム パーサーだけです。ユリウス日付書式を認識するカスタム パーサーを採用しない場合は、仕様またはドキュメント インスタンスでユリウス日付書式を使用しないでください。
位置揃え 次のオプションのいずれかを選択します。
  • [左] : 位置指定フラット ファイルの場合、データが最大フィールド長より小さいときに、そのデータを左側に揃えます。区切りフラット ファイルの場合は、必要最小値よりもデータ量の方が小さいときに、そのデータを左側に揃えます。

  • [右] : 位置指定フラット ファイルの場合、データが最大フィールド長より小さいときに、そのデータを右側に揃えます。区切りフラット ファイルの場合は、必要最小値よりもデータ量の方が小さいときに、そのデータを左側に揃えます。

注

  • [位置揃え] の値が空白の場合、既定値は [左] です。
埋め込み文字 | フィールドに埋め込む文字を入力または選択します。埋め込み文字には、スペースまたは 0 を含むすべての文字を選択できます。詳細については、「埋め込み文字」を参照してください。
囲み文字 フィールド データを囲む文字を入力します。このプロパティは、フィールド データに含まれている文字が、フィールドの親ノードの区切り記号値としても使用されている場合に役立ちます。たとえば、フィールド データが次のようになっていて、このフィールドを含むノードの区切り記号値としてカンマを使用している場合、"Browne" の後ろのカンマは、フィールド データの一部ではなく、区切り記号として解釈されます。

Brown,Robert,1231,yes

この問題を解決するには、"囲み文字" プロパティの値を定義してから、フィールド データを囲み文字で囲むようにします。たとえば、最初のフィールドの "囲み文字" プロパティを二重引用符に設定し、次の例のようにフィールド データを入力します。

"Brown,Robert",1231,yes

二重引用符の間のカンマは、区切り記号値ではなく、フィールド データとして解釈されます。

重要

  • フィールドで囲み文字が使用されている場合は、囲み文字とそれに先行または後続する区切り記号との間にデータを入れることはできません。

注

  • 囲み文字としても使用される文字がフィールド データに含まれている場合は、この文字を別の囲み文字のセットで囲む必要があります。

    たとえば、囲み文字の値が次のように二重引用符に設定されているとします。

    "Brown,Robert ""Rob"""

    BizTalk エディタはこれを次のように解析します。

    Brown,Robert "Rob"
埋め込み文字を含めた最小値 出力ドキュメント インスタンスのフィールドの、埋め込み文字を含めた最小値です。埋め込み文字の詳細については、「埋め込み文字」を参照してください。

注

  • このプロパティは、フィールドに埋め込み文字が設定されている場合にのみ設定できます。

  • フィールドの [宣言] プロパティ ページで "最小値" プロパティを設定した場合は、"埋め込み文字を含めた最小値" プロパティを "最小値" プロパティの値以上にする必要があります。"最小値" プロパティを設定していない場合は、"埋め込み文字を含めた最小値" プロパティを 1 以上にします。
カスタム最大値 このフィールドが保持できる文字数の最大値を入力し、Enter キーを押します。

注

  • このプロパティは、数値フィールドでピリオドやダッシュなどを使用できるようにします。

  • このプロパティが表示されるのは、[カスタム データ型] の値が [Number (N)] 、[Number (Nx)] (x は 1 から 9 までの数)、または [Number (R)] になっているときだけです。

  • EDI インスタンスでは、[カスタム最大値] の値を Nx の x (ここで x は 1 から 9 までの数) よりも大きくする必要があります。たとえば、[カスタム データ型] の値が [N2] に設定されている場合は、[カスタム最大値] は少なくとも 3 である必要があります。これは、解析中にパーサーによって 10 進数が挿入され、さらにシリアライザによって 10 進数が除去されて小数点以下の数が検証されるためです。

標準 : [Custom]
"構造" プロパティ: [区切り記号] :

重要

  • レコードとその子フィールドの [囲み文字]、[埋め込み文字]、[エスケープ文字]、および [区切り記号] の値は、互いに排他である必要があります。

  • 囲み文字とエスケープ文字には必ず異なる値を指定してください。

[解析] プロパティ ページ : ルート ノードまたはレコードのプロパティ

プロパティ | 値
構造 ルート ノードのプロパティで次のオプションを選択します。
  • [区切り記号] : ルート ノードが区切りファイル構造に基づいていることを示します。レコードは、個別に区切りファイル構造または位置指定ファイル構造に基づくことができます。

レコードのプロパティで次のオプションのいずれかを選択します。

  • [区切り記号] : レコードが区切りファイル構造に基づいていることを示します。子孫レコードは、個別に区切りファイル構造または位置指定ファイル構造に基づくことができます。

  • [位置指定] : レコードが位置指定ファイル構造に基づいていることを示します。位置指定レコードは子レコードを持つことができません。

注

  • 区切り記号と位置指定の両方の構造を含むドキュメントの場合は、ルート ノードの "構造" プロパティを [区切り記号] に設定する必要があります。レコードの "構造" プロパティは、必要に応じて個別に [位置指定] または [区切り記号] に設定できます。

  • 仕様の構造が位置指定である場合は、フィールドの [宣言] プロパティ ページで [種類] 値として [要素] を指定しないでください。指定すると、検証が失敗します。

  • 一方の構造からもう一方の構造に変更すると、メッセージ ボックスが表示されます。 [はい] をクリックして構造の変更を確認します。新しいプロパティが表示されたり、既存のプロパティの一部が削除される可能性があります。

  • 位置指定レコードの "構造" プロパティの "値" フィールドを右クリックし、[プロパティのクリア] をクリックすると、レコードの構造は区切り記号と解釈されます。新しいプロパティが表示されたり、既存のプロパティの一部が削除される可能性があります。

  • ドキュメントの "標準" プロパティが [Custom] に設定されている場合、ルート ノードとすべてのレコードの "構造" プロパティの既定値は空白です。"構造" プロパティを空白のままにしておくと、値は [区切り記号] になります。
送信元のタグ識別子 送信元のタグ識別子の名前です。これは、データを持つレコードと一致させるために使用されるタグ名です。

重要

  • ループ レコードがあり、そのデータ インスタンスがループ構造を含んでいないとき (すなわち構造が暗黙的であって、明示的でないとき)、[送信元のタグ認識子] の値が空白であることを確認してください。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティを入力して元のファイルに存在するタグを識別することができます。[送信元のタグ認識子] に <、>、"、および & の文字を含めることはできません。

  • "送信元のタグ識別子" プロパティでは、大文字と小文字が区別されます。
フィールド順 次のオプションのいずれかを選択します。
  • [接頭辞] : 接頭辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの前に付けます。たとえば、* が区切り記号である場合、a*a*b*c になります。

  • [接尾辞] : 接尾辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの後ろに付けます。たとえば、* が区切り記号である場合、a*a*b*c* になります。

  • [挿入辞] : 挿入辞の区切り記号を、コンポーネントと一連のコンポーネントのメンバの間に付けます。たとえば、* が区切り記号である場合、a*a*b*c になります。

注

  • 通常、XML ファイル以外のほとんどのファイルでは、ルート ノードの [フィールド順] を [接尾辞] に設定し、ループ レコード ノードを [挿入辞] に設定する必要があります。その例として、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ にある Flat-FileDelimited フォルダと Flat-FilePositional フォルダに入っているサンプルを参照してください。

  • [フィールド順] の値が空白の場合、既定値は [接頭辞] です。
区切り記号の種類 次のオプションのいずれかを選択して、現在のノードの直下の子ノードの区切り記号を選択します。
  • [文字] : [解析] プロパティ ページで区切り記号の値を指定できるようにします。[文字] を選択した場合は、区切り記号値を指定する必要があります。

  • [既定のレコード区切り記号] : 区切り記号は、ルート ノードの [参照] プロパティ ページの "既定のレコード区切り記号" プロパティの値であることを示します。

  • [既定のフィールド区切り記号] : 区切り記号は、ルート ノードの [参照] プロパティ ページの "既定のフィールド区切り記号" プロパティの値であることを示します。

  • [既定のサブフィールド区切り記号] : 区切り記号は、ルート ノードの [参照] プロパティ ページの "既定のサブフィールド区切り記号" プロパティの値であることを示します。
区切り記号値 | 区切り記号に使用する文字の値を入力または選択します。区切り記号値を指定するには、まず [解析] プロパティ ページの [区切り記号の種類] を [文字] に設定します。
エスケープの種類

(リリース文字とも呼ばれます)

 次のオプションのいずれかを選択して、現在のノードの直下の子ノードのエスケープ文字を選択します。
  • [文字] : [解析] プロパティ ページでエスケープ文字の値を指定できるようにします。[文字] を選択した場合は、エスケープ文字の値を指定する必要があります。

  • [既定のエスケープ文字] : エスケープ文字は、ルート ノードの [参照] プロパティ ページの "既定のエスケープ文字" プロパティの値であることを示します。

エスケープ文字は、フィールド データに含まれている文字が、フィールドの親ノードの区切り記号文字としても使用されている場合に役立ちます。たとえば、フィールド データが次のようになっていて、このフィールドを含むノードの区切り記号値としてカンマを使用している場合、"Browne" の後ろのカンマは、フィールド データの一部ではなく、区切り記号として解釈されます。

Brown,Robert,1231,yes

この問題を解決するには、フィールド データに含める区切り記号文字の直前にエスケープ文字を置きます。たとえば、エスケープ文字として円記号を指定した場合は、次の例のように区切り記号文字の直前に円記号を置きます。

Brown\,Robert,1231,yes

BizTalk エディタでは、円記号の後ろのカンマは、区切り記号文字ではなく、フィールド データとして解釈されます。
エスケープの値 | エスケープ文字に使用する文字の値を入力または選択します。エスケープ文字の値を指定するには、まず [解析] プロパティ ページの [エスケープの種類] を [文字] に設定します。
改行の追加 次のオプションのいずれかを選択します。
  • [はい] : シリアライザがレコード区切り記号に達したときに、改行 (LF、0x0A) を自動的に追加することを示します。

  • [いいえ] : シリアライザがレコード区切り記号に達したときに、次のレコードの処理を同じ行で継続することを示します。

注

  • [改行の追加] の値が空白の場合、既定値は [いいえ] です。
復帰文字のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の復帰文字 (CR) の値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の CR 値をスキップしないようにパーサーに通知します。

注

  • [復帰文字のスキップ] の値が空白の場合、既定値は [はい] です。
改行のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の改行 (LF) 値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の LF 値をスキップしないようにパーサーに通知します。

注

  • [改行のスキップ] の値が空白の場合、既定値は [はい] です。
レコード数の無視 次のオプションのいずれかを選択します。
  • [はい] : 仕様のレコード総数をカウントするときに、このレコードをカウントしないよう、パーサーまたはシリアライザに通知します。

  • [いいえ] : 仕様のレコード総数をカウントするときに、このレコードをカウントするよう、パーサーまたはシリアライザに通知します。

注

  • ドキュメント インスタンスが BizTalk Server に送信されたときに、ドキュメント インスタンスのレコード数が仕様で算出されたレコード数と一致しない場合、解析は失敗します。詳細については、「解析エラー」を参照してください。

  • [レコード数の無視] の値が空白の場合、既定値は [はい] です。

[解析] プロパティ ページ : フィールドのプロパティ

プロパティ | 値
カスタム データ型 次のオプションのいずれかを選択します。
  • String (AN) [文字列] : AN は英数字フィールドを示します。

  • Binary Hexadecimal (B) [バイナリ 16 進数] : B はバイナリ フィールドを示します。

  • Date (CY) [日付] : CY は 4 桁の日付フィールドを示します。

  • Number (D0-4) [数値] : D0 から D4 は 10 進数フィールドです。1 桁の数字は、小数点以下の桁数を表します。

  • Date (DT) [日付] : DT は日付フィールドを示します。

  • String (ID) [文字列] : ID は識別フィールドを示します。

  • Number (N) [数値] : N は整数フィールドを示します。

  • Number (N1-9) [数値] : N1 から N9 は 10 進数フィールドとして暗黙的に使用されます。10 進数字はデータに表示されません。1 桁の数字は、小数点以下の桁数を表します。

    注

    • 仕様を、暗黙的に指定される 10 進数形式との間で変換する場合は、[最大値] の値が解析結果やシリアライズの出力を処理できるかどうか確認する必要があります。たとえば、[カスタム データ型] の値が [N2] に設定されている場合は、[カスタム最大値] は少なくとも 3 である必要があります。これは、解析中にパーサーによって 10 進数が挿入され、さらにシリアライザによって 10 進数が除去されてから、小数点以下の数が検証されるためです。

    • たとえばフラット ファイルについて、[参照] プロパティ ページで "標準" プロパティの値を [X12] から [Custom] に変更し、次に [Number (N)] または [Number (Nx)] (x は 1 から 9 までの数) を選択すると、[カスタム最大値] プロパティは表示されません。そのため、仕様を暗黙的に指定される 10 進数形式との間で変換する場合は、解析結果やシリアライズの出力に対応するために、[宣言] プロパティ ページの [最大値] の値を大きくする必要はありません。
  • Number (R) [数値] : R は数値フィールドを示します。

  • Time (TM) [時刻] : TM は時刻フィールドを示します。

重要

  • [カスタム データ型] の値を指定すると、[宣言] プロパティ ページの[データ型] の値は [カスタム データ型] で選択した値と一致するように自動的に変更されます。たとえば、[解析] プロパティ ページの [カスタム データ型] 値を [Date (CY)] に変更すると、[宣言] プロパティ ページの [データ型] 値は自動的に [Date] に変更されます。

注

  • "カスタム データ型" プロパティに [Date (DT)]、[Date (CY)]、または [Time (TM)] を指定した場合は、"カスタム日付/時刻書式" プロパティの値も設定する必要があります。
カスタム日付/時刻書式 "カスタム データ型" プロパティとして [Date (DT)]、[Date (CY)]、または [Time (TM)] を設定した場合は、一覧のオプションをクリックします。詳細については、「カスタム日付/時刻書式プロパティの適用」を参照してください。サポートされている時刻書式の詳細については、「サポートされている X12 の時刻書式」を参照してください。

注

  • このプロパティ フィールドは、[カスタム データ型] を [Date (DT)]、[Date (CY)]、または [Time (TM)] に設定した場合にだけ利用できます。
位置揃え 次のオプションのいずれかを選択します。
  • [左] : 位置指定ファイルの場合、データが最大フィールド長より小さいときに、そのデータを左側に揃えます。区切りファイルの場合は、必要最小値よりもデータ量の方が小さいときに、そのデータを左側に揃えます。

  • [右] : 位置指定フラット ファイルの場合、データが最大フィールド長より小さいときに、そのデータを右側に揃えます。区切りフラット ファイルの場合は、必要最小値よりもデータ量の方が小さいときに、そのデータを左側に揃えます。

注

  • [位置揃え] の値が空白の場合、既定値は [左] です。
埋め込み文字 | フィールドに埋め込む文字を入力または選択します。埋め込み文字には、スペースまたは 0 を含むすべての文字を選択できます。詳細については、「埋め込み文字」を参照してください。
囲み文字 フィールド データを囲む文字を入力します。このプロパティは、フィールド データに含まれている文字が、フィールドの親ノードの区切り記号値としても使用されている場合に役立ちます。たとえば、フィールド データが次のようになっていて、このフィールドを含むノードの区切り記号値としてカンマを使用している場合、"Browne" の後ろのカンマは、フィールド データの一部ではなく、区切り記号として解釈されます。

Brown,Robert,1231,yes

この問題を解決するには、"囲み文字" プロパティの値を定義してから、フィールド データを囲み文字で囲むようにします。たとえば、最初のフィールドの "囲み文字" プロパティを二重引用符に設定し、次の例のようにフィールド データを入力します。

"Brown,Robert",1231,yes

二重引用符の間のカンマは、区切り記号値ではなく、フィールド データとして解釈されます。

注

  • 囲み文字としても使用される文字がフィールド データに含まれている場合は、この文字を別の囲み文字のセットで囲む必要があります。

    たとえば、囲み文字の値が次のように二重引用符に設定されているとします。

    "Brown,Robert ""Rob"""

    BizTalk エディタはこれを次のように解析します。

    Brown,Robert "Rob"

  • 入力ドキュメント インスタンスのフィールド データに改行文字と復帰文字が連続して含まれている場合は、両方が囲み文字のセットに囲まれていても、出力ドキュメント インスタンスの対応するフィールド データには改行文字だけが含まれます。
埋め込み文字を含めた最小値 出力ドキュメント インスタンスのフィールドの、埋め込み文字を含めた最小値です。詳細については、「埋め込み文字」を参照してください。

注

  • このプロパティは、フィールドに埋め込み文字が設定されている場合にだけ設定できます。

  • フィールドの [宣言] プロパティ ページで "最小値" プロパティを設定した場合は、"埋め込み文字を含めた最小値" プロパティを "最小値" プロパティの値以上にする必要があります。"最小値" プロパティを設定していない場合は、"埋め込み文字を含めた最小値" プロパティを 1 以上にします。

標準 : [Custom]
"構造" プロパティ: [位置指定]

[解析] プロパティ ページ : ルート ノードまたはレコードのプロパティ

プロパティ | 値
構造 ルート ノードのプロパティで次のオプションを選択します。
  • [位置指定] : ルート ノードが位置指定フラット ファイル構造に基づいていることを示します。

重要

  • フィールドの最大サイズの推奨値は 1 メガバイト (MB) です。この限界を超えてもかまいませんが、BizTalk Server のパフォーマンスが著しく低下します。

注

  • 仕様の構造が位置指定である場合は、フィールドの [宣言] プロパティ ページで [種類] 値として [要素] を指定しないでください。指定すると、検証が失敗します。

  • 位置指定ルート ノードのドキュメントにはレコードを含めることはできません。

  • 位置指定ルート ノードの "構造" プロパティの "値" フィールドを右クリックし、[プロパティのクリア] をクリックすると、ルート ノードの構造は区切り記号と解釈されます。新しいプロパティが表示されたり、既存のプロパティの一部が削除される可能性があります。

  • ドキュメントの "標準" プロパティが [Custom] に設定されている場合、ルート ノードとすべてのレコードの "構造" プロパティの既定値は空白です。"構造" プロパティを空白のままにしておくと、値は [区切り記号] になります。
送信元のタグ識別子 送信元のタグ識別子の名前です。これは、データを持つレコードと一致させるために使用されるタグ名です。

重要

  • ループ レコードがあり、そのデータ インスタンスがループ構造を含んでいないとき (すなわち構造が暗黙的であって、明示的でないとき)、[送信元のタグ認識子] の値が空白であることを確認してください。

注

  • フラット ファイルなどの非 XML ファイルでは、"送信元のタグ識別子" プロパティを入力して元のファイルに存在するタグを識別することができます。[送信元のタグ認識子] に <、>、"、および & の文字を含めることはできません。

  • "送信元のタグ識別子" プロパティでは、大文字と小文字が区別されます。
送信元のタグ位置 | 位置指定レコードの中でタグが始まる位置を表す数値です。
改行の追加 次のオプションのいずれかを選択します。
  • [はい] : シリアライザがレコード区切り記号に達したときに、改行 (LF、0x0A) を自動的に追加することを示します。

  • [いいえ] : シリアライザがレコード区切り記号に達したときに、次のレコードの処理を同じ行で継続することを示します。

注

  • [改行の追加] の値が空白の場合、既定値は [いいえ] です。
復帰文字のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の復帰文字 (CR) の値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の CR 値をスキップしないようにパーサーに通知します。

注

  • [復帰文字のスキップ] の値が空白の場合、既定値は [はい] です。
改行のスキップ 次のオプションのいずれかを選択します。
  • [はい] : 区切り記号の後の改行 (LF) 値をスキップするようにパーサーに通知します。

  • [いいえ] : 区切り記号の後の LF 値をスキップしないようにパーサーに通知します。

注

  • [改行のスキップ] の値が空白の場合、既定値は [はい] です。
レコード数の無視 次のオプションのいずれかを選択します。
  • [はい] : 仕様のレコード総数をカウントするときに、このレコードをカウントしないよう、パーサーまたはシリアライザに通知します。

  • [いいえ] : 仕様のレコード総数をカウントするときに、このレコードをカウントするよう、パーサーまたはシリアライザに通知します。

注

  • ドキュメント インスタンスが BizTalk Server に送信されたときに、ドキュメント インスタンスのレコード数が仕様で算出されたレコード数と一致しない場合、解析は失敗します。詳細については、「解析エラー」を参照してください。

  • [レコード数の無視] の値が空白の場合、既定値は [はい] です。

[解析] プロパティ ページ : フィールドのプロパティ

プロパティ | 値
カスタム データ型 次のオプションのいずれかを選択します。
  • String (AN) [文字列] : AN は英数字フィールドを示します。

  • Binary Hexadecimal (B) [バイナリ 16 進数] : B はバイナリ フィールドを示します。

  • Date (CY) [日付] : CY は 4 桁の日付フィールドを示します。

  • Number (D0-4) [数値] : D0 から D4 は 10 進数フィールドです。1 桁の数字は、小数点以下の桁数を表します。

  • Date (DT) [日付] : DT は日付フィールドを示します。

  • String (ID) [文字列] : ID は識別フィールドを示します。

  • Number (N) [数値] : N は整数フィールドを示します。

  • Number (N1-9) [数値] : N1 から N9 は 10 進数フィールドとして暗黙的に使用されます。10 進数字はデータに表示されません。1 桁の数字は、小数点以下の桁数を表します。

    注

    • 仕様を、暗黙的に指定される 10 進数形式との間で変換する場合は、[最大値] の値が解析結果やシリアライズの出力を処理できるかどうか確認する必要があります。たとえば、[カスタム データ型] の値が [N2] に設定されている場合は、[カスタム最大値] は少なくとも 3 である必要があります。これは、解析中にパーサーによって 10 進数が挿入され、さらにシリアライザによって 10 進数が除去されてから、小数点以下の数が検証されるためです。

    • たとえばフラット ファイルについて、[参照] プロパティ ページで "標準" プロパティの値を [X12] から [Custom] に変更し、次に [Number (N)] または [Number (Nx)] (x は 1 から 9 までの数) を選択すると、[カスタム最大値] プロパティは表示されません。そのため、仕様を暗黙的に指定される 10 進数形式との間で変換する場合は、解析結果やシリアライズの出力に対応するために、[宣言] プロパティ ページの [最大値] の値を大きくする必要はありません。
  • Number (R) [数値] : R は数値フィールドを示します。

  • Time (TM) [時刻] : TM は時刻フィールドを示します。

重要

  • [カスタム データ型] の値を指定すると、[宣言] プロパティ ページの[データ型] の値は [カスタム データ型] で選択した値と一致するように自動的に変更されます。たとえば、[解析] プロパティ ページの [カスタム データ型] の値を [Date (CY)] に変更すると、[宣言] プロパティ ページの [データ型] の値は自動的に [Date] に変更されます。[宣言] プロパティ ページの "データ型" の値を指定すると、"カスタム データ型" の値が消去されます。

注

  • "カスタム データ型" プロパティに [Date (DT)]、[Date (CY)]、または [Time (TM)] を指定した場合は、"カスタム日付/時刻書式" プロパティの値も設定する必要があります。
カスタム日付/時刻書式 "カスタム データ型" プロパティとして [Date (DT)]、[Date (CY)]、または [Time (TM)] を設定した場合は、一覧のオプションをクリックします。詳細については、「カスタム日付/時刻書式プロパティの適用」を参照してください。サポートされている時刻書式の詳細については、「サポートされている X12 の時刻書式」を参照してください。

注

  • このプロパティ フィールドは、[カスタム データ型] を [日付 (DT)]、[日付 (CY)]、または [時刻 (TM)] に設定した場合にだけ利用できます。
位置揃え 次のオプションのいずれかを選択します。
  • [左] : 位置指定フラット ファイルの場合、データが最大フィールド長より小さいときに、そのデータを左側に揃えます。区切りフラット ファイルの場合は、必要最小値よりもデータ量の方が小さいときに、そのデータを左側に揃えます。

  • [右] : 位置指定フラット ファイルの場合、データが最大フィールド長より小さいときに、そのデータを右側に揃えます。区切りフラット ファイルの場合は、必要最小値よりもデータ量の方が小さいときに、そのデータを左側に揃えます。

注

  • [位置揃え] の値が空白の場合、既定値は [左] です。
埋め込み文字 | フィールドに埋め込むために使用する文字を入力します。埋め込み文字には、スペースまたは 0 を含むすべての文字を選択できます。詳細については、「埋め込み文字」を参照してください。

関連項目

文字数の制限

埋め込み文字


カスタム日付/時刻書式プロパティの適用

[カスタム日付/時刻書式] データ型は、HHMMSSDD という書式で日付と時刻の情報を送信できるようにします。この時刻書式の詳細については、前の「サポートされている X12 の時刻書式」のトピックを参照してください。

  1. 仕様ツリーで、"カスタム日付/時刻" プロパティを設定するルート ノード、レコード、またはフィールドをクリックし、[解析] タブをクリックします。

  2. [カスタム データ型] の隣の [値] 列をダブルクリックします。

  3. オプションの一覧で [Time (TM)] をクリックし、Enter キーを押します。

    警告メッセージが表示されます。

  4. [はい] をクリックします。

  5. [カスタム日付/時刻書式] の隣の [値] 列をダブルクリックします。

  6. 値一覧で [HHMMSSDD] をクリックし、Enter キーを押します。

    新しい "カスタム日付/時刻" データ型が適用されます。

重要

  • 時刻を 10 分の 1 秒または 100 分の 1 秒の精度で表す場合は、ここで説明した "カスタム日付/時刻" データ型を使用してください。

注

  • カスタム日付/時刻を "HHMMSSDD" に変更すると、[解析] プロパティ ページの "カスタム日付/時刻" プロパティのデータ型は [文字列] に変更されます。

  • この "カスタム日付/時刻" データ型を使用すると、次の書式のいずれかで時刻を送信することができます。
    • HHMM

    • HHMMSS

    • HHMMSSD

    • HHMMSSDD

    X12 パーサーおよびシリアライザは "カスタム日付/時刻" データ型を左から右に読み取り、送信された日付と時刻が 8 文字未満であっても、エラー メッセージを返しません。たとえば、次の日付と時刻のデータが有効です。

    • 2211

    • 221101
  • "カスタム日付/時刻" データ型を使用する場合は、10 分の 1 秒を表す時刻データ以外の時刻データ コンテンツの送受信は、常に偶数桁で行う必要があります。たとえば、2211 は有効な時刻データですが、22115 は無効です。

  • この "カスタム日付/時刻" データ型を利用できるのは、スキーマのベースになっている標準が X12 である場合だけです。

関連項目

サポートされている X12 の時刻書式


名前空間の宣言

  1. 仕様ツリーで、任意のノードをクリックします。

  2. [名前空間] タブをクリックします。

  3. [プレフィックス] 列の最初の空白フィールドを右クリックし、[追加] をクリックします。

  4. 名前空間プレフィックスを入力し、Enter キーを押します。

  5. 右隣の [統一リソース名 (URN)] 列のフィールドをダブルクリックします。

  6. 統一リソース名 (URN) を入力し、Enter キーを押します。

重要

  • [統一リソース名 (URN)] に入力した名前空間は BizTalk エディタによって検証されません。

  • "x-schema:" で始まる名前空間 URN を指定しないでください。仕様に "x-schema" が含まれると、スキーマ参照はランタイム エンジンによって解決されません。

名前空間の詳細については、「名前空間宣言」を参照してください。

関連項目

カスタム コメントの追加

文字数の制限

カスタム コメントの削除

カスタム コメントの編集

名前空間宣言


カスタム コメントの追加

  1. 仕様ツリーで、カスタム コメントを追加するルート ノード、レコード、またはフィールドをクリックします。

    注

    • ルート ノードの [参照] プロパティ ページにカスタム コメントを追加することはできません。
  2. カスタム コメントを追加するプロパティ ページに応じて、[宣言] タブまたは [参照] タブをクリックします。

  3. [プロパティ] 列の最初の空白フィールドを右クリックし、[追加] をクリックします。

    [プロパティ] 列の編集モードがアクティブになります。

  4. プレフィックスと名前の組 (たとえば、bts:specification。ここで "bts" はプレフィックスで、"specification" は名前の組です。プレフィックスと名前の組をコロンで区切る必要があります) を入力し、Enter キーを押します。

    または

    一覧のカスタム コメントを 1 つクリックし、Enter キーを押します。

  5. 右隣の [値] 列の空白フィールドをダブルクリックします。

  6. カスタム コメントの値を入力し、Enter キーを押します。

重要

  • 仕様を正常にコンパイルするには、手順 4. で使用される名前空間プレフィックスを仕様で宣言しておく必要があります。詳細については、「名前空間の宣言」を参照してください。

関連項目

SQL コメントの追加

名前空間の宣言

カスタム コメントの削除

カスタム コメントの編集

名前空間宣言


カスタム コメントの編集

  1. 仕様ツリーで、編集するカスタム コメントが含まれているノードをクリックします。

  2. 編集するカスタム コメントを参照するタブ ([宣言] または [参照]) をクリックします。

  3. カスタム コメントの [プロパティ] フィールドをダブルクリックしてフィールドを編集し、Enter キーを押します。

  4. カスタム コメントの [値] フィールドをダブルクリックしてフィールドを編集し、Enter キーを押します。

関連項目

SQL コメントの追加

名前空間の宣言

名前空間宣言


カスタム コメントの削除

  1. 仕様ツリーで、削除するカスタム コメントが含まれているノードをクリックします。

  2. 削除するカスタム コメントを参照するタブ ([宣言] または [参照]) をクリックします。

  3. カスタム コメントを右クリックし、[削除] をクリックします。

  4. [はい] をクリックして変更を確認します。

関連項目

カスタム コメントの追加

SQL コメントの追加

名前空間の宣言.

カスタム コメントの編集

名前空間宣言


ディクショナリ プロパティの設定

  1. 仕様ツリーで、プロパティを指定するルート ノード、レコード、またはフィールドをクリックし、[ディクショナリ] タブをクリックします。

  2. [プロパティ] 列で、フィールドと関連付ける値のチェック ボックスをオンにします。

次の表は、[ディクショナリ] プロパティ ページに含まれているプロパティを一覧表示しています。[ディクショナリ] プロパティを設定できるのは、[参照] プロパティ ページの [標準] プロパティが [XML] または [Custom] に設定されている仕様だけです。

[ディクショナリ] プロパティ ページ : ルート ノードまたはレコードのプロパティ

プロパティ | ノード パス
ドキュメントのコンテナ ノード | エンベロープ スキーマで、ドキュメント ノードはドキュメントが含まれているレコードを示します。

注

  • BizTalk Server のフラット ファイル パーサーで解析され、[参照] プロパティ ページの "標準" プロパティが [Custom] に設定されているフラット ファイル仕様では、[ディクショナリ] プロパティ ページの [ドキュメントのコンテナ ノード] チェック ボックスをオンにしてもオフにしても影響はありません。このディクショナリ プロパティは利用可能ですが、利用するには、"ドキュメントのコンテナ ノード" ディクショナリ プロパティを使用するカスタム仕様とカスタム パーサーを作成する必要があります。

[ディクショナリ] プロパティ ページ : フィールドのプロパティ

プロパティ | ノード パス
ドキュメント名 | ドキュメント名が含まれているドキュメント インスタンスのフィールドのパスを表示します。
送信元の種類 | 送信元の種類が含まれているドキュメント インスタンスのフィールドのパスを表示します。
送信元の値 | 送信元の値が含まれているドキュメント インスタンスのフィールドのパスを表示します。
送信先の種類 | 送信先の種類が含まれているドキュメント インスタンスのフィールドのパスを表示します。
送信先の値 | 送信先の値が含まれているドキュメント インスタンスのフィールドのパスを表示します。

注

  • 仕様の解析では、チャネルの場所の特定には [ディクショナリ] プロパティ ページの情報が使用されます。チャネルは BizTalk メッセージ マネージャを使用して作成できます。チャネルと BizTalk メッセージ マネージャの詳細については、「チャネルについて」を参照してください。

  • オープンなメッセージ ポートに送信されるドキュメントを仕様を使って定義する場合は、送信先とトランスポートの情報を含むフィールドの [ディクショナリ] プロパティ ページで、送信先の値を選択する必要があります。送信パラメータを使用している場合は、ドキュメント内の送信先の情報は上書きされます。ドキュメントの送信の詳細については、「Submitting」を参照してください。

  • "ディクショナリ" プロパティを設定するには、[プロパティ] 列のフィールドを右クリックし、[ルーティング情報の設定] をクリックする方法もあります。

関連項目

カスタム ディクショナリ プロパティの追加

文字数の制限

ディクショナリ プロパティの消去

カスタム ディクショナリ プロパティの削除

カスタム ディクショナリ プロパティの名前の変更

Submitting

メッセージ ポートについて


カスタム ディクショナリ プロパティの追加

  1. 仕様ツリーで、カスタム ディクショナリ プロパティを追加するフィールドをクリックします。

  2. [ディクショナリ] タブをクリックします。

  3. [プロパティ] 列の最初の空白フィールドをダブルクリックします。

  4. プロパティの名前を入力し、Enter キーを押します。

注

  • 作成するカスタム プロパティごとに一意な名前を指定してください。

  • ルート ノードの "標準" プロパティが [X12] または [EDIFACT] に設定されている必要があります。

関連項目

ディクショナリ プロパティの消去

カスタム ディクショナリ プロパティの削除

カスタム ディクショナリ プロパティの名前の変更

ディクショナリ プロパティの設定


カスタム ディクショナリ プロパティの名前の変更

  1. [ディクショナリ] タブをクリックします。

  2. 名前を変更するカスタム プロパティを右クリックし、[名前の変更] をクリックします。

  3. プロパティの名前を入力し、Enter キーを押します。

注

  • 作成するカスタム プロパティごとに一意な名前を指定してください。

関連項目

カスタム ディクショナリ プロパティの追加

ディクショナリ プロパティの消去

カスタム ディクショナリ プロパティの削除

ディクショナリ プロパティの設定


ディクショナリ プロパティの消去

  1. 仕様ツリーで、"ディクショナリ" プロパティを消去するノードをクリックし、[ディクショナリ] タブをクリックします。

  2. [プロパティ] 列で、フィールドとの関連付けを解除する値のチェック ボックスをオフにします。

注

  • "ディクショナリ" プロパティの値を消去するには、[プロパティ] 列のフィールドを右クリックし、[ルーティング情報のクリア] をクリックする方法もあります。

  • ノードの "ディクショナリ" プロパティを消去すると、ルーティング情報が削除されます。

関連項目

カスタム ディクショナリ プロパティの追加

文字数の制限

カスタム ディクショナリ プロパティの削除

カスタム ディクショナリ プロパティの名前の変更

宣言のプロパティの設定


カスタム ディクショナリ プロパティの削除

  1. [ディクショナリ] タブをクリックします。

  2. 削除するカスタム プロパティを右クリックし、[削除] をクリックします。

  3. [はい] をクリックして変更を確認します。

関連項目

カスタム ディクショナリ プロパティの追加

ディクショナリ プロパティの消去

カスタム ディクショナリ プロパティの名前の変更

ディクショナリ プロパティの設定


コードの選択

  1. 仕様ツリーのフィールドをクリックします。

  2. [コード一覧] タブをクリックします。

  3. [値] 列で、使用するコードのチェック ボックスをオンにします。

注

  • コード一覧は ANSI X12 または EDIFACT に基づく仕様に対してのみ利用可能です。ただし、ANSI X12 または EDIFACT に基づいた仕様のすべてのフィールドに対してコードが関連付けられているわけではありません。特定のフィールドで利用できるコードの完全な一覧は、[コード一覧] プロパティ ページに表示されます。コードの横の [値] フィールドのチェック ボックスがオンになっている場合は、そのフィールドに対してコードが関連付けられています。"説明" フィールドに、コードに関する説明が表示されます。

  • [コード一覧] プロパティ ページのフィールドにコードを関連付けると、その関連付けは [宣言] プロパティ ページにも表示されます。[宣言] プロパティ ページの [データ型] の値が自動的に [Enumeration [列挙]] になり、[コード一覧] プロパティ ページで選択したコード一覧の番号が [データ型値] に表示されます。[宣言] プロパティ ページの [データ型] の値を消去すると、[コード一覧] プロパティ ページではコードが何も選択されていない状態になります。詳細については、「[値] 列のフィールドのプロパティの消去」を参照してください。

  • 一定範囲内のコードを選択するには、コードのチェック ボックスをオンにし、Shift キーを押しながら次のコードのチェック ボックスをオンにします。最初のコードと次のコードの間にあるすべてのコードが選択されます。

  • [コード一覧] プロパティ ページに表示されるコード値は、時折重複していることがあります。重複しているコード値の "説明" フィールドには、コード値と関連付けるドキュメントの種類に応じて、さまざまな説明が入ります。ドキュメント インスタンスの検証では、コード値を複数選択する必要はありません。コード一覧で値が重複している場合に、偶然に複数の重複コード値を選択したときは、次のように扱われます。
    • 重複した一連のコード値の中で、一番上に表示されているコード値を選択した場合は、そのコード値だけが選択されます。

    • 選択した値が、重複した一連のコード値の中で一番上に表示されている値ではなかった場合は、選択したコード値と共に一番上のコード値も自動的に選択されます。

    • 重複している一連のコード値の中で一番上に表示されているコード値は、ほかの値が 1 つでも選択されている場合は消去できません。

関連項目

[値] 列のフィールドのプロパティの消去

コードの消去

コード一覧の値と説明


コードの消去

  1. 仕様ツリーのフィールドをクリックします。

  2. [コード一覧] タブをクリックします。

  3. [値] 列で、消去するコードのチェック ボックスをオフにします。

注

  • コード一覧は ANSI X12 または EDIFACT に基づく仕様に対してのみ利用可能です。ただし、ANSI X12 または EDIFACT に基づいた仕様のすべてのフィールドに対してコードが関連付けられているわけではありません。特定のフィールドで利用できるコードの完全な一覧は、[コード一覧] プロパティ ページに表示されます。コードの横の [値] フィールドのチェック ボックスがオンになっている場合は、そのフィールドに対してコードが関連付けられています。"説明" フィールドに、コードに関する説明が表示されます。

  • [コード一覧] プロパティ ページに表示されるコード値は、時折重複していることがあります。重複しているコード値の "説明" フィールドには、コード値と関連付けるドキュメントの種類に応じて、さまざまな説明が入ります。ドキュメント インスタンスの検証では、コード値を複数選択する必要はありません。コード一覧で値が重複している場合に、偶然に複数の重複コード値を選択したときは、次のように扱われます。
    • 重複した一連のコード値の中で、一番上に表示されているコード値を選択した場合は、そのコード値だけが選択されます。

    • 選択した値が、重複した一連のコード値の中で一番上に表示されている値ではなかった場合は、選択したコード値と共に一番上のコード値も自動的に選択されます。

    • 重複している一連のコード値の中で一番上に表示されているコード値は、ほかの値が 1 つでも選択されている場合は消去できません。

関連項目

コード一覧の値と説明

コードの選択


[値] 列のフィールドのプロパティの消去

  1. 消去するプロパティが含まれているタブをクリックします。

  2. [値] 列のフィールドを右クリックし、[プロパティのクリア] をクリックします。


フィールド位置の自動計算

[カスタム データ型] の値が暗黙的に 10 進数に設定されている場合は、手動でフィールド位置を計算します。詳細については、「参照のプロパティの設定」の [開始位置] および [終了位置] 情報を参照してください。

  1. 位置指定レコードのフィールドを選択します。

  2. [データ型] 行の "値" フィールドをダブルクリックします。

  3. [データ型] ボックスの一覧で値をクリックします。

    注

    • 手順 4. と 5. で [最大値] の値を指定するには、[データ型] で、[String]、[Number]、[Binary (base64)]、または [Binary (hex)] のいずれかの値を選択する必要があります。
  4. [最大値] 行の "値" フィールドをダブルクリックします。

  5. "最大値" フィールドに数値を入力し、Enter キーを押します。

  6. レコードのフィールドごとに、手順 1. ～ 5. を繰り返します。

  7. レコードを右クリックし、[フィールド位置の計算] をクリックします。

    次の警告が表示されます。

    この操作を実行すると、選択したレコードにあるフィールドの開始位置プロパティと終了位置プロパティが変更されます。操作を続行しますか?

  8. [はい] をクリックします。

    レコードにあるフィールドの開始位置と終了位置が計算されます。詳細については、「フィールド位置の計算」を参照してください。


メモの編集と構文規則の表示

[ノードのプロパティ] ダイアログ ボックスでは、次の操作ができます。

  • フィールドとレコードのメモの読み取りと編集

  • レコードの構文規則の読み取り

[ノードのプロパティ] ダイアログ ボックスを表示するには、次の操作を行います。

  1. 仕様ツリーのレコードまたはフィールドを右クリックし、[プロパティ] をクリックします。

    既定では [メモ] プロパティ ページが表示されます。

  2. レコードの構文規則を表示するには、[構文規則] タブをクリックします。

注

  • 構文規則はレコードにだけ適用されます。

このダイアログ ボックスの使用方法については、次のトピックを参照してください。

  • レコード メモの入力

  • 構文規則の表示

  • フィールド メモの入力


レコード メモの入力

[ノードのプロパティ] ダイアログ ボックスを開く方法については、「メモの編集と構文規則の表示」を参照してください。

レコードに関する情報を、そのレコードに関連付けられているメモを使用して記録できます。記録する情報の例としては、レコードの目的や作成された理由などがあります。

  • メモを記録するには、[ノードのプロパティ] ダイアログ ボックスにテキストを入力し、[OK] をクリックします。

注

  • ルート ノードにはメモを追加できません。

  • 印刷できない文字 (通常、Alt キーと数字との組み合わせ) をメモに入力することはできません。たとえば、Alt キーを押して「75」と入力すると、文字 "K" が表示されます。

関連項目

フィールド メモの入力

構文規則の表示


構文規則の表示

[ノードのプロパティ] ダイアログ ボックスを開く方法については、「メモの編集と構文規則の表示」を参照してください。

構文規則は、仕様ツリーの構成方法に関する情報を提供するものです。構文規則が表示されるのは、ANSI X12 標準に基づいた仕様だけです。

  • レコードの構文規則を表示するには、[構文規則] タブをクリックします。

注

  • 構文規則はレコードにだけ適用されます。

関連項目

フィールド メモの入力

レコード メモの入力


フィールド メモの入力

[ノードのプロパティ] ダイアログ ボックスを開く方法については、「メモの編集と構文規則の表示」を参照してください。

フィールドに関する情報を、そのフィールドに関連付けられているメモを使用して記録できます。記録する情報の例としては、フィールドの目的や作成された理由などがあります。

  • メモを記録するには、[ノードのプロパティ] ダイアログ ボックスにテキストを入力し、[OK] をクリックします。

注

  • 印刷できない文字 (通常、Alt キーと数字との組み合わせ) をメモに入力することはできません。たとえば、Alt キーを押して「75」と入力すると、文字 "K" が表示されます。

関連項目

レコード メモの入力

構文規則の表示


ドキュメント インスタンスの管理

BizTalk エディタを使用して、仕様に基づいたドキュメント インスタンスの作成、および仕様に対するドキュメント インスタンスの検証ができます。

ここには次のトピックが含まれます。

  • ドキュメント インスタンスの作成

  • ネイティブ インスタンスの作成

  • ドキュメント インスタンスの検証


ドキュメント インスタンスの作成

  1. ドキュメント インスタンスの基本として使う仕様を開きます。

  2. [ツール] メニューの [XML インスタンスの作成] をクリックします。

    [ドキュメント インスタンスの作成] ダイアログ ボックスが表示されます。

  3. ドキュメント インスタンスを作成するフォルダを参照します。

  4. [ファイル名] ボックスにドキュメント インスタンスの名前を入力し、[保存] をクリックします。

    新しいドキュメント インスタンスが [出力] プロパティ ページに表示されます。

注

  • ドキュメント インスタンスの作成で利用できる形式は、Unicode だけです。

関連項目

ドキュメント インスタンスの検証


ネイティブ インスタンスの作成

  1. 仕様を開きます。

  2. [ツール] メニューの [ネイティブ インスタンスの作成] をクリックします。

    [ネイティブ ドキュメント インスタンスの作成] ダイアログ ボックスが表示されます。

  3. ネイティブ インスタンスを作成するフォルダを参照します。

  4. [ファイル名] ボックスにネイティブ インスタンスの名前を入力し、[保存] をクリックします。

    [ドキュメントの区切り記号] ダイアログ ボックスが表示されます。

  5. 次のそれぞれの一覧でオプションをクリックするか、または区切り記号を入力します。
    • レコード区切り記号

    • フィールド区切り記号

    • サブフィールド区切り記号

    • エスケープ文字

    重要

    • 独自の区切り記号を指定する場合は、Unicode 文字値を使用します。有効な文字の一覧については、Microsoft Global Software Development Web サイト (www.microsoft.com/globaldev/reference/wincp.asp) にあるグローバル コードページのページを参照してください。先頭に 2 つのゼロがあることを除いて、ANSI 文字コードが Unicode 文字コードと同じである場合は、ANSI 文字コードを使用することができます。

重要

  • ネイティブ インスタンスを正常に作成できた場合でも、構文規則に従っていないと、インスタンス検証で失敗します。

  • 文字範囲は無視されます。したがって、規則に合致していなくてもネイティブ インスタンスを正常に作成できますが、BizTalk Server が後にそのトランザクションを解析しようとすると失敗します。

  • [ネイティブ インスタンスの作成] は HHMMSSDD カスタム書式を作成しません。

  • 次のいずれかの場合には、位置指定ファイルのネイティブ インスタンスは生成されない場合があります。
    • [宣言] プロパティ ページの [データ型] の値が、[String]、[Number]、[Binary (base64)]、または [Binary (hex)] でない。

    • [宣言] プロパティ ページの [最大値] に値が含まれていない。


ドキュメント インスタンスの検証

  1. ドキュメント インスタンスの検証で使う仕様を開きます。

    詳細については、「仕様を開く」を参照してください。

  2. [ツール] メニューの [インスタンスの検証] をクリックします。

    [ドキュメント インスタンスの検証] ダイアログ ボックスが表示されます。

  3. 検証するドキュメント インスタンスを参照し、[開く] をクリックします。

  4. X12 標準または EDIFACT 標準に基づいた仕様に対して、エンベロープを持たないドキュメント インスタンスを検証する場合は、[ドキュメントの区切り記号] ダイアログ ボックスが表示されます。次のいずれかの操作を行います。
    • ANSI X12 に基づいた仕様の場合 : 検証するドキュメントに適した区切り記号を選択し、[OK] をクリックします。

    • EDIFACT に基づいた仕様の場合 : 検証するドキュメントに適した区切り記号とエスケープ文字を選択し、[OK] をクリックします。
  5. [警告] プロパティ ページに表示されたメッセージを確認します。仕様に対してドキュメント インスタンスを検証すると、次のメッセージが表示されます。

    ドキュメント インスタンスの検証が正常に終了しました。

    仕様に対してドキュメント インスタンスが検証されないと、[警告] プロパティ ページに、検証されなかったことを示すメッセージと、その原因を示すエラーが表示されます。警告された問題を解決し、再びドキュメント インスタンスを検証します。

  6. 非 XML 仕様に対する非 XML ドキュメント インスタンスの検証を行い、ドキュメント インスタンスが検証されると、[出力] タブをクリックして、ドキュメントの Extensible Markup Language (XML) バージョンを表示することができます。

各国語対応に関する問題

  • システム ロケールを日本語または韓国語に設定した環境で、日本語の円記号または韓国語のウォン記号を含むドキュメント インスタンスを作成したとします。所定の仕様に対してこのドキュメント インスタンスを正常に検証できた場合、円記号またはウォン記号は、BizTalk エディタの [出力] プロパティ ページでバックスラッシュ (\) として表示されます。バックスラッシュでなく、円記号またはウォン記号を表示するには、[出力] プロパティ ページのソースを表示します。
    1. 円記号やウォン記号でなくバックスラッシュを表示する [出力] プロパティ ページの任意の場所で右クリックし、次に [ソースの表示] をクリックします。

    2. メモ帳の [書式] メニューで [フォント] をクリックします。

    3. [フォント] ダイアログ ボックスの [フォント] で、[Tahoma] をクリックし、[OK] をクリックします。

注

  • インスタンスを検証する場合は、無効な XML 名文字に関する問題について理解しておくことが重要です。詳細については、「XML 名に使用できない文字」を参照してください。

  • XML-Data Reduced (XDR) データ型に型指定された要素が含まれている整形式 XML ドキュメント インスタンスは、対応する仕様に対して検証できないことがあります。このようなドキュメント インスタンスを対応する仕様に対して検証するには、XDR データ型に型指定されたすべての要素の "モデル" プロパティを [オープン] に設定します。"モデル" プロパティの詳細については、「宣言のプロパティの設定」を参照してください。

  • Unicode で保存された非 XML ドキュメント インスタンスを正常に検証するには、ファイルの先頭のバイト順序記号を削除する必要があります。バイト順序記号は、Unicode で保存されたファイルの最初の 2 バイトです。

  • "x-schema" スキーマ参照が含まれているドキュメント インスタンスは、BizTalk エディタで読み込まれるスキーマに関係なく、常にそのスキーマ参照を使用して検証されます。

  • 無効な文字コード表はインスタンスの検証の基準になりません。たとえば、[無効な文字コード範囲] ダイアログ ボックスの開始文字コードと終了文字コードの間にあるデータがインスタンスに含まれていても、検証は正常に終了します。

関連項目

ドキュメント インスタンスの作成

XML 名に使用できない文字

インスタンスと仕様の検証


無効な文字コード表の管理

ここには次のトピックが含まれます。

  • 無効文字範囲の追加

  • 無効文字範囲の編集

  • 無効文字範囲の削除


無効文字範囲の追加

  1. [表示] メニューの [無効な文字コード表] をクリックします。

    [無効な文字コード範囲] ダイアログ ボックスが表示されます。

  2. [新しい文字範囲の作成] ボタン [新しい文字範囲の作成] ボタン をクリックします。

    [無効な文字コード範囲の入力] ダイアログ ボックスが表示されます。

  3. [無効な開始文字コード] 一覧で値を選択し、Tab キーを押します。

  4. [無効な終了文字コード] 一覧で値を選択し、[OK] をクリックします。

  5. 手順 2. ～ 4. を繰り返して、そのほかの無効文字範囲を追加します。

重要

  • 無効な文字範囲を設定できるのは、非 XML ドキュメントに対してだけです。

  • 疑問符 (?) の正しい 16 進数は (0x3f) です。[無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスの既定の設定は、? (0x0) です。疑問符を表すときに、こちらを使用しないでください。疑問符を指定するには、? (0x3f) を一覧で選択してください。

注

  • [無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスに表示される値は 16 進数です。Microsoft Internet Explorer 5 以降などのアプリケーションを使用して仕様を Extensible Markup Language (XML) ソース ファイルとして表示すると、値は 10 進数で表示されます。たとえば、[無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスにセミコロン (;) を入力すると、表示される値は ; (0x3b) になります。ブラウザを使用して表示すると、この値は 59 と表示されます。

  • 無効文字範囲を入力するには、[無効な開始文字コード] および [無効な終了文字コード] ボックスの表示エリアをダブルクリックして、[無効な文字コード範囲の入力] ダイアログ ボックスを表示する方法もあります。

関連項目

無効文字範囲の削除

無効文字範囲の編集


無効文字範囲の編集

  1. [表示] メニューの [無効な文字コード表] をクリックします。

    [無効な文字コード範囲] ダイアログ ボックスが表示されます。

  2. 変更する文字範囲を選択し、[文字範囲の変更] [文字範囲の変更] ボタン をクリックします。

    [無効な文字コード範囲の入力] ダイアログ ボックスが表示されます。

  3. [無効な開始文字コード] ボックスの一覧で値を選択します。

    – または –

    [無効な終了文字コード] ボックスの一覧で値を選択します。

  4. [OK] をクリックします。

  5. 手順 2. ～ 4. を繰り返して、そのほかの無効文字範囲を変更します。

重要

  • 無効な文字範囲を設定できるのは、非 XML ドキュメントに対してだけです。

  • 疑問符 (?) の正しい 16 進数は (0x3f) です。[無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスの既定の設定は、? (0x0) です。疑問符を表すときに、こちらを使用しないでください。疑問符を指定するには、? (0x3f) を一覧で選択してください。

注

  • [無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスに表示される値は 16 進数です。Microsoft Internet Explorer 5 以降などのアプリケーションを使用して仕様を XML ソース ファイルとして表示すると、値は 10 進数で表示されます。たとえば、[無効な開始文字コード] ボックスと [無効な終了文字コード] ボックスにセミコロン (;) を入力すると、表示される値は ; (0x3b) になります。ブラウザを使用して表示すると、この値は 59 と表示されます。

  • 無効文字範囲を入力するには、[無効な開始文字コード] および [無効な終了文字コード] ボックスの表示エリアをダブルクリックして、[無効な文字コード範囲の入力] ダイアログ ボックスを表示する方法もあります。

関連項目

無効文字範囲の追加

無効文字範囲の削除


無効文字範囲の削除

重要

  • 無効な文字範囲を設定できるのは、非 XML ドキュメントに対してだけです。
  1. [表示] メニューの [無効な文字コード表] をクリックします。

    [無効な文字コード範囲] ダイアログ ボックスが表示されます。

  2. 削除する文字範囲をクリックし、[文字範囲の削除] [文字範囲の削除] ボタン をクリックします。

  3. [はい] をクリックして変更を確認します。

関連項目

無効文字範囲の追加

無効文字範囲の編集


表示の管理

ここには次のトピックが含まれます。

  • ツリー項目の展開

  • ツリー項目の折りたたみ

  • プロパティ値の表示

  • テキストのサイズの変更


ツリー項目の展開

  • 展開するルート ノードまたはレコードをクリックし、[表示] メニューの [ツリー項目の展開] をクリックします。

注

  • ツリー全体を展開するには、ルート ノードをクリックします。レコードをクリックすると、そのレコードの子レコードとフィールドだけが展開されます。

関連項目

ツリー項目の折りたたみ


ツリー項目の折りたたみ

  • 折りたたむルート ノードまたはレコードをクリックし、[表示] メニューの [ツリー項目の折りたたみ] をクリックします。

注

  • ツリー全体を折りたたむには、ルート ノードをクリックします。レコードをクリックすると、そのレコードの子レコードとフィールドだけが折りたたまれます。

関連項目

ツリー項目の展開


プロパティ値の表示

  • [表示] メニューで、次のプロパティのいずれかをクリックします。
    • 宣言

    • 参照

    • 解析

    • 名前空間

    • ディクショナリ

    • コード一覧


テキストのサイズの変更

  • [表示] メニューの [テキストのサイズ] をポイントし、使用するサイズをクリックします。


BizTalk エディタのショートカット キー

BizTalk エディタでは、ショートカット キーを使用して作業を行うことができます。次の表は、これらのショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。Windows 2000 Professional では、ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Ctrl + Shift + + (NumLock キーを使用可能にして、Shift キーを押しながら、テンキーの + キーを押します) 右側のウィンドウ内の名前空間データ シートにフォーカスを置いた状態で、新しいカスタム コメントを追加します。

または

[宣言]、[参照]、[名前空間]、または [ディクショナリ] プロパティ ページで新たにカスタム プロパティを作成します。

または

仕様にカスタム プロパティを挿入します。この機能を使用できるのは、[宣言]、[参照]、[名前空間]、[ディクショナリ] の各プロパティ シートで、プロパティが強調表示されている場合です。
Tab キー | [新しいドキュメント仕様] ダイアログ ボックスの右上隅のボタンにアクセスします。
Shift + F10 | 強調表示されている項目のコンテキスト メニューを開きます。
Ctrl + N | 新しい仕様を開きます。
Ctrl + O | 既存の仕様を開きます。
Ctrl + S | 仕様を保存します。
Ctrl + Shift + R | 新しいレコードをドキュメント仕様に挿入します。
Ctrl + R | レコードに新しいレコードを追加します。
Ctrl + Shift + F | 新しいフィールドをドキュメント仕様に挿入します。
Ctrl + F | レコードに新しいフィールドを追加します。
Del | レコードまたはフィールドを削除します。
F4 | 次の警告を強調表示します。
F5 | スキーマを検証します。
Ctrl + C | オブジェクトをコピーします。
Ctrl + X | オブジェクトを切り取ります。
Ctrl + V | オブジェクトを貼り付けます。
F6 | ウィンドウのフォーカスを時計回りに切り替えます。
Shift + F6 | ウィンドウのフォーカスを反時計回りに切り替えます。
Tab | 右側のウィンドウ内で、タブからその下のデータ シートへフォーカスを切り替えます。ボタンやフィールド間でフォーカスが移動します。
Space | チェック ボックスをオンまたはオフにします。ボタンにフォーカスがある場合、マウスのクリックと同様な動作になります。
F2 | 仕様ツリー内の強調表示されたノードに対して、編集モードをアクティブにします。右側のウィンドウのデータ シート内の強調表示された行に対して、編集モードをアクティブにします。
Shift + F2 次のフィールドに対して、編集モードをアクティブにします。
  • [宣言] プロパティ ページまたは [参照] プロパティ ページで強調表示されたカスタム コメント行の [プロパティ] 列

  • [名前空間] プロパティ ページで強調表示されたカスタム コメント行のプレフィックス列

  • [ディクショナリ] プロパティ ページで強調表示されたカスタム ディクショナリ行のプロパティ列
Alt + ↓ アクティブになっているリスト ボックスの一覧を表示します。
Shift + + | 右側のウィンドウ内の名前空間データ シートにフォーカスを置いた状態で、新しいカスタム コメントを追加します。
Enter | ノードと値に対して行った編集を確定します。
Esc | ノードと値に対して行った編集を取り消します。
F1 | オンライン ヘルプを表示します。
Alt + F4 | プログラムを終了します。
← 左のタブを選択します。
→ 右のタブを選択します。
任意の方向キー | ダイアログ ボックスのメイン ウィンドウ内のフォルダまたはファイルを強調表示します。フォーカスは切り替わりません。この機能を使用できるのは、[新しいドキュメント仕様]、[WebDAV に格納]、[WebDAV から取得] の各ダイアログ ボックスです。[新しいドキュメント仕様] ダイアログ ボックスの詳細については、「仕様の作成と検証」を参照してください。WebDAV の詳細については、「WebDAV から既存の仕様を開く」を参照してください。

BizTalk エディタでのマウス キーの使用

BizTalk エディタの操作の一部には、ショートカット キーがありません。次の操作を行うには、マウス キーを使用する必要があります。

  • 移動

  • ドラッグ アンド ドロップ操作

  • ノードのコピー


BizTalk マッパーの使用

Microsoft® BizTalk™ マッパーは変換設計ツールです。これを使用して、書式の異なる 2 つの仕様間でレコードやフィールドを対応付けることができます。BizTalk マッパーはリンクと Functoid を使用して、この変換を行います。Functoid は単純な計算から複雑なスクリプト機能まで、さまざまな操作を行います。

BizTalk マッパーを使用すると、送信元仕様のデータ要素と送信先仕様のデータ要素との間で行う構造変換の関係をグラフィカルに表現することができます。この相互参照とデータ処理機能によって、マップが作成されます。このマップが提供する一連の指示により、書式の異なる 2 つの仕様間の関係が定義されます。仕様の書式は BizTalk エディタを使用して定義します。

マップは、送信元仕様と送信先仕様との間のデータ変換を表現します。Microsoft BizTalk Server 2002 は、マップに定義されたデータを使用して、Extensible Stylesheet Language Transformation (XSLT) を生成します。次に、Microsoft XML Parser (MSXML) Version 3.0 は実行時に XSLT 出力を使用して、サーバー上のスキーマを変換します。マップを作成すると、XSLT が BizTalk マッパーの [出力] タブに表示されます。

BizTalk マッパーを使用すると、XML-Data Reduced (XDR) で定義されたデータ形式の仕様を外部と交換することができます。BizTalk マッパーで開くことができるのは、BizTalk エディタで保存された仕様だけです。一般的な Extensible Markup Language (XML) ファイルや非 XML ファイルは開くことができません。一般的な XML ファイル間の変換作業を行う場合は、それらのファイルを BizTalk エディタにインポートし、仕様として保存します。

BizTalk マッパーでは、単純な親子ツリー間のマッピングから、レコードと階層のループなどの細かく複雑なマッピングまで、さまざまなシナリオをサポートしています。マッピング プロセスが完了すると、シリアライザ コンポーネントは仕様を使って、取引先や内部アプリケーションが認識できるファイル形式を作成します。また、BizTalk マッパーにはスタイルシート コンパイラ コンポーネントが用意されているので、それを使用してマップを視覚的に表現したり、XSLT スタイル シートを作成することができます。

次の図は、送信元仕様から送信先仕様へのマッピング プロセスを示しています。送信元ファイルは電子データ交換 (EDI) ベースのドキュメントで、送信先ファイルはフラット ファイル ドキュメントです。この例では、EDI ドキュメント構造は中間 XML 形式に変換され、その構造は XDR 仕様で表現されます。データの最終形式はフラット ファイルです。データ ドリブン パーサーは XDR 仕様を使って、送信元 EDI 仕様の XML バージョンを作成します。次に XSL エンジンが、送信元 XML を送信先ファイル形式の XML に変換します。その後、送信先仕様はシリアライズされ、送信先ファイルのネイティブ形式 (この例ではフラット ファイル) になります。

EDI ドキュメントのフラット ファイル ドキュメントへの変換

ここには次のトピックが含まれます。

  • BizTalk マッパーの詳細については、「BizTalk マッパーについて」を参照してください。

  • 各作業の目的をまとめたクイック リファレンスについては、「BizTalk マッパーに関する作業を行う目的」を参照してください。

  • 作業を実行する手順の詳細については、「BizTalk マッパーに関する作業を行う方法」を参照してください。

  • 問題を解決するためのヒントについては、「BizTalk エディタと BizTalk マッパーのトラブルシューティング」を参照してください。


BizTalk マッパーについて

BizTalk マッパーは、送信元仕様と送信先仕様の両方を並べて表示し、レコード、フィールド、および Functoid の間に線を引くだけで変換を定義できるグラフィカルなツールです。BizTalk マッパーは、Extensible Stylesheet Language (XSL) Transformations (XSLT) と呼ばれるインターネット標準を使用します。これは Extensible Markup Language (XML) ドキュメントをある XML スキーマ から別の XML スキーマへ変換するための言語です。

ここでは、BizTalk マッパーを理解するための重要な概念について説明します。

ここには次のトピックが含まれます。

  • マッピング仕様

  • マッピングのシナリオ

  • BizTalk マッパーの環境

  • リンクの作成

  • ノードと階層レベルの対応

  • レコード、フィールド、リンク、および Functoid プロパティの参照

  • Functoid について

  • マップによる BizTalk サービスの統合

  • マップのコンパイル

  • マップのテスト


マッピング仕様

ある形式のデータを別の形式に変換するための情報は、マップで規定されます。マップは 2 つの仕様を必要とします。1 つは送信元仕様、もう 1 つは送信先仕様です。データのマッピングとは、送信元仕様の中のレコードおよびフィールドと、送信先仕様の中のレコードおよびフィールドとの対応関係を定義するデータ変換処理のことです。

マッピングには 2 つの種類があります。

  • 専用マッピング : このタイプのマップは、ある 1 つの取引先の特有のニーズに対応するために設計されます。ある取引先に特有のレコードおよびフィールド要件に合わせてマッピングを行う場合は、その取引先専用のマップを作成します。

  • 汎用マッピング : このタイプのマップは、複数の取引先のニーズに対応するために設計されます。汎用マッピングでは、複数の取引先の要件を 1 つのマップにまとめます。複数の組織が相互に接続されている場合もあるため、複数の取引先に対して同一のマップを使用できるようにしておくと、リソースと時間を節約できます。

BizTalk マッパーは、リンクと呼ばれる単純な値のコピーや変換、および Functoid と呼ばれる複雑な構造的操作を含んだマップを、グラフィカルに表示します。これらの要素を組み合わせると、送信元仕様と送信先仕様との間でデータを簡単にマッピングできます。

ここには次のトピックが含まれます。

  • マップ送信元および送信先ファイル


マップ送信元および送信先ファイル

マップとは、BizTalk マッパーによって作成される Microsoft BizTalk Server 固有の Extensible Markup Language (XML) ファイルです。以下の標準を基にマップを作成できます。

  • 業界標準 (XML、EDIFACT、X12 など)

  • 非業界標準 (区切りフラット ファイル、位置指定フラット ファイル、区切りおよび位置指定フラット ファイルなど)

  • 既存のファイル

BizTalk マッパーは、マップの作成にあたって、BizTalk Server 以外のスキーマの使用もサポートします。マップを作成するためには、2 つの仕様を使用しなければなりません。1 つは送信元仕様ツリー用、1 つは送信先仕様ツリー用です。

既存の BizTalk Server 2000 ファイル

BizTalk Server 2000 のマップは、BizTalk Server 2002 とほぼ完全な互換性があります。しかし、BizTalk Server 2000 で作成したマップを BizTalk Server 2002 で開き、保存すると、ファイル書式が変更されてしまうため、BizTalk Server 2000 で開くことはできなくなります。


マッピングのシナリオ

BizTalk マッパーでは、単純な親子ツリー型のマッピング操作から、ループ レコードや階層を含む複雑で詳細なマッピング操作まで、さまざまなシナリオをサポートしています。Extensible Markup Language (XML) のような形式では非常に柔軟な構造化書式の定義が可能なため、マッピングのシナリオはいっそう複雑になります。

基本的なマッピング操作

最も一般的なマッピング操作では、送信元仕様ツリー内のループしない親に属している送信フィールドを、送信先仕様ツリー内のループしない親に属しているフィールドにマップします。このタイプのマッピングでは複数の Functoid を使用したり、Functoid をカスケードするなどのさまざまな変換が可能ですが、基本的なシナリオは他のシナリオほど複雑ではありません。また、基本的なマッピング操作では、2 つの異なる親 (いずれもループしない) に属するフィールドを、送信先仕様ツリーのループしない親に属するフィールドにマッピングすることもあります。

複雑なマッピング操作

複雑なマッピング操作の中には、送信元仕様ツリー内の異なる親 (これらの親のどれか 1 つは複数個出現することも可) に属するフィールドを、送信先仕様ツリー内のループしない親にマッピングするようなこともあります。こうした種類のマッピングでは、ループ パスを適切に選択する必要があります。こうしたことは、電子データ交換 (EDI) に基づくドキュメントをマッピングする際によく発生します。このシナリオでは、Extensible Stylesheet Language (XSL) スタイル シート コンパイラによって正しいループ パスが選択される必要があります。そのループ パスでの反復により、要求される出力が生成されます。ループ パスの詳細については、「ループ パス」を参照してください。

ここには次のトピックが含まれます。

  • ループ パス

  • レコードとフィールドの順序


ループ パス

仕様内のあるレコードの [参照] タブで "最大発生数" プロパティにアスタリスク (*) が設定されていると、そのレコードはループします。"最大発生数" プロパティの詳細については、「参照のプロパティの設定」を参照してください。

送信元仕様内のループしたレコードに含まれるフィールドが、送信先仕様内のループしたレコードに含まれるフィールドにリンクしていると、マップでループ パスが発生します。次の図は、Root\Record1\Field1 から Root\RecordA\Field1、および Root\Record2\Field2 から \Root\RecordB\Field3 という、2 つのループ パスを示しています。

この [プロパティ] タブの "最大発生数" プロパティは、Record1 と RecordA がループしていることを示しています。Record2 と RecordB もループしています。

次のコードは入力ドキュメントのサンプルです。

<Root>
<Record1 Field1="Red">
<Record1 Field1="Green">
<Record1 Field1="Blue">
<Record2 Field2="50">
<Record2 Field2="100">
</Root>

上のマップを使用すると、この入力ドキュメントは次の出力ドキュメントにマップされます。

<Root>
<RecordA Field1="Red">
<RecordA Field1="Green">
<RecordA Field1="Blue">
<RecordB Field3="50">
<RecordB Field3="100">
</Root>

複数ループ パス

送信元仕様内にある複数のループしたレコードに含まれるフィールドが、送信先仕様にある 1 つのループしたレコードに含まれるフィールドにリンクしていると、マップ内で複数のループ パスが発生します。

次の図は、複数のループ パスの例を示しています。

BizTalk マッパーでは、複数のループ パスをサポートしていません。複数のループ パスが含まれるマップをコンパイルしようとすると、[警告] タブに、送信先ノードに複数の送信元ループ パスがありますというメッセージが表示されます。

関連項目

参照のプロパティの設定

ループ Functoid の使用


レコードとフィールドの順序

Extensible Stylesheet Language (XSL) 内での出力レコードおよびフィールドの順序は、暗黙的に決まるわけではありません。BizTalk マッパーは、送信先仕様の構造を参照してからマッピング グリッドを通って送信元に戻り、送信元仕様ツリーから値を抽出することで XSL を生成するからです。たとえば、先頭が BillTo Address レコードで、その次が ShipTo Address レコードという出力ファイルを作成するには、送信先仕様内で ShipTo Address レコードの前に BillTo Address レコードを配置する必要があります。

次の図は、この構造を示しています。

ContactType フィールドには有効なコードが 2 つ (BT と ST) 格納されていて、Address が BillTo と ShipTo のどちらであるかは、このコードによって識別されます。期待したとおりの出力を作成するため、マッピング グリッドに等号 Functoid が追加され、送信元仕様内のフィールドが送信先仕様内のレコードにリンクされています。

このマップでは、1 番目の Functoid によって、次の条件を満たしているかどうかをチェックしています。

ContactType が BT と一致しているか?

この条件が満たされている場合は、出力レコード BillToAddress が作成され、必要なフィールドが BillToAddress にマップされます。条件が満たされていない場合、BizTalk マッパーは条件を満たすために、すべての入力アドレス レコードを順に処理していきます。

重要

  • 出力ドキュメント インスタンス内でのレコードおよびフィールドの出現順序は、対応する出力仕様でのレコードおよびフィールドの順序によって決まります。


BizTalk マッパーの環境

BizTalk マッパーを開いた時に表示されるグラフィカル ユーザー インターフェイスによって、マップの作成と操作を簡単に行うことができます。

ここには次のトピックが含まれます。

  • BizTalk マッパーのユーザー インターフェイス

  • BizTalk マッパーのメニュー

  • BizTalk マッパーのツール バー ボタン

  • BizTalk マッパーの Functoid パレット

  • 表示のカスタマイズ


BizTalk マッパーのユーザー インターフェイス

BizTalk マッパーのメイン ウィンドウのツリーには、マップの作成に使用する 2 つの仕様が表示されます。左側はデータのマッピング元となる送信元仕様、右側はデータのマッピング先となる送信先仕様です。2 つの仕様の間にあるマッピング グリッドには、2 つの仕様間での構造的なデータ変換がグラフィカルに表示されます。リンクおよび Functoid はマッピング グリッド内に表示されます。ポインタをマッピング グリッドの端に移動させると、マッピング グリッド内を上下左右に簡単に移動できます。また、グリッド ページを追加して、リンクと Functoid をグループにまとめ、マップの種々の領域の表示を簡素化することもできます。たとえば、マップのヘッダー部を本体と切り離すことができます。

[グリッドのプレビュー] ダイアログ ボックスを使用すると、マッピング グリッド内のある場所から別の場所へすばやく移動できます。緑のロケータ バーをドラッグすると、上下左右に移動できます。マッピング グリッドにある Functoid は、プレビュー グリッドでは黒い枠付きの赤いボックスで表示されます。マッピング グリッドに 2 つ以上の Functoid がある場合は、2 つの赤いボックスが連結され、黒い枠で囲まれて表示されます。

ツリー表示とマッピング グリッドの下には、下部ウィンドウが表示されます。ここには 4 つのタブがあります。

  • [プロパティ] : 送信元仕様ツリーまたは送信先仕様ツリー内のノードを選択すると、そのノードのプロパティおよびプロパティ値が [プロパティ] タブに表示されます。

  • [値] : このタブには [送信元テスト値] と [送信先定数値] の 2 つのテキスト ボックスがあります。[送信元テスト値] ボックスでは、フィールドを選択し、値を入力できます。実際にフィールドに値を割り当てて、マップをテストできます。[送信先定数値] ボックスでは、フィールドに入れる値を指定できます。Functoid または送信元仕様内のノードから、定数値が割り当てられたフィールドへのリンクは作成できません。

  • [出力] : マップをコンパイルすると、コンパイルされた Extensible Stylesheet Language (XSL) スタイル シートがこのタブに表示されます。マップのテスト時は、テスト マップ出力が表示されます。

  • [警告] : このタブには、マップのコンパイル後にコンパイラからの警告が表示されます。警告を選択すると、マップの中で関連するリンクまたは Functoid が強調表示されるので、それによってエラーを見つけ、解決します。

関連項目

マップのコンパイル

マップのテスト

グリッドのプレビューを利用したリンクと Functoid の表示


BizTalk マッパーのメニュー

BizTalk マッパーのメニューは、コマンドを論理的にまとめることで、作業を簡単に実行できるようになっています。たとえば、[表示] メニューのコマンドを使用すると、送信元仕様ツリーのすべてのレコードおよびフィールドを展開したり、送信先仕様ツリーのすべてのレコードおよびフィールドを折りたたんだりできます。

BizTalk マッパーのメニューは次のとおりです。

  • [ファイル] : マップを作成する、開く、保存する、および閉じることができます。

  • [編集] : 送信元仕様および送信先仕様の置換、マッピング グリッド内のオブジェクトの削除、およびグリッド ページの追加または削除を行うことができます。

  • [表示] : Functoid パレット、Functoid のプロパティ、およびグリッドのプレビューを表示できます。また、BizTalk マッパーの表示テキスト サイズの選択、下部ウィンドウのタブの選択、仕様ツリーの展開と折りたたみ、および [警告] タブの次の警告の強調表示も行うことができます。

  • [ツール] : マップのコンパイルとテスト、および BizTalk マッパーのオプションの表示を行うことができます。

  • [ヘルプ] : BizTalk マッパーの概念についての説明、このマッパーでのさまざまな作業の意義、およびマッパー使用上の手順を表示することができます。

関連項目

BizTalk エディタのメニュー


BizTalk マッパーのツール バー ボタン

BizTalk マッパーには、メニュー バーを補うためのツール バーが用意されています。ツール バーのすべてのボタンは、それが実行する作業を表すグラフィックで表示されます。左から右へ、次の順序で並んでいます。

  • [新規作成]

  • [開く]

  • [保存]

  • [WebDAV から取得]

  • [WebDAV に格納]

  • [削除]

  • [折りたたみ]

  • [展開]

  • [Functoid パレットの表示]

  • [マップのコンパイル]

  • [マップのテスト]

  • [ページを追加]

  • [ページを削除]


BizTalk マッパーの Functoid パレット

Functoid パレットには、BizTalk マッパーで使用可能なすべての Functoid が含まれています。Functoid には、送信元仕様のレコードまたはフィールド、または別の Functoid (日付 Functoid など) からデータを取得し、データを個別に処理して、送信先仕様のレコードまたはフィールドにセットする新しい値を返すためのプログラムが含まれています。Functoid パレットの詳細については、「Functoid について」を参照してください。

関連項目

Functoid について

Functoid の操作


表示のカスタマイズ

BizTalk マッパーの外観は、いくつかの方法でカスタマイズできます。たとえば、マッピング グリッドの背景色を変更したり、リンクや選択したオブジェクトに対して新しい色を指定したり、コンパイラの警告の色を変更したり、文字サイズを変更するなどが可能です。カスタマイズできる項目は次のとおりです。

  • [グリッドの前景色] : マッピング グリッドの点線。

  • [グリッドの背景色] : マッピング グリッドの背景色。

  • [固定リンク] : マッピング グリッドの値コピー リンク。

  • [柔軟なリンク] : 送信元仕様ツリーから送信先仕様ツリーへ現在ドラッグされている状態の値コピー リンク。

  • [部分的なリンク] : 親レコード ノードが折りたたまれたフィールドまたはレコードのリンク。

  • [コンパイラ リンク] : F5 を押してコンパイルした時に自動的に作成されるコンパイラ ディレクティブ リンク。

  • [コンパイラの警告] : [警告] タブで、マップをコンパイルした時に生成された警告を選択すると、そのリンクまたは Functoidがコンパイラの警告に指定した色で強調表示されます。

  • [選択したオブジェクト] : マッピング グリッドで選択した Functoid やリンクなどのオブジェクトがこの色で表示されます。

これらは、[ツール] メニューの [オプション] ダイアログ ボックスで変更できます。文字サイズの変更は、[表示] メニューでも行えます。

関連項目

BizTalk マッパーのオプション : [色] タブ


リンクの作成

送信元仕様ツリーのレコードおよびフィールドから、送信先仕様ツリーのレコードおよびフィールドへのデータ コピーの基本機能は、リンクによって実行されます。BizTalk マッパーは、1 対 1 リンクおよび 1 対多リンクをサポートしています。たとえば、送信元仕様ツリーの 1 つのレコードまたはフィールドと、送信先仕様ツリーの 1 つのレコードまたはフィールドを、リンクによって結合できます。送信元仕様ツリーの 1 つのレコードまたはフィールドと、送信先仕様ツリーの複数のレコードまたはフィールドを、リンクで結合することも可能です。また、送信元仕様ツリーの複数のレコードまたはフィールドを 1 つの Functoid とリンクで結合し、それを送信先仕様ツリーの 1 つのレコードまたはフィールドとリンクで結合することもできます。送信元仕様ツリーの複数のレコードまたはフィールドを、送信先仕様ツリーの 1 つのレコードまたはフィールドと結合することも可能です。

関連項目

リンクの管理


ノードと階層レベルの対応

BizTalk マッパーには、コンパイラ ディレクティブが含まれています。このディレクティブを使用すると、送信元仕様ツリーの階層と、送信先仕様ツリーの階層の対応レベルを設定できます。送信元仕様ツリーのフィールドから、送信先仕様ツリーのフィールドへのリンクを作成すると、BizTalk マッパーは [リンク プロパティ] ダイアログ ボックスの [コンパイラ] タブにある [送信先仕様リンク] ボックスの設定に基づいて、自動的にコンパイラ リンクを追加します。詳細については、「送信先仕様リンクのコンパイラ プロパティの選択」を参照してください。次の図は、ノードと階層レベルの対応の例を示しています。

  • [リンクをフラット化 (既定)] : このモードでは、すべての送信元階層が送信先ノードの親レコードに対応するようにフラット化されます。第 1 のケースでは、送信元仕様は送信先仕様よりも複雑です。第 2 のケースでは、送信先仕様の方が複雑です。

  • [リンクを上から順に一致] : このモードでは、レベルとレベルが上から順に対応付けられます。第 1 のケースでは、送信元仕様は送信先仕様よりも複雑です。第 2 のケースでは、送信先仕様の方が複雑です。

  • [リンクを下から順に一致] : このモードでは、レベルとレベルが下から順に対応付けられます。第 1 のケースでは、送信元仕様は送信先仕様よりも複雑です。第 2 のケースでは、送信先仕様の方が複雑です。

次の表は、使用されているディレクティブの種類を基にして BizTalk マッパーがどのようにリンクを扱うかを示しています。

例えば、同じ親レコードを持つ送信元仕様の複数のフィールドと、同じ親レコードを持つ送信先仕様の複数のフィールドがあり、それらのフィールド間のリンクのコンパイラ ディレクティブとして、1 つの [リンクをフラット化 (既定)] と、1 つの [リンクを上から順に一致] と、1 つの [リンクを下から順に一致] を使用すると、BizTalk マッパーは、すべてのリンクに [リンクをフラット化 (既定)] が指定されたように扱います。

[リンクをフラット化 (既定)] | [リンクを上から順に一致] | [リンクを下から順に一致] | 結果
1 | 1 | 1 | BizTalk マッパーはすべてのリンクに [リンクをフラット化 (既定)] が指定されたように扱います。
複数 | 1 |  | BizTalk マッパーはすべてのリンクに [リンクを上から順に一致] が指定されたように扱います。
複数 |  | 1 | BizTalk マッパーはすべてのリンクに [リンクを下から順に一致] が指定されたように扱います。
 | 複数 | 複数 | BizTalk マッパーはすべてのリンクに [リンクをフラット化 (既定)] が指定されたように扱います。

関連項目

マップのコンパイル


レコード、フィールド、リンク、および Functoid プロパティの参照

送信元仕様および送信先仕様には、仕様に定義されたレコードおよびフィールドが表示されます。これらの仕様は、BizTalk エディタを使用して作成するか、整形式 XML、ドキュメント型定義 (DTD)、または XDR スキーマとして BizTalk エディタにインポートします。サードパーティ組織によって作成されたどんな XDR スキーマでも使用できます。しかし、グループや名前空間はサポートされません。送信元仕様はマッピング グリッドの左側に表示され、送信先仕様は右側に表示されます。

レコードおよびフィールドのプロパティと値

レコードおよびフィールドのプロパティと値は、メイン ウィンドウの下にある [プロパティ] タブに表示されます。レコードまたはフィールドを選択すると、BizTalk エディタのプロパティ タブの主要プロパティと値が表示されます。

リンクおよび Functoid のプロパティ

BizTalk マッパーのマッピング グリッドには、データ変換の構造がグラフィカルに表示されます。リンクは、送信元仕様ツリーのレコードまたはフィールドと、送信先仕様ツリーのレコードまたはフィールドとを接続する 1 本の線で表示されます。リンクは、レコードまたはフィールドと Functoid の接続にも使用されます。Functoid はアイコンで表示されます。リンクのプロパティには、送信元と送信先のデータおよびコンパイラ ディレクティブ情報が含まれています。Functoid のプロパティには、入力パラメータおよびスクリプト情報が含まれています。

関連項目

レコード、フィールド、およびプロパティ

Functoid について


Functoid について

BizTalk マッパーは、送信元仕様ツリーのレコードおよびフィールドから、送信先仕様ツリーのレコードおよびフィールドへの、複雑な構造変換をサポートしています。Functoid は、定義済みの式と引数と呼ばれる値を使用して、計算を実行します。この計算は、指定されたレコードおよびフィールドの順序に基づいて実行されます。

Functoid パレットで Functoid を選択してマッピング グリッドへドラッグし、それを送信元仕様ツリーおよび送信先仕様ツリーの要素とリンクすることで、データの加算、日付と時間の情報の変更、データの連結、そのほかの操作などが行われます。たとえば、加算 Functoid は値を加算します。

[Functoid パレット] には、次のタブがあります。

  • [文字列] : この Functoid は、文字列関数を使用してデータ文字列を処理します。たとえば、文字列位置検出 Functoid は、あるテキスト文字列を別のテキスト文字列内から検索し、発見した文字列の最初の文字の位置を返します。文字列処理を行う各 Functoid に必要なパラメータについては、文字列処理を行う Functoid を参照してください。

  • [数値演算] : この Functoid は、引数と呼ばれる値を使用して、特定の順序または構造で計算します。たとえば、加算 Functoid は指定されたフィールドまたレコードに値を加算します。数値演算を行う各 Functoid に必要なパラメータについては、数値演算を行う Functoid を参照してください。

  • [論理] : この Functoid では、論理テストが実行されます。論理演算を行う Functoid が送信先仕様のレコードに接続されていて、Functoid が TRUE (真) を返した場合、対応するレコードが出力ドキュメント内に生成されます。論理演算を行う Functoid が送信先仕様のレコードに接続されていて、Functoid が FALSE (偽) を返した場合、対応するレコードは出力ドキュメント内に生成されません。論理演算を行う Functoid の出力結果は、マップ内のほかの Functoid への入力としても使用できます。論理演算を行う Functoid とループ Functoid がリンクされていて、それが送信先仕様ツリーのレコードにリンクされている場合、ループ Functoid は論理演算を行う Functoid の出力が真である時にだけ使用されます。論理演算を行う各 Functoid に必要なパラメータについては、論理演算を行う Functoid を参照してください。

    重要

    • 送信元仕様の 2 つのレコードまたはフィールドを 2 つの異なる論理演算を行う Functoid にリンクして、それぞれの論理演算を行う Functoid を送信先仕様ツリーの同じレコードにリンクした場合、Extensible Stylesheet Language (XSL) Transformation (XSLT) の生成では最初の論理演算を行う Functoid だけが使用されます。2 番目の論理演算を行う Functoid からのリンクは無視されます。
  • [日付/時刻] : この Functoid では、日付と時間のデータの操作、または送信先仕様のレコードまたはフィールドへの、現在の日付、時刻、または日付と時間のデータの加算をします。日時処理を行う各 Functoid に必要なパラメータについては、日時処理を行う Functoid を参照してください。

  • [変換] : この Functoid は DEC2HEX などのエンジニアリング関数とほぼ等しく、与えられた 10 進数に対応する 16 進数を返します。また、文字を ASCII コード値に変換したり、ASCII コード値を対応する文字に変換するときも使用されます。変換を行う各 Functoid に必要なパラメータについては、変換を行う Functoid を参照してください。

  • [関数] : この Functoid は、数値を科学値に変換します。たとえば、コサイン Functoid はフィールドまたはレコードからラジアン値を取得し、コサインの値を返します。関数演算を行う各 Functoid に必要なパラメータについては、関数演算を行う Functoid を参照してください。

  • [累積] : この Functoid は、ループ レコードの合計、平均、最小、または最大入力を返します。累積演算を行う各 Functoid に必要なパラメータについては、累積演算を行う Functoid を参照してください。

  • [データベース] : この Functoid では、データベースからデータを抽出します。データベース操作を行う各 Functoid に必要なパラメータについては、データベース操作を行う Functoid を参照してください。

  • [高度] : このタブには、さまざまな操作を実行するいくつかの Functoid があります。たとえば、カスタム Microsoft® Visual Basic® スクリプトまたは Microsoft JScript® を使用できる Functoid、値のマッピング用の Functoid、ループ Functoid、インデックス Functoid、繰り返し Functoid、レコード ループの情報の管理と抽出用の Functoid があります。それぞれの高度 Functoid に必要なパラメータについては、高度 Functoid を参照してください。

独自のカスタム Functoid を作成することもできます。カスタム Functoid のサンプルは、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleFunctoid フォルダにあります。また、Microsoft® .NET ベースの Functoid サンプルが、BizTalk Server のサーバー インストールを行ったコンピュータ、または BizTalk Server のカスタム インストールでメッセージ処理のサンプルをインストールしたコンピュータの、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DateFunctoidNet フォルダにあります。

重要

  • カスタム Functoid を作成した場合、表示および使用する各コンピュータに登録しなければなりません。コンピュータに登録されていないカスタム Functoid がマップの中で使用されている場合、カスタム Functoid は "FT" という文字で表されます。この Functoid はグリッド ページに表示されますが、移動はできません。

ここには次のトピックが含まれます。

  • Functoid をカスケードしての使用

  • 累積演算を行う Functoid の使用

  • データベース操作を行う Functoid の使用

  • レコード カウント Functoid の使用

  • インデックス Functoid の使用

  • 繰り返し Functoid の使用

  • 値のマッピング Functoid の使用

  • 値のマッピング (フラット化) Functoid の使用

  • ループ Functoid の使用


Functoid をカスケードしての使用

Functoid をカスケードすると、送信先仕様のフィールドやレコードに必要な出力をするために、フィールドやレコードを複数の Functoid にリンクする必要のあるマップを作成できるようになります。Functoid をカスケードすると、複数の連続変換をマッピング グリッドに簡単に作成できます。ある Functoid を別の Functoid にリンクしてから、送信先仕様のレコードまたはフィールドにリンクすると、Functoid がカスケードされます。たとえば、連結された 2 つの文字列を使用して第 3 の文字列を生成し、それを送信先仕様のフィールドに格納するように、Functoid をカスケードすることができます。マッピング グリッド内でカスケードできる Functoid の数に制限はありませんが、複雑なカスケードを行うとパフォーマンスが低下します。


累積演算を行う Functoid の使用

累積演算を行う Functoid は、送信元仕様のレコード レベルのコンテキスト内で実行されます。通常、特定のレコードが 1 つの入力ファイルに何回も発生します。たとえば、注文時には、製品、説明、単価、数量などを含んだ明細が何回も発生します。次のコードは、注文の例を示しています。

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Northwind Traders</To>
<LineItems>
  <Item>
    <Product>Computer A</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>Computer A Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>Cleaner A</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

次の図は、この注文が BizTalk エディタに表示された様子を示しています。

Item レコードの [参照] タブで、"最大発生数" プロパティにアスタリスク (*) が設定されています。これは、この Item レコードがループしていることを示しており、BizTalk マッパーはこのレコードをループとしてコンパイルします。

注文のすべての明細の合計を調べ、累計を出力ドキュメントのフィールドにマップするとします。それには、最初に注文の各明細レコードの金額 (単価 x 数量) を計算し、次に注文のすべての明細レコードのマッピングを行いながら、各明細レコードの合計を集計します。

次の図は、乗算 Functoid および累積合計 Functoid を使用して、入力された注文の明細レコードを集計し、その結果を TotalsDocument ドキュメントの POTotal フィールドに出力する様子を示しています。

この例では、入力された注文 PurchaseOrder の LineItems レコードにあるすべての Item レコードが、累積操作の対象となります。Price および Quantity フィールドは、乗算 Functoid に渡されます。乗算 Functoid の出力が、累積合計 Functoid の入力になります。入力された注文 PurchaseOrder 内で、Item レコードが次々に累積されるため、累積合計 Functoid の出力は累積された値になります。この値は TotalsDocument ドキュメントの POTotal フィールドに送られ、次のように各製品の単価と数量を累積合計したものになります。(2000x1)+(50x2)+(2x100)=2300

注

  • ある入力の累積集計は、入力リンクの元となった親レコードに対して実行されます。これは、累積演算を行う Functoid の入力データを出力する Functoid でも同じです。

  • 累積演算を行う Functoid は数値以外の入力を無視します。たとえば、"Three" という入力値は無視されます。

累積平均 Functoid、累積最小値 Functoid、および累積最大値 Functoid の動作は、累積合計 Functoid とほぼ同じです。累積文字列 Functoid の動作はほかの累積演算を行う Functoid とは異なり、数値を集計するのではなく、文字列を連結します。

関連項目

累積演算を行う Functoid の追加

累積演算を行う Functoid


データベース操作を行う Functoid の使用

データベース操作を行う Functoid は、データベースからデータを抽出します。データベース操作を行う Functoid の使用方法を理解するため、広い地域に多数の店舗を持つ消費財メーカーを例に考えてみましょう。各店舗には数字コードが割り当てられ、すべての取引先に住所一覧が配布されています。住所一覧は次のような構造になっています。

StoreID: 123

Name: Contoso, Ltd

Address: 1234 Main Street

City: Denver, Colorado

PostalCode: 97402

PhoneNumber: 801-555-0179

StoreManager: Anthony Chor

トランザクションで注文に含めて送信されるのは、店舗を表す数字コードだけです。BizTalk マッパーはそのコードを使用して、データベースから住所情報を抽出します。次の図は、その様子を示しています。

データベース Functoid マップ

この図で、送信元仕様は入力された注文を表し、送信先仕様は請求書を表しています。データベース検索 Functoid データベース検索 Functoid によってデータベース検索が実行され、テーブルからレコードが検索されます。データベース検索 Functoid の出力の接続先にできるのは、値抽出 Functoid 値抽出 Functoid だけです。値抽出 Functoid によって、検索レコードから適切な列名が抽出されます。実行時にエラー （接続失敗など） が発生した場合は、エラー通知 Functoid エラー通知 Functoid からエラー情報が含まれた文字列が出力されます。

データベース検索 Functoid には、次の順序で 4 個の入力パラメータが必要です。

  1. 検索する値

  2. データベース接続文字列

  3. テーブル名

  4. 値を検索する列名

入力パラメータの挿入、削除、および移動方法については、「入力パラメータ」を参照してください。

前の例では、第 1 入力パラメータは入力された注文の StoreID フィールドから取得され、残り 3 個の入力パラメータにはデータベース検索 Functoid の [Functoid プロパティ] ダイアログ ボックスの [全般] タブの定数が使用されます。送信元仕様ツリーからリンクを作成し、4 個の入力パラメータに値を指定することも可能です。入力パラメータの挿入、削除、および移動方法については、「入力パラメータ」を参照してください。

値抽出 Functoid には、次の順序で 2 個の入力パラメータが必要です。

  1. データベース検索 Functoid へのリンク

  2. 列名

エラー通知 Functoid には、データベース検索 Functoid へのリンクが、入力パラメータとして 1 個だけ必要です。

注

  • Microsoft® SQL Server™ のデータ型には、text、ntext、image などのように、データベース検索 Functoid の検索値として使用できないものがあります。

  • データベース検索 Functoid の入力パラメータと一致するレコードが複数ある場合、値抽出 Functoid はテーブル内で最初に一致したレコードだけを抽出します。

関連項目

データベース操作を行う Functoid

入力パラメータ


レコード カウント Functoid の使用

レコード カウント Functoid は、送信元仕様のレコード レベルのコンテキスト内で実行されます。通常、特定のレコードが 1 つの入力ファイルに何回も発生します。たとえば、注文時には、製品、説明、単価、数量などを含んだ明細が何回も発生します。次のコードは、注文の例を示しています。

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Northwind Traders</To>
<LineItems>
  <Item>
    <Product>Computer A</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>Computer A Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>Clearner A</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

次の図は、この注文が BizTalk エディタに表示された様子を示しています。

Item レコードの [参照] タブで、"最大発生数" プロパティにアスタリスク (*) が設定されています。これは、この Item レコードがループしていることを示しており、BizTalk マッパーはこのレコードをループとしてコンパイルします。

注文の明細の合計数を調べ、その値を出力ドキュメントのフィールドにマップするとします。この環境は、送信元ドキュメントの内容を出力ドキュメントにマップするという、通常のマッピングの環境とは異なっています。その場合、出力ドキュメントにマップする値は、レコード カウント Functoid で生成されます。

レコード カウント Functoid には入力と出力が 1 つずつあります。入力は、送信元仕様のループ レコードからのリンクです。このレコードは、元の入力ドキュメント内に何回も出現します。レコード カウント Functoid の出力は、送信先仕様のフィールドへのリンクです。

次の図は、入力された注文に含まれる明細数をレコード カウント Functoid でカウントし、その値を POReport ドキュメントの Number_Of_Items フィールドに出力する様子を示しています。

レコード カウント Functioid のマップ

この例では、入力された注文に 3 つの明細があるため、Number_Of_Items フィールドの値は 3 になります。

関連項目

高度 Functoid


インデックス Functoid の使用

インデックス Functoid は、送信元仕様のレコード レベルのコンテキスト内で実行されます。通常、特定のレコードが 1 つの入力ファイルに何回も発生します。たとえば、天気予報では DailySummary セクションが何回も発生します。DailySummary セクションには、気温、気圧、風速などが含まれています。次のコードは、天気予報の例を示しています。

<WeatherReport>
  <DailySummary>
    <Temperature>20</Temperature>
    <Pressure>80</Pressure>
    <WindSpeed>10</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>23</Temperature>
    <Pressure>78</Pressure>
    <WindSpeed>20</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>24</Temperature>
    <Pressure>77</Pressure>
    <WindSpeed>16</WindSpeed>
  </DailySummary>
</WeatherReport>

次の図は、この天気予報が BizTalk エディタに表示された様子を示しています。

このコードでは、DailySummary レコードの "最大発生数" プロパティ ([参照] タブに表示されます) にアスタリスク (*) が設定されています。これは、この DailySummary レコードがループしていることを示しており、BizTalk マッパーはこのレコードをループとしてコンパイルします。

天気予報の中で、最初の 2 つの DailySummary レコードにある情報を集めるとします。BizTalk マッパーでは、入力された送信元仕様の DailySummary レコードの各フィールドをインデックス Functoid に接続し、どの DailySummary レコードから情報を取り出すかを、各インデックス Functoid で指定できます。ここでは、第 1、または第 2 のレコードがそれに当たります。そして、送信先仕様の適切なフィールドに、インデックス Functoid を接続します。

次の図は、このようなインデックス Functoid の使用方法を示しています。

1 日目の日別情報を取得するには、上の 3 つのインデックス Functoid のインデックス値が 1 になっている必要があります。2 日目の日別情報を取得するには、下の 3 つのインデックス Functoid のインデックス値が 2 になっている必要があります。

インデックス シーケンス入力は、インデックス Functoid のプロパティ シートにある [全般] タブで、入力パラメータとして設定されます。インデックス Functoid をダブルクリックすると、そのプロパティ シートが表示されます。最初の入力パラメータを見ると、このインデックス Functoid にリンクされた送信元仕様のフィールドがわかります。それ以降の入力パラメータは、インデックス値を示しています。

次の図は、前のマップの一番上のインデックス Functoid のプロパティ シートを示しています。

インデックス Functoid プロパティ

注

  • インデックス Functoid の入力パラメータに数値定数以外の値が割り当てられていると、BizTalk マッパーは値が 1 として解釈します。たとえば上の図で、第 2 入力パラメータを "anystring" という値に置き換えても、マッピング結果は変化しません。

  • 通常、[Functoid プロパティ] ダイアログ ボックスの [全般] タブにあるインデックス シーケンス入力は定数値ですが、入力シーケンス値として送信元仕様のノードからのリンクを使用することも可能です。このリンクが、第 1 入力パラメータの親ではないループ レコードからのものである場合、インデックス シーケンス入力値は、入力ドキュメントのノードの第 1 インスタンスから取得されます。

  • インデックス シーケンス入力の値は、送信元ドキュメントの現在のコンテキストに必ず関係しています。.

1 つの入力ファイルに複数の天気予報が含まれていて、各天気予報には複数の日別情報が含まれていた場合、複数のインデックス値を指定する必要があります。次のコードは、複数の天気予報が含まれた入力ファイルの例です。

<WeatherReports>
  <WeatherReport1>
    <DailySummary>
      <Temperature>20</Temperature>
      <Pressure>80</Pressure>
      <WindSpeed>10</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>23</Temperature>
      <Pressure>78</Pressure>
      <WindSpeed>20</WindSpeed>
    </DailySummary>
  </WeatherReport1>
  <WeatherReport2>
    <DailySummary>
      <Temperature>24</Temperature>
      <Pressure>77</Pressure>
      <WindSpeed>16</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>22</Temperature>
      <Pressure>79</Pressure>
      <WindSpeed>21</WindSpeed>
    </DailySummary>
  </WeatherReport2>
</WeatherReports>

2 つのインデックス値を持ち、第 1 インデックスが 1、第 2 インデックスが 2 に設定されたインデックス Functoid は、第 2 の天気予報の第 1 の日別情報からフィールド値を取得します。

重要

  • インデックス Functoid は、フィールド レベルからルート ノードの下の第 1 レベルにある親ノードと、同じ数のインデックス値を持つ必要があります。たとえば、複数の天気予報があるサンプル ドキュメントでは、2 つのインデックス値が必要です。天気予報が 1 つのサンプル ドキュメントで必要なインデックス値は、1 つだけです。設定したインデックス Functoid のインデックス値が必要な個数に達していない場合は、インデックス Functoid の最初の入力パラメータと一致する、送信元ドキュメントの最初のノードに基づいて出力が生成されます。

関連項目

高度 Functoid


繰り返し Functoid の使用

繰り返し Functoid は、ある時点でマップされているループ レコードのシーケンス番号を識別します。次の図は、等号 Functoid と組み合わせて使用した繰り返し Functoid を示しています。

繰り返し Functoid のマップ

送信先仕様の 2 つのレコードそれぞれに対して、Functoid の組 (繰り返し Functoid 繰り返し Functoid と等号 Functoid 等号 Functoid) があります。次の図は、上の等号 Functoid のプロパティ シートを示しています。

一番上の条件判断 Functoid のプロパティ シート

次のコードは、送信元仕様の構造に適合する入力ドキュメント インスタンスの例です。

<Root>
<Record1 Field1="A"/>
<Record1 Field1="B"/>
</Root>

入力ドキュメント インスタンスの中で、送信元仕様がループしていって、第 1 レコードがマップされているときに、繰り返し Functoid は "1" を返し、第 2 レコードがマップされているときは、"2" を返します。等号 Functoid は、2 つの入力パラメータが等しい場合、値 "true" を返します。その結果、入力ドキュメント インスタンスの第 1 レコードがマップされているときは、上の Functoid のペアは値 "true" を返します。そして、送信先仕様の Record2 に "true" が渡され、Record2 が出力ドキュメントに書き込まれます。下の等号 Functoid の第 2 入力パラメータの値が 2 の場合でも、下の Functoid ペアの動作は上の Functoid と同様です。つまり、入力ドキュメント インスタンスの第 2 レコードがマップされると、送信先仕様の Record3 が出力ドキュメント インスタンスに書き込まれます。次のコードは、出力ドキュメント インスタンスを示しています。

<Root2>
<Record2 Field2="A"/>
<Record3 Field3="B"/>
</Root2>

関連項目

高度 Functoid


値のマッピング Functoid の使用

値のマッピング Functoid 値のマッピング Functoid には 2 個の入力パラメータが必要で、第 1 パラメータが "true" の場合は、第 2 入力パラメータの値を返します。次の図は、値のマッピング Functoid を使用したマップを示しています。

マップを完成させるには、各 Functoid の入力パラメータを設定する必要があります。次の図は、3 つの値のマッピング Functoid のプロパティ シートを示しています。

値のマッピング Functoid のプロパティ シート

次の図は、一番上の等号 Functoid のプロパティ シートを示しています。

等号 Functoid のプロパティ シート

中央の等号 Functoid のプロパティ シートは似ていますが、第 2 入力パラメータの値が定数値 "Y" になっています。一番下の等号 Functoid のプロパティ シートも似ていますが、第 2 入力パラメータの値が定数値 "Z" になっています。

次のコードは、このマップの送信元仕様に対応するドキュメント インスタンスの例です。

<Root>
  <Record1>
    <Record2 Name="X" Value="1"/>
    <Record2 Name="Y" Value="2"/>
    <Record2 Name="Z" Value="3"/>
  </Record1>
  <Record>
    <Record2 Name="X" Value="4"/>
    <Record2 Name="Y" Value="5"/>
    <Record2 Name="Z" Value="6"/>
  </Record>
  <Record1>
    <Record2 Name="X" Value="7"/>
    <Record2 Name="Y" Value="8"/>
    <Record2 Name="Z" Value="9"/>
  </Record1>
</Root>

Name の値 "X" によって、このマップの一番上の等号 Functoid は値 "true" を返します。また、等号 Functoid から値 "true" が返されることによって、リンクされた値のマッピング Functoid は値 1 を返します。

このマップおよびこの送信元ドキュメント インスタンスを使用することで、BizTalk Server は次のドキュメント インスタンスを出力します。

<Root>
<Record X="1"/>
<Record Y="2"/>
<Record Z="3"/>
<Record X="4"/>
<Record Y="5"/>
<Record Z="6"/>
<Record X="7"/>
<Record Y="8"/>
<Record Z="9"/>
</Root>

重要

  • 値のマッピング Functoid で入力として使用できるのは、小文字の文字列 "true" および "false" という形式のブール型入力だけです。たとえば、入力ドキュメント インスタンスのフィールドが "True" という値を持ち、それが 値のマッピング Functoid の第 1 入力パラメータに直接リンクされている場合、値のマッピング Functoid の第 2 入力パラメータは出力ドキュメントに渡されません。

関連項目

高度 Functoid

値のマッピング (フラット化) Functoid の使用


値のマッピング (フラット化) Functoid の使用

Microsoft Commerce Server では、Commerce Server カタログからフラット スキーマへマップすることがよくあります。値のマッピング (フラット化) Functoid を使用すると、この種類のマッピングが可能になります。次のコードは、Commerce Server カタログの例です。

<Root>
  <Record1>
    <Record2 Name="X" Value="1"/>
    <Record2 Name="Y" Value="2"/>
    <Record2 Name="Z" Value="3"/>
  </Record1>
  <Record1>
    <Record2 Name="X" Value="4"/>
    <Record2 Name="Y" Value="5"/>
    <Record2 Name="Z" Value="6"/>
  </Record1>
  <Record1>
    <Record2 Name="X" Value="7"/>
    <Record2 Name="Y" Value="8"/>
    <Record2 Name="Z" Value="9"/>
  </Record1>
</Root>

次のコードは、フラット スキーマの例です。

<Root>
  <Record X="1" Y="2" Z="3"/>
  <Record X="4" Y="5" Z="6"/>
  <Record X="7" Y="8" Z="9"/>
</Root>

このマッピングのシナリオでは、カタログ内の 3 つのレコードとフラット スキーマ内の 3 つのレコードとの間の、1 対 1 の対応関係を維持することが重要です。次の図は、この対応関係を維持するマップを示しています。

このマップでは、送信元仕様は入力するカタログの構造を表し、送信先仕様は出力するフラット スキーマの構造を表しています。3 つのレコードそれぞれに対して、Functoid のペア (等号 Functoid 等号 Functoid と値のマッピング (フラット化) Functoid 値のマッピング (フラット化) Functoid) が存在しています。次の図は、3 つの値のマッピング (フラット化) Functoid のプロパティ シートを示しています。

値のマッピング Functoid のプロパティ シート

次の図は、一番上の等号 Functoid のプロパティ シートを示しています。

等号 Functoid のプロパティ シート

中央の等号 Functoid のプロパティ シートは似ていますが、第 2 入力パラメータの値が定数値 "Y" になっています。一番下の等号 Functoid のプロパティ シートも似ていますが、第 2 入力パラメータの値が定数値 "Z" になっています。

一番上の Functoid ペアが連携して動作することで、カタログ内の 3 つのレコードそれぞれからフラット スキーマ内の 3 つのレコードそれぞれに対して、値 "X" が渡されます。値のマッピング (フラット化) Functoid が、自分のプロパティ シートの第 2 パラメータの値を返すのは、第 1 パラメータの値が "true" の場合だけです。そのため、一番上の値のマッピング (フラット化) Functoid が "/Root/Record/Field/@Value" の値を返すのは、リンク先の等号 Functoid が値 "true" を返す場合だけです。リンク先の等号 Functoid は、入力されたカタログの中で Name 値が "X" になっているフィールドだけに対して、値 "true" を返します。

中央の Functoid ペアの等号 Functoid は、入力されたカタログの中で Name 値が "Y" になっているフィールドだけに対して、値 "true" を返します。そのため、カタログ内の 3 つのレコードそれぞれからフラット スキーマ内の 3 つのレコードそれぞれに値 "Y" が渡されることが、この Functoid ペアによって保証されます。一番下の Functoid ペアは、同様の方法で値 "Z" を処理します。

重要

  • 値のマッピング (フラット化) Functoid で入力として使用できるのは、小文字の文字列 "true" および "false" という形式のブール型入力だけです。たとえば、入力ドキュメント インスタンスのフィールドが "True" という値を持ち、それが値のマッピング (フラット化) Functoid の第 1 入力パラメータに直接リンクされている場合、値のマッピング (フラット化) Functoid の第 2 入力パラメータは出力ドキュメントに渡されません。

注

  • このマッピングのシナリオにおいて、入力ドキュメント インスタンス内のレコードの中に、いずれかの等号 Functoid の第 2 入力パラメータと一致する属性を持つ複数のフィールドがある場合、一致したものの中で最後のレコードだけが出力ドキュメントにマップされます。たとえば、この Commerce Server カタログの例で、第 1 Record に 3 つの Field があって、それらの Name 属性が X という値を持っている場合、最後の Field だけがマップされます。

フラット スキーマから Commerce Server カタログへのマッピング (このマッピングのシナリオとは逆方向のマッピング) の詳細については、「ループ Functoid の使用」を参照してください。

関連項目

高度 Functoid

値のマッピング Functoid の使用


ループ Functoid の使用

ループ Functoid ループ Functoid は、送信元仕様内の複数のレコードやフィールドを結合し、送信先仕様内の 1 つのレコードにするために使用されます。送信元仕様ツリーのノードからループ Functoid へのループとして表される各ループについて、BizTalk マッパーはそれぞれの子リンクを送信先仕様ツリー ノードから送信元仕様ツリー ノードへ逆方向にたどって、適切な Extensible Stylesheet Language (XSL) Transformation (XSLT) を生成します。しかし、送信元仕様ノードへのリンクに、別の入力送信元リンク (送信元仕様ツリーのノードからループ Functoid へ) の親がある場合、送信先仕様ノードは作成されません。

次の図は、このようなループ Functoid の使用方法を示しています。

ループ Functoid のマップ

[プロパティ] タブの [送信元の属性] および [送信先の属性] で、"最大発生数" に "*" が設定されているので、送信元仕様ツールの BillTo レコードおよび送信先仕様の Addresses レコードはループしています。この例では、送信元仕様の Header レコードもループしています。入力ドキュメント インスタンスに 3 つの BillTo レコードと 2 つの ShipTo レコードがある場合、ループ Functoid はそれらを結合し、出力ドキュメント内に 5 つの Addresses レコードを作成します。

次のコードは、入力ドキュメント インスタンスのサンプルです。

<Root>
<BillTo Name="Karin Zimprich" Address="345 North 63rd Street"
City="Boston" PostalCode="07458"></BillTo>
<BillTo Name="Wendy Wheeler" Address="7890 Broadway"
City="Columbus" PostalCode="46290"></BillTo>
<BillTo Name="Florian Voss" Address="1234 Main Street"
City="Denver" PostalCode="97402"></BillTo>
<ShipTo Name="Kelly Focht" Address="456 First Avenue"
City="Miami" PostalCode="81406"></ShipTo>
<ShipTo Name="Jim Kim" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103"></ShipTo>
<Header ID="01"></Header>
<Header ID="02"></Header>
<Header ID="03"></Header>
</Root>

この入力ドキュメント インスタンスが上の図に示したマップで処理されると、次の出力ドキュメント インスタンスが生成されます。

<Root>
<Addresses Name="Karin Zimprich" Address="345 North 63rd Street"
City="Boston" PostalCode="07458" ID="01" />
<Addresses Name="Wendy Wheeler" Address="7890 Broadway"
City="Columbus" PostalCode="46290" ID="01" />
<Addresses Name="Florian Voss" Address="1234 Main Street"
City="Denver" PostalCode="97402" ID="01" />
<Addresses Name="Kelly Focht" Address="456 First Avenue"
City="Miami" PostalCode="81406" ID="01" />
<Addresses Name="Jim Kim" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103" ID="01" />
</Root>

出力ドキュメント インスタンス内に作成された各 Addresses レコードは、ID フィールドの値が "01" になります。それは、Header レコードがループ Functoid に接続されていないからです。入力ドキュメント インスタンスの最初の ID フィールド値が、出力ドキュメント インスタンスに作成された各レコードに渡されます。

重要

  • 条件によっては、ループ Functoid を持つマップ内で使用される一部の Functoid が期待どおりに動作しないことがあります。Functoid が次の条件に該当している場合、その Functoid からは期待どおりの結果が得られません。
    • Functoid の送信元仕様リンクの中で、ループ Functoid の入力レコードの子フィールドにリンクされているものが 2 つ以上ある。その子フィールドどうしは親が異なる。

    これらの条件に該当する Functoid を前のマップに追加するとすれば、BillTo レコードの Name フィールドに接続された送信元仕様リンク、ShipTo レコードの Name フィールドに接続されたもう 1 つの送信元仕様リンク、および Addresses レコードの Name フィールドに接続された送信先仕様リンクを持つような Functoid が考えられます。

条件付きループ

条件付きループを作成するには、ループ Functoid と論理演算を行う Functoid の出力を同じ送信先レコードに結合します。送信先レコードは、論理的条件が満たされた時にだけ作成されます。

前の図で、最初の論理演算を行う Functoid は、BillTo の下の Name フィールドと "Cynthia Randall" を比較し、この条件が満たされている場合にだけ送信先の Address レコードを作成します。2 番目の論理演算を行う Functoid は、ShipTo の下の Name フィールドと "Jay Adams" を比較し、この条件が満たされている場合にだけ送信先 Address レコードを作成します。ループ Functoid のサンプルと同じ送信元データを使用した場合、このサンプルの出力は次のようになります。

<Root>
<Addresses Name="Cynthia Randall" Address="345 ABC Street" City="Boston" PostalCode="70000" ID="01" />
<Addresses Name="Jay Adams" Address="567 ABC Avenue" City="Seattle" PostalCode="98000" ID="01" /> </Root>
</Root>

フラット スキーマから Commerce Server カタログへのマッピング

ループ Functoid を使用すると、フラット スキーマを Microsoft Commerce Server カタログへマッピングできます。フラット スキーマおよび Commerce Server カタログの詳細については、「値のマッピング (フラット化) Functoid の使用」を参照してください。

次の図は、フラット スキーマから Commerce Server カタログへのマップを示しています。

重要

  • この種類のマップが正常に動作するためには、次のことを行う必要があります。
    • 送信先仕様の Name フィールドに接続された各リンクでは、名前をコピーするように送信元仕様リンク プロパティを設定します。詳細については、「送信元仕様リンクのコンパイラ プロパティの選択」を参照してください。

    • 送信先仕様の Value フィールドに接続された各リンクでは、値をコピーするように送信元仕様リンク プロパティを設定します。詳細については、「送信元仕様リンクのコンパイラ プロパティの選択」を参照してください。

    • ループ Functoid を送信先仕様の Record1 という名前のレコードに接続するリンクでは、送信先仕様リンクのプロパティで [リンクを上から順に一致] を設定します。詳細については、「送信先仕様リンクのコンパイラ プロパティの選択」を参照してください。

    • [BizTalk マッパーのオプション] ダイアログ ボックスの [送信先ツリー ノードへ複数の入力を許可] を必ずオンにします。詳細については、「BizTalk マッパーのオプション : [全般] タブ」を参照してください。.

関連項目

送信先仕様リンクのコンパイラ プロパティの選択

送信元仕様リンクのコンパイラ プロパティの選択

値のマッピング (フラット化) Functoid の使用


マップによる BizTalk サービスの統合

非 HTTP トランスポートを使用して BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合する場合、マップを作成して、パス名を書式名に変換する必要があることがあります。詳細については、「BizTalk サービスの統合」を参照してください。

パス名の書式名への変換

次のコードは、メッセージ キューのパス名の例を示しています。

private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

このパス名を書式名に変換するには、次の文字列をパス名の先頭に追加します。

queue://Direct=OS:

この処理は連結 Functoid によって行うことができます。

次の図は、連結 Functoid を使用して 2 つ以上の文字列を連結するマップを示しています。連結 Functoid の詳細については、「文字列処理を行う Functoid」を参照してください。

連結 Functoid をダブルクリックすると、そのプロパティが表示されます。次の図は、パス名 private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73} の前に queue://Direct=OS: を追加する連結 Functoid のプロパティがマップの中でどのようになるかを示しています。

詳細については、「Functoid プロパティの編集」を参照してください。

連結 Functoid のプロパティ


マップのコンパイル

マップ を コンパイルするとき、BizTalk マッパーのコンパイラ コンポーネントは Extensible Stylesheet Language (XSL) スタイル シートを生成します。このプロセスによって作成されたコンパイル済みのマップによって、送信元スキーマのインスタンス ドキュメントを送信先スキーマのインスタンス ドキュメントに変換することができます。マップをコンパイルすることで、マッピング グリッド内で指定された構造化ルールおよび変換が使えるようになります。

リンクなどの変換は、送信先構造のインスタンス内にレコードおよびフィールドが出現している順序と、同じ順序で処理されます。たとえば、BizTalk マッパーは関連付けられたリンクを持つ送信先レコードまたはフィールドを発見すると、そのリンクのプロパティをコンパイルします。その動作は、送信元仕様のレコードやフィールドから値を代入するだけの単純なコピーの場合や、または Functoid のプロパティを基にして、送信元のいくつかのレコードやフィールドから、送信先のいくつかのレコードやフィールドへの値の計算の場合もあります。

コンパイラで不正な出力が生成されるような状態が発生すると、BizTalk マッパーは [警告] タブに警告を表示します。たとえば、入力パラメータが 1 個必要な Functoid にパラメータが入力されなかった場合、BizTalk マッパーはマップのコンパイル時に [警告] タブに警告を表示します。警告が生成されなくなるまで、運用環境でマップを使用しないでください。

コンパイルされたマップは、BizTalk Server が実際に入力インスタンスから出力インスタンスへの変換を実行するために使用されます。

ここには次のトピックが含まれます。

  • コンパイラ ディレクティブ

関連項目

ノードと階層レベルの対応


コンパイラ ディレクティブ

ある要素からマップするとき、一般的な Extensible Stylesheet Language (XSL) Transformation (XSLT) は次のようになります。

<xsl:attribute name='CatalogPurposeCode'>
<xsl:value-of select='BCT/BCT01/text()'/>
</xsl:attribute>

BCT01 に混在したコンテンツが含まれる場合、"text()" を使用すると最初のサブ要素のところまでに現れた最初のテキストのみにアクセスできます。この XSLT 文で "text()" を使用しなかった場合、すべてのテキスト コンテンツと、サブ要素のすべてのテキスト コンテンツがテキストの 1 つの文字列としてマップされます。しかし、BizTalk マッパーには、送信元仕様ツリーの中のノードの値のコピーを制御できる機能があります。

送信元仕様ツリーの中のノードに接続されているリンクを右クリックし、[プロパティ] を選択することによって、BizTalk マッパーによるデータ変換の処理方法を指定できます。次の中から選択できます。

  • [値のコピー (既定)] : 受信ドキュメント インスタンスのノードの値をコピーします。たとえば、<Node>Hello<Name>Chris</Name>Cannon</Node> は "Hello." に変換されます。

  • [テキストとサブコンテンツの値をコピー] : 受信ドキュメント インスタンスの中のノードの値とその子孫のすべての値を連結した値をコピーします。たとえば、<Node>Hello<Name>Chris</Name>Cannon</Node> は "HelloChrisCannon." に変換されます。

  • [名前のコピー] : 受信ドキュメント インスタンスのノードの名前をコピーします。

送信先仕様ツリーの中のノードに接続されているリンクを右クリックし、[プロパティ] を選択することによって、BizTalk マッパーによる階層の処理方法を指定できます。コンパイラ ディレクティブの詳細については、「ノードと階層レベルの対応」を参照してください。

関連項目

送信先仕様リンクのコンパイラ プロパティの選択

送信元仕様リンクのコンパイラ プロパティの選択


マップのテスト

マップを作成した場合、自分が設計したマップが正しい出力を生成するかどうかを、BizTalk マッパーを使用して確認できます。[マップのテスト] 機能 ([ツール] メニューのオプション) を使用すると、送信元ドキュメントのテスト インスタンスが、仕様から自動的に生成されます。この機能では送信元仕様のレコードの発生数、フィールドのデータの種類などの情報を使用して、テスト インスタンスが生成されます。[値] タブの [送信元テスト値] ボックスで、任意のレコードまたはフィールドに対して値を指定し、そのデータの結果をテストできます。

BizTalk マッパーは、ネイティブまたは Extensible Markup Language (XML) 形式のインスタンスをサポートします。また、マップ テスト プロセスからのネイティブ形式の出力もサポートします。マップを構成する送信元仕様と送信先仕様に応じて、マップをテストするために次の表のオプションを利用できます。

マップのテストのオプション | 説明
[生成された XML から XML] | 送信元ドキュメントのテスト インスタンスが生成され、スタイル シートに送られます。出力は [出力] ウィンドウに XML として表示されます。
[生成された XML からネイティブ] | 送信元ドキュメントのテスト インスタンスが生成され、スタイル シートに送られます。出力はネイティブ形式にシリアライズされ、[出力] ウィンドウにネイティブ データとして表示されます。出力スキーマが XML である場合は、このオプションは利用できません。
[インスタンス XML から XML] | 指定したインスタンス ファイルを使用して出力が生成され、出力は [出力] ウィンドウに XML として表示されます。
[インスタンス XML から ネイティブ] | 指定したインスタンス ファイルを使用して出力が生成され、出力は [出力] ウィンドウにネイティブ データとして表示されます。出力スキーマが XML である場合は、このオプションは利用できません。
[ネイティブ インスタンスから XML] | 指定したネイティブ インスタンス ファイルを使用して出力が生成され、出力は [出力] ウィンドウに XML として表示されます。指定したインスタンスの形式は、入力スキーマの標準の形式に沿っているものとして処理されます。入力スキーマが XML である場合は、このオプションは利用できません。
[ネイティブ インスタンスから ネイティブ] | 指定したネイティブ インスタンス ファイルを使用して出力が生成され、出力は [出力] ウィンドウにネイティブ データとして表示されます。指定したインスタンスの形式は、入力スキーマの標準の形式に沿っているものとして処理されます。入力スキーマまたは出力スキーマが XML である場合は、このオプションは利用できません。

マップをテストするとき、BizTalk マッパーは自動的にそのマップをコンパイルします。しかし、先にマップをコンパイルし、警告やエラーを解消してからテストするようにしてください。テストを開始する前に、ファイルの保存を求めるメッセージが表示されます。テスト前にファイルを保存しておくと、万一マップに問題が起きても、データを元に戻せます。

BizTalk マッパーでは、マップ テストの前に送信元インスタンス データと送信元仕様の適合を検証するオプションを利用できます。マップで使用している仕様のどれかが BizTalk Server ベース以外の仕様である場合 (たとえば XML-Data Reduced (XDR) ファイルなど)、コンテンツ検証機能を使用したときに検証が失敗する可能性があります。XDR ファイルを開いた時に警告 (特に名前空間または要素グループ関連の警告) が表示された場合、コンテンツ検証機能を使用しないでください。

BizTalk にはまた、マッピング機能が完了した後でコンテンツを検証するオプションもあります。この場合、BizTalk マッパーは出力データと送信先仕様の適合を検証します。[マップのテスト前にコンテンツを検証] の場合と同様に、マップで使用している仕様のどれかが BizTalk Server ベース以外の仕様である場合 (たとえば XDR ファイルなど)、コンテンツ検証機能を使用したときに検証が失敗する可能性があります。XDR ファイルを開いた時に警告 (特に名前空間または要素グループ関連の警告) が表示された場合、コンテンツ検証機能を使用しないでください。

マップのテストが終わると、[出力] タブに結果が表示されます。テスト データは、送信先仕様に対応しています。

ここには次のトピックが含まれます。

  • ドキュメントの区切り記号の設定

関連項目

BizTalk マッパーのオプション : [ドキュメントの区切り記号] タブ

BizTalk マッパーのオプション : [全般] タブ

マップのテスト

リンクのあるレコードまたはフィールドのプロパティのテスト


ドキュメントの区切り記号の設定

BizTalk マッパーでは、マップのテスト中に区切り記号を指定できます。[ドキュメントの区切り記号] タブを使用して、テスト中に使用する既定の区切り記号を指定できます。また、マップをテストするたびに [ドキュメントの区切り記号] ダイアログ ボックスを自動的に表示するかどうかを指定することもできます。送信元仕様ツリーのレコードおよびフィールドの一意な区切り記号と、送信先仕様ツリーのレコードおよびフィールドの一意な区切り記号を指定できます。区切り文字を一度だけ設定するか、または BizTalk マッパーがテストごとに区切り記号の入力を要求するようにできます。

区切り記号の既定値のリストを次の表に示します。

区切り記号 | 値
レコード区切り記号 | ~ (0x7e)
フィールド区切り記号 | * (0x2a)
サブフィールド区切り記号 | > (0x3e)
エスケープ | ? (0x3f)


BizTalk マッパーに関する作業を行う目的

ここでは、BizTalk マッパーに関する作業を行う目的についてのクイック リファレンスを提供します。次の表は、主要な作業とそれらに付随する作業を示しており、各作業の目的と対応する手順へのリンクを明記しています。

作業 作業を実行する目的
BizTalk マッパーのオプションの変更
  • BizTalk マッパーのオプション : [全般] タブ
 以下の作業に関する BizTalk マッパーの動作をカスタマイズします。
  • 警告の受信

  • コンパイラ リンクの表示および消去

  • レコード コンテンツのリンクの許可

  • 送信先仕様ツリーへの複数の入力の許可

  • コンテンツの保存

  • コンテンツの検証
  • BizTalk マッパーのオプション : [色] タブ
 マッピング グリッドの色をカスタマイズします。
  • BizTalk マッパーのオプション :ドキュメントの区切り記号
 仕様に区切り構造があり、インスタンス テスト用にドキュメント区切り記号を設定する必要がある場合に対応します。Microsoft BizTalk Server 2002 では、運用環境のデータを処理するためにドキュメント区切り記号を必要とします。
  • BizTalk マッパーのオプション :[XSLT 出力] タブ
 データ出力時に XML 宣言を省略または挿入します。
マップを作成する、開く、保存する
  • 新しいマップの作成
 リンクと Functoid を使用して、ソース間でのデータ変換を処理できるようにします。
  • ローカル ハード ドライブにあるマップを開く
 マップのローカル コピーを使用する場合に対応します。たとえば、仕様を部分的に変更しテストしたいが、Web Distributed Authoring and Versioning (WebDAV) に格納されている共同で仕様される仕様は変更したくない場合などです。
  • WebDAV からのマップの取得
 ほかの人もアクセスして変更できる、共同で使用しているマップを使って作業する場合に対応します。これは、BizTalk メッセージ マネージャがトランザクションを処理するときに使用するファイルです。
  • フォルダから既存のマップを開く
 マップのローカル コピーを使用して作業する場合に対応します。たとえば、マップを部分的に変更し、それをテストしたいが、WebDAV に格納されている、共同で使用される仕様は変更したくない場合などです。
  • 新しいマップの保存
 作成したマップのローカル コピーを保存する場合に対応します。たとえば、WebDAV に格納されている、共同で使用するマップに影響を与えることなく、新たに作成したマップを保存しようとする場合などです。
  • 既存のマップの保存
 変更したマップのローカル コピーを保存する場合に対応します。たとえば、WebDAV に格納されている、共同で使用するマップに影響を与えることなく、修正したマップを保存しようとする場合などです。
  • コンパイル済みのマップの保存
 BizTalk Server が実行時に入力インスタンスから出力インスタンスへの変換を実際に実行するために使用するマップを作成します。コンパイル処理では、リンクおよびオブジェクトのすべての内容と機能など、送信元仕様と送信先仕様に関するすべての情報が保存されます。
  • マップの格納
 BizTalk メッセージ マネージャが、マップを WebDAV を通して利用できるようにする必要がある場合に対応します。これによって、そのファイルはほかの人も利用できるようになります。
仕様の置換
  • 送信元仕様の置換
 マップ作成時に、送信元仕様にレコードまたはファイルの追加などの変更が行われることがあります。この機能を使用すると、送信先仕様を置換し、送信元仕様と送信先仕様の間のマップで作成したすべてまたはほとんどのリンクおよび Functoid を保持できます。
  • 送信先仕様の置換
 マップ作成時に、送信先仕様にレコードまたはファイルの追加などの変更が行われることがあります。この機能を使用すると、送信先仕様を置換し、送信元仕様と送信先仕様の間のマップで作成したすべてまたは大部分のリンクおよび Functoid を保持できます。
グリッド ページでの操作
  • グリッド ページの追加
 マップの表示を簡略化する場合に対応します。たとえば、グリッド ページを追加する場合、ヘッダー情報に関連するすべてのリンクおよび Functoid を 1 つのページに入れ、マップの本体に関連するリンクおよび Functoid を別のページに入れることができます。また、作成したグリッド ページの名前の変更と削除もできます。
Functoid の追加と作業
  • 文字列処理を行う Functoid の追加
 データ文字列を処理します。たとえば、文字列位置検出 Functoid は、あるテキスト文字列を別のテキスト文字列内から検索し、発見した文字列の最初の文字の位置を返します。
  • 数値演算を行う Functoid の追加
 引数と呼ばれる値を使用して、特定の順序または構造で計算します。たとえば、加算 Functoid は指定されたフィールドまたレコードに値を加算します。
  • 論理演算を行う Functoid の追加
 論理テストを実行します。たとえば、論理演算を行う Functoid が送信先仕様のレコードに接続されていて、Functoid が TRUE (真) を返した場合、対応するレコードが出力ドキュメント内に生成されます。論理演算を行う Functoid が送信先仕様のレコードに接続されていて、Functoid が FALSE (偽) を返した場合、対応するレコードは出力ドキュメント内に生成されません。

また、マップ内のほかの Functoid の入力値となる論理演算を行う Functoid を追加する必要がある場合があります。

  • 日時処理を行う Functoid の追加
 日付と時間のデータの操作、または送信先仕様のレコードまたはフィールドへの現在の日付、時刻、または日付と時間のデータを加算します。
  • 変換を行う Functoid の追加
 データを変換します。たとえば、これらの Functoid は、文字を ASCII コード値に変換したり、ASCII コード値を対応する文字に変換するときにも使用できます。変換 Functoid は DEC2HEX などのエンジニアリング関数とほぼ等しく、与えられた 10 進数に対応する 16 進数を返します。
  • 関数演算を行う Functoid の追加
 数値を科学値に変換します。たとえば、コサイン Functoid はフィールドまたはレコードからラジアン値を取得し、コサインの値を返します。
  • 累積演算を行う Functoid の追加
 ループ レコードの合計、平均、最小、または最大入力を返します。
  • データベース操作を行う Functoid の追加
 コード化されたデータからコード化されていないデータへの変換を処理します。たとえば、ある企業が店舗名と住所を表すコードを使用するとします。取引先がトランザクションを処理するためには、実際の店舗名と住所を知る必要があります。データベース Functoid を使用すると、BizTalk Server でデータベース内のコードを検索し、そのコードをその実際の値に置き換えることができます。
  • スクリプト Functoid の追加
 Functoid パレット上で使用できる Functoid では実行できないカスタム動作を実行するために、カスタム Microsoft Visual Basic スクリプトまたはMicrosoft JScript を使用します。
  • レコード カウント Functoid の追加
 ループ レコードに関連する項目の総数を取得します。

たとえば、レコード カウント Functoid では、入力された注文に含まれる明細数をカウントし、その値を請求書のフィールドに出力します。
  • インデックス Functoid の追加
 繰り返されるレコードの特定の発生へアクセスします。たとえば、6 回繰り返される PO 明細があり、3 番目の値だけを取得したい場合、この Functoid を使用します。
  • 繰り返し Functoid の追加
 ある時間にマップされる予定のループ レコードのシーケンス番号を識別します。
  • 値のマッピング Functoid の追加
 "True" や "False" などの、論理要求を満たすデータを移動します。
  • 値のマッピング (フラット化) Functoid の追加
 "True" や "False" などの、論理要求を満たすデータを移動します。これは値のマッピング Functoid の追加と同じですが、この場合は階層がフラット化されています。つまり、送信元仕様ツリーで何かが 3 回繰り返される場合、送信先仕様ツリーでは、そおぬちの 1 つだけが作成されます。
  • ループ Functoid の追加
 コンパイラが送信元仕様ツリー データのループ動作にしたがって、送信先仕様ツリー データをループするようにします。これを並列 ループ 動作と言います。これは通常は明示的に指定し、自動的に発生するようにします。しかし複雑なマップでは、この動作を発生させるために、ループ Functoid を使用する必要があります。
  • Functoid とリンク、またはリンクのグリッド ページ間の移動
 多くのリンクおよび Functoid で非常に複雑になったグリッド ページを簡素化します。
  • Functoid パラメータについて
 それぞれの Functoid のパラメータ要件を明確にします。
  • 入力パラメータ
 Functoid の定数値などのパラメータを設定します。入力パラメータの名前を変更したり、入力パラメータを上下に移動して BizTalk マッパーがパラメータを処理する順序を変更することができます（パラメータの順序に意味がある場合）。
リンクの追加と作業
  • フィールド間のリンクの作成
 送信元仕様ツリーのフィールドから送信先仕様ツリーのフィールドへデータをコピーします。
  • フィールドと Functoid の間のリンクの作成
 送信元仕様ツリーのフィールドのデータを送信先仕様ツリーに出力する前に、さらに処理が必要なデータを Functoid へコピーします。
  • レコードとフィールドの間のリンクの作成
 送信元仕様ツリーのレコードから送信先仕様ツリーのフィールドへデータをコピーします。

重要

  • この作業を実行するには、[BizTalk マッパーのオプション] ダイアログ ボックスの [レコード コンテンツのリンクを許可] を選択する必要があります。
  • レコードと Functoid の間のリンクの作成
 送信元仕様ツリーのレコードのデータを送信先仕様ツリーに出力する前に、さらに処理が必要なデータを Functoid へコピーします。

重要

  • この作業を実行するには、[BizTalk マッパーのオプション] ダイアログ ボックスの [レコード コンテンツのリンクを許可] を選択する必要があります。
  • Functoid 間のリンクの作成
 送信先仕様ツリーへの正しい出力を生成するために複数の Functoid が必要な作業を実行します。
  • レコード コンテンツのリンクの許可
 レコードとフィールドの間、またはレコードと Functoid の間のリンクを作成できるようにします。
  • リンクのリダイレクト
 リンクの作成中に間違いがあり、終端リンクを再作成したい場合に実行します。
  • マッピング グリッドでのリンクと Functoid の表示
 グリッド内のリンクまたは Functoid が見えるようにグリッド領域内をスクロールします。
  • グリッドのプレビューを利用したリンクと Functoid の表示
 マッピング グリッド上の Functoid の配置を示す図を表示します。
  • リンク プロパティの表示: [全般] タブ
 リンクの送信元と送信先に関する情報を表示します。
  • リンク プロパティの表示: [コンパイラ] タブ
 送信元仕様リンクおよび送信先仕様リンクのコンパイラのプロパティの設定を表示します。
  • 送信元仕様リンクのコンパイラ プロパティの選択
 コンパイラが出力ツリー内を移動する方法を制御します。たとえば、コンパイラがテキストの値をコピーする、テキストとサブコンテンツの値をコピーする、または送信元仕様ツリーの名前をコピーするように設定できます。
  • 送信先仕様リンクのコンパイラ プロパティの選択
 コンパイラが出力ツリー内を移動する方法を制御します。たとえば、コンパイラがリンクをフラット化する、リンクを上から順に一致させる、またはリンクを下から順に一致させるように設定できます。詳細については、ノードと階層レベルの対応を参照してください。
コンパイル済みマップの作成および管理
  • マップのコンパイル
 BizTalk Server が実行時に入力インスタンスから出力インスタンスへの変換を実際に実行するために使用するマップをコンパイルします。コンパイル処理では、リンクおよびオブジェクトのすべての内容と機能など、送信元仕様と送信先仕様に関するすべての情報が保存されます。
  • マップのコンパイル後の警告とエラーの解決
 マップでのエラーを検出し、その解決方法の決定します。
  • 定数値の追加
 送信元仕様ツリーのフィールドのテストデータを作成する、または送信先仕様ツリーのフィールドへ実行時定数値を追加します。
マップ テストの実行
  • リンクのあるレコードまたはフィールドのプロパティのテスト
 マップ内のリンクが正しい出力を生成しているか検証します。
  • マップのテスト
 設計したマップが正しい出力を生成しているか検証します。たとえば、レコードの発生回数、フィールドのデータ タイプなどを検証します。この処理には、仕様からの送信元ドキュメントのテスト インスタンスの生成が含まれます。
表示の管理、ユーザ・インターフェイスのカスタマイズ、およびショートカット キーの使用
  • ツリー項目の展開
 ルート ノード以下の、またはあるレコード以下のすべてのレコードとフィールドを表示します。
  • ツリー項目の折りたたみ
 ルート ノード レコードと親レコードの一方だけ、またはその両方を表示します。
  • レコード プロパティとフィールド プロパティの表示
 BizTalk エディタの[宣言]、[参照] 、[解析] 、[名前空間] 、または[コード一覧] タブにある、レコードまたはフィールドのプロパティを表示します。
  • 送信元仕様ツリー ペインのサイズ調整
 送信元仕様ツリー、またはマッピング グリッド領域の表示サイズを調整します。
  • 送信先仕様ツリー ペインのサイズ調整
 送信先仕様ツリー、またはマッピング グリッド領域の表示サイズを調整します。
  • 下部ウィンドウのサイズ調整
 [プロパティ]、[値]、[出力]、または[警告] タブに含まれるコンテンツの表示サイズを調整します。
  • マッピング グリッドの色の変更
 マッピング グリッド内に破線で表される、グリッドの前景領域の色を表す [グリッドの前景色] の変更、またはマッピング グリッドの背景色を表す [グリッドの背景色] を変更します。
  • リンクの色の変更
 固定リンク、柔軟なリンク、部分的なリンク、およびコンパイラリンクの色を変更します。
  • 選択したオブジェクトの色の変更
 マウス ポインタを使って選択したオブジェクトの色を変更します。
  • コンパイラの警告の色の変更
 警告が発生されたとき強調表示されるレコードまたはフィールドの色を変更します。
  • 既定の色への復元
 すべての色オプションを元の設定に戻します。
  • テキストのサイズの変更
 BizTalk マッパーのテキストのフォント サイズを変更します。
  • BizTalk マッパーのショートカット キー
 マウスではなく、ショートカット キーを使って作業を実行します。


BizTalk マッパーに関する作業を行う方法

ここでは、ある仕様から別の仕様にデータをマップする方法を作業ごとに説明します。「BizTalk マッパーについて」を参照し、リンク、Functoid、およびその他のマッピング プロパティと機能について十分に理解しておいてください。

ここには次のトピックが含まれます。

  • BizTalk マッパーのオプションの変更

  • 新しいマップの作成

  • マップを開く

  • マップを保存する、格納する、閉じる

  • 仕様の置換

  • グリッド ページでの操作

  • Functoid の管理

  • リンクの管理

  • コンパイル済みマップの作成および管理

  • マップ テストの実行

  • 表示の管理

  • ユーザー インターフェイスのカスタマイズ

  • BizTalk マッパーのショートカット キー


BizTalk マッパーのオプションの変更

[BizTalk マッパーのオプション] ダイアログ ボックスでは、全般にわたるオプションの設定や、マッピング グリッドの色を選択することができます。

  • [BizTalk マッパーのオプション] ダイアログ ボックスを表示するには、[ツール] メニューの [オプション] をクリックします。

    [全般] タブが表示されます。

[BizTalk マッパーのオプション] ダイアログ ボックスの使用方法については、次の手順を参照してください。

  • BizTalk マッパーのオプション : [全般] タブ

  • BizTalk マッパーのオプション : [色] タブ

  • BizTalk マッパーのオプション : [ドキュメントの区切り記号] タブ

  • BizTalk マッパーのオプション : [XSLT 出力] タブ


BizTalk マッパーのオプション : [全般] タブ

[BizTalk マッパーのオプション] ダイアログ ボックスを開く方法については、「BizTalk マッパーのオプションの変更」を参照してください。

[全般] タブには、BizTalk マッパーの動作をカスタマイズするための 8 つのチェック ボックスがあります。

  • [単純なリンク エラーを警告] (既定ではオンになっています) : データ型が一致しないノード間にリンクを作成しようとすると、警告が表示されます。

  • [コンパイラ リンクを表示] (既定ではオンになっています) : コンパイルした後、マップにコンパイラ リンクが表示されます。

  • [ユーザーの操作後にコンパイラ リンクを削除] (既定ではオフになっています) : BizTalk マッパーで何らかの操作を行うと、コンパイラ リンクが削除されます。

  • [レコード コンテンツのリンクを許可] (既定ではオンになっています) : レコードから Functoid までのコンテンツ リンクを作成できます。

    注

    • Functoid の中には、入力または出力、あるいはその両方でレコード コンテンツを使用していないものがあり、それらの入出力に対しては [レコード コンテンツのリンクを許可] チェック ボックスの効果はありません。そのような入出力を行うものとしては、論理演算を行う Functoid (出力)、レコード カウント Functoid (入力)、繰り返し Functoid (入力)、およびループ Functoid (入出力) があります。
  • [送信先ツリー ノードへ複数の入力を許可] (既定ではオフになっています) : 送信先仕様ツリーのノードに、2 つ以上のリンクを作成することができます。

  • [マップのテスト前に保存するかどうかを確認] (既定でオンになっています) : [ツール] メニューの [マップのテスト] をクリックすると、変更内容をマップ ファイルに保存するかどうかを尋ねるダイアログ ボックスが表示されます。

  • [マップのテスト前にコンテンツを検証] (既定ではオフになっています) : 送信元仕様から送信先仕様へのマッピング機能が完了する前に、データが送信元仕様ツリーに適合しているかどうかが検証されます。

    注

    • マップで使用している仕様のどれかが BizTalk ベース以外の仕様である場合 (たとえば、XML-Data Reduced (XDR) ファイルである場合)、コンテンツ検証機能を使用すると検証は失敗します。XDR ファイルを開いた時に警告 (とくに名前空間または要素グループ関連の警告) が表示された場合、コンテンツ検証機能を使用してはいけません。
  • [マップのテスト後にコンテンツを検証] (既定ではオフになっています) : マッピング機能が完了した後、BizTalk マッパーは送信先仕様のデータを検証します。

    注

    • マップで使用している仕様のどれかが BizTalk ベース以外の仕様である場合 (たとえば、XDR ファイルである場合)、コンテンツ検証機能を使用すると検証は失敗します。XDR ファイルを開いた時に警告 (とくに名前空間または要素グループ関連の警告) が表示された場合、コンテンツ検証機能を使用してはいけません。

関連項目

BizTalk マッパーのオプション : [色] タブ


BizTalk マッパーのオプション : [色] タブ

[BizTalk マッパーのオプション] ダイアログ ボックスを開く方法については、「BizTalk マッパーのオプションの変更」を参照してください。

[色] タブには、マッピング グリッドの色をカスタマイズするためのオプションがあります。これらのオプションについては、次のトピックを参照してください。

  • マッピング グリッドの色の変更

  • リンクの色の変更

  • 選択したオブジェクトの色の変更

  • コンパイラの警告の色の変更

  • 既定の色への復元

関連項目

BizTalk マッパーのオプション : [全般] タブ


BizTalk マッパーのオプション : [ドキュメントの区切り記号] タブ

[BizTalk マッパーのオプション] ダイアログ ボックスを開く方法については、「BizTalk マッパーのオプションの変更」を参照してください。

[ドキュメントの区切り記号] タブには、マップをテストするためのオプションがあります。テストごとに一意な区切り記号を指定するか、または既定の区切り記号を設定して、テスト中に新しい区切り記号の入力が要求されないようにすることができます。

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [ドキュメントの区切り記号] タブをクリックします。

  3. [区切り記号の種類] で [ソースの区切り記号] または [ターゲットの区切り記号] を選択します。

  4. 以下のボックスのドロップダウン リストからオプションを選択するか、または独自のオプションを入力します。
    • [レコード区切り記号]

    • [フィールド区切り記号]

    • [サブフィールド区切り記号]

    • [エスケープ文字]

    重要

    • 独自の区切り記号を指定する場合は、Unicode 文字の値を使用します。有効な文字の一覧については、Microsoft Global Software Development Web サイト (www.microsoft.com/globaldev/reference/wincp.asp) にあるグローバル コードページのページを参照してください。先頭に 2 つのゼロがあることを除いて、ANSI 文字コードが Unicode 文字コードと同じである場合は、ANSI 文字コードを使用することができます。
  5. ドキュメント インスタンスを検証するたびに [ドキュメントの区切り記号] ダイアログ ボックスが表示されるのを避けるには、[インスタンス テスト時に区切り記号を要求] ボックスをオフにします。

重要

  • NULL 終端記号 (区切り記号) はサポートされていません。このサポートが必要な場合、ファイルを処理する前にフラット ファイルから Null 区切り記号を削除するか、ファイルを処理した後にフラット ファイルに NULL 区切り記号を追加します。

  • [インスタンス テスト時に区切り記号を要求] ボックスがオンになっているためにインスタンス テスト中に区切り記号の入力を要求された場合、指定した区切り記号はそのインスタンスのテストにだけ使用されます。[ドキュメント区切り記号] タブで指定した既定の区切り記号は変更されません。

  • [インスタンス テスト時に区切り記号を要求] ボックスがオンになっていて、テストしているインスタンスがエンベロープ情報を持つ EDI ファイルである場合、[ドキュメントの区切り記号] ダイアログ ボックスは表示されません。なぜならば、BizTalk マッパーは必要な区切り記号を自動的に検出するからです。インスタンス テスト時に [インスタンス テスト時に区切り記号を要求] ボックスを表示するように設定している場合はこのボックスは表示されますが、BizTalk マッパーは使用する区切り記号を判断することができません。

注

  • 複数のドキュメントとエンベロープ情報 (ヘッダー/トレーラ) がインスタンスに含まれている場合、[ドキュメントの区切り記号] タブで指定されているドキュメントの区切り記号が検証されるのは最初のドキュメントだけです。


BizTalk マッパーのオプション : [XSLT 出力] タブ

[BizTalk マッパーのオプション] ダイアログ ボックスを開く方法については、「BizTalk マッパーのオプションの変更」を参照してください。

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [XSLT 出力] タブをクリックします。

  3. [XML 宣言の省略] ボックスで、ドロップダウン リストから [はい] (宣言を省略する場合) または [いいえ](宣言を含める場合) を選択します。

    注

    • これは、XML 宣言が出力されるかどうかを表します。([いいえ] を選択した場合) 下のような XML 宣言が表示されます。
      <?xml version="1.0" encoding="utf-8" ?
  4. [OK] をクリックします。


新しいマップの作成

マップを作成するには、送信元仕様と送信先仕様の両方を指定する必要があります。

  1. [ファイル] メニューの [新規作成] をクリックします。

    [送信元仕様の種類の選択] ダイアログ ボックスが表示されます。

  2. 次のいずれかをダブルクリックします。
    • [ローカル ファイル]: 手順 3. に進みます。

    • [テンプレート]: 手順 4. に進みます。

    • [WebDAV ファイル]: 手順 3. に進みます。
  3. 送信元仕様が格納されているフォルダを参照し、手順 5. に進みます。

  4. [EDIFACT]、[X12]、または [XML] をクリックし、[OK] をクリックします。

    EDIFACT または X12 を選択する場合は、使用するバージョンも選択する必要があります。使用するバージョンが格納されているフォルダをクリックし、[OK] をクリックして手順 5. に進みます。

    重要

    • BizTalk Server インストールに含まれている X12 テンプレートを BizTalk マッパーで使用すると、次のようなエラー メッセージが表示される場合があります。

      "ITD05" フィールド ("") の長さが無効です。長さを 48 から -1 までで設定してください。このドキュメントは拒否されます。

      X12 テンプレートは、10 進数データ型 Nx を暗黙的に使用します。入力データが小数点を含んでいると、出力は N カスタム データ型 (これは小数点を含みません) と一致せず、中間 XML ファイルに無効なインスタンスが作成されます。このリリースの BizTalk Server では、シリアライザは、中間 XML ファイルがデータ型 N の出力で小数点を含んでいるかどうかを検出しない場合があります。この問題を解決するには、X12 テンプレートで暗黙的に使用される 10 進数データ型をほかの数値データ型に手動で変更する必要があります。

  5. 送信元仕様を選択し、[開く] をクリックします。

    [送信先仕様の種類の選択] ダイアログ ボックスが表示されます。

  6. 次のいずれかをダブルクリックします。
    • [ローカル ファイル]: 手順 7. に進みます。

    • [テンプレート]: 手順 8. に進みます。

    • [WebDAV ファイル]: 手順 7. に進みます。
  7. 送信先仕様が格納されているフォルダを参照し、手順 9. に進みます。

  8. [EDIFACT]、[X12]、または [XML] をクリックし、[OK] をクリックします。

    EDIFACT または ANSI X12 を選択する場合は、使用するバージョンも選択する必要があります。使用するバージョンが格納されているフォルダをクリックし、[OK] をクリックして手順 9. に進みます。

  9. 送信先仕様を選択し、[開く] をクリックします。

  10. XDR スキーマを選択した場合、[ルート要素の選択] ダイアログ ボックスが表示される場合があります。その場合、[ルート要素] ボックスの一覧からルート要素を選択し、[OK] をクリックします。

    注

    • XML-Data Reduced (XDR) スキーマにルートが含まれていない場合は、スキーマ内の該当するノードから指定する必要があります。

    • BizTalk マッパーで非 BizTalk Server XDR スキーマを開く場合、要素グループまたは名前空間の一方、あるいは両方がスキーマ内に存在していれば、エラーまたは警告メッセージが表示されます。結果として、マップが予想どおりに表示されないことがあります。

    • 送信先仕様ツリーまたは送信元ツリーに、グループは視覚的に表示されません。グループを持つスキーマがマップに含まれている場合は、ランタイム エンジンはグループ属性に対して検証を行います。ただし、BizTalk マッパーがグループの参照をグラフィカルに表示することはありません。

関連項目

送信先仕様の置換

送信元仕様の置換


マップを開く

ここには次のトピックが含まれます。

  • ローカル ハード ドライブにあるマップを開く

  • WebDAV からのマップの取得

  • フォルダから既存のマップを開く


ローカル ハード ドライブにあるマップを開く

  1. [ファイル] メニューの [開く] をクリックします。

    [マップ送信元を開く] ダイアログ ボックスが表示されます。

  2. マップが格納されているフォルダを参照します。

  3. 一覧にあるマップを選択し、[開く] をクリックします。

重要

  • BizTalk Server インストールに含まれている X12 テンプレートを BizTalk マッパーで使用すると、次のようなエラー メッセージが表示される場合があります。

    "ITD05" フィールド ("") の長さが無効です。長さを 48 から -1 までで設定してください。このドキュメントは拒否されます。

    X12 テンプレートは、10 進数データ型 Nx を暗黙的に使用します。入力データが小数点を含んでいると、出力は N カスタム データ型 (これは小数点を含みません) と一致せず、中間 XML ファイルに無効なインスタンスが作成されます。このリリースの BizTalk Server では、シリアライザは、中間 XML ファイルがデータ型 N の出力で小数点を含んでいるかどうかを検出しない場合があります。この問題を解決するには、X12 テンプレートで暗黙的に使用される 10 進数データ型をほかの数値データ型に手動で変更する必要があります。

注

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成したマップを開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

WebDAV からのマップの取得


WebDAV からのマップの取得

  1. [ファイル] メニューの [WebDAV から取得] をクリックします。

    [WebDAV から取得] ダイアログ ボックスが表示されます。

  2. [サーバー] ボックスの一覧にあるサーバー名をクリックします。

    重要

    • プロキシ サーバー ポートが 80 でない場合、WebDAV に格納されているマップにアクセスするには、[サーバー] ボックスの一覧に「http://<サーバー名>:<ポート番号>」と入力する必要があります。

    • 保護されているサーバーでマップを取得することはできません。たとえば、サーバーが https://<サーバー名>/biztalkserverrepository である場合、どのマップにもアクセスできません。
  3. 取得するマップが格納されているフォルダを参照し、マップを選択して、[開く] をクリックします。

重要

  • WebDAV から既存のマップを開こうとしたときに、"BizTalk Server リポジトリが http://<server name>/BizTalkServerRepository/Maps に見つかりませんでした。" というエラー メッセージが表示された場合は、msdaipp.dll を再登録して、コンピュータを再起動します。msdaipp.dll を再登録する方法の詳細については、WebDAVにおけるファイルの取得または格納を目的とした msdaipp.dll の再登録を参照してください。

  • BizTalk Server インストールに含まれている X12 テンプレートを BizTalk エディタで使用すると、次のようなエラー メッセージが表示される場合があります。

    "ITD05" フィールド ("") の長さが無効です。長さを 48 から -1 までで設定してください。このドキュメントは拒否されます。

    X12 テンプレートは、10 進数データ型 Nx を暗黙的に使用します。入力データが小数点を含んでいると、出力は N カスタム データ型 (これは小数点を含みません) と一致せず、中間 XML ファイルに無効なインスタンスが作成されます。このリリースの BizTalk Server では、シリアライザは、中間 XML ファイルがデータ型 N の出力で小数点を含んでいるかどうかを検出しない場合があります。この問題を解決するには、X12 テンプレートで暗黙的に使用される 10 進数データ型をほかの数値データ型に手動で変更する必要があります。

注

  • リモート WebDAV サーバーに初めて接続する場合は、時間がかかることがあります。

  • WebDAV からマップを取得するには、サーバー上のファイルを取得するためのアクセス許可が必要です。

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成したマップを開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

ローカル ハード ドライブにあるマップを開く

BizTalk エディタと BizTalk マッパーのトラブルシューティング


フォルダから既存のマップを開く

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[アクセサリ] をポイントし、[エクスプローラ] をクリックします。

  2. BizTalk マッパーで表示するファイルに移動します。

    必要に応じて、BizTalk マッパー ウィンドウを見ることができるようにするために、[元のサイズに戻す] をクリックし、ウィンドウのサイズを縮小します。

  3. ファイルを BizTalk マッパーにドラッグします。

重要

  • BizTalk Server インストールに含まれている X12 テンプレートを BizTalk エディタで使用すると、次のようなエラー メッセージが表示される場合があります。

    "ITD05" フィールド ("") の長さが無効です。長さを 48 から -1 までで設定してください。このドキュメントは拒否されます。

    X12 テンプレートは、10 進数データ型 Nx を暗黙的に使用します。入力データが小数点を含んでいると、出力は N カスタム データ型 (これは小数点を含みません) と一致せず、中間 XML ファイルに無効なインスタンスが作成されます。このリリースの BizTalk Server では、シリアライザは、中間 XML ファイルがデータ型 N の出力で小数点を含んでいるかどうかを検出しない場合があります。この問題を解決するには、X12 テンプレートで暗黙的に使用される 10 進数データ型をほかの数値データ型に手動で変更する必要があります。

注

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成したマップを開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。


マップを保存する、格納する、閉じる

ここには次のトピックが含まれます。

  • 新しいマップの保存

  • 既存のマップの保存

  • コンパイル済みのマップの保存

  • マップの格納

  • マップを閉じる


新しいマップの保存

  1. [ファイル] メニューの [名前を付けて保存] をクリックします。

    [マップ送信元に名前を付けて保存] ダイアログ ボックスが表示されます。

  2. [ファイル名] ボックスにマップの名前を入力します。

  3. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字セットが多い仕様では [UTF-8]、2 バイト文字セットが多い仕様では [Unicode] をお勧めしますが、どちらを使うことも可能です。

注

  • BizTalk マッパーでマップを保存すると、マップは自動的にコンパイルされます。コンパイル済みマップは [出力] タブで見ることができます。

  • BizTalk マッパーでマップを保存すると、マップはハード ドライブに保存されます。マップを WebDAV に格納するには、ファイルをサーバーに格納するためのアクセス許可が必要です。

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成したマップを開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

マップの格納


既存のマップの保存

  • [ファイル] メニューの [保存] をクリックします。

注

  • BizTalk マッパーでマップを保存すると、マップは自動的にコンパイルされます。コンパイル済みマップは [出力] タブで見ることができます。

  • BizTalk マッパーでマップを保存すると、マップはハード ドライブに保存されます。マップを WebDAV に格納するには、ファイルをサーバーに格納するためのアクセス許可が必要です。

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成したマップを開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

マップの格納


コンパイル済みマップの保存

  1. [ファイル] メニューの [コンパイル済みマップに名前を付けて保存] をクリックします。

    [コンパイル済みマップに名前を付けて保存] ダイアログ ボックスが表示されます。

    注

    • この機能を使用できるのは、マップをコンパイルした場合だけです。
  2. [ファイル名] ボックスにファイルの名前を入力し、[保存] をクリックします。

注

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成したマップを開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

マップの格納


マップの格納

  1. [ファイル] メニューの [WebDAV に格納] をクリックします。

    [WebDAV に格納] ダイアログ ボックスが表示されます。

  2. [サーバー] ボックスの一覧にあるサーバー名をクリックします。

    重要

    • プロキシ サーバー ポートが 80 でない場合、WebDAV にマップを格納するには、[サーバー] ボックスの一覧に「http://<サーバー名>:<ポート番号>」と入力する必要があります。

    • 保護されているサーバーでマップを格納することはできません。たとえば、サーバーが https://<サーバー名>/biztalkserverrepository である場合、どのマップも格納できません。
  3. マップを格納するフォルダを参照し、[ファイル名] ボックスにファイルの名前を入力します。

  4. [エンコード] ボックスの一覧で [UTF-8] または [Unicode] のいずれかをクリックし、[保存] をクリックします。

    ASCII 文字セットが多い仕様では [UTF-8]、2 バイト文字セットが多い仕様では [Unicode] をお勧めしますが、どちらを使うことも可能です。

各国語対応に関する問題

  • ファイルは、WebDAV リポジトリに Unicode エンコードでのみ保存できます。ただし、WebDAV レポジトリでは、異なるコード ページの名前のファイルを格納することはできません。

  • WebDAV では、ファイル名に Unicode 文字を使用できません。

  • システム ロケールがユーザーの言語に設定されていることを確認してください。たとえば、英語以外の言語を使用しているユーザーが Microsoft® Windows® の英語バージョンを実行しているコンピュータ上に BizTalk Server 2002 の英語バージョンをインストールしていて、ファイル名に Latin I コード ページ (Windows の1252、英語を含む) でサポートされていない文字を使用するためには、システム ロケールを自分のロケールに変更する必要があります。

  • ロケールを正しく設定していない場合、2 バイト文字コード セット (DBCS) を使用したファイル名ではファイルを格納できません。詳細については、「???.xml が WebDAV ダイアログ ボックスに表示される」を参照してください。

重要

  • マップをWebDAV に格納しようとしたときに、"BizTalk Server リポジトリが http://<server name>/BizTalkServerRepository/Maps に見つかりませんでした。" というエラー メッセージが表示された場合は、msdaipp.dll を再登録して、コンピュータを再起動します。msdaipp.dll の再登録方法については、「WebDAV におけるファイルの取得または格納を目的とした msdaipp.dll の再登録」を参照してください。

注

  • リモート WebDAV サーバーに初めて接続する場合は、時間がかかることがあります。

  • WebDAV にマップを格納するには、ファイルをサーバーに格納するためのアクセス許可が必要です。

  • BizTalk Server 2002 をインストールした後に BizTalk Server 2000 で作成したマップを開くと、ファイルの保存時にファイル形式が変更され、BizTalk Server 2002 で再び開くことができなくなります。

関連項目

BizTalk エディタと BizTalk マッパーのトラブルシューティング


マップを閉じる

  • [ファイル] メニューの [閉じる] をクリックします。


仕様の置換

ここには次のトピックが含まれます。

  • 送信元仕様の置換

  • 送信先仕様の置換


送信元仕様の置換

  1. [編集] メニューの [送信元仕様の置換] をクリックします。

    マップを保存していない場合は、マップ送信元の変更内容を保存するように求めるメッセージが表示されます。

    [送信元仕様の種類の選択] ダイアログ ボックスが表示されます。

  2. 次のいずれかをダブルクリックします。
    • [ローカル ファイル]: 手順 3. に進みます。

    • [テンプレート]: 手順 4. に進みます。

    • [WebDAV ファイル]: 手順 3. に進みます。
  3. 送信元仕様が格納されているフォルダを参照し、手順 5. に進みます。

  4. [EDIFACT]、[X12]、または [XML] をクリックし、[OK] をクリックします。

    EDIFACT または X12 を選択する場合は、使用するバージョンも選択する必要があります。使用するバージョンが格納されているフォルダをクリックし、[OK] をクリックして手順 5. に進みます。

  5. 送信元仕様を選択し、[OK] または [開く] をクリックします。

注

  • 新しい仕様に送信元テスト値と関連付けられたフィールドがある場合、送信元仕様を置換すると送信元テスト値が保存されます。

  • 送信元仕様を置換すると破損する可能性のあるリンクについては、[警告] タブに警告の一覧が表示されます。警告が表示された場合、問題は複数のグリッド ページにわたって存在する場合があります。

    たとえば、グリッド ページ 1 の送信元仕様ツリーの中のレコード (レコード名 Item) が送信先仕様ツリーの中のレコード (レコード名 Number) にリンクされていて、グリッド ページ 2 の送信元ツリーの中のレコード (レコード名 Product) が送信先仕様ツリーの中の同じ Number レコードにリンクされている場合、同一のレコードに複数の入力があることを知らせる警告メッセージが生成されます。しかし、グリッド ページ 1 を表示した場合は、Number レコードの中には 1 つの入力だけが表示されます。

関連項目

送信先仕様の置換


送信先仕様の置換

  1. [編集] メニューの [送信先仕様の置換] をクリックします。

    マップを保存していない場合は、マップ送信元の変更内容を保存するように求めるメッセージが表示されます。

    [送信先仕様の種類の選択] ダイアログ ボックスが表示されます。

  2. 次のいずれかをダブルクリックします。
    • [ローカル ファイル]: 手順 3. に進みます。

    • [テンプレート]: 手順 4. に進みます。

    • [WebDAV ファイル]: 手順 3. に進みます。
  3. 送信先仕様が格納されているフォルダを参照し、手順 5. に進みます。

  4. [EDIFACT]、[X12]、または [XML] をクリックし、[OK] をクリックします。

    EDIFACT または X12 を選択する場合は、使用するバージョンも選択する必要があります。使用するバージョンが格納されているフォルダをクリックし、[OK] をクリックして手順 5. に進みます。

  5. 送信先仕様を選択し、[開く] または [OK] をクリックします。

注

  • 新しい仕様に送信先定数値と関連付けられたフィールドがある場合、送信先仕様を置換すると送信先定数値が保存されます。送信先定数値の詳細については、「定数値の追加」を参照してください。

  • 送信先仕様を置換すると破損する可能性のあるリンクについては、[警告] タブに警告の一覧が表示されます。警告が表示された場合、問題は複数のグリッド ページにわたって存在する場合があります。

    たとえば、グリッド ページ 1 の送信元仕様ツリーの中のレコード (レコード名 Item) が送信先仕様ツリーの中のレコード (レコード名 Number) にリンクされていて、グリッド ページ 2 の送信元ツリーの中のレコード (レコード名 Product) が送信先仕様ツリーの中の同じ Number レコードにリンクされている場合、同一のレコードに複数の入力があることを知らせる警告メッセージが生成されます。しかし、グリッド ページ 1 を表示した場合は、Number レコードの中には 1 つの入力だけが表示されます。

関連項目

定数値の追加

送信元仕様の置換


グリッド ページでの操作

ここには次のトピックが含まれます。

  • グリッド ページの追加

  • グリッド ページの名前の変更

  • グリッド ページの削除


グリッド ページの追加

  • [編集] メニューの [ページの追加] をクリックします。

注

  • 追加できるグリッド ページの最大数は、20 です。


グリッド ページの名前の変更

  • グリッド ページ名をダブルクリックして、新しい名前を入力し、Enter キーを押します。

注

  • オートコンプリート機能は、入力したエントリと一致する以前のエントリの一覧を自動的に表示します。


グリッド ページの削除

  • [編集] メニューの [ページの削除] をクリックします。

注

  • グリッド ページを 1 ページ残してすべて削除できます。


Functoid の管理

ここには次のトピックが含まれます。

  • Functoid の操作

  • Functoid パラメータについて

  • Functoid プロパティの編集


Functoid の操作

Functoid パレットには、BizTalk マッパーで使用可能なすべての Functoid が含まれています。Functoid パレットで、使用する Functoid をクリックしてマッピング グリッドにドラッグしてください。タブにはさまざまな Functoid が用意されています。表示範囲外にあるタブを表示するには、左矢印ボタンまたは右矢印ボタンをクリックしてください。

ここには次のトピックが含まれます。

  • 文字列処理を行う Functoid の追加

  • 数値演算を行う Functoid の追加

  • 論理演算を行う Functoid の追加

  • 日時処理を行う Functoid の追加

  • 変換を行う Functoid の追加

  • 関数演算を行う Functoid の追加

  • 累積演算を行う Functoid の追加

  • データベース操作を行う Functoid の追加

  • スクリプト Functoid の追加

  • レコード カウント Functoid の追加

  • インデックス Functoid の追加

  • 繰り返し Functoid の追加

  • 値のマッピング Functoid の追加

  • 値のマッピング (フラット化) Functoid の追加

  • ループ Functoid の追加

  • Functoid とリンク、またはリンクのグリッド ページ間の移動

  • 複数のリンクとFunctoid の選択

  • Functoid の削除

関連項目

BizTalk マッパーの Functoid パレット

Functoid について


文字列処理を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [文字列] タブをクリックします。

  3. 文字列処理を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の文字列処理 Functoid の詳細については、「文字列処理を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


数値演算を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [数値演算] タブをクリックします。

  3. 数値演算を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の数値演算 Functoid の詳細については、「数値演算を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

各国語対応に関する問題

  • 多くの国または地域では、桁区切り記号としてカンマ (,) を使用します。Microsoft XML (MSXML) Parser では桁区切り記号としてピリオド (.) を使用するので、MSXML ではカンマを桁区切り記号として使う数字の検証は失敗します。この問題を解決するには、システム ロケール設定で次の手順に従って、桁区切り記号をカンマからピリオドに変更します。
    1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

    2. [地域のオプション] をダブルクリックします。

      [地域のオプション] コンソールが表示されます。

    3. [数値] タブをクリックします。

    4. [桁区切り記号] リスト ボックスに「:」と入力します。 .

    5. [適用] をクリックし、[OK] をクリックします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


論理演算を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [論理] タブをクリックします。

  3. 論理演算を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の論理演算 Functoid の詳細については、「論理演算を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 論理演算を行う Functoid で 2 つの文字列を比較する場合は、大文字と小文字が区別されます。たとえば、"Abc" と "abc" は等しくないと評価されます。例外は、論理演算を行う Functoid を使用して、ブール値の TRUE および FALSE を表す文字列を比較する場合です。たとえば、"True" と "true" は等しいと評価されます。

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


日時処理を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [日付/時刻] タブをクリックします。

  3. 日時処理を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の日時処理 Functoid の詳細については、「日時処理を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 日付、時刻、または日時を処理する Functoid で必要なのは、送信先仕様ツリーのフィールドまたはレコードへのリンクのみです。

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


変換を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [変換] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 変換を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の変換 Functoid の詳細については、「変換を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


関数演算を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [関数] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 関数演算を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の関数演算 Functoid の詳細については、「関数演算を行う Functoid」を参照してください。

  4. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


累積演算を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [累積] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 累積演算を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    特定の累積演算 Functoid の詳細については、「累積演算を行う Functoid」を参照してください。

  4. ループした親レコードを持つフィールドを、送信元仕様ツリーからマッピング グリッドの Functoid にドラッグし、次に、送信先仕様ツリーのレコードまたはフィールドに Functoid をドラッグします。

    ループ レコードの詳細については、「累積演算を行う Functoid の使用」を参照してください。

重要

  • この手順の詳細については、「累積演算を行う Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


データベース操作を行う Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [データベース] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. データベース操作を行う Functoid を、Functoid パレットからマッピング グリッドにドラッグします。

    データベース操作を行う Functoid の詳細については、「データベース操作を行う Functoid」を参照してくたさい。

重要

  • データベース操作を行う Functoid を使用してデータベースから情報を抽出する方法については、「データベース操作を行う Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


スクリプト Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. マッピング グリッドにスクリプト Functoid スクリプト Functoid をドラッグします。

    スクリプト Functoid の詳細については、「高度 Functoid」を参照してください。

  4. スクリプト Functoid をダブルクリックします。

    [Functoid プロパティ] ダイアログ ボックスが表示されます。

  5. [スクリプト] タブをクリックします。

  6. [スクリプト言語] で [VBScript] または [JScript] をクリックし、[Functoid スクリプト] に使用するスクリプトを入力し、[OK] をクリックします。

  7. レコードまたはフィールドを送信元仕様ツリーからマッピング グリッドのスクリプト Functoid にドラッグし、次に、スクリプト Functoid を送信先仕様ツリーのレコードまたはフィールドにドラッグします。

重要

  • スクリプト Functoid に複数の関数がある場合は、1 番目の関数が、主要部分を構成する基本の関数になります。スクリプト Functoid へのリンクがある場合は、この関数にパラメータを設定する必要があります。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

表示の管理


レコード カウント Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. レコード カウント Functoid レコード カウント Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    レコード カウント Functoid の詳細については、「高度 Functoid」を参照してください。

  4. ループ レコードを送信元仕様ツリーからマッピング グリッドのレコード カウント Functoid にドラッグし、次に、レコード カウント Functoid を送信先仕様ツリーのレコードにドラッグします。

    ループ レコードの詳細については、「レコード カウント Functoid の使用」を参照してください。

重要

  • この手順の詳細については、「レコード カウント Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


インデックス Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. インデックス Functoid インデックス Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    インデックス Functoid の詳細については、「高度 Functoid」を参照してください。

  4. ループした親レコードを持つフィールドを、送信元仕様ツリーからマッピング グリッドのインデックス Functoid にドラッグし、次に、送信先仕様ツリーのフィールドにインデックス Functoid をドラッグします。

    ループ レコードの詳細については、「インデックス Functoid の使用」を参照してください。

  5. インデックス Functoid をダブルクリックし、プロパティ シートを表示します。

  6. [新しいパラメータの挿入] ボタン [新しいパラメータの挿入] ボタン をクリックし、インデックス値を入力して Enter キーを押します。

  7. 必要に応じて、手順 6. を繰り返します。

  8. [OK] をクリックします。

重要

  • この手順の詳細については、「インデックス Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


繰り返し Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 繰り返し Functoid 繰り返し Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    繰り返し Functoid の詳細については、「高度 Functoid」を参照してください。

重要

  • 繰り返し Functoid の使用方法については、「繰り返し Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


値のマッピング Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 値のマッピング Functoid 値のマッピング Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    値のマッピング Functoid の詳細については、「高度 Functoid」を参照してください。

重要

  • 値のマッピング Functoid の使用方法については、「値のマッピング Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

値のマッピング (フラット化) Functoid の追加

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


値のマッピング (フラット化) Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. 値のマッピング (フラット化) Functoid 値のマッピング (フラット化) Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    値のマッピング (フラット化) Functoid の詳細については、「高度 Functoid」を参照してください。

重要

  • 値のマッピング (フラット化) Functoid の使用方法については、「値のマッピング (フラット化) Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

値のマッピング Functoid の追加

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


ループ Functoid の追加

  1. [表示] メニューの [Functoid パレット] をクリックします。

  2. [Functoid パレット] ダイアログ ボックスの [高度] タブをクリックします。

    [Functoid パレット] ダイアログ ボックスの右矢印をクリックし、タブを表示させる必要がある場合があります。

  3. ループ Functoid ループ Functoid を Functoid パレットからマッピング グリッドにドラッグします。

    ループ Functoid の詳細については、「高度 Functoid」を参照してください。

重要

  • 条件によっては、ループ Functoid を持つマップ内で使用された、一部の Functoid が期待どおりに動作しないことがあります。Functoid が次の条件に該当している場合、その Functoid からは期待どおりの結果が得られません。
    • Functoid に、複数の送信元仕様リンクがある。

    • Functoid の送信元仕様リンクの中で、ループ Functoid の入力レコードの子フィールドにリンクされているものが 2 つ以上ある。その子フィールドどうしは親が異なる。

    • Functoid に、ループ Functoid の出力レコードの子フィールドにリンクされた送信先仕様リンクがある。
  • ループ Functoid の使用方法については、「ループ Functoid の使用」を参照してください。

  • Functoid とレコード間のリンクを作成するには、[レコード コンテンツのリンクを許可] チェック ボックスをオンにする必要があります。これを行うには、[ツール] メニューの [オプション] をクリックします。[BizTalk マッパーのオプション] ダイアログ ボックスの [全般] タブで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

注

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

レコード コンテンツのリンクの許可

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成

Functoid について


Functoid とリンク、またはリンクのグリッド ページ間の移動

  1. 移動する Functoid またはリンクを選択します。

    注

    • Functoid を選択した場合は、それに関連するリンクも選択され、移動します。

    • チェーンの中にあるすべてのリンクおよびリンクされている Functoid が選択されていない場合、Functoid を移動できません。
  2. 必要に応じて、右矢印ボタンまたは左矢印ボタンをクリックし、Functoid または リンクを置くページのタブを表示します。

  3. Functoid またはリンクを移動先のページのタブまでドラッグし、グリッド ページが表示されるまでタブの上で保持します。

  4. Functoid またはリンクをそれを置くグリッドの場所までドラッグします。

注

  • ほかのページに Functoid およびそのリンクを移動する前に、その Functoid に接続されているすべてのリンクを表示する必要があります。リンクを表示するには、その Functoid に接続されているリンクを含んでいる送信元および送信先ノードを展開します。


複数のリンクとFunctoidの選択

  • カーソルをドラッグして、選択する複数のリンクおよび Functoid まで移動します。


Functoid の削除

  1. 削除する Functoid を右クリックし、[削除] をクリックします。

  2. 確認ダイアログ ボックスで [はい] をクリックします。


Functoid パラメータについて

ここでは、Microsoft BizTalk Server 2002 の各 Functoid についての説明、図、およびパラメータを示します。

ここには次のトピックが含まれます。

  • 文字列処理を行う Functoid

  • 数値演算を行う Functoid

  • 論理演算を行う Functoid

  • 日時処理を行う Functoid

  • 変換を行う Functoid

  • 関数演算を行う Functoid

  • 累積演算を行う Functoid

  • データベース操作を行う Functoid

  • 高度 Functoid


文字列処理を行う Functoid

Functoid パラメータ
文字列位置検出 Functoid 文字列位置検出

指定された別の文字列が始まる文字列位置を返します。

 この Functoid には 2 個の入力パラメータが必要です。この Functoid にリンクする 1 番目の文字列から 2 番目の文字列のある位置を探します。
左文字列抽出 Functoid 左文字列抽出

テキスト項目の一番左の文字から順に、指定された文字数だけ返します。

 この Functoid には 2 個の入力パラメータが必要です。この Functoid にリンクする 1 番目のフィールドは出力する文字列を指定します。この Functoid にリンクする 2 番目のフィールドは出力する文字数を指定します。出力結果は、Functoid にリンクした最初のフィールドの文字列のサブセットです。
小文字変換 Functoid 小文字変換

テキスト項目を小文字に変換します。

 この Functoid には 1 個の入力パラメータが必要です。
右文字列抽出 Functoid 右文字列抽出

テキスト項目の一番右の文字から順に、指定された文字数だけ抽出します。

 この Functoid には 2 個の入力パラメータが必要です。この Functoid にリンクする 1 番目のフィールドは出力する文字列を指定します。この Functoid にリンクする 2 番目のフィールドは出力する文字数を指定します。出力結果は、Functoid にリンクした最初のフィールドの文字列のサブセットです。
文字列長算出 Functoid 文字列長算出

文字列の長さを整数値で返します。

 この Functoid には 1 個の入力パラメータが必要です。出力結果は入力フィールドに含まれるデータの文字数を表したものです。
文字列抽出 Functoid 文字列抽出

入力文字列の開始位置と終了位置を指定し、文字列を抽出します。

 この Functoid には 3 個の入力パラメータが必要です。

この Functoid へのフィールドのリンク付けは、次の順序で行う必要があります。

  1. 文字列フィールド

  2. 開始位置フィールド

  3. 終了位置フィールド
連結 Functoid 連結

連続する入力文字列を連結します。

 この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限がありません。
文字列左スペース削除 Functoid 文字列左スペース削除

テキスト項目から先頭のスペースを削除します。

 この Functoid には 1 個の入力パラメータが必要です。
文字列右スペース削除 Functoid 文字列右スペース削除

テキスト項目から末尾のスペースを削除します。

 この Functoid には 1 個の入力パラメータが必要です。
大文字変換 Functoid 大文字変換

テキスト項目を大文字に変換します。

 この Functoid には 1 個の入力パラメータが必要です。


数値演算を行う Functoid

Functoid | パラメータ
絶対値算出 Functoid 絶対値算出 数値の絶対値を返します。 | この Functoid には 1 個の入力パラメータが必要です。実際の入力値に関係なく、最終値は常に正です。
整数部抽出 Functoid 整数部抽出 数値の整数部を返します。 | この Functoid には 1 個の入力パラメータが必要です。この Functoid は、数値の小数点以下を切り捨てます。
最大値算出 Functoid 最大値算出 一連の数値の中で最大値を返します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
最小値算出 Functoid 最小値算出 一連の数値の中で最小値を返します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
剰余 Functoid 剰余 整数で数値を除算した後の剰余を返します。 | この Functoid には 2 個の入力パラメータが必要です。この Functoid は、整数除算の剰余を返します。この Functoid は、出荷数量などについて、規定積載量に満たない値を計算するときに役に立ちます。
四捨五入 Functoid 四捨五入 指定された小数点以下の桁数に数値を四捨五入します。小数点以下の桁数が指定されない場合は、整数に四捨五入します。 | この Functoid には 2 個の入力パラメータが必要です。この Functoid にリンクしている 1 番目のパラメータは値を表し、2 番目のパラメータは四捨五入する小数点以下の桁数を表します。この Functoid は、標準の計算規則に基づいて、四捨五入を行います。
平方根算出 Functoid 平方根算出 数値の平方根を返します。 | この Functoid には 1 個の入力パラメータが必要です。
加算 Functoid 加算 一連の数値の合計を計算します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。
減算 Functoid 減算 1 つの数値をほかの数値から引き算します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
乗算 Functoid 乗算 1 つの数値をほかの数値で乗算します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
除算 Functoid 除算 1 つの数値をほかの数値で除算します。 | この Functoid には 2 個の入力パラメータが必要です。この Functoid は、実数や整数に使用できます。


論理演算を行う Functoid

Functoid | パラメータ
より大きい Functoid より大きい 1 つ目のパラメータが 2 つ目のパラメータより大きいときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
以上 Functoid 以上 1 つ目のパラメータが 2 つ目のパラメータ以上のときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
より小さい Functoid より小さい 1 つ目のパラメータが 2 つ目のパラメータより小さいときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
以下 Functoid 以下 1 つ目のパラメータが 2 つ目のパラメータ以下のときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
等号 Functoid 等号 1 つ目のパラメータが 2 つ目のパラメータと等しいときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
不等号 Functoid 不等号 1 つ目のパラメータが 2 つ目のパラメータと等しくないときに TRUE を返します。 | この Functoid には 2 個の入力パラメータが必要です。
文字列検査 Functoid 文字列検査 パラメータが文字列値のときに TRUE を返します。 | この Functoid には 1 個の入力パラメータが必要です。
日付検査 Functoid 日付検査 パラメータが日付値のときに TRUE を返します。 | この Functoid には 1 個の入力パラメータが必要です。
数値検査 Functoid 数値検査 パラメータが数値のときに TRUE を返します。 | この Functoid には 1 個の入力パラメータが必要です。
論理和 Functoid 論理和 パラメータの論理和を返します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
論理積 Functoid 論理積 パラメータの論理積を返します。 | この Functoid には少なくとも 1 個の入力パラメータが必要です。入力パラメータの最大数には制限はありません。
論理的な実体 Functoid 論理的な実体 入力レコードまたはフィールドが送信元のドキュメントに存在する場合、TRUE を返します。 | この Functoid が持つことのできる入力パラメータは 1 個のみです。


日時処理を行う Functoid

Functoid | パラメータ
日数加算 Functoid 日数加算 指定した日数を日付に加えます。 | この Functoid には 2 個の入力パラメータが必要です。1 番目のリンクには、入力値として日付情報が必要です。2 番目のリンクで、日付に加える日数を決定します。
日付 Functoid 日付 現在の日付を返します。 | この Functoid には入力パラメータは必要ありません。出力書式は YYYY-MM-DD です。
時刻 Functoid 時刻 現在の時刻を返します。 | この Functoid には入力パラメータは必要ありません。出力書式は HH:MM:SS です。
日時 Functoid 日時 現在の日付と時刻を返します。 | この Functoid には入力パラメータは必要ありません。出力書式は YYYY-MM-DDTHH:MM:SS です。


変換を行う Functoid

Functoid | パラメータ
文字の ASCII 値算出 Functoid 文字の ASCII 値算出 文字の ASCII コード値を返します。 | この Functoid には 1 個の入力パラメータが必要です。この Functoid は、基本 ASCII コード値に変換します。 例 : a=97
値の ASCII 文字化 Functoid 値の ASCII 文字化 指定した ASCII コード値に対応する文字を返します。 | この Functoid には 1 個の入力パラメータが必要です。この Functoid は、値を ASCII コード値に対応する文字に変換します。 例 : 98=b
16 進変換 Functoid 16 進変換 10 進数の値を 16 進数にして返します。 | この Functoid には 1 個の入力パラメータが必要です。この Functoid は 10 進数を 16 進数に変換します。 例 : 10=A
8 進変換 Functoid 8 進変換 10 進数の値を 8 進数にして返します。 | この Functoid には 1 個の入力パラメータが必要です。この Functoid は、10 進数を 8 進数に変換します。 例 : (8 進数 0-7)、8=10、および 10=12


関数演算を行う Functoid

Functoid | パラメータ
アーク タンジェント Functoid アーク タンジェント 数値のアーク タンジェントを返します。 | この Functoid には 1 個の入力パラメータが必要です。入力値の単位はラジアンである必要があります。
コサイン Functoid コサイン 数値のコサインを返します。 | この Functoid には 1 個の入力パラメータが必要です。入力値の単位はラジアンである必要があります。
サイン Functoid サイン 数値のサインを返します。 | この Functoid には 1 個の入力パラメータが必要です。入力値の単位はラジアンである必要があります。
タンジェント Functoid タンジェント 数値のタンジェントを返します。 | この Functoid には 1 個の入力パラメータが必要です。入力値の単位はラジアンである必要があります。
自然指数関数 Functoid 自然指数関数 e を指定した回数だけべき乗して返します。 | この Functoid には 1 個の入力パラメータが必要です。
自然対数 Functoid 自然対数 値の対数 (底 e) を返します。 | この Functoid には 1 個の入力パラメータが必要です。
10^X 10 を指定した回数だけべき乗して返します。 | この Functoid には 1 個の入力パラメータが必要です。
常用対数 Functoid 常用対数 値の対数 (底 10) を返します。 | この Functoid には 1 個の入力パラメータが必要です。
X^Y 値を指定した回数だけべき乗して返します。 | この Functoid には 2 個の入力パラメータが必要です。
底指定対数 Functoid 底指定対数 値の対数 (指定した底) を返します。 | この Functoid には 2 個の入力パラメータが必要です。


累積演算を行う Functoid

Functoid パラメータ
累積合計 Functoid 累積合計

親レコードを反復することで、接続されているフィールドのすべての値を合計します。

 この Functoid には 2 個の入力パラメータが必要です。2 番目のパラメータは、送信元ノードからの階層レベル (コンパイラ リンクを基準に) を指定します。このパラメータは、0 より大きく、ルート ノードからのノードの深さより小さい整数である必要があります。

注

  • この Functoid は、1 つの入力パラメータのみを要求する Microsoft BizTalk Server 2000 との下位互換性があります。

累積演算を行う Functoid の詳細および例については、「累積演算を行う Functoid の使用」を参照してください。
累積平均 Functoid 累積平均

親レコードを反復することで、接続されているフィールドのすべての値の平均値を計算します。

 この Functoid には 2 個の入力パラメータが必要です。2 番目のパラメータは、送信元ノードからの階層レベル (コンパイラ リンクを基準に) を指定します。このパラメータは、0 より大きく、ルート ノードからのノードの深さより小さい整数である必要があります。

注

  • この Functoid は、1 つの入力パラメータのみを要求する BizTalk Server 2000 との下位互換性があります。

累積演算を行う Functoid の詳細および例については、「累積演算を行う Functoid の使用」を参照してください。
累積最小値 Functoid 累積最小値

親レコードにまたがる入力の最小値を返します。

 この Functoid には 2 個の入力パラメータが必要です。2 番目のパラメータは、送信元ノードからの階層レベル (コンパイラ リンクを基準に) を指定します。このパラメータは、0 より大きく、ルート ノードからのノードの深さより小さい整数である必要があります。

注

  • この Functoid は、1 つの入力パラメータのみを要求する BizTalk Server 2000 との下位互換性があります。

累積演算を行う Functoid の詳細および例については、「累積演算を行う Functoid の使用」を参照してください。
Cumulative String functoid◆累積最大値 Functoid 累積最大値

親レコードにまたがる入力の最大値を返します。

 この Functoid には 2 個の入力パラメータが必要です。2 番目のパラメータは、送信元ノードからの階層レベル (コンパイラ リンクを基準に) を指定します。このパラメータは、0 より大きく、ルート ノードからのノードの深さより小さい整数である必要があります。

注

  • この Functoid は、1 つの入力パラメータのみを要求する BizTalk Server 2000 との下位互換性があります。

累積演算を行う Functoid の詳細および例については、「累積演算を行う Functoid の使用」を参照してください。
累積文字列 Functoid 累積文字列

親レコードを反復することで、接続されているフィールドの文字列値を結合した文字列を返します。

 この Functoid には 2 個の入力パラメータが必要です。2 番目のパラメータは、送信元ノードからの階層レベル (コンパイラ リンクを基準に) を指定します。このパラメータは、0 より大きく、ルート ノードからのノードの深さより小さい整数である必要があります。

注

  • この Functoid は、1 つの入力パラメータのみを要求する BizTalk Server 2000 との下位互換性があります。

累積演算を行う Functoid の詳細および例については、「累積演算を行う Functoid の使用」を参照してください。


データベース操作を行う Functoid

Functoid | パラメータ
データベース検索 Functoid データベース検索 指定された値を求めてデータベース検索を実行し、その値を含むレコードを取得して Microsoft ActiveX® Data Objects (ADO) レコード セットとして格納します。 | この Functoid には 4 個の入力パラメータが必要です。
値抽出 Functoid 値抽出 データベース検索 Functoid により取得された ADO レコード セットの特定の列から値を返します。 | この Functoid には 2 個の入力パラメータが必要です。
エラー通知 Functoid エラー通知 データベース検索 Functoid を使用したときに Open Database Connectivity (ODBC) から返されたエラー文字列を返します。 | この Functoid には 1 個の入力パラメータが必要です。


高度 Functoid

Functoid | パラメータ
スクリプト Functoid スクリプト カスタム Microsoft® Visual Basic® Scripting Edition (VBScript) またはカスタム Microsoft JScript® を返します。 | この Functoid に対する入力パラメータ数は、カスタム スクリプトを記述することで構成可能です。
レコード カウント Functoid レコード カウント インスタンス内で発見されたレコードの総数を返します。 | この Functoid には 1 個の入力パラメータが必要です。
インデックス Functoid インデックス 指定したインデックスにある、レコードまたはフィールドの値を返します。 | この Functoid には少なくとも 2 個の入力パラメータが必要です。入力パラメータの最大数は、仕様階層におけるレベルの個数によって制限されます。
繰り返し Functoid 繰り返し ソース レコードの (ループ内の) 繰り返し回数を返します。 | この Functoid には 1 個の入力パラメータが必要です。
値のマッピング Functoid 値のマッピング 1 つ目のパラメータの値が true のとき、2 つ目のパラメータの値を返します。 | この Functoid には 2 個の入力パラメータが必要です。
値のマッピング (フラット化) Functoid 値のマッピング (フラット化) 1 つ目のパラメータの値が true のときに 2 つ目のパラメータの値を返し、送信元のドキュメント階層をフラット化します。 | この Functoid には 2 個の入力パラメータが必要です。
ループ Functoid ループ 各入力レコードを反復することで、複数の出力レコードを作成します。 | この Functoid には入力パラメータが少なくとも 1 個必要です。入力パラメータの最大数には制限がありません。


Functoid プロパティの編集

  • [Functoid プロパティ] ダイアログ ボックスを表示するには、マッピング グリッドの Functoid を右クリックし、[プロパティ] をクリックします。

    または

    Functoid をダブルクリックして表示することもできます。

注

  • [全般] タブに、入力パラメータについての情報が表示されます。[スクリプト] タブに、スクリプトの内容が表示されます。

このダイアログ ボックスの使用方法については、次のトピックを参照してください。

  • 入力パラメータ

  • Functoid スクリプト


入力パラメータ

[Functoid プロパティ] ダイアログ ボックスを開く方法については、「Functoid プロパティの編集」を参照してください。

ほとんどの Functoid の入力パラメータは、[Functoid プロパティ] ダイアログ ボックスの [全般] タブで追加、削除、および上下に移動することができます。

ここには次のトピックが含まれます。

  • 入力パラメータの挿入

  • 入力パラメータの削除

  • 入力パラメータの移動

  • 入力パラメータの名前の変更

注

  • 一部の Functoid では、指定できるパラメータ数に制限があります。特定の Functoid に対して指定できるパラメータの数は、その Functoid の [Functoid プロパティ] ダイアログ ボックスの [全般] タブにある [入力パラメータ] ボックスの下に表示されます。


入力パラメータの挿入

  1. マッピング グリッドの Functoid をダブルクリックします。

    [Functoid プロパティ] ダイアログ ボックスが表示されます。

  2. [全般] タブの [新しいパラメータの挿入] ボタン [新しいパラメータの挿入] ボタン をクリックし、新しいパラメータの情報を入力して Enter キーを押します。

    注

    • [新しいパラメータの挿入] ボタンが利用できない場合、その Functoid は入力パラメータを受け付けないか、必要としない Functoid です。

    • 新しいパラメータ情報は、[スクリプト] タブに反映されます。
  3. 追加のパラメータが必要な場合は、手順 2. を繰り返します。

  4. [OK] をクリックします。

重要

  • [スクリプト] タブをクリックし、手動で入力パラメータを変更した場合、追加の入力パラメータは [スクリプト] タブには反映されず、実行時に実行されません。

  • 入力パラメータの定数値では、二重引用符を使用することはできません。

関連項目

入力パラメータの削除

入力パラメータの移動

入力パラメータの名前の変更

Functoid スクリプト


入力パラメータの削除

  1. マッピング グリッドの Functoid をダブルクリックします。

  2. [全般] タブの [入力パラメータ] ボックスで、削除する入力パラメータをクリックします。

  3. [選択したパラメータの削除] ボタン [image] をクリックし、[OK] をクリックします。

関連項目

入力パラメータの挿入

入力パラメータの移動

入力パラメータの名前の変更


入力パラメータの移動

  1. マッピング グリッドの Functoid をダブルクリックします。

  2. [全般] タブの [入力パラメータ] エリアで、移動する入力パラメータをクリックします。

  3. パラメータを上へ移動するには [選択したパラメータを上へ移動] ボタン [image] をクリックします。パラメータを下へ移動するには [選択したパラメータを下へ移動] ボタン [選択したパラメータを下へ移動] ボタン をクリックします。移動し終わったら [OK] をクリックします。

関連項目

入力パラメータの削除

入力パラメータの挿入

入力パラメータの名前の変更


入力パラメータの名前の変更

  1. マッピング グリッドの Functoid をダブルクリックします。

  2. [全般] タブの [入力パラメータ] ボックスで、名前を変更する入力パラメータを右クリックし、[値の変更] をクリックします。

  3. パラメータの新しい名前を入力し、[OK] をクリックします。

関連項目

入力パラメータの削除

入力パラメータの挿入

入力パラメータの移動


Functoid スクリプト

[Functoid プロパティ] ダイアログ ボックスを開く方法については、「Functoid プロパティの編集」を参照してください。

[Functoid プロパティ] ダイアログ ボックスの [スクリプト] タブで、スクリプトの内容を表示し、編集することができます。

注

  • どのFunctoid のスクリプトでも表示できますが、編集できるのはスクリプト Functoid のスクリプトのみです。

関連項目

入力パラメータ


リンクの管理

ここには次のトピックが含まれます。

  • フィールド間のリンクの作成

  • フィールドと Functoid の間のリンクの作成

  • レコードとフィールドの間のリンクの作成

  • レコードと Functoid の間のリンクの作成

  • Functoid 間のリンクの作成

  • レコード コンテンツのリンクの許可

  • リンクのリダイレクト

  • リンクの削除


フィールド間のリンクの作成

  • 送信元仕様ツリーにあるフィールドを、送信先仕様ツリーのフィールドにドラッグします。

重要

  • 送信元仕様ツリーのフィールドのデータ型は、リンク先となる送信先仕様ツリーのフィールドのデータ型と一致している必要があります。

  • BizTalk マッパーは、XSLT を生成する前に、送信元および送信先からのダイレクト リンクの属性または要素があるかどうか調べます。そのため、送信元フィールドが (オプションであるため) インスタンス ドキュメントに表示されない場合は、空白の送信先フィールドが作成されます。これは受け入れられない動作です。なぜなら、送信元フィールドが存在する場合だけ、送信先フィールドが作成される必要があるからです。この問題を解決するには、リンクされたフィールドが送信元スキーマの中でオプションであるかどうか調べます。オプションである場合、BizTalk Server は <xsl:if> 句を生成し、送信先フィールドを作成する前に送信元フィールドがあるかどうか調べます。これによって、送信元インスタンスに送信元フィールドがない場合に送信先フィールドが作成されないようにします。送信元インスタンスが送信元フィールドを含んでいる場合、送信先フィールドが通常通りに作成されます。

注

  • 送信先仕様の定数値を持つノードには、リンクできません。

  • 送信先仕様の既定値を持つ必須フィールドには、リンクできません。必須フィールドの作成については、「参照のプロパティの設定」を参照してください。フィールドの既定値の設定については、「宣言のプロパティの設定」を参照してください。

  • マップするフィールドを表示するために、仕様ツリーを展開しなければならないことがあります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

定数値の追加

表示の管理

宣言のプロパティの設定

参照のプロパティの設定

データ型とデータ型値の概要


フィールドと Functoid の間のリンクの作成

  • 送信元仕様ツリーまたは送信先仕様ツリーにあるフィールドを、マッピング グリッドの Functoid にドラッグします。

    または

    マッピング グリッドにある Functoid を、送信元仕様ツリーまたは送信先仕様ツリーのフィールドにドラッグします。

重要

  • 送信先仕様ツリーのフィールドに特定のデータ型プロパティを指定した場合は、そのフィールドを、ほかのデータ型で出力を行う Functoid にリンクすることはできません。

注

  • フィールドから Functoid へのリンクを設定する場合は、あらかじめマッピング グリッドに Functoid を配置しておく必要があります。マッピング グリッドへの Functoid の追加の詳細については、「Functoid の操作」を参照してください。

  • 送信先仕様の定数値を持つノードには、リンクできません。

  • 送信先仕様の既定値を持つ必須フィールドには、リンクできません。必須フィールドの作成については、「参照のプロパティの設定」を参照してください。フィールドの既定値の設定については、「宣言のプロパティの設定」を参照してください。

関連項目

定数値の追加

表示の管理

宣言のプロパティの設定

参照のプロパティの設定

Functoid の操作


レコードとフィールドの間のリンクの作成

  1. [ツール] メニューの [オプション] をクリックします。

  2. [BizTalk マッパーのオプション] ダイアログ ボックスで、[レコード コンテンツのリンクを許可] チェック ボックスをオンにして、[OK] をクリックします。

  3. 送信元仕様ツリーにあるレコードを、送信先仕様ツリーのフィールドにドラッグします。

    または

    送信先仕様ツリーにあるレコードを、送信元仕様ツリーのフィールドにドラッグします。

注

  • 送信先仕様の定数値を持つノードには、リンクできません。

  • 送信先仕様の既定値を持つ必須フィールドには、リンクできません。必須フィールドの作成については、「参照のプロパティの設定」を参照してください。フィールドの既定値の設定については、「宣言のプロパティの設定」を参照してください。

  • 仕様ツリーを展開し、マップするレコードまたはフィールドを参照する必要がある場合があります。詳細については、「ツリー項目の展開」を参照してください。

関連項目

定数値の追加

表示の管理

宣言のプロパティの設定

参照のプロパティの設定


レコードと Functoid の間のリンクの作成

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [レコード コンテンツのリンクを許可] チェック ボックスをオンにし、[OK] をクリックします。

  3. 送信元仕様ツリーまたは送信先仕様ツリーにあるレコードを、マッピング グリッドの Functoid にドラッグします。

    または

    マッピング グリッドにある Functoid を、送信元仕様ツリーまたは送信先仕様ツリーのレコードにドラッグします。

注

  • レコードから Functoid へのリンクを設定する場合は、あらかじめマッピング グリッドに Functoid を配置しておく必要があります。

  • 送信先仕様の定数値を持つノードには、リンクできません。送信先定数値の詳細については、「BizTalk マッパーのユーザー インターフェイス」を参照してください。

関連項目

定数値の追加

表示の管理


Functoid 間のリンクの作成

  • Functoid をマッピング グリッドの別の Functoid にドラッグします。

注

  • リンクは、マッピング グリッドで左から右に処理されます。ある Functoid から、その真上または真下にある別の Functoid へのリンクを作成することはできません。

関連項目

フィールドと Functoid の間のリンクの作成

レコードと Functoid の間のリンクの作成


レコード コンテンツのリンクの許可

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [レコード コンテンツのリンクを許可] チェック ボックスをオンにし、[OK] をクリックします。

  3. 送信元仕様ツリーにあるレコードを、送信先仕様ツリーのレコードにドラッグします。


リンクのリダイレクト

  1. マッピング グリッドで、リンクをクリックして強調表示します。

    リンクのエンドポイントが小さな青色四角形になり、強調表示されます。

  2. エンドポイントのどちらかを、Functoid にドラッグするか、ノードを接続したい所へドラッグします。

    エンドポイントをドラッグすると、ポインタが十字形になります。リンクを作成できないオブジェクトへドラッグすると、ポインタは斜線の描かれた円になります。

重要

  • 2 つ以上の送信元リンクが Functoid に接続されている場合に、それらの送信元リンクを送信元仕様ツリーの別のノードに 1 つ以上リダイレクトすると、Functoid の入力パラメータの順序は維持されません。Functoid をダブルクリックして入力パラメータを表示し、パラメータの順序が正しいことを確認します。


リンクの削除

  1. 削除するリンクを右クリックし、[削除] をクリックします。

  2. 確認ダイアログ ボックスで [はい] をクリックします。


グリッドでのリンクと Functoid の表示

ここには次のトピックが含まれます。

  • マッピング グリッドでのリンクと Functoid の表示

  • グリッドのプレビューを利用したリンクと Functoid の表示


マッピング グリッドでのリンクと Functoid の表示

  1. マッピング グリッド上で、スクロールする方向の端にカーソルを移動します。

    カーソルが、ポインタまたはパイプ (|) から大きな矢印に変わります。

  2. 矢印の方向にスクロールするには、左マウス ボタンをクリックしたまま離さないようにします。

注

  • 上下左右 4 方向のいずれかにスクロールする場合は、マッピング グリッドの背景をクリックし、矢印キーを押してスクロールすることもできます。

関連項目

BizTalk マッパーのユーザー インターフェイス

グリッドのプレビューを利用したリンクと Functoid の表示


グリッドのプレビューを利用したリンクと Functoid の表示

  1. [表示] メニューの [グリッドのプレビュー] をクリックします。

    [グリッドのプレビュー] ダイアログ ボックスが開き、マッピング グリッド上の Functoid の配置を示す図が表示されます。

  2. ロケータ バーを [グリッドのプレビュー] ダイアログ ボックスの新しい位置にドラッグします。

    緑色のロケータ バーを移動すると、マッピング グリッドの中のリンクと Functoid も移動します。

注

  • グリッドのプレビューは、マッピング グリッドを広く使って多くの Functoid を配置した場合に、マッピング グリッド内を移動するときに便利です。

関連項目

BizTalk マッパーのユーザー インターフェイス

マッピング グリッドでのリンクと Functoid の表示


リンク プロパティの編集

  • [リンク プロパティ] ダイアログ ボックスを表示するには、マッピング グリッドにあるリンクを右クリックし、[プロパティ] をクリックします。

    [全般] タブが表示されます。

このダイアログ ボックスの使用方法については、次のトピックを参照してください。

  • リンク プロパティの表示 : [全般] タブ

  • リンク プロパティの表示 : [コンパイラ] タブ

注

  • プロパティは、リンクをダブルクリックして表示することもできます。

関連項目

マップのコンパイル

リンクの管理


リンク プロパティの表示 : [全般] タブ

[リンク プロパティ] ダイアログ ボックスを開く方法については、「リンク プロパティの編集」を参照してください。

[全般] タブには、リンクの送信元と送信先に関する情報が表示されます。[送信元] ボックスには、リンクの送信元がレコード、フィールド、または Functoid のいずれであるかによって、リンク送信元のレコード パス、フィールド パス、または Functoid 名が表示されます。[送信先] ボックスには、リンクの送信先がレコード、フィールド、または Functoid のいずれであるによって、リンク送信先のレコード パス、フィールド パス、または Functoid 名が表示されます。

関連項目

リンク プロパティの表示 : [コンパイラ] タブ


リンク プロパティの表示 : [コンパイラ] タブ

[リンク プロパティ] ダイアログ ボックスを開く方法については、「リンク プロパティの編集」を参照してください。

[コンパイラ] タブは、送信元仕様リンクおよび送信先仕様リンクのコンパイラのプロパティを設定するためのタブです。これらの設定の変更については、次のトピックを参照してださい。

  • 送信元仕様リンクのコンパイラ プロパティの選択

  • 送信先仕様リンクのコンパイラ プロパティの選択

関連項目

リンク プロパティの表示 : [全般] タブ


送信元仕様リンクのコンパイラ プロパティの選択

  1. 送信元仕様ツリーのノードに接続されているマッピング グリッドのリンクを右クリックし、[プロパティ] をクリックします。

    [リンク プロパティ] ダイアログ ボックスが表示されます。

  2. [コンパイラ] タブをクリックし、[送信元仕様リンク] ボックスにある次のオプションのいずれか 1 つをクリックします。
    • [値のコピー (既定)] : 受信ドキュメント インスタンスのノードの値をコピーします。たとえば、<Node>Hello<Name>Chris</Name>Cannon</Node> は "Hello." に変換されます。

    • [テキストとサブコンテンツの値をコピー] : 受信ドキュメント インスタンスの中のノードの値とその子孫のすべての値を連結した値をコピーします。たとえば、<Node>Hello<Name>Chris</Name>Cannon</Node> は "Hello Chris Cannon." に変換されます。

    • [名前のコピー] : 受信ドキュメント インスタンスのノードの名前をコピーします。
  3. [OK] をクリックします。

重要

  • データに子要素が点在しているなどの、混在したコンテンツが要素に含まれている場合に、[値のコピー (既定)] を選択すると、コピーされるコンテンツは最初の子要素よりも上部のコンテンツだけになります。例 :
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    結果は、Item がコピーされます。

  • データに子要素が点在しているなどの、混在したコンテントが要素に含まれている場合、[テキストとサブコンテンツの値をコピー] を選択します。これによって子要素を含むすべてのコンテンツがコピーされます。例 :
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    結果は、Item1121314Number がコピーされます。

関連項目

送信先仕様リンクのコンパイラ プロパティの選択


送信先仕様リンクのコンパイラ プロパティの選択

  1. 送信先仕様のノードに接続されているマッピング グリッドのリンクを右クリックし、[プロパティ] をクリックします。

  2. [コンパイラ] タブをクリックし、[送信先仕様リンク] ボックスにある次のオプションのいずれか 1 つをクリックします。
    • [リンクをフラット化 (既定)] : このモードでは、すべての送信元階層が送信先ノードの親に対応するようにフラット化されます。

    • [リンクを上から順に一致] : このモードでは、レベルとレベルが上から順に対応付けられます。

    • [リンクを下から順に一致] : このモードでは、レベルとレベルが下から順に対応付けられます。
  3. [OK] をクリックします。

注

  • 送信元仕様ツリーのフィールドと送信先仕様ツリーのフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、1 つの [リンクをフラット化 (既定)] と、1 つの [リンクを上から順に一致] と、1 つの [リンクを下から順に一致] を使用すると、BizTalk マッパーは、すべてのリンクに、[リンクをフラット化 (既定)] が指定されたように扱います。

  • 送信元仕様ツリーのフィールドと送信先仕様ツリーのフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、1 つ以上の [リンクをフラット化 (既定)] と 1 つの [リンクを上から順に一致] を使用すると、BizTalk マッパーは、すべてのリンクに、[リンクを上から順に一致] が指定されたように扱います。

  • 送信元仕様ツリーのフィールドと送信先仕様ツリーのフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、1 つ以上の [リンクをフラット化 (既定)] と 1 つの [リンクを下から順に一致] を使用すると、BizTalk マッパーは、すべてのリンクに、[リンクを下から順に一致] が指定されたように扱います。

  • 送信元仕様ツリーのフィールドと送信先仕様ツリーのフィールドが同じ親レコードを共有している場合、それらのフィールド間のリンクに対し、1 つ以上の [リンクを上から順に一致] と 1 つ以上の [リンクを下から順に一致] を使用すると、BizTalk マッパーは、すべてのリンクに、[リンクをフラット化 (既定)] が指定されたように扱います。

関連項目

ノードと階層レベルの対応

送信元仕様リンクのコンパイラ プロパティの選択


コンパイル済みマップの作成および管理

ここには次のトピックが含まれます。

  • マップのコンパイル

  • マップのコンパイル後の警告とエラーの解決

  • 定数値の追加


マップのコンパイル

  • [ツール] メニューの [マップのコンパイル] をクリックします。

注意

  • 適切な結果が得られないような設定をコンパイラが検出した場合は、[警告] タブに警告が表示されます。本番運用環境で使用できるマップを準備する場合は、警告が表示されなくなるまで修正してください。

注

  • 警告が表示された場合、問題は複数のグリッド ページにわたって存在する場合があります。たとえば、グリッド ページ 1 の送信元仕様ツリーの中のレコード (レコード名 Item) が送信先仕様ツリーの中のレコード (レコード名 Number) にリンクされていて、グリッド ページ 2 の送信元ツリーの中のレコード (レコード名 Product) が送信先仕様ツリーの中の同じ Number レコードにリンクされている場合、同一のレコードに複数の入力があることを知らせる警告メッセージが生成されます。しかし、グリッド ページ 1 を表示した場合は、Number レコードの中には 1 つの入力だけが表示されます。

関連項目

マップのコンパイル後の警告とエラーの解決


マップのコンパイル後の警告とエラーの解決

警告が表示された場合、問題は複数のグリッド ページにわたって存在する場合があります。たとえば、グリッド ページ 1 の送信元仕様ツリーの中のレコード (レコード名 Item) が送信先仕様ツリーの中のレコード (レコード名 Number) にリンクされていて、グリッド ページ 2 の送信元ツリーの中のレコード (レコード名 Product) が送信先仕様ツリーの中の同じ Number レコードにリンクされている場合、同一のレコードに複数の入力があることを知らせる警告メッセージが生成されます。しかし、グリッド ページ 1 を表示した場合は、Number レコードの中には 1 つの入力だけが表示されます。

  1. [警告] タブの警告をダブルクリックします。

    警告またはエラーに関連したリンク、Functoid、またはノードが、マッピング グリッドで強調表示されます。

  2. 必要に応じて、リンク、Functoid、またはノードを修正します。

  3. 警告ごとに、手順 1. と 2. を繰り返します。

  4. [ツール] メニューの [マップのコンパイル] をクリックします。

関連項目

マップのコンパイル


定数値の追加

  1. 送信先仕様ツリーのレコードまたはフィールドをクリックし、[値] タブをクリックします。

  2. [送信先定数値] ボックスに、レコードまたはフィールドと関連付ける値を入力します。

注

  • 定数値が関連付けられているレコードまたはフィールドへは、リンクを作成できません。

  • 定数値を関連付けることができるのは、"コンテンツ" プロパティが "テキストのみ" または "混合" に設定されているレコードだけです。"コンテンツ" プロパティの詳細については、「宣言のプロパティの設定」を参照してください。

関連項目

宣言のプロパティの設定


マップ テストの実行

ここには次のトピックが含まれます。

  • リンクのあるレコードまたはフィールドのプロパティのテスト

  • マップのテスト


リンクのあるレコードまたはフィールドのプロパティのテスト

重要

  • テストを行う前に、常にマップをコンパイルすると、警告やエラーを解決することができます。詳細については、「マップのコンパイル」を参照してください。
  1. リンクで接続されている送信元仕様ツリーのフィールドをクリックします。

  2. [値] タブをクリックします。

  3. [送信元テスト値] ボックスに値を入力します。

  4. [ツール メニュー] の[マップのテスト] をポイントし、使用するオプションをクリックします。

    重要

    • テストを開始する前に、ファイルの保存を求めるメッセージが表示されます。マップに問題が発生したときに備えて、テストを行う前にファイルを保存しておきます。
  5. [はい] をクリックし、マップを保存します。

  6. [出力] タブの結果を確認します。

注

  • レコードの "最大発生数" プロパティがアスタリスク (*) の場合は、ループ レコードであることを示します。マップをテストするために BizTalk マッパーが生成する受信ドキュメント インスタンスには、レコードが 2 件発生します。

関連項目

マップのコンパイル

マップのテスト


マップのテスト

重要

  • テストを行う前に、常にマップをコンパイルすると、警告やエラーを解決することができます。詳細については、「マップのコンパイル」を参照してください。

  • マップのテストの前にコンテンツを検証する場合、以下の手順を実行します。
    1. [ツール] メニューの [オプション] をクリックします。

      [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

    2. [全般] タブで、[マップのテスト前にコンテンツを検証] を選択し、[OK] をクリックします。

    注

    • マップで使用している仕様のどれかが BizTalk ベース以外の仕様である場合 (たとえば、XML-Data Reduced (XDR) ファイルである場合)、コンテンツ検証機能を使用すると検証は失敗します。XDR ファイルを開いた時に警告 (とくに名前空間または要素グループ関連の警告) が表示された場合、コンテンツ検証機能を使用してはいけません。
  • マップのテストの後にコンテンツを検証する場合、以下の手順を実行します。
    1. [ツール] メニューの [オプション] をクリックします。

      [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

    2. [全般] タブで、[マップのテスト後にコンテンツを検証] を選択し、[OK] をクリックします。

    注

    • マップで使用している仕様のどれかが BizTalk ベース以外の仕様である場合 (たとえば、XML-Data Reduced (XDR) ファイルである場合)、コンテンツ検証機能を使用すると検証は失敗します。XDR ファイルを開いた時に警告 (とくに名前空間または要素グループ関連の警告) が表示された場合、コンテンツ検証機能を使用してはいけません。
  1. [ツール メニュー] の[マップのテスト] をポイントし、使用するオプションをクリックします。

    重要

    • テストを開始する前に、ファイルの保存を求めるメッセージが表示されます。マップに問題が発生したときに備えて、テストを行う前にファイルを保存しておきます。
  2. [はい] をクリックし、マップを保存します。

  3. コンパイル処理中に警告が生成された場合、メッセージ ボックスが表示されます。[はい] をクリックし、作業を続行してください。

  4. [生成された XML からネイティブ] を選択し、出力スキーマが EDI ベースの構造である場合、[ドキュメントの区切り記号] ダイアログ ボックスで区切り記号を指定する必要があります。区切り記号の指定の詳細については、「BizTalk マッパーのオプション : [ドキュメントの区切り記号] タブ」を参照してください。.

    または

    [インスタンス XML から XML] または [インスタンス XML からネイティブ] を選択した場合、[インスタンス XML ファイルの読み込み] ダイアログ ボックスが表示されます。インスタンス ファイルを参照し、[開く] をクリックします。

    または

    [ネイティブ インスタンスから XML] または [ネイティブ インスタンスからネイティブ] を選択した場合、[ネイティブ インスタンス ファイルの読み込み] ダイアログ ボックスが表示されます。インスタンス ファイルを参照し、[開く] をクリックします。

    注

    • 出力スキーマが XML である場合は、[生成された XML からネイティブ] および [インスタンス XML からネイティブ] オプションは利用できません。

    • 入力または出力スキーマが XML である場合は、[ネイティブ インスタンスからネイティブ] オプションは利用できません。

    • EDI インターチェンジに複数のドキュメントが含まれている場合は、マップのテストでは最初のドキュメントだけが使用されます。

    • [インスタンス テスト時に区切り記号を要求] ボックスがオンになっていて、テストしているインスタンスがエンベロープ情報を持つ EDI ファイルである場合、[ドキュメントの区切り記号] ダイアログ ボックスは表示されません。なぜならば、BizTalk マッパーは必要な区切り記号を自動的に検出するからです。インスタンス テスト時に [インスタンス テスト時に区切り記号を要求] ボックスを表示するように設定している場合でも、BizTalk マッパーは使用する区切り記号を判断することができない場合にだけこのボックスを表示します。
  5. [出力] タブの結果を確認します。

重要

  • まれに、BizTalk マッパーが 1 回の変換でデータをマップできない場合があります。しかし、Biztalk Server には、ポート構成の中のプライマリ トランスポートとして SubmitSync および LoopBack を使用する 2 つの繰り返しによってドキュメントを 2 回、同時にマップする機能があります。そのため、種々のチャネルを再利用し組み合わせることによって、マッピングをさまざまな段階に分割することができます。詳細については、\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples にあるサンプル フォルダ Mapping Twice を参照してください。

  • 文字範囲は無視されます。そのため、マップに文字制限が適用されていて、それらの制限が満たされていない場合でも、マップのテストが成功したとみなされます。しかし、BizTalk Server がトランザクションを解析しようとすると失敗します。

  • ネイティブ インスタンスを正常に作成できた場合でも、構文規則を満たしていないと、インスタンス検証で失敗します。

関連項目

マップのコンパイル

マップのテスト

Copyright © 1999-2001 Microsoft Corporation.
All rights reserved.

このトピックは役立ちましたか。ドキュメントやサンプル、製品全般に関するご意見、ご要望についてはこちらにお送りください。BizTalk Server に関するマイクロソフトへのフィードバック


表示の管理

ここには次のトピックが含まれます。

  • ツリー項目の展開

  • ツリー項目の折りたたみ

  • レコード プロパティとフィールド プロパティの表示

  • 送信元仕様ツリー ペインのサイズ調整

  • 送信先仕様ツリー ペインのサイズ調整

  • 下部ウィンドウのサイズ調整


ツリー項目の展開

  • 展開するルート ノードまたは仕様ツリーのレコードをクリックし、[表示] メニューの [ツリー項目の展開] をクリックします。

    または

    ルート ノードまたはツリーのレコードを右クリックし、[ツリー項目の展開] をクリックします。

関連項目

ツリー項目の折りたたみ


ツリー項目の折りたたみ

  • 折りたたむルート ノードまたは仕様ツリーのレコードをクリックし、[表示] メニューの [ツリー項目の折りたたみ] をクリックします。

注

  • ツリー項目の折りたたみは、ルート ノードまたはツリーのレコードを右クリックし、[ツリー項目の折りたたみ] をクリックしても実行できます。

関連項目

ツリー項目の展開


レコード プロパティとフィールド プロパティの表示

  • 送信元仕様ツリーまたは送信先仕様ツリーのレコードまたはフィールドをクリックし、[表示] メニューの [プロパティ] をクリックします。

    または

    どちらかのツリーのレコードまたはフィールドをクリックし、[プロパティ] タブをクリックします。

注

  • 特定のプロパティおよびそれに関連する値を表示する場合に、[プロパティ] タブのスクロール バーをドラッグしなければならないことがあります。


送信元仕様ツリー ペインのサイズ調整

  1. 送信元仕様ツリー ペインの右境界線をポイントし、カーソルを両方向矢印にします。

  2. 境界線を右にドラッグするとペインのサイズは大きくなり、左にドラッグすると小さくなります。

注

  • 境界線をダブルクリックし、既定の位置に復元します。

関連項目

送信先仕様ツリー ペインのサイズ調整

下部ウィンドウのサイズ調整


送信先仕様ツリー ペインのサイズ調整

  1. 送信先仕様ツリー ペインの左境界線をポイントし、カーソルを両方向矢印にします。

  2. 境界線を左にドラッグするとペインのサイズは大きくなり、右にドラッグすると小さくなります。

注

  • 境界線をダブルクリックし、既定の位置に復元します。

関連項目

送信元仕様ツリー ペインのサイズ調整

下部ウィンドウのサイズ調整


下部ウィンドウのサイズ調整

  1. 下部ウィンドウの上境界線をポイントし、カーソルを両方向矢印にします。

  2. ペインを上方にドラッグするとペインのサイズは大きくなり、下方にドラッグすると小さくなります。

注

  • 境界線をダブルクリックし、既定の位置に復元します。

関連項目

送信先仕様ツリー ペインのサイズ調整

送信元仕様ツリー ペインのサイズ調整


ユーザー インターフェイスのカスタマイズ

ここには次のトピックが含まれます。

  • マッピング グリッドの色の変更

  • リンクの色の変更

  • 選択したオブジェクトの色の変更

  • コンパイラの警告の色の変更

  • 既定の色への復元

  • テキストのサイズの変更


マッピング グリッドの色の変更

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [色] タブをクリックします。

  3. マッピング グリッドの破線を表す [グリッドの前景色] の隣のボックスをクリックし、色パレットで新しい色を選択します。

    または

    マッピング グリッドの背景色を表す [グリッドの背景色] の隣のボックスをクリックし、色パレットで新しい色を選択します。

  4. [OK] をクリックします。

関連項目

コンパイラの警告の色の変更

リンクの色の変更

選択したオブジェクトの色の変更

既定の色への復元


リンクの色の変更

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [色] タブをクリックします。

  3. 次のいずれかの隣にあるボックスをクリックします。
    • [固定リンク] : 固定リンクは、マッピング グリッド内にある単純な値コピー リンクです。

    • [柔軟なリンク] : 柔軟なリンクは、単純な値コピー リンクを送信元仕様ツリーから送信先仕様ツリーにドラッグしているときのリンクです。リンクが作成されると、リンクの色は固定リンクの色に変わります。

    • [部分的なリンク] : 部分的なリンクは、フィールドまたはレコードの親レコードが折りたたまれている場合に存在するリンクです。

    • [コンパイラ リンク] : コンパイラ リンクは、コンパイラ ディレクティブ リンクです。コンパイラ リンクは、送信元仕様ツリーのフィールドから送信先仕様ツリーのフィールドまでリンクを設定すると自動的に作成されるリンクです。
  4. 色パレットで新しい色を選択します。

  5. そのほかの色を変更する必要がある場合は、手順 3. を繰り返します。

  6. [OK] をクリックします。

関連項目

マッピング グリッドの色の変更

コンパイラの警告の色の変更

選択したオブジェクトの色の変更

既定の色への復元


選択したオブジェクトの色の変更

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [色] タブをクリックします。

  3. [選択したオブジェクト] の隣のボックスをクリックし、色パレットで新しい色を選択します。

  4. [OK] をクリックします。

関連項目

マッピング グリッドの色の変更

コンパイラの警告の色の変更

リンクの色の変更

既定の色への復元


コンパイラの警告の色の変更

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [色] タブをクリックします。

  3. [コンパイラの警告] の隣のボックスをクリックし、色パレットで新しい色を選択します。

  4. [OK] をクリックします。

関連項目

マッピング グリッドの色の変更

リンクの色の変更

選択したオブジェクトの色の変更

既定の色への復元


既定の色への復元

  1. [ツール] メニューの [オプション] をクリックします。

    [BizTalk マッパーのオプション] ダイアログ ボックスが表示されます。

  2. [色] タブをクリックします。

  3. [既定の色に戻す] をクリックし、[OK] をクリックします。

関連項目

マッピング グリッドの色の変更

コンパイラの警告の色の変更

リンクの色の変更

選択したオブジェクトの色の変更


BizTalk マッパーのショートカット キー

BizTalk マッパーでは、ショートカット キーを使用して作業を行うことができます。次の表は、これらのショートカット キーのクイック リファレンスです。

注

  • この一覧に示されていない機能は、マウスがなくても、数字キーパッドを使用してマウス ポインタを移動するマウス キーを使うことにより、利用できます。マウス キー機能の詳細については、Windows 2000 Server または Windows 2000 Advanced Server オンライン ヘルプの「キーボードを使ってマウス ポインタを移動する」を参照してください。Windows 2000 Professional では、ヘルプの「マウス キーでマウス ポインタを動かすには」を参照してください。
ショートカット キー | 機能
Ctrl + N | 新しい仕様を開きます。
Ctrl +O | 既存のマップを開きます。
Ctrl + S | マップを保存します。
Cｔｒｌ + F5 | マップをテストします。
F4 | 次の警告を強調表示します。
F5 | マップをコンパイルします。
Ctrl + A | グリッド ページを追加します。
グリッド ページ名の上で、F2 | グリッド ページの名前を変更します。
Ctrl + D | グリッド ページを削除します。
Del | マッピング グリッド内のオブジェクトを削除します。
F6 | ウィンドウのフォーカスを時計回りに切り替えます。
Shift + F6 | ウィンドウのフォーカスを反時計回りに切り替えます。Functoid パレットが開いた状態で Shift キーを押しながら F6 キーを押すと、フォーカスが [文字列] タブへ切り替わり、左右の方向キーを使用してタブを切り替えられます。
Shift + F10 | 強調表示されている項目のコンテキスト メニューを開きます。
Tab | 下部ウィンドウで、フォーカスをタブからその下のウィンドウまたはフィールドへ、時計回りに切り替えます。ボタンやフィールド間でフォーカスが移動します。また、このショートカット キーによって、[送信元仕様の種類の選択] ダイアログ ボックスの右上隅のボタンにアクセスできます。
Shift + Tab | 下部ウィンドウで、フォーカスをタブからその下のウィンドウまたはフィールドへ、反時計回りに切り替えます。
Space | チェック ボックスをオンまたはオフにします。ボタンにフォーカスがある場合、マウスのクリックと同様な動作になります。
F1 | オンライン ヘルプを表示します。
Alt + F4 | プログラムを終了します。
方向キー | [グリッドのプレビュー] ウィンドウ内でフォーカスを移動します。
← | 左のタブを選択します。
→ | 右のタブを選択します。
任意の方向キー | ダイアログ ボックスのメイン ウィンドウ内のフォルダまたはファイルを強調表示します。フォーカスは切り替わりません。この機能を使用できるのは、[WebDAV から取得] ダイアログ ボックス、および [WebDAV に格納] ダイアログ ボックスです。詳細については、「WebDAV からのマップの取得」を参照してください。

BizTalk マッパーでのマウス キーの使用

BizTalk マッパーの操作の一部には、ショートカット キーがありません。次の操作を行うには、マウス キーを使用する必要があります。

  • 移動

  • Functoid の選択

  • Functoid のドラッグ

  • リンクの作成


BizTalk エディタと BizTalk マッパーのトラブルシューティング

ここでは、Microsoft® BizTalk™ エディタ および BizTalk マッパーのトラブルシューティングについて説明します。BizTalk エディタまたは BizTalk マッパーで問題がある場合、ここで解決策を見つけてください。

ここには次のトピックが含まれます。

  • リモート WebDAV サーバーに接続する際にパスワードが要求される

  • WebDAV への接続またはファイルの格納ができない

  • ???.xml が WebDAV ダイアログ ボックスに表示される

  • [WebDAV から取得] ダイアログ ボックスに BizTalkServerRepositoryMaps フォルダが表示される

  • [WebDAV から取得] または [WebDAV に格納] ダイアログ ボックスが空になっている

  • http://localhost に接続できない

  • BizTalk Server に送信したフラット ファイルが完全には解析されない

  • BizTalk Server にフラット ファイルを送信すると空白が削除される

  • マップのテストが失敗する

  • DTD のインポートが失敗する

  • 日付または時刻フィールドを使用するとインスタンスの検証が失敗する

  • WebDAV におけるマップの取得または格納を目的とした msdaipp.dll の再登録

  • パーサーが必要な先頭の区切り記号を見つけられない

  • WebDAV へのファイルの格納ができない

  • XML-Data Reduced ファイルのインポートができない

  • 小数点を表すのにカンマを使用するとインスタンス検証が失敗する

  • IDOC ドキュメントの中の大きなデータ セグメントを SAP システムに送信できない

  • WebDAV での Unicode の制限

  • X12 テンプレートで小数点が暗黙的に使用されている

  • キーボードを使って韓国語の文字から中国語の文字に変換すると BizTalk エディタに障害が発生する

  • BizTalk エディタ、または BizTalk マッパーを開くことができない


リモート WebDAV サーバーに接続する際にパスワードが要求される

原因 : ユーザーが BizTalkServerRepository フォルダへのアクセス権を持っていない可能性があります。

解決策 : ユーザーに BizTalkServerRepository フォルダへのアクセス権を付与します。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[インターネット サービス マネージャ] をクリックします。

  2. コンソール ツリーでコンピュータの名前を展開します。

  3. [既定の Web サイト] を展開します。

  4. [BizTalkServerRepository] を右クリックし、[プロパティ] をクリックします。

    [BizTalkServerRepository のプロパティ] ダイアログ ボックスが表示されます。

  5. [ディレクトリ セキュリティ] タブをクリックします。

  6. [匿名アクセスおよび認証コントロール] の [編集] をクリックします。

  7. [匿名アクセス] チェック ボックスをオンにし、[OK] を 2 回クリックします。


WebDAV への接続またはファイルの格納ができない

原因 1 : WebDAV からマップや仕様を取得したり、WebDAV にこれらを格納する際に、次のいずれかのメッセージが表示されることがあります。

WebDAV リポジトリにファイルを格納できません。この時点ではサーバーを利用できない可能性があります。

現在の範囲には、指定された特性に一致するキーがありません。

このメッセージは、Web サーバーのユーザー アカウントの匿名設定で、リポジトリが置かれている Microsoft® Windows® 2000 のディレクトリに書き込み権限が設定されていない場合に表示されます。

解決策 : ユーザーにリポジトリへのアクセス権を付与します。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[アクセサリ] をポイントし、[エクスプローラ] をクリックします。

  2. Microsoft BizTalk Server 2002 をインストールした場所に移動します。

  3. [Microsoft BizTalk Server] ディレクトリを展開します。[BizTalkServerRepository] を右クリックし、[プロパティ] をクリックします。

    [BizTalkServerRepository のプロパティ] ダイアログ ボックスが表示されます。

  4. [セキュリティ] タブをクリックします。

  5. [追加] をクリックし、リポジトリへのアクセス許可を付与するユーザーのドメイン名とユーザー名を domain name\user name の形式で入力します。

  6. [OK] を 2 回クリックします。

原因 2 : WebDAV からマップや仕様を取得したり、WebDAV にこれらを格納する際に、次のメッセージが表示されることがあります。

BizTalk Server リポジトリが http://localhost/BizTalkServerRepository/DocSpecs に見つかりませんでした。別のサーバー名を入力して WebDAV 接続を再試行してください。

このメッセージは、Web サーバーで Microsoft® FrontPage® Server Extensions が有効になっている場合に表示されます。

解決策 : FrontPage Server Extensions を無効にします。World Wide Web Publishing Service を実行している場合は、サービスをいったん停止し再開します。

注

  • この問題は、WebDAV リポジトリを提供するコンピュータで World Wide Web Publishing Service を実行していなくても発生する場合があります。

FrontPage Server Extensions を無効にするには

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[インターネット サービス マネージャ] をクリックします。

  2. 詳細ペインでご使用のコンピュータ名をダブルクリックします。次に [既定の Web サイト] を右クリックし、[プロパティ] をクリックします。

    [既定の Web サイトのプロパティ] ダイアログ ボックスが表示されます。

  3. [Server Extensions] タブの [作成を有効にする] チェック ボックスをオフにし、[OK] をクリックします。

World Wide Web Publishing Service を停止し再開するには

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[コンポーネント サービス] をクリックします。

  2. コンソール ツリーで [サービス (ローカル)] をクリックします。

  3. 詳細ペインで [World Wide Web Publishing Service] を右クリックし、[停止] をクリックします。

  4. [World Wide Web Publishing Service] を右クリックし、[開始] をクリックします。


???.xml が WebDAV ダイアログ ボックスに表示される

各国語対応に関する問題

原因 : コンピュータが表示する文字は、BizTalk Server で指定したロケール設定に依存します。

解決策 : BizTalk Server で指定したロケール設定と同じ文字セットを使用中のコンピュータに指定します。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[設定] をポイントします。次に [コントロール パネル] をクリックします。

  2. [地域のオプション] をダブルクリックします。

  3. [全般] タブの [システムの言語設定] で必要な言語のチェック ボックスをオンにし、[既定値に設定] をクリックします。

    [システム ロケールの選択] ダイアログ ボックスが表示されます。

  4. 一覧から適切なロケールを選択し、[OK] を 2 回クリックします。

    [地域のオプションの変更] ダイアログ ボックスが表示されます。

  5. [はい] をクリックして変更を確定し、コンピュータを再起動します。

注

  • コンピュータを再起動すると、[地域のオプション] ダイアログ ボックスで選択した言語に "(既定)" という情報が表示されます。

関連項目

マップの格納

仕様の格納


[WebDAV から取得] ダイアログ ボックスに BizTalkServerRepositoryMaps フォルダが表示される

原因 : [BizTalkServerRepository のプロパティ] ダイアログ ボックスの [ローカル パス] ボックスの末尾に円記号があります。

解決策 : [BizTalkServerRepository のプロパティ] ダイアログ ボックスの [ローカル パス] ボックスで、末尾の円記号を削除します。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[インターネット インフォメーション サービス] をクリックし、[既定の Web サイト] を展開します。

  2. [BizTalkServerRepository] を右クリックし、[プロパティ] をクリックします。

    [BizTalkServerRepository のプロパティ] ダイアログ ボックスが表示されます。

  3. [ローカル パス] ボックスで、末尾の円記号を削除し、[OK] をクリックします。

この手順を完了すると、[WebDAV から取得] ダイアログ ボックスから BizTalkServerRepositoryMaps フォルダが削除されます。BizTalkServerRepositoryMaps フォルダは使用できないため、削除することをお勧めします。


[WebDAV から取得] または [WebDAV に格納] ダイアログ ボックスが空になっている

原因 : [BizTalkServerRepository のプロパティ] ダイアログ ボックスでディレクトリの参照が無効になっています。

解決策 : [BizTalkServerRepository のプロパティ] ダイアログ ボックスでディレクトリの参照を有効にします。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に、[管理ツール] をポイントし、[インターネット サービス マネージャ] をクリックします。

  2. トラブルシューティングの対象となるコンピュータを展開します。

  3. [既定の Web サイト] を展開します。

  4. [BizTalkServerRepository] を右クリックし、[プロパティ] をクリックします。

    [BizTalkServerRepository のプロパティ] ダイアログ ボックスが表示されます。

  5. [仮想ディレクトリ] タブで [ディレクトリの参照] チェック ボックスをオンにします。

  6. [読み取り] および [書き込み] チェック ボックスもオンになっていることを確認し、[OK] をクリックします。


http://localhost に接続できない

原因 : [プロキシ サーバーを使用する] チェック ボックスはオンになっていますが、[ローカル アドレスにはプロキシ サーバーを使用しない] チェック ボックスがオンになっていません。

解決策 : [プロキシ サーバーを使用する] チェック ボックスはオンにしたまま、[ローカル アドレスにはプロキシ サーバーを使用しない] チェック ボックスをオンにします。そのためには、次の操作を行います。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Internet Explorer] をクリックします。

  2. [ツール] メニューの [インターネット オプション] をクリックします。

    [インターネット オプション] ダイアログ ボックスが表示されます。

  3. [接続] タブをクリックし、[LAN の設定] をクリックします。

    [ローカル エリア ネットワーク (LAN) の設定] ダイアログ ボックスが表示されます。

  4. [プロキシ サーバー] の [ローカル アドレスにはプロキシ サーバーを使用しない] チェック ボックスをオンにします。

  5. [OK] を 2 回クリックします。

注

  • このエラーは、http://<コンピュータの名前> に接続する場合は発生しません。


BizTalk サーバーに送信したフラット ファイルが完全には解析されない

原因 : 区切りフラット ファイルでルート ノードの名前が、そのファイルのほかのノードの名前の部分文字列である場合、そのファイルが BizTalk Server に送信されたとき、解析エラーが発生する場合があります。

解決策 : 仕様内のほかのノード名の部分文字列と同じにならないように、ルート ノードの名前を変更します。


BizTalk Server にフラット ファイルを送信すると空白が削除される

原因 : フラット ファイルを BizTalk Server に送信すると、フィールドの空白が削除される場合があります。これは、基本となる MSXML パーサーでは、[宣言] タブの [種類] が [要素] に設定されたフィールド内の空白は既定で削除されるためです。

解決策 : フラット ファイル内のフィールドに空白を残す必要がある場合は、BizTalk エディタで送信元仕様のフィールドの [宣言] タブにある [種類] を [属性] に設定します。

関連項目

宣言のプロパティの設定


マップのテストが失敗する

原因 : マップをテストする場合、その前に BizTalk マッパーによってマップがコンパイルされます。コンパイル中に警告があった場合、マップのテストが失敗する可能性があります。その場合、次のエラー メッセージが表示されます。

テスト インスタンス ドキュメントを使用した、送信元仕様への XSL 変換に失敗しました。

解決策 : コンパイラのすべての警告を解決した後、マップを再コンパイルします。コンパイラの警告を解決するには、次の手順に従います。

  1. [警告] タブをクリックします。問題を解決する [警告] の行をダブルクリックします。

    警告メッセージに関連付けられたリンクまたは Functoid が強調表示されます。

  2. 必要に応じて、警告を解決します。

マップを再コンパイルするには

  • [ツール] メニューの [マップのコンパイル] をクリックします。

関連項目

マップのテスト


DTD のインポートが失敗する

原因 : 別のファイルへの外部参照を含むドキュメント型定義 (DTD) をインポートしようとすると、次のメッセージが表示される場合があります。

無効な文字が DTD 内に見つかりました。

解決策 : DTD をインポートする前に、その内部のすべての外部参照を削除します。


日付または時刻フィールドを使用するとインスタンスの検証が失敗する

原因 : BizTalk Server で受信ドキュメントのインスタンスの処理中に、Functoid または送信元仕様ツリーの中のフィールドから、送信先仕様ツリーの中の [データ型] プロパティが [Data]、[Date Time]、[Date Time.tz]、[Time]、[Time.tz] のいずれかに設定されているノードへのリンクがある場合、送信先仕様ツリーの中のノードで受信されるデータが ISO 8601 以外の形式であった場合、インスタンスの検証が失敗します。

解決策 : [データ型] プロパティが [Date]、[Date Time]、[Date Time.tz]、[Time]、[Time.tz] のいずれかに設定されている送信先仕様のフィールドにリンクする場合、そのフィールドに Functoid または受信ドキュメントのインスタンスのノードからリンクするデータが ISO 8601 形式であることを確認してください。[データ型] プロパティの各値の正しい ISO 8601 形式を次の表に示します。

[データ型] プロパティ | ISO 8601 形式
Date | YYYY-MM-DD (1988-04-07)
Date Time | YYYY-MM-DDTHH:MM:SS (1988-04-07T18:39:09)
Date Time.tz | YYYY-MM-DDTHH:MM:SS-TZH:TZM (1988-04-07T18:39:09-08:00)
Time | HH:MM:SS (08:15:27)
Time.tz | HH:MM:SS-TZH:TZM (08:15:27-05:00)


WebDAV におけるファイルの取得または格納を目的とした msdaipp.dll の再登録

原因 : WebDAV からマップや仕様を取得したり、WebDAV にこれらを格納する際に、次のメッセージが表示されることがあります。

BizTalk Server リポジトリが http://<サーバー名>/BizTalkServerRepository/DocSpecs に見つかりませんでした。

解決策 : この問題を解決するには、次の手順に従います。

  1. エクスプローラで \Program Files\Common Files\System\Ole DB\ に移動し、次に msdaipp.dll をダブルクリックします。

    [注意] ダイアログ ボックスが表示されます。

  2. [アプリケーションから開く] をクリックします。

    [ファイルを開くアプリケーションの選択] ダイアログ ボックスが表示されます。

  3. [その他] をクリックします。

    [アプリケーションから開く] ダイアログ ボックスが表示されます。

  4. \WINNT\system32\ に移動し、regsvr32.exe をダブルクリックします。

    [ファイルを開くアプリケーションの選択] ダイアログ ボックスが表示されます。

  5. Microsoft(C) Register Server が選択されていることを確認し、[OK] をクリックします。

    メッセージ ボックスが表示されます。

  6. [OK] をクリックします。


パーサーが必要な先頭の区切り記号を見つけられない

原因 : 使用しているドキュメント インスタンスの中に省略可能で空のレコードがあり、その中にフィールドがある場合、レコード区切り記号の前にフィールド区切り記号を追加しなければなりません。たとえば、次のドキュメント インスタンスにはレコード区切り文字としてチルダ (~) が含まれています。しかし、最初のレコードのフィールド区切り記号としてプラス記号 (+) も使用されています。そうするためには、[ドキュメントの区切り記号] ダイアログ ボックスで、[レコード区切り記号] を ~ に、[フィールド区切り記号] を + に設定しなければなりません。

前のドキュメント インスタンスを次の仕様の図に照らして検証した時、次のエラー メッセージが表示されます。

"レコード 1" の解析中、パーサーが先頭に必要な区切り記号 ("+") を見つけられません (0x002b)。

解決策 : この問題を解決するためには、ドキュメント インスタンスの中の "TTT" と "~" の間に "+" を追加します。


WebDAV へのファイルの格納ができない

原因 : BizTalk エディタ または BizTalk マッパー から WebDAV リポジトリへのファイルの保存が失敗した場合 (たとえば、許可が拒否された、またはファイルが読取専用であるとき)、それに対応したエラー メッセージが表示されます。しかし、ファイルを閉じて、WebDAV から再び取得した場合、WebDAV リポジトリからのファイルではなく、ローカルでキャッシュされているファイルが表示されます。[アクセス許可が拒否されました] ダイアログ ボックスが表示されますが、ファイルはあたかも WebDAV リポジトリに保存されていたかのように表示されます。

解決策 : Internet Explorer のキャッシュを消去します。キャッシュを消去するには、以下の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Internet Explorer] をクリックします。

  2. [ツール] メニューの [インターネット オプション] をクリックします。

    [インターネット オプション] ダイアログ ボックスが表示されます。

  3. [ファイルの削除] をクリックします。


XML-Data Reduced ファイルのインポートができない

原因 : 次のコードに示すように、属性宣言の中で型 IDREFS の属性の既定値が指定されている場合、XML-Data Reduced (XDR) のインポートは失敗します。

<AttributeType name="Field1" d:type="idrefs" default="a1 a2"> </AttributeType>
<attribute type="Field1" required="no"></attribute>

解決策 : BizTalk エディタにインポートする前に、次のコードに示すように XDR スキーマの属性参照の既定値を移動します。

<AttributeType name="Field1" d:type="idrefs"> </AttributeType>
<attribute type="Field1" required="no" default="a1 a2"></attribute>


小数点を表すのにカンマを使用するとインスタンス検証が失敗する

原因 : ドキュメント インスタンスで小数を表す時にピリオド (.) の代わりにカンマ (,) を使用すると、インスタンス検証が失敗します。これは、パーサーがドキュメント インスタンスを Extensible Markup Language (XML) ドキュメントに変換し、次に XML ドキュメント オブジェクト モデル (DOM) を使用して XML ドキュメントの仕様との適合を検証するからです。XML DOM では、カンマを小数点として使用できません。詳細については、MSDN Online Library の Web サイト (msdn.microsoft.com/library/default.asp) で 「XML Data Types Reference」を検索してください。

解決策 : ドキュメント インスタンスで小数点を表す時はピリオドを使用します。


IDOC ドキュメントの中の大きなデータ セグメントを SAP システムに送信できない

原因 : SAP システムで処理するためにルーティングされた IDOC ドキュメントの中で、大きなデータ セグメントが使用されている場合、一部のデータが処理されないことがあります。これは SAP システムで構成されているタイムアウト値のためです。

解決策 : SAP システムで設定されているタイムアウト値を変更します。


WebDAV での Unicode の制限

各国語対応に関する問題

原因 : WebDAV では、ファイル名に Unicode 文字を使用できません。しかし、ファイルそのものは、リポジトリに Unicode エンコードでのみ保存できます。

解決策 : コンピュータで設定されているシステム ロケールがユーザーの言語に設定されていることを確認してください。たとえば、ユーザーが Windows の英語バージョンを実行しているコンピュータ上に BizTalk Server 2002 の英語バージョンをインストールしていて、ファイル名に Latin I コード ページ (Windows の1252、英語を含む) でサポートされていない文字を使用するためには、システム ロケールを自分の言語をサポートするロケールに変更する必要があります。

また、韓国語と中国語の場合、インターネット ブラウザが URL を UTF-8 で送信するように設定されていないことを確認してください。このオプションが設定されていないことを確認するには、以下の手順を実行します。

  1. [スタート] ボタンをクリックし、[プログラム] をポイントします。次に [Internet Explorer] をクリックします。

  2. [ツール] メニューの [オプション] をクリックします。

    [インターネット オプション] ダイアログ ボックスが表示されます。

  3. [詳細設定] タブを選択し、[常に UTF-8 として URL を送信する] チェック ボックスをオフにします。


X12 テンプレートで小数点が暗黙的に使用されている

原因 : BizTalk Server 2002 に含まれている X12 テンプレートを BizTalk エディタまたは BizTalk マッパーで使用するとき、次のようなエラー メッセージが表示される場合があります。

"ITD05" フィールド ("") の長さが無効です。長さを 48 から -1 までで設定してください。このドキュメントは拒否されます。

X12 テンプレートは、暗黙的な小数点を含むデータ型 Nx を使用します。これは検証、およびマッピングに影響を及ぼします。入力データに小数点が含まれていると、出力は Nx カスタム データ型 (これは小数点を含みません) に適合せず、中間 XML ファイルとして無効なドキュメント インスタンスを作成します。

解決策 : X12 テンプレートの暗黙的な小数点を含むデータ型を、ほかの数値データ型に手動で変更します。


キーボードを使って韓国語の文字から中国語の文字に変換すると BizTalk エディタに障害が発生する

各国語対応に関する問題

韓国語のキーボードの CHINESE キーを使用して韓国語の文字を中国語の文字に変換すると、BizTalk エディタに障害が発生します。しかし、中国語の文字を直接 BizTalk エディタに入力することはできます (たとえば、[メモ帳] から中国語の文字をコピーする)。


BizTalk エディタ または BizTalk マッパーを開くことができない

原因 : XML パーサーを使用しているとき、BizTalk エディタまたは BizTalk マッパーを開くことができません。

解決策 : BizTalk Server 2002 では、Microsoft XML (MSXML) Parser Version 3.0 を使用することを強くお勧めします。また、MSXML パーサーを Side-by-Side モードで使用することをお勧めします。XMLINST.exe をインストールして、MSXML パーサーが置換モードで動作するように構成した場合、BizTalk Server で問題が発生することがあります。XMLINST.EXE を使用して、またはレジストリ キーを変更することによって MSXML パーサーが置換モードで動作するように構成した場合、BizTalk Server はサポートされません。

次の手順は、現在 MSXML パーサーが置換モードで動作するように構成されている場合に、それを Side-by-Side モードで動作するように構成する方法を示しています。

  1. [スタート] メニューをクリックし、[ファイル名を指定して実行] をクリックします。

  2. [名前] ボックスに「cmd」と入力し、[OK] をクリックします。

  3. コマンド プロンプトで「xmlinst –u」と入力して Enter キーを押します。

  4. コマンド プロンプトで「%WINDIR%\system32\regsvr32 msxml.dll」と入力し、Enter キーを押します。

  5. コマンド プロンプトで「%WINDIR%\system32\regsvr32 msxml2.dll」と入力し、Enter キーを押します。

  6. コマンド プロンプトで「%WINDIR%\system32\regsvr32 msxml3.dll」と入力し、Enter キーを押します。

  7. コマンド プロンプトで「exit」と入力し、Enter キーを押します。

XMLINST.exe の使用方法の詳細については、サポート技術情報の次の記事を参照してください。「[PRB] 運用サーバでの Xmlinst.exe 実行後に発生するアプリケーションエラー」(www.microsoft.com/JAPAN/support/kb/articles/JP278/6/36.asp)


BizTalk サービスの統合

Microsoft® BizTalk™ オーケストレーション サービスと BizTalk メッセージ サービスを統合することにより、取引先と複数のトランスポート サービスを使用する内部アプリケーションとの間のドキュメントおよびメッセージの交換を管理することができます。また、次の機能も提供します。

  • 複雑な長時間トランザクションとビジネス プロセスの制御

  • 信頼性の高いドキュメント配信およびメッセージ配信

  • 仕様に対する各ドキュメント インスタンスを確認することによるデータ検証

  • ドキュメントの構造および書式を変換するためのマップを使用したデータ マッピング

  • 暗号化証明書とデジタル署名証明書を使用したデータ セキュリティとデータ インテグリティ

  • 受信確認の生成と照合のサポート

BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合する方法はたくさんありますが、ここでは一般的なシナリオを示します。

このシナリオでは、メッセージを生成して取引先の送信先システムに送信するように送信元システムの XLANG スケジュール インスタンスを構成し、取引先からの応答メッセージの受信を待ってから、初期メッセージを送信した XLANG スケジュール インスタンスにその応答メッセージを配信します。この構成を利用する一般的なビジネス プロセスの一例として、注文書を送信し、注文書の受取書を受信してから、処理を続行することなどがあります。

ここでは、HTTP (Hypertext Transfer Protocol) トランスポートと非 HTTP トランスポートを使用して自分の会社と取引先との間でメッセージを交換するのに必要な構成手順について説明します。ただし、同様の構成を使用すると、自分の会社内のアプリケーション間でのメッセージ交換を制御できます。

Microsoft BizTalk Server 2002 は、初期メッセージを送信する送信元システムと、応答メッセージを送信する発信元システムのどちらとしても機能できるので、ここでは、この両方に必要な構成手順を示します。これにより、必要な構成全体を確認することもできます。

これらの構成を反映する XLANG スケジュールのサンプルとその他の関連ファイルは、\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Integrating BizTalk Services フォルダにあります。

注

  • BizTalk メッセージ サービスの "メッセージ ポート" と、BizTalk オーケストレーション サービスの "ポート" は、次のように意味が異なります。
    • メッセージ ポートとは、指定したトランスポート サービスを使用して、指定した送信先へドキュメントをトランスポートすることを BizTalk メッセージ サービスに指示する一連のプロパティです。

    • ポートとは、特定の実装を使用する名前付きの場所です。XLANG スケジュールでは、ポートは、同期通信と非同期通信をサポートし、XLANG スケジュールから、または XLANG スケジュールへ、メッセージを渡すのに使用されます。
  • BizTalk メッセージ サービスで送受信される XLANG スケジュールによって処理されるメッセージに関連するアクション イベントは、追跡データベースで追跡できます。詳細については、「追跡データベースでの XLANG スケジュール イベントの追跡」を参照してください。

ここには次のトピックが含まれます。

  • HTTP トランスポートの使用

  • 非 HTTP トランスポートの使用

関連項目

BizTalk Server の動作

インスタンス管理


HTTP トランスポートの使用

ここでは、送信元システムと送信先システムの両方について、BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合し、構成する方法について説明します。目的は次のとおりです。

  • 送信元システムが特定の XLANG スケジュール インスタンスを使用して、メッセージを生成し、それを取引先の送信先システムに送信するようにします。

  • 送信先システムが HTTP トランスポートを使用して応答メッセージを送信するようにします。

  • 送信元システムが応答メッセージを受信し、初期メッセージを生成して送信した XLANG スケジュール インスタンスへその応答メッセージを配信するようにします。

送信先システムが非 HTTP トランスポートを使用して応答メッセージを送信できるように両方のシステムを構成する方法については、「非 HTTP トランスポートの使用」を参照してください。

ここには次のトピックが含まれます。

  • HTTP トランスポートを使用するための送信元システムの構成

  • HTTP トランスポートを使用するための送信先システムの構成


HTTP トランスポートを使用するための送信元システムの構成

ここでは、HTTP URL の返信先アドレスを含むメッセージを生成し、送信するように送信元システムを構成する方法について説明します。取引先の送信先システムは、HTTP トランスポートを使用することで、初期メッセージに含まれた返信先アドレスを使用して、送信元システムの Web サイトにある ASP ページに応答メッセージを送信します。送信先システムが非 HTTP トランスポートを使用して応答メッセージを送信できるように送信元システムを構成する場合は、「非 HTTP トランスポートを使用するための送信元システムの構成」を参照してください。HTTPS (Secure Hypertext Transfer Protocol) トランスポートを使用するのに必要な構成手順については、後で説明します。

この構成で返信先アドレスとして使用される HTTP URL は、ポートのプロパティのデータに基づいて、XLANG スケジュールによって生成されます。HTTP URL は次の要素から構成されます。

  • 応答メッセージの送信先である送信元システムの Web サイト上の ASP ページのアドレス

  • 応答メッセージの処理に使用される送信元システムの BizTalk メッセージ サービス内のチャネルの名前を含むクエリ文字列、および XLANG スケジュール インスタンスによって作成される、応答メッセージの配信先であるインスタンスごとのキューの完全修飾パス

HTTP URL の返信先アドレスの例を次に示します。

http://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\ChannelForReply{9e0016bf-be1f-48fe-82de-b27077ab5e73}

送信元システムの ASP ページが応答メッセージを受信する場合、その応答メッセージには、次の手順を実行するスクリプトが含まれます。

  • クエリ文字列からチャネル名とキュー パス情報を抽出します。

  • キュー パスをパス名から形式名に変換し、BizTalk メッセージ サービスに必要な queue:// のプレフィックスを挿入します。

  • チャネル名とキュー パス情報を送信パラメータとして使用して、送信元システムの BizTalk メッセージ サービスへ応答メッセージを送信します。ドキュメントの送信の詳細については、「Submitting」を参照してください。

送信元システムの BizTalk メッセージ サービスは、指定されたチャネルを使用して応答メッセージを処理し、関連付けられたメッセージ ポートを使用します。メッセージ ポートはキュー パスを使用して、初期メッセージを生成した、実行中の同じ XLANG スケジュール インスタンスに応答メッセージをトランスポートします。

この送信元システムの構成を正しく機能させるには、取引先の送信先システムも正しく構成されている必要があります。送信先システムの構成については、「HTTP トランスポートを使用するための送信先システムの構成」を参照してください。

HTTP トランスポートを使用するように送信元システムを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 初期メッセージを処理するチャネルの受信と送信のドキュメント定義に必要な仕様を作成します。
  • 仕様の作成と検証

    注

    • 返信先アドレス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信先システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
  • 応答メッセージを処理するチャネルの受信と送信のドキュメント定義に必要な仕様を作成します。
  • 仕様の作成と検証

    注

    • これらの仕様に特別な構成は必要ありません。
BizTalk メッセージ マネージャ
  • 取引先と送信先システムを表す組織を作成します。
  • 組織の作成

    注

    • この組織に特別な構成は必要ありません。
  • 初期メッセージの処理に使用するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 返信先フィールドを持つ仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 応答メッセージの処理に使用するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • これらのドキュメント定義に特別な構成は必要ありません。
  • 初期メッセージを送信先システムへトランスポートするための、組織へのメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • このメッセージ ポートをオープンなメッセージ ポートにすることはできません。
  • XLANG スケジュールからの送信メッセージを処理するための、アプリケーションからのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページで [XLANG スケジュール] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。

    • チャネル名と受信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
  • 送信メッセージを生成したアクティブな XLANG スケジュール インスタンスへ応答メッセージをトランスポートするための、アプリケーションへのメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先アプリケーション] ページで [実行中の XLANG スケジュール] をクリックします。詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。
  • 送信先システムからの応答メッセージを処理するための、組織からのチャネルを作成します。
  • チャネルの作成

    注

    • 使用するチャネル名と送信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
BizTalk オーケストレーション デザイナ
  • BizTalk メッセージ シェイプを使用して、初期メッセージを送信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで [静的チャネル] をクリックし、[既存のチャネル名を入力してください] ボックスに初期メッセージの処理に使用する BizTalk メッセージ マネージャ内のチャネルの名前を入力します。
  • アクション シェイプと、初期メッセージを送信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの受信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、メッセージを処理するのに使用するチャネルの受信ドキュメント定義の名前を入力します。

    • [メッセージ仕様情報] ページの [参照] をクリックし、仕様を参照します。この仕様は、初期メッセージの処理で使用されるチャネルの受信ドキュメント定義で使用されます。

    • [メッセージ仕様情報] ページで、[メッセージ フィールド] の [追加] をクリックし、初期メッセージに返信先アドレスを格納するために作成した仕様のフィールドを追加します。
  • BizTalk メッセージ シェイプを使用して、応答メッセージを受信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [XLANG スケジュールのアクティブ化情報] ページで [いいえ] をクリックします。

    • [チャネル情報] ページの [チャネル名] ボックスに、応答メッセージの処理に使用する BizTalk メッセージ マネージャ内のチャネルの名前を入力します。

      BizTalk オーケストレーション デザイナはチャネル名と GUID を使用して、応答メッセージが配信されるインスタンスごとのキューを作成し、名前を付けます。

    • [チャネル情報] ページの [BizTalk メッセージ サービスがドキュメントを受信する HTTP URL アドレス] ボックスに、取引先が応答メッセージを送信できる ASP ページのアドレスを入力します。

      BizTalk オーケストレーション デザイナは、以前に入力されたアドレスとチャネル名を使用して、チャネル名とインスタンスごとのキューのキュー パスを含むクエリ文字列を持つ HTTP URL アドレスを作成します。
  • アクション シェイプと、応答メッセージを受信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの送信ドキュメント定義の名前を使用すると、受信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、応答メッセージの処理に使用するチャネルの送信ドキュメント定義の名前を入力します。

      BizTalk メッセージ サービスから XLANG スケジュール インスタンスに配信されるすべてのメッセージは、メッセージ キューに送信されます。これらのメッセージに付けられるメッセージ ラベルは、チャネルの送信ドキュメント定義の名前です。
  • 返信先アドレス フィールドにポート参照データを渡すためのデータ フローを確立します。
  • メッセージ間のフローの記述

    注

    • [データ] タブをクリックします。

    • [データ] ページのポート参照メッセージで、応答メッセージを受信するポートのポート参照をクリックします。次に、その制御ハンドルを、初期メッセージ内の返信先アドレス フィールドの接続ポイントまでドラッグします。

      これにより、ポート参照データが送信初期メッセージの返信先アドレス フィールドに渡されます。ポート参照は ASP ページの HTTP URL アドレスであり、チャネル名と、ポートのインスタンスごとのキューのキュー パスを持つクエリ文字列を含みます。
ASP ページ
  • BizTalk Server 2002 に用意されているサンプル ASP ページを使用するか、同じスクリプトをサンプル ページとして使用する ASP ページを構成できます。
 注
  • サンプル ASP ページを使用するには、インストール ドライブの \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts を参照し、ReceiveResponse.asp サンプルを見つけます。このファイルを送信元システムの Web サイトの適切なディレクトリに置きます。

  • サンプル ASP ページが応答メッセージを受信すると、そのページのスクリプトによって、HTTP ヘッダーのアドレス内のクエリ文字列からチャネル名とキュー パスが抽出されます。キュー パスもパス名から書式名に変換され、queue:// のプレフィックスも挿入されます。次に、このデータがパラメータとして使用され、送信元システムの BizTalk メッセージ サービスに応答メッセージが送信されます。ドキュメントの送信の詳細については、「Submitting」を参照してください。

セキュリティで保護された HTTPS トランスポートの使用

取引先とのメッセージの交換時に、セキュリティで保護されたトランスポートがビジネス プロセスで必要な場合は、HTTPS トランスポートを使用します。

HTTPS トランスポートを使用するには、送信元システムの構成のうち、応答メッセージを受信するポートの URL アドレスを変更するだけで済みます。

応答メッセージを受信するポートを実装するときに、返信先アドレスとして入力する URL に、HTTP ではなく HTTPS のプレフィックスを使用します。

次に、HTTPS を使用する返信先アドレスの例を示します。

https://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\ChannelForReply{9e0016bf-be1f-48fe-82de-b27077ab5e73}

送信先システムの構成はほかに何も変更する必要はありません。

関連項目

BizTalk サービスの統合


HTTP トランスポートを使用するための送信先システムの構成

ここでは、HTTP URL の返信先アドレスを含むメッセージを受信し、HTTP トランスポートを使用して送信元システムに応答メッセージを送信するように、送信先システムを構成する方法について説明します。応答メッセージの送信に非 HTTP トランスポートを使用するように送信先システムを構成する場合は、「非 HTTP トランスポートを使用するための送信先システムの構成」を参照してください。HTTPS トランスポートを使用する場合の構成の注意事項については、後で説明します。

送信先システムの BizTalk メッセージ サービスが初期メッセージを受信する場合は、指定された XLANG スケジュールの新しいインスタンスをアクティブにして、その XLANG スケジュール インスタンス内の指定されたポートにメッセージを送信するように、送信先システムを構成します。

初期メッセージのフィールドに格納されている返信先アドレス データを、応答メッセージの送信に使用されるポートのポート参照フィールドに渡すように、XLANG スケジュールを構成します。次に、XLANG スケジュールは、動的チャネル オプションを使用して BizTalk メッセージ サービスに応答メッセージを送信します。

動的チャネル オプションの場合、メッセージが BizTalk メッセージ サービスに送信されると、特定のポート データが送信パラメータとして渡されます。ポート参照データ (この場合は返信先アドレス) は送信先識別子パラメータとして渡され、ポートのメッセージの種類はドキュメント定義名パラメータとして渡されます。送信パラメータの詳細については、「Submitting」を参照してください。送信パラメータにより、BizTalk メッセージ サービスは、応答メッセージを処理する特定のチャネルを識別できるようになります。詳細については、「Identification」を参照してください。

動的チャネル オプションを使用する場合は、BizTalk メッセージ サービス内のチャネルが、オープンなメッセージ ポートに関連付けられている必要があります。オープンなメッセージ ポートは、返信先アドレスを使用することで取引先の送信元システムに応答メッセージをトランスポートします。この返信先アドレスは送信先識別子パラメータとして渡されます。これは送信元システム上の ASP ページの HTTP URL なので、HTTP トランスポートが使用されます。オープンなメッセージ ポートの詳細については、「オープンなメッセージ ポート」を参照してください。

この送信先システムの構成を正しく機能させるには、取引先の送信元システムも正しく構成されている必要があります。送信元システムの構成については、「HTTP トランスポートを使用するための送信元システムの構成」を参照してください。

HTTP トランスポートを使用するように送信先システムを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 初期メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • 返信先アドレス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信元システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
  • 応答メッセージを処理するチャネルの受信と送信のドキュメント定義に必要な仕様を作成します。
  • 仕様の作成と検証

    注

    • これらの仕様に特別な構成は必要ありません。
BizTalk メッセージ マネージャ
  • 送信元システムのある取引先を表す組織を作成します。
  • 組織の作成

    注

    • この組織に特別な構成は必要ありません。
  • 初期メッセージを処理するチャネルと、応答メッセージを処理するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 以前に作成された仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 新しい XLANG スケジュール インスタンスをアクティブにするための、アプリケーションへのメッセージ ポートを作成し、その XLANG スケジュール インスタンス内のポートへ初期メッセージをトランスポートします。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先アプリケーション] ページで [新しい XLANG スケジュール] をクリックします。

    • [スケジュール モニカ] ボックスに、指定されたスケジュールのモニカを入力するか、[参照] をクリックしてそのパスを設定します。

    • [ポート名] ボックスに、このスケジュールにあるドキュメントの特定の送信先ポートの名前を入力します。

      詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。

  • 取引先からの初期メッセージを処理するための、組織からのチャネルを作成します。
  • チャネルの作成

    注

    • 使用するチャネル名と送信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
  • 応答メッセージを送信元システムへトランスポートするための、組織へのオープンなメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先組織] ページで [オープンな送信先] をクリックします。詳細については、「送信先組織のプロパティの設定」を参照してください。

      オープンなメッセージ ポートでは、ドキュメントに送信先情報が含まれているか、送信パラメータで送信先情報が提供される必要があります。XLANG スケジュールが BizTalk メッセージ サービスに応答メッセージを送信する場合、XLANG スケジュールは、初期メッセージに含まれていた返信先アドレス データを送信先識別子送信パラメータとして渡します。
  • XLANG スケジュールからの応答メッセージを処理するための、アプリケーションからのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページで [XLANG スケジュール] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。
BizTalk オーケストレーション デザイナ
  • BizTalk メッセージ シェイプを使用して、初期メッセージを受信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [通信の方向] ページで [受信] をクリックします。

    • BizTalk メッセージ バインド ウィザードの [XLANG スケジュールのアクティブ化情報] ページで [はい] をクリックします。

    重要

    • [はい] を選択すると、メッセージの到着時に新しいスケジュール インスタンスをアクティブにするようにポートが構成されます。このオプションの使い方の詳細については、この手順の関連項目を参照してください。
  • アクション シェイプと、初期メッセージを受信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの送信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、応答メッセージの処理に使用するチャネルの送信ドキュメント定義の名前を入力します。

      BizTalk メッセージから XLANG スケジュールに渡されるすべてのメッセージは、メッセージ キューを使用します。これらのメッセージのラベルは、チャネルの送信ドキュメント定義の名前です。
  • BizTalk メッセージ シェイプを使用し、動的チャネルを使用して応答メッセージを送信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで [動的チャネル] をクリックします。

    • 動的チャネルを使用するポートを作成する場合、BizTalk メッセージ サービスがメッセージの処理に使用するチャネルは、送信パラメータとして渡されたポート データによって決まります。これについては、この表の後で説明します。
  • アクション シェイプと、応答メッセージの送信に使用するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの受信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、メッセージを処理するのに使用するチャネルの受信ドキュメント定義の名前を入力します。

      受信ドキュメント定義データは送信パラメータとして BizTalk メッセージ サービスに渡されます。これについては、この表の後で説明します。
  • 応答メッセージを送信するポートのポート参照に返信先アドレス フィールドを渡すためのデータ フローを確立します。
  • メッセージ間のフローの記述

    注

    • [データ] タブをクリックします。

    • [データ] ページで、初期メッセージの返信先アドレス フィールドをクリックします。次に、そのフィールドの制御ハンドルを、応答メッセージの送信に使用されるポートのポート参照メッセージ内のポート参照の左の接続ポイントまでドラッグします。

    重要

    • 返信先アドレス フィールドを、ポート参照の左の接続ポイントに接続する必要があります。ポート参照の左の接続ポイントを使用できるのは、動的チャネルを使用してメッセージを送信するようにポートが構成されている場合だけです。

      動的チャネルを使用するポートの場合、以前に受信したメッセージ内のフィールドからポート参照のデータが渡される必要があります。

      このシナリオでは、初期メッセージからの返信先アドレス データは、応答メッセージの送信に使用されるポートのポート参照フィールドに渡されます。返信先アドレスは応答メッセージの送信先の HTTP URL です。

      動的チャネルを使用するポートが BizTalk メッセージ サービスにメッセージを渡す場合、ポート参照データは送信先識別子パラメータとして渡され、メッセージの種類のデータはドキュメント定義パラメータとして渡されます。パラメータにより、BizTalk メッセージ サービスは、メッセージを処理するために呼び出すチャネルを識別できるようになります。詳細については、「Identification」および「Submitting」を参照してください。

      動的チャネルを使用するようにポートが構成されている場合、送信先の情報は、オープンな送信先送信内のパラメータとして渡されます。したがって、動的チャネルを使用するポートによって呼び出されるすべてのチャネルは、オープンなメッセージ ポートに関連付けられている必要があります。

セキュリティで保護された HTTPS トランスポートの使用

応答メッセージのトランスポートに使用するメッセージ ポートはオープンなメッセージ ポートなので、暗号化証明書を使用してドキュメントを暗号化することはできません。

取引先とのメッセージの交換時に、セキュリティで保護されたトランスポートがビジネス プロセスで必要な場合は、送信元システムが HTTP URL ではなく HTTPS URL を、送信される初期メッセージに返信先アドレスとして含める必要があります。

詳細については、「HTTP トランスポートを使用するための送信元システムの構成」を参照してください。


非 HTTP トランスポートの使用

ここでは、送信元システムと送信先システムの両方について、BizTalk オーケストレーション サービスと BizTalk メッセージ サービスを統合し、構成する方法について説明します。目的は次のとおりです。

  • 送信元システムが特定の XLANG スケジュール インスタンスを使用して、メッセージを生成し、それを取引先の送信先システムに送信するようにします。

  • 送信先システムが初期メッセージを受信し、応答メッセージを生成する XLANG スケジュール インスタンスをアクティブにしてから、非 HTTP トランスポートを使用して応答メッセージを送信元システムに送信するようにします。

送信先システムが HTTP トランスポートを使用して応答メッセージを送信できるように両方のシステムを構成する方法については、「HTTP トランスポートの使用」を参照してください。

ここには次のトピックが含まれます。

  • 非 HTTP トランスポートを使用するための送信元システムの構成

  • 非 HTTP トランスポートを使用するための送信先システムの構成


非 HTTP トランスポートを使用するための送信元システムの構成

ここでは、静的キューのパスを含むメッセージを生成し、送信するように送信元システムを構成する方法について説明します。メッセージ内のキュー パスを応答メッセージのフィールドに渡し、非 HTTP トランスポートを使用してその応答メッセージを送信元システムに送信するように、取引先の送信システムを構成します。送信先システムが HTTP トランスポートを使用して応答メッセージを送信できるように送信元システムを構成する場合は、「HTTP トランスポートを使用するための送信元システムの構成」を参照してください。

送信元システムは、応答メッセージを受信すると、BizTalk メッセージ サービスにメッセージを送信します。BizTalk メッセージ サービスは、ドキュメント フィールドに格納されたキュー パスに指定されたキューに応答メッセージをトランスポートします。このキューは初期メッセージを生成した XLANG スケジュール インスタンスによって監視され、XLANG スケジュールはそのキューから応答メッセージを取得します。

この送信元システムの構成を正しく機能させるには、取引先の送信先システムも正しく構成されている必要があります。送信先システムの構成については、「非 HTTP トランスポートを使用するための送信先システムの構成」を参照してください。

非 HTTP トランスポートを使用するように送信元システムを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 初期メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • キュー パス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信先システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
  • 応答メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • 受信仕様にキュー パス フィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信先システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。

    • 受信仕様のキュー パス フィールドを、送信先の値としてディクショナリ プロパティに設定する必要があります。詳細については、「ディクショナリ プロパティの設定」を参照してください。

      応答メッセージが受信され、送信元システム上の BizTalk メッセージ サービスへ送信されると、キュー パス フィールドが認識され、送信先識別子パラメータとして扱われます。詳細については、「Submitting」を参照してください。メッセージ ポートは、このキュー パスに指定されたキューに応答メッセージをトランスポートします。XLANG スケジュールはこのキューを監視し、応答メッセージを取得します。

BizTalk マッパー
  • 初期メッセージを処理するチャネルで使用されるマップを作成します。
  • 新しいマップの作成

    重要

    • XLANG スケジュールが生成するキュー パス名の構文をパス名から書式名に変更し、queue:// のプレフィックスを追加する必要があります。HTTP トランスポートのシナリオでは、ASP ページ内のスクリプトがこの変更を実行します。非 HTTP トランスポートのシナリオでこの変更を行うには、マップ内の連結 Functoid を使用します。詳細については、「マップによる BizTalk サービスの統合」を参照してください。
BizTalk メッセージ マネージャ
  • 送信先システムのある取引先を表す組織を作成します。
  • 組織の作成

    注

    • この組織に特別な構成は必要ありません。
  • 初期メッセージを処理するチャネルと、応答メッセージを処理するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 以前に作成された仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 初期メッセージを送信先システムへトランスポートするための、組織へのメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • このメッセージ ポートに特別な構成は必要ありません。
  • XLANG スケジュールからの初期メッセージを処理するための、アプリケーションからのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページで [XLANG スケジュール] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。

    • [送信ドキュメント] ページで、[受信ドキュメントを送信ドキュメントにマップする] チェック ボックスをオンにし、[マップ参照] ボックスの右側の [参照] をクリックします。次に、以前に作成したマップを参照し、[開く] をクリックします。

    • 使用するチャネル名と受信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
  • 初期メッセージを生成したアクティブな XLANG スケジュール インスタンスへ応答メッセージをトランスポートするための、組織へのオープンなメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先組織] ページで [オープンな送信先] をクリックします。詳細については、「送信先組織のプロパティの設定」を参照してください。

    • このシナリオでは、アプリケーション (XLANG スケジュール) へ応答メッセージを送信する場合でも、組織へのメッセージ ポートを作成します。

      これにより、キュー パス情報を送信パラメータとして使用し、オープンなメッセージ ポートを使用して応答メッセージを送信できます。詳細については、「Submitting」を参照してください。

      オープンなメッセージ ポートは、キュー パスに指定された静的キューに応答メッセージをトランスポートします。XLANG スケジュールはそのキュー パスから応答メッセージを取得するように構成されます。
  • 送信先システムからの応答メッセージを処理するための、組織からのチャネルを作成します。
  • チャネルの作成

    注

    • このチャネルの受信ドキュメント定義は、以前に作成した仕様を使用するドキュメント定義を使用する必要があります。この仕様は、キュー パス フィールドを送信先の値としてディクショナリ プロパティに指定した仕様です。

    • 使用するチャネル名と受信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
BizTalk オーケストレーション デザイナ
  • BizTalk メッセージ シェイプを使用して、初期メッセージを送信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで [静的チャネル] をクリックし、[既存のチャネル名を入力してください] ボックスに初期メッセージの処理に使用する BizTalk メッセージ マネージャ内のチャネルの名前を入力します。
  • アクション シェイプと、初期メッセージを送信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの受信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、メッセージを処理するのに使用するチャネルの受信ドキュメント定義の名前を入力します。

    • [メッセージ仕様情報] ページの [参照] をクリックし、初期メッセージのチャネルの受信ドキュメント定義に使用する仕様を参照します。

    • [メッセージ仕様情報] ページで、[メッセージ フィールド] の [追加] をクリックし、キュー パスを格納するために作成した仕様のフィールドを追加します。
  • メッセージ キュー シェイプを使用して、応答メッセージを受信するポートを実装します。
  • メッセージ キューを使用したポートの実装

    注

    • このシナリオでは、BizTalk メッセージ サービスからメッセージを受信する場合でも、メッセージ キューのポート バインドを使用します。

    • メッセージ キュー バインド ウィザードの [静的または動的キューの情報] ページで [静的キュー] をクリックします。

    • [キュー情報] ページの [すべてのインスタンスごとに新しいキューを作成する] をクリックし、[キューのプレフィックスを入力してください] ボックスに、キュー名の作成に使用するプレフィックス名を入力します。
  • アクション シェイプと、応答メッセージを受信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [XML 通信ウィザードへようこそ] ページで [受信] をクリックします。

    • [メッセージ情報] ページの [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージ名を入力します。

      任意の名前を使用できますが、チャネルの送信ドキュメント定義の名前を使用すると、受信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、応答メッセージの処理に使用するチャネルの送信ドキュメント定義の名前を入力します。

      BizTalk メッセージから XLANG スケジュールに渡されるすべてのメッセージは、メッセージ キューを使用します。これらのメッセージのラベルは、チャネルの送信ドキュメント定義の名前です。
  • 受信するポート参照からキュー パス フィールドへのデータ フローを確立します。
  • メッセージ間のフローの記述

    注

    • [データ] タブをクリックします。

    • [データ] ページのポート参照メッセージで、応答メッセージを受信するポートのフィールドをクリックします。次に、そのフィールドの制御ハンドルを、初期メッセージのキュー パス フィールドの接続ポイントまでドラッグします。

      これにより、初期メッセージのキュー パス フィールドにポート参照データが挿入されます。ポート参照は、応答メッセージの受信に使用するポートの、静的キューのキュー パスです。


非 HTTP トランスポートを使用するための送信先システムの構成

ここでは、送信先システムがキュー パスを含むメッセージを受信し、同じキュー パスを含む応答メッセージを非 HTTP トランスポートを使用して送信元システムに送信するように、送信先システムを構成する方法について説明します。HTTP トランスポートを使用して応答メッセージを送信するように送信先システムを構成する場合は、「HTTP トランスポートを使用するための送信先システムの構成」を参照してください。

送信先システムの BizTalk メッセージ サービスが初期メッセージを受信する場合は、指定された XLANG スケジュールの新しいインスタンスをアクティブにして、その XLANG スケジュール インスタンス内の指定されたポートにメッセージを渡すように BizTalk メッセージ サービスを構成します。

XLANG スケジュールは、初期メッセージのキュー パス フィールドに格納されていたデータを応答メッセージ内の対応するフィールドに渡してから、BizTalk メッセージ サービス内のチャネルに応答メッセージを送信するように構成されます。

BizTalk メッセージ サービスは、指定されたチャネルを使用して、応答メッセージを処理し、メッセージ ポートに渡します。このメッセージ ポートは、送信元システムのある取引先との間で同意されているアドレスに応答メッセージをトランスポートするように構成されます。このメッセージ ポートをオープンなメッセージ ポートにすることはできません。

この送信先システムの構成を正しく機能させるには、取引先の送信元システムも正しく構成されている必要があります。送信元システムの構成については、「非 HTTP トランスポートを使用するための送信元システムの構成」を参照してください。

非 HTTP トランスポートを使用するように送信先システムを構成するには、次の表の設定を行います。関連項目では各手順を示し、注記では構成時の特別な注意事項を示します。構成を完了するのに必要な他のプロパティの設定は、特定の業務状態によって異なるため、ここでは指定していません。

設定 関連項目と注記
BizTalk エディタ
  • 初期メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • キュー パス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信元システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
  • 応答メッセージの処理に使用するチャネルの受信と送信のドキュメント定義の仕様を作成します。
  • 仕様の作成と検証

    注

    • キュー パス用に、これらの各仕様のフィールドを追加する必要があります。このフィールドはどのレベルにも追加できますが、その場所は取引先との間で同意されていて、取引先の送信元システムの仕様と一致している必要があります。詳細については、「レコードとフィールドの管理」を参照してください。
BizTalk メッセージ マネージャ
  • 送信元システムのある取引先を表す組織を作成します。
  • 組織の作成

    注

    • この組織に特別な構成は必要ありません。
  • 初期メッセージを処理するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 以前に作成された仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 応答メッセージを処理するチャネルを作成するのに必要なドキュメント定義を作成します。
  • ドキュメント定義の作成

    注

    • 以前に作成された仕様をドキュメント定義で選択します。詳細については、「ドキュメント仕様の選択」を参照してください。
  • 新しい XLANG スケジュール インスタンスをアクティブにするための、アプリケーションへのメッセージ ポートを作成し、その XLANG スケジュール インスタンス内のポートへ初期メッセージをトランスポートします。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先アプリケーション] ページで [新しい XLANG スケジュール] をクリックします。

    • [スケジュール モニカ] ボックスに、指定されたスケジュールのモニカを 入力するか、[参照] をクリックしてそのパスを設定します。

    • [ポート名] ボックスに、このスケジュールにあるドキュメントの特定の送信先ポートの名前を入力します。

      詳細については、「送信先アプリケーションのプロパティの設定」を参照してください。

      この手順を完了するには、XLANG スケジュールのパスと、初期メッセージが配信される XLANG スケジュール内のポートの名前が必要です。したがって、この表の後で説明するように、最初に XLANG スケジュールを作成し、そのポートを構成する必要があります。
  • 取引先からの初期メッセージを処理するための、組織からのチャネルを作成します。
  • チャネルの作成

    注

    • 使用するチャネル名と送信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
  • 応答メッセージを送信元システムへトランスポートするための、組織へのメッセージ ポートを作成します。
  • メッセージ ポートの作成

    注

    • メッセージ ポート ウィザードの [送信先組織] ページで [組織] をクリックします。[名前] ボックスの右側の [参照] をクリックします。

    • [組織の選択] ダイアログ ボックスで、送信元システムのある取引先を表す、以前に作成した組織を選択します。詳細については、「送信先組織の選択」を参照してください。

    • メッセージ ポート ウィザードの [送信先組織] ページで [プライマリ トランスポート] の [参照] をクリックします。

    • [プライマリ トランスポート] ダイアログ ボックスの [トランスポートの種類] ボックスの一覧でトランスポートの種類を選択し、[アドレス] ボックスにアドレスを入力します。

      トランスポートの種類とアドレスは、取引先との間で同意されていて、取引先の送信元システムの仕様と一致している必要があります。

    • オープンなメッセージ ポートを使用して応答メッセージを送信することはできません。
  • XLANG スケジュールからの応答メッセージを処理するための、アプリケーションからのチャネルを作成します。
  • チャネルの作成

    注

    • チャネル ウィザードの [送信元アプリケーション] ページで [XLANG スケジュール] をクリックします。詳細については、「送信元アプリケーションのプロパティの設定」を参照してください。

    • 使用するチャネル名と受信ドキュメント定義名を記録します。これらの名前は、BizTalk オーケストレーション サービスを構成するのに使用されます。
BizTalk オーケストレーション デザイナ
  • BizTalk メッセージ シェイプを使用して、初期メッセージを受信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [通信の方向] ページで [受信] をクリックします。

    • BizTalk メッセージ バインド ウィザードの [XLANG スケジュールのアクティブ化情報] ページで [はい] をクリックします。

    重要

    • [はい] を選択すると、メッセージの到着時に新しいスケジュール インスタンスをアクティブにするようにポートが構成されます。このオプションの使い方の詳細については、この手順の関連項目を参照してください。

      このポートに付ける名前と、コンパイルした XLANG スケジュールを保存する場所を記録します。この情報は、この表の後で説明するとおり、BizTalk メッセージ サービスのメッセージ ポートを構成するのに必要です。
  • アクション シェイプと、初期メッセージを受信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの送信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、応答メッセージの処理に使用するチャネルの送信ドキュメント定義の名前を入力します。

      BizTalk メッセージから XLANG スケジュールに渡されるすべてのメッセージは、メッセージ キューを使用します。これらのメッセージのラベルは、チャネルの送信ドキュメント定義の名前です。

    • [メッセージ仕様情報] ページの [参照] をクリックし、初期メッセージのチャネルの送信ドキュメント定義に使用する仕様を参照します。

    • [メッセージ フィールド] の [追加] をクリックし、初期メッセージのキュー パス アドレスを格納するために作成した仕様のフィールドを追加します。
  • BizTalk メッセージ シェイプを使用して、返信メッセージを送信するポートを実装します。
  • BizTalk メッセージを使用したポートの実装

    注

    • BizTalk メッセージ バインド ウィザードの [静的または動的チャネルの情報] ページで [静的チャネル] をクリックし、[既存のチャネル名を入力してください] ボックスに応答メッセージの処理に使用する BizTalk メッセージ マネージャ内のチャネルの名前を入力します。

    • このポートは静的チャネルを使用するので、BizTalk メッセージへのオープンな送信先への送信の呼び出しは行われません。したがって、指定されたチャネルをオープンなメッセージ ポートに関連付けることはできません。
  • アクション シェイプと、応答メッセージを送信するポートとの間の通信フローを確立します。
  • 非同期メッセージの送信と受信

    注

    • XML 通信ウィザードの [メッセージ情報] ページで [新しいメッセージの作成] をクリックし、[メッセージ名] ボックスにメッセージの名前を入力します。

      任意の名前を使用できますが、チャネルの受信ドキュメント定義の名前を使用すると、送信中のメッセージをより明確にすることができます。

    • [メッセージの種類の情報] ページの [メッセージの種類] ボックスに、メッセージを処理するのに使用するチャネルの受信ドキュメント定義の名前を入力します。

    • [メッセージ仕様情報] ページの [参照] をクリックし、仕様を参照します。この仕様は、応答メッセージの処理で使用されるチャネルの受信ドキュメント定義で使用されます。

    • [メッセージ フィールド] の [追加] をクリックし、応答メッセージのキュー パス アドレスを格納するために作成した仕様のフィールドを追加します。
  • 初期メッセージ内のキュー パス フィールドから応答メッセージ内のキュー パス フィールドへのデータ フローを確立します。
  • メッセージ間のフローの記述

    注

    • [データ] タブをクリックします。

    • [データ] ページで、初期メッセージ内のキュー パス フィールドをクリックします。次に、そのフィールドの制御ハンドルを、応答メッセージ内のキュー パス フィールドの接続ポイントまでドラッグします。

      これにより、初期メッセージから応答メッセージへキュー パス データが渡されます。


BizTalk Server 2002 Developer Solutions

You can programmatically integrate applications with Microsoft® BizTalk™ Server 2002 by using the BizTalk Messaging Configuration object model, or by extending and customizing the functionality of the server to suit your business and information-exchange needs. The developer solutions provide all the information necessary for Microsoft Visual Basic® and C++ developers to use or extend BizTalk Server 2002. This section also includes a complete list of interfaces, objects, enumerations, code samples, and possible error messages.

BizTalk Server 2002 supports programmatic application integration by accessing the BizTalk Messaging Configuration object model and submitting documents by calling the methods of the IInterchange interface. BizTalk Server 2002 also supports the use of extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server 3.0, Commerce Edition.

Developer Solutions is divided into the following sections:

BizTalk Messaging Services

This section provides information about how to access the BizTalk Messaging Configuration object model, including all the reference pages for the supported interfaces. This information is provided for both C++ and Visual Basic developers. For more information, see BizTalk Messaging Services.

BizTalk Documents

This section covers submitting documents to BizTalk Server 2002, using the synchronous and asynchronous methods of the IInterchange interface. It shows how to move a document after the trading partner relationships are set up, and how to track documents moving through BizTalk Server 2002. For more information, see BizTalk Documents.

BizTalk Custom Components

This section covers BizTalk Server 2002 support for extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server 3.0, Commerce Edition.

This allows developers to do the following:

  • Enable business applications to receive business documents by using AICs.

  • Extend the functionality of BizTalk Server 2002 by developing components to perform digital signatures and verification, encryption and decryption, parsing, and transport.

For more information, see BizTalk Custom Components.

BizTalk Orchestration Services

This section provides information about the interfaces that can be used to access a running instance of a specific XLANG schedule, or to perform system-wide administrative tasks in the XLANG Scheduler run-time environment. This information is provided for both C++ and Visual Basic developers. For more information, see BizTalk Orchestration Services.

BizTalk Managing and Monitoring

This section covers the Windows Management Instrumentation (WMI) classes that allow you to perform administrative functions that support the management of systems in an enterprise. This information is provided for C++, Visual Basic, and Visual Basic Scripting Edition (VBScript) developers. For more information, see BizTalk Managing and Monitoring.

BizTalk Server Developer's Toolbox

This section provides code solutions to problems commonly encountered by developers working with BizTalk Server. For more information, see BizTalk Server Developer's Toolbox.

BizTalk Server Samples

This section provides documentation and instructions for running the samples included in the BizTalk Server SDK. For more information, see BizTalk Server Samples.

BizTalk Server Reference

This section documents the BizTalk Server application programming interfaces (APIs) and error messages. For more information, see BizTalk Server Reference.


BizTalk Messaging Services

This section provides information about how to access the BizTalk Messaging Configuration object model programmatically. It shows how to manage trading partner relationships and set up messaging ports and channels for the exchange of data, using Microsoft® BizTalk™ Server 2002. This section also shows how to create document definitions and envelopes, and how to set organization properties. For additional information, see the following sections:

  1. For introductory information about the BizTalk Messaging Configuration object model, see Introducing Messaging Services.

  2. For general background information, see Understanding Messaging Services.

  3. For information about COM interfaces, enumerations, and error messages, see the Messaging Services Reference.

  4. For examples of code, see BizTalk Messaging Services Code Samples.

The BizTalk Messaging Configuration object model can also be configured by using the BizTalk Messaging Manager graphical user interface. For more information, see Using BizTalk Messaging Manager.


Introducing Messaging Services

The BizTalk Messaging Configuration object model provides an easy way for applications to set up, maintain, and retrieve messaging ports and channels for trading partner relationships and application-to-application integration. The BizTalk Messaging Configuration object model can also create envelopes and document definitions, and set organization properties.

The BizTalk Messaging Configuration object model uses a Structured Query Language (SQL) database to store the port configurations and other relational data. ActiveX® Data Objects (ADO) recordsets are returned when querying for lists of object instances (for example, messaging ports or organizations).

The BizTalk Messaging Configuration object model consists of Component Object Model (COM) objects that expose the configuration data required for Microsoft BizTalk Server 2002 to configure the interchange of structured documents between applications and trading partners. The COM objects represent instances of data in memory that can be stored in the database.

All object properties are read/write, except where noted.

Related Topics

Messaging Configuration Objects

Referential Integrity

Security


Messaging Configuration Objects

The following table shows the objects of the BizTalk Messaging Configuration object model.

Object | Description
IBizTalkChannel | Contains the configuration related to the source entity and its binding with an IBizTalkPort object.
IBizTalkConfig | Creates and retrieves other BizTalk objects, such as channels, document specifications, and messaging ports.
IBizTalkDocument | Identifies and describes the specification of a document.
IBizTalkEnvelope | Identifies the envelope format and/or the envelope schema used for documents. Envelopes are required for documents using the X12 or EDIFACT format.
IBizTalkOrganization | Identifies the source or destination point for the exchange of electronic data. An organization can represent an external trading partner, your own company, or a business unit of a trading partner or your company. An organization can designate a source application in a channel or a destination application in a port.
IBizTalkPort | Defines the destination-related attributes of a document submission.
IBizTalkPortGroup | Configures a port group. This is a group of complete IBizTalkPort objects for sending the same document, such as a catalog, a price list, or a newsletter, to a group of trading partners.

Caution

  • Do not access the database directly. Do not directly call the stored procedures. Make all changes to the database by using the methods and properties of the BizTalk Messaging Configuration object model. Making changes to the database directly bypasses many constraints enforced by the BizTalk Messaging Configuration object model and either causes the server to function incorrectly or corrupts the database.

  • The BizTalk Messaging Configuration object model should be accessed only at design time. Accessing objects in use while BizTalk Server is processing documents can produce unexpected results.

  • BizTalk Server 2002 treats all variables with a BSTR data type as NULL-terminated strings. Any data contained in a BSTR after the NULL character is ignored. Documents containing embedded NULL characters must be submitted to BizTalk Server by using pass-through mode.

Related Topics

Channels

Document Definitions

Envelopes

Messaging Ports

Organizations


Referential Integrity

Referential dependency must be considered when instantiating objects in BizTalk Server 2002. Referential dependency indicates that one object refers to, and is dependent upon, another object. For example, an IBizTalkChannel object refers to an IBizTalkPort object.

To maintain referential integrity, an object instance cannot be deleted if it is referred to by another object instance. Referential integrity is maintained when the object that is referred to exists in the database.

Remove objects from the database in the reverse order of their creation. If an object instance that is referred to by another object instance is removed, a constraint error is returned. Using the preceding example, a constraint error is returned if an IBizTalkPort object that is being used by an IBizTalkChannel object is removed.

The following sequence shows the preferred order for creating objects to maintain the referential integrity of the objects:

  1. IBizTalkOrganization

  2. IBizTalkDocument

  3. IBizTalkEnvelope (if required)

  4. IBizTalkPort
    • The IBizTalkPort object requires the IBizTalkOrganization object.

    • The IBizTalkPort object conditionally uses the IBizTalkEnvelope object.
  5. IBizTalkChannel
    • The IBizTalkChannel object requires the IBizTalkPort object.

    • The IBizTalkChannel object requires the IBizTalkDocument object.

    • The IBizTalkChannel object requires the IBizTalkOrganization object.

    • The IBizTalkChannel object conditionally uses the IBizTalkPortGroup object if the channel is created for port groups.
  6. IBizTalkPortGroup (if used)
    • The IBizTalkPortGroup object requires the IBizTalkPort object.


Security

When accessing or creating objects in the BizTalk Messaging Configuration object model, the script or application must be run in the context of a user account in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2002 is installed. Additional users can be added to this group as necessary. For additional information, see Add users to the BizTalk Server Administrators group.


Understanding Messaging Services

This section provides detailed conceptual information that is important to understanding how to access the BizTalk Messaging Configuration object model. The following topics are covered in this section:

  • Channels

  • Messaging Ports

  • Openness

  • Organizations

  • Document Definitions

  • Envelopes

  • Certificates

For information about code samples that use the BizTalk Messaging Configuration object model, see BizTalk Messaging Services Code Samples.


Channels

The IBizTalkChannel object contains the configuration information related to the source entity and its binding with an IBizTalkPort object. When BizTalk Server 2002 receives a document, a specific IBizTalkChannel object, along with the properties configured in its associated IBizTalkPort object or an associated IBizTalkPort object within an IBizTalkPortGroup, directs the server through the steps necessary to process that document. Note that multiple channels might be bound to the same IBizTalkPort object. This represents multiple source entities that exchange documents with the same destination.

The IBizTalkChannel object identifies the map used for document transformation if the type of the input IBizTalkDocument object is different from the type of the output IBizTalkDocument object. It also points to the specification that contains fields for BizTalk document tracking and selects the type of logging desired.

The following topics are covered in this section:

  • Identification

  • Document Processing

  • Configuring

  • Channel Filtering

  • Document Storage

  • Document Tracking


Identification

BizTalk Server 2002 determines the appropriate IBizTalkChannel object for processing the input document by one of the following methods:

  • The source organization identifier, qualifier, and value; the destination organization identifier, qualifier, and value; and the name of the IBizTalkDocument object are parameters of the Submit or the SubmitSync method of the IInterchange object.

  • The source and destination organization identifiers, qualifiers, and values; and the name of the IBizTalkDocument object are specified in the header fields of the document instance.

  • The name of the IBizTalkChannel object is a parameter of the Submit or the SubmitSync method call.

When BizTalk Server 2002 receives a document, it first identifies all IBizTalkChannel objects that support the specified IBizTalkDocument object. The server then looks up each IBizTalkPort object and determines if the source organization and destination organization properties identify the source and destination IBizTalkOrganization objects specified by the organization identifiers in the document or in the parameters of Submit when the document is submitted. This includes any open messaging ports that match either the specified source organization or the destination organization.

This identification process can be bypassed by specifying the name of an IBizTalkChannel object to be used as a parameter of Submit or SubmitSync.

Related Topic

Submitting


Document Processing

When BizTalk Server 2002 identifies an IBizTalkChannel object, the server processes this object, which directs the server in the steps to process the document. To direct the server, the IBizTalkChannel object follows its own rules and the rules of its associated IBizTalkPort object.

An input IBizTalkDocument object is related to an output IBizTalkDocument object by an IBizTalkChannel object. The IBizTalkPort object must be created before an associated IBizTalkChannel object can be created.

When BizTalk Server 2002 processes an IBizTalkChannel object, the server calls upon each associated IBizTalkPort object to provide the document-processing rules needed by the server. The rules set by the properties of the IBizTalkChannel object direct the server in the initial steps of document processing, such as determining which input and output IBizTalkDocument objects to use, which map file to use, and what fields to track. After a document is in its final output format, the properties of the IBizTalkPort object direct the server in the steps to prepare and transport the document according to the rules agreed to by the source and destination organizations.

When a document is submitted, the server can identify multiple IBizTalkPort and IBizTalkChannel objects that match the source organization, the destination organization, and the specified IBizTalkDocument object. Therefore, it is possible for one input document to generate multiple output documents. It is also possible for each output document to be transmitted to a different location by using different transport properties in the matching IBizTalkPort objects, and for each output document instance to include a different subset of data from the original input document by using different map files.


Configuring

An IBizTalkChannel object consists of the internal document processing data for the specified input and output IBizTalkDocument objects. To be fully configured, an IBizTalkChannel object must have one complete IBizTalkPort object identified by its Port property. Input and output IBizTalkDocument objects must be specified. After the InputDocument and OutputDocument properties are selected for use in this IBizTalkChannel object, an IBizTalkPort object or an IBizTalkPortGroup object must be selected.

The name of an IBizTalkChannel object must be unique across the database for all objects of its type.

The following properties are required before an IBizTalkChannel object can be saved:

  • InputDocument

  • Port (or PortGroup)

  • OutputDocument

  • Name

After an IBizTalkChannel object has been created or saved, only the following properties can be changed:

  • Comments

  • ControlNumberValue

  • MapReference

  • Name

  • TrackFields


Channel Filtering

Channel filtering enables the user to build a filtering expression to select an IBizTalkChannel object for processing a document instance. The server uses these expressions to select the correct IBizTalkChannel object. The Expression property contains an XPath expression that evaluates to a Boolean value. If the expression evaluates to true, the channel is used to process the document. Otherwise, the channel is not invoked to process the document.

XPath expressions can be used to obtain the value of a specific element, attribute, or collection of these items within an XML document. Consider the following XML document:

<INVOICE>

<DATE>12/31/2000</DATE>

<BILLTO>Blue Yonder Airlines</BILLTO>

<SUMMARY>

<ITEM PARTNUMBER="10001" QUANTITY="10"/>

<ITEM PARTNUMBER="20002" QUANTITY="20"/>

<TOTAL VALUE="550"/>

</SUMMARY>

</INVOICE>

Based on this document, the following XPath expression can be created to ensure that this channel only processes invoices that exceed $500:

myChannel.Expression = "/INVOICE/SUMMARY/TOTAL[@VALUE>""500""]"

In this example, the channel would process the XML document instance because the total is greater than $500. For more information about XPath expressions, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Note

  • You can use BizTalk Messaging Manager to generate XPath channel filtering expressions. For more information, see Add a channel filtering expression.


Document Storage

You can choose how to log the activity of a document instance by using the IBizTalkLoggingInfo object. The default is to log the document in its native form.

For document storage, you have the options shown in the following table.

Property | Description
All properties empty | Store no copies of the document.
LogNativeInputDocument | Store input native format (default setting).
LogNativeOutputDocument | Store output native format.
LogXMLInputDocument | Store input XML format.
LogXMLOutputDocument | Store output interim (XML) format.
Any combination of these choices | Store the options as described above.

Note

  • There is a size limit for interchanges and documents that use logging, which if exceeded greatly affects the performance of BizTalk Server. For more information about the size limit, see Interchange and document size limit.


Document Tracking

An IBizTalkChannel object points to the specification that contains fields to track the instance of the document. The designated fields are logged to the Tracking database for each instance of a document that is processed. When you assign an input IBizTalkDocument object for an IBizTalkChannel object, you can designate fields to track within the document on this channel.

When BizTalk Server 2002 runs an IBizTalkChannel object, it uses the input IBizTalkDocument object to process an input document. The fields that you have designated for tracking are captured and logged for each instance of that document. Any fields designated for tracking in the output IBizTalkDocument object of the associated IBizTalkChannel object are ignored. To retrieve the information that is tracked during document processing, use the methods of the IBizTalkTrackData object.

By logging important data from the input documents that are processed, you can track and analyze detailed information about your operation. For example, an invoice-total field can be logged for every invoice that is sent to your trading partners. You can then determine the total dollar amount of invoices sent to all trading partners over time or determine the total dollar amount of invoices to each individual trading partner.

For additional information about document tracking, see Understanding the Tracking Database Schema.


Messaging Ports

Conceptually, a messaging port is a set of rules that trading partner organizations accept for sending documents to one another. It includes information regarding the destination, transport type, security, and envelope. It identifies the source and destination IBizTalkOrganization objects and the source and destination aliases. It also identifies any applications associated with the organization, if applicable.

An IBizTalkPort object identifies a specific destination organization unless it is designated as an open messaging port, in which case the destination organization is not specified. For open messaging ports, the IBizTalkPort object is valid only if the associated document or the parameters on the Submit or the SubmitSync method of the IInterchange object contain the destination transport and address information.

The IBizTalkPort object also identifies delimiter definitions and the EDI interchange control number. Delimiters are used to separate the records and fields of the envelope and the documents within the envelope. An interchange control number is used to identify and track documents that are sent using the envelope. The interchange control number is incremented with each use of the envelope at run time.

An IBizTalkPort object also identifies the encoding, encryption, and signature type, if required.

Note

  • After an IBizTalkPort object has been created and saved, the destination organization and the openness associated with the endpoint cannot be changed.

Related Topics

Openness

Port Groups


Port Groups

The IBizTalkPortGroup object configures a group of complete IBizTalkPort objects for sending the same document to a group of trading partners. For example, you can use this when you want to send a document, such as a catalog, a price list, or a newsletter, that contains identical data to a group of trading partners. One document is sent to a list of partners by calling a single Submit method on the IInterchange object.

The IBizTalkPortGroup object must contain at least one IBizTalkPort object. You can add or remove IBizTalkPort objects to or from an IBizTalkPortGroup by calling the AddPort or the RemovePort method.

An IBizTalkPortGroup object must be associated with at least one IBizTalkChannel object. After the port group has been created, associate a channel with the port group by using the PortGroup property available on the IBizTalkChannel object. When BizTalk Server 2002 invokes a channel related to a port group, it invokes only the channel that is associated with the port group to process the data. None of the channels that are associated with the individual ports in the port group are invoked. The server uses the properties of each port successively to transport the data to the destinations specified in the ports.

Notes

  • Open messaging ports cannot be added to a port group.

  • BizTalk Messaging Manager refers to port groups as distribution lists.

Related Topic

Submitting


Openness

The Openness property of the IBizTalkEndPoint object determines whether the messaging port or channel is open. An open IBizTalkPort object is a messaging port without a specified destination. An open IBizTalkChannel object is a channel without a specified source. The missing information for an open messaging port or channel must be supplied by the associated document or by the parameters on the Submit or the SubmitSync method of the IInterchange object.

If an open channel is specified by using BIZTALK_OPENNESS_TYPE_EX_SOURCE or an open messaging port is specified by using BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Usage, Reference, and Store properties cannot be specified on the IBizTalkCertificateInfo object.

Note

  • If an open messaging port is used with the SMTP transport type, the value specified for the IBizTalkOrganization identifier Reliable Messaging Acknowledgement SMTP From Address is used as the From address.

Related Topic

Submitting


Organizations

IBizTalkOrganization objects serve as sources or destinations for the exchange of electronic data. An organization can represent an external trading partner, your own company, or a business unit of a trading partner or your company. The home organization can designate a source application in a channel or a destination application in a messaging port.

Applications are properties of the home organization. An applications can be designated as a source application in an IBizTalkChannel object or as a destination application in an IBizTalkPort object.

Aliases

An alias is an organization identifier for the IBizTalkOrganization object. An IBizTalkOrganization object must always have one and only one default alias, but it can have multiple aliases. An alias is autogenerated for each IBizTalkOrganization object. The default alias and the autogenerated alias cannot be removed.

For more information, see Create and Manage Organizations.


Document Definitions

The IBizTalkDocument object describes and identifies the document specification used to describe the document sent or received. The document specification defines the structure of a document, as well as any validation rules and descriptions for the individual elements of the document specification. The IBizTalkDocument object includes the version and type of the specification and, optionally, a reference to the Web Distributed Authoring and Versioning (WebDAV) location of the specification. For more information about document specifications, see Create and Validate Specifications.

Notes

  • The document Content and NameSpace properties are not valid until you set the Reference property.

  • When creating a new IBizTalkDocument object that uses a namespace that is already registered with BizTalk Server, the new document inherits the Reference property of that namespace. The namespace must be unique (case insensitive) for a new Reference to be created.

The IBizTalkDocument object also contains the electronic data interchange (EDI) selection criteria by which BizTalk Server 2002 extracts information from the functional group header of the document to identify this object when the name of the IBizTalkDocument object is not available.

An IBizTalkDocument object points to the specification that contains fields to track the instance of the document. The designated fields are logged to the Tracking database for each document that is processed.

Selection criteria

For some EDI input interchanges, documents are contained within functional group envelopes. When BizTalk Server 2002 processes such documents, it cannot obtain the name of the IBizTalkDocument object from a field within each document. Also, because there are multiple types of documents involved, a single name cannot be specified as a parameter of the Submit method of the IInterchange object. In such cases, the server can locate document-related data within the functional group header (for example, in the GS header of an X12 interchange). By comparing this data to matching selection criteria specified in the PropertySet property on the IBizTalkDocument object, the server can uniquely identify an IBizTalkDocument object. After the IBizTalkDocument object is identified, the server can obtain the name and then identify and instantiate the appropriate IBizTalkChannel object.

Selection criteria also help BizTalk Server 2002 create the header of the EDI document when it is output.

Global tracking

An IBizTalkDocument object points to the specification from which fields can be selected for tracking. The designated fields in the input document specification are tracked for each document that is processed using that specification. Any fields designated for tracking in the output document specification are ignored. If an IBizTalkChannel object that specifies tracking fields is used with an input document specification containing fields designated for tracking, only the fields specified by the channel are used for tracking.

By logging important data from the input documents that are processed, you can track and analyze detailed information about your operation. For example, an invoice-total field can be logged for every invoice that is sent to your trading partners. You can then determine the total dollar amount of invoices sent to all trading partners over time or determine the total dollar amount of invoices to each individual trading partner.

Related Topics

Document Storage

Document Tracking


Envelopes

The IBizTalkEnvelope object consists of two pieces of information:

  • The type of envelope is specified in the Format property. The document Type should match the envelope Format for "flatfile", "custom xml", "x12", "edifact", and "reliable" document types.

  • The actual envelope file used is specified in the Reference property.

Input document envelopes

An envelope is required if the input document Type is "flatfile" because the envelope contains information about how to parse the document into XML and which parser should process the document. Input "flatfile" documents without an envelope are not processed. For all other input document types, an envelope is optional.

Output document envelopes

Envelopes are used to wrap an output document instance that has been transformed into the native format. The envelope used with an output document is specified on the IBizTalkPort object. An envelope is required if the output document Type is "x12" or "edifact". However, the Reference property is ignored for these format types because indicating that a document is X12 or EDIFACT is sufficient to serialize the document. For output documents with a Type of "custom xml", the Reference property is used if specified. If the Reference property is not specified, "custom xml" documents are submitted for processing in the transformed XML format.

Notes

  • Multiple IBizTalkPort objects can refer to an envelope.

  • The envelope Content and NameSpace properties are not valid until you set the Reference property.

  • When creating a new IBizTalkEnvelope object that uses a namespace that is already registered with BizTalk Server, the new document inherits the Reference property of that namespace. The namespace must be unique (case insensitive) for a new Reference to be created.


Certificates

An IBizTalkCertificateInfo object is automatically created when an IBizTalkPort or an IBizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the IBizTalkConfig object.

For output documents, access the IBizTalkCertificateInfo object by using the EncryptionCertificateInfo property of the IBizTalkPort object. For input documents, access the IBizTalkCertificateInfo object by using the SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo property of the IBizTalkChannel object. To obtain the set of all existing IBizTalkCertificateInfo objects, use the Certificates property of the IBizTalkConfig object.

Note

  • All certificates are stored in the local computer store. To configure certificates for the S/MIME components, the script or application accessing the object model must be run in the context of a user account in the BizTalk Server Administrators group.


BizTalk Documents

This section provides information about how to submit documents to Microsoft BizTalk Server 2002. For additional information, see the following sections:

  1. For help with specific tasks, see Using Documents.

  2. For general background information, see Understanding Documents.

  3. For information about COM interfaces and enumerations, see the Documents Reference.

  4. For examples of code, see BizTalk Messaging Services Code Samples.


Understanding Documents

This section provides detailed conceptual information that is important to understanding how to submit documents to Microsoft® BizTalk™ Server 2002. The following topics are covered in this section:

  • Submitting

  • Routing


Submitting

All documents must be sent to Microsoft BizTalk Server 2002 by using the Submit or SubmitSync method of the IInterchange interface in order to be processed. If an application is based on Microsoft Windows® and is capable of invoking methods on COM objects, it can submit a document directly. The business application calls the Submit or SubmitSync method of the IInterchange interface, passing in the document or the file path of the document as a string supplied as a parameter. This is the simplest approach because no additional configuration is necessary. However, this method requires that the business application be designed to support direct calls to BizTalk Server 2002.

If the application is not capable of invoking methods on COM objects, receive functions can be used to submit documents to BizTalk Server. Receive functions enable applications to post documents or interchanges to specific locations that BizTalk Server 2002 is monitoring. These locations are defined according to the specific receive function. Each receive function uses event-based monitoring to recognize the presence of a document or interchange. After the data is received by the function, it submits the data to BizTalk Server. For example, a File receive function can be configured to submit a document to BizTalk Server when the business application can save a document as a file but cannot submit it directly. For more information about adding and configuring receive functions, see Manage Receive Functions for a Server Group.

The receive functions are configured to continuously monitor a specific directory or queue for a file to appear and then be submitted to BizTalk Server. HTTP and SMTP protocols are configured outside BizTalk Server. You must create script pages for these transport services.

Notes

  • There is a size limit for interchanges and documents that use logging, which, if exceeded, greatly affects the performance of BizTalk Server. For more information about the size limit, see Interchange and document size limit.

  • A script or application that uses the IInterchange interface to submit documents to BizTalk Server can be run in any user account.

  • When processing envelopes that are compliant with BizTalk Framework 2.0, BizTalk Server should be considered the endpoint with regard to the expiration time. When BizTalk Framework 2.0-compliant documents are submitted to BizTalk Server, either from an application or from a trading partner, the following fields are overwritten if present, or created if absent:
    • In the properties subsection:

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • In the receipt information subsection:

      <sendTo>

      <address>

      <sendReceiptBy>

For examples of code, see BizTalk Messaging Services Code Samples.

Sending documents to BizTalk Server 2002 asynchronously

Applications that submit documents asynchronously to BizTalk Server call Submit. Receive functions also call Submit. Submit returns after sending the document. No response document is returned, because the protocol does not support it.

Submit accepts only a string buffer or a file path as the document or interchange. BizTalk Server supports Universal Naming Convention (UNC) and local file path formats.

Sending documents to BizTalk Server 2002 synchronously

Applications that submit documents synchronously to BizTalk Server call SubmitSync.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols, an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

SubmitSync accepts only a string buffer or a file path as the document or interchange. BizTalk Server supports UNC and local file path formats.

Error handling with the Submit and SubmitSync methods

When an error occurs when submitting interchanges or documents to BizTalk Server, an event log entry is created and/or an error is returned to the caller, depending on which method is called and the nature of the failure. Documents submitted can end up in the Suspended queue due to a number of possible conditions. The following table describes what happens when one or more of the documents or interchanges submitted are placed in the Suspended queue due to an error during submission.

Method called | Error returned to caller | Event log entry
Submit | Document failure error | For every document that fails in processing
SubmitSync | Document failure error | None

Related Topics

Routing

Submitting a Document

Documents Reference


Routing

To process a document, Microsoft BizTalk Server 2002 must load the rules that govern how the incoming document instance is to be processed. These rules are known as the channel. A specific IBizTalkChannel object is associated with an IBizTalkPort object and connects two organizations.

To find the channel to process the received document, the server must have the source organization, the destination organization, and the document definition. The server can obtain this information by one of the following methods:

  • This information can be found in the content of the document itself from the data contained in the routing fields (self-routing documents).

  • This information can be explicitly declared in the parameter list of the Submit method of the IInterchange interface (call-based routing).

  • This information can be explicitly declared in the properties of a custom receive function. For more information about receive functions, see Understanding Receive Functions and Document Routing.

  • You can choose to specify the channel to use when calling Submit. This causes the server to bypass the channel selection process.

After the server has this information, it searches for the messaging port/channel pair that matches these routing criteria. If more than one channel matches, each of the channels is processed, possibly resulting in multiple output documents.

Call-based routing

In call-based routing, the source organization identifier (SourceID), the destination organization identifier (DestID), and the name of the document definition (DocName) are specified as parameters of Submit. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. If the Openness flag is set to OpenDest, the DestID is used as the destination address. If SourceID, DestID, or DocName is left blank, the missing information must be provided by the routing information contained within the document. If one of these parameters/fields is not in Submit or in the document, the document goes to the Suspended queue.

Note

  • Note that the queue:// prefix must be used with an open messaging port when a message queue is specified as the destination address.

Self-routing documents

Self-routing documents have the source organization identifier (SourceID), the destination organization identifier (DestID), and the name of the document definition (DocName) defined in the routing tags defined by the document specification, which are contained within the <SelectionFields> tag. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The BizTalk Framework specification also defines the routing tags for BizTalk Framework–compliant messages. These tags are defined as the <to> and <from> tags under the <endpoint> tag, which is contained in the <header> tag under the root <biztalk> tag. The first tag under the <body> tag determines the document type. For more information, see the BizTalk Framework 2.0 Independent Document Messaging Specification. For X12 or EDIFACT routing, the locations of the routing fields are hard-coded and are not specified in a document specification.


Using Documents

This section provides task-specific information about how to submit documents to Microsoft BizTalk Server 2002. It is highly recommended that you review the Understanding Documents topic as well.

The following topics are covered in this section:

  • Submitting a Document

  • Submitting a Document from a Remote Client

  • Reading the Tracking Database

  • Preprocessing Documents in a Receive Function

  • Accessing the Suspended Queue


Submitting a Document

Use the following steps as a guideline when submitting documents to Microsoft BizTalk Server 2002 with the IInterchange interface.

  1. Determine whether the source organization, destination organization, and document definition name are in the parameters of the Submit or the SubmitSync method of the IInterchange interface or are included in the document; it might be a combination of the two.
    • This information can be explicitly declared in the parameter list of Submit or SubmitSync (call-based routing).

      One or more of these parameters can be left blank and the missing information can be provided by the routing information contained within the document.

    • This information can be found in the content of the document itself from the data in the routing fields (self-routing documents).

    • The user can choose to explicitly call out the specific channel to use when calling Submit. This causes the server to bypass channel selection.

    • This information can be explicitly declared in the properties of a custom receive function.
  2. Decide whether to submit asynchronously or synchronously.
    • Call Submit, passing in the document or the file path of the document as a string supplied as a parameter. BizTalk Server supports URL, UNC, and drive: format for the file path.

      Submit accepts only a string variable as the document or interchange.

    • Call SubmitSync, passing in the document or the file path of the document as a string supplied as a parameter.
      • A response document is returned to the user, if available.

      • This method is valid only for a single channel match.

      • This method can be used only for single-document interchanges.
  3. Decide whether to call some of the Suspended queue methods. (This is optional and can be implemented in the same application or in a different application.)
    • Call the CheckSuspendedQueue method of the IInterchange interface.
      • Retrieve items from the Suspended queue.

      • This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.
    • Call GetSuspendedQueueItemDetails.

      Retrieve the details about a particular item in the Suspended queue.

    • Call DeleteFromSuspendedQueue.

      Remove items from the Suspended queue.


Submitting a Document from a Remote Client

A document can be submitted to Microsoft BizTalk Server 2002 from a remote client running an application that uses the IInterchange interface. To accomplish this, follow these steps:

  1. Using a computer that has Microsoft BizTalk Server 2002 installed, go to the Start menu, point to Programs, point to Administrative Tools, and then click Component Services.

  2. In the tree pane, click Component Services, expand Computers, expand My Computer, expand COM+ Applications, and then click BizTalk Server Interchange Application.

  3. On the Action menu, click Export.

  4. In the Welcome to the COM Application Export Wizard dialog box, enter the name of an export installation package to be created.

  5. In the Export as area, click the Application proxy option and click Next to finish the wizard.

The COM Application Export Wizard creates a Windows Installer Package file with an .msi extension and its associated cabinet file with a .cab extension. Copy these files to the remote client and run the Windows Installer Package file. Now the remote client can run applications that use the IInterchange interface.

Notes

  • The remote client must be running Microsoft Windows 2000.

  • The computer used to create the installation package acts as an "interchange server" for the remote client that is submitting documents. Therefore, all documents submitted on the remote client are routed through that server.

  • You can also create a remote client during the BizTalk Server 2002 installation.


Reading the Tracking Database

The purpose of the tracking interface, IBizTalkTrackData, is to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2002. This complements the IInterchange interface so that returns from IInterchange calls can be fed to the IBizTalkTrackData methods to access data about the activity of documents submitted to BizTalk Server 2002.

There can be a one-to-one or a one-to-many relationship between input and output documents. In a normal document flow, one document is submitted to the server, is tracked and possibly transformed, and one document results as output from the server. However, the messaging port can be configured so that one document submitted can result in many documents as output to several destinations.

To read and use information from the Tracking database, perform the following steps:

  1. Get the SubmissionHandle return from the Submit method of the IInterchange interface.

  2. Call the GetInterchanges method, using the SubmissionHandle return as the input. This method returns a list of interchanges contained in that submission, including all the data from the Tracking database. Because transport-specific information (delivery times, receipt flags, and so on) appears in the interchange data, you can look here to confirm or check status on delivery, for example.

  3. Call the GetInDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were included in that submission. You can look here to find information about an input document (whether a document was valid, how many bytes it contained, and so on).

  4. Call the GetOutDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were generated as a result of the submission. You can look here to find information about an output document (for example, looking for PO #123456 from a submission made earlier today).

Related Topic

Documents Reference


Preprocessing Documents in a Receive Function

Documents can be submitted to Microsoft BizTalk Server 2002 for processing by using a receive function. Using this mechanism, other applications can send their output files to a specified directory or message queue. BizTalk Server continually monitors the specified location at regular intervals and processes the files or messages placed in that location. BizTalk Server provides interfaces that allow you to create custom preprocessing components. These components process the file or message picked up by the receive function prior to submitting the data to BizTalk Server for processing.

A custom preprocessor component is required to implement the category identifier (CATID) CATID_BIZTALK_CUSTOM_PROCESS in the registry. This allows the BizTalk Server Administration user interface, or administration console, to recognize the custom preprocessor and display it in the Preprocessor list, where it can be selected.

For additional information, see IBTSCustomProcess and IBTSCustomProcessContext.

Transaction Support

If a preprocessing component supports transactions, you must explicitly enable transaction support for that component. To enable transactions with custom preprocessor components, add a registry key by following these steps:

  1. Open the registry editor.

  2. Find the custom component in the registry.

  3. Right-click the component.

  4. Click New and then click DWORD Value.

  5. In the Name field, type UseTxForCustPreProcessor.

  6. Double-click the new UseTxForCustPreProcessor key.

    The Edit DWORD Value dialog box appears.

  7. In the Value data field, type 1.

  8. Click OK.

Related Topics

BizTalk Server Administration User Interface

Receive Functions


Accessing the Suspended Queue

The Suspended queue contains work items that have failed processing for a variety of reasons, including parsing errors, serialization errors, failed transmissions, or the inability to find a channel configuration. You can retrieve or delete items from the queue using the interfaces provided.

Note

  • When accessing or deleting items in the Suspended queue, the script or application must be run in the context of a user account in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2002 is installed. Additional users can be added to this group as necessary.

Retrieving items from the Suspended queue

To retrieve items from the Suspended queue, applications call the CheckSuspendedQueue method of the IInterchange interface.

CheckSuspendedQueue retrieves a list of items in the Suspended queue that meet the search criteria specified by the parameters of the method. This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.

Getting item details from the Suspended queue

CheckSuspendedQueue returns a list of handles to items in the Suspended queue. To process these items, you must get the item details associated with each item in the Suspended queue by using GetSuspendedQueueItemDetails.

GetSuspendedQueueItemDetails retrieves the details about an item in the Suspended queue. If this method does not return individual details about this item (because the item has been removed between the time CheckSuspendedQueue was called and the call to this method, for example), each parameter that cannot be determined is returned.

Removing items from the Suspended queue

To remove items from the Suspended queue, applications call DeleteFromSuspendedQueue.

DeleteFromSuspendedQueue removes from the Suspended queue a list of items that meet the search criteria specified by the parameters of the method.


BizTalk Custom Components

This section provides information about how to create custom components and extend Microsoft® BizTalk™ Server 2002 to integrate line-of-business applications and to add features such as encryption and decryption or digital signature. With this information, you can do the following:

  1. Create application integration components (AICs) that enable your applications to receive business documents by using BizTalk Server 2002.

  2. Extend the functionality of BizTalk Server 2002 by developing custom components to perform digital signature, encryption and decryption, parsing, serializing, and transport of documents.

For additional information, see the following sections:

  1. For help with specific tasks, see Using Custom Components.

  2. For general background information, see Understanding Custom Components.

  3. For information about COM interfaces, see Custom Components Reference.

  4. For examples of code, see BizTalk Messaging Services Code Samples.


Understanding Custom Components

This section provides detailed conceptual information that is important to understanding how to extend Microsoft® BizTalk™ Server 2002. BizTalk Server 2002 can perform data transformation, digital signature, encryption and decryption, parsing, serializing, and transport of documents. In addition, you can create your own application integration components (AICs) to extend the capabilities of BizTalk Server 2002.

The following topics are covered:

  • Custom Component Types

  • Application Integration Components

  • Parsers

  • Serializers


Custom Component Types

Custom components can be created for application integration (AICs), encryption, encoding, signing, parsing, and serializing. The following interfaces must be implemented for each component type:

Component types | Interfaces to be implemented
Pipeline components:

AIC
Encryption
Encoding
Signing

 IPipelineComponent, IPipelineComponentAdmin
AIC (lightweight) | IBTSAppIntegration
Parsing IBizTalkParserComponent

By default, BizTalk Server registers the following parser components, listed by ProgID:

  • Edifact: BizTalk.ParserEdifact

  • Flat File: BizTalk.ParserFFile

  • X12: BizTalk.ParserX12

  • XML: BizTalk.ParserXML
Serializing IBizTalkSerializerComponent, IPipelineComponentAdmin (optional)

By default, BizTalk Server registers the following serializer components, listed by ProgID:

  • Edifact: BizTalk.SerializerEdifact

  • Flat File: BizTalk. SerializerFFile

  • X12: BizTalk. SerializerX12

  • XML: BizTalk. SerializerXML


Application Integration Components

When creating an application integration component (AIC), you can implement either the pipeline model using the IPipelineComponent interface or the lightweight model using the IBTSAppIntegration interface.

Application integration components are COM objects that the BizTalk Server state engine calls to deliver data to an application. If a messaging port is configured in BizTalk Server 2002 to include the use of an AIC for application integration, this component is automatically instantiated and passed the requisite data. The component then determines how to handle communicating this data back to the application. This can be done using private API calls, invoking other COM objects, using database writes, and so on.

This section contains the following topics:

  • Pipeline Application Integration Components

  • Lightweight Application Integration Components

By default, AICs run in the LocalSystem account. If another security context is required, set it as part of the implementation of the AIC. However, if an AIC is installed as a COM+ application, an administrator can configure security of the AIC by using the Component Services console.

When developing an AIC using Microsoft Visual Basic®, ensure that all Visual Basic components set the Unattended Execution and Retain in Memory project settings.

Related Topic

Registering Custom Components


Pipeline Application Integration Components

One approach for application integration with BizTalk Server 2002 is the creation of a pipeline component. This is the same model used in Microsoft Site Server 3.0 Commerce Edition for application integration with the Commerce Interchange pipeline (CIP) and the Order Processing pipeline (OPP). BizTalk Server 2002 supports this method so that pipeline components written for application integration for CIP and OPP are compatible. This is also a useful technique when the component requires configuration properties.

The primary entry point for a pipeline component is the Execute method of the IPipelineComponent interface. This is the method that BizTalk Server 2002 calls to transfer control and to pass the data to the component. It is in the implementation of this method that the component does its work.

Related Topics

Lightweight Application Integration Components


Lightweight Application Integration Components

BizTalk Server 2002 supports an additional model for application developers who want a lighter-weight model for application integration, one that does not support a design-time user interface or configuration properties. This model requires a single interface that contains a single method as an entry point. The component is implemented, and the document is passed to it through the ProcessMessage method of the IBTSAppIntegration interface.

IBTSAppIntegration is for applications that do not need properties for their component and need only an entry point for receiving a document. This is a simpler approach to application integration than pipeline components. BizTalk Server 2002 queries for this interface first. If it does not find this interface implemented, it queries for the pipeline component interfaces.


Parsers

The parser has two responsibilities:

  • Convert the documents to XML for later processing.

  • Get the parameters necessary to select the channel (these are the source qualifier, source identifier, destination qualifier, destination identifier, and document definition name). These returned fields are combined with the parameters of the Submit method of the IInterchange interface to select the channels necessary to process the documents.

This interface gets information from the component for one interchange. If the incoming data stream represents multiple interchanges, the server selects the component at every interchange boundary. This simplifies construction of a component because it deals with only one interchange at a time. There is one component instance per thread. No single object needs to be safe for multiple threads. This interface is supported only in C++.

If the ProbeInterchangeFormat method of the IBizTalkParserComponent interface returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

Related Topics

Registering Custom Components

Working with Parsers


Serializers

The serializer converts the document from XML back to its native format. This interface is intended to work on a single interchange and is designed to get information from the component for one interchange. This simplifies the construction of this component because it has to deal with only one interchange at a time. There is only one instance per thread. No single object needs to be safe for multiple threads. The IBizTalkSerializerComponent interface is supported only in C++.

Related Topics

Registering Custom Components

Working with Serializers


Using Custom Components

This section provides task-specific information about how to create server components. It is highly recommended that you review the Understanding Custom Components topic as well.

The following topics are covered:

  • Creating Pipeline Components

  • Creating Receipt Correlator Components

  • Working with Parsers

  • Working with Serializers

  • Registering Custom Components

  • Handling Data Passed to AICs

  • Supporting the Tracking Database with Parser and Serializer Components


Creating Pipeline Components

Use the following steps to create a pipeline component:

  1. Create an Active Template Library (ATL) wizard–generated Inproc server project.

  2. Add a simple COM object.

  3. Go to the Projectname.idl file and remove the dual or custom interface generated by the wizard in step 2.

  4. Verify that the resulting IDL file looks like the code examples that follow. You might choose to implement your own set of interfaces from the ones defined in Pipecomp.idl.

// SimplePipeComponent.idl : IDL source for SimplePipeComponent.dll

//

import "oaidl.idl";

import "ocidl.idl";

import "pipecomp.idl";

[

uuid(D26A52F6-63A0-42B1-8C88-3C71C66BB189),

version(1.0),

helpstring("SimplePipeComponent 1.0 Type Library")

]

library SIMPLEPIPECOMPONENTLib

{

importlib("stdole32.tlb");

importlib("stdole2.tlb");

[

uuid(E66CAF06-18D8-4C70-9D39-5ED9756C21AD),

helpstring("MySimplePipelineComponent Class")

]

coclass MySimplePipelineComponent

{

[default] interface IPipelineComponentAdmin;

interface IPipelineComponent;

interface IPipelineComponentDescription;

};

};

  5. One of the implementations of MySimplePipelineComponent [coclass] is defined in the header file as follows:

// MySimplePipelineComponent.h : Declaration of the

// CMySimplePipelineComponent

#ifndef __MYSIMPLEPIPELINECOMPONENT_H_

#define __MYSIMPLEPIPELINECOMPONENT_H_

#include "resource.h" // main symbols

/////////////////////////////////////////////////////////////////////////////

// CMySimplePipelineComponent

class ATL_NO_VTABLE CMySimplePipelineComponent :

public CComObjectRootEx<CComSingleThreadModel>,

public CComCoClass<CMySimplePipelineComponent, &CLSID_MySimplePipelineComponent>,

public ISupportErrorInfo,

public IDispatchImpl<IPipelineComponentAdmin, &IID_IPipelineComponentAdmin, &LIBID_SIMPLEPIPECOMPONENTLib>,

public IDispatchImpl<IPipelineComponent, &IID_IPipelineComponent, &LIBID_SIMPLEPIPECOMPONENTLib>,

public IDispatchImpl<IPipelineComponentDescription, &IID_IPipelineComponentDescription, &LIBID_SIMPLEPIPECOMPONENTLib>

{

public:

CMySimplePipelineComponent()

{

}

DECLARE_REGISTRY_RESOURCEID(IDR_MYSIMPLEPIPELINECOMPONENT)

DECLARE_PROTECT_FINAL_CONSTRUCT()

BEGIN_COM_MAP(CMySimplePipelineComponent)

COM_INTERFACE_ENTRY2(IDispatch,IPipelineComponentAdmin)

COM_INTERFACE_ENTRY(IPipelineComponentAdmin)

COM_INTERFACE_ENTRY(IPipelineComponent)

COM_INTERFACE_ENTRY(IPipelineComponentDescription)

COM_INTERFACE_ENTRY(ISupportErrorInfo)

END_COM_MAP()

// ISupportsErrorInfo

STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);

public://IPipelineComponentAdmin

STDMETHODIMP GetConfigData(IDispatch** ppDict );

STDMETHODIMP SetConfigData(IDispatch* pDict );

public://IPipelineComponent

STDMETHODIMP Execute(IDispatch* pdispObject,IDispatch* pdispContext,LONG lFlags,LONG* plErrorLevel);

STDMETHODIMP EnableDesign(BOOL fEnable);

public: //IPipelineComponentDescription

STDMETHODIMP ValuesRead(VARIANT* pvar);

STDMETHODIMP ValuesWritten(VARIANT* pvar);

STDMETHODIMP ContextValuesRead(VARIANT* pvar);

};

#endif //__MYSIMPLEPIPELINECOMPONENT_H_

Related Topics

Application Integration Components

IPipelineComponent

IPipelineComponentAdmin


Creating Receipt Correlator Components

Receipt correlator components can be implemented to correlate documents, groups of documents, and interchanges with their receipts. To use a receipt correlator, you must implement a custom parser by using the IBizTalkParserComponent interface. This is required because the server can obtain only the progID of the receipt correlator to be used by calling the GetNextDocument method on the IBizTalkParserComponent interface.

In addition, with BizTalk Server on the receiver side where the receipt is being generated, the parser component is responsible for putting the acknowledgment status, as well as sufficient information, on the receipt (a Canonical Receipt to begin with, but it can be mapped into other receipt document schemas, such as AK997 in EDI) to allow the correlator component on the sender side to uniquely identify the original outbound interchange, group, or document record. For an XML document, using the GUID is usually sufficient. But for EDI interchanges, because GUID cannot be used (there is no placeholder for any GUID in an EDI interchange), a combination of EDI-specific fields is needed for this unique identifier. For instance, the default X12 correlator component uses a combination of the following fields for this purpose: version, release, functional group ID, control ID, source application name, and destination application name.

Whenever the server receives a receipt as an inbound document, the parser component's responsibility is to detect the inbound document as being a receipt, to extract all relevant information needed for correlation, and to place the receipt onto the transport dictionary. Upon returning from the GetNextDocument method call, the parser should set the DocIsReceipt parameter to TRUE and the CorrelationCompProgID parameter to the progID of the corresponding correlator component.

The server calls the Correlate method on the IBizTalkCorrelation interface, and passes in a pointer to the IBizTalkAcknowledge object and the transport dictionary containing the receipt as the working data. Then the receipt correlator's implementation of the Correlate method extracts all relevant information about the document, document group, or interchange that should have been set by the parser component from the transport dictionary. Using this information, the Correlate method then calls AckDocument, AckGroup, or AckInterchange on the IBizTalkAcknowledge interface and sets the DTA_ACK_STATUS value for that document, group, or interchange.

Note that the server does not immediately call IBizTalkCorrelation. The receipt document and the correlation progID are stored to the database for later correlation. When the document is picked up for processing, the correlation component is created and invoked with the transport dictionary that was given by the parser component and a pointer to IBizTalkAcknowledge.

Related Topics

Submitting Documents with Receipts

Understanding Receipts


Working with Parsers

The following tables show the possible sequence of calling the methods of the IBizTalkParserComponent interface, based on the following sample interchanges.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | True
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to False.
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to True.

If you have an interchange with two documents, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | False
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A

Related Topics

Parsers

IBizTalkParserComponent

Supporting the Tracking Database with Parser and Serializer Components


Working with Serializers

To create a custom serializer component, you need to perform the following tasks:

  • Create a COM component that implements the IBizTalkSerializerComponent and IPipelineComponentAdmin interfaces.

  • Register this component and include the category identifiers CATID_BIZTALK_COMPONENT and CATID_BIZTALK_SERIALIZER in the registry. For more information, see Registering Custom Components.

  • Create Active Server Pages (ASP) files for setting custom property values on your serializer component by using the pre-defined user interface management functions. These functions are available in the ASP include files located in the folder \Microsoft BizTalk Server\Messaging Manager\pipeline on the BizTalk Server installation drive. For more information about the ASP file format, see "ASP file formats" that follows.

  • Place the ASP files in the pipeline folder and name the files using these formats:
    File name | Description
    BizTalk_ComponentName_1.asp | Displays a dialog box that reads the serializer key values from the IDictionary object. These values are displayed to the user for modification.
    BizTalk_ComponentName_1_post.asp | Updates the serializer dictionary with the new key values set by the user.

  • Use the SetConfigComponent method to associate the custom serializer component with a channel.

After these tasks are completed, the user can access these settings by clicking Advanced on the Channel Properties page in BizTalk Messaging Manager. For more information, see Set advanced configuration properties.

ASP file formats

When using the functions provided in the ASP include files located in the folder \Microsoft BizTalk Server\Messaging Manager\pipeline on the BizTalk Server installation drive, use the following general format:

<!--#INCLUDE FILE="pe_edit_header.asp" -->

<-- optional HTML formatting tags here -->

<%

optional calls to input functions here

%>

<!--#INCLUDE FILE="pe_edit_footer.asp" -->

The following functions can be used in the ASP pages for displaying text or retrieving specific types of information from the user. These functions are defined in the file pe_global_edit.asp:

  • DisplayReadonlyText

  • GetLabelAccel

  • InputArrayAccel

  • InputCheckBoxAccel

  • InputFloatAccel

  • InputNumberAccel

  • InputPasswordAccel

  • InputRadioAccel

  • InputSimpleListAccel

  • InputTextAccel

Method Sequences

The following tables show the possible sequence of calling the methods of the IBizTalkSerializerComponent interface, based on the following sample interchanges.

If you have an interchange with one document, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 0.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with one group, with one document in the group, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 1.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence (this assumes support of batching):

Method | Return
Init | The numdocs parameter is set to 3.
AddDocument | The handle parameter is set to 0.
AddDocument | The handle parameter is set to 1.
AddDocument | The handle parameter is set to 2.
GetInterchangeInfo | The numGroups parameter is set to 2.
GetGroupInfo | The numdocs parameter is set to 2.
GetDocInfo | The handle parameter is set to 1.
GetDocInfo | The handle parameter is set to 0.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The handle parameter is set to 2.

Related Topics

Serializers

Supporting the Tracking Database with Parser and Serializer Components


Registering Custom Components

To use a custom component in BizTalk Server 2002, the component must be registered with the category IDs for all pipeline components and for the specific type of pipeline component.

Register the component as an out-of-process component to provide better isolation. A component can be registered as an in process (inproc) component to increase its performance. However, an inproc component that fails to respond during an error condition might cause BizTalk Server to fail. Therefore, a component should be thoroughly tested before registering it as an inproc component.

Note

  • An out-of-process component registered as a COM+ application must be configured to run in an identity other than the interactive user. For more information about Component Services and COM+, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to Component Services in the Platform SDK.

BizTalk Server category identifiers

Custom components that are used in BizTalk Server must be associated with one or more category identifiers (CATID). The following table shows the category identifiers defined by BizTalk Server.

CATID | GUID | Description
CATID_BIZTALK_ AIC | BD193E1D-D7DC-4B7C-B9D2-92AE0344C836 | Identifies the component as an application integration component (AIC).
CATID_BIZTALK_ COMPONENT | 5C6C30E7-C66D-40E3-889D-08C5C3099E52 | Identifies the component as a BizTalk Server component. All components that are used with BizTalk Server must implement this category identifier.
CATID_BIZTALK_ CUSTOM_PROCESS | 20E8080F-F624-4401-A203-9D99CF18A6D9 | Identifies the component as a custom preprocessor for a receive function.
CATID_BIZTALK_ IDocSpecExtension | 711E279C-DE24-11D2-974B-00C04F680FE7 | Identifies the component as an extension module for importing XML documents.
CATID_BIZTALK_ MapEditFunctoids | 2560F3BF-DB47-11D2-B3AE-00C04F72D6C1 | Identifies the component as a custom functoid that is displayed in the functoid palette.
CATID_BIZTALK_ PARSER | C0DCDF4E-692C-11D2-89E7-00C04F79DBAA | Identifies the component as a parser that is used to process inbound documents.
CATID_BIZTALK_ SERIALIZER | AFCC065F-E0A6-47A6-B0A8-ECAA2FEEE2F4 | Identifies the component as a serializer that is used to process outbound documents.

Assigning affinity

Each component must be associated with two category IDs. One category ID marks the component as a BizTalk Server component. A component so marked appears in a list of components in the BizTalk Server administration console. The second category ID indicates the type or purpose of the component. This second association is called affinity, which allows BizTalk Server to determine the context in which the component can be used. For example, only those components whose affinity is registered as an application integration component (AIC) appear in the list of available components when an AIC transport type has been selected in BizTalk Messaging Manager.

To register affinity for an AIC created with Microsoft Visual C++® using ATL, include the following code in your header file:

#include "bts_sdk_guids.h"

// Implement the Component and AIC Category IDs (CATID)

BEGIN_CATEGORY_MAP(AIC_ClassName)

IMPLEMENTED_CATEGORY(CATID_BIZTALK_COMPONENT)

IMPLEMENTED_CATEGORY(CATID_BIZTALK_AIC)

END_CATEGORY_MAP()

To register affinity for an AIC created with Microsoft Visual Basic:

  1. After registering your component using Regsvr32.exe, search the registry for the CLSID of your AIC under the following key:

    HKEY_CLASSES_ROOT\CLSID

  2. Expand the Implemented Categories key of your AIC.

  3. Add two new keys with the following names:

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{5C6C30E7-C66D-40e3-889D-08C5C3099E52}

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{BD193E1D-D7DC-4b7c-B9D2-92AE0344C836}

These GUIDs can be found in bts_sdk_guids.h in the Program Files\Microsoft BizTalk Server\SDK\Include folder. The first key shown in step 3 above identifies the AIC as a BizTalk Server component (CATID_BIZTALK_COMPONENT). The second key shown in step 3 above identifies the component as an AIC (CATID_BIZTALK_AIC).

Testing affinity

To test affinity, use BizTalk Messaging Manager to create a port that uses the AIC. For more information, see Select an application integration component.

Related Topics

IFunctoid Interface

ISchemaImporter Interface

IBTSCustomProcess

Parsers

Serializers


Handling Data Passed to AICs

The proper method for handling data returned by an application integration component (AIC) depends on several factors, including programming language, the characteristics of the channel being used, and the document being passed.

For an AIC written in Visual Basic, you receive a buffer that contains Unicode characters, ANSI characters, or bytes.

The Direct Integration sample contains an ATL component that unpacks binary buffers returned as BSTR data. The component defines and implements the IConvertBstr interface, which defines a single method called Convert:

HRESULT Convert([in] BSTR bstrData, [out,retval] VARIANT* psaData);

When a buffer is passed as a BSTR to this method, the component creates a safe array of characters. The size of the array is the size of the buffer passed in the BSTR. A simple operation of memory copying helps translate the BSTR data to a safe array. Convert can be used by an AIC to convert the data to a format that can be iterated, as shown in the following code:

STDMETHODIMP CConvertBstr::Convert(BSTR bstrData, VARIANT *psaData) {

HRESULT hr = S_OK;

SAFEARRAY *psa = NULL;

BYTE HUGEP*psaBuffer = NULL;

SAFEARRAYBOUND rgsaBound[1];

UINT nDataLength = 0;

Determine if the arguments passed to Convert are valid, as shown in the following code:

if (!psaData || !bstrData)

return E_FAIL;

Clear the variant data type, as shown in the following code:

hr = VariantClear(psaData);

if (FAILED(hr))

return hr;

The client code must initialize the variant. Then, retrieve the length of the allocated BSTR, in bytes, as shown in the following code:

nDataLength = SysStringByteLen(bstrData);

At this point, construct a SAFEARRAY that will contain the bytes from the input BSTR data type, as shown in the following code:

rgsaBound[0].lLbound = 0;

rgsaBound[0].cElements = (ULONG)nDataLength;

psa = SafeArrayCreate(VT_UI1, 1, rgsaBound) ;

if (!psa)

return E_FAIL;

SafeArrayAccessData(psa, (void HUGEP**) &psaBuffer);

memcpy(psaBuffer, bstrData, nDataLength);

SafeArrayUnaccessData(psa);

Finally, return the SAFEARRAY through the output parameter, as shown in the following code:

V_VT(psaData) = VT_ARRAY | VT_UI1;

V_ARRAY(psaData) = psa;

return hr;

}

In addition, all pipeline AICs receive an IDictionary object, containing a set of fields. Every IDictionary object contains a working_data field. Several other fields could be present, including the following string values supplied by the server for all AICs:

  • Src_ID_Type: The type of identifier used for the source organization.

  • Src_ID_Value: The value of the source organization identifier.

  • Dest_ID_Type: The type of identifier used for the destination organization.

  • Dest_ID_Value: The value of the destination organization identifier.

  • Document_Name: The name of the input document definition.

  • Tracking_ID: A key value that is based on the globally unique identifier (GUID) and used for tracking.

  • Src_Filename: The name of the source document.

  • Src_Filepath: The file path of the source document.

  • Out_Codepage: The codepage used by the component to interpret the BSTR data.

Related Topics

Supporting the Tracking Database with Parser and Serializer Components

Execute Method


Supporting the Tracking Database with Parser and Serializer Components

When creating a custom parser or serializer, you might want your component to support the BizTalk Server Tracking database. To accomplish this, the component must use the IDictionary interface to add key/value pairs into the database.

Interchange table

The following table contains the list of keys that can be used to support the Tracking database from the interchange level with a custom component. The table used in the database is dta_interchange_details.

Dictionary key | Inbound or outbound | Column logged in Tracking database | Description
Src_ID_Type | Both | *nvcSrcAliasQualifier | This is the qualifier for the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Src_ID_Value | Both | *nvcSrcAliasId | This contains the value of the qualifier of the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Src_ID_App | Inbound | nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Dest_ID_Type | Both | *nvcDestAliasQualifier | This is the qualifier for the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Dest_ID_Value | Both | *nvcDestAliasId | This contains the value of the qualifier of the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Dest_ID_App | Inbound | nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_id | Inbound | nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_version | Inbound | nvcVersion | This is the version of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Out_Src_ID_App | Outbound | *nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
Out_Dest_ID_App | Outbound | *nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_id | Outbound | *nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. The serializer usually generates this unique value. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_version | Outbound | *nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.

Note

  • The columns of the dta_interchange_details table marked with an asterisk (*) are used for receipt correlation.

Group table

The following table contains the list of keys that can be used to support the Tracking database from the group level with a custom component. The table used in the database is dta_group_details. This table applies to both inbound and outbound documents.

Dictionary key | Column logged in Tracking database | Description
group_id | *nvcControlID | This is the unique control number of a group instance within an EDI interchange. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. For outbound document processing, the serializer usually generates this value.
functional_identifier | *nvcFunctionalGroupID | This is the code for the type of documents in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
application_sender_code | *nvcSrcAppName | This is the group level identifier for the source application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
application_receiver_code | *nvcDestAppName | This is the group level identifier for the destination application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
standards_version | *nvcVersion | This is the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.
standards_release | *nvcRelease | This is the release of the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.

Note

The columns of the dta_group_details table marked with an asterisk (*) are used for receipt correlation.

Inbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_indoc_details. This table applies to inbound documents only.

Dictionary key | Column logged in Tracking database | Description
doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_version | nvcVersion | This is the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_release | nvcRelease | This is the release of the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
doc_type | nvcDocType | This is the document type or transaction set identifier. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.

Outbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_outdoc_details. This table applies to outbound documents only.

Dictionary key | Column logged in Tracking database | Description
out_doc_doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_syntax | nvcSyntax | This is the code for document syntax, such as XML, X12, EDIFACT, H7, and so on. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_standards_version | nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
out_doc_standards_release | nvcRelease | This is the release of the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
out_doc_doc_type | nvcDocType | This is the document type or transaction set identifier. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
Tracking_ID | uidTrackingGUID | This is the tracking identifier of the document for which a receipt is generated.

Note

  • The Tracking_ID key is used when calling the AckDocument method.

Interchange and document tables

The following table contains the list of keys that can be used to support the Tracking database from the interchange and document level with a custom component. The table used in the database for interchange data is dta_interchange_data. The table used in the database for document data is dta_document_data.

Dictionary key | Inbound or outbound | Column logged in Tracking database | Description
in_codepage | Inbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the parser sets the value with this dictionary key, the value is logged in the data record related to the inbound interchange/document in the Tracking database.
out_codepage | Outbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the serializer sets the value with this dictionary key, the value is logged in the data record related to the outbound interchange/document in the Tracking database.

Related Topic

Understanding the Tracking Database Schema


BizTalk Orchestration Services

The interfaces in this section provide access to XLANG Scheduler System Managers, XLANG group managers, XLANG schedule instances, and XLANG ports.

The XLANG Scheduler System Manager provides moniker resolution and maintains a collection of group managers. A group manager runs in every COM+ application that has been designated as an XLANG schedule host, and maintains a collection of XLANG schedule instances. An XLANG schedule instance represents a running XLANG schedule that can be queried for information, such as the schedule's completion status. For XLANG schedules with a COM-bound port, a proxy object can be used to obtain a reference to the interface specified in the port binding.

  • For help with specific tasks, see Using Orchestration Services.

  • For general background information, see Understanding Orchestration Services.

  • For information about COM interfaces and error messages, see the Orchestration Services Reference.

Related Topic

Moniker Syntax


Understanding Orchestration Services

This section provides detailed conceptual information that is important to understanding how to access and work with BizTalk Orchestration Services. The following topics are covered in this section:

  • XLANG Interfaces

  • XLANG Schedule Correlation

The interfaces described in this section provide access to XLANG Scheduler System Managers, XLANG group managers, XLANG schedule instances, and XLANG ports.


XLANG Interfaces

The XLANG Scheduler System Manager provides moniker resolution and maintains a collection of group managers. A group manager runs in every COM+ application that has been designated as an XLANG schedule host, and maintains a collection of XLANG schedule instances. An XLANG schedule instance represents a running XLANG schedule that can be queried for information, such as the schedule's completion status. For XLANG schedules with a COM-bound port, a proxy object can be used to obtain a reference to the interface specified in the port binding.

The following illustration shows the relationship between the XLANG interfaces covered in this section, and the corresponding monikers.

XLANG Scheduler interfaces

The following XLANG schedule interfaces are available:

Administrator interfaces:

  • IWFGroupAdmin

  • IWFSystemAdmin

Schedule instance interfaces:

  • IWFProxy

  • IWFWorkflowInstance


XLANG Schedule Correlation

XLANG schedule correlation enables you to use a single message queue shared across multiple XLANG schedule instances, allowing incoming messages on that queue to be correlated to the correct running XLANG schedule instance. Src_XLANG_InstanceID and Dest_XLANG_InstanceID are dictionary keys created to take advantage of XLANG schedule correlation. The XLANG Scheduler Engine supports the ability to set the globally unique identifier (GUID) assigned to the schedule instance, or InstanceID, as the message label on received Message Queuing messages. These keys are provided by BizTalk Messaging Services to supply a simple mechanism to save and retrieve the data from the XLANG Scheduler Engine. By using these keys, you do not need to write code to retrieve and look up the InstanceIDs in the XLANG schedule, and you can leverage the existing BizTalk Messaging transports.

The Src_XLANG_InstanceID dictionary key appears on messages that originate from the BizTalk Messaging binding in an XLANG schedule instance, as long as the message is declared to send the InstanceID. This information can be used by a component in the messaging port to store the InstanceID to a custom database with a business-level correlation ID.

When a response message is received for a business interaction, the messaging port bound to the running XLANG schedule instance must contain the InstanceID in order to send the data to the correct running XLANG schedule instance. To do this, the Dest_XLANG_InstanceID key is extracted by BizTalk Messaging Services and placed on the Message Queuing label for the receiving queue. The key is set by custom pipeline components that look up the XLANG schedule InstanceID based on the business-level correlation ID.

Note

  • The tracking dictionary does not use these keys and they are not defined in a database table. To capture the correlation state, you need to implement a custom database.

For more information, run the E-Procurement Sample, which demonstrates the XLANG schedule correlation feature.

Related Topic

Instance Management


Using Orchestration Services

This section provides task-specific information about how to use BizTalk Orchestration Services. It is highly recommended that you review the Understanding Orchestration Services topic as well.

The following topics are covered in this section:

  • Activating an XLANG Schedule Instance

  • Accessing a Running XLANG Schedule Instance

  • Accessing the XLANG Scheduler System Manager

  • Accessing Group Managers


Activating an XLANG Schedule Instance

Use IWFProxy to obtain a schedule instance. If IWFProxy is used on a non-COM port binding, an error is returned.

A reference to IWFProxy can be obtained from:

  • The Port property available on the IWFWorkflowInstance interface.

  • An XLANG schedule moniker that specifies the port name.

The following Microsoft Visual Basic code sample shows how to activate an XLANG schedule on the local computer by using a moniker, and obtain a reference to the named port on that XLANG schedule instance.

Dim oPort As Object

Set oPort = GetObject("sked:///C:\schedules\test.skx/PortA")

At this point, the oPort variable contains a reference to the COM object bound in PortA of the schedule instance.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.


Accessing a Running XLANG Schedule Instance

Use IWFWorkflowInstance to gather information about a specific running schedule instance.

A reference to IWFWorkflowInstance can be obtained from:

  • The WorkflowInstance property available on the IWFProxy interface.

  • The collection of IWFWorkflowInstance objects returned by the IWFGroupAdmin object.

  • An XLANG schedule moniker.

The following Microsoft Visual Basic code sample shows how to instantiate an XLANG schedule on the local computer and obtain a reference to that schedule instance.

Dim oWFI As IWFWorkflowInstance

Set oWFI = GetObject("sked:///C:\schedules\test.skx")

To obtain a reference to all currently running schedule instances in a group manager, you can access the collection of IWFWorkflowInstance objects contained by the IWFGroupAdmin object. The following Microsoft Visual Basic code displays the fully qualified name of each schedule instance running in the default XLANG Scheduler Group Manager.

Dim oGM As IWFGroupAdmin

Dim oWFI As IWFWorkflowInstance

Set oGM = GetObject("sked://!XLANG Scheduler")

For Each oWFI In oGM

MsgBox ("XLANG Schedule: " + oWFI.FullyQualifiedName)

Next

When using multiple group managers, you can determine the group manager associated with any schedule instance by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFWorkflowInstance object.

  2. Parse the group manager name out of the moniker string returned.

    This is the portion that begins with an exclamation point (!) and ends with a slash (/).

  3. Obtain a reference to the IWFGroupAdmin object using a moniker created with the group manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Notes

  • When using C++, the COM CoGetObject function is used in place of GetObject.

  • When accessing this object in Microsoft Visual Basic, you must declare your object variable with the appropriate type information rather than using the Object type. For example:

Dim myInstance As IWFWorkflowInstance


Accessing the XLANG Scheduler System Manager

Use IWFSystemAdmin to start, stop, and retrieve information about the group managers.

To obtain a reference to this object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the XLANG Scheduler System Manager on the local computer.

Dim oSM As SysMgr

Set oSM = GetObject("sked://")

This object also enumerates a collection of the IWFGroupAdmin objects that represent the group managers associated with this XLANG Scheduler System Manager.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.


Accessing Group Managers

To obtain a reference to an IWFGroupAdmin object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the default XLANG Scheduler Group Manager on the local computer.

Dim oGM As IWFGroupAdmin

Set oGM = GetObject("sked://!XLANG Scheduler")

To obtain a reference to other group managers, replace "XLANG Scheduler" with the name of the COM+ application that has been designated as an XLANG Scheduler Engine host or group manager. You can determine whether a COM+ application is a group manager by using the IsWorkflowHost method on IWFSystemAdmin.

You can also obtain a reference to all group managers associated with the XLANG Scheduler System Manager through the collection of IWFGroupAdmin objects contained by the SysMgr object. The following Microsoft Visual Basic code displays the fully qualified name of each group manager.

Dim oSM As SysMgr

Dim oGM As IWFGroupAdmin

Set oSM = GetObject("sked://")

For Each oGM In oSM

MsgBox ("Group Manager: " + oGM.FullyQualifiedName)

Next

The IWFGroupAdmin object also enumerates a collection of the IWFWorkflowInstance objects that represent currently running schedule instances for this group manager.

You can determine the XLANG Scheduler System Manager associated with any group manager by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFGroupAdmin object.

  2. Parse the XLANG Scheduler System Manager name out of the moniker string returned.

    This is the portion between the sked:// prefix and the exclamation point (!).

  3. Obtain a reference to the IWFSystemAdmin object using a moniker created with the XLANG Scheduler System Manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.


BizTalk Managing and Monitoring

Windows Management Instrumentation (WMI) is a data-management layer included in Microsoft® Windows® 2000. Microsoft BizTalk™ Server 2002 uses the WMI layer to encapsulate administrative functions that support the management of systems in an enterprise.

  • For help with specific tasks, see Using Managing and Monitoring.

  • For general background information, see Understanding Managing and Monitoring.

  • For information about COM interfaces, see the Managing and Monitoring Reference.

This section contains sample code in Microsoft Visual Basic® and Visual Basic Script.


Understanding Managing and Monitoring

When you use the BizTalk Server Administration Microsoft Management Console (MMC) snap-in (the administration console) to change group, server, queue, and database management settings, the new values are stored in the BizTalk Messaging Management database through the BizTalk Server WMI provider. In BizTalk Server 2002, this WMI provider uses a Microsoft® SQL Server™ database to store administrative objects. All timestamps are created by using the local time on the computer that is running SQL Server. However, the WMI provider refers to all timestamps in coordinated universal time (UTC). The administration console then converts the timestamps back to local time for display.

The WMI provider acts as an intermediary between WMI and the administration console MMC snap-in. The WMI provider gathers information from a resource (managed object) and makes it available to management applications through the WMI API.

The BizTalk Server schema classes are registered and defined by using Managed Object Format (MOF), which is a compiled language based on the Interface Definition Language (IDL). You place this information in an .mof file that you submit to the MOF compiler, Mofcomp.exe.

This section contains the following topics:

  • BizTalk Server Namespace

  • BizTalk Server Provider and Registration

  • Custom Counters

The MOF code examples in the following topics are taken from the InterchangeProvSchema.mof file found in the \Program Files\Microsoft BizTalk Server\Setup folder. This file, along with SrvEvents.mof, contains the BizTalk Server namespace, provider, provider registration, and schema class definitions.

To access the WMI database layer programmatically, see Managing and Monitoring Reference, which documents the BizTalk Server WMI schema classes that correspond to the Administration objects.


BizTalk Server Namespace

Every WMI namespace contains a set of system classes, including __NAMESPACE. A namespace groups a collection of classes into logical units. Every computer has a defined namespace at the top of the hierarchy called the Root namespace. The location of a namespace is described by a path.

In the following MOF code, "MicrosoftBizTalkServer" is specified as the value for the Name property of the __NAMESPACE system class for BizTalk Server:

#pragma namespace ("\\\\.\\Root")

instance of __Namespace

{

Name = "MicrosoftBizTalkServer";

}

BizTalk Server defines the "MicrosoftBizTalkServer" namespace as a sibling of the Root namespace, logically distinguishing the BizTalk Server–managed environment from other managed environments.


BizTalk Server Provider and Registration

When WMI receives a request from a BizTalk Server management application, it forwards the request to the WMI provider, "InterchangeProv." The WMI provider retrieves, modifies, deletes, and/or enumerates instances of the BizTalk Server schema classes.

"InterchangeProv" is a custom provider designed to interact with the managed objects in the BizTalk Server environment. For a complete reference of these managed objects and their properties and methods, see Managing and Monitoring Reference.

The BizTalk Server instance provider supports data retrieval, data modification, data deletion, data enumeration, and query processing.

For more information about how to author and interpret .mof files, see the article "Managed Object Format (MOF) Language," in the WMI SDK on the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp).


Custom Counters

Custom counters are WMI class instances based on custom queries of the Tracking database. After they are created, these custom counters can be consumed by user-defined rules in Microsoft Operations Manager 2000 (MOM).

This section contains the following topics:

  • Custom Counter Query Properties

  • Custom Counters Validation

To programmatically create, delete, and update custom counters, see Creating a Custom Counter Using WMI.

For information about using BizTalk Server 2002 together with MOM, see About Microsoft Operations Manager.

The BizTalk Server 2002 Management Pack module includes a sample custom counter performance processing rule called "Sample - Custom Counter." This sample executes the query defined in the WMI custom counter class to acquire the number of documents in the Tracking database.

Notes

  • Unless you want to construct a regular expression when working with custom counters, there are a list of characters that need special consideration:

    [ ], ^, %, _

    You should enclose these characters in [ ] braces. For example, the string "Org%ani^za_tio[n", should be replaced by "Org[%]ani[^]za[_]tio[[]n".

  • Only the following custom counter setting properties can accept regular expressions: DocType, DestOrgName, SrcOrgName, DestQualifier, DestQualifierValue, SrcQualifier, and SrcQualifierValue.


Custom Counter Query Properties

When you create a new custom counter class instance, you provide values for properties that determine the query executed by the custom counter.

Values for the following query properties can be specified, when creating an instance of the MSBTS_CustomCounterSetting class:

  • Custom Counter Name. Name of the new class instance being created.

  • Source Organization. Name of the organization that is the source for the channel through which the document is processed, as defined in the BizTalk Messaging Management configuration.

  • Source Qualifier. Qualifier for the source organization identifier for the channel through which the document is processed.

  • Source Value. Value for the source organization identifier for the channel through which the document is processed.

  • Destination Organization. Name of the organization that is the destination for the channel through which the document is processed, as defined in the BizTalk Messaging Management configuration.

  • Destination Qualifier. Qualifier for the destination organization identifier for the channel through which the document is processed.

  • Destination Value. Value for the organization identifier defined in the BizTalk Messaging Management configuration as the destination for the channel through which the document is processed.

  • Document Type. Name of the root element from the document schema.

  • Time Interval. Interval of time, in seconds, over which to accumulate the custom counter value.

  • BizTalk Server Group Name. Name of the BizTalk Server group against which the custom counter query is to be executed.

For an example of programmatically setting these properties, see Creating a Custom Counter Using WMI and the Custom Counters sample.

Notes

  • In BizTalk Server 2002, organizations can be assigned an identifier alias. Identifiers consist of a name, qualifier, and value. When creating an organization, a default qualifier of OrganizationName is used along with a user-assigned name string as the identifier value. You can then create additional organization identifiers for specific tracking or routing purposes.

  • When tracking documents during processing, BizTalk Server records the qualifier and value for each channel source and destination organization. When creating a new custom counter class instance, it is possible to specify just the source and destination organization name or a qualifier-value pair. However, organization names and qualifier-value pairs cannot be specified at the same time.

  • When only the source and/or destination organization name is provided, the custom counter will include all documents that were processed through channels with any of the identifiers for the specified organization. When qualifier-value pairs are provided, only the documents processed by channels configured with those qualifier-value pairs are included.

  • To count only documents whose processing channel(s) had only the default qualifier-value pair configured, the qualifier should be OrganizationName and the value should be the name of the organization.

  • Wild-card expressions can be used for the following arguments when creating a new custom-counter class instance:
    • Source Organization

    • Source Qualifier

    • Source Value

    • Destination Organization

    • Destination Qualifier

    • Destination Value

    • Document Type


Custom Counters Validation

Validation of custom counters is optional and is provided through the IsValid method on the custom counter setting class, MSBTS_CustomCounterSetting.


Using Managing and Monitoring

This section provides task-specific information about how to manage and monitor by using Microsoft BizTalk Server 2002. Topics illustrate how to create and manipulate the BizTalk Server Administration objects by using WMI. It is highly recommended that you review the Understanding Managing and Monitoring topic as well.

The following topics are covered:

  • Creating an Event Consumer Using WMI

  • Creating a Custom Counter Using WMI

  • Handling WMI Errors


Creating an Event Consumer Using WMI

WMI provides a powerful event architecture that enables modifications in management information to be identified, aggregated, and associated with other management information, which can then be forwarded to local or remote management applications. Event handling and notification is a key benefit provided by WMI that provides a mechanism for identifying and dealing with hardware or software events and errors.

After an event occurs, a notification is delivered to one or more registered recipients, knows as event consumers. Event consumers can register to receive certain types of notifications. Event consumers register to receive notifications without any knowledge of how events and notifications are provided. To register, event consumers specify a filter that is created by using the WMI Query Language (WQL). The query describes the conditions under which the consumer receives the event notification.

In addition to DCOM interfaces, WMI supports a uniform scripting application programming interface (API) that gives applications and scripts access to the WMI provider on either a local computer or a remote computer.

This section shows the basic steps necessary to write a temporary WMI event consumer with Microsoft Visual Basic script, although some of the associated DCOM interfaces are mentioned.

This section contains the following topics:

  • Declaring Variables

  • Connecting to the Microsoft BizTalk Server Namespace

  • Creating the Event Object

  • Monitoring Events

Note

  • If you have Health Monitor installed (either from Microsoft Application Center 2000 or Microsoft BackOffice® Server), you can configure Health Monitor through its Microsoft Management Console (MMC) user interface (UI) (or its WMI class) to consume events.


Declaring Variables

To write an event consumer using WMI, you will need to obtain a locator object, a services object, an event object, and an object to represent a WMI class instance.

First, declare the variables, as shown in the following code:

Dim wbemLocat

Dim wbemSrvcs

Dim wbemEvent

Dim wbemObject

The locator object variable, wbemLocat, of type SwbemLocator, is used to connect to WMI. To connect to the "MicrosoftBizTalkServer" namespace under the Root namespace (Root/MicrosoftBizTalkServer), you set the services object variable, wbemSrvcs, of type SWbemServices. The event object variable, wbemEvent, of type SwbemEventSource, is needed to execute a query to receive events. To retrieve an event from the event query, you set the wbemObject variable of type SwbemObject.


Connecting to the Microsoft BizTalk Server Namespace

After you declare the variables, you need to retrieve the locator object. If you are using the scripting API, create a WbemScripting.SwbemLocator object, as shown in the following code:

Set wbemLocat = CreateObject("WbemScripting.SWbemLocator")

Note that the first step for any application using WMI is to retrieve a locator object. If you are using the DCOM interfaces in C/C++, you would retrieve an IWBEMLocator pointer by using the COCreateInstance method with the CLSID_WbemLocator class identifier, as shown in the following code:

IWbemLocator* piWMI = NULL;
HRESULT hr;

    hr = CoCreateInstance(
        CLSID_WbemLocator,
        NULL,
        CLSCTX_INPROC_SERVER,
        IID_IWbemLocator,
        (LPVOID*) &piWMI
    );

Using the locator object and the ConnectServer method, you can request a connection to the WMI service. The following code attempts to connect to WMI by specifying the Root namespace on the local computer. In the following code, replace the string "ComputerName" with the name of the server that publishes the event:

Set wbemSrvcs = wbemLocat.ConnectServer("ComputerName", "root\MicrosoftBizTalkServer")

If Err.number is equal to 0, then the connection to the WMI namespace is established. Specify both the computer name and the namespace; otherwise, if these fields are left blank, you will be connected to the default namespace on the local computer.

The returned SWbemServices object provides a communication path to the SQL Server database that is used to store administrative objects.


Creating the Event Object

Now that you have connected to the "MicrosoftBizTalkServer" namespace, you need to create the event object. The following code generates an event object to receive event notifications:

Set wbemEvent = wbemSrvcs.ExecNotificationQuery("Select * from DocSuspendedEvent")

The filter used in the SWbemServices.ExecNotificationQuery method call is "Select * from DocSuspendedEvent", which is written using WQL. Like SQL queries, WQL queries can be refined to return a specific set of properties, or a subset of instances that satisfy some criteria.

When the consumer submits this query, it requests to be notified of all occurrences of the event represented by the DocSuspendedEvent class. This request includes a request for notification on all of the event's system and nonsystem properties. When the event provider submits the query, it registers support for generating notifications whenever an event represented by the DocSuspendedEvent class occurs.


Monitoring Events

Now that you have created the event object for the DocSuspendedEvent class, you need to set up the mechanism to monitor events represented by that class. First, set wbemObject of type SWbemObject to Empty, as shown in the following code:

wbemObject = Empty

Then, if an event is available, the SWbemEventSource.NextEvent method retrieves the event from an event query, as shown in the following code:

Set wbemObject = wbemEvent.NextEvent(Timeout)

The SWbemObject object supports generic properties and methods that apply to all WMI objects, as well as exposing the properties and methods of the object as dynamic automation properties and methods of this object.

Use the following code to retrieve the globally unique identifier (GUID) for the item in the suspended queue event:

EventSuspendedQueueWaitForEvent = wbemObject.Properties_.Item("stringSuspendedGuid").Value

If the wbemObject is not set to Empty, then the GUID for the item in the Suspended queue event is retrieved; otherwise; a time-out error occurs while waiting for the Suspended queue event.

Note that stringSuspendedGuid is a property of the DocSuspendedEvent class. The Properties_ property returns an SWbemPropertySet object that is a collection of the properties for the current class or instance, in this case the DocSuspendedEvent class. The Item method then retrieves an SWbemProperty from the collection, in this case the stringSuspendedGuid property.

For more information about WMI Application Programming in BizTalk Server, see Handling WMI Errors.


Creating a Custom Counter Using WMI

This section shows the basic steps necessary to create a custom counter using organizations, and to perform a Tracking database query.

This section contains the following topics:

  • Declaring Variables

  • Setting the Security Level

  • Setting the Query Properties

  • Creating or Updating the Custom Counter

  • Validating the Custom Counter

  • Executing the Custom Counter Query

The code examples in this section use Microsoft Windows Instrumentation (WMI) and Microsoft Visual Basic script.

For an example of how to create a custom counter using qualifier and value pairs instead of organizations, see the Custom Counters sample.


Declaring Variables

To write a custom counter using WMI, define the following constants:

Const wbemChangeFlagUpdateOnly = 1

Const wbemChangeFlagCreateOnly = 2

Const CUSTCOUNTER_SETTING_NAMESPACE = "MSBTS_CustomCounterSetting"

In addition, you will need to obtain a locator object, a services (or namespace) object, and objects to represent WMI class instances.

Declare the variables, as shown in the following code:

Dim WBEMLocator

Dim WBEMNameSpace

Dim objCustomCounterFactory

Dim objCustomCounterSetting

Dim objCustomCounter


Setting the Security Level

Before setting the security level, you need to connect to the "MicrosoftBizTalkServer" namespace under the Root namespace (Root/MicrosoftBizTalkServer), as shown in the following code:

Set WBEMLocator = CreateObject("WbemScripting.SWbemLocator")

Set WBEMNameSpace = WBEMLocator.ConnectServer(, "root/MicrosoftBizTalkServer")

Then, set the security level for the namespace, as show in the following code:

WBEMNameSpace = GetObject("Winmgmts:{impersonationlevel=impersonate}!root/" & "MicrosoftBizTalkServer")


Setting the Query Properties

Before setting the query properties, you need to create a new instance of a custom counter setting class, as shown in the following code:

Set objCustomCounterFactory = WBEMNameSpace.Get(CUSTCOUNTER_SETTING_NAMESPACE)

Set objCustomCounterSetting = objCustomCounterFactory.SpawnInstance_

After the call to SpawnInstance_, objCustomCounterSetting contains an instance of MSBTS_CustomCounterSetting. This class is used to create, delete, and update custom counters.

In this example, the custom counter query is based on the source and destination organizations. To set the query properties, set the properties of the MSBTS_CustomCounterSetting instance, as shown in the following code:

objCustomCounterSetting.Name = "My Custom Counter"

objCustomCounterSetting.SrcOrgName = "SourceOrg"

objCustomCounterSetting.DestOrgName = "DestinationOrg

objCustomCounterSetting.DocType = "PORequest"

objCustomCounterSetting.TimeInterval = 300

objCustomCounterSetting.GroupName = "BizTalk Server Group"

So, the custom counter will count the number of documents passing from the source organization ("SourceOrg") to the destination organization ("DestinationOrg") using a document schema with the root element "PORequest". Also, note that the custom counter will only query the Tracking database for document entries from the previous 300 seconds.


Creating or Updating the Custom Counter

After setting the query properties, you should create or update the custom counter setting.

To create the custom counter setting, specify the wbemChangeFlagCreateOnly flag, as shown in the following code:

objCustomCounterSetting.Put_(wbemChangeFlagCreateOnly)

To update the custom counter setting, specify the wbemChangeFlagUpdateOnly flag, as shown in the following code:

objCustomCounterSetting.Put_(wbemChangeFlagUpdateOnly)

Note

  • When calling the Put_ method to create or update the custom counter setting, the wbemChangeFlagCreateOrUpdate flag is not supported. Instead, you must specify either wbemChangeFlagCreateOnly or wbemChangeFlagUpdateOnly, depending on whether you want to create or update the custom counter setting.


Validating the Custom Counter

After setting the query properties and creating or updating the custom counter, you should validate your custom counter.

You can validate on the following properties:

  • Source Organization

  • Source Organization Identifier

  • Destination Organization

  • Destination Organization Identifier

  • BizTalk Server Group

Note

  • The document type is not validated, because the value of the document type is not always known until the actual document is received.

Validate the custom counter settings, as shown in the following code:

objCustomCounterSetting.IsValid bSrcOrg, bSrcOrgId, bDestOrg, bDestOrgId, bGroup

As an example, you can use a message box to ensure that your query properties are valid, as shown in the following code:

WScript.Echo "ValidityCheck: " & vbCrLf & _

"SrcOrg " & CStr(bSrcOrg) & vbCrLf & _

"SrcId " & CStr(bSrcOrgId) & vbCrLf & _

"DestOrg " & CStr(bDestOrg) & vbCrLf & _

"DestId " & CStr(bDestOrgId) & vbCrLf & _

"Group " & CStr(bGroup)


Executing the Custom Counter Query

To execute the custom counter query, you need to retrieve an instance on the MSBTS_CustomCounter class. Since both the custom counter setting Name property and the custom counter Name property are key properties and share the same value, you can use their Name properties to retrieve the custom counter object, as shown in the following code:

Set objCustomCounter = WBEMNameSpace.Get("MSBTS_CustomCounter.Name=""" & _

objCustomCounterSetting.Name & """")

After retrieving the custom counter object, you can query the MatchCount property to view the results of the query, as shown in the following code:

WScript.Echo "Counter Information: " & objCustomCounter.Name & vbCrLf & _

"Matching Documents: " & objCustomCounter.MatchCount


Handling WMI Errors

This section uses Microsoft Visual Basic code to illustrate how to determine whether a WMI method returns an error, and if so, how to decipher the meaning of the error.

First, you declare two variables: an SWbemLastError object to contain and manipulate error objects, and an array of String objects to contain the numerical value, parameter information, and text description of the error, as shown in the following code:

Dim objWMIError As SWbemLastError

Dim strError(0 To 2) As String

To determine whether WMI raises an error, check the Err object. If the Err object is not equal to 0, then an error has been raised. Then, you can try to set the SWbemLastError object to a new instance.

Note that the TypeName function is used to return information about the objWMIError variable. If it is equal to Nothing, error information is not available, and the attempt to create the error object has failed.

If the call succeeds and an error object returns, the status of the object is reset and the members of the string array are set to meaningful values, as shown in the following code:

If Err <> 0 Then

strError(0) = Hex(Err.Number)

Set objWMIError = New SwbemLastError

If TypeName(objWMIError) <> "Nothing" Then

strError(1) = objWMIError.ParameterInfo

strError(2) = objWMIError.Description

Else

Err.Clear

strError(1) = ""

strError(2) = ""

End If

Else

strError(0) = 0

strError(1) = ""

strError(2) = ""

End If


BizTalk Server Developer's Toolbox

This section uses Microsoft® Visual Basic®, C++, and Visual Basic script to provide a toolbox of solutions to common tasks encountered by BizTalk Server developers. These code examples are provided without robust error-handling functionality and should serve as an introduction to designing your own tools when working with BizTalk Server.

These code examples should not be used in a production environment.

This section contains the following topics:

  • BizTalk Messaging Services Tasks

  • BizTalk Orchestration Services Tasks

  • BizTalk Managing and Monitoring Tasks

  • Miscellaneous Tasks

Note that some of these solutions are not specific to BizTalk Server.


BizTalk Messaging Services Tasks

This section contains the following topics:

  • Clear BizTalk Messaging Configurations

  • Update Messaging Configurations with ADO Objects


Clear BizTalk Messaging Configurations

The following code clears the BizTalk Messaging Management database.

This example ClearBTMConfigurations method is written in Microsoft Visual Basic.

Sub ClearBTMConfigurations()

First, declare the variables, as shown in the following declaration:

    Dim Configuration, Obj, CurrObj, HomeOrgID

To delete all existing configurations, create a configuration object to access the messaging objects, as shown in the following code:

    Set Configuration = CreateObject("BizTalk.BizTalkConfig")

Then, loop through and delete all existing channels, as shown in the following code:

    Set Obj = Configuration.CreateChannel
    Set CurrObj = Configuration.Channels

    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing port groups, as shown in the following code:

    Set Obj = Configuration.CreatePortGroup
    Set CurrObj = Configuration.PortGroups
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing ports, as shown in the following code:

    Set Obj = Configuration.CreatePort
    Set CurrObj = Configuration.Ports
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing envelopes, as shown in the following code:

    Set Obj = Configuration.CreateEnvelope
    Set CurrObj = Configuration.Envelopes
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing document definitions, as shown in the following code:

    Set Obj = Configuration.CreateDocument
    Set CurrObj = Configuration.Documents
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing organizations, as shown in the following code:

    Set Obj = Configuration.CreateOrganization
    Set CurrObj = Configuration.Organizations
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)

Note the home (default) organization identifier, as shown in the following code:

        If Obj.IsDefault Then

Ensure that the home organization is not deleted and that it is saved for removing aliases, as shown in the following code.

            HomeOrgID = Obj.Handle
        ElseIf Obj.Name = "SEED Test Organization" Then

Do not perform any action at this point; only ensure that the SEED organization is not deleted.

        Else
            Obj.Remove
        End If

        CurrObj.MoveNext
    Wend

Clear the home organization aliases, except for the default alias and the alias with the organization name, as shown in the following code:

    Obj.load HomeOrgID
    Set CurrObj = Obj.Aliases

Then, reset the default alias, as shown in the following code:

    Obj.SaveAlias Obj.GetDefaultAlias, "sName" & Now(), False, "sQual" & Now(), "sValue" & Now()

    CurrObj.MoveFirst
    While Not CurrObj.EOF
        If CurrObj("qualifier") = "OrganizationName"  Then
            Obj.SaveAlias CurrObj(0), "Organization", True, "OrganizationName", Obj.Name
            Obj.Save
        Else

        If CurrObj("qualifier") <> "SMTP" then Obj.RemoveAlias CurrObj(0)
        End If

        CurrObj.MoveNext
    Wend

Loop through and delete all existing home organization applications, as shown in the following code:

    Set CurrObj = Obj.Applications
    While Not CurrObj.EOF
        Obj.RemoveApplication CurrObj("id")
        CurrObj.MoveNext
    Wend

    Obj.save

Finally, set all objects to Nothing to release memory back to the system, as shown in the following code:

    Set Obj = Nothing
    Set CurrObj = Nothing
    Set Configuration = Nothing
End Sub


Update Messaging Configurations with ADO Objects

The following code uses the Microsoft ActiveX® Data Objects (ADO) returned by the BizTalk Messaging Configuration object model to select a subset of existing channels, and to modify the configurations of those channels. In this sample, all existing channels using an input document definition name of "Invoice" will be selected, their RetryCount property will be updated to six retries, and their RetryInterval property will be set to ten minutes.

This example UpdateRetry method is written in Microsoft Visual Basic Scripting Edition (VBScript).

Sub UpdateRetry()

First, declare the variables, as shown in the following declaration:

    Dim objConfig
    Dim objChannel
    Dim objDoc
    Dim objADO

Then, create the channel and document objects, as shown in the following code:

    Set objConfig = CreateObject("BizTalk.BizTalkConfig")
    Set objChannel = objConfig.CreateChannel
    Set objDoc = objConfig.CreateDocument

Obtain a reference to the Channels recordset containing all existing channels in the BizTalk Messaging Management database, as shown in the following code:

    Set objADO = objConfig.Channels

Loop through all records in the recordset and load each channel by using the Handle provided in the first field of the record. Load the InputDocument associated with each channel to obtain the document definition name, and compare it to the string "Invoice" to select the appropriate records. When a record is selected, update the RetryCount and RetryInterval properties and Save the new channel configuration. This logic is shown in the following code:

    Do While NOT objADO.EOF
        objChannel.Load(objADO.Fields.Item(0))
        objDoc.Load(objChannel.InputDocument)
        If objDoc.Name = "Invoice" Then
            objChannel.RetryCount = 6
            objChannel.RetryInterval = 10
            objChannel.Save
        End If
        objADO.MoveNext
    Loop

Finally, set all objects to Nothing to release memory back to the system, as shown in the following code:

    Set objChannel = Nothing
    Set objConfig = Nothing
    Set objDoc = Nothing
    Set objADO = Nothing
End Sub


BizTalk Orchestration Services Tasks

This section contains the following topic:

  • Access a Messaging Port


Access a Messaging Port

The following code accesses a messaging port in an XLANG schedule instance:

This example is in Microsoft Visual Basic:

Dim oSked As IWFWorkflowInstance
Dim oPort

Set oSked = GetObject("sked://localhost/C:\temp\MySchedule.skx")
Set oPort = oSked.Port("PortIn")

This example is in VBScript:

Set oSked = GetObject("sked://localhost/C:\temp\MySchedule.skx")
Set oPort = oSked.Port("PortIn")


BizTalk Managing and Monitoring Tasks

This section contains the following topic:

  • WMI Tasks


WMI Tasks

To ensure that your Visual Basic projects can access the Windows® Management Instrumentation (WMI) objects used in the following topics, you need to add the Microsoft WMI Scripting V1.1 Library in the Reference dialog.

Then, you declare the following WMI locator and services variables:

Public g_objLocator As SWbemLocator
Public g_objService As SWbemServices

In addition, the following constants should be defined:

Public Const GROUP_NAMESPACE = "MicrosoftBizTalkServer_Group"
Public Const MGMT_NAMESPACE = "MicrosoftBizTalkServer_MgmtDB"
Public Const SERVER_NAMESPACE = "MicrosoftBizTalkServer_Server"
Public Const RECVSVC_NAMESPACE = "MicrosoftBizTalkServer_ReceiveFunction"
Public Const QUEUE_NAMESPACE = "MicrosoftBizTalkServer_Queue"
Public Const WORKQ_NAMESPACE = "MicrosoftBizTalkServer_WorkQueue"
Public Const SCHEDULEDQ_NAMESPACE = "MicrosoftBizTalkServer_ScheduledQueue"
Public Const RETRYQ_NAMESPACE = "MicrosoftBizTalkServer_RetryQueue"
Public Const SUSPENDEDQ_NAMESPACE = "MicrosoftBizTalkServer_SuspendedQueue"

You make the connection to WMI with the following code:

Set g_objLocator = New SWbemLocator
Set g_objService = g_objLocator.ConnectServer(, "root/MicrosoftBizTalkServer")

This section contains the following topics:

  • Documents and WMI

  • Groups and WMI

  • BizTalk Messaging Management Database and WMI

  • Receive Services and WMI

  • Servers and WMI

  • Queues and WMI


Documents and WMI

The code examples in this section are useful when working with documents and interchanges. An interchange is a collection of one or more document instances that makes up a single transmission.

This section presents functions that work together to convert variant data from a document or interchange into a string.

This section contains the following topic:

  • Displaying the Contents of a Document or an Interchange


Displaying the Contents of a Document or an Interchange

When you use the ViewDocument or ViewInterchange methods of the MicrosoftBizTalkServer_SuspendedQueue class, you might need to convert the returned byte array into a readable format.

The following function takes a code page and variant data and returns a string:

Function ConvertViewDocument(ByVal varData As Variant, ByVal codepage As Long) As String
    Dim varData2() As Byte
    Dim i As Long
    Dim strTemp As String
    Dim Dom As New DOMDocument

    On Error Resume Next
    ReDim varData2(UBound(varData))
    For i = LBound(varData) To UBound(varData)
        varData2(i) = varData(i)
        Next

    If codepage = -1 Then
        strTemp = CStr(varData2)
        Call Dom.loadXML(strTemp)
        If Err <> 0 Then
            ConvertViewDocument = ""
        ElseIf Dom.parseError.errorCode <> 0 Then
            ConvertViewDocument = ""
        Else
            ConvertViewDocument = Dom.xml
        End If
    Else
        ConvertViewDocument = ConvertVarToBstr(varData2, codepage)
    End If
End Function

The ConvertViewDocument function uses the following function to convert the variant data into a string:

Public Function ConvertVarToBstr(ByRef varData As Variant, ByVal strCodePage As String) As String
    Dim stm As New ADODB.Stream

    Select Case UCase(TypeName(varData))
        Case "STRING"
            ConvertVarToBstr = varData
        Case "BYTE()"
            stm.Type = adTypeBinary
            stm.Open
            stm.Write varData
            stm.Position = 0
            stm.Type = adTypeText
            stm.Charset = GetCharset(strCodePage)
            ConvertVarToBstr = stm.ReadText
            .Close
        Case Else
            ConvertVarToBstr = ""
    End Select
End Function

The ConvertVarToBstr function uses the following private function to return a character set:

Private Function GetCharset(ByVal codepage As String)
    Select Case codepage
        Case 932
            GetCharset = "shift-jis"
        Case 1252
            GetCharset = "us-ascii"
        Case 160001
            GetCharset = "utf-8"
        Case 1200
            GetCharset = "unicode"
    End Select
End Function


Groups and WMI

The code examples in this section are useful when working with groups. Server groups are collections of individual servers that are centrally managed, configured, and monitored.

This section presents functions that create a group, delete a group, retrieve a group by name, and retrieve all groups.

This section contains the following topics:

  • Creating a Group

  • Deleting a Group

  • Retrieving a Group by Name

  • Retrieving All Groups


Creating a Group

The following function creates a group:

Public Function CreateGroup(ByVal strGroupName As String, _
                ByVal strDocTrackDbLogon As String, _
                ByVal strDocTrackDbName As String, _
                ByVal strDocTrackDbPassword As String, _
                ByVal strDocTrackDbServer As String, _
                ByVal strQueueDbLogon As String, _
                ByVal strQueueDbName As String, _
                ByVal strQueueDbPassword As String, _
                ByVal strQueueDbServer As String, _
                Optional ByVal lAdminCacheRefreshInterval As Long, _
                Optional ByVal strSMTPHost As String, _
                Optional ByVal strReliableMessagingReplyToURL As String, _
                Optional UseProxyServer As Boolean, _
                Optional strProxyName As String, _
                Optional lProxyport As Long, _
                Optional lLoggingPointState As Integer) As Boolean
    Dim objBTGroup As SWbemObject
    Dim objBTGroupInstance As SWbemObject

    On Error Resume Next
    Set objBTGroup = g_objService.Get(GROUP_NAMESPACE)
    Set objBTGroupInstance = objBTGroup.SpawnInstance_

    CreateGroup = True

    objBTGroupInstance.Name = strGroupName
    objBTGroupInstance.DocTrackDbLogon = strDocTrackDbLogon
    objBTGroupInstance.DocTrackDbName = strDocTrackDbName
    objBTGroupInstance.DocTrackDbPassword = strDocTrackDbPassword
    objBTGroupInstance.DocTrackDbServer = strDocTrackDbServer
    objBTGroupInstance.QueueDbLogon = strQueueDbLogon
    objBTGroupInstance.QueueDbName = strQueueDbName
    objBTGroupInstance.QueueDbPassword = strQueueDbPassword
    objBTGroupInstance.QueueDbServer = strQueueDbServer

    If strReliableMessagingReplyToURL <> "" Then
        objBTGroupInstance.ReliableMessagingReplyToURL = strReliableMessagingReplyToURL
    End If
    If lAdminCacheRefreshInterval <> 0 Then
        objBTGroupInstance.ConfigurationCacheRefreshInterval = lAdminCacheRefreshInterval
    End If

    objBTGroupInstance.UseProxyServer = UseProxyServer
    objBTGroupInstance.ProxyHost = strProxyName

    If lProxyport = 0 Then
        objBTGroupInstance.ProxyPort = lProxyport
    Else
        objBTGroupInstance.ProxyPort = lProxyport
    End If

    objBTGroupInstance.LoggingPointState = lLoggingPointState
    objBTGroupInstance.SMTPHost = strSMTPHost
    objBTGroupInstance.Put_ (wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateGroup = False
    End If
End Function


Deleting a Group

The following function deletes a group:

Public Function DeleteGroup(ByVal strGroupName As String) As Boolean
    On Error Resume Next
    DeleteGroup = True
    Call g_objService.Delete(GROUP_NAMESPACE & ".NAME=""" & strGroupName & """")

    If Err <> 0 Then
        DeleteGroup = False
    End If
End Function


Retrieving a Group by Name

The following function retrieves a group by name:

Public Function GetGroupByName(ByVal strGroupName As String) As Object
    Dim objBTGroup As SwbemObject

    On Error Resume Next
    Set GetGroupByName = Nothing
    Set GetGroupByName = g_objService.Get(GROUP_NAMESPACE & ".NAME=""" & strGroupName & """")

    If Err <> 0 Then
    End If
End Function


Retrieving All Groups

The following function retrieves all groups:

Public Function GetAllGroups() As SWbemObjectSet
    Dim objBTGroup As SWbemObject

    On Error Resume Next
    Set GetAllGroups = Nothing
    Set objBTGroup = g_objService.Get(GROUP_NAMESPACE)
    Set GetAllGroups = objBTGroup.Instances_

    If Err <> 0 Then
    End If
End Function


BizTalk Messaging Management Database and WMI

The code examples in this section are useful when working with the BizTalk Messaging Management database. The BizTalk Messaging Management database stores information for all server configurations, including group and server settings, and receive functions.

This section presents functions that create the BizTalk Messaging Management database and retrieve the BizTalk Messaging Management database.

This section contains the following topics:

  • Creating the BizTalk Messaging Management Database

  • Retrieving the BizTalk Messaging Management Database


Creating the BizTalk Messaging Management Database

The following function creates the BizTalk Messaging Management database:

Public Function CreateMgmtDB(ByVal strMgmtDbLogon As String, _
                            ByVal strMgmtDBPassword As String, _
                            ByVal strMgmtDBServer As String, _
                            ByVal strMgmtDBDatabase As String, _
                            ByVal strLocalServer As String) As Boolean
    Dim objBTSMgmt As SWbemObject
    Dim objBTSMgmtInstance As SwbemObject

    On Error Resume Next
    CreateMgmtDB = True
    Set objBTSMgmt = g_objService.Get(GROUP_NAMESPACE)
    Set objBTSMgmtInstance = objBTGroup.SpawnInstance_
        objBTSMgmtInstance.MgmtDbLogon = strMgmtDbLogon
        objBTSMgmtInstance.MgmtDBPassword = strMgmtDBPassword
        objBTSMgmtInstance.MgmtDbServer = strMgmtDBServer
        objBTSMgmtInstance.MgmtDbDatabase = strMgmtDBDatabase
        objBTSMgmtInstance.localserver = strLocalServer
        objBTSMgmtInstance.Put_ (wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateMgmtDB = False
    End If
End Function


Retrieving the BizTalk Messaging Management Database

The following function retrieves the BizTalk Messaging Management database:

Public Function GetMgmtDB(ByVal strLocalServer As String) As SWbemObject
    Dim objBTSMgmt As SWbemObject
    Dim objSet_BTSMgmt As SWbemObjectSet
    Dim objBTSMgmtInstance As SWbemObject

    On Error Resume Next
    Set GetMgmtDB = Nothing
    Set objBTSMgmt = g_objService.Get(MGMT_NAMESPACE)
    Set objSet_BTSMgmt = objBTSMgmt.Instances_

    If objSet_BTSMgmt.Count <> 1 Then
        Exit Function
    End If

    Set GetMgmtDB = objSet_BTSMgmt.Item(MGMT_NAMESPACE & ".LocalServer=""" & strLocalServer & """")
End Function


Receive Services and WMI

The code examples in the section are useful when working with receive services. You create receive services to process data.

This section presents functions that create a File receive service, delete a File receive service, retrieve a receive service by name, retrieve all receive services, and retrieve all receive services by group.

This section contains the following topics:

  • Creating a File Receive Service

  • Deleting a File Receive Service

  • Retrieving a Receive Service by Name

  • Retrieving All Receive Services

  • Retrieving All Receive Services by Group


Creating a File Receive Service

The following function creates a File receive service:

Public Function CreateReceiveService(ByVal strRecvSvcName As String, _
                        ByVal strGroupName As String, _
                        ByVal strProcessingServer As String, _
                        ByVal strFileMask As String, _
                        ByVal fProtocolType As ProtocolType, _
                        ByVal strPollingLoc As String, _
                        Optional ByVal strPassword As String, _
                        Optional ByVal strUsername As String, _
                        Optional ByVal strDocumentName As String, _
                        Optional ByVal strSourceID As String, _
                        Optional ByVal strSourceQualifier As String, _
                        Optional ByVal strDestinationID As String, _
                        Optional ByVal strDestinationQualifier As String, _
                        Optional ByVal lOpenness As Integer, _
                        Optional ByVal lPassthrough As Integer, _
                        Optional ByVal strChannelName As String, _
                        Optional fDisabled As Boolean, _
                        Optional ByVal strEnvelopeName As String, _
                        Optional ByVal strComment As String, _
                        Optional ByVal strPreProcessor As String) As Boolean
    Dim objBTSRecvSvc As SWbemObject
    Dim objBTSRecvSvcInstance As SWbemObject

    On Error Resume Next
    CreateReceiveService = True
    Set objBTSRecvSvc = g_objService.Get(RECVSVC_NAMESPACE)
    Set objBTSRecvSvcInstance = objBTSRecvSvc.SpawnInstance_

        objBTSRecvSvcInstance.Name = strRecvSvcName
        objBTSRecvSvcInstance.groupName = strGroupName
        objBTSRecvSvcInstance.Comment = strComment
        objBTSRecvSvcInstance.FilenameMask = strFileMask
        objBTSRecvSvcInstance.ProcessingServer = strProcessingServer
        objBTSRecvSvcInstance.ProtocolType = fProtocolType
        objBTSRecvSvcInstance.PollingLocation = strPollingLoc
        objBTSRecvSvcInstance.password = strPassword
        objBTSRecvSvcInstance.UserName = strUsername
        objBTSRecvSvcInstance.DocumentName = strDocumentName
        objBTSRecvSvcInstance.SourceID = strSourceID
        objBTSRecvSvcInstance.SourceQualifier = strSourceQualifier
        objBTSRecvSvcInstance.DestinationID = strDestinationID
        objBTSRecvSvcInstance.DestinationQualifier = strDestinationQualifier
        objBTSRecvSvcInstance.EnvelopeName = strEnvelopeName
        objBTSRecvSvcInstance.DisableReceiveFunction = fDisabled
        objBTSRecvSvcInstance.PreProcessor = strPreProcessor

    If lOpenness <> 0 Then
        objBTSRecvSvcInstance.OpennessFlag = lOpenness
    End If

    If lPassthrough <> 0 Then
        objBTSRecvSvcInstance.IsPassThrough = lPassthrough
    End If

    If strChannelName <> "" Then
        objBTSRecvSvcInstance.ChannelName = strChannelName
    End If

        objBTSRecvSvcInstance.Put_ (wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateReceiveService = False
    End If
End Function


Deleting a File Receive Service

The following function deletes a File receive service:

Public Function DeleteReceiveSvc(ByVal strRecvSvcName As String) As Boolean
    On Error Resume Next
    DeleteReceiveSvc = True
    Call g_objService.Delete(RECVSVC_NAMESPACE & ".NAME=""" & strRecvSvcName & """")

    If Err <> 0 Then
        DeleteReceiveSvc = False
    End If
End Function


Retrieving a Receive Service by Name

The following function retrieves a receive service by name:

Public Function GetReceiveFunctionByName(ByVal strRecvFunction As String) As SWbemObject
    On Error Resume Next
    Set GetReceiveFunctionByName = Nothing
    Set GetReceiveFunctionByName = g_objService.Get(RECVSVC_NAMESPACE & ".NAME=""" & strRecvFunction & """")

    If Err <> 0 Then
    End If
End Function


Retrieving All Receive Services

The following function retrieves all receive services:

Public Function GetAllReceiveServices() As SWbemObjectSet
    Dim objBTSRecvSvc As SWbemObject

    On Error Resume Next
    Set GetAllReceiveServices = Nothing
    Set objBTSRecvSvc = g_objService.Get(RECVSVC_NAMESPACE)
    Set GetAllReceiveServices = objBTSRecvSvc.Instances_

    If Err <> 0 Then
    End If
End Function


Retrieving All Receive Services by Group

The following function retrieves all receive services by group:

Public Function GetAllReceiveSvcsByGroup(ByVal strGroupName As String)
    Dim strWMIQuery As String

    On Error Resume Next
    strWMIQuery = "select * from " & RECVSVC_NAMESPACE & " where groupname= '" & strGroupName & "'"
    Set GetAllReceiveSvcsByGroup = g_objService.ExecQuery(strWMIQuery)

    If Err <> 0 Then
    End If
End Function


Servers and WMI

The code examples in this section are useful when working with servers. A server in a server group hosts the appropriate BizTalk Messaging Services functionality to manage document exchange between other servers and applications that are external to the BizTalk Server group.

This section presents functions that create a server, delete a server, start a server, stop a server, retrieve a server by name, retrieve all servers, and retrieve all servers by group.

This section contains the following topics:

  • Creating a Server

  • Deleting a Server

  • Starting a Server

  • Stopping a Server

  • Retrieving a Server by Name

  • Retrieving All Servers

  • Retrieving All Servers by Group


Creating a Server

The following function creates a server:

Public Function CreateServer(ByVal strServerName As String, _
                        ByVal strGroupName As String, _
                        ByVal lMaxWorkerThreadsPerProcessor As Long, _
                        ByVal lSchedulerWaitTime As Double) As Boolean
    Dim objBTSSvr As SWbemObject
    Dim objBTSSvrInstance As SWbemObject

    On Error Resume Next
    CreateServer = True
    Set objBTSSvr = g_objService.Get(SERVER_NAMESPACE)
    Set objBTSSvrInstance = objBTSSvr.SpawnInstance_

        objBTSSvrInstance.Name = strServerName
        objBTSSvrInstance.groupName = strGroupName
        objBTSSvrInstance.MaxWorkerThreadsPerProcessor = lMaxWorkerThreadsPerProcessor
        objBTSSvrInstance.SchedulerWaitTime = lSchedulerWaitTime

    Call objBTSSvrInstance.Put_(wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateServer = False
    End If
End Function


Deleting a Server

The following function deletes a server:

Public Function DeleteServer(ByVal strServerName As String) As Boolean
    On Error Resume Next
    DeleteServer = True
    Call g_objService.Delete(SERVER_NAMESPACE & ".NAME=""" & strServerName & """")

    If Err <> 0 Then
        DeleteServer = False
    End If
End Function


Starting a Server

The following function starts a server:

Public Function StartServer(ByVal strServerName As String) As Boolean
    Dim strWMIPath As String
    Dim objBTSSvrs As SWbemObject

    On Error Resume Next
    StartServer = True
    strWMIPath = SERVER_NAMESPACE & ".NAME=""" & strServerName & """"
    Set objBTSSvrs = g_objService.ExecMethod(strWMIPath, "StartServer")

    If Err <> 0 And Hex(Err) <> "80070420" Then
        StartServer = False
    Else
        Err.Clear
    End If
End Function

Note that if Err is not equal to 0, and the hexadecimal value of the error is not equal to 80070420, then the service was already running.


Stopping a Server

The following function stops a server:

Public Function StopServer(ByVal strServerName As String) As Boolean
    Dim strWMIPath As String
    Dim objBTSSvrs As SWbemObject

    On Error Resume Next
    StopServer = True
    strWMIPath = SERVER_NAMESPACE & ".NAME=""" & strServerName & """"
    Set objBTSSvrs = g_objService.ExecMethod(strWMIPath, "StopServer")

    If Err <> 0 And Hex(Err) <> "80070426" Then
        StopServer = False
    Else
        Err.Clear
    End If
End Function

Note that if Err is not equal to 0, and the hexadecimal value of the error is not equal to 80070426, then the service was not running.


Retrieving a Server by Name

The following function retrieves a server by name:

Public Function GetServerByName(ByVal strServerName As String) As SWbemObject
    On Error Resume Next
    Set GetServerByName = Nothing
    Set GetServerByName = g_objService.Get(SERVER_NAMESPACE & ".NAME=""" & strServerName & """")
End Function


Retrieving All Servers

The following function retrieves all servers:

Public Function GetAllServers() As SWbemObjectSet
    Dim objBTSSvrs As SWbemObject

    On Error Resume Next
    Set objBTSSvrs = g_objService.Get(SERVER_NAMESPACE)
    Set GetAllServers = objBTSSvrs.Instances_
End Function


Retrieving All Servers by Group

The following function retrieves all servers by group:

Public Function GetAllServersByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Dim strWMIQuery As String

    On Error Resume Next
    strWMIQuery = "select * from " & SERVER_NAMESPACE & " where groupname= '" & strGroupName & "'"
    Set GetAllServersByGroup = g_objService.ExecQuery(strWMIQuery)
End Function


Queues and WMI

The code examples in this section are useful when working with queues. Queues are used to contain incoming and outgoing documents that are in various stages of routing and processing in BizTalk Server.

This section presents functions that retrieve queues by group and retrieve all queues.

This section contains the following topics:

  • Retrieving Queues by Group

  • Retrieving All Queues


Retrieving Queues by Group

This section illustrates functions that retrieve the Work, Retry, Suspended, or Scheduled queue by group.

The Work queue contains documents that are currently being processed by BizTalk Server. The following function retrieves the Work queue by group:

Public Function GetWorkQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetWorkQByGroup = GetXXXXQByGroup(strGroupName, WORKQ_NAMESPACE)
End Function

The Retry queue contains documents that are being resubmitted for delivery and documents that are waiting for reliable messaging receipts. The following function retrieves the Retry queue by group:

Public Function GetRetryQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetRetryQByGroup = GetXXXXQByGroup(strGroupName, RETRYQ_NAMESPACE)
End Function

The Suspended queue contains work items that have failed processing for a variety of reasons, including parsing errors, serialization errors, and failed transmissions. The following function retrieves the Suspended queue by group:

Public Function GetSuspendedQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetSuspendedQByGroup = GetXXXXQByGroup(strGroupName, SUSPENDEDQ_NAMESPACE)
End Function

The Scheduled queue contains work items that have been processed by BizTalk Server and are waiting for transmission. The following function retrieves the Scheduled queue by group:

Public Function GetScheduledQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetScheduledQByGroup = GetXXXXQByGroup(strGroupName, SCHEDULEDQ_NAMESPACE)
End Function

The following helper function is used by the previous functions to retrieve a given queue by group:

Public Function GetXXXXQByGroup(ByVal strGroupName As String, ByVal QueueNameSpace As String) As SWbemObjectSet
    Dim strWMIQuery As String

    On Error Resume Next
    strWMIQuery = "select * from " & QueueNameSpace & " where group= """ & strGroupName & """"
    Set GetXXXXQByGroup = g_objService.ExecQuery(strWMIQuery)
End Function


Retrieving All Queues

The following function retrieves all queues:

Public Function GetAllQueues() As SWbemObjectSet
    Dim objBTQueue As SWbemObject

    On Error Resume Next
    Set GetAllQueues = Nothing
    Set objBTQueue = g_objService.Get(QUEUE_NAMESPACE)
    Set GetAllQueues = objBTQueue.Instances_
End Function


Miscellaneous Tasks

This section contains the following topics:

  • Determine if BizTalk Server is Installed

  • Modify the XML Encoding

  • Retrieve BizTalk Server Product Information

  • Validate an XML Document


Determine if BizTalk Server is Installed

The following code determines if BizTalk Server is installed on the local machine.

Dim objService, objLocator, objConfig, strGroupName

Set objLocator = CreateObject("WbemScripting.SWbemLocator")

On Error Resume Next
Set objService = objLocator.ConnectServer(, "root/MicrosoftBizTalkServer")

PassFail "Unable to connect to BizTalk Server. Please verify that your BizTalk " & "Server is installed and functions properly."

Sub PassFail(strScope)
    If Err.Number <> 0 Then

MsgBox strScope & " Error: x" & Hex(Err.Number) & " Description: " & Err.Description & " Source: " & Err.Source

        Err.Clear
    Else

MsgBox "BizTalk Server appears to be installed."

    End If
End Sub


Modify the XML Encoding

BizTalk Server uses UTF-8 encoding in XML output files by default. Use the following Microsoft Visual Basic Scripting Edition (VBScript) code to specify a different encoding type:

set xmlObj = CreateObject("MSXML2.DomDocument.3.0")
wscript.echo wscript.arguments(1)

if wscript.arguments.count < 2 then
    wscript.echo "Usage: encoding.vbs XMLDocument Encoding"
    wscript.quit
end if

if xmlobj.load(wscript.arguments(0)) = False then
    wscript.echo "Unable to load the XML document."
    wscript.Echo "Error: " + xmlobj.ParseError.Reason + "Line: " + CStr(xmlobj.ParseError.Line)
    wscript.quit
end if

if (xmlObj.firstChild.nodeType = 7) and (xmlObj.firstChild.nodeName = "xml") then
    set child = xmlObj.firstChild
    xmlObj.removeChild child
end if

set pi = xmlObj.createProcessingInstruction("xml","version='1.0' encoding='" & wscript.arguments(1) & "'")
xmlObj.insertBefore pi, xmlObj.firstChild
xmlObj.save "newxml.xml"
wscript.echo "Done"

Notes

  • The "Usage" statement assumes that the script file containing this code is named encoding.vbs.

  • The first argument is the name of the XML document to be modified.

  • The second argument is a valid XML encoding value.

  • A new, modified version of the input XML file is created in the same folder with the name newxml.xml.

To run this script, open a Command Prompt window and use the following syntax:

C:\ > wscript encoding.vbs file.xml enctype

Where file.xml is the name of the XML file to be converted, and enctype is the encoding type to be used in the XML file.

To use this code with XML files created by BizTalk Server, you can create an application integration component (AIC) that incorporates similar XML document object model code. If you prefer to manually edit the file or run the script shown above, you can use the file transport protocol on the port to create the XML files to be converted.

Related Topics

Application Integration Components

Specify a transport address


Retrieve BizTalk Server Product Information

The following VBScript example uses the Microsoft Windows Installer Object Library to obtain information about BizTalk Server. In a Microsoft Visual Basic project, use the Microsoft Windows Installer Object Library (\system32\msi.dll).

Public objInstaller
Const gstrProductName = "Microsoft BizTalk Server 2002"

Sub Main()
    Dim guidProductCode

        On Error Resume Next
        Set objInstaller = CreateObject("WindowsInstaller.Installer")
        guidProductCode = GetProductGuid(gstrProductName)
        Wscript.echo "PRODUCT INFORMATION" & vbNewLine & vbNewLine & GetProductInfo(guidProductCode)
End Sub

Function GetProductGuid(sProductName)
    Dim sName
    Dim guidProductCode

        On Error Resume Next
        GetProductGuid = ""

        For Each guidProductCode In objInstaller.Products
            sName = objInstaller.ProductInfo(guidProductCode, "ProductName")

            If (LCase(sProductName) = LCase(sName)) Then
                GetProductGuid = CStr(guidProductCode)
                Exit For
            End If
        Next
End Function

Function GetProductInfo(guidProductCode)
    Dim s

    On Error Resume Next
    s = "ProductInfo for " & guidProductCode & vbNewLine
    s = s & vbNewLine
    s = s & "InstalledProductName: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstalledProductName") & vbNewLine
    s = s & "VersionString: " & vbTab & objInstaller.ProductInfo(guidProductCode, "VersionString") & vbNewLine
    s = s & "HelpLink:      " & vbTab & objInstaller.ProductInfo(guidProductCode, "HelpLink") & vbNewLine
    s = s & "HelpTelephone: " & vbTab & objInstaller.ProductInfo(guidProductCode, "HelpTelephone") & vbNewLine
    s = s & "InstallLocation: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstallLocation") & vbNewLine
    s = s & "InstallSource: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstallSource") & vbNewLine
    s = s & "InstallDate: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstallDate") & vbNewLine
    s = s & "Publisher: " & vbTab & objInstaller.ProductInfo(guidProductCode, "Publisher") & vbNewLine
    s = s & "LocalPackage: " & vbTab & objInstaller.ProductInfo(guidProductCode, "LocalPackage") & vbNewLine
    s = s & "URLInfoAbout: " & vbTab & objInstaller.ProductInfo(guidProductCode, "URLInfoAbout") & vbNewLine
    s = s & "URLUpdateInfo: " & vbTab & objInstaller.ProductInfo(guidProductCode, "URLUpdateInfo") & vbNewLine
    s = s & "VersionMinor: " & vbTab & objInstaller.ProductInfo(guidProductCode, "VersionMinor") & vbNewLine
    s = s & "VersionMajor: " & vbTab & objInstaller.ProductInfo(guidProductCode, "VersionMajor") & vbNewLine
    s = s & vbNewLine
    s = s & "Transforms: " & vbTab & objInstaller.ProductInfo(guidProductCode, "Transforms") & vbNewLine
    s = s & "Language: " & vbTab & objInstaller.ProductInfo(guidProductCode, "Language") & vbNewLine
    s = s & "ProductName: " & vbTab & objInstaller.ProductInfo(guidProductCode, "ProductName") & vbNewLine
    s = s & "AssignmentType: " & vbTab & objInstaller.ProductInfo(guidProductCode, "AssignmentType") & vbNewLine
    s = s & "PackageCode: " & vbTab & objInstaller.ProductInfo(guidProductCode, "PackageCode") & vbNewLine
    s = s & "Version:        " & vbTab & objInstaller.ProductInfo(guidProductCode, "Version") & vbNewLine
    s = s & "ProductIcon: " & vbTab & objInstaller.ProductInfo(guidProductCode, "ProductIcon") & vbNewLine
    GetProductInfo = s
End Function

Main


Validate an XML Document

The following code validates an XML document:

Dim xmlDoc As New Msxml2.DOMDocument

    xmlDoc.async = False
    xmlDoc.validateOnParse = True
    xmlDoc.Load "myXML.xml"


BizTalk Server Samples

Samples provided in the BizTalk Server SDK are located in the folder \Program Files\Microsoft BizTalk Server\SDK on the installation drive. These samples should not be used in a production environment.

Sample Requirements

The samples provided with BizTalk Server require one or more of the following applications:

  • Microsoft Visual Basic® is necessary to modify and compile the Visual Basic source files, such as .vbp files, that are included in the SDK. The Visual Basic runtime, VB6.exe, is also needed to run some of the executable files included in the SDK.

  • A compiler and source code editor, such as Microsoft Visual C++®, is necessary to modify and compile the C++ source files.

  • Microsoft Word or Wordpad is necessary to view some of the readme files that use a .doc file type extension.

  • An HTML browser, such as Microsoft Internet Explorer, is necessary to view some of the readme files that use an .htm file type extension.

This section contains the following topics:

  • BizTalk Messaging Services Code Samples

  • BizTalk Orchestration Services Code Samples

E-Procurement Sample


BizTalk Messaging Services Code Samples

Sample files are located in the Messaging Samples folder on the Microsoft BizTalk Server installation drive. Browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples on the installation drive to find the sample files. This is only a relative path. Depending on your installation of BizTalk Server 2002, you might need to modify this path.

  • Application Integration in Visual Basic

  • Application Integration in Visual C++

  • BizTalk Framework Developers' Toolkit

  • Configuration Assistant

  • Custom Counters

  • Custom Import Module

  • Custom Preprocessor in Visual Basic

  • Custom Preprocessor in Visual C++

  • Date Functoid

  • Date Functoid with .NET

  • Direct Integration

  • Distribution List

  • EDI and Receipts

  • EDI Introduction

  • Encryption and Decryption

  • Flat-File Delimited

  • Flat-File Positional

  • HTTP Receive Function

  • Mapping Twice

  • Message Queuing 4 MB Limit

  • Multi-part MIME Attachment

  • Pipeline Component in Visual Basic

  • Pipeline Component in Visual C++

  • Queue Sniffer

  • Receive Scripts

  • Refresh Messaging Manager

  • Reliable Messaging

  • Self Routing

  • Send To Remote Queue

  • Submitting Documents

  • Submitting Documents with Receipts

  • Submitting Documents to a Port Group

  • Suspended Queue Monitoring

  • Synchronous Orchestration Component

  • Tracking Database Tasks

  • Windows Management Instrumentation

Notes

  • When using C++, you need to add \Program Files\Microsoft BizTalk Server\SDK\Include to the include directory list.

  • Some of the samples have a dependency on the Pipecomplib.tlb file. For these samples, you need to add \Program Files\Common Files\Microsoft Shared\Enterprise Servers\Commerce to the include directory list.


Application Integration in Visual Basic

This sample demonstrates an application integration component (AIC) that implements the IBTSAppIntegration interface. The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the BizTalk Server WebDAV repository), instantiates a schedule (provided with this sample) and passes the document to the schedule. The schedule gets the document and sends it to the file C:\temp\WFOut.txt.

For a related sample, see Application Integration in Visual C++.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTSAppIntegration\VB

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual Basic component (this is optional because the DLL is provided with the sample).

  2. Register the component, its category IDs, and its setup configuration by running the script:

    cscript scenario.wsf //job:setup

    When prompted whether to register information from Affinity.reg, click Yes. The component progid is "BTSSamples_IBTSAppInt_VB AIC2Sched".

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_AIC2Sched" by using the script:

    cscript scenario.wsf //job:submit

    If the submission succeeds, the document appears in C:\temp\WFOut.txt.


Application Integration in Visual C++

This sample demonstrates an application integration component (AIC) that implements the IBTSAppIntegration interface by using the Active Template Library (ATL). The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the BizTalk Server WebDAV repository) and returns the first element of the document.

For a related sample, see Application Integration in Visual Basic.

Note

  • This sample requires the Microsoft XML Parser (MSXML) version 3.0 or higher.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTSAppIntegration\VC\ATL

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual C++ component.

  2. Set up the configuration by running the script:

    cscript scenario.wsf //job:setup

    The component progid is "BTSSamples.AtlIBTSAppInt".

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_ATL_IBTSAppInt_AIC" by using the script:

    cscript scenario.wsf //job:SubmitSync

    If the submission succeeds, it replies with the first element of the submitted document.


BizTalk Framework Developers' Toolkit

This sample demonstrates how to programmatically access the BizTalk Framework 2.0 tags in a message.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTFDevToolkit

User's Guide

Before running the sample, complete the following steps:

  1. Register one of the envelope objects using regsvr32. Depending on which version of the XML parser you have (version 2.0, version 2.6, or version 3.0), register BTFEnvelope20.dll, BTFEnvelope26.dll, or BTFEnvelope30.dll respectively. Note that only one of these libraries can be registered at a time because they share a common CLSID.
    2. Copy SchemaPluginGenerator.dll to $:\Microsoft Visual Studio\Common\MSDev98\AddIns and run regsvr32 on the DLL to register it. The AddIns folder path location can vary depending on where Microsoft Visual Studio® is installed.
  3. Copy the file pigen.ini to the same location as SchemaPluginGenertor.dll (the Visual Studio AddIns folder).

  4. Register the MSPlugin type library depending on which version of the XML parser you are running. Register the type library MSPlugin20.tlb, MSPlugin26.tlb, or MSPlugin30.tlb if you are using XML parser version 2.0, version 2.6, or version 3.0 respectively You can register this file by verifying, and updating if necessary, the TLB file location paths in Plugin2.reg. After the paths are correct, you can run the Plugin2.reg file by double-clicking it.

  5. Copy the following files to the Template\Classes folder in the Visual Basic program tree, $:\Microsoft Visual Studio\VB98\Template\Classes:
    • Microsoft Plugin class instance.cls

    • Microsoft Plugin collection instance.cls

    • Microsoft Plugin Main.cls

    Be sure that these files are not read-only.

  6. Copy the following file to the Template\Code folder in the Visual Basic program tree, $:\Microsoft Visual Studio\VB98\Template\Code:
    • modXMLHelper3.bas

    Be sure that this file is not read-only.

  7. Load the code generator. Open Visual Basic and run the Add-In manager. You should see the following available add-in: BTF Developers Toolkit Schema Plug-in Generator. Select the Loaded/Unloaded check box to load the add-in. It will appear in the Add-Ins drop-down menu.

To run the sample, you must have the following components installed:

  1. Visual Basic version 6.0 SP3 or SP4

  2. Microsoft XMLDOM typelib {F5078F18-C551-11D3-89B9-0000F81FE221}. There are components specifically targeted at all three versions (2.0, 2.6, and 3.0) of the Microsoft XML Parser (MSXML). Any one of these three versions of the document object model (DOM) will work. Read UsingPluginGenerator.doc for more information about the DOM-targeted versions of the BTFEnvelope component and the MSPlugin type library.

Programming Notes

The Resource Kit components consist of two core components and a type library:

  • Envelope object. This object provides programmatic access to the BTF2.0 header tags in the XML document, including management of the message body and the ability to add documents.

  • Plugin code generator. This takes an XDR schema and generates a "plugin" set of Microsoft Visual Basic COM components that provide programmatic access to the BODY tags in a BTF 2.0 message.

  • PlugIn2 interface. Exposed through the MSPlugin type library. This interface is implemented by the generated plugin component and called by the Envelope object. This interface is the link between the Envelope and the Plugin.

You can find further documentation on the Envelope and Plugin in the files UsingPluginGenerator.doc and EnvelopeAndPlugin.doc. The BizTalk Framework 2.0 (BTF) tag specification and the XML-Data Reduced (XDR) schema documentation can be found at http://msdn.microsoft.com/xml. It is highly recommended that you read the BTF specification and the UsingPluginGenerator documents before you use the components. You can obtain further architectural detail from the EnvelopeAndPlugin document.

Known Issues

  • The Plugin generator does not support XDR <group> structures when nested within another <group>. Generated code will work, but the embedded group will not have object model access code. In this scenario the IXMLDOMNode nodes will be available and the plugin is still usable and correct.

  • The generator will treat XDR order="one" attributes like order="many" because it does not know which child element will eventually be used. The programmer must set only one child element so that the resulting XML document will be valid.

  • The Visual Basic "Microsoft Plugin" template files located under $:\Microsoft Visual Studio\VB98\Template must not be read-only. If they are read-only, the generator will fail when adding modules to the targets Visual Basic project.

  • The BTFEnvelope object does not yet support BTF 2.0 Multipart MIME structures and Reliable Delivery structures. While this support is not directly developed into the component, the DOM nodes at each level are exposed so that they can easily be extended and customized.

  • The envelope can currently accept only one business document added to its body. Therefore it is not currently possible to add or access more than one business document nested in the body.


Configuration Assistant

This sample enables you to view all details of a BizTalk Server configuration and to export and import that configuration. The configuration export and import is completed as a package that includes all messaging objects such as document specifications, maps, custom parsers, serializers, and application integration components (AIC).

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTConfigAssistant

User's Guide

Detailed information is provided in the Readme.doc file located in the BTConfigAssistant folder.


Custom Counters

This sample allows you to create a custom counter that you can use to count the number of documents in the Tracking database (DTA) that match a specified set of criteria. This sample allows you to create two types of counters, one based on source and destination organization names, and one based on qualifier and value pairs. Each counter is validated after it is created.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Custom Counter

User's Guide

Before running the scripts, complete the following steps:

  1. On the C drive, create a folder called CustomCounterSample with two subfolders called SrcOrg and DestOrg.

  2. On the BizTalk Server installation drive, copy POReq.xml to \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

  3. Run CustomCounterConfig.vbs to configure BizTalk Messaging Services.

To run documents through the DTA, copy and paste PORequest.xml to the C:\CustomCounterSample\SrcOrg folder. You should see an output file, Output.xml, in the C:\CustomCounterSample\DestOrg folder. Each time you do this an additional record will be tracked in the DTA.

To create a custom counter based on source and destination organization names, run CreateCustomCounter_Organizations.vbs.

To create a custom counter based on qualifier and value pairs, run CreateCustomCounter_Identifiers.vbs.

The first time you run each script, you will be creating an instance of the counter classes. When you run the script again to view the number of matching documents in the DTA, you will update the class.

To run the sample, you need to remove the read-only property from the sample data file, PORequest.xml.

Important

  • When calling the Put_ method to create or update the custom counter setting object, the wbemChangeFlagCreateOrUpdate flag is not supported. Instead, you must specify either wbemChangeFlagCreateOnly or wbemChangeFlagUpdateOnly, depending on whether you want to create or update the custom counter setting object. As a result, you need to update the source code of CreateCustomCounter_Organizations.vbs or CreateCustomCounter_Identifiers.vbs accordingly.

    For example, the following code from both the sample scripts creates the custom counter setting object:

    objCustomCounterSetting.Put_(wbemChangeFlagCreateOnly)

    To update the existing custom counter setting object, modify the code by specifying the wbemChangeFlagUpdateOnly flag, as shown in the following code:

    objCustomCounterSetting.Put_(wbemChangeFlagUpdateOnly)

    When you run the script again, the existing custom counter setting object will be updated.

    When the sample scripts are first installed, they are set up to create a custom counter setting object, in order to update the custom counter setting object and query the MatchCount property, you will need to update the scripts as specified above.

  • For the value of the MatchCount property to be consumed by Microsoft Operations Manager (MOM), the MOM DAS account must be a member of the BizTalk Server Administration group.

Programming Notes

This sample uses the MSBTS_CustomCounterSetting and MSBTS_CustomCounter Windows Management Instrumentation (WMI) classes. To locate the definitions of these classes, view the InterchangeProvSchema.mof file. The MatchCount property of MSBTS_CustomCounter is incremented each time a document runs through the DTA.


Custom Import Module

This sample creates a custom import module that imports a flat file and displays it in BizTalk Editor. The imported file is a delimited flat file exported from an SQL table. It is an ANSI file that uses "{CR}{LF}" as the row delimiter and comma as the column delimiter. The first line contains column names. The custom import module first creates a schema root called "SQLFile". It then parses the first line of the input file, extracts each column name, and creates each column as a text-only element under the root. The import module returns an XDR schema with BizTalk Server annotations.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleImporter

User's Guide

To use this sample in BizTalk Editor, follow these steps:

  1. Register CustomImporter.dll (run regsvr32 CustomImporter.dll).

  2. Merge CustomImporter.reg (right-click CustomImporter.reg and then click Merge).

  3. In BizTalk Editor, on the Tools menu, click Import. The "Custom data" import module will appear in the "Select Import Module" window.

  4. Select 'sqlfile.txt'. The BizTalk Editor tree view window will display the schema structure that was created based on the input file.

  5. Select 'Blank.txt'. BizTalk Editor will display a dialog box that indicates a "column not found" error.

  6. Select 'FilewithWarning.txt'. BizTalk Editor will report warnings in the output window.

To remove this custom importer from BizTalk Editor, you need to unregister CustomImporter.dll by using the command: run regsvr32 /u CustomImporter.dll.


Custom Preprocessor in Visual Basic

This sample demonstrates a very simple implementation of a custom preprocessor to be used with a File receive function.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\VBCustPreProcessor

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual Basic project into VBCustPreProcessor.dll.

  2. Register VBCustPreProcessor.dll by using regsvr32.

To run the sample, follow these steps:

  1. Set up a File receive function.

  2. Submit a document to BizTalk Server.

  3. Submit a document to the receive function.

Programming Notes

The Execute method simply loads the file into the XML DOM and then returns the XML data to BizTalk Server. The files should therefore always contain XML for the purposes of this sample.

This sample also demonstrates how to obtain context information from BizTalk Server although it does not actually use this context information during processing.


Custom Preprocessor in Visual C++

This sample demonstrates a very simple implementation of a custom preprocessor to be used with either File or Message Queuing receive functions.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\CustomPreProcessor

User's Guide

Before running the sample, complete the following steps:

  1. Compile the source files provided in this folder into CustomPreProcessorps.dll.

  2. Register CustomPreProcessorps.dll by using regsvr32.

To run the sample, follow these steps:

  1. Set up either a File receive function or a Message Queuing receive function.

  2. Submit a document to the receive function.

Programming Notes

When used by a File receive function, the Execute method simply loads the file into the XML DOM and then returns the XML data to BizTalk Server. The files should therefore always contain XML for the purposes of this sample.

When used by a Message Queuing receive function, if the input data contains an array of bytes, it is converted to a BSTR. Alternatively, if the input data contains a BSTR, it is converted to an array of bytes.

This sample also demonstrates how to obtain context information from BizTalk Server although it does not actually use this context information during processing.


Date Functoid

This sample creates a custom functoid that converts date formats. It converts a date in ISO format (generated from Date(), Time(), Now() in Visual Basic or from Date, Time, DateTime functoids) to a date in mm-dd-yyyy format. This sample is similar to the Date Functoid with .NET sample that is written in Visual C#™ .NET.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleFunctoid

User's Guide

Before running the sample, complete the following steps:

  1. Register DateConversion.dll (run regsvr32 DateConversion.dll).

  2. Merge DateConversion.reg (right-click DateConversion.reg and then click Merge).

To run the sample in BizTalk Mapper:

  • Select the DateConversion functoid that appears in the functoid palette on the Date/Time tab.


Date Functoid with .NET

This sample creates a custom functoid that converts date formats. It converts a date in ISO format (generated from Date(), Time(), Now() in Visual Basic or from Date, Time, DateTime functoids) to a date in mm-dd-yyyy format. This sample is written in Visual C# .NET and shows how to write a functoid by using Microsoft .NET Framework. This sample is identical in functionality to the Date Functoid sample that is written in Visual Basic.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DateFunctoidNet

User's Guide

Before running the sample, complete the following steps:

  1. Register AssemblyPathFinder.dll by typing the following two commands:

    regasm AssemblyPathFinder.dll

    gacutil /i AssemblyPathFinder.dll

  2. Register AssemblyPathFinderProxy.dll by using the command:

    run regsvr32 AssemblyPathFinderProxy.dll

To run the sample with BizTalk Mapper, follow these steps:

  1. Run buildme.bat.

  2. Merge DateFunctoidNet.reg (right-click DateFunctoidNet.reg and then click Merge).

  3. The DateFunctoidNet functoid appears in the functoid palette on the Date/Time tab.

To remove this functoid from the BizTalk Mapper functoid palette, follow these steps:

  1. Run unreg.bat

  2. Delete the following key from the registry (by using regedit):

    HKEY_CLASSES_ROOT\CLSID\{722FF791-A0F8-42b9-B390-16C3F9238A5E}

Programming Notes

.NET Framework must be installed to run this sample.


Direct Integration

This sample demonstrates the use of IInterchange methods to submit documents to BizTalk Server. A user interface offers the ability to set parameters interactively before submitting a document.

The sample also contains the source code for a component that can be used to unpack binary buffers returned as BSTR. Buffers are converted to safe character arrays. The component is used by the main sample when saving data items from the Suspended queue to file.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DirectIntegration

User's Guide

Detailed information is provided in the Readme.doc file located in the DirectIntegration folder.


Distribution List

This sample consists of independent Visual Basic and Visual C++ samples that configure and run a DistributionList, or port group, scenario that sends documents to multiple trading partners. The two samples perform the same tasks and show how to implement those tasks by using two different programming languages.

The sample Submitting Documents to a Port Group contains related information.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DistributionList

User's Guide

Before running the sample, complete the following steps:

  1. In the C++ sample, compile the source files DistributionList.cpp and DistributionList.h into an executable file.

  2. In the Visual Basic sample, create an executable file from the DistributionList project (.bas) file.

To run the sample:

  • Run the .exe file that you created in the preceding steps.

Programming Notes

In the C++ sample, the code shows how to set up the BizTalk Messaging Management database to submit a CommonPO document to a distribution list (port group).

The distribution list consists of two ports:

Port "SRC -> DST Port" wraps the input document in a BizTalk Framework (BTF) 2.0 envelope and drops the output to the file "%HOMEDRIVE%\DL_SRCtoDST.TXT".

Port "SRC -> APP2 Port" transports the input document and drops it to the file "%HOMEDRIVE%\DL_SRCtoAPP2.TXT".

After configuring the BizTalk Messaging Management database, the sample submits a CommonPO to BizTalk Server and then checks that there are no entries in the Suspended queue and that the expected number of entries was tracked in the Tracking database during the last Submit call.

In the Visual Basic sample, the code shows how to set up the BizTalk Messaging Management database to submit a CommonPO document to a distribution list.

The distribution list consists of two ports:

Port "SRC -> DST Port" wraps the input document in a BTF 2.0 envelope and drops the output to the file "%HOMEDRIVE%\DL_SRCtoDST.TXT".

Port "SRC -> APP2 Port" transports the input document and drops it to the file "%HOMEDRIVE%\DL_SRCtoAPP2.TXT".


EDI and Receipts

This sample demonstrates how BizTalk Server can be used to support inbound X12 purchase order (850) messages from a trading partner and generate outbound X12 receipts (997) for those messages.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\EDI and Receipts

User's Guide

The sample scenario involves an external trading partner (Fabrikam, Inc.) submitting X12 purchase order (850) documents to the home organization (Microsoft). The inbound X12 electronic data interchange (EDI) documents are mapped to XML format and transported to the internal recipient application (MOLP). To signal that the X12 850 has been received, the home organization sends a functional acknowledgement (997) document to the external organization. The outbound X12 997 receipt is generated from a canonical receipt format that is shipped with BizTalk Server.

This sample uses only file transport to simulate the scenario, and does not use BizTalk Orchestration Services. X12 EDI documents from Fabrikam are dropped in one directory, and the transformed XML documents and receipt documents are generated as output in other directories on the local file system.

Note

  • If you have run setup.cmd on the EDI Introduction sample, you must run the setup on this sample for the scenario to work correctly.

To run the sample, follow these steps:

  1. Run setup.cmd in the sample folder to configure the scenario.

    Configuration involves the creation of the following BizTalk Server objects:

    • Organizations: Microsoft (default organization), Fabrikam

    • Document Definitions: Fabrikam850, Microsoft997, MicrosoftPO-MOLP, MyCanonicalReceipt

    • Envelope: EDItoFabrikam

    • Port: EDIPortToFabrikam, PortToMOLP

    • Channel: Channel997toFabrikam, Channel850toFabrikam

    • Receive Function: EDIFiles

    Files are copied onto the C drive. Make the necessary modifications in setup.cmd and ConfigureEDIReceipts.vbs if the C drive does not exist.

  2. With BizTalk Server running, navigate to c:\EDIReceipts\ and copy the file Fabrikam850.edi into c:\ EDIReceipts\Fabrikam.

    This file should be consumed by BizTalk Server, transformed, and submitted to C:\EDIIntroduction\Microsoft as the file xmlpotomolp_%tracking_id%.xml, where %tracking_id% is a unique ID value. A receipt file named EDItofabrikam_%tracking_id%.edi is then submitted to C:\EDIIntroduction\Fabrikam\Receipts.

To walk through how the sample is prepared, follow these steps:

  • Set Up Organizations and Associated Identifiers

  • Set Up and Verify Document Specifications

  • Set Up Map for Converting X12 to XML

  • Create Document Definitions

  • Create EDI Envelope

  • Create Ports

  • Create Channels

  • Create File Receive Function

  • Run the Sample Scenario

Programming Notes

The schemas and maps for this sample are completed and are available for review. It is also recommended that you complete the EDI Introduction sample for additional background.


Set Up Organizations and Associated Identifiers

This section creates the home organization (Microsoft), the application within the home organization (MOLP), and the destination organization (Fabrikam). It also sets up the organizational identifiers that uniquely determine how the EDI interchange is processed.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. If the BizTalk Messaging Manager dialog box appears, click Cancel.

  3. In the left frame, click Organizations, and then click Search Now.

  4. Ensure that Microsoft is the home organization.

    The home organization is indicated by (Default) next to the name. The dialog box that appears when you double-click the home organization should have three tabs.

  5. Click the Applications tab in the Organization Properties dialog box for Microsoft.

  6. Click Add, type MOLP, and then click OK.

  7. Click the Identifiers tab in the Organization Properties dialog box for Microsoft.

  8. Click Add, click Custom, and then type any name you like (for example, MyD&Bnumber) in the Custom text box.

  9. Enter 01 for Qualifier and 081466849 for Value. Click OK twice.

  10. To add the external trading partner organization Fabrikam, right-click the organization view window and click New Organization on the context menu.

  11. Click the Identifiers tab in the Organization Properties dialog box for Fabrikam.

  12. Click Add, click Custom, and then type any name you like in the Custom text box.

  13. Enter 01 for Qualifier and 0123456789 for Value. Click OK twice.


Set Up and Verify Document Specifications

In this section, you will set up, verify, and store to WebDAV the following document specifications:

  • schFabrikam850.xml - X12 850 purchase order sent from Fabrikam

  • schMicrosoftPO.xml - XML purchase order received by Microsoft

  • schMicrosoft997.xml - X12 997 receipt sent by Microsoft upon receiving 850

Note that the specification for a canonical receipt, CanonicalReceipt.xml, ships with BizTalk Server. It can be found in WebDAV in the Microsoft folder.

Set up EDI source specification

The file schFabrikam850.xml contains the document specification for the purchase order that is sent from Fabrikam. In this procedure you will examine an example X12 purchase order (850) that follows this specification (Fabrikam850.edi), validate the specification against a created test instance of the X12 850 (Fabrikam850NoEnvelope.edi), and store the specification to the WebDAV repository for future use.

  1. Using Notepad, open Fabrikam850.edi. (Right-click the file name, click Open With, and then select Notepad from the list of applications.) Leave Notepad active.

    You are looking at the EDI X12 purchase order (850). Note the delimiters needed to separate the records, fields, and subfields in the 850. They will be given in step 7 to validate the specification.

  2. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Editor.

  3. On the File menu, click Open, or use the toolbar icon to navigate to and select schFabrikam850.xml.

  4. Examine the specification. Select the nodes (for example, the root node X12_4010_850) and, on the View menu, click Expand Tree Items, or click the expand indicator (+).

  5. Using another instance of Notepad, open Fabrikam850NoEnvelope.edi. Compare this file with Fabrikam850.edi.

    As the file name indicates, Fabrikam850NoEnvelope.edi is the EDI X12 850 in step 1 with the header and trailer removed so that the BEG segment is at the top and the AMT segment followed by a carriage return/line feed is at the bottom. It will be used as a test validation instance of the EDI specification, because validation instances cannot contain envelope information.

  6. On the Tools menu, click Validate Instance and provide the file name Fabrikam850NoEnvelope.edi (in the same folder as other files used in this sample).

  7. In the Document Delimiters dialog box, specify ? (0x12), ~ (0x7e), and > (0x3e) for the Record, Field, and Subfield delimiters respectively. Click OK.

    If the instance test worked, the EDI will be transformed to XML and shown in the Output window at the bottom of BizTalk Editor, and the message "The document instance validation succeeded" will appear.

  8. On the File menu, click Store to WebDAV, and place the schema into the BizTalk Server WebDAV repository under the name schFabrikam850.xml.

Set up XML destination specification

The file schMicrosoftPO.xml contains the XML source specification for the purchase order that is received by Microsoft. Open this document, validate it, and store it to the WebDAV repository for future use.

  1. In BizTalk Editor, on the File menu, click Open, or use the toolbar icon to navigate to and select schMicrosoftPO.xml (in the same folder as other files used in this sample).

  2. On the Tools menu, click Validate Specification.

  3. On the File menu, click Store to WebDAV, and place the schema into the BizTalk Server WebDAV repository under the name schMicrosoftPO.xml.

Create receipt specification

An X12 functional acknowledgement (a 997) is sent from Microsoft to Fabrikam. The specification for this document, schMicrosoft977.xml, can be created from a template that is shipped with BizTalk Server.

  1. In BizTalk Editor, on the File menu, click New.

  2. In the New Document Specification dialog box, select X12, select 4010, and then select 997Schema.xml. Click OK.

  3. Select the document root node (X12_4010_997) and click the Reference tab in the right frame.

    The Receipt property on the Reference tab should be set to Yes to indicate that the specification is a receipt type.

  4. On the File menu, click Store to WebDAV, and then place the schema into the BizTalk Server WebDAV repository under the name schMicrosoft997.xml.


Set Up Map for Converting X12 to XML

The file mapFabrikam850toMicrosoftPO.xml specifies how the X12 source specification should be converted to the XML destination specification. Review and compile the map, and store it to WebDAV for future use. Note that no map needs to be constructed for the receipt response, because one is pre-built and included with BizTalk Server for this version of X12 (4010). A copy of this pre-built map (CanonicalReceiptTo4010-997.xml) is included in the same directory for reference.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Mapper.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select mapFabrikam850toMicrosoftPO.xml.

  3. On the Tools menu, click Compile Map, or press F5, or click the toolbar icon that is second from the right.

  4. Review the warnings that appear. Double-click a warning to see the problem that it refers to.

    The following types of warnings appear. Mapping will occur as expected even with these warnings, and they can be ignored.

    • "Warning: The required field 'X' has no incoming link or constant value"

      This type of warning can be ignored because the field's parent will not be created. Therefore the field itself cannot violate the validation criteria because it will not actually exist.

    • "Warning: The destination node 'X' has multiple source loop paths"

      This type of warning can be ignored in this case because the single occurrence of the input records in the instance will not cause a problem with the multiple loop paths. This map might not function as expected with document instances that differ greatly from the one in this sample.

    • "Warning: The destination node "X" has 3 input(s). The maximum number of possible inputs to this node is 1"

      This type of warning can be ignored because the mapper is not able to determine the presence of logical gating of the multiple inputs, which allows only one value to be selected from the multiple inputs.

  5. On the File menu, click Store to WebDAV, and then place the map into the BizTalk Server repository under the name mapFabrikam850toMicrosoftPO.xml.


Create Document Definitions

In this section, you will create the following document definitions:

  • Fabrikam850 - X12 850 purchase order sent from Fabrikam

  • MicrosoftPO-MOLP - XML purchase order received by Microsoft

  • MyCanonicalReceipt – Receipt document used to generate the outbound X12 997

  • Microsoft997 – Outbound X12 997 receipt sent by Microsoft upon receiving 850

Create EDI source document definition

In this procedure, you create the document definition Fabrikam850 for the Fabrikam X12 850 that is based on schFabrikam850.xml. Document tracking and selection criteria for the EDI document definition will be utilized.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. In the left frame, click Document Definitions, and then click Search Now.

  3. Right-click in the right frame and click New Document Definition on the context menu.

  4. For Document definition name type Fabrikam850.

  5. Select the Document specification check box.

  6. Click Browse and select schFabrikam850.xml from the repository list of schemas.

  7. Click the Global Tracking tab.

  8. Expand the BEG segment by clicking the expand indicator (+), select BEG03 (PO number), and then click Text to store this field for all instances processed through this document definition.

  9. Click the Selection Criteria tab.

  10. Click Add, type application_receiver_code for Name, type MAXCIM for Value, and then click OK.

  11. Repeat step 10 to create three more Selection Criteria name/value pairs:
    • application_sender_code / 0123456789

    • functional_identifier / PO

    • standards_version / 004010
  12. Click OK.

Create XML destination document definition

In this procedure, you create the document definition MicrosoftPO-MOLP for the XML purchase order that is received by Microsoft, based on schMicrosoftPO.xml. Document tracking will not be used in this case, and because this is not an EDI definition, defining the selection criteria is also not necessary.

  1. In BizTalk Messaging Manager, right-click in the Document Definitions right frame and click New Document Definition on the context menu.

  2. For Document definition name type MicrosoftPO-MOLP.

  3. Select the Document specification check box.

  4. Click Browse and select schMicrosoftPO.xml from the repository list of schemas.

  5. Click OK.

Create inbound (canonical) receipt document definition

When BizTalk Messaging Services on the home organization processes an inbound interchange from a trading partner, and receipts are required, the parser extracts header elements to generate a canonical receipt. In this procedure, you create the document definition MyCanonicalReceipt based on the canonical receipt specification CanonicalReceipt.xml that is shipped with BizTalk Server. This canonical receipt will then be used as the inbound document definition for the receipt channel (to be created) for delivery to Fabrikam. Neither document tracking nor selection criteria is necessary in defining MyCanonicalReceipt.

  1. In BizTalk Messaging Manager, right-click in the Document Definitions right frame and click New Document Definition on the context menu.

  2. For Document definition name type MyCanonicalReceipt.

  3. Select the Document specification check box.

  4. Click Browse and select CanonicalReceipt.xml from the Microsoft folder in the repository list of schemas.

  5. Click OK.

Create outbound receipt document definition

In this procedure, you create the document definition Microsoft997 based on schMicrosoft997.xml. This defines the outbound X12 997 receipt that Fabrikam expects from Microsoft. The receipt is generated by a mapping from MyCanonicalReceipt, with the map pre-built and included with BizTalk Server for this version of X12. Document tracking will not be utilized here, but defining the selection criteria is necessary.

  1. In BizTalk Messaging Manager, right-click in the Document Definitions right frame and click New Document Definition on the context menu.

  2. For Document definition name type Microsoft997.

  3. Select the Document specification check box.

  4. Click Browse and select schMicrosoft997.xml from the repository list of schemas.

  5. Click the Selection Criteria tab.

  6. Click Add, type application_receiver_code for Name and 0123456789 for Value, and then click OK.

  7. Repeat step 6 to create three more Selection Criteria name/value pairs:
    • application_sender_code / MAXCIM

    • functional_identifier / FA

    • standards_version / 004010
  8. Click OK.


Create EDI Envelope

This section will define the EDItoFabrikam envelope that will be used to wrap the X12 997 receipt from Microsoft to Fabrikam. Envelopes are needed whenever you are using non-XML documents.

  1. In BizTalk Messaging Manager, click Envelopes in the left frame and then click Search Now.

  2. Right-click in the right frame and click New Envelope on the context menu.

  3. Type EDItoFabrikam in the Name text box, click X12 on the Envelope Format drop-down menu, and then click OK.


Create Ports

This section will generate the two ports that are necessary for the inbound interchange and for the outbound receipt interchange.

Create port for internal application

This procedure will create the port PortToMOLP.

  1. In BizTalk Messaging Manager, click Messaging ports in the left frame and then click Search Now.

  2. Right-click in the right frame, click New Messaging Port on the context menu, and then click To Application.

  3. For Name enter PortToMOLP, leave Comments blank, and then click Next.

  4. The Applications option should be pre-selected. Click Name, select MOLP from the list, and then click OK.

  5. Create the directory c:\EDIReceipts\Microsoft\

    This is the location where Microsoft will receive the purchase order sent by Fabrikam and transformed to XML format.

  6. In the Primary Transport dialog box, click Browse, and then select File as the Transport Type.

  7. For the file name, type c:\EDIReceipts\Microsoft\xmlpotomolp_%tracking_id%.xml, click OK, and then click Next twice.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  8. Clear the Create a channel for this messaging port check box, and then click Finish.

Create port for external trading partner

This procedure will create the port EDIPortToFabrikam.

  1. In BizTalk Messaging Manager, right-click in the Messaging ports right frame, click New Messaging Port on the context menu, and then click To an Organization.

  2. For Name enter EDIPortToFabrikam, leave Comments blank, and then click Next.

  3. The Organization option should be pre-selected. Click Browse, select Fabrikam from the list, and then click OK.

  4. Create the directory c:\EDIReceipts\Fabrikam\Receipts.

    This is the location where Fabrikam receives the X12 997 documents.

  5. In the Primary Transport dialog box, click Browse, and then select File as the Transport Type.

  6. For the file name, type c:\EDIReceipts\Fabrikam\Receipts\EDItofabrikam_%tracking_id%.edi, click OK, and then click Next.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  7. Click EDItoFabrikam on the Envelope Information drop-down menu.

    Note that you can also create an envelope here if you forgot to do it earlier in Create EDI Envelope.

  8. Click Delimiters, enter the delimiters ~, *, and >, and then click OK.

    In this case, it does not matter what your delimiters are because there is no real business partner on the other end. In real scenarios, the delimiters are agreed upon between you and your business partners.

  9. In the Interchange Control Number dialog box, type a non-zero number.

  10. On the Organization Identifier drop-down menu, click 0123456789, and then click Next.

  11. Clear the Create a channel for this messaging port check box, and then click Finish.


Create Channels

This section will create the two channels for the inbound purchase order and outbound receipt interchanges. Note that the outbound receipt channel must be created first.

Create channel for outbound receipt

This procedure will create the receipt channel Channel997toFabrikam, with MyCanonicalReceipt as the inbound document definition and Microsoft997 as the outbound document definition. A pre-built map that is shipped with BizTalk Server (CanonicalReceiptTo4010-997.xml) will be used to transform the two definitions.

  1. Right-click EDIPortToFabrikam, click New Channel, and then click From an Application.

  2. For Name type Channel997toFabrikam.

  3. Select the This is a receipt channel check box, and click Next.

  4. The Application option should be pre-selected. Select MOLP from the drop-down list of application names.

  5. Select the 081466849 qualifier from the drop-down list, and then click Next.

  6. Under Inbound Document Definition Name click Browse, select the document definition called MyCanonicalReceipt, click OK, and then click Next.

  7. Under Outbound Document Definition Name click Browse, select the document definition called Microsoft997, and then click OK.

  8. The Map Inbound Document check box should be pre-selected. Click Browse to choose the map CanonicalReceiptTo4010-997.xml in the Microsoft folder of the WebDAV repository, click OK, and then click Next.

  9. Select any document storage options that interest you for the purpose of viewing in the BizTalk Document Tracking (see Start menu), and then click Next.

  10. Type an integer value in the Group Control Number text box.

    The value is not important, but you will note that repeated document flows through this channel will result in serially incremented values for this number.

  11. Click Finish.

Create channel for inbound purchase order

This procedure will create the channel Channel850toMOLP that will use Channel997toFabrikam as its associated receipt channel.

  1. In the left frame of BizTalk Messaging Manager, click Messaging ports, and then click Search Now.

  2. Right-click PortToMOLP, click New Channel, and then click From an Organization.

  3. For Name type Channel850toMOLP, and then click Next.

  4. The Organization option should be pre-selected. Click Browse, choose Fabrikam from the drop-down list, and then click OK.

  5. Select the Generate Receipt check box at the bottom of the dialog box.

  6. Click Browse, select Channel997toFabrikam, click OK, and then click Next.

  7. Under Inbound Document Definition Name, click Browse, select Fabrikam850, click OK, and then click Next.

  8. Under Outbound Document Definition Name, click Browse, select MicrosoftPO-MOLP, and then click OK.

  9. The Map Inbound Document check box should be pre-selected. Click Browse, select mapFabrikam850toMicrosoftPO.xml from the maps repository, click OK, and then click Next.

  10. Select any document storage options that interest you for the purpose of viewing in the BizTalk Document Tracking (see Start menu), click Next, and then click Finish.


Create File Receive Function

This section will create the File receive function EDIFiles for picking up Fabrikam purchase orders to send to Microsoft.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Server Administration.

  2. Expand the Microsoft BizTalk Server 2002 node in the left frame tree until the Queues and Receive Functions nodes are fully expanded.

  3. Add a new File receive function either by clicking the Receive Functions node and choosing Action | New | File Receive Function from the menu bar or by right-clicking the Receive Functions node and clicking New | File Receive Function on the context menu.

  4. Type EDIFiles for Name. Comments can be left blank.

    The machine you are working on should be pre-selected in the drop-down list titled Server on which.

  5. Type *.EDI in the File type to poll for text box.

  6. Verify the existence of the directory c:\EDIReceipts\Fabrikam.

    This is the location where Fabrikam will drop the X12 850 documents to be sent to Microsoft.

  7. Type c:\EDIReceipts\Fabrikam in the Polling Location text box.

  8. Click Advanced. In the Channel Name drop-down list, select Channel850toMOLP, and leave the defaults in the other data items.

  9. Click OK to close the Advanced dialog box, and then click OK to close the Add a File Receive Function dialog box.


Run the Sample Scenario

  1. The sample is run by placing the X12 instance Fabrikam850.edi into the Fabrikam folder and observing XML output to the Microsoft folder and the EDI receipt output to the Fabrikam/Receipts folder.

  2. Verify that the BizTalk service is running by making sure that a green arrow appears on your server icon in the BizTalk Server Administration MMC (server is immediately below Receive Functions in the tree); right-click the icon and click Start on the context menu if no green arrow is displayed.

  3. Copy Fabrikam850.edi to c:\EDIReceipts\Fabrikam and wait.

  4. Open the c:\EDIReceipts\Microsoft folder and look for a file called xmlpotomolp_%tracking_id%.xml, where the %tracking_id% symbol will be replaced with a GUID value.

  5. Open the c:\EDIReceipts\Fabrikam\Receipts folder and look for a file called EDItofabrikam_%tracking_id%.edi, where the %tracking_id% symbol will be replaced with a GUID value.


EDI Introduction

This sample demonstrates how to configure BizTalk Server to support XML documents flowing outbound from the home organization to an external trading partner using the EDI X12 855 document format.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\EDI Introduction

User's Guide

An internal application (MOLP) of the home organization (Microsoft) submits XML documents to BizTalk Server. These files are then mapped to an X12 EDI format and transported to the recipient trading partner (Fabrikam).

This sample uses only file transport to simulate the scenario, and does not use BizTalk Orchestration Services. XML documents from Microsoft are dropped in one directory, and the transformed X12 EDI documents are generated as output in another directory on the local file system.

Note

  • If you have run setup.cmd on the EDI and Receipts sample, you must run setup.cmd again on this sample for the scenario to work correctly.

To run the sample, follow these steps:

  1. Run setup.cmd in the sample directory to configure the scenario.

    Configuration involves the creation of the following BizTalk Server objects:

    • Organizations: Microsoft (default organization), Fabrikam

    • Document Definitions: Fabrikam855, MicrosoftPOAck

    • Envelope: EDItoFabrikam

    • Port: EDIPortToFabrikam

    • Channel: Channel855toFabrikam

    • Receive Function: XMLAcks

    Files are copied onto the C drive. Make the necessary modifications in setup.cmd and ConfigureEDI.vbs if the C drive does not exist.

  2. With BizTalk Server running, navigate to c:\EDIIntroduction\ and copy the file MOLPpoAck.xml into c:\EDIIntroduction\Microsoft.

    This file should be consumed by BizTalk Server, transformed, and submitted to C:\EDIIntroduction\Fabrikam as the file EDItoFabrikam_%tracking_id%.edi, where %tracking_id% is a unique ID value.

To walk through how the sample is prepared, follow these steps:

  • Set Up Organizations and Associated Identifiers

  • Set Up Source Specification

  • Set Up Destination Specification

  • Set Up Map for Converting XML to X12

  • Create Document Definition for Microsoft

  • Create Document Definition for Fabrikam

  • Define EDI Selection Criteria for Fabrikam

  • Create EDI Envelope

  • Create Port for Delivering EDI to Fabrikam

  • Create Channel from Microsoft to Fabrikam

  • Create File Receive Function

  • Run the Sample Scenario

  • Troubleshooting

Programming Notes

Electronic data interchange (EDI) is a set of standards for controlling the exchange of business documents (such as purchase orders and invoices) between computers. Although standardization efforts for EDI formats began in the 1960s, the expensive setup and operational costs of EDI server systems and the somewhat cryptic EDI document formats limited its use.

BizTalk Server supports the EDIFACT standard adopted in 1987 by the International Organization for Standardization (ISO) as well as the older X12 standard used primarily for American domestic trade. This sample goes through the transmission of a purchase order acknowledgement from Microsoft to Fabrikam using the X12 standard.

The schemas and maps for this sample are completed and are available for review to get a better understanding.


Set Up Organizations and Associated Identifiers

This section creates the home organization (Microsoft), the application within the home organization (MOLP), and the destination organization (Fabrikam). It also sets up the organizational identifiers that uniquely determine how the EDI interchange is processed.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and click BizTalk Messaging Manager.

  2. If the BizTalk Messaging Manager dialog box appears, click Cancel.

  3. In the left frame, click Organizations, and then click Search Now.

  4. Verify that Microsoft is the home organization.

    The home organization is indicated by (Default) next to the name. The dialog box that appears when you double-click the home organization should have three tabs.

  5. Click the Applications tab in the Organization Properties dialog box for Microsoft.

  6. Click Add, type MOLP, and then click OK.

  7. Click the Identifiers tab in the Organization Properties dialog box for Microsoft.

  8. Click Add, click Custom, and type any name you like (for example, MyD&Bnumber) in the Custom box.

  9. Enter 01 for Qualifier and 081466849 for Value. Click OK twice.

  10. Add the external trading partner organization Fabrikam by right-clicking the organization view window and clicking New Organization on the context menu.

  11. Click the Identifiers tab in the Organization Properties dialog box for Fabrikam.

  12. Click Add, click Custom, and type any name you like in the Custom box

  13. Enter 01 for Qualifier and 0123456789 for Value. Click OK twice.


Set Up Source Specification

The file schMicrosoftPOAck.xml contains the XML source specification for the purchase order acknowledgement that is sent from Microsoft. Look at this document, validate it against an instance (MOLPpoAck.xml), and store it to the WebDAV repository for future use.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Editor.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select schMicrosoftPOAck.xml.

  3. Examine the specification by clicking the nodes (for example, the root node MicrosoftPOAck) and clicking Expand Tree Items on the View menu or clicking the expand indicator (+).

  4. On the Tools menu, click Validate Instance and provide the file name MOLPpoAck.xml (in the same folder as other files used in this sample).

    The message "The document instance validation succeeded" is shown if the instance test worked.

  5. On the File menu, click Store to WebDAV and place the schema into the BizTalk Server repository under the name schMicrosoftPOAck.xml.


Set Up Destination Specification

The file schFabrikam855.xml contains the specification for the X12 version release 4010 purchase order acknowledgement (855) that Fabrikam expects to receive. Review this document, validate the specification, and store it to the WebDAV repository for future use.

  1. In BizTalk Editor, open schFabrikam855.xml and expand the specification tree as before.

  2. On the Tools menu, click Validate Specification.

  3. On the File menu, click Store to WebDAV and place the specification into the BizTalk Server WebDAV repository under the name schMicrosoftPOAck.xml.


Set Up Map for Converting XML to X12

The file mapMicrosoftPOAcktoFabrikam855.xml specifies how the XML source specification should be converted to the X12 destination specification. Review and compile the map, and store it to WebDAV for future use.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Mapper.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select mapMicrosoftPOAcktoFabrikam855.xml.

  3. On the Tools menu, click Compile Map, or press F5, or click the toolbar icon that is second from the right.

  4. Review warnings.

    One type of warning appears: "Warning: The required field 'X' has no incoming link or constant value." Mapping will occur as expected even with this warning. It can be ignored because the field's parent will not be created, and therefore the field itself cannot violate the validation criteria because it will not actually exist.

  5. On the File menu, click Store to WebDAV, and place the map into the BizTalk Server repository under the name mapMicrosoftPOAcktoFabrikam855.xml.


Create Document Definition for Microsoft

In this procedure, you create a document definition MicrosoftPOAck for the Microsoft purchase order acknowledgement that is based on schMicrosoftPOAck.xml.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. In the left frame, click Document Definitions, and then click Search Now.

  3. Right-click in the right frame and click New Document Definition on the context menu.

  4. Type MicrosoftPOAck in the Document definition name box.

  5. Select the Document specification check box.

  6. Click Browse and select schMicrosoftPOAck.xml from the repository list of schemas.

  7. Click OK.


Create Document Definition for Fabrikam

In this procedure, you create a document definition Fabrikam855 for the Fabrikam X12 855 based on schFabrikam855.xml. A document definition for EDI also involves specifying the selection criteria, which is the subject of the next section.

  1. Right-click in the right frame of BizTalk Messaging Manager and click New Document Definition on the context menu.

  2. Type Fabrikam855 in the Document definition name box.

  3. Select the Document specification box.

  4. Click Browse and select schFabrikam855.xml from the repository list of schemas.

  5. Click OK.


Define EDI Selection Criteria for Fabrikam

The selection criteria is a list of name/value pairs that will allow the BizTalk messaging engine to uniquely identify the appropriate document definition for an EDI document. This is necessary because multiple EDI documents can be contained in a single interchange and multiple document types can be mixed within an interchange.

  1. Click the Selection Criteria tab for the Fabrikam855 document definition.

  2. Click Add. For Name, type application_receiver_code, for Value, type 0123456789, and then click OK.

  3. Repeat step 2 to create three more Selection Criteria name/value pairs:
    • application_sender_code / MAXCIM

    • functional_identifier / PR

    • standards_version / 004010
  4. Click OK to complete the document definition.


Create EDI Envelope

This section will define the EDItoFabrikam envelope. Envelopes are needed whenever you are using non-XML documents. A particular envelope is associated with a particular type of document (for example, X12), and contains information that the BizTalk messaging engine needs to route the document.

  1. In BizTalk Messaging Manager, click Envelopes in the left frame, and then click Search Now.

  2. Right-click in the right frame and click New Envelope on the context menu.

  3. Type EDItoFabrikam in the Name box, choose X12 from the Envelope Format drop-down list, and then click OK.


Create Port for Delivering EDI to Fabrikam

This procedure will create the port EDIPortToFabrikam.

  1. In BizTalk Messaging Manager, click Messaging ports in the left frame and then click Search Now.

  2. Right-click in the right frame, point to New Messaging Port, and click To an Organization.

  3. Type EDIPortToFabrikam in the Name box, leave Comments blank, and then click Next.

  4. The Organization option button should be pre-selected. Click Browse to select the organization name Fabrikam from the list, and then click OK.

  5. Create the directory c:\EDIIntroduction\Fabrikam\. This will be the location where Fabrikam receives the X12 855 documents.

  6. In the Primary Transport dialog box, click Browse, and choose File as the Transport Type.

  7. Type (after file://) c:\EDIIntroduction\Fabrikam\EDItofabrikam_%tracking_id%.edi as the file name, click OK, and then click Next.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  8. Under Envelope Information, select EDItoFabrikam in the drop-down list.

    Note

    • You can also create an envelope at this point, if you did not do it previously in Create EDI Envelope.
  9. Click Delimiters and type the delimiters ~, *, and >. Click OK.

    In this case, it does not matter what your delimiters are because there is no real business partner on the other end. In real scenarios, the delimiters are agreed upon between you and your business partners.

  10. In the Interchange Control Number dialog box, type a non-zero number.

  11. Under Organization Identifier select the 0123456789 ID from the drop-down list, and then click Next.

  12. Clear the Create a channel for this messaging port check box, and click Finish.


Create Channel from Microsoft to Fabrikam

This procedure will create the channel Channel855toFabrikam.

  1. Right-click the EDIPortToFabrikam created previously, and click New Channel | From an Application.

    Alternatively, you could leave the Create a channel for this messaging port check box selected at the end of the New Messaging Port dialog

  2. For Name type Channel855toFabrikam, and then click Next.

  3. The Application option button should be pre-selected. Choose MOLP from the drop-down list of application names.

  4. Select the 081466849 qualifier from the drop-down list, and then click Next.

  5. Under Inbound Document Definition Name click Browse and select the document definition MicrosoftPOAck, click OK, and then click Next.

  6. Under Outbound Document Definition Name click Browse and select the document definition Fabrikam855, and then click OK.

  7. The Map Inbound Document check box should be pre-selected. Click Browse and choose MicrosoftPOAcktoFabrikam855.xml from the maps repository, click OK, and then click Next.

  8. Select any document storage options that interest you for the purpose of viewing in BizTalk Document Tracking (see Start menu), and then click Next.

  9. Type an integer value in the Group Control Number box.

    The value is not especially important. You will see that repeated document flows through this channel will result in serially incremented values for this number.

  10. Click Advanced, click the Envelope tab, and then click Properties. Review the dialog box where you will access the values to be used when creating the interchange envelope (no changes to these values are necessary for the sample).

  11. Click Finish.


Create File Receive Function

This section will create the File receive function XMLAcks for Microsoft documents.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Server Administration.

  2. Expand the Microsoft BizTalk Server 2002 node in the left frame tree until the Queues and Receive Functions nodes are fully expanded.

  3. To add a new File receive function, click the Receive Functions node.

  4. On the Action menu, point to New and click File Receive Function.

  5. Type XMLAcks in the Name box. Comments can be left blank.

    The machine you are working on should be pre-selected in the drop-down list titled Server on which.

  6. Type *.XML in the File type to poll for box.

  7. Create the directory c:\EDIIntroduction\Microsoft

    This is the location where Microsoft will drop the XML documents to be sent to Fabrikam.

  8. Type c:\EDIIntroduction\Microsoft in the Polling Location box.

  9. Click Advanced. In the Channel Name drop-down list, select Channel855toFabrikam, and leave the defaults in the other data items.

  10. Click OK to close the Advanced dialog box, and then click OK to close the Add a File Receive Function dialog box.


Run the Sample Scenario

The sample is run by placing the XML instance MOLPpoAck.xml into the Microsoft folder and observing the EDI output to the Fabrikam folder.

  1. Verify that the BizTalk service is running by making sure that a green arrow appears on your server icon in the BizTalk Server Administration MMC (the server is immediately below Receive Functions in the tree); right-click the icon and click Start on the context menu if no green arrow is displayed.

  2. Copy MOLPpoAck.xml to c:\EDIIntroduction\Microsoft.

  3. Open the c:\EDIIntroduction\Fabrikam folder and look for a file called EDItofabrikam_%tracking_id%.edi (from step 7 of "Create Port for Delivering EDI to Fabrikam"), where the %tracking_id% symbol is replaced with a GUID value.


Troubleshooting

If the MOLPpoAck.xml file is not picked up and deleted from c:\EDIIntroduction\Microsoft after a reasonable time period, check that the receive function XMLAcks in BizTalk Server Administration is correctly configured by right-clicking on the receive function and clicking Properties. Also make sure that the Disable receive function check box is cleared.

If MOLPpoAck.xml is picked up but there is no output in the c:\EDIIntroduction\Fabrikam directory, check the Suspended queue in BizTalk Server Administration for the error description.


Encryption and Decryption

This sample walks through the process of setting up a secure document exchange between two trading partners. This sample demonstrates the use of digital certificates to:

  • Encrypt an outgoing document

  • Sign an outgoing document

  • Decrypt an incoming document

  • Verify the signature on an incoming document

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Encryption

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup (setup.cmd)

  • Obtain and Install Digital Certificates

  • Create Secure Ports and Channels

  • Create File Receive Functions

  • Run the Sample Scenario

Programming Notes

The sample scenario simulates establishing secure communications between two organizations: Buyer and Home. These organizations can be considered as separate Web sites.

A flat-file purchase order, myPO.csv, is sent from Buyer to Home. Because the purchase order is considered sensitive, the information needs to be encrypted and signed by Buyer before it is transported. Encryption prevents documents from being viewed by unauthorized individuals. Signing ensures that a document is authentic and unaltered. Home decrypts, verifies, and transforms the purchase order as an XML document of decision factors.

This sample requires obtaining certificates for each organization to perform the encryption, decryption, and digital signature. It is recommended that you familiarize yourself with certificates before using this sample.


Preliminary Setup (setup.cmd)

Running setup.cmd in the sample directory performs the following tasks, which are described in detail in the following topics:

  • Create Folders

  • Create Organizations

  • Create Document Definitions

  • Set Up Map

  • Create Envelope

If you encounter errors, be sure to clear out all conflicting organizations, document definitions, and so on that are used in this scenario before running setup.cmd.


Create Folders

In this procedure, you create one folder that contains three subfolders. Each subfolder simulates an organization in the scenario.

To create the folders:

  1. In Windows Explorer, browse to the root directory of your C drive.

  2. Create a new folder on the root of the C drive; name the folder Encryption.

  3. Click the new Encryption folder and create three subfolders with the following names:
    • Buyer

    • Home

    • Approver


Create Organizations

In this procedure, you will create the three organizations in the scenario.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. If the BizTalk Messaging Manager dialog box appears, click Cancel.

  3. In the left frame, click Organizations, and then click Search Now.

  4. Right-click the organization view window and click New Organization on the context menu.

  5. Type Buyer in the Organization name box and click OK.

  6. Repeat steps 4 and 5 for the Home and Approver organizations.


Create Document Definitions

In this procedure, you will examine and store three document specifications to WebDAV and create three document definitions that are based on the following specifications:

  • BasicPO. The purchase order sent by Buyer for approval.

  • DecisionFactors. The decision factors extracted from the basic purchase order that are relevant for approval.

  • Response. The final approval response: yes or no.

  • To create the document definitions:
  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Editor.

  2. For each of the following document specifications, on the File menu, click Store to WebDAV, and store these document specifications in the same folder:

    defBasicPO.xml

    defDecisionFactors.xml

  3. In the left frame of BizTalk Messaging Manager, click Document definitions, and then click Search Now.

  4. Right-click in the right frame and click New Document Definition on the context menu.

  5. Type BasicPO in the Document definition name box.

  6. Select the Document specification check box and click Browse.

  7. Select defBasicPO.xml in the WebDAV repository and click Open.

  8. Click OK to close the New Document Definition dialog box.

  9. Repeat steps 4-8 for the document specification defDecisionFactors.xml, naming it DecisionFactors.


Set Up Map

The file mapBasicPO_DecisionFactors.xml specifies how the BasicPO source specification should be converted to the DecisionFactors destination specification. Review and compile the map, and store it to WebDAV for future use.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Mapper.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select mapBasicPO_DecisionFactors.xml.

  3. On the Tools menu, click Compile Map, or press F5, or click the toolbar icon that is second from the right.

  4. On the File menu, click Store to WebDAV, and place the map into the BizTalk Server repository under the name mapBasicPO_DecisionFactors.xml.


Create Envelope

In this procedure you will create the BasicPOEnv envelope that is used to wrap the flat-file purchase order that is sent from Buyer. Envelopes are needed whenever you are using non-XML documents.

  1. In the left frame of BizTalk Messaging Manager, click Envelopes and then click Search Now.

  2. Right-click in the right frame and click New Envelope on the context menu.

  3. Type BasicPOEnv in the Name text box.

  4. Select FLATFILE from the Envelope Format drop-down list.

  5. Select the Envelope specification check box and click Browse.

  6. Click defBasicPO.xml in the WebDAV repository and click Open.

  7. Click OK to close the New Envelope dialog box.


Obtain and Install Digital Certificates

This sample requires the use of two certificates. These certificates must either be obtained from a trusted certification authority (CA), or be created by using Microsoft Certificate Services. One certificate will be denoted as the Buyer certificate, and the other as the Home certificate. A purchase order will be encrypted and signed, and then decrypted and verified with these two certificates.

To create the certificates by using Microsoft Certificate Services, follow these guidelines. Note that these guidelines are subject to change. For more information about creating certificates, see the Certificate Services Help file that is available in the Certification Authority MMC snap-in.

  • Install Certificate Services

  • Request Certificates

  • Issue Certificates

  • Install MMC Certificates Snap-in

  • Install Certificates to Personal Store

  • Install Certificates to BizTalk Store


Install Certificate Services

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Add/Remove Programs.

  3. Click Add/Remove Windows Components, click Certificate Services, and then click Next.

  4. Complete the steps in the Certificate Services installation wizard.

    For this sample, it is sufficient to use the wizard's default selected options.


Request Certificates

  1. Use your browser to navigate to http://localhost/certsrv/default.asp.

  2. Click Request a certificate and then click Next.

  3. Select Advanced request and then click Next.

  4. Select Submit a certificate request to this CA using a form and then click Next.

  5. Under Identifying Information, enter Buyer as the Name.

    Enter other identifying information as desired.

  6. Under Key Options, select Mark keys as exportable and Use local machine store.

    Keeping these options selected ensures that the certificate gets installed on the local computer and can be exported to a file.

  7. Click Submit.

  8. Repeat steps 2 through 7, changing the certificate name to Home.


Issue Certificates

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Certification Authority.

  4. Fully expand the Certificate Authority tree and click the Pending Requests folder.

    Two new requests for certificates should appear.

  5. Select both new pending requests and right-click.

  6. Click All Tasks, and then click Issue.

    The requests should now disappear from the Pending Requests folder.

  7. Verify that the certificates now appear in the Issued Certificates folder.


Install MMC Certificates Snap-in

BizTalk Server uses the Local Computer certificate store to locate digital certificates. Install the MMC Certificates snap-in to be able to manage the certificates.

  1. On the Start menu, click Run, and then type mmc to start Microsoft Management Console.

  2. On the Console menu, click Add/Remove Snap-in.

    The Add/Remove Snap-in dialog box is displayed.

  3. Click Add and select Certificates.

  4. Select Computer account as the account for which the snap-in will manage certificates.

  5. Click Next to go to the Select Computer dialog box.

  6. The default Local computer should be selected. Click Finish.

  7. Click Close to close the Add Standalone Snap-in dialog box.

  8. Click OK to close the Add/Remove Snap-in dialog box.

  9. Keep the Console window open to verify installation in future steps.


Install Certificates to Personal Store

  1. Use your browser to navigate to http://localhost/certsrv/default.asp.

  2. Click Check on a pending certificate and then click Next.

  3. Click the first certificate request and then click Next.

  4. Click Install this certificate.

  5. Open the Microsoft Management Console window with the Certificates snap-in installed.

  6. Navigate to Certificates (Local Computer) | Personal | Certificates in the left frame.

  7. Verify that a new certificate with the name specified (for example, Buyer) has been installed.

  8. Repeat steps 2 through 7 to install the remaining certificate request.


Install Certificates to BizTalk Store

  1. In the Console window, right-click the Buyer certificate, and select All Tasks | Export.

    The Certificate Export Wizard appears.

  2. Click Next.

  3. In the Export Private Key dialog box, select No, do not export the private key, and then click Next.

    The BizTalk Server store does not require certificates with private keys.

  4. Click Next to get to the File to Export dialog box.

  5. Click Browse and enter a file name for the exported certificate (for example. c:\Encryption\buyer.cer).

    Remember the certificate location and file name for future steps.

  6. Click Next and then click Finish.

    A dialog should appear indicating that the export was successful.

  7. Repeat the preceding steps to export the Home certificate.

  8. In the left frame of the Console, right-click the BizTalk folder under Certificates (Local Computer).

  9. Click All Tasks, and then click Import.

    The Certificate Import Wizard appears.

  10. Click Next.

  11. Click Browse to navigate to and select the Buyer certificate.

  12. Click Next, click Next again, and then click Finish.

    A dialog should appear indicating that the import was successful.

  13. Repeat the preceding steps to import the Home certificate.

  14. Navigate to Certificates (Local Computer) | BizTalk | Certificates to verify that the two certificates have been imported.


Create Secure Ports and Channels

This section shows how to create ports and channels that carry out encryption, decryption, signing, and verification. Two ports and two channels will be created.

This section contains the following topics:

  • Create Port and Channel to Encrypt and Sign Outbound Files

  • Create Port and Channel to Receive Encrypted and Signed Files


Create Port and Channel to Encrypt and Sign Outbound Files

In this section, you will create the port BuyerEncryptPort and the associated channel BuyerEncryptChannel to encrypt and sign documents. Because the documents are sent from Buyer to Home, they need to be encrypted with Home's public key and signed with Buyer's private key. The certificates used for signing and encryption will be specified in the properties of both the port and the channel.

  1. In Biztalk Messaging Manager, on the File menu, click New, click Messaging Port, and then click To an Organization.

    The New Messaging Port Wizard opens.

  2. In the Name box, type BuyerEncryptPort and then click Next.

  3. On the Destination Organization page, in the Organization area, click Browse.

  4. Select Buyer from the list of available organizations, and then click Next.

  5. In the Primary Transport box, click Browse, and choose File as the Transport Type.

  6. Type (after file://) c:\Encryption\Buyer\Encrypted\myPO_%tracking_id%.txt as the file name.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  7. Click OK to close the Primary Transport dialog box.

  8. Click Next twice to get to the Security Information page.

  9. In the Encryption group box, select S/MIME from the Type drop-down list and click Browse.

    A list appears, showing certificates that are stored on the computer with public keys.

  10. Select the Home digital certificate and click OK.

  11. In the Signature group box, select S/MIME from the Type drop-down list.

    The digital certificate used to sign the document will be specified in the channel.

  12. Verify that the Create a channel for the messaging port check box is selected.

  13. Select "From an organization" as the Channel Type and click Finish.

    The New Channel Wizard opens.

  14. On the General Information page, in the Name box, type BuyerEncryptChannel and click Next.

  15. On the Source Organization page, in the Organization area, click Browse.

  16. Select Buyer from the list of available organizations, and then click Next.

  17. On the Inbound Document page, click Browse and select BasicPO as the document definition.

  18. Click Next.

  19. On the Outbound Document page, click Browse and again select BasicPO as the document definition.

  20. Select "Sign outbound document" and click Browse.

    A list appears, showing certificates that are stored on the computer with private keys.

  21. Select the Buyer digital certificate and click OK.

  22. Click Next twice, and then click Finish.


Create Port and Channel to Receive Encrypted and Signed Files

In this section, you will create the port SubmitPort and the associated channel BuyerHomeChannel for transporting an encrypted and signed purchase order from the Buyer to the Home organization. The flat-file purchase order has been signed with Buyer's private key and encrypted with Home's public key. Therefore, it needs to be verified with Buyer's public key and decrypted with Home's private key. The certificates that are used for verification and decryption will be specified in the properties of BuyerHomeChannel.

  1. In BizTalk Messaging Manager, on the File menu, click New, click Messaging Port, and then click To an Organization.

    The New Messaging Port Wizard opens.

  2. In the Name box, type SubmitPort and click Next.

  3. On the Destination Organization page, in the Organization area, click Browse.

  4. Select Home from the list of available organizations, and then click Next.

  5. In the Primary Transport box, click Browse, and choose File as the Transport Type.

  6. Type (after file://) c:\Encryption\Home\DecisionFactor_%tracking_id%.xml as the file name.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  7. Click OK to close the Primary Transport dialog box.

  8. Click Next twice.

  9. On the Security Information page, verify that the Create a channel for the messaging port check box is selected.

  10. Select "From an organization" as the Channel Type, and click Finish.

    The New Channel Wizard opens.

  11. On the General Information page, in the Name box, type BuyerHomeChannel and click Next.

  12. On the Source Organization page, in the Organization area, click Browse.

  13. Select Buyer from the list of available organizations, and then click Next.

  14. On the Inbound Document page, click Browse and select BasicPO as the document definition.

  15. Select Verify decryption on inbound document, and click Browse.

    A list appears, showing certificates that are stored on the computer with private keys.

  16. Select the Home digital certificate and click OK.

    Because Home's public key was used to encrypt the purchase order, Home's private key must be used to decrypt it.

  17. Select Verify signature on inbound document, and click Browse.

    A list appears, showing certificates that are stored on the computer with public keys.

  18. Select the Buyer digital certificate and click OK.

    Because Buyer's private key was used to sign the purchase order, Buyer's public key must be used to verify the signature.

  19. Click Next.

  20. On the Outbound Document page, click Browse and select DecisionFactors as the document definition.

  21. Make sure that "Map inbound document to outbound document" is selected.

  22. Click Browse in the Map reference area and select mapBasicPO_decisionfactors.xml.

  23. Click Next twice, and then click Finish.


Create File Receive Functions

This section will create two File receive functions, BuyerReceiveFunction and BuyerEncryptedReceiveFunction, for picking up documents in c:\Buyer and c:\Buyer\Encrypted, respectively.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Server Administration.

  2. Expand the Microsoft BizTalk Server 2002 item in the left frame tree until the Queues and Receive Functions nodes are fully expanded.

  3. Add a new File receive function either by clicking the Receive Functions node and choosing Action | New | File Receive Function from the menu bar or by right-clicking the Receive Functions node and choosing New | File Receive Function from the context menu.

  4. Type BuyerReceiveFunction in the Name box. Comments can be left blank. The computer you are working on should be pre-selected in the drop-down list titled Server on which.

  5. Type myPO.csv in the text box labeled File type to poll for.

  6. Type c:\Encryption\Buyer in the text box labeled Polling Location.

  7. Click Advanced.

  8. In the Envelope Name drop-down list, select BasicPOEnv.

  9. In the Channel Name drop-down list, select BuyerEncryptChannel.

  10. Click OK to close the Advanced dialog box, and OK to close the Add a File Receive Function dialog box.

  11. Add the second File receive function with the name BuyerEncryptReceiveFunction.

  12. Type myPO*.txt in the text box labeled File type to poll for.

  13. Type c:\Encryption\Buyer\Encrypted in the text box labeled Polling Location.

  14. Click Advanced.

  15. In the Envelope Name drop-down list, select BasicPOEnv.

  16. In the Channel Name drop-down list, select BuyerHomeChannel.

  17. Click OK to close the Advanced dialog box, and OK to close the Add a File Receive Function dialog box.


Run the Sample Scenario

To run the sample, put the comma-delimited purchase order myPO.csv into the c:\Encryption\Buyer folder. This file gets signed and encrypted, and finally is transformed as a decision factor output to the c:\Encryption\Home folder.

This section contains the following topics:

  • Disable Intermediate Receive Function

  • Encrypt and Sign an Outbound Document

  • Receive an Encrypted and Signed Purchase Order


Disable Intermediate Receive Function

Temporarily disabling the receive function BuyerEncryptReceiveFunction will allow the intermediate signed and encrypted purchase order to be viewed.

  1. In the left frame of BizTalk Server Administrator, expand the tree down to the level of the Receive Function nodes.

  2. Right-click the receive function BuyerEncryptReceiveFunction and click Properties.

  3. Select the Disable receive function check box on the General tab.

  4. Click Yes to confirm.

  5. Click OK to close the receive function properties.


Encrypt and Sign an Outbound Document

  1. With BizTalk Server running, navigate to c:\Encryption\ and copy the file myPO.csv into c:\Encryption\Buyer.

    This file should be consumed by BizTalk Server, transformed, and submitted to c:\Encryption\Buyer\Encrypted as the file myPO_%tracking_id%.txt, where %tracking_id% is a unique ID value.

  2. Open c:\Encryption\Buyer\Encrypted\myPO_%tracking_id%.txt in Notepad to see that the content has been encrypted and signed.

  3. Close c:\Encryption\Buyer\Encrypted\myPO_%tracking_id%.txt.


Receive an Encrypted and Signed Purchase Order

  1. Enable the BuyerEncryptReceiveFunction by clearing the Disable receive function check box under the Properties of the receive function.

    The file myPO_%tracking_id%.txt in the c:\Encryption\Buyer\Encrypted folder should be consumed.

  2. Open the c:\Encryption\Home folder and look for a file called decisionfactor_%tracking_id%.xml, where the %tracking_id% symbol will be replaced with a GUID value.

  3. Open decisionfactor_%tracking_id%.xml in Notepad or Internet Explorer to verify that the content is valid XML.


Flat-File Delimited

This sample translates an inbound delimited flat-file source document into an XML destination document.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Flat-File Delimited

User's Guide

Before running the sample, complete the following steps:

  1. On the C drive, create a folder called FlatFileDelimited.

  2. On the C drive, create a folder called XMLDest.

  3. Copy FlatFileDelimited.xml to the folder \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft on the installation drive.

  4. Run FlatFileDelimitedSetup.vbs to configure BizTalk Messaging Services.

Note

  • The BizTalk Messaging Services configuration script, FlatFileDelimitedSetup.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Channel: Flat File Delimited To XML Channel

    2. Port: Flat File Delimited to XML Port

    3. Organization: Flat File Delimited Sample Org

    4. Document definition: Flat File Delimited to XML

    5. Envelope: Flat File Delimited Envelope

    6. File receive function: FlatFileDelimited

To run the sample, follow these steps:

  1. Ensure that the FlatFileDelimitedSampleData.txt file is not read-only. To modify this property, right-click the file, click Properties, clear the Read-only attribute, and then click OK.

  2. Copy and paste the flat file, FlatFileDelimitedSampleData.txt, to the C:\FlatFileDelimited folder. You should see an output XML file in the C:\XMLDest folder.

Programming Notes

The same document specification, FlatFileDelimited.xml, is used for both the inbound and outbound documents, so a map is not required.

Related Topic

Working with Positional and Delimited Flat Files


Flat-File Positional

This sample translates an inbound positional flat-file source document into an XML destination document.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Flat-FilePositional

User's Guide

Before running the sample, complete the following steps:

  1. On the C drive, create a folder called FlatFilePosSample with two subfolders called SourceOrg and DestOrg.

  2. On the BizTalk Server installation drive, copy FlatFilePosSpec.xml to \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

  3. Run FlatFilePosConfig.vbs to configure BizTalk Messaging Services.

To run the sample, follow these steps:

  1. Ensure that the FlatFilePosSampleData.txt file is not read-only. To modify this property, right-click the file, click Properties, clear the Read-only attribute, and then click OK.

  2. Copy and paste the flat file, FlatFilePosSampleData.txt, to the C:\FlatFilePosSample\SourceOrg folder. You should see an output XML file in the C:\CustomCounterSample\DestOrg folder.

Note

  • The BizTalk Messaging Services configuration script, FlatFilePosConfig.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Channel: FlatFile Positional Channel

    2. Messaging Port: FlatFile Positional Port

    3. Organizations: FlatFilePos Source Organization, FlatFilePos Destination Organization

    4. Document Definition: FlatFilePosDef

    5. Envelope: FlatFilePosEnv

    6. File Receive Function: FlatFilePos

Programming Notes

The same document specification, FlatFilePosSpec.xml, is used for both the inbound and outbound documents, so a map is not required.

Related Topic

Working with Positional and Delimited Flat Files


HTTP Receive Function

This sample illustrates how an online buyer organization delivers a purchase order (PO) to a supplier organization through a Web-based front end. The information is converted to an XML document and is sent to BizTalk Server by using an HTTP receive function.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function

User's Guide

To prepare and run the sample, follow these steps:

  • Set Up the Web Site Environment

  • Run the HTTP Receive Function Sample

Note

  • This sample assumes that BizTalk Server is installed on your C drive. If this is not the case, you should make the appropriate path modifications.


Set Up the Web Site Environment

This section shows you how to set up the Web-based order entry screen, the IIS virtual directory, and the objects that are needed to create and deliver an XML document by using an HTTP receive function.

This section contains the following topics:

  • Create a Web Application

  • Configure the IIS COM+ Package

  • Examine Default.htm

  • Examine ProcessPO.asp

  • Create an HTTP Receive Function


Create a Web Application

In this procedure, you create a Web application to host the order entry form and send the contents to the HTTP receive function.

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Internet Services Manager.

    The Internet Services Manager console appears.

  4. In the Internet Services Manager console tree, expand the <your computer> node.

  5. Right-click Default Web Site.

  6. On the Action menu, click New, and then click Virtual Directory.

    The Virtual Directory Creation Wizard appears.

  7. On the Welcome to the Virtual Directory Creation Wizard page, click Next.

  8. On the Virtual Directory Alias page, in the Alias box, type PurchaseSite and then click Next.

  9. On the Web Site Content Directory page, click Browse.

  10. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function, click OK, and then click Next.

  11. On the Access Permissions page, make sure that the Execute (such as ISAPI applications or CGI) option is selected and then click Next.

  12. Click Finish to close the Virtual Directory Creation Wizard.

  13. Right-click PurchaseSite.

  14. On the menu that appears, click Properties.

  15. In the Virtual Directory section, make sure that Execute Permissions is set to Scripts and Executables.

  16. In the same section, change the Application Protection option to High (Isolated).

  17. Click OK.

  18. Copy the BizTalkHTTPReceive.dll file to the location that was specified on the Web Site Content Directory page during the creation of the virtual directory.


Configure the IIS COM+ Package

In this procedure, you modify the account under which the Internet Information Services component runs for PurchaseSite.

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Component Services.

  4. In the Component Services Manager console tree, expand the Component Services node.

  5. Expand Computers, and then expand COM+ Applications.

  6. Right-click IIS-{Default Web Site//Root/PurchaseSite}.

  7. Click Properties.

  8. The IIS-{Default Web Site//Root/PurchaseSite} Properties manager appears.

  9. Click the Identity tab.

  10. Change the account under which the application will run to Interactive user – the current logged on user, or to a user with the appropriate authority.


Examine Default.htm

Look at Default.htm. This HTML file is located in the HTTP Receive Function sample folder, and is a Web-based entry form that will post the information entered to the ProcessPO.asp file.


Examine ProcessPO.asp

Look at ProcessPO.asp. This .asp file is located in the HTTP Receive Function sample folder, and accepts the information that Default.htm sends to it. This .asp file takes the information that is entered in the HTTP form, converts the information into well-formed XML, and posts the XML to the PurchaseSiteFunc HTTP receive function.


Create an HTTP Receive Function

In this procedure, you create an HTTP receive function to process the purchase order.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  2. Expand Microsoft BizTalk Server, expand BizTalk Server Group, and then click Receive Functions.

  3. On the Action menu, point to New, and then click HTTP Receive Function.

    The Add an HTTP Receive Function dialog box appears.

  4. In the Name box, type PurchaseSiteFunc.

  5. In the Server on which the receive function will run box, click the name of a server in the BizTalk Server group.

  6. In the Virtual directory box, type PurchaseSite/biztalkhttpreceive.dll?PO.

  7. In the Submit to drop-down list box, select the File option.

    You can also configure the HTTP receive function to send the data received to BizTalk Server synchronously or asynchronously.

  8. In the File Path and Name box, type \Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function\PurchaseOrder_%guid%.xml.

    This is the path of the file that the HTTP receive function will create. Notice that the GUID is used as a unique identifier.

  9. Click OK to close the Add a File Receive Function dialog box.

  10. Close BizTalk Server Administration.


Run the HTTP Receive Function Sample

This section shows you how to run the HTTP receive function sample.

  1. Open your Web browser.

  2. Point your browser to the virtual directory that you created earlier (for example, http://localhost/PurchaseSite).

    This will bring up the HTTP Receive Function Sample Purchase Order Form.

  3. Enter information in the various fields and then click Submit.

    This will send the information that you just entered to the ProcessPO.asp file. This .asp file will convert the information into well-formed XML and then post the information to the PurchaseSiteFunc HTTP receive function that you created earlier.

  4. A reply message will be displayed stating that the BizTalk Server system has processed your order.

    You can verify this by looking in the \Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function directory for an XML file.


Mapping Twice

This sample demonstrates mapping a document from its source to its destination by using two iterations.

Biztalk Server allows you to map a document synchronously through two iterations by using SubmitSync and the Loopback transport service. You can break your mapping into various stages by reusing and combining different channels.

In this scenario, we will first map Input.xml (which is hard-coded in the Microsoft Visual Basic source) to an intermediate XML file by using 1stMap.xml. A message box will report the resulting IntermediateOutput.xml file. Then we will map IntermediateOutput.xml to the final destination, producing FinalOutput.xml.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Mapping Twice

User's Guide

Before running the sample, complete the following steps:

  1. In the Mapping Twice sample directory, double-click the DocSpecs folder.

  2. Copy the Microsoft folder and paste it into the DocSpecs repository at:

    \Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs

  3. In the Mapping Twice sample directory, double-click the Maps folder.

  4. Copy the Microsoft folder and paste it into the Maps Repository at:

    \Microsoft BizTalk Server\BizTalkServerRepository\Maps

  5. Double-click SetUp.vbs to run Setup.

To run the sample:

  • Run Mapping_Twice.exe.

Programming Notes

In the first mapping, the following files are used:

File name | Purpose
Input.xml | Source instance file
SourceDocSpec.xml | Source specification file
IntermediateDocSpec.xml | Intermediate specification file
1stMap.xml | Map source file
IntermediateOutput.xml | Intermediate instance after first mapping

In the second mapping, the following files are used:

File name | Purpose
IntermediateOutput.xml | Intermediate instance file
IntermediateDocSpec.xml | Intermediate specification file
DestinationDocSpec.xml | Destination specification file
2ndMap.xml | Map source file
FinalOutput.xml | Final instance after first mapping

When running the sample, the first Msgbox should correspond to /Data/IntermediateOutput.xml, and the second Msgbox should correspond to /Data/FinalOutput.xml.

The application will create two files in the Mapping Twice sample folder: SampleIntermediateOutput.xml and SampleFinalOutput.xml. These files hold the values in the two messages that are displayed when you run the Mapping_Twice.exe file.

The BizTalk Messaging Services configuration script, SetUp.vbs, should be run only once. If you want to run the script again, you must first delete the configuration objects, such as organizations, ports, channels, and so on, that were previously created by the script.


Message Queuing 4 MB Limit

This sample shows one way to process documents that exceed the Message Queuing maximum size limit. Depending on your requirements, this method might not be suitable.

Message Queuing is limited in the size of documents that can be processed. The maximum size document that Message Queuing supports is 4 MB if the document is in ASCII. The message queue can handle a maximum of 2 MB if the document is in Unicode.

In the Message Queuing 4 MB sample, a buyer organization delivers a large purchase order (PO) file, in excess of 4 MB, to a supplier organization by using the BizTalk Framework 2.0 reliable messaging protocol.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\MSMQ 4MB Limit

User's Guide

Before running the sample, complete the following steps:

  1. In the MSMQ 4MB Limit directory remove the read-only property on the following files:

    BigCustomerPO.xml

    CustomerPO.xml

    MSMQ 4MB Limit.skv

    MSMQ 4MB Limit.skx

  2. Copy the following files to the Biztalk Repository at \Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft:

    \Setup\Docs\customerid.xml

    \Setup\Docs\largeFileReceive.xml

  3. Create a private transactional queue named customeridq in the Computer Management tool. Be sure to modify the security settings for this queue to allow everyone full control.

  4. In the SetUp folder, run SetUp.cmd and follow the prompts.

  5. Close the Command window if it is still open.

  6. Install XML for SQL Server Web Release 1 (WR1) by finding the downloadable release at: www.microsoft.com/sql/downloads.

  7. Modify the CustomerPO.xml and BigCustomerPO.xml files so that they are editable. By default, the files are read-only. If the file attributes are not changed, the sample will not work correctly.

    XML for SQL Server is required for this sample.

Verify that the settings are correct:

  1. Open Biztalk Server Administration. Expand the Console Root until you see Receive Functions.

  2. Click filercv_CustomerPO. In the right pane, edit this File receive function by double-clicking filercv_CustomerPO.

  3. On the General tab, be sure that the Disable Receive Function check box is cleared.

  4. On the Services tab, be sure that the Polling Location is polling in the \POdrop folder in your Samples directory.

  5. Click OK.

  6. Click msmqrcv_CustomerID. In the right pane, edit this File receive function by double-clicking msmqrcv_CustomerID.

  7. On the General tab, be sure that the Disable Receive Function check box is cleared.

Modify the Orchestration schedule:

  1. Edit the Orchestration schedule by right-clicking MSMQ 4MB Limit.skv and selecting Edit With Orchestration Designer.

  2. Double-click the blue line connecting the port to the action "Receive CustomerID from Queue."

  3. Click Next four times until you see Message Specification Information.

  4. Click Browse and select the location of \Schemas\CustomerID.xml in the MSMQ 4MB Limit sample folder.

  5. Double-click the GetSQLData COM shape; this should open the COM Component Binding Wizard.

  6. Click Next twice.

  7. Under Class Information, double-click the GetSqlData folder to expand the component.

  8. Double-click the getData class.

  9. Click Finish.

    If a message box appears, click OK and perform the following steps:

    1. Double-click the red and blue lines connecting the port to the action "Call COM Object."

    2. Click Next.

    3. Click Finish.

    4. Click Yes in the dialog box.

    5. Open the Data Flow page by clicking the Data tab.

    6. Under the msg_CustomerID table, connect CustomerID to the strCust_ID in the getData_in table.

    7. Make the XLANG schedule by clicking Make XLANG MSMQ 4MB Limit.skx on the File menu.

    8. Be sure that XLANG MSMQ 4MB Limit.skx is being created in the MSMQ 4MB Limit samples directory.

    9. Click OK to replace the file.

Update the messaging port

  1. Open Biztalk Messaging Manager and search for all ports.

  2. Double-click the port_CustomerID port.

  3. Click Next.

  4. In the first input box under "New XLANG schedule" click Browse.

  5. Select MSMQ 4MB Limit.skx in your Samples directory.

  6. Click Finish.

To run the sample:

  • Copy CustomerPO.xml and paste it into \PODrop to run this sample. You should see a message box pop up momentarily. Check the Event Logs for errors. The CustomerPO.xml file is a small test file that will be processed in the same manner as a large file. To test a large file, copy the BigCustomerPO.xml file to the \PODrop directory. Processing a large file will take longer.

Programming Notes

The BizTalk Messaging Services configuration script, SetUp.cmd, should be run only once. If you want to run the script again, you must first delete the configuration objects, such as organizations, ports, channels, and so on, that were previously created by the script.

The following objects are created by the setup file:

Organizations

org_CustomerID

org_CustomerPO

Channels

channel_CustomerID

channel_CustomerPO

Document Definitions

docdef_CustomerID

docdef_CustomerPO

Messaging Ports

port_CustomerID

port_CustomerPO

Receive Functions (in BizTalk Server Administration):

filercv_CustomerPO

msmqrcv_CustomerID

Messaging Queues (in Computer Management)

customeridq

BizTalk Server Repository

largeFileReceive.xml

customerid.xml


Multi-Part MIME Attachment

This sample shows how BizTalk Server handles an inbound document that contains multiple MIME attachments.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Multi-Part MIME Attachment

User's Guide

Before running the sample, complete the following steps:

  1. On the Start menu, click Run.

  2. On the command line type CMD.

    This will bring up a Command Line window.

  3. Change the directory to the Multi-Part MIME Attachment sample directory.

  4. Type Config.wsf.

    This will create the MimeSampleSource->MimeSampleDest port, MimeSampleSource->MimeSampleDest channel, CommonPO document definition, BTFEnvelope envelope, and the MimeSample_DestinationOrg and MimeSample_SourceOrg organizations.

  5. Type Exit in the Command Line window to close it.

  6. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  7. Double-click Microsoft BizTalk Server 2002.

  8. Right-click BizTalk Server Group, click Properties, and then click the Tracking tab.

  9. Ensure that the Enable Document Tracking and Log the original MIME-encoded message check boxes are selected.

    These options instruct BizTalk Server to store in a table all incoming documents as well as the original MIME documents.

  10. Click OK.

  11. Close BizTalk Server Administration.

To run the sample, follow these steps:

  1. On the Start menu, click Run.

  2. On the command line type CMD.

    This will bring up a Command Line window.

  3. Change the directory to the Multi-Part MIME Attachment sample directory.

  4. Type Submit.vbs.

    This script file will use the Submit method to submit the CommonPOAttached.txt file to BizTalk Server. When the submission process is complete, a message box will appear stating that the submission was successful.

  5. Verify that a new file has been created in the Multi-Part MIME Attachment sample directory. This file will be named with a unique GUID and have a .txt extension (for example, {4DE29CC8-7631-46A7-BCA7-F92B910A2AD1}.txt).

  6. Type Exit in the Command Line window to close it.

    You can verify that the MIME attachments have been included by opening the .txt file. Note that the XML data within the multi-part MIME file is encapsulated by a SOAP envelope.

Programming Notes

This sample assumes that BizTalk Server is installed on your C drive. If this is not the case, you should make the appropriate path modifications.


Pipeline Component in Visual Basic

This sample demonstrates an application integration component (AIC) that implements the IPipelineComponent and IPipelineComponentAdmin interfaces in Microsoft Visual Basic. The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the Microsoft BizTalk Server repository), logs some of the properties passed to it in the dictionary, and copies the incoming message to a file.

For a related sample, see Pipeline Component in Visual C++.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\PipelineComponent\VB

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual Basic component (this is optional because the DLL is provided).

  2. Register the component, its category IDs, and its setup configuration by running:

    cscript scenario.wsf //job:setup

    When asked whether to register information from Affinity.reg, click "Yes." The component ProgID is "BTSSamples_VBPipeComp.PipelineComp".

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_VBPipeComp" by using the command:

    cscript scenario.wsf //job:submit

    If the submission succeeds, a log file, BTSSamples.log, and an output file, BTSSamples_pipe.out, will be created in the temporary system directory (C:\WINNT\temp).

Programming Notes

If you want to configure the component, you must' copy the ASP pages to the directory designated for property pages (for example, C:\Program Files\Microsoft BizTalk Server\MessagingManager\pipeline). You can then open the BizTalk Messaging Manager and edit the channel. The Advanced button in the last dialog box allows you to set the properties for the primary transport.


Pipeline Component in Visual C++

This sample demonstrates an application integration component (AIC) that implements the IPipelineComponent and IPipelineComponentAdmin interfaces by using the Active Template Library (ATL). The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the Microsoft BizTalk Server repository), logs some of the default dictionary properties to a file, C:\temp\BTSSamples_ATLPipeComp.log, and writes the incoming data to another file, C:\BTSSamples_ATLPipeComp.out.

For a related sample, see Pipeline Component in Visual Basic.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\PipelineComponent\VC\ATL

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual C++ component.

  2. Set up the configuration by running:

    cscript scenario.wsf //job:setup

    The component ProgID is "BTSSamples_AtlPipelineComp BTSPipelineComp".

  3. Copy ASP files to the configuration files for BizTalk Messaging Manager:

    C:\Program Files\Microsoft BizTalk Server\MessagingManager\pipeline

    You can now change the default settings for output and log files.

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_ATLPipelineComp" by using the command:

    cscript scenario.wsf //job:Submit

    If the submit succeeds, you will get two files:

    C:\temp\BTSSamples_ATLPipeComp.log

    C:\temp\BTSSamples_ATLPipeComp.out


Queue Sniffer

This sample enables you to view, forward, and remove messages in Message Queuing queues. This application supports the following features:

  • Displays the entire content of a message

  • Displays XML and flat text file formats

  • Accesses message queues on remote servers

  • Performs criteria-based searches for specific messages

  • Forwards messages to other message queues

  • Removes messages from a queue

  • Retrieves detailed message information

  • Displays journal messages

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Queue Sniffer

User's Guide

To use this application, perform the following steps:

  1. Run the executable file QueueSniffer.exe, located on the BizTalk Server installation drive at \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Queue Sniffer\QueueSniffer.exe.

  2. Type the name or TCP/IP address of a Message Queuing server in the Message Queuing Server text box that is located at the top of the window.

  3. Type a message queue name in the Message Queue text box.

  4. If the queue you are accessing is transactional, select the Use Transactional Queue check box.

  5. If you wish to view journal messages for the queue, select the Use Journal check box.

After you have entered the required information, you can perform one of the following actions:

  • View the next message in the queue. Click View Next Message to display the next message in the queue.

  • Search for a specific message in the queue. Enter search criteria in the Message Search Criteria section and click Search to display a message that matches your criteria. Click Search again to see the next message that matches your search criteria.

After a message is displayed in the Message Information area, you can remove the message from the queue by clicking Remove from Queue, or you can forward a copy of the message to another queue by clicking Forward Message.

Note

  • The information in the message label cannot be passed to a remote queue.


Receive Scripts

This sample demonstrates an HTTP receive function.

ReceiveResponse.asp is used as a page where the BizTalk Messaging Service receives documents to be sent to an existing Orchestration schedule. If you copy that page into your localhost location, you can use http://localhost/ReceiveResponse.asp as the HTTP URL address on the Channel Information page of the BizTalk Messaging Binding Wizard.

ReceiveStandard.asp is an example of an HTTP receive function. The document data posted to that page will be submitted as a self–routing document for a NOT OPEN configuration.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts

Programming Notes

The Exchange Server 5.5 folder contains an example SMTP receive function. The document data sent as an e-mail message will be deposited into C:\temp\RS_data.txt and then submitted as a self-routing document for a NOT OPEN configuration.

The Exchange Server 2000 folder contains an example of an event sink that intercepts e-mail messages and submits them to BizTalk Server. See the readme.doc file in that folder for more details.


Refresh Messaging Manager

This sample allows you to refresh objects in BizTalk Messaging Manager. You must refresh the objects in the Messaging Manager when a document definition, envelope, or channel is modified. This sample lets you choose whether to refresh all objects or individual objects.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Refresh Messaging Manager

User's Guide

To prepare and run the sample, follow these steps:

  1. Copy the BTM_RefreshV2.exe file to the BizTalk Server on which you are working.

    The BTM_RefreshV2.exe file can be copied to any BizTalk Server. The Refresh Messaging Manager application will only affect the BizTalk Server that it is currently running on.

  2. Open Windows Explorer and browse to the BTM_RefreshV2.exe file.

  3. Double-click the BTM_RefreshV2.exe file to start the application.

    Within the application are three windows that display the document definitions, envelopes, and channels that are available on the BizTalk Server.

  4. To refresh individual objects, highlight the objects and then click the corresponding button to refresh only the highlighted objects. To refresh all the listed objects (whether highlighted or not), click Update All.

  5. To exit, click Exit.

Note

  • This sample assumes that BizTalk Server is installed on your C drive. If this is not the case, you should make the appropriate path modifications.


Reliable Messaging

This sample illustrates how a buyer organization delivers a purchase order (PO) to a supplier organization by using the BizTalk Framework 2.0 reliable messaging protocol.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMessaging

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Enable Reliable Messaging

  • Run the Reliable Messaging Sample

Note

  • The BizTalk Messaging Services configuration script, ReliableMsgConfig.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Applications: PurchaserOrgApp, SupplierOrgApp

    2. Channels: PurchaserOrgOutgoingMsgChannel, SupplierOrgIncomingMsgChannel

    3. Messaging Ports: PurchaserOrgOutgoingPort, SupplierOrgIncomingPort

    4. Organization: Supplier Organization

    5. Document Definition: PurchaserOrgPO

    6. Envelope: PurchaserReliableEnvelope

    7. File Receive Functions: PurchaserOrgOutgoingFunc, SupplierOrgIncomingFunc

Programming Notes

BizTalk Framework 2.0 (BTF) guarantees only a single delivery of a message to the destination organization. After the supplier organization receives the message, the BizTalk Server in the supplier organization responds with a receipt to the purchaser organization. When the purchaser organization receives the receipt, the transmission is complete.

As a brief example, consider an application (PurchaserOrgApp) in the buyer organization, which sends a PO to BizTalk Server (PurchaserOrg), which, in turn, delivers the PO to the supplier organization application (SupplierOrgApp), as explained below:

BizTalk Server in the buyer organization

  1. BizTalk Server wraps the PO with a BTF reliable message envelope and sends the message to the supplier organization.

  2. BizTalk Server places a copy of the PO into the BizTalk Server Retry queue.

  3. BizTalk Server tries to send the PO to a supplier organization until a BTF receipt is received. The number of retries is based on the configuration and the interval between retries.

  4. When the number of retries is exhausted and the receipt has not been received, the PO is placed into the Suspended queue.

  5. If the receipt arrives before the number of retries is exhausted, BTF removes the PO from the Retry queue.

BizTalk Server in the supplier organization

  1. BizTalk Server removes the PO from the BTF envelope and sends an acknowledgement receipt to the source organization.

  2. The PO, without an envelope, is delivered to the supplier organization's internal application.

  3. BizTalk Server logs the PO in the document-tracking database. However, no log is created for the receipt.

When BizTalk Messaging Services on the supplier organization receives an interchange with a reliable messaging format, it uses a special document definition, channel, and messaging port to process and transport a receipt to the buyer organization. These special system objects are not viewable in BizTalk Messaging Manager, and you cannot create similar objects by using the reserved system names.

BizTalk Server uses the reply-to address that is included in the header of the inbound interchange as the destination address for the receipt. You do not need to further configure BizTalk Messaging Services for the supplier system to return a receipt for an interchange sent with the reliable messaging envelope.


Preliminary Setup

Before you begin the sample, you must complete the following tasks:

  • Create Folders

  • Copy Files

  • Run Setup Script


Create Folders

In this procedure, you create one folder that contains six subfolders. You use four of the subfolders as locations for messages as they move into and out of the buyer and seller systems, one as a repository for the reliable receipt and one as a document data folder.

To create the folders:

  1. In Windows Explorer, browse to the root directory of your C drive.

  2. Create a new folder on the root of the C drive; name the folder ReliableMessaging.

  3. Click the new ReliableMessaging folder and create two subfolders with the following names:
    • PurchaserOrg

    • SupplierOrg
  4. Click the new PurchaserOrg folder and create two subfolders with the following names:
    • InPurchaserOrg

    • ReliableReceipts
  5. Click the new SupplierOrg folder and create two subfolders with the following names:
    • InSupplierOrg

    • OutSupplierOrg


Copy Files

In this procedure, you copy the files that are needed to complete the sample.

  1. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMesssaging and copy POSpec.xml.

  2. Paste the file to \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

  3. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMesssaging and copy ReliableMsgReceipt.asp.

  4. Paste the file to C:\ReliableMesssaging\PurchaserOrg.


Run Setup Script

In this procedure, you run the script that sets up all the messaging configuration objects that are necessary for this sample.

  • Run ReliableMsgConfig.vbs to configure BizTalk Messaging Services.


Enable Reliable Messaging

This section shows you how to enable reliable messaging for the sample. It contains the following topics:

  • Create a Web Application

  • Examine ReliableMsgReceipt.asp

  • Define a Reliable Messaging Reply-to URL


Create a Web Application

In this procedure, you create a Web application to receive the reliable messaging receipt.

  1. On the Start menu, point to Settings and click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Internet Services Manager.

    The Internet Services Manager console appears.

  4. In the Internet Services Manager console tree, expand <your computer>.

  5. Right-click Default Web Site.

  6. On the Action menu, select New and click Virtual Directory.

    The Virtual Directory Creation Wizard appears.

  7. On the Welcome to the Virtual Directory Creation Wizard page, click Next.

  8. On the Virtual Directory Alias page, in the Alias box, type PurchaserOrg and click Next.

  9. On the Web Site Content Directory page, click Browse.

  10. Browse to C:\ReliableMessaging\PurchaserOrg, click OK, and then click Next.

  11. On the Access Permissions page, click Next.

  12. Click Finish to close the Virtual Directory Creation Wizard.


Examine ReliableMsgReceipt.asp

Look at ReliableMsgReceipt.asp. This ASP file is located in the PurchaserOrg directory, and is a standard receive page that delivers the receipt to the buyer organization, using BizTalk Framework 2.0.

For the call to Submit, the only parameters specified are the openness type and the document string, as shown in the following code:

SubmissionHandle = interchange.submit( 1, PostedDocument )

BizTalk Server understands the schema of the reliable message receipt, so you do not need to define a port or a channel to process the receipt.


Define a Reliable Messaging Reply-to URL

In this procedure, you define a reliable messaging reply-to URL.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

    The BizTalk Server Administration console appears.

  2. In the BizTalk Server Administration console tree, expand BizTalk Server.

  3. Right-click BizTalk Server Group.

  4. On the Action menu, right-click Properties.

    The BizTalk Server Group Properties dialog box appears.

  5. On the General tab, in the Reliable messaging repy-to URL box, type http://localhost/PurchaserOrg/ReliableMsgReceipt.asp, click Apply, and click OK.

    ReliableMsgReceipt.asp is an ASP file that uses the Submit method to deliver the receipt to the PurchaserOrg BizTalk Server.

    The URL that is specified is used by the supplier system BizTalk Server to deliver the receipt to the buyer system BizTalk Server.


Run the Reliable Messaging Sample

This section shows you how to run the reliable messaging sample. It contains the following topics:

  • Run the Sample with a Disabled Receive Function

  • Run the Sample with an Enabled Receive Function

To run the sample, you need to remove the read-only property from the sample data file, SamplePO.xml.


Run the Sample with a Disabled Receive Function

Run the sample with a disabled receive function to allow you to analyze the content of the inbound purchase order (PO) from the buyer system. You will be able to look at the purchase order wrapped with a BizTalk Framework 2.0 reliable envelope.

Before running the sample, disable the receive function in the seller system, so that you can view the content of the arriving purchase order (PO) from the buyer system. You will be able to analyze the PO wrapped with the BizTalk Framework 2.0 reliable envelope.

To disable the receive function:

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  2. Expand Microsoft BizTalk Server, expand BizTalk Server Group, and then click Receive Functions.

  3. Click the receive function named SupplierOrgIncomingFunc.

  4. On the Action menu, click Properties.

    The Properties dialog box appears.

  5. Select the Disable receive function check box, and then click Yes to confirm your choice.

  6. Click OK.

To submit the PO:

  1. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMesssaging and copy SamplePO.xml.

  2. Paste the file to C:\ReliableMesssaging\PurchaserOrg\InPurchaserOrg.

    In this step you place the sample purchase order (PO) to the directory that is being monitored by the buyer system receive function. The receive function will pick up the sample PO.

    At this point, you can view the sample PO in the Retry queue. Note the number of retries and the time interval between each retry.

  3. Browse to C:\ReliableMessaging\SupplierOrg\InSupplierOrg.

    In this directory, you can view the sample PO arriving from the buyer system. The message contains two parts, the SOAP envelope and the body. The body of the message contains the sample PO.


Run the Sample with an Enabled Receive Function

By enabling the receive function on the supplier system, you allow the inbound sample purchase order (PO) to be picked up. Then BizTalk Server removes the envelope, sends a receipt to the buyer system, and submits the PO to the supplier system application through the configured port and channel.

To enable the receive function:

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  2. Expand Microsoft BizTalk Server, expand BizTalk Server Group, and then click Receive Functions.

  3. Click the receive function named SupplierOrgIncomingFunc.

  4. On the Action menu, click Properties.

    The Properties dialog box appears.

  5. Clear the Disable receive function check box, and then click OK.

    After enabling the receive function, BizTalk Server delivers the reliable message receipt to the reply-to URL, http://localhost/PurchaserOrg/ReliableMsgReceipt.asp.

To complete the sample:

  1. Browse to C:\ReliableMessaging\SupplierOrg\OutSupplierOrg.

    In this directory, you can view the PO. Note that there is no envelope information, and that it is the same PO that was originally sent by the buyer system.

  2. Browse to C:\ReliableMessaging\PurchaserOrg\ReliableReceipts.

    In this directory, you can view the receipt file. The receipt file contains the reply-to URL and the from and to tags. Note that the receipt file contains no information on the PO.


Self-Routing

This sample demonstrates the BizTalk Server 2002 capability to route documents through BizTalk Server channels and ports based on the contents of the document being routed.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Self-Routing

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Run the Self-Routing Sample

Programming Notes

This sample walks through the process of setting up a self-routing document scheme that utilizes the routing capabilities of BizTalk Server 2002 and, in the process, demonstrates the following:

  • The use of dictionary properties that are added to document specifications by BizTalk Editor and are used by the BizTalk Server runtime to determine routing

  • The use of envelopes to parse and route differently formatted inbound flat files

  • The use of document selection criteria to determine routing

  • The use of receive functions in determining routing

In this sample, we will modify the business scenario and show how a single receive function can be used, with three different inbound file formats, channels, and maps, to send the same DecisionFactors document to the approver through the existing ApprovalMessagingPort port.

We modify the POApproval scenario by introducing the following business requirements:

  • Rather than one buyer organization, as in the original POApproval scenario, we now have two separate buyer departments, each of which has its own flat-file format for a purchase order. The buyer departments are divided by region: Northwest buyers (NWB) and Central buyers (CB).

  • Each buyer department has agreed to add a common header record, known as an inbound envelope, to each of their purchase orders before submitting them for approval. They have also agreed to a data content convention for the common header to properly route their documents.

  • We want to reuse our existing business logic, approver addresses, and wire protocols to route documents from both buyer departments with a minimum of additional effort.

  • We want to use a single share drop location on the network for both departments and a single receive function no matter how many buyer departments we add in the future. Note that we are assuming that all departments added in the future will send flat files with the common header.

Inbound Envelope

Each buyer department uses the inbound envelope to tell BizTalk Server the source of the document and which file format to expect. The envelope has the following format:

POHeader,999,XXX

The first field in the envelope is a constant string literal (that is, identical and unchanging in all documents) that is used to identify the record type when the inbound file is parsed. This is the primary mechanism that BizTalk Server uses at run time to separate individual purchase orders that are submitted in the same flat file.

The second and third fields correspond to the document Source Qualifier and Source Name respectively. In addition, the third field doubles as the Document Type property for the associated purchase order. Because each buyer department sends only one document format, the third field can be "overloaded" in this way.

The Northwest and Central buyer departments provide the Source Qualifier/Source Name pairs 10/NWB and 12/CB, respectively.

A document specification file is provided by the sample and contains the XML-Data Reduced (XDR) information for the envelope. The file name for this specification is defPOEnv.xml. If you look at this file in BizTalk Editor you will see that the string "POHeader" has been entered as the Source Tag Identifier for the record.

Buyer Department Document Specifications and Input Files

The sample provides the document specifications and sample input files for the buyer departments. The specifications are named defNWBPO.xml and defCBPO.xml for the Northwest and Central departments respectively. The sample input files are named NWBPOx.csv and CBPOx.csv, where x is the number of purchase orders in the file (that is, the number of common header records that you should expect to see).


Preliminary Setup

Before you begin the sample, you must complete the following tasks to set up the basic POApproval scenario:

  • Copy Self-Routing Document Specifications and Maps to the Repository

  • Create Two Private Transactional Message Queuing Queues

  • Create Folders

  • Copy Files

  • Remove Read-Only Property from .csv File

  • Run Setup Script

  • Check Receive Function


Copy Self-Routing Document Specifications and Maps to the Repository

  1. In the Self-Routing sample directory, double-click the DocSpecs folder.

  2. Copy the POApproval folder and paste it into the DocSpecs repository at:
    \Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs

  3. In the Self-Routing sample directory, double-click the Maps folder.

  4. Copy the POApproval folder and paste it into the Maps repository at:
    \Microsoft BizTalk Server\BizTalkServerRepository\Maps


Create Two Private Transactional Message Queuing Queues

  1. On the Start menu, point to Settings, click Control Panel, double-click Administrative Tools, and then double-click Computer Management.

  2. Expand the Services and Application node.

  3. Expand the Message Queuing node.

  4. Right-click the Private Queues folder, point to New, and then click Private Queue.

  5. In the Name text box, type approvalmsmq and select the Transactional check box.

  6. Click OK.

  7. Repeat steps 4 through 6 to create another new private queue named responsemsmq.


Create Folders

In this procedure, you create the folder that is necessary to run the sample.

  1. In Windows Explorer, browse to the root directory of your C drive.

  2. Create a new folder on the root of the C drive; name the folder Data.


Copy Files

In this procedure, you copy files that are needed to complete the sample.

  1. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Self-Routing and copy the following two folders: POApproval, SetUp.vbs.

  2. Paste the folders to C:\Data\.


Remove Read-Only Property from .csv File

  1. In the C:\Data\POApproval folder there are three files: NWBPO2.csv, NWBPO1.csv,and CBPO1.csv.

  2. While holding CTRL, select the three files.

  3. Right-click the selection and click Properties.

  4. On the General tab, in the Attributes area, clear the Read-only check box.

  5. Click OK.


Run Setup Script

In this procedure, you run the script that sets up all the ports, channels, document definitions, maps, and specifications that are necessary for this sample.

  1. On the Biztalk Server installation drive, browse to C:\Data and double-click the executable file SetUp.vbs. The command prompt window should appear detailing the configuration process.

  2. When the script finishes, the window should close.


Check Receive Function

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and click Biztalk Server Administration.

  2. From the Console Root navigate to \Microsoft BizTalk Server 2002\BizTalk Server Group\Receive Functions. Right-click ApprovalReceiveFunction and click Properties.

  3. Be sure that the Disable receive function check box is cleared.

  4. Click OK. You can now close Biztalk Server Administration.


Run the Self-Routing Sample

This sample demonstrates that each document is processed through the channel that is designed for that specific document, and that each document is delivered to the Approval queue, ready to be processed by the POApproval.skx schedule. Although the documents have differing sources and starting formats, they are processed by the POApproval scenario with little modification (only the receive function is modified).

This sample also shows how to use BizTalk Document Tracking to check the history and status of documents that pass through BizTalk Server.

This section contains the following topics:

  • Drop Inbound Purchase Orders for Approval

  • Use BizTalk Document Tracking to View Processing History

  • Check That Each Document Is Processed Through the Proper Channel

BizTalk Server needs five key pieces of information to select channels into which to route incoming documents: Source Qualifier, Source Name, Destination Qualifier, Destination Name, and Document Definition Name. Using this data, BizTalk Server queries the BizTalk Messaging Management database to acquire a list of appropriate channels.

An appropriate channel meets all of the following criteria:

  • Its source organization matches the source key values.

  • It is attached to a port with a destination organization that matches the destination key values.

  • It has an inbound document definition name that matches the document definition key name.

The following things happen when one of the self-routing documents is submitted to the receive function:

  • When the receive function loads the document from the monitored file share, it first determines the file type. It does this through a "snoop and loop" approach, testing for each file type in the order specified on the Parsers tab of the Properties dialog for the BizTalk Server Group in the BizTalk Administrator snap-in. In our case, the file is a flat file.

  • All flat files that are consumed by receive functions require an envelope. One of the primary purposes of the envelope is to determine individual document boundaries in the incoming file. Another purpose of the envelope is to act as a reliable way to provide routing information. In our case the source information and the selection criteria for our routing is in the header.

  • To determine the document definition name using the header information, BizTalk Server first uses the document schema (defined in BizTalk Editor and referenced by the document definition in BizTalk Messaging Manager) to parse the header, convert it to XML, and load it into the Document Object Model (DOM). Using the dictionary properties in the header schema, BizTalk Server retrieves three key pieces of information: the source qualifier, the source name, and the document type selection criteria.

  • Because the destination key values are provided to BizTalk Server by the receive function, we have four out of five key values. We still need the document definition to parse and convert the bulk (that is, the non-envelope) portions of the document. BizTalk Server accomplishes this by performing a query against the BizTalk Messaging Management database using the selection criteria, in our case, document_type. For example, BizTalk Server would query for all of the document definitions that have a selection criteria called document_type that is equal to the value pulled from the header, for example, "NWB".

  • After all five keys are determined, BizTalk Server makes the final query to find matching channels. Note that zero or more channels can be returned by this query. For example, finding more than one document with the matching selection criteria could result in more than one channel in the final query. If this happens, the document is submitted to all channels in the query results.


Drop Inbound Purchase Orders for Approval

To exercise the solution that we have now built for self-routing documents, we simply drop one or more of the instance documents provided in the demonstration.

  1. Using Windows Explorer (or other tool of your choice), navigate to c:\data\source and copy the file named NWBPO2.csv and paste it into c:\data\POApproval\PODrop.

  2. After you do this, you should see the VBScript message box that says "PO Approval Submitted for Approval".

  3. If you do not see the message box, then the receive function was unable to use the envelope to parse and route the document to the appropriate channel. Examine the Suspended queue and the Application Event Log for more information.


Use BizTalk Document Tracking to View Processing History

To determine how the documents are actually processed, we can use BizTalk Document Tracking as follows:

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and click BizTalk document tracking on localhost.

  2. In the tracking interface, under Source Selection, select one or both of the organizations that are used in the routing scenario (NWBuyers or CBuyers).

  3. Under Destination Selection, click Home Organization.

    Note that the only document definition that appears in the list is DecisionFactors because that is the only document that is currently configured as an inbound document on any channels that have the source and destination specified.

  4. Under Document Type Selection, click Show Documents.

  5. Click Query.

    Notice that in the Source Selection box, you see only the NWBuyer source. This is because the other sources have not yet sent any documents. Later, , you will see the other source, Cbuyer, appear in the Source Selection box.

  6. In the resulting list, note the key information (source, destination, and document definition name) that defines how the documents were processed. Also notice the time stamp and other information about the documents. Both inbound (native .csv) and outbound (.xml) documents are listed. In addition, you can click the icon in the data column to see the document contents.


Check That Each Document Is Processed Through the Proper Channel

Note that documents with a "2" in the name have two documents contained in the file. Notice that two documents are placed on the Approval queue when these documents are submitted because BizTalk Server breaks up the inbound file based on the flat-file envelope that is used.

  1. Submit each of the files: CBPO1.csv, NWBPO1.csv, and NWBPO2.csv, by dropping each into c:\Data\POApproval\PODrop.

  2. Use BizTalk Document Tracking to review how each document was processed, as described in the preceding topic.


Send to Remote Queue

This sample contains a COM object in the library SendToRemoteQueue.dll that can be used to send XLANG messages to a message queue on a remote server.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Send To Remote Queue

User's Guide

Before running the sample, register the library SendToRemoteQueue.dll on your system by using the RegSvr32 registration utility. This library must be registered on a computer that is running Microsoft BizTalk Server.

This sample provides a simple schedule (RemoteQueue.skv) that reads a common purchase order file (CommonPOSample.xml) from a local message queue, and then sends that purchase order to a remote message queue. To run this schedule, follow these steps:

  1. Create a private queue named .\private$\inbound on the local computer.

  2. Open the file RemoteQueue.skv in BizTalk Orchestration Designer.

  3. Click the Data tab at the bottom of the window.

  4. Double-click the Constants message to open the Constants Message Properties dialog box. Replace the values "RemoteServerName" and "RemoteServerQueue" with the real names of your remote server and queue.

  5. Verify that the QueueType and IsTxn constant values are correct for the remote queue. If not, update them accordingly.

  6. Compile the drawing into an XLANG schedule file (.skx).

  7. Run the XLANG schedule.

  8. Send a message to the .\private$\inbound queue that contains the purchase order data in the file CommonPOSample.xml. Note that the sample does not provide this functionality.

For additional information on compiling and running XLANG schedules, see the following topics:

  • Run XLANG Schedules

  • Compile an XLANG schedule drawing into an XLANG schedule

Programming Notes

To use the sample, add one or more bindings to this COM object in your existing XLANG schedule files. After the object is bound to a schedule, you also need to modify the data mapping in the schedule to specify the remote server and queue name destination for the message. The SendToRemoteQueue object contains the following input parameters for sending messages to a remote queue:

strMessage

String containing the message body.

strMSMQServerName

String containing the name of the remote server computer.

strMSMQQueueName

String containing the name of the remote message queue.

strMSMQQueueType

String containing the type of the remote queue. This value can be set to "PUBLIC" or "PRIVATE".

strMSMQMsgLabel

String containing the label of the message.

bollsQueueTransactional

Boolean that indicates whether the remote queue is transactional.

Note

  • The information in the message label cannot be passed to a remote queue.


Submitting Documents

This sample demonstrates how to set up a BizTalk Messaging Management database and call the Submit method of the Interchange object, which submits a business document to BizTalk Server 2002 from VBScript. The sample also demonstrates the creation and use of an open destination messaging port, organization aliases, custom envelopes, and the IBizTalkTrackData object.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Sample1

User's Guide

Before running the sample, complete the following steps:

  1. Start a Command Line window.

  2. Change the directory to:

    <Microsoft BizTalk Installation Path>\SDK\Messaging Samples\Sample1

To run the sample:

  • Run cscript Sample1.vbs.

Programming Notes

During execution Sample1 outputs messages indicating its progress. It performs the following steps:

  • First it reports the results of using BizTalk Messaging to configure one organization, two documents, one envelope, an open destination port, and a channel.

  • It then reports the results of the Submit method call, waits for 10 seconds, and outputs the content of the tracked business document.

  • Finally, Sample1 creates the file C:\temp\Sample1_<tracking_id_GUID>.txt, which contains a SOAP-enveloped document from the original Sample1.xml data file.

The input file, Sample1.xml, is an XML CommonPO document wrapped in a BizTalk Framework (BTF) 1.0 envelope.

The output file, C:\temp\Sample1_<tracking_id_GUID>.txt, is an XMLCommonPO document identical to Sample1.xml wrapped in a BTF 2.0 envelope, also known as a SOAP envelope.


Submitting Documents with Receipts

This sample shows how to set up a BizTalk Messaging Management database and explains one way of generating a receipt. This is accomplished by mapping a received purchase order (PO) to a PO acknowledgment without using a receipt channel.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Sample2

User's Guide

Before running the sample, complete the following steps:

  1. Start a Command Line window.

  2. Change the directory to

    <Microsoft BizTalk Installation Path>\SDK\Messaging Samples\Sample2

To run the sample:

  • Run cscript Sample2.vbs.

Programming Notes

There are three parties involved in this sample: the source application, the source organization, and the destination organization. The PO originates from the source application, is passed to the source organization, and then is passed from the source organization to the destination organization. The destination organization then sends the PO acknowledgment back to the source organization.

The sample uses local file transport. Two local File receive functions are configured for this sample.Both receive functions call the Submit method of the IInterchange object.

The setup section of the script creates three folders on the C drive. They are C:\temp\SRC, C:\temp\DST, and C:\temp\ACK. This script places the original PO in C:\temp\SRC, and the SRC receive function is configured to pick up files there. The SRC receive function moves the original PO to C:\temp\DST, and the DST receive function places the PO acknowledgment in the C:\temp\ACK folder.

This sample calls SubmitSync for the first submission and overwrites the component configurations on the channel.

The channels created can be described as follows:

SRC/APP->SRC/APP (C:\temp\SRC, used the script to drop a file)

OpenSrc->DST (C:\temp\DST, used receive function to drop a file)

DST->SRC (C:\temp\ACK, used receive function to drop a file)

During execution, Sample2 outputs messages indicating its progress. It performs the following steps:

  • First it copies CommonPOACKMAP.xml into the BizTalkServerRepository\Maps\Microsoft folder.

  • It then verifies the existence of the C:\temp, C:\temp\SRC, C:\temp\DST, and C:\temp\ACK folders, and creates two File receive functions: "SRC File Receive Function" and "DST File Receive Function."

  • The script then tries to remove all pre-existing Sample2-related configuration objects if Sample2 was previously executed. It configures the following Sample2 objects: two organizations, two documents, one envelope, one port, and three channels.

  • It then calls SubmitSync, verifies the response from SubmitSync, waits for one minute, and verifies that no Suspended queue items are present and that the C:\temp\ACK\Sample2ACK.xml file exists. This file should contain CommonPOAcknowledgment wrapped in SOAP envelope.

The input file, Sample2.xml, is an XML CommonPO document wrapped in a BizTalk Framework (BTF) 2.0 (SOAP) envelope.

The output file, C:\temp\ACK\Sample2ACK.xml, is a CommonPOAcknowledgment file mapped from CommonPO and wrapped in a SOAP envelope.


Submitting Documents to a Port Group

This sample sets up a BizTalk Messaging Management database and calls the Submit method of the IInterchange object, which submits the business document to BizTalk Server 2002 synchronously.

A distribution list in BizTalk Server is a way to send an identical business document, containing identical data, to a number of partners. The business document originates from the source application and is passed to the distribution list, which causes the same purchase order (PO) to be sent to the source application and to the destination organization. To verify that the documents have been processed correctly, look for Sample3_DST.txt and Sample3_SRCAPP.txt files in the C:\temp folder.

The sample Distribution List contains related information.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Sample3

User's Guide

To run the sample, follow these steps:

  1. Start a Command Line window.

  2. Change the directory to:

    <Microsoft BizTalk Installation Path>\SDK\Messaging Samples\Sample3

  3. Run cscript Sample3.vbs.

Programming Notes

During execution, Sample3 outputs messages indicating its progress. It performs the following steps:

  • First it copies Sample3.asp into the default Web site of Internet Information Services (IIS).

  • It then tries to remove all Sample3-related Configuration objects if they exist.

  • It configures the following objects: two organizations, one document, one envelope, two ports, one port group, and one channel pointing to the port group (distribution list).

  • It calls Submit, waits for 15 seconds, and verifies that the resulting C:\temp\Sample3_SRCAPP.txt and C:\temp\Sample3_DST.txt files exist.

The C:\temp\Sample3_DST.txt file is created as a result of posting the data to the Sample3.asp page. The C:\temp\Sample3_SRCAPP.txt file is created by a file transport configured in the source application port. The first line of C:\temp\Sample3_DST.txt indicates when the data was received by the destination organization. Both files contain SOAP-enveloped data from the original Sample3.xml.

The input file Sample3.xml is an XML CommonPO document wrapped in a BizTalk Framework (BTF) 2.0 (SOAP) envelope.

The output files are as follows:

  • C:\temp\Sample3_SRCAPP.txt is an XMLCommonPO document identical to the one from Sample3.xml wrapped in a BTF 2.0 envelope, also known as a SOAP envelope.

  • C:\temp\Sample3_DST.txt is an XMLCommonPO document identical to the one from Sample3.xml wrapped in a BTF 2.0 envelope, also known as SOAP envelope, with a first line containing "- Received at date/time -".


Suspended Queue Monitoring

This sample demonstrates how to raise an alert in Microsoft Operations Monitor (MOM) when a document is sent to the BizTalk Server Suspended queue.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Suspended Queue Monitoring

User's Guide

Complete the following steps to configure this sample:

  1. On your C drive, create a folder named ReceivePO.

  2. Run the configuration script, SuspendedQueueConfig.vbs, to configure BizTalk Messaging Services.

  3. Enable the event processing rule named "Suspended Queue Sample" in the BizTalk Server 2002 Management Pack that is installed in Microsoft Operations Monitor.

  4. Verify that the computer running BizTalk Server is a managed computer agent in Microsoft Operations Monitor.

Note

  • The BizTalk Messaging Services configuration script, SuspendedQueueConfig.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Channel: TestChannel

    2. Port: TestPort

    3. Organization: Dest Org

    4. Organization: Source Org

    5. Document Definition: PO

    6. File Receive Function: ReceivePurchaseOrders

To run the sample, complete the following steps:

  1. Ensure that the InvalidPO.xml file is not read-only. To modify this property, right-click the file, click Properties, clear the read-only attribute, and then click OK.

  2. Copy the file InvalidPO.xml into the file receive directory C:\ReceivePO. This will generate a Suspended queue event, which is displayed in the alerts for that agent computer in the Microsoft Operations Monitor console.

Important

  • For the Suspended queue event to be consumed by MOM, the MOM DAS account must be a member of the BizTalk Server Administration group.


Synchronous Orchestration Component

This sample demonstrates a synchronous method for invoking and interacting with an XLANG schedule.

A synchronous call into BizTalk Server expects a response document in return for a request document submitted through the SubmitSync method. For example, in a Web scenario where data flows through HTTP.Request into a Web page (for example, request-submit.asp) and is submitted to BizTalk Server through SubmitSync, the response from BizTalk Server is sent back to the HTTP client by mapping the response document to the HTTP.Response. If the application that produces the response document behind BizTalk Server is accessed through an XLANG schedule, BizTalk Server must implement a synchronous, or blocking, method of invoking and interacting with the XLANG schedule.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SOC

User's Guide

Before running the sample, complete the following steps:

  1. Open the SOC.dsw Visual C++ workspace. Compile the SOC and REQRES Visual C++ projects. The AIC will be registered with a ProgID of "BizTalk.SyncOrchestration".

  2. Open the XLANG schedule drawing RequestResponse.skv in the Schedule subfolder. Use the Make XLANG RequestResponse.skx command on the File menu to create an XLANG schedule.

  3. Copy the ASP files located in the ASP subfolder to the folder:

    \Program Files\Microsoft BizTalk Server\MessagingManager\pipeline

  4. Create a messaging port that uses an AIC transport type, and is referencing the new BizTalk.SyncOrchestration component.

  5. Create a channel for the messaging port, with any document specification, and a document instance generated from BizTalk Editor. On the Advanced Configuration page, click Advanced. On the Primary Transport tab, click Properties.

  6. On the BizTalk SyncOrchestration Properties page, enter the path and file name of the XLANG schedule in the Skedpath text box. Enter the XLANG port name SyncPort in the Skedport text box.

To run the sample:

Create the IInterchange object and call the SubmitSync method with the channel name and a sample document that uses the Inbound Document Definition specified on the channel. The response will appear as the out parameter of the SubmitSync method call.

Programming Notes

Synchronous COM calls into XLANG schedules are made by invoking a synchronous orchestration component, which is an application integration component (AIC) that implements the IPipelineComponent interface. A synchronous orchestration component uses a property page (.asp) configured with the path of the associated XLANG schedule, which will be used to process messages of a particular schema on the port. When a message arrives at the port through a channel, BizTalk Server invokes a predefined and configured synchronous orchestration component, passing the dictionary object to it. The custom synchronous orchestration component inspects the dictionary object and retrieves the schedule path. It then uses the path to invoke the XLANG schedule, passing along the document in the working_data field of the dictionary object.

The first action in the XLANG schedule is bound to the IRequestResponse::SetRequest(requestDoc) method. The synchronous orchestration component invokes this method and passes the request document to the XLANG schedule for processing. To receive the resulting response document from the XLANG schedule processing, the synchronous orchestration component makes two subsequent calls to the XLANG schedule instance. The first method invoked is IRequestResponse::CompleteProcessing, which sets the response document. Immediately thereafter, the synchronous orchestration component invokes the IRequestResponse::GetResponse method to retrieve the response document. The synchronous orchestration component is blocked until the XLANG schedule processing flows to the action that is bound to the SetResponse port. This call will time out after 120 seconds if no response is available. You can change this default time-out setting of 120 seconds by changing the constant MAX_TIMEOUT_SECS in RequestResponseExample.h.

Note

  • Because the client is blocked while awaiting a response, any issues with time-out limits must be addressed when implementing a synchronous process flow.

The response document is then returned by the synchronous orchestration component to BizTalk Server as a field in the dictionary. BizTalk Server then returns the response document to the Web page that called SubmitSync. The Web page in turn maps the response document to HTTP.Response. To provide COM activation and message delivery from BizTalk Messaging Services to an XLANG schedule, the XLANG schedule must have its first action bound to the IRequestResponse::SetRequest method and its last two actions bound to the actions that will allow the passing of a response document.

Notes

  • If outbound processing by BizTalk Server is required for the response document, the synchronous orchestration component can call into BizTalk Server by using SubmitSync before returning the results to the ASP page through BizTalk Messaging Services.

  • The synchronous orchestration component can be used as an orchestration activation and as a DCOM data delivery mechanism by modifying the synchronous orchestration component to call only SetRequest.


Tracking Database Tasks

This sample contains an SQL script for creating a sample SQL Server Agent job: dtaJob_receipt_monitor_<TrackingDatabaseName>

This job monitors expiring records in the dta_outdoc_details table that are expecting receipts to come back and whose waiting periods have a time-out. By default, this job runs every 30 minutes. It calls the dta_job_mark_expired_outdocs stored procedure.

For a related sample, see the file dta.vbs in the folder \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Miscellaneous.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SQLServerAgentJobs

User's Guide

Before running the sample, complete the following steps:

  1. In a text editor, open the DTA_SampleJobs.sql sample file.

  2. Find all instances of the string "%InterchangeDTA%" and replace them with the name of your BizTalk Server Tracking database.

  3. Save the file. You might need to remove the read-only attribute on the file before you can save it.

  4. Start the SQL Server Agent service if it has not already been started.

  5. Start SQL Query Analyzer. On the Start menu, click Programs, click Microsoft SQL Server, and then click Query Analyzer.

  6. In SQL Query Analyzer, connect to the SQL database server to which your BizTalk Server Tracking database belongs.

  7. Change the current database to your BizTalk Server Tracking database.

To run the sample:

  • Open the modified DTA_SampleJobs.sql file and execute a query (press F5).

Programming Notes

If you encounter errors, make sure that the database user account with which you are connecting to the database server has sufficient permissions to create stored procedures and SQL Server Agent jobs. Also make sure that the string find-and-replace in step 2 was done correctly.


Windows Management Instrumentation

This sample illustrates the use of Visual Basic scripts to configure administrative entities such as organizations, document definitions, ports, channels, and receive functions.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\WMI

User's Guide

The sample sets up a file-to-file scenario between two organizations. Each organization is simulated by a directory on the file system. BizTalk Server receives a document from the source organization, and then transforms it and submits it to the destination organization.

To prepare and run the sample, follow these steps:

  1. Run setup.cmd in the sample directory to configure the scenario and run the scripts.

  2. Run the sample scenario by navigating to C:\BizTalkWMI\ and copying the file SourceInstance.xml into C:\BizTalkWMI\SourceOrg.

    This file should be consumed by BizTalk Server, transformed, and submitted to C:\BizTalkWMI\DestinationOrg as the file OutDoc%tracking_id%.xml, where %tracking_id% is a unique ID value.

  3. Run Cleanup.vbs to clear the configuration changes that were made by the sample scripts and to delete c:\BizTalkWMI.

  4. To clear the files stored to WebDAV, navigate to Program Files\Microsoft BizTalk Server\BizTalkServerRepository on the file system and delete DocSpecs\WMISourcePOSchema.xml, DocSpecs\WMIDestPOSchema.xml, and Maps\WMIPOMap.xml.

The two setup scripts that are run in this sample are:

  • ConfigureBTC.vbs. This script creates the organizations for the source and destination, the documents for the source and destination specifications, and the port and channel that are needed for the scenario.

  • ReceiveFunction.vbs. This script configures the File receive function for the scenario.

For more information on these scripts, see the following topics:

  • Creating ConfigureBTC.vbs

  • Creating ReceiveFunction.vbs

These scripts have already been created, but the following programming notes are included to provide a better understanding of how the scripts work.

Programming Notes

The setup.cmd program creates the following folders on your computer:

  • c:\BizTalkWMI. The common folder where all the scenario-related files are copied

  • c:\BizTalkWMI\SourceOrg. The location where BizTalk Server receives documents that are to be sent to the destination organization

  • c:\BizTalkWMI\DestinationOrg. The location where BizTalk Server drops documents that were received from the source organization after processing them

The following files are used in the scenario. You might want to examine them to gain a better understanding. These files are copied to C:\BizTalkWMI and installed in WebDAV:

  • SourcePOSchema.xml. The specification for the source purchase order

  • DestPOSchema.xml. The specification for the destination purchase order

  • POMap.xml. The map that is used for transforming the source specification to the destination specification

The following sections walk through the process of creating ConfigureBTC.vbs and ReceiveFunction.vbs. Double-click the scripts to run them. To avoid name conflict errors, run Cleanup.vbs before attempting to rerun the two configuration scripts. The names of all objects that are created by the scripts in this sample start with "WMI".


Creating ConfigureBTC.vbs

This section walks through the steps that are necessary to set up the two organizations, two document definitions, one port, and one channel that are used in the scenario. After running the script, use BizTalk Messaging Manager to verify that these objects have indeed been added.

  1. Create the Configuration object.

    Calling CreateObject with the ProgID "BizTalk.BizTalkConfig" is the first step in any script that uses the SDK. All other BizTalk Messaging Configuration objects are accessed through this main Configuration object.

  2. Create the source organization.

    Create an Organization object and set its name attribute to the name desired for the source organization. Store the organization handle for use later while configuring the channel.

  3. Create the destination organization.

    Create an Organization object and set its name attribute to the name desired for the destination organization. Store the organization handle for use later while configuring the port.

  4. Add specifications and maps to WebDAV.

    Helper subroutines and functions are used to extract server information and to store the document specifications and map to WebDAV. A WebDAV URL is in the form http://SERVER_NAME/BizTalkServerRepository/. Note that document specifications must be stored in the DocSpecs folder and maps must be stored in the Maps folder under the WebDAV URL.

  5. Create the input document definition.

    Create a Document object that represents the input document specification. Set its name and set its reference to the WebDAV path of the source document specification. Store the document definition handle for use in configuring the channel.

  6. Create the output document definition.

    Create a Document object that represents the output document specification. Set its name and set its reference to the WebDAV path of the output document specification. Store the document definition handle for use in configuring the channel.

  7. Create the port.

    The port represents the destination of this configuration. Set its name, a handle to its destination organization, a constant to indicate its primary transport type (file), and a string to indicate its primary transport address (file://C:\BizTalkWMI\DestinationOrg\OutDoc%tracking_id%.xml). Store the port handle for use in configuring the channel.

  8. Create the channel.

    The channel contains the information that is involved in transforming the document from the source format to the destination format. Set its name, a handle to its source organization, a handle to its associated port, handles to its input and output document definitions, and a reference to the WebDAV path of the map that specifies the transformation.


Creating ReceiveFunction.vbs

This section walks through the steps that are necessary to set up the File receive function that monitors C:\BizTalkWMI\SourceOrg for XML files. After the XML files are picked up, they are processed and sent to the destination organization.

Note that it is important to run this script after the configuration script, because the receive function assumes the existence of an associated channel that is created in ConfigBTC.vbs. After running the script, check to see that the receive function has been created by opening up the BizTalk Server Administrator tool and navigating to the list of receive functions.

  1. Create the locator object.

    Calling CreateObject with the ProgID "WbemScripting.SWbemLocator" is the first step in any WMI-related script. This is the standard way to get an entry point into the WMI objects.

  2. Create the services object.

    To connect to and access a set of related services on a computer, the namespace that identifies that set of services must be given. The target computer defaults to the local computer, and the namespace for the BizTalk Server services is "root/MicrosoftBizTalkServer".

  3. Get the ReceiveFunction class object.

    Use either Get or ExecQuery to retrieve the receive function class. The name of the class is "MicrosoftBizTalkServer_ReceiveFunction".

  4. Spawn an instance of the receive function.

    Use the SpawnInstance_ method on the receive function class to set its attributes.

  5. Set the name of the receive function instance.

  6. Specify the protocol type for this receive function (as File).

    Because the receive function class represents all receive functions, its ProtocolType must be set to 1 (for ADMIN_PROTOCOL_TYPE_FILE) to indicate that it is a File receive function.

  7. Specify the processing server on which this receive function will run.

    In this case, helper functions are used to determine the local computer name.

  8. Specify the name of the group that is associated with this receive function.

    "BizTalk Server Group" is the default name that is set by the script.

  9. Specify the file name mask for this receive function.

    Setting *.xml indicates that all XML files should be picked up from the specified location.

  10. Specify the location to poll for this File receive function.

    This is the location on the file system where the receive function will monitor and pick up source document instances. In this scenario, the PollingLocation is "C:\BizTalkWMI\SourceOrg".

  11. Specify the name of the channel to use.

    This is the channel that was created earlier by ConfigureBTC.vbs.

  12. Set the flag to create the receive function as configured.

    Calling Put_ with the flag set to 2 (wbemChangeFlagCreateOnly) means that we are creating the receive function as configured. The value 2 is the only supported value in the SDK.


BizTalk Orchestration Services Code Samples

Sample files are located in the XLANG Samples folder on the Microsoft BizTalk Server installation drive. Browse to \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples on the installation drive to find the sample files. This is only a relative path. Depending on your installation of BizTalk Server 2002, you might need to modify this path.

  • BizTalk Framework Correlation

  • BizTalk Services Integration

  • Dispatcher Application

  • Dynamic Binding with COM

  • Dynamic Binding with Message Queuing

  • Exception Handling

  • Iteration

  • Nested Transactions

  • Orchestration Services Audit

  • Orchestration Services Audit Client

  • Personalized Queues

  • Queue Listener

  • While Shape

  • XLANG and ASP

  • XLANG Interfaces

  • XLANG Schedule Pooling

  • XLANG Submit Synchronously and Query Asynchronously

  • XLANG Trace

  • XML Translation


BizTalk Framework Correlation

This sample illustrates the use of BizTalk Framework (BTF) 2.0 and orchestration to accomplish stateful interoperability between two applications. It allows two (or more) applications to engage in a potentially long-lived exchange of messages. Each exchange is capable of referring back to the data passed in previous exchanges.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Integrating BizTalk Services

User's Guide

The sample contains the following directories:

  • App contains the BTS SimpleApproval schedule file.

  • BTM2BPO contains a combination application integration component (AIC) and utility component. The AIC part of the component allows a BTF-enveloped message, which includes the <prc> tag, to be sent to the correct existing instance of an orchestration through a message queue or a COM interface (ReceiveMsg). The port name and other options are set through the BizTalk Messaging Manager (Advanced-Properties). In addition to this AIC, this project also contains code needed to envelope an existing message and include the <prc> tag and 'reflect' an enveloped message.

  • ThirdPartyApp contains an application that simulates a third-party application.

  • FileSubmit is the polling location for the ReceiveNewApp receive function.

  • Schema is the directory containing the schema.

  • CorrUtil contains a utility component.

  • SetupFiles contains the scripts to install and uninstall the sample.

To run the sample, follow these steps:

  1. Run setup.cmd to install the sample.

  2. Run SubmitDoc.cmd to drop the NewAppInst.xml file into the FileSubmit directory.

  3. Run ThirdPartyApp\ThirdPartyApp.exe. The Get Message button will retrieve the next message from the RequestApproval queue. It should appear in the edit window. Press the Reflect button to prepare the message for sending back to the schedule. Press Approve to send it to the Approvals queue or Decline to send it to the Denials queue. Message Queuing receive functions will pass these messages back to BizTalk Server and through BTM2BPO back to the schedule.

    The BTS SimpleApproval schedule illustrates two ways in which the response document is delivered to the running schedule instance. The ReceiveApprovalPort port is a Message Queuing port and receives the document through a per-instance queue. The ReceiveDenialPort port is a COM port and receives the document as a parameter to the ReceiveMsg method of the IReceive interface.

  4. View the Application Log by using EventViewer for the name of the port to which the response document was delivered.

  5. Run remove.cmd to uninstall the sample.

Programming Notes

The sample uses:

  • Orchestration to maintain the state of the exchange and determine the sequence of exchanges.

  • BizTalk Framework 2.0 envelopes to pass a state identifier between the applications.

  • BizTalk Server 2002 messaging facilities to abstract individual applications from each other.

BTS SimpleApproval.skv provides a summary view of a sample orchestration using all of the above.


BizTalk Services Integration

Two samples are provided to demonstrate the integration of BizTalk Messaging Services and BizTalk Orchestration Services.

Paths

To locate the sample files for the sample using HTTP as a transport mechanism, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Integrating BizTalk Services\http

To locate the sample files for the sample using Message Queuing and File receive functions, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Integrating BizTalk Services\non-http

User's Guide

Detailed information regarding the HTTP-based sample is provided in the Setting Up HTTP Sample.doc file located in the http folder.

Detailed information regarding the Message Queuing sample is provided in the Setting Up Non-HTTP sample.doc file located in the non-http folder.


Dispatcher Application

This sample demonstrates a dispatcher application that sends and receives documents on behalf of a client application. When a document is sent, the dispatcher saves the "From address" in a database before sending the document and uses the saved address to route the response document to the correct sender.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Dispatcher

User's Guide

This sample consists of the following directories:

  • Apps contains the schedules, a data file, and VBScript files to run the sample.

  • ClientUtil contains a helper component for the ClientApp schedule.

  • DbUtil contains a helper component for simulating a database.

  • DestUtil contains a helper component for the DestApp schedule.

  • DispatchUtil contains a helper component for the DispatchApp schedule.

  • SendUtil contains a helper component for the SendApp schedule.

The setup script, "setup.cmd", does the following:

  • Registers the following components: ClientAppUtil, SendAppUtil, DestAppUtil, DispatchAppUtil, and DbComp.

  • Creates the Message Queuing queues SendDocs, RecvDocs, and UnknownDocs.

To remove the sample, run "remove.cmd".

To run the sample, first run "startDispatchApp.vbs" in the "Apps" directory. This starts the "DispatchApp" schedule and should be run only once. Then run "startClientApp.vbs" in the "Apps" directory. This starts the "ClientApp" and "DestApp" schedules.

The "ClientApp" schedule sends a document to the "SendApp" schedule along with the To Queue and From Queue paths and then waits on a per-instance queue for the response.

The "SendApp" schedule generates a unique token and saves the FromQueue (the per-instance queue of ClientApp) path and the token in a database. The token is added to the document, which is then sent to the To Queue (SendDocs).

The "DestApp" monitors the "SendDocs" queue, reads the document from the queue, extracts the token, creates a response document, adds the token to the response document, and sends the response document to the response queue "RecvDocs".

The "DispatchApp" schedule monitors the "RecvDocs" queue for any document. When the response document is available in the queue, it extracts the token from the document, gets the corresponding delivery queue path from the database, and sends the response document to the delivery queue. If the delivery queue cannot be determined, the document is sent to the "UnknownDocs" queue. After dispatching the document to the correct queue, the "DispatchApp" schedule starts another instance of itself to continue monitoring the "RecvDocs" queue.

The "ClientApp" that is waiting on the per-instance queue receives the response document and processes it.

The "startClientApp.vbs" script can be run any number of times. To terminate the "DispatchApp" schedule, shut down and restart the "XLANG Scheduler" COM+ application by using the Component Services MMC snap-in.

Programming Notes

The "ClientApp" schedule gets the document as an input parameter. The Get Constants action is used to get constant values into the schedule. The Display Input Doc action displays the input document. The Send Doc action uses a helper component to start the "SendApp" schedule and pass it the document, the path of the queue to send the document to, and the path of the per-instance queue where the response should be sent. The Get Response Doc action is used to wait on the per-instance response queue for the response document. The Display Response Doc action displays the received response document.

The "SendApp" schedule receives the document and the From Queue and To Queue paths from the Get Input action. The Save Return Address action generates a GUID token and saves the token and the From Queue address in a database. The token is then added to the document to be sent. The SendDoc action sends the document to the To Queue (SendDocs).

The "DestApp" schedule waits on the "SendDocs" queue for the document. The ReceiveDoc action gets the document from the queue. The CreateResponse action extracts the token from the document, creates a response document, and adds the token to the response document. The SendResponse action sends the response document to the "RecvDocs" queue.

The "DispatchApp" schedule waits on the "RecvDocs" queue for the document. The Get Doc From Queue action gets the document from the queue. The Get Delivery Queue action extracts the token from the document and retrieves the corresponding delivery queue path from the database. The SendDoc action sends the document to the delivery queue.

The "ClientAppUtil" helper component is used by the "ClientApp" schedule to get input parameters, get constants into the schedule, display a message box, start the "SendApp" schedule, and pass parameters to it.

The "SendAppUtil" helper component is used by the "SendApp" schedule to get input parameters and to save the delivery queue path in the database.

The "DestAppUtil" helper component is used by the "DestApp" schedule to extract the token from the input document, create the response document, and add the token to the response document.

The "DispatchAppUtil" helper component is used by the "DispatchApp" schedule to get input parameters, get the delivery queue path from the database, and restart the "DispatchApp" schedule.

The "DbComp" helper component is used by the "SendAppUtil" and "DispatchAppUtil" components to save and retrieve the delivery queue address from a file-based database. The database is simulated by using an XML file, "TrackDb.xml," that is created in the DbUtil directory.

Note

  • To simplify this sample, a file-based database is used. Therefore a transaction shape cannot be used with the database-related actions. Ideally one would use transaction shapes in conjunction with a transactional database to ensure proper recovery in case of failures. The QueueListener sample demonstrates how to use transactions to ensure that a schedule is restarted in the event of an abnormal termination.


Dynamic Binding with COM

This sample demonstrates how to bind dynamically to a COM component. The COM component that the schedule binds to is decided at run time.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Dynamic Binding\COM

User's Guide

The sample consists of the following directories:

  • ScrambleApp contains the scramble sample schedule and the VBScript file to run the sample.

  • ScrambleUtil contains a helper component used to create the COM component to bind to and display messages.

  • ScrambleInterface contains the type library for the IScramble interface.

  • HighSecurityScramble contains a COM component that implements the IScramble interface.

  • LowSecurityScramble contains a second COM component that implements the IScramble interface.

The setup script, "setup.cmd", does the following:

  • Registers the "Scramble" typelib.

  • Registers the following components: HighScramble, LowScramble, and ScrambleHelper.

To remove the sample, run "remove.cmd".

To run the sample, run "startit.vbs" in the "ScrambleApp" directory. The input data to be scrambled is passed to the schedule. When the message High Security Scramble for "Hello World!"? is displayed, click "Yes" to scramble the data by using the "HighScramble" component or click "No" to scramble the data by using the "LowScramble" component. The output is displayed in a message box.

Programming Notes

In this schedule, the "GetInput" action gets the data to be scrambled.

The "GetScrambler" action creates the scrambler component to use based on user selection.

The "ScrambleData" action scrambles the data by using the component created by the previous action. This action can bind to any component that implements the "IScramble" interface.

The "DisplayScrambledData" action displays the output of the "ScrambleData" action.

A helper component, "ScrambleHelper," is used to create the scrambler component and to display messages.


Dynamic Binding with Message Queuing

This sample demonstrates how to bind dynamically to a message queue. The queue path is specified at run time.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Dynamic Binding\Queue

User's Guide

The sample consists of the following directories:

  • QueueBindApp contains the queuebind sample schedule, data file, and VBScript files to run the sample.

  • QueueBindUtil contains a helper component used to process the data file and display messages.

The setup script, "setup.cmd", does the following:

  • Registers the "QueueBindUtil" component.

  • Creates Message Queuing queues named purchase_dept and marketing_dept.

To remove the sample, run "remove.cmd".

To run the sample, run "startit.vbs" in the "QueueBindApp" directory. The "MarketingDeptOrder.xml" data file is sent to the "purchase_dept" queue and the schedule is executed. The schedule reads the data file from the queue and sends an acknowledgment to the "marketing_dept" queue. A message box displays the acknowledgement generated and the reply queue.

Programming Notes

In this schedule, the incoming document received by the "GetOrder" action contains the reply queue location where the acknowledgement needs to be sent.

The "ProcessOrder" action builds the acknowledgement document and extracts the path of the reply queue from the incoming document.

The "DisplayAck" action displays the acknowledgement document and the reply queue location.

The "SendAck" action sends the acknowledgement document to the reply queue that was specified in the incoming document.

A helper component, "QueueBindUtil," is used to process the data file and to display messages.


Exception Handling

This sample demonstrates how to handle an exception.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Transaction Abort

User's Guide

The sample consists of the following modules:

  • A Visual Basic ActiveX DLL contains the component called by the schedule.

  • Abort.vbs contains the code to run the schedule.

The setup script, setup.cmd, registers the abortsample component.

To remove the sample, run remove.cmd.

To run the sample, run Abort.vbs. When you click OK in the dialog box, it sends the string to the schedule. If you have typed Abort, the transaction will be aborted, and you will be shown the appropriate messages.

Programming Notes

This sample demonstrates the use of an abort handler and auto return. When a method call returns a negative HRESULT, then the outer transaction is aborted and the abort handler code for the transaction starts executing. After the abort handler code completes, the command goes to the next action.

If the transaction is aborted then the document is put back on the Received_Doc_In queue (because Message Queuing is used in the transaction) and the abort handler drops a copy of the document into the aborted_doc_out_ queue.


Iteration

This sample demonstrates how to iterate through a list of items and process each item independently based on a condition.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Iteration

User's Guide

Before running the sample, run the setup script setup.cmd.

To run the sample, follow these steps:

  1. Browse to the LineItemsApp folder.

  2. Run the script file startit.vbs.

  3. When prompted, click OK on the message box to continue.

Programming Notes

When run, the "ItemList.xml" file is sent to the "items_in" queue. This file contains a list of items to be processed. The schedule picks up the file from the queue and processes the items in it. Each item is placed in a different "out" queue based on the item type. Any item of unknown type is placed in the "unknown_out" queue. A message box is displayed as each item is processed.

This sample uses a simple counted loop to iterate through the list of items. The GetItemCount action is used to get the maximum iteration count and the While shape is used to control the loop. The Decision shape uses different rules to determine the branch to execute. The Join shape uses an OR join type because only one of the branches will be executed at any given time.

A helper component, "LineItemHelper", is used to increment the loop count, process the data file, and display messages.

To remove this sample, run the script remove.cmd.


Nested Transactions

This sample illustrates nested transactions, aborting a transaction, and compensation.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\NestedTxns

User's Guide

To install this sample, register all the script components in the sample directory.

To run the sample, run the "NestedTxns.wsf" script file.

Programming Notes

The scenario for this sample is ordering an item, submitting payment, receiving the item, returning the item, and having the payment reversed. This scenario is based on a familiar shopping experience, where a merchant accepts returned merchandise and processes a credit-card credit. The credit slip looks like a credit-card debit slip except that it is usually printed in red ink.

The sample encapsulates the entire purchasing cycle in an outer transaction called "Purchase". Inside that transaction is a nested transaction called "Payment". The compensation block for "Payment" includes a transaction named "ReverseCharges". This sample has a total of three transaction envelopes.

The "Purchase" transaction includes an "Order" action; a "Payment" transaction; a "ReceiveItem" action; a decision about whether to keep the item; a branch to return the item, abort, and compensate the payment; and another branch to keep the item. The "Abort" action causes the entire "Purchase" transaction to abort, which, in turn, causes the nested "Payment" transaction to abort. The "Payment" transaction has a compensation block, itself transactional, that carries out the credit or reversal of charges.


Orchestration Services Audit

This sample demonstrates an orchestration audit component.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit

User's Guide

There is one interface, IUserEvent.

ServerName is the name of the server associated with your tracking database:

HRESULT Install( /*[in]*/ BSTR ServerName,

Datasource is the name of your tracking database:

/*[in]*/ BSTR Datasource,

/*[in]*/ BSTR Username,

/*[in]*/ BSTR Password,

/*[in,optional]*/ BSTR ApplicationFilter, /*[in,optional, defaultvalue(egAllEvents)]*/ EventGroupTypes EventFilter

HRESULT Uninstall();

Install installs the subscription into the COM+ catalog, and connects to the database. ApplicationFilter can be the name of a COM+ application or the GUID key for that application. EventGroupTypes can be any combination of the enumeration combined by using OR. The default is for all events.

Uninstall removes the subscription from the COM+ catalog and disconnects from the database.

A client should explicitly call Uninstall before releasing the component. Otherwise the subscription will be orphaned until the server is rebooted.

Programming Notes

The database tables and stored procedures are initially built by setup. If you want to restore these, you need to run files in the query analyzer after selecting your tracking database, in the following order:

<InstallationFolder>\Setup\BTS_WorkflowEvents_Schema.sql

<InstallationFolder>\Setup\BTS_WorkflowEvents_Logic.sql

Important

  • This orchestration audit component persists detected events into the InterchangeDTA (default name) database, which is the BizTalk Server Tracking data store. Two tables are used to contain the data for monitored events: dta_wf_WorkFlowEvent and dta_wf_EventData. The first of these contains a row for each event detected and the second contains one or more rows for each property related to a particular event in the first table. Note that the BizTalk Server Tracking user interface might show truncated event data because the columns in the second table (event data) that contain property name and value pairs are set to 100 characters, and actual names and values can exceed this length.


Orchestration Services Audit Client

This sample demonstrates an orchestration audit client.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient

User's Guide

To run this application, first register the WorkFlowAudit.dll file by typing regsvr32 WorkFlowAudit.dll at the command prompt. This file is in the <Installation Folder>\SDK\XLANG Samples\WorkflowAudit\bin folder.

After registering this component, run WorkflowAuditClient.exe. When the application is first run, it asks you to enter four parameters. Except for the database user password, the values are taken from the Windows Management Instrumentation (WMI) provider. If you want to change the default settings, type the new values.

When you click Start, the application calls the Install method of the interface in the WorkFlowAudit.dll. The events that are fired by the XLANG Scheduler will be monitored. Do not close the application while tracking the scheduler events. Doing so will terminate the monitoring process.


Personalized Queues

This sample uses a shared queue and per-instance queues. A shared queue called the new-user queue permanently resides at a URL. This queue is associated with the enterprise Web site and with a schedule for creating new users. The client goes to the well-known URL to create a new user account or to log on to an existing user account.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Personalized Queues

User's Guide

This sample uses the items described in the following paragraphs.

Queues

Queues can be inspected from the Management Console (right-click My Computer on the desktop, click Manage, navigate to Services and Applications, Message Queuing, Private Queues).

  • Fixed queue: .\private$\AmysNewUserAccount

  • Account queue: .\private$\AccountQueues{...fresh guid... }

Schedules

Schedules can be inspected with the XLANG Event Monitor that is installed with the BizTalk Server SDK.

  • AmysZoneTop.skv checks that a new user name has been deposited in the top-level queue. In a real application, this would set up user account database tables.

  • AccountSchedule.skv takes command messages in a loop from the per-instance account queue. The loop terminates when the command "Close" comes in.

Windows Batch Command Files

  • Run setup.cmd before running the sample.

  • Run remove.cmd to disable the sample and clean up.

Windows Script Files and Windows Script Components

  • RunMe.wsf runs the sample.

  • VerifyForm.wsc shows that the new user name was received by the new-user queue.

  • RecordQueueName.wsc records the user name and its associated per-instance account queue name in a text-file database.

  • CloseUserAccount.wsc removes the user name from the text-file database.

  • ReportUserCommand.wsc shows that the account schedule has received commands from the SessionWebPage.

  • CreateTopLevelQueue.vbs is run by setup.cmd.

  • DeleteTopLevelQueue.vbs is run by remove.cmd.

HTML pages

  • ClientWebPage.htm allows users to create new accounts or to log on to existing accounts.

  • SessionWebPage.htm feeds user commands to AccountSchedule.skv.

The sample setup script, setup.cmd, creates the unique shared new-user queue.

Note

  • This sample stores the user account database in a text file in the C:\winnt\system32 folder, and assumes that that folder exists. The folder name is hard-coded in only one place in the sample code, so fixing this limitation is easy. Simply edit RunMe.wsf, search for the string "winnt", and change the reference to match the name of your system folder.

To run the sample:

  • Run RunMe.wsf in the ClientApplication folder. Interact with its Web pages and dialogs.

  • Run the Microsoft Management Console (right-click My Computer on the desktop, and then click Manage) to inspect queues and the event log.

  • Run the XLANG Event Monitor to watch the schedules running.

  • Inspect the file C:\winnt\system32\AccountQueuesDB.txt to see the association of user names and per-instance queues.

To remove the sample, run remove.cmd.

Programming Notes

A new user account is represented by a new per-instance queue called the account queue. The account queue is bound to a very-long-lived schedule instance, the account schedule. The account schedule is born (instantiated) at account creation time and lives until account destruction time. Thus, its lifetime is the same as the lifetime of the user account, and this could be measured in years.

We have one new-user queue for the entire enterprise. The enterprise encompasses many user accounts, each with its own account schedule and account queue.

The user logs on to the account by interacting with the account schedule through the account queue. Conceivably, the same technique used to associate many users with one enterprise could be repeated one more level down to associate many sessions with each user. We do not do so in this sample, presuming that two levels of schedules and queues suffice to illustrate the point. However, if session schedules were used, then the account schedule would, in turn, create another per-instance queue called the session queue, which is bound to a session schedule that lives until the user logs off the account.

For now, we assume that each user gets one session, so we combine the functionality of the account with that of the session.

We call this sample Personalized Queues because there is one per-instance queue per user. The most interesting aspect of this application is that the account queue and schedule live as long as the user account. Such a schedule could encapsulate a considerable amount of persistent state information about the user.

The user first approaches the application through a script called RunMe.wsf in the ClientApplication directory. This script launches a Web page called ClientWebPage.htm. To create a new account, the user chooses a user name and a password and enters them into a form on this Web page. When the user clicks Create New User, the script, RunMe.wsf, deposits the new user name in the new-user queue and invokes the schedule in AmysZoneTop.skx.

The job of AmysZoneTop is to create the account queue and instantiate the account schedule, whose XLANG specification is stored in AccountSchedule.skx. Each instance of this schedule lives as long as the user account, and this time could be measured in years.

AccountSchedule creates a new queue for the user. The name of this queue is generated automatically by the system. AccountSchedule invokes a script component, RecordQueueName.wsc, to store the name of the new queue in a system database. For illustration purposes in this sample, the database is stored in a flat text file in the system directory. In a real application, it will be necessary to keep user names and queue names in a SQL Server database.

AccountSchedule then goes into an indefinite loop awaiting commands from the user to arrive on the user's personalized queue.

Note that no real processing of passwords is done in this sample. Password processing is a delicate and critical topic; however, it is beside the point of this sample, which is to illustrate very-long-lived per-instance queues. We therefore avoid the topic in this sample.

The user can also log on to the application by running RunMe.wsf. The script checks the user name in the database and changes to another Web page that allows the user to submit commands to the personalized queue. Some suggested commands appear on the Web page SessionWebPage.htm. These commands only generate pop-up confirmation dialogs.

The one exception is the command Close This User Account. This command removes the user name from the database and shuts down the AccountSchedule, also causing deletion of the personalized queue.

Note that multiple copies of RunMe.wsf can run at one time, and, up to the limitations of contention for the simple text-file "database," all operations of this sample can be interleaved in any way. With user names stored in a SQL Server database, this issue would go away.

The theory articulated here can be verified through the Management Console and XLANG Monitor tools, as well as by inspecting the AccountQueuesDB.txt file over time. Also look at the schedules AmysZoneTop.skv and AccountSchedule.skv in BizTalk Orchestration Designer.

There is one final point worth mentioning. Due to a known limitation of XLANG script binding, it is necessary to have two messages in Port_4 of AccountSchedule. This port reports the user's command to a pop-up dialog box. One of the two messages is outside the loop and corresponds to the first command issued by the user. The other message is inside the loop and corresponds to subsequent commands issued by the user. Two messages are required because XLANG script binding refreshes the contents of a sourced message instance only once. Each iteration of the loop creates a new instance of the message as long as the message is not also present outside the loop. If there were only one message, the pop-up would show only the first command issued by the user, over and over again. The workaround for the limitation is to have two messages of identical form. Note that the Message Queuing binding in Port_2 does not suffer from this limitation, so a single message specification can be used both inside and outside the loop body.


Queue Listener

This sample demonstrates how to continuously monitor a queue for data and start another schedule when new data is available.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\QueueListener

User's Guide

The sample consists of the following directories:

  • ListenerApp contains the sample schedules, a data file, and VBScript files to run the sample.

  • ListenerClientUtil contains a helper component used by the ClientApp schedule.

  • ListenerUtil contains a helper component used by the ListenerApp schedule.

The setup script, setup.cmd, does the following:

  • Registers the ListenerClient component.

  • Registers the ListenerComp component.

  • Creates the Message Queuing queue, Listener.

To remove the sample, run remove.cmd.

To run the sample, first run startListenerApp.vbs in the ListenerApp directory. This starts the ListenerApp schedule and should be executed only once. The ListenerApp schedule monitors the Listener queue for data. When data is available in the queue, it starts the ClientApp schedule, passes the data to it, and starts another instance of itself. To put the data file order.xml into the queue, run File2Queue.vbs in the ListenerApp directory.

The File2Queue.vbs script can be run any number of times. To terminate the queue listener schedule, shut down and restart the XLANG Scheduler COM+ application by using the Component Services MMC snap-in.

Programming Notes

In the ListenerApp, the GetSkedInfo action is used to pass in the path of the ClientApp and ListenerApp schedules. The Receive Doc From Queue action waits until the document is available on the queue. The Start Client App action uses the helper component to start the ClientApp schedule and pass it the document. The Restart Schedule action uses the helper component to start another instance of the ListenerApp schedule before the current instance terminates.

Two transaction shapes are used to ensure that the schedule recovers from any abnormal termination. Transaction1 ensures that the schedule is persisted at the point where it is waiting on the Listener queue. Transaction2 ensures that the schedule is persisted just after the document is read from the queue. If the schedule is terminated at any time, it will be restarted from the last persisted state. It is important to ensure that the database is set up correctly to support persistence.

The ClientApp schedule simply displays the document that is passed to it as input.

The ListenerComp helper component is used by ListenerApp to receive input parameters and start schedules.

The ListenerClient helper component is used by ClientApp to receive input parameters and display the input document.


While Shape

This sample demonstrates how to use the While shape to retry a business process a limited number of times. A loop counter component is used to track the number of times the loop has executed. The loop terminates when the retry count is reached or when the simulated work completes successfully.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Loop

User's Guide

The sample consists of the following directories:

  • RetryApp contains the retry sample schedule and associated script components. It also includes a small VBScript file to run the sample.

  • LoopControl contains a helper component that implements a simple loop counter and supports persistence.

  • LoopUtil contains another helper component to display message boxes indicating the status of the schedule and to prompt for success or failure of the simulated work.

The setup script, setup.cmd, registers the loopcontrol component.

To remove the sample, run remove.cmd.

To run the sample, run startit.vbs in the LoopApp directory. When the schedule runs, it displays a message box to simulate the work being attempted. Click Yes to simulate successful completion of the work, or No to simulate failure. If you click No, the schedule retries the operation and displays the message box again. The schedule proceeds to completion after you click Yes or after the retry limit is reached, and indicates whether the operation was successful.

Programming Notes

This sample is a variation on a simple counted loop. The loop can terminate when the count limit is reached (the retry count) or when the simulated work completes successfully. To exit the loop early, the schedule initializes the loop count to a negative number. The While shape's rule is constructed to exit the loop when the maximum count is reached or when the count is negative.

A "constants" script component is used to supply the schedule with several constant values that are passed to other components.


XLANG and ASP

This sample demonstrates how to call a schedule from an ASP script, passing in data and getting back the result. The script initiates the work and then waits for the result.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\ASP

User's Guide

The sample consists of the following directories:

  • CreditCheckApp contains the creditcheck sample schedule, the ASP page, and a VBScript file to run the sample.

  • CreditCheckUtil contains a helper component to input data into the schedule and return the result.

  • CreditChecker contains a helper component that simulates the credit checking functionality.

The setup script, setup.cmd, does the following:

  • Registers the CreditCheckUtil component.

  • Registers the CreditChecker component.

  • Creates a creditsample Web directory on the default Web site of the local machine.

To remove the sample, run remove.cmd.

To run the sample, follow these steps:

  1. Run startit.vbs in the CreditCheckApp directory. The creditcheck ASP page is displayed in the Web browser.

  2. Enter a number in the text box and click Submit.

Credit will be denied to any number starting with 1 and to any number less then four characters in length.

Programming Notes

This sample uses a Fork shape to start both the credit checks simultaneously and a Join shape to wait for both the credit checks to complete. The ASP script waits on the IsCreditApproved call until the schedule executes the IsCreditApproved action.

Two helper components are used. The CreditCheckUtil component is used to input data into the schedule and return the results to the calling ASP script. The CreditChecker component is used to simulate calls to two different credit agencies to approve the credit.


XLANG Interfaces

This sample demonstrates how to use the XLANG public interfaces to enumerate and manage the running schedule instances and the XLANG host applications.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\PublicInterfaces

User's Guide

When run with no arguments, the sked.vbs script displays its usage options:

usage: cscript sked.vbs <command> <args>

commands:

hosts [computer]

shutdown [computer[!group]]

startup [computer[!group]]

list [computer[!group]]

run [computer[!group]] <schedule path or query> [count]

kill [computer[!group]] <instanceId>

suspend [computer[!group]] <instanceId>

resume [computer[!group]] <instanceId>

The following table shows examples of managing the schedule instances in the default group (host application "XLANG Scheduler") in the local machine.

Option | Result
sked list | Show a snapshot of the running schedules.
sked suspend {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Suspend the schedule with the given ID.
sked resume {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Resume the schedule with the given ID.
sked run c:\MySchedule.skx | Run the Orchestration schedule with the given full path. If the schedule is successfully started, the ScheduleID will be shown.
sked run c:\MySchedule.skx 10 | Run 10 instances of the given schedule.

The following table shows examples of managing the XLANG host applications.

Option | Result
sked hosts | Show the COM+ applications that can host the XLANG schedules.
sked shutdown | Shut down all host applications.
sked startup | Start all host applications.
sked shutdown "!My Host App" | Shut down only the host application named "My Host App".
sked startup "!My Host App" | Start the application "My Host App". (If the default host "XLANG Scheduler" was shut down, it will start too.)
sked hosts OtherMachine | List the host applications on the remote computer OtherMachine.
sked shutdown OtherMachine | Shut down all host applications on the remote machine OtherMachine.
sked startup OtherMachine!MyApp | Start the application MyApp on the remote computer OtherMachine (and possibly the default host "XLANG Scheduler").

The following table shows examples of managing schedules on different host applications and different machines.

Option | Result
sked list "!My Host App" | List the schedules running in "My Host App".
sked list "OtherMachine!MyApp" | List the schedules running in the application "MyApp" on the remote computer OtherMachine.
sked list OtherMachine | List the schedules running in the default host application ("XLANG Scheduler") on the remote computer OtherMachine.
sked run !MyApp c:\MySked.skx | Run the schedule MySked.skx in the application MyApp on the local machine.
sked run OtherMachine!MyApp \\server\share\MySked.skx | Run the schedule MySked.skx in the application MyApp on the remote machine OtherMachine. Note that the .skx file should be accessible to the application, for example, on a public share.
sked suspend !MyApp {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Suspend the schedule with the given ID, which is running in the application MyApp on the local machine.
sked resume OtherMachine!MyApp {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Resume a schedule running in the application MyApp on the remote computer OtherMachine.
sked kill OtherMachine {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Terminate a schedule running in the default host on the remote computer OtherMachine.

Programming Notes

The XLANG public interfaces are available from the type library "XLANG Scheduler Runtime Type Library."

The sked.vbs script uses the public interfaces IWFSystemAdmin, IWFGroupAdmin, and IWFWorkflowInstance, as well as some COM+ admin interfaces and objects.

To list the running schedules or to suspend, resume, or terminate a schedule, the moniker for the Group Manager of the given application is constructed, and its IWFGroupAdmin interface is used.

To shut down or start all host applications, or to shut down a particular application, the IWFSystemAdmin interface is used.

To start a particular application, its moniker is constructed and used in GetObject.

To run a schedule, the proper moniker is constructed (for example, "sked://"+ the computer name +"!" + the application name +"/"+schedule path) and is used in GetObject. To obtain the ID and the module name of the newly started schedule, its IWFWorkflowInstance interface is used.

To list the XLANG host applications, the COM+ admin objects are used.


XLANG Schedule Pooling

This sample demonstrates how to use the pooling feature that is built into the XLANG Scheduler Engine. This feature helps running schedules to effectively use system resources. This sample also demonstrates the new BizTalk Server 2002 feature that makes the instance ID available.

BizTalk Server 2002 provides the capability to control the load on the XLANG Scheduler Engine by limiting the number of schedules that can be run simultaneously at any given time. If many schedules are active simultaneously, the server will constantly context switch and will use the operating system resources inefficiently.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Schedule Throttling

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Run the Sample

Programming Notes

The following instructions walk through the process of setting up the pooling sample that utilizes the load-limiting capabilities of the BizTalk Server 2002 XLANG Scheduler Engine.

This schedule contains an action that is bound to a method called MessageBox on the script component. That method takes the instance ID of the schedule instance as a parameter, demonstrating one use of the new BizTalk Server 2002 feature that makes the instance ID available. As its name implies, the method displays a message box containing the instance ID. After the user clicks the message box, the schedule completes.


Preliminary Setup

Before you run the sample, you must complete the following tasks:

  • Register the Script Component

  • Run the Setup Script


Register the Script Component

In this procedure, you register the script component that is used by the sample schedule.

  1. Right-click the icon that represents the script component ThrottlingSample.wsc.

  2. Click Register.


Run the Setup Script

In this procedure, you run the script that sets up the pooling properties.

  1. Double-click the script ThrottlingConfig.vbs. Input boxes appear and request configuration information.

  2. Provide the requested information in each box and then click OK. The script uses this information to set the activation properties of the pool in which the sample schedule will run.


Run the Sample

In this procedure, you run the sample that demonstrates the pooling feature.

  1. Double-click the script ThrottlingSample.vbs. An input box appears and asks for the number of schedule instances to run.

  2. Enter the desired number of schedule instances to run and click OK.

  3. Monitor the number of running XLANG schedule instances by using XLANG Event Monitor (XLANGMon.exe). This number should not exceed the maximum pool size that was configured by using the setup script.

    Clicking the message box that a schedule instance displays allows that instance to complete and thereby make room for one more instance in the pool. If the pool becomes full before all the requested schedule instances have been activated, the next instance cannot be activated and will eventually time out. Thus, if you allow schedule instances to fill the pool (by not clicking their message boxes), you will eventually see a different message box declaring that activation of the next schedule instance has timed out.

  4. To rerun the sample with different pooling properties, rerun the setup script, ThrottlingConfig.vbs, and then start again at step 1 of this procedure.


XLANG Submit Synchronously and Query Asynchronously

This sample shows how to make an ASP page submit information into a XLANG schedule and then retrieve information without having to be interlocked with the running schedule.

Note

This sample is an extension of the ASP sample that shows the interaction between an ASP page and an XLANG schedule.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Modifying the Default Configuration

  • Running the Sample


Preliminary Setup

Complete the steps outlined in this section to configure your computer to run the sample.

Configuring the Sample Objects and Web Pages

The default configuration of this sample assumes that BizTalk Server 2002 and SQL Server 2000 are installed on the local computer. If you need to change the configuration, modify the values of DBHost as described in Modifying the Default Configuration.

To set up the required table, register COM objects, and configure a virtual Web directory, run SETUP.CMD located at \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\setup.


Modifying the Default Configuration

For the ASP page to interact asynchronously with the XLANG schedule, this sample uses a shared SQL table to store state and XLANG-to-ASP return information. Both parts of the sample (the ASP page and the XLANG schedule) share the COM object in XLANG_SAMPLE_ASYNC_SQL.DLL to communicate to the SQL table. The default configuration of the sample is to use the instance of SQL Server on "localhost."

Note that both groups of steps must be performed.

To change the COM object configuration:

  1. Change the default read-only status of the files in \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\SQL_Object to read/write. (Alternatively, copy the files to another working directory and make that copy writable; note that later you will have to re-register the COM object for this new location.)

  2. Using Visual Basic, open the project XLANG_SAMPLE_ASYNC_SQL.VBP.

  3. Open the module "globals" (the file globals.bas).

  4. Modify the variable DBHost to reference the desired instance of SQL Server.

  5. Make the project to rebuild XLANG_SAMPLE_ASYNC_SQL.DLL.

  6. If you have moved its location, remember to re-register the DLL using regsvr32.

To build the shared database on a computer other than "localhost":

  1. Change the default read-only status of the file \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\SETUP/SETUP_DB.CMD to read/write.

  2. Edit the file and change the two instances of "-S localhost" to the appropriate computer name.

  3. Save and run this modified setup script.

Security

Note that the virtual Web directory created for this sample uses Windows NT Authentication. A user accessing the sample Web page and possibly the service account for BizTalk (service BTSSvc) needs to have permission to the shared database. Generally the user of this sample is part of the "BizTalk Administrators" group and is the creator of the table, so there should be no problem running the sample.

Any other configuration or situation might require adjustments of security permissions in the SQL Server Enterprise Manager.


Running the Sample

To run the sample, you can run \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\RUN_SAMPLE.CMD.

Alternatively you can access http://localhost/sync_async_xlang/async.asp.

You can also complete the following steps:

  1. From a remote computer substitute the appropriate host name for "localhost."

  2. For "name of fruit", enter apples (note that this program is case-sensitive).

  3. For the amount enter any number (there are 50 "apples" in the warehouse).

  4. Click Submit.

The Web page will update with a blank table with a button labeled Check_Details on WorkItem #. At this point the ASP page has broken free of the XLANG schedule. Clicking the Check_Details� button repeatedly will update the blank table.

Approximately 30 seconds after submitting (for "apples"), the state column will change from "0 processing" to "1 Complete" and return information will appear in the strSKU and iAmountAvailable columns.

To contrast this with the normal synchronous interaction with XLANG, access the page:

http://localhost/sync_async_xlang/async.asp

This page (and its associated XLANG schedule) will not completely reload until the XLANG schedule returns information.


Programming Notes

This sample addresses the fact that some workflows in an XLANG schedule can take a long time to complete, especially when a schedule has to send a document or message to another organization and wait for returned information. BizTalk Server can handle the long delays, but a user waiting for an order to complete on a Web page might not.

This sample shows a technique to allow the user to submit information to an XLANG schedule and then quickly separate from the processing. The user can then asynchronously query the state of the processing.

For this sample, the business model is a simulated fruit warehouse. The user will request an inventory check for, say, "234 apples" and the warehouse will return a document with the available number of apples and the order code (SKU) for an actual purchase. To make the sample interesting, the processing takes a different amount of time depending upon what type of fruit is selected, as follows:

  • Bananas take 10 seconds to check inventory.

  • Apples take 30 seconds.

  • Oranges take 50 seconds.

  • Anything else is not in stock, and takes 0 seconds.

Note

  • To simulate the processing delay, the business code uses the Sleep function. This function should not be used in a production COM object because it will do things like prevent the long-running XLANG process from being dehydrated. It is used here to simplify the non-essential part of the sample code.

Technique Used

To allow the ASP page to work asynchronously with the XLANG schedule, the sample does the following:

  • The user fills out the form on the ASP page and clicks Submit.

  • The ASP page invokes the XLANG schedule.

  • Synchronously, the ASP page passes the request information to the schedule through a shared COM object.

  • The XLANG schedule registers for a row in a shared SQL table. The unique key for this row is used as a token for the working instance. The row now contains information in a "not ready" state.

  • The ASP page synchronously retrieves the token from the XLANG schedule (through the shared COM object) and is now free from the XLANG schedule.

  • The ASP page can now query the shared SQL table at any time to check for the change of state of the row.

  • The XLANG schedule does its processing. When complete, it updates the row in the shared table with returned data and changes the state to "completed."

  • Eventually, the ASP page query of the row will get the updated state and the returned information.

The following paragraphs provide information about the modules used in this example.

Inventory_OBJECT\XLANG_sample_fruit.dll

This is the simulated business process. Rather than complicating the sample with a complex workflow, this COM object simulates a long-running process.

Public Sub check_storeroom(ByVal str_in_type As String, _

ByVal i_in_amount_requested As Integer, _

ByRef str_out_SKU As String, _

ByRef i_out_amount_available)

This takes a fruit name (str_in_type) and a desired amount (i_in_amount) and eventually returns an order code (str_out_SKU) and amount available (i_out_amount_available).

Note

  • To simulate the processing delay, the business code uses the Sleep function. This function should not be used in a production COM object because it will do things like prevent the long-running XLANG process from being dehydrated. It is used here to simplify the non-essential part of the sample code.

ASP_OBJECT\XLANG_sample_ASP.dll

This is the linking COM object between the ASP page and the XLANG schedules. It is similar to the object used in the XLANG_Samples\ASP example.

It performs two tasks:

  • Provides the synchronization points between the ASP page and the XLANG schedules

  • Persists returned information from XLANG for the ASP to use

Note that this COM object is shared between the blocking.asp sample and the async.asp sample.

Persisted data for blocking.asp are the variables:

Dim stored_SKU As String

Dim stored_amount_available As Integer

Persisted data for async.asp is the variable

Dim stored_WorkID As Integer

This stub function is used by both blocking.asp and async.asp to pass information into their associated XLANG schedules:

Public Sub Request_fruit_amount(ByVal fruit_type As String, _

ByVal amount As Integer)

Note

  • The body of this method is never used. The XLANG schedule performs a "wait for synchronous call." This means that the XLANG schedule provides the body for the method and will wait until another program (the ASP page sharing the COM object) calls the method. The XLANG implementation then provides the arguments that are provided to the data page of the schedule.

For the blocking.asp sample, this method is used by blocking_sample.skv to store return data into the persisted data area:

Public Sub Store_fruit_response(ByVal SKU As String, _

ByVal amount_available As Integer)

For the blocking.asp sample, these methods are used by the ASP page to retrieve the persisted data:

Public Function Get_fruit_SKU() As String

Public Function Get_fruit_amount_available() As Integer

Notes

  • The XLANG schedule blocking_sample.skv performs a "wait for synchronous call" on these methods. This must be done for the sked object that calls these methods so that the VBScript code in the ASP page can access them.

  • In the schedule, the order in which the XLANG schedule waits for these methods must match exactly the order in which the ASP page will call them.

Compared to the blocking.asp sample, the mechanism in async.asp to communicate between the XLANG and ASP is simpler.

The ASP page still calls the Request_fruit_amount method but then uses this method to get a token for the row in the shared table:

Public Function Get_async_WorkID() As Integer

The XLANG schedule async_sample.skv gets the token and stores it through this method:

Public Sub Store_async_WorkID(ByVal iWorkID As Integer)

The XLANG schedule async_sample.skv then synchronizes with the ASP page with Get_async_WorkID

Note

  • The XLANG schedule async_sample.skv synchronizes with the ASP page at only two places. One is at the beginning of the schedule to get the input information and the other is to immediately pass the token information through Get_async_WorkID. The schedule then runs asynchronously from this point onward.

SQL_object\XLANG_SAMPLE_ASYNC_SQL.dll

This is the shared COM object between async.asp and async_sample.skv that handles working with the common SQL table:

Function Register_for_work_id(ByVal strFruitType, _

ByVal iRequestAmount) As String

This method is used by the XLANG schedule async_sample.skv to create a new row in the shared table. The method populates it with the input information and sets the state column (iState) to 0 (processing). The method returns a unique key for the row (WorkID). Any references to the row must use this unique key.

Public Function Update_work_entry(ByVal iWorkID As Integer, _

ByVal iState As Integer, _

ByVal strSKU As String, _

ByVal iAmountAvailable As Integer)

This method is used by the XLANG schedule async_sample.skv when the processing is complete to update the row with the returned information.

Public Function GetWorkItemXML(ByVal iWorkID As Integer) As String

This method is used by async.asp to populate a frame with the state of the row. The returned sting is SQL XML format (SQL table was accessed as "FOR XML AUTO")

Async.asp

This is the user page that invokes the XLANG schedule and then can query for returned information asynchronously.

Note

  • The following code invokes the XLANG schedule and exposes the interface methods used to synchronize with it:

sSkedUrl = "sked:///" & sPath & "async_sample.skx/ASP_async_Interface"

This references the schedule file. Note the addition of the COM interface that should be exposed.

set sked = GetObject(sSkedUrl)

This actually starts the XLANG schedule, which now waits for the first call to request_fruit_amount.

sked.request_fruit_amount sText, sAmount

iWorkID = sked.Get_async_WorkID()

These two lines pass information in and retrieve the token from the schedule (the only synchronous operation with the schedule).

The rest of the ASP page creates a button to invoke Work_item_details.asp to fill the frame at the bottom of the page.

Work_item_details.asp

This ASP page calls GetWorkItemXML to retrieve the state of the schedule's operations and formats the XML for rendering as a table.

The rendering is done by an XSLtransform in workitem_details.xsl.


XLANG Trace

This sample uses a COM object in the library XLANG_TRACE.dll to insert tracing operations into an XLANG schedule. This COM object helps trace and debug problems in an XLANG schedule by writing data from the running schedule into a logging table. Any data that is used in the schedule can be sent to the logging table, including the XML documents being passed between actions in the schedule.

Note

  1. This sample is intended only for debugging a specific XLANG schedule. In a production environment, the tracing COM object should not be used because it can significantly impact XLANG schedule processing performance.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE.

User's Guide

To prepare and run the sample, follow these steps:

  2. Preliminary Setup

  3. Modifying the Default Configuration

  4. Using the Tracing Component

  5. Viewing the Trace Results

Programming Notes

After the XLANG_TRACE COM object is registered on a computer running BizTalk Server, you can add one or more bindings to this object in your existing XLANG schedule files. After the object is bound to a schedule, you need to modify the data mapping in the schedule to specify the data being traced. The XLANG_TRACE object contains the following input parameters for recording schedule data:

message_label

String to describe the name of the Action shape.

message_ID

String to hold a unique identifier for this schedule, such as the instance GUID of the schedule.

message_UserKey

String to store a unique document identifier, such as a purchase order number.

message_body

String to store a large amount of data, such as an entire XML document in a message.


Preliminary Setup

Complete the steps outlined in this section to configure your computer to run the XLANG tracing sample.

Configuring the Tracing Database

The default settings of the XLANG tracing sample require a database for storing the tracing data. However, you can modify these settings to use Event Logging instead of, or in addition to, a database. If you do not want to use a database, proceed to the next section, Modifying the Default Configuration.

To use a database for the tracing data, run the command script setup_db.cmd that is located on the installation drive at \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE\setup. This command script file creates the following items:

  6. A database named XLANG_TRACE

  7. A table in this database named trace_table

  8. A stored procedure in this database named Log_text_message

Note

  9. If you choose to run this file on a remote computer, you must modify the DBHost value in the Globals.bas file, as described in Modifying the Default Configuration.

Registering the Tracing Component

To register the XLANG_TRACE.dll component, run the command script register_COM.cmd that is located on the installation drive at \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE\setup. The COM object XLANG_TRACE.dll must be registered on each computer that uses it.


Modifying the Default Configuration

The XLANG_TRACE sample can be configured to output tracing information into an SQL table or to the system Event Viewer. By default, the XLANG_TRACE COM object (XLANG_TRACE.dll) is configured to store the trace information in a SQL Server database on the local computer ("localhost"). This configuration assumes that both BizTalk Server and SQL Server are running on the local computer.

To change the settings of the tracing object, you must edit the global variable values in the file Globals.bas, and recompile the Microsoft Visual Basic project named XLANG_TRACE.vbp. The following global variables can be modified:

DBHost

String containing the host name of the computer running SQL Server where the tracing data will be stored. An empty string ("") is used to indicate that tracing data will not be stored to a database. The default value is "localhost".

EventLogging

Boolean that indicates whether tracing data should be logged in the system Event Viewer. A value of True indicates that tracing data is logged in the Event Viewer. The default value is False.

The other variables in the Globals.bas module contain information about the database (DBTraceDatabase) and table (DBTraceTable) names. It is not necessary to modify these values. If these values are changed, the file dumptable.xsl will also require modification.

After you have modified the global variables and saved the Visual Basic project, recompile the project into a new DLL file.

Notes

  10. If any changes are made to the COM object after its first use, you might need to stop and restart the XLANG Scheduler Engine to release the cached version of the COM object before the new version can be run. For information on stopping and restarting the XLANG Scheduler Engine, see the following topics in the BizTalk Server Help file:
    1. Shut down all XLANG applications

    2. Restart all XLANG applications
  11. If the dumptable.asp page is used to view the tracing data before changes are made to the tracing object, Internet Information Services (IIS) might also use a cached version of the original object. For more information, see Restarting BizTalk Server and Internet Information Services.

  12. When event logging is enabled, the events appear in the application log. The XLANG tracing entries will have a Type value of Information, and a Source value of VBRuntime.


Restarting Biztalk Server and Internet Information Services

If a BizTalk Server schedule or an ASP page references a COM object, it will be locked "in use" and cannot be replaced by a recompile. These services must be restarted to release the cached COM object and allow the COM object to be recompiled.

This procedure explains how to restart Internet Information Services (IIS).

  1. On the Start menu, point to Settings and click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Computer Management.

  4. In the Computer Management console tree, expand Services and Applications and then click Internet Information Services.

  5. On the Action menu, click Restart IIS.

    The Stop/Start/Reboot dialog box appears.

  6. Verify that Restart Internet Services on computer_name is selected.

  7. Click OK to restart IIS.

This procedure restarts the Biztalk Server service that will also hold onto a COM object.

  13. Still using Computer Management, click the Services node and click XLANG Schedule Restart Service near the bottom.

  14. On the Action menu, click Restart


Using the Tracing Component

After the tracing component has been configured and registered, you can add one or more references to it in any XLANG schedule. To add the tracing component to an XLANG schedule, complete the following steps:

  1. Open your XLANG schedule drawing (.skv) in BizTalk Orchestration Designer.

  2. Add a COM component implementation shape to the right side of the Business Process drawing.

  3. Complete the COM Component Binding Wizard and select the Logger class from XLANG_TRACE in the list of registered components.

  4. Add an Action shape to the left side of the Business Process drawing.

  5. Connect the process flow arrow from the bottom of the preceding shape into the top of the new Action shape.

  6. Connect the process flow arrow from the bottom of the new Action shape into the top of the following shape.

  7. Click the new Action shape to highlight it, and then drag the connection point on the right side of the Action shape to the connection point on the left side of the port that is associated with the XLANG_TRACE COM object.

  8. Complete the Method Communication Wizard.

  9. Re-map the data flow on the Data page. You can set the input values of the XLANG_TRACE LogStringMessage method by using other messages on the Data page or by using constants.

  10. Save and re-compile your XLANG schedule. It might be helpful to save the file as a separate tracing version by using a different name. For example, a new version of a file named myschedule.skv can be named myschedule_trace.skv.

  11. Run the new schedule and view the tracing information in the database or in Event Viewer, depending on your configuration.

For additional information about using BizTalk Orchestration Designer, see the BizTalk Server Help file.


Viewing the Trace Results

The tracing information that is stored in the database can be viewed directly through SQL Server. To view this data, follow these steps:

  1. On the Start menu, point to Programs, point to Microsoft SQL Server, and click Enterprise Manager.

  2. Expand the Microsoft SQL Servers tree, and expand the group and server name of the computer that is running the database for the XLANG tracing information.

  3. Expand the Databases folder, expand the XLANG_TRACE database, and then click Tables.

  4. Right-click the table named trace_table, and then point to Open Table and click Return all rows.

The tracing information that is stored in the database can also be accessed by using the file Dumptable.asp located in the folder \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE\ASP on the BizTalk Server installation drive.

Notes

  15. To use the ASP file, you must either map the ASP folder as a virtual directory in Internet Information Services (IIS), or place the contents of the ASP folder into an existing virtual directory.

  16. You might need to add the Internet user account (ISR_computername) to allow IIS access to the database.

Event Viewer logs can be accessed in the Computer Management console.


XML Translation

This sample demonstrates how to use the SubmitSync method of BizTalk Server to perform an XML transformation by using BizTalk Orchestration Services.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XML Translation

User's Guide

The sample consists of the following modules:

  • A Visual Basic ActiveX DLL contains the component called by the schedule to get the submission parameters.

  • The loopback.vbs script contains the code to run the schedule.

The setup script, setup.cmd, does the following:

  • Registers the ProcessDoc component

  • Creates message queues.

  • Creates BizTalk Configuration objects.

To remove the sample, run remove.cmd and delete the copied files from the directories.

To run the sample, run loopback.vbs. The script sends SamplePOData.xml to the received_in message queue and starts the loopback.skx schedule.

Programming Notes

This sample demonstrates the use of the SubmitSync call using BizTalk Orchestration Services to do the XML transformations. The schedule picks up the document from the received_in queue and then calls GetSubmitParams to get parameters for calling SubmitSync. When the SubmitSync call is returned, the transformed document is returned in the out parameter, which is displayed and then sent to the biztalk_out message queue.


BizTalk Server Reference

This section contains the following topics:

  • Messaging Services Reference

  • Documents Reference

  • Custom Components Reference

  • Orchestration Services Reference

  • Managing and Monitoring Reference

  • Error Messages


Messaging Services Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for accessing messaging services:

  • Interfaces

  • Enumerations

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented:

  • IBizTalkBase

  • IBizTalkCertificateInfo

  • IBizTalkChannel

  • IBizTalkConfig

  • IBizTalkDocument

  • IBizTalkEndPoint

  • IBizTalkEnvelope

  • IBizTalkLoggingInfo

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

  • IBizTalkServiceWindowInfo

  • IBizTalkTransportInfo

  • IDictionary

  • ISimpleList


IBizTalkBase

Defines common methods and properties inherited by several messaging services objects.

Hierarchy

IDispatch

|--IBizTalkBase

Declaration

[Visual Basic]

Class IBizTalkBase

[C++]

interface IBizTalkBase : IDispatch

Members

IBizTalkBase defines the following properties:

Property | Description
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
Name | Contains the name of the object.

IBizTalkBase defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Remarks

The following interfaces inherit properties and methods from IBizTalkBase:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Note

  • The methods and properties of IBizTalkBase are always invoked on the objects listed above, rather than by creating an actual IBizTalkBase object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Clear Method

Clears the object from memory.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Clear( )

[C++]

HRESULT Clear( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

After Clear is called, all member variables of the object in memory are initialized to their default values.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Create Method

Creates a new object in the database.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Function Create( ) As Long

[C++]

HRESULT Create(

long* BiztalkObjectHandle

);

Parameters

BiztalkObjectHandle

[out, retval] In C++, contains a handle to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a handle to the object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The Name property must be set before calling this method. Name must be unique across the database for each object type. Create updates the DateModified property.

When creating any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


DateModified Property

Contains the date and time at which the information in the object was created or last modified.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Property Declaration

[Visual Basic]

Property DateModified As String

[C++]

HRESULT get_DateModified(

BSTR* Modified

);

Parameters

Modified

[out, retval] In C++, contains the date modified. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the date modified.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The format for the Modified string is yyyy-mm-dd hh:mm:ss. The time is in coordinated universal time (UTC). The server sets this property when the Create or the Save method is called for the object.

The following objects support this property:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Handle Property

Contains the handle to the object.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Property Declaration

[Visual Basic]

Property Handle( ) As Long

[C++]

HRESULT get_Handle(

long* BiztalkObjectHandle

);

Parameters

BiztalkObjectHandle

[out, retval] In C++, contains the handle to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property contains the handle to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The following objects support this property:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Load Method

Loads a specified object in memory.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Load( _

BiztalkObjectHandle As Long _

)

[C++]

HRESULT Load(

long BiztalkObjectHandle

);

Parameters

BiztalkObjectHandle

[in] Contains the handle to the object to load.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Load calls the Clear method internally before loading the object.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


LoadByName Method

Loads a specified object by name in memory.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub LoadByName( _

Name As String_

)

[C++]

HRESULT LoadByName(

BSTR Name

);

Parameters

Name

[in] Contains the name of the object to load.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

LoadByName calls the Clear method internally before loading the object.

Names have a maximum length of 64 characters.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Name Property

Contains the name of the object.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--LoadLat_SDK_BTCOM_Base_GQNF

|--LoadByName

|--Name

|--Remove

|--Save

Property Declaration

[Visual Basic]

Property Name( ) As String

[C++]

HRESULT get_Name(

BSTR* Name

);

HRESULT put_Name(

BSTR Name

);

Parameters

Name

[out, retval], [in] In C++, contains the name of the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The server requires the Name property. It must be set before calling the Create or the Save method for the object. Name must be unique across a database for each object type and must be at least one character long. Names have a maximum length of 64 characters.

The following table lists names reserved for use by BizTalk Server:

Name | Object type
Reliable Message Acknowledgement Port | IBizTalkPort
Reliable Message Acknowledgement Channel | IBizTalkChannel
BizTalk Canonical Receipt | IBizTalkDocument
Reliable Messaging Acknowledgement | IBizTalkDocument
Reliable Messaging Acknowledgement SMTP From Address | IBizTalkOrganization
Home Organization | IBizTalkOrganization

The following objects support this property:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Remove Method

Removes the object from the database.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Remove( )

[C++]

HRESULT Remove( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The object cannot be removed if any other object refers to it.

A BizTalkOrganization object cannot be removed if it is the default organization. Before it can be removed, the IsDefault property must be set to False, and another organization must have the IsDefault property set to True.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Referential Integrity


Save Method

Saves the object in the database.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Save( )

[C++]

HRESULT Save( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The Save method updates the DateModified property.

When saving any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo

Configures a certificate associated with an IBizTalkPort or IBizTalkChannel object.

Hierarchy

IDispatch

|--IBizTalkCertificateInfo

Declaration

[Visual Basic]

Class BizTalkCertificateInfo

[C++]

interface IBizTalkCertificateInfo : IDispatch

Members

IBizTalkCertificateInfo defines the following properties:

Property | Description
Name | Contains the name of the certificate.
Reference | Contains a reference to the certificate in the certificate store.
Store | Contains the store type for the certificate.
Usage | Contains the type of use for the certificate.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Certificates


Name Property

Contains the name of the certificate.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Name As String

[C++]

HRESULT get_Name(

BSTR* Name

);

Parameters

Name

[out, retval] In C++, contains the name of the certificate. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the certificate.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Reference Property

Contains a reference to the certificate in the certificate store.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Reference As String

[C++]

HRESULT get_Reference(

BSTR* Reference

);

HRESULT put_Reference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the certificate reference. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate reference.

In C++, this property returns an HRESULT value, indicating success or failure.

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, the put method returns CryptoAPI errors. Additional information about CryptoAPI is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). A reference to a certificate should be obtained by using the Certificates property on the IBizTalkConfig object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Store Property

Contains the store type for the certificate.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Store As BIZTALK_STORE_TYPE

[C++]

HRESULT get_Store(

BIZTALK_STORE_TYPE* StoreType

);

HRESULT put_Store(

BIZTALK_STORE_TYPE StoreType

);

Parameters

StoreType

[out, retval], [in] In C++, contains the store type for the certificate. Valid values for this parameter are defined by the BIZTALK_STORE_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_STORE_TYPE enumeration.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The store, which contains the certificate, is determined by the use of the certificate as follows:

Certificate type | Store
Decryption | MY
Encryption | BIZTALK
Signature | MY
Verify signature | BIZTALK

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Usage Property

Contains the type of use for the certificate.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Usage As BIZTALK_USAGE_TYPE

[C++]

HRESULT get_Usage(

BIZTALK_USAGE_TYPE* UsageType

);

Parameters

UsageType

[out, retval] In C++, contains the usage type for the certificate. Valid values for this parameter are defined by the BIZTALK_USAGE_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_USAGE_TYPE enumeration.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel

Configures a channel for processing documents.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkChannel

Declaration

[Visual Basic]

Class BizTalkChannel

[C++]

interface IBizTalkChannel : IBizTalkBase

Members

IBizTalkChannel defines the following properties:

Property | Description
Comments | Contains user comments for the object.
ControlNumberValue | Contains the value of the group control number.
DateModified | Contains the date and time at which the information in the object was created or last modified.
DecryptionCertificateInfo | Contains information about the certificate that decrypts the input document.
ExpectReceiptTimeout | Contains the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.
Expression | Contains a complete set of equations that filter the selection of the object.
Handle | Contains the identifier of the object.
InputDocument | Contains the handle to the input IBizTalkDocument object that describes the input document specification.
IsReceiptChannel | Contains the flag that indicates whether the object is a receipt channel.
LoggingInfo | Contains information about logging the document.
MapContent | Contains the contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.
MapReference | Contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.
Name | Contains the name of the object.
OutputDocument | Contains the handle to the output IBizTalkDocument object that describes the output document specification.
Port | Contains the handle to the associated IBizTalkPort object.
PortGroup | Contains the handle to the associated IBizTalkPortGroup object.
ReceiptChannel | Contains the handle to the receipt channel for this object.
RetryCount | Contains the number of times to retry submitting a document when a destination connection failure occurs.
RetryInterval | Contains the amount of time, in minutes, between retry attempts when a destination connection failure occurs during document submission.
SignatureCertificateInfo | Contains information about the certificate that signs the output document.
SourceEndpoint | Contains information about the source.
TrackFields | Contains the IDictionary object that points to the specification that contains fields to track interchange data on input documents for this IBizTalkChannel object.
VerifySignatureCertificateInfo | Contains information about the certificate that verifies the signature of the input document.

IBizTalkChannel defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
GetConfigComponent | Retrieves the CLSID of the component associated with the IBizTalkPort object.
GetConfigData | Retrieves the configuration associated with the specified IBizTalkPort object.
Load | Loads an object in memory.
LoadByName | Loads an object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.
SetConfigComponent | Sets the CLSID of the component associated with the IBizTalkPort object.
SetConfigData | Sets the configuration information for the associated IBizTalkPort object.

Remarks

An IBizTalkChannel object requires an associated complete IBizTalkPort object. One or more IBizTalkChannel objects can be associated with an IBizTalkPort object. An IBizTalkChannel object can be associated with only one input IBizTalkDocument object and one output IBizTalkDocument object; however, an IBizTalkDocument object can be associated with more than one IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Channels

Document Processing


Comments Property

Contains the user comments for the object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property Comments As String

[C++]

HRESULT get_Comments(

BSTR* Comments

);

HRESULT put_Comments(

BSTR Comments

);

Parameters

Comments

[out, retval], [in] In C++, contains the user comments for the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the user comments for the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ControlNumberValue Property

Contains the value of the group control number.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property ControlNumberValue As String

[C++]

HRESULT get_ControlNumberValue(

BSTR* strControlNumberValue

);

HRESULT put_ControlNumberValue(

BSTR strControlNumberValue

);

Parameters

strControlNumberValue

[out, retval], [in] In C++, contains the value of the group control number. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the value of the group control number.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The ControlNumberValue property must contain a value between 1 and 999999999.

If the Format property of the IBizTalkEnvelope object for the associated IBizTalkPort object is set to X12, EDIFACT, or Custom, this property is required.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


DecryptionCertificateInfo Property

Contains information about the certificate that decrypts the input document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property DecryptionCertificateInfo As Object

[C++]

HRESULT get_DecryptionCertificateInfo(

IDispatch** DecryptionCertificateInfoDisp

);

HRESULT putref_DecryptionCertificateInfo(

IDispatch* DecryptionCertificateInfoDisp

);

Parameters

DecryptionCertificateInfoDisp

[out, retval], [in] In C++, contains the information about the certificate that decrypts the input document. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the information about the certificate that decrypts the input document.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the IBizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ExpectReceiptTimeout Property

Contains the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property ExpectReceiptTimeout As Long

[C++]

HRESULT get_ExpectReceiptTimeout(

long* Minutes

);

HRESULT put_ExpectReceiptTimeout(

long Minutes

);

Parameters

Minutes

[out, retval], [in] In C++, contains the time, in minutes, in which to expect the receipt for the current document before treating the document as expired. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of 0.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Expression Property

Contains a complete set of equations that filter the selection of the object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property Expression As String

[C++]

HRESULT get_Expression(

BSTR* Expression

);

HRESULT put_Expression(

BSTR Expression

);

Parameters

Expression

[out, retval], [in] In C++, contains a complete set of equations that filter the selection of the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a complete set of equations that filter the selection of the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). If the expression evaluates to true, the server selects the channel for processing the document.

The XPath expression must be based on the input document specification set in the InputDocument property.

Note

  • If the specification field that you are using to create an expression has a Boolean data type, you cannot use the text strings "true" or "false" as the expression value. You must use a numerical value instead: "-1" for true and "0" for false. For example, to filter a channel so it processes only approved purchase orders, your expression might look like this:

Channel1.Expression = "/PORequest/Total[IsApproved = -1]"

This sample assumes that the input document specification contains a Total subelement with a Boolean IsApproved field.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Channel Filtering


GetConfigComponent Method

Retrieves the CLSID of the component associated with the IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Function GetConfigComponent( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

PortHandle As Long _

) As String

[C++]

HRESULT GetConfigComponent(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long PortHandle,

BSTR* CLSID

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

PortHandle

[in] Contains the handle to the IBizTalkPort object.

CLSID

[out, retval] In C++, contains the CLSID of the component associated with the IBizTalkPort object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the CLSID of the component associated with the IBizTalkPort object.

In C++, this method returns an HRESULT value, indicating success or failure.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If the ConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated IBizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


GetConfigData Method

Retrieves the configuration associated with the specified IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Function GetConfigData( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

PortHandle As Long, _

Type As Variant _

)

[C++]

HRESULT GetConfigData(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long PortHandle,

VARIANT* Type,

VARIANT* Dictionary

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

PortHandle

[in] Identifies the handle to the associated IBizTalkPort object.

Type

[in, out] Contains the transport type.

Dictionary

[in, out] In C++, contains the IDictionary interface of an object that contains the primary transport configuration information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an IDictionary object that contains the primary transport configuration information.

In C++, this method returns an HRESULT value, indicating success or failure.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When reading serializer data, the IDictionary object returned by this method has specific string qualifiers used for EDIFACT and X12. The following tables describe these strings.

EDIFACT

Qualifier string | Description
SerializerEdifact_SenderIntID | Interchange sender internal identification
SerializerEdifact_SenderIntSubID | Interchange sender internal subidentification
SerializerEdifact_RecipientIntID | Interchange recipient internal identification
SerializerEdifact_RecipientIntSubID | Interchange recipient internal subidentification
SerializerEdifact_RecipientRefPwd | Recipient reference/password
SerializerEdifact_RecipientRefPwdQual | Recipient reference/password qualifier
SerializerEdifact_ApplicationRef | Application reference
SerializerEdifact_ProcPriCode | Processing priority code
SerializerEdifact_AckRequest | Acknowledgment request
SerializerEdifact_AgreementID | Interchange agreement identifier
SerializerEdifact_TestInd | Test indicator
SerializerEdifact_UNACtrl | "Send UNA Always" or "Send UNA Only When Required"
SerializerEdifact_SyntaxID | Syntax identifier

X12

Qualifier string | Description
SerializerX12_AuthInfoQual | Authorization information qualifier
SerializerX12_AuthInfo | Authorization information
SerializerX12_SecInfoQual | Security information qualifier
SerializerX12_SecInfo | Security information
SerializerX12_CtrlStdID | Interchange control standards identifier
SerializerX12_CtrlVerNum | Interchange control version number
SerializerX12_AckRequired | Acknowledgment required
SerializerX12_UseInd | Usage indicator

Note

  • For more information about the EDIFACT standard, see the United Nations Economic Commission for Europe Web site (www.unece.org).

  • For more information about the X12 standard, see the Data Interchange Standards Association Web site (www.disa.org).

If you override the transport properties of an IBizTalkPort object with this method and then change the transport properties in that IBizTalkPort object, you must call this method again.

If the ConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated IBizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty IDictionary object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


InputDocument Property

Contains the handle to the input IBizTalkDocument object that describes the input document specification.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property InputDocument As Long

[C++]

HRESULT get_InputDocument(

long* InDocHandle

);

HRESULT put_InputDocument(

long InDocHandle

);

Parameters

InDocHandle

[out, retval], [in] In C++, contains the handle of the input IBizTalkDocument object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle of the input IBizTalkDocument object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property.

This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Configuring

Document Definitions

Document Processing


IsReceiptChannel Property

Contains a flag that indicates whether the object is a receipt channel.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property IsReceiptChannel As Boolean

[C++]

HRESULT get_IsReceiptChannel(

VARIANT_BOOL* IsReceiptChannel

);

HRESULT put_IsReceiptChannel(

VARIANT_BOOL IsReceiptChannel

);

Parameters

IsReceiptChannel

[out, retval], [in] In C++, contains a value indicating whether or not the channel is a receipt channel. VARIANT_TRUE indicates that this channel is a receipt channel; VARIANT_FALSE indicates that this channel is not a receipt channel. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value indicating whether or not the channel is a receipt channel. True indicates that this channel is a receipt channel; False indicates that this channel is not a receipt channel.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

ReceiptChannel


LoggingInfo Property

Contains information about logging the document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property LoggingInfo As Object

[C++]

HRESULT get_LoggingInfo(

IDispatch** LoggingInfoDisp

);

HRESULT putref_LoggingInfo(

IDispatch* LoggingInfoDisp

);

Parameters

LoggingInfoDisp

[out, retval], [in] In C++, contains the logging fields. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the logging fields.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Information contained by this property includes the LogNativeInputDocument, LogNativeOutputDocument, LogXMLInputDocument, and LogXMLOutputDocument properties and is created and stored in memory in the IBizTalkLoggingInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


MapContent Property

Contains the contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property MapContent As String

[C++]

HRESULT get_MapContent(

BSTR* MapContent

);

onkeypress="expand(expand3, img3)" onclick="expand(expand3, img3)"> Parameters

MapContent

[in] In C++, contains the map contents. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the map contents.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). This is a read-only property. The Create and Save methods copy the text of the map specified by the MapReference property to this string, if empty.

Once you have created or saved a IBizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring IBizTalkChannel object. To update the IBizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the IBizTalkChannel object to its current value, and then call Save on the referring IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


MapReference Property

Contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property MapReference As String

[C++]

HRESULT get_MapReference(

BSTR* Reference

);

HRESULT put_MapReference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the map name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the map name.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). This is a required property if the InputDocument property refers to a different document specification than the OutputDocument property.

Once you have created or saved a IBizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring IBizTalkChannel object. To update the IBizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the IBizTalkChannel object to its current value, and then call Save on the referring IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


OutputDocument Property

Contains the handle to the IBizTalkDocument object that describes the output document specification.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property OutputDocument As Long

[C++]

HRESULT get_OutputDocument(

long* OutDocHandle

);

HRESULT put_OutputDocument(

long OutDocHandle

);

Parameters

OutDocHandle

[out, retval], [in] In C++, contains the handle to the output IBizTalkDocument object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the output IBizTalkDocument object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property. This property cannot be changed after the Create or the Save method is called.

If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_SOURCE, the InputDocument property can identify an input IBizTalkDocument object that has an X12 or an EDIFACT specification. If it does, however, OutputDocument must not identify an IBizTalkDocument object that has an X12 or an EDIFACT specification.

If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the OutputDocument property for this IBizTalkChannel object must not identify an output IBizTalkDocument object that has an X12 or an EDIFACT specification.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions


Port Property

Contains the handle to the associated IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property Port As Long

[C++]

HRESULT get_Port(

long* PortHandle

);

HRESULT put_Port(

long PortHandle

);

Parameters

PortHandle

[out, retval], [in] In C++, contains the handle to the IBizTalkPort object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the IBizTalkPort object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The following constraints are enforced:

  • Either the Port or the PortGroup property must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Messaging Ports


PortGroup Property

Contains the handle to the associated IBizTalkPortGroup object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property PortGroup As Long

[C++]

HRESULT get_PortGroup(

long* PortGroupHandle

);

HRESULT put_PortGroup(

long PortGroupHandle

);

Parameters

PortGroupHandle

[out, retval], [in] In C++, contains the handle to the associated IBizTalkPortGroup object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the associated IBizTalkPortGroup object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The following constraints are enforced:

  • Either the Port property or PortGroup must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Port Groups


ReceiptChannel Property

Contains the handle to the receipt channel for this object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property ReceiptChannel As Long

[C++]

HRESULT get_ReceiptChannel(

long* ReceiptChannelHandle

);

HRESULT put_ReceiptChannel(

long ReceiptChannelHandle

);

Parameters

ReceiptChannelHandle

[out, retval], [in] In C++, contains the handle to the receipt channel. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the receipt channel.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. An IBizTalkChannel object can specify a receipt channel only if it is not a receipt channel itself. The channel specified as the receipt channel must have the IsReceiptChannel property set to TRUE. In addition, the receipt channel must use a messaging port with a DestinationEndpoint that is the same as the SourceEndpoint on the channel using the receipt channel. This allows the receipt channel to send a receipt to the original source of the document.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RetryCount Property

Contains the number of times to retry submitting a document when a destination connection failure occurs.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property RetryCount As Long

[C++]

HRESULT get_RetryCount(

long* Count

);

HRESULT put_RetryCount(

long Count

);

Parameters

Count

[out, retval], [in] In C++, contains the number of retries. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of retries.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The RetryCount property must contain a value between 0 and 999. The default value is 3 retries.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RetryInterval Property

Contains the amount of time, in minutes, between retry attempts when a destination connection failure occurs during document submission.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property RetryInterval As Long

[C++]

HRESULT get_RetryInterval(

long* Interval

);

HRESULT put_RetryInterval(

long Interval

);

Parameters

Interval

[out, retval], [in] In C++, contains the retry interval, in minutes. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the retry interval, in minutes.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The RetryInterval property must contain a value between 1 and 63999. The default value is 5 minutes.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SetConfigComponent Method

Sets the CLSID of the component associated with the IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Sub SetConfigComponent( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

PortHandle As Long, _

CLSID As String _

)

[C++]

HRESULT SetConfigComponent(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long PortHandle,

BSTR CLSID

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

PortHandle

[in] Contains the handle.

CLSID

[in] Contains the CLSID of the component.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SetConfigData Method

Sets the configuration information for the associated IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Sub SetConfigData( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

ConfigDataHandle As Long, _

ConfigDataDisp As Object _

)

[C++]

HRESULT SetConfigData(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long ConfigDataHandle,

IDispatch* ConfigDataDisp

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

ConfigDataHandle

[in] Identifies the handle to the associated IBizTalkPort object.

ConfigDataDisp

[in] IDictionary object that contains information about the component specified in the ConfigType parameter.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The IDictionary object passed to this method has specific string qualifiers used for EDIFACT and X12. For a description of these qualifiers, see the GetConfigData Method.

When using the BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT or BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT enumeration value, the content of the transport dictionary varies according to the transport protocol used. The following tables list the transport dictionary fields for each protocol.

HTTP and HTTPS

Field name | Data type | Required | Description
URL | String | Yes | URL of the document destination.
ContentType | String | No | Value for the Content-Type HTTP/HTTPS property that appears in HTTP headers during transmission. The default value is an empty string ("").
ClientCert | String | No | Reference to the certificate used with SSL connections using HTTPS. The default value is an empty string ("").
ProxyName | String | No | URL of the proxy server used when sending documents outside a firewall.
ProxyPort | Integer | No | Port number used by the proxy server.
UseProxy | Boolean | No | Value that indicates whether the proxy server is used. The default value is True.

Local File

Field name | Data type | Required | Description
Filename | String | Yes | Name and path of the file to be created.
CopyMode | Integer | No | Value that indicates how the file should be written. Use a value of 0 for overwrite mode, a value of 1 for append mode, and a value of 2 to create a new file. The default value is append mode (1).
UserName | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").
Password | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").

Message Queuing

Field name | Data type | Required | Description
QueueName | String | Yes | Name of the Messaging Queue to which the document is sent.
MessageLabel | String | Yes | Value specified in the message label field on the queue.
Priority | Integer | No | Priority of the message placed in the queue. This must be a value between 0 and 7, where a higher value indicates a higher priority. The default value is 3
AuthLevel | Integer | No | Value indicating whether the message needs to be authenticated using a digital signature. Use a value of 0 to bypass authentication. A value of 1 indicates that authentication will be used. The default value is 0.
Delivery | Integer | No | Value indicating how a message is delivered to a queue. Use a value of 1 to indicate that the message should be backed up until it is delivered to the queue. A value of 0 indicates that the message is only resident in memory. The default value is 0.

Notes

  • When you override messaging port properties in a channel, the overrides apply only to that channel. No errors are generated as a result of overriding previous values.

  • You cannot override the transport address that was set in a messaging port.

  • The default setting for the HTTP transport component is to use the HTTP proxy server. This is the correct setting to transport data to Web sites outside your business's firewall. To transport data to Web sites that are inside your business's firewall (that is, within your intranet), modify the transport dictionary values to override the default setting.

  • For the HTTPS transport component, use only certificates that are specified for client authentication.

  • The default setting for the file transport component is to append files (CopyMode=1). If you choose the file transport type with its default settings in a messaging port and use antivirus software on the server on which BizTalk Server 2002 is installed, and you send multiple files that have exactly the same name to the same file location, at the same time, BizTalk Server 2002 might stop responding and must be restarted. You can eliminate this problem by changing the default setting for the file transport component to overwrite (CopyMode=0). You also can eliminate this problem by creating a unique file for each document instance processed by using %tracking_id% in the Address property of the IBizTalkTransportInfo object.

To access the properties in a custom component dictionary through BizTalk Messaging Manager, you must create ASP pages in the \Program Files\BizTalk Server\MessagingManager\pipeline folder. These ASP pages provide a dialog box for editing the properties of your custom component. This dialog box is displayed from the channel Advanced Configuration page when you click Advanced and then click Properties on the Primary Transport tab. For additional information about the ASP pages, see Working with Serializers. For a sample that uses SetConfigData with custom property pages, see Synchronous Orchestration Component.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SignatureCertificateInfo Property

Contains information about the certificate that signs the output document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property SignatureCertificateInfo As Object

[C++]

HRESULT get_SignatureCertificateInfo(

IDispatch** SignatureCertificateInfoDisp

);

HRESULT putref_SignatureCertificateInfo(

IDispatch* SignatureCertificateInfoDisp

);

Parameters

SignatureCertificateInfoDisp

[out, retval], [in] In C++, contains the certificate information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SourceEndpoint Property

Contains information about the source.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property SourceEndpoint As Object

[C++]

HRESULT get_SourceEndpoint(

IDispatch** SrcEndpointDisp

);

HRESULT putref_SourceEndpoint(

IDispatch* SrcEndpointDisp

);

Parameters

SrcEndpointDisp

[out, retval], [in] In C++, contains information about the source. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns information about the source.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Alias, Application, and Organization properties and is created and stored in memory in the IBizTalkEndPoint object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


TrackFields Property

Contains the IDictionary object that points to the specification that contains fields to track interchange data on input documents for this BizTalkChannel object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property TrackFields As Object

[C++]

HRESULT get_TrackFields(

IDispatch** TrackFieldsDisp

);

HRESULT putref_TrackFields(

IDispatch* TrackFieldsDisp

);

Parameters

TrackFieldsDisp

[out, retval], [in] In C++, contains the custom tracking fields. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the custom tracking fields.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The tracking fields specified by this property override the fields set in the TrackFields property on the IBizTalkDocument object.

The fields in the IDictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the IDictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the IDictionary object, and set the value to an ISimpleList object. The ISimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the IDictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Tracking


VerifySignatureCertificateInfo Property

Contains information about the certificate that verifies the signature of the input document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property VerifySignatureCertificateInfo As Object

[C++]

HRESULT get_VerifySignatureCertificateInfo(

IDispatch** VerifySignatureCertificateInfoDisp

);

HRESULT putref_VerifySignatureCertificateInfo(

IDispatch* VerifySignatureCertificateInfoDisp

);

Parameters

VerifySignatureCertificateInfoDisp

[out, retval], [in] In C++, contains the certificate information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the IBizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig

Creates channels, document specifications, envelopes, organizations, ports, and port groups.

Hierarchy

IDispatch

|--IBizTalkConfig

Declaration

[Visual Basic]

Class BizTalkConfig

[C++]

interface IBizTalkConfig : IDispatch

Members

IBizTalkConfig defines the following properties:

Property | Description
Certificates | Contains an ADO recordset that contains all specified certificates.
Channels | Contains an ADO recordset that contains all IBizTalkChannel objects.
Documents | Contains an ADO recordset that contains all IBizTalkDocument objects.
Envelopes | Contains an ADO recordset that contains all IBizTalkEnvelope objects.
Organizations | Contains an ADO recordset that contains all IBizTalkOrganization objects.
PortGroups | Contains an ADO recordset that contains all IBizTalkPortGroup objects.
Ports | Contains an ADO recordset that contains all IBizTalkPort objects.

IBizTalkConfig defines the following methods:

Method | Description
CreateChannel | Returns a new IBizTalkChannel object.
CreateDocument | Returns a new IBizTalkDocument object.
CreateEnvelope | Returns a new IBizTalkEnvelope object.
CreateOrganization | Returns a new IBizTalkOrganization object.
CreatePort | Returns a new IBizTalkPort object.
CreatePortGroup | Returns a new IBizTalkPortGroup object.

Remarks

Each object created by using one of the methods of this interface inherits the following common methods from IBizTalkBase:

  • DateModified

  • Handle

  • Name

  • Clear

  • Create

  • Load

  • LoadByName

  • Remove

  • Save

When IBizTalkPort and IBizTalkChannel objects are created, BizTalk Server automatically creates some associated subobjects. You can access these subobjects by using properties of the IBizTalkPort and IBizTalkChannel objects.

The relationship between objects, their subobjects, and the properties used to obtain the subobjects is shown in the following table.

Subobject | Associated object | Property to set
BizTalkEndPoint | BizTalkPort | DestinationEndpoint
BizTalkEndPoint | BizTalkChannel | SourceEndpoint
BizTalkLoggingInfo | BizTalkChannel | LoggingInfo
BizTalkTransportInfo | BizTalkPort | PrimaryTransport, SecondaryTransport
BizTalkServiceWindowInfo | BizTalkPort | ServiceWindowInfo
BizTalkCertificateInfo | BizTalkPort | EncryptionCertificateInfo
BizTalkCertificateInfo | BizTalkChannel | SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Certificates Property

Contains an ADO recordset that contains all specified certificates.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Certificates( _

StoreType As BIZTALK_STORE_TYPE, _

UsageType As BIZTALK_USAGE_TYPE, _

NamePrefix As String _

) As Object

[C++]

HRESULT get_Certificates(

BIZTALK_STORE_TYPE StoreType,

BIZTALK_USAGE_TYPE UsageType,

BSTR NamePrefix,

IDispatch** CertsDisp

);

Parameters

StoreType

[in] Determines the store type. Valid values for this parameter are defined by the BIZTALK_STORE_TYPE enumeration.

UsageType

[in] Determines the usage type. Valid values for this parameter are defined by the BIZTALK_USAGE_TYPE enumeration.

NamePrefix

[in] Contains a prefix used as the selection criteria for certificate names. Any certificate Name starting with this value is returned in the recordset. This value is case sensitive.

CertsDisp

[out, retval] Contains all specified certificates. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all specified certificates.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkCertificateInfo object in the database. The fields in each record contain the following information:

Field content | Item number
Name | 0
Reference | 1
Store | 2
Usage | 3

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Channels Property

Contains an ADO recordset that contains all IBizTalkChannel objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Channels As Object

[C++]

HRESULT get_Channels(

IDispatch** ChannelsDisp

);

Parameters

ChannelsDisp

[out, retval] Contains all IBizTalkChannel objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkChannel objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkChannel object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


CreateChannel Method

Returns a new IBizTalkChannel object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateChannel( ) As Object

[C++]

HRESULT CreateChannel(

IDispatch** ChannelDisp

);

Parameters

ChannelDisp

[out, retval] Contains a new IBizTalkChannel object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkChannel object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateDocument Method

Returns a new IBizTalkDocument object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateDocument( ) As Object

[C++]

HRESULT CreateDocument(

IDispatch** DocumentDisp

);

Parameters

DocumentDisp

[out, retval] Contains a new IBizTalkDocument object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkDocument object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateEnvelope Method

Returns a new IBizTalkEnvelope object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateEnvelope( ) As Object

[C++]

HRESULT CreateEnvelope(

IDispatch** EnvelopeDisp

);

Parameters

EnvelopeDisp

[out, retval] Contains a new IBizTalkEnvelope object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkEnvelope object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateOrganization Method

Returns a new IBizTalkOrganization object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateOrganization( ) As Object

[C++]

HRESULT CreateOrganization(

IDispatch** OrganizationDisp

);

Parameters

OrganizationDisp

[out, retval] Contains a new IBizTalkOrganization object. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkOrganization object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreatePort Method

Returns a new IBizTalkPort object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreatePort( ) As Object

[C++]

HRESULT CreatePort(

IDispatch** PortDisp

);

Parameters

PortDisp

[out, retval] Contains a new IBizTalkPort object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkPort object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreatePortGroup Method

Returns a new IBizTalkPortGroup object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreatePortGroup( ) As Object

[C++]

HRESULT CreatePortGroup(

IDispatch** PortGroupDisp

);

Parameters

PortGroupDisp

[out, retval] Contains a new IBizTalkPortGroup object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkPortGroup object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Documents Property

Contains an ADO recordset that contains all IBizTalkDocument objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Documents( ) As Objects

[C++]

HRESULT get_Documents(

IDispatch** DocumentsDisp

);

Parameters

DocumentsDisp

[out, retval] Contains all BizTalkDocument objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all BizTalkDocument objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkDocument object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Envelopes Property

Contains an ADO recordset that contains all IBizTalkEnvelope objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Envelopes( ) As Objects

[C++]

HRESULT get_Envelopes(

IDispatch** EnvelopesDisp

);

Parameters

EnvelopesDisp

[out, retval] Contains all IBizTalkEnvelope objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkEnvelope objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkEnvelope object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2
Format | 3

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Organizations Property

Contains an ADO recordset that contains all IBizTalkOrganization objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Organizations( ) As Objects

[C++]

HRESULT get_Organizations(

IDispatch** OrganizationsDisp

);

Parameters

OrganizationsDisp

[out, retval] Contains all IBizTalkOrganization objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkOrganization objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkOrganization object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2
IsDefault | 3

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


PortGroups Property

Contains an ADO recordset that contains all IBizTalkPortGroup objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property PortGroups( ) As Objects

[C++]

HRESULT get_PortGroups(

IDispatch** PortGroupsDisp

);

Parameters

PortGroupsDisp

[out, retval] Contains all IBizTalkPortGroup objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkPortGroup objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkPortGroup object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Ports Property

Contains an ADO recordset that contains all IBizTalkPort objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Ports( ) As Objects

[C++]

HRESULT get_Ports(

IDispatch** PortsDisp

);

Parameters

PortsDisp

[out, retval] Contains all IBizTalkPort objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkPort objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkPort object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


IBizTalkDocument

Identifies and describes the document specification of a document.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkDocument

Declaration

[Visual Basic]

Class BizTalkDocument

[C++]

interface IBizTalkDocument : IBizTalkBase

Members

IBizTalkDocument defines the following properties:

Property | Description
Content | Contains the content of the document specification described by the object.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
NameSpace | Contains the string that resolves naming conflicts between elements in a document.
PropertySet | Contains an IDictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input.
Reference | Contains the full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by this IBizTalkDocument object.
TrackFields | Contains an IDictionary object that stores the custom fields that Tracking uses to track all documents processed by the server, based on this document instance.
Type | Contains the type of document specification.
Version | Contains the version of the document standard.

IBizTalkDocument defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
LoadByPropertySet | Loads the document object by its PropertySet object.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Remarks

Each IBizTalkDocument object must have at least one associated IBizTalkChannel object. More than one IBizTalkDocument object can refer to the same document specification.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions


Content Property

Contains the content of the document specification described by the object.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Content As String

[C++]

HRESULT get_Content(

BSTR* Content

);

Parameters

Content

[out, retval] In C++, contains the content. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the content.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with a default value of an empty string ("").

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


LoadByPropertySet Method

Loads the document object by its PropertySet object.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Method Declaration

[Visual Basic]

Property LoadByPropertySet( _

PropSetDictionaryDisp As Object _

)

[C++]

HRESULT LoadByPropertySet(

IDispatch** PropSetDictionaryDisp

);

Parameters

PropSetDictionaryDisp

[in] In C++, contains the PropertySet. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the PropertySet.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


NameSpace Property

Contains the string that resolves naming conflicts between elements in a document.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property NameSpace As String

[C++]

HRESULT get_NameSpace(

BSTR* NameSpace

);

Parameters

NameSpace

[out, retval] In C++, contains the namespace. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the namespace.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with a default value of an empty string ("").

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and NameSpace is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating a document, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


PropertySet Property

Contains an IDictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property PropertySet As Object

[C++]

HRESULT get_PropertySet(

IDispatch** PropSetDisp

);

HRESULT putref_PropertySet(

IDispatch* PropSetDisp

);

Parameters

PropSetDisp

[out, retval], [in] In C++, contains the selection criteria. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the selection criteria.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

This is a required property if the document is an EDI document. The Delimiters property of the associated IBizTalkPort object must also be defined.

The following table shows whether names are required in the IDictionary object for PropertySet.

Selection criteria | X12 | EDIFACT
application_sender_code | Yes | Yes
application_receiver_code | Yes | Yes
functional_identifier | Yes | Yes
standards_version | Yes | No
standards_version_type | No | Yes
standards_version_value | No | Yes

Note

  • The name/value pairs contained in the IDictionary object cannot exceed a total of 450 bytes.

PropertySet can be set only if the Reference property is set.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions


Reference Property

Contains the full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by this IBizTalkDocument object.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Reference As String

[C++]

HRESULT get_Reference(

BSTR* Reference

);

HRESULT put_Reference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the reference. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the reference.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

If Reference is not set, the PropertySet and TrackFields properties must not be set.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


TrackFields Property

Contains an IDictionary object that stores the custom fields that Tracking uses to track all documents processed by the server, based on this document instance.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property TrackFields As Object

[C++]

HRESULT get_TrackFields(

IDispatch** TrackFieldsDisp

);

HRESULT putref_TrackFields(

IDispatch* TrackFieldsDisp

);

Parameters

TrackFieldsDisp

[out, retval], [in] In C++, contains the custom tracking fields. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the custom tracking fields.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

TrackFields can be set only if the Reference property is set. Tracking fields specified for an output IBizTalkDocument object are ignored.

An IBizTalkDocument object points to the specification that contains fields to track the document. The designated fields are logged to the Tracking database for each instance of a document that is processed. Tracking fields on the IBizTalkDocument object are global. The TrackFields property on the IBizTalkChannel object overrides the values specified by this property.

The fields in the IDictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the IDictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the IDictionary object and set the value to a SimpleList object. The SimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the IDictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions

Document Tracking


Type Property

Contains the version of the document standard.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Type As String

[C++]

HRESULT get_Type(

BSTR* Type

);

Parameters

Type

[out, retval] In C++, contains the document type. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the document type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with a default value of an empty string ("").

All document instances must have the same document type as the associated envelope. For example, if the Format property of the IBizTalkEnvelope object is set to X12, Type must also be X12.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Version Property

Contains the version of the document standard.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Version As String

[C++]

HRESULT get_Version(

BSTR* Version

);

Parameters

Version

[out, retval] In C++, contains the version. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the version.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint

Configures source information for an IBizTalkChannel object and destination information for an IBizTalkPort object.

Hierarchy

IDispatch

|--IBizTalkEndPoint

Declaration

[Visual Basic]

Class BizTalkEndpoint

[C++]

interface IBizTalkEndpoint : IDispatch

Members

IBizTalkEndPoint defines the following properties:

Property | Description
Alias | Contains a handle to the organization identifier type/value pair for the destination IBizTalkOrganization object for the associated IBizTalkPort object.
Application | Contains a handle to the associated application for the destination IBizTalkOrganization object for this IBizTalkPort object.
Openness | Contains an enumeration value that indicates whether the object has an open destination or source, or neither.
Organization | Contains a handle to the destination IBizTalkOrganization object for this IBizTalkPort object.

Remarks

The IBizTalkEndPoint object is automatically created when an IBizTalkPort object or an IBizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the IBizTalkConfig object.

For destination endpoints, access the IBizTalkEndPoint object by using the DestinationEndpoint property of the IBizTalkPort object. For source endpoints, access the IBizTalkEndPoint object by using the SourceEndpoint property of the IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Alias Property

Contains a handle to the organization identifier type/value pair for the destination IBizTalkOrganization object for the associated IBizTalkPort object.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Alias As Long

[C++]

HRESULT get_Alias(

long* AliasHandle

);

HRESULT put_Alias(

long AliasHandle

);

Parameters

AliasHandle

[out, retval], [in] In C++, contains the handle to the alias. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the alias.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Application Property

Contains a handle to the associated application for the destination IBizTalkOrganization object for this IBizTalkPort object.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Application As Long

[C++]

HRESULT get_Application(

long* AppHandle

);

HRESULT put_Application(

long AppHandle

);

Parameters

AppHandle

[out, retval], [in] In C++, contains the handle to the application. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the application.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Openness Property

Contains an enumeration value that indicates whether the object has an open destination or source, or neither.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Openness As BIZTALK_OPENNESS_TYPE_EX

[C++]

HRESULT get_Openness(

BIZTALK_OPENNESS_TYPE_EX* OpennessType

);

HRESULT put_Openness(

BIZTALK_OPENNESS_TYPE_EX OpennessType

);

Parameters

OpennessType

[out, retval], [in] In C++, contains a value indicating whether the object has an open destination or source, or neither. Valid values for this parameter are defined by the BIZTALK_OPENNESS_TYPE_EX enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_OPENNESS_TYPE_EX enumeration, indicating whether the object has an open destination or source, or neither.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_OPENNESS_TYPE_EX_NOTOPEN.

The IBizTalkPort object is valid only if the associated document or the parameters on the Submit or the SubmitSync method of IInterchange identify the missing information.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_SOURCE for an IBizTalkEndPoint object associated with a channel, the following constraints apply:

  • The SignatureType property must not be set.

  • The IBizTalkPort object cannot be included in a port group.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW on a channel, the associated IBizTalkOrganization object must be the default organization.

If Openness on the object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION for an IBizTalkEndPoint object associated with a messaging port, the following constraints apply:

  • The PrimaryTransportType property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • The EncryptionType property must not be set.

  • The document or the parameters on Submit or SubmitSync must specify the destination, transport type, and address.

  • The IBizTalkPort object cannot be included in a port group.

Note

  • This property cannot be changed on an existing port.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Openness


Organization Property

Contains a handle to the destination IBizTalkOrganization object for this IBizTalkPort object.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Organization As Long

[C++]

HRESULT get_Organization(

long* OrganizationHandle

);

HRESULT put_Organization(

long OrganizationHandle

);

Parameters

OrganizationHandle

[out, retval], [in] In C++, contains the handle to the organization. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the organization.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for this object to be complete unless the Openness property is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope

Configures the envelope format used with documents processed by BizTalk Server. An envelope is the header information for an interchange.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkEnvelope

Declaration

[Visual Basic]

Class BizTalkEnvelope

[C++]

interface IBizTalkEnvelope : IBizTalkBase

Members

IBizTalkEnvelope defines the following properties:

Property | Description
Content | Contains the contents of the selected envelope format specification.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Format | Contains a string that identifies the type of envelope.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
NameSpace | Contains a string that resolves naming conflicts between elements in an envelope specification.
Reference | Contains a full Web Distributed Authoring and Versioning (WebDAV) URL name of the envelope format specification file.
Version | Contains the version of the envelope format specification.

IBizTalkEnvelope defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Remarks

All document instances in an electronic data interchange (EDI) functional group must have the same format. All document instances must have the same document type as the associated envelope. For example, if Format is set to X12, the Type property of the IBizTalkDocument objects for the associated IBizTalkPort object must also be X12.

If you use an envelope with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier. To do this, use the CreateAlias method on the IBizTalkOrganization object. When an empty qualifier is encountered on an input EDIFACT envelope, the server converts the empty qualifier to a dash. For an output EDIFACT envelope, the server converts the dash to an empty qualifier.

The IBizTalkEnvelope object is required for input documents if the Type property of the IBizTalkDocument object is set to "flatfile" or "custom xml".

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Envelopes


Content Property

Contains the contents of the selected envelope format specification.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Content As String

[C++]

HRESULT get_Content(

BSTR* Content

);

Parameters

Content

[out, retval] In C++, contains the content. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the content.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Format Property

Contains a string that identifies the type of envelope.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Format As String

[C++]

HRESULT get_Format(

BSTR* Format

);

HRESULT put_Format(

BSTR Format

);

Parameters

Format

[out, retval], [in] In C++, contains the envelope format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the envelope format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The format value must be one of the following strings:

  • x12

  • edifact

  • custom xml (default)

  • custom

  • flatfile

  • reliable

Note

  • Any string other than the ones listed here will cause an error at run time.

If this property is set to "custom", the Reference property is required. Also, a custom parser component has to be registered with the server for input documents with this property set to "custom". For more information about custom parser components, see Parsers.

All document instances must have the same document type as the associated envelope. For example, if Format is set to "x12", the Type property of the IBizTalkDocument objects must also be "x12".

If Format is set to X12, edifact, or reliable, the Reference property should not be set.

For more information about envelope formats, see Create envelopes.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Envelopes


NameSpace Property

Contains a string that resolves naming conflicts between elements in an envelope specification.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property NameSpace As String

[C++]

HRESULT get_NameSpace(

BSTR* NameSpace

);

Parameters

NameSpace

[out, retval] In C++, contains the namespace. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the namespace.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value. The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and NameSpace is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating an envelope, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Reference Property

Contains a full Web Distributed Authoring and Versioning (WebDAV) URL name of the envelope format specification file.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Reference As String

[C++]

HRESULT get_Reference(

BSTR* Reference

);

HRESULT put_Reference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the reference. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the reference.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property if the Format property is set to "custom". Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Version Property

Contains the version of the envelope format specification.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Version As String

[C++]

HRESULT get_Version(

BSTR* Version

);

Parameters

Version

[out, retval] In C++, contains the version. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the version.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkLoggingInfo

Configures the document-logging information for an associated IBizTalkChannel object.

Hierarchy

IDispatch

|--IBizTalkLoggingInfo

Declaration

[Visual Basic]

Class BizTalkLoggingInfo

[C++]

interface IBizTalkLoggingInfo : IDispatch

Members

IBizTalkLoggingInfo defines the following properties:

Property | Description
LogNativeInputDocument | Contains a value that indicates whether the input document instance is saved and logged in its native format.
LogNativeOutputDocument | Contains a value that indicates whether the output document instance is saved and logged in its native format.
LogXMLInputDocument | Contains a value that indicates whether the XML input document is saved and logged.
LogXMLOutputDocument | Contains a value that indicates whether the XML output document is saved and logged.

Remarks

The IBizTalkLoggingInfo object is automatically created when an IBizTalkChannel object is instantiated with the CreateChannel method of the IBizTalkConfig object. You can access the IBizTalkLoggingInfo object by using the LoggingInfo property of the IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogNativeInputDocument Property

Contains a value that indicates whether the input document instance is saved and logged in its native format.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogNativeInputDocument As Boolean

[C++]

HRESULT get_LogNativeInputDocument(

VARIANT_BOOL* LogNativeInDoc

);

HRESULT put_LogNativeInputDocument(

VARIANT_BOOL LogNativeInDoc

);

Parameters

LogNativeInDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the input documents will be saved and logged in their native format. VARIANT_TRUE indicates that the input documents will be saved and logged in their native formats; VARIANT_FALSE indicates that the input documents will not be saved and logged in their native formats. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the input documents will be saved and logged in their native format. True indicates that the input documents will be saved and logged in their native formats; False indicates that the input documents will not be saved and logged in their native formats.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogNativeOutputDocument Property

Contains a value that indicates whether the output document instance is saved and logged in its native format.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogNativeOutputDocument As Boolean

[C++]

HRESULT get_LogNativeOutputDocument(

VARIANT_BOOL* LogNativeOutDoc

);

HRESULT put_LogNativeOutputDocument(

VARIANT_BOOL LogNativeOutDoc

);

Parameters

LogNativeOutDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the output documents will be saved and logged in their native format. VARIANT_TRUE indicates that the output documents will be saved and logged in their native formats; VARIANT_FALSE indicates that the output documents will not be saved and logged in their native formats. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the output documents will be saved and logged in their native format. True indicates that the output documents will be saved and logged in their native formats; False indicates that the output documents will not be saved and logged in their native formats.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogXMLInputDocument Property

Contains a value that indicates whether the XML input document is saved and logged.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogXMLInputDocument As Boolean

[C++]

HRESULT get_LogXMLInputDocument(

VARIANT_BOOL* LogXMLInDoc

);

HRESULT put_LogXMLInputDocument(

VARIANT_BOOL LogXMLInDoc

);

Parameters

LogXMLInDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the input documents will be saved and logged in XML format. VARIANT_TRUE indicates that the input documents will be saved and logged in XML format; VARIANT_FALSE indicates that the input documents will not be saved and logged in XML format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the input documents will be saved and logged in XML format. VARIANT_TRUE indicates that the input documents will be saved and logged in XML format; VARIANT_FALSE indicates that the input documents will not be saved and logged in XML format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogXMLOutputDocument Property

Contains a value that indicates whether the XML output document is saved and logged.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogXMLOutputDocument As Boolean

[C++]

HRESULT get_LogXMLOutputDocument(

VARIANT_BOOL* LogXMLOutDoc

);

HRESULT put_LogXMLOutputDocument(

VARIANT_BOOL LogXMLOutDoc

);

Parameters

LogXMLOutDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the output documents will be saved and logged in XML format. VARIANT_TRUE indicates that the output documents will be saved and logged in XML format; VARIANT_FALSE indicates that the output documents will not be saved and logged in XML format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the output documents will be saved and logged in XML format. VARIANT_TRUE indicates that the output documents will be saved and logged in XML format; VARIANT_FALSE indicates that the output documents will not be saved and logged in XML format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


IBizTalkOrganization

Configures an organization, its organization identifiers (aliases), and the applications within the organization that send and/or receive documents. The application indicates the ultimate source or destination of the document.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkOrganization

Declaration

[Visual Basic]

Class BizTalkOrganization

[C++]

interface IBizTalkOrganization : IBizTalkBase

Members

IBizTalkOrganization defines the following properties:

Property | Description
Aliases | Contains an ADO recordset of aliases that refer to the object.
Applications | Contains an ADO recordset of applications that refer to the object.
Comments | Contains user comments for the object.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
IsDefault | Contains a value that indicates whether the object is the default organization.
Name | Contains the name of the object.

IBizTalkOrganization defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
CreateAlias | Creates an alias for the object.
CreateApplication | Creates a new application.
GetDefaultAlias | Retrieves the default alias for the object.
Load | Loads a specified object in memory.
LoadAlias | Loads an existing alias for the object in memory.
LoadApplication | Loads an application in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
RemoveAlias | Removes an alias.
RemoveApplication | Removes an application.
Save | Saves the object in the database.
SaveAlias | Saves the alias.
SaveApplication | Saves the application.

Remarks

An IBizTalkOrganization object can have more than one application, but each application name must be unique for that object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


Aliases Property

Contains an ADO recordset of aliases that refer to the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property Aliases As Object

[C++]

HRESULT get_Aliases(

IDispatch** AliasesDisp

);

Parameters

AliasesDisp

[out, retval] Contains all aliases that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all aliases that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The alias for an object is the organization qualifier/value pair. BizTalk Messaging Manager refers to aliases as identifiers.

Each record in the ADO recordset returned by this property contains information about the aliases of an existing IBizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the alias.

  • Name specified in the CreateAlias method.

  • Boolean specified in the CreateAlias method.

  • Qualifier specified in the CreateAlias method.

  • Value specified in the CreateAlias method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


Applications Property

Contains an ADO recordset of applications that refer to the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property Applications As Object

[C++]

HRESULT get_Applications(

IDispatch** ApplicationsDisp

);

Parameters

ApplicationsDisp

[out, retval] Contains all applications that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all applications that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about the applications of an existing IBizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the application.

  • Name specified in the CreateApplication method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Comments Property

Contains user comments for the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property Comments As String

[C++]

HRESULT get_Comments(

BSTR* Comments

);

HRESULT put_Comments(

BSTR Comments

);

Parameters

Comments

[out, retval], [in] In C++, contains the comments. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the comments.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateAlias Method

Creates an alias for the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub CreateAlias( _

Name As String, _

Default As Boolean, _

Qualifier As String, _

Value As String _

)

[C++]

HRESULT CreateAlias(

BSTR Name,

VARIANT_BOOL Default,

BSTR Qualifier,

BSTR Value

);

Parameters

Name

[in] Contains the name of the alias.

Default

[in] In Visual Basic, contains a value that indicates whether or not this default alias overrides the previous default alias. True indicates that this default alias overrides the previous default alias; False indicates that this default alias should not override the previous default alias. If no alias is specified as the default, one is assigned when the Create method is called.

[in] In C++, contains a value that indicates whether or not this default alias overrides the previous default alias. VARIANT_TRUE indicates that this default alias overrides the previous default alias; VARIANT_FALSE indicates that this default alias should not override the previous default alias. If no alias is specified as the default, one is assigned when the Create method is called.

Qualifier

[in] Contains the qualifier. This parameter cannot be set to "group".

Value

[in] Contains the value.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The alias for an object is the organization identifier that contains a name and a qualifier/value pair.

More than one alias can be created for an IBizTalkOrganization object. The organization alias must contain a name that is unique for the specified IBizTalkOrganization object, and a qualifier/value pair that is unique across all IBizTalkOrganization objects. One of these aliases must be specified as the default alias for the object.

The server automatically creates an alias named Organization with a default identifier of OrganizationName and the value set to the organization's name for new organizations. If the organization name is changed, the value is automatically updated with the new name. This alias cannot be removed.

Note

  • When using envelopes with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


CreateApplication Method

Creates a new application.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub CreateApplication( _

Name As String _

)

[C++]

HRESULT CreateApplication(

BSTR Name

);

Parameters

Name

[in] Contains the name of the application.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If an IBizTalkOrganization object is associated with more than one application, each application name must be unique.

Notes

  • BizTalk Messaging Manager refers to the default organization as the home organization.

  • BizTalk Messaging Manager allows applications to be created for the home organization only. The BizTalk Messaging Configuration object model does not enforce this restriction. Therefore, if you create an application for an organization other than the default (home) organization, you cannot modify it using BizTalk Messaging Manager.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


GetDefaultAlias Method

Retrieves the default alias for the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Function GetDefaultAlias( ) As Long

[C++]

HRESULT GetDefaultAlias(

long* AliasHandle

);

Parameters

AliasHandle

[out, retval] Contains the handle. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the handle.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The default alias for an object is the default organization identifier type/value pair.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


IsDefault Property

Contains a value that indicates whether the object is the default organization.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property IsDefault( ) As Boolean

[C++]

HRESULT get_IsDefault(

VARIANT_BOOL* IsDefault

);

Parameters

IsDefault

In C++, contains a value that indicates whether or not this organization is the default organization. VARIANT_TRUE indicates that this organization is the default organization; VARIANT_FALSE indicates that this organization is not the default organization. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not this organization is the default organization. True indicates that this organization is the default organization; False indicates that this organization is not the default organization.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property. There must be one and only one default organization at any time.

Note

  • BizTalk Messaging Manager refers to the default organization as the home organization.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


LoadAlias Method

Loads an existing alias for the object in memory.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub LoadAlias( _

AliasHandle As Long, _

Name As Variant, _

Default As Variant, _

Qualifier As Variant, _

Value As Variant _

)

[C++]

HRESULT LoadAlias(

long AliasHandle,

VARIANT* Name,

VARIANT* Default,

VARIANT* Qualifier,

VARIANT* Value

);

Parameters

AliasHandle

[in] Contains the handle to the alias.

Name

[in, out] Contains the name of the organization identifier.

Default

[in, out] Contains the default flag.

Qualifier

[in, out] Contains the qualifier of the organization identifier.

Value

[in, out] Contains the value of the organization identifier.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The alias for an object is the organization qualifier/value pair.

The values used with the parameters of this method can be obtained from the Aliases property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


LoadApplication Method

Loads an application in memory.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub LoadApplication( _

ApplicationHandle As Long, _

Name As Variant _

)

[C++]

HRESULT LoadApplication(

long ApplicationHandle,

VARIANT* Name

);

Parameters

ApplicationHandle

[in] Contains the application handle.

Name

[in, out] Contains the name of the application.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The values used with the parameters of this method can be obtained from the Applications property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RemoveAlias Method

Removes an alias.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub RemoveAlias( _

AliasHandle As Long _

)

[C++]

HRESULT RemoveAlias(

long AliasHandle

);

Parameters

AliasHandle

[in] Contains the handle to the alias.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This record cannot be removed if any of the following conditions apply:

  • An IBizTalkPort or an IBizTalkChannel object refers to it.

  • It has been designated the default organization identifier.

  • This alias was autogenerated.

The alias handle can be obtained from the Aliases property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


RemoveApplication Method

Removes an application.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub RemoveApplication( _

ApplicationHandle As Long _

)

[C++]

HRESULT RemoveApplication(

long ApplicationHandle

);

Parameters

ApplicationHandle

[in] Contains the handle.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This record cannot be removed if an IBizTalkPort or an IBizTalkChannel object refers to it.

The application handle can be obtained from the Applications property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SaveAlias Method

Saves the alias.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub SaveAlias( _

AliasHandle As Long, _

Name As String, _

Default As Boolean, _

Qualifier As String, _

Value As String _

)

[C++]

HRESULT SaveAlias(

long AliasHandle,

BSTR Name,

VARIANT_BOOL Default,

BSTR Qualifier,

BSTR Value

);

Parameters

AliasHandle

[in] Contains the handle to the alias.

Name

[in] Contains the name of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

Default

[in] In Visual Basic, contains a value that indicates whether or not this is the default alias for the organization. True indicates that this is the default alias for the organization; False indicates that this is not the default alias for the organization.

[in] In C++, contains a value that indicates whether or not this is the default alias for the organization. VARIANT_TRUE indicates that this is the default alias for the organization; VARIANT_FALSE indicates that this is not the default alias for the organization.

Qualifier

[in] Contains the qualifier of the organization identifier. This parameter cannot be changed if this alias was autogenerated. This parameter cannot be set to "group".

Value

[in] Contains the value of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The alias for an object is the organization identifier type/value pair.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


SaveApplication Method

Saves the application.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub SaveApplication( _

ApplicationHandle As Long, _

Name As String _

)

[C++]

HRESULT SaveApplication(

long ApplicationHandle,

BSTR Name

);

Parameters

ApplicationHandle

[in] Contains the handle to the application.

Name

[in] Contains the name of the application.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort

Configures a one-way transfer of a document between organizations and applications. It identifies the source organization and/or application, the destination organization and/or application, the primary transport type, and, if selected, the associated envelope for transmission.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkPort

Declaration

[Visual Basic]

Class BizTalkPort

[C++]

interface IBizTalkPort : IBizTalkBase

Members

IBizTalkPort defines the following properties:

Property | Description
Channels | Contains an ADO recordset that includes information about all IBizTalkChannel objects that refer to the object.
Comments | Contains the user comments for the IBizTalkPort object.
ControlNumberValue | Contains the value of the interchange control number.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Delimiters | Contains an IDictionary object that includes all delimiters used in the document specification.
DestinationEndpoint | Contains information about the destination.
EncodingType | Contains an enumeration value that indicates the type of document encoding.
EncryptionCertificateInfo | Contains information about the certificate that encrypts the document.
EncryptionType | Contains an enumeration value that indicates the type of document encryption.
Envelope | Contains a handle to the IBizTalkEnvelope object associated with this IBizTalkPort object.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
PrimaryTransport | Contains the primary transport component information.
SecondaryTransport | Contains the secondary transport component information.
ServiceWindowInfo | Contains the service window information.
SignatureType | Contains an enumeration value that indicates the type of digital signing and verification.

IBizTalkPort defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Processing

Messaging Ports


Channels Property

Contains an ADO recordset that includes information about all IBizTalkChannel objects that refer to the object.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Channels( ) As Object

[C++]

HRESULT get_Channels(

IDispatch** ChannelsDisp

);

Parameters

ChannelsDisp

[out, retval] Contains the IBizTalkChannel objects that refer to the object.

Return Values

In Visual Basic, this property returns the IBizTalkChannel objects that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about the IBizTalkChannel objects in the database that are associated with this IBizTalkPort object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • A unique channel identifier, in GUID format.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Comments Property

Contains the user comments for the IBizTalkPort object.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Comments As String

[C++]

HRESULT get_Comments(

BSTR* Comments

);

HRESULT put_Comments(

BSTR Comments

);

Parameters

Comments

[out, retval], [in] In C++, contains the comments. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the comments.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ControlNumberValue Property

Contains the value of the interchange control number.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property ControlNumberValue As String

[C++]

HRESULT get_ControlNumberValue(

BSTR* ControlNumberValue

);

HRESULT put_ControlNumberValue(

BSTR ControlNumberValue

);

Parameters

ControlNumberValue

[out, retval], [in] In C++, contains the interchange control number. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property the interchange control number.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The ControlNumberValue property must contain a value between 1 and 999999999. This property has no default value.

This is a required property if the Format property of the associated IBizTalkEnvelope object is set to "x12", "edifact", or "custom". This constraint is not enforced for this release, but the server fails if it is not adhered to.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Delimiters Property

Contains an IDictionary object that includes all delimiters used in the document specification.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Delimiters As Object

[C++]

HRESULT get_Delimiters(

IDispatch** DelimitersDisp

);

HRESULT putref_Delimiters(

IDispatch* DelimitersDisp

);

Parameters

DelimitersDisp

[out, retval], [in] In C++, contains the delimiters. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the delimiters.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for the object to be complete if the Format property of the associated IBizTalkEnvelope object is set to "x12", "edifact", or "custom". Delimiters specifies which characters to use to separate data within the envelope and the documents that are sent using this envelope.

The PropertySet property of the associated IBizTalkDocument object must also be defined. The following table shows which names are required for the delimiters of the IDictionary object for various formats:

Delimiter | X12 | EDIFACT
Record_delim | Yes | Yes
Field_delim | Yes | Yes
Subfield_delim | Yes | Yes
Escape_char | No | Yes

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


DestinationEndpoint Property

Contains information about the destination.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property DestinationEndpoint As Object

[C++]

HRESULT get_DestinationEndpoint(

IDispatch** DestEndpointDisp

);

HRESULT putref_DestinationEndpoint(

IDispatch* DestEndpointDisp

);

Parameters

DestEndpointDisp

[out, retval], [in] In C++, contains information about the destination. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns information about the destination.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information provided by this property includes the Alias, Application, and Organization properties and is created and stored in memory in the IBizTalkEndPoint object.

Once an IBizTalkPort object has been created, the destination IBizTalkOrganization object cannot be changed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


EncodingType Property

Contains an enumeration value that indicates the type of document encoding.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property EncodingType As BIZTALK_ENCODING_TYPE

[C++]

HRESULT get_EncodingType(

BIZTALK_ENCODING_TYPE* EncodingType

);

HRESULT put_EncodingType(

BIZTALK_ENCODING_TYPE EncodingType

);

Parameters

EncodingType

[out, retval], [in] In C++, contains the encoding type. Valid values for this parameter are defined by the BIZTALK_ENCODING_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_ENCODING_TYPE enumeration, indicating the encoding type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_ENCODING_TYPE_NONE. The Clear method sets EncodingType to BIZTALK_ENCODING_TYPE_NONE.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


EncryptionCertificateInfo Property

Contains information about the certificate that encrypts the document.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property EncryptionCertificateInfo As Object

[C++]

HRESULT get_EncryptionCertificateInfo(

IDispatch** EncryptionCertificateInfoDisp

);

HRESULT putref_EncryptionCertificateInfo(

IDispatch* EncryptionCertificateInfoDisp

);

Parameters

EncryptionCertificateInfoDisp

[out, retval], [in] In C++, contains the certificate information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information provided by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the IBizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


EncryptionType Property

Contains an enumeration value that indicates the type of document encryption.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property EncryptionType As BIZTALK_ENCRYPTION_TYPE

[C++]

HRESULT get_EncryptionType(

BIZTALK_ENCRYPTION_TYPE* EncryptionType

);

HRESULT put_EncryptionType(

BIZTALK_ENCRYPTION_TYPE EncryptionType

);

Parameters

EncryptionType

[out, retval], [in] In C++, contains the encryption type. Valid values for this parameter are defined by the BIZTALK_ENCRYPTION_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_ENCRYPTION_TYPE enumeration, indicating the encoding type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_ENCRYPTION_TYPE_NONE. The Clear method sets EncryptionType to BIZTALK_ENCRYPTION_TYPE_NONE.

If the EncryptionType is set to BIZTALK_ENCRYPTION_TYPE_SMIME, then the EncryptionCertificateInfo property must be set.

For open messaging ports, EncryptionType must be set to BIZTALK_ENCRYPTION_TYPE_NONE.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Envelope Property

Contains a handle to the IBizTalkEnvelope object associated with this IBizTalkPort object.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Envelope As Long

[C++]

HRESULT get_Envelope(

long* EnvelopeHandle

);

HRESULT put_Envelope(

long EnvelopeHandle

);

Parameters

EnvelopeHandle

[out, retval], [in] In C++, contains the handle to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Envelopes


PrimaryTransport Property

Contains the primary transport component information.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property PrimaryTransport As Object

[C++]

HRESULT get_PrimaryTransport(

IDispatch** TransportInfoDisp

);

HRESULT putref_PrimaryTransport(

IDispatch* TransportInfoDisp

);

Parameters

TransportInfoDisp

[out, retval], [in] In C++, contains the primary transport component information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the primary transport component information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for the object.

Information provided by this property includes the Address, Parameter, and Type properties of the IBizTalkTransportInfo object.

The following constraints are enforced:

  • If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and PrimaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION. The IBizTalkServiceWindowInfo object cannot be used with open destination ports.

  • Once an IBizTalkPort object has been created, the Openness property of the associated IBizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • When using a Type of BIZTALK_TRANSPORT_TYPE_LOOPBACK, the primary and secondary transport Address property cannot be set, and the IBizTalkServiceWindowInfo object cannot be used.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SecondaryTransport Property

Contains the secondary transport component information.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property SecondaryTransport As Object

[C++]

HRESULT get_SecondaryTransport(

IDispatch** TransportInfoDisp

);

HRESULT putref_SecondaryTransport(

IDispatch* TransportInfoDisp

);

Parameters

TransportInfoDisp

[out, retval], [in] In C++, contains the secondary transport component information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the secondary transport component information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for the object to be complete.

Information provided by this property includes the Address, Parameter, and Type properties, and is created and stored in memory in the IBizTalkTransportInfo object.

The following constraints are enforced:

  • If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and SecondaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • Once an IBizTalkPort object has been created, the Openness property of the associated IBizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • The Type property cannot be set to BIZTALK_TRANSPORT_TYPE_LOOPBACK.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ServiceWindowInfo Property

Contains the service window information.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property ServiceWindowInfo As Object

[C++]

HRESULT get_ServiceWindowInfo(

IDispatch** ServiceWindowInfoDisp

);

HRESULT putref_ServiceWindowInfo(

IDispatch* ServiceWindowInfoDisp

);

Parameters

ServiceWindowInfoDisp

[out, retval], [in] In C++, contains the service window. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the service window.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information provided by this property includes the FromTime, IsEnabled, and ToTime properties and is created and stored in memory in the IBizTalkServiceWindowInfo object.

If this property is used, the IBizTalkServiceWindowInfo object must specify a valid time range by using the FromTime and ToTime properties.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SignatureType Property

Contains an enumeration value that indicates the type of digital signing and verification.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property SignatureType As BIZTALK_SIGNATURE_TYPE

[C++]

HRESULT get_SignatureType(

BIZTALK_SIGNATURE_TYPE* SignatureType

);

HRESULT put_SignatureType(

BIZTALK_SIGNATURE_TYPE SignatureType

);

Parameters

SignatureType

[out, retval], [in] In C++, contains the signature type. Valid values for this parameter are defined by the BIZTALK_SIGNATURE_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_SIGNATURE_TYPE enumeration, indicating the encoding type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_SIGNATURE_TYPE_NONE. The Clear method sets SignatureType to BIZTALK_SIGNATURE_TYPE_NONE.

IBizTalkPort objects associated with open channels cannot have a SignatureType.

If the SignatureType on an IBizTalkPort object is changed from BIZTALK_SIGNATURE_TYPE_NONE to BIZTALK_SIGNATURE_TYPE_SMIME, all channels associated with this IBizTalkPort object must have already been saved with SignatureCertificateInfo. Also, if a IBizTalkChannel contains a SignatureCertificateInfo object and the SignatureType of the IBizTalkPort is set to BIZTALK_SIGNATURE_TYPE_NONE, the signature will be ignored.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup

Configures port groups that are used to distribute the same document to many organizations.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkPortGroup

Declaration

[Visual Basic]

Class BizTalkPortGroup

[C++]

interface IBizTalkPortGroup : IBizTalkBase

Members

IBizTalkPortGroup defines the following properties:

Property | Description
Channels | Contains an ADO recordset that contains information about all IBizTalkChannel objects that refer to this object.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
Ports | Contains an ADO recordset that contains information about all IBizTalkPort objects that refer to this object.

IBizTalkPortGroup defines the following methods:

Method | Description
AddPort | Adds an IBizTalkPort object to this port group. There must be at least one IBizTalkPort object in the port group.
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
RemovePort | Removes an IBizTalkPort object from the port group. There must be at least one IBizTalkPort object in the port group.
Save | Saves the object in the database.

Remarks

There must always be at least one IBizTalkPort object and one IBizTalkChannel object associated with a IBizTalkPortGroupobject. The IBizTalkChannel object is associated with the IBizTalkPortGroup object, not the IBizTalkPort object within the group. Each IBizTalkPort object within the group has another IBizTalkChannel object or objects associated with it, but these are ignored when the port group channel is invoked.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Distribution List

Port Groups

Submitting Documents to a Port Group


AddPort Method

Adds an IBizTalkPort object to this port group. There must be at least one IBizTalkPort object in the port group.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Method Declaration

[Visual Basic]

Sub AddPort( _

PortHandle As Long _

)

[C++]

HRESULT AddPort(

long PortHandle

);

Parameters

PortHandle

[in] Contains the handle to the object.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The following constraints apply to this method:

  • There must be at least one IBizTalkPort in this IBizTalkPortGroup object.

  • The Openness property of the associated BizTalkEndPoint object to be added must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN.

  • The port group specified by this object cannot contain any duplicate IBizTalkPort objects.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Channels Property

Contains an ADO recordset that contains information about all IBizTalkChannel objects that refer to this object.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Property Declaration

[Visual Basic]

Property Channels As Object

[C++]

HRESULT get_Channels(

IDispatch** ChannelsDisp

);

Parameters

ChannelsDisp

[out, retval] Contains an ADO recordset that contains all IBizTalkChannel objects that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns an ADO recordset that contains all IBizTalkChannel objects that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Each record in the ADO recordset returned by this property contains information about the IBizTalkChannel objects in the database that are associated with this IBizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Ports Property

Contains an ADO recordset that contains information about all IBizTalkPort objects that refer to this object.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Property Declaration

[Visual Basic]

Property Ports As Object

[C++]

HRESULT Ports(

IDispatch** PortsDisp

);

Parameters

PortsDisp

[out, retval] Contains an ADO recordset that includes all IBizTalkPort objects that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values.

Return Values

In Visual Basic, this property returns an ADO recordset that includes all IBizTalkPort objects that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Each record in the ADO recordset returned by this property contains information about the IBizTalkPort objects in the database that are associated with this IBizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RemovePort Method

Removes an IBizTalkPort object from the port group. There must be at least one IBizTalkPort object in the port group.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Method Declaration

[Visual Basic]

Sub RemovePort( _

PortHandle As Long _

)

[C++]

HRESULT RemovePort(

long PortHandle

);

Parameters

PortHandle

[in] Contains the handle to the object to remove.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The last IBizTalkPort object associated with the object cannot be removed. An IBizTalkPort object cannot be removed if an IBizTalkChannel object refers to it.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo

Configures the service window for an associated IBizTalkPort object. The service window indicates a valid time range for transmitting documents.

Hierarchy

IDispatch

|--IBizTalkServiceWindowInfo

Declaration

[Visual Basic]

Class BizTalkServiceWindowInfo

[C++]

interface IBizTalkServiceWindowInfo : IDispatch

Members

IBizTalkServiceWindowInfo defines the following properties:

Property | Description
FromTime | Contains the earliest time that the interchange can be transmitted.
IsEnabled | Contains a value that indicates whether the service window is enabled.
ToTime | Contains the latest time that the interchange can be transmitted.

Remarks

The IBizTalkServiceWindowInfo object is automatically created when an IBizTalkPort object is instantiated with the CreatePort method of the IBizTalkConfig object. Access the properties of the IBizTalkServiceWindowInfo object by using the ServiceWindowInfo property of the IBizTalkPort object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


FromTime Property

Contains the earliest time that the interchange can be transmitted.

Member List

IBizTalkServiceWindowInfo

|--FromTime

|--IsEnabled

|--ToTime

Property Declaration

[Visual Basic]

Property FromTime As String

[C++]

HRESULT get_FromTime(

BSTR* FromTime

);

HRESULT put_Comments(

BSTR FromTime

);

Parameters

FromTime

[out, retval], [in] In C++, contains the earliest time that the interchange can be transmitted. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the earliest time that the interchange can be transmitted.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The FromTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified. Service window hours are displayed in the coordinated universal time (UTC) format and reflect the time on the database server.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IsEnabled Property

Contains a value that indicates whether the service window is enabled.

Member List

IBizTalkServiceWindowInfo

|--FromTime

|--IsEnabled

|--ToTime

Property Declaration

[Visual Basic]

Property IsEnabled As Boolean

[C++]

HRESULT get_IsEnabled(

VARIANT_BOOL* IsEnabled

);

HRESULT put_IsEnabled(

_BOOL IsEnabled

);

Parameters

IsEnabled

[out, retval], [in] In C++, contains a value that indicates whether or not a service window is enabled. VARIANT_TRUE indicates that the service window is enabled; VARIANT_FALSE indicates that the service window is not enabled. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not a service window is enabled. True indicates that the service window is enabled; False indicates that the service window is not enabled.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ToTime Property

Contains the latest time that the interchange can be transmitted.

Member List

IBizTalkServiceWindowInfo

|--FromTime

|--IsEnabled

|--ToTime

Property Declaration

[Visual Basic]

Property ToTime As String

[C++]

HRESULT get_ToTime(

BSTR* ToTime

);

HRESULT put_ToTime(

BSTR ToTime

);

Parameters

ToTime

[out, retval], [in] In C++, contains the latest time that the interchange can be transmitted. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the latest time that the interchange can be transmitted.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The ToTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified. Service window hours are displayed in the coordinated universal time (UTC) format and reflect the time on the database server.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo

Configures the transport service for an associated IBizTalkPort object.

Hierarchy

IDispatch

|--IBizTalkTransportInfo

Declaration

[Visual Basic]

Class BizTalkTransportInfo

[C++]

interface IBizTalkTransportInfo : IDispatch

Members

IBizTalkTransportInfo defines the following properties:

Property | Description
Address | Contains the destination address of the primary transport component.
Parameter | Contains the required return e-mail address for the associated source IBizTalkOrganization object if the Type property is BIZTALK_TRANSPORT_ TYPE_SMTP.
Type | Contains an enumeration value that indicates the type of transport component to be used for the primary transport.

Remarks

The IBizTalkTransportInfo object is automatically created when an IBizTalkPort object is instantiated with the CreatePort method of the IBizTalkConfig object.

Access the IBizTalkTransportInfo object by using the PrimaryTransport or SecondaryTransport property of the IBizTalkPort object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Address Property

Contains the destination address of the primary transport component.

Member List

IBizTalkTransportInfo

|--Address

|--Parameter

|--Type

Property Declaration

[Visual Basic]

Property Address As String

[C++]

HRESULT get_Address(

BSTR* TransportAddress

);

HRESULT put_Address(

BSTR TransportAddress

);

Parameters

TransportAddress

[out, retval], [in] In C++, contains the address. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the address.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, Address cannot be set, and the Type property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

Address must have one of the following prefixes, according to the Type property:

Transport type | Prefix | Example Address value
APPINTEGRATION | Not applicable | {11111111-1111-1111-1111-111111111111}
FILE | file:// | file://C:\Test\MyFile.xml
HTTP | http:// | http://www.adatum.com/repository/bts.asp
HTTPS | https:// | https://www.adatum.com/secure/btss.asp
LOOPBACK | Not applicable | Not applicable
MSMQ | Not applicable | DIRECT=OS:.\private$\myqueue
NONE | Not applicable | Not applicable
OPENDESTINATION | Not applicable | Not applicable
ORCHESTRATIONACTIVATION | Not applicable | C:\XLANG\Schedules\mysched.skx
SMTP | mailto: | mailto:patricia@adatum.com

Notes

  • The queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. For open messaging ports, the address is specified either in the document instance or as a parameter when submitting the document. For more information, see Routing.

  • When using the Orchestration Activation Component transport type, the Address property must contain the full path of the XLANG schedule on the local computer. The file:// prefix cannot be used when specifying the path of the XLANG schedule (.skx) file.

  • When using the HTTP or HTTPS transport types, BizTalk Server sends the data using a proxy server by default. This is the correct setting to transport data to computers outside of your company's firewall. However, when sending data within your company's intranet, you can bypass the use of a proxy server. To do this, you must set the UseProxy field to False in the transport dictionary. For more information, see SetConfigData.

When using the file:// transport type, you can include symbols to modify the file name. The file name created by the server contains any static characters you specified in the Address property, along with the actual value of the symbol. For example, if the Address property is set to "file://C:\Orders\Invoice_%tracking_id%.xml", the actual file name would use a format similar to: C:\Orders\Invoice_{12345678-90AB-CDEF-1234-567890ABCDEF}. The following table contains the symbols that can be used with the file:// transport type:

Symbol | Description | Unique file name
%datetime% | Date and time, in milliseconds, of the file creation. The time is based on Greenwich Mean Time (GMT) rather than local time. | No
%src_filename% | Name of the source document processed by BizTalk Server. | No
%src_filepath% | This value is not supported. | Not applicable
%document_name% | Name of the document definition used to process the source file. | No
%server% | Host name of the server that processed the document. | No
%tracking_id% | Globally unique tracking number. | Yes
%uid% | Counter that increases over time, represented in milliseconds. This number is reset when the server is rebooted. | No

When sending reliable messaging receipts that use the SMTP transport protocol, the value specified in the identifier named Reliable Messaging Acknowledgement SMTP From Address is used as the From address. This identifier is automatically created for the default IBizTalkOrganization object. This identifier cannot be removed. You should not modify the name or qualifier for this identifier, but you can modify the value. For more information, see Processing Receipts Using Reliable Messaging.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Parameter Property

Contains the required return e-mail address of the associated source IBizTalkOrganization object if the Type property is set to BIZTALK_TRANSPORT_TYPE_SMTP.

Member List

IBizTalkTransportInfo

|--Address

|--Parameter

|--Type

Property Declaration

[Visual Basic]

Property Parameter As String

[C++]

HRESULT get_Parameter(

BSTR* PrimaryTransportParameter

);

HRESULT put_Parameter(

BSTR PrimaryTransportParameter

);

Parameters

PrimaryTransportParameter

[out, retval], [in] In C++, contains the required return e-mail address. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the required return e-mail address.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

  • This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Type Property

Contains an enumeration value that indicates the type of transport component to be used for the primary transport.

Member List

IBizTalkTransportInfo

|--Address

|--Parameter

|--Type

Property Declaration

[Visual Basic]

Property Type As BIZTALK_TRANSPORT_TYPE

[C++]

HRESULT get_Type(

BIZTALK_TRANSPORT_TYPE* TransportType

);

HRESULT put_Type(

BIZTALK_TRANSPORT_TYPE TransportType

);

Parameters

TransportType

[out, retval], [in] In C++, contains the transport type. Valid values for this parameter are defined by the BIZTALK_TRANSPORT_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_TRANSPORT_TYPE enumeration, indicating the transport type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The following constraints are enforced:

  • If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the Address property cannot be set, and Type must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

When using the Message Queuing transport type (BIZTALK_TRANSPORT_TYPE_MSMQ), the following restrictions apply:

  • When using an envelope, the maximum size of a document submitted to BizTalk Server is 4MB.

  • When an envelope is not used, the maximum size of a document submitted to BizTalk Server is 2MB.

  • When using the BIZTALK_TRANSPORT_TYPE_SMTP, the Parameter property must be set to the reply-to SMTP address.

  • The transport Type of BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION is supported only when the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_TOWORKFLOW.

  • When using the Orchestration activation component type (BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION), the maximum size of a document sent to the port on the XLANG schedule is 2MB.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IDictionary

Supports the creation, storage, and retrieval of name/value pairs in memory. This collection object is used by several methods in the BizTalk Messaging Configuration object model.

Hierarchy

IDispatch

|--IDictionary

Declaration

[Visual Basic]

Class CDictionary

[C++]

interface IDictionary : IDispatch

Members

IDictionary defines the following properties:

Property | Description
Count | Contains the number of entries in the IDictionary object.
Prefix | Contains the prefix that is used to exclude all entries with that prefix when the contents of the IDictionary object are saved.
Value | Contains the value associated with an entry name.

IDictionary defines the following methods:

Method | Description
GetMultiple | Returns the values of multiple entries from the IDictionary object.
PutMultiple | Adds specified entries to the IDictionary object or changes them.

Remarks

An IDictionary object is designed to be a general-purpose collection. Therefore, it can be used for anything that is supported by its internal structure. Every value in an IDictionary object is a Variant. This means that an IDictionary object can be created that consists of almost any kind of value (including other IDictionary objects).

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Count Property

Contains the number of entries in the IDictionary object.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] In C++, contains the count. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the count.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property is read-only with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


GetMultiple Method

Returns the values of multiple entries from the IDictionary object.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Method Declaration

[Visual Basic]

Sub GetMultiple( _

NumberOfEntries As Long, _

Entries As String, _

Values As Variant _

)

[C++]

HRESULT GetMultiple(

long NumberOfEntries,

const LPOLESTR Entries[],

VARIANT Values[]

);

Parameters

NumberOfEntries

[in] Specifies the number of values to retrieve.

Entries

[in, size_is(cb)] Array of string values that identifies the Dictionary object entries for which the values should be retrieved.

Values

[out, size_is(cb)] Array of VARIANTs. When GetMultiple returns, this array contains the values associated with the Dictionary object entries identified by the Entries[] array.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Prefix Property

Contains the prefix that is used to exclude all entries with that prefix when the contents of the IDictionary object are saved.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Property Declaration

[Visual Basic]

Property Prefix As String

[C++]

HRESULT get_Prefix(

BSTR* Prefix

);

HRESULT put_Prefix(

BSTR Prefix

);

Parameters

Prefix

[out, retval], [in] In C++, contains the prefix. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the prefix.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Any name/value pair with a name beginning with the specified prefix is not saved to the database. The prefix default is an underscore (_). Therefore, any keywords that begin with an underscore are not saved unless the prefix is changed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


PutMultiple Method

Adds specified entries to the IDictionary object or changes them.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Method Declaration

[Visual Basic]

Sub PutMultiple( _

NumberOfEntries As Long, _

Entries As String, _

Values As Variant _

)

[C++]

HRESULT PutMultiple(

long NumberOfEntries,

const LPOLESTR Entries[],

const VARIANT Values[]

);

Parameters

NumberOfEntries

[in] Identifies the number of elements in the rgolestr and rgvar arrays.

Entries

[in, size_is(cb)] Array of strings that contains the names to add to the IDictionary object.

Values

[in, size_is(cb)] Array of VARIANTs that contains the values to add to the IDictionary object.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

A one-to-one mapping exists between the elements of the Entries[] and Values[] arrays. This means that Entries[n] is added to the IDictionary object and is initialized to Values[n]. If the element specified by Entries[n] is already in the IDictionary object, the value associated with the element is overwritten with the value stored in Values[n].

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Value Property

Contains the value associated with an entry name.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Property Declaration

[Visual Basic]

Property Value( _

Name As String _

)

[C++]

HRESULT get_Value(

BSTR Name,

VARIANT* Value

);

HRESULT put_Value(

BSTR Name,

VARIANT Value

);

Parameters

Name

[in] Contains the name.

Value

[out, retval] [in] In C++, contains the value. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property optionally returns the value.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The value of an IDictionary object can be read or written to without explicitly using the Value property by treating the named entry as a property of the IDictionary object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList

Creates an array of variants that supports enumeration.

Hierarchy

IDispatch

|--ISimpleList

Declaration

[Visual Basic]

Class CSimpleList

[C++]

interface ISimpleList : IDispatch

Members

ISimpleList defines the following properties:

Property | Description
Count | Contains the number of elements in the ISimpleList object.
Item | Contains a container for an element of the ISimpleList object.

ISimpleList defines the following methods:

Method | Description
Add | Adds the specified item to the ISimpleList object.
Delete | Deletes the specified item from the ISimpleList object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Add Method

Adds the specified item to the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Method Declaration

[Visual Basic]

Sub Add( _

Var As Variant _

)

[C++]

HRESULT Add(

VARIANT* Var

);

Parameters

Var

[in] Contains the object to add to the ISimpleList object.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Count Property

Contains the number of elements in the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] Contains the number of items in the ISimpleList object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of items in the ISimpleList object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property is read-only with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Delete Method

Deletes the specified item from the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Method Declaration

[Visual Basic]

Sub Delete( _

Index As Long _

)

[C++]

HRESULT Delete(

long Index

);

Parameters

Index

[in] Contains the index value of the item to delete.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Item Property

Contains a container for an element of the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Property Declaration

[Visual Basic]

Property Item( _

Index (ISimpleList, Item) As Long _

) As Variant

[C++]

HRESULT get_Item(

long Index (ISimpleList, Item),

VARIANT* Item (ISimpleList, Item)

);

HRESULT put_Item(

long Index,

VARIANT Item

);

HRESULT putref_Item(

long Index,

VARIANT Item

);

Parameters

Index

[in], [in] In C++, contains the index of the item.

Item

[out, retval], [in] In C++, contains the object used to return the item. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the object used to return the item.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The Item property is a read/write Variant that contains an element of the ISimpleList object. An initialized Variant is stored at a specified array index. If an item is already stored at the specified index, that item is overwritten by the put method.

In C++, When putting a value, use the putref_Item method if you are setting an object reference; use the put_Item method if you are setting a scalar value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Enumerations

The following enumerations provide possible property and parameter values:

  • BIZTALK_CONFIGDATA_TYPE

  • BIZTALK_ENCODING_TYPE

  • BIZTALK_ENCRYPTION_TYPE

  • BIZTALK_OPENNESS_TYPE

  • BIZTALK_OPENNESS_TYPE_EX

  • BIZTALK_SIGNATURE_TYPE

  • BIZTALK_STORE_TYPE

  • BIZTALK_TRANSPORT_TYPE

  • BIZTALK_USAGE_TYPE


BIZTALK_CONFIGDATA_TYPE

Configures messaging ports.

[Visual Basic]

Enum BIZTALK_CONFIGDATA_TYPE

[C++]

enum BIZTALK_CONFIGDATA_TYPE

Members

BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT

[0] Configures the primary transport on the messaging port.

BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT

[1] Configures the secondary transport on the messaging port.

BIZTALK_CONFIGDATA_TYPE_ENCRYPTION

[2] Configures the encryption certificate on the messaging port.

BIZTALK_CONFIGDATA_TYPE_ENCODING

[2] Configures the encoding type on the messaging port.

BIZTALK_CONFIGDATA_TYPE_SIGNATURE

[4] Configures the signature verification on the messaging port.

BIZTALK_CONFIGDATA_TYPE_SERIALIZER

[5] Configures the serializer on the messaging port.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

GetConfigComponent

GetConfigData

SetConfigComponent

SetConfigData

Using Custom Components


BIZTALK_ENCODING_TYPE

Specifies the encoding type.

[Visual Basic]

Enum BIZTALK_ENCODING_TYPE

[C++]

enum BIZTALK_ENCODING_TYPE

Members

BIZTALK_ENCODING_TYPE_NONE

[1] Specifies that encoding is not used.

BIZTALK_ENCODING_TYPE_MIME

[2] Specifies Multipurpose Internet Mail Extensions (MIME) encoding.

BIZTALK_ENCODING_TYPE_CUSTOM

[3] Specifies custom encoding.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

EncodingType


BIZTALK_ENCRYPTION_TYPE

Specifies the encryption type.

[Visual Basic]

Enum BIZTALK_ENCRYPTION_TYPE

[C++]

enum BIZTALK_ENCRYPTION_TYPE

Members

BIZTALK_ENCRYPTION_TYPE_NONE

[1] Specifies that encryption is not used.

BIZTALK_ENCRYPTION_TYPE_CUSTOM

[2] Specifies custom encryption.

BIZTALK_ENCRYPTION_TYPE_SMIME

[4] Specifies Secure Multipurpose Internet Mail Extensions (S/MIME) encryption.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

EncryptionType


BIZTALK_OPENNESS_TYPE

Specifies the openness type.

[Visual Basic]

Enum BIZTALK_OPENNESS_TYPE

[C++]

enum BIZTALK_OPENNESS_TYPE

Members

BIZTALK_OPENNESS_TYPE_NOTOPEN

[1] Specifies that this instance of the object is not open.

BIZTALK_OPENNESS_TYPE_SOURCE

[2] Specifies that the source organization of this instance of the object is open.

BIZTALK_OPENNESS_TYPE_DESTINATION

[4] Specifies that the destination organization of this instance of the object is open.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: (cisapi.tlb)

Related Topics

Openness

Submit

SubmitSync


BIZTALK_OPENNESS_TYPE_EX

Specifies the openness type.

[Visual Basic]

Enum BIZTALK_OPENNESS_TYPE_EX

[C++]

enum BIZTALK_OPENNESS_TYPE_EX

Members

BIZTALK_OPENNESS_TYPE_EX_NOTOPEN

[1] Specifies that this instance of the object is not open.

BIZTALK_OPENNESS_TYPE_EX_SOURCE

[2] Specifies that the source organization of this instance of the object is open.

BIZTALK_OPENNESS_TYPE_EX_DESTINATION

[4] Specifies that the destination organization of this instance of the object is open.

BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW

[8] Specifies that BizTalk Server is receiving a document from an XLANG schedule instance.

BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW

[16] Specifies that BizTalk Server is sending a document to an XLANG schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Openness


BIZTALK_SIGNATURE_TYPE

Specifies the signature type.

[Visual Basic]

Enum BIZTALK_SIGNATURE_TYPE

[C++]

enum BIZTALK_SIGNATURE_TYPE

Members

BIZTALK_SIGNATURE_TYPE_NONE

[1] Specifies that there is no signature.

BIZTALK_SIGNATURE_TYPE_CUSTOM

[2] Specifies the custom signature of the document.

BIZTALK_SIGNATURE_TYPE_SMIME

[4] Specifies the S/MIME signature of the document.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

SignatureType


BIZTALK_STORE_TYPE

Specifies the store type of the certificate.

[Visual Basic]

Enum BIZTALK_STORE_TYPE

[C++]

enum BIZTALK_STORE_TYPE

Members

BIZTALK_STORE_TYPE_MY

[1] Specifies that the certificate store is type MY. This store contains certificates authorized only by your organization.

BIZTALK_STORE_TYPE_BIZTALK

[2] Specifies that the certificate is stored in the dedicated BizTalk Server 2002 store.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Certificates

Store


BIZTALK_TRANSPORT_TYPE

Specifies the transport component type.

[Visual Basic]

Enum BIZTALK_TRANSPORT_TYPE

[C++]

enum BIZTALK_TRANSPORT_TYPE

Members

BIZTALK_TRANSPORT_TYPE_NONE

[1] Specifies that this instance of the object does not select a transport component.

BIZTALK_TRANSPORT_TYPE_HTTP

[4] Specifies that this instance of the object selects a Hypertext Transfer Protocol (HTTP) transport component.

BIZTALK_TRANSPORT_TYPE_SMTP

[8] Specifies that this instance of the object selects a Simple Mail Transfer Protocol (SMTP) transport component.

BIZTALK_TRANSPORT_TYPE_APPINTEGRATION

[32] Specifies that this instance of the object selects an application integration component (AIC) transport component.

BIZTALK_TRANSPORT_TYPE_MSMQ

[128] Specifies that this instance of the object selects a Microsoft Message Queuing transport component.

BIZTALK_TRANSPORT_TYPE_FILE

[256] Specifies that this instance of the object selects a file as a transport component.

BIZTALK_TRANSPORT_TYPE_HTTPS

[1024] Specifies that this instance of the object selects a Secure Hypertext Transfer Protocol (HTTPS) transport component.

BIZTALK_TRANSPORT_TYPE_OPENDESTINATION

[2048] Specifies that the messaging port is an open destination.

BIZTALK_TRANSPORT_TYPE_LOOPBACK

[4096] Specifies that the document submitted to the server with the SubmitSync method will be processed and then returned back as the response document of the method.

BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION

[8192] Specifies that the Address property contains the path of an XLANG schedule to be executed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Type


BIZTALK_USAGE_TYPE

Specifies the usage type of the certificate.

[Visual Basic]

Enum BIZTALK_USAGE_TYPE

[C++]

enum BIZTALK_USAGE_TYPE

Members

BIZTALK_USAGE_TYPE_ENCRYPTION

[1] Specifies that this is an encryption certificate.

BIZTALK_USAGE_TYPE_SIGNATURE

[2] Specifies that this is a signature certificate.

BIZTALK_USAGE_TYPE_BOTH

[4] Specifies that this certificate is used for both encryption and signature.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Certificates

Usage


Documents Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for working with documents:

  • Interfaces

  • Enumerations

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented:

  • IBizTalkTrackData

  • IBTSCustomProcess

  • IBTSCustomProcessContext

  • IInterchange


IBizTalkTrackData Interface

Use this object to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2002. This object complements the IInterchange object so that returns from IInterchange methods can be passed to these methods for reading tracking data about the documents submitted to BizTalk Server 2002.

Hierarchy

IDispatch

|--IBizTalkTrackData

Declaration

[Visual Basic]

Class BTSDocTracking

[C++]

interface IBizTalkTrackData : IDispatch

Members

IBizTalkTrackData defines the following methods:

Method | Description
GetInDocDetails | Returns an ADO recordset that contains a list of the documents that were submitted to BizTalk Server by using the Submit method.
GetInterchanges | Returns an ADO recordset that contains a list of interchanges that were submitted to BizTalk Server by using the Submit method, including all the data from the Tracking database.
GetOutDocDetails | Returns an ADO recordset that contains a list of the documents that were generated as a result of the Submit method.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema

Document Definitions

Reading the Tracking Database

Document Tracking


GetInDocDetails Method

Returns an ADO recordset that contains a list of the documents that were submitted to BizTalk Server by using the Submit method.

Member List

IBizTalkTrackData

|--GetInDocDetails

|--GetInterchanges

|--GetOutDocDetails

Method Declaration

[Visual Basic]

Function GetInDocDetails( _

SubmissionID As String _

) As Object

[C++]

HRESULT GetInDocDetails(

BSTR SubmissionID ,

IDispatch** Result

);

Parameters

SubmissionID

[in] Contains the SubmissionHandle string returned by Submit for this document instance.

Result

[out, retval] In C++, an IDispatch interface that contains a list of the documents that were included in the submission. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an Object that contains a list of the documents that were included in the submission.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method returns specific information for an input document.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema


GetInterchanges Method

Returns an ADO recordset that contains a list of interchanges that were submitted to BizTalk Server by using the Submit method, including all the data from the Tracking database.

Member List

IBizTalkTrackData

|--GetInDocDetails

|--GetInterchanges

|--GetOutDocDetails

Method Declaration

[Visual Basic]

Function GetInterchanges( _

SubmissionID As String _

) As Object

[C++]

HRESULT GetInterchanges(

BSTR SubmissionID ,

IDispatch** Result

);

Parameters

SubmissionID

[in] Contains the SubmissionHandle string returned by Submit for this interchange.

Result

[out, retval] In C++, an IDispatch interface that contains a list of the interchanges that were included in the submission, including all the data from the Tracking database. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method optionally returns an Object that contains a list of interchanges contained in this submission, including all the data from the Tracking database.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

You can check the Tracking database to confirm or check status on delivery because transport-specific information, such as delivery times and receipt flags, appears in the Tracking database.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema


GetOutDocDetails Method

Returns an ADO recordset that contains a list of the documents that were generated as a result of the Submit method.

Member List

IBizTalkTrackData

|--GetInDocDetails

|--GetInterchanges

|--GetOutDocDetails

Method Declaration

[Visual Basic]

Function GetOutDocDetails( _

SubmissionID As String _

) As Object

[C++]

HRESULT GetOutDocDetails(

BSTR SubmissionID ,

IDispatch** Result

);

Parameters

SubmissionID

[in] Contains the SubmissionHandle string returned by Submit for this document instance.

Result

[out, retval] In C++, an IDispatch interface that contains a list of the documents that were generated as a result of the submission. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an Object that contains a list of the documents that were generated as a result of the submission.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method returns specific information for an output document, for example, PO #123456 from a Submit call made on a specific date.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema


IBTSCustomProcess

Implement IBTSCustomProcess to create a custom preprocessor for BizTalk Server receive functions.

Hierarchy

IUnknown

|--IBTSCustomProcess

Declaration

[Visual Basic]

Class IBTSCustomProcess

[C++]

interface IBTSCustomProcess : IUnknown

Members

IBTSCustomProcess defines the following methods:

Method | Description
Execute | Performs the custom processing on data obtained from a receive function.
SetContext | Retrieves context information associated with the data being processed.

Remarks

For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Custom preprocessor components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Preprocessor components register themselves with the category ID CATID_BIZTALK_CUSTOM_PROCESS. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


Execute Method

Performs the custom processing on data obtained from a receive function.

Member List

IBTSCustomProcess

|--Execute

|--SetContext

Method Declaration

[Visual Basic]

Sub Execute( _

DataIn As Variant, _

CodePageIn As Long, _

IsFilePath As Boolean, _

CodePageOut As Variant, _

DataOut As Variant _

)

[C++]

HRESULT NAME(

VARIANT DataIn,

long CodePageIn,

VARIANT_BOOL IsFilePath,

VARIANT* CodePageOut,

VARIANT* DataOut

);

Parameters

DataIn

[in] In Visual Basic, contains the input data read by the receive function. For data read from a message queue, the data can be either an array or a String. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the IsFilePath parameter is set to True.

[in] In C++, contains the input data read by the receive function. For data read from a message queue, the data can be either an array or a BSTR. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the IsFilePath parameter is set to VARIANT_TRUE.

CodePageIn

[in] Contains the code page of the input data. The code page indicates the character set and keyboard layout used on a computer.

IsFilePath

[in] In Visual Basic, contains a value that indicates whether or not the DataIn parameter contains a file path. True indicates that the DataIn parameter contains a file path; False indicates that the DataIn parameter contains data from a message queue receive function.

[in] In C++, contains a value that indicates whether or not the DataIn parameter contains a file path. VARIANT_TRUE indicates that the DataIn parameter contains a file path; VARIANT_FALSE indicates that the DataIn parameter contains data from a message queue receive function.

CodePageOut

[in, out] Contains the code page of the output data. The code page indicates the character set and keyboard layout used on a computer.

DataOut

[in, out] In Visual Basic, contains the output data. For file receive functions, this will be a String. The data in this parameter is sent to BizTalk Server for processing.

[in, out] In C++, contains the output data. For file receive functions, this will be a BSTR. The data in this parameter is sent to BizTalk Server for processing.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If BizTalk Server fails to create the custom preprocessor component, or if the Execute method returns an error or invalid data, the document being processed is placed in the Suspended queue.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


SetContext Method

Retrieves information associated with a document submitted to BizTalk Server.

Member List

IBTSCustomProcess

|--Execute

|--SetContext

Method Declaration

[Visual Basic]

Sub SetContext( _

Ctx As IBTSCustomProcessContext _

)

[C++]

HRESULT SetContext(

IBTSCustomProcessContext* Ctx

);

Parameters

Ctx

[in] IBTSCustomProcessContext that contains information associated with the document being processed by BizTalk Server.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

For additional information about the custom process context object, see IBTSCustomProcessContext.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext

Retrieves information associated with data being processed by using a custom preprocessor component.

Hierarchy

IUnknown

|-- IBTSCustomProcessContext

Declaration

[Visual Basic]

Class IBTSCustomProcessContext

[C++]

interface IBTSCustomProcessContext: IUnknown

Members

IBTSCustomProcessContext defines the following properties:

Property | Description
ChannelName | Contains the name of the channel.used for processing the current document.
DestID | Contains the value of the destination organization qualifier.
DestQualifier | Contains the destination organization qualifier type.
DocName | Contains the name of the document definition used by the current document.
EnvelopeName | Contains the name of the envelope used with the current document.
Openness | Contains the openness value associated with the messaging port.
PassThrough | Contains a value indicating whether the document uses pass-through submission mode.
SourceID | Contains the value of the source organization qualifier.
SourceQualifier | Contains the source organization qualifier type.

Remarks

This object can be obtained by calling the SetContext method on the IBTSCustomProcess object. For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


ChannelName Property

Contains the name of the channel used for processing the current document.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property ChannelName As String

[C++]

HRESULT get_ChannelName(

BSTR* ChannelName

);

Parameters

ChannelName

[out, retval] In C++, contains the name of the channel used for processing the current document. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the channel.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


DestID Property

Contains the value of the destination organization qualifier.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property DestID As String

[C++]

HRESULT get_DestID(

BSTR* DestID

);

Parameters

DestID

[out, retval] In C++, contains the value of the destination organization qualifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the destination organization qualifier.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


DestQualifier Property

Contains the destination organization qualifier type.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property DestQualifier As String

[C++]

HRESULT get_DestQualifier(

BSTR* DestQualifier

);

Parameters

DestQualifier

[out, retval] In C++, contains the value of the destination organization type. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the destination organization qualifier type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


DocName Property

Contains the name of the document definition used by the current document.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property DocName As String

[C++]

HRESULT get_DocName(

BSTR* DocName

);

Parameters

DocName

[out, retval] In C++, contains the document definition name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the document definition.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


EnvelopeName Property

Contains the name of the envelope used with the current document.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property EnvelopeName As String

[C++]

HRESULT get_EnvelopeName(

BSTR* EnvName

);

Parameters

EnvName

[out, retval] In C++, contains the envelope name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the envelope.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


Openness Property

Contains the openness value associated with the messaging port.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property Openness As Long

[C++]

HRESULT get_Openness(

long* Openness

);

Parameters

Openness

[out, retval] In C++, indicates the openness on the messaging port. Valid values for this parameter are defined by the BIZTALK_OPENNESS_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_OPENNESS_TYPE enumeration.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


PassThrough Property

Contains a value indicating whether the document uses pass-through submission mode.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property PassThrough As Long

[C++]

HRESULT get_PassThrough(

long* PassThrough

);

Parameters

PassThrough

[out, retval] In C++, indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


SourceID Property

Contains the value of the source organization qualifier.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property SourceID As String

[C++]

HRESULT get_SourceID(

BSTR* SourceID

);

Parameters

SourceID

[out, retval] In C++, contains the value of the source organization qualifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the source organization qualifier.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


SourceQualifier Property

Contains the source organization qualifier type.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property SourceQualifier As String

[C++]

HRESULT get_SourceQualifier(

BSTR* SourceQualifier

);

Parameters

SourceQualifier

[out, retval] In C++, contains the value of the source organization type. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the source organization qualifier type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IInterchange

Use this object to exchange documents between applications and BizTalk Server 2002 directly or through a receive function

Hierarchy

IDispatch

|--IInterchange

Declaration

[Visual Basic]

Class Interchange

[C++]

interface IInterchange : IDispatch

Members

IInterchange defines the following methods:

Method | Description
CheckSuspendedQueue | Returns a list of documents from the Suspended queue that match the request criteria.
DeleteFromSuspendedQueue | Deletes all specified documents from the Suspended queue.
GetSuspendedQueueItemDetails | Retrieves information about a single entry in the Suspended queue.
Submit | Sends an interchange or document to BizTalk Server 2002 for asynchronous processing. BizTalk Server 2002 places the document in a queue until the next available server can process it.
SubmitSync | Sends an interchange or document to BizTalk Server 2002 for synchronous processing. An optional response document is returned to the caller.

Remarks

Using parameters with Submit and SubmitSync overrides certain fields in the header of a self-routing document.

For information about submitting documents from a remote client, see How To.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Direct Integration

Submitting

Routing

Submitting Documents

Submitting a Document


CheckSuspendedQueue Method

Returns a list of documents from the Suspended queue that match the request criteria.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Function CheckSuspendedQueue( _

DocName As String, _

SourceName As String, _

DestName As String_

)

[C++]

HRESULT CheckSuspendedQueue(

BSTR DocName,

BSTR SourceName,

BSTR DestName,

VARIANT* DocumentHandleList

);

Parameters

DocName

[in] Contains the name of the IBizTalkDocument object. This parameter narrows the search for items in the Suspended queue. If this parameter is omitted, this method matches all IBizTalkDocument objects. This is an optional parameter.

SourceName

[in] Contains the name of the source IBizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all IBizTalkOrganization objects. This is an optional parameter.

DestName

[in] Contains the name of the destination IBizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all IBizTalkOrganization objects. This is an optional parameter.

DocumentHandleList

[out, retval] In C++, contains a list of handles to all documents in the Suspended queue. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a list of handles to all documents in the Suspended queue.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The returned items are not deleted from the queue. To delete items from the Suspended queue, use the DeleteFromSuspendedQueue method.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Submitting a Document


DeleteFromSuspendedQueue Method

Deletes all specified documents from the Suspended queue.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Sub DeleteFromSuspendedQueue( _

DocumentHandleList As Variant _

)

[C++]

HRESULT DeleteFromSuspendedQueue(

VARIANT* DocumentHandleList

);

Parameters

DocumentHandleList

[in] Contains a full list of handles or a subset for documents to be deleted from the Suspended queue.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Submitting a Document


GetSuspendedQueueItemDetails Method

Retrieves information about a single entry in the Suspended queue.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Sub GetSuspendedQueueItemDetails( _

ItemHandle As String, _

SourceName As Variant, _

DestName As Variant, _

DocName As Variant, _

ReasonCode As Variant, _

ItemData As Variant

)

[C++]

HRESULT GetSuspendedQueueItemDetails(

BSTR ItemHandle,

VARIANT* SourceName,

VARIANT* DestName,

VARIANT* DocName,

VARIANT* ReasonCode,

VARIANT* ItemData

);

Parameters

ItemHandle

[in] Contains the handle of an item in the Suspended queue. This value can be obtained by calling the CheckSuspendedQueue method.

SourceName

[out] Contains the name of the source IBizTalkOrganization object.

DestName

[out] Contains the name of the destination IBizTalkOrganization object.

DocName

[out] Contains the name of the IBizTalkDocument object.

ReasonCode

[out] Contains the reason a document or interchange has been placed in the Suspended queue. For more information about this value, see the CISReasonToQueue enumeration.

ItemData

[out] Contains the document instance or interchange.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Submitting a Document


Submit Method

Sends an interchange or document to BizTalk Server 2002 for asynchronous processing. BizTalk Server 2002 places the document in a queue until the next available server can process it.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Function Submit( _

Openness As BIZTALK_OPENNESS_TYPE, _

Document As String, _

DocName As String, _

SourceQualifier As String, _

SourceID As String, _

DestQualifier As String, _

DestID As String, _

ChannelName As String, _

FilePath As String, _

EnvelopeName As String, _

PassThrough As Long

) As String

[C++]

HRESULT Submit(

BIZTALK_OPENNESS_TYPE Openness,

BSTR Document,

BSTR DocName,

BSTR SourceQualifier,

BSTR SourceID,

BSTR DestQualifier,

BSTR DestID,

BSTR ChannelName,

BSTR FilePath,

long EnvelopeName,

BSTR* PassThrough,

BSTR* SubmissionHandle

);

Parameters

Openness

[in] Indicates whether associated IBizTalkPort objects can be open. Valid values are defined by the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] Contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, IDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] Contains the name of the IBizTalkDocument object associated with the instance of the document being submitted. If the Openness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input IBizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output IBizTalkDocument must not have an X12 or EDIFACT specification. If Openness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the IBizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] Contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the Data Universal Numbering System (D-U-N-S) number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] Contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] Contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. You must specify a DestID. The default qualifier for all new organizations is OrganizationName and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] Contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] Contains the name of the IBizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] Specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2002 supports URL, UNC, and drive: format only. If the document is submitted as a file that is pointed to by the FilePath parameter, the call returns successfully after BizTalk Server 2002 has successfully copied the file to the Work queue. It is safe to delete the file from the specified path as soon as this method returns successfully. When a document is submitted to the server, using FilePath to specify the data, Submit can take 30 seconds or longer if the location of the file resides on a remote server that is unavailable, if the UNC path is invalid, or if the SQL server is down. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] Contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. When submitting a flat file to BizTalk Server 2002, you must create an envelope for this flat file and specify the name of the envelope in EnvelopeName. This is an optional parameter.

PassThrough

[in] Indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out, retval] In C++, contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned, yet the Tracking database enables the user to get the status of all child documents related to this interchange identifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Submitting a Document


SubmitSync Method

Sends an interchange or document to BizTalk Server 2002 for synchronous processing. An optional response document is returned to the caller.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Sub SubmitSync( _

Openness As BIZTALK_OPENNESS_TYPE, _

Document As String, _

DocName As String, _

SourceQualifier As String, _

SourceID As String, _

DestQualifier As String, _

DestID As String, _

ChannelName As String, _

FilePath As String, _

EnvelopeName As String, _

PassThrough As Long, _

SubmissionHandle As Variant, _

ResponseDocument As Variant

)

[C++]

HRESULT SubmitSync(

BIZTALK_OPENNESS_TYPE Openness,

BSTR Document,

BSTR DocName,

BSTR SourceQualifier,

BSTR SourceID,

BSTR DestQualifier,

BSTR DestID,

BSTR ChannelName,

BSTR FilePath,

long EnvelopeName,

BSTR* PassThrough,

VARIANT* SubmissionHandle,

VARIANT* ResponseDocument

);

Parameters

Openness

[in] Indicates whether associated IBizTalkPort objects can be open. Valid values are defined by the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] Contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, IDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] Contains the name of the IBizTalkDocument object associated with the instance of the document submitted. If the Openness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input IBizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output IBizTalkDocument must not have an X12 or EDIFACT specification. If Openness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the IBizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] Contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] Contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] Contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. You must specify a DestID parameter. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] Contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] Contains the name of the IBizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] Specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2002 supports URL, UNC, and drive: format only. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] Contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. This is an optional parameter.

PassThrough

[in] Indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out] Contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

ResponseDocument

[out] Contains the optional response document.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

SubmitSync returns an optional response document when provided. If no response is returned, the call returns successfully, but with no response and with an HRESULT value of S_FALSE. If the destination is another BizTalk Server, an ASP page must be used to return a response.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols (HTTP and AIC), an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Submitting a Document


Enumerations

The following enumeration provides possible property and parameter values:

  • CISReasonToQueue


CISReasonToQueue

Describes the reasons a document was placed in a queue.

[Visual Basic]

Enum CISReasonToQueue_tag

[C++]

enum CISReasonToQueue

Members

noReason

[0] Not supported for this release.

rtdlqParserFailure

[1] Specifies that the instance of the document was placed in the queue because of failure of the parser.

rtdlqParserDocFailure

[2] Specifies that the instance of the document was placed in the queue because the business document was invalid.

rtdlqDocValidation

[3] Specifies that the document was placed in the queue because document validation failed.

rtdlqChannelSelectFailure

[4] Specifies that the instance of the document was placed in the queue because of failure in selecting the correct IBizTalkChannel object.

rtdlqInvalidMap

[5] Specifies that the instance of the document was placed in the queue because the map referred to by the BizTalkChannel object was formatted incorrectly.

rtdlqFieldTrackingFailure

[6] Specifies that the instance of the document was placed in the queue because the server was unable to track the requested fields within the document.

rtdlqMappingFailure

[7] Specifies that the instance of the document was placed in the queue because of failure of transformation.

rtdlqSerializerFailure

[8] Specifies that the instance of the document was placed in the queue because the server could not convert this document to its native format.

rtdlqEncodingFailure

[9] Specifies that the instance of the document was placed in the queue because the server was unable to encode this interchange.

rtdlqSigningFailure

[10] Specifies that the instance of the document was placed in the queue because the server was unable to sign this interchange.

rtdlqEncryptionFailure

[11] Specifies that the instance of the document was placed in the queue because the server was unable to encrypt this interchange.

rtdlqTransmissionFailure

[12] Specifies that the instance of the document was placed in the queue because the server was unable to deliver this document.

rtdlqUserMove

[13] Specifies that the administrator moved this instance of the document to the queue.

rtdlqTimeout

[14] Specifies that the instance of the document was placed in the queue because a time-out occurred.

rtdlqCustomCompFailure

[15] Specifies that the instance of the document was placed in the queue because of failure of a custom component.

unkReason

[16] Specifies that this item was marked as "In process" by an inactive server. On restart of this server, this item was automatically moved to the Suspended queue. There was probably a catastrophic failure on the original server. Contact the system administrator for more information.

rtdlqNoChannel

[17] Specifies that the instance of the document was placed in the queue because the BizTalkChannel object was deleted.

rtdlqMissingChannel

[18] Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface was not found.

rtdlqInvalidChannel

[19] Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface specifies an open IBizTalkPort object. This is not permitted.

rtdlqOutOfMemory

[20] Specifies that your computer has run out of memory. Rebooting is recommended.

rtdlqBTFRecReqExpired

[21] Specifies that the document was placed in the queue because the BTF timestamp receiptRequiredBy expired.

rtdlqBTFExpiresAtExpired

[22] Specifies that the document was placed in the queue because the BTF timestamp expiresAt expired.

rtdlqCorrelationFailure

[23] Specifies that the document receipt failed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

GetSuspendedQueueItemDetails


Custom Components Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for working with custom components:

  • Interfaces

  • Enumerations

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented for C++ developers:

  • IBizTalkParserComponent

  • IBizTalkSerializerComponent

The following COM interfaces are documented for both C++ and Visual Basic developers:

  • IBizTalkAcknowledge

  • IBizTalkCorrelation

  • IBTSAppIntegration

  • IFunctoid

  • IPipelineComponent

  • IPipelineComponentAdmin

  • ISchemaImporter

  • ISchemaImporterError

  • ISchemaImporterErrorProvider


IBizTalkAcknowledge

Processes receipts sent to the server.

Hierarchy

IUnknown

|--IBizTalkAcknowledge

Declaration

[Visual Basic]

Class IBizTalkAcknowledge

[C++]

interface IBizTalkAcknowledge : IUnknown

Members

IBizTalkAcknowledge defines the following methods:

Method | Description
AckDocument | Processes receipts received for documents.
AckGroup | Processes receipts received for document groups.
AckInterchange | Processes receipts received for document interchanges.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Creating Receipt Correlator Components

How Receipts Are Logged

Understanding Receipts


AckDocument Method

Processes receipts received for documents.

Member List

IBizTalkAcknowledge

|--AckDocument

|--AckGroup

|--AckInterchange

Method Declaration

[Visual Basic]

Sub AckDocument( _

Syntax As String, _

TrackingId As String, _

AckStatus As DTA_ACK_STATUS _

)

[C++]

HRESULT AckDocument(

BSTR Syntax,

BSTR TrackingId,

DTA_ACK_STATUS AckStatus

);

Parameters

Syntax

[in] Contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT.

TrackingId

[in] Contains the globally unique identifier (GUID) for tracking the document. This value can be obtained from the Tracking_ID field in the dta_outdoc_details table. For more information, see Supporting the Tracking Database with Parser and Serializer Components.

AckStatus

[in] Indicates the receipt status. Valid values for this parameter are defined by the DTA_ACK_STATUS enumeration.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only for receipts on individual documents. If the receipt needs to be mapped, a document definition that points to CanonicalReceipt.xml shipped in WebDAV must be created for the receipt.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


AckGroup Method

Processes receipts received for document groups.

Member List

IBizTalkAcknowledge

|--AckDocument

|--AckGroup

|--AckInterchange

Method Declaration

[Visual Basic]

Sub AckGroup( _

Syntax As String, _

Version As String, _

Release As String, _

FunctionalGroupId As String, _

ControlId As String, _

SrcAppName As String, _

DestAppName As String, _

AckStatus As DTA_ACK_STATUS _

)

[C++]

HRESULT AckGroup(

BSTR Syntax,

BSTR Version,

BSTR Release,

BSTR FunctionalGroupId,

BSTR ControlId,

BSTR SrcAppName,

BSTR DestAppName,

DTA_ACK_STATUS AckStatus

);

Parameters

Syntax

[in] Contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

Version

[in] Contains the version of the syntax, used primarily for EDI.

Release

[in] Contains the release of the version of the syntax, used primarily for EDI.

FunctionalGroupId

[in] Contains the code for the type of documents in a group, used primarily for EDI.

ControlId

[in] Contains the unique identifier for the control number, used primarily for EDI.

SrcAppName

[in] Contains the name of the source application.

DestAppName

[in] Contains the name of the destination application.

AckStatus

[in] Indicates the receipt status. Valid values are defined by the DTA_ACK_STATUS enumeration.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only for receipts on document groups.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


AckInterchange Method

Processes receipts received for document interchanges.

Member List

IBizTalkAcknowledge

|--AckDocument

|--AckGroup

|--AckInterchange

Method Declaration

[Visual Basic]

Sub AckInterchange( _

Syntax As String, _

InterchangeId As String, _

Version As String, _

ControlId As String, _

SrcAliasQualifier As String, _

SrcAliasId As String, _

SrcAppName As String, _

DestAliasQualifier As String, _

DestAliasId As String, _

DestAppName As String, _

AckStatus As DTA_ACK_STATUS _

)

[C++]

HRESULT AckInterchange(

BSTR Syntax,

BSTR InterchangeId,

BSTR Version,

BSTR ControlId,

BSTR SrcAliasQualifier,

BSTR SrcAliasId,

BSTR SrcAppName,

BSTR DestAliasQualifier,

BSTR DestAliasId,

BSTR DestAppName,

DTA_ACK_STATUS AckStatus

);

Parameters

Syntax

[in] Contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

InterchangeId

[in] Contains the unique tracking identifier of the interchange. This value is a globally unique identifier (GUID).

Version

[in] Contains the version of the syntax, used primarily for EDI.

ControlId

[in] Contains the unique identifier for the control number, used primarily for EDI.

SrcAliasQualifier

[in] Contains the qualifier of the source organization. This indicates how the bstrSrcAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the Data Universal Numbering System (D-U-N-S) number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

SrcAliasId

[in] Contains the value of the qualifier of the source organization. For example, if the bstrSrcAliasQualifier parameter is Telephone, this value is the telephone number.

SrcAppName

[in] Contains the name of the source application.

DestAliasQualifier

[in] Contains the qualifier of the source organization. This indicates how the bstrDestAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

DestAliasId

[in] Contains the value of the qualifier of the source organization. For example, if the bstrDestAliasQualifier parameter is Telephone, this value is the telephone number.

DestAppName

[in] Contains the name of the destination application.

AckStatus

[in] Indicates the receipt status. Valid values are defined by the DTA_ACK_STATUS enumeration.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only for receipts on document interchanges.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


IBizTalkCorrelation

Creates receipt correlator components.

Hierarchy

IUnknown

|--IBizTalkCorrelation

Declaration

This interface is only supported in C++

interface IBizTalkCorrelation : IUnknown

Members

IBizTalkCorrelation defines the following method:

Method | Description
Correlate | Extracts all relevant information from the document, document group, or interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Creating Receipt Correlator Components


Correlate Method

Extracts all relevant information from the document, document group, or interchange.

Member List

IBizTalkCorrelation

|--Correlate

Method Declaration

This method is only supported in C++

HRESULT Correlate(

IUnknown* Acknowledge,

IDictionary* Dict

);

Parameters

Acknowledge

[in] An IBizTalkAcknowledge interface used to invoke and set the receipt flag.

Dict

[in] An IDictionary interface of an object that contains the receipt information.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h


IFunctoid

Creates custom mapping functions. IFunctoid defines the generic protocol for calling custom functions used by the mapping tool.

Hierarchy

IDispatch

|--IFunctoid

Declaration

[Visual Basic]

Class CannedFunctoid

[C++]

interface IFunctoid : IDispatch

Members

IFunctoid defines the following properties:

Property | Description
FunctionsCount | Contains the number of functions implemented by the functoid.
Version | Contains the version of the functoid.

IFunctoid defines the following methods:

Method | Description
GetFunctionDescripter | Retrieves information about a specific functoid.
GetFunctionParameter | Retrieves the connection-type bit flags for the specified parameter.
GetScriptBuffer | Retrieves the script code used to implement the functoid.

Remarks

Custom functoids must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Functoids register themselves with the category ID CATID_BIZTALK_MapEditFunctoids. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Each custom functoid can support multiple functions and can contain icons and names for each supported function. Function identifiers from 0 to 1000 are reserved for built-in functions in BizTalk Mapper. User-defined functions (custom functions) should use function identifiers 1001 and above.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


FunctionsCount Property

Contains the number of functions implemented by the functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Property Declaration

[Visual Basic]

Property FunctionsCount As Long

[C++]

HRESULT get_FunctionsCount(

long* Count

);

Parameters

Count

[out, retval] In C++, contains the number of functions implemented by the functoid. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of functions implemented by the functoid.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


GetFunctionDescripter Method

Retrieves information about a specific functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Method Declaration

[Visual Basic]

Function GetFunctionDescripter( _

Index As Long, _

FuncCategory As FUNC_CATEGORY, _

ScriptCategory As SCRIPT_CATEGORY, _

FuncType As FUNC_TYPE, _

Name As String, _

ToolTip As String, _

BitmapID As Long, _

ParmCount As Long _

) As Long

[C++]

HRESULT GetFunctionDescripter(

long Index,

FUNC_CATEGORY* FuncCategory,

SCRIPT_CATEGORY* ScriptCategory,

FUNC_TYPE* FuncType,

BSTR* Name,

BSTR* ToolTip,

long* BitmapID,

long* ParmCount,

FUNCID* FuncId

);

Parameters

Index

[in] Specifies the index number of the function.

FuncCategory

[in, out] Contains a value indicating the tab on the functoid palette on which the custom functoid will appear. Valid values for this parameter are defined by the FUNC_CATEGORY enumeration.

ScriptCategory

[in, out] Contains the scripting language used by the custom functoid. Valid values for this parameter are defined by the SCRIPT_CATEGORY enumeration.

FuncType

[in, out] Contains the function type information for the custom functoid. Valid values for this parameter are defined by the FUNC_TYPE enumeration.

Name

[in, out] Contains the function name.

ToolTip

[in, out] Contains the ToolTip that appears when the mouse pointer is paused over the custom functoid icon in the mapping tool.

BitmapID

[in, out] Contains a bitmap identifier of the bitmap used for the custom functoid icon displayed in the mapping tool.

ParmCount

[in, out] Contains the number of parameters implemented by the function.

FuncId

[out, retval] In C++, contains the function identifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the function identifier.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


GetFunctionParameter Method

Retrieves the connection-type bit flags for the specified parameter.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Method Declaration

[Visual Basic]

Function GetFunctionParameter( _

FuncId As Long, _

Parameter As Long _

) As Long

[C++]

HRESULT GetFunctionParameter(

FUNCID FuncId,

long Parameter,

long* ConnectionType

);

Parameters

FuncId

[in] Contains the function identifier.

Parameter

[in] Contains the function parameter number. For output parameters, a value of -1 is used.

ConnectionType

[out, retval] In C++, contains the connection type information of the specified parameter. Valid values for this parameter are defined by the CONNECTION_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the connection type information of the specified parameter. Valid values for this parameter are defined by the CONNECTION_TYPE enumeration.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


GetScriptBuffer Method

Retrieves the script code used to implement the functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Method Declaration

[Visual Basic]

Function GetScriptBuffer( _

FuncId As Long, _

InputParameters As Long _

) As String

[C++]

HRESULT GetScriptBuffer(

FUNCID FuncId,

long InputParameters,

BSTR* ScriptBuffer

);

Parameters

FuncId

[in] Contains the function identifier.

InputParameters

[in] Indicates the number of connected input parameters for the specified function.

ScriptBuffer

[out, retval] In C++, contains the script code used to implement the function. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the script code used to implement the function.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


Version Property

Contains the version of the functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Property Declaration

[Visual Basic]

Property Version As Long

[C++]

HRESULT get_Version(

long* Version

);

Parameters

Version

[out, retval] In C++, contains the custom functoid version. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the custom functoid version.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

If the custom functoid is modified in any way, the author should update the version number.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IBizTalkParserComponent

Converts a document to XML for later processing and identifies the IBizTalkChannel objects necessary to process the documents.

Hierarchy

IUnknown

|--IBizTalkParserComponent

Declaration

This interface is only supported in C++

interface IBizTalkParserComponent : IUnknown

Members

IBizTalkParserComponent defines the following methods:

Method | Description
GetGroupDetails | Gets details of the group for the Tracking database. This method is called only if there are groups in the interchange.
GetGroupSize | Gets the size of the group after all documents in the group are parsed. This method is called only if there are groups in the interchange.
GetInterchangeDetails | Gets information about the organization identifiers of the source and destination IBizTalkOrganization objects.
GetNativeDocumentOffsets | Identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.
GetNextDocument | Examines the data in a document and determines when to get the next document if this is not the last document.
GroupsExist | Determines whether the interchange contains groups.
ProbeInterchangeFormat | Identifies the format of the interchange.

Remarks

Custom parser components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Parser components register themselves with the category ID CATID_BIZTALK_PARSER. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Identification

Working with Parsers

Parsers


GetGroupDetails Method

Gets details of the group for the Tracking database. This method is called only if there are groups in the interchange.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetGroupDetails(

IDictionary* Dict

);

Parameters

Dict

[in] IDictionary interface of an object that contains details about the group. All information is returned as string types, no matter how it appears in the data.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only if groups are detected in the interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetGroupSize Method

Gets the size of the group after all documents in the group are parsed. This method is called only if there are groups in the interchange.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetGroupSize(

long* GroupSize,

BOOL* LastGroup

);

Parameters

GroupSize

[out] Contains the size of the interchange.

LastGroup

[out] Indicates whether the group is the last group in the interchange. If this parameter is set to TRUE, the next method called is GetGroupDetails for the next group in the data. If it is set to FALSE, the component is finished. When it is released, it leaves the IStream interface after the last byte it has read.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

After all documents in the group are called, the final details about the group are required. Both output parameters are added to the Tracking database for final logging.

This method is called only if there are groups in the interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetInterchangeDetails Method

Gets information about the organization identifiers of the source and destination IBizTalkOrganization objects.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetInterchangeDetails(

IDictionary* Dict

);

Parameters

Dict

[in] IDictionary interface of an object that contains information about the organization identifiers of the source and destination IBizTalkOrganization objects.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The minimum sets of fields are:

Field | Description
src_id_type | Source qualifier
src_id_value | Source ID
dest_id_type | Destination qualifier
dest_id_value | Destination ID

The parameters of the Submit method of the IInterchange interface override any fields set here.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetNativeDocumentOffsets Method

Identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetNativeDocumentOffsets(

BOOL SizeFromXMLDoc,

LARGE_INTEGER* StartOffset,

long* DocLength

);

Parameters

SizeFromXMLDoc

[out] Indicates whether the XML document passed in from the GetNextDocument method was used to determine the size. If this parameter is TRUE, the server fills in the StartOffset and DocLength values for the document just parsed. If this parameter is FALSE, the server ignores the values in StartOffset and DocLength.

StartOffset

[out] Contains the location of the beginning of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

DocLength

[out] Contains the length of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called immediately after GetNextDocument whether or not the document is valid (as long as the parser does not return an error value). These are offsets into the IStream object relative to the beginning of the stream, not the beginning of the interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetNextDocument Method

Examines the data in a document and determines when to get the next document if this is not the last document.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetNextDocument(

IDictionary* Dict,

BSTR DocSpecName,

BOOL* DocIsValid,

BOOL* LastDocument,

GeneratedReceiptLevel ReceiptGenerated,

BOOL* DocIsReceipt,

BSTR* CorrelationCompProgID

);

Parameters

Dict

[in] IDictionary interface of an object into which to set the XML instance created on parsing the current document. The parsed XML document is placed into the working_data field of the dictionary.

DocSpecName

[in] Contains the name of the BizTalk document specification used to generate the XML from the document's native format.

DocIsValid

[out] Indicates whether the document instance is valid. If it is invalid but the parser can recover from it, set this parameter to FALSE. This parameter and the LastDocument parameter are independent. Therefore, if there are no more documents and the last one is invalid, both flags are set. If the document is invalid and the parser cannot continue, it might return an error value. The server then stops at the current position of the IStream pointer. The component places the invalid data (if the parser can recover) in the working_data field for inspection by the system administrator if the document is invalid.

LastDocument

[out] Indicates whether this is the last document instance in the group or interchange. When the last document is found, the LastDocument flag is set to TRUE. If there are groups, this flag signals the last document in the group, and the GetGroupSize method is called. If there are no groups, this is the last call to get document data from the parser, and the IStream pointer is set appropriately.

ReceiptGenerated

[out] Contains the receipt status information. Valid values are defined by the GeneratedReceiptLevel enumeration.

DocIsReceipt

[out] Identifies whether or not this document is a receipt.

CorrelationCompProgID

[out] Contains the program ID for the correlation of documents.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GroupsExist Method

Determines whether the interchange contains groups.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GroupsExist(

BOOL* GrpsExist

);

Parameters

GrpsExist

[out, retval] Indicates whether the data format contains groups. If this parameter is set to FALSE, the GetGroupDetails and GetGroupSize methods are never called.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


ProbeInterchangeFormat Method

Identifies the format of the interchange.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT ProbeInterchangeFormat(

IStream* pData,

BOOL FromFile,

BSTR EnvName,

IStream* pReceiptData,

BSTR* Format

);

Parameters

pData

[in] IStream object that contains the data for the document interchange. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

FromFile

[in] Contains a value that indicates whether or not the data came from the FilePath parameter of the Submit or the SubmitSync method of the IInterchange interface. TRUE indicates that the data came from the file referred to by the FilePath parameter. FALSE indicates that the data came from the Document parameter of Submit or SubmitSync as a string. If the data is from a file, no conversion is made. If the data is a string, you can use UNICODE/MBCS techniques to understand it.

EnvName

[in] Contains the name of the envelope.

pReceiptData

[in] IStream object that contains the receipt document.

Format

[out] Contains the format of the data. If the server recognizes the format, it must fill in this parameter with a non-empty string and hold on to (add a reference count to) the IStream interface because it is not given back to the component. This IStream object is read-only; it supports only the Read, Stat, and Seek methods. All other methods return E_NOTIMPL. This method should not return a failure if it does not recognize the format. It returns S_FALSE or an empty or NULL Format string. If you do not recognize the format, you do not need to move the IStream pointer back to its original position; the server resets the IStream pointer. Unless your format requires it, do not assume that the pointer is at the beginning. The pointer can be somewhere in the middle during the probing stage.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is the first method that is called by the server. If ProbeInterchangeFormat returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


IBizTalkSerializerComponent

Converts a document from XML to the document's original native format.

Hierarchy

IUnknown

|--IBizTalkSerializerComponent

Declaration

This interface is only supported in C++

interface IBizTalkSerializerComponent : IUnknown

Members

IBizTalkSerializerComponent defines the following methods:

Method | Description
AddDocument | Adds an XML document for storage by the serializer component.
GetDocInfo | Gets details of the document.
GetGroupInfo | Gets details of the group, such as size and offset, for the Tracking database.
GetInterchangeInfo | Gets information about the interchange created.
Init | Outputs the document instance to the serializer component and indicates where it should be sent.

Remarks

Custom serializer components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Serializer components register themselves with the category ID CATID_BIZTALK_SERIALIZER. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


AddDocument Method

Adds an XML document for storage by the serializer component.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT AddDocument(

long DocHandle,

IDictionary* Transport,

BSTR TrackID,

long ChannelID

);

Parameters

DocHandle

[in] Contains the handle to the document that is stored by the component and later retrieved when calling the GetDocInfo method. This parameter supports out-of-order recreation of the interchange in case the documents need to be reordered (such as in X12).

Transport

[in] Contains an IDictionary interface of an object that contains the XML document to be stored. It is on the working_data field. This parameter cannot be set by the component. This is an optional parameter.

TrackID

[in] Contains the document tracking ID used by the server.

ChannelID

[in] Contains the IBizTalkChannel object associated with the current document.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only once per interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


GetDocInfo Method

Gets details of the document.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT GetDocInfo(

long* DocHandle,

BOOL* SizeFromXMLDoc,

LARGE_INTEGER* DocStartOffset,

long* DocLen

);

Parameters

DocHandle

[out] Contains the document handle. For each ID that is passed back, this address is assigned to the group record that was created when the GetGroupInfo method was called. This parameter also returns properties of the document, for example, size and length, unless the SizeFromXMLDoc parameter is set to TRUE, in which case the other parameters are ignored.

SizeFromXMLDoc

[out] Indicates that the document offset and length values are retrieved from the XML document. TRUE indicates that the server fills in the DocStartOffset and DocLen values for the document; FALSE indicates that the server ignores the values in DocStartOffset and DocLen.

DocStartOffset

[out] Contains the offset to the beginning of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

DocLen

[out] Contains the length of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called once for every document in a group (or interchange, if there are no groups).

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


GetGroupInfo Method

Gets details of the group, such as size and offset, for the Tracking database.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT GetGroupInfo(

long* NumDocs,

LARGE_INTEGER* GrpStartOffset,

long* GrpLen

);

Parameters

NumDocs

[out] Contains the number of documents in the group.

GrpStartOffset

[out] Contains the offset to the start of the group in the IStream interface.

GrpLen

[out] Contains the length of the group.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called the number of times returned by the GetInterchangeInfo method. Call the GetDocInfo method for each document in the group.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Serializers


GetInterchangeInfo Method

Gets information about the interchange created.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT GetInterchangeInfo(

BSTR* InterchangeID,

long* NumGroups

);

Parameters

InterchangeID

[out] Contains the interchange ID, which is placed in the Tracking database.

NumGroups

[out] Contains the number of groups generated in the interchange. This value can be either 0 or 1. A document can exist in only one group.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called after all the documents are passed in.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


Init Method

Outputs the document instance to the serializer component and indicates its destination.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT Init(

BSTR srcQual,

BSTR srcID,

BSTR destQual,

BSTR destID,

long envID,

IDictionary* Delimiters,

Istream* OutputStream,

long NumDocs

);

Parameters

srcQual

[in] Contains the source-organization identifier qualifier.

srcID

[in] Contains the source-organization identifier value.

destQual

[in] Contains the destination-organization identifier qualifier.

destID

[in] Contains the destination-organization identifier value.

EnvID

[in] Contains the envelope identifier value.

Delimiters

[in] Contains an IDictionary interface of an object that contains the delimiters used in the document.

OutputStream

[in] Contains an IStream interface that contains the data of this document. This IStream pointer is write-only. The only methods that are supported are Write and Stat; all other methods return E_NOTIMPL. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

NumDocs

[in] Contains the number of documents sent as part of this interchange. For this release, this parameter is set to 1.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


IBTSAppIntegration

Creates an entry point for receiving a document.

Hierarchy

IDispatch

|--IBTSAppIntegration

Declaration

[Visual Basic]

Class IBTSAppIntegration

[C++]

interface IBTSAppIntegration : IDispatch

Members

IBTSAppIntegration defines the following method:

Method | Description
ProcessMessage | Processes a document and returns a response document, if available. This method is called at run time when the server is sending a document to the component.

Remarks

Application integration components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)

Related Topics

Lightweight Application Integration Components

Application Integration in Visual Basic

Application Integration in Visual C++


ProcessMessage Method

Processes a document and returns a response document, if available. This method is called at run time when the server is sending a document to the component.

Member List

IBTSAppIntegration

|--ProcessMessage

Method Declaration

[Visual Basic]

Function ProcessMessage( _

Document As String _

) As String

[C++]

HRESULT ProcessMessage(

BSTR Document,

BSTR* ResponseDocument

);

Parameters

Document

[in] Contains the document to be processed.

ResponseDocument

[retval, out] In C++, contains the response document processed by the component, if available. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the response document, if available.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Components can return a response string to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface to send documents.

Components must raise an error if a problem with processing occurs so that the document can be retransmitted or sent to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IPipelineComponent

Creates custom pipeline components that can execute in Microsoft BizTalk Server 2002 to extend its functionality.

Hierarchy

IUnknown

|--IPipelineComponent

Declaration

[Visual Basic]

Class IPipelineComponent

[C++]

interface IPipelineComponent : IUnknown

Members

IPipelineComponent defines the following methods:

Method | Description
EnableDesign | Configures the component for execution in one of two modes: design mode or execution mode.
Execute | Executes the operation expected of the component, given the transport IDictionary object and other configuration settings.

Remarks

Application integration components must be properly registered so that BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topics

Application Integration Components

Pipeline Components in Visual Basic

Pipeline Components in Visual C++


EnableDesign Method

Configures the component for execution in one of two modes: design mode or execution mode.

Member List

IPipelineComponent

|--EnableDesign

|--Execute

Method Declaration

[Visual Basic]

Sub EnableDesign( _

Enable As Boolean _

)

[C++]

HRESULT EnableDesign(

BOOL Enable

);

Parameters

Enable

[in] Indicates the mode of the component. True specifies that the component runs in design mode. False specifies execution mode. The default value is False.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The pipeline component runs in execution mode by default.

This method is called when the Override messaging port defaults page is opened in the Channel Wizard's Advanced Configuration page. It is also called when the property page is closed and the Enable parameter is set to true. Design mode is not enabled unless this method has been called with the Enable parameter set to True.

Design-only fields are returned only when the Enable parameter is set to true. Otherwise, the IDictionary object passed to the server contains unnecessary information.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


Execute Method

Executes the operation expected of the component, given the transport IDictionary object and other configuration settings.

Member List

IPipelineComponent

|--EnableDesign

|--Execute

Method Declaration

[Visual Basic]

Function Execute( _

DispOrder As Object, _

DispContext As Object, _

Flags As Long _

) As Long

[C++]

HRESULT Execute(

IDispatch* DispOrder,

IDispatch* DispContext,

long Flags,

long* ErrorLevel

);

Parameters

DispOrder

[in] Transport IDictionary object.

DispContext

[in] Not supported for this release.

Flags

[in] Reserved.

ErrorLevel

[out, retval] Reserved.

Return Values

In Visual Basic, this method returns the error level.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Microsoft BizTalk Server 2002 calls this method, passing in the transport IDictionary object. The component can read these IDictionary object values, perform the necessary functions, and optionally write new values back to the transport IDictionary object for further processing.

For a component designed to run in BizTalk Server 2002, the first parameter is a Transport Dictionary object. The Transport Dictionary values can be read by the component for processing. The string values supplied by the server for all application integration components (AICs) are defined in the Handling Data Passed to AICs topic.

For a component that runs in a Commerce Server order-processing pipeline, the first parameter contains the OrderForm object.

This method is called at run time when the server is sending a document to the component. This method is called immediately after the SetConfigData method of the IPipelineComponentAdmin interface. The document is passed in the first parameter as a dictionary within the working_data field of the IDictionary object. Components can add the ResponseField key to the IDictionary object to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface.

The component must raise an error if a problem with processing occurs so that the server can retry transmission later and, after all retries, send the document to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


IPipelineComponentAdmin

Gets and sets configuration information for a component. Use IPipelineComponentAdmin between the component and the component user interface.

Hierarchy

IDispatch

|--IPipelineComponentAdmin

Declaration

[Visual Basic]

Class IPipelineComponentAdmin

[C++]

interface IPipelineComponentAdmin : IDispatch

Members

IPipelineComponentAdmin defines the following methods:

Method | Description
GetConfigData | Returns an IDictionary object that contains the configuration data for the component to be used to display these values.
SetConfigData | The SetConfigData method sets the configuration for a component, using the contents of an IDictionary object.

Remarks

Application integration components must be properly registered so that BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topics

Application Integration Components

Pipeline Components in Visual Basic

Pipeline Components in Visual C++


GetConfigData Method

Returns an IDictionary object that contains the configuration data for the component to be used to display these values.

Member List

IPipelineComponentAdmin

|--GetConfigData

|--SetConfigData

Method Declaration

[Visual Basic]

Function GetConfigData() As Object

[C++]

HRESULT GetConfigData(

IDispatch** ConfigDictionary

);

Parameters

ConfigDictionary

[out, retval] In C++, an IDictionary object from which the user interface can read the configuration data. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method optionally returns a CDictionary object from which the user interface can read the configuration data.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

GetConfigData enables the user interface component to read the current value from the component and display it on the property page initially.

When an IBizTalkPort object is first saved, this method is called to get the defaults for use in autoconfiguring the application integration component (AIC) from the IDictionary object provided. Components must provide defaults for all mandatory properties, whenever possible.

This method is called when the user selects the property page. It is used to supply property page defaults. It is called again when the property page is closed. The contents of this returned IDictionary object are not used.

Components must always return a valid dictionary pointer from GetConfigData.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


SetConfigData Method

The SetConfigData method sets the configuration for a component, using the contents of an IDictionary object.

Member List

IPipelineComponentAdmin

|--GetConfigData

|--SetConfigData

Method Declaration

[Visual Basic]

Sub SetConfigData( _

ConfigDictionary As Object _

)

[C++]

HRESULT SetConfigData(

IDispatch* ConfigDictionary

);

Parameters

ConfigDictionary

[in] Contains an IDictionary object that contains the configuration information.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

With this method, the user interface can set or change these values. SetConfigData enables the user interface to write the updated value from the property page to the component.

The server calls SetConfigData when the property page is saved. It is used to verify the values entered by the user on the property page. The contents of this provided IDictionary object are also stored in the database.

This method is called immediately before the Execute method of the IPipelineComponent interface at run time, when the server is ready to send a document to the component. Data stored during design time from autoconfiguration or from property-page updates is passed to the component to allow for property setup prior to calling Execute.

Components validate the properties provided in SetConfigData and raise an error if any of the properties are invalid or missing.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


ISchemaImporter

Handles the importing of DTDs, XDRs, and well-formed XML documents.

Hierarchy

IDispatch

|--ISchemaImporter

Declaration

[Visual Basic]

Class ISchemaImporter

[C++]

interface ISchemaImporter : IDispatch

Members

ISchemaImporter defines the following properties:

Property | Description
ImportFormatDescription | Contains descriptive text about a supported import format.
ImportFormatIcon | Contains an icon for a supported import format.
NumberOfSupportedImportFormats | Contains the number of supported data formats from which a schema can be extracted.

ISchemaImporter defines the following method:

Method | Description
ExtractXMLSchema | Extracts a schema from a document.

Remarks

Custom XML import components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Custom XML import components register themselves with the category ID CATID_BIZTALK_IDocSpecExtension. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ExtractXMLSchema Method

Extracts a schema from a document.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Method Declaration

[Visual Basic]

Function ExtractXMLSchema( _

FormatIndex As Long, _

DocumentPath As String _

) As Object

[C++]

HRESULT ExtractXMLSchema(

long FormatIndex ,

BSTR DocumentPath ,

IDispatch** SchemaDOM

);

Parameters

FormatIndex

[in] Contains an index value that specifies the type of document from which to import the schema. Use the value 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

DocumentPath

[in] Contains the path to the document from which to import the schema.

SchemaDOM

[out, retval] In C++, contains an IDispatch interface that contains the extracted XML schema. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an Object that contains information about the extracted XML schema.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ImportFormatDescription Property

Contains descriptive text about a supported import format.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Property Declaration

[Visual Basic]

Property ImportFormatDescription( _

FormatIndex As Long _

) As String

[C++]

HRESULT get_ImportFormatDescription(

long FormatIndex ,

BSTR* Description

);

Parameters

FormatIndex

[in] Contains an index value that specifies the type of document from which to import the schema. Use the value 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

Description

[out, retval] In C++, contains a textual description of the input document format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a textual description of the input document format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ImportFormatIcon Property

Contains an icon for a supported import format.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Property Declaration

[Visual Basic]

Property ImportFormatIcon( _

FormatIndex As Long _

) As Long

[C++]

HRESULT get_ImportFormatIcon(

long FormatIndex,

long* IconID

);

Parameters

FormatIndex

[in] Contains an index value that specifies the type of document from which to import the schema. Use the value 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

IconID

[out, retval] In C++, contains the icon identifier for the input format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the icon identifier for the input format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read only-property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


NumberOfSupportedImportFormats Property

Contains the number of supported data formats from which a schema can be extracted.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Property Declaration

[Visual Basic]

Property NumberOfSupportedImportFormats As Long

[C++]

HRESULT get_NumberOfSupportedImportFormats(

long* Number

);

Parameters

Number

[out, retval] In C++, indicates the number of supported import formats. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of supported import formats.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError

Identifies and deciphers errors or warnings.

Hierarchy

IDispatch

|--ISchemaImporterError

Declaration

[Visual Basic]

Class ISchemaImporterError

[C++]

interface ISchemaImporterError : IDispatch

Members

ISchemaImporterError defines the following properties:

Property | Description
IsWarning | Contains a value that identifies the object as an error or a warning.
NodePath | Contains the path to the node that generated the error or warning.
Text | Contains the error or warning message.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


IsWarning Property

Contains a value that identifies the object as an error or a warning.

Member List

ISchemaImporterError

|--IsWarning

|--NodePath

|--Text

Property Declaration

[Visual Basic]

Property IsWarning As Boolean

[C++]

HRESULT get_IsWarning(

VARIANT_BOOL* IsWarning

);

Parameters

IsWarning

[out, retval] In C++, contains a value that indicates whether or not the object is a warning. VARIANT_TRUE indicates that this is a warning object; VARIANT_FALSE indicates that this is an error object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the object is a warning. True indicates that this is a warning object; False indicates that this is an error object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


NodePath Property

Contains the path to the node that generated the error or warning.

Member List

ISchemaImporterError

|--IsWarning

|--NodePath

|--Text

Property Declaration

[Visual Basic]

Property NodePath As String

[C++]

HRESULT get_NodePath(

BSTR* NodePath

);

Parameters

NodePath

[out, retval] In C++, contains the fully qualified name of the node that generated the error or warning. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the fully qualified name of the node that generated the error or warning.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Text Property

Contains the error or warning message.

Member List

ISchemaImporterError

|--IsWarning

|--NodePath

|--Text

Property Declaration

[Visual Basic]

Property Text As String

[C++]

HRESULT get_Text(

BSTR* errText

);

Parameters

errText

[out, retval] In C++, contains the text associated with the error or warning. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the text associated with the error or warning.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterErrorProvider

Returns errors or warnings.

Hierarchy

IDispatch

|--ISchemaImporterErrorProvider

Declaration

[Visual Basic]

Class ISchemaErrorProvider

[C++]

interface ISchemaErrorProvider : IDispatch

Members

ISchemaImporterErrorProvider defines the following properties:

Property | Description
Error | Contains the error or warning.
NumberOfErrors | Contains the number of errors or warnings.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Error Property

Contains the error or warning.

Member List

ISchemaImporterErrorProvider

|--Error

|--NumberOfErrors

Property Declaration

[Visual Basic]

Property Error( _

Index As Long _

) As ISchemaImporterError

[C++]

HRESULT get_Error(

long Index,

IschemaImporterError** Error

);

Parameters

Index

[in] Contains the index of the error or warning.

Error

[out, retval] In C++, contains an ISchemaImporterError interface that contains the error or warning. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a SchemaImporterError object that contains the error or warning.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


NumberOfErrors Property

Contains the number of errors or warnings.

Member List

ISchemaImporterErrorProvider

|--Error

|--NumberOfErrors

Property Declaration

[Visual Basic]

Property NumberOfErrors As Long

[C++]

HRESULT get_NumberOfErrors(

long* NumberOfErrors

);

Parameters

NumberOfErrors

[out, retval] In C++, indicates the number of errors. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of errors.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Enumerations

The following enumerations provide possible property and parameter values:

  • CONNECTION_TYPE

  • DTA_ACK_STATUS

  • FUNC_CATEGORY

  • FUNC_TYPE

  • GeneratedReceiptLevel

  • SCRIPT_CATEGORY


CONNECTION_TYPE

Specifies the connection type.

[Visual Basic]

Enum CONNECTION_TYPE

[C++]

enum CONNECTION_TYPE

Members

CONNECT_TYPE_NONE

[0] The connection type is none.

CONNECT_TYPE_FIELD

[1] The connection type is field.

CONNECT_TYPE_RECORD

[2] The connection type is record.

CONNECT_TYPE_RECORD_CONTENT

[4] The connection type is record content.

CONNECT_TYPE_FUNC_STRING

[8] The connection type function is string.

CONNECT_TYPE_FUNC_MATH

[16] The connection type function is mathematical.

CONNECT_TYPE_FUNC_DATACONV

[32] The connection type function is data conversion.

CONNECT_TYPE_FUNC_DATETIME_FMT

[64] The connection type function is date/time format.

CONNECT_TYPE_FUNC_SCIENTIFIC

[128] The connection type function is scientific.

CONNECT_TYPE_FUNC_BOOLEAN

[256] The connection type function is Boolean.

CONNECT_TYPE_FUNC_SCRIPTER

[1024] The connection type function is script.

CONNECT_TYPE_FUNC_COUNT

[2048] The connection type function is count.

CONNECT_TYPE_FUNC_INDEX

[2048] The connection type function is index.

CONNECT_TYPE_FUNC_CUMULATIVE

[4096] The connection type function is cumulative.

CONNECT_TYPE_FUNC_VALUE_MAPPING

[8192] The connection type function is value mapping.

CONNECT_TYPE_FUNC_LOOPING

[16384] The connection type function is looping.

CONNECT_TYPE_FUNC_ITERATION

[32768] The connection type function is iteration.

CONNECT_TYPE_FUNC_DBLOOKUP

[65536] The connection type function is database lookup.

CONNECT_TYPE_FUNC_DBEXTRACT

[131072] The connection type function is database extraction.

CONNECT_TYPE_ALL

[-1] The connection type includes all connection types.

CONNECT_TYPE_ALL_EXCEPT_RECORD

[-3] The connection type includes all connection types except records.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionParameter


DTA_ACK_STATUS

Indicates the acknowledgement status.

[Visual Basic]

Enum DTA_ACK_STATUS

[C++]

enum DTA_ACK_STATUS

Members

DTA_ACK_NONE

[0] No receipt is expected.

DTA_ACK_PENDING

[1] The receipt is expected but has not yet arrived.

DTA_ACK_OVERDUE

[2] The receipt has timed out.

DTA_ACK_ACCEPTED

[3] The receipt has arrived with a status of accepted.

DTA_ACK_PARTIALLY_ACCEPTED

[4] The receipt has arrived with a status of accepted with errors.

DTA_ACK_REJECTED

[5] The receipt has arrived with a status of rejected.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

AckDocument

AckGroup

AckInterchange


FUNC_CATEGORY

Defines the values to specify the functoid palette on which the custom functoid will appear.

[Visual Basic]

Enum FUNC_CATEGORY

[C++]

enum FUNC_CATEGORY

Members

FUNC_CATEGORY_STRING

[3] The function category is string.

FUNC_CATEGORY_MATH

[4] The function category is mathematical.

FUNC_CATEGORY_DATACONV

[5] The function category is data conversion.

FUNC_CATEGORY_DATETIME_FMT

[6] The function category is date/time format.

FUNC_CATEGORY_SCIENTIFIC

[7] The function category is scientific.

FUNC_CATEGORY_BOOLEAN

[8] The function category is Boolean.

FUNC_CATEGORY_SCRIPTER

[9] The function category is script.

FUNC_CATEGORY_COUNT

[10] The function category is count. This value is not supported for this release.

FUNC_CATEGORY_INDEX

[11] The function category is index.

FUNC_CATEGORY_CUMULATIVE

[12] The function category is cumulative.

FUNC_CATEGORY_VALUE_MAPPING

[13] The function category is value mapping. This value is not supported for this release.

FUNC_CATEGORY_LOOPING

[14] The function category is looping. This value is not supported for this release.

FUNC_CATEGORY_ITERATION

[15] The function category is iteration. This value is not supported for this release.

FUNC_CATEGORY_DBLOOKUP

[16] The function category is database lookup. It is not recommended to add custom functoids to the Database tab on the functoid palette. See the note following this table for information on adding functoids to the Advanced tab.

FUNC_CATEGORY_DBEXTRACT

[17] The function category is database extraction. It is not recommended to add custom functoids to the Database tab on the functoid palette. See the note following this table for information on adding functoids to the Advanced tab.

FUNC_CATEGORY_UNKNOWN

[31] The function category is unknown.

Remarks

Custom functoids using a category value between 18 and 31 appear on the Advanced tab in the functoid palette.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionDescripter


FUNC_TYPE

Specifies the function type.

[Visual Basic]

Enum FUNC_TYPE

[C++]

enum FUNC_TYPE

Members

FUNC_TYPE_STD

[1] The function type is standard.

FUNC_TYPE_VARIABLEINPUT

[2] The function type is variable input.

FUNC_TYPE_SCRIPTOR

[3] The function type is script.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionDescripter


GeneratedReceiptLevel

Specifies the generated receipt level.

This enumeration is only supported in C++.

enum GeneratedReceiptLevel

Members

NoReceiptGenerated

[0] No receipt is created.

DocReceiptGenerated

[1] A receipt is generated for each document.

GroupReceiptGenerated

[2] A receipt is generated for each group.

InterchangeReceiptGenerated

[3] A receipt is generated for each interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

GetNextDocument


SCRIPT_CATEGORY

Specifies the script category.

[Visual Basic]

Enum SCRIPT_CATEGORY

[C++]

enum SCRIPT_CATEGORY

Members

SCRIPT_CATEGORY_VBSCRIPT

[0] The custom functoid function is written in the Microsoft Visual Basic Scripting Edition (VBScript) language.

SCRIPT_CATEGORY_JSCRIPT

[1] The custom functoid function is written in the Microsoft JScript language.

SCRIPT_CATEGORY_XSLSCRIPT

[2] The custom functoid function is written in the Extensible Stylesheet Language (XSL). This value is not supported for this release.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionDescripter


Orchestration Services Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, and properties exposed for accessing orchestration services:

  • Interfaces

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented:

  • IWFGroupAdmin

  • IWFProxy

  • IWFSystemAdmin

  • IWFWorkflowInstance


IWFGroupAdmin

Allows a client application to control running instances of an XLANG schedule. Use IWFGroupAdmin to stop, suspend, resume, and retrieve information about all the schedule instances associated with a group manager.

Hierarchy

IDispatch

|--IWFGroupAdmin

Declaration

[Visual Basic]

Class IWFGroupAdmin

[C++]

interface IWFGroupAdmin : IDispatch

Members

IWFGroupAdmin defines the following properties:

Property | Description
Count | Contains the number of running XLANG schedule instances associated with this group manager.
FullyQualifiedName | Contains the moniker of this group manager.
InstanceIsResident | Contains a value that indicates whether the specified XLANG schedule instance is currently resident in memory.
InstanceIsSuspended | Contains a value that indicates whether the specified XLANG schedule instance is currently in a suspended state.
Name | Contains the name of this group manager.
UseFileDSN | Contains a value that indicates whether a Data Source Name (DSN) file is used for dehydrating the XLANG schedule instances.

IWFGroupAdmin defines the following methods:

Method | Description
ResumeInstance | Resumes the execution of an XLANG schedule instance in a suspended state.
Shutdown | Stops the group manager and dehydrates all running XLANG schedule instances.
Startup | Starts all the dehydrated XLANG schedule instances for the current group manager.
SuspendInstance | Pauses the running XLANG schedule instance in its current state.
TerminateInstance | Stops execution of the running XLANG schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Accessing Group Managers

XLANG Interfaces


Count Property

Contains the number of running XLANG schedule instances associated with this group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] In C++, contains the number of running schedule instances associated with this group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of running schedule instances associated with this group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


FullyQualifiedName Property

Contains the moniker of this group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] In C++, contains the moniker of this group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of this group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Although a group manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the default XLANG Scheduler Group Manager, named XLANG Scheduler, is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com!XLANG Scheduler.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Moniker Syntax


InstanceIsResident Property

Contains a value that indicates whether the specified XLANG schedule instance is currently resident in memory.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property InstanceIsResident( _

InstanceId As String _

) As Boolean

[C++]

HRESULT get_InstanceIsResident(

BSTR InstanceId,

VARIANT_BOOL* IsResident

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance.

IsResident

[out, retval] In C++, contains a value that indicates whether or not the specified schedule instance is currently resident in memory. VARIANT_TRUE indicates that the specified schedule instance is currently resident in memory; VARIANT_FALSE indicates that the specified schedule instance is not currently resident in memory. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the specified schedule instance is currently resident in memory. True indicates that the specified schedule instance is currently resident in memory; False indicates that the specified schedule instance is not currently resident in memory.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


InstanceIsSuspended Property

Contains a value that indicates whether the specified XLANG schedule instance is currently in a suspended state.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property InstanceIsSuspended( _

InstanceId As String _

) As Boolean

[C++]

HRESULT get_InstanceIsSuspended(

BSTR InstanceId,

VARIANT_BOOL* IsSuspended

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance.

IsSuspended

[out, retval] In C++, contains a value that indicates whether or not the specified schedule instance is currently in a suspended state. VARIANT_TRUE indicates that the specified schedule instance is currently in a suspended state; VARIANT_FALSE indicates that the specified schedule instance is not currently in a suspended state. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the specified schedule instance is currently in a suspended state. VARIANT_TRUE indicates that the specified schedule instance is currently in a suspended state; VARIANT_FALSE indicates that the specified schedule instance is not currently in a suspended state.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

This property should be checked prior to calling the ResumeInstance method.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Name Property

Contains the name of this group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Name As String

[C++]

HRESULT get_Name(

BSTR* Name

);

[
Parameters

Name

[out, retval] In C++, contains the name of this group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of this group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

This property is the same as the name of the hosting COM+ application.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ResumeInstance Method

Resumes the execution of an XLANG schedule instance in a suspended state.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub ResumeInstance( _

InstanceId As String _

)

[C++]

HRESULT ResumeInstance(

BSTR InstanceId

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance to be resumed.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The schedule instance can be paused with the SuspendInstance method. Prior to calling the ResumeInstance method, the InstanceIsSuspended property should be checked.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Shutdown Method

Stops the group manager and dehydrates all running XLANG schedule instances.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub Shutdown( )

[C++]

HRESULT Shutdown( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Prior to stopping the group manager, all running schedule instances associated with this group manager are dehydrated to the database specified in the Data Source Name (DSN) file, and requests for activation of any new schedule instances are refused until shutdown is completed.

Any component that is bound in an XLANG schedule should not invoke this method to stop the group manager, as this can produce unexpected results.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Startup Method

Starts all the dehydrated XLANG schedule instances for the current group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub Startup( )

[C++]

HRESULT Startup( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The XLANG Scheduler System Manager normally calls this method. Users should not call this method directly.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


SuspendInstance Method

Pauses the running XLANG schedule instance in its current state.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub SuspendInstance( _

InstanceId As String _

)

[C++]

HRESULT SuspendInstance(

BSTR InstanceId

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance to be suspended.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The schedule instance can be restarted with the ResumeInstance method.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


TerminateInstance Method

Stops execution of the running XLANG schedule instance.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub TerminateInstance( _

InstanceId As String _

)

[C++]

HRESULT TerminateInstance(

BSTR InstanceId

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance to be stopped.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

A terminated schedule instance can never be restarted or resumed.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


UseFileDSN Property

Contains a value that indicates whether a Data Source Name (DSN) file is used for dehydrating the XLANG schedule instances.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property UseFileDSN As Boolean

[C++]

HRESULT get_UseFileDSN(

VARIANT_BOOL* UseFileDSN

);

Parameters

UseFileDSN

[out, retval] In C++, contains a value that indicates whether or not the group manager uses a DSN file for dehydrating schedule instances. VARIANT_TRUE indicates that the group manager uses a DSN file for dehydrating schedule instances; VARIANT_FALSE indicates that the group manager does not use a DSN file for dehydrating schedule instances. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the group manager uses a DSN file for dehydrating schedule instances. True indicates that the group manager uses a DSN file for dehydrating schedule instances; False indicates that the group manager does not use a DSN file for dehydrating schedule instances.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The value of this property is set when the group manager process is launched. The DSN setting in the COM+ catalog is changed either on the XLANG tab of the XLANG Scheduler Properties dialog box or by setting the UseFileDSN property on the IWFSystemAdmin interface. If the DSN value is changed while the group manager is running, the value of this property is not dynamically updated. The new value is not reflected until the next time the group manager is launched. Updates to this property require the caller to be in the XLANG Administrator role and are not normally performed by user code.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFProxy

Contains information about ports in an XLANG schedule instance that are bound to a COM component.

Hierarchy

IDispatch

|--IWFProxy

Declaration

[Visual Basic]

Class IWFProxy

[C++]

interface IWFProxy : IDispatch

Members

IWFProxy defines the following properties:

Property | Description
FullyQualifiedName | Contains the fully qualified name of a COM-bound port.
WorkflowInstance | Contains a reference to the current XLANG schedule instance.

Remarks

Use IWFProxy to obtain a schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Activating an XLANG Schedule Instance


FullyQualifiedName Property

Contains the fully qualified name of a COM-bound port.

Member List

IWFProxy

|--FullyQualifiedName

|--WorkflowInstance

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] Contains the moniker of the port. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of the port.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The moniker retrieved with this property can be used with the COM GetObject function to obtain a reference to the XLANG schedule instance. This moniker is valid as long as the schedule instance is running. If the schedule instance is dehydrated and rehydrated for any reason, such as rebooting the system, the moniker remains valid. Once the schedule instance completes, or ends by using the TerminateInstance method, the moniker can no longer be used.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


WorkflowInstance Property

Contains a reference to the current XLANG schedule instance.

Member List

IWFProxy

|--FullyQualifiedName

|--WorkflowInstance

Property Declaration

[Visual Basic]

Property WorkflowInstance As IWFWorkflowInstance

[C++]

HRESULT get_WorkflowInstance(

IWFWorkflowInstance** ScheduleInstance

);

Parameters

ScheduleInstance

[out, retval] Contains an IWFWorkflowInstance object that contains the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns an IWFWorkflowInstance object that contains the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFSystemAdmin

Provides a client application with system-wide administrative control over the XLANG Scheduler Engine.

Hierarchy

IDispatch

|--IWFSystemAdmin

Declaration

[Visual Basic]

Class SysMgr

[C++]

interface IWFSystemAdmin : IDispatch

Members

IWFSystemAdmin defines the following properties:

Property | Description
Count | Contains the number of group managers associated with this XLANG Scheduler System Manager.
FullyQualifiedName | Contains the fully qualified DNS-style name of the XLANG Scheduler System Manager.
IsWorkflowHost | Contains a value that indicates whether the COM+ server application is an XLANG Scheduler Engine host.
Item | Contains a reference to the named schedule group.
UseFileDSN | Contains a value that indicates whether a COM+ server application uses a Data Source Name (DSN) file for dehydrating the XLANG schedule instances.

IWFSystemAdmin defines the following methods:

Method | Description
ShutdownAll | Stops the group managers and terminates their associated COM+ applications.
ShutdownApp | Stops a specific group manager application and terminates the associated COM+ application.
Startup | Starts all group managers.
TestAdminStatus | Determines whether a caller on IWFGroupAdmin is an XLANG Scheduler Engine administrator.

Remarks

Use IWFSystemAdmin to start, stop, and retrieve information about the group managers.

All XLANG Scheduler System Manager objects must have an associated Data Source Name (DSN) to support the dehydration and rehydration of long-running business processes. Therefore, you must create a DSN for the XLANG Scheduler System Manager by using the ODBC Data Source Administrator. XLANG schedules run by an XLANG Scheduler System Manager without a DSN configured will generate an error. For more information about creating a DSN, see Change the DSN settings for a COM+ application.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)

Related Topics

Accessing the XLANG Scheduler System Manager

XLANG Interfaces


Count Property

Contains the number of group managers associated with this XLANG Scheduler System Manager.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] Contains the number of running group managers. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of running group managers.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


FullyQualifiedName Property

Contains the fully qualified DNS-style name of the XLANG Scheduler System Manager.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] Contains the moniker of this XLANG Scheduler System Manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of this XLANG Scheduler System Manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Although an XLANG Scheduler System Manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the XLANG Scheduler System Manager is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)

Related Topics

Moniker Syntax


IsWorkflowHost Property

Contains a value that indicates whether the COM+ server application is an XLANG Scheduler Engine host.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property IsWorkflowHost( _

AppName As String _

) As Boolean

[C++]

HRESULT get_IsWorkflowHost(

BSTR AppName,

VARIANT_BOOL* IsWorkflowHost

);

HRESULT put_IsWorkflowHost(

BSTR AppName,

VARIANT_BOOL IsWorkflowHost

);

Parameters

AppName

[in] Contains the COM+ server application name.

IsWorkflowHost

[out, retval], [in] In C++, contains a value that indicates whether or not the COM+ server application is hosting the XLANG Scheduler Engine. VARIANT_TRUE indicates that the COM+ server application is hosting the XLANG Scheduler Engine; VARIANT_FALSE indicates that the COM+ server application is not hosting the XLANG Scheduler Engine. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the COM+ server application is hosting the XLANG Scheduler Engine. True indicates that the COM+ server application is hosting the XLANG Scheduler Engine; False indicates that the COM+ server application is not hosting the XLANG Scheduler Engine.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property cannot be set on the XLANG Scheduler Engine application, or on any COM+ application marked as read-only.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


Item Property

Contains a reference to the named schedule group.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Item( _

GrpMgrName As String _

) As Unknown

[C++]

HRESULT get_Item(

BSTR GrpMgrName,

IUnknown** Item

);

Parameters

GrpMgrName

[in] Contains the group name corresponding to the hosting COM+ server application name. Group names are case sensitive and can contain spaces.

Item

[out, retval] Contains an object that refers to a group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns an object that refers to a group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


ShutdownAll Method

Stops the group managers and terminates their associated COM+ applications.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub ShutdownAll( )

[C++]

HRESULT ShutdownAll( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When the ShutdownAll method is called, new schedule activations are disabled and the shutdown notice is propagated to all running group managers. Once this method has completed, all group managers are stopped and the system can be safely rebooted.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


ShutdownApp Method

Stops a specific group manager application and terminates the associated COM+ application.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub ShutdownApp( _

AppName As String _

)

[C++]

HRESULT ShutdownApp(

BSTR AppName

);

Parameters

AppName

[in] Contains the COM+ server application name to be stopped.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When the ShutdownApp method is called, new schedule activations on the named application are disabled and all running XLANG schedule instances associated with that application are stopped. If this method is called on the default XLANG Scheduler Group Manager, all group managers are shut down. Calling this method on the default XLANG Scheduler Group Manager is equivalent to calling the ShutdownAll method.

Note

  • The COM+ application name of the default XLANG Scheduler Group Manager is XLANG Scheduler.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


StartUp Method

Starts all group managers.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub StartUp( )

[C++]

HRESULT StartUp( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When this method is invoked, rehydration is initiated for all group managers and, subsequently, all XLANG schedules. This method is asynchronous, and it can complete before all group managers and schedules are running.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


TestAdminStatus Method

Determines whether a caller on IWFSystemAdmin is an XLANG Scheduler Engine administrator.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub TestAdminStatus( )

[C++]

HRESULT TestAdminStatus( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is intended for internal use by the group managers.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


UseFileDSN Property

Contains a value that indicates whether a COM+ server application uses a Data Source Name (DSN) file for dehydrating the XLANG schedule instances.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property UseFileDSN( _

AppName As String _

) As Boolean

[C++]

HRESULT get_UseFileDSN(

BSTR AppName,

VARIANT_BOOL* UseFileDSN

);

HRESULT put_UseFileDSN(

BSTR AppName,

VARIANT_BOOL* UseFileDSN

);

Parameters

AppName

[in] Contains the COM+ server application name.

UseFileDSN

[out, retval], [in] In C++, contains a value that indicates whether or not the COM+ server application uses a DSN file for dehydrating schedule instances. VARIANT_TRUE indicates that the COM+ server application uses a DSN file for dehydrating schedule instances; VARIANT_FALSE indicates that the COM+ server application does not use a DSN file for dehydrating schedule instances. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the COM+ server application uses a DSN file for dehydrating schedule instances. True indicates that the COM+ server application uses a DSN file for dehydrating schedule instances; False indicates that the COM+ server application does not use a DSN file for dehydrating schedule instances.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If this property is changed while any group manager is running, the value of this property is not dynamically updated in the group managers. Therefore, the UseFileDSN property value exposed by IWFGroupAdmin contains an incorrect value. The updated value is not reflected until the next time the group manager is launched.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFWorkflowInstance

Allows a client application to navigate the ports of an XLANG schedule instance, check the completion status, and determine whether the schedule instance completed successfully.

Hierarchy

IDispatch

|--IWFWorkflowInstance

Declaration

[Visual Basic]

Class IWFWorkflowInstance

[C++]

interface IWFWorkflowInstance : IDispatch

Members

IWFWorkflowInstance defines the following properties:

Property | Description
CompletionStatus | Contains a value that indicates the success or failure of the XLANG schedule instance.
FullPortName | Contains the full name of a port in a form usable by the associated technology.
FullyQualifiedName | Contains the fully qualified name of this XLANG schedule instance.
InstanceId | Contains the globally unique identifier (GUID) assigned to the current XLANG schedule instance.
IsCompleted | Contains a value that indicates whether the XLANG schedule instance has finished executing.
ModuleId | Contains the globally unique identifier (GUID) of the XML module associated with the current XLANG schedule instance.
ModuleName | Contains the name of the XML module associated with the current XLANG schedule instance.
ParentInstanceID | Contains the globally unique identifier (GUID) assigned to the parent XLANG schedule instance of the current schedule instance.
Port | Contains a reference to the named port. This is applicable only to COM-based port bindings.

IWFWorkflowInstance defines the following method:

Method | Description
WaitForCompletion | Waits until the current XLANG schedule instance completes executing.

Remarks

Use IWFWorkflowInstance to gather information about a specific, running schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Accessing a Running XLANG Schedule Instance

XLANG Interfaces


CompletionStatus Property

Contains a value that indicates the success or failure of the XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property CompletionStatus As Long

[C++]

HRESULT get_CompletionStatus(

long* CompletionStatus

);

Parameters

CompletionStatus

[out, retval] Contains the completion status of the schedule instance. A value of 0 indicates success. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the completion status of the schedule instance. A value of 0 indicates success.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • A return value of S_OK does not indicate that the processes or applications associated with the schedule instance completed successfully. It indicates only that the schedule instance was completely processed by the XLANG Scheduler Engine, without errors.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


FullPortName Property

Contains the full name of a port in a form usable by the associated technology.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property FullPortName( _

Port As String _

) As String

[C++]

HRESULT get_FullPortName(

BSTR Port,

BSTR* FullPortName

);

Parameters

Port

[in] Contains the name of the port to be retrieved.

FullPortName

[out, retval] Contains the full port name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the full port name.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The full port name is returned in a form that is usable by the associated binding technology. For example, a port that is bound to a COM component returns a fully qualified moniker as the name of the port. For a port that is bound to Microsoft Message Queuing, this method returns the full path of the queue.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


FullyQualifiedName Property

Contains the fully qualified name of this XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] Contains the moniker of the schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of the schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


InstanceId Property

Contains the globally unique identifier (GUID) assigned to the current XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property InstanceId As String

[C++]

HRESULT get_InstanceId(

BSTR* InstanceId

);

Parameters

InstanceId

[out, retval] Contains the GUID of the schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the GUID of the schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


IsCompleted Property

Contains a value that indicates whether the XLANG schedule instance has finished executing.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property IsCompleted As Boolean

[C++]

HRESULT get_IsCompleted(

VARIANT_BOOL* IsCompleted

);

Parameters

IsCompleted

[out, retval], In C++, contains a value that indicates whether or not the schedule instance has finished executing. VARIANT_TRUE indicates that the schedule instance has finished executing; VARIANT_FALSE indicates the schedule instance has not finished executing. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the schedule instance has finished executing. True indicates that the schedule instance has finished executing; False indicates the schedule instance has not finished executing.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ModuleId Property

Contains the globally unique identifier (GUID) of the XML module associated with the current XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property ModuleId As String

[C++]

HRESULT get_ModuleId(

BSTR* ModuleId

);

Parameters

ModuleId

[out, retval] Contains the GUID of the XLANG module associated with the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the GUID of the XLANG module associated with the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ModuleName Property

Contains the name of the XML module associated with the current XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property ModuleName As String

[C++]

HRESULT get_ModuleName(

BSTR* ModuleName

);

Parameters

ModuleName

[out, retval] Contains the name of the XLANG module associated with the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the XLANG module associated with the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The module name is defined in the XLANG schedule (.skx) file.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ParentInstanceID Property

Contains the globally unique identifier (GUID) assigned to the parent XLANG schedule instance of the current schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property ParentInstanceID As String

[C++]

HRESULT get_ParentInstanceID(

BSTR* ParentInstanceID

);

Parameters

ParentInstanceID

[out, retval] Contains the GUID of the parent schedule instance of the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the GUID of the parent schedule instance of the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

In C++, the property returns a NULL value if no parent schedule instance exists.

In Visual Basic, the property returns a Nothing value if no parent schedule instance exists.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Port Property

Contains a reference to the named port. This is applicable only to COM-based port bindings.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property Port( _

Port As String _

) As Unknown

[C++]

HRESULT get_Port(

BSTR Port,

IUnknown** PortReference

);

Parameters

Port

[in] Contains the name of the port to which to obtain a reference.

PortReference

[out, retval] Contains a reference to a port in the current XLANG schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a reference to a port in the current XLANG schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The MK_E_NOOBJECT error code is returned if the moniker or port name passed in the Port parameter is incorrect.

In Visual Basic, the variable used for the port reference returned by using this property should be declared as a specific class or as a Variant. You can't obtain the port reference if you declare the variable as an Object since the port actually returns an IUnknown reference.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


WaitForCompletion Method

Waits until the current XLANG schedule instance completes executing.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Method Declaration

[Visual Basic]

Sub WaitForCompletion( )

[C++]

HRESULT WaitForCompletion( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Managing and Monitoring Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for working with managing and monitoring BizTalk Server:

  • WMI Classes

In addition, a complete list of Error Messages is provided.


WMI Classes

The following COM interfaces are documented:

  • DocSuspendedEvent

  • InterchangeProvError

  • MicrosoftBizTalkServer_Group

  • MicrosoftBizTalkServer_GroupReceiveFunction

  • MicrosoftBizTalkServer_GroupServer

  • MicrosoftBizTalkServer_MgmtDB

  • MicrosoftBizTalkServer_Queue

  • MicrosoftBizTalkServer_ReceiveFunction

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_Server

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

  • MSBTS_CustomCounter

  • MSBTS_CustomCounterSetting

  • ReceiveFunctionDisabledEvent


DocSuspendedEvent

Represents events raised by documents sent to the Suspended queue.

Hierarchy

__ExtrinsicEvent

|--DocSuspendedEvent

Declaration

[Visual Basic]

Class DocSuspendedEvent

[C++]

class DocSuspendedEvent : __ExtrinsicEvent

Members

DocSuspendedEvent defines the following properties:

Property | Description
ChannelHandle | Contains the handle of the channel through which the suspended document was to be processed.
Destination | Contains the name of the destination organization to which the suspended document was to be processed.
DocName | Contains the name of the document definition designated as the input or output document for the channel through which the suspended document was to be processed.
PortHandle | Contains the handle of the messaging port attached to the channel through which the suspended document was to be processed.
Reason | Contains a value that indicates why the document was placed in the Suspended queue.
Source | Contains the name of the source organization from which the suspended document was to be processed.
State | Contains a value that indicates the state of the suspended document.
stringSuspendedGuid | Contains the tracking key of the item in the Suspended queue event.

Remarks

DocSuspendedEvent inherits from the __ExtrinsicEvent system class, an abstract base class that serves as a superclass for all user-defined event types.

The purpose of this event is to raise a notification when a document is delivered to the suspended queue because of a server processing error.

In the event that an administrator intentionally moves a document to the suspended queue using one of the following methods, a document suspended event will not be raised:

  • MoveToSuspendedQueue

  • MoveToSuspendedQueue

  • MoveToSuspendedQueue

Requirements

Windows NT/ Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ChannelHandle Property

Contains the handle of the channel through which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ChannelHandle;

Parameters

None

Return Values

Returns the handle of the channel through which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Destination Property

Contains the name of the destination organization to which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Destination;

Parameters

None

Return Values

Returns the name of the destination organization to which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocName Property

Contains the name of the document definition designated as the input or output document for the channel through which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocName;

Parameters

None

Return Values

Returns the name of the document definition designated as the input or output document for the channel through which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PortHandle Property

Contains the handle of the messaging port attached to the channel through which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 PortHandle;

Parameters

None

Return Values

Returns the handle of the messaging port attached to the channel through which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Reason Property

Contains a value that indicates why the document was placed in the Suspended queue.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 Reason;

Parameters

None

Return Values

Returns a value that indicates why the document was placed in the Suspended queue. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value for this property corresponds to the Suspended queue Error Description column in BizTalk Server Administration. BizTalk Server Administration translates this value into an error string. For more information, see Suspended Queue.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Source Property

Contains the name of the source organization from which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Source;

Parameters

None

Return Values

Returns the name of the source organization from which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


State Property

Contains a value that indicates the state of the suspended document.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 State;

Parameters

None

Return Values

Returns a value that indicates the state of the suspended document. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The tables in this section show the possible processing states of a document or interchange in the Suspended queue.

Documents in the states listed in the following table are at the interchange level, so you should use the ViewInterchange method to view the data. In addition, interchanges in these states cannot be resubmitted, so in this case you should not call Resubmit.

Value | State
0 | Initial
1 | Custom component
2 | Parsing

Documents in the states listed in the following table are considered documents instead of interchanges, so you should use the ViewDocument method to view the data. In addition, documents in the document validation state (3) cannot be resubmitted, so for those documents you should not call Resubmit.

Value | State
3 | Document validation
4 | Channel selection
5 | Field tracking
6 | Correlating
7 | Mapping
8 | Serializing

Documents in the states listed in the following table are considered interchanges, so you should use the ViewInterchange method to view the data.

Value | State
9 | Encoding
10 | Signing
11 | Encrypting
12 | Transmitting

Note that the ViewErrorDescription method can be used to retrieve error description information about failed documents and interchanges.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


stringSuspendedGuid Property

Contains the tracking key of the item in the Suspended queue event.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string stringSuspendedGuid;

Parameters

None

Return Values

Returns the tracking key of the item in the Suspended queue event. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The tracking key of the item in the Suspended queue event is based on a GUID.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


InterchangeProvError

Represents error information returned by the interchange provider when creating class instances.

Hierarchy

__ExtendedStatus

|--InterchangeProvError

Declaration

[Visual Basic]

Class InterchangeProvError

[C++]

class InterchangeProvError : __ExtendedStatus

Members

InterchangeProvError defines the following property:

Property | Description
InterchangeProvName | Contains the name of the interchange provider returning error information.

Remarks

InterchangeProvError inherits from the __ExtendedStatus system class, which is used to report detailed status and error information.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


InterchangeProvName Property

Contains the name of the interchange provider returning error information.

Member List

InterchangeProvError

|--InterchangeProvName

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string InterchangeProvName;

Parameters

None

Return Values

Returns the name of the interchange provider returning error information.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_Group

Represents a logical grouping of a specific number of BizTalk Servers in an enterprise. It is the management abstraction for global BizTalk Server properties.

Hierarchy

MicrosoftBizTalkServer_Group

Declaration

[Visual Basic]

Class Group

[C++]

class MicrosoftBizTalkServer_Group

Members

MicrosoftBizTalkServer_Group defines the following properties:

Property | Description
ConfigurationCacheRefreshInterval | Contains a value that indicates how often the server refreshes the cache of the BizTalk Messaging Configuration objects, in seconds.
ConnectToDbStatus | Contains a value that indicates the status of the connection to the Tracking and Shared Queue databases.
DateModified | Contains a value that indicates the last modification date of the instance data.
DocTrackDbName | Contains the database name component of the connect string for the Tracking database.
DocTrackDbServer | Contains the server name component of the connect string for the Tracking database.
EnableDocumentTracking | Contains a value that indicates whether document tracking is enabled or disabled.
LoggingPointState | Contains a collection of flags that indicate the events that cause a Tracking entry to be logged.
Name | Contains the name of the server.
ParserOrder | Contains the CLSIDs of the parser components registered in the registry, sorted in parsing order.
ProxyHost | Contains the proxy host address.
ProxyLogon | Contains the proxy logon.
ProxyPassword | Contains the proxy password.
ProxyPort | Contains a value that indicates the proxy port number.
QueueDbName | Contains the database name component of the connect string for the Shared Queue database.
QueueDbServer | Contains the server name component of the connect string for the Shared Queue database.
ReliableMessagingReplyToURL | Contains the URL repository for reliable messaging.
RetryQueueCount | Contains a value that indicates the number of documents in the Retry queue.
ScheduledQueueCount | Contains a value that indicates the number of documents in the Scheduled queue.
SMTPHost | Contains the name of the Simple Mail Transfer Protocol (SMTP) host that is used for this group.
SuspendedQueueCount | Contains a value that indicates the number of documents in the Suspended queue.
UseProxyServer | Contains a value that indicates whether to use the proxy server.
WorkQueueCount | Contains a value that indicates the number of documents in the Work queue.

MicrosoftBizTalkServer_Group defines the following methods:

Method | Description
PurgeSuspendedQueue | Enables an administrator to remove all the documents in the Suspended queue.
RefreshParserListFromRegistry | Updates the list of parser components in the database, based on current components registered in the registry.

Remarks

MicrosoftBizTalkServer_Group is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ConfigurationCacheRefreshInterval Property

Contains a value that indicates how often the server refreshes the cache of the BizTalk Messaging Configuration objects, in seconds.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ConfigurationCacheRefreshInterval = 50;

Parameters

None

Return Values

Returns how often the server refreshes the cache of the BizTalk Messaging Configuration objects, in seconds.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

This property has a default value of 50.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ConnectToDbStatus Property

Contains a value that indicates the status of the connection to the Tracking and Shared Queue databases.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ConnectToDbStatus;

Parameters

None

Return Values

Returns the status of the connection to the Tracking and Shared Queue databases. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Permissible values for this property are "BothDbConnectOK", "DTAConnectFail", "SQConnectFail", and "BothConnectFail", which map to the integers 0, 1, 2, and 3, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the mapping:

Values {"BothDbConnectOK", "DTAConnectFail", "SQConnectFail",

"BothConnectFail"},

ValueMap{"0", "1", "2", "3"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DateModified Property

Contains a value that indicates the last modification date of the instance data.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime DateModified;

Parameters

None

Return Values

Returns the last modification date of the instance data.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocTrackDbName Property

Contains the database name component of the connect string for the Tracking database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocTrackDbName;

Parameters

None

Return Values

Returns the database name component of the connect string for the Tracking database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 123 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocTrackDbServer Property

Contains the server name component of the connect string for the Tracking database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocTrackDbServer;

Parameters

None

Return Values

Returns the server name component of the connect string for the Tracking database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 60 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


EnableDocumentTracking Property

Contains a value that indicates whether document tracking is enabled or disabled.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean EnableDocumentTracking = 1;

Parameters

None

Return Values

Returns a language-specific value representing true if document tracking is enabled; if data tracking is not enabled, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing true.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


LoggingPointState Property

Contains a collection of flags that indicate the events that cause a Tracking entry to be logged.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 LoggingPointState;

Parameters

None

Return Values

Returns a collection of flags that indicate the events that cause a Tracking entry to be logged. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "LogIncomingInterchange", "LogMIMEBlob", and "LogOutgoingInterchange", which map to the integers 0, 1, and 2, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the mapping:

Values{"LogIncomingInterchange", "LogMIMEBlob",

"LogOutgoingInterchange" },

BitMap{"0", "1", "2"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the server.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ParserOrder Property

Contains the CLSIDs of the parser components registered in the registry, sorted in parsing order.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ParserOrder[];

Parameters

None

Return Values

Returns the CLSIDs of the parser components registered in the registry, sorted in parsing order.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyHost Property

Contains the proxy host address.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProxyHost;

Parameters

None

Return Values

Returns the proxy host address.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyLogon Property

Contains the proxy logon.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProxyLogon;

Parameters

None

Return Values

Returns the proxy logon.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyPassword Property

Contains the proxy password.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProxyPassword;

Parameters

None

Return Values

Returns the proxy password.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-only. Due to security considerations, when you try to read this property, NULL is returned instead of the password value.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyPort Property

Contains a value that indicates the proxy port number.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ProxyPort = 80;

Parameters

None

Return Values

Returns the proxy port number.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 80.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PurgeSuspendedQueue Method

Enables an administrator to remove all the documents in the Suspended queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 PurgeSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QueueDbName Property

Contains the database name component of the connect string for the Shared Queue database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string QueueDbName;

Parameters

None

Return Values

Returns the database name component of the connect string for the Shared Queue database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 123 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QueueDbServer Property

Contains the server name component of the connect string for the Shared Queue database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string QueueDbServer;

Parameters

None

Return Values

Returns the server name component of the connect string for the Shared Queue database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 60 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RefreshParserListFromRegistry Method

Updates the list of parser components in the database, based on current components registered in the registry.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 RefreshParserListFromRegistry();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ReliableMessagingReplyToURL Property

Contains the URL repository for reliable messaging.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ReliableMessagingReplyToURL;

Parameters

None

Return Values

Returns the URL repository for reliable messaging.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 512 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RetryQueueCount Property

Contains a value that indicates the number of documents in the Retry queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 RetryQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Retry queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ScheduledQueueCount Property

Contains a value that indicates the number of documents in the Scheduled queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ScheduledQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Scheduled queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SMTPHost Property

Contains the name of the SMTP host that is used for this group.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SMTPHost;

Parameters

None

Return Values

Returns the name of the SMTP host that is used for this group.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SuspendedQueueCount Property

Contains a value that indicates the number of documents in the Suspended queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 SuspendedQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Suspended queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


UseProxyServer Property

Contains a value that indicates whether to use the proxy server.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean UseProxyServer = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if a proxy server is used; if a proxy server is not used, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


WorkQueueCount Property

Contains a value that indicates the number of documents in the Work queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 WorkQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Work queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_GroupReceiveFunction

Allows you to retrieve all the receive functions in a group.

Hierarchy

MicrosoftBizTalkServer_GroupReceiveFunction

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_GroupReceiveFunction

[C++]

class MicrosoftBizTalkServer_GroupReceiveFunction

Members

MicrosoftBizTalkServer_GroupReceiveFunction defines the following properties:

Property | Description
Antecedent | Contains references to the properties of the BizTalk Server group.
Dependent | Contains references to the properties of the receive function that is associated with the BizTalk Server group.

Remarks

MicrosoftBizTalkServer_GroupReceiveFunction is an association class.

Associations are instances of association classes and are used to represent relationships between other WMI objects.

MicrosoftBizTalkServer_GroupReceiveFunction is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Antecedent Property

Contains references to the properties of the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupReceiveFunction

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_Group ref Antecedent;

Parameters

None

Return Values

Returns a value that references the properties of the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_Group object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Dependent property uniquely identifies an instance of the class.

This property is the parent component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Dependent Property

Contains references to the properties of the receive function that is associated with the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupReceiveFunction

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_ReceiveFunction ref Dependent;

Parameters

None

Return Values

Returns a value that references the properties of the receive function that is associated with the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_ReceiveFunction object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Antecedent property uniquely identifies an instance of the class.

This property is the child component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_GroupServer

Allows you to retrieve all the servers in a group.

Hierarchy

MicrosoftBizTalkServer_GroupServer

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_GroupServer

[C++]

class MicrosoftBizTalkServer_GroupServer

Members

MicrosoftBizTalkServer_GroupServer defines the following properties:

Property | Description
Antecedent | Contains references to the properties of the BizTalk Server group.
Dependent | Contains references to the properties of the server that is associated with the BizTalk Server group.

Remarks

MicrosoftBizTalkServer_GroupServer is an association class.

Associations are instances of association classes and are used to represent relationships between other WMI objects.

MicrosoftBizTalkServer_GroupServer is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Antecedent Property

Contains references to the properties of the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupServer

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_Group ref Antecedent;

Parameters

None

Return Values

Returns a value that references the properties of the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_Group object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Dependent property uniquely identifies an instance of the class.

This property is the parent component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Dependent Property

Contains references to the properties of the server that is associated with the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupServer

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_Server ref Dependent;

Parameters

None

Return Values

Returns a value that references the properties of the server that is associated with the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_Server object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Antecedent property uniquely identifies an instance of the class.

This property is the child component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_MgmtDB

Represents the BizTalk Messaging Management database.

Hierarchy

MicrosoftBizTalkServer_MgmtDB

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_MgmtDB

[C++]

class MicrosoftBizTalkServer_MgmtDB

Members

MicrosoftBizTalkServer_MgmtDB defines the following properties:

Property | Description
LocalServer | Contains the name of the class, identifying the instance of the class.
MgmtDbName | Contains the initial catalog component of the BizTalk Messaging Management database connect string and represents the database name.
MgmtDbServer | Contains the data source part of the BizTalk Messaging Management database connect string.

Remarks

MicrosoftBizTalkServer_MgmtDB is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


LocalServer Property

Contains the name of the class, which identifies the instance of the class.

Member List

MicrosoftBizTalkServer_MgmtDB

|--LocalServer

|--MgmtDbName

|--MgmtDbServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string LocalServer;

Parameters

None

Return Values

Returns the name of the class, which identifies the instance of the class.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MgmtDbName Property

Contains the initial catalog component of the BizTalk Messaging Management database connect string and represents the database name.

Member List

MicrosoftBizTalkServer_MgmtDB

|--LocalServer

|--MgmtDbName

|--MgmtDbServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string MgmtDbName;

Parameters

None

Return Values

Returns the initial catalog component of the BizTalk Messaging Management database connect string and represents the database name.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 123 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MgmtDbServer Property

Contains the data source part of the BizTalk Messaging Management database connect string.

Member List

MicrosoftBizTalkServer_MgmtDB

|--LocalServer

|--MgmtDbName

|--MgmtDbServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string MgmtDbServer;

Parameters

None

Return Values

Returns the data source part of the BizTalk Messaging Management database connect string.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 60 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_Queue

Provides a set of properties inherited by Retry queue, Scheduled queue, Suspended queue, and Work queue objects.

Hierarchy

MicrosoftBizTalkServer_Queue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_Queue

[C++]

class MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_Queue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
Group | Contains the name of the group to which the queue belongs.
QID | Contains a value that identifies an instance of the class.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

Remarks

MicrosoftBizTalkServer_Queue serves only as a base for new classes. This class is abstract and should not be implemented.

The following interfaces inherit properties from MicrosoftBizTalkServer_Queue:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Destination Property

Contains the name of the organization or application that receives the document.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Destination;

Parameters

None

Return Values

Returns the name of the organization or application that receives the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 512 characters.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Group Property

Contains the name of the group to which the queue belongs.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Group;

Parameters

None

Return Values

Returns the name of the group to which the queue belongs.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the QID property uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QID Property

Contains a value that identifies an instance of the class.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 QID;

Parameters

None

Return Values

Returns a value that identifies an instance of the class.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Group property uniquely identifies an instance of the class.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Source Property

Contains the name of the organization or application that sends the document.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Source;

Parameters

None

Return Values

Returns the name of the organization or application that sends the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 64 characters.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Timestamp Property

Contains a value that indicates the last time the document was used or when it entered the queue.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime Timestamp;

Parameters

None

Return Values

Returns the last time the document was used or when it entered the queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_ReceiveFunction

Represents a service that is set up on a BizTalk Server to handle incoming interchanges by using a specific protocol such as File, Message Queuing, or Script.

Hierarchy

MicrosoftBizTalkServer_ReceiveFunction

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_ReceiveFunction

[C++]

class MicrosoftBizTalkServer_ReceiveFunction

Members

MicrosoftBizTalkServer_ReceiveFunction defines the following properties:

Property | Description
ChannelName | Contains the name of the channel that the receive function should pass to the Submit method call when the pass-through flag is enabled.
Comment | Contains user comments.
DateModified | Contains a value that indicates the last modification date of the instance data.
DestinationID | Contains the ID of the organization or application that receives the document.
DestinationQualifier | Contains the ID type of the organization or application that receives the document.
DisableReceiveFunction | Contains a value that indicates whether to enable or disable the receive function.
DocumentName | Contains the name of the document definition for the input document of a channel.
EnvelopeName | Contains the name of an envelope definition instance in the BizTalk Messaging Management database.
FilenameMask | Contains the file name mask to use for receive functions that pull files from the file system for input to BizTalk Server.
GroupName | Contains the name of the group to which the server belongs.
HttpReturnContentType | Contains the name of the document type.
HttpReturnCorrelationToken | Contains a value that indicates whether to return a correlation token.
HttpTransportType | Contains the enumeration value used to represent the method used by the HTTP receive function to submit an interchange.
IsPassThrough | Contains a value that indicates whether a Submit method call is made with the pass-through flag enabled or disabled.
Name | Contains the name of the component.
OpennessFlag | Contains a value that indicates the value of the Openness parameter that the receive function passes to the Submit method.
Password | Contains the password to use for File Transfer Protocol (FTP) or Message Queuing receive functions that require a user name and password.
PollingLocation | Contains the name of the directory to poll (directory, message queue, and so on) for receive functions that require polling.
PreProcessor | Contains a value that indicates any preprocessing that must be done for a received document.
ProcessingServer | Contains the name of the server that is currently processing the interchange.
ProtocolType | Contains the enumeration value used to represent the type of the receive function component.
SourceID | Contains the ID of the organization or application that sends the document.
SourceQualifier | Contains the ID type of the organization or application that sends the document.
TransportURL | Contains the transport URL, indicating how and where the HTTP receive function submits the document.
Username | Contains the user name to use for FTP or Message Queuing receive functions.

Remarks

MicrosoftBizTalkServer_ReceiveFunction is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ChannelName Property

Contains the name of the channel that the receive function should pass to the Submit method call when the pass-through flag is enabled.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ChannelName;

Parameters

None

Return Values

Returns the name of the channel that the receive function should pass to the Submit method call when the pass-through flag is enabled. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Comment Property

Contains user comments.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Comment;

Parameters

None

Return Values

Returns user comments.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DateModified Property

Contains a value that indicates the last modification date of the instance data.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime DateModified;

Parameters

None

Return Values

Returns the last modification date of the instance data.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestinationID Property

Contains the ID of the organization or application that receives the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestinationID;

Parameters

None

Return Values

Returns the ID of the organization or application that receives the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestinationQualifier Property

Contains the ID type of the organization or application that receives the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestinationQualifier;

Parameters

None

Return Values

Returns the ID type of the organization or application that receives the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DisableReceiveFunction Property

Contains a value that indicates whether to enable or disable the receive function.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean DisableReceiveFunction = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if the receive function is disabled; if the receive function is enabled, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocumentName Property

Contains the name of the document definition for the input document of a channel.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocumentName;

Parameters

None

Return Values

Returns the name of the document definition for the input document of a channel.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


EnvelopeName Property

Contains the name of an envelope definition instance in the BizTalk Messaging Management database.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string EnvelopeName;

Parameters

None

Return Values

Returns the name of an envelope definition instance in the BizTalk Messaging Management database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


FilenameMask Property

Contains the file name mask to use for receive functions that pull files from the file system for input to BizTalk Server.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string FilenameMask;

Parameters

None

Return Values

Returns the file name mask to use for receive functions that pull files from the file system for input to BizTalk Server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupName Property

Contains the name of the group to which the server belongs.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupName;

Parameters

None

Return Values

Returns the name of the group to which the server belongs.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


HttpReturnContentType Property

Contains the name of the document type.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string HttpReturnContentType;

Parameters

None

Return Values

Returns the name of the document type.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


HttpReturnCorrelationToken Property

Contains a value that indicates whether to return a correlation token.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean HttpReturnCorrelationToken = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if the correlation token is returned; if the correlation token is not returned, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


HttpTransportType Property

Contains the enumeration value used to represent the method used by the HTTP receive function to submit an interchange.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 HttpTransportType;

Parameters

None

Return Values

Returns the enumeration value used to represent the method used by the HTTP receive function to submit an interchange. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "File", "Submit", and "SubmitSync", which map to the integers 1, 2, and 3, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the values:

Values {"File", "Submit", "SubmitSync"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


IsPassThrough Property

Contains a value that indicates whether a Submit method call is made with the pass-through flag enabled or disabled.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean IsPassThrough = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if the pass-through flag is enabled; if the pass-through flag is disabled, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the component.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the component.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


OpennessFlag Property

Contains a value that indicates the value of the Openness parameter that the receive function passes to the Submit method.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 OpennessFlag;

Parameters

None

Return Values

Returns the value of the Openness parameter that the receive function passes to the Submit method. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "NotOpen", "OpenSource", and "OpenDestination", which map to the integers 0, 1, and 2, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the values:

Values {"NotOpen", "OpenSource", "OpenDestination"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Password Property

Contains the password to use for FTP or Message Queuing receive functions that require a user name and password.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Password;

Parameters

None

Return Values

Returns the password to use for FTP or Message Queuing receive functions that require a user name and password.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-only. Due to security considerations, when you try to read this property, NULL is returned instead of the password value.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PollingLocation Property

Contains the name of the directory to poll (directory, message queue, and so on) for receive functions that require polling.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string PollingLocation;

Parameters

None

Return Values

Returns the name of the directory to poll (directory, message queue, and so on) for receive functions that require polling.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 260 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PreProcessor Property

Contains a value that indicates any preprocessing that must be done for a received document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string PreProcessor;

Parameters

None

Return Values

Returns a value indicating any preprocessing that must be done for a received document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that is currently processing the interchange.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that is currently processing the interchange.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProtocolType Property

Contains the enumeration value used to represent the type of the receive function component.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ProtocolType;

Parameters

None

Return Values

Returns the enumeration value used to represent the type of the receive function component. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "File", "MSMQ", and "HTTP", which map to the integers 1, 2, and 3, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the values:

Values {"File", "MSMQ", "HTTP"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SourceID Property

Contains the ID of the organization or application that sends the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SourceID;

Parameters

None

Return Values

Returns the ID of the organization or application that sends the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SourceQualifier Property

Contains the ID type of the organization or application that sends the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SourceQualifier;

Parameters

None

Return Values

Returns the ID type of the organization or application that sends the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions. The value of this property can be a phone number, a Dunn & Bradstreet number, and so on.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


TransportURL Property

Contains the transport URL, indicating how and where the HTTP receive function submits the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string TransportURL;

Parameters

None

Return Values

Returns the transport URL, indicating how and where the HTTP receive function submits the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Username Property

Contains the user name to use for FTP or Message Queuing receive functions.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Username;

Parameters

None

Return Values

Returns the user name to use for FTP or Message Queuing receive functions.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_RetryQueue

Represents a logical grouping of interchanges in the Shared queue that are awaiting receipt correlation, or interchanges that are due to be sent to multiple destinations.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_RetryQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_RetryQueue

[C++]

class MicrosoftBizTalkServer_RetryQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_RetryQueue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
Group | Contains the name of the group to which the queue belongs.
LastRetryTime | Contains a value that indicates the last time the server attempted a transmission.
ProcessingServer | Contains the name of the server that last processed the document.
QID | Contains a value that identifies an instance of the class.
RemainingRetryCount | Contains a value that indicates the number of outstanding retries remaining.
RetryInterval | Contains a value that indicates the wait time between retry intervals, in minutes.
ServiceWindowFromTime | Contains a value that indicates the start time of the service window in which to send interchanges.
ServiceWindowToTime | Contains a value that indicates the end time of the service window in which to send interchanges.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_RetryQueue defines the following method:

Method | Description
MoveToSuspendedQueue | Enables the administrator to move the selected document to the Suspended queue.

Remarks

MicrosoftBizTalkServer_RetryQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


LastRetryTime Property

Contains a value that indicates the last time the server attempted a transmission.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime LastRetryTime;

Parameters

None

Return Values

Returns the last time the server attempted a transmission.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MoveToSuspendedQueue Method

Enables the administrator to move the selected document to the Suspended queue.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 MoveToSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

Calling this method will not raise a DocSuspendedEvent.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that last processed the document.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that last processed the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This is a read-only property.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RemainingRetryCount Property

Contains a value that indicates the number of outstanding retries remaining.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 RemainingRetryCount;

Parameters

None

Return Values

Returns the number of outstanding retries remaining.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RetryInterval Property

Contains a value that indicates the wait time between retry intervals, in minutes.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 RetryInterval;

Parameters

None

Return Values

Returns the wait time between retry intervals, in minutes.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowFromTime Property

Contains a value that indicates the start time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowFromTime;

Parameters

None

Return Values

Returns the start time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowToTime Property

Contains a value that indicates the end time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowToTime;

Parameters

None

Return Values

Returns the end time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_ScheduledQueue

Represents a logical grouping of interchanges in the Shared queue that are scheduled to be delivered at a later time based on a service window.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_ScheduledQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_ScheduledQueue

[C++]

class MicrosoftBizTalkServer_ScheduledQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_ScheduledQueue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
Group | Contains the name of the group to which the queue belongs.
ProcessingServer | Contains the name of the server that last processed the document.
QID | Contains a value that identifies an instance of the class.
ServiceWindowFromTime | Contains a value that indicates the start time of the service window in which to send interchanges.
ServiceWindowToTime | Contains a value that indicates the end time of the service window in which to send interchanges.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_ScheduledQueue defines the following method:

Method | Description
MoveToSuspendedQueue | Enables the administrator to move the selected document to the Suspended queue.

Remarks

MicrosoftBizTalkServer_ScheduledQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MoveToSuspendedQueue Method

Enables the administrator to move the selected document to the Suspended queue.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 MoveToSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

Calling this method will not raise a DocSuspendedEvent.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that last processed the document.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that last processed the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowFromTime Property

Contains a value that indicates the start time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowFromTime;

Parameters

None

Return Values

Returns the start time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in interval format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowToTime Property

Contains a value that indicates the end time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowToTime;

Parameters

None

Return Values

Returns the end time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in interval format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_Server

Represents specific Windows 2000 computers within a BizTalk Server group that are running BizTalk Messaging Services.

Hierarchy

MicrosoftBizTalkServer_Server

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_Server

[C++]

class MicrosoftBizTalkServer_Server

Members

MicrosoftBizTalkServer_Server defines the following properties:

Property | Description
DateModified | Contains the date of the last modification of the instance data.
GroupName | Contains the name of the group to which the server belongs.
MaxRecvSvcThreadsPerProcessor | Contains the maximum number of receive function threads that BizTalk Server can use per processor for asynchronous calls.
MaxWorkerThreadsPerProcessor | Contains the maximum number of worker threads that BizTalk Server can use per processor for asynchronous calls.
Name | Contains the name of the server.
ParticipateInWorkItemProcessing | Contains a value that indicates whether the server participates in work-item processing.
SchedulerWaitTime | Contains the time interval that BizTalk Server Scheduler waits between tries, in milliseconds.
ServiceState | Contains a value that indicates the state of the BizTalk services on a particular server.

MicrosoftBizTalkServer_Server defines the following methods:

Method | Description
FreeInterchanges | Frees interchanges that are currently assigned to a specific server if the server is stopped, removed, or in an error state, so that other servers can use these interchanges.
RegisterServerInAD | Registers the BizTalk Server in the Microsoft Active Directory.
StartServer | Starts the BizTalk services on a specific server.
StopServer | Stops the BizTalk services on a specific server.
UnregisterServerInAD | Unregisters the BizTalk Server in the Microsoft Active Directory.

Remarks

MicrosoftBizTalkServer_Server is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DateModified Property

Contains the date of the last modification of the instance data.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime DateModified;

Parameters

None

Return Values

Returns the date of the last modification of the instance data.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


FreeInterchanges Method

Frees interchanges that are currently assigned to a specific server if the server is stopped, removed, or in an error state, so that other servers can use these interchanges.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 FreeInterchanges();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupName Property

Contains the name of the group to which the server belongs.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupName;

Parameters

None

Return Values

Returns the name of the group to which the server belongs.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MaxRecvSvcThreadsPerProcessor Property

Contains the maximum number of receive function threads that BizTalk Server can use per processor for asynchronous calls.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 MaxRecvSvcThreadsPerProcessor = 4;

Parameters

None

Return Values

Returns the maximum number of receive function threads that BizTalk Server can use per processor for asynchronous calls.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 4.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MaxWorkerThreadsPerProcessor Property

Contains the maximum number of worker threads that BizTalk Server can use per processor for asynchronous calls.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 MaxWorkerThreadsPerProcessor = 4;

Parameters

None

Return Values

Returns the maximum number of worker threads that BizTalk Server can use per processor for asynchronous calls.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 4.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ParticipateInWorkItemProcessing Property

Contains a value that indicates whether the server participates in work-item processing.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean ParticipateInWorkItemProcessing = 1;

Parameters

None

Return Values

Returns a language-specific value representing true if the server participates in work-item processing; if the server does not participate in work-item processing, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is TRUE.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RegisterServerInAD Method

Registers the BizTalk Server in the Microsoft Active Directory.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 RegisterServerInAD();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SchedulerWaitTime Property

Contains the time interval that BizTalk Server Scheduler waits between tries, in milliseconds.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 SchedulerWaitTime = 2000;

Parameters

None

Return Values

Returns the time interval that BizTalk Server Scheduler waits between tries, in milliseconds.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 2,000 milliseconds.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceState Property

Contains a value that indicates the state of the BizTalk services on a particular server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ServiceState;

Parameters

None

Return Values

Returns the state of the BizTalk services on a particular server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


StartServer Method

Starts the BizTalk services on a specific server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 StartServer();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The execution of this method is valid any time the specific server is stopped.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


StopServer Method

Stops the BizTalk services on a specific server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 StopServer();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The execution of this method is valid any time the specific server is running.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


UnregisterServerInAD Method

Unregisters the BizTalk Server in the Microsoft Active Directory.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 UnregisterServerInAD();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_SuspendedQueue

Represents a logical grouping of interchanges in the Shared queue that could not be successfully processed.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_SuspendedQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_SuspendedQueue

[C++]

class MicrosoftBizTalkServer_SuspendedQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_SuspendedQueue defines the following properties:

Property | Description
ChannelHandle | Contains the handle of the channel used for processing the interchange or document in the Suspended queue.
Destination | Contains the name of the organization or application that receives the document.
DocName | Contains the name of the document definition related to the document in the queue.
ErrorDescription | Contains the first 64 characters of the error description.
Group | Contains the name of the group to which the queue belongs.
QGUID | Contains the submission GUID of the Suspended queue work item.
QID | Contains a value that identifies an instance of the class.
Size | Contains the approximate size of the interchange or document in the Suspended queue, in bytes.
Source | Contains the name of the organization or application that sends the document.
State | Contains a value that indicates the state of the document or interchange in the Suspended queue.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_SuspendedQueue defines the following methods:

Method | Description
Resubmit | Enables an administrator to resubmit the selected document to the server.
ViewDocument | Enables an administrator to view the contents of a selected document in the Suspended queue.
ViewErrorDescription | Enables the administrator to view a description of the error.
ViewInterchange | Enables the administrator to view the contents of a selected interchange in the Suspended queue.

Remarks

MicrosoftBizTalkServer_SuspendedQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ChannelHandle Property

Contains the handle of the channel used for processing the interchange or document in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ChannelHandle;

Parameters

None

Return Values

Returns the handle of the channel used for processing the interchange or document in the Suspended queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocName Property

Contains the name of the document definition related to the document in the queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocName;

Parameters

None

Return Values

Returns the name of the document definition related to the document in the queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ErrorDescription Property

Contains the first 64 characters of the error description.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ErrorDescription;

Parameters

None

Return Values

Returns the first 64 characters of the error description.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 64 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QGUID Property

Contains the submission GUID of the Suspended queue work item.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string QGUID;

Parameters

None

Return Values

Returns the submission GUID of the Suspended queue work item.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Resubmit Method

Enables an administrator to resubmit the selected document to the server.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 Resubmit();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This method enables an administrator to resubmit interchanges after problems have been fixed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Size Property

Contains the approximate size of the interchange or document in the Suspended queue, in bytes.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 Size;

Parameters

None

Return Values

Returns the approximate size of the interchange or document in the Suspended queue, in bytes.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


State Property

Contains a value that indicates the state of the document or interchange in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 State;

Parameters

None

Return Values

Returns the state of the document or interchange in the Suspended queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The tables in this section show the possible processing states of a document or interchange in the Suspended queue.

Documents in the states listed in the following table are at the interchange level, so you should use the ViewInterchange method to view the data. In addition, interchanges in these states cannot be resubmitted, so in this case you should not call Resubmit.

Value | State
0 | Initial
1 | Custom component
2 | Parsing

Documents in the states listed in the following table are considered documents instead of interchanges, so you should use the ViewDocument method to view the data. In addition, documents in the document validation state (3) cannot be resubmitted, so for those documents you should not call Resubmit.

Value | State
3 | Document validation
4 | Channel selection
5 | Field tracking
6 | Correlating
7 | Mapping
8 | Serializing

Documents in the states listed in the following table are considered interchanges, so you should use the ViewInterchange method to view the data.

Value | State
9 | Encoding
10 | Signing
11 | Encrypting
12 | Transmitting

Note that the ViewErrorDescription method can be used to retrieve error description information about failed documents and interchanges.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ViewDocument Method

Enables an administrator to view the contents of a selected document in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--QID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 ViewDocument(

uint8 Document[],

uint32 CodePage

);

Parameters

Document

[out] An array of bytes, representing the information in the document. This data may need to be converted into a readable format. The maximum size for this parameter is 4 MB. If the data exceeds 4 MB, the data will be truncated. For more information, see "Remarks".

CodePage

[out] The code page of the document. For more information, see "Remarks".

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The following table shows the possible values for the CodePage parameter and their meanings.

Value | Description
-1 | No code page available
0 | Default system code page
1200 | Unicode code page
1252 | ASCII code page

If the value returned in the CodePage parameter is 0 or 1200, the data can be displayed and no conversion is needed. However, if the value is -1, you should try loading the data into Microsoft XML (MSXML).

If the value returned in CodePage is 1252, you should try loading the data into MSXML. If this fails, you can use the MultiByteToWideChar function, passing in CodePage as the code page parameter to the Microsoft Win32® API.

If the data contained in the Document parameter is larger than 4 MB, C++ programmers can use the GetSuspendedQueueItemDetails method to retrieve the document.

ViewDocument is not available in a tools-only installation of BizTalk Server 2002.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ViewErrorDescription Method

Enables the administrator to view a description of the error.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 ViewErrorDescription(

string CompleteErrorDescription

);

Parameters

CompleteErrorDescription

[out] A string describing the error.

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ViewInterchange Method

Enables the administrator to view the contents of a selected interchange in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 ViewInterchange(

uint8 Interchange[],

uint32 CodePage

);

Parameters

Interchange

[out] An array of bytes, representing the information in the interchange. This data may need to be converted into a readable format. The maximum size for this parameter is 4 MB. If the data exceeds 4 MB, the data will be truncated. For more information, see "Remarks".

CodePage

[out] The code page of the interchange. For more information, see "Remarks".

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The following table shows the possible values for the CodePage parameter and their meanings.

Value | Description
-1 | No code page available
0 | Default system code page
1200 | Unicode code page
1252 | ASCII code page

If the value returned in the CodePage parameter is 0 or 1200, the data can be displayed and no conversion is needed. However, if the value is -1, you should try loading the data into MSXML.

If the value returned in CodePage is 1252, you should try loading the data into MSXML. If this fails, you can use the MultiByteToWideChar function, passing in CodePage as the codepage parameter to the Win32 API.

If the data contained in the Interchange parameter is larger than 4 MB, C++ programmers can use the GetSuspendedQueueItemDetails method to retrieve the interchange.

ViewInterchange is not available in a tools-only installation of BizTalk Server 2002.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_WorkQueue

Represents a logical grouping of interchanges in the Shared queue that are currently in process.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_WorkQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_WorkQueue

[C++]

class MicrosoftBizTalkServer_WorkQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_WorkQueue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
DocName | Contains the name of the document definition related to the document in the queue.
EngineState | Contains a value that indicates whether the work item is waiting for receipt correlation or waiting for transmission.
Group | Contains the name of the group to which the queue belongs.
ProcessingServer | Contains the name of the server that last processed the document.
QID | Contains a value that identifies an instance of the class.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_WorkQueue defines the following method:

Method | Description
MoveToSuspendedQueue | Enables the administrator to move the selected document to the Suspended queue.

Remarks

MicrosoftBizTalkServer_WorkQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocName Property

Contains the name of the document definition related to the document in the queue.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocName;

Parameters

None

Return Values

Returns the name of the document definition related to the document in the queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


EngineState Property

Contains a value that indicates whether the work item is waiting for receipt correlation or waiting for transmission.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 EngineState;

Parameters

None

Return Values

Returns a value that indicates whether the work item is waiting for receipt correlation or waiting for transmission.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The possible values for this property are defined by the BTSCoreQueueStates enumeration, as shown in the following code:

typedef enum {

Processing = STATE_TRANSLATION,

Correlation = STATE_RECEIPT_CORRELATION,

TransmissionWServiceWindow = STATE_FIND_TRANSMISSION,

Transmission = STATE_TRANSMISSION

} BTSCoreQueueStates;

The following table provides the numerical values of the constants defined in the BTSCoreQueueStates enumeration.

Value | Constant
29 | Processing
30 | Correlation
31 | TransmissionWServiceWindow
33 | Transmission

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MoveToSuspendedQueue Method

Enables the administrator to move the selected document to the Suspended queue.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

type name;

uint32 MoveToSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

Calling this method will not raise a DocSuspendedEvent.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that last processed the document.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that last processed the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MSBTS_CustomCounter

Retrieves the value of the custom counter query.

Hierarchy

CIM_ManagedSystemElement

|--CIM_LogicalElement

|--MSBTS_CustomCounter

Declaration

[Visual Basic]

Class MSBTS_CustomCounter

[C++]

class MSBTS_CustomCounter : CIM_LogicalElement

Members

MSBTS_CustomCounter defines the following properties:

Property | Description
GroupCounterName | Contains the Tracking database and custom counter names.
MatchCount | Contains the number of documents that match the criteria specified by the custom counter setting.
Name | Contains the name of the custom counter.

Remarks

MSBTS_CustomCounter is derived from CIM_LogicalElement.

MSBTS_CustomCounter is a dynamic class that is automatically created for every instance of MSBTS_CustomCounterSetting.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupCounterName Property

Contains the Tracking database and custom counter names.

Member List

MSBTS_CustomCounter

|--GroupCounterName

|--MatchCount

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupCounterName;

Parameters

None

Return Values

This property returns the Tracking database and custom counter names.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

For a custom counter with a GroupName property of "BizTalk Server Group" and a Name property of "My Custom Counter", the value for this property would be "BizTalk Server Group\MyCustomCounter".

This property is required to distinguish between custom counters with the same name that monitor different DTA databases.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MatchCount Property

Contains the number of documents that match the criteria specified by the custom counter setting.

Member List

MSBTS_CustomCounter

|--GroupCounterName

|--MatchCount

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 MatchCount;

Parameters

None

Return Values

This property returns the number of documents that match the query associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Note that this property counts both inbound and outbound documents. For example, if a single document passes through the system and no mapping is performed, then MatchCount will be incremented by two.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the custom counter.

Member List

MSBTS_CustomCounter

|--GroupCounterName

|--MatchCount

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

This property returns the name of the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

Both MSBTS_CustomCounter and MSBTS_CustomCounterSetting share the same value for their key property, Name.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MSBTS_CustomCounterSetting

Creates, deletes, and validates custom counters.

Hierarchy

CIM_Setting

|--MSBTS_CustomCounterSetting

Declaration

[Visual Basic]

Class MSBTS_CustomCounterSetting

[C++]

class MSBTS_CustomCounterSetting : CIM_Setting

Members

MSBTS_CustomCounterSetting defines the following properties:

Property | Description
DestOrgName | Contains the name of the destination organization associated with the custom counter.
DestQualifier | Contains the name of the destination qualifier type associated with the custom counter.
DestQualifierValue | Contains the value of the destination qualifier type associated with the custom counter.
DocType | Contains the name of the root element from the document schema.
GroupName | Contains the name of the BizTalk Server group against which the custom counter query executes.
Name | Contains the name of the custom counter.
SrcOrgName | Contains the name of the source organization associated with the custom counter.
SrcQualifier | Contains the name of the source qualifier type associated with the custom counter.
SrcQualifierValue | Contains the value of the source qualifier type associated with the custom counter.
TimeInterval | Contains the time over which to accumulate the custom counter query value, in seconds.

MSBTS_CustomCounterSetting defines the following method:

Method | Description
IsValid | Validates the custom counter creation parameters.

Remarks

MSBTS_CustomCounterSetting is derived from CIM_Setting.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestOrgName Property

Contains the name of the destination organization associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestOrgName;

Parameters

None

Return Values

This property returns the name of the destination organization associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

When the destination information is not explicitly declared in the messaging port the string value that is tracked for DstOrgName is "<OPEN DESTINATION>". For more information, see How Interchanges and Documents Are Logged.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestQualifier Property

Contains the name of the destination qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestQualifier;

Parameters

None

Return Values

This property returns the name of the destination qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestQualifierValue Property

Contains the value of the destination qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestQualifierValue;

Parameters

None

Return Values

This property returns the value of the destination qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocType Property

Contains the name of the root element from the document schema.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocType;

Parameters

None

Return Values

This property returns the name of the root element from the document schema.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

When a document specification is created using BizTalk Editor, you can specify the Document Type reference property to a user-defined string value. If the root XML element is not defined, the value of the Document Type reference property, if defined, will be tracked as the DocType value. For more information, see Set Reference Properties.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupName Property

Contains the name of the BizTalk Server group against which the custom counter query executes.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupName;

Parameters

None

Return Values

This property returns the name of the BizTalk Server group against which the custom counter query executes.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property is used to look up the database name, server, user name, and password, and to validate the custom counter parameters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


IsValid Method

Validates the custom counter creation parameters.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 IsValid(

boolean IsValidSrcOrg,

boolean IsValidSrcId,

boolean IsValidDestOrg,

boolean IsValidDestId,

boolean IsValidGroup

);

Parameters

IsValidSrcOrg

[out] Returns a language-specific value representing true if the source organization name is valid; otherwise, if the source organization name is not valid, this parameter returns a language-specific value representing false.

IsValidSrcId

[out] Returns a language-specific value representing true if the source identifier name is valid; otherwise, if the source identifier name is not valid, this parameter returns a language-specific value representing false.

IsValidDestOrg

[out] Returns a language-specific value representing true if the destination organization name is valid; otherwise, if the destination organization name is not valid, this parameter returns a language-specific value representing false.

IsValidDestId

[out] Returns a language-specific value representing true if the destination identifier name is valid; otherwise, if the destination identifier name is not valid, this parameter returns a language-specific value representing false.

IsValidGroup

[out] Returns a language-specific value representing true if the BizTalk Server group name is valid; otherwise, if the BizTalk Server group name is not valid, this parameter returns a language-specific value representing false.

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

This property returns the name of the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

Both MSBTS_CustomCounterSetting and MSBTS_CustomCounter share the same value for their key property, Name.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SrcOrgName Property

Contains the name of the source organization associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SrcOrgName;

Parameters

None

Return Values

This property returns the name of the source organization associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

When the source information is not explicitly declared in the channel, the string value that is tracked for SrcOrgName is "<OPEN SOURCE>". For more information, see How Interchanges and Documents Are Logged.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SrcQualifier Property

Contains the name of the source qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SrcQualifier;

Parameters

None

Return Values

Returns the name of the source qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SrcQualifierValue Property

Contains the value of the source qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SrcQualifierValue;

Parameters

None

Return Values

Returns the value of the source qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


TimeInterval Property

Contains the time over which to accumulate the custom counter query value, in seconds.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 TimeInterval;

Parameters

None

Return Values

Returns the time over which to accumulate the custom counter query value, in seconds.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ReceiveFunctionDisabledEvent

Represents events raised by disabled receive functions.

Hierarchy

__ExtrinsicEvent

|--ReceiveFunctionDisabledEvent

Declaration

[Visual Basic]

Class ReceiveFunctionDisabledEvent

[C++]

class ReceiveFunctionDisabledEvent : __ExtrinsicEvent

Members

ReceiveFunctionDisabledEvent defines the following property:

Property | Description
Name | Contains the name of the disabled receive function.

Remarks

ReceiveFunctionDisabledEvent inherits from the __ExtrinsicEvent system class, an abstract base class that serves as a superclass for all user-defined event types.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the disabled receive function.

Member List

ReceiveFunctionDisabledEvent

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the disabled receive function.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This event is raised when a receive function is disabled.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Error Messages

The properties and methods of the BizTalk™ Messaging Services and BizTalk Orchestration Services object models use standard Component Object Model (COM) HRESULT return values to communicate whether the operation was successful or not.

In C++, these values are the actual return values from the methods themselves (including property get_ and put_ methods). The program must explicitly perform error checking by examining these return values, or use some variation of structured error handling.

In Microsoft® Visual Basic®, and in Microsoft Visual Basic Scripting Edition (VBScript), these values are placed in the Number property of the global Err object. Error handling is either handled automatically, displaying a standard error dialog box, or explicitly by the program, checking the value of the Number property of the global Err object. The On Error Resume Next command disables automatic error handling, thereby enabling explicit error handling.

For additional information about error message values, see the following sections:

  • Messaging Services Error Messages

  • Orchestration Services Error Messages

  • Standard COM Error Messages


Messaging Services Error Messages

The BizTalk Messaging Services object model error messages defined by BizTalk Server can be used in your application by including the bts_config_errors.h file located in the BizTalk Server installation directory at \Program Files\Microsoft BizTalk Server\SDK\Include. These error messages, returned during design time by the methods and properties of the object model, contain a BTS_ prefix in the message name. All other errors occur during run time, while BizTalk Server is processing a document.

The following table contains both design time and run time errors.

Message name | Value | Description
CIS_E_OBJECT_NOT_FOUND | 0x0100 | The object was not found.
CIS_E_STATE_NOT_FOUND | 0x0101 | The state engine state was not found in the messaging port definition.
CIS_E_STATE_TRANSITION | 0x0103 | The state table contains a bad engine state transition.
CIS_E_BAD_ENGINE_CONFIG_FILE | 0x0105 | The string that describes the input state configuration is not valid.
CIS_E_CANNOT_ADD_STATE | 0x0106 | BizTalk Server could not add the user-defined state to the system.
CIS_E_NO_COMPONENT_FOUND | 0x0107 | There is no component in the state definition or the ProgID is wrong.
CIS_E_PIPECOMP_ADMIN_REQUIRED | 0x0108 | The required IPipelineComponentAdmin interface was not found on the component.
CIS_E_BAD_COMPONENT_TYPE | 0x0109 | The component type specified for the state engine is not recognized.
CIS_E_BAD_STATE_CONFIG | 0x010A | The state configuration is not valid.
CIS_E_BAD_STATE_TYPE | 0x010B | The specified state type is not recognized.
CIS_E_BAD_COMPONENT_CONFIG | 0x010C | The component configuration is not valid.
CIS_E_INTERNAL_FAILURE | 0x010F | An internal server failure occurred due to an unknown cause.
CIS_E_CREATE_SCHEDULER_FAILED | 0x0111 | The Queue Scheduler for the service could not be created.
CIS_E_AGREEMENT_SELECT_FAILED | 0x0112 | No channels matched the input criteria. Verify that a messaging port and a channel exist, and that they match the following fields: Source qualifier: "%1" Source identifier value: "%2" Source document name: "%3" Destination qualifier: "%4" Destination identifier value: "%5" Also verify that any expressions specified for the channels are compatible with this document.
CIS_E_ERROR | 0x0113 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1
CIS_E_SERVICE_INITIALIZATION_FAILURE | 0x0114 | The service failed to start. Verify that this server is enlisted in a BizTalk Server group.
CIS_E_SCHEDULER_FAILED | 0x0115 | The Queue Scheduler failed and has exited.
CIS_E_WORKER_THREAD_FAILED | 0x0116 | A worker thread failed and has exited.
CIS_E_SHARED_QUEUE_DB_EXEC_FAILED | 0x0117 | Execution against the Shared Queue database has failed.
CIS_E_CANT_READ_WORK_ITEM | 0x0119 | A work item in the Shared Queue database cannot be read.
CIS_E_CHECKPOINT_FAILED | 0x011c | Checkpointing the work item failed.
CIS_E_CREATE_DEAD_WORK_ITEM_FAILED | 0x011e | A new work item in the Suspended queue cannot be created.
CIS_E_GET_SNAPSHOT_FAILED | 0x0122 | A snapshot of the Shared Queue database cannot be taken.
CIS_E_FREE_INTERCHANGES_FAILED | 0x0124 | The specified interchanges cannot be freed.
CIS_E_DELETE_INTERCHANGE_FAILED | 0x0125 | The specified interchange cannot be deleted.
CIS_E_RECEIVING_INTERCHANGE_FAILED | 0x0127 | The specified interchange was not received.
CIS_E_GETTING_NEXT_SCHEDULED_WORK_ITEM_FAILED | 0x0128 | The next scheduled work item cannot be obtained for processing.
CIS_E_GET_COUNT_FAILED | 0x0129 | The count on the shared queues cannot be obtained.
CIS_E_TRANSMISSION_FAILED | 0x012a | All retry transmissions failed.
CIS_W_TRANSMISSION_ATTEMPT_FAILED | 0x012b | A transmission attempt failed.
CIS_W_TRANSMISSION_XFER_TO_SECONDARY | 0x012c | The primary transport for messaging port "%1" cannot transmit the data. The server will switch to the secondary transport.
CIS_E_RECEIPT_GENERATION_FAILED | 0x012e | After creating the work item, the attempt to generate a receipt failed.
CIS_E_RECEIPT_GENERATION_FAILED_NO_WORK_ITEM | 0x012f | The attempt to generate a receipt failed before the work item was created.
CIS_E_L1_RECEIPT_CORRELATION_FAILED | 0x0130 | Receipt correlation failed.
CIS_E_AGREEMENT_LACKING_PARAMS | 0x0133 | At least one of the fields necessary to select a channel is missing. Verify that your document and envelopes extract the proper fields for the parser, or specify the necessary fields upon submission. Channel selection fields: Source identifier type: "%1" Source identifier value: "%2" Source document name: "%3" Destination identifier type: "%4" Destination identifier value: "%5"
CIS_E_AGREEMENT_FAILED | 0x0134 | The channel cannot be selected.
CIS_E_ORIGINAL_L1_INTERCHANGE_MISSING | 0x0135 | When trying to correlate an incoming receipt, the original interchange and related document(s) are no longer present.
CIS_E_UNEXPECTED_DB_BEHAVIOR | 0x0136 | An unexpected return occurred. The database may need to be restarted.
CIS_E_AGREEMENT_INVALID_MAP | 0x0137 | The map specified by the reference "%1" is not valid. Verify that the reference points to a valid map created by BizTalk Mapper.
CIS_I_SERVICE_MSG | 0x0138 | 1%
CIS_E_AGREEMENT_MAP_FAILED | 0x0139 | The XML document could not be translated. The map specified by reference "%1" failed. Verify that the map is up to date.
CIS_E_XML_ERROR | 0x013A | The XML document could not be parsed on line: %2, position: %3 for the following reason: "%1"
CIS_E_AGREEMENT_PROCESSING_FAILED | 0x013f | The server could not finish processing the document.
CIS_E_AGREEMENT_PROCESSING_FAILED_W_NAME | 0x0140 | The following channel configuration setting is not valid: "%1"
CIS_E_AGREEMENT_INVALID_QUERY | 0x0141 | The "%2" query for the "%1" document tracking field is not a valid XSL pattern. This pattern must be removed or corrected.
CIS_I_SERVICE_START | 0x0142 | The service has started.
CIS_I_SERVICE_STOP | 0x0143 | The service has stopped.
CIS_E_ERROR_EX | 0x0144 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_E_ERROR_EX_HEAD | 0x0145 | An error occurred in BizTalk Server.
CIS_E_ERROR_EX_FOOT | 0x0146 |
CIS_E_INVALID_DATA_FORMAT | 0x0147 | The business document that was passed in is not in a recognized format and could not be parsed or decrypted.
CIS_E_CREATE_ENGINE | 0x0148 | BizTalk Server was unable to create a new instance of the processing engine to process a work item. This might be due to a failure to create a new COM+ transaction.
CIS_E_MISSING_DESTINATION_DOCUMENT_SPEC | 0x0149 | BizTalk Server has detected an incomplete messaging port. The destination specification is missing from the messaging port.
CIS_E_PROCESSING_THREAD_FAILED | 0x014A | The processing thread failed to start. This might be due to a failure to create the state engine.
CIS_E_NOSRCORG | 0x014B | No source organization that corresponds to the ID and Qualifier pair has been specified.
CIS_E_NODESTORG | 0x014C | No destination organization that corresponds to the Identifier and Qualifier pair has been specified.
CIS_E_NODOC | 0x014D | No document that corresponds to the document name has been specified.
CIS_E_NOPIPELINES | 0x014E | No channel that corresponds to the parameters has been specified.
CIS_E_NOT_RESUBMITTABLE | 0x014F | The state of the item in the Suspended queue does not allow resubmission.
CIS_E_PIPESELECT_POLICY_FAILED | 0x0150 | No channels matched the certificates that were found with the incoming data. The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_E_SUBMIT_INVALIDDOC | 0x0151 | The submitted document is not valid. See the following messages for more details.
CIS_E_SUBMITSYNC_TOOMANYDOCS | 0x0152 | The SubmitSync method failed because multiple documents where found within the data. Only one document is allowed per synchronous submission. If this is a structured flat-file submission, then the most common cause of failure is extra leading or trailing white space around the data.
CIS_E_SUBMITSYNC_TOOMANYPIPES | 0x0153 | The synchronous submission could not be completed because multiple valid channels matched the incoming document. Only one channel is allowed to match the incoming document.
CIS_E_XMIT_NOTRANSPORTCOMP | 0x0154 | This server could not create a component with the class ID "%1" for transport. Verify that this component is properly registered. The following error was returned:
CIS_E_XMIT_EMPTY_DOCUMENT | 0x0155 | Messaging port "%1" cannot transmit a zero-byte document.
CIS_E_XMIT_FAILED_W_NAME | 0x0156 | The server could not finish processing messaging port "%1".
CIS_E_XMIT_NO_INTERFACE | 0x0157 | The server could not obtain the "%1" interface from the transport component with CLSID "%2".
CIS_E_XMIT_NO_BTS_AIC_INTERFACES | 0x0158 | The server could not obtain either the "%1" or "%2" interfaces from the BizTalk Server application integration component with CLSID "%3".
CIS_E_XMIT_FAILED_W_DETAILS | 0x0159 | The server encountered a transport error while processing the messaging port "%1", which uses a transport component with a ProgID of "%2".
CIS_E_NOHDR_ERROR_EX | 0x015A | %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_W_COMP_NOACK | 0x015B | The correlation component "%1" could not find a document for which to send a receipt. No action will be taken.
CIS_E_CORRELATIONCOMP_FAILED | 0x015C | The correlation component "%1" returned an unexpected failure. The document will be placed in the Suspended queue.
CIS_E_CORRELATION_FAILED | 0x015D | Receipt correlation processing failed.
CIS_E_XML_VALIDATE_ERROR | 0x015E | The XML document has failed validation for the following reason: %1
CIS_E_CHANNEL_ACCESSDENIED | 0x015F | The submitted document does not have the necessary signature or encryption required by channel "%3". The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_I_SERVICE_RESTARTING | 0x0160 | The service is restarting.
BTS_E_CONSTRAINT | 0x1201 | Constraint Error
BTS_E_NOOBJECT | 0x1202 | The object was not found.
BTS_E_INTERNALFAILURE | 0x1203 | An internal failure occurred.
BTS_E_ENVELOPE_CONTROLNUMBER | 0x120C | If the envelope format is set to X12 or EDIFACT, the control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_DELIMETER | 0x120D | If the envelope format is set to X12, then delimiters are required and must be set.
BTS_E_ENCRYPTION_CUSTOM_NOCLSID | 0x120E | If the encryption type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_ENCODING_CUSTOM_NOCLSID | 0x120F | If the encoding type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_SIGNATURE_CUSTOM_NOCLSID | 0x1210 | If the signature type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_INVALIDCONTROLNUMBER | 0x1212 | The control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_INUSE | 0x1213 | The format of the envelope cannot be changed because it is used in a messaging port.
BTS_E_CHANNEL_MISSINGMAPSOURCE | 0x1215 | The channel is missing the MapSource node.
BTS_E_INVALID_CERT_USAGE | 0x1216 | The certificate is not valid for the current usage. An encryption certificate cannot be used for signing; nor can a signing certificate be used for encryption. Make sure that the correct certificate is selected.
BTS_E_MISSINGSMTPHOST | 0x1218 | The SMTP host is missing. The SMTP host can be configured in BizTalk Server Administration.
BTS_E_INVALID_ENCRYPT_STORE | 0x1219 | The encryption store type is not valid. The store type must be BIZTALK.
BTS_E_INVALID_SGNTCERT_STORE | 0x121A | The signature store type is not valid. The store type must be MY.
BTS_E_DATATOOLONG | 0x121B | The data length is too long.
BTS_E_INVALID_VERIFY_ENCRYPTCERT_STORE | 0x121C | The encryption verification store type is not valid. The store type must be MY.
BTS_E_INVALID_VERIFY_SGNTCERT_STORE | 0x121D | The signature verification store type is not valid. The store type must be BIZTALK.
BTS_E_ORGANIZATION_UNIQUE_ID | 0x121F | The organization identifier must be a unique identifier.
BTS_E_ORGANIZATION_UNIQUE_NAME | 0x1220 | The organization name must be a unique name.
BTS_E_OBJECT_ALREADY_EXISTS | 0x1221 | The object already exists. You cannot call the Create() method on a BizTalk Messaging Configuration object multiple times without also calling the Clear() or Remove() methods.
BTS_E_ALIAS_UNIQUE_ID | 0x1222 | The identifier must be a unique identifier.
BTS_E_ALIAS_UNIQUE_NAME | 0x1223 | The identifier name for this organization must be a unique name.
BTS_E_ALIAS_UNIQUE_QUALIFIERVALUE | 0x1225 | The identifier must have a unique qualifier-value pair.
BTS_E_ALIAS_FOREIGN_OWNERID | 0x1226 | The organization cannot be removed because it is referred to by an identifier.
BTS_E_XMLSHARE_UNIQUE_ID | 0x1227 | The primary identifier for the XML Share table in the SQL Server database must be a unique identifier.
BTS_E_XMLSHARE_UNIQUE_REFERENCE | 0x1228 | The reference for the XML Share table in the SQL Server database must be a unique reference.
BTS_E_DOCUMENT_UNIQUE_ID | 0x1229 | The document identifier must be a unique identifier.
BTS_E_DOCUMENT_UNIQUE_NAME | 0x122A | The document name must be a unique name.
BTS_E_DOCUMENT_FOREIGN_SHAREID | 0x122C | The XML Share table in the SQL Server database cannot be removed because it is referred to by a document.
BTS_E_ENVELOPE_UNIQUE_ID | 0x122D | The envelope identifier must be a unique identifier.
BTS_E_ENVELOPE_UNIQUE_NAME | 0x122E | The envelope name must be a unique name.
BTS_E_ENVELOPE_FOREIGN_SHAREID | 0x1230 | The XML Share table in the SQL Server database cannot be removed because it is referred to by an envelope.
BTS_E_CONTROLNUMBER_UNIQUE_ID | 0x1231 | The control-number identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_ID | 0x1232 | The distribution list identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_NAME | 0x1233 | The distribution list name must be a unique name.
BTS_E_MISSING_VALUE | 0x1235 | The identifier value property must have a value.
BTS_E_MISSING_SRCORGID | 0x1236 | The Channel SourceOrganization property must have a value.
BTS_E_APPLICATION_UNIQUE_ID | 0x1237 | The application identifier must be a unique identifier.
BTS_E_APPLICATION_FOREIGN_OWNERID | 0x1238 | The organization cannot be removed because it is referred to by an application.
BTS_E_APPLICATION_UNIQUE_NAME | 0x1239 | For applications within this organization, the application name must be a unique name.
BTS_E_CHANNEL_UNIQUE_ID | 0x123A | The channel identifier must be a unique identifier.
BTS_E_CHANNEL_UNIQUE_NAME | 0x123B | The channel name must be a unique name.
BTS_E_CHANNEL_FOREIGN_INPDOCID | 0x123D | The inbound document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_OUTDOCID | 0x123E | The output document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_PORTGROUPID | 0x123F | The distribution list cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_SRCORGID | 0x1240 | The source organization cannot be removed because it is used by a channel.
BTS_E_ENVELOPE_INVALIDFORMAT | 0x1241 | The only valid envelope-format strings are: Custom, Custom XML, EDIFACT, Flatfile, X12, and Reliable. The previously specified format will remain unchanged.
BTS_E_CHANNEL_FOREIGN_CONTROLNUMID | 0x1242 | The control number cannot be removed because it is used by an channel.
BTS_E_PORT_UNIQUE_ID | 0x1243 | The messaging port identifier must be a unique identifier.
BTS_E_PORT_UNIQUE_NAME | 0x1244 | The messaging port name must be a unique name.
BTS_E_CHANNEL_FOREIGN_SRCAPPID | 0x1247 | The source application cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTORGID | 0x1248 | The destination organization cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_DSTALIASID | 0x1249 | The destination identifier cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_ENVID | 0x124A | The envelope cannot be removed because it is used by a messaging port.
BTS_E_CHANNEL_FOREIGN_SRCALIASID | 0x124B | The source identifier cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTAPPID | 0x124C | The destination application cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_CONTROLNUMID | 0x124D | The control number cannot be removed because it is used by a messaging port.
BTS_E_DOCUMENT_MISSING_REFERENCE | 0x124E | The Reference property must have a value if the TrackingFields or PropertySet properties are specified.
BTS_E_DOCUMENT_REFERENCE_CANT_BE_CHANGED | 0x124F | A document reference cannot be modified if it is referred to by a channel.
BTS_E_PORTGROUP_NOTOPENGRP | 0x1251 | Messaging ports that are set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW) cannot be used in distribution lists.
BTS_E_PORTGROUP_DUPLICATEPORT | 0x1252 | A duplicate messaging port cannot be added to the distribution list.
BTS_E_OUTPUTCONFIG_UNIQUE_ID | 0x1255 | The output configuration identifier must be a unique identifier.
BTS_E_OUTPUTCONFIG_FOREIGN_PORTID | 0x1256 | The messaging port cannot be removed because it is used by a channel.
BTS_E_OUTPUTCONFIG_FOREIGN_CHANNELID | 0x1257 | The channel cannot be removed because it is used by a messaging port.
BTS_E_PORT_LOOPBACK_RELIABLE | 0x125F | A messaging port with the transport type Loopback cannot be associated with an envelope that uses the Reliable format.
BTS_E_ALIAS_RESERVEDWORD | 0x1262 | Group is a reserved word for qualifiers and cannot be used as the qualifier for an identifier.
BTS_E_DOCUMENT_NEEDMAPREF | 0x1268 | A map reference is required to transform the inbound document to the outbound document if the document specifications are different.
BTS_E_PORT_DESTORGNOTSPECIFIED | 0x126C | This messaging port must have a destination organization specified.
BTS_E_PORT_MISSING_PRITRANSTYPE | 0x126D | You must specify a primary transport type for this messaging port. The primary transport cannot be blank, and it cannot be an open destination.
BTS_E_PORT_MISSING_PRITRANSADDRESS | 0x126E | This messaging port must have a primary transport address specified.
BTS_E_PORT_INVALID_SECTRANSTYPE | 0x126F | The secondary transport type cannot be set to Open, Loopback, or to BizTalk Orchestration Activation.
BTS_E_PORT_MISSING_SECTRANSADDRESS | 0x1270 | The secondary transport address is missing, although the transport type has been defined.
BTS_E_PORT_INVALID_ORG | 0x1271 | The organization specified in this messaging port does not exist.
BTS_E_PORT_INVALID_ALIAS | 0x1272 | The identifier specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_APPLICATION | 0x1273 | The application specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_ENVELOPE | 0x1274 | The envelope specified in this messaging port does not exist.
BTS_E_PORT_OPEN_DESTORG_SPECIFIED | 0x127C | An open-destination messaging port cannot have a destination organization specified.
BTS_E_PORT_OPEN_DESTAPP_SPECIFIED | 0x127E | An open-destination messaging port cannot have a destination application specified.
BTS_E_PORT_OPEN_PRITRANSTYPEOPEN | 0x127F | An open-destination messaging port must specify a primary transport type as an open destination.
BTS_E_PORT_OPEN_PRITRANSADDRESS | 0x1280 | An open-destination messaging port cannot specify a primary transport address.
BTS_E_PORT_OPEN_PRITRANSPARAMETER | 0x1281 | An open-destination messaging port cannot specify a primary transport parameter.
BTS_E_PORT_OPEN_SECTRANSTYPE | 0x1282 | An open-destination messaging port cannot specify the secondary transport type.
BTS_E_PORT_OPEN_SECTRANSADDRESS | 0x1283 | An open-destination messaging port cannot specify a secondary transport address.
BTS_E_PORT_OPEN_SECTRANSPARAMETER | 0x1284 | An open-destination messaging port cannot specify a secondary transport parameter.
BTS_E_PORT_OPEN_ENCRYPTIONTYPE | 0x1285 | An open-destination messaging port cannot specify an encryption type.
BTS_E_PORT_OPEN_ENCRYPTIONREF | 0x1286 | An open-destination messaging port cannot specify an encryption reference.
BTS_E_PORT_SIGNATTYPEANDREFERENCE | 0x1287 | The signature type is specified; however, the signature reference is missing.
BTS_E_PORT_ENCRYPTIONTYPEANDREFERENCE | 0x1288 | The encryption type is specified; however, the encryption reference is missing.
BTS_E_ALIAS_DEFAULT | 0x128A | One and only one default identifier is required and permitted at all times. The default identifier cannot be missing, nor can it be duplicated.
BTS_E_ALIAS_AUTO | 0x128B | The alias, which uses the name "Organization" and the qualifier "OrganizationName," is a system-created alias. You cannot remove this alias, create another alias that uses the same name and qualifier, or change any fields of this alias.
BTS_E_TRANSPORT_SYNTAXAPPINT | 0x128E | Either the syntax of this address is incorrect for the Application Integration Component transport type property, or the component is not registered, or else the component is not a valid AIC component.
BTS_E_TRANSPORT_SYNTAXFILE | 0x128F | The syntax of this address is incorrect for the File transport type.
BTS_E_TRANSPORT_SYNTAXHTTP | 0x1291 | The syntax of this address is incorrect for the HTTP transport type.
BTS_E_TRANSPORT_SYNTAXHTTPS | 0x1292 | The syntax of this address is incorrect for the HTTPS transport type.
BTS_E_TRANSPORT_SYNTAXSMTP | 0x1293 | The syntax of this address is incorrect for the SMTP transport type.
BTS_E_TRANSPORT_SYNTAXNONE | 0x1294 | You cannot specify a transport address or a parameter when the transport type is set to None, or when the source or destination are Open.
BTS_E_TRANSPORT_LOCALHOST | 0x1295 | The transport address cannot contain the word "localhost". Replace it with the computer name instead.
BTS_E_PORTGROUP_LASTPORT | 0x1296 | The messaging port cannot be removed if it is the last remaining messaging port in a distribution list.
BTS_E_TRANSPORT_MISSING_PRISMTPPARAMETER | 0x1298 | A primary transport parameter is required for the SMTP transport type.
BTS_E_TRANSPORT_MISSING_SECSMTPPARAMETER | 0x1299 | A secondary transport parameter is required for the SMTP transport type.
BTS_E_NAMEREQ | 0x129A | The Name property must always be at least one character long.
BTS_E_INVALIDTIMEFORMAT | 0x129B | The time format is not valid. Enter the time, in hours, in a 24-hour format (from 0 to 23 hours). You can enter only hours, not minutes or seconds.
BTS_E_TIMESTAMP | 0x129C | This object cannot be saved or removed because the timestamp has changed.
BTS_E_PORTGROUP_MISSING_PORT | 0x129D | A distribution list must contain at least one messaging port.
BTS_E_ORGANIZATION_REMOVEDEFAULT | 0x129E | The home organization cannot be removed.
BTS_E_PORT_SERVICEWINDOW_EQUAL | 0x129F | The start time (FromTime) and end time (ToTime) for the service window cannot be equal.
BTS_E_ENVELOPE_REFERENCENOTALLOWED | 0x12A2 | The reference property cannot be set for this envelope format.
BTS_E_ENVELOPE_REFERRED | 0x12A3 | This envelope cannot be removed because it is used in a messaging port or channel.
BTS_E_TRANSPORT_LOOPBACK_SECTYPECONFLICT | 0x12A4 | The secondary transport type cannot be specified for the messaging port if the primary transport type is set to Loopback.
BTS_E_TRANSPORT_LOOPBACK_SECADDRESSCONFLICT | 0x12A5 | The secondary transport address cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_LOOPBACK_SERVICEWINDOW | 0x12A6 | The service window cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_OPEN_DESTALIAS_SPECIFIED | 0x12A7 | An open-destination messaging port cannot have a destination identifier specified.
BTS_E_PORT_OPEN_SERVICEWINDOW | 0x12A8 | The service window cannot be specified for the messaging port if the messaging port is an open-destination messaging port.
BTS_E_PORT_SERVICEWINDOWTIMES | 0x12AA | To use a service window, you must set both the From and To times or else, do not set either time.
BTS_E_TRANSPORT_LOOPBACK_PRIADDRESSCONFLICT | 0x12AC | A primary transport address cannot be specified for the messaging port if the transport type is Loopback.
BTS_E_PORT_ORGCHANGE | 0x12AD | The destination-organization identifier cannot be changed after it is created.
BTS_E_PORT_OPENNESSCHANGE | 0x12AE | The Openness property cannot be changed after it is created.
BTS_E_PORT_SIGNATURE_CHANNEL_CERTREF | 0x12AF | The signature-certification reference for a channel does not match the signature type for the port.
BTS_E_PORT_SIGNATURE_CHANNEL_OPEN | 0x12B0 | A messaging port that contains a signature type cannot be connected to an open-source channel. Also, a messaging port that is already connected to an open-source channel cannot have a signature type assigned to it.
BTS_E_CHANNEL_OPEN_SRCORG | 0x12B1 | An open-source channel cannot specify a source organization.
BTS_E_PORTGROUP_LOOPBACKPORT | 0x12B2 | A messaging port that uses the Loopback transport type cannot be added to a distribution list. Also, the transport type of a messaging port that is already included in a distribution list cannot be changed to Loopback.
BTS_E_CHANNEL_OPEN_SRCALIAS | 0x12B3 | An open-source channel cannot have a source identifier specified.
BTS_E_CHANNEL_OPEN_SRCAPP | 0x12B4 | An open-source channel cannot specify a source application.
BTS_E_CHANNEL_PORTORPORTGROUP | 0x12B5 | Either a messaging port or a distribution list, but not both, must be specified in a channel.
BTS_E_CHANNEL_MISSING_DOCUMENT | 0x12B6 | Both input and output documents are needed in a channel.
BTS_E_CHANNEL_INVALIDTYPE | 0x12B7 | A channel cannot be set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_CHANNEL_MISSING_OUTDOCREFERENCE | 0x12B8 | If the inbound document definition for a channel has a reference to a specification, the outbound document definition must also have a reference to a specification.
BTS_E_CHANNEL_TRACKFIELDSCANTBESET | 0x12B9 | If the inbound document definition for a channel does not have a reference to a specification, the tracking fields cannot be set.
BTS_E_CHANNEL_EXPRESSIONCANTBESET | 0x12BA | If the inbound document definition for a channel does not have a reference to a specification, the channel-filtering expressions cannot be set.
BTS_E_CHANNEL_MAPREFCANTBESET | 0x12BB | If the inbound document definition for a channel does not have a reference to a specification then a reference to a map cannot be set.
BTS_E_CHANNEL_NOTSAME_INPDOC_OUTDOC | 0x12BC | If the inbound document definition for a channel does not have a reference to a specification then the outbound document handle should be the same of inbound document handle.
BTS_E_CHANNEL_OPEN_RECEIPTCONFLICT | 0x12BD | Channels that are set from an open source or set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW) cannot be receipt channels.
BTS_E_CHANNEL_RECEIPT_RECEIPTTIMEOUT | 0x12BE | The Expect Receipt Timeout property cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CANTSETRECEIPTCHANNEL | 0x12BF | An identifier cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CONFLICT | 0x12C0 | In a receipt channel, the source specification from the original channel must be used as the destination specification, and the destination specification from the original channel must be used as the source specification.
BTS_E_CHANNEL_SRCORGDEFAULT | 0x12C1 | If the channel is set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW), the source organization must be the home organization.
BTS_E_CHANNEL_PORT_BOTHOPEN | 0x12C2 | Both the channel and messaging port cannot be set to Open.
BTS_E_CHANNEL_RECEIPT_INVALID | 0x12C3 | The Receipt Channel and Expect Receipt Timeout properties cannot be set for an open-source channel. These properties also cannot be set if the messaging port is set to an open destination, set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW), or if the messaging port uses the Loopback transport type.
BTS_E_CHANNEL_RECEIPTMATCHNOTFOUND | 0x12C4 | The corresponding receipt channel for this channel could not be found.
BTS_E_CHANNEL_RECEIPT_OPENPORT | 0x12C5 | A receipt channel can be connected only to messaging ports that are not open messaging ports.
BTS_E_CHANNEL_RECEIPT_LOOPBACKPORT | 0x12C6 | A receipt channel cannot be connected to a messaging port that uses the Loopback transport type. Also, the transport type of a messaging port that is already connected to a receipt channel cannot be changed to Loopback.
BTS_E_CHANNEL_CANNOTUPDATE | 0x12C8 | After a channel is created, the following properties cannot be changed: source organization, openness designation, messaging port, distribution list, and receipt channel designation.
BTS_E_PORT_INVALIDOPENNESS | 0x12C9 | A messaging port cannot be set to an open source; nor can it be set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW).
BTS_E_CHANNEL_CONTROLNUMBER_ENVELOPEFORMATMISMATCH | 0x12CA | If the envelope format for the messaging port is X12 or EDIFACT, the control-number value on the channel must be set.
BTS_E_PORT_ENVELOPE_SERIALIZERCLSID | 0x12CB | If the envelope format for the messaging port is set to Custom, a class identifier (CLSID) for the serializer component must be specified.
BTS_E_CHANNEL_AIC_TRANSPORTCLSID | 0x12CD | If the transport type associated with the channel is set to Application Integration Component, a class identifier (CLSID) must be specified for the primary transport.
BTS_E_CHANNEL_RECEIPT_PORTGROUP | 0x12CE | If a channel is connected to a distribution list, a receipt channel cannot be specified.
BTS_E_COMPONENTREQUIRES2AGGREGATEFTM | 0x12CF | To be a valid object in the BizTalk Object Model, this custom component must aggregate the free-threaded marshaler.
BTS_E_CERTREFNOTFOUND | 0x12D1 | Either the certificate reference could not be found in MY or BIZTALK stores or it is not valid.
BTS_E_NODOC | 0x12D2 | The Document Definition has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOENV | 0x12D3 | The envelope has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOCHANNEL | 0x12D4 | The channel has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_INVALIDREFERENCE | 0x12D5 | Either the WebDAV repository reference does not contain a valid HTTP address or it contains the text "localhost." Please provide either a valid HTTP address or replace the text "localhost" with the actual computer name.
BTS_E_CANNOTCONTAINSUBOBJECTS | 0x12D6 | The property set and delimiter objects cannot contain any subobjects.
BTS_E_INVALIDTRACKFIELDS | 0x12D7 | The "x_custom_search" field in the tracking field dictionary must be a simple list.
BTS_E_CHANNEL_INVALID_ORG | 0x12D8 | The organization specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_ALIAS | 0x12D9 | The identifier specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_APPLICATION | 0x12DA | The application specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_INPDOCID | 0x12DB | The input document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_OUTDOCID | 0x12DC | The output document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_PORTGROUP | 0x12DD | The distribution list specified in this channel does not exist.
BTS_E_OBJECT_NOT_XMLSERILIZABLE | 0x12DE | The given dictionary or simplelist object must implement IPersistXML methods.
BTS_E_CHANNEL_INVALID_PORT | 0x12E0 | At least one messaging port that is referenced in this channel either does not exist or it is not associated with this channel.
BTS_E_CHANNEL_RECEIPT_VERSIGN_DECRYPT | 0x12E1 | The Verify Signature or Decrypt Encryption properties cannot be set on a receipt channel.
BTS_E_INVALID_REQUEST_CHANNEL | 0x12E2 | A channel that is connected to a distribution list cannot be used as a request channel.
BTS_E_DESTINATION_NOT_FOUND | 0x12E3 | The destination URL is not specified, and the messaging port is an open destination. Either the destination URL or a destination for the messaging port must be specified.
BTS_E_DESTINATION_CONFLICT | 0x12E4 | Both a destination URL and a destination for the messaging port cannot be specified. Specify only one of these properties.
BTS_E_ASYNC_TRANSPORT | 0x12E5 | The transport type for the request channel is not valid. Only the HTTP, HTTPS, and Application Integration Component transport types are valid for a request channel.
BTS_E_INVALID_RESPONSE_CHANNEL | 0x12E6 | The response channel can be connected only to a messaging port with a transport type set to Loopback.
BTS_E_INVALID_VERSION | 0x12E7 | The database version is incompatible with the installed version of the server. Try running setup again.
BTS_E_INVALID_SCHEMA | 0x12E8 | The document or envelope specification is not valid. Open the specification in BizTalk Editor, and then on the Tools menu, click Validate Specification. Resolve any warnings to ensure that the specification is valid.
BTS_E_CHANNEL_RECEIPTCHANNEL_PORTGROUP | 0x12E9 | A receipt channel cannot be connected to a distribution list.
BTS_E_TRANSPORT_ORCHESTRATION_OPENNESS | 0x12EA | A messaging port that uses the BizTalk Orchestration Activation transport type must have the Openness Type property set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_TRANSPORT_ORCHESTRATION_ADDRESSPARAMETER | 0x12EB | Both a primary address and a parameter are required for a messaging port that uses a BizTalk Orchestration Activation transport type.
BTS_E_ORCHESTRATION_INVALIDORG | 0x12EC | A messaging port that uses a BizTalk Orchestration Activation transport type must have the home organization set as the destination organization.
BTS_E_INVALID_FILTEREXPRESSION | 0x12ED | The channel filtering expression is not valid. Make sure that the node-path expression is valid.
BTS_E_MULTIPLEDOCDEFSFORPROPSET | 0x12EE | Multiple document definitions were found for the given property set. Only a single document definition for a given property set is expected.
BTS_E_INVALID_PROPSET | 0x12EF | The PropertySet cannot contain non-string element values.
BTS_E_DBSCHEMA_MISMATCH | 0x1300 | The existing Database Schema is not compatible with the current version of the product. You must delete the existing database.
BTS_E_UNEXPECTED_INSTALL | 0x1301 | The existing Database Schema is newer than the current version that is installed. Setup will rollback the changes.
CIS_E_DOCSCHEMA_ATTRIB_MISSING | 0x1400 | The "%3" attribute is missing in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB_VALUE | 0x1401 | The "%3" attribute value "%4" is not valid. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_EMPTY_ELEMENT | 0x1402 | The "%3" element cannot be empty. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_CHILD_ELEMENT | 0x1403 | The "%3" element cannot be a child of the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MULTIPLE_INFO | 0x1404 | Only one record description or one field description is allowed for each element declaration. One of the descriptions must be removed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_FIELD_DECL | 0x1405 | The root node cannot contain a field. The root node of the document must contain a record. Verify that the root node in your document is declared as a record. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_LEN_DECL | 0x1406 | The minimum length value must be no greater than the maximum length value. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_POSLEN_DECL | 0x1407 | The value of the start position must be no greater than the value of the end position. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO_YET | 0x1408 | A field description or record description must be specified before references to other elements. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_SCHEMATYPE_XML | 0x1409 | Only non-XML document specifications are allowed for this format. The schema_type attribute has the value "xml". Verify that the specification selected is a non-XML specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO | 0x140A | No record information or field information was found in the "%3" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB | 0x140B | The "%3" attribute is not allowed in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MISSING_ELEM_DECL | 0x140C | There is no element with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_MISSING_ATTR_DECL | 0x140D | There is no attribute with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_INVALID_POSITIONAL_DECL | 0x140E | The "%1" record cannot be a child of the "%2" positional record. Only fields can be children of positional records.
CIS_E_DOCSCHEMA_INVALID_RECORD_CHILDREN | 0x140F | The children of the "%1" delimited record must either be all records or all fields. Records with no tag identifier cannot have mixed records and fields as children.
CIS_E_DOCSCHEMA_NO_RECORD_CHILDREN | 0x1410 | The "%1" delimited record must have at least one child. Records with no tag identifier must have at least one child, or else the record cannot be found in a non-XML format. Either add a child to the record, give the record a tag identifier, or remove the record from the specification.
CIS_E_DOCSCHEMA_MISSING_RECORD_TAG | 0x1411 | The "%1" delimited record is marked to repeat but it does not have a tag identifier. Only the last record in a document specification is allowed to have this property. If this record appears only once in the document, then mark it as a single occurrence. Otherwise, give the record a tag identifier that tells the server where to look for the next record in the specification.
CIS_E_DOCSCHEMA_NO_ROOT_ELEMENT | 0x1412 | The root-node name "%3" was not found in the specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ROOT_ELEMENT | 0x1413 | The "%3" element cannot be the root node of this document. Only <Schema> is allowed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_EMPTY_ATTRIBUTE | 0x1414 | The "%3" attribute in the "%4" element cannot be empty. Either specify a nonempty value or remove the attribute. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_REFERENCE | 0x1415 | The "%1" record has an illegal cyclic path through the "%2" record. The only cyclic reference allowed for a record is if the record has a tag identifier that allows the system to terminate the search. Either remove the cyclic reference or add an appropriate tag identifier to the document specification.
CIS_E_DOCSCHEMA_LOADFAILED | 0x1416 | The specification failed to load. See the following messages for details.
CIS_E_DOCSCHEMA_MISSING_NS | 0x1417 | Valid BizTalk Server specifications for non-XML documents must have the namespace declarations of "urn:schemas-microsoft-com:BizTalkServer", "urn:schemas-microsoft-com:datatypes", and "urn:schemas-microsoft-com:xml-data" in the root node of the specification.
CIS_E_DOCSCHEMA_INVALID_SCHEMA_USAGE | 0x1418 | The specification referenced in the "%1" document is not compatible with the "%2" format. Select a specification that is compatible with this format, or if this is a valid specification for the defined format, assign "%2" to the "standard" property on this specification.
CIS_E_DOCSCHEMA_MISSING_POSLEN_DECL | 0x1419 | The "%3" field is missing a start and end position, and is referenced in the "%4" positional record. Specify valid start and end positions for this field. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_DUPLICATE_NAMESPACE | 0x141A | The duplicate namespace declaration "%3" has been found. Please remove the duplicate reference to same namespace. Line: %1, Pos: %2.
CIS_E_PARSER_EOF | 0x1430 | The end of the file was reached prematurely.
CIS_E_PARSER_MISSING_TAG | 0x1431 | The required "%1" record was not found in the inbound document.
CIS_E_PARSER_MISSING_FIELD | 0x1432 | The required field "%1" in the "%2" record was not found in the inbound document.
CIS_E_PARSER_FAILURE | 0x1433 | The parser failed to convert the document due to processing errors. See the following messages for details.
CIS_E_PARSER_INVALIDDATA | 0x1434 | The parser cannot match the current position of the data with the specification. Verify that the version of this specification is consistent with the version of the data and that the root parsing tags match.
CIS_E_PARSER_NO_DATA | 0x1435 | There is no data that can be parsed on the dictionary. Verify that either the "working_data" field or the "file_path" field contains nonempty data.
CIS_E_PARSER_INVALID_ENVNAME | 0x1436 | The envelope name "%1" does not reference a valid envelope for the BizTalk Server parser. Either the envelope name does not exist or there is an envelope specification attached that is not valid.
CIS_E_PARSER_NO_COMPONENTS_FOUND | 0x1439 | No parser component recognizes the data. This might be caused by an interchange specification that is missing or not valid, or it might be caused by data that is not valid. Verify that both the interchange specification (if one is specified) and the data match.
CIS_E_PARSER_COMPONENT_FAILED | 0x1440 | While trying to process document #%4 during submission "%1", the parser component named "%2" failed on the method "%3" with the error code "%5". Possible causes are: the component found unexpected data in the incoming stream; a document specification could not be found given the data; or an internal component failure occurred. If this problem continues, remove this component from the valid list of parser components or contact your system administrator.
CIS_E_PARSER_DOCUMENT_FAILED | 0x1441 | Document #%4 within submission "%1" was returned as a document that was not valid from the parser component named "%2". The most frequent cause is a document specification that is not valid or else the component was unable to determine the necessary routing fields. Verify that the proper specification is defined for this data.
CIS_E_PARSER_INVALID_DATETIME | 0x1442 | The "%1" date or time format for the tag "%3" does not match the format of the "%2" data extracted from the incoming data.
CIS_E_PARSER_INVALID_COMPONENT | 0x1443 | Within submission "%1", the parser component named "%2" could not be loaded. Verify that this component can be run in a stand-alone executable and that the server has sufficient permissions to start it.
CIS_W_PARSER_SKIPPED_COMPONENT | 0x1444 | The parser was unable to probe the specified component. This component will be skipped.
CIS_E_PARSER_UNUSEABLE_DOCNAME | 0x1445 | The parser cannot use the document "%1" as it has no specification. Please attach a specification to this document or specify a different one.
CIS_E_PARSER_CONTROL_NUMBER_MISMATCH | 0x1446 | The control number of segment "%1" (%2) does not match that of segment "%3" (%4).
CIS_E_PARSER_DOCCOUNT_INCORRECT | 0x1447 | The document or segment count contained in tag "%1" (%2) does not match the number of documents or segments processed (%3).
CIS_E_PARSER_X12_ISA_PARSE_FAILED | 0x1448 | The parser cannot parse the ISA section of the X12 document. This segment is fixed-width; if fields in this segment do not have correct length, the parsing will fail because the delimiters are picked up from the wrong offsets.
CIS_E_PARSER_MIN_LENGTH | 0x1449 | The data contains a field value ("%1") that doesn't meet minimum length requirement for tag "%2" (minimum length is %3).
CIS_E_PARSER_MAX_LENGTH | 0x144A | The data contains a field value ("%1") that doesn't meet maximum length requirement for tag "%2" (maximum length is %3).
CIS_E_PARSER_NO_DATA_CONSUMED | 0x144B | No data was read by the parser. Make sure that the code page is set correctly for the data. If the data is UNICODE, make sure that there is no byte order mark (0xFFFE or 0xFEFF) appears at the beginning of the file.
CIS_E_PARSER_UNSUPPORTED_EDIFACT_SYNTAX | 0x144C | EDIFACT documents with the "UNOX" or the "UNOY" syntax identifier are not supported.
CIS_E_PARSER_DATA_REMAINING | 0x144D | Additional data in the document instance was not parsed. Make sure that the document instance you want to validate contains only one document.
CIS_E_PARSER_MISSING_DELIMITER | 0x144E | While parsing record "%1", the parser cannot find the required delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_LEADING_DELIMITER | 0x144F | While parsing record "%1", the parser cannot find the required leading delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_TRAILING_DELIMITER | 0x1450 | While parsing record "%1", the parser cannot find the required trailing delimiter: "%2" (%3).
CIS_E_VALIDATE_GROUP_RULE | 0x1451 | In record "%1", if any of the following fields exist, then all must exist: %2
CIS_E_VALIDATE_GROUP_ALL | 0x1452 | In record "%1", all of the following fields must exist: %2
CIS_E_VALIDATE_GROUP_ONE | 0x1453 | In record "%1", only one of the following fields can exist: %2
CIS_E_PARSER_INVALID_WRAP_CHAR_FOUND | 0x1454 | While parsing record "%1", the parser found an occurrence of a wrap character, "%2", that is not valid.
CIS_E_VALIDATE_GROUP_ANY | 0x1455 | In record "%1", one or more of the following fields must exist: %2
CIS_E_PARSER_EXTRA_DELIMITER | 0x1456 | While parsing record "%1", the parser found the following extra delimiter: "%2".
BTS_E_DOCUMENT_HAS_INVALID_MANIFEST | 0x1457 | Error parsing the manifest.
CIS_E_ADMIN_CACHE_PARSERS | 0x1504 | The latest modification date from the administration parser table could not be loaded.
CIS_E_ADMIN_INIT_CACHE | 0x1505 | The configuration data in the global cache could not be initialized.
CIS_E_ADMIN_RELOAD_CACHE | 0x1506 | The configuration data from the database could not be reloaded.
CIS_E_ADMIN_PARSER_GETCLSID | 0x1507 | The class identifiers (CLSIDs) of the parser records could not be loaded.
CIS_E_ADMIN_CACHE_OBJECTNOTCREATED | 0x1509 | The administration cache cannot be created.
CIS_E_ADMIN_CACHE_INITIALLOAD | 0x150A | The configuration cache data from the database could not be loaded.
CIS_E_ADMIN_ADD_SERVER_ACCESS_DENIED | 0x150B | Server "%1" cannot be added because access to the "%2" is denied.
CIS_E_ADMIN_ADD_SERVER_NO_SERVICE | 0x150C | Server "%1" cannot be added because BizTalk Server is not installed on the computer.
CIS_E_ADMIN_DELETE_SERVER_NO_ACCESS | 0x150D | The "%1" server cannot be deleted because access to the "%2" service is denied and the service cannot be stopped.
CIS_E_ADMIN_DELETE_GROUP_SERVER_RUNNING | 0x150E | This server group cannot be deleted because the "%1" server is still running.
CIS_E_ADMIN_DELETE_GROUP_SERVER_ACCESS_DENIED | 0x150F | This server group cannot be deleted because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_NOGROUP | 0x1512 | The specified administration group does not exist.
CIS_E_ADMIN_NOSERVER | 0x1513 | The specified administration server does not exist.
CIS_E_ADMIN_NORECEIVESERVICE | 0x1514 | The specified administration receive function does not exist in the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_RECEIVESERVICE | 0x1515 | An unexpected error occurred while trying to remove the "%1" receive function from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_GROUP | 0x1516 | An unexpected error occurred while trying to remove the "%1" group from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_SERVER | 0x1517 | An unexpected error occurred while trying to remove the "%1" server from the database.
CIS_E_ADMIN_NOTIMESTAMPS | 0x151A | The specified administration timestamps object does not exist in the database.
CIS_E_ADMIN_REFRESH_THREAD_ERROR | 0x151B | The configuration refresh thread encountered an error while loading the configuration data.
CIS_E_ADMIN_REFRESH_THREAD_EXIT | 0x151C | The configuration refresh thread cannot load the configuration data because of a previous error.
CIS_E_ADMIN_RECSVC_GENERAL | 0x151D | The configuration refresh thread cannot set up one or more receive functions. This might be because SQL Server is not started.
CIS_E_ADMIN_CREATE_GROUP | 0x1529 | The server group cannot be created because "%1".
CIS_E_ADMIN_LOAD_GROUP_PROPS | 0x152A | The group properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_GROUP_PROPS | 0x152B | The group properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_GROUP | 0x152C | The server group cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINGROUPS | 0x152D | All server groups cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERS | 0x152E | All servers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETRECEIVESERVICES | 0x152F | All receive functions for the "%1" group cannot be retrieved from database because "%2".
CIS_E_ADMIN_GETPARSERS_IN_GROUP | 0x1531 | All parsers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETLOCALSMTPHOST | 0x1538 | The local SMTP host cannot be retrieved because "%1".
CIS_E_ADMIN_CREATE_SERVER | 0x1539 | The server cannot be created because "%1".
CIS_E_ADMIN_LOAD_SERVER_PROPS | 0x153A | The server properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_SERVER_PROPS | 0x153B | The server properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_SERVER | 0x153C | The server cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINSERVRES | 0x153D | All servers cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERBYNAME | 0x153E | The server properties for "%1" cannot be retrieved because "%2".
CIS_E_ADMIN_DECRYPT_PASSWORD | 0x1540 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_EXEC_COMMMAND_ON_PARSER | 0x154F | The SQL command "%1" on the parser database table cannot be executed because "%2".
CIS_E_ADMIN_PREPOROCESSOR_NOT_SUPPORTED_BY_HTTP_RF | 0x155C | The "%1" property is not supported for the HTTP receive function in Submit to File mode.
CIS_E_ADMIN_CREATE_RECEIVESERVICE | 0x155D | The receive function cannot be created because "%1".
CIS_E_ADMIN_LOAD_RECEIVESERVICE_PROPS | 0x155E | The receive function properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_RECEIVESERVICE_PROPS | 0x155F | The receive function properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_RECEIVESERVICE | 0x1560 | The receive function cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICES | 0x1561 | All receive functions cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICESINSERVER | 0x1562 | All receive functions cannot be retrieved for the "%1" server because "%2".
CIS_E_ADMIN_LOAD_TIMESTAMPS | 0x1563 | All timestamps cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETSQCONNECT | 0x1570 | The Shared Queue database connection string cannot be retrieved from the database.
CIS_E_ADMIN_GETCOMPUTERNAME | 0x1571 | The name of the local computer cannot be retrieved. Internally, BizTalk Server is using "localhost" as the computer name.
CIS_E_ADMIN_MIN_CONSTRAINT | 0x1573 | The size of the "%1" property is less than the minimum required length for "%2".
CIS_E_ADMIN_MAX_CONSTRAINT | 0x1574 | The size of the "%1" property is greater than the maximum length allowed for "%2".
CIS_E_ADMIN_GET_MGMTDB_CONNECT_PROPS | 0x1575 | The BizTalk Messaging Management database properties cannot be retrieved.
CIS_E_ADMIN_KEY_EMPTY | 0x1576 | The key to the database table, property "%1", is empty.
CIS_E_ADMIN_COCREATE_IN_CREATE | 0x1577 | An instance of the "%1" object could not be created while creating a new "%2" object.
CIS_E_ADMIN_ADO_OPEN_CONNECTSTRING | 0x1578 | The connection to the BizTalk Messaging Management database could not be opened.
CIS_E_ADMIN_COCREATE_IN_LOAD | 0x1579 | An instance of the "%1" object could not be created while loading the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_SAVE | 0x1580 | An instance of the "%1" object could not be created while saving the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_REMOVE | 0x1581 | An instance of the "%1" object could not be created while trying to remove the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETALL | 0x1582 | An instance of the "%1" object could not be created while trying to get all instances of "%2".
CIS_E_ADMIN_COCREATE_IN_GETALL_INSERVER | 0x1583 | An instance of the "%1" object could not be created while trying to get all instances of the "%2" object in the "%3" server.
CIS_E_ADMIN_GET_PROP | 0x1584 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_CLOSE_ADO_CONNECTION | 0x1585 | The ADO connection cannot be closed.
CIS_E_ADMIN_CLOSE_ADO_RECORDSET | 0x1586 | The ADO record set cannot be retrieved.
CIS_E_ADMIN_ENCRYPT_PASSWORD | 0x1587 | The "%1" property cannot be processed.
CIS_E_ADMIN_COCREATE_IN_GETALLNAMES | 0x1588 | An instance of the "%1" object could not be created while trying to get the names of all the "%2" object instances.
CIS_E_ADMIN_COCREATE_IN_GETOTHERS_OF_GROUP | 0x1589 | An instance of the "%1" object could not be created while trying to get all instance of the "%2" object in the "%3" group.
CIS_E_ADMIN_COCREATE_IN_GET_SMTPHOST | 0x158A | An instance of the "%1" object could not be created while trying to get "%2" for the local server.
CIS_E_ADMIN_COCREATE_IN_GET_SQ_CONNECTSTRING | 0x158B | An instance of the "%1" object could not be created while trying to get the Shared Queue parameters of "%2" in order to connect to the database.
CIS_E_ADMIN_COCREATE_SERVER_BYNAME | 0x158C | An instance of the "%1" object could not be created while trying to get the properties of the "%2" server instance of the "%3" class.
CIS_E_ADMIN_GETSQCONNECT_IN_OPEN | 0x158D | The Shared Queue database connection string could not be retrieved from the database because "%1".
CIS_E_ADMIN_COCREATE_EXEC_SQL_COMMAND_ON_PARSER | 0x158E | An instance of the "%1" object could not be created while trying to execute a SQL command on the "%2" database table.
CIS_E_ADMIN_COCREATE_PARSER_CLSIDS_IN_GROUP | 0x158F | An instance of the "%1" object could not be created while retrieving the class identifiers (CLSIDs) for the parsers that belong to the "%2" group.
CIS_E_ADMIN_INVALID_ARGUMENT | 0x1590 | An unexpected internal error occurred. An invalid "%1" argument was used when calling the "%2" method.
CIS_E_ADMIN_MAX_ENUM_CONSTRAINT | 0x1591 | The value of the "%1" property is greater than the maximum value allowed for "%2".
CIS_E_ADMIN_MIN_ENUM_CONSTRAINT | 0x1592 | The value of the "%1" property is smaller than the minimum value allowed for "%2".
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BSTR | 0x1593 | The type of the "%1" property could not be changed to a string.
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BOOL | 0x1594 | The type of the "%1" property could not be changed to Boolean.
CIS_E_ADMIN_COCREATE_IN_ENUMINSTANCES | 0x1595 | An instance of the "%1" object could not be created while enumerating instances of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_PUTINSTANCE | 0x1596 | An instance of the "%1" object could not be created while setting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETOBJECT | 0x1597 | An instance of the "%1" object could not be created while getting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_DELETEINSTANCE | 0x1598 | An instance of the "%1" object could not be created while deleting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPROPS | 0x1599 | An instance of the "%1" object could not be created while loading properties for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPARSERS | 0x159B | An instance of the "%1" object could not be created while loading parsers from a database for an instance the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_REGISTRY | 0x159C | An instance of the "%1" object could not be created while setting parsers from the registry for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_CLIENT | 0x159D | An instance of the "%1" object could not be created while setting parsers from the client for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_REFRESHPARSERLIST | 0x159E | An instance of the "%1" object could not be created while refreshing the parser list for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_MOVETOSUSPENDED_Q | 0x159F | An instance of the "%1" object could not be created while moving an instance of "%2" to the Suspended queue.
CIS_E_ADMIN_COCREATE_IN_RESUBMIT | 0x15A0 | An instance of the "%1" object could not be created while resubmitting an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWDOC | 0x15A2 | An instance of the "%1" object could not be created while viewing a document instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWERRORDESC | 0x15A3 | An instance of the "%1" object could not be created while viewing the error description of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWINTERCHANGE | 0x15A4 | An instance of the "%1" object could not be created while viewing the interchanges of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_FREEINTERCHANGES | 0x15A5 | An instance of the "%1" object could not be created while freeing the interchanges for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STARTSERVER | 0x15A6 | An instance of the "%1" object could not be created while starting the server for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STOPSERVER | 0x15A7 | An instance of the "%1" object could not be created while stopping the server for an instance of a "%2".
CIS_E_ADMIN_NO_DELETE_SERVER_IN_RECVSERVICE | 0x15A8 | The "%1" server cannot be deleted because it is the processing server for at least one receive function.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_RUNNING | 0x15A9 | The server group properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_ACCESS_DENIED | 0x15AA | The server group properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_RUNNING | 0x15AC | The server properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_ACCESS_DENIED | 0x15AD | The server properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_READ_ONLY_PROP | 0x15AE | The "%1" property cannot be changed. It is a read only property.
CIS_E_ADMIN_DIFFERENT_ROOT | 0x15AF | The "%1" server may already belong to a different BizTalk Server installation.
CIS_E_ADMIN_NOT_RESUBMITABLE | 0x15B0 | This Suspended queue item cannot be submitted again.
CIS_E_ADMIN_DBCONNECT | 0x15B1 | BizTalk Server failed to access the "%1" database on the "%2" server with the database connection information.
CIS_E_ADMIN_PURGE_SUSPENDEDQ | 0x15B2 | An instance of the "%1" object could not be created while deleting documents from "%2".
CIS_E_ADMIN_REQ_PROP_MISSING | 0x15B3 | %1 cannot be NULL.
CIS_E_ADMIN_WMI_ERROR_HANDLING | 0x15B4 | The BizTalk Server WMI provider error-handling method failed. The original error description for the error that called the error-handling method is: "%1".
CIS_W_ADMIN_QUERY_FAILED | 0x15B5 | An attempt to get the Where clause values for a WMI Query failed.
CIS_E_ADMIN_INVALID_ENUM_CONSTRAINT | 0x15B6 | The value "%2" of the "%1" property is not valid.
CIS_E_ADMIN_OPENNESS_CONSTRAINT | 0x15B7 | The value "%2" of the "%1" property is not permitted when the value of the IsPassThrough property is set to TRUE.
CIS_E_ADMIN_RECEIVE_INVALID_SERVER_GROUP | 0x15B8 | the specified server and/or group is not valid
CIS_E_ADMIN_INVALID_INSTANCE_NAME | 0x15B9 | The specified instance name "%1" contains at least one of the following characters that is not valid: [ ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | \ ; " ' < > , . ? ]
BTS_E_ADMIN_GROUP_UNIQUE_NAME | 0x15BA | A BizTalk Server group with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_TIMESTAMPS_DATA_CORRUPTION | 0x15BB | Internal data corruption has been detected in the adm_TimeStamps table of the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_UNIQUE_NAME | 0x15BC | A BizTalk Server with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_FOREIGN_GROUPNAME | 0x15BD | This BizTalk Server does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_UNIQUE_NAME | 0x15BE | A BizTalk Server receive function with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_FOREIGN_GROUPNAME | 0x15BF | This BizTalk Server receive function does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_UNIQUE_HTTP_POLLING_LOCATION | 0x15C0 | An HTTP receive function polling from the same location already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_UNIQUE_ID | 0x15C1 | A BizTalk Server parser with the same CLSID and Group Name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_FOREIGN_GROUPNAME | 0x15C2 | This BizTalk Server parser does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
CIS_E_ADMIN_DB_SPROCVERSION | 0x15C3 | The "%1" database on the "%2" server does not contain the necessary database schema.
CIS_E_ADMIN_DB_VERSION | 0x15C4 | The "%1" database on the "%2" server is not compatible with the current version of the product.
CIS_E_ADMIN_CREATE_CUSTOM_COUNTER | 0x15D0 | The custom counter cannot be created because "%1".
CIS_E_ADMIN_LOAD_CUSTOM_COUNTER_PROPS | 0x15D1 | The custom counter cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_CUSTOM_COUNTER_PROPS | 0x15D2 | The custom counter cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_CUSTOM_COUNTER_PROPS | 0x15D3 | The custom counter cannot be removed because "%1".
CIS_E_ADMIN_NOCUSTOM_COUNTER | 0x15D4 | The specified custom counter could not be found. Verify that the name of the specified custom counter is correct.
CIS_E_ADMIN_UNEXPECTED_REMOVE_CUSTOM_COUNTER | 0x15D5 | An unexpected error occurred while trying to remove the "%1" custom counter from the database.
CIS_E_ADMIN_VALIDATE_COUNTER_PROPS | 0x15D6 | The custom counter cannot be validated because "%1".
CIS_E_ADMIN_GET_VALUE_CUSTOM_COUNTER_PROPS | 0x15D7 | The value of the custom counter cannot be evaluated because "%1".
CIS_E_ADMIN_UNEXPECTED_VALIDATE_CUSTOM_COUNTER | 0x15D8 | An unexpected error occurred while trying to validate the "%1" custom counter.
CIS_E_ADMIN_CUSTOM_COUNTER_ORG_CONSTRAIN | 0x15D9 | Either both %1 and %2 properties must be empty or %3 property must be empty.
CIS_E_ADMIN_WRONG_HTTP_POLLING_LOCATION | 0x15DA | The "%1" property is incorrect for the HTTP receive function ( http://... expected).
CIS_E_DTA_LOG_INTERCHANGE_DETAILS_FAILED | 0x1604 | The details of an interchange could not be logged.
CIS_E_DTA_LOG_DOCUMENT_DETAILS_FAILED | 0x1605 | The details of a document could not be logged.
CIS_E_DTA_LOG_GROUP_DETAILS_FAILED | 0x1606 | The details of a group could not be logged.
CIS_E_DTA_INIT_FAILED | 0x160A | The DTA object could not be initialized.
CIS_E_DTA_FAILED_TO_GET_ADMIN_PROPERTIES | 0x160E | The administration properties could not be obtained.
CIS_E_DTA_DATABASE_CONNECTION | 0x160F | The server could not establish connection to the Tracking database.
CIS_E_DTA_LOG_DOCUMENT_FAILED | 0x1619 | A copy of the document could not be logged.
CIS_E_DTA_LOG_INTERCHANGE_FAILED | 0x1620 | A copy of the interchange could not be logged.
CIS_E_DTA_OBJECT_IS_UNINITIALIZED | 0x1623 | The DTA initialization method must be explicitly invoked before any DTA method can be invoked.
CIS_E_DTA_FAILED_TO_COMMIT | 0x1625 | Changes could not be committed to the database.
CIS_E_DTA_FAILED_TO_LOG_SOURCE_XML | 0x1626 | The intermediate source XML could not be logged.
CIS_E_DTA_FAILED_TO_LOG_DEST_XML | 0x1627 | The intermediate destination XML could not be logged.
CIS_E_DTA_ACK_NO_ROW_FOUND | 0x162B | Acknowledgment correlation failed. The correlation key(s) given did not match any record in the Tracking database.
CIS_E_DTA_ACK_MULTIPLE_ROWS_FOUND | 0x162C | Acknowledgment correlation failed. The correlation key(s) given match more than one record in the Tracking database.
CIS_E_DTA_LOG_MIME_FAILED | 0x162D | The MIME data for submission "%1" could not be logged.
CIS_W_DTA_LOG_TRACKING_FIELD_FAILED | 0x162E | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 Actual value: %4 Possible causes are either a conversion error or an arithmetic overflow error. Check the tracking field settings in the document or channel configuration.
CIS_W_DTA_LOG_BINARY_TRACKING_FIELD_FAILED | 0x162F | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 The submission could not be logged because the corresponding XML element or attribute is set to binary type, which can only be tracked as custom type tracking field. Correct the tracking field settings in the document or channel configuration.
CIS_E_DTA_INIT_TRANSACTIONAL_SESSION | 0x1631 | The server could not create a transactional session for the Tracking object.
CIS_W_DTA_RECORD_UPDATE_FAILED | 0x1632 | An attempt to update a tracking record has failed. The record was probably deleted prior to the update action.
CIS_E_RESPONSE_DOM_LOAD_FAILED | 0x1701 | The XML-DOM could not be loaded from the response data.
CIS_E_RECEIVE_MSMQ_BYOT_CREATE_FAILED | 0x1702 | A Message Queuing receive function failed to create an IInterchange object using a Bring Your Own Transaction (BYOT) object. This may have been caused by editing the BizTalk Server COM+ application or configuring the BYOT object in its own COM+ application. This BizTalk Message Queuing receive function will be stopped.
CIS_E_RECEIVE_MSMQ_ZERO_BYTE_DOC | 0x1703 | A Message Queuing receive function read a zero byte document. This document has been discarded.
CIS_E_RECEIVE_SERVICE_FAILED | 0x1704 | There was a failure processing the "%1" receive function. Check your receive function configuration in BizTalk Server Administration.
CIS_E_INITWORKITEM | 0x1705 | There was a failure creating the internal work item. Make sure that SQL Server is running.
CIS_E_NOPIPELINE | 0x1706 | A channel with the name "%1" cannot be located.
CIS_E_OPEN_PASSTHROUGH | 0x1707 | The channel and messaging port openness type are not compatible with the submit method call.
CIS_E_DLQ_DETAILS | 0x1708 | Details about the Suspended queue could not be retrieved.
CIS_E_INVALID_OPENDEST | 0x1709 | The destination specified for the following open-destination messaging port was not valid: %1
CIS_E_SQL_MISSINGROWS | 0x170a | Rows were missing from the record returned by SQL OLEDB provider.
CIS_E_BTF_TIME_STAMP_EXPIRED | 0x170b | The BizTalk Framework document "%1" was received with an expired "%2" timestamp. This message will be discarded.
CIS_E_ACCESS_DENIED | 0x170c | The current process did not have administrative privileges and cannot access the Suspended queue.
CIS_E_BTF_ERROR_FINDING_TAG | 0x170d | The parser could either not find the BizTalk Framework tag "%1", or the tag did not have a value. This document will be moved to the Suspended queue.
CIS_E_INVALID_FORMAT | 0x170e | The "%1" envelope format is not recognized by the server. Specify a valid envelope format.
CIS_E_INVALID_MAP | 0x170f | The server could not load the map that is referenced by this channel.
CIS_E_MALFORMED_EXPR | 0x1710 | The expression "%1" is malformed and cannot be interpreted by the server.
CIS_E_DB_SHUTDOWN | 0x1711 | The server is shutting down because of a database failure.
CIS_E_SUBMIT_BLOCKED | 0x1712 | All submit calls have been blocked due to a database failure. After correcting this problem, please go to Component Services and shut down the 'BizTalk Server Interchange Application', before attempting to call any submit method.
CIS_E_CERT_NOT_FOUND | 0x1713 | The required certificate cannot be found in the certificate store.
CIS_E_NODATA | 0x1714 | The Submit method call did not contain a document or a file path.
CIS_E_TOOMUCH_DATA | 0x1715 | The Submit method call contained both a document and a file path.
CIS_E_INVALID_OPENFLAG | 0x1716 | The Submit method call was passed an openness type that is not valid. Refer to the BizTalk Server 200 Help documentation for the enumeration of these values.
CIS_E_PASSTHROUGH_PARAMS | 0x1717 | The Submit method call contained a channel along with source, destination, or document name information. Do not include source, destination, or document name information when passing the channel as a parameter within a Submit method call.
CIS_E_NOSRCID | 0x1718 | The Submit method call contained a source qualifier but no source identifier.
CIS_E_NODESTID | 0x1719 | The Submit method call contained a destination qualifier but no destination identifier.
MSG_TIMEBOMB_EXPIRED | 0x171A | Thank you for evaluating Microsoft BizTalk Server. The period for this evaluation version has ended. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server.
CIS_E_LOOPBACK | 0x171B | An attempt was made to submit a document that uses the Loopback transport type. The Loopback transport type can only be used when calling the SubmitSync method.
CIS_E_DBEXECUTE | 0x171C | The following stored procedure call failed: "%1".
CIS_E_MISSING_SMTPHOST | 0x171D | In order to use the SMTP transport, the SMTP host must be specified. To specify an SMTP host, in BizTalk Server Administration expand Microsoft BizTalk Server 200, right-click BizTalk Server Group, and then click Properties to open the BizTalk Server Group Properties dialog box. On the General tab, in the SMTP host box, specify the SMTP host that you want to use.
CIS_E_INVALIDHANDLE | 0x171E | This method expected a submission handle or an array of submission handles, but the incoming data was not valid. Verify that the parameters are correct.
CIS_E_DBCONNECT | 0x171F | BizTalk Server failed to initialize a connection to database: "%1" on server: "%2".
CIS_E_PASSTHROUGH_WITH_NOCHANNEL | 0x1720 | A valid channel name must be specified as a submission parameter on a Submit or SubmitSync method call when the pass-through flag is set to true.
CIS_W_DBFAILURE | 0x1721 | The database call failed and returned the following error string: "%1". If possible, we will attempt to retry this call.
CIS_E_GET_BTMPARAMS | 0x1722 | Unable to load connection parameters for BTM database. Please go to the Administration MMC to resolve this problem.
CIS_E_UNABLE_TO_CREATE_CUSTOM_PRE_PROC | 0x1723 | The custom preprocessing component for the receive function "%1" could not be created. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_FAILED | 0x1724 | The custom preprocessing component used by the receive function "%1" failed. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_NO_BSTR | 0x1725 | The custom preprocessing component used by the File receive function "%1" failed to return a valid BSTR. A valid BSTR is required. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA | 0x1726 | The custom preprocessing component used by the Message Queue receive function "%1" cannot be called because the message contains data that is not a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_CP | 0x1727 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid code page. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA_OUT | 0x1728 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid document, the document must be either a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_FILE_PRE_PROC_FAIL | 0x1729 | The custom preprocessing component used by the file receive function "%1" failed. The document "%2" will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_CANT_SET_CTX | 0x172A | The server was unable to set the context on the custom preprocessing component used by the receive function "%1". This document will be moved to the Suspended queue.
CIS_E_FILERCV_FILE_SHARE_DOWN | 0x172B | The file receive function "%1" was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_FILERCV_NETWORK_DOWN | 0x172C | The file receive function "%1" is experiencing network problems and was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_RECEIVE_FUNCTION_DISABLED | 0x172D | The receive function "%1" has experienced problems, it will be shut down and disabled. Once these problems have been corrected, re-enable this receive function in BizTalk Server Administration.
CIS_E_UNRECOVERABLE | 0x172E | There was a serious error within the BizTalk Server scheduler component. The server is being shut down. Resolve this problem and then restart the server.
CIS_E_RELIABLE_NOACK | 0x172F | The server has not received a receipt for the reliable message.
CIS_E_DLQ_ID | 0x1730 | Suspended Queue ID: "%1"
CIS_E_CANNOT_FIRE_EVENT | 0x1731 | The server cannot send a WMI event for the Suspended queue item "%1". The most likely cause is that the user configured for this submission has insufficient privileges to access WMI.
CIS_E_HTTP_L_INITIALIZATION | 0x1750 | The BizTalk HTTP receive function could not complete initialization. Verify that the security credentials of "BizTalkHTTPReceive.dll" include access to the BizTalk configuration database.
CIS_E_HTTP_L_NO_DATA_SEND | 0x1751 | The BizTalk HTTP receive function "%1" received a request with no data.
CIS_E_HTTP_L_NO_THREAD_FROM_POOL | 0x1752 | The BizTalk HTTP receive function "%1" could not retrieve a thread from the thread pool.
CIS_E_HTTP_L_NO_TRANSPORT | 0x1753 | The BizTalk HTTP receive function could not select a valid transport. Check the configuration of this receive function: Request URL="%1".
CIS_E_HTTP_L_SERVER_SUPP_FUNCT | 0x1754 | The BizTalk HTTP receive function "%1" made a call to IIS Server Support Function: "%2" which failed.
CIS_E_HTTP_L_POST_THREAD_POOL | 0x1755 | The BizTalk HTTP receive function "%1" could not post the work item to the thread pool. Try increasing the length of the thread pool queue using the registry key "QueueFactor".
CIS_E_HTTP_L_GET_FROM_THREAD_POOL | 0x1756 | The BizTalk HTTP receive function "%1" could not retrieve a work item from the thread pool.
CIS_E_HTTP_L_SEND_HEADERS | 0x1757 | The BizTalk HTTP receive function "%1" could not send the HTTP headers to the client.
CIS_E_HTTP_L_ASYNC_PROCESSING | 0x1758 | The BizTalk HTTP receive function "%1" failed during asynchronous processing of an IIS request.
CIS_E_HTTP_L_ASYNC_IIS_ERROR | 0x1759 | The BizTalk HTTP receive function "%1" received an error from IIS while processing an asynchronous request.
CIS_E_HTTP_L_DLL_LOAD_FAILURE | 0x175A | The BizTalk HTTP receive function could not load the DLL "%1".
CIS_E_HTTP_L_CREATION_FAILURE | 0x175B | The BizTalk HTTP receive function could not create "%1", error:"%2".
CIS_E_HTTP_L_TRANSPORT_URL | 0x175C | The BizTalk HTTP receive function could not extract a valid transport URL from the request URL. Error:"%1". Request URL="%2".
CIS_E_HTTP_L_TRANSPORT_URL_INVALID | 0x175D | The BizTalk HTTP receive function transport alias "%1" is not valid. Check the configuration of this receive function.
CIS_E_HTTP_L_TRANSPORT_HANDLE_INVALID | 0x175E | The BizTalk HTTP receive function transport handle for alias "%1" is not valid. Check the configuration of this receive function.
CIS_E_HTTP_L_FILE_CREATION_FAILURE | 0x175F | The BizTalk HTTP receive function "%1" could not create the file "%2".
CIS_E_HTTP_L_SET_FILE_POINTER_FAILURE | 0x1760 | The BizTalk HTTP receive function "%1" could not set the file pointer while writing to the file "%2".
CIS_E_HTTP_L_FILE_WRITE_FAILURE | 0x1761 | The BizTalk HTTP receive function "%1" could not write to the file "%2".
CIS_E_HTTP_L_FILE_LOCK_FAILURE | 0x1762 | The BizTalk HTTP receive function "%1" could not obtain a lock on the file "%2".
CIS_E_HTTP_L_BUILD_FILE_NAME_FAILURE | 0x1763 | The BizTalk HTTP receive function "%1" could not build a valid file name for "%2.
CIS_E_HTTP_L_FILE_DELETE_FAILURE | 0x1764 | The BizTalk HTTP receive function "%1" could not delete the file "%2".
CIS_E_HTTP_L_DETERMINING_CODE_PAGE | 0x1765 | The BizTalk HTTP receive function "%1" could not retrieve the code page for charset="%2".
CIS_E_HTTP_L_MSMQ_SEND_FAILURE | 0x1766 | The BizTalk HTTP receive function could not send a message to the message queue "%1", HR=%2, Request URL:"%3".
CIS_E_HTTP_L_MSMQ_OPEN_FAILURE | 0x1767 | The BizTalk HTTP receive function could not open the message queue "%1", HR=%2.
CIS_E_HTTP_L_REGISTRY_FAILURE | 0x1768 | The BizTalk HTTP receive function could not retrieve the configuration from the registry.
CIS_E_HTTP_L_CP_CONVERTION_FAILURE | 0x176A | The BizTalk HTTP receive function "%1" encountered an error converting the document to UNICODE.
CIS_E_HTTP_L_SUBMIT_FAILED | 0x176B | The BizTalk HTTP receive function "%1" failed to submit the document into BizTalk Messaging.
CIS_E_HTTP_L_SERVER_VARIABLE | 0x176C | The BizTalk HTTP receive function could not successfully retrieve the server variable "%1" from IIS, error:%2.
CIS_E_HTTP_L_BASE_URL_NOT_OBTAINABLE | 0x176D | The BizTalk HTTP receive function could not retrieve the URL from IIS.
CIS_E_HTTP_L_SUBMISSION_HANDLE_ERROR | 0x176E | The BizTalk HTTP receive function "%1" could not send the BizTalk correlation token to the client.
CIS_E_HTTP_L_GET_CONFIG_ERROR | 0x176F | The BizTalk HTTP receive function could not successfully retrieve the configuration information from the database, hr=%1.
CIS_E_HTTP_L_IMPERSNT_FAILED | 0x1770 | The BizTalk HTTP receive function could not get the appropriate security credentials to access the database.
CIS_E_HTTP_L_WRITE_RESPONSE_ERROR | 0x1771 | The BizTalk HTTP receive function "%1" could not send the HTTP response to the client.
CIS_E_HTTP_L_SUBMITSYNC_FAILED | 0x1772 | The BizTalk HTTP receive function "%1" could not synchronously submit the document to BizTalk Messaging.
CIS_E_HTTP_L_MOVETOSUSPENDQ_FAILED | 0x1773 | The BizTalk HTTP receive function "%1" could not move the document received to the Suspended Queue.
CIS_E_SERIALIZER_INVALID_DOCUMENT | 0x1800 | The document with the "%1" tracking identifier is invalid XML. The serializer cannot continue.
CIS_E_BTF_INVALID_ADDRESS_TYPE | 0x1801 | The BizTalk Framework document has an "type" specified that is not valid for the "%1" address field. This document will be moved to the Suspended queue.
CIS_E_RELIABLE_MSG_RECEIPT_REQ_BY | 0x1802 | The BizTalk Framework document "%1" will not be transmitted as it has an expired "receiptRequiredBy" timestamp. This message will be discarded.
CIS_E_CUSTOM_ENVELOPE_ERROR | 0x1803 | The custom envelope:"%1" had the property "%2" specified, but the custom envelope generator could not to locate the XML node. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_DATETIME | 0x1804 | The "%1" date or time format is not valid. Correct the format specification.
CIS_E_SERIALIZER_INVALID_DTDATA | 0x1805 | The "%1" date or time field is not a valid ISO8601 format. Make sure that the XML date or time is formatted correctly.
CIS_E_SERIALIZER_INVALID_DELIMITER | 0x1806 | The "%1" delimiter is either missing or has a value specified that is not valid. Update the delimiter value.
CIS_E_SERIALIZER_MISSING_PROPSET | 0x1807 | The "%1" document is missing the entire property set that is required for this serializer to run.
CIS_E_SERIALIZER_MISSING_PROP | 0x1808 | The property set for the "%1" document either is missing or does not contain a valid value for the "%2" property. Add or correct this property.
CIS_E_SERIALIZER_INVALIDARG | 0x1809 | Both source and destination qualifiers and values are required for this serializer to run. Specify qualifiers and values in the messaging port for this transaction.
CIS_E_SERIALIZER_MISMATCH_SPEC | 0x180A | The serialization produced no output. Verify that the document specification matches the outbound XML document.
CIS_E_SERIALIZER_FAILED | 0x180B | The serializer could not finish processing. See the following messages for details.
CIS_E_SERIALIZER_INVALID_SRCQUAL | 0x180C | The "%1" qualifier for the source identifier is too long to be placed in the outbound document header. Update the channel with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_SRCID | 0x180D | The "%1" value for the source identifier is too long to be placed in the output header. Update the channel with a shorter value.
CIS_E_SERIALIZER_INVALID_DESTQUAL | 0x180E | The "%1" qualifier for the destination identifier is too long to be placed in the output header. Update the port with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_DESTID | 0x180F | The "%1" value for the destination identifier is too long to be placed in the output header. Update the port with a shorter identifier.
CIS_E_SERIALIZER_INVALID_POSREC | 0x1810 | The "%1" positional record is defined to contain a record length of zero. This happens when there is no tag, and none of the fields in this record specify start and end positions. Update the fields to have valid start and end positions for this record.
CIS_E_SERIALIZER_NODELIMS | 0x1811 | This serializer component requires delimiters specified in the messaging port. Specify a valid delimiter set for this component.
CIS_E_SERIALIZER_INVALID_CHAR | 0x1812 | The serializer component has encountered a character, "%1", that is not valid. An entry specified in the InvalidCharacterMap tag of the document specification states that characters between "%2" and "%3" are not valid.
CIS_E_SERIALIZER_INVALID_LENGTH | 0x1813 | The length of the "%1" field ("%2") is not valid; it must be between %3 and %4. This document will be rejected.
CIS_E_SERIALIZER_SELECT_SINGLE_NODE_FAILED | 0x1814 | The serializer component cannot find the node using the query "%1". This document will be rejected.
CIS_E_SERIALIZER_RELIABLE_URL_MISSING | 0x1815 | The reply-to URL required for reliable messaging was not set. This document will be rejected.
CIS_E_SERIALIZER_CONTROL_NUMBER | 0x1816 | The serializer component cannot find a control number for %1 %2 in the BizTalk Management database. This document will be rejected.
CIS_E_CUSTOM_ENV_PARSE_TABLE_ERROR | 0x1817 | The serializer component failed to build the custom envelope ID:"%1", this was due to errors in the XML Schema supplied. This document will be moved to the Suspended queue.
CIS_E_SUBSYNC_RELIABLE_MSG | 0x1818 | The BizTalk Framework document that was submitted has "reliability" information specified. This information is not permitted in a synchronous call.
CIS_E_CUSTXML_BODY_NOT_FOUND | 0x1819 | The parser was unable to locate the XML document node by using the query specified in the XML specification: "%1".
CIS_E_BTF_ACK_BAD_MSG_ID | 0x181A | The BizTalk Framework receipt had a <prop:identity> tag that is not valid: "%1". This document will be moved to the Suspended queue.
CIS_E_BTF_MANIFEST_REF_MISSING | 0x181B | The BizTalk Framework document has a <manifest> tag without the mandatory <reference> tag. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_ENV_NO_DOC_NODE | 0x181C | The serializer failed to create the custom envelope because the Document Container Node property was not specified in the XML specification. This document will be moved to the Suspended queue.
CIS_E_BTF_INVALID_XSI_TYPE | 0x181D | The BizTalk Framework document contains an xsi:type attribute "%1" that is not valid. This attribute must not have spaces, and the first character must be alphabetical. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_SYNTAX_IDENTIFIER | 0x181E | The EDIFACT Syntax Identifier "%1" is not valid. Update the channel with a correct identifier.
CIS_E_SERIALIZER_INVALID_UNA_CONTROL | 0x181F | The EDIFACT UNA Control value "%1" is not valid. Update the channel with a correct value.
CIS_E_SERIALIZER_EXPECT_BSTR_VALUE | 0x1820 | The configuration data for the field "%1" must be a string. Update the data for this field.
BTS_E_XMLSERIALIZER_MISSING_DEST | 0x1821 | The BizTalk Framework header could not be generated because no destination identifier was specified.
BTS_E_XMLSERIALIZER_MISSING_SRC | 0x1822 | The BizTalk Framework header could not be generated because no source identifier was specified.
CIS_E_BTF_IDENTITY_MISSING | 0x1904 | The parser could not find the mandatory BizTalk Framework tag "identity". This document will be moved to the Suspended queue.
CIS_E_BTF_EXPIRESAT_MISSING | 0x1905 | The parser could not find the mandatory BizTalk Framework tag "expiresAt". This document will be moved to the Suspended queue.
CIS_E_MSMQ_NOT_INSTALLED | 0x1906 | The Message Queuing receive function could not be started because the Message Queuing service is not installed on the server.
CIS_W_FILE_RECEIVE_RETRY_FAILURE | 0x1907 | There are file(s) in the "%1" directory that cannot be accessed by the file receive function. The receive service will try again to access the file(s) in "%2" seconds.
CIS_E_FILE_RECEIVE_DELETE_FAILURE | 0x1909 | The following file could not be deleted after processing: "%1". Make sure that the file attribute is not set to read-only.
CIS_E_LOGON_USER_FAILURE | 0x190a | Unable to logon with the account %1. Make sure that %2 has been granted "logon locally" privilege on this server and that the BizTalk Server account has "act as part of the operating system" privilege.
CIS_E_MSMQ_RECEIVE_IMPERSONATION_FAILURE | 0x190b | The "%1" Message Queuing receive function could not impersonate the logged on user.
CIS_E_RECEIVE_CANNOT_CREATE_THREAD | 0x190c | A receive-function thread cannot be created due to a system error.
CIS_E_MSMQ_RECEIVE_OPENQ_FAILURE | 0x190d | The following Message Queuing queue cannot be opened: "%1" (Message Queuing error code: 0x%2=%3). Verify the existence and security setting of the queue.
CIS_E_MSMQ_RECEIVE_PEEKQ_FAILURE | 0x190e | The Message Queuing queue could not be read: "%1" (Message Queuing error code: 0x%2=%3).
CIS_E_MSMQ_RECEIVE_RETRIEVEQ_FAILURE | 0x190f | A message could not be retrieved from the following Message Queuing queue: '%1' (Message Queuing error: 0x%2=%3).
CIS_E_FILE_RECEIVE_FINDCHANGE_FAILURE | 0x1910 | The file-change notification cannot be set up on the following directory: "%1". Make sure that the path is correct.
CIS_E_SET_CURRENT_DIR_FAILURE | 0x1911 | The current directory cannot be set to: "%1". Make sure that the path is correct.
CIS_W_RECEIVE_SUBMIT_FAILURE | 0x1914 | A submit request initiated from the "%1" receive function has failed.
CIS_E_READONLY_FILE | 0x1915 | The "%1" receive function picked up the following file: '%2'. This file is marked as read-only and cannot be processed.
CIS_E_BAD_RECSVC | 0x1916 | There was a serious failure in the receive function "%1". This receive service will be shut down, please check the event log for additional error messages.
CIS_E_FILE_RECEIVE_IMPERSONATION_FAILURE | 0x1917 | The "%1" file receive function could not impersonate the logged on user.
CIS_E_MSMQ_RECEIVE_UNEXPECTED_PASSTHROUGH | 0x1918 | The ""%1"" Message Queuing receive function is not configured for a pass-through submission, but it has encountered a document that was submitted previously as a pass-through submission. Change this receive function to accept pass-through submissions or remove the pass-through document from the queue. This receive function will be shut down.
CIS_E_BTSDOCUMENT_INVALIDNAME | 0x1A00 | The document named "%1" does not exist. Correct the document name or add the document to the BizTalk Messaging Management database.
CIS_E_BTSDOCUMENT_INVALIDDOC | 0x1A01 | The server could not load any documents with the given criteria.
CIS_E_BTSDOCUMENT_AMBIGUOUS_NAMESPACE | 0x1A02 | The root node "%1" is ambiguous because documents "%2" and "%3" refer to different specifications with that name. Either change the specifications to remove this ambiguity or use the document name explicitly.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSET | 0x1A03 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSETSHAREID | 0x1A04 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set and have reference "%3".
CIS_E_BTSDOCUMENT_INVALIDPROPERTYSET | 0x1A05 | The following property set was specified: %1.
CIS_E_BTSDOCUMENT_EMPTYPROPERTYSET | 0x1A06 | The property set was empty.
CIS_E_BTSDOCUMENT_LOADFAILED | 0x1A07 | The document "%1" could not be loaded. Possible causes are using a non-envelope specification, or incorrectly configured tracking details.
CIS_E_BTSENVELOPE_LOADFAILED | 0x1A20 | The envelope "%1" could not be loaded. A possible cause is that the specification is not valid. Configure a valid envelope specification.
CIS_E_FAILED_TO_JOIN_TX | 0x1A21 | BizTalk Server failed to join a transaction. Ensure both the DTC and the SQL Server database are running.
MSG_COM_CREATE_FAILED | 0x1B01 | An instance of the %1 class cannot be created: %2.
MSG_CONNECT_WMI_FAILED | 0x1B02 | A connection to Windows Management on "%1" cannot be established: %2.
MSG_COSETPROXY_FAILED | 0x1B03 | The authentication credential cannot be set for the Windows Management connection: %1.
MSG_WMI_ENUMINST_FAILED | 0x1B04 | Instances of the BizTalk Server WMI provider class "%1" cannot be enumerated: %2.
MSG_WMI_GETPROP_FAILED | 0x1B05 | The property value of "%1" cannot be retrieved from the BizTalk Server WMI provider because of an unexpected error: %2.
MSG_WMI_EXECQUERY_FAILED | 0x1B06 | An unexpected error is preventing execution of the BizTalk Server WMI provider query "%1": %2.
MSG_WMI_GETOBJ_FAILED | 0x1B07 | The BizTalk Server WMI provider instance of "%1" cannot be retrieved because of an unexpected error: %2.
MSG_WMI_PUTPROP_FAILED | 0x1B08 | The property value of "%1" cannot be changed because of an unexpected error: %2.
MSG_WMI_PUTINST_FAILED | 0x1B09 | The property values of the BizTalk Server WMI provider instance "%1" cannot be updated because of an unexpected error: %2.
MSG_WMI_DELINST_FAILED | 0x1B0A | The BizTalk Server WMI provider instance "%1" cannot be deleted because of an unexpected error: %2.
MSG_WMI_CREATEINST_FAILED | 0x1B0B | A new instance of the WMI class "%1" cannot be created in the BizTalk Server WMI provider: %2.
MSG_WMI_CREATEGETOBJ_FAILED | 0x1B0C | A new instance of the BizTalk Server WMI provider class "%1" cannot be created because of an unexpected error: %2.
MSG_WMI_EXECMETHOD_GETOBJ_FAILED | 0x1B0D | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the class: %3.
MSG_WMI_EXECMETHODCLASS_FAILED | 0x1B0E | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the method information: %3.
MSG_WMI_EXECMETHODSPAWN_FAILED | 0x1B0F | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of an unexpected error: %3.
MSG_WMI_EXECMETHODPUTPARAM_FAILED | 0x1B10 | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to set the parameter value: %3.
MSG_WMI_EXECMETHOD_FAILED | 0x1B11 | The method "%1" of the WMI class "%2" cannot be executed by the BizTalk Server WMI provider: %3.
MSG_GET_HOSTNAME_FAILED | 0x1B12 | The local computer name cannot be obtained because of an unexpected error: %1.
MSG_OUT_OF_MEMORY | 0x1B14 | Insufficient memory.
MSG_FAIL_LOAD_BMP | 0x1B17 | At least one of the bitmaps cannot be loaded in the BizTalk Server Administration console: %1.
MSG_FAIL_SET_BMPSTRIP | 0x1B18 | At least one pair of bitmaps cannot be added to the image list of the BizTalk Server Administration console: %1.
MSG_ERROR_WMI_PATH_EMPTY | 0x1B19 | The requested operation cannot be completed because of a previous WMI failure. The WMI object path is empty in this case.
MSG_ERROR_BTM_GRP_ENUM_FAIL | 0x1B20 | Unknown problems are preventing the WMI provider from enumerating a list of server groups from the BizTalk Messaging Management database: %1.
MSG_ERROR_GRP_DTA_DB_FAIL | 0x1B21 | Unknown problems are preventing the WMI provider from accessing the Tracking database for the "%1" group.
MSG_ERROR_GRP_SQ_DB_FAIL | 0x1B22 | Unknown problems are preventing the WMI provider from accessing the Shared Queue database the "%1" group.
MSG_ERROR_GRP_BOTH_DB_FAIL | 0x1B23 | Unknown problems are preventing the WMI provider from accessing the Tracking and Shared Queue databases for the "%1" group.
MSG_ERROR_DECRYPT_FAIL | 0x1B24 | Password decryption failed: %1.
MSG_WARN_ENUM4ROOTUPD_FAILED | 0x1B27 | Unknown problems are preventing the WMI provider from retrieving following list of servers and their states to prepare for BizTalk Messaging Management database update: %1
MSG_ERROR_CHANGE_ROOTDB | 0x1B28 | The server "%1" cannot be updated with the new BizTalk Messaging Management database information: %2.
MSG_ERROR_CHANGE_ROOTDB_CONNECT | 0x1B29 | We cannot connect to the WMI namespace "%1" to update server "%2" with the new BizTalk Messaging Management database information: %3
MSG_CHANGE_ROOTDB_SUMMARY | 0x1B30 | The BizTalk Messaging Management database change request has been completed. %1%2 %3%4
MSG_CHANGE_ROOTDB_ON_LOCAL | 0x1B3A | Because the server and server group information cannot be retrieved from the original BizTalk Messaging Management database, the BizTalk Messaging Management database information will be updated only on the local computer "%1". The update has been successful.
MSG_ERROR_UNEXPECTED_ENDOFLIST | 0x1B3C | An unexpected end of list (EOL) for the "%1" class enumeration has been reached.
MSG_ERROR_ORG_QUALIFIERS_FROM_DB_FAILED | 0x1B3D | The organization qualifiers cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_ERROR_ORG_VALUES_FROM_DB_FAILED | 0x1B3E | The organization values cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_WARN_NOT_RESUBMITABLE | 0x1B3F | In the selected group of multiple items, at least one item cannot be submitted again.
MSG_WARNING_PROP_VALUES_CHANGED | 0x1B40 | %1 "%2" specified for receive function "%3" has been removed from the BizTalk Messaging Management database.
MSG_WARNING_QUALIFIER_CHANGED | 0x1B41 | The qualifier and identifier pair "%1" and "%2" specified for receive function "%3" is not valid in the BizTalk Messaging Management database.
MSG_WARNING_ORGANIZATION_CHANGED | 0x1B42 | Organization "%1" specified for receive function "%2" is not valid in the BizTalk Messaging Management database.
MSG_TIMEBOMB_DAYS_LEFT | 0x1B43 | Thank you for evaluating Microsoft BizTalk Server. The period for this evaluation version has %1 days left. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server.
INTERCHANGE_EVENT | 0x3005 | BizTalk Server: %1

Note

  • When an error occurs, the %n variables are replaced with relevant information, such as an object name.


Orchestration Services Error Messages

The BizTalk Orchestration Services object model error messages in the following table are returned when a running XLANG schedule generates the warning or error. These messages can be viewed in Windows® 2000 Event Viewer.

Message name | Value | Description
ID_W_NOT_CREATOR | 0x1000 | An unauthorized client attempted to create a new instance of an XLANG schedule. The remainder of the moniker string and the identity of the client are shown in the following message. The client's security identifier (SID) is included as binary data: %1%0
ID_W_NOT_USER | 0x2001 | An unauthorized client attempted to gain access to an existing instance of an XLANG schedule. The remainder of the moniker string identifying the instance and the identity of the client are shown in the following message. The client's security identifier (SID) is included as binary data: %1%0
ID_W_REHYDRATIONERROR | 0x2002 | An error was encountered while rehydrating an XLANG schedule. There might be a problem reading the database or a problem with the information stored, or your system might be low on resources. The operation will be retried. Detailed information is provided in the following message.%1%0
IDS_E_COMSVCS_INTERNAL_ERROR | 0x3000 | The XLANG Scheduler Engine has detected an inconsistency in its internal state. Please contact Microsoft Product Support Services to report this error: %1%0
IDS_COMSVCS_RESOURCE_ERROR | 0x3001 | The XLANG Scheduler Engine has detected the absence of a critical resource and has caused the process that hosted it to end: %1%0
IDS_COMSVCS_INTERNAL_ERROR_ASSERT | 0x3002 | COM+ internal error. Please contact Microsoft Product Support Services to report this error. Assertion failure: %1%0
ID_E_USER_EXCEPTION | 0x3003 | The system has called a scheduled component and that component has failed and generated an exception. This indicates a problem with the scheduled component. Notify the developer of this component that a failure has occurred and provide the following information: %1%2%0
ID_INITIALIZE_FOR_DTC | 0x3004 | The XLANG Scheduler Engine was unable to initialize for transactions that are required to support transactional components. Make sure that MS DTC is running: %1%0
ID_E_CANT_CREATE_COMPONENT | 0x3005 | The XLANG Scheduler Engine was unable to create a user component that is required by the running XLANG schedule. Detailed information is provided in the following message. %1%0
ID_E_PROGID_NOT_FOUND | 0x3006 | The XLANG Scheduler Engine was unable to convert the Programmatic ID in the following message to a COM class ID: %1%0
ID_E_CANT_CREATE_INTERCEPTOR | 0x3007 | The XLANG Scheduler Engine was unable to create an interceptor object for the interface ID shown in the following message. Probable causes for this are 1) the interface isn't registered properly; 2) no type library is provided for the interface; or 3) the file that contains the interface type information can't be loaded. The port name associated with this interceptor is: %1%0
ID_E_INTF_NOT_SUPPORTED | 0x3008 | The XLANG Scheduler Engine detected an inconsistency between the port implementation and the COM components to which it refers. A component listed in the port implementation has failed to support the expected interface. The class ID of the component and the IID that it failed to support are shown in the following message. The port name associated with this component is: %1%0
ID_E_UNKNOWN_METHOD | 0x3009 | The XLANG Scheduler Engine received a call to a method that was not specified in the port implementation for this XLANG schedule. The IID and method number are shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_UNKNOWN_IDISPATCH_METHOD | 0x300A | The XLANG Scheduler Engine received a call through the IDispatch::Invoke() interface to a method that no longer exists. The dispatch ID for the method is shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_NAMED_PARAMS | 0x300B | The XLANG Scheduler Engine received a call through the IDispatch::Invoke() interface to a method that contains named arguments. Use positional arguments instead. The dispatch ID for the method is shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_BAD_INVOKE_PARAMS | 0x300C | The XLANG Scheduler Engine received a call through the IDispatch::Invoke() interface to a method with an incorrect number of parameters. The IID and the dispatch ID for the method are shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_BAD_RETURN_POINTER | 0x300D | The XLANG Scheduler Engine received an incorrect Out parameter through the IDispatch::Invoke() interface from a method. The reference returned was either not valid (NULL or a bad pointer) or does not support the expected interface. The expected dispatch ID is shown in the following message. The name of the message containing the bad port reference is: %1%0
ID_E_ACCESS_CHECK_FAILURE | 0x300E | The XLANG Scheduler Engine was not able to authorize the client's moniker resolution request. Access is denied.%0
ID_E_BAD_INVOKE | 0x300F | The IDispatch::Invoke() interface call to a method failed. The dispatch ID for the method is shown in the following message. The name of the port on which the call was attempted is: %1%0
ID_E_INVOKED_METHOD | 0x3010 | The invoked method, whose dispatch ID is shown in the following message, reported an error. The name of the port on which the call was attempted is: %1%0
ID_E_CANT_GET_TYPEINFO | 0x3011 | The component whose port name and COM CLSID are shown in the following message was unable to supply required type information to the XLANG Scheduler Engine.%1%0
ID_E_CANT_INVOKE_METHOD | 0x3012 | The XLANG Scheduler Engine was unable to deliver a method call to the object associated with the port name shown in the following message. The interface and method name that are invoked are also shown.%1%0
ID_E_CANT_GET_CLASSINFO | 0x3013 | The component whose port name and COM CLSID are shown in the following message was unable to supply required type information to the XLANG Scheduler Engine through the IProvideClassInfo::GetClassInfo interface.%1%0
ID_E_SCRIPT_ERROR | 0x3014 | A scripted decision rule in an XLANG schedule instance could not be executed. The error returned by the script engine is shown in the following message. The script's source code and information about the schedule instance in which the error occurred is also provided.%1%0
ID_E_SCRIPT_ERROR_NOINFO | 0x3015 | A scripted decision rule in an XLANG schedule instance has failed. Detailed information regarding the error could not be obtained due to an internal error. The error code is shown in the following message.%1%0
ID_E_SCRIPT_BADCONV | 0x3016 | A scripted decision rule in an XLANG schedule instance referred to a message field whose type was incompatible with the VBScript Engine. The XLANG Scheduler Engine attempted to convert the field to a compatible type but was unable to do so. The information in the following message shows the script rule, message, and field involved, as well as the original field variant type and the type to which a conversion was attempted. The field's VARIANT data structure is attached to this log entry as binary data.%1%0
ID_E_SCRIPT_BADARRAY | 0x3017 | A scripted decision rule in an XLANG schedule instance referred to a message field containing an array type that is incompatible with the VB script engine. Only variant arrays are supported by Visual Basic Scripting. The information in the following message shows the script rule, message, and field involved. The field's VARIANT data structure is attached to this log entry as binary data.%1%0
ID_E_SCRIPT_BADEXPR | 0x3018 | A scripted decision rule in an XLANG schedule instance contained an expression that did not return a Boolean result. The information in the following message shows the script rule and expression involved. The VARIANT data structure returned by the expression is attached to this log entry as binary data.%1%0
ID_E_SCHEDULE_NOT_RUNNING | 0x3019 | The XLANG Scheduler Engine received a call to an object associated with a port in an XLANG schedule instance that is not running. The name of the port on which the call arrived is: %1%0
ID_E_INTERNAL_EXCEPTION | 0x301A | A COM+ internal exception occurred. Contact Microsoft Product Support Services to report this error, and provide them with the information in the following message.%1%2%0
ID_E_BAD_DATAFLOW_NOMESSAGE | 0x301B | There is a problem with the data-flow specification. A message that is indicated as a source of data does not currently exist while this XLANG schedule is running. Detailed information is provided in the following message.%1%0
ID_E_BAD_ARGUMENTVALUE | 0x301C | One of the fields that is used as a parameter for a COM method call has a bad value type in it. This is most likely caused by incorrect or missing data flow. Detailed information is provided in the following message.%1%0
ID_E_DEEP_VARIANT_NESTING | 0x301D | One of the fields that is used as a parameter for a COM method call has more than one nesting level of VARIANTs. The IID and the method's dispatch ID are shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_BAD_MAPPORTVALUE | 0x301E | A field carrying a mapped port is not valid. Detailed information is provided in the following message.%1%0
ID_E_BAD_CALLPARAMNUMBER | 0x301F | An incorrect number of parameters are being passed into a call. Detailed information is provided in the following message.%1%0
ID_E_EXECUTINGCALLEDSCHEDULE | 0x3020 | The XLANG schedule cannot be executed as a top-level schedule. Context parameters must be passed to it. Detailed information is provided in the following message.%1%0
ID_E_CANT_GET_SUPPORTERRORINFO | 0x3021 | The component whose port name and COM CLSID are shown in the following message was unable to return success from an interface that it claimed to support to the XLANG Scheduler Engine via ISupportErrorInfo::InterfaceSupportsErrorInfo.%1%0
ID_E_PERSIST_FAILURE | 0x3022 | The state of the schedule instance could not be saved to the database. Detailed information is provided in the following message.%1%0
ID_E_TRANSACTION_COMMIT_FAILURE | 0x3023 | The system failed to commit a transactional context. Detailed information is provided in the following message.%1%0
ID_E_TRANSACTION_ABORTED | 0x3024 | The system aborted a transactional context. Detailed information is provided in the following message.%1%0
ID_E_TRANSACTION_ABORT_FAILURE | 0x3025 | The system failed to abort a transactional context. The state of this transaction is not known. Detailed information is provided in the following message.%1%0
ID_E_PENDINGREHYDRATIONERROR | 0x3026 | The rehydration application encountered an error and is shutting down. Some of the rehydration requests will fail due to this shutdown. Restart the XLANG Scheduler Engine service. Detailed information is provided in the following message.%1%0
ID_E_REHYDRATIONONSTARTUPERROR | 0x3027 | One or more XLANG schedules could not be rehydrated because of a system error. There might be problems reading the database or problems with the data that was read. Detailed information is provided in the following message.%1%0
ID_E_REHYDRATIONERROR | 0x3028 | An error was encountered while rehydrating an XLANG schedule. There might be a problem reading the database, or there might be a problem with the information stored. It is probable that the XLANG schedule was not dehydrated properly. Detailed information is provided in the following message.%1%0
ID_E_FOUNDINITIALIZEDTHREAD | 0x3029 | The XLANG Scheduler Engine service encountered a critical thread-management error while processing an XLANG schedule. The schedule might fail to continue processing. Contact your technical support.%1%0
ID_E_CALLONCOMPLETEDSCHEDULE | 0x302A | The XLANG Scheduler Engine service received a call on a completed XLANG schedule instance. The schedule instance has already been removed from memory. The IID for the interface is shown in the following message.%1%0
IDS_MSG_TIMEBOMB_EXPIRED | 0x302B | Thank you for evaluating Microsoft BizTalk Server 2002. The period for this evaluation version has ended. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server 2002.%0
ID_E_FIELDPORTPERSISTENCEERROR | 0x302C | An error was encountered while attempting to persist an XLANG schedule instance. Detailed information is provided in the following message.%1%0
ID_E_FIELDPORTREHYDRATIONERROR | 0x302D | An error was encountered while attempting to restore a particular sub-component of an XLANG schedule instance from the database. Detailed information is provided in the following message.%1%0
ID_E_SCHEDULEDONE | 0x3030 | The XLANG Scheduler Engine encountered an error while marking the XLANG schedule instance as done. Either the database could not be updated or another error was encountered in the final stage. Detailed information is provided in the following message.%1%0
ID_E_COMPONENT_INCOMPATIBLE_TXN | 0x3031 | The XLANG Scheduler Engine encountered an error while attempting to instantiate a component. Either the component was previously enrolled in a different transaction, or the component was previously not enrolled in a transaction and the current instantiation requires a transaction. Detailed information is provided in the following message.%1%0
ID_E_SUSPEND_FAILURE | 0x3032 | The XLANG schedule instance could not be suspended. Detailed information is provided in the following message.%1%0
ID_E_INITNEW | 0x3033 | The XLANG Scheduler Engine received an error when doing IPersistStreamInit::InitNew. The class ID of the component and the error code are shown in the following message. The port name associated with this component is: %1%0
ID_E_POSSIBLEBYOTISSUE | 0x3034 | The component you requested could not be created. One possible reason for this is that you have configured the BYOT component inside a COM+ application on this machine. This setting is incompatible with the XLANG Scheduler service. The port name associated with this component is: %1%0
ID_E_FIELDPROCESSINGERROR | 0x3035 | The field value provided was not valid. Detailed information is provided in the following message.%1%0
ID_E_NO_OBJECT | 0x3036 | The XLANG schedule could not be instantiated. Detailed information is provided in the following message.%1%0
ID_E_STARTUP_FAILED | 0x3037 | One or more of the XLANG Group Managers failed to start up with the following error: %1%0
ID_E_NON_SCRIPT_BADEXPR | 0x3038 | An XLANG schedule instance has a rule comparing fields for data types that are not permitted. Detailed information is provided in the following message.%1%0
E_BTW_PERSIST_REACHEDEOF | 0x3039 | The recordset cannot return this row, because the end-of-file (EOF) has been reached.%1%0
ID_E_BAD_DATAFLOW_EMPTYFIELD | 0x3040 | There is a problem with the data-flow specification. A field indicated as a source of data is empty. This may be because it could not be persisted earlier. Detailed information is provided in the following message.%1%0
ID_E_CANT_OPEN_DEADLETTER_QUEUE | 0x3041 | The XLANG Scheduler Engine was unable to create or open the XLANG dead-letter queue for its host COM+ application. The name of the failing COM+ application is: %1%0
ID_E_CANT_XFER_TO_DEADLETTER_QUEUE | 0x3042 | The XLANG Scheduler Engine was unable to transfer an invalid message to the XLANG dead-letter queue for its host COM+ application. The name of the failing COM+ application is: %1%0
ID_E_CANT_LOADMODULE | 0x3043 | The XLANG Scheduler engine was unable to load a required module. This may have been due to compilation/semantic errors with the module. Detailed information is available in the following message: %1%0
ID_E_USER_DATA_EXCEPTION | 0x3044 | A value that was received from the client has caused an exception to be raised. This can be caused by incorrectly allocating memory for the data, by a reference counting mismatch, or other data corruption. The most likely source of the problem is in the client code. Detailed information is available in the following message: %1%2%0
E_BTW_INTERNAL_ERROR | 0x4001 | An internal error has occurred. %1%0
E_EXPORT_FAILED | 0x4002 | The XLANG schedule could not be processed.%0
E_BTW_UNKNOWN_SHAPE | 0x4003 | The compiler does not understand the shape. This shape is an unknown shape.%0
E_BTW_INCOMPLETE_FLOW | 0x4004 | The flow is incomplete because a connector is missing.%0
E_BTW_INCOMPLETE_FLOW_LEFT | 0x4005 | The flow is incomplete. The shape must have a flow connected to the left connector.%0
E_BTW_INCOMPLETE_FLOW_RIGHT | 0x4006 | The flow is incomplete. The shape must have a flow connected to the right connector.%0
E_BTW_INCOMPLETE_FLOW_LATERAL | 0x4007 | The flow is incomplete. The shape is not attached to anything on the side.%0
E_BTW_INCOMPLETE_FLOW_TOP | 0x4008 | The flow is incomplete. The shape must have a flow connected to the top connector.%0
E_BTW_INCOMPLETE_FLOW_BOTTOM | 0x4009 | The flow is incomplete. The shape must have a flow connected from the bottom connector.%0
E_BTW_INCOMPLETE_FLOW_ANYLINE | 0x400A | The flow is incomplete. Not connected to any shape.%0
E_BTW_MIRRORLIST_INCONSISTENT | 0x400B | Mirror shapes are not found in the On Failure or Compensation page. Retry after replacing the shape with a new one.%0
E_BTW_BEGIN_INSIDE_TRANSACTION | 0x4010 | The Begin shape must not be enclosed within a transaction.%0
E_BTW_END_MULTIPLE_LOOP | 0x4020 | Only one End shape can be used in the loop branch.%0
E_BTW_END_IN_TRANSACTION | 0x4021 | The End shape cannot be used in the context.%0
E_BTW_SYNCACTION_NO_PAIR | 0x4030 | Binding to a COM port requires actions to appear in pairs.%0
E_BTW_INCOMPLETE_FLOW_BINDING | 0x4031 | No binding for this action or port.%0
E_BTW_FIELD_TYPE_NOT_SUPPORTED | 0x4040 | Type (variant type=%1) is not supported.%0
E_BTW_ROLE_NOT_SUPPORTED | 0x4050 | Contracts (XLANG Schedules with Roles) cannot be compiled.%0
E_BTW_EMPTY_TRANSACTION | 0x4060 | The transaction contains no valid shapes.%0
E_BTW_TRANSACTION_NOT_PERMITTED | 0x4061 | Transaction shapes are not permitted when the XLANG schedule is treated as a COM+ component. Remove the transaction or edit the properties of the Begin shape to change the transaction model.%0
E_BTW_TRANSACTION_BOUNDARIES_CROSSED | 0x4062 | You cannot connect a flow from outside a transaction to a shape within a transaction without first connecting the flow to the transaction. Draw your flow to the top connection point of a transaction to connect it to the transaction. Then, click the transaction to highlight it. Draw another flow from the transaction connection point to the first shape within the transaction. To draw a flow that leaves the transaction, you must first connect the flow to the connection point at the bottom of the transaction. Then, click the transaction to highlight it. Draw another flow from the bottom connection point to the next shape in the business process.%0
E_BTW_TRANSACTION_TERMINATED_PREMATURELY | 0x4063 | At least one path within the transaction should flow out of the transaction.%0
E_BTW_NO_RULES_FOR_SWITCH | 0x4070 | Decision shapes must contain at least one rule.%0
E_BTW_CANNOT_WAIT_ON_ALL_SWITCH_BRANCHES | 0x40A0 | Cannot wait on "all" branches from the decision.%0
E_BTW_NO_BRANCH_FOUND | 0x40A1 | The join cannot find the corresponding fork or decision.%0
E_BTW_JOIN_MISMATCH | 0x40A2 | Only a single join may be used with a given fork or decision.%0
E_BTW_JOIN_SHARED | 0x40A3 | The same join cannot be used for flows coming from different forks or decisions.%0
E_BTW_CANNOT_WAIT_ON_SOME_SWITCH_BRANCHES | 0x40A4 | Not all paths from the decision come to the join.%0
E_BTW_CANNOT_WAIT_ANY_ON_FORK_BRANCHES | 0x40A5 | Cannot wait "Or". The branches contain process forms that might never finish, resulting in hung schedules.%0
E_BTW_DATAFLOW_DISALLOWED_ON_BTM_PORT | 0x40C0 | This port cannot be used in multiple receive actions or within a single receive action in a loop.%0
E_BTW_MESSAGE_TECH_NOT_FOUND | 0x4110 | The message is not bound to any port.%0
E_BTW_MESSAGE_TYPE_MISMATCH | 0x4111 | The message was used with conflicting types "%1" and "%2".%0
E_BTW_MISSING_TECHNOLOGY | 0x4120 | The list of available methods for this communication flow has changed. Re-run the Method Communication Wizard to select a different method and update this communication flow.%0
E_BTW_MISSING_PORT_DATAFLOW | 0x41A0 | The settings for this port indicate that it is created externally to the XLANG Scheduler Engine. You must designate the source of this port reference by drawing a connection from the appropriate message field.%0
E_BTW_CIRCULAR_DATAFLOW | 0x41A1 | There appears to be a circular path in the data-flow path for this XLANG schedule.%0
E_BTW_LOOP_NORULE | 0x41D0 | A rule has not been defined.%0
E_BTW_LOOP_BODY_EXITS_TRANSACTION | 0x41D1 | The body of the loop cannot exit the enclosing transaction.%0
E_BTW_LOOP_BODY_END_MISSING | 0x41D2 | The end of the body of the loop is not found.%0
E_BTW_ABORT_NOT_IN_TXN | 0x41E0 | Abort shapes must be associated with an enclosing transaction.%0
E_BTW_ABORT_CONTEXT_INVALID_SCOPE | 0x41E1 | Abort shapes can refer to current or parent contexts only.%0
E_BTW_END_MULTIPLE_ABORT | 0x41E2 | Multiple End shapes are not allowed on the On Failure page.%0
E_BTW_COMPILER_FAILED | 0x5000 | Compile failed on "%1".%0
E_BTW_PARSE_FAILED | 0x5001 | Parse failed.%0
E_BTW_FIXUP_FAILED | 0x5002 | Fixup failed.%0
E_BTW_VALIDATION_FAILED | 0x5003 | Validation failed.%0
E_BTW_NODE_FAILURE | 0x5004 | at node "%1" (%2!d!,%3!d!).%0
E_BTW_STACK_TOO_MANY_ITEMS | 0x5005 | Too many items were found on the stack.%0
E_BTW_STACK_UNEXPECTED_NODE | 0x5006 | An unexpected node was found.%0
E_BTW_XMLQUERY_RETURNED_ZERO_NODES | 0x5007 | The XML Query returned zero nodes.%0
E_BTW_XMLQUERY_RETURNED_MULTIPLE_NODES | 0x5008 | The XML Query returned multiple nodes.%1%0
E_BTW_XMLQUERY_MISSING_ATTRIBUTE | 0x5009 | Required attribute "%1" is missing its value.%0
E_BTW_LOAD_MODULE_FAILED | 0x500A | Failed to load module "%1".%0
E_BTW_XML_LOAD_FAILED | 0x500B | The XML-DOM returned an error at "%1!d!, %2!d!".%0
E_BTW_ERROR_LOADING_PACKAGE | 0x500C | 0x%1!X! error occurred while trying to load the following URL: "%2".%0
E_BTW_NAMED_LIST_HAS_DUPLICATE_ENTRIES | 0x500D | The list has duplicate entries with the name "%1".%0
E_BTW_REQUIRED_ELEMENT_MISSING | 0x500E | Required element "%1" is missing.%0
E_BTW_ELEMENT_MISSING_VALUE | 0x5100 | The element value is missing.%0
E_BTW_REFERENCE_RESOLVE_FAILED | 0x5110 | Unable to resolve "%1" with location value "%2".%0
E_BTW_CONTEXTREF_INVALID_REFERENCE | 0x5120 | Returning to or "releasing" from an independent (non-enclosing) context is not permitted.%0
E_BTW_CONTEXTREF_SELF_REFERENCE | 0x5121 | Return or Release referring to a context from within that context is not permitted.%0
E_BTW_ASYNC_ACTION_COM_NOT_ALLOWED | 0x5400 | An asynchronous action must refer to a non-COM port.%0
E_BTW_CONNECTION_PORT_HAS_TECH_BINDING | 0x5490 | The port "%1" used in a connection cannot have technology binding.%0
E_BTW_CONNECTION_PORT_REUSED | 0x5491 | The port "%1" used in a connection has been used before in the XLANG schedule.%0
E_BTW_TRANSACTIONS_NESTED | 0x54B0 | When transactions are nested, the outer transaction must be long-running.%0
E_BTW_TRANSACTIONS_NESTED_RETRY | 0x54B1 | When transactions are nested, the outer transaction cannot have retry count.%0
E_BTW_MESSAGE_HAS_NO_DECL | 0x5520 | Message "%1" has no associated declaration.%0
E_BTW_MESSAGE_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5521 | Message "%1" has unsatisfied data dependencies on "%2". The dependencies are either not getting created in the flow or are potentially expected on a port in which the "No instantiation" option has been selected.%0
E_BTW_PORT_HAS_NO_BINDING | 0x5570 | Port "%1" has no associated binding.%0
E_BTW_PORT_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5571 | Port "%1" has unsatisfied data dependencies on messages "%2". The dependencies are either not being created in the flow or are potentially expected on a port in which the "No instantiation" option has been selected.%0
E_BTW_RULE_HAS_NO_BINDING | 0x55B0 | Rule "%1" has no associated binding.%0
E_BTW_SCHEDULE_SUSPENDED | 0x55E0 | The XLANG schedule has been suspended.%0
E_BTW_SCHEDULE_STOPPED | 0x55E1 | The XLANG schedule has been stopped.%0
E_BTW_PERSIST_FAILED | 0x55E2 | The state of the XLANG schedule instance could not be saved to the database.%0
E_BTW_SUSPEND_FAILED | 0x55E3 | The XLANG schedule could not be suspended.%0
E_XLANG_SHUTTINGDOWN | 0x55E4 | The XLANG application is shutting down.%0
E_BTW_MISSING_MESSAGE_BINDING_ON_PORT | 0x5730 | The action uses port "%1" whose binding does not define the binding for message "%2".%0
E_BTW_MISSING_INCOMING_PORTREF | 0x5731 | The message used by this receive action contains a field (%1) that is connected to a port reference (%2) but the dataflow connections do not indicate that the port reference should be received.%0
E_BTW_SOURCE_PORT_HAS_NOINVOCATION | 0x5740 | The send action refers to port "%1", in which the "No instantiation" option has been selected.%0
E_BTW_MISSING_OUTGOING_PORTREF | 0x5741 | The message used by this source action contains a field (%1) that is connected to a port reference (%2) but the dataflow connections do not indicate that the port reference should be sent.%0
E_BTW_TASK_LIMIT | 0x5750 | The task has "%1!d!" actions. The current limit is "%2!d!".%0
E_BTW_SYNC_DIFFERENT_PORTS | 0x5760 | Synchronous action pair refers to different ports: "%1" and "%2".%0
E_BTW_SYNC_SAME_MESSAGE | 0x5761 | Synchronous action pair refers to the same message: "%1".%0
E_BTW_SYNC_ONLY_COM_ALLOWED | 0x5762 | Synchronous action pair must refer to COM port only.%0
E_BTW_SYNC_SECOND_MESSAGE_MUST_BE_OUT_FOR_FIRST_MESSAGE | 0x5763 | In a synchronous action pair the message in the second action must be the out message for the message in the first action.%0
E_BTW_INVALID_DELAY_TIME | 0x5770 | The delay time (%1!d!) is not valid. The delay time cannot be a negative number.%0
E_BTW_CALL_MESSAGE_SCHEMA_NAME_MISMATCH | 0x5800 | The message specification name "%1" for the message "%2" in the calling XLANG schedule does not match the specification name "%3" in the called XLANG schedule.%0
E_BTW_CALL_MESSAGE_SCHEMA_REPRESENTATION_MISMATCH | 0x5801 | The message specification representation for message "%1" in the calling XLANG schedule does not match the specification representation in the called XLANG schedule.%0
E_BTW_ASSIGNMENT_PORT_HAS_TECH_BINDING | 0x5830 | Port "%1" used in an assignment in a cut form cannot have technology binding.%0
E_BTW_PARTITION_LIMIT | 0x5850 | The partition has "%1!d!" process(es). The current limit is "%2!d!".%0
E_BTW_MESSAGE_USED_IN_PARALLEL | 0x5851 | Parallel actions or processes use the same message "%1".%0
E_BTW_PORT_USED_IN_PARALLEL | 0x5852 | Parallel actions or processes use the same port "%1".%0
E_BTW_INVALID_RETRY_COUNT | 0x5A30 | The retry count "%1!d!" is not valid. The retry count cannot be negative.%0
E_BTW_INVALID_BACKOFF_VALUE | 0x5A31 | The back-off value "%1!d!" is not valid. The back-off value cannot be negative.%0
E_BTW_INVALID_TIMEOUT_VALUE | 0x5A32 | The timeout value "%1!d!" is not valid. The timeout value cannot be negative.%0
E_BTW_FIELD_RESERVED_NAME | 0x5A50 | %1 is a reserved field name.%0
E_BTW_ELEMENT_TYPE_NOT_DEFINED | 0x5A51 | The element type "%1" is not defined.%0
E_BTW_ELEMENT_TYPE_INCOMPLETE | 0x5A70 | The element type definition is incomplete. Provide either subelements or dt:type.%0
E_BTW_MULTIPLE_PORTS | 0x5A90 | Distinct ports "%1" and "%2" are used on the same field.%0
E_XLANG_INVALID_COMPARE_TYPE | 0x5A91 | Comparison of this data type is not permitted.%0
E_BTW_FIELD_NOT_MATCHING_SCHEMA_ELEMENT | 0x5A92 | FieldBinding for "%1" does not have a matching element in the schema at position "%2!d!".%0
E_BTW_FIELD_HAS_AMBIGUOUS_DATAFLOW | 0x5A93 | A message field cannot have both a data flow from another message field and a reference to a port. One of the data flows must be removed.%0
E_BTW_PORT_TARGET_INVALID | 0x5A94 | The type of this field is inappropriate for use as a port reference. Ports bound to a COM component can be communicated as object references or strings. Ports bound to Message Queuing may only be transferred as strings. Internal ports can be communicated only as object references.%0
E_BTW_FIELD_TARGET_INVALID | 0x5A95 | The target field "%1", which is of variant type "%2", cannot get data from source field "%3", which is of variant type "%4".%0
E_BTW_INITIALIZED_MESSAGEFIELD_INVALID_OVERWRITE | 0x5A96 | The data in field "%1" of an initialized message "%2" cannot be overwritten with data from another message or port in the binding specification.%0
E_BTW_DATAFLOW_INCOMPLETE | 0x5AB1 | A source action accepting [in] parameters must have the corresponding fields populated by data flow (that is, "from").%0
E_BTW_DATAFLOW_FROM_SYSTEM_FIELD | 0x5AB2 | Port cannot be initialized from a system field.%0
E_BTW_DATAFLOW_FROM_CONSTANT_FIELD | 0x5AB3 | Port cannot be initialized from a constant message field.%0
E_BTW_MISSING_SCRIPT_EXPRESSION | 0x5AC0 | No script expression was supplied for the rule.%0
E_BTW_BAD_SCRIPT_EXPRESSION | 0x5AC1 | %1 %2 at character position %3!d! in "%4".%0
E_BTW_MAP_INVALID_BINDING | 0x5AE0 | The binding for message "%1" must contain a reference for mapped port "%2".%0
E_BTW_MESSAGE_BINDING_SCHEMA_MISMATCH | 0x5AE1 | There is a mismatch between the binding and schema for the message "%1".%0
E_BTW_MESSAGEDECL_INIT_DATA_UNAVAILABLE | 0x5B00 | Unable to obtain initialization data for field "%1".%0
E_BTW_LATENCY_INVALID_VALUE | 0x5B20 | The Latency property value must be a non-negative integer that is less than the maximum long integer "%1!d!".%0
E_BTW_PORT_LATENCY_ON_INTERNAL | 0x5B21 | Cannot specify latency on an internal port.%0
E_BTW_MESSAGE_TECHNOLOGY_MISMATCH | 0x5BB0 | There is a mismatch between the port "%1" technology "%2" and the message "%3" technology "%4".%0
E_BTW_FIELD_TECHNOLOGY_MISMATCH | 0x5BC0 | There is a mismatch between the message "%1" technology "%2" and the field "%3" technology "%4".%0
E_BTW_COM_PORT_NOT_CREATABLE | 0x5C10 | If a COM port can be invoked, it must have a CLSID, a ProgID, or a moniker.%0
E_BTW_AUTORETURN_COM_PORT_MUST_BE_USED_INSIDE_CONTEXT | 0x5C11 | The port "%1", which is configured to abort a transaction if a method returns a failure HRESULT, can only be used inside a transaction.%0
E_BTW_COM_PORT_GENERAL_ACCESS_FAILURE | 0x5C12 | A COM port can be invoked. Please refer to the Windows 2000 documentation.%1%0
E_BTW_COM_PARAMETERS_LIMIT | 0x5C20 | The method has "%1!d!" parameter(s). The current limit is "%2!d!".%0
E_BTW_COM_NO_MATCHING_RETURN | 0x5C21 | The COM method has no matching Return.%0
E_BTW_COM_NO_MATCHING_METHOD | 0x5C22 | The COM Return has no matching method.%0
E_BTW_INVALID_SLOT_NUMBER | 0x5C23 | The slot number "%1!d!" is not valid. Slot numbers cannot be less than the following value: SLOT_NONE(-1).%0
E_BTW_INVALID_INVOKE_KIND | 0x5C24 | The invokeKind value "%1!d!" is not valid. Acceptable values are: 1,2,3,4 and 8.%0
E_BTW_PROXY_DISCONNECTED | 0x5C25 | The proxy has been disconnected.%0
E_BTW_COM_DISPATCH_SLOT_SPECIFIED | 0x5C26 | A slot number cannot be specified for the dispatch interface.%0
E_BTW_COM_SPECIFY_DISPID_OR_SLOT | 0x5C27 | Valid values for dispid or slot must be specified.%0
E_BTW_COM_INVALID_BYREF_FOR_RETURN_MESSAGES | 0x5C30 | Byref should be "1" since "%1" is a <com:return> message.%0
E_BTW_COM_INVALID_NESTED_VARIANTS | 0x5C31 | More than one level of nesting for variants is not permitted.%0
E_BTW_COM_FIELD_INDEX_MUST_BE_NON_NEGATIVE | 0x5C32 | The index "%1!d!" for the field is not valid. The index must be a non-negative integer.%0
E_BTW_COM_FIELD_INDEX_REPEATED | 0x5C33 | The index "%1!d!" for the field has been used before on another field in the message.%0
E_BTW_COM_FIELD_INDEX_NOT_CONTIGUOUS | 0x5C34 | For synchronous action pair messages "%1" and "%2", the index "%3!d!" for a field is not valid. The field indices for these messages must form a contiguous block of non-negative numbers that start with zero.%0
E_BTW_MSMQ_NO_MQRT_DLL | 0x5D00 | The Message Queue DLL, MQRT.DLL, cannot be loaded.%0
E_BTW_MSMQ_CREATECHANNEL | 0x5D01 | MQBinder: CreateChannel failed for: %1.%0
E_BTW_MSMQ_NOT_CONFIGERED_PROPERLY | 0x5D02 | The Message Queuing Service is not configured properly. A queue object could not be opened %1.%0
E_BTW_MSMQ_NO_CERTIFICATE_AVAILABLE | 0x5D03 | The Message Queuing Service is not able to obtain a certificate.%1%0
E_BTW_MSMQ_NO_WELLKNOWN_QUEUE_NAME | 0x5D04 | A message cannot be sent to a known queue because the queue is not named in the XLANG schedule. You must provide a queue name in the XLANG schedule.%1%0
E_BTW_MSMQ_INVALID_FIELD_TYPE | 0x5D05 | The field type specified for message "%1" field "%2" is not valid.%0
E_BTW_MSMQ_PORT_NOT_BOUND | 0x5D06 | The Message Queuing port is not bound.%1%0
E_BTW_MSMQ_QUEUE_NOT_TRANSACTIONAL | 0x5D10 | The queue does not have the correct transactional properties.%1%0
E_BTW_MSMQ_OPEN_ACCESSDENIED | 0x5D11 | A Message Queuing access denied error occurred when opening the queue. Compare the accessRole specified for the queue in the XLANG schedule with the rights associated to the current user.%1%0
E_BTW_MSMQ_OPEN_GENERALFAILURE | 0x5D12 | A Message Queuing failure occurred when opening the queue. Refer to the Message Queuing Service documentation in Windows 2000 to look up the error code and diagnose as appropriate.%1%0
E_BTW_MSMQ_PORT_NOT_CREATABLE | 0x5D13 | A port that is implemented by using a message queue must have a queue name.%0
E_BTW_MSMQ_GENERAL_QUEUE_ACCESS_FAILURE | 0x5D14 | A Message Queuing failure occurred when accessing the queue. Refer to the Message Queuing Service documentation in Windows 2000 to look up the error code and diagnose as appropriate.%1%0
E_BTW_MSMQ_INVALID_MESSAGE_VT_TYPE | 0x5D20 | The Message Queuing message is of unknown format.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGETYPE | 0x5D21 | The Message Queuing message is of unknown message type. The message type could not be obtained from the message.%1%0
E_BTW_MSMQ_MESSAGE_UNAUTHENTICATED | 0x5D22 | The Message Queuing message is not authenticated but the port only accepts authenticated messages.%1%0
E_BTW_MSMQ_MESSAGE_INCORRECT_AUTHENTICATE_LEVEL | 0x5D23 | The Message Queuing message is not authenticated at the requested level.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGE | 0x5D24 | The Message Queuing message has a message body that is not valid.%1%0
E_BTW_MSMQ_MESSAGE_NOT_SEND | 0x5D25 | The Message Queuing message could not be sent.%1%0
E_BTW_MSMQ_MESSAGE_SCHEMAVALIDATION_FAILED | 0x5D26 | The Message Queuing message was not successfully validated against the schema that was provided. Check the schema and the schema path.%1%0
E_BTW_MSMQ_COULD_NOT_CREATE_MQMESSAGE | 0x5D27 | The message instance could not be converted to a Message Queuing message. %1%0
E_BTW_MSMQ_NO_TRUSTRELATIONSHIP_FOR_USER | 0x5D28 | The trust relationship for the provided user could not be established.%1%0
E_BTW_MSMQ_MESSAGE_EMPTY_MESSAGE | 0x5D29 | The Message Queuing message has an empty message body.%1%0
E_BTW_MSMQ_MESSAGE_ONLY_ONE_EMPTY_XPATH_ALLOWED | 0x5D2A | The Message Queuing message can have only one field with an empty node path (XPath).%0
E_BTW_MSMQ_MESSAGE_ONE_EMPTY_XPATH_NEEDED | 0x5D2B | The Message Queuing message must have one field with an empty node path (XPath).%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGEBODY | 0x5D2C | The Message Queuing message has a message body that is not valid.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGESTRING | 0x5D2D | The Message Queuing message has an invalid string for the message body.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGE | 0x5D2E | The Message Queuing message is an invalid or unknown message and was moved to the dead-letter queue.%1%0
E_BTW_MSMQ_MESSAGE_TYPE_CONFLICTING_SCHEMA | 0x5D2F | The Message Queuing messages "%1" and "%2", which are of type "%3" on port "%4", have conflicting specification representations. This could be because the name, type, or XPath query does not match for one of the fields in the two representations.%0
E_BTW_MSMQ_DOCUMENT_FIELD_TYPE_NOT_STRING | 0x5D30 | A Message Queuing message's field "%1", that has an empty node path (XPath), must be a string data type.%0
E_BTW_MSMQ_DOCUMENT_FIELD_CANNOT_CONVERT_TO_STRING | 0x5D31 | A Message Queuing message's field could not be converted to a string.%1%0
E_BTW_MSMQ_DOCUMENT_FIELD_CONVERTION_FAILURE | 0x5D32 | The Message Queuing message's field could not be converted.%1%0
E_BTW_CANT_DISPOSE_MESSAGE | 0x6001 | The XLANG schedule instance was bound to a queue that received a message that is not valid. The XLANG Scheduler Engine was unable to transfer this message to the dead-letter queue, so the schedule instance has been terminated.%0

Related Topic

Configure Event Viewer for BizTalk Server errors


Standard COM Error Messages

The following table shows the most common standard COM errors returned by the properties and methods of the BizTalk Server objects.

Constant | Value (32-bit) | Description
S_OK | 00000000 | The standard return value used to communicate successful completion.
S_FALSE | 00000001 | An alternate success value, typically used to communicate successful, but non-standard completion. The precise meaning depends on the method or property in question.
E_UNEXPECTED | 8000FFFF | Catastrophic failure error.
E_NOTIMPL | 80004001 | Not implemented error.
E_OUTOFMEMORY | 8007000E | Out of memory error.
E_INVALIDARG | 80070057 | One or more arguments are not valid error.
E_NOINTERFACE | 80004002 | Interface not supported error.
E_POINTER | 80004003 | Pointer not valid error.
E_HANDLE | 80070006 | Handle not valid error.
E_ABORT | 80004004 | Operation aborted error.
E_FAIL | 80004005 | Unspecified error.
E_ACCESSDENIED | 80070005 | General access denied error.
MK_E_NOOBJECT | 800401E5 | The object identified by this moniker could not be found.

Additional information may be available using the global Err object. In Visual Basic, the Description property of the Err object may contain a text description of the error.

In C++, call the OLE DB method GetErrorInfo on the IErrorRecords interface to retrieve the most recently set IErrorInfo pointer in the current logical thread. The GetDescription method of the IErrorInfo interface may return a text description of the error. For more information about the GetErrorInfo method, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to OLE DB Interfaces in the Platform SDK.


BizTalk Server 用語集

A

ANSI X12

米国の公的な標準化委員会 X12 によって設定された EDI 標準。その内容は米国規格協会 (American National Standards Institute) によって標準として認められています。

Application Center 2000

開発サイクル中 （開発から試験を経て運用に至るまで） 中にアプリケーションを移行する作業を簡素化する Microsoft 製品。Application Center は開発アプリケーション、試験アプリケーション、および運用アプリケーション間の一貫性を保証します。サーバー間のアプリケーション展開を自動化することによって、Application Center は転送速度を上げ、手動エラーをなくし、リリースの品質を上げます。

Application Center 2000 クラスタ

統一したコンピューティング リソースとして同時に作動する独立サーバーのグループ。Application Center クラスタはリソースを共有しません。故障したクラスタ メンバを切り離して無視することによって高可用性を提供します。リソース共有とフェールオーバーで高信頼性を提供する Microsoft Windows クラスタと比較してください。

B

BizTalk Accelerator for HIPAA

組織が HIPAA ソリューションを迅速かつ容易に構築できるようにする Microsoft BizTalk Server 2002 へのアドオン製品。BizTalk Accelerator for HIPAA には、医療保健機関、支払者、およびクリアリングハウス (医療保険機関または支払者の代理として機能する) が HIPAA 固有のトランザクションの交換、監視、制御を行えるようにするアプリケーションが複数含まれています。BizTalk Accelerator for HIPAA は、HIPAA 固有の BizTalk Server 2002 ベースのソリューションを迅速に開発するために必要なドキュメント仕様、アプリケーション、およびコンポーネントを提供します。

BizTalk SEED ウィザード

会社の構成を組み込んだ XML パッケージの作成を可能にさせるツール。パッケージが作成されると、取引先は、BizTalk SEED ウィザードを使用して自分の組織内にその構成をインストールして、Web上で開始会社と取り引きすることができます。

BizTalk Server 2002

企業内および企業間において、ビジネス プロセスの自動化およびアプリケーションの統合を実現するための Microsoft 製品。BizTalk Server 2002 は、企業内および企業間の疎結合、長時間ビジネス プロセスを統合する、強力な Web ベースの開発環境および実行環境を提供します。

BizTalk Server 2002 の機能としては、新規の XLANG スケジュールと既存の XLANG スケジュールの合成、既存のアプリケーションの統合、ドキュメント仕様と仕様変換の定義、および実行時の利用状況の監視とログの記録があります。

サーバーは、インターネットを利用したドキュメントの送受信のための標準ゲートウェイを提供すると同時に、データの整合性、配信、および安全性を確保するサービスや、BizTalk フレームワークおよびその他の主要ドキュメント書式をサポートするサービスなど、さまざまなサービスを提供します。

BizTalk Server Accelerator for RosettaNet

組織が迅速かつ容易に RosettaNet ソリューションを構築できるようにする、Microsoft BizTalk Server 2002 へのアドオン製品。BizTalk Server Accelerator for RosettaNet には、ユーザーが BizTalk Server 2002 XLANG スケジュールとして実装される RosettaNet 標準準拠の Partner Interface Process (PIP) を開発、管理、およびテストできるようにするアプリケーションが複数含まれています。

BizTalk Server 管理コンソール

BizTalk Server 2002 のサーバー グループとそのプロパティの管理、受信機能の監視、およびサーバー グループによって使用される Microsoft SQL Server キュー内の作業項目を監視するために使用する Microsoft 管理コンソール (MMC) インターフェイス。

BizTalk エディタ

XML 仕様を作成、編集、および管理するためのツール。BizTalk エディタを使用すると、仕様のテンプレート、既存のスキーマ、特定の種類のドキュメント インスタンス、または空の仕様を基に、仕様を作成することができます。

BizTalk オーケストレーション サービス

XLANG スケジュールの設計、コンパイル、および実行を含むサービス。そのほかのサービスとして、特定の XLANG スケジュール インスタンスをホストするカスタム COM+ アプリケーションを作成する機能や XLANG スケジュールの永続化があります。

BizTalk オーケストレーション デザイナ

長時間、疎結合、コンピュータ処理可能なビジネス プロセスを記述するフローチャートを作成するための設計ツール。XLANG スケジュール フローチャートは、自動化されたビジネス プロセスを実行するために使用する XLANG スケジュールにコンパイルされます。

BizTalk ドキュメント トラッキング

BizTalk メッセージ サービスのすべての追跡情報にアクセスするために使用する Web ベースのユーザー インターフェイス (UI)。BizTalk オーケストレーション サービスの XLANG スケジュール ステータスを追跡することもできます。

BizTalk フレームワーク

Extensible Markup Language (XML) スキーマおよび業界標準に基づく、プラットフォームに依存しない電子商取引のフレームワーク。フレームワークにより、ハードウェア、オペレーティング システム、テクノロジに関係なく、業界間およびビジネス システム間を統合できます。具体的には、フレームワークは、スキーマ、製品、およびサービスから構成されます。BizTalk フレームワークの詳細については、BizTalk の Web サイト (www.microsoft.com/japan/biztalk/) を参照してください。

BizTalk マッパー

ある仕様のレコードおよびフィールドと、別の仕様のレコードおよびフィールドとの対応関係を定義するマップを作成するためのツール。マップには、マップに記述された変換を実行するために BizTalk Server が使用する Extensible Stylesheet Language (XSL) スタイル シートが含まれます。

BizTalk メッセージ管理データベース

すべてのサーバー構成に関連する情報を格納する Microsoft SQL Server データベース。サーバー構成には、グループおよびサーバー設定、受信機能、BizTalk メッセージ マネージャを使用して作成されるオブジェクのすべてのメッセージ構成情報、および BizTalk メッセージ構成オブジェクト モデルにアクセスして作成されるオブジェクトのすべてのメッセージ構成情報が含まれます。

BizTalk メッセージ サービス

ドキュメントの送信/受信/解析/追跡、受信確認の生成と照合、およびデータのマッピング/データ整合/セキュリティを含むサービス。

参照 : BizTalk メッセージ マネージャ

BizTalk メッセージ マネージャ

取引先とアプリケーションとの間でドキュメントを交換できるように BizTalk メッセージ サービスを構成するために使用するグラフィカル ユーザー インターフェイス (UI)。

参照 : BizTalk メッセージ サービス

E

EDIFACT

Electronic Data Interchange For Administration, Commerce, and Transport の略。国際連合で開発された、国際的な EDI 標準。この標準は、ヨーロッパで普及していて、日本を始めアジアの国や地域でも使用されています。UN/EDIFACT としても知られています。

Extensible (XML) Structure Definitions (XSD)

スキーマ言語。XSD 言語は、Extensible Markup Language (XML) 構造を定義するための言語として最近 World Wide Web Consortium (W3C) が推奨している言語です。

Extensible Markup Language (XML)

World Wide Web Consortium (W3C) によって開発された仕様。これにより、システム設計者は標準 HTML にはない独自のタグを作成することができます。HTML はあらかじめ定義されたタグのみを使用してページ内の要素を記述しますが、XML ではページの開発者がタグを定義することができます。製品や支払総額など、事実上どのようなデータ項目のタグでもそれぞれのアプリケーションで使用することができます。これにより Web ページをデータベース レコードとして利用することができます。

参照 : コンパイル、データ変換、マップ、XML-Data Reduced (XDR)、XPath

Extensible Stylesheet Language (XSL)

Extensible Markup Language (XML) ドキュメントのスタイル シート書式。XSL は、Cascading Style Sheets (CSS) が Hypertext Markup Language (HTML) の表示を定義するために使用されるのと同じように、XML の表示を定義するために使用されます。BizTalk Server は、仕様間の変換言語として XSL を使用します。

F

Functoid

再利用可能な組み込み関数。これにより、送信元仕様の要素、送信先仕様の要素、およびほかの Functoid の間で複雑で構造的な処理ができます。

参照 : リンク

Functoid パレット

すべての Functoid を含むツール ボックス。送信元仕様の要素と送信先仕様の要素との間の関係を作成する場合に使用します。

M

Microsoft Operations Manager (MOM)

Microsoft Windows 2000 のオープンな高拡張性のエンタープライズ操作管理およびモニタリング アプリケーション。ユーザー、アプリケーション、ソフトウェア、サーバー、デスクトップによって生成されるイベントの集中化した、動的なモニタリングと自動問題解決を可能にします。

MOM は規則を使用して、さまざまなイベントへの応答をモニタリングして生成します。この応答の範囲は、ユーザー通知から問題の自動解決までさまざまです。

S

SEED パッケージ

BizTalk SEED ウィザードを使用して作成される、会社のビジネス ドキュメント構成を含む XML パッケージ。パッケージが作成されると、取引先は、BizTalk SEED ウィザードを使用して自分の組織内にその構成をインストールして、Web 上で中央の会社と取り引きすることができます。

参照 : ハブ、スポーク

W

Web Distributed Authoring and Versioning (WebDAV)

HTTP 接続上のファイル システムなどの階層ファイル格納メディアを表示する HTTP 1.1 標準の拡張部分。WebDAV によって、ドキュメントはユーザーが誤って上書きしないようにロックされます。また、オーサリング ツール、プラットフォーム、ファイルが格納されている Web サーバーの種類にかかわらず、サーバー ベースのドキュメントを共有および作業できるようになります。

Windows Management Instrumentation (WMI)

共通のインターフェイス セットを通じてシステム リソースの監視および制御をサポートし、Windows 操作、構成、およびステータスの論理的に編成された一貫性のあるモデルを提供する、Microsoft Windows 2000 の管理インフラストラクチャ。BizTalk Server 2002 は、WMI レイヤを使用して管理機能をカプセル化します。

X

XLANG ID

XLANG スケジュール フローチャートのバージョンを識別するために使用される、グローバル一意識別子 (GUID)。この ID は読み取り専用であり、変更することはできません。XLANG スケジュール フローチャートを更新すると、そのたびにこの ID も更新されます。XLANG ID は、ある XLANG スケジュールと、そのスケジュールのコンパイルに使用した特定のバージョンの XLANG スケジュール フローチャートとを関連付ける場合に利用できます。

XLANG 言語

ビジネス プロセス フローの論理的な順序を記述するための言語。さまざまな実装技術を利用した、ビジネス プロセスの実装を記述するためにも使用されます。XLANG 言語は XML で表現されます。

XLANG スケジューラ

BizTalk Server 2002 と共にインストールされる既定の COM+ アプリケーション。実行中の XLANG スケジュール インスタンスをホストするために使用されます。

XLANG スケジューラ エンジン

XLANG スケジュール インスタンスを実行するサービス。XLANG スケジュールの開始、実行、ステータス退避、およびステータス復元を制御します。

参照 : ステータス退避、ステータス復元、XLANG スケジュール、XLANG スケジュール フローチャート、XLANG スケジュール インスタンス

XLANG スケジュール

ビジネス プロセスを、XLANG 言語で表現したもの。保存した XLANG スケジュールには、.skx というファイル拡張子が付いています。

参照 : XLANG スケジューラ エンジン、XLANG スケジュール フローチャート、XLANG スケジュール インスタンス

XLANG スケジュール インスタンス

実際に開始されたスケジュール。"XLANG スケジュール" は、ビジネス プロセスとそれに実装されるサービスのみを表します。XLANG スケジュールは XLANG スケジューラ エンジンによって実行され、1 つだけを実行することも、複数実行することもできます。同じ XLANG スケジュールからインスタンスを作成した場合は、すべてのインスタンスが同一のビジネス プロセスを実行しますが、含まれるメッセージはインスタンスごとに異なります。

参照 : XLANG スケジュール、XLANG スケジューラ エンジン

XLANG スケジュール ステータス

XLANG スケジュール インスタンスに含まれている情報。ステータスに含まれているのは、インスタンスが送受信したメッセージ、インスタンスが使用したすべての COM オブジェクト、およびビジネス プロセス内におけるインスタンスの進捗状況です。

参照 : ステータス

XLANG スケジュール フローチャート

ビジネス プロセスを表現したフローチャート。BizTalk オーケストレーション デザイナを使用して完成させたフローチャートをコンパイルすると、それをもとに XLANG スケジュールを作成し、実行できます。保存した XLANG スケジュール フローチャートには、.skv というファイル拡張子が付いています。

参照 : XLANG スケジュール、XLANG スケジューラ エンジン、通信シェイプ、フローチャート シェイプ

XML-Data Reduced (XDR)

Microsoft が考案し、1998 年に World Wide Web Consortium (W3C) に提出された XML スキーマ方言。XML-Data と同様に、XML ドキュメントの構造を定義するための Extensible Markup Language (XML) スキーマ用の構文として使用します。XDR は XML-Data のサブセットです。

参照 : Extensible Markup Language (XML)

XPath

階層構造の XML ドキュメントを操作するために使用される、多機能な言語。XPath 式を使用すると、XML の要素と属性に関する情報を取得できるほか、特定の条件を満たすデータを選択したり、抽出したデータを比較したりできます。ノード パスと呼ばれることもあります。

参照 : Extensible Markup Language (XML)、ノード パス

あ

アクション

メッセージを送受信すること。送信アクションおよび受信アクションは、どのアプリケーション サービスが XLANG スケジュールに実装されているかによって、同期または非同期になります。

アプリケーション統合コンポーネント (AIC)

アプリケーションにデータを引き渡すために BizTalk Server ステータス エンジンが呼び出す COM オブジェクト。BizTalk Server 2002 にメッセージ ポートが構成されて、アプリケーション統合のために AIC の使用が組み込まれる場合、このコンポーネントは自動的にインスタンス化され、必要なデータが渡されます。次にコンポーネントはアプリケーションと通信してこのデータを戻す方法を決定します。これは、個別の API 呼び出しを使用したり、ほかの COM オブジェクトを呼び出したり、データベースへの書き込みを使用したりして行うことができます。

位置指定フラット ファイル

固定長フィールドおよび共通のレコード終端記号を持つレコードを含むファイル。

イベント コンシューマ

Windows Management Instrumentation (WMI) のイベントや Windows NT イベント ログのイベントなどのシステムおよびアプリケーション イベント通知の受信者。たとえば、Microsoft Operations Manager (MOM) は、イベント通知を使用して警告を出し、管理者に通知し、スクリプトを実行するイベント コンシューマです。

参照 : プロバイダ

インスタンス キュー

XLANG スケジュールの各新規インスタンスで使用するために作成されたキュー。

参照 : 静的キュー、動的キュー

インターチェンジ

単一の送信を構成するドキュメント インスタンスの集合。組織内のアプリケーションとアプリケーション、または取引先との間で交換します。

内側のトランザクション

別のトランザクションの処理フロー内に含まれるトランザクション。

参照 : 長時間トランザクション、ネストしたトランザクション、外側のトランザクション、トランザクション

エンベロープ

1. エンベロープを定義する一連のプロパティ。エンベロープのプロパティにはエンベロープ書式が含まれ、エンベロープ仕様へのポインタを含むことができます。

2. ヘッダーとフッター情報、またはヘッダー情報のみ。トランスポートのためにドキュメント データをカプセル化し、必要な情報を提供します。

エンベロープ書式

XML や ANSI X12 など、エンベロープの中に含まれるドキュメントの書式。

オープン チャネル

送信元組織にオープンであると明示的に宣言されているチャネル。オープン チャネルの送信元指定データは、ドキュメント内またはドキュメントとともに送信されるパラメータのいずれかで BizTalk メッセージ サービスに渡されます。

参照 : チャネル、オープンネス、送信元組織

オープンなメッセージ ポート

送信先組織にオープンであると明示的に宣言されているメッセージ ポート。オープンなメッセージ ポートの送信先指定データは、ドキュメント内またはドキュメントとともに送信されるパラメータのいずれかで BizTalk メッセージ サービスに渡されます。

参照 : チャネル、オープンネス、送信元組織

オープンネス

チャネルの送信元またはメッセージ ポートの送信先についての明示的な情報を静的に設定しないこと。チャネルには送信元を識別する情報が含まれています。メッセージ ポートには送信先を識別する情報が含まれています。チャネルを "オープンな送信元" として設定したときは、チャネルには送信元情報を明示的に宣言せず、ほかの手段で指定します。この情報は、受信ドキュメントのインスタンスに含まれるか、Submit メソッドのパラメータとして指定します。同様に、メッセージ ポートを "オープンな送信先" として設定すると、メッセージ ポートには送信先情報を明示的に宣言せず、代わりに、送信ドキュメント インスタンスまたは Submit メソッドのパラメータで指定します。

参照 : 送信先組織、オープン チャネル、オープンなメッセージ ポート、送信元組織

か

階層レベル (HL)

行項目データと出荷データの関係やパッケージ データと行項目データの関係など、詳細情報のレベルを識別する階層構造のセグメント。HL を使用して、データ セグメントの階層的に関連付けられたグループ間の依存関係とその内容を識別します。

カスタム カウンタ

ユーザーが追跡データベースの高度なクエリを基にして独自の Windows Management Instrumentation (WMI) クラス インスタンスを定義できるようにする値。

完全構成された規則

Microsoft BizTalk Server 2002 管理パックの一部として完全に事前構成されたMicrosoft Operations Manager (MOM) の規則。

参照 : ユーザー定義された規則

関連付け

受信ドキュメントと正確なスケジュール インスタンスの関連付け。

関連付けトークン

HTTP 受信機能への送信が成功したとき、クライアントに戻される変数パラメータ。これには、ドキュメントの送信先が BizTalk Server かファイルかによって、送信ハンドルまたはファイル名が含まれます。

基幹業務 (LOB) アプリケーション

組織の主要な業務用アプリケーション。BizTalk Server 2002 は多数の通信プロトコルをサポートします。これにより、基幹業務アプリケーションは確実に情報を送受信できます。

企業内アプリケーション統合 (EAI)

個別のアプリケーションがデータを電子的に共有できるようにするシステム。EAI により、組織は統合作業および個々のトランザクションを実行することができます。

既定の組織

BizTalk メッセージ マネージャで自分の企業を表すオブジェクト。既定の組織は、BizTalk Server 2002 をインストールすると、自動的に作成されます。既定の組織だけがアプリケーションを持つことができます。

参照 : 送信先アプリケーション、同報リスト、組織、送信元アプリケーション、取引先

休止ステータス

非アクティブまたは休止している処理状態を表すステータス。またはプロセスがスタンバイ モードのときのステータス。

業界標準

情報の交換に使用される標準。標準は拡張可能で、明確な規則または構文が定められています。

共有キュー データベース

サーバー グループ内のすべてのサーバーで共有される Microsoft SQL Server データベース。共有キュー データベースには、BizTalk Server が処理するドキュメントに関連するすべてのチェックポイント情報が格納されます。サーバーに障害が発生しても、同じ共有キュー データベースを使用するほかのコンピュータは、作業キューからのメッセージの取得および作業キューへのメッセージの送信を続けることができます。これにより、冗長性と処理の負荷分散を実現します。共有キュー データベースは、BizTalk Server 管理コンソールに、一連の個別キューとしてグラフィカルに表示されます。

参照 : 再送信キュー、送信待キュー、保留キュー、作業キュー

クエリ

情報を検索するために使用される式。BizTalk ドキュメント トラッキングでは、クエリは、送信元組織などの標準の検索条件を使用して追跡データベースから追跡データを抽出するために使用する SQL ステートメントです。

参照 : 高度なクエリ

区切りフラット ファイル

区切り文字で区切られたフィールドの集まりとして表されるレコードを含むファイル。レコードは、それ自体も区切り文字で区切られます。

クラスタ

より高度な可用性、操作性、拡張可能性を持つ単一システムとして管理される独立サーバーのグループ。1 つのサーバー クラスタの最小要件は、2 つのサーバーがネットワークで接続されていること、各サーバーがほかのサーバーのディスク データにアクセスする方法の搭載、Windows クラスタのような特定のクラスタ ソフトウェアが搭載されていることです。この特定のソフトウェアは障害検索、回復などのサービスや、サーバーを単一システムとして管理する機能を提供します。

グローバル追跡項目

BizTalk メッセージ サービスが処理したドキュメントのインスタンスごとに、追跡データベースに記録するドキュメント仕様フィールド。ドキュメント定義内で指定します。

参照 : ドキュメント定義、ドキュメント インスタンス

コード一覧

さまざまなテキスト情報の略語として使用されるコード値の一覧。たとえば、ST は "Ship To" に対するコード一覧の値で、一般的に住所を修飾するために使用されます。

構成

BizTalk Server 2002 のさまざまなコンポーネント (BizTalk ポート、BizTalk ポート グループ、BizTalk 受信機能、BizTalk スケジュール、および BizTalk カスタム カウンタなどのリソース) を定義する情報パッケージ。

構成 XML

1 つまたは複数のアプリケーションを試験やステージング環境から運用環境へと展開するときに使用する、共にパッケージされたチャネルやポート情報などの関連構成項目のセットのテキスト (通常は XML) 表現。

高度なクエリ

特定の情報を検索するために使用される式。BizTalk ドキュメント トラッキングでは、高度なクエリは、Purchase Order Total などのカスタム検索条件を使用して追跡データベースから特定の追跡データを抽出するために使用する SQL ステートメントです。

参照 : クエリ

コミット

保留中のトランザクションによって要求されているすべての変更を実行すること。このアクションは、トランザクション内のすべてのアクションが正常に完了した場合に発生します。

参照 : 中断、トランザクション

混在したコンテンツ

XML で、テキスト内容とサブ要素の両者を含む要素。要素は属性を持つ場合と、持たない場合があります。

コンパイル

BizTalk Server が使用できる Extensible Stylesheet Language Transformations (XSLT) バージョンのマップを BizTalk マッパーで作成すること。マップは WebDAV リポジトリに格納され、あるドキュメント書式から別のドキュメント書式に変換するために BizTalk Server によって使用されます。

参照 : マップ、データ マッピング、データ変換、Extensible Markup Language (XML)

さ

サーバー グループ

集中的に管理、構成、監視される個々のサーバーの集合。

再送信

保留キューから BizTalk Server にインターチェンジまたはドキュメントを送信する処理手順。ドキュメントは障害が発生した時点から処理されます。

再送信キュー

Microsoft SQL Server の共有キュー データベース内のテーブル。再送信キューは、最初の送信が試行された後に返信用にスケジュールされた作業項目を含むサーバー グループに関連付けられています。

参照 : 保留キュー、作業キュー、送信待キュー、共有キュー データベース、トランスポート サービス

作業キュー

Microsoft SQL Server の共有キュー データベース内のテーブル。作業キューはサーバー グループに関連付けられています。現在 BizTalk Server 2002 が処理しているインターチェンジが含まれます。

参照 : 再送信キュー、送信待キュー、共有キュー データベース、保留キュー

サポート技術情報

イベントの意味および重要度に関する知識を含む規則コメントの集まり。サポート技術情報には、Microsoft からの定義済み情報が含まれています。サポート技術情報には、Microsoft Operations Manager 2000 ユーザーによって入力された情報が含まれています。

実装シェイプ

XLANG スケジュール エンジンがサポートするテクノロジを表すシェイプ。このカテゴリのシェイプには、BizTalk メッセージ、COM コンポーネント、メッセージ キュー、およびスクリプト コンポーネントが含まれます。

参照 : フローチャート シェイプ、実装ステンシル、通信シェイプ

実装ステンシル

BizTalk オーケストレーション デザイナが提供するステンシル。実装ステンシルには、実装テクノロジへポートをバインドするのに使用できるすべてのシェイプがあります。

参照 : フローチャート ステンシル、実装シェイプ

実装テクノロジ

XLANG スケジュールのポートを実装するために使用するテクノロジ。XLANG スケジューラ エンジンによってサポートされるテクノロジには、COM コンポーネント、Windows スクリプト コンポーネント、メッセージ キュー サービス、および BizTalk メッセージ サービスがあります。

受信確認チャネル

ドキュメントの送信者に返信する受信確認を処理するために必要な情報を含むチャネル。

参照 : チャネル

受信機能

BizTalk サーバーがディレクトリを監視し、BizTalk Server にドキュメントを送信できるようにする機能。BizTalk Server 2002 では、ファイル受信機能、HTTP 受信機能、およびメッセージ キュー受信機能がサポートされます。

出力インスタンス

コンパイルされたスタイル シートで入力インスタンスの使用によって生じるファイル。

参照 : 入力インスタンス

出力して終了

内部エラーまたは不整合の探索時に、重大または回復不可能な可能性がある後続エラーを回避するためにプロセスが早期終了すること。

循環参照

レコードがそれ自体の下位要素として作成されるときに行われる仕様内の参照。循環参照が行われるのは、BizTalk エディタの [参照] タブで標準プロパティ値が [XML] に設定されている場合だけです。

仕様

BizTalk Server 特有の XML スキーマ。仕様は BizTalk エディタで作成し、業界標準 (EDIFACT、ANSI X12、XML など) またはフラット ファイル (区切り、位置指定、または区切り位置指定) を基にして作成することができます。BizTalk マッパーは、送信元仕様および送信先仕様を開き、それらの仕様を使ってマップを作成します。

シリアライザ

XML ファイルを非 XML ファイル (ANSI X12、EDIFACT、フラット ファイルなど) に変換する BizTalk Server のコンポーネント。

信頼できるメッセージ

インターネット間の異種環境において、ドキュメントの確実に一度だけ配信される機能をサポートする BizTalk フレームワーク 2.0 プロトコルの機能。

スキーマ

XML ファイルの構造の定義。スキーマには構造内のレコードおよびフィールドに属するプロパティ情報が含まれます。

ステータス

コンピュータ処理のさまざまな要素のある時点での状態。

参照 : XLANG スケジュール ステータス

ステータス退避

ビジネス プロセスの次のアクションを実行する前、XLANG スケジューラ エンジンがメッセージの受信を待機している間に、XLANG スケジュール インスタンスのすべてのステータス情報を SQL Server データベースに格納すること。

参照 : XLANG スケジューラ エンジン

ステータス退避済みスケジュール

次のアクションに進む前、メッセージの受信を待機している間に、一時的にデータベースに格納されたスケジュール。スケジュールのすべてのステータス情報は、メッセージが受信されるまでデータベースに格納されます。スケジュールをステータス退避すると、スケジュールをホストしているコンピュータの負荷が減ります。

ステータス復元

メッセージが XLANG スケジュール エンジンによって受信された後、SQL Server データベースから XLANG スケジュール インスタンスのすべてのステータス情報を取得すること。

参照 : XLANG スケジューラ エンジン

ステータス保存データベース

XLANG スケジュールが退避されるときに、XLANG スケジュールのステータスを格納するために使用されるデータベース。BizTalk Server 2002 をインストールするとき、インストール中にオーケストレーション データベースという既定のデータベースが作成されます。

スポーク

ビジネス ドキュメントを交換できるように中央の会社 (ハブ) から SEED パッケージを受信する取引先。通常のシナリオでは、1 つの中央の会社と、その会社が取り引きする同種の取引先から構成されます。中央の会社はハブと呼ばれ、取引先はスポークと呼ばれます。

参照 : ハブ、SEED パッケージ

整形式 XML

単一のルートおよび完全にネストしているかまったくしていない要素を持つ、標準に適合した XML。

静的キュー

アドレスが静的に決まっているキュー。キューの場所が決まっていて不変な場合、メッセージ キューを使用するポートは静的キューを使用します。

参照 : 動的キュー、インスタンス キュー

静的ポート

XLANG スケジュールに必要なすべての情報を、設計時に設定するポート。XLANG スケジュールを作成するときに、メッセージの送信先や受信する場所、および通信アクションに使用する実装シェイプのテクノロジを設定します。

参照 : 動的ポート、ポート

セルフルーティング ドキュメント

ルーティング タグまたはドキュメント内に、送信元組織識別子、送信先組織識別子、ドキュメント定義などのすべての必要なルーティング情報を含んでいるドキュメント。

選択条件

ドキュメント定義に指定された、名前と値の組。名前と値の組は、ファンクショナル グループ ヘッダーにある値に基づいて、受信 EDI インターチェンジに対応するドキュメント定義を一意に識別するため、および送信 EDI インターチェンジのファンクショナル グループ ヘッダーに値を設定するために使用されます。

参照 : ドキュメント定義、電子データ交換 (EDI)

送信先

ドキュメントが処理されるチャネルの組織名。送信先は BizTalk メッセージ サービスで定義されます。

送信先アプリケーション

メッセージ ポートにドキュメントの送信先として指定されている既定の組織のアプリケーション。

参照 : 既定の組織

送信先仕様

送信ドキュメントを表す、マップ内の仕様。BizTalk マッパーを使用して、送信元仕様を送信先仕様にマップします。

参照 : 送信元仕様

送信先組織

メッセージ ポートにドキュメントの送信先として設定されている取引先の組織。

参照 : オープンネス、組織、送信元組織

送信待キュー

Microsoft SQL Server の共有キュー データベース内のテーブル。送信待キューは、BizTalk Server が受信したがまだ処理していないインターチェンジを持つサーバー グループに関連付けられています。

参照 : 再送信キュー、保留キュー、作業キュー、共有キュー データベース

送信元

ドキュメントが処理されるチャネルの送信元として指定された組織名。送信元は BizTalk メッセージ サービスで定義されます。

送信元アプリケーション

チャネルにドキュメントの送信元として指定されている既定の組織のアプリケーション。

参照 : チャネル、既定の組織

送信元仕様

受信ドキュメントを表す、マップ内の仕様。BizTalk マッパーを使用して、送信元仕様を送信先仕様にマップします。

参照 : 送信先仕様

送信元組織

チャネルにドキュメントの送信元として設定している取引先の組織。

参照 : チャネル、送信先組織、オープン チャネル、オープンなメッセージ ポート、オープンネス、組織、取引先

属性

レコードまたはフィールドの特性。属性には複数のプロパティが含まれます。

組織

取引先または取引先の業務部門。既定の組織の場合、自分の企業。

参照 : 送信先組織、組織識別子、取引先、既定の組織、送信元組織

組織識別子

組織を一意に識別する一連のプロパティ。組織は複数の組織識別子を持つことができます。組織識別子は、名前、修飾子、値から構成されます。

参照 : 組織

外側のトランザクション

処理フローに 1 つ以上のトランザクションを含むトランザクション。

参照 : 内側のトランザクション、長時間トランザクション、ネストしたトランザクション、トランザクション

た

短時間トランザクション

作業の単独論理単位として実行するアクションの集合。

参照 : 長時間トランザクション、トランザクション

チェックポイント

作業項目の現在のステータスが格納されている、共有キュー データベース内の格納場所。サーバーに障害が発生した場合、そのサーバーのキューにあるドキュメントは、チェックポイントに記録されている情報を基に、共有キュー データベースから取り出され、サーバー グループ内の別のサーバーで処理されます。

チャネル

送信元のドキュメントを指定し、チャネルに関連付けられているメッセージ ポートまたは同報リストによって指定されている送信先にドキュメントが配信される前に BizTalk メッセージ マネージャが行う特定の処理手順を定義するプロパティ。

参照 : パススルー送信、受信確認チャネル、送信元アプリケーション、取引先、オープン チャネル、オープンなメッセージ ポート、送信元組織

チャネル ID

ドキュメントが処理されるチャネルを一意に識別するために BizTalk Server 2002 によって割り当てられたグローバル固有識別子 (GUID)。

チャネル フィルタ

ドキュメント インスタンス内のフィールドの値とチャネル内に指定された式の値を比較すること。この比較により、ドキュメントを処理するためにサーバーが呼び出すチャネルが決まります。

中断

進行中のトランザクションを取り消すこと。オーケストレーション スケジュールで、[中断] シェイプは、トランザクション再試行を中断し、失敗した最小トランザクションを検討するよう XLANG スケジューラ エンジンに明示的に指示するために使用されます。失敗したトランザクションは、"トランザクションの失敗時" コードを実行することもできます。

参照 : トランザクション、コミット

長時間トランザクション

数日間、数ヶ月間などの長期に渡るメッセージを送受信するアクションの集合。通常、長時間トランザクションにはいくつかのネストした短時間トランザクションが含まれます。

参照 : 内側のトランザクション、ネストしたトランザクション、外側のトランザクション、短時間トランザクション、トランザクション

追跡データベース

個別またはバッチでサーバーが処理するドキュメントを追跡する、サーバー グループに関連付けられている Microsoft SQL Server データベース。XLANG スケジュール ステータスも追跡できます。

通信シェイプ

メッセージの内容そのもの、および XLANG スケジュール フローチャートに実装されるアプリケーション サービスの種類を表すためのシェイプ。この種類のシェイプには、定数 (Constants)、メッセージ (Message)、ポート (Port)、ポート参照 (Port References) が含まれます。

参照 : フローチャート シェイプ、実装シェイプ、XLANG スケジュール フローチャート

データ変換

データをある形式から別の形式に変換する処理。データ変換は、BizTalk Server が実行しているときに行われます。データを送信元仕様の形式から送信先仕様の形式に変換する際、データに必要な処理および計算を実行するのに、マップに指定された規則が使用されます。

参照 : コンパイル、データ マッピング、マップ、Extensible Markup Language (XML)

データ マッピング

送信元仕様のレコードおよびフィールドと、送信先仕様のレコードおよびフィールドとの対応関係を BizTalk マッパーで作成すること。

参照 : コンパイル、データ変換

ディクショナリ

BizTalk Server によって処理される各作業単位に関連付けられるプロパティの集まり。これによって、メッセージ ポートを決定するのに使うドキュメント インスタンス内にあるプロパティの値の検索方法を、BizTalk Server に対して指示できます。ディクショナリは BizTalk エディタで設定します。

電子データ交換 (EDI)

異なる企業間で、商取引のためのデータを、通信回線を介して標準的な規約 (可能な限り広く合意された各種規約) を用いて、コンピュータ (端末を含む) 間で交換すること。コンピュータ間の注文や請求書などのドキュメントの転送を制御するために使用する一連の標準。

参照 : 選択条件

同期通信

2 つ以上のプロセス間の対話。あるプロセスは別のプロセスと通信しますが、ほかのプロセスから特定の応答を受信するまで、処理を続行できません。

参照 : 非同期通信

同時実行

同時に実行される 2 つ以上のアクション。

動的キュー

アドレスが動的に決まるキュー。メッセージ キューを使用するポートは、キューの場所が動的な場合、動的キューを使用します。実行時にメッセージが、このキューのアドレスのポート参照を指定します。

参照 : 静的キュー、インスタンス キュー

動的ポート

実行時に、XLANG スケジュールに特定の場所情報を提供する必要があるポート。動的ポートの場所は、実行時にポートを参照する場所情報を持ったメッセージによって提供されます。

参照 : 静的ポート、ポート

同報リスト

複数の異なる取引先または既定の組織のアプリケーションに、同じドキュメントを送信するためのメッセージ ポートのグループ。BizTalk メッセージ構成オブジェクト モデルでは、同報リストはポート グループとして参照されます。

参照 : メッセージ ポート、取引先、既定の組織

ドキュメント インスタンス

BizTalk Server に送信される実際のデータの表現。ドキュメント インスタンスは、構造化されたデータの表現です。データ構造を定義する仕様とは別のものです。

参照 : グローバル追跡項目、パススルー送信

ドキュメント型

仕様が準拠しているドキュメント形式の名称。たとえば、仕様が ANSI X12 標準からの 850Schema.xml に準拠している場合、その仕様を BizTalk エディタで開くと、ルート ノードの [参照] タブの [ドキュメント型] フィールドに 850 と表示されます。

ドキュメント型定義 (DTD)

どの要素および属性がほかの要素および属性にあるかを指定する標準に基づいた定義、順序、繰り返し、および内容なども定義します。

ドキュメント定義

特定のドキュメントを表す一連のプロパティ。ドキュメント定義のプロパティにはドキュメント定義へのポインタが含まれ、グローバル追跡項目および選択条件も含みます。

参照 : グローバル追跡項目、選択条件

ドキュメント標準

ANSI X12 標準 850 (注文) などのトランザクション セットの構造のインプリメンテーション。実装ガイドライン (データ交換接続システム準備のための説明書) はドキュメント標準から作成することができます。

ドキュメント メッセージ処理

BizTalk メッセージ サービスを使用して、メッセージ ドキュメントを送信、受信、解析、追跡すること。

トポロジ

1 つの構成内にあるコンピュータ間の組織的関係。たとえば、BizTalk Server 内の共通トポロジでは、複数の処理サーバーが単一の BizTalk メッセージ管理データベースを共有します。

トランザクション

顧客からの注文入力や在庫の更新など、コンピュータ システム内の個々の処理。集合的に成功または失敗する一連の操作から構成されます。つまり、ある操作が失敗した場合、トランザクション全体がロールバックされ、失敗の前に行われた操作の結果はすべて元に戻されます。トランザクションは通常、データベース管理システム、注文入力システムなどのオンライン システムに関連付けられています。BizTalk オーケストレーション デザイナでは、トランザクションはトランザクション シェイプ内のグループ化されたアクションの集合として表されます。

参照 : 中断、内側のトランザクション、長時間トランザクション、ネストしたトランザクション、外側のトランザクション、短時間トランザクション、コミット

トランザクション セット

ビジネス ドキュメントを表現する、EDI スキーマ。意味的に関連するフィールドの集まりであるセグメント複数で構成され、フィールドやセグメントの順序と意味が定義されています。トランザクション セットは、ANSI X12の用語で、EDIFACT では、メッセージという用語が使われます。

トランスポート サービス

ネットワーク プロトコルとアプリケーション統合コンポーネント (AIC) を含む一連のサービス。BizTalk Server 2002 は主要なトランスポート サービスをサポートします。これにより、アプリケーションが COM インターフェイスを使ってサーバーと直接通信できるかどうかに関係なく、サーバーは組織またはアプリケーションにドキュメントを送信できます。BizTalk Server 2002 は、ファイル、HTTP、HTTPS、および SMTP の各ネットワーク プロトコルと、メッセージ キューをサポートしています。トランスポート サービスは、トランスポート コンポーネントとも呼ばれます。

参照 : ループバック、再送信キュー

取引先

既定の組織が電子データを交換する外部の組織。メッセージ ポート、同報リスト、チャネル、および XLANG スケジュールによって、取引先とのドキュメント交換を管理します。

参照 : チャネル、同報リスト、既定の組織、組織、送信元組織

な

入力インスタンス

特定のスキーマまたは仕様に対応する、内容を保持するドキュメント。

参照 : 出力インスタンス

ネイティブ

Extensible Markup Language (XML) データではないすべてのデータ。

ネイティブ インスタンス

ネイティブ データのインスタンス。たとえば、EDI 850 (注文)。

ネストしたトランザクション

より大きなトランザクションの処理フロー内に含まれるトランザクション。

参照 : 内側のトランザクション、長時間トランザクション、外側のトランザクション、トランザクション

ノード パス

XML 要素および属性情報の取得、条件に一致するデータの選択、および取得したデータの比較の実行に使用する式。公式には、XPath として知られています。

参照 : XPath

は

パーサー

XML ファイルや、非 XML ファイル (ANSI X12、EDIFACT、フラット ファイルなど) を XML ファイルに変換する BizTalk Server のコンポーネント。

バージョン

BizTalk Server 2002 では、仕様のリリース番号、または作成した仕様の元となった業界標準のバージョン番号のいずれかのこと。

パイプライン コンポーネント

BizTalk Server 2002 でアプリケーションを統合するために作成されるコンポーネント。開発者は、IPipelineComponent または IPipelineComponentAdmin インターフェイスのいずれか、またはより負荷の少ない IBTSAppIntegration インターフェイスを使用して、これらのコンポーネントを開発できます。

バインド

ポートを実装すること。

参照 : ポート

パススルー送信

解析、デコード、暗号解読、変換、および署名検証の処理段階をバイパスする送信。ドキュメント インスタンスは、送信パラメータで指定されたチャネルに直接渡されます。この種類の送信は、データが破損しないようにバイナリ ファイルを送信するため、またはサーバー トランスポートとグローバル追跡機能のみを使用するために使用することができます。

参照 : チャネル、ドキュメント インスタンス

ハブ

BizTalk SEED ウィザードを使用して取引先 (スポーク) に送信する SEED パッケージを作成して、ビジネス ドキュメントを交換できるようにする中央の会社。通常のシナリオでは、1 つの中央の会社と、その会社が取り引きする同種の取引先から構成されます。中央の会社はハブと呼ばれ、取引先はスポークと呼ばれます。

参照 : SEED パッケージ、スポーク

パフォーマンス カウンタ

BizTalk Server 2002 用の特定のパフォーマンス関連パラメータを示し、Microsoft Windows 2000 のパフォーマンス カウンタ インフラストラクチャを介して使用可能になる値。パフォーマンス カウンタは通常 Windows 2000 の標準ユーティリティであるシステム モニタを使用して表示されますが、Microsoft Operations Manager (MOM) などのほかのアプリケーションによって使用されることもあります。

判断

条件式を順番に評価する処理。BizTalk オーケストレーション デザイナでは、判断は判断シェイプで表されます。条件は、Microsoft Visual Basic Scripting Edition (VBScript) 式で記述し、[判断] シェイプおよび [繰り返し] シェイプで使用します。

非セルフルーティング ドキュメント

送信元組織識別子、送信先組織識別子、ドキュメント定義などのルーティング情報のうち、1 つ以上が欠けているドキュメント。

非同期通信

2 つ以上のプロセス間の対話。あるプロセスは別のプロセスと通信し、ほかのプロセスとは無関係に処理を続けることができます。

参照 : 同期通信

プール

COM+ オブジェクト プールを使用して、メモリ内に同時にアクティブで常駐している 1 つまたは複数のスケジュールのインスタンス数を制限すること。

フローチャート シェイプ

XLANG スケジュール フローチャートのルーティング定義を表すシェイプ。このカテゴリのシェイプには、開始、アクション、判断、繰り返し、分岐、結合、トランザクション、終了、および中断が含まれます。

参照 : フローチャート ステンシル、XLANG スケジュール フローチャート、通信シェイプ、実装シェイプ

フローチャート ステンシル

BizTalk オーケストレーション デザイナが提供するステンシル。フローチャート ステンシルには、LANG スケジュールで実行できるビジネス プロセスの処理フローを設計するのに使用できるすべてのシェイプがあります。

参照 : 実装ステンシル、フローチャート シェイプ

プロバイダ

Microsoft Operations Manager (MOM) によって収集される情報の収集元。プロバイダには、システム イベント ログ、パフォーマンス カウンタなどがあります。

参照 : イベント コンシューマ

ポート

特定の実装を行う名前を付けられた場所。BizTalk オーケストレーション デザイナでは、メッセージが送受信される場所、または通信アクションを実装する場所のこと。場所はポート名によって一意に識別されます。

参照 : バインド、動的ポート、モニカ、静的ポート、ポート実装、ポートの場所、ポート名、ポート参照

ポート ID

ドキュメントが処理されるポートを一意に識別するために BizTalk Server 2002 によって割り当てられたグローバル固有識別子 (GUID)。

ポート グループ

同じドキュメントをいくつかの異なる取引先の組織またはアプリケーションに送信するために使用することができるメッセージ ポートの集まり。BizTalk メッセージ マネージャでは、これを同報リストと呼びます。

ポート参照

XLANG スケジュール内の各ポートの場所を含む一意なメッセージ。ポート参照シェイプは [データ] ページに表示されます。このメッセージの内外のデータ フローには、ポートの場所が含まれます。

参照 : ポート、ポート実装、ポートの場所、ポート名

ポート実装

通信アクションを実装するためにポートが使用する特定のテクノロジ。

参照 : ポート、ポートの場所、ポート名、ポート参照

ポートの場所

特定のポートと関連付けられた場所。場所は使用されるポート実装に依存します。各実装によって、ポートに対して異なる種類の場所が提供されます。

参照 : ポート、ポート実装、ポート名、ポート参照

ポート名

ポートの一意な ID。この ID は、ポートの場所を特定のポートに関連付けるために使用されます。

参照 : ポート、ポート実装、ポートの場所、ポート参照

補正

完了したトランザクションに対する修復処理。たとえば、注文に対する支払いを済ませた後、結局その注文に応えられなかった場合、支払い額を購入者に返します。

保留キュー

Microsoft SQL Server の共有キュー データベース内のテーブル。保留キューはサーバー グループに関連付けられています。キューには、処理中にエラーが発生した作業項目が含まれます。キューは、ドキュメントが修正および再処理されるか単純に削除されるまで、ドキュメントを格納します。

参照 : 再送信キュー、送信待キュー、共有キュー データベース、作業キュー

ま

マッピング

ある構造のデータを別の構造に変換する方法の指定に従ってする処理。

マップ

ある仕様のレコードおよびフィールドと、別の仕様のレコードおよびフィールドとの対応関係を定義する XML ファイル。マップには、マップに記述された変換を実行するために BizTalk Server が使用する Extensible Stylesheet Language (XSL) スタイル シートが含まれます。マップは BizTalk マッパーで作成します。

参照 : コンパイル、データ変換、Extensible Markup Language (XML)

メタデータ

ほかのデータを記述するために使用されるデータ。たとえば、データ型はメタデータの一部で、プロパティをさらに記述します。

メッセージ

1. XLANG スケジュールによって送受信されるデータ パケット。

2. BizTalk オーケストレーション デザイナの、XLANG スケジュールのメッセージに対応する、[データ] ページのシェイプ。メッセージ シェイプは一意に名前付けされたフィールドから構成され、各フィールドにはそれぞれのデータ型のデータが含まれています。

メッセージ ポート

ドキュメントにどのようにエンベロープを付け、どのようにセキュリティをかけ、どのように指定した送信先組織またはアプリケーションに送信するかを指示する一連のプロパティ。

参照 : 同報リスト

モニカ

オブジェクトを表す名前。オブジェクトの場所を識別する完全パスまたはアドレスを含むことができます。

参照 : ポート

や

ユーザー定義された規則

ユーザーによって完全に設計、作成、および構成された Microsoft Operations Manager (MOM) の規則。

参照 : 完全構成された規則

要素

情報の名前付きセクションを識別するマークアップ タグのセット。要素のタグはその要素の名前および開始と終了を識別します。

ら

リンク

Microsoft BizTaｌk マッパーで、送信元仕様のフィールドから送信先のフィールドまたは Functoid への単純な値や名前のコピーを指定する操作。

参照 : Functoid

ルーティング ロジック

XLANG スケジュール内で実行する順序を決定する一連の規則。ルーティング ロジックは、BizTalk オーケストレーション デザイナの判断シェイプによって実装されます。

ループバック

現在のステータス データをステータス データの元となるアプリケーションに返すことを可能にする特別なトランスポート サービス。ループバックでは、ステータス データを元のアプリケーションに戻すために、SubmitSync メソッドを使います。

参照 : トランスポート サービス

ループ レコード

インスタンス ドキュメントに 2 回以上発生することがある構造。この構造は内容を保持するフィールドのみで構成される要素レコード、またはネストされた階層構造を持つ構造の場合があります。

レプリケーション

サーバー内でデータをコピーする基礎プロセス。サーバーが複製プロセスを完了すると、そのデータはほかのサーバーと同期化されます。


.topic 5
このチェック ボックスをオンにすると、COM+ アプリケーションが XLANG スケジュール インスタンスを実行できるようになります。

.topic 8
このチェック ボックスをオンにすると、ファイル DSN を使用して、この COM+ アプリケーションのステータス保存データベースを参照します。このチェック ボックスをオフにすると、システムまたはユーザー DSN が使われます。ファイル データ ソース名 (DSN) は、データベース接続に関する情報をファイルに保存します。このファイルは拡張子が .dsn で、既定の設定では $\Program Files\Common Files\ODBC\Data Sources ディレクトリに保存されます。

.topic 3
このフィールドには、この COM+ アプリケーションのステータス保存データベースと通信するために使われる DSN の名前が表示されます。DSN の名前は、常に COM+ アプリケーション名と同じである必要があります。

.topic 2
このボタンをクリックすると、XLANG スケジューラ エンジンをホストする COM+ アプリケーションの ODBC データ ソース名 (DSN) を作成します。 重要: [XLANG スケジューラのプロパティ] ダイアログ ボックスで構成されるデータ ソース名の名前は、COM+ アプリケーション名と同じである必要があります。

.topic 1
このボタンをクリックすると、このコンピュータに定義されたすべてのデータ ソースを管理する ODBC データ ソース アドミニストレータが起動します。

.topic 4
このボタンをクリックすると、XLANG スケジュール インスタンスの永続性をサポートするために必要なテーブルを SQL Server データベースに作成します。

.topic 7
このボタンをクリックすると、すべての実行中の XLANG スケジュール インスタンスをシャットダウンします。実行中のスケジュールのステータスは、ステータス保存データベースに保存されます。

.topic 6
このボタンをクリックすると、XLANG スケジュール インスタンスをホストするすべての実行中の COM+ アプリケーションに対して、スケジュール インスタンスのステータスを復元し、可能であれば実行を継続します。

.topic 0
この項目に対応するヘルプトピックはありません。


オンライン サポート
と情報

* | Microsoft BizTalk Server の Web サイト
* | Microsoft 製品サポート サービスの Web サイト
* | Microsoft COM の Web サイト
* | Microsoft Message Queuing の Web サイト
* | Microsoft SQL Server の Web サイト
* | Microsoft Windows Script Technologies の Web サイト
* | Microsoft XML Developer Center
* | MSDN Online
* | MSDN Library
* | マイクロソフト アクセシビリティ Web サイト


BizTalk Server 2002 ～ Developer Solutions

The BizTalk Server WMI classes are defined in text files by using the Managed Object Format (MOF). Note that each class has a key property qualifier. The key property qualifier tells you that any instance of that class (or any instance of a derived class) can be uniquely identified by the value of the key property qualifier. This is a concept borrowed from database technologies.

To access the functionality provided by WMI you call a set of DCOM interfaces, including IWbemClassObject and IWbemServices. These interfaces make it possible to write management applications that work with classes and instances that are managed by WMI.

In addition, you can access WMI from environments that support Automation objects through scripting objects that wrap the DCOM interfaces. For example, the SWbemObject class wraps the IWbemClassObject interface, and SWbemServices wraps IWbemServices. When using WMI with the BizTalk Server schema classes, you can get complete access to WMI through Microsoft Visual Basic or Visual Basic Scripting Edition (VBScript). Visual Basic projects can access these objects by adding Microsoft WMI Scripting V1.1 Library in the Reference dialog box.

The Component Object Model (COM) API is available directly to C/C++ programmers. You can use the Scripting API to develop script and applications based on Microsoft Visual Basic that you can use to view or control managed objects.

For a description of the interfaces in the WMI COM API, see the article "COM API for WMI," in the WMI SDK on the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp).

For a description of the interfaces in the Scripting API, see the article "Scripting API for WMI," in the WMI SDK on the MSDN Online Library Web site.


著作権情報

このソフトウェアの仕様およびマニュアルに記載されている事柄は、将来予告なしに変更することがあります。特別記載されていない場合、このソフトウェアおよびマニュアルで使用している会社、組織、製品、ドメイン名、電子メール アドレス、ロゴ、人物、場所、出来事などの名称は架空のものです。実在する商品名、団体名、ドメイン名、電子メール アドレス、ロゴ、個人名、場所、出来事などとは一切関係ありません。このソフトウェアおよびマニュアルは、本製品の使用許諾契約書のもとでのみ使用することができます。このソフトウェアおよびマニュアルのいかなる部分も、米国 Microsoft Corporation の書面による許諾を受けることなく、その目的を問わず、どのような形態であっても、複製または譲渡することは禁じられています。ここでいう形態とは、複写や記録など、電子的な、または物理的なすべての手段を含みます。

マイクロソフトは、このマニュアルに記載されている内容に関し、特許、特許申請、商標、著作権、またはその他の無体財産権を有する場合があります。このマニュアルはこれらの特許、商標、著作権、またはその他の無体財産権に関する権利をお客様に許諾するものではありません。

© 1999-2001 Microsoft Corporation.All rights reserved.

Microsoft、Active Directory、ActiveX、BizTalk、FrontPage、JScript、MSDN、MS-DOS、Visio、Visual Basic、Visual C++、Visual C#、Visual InterDev、Visual Studio、Win32、Windows、および Windows NT は、米国 Microsoft Corporation の米国およびその他の国における登録商標または商標です。

Intel は、Intel Corporation の登録商標です。

記載されている会社名、製品名には、各社の商標のものもあります。