MicrosoftBizTalkServer2002-Hilfe - Einführung

BizTalk Server-Bannergrafik

Microsoft BizTalk Server 2002-Hilfe - Einführung

Das Integrieren der internen Anwendungen eines Unternehmens war bislang immer schwierig. Das Integrieren dieser Anwendungen und der Anwendungen externer Kunden und Lieferanten bereitete noch größere Probleme. Mit Microsoft® BizTalk™ Server 2002 können Sie jedoch alle Integrationsprobleme zwischen dem Unternehmen und dem Internet lösen. In der folgenden Abbildung ist ein Beispiel dargestellt, wie Sie Ihr Unternehmen orchestrieren können, angefangen von internen Anwendungen bis hin zu unternehmensübergreifenden Geschäftsprozessen.

BizTalk Server 2002 hilft bei der Orchestrierung Ihres Unternehmens, von internen Anwendungen bis hin zu unternehmensübergreifenden Geschäftsprozessen.

Microsoft BizTalk Server 2002 gehört zur Produktfamilie Microsoft .NET Enterprise Server und vereinigt in einem Produkt die Integration von Unternehmensanwendungen und die Integration von B2B-Anwendungen (Business-to-Business). Unabhängig davon, wie Ihr Unternehmen im Bereich E-Commerce tätig ist, BizTalk Server ist immer bei der gesamten Orchestrierung des Unternehmens nützlich, angefangen von internen Anwendungen bis hin zu unternehmensübergreifenden Geschäftsprozessen.

BizTalk Server hilft bei der Integration

Ihr Interesse an BizTalk zeigt, dass Sie sich bereits mit der Anwendungsintegration beschäftigt haben. Möglicherweise sind Sie dafür verantwortlich, ins System für die Auftragserfüllung Ihres Unternehmens andere interne Anwendungen zu integrieren. Eventuell wurden Sie damit beauftragt, Ihre neuen im Web verwendeten Handelssysteme in Ihre Back-End-Fertigungs- und Vertriebssysteme zu integrieren. Oder es ist Ihre Aufgabe, eine Möglichkeit zu entwickeln, wie das Internet für die Integration Ihrer Geschäftprozesse und der der wichtigsten Lieferanten und Zwischenhändler verwendet werden kann.

Mit der umfassenden Unterstützung für XML-, HTTP-, HTTPS-, SMTP-, SSL-, S/MIME- und x509v3-Zertifikate ist BizTalk Server ein gutes Beispiel für die Anwendung von Technologien nach Internetstandard zur Lösung von Integrationsproblemen.

Über diese Einführung

Diese Einführung ist eine allgemeine Darstellung von BizTalk Server 2002. Sie enthält Abbildungen, Hyperlinks und Definitionen, damit Sie besser verstehen, wie Sie mithilfe von BizTalk Server die spezifischen E-Commerce-Probleme Ihres Unternehmens oder Ihrer Organisation lösen können.

In diesem Abschnitt werden folgende Themen behandelt:

  • Erste Schritte

  • Verwenden der BizTalk Server 2002-Hilfe

Copyright © 1999–2001 Microsoft Corporation.
Alle Rechte vorbehalten.


Erste Schritte

Microsoft® BizTalk™ Server 2002 stellt eine leistungsstarke Entwicklungs- und Ausführungsumgebung bereit, die flexibel verbundene, langlebige Geschäftsprozesse innerhalb des Unternehmen und zwischen Handelspartnern im Internet integriert. BizTalk Server kann Transaktionen verarbeiten, die über einen Zeitraum von Wochen oder Monaten und nicht nur von Minuten oder Sekunden ausgeführt werden.

Zu den BizTalk Server 2002-Features gehören die Funktionen zum Entwerfen und Ausführen vollständiger Geschäftsprozesse in Form von XLANG-Ablaufplänen, zum Integrieren vorhandener Anwendungen, zum Definieren von Dokumentspezifikationen und Spezifikationstransformationen sowie zum Überwachen und Protokollieren von Aktivität zur Laufzeit.

BizTalk Server stellt einen Standardgateway für das Senden und Empfangen von Dokumenten über das Internet bereit. Außerdem bietet BizTalk Server eine Reihe von Diensten zur Sicherstellung von Datenintegrität, -übermittlung und -sicherheit sowie Unterstützung für BizTalk Framework und andere wichtige Dokumentformate, wie XML (Extensible Markup Language), EDI (Electronic Data Interchange) und Flatfiles.

Informationen zu BizTalk Framework 2.0 sowie Informationen zu BizTalk Server-Produktressourcen, wie z. B. Communitydiensten, eine große Schemabibliothek und Whitepaper finden Sie in der Microsoft BizTalk Server-Website (http://www.microsoft.com/biztalk).

Gründe für die Verwendung von BizTalk Server

Mit BizTalk Server können schwierige Probleme leichter gelöst werden. In BizTalk Server werden zwei wichtige Features - Orchestrierung und Messaging - in einem Produkt integriert. Mit dem leistungsfähigen Messagingmodul wird der Transport und die Zuordnung von Nachrichten verarbeitet. BizTalk-Orchestrierungsdienste können Geschäftsprozesse, die sich aus Komponenten zusammensetzen, und Nachrichten orchestrieren, die mithilfe der BizTalk-Messagingdienste gesendet und empfangen werden.

BizTalk Server bietet z. B. folgende Möglichkeiten:

  • Erstellen dynamischer Geschäftsprozesse. Durch die BizTalk Server-Infrastruktur können Sie schnell dynamische Geschäftsprozesse integrieren, verwalten und automatisieren, indem Sie Geschäftsdokumente zwischen Anwendungen, innerhalb von Organisationen oder organisationsübergreifend austauschen. BizTalk Server bietet alle Tools, die für die Orchestrierung von Geschäftsprozessen erforderlich sind. So können Sie Prozesse erstellen, die sich unter Verwendung des Internets über Anwendungen und Unternehmen erstrecken.

  • Integrieren von Anwendungen und Geschäftspartnern. BizTalk Server erleichtert es Entwicklern, Anwendungen und Unternehmen gemeinsam zu integrieren. Unternehmensexperten und Anwendungsentwickler können die grafischen Tools zum Erstellen eines Schemas für Geschäftsdokumente, zum Durchführen von Schematransformationen, zum Herstellen von Beziehungen mit Handelspartnern und zum Überwachen und Analysieren von Daten nutzen. Mit der Unterstützung für XML und standardmäßige Internettechnologien erweitert BizTalk Server die Features herkömmlicher E-Commerce-Anwendungen und von EDI auf ganze E-Commerce-Communities.

  • Sicherstellen von Interoperabilität mithilfe von öffentlichen Standards. Mit der umfassenden Unterstützung für öffentliche Standards und Spezifikationen, wie XML, EDI, HTTP (Hypertext Transfer Protocol) und HTTPS, sowie für Sicherheitsstandards, wie Verschlüsselung öffentlicher Schlüssel und digitale Signaturen, stellt BizTalk Server das höchste Maß an Interoperabilität und Sicherheit für Anwendungen und Geschäftspartner sicher.

In BizTalk Server wird XML verwendet, um die Daten und die Struktur von Geschäftsdokumenten zu definieren. Außerdem werden standardmäßige Internetprotokolle wie HTTP und SMTP (Simple Mail Transfer Protocol) verwendet, um diese Dokumente an deren Ziele zu senden. Auf diese Weise können Sie mit verschiedenen Anwendungen in unterschiedlichen Umgebungen arbeiten, wenn diese Anwendungen Internetstandards unterstützen. Sie können Dokumente an BizTalk Server als XML, EDI oder Flatfiles senden.

Welche Probleme können mit BizTalk Server gelöst werden?

Probleme in Bezug auf die interne und externe Integration.

Über einen Zeitraum von Jahren haben Unternehmen ihre Unternehmensanwendungen bei verschiedenen Lieferanten gekauft. Dies hat dazu geführt, dass eine Vielzahl von Anwendungen auf mehreren Plattformen ausgeführt wurde. Da jede Anwendung eine bestimmte Aufgabe erfüllen musste, z. B. Lagerhaltung oder CRM (Customer Relationship Management), mussten diese Anwendungen selten integriert werden. Wenn sich ein Unternehmen doch dazu entschlossen hatte, die internen Anwendungen zu integrieren, stellte sich dies immer als eine teure und zeitaufwendige Aufgabe heraus.

Bedenken Sie diese häufig genannten Probleme bezüglich der Integration:

  • Unterschiedliche Anwendungen: "Es ist zu schwierig, verschiedene Anwendungen auf dem Computer zu integrieren."

  • Programmieraufwand: "Es dauert zu lange, eine integrierte Lösung für das ERP-System (Enterprise Resource Planning) eines Unternehmens zu entwickeln."

  • Unterschiedliche Berichte: "Es gibt keine Möglichkeit, rechtzeitig integrierte Berichte von den verschiedenen Anwendungen zu generieren, da die Daten an zu vielen Orten gespeichert sind."

  • Schwierigkeiten bei Änderungen: "Wenn die internen Anwendungen einmal integriert sind, wird das Ändern der Anwendungen schwierig und aufwendig."

  • Kein festgelegtes Verfahren: "Im Unternehmen gibt es keine einheitliche Methode für das Implementieren der wichtigen Geschäftsprozesse."

  • Probleme mit Partnern: "Es ist zu schwierig, die Geschäftsprozesse eines Unternehmens und die der Handelspartner zu integrieren."

  • Wechseln von Partnern: "Wenn ein anderes Unternehmen ein besseres Angebot macht, ist es durch die aufwendige IT-Infrastruktur schwierig, dieses Angebot zu nutzen."

In der heutigen Zeit ist mit der Verbreitung des World Wide Web die Nutzung von E-Commerce (Geschäfte über das Internet) verbunden. Das Integrieren interner Anwendungen ist zwar schwierig, aber der Handel mit Kunden und Lieferanten über das Internet ist weit komplizierter. Dies wird im Wesentlichen durch die größeren Probleme im Hinblick auf Sicherheit und Zuverlässigkeit von Onlinetransaktionen verursacht. BizTalk Server soll Ihnen bei der Lösung dieser Probleme helfen. Mithilfe von grafischen Tools, wie dem BizTalk-Orchestrierungs-Designer und BizTalk-Editor, können Sie mit BizTalk Server in einer visuellen Entwurfsumgebung eindeutige Geschäftsprozesse entwerfen. BizTalk Server führt dann das visuelle Diagramm aus und ermöglicht so eine schnelle Anwendungsentwicklung (Rapid Application Development, RAD).

Lernprogramme

Sie können sofort praktische Erfahrungen mit BizTalk Server 2002 sammeln, indem Sie die Lernprogramme in diesem Handbuch durchgehen:

  • Mit Kennenlernen von BizTalk Server 2002 können Sie besser verstehen, wie der BizTalk-Editor, der BizTalk-Mapper, der BizTalk-Messaging-Manager, die BizTalk-Verwaltung und der BizTalk-Orchestrierungs-Designer verwendet werden, um BizTalk Server für die Ausführung eines automatisierten Beschaffungsprozesses auf Business-to-Business-Ebene zu konfigurieren.

  • BizTalk Server 2002-Lernprogramm erläutert Schritt für Schritt, wie BizTalk Server-Prozesse konfiguriert werden.

  • Im Beispiel für die elektronische Beschaffung (E-Procurement) werden BizTalk Server, das Internet und eine Korrelation verwendet, um zu zeigen, wie der Beschaffungsprozess automatisiert werden kann, der zwischen Ihrem Unternehmen und dessen Lieferanten ausgeführt wird.

Beispiele

Zu BizTalk Server 2002 gehören über 20 Beispiele, mit denen ein großer Teil der BizTalk Server-Funktionalität dargestellt wird. Die Beispiel werden im BizTalk Server Software Development Kit (SDK) zur Verfügung gestellt, dass sich im Ordner \Programme\Microsoft BizTalk Server\SDK auf dem Installationslaufwerk befindet.

Die BizTalk Server-Beispiele sind in zwei Kategorien unterteilt:

  • BizTalk Messaging Services Code Samples.

  • BizTalk Orchestration Services Code Samples

In diesem Abschnitt

In diesem Abschnitt werden folgende Themen behandelt:

  • Neuigkeiten in BizTalk Server 2002

  • Für wen ist BizTalk Server gedacht?

  • Funktionsweise von BizTalk Server

  • BizTalk Server-Features

  • BizTalk Server-Anwendungsmodell

  • BizTalk Server-Verwaltungsmodell

Copyright © 1999–2001 Microsoft Corporation.
Alle Rechte vorbehalten.

Fanden Sie diese Informationen hilfreich? Bitte senden Sie Ihre Vorschläge und Anmerkungen zur Dokumentation an BizTalk Server Dokumentationsfeedback@microsoft.com


Neuigkeiten in BizTalkServer2002

BizTalk Server 2002 ~ Erste Schritte

Neuigkeiten in BizTalk Server 2002

Microsoft® BizTalk™ Server 2002 Enterprise Edition enthält die folgenden Verbesserungen:

  • Bereitstellung von BizTalk Server-Objekten in einem Unternehmen. BizTalk Server 2002 verbessert die Bereitstellung in einem Unternehmen mithilfe eines BizTalk Server-Replikationstreibers für Microsoft Application Center 2000. Application Center 2000 erleichtert die Bereitstellung durch automatisches Migrieren und Synchronisieren der BizTalk Server-Objekte in unterschiedlichen Umgebungen. Application Center 2000 ermöglicht zwei Hauptbereitstellungszenarien:
    • Von der Entwicklung über die Vorbereitung zur Produktion

    • Innerhalb einer Produktionsserverfarm
  • Schnelle unternehmensübergreifende Bereitstellung und Testen der öffentlichen Dokumentschnittstellen zu Partnerunternehmen. Mit der Einführung von SEED-Paketen bietet BizTalk Server 2002 nahtlose unternehmensübergreifende Bereitstellungsmöglichkeiten. SEED-Pakete enthalten die Dokumentschemas und andere relevante Informationen, die ein Unternehmen (Initiator) an seine Handelspartner (Empfänger) sendet und von diesen empfängt. SEED-Pakete werden einzeln erstellt und dann für viele Handelspartner bereitgestellt. Die SEED-Pakete werden von einem Handelspartner geöffnet, der die eindeutigen Konfigurationsanforderungen der Organisation eingibt. Die Konfigurationsinformationen werden automatisch erstellt und vor Ort in der Umgebung des Handelspartners und dann erneut auf einem Remoteserver getestet. Nach dem Testen der Konfiguration können die Partner die Konfiguration in die Produktionsumgebung übernehmen. Der SEED-Assistent von BizTalk verringert die Installationszeit des Handelspartners und die vom Initiator des SEED-Pakets zum Testen benötigte Zeit.

  • Detaillierte Überwachung und detailliertes Ereignismanagement. BizTalk Server 2002 enthält neue und verbesserte WMI-Ereignisse (Windows Management Instrumentation) zum Verwalten von Geschäftsprozessen. Zum Lieferumfang von BizTalk Server 2002 gehört ein speziell für BizTalk Server entwickeltes Management Pack für Microsoft Operations Manager (MOM), mit dessen Hilfe Sie von diesem verbesserten Ereignismanagement profitieren können. Mithilfe des Management Packs von BizTalk Server 2002 Enterprise Edition können Sie problemlos vordefinierte Warnungen und Regeln auswählen, um Ihre Anwendungen anzupassen. Dadurch erhalten Sie basierend auf einem Ereignis oder kombinierten Ereignissen genau die Informationen, die sie benötigen. Mithilfe von MOM und der neuen WMI-Klasse benutzerdefinierter BizTalk-Zähler können Sie außerdem angepasste Überwachungsanwendungen erstellen, um mehr über die interne Funktionsweise Ihrer BizTalk Server-Installation zu erfahren.

  • Erhöhter Support für XML-Webdienste. Da Anwendungen von vielen verschiedenen Systemen, darunter auch Webdiensten, erstellt werden, wird das Integrieren von Anwendungen in einen Geschäftsprozess immer wichtiger. Zum Lieferumfang von BizTalk Server 2002 gehört das SOAP Toolkit 2.0 Service Pack 2 (SP2), mit dem Sie Geschäftsprozesse orchestrieren können, die XML-Webdienste umfassen. Das SOAP Toolkit 2.0 SP2 befindet sich im Verzeichnis WebServices auf der Installations-CD von Microsoft BizTalk Server 2002.

  • Remoteverwaltung. Die BizTalk Server-Verwaltungskonsole gehört jetzt zur Toolinstallation. Die Verwaltungskonsole kann auf einem Remotecomputer ohne BizTalk Server installiert werden und auf einen beliebigen Computer mit BizTalk Server in Ihrer Umgebung verweisen, um die Verwaltung zu vereinfachen und flexibler zu gestalten.

  • HTTP-Empfangsfunktion. BizTalk Server enthält nun eine ISAPI-HTTP-Empfangsfunktion mit hoher Leistung, die direkt in der BizTalk Server-Verwaltungskonsole verwaltet und konfiguriert werden kann.

  • Separate Transaktions- und Ausnahmebehandlung im BizTalk-Orchestrierungs-Designer. Mit einer vom BizTalk-Orchestrierungs-Designer bereitgestellten neuen Option können Sie angeben, dass eine Transaktion für die Ausnahmebehandlung verwendet wird. Dies führt zu einer Leistungserhöhung bei gleichzeitiger Minimierung der Lese-/Schreibaktivität der Datenbank.

  • Integrierte SQL-Sicherheit. BizTalk Server 2002 greift mit der integrierten Microsoft Windows®-Sicherheit auf Microsoft SQL Server™ zu. BizTalk Server ermittelt SQL-Rechte also anhand der Anmeldeinformationen eines Windows 2000-Benutzers und nicht anhand der SQL-Anmeldeinformationen.

  • Datenbankverwaltung. Mehrere neue Dienstprogramme und Skripts zur Verwaltung der Überwachungsdatenbank und der XLANG-Persistenzdatenbank stehen zur Verfügung.

  • XLANG-Korrelation. Beim Starten eines Geschäftsprozesses können mehrere Ablaufplaninstanzen nun die gleiche Nachrichtenwarteschlange verwenden. Eingehende Nachrichten in dieser Warteschlange können außerdem zum Fortsetzen des Geschäftsprozesses mit einer bestimmten Instanz korreliert werden. Des Weiteren wurde der Prozess der Korrelation mit einem aktiven Geschäftsprozess vereinfacht.

  • XLANG-Ablaufplanpooling. Sie können jetzt einen Ablaufplanpool angeben. Dabei handelt es sich um die maximale Anzahl an Ablaufplaninstanzen, die zu einem bestimmten Zeitpunkt im Arbeitsspeicher enthalten sein dürfen. Damit erhalten Sie eine gute Kontrolle über die Computerressourcen, was besonders bei Hardwarebeschränkungen hilfreich ist. BizTalk Server 2002 profitiert vom Objektpooling von COM+, um eine maximale Leistung zu erzielen.

  • Verbesserung des BizTalk-Mappers: Der BizTalk-Mapper wurde aktualisiert und enthält nun folgende Features:
    • Gemischter XML-Inhalt wird nun unterstützt.

    • Sie können jetzt Instanztests an systemeigenen Dokumentinstanzen (einschließlich XML und nicht-XML) direkt im BizTalk-Mapper durchführen.

    • Die Rasterzone wurde skaliert, so dass mehrere Seiten zulässig sind.

    • Drag & Drop-Möglichkeiten wurden hinzugefügt.

    • Sie können jetzt Funktoidskripts mit Microsoft JScript® schreiben. Außerdem können Sie nun Funktoidassemblierungen mit Microsoft Visual C#™ .NET und Microsoft Visual Studio® .NET schreiben.
  • Verbesserung des BizTalk-Editors: Der BizTalk-Editor wurde aktualisiert und enthält nun folgende Features:
    • Sie können nun eine systemeigene Dokumentinstanz erstellen.

    • Gemischter XML-Inhalt wird nun unterstützt.

    • Drag & Drop-Möglichkeiten wurden hinzugefügt.

    • Sie können jetzt die Dokumentinstanz anhand einer Spezifikation überprüfen.

    • Das Eingeben von Datensatzdaten wird jetzt unterstützt.

    • Sie können jetzt XSD-Schemas direkt aus dem BizTalk-Editor exportieren.
  • Verbesserte Dokumentation. Die BizTalk Server-Hilfe wurde um über 500 Seiten mit neuen Informationen ergänzt. Dies schließt folgende Informationen ein:
    • Ein neuer Abschnitt Erste Schritte, der u. a. folgende Themen enthält: Für wen ist BizTalk Server gedacht?, Funktionsweise von BizTalk Server und Erstellen einer BizTalk Server-Lösung.

    • Kennenlernen von BizTalk Server 2002, sieben Lektionen, in denen die grundlegenden Konzepte von BizTalk Server erläutert werden. Zudem enthalten sie Informationen, die Ihnen die zum Erstellen von Lösungen mit BizTalk Server notwendigen Tools und Prozesse erklären.

    • Beispiel für die elektronische Beschaffung (E-Procurement), das mithilfe von BizTalk Server 2002, Internet und Korrelation demonstriert, wie der zwischen Ihrem Unternehmen und Ihren Lieferanten stattfindende Beschaffungsprozess automatisiert werden kann.

    • Eine erweiterte BizTalk Server Developer's Toolbox mit allen Informationen, die Programmierer in den Programmiersprachen C++ und Microsoft Visual Basic® zum Verwenden oder Erweitern von BizTalk Server 2002 benötigen.
  • Weitere Beispiele. BizTalk Server 2002 enthält über 20 neue Beispiele, die einen Großteil der neuen Programmfunktionalität darstellen. Diese Beispiele schließen u. a. Folgendes ein:
    • Aktualisieren aller BizTalk-Messagingobjekte, die in WebDAV gespeichert sind. Siehe Refresh Messaging Manager.

    • Überwachen und Protokollieren von XLANG-Ablaufplänen für das Debuggen. Siehe XLANG Trace.

    • Senden von Dokumenten mit einer Größe von über 4 MB an die BizTalk-Orchestrierungsdienste. Siehe Message Queuing 4 MB Limit.

    • Senden von MIME-Anlagen (Multipurpose Internet Mail Extensions), die aus mehreren Teilen bestehen, an die BizTalk-Messagingdienste. Siehe Multi-Part MIME Attachment.

    • Synchrones Senden mehrerer Dokumente und asynchrones Senden von Abfragen an XLANG-Ablaufpläne. Siehe XLANG Submit Synchronously and Query Asynchronously.

    • Senden von automatisch gerouteten Dokumenten. Siehe Self-Routing.

    • Überwachen der Angehalten-Warteschlange. Siehe Suspended Queue Monitoring.

    • Verwenden von Reliable Messaging. Siehe Reliable Messaging.

    • Verwenden von XLANG-Ablaufplanpooling. Siehe XLANG Schedule Pooling.

    • Verwenden von benutzerdefinierten Zählern. Siehe Custom Counters.

    • Verwenden von EDI (Electronic Data Interchange) und EDI-Empfangsbestätigungen. Siehe EDI and Receipts.

    • Verwenden von Flatfiles mit Feldern fester Breite und Flatfiles mit Trennzeichen. Siehe Flat-File Positional und Flat-File Delimited.

    Darüber hinaus wurde BTConfigAssistant, das eine einfache Unterstützung für die in ein Skript eingebundene Bereitstellung von Informationen zur BizTalk Server-Messagingkonfiguration bereitstellt, um die Unterstützung von Empfangsfunktionen erweitert.

  • Verfügbare Geschäftsadapter. Im Paket enthaltene Adapter ermöglichen nun das Verbinden unterschiedlicher Systeme und das Zugreifen auf heterogene Datenspeicher. Wenn Sie den Zugriff auf Ihre Systeme und Daten mithilfe dieser Adapter ermöglichen, reduziert sich der bei der manuellen Implementierung der Verbindung normalerweise anfallende umfangreiche Codierungsaufwand drastisch und ist in vielen Fällen sogar ganz überflüssig. Diese Adapter verbinden BizTalk Server 2002 mit Anwendungen und Daten von Drittanbietern, darunter die folgenden:
    • Datenbanken

    • FTP (File Transfer Protocol)

    • ERP-Anwendungen (Enterprise Resource Planning)

    • CRM-Anwendungen (Customer Relationship Management)

    Eine vollständige Liste der zurzeit von Microsoft und seinen Partnern verfügbaren BizTalk Server-Adaptern finden Sie auf der Seite "BizTalk Server Adapters and Connectivity" in der Microsoft BizTalk Server-Website (www.microsoft.com/biztalk/evaluation/adapters.asp)).


Für wen ist BizTalkServer gedacht?

BizTalk Server 2002 ~ Erste Schritte

Für wen ist BizTalk Server gedacht?

BizTalk Server 2002 löst kritische Integrationsprobleme für unterschiedlichste Organisationen, von kleinen Geschäften, deren Existenz von einer einzelnen Partnerschaft abhängt, bis hin zu großen Produktionsunternehmen, die Hunderte von Partnerschaften eingehen und pro Sekunde Tausende von Dokumenten verarbeiten.

Kleinere Unternehmen verwenden BizTalk Server möglicherweise für Punkt-zu-Punkt-Verbindungen. Für größere Unternehmen ist dies aber weniger effizient. In sehr großen Unternehmen können mehrere BizTalk Server-Gruppen verbunden werden und so einen verteilten Integrationsbus bilden. Diese Organisationen sind normalerweise in autonome, separate Geschäftseinheiten unterteilt, die ihre eigenen Systeme entwickeln und verwalten. Diese Geschäftseinheiten müssen Daten für Anwendungen freigeben, die von anderen Geschäftseinheiten gesteuert werden, und außerdem mit externen Handelspartnern kommunizieren.

Aus der folgenden Abbildung wird ersichtlich, wie Daten in einem Unternehmen gemeinsam verwendet werden können, dessen Integrationsarchitektur das Ergebnis des sich im Lauf der Zeit ergebenden Bedarfs ist. Die rechte Seite zeigt, wie der Datenaustausch mithilfe von BizTalk Server 2002 besser organisiert und effizienter gestaltet werden kann.

BizTalk Server ermöglicht eine nahtlose und effiziente Datenintegration.

Etablierte Unternehmen werden beim Einsatz von BizTalk Server feststellen, dass ihre Legacysysteme effizienter arbeiten und ihre Architektur für B2B-E-Commerce (Business-to-Business) mit neuen Tools ausgestattet werden kann. Ein neu gegründetes Unternehmen kann BizTalk Server von Anfang an als Schlüsselkomponente verwenden, auf deren Basis ein neues System in das Unternehmen integriert wird.

Sehen Sie sich die folgenden Szenarien aus der Geschäftswelt an:

  • Ein Hersteller im Bereich Gesundheitswesen verwendet BizTalk Server für die Interaktion mit einer Reihe von E-Commerce-Plattformen.

  • Ein Privatunternehmen, das B2B-E-Commerce- und Prozessautomatisierungslösungen für den globalen Unternehmenskapitalmarkt entwickelt, verwendet BizTalk Server-Technologien zum Aufbau einer Infrastruktur, die eine nahtlose, kostengünstigere und effizientere Datenintegration ermöglicht.

  • Ein PC-Hersteller verwendet BizTalk Server für die schnelle Übermittlung von Daten und Dokumenten und zur Integration seiner Lieferkettenbeziehungen, um die Lieferkette zu verbessern, die Effizienz zu erhöhen und den Kunden reibungs- und problemlose Erfahrungen zu bieten.

  • Ein Unternehmen des digitalen Marktes verwendet Microsoft Windows 2000, Internet-Informationsdienste (Internet Information Services, IIS) und BizTalk Server für den Aufbau eines Internethubs, der eine zentrale Anlaufstelle für potenzielle Schüler weiterführender Schulen, Berufsberater an Schulen und die Anwerbungs- und Zulassungsabteilungen von Universitäten bereitstellt.

  • Ein Unternehmen, das eine Reihe von Finanz- und Buchhaltungsdiensten speziell für kleine und mittelständische Unternehmen anbietet, erstellt mithilfe von XML und BizTalk Server Webdienste, die auf seiner internen SAP R/3-Anwendungssuite basieren.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Integrieren von BizTalk Server in die IT-Infrastruktur einer Organisation

  • Integrieren von BizTalk Server in die .NET-Plattform


Integrieren von BizTalkServer in die IT-Infrastruktur einer Organisation

BizTalk Server 2002 ~ Erste Schritte

Integrieren von BizTalk Server in die IT-Infrastruktur einer Organisation

Wie sieht die technische Infrastruktur Ihres Unternehmens aus? Baut sie auf einer einzelnen Plattform, wie z. B. Windows oder UNIX, auf? Höchstwahrscheinlich nicht. In den meisten Unternehmen wird eine Mischung aus verschiedenen Systemen ausgeführt. Selbst wenn es eine Standardplattform gibt, werden wahrscheinlich gleichzeitig andere Anwendungen und Entwicklungsumgebungen ausgeführt, die zum Erreichen der Geschäftsziele Ihres Unternehmens dienen.

Ihre aktuelle Konfiguration stellt ein bewährtes System dar, in das bedeutende Zeit- und Kosteninvestitionen geflossen sind. Daher sollten sie Ihr System nicht allein wegen der Lösung eines neuen Geschäftsproblem ersetzen müssen. Legacysysteme werden normalerweise nur dann ersetzt, wenn es dafür einen triftigen Geschäftsgrund gibt.

BizTalk Server stellt einen zentralen, datengesteuerten Integrationsserver und eine Gruppe erweiterter Produktivitätstools und -dienste bereit, mit denen Sie Geschäftsprozesse zum Durchführen der Integration von Unternehmensanwendungen und von B2B-Transaktionen (Business-to-Business) aufbauen und bereitstellen können. Durch die Unterstützung mehrerer Transporte und Protokolle können Sie mit BizTalk Server vorhandene IT-Investitionen XML-fähig machen und in neue E-Commerce-Technologien integrieren.

BizTalk Server verbessert Ihre existierenden IT-Investitionen folgendermaßen mit XML:

  • Durch Bereitstellen des BizTalk-Mappers, einem grafischen Datenzuordnungstool zum Konvertieren von XML-Daten von und in Legacydatenformate mit verschiedenen Strukturen, wie z. B. EDI und Flatfiles.

  • Durch Unterstützung von Transporten und Protokollen, die dem Industriestandard entsprechen, wie z. B. HTTP, HTTPS, SMTP, SSL, S/MIME und SOAP. Auf diese Weise können Ihre existierenden IT-Investitionen in Webanwendungen und -dienste integriert werden.

  • Durch Verwenden von Standardadaptern führender Hersteller für den Zugriff auf Geschäftsanwendungen. Weitere Informationen finden Sie auf der Seite "BizTalk Server Adapters and Connectivity" in der Microsoft BizTalk Server-Website (www.microsoft.com/biztalk/evaluation/adapters.asp).

BizTalk Server hat nur minimale Hardware- und Softwareanforderungen und kann in Ihrer etablierten IT-Infrastruktur installiert werden.

Ausführliche Informationen über die Features von BizTalk Server, wie z. B. die XML-Tools, den BizTalk-Messaging-Manager und den BizTalk-SEED-Assistenten, finden Sie unter BizTalk Server-Features.


Integrieren von BizTalk Server in die .NET-Plattform

Die Microsoft® .NET-Plattform schließt eine umfangreiche .Net-basierte Produktfamilie ein, die anhand von Industrie- und Internetstandards entwickelt wurde und für sämtliche Aspekte der Entwicklung (Tools), Verwaltung (Server), Verwendung (Bausteindienste und Smartclients) und Erfahrung (reichhaltige Benutzererfahrungen) XML-Webdienste bereitstellt.

Die .NET Enterprise Server-Produkte umfassen sowohl E-Commerce als auch die gesamte Unternehmensinfrastruktur. Die Produktfamilie Windows 2000 Server bildet die sichere, skalierbare Grundlage von Microsoft für das Ausführen von .NET Enterprise Server-Produkten und E-Commerce-Geschäftsanwendungen.

Die .NET Enterprise Server-Produkte enthalten Folgendes:

  • Application Center 2000 zum Bereitstellen und Verwalten von skalierbaren Webanwendungen mit hoher Verfügbarkeit.

  • BizTalk Server 2002 zum Entwickeln von anwendungs- und unternehmensübergreifenden XML-basierten Geschäftsprozessen.

  • Commerce Server 2000 zum Entwickeln skalierbarer E-Commerce-Lösungen.

  • Content Management Server 2001 zum Verwalten des Inhalts von dynamischen E-Business-Websites.

  • Exchange 2000 Server für Messaging und Zusammenarbeit.

  • Host Integration Server 2000 zum Überbrücken von Daten und Anwendungen auf Legacysystemen.

  • Internet Security & Acceleration Server 2000 für sichere und schnelle Internetverbindungen.

  • Mobile Information 2001 Server für den Anwendungssupport mit mobilen Geräten, wie z. B. Mobiltelefonen.

  • SharePoint Portal Server 2001 zum Suchen, Freigeben und Veröffentlichen von Geschäftsinformationen.

  • SQL Server 2000 zum Speichern, Abrufen und Analysieren strukturierter XML-Daten.

Microsoft SQL Server verwaltet die Geschäftslogik Ihrer Datenbanken, während Microsoft Commerce Server die Front-End-Kundenschnittstelle verwaltet.

BizTalk Server ist das Back-End, das eine E-Commerce- oder Back-End-Unternehmenslösung antreibt. Nachdem die Einkaufsanwendung, wie z. B. Microsoft Commerce Server, die Produktbestellung für die Kunden vereinfacht hat, wickelt BizTalk Server den früher manuell durchgeführten Einkaufsprozess ab. BizTalk Server "kauft" das Produkt von den Händlern, verwaltet das Austauschen des Auftrags und führt eine interne Integration von Unternehmensanwendungen durch. Nachdem der Kauf bestätigt wurde, werden die Datensätze des Kunden an eine Finanzanwendung weitergegeben, die ein Bestellticket an das Verteilungsprogramm sendet.

Darüber hinaus bieten Microsoft Host Integration Server und Hostsystemadapter Zugriff auf unternehmenswichtige Daten, die auf einem Back-End-Mainframe oder -Minicomputer gespeichert sind. Host Integration Server dient zum Extrahieren von Daten aus einem Mainframe und zum Übertragen dieser Daten an BizTalk Server oder Commerce Server. Durch diese Vorgänge wird die gesamte E-Business-Transformation abgeschlossen, ohne dass die Mainframehardware oder -software konvertiert oder ersetzt wird.

Weitere Informationen zu .NET Enterprise Server-Produkten finden Sie in der Microsoft .NET Enterprise Server-Website (http://www.microsoft.com/germany/server/).

Informationen zu BizTalk Framework 2.0 sowie Informationen zu BizTalk Server-Produktressourcen, wie z. B. Communitydiensten, eine große Schemabibliothek und Whitepaper finden Sie in der Microsoft BizTalk Server-Website (www.microsoft.com/germany/biztalk).

XML-Webdienste

Der bei Unternehmen und Kunden angestiegene Bedarf an E-Commerce-Lösungen hat zur Entwicklung eines neuen Computermodells geführt. Dieses Modell bietet eine Standardmethode für die Entwicklung von Anwendungen und Prozessen, die das Herstellen von Verbindungen und das Austauschen von Informationen über das Web ermöglichen. Die neue, als XML-Webdienste bezeichnete internetbasierte Integrationsmethode ermöglicht eine bisher unerreichte Zusammenarbeit zwischen Anwendungen, Computern und Unternehmen.

Die folgende Abbildung zeigt, wie XML-Webdienste in verschiedenen Kombinationen neue Benutzererfahrungen begünstigen können.

XML-Webdienste ermöglichen die Zusammenarbeit von Anwendungen, Computern und Unternehmen.

Mithilfe von XML-basierten Technologien erstellen Entwickler eine neue Art von Software, die XML zum Bereitstellen webbasierter Dienste verwendet. Zu diesen Technologien gehören beispielsweise SOAP, das die Zusammenarbeit von Anwendungen mit Standardinternetprotokollen ermöglicht, und UDDI (Universal Description, Discovery and Integration), das Unternehmen eine Standardmethode zum Beschreiben ihrer Dienste und zum Herstellen automatischer Verbindungen bietet. (Weitere Informationen zu UDDI finden Sie unter www.uddi.org). XML-Webdienste sind flexible Technologien, die unterschiedliche Systeme sprachenübergreifend verbinden und so Personal Computing, Enterprise Computing und das Web vereinheitlichen. Diese XML-Webdienste können ähnlich wie Komponentensoftware programmiert und wiederverwendet werden; zudem ist im Gegensatz zur Komponentensoftware der Zugriff auf diese Dienste im gesamten Internet möglich. Programme, die dieses Modell verwenden, können webseitenübergreifend ausgeführt werden und dabei Informationen und Dienste von jeder Webseite nutzen, die sie dann in benutzerdefinierter Form kombinieren und bereitstellen.

Mit der Microsoft .NET-Plattform können Sie XML-Webdienste erstellen, bereitstellen, betreiben und integrieren. Die folgende Liste enthält die vier Grundsätze für die XML-Webdienste:

  1. Systeme müssen eine Verbindung über das Internet herstellen. Dies ist eine leicht zu erfüllende Bedingung, da das Internet bereits kostengünstige Verbindungen bei hoher Verfügbarkeit bereitstellt.

  2. Eine einfache Methode zum Suchen nach Diensten im Internet, mit denen Unternehmen arbeiten können, ist unabdingbar. UDDI ist eine weit reichende Bemühung der Industrie, an der mehrere führende Unternehmen teilnehmen. UDDI bietet eine Möglichkeit zum Finden und Verstehen von Diensten, die von anderen Unternehmen bereitgestellt werden.

  3. Um sicherzustellen, dass Informationen mit anderen gemeinsam genutzt werden können, ist eine gemeinsame Sprache erforderlich. XML erfüllt diese Forderung. XML bietet ein gebräuchliches Datenformat, so dass Sie mit Daten und Informationen weiterhin auf gewohnte Art arbeiten können. Ihre Geschäftspartner und Kunden müssen also weder eine bestimmte Programmiersprache oder Anwendung noch ein bestimmtes Betriebssystem verwenden, um mit Ihren Systemen interagieren zu können.

  4. Es muss eine Möglichkeit für das tatsächliche Betreiben von Geschäften geben. Beispielsweise muss es eine Methode geben, um über ein gemeinsames Protokoll einen Dienst anzurufen, einen Termin auszumachen, ein Ersatzteil zu bestellen oder Informationen zu übertragen. Dieses Protokoll heißt SOAP, und es ermöglicht Systemen, miteinander zu kommunizieren und Anforderungen zu stellen. SOAP ist das neue Modell für die systemeigene Integration im Internet.

Diese vier Grundsätze ermöglichen das Herstellen von Verbindungen zwischen Systemen, Anwendungen und Prozessen und das Ausführen von Such-, Transformations- und Transaktionsvorgängen, um XML-Webdienste bereitzustellen.

Mithilfe der in Tools wie z. B. BizTalk-Mapper, BizTalk-Editor und BizTalk-Orchestrierungs-Designer integrierten grafischen Benutzeroberfläche stellt BizTalk Server eine Hauptkomponente beim Entwerfen anwendungs- und unternehmensübergreifender XML-basierter Geschäftsprozesse dar. Weitere Informationen zu XML-Webdiensten und zur Microsoft .NET-Plattform finden sie unter http://www.microsoft.com/germany/themen/net/


Funktionsweise von BizTalkServer

BizTalk Server 2002 ~ Erste Schritte

Funktionsweise von BizTalk Server

Microsoft BizTalk Server 2002 besteht aus zwei Hauptdiensten: den BizTalk-Messagingdiensten, über die Sie Nachrichten zwischen Geschäftsprozessen senden, und den BizTalk-Orchestrierungsdiensten, mit denen Sie Geschäftsprozesse erstellen.

Die Schwierigkeiten der Integration

Es steht außer Frage, dass das Integrieren von Anwendungen in einer Organisation bisher sehr mühsam war. Sicher mussten auch Sie schon den folgenden Herausforderungen entgegentreten: unterschiedliche Anwendungen unter verschiedenen Betriebssystemen, die in verschiedenen Sprachen geschrieben wurden und auf unterschiedlichen Programmierungsmodellen basieren. Unsere Aufgabe ist es, die Kommunikation zwischen all diesen Elementen zu ermöglichen.

In der Welt des E-Commerce sind Integrationsaufgaben allerdings wesentlich komplizierter. Sie müssen nicht nur Ihre internen Systeme, sondern auch deren Prozesse mit den Prozessen externer Kunden und wichtiger Lieferanten integrieren. Dafür sind offene Technologien wie z. B XML-Webdienste, HTTP oder SMTP für die Übermittlung und XML für die Datenformatierung erforderlich. Und erschwerend kommt noch hinzu, dass all diese Vorgänge über das Internet erfolgen müssen.

Unternehmen, die wettbewerbsfähig bleiben möchten, müssen die interne und externe Integration von vornherein richtig durchführen. In der Vergangenheit wurden die Unterschiede zwischen der internen und externen Integration als verschiedene Gruppen von Punkt-zu-Punkt-Verbindungen angesehen. Verbindungen sind allerdings nur ein Mittel zum Zweck. Das tatsächliche Ziel ist die Integration von Geschäftsprozessen.

Normalerweise verwenden Unternehmen intern proprietäre Datenformate, und bisher hat ein Großteil von ihnen einen synchronen RPC-Mechanismus (Remoteprozeduraufruf) verwendet. Wenn Sie aber immer mehr interne Anwendungen integrieren, treten beim synchronen Modell Probleme in Bezug auf die Zuverlässigkeit und Verfügbarkeit auf. Um dieses Problem zu vermeiden, setzen Unternehmen heutzutage immer häufiger ein asynchrones Modell ein, das jedoch synchron erscheint und als "sync zu async" bezeichnet wird.

Wo fangen Sie also am besten an? Die Integration von Geschäftsprozessen ist eine große Herausforderung, und in vielen Fällen erweist sich schon allein die Bemühung, eine ordnungsgemäße Funktionsweise der Verbindungen sicherzustellen, als Vollzeitbeschäftigung. Letztendlich ist es Ihre Aufgabe, die richtigen Informationen zum richtigen Zeitpunkt an der richtigen Stelle zur Verfügung zu stellen.

Und dabei kann Sie BizTalk Server unterstützen.

BizTalk Server ermöglicht die Integration von Geschäftsprozessen

Mit BizTalk Server können Geschäftsanalysten, IT-Spezialisten und Entwickler in einer gemeinsamen Umgebung arbeiten, in der sie integrierte Lösungen, die mit verschiedenen Anwendungen, Plattformen und Organisationen arbeiten, schnell definieren, entwickeln und bereitstellen können.

BizTalk Server erleichtert das Orchestrieren dynamischer Geschäftsprozesse in Organisationen und organisationsübergreifend.

Im Einzelnen ermöglicht BizTalk Server Folgendes:

  • Vereinfachen der Anwendungsintegration. Erstellen, verwalten und überwachen Sie problemlos verteilte Geschäftsprozesse, die die Grenzen von Anwendungen, Organisationen und der Zeit überschreiten.

  • Verkürzen der Markteinführungszeit. Erstellen Sie rasch zuverlässige, sichere B2B-Handelsbeziehungen (Business-to-Business) mit Kunden und wichtigen Partnern über das Internet.

  • Nutzen vorhandener IT-Investitionen. Integrieren Sie unterschiedliche Legacyanwendungen kostengünstig mithilfe von plattformunabhängigen Standards.

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-Messagingdienste

  • BizTalk-Orchestrierungsdienste

  • Erstellen einer BizTalk Server-Lösung

  • Verwaltbarkeit, Zuverlässigkeit, Flexibilität

  • BizTalk Server Accelerator


BizTalk-Messagingdienste

BizTalk-Messagingdienste kommen bei folgenden Aufgaben zum Einsatz:

  • Empfangen eingehender Dokumente.

  • Analysieren der Dokumente zum Ermitteln ihres speziellen Formats.

  • Extrahieren der Schlüsselbezeichner und Identifizieren bestimmter Routingregeln.

  • Übermitteln von Dokumenten an die vorgesehenen Ziele.

  • Überwachen von Dokumenten.

Ferner enthalten sie Dienste für die Datenzuordnung, die Erstellung und Korrelation von Empfangsbestätigungen und für den Schutz von Datenintegrität und -sicherheit.

Informationen zum Zugreifen auf die von den BizTalk-Messagingdienste verwendeten Codebeispiele finden Sie unter BizTalk Messaging Services Code Samples.

Methoden für die Messagingkonfiguration

BizTalk Server stellt für den Austausch von Dokumenten zwischen Handelspartnern und Anwendungen innerhalb eines Unternehmens zwei Konfigurationsmethoden für die BizTalk-Messagingdienste bereit. Dabei handelt es sich um folgenden Methoden:

  • Den BizTalk-Messaging-Manager, eine grafische Benutzeroberfläche mit einem Messaging-Assistenten.

  • Das BizTalk-Messaging-Konfigurationsobjektmodell, auf das Sie direkt zugreifen können.

Mithilfe des BizTalk-Messaging-Managers oder des BizTalk-Messaging-Konfigurationsobjektmodells können Sie Messagingports und Kanäle zum Verwalten des Datenaustauschs erstellen. Sie ermöglichen zudem das Erstellen von Dokumentdefinitionen, Umschlägen und Organisationen, die zum Erstellen von Messagingports und Kanälen verwendet werden, sowie das Erstellen von Verteilerlisten, bei denen es sich um Gruppen von Messagingports handelt.

Konfigurieren des Messagingdienstes

Die folgende Abbildung zeigt die Schritte, die Sie beim Erstellen einer Dokumentspezifikation und beim Konfigurieren des Messagingdienstes durchführen müssen.

Vorgehensweise beim Konfigurieren des Messagingdienstes

Sie verwenden zunächst den BizTalk-Editor für die grafische Erstellung einer Dokumentspezifikation. Bei dieser Spezifikation handelt es sich um eine XML-Datei (Extensible Markup Language), die die Struktur, den Typ und die Version des Dokuments definiert. Wenn Ihr Handelspartner das Dokument in einem anderen Format benötigt, können Sie die Dokumentdaten mit dem BizTalk-Mapper einem Format zuordnen, das Ihr Partner verwenden kann.

Um den Messagingdienst zu konfigurieren, müssen Sie eine Dokumentdefinition einrichten, die auf die von Ihnen erstellte Spezifikation verweist. Dazu greifen Sie entweder grafisch über den BizTalk-Messaging-Manager oder direkt über die Schnittstelle für Anwendungsprogrammierung (Application Programming Interface, API) auf das BizTalk-Messaging-Konfigurationsobjektmodell zu. Von der Idee her sind eine XML-Spezifikation und eine BizTalk-Dokumentdefinition identisch. Aus technischer Sicht bestehen zwischen ihnen aber große Unterschiede in Bezug auf ihre Erstellung und Speicherung. Spezifikationen sind Dokumente, die vom BizTalk-Editor erstellt und als XML-Dateien im WebDAV-Repository gespeichert werden. Dokumentdefinitionen sind hingegen Objekte, die vom BizTalk-Messaging-Konfigurationsobjektmodell (entweder mit dem BizTalk-Messaging-Manager oder der API) erstellt und in der BizTalk-Messaging-Verwaltungsdatenbank, einer von BizTalk Server verwendeten SQL Server-Datenbank, gespeichert werden. Sie können sich eine BizTalk Server-Dokumentdefinition als eine XML-Spezifikation vorstellen, die in eine Objektform konvertiert wurde.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Empfangsfunktionen

  • Transportdienste

  • Datenparser

  • Datenüberprüfung

  • Reliable Messaging

  • Sicherheit

Verwandte Themen

BizTalk Messaging Services Code Samples.

Introducing Messaging Services

Verwenden des BizTalk-Messaging-Managers


Empfangsfunktionen

BizTalk Server 2002 stellt Empfangsfunktionen bereit, durch die der Server die Dokumente überwachen kann, die an die angegebenen Zielorte gesendet werden. BizTalk Server unterstützt die folgenden Empfangsfunktionen, die mithilfe der BizTalk Server-Verwaltung konfiguriert werden:

  • Datei

  • HTTP

  • Message Queuing

BizTalk Server 2002 unterstützt ferner die folgenden eingehenden Protokolle, die mithilfe von ASP-Seiten oder eines Microsoft Exchange-Skripts konfiguriert werden:

  • Hypertext Transfer Protocol (HTTP) mithilfe einer ASP-Seite

  • Secure Hypertext Transfer Protocol (HTTPS) mithilfe einer ASP-Seite

  • Simple Mail Transfer Protocol (SMTP) mithilfe eines Microsoft Exchange-Skripts

  • File Transfer Protocol (FTP) mithilfe des IIS-FTP-Dienstes (Internet Information Services, Internet-Informationsdienste) und einer Dateiempfangsfunktion

Verwandte Themen

Datenparser

Datenüberprüfung

Empfangsfunktionen

Reliable Messaging

Sicherheit

Transportdienste


Transportdienste

BizTalk Server 2002 stellt Transportdienste bereit, mit denen Dokumente an ihr Ziel übertragen werden. BizTalk Server unterstützt die folgenden Transportdienste:

  • Hypertext Transfer Protocol (HTTP)

  • Secure Hypertext Transfer Protocol (HTTPS)

  • Simple Mail Transfer Protocol (SMTP)

  • Datei

  • Message Queuing

  • Anwendungsintegrationskomponenten (Application Integration Components, AICs)

  • Loopback

Verwandte Themen

Datenparser

Datenüberprüfung

Empfangsfunktionen

Reliable Messaging

Sicherheit

Transportdienste

Copyright © 1999–2001 Microsoft Corporation.
Alle Rechte vorbehalten.

Fanden Sie diese Informationen hilfreich? Bitte senden Sie Ihre Vorschläge und Anmerkungen zur Dokumentation an BizTalk Server Dokumentationsfeedback@microsoft.com


Datenparser

BizTalk Server 2002 unterstützt Datenparser für eine Vielzahl von Dokumentstandards, wie beispielsweise ANSI X12, UN/EDIFACT und gültige wohlgeformte XML. Darüber hinaus können Sie auch eigene benutzerdefinierte Parserkomponenten entwickeln, registrieren und verwenden.

BizTalk Server unterstützt zudem BizTalk Framework 2.0. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk Server-Website (www.microsoft.com/germany/biztalk/).

Verwandte Themen

Datenüberprüfung

Empfangsfunktionen

Reliable Messaging

Horizontales Skalieren der BizTalk-Messagingdienste

Sicherheit

Transportdienste


Datenüberprüfung

BizTalk Server 2002 stellt eine Datenüberprüfung bereit, bei der jede Instanz eines Dokuments mit einer Spezifikation verglichen wird. Wenn das Dokument nicht den Regeln der Spezifikation entspricht, wird es zur weiteren Überprüfung oder Fehlerkorrektur in der Angehalten-Warteschlange abgelegt.

Verwandte Themen

Datenparser

Empfangsfunktionen

Reliable Messaging

Sicherheit

Transportdienste


Reliable Messaging

BizTalk Server 2002 stellt Reliable Messaging mithilfe konfigurierbarer Eigenschaften der BizTalk-Messagingdienste bereit. Zu den Eigenschaften zählen das Festlegen der Dienstfenster für das Senden von Dokumenten, das Senden und Empfangen von Empfangsbestätigungen, das Festlegen der Anzahl von Wiederholungen und das Festlegen des Zeitraumes zwischen Wiederholungen. BizTalk Server unterstützt die Verwendung BizTalk Framework-kompatibler Umschläge, die zuverlässige Messagingfunktionen ermöglichen. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website (www.microsoft.com/germany/biztalk/). BizTalk Server legt ferner Dokumente in Warteschlangen an einem zentralen Speicherort ab. Bei einem Serverausfall können mithilfe von Rollovermechanismen neue Server aktiviert werden, die die Steuerung über die Dokumente übernehmen und diese verarbeiten.

Verwandte Themen

Datenparser

Datenüberprüfung

Empfangsfunktionen

Sicherheit

Transportdienste


Sicherheit

Microsoft BizTalk Server 2002 ermöglicht Unternehmen einen sicheren Datenaustausch mit Handelspartnern. BizTalk Server verwendet dabei die folgenden Sicherheitsfunktionen von Microsoft Windows 2000:

  • Windows Sicherheitsrichtlinien für Konten und lokale Richtlinien

  • Integrierte Windows- und Microsoft SQL Server™-Anmeldesicherheit

  • Sicherheit und Rollen der Komponentendienste von Microsoft

  • Infrastruktur öffentlicher Schlüssel (Public-Key Infrastructure, PKI)

  • CryptoAPI

  • Smartcards

  • Kerberos-Protokoll

BizTalk Server 2002 unterstützt die auf Zertifikaten basierende S/MIME-Verschlüsselung (Secure Multipurpose Internet Mail Extensions) mit öffentlichen Schlüsseln und digitalen Signaturen für alle Dokumente, die mit Transportdiensten von BizTalk Server 2002 übertragen werden. BizTalk Server unterstützt darüber hinaus die Entschlüsselung und Signaturüberprüfung für empfangene Dokumente.

Verwandte Themen

Datenparser

Datenüberprüfung

Empfangsfunktionen

Reliable Messaging

Transportdienste

Grundlegendes zur Sicherheit


BizTalk-Orchestrierungsdienste

Bevor Sie sich Gedanken zu den BizTalk-Orchestrierungsdiensten machen, denken Sie zunächst über das Wort "orchestrieren" nach. Denken Sie dabei an Musik? Der Dirigent eines Orchesters arbeitet mit Dutzenden von Musikern und führt sie geschickt zu einem harmonischen Zusammenspiel zusammen. Ohne den Dirigenten sind die einzelnen Musiker verloren. Sie haben doch sicher schon einmal vor einer Aufführung gehört, wie 40 verschiedene Musiker ihre Instrumente stimmen. Es ist die reinste Disharmonie. Sobald aber der Dirigent die Leitung übernimmt, entsteht durch die Orchestrierung ein harmonisches Zusammenspiel dieser 40 Instrumente.

Genauso wirkt sich BizTalk Server auf Ihre Geschäftsprozessen aus.

Ein Geschäftsprozess bestimmt die logische Reihenfolge der Aktionen

Die Integration von Geschäftsprozessen entwickelt sich oft aus dem Verständnis der externen Schnittstellen, die jedes System offen legt, und der zum Übertragen von Nachrichten verwendeten Nachrichtenformate und Spezifikationen. Normalerweise müssen auch Aspekte der Dienstqualität, wie z. B. Sicherheit, Nachrichtencodierung und Reliable Messaging, behandelt werden. Das Adressieren, Senden und Empfangen von Nachrichten ist allerdings für die Bereitstellung einer kompletten Lösung zur Integration von Geschäftsprozessen nicht ausreichend.

Wie wird die Originalnachricht erstellt? Wie erfolgt das Empfangen, Verarbeiten und Antworten auf Nachrichten? Hierbei handelt es sich, von den einfachsten Fällen abgesehen, um Geschäftsprozesse. Ein Geschäftsprozess bestimmt die logische Reihenfolge von Aktionen und den zugehörigen Nachrichtenfluss und definiert zudem das Nachrichtenaustauschprotokoll zwischen den verteilten Teilnehmern.

Heutzutage werden die meisten Geschäftsprozesse (und vielleicht auch Ihre) mit benutzerdefiniertem Code erstellt. Aus diesem Grund können Unternehmen den in der heutigen schnelllebigen Umgebung notwendigen Änderungen der Geschäftsprozessimplementierungen, die infolge einer Weiterentwicklung der Geschäftsanforderungen anfallen, häufig nicht nachkommen. Die BizTalk-Orchestrierungsdienste lösen dieses Problem, denn sie machen den Codierungsaspekt beim Erstellen von Geschäftsprozessen überflüssig. Das Ergebnis ist eine Umgebung, die schnell verändert werden kann.

Mit BizTalk Server können Sie Ihre Geschäftsprozesse orchestrieren

Die BizTalk-Orchestrierungsdienste stellen einen neuen Ansatz für das Entwerfen, Bereitstellen und Verwalten von verteilten Geschäftsprozessen dar. Sie dienen zum Entwerfen von Geschäftsprozessen, die die Geschäftslogik insgesamt verwalten. Mit BizTalk Server können Sie Ihre Geschäftsprozesse orchestrieren, indem Sie ein Laufzeitmodul mit dem Entwurfszeittool BizTalk-Orchestrierungs-Designer kombinieren. Mit dem BizTalk-Orchestrierungs-Designer koordinieren Sie alle B2B-Orchestrierungen visuell auf dem Bildschirm in einer grafischen Microsoft® Visio®-Benutzeroberfläche. BizTalk Server speichert dann Ihren Workflow in einer als XLANG-Ablaufplan bezeichneten ausführbaren Datei, mit deren Hilfe ein Laufzeitmodul Ihre Geschäftsprozesse ausführt. Sie schreiben keinen Code, um die Geschäftsprozesse aneinander zu binden. Die Codierung liegt in den individuellen Komponenten einer speziellen Geschäftslogik und nicht in der Implementierung, die sie zusammenhält.

Die BizTalk-Orchestrierungsdienste ermöglichen die Integration lang andauernder Geschäftsprozesse in die Anwendungen, die diese Geschäftsprozesse ausführen. Die Integration wird vom XLANG-Ablaufplan bereitgestellt. Weitere Dienste ermöglichen die Ausführungssteuerung von XLANG-Ablaufplaninstanzen.

Eine Schlüsselfunktion der BizTalk-Orchestrierungsdienste ist die Möglichkeit, komplexe Transaktionen zu verarbeiten, die nicht nur Minuten oder Stunden, sondern Wochen oder Monate dauern. Mit den BizTalk-Orchestrierungsdiensten kann zudem die Implementierung paralleler Aktionen innerhalb eines einzelnen XLANG-Ablaufplanes ausgeführt werden. Darüber hinaus müssen Sie keinen benutzerdefinierten Code schreiben, um den Status des Geschäftsprozesses zu verwalten. Die BizTalk-Orchestrierungsdienste übernehmen diese Aufgabe für Sie.

Informationen zum Zugreifen auf von den BizTalk-Orchestrierungsdiensten verwendeten Codebeispielen finden Sie unter BizTalk Orchestration Services Code Samples.

Folgende Themen werden in diesem Abschnitt behandelt:

  • XLANG-Ablaufpläne

  • Implementierungstechnologien

  • XLANG-Sprache

Verwandte Themen

BizTalk Orchestration Services Code Samples

Entwerfen von BizTalk-Orchestrierungen


XLANG-Ablaufpläne

Ein XLANG-Ablaufplan ist ein Geschäftsprozess, der durch das Verbinden jedes Prozessschrittes mit einer Technologiekomponente oder einem Dienst implementiert wird, die bzw. der diesen Schritt ausführt. Ein XLANG-Ablaufplan wird anschließend von einem XLANG-Ablaufplanungsmodul genannten Dienst ausgeführt. Dieses Modul steuert die Instanziierung, Ausführung, Pausierung und Aktivierung eines XLANG-Ablaufplanes oder mehrerer Instanzen eines oder mehrerer Ablaufpläne.

Verwandte Themen

Implementierungstechnologien

XLANG-Sprache

XLANG-Ablaufpläne

Copyright © 1999–2001 Microsoft Corporation.
Alle Rechte vorbehalten.

Fanden Sie diese Informationen hilfreich? Bitte senden Sie Ihre Vorschläge und Anmerkungen zur Dokumentation an BizTalk Server Dokumentationsfeedback@microsoft.com


Implementierungstechnologien

Die BizTalk-Orchestrierungsdienste unterstützen folgende Implementierungstechnologien:

  • BizTalk-Messagingdienste

  • COM-Komponenten

  • Message Queuing-Dienste

  • Windows-Skriptkomponenten

  • Microsoft .NET-basierte Komponenten mithilfe der COM-Interoperabilität (Component Object Model)

Verwandte Themen

Implementieren von Geschäftsprozessen

XLANG-Ablaufpläne

XLANG-Sprache


Die Sprache XLANG

XLANG ist eine Sprache, die die logische Abfolge von Geschäftsprozessen sowie die Implementierung von Geschäftsprozessen mithilfe von verschiedenen Technologiekomponenten und Diensten beschreibt. Sie wird in XML (Extensible Markup Language) ausgedrückt.

Verwandte Themen

Implementierungstechnologien

XLANG-Ablaufpläne

XLANG Interfaces


Erstellen einer BizTalkServer-Lösung

BizTalk Server 2002 ~ Erste Schritte

Erstellen einer BizTalk Server-Lösung

Vor dem Erstellen Ihrer BizTalk Server-Lösung müssen Sie die zu verwendenden Methoden planen. Sie müssen also im Vorfeld das genaue Verhalten einer Lösung ermitteln, um sicherzustellen, dass die relevanten Ergebnisse erzielt werden.

Sie könnten sich z. B. folgende Planungsfragen stellen:

  • Müssen Sie Dokumente bereitstellen oder empfangen, oder müssen Sie Dokumente bereitstellen und empfangen?

  • Welche Dokumente müssen übertragen werden?

  • Wohin müssen sie übertragen werden?

  • Zu welchem Zeitpunkt müssen sie am Zielort ankommen?

  • Welches Dokumentformat soll verwendet werden?

  • Mit welchen Protokollen werden die Dokumente übertragen?

  • Gibt es Legacysysteme, die an das neue Integrationssystem angepasst werden müssen?

  • Welche Arten von Dateien benötigen diese Legacysysteme?

Die auf diesen und anderen Fragen basierenden Entscheidungen werden traditionell in der Entwurfsphase eines Projekts gefällt und dann über mehrere Wochen oder Monate von einem Programmierteam implementiert. Mit BizTalk Server können Sie Geschäftsprozesse schnell visuell im BizTalk-Orchestrierungs-Designer erstellen.

Ein gängiges Szenario zum Integrieren von zwei Diensten ist die Korrelation von Nachrichten in einer einzelnen aktiven XLANG-Ablaufplaninstanz. In diesem Fall sendet eine XLANG-Ablaufplaninstanz eine Nachricht an eine interne Anwendung oder einen Handelspartner, von denen eine Antwortnachricht erwartet wird. Ein Beispiel hierfür ist das Senden eines Auftrags und das Erwarten der Auftragsbestätigung.

Bei der Verwendung der in BizTalk Server bereitgestellten XML-Tools könnte der Entwicklungsprozess wie in der folgenden Tabelle ablaufen.

Entwicklungsaufgabe | Traditionelle Methode | BizTalk Server-Methode
Diagramm des Geschäftsprozesses | Skizzieren des Geschäftsprozesses auf Papier oder einem Whiteboard oder Verwenden eines CASE-Tools. | Kombinieren von geometrischen Formen und Verbindungen mithilfe des BizTalk-Orchestrierungs-Designers zu einer XLANG-Ablaufplanzeichnung.
Implementieren des Geschäftsprozesses | Manuelles Schreiben des Codes, der der gewünschten Geschäftslogik entspricht. | Anbinden der XLANG-Ablaufplankomponenten, um aussagekräftigen ausführbaren Code auf die Zeichnung anzuwenden.
Entwerfen der Struktur Ihrer Dokumente | Festlegen der Struktur der Dokumente, Vermitteln dieser Informationen an die Programmierungsabteilung, die dann eine Sprache auswählt und manuell den Code passend zur Dokumentstruktur schreibt. | Erstellen der Dokumentspezifikationen mithilfe des BizTalk-Editors.
Synchronisieren Ihrer Daten mit den Daten Ihres Geschäftspartners | Manuelles Schreiben des Codes, der Datenformate liest und in die Dokumentstruktur schreibt. | Visuelles Zuordnen Ihres Datenformats zum Datenformat Ihres Partners mithilfe von BizTalk-Mapper.
Konfigurieren der Kommunikation zwischen Ihrem Unternehmen und Ihrem Geschäftspartner | Manuelles Schreiben des Codes, der Dokumente und Nachrichten sendet und empfängt. Bei Bedarf Schreiben von Code zum Ausführen von Message Queuing und Konfiguration. | Erstellen von Kanälen und Ports mithilfe des BizTalk-Messaging-Managers.
Bereitstellen der Lösung | Manuelles Konfigurieren des Systems für den Empfang neuer Dokumente von Handelspartnern. Anschließend müssen Ihre Handelspartner Code schreiben, um ihre Systeme für die Zusammenarbeit mit Ihren Systemen zu konfigurieren und bereitzustellen. | Bereitstellung in Ihrem Unternehmen mithilfe von Microsoft Application Center. Anschließendes Verpacken Ihrer Konfiguration mithilfe des BizTalk-SEED-Assistenten und Bereitstellen bei einem Handelspartner.
Überwachung Ihrer Dokumente | Manuelles Schreiben von Code, der Dokumente überwacht, Leistungsstatistiken erstellt und Berichte über Ihren angepassten Code erzeugt. | Überwachen von Warnbenachrichtigungen, Erstellen von Leistungsstatistiken und Überwachen von Datenbanken mithilfe von Microsoft Operations Manager (MOM) und der Überwachungsdatenbank.

RAD für Geschäftsprozesse

Die Idee für RAD (Rapid Application Development) ergab sich aus der Notwendigkeit, Softwarelösungen schnell zu entwickeln und bereitzustellen, um die Relevanz der Lösung zum Zeitpunkt ihrer Implementierung sicherzustellen. Bei einer effizienten Implementierung verkürzt der RAD-Ansatz nicht nur die Entwicklungszeit, sondern senkt auch die Produktionskosten.

BizTalk Server führt die RAD-Konzepte bei der unternehmensübergreifenden Entwicklung von Geschäftsprozessen durch die Bereitstellung von leistungsfähigen XML-Tools ein, wie z. B. BizTalk-Orchestrierungs-Designer, BizTalk-Editor und BizTalk-Mapper.

Mit BizTalk Server können Sie langfristige Investitionen in die Infrastruktur wahren und gleichzeitig die Anforderungen für kurzfristige, aber entscheidende Erfolge erfüllen.

Folgende Themen werden in diesem Abschnitt behandelt:

Integration von Unternehmensanwendungen

Business-to-Business-Integration

Automatisierung von Geschäftsprozessen


Integration von Unternehmensanwendungen

Jede Anwendung stellt ein bewährtes, effizientes System in einer Organisation dar. Unternehmen verlassen sich heutzutage auf Anwendungen, die geschäftsentscheidende Funktionen übernehmen, wie z. B. das Bestellen von Bedarfsmaterial, das Planen der Herstellung und das Erfüllen von Kundenbestellungen. Die Integration von Unternehmensanwendungen ermöglicht es separaten Anwendungen, Daten elektronisch freizugeben.

Aus der Sicht von Messaging setzen die Technologien zur Integration von Unternehmensanwendungen eine Methode zum Integrieren von Anwendungen ein, die zu 1:n- und n:1-Messagingbeziehungen führt. In diesen Modellen müssen Anwendungen einander nicht erkennen. Daten können erst an BizTalk Server und dann an die relevanten Anwendungen weitergeleitet werden. Dieser Ansatz konzentriert sich auf das Integrieren von Anwendungen in die Datenverteilungsinfrastruktur der Geschäftsdomäne, statt Anwendungen direkt miteinander zu integrieren. Im Modell zur Integration von Unternehmensanwendungen können Anwendungen zum Datenstrom des Geschäftsnetzwerkes hinzugefügt werden und am Geschäftsprozessablauf teilnehmen, ohne dass eng verbundene Abhängigkeiten zwischen Systemen entstehen.

BizTalk Server kann aufgrund seiner Unterstützung offener Standards (z. B. XML) und Legacydateiformaten (z. B. Flatfiles mit Feldern fester Breite und Flatfiles mit Trennzeichen) in andere Anwendungen integriert werden. In vielen Fällen stehen im Voraus erstellte Adapter zur Verfügung, die die Integration unterschiedlicher Systeme erleichtern. Ein Adapter setzt sich aus einer Gruppe von APIs zusammen, die Transaktionen zwischen BizTalk Server und anderen angegebenen Anwendungen mithilfe des BizTalk-Messagingmoduls erleichtern. BizTalk Server bietet zurzeit Adapter für mehrere Geschäftsanwendungen, und weitere befinden sich in der Entwicklung. Einfach ausgedrückt bedeutet dies, dass Adapter aufwändige Routinearbeiten für Sie erledigen. Statt Ihre Zeit mit dem Schreiben von Low-Level-Code für die Integration von Unternehmensanwendungen zu verbringen, können Sie sich jetzt auf das Verfeinern Ihrer eigenen speziellen Geschäftsprozesse konzentrieren. Eine vollständige Liste der zurzeit verfügbaren BizTalk Server-Adapter finden Sie auf der Seite "BizTalk Server Adapters and Connectivity" in der Microsoft BizTalk Server-Website (www.microsoft.com/biztalk/evaluation/adapters.asp).

Verwandte Themen

Business-to-Business-Integration

Automatisierung von Geschäftsprozessen


Business-to-Business-Integration

Die allgemeine Verbreitung des Internets in den 90er Jahren zog die Entstehung von Business-to-Business-Prozessen (B2B) nach sich, die Unternehmen den Datenaustausch mit wichtigen Handelspartnern oder Kunden ermöglichen. Wenn Sie Ihre Geschäftsprozesse in die eines Partners integrieren möchten, benötigen Sie natürlich ein kompatibles Dokumentformat für den Datenaustausch.

BizTalk Server transformiert Daten und leitet sie in Form von XML-basierten Nachrichten auch organisationsübergreifend weiter, selbst wenn die betreffenden Unternehmen unterschiedliche Software- und Hardwareplattformen verwenden.

B2B ist aber kein Ersatz für die Integration von Unternehmensanwendungen. Diese beiden Ansätze ergänzen sich vielmehr. An fast jeder Transaktion zwischen Unternehmen sind zwei Transaktionen zur Integration von Unternehmensanwendungen beteiligt: eine zum Abrufen des Dokuments und die andere zum Transportieren des Dokuments zu einem anderen Computer. Angenommen Sie müssen einen Auftrag von Ihrem Back-End-System über das Internet zum Back-End-System Ihres Geschäftspartners transportieren. B2B kann zwar den unternehmensübergreifenden Transport übernehmen, aber Sie benötigen weiterhin Implementierungen für die Integration von Unternehmensanwendungen, um den Auftrag zwischen Ihrem Back-End-System und Ihrem Front-End-Server zu verschieben.

BizTalk Server unterstützt Sie beim Orchestrieren des gesamten Prozesses.

Verwandte Themen

Automatisierung von Geschäftsprozessen

Integration von Unternehmensanwendungen


Automatisierung von Geschäftsprozessen

Die Automatisierung von Geschäftsprozessen bietet eine ganzheitliche Ansicht des gesamten Entwicklungsprozesses. Dies ist wichtig, denn dieser Vorgang bietet eine einheitliche Ansicht des gesamten Prozesses. Bisher wurde stattdessen eine Gruppe ungleicher Komponenten bereitgestelllt, deren Interaktion in der Vergangenheit nur auf Papier definiert werden konnte. In der Welt des E-Commerce ist ein Prozess nicht mehr auf ein einzelnes Unternehmen beschränkt, sondern maximiert seine Effizienz häufig, indem er sich über mehrere Organisationen und Systeme erstreckt. Die Automatisierung von Geschäftsprozessen bettet das geistige Eigentum eines Projekts in die Software ein, so dass Sie einen vorhandenen Geschäftsprozess schnell verstehen und bei Bedarf ändern können.

Verwandte Themen

Business-to-Business-Integration

Integration von Unternehmensanwendungen


Verwaltbarkeit, Zuverlässigkeit, Flexibilität

BizTalk Server stellt Tools zum Definieren und Verwalten von Geschäftsprozessen zur Verfügung, die vom Produkt verwaltet werden. Zudem nutzt die Anwendung die von der Windows 2000-Plattform gebotenen Verwaltungsfunktionen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwaltbarkeit

  • Zuverlässigkeit

  • Flexibilität


Verwaltbarkeit

BizTalk Server stellt den BizTalk-Messaging-Manager zum Definieren von verteilten Geschäftsprozessen und zum Verwalten aller Anwendungsbeziehungen bereit. Diese Anwendungsbeziehungen umfassen interne sowie Beziehungen mit externen Handelspartnern.

Weitere Funktionen von BizTalk Server:

  • Bereitstellung eines MMC-Snap-Ins (Microsoft Management Console) zur Überwachung von kritischen Diensten und Warteschlangen, auf die sich das Produkt verlässt.

  • Ein WMI-Provider (Windows Management Instrumentation) für den Low-Level-Zugriff auf Ereignisinformationen, der dann die entsprechenden Einträge im Windows-Ereignisprotokoll erstellt.

  • Offenlegung von Schlüsselattributen als Leistungsindikatoren, damit mit der Windows 2000-Umgebung vertraute Mitarbeiter die Aktivität auf dem Server überwachen und verwalten können.

  • Bereitstellung einer webbasierten Schnittstelle zum Abfragen des Datenüberwachungs- und Datenanalyse-Subsystems. Dadurch können Daten, die die aus dem Produktdurchlauf resultierende Geschäftsaktivität darstellen, gesucht und darauf zugegriffen werden.

Sie können die Aktivität von BizTalk Server außerdem mit Microsoft Operations Manager 2000 (MOM) und Microsoft Application Center 2000 überwachen.

Microsoft Operations Manager

Microsoft Operations Manager 2002 (MOM) ist ein Tool für die Ereignisauflistung, Leistungsüberwachung und Berichterstellung für Serverbetriebssysteme und serverbasierte Anwendungen von Microsoft. MOM übernimmt die zentrale Überwachung, Verwaltung und Sicherung vielfältiger Ressourcen und verbessert die Verfügbarkeit, Leistung und Sicherheit von Windows 2000-Netzwerken und -Anwendungen durch die Bereitstellung einer proaktiven Systemüberwachung in Echtzeit.

MOM stellt die folgenden Features bereit:

  • Ereignisgesteuertes Überwachen von Operationen

  • Automatisch bereitgestellte, skalierbare Lösungen

  • Erweiterte Funktionen zur Überwachung und Durchsetzung von Sicherheitsrichtlinien

  • Verbesserte Systemverfügbarkeit und Leistungsüberwachung

  • Zahlreiche Methoden zum Anzeigen und Ausgeben von Daten in Berichtform

Microsoft Application Center 2000

Mit Microsoft Application Center können Sie eine BizTalk Server-Konfiguration aus einer Umgebung in einer anderen Umgebung bereitstellen, d. h., Sie können beispielsweise eine Konfiguration von einer Testumgebung in eine Produktionsumgebung verschieben. Wenn Sie die Bereitstellung mit Application Center durchführen, sparen Sie Zeit beim Verschieben von Konfigurationen und außerdem fallen weniger manuelle Eingriffe als üblich an.

Verwandte Themen

Informationen zu Microsoft Operations Manager (MOM)

Flexibilität

Zuverlässigkeit

Verwenden von Application Center 2000

Verwenden von Application Center für die Bereitstellung der elektronischen Beschaffung


Zuverlässigkeit

BizTalk Server 2002 wurde für den Umgang mit den anspruchsvollsten Verarbeitungsanforderungen konzipiert. Im Einzelnen bedeutet dies, dass BizTalk Server mit dem Konzept einer gemeinsam genutzten Warteschlange arbeitet, wobei Server die anfallenden Aufgaben zur Verarbeitung aus einer zentralen Warteschlange abrufen. Sämtliche zu verarbeitende Aufgaben werden an eine einzelne Warteschlange übertragen, die sich technisch gesehen in Microsoft SQL Server befindet, und auf die ein oder mehrere Verarbeitungsserver zugreifen. (Diese Warteschlange kann sich als Cluster auf einem Back-End befinden, um Fehlertoleranz zu ermöglichen.)

Wenn eine stärkere Skalierbarkeit erforderlich ist, können Sie Server zum Verarbeitungsarray hinzufügen. Wenn BizTalk Server installiert ist, können Sie die Anwendung in einer Servergruppe aufnehmen, indem Sie sie auf die gemeinsam genutzte Warteschlange verweisen. Damit ist ein sehr stark skalierbares Szenario mit dezentralisierter Skalierung möglich, in dem kleinere Verarbeitungslasten von lediglich einem oder zwei Servern verarbeitet werden. Sie können in diesem Fall aber fünf, zehn oder sogar noch mehr Server zum Array hinzufügen, um Skalierungsanforderungen nachzukommen, bei denen täglich Millionen von Dokumenten verarbeitet werden müssen. Um auf einem Server oder auf mehreren zusammenarbeitenden Servern eine höhere zentrale Skalierung zu ermöglichen, unterstützt Windows 2000 Datacenter Server die Verwendung von BizTalk Server auf Systemen mit maximal 8 CPUs.

Integrierte Redundanz

Es besteht ein wichtiger Unterschied zwischen Redundanzservern, die keine Daten auf ihren lokalen Festplatten persistent speichern, und Servern, die Daten persistent speichern. BizTalk Server stellt bereits Redundanz und Skalierbarkeit bereit, denn alle Server in einer Gruppe können über das Netzwerk auf einen einzelnen BizTalk Server-Datenbankserver zugreifen. Fällt einer der Server in der Gruppe aus, übernehmen die anderen seine Arbeit und greifen weiterhin auf den Datenbankserver zu. Dies ist möglich, weil keiner der Server in der Gruppe Arbeitsdaten persistent auf seinen Festplatten speichert. Fällt allerdings der Remote-Datenbankserver aus, kann keiner der Server in der Gruppe weiterarbeiten. Verwenden Sie die Microsoft Clusterdienste, um eine Verfügbarkeit des zentralen Datenbankservers rund um die Uhr sicherzustellen, auch wenn ein einzelner Server ausfällt.

Die Entscheidung für die Verwendung der Clusterdienste hängt von zwei Faktoren ab:

  • Von der Ausfallzeit, die Ihr Unternehmen beim Ausfall eines Servers tolerieren kann, der wichtige Daten auf einer lokalen Festplatte persistent speichert.

  • Von dem Budget, das Ihnen für zusätzliche Hardware und Software zum Bereitstellen einer akzeptablen Redundanz zur Verfügung steht.

Für eine einfache Redundanz sind mindestens zwei Server erforderlich.

Verwandte Themen

Verwaltbarkeit

Flexibilität


Flexibilität

BizTalk Server ist ein Beispiel für das Anwenden von dem Internetstandard entsprechenden Technologien zum Erfüllen Ihrer Integrationsanforderungen. BizTalk Server unterstützt folgende Technologien:

  • XML (Extensible Markup Language)

  • Hypertext Transfer Protocol (HTTP)

  • Secure Hypertext Transfer Protocol (HTTPS)

  • Simple Mail Transfer Protocol (SMTP)

  • Secure Sockets Layer (SSL)

  • Secure Multipurpose Internet Mail Extensions (S/MIME)

  • SOAP

  • x509v3-Zertifikate

Eine Erweiterung von BizTalk Server ist mithilfe von Plug-In-Komponenten und Software Development Kits (SDK) möglich. Darüber hinaus stellt die Unterstützung von XML-basierten Schlüsselstandards im gesamten Produkt die Integration mit Anwendungen auf anderen Systemen unabhängig vom Betriebssystem, Programmierungsmodell oder der Programmierungssprache bereit.

Accelerator und Adapter

BizTalk Server unterstützt XML- und viele Nicht-XML-Datenformate, wie z. B. EDI (Electronic Data Interchange) und Flatfiles. Mithilfe von benutzerdefinierten Serialisierungskomponenten und Parsern, die Sie im Rahmen von Industrievorgaben beziehen oder mit dem BizTalk Server Developer's Toolbox erstellen können, kann BizTalk Server beliebige Datei- und Umschlagformate unterstützen. Weitere Informationen finden Sie unter BizTalk Server Accelerator.

BizTalk Server unterstützt mehrere im Voraus erstellte Adapter von Drittanbietern, die die Integration unterschiedlicher Systeme erleichtern. Ein Adapter setzt sich aus einer Gruppe von APIs zusammen, die Transaktionen zwischen BizTalk Server und anderen angegebenen Anwendungen mithilfe des BizTalk-Messagingmoduls erleichtern. Eine vollständige Liste der zurzeit verfügbaren BizTalk Server-Adapter finden Sie auf der Seite "BizTalk Server Adapters and Connectivity" in der Microsoft BizTalk Server-Website (www.microsoft.com/biztalk/evaluation/adapters.asp).

Transportprotokolle, Funktoide und Architektur

BizTalk Server enthält eine systemeigene Unterstützung vieler führender Transportprotokolle, wie z. B. DCOM, Message Queuing, HTTP, HTTPS, SMTP und FTP. Darüber hinaus unterstützt BizTalk Server die MQSeries- und SNA-Protokolle mithilfe des Host Integration Server 2000-Plug-Ins und des MQSeries-Adapters.

BizTalk Server ermöglicht die Transformation von Dokumenten mithilfe von Konvertierungsfunktionen, die als Funktoide bezeichnet werden. Funktoide können erstellt und wieder verwendet werden. Im BizTalk-Mapper wird eine umfassende Gruppe von Funktoiden bereitgestellt. Außerdem können Sie mithilfe der BizTalk Server Developer's Toolbox benutzerdefinierte Funktoide erstellen.

Die BizTalk Server-Architektur ermöglicht das Verwenden einer geeigneten Kombination aus Datenbank-, Empfangs- und Verarbeitungsservern für die Abwicklung der Verarbeitungsanforderungen.

XML und XML-bezogene Technologien

BizTalk Server unterstützt XML zur Bereitstellung der offenen Integration in Anwendungen auf verschiedenen Plattformen.

Weitere Funktionen von BizTalk Server:

  • Verwendung von XML als internes Standardformat.

  • Verwendung des XML-Dokumentobjektmodells zum Zugreifen auf Dokumente im Arbeitsspeicher.

  • Unterstützung von XPath zum Zugreifen auf XML-Dokumentknoten.

  • Verwendung von Extensible Stylesheet Language Transformation (XSLT) als Standard für das Konvertieren von Dokumentformaten.

  • Unterstützung von XML-Namespaces für semantische Genauigkeit.

  • Verwendung von XML-Schematechnologien (mithilfe von XML-Data Reduced (XDR), einer funktionellen Untergruppe des XML-Schemas) für das Eingeben von Daten, Namespaceunterstützung und ein erweiterbares Modell.

Verwandte Themen

Verwaltbarkeit

Zuverlässigkeit


BizTalkServer Accelerator

BizTalk Server 2002 ~ Erste Schritte

BizTalk Server Accelerator

Microsoft bietet Accelerator, die die Entwicklung und Leistung von BizTalk Server 2002-Installationen innerhalb bestimmter Märkte und Industrien deutlich steigern können.

Microsoft bietet zurzeit BizTalk Server Accelerator für folgende Bereiche an:

  • Krankenversicherungsstandards: BizTalk Accelerator for HIPAA

  • Mehrere Supply-Channel: BizTalk Accelerator for Suppliers

  • Supply-Chain-Standards: BizTalk Server Accelerator for RosettaNet


BizTalk Accelerator for HIPAA

Microsoft BizTalk Accelerator for HIPAA rationalisiert die Entwicklung und Bereitstellung von Integrationslösungen für den Datenaustausch, die mit den US-amerikanischen Bestimmungen für Transaktionsstandards des Gesetzes Health Insurance Portability and Accountability Act of 1996 (HIPAA) konform sind. HIPAA wurde hauptsächlich zur Verbesserung der Portabilität und Kontinuität der Krankenversicherungsdeckung für Einzelpersonen und Gruppen in den USA erlassen. HIPAA schreibt vor, dass sich Krankenversicherungen bei der elektronischen Übertragung von Informationen an die HIPAA-Richtlinien halten müssen. HIPAA soll eine Senkung der durch Krankheiten verursachten Kosten ohne Auswirkungen auf die Versicherer bewirken. Heutzutage gibt es bereits allein für eine der HIPPA-Transaktionen, den Anspruch auf medizinische Versorgung, über 400 unterschiedliche Übertragungsformate mit unterschiedlichem Inhalt. Nach der Einführung von HIPAA (derzeit für den 16. Oktober 2002 geplant) gibt es einen Inhaltssatz und ein Format, die von allen Zahlern akzeptiert werden müssen.

Microsoft bietet zusammen mit Washington Publishing Company (WPC), dem Domänenexperten und Exklusivverlag der HIPAA-Implementierungshandbücher (www.wpc-edi.com/hipaa), BizTalk Accelerator for HIPAA an. Dieser Accelerator unterstützt die Krankenversicherungsindustrie beim Entwickeln von auf Standards basierenden Technologielösungen und beim Einsparen von Zeit und Kosten, die Organisationen für die Einhaltung der HIPAA-Bestimmungen aufbringen müssen. Krankenversicherungen und Partnerorganisationen, die von HIPAA betroffen sind, können die Integrationsfunktionen von BizTalk Server 2002 zusammen mit den von WPC bereitgestellten HIPAA-Ressourcen einsetzen, um Geschäftsprozesse zu automatisieren und rasch Integrationslösungen zu entwickeln. Damit halten sie sich an das Bundesgesetz und können gleichzeitig vorhandene IT-Investitionen nutzen. Die Interoperabilität von BizTalk Server 2002 mit den Legacysystemen von Krankenversicherungen und Partnerorganisationen stellt zusammen mit den BizTalk-HIPAA-Schemas Tools für die Industrie bereit, die die HIPAA-Vorschriften erfüllen.

Weitere Informationen über BizTalk Accelerator for HIPAA finden Sie in der Microsoft für Partner-Website (www.microsoft.com/Partner/products/serverproducts/biztalkserver2000/btshipaafinal.asp).


BizTalk Accelerator for Suppliers

Microsoft BizTalk Accelerator for Suppliers stellt eine erweiterbare Softwarelösung bereit, die Lieferanten einen effektiveren Verkauf über mehrere Onlinekanäle ermöglicht. Der Accelerator basiert auf einer erweiterbaren Architektur und versetzt Organisationen somit in die Lage, eine Verbindung zu ihren B2B-Handelspartnern sowie zu internen Geschäftsbereichsanwendungen (Line-of-Business Applications, LOB) herzustellen. Zu den internen Geschäftsbereichsanwendungen können beispielsweise ERP- (Enterprise Resource Planning), Supply Chain Management- oder CRM-System (Customer Relationship Management) gehören. Im Voraus erstellte Webseiten erleichtern es den Lieferanten, einmalige Weberlebnisse für Kunden zu erstellen und dabei gleichzeitig von Remoteshoppingstandards zu profitieren.

BizTalk Accelerator for Suppliers bietet Folgendes:

  • Erhöhte Erträge und Unternehmensflexibilität. Mit BizTalk Accelerator for Suppliers kann ein Unternehmen seine Erträge steigern, seine Beziehungen zu vorhandenen Kunden stärken und dabei gleichzeitig die Handelskosten senken, die sich aus nicht elektronischen Prozessen ergeben. Firmen werden außerdem flexibler, denn sie erhalten eine effiziente Methode für das Erschließen neuer Märkte und das rechtzeitige Reagieren auf Marktveränderungen. Darüber hinaus können Unternehmen mit neuen Vertriebskanälen und -funktionen interagieren, die auf verschiedenen im Accelerator bereitgestellten Technologien, Protokollen, Datenformaten und Geschäftsprozessen basieren.

  • Eine Gelegenheit, sich von der Konkurrenz abzuheben. Mit BizTalk Accelerator for Suppliers erhalten Unternehmen Gelegenheit, den vollen Wertbeitrag und den Markennamen des Lieferanten in einem elektronischen Medium offen zu legen. Unternehmen können Kosten senken, die Akquirierung von neuen Kunden beschleunigen und dabei gleichzeitig die Geschäftstätigkeit mit dem existierenden Kundenstamm ausweiten.

  • Kostensenkung und die Möglichkeit zur Nutzung vorhandener Investitionen. Zudem Verbesserung und Ergänzung von vorhandenen Geschäftsprozessen und Technologieinvestitionen, wie z. B. ERP, Supply-Chain, CRM, Logistik und Zusammenarbeit.

Weitere Informationen zu BizTalk Accelerator for Suppliers finden Sie in der Microsoft Evaluierungswebsite (www.microsoft.com/germany/ms/net-Server/biztalkserver/suppliers/default.asp).


BizTalk Server Accelerator for RosettaNet

Microsoft BizTalk Server Accelerator for RosettaNet enthält mehrere Anwendungen, mit denen Benutzer PIP-Implementierungen (Partner Interface Process) für XLANG-Ablaufpläne entwickeln, verwalten und testen können, die den RosettaNet-Standards entsprechen. Für das Schemamanagement und die Messagingkonfiguration werden zwei zusätzliche Anwendungen bereitgestellt. Diese Lösung bietet die notwendigen Anwendungsadapter und die Serverplattform für die Entwicklung von RosettaNet-basierten Lösungen, mit denen Anwendungen integriert, Handelspartner in Versorgungsketten eingebunden und die Orchestrierung komplexer, kollaborativer Geschäftsprozesse ermöglicht werden.

Die in BizTalk Server Accelerator for RosettaNet enthaltenen Anwendungen ermöglichen Benutzern zusammen mit BizTalk Server 2002 die Rationalisierung von Versorgungskettenverfahren und die Zusammenarbeit mit Handelspartnern und Lieferanten mithilfe des RosettaNet-Standards. Im Folgenden finden Sie eine Liste der Anwendungen von BizTalk Server Accelerator for RosettaNet:

  • PIP Administrator Diese Anwendung enthält sämtliche Kennwortinformationen für die Datenbank und ermöglicht es Benutzern, den Speicherort der XLANG-Ablaufpläne anzugeben.

  • PIP XLANG Schedule Tester Mithilfe dieser Anwendung können Benutzer XLANG-Ablaufpläne testen.

  • PIP Schema Manager Diese Anwendung dient zum Zusammenführen von Dokumentspezifikationen.

  • Messaging Configuration Wizard Mit dieser Anwendung können Benutzer Organisationen als Handelspartner einrichten. Sie generiert Konfigurationsskripts, die BizTalk-Messagingkonfigurationsobjekte programmgesteuert aufrufen, um die notwendigen Ports und Kanäle zu erstellen und zu konfigurieren.

Weitere Informationen zu BizTalk Server Accelerator for RosettaNet finden Sie in der Microsoft für Partner-Website (www.microsoft.com/germany/ms/net-server/biztalkserver/accelerator/default.htm).


BizTalkServer-Features

BizTalk Server 2002 ~ Erste Schritte

BizTalk Server-Features

Die folgende Tabelle zeigt die BizTalk Server-Features und deren Verwendung.

Feature Funktion
Verwaltung
  • Verwalten von Servern und Anwendungen

  • BizTalk Orchestration Services
  • Erstellen und Verwalten von Servern und Servergruppen

  • Konfigurieren globaler Servergruppeneigenschaften, wie z. B. den Speicherort der Datenbank für gemeinsam genutzte Warteschlangen und der Überwachungsdatenbank

  • Konfigurieren von Servereinstellungen

  • Konfigurieren und Verwalten von Empfangsfunktionen

  • Anzeigen und Verwalten von Dokumentwarteschlangen

  • Programmgesteuertes Zugreifen auf den System-Manager der XLANG-Ablaufplanung (XLANG Scheduler), XLANG-Gruppen-Manager, XLANG-Ablaufplaninstanzen und XLANG-Ports
Dokumentüberwachung
  • Überwachen von Dokumenten
  • Überwachen des Status von Dokumenten, die von Microsoft BizTalk Server 2002 verarbeitet werden

  • Suchen, Anzeigen und Speichern vollständiger Kopien von Austauschvorgängen und Dokumenten, die von BizTalk Server 2002 verarbeitet werden

  • Erstellen von Abfragen zum Extrahieren wesentlicher Informationen aus der Überwachungsdatenbank in einem überschaubaren Format

  • Extrahieren, Speichern und Analysieren wichtiger benutzerdefinierter Daten in Dokumenten
Orchestrierungsentwurf
  • Entwerfen von BizTalk-Orchestrierungen
  • Erstellen von Zeichnungen zur Abbildung von Geschäftsprozessen und deren programmgesteuerten Implementierung innerhalb einer integrierten Entwurfsumgebung

  • Kompilieren von XLANG-Ablaufplanzeichnungen in XLANG-Ablaufpläne

  • Definieren des Datenflusses zwischen Nachrichten innerhalb von Geschäftsprozessen
Messaging
  • Verwenden des BizTalk-Messaging-Managers

  • Understanding Messaging Services
  • Lokale oder Remoteverwaltung des Datenaustauschs mithilfe des BizTalk-Messaging-Managers

  • Programmgesteuertes Verwalten des Datenaustauschs mithilfe des BizTalk-Messaging-Konfigurationsobjektmodells

  • Erstellen und Verwalten von Kanälen, Messagingports, Dokumentdefinitionen, Umschlägen, Organisationen und Verteilerlisten
XML-Tools
  • Verwenden des BizTalk-Editors

  • Verwenden des BizTalk-Mappers
  • Erstellen und Verwalten von Dokumentspezifikationen

  • Erstellen von Datensätzen und Feldern und Festlegen der entsprechenden Eigenschaften

  • Zuordnen von Datensätzen und Feldern in einer Quellspezifikation zu Datensätzen und Feldern in einer Zielspezifikation

  • Verwenden von Funktoiden zum Implementieren leistungsstarker Datentransformationsfunktionen
Bereitstellung
  • BizTalk-SEED-Assistent
  • Rasche Aktivierung Ihrer Handelspartner mithilfe von SEED-Paketen, um Ihre Konfigurationen im Internet zur Verfügung zu stellen


BizTalk Server-Anwendungsmodell

Microsoft BizTalk Server 2002 bietet Tools und Dienste, mit denen Sie ausführbare Anwendungen zum Steuern von Geschäftsprozessen und zum Austauschen von Daten zwischen Handelspartnern und Anwendungen innerhalb eines Unternehmens erstellen können. Eine Liste der von BizTalk Server 2002 bereitgestellten Features finden Sie unter BizTalk Server-Features.

Das Integrieren der BizTalk-Orchestrierungsdienste und der BizTalk-Messagingdienste ermöglicht den Austausch von Dokumenten und Nachrichten zwischen Ihren Handelspartnern und internen Anwendungen mithilfe mehrerer Transportdienste. Das BizTalk Server-Anwendungsmodell stellt außerdem Folgendes bereit:

  • Steuerung komplexer, langlebiger Transaktionen und Geschäftsprozesse.

  • Zuverlässige Übermittlung von Dokumenten und Nachrichten.

  • Datenüberprüfung durch Abgleichen jeder Dokumentinstanz mit einer Spezifikation.

  • Datenzuordnung mithilfe von Zuordnungen zum Transformieren der Dokumentstruktur und des Dokumentformats.

  • Datensicherheit und -integrität mithilfe von Verschlüsselung und digitaler Signaturzertifikate.

  • Generierung von Empfangsbestätigungen und Korrelationsunterstützung.

Weitere Informationen zum Konfigurieren von BizTalk Server für das Senden und Empfangen von Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Detaillierte Informationen zum Integrieren der BizTalk-Orchestrierungsdienste und der BizTalk-Messagingdienste finden Sie unter Integrieren der BizTalk-Dienste.


BizTalkServer-Verwaltungsmodell

BizTalk Server 2002 ~ Erste Schritte

BizTalk Server-Verwaltungsmodell

Die folgende Tabelle stellt die vier Hauptverwaltungsbereiche von Microsoft BizTalk Server 2002 sowie die jeweiligen Verwaltungsfunktionen in den einzelnen Bereichen vor.

Verwaltungsbereich Verwaltungsfunktionen
Serververwaltung
  • Konfigurieren und Verwalten von Servergruppen und Servern

  • Konfigurieren und Verwalten von Empfangsfunktionen

  • Verwalten von Warteschlangen
Anwendungsverwaltung
  • Konfigurieren und Verwalten von COM+-Anwendungen, die als Host für XLANG-Ablaufpläne dienen

  • Konfigurieren und Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)
Programmgesteuerte Verwaltung
  • Konfigurieren von XLANG-System-Managern, XLANG-Gruppen-Managern, XLANG-Ablaufplaninstanzen und XLANG-
Datenbankverwaltung
  • Konfigurieren, Verwaltung und Pflegen der folgenden Datenbanken:
    • BizTalk-Messaging-Verwaltungsdatenbank

    • Persistenzdatenbank für die Orchestrierung

    • Überwachungsdatenbank

    • Datenbank für gemeinsam genutzte Warteschlangen

Serververwaltung

Die Serververwaltung in BizTalk Server 2002 umfasst Aufgaben wie das Verwalten und Konfigurieren von Servergruppen, das Hinzufügen, Löschen und Konfigurieren von Servern, das Hinzufügen und Konfigurieren von Empfangsfunktionen sowie das Verwalten der gemeinsam genutzten Warteschlangen von Servergruppen. Die folgende Tabelle stellt die allgemeinen Serververwaltungsaufgaben samt einer Beschreibung vor und gibt Quellen für weitere Informationen an.

Verwaltungsaufgabe Beschreibung Informationsquellen
Konfigurieren von Servern und Servergruppen
  • Konfigurieren der Verbindungen zwischen der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen

  • Konfigurieren der Transportdienste und Parserreihenfolge

  • Konfigurieren von Servereinstellungen
  • Hinzufügen, Löschen und Konfigurieren einer Servergruppe

  • Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe
Verwalten von Warteschlangen
  • Löschen und erneutes Senden von Austauschvorgängen und Dokumenten

  • Anzeigen von Daten und Fehlermeldungen
  • Verwalten von Warteschlangen
Verwalten von Empfangsfunktionen
  • Konfigurieren von Empfangsfunktionen
  • Verwalten von Empfangsfunktionen für eine Servergruppe
Problembehandlung
  • Behandeln von Server- und Dokumentverarbeitungsproblemen
  • Verwalten der Ereignisanzeige

  • Problembehandlung - BizTalk Server-Verwaltung

Anwendungsverwaltung

Die Anwendungsverwaltung umfasst das Konfigurieren und Verwalten der COM+-Anwendungen, die als Host für XLANG-Ablaufpläne dienen, der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und der Persistenzdatenbank für die Orchestrierung, die bei der Installation von BizTalk Server 2002 installiert wird. Die folgende Tabelle stellt die allgemeinen Anwendungsverwaltungsaufgaben samt einer Beschreibung vor und gibt Quellen für weitere Informationen an.

Verwaltungsaufgabe Beschreibung Informationsquellen
Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)
  • Ändern der Konfigurationseinstellungen der Anwendung XLANG-Ablaufplanung (XLANG Scheduler)
  • Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und -Datenbank
Verwalten von COM+-Anwendungen
  • Erstellen von COM+-Anwendungen, die bestimmte XLANG-Ablaufpläne ausführen
  • Verwalten von weiteren COM+-Hostanwendungen für XLANG-Ablaufpläne

Programmgesteuerte Verwaltung

Die Verwaltung von Servern und Anwendungen kann in Microsoft BizTalk Server 2002 programmgesteuert erfolgen. Die folgende Tabelle stellt die allgemeinen programmgesteuerten Verwaltungsaufgaben samt einer Beschreibung vor und gibt Quellen für weitere Informationen an.

Verwaltungsaufgabe Beschreibung Informationsquellen
Konfigurieren und Verwalten von System-Managern für die XLANG-Ablaufplanung (XLANG Scheduler), XLANG-Gruppen-Managern, XLANG-Ablaufplaninstanzen und XLANG-Ports
  • Starten und Beenden des System-Managers für die XLANG-Ablaufplanung (XLANG Scheduler) und von Gruppen-Managern sowie Abrufen zugehöriger Informationen

  • Beenden, Unterbrechen, Wiederaufnehmen der Ablaufpläne, die einer Gruppe zugeordnet sind, sowie das Abrufen zugehöriger Informationen
  • BizTalk Orchestration Services
Erstellen von Anwendungsintegrationskomponenten
  • Erstellen von benutzerdefinierten Komponenten

  • Integrieren von LOB-Anwendung (Line-of-Business)

  • Hinzufügen von Verschlüsselung, Entschlüsselung und digitalen Signaturfeatures
  • BizTalk Custom Components
Verwenden von Dokumenten und Austauschvorgängen
  • Zugreifen auf die Angehalten-Warteschlange

  • Lesen der Überwachungsdatenbank

  • Senden von Dokumenten

  • Anzeigen von Austausch- und Dokumentdaten
  • BizTalk Documents

  • Documents and WMI

  • Displaying the Contents of a Document or an Interchange

  • WMI Tasks
Verwalten von Dateiempfangsdiensten
  • Ausführen von Dateiempfangsfunktionen, wie z. B. Erstellen, Löschen und Abrufen
  • Receive Services and WMI

  • WMI Tasks
Verwalten von Warteschlangen
  • Abrufen von Warteschlangen nach Gruppen

  • Abrufen aller Gruppen
  • Queues and WMI

  • WMI Tasks
Verwalten von Servergruppen
  • Ausführen von Servergruppenfunktionen, wie z. B. Erstellen, Löschen und Abrufen
  • Groups and WMI

  • WMI Tasks
Verwalten von Servern
  • Ausführen von Serverfunktionen, wie z. B. Erstellen, Löschen und Abrufen
  • Servers and WMI

  • WMI Tasks
Verwalten der BizTalk-Messaging-Verwaltungsdatenbank
  • Erstellen und Abrufen der BizTalk-Messaging-Verwaltungsdatenbank
  • BizTalk Messaging Management Database and WMI

  • WMI Tasks
Verwalten von Handelspartnerbeziehungen
  • Einrichten von Messagingports und Kanälen für den Datenaustausch

  • Erstellen von Dokumentdefinitionen und Umschlägen

  • Festlegen von Organisationseigenschaften
  • BizTalk Messaging Services

Weitere Informationen zum Verwenden der Windows-Verwaltungsinstrumentation (WMI) und zur WMI-Anwendungsprogrammierung finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "WMI Application Programming".

Datenbankverwaltung

Neben Aufgaben wie dem Komprimieren von Datendateien und dem Sichern der Datenbank- und Transaktionsdateiprotokolle, die zur normalen Datenbankpflege und -verwaltung gehören, müssen Sie weitere Datenbankaufgaben ausführen. Zu diesen zusätzlichen Aufgaben zählen u. a. das Aufrechterhalten der Verbindungen zwischen BizTalk Server und Microsoft SQL Server, das Hinzufügen, Löschen und Wiederherstellen von Datenbanken sowie das Konfigurieren neuer Datenbanken. Die folgende Tabelle stellt die allgemeinen Datenbankverwaltungsaufgaben samt einer Beschreibung vor und gibt Quellen für weitere Informationen an.

Verwaltungsaufgabe Beschreibung Informationsquellen
Verwalten von Datenbanken
  • Konfigurieren und/oder Bearbeiten der BizTalk-Messaging-Verwaltungsdatenbank

  • Erstellen und Konfigurieren neuer Persistenzdatenbanken

  • Wiederherstellen und/oder manuelles Entfernen der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen
  • Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank

  • Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

  • Erstellen einer neuen, leeren Persistenzdatenbank

  • Verwalten von Datenbanken für eine Servergruppe
Überwachen des eingehenden Datenbankverkehrs
  • Konfigurieren von Servereinstellungen
  • Grundlegendes zu Servereigenschaften

  • Optimieren der Servereigenschaften


Verwenden der BizTalkServer2002-Hilfe

BizTalk Server 2002 ~ Erste Schritte

Verwenden der BizTalk Server 2002-Hilfe

Dieser Abschnitt enthält Informationen zum Microsoft® BizTalk™ Server 2002-Hilfesystem.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ausführliche Informationen zur BizTalk Server 2002-Hilfe finden Sie unter Informationen zur Hilfe.

  • Detaillierte Beschreibungen der Verfahren für bestimmte Aufgaben finden Sie unter Durchführen von Hilfeaufgaben.


Informationen zur Hilfe

Die Informationen im Microsoft BizTalk Server 2002-Hilfesystem werden unter Verwendung von HTML formatiert und angezeigt. Die Hilfeanzeige stellt ein integriertes Inhaltsverzeichnis, einen Index und eine Funktion zur Volltextsuche bereit, die Ihnen das leichte Auffinden von Informationen ermöglichen. Über die Buchsymbole können Sie untergeordnete Bücher und Hilfethemen anzeigen. Klicken Sie auf das Erweiterungssymbol (+) neben einem Buchtitel, um das Inhaltsverzeichnis zu erweitern und die Themen in einem Buch anzuzeigen. Wenn Sie auf das Reduktionssymbol klicken (-), werden die Themen ausgeblendet. Die Hilfeanzeige bietet außerdem die Möglichkeit, neben dem eigentlichen Hilfethema gleichzeitig auch das Inhaltsverzeichnis, den Index oder Suchergebnisse anzuzeigen.

Zusätzlich finden Sie in der Hilfeanzeige die Registerkarte Favoriten, auf der Sie Hilfethemen mit einem Lesezeichen versehen können. So können Sie häufig verwendete Themen schnell und einfach anzeigen.

Sie können das Inhaltsverzeichnis verwenden, um in der Dokumentation zu suchen und weitere Informationen zu BizTalk Server 2002 zu erhalten. Wenn Sie im Inhaltsverzeichnis auf ein Thema klicken, werden die Informationen im Inhaltsbereich im Hilfefenster angezeigt

Das Inhaltsverzeichnis ist nach Büchern entsprechend den Hauptfeatures und -funktionen von BizTalk Server 2002 geordnet. Jedes Buch enthält einige oder alle der folgenden Kapitel:

  • Informationen zu <Feature/Funktion/Verwandtes Konzept>. Diese Kapitel enthalten Beschreibungen und allgemeine Informationen zu BizTalk Server 2002, seine Features und verwandte Konzepte.

  • Gründe für das Durchführen von <Feature-/Funktionsname>-Aufgaben. Diese Kapitel enthalten kurze Referenzen zum Durchführen bestimmter Aufgaben.

  • Durchführen von <Feature-/Funktionsname>-Aufgaben. Diese Kapitel enthalten Informationen zu Verfahrensweisen und aufgabenbasierte Informationen.

  • Problembehandlung - <Feature-/Funktionsname>. In diesen Kapiteln finden Sie Anweisungen zum Beheben von Problemen.

Programmierungsinformationen finden Sie unter BizTalk Server 2002 Developer Solutions.

Verwandte Themen

Suchen eines Hilfethemas

Hilfeanzeige - Tastenkombinationen


Durchführen von Hilfeaufgaben

Führen Sie die in diesem Abschnitt beschriebenen Aufgaben durch, um in der Microsoft BizTalk Server 2002-Hilfe nach Informationen zu suchen. Beispielsweise können Sie in der Hilfe suchen, um bestimmte Informationen zu ermitteln, und diese Informationen dann mit einem Lesezeichen versehen, indem Sie sie auf der Registerkarte Favoriten zu einer Liste bevorzugter Hilfethemen hinzufügen. Sie können Informationen aus der Hilfe in ein anderes Dokument kopieren und dieses drucken. Sie können außerdem die Schriftgröße ändern, um die Lesbarkeit zu verbessern.

In diesem Abschnitt werden folgende Verfahren behandelt:

  • Suchen eines Hilfethemas

  • Kopieren eines Hilfethemas

  • Drucken eines Hilfethemas

  • Ändern der Schriftgröße

  • Hilfeanzeige - Tastenkombinationen


Suchen eines Hilfethemas

In der Hilfeanzeige stellen die folgenden Registerkarten Optionen zum Suchen und Durchsuchen bereit:

  • Registerkarte "Inhalt"

  • Registerkarte "Index"

  • Registerkarte "Suchen"

  • Registerkarte "Favoriten"

Registerkarte "Inhalt"

Mithilfe der Registerkarte Inhalt können Sie durch die Hilfe navigieren und mehr über BizTalk Server 2002 erfahren.

  1. Klicken Sie auf die Registerkarte Inhalt, um das Inhaltsverzeichnis zu durchsuchen.

  2. Doppelklicken Sie auf die Buchsymbole, um ein Thema oder weitere Bücher einzublenden.

  3. Klicken Sie auf einen Eintrag im Inhaltsverzeichnis, um das entsprechende Thema anzuzeigen.

Registerkarte "Index"

Mithilfe der Registerkarte Index können Sie den Inhalt der Hilfe durchsuchen und die entsprechenden Themen anzeigen.

  1. Klicken Sie auf die Registerkarte Index, um eine Liste der Indexeinträge anzuzeigen. Geben Sie ein Wort ein, oder führen Sie einen Bildlauf in der Liste durch.

    Themen werden oftmals unter mehreren Einträgen indiziert.

  2. Doppelklicken Sie auf einen Indexeintrag, um das entsprechende Thema anzuzeigen.

    -Oder-

    Doppelklicken Sie auf einen Indexeintrag der obersten Ebene, der über Untereinträge verfügt, um eine Liste aller Themen anzuzeigen, die das entsprechende Wort enthalten.

    Das Dialogfeld Themen gefunden wird angezeigt.

    Klicken Sie auf das anzuzeigende Thema, und klicken Sie dann auf Anzeigen.

Registerkarte "Suchen"

Mithilfe der Registerkarte Suchen können Sie nach jedem Vorkommen eines Wortes oder Ausdrucks in der Hilfe suchen.

  1. Klicken Sie auf die Registerkarte Suchen, geben Sie das gesuchte Wort oder den Ausdruck ein, und klicken Sie dann auf Themen auflisten, um jedes Vorkommen eines Wortes oder Ausdrucks zu suchen.

    Um die Suche zu optimieren, verwenden Sie die in der folgenden Tabelle aufgelisteten Suchparameter.

    Suchparameter Zu suchende Elemente Beispiel
    AND, OR, NEAR oder NOT Mehrere Wörter oder Ausdrücke. Mit diesen Parametern können Sie nach Kombinationen von Wörtern suchen und Wörter ausschließen. Messaging AND Orchestrierung

    Anmerkung

    • Klicken Sie neben dem Feld Suchbegriff(e) eingeben auf den Pfeil nach rechts, und wählen Sie eine Option aus der Dropdownliste aus.
    Sternchen (*) Alle Wörter, die mit den Buchstaben vor dem Sternchen beginnen. Es werden Wörter mit unterschiedlichen Endungen gefunden. Admin*

    Spezif*
    Anführungszeichen ("") Ein Begriff oder Ausdruck, der aus mehreren Wörtern besteht. Übereinstimmungen für einzelne Wörter werden nicht berücksichtigt. Wenn Sie z. B. "BizTalk Server" eingeben, werden nur Ergebnisse für beide Wörter aufgelistet, nicht für "BizTalk" und "Server" alleine. "BizTalk Server"

    "Flatfile mit Trennzeichen"

    Darüber hinaus können Sie unten auf der Registerkarte Suchen die Optionen auswählen, um die Suche anzupassen:

    • Vorherige Ergebnisse suchen. Durchsucht die aktuelle Liste im Ergebnisbereich mit den von Ihnen angegebenen neuen Suchparametern.

    • Ähnliche Wörter suchen. Sucht nach allen Variationen des eingegebenen Wortes. Bei Eingabe von "Benachrichtigen" werden beispielsweise auch Suchergebnisse für "Benachrichtigungen" zurückgegeben. Diese Option ist standardmäßig aktiviert.

    • Nur Titel suchen. Durchsucht nur die Titel von Büchern, untergeordneten Büchern und Hilfethemen, nicht den gesamten Text.
  2. Doppelklicken Sie auf einen Suchergebniseintrag, um das entsprechende Thema anzuzeigen.

Anmerkung

  • Die gesuchten Wörter und Ausdrücke werden in dem Text des angezeigten Hilfethemas markiert. Sie können dieses Feature deaktivieren, indem Sie im Menü Optionen den Befehl Suchbegriffhervorhebung deaktivieren auswählen.

Registerkarte "Favoriten"

Sie können eine Liste bevorzugter oder häufig verwendeter Hilfethemen erstellen, indem Sie sie auf der Registerkarte Favoriten mit einem Lesezeichen versehen.

  1. Verwenden Sie die Registerkarten Inhalt, Index oder Suchen zum Suchen und Anzeigen eines Hilfethemas, und versehen Sie das Thema dann mit einem Lesezeichen.

  2. Klicken Sie auf die Registerkarte Favoriten und dann auf Hinzufügen, um das Hilfethema zur Liste Themen hinzuzufügen.

Das Thema wird zur Liste Themen der Hilfeanzeige hinzugefügt. Später können Sie zu dieser Liste zurückkehren und auf das Lesezeichen doppelklicken, um das Thema direkt anzuzeigen.

Anmerkung

  • Klicken Sie auf das Lesezeichen und dann auf Entfernen, um ein Lesezeichen aus der Liste Themen zu entfernen.

Verwandtes Thema

Hilfeanzeige - Tastenkombinationen


Kopieren eines Hilfethemas

  1. Klicken Sie im Themenfenster in der Hilfeanzeige mit der rechten Maustaste in das Thema, das Sie kopieren möchten, und klicken Sie dann auf Alles auswählen.

  2. Klicken Sie erneut mit der rechten Maustaste in das Thema, und klicken Sie dann auf Kopieren.

    Dadurch wird das Thema in die Zwischenablage kopiert.

  3. Öffnen Sie das Dokument, in das Sie das Thema kopieren möchten.

  4. Klicken Sie in dem Dokument an die Stelle, an der die Informationen angezeigt werden sollen.

  5. Klicken Sie im Menü Bearbeiten auf Einfügen.

Anmerkungen

  • Wenn Sie nur einen Teil eines Themas kopieren möchten, markieren Sie den zu kopierenden Teil, klicken Sie mit der rechten Maustaste auf den markierten Text und dann auf Kopieren.

  • Die Nummern der Schritte werden nicht in die Zwischenablage kopiert.

Verwandte Themen

Suchen eines Hilfethemas

Drucken eines Hilfethemas


Drucken eines Hilfethemas

  1. Wählen Sie auf der Registerkarte Inhalt ein Thema aus.

  2. Klicken Sie auf der Symbolleiste auf Drucken.

    Das Dialogfeld Thema drucken wird angezeigt.

  3. Klicken Sie auf Ausgewähltes Thema drucken, um ein einzelnes Thema zu drucken, und klicken Sie dann auf OK.

    Oder

    Klicken Sie auf Ausgewähltes Thema und alle Unterthemen drucken, um alle Themen in einem Buch zu drucken, und klicken Sie auf OK.

    Das Dialogfeld Drucken wird angezeigt.

  4. Klicken Sie auf Drucken.

Wichtig

  • Es wird empfohlen, dass Sie als Seitenausrichtung Querformat auswählen, da Seiten mit Codebeispielen, umfangreichen Illustrationen und wichtigen Textstellen bei Verwendung von Hochformat möglicherweise nicht vollständig gedruckt werden. Zur Auswahl von Querformat klicken Sie im Dialogfeld Drucken auf die Registerkarte Layout und dann im Bereich Ausrichtung auf Querformat.

Verwandte Themen

Suchen eines Hilfethemas

Hilfeanzeige - Tastenkombinationen


Ändern der Schriftgröße

Sie können die Schriftgröße des Textes vergrößern, um die Anzeige zu vereinfachen. Sie können die Schriftgröße auch verkleinern, um eine Darstellung des Layouts einer Seite anzuzeigen.

  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Schriftart ( Schaltfläche "Schriftart"), um die Schrift zu vergrößern oder zu verkleinern.

Änderungen an der Schriftgröße werden beibehalten, wenn Sie die Hilfedatei schließen, so dass die zuletzt ausgewählte Schriftgröße beim nächsten Öffnen der Hilfedatei verwendet wird.


Hilfeanzeige - Tastenkombinationen

Mit Tastenkombinationen können Sie Aufgaben in der BizTalk Server 2002-Hilfeanzeige ausführen. Die folgende Tabelle ist eine kurze Referenz zu den in der Hilfeanzeige verfügbaren Tastenkombinationen.

Anmerkung

  • Um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind, können Sie mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen. Weitere Informationen zur Tastaturmaus finden Sie in der Microsoft® Windows® 2000 Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".

Tastenkombinationen in der Hilfeanzeige

Taste/Tastenkombination | Zweck
ALT+LEER | Systemmenüs anzeigen.
UMSCHALT+F10 Kontextmenü der Hilfeanzeige anzeigen.

Anmerkung

  • Verwenden Sie diese Tastenkombination, wenn sich der Fokus im Themenbereich befindet.
ALT+TAB | Zwischen der Hilfeanzeige und anderen geöffneten Fenstern umschalten.
ALT+O | Menü Optionen anzeigen.
ALT+O und dann T drücken | Ausblenden oder Einblenden des Navigationsfenster.
STRG+TAB | Zur nächsten Registerkarte im Navigationsfenster wechseln.
STRG+UMSCHALT+TAB | Zur vorherigen Registerkarte im Navigationsfenster wechseln.
NACH-OBEN-TASTE | Zu dem Thema wechseln, das oberhalb des aktuellen Themas im Inhaltsverzeichnis, im Index oder in der Liste der Suchergebnisse angezeigt wird.
NACH-UNTEN-TASTE | Zu dem Thema wechseln, das unterhalb des aktuellen Themas im Inhaltsverzeichnis, im Index oder in der Liste der Suchergebnisse angezeigt wird.
BILD-NACH-OBEN | Zur vorherigen Seite im Inhaltsverzeichnis, im Index oder in der Liste der Suchergebnisse wechseln.
BILD-NACH-UNTEN | Zur nächsten Seite im Inhaltsverzeichnis, im Index oder in der Liste der Suchergebnisse wechseln.
F6 | Zwischen dem Navigations- und dem Themenfenster umschalten.
ALT+O und dann K drücken | Anzeige des im Themenfenster angezeigten Themas aktualisieren.
NACH-OBEN- oder NACH-UNTEN-TASTE | Bildlauf in einem Thema.
STRG+POS1 | Zum Anfang eines Themas wechseln.
STRG+ENDE | Zum Ende eines Themas wechseln.
STRG+A | Gesamten Text im Themenbereich markieren.
ALT+O und dann D drücken | Ein Thema drucken.
ALT+O und dann Z | Zum vorher angezeigten Thema wechseln.
ALT+O und dann V | Zum nächsten (zuvor angezeigten) Thema wechseln.
TAB Zwischen verwandten Themen bewegen.

Anmerkung

  • Verwenden Sie diese Tastenkombination, wenn sich der Fokus im Themenbereich befindet.
ALT+F4 | Hilfeanzeige schließen.

Tastenkombinationen auf der Registerkarte "Inhalt"

Taste/Tastenkombination | Zweck
ALT+A | Registerkarte Inhalt anzeigen.
NACH-RECHTS-TASTE | Ein Buch öffnen.
NACH-LINKS-TASTE | Ein Buch schließen.
RÜCKTASTE | Zum zuvor geöffneten Buch zurückkehren.
NACH-OBEN- oder NACH-UNTEN-TASTE | Ein Thema auswählen.
ALT+NACH-LINKS-TASTE | Zum vorher angezeigten Thema wechseln.
ALT+NACH-RECHTS-TASTE | Zum nächsten (zuvor angezeigten) Thema wechseln.
EINGABETASTE | Ausgewähltes Thema anzeigen.

Tastenkombinationen auf der Registerkarte "Index"

Taste/Tastenkombination | Zweck
ALT+N | Registerkarte Index anzeigen.
NACH-OBEN- oder NACH-UNTEN-TASTE | Ein Schlüsselwort in der Liste auswählen.
ALT+Z oder EINGABETASTE | Zugeordnetes Thema anzeigen.

Tastenkombinationen auf der Registerkarte "Suchen"

Taste/Tastenkombination | Zweck
ALT+S | Registerkarte Suchen anzeigen.
ALT+L | Suche starten.
ALT+Z oder EINGABETASTE | Ausgewähltes Thema anzeigen.

Tastenkombinationen auf der Registerkarte "Favoriten"

Taste/Tastenkombination | Zweck
ALT+F | Registerkarte Favoriten anzeigen.
ALT+O | Hilfethema zur Liste Themen hinzufügen.
ALT+T Thema in der Liste Themen auswählen.

Anmerkung

  • Verwenden Sie diese Tastenkombination, wenn sich der Fokus im Themenbereich befindet und Sie zur Liste Themen wechseln möchten.
ALT+T | Thema aus der Liste Themen entfernen.
ALT+L | Thema in der Liste Themen anzeigen.

Verwandtes Thema

Informationen zur Hilfe


Eingabehilfen für körperlich Behinderte

Microsoft hat es sich zur Aufgabe gemacht, die Verwendung seiner Produkte noch einfacher zu gestalten. Informationen zu Features, durch die Microsoft® BizTalk™ Server 2002 besser zugänglich wird, finden Sie unter den folgenden Themen:

  • Hilfeanzeige - Tastenkombinationen

  • BizTalk Server-Verwaltung - Tastenkombinationen

  • BizTalk-Dokumentüberwachung - Tastenkombinationen

  • BizTalk-Orchestrierungs-Designer - Tastenkombinationen

  • BizTalk-Messaging-Manager - Tastenkombinationen

  • BizTalk-Editor - Tastenkombinationen

  • BizTalk-Mapper - Tastenkombinationen

Anmerkungen

  • Weitere Informationen zu den Optionen für Eingabehilfen finden Sie in der Microsoft Windows® 2000 Server-Hilfe, im Buch Erste Schritte für Windows 2000 Server unter "Eingabehilfen für körperlich Behinderte". In der Windows 2000 Professional-Hilfe finden Sie Informationen im Kapitel "Eingabehilfen für besondere Anforderungen".

  • Informationen zu Optionen für Eingabehilfen in verschiedenen Microsoft-Produkten finden Sie in der Microsoft-Website für Eingabehilfen (www.microsoft.com/enable/).


Microsoft Product Support Services

Produktname: Microsoft® BizTalk™ Server 2002

Supportoptionen: Die neuesten Informationen zu Ihren Supportoptionen erhalten Sie in der Microsoft Product Support Services-Website (www.microsoft.com/germany/support/).

  • Weltweiter Support: Die in Ihrem Land bzw. Ihrer Region gültigen Optionen, Geschäftsstunden und Kosten können von denen in den Vereinigten Staaten abweichen. Für weitere Informationen wenden Sie sich bitte an Ihre zuständige Niederlassung.

  • Bedingungen: Microsoft Product Support Services unterliegen den jeweils aktuellen Preisen und Geschäftsbedingungen von Microsoft, die ohne vorherige Ankündigung geändert werden können.


Erlernen der Verwendung von BizTalkServer2002

BizTalk Server 2002 ~ Lernprogramme

Erlernen der Verwendung von BizTalk Server 2002

Dieser Abschnitt enthält drei hilfreiche Szenarien, die Ihnen Kenntnisse in Bezug auf die Tools und Dienste von Microsoft® BizTalk™ Server 2002 und deren Verwendung vermitteln sollen.

  • Das BizTalk Server 2002-Lernprogramm ist ein herkömmliches Lernprogramm, mit dem Sie die Verfahren kennen lernen, die zum Konfigurieren eines vollständigen automatisierten Beschaffungsprozesses auf Business-to-Business-Ebene erforderlich sind. In diesem Lernprogramm lernen Sie in erster Linie, wie der BizTalk-Mapper, der BizTalk-Editor, der BizTalk-Orchestrierungs-Designer, der BizTalk-Messaging-Manager und die BizTalk Server-Verwaltung verwendet werden.

  • Kennenlernen von BizTalk Server 2002 ist eine konzeptuelle Übersicht über die grundlegenden Konzepte, die mit den Prozessen und Aufgaben zusammenhängen, die zum Erstellen eines automatisierten Beschaffungsprozesses auf Business-to-Business-Ebene mit BizTalk Server erforderlich sind. Dieser Ansatz ermöglicht es Ihnen, Skripts auszuführen, die die Installation für Sie ausführen. Dank der Übersicht werden Sie die Funktionsweise der Dienste und Prozesse besser verstehen.

  • Das E-Procurement Sample zeigt einige der neuesten Features von BizTalk Server. Es wird außerdem eine Übersicht über den BizTalk SEED-Assistenten gegeben sowie über die Bereitstellung von Application Center und verbesserte Überwachungsfunktionen durch die Verwendung von Microsoft Operations Manager (MOM). Das Beispiel enthält zudem eine neue XLANG-Korrelation, die gemeinsame Warteschlangen anstelle von instanzbezogenen Warteschlangen verwendet.


BizTalkServer2002-Lernprogramm

BizTalk Server 2002 ~ Lernprogramm

BizTalk Server 2002-Lernprogramm

Automatisierte Beschaffung auf Business-to-Business-Ebene

In diesem Lernprogramm wird erläutert, wie Microsoft® BizTalk™ Server 2002 für die Einrichtung und Ausführung eines automatisierten Beschaffungsprozesses auf Business-to-Business-Ebene konfiguriert wird.

Darüber hinaus erfahren Sie, wie BizTalk Server-Komponenten und -Dienste zusammenarbeiten, um flexibel verbundene zeitintensive Geschäftsprozesse sowohl firmenintern als auch firmenübergreifend zu integrieren.

Anmerkung

  • Das BizTalk Server 2002-Lernprogramm wird auch im Microsoft Word-Format bereitgestellt. Zum Drucken des Lernprogramms müssen Sie die Word-Version verwenden. Wenn Sie Word nicht installiert haben, können Sie die Datei mit WordPad oder Microsoft Word 97/2000 Viewer anzeigen. Klicken Sie auf Durchsuchen ([...]), und wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab auf dem BizTalk Server-Installationslaufwerk.

Anforderungen

BizTalk Server 2002 und alle seine Abhängigkeiten müssen installiert werden, damit das Lernprogramm erfolgreich durchgeführt werden kann. Außerdem ist für Teile des Anhangs Microsoft Visual Basic® 6.0 erforderlich. Eine vollständige Liste der Hardware- und Softwareanforderungen für BizTalk Server 2002 finden Sie unter Installieren von BizTalk Server 2002.

Szenario

Das in diesem Lernprogramm verwendete Szenario stellt eine umfassende Übersicht der Hauptelemente von BizTalk Server 2002 sowie schrittweise Anleitungen zur Verwendung von BizTalk Server-Tools und –Diensten bereit.

In diesem Szenario wird BizTalk Server 2002 von Northwind Traders (in diesem Lernprogramm der Käufer) verwendet, um einen automatisierten Beschaffungsprozess auf Business-to-Business-Ebene mit Contoso, Ltd (in diesem Lernprogramm der Verkäufer) zu entwerfen und zu implementieren. Eine von Northwind Traders generierte Auftragsanforderung muss vor der Genehmigung bestimmte Kriterien erfüllen. Wenn der Umfang der Auftragsanforderung nicht größer ist als €1.000, wird ein Auftrag generiert und an Contoso, Ltd gesendet. Ansonsten wird die Auftragsanforderung abgelehnt und der Prozess beendet. Northwind Traders automatisiert diesen Prozess durch die Verwendung eines XLANG-Ablaufplanes zur Steuerung des Nachrichtenflusses durch ihr System.

Ist die Auftragsanforderung genehmigt, verwendet das System des Käufers BizTalk-Messagingdienste, um den Auftrag zu empfangen, weiterzuleiten und in das Format von Contoso, Ltd umzuwandeln und die Daten dann zu extrahieren. Der Verkäufer (Contoso, Ltd) führt den Auftrag aus und sendet eine Rechnung zurück an den Käufer (Northwind Traders). Wenn der Käufer die Rechnung erhält, wird eine Zahlung ausgegeben und an den Verkäufer gesendet.

Dieser Beschaffungsprozess wird durch das Verwenden von BizTalk Server 2000-Tools und -Dienste automatisiert. Beide Systeme verwenden auch eine Reihe von Hilfskomponenten, die mit BizTalk Server 2002 zusammenarbeiten, um wichtige Datenverarbeitungsaufgaben durchzuführen.

Die folgende Abbildung zeigt die Interaktion des automatisierten Beschaffungssystems auf Business-to-Business-Ebene, das von Northwind Traders und Contoso, Ltd implementiert wurde. Die Pfeile zeigen den Datenfluss zwischen Rollen und Entitäten an.

Wichtig

  • Für dieses Szenario sind sowohl das Käufer- als auch das Verkäufersystem auf einer einzigen Installation von BizTalk Server 2002 konfiguriert.

Die folgende Abbildung zeigt die Bewegung der Dokumente durch die Käufer- und Verkäufersysteme. Sie stellt auch die Interaktion zwischen dem XLANG-Ablaufplan, den BizTalk-Messagingdiensten und den Hilfskomponenten dar. Diese Abbildung ist eine hilfreiche Referenz, die Sie ausdrucken können, um sie stets zur Verfügung zu haben, da in den Unterrichtseinheiten dieses Lernprogramms mehrfach darauf verwiesen wird.

Käufer und Verkäufer - Übersicht

Inhalt

Unterrichtseinheit 1: Gestalten von Geschäftsprozessen

In dieser Unterrichtseinheit lernen Sie Folgendes:

  • Erstellen einer XLANG-Ablaufplanzeichnung, mit der die Beschaffungsprozesse für Northwind Traders festgelegt und implementiert werden, mithilfe des BizTalk-Orchestrierungs-Designers. Weitere Informationen finden Sie unter Entwerfen von BizTalk-Orchestrierungen.

  • Kompilieren der XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan. Weitere Informationen finden Sie unter Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan.

  • Ausführen des XLANG-Ablaufplanes, um zu sehen, wie eine Nachricht durch das Käufersystem bewegt wird.

Unterrichtseinheit 2: Erstellen von Spezifikationen und Zuordnungen

In dieser Unterrichtseinheit lernen Sie Folgendes:

  • Erstellen von Dokumentspezifikationen mithilfe des BizTalk-Editors. Weitere Informationen finden Sie unter Erstellen und Überprüfen von Spezifikationen.

  • Erstellen von Zuordnungen mithilfe des BizTalk-Mappers. Weitere Informationen finden Sie unter Erstellen neuer Zuordnungen.

Unterrichtseinheit 3: Konfigurieren der BizTalk-Messagingdienste

In dieser Unterrichtseinheit lernen Sie Folgendes:

  • Konfigurieren der BizTalk-Messagingdienste für Contoso, Ltd mithilfe des BizTalk-Messaging-Managers. Weitere Informationen finden Sie unter Verwenden des BizTalk-Messaging-Managers.

  • Erstellen einer Dateiempfangsfunktion für Contoso, Ltd mithilfe der BizTalk Server-Verwaltung. Weitere Informationen finden Sie unter Hinzufügen einer Dateiempfangsfunktion.

Unterrichtseinheit 4: Fertigstellen des XLANG-Ablaufplanes

In dieser Unterrichtseinheit lernen Sie Folgendes:

  • Implementieren eines Ports in die XLANG-Ablaufplanzeichnung, mit der Sie in Unterrichtseinheit 2 begonnen haben, mithilfe der BizTalk-Messagingimplementierung. Informationen zu den Unterschieden zwischen Ports und Messagingports finden Sie unter Grundlegendes zu Portimplementierungen und Grundlegendes zu Messagingports.

  • Beenden der XLANG-Ablaufplanzeichnung und Kompilieren der Zeichnung in einen XLANG-Ablaufplan.

  • Ausführen des Ablaufplanes, um sämtliche Nachrichtenbewegungen zwischen dem Käufer- und dem Verkäufersystem zu verstehen.

Verknüpfungen

  • Im gesamten Lernprogramm stehen mehrere Verknüpfungen zu Verfügung, mit denen Sie durch das Verwenden eines vorhandenen XLANG-Ablaufplanes, einer Dokumentspezifikation, einer Zuordnung oder eines Konfigurationsskripts Zeit und Arbeit sparen können. Durch das Verwenden von Verknüpfungen gelangen Sie zu den nachfolgenden Abschnitten des Lernprogramms.

  • Für die Verwendung von Verknüpfungen müssen alle Komponenten des Lernprogramms auf Laufwerk C: installiert sein. Sie können das Lernprogramm nicht ausführen, wenn Sie ein anderes Laufwerk verwenden.

Weiter mit Vorläufige Installation.


Vorläufige Installation

Bevor Sie mit dem Lernprogramm beginnen, müssen Sie Folgendes erstellen:

  • Einen Ordner mit vier Unterordnern

  • Zwei lokale Websiteordner mit ASP-Dateien (Active Server Pages)

  • Zwei Nachrichtenwarteschlangen für das Käufersystem

Weiter mit Erstellen von Ordnern.


Erstellen von Ordnern

In diesem Verfahren erstellen Sie einen Ordner, der vier Unterordner enthält. Sie verwenden zwei der Unterordner, Buyer and Seller, als Speicherort für Nachrichten, die beim Käufer- und Verkäufersystem ein und aus gehen. Bei den anderen handelt es sich um Inhaltsordner für die Käufer- und Verkäuferwebsites.

So erstellen Sie die Ordner:

  1. Gehen Sie in Windows® Explorer zum Stammverzeichnis des Laufwerks C:.

    Wichtig

    • Folgende Ordner müssen auf Laufwerk C: erstellt werden. Sie können das Lernprogramm nicht ausführen, wenn Sie ein anderes Laufwerk verwenden.
  2. Erstellen Sie einen neuen Ordner im Stammverzeichnis von Laufwerk C:, und nennen Sie den Ordner TutorialFiles.

  3. Klicken Sie auf den neuen Ordner TutorialFiles, und erstellen Sie vier Unterordner mit den folgenden Namen:
    • Buyer

    • Seller

    • SubmitPO

    • InvoiceToQueue

Weiter mit Kopieren von Dateien.


Kopieren von Dateien

In diesem Verfahren kopieren Sie eine Karte zur späteren Verwendung in das BizTalk Server-Respository und ASP-Dateien in die Webinhaltsordner von Käufer und Verkäufer.

  1. Wechseln Sie auf dem BizTalk Server-Installationslaufwerk in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps, und kopieren Sie POReqtoPO.xml.

  2. Fügen Sie die Datei in das Verzeichnis \Programme\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft ein.

  3. Verwenden Sie die folgende Tabelle, um weitere Dateien zu kopieren und in die Unterordner TutorialFiles einzufügen.
    Kopieren aus: Einfügen in:
    \Programme\Microsoft BizTalk Server\Tutorial\Components\SubmitPO\Solution\SubmitNorthwindPO.asp | C:\TutorialFiles\SubmitPO
    \Programme\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\DropInvoicetoMSMQ.asp | C:\TutorialFiles\InvoiceToQueue
    \Programme\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\Global.asa | C:\TutorialFiles\InvoiceToQueue

Weiter mit Erstellen von virtuellen Websiteverzeichnissen.


Erstellen von virtuellen Websiteverzeichnissen

In diesem Verfahren erstellen Sie zwei virtuelle Verzeichnisse in Internet-Informationsdienste (Internet Information Services, IIS), die auf ASP-Dateien verweisen. Das erste Verzeichnis simuliert die Verkäuferwebsite, in der Aufträge empfangen werden. Das zweite Verzeichnis simuliert die Käuferwebsite, in der Rechnungen empfangen werden.

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Verwaltung.

  3. Doppelklicken Sie auf Internetdienste-Manager

    Die Verwaltungskonsole für Internet-Informationsdienste wird angezeigt.

  4. Erweitern Sie in der Konsolenstruktur der IIS-Verwaltung <Ihren Computer>, und klicken Sie dann auf Standardwebsite.

  5. Im Menü Vorgang zeigen Sie auf Neu, und klicken Sie dann auf Virtuelles Verzeichnis.

    Der Assistent zum Erstellen virtueller Verzeichnisse wird geöffnet.

  6. Klicken Sie auf der Seite Willkommen auf Weiter.

  7. Auf der Seite Alias für Virtuelles Verzeichnis im Feld Alias geben Sie SubmitPO ein, und klicken Sie dann auf Weiter.

  8. Klicken Sie auf der Seite Verzeichnis des Websiteinhalts auf Durchsuchen.

  9. Suchen Sie C:\TutorialFiles\SubmitPO, klicken Sie auf OK und dann auf Weiter.

  10. Klicken Sie auf der Seite Zugriffsberechtigungen auf Weiter.

  11. Klicken Sie auf Fertig stellen, um den Assistenten zum Erstellen virtueller Verzeichnisse zu schließen.

  12. Klicken Sie in der Konsolenstruktur der Computerverwaltung auf Standardwebsite.

  13. Um den Ordner zu erstellen, der die Käuferwebsite simuliert, wiederholen Sie die Schritte 5 bis 11 mit den folgenden Änderungen:
    • Bei Schritt 7 geben Sie InvoiceToQueue im Feld Alias ein.

    • Bei Schritt 9 suchen Sie C:\TutorialFiles\InvoiceToQueue.

    Die Konsole der Computerverwaltung sollte so ähnlich aussehen wie im Folgenden abgebildet.

    Konsole der Computerverwaltung

  14. Schließen Sie die Konsole der Computerverwaltung.

Weiter mit Erstellen von Nachrichtenwarteschlangen.


Erstellen von Nachrichtenwarteschlangen

In diesem Verfahren erstellen Sie zwei Nachrichtenwarteschlangen, um das Käufersystem für das Versenden und Empfangen von Nachrichten zu aktivieren. Northwind Traders verwendet eine Anwendung zum Senden einer Auftragsanforderung. Die Auftragsanforderung wird zur weiteren Verarbeitung an die ReceivePOReq-Warteschlange gesendet. Wenn Contoso, Ltd eine Rechnung über eine ASP an die Käuferwebsite sendet, sendet die ASP die Rechnung zur weiteren Verarbeitung an die ReceivePOReq-Warteschlange.

Anmerkung

  • Für die Durchführung dieses Verfahrens muss Message Queuing installiert sein. Anweisungen zum Installieren von Message Queuing finden Sie unter Installieren der Message Queuing-Dienste.

So erstellen Sie Nachrichtenwarteschlangen:

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Verwaltung.

  3. Doppelklicken Sie auf Computerverwaltung.

    Die Konsole der Computerverwaltung wird angezeigt.

  4. Erweitern Sie in der Konsolenstruktur der Computerverwaltung Dienste und Anwendungen und Message Queuing, und klicken Sie dann auf Private Warteschlangen.

  5. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Private Warteschlange.

    Das Dialogfeld Warteschlangenname wird angezeigt.

  6. Im Feld Name geben Sie ReceivePOReq ein.

  7. Aktivieren Sie das Kontrollkästchen Auf Transaktionen ausgelegt, und klicken Sie auf OK.

  8. Um die zweite Nachrichtenwarteschlange zu erstellen, wiederholen Sie die Schritte 5 bis 7 mit folgenden Änderungen:
    • Bei Schritt 6 geben Sie ReceiveInvoice im Feld Name ein.

    Die Konsole der Computerverwaltung sollte so ähnlich aussehen wie im Folgenden abgebildet.

    Konsole der Computerverwaltung

  9. Schließen Sie die Konsole der Computerverwaltung.

Weiter mit Installieren der Hilfskomponenten.


Installieren der Hilfskomponenten

In diesem Verfahren installieren Sie die folgenden Hilfskomponenten:

  • Eine Anwendungsintegrationskomponente (Application Integration Component, AIC) auf dem Verkäufersystem, die zum Generieren einer Rechnung verwendet wird, die auf den Daten im Auftragsformular des Käufers basiert.

  • Eine Windows-Skriptkomponente auf dem Käufersystem, die zum Implementieren eines Ports in einen XLANG-Ablaufplan verwendet wird und die den Genehmigungs- oder Ablehnungsstatus für eine Auftragsanforderung aus dem XLANG-Ablaufplan annimmt.

    Wichtig

    • Wenn Sie diese Komponenten bereits auf Ihrem Computer installiert haben, müssen Sie sie zuerst wieder deinstallieren. Fahren Sie mit Deinstallieren der Hilfskomponenten fort, um die Komponenten zu deinstallieren.

    Internationales Problem

    • Das BizTalk Server 2002-Lernprogramm unterstützt nur ASCII-Daten. Wenn Sie Nicht-ASCII-Zeichen verwenden müssen, ändern Sie den Code für die Skriptkomponente (PORequestApproval.wsc), so dass diese das XML-Dokumentobjektmodell (DOM) zum Schreiben von Daten verwendet.

So installieren Sie die Hilfskomponenten:

  1. Auf dem BizTalk Server-Installationslaufwerk suchen Sie \Programme\Microsoft BizTalk Server\Tutorial\Setup.

  2. Doppelklicken Sie auf Install_POtoInvoice.vbs.

    Eine Feld mit der Meldung, dass die Komponente erfolgreich installiert wurde, wird angezeigt.

  3. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution, und klicken Sie dann auf PORequestApproval.wsc.

  4. Klicken Sie im Menü Datei auf Registrieren.

    Ein Feld mit der Meldung, dass die Komponente erfolgreich registriert wurde, wird angezeigt.

Weiter mit Unterrichtseinheit 1: Gestalten von Geschäftsprozessen.


Deinstallieren der Hilfskomponenten

Vorsicht

  • Verwenden Sie dieses Verfahren nur, wenn Sie eine vorherige Installation der Komponenten entfernen möchten.
  1. Für die Komponente POtoInvoice wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Setup auf dem BizTalk Server-Installationslaufwerk.

  2. Doppelklicken Sie auf Remove_POtoInvoice.vbs.

    Ein Feld mit der Meldung, dass die Komponente erfolgreich deinstalliert wurde, wird angezeigt.

  3. Für die Windows-Skriptkomponente wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution, und klicken Sie dann auf PORequestApproval.wsc.

  4. Klicken Sie im Menü Datei auf Registrierung aufheben.

    Ein Feld mit der Meldung, dass die Registrierung der Komponente erfolgreich aufgehoben wurde, wird angezeigt.

Fahren Sie mit Installieren der Hilfskomponenten fort, um die Komponenten erneut zu installieren.


Unterrichtseinheit1: Gestalten von Geschäftsprozessen

BizTalk Server 2002 ~ Lernprogramm

Unterrichtseinheit 1: Gestalten von Geschäftsprozessen

In dieser Unterrichtseinheit verwenden Sie den BizTalk-Orchestrierungs-Designer für die Erstellung einer XLANG-Ablaufplanzeichnung, die einen automatisierten Beschaffungsprozess für Northwind Traders definiert und implementiert. Anschließend kompilieren Sie die XLANG-Ablaufplanzeichnung in einen ausführbaren XLANG-Ablaufplan, der den Nachrichtenstrom für das Käufersystem steuert.

Lernziele

  • Erstellen einer XLANG-Ablaufplanzeichnung, die den automatisierten Beschaffungsprozess definiert. Weitere Informationen finden Sie unter Erstellen von XLANG-Ablaufplanzeichnungen.

  • Verbinden der Aktionen in einer logischen Reihenfolge zur weiteren Definition der Geschäftsprozesse. Weitere Informationen finden Sie unter Verbinden von Formen.

  • Implementieren von Geschäftsprozessen durch das Verbinden von Aktionen mit Ports. Weitere Informationen finden Sie unter Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port.

  • Hinzufügen einer Regel zu Geschäftsprozessen durch das Schreiben eines Skriptausdrucks. Weitere Informationen finden Sie unter Entwerfen von Regeln.

  • Definieren des Datenflusses für Nachrichten. Weitere Informationen finden Sie unter Kommunikationsformen.

  • Speichern der XLANG-Ablaufplanzeichnung und Kompilieren der Zeichnung in einen XLANG-Ablaufplan. Weitere Information finden Sie unter Kompilieren von XLANG-Ablaufplänen.

  • Ausführen des XLANG-Ablaufplanes, um die Nachricht in BizTalk Server zu verarbeiten. Weitere Informationen finden Sie unter Ausführen von XLANG-Ablaufplänen.

Weiter mit Erstellen des XLANG-Ablaufplanes für den Käufer.

Verwandtes Thema

Entwerfen von BizTalk-Orchestrierungen


Erstellen des XLANG-Ablaufplanes für den Käufer

In den folgenden Verfahren definieren und implementieren Sie die Geschäftsprozesse für Northwind Traders (den Käufer), und Sie erstellen einen XLANG-Ablaufplan und führen diesen aus.

Zum Erstellen eines XLANG-Ablaufplanes weiter mit Erstellen der Käuferaktionen.

Verknüpfung

  • Für die Verwendung eines vorhandenen XLANG-Ablaufplanes weiter mit Ausführen des XLANG-Ablaufplanes.


Erstellen der Käuferaktionen

Der erste Schritt beim Erstellen des automatisierten Beschaffungsprozesses besteht in der Analyse des von Northwind Traders verwendeten Geschäftsprozesses sowie im Erstellen eines Interaktionsdiagramms zur Beschreibung dieses Prozesses. In diesem Verfahren verwenden Sie den BizTalk-Orchestrierungs-Designer um eine Darstellung des Northwind Traders-Geschäftsprozesses zu zeichnen. Flussdiagrammformen werden verwendet, um die Aktionen zu definieren, die stattfinden, wenn eine Auftragsanforderung empfangen und wenn diese Auftragsanforderung akzeptiert bzw. abgelehnt wird.

Eine detaillierte Beschreibung der Flussdiagrammformen finden Sie unter Flussdiagrammformen. Weitere Informationen zu Geschäftsprozessen finden Sie unter Grundlegendes zu Geschäftsprozessen.

So erstellen Sie die Käuferaktionen:

  1. Zeigen Sie im Startmenü auf Programme und auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Orchestrierungs-Designer.

  2. Ziehen Sie die Aktion-Form aus der Flussdiagrammschablone in der äußerst linken Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die Form unterhalb der Beginn-Form.

  3. Klicken Sie mit der rechten Maustaste auf die Aktion-Form, und wählen Sie dann Eigenschaften.

    Das Dialogfeld Aktionseigenschaften wird angezeigt.

  4. Im Feld Name geben Sie Receive PO Request (Auftragsanforderung erhalten) ein, und klicken Sie dann auf OK.

    Vorsicht

    • Damit dieses Szenario richtig ausgeführt wird, müssen alle Namen genauso eingegeben werden, wie in den Anweisungen angegeben. Die Lernprogrammkomponenten verwenden diese Namen.
  5. Ziehen Sie die Entscheidung-Form aus der Flussdiagrammschablone in der äußerst linken Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die Form unter der Receive PO Request-Aktion.

  6. Klicken Sie mit der rechten Maustaste auf die Entscheidung-Form, und klicken Sie auf Regel hinzufügen.

    Das Dialogfeld Eigenschaften der Regel wird angezeigt.

  7. Im Feld Regelname geben Sie Denied (Abgelehnt) ein, und klicken Sie dann auf OK.

    Die Eingabe von Informationen in das Feld Regelbeschreibung ist optional.

    Lassen Sie das Feld Skriptausdruck leer. Weiter unten in dieser Unterrichtseinheit fügen Sie einen Skriptausdruck hinzu, der die Entscheidungsregel implementiert, nachdem Sie die Entscheidung-Form an die Skriptkomponente gebunden haben, die die Nachrichten- und die Feldnamen bereitstellt.

  8. Wiederholen Sie die Schritte 2 bis 4, um die folgenden drei Aktionen zu erstellen:
    • Positionieren Sie eine zweite Aktion-Form rechts neben der Entscheidung-Form. Nennen Sie diese Aktion Send Denial (Ablehnung senden).

    • Positionieren Sie eine dritte Aktion-Form unter der Entscheidung-Form. Nennen Sie diese Aktion Send Approval (Genehmigung senden).

    • Positionieren Sie eine vierte Aktion-Form unter der Send Approval-Aktion. Nennen Sie diese Aktion Write PO Request to File (Auftragsanforderung in Datei schreiben).
  9. Ziehen Sie die Ende-Form aus der Flussdiagrammschablone in der äußerst linken Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die Form unter der Send Denial-Aktion.

    Wenn die Auftragsanforderung nicht genehmigt wird, zeigt der XLANG-Ablaufplan eine Ablehnungsnachricht an und endet.

  10. Ziehen Sie die Ende-Form aus der Flussdiagrammschablone in der äußerst linken Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die Form unter der Write PO Request to File-Aktion.

    Wenn die Auftragsanforderung genehmigt wird, schreibt der XLANG-Ablaufplan die Auftragsanforderung in ein Dateiverzeichnis, zeigt eine Genehmigungsnachricht an und endet dann.

Weiter mit Verbinden der Käuferaktionen in einer Reihenfolge.


Verbinden der Käuferaktionen in einer Reihenfolge

Wenn Sie die Northwind Traders-Aktionen erstellt haben, müssen Sie die Ereignisabfolge weiter definieren, indem Sie die Flussdiagrammformen verbinden, so dass der Geschäftsprozess beginnt, wenn eine Auftragsanforderung empfangen wird, und endet, wenn die Auftragsanforderung akzeptiert bzw. abgelehnt wird. Sie speichern die Darstellung dann als XLANG-Ablaufplanzeichnung mit der Dateierweiterung SKV. Weitere Informationen finden Sie unter Verbinden von Formen.

So verbinden Sie die Käuferaktionen:

  1. Klicken Sie auf die Beginn-Form, um die Kontrollhandles zu markieren.

    Ziehen Sie den unteren Kontrollhandle zum oberen Verbindungspunkt der Receive PO Request-Aktion.

    Die Receive PO Request-Aktion stellt den Anfang des Geschäftsprozesses dar. Wenn eine Auftragsanforderung empfangen wird, wird der XLANG-Ablaufplan ausgeführt.

    Anmerkungen

    • Eine gelbe Raute auf einer markierten Form zeigt ein Kontrollhandle an. Sie können Kontrollhandles ziehen, um eine Verbindung mit einer Aktion herzustellen.

    • Ein blaues X auf einer Form zeigt einen Verbindungspunkt an.

    • Verbindungspunkte an der Seite einer Aktion-Form werden nur für die Verbindung mit Ports verwendet, nicht für die Verbindung mit anderen Aktion-Formen.
  2. Wiederholen Sie Schritt 1, um eine Verbindung für die folgende Aktion herzustellen:
    • Verbinden Sie die Receive PO Request-Aktion mit der Entscheidung-Form.
  3. Markieren Sie die Denied-Regel in der Entscheidung-Form, und ziehen Sie dann das rechte Kontrollhandle der Denied-Regel zum oberen Verbindungspunkt der Send Denial-Aktion.

  4. Markieren Sie die Else-Regel in der Entscheidung-Form, und ziehen Sie das linke Kontrollhandle der Else-Regel zum oberen Verbindungspunkt der Send Approval-Aktion.

    Anmerkung

    • Sie können die Regeln in der Entscheidung-Form sowohl vom rechten als auch vom linken Kontrollhandle mit den Aktionen Send Approval und Send Denial verbinden.
  5. Verbinden Sie die Send Approval-Aktion mit der Write PO Request to File-Aktion.

  6. Verbinden Sie die Write PO Request to File-Aktion mit der Ende-Form, die sich darunter befindet.

  7. Verbinden Sie die Send Denial-Aktion mit der Ende-Form, die sich darunter befindet.

  8. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld XLANG-Ablaufplanzeichnung speichern unter wird angezeigt.

    Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk.

  9. Im Feld Dateiname geben Sie Buyer1 (Käufer1) ein, und klicken Sie dann auf Speichern.

Die XLANG-Ablaufplanzeichnung, die Sie erstellt und gespeichert haben, sollte so wie in der folgenden Darstellung aussehen.

Weiter mit Implementieren eines Ports mithilfe von Message Queuing für den Empfang einer Auftragsanforderung.


Implementieren eines Ports mithilfe von Message Queuing für den Empfang einer Auftragsanforderung

Im vorläufigen Setup für dieses Lernprogramm haben Sie die ReceivePOReq-Nachrichtenwarteschlange erstellt. In diesem Verfahren fügen Sie die Message Queuing-Form zur XLANG-Ablaufplanzeichnung hinzu und implementieren einen Port zur ReceivePOReq-Nachrichtenwarteschlange.

Die Message Queuing-Form stellt den Message Queuing-Dienst zum Senden oder Empfangen von Nachrichten dar. Der Dienst wird für die Überwachung der ReceivePOReq-Nachrichtenwarteschlange für eine Auftragsanforderung konfiguriert. Sobald sich die Auftragsanforderung in der Warteschlange befindet, beginnt der XLANG-Ablaufplan mit der Verarbeitung. Weitere Informationen finden Sie unter Verwenden der Message Queuing-Form.

Informationen zum Verwenden von Ports und Messagingports in diesem Lernprogramm finden Sie unter Integrieren der BizTalk-Dienste.

So implementieren Sie den Port:

  1. Ziehen Sie die Message Queuing-Form aus der Implementierungsschablone in der äußerst rechten Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die Message Queuing-Form so, dass sie sich horizontal auf einer Linie mit der Receive PO Request-Aktion befindet.

    Der Bindungs-Assistent für Message Queuing wird geöffnet.

  2. Überprüfen Sie, ob auf der Seite Willkommen beim Bindungs-Assistenten für Message Queuing die Option Neuen Port erstellen ausgewählt ist.

  3. Im Feld Neuen Port erstellen geben Sie ReceivePORequest (Auftragsanforderung erhalten) ein, und klicken Sie dann auf Weiter.

  4. Überprüfen Sie auf der Seite Informationen über statische oder dynamische Warteschlangen, ob Statische Warteschlange ausgewählt ist, und klicken Sie dann auf Weiter.

  5. Auf der Seite Warteschlangeninformationen klicken Sie auf Bekannte Warteschlange für alle Instanzen verwenden.

  6. Im Feld Geben Sie den Namen der Warteschlange ein geben Sie .\private$\ReceivePOReq ein, und klicken Sie dann auf Weiter.

  7. Auf der Seite Erweiterte Porteigenschaften klicken Sie auf Fertig stellen.

    Auf der Geschäftsprozessseite werden der ReceivePORequest-Port (Auftragsanforderung erhalten) und die zugeordnete Message Queuing-Implementierung angezeigt.

Anmerkung

  • Es wird eine statische Warteschlange anstatt einer dynamischen Warteschlange verwendet, da wir genau wissen, wohin die Auftragsanforderung übermittelt werden soll, und wir bereits eine spezielle Warteschlange erstellt haben, um sie zu empfangen.

Weiter mit Erstellen des Kommunikationsflusses für die Receive PO Request-Aktion.


Erstellen des Kommunikationsflusses für die Receive PO Request-Aktion

In diesem Verfahren verwenden Sie den Assistenten für XML-Kommunikation, um die Kommunikation zwischen der Receive PO Request-Aktion und dem Receive PO Request-Port zu vereinfachen. Über den Assistenten für XML-Kommunikation stellen Sie spezifische Informationen und Spezifikationen bereit, mit deren Hilfe das XLANG-Ablaufplanungsmodul die richtige Nachricht identifizieren und aus der Warteschlange abrufen kann. Außerdem fügen Sie das Nachrichtenfeld POTtl hinzu, das zur Aktivierung des datengesteuerten Routings verwendet wird.

  1. Markieren Sie die Receive PO Request-Aktion, und ziehen Sie den Kontrollhandle rechts neben der Receive PO Request-Aktion zum linken Verbindungspunkt des ReceivePORequest-Ports.

    Der Assistent für XML-Kommunikation wird geöffnet.

  2. Auf der Seite Willkommen beim Assistenten für XML-Kommunikation klicken Sie auf Empfangen und dann auf Weiter.

  3. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist.

  4. Im Feld Nachrichtenname geben Sie POReq ein, und klicken Sie dann auf Weiter.

  5. Überprüfen Sie auf der Seite Informationen über die XML-Konvertierung, ob die Option Nachrichten in der Warteschlange als XML-Nachrichten empfangen ausgewählt ist, und klicken Sie dann auf Weiter.

  6. Auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp geben Sie POReq ein, und klicken Sie dann auf Weiter.

  7. Auf der Seite Informationen über die Nachrichtenspezifikation klicken Sie auf Durchsuchen.

    Das Dialogfeld Nach Spezifikation durchsuchen wird angezeigt.

  8. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps auf dem BizTalk Server-Installationslaufwerk.

  9. Klicken Sie auf POReq.xml und dann auf Öffnen.

  10. Klicken Sie auf Hinzufügen.

    Das Dialogfeld Feldauswahl wird angezeigt.

  11. Im Bereich Auswahlknoten erweitern Sie Total, und klicken Sie dann auf POTtl und anschließend auf OK.

    Im Bereich Nachrichtenfelder sollte POTtl in der Liste der Nachrichtenfelder angezeigt werden.

  12. Klicken Sie auf Fertig stellen.

Nach dem Implementieren des Ports und dem Erstellen des Kommunikationsflusses sollte die XLANG-Ablaufplanzeichnung so wie in der folgenden Darstellung aussehen.

Weiter mit Implementieren eines Ports mithilfe einer Skriptkomponente.


Implementieren eines Ports mithilfe einer Skriptkomponente

Für dieses Verfahren verwenden Sie die Windows-Skriptkomponente PORequestApproval.wsc, die Sie beim vorläufigen Setup dieses Lernprogramms installiert und registriert haben. Mithilfe der Skriptkomponente können bestimmte Aktionen innerhalb des XLANG-Ablaufplanes durchgeführt werden. In diesem Verfahren implementieren Sie den ApprovalComponent-Port, damit Genehmigungs- und Ablehnungsaktionen mit dem Port verbunden und an die Skriptkomponente gebunden werden können. Weitere Informationen finden Sie unter Verwenden der Skriptkomponente-Form.

Mithilfe der Skriptkomponente können die folgenden Aktionen innerhalb des XLANG-Ablaufplanes durchgeführt werden.

Wenn der Umfang der Auftragsanforderung €1.000 überschreitet, geschieht Folgendes:

  • Die Entscheidung-Form sendet eine Nachricht an den Port.

  • Die Skriptkomponente zeigt ein Meldungsfeld an, das den Benutzer über die Ablehnung informiert.

  • Der XLANG-Ablaufplan endet.

Wenn der Gesamtumfang der Auftragsanforderung €1.000 oder weniger beträgt, geschieht Folgendes:

  • Die Entscheidung-Form sendet eine Genehmigungsnachricht an den Port.

  • Die Skriptkomponente zeigt ein Meldungsfeld an, das den Benutzer über die Genehmigung informiert.

  • Die Skriptkomponente schreibt die Auftragsanforderungnachricht in ein lokales Dateiverzeichnis.

  • Der XLANG-Ablaufplan endet.

So implementieren Sie den Port:

  1. Ziehen Sie die Skriptkomponente-Form aus der Implementierungsschablone in der äußerst rechten Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die Form so, dass sie horizontal auf einer Linie mit der Entscheidung-Form liegt.

    Der Bindungs-Assistent für Skriptkomponenten wird geöffnet.

  2. Auf der Seite Willkommen beim Bindungs-Assistenten für Skriptkomponenten im Feld Neuen Port erstellen geben Sie ApprovalComponent (Genehmigungskomponente) ein, und klicken Sie dann auf Weiter.

  3. Überprüfen Sie auf der Seite Statische oder dynamische Kommunikation, ob Statisch ausgewählt ist, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der Seite Skriptdatei angeben auf Durchsuchen.

  5. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution auf dem BizTalk Server-Installationslaufwerk.

  6. Klicken Sie auf PORequestApproval.wsc, klicken Sie auf Öffnen und dann auf Weiter.

  7. Überprüfen Sie auf der Seite Informationen über Komponenteninstanziierung, ob Mit Programm-ID "BTSTutorial.PORequestApproval" ausgewählt ist, und klicken Sie dann auf Weiter.

  8. Auf der Seite Methodeninformationen klicken Sie auf Alle auswählen, und klicken Sie dann auf Weiter.

  9. Auf der Seite Erweiterte Porteigenschaften klicken Sie auf Fertig stellen.

Weiter mit Definieren von Nachrichteneigenschaften für die Skriptkomponente.


Definieren von Nachrichteneigenschaften für die Skriptkomponente

In diesem Verfahren verwenden Sie den Methodenkommunikations-Assistenten, um den Nachrichtenfluss von Aktion-Formen zur Skriptkomponente zu definieren. Eine detaillierte Beschreibung der einzelnen Schritte in diesem Prozess finden Sie unter Senden oder Empfangen synchroner Nachrichten.

  1. Markieren Sie die Send Denial-Aktion, und ziehen Sie das rechte Kontrollhandle zum ApprovalComponent-Skriptkomponentenport von Windows.

    Der Methodenkommunikations-Assistent wird geöffnet.

  2. Überprüfen Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten, ob Synchronen Methodenaufruf initiieren ausgewählt ist, und klicken Sie dann auf Weiter.

  3. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist, und klicken Sie dann auf Weiter.

  4. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation in der Liste Methoden auf SendDenial, und klicken Sie dann auf Fertig stellen.

  5. Markieren Sie die Send Approval-Aktion, und ziehen Sie den Kontrollhandle rechts neben der Send Approval-Aktion zum ApprovalComponent-Port.

    Der Methodenkommunikations-Assistent wird geöffnet.

  6. Überprüfen Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten, ob Synchronen Methodenaufruf initiieren ausgewählt ist, und klicken Sie dann auf Weiter.

  7. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist, und klicken Sie dann auf Weiter.

  8. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation in der Liste Methoden auf SendApproval, und klicken Sie dann auf Fertig stellen.

  9. Markieren Sie die Write PO Request to File-Aktion, und ziehen Sie den Kontrollhandle rechts neben der Write PO Request to File-Aktion zum ApprovalComponent-Port.

    Der Methodenkommunikations-Assistent wird geöffnet.

  10. Überprüfen Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten, ob Synchronen Methodenaufruf initiieren ausgewählt ist, und klicken Sie dann auf Weiter.

  11. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist, und klicken Sie dann auf Weiter.

  12. Überprüfen Sie auf der Seite Informationen über die Nachrichtenspezifikation in der Liste Methoden, ob WriteToFile ausgewählt ist, und klicken Sie dann auf Fertig stellen.

Weiter mit Schreiben des Skriptausdrucks für die Entscheidungsregel.


Schreiben des Skriptausdrucks für die Entscheidungsregel

Die Geschäftsregeln von Northwind Traders legen fest, dass eine Auftragsanforderung abgelehnt wird, wenn diese größer als €1000 ist. Die Nachricht muss dieser Geschäftsregel entsprechend weitergeleitet werden. Der XLANG-Ablaufplan leitet den Wert POTtl im Feld Total in der Auftragsanforderung an die Entscheidung-Form weiter. Der Skriptausdruck in der Entscheidungsregel verzweigt den Ablaufplanpfad und sendet die entsprechende Nachricht an die Portimplementierung, die die Windows-Skriptkomponente (WSC) verwendet. Die Ablehnungsentscheidungsregel enthält den Skriptausdruck, der das Verhalten der Entscheidung-Form definiert. Der Skriptausdruck wird auf TRUE oder FALSE ausgewertet und definiert auch die logischen Namen und Variablennamen, die von der Entscheidung-Form verwendet werden.

So schreiben Sie den Skriptausdruck:

  1. Klicken Sie unten auf der Seite auf die Registerkarte Daten.

    Die Seite Daten wird angezeigt.

  2. Zeigen Sie die POReq-Nachricht an, um den Feldnamen zu finden.

    Für das Schreiben des Skriptausdrucks sind sowohl der Nachrichtenname als auch der Feldname erforderlich. In diesem Fall lautet der Nachrichtenname POReq und der Feldname POTtl.

  3. Klicken Sie unten auf der Seite auf die Registerkarte Geschäftsprozess.

    Die Geschäftsprozessseite wird angezeigt.

  4. Klicken Sie mit der rechten Maustaste auf Entscheidung-Form, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld Entscheidungseigenschaften wird angezeigt.

  5. Überprüfen Sie, ob Denied ausgewählt ist, und klicken Sie dann auf Bearbeiten.

    Das Dialogfeld Eigenschaften der Regel wird angezeigt.

  6. Im Feld Skriptausdruck geben Sie POReq.POTtl > 1000 ein.

    Diese Eingabe gibt an, dass die Auftragsanforderung abgelehnt wird, wenn der Betrag im Feld Total der Anforderung größer als €1000 ist.

  7. Klicken Sie auf OK, um das Dialogfeld Eigenschaften der Regel zu schließen, und klicken Sie dann erneut auf OK, um das Dialogfeld Entscheidungseigenschaften zu schließen.

Die XLANG-Ablaufplanzeichnung sollte so wie in der folgenden Darstellung aussehen.

Weiter mit Definieren des Datenflusses.


Definieren des Datenflusses

Erstellen Sie Verbindungen zwischen den Feldern in den Nachrichtenformen auf der Datenseite, um den Datenfluss innerhalb des Geschäftsprozesses zu definieren. Die Verbindungen zeigen an, dass die im Dokumentfeld in POReq enthaltenen Daten an die Dokumentfelder in den Nachrichten SendDenial, SendApproval und WriteToFile übergeben werden. Der Datenfluss zwischen Nachrichten muss definiert werden, bevor Sie den XLANG-Ablaufplan kompilieren können. Eine detaillierte Beschreibung der Datenseite finden Sie unter Die Datenseite.

So definieren Sie den Datenfluss:

  1. Klicken Sie unten auf der Seite auf die Registerkarte Daten.

    Die Seite Daten wird angezeigt.

  2. Klicken Sie in der POReq-Nachricht auf das Feld Document, und ziehen Sie das Kontrollhandle auf der rechten Seite zu einem Verbindungspunkt auf dem Feld Document in der SendDenial_in-Nachricht.

  3. Wiederholen Sie Schritt 2, indem Sie auf das Feld Document klicken und dann den markierten Kontrollhandle rechts vom POReq-Feld zu einem Verbindungspunkt auf den folgenden Feldern ziehen:
    • Das Feld Document im Dialogfeld SendApproval_in.

    • Das Feld Document im Dialogfeld WriteToFile_in.

Anmerkung

  • Klicken Sie auf das Feld Document in der POReq-Nachricht, bevor Sie versuchen, das Kontrollhandle auf die anderen Felder zu ziehen.

Die fertige Datenseite sollte so wie in der folgenden Darstellung aussehen.

Weiter mit Speichern der XLANG-Ablaufplanzeichnung.


Speichern der XLANG-Ablaufplanzeichnung

  • Klicken Sie im Menü Datei auf Buyer1.skv speichern.

Weiter mit Kompilieren des XLANG-Ablaufplanes.


Kompilieren des XLANG-Ablaufplanes

In diesem Verfahren kompilieren Sie die XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan, der beim Empfang der Auftragsanforderung aktiviert wird. Wenn Sie eine XLANG-Ablaufplanzeichnung kompilieren, werden alle Probleme in der Zeichnung identifiziert. Weitere Informationen zum Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan finden Sie unter Kompilieren von XLANG-Ablaufplänen.

  1. Klicken Sie im Menü Datei auf XLANG Buyer1.skx erstellen.

    Das Dialogfeld XLANG-Ablaufplan speichern unter wird angezeigt.

  2. Stellen Sie sicher, dass der XLANG-Ablaufplan im Ordner \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk gespeichert wird, und klicken Sie dann auf Speichern.

  3. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Orchestrierungs-Designer zu schließen.

Weiter mit Ausführen des XLANG-Ablaufplanes.


Ausführen des XLANG-Ablaufplanes

In diesem Verfahren führen Sie eine Anwendung aus, die eine Auftragsanforderung an die ReceivePOReq-Warteschlange übermittelt und den XLANG-Ablaufplan aktiviert. Sie führen die Anwendung zweimal aus, um den in Unterrichtseinheit 1 erstellten Geschäftsprozess anzuzeigen. Wenn die Auftragsanforderung zum ersten Mal genehmigt wird, wird eine Nachricht gesendet und die Auftragsanforderung in eine Datei geschrieben. Bei der zweiten Ausführung der Anwendung wird die Auftragsanforderung abgelehnt, eine Nachricht gesendet und der Prozess beendet.

So führen Sie den XLANG-Ablaufplan aus:

  1. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk.

  2. Doppelklicken Sie auf ExecuteTutorial.exe.

    Diese Anwendung wird verwendet, um den XLANG-Ablaufplan mithilfe eines Monikers zu aktivieren.

    Die Anwendung ExecuteTutorial wird geöffnet.

  3. Klicken Sie auf Browse for Schedule.

    Verknüpfung

    • Sind BizTalk Server und all seine Komponenten auf Laufwerk C: installiert, können Sie den vorhandenen XLANG-Ablaufplan verwenden. Navigieren Sie zu \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution, und fahren Sie mit Schritt 5 fort.
  4. Wenn Sie den XLANG-Ablaufplan Buyer1 erstellt haben, wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab.

  5. Klicken Sie auf die XLANG-Ablaufplandatei Buyer1.skx und dann auf Öffnen.

  6. Klicken Sie auf Browse for Data File, und wechseln Sie zu \Programme\Microsoft BizTalk Server\Tutorial\Schedule\SampleData.

  7. Klicken Sie auf POReqAccept.xml und dann auf Öffnen.

  8. Klicken Sie auf Start XLANG Schedule.

    Da der Gesamtumfang der Auftragsanforderung unter €1000 liegt, wird sie genehmigt. Ein Feld wird mit der Meldung angezeigt, dass die Anwendung Daten an das XLANG-Ablaufplanungsmodul weitergeleitet hat. An dieser Stelle wird die Anwendung beendet. Ein zweites Meldungsfeld informiert Sie darüber, dass die Auftragsanforderung genehmigt wurde. Klicken Sie auf OK, um die Meldungsfelder zu schließen.

  9. Klicken Sie auf End (Ende), um die Anwendung ExecuteTutorial zu schließen.

    Wichtig

    • Wenn Sie beim Ausführen der Anwendung einen Automatisierungsfehler feststellen, überprüfen Sie, ob Sie die private Warteschlange richtig konfiguriert haben und der Name richtig ist.
  10. Wechseln Sie in das Verzeichnis C:\TutorialFiles\Buyer.

    Der Dateiname ist POReqXXXXX.xml, wobei XXXXX einen eindeutigen Zahlensatz darstellt. Doppelklicken Sie auf die Datei, um sie in Microsoft Internet Explorer zu öffnen. Dies ist eine Kopie der Auftragsanforderungsdatei, die die Anwendung an die Nachrichtenwarteschlange weitergeleitet hat. Nach dem Anzeigen der Datei löschen Sie sie.

  11. Wiederholen Sie die Schritte 1 bis 5, um die Anwendung ExecuteTutorial erneut auszuführen.

  12. Klicken Sie auf Browse for Data File, und wechseln Sie zu \Programme\Microsoft BizTalk Server\Tutorial\Schedule\SampleData.

  13. Klicken Sie auf POReqDeny.xml und dann auf Öffnen.

  14. Klicken Sie auf Start XLANG Schedule.

    Weil der Gesamtumfang €1000 überschreitet, wird die Auftragsanforderung abgelehnt. Ein Feld mit der Meldung, dass die Anwendung beendet wurde, wird angezeigt. Eine zweites Meldungsfeld informiert Sie darüber, dass die Dokumentenablehnung empfangen wurde. Klicken Sie auf OK, um die Meldungsfelder zu schließen.

  15. Klicken Sie auf End (Ende), um die Anwendung ExecuteTutorial zu schließen.

Die folgende Abbildung zeigt den Datenfluss beim Ausführen des XLANG-Ablaufplanes.

Weiter mit Zusammenfassung von Unterrichtseinheit 1.


Zusammenfassung von Unterrichtseinheit1

BizTalk Server 2002 ~ Lernprogramm

Zusammenfassung von Unterrichtseinheit 1

In dieser Unterrichtseinheit haben Sie Folgendes durchgeführt:

  • Die XLANG-Ablaufplanzeichnung erstellt, die den automatisierten Beschaffungsprozess beschreibt. Weitere Informationen finden Sie unter Erstellen von XLANG-Ablaufplanzeichnungen.

  • Die Aktionen in einer logischen Reihenfolge verbunden, die den Geschäftsprozess beschreibt. Weitere Informationen finden Sie unter Verbinden von Formen.

  • Den Geschäftsprozess durch das Verbinden von Aktionen mit Ports implementiert. Weitere Informationen finden Sie unter Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port.

  • Eine Regel zum Geschäftsprozess durch Schreiben eines Skriptausdrucks hinzugefügt. Weitere Informationen finden Sie unter Entwerfen von Regeln.

  • Den Datenfluss für Nachrichten definiert. Weitere Informationen finden Sie unter Kommunikationsformen.

  • Die XLANG-Ablaufplanzeichnung gespeichert und in den XLANG-Ablaufplan kompiliert. Weitere Information finden Sie unter Kompilieren von XLANG-Ablaufplänen.

  • Den XLANG-Ablaufplan zweimal ausgeführt, um die Auftragsanforderung in BizTalk Server zu verarbeiten, und die Genehmigungs- und Ablehnungsaktionen beobachtet. Weitere Informationen finden Sie unter Ausführen von XLANG-Ablaufplänen.

Der markierte Bereich der folgenden Abbildung zeigt, welche Schritte Sie in dieser Unterrichtseinheit durchgeführt haben.

Weiter mit Unterrichtseinheit 2: Erstellen von Spezifikationen und Zuordnungen.

Verwandtes Thema

Entwerfen von BizTalk-Orchestrierungen


Unterrichtseinheit2: Erstellen von Spezifikationen und Zuordnungen

BizTalk Server 2002 ~ Lernprogramm

Unterrichtseinheit 2: Erstellen von Spezifikationen und Zuordnungen

Nachdem Sie den Geschäftsprozess erstellt haben und wissen, wie der Kommunikationsfluss innerhalb dieses Modells funktioniert, müssen Sie die Struktur der Geschäftsdokumente festlegen, die gesendet und empfangen werden. Die Struktur der Geschäftsdokumente wird in XML-Schemas definiert, die auch als Spezifikationen bezeichnet werden. In dieser Unterrichtseinheit verwenden Sie den BizTalk-Editor, um Zahlungs- und Auftragsspezifikationen für den Käufer Northwind Traders zu erstellen.

Contoso, Ltd verwendet ein Standardschema für die Rechnung, die an Northwind Traders gesendet wird. Wenn Northwind Traders die Rechnung empfängt, müssen die Spezifikationen in Zahlungsspezifikationen konvertiert werden. Sie verwenden den BizTalk-Mapper zum Erstellen einer Zuordnung zwischen den Datensätzen und Feldern der Zahlungsspezifikationen, die Sie für Northwind Traders erstellen, und den CommonInvoice-Spezifikationen, die von Contoso, Ltd verwendet werden.

Lernziele

  • Erstellen einer Spezifikation. Weitere Informationen finden Sie unter Verwenden des BizTalk-Editors.

  • Hinzufügen von neuen Datensätzen und Feldern zu einer Spezifikation. Weitere Informationen finden Sie unter Hinzufügen neuer Felder zu Datensätzen.

  • Erstellen einer Zuordnung. Weitere Informationen finden Sie unter Verwenden des BizTalk-Mappers.

  • Erstellen von Verknüpfungen zwischen Feldern in einer Zuordnung. Weitere Informationen finden Sie unter Erstellen von Verknüpfungen.

  • Verwenden von Funktoiden, um Werte in einer Zuordnung mathematisch zu bearbeiten. Weitere Informationen finden Sie unter Grundlegendes zu Funktoiden.

  • Speichern von Spezifikationen und Zuordnungen im WebDAV-Repository (Web Distributed Authoring and Versioning). Weitere Informationen finden Sie unter Speichern von Spezifikationen und Speichern von Zuordnungen.

Weiter mit Verwenden des BizTalk-Editors.

Verwandtes Thema

Erstellen von Spezifikationen und Zuordnen von Daten


Verwenden des BizTalk-Editors

Sie verwenden den BizTalk-Editor, um Spezifikationen zu erstellen, zu bearbeiten und zu verwalten.

Zum Erstellen der Zahlungsspezifikation mithilfe des BizTalk-Editors weiter mit Erstellen der Zahlungsspezifikation.

Verknüpfung

  • Zum Verwenden der vorhandenen Zahlungsspezifikation weiter mit Verwenden der vorhandenen Zahlungsspezifikation.


Verwenden der vorhandenen Zahlungsspezifikation

  1. Kopieren Sie PaymentSpec.xml aus dem Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps auf dem BizTalk Server-Installationslaufwerk.

  2. Fügen Sie die Datei in das Verzeichnis \Programme\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft ein.

Zum Erstellen der Spezifikation für die Auftragsanforderung mithilfe des BizTalk-Editors weiter mit Erstellen der Auftragsanforderungsspezifikation.

Verknüpfung

  • Sind BizTalk Server und all seine Komponenten auf Laufwerk C: installiert, können Sie die vorhandene Auftragsanforderungsspezifikation verwenden. Weiter mit Verwenden der vorhandenen Auftragsanforderungsspezifikation.


Erstellen der Zahlungsspezifikation

In diesem Verfahren erstellen Sie ein XML-Schema bzw. Zahlungsspezifikationen, welche die Struktur und die Daten definieren, mit denen Northwind Traders eine Zahlung an Contoso, Ltd sendet. Weitere Informationen zu Spezifikationen finden Sie unter Grundlegendes zu Spezifikationen.

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Editor.

  2. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Neue Dokumentspezifikation wird angezeigt.

  3. Klicken Sie auf das Symbol Leere Spezifikation, und klicken Sie dann auf OK.

  4. Im Stammknoten klicken Sie auf LeereSpezifikation.

  5. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Zeile Name, geben Sie Payment (Zahlung) ein, und drücken Sie dann die EINGABETASTE.

  6. Doppelklicken Sie auf das Feld Wert in der Modell-Zeile, klicken Sie auf Offen, und drücken Sie dann die EINGABETASTE.

Weiter mit Hinzufügen von neuen Datensätzen zum Zahlungsstammknoten der Zahlungsspezifikation.


Hinzufügen von neuen Datensätzen zum Zahlungsstammknoten der Zahlungsspezifikation

  1. Klicken Sie mit der rechten Maustaste auf den Stammknoten Payment, und klicken Sie dann auf Neuer Datensatz.

  2. Benennen Sie diesen Datensatz PaymentHeader (Zahlungskopfzeile), und drücken Sie dann die EINGABETASTE.

  3. Wiederholen Sie die Schritte 1 und 2, um vier zusätzliche Datensätze unter dem Stammknoten Payment zu erstellen und zu benennen.

    Diese Datensätze sind untergeordnete Datensätze des Stammknotens Payment. Benennen Sie diese Datensätze wie folgt:

    • Seller

    • Buyer

    • Item

    • PaymentSummary

Weiter mit Hinzufügen neuer Datensätze zu vorhandenen Datensätzen in der Zahlungsspezifikation.


Hinzufügen neuer Datensätze zu vorhandenen Datensätzen in der Zahlungsspezifikation

  1. Klicken Sie mit der rechten Maustaste auf den Seller-Datensatz, und klicken Sie dann auf Neuer Datensatz.

  2. Nennen Sie diesen Datensatz Address (Adresse), und drücken Sie dann die EINGABETASTE.

  3. Wiederholen Sie die Schritte 1 und 2, um untergeordnete Datensätze für die in der folgenden Tabelle aufgelisteten übergeordneten Datensätze zu erstellen.
    Übergeordneter Datensatz | Name des untergeordneten Datensatzes
    Seller | ContactInfo
    Buyer | Address
    Buyer | ContactInfo

Weiter mit Hinzufügen neuer Felder zu vorhandenen Datensätzen in der Zahlungspezifikation.


Hinzufügen neuer Felder zu vorhandenen Datensätzen in der Zahlungspezifikation

  1. Klicken Sie mit der rechten Maustaste auf den PaymentHeader-Datensatz, und klicken Sie dann auf Neues Feld.

  2. Benennen Sie das Feld PONumber (Auftragsnummer), und drücken Sie die EINGABETASTE.

  3. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Datentyp-Zeile, klicken Sie auf String, und drücken Sie dann die EINGABETASTE.

  4. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Minimallänge-Zeile, geben Sie 1 ein, und drücken Sie dann die EINGABETASTE.

  5. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Maximallänge-Zeile, geben Sie 22 ein, und drücken Sie dann die EINGABETASTE.

  6. Wiederholen Sie die Schritte 1 bis 5, um für die in der folgenden Tabelle aufgeführten Datensätze oder untergeordneten Datensätze Felder zu erstellen.

    Jeder Datensatz enthält mehrere Felder.

    Sie müssen diese Felder nicht für den Käufer erstellen, weil für den Käufer und den Verkäufer parallele Datensatznamen vorhanden sind. Alle Datensätze mit dem gleichen Namen enthalten dieselben Datensatz- und Feldinformationen. Wenn Sie neue Felder zu den Datensätzen Seller/Address oder Seller/ContactInfo hinzufügen, werden die Datensätze Buyer/Address oder Buyer/ContactInfo automatisch mit denselben Feldern aktualisiert.

    Übergeordneter Datensatz | Feldname | Datentyp | Minimallänge | Maximallänge
    PaymentHeader | Date | Date | Nicht anwendbar | Nicht anwendbar
    Seller/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Seller/ContactInfo | Name | String | 1 | 60
    Number | String | 1 | 60
    Item | Quantity | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Price | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Description | String | 1 | 80
    ExtendedPrice | Real(r4) | Nicht anwendbar | Nicht anwendbar
    PaymentSummary | Total | Real(r4) | Nicht anwendbar | Nicht anwendbar

Weiter mit Speichern der Zahlungsspezifikation in WebDAV.


Speichern der Zahlungsspezifikation in WebDAV

Wenn Sie eine Datei in WebDAV speichern, wird sie auf dem Server anstatt auf dem lokalen Laufwerk gespeichert. WebDAV sperrt Dokumente, damit Benutzer nicht aus Versehen die Änderungen anderer Benutzer überschreiben. Es ermöglicht Benutzern die gemeinsame Bearbeitung serverbasierter Dokumente, unabhängig vom Dokumenterstellungstool, der Plattform oder des Webservertyps, auf dem die Dateien gespeichert sind. Im folgenden Verfahren überprüfen Sie außerdem die Dokumentinstanz. Ist die Dokumentinstanz nicht gültig, zeigt die Registerkarte Warnung dies zusammen mit den Fehlern an, die auf den Grund hinweisen.

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

    Das Dialogfeld In WebDAV speichern wird angezeigt.

  2. Doppelklicken Sie auf den Ordner Microsoft.

  3. Im Feld Dateiname geben Sie PaymentSpec (Zahlungsspezifikation) ein, und klicken Sie dann auf Speichern.

  4. Klicken Sie im Menü Extras auf Instanz überprüfen.

    Das Dialogfeld Dokumentinstanz überprüfen wird angezeigt.

  5. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk.

  6. Klicken Sie auf payment_valid.xml, und klicken Sie dann auf Öffnen.

    Warnungen oder Fehler werden gegebenenfalls auf der Registerkarte Warnungen angezeigt. Wählen Sie die Warnungsmeldung aus, um einen Fehler zu beheben.

Die Zahlungsspezifikation sollte so wie in der folgenden Darstellung aussehen.

Zum Erstellen der Auftragsanforderungsspezifikation mithilfe des BizTalk-Editors fahren Sie mit Erstellen der Auftragsanforderungsspezifikation fort.

Verknüpfung

  • Sind BizTalk Server und all seine Komponenten auf Laufwerk C: installiert, können Sie die vorhandene Auftragsanforderungsspezifikation verwenden. Weiter mit Verwenden der vorhandenen Auftragsanforderungsspezifikation.


Verwenden der vorhandenen Auftragsanforderungsspezifikation

  1. Kopieren Sie POReq.xml aus dem Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps auf dem BizTalk Server-Installationslaufwerk.

  2. Fügen Sie die Datei in das Verzeichnis \Programme\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft ein.

Weiter mit Verwenden des BizTalk-Mappers.


Erstellen der Auftragsanforderungsspezifikation

In diesem Verfahren erstellen Sie den Stammknoten der Auftragsanforderungsspezifikation. Die Auftragsanforderungsspezifikation definiert die Struktur und die Daten, mit denen Northwind Traders eine Auftragsanforderung zur Genehmigung sendet.

So erstellen Sie den Stammknoten:

  1. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Neue Dokumentspezifikation wird angezeigt.

  2. Klicken Sie auf das Symbol Leere Spezifikation, und klicken Sie dann auf OK.

  3. Im Stammknoten klicken Sie auf LeereSpezifikation.

  4. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Zeile Name, geben Sie POReq ein, und drücken Sie dann die EINGABETASTE.

  5. Doppelklicken Sie auf das Feld Wert in der Modell-Zeile, klicken Sie auf Offen, und drücken Sie dann die EINGABETASTE.

Weiter mit Hinzufügen neuer Datensätze zum Stammknoten in der Auftragsanforderungsspezifikation.


Hinzufügen neuer Datensätze zum Stammknoten in der Auftragsanforderungsspezifikation

  1. Klicken Sie mit der rechten Maustaste auf den Stammknoten POReq, und klicken Sie dann auf Neuer Datensatz.

  2. Benennen Sie diesen Datensatz Header (Kopfzeile), und drücken Sie dann die EINGABETASTE.

  3. Wiederholen Sie die Schritte 1 und 2, um fünf zusätzliche Datensätze unter dem Stammknoten POReq zu erstellen und zu benennen.

    Diese Datensätze sind untergeordnete Datensätze des Stammknotens POReq. Benennen Sie diese Datensätze wie folgt:

    • EmployeeInfo

    • BillTo (RechnungAn)

    • ShipTo (LiefernAn)

    • Item

    • Total

Weiter mit Hinzufügen von neuen Datensätzen zu vorhandenen Datensätze in der Auftragsanforderungsspezifikation.


Hinzufügen von neuen Datensätzen zu vorhandenen Datensätze in der Auftragsanforderungsspezifikation

  1. Klicken Sie mit der rechten Maustaste auf den BillTo-Datensatz, und klicken Sie dann auf Neuer Datensatz.

  2. Nennen Sie diesen Datensatz Address (Adresse), und drücken Sie dann die EINGABETASTE.

  3. Wiederholen Sie die Schritte 1 und 2, um für den übergeordneten Datensatz ShipTo einen untergeordneten Datensatz Address zu erstellen und zu benennen.

Weiter mit Hinzufügen von neuen Feldern zu vorhandenen Datensätzen in der Auftragsanforderungsspezifikation.


Hinzufügen von neuen Feldern zu vorhandenen Datensätzen in der Auftragsanforderungsspezifikation

  1. Klicken Sie mit der rechten Maustaste auf den Header-Datensatz, und klicken Sie dann auf Neues Feld.

  2. Benennen Sie dieses Feld Date, und drücken Sie dann die EINGABETASTE.

  3. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Datentyp-Zeile, klicken Sie auf Date, und drücken Sie dann die EINGABETASTE.

  4. Klicken Sie mit der rechten Maustaste auf den EmployeeInfo-Datensatz, und klicken Sie dann auf Neues Feld.

  5. Benennen Sie dieses Feld EmpID, und drücken Sie dann die EINGABETASTE.

  6. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Datentyp-Zeile, klicken Sie auf String, und drücken Sie dann die EINGABETASTE.

  7. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Minimallänge-Zeile, geben Sie 1 ein, und drücken Sie dann die EINGABETASTE.

  8. Doppelklicken Sie auf der Registerkarte Deklaration auf das Feld Wert in der Maximallänge-Zeile, geben Sie 60 ein, und drücken Sie dann die EINGABETASTE.

  9. Wiederholen Sie die Schritte 4 bis 8, um für die in der folgenden Tabelle aufgeführten Datensätze oder untergeordneten Datensätze Felder zu erstellen.

    Jeder Datensatz enthält mehrere Felder.

    Sie müssen diese Felder nicht für ShipTo erstellen, weil für BillTo und ShipTo parallele Datensatznamen vorhanden sind. Alle Datensätze mit dem gleichen Namen enthalten dieselben Datensatz- und Feldinformationen. Wenn Sie zum BillTo/Address-Datensatz neue Felder hinzufügen, wird der ShipTo/Address-Datensatz automatisch mit denselben Feldern aktualisiert.

    Übergeordneter Datensatz | Feldname | Datentyp | Minimallänge | Maximallänge
    EmployeeInfo | LastName (Nachname) | String | 1 | 30
    FirstName (Vorname) | String | 1 | 30
    BillTo/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Item | Quantity | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Price | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Description | String | 1 | 80
    UnitofMeasure (Maßeinheit) | String | 2 | 2
    ExtendedPrice | Real(r4) | Nicht anwendbar | Nicht anwendbar
    Total | LineItemTtl | Real(r4) | Nicht anwendbar | Nicht anwendbar
    QtyTtl | Real(r4) | Nicht anwendbar | Nicht anwendbar
    POTtl | Real(r4) | Nicht anwendbar | Nicht anwendbar

Weiter mit Speichern der Auftragsanforderungsspezifikation.


Speichern der Auftragsanforderungsspezifikation

Wie auch im vorherigen Verfahren Speichern der Zahlungsspezifikation in WebDAV sollten Sie die Datei in WebDAV anstatt auf dem lokalen Laufwerk speichern.

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

    Das Dialogfeld In WebDAV speichern wird angezeigt.

  2. Überprüfen Sie, ob der Ordner Microsoft geöffnet ist.

  3. Im Feld Dateiname geben Sie POReq ein, und klicken Sie dann auf Speichern.

  4. Klicken Sie im Menü Extras auf Instanz überprüfen.

    Das Dialogfeld Dokumentinstanz überprüfen wird angezeigt.

  5. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\SampleData auf dem BizTalk Server-Installationslaufwerk.

  6. Klicken Sie auf POReqAccept.xml und dann auf Öffnen.

    Warnungen oder Fehler werden gegebenenfalls auf der Registerkarte Warnungen angezeigt.

    Die Auftragsanforderungsspezifikation sollte so wie in der folgenden Abbildung aussehen.

  7. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Editor zu schließen.

Weiter mit Verwenden des BizTalk-Mappers.


Verwenden des BizTalk-Mappers

In diesem Verfahren erstellen Sie mithilfe des BizTalk-Mappers eine Zuordnung. Diese Zuordnung transformiert die Daten aus einer Nachricht, die mit den Spezifikationen von CommonInvoice (Standardrechnung) übereinstimmt, in Daten einer Nachricht, die mit den Spezifikationen von PaymentSpec übereinstimmt, die Sie für den Käufer Northwind Traders erstellt haben.

In der nächsten Unterrichtseinheit erfahren Sie, wie BizTalk-Messagingdienste diese Zuordnung in einem Kanal verwenden, um anzugeben, wie Daten in einem Dokument, das ein XML-Schema verwendet, in ein Dokument umgewandelt werden, das ein anderes XML-Schema verwendet.

Wenn Sie die Übersichtsabbildung vom Anfang dieses Lernprogramms ausgedruckt haben, sollten Sie die visuelle Darstellung dieses Prozesses betrachten, der im unteren Bereich der Zeichnung unter "BizTalk-Messagingdienste" dargestellt wird.

Zum Erstellen der Zuordnung mithilfe des BizTalk-Mappers fahren Sie mit Erstellen der InvoiceToPayment-Zuordnung fort.

Verknüpfung

  • Sind BizTalk Server und all seine Komponenten auf Laufwerk C: installiert, können Sie die vorhandene Zuordnung verwenden. Weiter mit Verwenden der vorhandenen InvoiceToPayment-Zuordnung.


Verwenden der vorhandenen InvoiceToPayment-Zuordnung

  1. Kopieren Sie InvoiceToPayment.xml aus dem Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps auf dem BizTalk Server-Installationslaufwerk.

  2. Fügen Sie die Datei in das Verzeichnis \Programme\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft ein.

Weiter mit Unterrichtseinheit 3: Konfigurieren der BizTalk-Messagingdienste.


Erstellen der InvoiceToPayment-Zuordnung

Vor Erstellen der Zuordnung müssen Sie als Quellspezifikation CommonInvoice.xml öffnen und als Zielspezifikation PaymentSpec.xml.

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Mapper.

  2. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Quellspezifikationstyp auswählen wird angezeigt.

  3. Klicken Sie auf das Symbol WebDAV-Dateien und dann auf OK.

    Das Dialogfeld Quellspezifikation abrufen wird angezeigt.

  4. Doppelklicken Sie auf den Ordner Microsoft.

  5. Klicken Sie auf CommonInvoice.xml und dann auf Öffnen.

    Das Dialogfeld Zielspezifikationstyp auswählen wird angezeigt.

  6. Klicken Sie auf das Symbol WebDAV-Dateien und dann auf OK.

  7. Klicken Sie auf PaymentSpec.xml und dann auf Öffnen.

Weiter mit Erstellen von Verknüpfungen zwischen Feldern.


Erstellen von Verknüpfungen zwischen Feldern

In dem folgenden Verfahren verknüpfen Sie Felder aus der Quellspezifikation mit Feldern in der Zielspezifikation. Verknüpfungen übernehmen die grundlegende Funktion, Daten aus Datensätzen und Feldern der Quellspezifikationsstruktur in Datensätze und Felder der Zielspezifikationsstruktur zu kopieren.

So erstellen Sie Verknüpfungen zwischen Feldern:

  1. Erweitern Sie in der Quellspezifikationsstruktur den InvoiceHeader-Datensatz (Rechnungskopfzeile), um die zugeordneten Felder anzuzeigen.

    Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

  2. Erweitern Sie in der Zielspezifikationsstruktur den PaymentHeader-Datensatz, um die zugeordneten Felder anzuzeigen.

  3. Ziehen Sie das Feld InvoiceHeader/Date aus der Quellspezifikationsstruktur zum Feld PaymentHeader/Date in der Zielspezifikationsstruktur.

  4. Wiederholen Sie die Schritte 1 bis 3, um Verknüpfungen zwischen den in den folgenden Tabellen aufgeführten Feldern zu erstellen.
    Quelldatensatz/Feld | Zieldatensatz/Feld
    InvoiceHeader/Number | PaymentHeader/PONumber

    Seller/Address/Name | Seller/Address/Name
    Seller/Address/Address1 | Seller/Address/Address1
    Seller/Address/Address2 | Seller/Address/Address2
    Seller/Address/City | Seller/Address/City
    Seller/Address/State | Seller/Address/State
    Seller/Address/PostalCode | Seller/Address/Zip
    Seller/Address/Country | Seller/Address/Country

    Seller/ContactInfo/ContactName | Seller/ContactInfo/Name
    Seller/ContactInfo/ContactNumber | Seller/ContactInfo/Nummer

    Buyer/Address/Name | Buyer/Address/Name
    Buyer/Address/Address1 | Buyer/Address/Address1
    Buyer/Address/Address2 | Buyer/Address/Address2
    Buyer/Address/City | Buyer/Address/City
    Buyer/Address/State | Buyer/Address/State
    Buyer/Address/PostalCode | Buyer/Address/Zip
    Buyer/Address/Country | Buyer/Address/Country

    Buyer/ContactInfo/ContactName | Buyer/ContactInfo/Name
    Buyer/ContactInfo/ContactNumber | Buyer/ContactInfo/Number

    Item/ItemHeader/Quantity | Item/Quantity
    Item/ItemHeader/Price | Item/Price
    Item/ItemDescription/Description | Item/Description

    InvoiceSummary/InvoiceTotal/Amount PaymentSummary/Total

Weiter mit Verwenden von Funktoiden zum Erstellen von Verknüpfungen.


Verwenden von Funktoiden zum Erstellen von Verknüpfungen

In diesem Verfahren verwenden Sie ein Funktoid, um das Mengenfeld mit dem Preisfeld in der Quellspezifikation zu multiplizieren und diesen Wert in das Feld ExtendedPrice in der Zielspezifikation einzufügen.

So verwenden Sie Funktoide zum Erstellen von Verknüpfungen:

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

    Die Funktoidpalette wird angezeigt.

  2. Klicken Sie auf die Registerkarte Mathematisch, ziehen Sie das Funktoid Multiplikation Funktoid "Multiplikation" auf das Zuordnungsraster, und schließen Sie dann die Funktoidpalette.

  3. Ziehen Sie in der Quellspezifikationsstruktur das Feld Item/ItemHeader/Quantity zum Funktoid.

  4. Ziehen Sie in der Quellspezifikationsstruktur das Feld Item/ItemHeader/Price zum Funktoid.

  5. Ziehen Sie das Funktoid Multiplikation zum Feld Item/ExtendedPrice in der Zielspezifikationsstruktur.

Weiter mit Kompilieren der Zuordnung.


Kompilieren der Zuordnung

Sie müssen eine Zuordnung vor der Verwendung kompilieren, damit Sie Warnungen oder Fehler beheben können.

  1. Klicken Sie im Menü Extras auf Zuordnung kompilieren.

  2. Klicken Sie im unteren Bereich auf die Registerkarte Ausgabe.

    Die Informationen auf der Registerkarte Ausgabe zeigen an, dass eine XSL-Zuordnung erstellt wurde. Warnungen oder Fehler werden gegebenenfalls auf der Registerkarte Warnungen angezeigt.

Weiter mit Speichern der Zuordnung in WebDAV.


Speichern der Zuordnung in WebDAV

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

    Das Dialogfeld In WebDAV speichern wird angezeigt.

  2. Doppelklicken Sie auf den Ordner Microsoft.

  3. Im Feld Dateiname geben Sie InvoiceToPayment (RechnungAnZahlung) ein, und klicken Sie dann auf Speichern.

    Die von Ihnen erstellte Zuordnung sollte so wie in der folgenden Darstellung aussehen.

  4. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Mapper zu schließen.

Weiter mit Zusammenfassung von Unterrichtseinheit 2.


Zusammenfassung von Unterrichtseinheit2

BizTalk Server 2002 ~ Lernprogramm

Zusammenfassung von Unterrichtseinheit 2

In dieser Unterrichtseinheit haben Sie Folgendes durchgeführt:

  • Eine Spezifikation erstellt. Weitere Informationen finden sie unter Grundlegendes zu Spezifikationen.

  • Neue Datensätze und Felder zu einer Spezifikation hinzugefügt. Weitere Informationen finden Sie unter Hinzufügen neuer Felder zu Datensätzen.

  • Eine Zuordnung erstellt. Weitere Informationen finden Sie unter Verwenden des BizTalk-Mappers.

  • Zwischen Feldern in einer Zuordnung Verknüpfungen erstellt. Weitere Informationen finden Sie unter Erstellen von Verknüpfungen.

  • Funktoide verwendet, um Werte in einer Zuordnung mathematisch zu bearbeiten. Weitere Informationen finden Sie unter Grundlegendes zu Funktoiden.

  • Spezifikationen und Zuordnungen im WebDAV-Repository gespeichert. Weitere Informationen finden Sie unter Speichern von Spezifikationen und Speichern von Zuordnungen.

Der markierte Bereich der folgenden Abbildung zeigt, welche Schritte Sie in dieser Unterrichtseinheit durchgeführt haben.

Weiter mit Unterrichtseinheit 3: Konfigurieren der BizTalk-Messagingdienste.

Verwandtes Thema

Erstellen von Spezifikationen und Zuordnen von Daten


Unterrichtseinheit3: Konfigurieren der BizTalk-Messagingdienste

BizTalk Server 2002 ~ Lernprogramm

Unterrichtseinheit 3: Konfigurieren der BizTalk-Messagingdienste

An diesem Punkt des Lernprogramms haben Sie den Geschäftsprozess und den Kommunikationsfluss entworfen und die Struktur der Dokumente, die gesendet und empfangen werden, festgelegt. Der nächste Schritt besteht im Konfigurieren der BizTalk-Messagingdienste auf den Käufer- und Verkäufersystemen, damit die Dokumente gesendet und empfangen werden können.

In dieser Unterrichtseinheit lernen Sie, wie der BizTalk-Messaging-Manager verwendet wird, um Organisationen, Kanäle und Messagingports für Verkäufer- und Käufersysteme zu konfigurieren. Sie lernen darüber hinaus auch die Verwendung der BizTalk Server-Verwaltung für die Konfiguration einer Dateiempfangsfunktion kennen.

Lernziele

  • Erstellen der Dokumentdefinitionen. Weitere Informationen finden Sie unter Erstellen und Verwalten von Dokumentdefinitionen.

  • Erstellen von Organisationen. Weitere Informationen finden Sie unter Erstellen und Verwalten von Organisationen.

  • Erstellen von Messagingports. Weitere Informationen finden Sie unter Erstellen und Verwalten von Messagingports und Integrieren der BizTalk-Dienste.

  • Erstellen von Kanälen. Weitere Informationen finden Sie unter Erstellen und Verwalten von Kanälen.

  • Verwenden einer Zuordnung in einem Kanal, um ein Dokument zu transformieren. Weitere Informationen finden Sie unter Verwenden des BizTalk-Mappers.

  • Erstellen einer Empfangsfunktion. Weitere Informationen finden Sie unter Empfangsfunktionen.

Weiter mit Konfigurieren des Käufersystems.

Verwandtes Thema

Verwenden des BizTalk-Messaging-Managers


Konfigurieren des Käufersystems

Sie verwenden den BizTalk-Messaging-Manager, um Organisationen zu erstellen, die Handelspartner darstellen.

Zum Konfigurieren des Northwind Traders-System mithilfe des BizTalk-Messaging-Managers fahren Sie mit Erstellen der Organisationen für das Käufersystem fort.

Verknüpfung

  • Sind BizTalk Server und all seine Komponenten auf Laufwerk C: installiert, können Sie ein Skript verwenden, um das Northwind Traders-System zu konfigurieren. Weiter mit Konfigurieren des Käufersystems mithilfe eines Konfigurationsskripts.


Konfigurieren des Käufersystems mithilfe eines Konfigurationsskripts

Dieses Skript konfiguriert Folgendes:

  • Eine Quellorganisation mit dem Namen Northwind Traders on Buyer auf dem Käufersystem.

  • Eine Zielorganisation mit dem Namen Contoso on Buyer auf dem Käufersystem.

  • Vier Dokumentdefinitionen, die auf Spezifikationen für CommonPO, CommonInvoice, PaymentSpec und POReq verweisen.

  • Einen Messagingport und einen Kanal, die die Bewegungen einer Auftragsanforderung vom Käufersystem zum Verkäufersystem definieren, indem sie einen HTTP-Transportdienst zu einer ASP-Datei auf dem Verkäufersystem verwenden.

  • Einen Messagingport und einen Kanal, die die Bewegungen einer Rechnung definieren, die zum Kunden übermittelt wurde, und sie in ein Zahlungsdokument auf dem Verkäufersystem transformieren.

Vorsicht

  • Wenn Sie den BizTalk-Messaging-Manager und die BizTalk Server-BizTalk Server-Verwaltung verwendet haben, um das Käufersystem zu konfigurieren, führen Sie das Konfigurationsskript nicht aus.

So führen Sie das Skript aus, das die BizTalk-Messagingdienste für das Käufersystem konfiguriert:

  1. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Setup\MessagingConfigurationScript auf dem BizTalk Server-Installationslaufwerk.

  2. Doppelklicken Sie auf ConfigureBuyer.VBS.

    Ein Meldungsfeld zeigt an, dass der Vorgang erfolgreich durchgeführt wurde.

Weiter mit Konfigurieren des Verkäufersystems.


Erstellen der Organisationen für das Käufersystem

Der BizTalk-Messaging-Manager wird verwendet, um den Austausch von Dokumenten über das Konfigurieren von BizTalk-Messagingdiensten zu verwalten. Verwenden Sie den BizTalk-Messaging-Manager, um die BizTalk-Messagingdienste vor dem Verarbeiten von Dokumenten zu konfigurieren. Die von Ihnen erstellten Organisationen dienen als Quelle für einen Kanal oder als Ziel für einen Messagingport. Messagingport und Kanal definieren den Dokumentenverkehr zwischen Handelspartnern. Weitere Informationen finden Sie unter Grundlegendes zu Organisationen.

In diesem Verfahren erstellen Sie die Quellorganisation Northwind Traders und die Zielorganisation Contoso, Ltd auf dem System von Northwind Traders.

Wichtig

  • Wenn Sie das Konfigurationsskript verwendet haben, konfigurieren Sie das Käufersystem nicht mithilfe des BizTalk-Messaging-Managers und der BizTalk Server-Verwaltung. Weiter mit Konfigurieren des Verkäufersystems.

So erstellen Sie die Organisationen auf dem Northwind Traders-System:

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Wenn das Dialogfeld BizTalk-Messaging-Manager angezeigt wird, klicken Sie auf Abbrechen.

  3. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Organisation.

    Das Dialogfeld Neue Organisation wird angezeigt.

  4. Im Feld Organisationsname geben Sie Contoso on Buyer ein, und klicken Sie dann auf OK.

  5. Wiederholen Sie die Schritte 3 und 4, und nennen Sie die neue Organisation Northwind Traders on Buyer.

Weiter mit Erstellen der Dokumentdefinitionen für die Käufer- und Verkäufersysteme.


Erstellen der Dokumentdefinitionen für die Käufer- und Verkäufersysteme

In diesem Verfahren erstellen Sie vier Dokumentdefinitionen, die sich auf die Dokumentspezifikationen CommonInvoice, CommonPO, PaymentSpec und POReq beziehen. Käufer- und Verkäufersystem verwenden diese Dokumentdefinitionen gemeinsam, so dass beide Systeme das zwischen den Systemen übertragene Geschäftsdokument verstehen. Eine Dokumentdefinition stellt den Typ eines eingehenden bzw. ausgehenden Dokuments in einem Kanal dar und stellt einen Verweis auf die entsprechende Spezifikation bereit. Weitere Informationen finden Sie unter Grundlegendes zu Dokumentdefinitionen.

So erstellen Sie die Dokumentdefinitionen:

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Dokumentdefinition.

    Das Dialogfeld Neue Dokumentdefinition wird angezeigt.

  2. Im Feld Dokumentdefinitionsname geben Sie Purchase Order (Auftrag) ein.

  3. Aktivieren Sie das Kontrollkästchen Dokumentspezifikation, und klicken Sie auf Durchsuchen.

    Das Dialogfeld Dokumentspezifikation aus dem WebDAV-Repository auswählen wird angezeigt.

  4. Doppelklicken Sie auf den Ordner Microsoft.

  5. Klicken Sie auf CommonPO.xml und dann auf Öffnen.

  6. Klicken Sie auf OK, um das Dialogfeld Neue Dokumentdefinition zu schließen.

  7. Wiederholen Sie die Schritte 1 bis 6, um neue Dokumentdefinitionen mit den folgenden Abweichungen zu erstellen:
Name der Dokumentdefinition | Dokumentspezifikation
Invoice | CommonInvoice.xml
Purchase Order Request | POReq.xml
Payment | PaymentSpec.xml

Weiter mit Erstellen eines Messagingports zu Contoso, Ltd für das Käufersystem.


Erstellen eines Messagingports zu Contoso, Ltd für das Käufersystem

In diesem Verfahren erstellen Sie einen Messagingport für das Käufersystem. Ein Messagingport definiert das Ziel für ein Dokument.

Wenn in diesem Szenario eine Auftragsanforderung angenommen wird, suchen die BizTalk-Messagingdienste den geeigneten Kanal, um diese zu verarbeiten. Nach dem Verarbeiten des Dokuments verweist der Kanal den Server an den ihm zugeordneten Messagingport, der den Server durch die Abfolge der erforderlichen Schritte führt, um das Dokument an das angegebene Ziel zu transportieren. Die Zielorganisation des Messagingports, den Sie in diesem Verfahren erstellen, ist Contoso on Buyer. Sie erstellen den Kanal, nachdem Sie den Messagingport erstellt haben.

Die Transporteigenschaften, die für einen Messagingport angegeben werden, ermitteln den Transportdienst, der verwendet wird, um Dokumente an die Zielorganisation oder die Zielanwendung zu übermitteln, sowie die genaue Adresse, an die Dokumente gesendet werden. Für diesen Messagingport geben Sie den HTTP-Transportdienst an, mit dem Dokumente an eine ASP-Datei in der Website von Contoso übermittelt werden.

So erstellen Sie den Messagingport:

  1. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Messagingport, und klicken Sie dann auf Zu einer Organisation.

    Der Messagingport-Assistent wird geöffnet.

  2. Im Feld Name geben Sie Port to Contoso via HTTP (Port zu Contoso via HTTP) ein und klicken dann auf Weiter.

  3. Auf der Seite Zielorganisationsname im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  4. Klicken Sie auf Contoso on Buyer, und klicken Sie dann auf OK.

  5. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. In der Liste Transporttyp klicken Sie auf HTTP.

  7. Im Feld Adresse nach dem Präfix http:// geben Sie Name Ihres Computers ein, gefolgt von /SubmitPO/SubmitNorthwindPO.asp, klicken Sie anschließend auf OK und dann auf Weiter.

    Wird diese Nachricht z. B. an eine ASP in der Website von Contoso übermittelt, können Sie http://ContosoLtd/SubmitPO/SubmitNorthwindPO.asp eingeben.

    Führen Sie folgende Schritte durch, um den Namen Ihres Computers zu finden:

    1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

    2. Doppelklicken Sie auf Verwaltung.

    3. Doppelklicken Sie auf Computerverwaltung.

      Die Konsole der Computerverwaltung wird angezeigt.

    4. Klicken Sie im Menü Vorgang auf Eigenschaften.

      Das Dialogfeld Eigenschaften von Computerverwaltung (Lokal) wird angezeigt.

    5. Klicken Sie auf die Registerkarte Netzwerkidentifikation.

      Der Name Ihres Computers wird im Feld Computername angezeigt.

  8. Klicken Sie auf der Seite Umschlagsinformationen auf Weiter.

  9. Überprüfen Sie auf der Seite Sicherheitsinformationen, ob das Kontrollkästchen Kanal für diesen Messagingport erstellen aktiviert ist.

  10. Klicken Sie in der Liste Kanaltyp auf Von einer Organisation, und klicken Sie dann auf Fertig stellen.

    Der Kanal-Assistent wird geöffnet.

Weiter mit Erstellen eines Kanals von Northwind Traders für das Käufersystem.


Erstellen eines Kanals von Northwind Traders für das Käufersystem

Wenn Sie den Messagingport erstellt haben, müssen Sie den Kanal definieren, der dem Messagingport zugeordnet ist. In diesem Kanal wird die Quelle des Dokuments als Northwind Traders on Buyer identifiziert und angegeben, dass es sich bei dem eingehenden Dokument um eine Auftragsanforderung und bei dem ausgehenden Dokument um einen Auftrag handelt. Wir verwenden die Zuordnung POReqtoPO.xml, um das Dokument von einer Auftragsanforderung in einen Auftrag umzuwandeln. Weitere Informationen finden Sie unter Grundlegendes zu Kanälen.

Wenn Sie die Übersichtsabbildung vom Anfang dieses Lernprogramms ausgedruckt haben, sollten Sie die visuelle Darstellung von Kanal und Messagingport betrachten, die in diesen Verfahren erstellt wurden.

So erstellen Sie den Kanal:

  1. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Channel for POReq to PO (Kanal für Auftragsanforderung an Auftrag) ein, und klicken Sie dann auf Weiter.

  2. Klicken Sie auf der Seite Quellorganisation auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf Northwind Traders on Buyer, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  4. Auf der Seite Eingehendes Dokument klicken Sie rechts vom Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  5. Klicken Sie auf Purchase Order Request, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  6. Auf der Seite Ausgehendes Dokument klicken Sie rechts vom Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  7. Klicken Sie auf Purchase Order, und klicken Sie dann auf OK.

  8. Überprüfen Sie, ob das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen aktiviert ist.

  9. Klicken Sie rechts vom Feld Verweis zuordnen auf Durchsuchen.

    Das Dialogfeld Eine Zuordnung aus dem WebDAV-Repository auswählen wird angezeigt.

  10. Doppelklicken Sie auf den Ordner Microsoft.

  11. Klicken Sie auf POReqtoPO.xml, klicken Sie auf Öffnen und dann auf Weiter.

  12. Klicken Sie auf der Seite Dokumentprotokollierung auf Weiter.

  13. Klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen.

Weiter mit Erstellen eines Messagingports zu Contoso, Ltd innerhalb des Käufersystems.


Erstellen eines Messagingports zu Contoso, Ltd innerhalb des Käufersystems

Dieses Verfahren ist ein Beispiel zur Verwendung des Dateitransportdienstes. Da sich das Käufer- und das Verkäufersystem auf demselben Computer befinden, können wir das Übermitteln einer Datei an einen Standort auf dem System des Verkäufers simulieren. In den meisten Fällen besitzt der Käufer jedoch keine Zugriffsberechtigungen, um eine Datei auf dem System des Verkäufers platzieren zu können. Im Allgemeinen wird zum Senden von Dokumenten an einen Handelspartner ein anderer Transportmechanismus verwendet, z. B. HTTP.

In diesem Verfahren versendet der Messagingport mithilfe des Dateitransportdienstes vom Northwind Traders-System verarbeitete Dokumente an das System von Contoso, Ltd. Die Dokumente werden an den in der Zieladresse des Messagingports angegebenen Ordner (C:\TutorialFiles\Seller) gesendet.

So erstellen Sie den Messagingport:

  1. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Messagingport, und klicken Sie dann auf Zu einer Organisation.

    Der Messagingport-Assistent wird geöffnet.

  2. Im Feld Name geben Sie Port to Contoso via Local File (Port zu Contoso über lokale Datei) ein, und klicken Sie dann auf Weiter.

  3. Klicken Sie auf der Seite Zielorganisationsname im Bereich Organisation auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  4. Klicken Sie auf Contoso on Buyer, und klicken Sie dann auf OK.

  5. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. Klicken Sie in der Liste Transporttyp auf File.

  7. Im Feld Adresse nach dem Präfix file:// geben Sie C:\TutorialFiles\Seller\payment%tracking_id%.xml ein.

    Beispielsweise file://c:\TutorialFiles\Seller\payment%tracking_id%.xml

    Anmerkung

    • Beim Dateitransportdienst besteht die Standardeinstellung für die Transportkomponente im Anhängen neuer Dateien an eine vorhandene Datei im angegebenen Verzeichnis. Sie müssen das folgende Dateipfadformat verwenden, um eine neue Datei mit einem eindeutigen Namen für jede Dokumentinstanz zu erstellen:
      file://C:\dir\file%tracking_id%.xml
  8. Klicken Sie auf OK, um das Dialogfeld Primärer Transport zu schließen, und klicken Sie dann auf Weiter.

  9. Klicken Sie auf der Seite Umschlagsinformationen auf Weiter.

  10. Überprüfen Sie auf der Seite Sicherheitsinformationen, ob das Kontrollkästchen Kanal für diesen Messagingport erstellen aktiviert ist.

  11. Klicken Sie in der Liste Kanaltyp auf Von einer Organisation, und klicken Sie dann auf Fertig stellen.

    Der Kanal-Assistent wird geöffnet.

Weiter mit Erstellen eines Kanals von Contoso, Ltd für das Käufersystem.


Erstellen eines Kanals von Contoso, Ltd für das Käufersystem

Der Kanal, den Sie in diesem Verfahren erstellen, verarbeitet Rechnungen, die von Contoso, Ltd empfangen werden, und verwendet eine Zuordnung, um eine Rechnung in eine Zahlung zu transformieren. Genauer ausgedrückt wird die Quelle des Dokuments als Contoso on Buyer identifiziert und angegeben, dass es sich bei dem eingehenden Dokument um eine Rechnung und bei dem ausgehenden Dokument um eine Zahlung handelt. BizTalk-Messagingdienste verwenden die Zuordnung InvoiceToPayment.xml, um das Dokument von einer Rechnung in eine Zahlung umzuwandeln.

Wenn Sie die Übersichtsabbildung vom Anfang dieses Lernprogramms ausgedruckt haben, sollten Sie die visuelle Darstellung dieses Prozesses betrachten.

So erstellen Sie den Kanal:

  1. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Channel for Invoice To Payment (Kanal für Auftrag an Zahlung) ein, und klicken Sie dann auf Weiter.

  2. Auf der Seite Quellorganisation im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf Contoso on Buyer, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  4. Auf der Seite Eingehendes Dokument klicken Sie rechts vom Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  5. Klicken Sie auf Invoice und dann auf OK, und klicken Sie anschließend auf Weiter.

  6. Auf der Seite Ausgehendes Dokument klicken Sie rechts vom Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  7. Klicken Sie auf Payment und dann auf OK.

  8. Überprüfen Sie, ob das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen aktiviert ist.

  9. Klicken Sie rechts vom Feld Verweis zuordnen auf Durchsuchen.

    Das Dialogfeld Eine Zuordnung aus dem WebDAV-Repository auswählen wird angezeigt.

  10. Doppelklicken Sie auf den Ordner Microsoft.

  11. Klicken Sie auf InvoicetoPayment.xml, klicken Sie auf Öffnen und dann auf Weiter.

  12. Klicken Sie auf der Seite Dokumentprotokollierung auf Weiter.

  13. Klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen.

  14. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Messaging-Manager zu schließen.

Weiter mit Erstellen einer Dateiempfangsfunktion für das Käufersystem.


Erstellen einer Dateiempfangsfunktion für das Käufersystem

In diesem Verfahren erstellen Sie eine Dateiempfangsfunktion, die die Auftragsanforderung des Käufers aus einem lokalen Dateiverzeichnis empfängt und an die BizTalk-Messagingdienste versendet.

Mithilfe von Empfangsfunktionen können Anwendungen Dokumente an bestimmte Standorte übermitteln, die von BizTalk Server 2002 überwacht werden. In diesem Verfahren definieren Sie den Standort als C:\TutorialFiles\Buyer. Die Empfangsfunktion verwendet eine ereignisbasierte Überwachung, um die Anwesenheit eines Dokuments an diesem Standort zu erkennen. Sobald die Dokumentdaten von der Funktion empfangen werden, sendet diese die Daten an BizTalk Server. Jedes Dokument, das an BizTalk Server versendet wird, erfordert eine Reihe von Regeln, die festlegen, wie es verarbeitet werden soll. In diesem Verfahren geben Sie als Kanal Channel for POReq to PO an. Der Kanal enthält alle Informationen, die der Server benötigt, um das Dokument zu verarbeiten.

Die folgende Abbildung zeigt die Beziehung zwischen der versendenden Geschäftsanwendung, dem Dateisystem, in dem sich die Datei befindet, und der Empfangsfunktion.

Weitere Informationen zu Empfangsfunktionen finden Sie unter Grundlegendes zu Empfangsfunktionen und Dokumentrouting.

So erstellen Sie die Dateiempfangsfunktion:

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk Server-Verwaltung.

  2. Erweitern Sie Microsoft BizTalk Server 2002 und BizTalk Server-Gruppe, und klicken Sie dann auf Empfangsfunktionen.

  3. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Dateiempfangsfunktion.

    Das Dialogfeld Dateiempfangsfunktion hinzufügen wird angezeigt.

  4. Im Feld Name geben Sie PORequest Receive Function at Northwind Traders (Auftragsanforderung-Empfangsfunktion von Northwind Traders) ein.

  5. Klicken Sie im Feld Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen eines Servers in der BizTalk-Servergruppe.

  6. Im Feld Abzurufende Dateitypen geben Sie *.xml ein.

  7. Im Feld Abrufspeicherort geben Sie C:\TutorialFiles\Buyer ein.

  8. Klicken Sie auf Erweitert.

    Das Dialogfeld Erweiterte Optionen für Empfangsfunktionen wird angezeigt.

  9. Klicken Sie in der Liste Kanalname auf Channel for POReq to PO, und klicken Sie dann auf OK.

  10. Klicken Sie auf OK, um das Dialogfeld Dateiempfangsfunktion hinzufügen zu schließen.

  11. Schließen Sie die BizTalk Server-Verwaltung.

Weiter mit Konfigurieren des Verkäufersystems.


Konfigurieren des Verkäufersystems

In den folgenden Verfahren verwenden Sie den BizTalk-Messaging-Manager zum Erstellen von Organisationen, welche die Handelspartner auf dem System von Contoso, Ltd darstellen. Außerdem konfigurieren Sie die Messagingports und Kanäle, die den Austausch von Dokumenten auf diesem System definieren.

Weiter mit Erstellen der Organisationen für das Verkäufersystem.


Erstellen der Organisationen für das Verkäufersystem

In diesem Verfahren erstellen Sie Organisationen auf dem System von Contoso, Ltd, die als Quelle für einen Kanal oder als Ziel für einen Messagingport dienen. Weitere Informationen finden Sie unter Grundlegendes zu Organisationen.

Anmerkung

  • Für dieses Lernprogramm wurden das Käufer- und das Verkäufersystem auf nur einem Computer konfiguriert.
  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Wenn das Dialogfeld BizTalk-Messaging-Manager angezeigt wird, klicken Sie auf Abbrechen.

  3. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Organisation.

    Das Dialogfeld Neue Organisation wird angezeigt.

  4. Auf der Registerkarte Allgemein im Feld Organisationsname geben Sie Contoso on Seller (Contoso an Verkäufer) ein, und klicken Sie dann auf OK.

  5. Wiederholen Sie die Schritte 3 und 4, nennen Sie die neue Organisation Northwind Traders on Seller (Northwind Traders an Verkäufer), und klicken Sie dann auf OK.

Weiter mit Erstellen eines Messagingports zu Contoso, Ltd für das Verkäufersystem.


Erstellen eines Messagingports zu Contoso, Ltd für das Verkäufersystem

In diesem Verfahren erstellen Sie einen Messagingport, der das Ziel für den Auftrag auf dem System des Verkäufers definiert. Dieser Messagingport versendet Dokumente innerhalb des Systems von Contoso, Ltd mithilfe einer Anwendungsintegrationskomponente (Application Integration Component, AIC) als Transportdienst.

Eine Anwendungsintegrationskomponente dient normalerweise als Integrationspunkt zwischen BizTalk Server 2002 und einer Back-End-Anwendung. In diesem Szenario funktioniert die Anwendungsintegrationskomponente sowohl als Integrationspunkt als auch als hypothetische Back-End-Anwendung. Der Messagingport leitet den Auftrag an die Anwendungsintegrationskomponente weiter. Wird ein Auftrag an einen Verkäufer gesendet, können mehrere zusätzliche Geschäftsprozesse stattfinden, bevor eine Rechnung generiert wird. Im Rahmen dieses Lernprogramms führt die Anwendungsintegrationskomponente jedoch alle für die Umwandlung des Auftrags in eine Rechnung erforderlichen Tasks durch und sendet die Rechnung an den entsprechenden Kanal der BizTalk-Messagingdienste innerhalb des Verkäufersystems.

Der Auftrag könnte auch mithilfe einer Zuordnung im Kanal in eine Rechnung transformiert werden, aber um die Verwendung eines anderen Transportdienstes zu veranschaulichen, übernimmt die Anwendungsintegrationskomponente in diesem Szenario diese Funktion.

So erstellen Sie den Messagingport:

  1. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Messagingport, und klicken Sie dann auf Zu einer Organisation.

    Der Messagingport-Assistent wird geöffnet.

  2. Im Feld Name geben Sie Port to Contoso via AIC (Port zu Contoso via AIC) ein und klicken dann auf Weiter.

  3. Auf der Seite Zielorganisationsname im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  4. Klicken Sie auf Contoso on Seller, und klicken Sie dann auf OK.

  5. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. Überprüfen Sie, ob in der Liste Transporttyp die Option Anwendungsintegrationskomponente ausgewählt ist, und klicken Sie dann auf Durchsuchen.

    Das Dialogfeld Komponente auswählen wird angezeigt.

  7. Klicken Sie auf POToINVAIC ConvertPOToInvoice und dann auf OK.

  8. Klicken Sie auf OK, um das Dialogfeld Primärer Transport zu schließen, und klicken Sie dann auf Weiter.

  9. Klicken Sie auf der Seite Umschlagsinformationen auf Weiter.

  10. Überprüfen Sie auf der Seite Sicherheitsinformationen, ob das Kontrollkästchen Kanal für diesen Messagingport erstellen aktiviert ist.

  11. Klicken Sie in der Liste Kanaltyp auf Von einer Organisation, und klicken Sie dann auf Fertig stellen.

    Der Kanal-Assistent wird geöffnet.

Weiter mit Erstellen eines Kanals von Northwind Traders für das Verkäufersystem.


Erstellen eines Kanals von Northwind Traders für das Verkäufersystem

In diesem Verfahren erstellen Sie einen Kanal für den Messagingport.

Der Kanal, den Sie erstellen, hat als Quellorganisation Northwind Traders on Seller, die den Käufer auf dem System von Contoso, Ltd darstellt. Dieser Kanal verarbeitet Aufträge, die von Northwind Traders empfangen werden. Da die eingehenden und ausgehenden Dokumentdefinitionen identisch sind, ist kein Zuordnungsverweis für diesen Kanal erforderlich, und es tritt keine Dokumenttransformation ein.

Wenn Sie die Übersichtsabbildung vom Anfang dieses Lernprogramms ausgedruckt haben, sollten Sie in der visuellen Darstellung betrachten, wie Kanal, Messagingport und AIC-Transport den Auftrag verarbeiten.

So erstellen Sie den Kanal:

  1. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Channel for PO (Kanal für Auftrag) ein, und klicken Sie dann auf Weiter.

  2. Auf der Seite Quellorganisation im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf Northwind Traders on Seller, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  4. Auf der Seite Eingehendes Dokument klicken Sie rechts vom Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  5. Klicken Sie auf Purchase Order und dann auf OK, und klicken Sie anschließend auf Weiter.

  6. Auf der Seite Ausgehendes Dokument klicken Sie rechts vom Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  7. Klicken Sie auf Purchase Order und dann auf OK, und klicken Sie anschließend auf Weiter.

  8. Klicken Sie auf der Seite Dokumentprotokollierung auf Weiter.

  9. Klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen.

Weiter mit Erstellen eines Messagingports zu Northwind Traders für das Verkäufersystem.


Erstellen eines Messagingports zu Northwind Traders für das Verkäufersystem

In diesem Verfahren erstellen Sie einen Messagingport auf dem System von Contoso, Ltd, der das Ziel für die Rechnung definiert. Genauer gesagt sendet dieser Messagingport die Rechnung aus dem System von Contoso, Ltd an den Käufer Northwind Traders. Sie verwenden HTTP als Transportdienst, um die Rechnung an eine ASP auf dem Webserver von Northwind Traders zu übermitteln. Die ASP übermittelt die Rechnung dann an die ReceiveInvoice-Warteschlange im Käufersystem.

So erstellen Sie den Messagingport:

  1. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Messagingport, und klicken Sie dann auf Zu einer Organisation.

    Der Messagingport-Assistent wird geöffnet.

  2. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Port to Northwind Traders via HTTP (Port zu Northwind Traders über HTTP) ein, und klicken Sie dann auf Weiter.

  3. Auf der Seite Zielorganisationsname im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  4. Klicken Sie auf Northwind Traders on Seller, und klicken Sie dann auf OK.

  5. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. In der Liste Transporttyp klicken Sie auf HTTP.

  7. Im Feld Adresse nach dem Präfix http:// geben Sie den Namen Ihres Computers ein, gefolgt von /InvoiceToQueue/DropInvoicetoMSMQ.asp, klicken Sie auf OK, und klicken Sie dann auf Weiter.

    Geht diese Nachricht z. B. an eine ASP auf dem Northwind Traders-Server, können Sie http://NorthwindTraders/InvoiceToQueue/DropInvoicetoMSMQ.asp eingeben.

    Führen Sie folgende Schritte durch, um den Namen Ihres Computers zu finden:

    1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

    2. Doppelklicken Sie auf Verwaltung.

    3. Doppelklicken Sie auf Computerverwaltung.

      Die Konsole der Computerverwaltung wird angezeigt.

    4. Klicken Sie im Menü Vorgang auf Eigenschaften.

      Das Dialogfeld Eigenschaften von Computerverwaltung (Lokal) wird angezeigt.

    5. Klicken Sie auf die Registerkarte Netzwerkidentifikation.

      Der Name Ihres Computers wird im Feld Computername angezeigt.

  8. Klicken Sie auf der Seite Umschlagsinformationen auf Weiter.

  9. Überprüfen Sie auf der Seite Sicherheitsinformationen, ob das Kontrollkästchen Kanal für diesen Messagingport erstellen aktiviert ist.

  10. Klicken Sie in der Liste Kanaltyp auf Von einer Organisation, und klicken Sie dann auf Fertig stellen.

    Der Kanal-Assistent wird geöffnet.

Weiter mit Erstellen eines Kanals von Contoso, Ltd für das Verkäufersystem.


Erstellen eines Kanals von Contoso, Ltd für das Verkäufersystem

Der Kanal, den Sie in diesem Verfahren erstellen, besitzt als Quellorganisation Contoso on Seller, da die Rechnung von einer internen Quelle kommt, sobald sie verarbeitet und aus einem Auftrag konvertiert wurde. Dieser Kanal verarbeitet Rechnungen, die gemäß den Regeln des von Ihnen gerade erstellten Messagingports Port to Northwind Traders via HTTP intern an Northwind Traders auf dem Verkäufersystem versendet werden.

Wenn Sie die Übersichtsabbildung vom Anfang dieses Lernprogramms ausgedruckt haben, sollten Sie in der visuellen Darstellung betrachten, wie Kanal, Messagingport und HTTP-Transportdienst die Rechnung verarbeiten.

So erstellen Sie den Kanal:

  1. Auf der Seite Allgemeine Informationen im Feld Name geben Sie Channel for Invoice ein, und klicken Sie dann auf Weiter.

  2. Auf der Seite Quellorganisation im Bereich Organisation klicken Sie auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf Contoso on Seller, klicken Sie auf OK, und klicken Sie dann auf Weiter.

  4. Auf der Seite Eingehendes Dokument klicken Sie rechts vom Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  5. Klicken Sie auf Invoice und dann auf OK, und klicken Sie anschließend auf Weiter.

  6. Klicken Sie auf der Seite Ausgehendes Dokument auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  7. Klicken Sie auf Invoice und dann auf OK, und klicken Sie anschließend auf Weiter.

  8. Klicken Sie auf der Seite Dokumentprotokollierung auf Weiter.

  9. Klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen.

  10. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Messaging-Manager zu schließen.

Weiter mit Zusammenfassung von Unterrichtseinheit 3.


Zusammenfassung von Unterrichtseinheit3

BizTalk Server 2002 ~ Lernprogramm

Zusammenfassung von Unterrichtseinheit 3

In dieser Unterrichtseinheit haben Sie BizTalk-Messagingdienste auf dem Käufer- und dem Verkäufersystem konfiguriert. Es ist wichtig, die Reihenfolge der Ereignisse zu beachten. Zunächst richten Sie die Handelspartner auf dem jeweiligen System ein, indem Sie Organisationen erstellen, und dann definieren Sie die Dokumente, welche die Organisationen senden und empfangen werden. Dann gehen Sie rückwärts vor, konfigurieren das Ziel für das Dokument, die Quelle des Dokuments und dann die Empfangsfunktion (für das Käufersystem), die das Dokument abruft und an die BizTalk-Messagingdienste sendet.

In dieser Unterrichtseinheit haben Sie die folgenden Aufgaben durchgeführt:

  • Organisationen erstellt. Weitere Informationen finden Sie unter Erstellen und Verwalten von Organisationen.

  • Dokumentdefinitionen erstellt. Weitere Informationen finden Sie unter Erstellen und Verwalten von Dokumentdefinitionen.

  • Messagingports erstellt. Weitere Informationen finden Sie unter Erstellen und Verwalten von Messagingports.

  • Kanäle erstellt. Weitere Informationen finden Sie unter Erstellen und Verwalten von Kanälen.

  • Eine Zuordnung in einem Kanal verwendet, um ein Dokument zu transformieren. Weitere Informationen finden Sie unter Verwenden des BizTalk-Mappers.

  • Eine Dateiempfangsfunktion erstellt. Weitere Informationen finden Sie unter Empfangsfunktionen.

Verwenden Sie die Schaltfläche Jetzt suchen im BizTalk-Messaging-Manager, um die Dokumentdefinitionen, Organisationen, Messagingports, Kanäle und die Zuordnung anzuzeigen, die Sie in dieser Unterrichtseinheit erstellt haben.

Der markierte Bereich der folgenden Abbildung zeigt, welche Schritte Sie in dieser Unterrichtseinheit durchgeführt haben.

Weiter mit Unterrichtseinheit 4: Fertigstellen des XLANG-Ablaufplanes.

Verwandtes Thema

Verwenden des BizTalk-Messaging-Managers


Unterrichtseinheit4: Fertigstellen des XLANG-Ablaufplanes

BizTalk Server 2002 ~ Lernprogramm

Unterrichtseinheit 4: Fertigstellen des XLANG-Ablaufplanes

Die ursprüngliche Darstellung des Northwind Traders-Geschäftsprozesses hat lediglich den Auftragsgenehmigungsprozess behandelt. Zu den Geschäftsprozessen um einen Auftrag gehört außerdem das Senden eines genehmigten Auftrags, das Empfangen einer Rechnung sowie das Zurücksenden einer Rechnung.

In dieser Unterrichtseinheit verwenden Sie den BizTalk-Orchestrierungs-Designer, um den XLANG-Ablaufplan so zu ändern, dass er die Rechnungs- und Zahlungsaktionen umfasst, und um die erforderlichen Ports zu implementieren. Anschließend kompilieren Sie den fertig gestellten XLANG-Ablaufplan und führen ihn aus.

Lernziele

  • Hinzufügen von Rechnungs- und Zahlungsaktionen. Weitere Informationen finden Sie unter Hinzufügen von Formen.

  • Implementieren eines Ports mithilfe der BizTalk-Messagingdienste. Weitere Informationen finden Sie unter Verwenden der BizTalk-Messaging-Form.

  • Kompilieren und Ausführen des fertig gestellten XLANG-Ablaufplanes. Weitere Informationen finden Sie unter Kompilieren von XLANG-Ablaufplänen und Ausführen von XLANG-Ablaufplänen.

Zum Fertigstellen des XLANG-Ablaufplanes fahren Sie mit Hinzufügen von Rechnungs- und Zahlungsaktionen fort.

Verknüpfung

  • Sind BizTalk Server und all seine Komponenten auf Laufwerk C: installiert, können Sie den vorhandenen XLANG-Ablaufplan verwenden. Weiter mit Ausführen des fertig gestellten XLANG-Ablaufplanes.

Verwandtes Thema

Entwerfen von BizTalk-Orchestrierungen


Hinzufügen von Rechnungs- und Zahlungsaktionen

In diesem Verfahren ändern Sie den Northwind Traders-Geschäftsprozess im BizTalk-Orchestrierungs-Designer, indem Sie eine Aktion hinzufügen, welche die Rechnung vom Käufer empfängt, sowie eine weitere Aktion, welche die Zahlungsnachricht an Contoso, Ltd sendet.

So erstellen Sie Aktionen:

  1. Zeigen Sie im Startmenü auf Programme und auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Orchestrierungs-Designer.

  2. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld XLANG-Ablaufplanzeichnung öffnen wird angezeigt.

  3. Wenn Sie die vorhandene Datei Buyer1.skv verwenden, wechseln Sie im Dialogfeld XLANG-Ablaufplanzeichnung öffnen in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk, klicken Sie auf Buyer1.skv und dann auf Öffnen.

    Wenn Sie die Datei Buyer1.skv in Unterrichtseinheit 1 erstellt haben, wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab, klicken Sie auf Buyer1.skv und dann auf Öffnen.

    Anmerkung

    • Sie können die leere Zeichnung, die im BizTalk-Orchestrierungs-Designer angezeigt wird, schließen.
  4. Markieren Sie die Verbindung zwischen den Aktionen Write PO Request to File und Ende, und drücken Sie dann die ENTF-TASTE.

  5. Verschieben Sie die Ende-Aktion nach unten, um Platz für zwei neue Aktionsformen zu schaffen.

  6. Ziehen Sie die Aktion-Form aus der Flussdiagrammschablone in der äußerst linken Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die Form unter der Write PO Request to File-Aktion.

  7. Klicken Sie mit der rechten Maustaste auf die Aktion-Form, und wählen Sie dann Eigenschaften.

    Das Dialogfeld Aktionseigenschaften wird angezeigt.

  8. Im Feld Name geben Sie Receive Invoice (Rechnung erhalten) ein, und klicken Sie dann auf OK.

  9. Ziehen Sie die Aktion-Form aus der Flussdiagrammschablone in der äußerst linken Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die Form direkt unterhalb der Receive Invoice-Aktion.

  10. Klicken Sie mit der rechten Maustaste auf die Aktion-Form, und wählen Sie dann Eigenschaften.

    Das Dialogfeld Aktionseigenschaften wird angezeigt.

  11. Im Feld Name geben Sie Send Payment (Zahlung senden) ein, und klicken Sie dann auf OK.

  12. Verbinden Sie die Write PO Request to File-Aktion mit der Receive Invoice-Aktion.

  13. Verbinden Sie die Receive Invoice-Aktion mit der Send Payment-Aktion.

  14. Verbinden Sie die Send Payment-Aktion mit der Ende-Form.

Weiter mit Binden des Message Queuing-Dienstes an das Empfangen einer Rechnung.


Binden des Message Queuing-Dienstes an das Empfangen einer Rechnung

Im vorläufigen Setup für dieses Lernprogramm haben Sie die ReceiveInvoice-Nachrichtenwarteschlange erstellt, damit Northwind Traders Rechnungsnachrichten empfangen kann. In diesem Verfahren fügen Sie die Message Queuing-Form zur XLANG-Ablaufplanzeichnung hinzu und implementieren einen Port zur ReceivePOReq-Nachrichtenwarteschlange. Die Message Queuing-Form stellt den Message Queuing-Dienst zum Senden oder Empfangen von Nachrichten dar. Der Dienst wird für die Überwachung einer Nachrichtenwarteschlange für eine Rechnung konfiguriert. Die Receive Invoice-Aktion ist an den Message Queuing-Dienst gebunden. Wenn eine Rechnung an die ReceiveInvoice-Nachrichtenwarteschlange übergeben wird, aktiviert sie die Receive Invoice-Aktion. Weitere Informationen finden Sie unter Verwenden der Message Queuing-Form.

Wenn Sie die Übersichtsabbildung vom Anfang dieses Lernprogramms ausgedruckt haben, sollten Sie in der visuellen Darstellung betrachten, wie ASP-Datei, Nachrichtenwarteschlange und Receive Invoice-Aktion die Bewegung des Dokuments vereinfachen.

So binden Sie den Message Queuing-Dienst:

  1. Ziehen Sie die Message Queuing-Form aus der Implementierungsschablone in der äußerst rechten Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die Message Queuing-Form so, dass sie sich horizontal auf einer Linie mit der Receive Invoice-Aktion befindet.

    Der Bindungs-Assistent für Message Queuing wird geöffnet.

  2. Überprüfen Sie, ob auf der Seite Willkommen beim Bindungs-Assistenten für Message Queuing die Option Neuen Port erstellen ausgewählt ist.

  3. Im Feld Neuen Port erstellen geben Sie ReceiveInvoice ein, und klicken Sie dann auf Weiter.

  4. Überprüfen Sie auf der Seite Informationen über statische oder dynamische Warteschlangen, ob Statische Warteschlange ausgewählt ist, und klicken Sie dann auf Weiter.

  5. Auf der Seite Warteschlangeninformationen klicken Sie auf Bekannte Warteschlange für alle Instanzen verwenden.

  6. Im Feld Geben Sie den Namen der Warteschlange ein geben Sie .\private$\ReceiveInvoice ein, und klicken Sie dann auf Weiter.

  7. Auf der Seite Erweiterte Porteigenschaften klicken Sie auf Fertig stellen.

Weiter mit Definieren von Nachrichteneigenschaften für den Rechnungsempfangsdienst.


Definieren von Nachrichteneigenschaften für den Rechnungsempfangsdienst

In diesem Verfahren verwenden Sie den Assistenten für XML-Kommunikation, um die Kommunikation zwischen der Receive Invoice-Aktion und dem Receive Invoice-Port zu vereinfachen. Über den Assistenten für XML-Kommunikation stellen Sie spezifische Informationen und Spezifikationen bereit, mit deren Hilfe das XLANG-Ablaufplanungsmodul die richtige Nachricht identifizieren und aus der Warteschlange abrufen kann.

  1. Markieren Sie die Receive Invoice-Aktion, und ziehen Sie das Kontrollhandle rechts neben der Receive Invoice-Aktion auf den ReceiveInvoice-Port.

    Der Assistent für XML-Kommunikation wird geöffnet.

  2. Klicken Sie auf der Seite Willkommen beim Assistenten für XML-Kommunikation auf Empfangen und dann auf Weiter.

  3. Überprüfen Sie auf der Seite Nachrichteninformationen, ob Neue Nachricht erstellen ausgewählt ist.

  4. Im Feld Nachrichtenname geben Sie CommonInvoice ein, und klicken Sie dann auf Weiter.

  5. Überprüfen Sie auf der Seite Informationen über die XML-Konvertierung, ob Nachrichten in der Warteschlange als XML-Nachrichten empfangen ausgewählt ist, und klicken Sie dann auf Weiter.

  6. Auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp geben Sie CommonInvoice ein, und klicken Sie dann auf Weiter.

  7. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Fertig stellen.

Weiter mit Binden der BizTalk-Messagingdienste.


Binden der BizTalk-Messagingdienste

In diesem Verfahren fügen Sie die BizTalk Messaging-Form zur Zeichnung hinzu und verwenden den Bindungs-Assistenten für BizTalk-Messaging zum Benennen des Ports und um anzugeben, dass der Port Dokumente sendet und nicht empfängt. Die BizTalk-Messaging-Form stellt BizTalk-Messagingdienste dar, mit denen Nachrichten zwischen BizTalk-Orchestrierungsdiensten und BizTalk-Messagingdiensten ausgetauscht werden.

In diesem Verfahren binden Sie einen BizTalk-Messagingdienst an die XLANG-Ablaufplanzeichnung. Sie können auch den Kanal in den BizTalk-Messagingdiensten identifizieren, der zur Umwandlung der Rechnung in eine Zahlung verwendet wird. Weitere Informationen finden Sie unter Verwenden der BizTalk-Messaging-Form.

So binden Sie die BizTalk-Messagingdienste:

  1. Ziehen Sie die BizTalk Messaging-Form aus der Implementierungsschablone in der äußerst rechten Spalte auf die Geschäftsprozessseite.

    Positionieren Sie die BizTalk Messaging-Form so, dass sie sich horizontal auf einer Linie mit der Send Payment-Aktion befindet.

    Der BizTalk-Bindungs-Assistent für Messaging wird geöffnet.

  2. Überprüfen Sie auf der Seite Willkommen beim BizTalk-Bindungs-Assistenten für Messaging, ob Neuen Port erstellen ausgewählt ist.

  3. Im Feld Neuen Port erstellen geben Sie SendPayment ein, und klicken Sie dann auf Weiter.

  4. Überprüfen Sie auf der Seite Kommunikationsrichtung, ob Senden ausgewählt ist, und klicken Sie dann auf Weiter.

  5. Überprüfen Sie auf der Seite Informationen über statische oder dynamische Kanäle, ob Statischer Kanal ausgewählt ist.

  6. Im Feld Geben Sie den Namen eines bekannten, vorgegebenen Kanals ein geben Sie Channel for Invoice To Payment ein, und klicken Sie dann auf Fertig stellen.

    Beachten Sie, dass Channel for Invoice To Payment in Unterrichtseinheit 3 erstellt wurde.

Weiter mit Definieren von Nachrichteneigenschaften für die BizTalk-Messagingdienste.


Definieren von Nachrichteneigenschaften für die BizTalk-Messagingdienste

In diesem Verfahren verwenden Sie den Assistenten für XML-Kommunikation, um die Kommunikation zwischen der Send Payment-Aktion und dem SendPayment-Port zu vereinfachen.

  1. Ziehen Sie das Kontrollhandle rechts neben der Send Payment-Aktion zum SendPayment-Port.

    Der Assistent für XML-Kommunikation wird geöffnet.

  2. Auf der Seite Willkommen beim Assistenten für XML-Kommunikation klicken Sie auf Weiter.

  3. Auf der Seite Nachrichteninformationen klicken Sie auf Verweis zu einer vorhandenen Nachricht hinzufügen, klicken Sie auf CommonInvoice und dann auf Weiter.

  4. Überprüfen Sie auf der Seite Informationen über die XML-Konvertierung, ob Nachrichten im XML-Format an die Warteschlange senden ausgewählt ist, und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der Seite Informationen über den Nachrichtentyp auf Weiter.

  6. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Fertig stellen.

Weiter mit Speichern der fertig gestellten XLANG-Ablaufplanzeichnung.


Speichern der fertig gestellten XLANG-Ablaufplanzeichnung

  1. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld XLANG-Ablaufplanzeichnung speichern unter wird angezeigt.

  2. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk.

  3. Im Feld Dateiname geben Sie Buyer2 ein, und klicken Sie dann auf Speichern.

Weiter mit Kompilieren des fertig gestellten XLANG-Ablaufplanes.


Kompilieren des fertig gestellten XLANG-Ablaufplanes

Weitere Informationen zum Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan finden Sie unter Kompilieren von XLANG-Ablaufplänen.

  1. Klicken Sie im Menü Datei auf XLANG Buyer2.skx erstellen.

    Das Dialogfeld XLANG-Ablaufplan speichern unter wird angezeigt.

  2. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk.

  3. Im Feld Dateiname geben Sie Buyer2 ein, und klicken Sie dann auf Speichern.

    Die fertig gestellte XLANG-Ablaufplanzeichnung sollte so wie in der folgenden Darstellung aussehen.

  4. Klicken Sie im Menü Datei auf Beenden.

Weiter mit Ausführen des fertig gestellten XLANG-Ablaufplanes.


Ausführen des fertig gestellten XLANG-Ablaufplanes

Sie haben die Konfiguration einer automatisierten Beschaffungslösung auf Business-to-Business-Ebene abgeschlossen. Sie können nun die Anwendung ausführen, die den XLANG-Ablaufplan aktiviert.

In diesem Verfahren verwenden Sie die Anwendung ExecuteTutorial, die den XLANG-Ablaufplan aktiviert, indem sie eine Auftragsanforderung an die überwachte Nachrichtenwarteschlange übermittelt.

So führen Sie den XLANG-Ablaufplan aus:

  1. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk.

  2. Doppelklicken Sie auf ExecuteTutorial.exe. Diese Anwendung wird verwendet, um den XLANG-Ablaufplan mithilfe eines Monikers zu aktivieren.

    Die Anwendung ExecuteTutorial wird geöffnet.

  3. Klicken Sie auf Browse for Schedule.

    Verknüpfung

    • Sind BizTalk Server und all seine Komponenten auf Laufwerk C: installiert, können Sie den vorhandenen XLANG-Ablaufplan verwenden. Wechseln Sie zu \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution, und fahren Sie mit Schritt 5 fort.
  4. Wenn Sie den XLANG-Ablaufplan Buyer2 erstellt haben, wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab.

  5. Klicken Sie auf den Buyer2.skx-Ablaufplan und dann auf Öffnen.

  6. Klicken Sie auf Browse for Data File, und wechseln Sie zu \Programme\Microsoft BizTalk Server\Tutorial\Schedule\SampleData.

  7. Klicken Sie auf POReqAccept.xml und dann auf Öffnen.

  8. Klicken Sie auf Start XLANG Schedule.

    Da der Gesamtumfang der Auftragsanforderung unter €1000 liegt, wird sie genehmigt. Ein Feld wird mit der Meldung angezeigt, dass die Anwendung Daten an das XLANG-Ablaufplanungsmodul weitergeleitet hat. An dieser Stelle wird die Anwendung beendet. Ein zweites Meldungsfeld informiert Sie darüber, dass die Auftragsanforderung genehmigt wurde. Klicken Sie auf OK, um die Meldungsfelder zu schließen.

  9. Klicken Sie auf End, um die Anwendung ExecuteTutorial zu schließen.

  10. Wechseln Sie in das Verzeichnis C:\TutorialFiles\Seller.

    Dort befindet sich die Zahlungsdatei. Der Dateiname ist PaymentXXXX.xml, wobei XXXX einen eindeutigen Zahlensatz darstellt. Doppelklicken Sie auf die Datei, um sie in Microsoft Internet Explorer zu öffnen.

Sie haben eine Auftragsanforderung versendet. Die Auftragsanforderung wurde genehmigt und an den Verkäufer gesendet. Der Auftrag wurde erfüllt und eine Rechnung erstellt. Beim Empfang der Rechnung wurde eine Zahlungsnachricht an das Verkäufersystem gesendet.

Weiter mit Zusammenfassung von Unterrichtseinheit 4.


Zusammenfassung von Unterrichtseinheit4

BizTalk Server 2002 ~ Lernprogramm

Zusammenfassung von Unterrichtseinheit 4

In dieser Unterrichtseinheit haben Sie Folgendes durchgeführt:

  • Rechnungs- und Zahlungsaktionen hinzugefügt. Weitere Informationen finden Sie unter Verbinden von Formen.

  • Einen Messagingport mithilfe der BizTalk-Messagingdienste implementiert. Weitere Informationen zum Implementieren eines Messagingports mithilfe der BizTalk-Messagingdienste finden Sie unter Verwenden der BizTalk-Messaging-Form.

  • Den fertig gestellten XLANG-Ablaufplan kompiliert und ausgeführt. Weitere Informationen finden Sie unter Kompilieren von XLANG-Ablaufplänen und Ausführen von XLANG-Ablaufplänen.

Der markierte Bereich der folgenden Abbildung zeigt, welche Schritte Sie in dieser Unterrichtseinheit durchgeführt haben.

Weiter mit Zusammenfassung des Lernprogramms.

Verwandtes Thema

Entwerfen von BizTalk-Orchestrierungen


Zusammenfassung des Lernprogramms

In diesem Lernprogramm haben Sie Microsoft BizTalk Server 2002 für die Einrichtung und Ausführung eines automatisierten Beschaffungsprozesses auf Business-to-Business-Ebene konfiguriert.

Die folgende Abbildung zeigt den Datenfluss durch BizTalk Server beim Ausführen des XLANG-Ablaufplanes Buyer2 am Ende von Unterrichtseinheit 4.

Sie haben erfahren, wie BizTalk Server-Komponenten und -Dienste zusammenarbeiten, um flexibel verbundene zeitintensive Geschäftsprozesse sowohl firmenintern als auch firmenübergreifend zu integrieren.

Darüber hinaus haben Sie Folgendes gelernt:

  • Mithilfe des BizTalk-Orchestrierungs-Designers Geschäftsprozesse zu gestalten, indem Sie eine XLANG-Ablaufplanzeichnung erstellen.

  • Mithilfe des BizTalk-Messaging-Managers Organisationen, Kanäle, Messagingports und Dokumentdefinitionen zu erstellen.

  • Mithilfe des BizTalk-Editors Spezifikationen zu erstellen.

  • Mithilfe des BizTalk-Mappers Zuordnungen zu erstellen.

  • Einen XLANG-Ablaufplan zu kompilieren und auszuführen.

Sie haben das Lernprogramm erfolgreich absolviert.

Weitere Ressourcen

Weitere Informationen zum Erstellen von in diesem Lernprogramm verwendeten Hilfskomponenten finden Sie unter Anhang: Erstellen von Hilfskomponenten.

Eine Übersicht der grundlegenden Konzepte um die Prozesse und Aufgaben herum, die zum Erstellen eines automatisierten Beschaffungsprozesses auf Business-to-Business-Ebene mit BizTalk Server erforderlich sind, finden Sie unter Kennen lernen von BizTalk Server 2002.

Ein umfassendes Beispiel zur Verwendung von mehreren der neuen Features in BizTalk Server 2002 finden Sie unter E-Procurement Sample. Zu den neuen Features gehören Folgende:

  • BizTalk SEED-Assistent für die schnelle Partneraktivierung

  • Application Center-Bereitstellungsfunktionen

  • Erweiterte Überwachungsfunktionen mit Microsoft Operations Manager (MOM)

  • Neue XLANG-Korrelation mithilfe allgemeiner anstatt instanzbezogener Warteschlangen


Anhang: Erstellen von Hilfskomponenten

In diesem Anhang wird die Erstellung von Hilfskomponenten erläutert, die bei der Verarbeitung von Daten mit Microsoft BizTalk Server 2002 zusammenarbeiten. Jede Komponente, ihre Rolle und ihre Beziehungen im Prozess werden detailliert beschrieben.

Wichtig

  • Für einige Verfahren in diesem Anhang ist Microsoft Visual Basic 6.0 erforderlich.

Im Einzelnen erstellen Sie:

  • Eine Anwendung auf dem Käufersystem, die einen XLANG-Ablaufplan aktiviert und eine Auftragsanforderung (Purchase Order, PO) an eine Nachrichtenwarteschlange versendet, die an den XLANG-Ablaufplan gebunden ist, der den Nachrichtenstrom durch das Käufersystem steuert.

  • Eine Windows-Skriptkomponente auf dem Käufersystem, die den Genehmigungs- oder Ablehnungsstatus für eine Auftragsanforderung aus dem XLANG-Ablaufplan annimmt. Bei einer Genehmigung zeigt die Windows-Skriptkomponente eine Genehmigungsmeldung an und schreibt die Auftragsanforderung in ein lokales Dateiverzeichnis, in dem die BizTalk-Messagingdienste sie für das Käufersystem empfangen. Bei einer Ablehnung zeigt die Windows-Skriptkomponente eine Ablehnungsmeldung an, und der Ablaufplan endet.

  • Eine Anwendungsintegrationskomponente (Application Integration Component, AIC) auf dem Verkäufersystem, die auf der Basis der Auftragsdaten des Käufers eine Rechnung generiert.

Weiter mit Erstellen der Anwendung.


Erstellen der Anwendung

In diesem Abschnitt erstellen Sie eine Anwendung, die einen XLANG-Ablaufplan aktiviert und dann eine Auftragsanforderung an eine Warteschlange übermittelt. Sie verwenden diese Anwendung, um die Implementierung des XLANG-Ablaufplanes und die Konfiguration des BizTalk-Messaging-Managers zu testen.

Zum Abschluss dieser Übungseinheit ändern Sie den Code im Beispielprojekt. Sie konzentrieren sich dabei auf den Code, der für das Aktivieren des XLANG-Ablaufplanes und das Übermitteln einer Nachricht an eine Warteschlange zuständig ist. Der Hilfscode wird bereitgestellt.

Jeder Schritt entspricht einem Codesegment. Achten Sie auf Kommentarblöcke wie im folgenden Beispiel:

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'To Do: Step A
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Nach diesem Code folgen Zeilen mit Fragezeichen (?), die als Platzhalter überall dort stehen, wo Sie Änderungen vornehmen müssen. Zum Abschluss der Übungseinheit ersetzen Sie die Fragezeichen mit dem richtigen Code. Beispiel:

Private g_MSMTxDisp As ?

sollte wie folgt geändert werden:

Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenser

Anmerkung

  • Diese Codezeilen wurden kommentiert. Entfernen Sie auf jeden Fall die Kommentarzeichen am Anfang der Zeilen, in denen Sie Änderungen vornehmen. Die Schritte im Codefenster sind nicht zwangsläufig in der richtigen Reihenfolge.

Weiter mit Öffnen der Anwendung.


Öffnen der Anwendung

  1. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk.

  2. Doppelklicken Sie auf ExecuteTutorial.vbp.

Weiter mit Hinzufügen der erforderlichen Verweise zur Anwendung.


Hinzufügen der erforderlichen Verweise zur Anwendung

In diesem Verfahren können eine Reihe von DLLs (Dynamic Link Libraries), die für die Verwendung von Message Queuing, XML und Scripting Runtime erforderlich sind, durch die Anwendung implementiert werden.

  1. Klicken Sie im Menü Projekt auf Verweise.

  2. Wählen Sie Microsoft Message Queue 2.0 Object Library aus.

    Der vollständige Pfad für diese Typbibliothek lautet \WINNT\System32\MQOA.dll.

  3. Wählen Sie Microsoft Scripting Runtime aus.

    Der vollständige Pfad für diese DLL lautet \WINNT\System32\Scrrun.dll.

  4. Wählen Sie Microsoft XML, v 3.0 aus.

    Der vollständige Pfad für diese DLL lautet \WINNT\System32\msxml3.dll.

  5. Klicken Sie auf OK.

Weiter mit Definieren und Initialisieren der Message Queue-Objekte.


Definieren und Initialisieren der MessageQueue-Objekte

BizTalk Server 2002 ~ Lernprogramm

Definieren und Initialisieren der Message Queue-Objekte

In diesem Verfahren fügen Sie den Code für die Verwendung der ausgewählten Typbibliotheken hinzu. Die nummerierten Schritte in der folgenden Liste entsprechen den nummerierten Schritten im bereitgestellten Code.

  1. Erweitern Sie im Projektfenster Formulare, und klicken Sie auf Form1 (ExecuteTutorial.frm).

  2. Klicken Sie im Menü Ansicht auf Code.

  3. Im Abschnitt General Declarations bei Schritt A des Codes erstellen Sie Nachrichtenwarteschlangen-Objekte wie im folgenden Beispiel:
    Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenser
Private g_MSMQQueue As MSMQ.MSMQQueue
Private g_MSMQInfo As MSMQ.MSMQQueueInfo
  4. Im Ereignisabschnitt Form_Load unter Schritt B des Codes initialisieren Sie die Message Queue-Objekte wie im folgenden Beispiel:
    Set g_MSMQInfo = CreateObject("MSMQ.MSMQQueueInfo")
Set g_MSMTxDisp = CreateObject("MSMQ.MSMQTransactionDispenser")

Weiter mit Hinzufügen von Code für die Platzierung von Daten in eine Warteschlange.


Hinzufügen von Code für die Platzierung von Daten in eine Warteschlange

In diesem Verfahren fügen Sie eine neue Subroutine mit dem Namen ExecuteMSMQ hinzu. Diese Routine wird vom cmdRunSked_Click-Ereignis aufgerufen. Sie fügen den Code hinzu, um diese Subroutine im folgenden Verfahren aufzurufen.

  • Platzieren Sie bei Schritt C den folgenden Code an das Ende des Codefensters im Projekt:
    Public Sub ExecuteMSMQ(ByVal strQueuePath As String, DataToQueue As String)
    Dim QueueMsg As New MSMQMessage

    Dim strData As String
    Dim fSend As Boolean
    Dim txt As TextStream
    Dim mybyte() As Byte

    g_MSMQInfo.FormatName = strQueuePath
    Set g_MSMQQueue = g_MSMQInfo.Open(MQ_SEND_ACCESS, MQ_DENY_NONE)
    mybyte = StrConv(DataToQueue, vbFromUnicode)
    QueueMsg.Body = DataToQueue

    Set MSMQTx = g_MSMTxDisp.BeginTransaction
    QueueMsg.send g_MSMQQueue, MSMQTx
    MSMQTx.Commit

    Set QueueMsg = Nothing
    Set MSMQTx = Nothing

End Sub

Weiter mit Hinzufügen von Code für die Aktivierung des XLANG-Ablaufplanes und für den Aufruf von "ExecuteMSMQ".


Hinzufügen von Code für die Aktivierung des XLANG-Ablaufplanes und für den Aufruf von "ExecuteMSMQ"

In diesem Verfahren fügen Sie Code zum cmdRunSked_Click-Ereignis hinzu, das den XLANG-Ablaufplan aktiviert und den Code aufruft, der eine Nachricht an eine Warteschlange sendet.

  1. Im cmdRunSked_Click-Ereignisabschnitt bei Schritt D des Codes rufen Sie ExecuteMSMQ auf, wie im folgenden Code gezeigt:
    ExecuteMSMQ "DIRECT=OS:.\private$\ReceivePOReq", objfs.OpenTextFile(txtData.Text, ForReading).ReadAll
  2. Im cmdRunSked_Click-Ereignisabschnitt bei Schritt E des Codes rufen Sie GetObject auf, um den XLANG-Ablaufplan durch einen Moniker zu instanziieren, wie im folgenden Code gezeigt:
    Set SendPAQ = GetObject(txtSked.Text)

Weiter mit Speichern und Kompilieren der Anwendung.


Speichern und Kompilieren der Anwendung

In diesem Verfahren speichern und kompilieren Sie die Anwendung.

  1. Klicken Sie im Menü Datei auf Projekt speichern.

  2. Klicken Sie im Menü Datei auf ExecuteTutorial.exe erstellen.

    Das Dialogfeld Projekt erstellen wird angezeigt.

  3. Wechseln Sie in den Ordner \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk, und klicken Sie auf OK.

Sie können die Anwendung jetzt starten, um den Käuferablaufplan in den Unterrichtseinheiten 1 und 4 auszuführen.

Weiter mit Erstellen der Windows-Skriptkomponente.


Erstellen der Windows-Skriptkomponente

In diesem Abschnitt erstellen Sie eine Windows-Skriptkomponente, die an den XLANG-Ablaufplan gebunden ist. Der Zweck der Windows-Skriptkomponente ist die Anzeige eines Meldungsfeldes mit Genehmigungs- oder Ablehnungsstatus hinsichtlich der Auftragsanforderung sowie gegebenenfalls das Schreiben der Auftragsanforderung in eine lokale Datei, wenn die Auftragsanforderung genehmigt wurde.

Weiter mit Hinzufügen eines Skripts für die Registrierung der Komponente.


Hinzufügen eines Skripts für die Registrierung der Komponente

In diesem Verfahren fügen Sie ein Skript hinzu, mit dem die Komponente in der Datei registriert werden kann.

  1. Zeigen Sie im Startmenü auf Programme und dann auf Zubehör, und klicken Sie anschließend auf Editor.

  2. Fügen Sie das folgende Skript hinzu:
    <?xml version="1.0"?>
<component>
<?component error="true" debug="true"?>
<registration
     description="PORequestApproval"
     progid="BTSTutorial.PORequestApproval"
     version="1.00"
     classid="{2938621b-40fc-48e2-827c-bed74e21a538}"
>
</registration>

    Da Sie dieselbe Klassen-ID verwenden wie die vorkonfigurierte Komponente, wird die alte Komponente in der Registrierung außer Kraft gesetzt.

Weiter mit Hinzufügen eines Skripts für die Implementierung von Methoden.


Hinzufügen eines Skripts für die Implementierung von Methoden

Diese Komponente umfasst drei mögliche Methoden. Die erste Methode sendet einen Genehmigungsstatus in Form eines Meldungsfeldes, das dem Benutzer angezeigt wird. Die zweite Methode sendet einen Ablehnungsstatus, ebenfalls in Form eines Meldungsfeldes, das dem Benutzer angezeigt wird. Die Entscheidung, welche Methode aufgerufen wird, wird von der Entscheidungsregel in der XLANG-Ablaufplanzeichnung bestimmt. Die letzte Methode schreibt den Auftrag in eine lokale Datei, wenn die Auftragsanforderung genehmigt wurde.

  1. Fügen Sie die drei Methodensignaturen am Dateiende hinzu:
    <public>
     <method name="SendApproval">
          <PARAMETER name="Document"/>
     </method>
     <method name="SendDenial">
          <PARAMETER name="Document"/>
     </method>
     <method name="WriteToFile">
          <PARAMETER name="Document"/>
          <PARAMETER name="FileName"/>
     </method>
</public>
  2. Fügen Sie das Skript hinzu, das die Methoden am Dateiende implementiert:
    <implements type="Behavior" id="Behavior"/>

<script language="VBScript">
<![CDATA[

function SendApproval(Document)
     MsgBox "Scheduler Engine Accepted document :" + vbcrlf + + vbcrlf + Document, 0, "Document Approval Received"
end function

function SendDenial(Document)
     MsgBox "Scheduler Engine Denied document :" + vbcrlf + + vbcrlf + Document, 0, "Document Denied"
end function

function WriteToFile(Document, FileName)
     dim objFileSys, strTimeNow

     if FileName = "" then
            FileName = "c:\TutorialFiles\Buyer\POReq*.xml"
     end if

'Generate a Unique Number used to generate unique files using a mask
   strTimeNow = left(Replace(CStr(FormatDateTime(Now(), 3)),":",""), 6)

'Create File System Object
     Set objFileSys = CreateObject("Scripting.FileSystemObject")

'Create the Specified file, write the document data and close
     Set filestream = objFileSys.CreateTextFile(Replace(FileName, "*", strTimeNow), False)
     filestream.writeline Document
      filestream.close
end function

]]>
</script>

</component>
  3. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld Speichern unter wird angezeigt.

  4. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab auf dem BizTalk Server-Installationslaufwerk.

  5. Im Feld Dateiname geben Sie PORequestApproval.wsc ein.

  6. Klicken Sie im Feld Speichern unter Typ auf Alle Dateien, und klicken Sie dann auf Speichern.

  7. Schließen Sie Editor.

  8. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab.

  9. Klicken Sie mit der rechten Maustaste auf PORequestApproval.wsc, und klicken Sie dann auf Registrieren.

Diese Komponente kann durch die vorkonfigurierte Windows-Skriptkomponente ersetzt werden, die Sie in Unterrichtseinheit 1 verwendet haben. Um die Komponente verwenden zu können, müssen Sie die vorhandene Bindung der Windows-Skriptkomponente aus dem Ablaufplan entfernen und dann eine neue Bindung der Windows-Skriptkomponente erstellen, die auf Ihre Komponente verweist.

Weiter mit Löschen der Windows-Skriptkomponente.


Löschen der Windows-Skriptkomponente

In diesem Verfahren löschen Sie die Windows-Skriptkomponente aus der XLANG-Ablaufplanzeichnung Buyer2. Sie können die Komponente, die Sie erstellt haben, neu binden.

  1. Zeigen Sie im Startmenü auf Programme und auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Orchestrierungs-Designer.

  2. Öffnen Sie die Datei Buyer2.skv, die sich im Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Lab auf dem BizTalk Server-Installationslaufwerk befindet, um die in Unterrichtseinheit 4 erstellte Zeichnung zu verwenden.

    Öffnen Sie die Datei Buyer2.skv, die sich im Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution befindet, um die vorhandene Zeichnung Buyer2 zu verwenden.

  3. Klicken Sie auf die Skriptkomponente-Form, und drücken Sie dann die ENTF-TASTE.

  4. Klicken Sie auf die Registerkarte Daten.

  5. Löschen Sie die Meldungsfelder für SendApproval, SendDenial und WriteToFile.

Sie können nun die Windows-Skriptkomponente im Ablaufplan verwenden. Gehen Sie wie folgt vor:

  1. Implementieren Sie einen Port zu Buyer2.skv mithilfe der Windows-Skriptkomponente.

    Ein Beispiel für die Vorgehensweise finden Sie unter Implementieren eines Ports mithilfe einer Skriptkomponente. Verwenden Sie aber nicht die Komponente im Beispiel, sondern Ihre eigene Komponente.

  2. Definieren Sie die Methodenkommunikation für die Portimplementierung.

    Ein Beispiel für die Vorgehensweise finden Sie unter Definieren von Nachrichteneigenschaften für die Skriptkomponente.

  3. Definieren Sie den Datenfluss für den Port.

    Ein Beispiel für die Vorgehensweise finden Sie unter Definieren des Datenflusses.

  4. Speichern Sie die XLANG-Datei.

    Ein Beispiel für die Vorgehensweise finden Sie unter Speichern der XLANG-Ablaufplanzeichnung.

  5. Starten Sie die Anwendung ExecuteTutorial, die sich im Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk befindet, um Ihre Komponente zu testen.

Weiter mit Erstellen der Anwendungsintegrationskomponente.


Erstellen der Anwendungsintegrationskomponente

In diesem Abschnitt erstellen Sie eine neue Anwendungsintegrationskomponente (Application Integration Component, AIC) mit dem Namen POtoINVAIC, die ein Auftragsdokument mithilfe von MSXML-DOM in ein Rechnungsdokument konvertiert.

Weiter mit Erstellen eines ActiveX-DLL-Projekts für die Anwendungsintegrationskomponente.


Erstellen eines ActiveX-DLL-Projekts für die Anwendungsintegrationskomponente

  1. Starten Sie Microsoft Visual Basic 6.0.

  2. Klicken Sie im Dialogfeld Neues Projekt auf die Registerkarte Neu, klicken Sie dann auf ActiveX-DLL und anschließend auf Öffnen.

    Auf diese Weise erstellen Sie für Ihre Komponente ein neues Projekt mit dem Namen Projekt1.

  3. Klicken Sie im Projektstrukturfenster auf Projekt1, um das Projekt und das Steuerelement sinnvoll umzubenennen, und ändern Sie im Eigenschaftenfenster die (Name)-Eigenschaft in POtoInvAICLab.

  4. Klicken Sie im Projektstrukturfenster auf Class1(Class1), und ändern Sie im Eigenschaftenfenster die (Name)-Eigenschaft in ConvertPOtoInvoice.

Weiter mit Hinzufügen der erforderlichen Verweise für die Anwendungsintegrationskomponente.


Hinzufügen der erforderlichen Verweise für die Anwendungsintegrationskomponente

In diesem Verfahren kann eine Anzahl von Schnittstellen, die BizTalk Server 2002 benötigt, durch die Komponente implementiert werden.

  1. Klicken Sie im Menü Projekt auf Verweise.

  2. Klicken Sie auf Microsoft BizTalk Server Application Interface Components 1.0 Type Library.

    Der vollständige Pfad für diese Typbibliothek lautet \Programme\Microsoft BizTalk Server\btscomplib.tlb.

  3. Wählen Sie Microsoft BizTalk Interchange 1.0 Type Library aus.

    Der vollständige Pfad für diese Typbibliothek lautet \Programme\Microsoft BizTalk Server\cisapi.tlb.

  4. Wählen Sie Microsoft Scripting Runtime aus.

    Der vollständige Pfad für diese DLL lautet \WINNT\System32\Scrrun.dll. Verwenden Sie diese Bibliothek, um ein Dateisystemobjekt zu erstellen, und öffnen Sie einen Text, der zum Schreiben eines Auftrags auf die Festplatte verwendet wird.

  5. Wählen Sie Microsoft XML, v 3.0 aus.

    Der vollständige Pfad für diese DLL lautet \WINNT\System32\msxml3.dll.

  6. Klicken Sie auf OK.

Weiter mit Implementieren der erforderlichen Schnittstelle.


Implementieren der erforderlichen Schnittstelle

Damit BizTalk Server eine Komponente als Anwendungsintegrationskomponente erkennen kann, muss eine von zwei Schnittstellen implementiert sein. Im Rahmen dieses Lernprogramms implementieren Sie die IBTSAppIntegration-Schnittstelle.

  1. Im Fenster Projekt klicken Sie auf das ConvertPOtoInvoice-Klassenmodul.

  2. Klicken Sie im Menü Ansicht auf Code.

  3. Fügen Sie die folgende Codezeile oben im Codefenster ein, um sicherzustellen, dass alle Variablen deklariert sind. Dadurch können einfache Fehler minimiert werden.
    Option Explicit
  4. Implementieren Sie die erforderliche Schnittstelle, indem Sie die folgende Codezeile nach der Option Explicit-Anweisung hinzufügen:
    Implements IBTSAppIntegration

Weiter mit Definieren und Initialisieren der Klassenobjekte.


Definieren und Initialisieren der Klassenobjekte

In diesem Verfahren fügen Sie Code hinzu, um das MSXML-Klassenobjekt zum Erstellen von XML-Dateien mithilfe von DOM zu definieren. Sie werden eine Zeichenfolgenvariable erstellen, die auf das Projektstylesheet verweist, das einen Auftrag in eine Rechnung konvertiert.

  1. Platzieren Sie den folgenden Code unter die Implements IBTSAppIntegration-Anweisung:
    'Class Object Defines
Private m_DOMCommonPO As MSXML2.DOMDocument
Private m_DOMStylesheet As MSXML2.DOMDocument
Private m_objSubmit As BTSInterchangeLib.Interchange

'Embedded Project Stylesheet to Convert CommonPO to CommonInvoice
Private m_strStylesheet As String
  2. Fügen Sie den folgenden Code hinzu, um die XML-DOM-Objekte, die den Auftrag in eine Rechnung konvertieren, sowie das Interchange-Objekt, das das endgültige Rechnungsdokument an BizTalk Server versendet, zu initialisieren:
    Private Sub Class_Initialize()
'Create DOM/Interchange Objects
    Set m_DOMCommonPO = New MSXML2.DOMDocument
    Set m_DOMStylesheet = New MSXML2.DOMDocument
    Set m_objSubmit = New BTSInterchangeLib.Interchange

'Configure DOM Objects to be Synchronous
    m_DOMCommonPO.async = False
    m_DOMStylesheet.async = False

'Fill Stylesheet Embedded String
    m_strStylesheet = m_strStylesheet + ""

End Sub

Weiter mit Implementieren der Schnittstellenmethode.


Implementieren der Schnittstellenmethode

Die ProcessMessage-Methode der IBTSAppIntegration-Schnittstelle empfängt ein eingehendes XML-Standardauftragsdokument, das von BizTalk Server übertragen wurde, und übersetzt die Daten, um es in ein XML-Standardrechnungsdokument zu konvertieren. Das Standardrechnungsdokument wird dann zurück an BizTalk Server versendet. Es soll ein Back-End-System simuliert werden, das Aufträge empfängt und dann eine Rechnung für diese Aufträge zurückgibt.

  1. Fügen Sie die Funktionsdefinition und die Variablen für äußere Maße hinzu, wie im folgenden Code angezeigt:
    Private Function IBTSAppIntegration_ProcessMessage( _
                                ByVal bstrDocument As String) As String
    Dim bstrInvoiceDocument As String
    Dim objScripting As New Scripting.FileSystemObject
'Initialize ProcessMessage to null
    IBTSAppIntegration_ProcessMessage = ""
  2. Fügen Sie den Code hinzu, um die empfangenen Daten in ein DOM-Objekt zu laden, und überprüfen Sie, ob es im richtigen Format ist, indem Sie den folgenden Code im Anschluss an die IBTSAppIntegration_ProcessMessage-Anweisung hinzufügen:
        m_DOMCommonPO.loadXML bstrDocument

    If m_DOMCommonPO.parseError.errorCode <> 0 Then 'The data was not valid XML
'Raised errors are not caught in the component, and will be sent back to BizTalk Server
        Err.Raise m_DOMCommonPO.parseError.errorCode, "AICSample.ConvertPOToInvoice Component", _
            "The provided document was not valid XML and could not be processed because:" + _
            vbCrLf + vbCrLf + m_DOMCommonPO.parseError.reason + vbCrLf + " on line: " + _
            CStr(m_DOMCommonPO.parseError.Line) + vbCrLf + "at position: " + _
            CStr(m_DOMCommonPO.parseError.linepos)
    End If
  3. Fügen Sie den folgenden Code im Anschluss an die End If-Anweisung hinzu, um die im XSL-Code enthaltende Ressourcendatei zu verwenden, die einen Auftrag in eine Rechnung konvertiert:
        If m_strStylesheet = "" Then
        m_strStylesheet = StrConv(LoadResData(101, "CUSTOM"), vbUnicode)

    End If
    m_DOMStylesheet.loadXML m_strStylesheet
    bstrInvoiceDocument = m_DOMCommonPO.transformNode(m_DOMStylesheet)

    If bstrInvoiceDocument = "" Then ' Mapping Failed Raise an Error
        Err.Raise vbObjectError + 100, "AICSample.ConvertPOToInvoice Component", _
            "The provided CommonPO document could not be translated into a Common Invoice " + _
            "as the map produced blank output."
    End If
  4. Fügen Sie den folgenden Code im Anschluss an die End If-Anweisung hinzu, um das Rechnungsdokument an die BizTalk-Messagingdienste zu versenden:
    IBTSAppIntegration_ProcessMessage = m_objSubmit.Submit(BIZTALK_OPENNESS_TYPE_NOTOPEN, bstrInvoiceDocument, , , "Contoso on Seller", , "Northwind Traders on Seller")

End Function

    Der Submit-Aufruf gibt die Versendungs-ID zurück, die in diesem Fall nicht verwendet wird.

Weiter mit Beenden der Klassenobjekte.


Beenden der Klassenobjekte

Fügen Sie folgenden Code am Ende des Projekts hinzu, um sicherzustellen, dass alle Objekte aus dem Speicher freigegeben werden, wenn die Klasse beendet wird:

Private Sub Class_Terminate()
    Set m_DOMCommonPO = Nothing
    Set m_DOMStylesheet = Nothing
    Set m_objSubmit = Nothing
End Sub

Weiter mit Erstellen der Ressourcendatei.


Erstellen der Ressourcendatei

In diesem Verfahren fügen Sie die Ressourcendatei hinzu, die die XSL zum Transformieren eines Auftrags in eine Rechnung enthält.

  1. Im Menü Add-Ins klicken Sie auf Add-In-Manager.

    Das Dialogfeld Add-In-Manager wird angezeigt.

  2. Klicken Sie auf VB 6 Ressourcen-Editor.

  3. Im Bereich Ladeverhalten klicken Sie auf Laden/Entladen, um den Ressourcen-Editor zu laden, klicken Sie dann auf Beim Start laden und anschließend auf OK.

  4. Klicken Sie im Menü Extras auf Ressourcen-Editor.

  5. Klicken Sie auf der Symbolleiste auf das Symbol Benutzerdefinierte Ressource hinzufügen.

    Das Dialogfeld Benutzerdefinierte Ressource öffnen wird angezeigt.

  6. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab auf dem BizTalk Server-Installationslaufwerk, klicken Sie auf POtoINVAIC.txt, und klicken Sie dann auf OK.

    Vorsicht

    • Stellen Sie sicher, dass die ID Ihrer Ressource 101 ist. Standardmäßig hat die erste Ressource eine ID von 101, aber diese Zahl erhöht sich jeweils um eins, wenn Sie die Ressource ändern. Klicken Sie mit der rechten Maustaste auf die Ressourcen-ID, und klicken Sie dann auf Eigenschaften, um die Ressourcen-ID in 101 zu ändern. Im Feld ID geben Sie 101 ein.
  7. Klicken Sie auf das Symbol Speichern.

    Das Dialogfeld Ressourcendatei speichern unter wird angezeigt.

  8. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab.

  9. Im Feld Dateiname geben Sie POtoInvAICLab.RES ein, und klicken Sie dann auf Speichern.

  10. Schließen Sie den Ressourcen-Editor.

Weiter mit Aufbauen der Komponente und Festlegen der Binärkompatibilität.


Aufbauen der Komponente und Festlegen der Binärkompatibilität

Da Sie eine neue Komponente erstellen, müssen Sie die Komponente zunächst aufbauen und dann die Projekteigenschaften für Binärkompatibilität mit der neu erstellten DLL festlegen. Die Binärkompatibilität stellt sicher, dass Sie nicht jedes Mal beim Kompilieren der DLL einen neuen global eindeutigen Bezeichner (Globally Unique Identifier, GUID) für das Objekt generieren.

  1. Klicken Sie im Menü Datei auf Projekt speichern unter.

    Das Dialogfeld Datei speichern unter wird angezeigt.

  2. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab auf dem BizTalk Server-Installationslaufwerk.

  3. Im Feld Dateiname geben Sie ConvertPOtoInvoice.cls ein, und klicken Sie dann auf Speichern.

    Das Dialogfeld Projekt speichern unter wird angezeigt.

  4. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab.

  5. Im Feld Dateiname geben Sie POToInvAICLab ein, und klicken Sie dann auf Speichern.

  6. Klicken Sie im Menü Datei auf POToInvAICLab.dll erstellen.

    Das Dialogfeld Projekt erstellen wird angezeigt.

  7. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab, und klicken Sie auf OK.

  8. Im Menü Projekt klicken Sie auf Eigenschaften von POToInvAICLab.

  9. Klicken Sie auf die Registerkarte Komponente.

  10. Klicken Sie auf Binär-Kompatibilität.

  11. Klicken Sie auf die Schaltfläche Durchsuchen (...), um das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab zu suchen.

  12. Klicken Sie auf POToInvAICLab.dll und dann auf Öffnen.

  13. Klicken Sie auf OK.

Weiter mit Registrieren der Anwendungsintegrationskomponente.


Registrieren der Anwendungsintegrationskomponente

In diesem Verfahren registrieren Sie die Anwendungsintegrationskomponente, damit sie von BizTalk Server erkannt wird. BizTalk Server durchsucht die Liste der registrierten COM-Komponenten und fragt diese Komponenten ab, um zu ermitteln, durch welche Komponente entweder die IBTSAppIntegration-Schnittstelle oder die IPipelineComponent-Schnittstelle implementiert wird. Alle Komponenten, die den Kriterien entsprechen, werden in einer Komponentenliste im BizTalk-Messaging-Manager angezeigt.

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Verwaltung.

  3. Doppelklicken Sie auf Komponentendienste.

    Die Konsole der Komponentendienste wird angezeigt.

  4. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz, und klicken Sie dann auf COM+-Anwendungen.

  5. Klicken Sie mit der rechten Maustaste auf COM+ Anwendungen, zeigen Sie auf Neu, und klicken Sie dann auf Anwendung.

    Der COM-Anwendungsinstallations-Assistent wird geöffnet.

  6. Auf der Seite Willkommen beim COM-Anwendungsinstallations-Assistenten klicken Sie auf Weiter.

  7. Auf der Seite Neue Anwendung erstellen oder installieren klicken Sie auf Eine leere Anwendung erstellen.

  8. Im Feld Geben Sie einen Namen für die neue Anwendung ein geben Sie POToInvAICLab ein.

  9. Klicken Sie im Bereich Aktivierungstyp auf Serveranwendung, und klicken Sie dann auf Weiter.

  10. Klicken Sie im Bereich Konto auf Interaktiver Benutzer, der zurzeit angemeldete Benutzer, und klicken Sie dann auf Weiter.

  11. Klicken Sie auf Fertig stellen.

  12. In der Konsolenstruktur erweitern Sie COM+ Anwendungen und dann das Paket POToInvAICLab, das Sie neu erstellt haben.

  13. Klicken Sie auf Komponenten.

  14. Wechseln Sie in das Verzeichnis \Programme\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab auf dem BizTalk Server-Installationslaufwerk.

  15. Ziehen Sie POToInvAICLab.dll zum Ordner Komponenten in den Komponentendiensten.

  16. Schließen Sie die Komponentendienste.

Sie können den Port jetzt für die Verwendung der neuen Anwendungsintegrationskomponente neu konfigurieren, indem Sie folgende Schritte durchführen:

Anmerkung

  • Der aktuell angemeldete Benutzer muss ein Mitglied der Gruppe BizTalk Server-Administratoren sein und während des Ausführens dieses Szenarios angemeldet bleiben.
  1. Öffnen Sie den BizTalk-Messaging-Manager.

  2. Im Bereich Suchen klicken Sie auf Messagingports und dann auf Jetzt suchen.

  3. In der Liste Messagingportname doppelklicken Sie auf Port to Contoso via AIC.

  4. Auf der Seite Allgemeine Informationen klicken Sie auf Weiter.

  5. Auf der Seite Zielorganisation im Bereich Primärer Transport klicken Sie auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  6. Klicken Sie auf Durchsuchen.

  7. In der Liste Verfügbare Komponenten klicken Sie auf POToInvAICLab ConvertPOtoInvoice, und klicken Sie dann auf OK.

  8. Klicken Sie auf OK, um das Dialogfeld Primärer Transport zu schließen, und klicken Sie dann auf Fertig stellen.

  9. Testen Sie die Komponente, indem Sie die Anwendung ExecuteTutorial ausführen, die sich unter \Programme\Microsoft BizTalk Server\Tutorial\Schedule\Solution auf dem BizTalk Server-Installationslaufwerk befindet.


Kennenlernen von BizTalkServer2002

BizTalk Server 2002 ~ Kennenlernen

Kennenlernen von BizTalk Server 2002

In diesen Lektionen lernen Sie, wie Ihr Unternehmen beim Austausch unterschiedlicher Dokumente mit Geschäftspartnern sowie bei der Integration interner Geschäftsprozesse und -anwendungen Microsoft® BizTalk™ Server 2002 verwenden kann.

In diesen Lektionen werden die grundlegenden Konzepte von BizTalk Server erklärt sowie Informationen zu den für das Erstellen von Lösungen mit BizTalk Server erforderlichen Tools und Prozessen gegeben.

Anmerkung

  • Eine genaue Anleitung zum Konfigurieren von BizTalk Server-Prozessen finden Sie unter BizTalk Server 2002-Lernprogramm. Im BizTalk Server-Lernprogramm wird gezeigt, wie mithilfe des BizTalk-Editors, des BizTalk-Mappers, des BizTalk-Messaging-Managers, des BizTalk-Orchestrierungs-Designers und der BizTalk Server-Verwaltung BizTalk Server für die Ausführung eines automatisierten B2B-Beschaffungsprozesses (Business-to-Business) konfiguriert wird. Weitere allgemeine Informationen zu BizTalk Server 2002 finden Sie unter Microsoft BizTalk Server 2002 - Einführung.

Anforderungen

Für dieses Lernprogramm müssen BizTalk Server und alle zugehörigen Komponenten auf Laufwerk C: installiert sein. Es ist zwar möglich, diese Dateien von einem anderen Laufwerk oder Verzeichnis auszuführen, jedoch müssten Sie dazu umfangreiche Änderungen an den Quelldateien vornehmen.

Bevor Sie dieses Lernprogramm ausführen, müssen Sie außerdem das Verzeichnis Learn BizTalk auf Laufwerk C: kopieren:

  1. Kopieren Sie das Verzeichnis C:\Programme\Microsoft BizTalk Server\SDK\Learn BizTalk in den Ordner C:\LearnBizTalk.

  2. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Documents.

  3. Markieren Sie bei gedrückter STRG-Taste ReqToApprove.xml und ReqToDecline.xml.

  4. Klicken Sie mit der rechten Maustaste auf die Auswahl und anschließend auf Eigenschaften.

  5. Deaktivieren Sie auf der Registerkarte Allgemein im Bereich Attribute das Kontrollkästchen Schreibgeschützt.

  6. Klicken Sie auf OK.

Wichtig

  • Im Verzeichnis C:\LearnBizTalk\Scripts gibt es mehrere Skripts. Sie können die Skriptdateien ausführen, indem Sie darauf doppelklicken. Diese Skripts nehmen Konfigurationsänderungen in Ihrer BizTalk Server-Installation vor, damit Sie die Lektionen durcharbeiten können. Das Ausführen dieser Skripts dauert einige Minuten. Sobald ein Skript abgeschlossen ist, wird ein Meldungsdialogfeld angezeigt.

  • Wenn Sie das Lernprogramm durchgearbeitet haben, können Sie das Skript CleanUp.vbs ausführen, um alle Änderungen zu entfernen.

Inhalt

  • Lektion 1: BizTalk Server - Einführung

  • Lektion 2: Konfigurieren der BizTalk-Messagingdienste

  • Lektion 3: Entwerfen der BizTalk-Orchestrierungsdienste

  • Lektion 4: Grundlegendes zur Implementierung

  • Lektion 5: Verwenden des BizTalk-Mappers

  • Lektion 6: Senden und Empfangen von Dokumenten

  • Lektion 7: Abschließen der Transaktion


Lektion 1: BizTalkServer - Einführung

BizTalk Server 2002 ~ Kennenlernen

Lektion 1: BizTalk Server - Einführung

In dieser Lektion wird eine Übersicht über BizTalk Server und das in den Lektionen verwendete Szenario gegeben.

Folgende Themen werden in dieser Lektion behandelt:

  • Was ist BizTalk Server?

  • Gründe für die Verwendung von BizTalk Server

  • Gründe für die Verwendung von XML

  • Integrierte Lösungen

  • Installieren von BizTalk Server

  • Das Szenario

  • Ausführen des Szenarios


Was ist BizTalkServer?

BizTalk Server 2002 ~ Kennenlernen

Was ist BizTalk Server?

Microsoft BizTalk Server 2002 stellt eine Entwicklungs- und Ausführungsumgebung bereit, die Geschäftsprozesse sowohl innerhalb von Unternehmen und als auch zwischen Unternehmen orchestriert. BizTalk Server kann Geschäftstransaktionen verarbeiten, die über einen Zeitraum von Wochen oder Monaten ausgeführt werden.

Zu den Features von BizTalk Server 2002 zählen die folgenden: Definieren von Spezifikationen für Geschäftsdokumente und deren Umwandlung für die Weiterleitung zwischen Anwendungen, und Überwachen und Protokollieren von Serveraktivitäten.

Der Server stellt einen Standardgateway für das Senden und Empfangen von Dokumenten über das Internet bereit sowie eine Reihe von Diensten, die Datenintegrität, -übermittlung und –sicherheit sicherstellen.

Weiter mit Gründe für die Verwendung von BizTalk Server


Gründe für die Verwendung von BizTalkServer

BizTalk Server 2002 ~ Kennenlernen

Gründe für die Verwendung von BizTalk Server

In der aktuellen Geschäftsumgebung muss unbedingt sichergestellt werden, dass die gewählte Lösung auf allgemein akzeptierten Protokollen und Dokumentformaten basiert. Des Weiteren ist es wichtig zu wissen, dass Ihre Lösung durch die Integration unterschiedlichster Anwendungen eine sichere Verbindung zu den verschiedensten Geschäftspartnern über das Internet ermöglicht und bei wachsenden Geschäftsanforderungen skaliert werden kann. Microsoft BizTalk Server 2002 wurde speziell hierfür entwickelt.

Auf dem globalen Markt von heute ist ein effizienter Betrieb rund um die Uhr erforderlich. Kunden stellen höhere Ansprüche und erwarten, dass aktuelle Informationen in Echtzeit zur Verfügung gestellt werden. Dies führt zu einem beschleunigten Geschäftstempo und einem Bedarf an schnelleren Entscheidungsprozessen. Darüber hinaus sind Geschäftsbeziehungen heutzutage sehr dynamisch, und neue Kunden und Partner erwarten, dass Unternehmen sich schnell an neue Gegebenheiten anpassen.

Des Weiteren muss die Unterstützung mehrerer Anwendungen auf verschiedenen Plattformen und deren Integration möglich sein, um eine sichere Verbindung zu Geschäftspartnern über das Internet, Extranets, B2B-Austauschvorgänge und andere Ressourcen zu gewährleisten. Vorhandene IT-Investitionen müssen aufrechterhalten werden, d. h., es muss eine Unterstützung von Legacysystemen und EDI-Netzwerken (Electronic Data Interchange), wie z. B. X12 und EDIFACT, möglich sein. Die wichtigste Voraussetzung für einen effektiven Wettbewerb im heutigen Markt ist möglicherweise die Fähigkeit, mithilfe von offenen Internetstandards und -technologien schnell neue Lösungen zu entwickeln und so eine maximale Interoperabilität zu gewährleisten. Weitere Informationen finden Sie unter Unterstützen von Standards.

BizTalk Server verwendet XML intern zum Definieren der Daten und der Struktur Ihrer Geschäftsdokumente und Standardinternetprotokolle, wie z. B. Hypertext Transfer Protocol (HTTP) und Simple Mail Transfer Protocol (SMTP), zum Übermitteln dieser Dokumente an ihre Zielorte. Damit können Sie mit verschiedenen, in beliebigen Umgebungen ausgeführten Anwendungen zusammenarbeiten, solange die Anwendungen Internetstandards unterstützen. Sie können Dokumente als XML (Extensible Markup Language), EDI oder Flatfiles an BizTalk Server senden.

Weiter mit Gründe für die Verwendung von XML


Gründe für die Verwendung von XML

Für den Austausch von Dokumenten in einer Umgebung, in der keine Partei von der Technologie der anderen Partei abhängig sein möchte, müssen Unternehmen eine gemeinsame Sprache wählen, in der diese Dokumente verfasst werden sollen. XML (Extensible Markup Language) hat sich als diese gemeinsame Sprache durchgesetzt.

XML bietet eine flexible Methode zum Erstellen von gängigen Informationsformaten und Freigeben des Formats und der Daten im Web. Sie können ein in XML verfasstes Dokument mit einem beliebigen Texteditor anzeigen und bearbeiten. Außerdem ist es leicht verständlich. Im folgenden Beispiel bestellt das Unternehmen Northwind Traders zwei Monitore bei der Firma Contoso AG. Sehen Sie sich nun die folgende interne Beschaffungsanforderung von Northwind Traders an, die im XML-Format vorliegt:

<NorthwindReq>
<Header reqNumber="IL0829" reqStatus="New" dateCreated="2000-10-24"/>
<Shipping
name="Brian H. Valentine"
addr1="1234 Main Street"
city="Anytown"
state="AL"
zip="12345"
country="USA"
phone="(555)555-0123" />
<Items count="2">
<Item partNo="270FS" description="27-inch flat screen monitor" qty="2" />
</Items>
</NorthwindReq>

In diesem Dokument wird ein vordefiniertes Format verwendet, das als Schema bezeichnet wird. Ein Schema ist ein XML-Dokument, das das Format anderer XML-Dokumente beschreibt. Im Gegensatz zu anderen XML-Dokumenten enthält ein Schema keine Daten, sondern nur die Formatierungsregeln für Dokumentelemente, die in einem zugehörigen XML-Dokument möglicherweise angezeigt werden.

XML wurde vom World Wide Web Consortium (W3C) einem formalen Standardisierungsprozess unterzogen und erhielt die Auszeichnung "W3C Recommendation", die höchste Empfehlung von W3C. Weitere Informationen zur XML-Empfehlung finden Sie auf der Seite "XML (Extensible Markup Language)" in der Website des World Wide Web Consortium (www.w3.org/XML).

Microsoft BizTalk Server 2002 definiert Dokumente außerdem mithilfe eines als XDR (XML-Data Reduced) bezeichneten Formats, einer funktionalen Untergruppe des W3C XML-Schemas, das Ihnen viele Vorteile des XML-Schemas bietet. W3C XML erhielt vor kurzem die Auszeichnung "W3C Recommendation", und künftige Versionen von BizTalk Server werden XML-Schema unterstützen und dabei gleichzeitig einen nahtlosen Migrationspfad für das vorhandene XDR-Format bereitstellen. Weitere Informationen zum XML-Schema finden Sie auf der Seite "XML Schema" in der Website des World Wide Web Consortium (www.w3.org/XML).

Weiter mit Integrierte Lösungen


Integrierte Lösungen

Microsoft BizTalk Server übernimmt die beiden Hauptaufgaben bei Dokumentaustauschvorgängen: Messaging und Orchestrierung.

Die BizTalk-Messagingdienste ermöglichen das sichere und zuverlässige Senden von Geschäftsdokumenten. Bei einem solchen Dokument könnte es sich beispielsweise um einen an einen Lieferanten gesendeten Auftrag oder die Anfrage nach einem Preisangebot von mehreren Händlern handeln, um herauszufinden, wer den günstigsten Preis bietet.

Die BizTalk-Orchestrierungsdienste ermöglichen Ihnen das Definieren von Geschäftsprozessen, mit denen die Nachricht erstellt wird, und ihre anschließende Implementierung mithilfe einer weitgehend integrierten grafischen Umgebung. Prozesse, die mithilfe der BizTalk-Orchestrierungsdienste definiert wurden, zeichnen sich in erster Linie dadurch aus, dass sie problemlos geändert werden können, wenn sich die Geschäftsbedingungen ändern. So können Sie flexibel auf diese Änderungen reagieren.

Da bei den meisten Geschäftsprozessen Dokumente gesendet und empfangen und Geschäftsregeln auf den Prozess angewendet werden, wurden die BizTalk-Messagingdienste und BizTalk-Orchestrierungsdienste so entworfen, dass sie problemlos zusammenarbeiten können. So haben Sie die Möglichkeit, integrierte Lösungen zu erstellen.

Weiter mit Installieren von BizTalk Server.


Installieren von BizTalkServer

BizTalk Server 2002 ~ Kennenlernen

Installieren von BizTalk Server

In den folgenden Lektionen arbeiten Sie mit einem Beispielszenario, in dem Northwind Traders Computer bei der Contoso AG kauft. In diesen Lektionen wird erläutert, was in jedem Schritt des Prozesses geschieht, und es wird gezeigt, wie Sie mit dem BizTalk-Editor Formate für die Geschäftsdokumente in XML definieren, wie Sie mit dem BizTalk-Orchestrierungs-Designer interne Geschäftsprozesse beschreiben und wie Sie dies alles verbinden. Es gibt zwar keine spezifische Codierung für die BizTalk Server-Integration, dennoch müssen Sie Ihre eigenen geschäftsspezifischen Regeln festlegen. In diesen Lektionen ist allerdings nur eine minimale Codierung erforderlich.

Die in den Lektionen verwendeten Beispiele sind so konzipiert, dass sie auf einem Einzelcomputer installiert und ausgeführt werden können. Sie können das gleiche Szenario aber auch für zwei oder mehrere Server konfigurieren.

Lesen Sie vor der Installation von Microsoft BizTalk Server 2002 die Dokumente Readme.htm und Installation Guide.htm, und stellen Sie sicher, dass folgende Voraussetzungen erfüllt sind:

  • Sie benötigen einen Computer unter Microsoft® Windows® 2000 mit Service Pack 2 oder höher (entweder Windows 2000 Professional oder Windows 2000 Server), einschließlich Internet-Informationsdienste (IIS) und Message Queuing, und ein Konto mit Administratorrechten auf diesem Computer.

  • Sie benötigen Microsoft SQL Server™ 7.0 mit Service Pack 3 oder SQL Server 2000 mit Service Pack 1. Sie müssen SQL Server für die Windows-Authentifizierung konfigurieren.

  • Auf dem Computer, auf dem Sie BizTalk Server installieren, muss bereits Microsoft Visio® 2002 installiert sein.

  • Im Internetdienste-Manager der Verwaltung muss das Kontrollkästchen Dokumenterstellung aktivieren auf der Registerkarte Servererweiterungen des Dialogfeldes Eigenschaften von Standardwebsite deaktiviert sein. Weitere Informationen finden Sie unter Konfigurieren von IIS-Einstellungen für BizTalk Server 2002.

  • Um die Skripts für diese Lektionen auszuführen, müssen Sie die Komponente Message Queuing von Windows 2000 installieren.

Detaillierte Informationen zum Installationsvorgang finden Sie unter Installieren von BizTalk Server 2002.

Weiter mit Das Szenario.


Das Szenario

Ein Computerhardwarehändler, Northwind Traders, bestellt Computerersatzteile von einem seiner Lieferanten, der Contoso AG. Eine interne Beschaffungsanwendung bei Northwind Traders erstellt eine Kaufanforderung, wie die in Gründe für die Verwendung von XML, und schreibt sie als Datei auf eine Festplatte. Microsoft BizTalk Server 2002 überwacht den Dateispeicherort und gibt die Datei an den automatisierten Bestellungsgenehmigungsprozess von Northwind Traders weiter, sobald eine Kaufanforderung festgestellt wird. Eine abgelehnte Anforderung wird entsprechend markiert und als Datei auf eine Festplatte geschrieben. Für eine genehmigte Anforderung wird ein Auftrag generiert und mithilfe des HTTP-Protokolls an die Contoso AG gesendet. In diesem Szenario wird eine Anforderung immer genehmigt, sofern sie nicht über einen Wert von €1000 hinausgeht. Andernfalls wird sie abgelehnt.

In diesem Szenario verwenden beide Unternehmen BizTalk Server. Server mit BizTalk Server arbeiten sehr gut zusammen. Die Verwendung von BizTalk Server ist jedoch auch für die Zusammenarbeit mit Unternehmen möglich, die diese Anwendung nicht verwenden.

Nachdem BizTalk Server den Auftrag bei der Contoso AG empfangen hat (in diesem Szenario werden Aufgaben bei beiden Beteiligten von der gleichen BizTalk Server-Instanz abgewickelt), übergibt BizTalk Server den Auftrag an den Geschäftsprozess der Contoso AG, der eine Rechnung generiert. Die Rechnung wird über HTTP an Northwind Traders übermittelt. Schließlich empfängt die Anwendung BizTalk Server bei Northwind Traders die Rechnung und schreibt sie als Datei auf eine Festplatte.

Die folgende Abbildung zeigt diesen Prozess auf allgemeiner Ebene.

Prozessübersicht für das Lernprogramm "Kennenlernen von BizTalk".

Weiter mit Ausführen des Szenarios.


Ausführen des Szenarios

Wichtig

  • Für eine erfolgreiche Ausführung dieses Szenarios müssen Sie das Verzeichnis LearnBizTalk auf Laufwerk C: kopieren und alle Komponenten von BizTalk Server auf Laufwerk C: installieren. Es ist zwar möglich, diese Dateien von einem anderen Laufwerk bzw. Verzeichnis auszuführen, jedoch müssten Sie dazu umfangreiche Änderungen an den Quelldateien vornehmen. Weitere Informationen zu diesen Voraussetzungen finden Sie unter Kennenlernen von BizTalk Server 2002.

So konfigurieren Sie BizTalk Server für das Lernprogramm

  1. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Scripts, und doppelklicken Sie auf Setup.vbs.

    Diese Skriptdatei konfiguriert BizTalk Server für die Verwendung in diesen Lektionen. Die Ausführung des Skripts kann je nach Serverumgebung mehrere Minuten dauern. Wenn der Vorgang abgeschlossen ist, werden Sie über ein Meldungsfeld informiert.

  2. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Documents, und doppelklicken Sie auf ReqToApprove.xml und ReqToDecline.xml, um diese beiden Dateien in Microsoft Internet Explorer zu öffnen.

    Wie Sie sehen, ist das Feld reqStatus jetzt auf New festgelegt. Beachten Sie außerdem die Werte der Felder totalPrice und reqNumber in jedem Dokument.

So zeigen Sie die Verarbeitung des Dokuments durch BizTalk Server an

  1. Kopieren Sie die Datei ReqToDecline.xml aus dem Verzeichnis C:\LearnBizTalk\Documents in das Verzeichnis C:\LearnBizTalk\Pickup.

    Anmerkung

    • Sie dürfen die Datei nicht verschieben, denn sie wird von BizTalk Server verarbeitet und dann aus dem Verzeichnis \Pickup entfernt. Da der Bestellwert dieser Anforderung €1000 überschreitet, wird sie abgelehnt und ein Meldungsdialogfeld angezeigt.
  2. Kopieren Sie die Datei ReqToApprove.xml aus dem Verzeichnis C:\LearnBizTalk\Documents in das Verzeichnis C:\LearnBizTalk\Pickup.

    Diesmal wird die Anforderung genehmigt, ein Auftrag generiert und an die Contoso AG gesendet. Dort wird der Auftrag verarbeitet, eine Rechnung erstellt und an Northwind Traders zurückgesendet, wo sie schließlich eingeht und als Datei in das Verzeichnis C:\LearnBizTalk\Output geschrieben wird.

  3. Doppelklicken Sie im Verzeichnis \Output auf die Datei ContosoInvoice.xml, um sie in Internet Explorer zu öffnen.

    Der Wert im Feld referenceNumber stimmt nun mit dem Wert im ursprünglichen Feld reqNumber überein.

In den folgenden Lektionen werden wir uns genauer ansehen, was in jedem einzelnen Schritt dieses Prozesses abläuft und wie BizTalk Server für die Ausführung aller notwendigen Tasks konfiguriert wird.

Weiter mit Lektion 2: Konfigurieren der BizTalk-Messagingdienste.


Lektion 2: Konfigurieren der BizTalk-Messagingdienste

In dieser Lektion werden die einzelnen Schritte des in Lektion 1 eingerichteten Szenarios erläutert. In den übrigen Lektionen werden Sie weitere Skriptdateien ausführen. Diese Skripts nehmen Anpassungen an der ursprünglichen Microsoft BizTalk Server 2002-Konfiguration vor, damit Sie anstatt des in Lektion 1 gezeigten vollständigen Prozesses die Ergebnisse einzelner Schritte im Prozess sehen können.

Folgende Themen werden in dieser Lektion behandelt:

  • Konfigurieren der BizTalk-Messagingdienste

  • Konfigurieren von Dateiempfangsfunktionen

  • Konfigurieren von Messagingports und Kanälen

  • Definieren von Dokumentspezifikationen

  • Ausführen des Szenarios


Konfigurieren der BizTalk-Messagingdienste

Die BizTalk-Messagingdienste bieten eine Methode zum Übergeben von Dokumenten zwischen internen Anwendungen und externen Geschäftspartnern. Mit den BizTalk-Messagingdiensten können Sie den Empfang, die Verarbeitung und die Übermittlung von Dokumenten an das jeweilige Ziel definieren. Außerdem stellen Sie wichtige Features bereit, wie z. B das Überprüfen der Dokumentstruktur, digitale Signaturen, Verschlüsselungen und die sichere Übermittlung bei unzuverlässigen Transportmethoden.

Die Skriptdatei L2Prep.vbs ändert die Konfiguration der BizTalk-Messagingdienste, so dass das Dokument nicht an die BizTalk-Orchestrierungsdienste übermittelt, sondern als Datei geschrieben wird, die sie überprüfen können.

So führen Sie dieses Skript aus

  • Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Scripts, und doppelklicken Sie auf L2Prep.vbs.

Die folgende Abbildung zeigt, wie das Dokument verarbeitet wird.

Weiter mit Konfigurieren der Dateiempfangsfunktionen


Konfigurieren von Dateiempfangsfunktionen

Mit den Dateiempfangsfunktionen können Sie eine von einer internen Anwendung erstellte Datei mit den BizTalk-Messagingdiensten verwenden. Ein Vorteil der Verwendung einer Ausgabedatei besteht darin, dass eine interne Geschäftsanwendung, die diese Datei erstellt, nicht mit BizTalk Server kommunizieren muss. Sie erstellt einfach eine Datei, die das Dokument enthält, und sendet sie an einen bestimmten, von BizTalk Server überwachten Speicherort, an dem BizTalk Server sie aufnimmt. Wenn Sie Ausgabedateien erstellen und Eingabedateien in den vorhandenen Anwendungen empfangen können, können Sie sie möglicherweise ganz unverändert mit BizTalk Server verwenden.

Ein weiterer wichtiger Aspekt der Dateiempfangsfunktionen ist die asynchrone Verarbeitung. Asynchron (Bedeutung: "nicht zur gleichen Zeit") bezieht sich auf Prozesse, die unabhängig voneinander erfolgen. Das Verwenden der asynchronen Verarbeitung ist in einer verteilten Umgebung wichtig, denn sie macht es möglich, dass jeder Teil der Lösung selbständig funktioniert und nicht betroffen ist, wenn ein anderer Teil der Lösung aufgrund eines Fehlers oder eines geplanten Wartungsvorgangs vorübergehend nicht verfügbar ist.

Wenn das Netzwerk z. B. für kurze Zeit ausfällt, hat dies keine Auswirkungen auf die Anwendung insgesamt, denn die von den internen Geschäftsanwendungen produzierten Dokumente sammeln sich einfach auf der Festplatte an. Sobald das Netzwerk wieder verfügbar ist, nimmt BizTalk Server alle im zugewiesenen Verzeichnis enthaltenen Dateien auf und verarbeitet sie. Wenn Sie mehr Dokumente generieren, als ein Server mit einer akzeptablen Geschwindigkeit verarbeiten kann, können Sie auch weitere BizTalk-Server hinzufügen und für die Verarbeitung von Dokumenten aus dem gleichen Verzeichnis konfigurieren.

So sehen Sie, wie die Dateiempfangsfunktion konfiguriert ist.

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk Server-Verwaltung.

  2. Erweitern Sie Microsoft BizTalk Server 2002, BizTalk Server-Gruppe und Empfangsfunktionen, klicken Sie mit der rechten Maustaste auf ReceiveReq, und klicken Sie auf Eigenschaften.

    Das Dialogfeld Eigenschaften von ReceiveReq wird angezeigt.

    Überprüfen Sie die Einstellungen auf der Registerkarte Allgemein, und wählen Sie dann die Registerkarte Dienste aus. Die folgende Abbildung zeigt die Registerkarte Dienste, auf der Sie erkennen, dass die Funktion als Dateiempfangsfunktion konfiguriert wurde und das nach Dateien zu durchsuchende Verzeichnis und die aufzunehmenden Dateitypen angegeben wurden.

    Dialogfeld Eigenschaften von ReceiveReq

    Auf der Registerkarte Erweitert wird angegeben, wohin BizTalk Server die gefundenen Dateien übermittelt. Außerdem wird hier ein Kanal mit dem Namen Channel To Approval identifiziert, an den die Empfangsfunktion die Dokumente übermittelt. Kanäle sowie die zugehörigen Messagingports werden im nächsten Abschnitt behandelt. Weitere Informationen finden Sie unter Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen.

  3. Schließen Sie das Dialogfeld Eigenschaften von ReceiveReq.

  4. Schließen Sie das Fenster BizTalk Server-Verwaltung.

Anmerkung

  • Dateiempfangsfunktionen stellen nicht die einzige Möglichkeit zum Übermitteln von Dokumenten an BizTalk Server dar. Sie können auch Dokumente von Message Queuing, über E-Mail (SMTP) und von Webseiten (HTTP/HTTPS) sowie von einem Component Object Model (COM) in Ihren eigenen Anwendungen empfangen. Weitere Informationen finden Sie unter Verfügbare Empfangsfunktionen.

Weiter mit Konfigurieren von Messagingports und Kanälen


Konfigurieren von Messagingports und Kanälen

Um ein Dokument an ein Ziel zu übermitteln, müssen Sie das Ziel in den BizTalk-Messagingdiensten definieren. Ziele werden in den BizTalk-Messagingdiensten als Messagingports bezeichnet. Ein Messagingport enthält außerdem eine Gruppe von Eigenschaften, mit denen Sie steuern können, wie Dokumente gesichert und an ihr Ziel (d. h. eine interne Anwendung oder einen externen Geschäftspartner) transportiert werden.

Anmerkung

  • Sie können Messagingports in Verteilerlisten gruppieren, um das gleiche Dokument an mehrere Ziele (d. h. an interne Anwendungen oder externe Geschäftspartner) zu senden.

Der beim Ausführen des Setupskripts definierte Messagingport heißt Req Approval Port. Dies ist der Messagingport zu einer internen Anwendung, die den Geschäftsprozess für die Anforderungsgenehmigung bei Northwind Traders darstellt.

So zeigen Sie die Messagingporteigenschaften an

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Klicken Sie auf Messagingports und dann auf Jetzt suchen.

  3. Doppelklicken Sie im rechten Fenster auf Req Approval Port, um dieses zu bearbeiten.

    Die Seite Messagingporteigenschaften wird geöffnet.

  4. Klicken Sie auf Weiter.

    Die Seite Zielorganisation wird angezeigt.

    In der folgenden Abbildung zeigt die Seite Zielorganisation, dass dieses Dokument an eine Datei gesendet wird.

    Seite Zielorganisation im Messagingport-Assistenten

In Lektion 1 hat dieser Messagingport eine Nachricht an den XLANG-Ablaufplan in den BizTalk-Orchestrierungsdienstengesendet. Dadurch wird der Genehmigungsprozess implementiert. (Die BizTalk-Orchestrierungsdienste werden in der nächsten Lektion ausführlicher behandelt.) Dies wurde zu Beginn der Lektion durch Ausführen des Skripts geändert, so dass Sie nun die Ausgabe sehen können.

Anstatt ein Dokument an die BizTalk-Orchestrierungsdienste oder an eine Datei zu übermitteln, können Sie einen Messagingport so konfigurieren, dass Dokumente über ein beliebiges, unterstütztes Protokoll, wie z. B. HTTP/HTTPS, SMTP, Message Queuing und benutzerdefinierte Anwendungsintegrationskomponenten (Application Integration Components, AICs), übermittelt werden.

Sie können außerdem zusätzliche Sicherheitsfeatures für einen Messagingport konfigurieren, indem Sie Ihr Dokument verschlüsseln (optional) und/oder eine digitale Signatur hinzufügen.

Als Nächstes werden Sie einen Kanal definieren, über den dieses Dokument übermittelt wird. Ein Kanal enthält eine Gruppe von Eigenschaften, mit denen die Quellorganisation oder -anwendung identifiziert wird, die das Dokument gesendet hat. Zudem werden mit den Eigenschaften die spezifischen Schritte definiert, die BizTalk Server ausführt, bevor das Dokument an den zum Kanal gehörenden Messagingport gesendet wird. Die folgende Abbildung zeigt die Beziehungen zwischen Empfangsfunktionen, Kanälen und Messagingports.

Empfangsfunktionen, Kanäle und Messagingports

So sehen Sie, wie der Kanal eingerichtet ist, der Anforderungen an den Genehmigungsprozess von Northwind Traders sendet

  1. Öffnen Sie ggf. den BizTalk-Messaging-Manager.

  2. Klicken Sie auf Kanäle und dann auf Jetzt suchen.

  3. Doppelklicken Sie im rechten Fenster auf Channel To Approval, um diesen Kanal zu bearbeiten.

    Die Seite Kanaleigenschaften wird angezeigt.

  4. Klicken Sie auf Weiter.

    Anmerkung

    • Alternativ können Sie auch den Messagingport Req To Approval auswählen, indem Sie mit der rechten Maustaste darauf klicken und dann im Kontextmenü auf Kanäle suchen klicken. Dadurch werden alle Kanäle angezeigt. Nur Channel To Approval ist mit Req To Approval verbunden.

    In den folgenden Abbildungen können Sie sehen, dass die von diesem Kanal zu verarbeitenden Dokumente von einer internen Einkaufsanwendung stammen und ein Format aufweisen, das von einer Dokumentdefinition namens Northwind Req beschrieben wird.

    Seite Quellanwendung im Kanal-Assistenten

  5. Klicken Sie auf Abbrechen, um die Seite Kanaleigenschaften zu schließen.

  6. Schließen Sie das Fenster BizTalk-Messaging-Manager.

Anmerkung

  • Sie haben die Möglichkeit, einen Kanal anzuweisen, ein Dokument von einer Dokumentdefinition in eine andere zu konvertieren, und können außerdem angeben, welche Informationen beim Übermitteln von Dokumenten durch den Kanal zu Überwachungszwecken protokolliert werden müssen. In Lektion 5 finden Sie weitere Informationen zur Dokumentkonvertierung mit dem BizTalk-Mapper.

Weitere Informationen zu Messagingports und Kanälen finden Sie unter Grundlegendes zu Messagingports und Grundlegendes zu Kanälen.

Im folgenden Thema wird erläutert, was eine Dokumentdefinition ist und wie sie erstellt wird.

Weiter mit Definieren von Dokumentspezifikationen


Definieren von Dokumentspezifikationen

In Lektion 1 wurde erklärt, wie wichtig es für Unternehmen ist, beim Beschreiben von Dokumenten, die zwischen Unternehmen ausgetauscht werden, die gleiche Sprache zu verwenden. Diese gemeinsame Sprache ist XML. Obwohl XML-Dokumente im Textformat gespeichert werden und mit einem beliebigen Texteditor geöffnet werden können, ist ihre manuelle Erstellung und Bearbeitung mühselig und kann zu Fehlern führen. BizTalk Server stellt den BizTalk-Editor bereit, ein Tool, das diese Aufgabe erleichert.

So öffnen Sie die Datei "NorthwindReq.xml"

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Editor.

  2. Klicken Sie im Menü Datei auf Öffnen.

  3. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Documents, wählen Sie NorthwindReq.xml aus, und klicken Sie anschließend auf Öffnen.

    Die Datei wird im BizTalk-Editor geöffnet und wie in der folgenden Abbildung angzeigt.

    NorthwindReq.xml im BizTalk-Editor geöffnet

Der BizTalk-Editor bietet eine einfache Methode zum Verwalten von Spezifikationen. Dazu gehört die Möglichkeit, das Format eines Dokuments zu visualisieren, Datentypen für einzelne Elemente und Attribute zu definieren und festzulegen, welche Datenfelder erforderlich und welche optional sind. Dieses bestimmte Dokumentschema stellt ein XML-Dokument dar, aber der BizTalk-Editor sieht bei EDI- (Electronic Data Interchange) und Flatfile-Schemas ähnlich aus.

Da Sie auf einer beliebigen Arbeitsstation, auf der der BizTalk-Editor installiert ist, mit der Dokumentspezifikation arbeiten können, muss die Spezifikation nach ihrer Erstellung dem WebDAV-Repository von BizTalk Server hinzugefügt werden, damit BizTalk Server sie abrufen kann.

Anmerkung

  • WebDAV (Web Distributed Authoring and Versioning) ist der IETF-Standard (Internet Engineering Task Force) für die kollaborative Dokumenterstellung im Web. Es erleichtert die kollaborative Bearbeitung und Dateiverwaltung zwischen Benutzern an verschiedenen Standorten im Internet. Weitere Informationen zu WebDAV finden Sie im Dokument "HTTP Extensions for Distributed Authoring -- WEBDAV" in der IETF-Website (ietf.org/rfc/rfc2518.txt).

Um die Dokumentdefinition zu erstellen, müssen Sie eine spezifische, im BizTalk-Editor erstellte und in WebDAV gespeicherte XML-Spezifikation mit einem von BizTalk Server verwendeten Namen verknüpfen.

So erstellen Sie eine Dokumentdefinition

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Wenn das Dialogfeld BizTalk-Messaging-Manager angezeigt wird, klicken Sie auf Abbrechen.

  3. Zeigen Sie im Menü Datei auf Neu, und klicken Sie dann auf Dokumentdefinition.

    Das Dialogfeld Neue Dokumentdefinition wird angezeigt.

  4. Geben Sie in das Feld Dokumentdefinitionsname einen Namen für die Dokumentdefinition ein.

  5. Aktivieren Sie das Kontrollkästchen Dokumentspezifikation, und klicken Sie auf Durchsuchen.

    Das Dialogfeld Dokumentspezifikation aus dem WebDAV-Repository auswählen wird angezeigt.

  6. Doppelklicken Sie auf den Ordner Microsoft, klicken Sie auf das gewünschte Schema und dann auf Öffnen.

    In diesem Dialogfeld können Sie ein beliebiges im BizTalk Server WebDAV-Repository gespeichertes Schema auswählen.

  7. Klicken Sie auf OK, um die neue Dokumentdefinition zu speichern.

  8. Schließen Sie den BizTalk-Messaging-Manager.

Anmerkung

  • Sie können mehrere Dokumentdefinitionen erstellen, die auf dem gleichen Schemadokument basieren. Sie können für jede erstellte Dokumentdefinition globale Dokumentüberwachungsoptionen definieren (optional). Weitere Informationen finden Sie unter Grundlegendes zu Dokumentdefinitionen.

Weiter mit Ausführen des Szenarios.


Ausführen des Szenarios

Wichtig

  • Für eine erfolgreiche Ausführung dieses Szenarios müssen Sie das Verzeichnis LearnBizTalk auf Laufwerk C: kopieren und alle Komponenten von BizTalk Server auf Laufwerk C: installieren. Es ist zwar möglich, diese Dateien von einem anderen Laufwerk bzw. Verzeichnis auszuführen, jedoch müssten Sie dazu umfangreiche Änderungen an den Quelldateien vornehmen. Weitere Informationen zu diesen Voraussetzungen finden Sie unter Kennenlernen von BizTalk Server 2002.

So führen Sie das Szenario aus

  1. Kopieren Sie die Datei ReqToApprove.xml aus dem Verzeichnis C:\LearnBizTalk\Documents ins Verzeichnis C:\LearnBizTalk\Pickup.

    Die zuvor definierte Dateiempfangsfunktion ReceiveReq nimmt diese Datei auf und übermittelt sie über den Kanal Channel To Approval an den Messagingport Req Approval Port.

  2. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Output, und doppelklicken Sie auf die Datei NorthwindRequisition.xml, um sie in Internet Explorer zu öffnen.

    Beachten Sie, dass es sich hierbei um das gleiche Dokument handelt, das Sie ins Verzeichnis \Pickup eingefügt haben. Zu Beginn dieser Lektion haben Sie das Skript L2Prep.vbs ausgeführt, das die Kanal- und Messagingportdefinitionen geändert hat. Anstatt das Anforderungsdokument an die BizTalk-Orchestrierungsdienste zu übermitteln, hat der Messagingport den Inhalt des Dokuments in die Datei NorthwindRequisition.xml im Verzeichnis \Output geschrieben.

  3. Führen Sie diese Schritte erneut aus, aber diesmal mit der Datei ReqToDecline.xml. Die Datei im Verzeichnis \Output wird von der neu gesendeten Anforderung überschrieben.

In dieser Lektion haben Sie eine Übersicht über die grundlegende Funktionsweise der BizTalk-Messagingdienste erhalten. Sie haben ein Skript ausgeführt, das die Dienste konfiguriert hat, die betreffenden Eigenschaften überprüft, eine Datei aus dem Dateisystem eines Verzeichnisses in einem anderen Verzeichnis abgelegt. Nachdem Sie nun die Hauptkonzepte und die grundlegende Terminologie kennen gelernt haben, werden in den folgenden Lektionen einige zusätzliche Features vorgestellt.

In der nächsten Lektion erfahren Sie, wie der Anforderungsgenehmigungsprozess von Northwind Traders mithilfe der BizTalk-Orchestrierungsdienste definiert wird.

Weiter mit Lektion 3: Entwerfen der BizTalk-Orchestrierungsdienste


Lektion 3: Entwerfen der BizTalk-Orchestrierungsdienste

In dieser Lektion wird eine Übersicht darüber gegeben, wie Northwind Traders ihren Anforderungsgenehmigungsprozess mithilfe der BizTalk-Orchestrierungsdienste implementiert. Die folgende Abbildung bietet eine Detailansicht des Anforderungsgenehmigungsprozesses.

Lektion 3: Prozessvorschau

In diesem Abschnitt werden folgende Themen behandelt:

  • BizTalk-Orchestrierungsdienste

  • Definieren des Geschäftsprozesses

  • Implementieren des Geschäftsprozesses

  • Erstellen des Kommunikationsflusses

  • Ausführen des Szenarios


BizTalk-Orchestrierungsdienste

Microsoft BizTalk Server 2002 löst zwei Probleme: Es stellt BizTalk-Messagingdienste zum Senden von Nachrichten zwischen Geschäftsprozessen und BizTalk-Orchestrierungsdienste zum Erstellen von Geschäftsprozessen bereit. In der vorangegangenen Lektion haben Sie gelernt, wie Sie Ihre Geschäftsdokumente an BizTalk-Messagingdienste übermitteln. In dieser Lektion wird erläutert, wie Sie Geschäftsprozesse definieren und mithilfe der BizTalk-Orchestrierungsdienste anwenden.

BizTalk-Orchestrierungsdienste ermöglichen das Erstellen einer detaillierten Darstellung Ihres Geschäftsprozesses und die programmgesteuerte Implementierung des Geschäftsprozesses in eine integrierte, auf Microsoft Visio 2002 basierende Entwurfsumgebung. In der Vergangenheit wurden die Entwurfs- und die Implementierungsphase getrennt ausgeführt. Zu den wichtigen Features der BizTalk-Orchestrierungsdienste gehört die Integration dieser ehemals getrennten Phasen in einer vereinheitlichten grafischen Entwurfsumgebung.

Wenn sich die Geschäftsprozesse auf der Geschäftsebene ändern, können Änderungen wesentlich schneller auf der Implementierungsebene wiedergegeben werden, da diese Prozesse in einer grafischen Umgebung definiert werden.

Die BizTalk-Orchestrierungsdienste integrieren nicht nur den Entwurf und die Implementierung, sondern stellen darüber hinaus Funktionen bereit, mit denen Prozesse mit Parallelität erstellt, mehrere Aufgaben gleichzeitig erledigt und robuste, langlebige Geschäftsprozesse erstellt werden können, die sich über Anwendungen, Plattformen und Organisationen erstrecken.

Zum Erstellen von robusten, langlebigen Geschäftsprozessen speichern die BizTalk-Orchestrierungsdienste Instanzen von langlebigen Geschäftsprozessen und halten sie an. Dadurch werden Computerressourcen eingespart und zusätzliche Zuverlässigkeit erzielt. Zu einem späteren Zeitpunkt startet der Server diese Prozesse an genau der Stelle neu, an der sie für die Ausführung eines langen Vorgangs angehalten wurden. Die angehaltenen Prozesse werden bei Auslösung neu gestartet, auch wenn der Computer in der Zwischenzeit ausgeschaltet wurde. Die Bezahlung einer Rechnung ist ein Beispiel für einen solchen langlebigen Vorgang. Der Vorgang dauert i. d. R. 20 bis 30 Tage, bevor er abgeschlossen ist. Weitere Informationen finden Sie unter Understanding Orchestration Services.

Weiter mit Definieren des Geschäftsprozesses


Definieren des Geschäftsprozesses

In dieser Lektion werden Sie die XLANG-Ablaufplanzeichnung öffnen und durchgehen, die den Geschäftsprozess zum Genehmigen von Anforderungen bei Northwind Traders darstellt.

So überprüfen Sie den Geschäftsprozess von Northwind Traders

  1. Zeigen Sie im Startmenü auf Programme und auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Orchestrierungs-Designer.

  2. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld XLANG-Ablaufplanzeichnung öffnen wird angezeigt.

  3. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Schedules, wählen Sie NorthWindApprovalL3.skv aus, und klicken Sie anschließend auf Öffnen.

Anmerkung

  • Sie können die leere Zeichnung, die im BizTalk-Orchestrierungs-Designer angezeigt wird, schließen.

Die folgende Abbildung zeigt die Zeichnung des Genehmigungsprozesses von Northwind Traders, die im BizTalk-Orchestrierungs-Designer entworfen wurde.

Genehmigungsprozess von Northwind Traders

Wenn Sie schon einmal Diagramme mit Microsoft Visio gezeichnet haben, wird Ihnen der BizTalk-Orchestrierungs-Designer wahrscheinlich vertraut vorkommen. Im BizTalk-Orchestrierungs-Designer definieren Sie Ihre Geschäftsprozess mithilfe von Flussdiagrammformen, wie z. B. Aktion, Entscheidung und While, anstatt mit komplexeren Elementen, wie z. B. Dokumenten, Spezifikationen, Komponenten und Nachrichten. Der Anzahl oder der Namen der Schritte in Ihrem Geschäftsprozess sind keine Grenzen gesetzt. Darüber hinaus können Sie den Prozess mit Verzweigung-Formen in mehrere parallele Pfade aufteilen, um z. B. ein Preisangebot von mehreren Lieferanten anzufordern, und die Pfade später mit einer Verknüpfung-Form wieder vereinigen. Und schließlich können Sie mit der Transaktion-Form bei Bedarf mehrere Schritte des Prozesses zu einer einheitlichen Transaktion bündeln. Weitere Informationen finden Sie unter Flussdiagrammformen.

Weiter mit Implementieren des Geschäftsprozesses


Implementieren des Geschäftsprozesses

Nachdem Sie den Geschäftsprozess definiert haben, können Sie ihn implementieren. Dazu müssen Sie BizTalk für die Ausführung jeder einzelnen, im Geschäftsprozess definierten Aufgabe konfigurieren.

Die folgende Abbildung zeigt die im Genehmigungsprozess von Northwind Traders verwendeten Implementierungsformen.

Implementierungsformen im BizTalk-Orchestrierungs-Designer

Es ist wichtig zu verstehen, wie die BizTalk-Messaging-Form, die COM-Komponente-Form und die Message Queuing-Form verwendet werden. Beachten Sie, dass Sie keinen Code schreiben, um die Geschäftsprozesse zu verbinden. Die Codierung liegt in den individuellen Komponenten einer speziellen Geschäftslogik, und nicht in der Implementierung, die sie zusammenhält.

Wenn Sie z. B. eine BizTalk-Messaging-Form durch Drag&Drop auf eine Zeichnung ziehen, wird der BizTalk-Bindungs-Assistent für Messaging geöffnet, der Sie durch eine Reihe von Seiten führt, auf denen Sie den mit einer bestimmten Implementierungsform verknüpften Messagingport definieren. Ein Messagingport ist eine Auflistung von Eigenschaften, die mit einem bestimmten Dokumentziel verknüpft sind. Ihr Geschäftsprozess kann ein solches Ziel darstellen. Weitere Informationen finden Sie unter Implementierungsformen.

Für leichtere Aufgaben können Sie auch Komponenten in einer Skriptsprache Ihrer Wahl erstellen, wie z. B. Microsoft® Visual Basic® Scripting Edition (VBScript). Eine solche Komponente wurde in dieser XLANG-Ablaufplanzeichnung verwendet. Diese Skriptkomponente verwendet die DeclineReq-Methode, deren einzige Aufgabe es ist, dem Benutzer ein Meldungsfeld anzuzeigen, wenn eine Anforderung abgelehnt wurde. Weitere Informationen finden Sie unter Erstellen einer Skriptkomponente.

Der XLANG-Ablaufplan NorthwindApprovalL3.skv enthält zwei Skriptkomponenten und eine BizTalk-Messaging-Form.

Wenn bei einem bestimmten Teil des Geschäftsprozesses spezielle Aufgaben anfallen, wie z. B. das Zugreifen auf interne Datenbanken oder das Herstellen einer Verbindung mit einem Mainframesystem, würden Sie die Aufgaben höchstwahrscheinlich in eine COM-Komponente implementieren und die entsprechenden Methoden von den BizTalk-Orchestrierungsdiensten aufrufen.

In der nächsten Lektion wird der Prozess beim Erstellen einer Skriptkomponente behandelt.

Weiter mit Erstellen des Kommunikationsflusses.


Erstellen des Kommunikationsflusses

Um einen Kommunikationsfluss zu erstellen, müssen Sie eine Verbindung zwischen der Geschäftsprozessdefinition und der Implementierung herstellen. Jede in der Flussdiagrammschablone verwendete Flussdiagrammform sowie jede in der Implementierungsschablone verwendete Implementierungsform hat einen seitlichen Kontrollhandle ( Kontrollhandle ). Sie können eine Aktion-Form auf der linken Seite mit einer Implementierungsform auf der rechten Seite verbinden, indem Sie zwischen dem Handle der Aktion-Form und dem Handle des Implementierungsports eine Linie zeichnen. Nachdem die Formen verbunden wurden, wird der Assistent für XML-Kommunikation geöffnet und fordert Sie auf, einige Fragen zu beantworten, anhand derer ermittelt wird, wie die Kommunikation zwischen den Formen abläuft. Weitere Informationen finden Sie unter Verwenden des Assistenten für die XML-Kommunikation.

Nachdem Sie die Aktion- und Implementierungsformen verbunden haben, müssen Sie im letzten Schritt auf der Datenseite definieren, wie das Geschäftsdokument von einer Aktion an die nächste übergeben wird. Zum Anzeigen der Datenseite klicken Sie auf die Registerkarte Daten unten in der Zeichnung im BizTalk-Orchestrierungs-Designer. In der nächsten Lektion wird die Datenseite ausführlicher behandelt.

Weiter mit Ausführen des Szenarios.


Ausführen des Szenarios

Wichtig

  • Für eine erfolgreiche Ausführung dieses Szenarios müssen Sie das Verzeichnis LearnBizTalk auf Laufwerk C: kopieren und alle Komponenten von BizTalk Server auf Laufwerk C: installieren. Es ist zwar möglich, diese Dateien von einem anderen Laufwerk bzw. Verzeichnis auszuführen, jedoch müssten Sie dazu umfangreiche Änderungen an den Quelldateien vornehmen. Weitere Informationen zu diesen Voraussetzungen finden Sie unter Kennenlernen von BizTalk Server 2002.

So testen Sie das Szenario

  1. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Scripts, und doppelklicken Sie auf L3Post.vbs.

    Dieses Skript ändert vorübergehend Ihre XLANG-Ablaufplanzeichnung, so dass die Anforderung noch nicht an die Contoso AG übergeben wird. Die ursprüngliche Konfiguration wird zu einem späteren Zeitpunkt wiederhergestellt. Diese Änderung ist aber jetzt von Nutzen, um Ihnen diesen Schritt im Prozess zu zeigen.

  2. Kopieren Sie die Datei ReqToDecline.xml aus dem Verzeichnis C:\LearnBizTalk\Documents in das Verzeichnis C:\LearnBizTalk\Pickup.

    Die Dateiempfangsfunktion empfängt diese Datei und übermittelt sie an die BizTalk-Messagingdienste. Die BizTalk-Messagingdienste rufen mithilfe der BizTalk-Orchestrierungdienste den Anforderungsgenehmigungsprozess von Northwind Traders auf, da Sie einen XLANG-Ablaufplan als Ziel für den Messagingport definiert haben, der für diesen Geschäftsprozess erstellt wurde. Zum Schluss verarbeiten die BizTalk-Orchestrierungdienste die Anforderung und zeigen ein Meldungsdialogfeld an, das Ihnen mitteilt, dass diese Anforderung abgelehnt wurde.

  3. Wiederholen Sie Schritt 2 mit der Datei ReqToApprove.xml.

    Das Meldungsdialogfeld informiert Sie, dass die Anforderung genehmigt wurde.

In Lektion 4 werden weitere Informationen zum Konfigurieren von Implementierungsformen im BizTalk-Orchestrierungs-Designer gegeben sowie zum Entwickeln einer Skriptkomponente und zu den auf der Datenseite notwendigen Arbeitsschritten, damit das Dokument ordnungsgemäß von einer Aktion zur nächsten übergeben wird.

Weiter mit Lektion 4: Grundlegendes zur Implementierung


Lektion 4: Grundlegendes zur Implementierung

In Lektion 4 werden Sie den XLANG-Ablaufplan aus Lektion 3 erweitern und die Implementierung des Anforderungsgenehmigungsprozesses von Northwind Traders untersuchen.

Der Anforderungsgenehmigungsprozess wird mit den BizTalk-Orchestrierungsdiensten in Form eines XLANG-Ablaufplanes implementiert. In dieser Lektion werden Sie sich Konfigurationsparameter für verschiedene Implementierung-Formen ansehen, den Prozess zur Erstellung einer Windows-Skriptkomponentenimplementierung wiederholen und lernen, welche Arbeitsschritte Sie auf der Datenseite im BizTalk-Orchestrierungs-Designer ausführen müssen, um den korrekten Informationsfluss an den und aus dem XLANG-Ablaufplan sicherzustellen.

Folgende Themen werden in dieser Lektion behandelt:

  • Senden und Empfangen von Dokumenten in den BizTalk-Orchestrierungsdiensten

  • Hinzufügen von Feldern zu Nachrichtenspezifikationen

  • Arbeiten mit COM-Komponenten

  • Erstellen einer Skriptkomponente

  • Datenseite von Northwind Traders


Senden und Empfangen von Dokumenten in den BizTalk-Orchestrierungsdiensten

Ein XLANG-Ablaufplan ist der Ort, an dem Sie Ihren Geschäftsprozess implementieren. In den meisten Fällen muss dieser Prozess die verschiedenen Felder eines eingehenden Dokuments untersuchen und basierend auf den Werten Entscheidungen treffen oder Aktionen durchführen. In diesem Lernprogramm wird der Wert totalPrice des Anforderungsdokuments überprüft und die Anforderung nur genehmigt, wenn ihr Gesamtwert €1000 nicht überschreitet. Zuvor muss das Anforderungsdokument aber an den Genehmigungsprozess übermittelt werden.

Öffnen Sie zu Beginn dieser Lektion die Datei NorthwindApproval.skv im BizTalk-Orchestrierungs-Designer. Diese Datei ist der Datei NorthwindApprovalL3.skv aus Lektion 3 sehr ähnlich. Allerdings wurde hier eine der Windows-Skriptkomponenten durch eine BizTalk-Messaging-Form ersetzt, auf der Channel To Contoso zu lesen ist (siehe folgende Abbildung).

BizTalk-Messaging-Form Channel To Contoso

Nachdem der Geschäftsprozess der XLANG-Ablaufplanzeichnung definiert wurde und die Implementierungen hinzugefügt wurden, wird das Programm in einen XLANG-Ablaufplan kompiliert. Der Ablaufplan ist eine in der XLANG-Sprache verfasste Datei. Diese Sprache beschreibt mithilfe verschiedener Technologien die logische Abfolge von Geschäftsprozessen sowie die Implementierung des Geschäftsprozesses. Die XLANG-Sprache wird in XML dargestellt. Der XLANG-Ablaufplan definiert alle auszuführenden Schritte, aufzurufenden Komponenten und Daten, die übergeben werden müssen, um den definierten Prozess auszuführen. Nachdem beide Seiten des Diagramms abgeschlossen wurden, können Sie die XLANG-Ablaufplanzeichnung durch Klicken auf XLANG <Dateiname>.skx im Menü Datei des BizTalk-Orchestrierungs-Designers kompilieren.

In den vorangegangenen Lektionen haben Sie gelernt, wie eine Nachricht, die ein Geschäftsdokument enthält, mithilfe von BizTalk-Messagingdiensten gesendet wird. In dieser Lektion werden Sie die Nachricht und den Geschäftsprozess kombinieren.

In Lektion 2 haben Sie einen Messagingport definiert und ihn für die Übermittlung des Anforderungsdokuments an den XLANG-Ablaufplan konfiguriert. Sie haben den Namen eines XLANG-Ablaufplanes (die XLANG-Datei) angegeben, der von den BizTalk-Messagingdiensten gestartet werden soll, um die Anforderung zu verarbeiten. Sie haben des Weiteren den Namen eines Messagingports angegeben, um die im Ablaufplan enthaltene Anforderung zu empfangen. Dieser Orchestrierungsport muss im BizTalk-Orchestrierungs-Designer konfiguriert werden. Wie Sie sehen, bezieht sich der Begriff "Port" auf zwei verschiedene Elemente: Bei einem im BizTalk-Messaging-Manager definierten Messagingport und einem im BizTalk-Orchestrierungs-Designer definierten Orchestrierungsport handelt es sich um verschiedene Dinge.

Verwenden einer BizTalk-Messaging-Implementierung

Die BizTalk-Messaging-Form dient zum Übergeben von Dokumenten von den BizTalk-Messagingdiensten an die BizTalk-Orchestrierungsdienste.

Wenn Sie eine BizTalk-Messaging-Form zur rechten Seite der XLANG-Ablaufplanzeichnung hinzufügen, wird der BizTalk-Bindungs-Assistent für Messaging geöffnet. Doppelklicken Sie auf die BizTalk-Messaging-Form, um eine vorhandene BizTalk-Messaging-Implementierung zu bearbeiten. Sie benennen den Orchestrierungsport im BizTalk-Bindungs-Assistenten für Messaging (dieser Name muss mit dem im BizTalk-Messaging-Manager angegebenen Namen übereinstimmen) und geben außerdem an, ob dieser Port Dokumente empfängt oder sendet, und ob er zum Starten eines Geschäftsprozesses verwendet werden soll.

Wenn Sie ein Dokument an die BizTalk-Messagingdienste zurücksenden müssen, fügen Sie eine BizTalk-Messaging-Form zur rechten Seite der XLANG-Ablaufplanzeichnung hinzu, und geben Sie den Namen des Kanals an, an den das Dokument gesendet werden muss. Beachten Sie, dass dieser Kanal beim Erstellen der XLANG-Ablaufplanzeichnung noch nicht vorhanden sein muss. Beim Ausführen des Ablaufplanes ist er allerdings erforderlich.

Verbinden Sie nach der Erstellung des Orchestrierungsports die Aktion-Form mit diesem Port. Ähnlich wie zuvor beim Konfigurieren der BizTalk-Orchestrierungsdienste für den Empfang von Dokumenten von den BizTalk-Messagingdiensten geben Sie nun im Assistenten für XML-Kommunikation an, ob das Dokument als XML oder als Zeichenfolge gesendet werden soll, und geben Sie die Nachrichtentypinformationen sowie eine optionale XML-Spezifikation zur Überprüfung des Dokuments an. Weitere Informationen finden Sie unter Verwenden der BizTalk-Messaging-Form.

Verwenden einer Messag Queuing-Implementierung

Sie können zum Empfangen eines Dokuments in einem XLANG-Ablaufplan auch die Message Queuing-Form verwenden. Wenn Sie zur Zeichnung diese Form hinzufügen, wird der BizTalk-Bindungs-Assistent für Messaging gestartet, und Sie werden aufgefordert, einen Namen für eine private oder öffentliche Nachrichtenwarteschlange anzugeben, die zum Senden oder Empfangen von Dokumenten verwendet werden soll. Wenn Message Queuing jedoch zum Empfangen von Dokumenten verwendet wird, wird der Ablaufplan, anders als beim Empfang von Dokumenten von den BizTalk-Messagingdiensten, nicht automatisch gestartet. Daher benötigen Sie eine andere Methode zum Starten des Ablaufplanes, nachdem das Dokument an eine Warteschlange gesendet wurde.

Wenn Sie die Aktion-Form Receive Requisition auf der linken Seite der Zeichnung mit dem ReceiveReq-Port verbinden, wird der Assistent für XML-Kommunikation geöffnet. Doppelklicken Sie auf die blaue Linie, die die Receive Requisition-Aktion mit dem ReceiveReq-Port verbindet, um eine vorhandene Message Queuing-Implementierung zu bearbeiten und den Assistenten für XML-Kommunikation zu öffnen.

Der Assistent für XML-Kommunikation fordert Sie auf, eine Nachricht zu erstellen, mit der das Dokument durch den vom XLANG-Ablaufplan dargestellten Orchestrierungsprozess geführt wird. Dazu müssen Sie diese Nachricht mit anderen Nachrichten auf der Seite Data verbinden, angeben, ob das Dokument im XML-Format verarbeitet wird, und einen Nachrichtentyp angeben. Sie können wahlweise den Namen und Speicherort einer XML-Datei angeben, die Ihre Dokumentspezifikation enthält. Die BizTalk-Orchestrierungsdienste können dann jedes Dokument vor der Verarbeitung anhand der Spezifikation überprüfen.

Sie können außerdem Dokumente mithilfe von Message Queuing aus einem XLANG-Ablaufplan senden. In diesem Fall müssen Sie anstelle des Kanalnamens den Namen einer privaten oder öffentlichen Warteschlange angeben, an die das Dokument gesendet werden soll. Weitere Informationen finden Sie unter Verwenden der Message Queuing-Form.

Nachdem der Geschäftsprozess der XLANG-Ablaufplanzeichnung definiert wurde und die Implementierungen hinzugefügt wurden, wird das Programm in einen XLANG-Ablaufplan kompiliert. Weitere Informationen finden Sie unter Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan. Der XLANG-Ablaufplan definiert alle auszuführenden Schritte, aufzurufenden Komponenten und Daten, die übergeben werden müssen, um den definierten Prozess auszuführen.

Sie sind nun in der Lage, Dokumente von den BizTalk-Messagingdiensten zu senden und zu empfangen. Jetzt werden wir uns ansehen, wie diese Dokumente in den BizTalk-Orchestrierungsdiensten eingesetzt werden.

Weiter mit Hinzufügen von Feldern zu Nachrichtenspezifikationen


Hinzufügen von Feldern zu Nachrichtenspezifikationen

Sie haben zuvor eine XML-Kommunikation für eine Nachricht erstellt und angegeben, welche XML-Spezifikation das zu empfangende Dokument darstellt. Jetzt können Sie die Werte der einzelnen Felder im Dokument mit den BizTalk-Orchestrierungsdiensten abrufen und die Informationen an COM-Komponenten oder andere Nachrichten übertragen.

  1. Doppelklicken Sie auf die blaue Linie, die die Receive Requisition-Aktion mit dem ReceiveReq-Port verbindet, um den Assistenten für XML-Kommunikation für den ReceiveReq-Port zu öffnen.

  2. Klicken Sie dann viermal auf Weiter.

    Die Seite Informationen über die Nachrichtenspezifikation des Assistenten wird geöffnet.

  3. Wie Sie sehen, enthält der Abschnitt Nachrichtenfelder mehrere Einträge. Der Eintrag mit dem Namen Document ist das Feld, das ein gesamtes an den XLANG-Ablaufplan übergebenes Dokument enthält. Klicken Sie auf Hinzufügen.

    Das Dialogfeld Feldauswahl wird angezeigt.

    Da Sie angegeben haben, dass das an den XLANG-Ablaufplan übergebene Dokument mit einer bestimmten XML-Spezifikation, und zwar der Northwind Requisition-Spezifikation, übereinstimmen soll, können Sie jetzt mit einer Standard-XML-Abfragesprache namens XPath einzelne Felder dieses Dokuments auswählen.

    Anmerkung

    • XPath ist eine Sprache für den Umgang mit Teilen eines XML-Dokuments und stellt einen öffentlichen Standard dar, der von der W3C gewahrt wird. Weitere Informationen zu XPath finden Sie auf der Seite "XPath" in der W3C-Website (www.w3.org).
  4. Erweitern Sie den Knoten Items, und klicken Sie auf totalPrice.

    Im Feld Knotenpfad wird ein XPath für den Knoten angezeigt. Die folgende Abbildung zeigt das Dialogfeld Feldauswahl, in dem das Feld totalPrice ausgewählt ist.

    Sie können andere Felder der Spezifikation auf ähnliche Weise zu Ihrer Nachricht hinzufügen. Alle in diesem Dialogfeld hinzugefügten Felder sind auf der Datenseite im BizTalk-Orchestrierungs-Designer verfügbar, so dass Sie sie in Ausdrücken verwenden und als Parameter an Komponenten übergeben können.

  5. Klicken Sie auf Abbrechen, um das Dialogfeld Feldauswahl zu schließen.

  6. Klicken Sie auf Abbrechen, um den Assistenten für XML-Kommunikation zu schließen.

  7. Klicken Sie auf der linken Seite der XLANG-Ablaufplanzeichnung mit der rechten Maustaste auf die Decision-Form, und klicken Sie dann auf Properties.

    Das Dialogfeld Entscheidungseigenschaften wird angezeigt.

  8. Klicken Sie auf Bearbeiten.

    Ein Dialogfeld, ähnlich wie das in der folgenden Abbildung, wird angezeigt.

    Dialogfeld Eigenschaften der Regel

    Die Informationen unter Skriptausdruck zeigen, dass Sie mit der MessageName.FieldName-Notation auf den Wert des Feldes totalPrice zugreifen können. In diesem Beispiel wird mithilfe von Message_1.totalPrice der Gesamtpreis des Anforderungsdokuments ermittelt.

Weiter mit Arbeiten mit COM-Komponenten


Arbeiten mit COM-Komponenten

Da das Dokument nun im XLANG-Ablaufplan enthalten ist, können Sie verschiedene Geschäftskomponenten aufrufen und Ihr Dokument als Parameter übergeben. Diese Komponenten können Aufgaben ausführen, z. B. sich um Geschäftsregeln kümmern, auf Unternehmensdatenbanken und Legacysysteme zugreifen und E-Mail-Nachrichten senden. Die Komponenten können außerdem das Dokument selbst ändern und diese Änderungen an den XLANG-Plan zurückgeben, damit sie an die nächste Aktion übergeben werden können. Dazu müssen Sie die Geschäftslogik als Standard-COM-Komponenten implementieren, diese Komponenten auf der rechten Seite der XLANG-Ablaufplanzeichnung hinzufügen und dann die aufzurufenden Methoden auswählen.

An diesem Punkt des Lernprogramms haben Sie bereits folgende Schritte ausgeführt:

  • Lesen des Anforderungsdokuments von einer Datei auf der Festplatte und Übergeben dieser Datei an die BizTalk-Messagingdienste (mit einer Dateiempfangsfunktion).

  • Überprüfen des Anforderungsdokuments anhand einer XML-Spezifikation (mithilfe eines Kanals) und Übergeben des Dokuments an die BizTalk-Orchestrierungsdienste.

  • Empfangen des Dokuments in einem XLANG-Ablaufplan und Abrufen der Werte bestimmter Felder (mit dem Assistenten für XML-Kommunikation).

  • Verwenden der Regeleigenschaften in einer Entscheidung-Form, um die Werte zu beurteilen und Ihre Geschäftslogik zu erstellen.

Bisher war in diesem Lernprogramm zum Erstellen und Implementieren eines Geschäftsprozesses kein Programmieren erforderlich. Sie müssen aber möglicherweise eine Geschäftskomponente schreiben, um bestimmte unternehmensspezifische Aktionen zu implementieren (damit z. B. bestimmte Mitarbeiter die Genehmigungsgrenzen für Anforderungen nachschlagen können). Im folgenden Abschnitt wird daher erläutert, wie eine Windows-Skriptkomponente geschrieben wird. Weitere Informationen finden Sie unter Verwenden der COM-Komponente-Form.

Weiter mit Erstellen einer Windows-Skriptkomponente.


Erstellen einer Windows-Skriptkomponente

Microsoft Windows-Skriptkomponenten bieten eine Möglichkeit zum Erstellen von COM-Komponenten (Component Object Model) mithilfe von Skriptsprachen, wie z. B. Microsoft Visual Basic Scripting Edition (VBScript) und Microsoft® JScript®. Sie können Skriptkomponenten genau wie andere COM-Komponenten in einer beliebigen Anwendung verwenden, die COM unterstützt.

Skriptkomponenten werden anders als kompilierte Komponenten ausgeführt, denn sie werden zur Laufzeit interpretiert. Sie stellen aber eine Möglichkeit dar, einen Prototyp für eine Schnittstelle für eine COM-Komponente zu erstellen, die später entwickelt wird.

Der neue Windows Script Component Wizard von Microsoft soll Ihnen bei der Erstellung von Skriptkomponenten einen Vorsprung geben. Sie können diesen Assistenten von der MSDN-Website (msdn.microsoft.com/scripting/) downloaden. Die Erstellung des Rahmencodes für Ihre Komponente ist ganz einfach: Wählen Sie einen Namen für die Komponente aus, entscheiden Sie sich für eine Skriptsprache für die Implementierung der Komponente, geben Sie die Eigenschaften und Methoden für Ihre Komponente an, und klicken Sie auf Finish. Der Assistent generiert den gesamten für die Komponente benötigten Code und speichert ihn in einer Datei mit der Erweiterung WSC. Sie können die Datei dann in einem beliebigen Editor öffnen und den tatsächlichen Code hinter den Methoden hinzufügen.

Die zu verwendende Komponente hat zwei Methoden, ApproveReq und DeclineReq, von denen jede über einen einzelnen Parameter, Document, verfügt. Die folgende Abbildung zeigt die Seite im Windows Script Component Wizard, auf der Sie diese Methoden der Skriptdatei hinzufügen.

Schritt 4 von 6 im Windows Script Component Wizard

Der folgende Code gilt für die Requisition Approval-Komponente:

<?xml version="1.0"?>
<component>

<registration
   description="Req Approval"
   progid=" LearnBizTalk.ProcessReq"
   version="1.00"
   classid="{AD454A9F-58FE-4877-B7CD-F61BD45988F5}">
</registration>

<public>
   <method name="ApproveReq">
      <PARAMETER name="Document"/>
   </method>
   <method name="DeclineReq">
      <PARAMETER name="Document"/>
   </method>
</public>

<script language="VBScript">
<![CDATA[

function ApproveReq(Document)
MsgBox "Orchestration Engine Approved Requisition:" & vbCrLf & vbCrLf & Document, 64, "Requisition Approved"
end function

function DeclineReq(Document)
MsgBox "Orchestration Engine Declined Requisition:" & vbCrLf & vbCrLf & Document, 16, "Requisition Declined"
end function

]]>
</script>

</component>

Der gesamte Inhalt dieser Datei, mit Ausnahme des Implementierungscodes für die fett gedruckten Methoden ApproveReq und DeclineReq, wurde vom Assistenten generiert.

Ihre Geschäftsprozessabläufe sind möglicherweise sehr komplex, so dass Entwickler mehrere Wochen zum Erstellen und Testen der COM-Komponenten benötigen. Das bedeutet aber nicht, dass Sie die XLANG-Ablaufplanzeichnung nicht schon vor der Fertigstellung dieser Komponenten entwerfen und testen können. Erstellen Sie mithilfe des Windows Script Component Wizard Beispielversionen der komplexen COM-Komponenten, ergänzen Sie die erforderlichen Eigenschaften und Methoden, und verwenden Sie diese Skriptkomponenten anstelle der tatsächlichen, zu einem späteren Zeitpunkt fertig gestellten COM-Komponenten in Ihrer XLANG-Ablaufplanzeichnung. Jetzt können Sie die XLANG-Ablaufplanzeichnung entwerfen, ohne warten zu müssen, bis die Entwickler die Codierung abgeschlossen haben. Weitere Informationen finden Sie unter Verwenden der Skriptkomponente-Form.

Sie können außerdem die Implementierung der BizTalk-Messagingdienste und der BizTalk-Orchestrierungsdienste mit den Skriptkomponenten testen und sie durch COM-Komponenten ersetzen, die zu einem späteren Zeitpunkt in einer anderen Sprache entwickelt wurden. Wenn Sie die Skriptkomponenten ersetzen möchten, fügen Sie zur XLANG-Ablaufplanzeichnung eine COM-Komponente-Form hinzu. Dadurch wird der Bindungs-Assistent für COM-Komponenten geöffnet, der Sie auffordert, Informationen zum Erstellen eines neuen Orchestrierungsports einzugeben. Danach trennen Sie die Verbindung zwischen der vorhandenen Aktion-Form und einer Portimplementierung für Skriptkomponenten, und verbinden Sie die Aktion-Form dann mit dem neuen Orchestrierungsport. Anschließend können Sie den Ablaufplan neu kompilieren.

Weiter mit Datenseite von Northwind Traders


Datenseite von Northwind Traders

Nachdem eine XLANG-Ablaufplanzeichnung erstellt und alle Implementierung-Formen mit den Aktion-Gegenstücken verbunden wurden, müssen Sie den Ablauf von einem Schritt des Prozesses zum nächsten konfigurieren. Dazu verwenden Sie die Seite Data in den BizTalk-Orchestrierungsdiensten. Bevor Sie die Seite Data ausfüllen, sieht sie so wie in der folgenden Abbildung aus.

Seite Data von Northwind Traders

Wie Sie sehen, zeigt die Seite Data mehrere Feldgruppen, die jeweils den Namen der Nachricht haben, die das Dokument an den oder vom Orchestrierungsport transportiert.

Öffnen Sie NorthwindApproval.skv im BizTalk-Orchestrierungs-Designer, und klicken Sie im Menü Ansicht auf Datenseite. Beachten Sie, dass das Feld Document in Message_1 mit dem Feld Document in Message_2 und DeclineReq_in verbunden wurde. Dies bedeutet, dass das von den BizTalk-Messagingdiensten bei Message_1 eingegangene Dokument an die DeclineReq_in-Nachricht übergeben wurde. Hierbei handelt es sich um die Nachricht, die das Dokument an die Skriptkomponente und an Message_2 übermitteln wird, wobei Message_2 das gleiche Dokument an die BizTalk-Messagingdienste zurücksenden wird. Sie können die Nachrichten auf dieser Seite umorganisieren, damit die Zeichnung besser verständlich ist.

Klicken Sie auf die Registerkarte Data am unteren Rand der Entwurfsseiten, um die Datenseite anzuzeigen. Die Seite Data in NorthwindApproval.skv sollte so wie in der folgenden Abbildung aussehen.

Seite Data von Northwind Traders mit Verbindungen

Nachdem Sie den Datenfluss zwischen Nachrichten definiert haben, können sie die Zeichnung in einen ausführbaren XLANG-Ablaufplan kompilieren.

So speichern und kompilieren Sie eine XLANG-Ablaufplanzeichnung

  1. Klicken Sie im Menü Datei auf <Dateiname>.skv speichern.

  2. Klicken Sie im Menü Datei auf XLANG <Dateiname>.skx erstellen.

    Das Dialogfeld XLANG-Ablaufplan speichern unter wird angezeigt.

  3. Überprüfen Sie den Speicherort, an dem der XLANG-Ablaufplan gespeichert werden soll, und klicken Sie auf Speichern.

  4. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Orchestrierungs-Designer zu schließen.

    Jetzt können Sie Ihren XLANG-Ablaufplan ausführen.

Weitere Information finden Sie unter Kompilieren von XLANG-Ablaufplänen.

In den nächsten Lektionen wird gezeigt, wie Sie das Dokument für die Übermittlung an den Handelspartner vorbereiten, indem Sie es mithilfe von Zuordnungen transformieren. Außerdem wird die Verwendung dieser Zuordnungen mit den BizTalk-Messagingdiensten erläutert.

Weiter mit Lektion 5: Verwenden des BizTalk-Mappers


Lektion 5: Verwenden des BizTalk-Mappers

In den vorangegangenen Lektionen haben Sie gelernt, wie Microsoft BizTalk Server 2002 Dokumente von LOB-Anwendungen (Line-of-Business) annimmt, und wie diese Dokumente in den BizTalk-Orchestrierungsdiensten verarbeitet werden.

In dieser Lektion erfahren Sie, wie das Anforderungsdokument für die Übermittlung an die Contoso AG vorbereitet wird, und lernen die Schritte kennen, die für diese Aufgabe in den BizTalk-Messagingdiensten ausgeführt werden müssen.

Folgende Themen werden in dieser Lektion behandelt:

  • Erstellen der Zuordnung

  • Verwenden der Zuordnung

  • Ausführen des Szenarios


Erstellen der Zuordnung

Das bisher verwendete Anforderungsdokument stellt eine interne Kaufanforderung dar, die von einer Anwendung bei Northwind Traders erstellt wurde. Wenn diese Anforderung von einem Geschäftsprozess (der in diesem Szenario mithilfe der BizTalk-Orchestrierungsdienste implementiert wird) genehmigt wird, muss ein Auftrag an die Contoso AG gesendet werden, um die Ware zu kaufen.

Zurzeit gibt es kein Auftragsdokument, sondern nur eine Anforderung. Die Struktur des Auftrags der Contoso AG und die meisten zum Erstellen des Auftragsdokuments benötigten Daten, wie z. B. die Warenliste und die Rechnungsadresse, sind allerdings schon in der Anforderung enthalten. Mithilfe des BizTalk-Mappers können Sie die Informationen im Anforderungsdokument in einen Auftrag umwandeln, den die Contoso AG verwenden kann. Der BizTalk-Mapper verwendet den Internetstandard XSL-Transformation (XSLT), eine Sprache zum Konvertieren von XML-Dokumenten von einem XML-Schema in ein anderes.

Anmerkung

  • XSLT ist eine W3C-Empfehlung. Weitere Informationen zu XSLT finden Sie auf der Seite "XXLT" in der W3C-Website (www.w3.org).

Sie können den BizTalk-Mapper auch dann verwenden, wenn Sie keine Kenntnisse in Bezug auf XSLT haben. Der BizTalk-Mapper ist ein grafisches Tool, das beide Spezifikationen Seite an Seite darstellt, und in dem Sie Transformationen einfach durch Zeichnen von Linien zwischen Spezifikationsfeldern definieren können. Weitere Informationen finden Sie unter Zuordnen von Spezifikationen.

In Fällen, in denen einfache Regeln, wie z. B. "Feld A aus Dokument 1 wird in Feld B in Dokument 2 gespiegelt", nicht ausreichen, bietet der BizTalk-Mapper eine Reihe von leistungsstarken Transformationselementen, die so genannten Funktoide. BizTalk-Mapper umfasst über 60 Funktoide, mit denen Sie mathematische, logische, Zeichenfolgen-, Datums-/Uhrzeit-, wissenschaftliche, Datenbank- und sonstige Vorgänge durchführen können. Es gibt auch ein Skriptfunktoid, mit dem Sie Ihre eigenen Subroutinen in Microsoft Visual Basic Scripting Edition (VBScript) schreiben können, sollte sich keines der vorhandenen Funktoide für den Vorgang eignen. Der resultierenden VBScript-Code ist direkt in den vom BizTalk-Mapper generierten XSLT eingebettet. Weitere Informationen finden Sie unter Grundlegendes zu Funktoiden.

Anmerkung

  • Durch Kaskadieren von Funktoiden kann die Funktionalität noch erweitert werden. Bei dieser Methode werden die Ergebnisse einer Funktoidausführung als Eingabe an das nächste Funktoid weitergegeben. Sie können außerdem benutzerdefinierte Funktoide in einer Sprache wie z. B. Visual Basic erstellen und zur späteren Verwendung Ihrer Funktoidpalette hinzufügen.

Für dieses Geschäftsszenario haben wir eine Zuordnung erstellt, die das Anforderungsdokument von Northwind Traders in den Auftrag der Contoso AG umwandelt. Diese Zuordnung ist in der Datei ContosoPOMap.xml im Verzeichnis C:\LearnBizTalk\Documents\ gespeichert. Wenn Sie diese Zuordnung im BizTalk-Mapper öffnen, wird der in der folgenden Abbildung gezeigte Bildschirm angezeigt.

ContosoPOMap.xml im BizTalk-Mapper geöffnet

Die meisten zum Erstellen eines Auftragsdokuments für die Contoso AG erforderlichen Felder sind bereits im Anforderungsdokument enthalten, haben aber u. U. andere Namen. Einige Felder, wie z. B. PONumber, sind neu. Ihre Werte mussten deshalb generiert werden.

Wie Sie sehen, wurden in dieser Zuordnung drei Funktoide verwendet:

  • Ein Funktoid vom Typ Zeichenfolgenverkettung, das zwei Adressfelder der Anforderung im Auftrag zu einem Feld kombiniert

  • Ein Funktoid vom Typ Datum/Uhrzeit, das den aktuellen Zeitstempel für das Feld created generiert

  • Ein Skriptfunktoid, das eine bestimmte Geschäftsregel implementiert, um eine Auftragsnummer zu generieren (in diesem Beispiel verwendet das Funktoid eine zufällige Nummer als Auftragsnummer).

Da die Werte einiger Zielfelder sich im Laufe der Zeit nicht ändern (z. B. der Name und die Anschrift Ihrer Firma), ermöglicht der BizTalk-Mapper das Angeben konstanter Werte. Markieren Sie dazu das Feld, für das Sie einen konstanten Wert angeben müssen, klicken Sie auf die Registerkarte Werte, und geben Sie den Wert ein. Die folgende Abbildung zeigt die Registerkarte Werte.

Registerkarte Werte im BizTalk-Mapper

Anmerkung

  • Sie können keine Verknüpfung mit einem Knoten in der Zielspezifikation erstellen, dem ein konstanter Wert für das Ziel zugeordnet ist.

Weitere Informationen zum Erstellen einer Zuordnung finden Sie in Unterrichtseinheit 2 im BizTalk Server 2002-Lernprogramm.

Weiter mit Verwenden der Zuordnung.


Verwenden der Zuordnung

Nachdem die Zuordnung erstellt wurde, kehren wir zum BizTalk-Messaging-Manager zurück und konfigurieren den Kanal Channel To Contoso, der verwendet wird, um den Auftrag mithilfe der Zuordnung an die Contoso AG zu übermitteln.

Dies ist der gleiche Kanal, den Sie in der in Lektion 4 beschriebenen XLANG-Ablaufplanzeichnung beim Konfigurieren des Ports angegeben haben, der das Anforderungsdokument an die Contoso AG gesendet hat. Der XLANG-Ablaufplan gibt das gleiche Anforderungsdokument aus, das er empfängt. Er erkennt keine potenziellen Transformationen an diesem Dokument, die später in den BizTalk-Messagingdiensten erfolgen (z. B. die Umwandlung in einen Auftrag). Die Gesamtlösung ist so flexibel und anpassungsfähig, weil es eine Trennung zwischen einem für die Anforderungsgenehmigung verwendeten Geschäftsprozess und den technischen Details für die Verwaltung des Dokumentformats und des Zustellungsmechanismus gibt.

Von Bedeutung ist hier, dass die BizTalk-Orchestrierungsdienste die Technologie zum Erstellen von Geschäftsprozessen, die BizTalk-Messagingdienste dagegen die Technologie für das zuverlässige Senden von Dokumenten zwischen Geschäftsprozessen für deren Integration darstellen.

Sollte die Contoso AG in Zukunft das Format ihrer Aufträge ändern, müssen Sie nicht den gesamten Geschäftsprozess neu erstellen, sondern nur die Spezifikation für den Auftrag von Contoso und die Zuordnung entsprechend der neuen Spezifikationsänderungen aktualisieren.

Wenn Sie den Kanal im BizTalk-Messaging-Manager konfigurieren und eine ausgehende Dokumentdefinition angeben, die sich von einer eingehenden Dokumentdefinition unterscheidet, fordert der BizTalk-Messaging-Manager Sie automatisch auf, ein Zuordnungsdokument bereitzustellen, das die Umwandlung zwischen diesen beiden Dokumentspezifikationen durchführt. Die folgende Abbildung zeigt, wie das Zuordnungsdokument identifiziert wird.

Seite Ausgehendes Dokument im Kanal-Assistenten

So öffnen Sie den Kanal zur Contoso AG und zeigen die Kanaleigenschaften an:

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Wenn das Dialogfeld BizTalk-Messaging-Manager angezeigt wird, klicken Sie auf Abbrechen.

  3. Klicken Sie im Bereich Nach anderen Elementen suchen auf Kanäle.

  4. Klicken Sie auf Jetzt suchen.

Doppelklicken Sie in der Liste Kanalname auf Channel to Contoso.

  5. Klicken Sie dreimal auf Weiter, um zur Seite Ausgehendes Dokument zu gelangen.

Weiter mit Ausführen des Szenarios.


Ausführen des Szenarios

Wichtig

  • Für eine erfolgreiche Ausführung dieses Szenarios müssen Sie das Verzeichnis LearnBizTalk auf Laufwerk C: kopieren und alle Komponenten von BizTalk Server auf Laufwerk C: installieren. Es ist zwar möglich, diese Dateien von einem anderen Laufwerk bzw. Verzeichnis auszuführen, jedoch müssten Sie dazu umfangreiche Änderungen an den Quelldateien vornehmen. Weitere Informationen zu diesen Voraussetzungen finden Sie unter Kennenlernen von BizTalk Server 2002.

So führen Sie das Szenario aus

  1. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Scripts, und doppelklicken Sie auf L5Post.vbs.

    Das Skript entfernt die vorübergehenden Änderungen, die am Ende von Lektion 3 am Orchestrierungsprozess vorgenommen wurden, und ermöglicht den BizTalk-Orchestrierungsdiensten die Ausgabe des Dokuments an die BizTalk-Messagingdienste.

  2. Kopieren Sie die Datei ReqToDecline.xml aus dem Verzeichnis C:\LearnBizTalk\Documents in das Verzeichnis C:\LearnBizTalk\Pickup.

    Diese Anforderung wird wie zuvor abgelehnt, und ein entsprechendes Meldungsfeld wird angezeigt.

  3. Wiederholen Sie Schritt 2 stattdessen mit der Datei ReqToApprove.xml.

    Diese Anforderung wird genehmigt, und die BizTalk-Orchestrierungsdienste senden sie an die BizTalk-Messagingdienste.

    Der Kanal empfängt das Dokument, konvertiert es mithilfe der angegebenen Zuordnung in den Auftrag der Contoso AG, und die BizTalk-Messagingdienste schreiben das resultierenden Dokument unter dem Namen ContosoPO.xml in das Verzeichnis C:\LearnBizTalk\Output\.

    Anmerkung

    • Wenn diese Nachricht in eine Datei geschrieben wird, wird kein Meldungsfeld mit dem Hinweis angezeigt, dass die Anforderung genehmigt wurde.
  4. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Output, und doppelklicken Sie auf die Datei ContosoPO.xml, um sie in Microsoft Internet Explorer zu öffnen.

    Sehen Sie sich die Werte des vom Skriptfunktoid nach dem Zufallsprinzip generierten Feldes PONumber an sowie das Feld created, das den Zeitpunkt der Dateierzeugung enthält, und das Feld address, das die Werte aus den beiden durch das Zeichenfolgenfunktoid verketteten ursprünglichen Feldern addr1 and addr2 enthält.

Weitere genaue Anleitungen zur Verwendung des BizTalk-Mappers finden Sie in Unterrichtseinheit 2 im BizTalk Server 2002-Lernprogramm.

In der nächsten Lektion lernen Sie die verschiedenen Methoden zum Übermitteln von Dokumenten an Ihre Handelspartner kennen. Außerdem erfahren Sie, wie diese Aufgabe durch Standardinternetprotokolle vereinfacht wird.

Weiter mit Lektion 6: Senden und Empfangen von Dokumenten


Lektion 6: Senden und Empfangen von Dokumenten

In dieser Lektion lernen Sie den Prozess kennen, den Northwind Traders verwendet, um den Auftrag an die Contoso AG zu senden. Außerdem erfahren Sie, wie dieser Auftrag von der Contoso AG empfangen und gespeichert wird.

Folgende Themen werden in dieser Lektion behandelt:

  • Auswählen eines Protokolls

  • Empfangen von Dokumenten über HTTP

  • Verwenden der Warteschlange

  • Ausführen des Szenarios


Auswählen eines Protokolls

Nachdem das Auftragsdokument generiert wurde, muss es zur Verarbeitung an die Contoso AG gesendet werden. Wenn Sie einen Transportdienst für diese Aufgabe auswählen, müssen Sie einige wichtige Punkte berücksichtigen:

  • Der Transportdienst muss ein Standardprotokoll verwenden, damit Sie sicher sein können, dass Ihr Handelspartner (Contoso) Dokumente mithilfe verschiedener, auf einer beliebigen Plattform ausgeführter Softwareprogramme empfangen kann.

  • Der Transportdienst muss zuverlässig sein, damit Sie sicher sein können, dass Ihr Handelspartner das Dokument tatsächlich erhalten hat.

  • Der Transportdienst muss sicher sein, damit Sie den gesamten Übertragungsprozess verschlüsseln können, um vertrauliche Daten zu schützen.

Für dieses Szenario wurde ein Transportdienst gewählt, der HTTP (Hypertext Transfer Protocol) verwendet. HTTP ist ein Standardprotokoll, mit dem Internetbrowser Informationen von Webservern abrufen. Die meisten Administratoren, die mit Unternehmensfirewalls arbeiten, haben keine Bedenken, wenn auf HTTP basierende Übertragungen an Standorte außerhalb der Firma gesendet werden. Dies ist ein wichtiger Aspekt in Bezug auf den Prozess, bei dem der richtige Transportdienst ausgewählt werden muss. Ein Server mit Microsoft BizTalk Server muss mit internen Anwendungen, Datenbanken und Legacysystemen kommunizieren können und sich somit innerhalb des Firewalls befinden. Gleichzeitig muss er aber möglicherweise Dokumente an einen externen Partner senden und von ihm empfangen. Dabei sollte nach Möglichkeit ein anerkanntes Protokoll verwendet werden, das den Firewall durchlaufen kann.

Was den Transport angeht, ist HTTP zuverlässig, denn es wird eine Standardmethode festgelegt, mit der die empfangende Seite den Status der Übertragung an den Absender übermitteln kann. Im Hinblick auf die Geschäftsprozesse sollte eine Wiederherstellung für den Fall möglich sein, dass vorübergehende Internetprobleme zu einem Übertragungsfehler führen. BizTalk Server kann den Übertragungsprozess überwachen, das Senden von Dokumenten nach einer zuvor festgelegten Anzahl von Wiederholungen erneut versuchen, und einen Administrator informieren, wenn die Übertragung fehlgeschlagen ist.

Schließlich gibt es noch eine sichere Version von HTTP, nämlich HTTPS (Secure Hypertext Transfer Protocol). HTTPS ermöglicht die Verschlüsselung der gesamten Übertragung mithilfe von Standardalgorithmen. HTTPS verschlüsselt den gesamten Kommunikationsstrom mit einem Handelspartner und kann zusammen mit der Verschlüsselung und digitalen Signierung des Dokuments verwendet werden, um eine zusätzliche Sicherheitsstufe zu bieten.

Anmerkung

  • Eine weitere Möglichkeit, Dokumente an Handelspartner zu senden, besteht darin, ein Dokument mithilfe des Dateitransportdienstes in einer Datei auf einer Festplatte zu speichern. Die Dateien werden dann von einem anderen Prozess aufgenommen und mit einer EDI-VAN-Wählhilfe oder einem FTP-Prozess an einen Partner übermittelt.

Weitere Informationen zu den von BizTalk Server 2002 unterstützten Transportdiensten finden Sie unter Transportdienste.

Weiter mit Empfangen von Dokumenten über HTTP


Empfangen von Dokumenten über HTTP

Im Folgenden wird erläutert, was der Empfänger tun muss, um ein Dokument zu akzeptieren, das von BizTalk Server über HTTP gesendet wurde, und um das Dokument zu verarbeiten. Bei diesem Szenario wird davon ausgegangen, dass die Contoso AG zum Empfangen von Aufträgen und zum Generieren und Senden von Rechnungen ebenfalls BizTalk Server verwendet.

Da BizTalk Server auf Microsoft Windows 2000 Server ausgeführt wird, einer Plattform mit Internet-Informationsdiensten (IIS) 5.0, kann Contoso ein ASP-Skript (Active Server Pages) verwenden, um Dokumente von der BizTalk Server-Anwendung von Northwind Traders zu akzeptieren und sie zur Verarbeitung an die BizTalk Server-Anwendung der Contoso AG zu senden.

Anmerkung

  • In diesen Lektionen wird die Verarbeitung bei Northwind Traders und der Contoso AG mit einer einzigen Instanz von BizTalk Server simuliert. In einer echten Produktionsumgebung würden an den jeweiligen Standorten der beteiligten Unternehmen voneinander getrennte Server ausgeführt.

Nachdem ein ASP-Skript das Dokument empfangen hat, muss es schließlich zur Weiterverarbeitung an BizTalk Server zurückgesendet werden. Hierfür stehen mehrere Optionen zur Verfügung. Es ist dabei wichtig, eine Lösung zu entwerfen, bei der das Ergebnis ohne Ausfälle erzielt wird.

Wenn die Server der Contoso AG z. B. aufgrund einer geplanten Wartung oder einer Aktualisierung vorübergehend nicht in Betrieb sind oder die Server ungewöhnlich stark ausgelastet sind und die Verarbeitung von Aufträgen nicht in Echtzeit erfolgen kann, sollten Northwind Traders oder andere Handelspartner auch weiterhin in der Lage sein, ihre Auftragsdokumente zu senden. Im Prinzip sollte Northwind Traders abgesehen von der erfolgreichen Übertragung des Auftrags nichts über die Vorgänge bei Contoso oder die verwendete Technologie wissen. Obwohl BizTalk Server eine Standardmethode für das Akzeptieren von Dokumenten mithilfe von COM darstellt, ist es in diesem Beispiel nicht die optimale Wahl.

Versuchen wir also, eine bessere Methode für diesen Teil der Lösung zu finden. Wenn das ASP-Skript das übertragene Dokument empfängt, sollte es das Dokument in einer Datei auf einer Festplatte speichern und dann beendet werden, nachdem es den erfolgreichen Empfang des Dokuments bestätigt hat. In der Zwischenzeit kann BizTalk Server das gespeicherte Dokument abrufen und es völlig asynchron verarbeiten. In Lektion 2 haben Sie die Dateiempfangsfunktionen der BizTalk-Messagingdienste kennen gelernt und erfahren, wie Sie mithilfe dieser Funktionen eine Datei an einen bestimmten Speicherort senden, der von BizTalk Server überwacht wird. Es ist deshalb in diesem Szenario möglich, dass das ASP-Skript ein Dokument in einer Datei speichert, das später von einer Dateiempfangsfunktion aufgenommen wird. Mit einer solchen Architektur können Sie flexibel entscheiden, wann genau BizTalk Server die Dokumente verarbeiten soll. Außerdem können Sie bei steigenden Geschäftsanforderungen weitere BizTalk-Server für die Verarbeitung von eingehenden Dokumenten hinzufügen.

Im folgenden Thema wird eine Alternative gezeigt, mit der Sie die gleichen zuverlässigen Ergebnisse erzielen können, ohne die Dokumente in Dateien speichern zu müssen. Außerdem hat sie einen weiteren Vorteil: sie ist transaktionsorientiert.

Weiter mit Verwenden der Warteschlange.


Verwenden der Warteschlange

Message Queuing (auch MSMQ) ist eine der Standardkomponenten von Windows 2000 Server und bietet eine weitere einfache und zuverlässige Methode zum Erstellen einer asynchronen Lösung (wie die von uns entworfene).

Nachdem ein ASP-Skript das Dokument empfangen hat, können Sie das Dokument als Nachricht in einer Nachrichtenwarteschlange auf dem Server statt in einer Datei auf einer Festplatte speichern, und es danach mithilfe der Message Queuing-Empfangsfunktion, die einer Dateiempfangsfunktion ähnlich ist, an die BizTalk-Messagingdienste übermitteln. Bei den meisten Konfigurationen können Sie Message Queuing für eine höhere Zuverlässigkeit transaktionsorientiert einrichten.

Der gesamte Prozess wird in der folgenden Abbildung dargestellt:

Lektion 6: Prozessübersicht

So erstellen Sie eine Message Queuing-Empfangsfunktion

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk Server-Verwaltung.

  2. Erweitern Sie Microsoft BizTalk Server 2000, erweitern Sie BizTalk Server-Gruppe, klicken Sie mit der rechten Maustaste auf Empfangsfunktionen, zeigen Sie auf Neu, und klicken Sie dann auf Message Queuing-Empfangsfunktion.

    Das Dialogfeld Message Queuing-Empfangsfunktion hinzufügen wird angezeigt.

  3. Geben Sie im Feld Name einen Namen für die Funktion und im Feld Abrufspeicherort den Warteschlangennamen für den Abrufspeicherort ein.

  4. Klicken Sie auf Erweitert.

    Das Dialogfeld Erweiterte Optionen für Empfangsfunktionen wird angezeigt.

  5. Wählen Sie im Feld Kanalname den Kanal aus der Dropdownliste aus, der die von dieser Funktion empfangenen Dokumente verarbeitet.

    Anmerkungen

    • Wenn Sie Dokumente in einer privaten Nachrichtenwarteschlange speichern, geben Sie den Warteschlangennamen im folgenden Format ein: DIRECT=OS:.\private$\<Warteschlangenname>.

    • Wenn Sie eine öffentliche Nachrichtenwarteschlange verwenden, geben Sie den Warteschlangennamen in folgendem Format ein: DIRECT=OS:<Servername>\<Warteschlangenname>

Sie können sich die Eigenschaften der Message Queuing-Empfangsfunktion ReceivePO ansehen, die während der Installation konfiguriert wurde. Diese Empfangsfunktion verarbeitet Auftragsdokumente, die vom weiter oben behandelten ASP-Skript angenommen werden. Diese Funktion wurde vorübergehend deaktiviert, damit die Dokumente in der Warteschlange verbleiben und überprüft werden können. Sie können diese Funktion am Ende dieser Lektion wieder aktivieren.

Als Nächstes sehen wir uns das Skript in der Datei ContosoReceive.asp an, um herauszufinden, welche Schritte ausgeführt werden, um die von BizTalk Server übertragenden Daten zu akzeptieren und an eine Nachrichtenwarteschlange zu übertragen. Dieser Code verwendet zunächst eine BinaryRead-Methode eines von ASP zum Lesen der übertragenen Daten bereitgestellten Request-Objekts. Danach werden die empfangenen Daten mithilfe von Microsoft® ActiveX® Data Objects (ADO) vom binären Format in ein Textformat umgewandelt. Zum Schluss werden die Message Queuing-Funktionen zum Erstellen einer neuen Nachricht aus der Warteschlange und Senden der Nachricht an eine von uns gewählte private Warteschlange verwendet.

Sie können den gesamten Quellcode in der Datei ContosoReceive.asp im Verzeichnis C:\LearnBizTalk\ASP\ sehen.

Weiter mit Ausführen des Szenarios.


Ausführen des Szenarios

Wichtig

  • Für eine erfolgreiche Ausführung dieses Szenarios müssen Sie das Verzeichnis LearnBizTalk auf Laufwerk C: kopieren und alle Komponenten von BizTalk Server auf Laufwerk C: installieren. Es ist zwar möglich, diese Dateien von einem anderen Laufwerk bzw. Verzeichnis auszuführen, jedoch müssten Sie dazu umfangreiche Änderungen an den Quelldateien vornehmen. Weitere Informationen zu diesen Voraussetzungen finden Sie unter Kennenlernen von BizTalk Server 2002.

So führen Sie das Szenario aus

  1. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Scripts, und doppelklicken Sie auf L6Post.vbs.

    Dieses Skript stellt die Konfiguration des zuvor geänderten Messagingports Port To Contoso wieder her und weist ihn an, Dokumente über einen HTTP-Transport an die Contoso AG zu übermitteln, anstatt sie wie in Lektion 5 in eine Datei zu schreiben.

  2. Kopieren Sie die Datei ReqToApprove.xml aus dem Verzeichnis C:\LearnBizTalk\Documents in das Verzeichnis C:\LearnBizTalk\Pickup.

    Die Datei wird von einer Dateiempfangsfunktion verarbeitet und von den BizTalk-Messagingdiensten zur Genehmigung an die BizTalk-Orchestrierungsdienste übergeben. Danach wird sie an die BizTalk-Messagingdienste zurückgesendet und zum Schluss mithilfe des HTTP-Protokolls an Contoso übertragen.

Ein ASP-Skript, das die Contoso AG simuliert, liest die übertragenen Daten, konvertiert sie in ein Dokument und sendet das Dokument an eine lokale, private Warteschlange.

Danach sollte eine Message Queuing-Empfangsfunktion das Dokument aus der Warteschlange abrufen und an die BizTalk-Messagingdienste senden. Wie Sie sich aber vielleicht erinnern, wurde diese Empfangsfunktion vorübergehend deaktiviert, damit Sie das an die Warteschlange gesendete Dokument überprüfen können.

So sehen Sie sich die Nachrichten in der Warteschlange an

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Verwaltung.

  3. Doppelklicken Sie auf Computerverwaltung.

    Die Konsole Computerverwaltung wird angezeigt.

  4. Erweitern Sie in der Konsolenstruktur des Fensters Computerverwaltung die Optionen Dienste und Anwendungen, Message Queuing, Private Warteschlangen und schließlich contosopoqueue.

  5. Klicken Sie im linken Fenster auf Warteschlangennachrichten, um alle zurzeit an die Warteschlange gesendeten Nachrichten anzuzeigen.

  6. Klicken Sie mit der rechten Maustaste auf die Nachricht im rechten Fenster, klicken Sie auf Eigenschaften und dann auf die Registerkarte Nachrichtentext, um den Beginn des Nachrichtentextes anzuzeigen.

Nachdem Sie die Nachricht überprüft haben, löschen Sie sie aus der Warteschlange, indem Sie im linken Fenster mit der rechten Maustaste auf Warteschlangennachrichten klicken und danach auf Alle Tasks zeigen und auf Leeren klicken.

Weitere Informationen finden Sie unter Grundlegendes zu Empfangsfunktionen und Dokumentrouting.

In der nächsten Lektion werden die letzten Schritte des Szenarios behandelt: das Verarbeiten des Auftragsdokuments durch Contoso, das Generieren der Rechnung und das Übermitteln der Rechnung an Northwind Traders.

Weiter mit Lektion 7: Abschließen der Transaktion


Lektion 7: Abschließen der Transaktion

In Lektion 7 lernen Sie, wie die Contoso AG den von Northwind Traders über das Internet gesendeten Auftrag empfängt, den Auftrag mit den BizTalk-Messaging- und -Orchestrierungsdiensten verarbeitet und die Rechnung generiert und an Northwind Traders zurücksendet. Um dieses Beispiel für die Kommunikation zwischen Käufer und Lieferant abzuschließen, wird gezeigt, wie Northwind Traders die Rechnung empfängt und speichert.

Die folgende Abbildung zeigt die letzten Teile des Szenarios.

Lektion 7: Prozessübersicht

Folgende Themen werden in dieser Lektion behandelt:

  • Message Queuing

  • Verarbeiten des Auftrags

  • Ausführen des Szenarios


Message Queuing

Am Ende von Lektion 6 wurde ein von einem ASP-Skript bei der Contoso AG empfangenes Auftrags-Dokument an eine Nachrichtenwarteschlange übermittelt. Sie haben zudem gelernt, wie eine Message Queuing-Empfangsfunktion konfiguriert wird, die die Nachrichtenwarteschlange in Bezug auf eingehende Nachrichten überwacht und die Nachrichten an die BizTalk-Orchestrierungsdienste übermittelt. Es wurde entschieden, eingehende Aufträge in einer Nachrichtenwarteschlange und nicht in Dateien zu speichern, weil eine Nachrichtenwarteschlange Transaktionen unterstützt und somit eine höhere Zuverlässigkeit bietet. Dies ist bei einem Dateisystem nicht möglich.

Nachdem die Message Queuing-Empfangsfunktion das Dokument aus der Warteschlange entgegengenommen hat, wird es an den Kanal gesendet, der es wiederum an den für den Geschäftsprozess der Contoso AG erstellten Messagingport übermittelt. Dieser Messagingport wurde so konfiguriert, dass er das Dokument an einen XLANG-Ablaufplan übermittelt. Daran erkennen Sie, dass der Port einen XLANG-Ablaufplan starten wird, um den Geschäftsprozess der Contoso AG ähnlich wie das Anforderungsdokument auszuführen, das in Lektion 4 an den XLANG-Ablaufplan von Northwind Traders gesendet wurde.

Weiter mit Verarbeiten des Auftrags.


Verarbeiten des Auftrags

Die Verarbeitung eines echten Auftrags hängt vom jeweiligen Unternehmen ab. Um dieses Szenario zu vereinfachen, haben wir in der XLANG-Ablaufplanzeichnung der Contoso AG eine einzelne Aktion-Form (Do Some Work) definiert, die alle Aktionen darstellt, die normalerweise von einem Lieferanten ausgeführt würden, z. B. das Überprüfen des Inventars und die Weitergabe der Versandanweisungen an das Lager.

Die Implementierung für die Aktion-Form ist eine einfache Windows-Skriptkomponente, ProcessPO.wsc, die ein Meldungsfeld anzeigt, das dem Benutzer mitteilt, dass ein Auftrag verarbeitet wird. Bei der Erstellung dieser Komponente haben wir den Windows Script Component Wizard verwendet.

In einem Produktionssystem sollten von den Komponenten der BizTalk-Orchestrierungsdienste keine Meldungsfelder angezeigt werden, da kein Benutzer am Server angemeldet ist, der diese Meldungen erhält und bestätigen kann. Der Ablaufplan kann erst fortgesetzt werden, wenn ein Benutzer das Meldungsfeld schließt. Dies kann unerwünschte Auswirkungen haben. Zur Kommunikation sind E-Mail-Nachrichten oder Einträge in das Windows-Ereignisprotokoll, die wiederum andere Aktionen auslösen können, wesentlich besser geeignet.

Um die XLANG-Ablaufplanzeichnung von Contoso zu öffnen, wechseln Sie in das Verzeichnis C:\LearnBizTalk\Schedules\, und doppelklicken Sie auf ContosoInvoice.skv. Die folgende Abbildung zeigt den in der XLANG-Ablaufplanzeichnung definierten BizTalk-Orchestrierungsdiensteprozess für die Contoso AG.

BizTalk-Orchestrierungsdiensteprozess für die Contoso AG

In dieser XLANG-Ablaufplanzeichnung wurden mithilfe des Assistenten für XML-Kommunikation individuelle Feldwerte, hier der Felder PONumber und created, aus dem Auftragsdokument extrahiert und als Parameter an die Skriptkomponente übergeben, ohne dass Code geschrieben werden musste. Dies erfolgt auf ähnliche Weise wie das Extrahieren des Feldwertes für totalPrice aus dem Anforderungsdokument in Lektion 4.

Auf der Seite Data der XLANG-Ablaufplanzeichnung wurden diese Felder mit Eingabeparametern der DoWork-Methode der Skriptkomponente verbunden. Wie Sie in der folgenden Abbildung sehen, wird nicht der gesamte Auftrag an die Komponente übergeben, sondern lediglich die beiden extrahierten Felder.

Seite Daten von.ContosoInvoice.skv

Wenn Sie dieses Szenario ausführen und in dem von der Skriptkomponente angezeigten Meldungsfeld auf OK klicken, sendet der XLANG-Ablaufplan den Auftrag an die BizTalk-Messagingdienste zurück, wo sie unter Verwendung einer anderen Zuordnung in eine Rechnung umgewandelt werden. Anschließend werden sie mithilfe des HTTP-Transports an Northwind Traders gesendet, dem gleichen Transporttyp, mit dem Northwind Traders Aufträge an die Contoso AG sendet.

Wenn ein ASP-Skript bei Northwind Traders das Rechnungsdokument empfängt, speichert es das Dokument für die Weiterverarbeitung als Datei. In der Realität kann diese Verarbeitung Folgendes umfassen: Vergleichen der Rechnung mit der Originalanforderung und dem Originalauftrag, Aktualisieren der internen Systeme mit den Rechnungsinformationen usw.

Weiter mit Ausführen des Szenarios.


Ausführen des Szenarios

Wichtig

  • Für eine erfolgreiche Ausführung dieses Szenarios müssen Sie das Verzeichnis LearnBizTalk auf Laufwerk C: kopieren und alle Komponenten von BizTalk Server auf Laufwerk C: installieren. Es ist zwar möglich, diese Dateien von einem anderen Laufwerk bzw. Verzeichnis auszuführen, jedoch müssten Sie dazu umfangreiche Änderungen an den Quelldateien vornehmen. Weitere Informationen zu diesen Voraussetzungen finden Sie unter Kennenlernen von BizTalk Server 2002.

So führen Sie das Szenario aus

  1. Wechseln Sie in das Verzeichnis C:\LearnBizTalk\Scripts, und doppelklicken Sie auf L7Post.vbs.

    Dieses Skript aktiviert die Message Queuing-Empfangsfunktion neu, die in Lektion 6 vorübergehend deaktiviert wurde.

  2. Kopieren Sie das Anforderungsdokument ReqToApprove.xml aus dem Verzeichnis C:\LearnBizTalk\Documents in das Verzeichnis C:\LearnBizTalk\Pickup.

Im Folgenden finden Sie einen Überblick über den gesamten Ablauf dieses Szenarios:

  1. Die Dateiempfangsfunktion bei Northwind Traders liest die Datei ReqToApprove.xml, die im Verzeichnis \Pickup abgelegt wurde, und sendet sie über die BizTalk-Messagingdienste an den BizTalk-Orchestrierungsdiensteprozess von Northwind Traders.

  2. Der XLANG-Ablaufplan extrahiert den Wert des Feldes totalPrice und genehmigt die Anforderung, da der Wert geringer als €1000 ist. Dazu wird sie an die BizTalk-Messagingdienste zurückgesendet.

  3. Die BizTalk-Messagingdienste empfangen die Anforderung von den BizTalk-Orchestrierungsdiensten und erstellen mithilfe einer Zuordnung ein Auftragsdokument. Dieses Dokument wird dann über das dem Industriestandard entsprechende HTTP-Protokoll an die Contoso AG übertragen.

  4. Ein ASP-Skript der Contoso AG empfängt die Übertragung, extrahiert das Dokument und sendet es als Nachricht an eine private Nachrichtenwarteschlange.

  5. Eine Message Queuing-Empfangsfunktion findet in der Warteschlange ein neues Dokument, ruft es ab und sendet es mithilfe der BizTalk-Messagingdienste zur Verarbeitung an die BizTalk-Orchestrierungsdienste.

  6. Der XLANG-Ablaufplan extrahiert die Werte der Felder PONumber und created und ruft eine Methode für eine Skriptkomponente auf. Daraufhin wird ein Meldungsfeld angezeigt, das den Eingang des Auftrags ankündigt.

  7. Der XLANG-Ablaufplan sendet den Auftrag an die BizTalk-Messagingdienste zurück, um eine Rechnung zu generieren.

  8. Die BizTalk-Messagingdienste wenden eine Zuordnung an, um den Auftrag in eine Rechnung umzuwandeln, und übertragen die Rechnung mithilfe des HTTP-Protokolls an Northwind Traders.

  9. Ein ASP-Skript bei Northwind Traders akzeptiert die Übertragung, extrahiert das Dokument und speichert es als Datei unter C:\LearnBizTalk\Output\ContosoInvoice.xml.

Damit ist die Integration der internen Geschäftsprozesse und -anwendungen zwischen zwei Beispielfirmen, Northwind Traders und Contoso AG, abgeschlossen. Die folgende Abbildung zeigt die Komponenten dieses Prozesses, einschließlich der XLANG-Ablaufpläne, BizTalk-Messagingdienste, Empfangsfunktionen, ASP-Seiten, Warteschlangen und ihrer Beziehungen.

Übersicht über den gesamten Prozess

Wenn Sie jetzt das Verzeichnis C:\LearnBizTalk\Output öffnen, finden Sie die Datei ContosoInvoice.xml, die die Rechnung enthält, die Northwind Traders von der Contoso AG empfangen hat und die in dieser Datei gespeichert wurde.

Weiter mit Zusammenfassung.


Zusammenfassung

Im Laufe dieser sieben Lektionen haben Sie die Erstellung eines funktionierenden Integrationsszenarios zwischen einem Käufer und einem Lieferanten mitverfolgt.

Wir hoffen, dass diese Lektionen zu einem besseren Verständnis von Microsoft BizTalk Server beigetragen und Ihnen gezeigt haben, wie BizTalk Server den beim Integrieren von Business-to-Business-Prozessen anfallenden Arbeitsaufwand drastisch verringern kann.

Führen Sie das im Verzeichnis C:\LearnBizTalk\Scripts\ enthaltene Skript Cleanup.vbs aus, um die in diesen Lektionen an der BizTalk Server-Installation vorgenommenen Konfigurationsänderungen rückgängig zu machen. Nach abgeschlossener Ausführung des Skripts (dies wird Ihnen über ein Meldungsfeld mitgeteilt) können Sie das Verzeichnis C:\LearnBizTalk und die darin enthaltenen Dateien ohne Weiteres entfernen.

Eine genaue Anleitung zum Konfigurieren von BizTalk Server-Prozessen finden Sie unter BizTalk Server 2002-Lernprogramm. Im BizTalk Server-Lernprogramm wird die Verwendung des BizTalk-Editors, BizTalk-Mappers, BizTalk-Messaging-Managers, BizTalk-Orchestrierungs-Designers und der BizTalk Server-Verwaltung zum Konfigurieren von BizTalk Server als automatisierter B2B-Beschaffungsprozess (Business-to-Business) erklärt.

Weitere Informationen zu BizTalk Server 2002 finden Sie in der Microsoft BizTalk Server-Website (www.microsoft.com/biztalk/). Diese Website enthält technische Produktinformationen, Whitepaper, Schulungen und Veranstaltungen sowie Angebote von Drittanbietern.


Beispiel für die elektronische Beschaffung (E-Procurement)

In diesem Beispiel werden die folgenden neuen Features von Microsoft® BizTalk™ Server 2002 vorgestellt:

  • BizTalk-SEED-Assistent – Ein Assistent für die schnelle Aktivierung von Partnern

  • Bereitstellung mithilfe von Application Center 2000

  • Erweiterte Überwachungsfunktionen mithilfe von Microsoft Operations Manager (MOM)

  • Neue XLANG-Korrelation mithilfe von Standardwarteschlangen anstelle von Warteschlangen auf Instanzebene

  • HTTP-Empfangsfunktion

In diesem Szenario wird eine Geschäftssituation betrachtet, in der das Unternehmen Produkte von mehreren unterschiedlichen Lieferanten bezieht. Im Mittelpunkt steht das Einrichten einer Geschäftslösung mithilfe von Microsoft BizTalk Server 2002, dem Internet und der Korrelation, mit deren Hilfe der Beschaffungsprozess zwischen dem Unternehmen und den Lieferanten automatisiert wird. Diese Lösung wird elektronische Beschaffung (E-Procurement) genannt.

In diesem Szenario richten Sie einen Hub für das Unternehmen ein. Der Hub behandelt alle Dokumente der Bereiche Auftragserteilung, Rechnungswesen und Zahlungsvorgänge, die an die Lieferanten (Suppliers) gesendet und von den Lieferanten zurückgeschickt werden. Die in diesem Beispiel enthaltene EprocSetup-Anwendung konfiguriert den Hub und ein Lieferantensystem für die Verwendung von BizTalk Server, dem Internet und der Korrelation zur Behandlung dieser Dokumente und zur vollständigen Abwicklung des Beschaffungsprozesses. Nach Abschluss der Konfiguration führen Sie das Skript DocumentGenerator.vbs aus, um eine Transaktion zu starten, bei der ein Auftrag an den Lieferanten geschickt wird, eine Rechnung vom Lieferanten zurückgeschickt wird und der Hub eine Zahlung veranlasst. Schließlich schickt der Lieferant zum Abschluß des elektronischen Beschaffungsprozesses eine Zahlungsbestätigung. Die folgende Abbildung zeigt die in diesem Beispiel verwendete Geschäftstransaktion.

Datenfluss in einer Geschäftstransaktion

Nachdem das Beispiel für die elektronische Beschaffung erfolgreich ausgeführt wurde, steht die Bereitstellung dieser Konfiguration für andere Server mithilfe von Microsoft Application Center 2000 im Mittelpunkt. Diese Konfiguration wird dann aus einer Testumgebung in eine Produktionsumgebung übernommen. Zudem wird erläutert, wie die Konfiguration des Lieferanten mithilfe des BizTalk-SEED-Assistenten gepackt wird, so dass sie auf einfache Art und Weise von einer Website gedownloadet und von anderen Lieferanten implementiert werden kann. Schließlich wird das Einrichten von Microsoft Operations Manager (MOM) zur Überwachung der im Hub stattfindenden Aktivitäten erläutert.

In den folgenden Themen werden die Installations- und Konfigurationsvorgänge erläutert, die zum Durcharbeiten dieses Szenarios erforderlich sind:

  • Benutzerhandbuch
    • Vorläufige Installation

    • Ausführen des Beispiels für die elektronische Beschaffung
  • Programmierhinweise

  • Optionale Verfahren für Überwachung und Bereitstellung
    • Verwenden von Application Center für die Bereitstellung der elektronischen Beschaffung

    • Erstellen eines SEED-Pakets

    • Erstellen eines benutzerdefinierten MOMZählers im Beispiel für die elektronische Beschaffung


Benutzerhandbuch

Vor dem Ausführen dieses Beispiels müssen Sie zunächst die Korrelationsdatenbanken anfügen und das Installationsprogramm für die elektronische Beschaffung ausführen.

Wichtig

  • Bei den Anweisungen in diesem Beispiel wird vorausgesetzt, dass dieses Beispiel und BizTalk Server 2002 auf demselben Laufwerk installiert sind.

  • Die eProcurement-Beispieldateien müssen auf der Stammebene des Laufwerkes in den Ordner eProcurementSample kopiert werden. Diese Beispieldateien befinden sich auf der Stammebene der BizTalk Server 2002-CD im Ordner eProcurementSample.

  • Nach dem Kopieren der Dateien auf das Laufwerk müssen Sie überprüfen, ob der leere Ordner PaymentAckReceived direkt unter dem Ordner ePprocurementSample vorhanden ist. Erstellen Sie gegebenenfalls den Ordner PaymentAckReceived.

Beenden Sie zur Vorbereitung und Ausführung des Beispiels für die elektronische Beschaffung die folgenden Verfahren:

  • Vorläufige Installation

  • Ausführen des Beispiels für die elektronische Beschaffung


Vorläufige Installation

In diesem Abschnitt erfahren Sie, mit welchen Schritten Sie das System zur Ausführung des Beispiels für die elektronische Beschaffung konfigurieren müssen. Bevor Sie das Beispiel für die elektronische Beschaffung ausführen können, müssen Sie Korrelationsdatenbanken anfügen und den Hub und die Lieferantensysteme konfigurieren. In diesem Szenario werden sowohl der Hub als auch der Lieferant in einer BizTalk Server-Installation konfiguriert. In einer realen Produktionsumgebung wären der Hub und der Lieferant zwei voneinander getrennte Entitäten.

Voraussetzungen

Bei diesem Beispiel wird vorausgesetzt, dass folgende Komponenten auf dem Computer mit BizTalk Server ausgeführt werden:

  • Microsoft BizTalk Server 2002

  • Microsoft SQL Server™

  • Message Queuing (auch MSMQ genannt)

Anmerkung

  • Falls Sie in dieser Demo auch den Abschnitt zur Verwendung von Application Center durcharbeiten möchten, müssen Sie vor dem Installieren von BizTalk Server erst Application Center installieren.

  • Zudem sollten Sie das Beispiel nach einer Neuinstallation von BizTalk Server ausführen. Wenn Sie alle BizTalk Server-Objekte (Ports, Kanäle usw.) schnell löschen möchten, können Sie das Skript CleanBTM.vbs ausführen, das sich im Verzeichnis eProcurementSample befindet.

Wichtig

  • Das Skript CleanBTM.vbs entfernt alle Konfigurationsinformationen aus der BizTalk Messaging-Verwaltungsdatenbank. Dieses Skript sollte nur in einer Testumgebung ausgeführt werden.

Anfügen der Datenbanken

In diesem Verfahren richten Sie die im Beispiel für elektronische Beschaffung verwendeten Korrelationsdatenbanken mithilfe von Microsoft SQL Server 2000 ein. Falls Sie Microsoft SQL Server 7.0 verwenden, finden Sie weitere Informationen im Abschnitt "Erstellen der Datenbanken". Es gibt zwei Korrelationsdatenbanken, eine für den Hub und eine für den Lieferanten. Diese Datenbanken erfassen und speichern den global eindeutigen Bezeichner (Globally Unique Identifier, GUID) und die Transaktions-ID. die zu Beginn des XLANG-Ablaufplanes generiert werden. GUID und Transaktions-ID werden zur Korrelation der in dieser Transaktion gesendeten und empfangenen Dokumente mit dem richtigen XLANG-Ablaufplan verwendet. Als Transaktions-ID wird ein Bezeichner wie eine Auftragsnummer oder eine Rechnungsnummer verwendet.

Anmerkung

Bei den folgenden Anweisungen wird vorausgesetzt, dass SQL Server 2000 auf demselben Computer installiert ist wie BizTalk Server. Falls SQL Server auf einem anderen Computer installiert ist, müssen Sie diese Anweisungen an die entsprechende Umgebung anpassen. Stellen Sie vor Beginn dieses Verfahrens sicher, dass für die Eigenschaften in den Datenbanken CustomCorrelation_Data und SupplierCustomCorrelation_Data kein Schreibschutz festgelegt ist. Die Datenbankdateien befinden sich im Verzeichnis Databases unter dem Verzeichnis eProcurementSample.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

    SQL Server Enterprise Manager wird angezeigt.

  2. Erweitern Sie Microsoft SQL Server, erweitern Sie SQL Server-Gruppe und dann den Server, auf dem Sie die Datenbank anfügen möchten.

  3. Klicken Sie auf Datenbanken.

  4. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie dann auf Datenbank anhängen.

    Das Dialogfeld Datenbank anfügen wird angezeigt.

  5. Klicken Sie auf die Schaltfläche mit den drei Punkten (...).

    Das Dialogfeld Vorhandene Datei suchen wird angezeigt.

  6. Gehen Sie zum Verzeichnis Databases, das sich im Verzeichnis eProcurementSample befindet.

  7. Klicken Sie auf CustomCorrelation_Data.MDF und dann auf OK.

    Ein Feld wird mit der Meldung angezeigt, dass der Vorgang erfolgreich ausgeführt wurde.

  8. Wiederholen Sie die Schritte in diesem Verfahren, um die Datei SupplierCustomCorrelation_Data.MDF anzufügen, die sich im Verzeichnis Databases unter dem Verzeichnis eProcurementSample befindet.

Erstellen der Datenbanken

Führen Sie das folgende Verfahren aus, wenn Sie Microsoft SQL Server 7.0 in der BizTalk Server-Installation verwenden.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server 7.0, und klicken Sie dann auf Enterprise Manager.

    SQL Server Enterprise Manager wird angezeigt.

  2. Erweitern Sie Microsoft SQL Server, erweitern Sie SQL Server-Gruppe und dann den Server, auf dem Sie die Datenbank anfügen möchten.

  3. Klicken Sie auf Datenbanken.

  4. Klicken Sie im Menü Vorgang auf Neue Datenbank.

    Das Menü Datenbankeigenschaften wird angezeigt.

  5. Geben Sie im Feld Name für die Datenbank den Namen CustomCorrelation ein.

  6. Klicken Sie auf OK.

  7. Klicken Sie im Menü Vorgang auf Neue Datenbank.

  8. Das Menü Datenbankeigenschaften wird angezeigt.

  9. Geben Sie im Feld Name für die Datenbank den Namen SupplierCustomCorrelation ein.

  10. Klicken Sie auf OK.

  11. Schließen Sie SQL Server Enterprise Manager.

  12. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server 7.0, und klicken Sie dann auf Query Analyzer.

    Das Menü Verbindung mit SQL Server herstellen wird angezeigt.

  13. Stellen Sie sicher, dass die richtigen Informationen für das Herstellen einer Verbindung zu SQL Server eingegeben wurden. Klicken Sie auf OK.

  14. Stellen Sie sicher, dass auf der Menüleiste im Feld DB der Wert CustomCorrelation steht. Falls dies nicht der Fall ist, klicken Sie auf das Dropdown-Listenfeld DB, und wählen Sie CustomCorrelation aus.

  15. Klicken Sie im Menü Datei auf Öffnen.

  16. Gehen Sie zum Verzeichnis Databases, das sich im Verzeichnis eProcurementSample befindet.

  17. Klicken Sie auf die Datei CustomCorrelationTable.sql.

  18. Klicken Sie im Menü Abfrage auf Ausführen. Dadurch wird die Datei CustomCorrelationTable.sql verarbeitet. Nach der Ausführung der SQL-Datei wird die folgende Meldung angezeigt: "Befehl(e) erfolgreich abgeschlossen".

  19. Wiederholen Sie die Schritte in diesem Verfahren für die Datei SupplierCustomCorrelationTable.sql.

  20. Schließen Sie Query Manager.

Einrichten der Konfiguration für die elektronische Beschaffung

In diesem Verfahren führen Sie das Installationsprogramm aus, um BizTalk Server für den Hub und den Lieferanten zum Ausführen des Beispiels für die elektronische Beschaffung zu konfigurieren.

Das Installationsprogramm für die elektronische Beschaffung führt die folgenden Tasks aus:

  • Erstellen der folgenden Nachrichtenwarteschlangen:

    .\private$\receiveinvoice

    .\private$\receivepayment

    .\private$\receivepaymentack

    .\private$\receivepo

    .\private$\receivepo2

    .\private$\supplierreceivepo

    .\private$\supplierreceivepo2

    Die Warteschlangen werden zum Übertragen von Daten zwischen den Geschäftspartnern verwendet, die durch die ausgeführten XLANG-Ablaufpläne für Hub und Lieferanten dargestellt sind.

  • Erstellen der virtuellen Verzeichnisse

    Die virtuellen Verzeichnisse werden mit HTTP-Empfangsfunktionen verwendet, so dass ein Handelspartner Daten an BizTalk Server senden kann.

    Nach Abschluss dieses Verfahrens sollte die Struktur der virtuellen Verzeichnisse in etwa folgendermaßen aussehen:

    Alias | Websitestruktur | Verzeichnispfad
    hub | Hub | \Programme\Microsoft BizTalk Server\HTTP Receive
    paymentack | hub/paymentack | \Programme\Microsoft BizTalk Server\HTTP Receive
    supplier | Supplier | \Programme\Microsoft BizTalk Server\HTTP Receive
    payment | supplier/payment | \Programme\Microsoft BizTalk Server\HTTP Receive

    Anmerkung

    • Der Wert für das virtuelle Verzeichnis Anwendungsschutz wird für alle in diesem Beispiel verwendete virtuellen Verzeichnisse auf Niedrig (IIS-Prozess) festgelegt. Mittel (zusammengefaßt) ist der Standardwert.
  • Erstellen der Kanäle und Ports

    Alle Kanäle werden so konfiguriert, dass sie die Standardwerte für den Messagingport außer Kraft setzen und die Nachricht mithilfe einer Nachrichtenbezeichnung mit einer bestimmten XLANG-Ablaufplaninstanz verbinden.

  • Registrieren der COM-Komponenten

  • Verschieben der Dokumentspezifikationen in den Ordner WebDAV

  • Erstellen der HTTP-Empfangsfunktionen

  • Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank

  • Registrieren der erforderlichen DLLs

Vor der Ausführung des Installationsprogramms müssen Sie sicherstellen, dass keine der oben aufgeführten Nachrichtenwarteschlangen vorhanden ist. Falls eine dieser Warteschlangen vorhanden ist, kann die Installation des Beispiels für elektronische Beschaffung fehlschlagen.

So installieren Sie das Beispiel für elektronische Beschaffung:

  1. Gehen Sie im Windows® Explorer zum Verzeichnis \COM Components\Setup, das sich im Verzeichnis eProcurementSample befindet.

  2. Doppelklicken Sie auf eProcSetup.exe.

    Ein Dialogfeld für die Installation wird angezeigt.

  3. Klicken Sie auf eProcurement Setup.

    Ein Dialogfeld wird mit der Meldung angezeigt, dass die Installation erfolgreich war.

Weiter mit Ausführen des Beispiels für die elektronische Beschaffung.


Ausführen des Beispiels für die elektronische Beschaffung

Das Beispiel für die elektronische Beschaffung zeigt die Korrelation von benutzerdefinierten Feldern in einem XLANG-Ablaufplan. Auf diese Weise können Sie einen Datenwert (z. B. eine Auftragsnummer) verwenden, der ein Dokument eindeutig identifiziert, und diesen Bezeichner mit einer ausgeführten XLANG-Ablaufplaninstanz verbinden, um ein Dokument in allen Schritten einer Geschäftstransaktion zu verarbeiten.

Gehen Sie zur Ausführung dieses Beispiels folgendermaßen vor:

  1. Gehen Sie in Windows Explorer zum Verzeichnis eProcurementSample.

  2. Starten Sie die XLANG-Ereignisüberwachung unter \Programme\Microsoft BizTalk Server\SDK\XLANG Tools.

  3. Doppelklicken Sie auf DocumentGenerator.vbs.

Um den erfolgreichen Abschluss der Transaktion zu überprüfen, gehen Sie zum Verzeichnis PaymentAckReceived, das sich im Verzeichnis eProcurementSample befindet. Dieses Verzeichnis sollte eine XML-Datei für die Zahlungsbestätigung enthalten, die der folgenden Benennungskonvention folgt: payack_[GUID].xml.

Um das Beispiel auszuführen und den Auftrag im Hub abzulehnen, ändern Sie POTotal in der Datei PO.xml auf einen Wert größer als 1000. Um das Beispiel auszuführen und den Auftrag durch das Lieferantensystem abzulehnen, ändern Sie POTotal in der Datei PO.xml auf einen Wert kleiner als 300. Die Datei PO.xml befindet sich im Verzeichnis eProcurementSample.

Anmerkung

  • Standardmäßig sind die Ablaufpläne von Hub und Lieferanten an Windows Scripting-Komponenten gebunden, die sich unter C:\EprocurementSample\Script Components\Message.wsc befindet. Falls die Komponente nicht an diesem Speicherort vorhanden ist, schlägt der Ablaufplan fehl. Öffnen Sie zur Lösung dieses Problems die Ablaufpläne im BizTalk Orchestrierungs-Designer, und verwenden Sie den Bindungs-Assistenten für Skriptkomponenten, um die Skriptdatei erneut mit dem richtigen Laufwerk und Pfad für die Komponente zu verbinden.

Weiter mit Programmierhinweise.


Programmierhinweise

Aktivierung des XLANG-Ablaufplanes im Beispiel für die elektronische Beschaffung

Beim Ausführen dieses Beispiels wird die Datei PO.xml an die Warteschlange ReceivePO übergeben, ein XLANG-Ablaufplan aktiviert und der Vorgang für die elektronische Beschaffung gestartet. Der Messagingport HubReceivePO aktiviert eine neue Instanz des XLANG-Ablaufplanes hub.skx und übermittelt das Dokument anschließend an den Port ReceivePO. Nachdem der Auftrag genehmigt wurde, wird er an den Hub gesendet. Der Hub sendet den Auftrag an den Lieferanten und wartet auf den Erhalt einer Rechnung.

Mithilfe der HTTP-Empfangsfunktion wird der Auftrag an den Lieferanten übermittelt. Wenn der Lieferant den Auftrag empfängt, wird ein XLANG-Ablaufplan im Lieferantensystem aktiviert, und der Vorgang wird in diesem System gestartet. Der Messagingport SupplierReceivePO aktiviert eine neue Instanz des XLANG-Ablaufplanes supplier.skx und übermittelt das Dokument anschließend an den Port ReceivePOfromHub. Nachdem der Auftrag in eine Rechnung umgewandelt wurde, wird diese Rechnung zurück an den Hub geschickt.

Mithilfe der HTTP-Empfangsfunktion wird die Rechnung an den Hub übermittelt. Der Hub empfängt die Rechnung und sendet eine Zahlungsanweisung. Erneut wird die HTTP-Empfangsfunktion zum Übermitteln der Zahlungsanweisung an den Lieferanten verwendet. Sobald der Lieferant die Zahlung erhält, wird eine Bestätigung versandt. Die Transaktion ist abgeschlossen, wenn die Bestätigung durch den Hub empfangen und in eine Datei unter \eProcurementSample\PaymentAckReceived geschrieben wird.

Korrelation des XLANG-Ablaufplanes für das Beispiel für die elektronische Beschaffung

Jeder Instanz eines XLANG-Ablaufplanes wird durch das XLANG-Ablaufplanungsmodul ein global eindeutiger Bezeichner (Globally Unique Identifier, GUID) zugewiesen. In diesem Beispiel wird die GUID aus der Nachricht extrahiert, in einer Korrelationsdatenbank gespeichert und mit einer Transaktions-ID (wie z. B. einer Auftragsnummer oder Rechnungsnummer) verbunden.

Im Einzelnen geschieht Folgendes: Wenn der Hub einen Auftrag empfängt, wird die GUID extrahiert, in der Datenbank CustomCorrelation gespeichert und mit einer Transaktions-ID verbunden. Wenn der Lieferant den Auftrag empfängt, wird die Transaktions-ID angezeigt, zudem werden jedoch eine eigene GUID und eine eigene Transaktions-ID generiert, die in der Datenbank SupplierCustomCorrelation gespeichert werden. Diese Werte werden zur Korrelation eingehender und ausgehender Nachrichten mit der richtigen ausgeführten Ablaufplaninstanz verwendet, wenn die Transaktion von einem Auftrag in eine Rechnung und von der Rechnung in eine Zahlung umgewandelt und schließlich mit der Zahlungsbestätigung beendet wird. Die Korrelation beginnt bereits, wenn der Hub eine Rechnung empfängt und die Rechnung mit dem richtigen Auftrag und somit mit dem richtigen XLANG-Ablaufplan verbunden werden muss.

Zusätzliche Informationen zur Korrelation finden Sie unter:

XLANG Schedule Correlation

Instanzenverwaltung

Deinstallieren des Beispiels für die elektronische Beschaffung

Es steht kein Skript zum Entfernen der Dateien und BizTalk-Messaging-Konfigurationsobjekte wie z. B. Ports und Kanäle zur Verfügung, die durch das Ausführen des Installationsprogramms erstellt werden. In der nachstehenden Liste sind die in diesem Beispiel verwendeten BizTalk-Messaging-Konfigurationsobjekte, -Dateien, -Ordner und -Bibliotheken aufgeführt. Diese Elemente können nach Beendigung des Beispiels manuell entfernt werden.

Organisationen

Hub, Lieferant

Kanäle

HubReceivePO, HubSendPO, SupplierReceivePO, HubReceiveInvoice, SupplierSendInvoice, HubSendPayment, SupplierReceivePayment, SupplierSendPaymentAck, HubReceivePaymentAck, HubSendPayAckToFile

Dokumentdefinitionen

EcommonInvoice, EcommonPayment, EcommonPO, EPaymentAck

Messagingports

HubReceivePO, HubSendPO, SupplierReceivePO, HubReceiveInvoice, SupplierSendInvoice, HubSendPayment, SupplierReceivePayment, SupplierSendPaymentAck, HubReceivePaymentAck, HubSendPayAckToFile

Empfangsfunktionen (in der BizTalk Server-Verwaltung):

HubReceiveInvoice, HubReceivePaymentAck, Receive PO, SupplierReceivePayment, SupplierReceivePO

Private Messaging-Warteschlangen (in der Computerverwaltung)

receiveinvoice, receivepayment, receivepaymentack, receivepo, receivepo2, supplierreceivepo, supplierreceivepo2

BizTalk Server Repository-Dateien (WebDAV)

ECommonInvoice.xml, eCommonPayment.xml, ECommonPO.xml, ePaymentAck.xml

Registrierte Bibliotheken

Correlation.dll, HubTransformation.dll, PaymentTransformation.dll, SuppCorrelation.dll, Transformation.dll

Ordner in "\Microsoft BizTalk Server\HTTP Receive"

Hub
Hub/PaymentAck
Supplier
Supplier/Payment

Anmerkung

  • Mit jedem dieser Ordner ist ein virtuelles Verzeichnis in IIS (Internet Information Services, Internet-Informationsdienste) verbunden.


Optionale Verfahren für Überwachung und Bereitstellung

Bevor Sie fortfahren, müssen Sie das Beispiel für die elektronische Beschaffung installieren und ausführen. Die folgenden Verfahren sind jedoch optional:

Es folgen die Voraussetzungen für die Überwachung und Bereitstellung:

  • Zum Ausführen des Bereitstellungsverfahrens muss Application Center 2000 ausgeführt werden.

  • Während der Installation von Microsoft Operations Manager (MOM) wird die MOM-Konfiguration für erweiterte Überwachungsfunktionen ausgeführt. Für dieses Verfahren ist MOM 2000 und das BizTalk Server 2002 Management Pack erforderlich.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden von Application Center für die Bereitstellung der elektronischen Beschaffung

  • Erstellen eines SEED-Pakets

  • Erstellen eines benutzerdefinierten MOMZählers im Beispiel für die elektronische Beschaffung


Verwenden von Application Center für die Bereitstellung der elektronischen Beschaffung

Application Center kann zum Bereitstellen einer BizTalk Server-Konfiguration aus einer Umgebung in einer anderen Umgebung verwendet werden, z. B. zum Verschieben einer Konfiguration aus einer Testumgebung in eine Produktionsumgebung. Wenn Application Center zum Bereitstellen von Umgebungen verwendet wird, werden sowohl die zum Verschieben der Konfigurationen benötigte Zeit als auch die mit dieser Verschiebung verbundene Anzahl von Benutzereingriffen deutlich reduziert.

In diesem Szenario befindet sich der Hub auf einem Server (der Quelle), und die BizTalk Server-Konfiguration wird auf einem anderen Server (dem Ziel) innerhalb der Organisation bereitgestellt. Bei dem Beispiel für die elektronische Beschaffung wurden die Hub- und Lieferantenkonfiguration auf demselben Computer installiert. Wenn demnach die gesamte Konfiguration von einer Umgebung zu einer anderen verschoben wird, sind sowohl der Hub als auch der Lieferant darin enthalten. In einer Produktionsumgebung wären der Hub und der Lieferant auf unterschiedlichen Computern, und der Lieferant würde nicht bereitgestellt.

Anmerkung

  • Sie müssen Application Center installieren, bevor Sie BizTalk Server installieren.

Es folgen die Voraussetzungen für die Verwendung von Application Center zur Bereitstellung:

  • Um Application Center für die Bereitstellung elektronischer Beschaffung zu verwenden, müssen Sie Application Center 2000 auf zwei Computern installieren. Ein Computer wird als Quellcomputer und der andere als Zielcomputer verwendet. Auf beiden Computern sollte BizTalk Server 2002 installiert sein und ausgeführt werden. Zudem muss das Beispiel für die elektronische Beschaffung auf dem Quellcomputer installiert sein und ordnungsgemäß ausgeführt werden.

  • Nach der Installation von Application Center 2000 müssen Sie Service Pack 1 für Application Center 2000 installieren. Service Pack 1 für Application Center 2000 befindet sich im Verzeichnis Application Center 2000 SP1 auf der Installations-CD von BizTalk Server 2002.

  • Falls auf dem Computer noch keine Cluster erstellt wurden, müssen Sie sowohl auf dem Quell- als auch auf dem Zielcomputer Cluster erstellen. Der Quellcomputer und der Zielcomputer müssen sich unbedingt auf separaten Clustern befinden, so dass mit dem Beispiel die Bereitstellung aus einer Umgebung in eine andere simuliert werden kann, z. B. von einer Testumgebung in eine Produktionsumgebung.

Nachdem der Quellcomputer und der Zielcomputer ordnungsgemäß konfiguriert wurden, können Sie mit Application Center eine Anwendung auf dem Quellcomputercluster erstellen. Weitere Informationen finden Sie unter Verwenden von Application Center 2000.

Zu den Ressourcentypen für diesen Cluster zählen folgende:

  • Dateisystempfade
    • Die Site mit dem Beispiel für die elektronische Beschaffung (z. B., \eProcurementSample)
  • Websites und virtuelle Verzeichnisse
    • Virtuelles Verzeichnis Hub

    • Virtuelles Verzeichnis Supplier
  • BizTalk
    • BizTalkPorts

    • BizTalkReceiveFunctions

Nach ihrer Erstellung können Sie die Anwendung Application Center vom Quellcomputer aus auf dem Zielcomputer bereitstellen. Weitere Informationen finden Sie unter Bereitstellen einer Application Center-Anwendung auf einem Zielserver.

Da der Zielcomputer Teil eines anderen Clusters ist, müssen Sie im Bereitstellungs-Assistenten auf der Seite Deployment Target Options die Option Deploy content outside the current cluster auswählen. Der Bereitstellungs-Assistent verfügt auch über eine Dropdownliste mit den für die Bereitstellung verfügbaren Anwendungen. Geben Sie an, dass die zuvor von Ihnen auf dem Quellcomputer erstellte Anwendung auf dem Zielcomputer bereitgestellt werden soll.

Nach Abschluß der Bereitstellung müssen Sie geringfügige Änderungen auf dem Zielcomputer vornehmen. Falls z. B. die Korrelationsdatenbanken, die im Beispiel für die elektronische Beschaffung verwendet werden, während der Bereitstellung von SQL Server verwendet werden, können Sie nicht mithilfe von Application Center auf den Zielcomputer kopiert werden.

Um die Korrelationsdatenbanken manuell zur SQL Server-Instanz des Zielcomputers zu kopieren, verwenden Sie das Verfahren zum Anfügen der Datenbanken, das im Abschnitt "Vorläufige Installation" des Beispiels für die elektronische Beschaffung erläutert wird. Sie können auch Data Transformation Services (DTS) von SQL Server zum Exportieren der Datenbanken zur SQL Server-Instanz des Zielcomputers verwenden.

Darüber hinaus werden die vom Beispiel für die elektronische Beschaffung verwendeten DLLs mithilfe von Application Center auf den Zielcomputer kopiert, sie werden jedoch nicht auf dem Zielcomputer registriert. Registrieren Sie die erforderlichen DLLs, indem Sie die Skriptdatei RegisterDLLs.vbs im Verzeichnis \eProcurementSample\Application Center ausführen. Falls Sie zum ersten Mal das Beispiel auf dem Zielcomputer bereitgestellt haben, wurden die Nachrichtenwarteschlangen sehr wahrscheinlich noch nicht auf diesem Computer erstellt. Erstellen Sie die erforderlichen Nachrichtenwarteschlangen, indem Sie die Skriptdatei CreateQueues.vbs im Verzeichnis \eProcurementSample\Application Center ausführen.

Anmerkung

  • Möglicherweise müssen Sie alle BizTalk-Empfangsfunktionen aktivieren, die vom Beispiel für die elektronische Beschaffung verwendet werden. Sie können die Empfangsfunktionen in der Anwendung BizTalk Server-Verwaltung aktivieren. Dies kann erforderlich sein, da die Empfangsfunktionen bereits vor den Nachrichtenwarteschlangen erstellt werden. BizTalk Server deaktiviert Empfangsfunktionen automatisch, wenn auf die entsprechenden Abrufspeicherorte (Verzeichnis, Nachrichtenwarteschlange usw.) nicht zugegriffen werden kann.

Schließlich müssen die BizTalk-Ports auf dem Zielcomputer geändert werden, so dass die primäre Portadresse auf den Zielserver zeigt. Wenn Application Center die BizTalk Server-Konfiguration von einem Computer auf einem anderen bereitstellt, werden die BizTalk-Ports nicht geändert. Sie zeigen weiterhin auf den Quellserver. Die folgenden Ports müssen bearbeitet werden, so dass sie auf den Zielserver zeigen:

  • HubSendPayment

  • HubSendPO

  • SupplierSendInvoice

  • SupplierSendPaymentAck

Anmerkung

  • Möglicherweise müssen Sie den BizTalk-Dienst starten und anhalten, damit die Änderungen wirksam werden. Sie können den BizTalk-Dienst im Tool BizTalk Server-Verwaltung starten und anhalten.


Erstellen eines SEED-Pakets

Zur Ausführung dieses Verfahrens muss das Beispiel für die elektronische Beschaffung auf dem Server installiert sein und ordnungsgemäß ausgeführt werden.

In diesem Beispiel wird erläutert, wie ein Hub ein SEED-Paket erstellt, wie ein Lieferant das SEED-Paket installiert und wie das SEED-Paket vom Lieferanten getestet wird.

In diesem Szenario erstellt der Hub ein SEED-Paket mit speziellen Dokumentspezifikationen, die an den Handelspartner gesendet werden sollen (entspricht der Lieferantenorganisation in diesem Beispiel). Der Handelspartner installiert das SEED-Paket. Das Beispiel für die elektronische Beschaffung wurde so eingerichtet, dass sich der Hub und der Lieferant auf einem Computer befinden. SEED-Pakete sollen in zwei getrennten Umgebungen verwendet werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Vorbereitungen für das SEED-Paket

  • Erstellen des SEED-Pakets


Vorbereitungen für das SEED-Paket

Bevor Sie das SEED-Paket erstellen, müssen Sie ein virtuelles Verzeichnis in IIS (Internet Information Services, Internet-Informationsdienste) für das SEED-Paket erstellen und die entsprechenden ASP-Dateien kopieren. Sie werden für die Testsite des Hubs verwendet.

Erstellen eines virtuellen Verzeichnisses in IIS für das SEED-Paket

  1. Erstellen Sie ein neues Verzeichnis mit dem Namen SEEDPackage auf dem Computer mit BizTalk Server. Dieses Verzeichnis wird beim Testen des SEED-Pakets verwendet.

  2. Erstellen Sie im Verzeichnis SEEDPackage die drei folgenden neuen Verzeichnisse: SeedTestSite, SeedDropSite und SeedReceiveSite.

  3. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Internetdienste-Manager. Erweitern Sie die aktuelle Computerliste.

  4. Klicken Sie mit der rechten Maustaste auf Standardwebsite, zeigen Sie auf Neu, und klicken Sie dann auf Virtuelles Verzeichnis. Der Assistent zum Erstellen virtueller Verzeichnisse wird geöffnet.

  5. Klicken Sie auf Weiter. In einem neuen Bildschirm wird nach dem Alias für das virtuelle Verzeichnis gefragt. Geben Sie im Feld Alias den Namen SeedTestSite ein, und klicken Sie dann auf Weiter.

  6. In einem neuen Bildschirm wird nach dem Speicherort gefragt, auf den das virtuelle Verzeichnis zeigen soll. Verwenden Sie die Schaltfläche Durchsuchen, um das zuvor erstellte Verzeichnis SeedTestSite zu suchen, oder geben Sie im Feld Verzeichnis den vollständigen Pfad des Verzeichnisses SeedTestSite ein. Klicken Sie dann auf Weiter.

  7. In einem neuen Bildschirm können Sie die Zugriffsberechtigungen für das virtuelle Verzeichnis ändern. Behalten Sie die Standardeinstellungen bei, und klicken Sie auf Weiter. Klicken Sie im nächsten Bildschirm auf Fertig stellen.

Kopieren der entsprechenden Dateien

Kopieren Sie die folgenden ASP-Dateien aus dem Verzeichnis SEED, das sich unter \Programme\Microsoft BizTalk Server\SEED befindet:

  • LocalSubmit.asp

  • SlingBack.asp

  • Trigger.asp

Fügen Sie die Dateien in das zuvor erstellte Verzeichnis SeedTestSite ein. Die Dateien SlingBack.asp und Trigger.asp werden vom Hub in Remotetests für eingehende und ausgehende Dokumente verwendet. LocalSubmit.asp wird vom Lieferanten in Remotetests für ausgehende Dokumente verwendet. Weitere Informationen zum Verwenden dieser ASP-Dateien finden Sie unter Grundlegendes zu den ASP-Seiten in SEED.

Weiter mit Erstellen des SEED-Pakets.


Erstellen des SEED-Pakets

Der Hub erstellt ein SEED-Paket und stellt es den Lieferanten zur Verfügung. Wenn der Hub eine Partnerschaft mit einem neuen Lieferanten einrichtet, downloadet der neue Lieferant das SEED-Paket, installiert es und sendet Dokumente an die Testsite des Hubs. Falls keine Probleme auftreten, kann der Lieferant diese Konfiguration in die Produktionsumgebung integrieren und mit Transaktionen für die elektronische Beschaffung mit dem Hub beginnen. Die folgenden Verfahren erläutern das Einrichten, Installieren und Testen eines SEED-Pakets.

Anmerkung

  • Das Beispiel für die elektronische Beschaffung wurde so eingerichtet, dass sich der Hub und der Lieferant auf einem Computer befinden. SEED-Pakete sollen jedoch in zwei getrennten Umgebungen verwendet werden.

Führen Sie zur Implementierung der Verwendung eines SEED-Pakets die folgenden Verfahren aus:

  • Hinzufügen der Spezifikation "Standardauftrag"

  • Hinzufügen der Spezifikation "Standardrechnung"

  • Hinzufügen der Spezifikation "Standardzahlung"

  • Hinzufügen der Spezifikation "Zahlungsbestätigung"

  • Abschluß der SEED-Paket-Erstellung

  • Installieren des SEED-Pakets

  • Testen der SEED-Paket-Spezifikationen


Hinzufügen der Spezifikation "Standardauftrag"

Das vom Hub erstellte SEED-Paket enthält Dokumentspezifikationen vom Typ Standardauftrag.

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002. Klicken Sie dann auf BizTalk-SEED-Assistent.

  2. Das Menü BizTalk-SEED-Assistent wird angezeigt. Der Standardwert ist SEED-Paket erstellen. Klicken Sie auf Weiter.

  3. Geben Sie Hub im Feld Organisation ein, und klicken Sie auf Weiter.

  4. Das Menü Paketerstellung – Dokumentspezifikationen wird angezeigt. Klicken Sie auf Hinzufügen.

  5. Klicken Sie neben dem Feld Spezifikation auf Durchsuchen. Doppelklicken Sie auf das Verzeichnis eProcurement. Doppelklicken Sie auf die Dokumentspezifikation ECommonPO.xml. Dadurch wird das Feld Spezifikation automatisch mit dem Speicherort der Schemadatei gefüllt.

  6. Klicken Sie neben dem Feld Testinstanz auf Durchsuchen. Gehen Sie zum Verzeichnis eProcurementSample. Doppelklicken Sie im Verzeichnis eProcurementSample auf das Verzeichnis Instances. Doppelklicken Sie im Verzeichnis Instances auf CommonPO_Instance.xml. Dadurch wird das Feld Testinstanz mit dem Speicherort der Instanzdatei gefüllt.

  7. Stellen Sie sicher, dass die Option Ausgehend von Initiator aktiviert ist.

  8. Im Feld URL für Remotetest sollte die Eingabe auf die zuvor erstellte Site des virtuellen Verzeichnisses für das SEED-Paket zeigen und auf die Datei Trigger.asp. Die Eingabe sollte folgendermaßen lauten: http://<Servername>/SeedTestSite/Trigger.asp. Die Datei Trigger.asp wird in Remotetests für ausgehende Dokumente verwendet.

  9. Klicken Sie auf OK.

Weiter mit Hinzufügen der Spezifikation "Standardrechnung".


Hinzufügen der Spezifikation "Standardrechnung"

Das vom Hub erstellte SEED-Paket enthält auch Dokumentspezifikationen vom Typ Standardrechnung.

  1. Klicken Sie im Menü Paketerstellung – Dokumentspezifikationen auf Hinzufügen. Dadurch wird ein weiteres Dokument zum SEED-Paket für das Testen hinzugefügt.

  2. Klicken Sie neben dem Feld Spezifikation auf Durchsuchen. Doppelklicken Sie auf das Verzeichnis eProcurement. Doppelklicken Sie auf die Dokumentspezifikation ECommonInvoice.xml.

  3. Klicken Sie neben dem Feld Testinstanz auf Durchsuchen. Gehen Sie zum Verzeichnis eProcurementSample. Doppelklicken Sie im Verzeichnis eProcurementSample auf das Verzeichnis Instances. Doppelklicken Sie im Verzeichnis Instances auf CommonInvoice_Instance.xml.

  4. Stellen Sie sicher, dass die Option Eingehend an Initiator ausgewählt ist.

  5. Im Feld URL für Remotetest sollte die Eingabe auf die zuvor erstellte Site des virtuellen Verzeichnisses für das SEED-Paket zeigen und auf die Datei SlingBack.asp. Die Eingabe sollte folgendermaßen lauten: http://<Servername>/SeedTestSite/SlingBack.asp. Die Datei SlingBack.asp wird in Tests für eingehende Dokumente verwendet.

  6. Da in dieser Übung das Erstellen eines SEED-Pakets anhand eines Beispiels gezeigt werden soll, wird nicht auf eine reale Produktionssite gezeigt. Daher können Sie im Feld Produktions-URL den Wert aus dem Feld URL für Remotetest kopieren. In einer realen Produktionsumgebung würden Sie in diesem Feld die Informationen der Produktionssite eingeben.

  7. Klicken Sie auf OK.

Weiter mit Hinzufügen der Spezifikation "Standardzahlung".


Hinzufügen der Spezifikation "Standardzahlung"

Das vom Hub erstellte SEED-Paket enthält auch Dokumentspezifikationen vom Typ Standardzahlung.

  1. Klicken Sie im Menü Paketerstellung – Dokumentspezifikationen auf Hinzufügen. Dadurch wird ein weiteres Dokument zum SEED-Paket für das Testen hinzugefügt.

  2. Klicken Sie neben dem Feld Spezifikation auf Durchsuchen. Doppelklicken Sie auf das Verzeichnis eProcurement. Doppelklicken Sie auf die Dokumentspezifikation ECommonPayment.xml.

  3. Klicken Sie neben dem Feld Testinstanz auf Durchsuchen. Gehen Sie zum Verzeichnis eProcurementSample. Doppelklicken Sie im Verzeichnis eProcurementSample auf das Verzeichnis Instances. Doppelklicken Sie im Verzeichnis Instances auf CommonPayment_Instance.xml.

  4. Stellen Sie sicher, dass die Option Ausgehend von Initiator ausgewählt ist.

  5. Im Feld URL für Remotetest sollte die Eingabe auf die zuvor erstellte Site des virtuellen Verzeichnisses für das SEED-Paket zeigen und auf die Datei Trigger.asp. Die Eingabe sollte folgendermaßen lauten: http://<Servername>/SeedTestSite/Trigger.asp. Weitere Informationen zu dieser Datei finden Sie unter Grundlegendes zu den ASP-Seiten in SEED.

  6. Klicken Sie auf OK.

Weiter mit Hinzufügen der Spezifikation "Zahlungsbestätigung".


Hinzufügen der Spezifikation "Zahlungsbestätigung"

Das vom Hub erstellte SEED-Paket enthält auch Dokumentspezifikatione vom Typ Zahlungsbestätigung.

  1. Klicken Sie im Menü Paketerstellung – Dokumentspezifikationen auf Hinzufügen. Dadurch wird ein weiteres Dokument zum SEED-Paket für das Testen hinzugefügt.

  2. Klicken Sie neben dem Feld Spezifikation auf Durchsuchen. Doppelklicken Sie auf das Verzeichnis eProcurement. Doppelklicken Sie auf die Dokumentspezifikation EPaymentAck.xml.

  3. Klicken Sie neben dem Feld Testinstanz auf Durchsuchen. Gehen Sie zum Verzeichnis eProcurementSample. Doppelklicken Sie im Verzeichnis eProcurementSample auf das Verzeichnis Instances. Doppelklicken Sie im Verzeichnis Instances auf PaymentAck_Instance.xml.

  4. Stellen Sie sicher, dass die Option Eingehend an Initiator ausgewählt ist.

  5. Im Feld URL für Remotetest sollte die Eingabe auf die zuvor erstellte Site des virtuellen Verzeichnisses für das SEED-Paket zeigen und auf die Datei SlingBack.asp. Die Eingabe sollte folgendermaßen lauten: http://<Servername>/SeedTestSite/SlingBack.asp. Die Datei SlingBack.asp wird in Tests für eingehende Dokumente verwendet. Weitere Informationen zu dieser Datei finden Sie unter Grundlegendes zu den ASP-Seiten in SEED.

  6. Da in dieser Übung das Erstellen eines SEED-Pakets anhand eines Beispiels gezeigt werden soll, wird nicht auf eine reale Produktionssite gezeigt. Daher können Sie im Feld Produktions-URL den Wert aus dem Feld URL für Remotetest kopieren. In einer realen Produktionsumgebung würden Sie in diesem Feld die Informationen der Produktionssite eingeben.

  7. Klicken Sie auf OK.

Weiter mit Abschluß der SEED-Paket-Erstellung.


Abschluß der Erstellung des SEED-Pakets

  1. Klicken Sie im Menü Paketerstellung – Dokumentspezifikationen auf Weiter.

  2. Klicken Sie auf Durchsuchen, und gehen Sie zum Verzeichnis SEEDPackage, das Sie zuvor erstellt haben. Legen Sie für das SEED-Paket den Namen SamplePackage.xml fest.

  3. Klicken Sie auf Fertig stellen. Ein Feld wird mit der Meldung angezeigt, dass das SEED-Paket erfolgreich erstellt wurde. Klicken Sie auf OK.

Weiter mit Installieren des SEED-Pakets.


Installieren des SEED-Pakets

Der Hub platziert das SEED-Paket auf seiner Website, damit die Lieferanten es downloaden können. Ein Lieferant downloadet das SEED-Paket und beendet die Konfiguration dann mithilfe des BizTalk-SEED-Assistenten. Dieses SEED-Beispiel wurde für die Erstellung, Installation und Bereitstellung auf einem einzelnen Computer entworfen. In einem realen Szenario würde das SEED-Paket auf einem Computer erstellt und auf einem anderen Computer installiert.

Bei der Installation des SEED-Pakets auf dem Lieferantensystem werden die erforderlichen Ports, Kanäle, Dokumentdefinitionen und Empfangsfunktionen erstellt. Die Titel der Ports, Kanäle, Dokumentdefinitionen und Empfangsfunktionen beginnen jeweils mit dem Namen des SEED-Pakets. Dieses Namensschema stellt sicher, dass eindeutige Namen für die Objekte des SEED-Pakets festgelegt werden, und es verhindert, dass bereits vorhandene Objekte erneut erstellt werden. Mithilfe des Namensschemas können die Objekte auch von den Objekten anderer SEED-Pakete unterschieden werden, die möglicherweise auf den Computern mit BizTalk Server installiert sind.

Bei dem Verfahren wird vorausgesetzt, dass sich das SEED-Paket in einem Repository befindet, auf das der Server zugreifen kann.

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002. Klicken Sie anschließend auf BizTalk-SEED-Assistent.

  2. Das Menü BizTalk-SEED-Assistent wird angezeigt. Stellen Sie sicher, dass die Option SEED-Paket installieren ausgewählt ist. Klicken Sie auf Weiter.

  3. Klicken Sie neben dem Feld Paketdatei auf Durchsuchen. Gehen Sie zum Verzeichnis SEEDPackage. Doppelklicken Sie auf die Datei SamplePackage.xml.

  4. Dadurch werden die Informationen zum SEED-Paket angezeigt (Paket-ID, Organisation usw.). Klicken Sie auf Weiter. Übernehmen Sie im Menü Paketinstallation – Testinformationen die Standardeinstellungen, und klicken Sie dann auf Weiter.

  5. Auf dem nächsten Bildschirm werden die Dokumente angezeigt, die Teil des SEED-Pakets sind. Markieren Sie die Spezifikation EcommonPO.xml, und klicken Sie auf Konfigurieren.

  6. Geben Sie im Feld Produktions-URL den Pfad http://<Servername>/SeedTestSite/localsubmit.asp ein. Die Datei localsubmit.asp wird in Remotetests für ausgehende Dokumente verwendet. Weitere Informationen zu dieser Datei finden Sie unter Grundlegendes zu den ASP-Seiten in SEED.

  7. Klicken Sie neben dem Feld Endgültiges Verzeichnis auf Durchsuchen. Gehen Sie zum Verzeichnis SeedDropSite im Verzeichnis SEEDPackage, das Sie zuvor erstellt haben. Stellen Sie sicher, dass das Verzeichnis SeedDropSite ausgewählt ist. Klicken Sie auf OK.

  8. Markieren Sie die Spezifikation ECommonInvoice.xml, und klicken Sie auf Konfigurieren.

  9. Klicken Sie neben dem Feld Speicherort auf Durchsuchen. Gehen Sie zum Verzeichnis SeedReceiveSite im Verzeichnis SEEDPackage, das Sie zuvor erstellt haben. Stellen Sie sicher, dass das Verzeichnis SeedReceiveSite ausgewählt ist. Klicken Sie auf OK.

  10. Geben Sie im Feld Abzurufende Dateitypen die Spezifikation CommonInvoice_Instance.xml ein.

  11. Klicken Sie neben dem Feld Textverzeichnis auf Durchsuchen. Gehen Sie zum Verzeichnis SeedDropSite im Verzeichnis SEEDPackage, das Sie zuvor erstellt haben. Stellen Sie sicher, dass das Verzeichnis SeedDropSite ausgewählt ist. Klicken Sie auf OK.

  12. Markieren Sie die Spezifikation ECommonPayment.xml, und klicken Sie auf Konfigurieren.

  13. Geben Sie im Feld Produktions-URL den Pfad http://<Servername>/SeedTestSite/localsubmit.asp ein. Die Datei localsubmit.asp wird in Remotetests für ausgehende Dokumente verwendet. Weitere Informationen zu dieser Datei finden Sie unter Grundlegendes zu den ASP-Seiten in SEED.

  14. Klicken Sie neben dem Feld Endgültiges Verzeichnis auf Durchsuchen. Gehen Sie zum Verzeichnis SeedDropSite im Verzeichnis SEEDPackage, das Sie zuvor erstellt haben. Stellen Sie sicher, dass das Verzeichnis SeedDropSite ausgewählt ist. Klicken Sie auf OK.

  15. Markieren Sie die Spezifikation EPaymentAck.xml, und klicken Sie auf Konfigurieren.

  16. Klicken Sie neben dem Feld Speicherort auf Durchsuchen. Gehen Sie zum Verzeichnis SeedReceiveSite im Verzeichnis SEEDPackage, das Sie zuvor erstellt haben. Stellen Sie sicher, dass das Verzeichnis SeedReceiveSite ausgewählt ist. Klicken Sie auf OK.

  17. Geben Sie im Feld Abzurufende Dateitypen die Spezifikation PaymentAck_Instance.xml ein.

  18. Klicken Sie neben dem Feld Testverzeichnis auf Durchsuchen. Gehen Sie zum Verzeichnis SeedDropSite im Verzeichnis SEEDPackage, das Sie zuvor erstellt haben. Stellen Sie sicher, dass das Verzeichnis SeedDropSite ausgewählt ist. Klicken Sie auf OK.

  19. Klicken Sie auf OK.

Weiter mit Testen der SEED-Paket-Spezifikationen.


Testen der SEED-Paket-Spezifikationen

Zu diesem Zeitpunkt sollten alle Dokumentspezifikationen über den Status Konfigurieren Vollständig verfügen. Die SEED-Anwendung hat bis zu diesem Zeitpunkt noch keine neuen Objekte (Empfangsfunktionen, Ports, Kanäle usw.) erstellt. Der Lieferant muss folgende Schritte ausführen, um das SEED-Paket zu testen.

  1. Markieren Sie die Spezifikation ECommonPO.xml. Klicken Sie auf Erstellen. Nachdem die SEED-Anwendung die erforderlichen Objekte erstellt hat, sollte sich der Status der Spezifikation in Erstellen Weitergeleitet ändern. Dieser Vorgang muss für alle übrigen Spezifikationen wiederholt werden. Nachdem eine Spezifikation erstellt wurde, ist die Schaltfläche Lokal testen aktiviert.

  2. Markieren Sie die Spezifikation ECommonPO.xml. Klicken Sie auf Lokal testen. Nachdem der lokale Test für eine Spezifikation erfolgreich beendet wurde, ändert sich der Status in Lokaler Test Weitergeleitet, und die Schaltfläche Remote testen ist aktiviert. Bei der Ausführung eines lokalen Tests erstellt die SEED-Anwendung eine Instanz der bestimmten Spezifikation und sendet sie direkt an den entsprechenden zu überprüfenden Kanal. In diesem Fall ist dies der Kanal SamplePackage_ECommonPO. Dadurch wird sichergestellt, dass das Dokument das richtige Format hat. Falls das Instanzformat richtig ist, wird der Status der Spezifikation innerhalb des SEED-Pakets aktualisiert. Dieser Vorgang muss für alle übrigen Spezifikationen wiederholt werden. Bei eingehenden Dokumenten wird ein andere Vorgang für Lokal testen verwendet. Weitere Informationen zu lokalen SEED-Tests finden Sie unter Grundlegendes zu den ASP-Seiten in SEED.

  3. Markieren Sie die Spezifikation ECommonPO.xml. Klicken Sie auf Remote testen. Nachdem der Remotetest für eine eingehende Spezifikation erfolgreich beendet wurde, ändert sich der Status in Remotetest Weitergeleitet, und die Schaltfläche Bereitstellen ist aktiviert. Für ausgehende Spezifikationen wird die Schaltfläche Bereitstellen nicht aktiviert. Beim Ausführen eines Remotetests durch die SEED-Anwendung wird eine Instanz der jeweiligen Spezifikation erstellt und zu dem Remotetest-URL gesendet, der beim Erstellen des SEED-Pakets durch HTTP Post angegeben wurde. Anschließend wird die Instanz zur Seite trigger.asp gesendet, die sich auf dem Hub befindet. Die Seite trigger.asp sendet sie an den Lieferanten zurück, wo das Dokumentformat überprüft wird. Falls das Instanzformat richtig ist, wird der Status der Spezifikation innerhalb des SEED-Pakets aktualisiert. Dieser Vorgang muss für alle übrigen Spezifikationen wiederholt werden. Bei eingehenden Dokumenten wird ein anderer Vorgang für Remote testen verwendet. Weitere Informationen zu SEED-Remotetests finden Sie unter Grundlegendes zu den ASP-Seiten in SEED.

  4. Markieren Sie die Spezifikation ECommonInvoice.xml. Klicken Sie auf Bereitstellen. Nachdem die Spezifikation den Bereitstellungstest bestanden hat, wird ihr Status in Bereitstellen Weitergeleitet geändert. Wiederholen Sie die Schritte mit der Spezifikation ePaymentAck.xml.

  5. Wenn Sie beide Spezifikationen bereitgestellt haben, klicken Sie auf Weiter. Klicken Sie dann auf Fertig stellen.

Anmerkung

  • Die in diesem Verfahren von SEED erstellten Ports und Kanäle sind nicht Bestandteil des Beispiels für die elektronische Beschaffung. Die Ports und Kanäle im Beispiel für die elektronische Beschaffung wurden bereits konfiguriert. Das hier erläuterte SEED-Verfahren dient lediglich als Beispiel.

    In einem realen Szenario würden die Kunden zu diesem Zeitpunkt eigene Ablaufpläne um die durch SEED bereitgestellte Messaging-Konfiguration erstellen. Im Szenario für die elektronische Beschaffung wurde der Lieferantenablaufplan bereits um die Messaging-Konfiguration entwickelt, die für Geschäftstransaktionen mit dem Hub erforderlich sind.


Erstellen eines benutzerdefinierten MOMZählers im Beispiel für die elektronische Beschaffung

BizTalk Server 2002 ~ Beispiel für die elektronische Beschaffung (E-Procurement)

Erstellen eines benutzerdefinierten MOMZählers im Beispiel für die elektronische Beschaffung

Möglicherweise möchten die Administratoren des Hubsystems die Transaktionen mit dem Lieferanten überwachen. Mithilfe von Microsoft Operations Manager (MOM) können die Administratoren der Hubcomputer Regeln zum Zählen der Dokumente einrichten, die empfangen oder an den Lieferanten gesendet werden. Dieser Teil des Beispiels enthält die erforderlichen Schritte zum Einrichten von MOM-Regeln für das Überwachen von CommonInvoice-Dokumenten, die vom Lieferanten empfangen werden.

Für die folgenden Verfahren müssen MOM und BizTalk Server 2002 Management Pack für erweiterte Überwachungsfunktionen installiert sein. Um die Ergebnisse in MOM zu lesen, muss das Beispiel für die elektronische Beschaffung konfiguriert sein und ausgeführt werden.

Führen Sie die folgenden Verfahren aus, um einen benutzerdefinierten Zähler in MOM zu erstellen und zu verwenden:

  • Einrichten des benutzerdefinierten Zählers

  • Erstellen der MOM-Regel

  • Verteilen der Regeln an den Agent

  • Lesen der Ergebnisse in MOM


Einrichten des benutzerdefinierten Zählers

BizTalk Server 2002 ~ Beispiel für die elektronische Beschaffung (E-Procurement)

Einrichten des benutzerdefinierten Zählers

Mithilfe des folgenden Verfahrens wird der benutzerdefinierte Zähler von WMI (Windows Management Instrumentation, Windows-Verwaltungsinstrumentation) in BizTalk Server für das CommonInvoice-Dokument erstellt. Der erstellte benutzerdefinierte Zähler liest die Überwachungsdatenbank und gibt die Anzahl der Dokumente vom Typ CommonInvoice zurück, die in den letzten 300 Sekunden verarbeitet wurden.

Anmerkung

  • Dieses Skript muss auf dem Computer ausgeführt werden, auf dem BizTalk Server und der MOM Agent ausgeführt werden.

So richten Sie den benutzerdefinierten Zähler ein:

  1. Gehen Sie zu \eProcurementSample\Operations Manager.

  2. Doppelklicken Sie auf CustomCounter_eProcurement_CommonInvoice.vbs.

  3. Es wird ein Meldungsfeld zur Gültigkeitsüberprüfung angezeigt. Klicken Sie auf OK.

Weiter mit Erstellen der MOM-Regel.


Erstellen der MOM-Regel

BizTalk Server 2002 ~ Beispiel für die elektronische Beschaffung (E-Procurement)

Erstellen der MOM-Regel

Zum Ausführen der Schritte in den folgenden Verfahren muss BizTalk Server 2002 Management Pack installiert sein. Zudem müssen Sie grundsätzlich mit MOM-Operationen vertraut sein.

Starten Sie zum Erstellen der MOM-Regel die MOM Administrator Console. Alle Schritte werden innerhalb dieser Konsole ausgeführt.

Festlegen der Gruppe "Event Collection Rule"

Der Gruppenordner für die Regelverarbeitung Microsoft BizTalk Server verfügt zunächst nicht über eine Computergruppenzuordnung. Ohne diese Zuordnung können die in diesem Ordner platzierten Regeln nicht zum MOM Agent weitergeleitet werden.

  1. Erweitern Sie in MOM Administrator Console den Ordner Rules und dann Processing Rule Groups.

  2. Klicken Sie mit der rechten Maustaste auf den Ordner Microsoft BizTalk Server, und klicken Sie auf Properties.

    Für den Ordner wird das Dialogfeld Processing Rule Group Properties geöffnet.

  3. Klicken Sie auf die Registerkarte Computer Groups.

    Es wird eine Liste der Computergruppen angezeigt, die mit diesem Ordner verbunden sind.

  4. Falls die Liste leer ist, klicken Sie auf Add.

    Das Dialogfeld Select Item wird mit der Liste aller MOM-Computergruppen angezeigt.

  5. Wählen Sie Microsoft BizTalk Server 2002 Enterprise Edition aus.

    Klicken Sie auf OK, um das Dialogfeld Select Item zu schließen.

  6. Klicken Sie auf OK, um das Dialogfeld Properties zu schließen.

Erstellen der MOM-Regel "Alert Processing"

  1. Erweitern Sie in MOM Administrator Console die Ordner Rules, Processing_Rule_Groups und Microsoft BizTalk Server.

  2. Klicken Sie mit der rechten Maustaste auf Performance Processing Rules, zeigen Sie auf New, und klicken Sie dann auf Performance Processing Rule.

    Das Dialogfeld Performance Processing Rule Type wird angezeigt.

  3. Markieren Sie Compare Performance Data (Threshold).

  4. Klicken Sie auf Weiter.

    Das Dialogfeld Threshold Processing Rule Properties –Data Provider wird angezeigt.

  5. Klicken Sie auf New, um einen neuen Datenprovider zu erstellen.

    Das Dialogfeld Select Provider Type wird angezeigt.

  6. Markieren Sie WMI Numeric Event, und klicken Sie auf OK.

    Das Dialogfeld WMI Numeric Provider Properties wird angezeigt.

  7. Geben Sie Daten in den folgenden Felder ein:
    • Provider name: Custom Counter for CommonInvoice Documents

    • WMI Namespace: root\MicrosoftBiztalkServer

    • Class of Object to be measured: MSBTS_CustomCounter

    • Object Instance Expression: Name = "Custom Counter for CommonInvoice Documents"

    • Numeric property to sample: MatchCount

    • Text Property to be Instances: Name

    • Sample Every: 10 Seconds

Anmerkung

  • Das Ändern des Stichprobenintervalls auf einen kleineren Wert kann sich auf das Leistungsverhalten des Computers, der als MOM Consolidator verwendet wird, und des Computer mit dem MOM Agents auswirken.
  8. Klicken Sie auf Weiter.

  9. Lassen Sie das Kontrollkästchen Synchronize at deaktiviert, und klicken Sie auf Finish, um das Dialogfeld zu schließen.

  10. Klicken Sie im Dialogfeld Threshold Processing Rule Properties auf Next.

  11. Übernehmen Sie den Standardwert always process data auf der Seite specify optional schedule, und klicken Sie auf Next.

  12. Übernehmen Sie die Standardeinstellung (kein Kontrollkästchen ist aktiviert) auf der Seite select the properties you would like to match, und klicken Sie auf Next.

  13. Übernehmen Sie die Standardeinstellung auf der Seite Specify the threshold value you would like to match.

    Dies bewirkt, dass das MOM-System eine Warnung generiert, wenn der Zähler größer als 0 ist.

  14. Klicken Sie auf Weiter.

  15. Wählen Sie auf der Seite Specify whether a match to this rule generates an alert die Option Generate Alert; Klicken Sie in der Liste Alert Severity auf Success, und geben Sie im Textfeld Owner den Begriff E-Procurement Sample ein. Übernehmen Sie in allen anderen Feldern die Standardwerte.

  16. Klicken Sie auf Weiter.

  17. Deaktivieren Sie auf der Seite Define the handling of duplicate alerts das Kontrollkästchen suppress duplicate alerts, falls immer dann eine Warnung angezeigt werden soll, wenn die Bedingung erfüllt ist. Andernfalls wird nur eine Warnung angezeigt.

  18. Klicken Sie auf Weiter.

  19. Klicken Sie auf der Seite Define any response action auf Next.

  20. Klicken Sie auf der Seite Company Knowledge Base auf Next.

  21. Übernehmen Sie auf der Seite Specify the Comments for the Knowledge Base Entry die Standardwerte, und klicken Sie auf Next. Beachten Sie, dass diese Seite nur zur Verfügung steht, wenn eine MOM Knowledge Authorizing License installiert ist.

  22. Übernehmen Sie auf der Seite Specify the advanced setting properties die Standardwerte, und klicken Sie auf Next. Beachten Sie, dass diese Seite nur zur Verfügung steht, wenn eine MOM Knowledge Authorizing License installiert ist.

  23. Geben Sie auf der Seite Enter a name for the processing rule die Worte eProcurement-CustomCounter for CommonInvoice ein, und klicken Sie auf Finish.

Weiter mit Verteilen der Regeln an den Agent


Verteilen der Regeln an den Agent

BizTalk Server 2002 ~ Beispiel für die elektronische Beschaffung (E-Procurement)

Verteilen der Regeln an den Agent

Zu diesem Zeitpunkt werden die Regeln zwar aktualisiert, nicht jedoch auf den MOM Agents zur Verarbeitung veröffentlicht. Um die Regeln an den Agent zu verteilen, klicken Sie in der MOM-Konsole mit der rechten Maustaste auf Rules, und klicken Sie dann auf Commit Configuration Changes. Es kann einige Minuten dauern, bis das MOM-System die Regeln an die Agents übergibt.

Weiter mit Lesen der Ergebnisse in MOM.


Lesen der Ergebnisse in MOM

BizTalk Server 2002 ~ Beispiel für die elektronische Beschaffung (E-Procurement)

Lesen der Ergebnisse in MOM

Bei jeder Ausführung des Beispielskripts für die elektronische Beschaffung wird ein CommonInvoice-Dokument im Hubablaufplan generiert. Wenn Sie z. B. DocumentGenerator.vbs drei Mal in rascher Folge ausführen, werden die MOM Agents eine Stichprobe des CustomCounter-Wertes entnehmen und eine Warnung ausgeben.

Um diese Warnung anzuzeigen, erweitern Sie den Ordner Monitor in der MOM-Konsole, und wählen Sie die Option all open alerts aus. Es sollte mindestens eine Warnung mit einem grünen Häkchen und dem Schweregrad Success vorhanden sein. In der Owner-Spalte sollte e-procurement sample angezeigt werden.


BizTalkServer2002-Verwaltung

BizTalk Server 2002 ~ Verwaltung

BizTalk Server 2002-Verwaltung

Die Microsoft® BizTalk™ Server 2002-Verwaltung ist in die folgenden Bereiche unterteilt:

Installieren von BizTalk Server 2002

Dieser Abschnitt stellt Informationen zum Installieren von BizTalk Server 2002 bereit. Die Informationen enthalten Richtlinien für die Hardware- und Softwareanforderungen und Anweisungen für die Installationsvarianten Vollständig, Tools oder Benutzerdefiniert. Weitere Informationen finden Sie unter Installieren von BizTalk Server 2002.

Grundlegendes zur Sicherheit

Dieser Abschnitt behandelt den sicheren Datenaustausch von Unternehmen mit Handelspartnern bei der Verwendung von BizTalk Server 2002. BizTalk Server nutzt die Sicherheitsfeatures von Microsoft Windows® 2000. Weitere Informationen finden Sie unter Grundlegendes zur Sicherheit.

Verbessern von Leistung und Skalierbarkeit

Dieser Abschnitt stellt Informationen zum Verbessern der Leistung von BizTalk Server und zum Erstellen von skalierbaren Lösungen bereit. Die in diesem Abschnitt behandelten Probleme und Richtlinien umfassen das Identifizieren möglicher Engpässe, das Behandeln von Wartezeiten und das Verwalten von Datenbanken. Weitere Informationen zum Erstellen von skalierbaren, leistungsfähigen Lösungen finden Sie unter Verbessern von Leistung und Skalierbarkeit.

Verwalten von Servern und Anwendungen

Dieser Abschnitt behandelt das Verwalten von Servern und XLANG-verwandten Anwendungen. Die in diesem Abschnitt behandelten Themen enthalten das zentrale Konfigurieren und Verwalten von Servern in mehreren Gruppen, das Konfigurieren und Verwalten von Empfangsfunktionen, das Verwalten der gemeinsam genutzten Warteschlange sowie der COM+-Anwendungen, die als Host für XLANG-Ablaufpläne dienen. Weitere Informationen finden Sie unter Verwalten von Servern und Anwendungen.

Überwachen von Dokumenten

Dieser Abschnitt stellt Informationen zum Überwachen von Austauschvorgängen und Dokumenten bereit, die von BizTalk Server 2002 verarbeitet werden. Die in diesem Abschnitt behandelten Themen umfassen das Erstellen von Abfragen und erweiterten Abfragen, das Sichern von Austausch- und Dokumentdaten und Daten der benutzerdefinierten Suche. Außerdem wird Grundlegendes zu den Ergebnissen von Austauschdatensätzen, Dokumentdatensätzen und zu Empfangsbestätigungen behandelt. Weitere Informationen finden Sie unter Überwachen von Dokumenten.

Überwachen von Dokumenten

Dieser Abschnitt stellt Informationen zum BizTalk Server 2002 Enterprise Edition Management Pack für Microsoft Operations Manager (MOM) bereit. Zu diesen Informationen gehören Leistungsindikatoren, Microsoft Windows NT®-Ereignisregeln, vom Benutzer konfigurierte Regeln und in diesem Management Pack enthaltene Ansichten zur Steigerung der MOM-Kapazitäten durch das Überwachen spezieller BizTalk Server-Ereignisse. Weitere Informationen finden Sie unter Überwachen von Dokumenten.

Anmerkung

  • Der Dateipfad zum Öffnen der verschiedenen Dienste und Tools von Windows 2000, beispielsweise der Komponentendienste und der Verwaltung, hängt davon ab, ob der verwendete Computer unter Windows 2000 Server oder Windows 2000 Professional ausgeführt wird. Weitere Informationen finden Sie unter Öffnen der Komponentendienste.

    In der Microsoft BizTalk Server 2002-Hilfe wurden die Pfade zu diesen Diensten und Tools auf der Basis einer Installation von Windows 2000 Server dokumentiert. Beim Verwenden von Windows 2000 Professional finden Sie in der Windows 2000 Professional-Hilfe weitere Informationen zum Öffnen des von Ihnen benötigten/gewünschten Dienstes oder Tools.

Verwandtes Thema

BizTalk Server-Verwaltungsmodell


Installieren von BizTalk Server2002

BizTalk Server 2002 ~ Installation

Installieren von BizTalk Server 2002

Willkommen beim Microsoft® BizTalk™ Server 2002-Installationshandbuch. Dieses Handbuch stellt Informationen zu Hardware- und Softwareanforderungen sowie vollständige Anweisungen für die folgenden Installationsoptionen bereit:

  • Vollständige Installation. Ermöglicht die Ausführung einer vollständigen Installation von BizTalk Server 2002, einschließlich sämtlicher BizTalk-Dienste, -Tools und -Beispiele.

  • Toolsinstallation. Ermöglicht die Ausführung einer vollständigen Installation der BizTalk Server 2002-Tools, einschließlich des BizTalk-Orchestrierungs-Designers, des BizTalk-Editors, des BizTalk-Mappers, des MMC-Snap-Ins (Microsoft Management Console) BizTalk Server-Verwaltung und der BizTalk Server 2002-Hilfe. Der Parser von BizTalk Server 2002, die Serialisierungskomponente, die Korrelationskomponente und die Laufzeitbinärdateien werden nicht installiert.

  • Benutzerdefinierte Installation. Ermöglicht die Ausführung einer benutzerdefinierten Installation mit jeder beliebigen Kombination von BizTalk Server 2002-Diensten und -Tools.

  • Aktualisierungsinstallation. Ermöglicht die Aktualisierung von den BizTalk Server 2000-Tools und -Diensten auf die BizTalk Server 2002-Tools und -Dienste.

  • Unbeaufsichtigte Installation. Ermöglicht die unbeaufsichtigte Installation von BizTalk Server 2002 durch Festlegen von Eigenschaftenwerten in der Befehlszeile.

  • Entfernen von BizTalk Server 2002. Ermöglicht die Deinstallation von BizTalk Server 2002

In diesem Handbuch werden folgende Themen behandelt:

  • Installationscheckliste

  • Hardware- und Softwareanforderungen

  • Installationsanweisungen


Installationscheckliste

Diese Checkliste beschreibt die Schritte zum Einrichten einer vollständigen Installation von Microsoft® BizTalk™ Server 2002 und aller zugehörigen Komponenten. In jedem Schritt werden Sie auf Anweisungen verwiesen, die zum Fertigstellen des Schrittes notwendig sind. Es empfiehlt sich, diese Checkliste als Nachschlagewerk für die Installation auszudrucken.

Schritt | Referenz
Überprüfen der Hardwareanforderungen. | Minimale Hardwareanforderungen
Überprüfen der Softwareanforderungen. | Softwareanforderungen
Nachlesen der neusten Entwicklungen in der Infodatei. | Die Infodatei befindet sich im Stammverzeichnis der BizTalk Server-Installations-CD.
Installieren des Betriebssystems Microsoft Windows® 2000. | Windows 2000-Vorbereitungen und Installationsanforderungen
Installieren von Microsoft Message Queuing. | Installieren der Message Queuing-Dienste
Installieren der Internet-Informationsdienste (IIS). | Installieren der Internet-Informationsdienste (IIS)
Konfigurieren der Internet-Informationsdienste. | Konfigurieren von IIS-Einstellungen für BizTalk Server 2002
Installieren von Windows 2000 Service Pack. | Installieren von Windows 2000 Service Pack 2
Hinzufügen Ihres Benutzerkontos zur Windows 2000-Administratorengruppe und Erstellen eines BizTalk Server-Dienstkontos. | Einrichten eines Dienstkontos
Installieren von Microsoft SQL Server™. | SQL Server-Vorbereitungen und Installationsanforderungen
Installieren von SQL Server Service Pack. | Installieren des Service Packs für SQL Server
Überprüfen der Ausführung von SQL Server. | Überprüfen der Ausführung von SQL Server
Hinzufügen eines SQL Server-Anmeldekontos (bei Remoteinstallation von SQL Server). | Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken
Installieren von Microsoft Visio® 2002. | Installieren von Visio 2002
Installieren von Microsoft Application Center 2000 SP1. | Installieren von Application Center 2000
Installieren von BizTalk Server 2002. | Installationsanweisungen
Einrichten Sie von Remotedatenbank-Rechten, wenn SQL Server auf einem Remotecomputer installiert ist. | Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken
Konfigurieren der COM+-Anwendungen, so dass sie nicht als Interaktiver Benutzer ausgeführt werden. | Ändern der Anwendungsidentität einer COM+-Anwendung
Starten des WWW-Publishingdienstes. | Starten des WWW-Publishingdienstes
Konfigurieren von Internet Explorer für die BizTalk-Dokumentüberwachung. | Konfigurieren der BizTalk-Dokumentüberwachung


Hardware- und Softwareanforderungen

Dieser Abschnitt enthält Informationen zu den minimalen Hardwareanforderungen sowie den Konfigurationsoptionen für die Installation von Microsoft BizTalk Server 2002. Außerdem werden die Installationsanweisungen der für BizTalk Server 2002 erforderlichen Software beschrieben.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Minimale Hardwareanforderungen

  • Empfohlene Konfiguration für optimale Leistung beim Dokumentmessaging

  • Softwareanforderungen

  • Windows 2000-Vorbereitungen und Installationsanforderungen

  • SQL Server-Vorbereitungen und Installationsanforderungen

  • Installieren von Visio 2002

  • Installieren von Application Center 2000


Minimale Hardwareanforderungen

Die folgenden Hardwareanforderungen müssen mindestens erfüllt sein, damit eine vollständige Installation von Microsoft BizTalk Server 2002 ausgeführt werden kann:

  • Intel® Pentium®-kompatible CPU mit 400 Megahertz oder höher

  • 256 Megabyte RAM

  • 6-Gigabyte-Festplatte

  • CD-ROM-Laufwerk

  • Netzwerkkarte

  • VGA- oder Super-VGA-Monitor

  • Microsoft Maus oder kompatibles Zeigegerät

Anmerkung

  • Während der Installation von BizTalk Server 2002 ermittelt das Installationsprogramm den verfügbaren Festplattenspeicher auf Ihrem Computer. Für eine vollständige Installation sind ca. 52 Megabyte (MB) Festplattenspeicher erforderlich, wobei die Anforderungen für die BizTalk-Messaging-Verwaltungsdatenbank, die Überwachungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen und die Persistenzdatenbank für die Orchestrierung noch nicht berücksichtigt sind. Eine Toolsinstallation erfordert ca. 30 MB Festplattenspeicher. Für eine benutzerdefinierte Installation sind (ausschließlich Datenbankanforderungen) zwischen 2 und 52 MB Festplattenspeicher erforderlich, abhängig von den Diensten und Tools, die installiert werden.


Empfohlene Konfiguration für optimale Leistung beim Dokumentmessaging

Die folgenden Richtlinien helfen Ihnen, Microsoft BizTalk Server 2002 optimal zu konfigurieren:

  • Erstellen Sie eine Konfiguration mit drei Computern. Auf dem ersten Computer installieren Sie BizTalk Server 2002, auf dem zweiten die Überwachungsdatenbank und auf dem dritten die BizTalk-Messaging-Verwaltungsdatenbank sowie die Datenbank für gemeinsam genutzte Warteschlangen.

  • Anstatt sämtliche Verarbeitungs- und Empfangsfunktionen von einem einzelnen Server ausführen zu lassen, können Sie zwei Server mit BizTalk Server 2002 konfigurieren, von denen einer die Verarbeitung und der andere den Empfang übernimmt, und so die Leistung verbessern.

  • Installieren Sie die Überwachungsdatenbank auf einem Computer mit mehreren physischen Festplatten. Die optimale Konfiguration umfasst vier SCSI II-Festplatten und einen SCSI II-Controller. Die erste Festplatte speichert die Dokumentüberwachung. Die zweite Festplatte speichert die Microsoft Windows® 2000-Auslagerungsdatei. Die dritte Festplatte speichert das Protokoll für die Überwachung von Transaktionen und die vierte das DTC-Protokoll (Distributed Transaction Coordinator).

  • Erstellen Sie mehrere Instanzen von Empfangsfunktionen, um mehrere Empfangsstandorte für die zu verarbeitenden Dokumente überwachen zu können. Um die Dokumentauslastung auf verschiedene Computer zu verteilen, speichern Sie die Empfangsfunktionen auf separaten Computern. Jeder Überwachungsstandort muss eindeutig sein und über eine eigene Empfangsfunktion verfügen. Um die Überlastung einer einzelnen Empfangsfunktion zu vermeiden, sollte die Geschäftsanwendung, die Dokumente ausgibt, diese Dokumente gleichmäßig auf alle Überwachungsstandorte verteilen.

Wichtig

  • Installieren Sie den BizTalk-Messaging-Manager, die Internet-Informationsdienste (IIS) und die BizTalk Server-Konfigurationsdatenbank nicht auf drei separaten Computern. Bei diesem Konfigurationstyp treten Authentifizierungsprobleme auf. Weitere Informationen finden Sie unter Authentifizierungsprobleme treten auf, wenn IIS, der BizTalk-Messaging-Manager und SQL Server auf drei verschiedenen Computern ausgeführt werden.

  • Weitere Informationen zur Verbesserung der Leistung von BizTalk Server finden Sie unter Verbessern von Leistung und Skalierbarkeit.


Softwareanforderungen

In der folgenden Tabelle wird die Software aufgelistet, die installiert sein muss, damit Microsoft BizTalk Server 2002 ausgeführt werden kann.

Vollständige Installation | Toolsinstallation | Benutzerdefinierte Installation
Microsoft Windows 2000 mit Service Pack 2 (SP2)* und dem NTFS-Dateisystem | Microsoft Windows 2000 mit Service Pack 2 (SP2)* und dem NTFS-Dateisystem bzw. Windows XP Professional oder höher | Microsoft Windows 2000 mit Service Pack 2 (SP2)* und dem NTFS-Dateisystem
Microsoft Internet Explorer 5.5 oder höher | Microsoft Internet Explorer 5.5 oder höher | Microsoft Internet Explorer 5.5 oder höher
Microsoft Visio® 2002 (für die Verwendung des BizTalk-Orchestrierungs-Designers erforderlich) | Microsoft Visio® 2002 (für die Verwendung des BizTalk-Orchestrierungs-Designers erforderlich) | Microsoft Visio® 2002 (für die Verwendung des BizTalk-Orchestrierungs-Designers erforderlich)
Microsoft SQL Server 7.0 mit SQL Server Service Pack 3 (SP3) oder SQL Server 2000 SP1 | Microsoft SQL Server 7.0 mit SQL Server Service Pack 3 (SP3) oder SQL Server 2000 SP1
Anmerkung
  • BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ebenfalls ausgeführt wird.
 Anmerkung
  • BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ebenfalls ausgeführt wird.
 Anmerkung
  • BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ebenfalls ausgeführt wird.

*Zum Installieren von BizTalk Server 2002 muss die Windows 2000-Systemkonsole verwendet werden. Die Installation von BizTalk Server mithilfe der Terminaldienste wird nicht unterstützt.

Anmerkungen

  • Microsoft SQL Server ist für eine benutzerdefinierte Installation nur erforderlich, wenn Sie die Hauptdienste von BizTalk installieren. Für eine Toolsinstallation ist dieses Programm nicht erforderlich.

  • Microsoft Application Center 2000 mit SP1 ist nur erforderlich, wenn Sie von den Bereitstellungsfunktionen von BizTalk Server 2002 profitieren möchten. Weitere Informationen finden Sie unter Installieren von Application Center 2000.

  • Microsoft Operations Manager 2000 (MOM) ist nur erforderlich, wenn Sie BizTalk Server 2002 Management Pack installieren, um die erweiterten Überwachungsfunktionen zu nutzen. Weitere Informationen über den BizTalk Server 2002 Management Pack finden Sie unter Importieren des BizTalk Server 2002 Management Pack.


Windows2000-Vorbereitungen und Installationsanforderungen

BizTalk Server 2002 ~ Installation

Windows 2000-Vorbereitungen und Installationsanforderungen

Microsoft Windows 2000 Service Pack 2 (SP2) ist für alle Microsoft BizTalk Server 2002-Installationen erforderlich. Da BizTalk Server 2002 unter Windows 2000 SP2 ausführlich getestet wurde, enthält dieses Installationshandbuch detaillierte Konfigurationsinformationen für Windows 2000 Server, Windows 2000 Advanced Server und Windows 2000 Professional in Verbindung mit BizTalk Server. Sie müssen außerdem Message Queuing und die Internet-Informationsdienste (IIS) mit Ihrer Windows 2000-Installation installieren. Weitere Informationen finden Sie unter Installieren der Message Queuing-Dienste und Installieren der Internet-Informationsdienste (IIS). Enthält Ihre Windows 2000-Installation nicht Service Pack 2, müssen Sie dieses ebenfalls installieren. Weitere Informationen finden Sie unter Installieren von Windows 2000 Service Pack 2.

Nach der Installation von Windows 2000 müssen Sie ein Windows 2000-Benutzerkonto zur Administratorengruppe hinzufügen, bevor Sie weitere Software installieren.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Installieren von Windows 2000 Server, Advanced Server oder Professional

  • Installieren der Message Queuing-Dienste

  • Installieren der Internet-Informationsdienste (IIS)

  • Konfigurieren von IIS-Einstellungen für BizTalk Server 2002

  • Installieren von Windows 2000 Service Pack 2

  • Einrichten eines Dienstkontos


Installieren von Windows2000 Server, Advanced Server oder Professional

BizTalk Server 2002 ~ Installation

Installieren von Windows 2000 Server, Advanced Server oder Professional

Ist Windows 2000 Server, Advanced Server oder Professional bereits auf Ihrem Computer installiert, überprüfen Sie, ob die in diesem Thema beschriebenen Anforderungen erfüllt sind.

Ist Windows 2000 noch nicht auf Ihrem Computer installiert, legen Sie die Windows 2000-CD in das CD-ROM-Laufwerk ein, und folgen Sie den Anweisungen auf dem Bildschirm. Der Setup-Assistent führt Sie durch die Schritte zum Installieren von Windows 2000.

Beachten Sie dabei Folgendes:

  • Der Computername darf nur aus alphanumerischen Zeichen bestehen, da Microsoft SQL Server einen eingeschränkten Zeichensatz in Servercomputernamen unterstützt.

  • Formatieren Sie die Partition mit dem NTFS-Dateisystem.

  • Klicken Sie auf der Seite Windows 2000-Komponenten in der Liste Komponenten auf Message Queuing-Dienste. Falls Sie Windows 2000 Professional installieren, klicken Sie auf Internet-Informationsdienste (IIS) und dann auf Weiter. Klicken Sie auf der Seite Message Queue-Installationstyp auf Weiter.

  • Klicken Sie auf der Seite Netzwerkeinstellungen auf Standardeinstellungen.

Anmerkungen

  • Wenn Sie Message Queuing-Dienste auf der Seite Windows 2000-Komponenten während der Installation nicht ausgewählt haben, müssen Sie diese vor der Installation von Windows 2000 Service Pack installieren. Weitere Informationen finden Sie unter Installieren der Message Queuing-Dienste.

  • Wenn Sie Internet-Informationsdienste (IIS) auf der Seite Windows 2000-Komponenten während der Installation nicht ausgewählt haben, müssen Sie diese vor der Installation von Windows 2000 Service Pack installieren. Weitere Informationen finden Sie unter Installieren der Internet-Informationsdienste (IIS).

  • Enthält Ihre Installation Service Pack 2 nicht, müssen Sie dieses ebenfalls installieren. Weitere Informationen finden Sie unter Installieren von Windows 2000 Service Pack 2.

  • Die Windows 2000-Partition muss in die neueste NTFS-Version konvertiert werden. Das Installationsprogramm führt diese Aktualisierung automatisch durch, falls es sich bei dem vorhandenen Dateisystem um eine alte Version von NTFS handelt. Handelt es sich bei der vorhandenen Partition um FAT oder FAT32, haben Sie die Möglichkeit, diese in NTFS zu konvertieren. Wählen Sie NTFS aus, wenn Sie dazu aufgefordert werden.

  • Nach der Installation von Windows 2000 Server, Advanced Server oder Professional müssen Sie zur Administratorengruppe ein Windows 2000-Benutzerkonto zur Administratorengruppe hinzufügen, bevor Sie Software installieren.


Installieren der Message Queuing-Dienste

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

    Das Dialogfeld Software wird angezeigt.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

    Der Assistent für Windows-Komponenten wird geöffnet.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Message Queuing-Dienste, und klicken Sie auf Weiter.

  5. Klicken Sie auf der Seite Message Queue-Installationstyp auf Weiter.

  6. Klicken Sie auf Fertig stellen, um den Assistenten zu schließen.

Anmerkung

  • Übernehmen Sie die Standardeinstellungen, wenn Sie die Message Queuing-Dienste installieren.


Installieren der Internet-Informationsdienste (IIS)

Anmerkungen

  • Wenn Sie Internet-Informationsdienste (IIS) auf der Seite Windows 2000-Komponenten während der Installation nicht ausgewählt haben, müssen Sie diese vor der Installation von Windows 2000 Service Pack installieren. Windows 2000 Professional installiert IIS nur dann standardmäßig, wenn Sie von einer früheren Version von Windows und Personal Web Server (PWS) auf Windows 2000 aktualisieren.

  • IIS wird standardmäßig mit Microsoft Windows 2000 Server installiert.
  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

    Das Dialogfeld Software wird angezeigt.

  3. Klicken Sie auf Windows-Komponenten hinzufügen/entfernen.

    Der Assistent für Windows-Komponenten wird geöffnet.

  4. Aktivieren Sie in der Liste Komponenten das Kontrollkästchen Internet-Informationsdienste (IIS), und klicken Sie auf Weiter.

  5. Klicken Sie auf Fertig stellen, um den Assistenten zu schließen.


Konfigurieren von IIS-Einstellungen für BizTalk Server2002

BizTalk Server 2002 ~ Installation

Konfigurieren von IIS-Einstellungen für BizTalk Server 2002

Sie müssen die Option Dokumenterstellung aktivieren der Internet-Informationsdiensten (IIS) ausschalten, um Probleme beim Zugriff auf und Speichern von Spezifikationen im BizTalk Server 2002-Repository zu vermeiden.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Internetdienste-Manager.

  2. Klicken Sie auf das Erweiterungssymbol (+) für den lokalen IIS-Server.

  3. Klicken Sie mit der rechten Maustaste auf Standardwebsite und dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Standardwebsite wird angezeigt.

  4. Klicken Sie auf die Registerkarte Servererweiterungen, und deaktivieren Sie das Kontrollkästchen Dokumenterstellung aktivieren.


Installieren von Windows2000 Service Pack2

BizTalk Server 2002 ~ Installation

Installieren von Windows 2000 Service Pack 2

  • Legen Sie die Windows 2000 SP2-CD in das CD-ROM-Laufwerk ein, und folgen Sie den Anweisungen auf dem Bildschirm.

    Über die Microsoft Windows 2000-Website (www.microsoft.com/germany/windows2000/) können Sie das Windows 2000 SP2 downloaden oder die CD bestellen.


Einrichten eines Dienstkontos

Um die verbleibende Software zu installieren, müssen Sie sicherstellen, dass das Konto, das die Installation ausführt, sich in der lokalen Windows 2000-Administratorengruppe der Server befindet, auf denen die Software installiert wird. Dies gilt auch für Remotecomputer mit SQL Server. Darüber hinaus haben Sie die Möglichkeit, ein Dienstkonto zu erstellen, an das sich der BizTalk-Messagingdienst anmelden kann. Wenn Sie sich gegen die Erstellung eines Dienstkontos entscheiden, können Sie den BizTalk-Messagingdienst während der Installation für die Ausführung als lokales System konfigurieren.

Anmerkung

  • Wenn Sie BizTalk Server und SQL Server auf zwei verschiedenen Computern installieren möchten, benötigt das BizTalk Server-Dienstkonto Zugriffsrechte für den Computer mit SQL Server. Weitere Informationen finden Sie unter Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken.
  1. Melden Sie sich als Administrator an.

  2. Zeigen Sie im Menü Start auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

    Das Dialogfeld Computerverwaltung wird angezeigt.

  3. Erweitern Sie in der Konsolenstruktur Systemprogramme, und klicken Sie auf Lokale Benutzer und Gruppen.

  4. Klicken Sie auf Benutzer, klicken Sie mit der rechten Maustaste in den Detailfensterbereich, und klicken Sie dann auf Neuer Benutzer.

    Das Dialogfeld Neuer Benutzer wird angezeigt.

  5. Geben Sie im Feld Neuer Benutzer einen Namen für das Dienstkonto ein, geben Sie im Feld Kennwort ein Kennwort ein, und geben im Feld Kennwort bestätigen dasselbe Kennwort noch einmal ein.

  6. Deaktivieren Sie das Kontrollkästchen Benutzer muss Kennwort bei der nächsten Anmeldung ändern, klicken Sie auf Erstellen und dann auf Schließen.

  7. Schließen Sie das Fenster Computerverwaltung.

  8. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Lokale Sicherheitsrichtlinie.

    Das Dialogfeld Lokale Sicherheitsrichtlinie wird angezeigt.

  9. Erweitern Sie in der Konsolenstruktur Lokale Richtlinien, und klicken Sie auf Zuweisen von Benutzerrechten.

  10. Doppelklicken Sie im Detailfensterbereich auf Einsetzen als Teil des Betriebssystems, klicken Sie auf Hinzufügen, klicken Sie im Listenfeld auf den Namen des soeben erstellten Dienstkontos, klicken Sie noch einmal auf Hinzufügen, und klicken Sie dann zweimal auf OK.

  11. Wiederholen Sie Schritt 10 für die Richtlinie Als Dienst anmelden.

    Wichtig

    • Diese Richtlinien treten erst nach einem Computerneustart in Kraft.

Wenn BizTalk Server 2002 bereits installiert ist und ein Konto verwendet, das zur Administratorengruppe gehört, führen Sie nach der Erstellung eines Dienstkontos die folgenden Schritte aus.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Dienste.

  2. Doppelklicken Sie im Detailfensterbereich auf BizTalk-Messagingdienst.

    Das Dialogfeld Eigenschaften von BizTalk-Messagingdienst (Lokaler Computer) wird angezeigt.

  3. Klicken Sie auf die Registerkarte Anmelden und dann auf Dieses Konto.

  4. Klicken Sie auf Durchsuchen, suchen Sie nach dem Namen des von Ihnen erstellten Dienstkontos, und doppelklicken Sie darauf.

  5. Geben Sie im Feld Kennwort dasselbe Kennwort ein, das Sie dem Dienstkonto zugewiesen haben, geben Sie im Feld Kennwort bestätigen das Kennwort noch einmal ein, und klicken Sie dann auf OK.

  6. Klicken Sie in dem daraufhin angezeigten Meldungsfeld auf OK.

  7. Starten Sie den Computer neu.


SQLServer-Vorbereitungen und Installationsanforderungen

BizTalk Server 2002 ~ Installation

SQL Server-Vorbereitungen und Installationsanforderungen

Bevor Sie Microsoft BizTalk Server 2002 installieren, müssen Sie zuerst Microsoft SQL Server 7.0 mit Service Pack 3 (SP3) oder Microsoft SQL Server 2000 mit Service Pack 1 (SP1) installieren. Wenn Sie BizTalk Server 2002 installieren, erstellt der Installationsvorgang vier BizTalk Server 2002-Datenbanken in SQL Server (die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die Persistenzdatenbank für die Orchestrierung).

Wichtig

  • Wenn Sie beabsichtigen, BizTalk Server 2002 auf einem Computer unter Microsoft Windows 2000 Professional zu installieren, müssen Sie die Standard oder Enterprise Edition von SQL Server auf einem separaten Computer installieren. Beim Installieren der Datenbanken für BizTalk Server 2002 müssen Sie den Namen des Computers angeben, auf dem SQL Server installiert ist. Die Standard und Enterprise Edition von SQL Server kann nicht unter Windows 2000 Professional installiert werden.

  • Wenn Sie BizTalk Server und SQL Server auf zwei verschiedenen Computern installieren möchten, benötigen Ihr Anmeldekonto und das BizTalk Server-Dienstkonto Systemadministratorrechte für den Zugriff auf den Computer mit SQL Server. Weitere Informationen finden Sie unter Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken.

Standardmäßig wird der Authentifizierungsmodus während der SQL Server 2000-Installation auf Nur Windows festgelegt. BizTalk Server 2002 verwendet die Windows-Authentifizierung für den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die BizTalk-Dokumentüberwachung-Webanwendung. Stellen Sie sicher, dass der SQL Server-Authentifizierungsmodus in Windows festgelegt wurde, bevor Sie BizTalk Server 2002 installieren. Weitere Informationen finden Sie unter Festlegen des SQL-Authentifizierungsmodus für SQL Server 2000.

Bei einem Cluster handelt es sich um eine Sammlung von Servern, die als ein einziger Server agieren. Wenn SQL Server auf einem Cluster installiert wurde und BizTalk Server 2002 auf einem anderen Computer installiert werden soll, müssen Sie die SQL Server-Clienttools auf dem Computer mit BizTalk Server 2002 installieren. Weitere Informationen finden Sie unter Installieren der SQL Server-Clienttools. Nach Abschluss der Toolsinstallation müssen Sie die SQL Server-Clientkonfiguration verwenden, um die Standard-Netzwerkbibliothek von Named Pipes in TCP/IP zu ändern. Weitere Informationen finden Sie unter Ändern der Standard-Netzwerkbibliothek in TCP/IP.

Internationales Problem

  • Bei der Installation von SQL Server ist es wichtig, die richtigen Sortierungseinstellungen zu verwenden. "Sortierung" verweist auf eine Gruppe von Regeln, die ermittelt, wie Daten sortiert und verglichen werden. Zeichendaten werden mithilfe von Regeln sortiert, die die korrekte Zeichenreihenfolge definieren, wobei angegeben werden kann, dass in Bezug auf Groß-/Kleinschreibung, Akzente, Kanazeichentypen und Zeichenbreite unterschieden werden soll. Um beispielsweise japanische Zeichen zu speichern, wählen Sie eine Sortierreihenfolge aus, bei der die Groß-/Kleinschreibung beachtet wird, um bei der Einrichtung von SQL Server zwischen Hiraganazeichen und Katakanazeichen zu unterscheiden. Weitere Informationen zu Sortierungseinstellungen erhalten Sie, indem Sie im Startmenü auf Programme zeigen, dann auf Microsoft SQL Server zeigen und anschließend auf Onlinedokumentation klicken. Unter den Themen "Verwenden von SQL-Sortierungen" und "Sortierarten für Windows-Sortierung" finden Sie zusätzliche Information.

Wenn SQL Server für die Verwendung auf die binäre Sortierreihenfolge festgelegt ist, werden Groß- und Kleinschreibung unterschieden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Installieren von SQL Server 7.0 oder SQL Server 2000

  • Suchen nach SQL Server Service Pack 2

  • Installieren des Service Packs für SQL Server

  • Installieren der SQL Server-Clienttools

  • Ändern der Standard-Netzwerkbibliothek in TCP/IP

  • Festlegen des SQL-Authentifizierungsmodus für SQL Server 2000

  • Überprüfen der Ausführung von SQL Server

  • Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken


Installieren von SQLServer7.0 oder SQLServer2000

BizTalk Server 2002 ~ Installation

Installieren von SQL Server 7.0 oder SQL Server 2000

Legen Sie zum Installieren von SQL Server die Microsoft SQL Server-CD in das CD-ROM-Laufwerk ein, und folgen Sie den Anweisungen auf dem Bildschirm. Der Setup-Assistent führt Sie durch die Schritte zum Installieren von SQL Server.

Beachten Sie dabei Folgendes:

  • Klicken Sie auf der Seite Setup-Typ auf Standard.

  • Verwenden Sie auf der Seite Dienstkonten ein Domänenbenutzerkonto (falls eine Verbindung zu einem Netzwerk besteht).

  • Geben Sie bei der Installation von SQL Server 2000 die Windows-Authentifizierung an.

Wichtig

  • Nach der Installation von SQL Server müssen Sie das neueste SQL Server Service Pack installieren. Mithilfe von Query Analyzer können Sie feststellen, ob das neuste Service Pack installiert ist. Weitere Informationen finden Sie unter Suchen nach SQL Server Service Pack. Weitere Informationen zum Installieren von SQL Server Service Packs finden Sie unter Installieren des Service Packs für SQL Server.


Suchen nach SQL Server Service Pack

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Query Analyzer.

    Das Dialogfeld Verbindung mit SQL Server herstellen wird angezeigt.

  2. Klicken Sie auf OK.

    Wird der Servername in der Liste SQL Server nicht angezeigt, geben Sie ihn ein, und klicken Sie anschließend auf OK.

  3. Geben Sie SELECT @@VERSION im Feld Abfrage ein.

  4. Klicken Sie im Menü Abfrage auf Ausführen.

    Die erste Zeile des Abfrageergebnisses enthält die aktuell ausgeführte Version von SQL Server.


Installieren des Service Packs für SQL Server

  1. Legen Sie die SQL Server Service Pack 2-CD in das CD-ROM-Laufwerk ein.

  2. Führen Sie das Installationsprogramm für das SQL Server Service Pack 2 aus, und folgen Sie den Anweisungen auf dem Bildschirm.

    Über die Microsoft SQL Server-Website (www.microsoft.com/germany/sql/) können Sie die Service Packs für SQL Server downloaden oder die CD bestellen.


Installieren der SQLServer-Clienttools

BizTalk Server 2002 ~ Installation

Installieren der SQL Server-Clienttools

Wichtig

  • Wenn Sie sich in einer Clusterumgebung befinden und SQL Server und BizTalk Server auf zwei unterschiedlichen Computern installiert wurden, müssen Sie die SQL Server-Clienttools auf dem Computer mit BizTalk Server 2002 installieren.

Legen Sie zum Installieren der SQL Server-Clienttools die Microsoft SQL Server-CD in das CD-ROM-Laufwerk ein, und folgen Sie den Anweisungen auf dem Bildschirm. Der Setup-Assistent führt Sie durch die Schritte zum Installieren von SQL Server.

Beachten Sie dabei Folgendes:

  • Klicken Sie auf der Seite Installationsauswahl auf Eine neue Instanz von SQL Server erstellen oder Clienttools installieren.

  • Klicken Sie auf der Seite Installationsdefinition auf Nur Clienttools.


Ändern der Standard-Netzwerkbibliothek in TCP/IP

Wenn Sie SQL Server-Clienttools installieren, installiert das Installationsprogramm für SQL Server Named Pipes als Standard-Clientnetzwerkbibliothek. BizTalk Server kommuniziert über TCP/IP mit SQL Server. Sie müssen deshalb die Standard-Netzwerkbibliothek in TCP/IP ändern.

So ändern Sie die Standard-Netzwerkbibliothek in SQL Server 7.0

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server 7.0, und klicken Sie dann auf SQL Server-Clientkonfiguration.

    Das Dialogfeld SQL Server-Clientkonfiguration wird angezeigt.

  2. Wählen Sie auf der Registerkarte Allgemein die Option TCP/IP aus der Liste Standard-Netzwerkbibliothek.

  3. Klicken Sie auf OK.

So ändern Sie die Standard-Netzwerkbibliothek in SQL Server 2000

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf SQL Server-Clientkonfiguration.

  2. Überprüfen Sie auf der Registerkarte Allgemein, dass TCP/IP in der Liste Aktivierte Protokolle in Reihenfolge enthalten ist, und klicken Sie dann auf den Aufwärtspfeil, um TCP/IP an die erste Stelle der Protokollliste zu verschieben.


Festlegen des SQL-Authentifizierungsmodus für SQLServer2000

BizTalk Server 2002 ~ Installation

Festlegen des SQL-Authentifizierungsmodus für SQL Server 2000

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Server und anschließend SQL Server-Gruppe.

  3. Klicken Sie mit der rechten Maustaste auf den Namen des Servers, und klicken Sie auf Eigenschaften.

    Das Dialogfeld SQL Server-Eigenschaften (Konfigurieren) - <Servername> wird angezeigt.

  4. Klicken Sie auf die Registerkarte Sicherheit, klicken Sie auf Nur Windows, und klicken Sie dann auf OK.


Überprüfen der Ausführung von SQLServer

BizTalk Server 2002 ~ Installation

Überprüfen der Ausführung von SQL Server

Vor der Installation von BizTalk Server 2002 müssen Sie überprüfen, ob SQL Server auf dem Server ausgeführt wird. Dies ist notwendig, da BizTalk Server 2002 während der Installation vier SQL-Datenbanken erstellt.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server (wenn Sie SQL Server 2000 installiert haben) oder Microsoft SQL Server 7.0 (wenn Sie SQL Server 7.0 installiert haben), und klicken Sie dann auf Dienst-Manager.

    Das Dialogfeld SQL Server-Dienst-Manager wird angezeigt.

  2. Überprüfen Sie in der Liste Server, ob es sich bei dem Namen des Servers um den Namen Ihres Computers handelt.

    Ist dies nicht der Fall, klicken Sie auf den nach unten zeigenden Pfeil, um eine Liste aller verfügbaren Server anzuzeigen, und suchen Sie nach dem entsprechenden Server.

  3. Klicken Sie in der Liste Dienste auf MSSQLServer (für SQL Server 7.0) oder SQL Server (für SQL Server 2000).

  4. Stellen Sie sicher, dass der MSSQLServer- bzw. der SQL Server-Dienst ausgeführt wird.

    Der Dienst wird ausgeführt, wenn im Dialogfeld die Schaltfläche Starten/Weiter nicht verfügbar ist. Außerdem wird unten im Dialogfeld eine Meldung angezeigt, die besagt, dass der Dienst ausgeführt wird. Zum Beispiel: Wird ausgeführt - \\<Servername> - MSSQLServer.

  5. Wird der Dienst nicht ausgeführt, ist die Schaltfläche Starten/Weiter verfügbar. Klicken Sie darauf, um den Dienst zu starten.


Interaktionen zwischen SQLServer und BizTalk Server2002-Datenbanken

BizTalk Server 2002 ~ Installation

Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken

Verwenden Sie die Optionen Protokoll bei Prüfpunkt abschneiden und Automatisch verkleinern von Microsoft SQL Server, um unnötige Speicherplatzreservierungen zu vermeiden. Andernfalls können die SQL Server-Protokolle sehr viel Speicherplatz belegen. Sie müssen allerdings BizTalk Server 2002 installieren, bevor Sie dieses Verfahren durchführen können. Weitere Informationen finden Sie unter Vermeiden unnötiger Speicherplatzreservierung. Weitere Informationen zur Installation von BizTalk Server 2002 finden Sie unter Installationsanweisungen.

BizTalk Server 2002 verwendet die Windows-Authentifizierung für den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die BizTalk-Dokumentüberwachung-Webanwendung. Wenn Sie BizTalk Server und SQL Server auf zwei verschiedenen Computern installieren möchten, benötigt das verwendete Dienstkonto Administratorrechte sowohl für den Computer mit SQL Server als auch den Computer mit BizTalk Server.

Internationales Problem

  • BizTalk Server kann keine Verbindungen mit Datenbanken herstellen, die mit einer anderen Sprachversion von BizTalk Server erstellt wurden.

Die folgenden Verfahren sind erforderlich, um Rechte für Remoteinstallationen von SQL Server und Berechtigungen für die zutreffenden BizTalk Server-Datenbanken auf dem Remoteserver einzurichten

Remoteanmeldekonto für SQL Server

Anmerkung

  • Wenn sowohl SQL Server als auch BizTalk Server 2002 auf dem lokalen Computer installiert sind und das Konto für den BizTalk Server-Messagingdienst auf diesem Computer zur Administratorengruppe hinzugefügt wurde, hat dieses standardmäßig bereits Systemadministratorrechte in SQL Server, und das folgende Verfahren ist überflüssig. Wenn Sie BizTalk Server und SQL Server aber auf separaten Computern installieren, müssen Sie das folgende Verfahren durchführen, damit BizTalk Server 2002 auf SQL Server zugreifen kann.
  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Server, danach SQL Server-Gruppe, dann den Server, zu dem Sie ein SQL Server-Anmeldekonto hinzufügen möchten, und anschließend Sicherheit.

  3. Klicken Sie mit der rechten Maustaste auf Benutzernamen, und klicken Sie dann auf Neuer Benutzername.

    Das Dialogfeld SQL Server-Anmeldungseigenschaften - Neuer Benutzername wird angezeigt.

  4. Geben Sie auf der Registerkarte Allgemein im Feld Name eine Domäne und einen Windows-Kontonamen ein.

    Beispiel: <DOMÄNE>\<Dienstkonto> zum Festlegen des Namens des Kontos, unter dem die BizTalk Messagingdienste ausgeführt werden.

  5. Aktivieren Sie auf der Registerkarte Serverrollen in der Liste Serverrollen das Kontrollkästchen Systemadministratoren.

Anmerkung

  • Für das Dienstkonto zur ordnungsgemäßen Ausführung der BizTalk-Messagingdienste sind keine Administratorprivilegien erforderlich.
  6. Klicken Sie auf OK, um die Seite SQL Server-Anmeldungseigenschaften zu verlassen.

Einrichten von Rechten für die Remotedatenbank

Nach der Installation von BizTalk Server 2002 müssen Sie die Datenbanken festlegen, auf die das SQL Server-Anmeldekonto zugreifen kann. Führen Sie die folgenden Schritte aus, um dem SQL Server-Anmeldekonto Rechte an der BizTalk-Messaging-Verwaltungs-datenbank, der Datenbank für gemeinsam genutzte Warteschlangen und der Überwachungsdatenbank zu erteilen.

Anmerkung

  • Dieses Verfahren kann erst durchgeführt werden, wenn BizTalk Server installiert wurde.
  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Server, danach SQL Server-Gruppe, dann den Server, der die BizTalk Server-Datenbanken enthält, und anschließend Benutzernamen.

  3. Doppelklicken Sie im Detailfensterbereich auf das SQL Server-Anmeldekonto, das Sie für das BizTalk Server-Messagingdienstkonto erstellt haben.

    Die Seite SQL Server-Anmeldungseigenschaften wird angezeigt.

  4. Aktivieren Sie auf der Registerkarte Datenbankzugriff das Kontrollkästchen InterchangeBTM.

    Der angegebene Kontoname wird im Feld Benutzer angezeigt. Unten auf der Seite wird automatisch das Feld In Datenbankrolle zulassen angezeigt.

  5. Aktivieren Sie im Feld In Datenbankrolle zulassen die Kontrollkästchen db_owner und dta_ui_role.

  6. Wiederholen Sie Schritt 4 und 5 für die Datenbanken InterchangeDTA und InterchangeSQ. Aktivieren Sie im Feld In Datenbankrolle zulassen aber nur das Kontrollkästchen db_owner.

    Anmerkung

    • Bei der Installation erhält die BizTalk-Messaging-Verwaltungsdatenbank standardmäßig den Namen InterchangeBTM, die Überwachungsdatenbank den Namen InterchangeDTA und die Datenbank für gemeinsam genutzte Warteschlangen den Namen InterchangeSQ. Möglicherweise haben Sie diesen Datenbankobjekten während der Installation andere Namen gegeben.


Installieren von Visio2002

BizTalk Server 2002 ~ Installation

Installieren von Visio 2002

Da es sich bei dem BizTalk-Orchestrierungs-Designer um eine Benutzeroberfläche handelt, die auf Microsoft Visio 2002 basiert, muss Visio 2002 auf Ihrem Computer installiert werden, bevor Sie den BizTalk-Orchestrierungs-Designer verwenden können. Der BizTalk-Orchestrierungs-Designer wurde ausführlichen Tests mit Visio 2002 unterzogen.

Installieren von Visio 2002 Standard Edition

  1. Legen Sie die Microsoft Visio 2002-CD in das CD-ROM-Laufwerk ein.

  2. Führen Sie das Installationsprogramm von Visio 2002 aus, und folgen Sie den Anweisungen auf dem Bildschirm.

Weitere Informationen finden Sie in der Dokumentation zu Microsoft Visio 2002.

Internationales Problem

  • In einigen Sprachen werden bestimmte Zeichen möglicherweise im BizTalk-Orchestrierungs-Designer nicht richtig angezeigt. Sie können diesen Fehler beheben, indem Sie festlegen, dass Microsoft Visio 2002 immer die Standardschriftart des Systems verwenden muss:
    1. Zeigen Sie im Startmenü auf Programme, und klicken Sie dann auf Microsoft Visio.

    2. Klicken Sie im Menü Extras auf Optionen.

    3. Klicken Sie auf der Registerkarte Ländereinstellungen im Bereich Basisschriftart des Dokuments auf Immer Standardschriftart verwenden.

    4. Schließen Sie Visio, und öffnen Sie den BizTak-Orchestrierungs-Designer.


Installieren von Application Center2000

BizTalk Server 2002 ~ Installation

Installieren von Application Center 2000

Microsoft Application Center 2000 mit Service Pack 1 (SP1) ist nur erforderlich, wenn Sie von den Bereitstellungsfunktionen von BizTalk Server 2002 profitieren möchten.

Wichtig

  • Sie müssen Application Center vor BizTalk Server installieren. Darüber hinaus müssen beide Anwendungen auf dem gleichen Computer installiert sein.

  • Sie können Application Center 2000 nicht auf einem Computer mit Microsoft Windows 2000 Datacenter Server installieren.

Installieren von Application Center 2000

  1. Legen Sie die Application Center 2000-CD in das CD-ROM-Laufwerk ein.

  2. Führen Sie das Installationsprogramm von Application Center 2000 aus, und folgen Sie den Anweisungen auf dem Bildschirm.

Wichtig

  • Nachdem Sie Application Center 2000 installiert haben, müssen Sie SP1 für Application Center 2000 installieren. Weitere Informationen zum Installieren des Patches, finden Sie in der Infodatei im Verzeichnis Application Center 2000 SP1.

  • Wenn Sie Application Center nicht zuerst installieren, werden der Treiber und Enumerator im Verzeichnis AppCenter im Installationsverzeichnis von BizTalk Server installiert und nicht registriert.

    So installieren Sie den Treiber und Enumerator

    1. Installieren Sie Application Center 2000 und SP1.

    2. Kopieren Sie die Dateien Rdrvbts.dll und AcBtsEnm.dll aus dem Verzeichnis \Programme\Microsoft BizTalk Server\AppCenter in das Installationsverzeichnis von Application Center.

    3. Kopieren Sie die GIF-Dateien aus dem Verzeichnis \Programme\Microsoft BizTalk Server\AppCenter in den Ordner Admin\Images im Installationsverzeichnis von Application Center.

    4. Registrieren Sie den Treiber und Enumerator, indem Sie in der Befehlszeile "regsvr32.exe rdrvbts.dll" und "regsvr32.exe AcBtsEnm.dll" ausführen. Sie müssen möglicherweise den vollständigen Pfad zu den DLLs (Dynamic-Link Liberaries) angeben.


Installationsanweisungen

Sie können bei der Installation von Microsoft BizTalk Server 2002 den Installations-Assistenten (Microsoft BizTalk Server.msi) oder den Microsoft Windows Installer (Msiexec.exe) verwenden. Der Installations-Assistent ist ein schrittweiser Prozess, bei dem Sie Optionen auswählen, die bestimmten Eigenschaftswerten entsprechen. Der Microsoft Windows Installer ermöglicht Ihnen das Festlegen von Eigenschaftswerten in der Befehlszeile. Mit dieser Methode können Sie BizTalk Server 2002 ohne Aufsicht (d. h. ohne ständige Interaktion oder Aufforderungen) installieren. Eine unbeaufsichtigte Installation von BizTalk Server 2002 eignet sich ideal für Testszenarien oder bei einer unternehmensweiten Installation.

Unabhängig von der durchgeführten Installation sollten Sie sich jedoch die folgenden Informationen notieren, damit Sie später darauf zurückgreifen können:

  • BizTalk Server-Gruppennamen
    Standard: BizTalk Server-Gruppe

  • Microsoft SQL Server-Namen
    Standard: der Name des Computers mit SQL Server

  • Benutzernamen und Kennwörter für das BizTalk Server-Dienstkonto

  • Name der BizTalk-Messaging-Verwaltungsdatenbank
    Standard: InterchangeBTM

  • Name der Überwachungsdatenbank
    Standard: InterchangeDTA

  • Name der Datenbank für gemeinsam verwendete Warteschlangen
    Standard: InterchangeSQ

  • Name der Persistenzdatenbank für die Orchestrierung
    Standard: XLANG

  • URL für das WebDAV-Repository
    Standard: \\localhost\BizTalkTracking

Wichtig

  • Bevor Sie das Installationsprogramm für BizTalk Server 2002 ausführen, stellen Sie sicher, dass Sie mit einem Konto am Computer angemeldet sind, das über Administratorrechte für den lokalen Computer und alle SQL Server-Computer verfügt, die konfiguriert werden sollen. Weitere Informationen zum Erstellen eines SQL Server-Anmeldekontos mit Administratorrechten an einem Remotecomputer finden Sie unter Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken.

  • BizTalk Server 2002 benötigt Microsoft XML Parser (MSXML), Version 3.0, mit Service Pack 1 (SP1). Bei dieser Version von BizTalk Server 2002 wird MSXML 3.0 SP1 automatisch installiert. Die Verwendung von BizTalk Server 2002 mit einer anderen Version von MSXML kann zu unerwarteten Ergebnissen führen. Wenn eine gleichzeitige Installation von MSXML 3.0 und 4.0 (oder höher) erforderlich ist, müssen Sie MSXML 4.0 vor der Installation von BizTalk Server 2002 deinstallieren und die Anwendung nach der Installation von BizTalk Server 2002 erneut installieren.

  • Zum Installieren von BizTalk Server 2002 muss die Windows 2000-Systemkonsole verwendet werden. Die Installation von BizTalk Server mithilfe der Terminaldienste wird nicht unterstützt.

Anmerkungen

  • Ausführliche Informationen zu BizTalk Server-Sicherheitsüberlegungen finden Sie unter Sicherheitsrichtlinien.

  • Weitere Informationen zum Bereitstellen von BizTalk Server 2002 in einer Clusterumgebung finden Sie in der Microsoft BizTalk Server-Website (www.microsoft.com/biztalk) auf der Seite "Deployment" im Abschnitt "Technical Resources".

Folgende Themen werden in diesem Abschnitt behandelt:

  • Vollständige Installation

  • Toolsinstallation

  • Benutzerdefinierte Installation

  • Aktualisierungsinstallation

  • Unbeaufsichtigte Installation

  • Entfernen von BizTalk Server 2002


Vollständige Installation

Im folgenden Abschnitt wird die Ausführung einer vollständigen Installation von BizTalk Server 2002 beschrieben, einschließlich sämtlicher Microsoft BizTalk-Dienste, -Tools und -Beispiele.

Wichtig

  • Vor der Installation von BizTalk Server 2002 müssen die Mindestanforderungen an Hardware und Software erfüllt sein. Sehen Sie sich die Installationscheckliste an, um sicherzustellen, dass die notwendigen Voraussetzungen erfüllt sind.

  • Um BizTalk Server erfolgreich installieren zu können, muss IIS aktiviert sein. Der Dienst wird während der BizTalk Server-Installation gestartet.

  • BizTalk Server 2002 verwendet die Windows-Authentifizierung für den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die BizTalk-Dokumentüberwachung-Webanwendung. Stellen Sie sicher, dass der Microsoft SQL Server-Authentifizierungsmodus in Windows festgelegt wurde, bevor Sie BizTalk Server 2002 installieren. Weitere Informationen finden Sie unter Festlegen des SQL-Authentifizierungsmodus für SQL Server 2000. Wenn SQL Server auf einem Remotecomputer installiert ist, überprüfen Sie, ob das verwendete Konto Mitglied der SQL Server-Administratorengruppe ist. Weitere Informationen finden Sie unter Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken.

  • BizTalk Server 2002 benötigt Microsoft XML Parser (MSXML), Version 3.0, mit Service Pack 1 (SP1). Bei dieser Version von BizTalk Server 2002 wird MSXML 3.0 SP1 automatisch installiert. Die Verwendung von BizTalk Server 2002 mit einer anderen Version von MSXML kann zu unerwarteten Ergebnissen führen. Wenn eine gleichzeitige Installation von MSXML 3.0 und 4.0 (oder höher) erforderlich ist, müssen Sie MSXML 4.0 vor der Installation von BizTalk Server 2002 deinstallieren und die Anwendung nach der Installation von BizTalk Server 2002 erneut installieren.

Ausführen einer vollständigen Installation von BizTalk Server 2002

  1. Legen Sie die Microsoft BizTalk Server 2002-CD in das CD-ROM-Laufwerk ein, um den Installations-Assistenten zu starten. Dieser Assistent führt Sie durch die Installation von BizTalk Server 2002. Dabei müssen Sie die in den folgenden Schritten beschriebenen Einstellungen vornehmen.

  2. Geben Sie auf der Seite Kundeninformationen im Feld Benutzername Ihren Namen und im Feld Organisation den Namen Ihrer Firma ein. Klicken Sie anschließend auf Weiter.

  3. Klicken Sie auf der Seite Zielordner auf Weiter, um BizTalk Server 2000 am Standardspeicherort C:\Programme\Microsoft BizTalk Server zu installieren, oder klicken Sie auf Ändern, um einen anderen Speicherort auszuwählen.

  4. Klicken Sie auf der Seite Setup-Typ auf Vollständig, und klicken Sie dann auf Weiter.

  5. Übernehmen Sie auf der Seite Administratorzugriff für BizTalk Server konfigurieren den Standardnamen, BizTalk Server-Administratoren, oder geben Sie im Feld Gruppenname den Gruppennamen ein, den Sie verwenden möchten.

    Wichtig

    • Sie dürfen diese Gruppe nicht umbenennen, ohne nicht auch den Wert "AdminGroupName" in der Windows-Registrierung unter HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0\NTGroups zu ändern. BizTalk Server 2002 verwendet diesen Registrierungsschlüssel, um die Gruppe zu finden.

    Anmerkung

    • Beim Festlegen von Gruppennamen gelten die folgenden Beschränkungen:

      Der Gruppenname darf nicht mit einem anderen Gruppen- oder Benutzernamen auf diesem Computer übereinstimmen.

      Der Gruppenname darf keines der folgenden Zeichen enthalten: ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | ; \ " ' < > , . ?

      Der Gruppenname darf nicht nur aus Punkten (.) oder Leerzeichen bestehen.

  6. Geben Sie im Feld Gruppenbeschreibung eine neue Beschreibung für den Gruppennamen ein, oder übernehmen Sie die Standardbeschreibung, und klicken Sie dann auf Weiter.

  7. Übernehmen Sie auf der Seite Anmeldeeigenschaften des BizTalk Server-Dienstes die Standardeinstellung Dieses Konto, um ein Dienstkonto festzulegen. Unter diesem Konto wird der BizTalk-Messagingdienst ausgeführt. Damit BizTalk-Messaging ordnungsgemäß ausgeführt wird, benötigt dieses Konto Zugriff auf SQL Server. Geben Sie in das Feld Kennwort ein gültiges Kennwort ein.

    Sollen die BizTalk-Dienste nicht unmittelbar nach Abschluss der Installation gestartet werden, deaktivieren Sie das Kontrollkästchen Dienst nach Abschluss der Installation starten. Die BizTalk Server-Messagingdienste werden nicht automatisch gestartet.

    Anmerkungen

    • Während der BizTalk Server-Installation werden dem auf der Seite Anmeldeeigenschaften des BizTalk Server-Dienstes angegebenen Konto die Berechtigungen Als Dienst anmelden und Einsetzen als Teil des Betriebssystems erteilt.

    • Wenn Sie Dieses Konto auswählen und in Ihrer BizTalk Server-Implementierung öffentliche oder private Schlüsselzertifikate verwenden möchten, müssen Sie ein Konto festlegen, das zur Windows 2000-Administratorengruppe auf dem lokalen Computer gehört. Um Zertifikate für die S/MIME-Komponenten mithilfe des BizTalk Messaging-Managers zu konfigurieren, müssen Sie sich ebenfalls mit einem Konto anmelden, das zur Windows 2000-Administratorengruppe gehört.
  8. Klicken Sie auf Weiter.

  9. Klicken Sie auf der Seite Bereit zum Installieren des Programms auf Installieren.

    Die BizTalk Server 2002-Installation kann mehrere Minuten in Anspruch nehmen.

  10. Wenn die Seite Willkommen beim Einrichtungs-Assistenten für BizTalk Server 2002-Messagingdatenbanken angezeigt wird, klicken Sie auf Weiter.

    Während der Installation der BizTalk Server 2002-Datenbanken werden Sie aufgefordert, für die Konfiguration der BizTalk-Messaging-Verwaltungsdatenbank, der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen Informationen zum SQL Server-Computer und zur SQL Server-Datenbank anzugeben.

    Vorsicht

    • Ändern Sie den Code, z. B. gespeicherte Prozeduren oder Trigger, in der BizTalk-Messaging-Verwaltungsdatenbank, der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen nicht. Greifen Sie nicht direkt auf die Datenbanken zu. Rufen Sie die gespeicherten Prozeduren nicht direkt auf. Ändern Sie die Datenbanken nur mithilfe der Methoden und Eigenschaften des BizTalk-Messaging-Konfigurationsobjektmodells. Durch direkte Änderungen an den Datenbanken werden vom BizTalk-Messaging-Konfigurationsobjektmodell erzwungene Einschränkungen umgangen, was Serverfehler verursachen oder die Datenbank beschädigen kann.
  11. Übernehmen Sie auf der Seite BizTalk-Messaging-Verwaltungsdatenbank konfigurieren die Standardeinstellung, Neue BizTalk-Messaging-Verwaltungsdatenbank erstellen, oder klicken Sie auf Vorhandene Datenbank auswählen, und geben Sie im zutreffenden Textfeld einen Servernamen ein:

    Wichtig

    • Wird BizTalk Server 2002 auf einem Computer unter Microsoft Windows 2000 Professional installiert, müssen Sie als Servernamen den Namen des Computers angeben, auf dem Microsoft SQL Server 7.0 bzw. Microsoft SQL Server 2000 installiert ist.

    • Soll eine neue Datenbank denselben Namen erhalten wie eine vorhandene Datenbank auf demselben Server, empfiehlt es sich, den Datenbankinhalt manuell zu löschen. Weitere Informationen zum Löschen von Datenbankinhalten erhalten Sie, indem Sie im Startmenü auf Programme zeigen, dann auf Microsoft SQL Server zeigen und schließlich auf Onlinedokumentation klicken. Bei der Installation von BizTalk Server wird lediglich überprüft, ob eine von der Datenbank benötigte gespeicherte Prozedur existiert, nicht ob alle erforderlichen Variablen vorhanden sind. Ist eine gespeicherte Prozedur vorhanden, nimmt das Installationsprogramm von BizTalk Server keine Änderungen an der Datenbank vor. Ist die gespeicherte Prozedur nicht vorhanden, wird die Datenbank vom Installationsprogramm gelöscht. Anschließend werden die Tabellen der BizTalk-Messaging-Verwaltungsdatenbank neu initialisiert. Diese Informationen gelten auch für die Datenbank für gemeinsam genutzte Warteschlangen und die Überwachungsdatenbank.

    • Falls Sie mit mehreren Installationen von BizTalk Server arbeiten und die BizTalk-Messaging-Verwaltungsdatenbank zentral verwalten möchten, wird dringend empfohlen, dass Sie sich über das Ändern der BizTalk Server-Verwaltungsdatenbank informieren. Weitere Informationen finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank.
  12. Klicken Sie auf Weiter.

  13. Geben Sie auf der Seite BizTalk Server-Gruppe konfigurieren im Feld Gruppenname den gewünschten Namen für die BizTalk Server-Gruppe ein, oder übernehmen Sie die Standardeinstellung (BizTalk Server-Gruppe), und klicken Sie dann auf Weiter.

    Wenn Sie weitere BizTalk Server-Gruppen eingerichtet haben, können Sie auch auf Vorhandene BizTalk Server-Gruppe auswählen klicken und einen Namen aus der Liste Gruppenname auswählen.

    Wichtig

    • Der Gruppenname darf keines der folgenden Zeichen enthalten: ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | ; \ " '< > , . ? Auf allen Servern in einer Gruppe muss dieselbe Version und Sprache von BizTalk Server installiert sein. Wenn Server mit unterschiedlichen Versionen von BizTalk Server (BizTalk Server 2000, BizTalk Server 2000 Service Pack 1, BizTalk Server 2002 Enterprise Edition oder eine andere Sprachversion von BizTalk Server) in einer Gruppe installiert sind, funktionieren die Datenbanken nicht ordnungsgemäß.
  14. Wiederholen Sie auf der Seite Überwachungsdatenbank konfigurieren das Verfahren in Schritt 11, und klicken Sie auf Weiter.

  15. Wiederholen Sie auf der Seite Datenbank für gemeinsam genutzte Warteschlangen konfigurieren das Verfahren in Schritt 11, und klicken Sie auf Weiter.

  16. Überprüfen Sie auf der Seite BizTalk Server-Gruppe überprüfen, ob die Informationen im Feld Eigenschaften der BizTalk Server-Gruppe korrekt sind, und klicken Sie auf Weiter.

  17. Klicken Sie auf der letzten Seite des Einrichtungs-Assistenten für BizTalk Server 2002-Messagingdatenbanken auf Fertig stellen, um die Konfiguration der BizTalk-Messaging-Verwaltungsdatenbank, der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen abzuschließen.

  18. Klicken Sie auf der Seite Willkommen beim Einrichtungs-Assistenten für Persistenzdatenbanken für BizTalk Server 2002-Orchestrierung auf Weiter, um die Persistenzdatenbank für die Orchestrierung zu installieren.

    Anmerkung

    • Wenn Sie auf Abbrechen klicken, wird BizTalk Server 2002 zwar installiert, die Persistenzdatenbank für die Orchestrierung und der Datenquellenname jedoch nicht. Sie können die Datenbank und den Datenquellennamen später installieren. Weitere Informationen finden Sie unter Erstellen einer neuen Persistenzdatenbank, Verwalten von weiteren COM+-Hostanwendungen für XLANG-Ablaufpläne und Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne.
  19. Übernehmen Sie auf der Seite Standard-Persistenzdatenbank für die Orchestrierung konfigurieren die Standardeinstellung, Neue Standard-Persistenzdatenbank für die Orchestrierung erstellen, oder klicken Sie auf Vorhandene Datenbank auswählen. Anschließend können Sie einen SQL Server-Computernamen auswählen und Datenbankinformationen in den entsprechenden Textfeldern eingeben.

    Wichtig

    • Wenn Sie Neue Standard-Persistenzdatenbank für die Orchestrierung erstellen und dann eine Datenbank auswählen, die denselben Namen besitzt wie eine vorhandene Datenbank auf demselben Server, wird der Inhalt dieser Datenbank vom BizTalk Server-Installationsprogramm gelöscht. Anschließend werden die Tabellen der Persistenzdatenbank für die Orchestrierung vom BizTalk Server-Installationsprogramm neu initialisiert.

    • Wird BizTalk Server 2002 auf einem Computer unter Microsoft Windows 2000 Professional installiert, muss der angegebene Servername dem Namen des Computers entsprechen, auf dem SQL Server installiert ist.

    Anmerkungen

    • Die Persistenzdatenbank für die Orchestrierung wird auf der Basis der aktuellen Benutzeridentität erstellt.

    • Um SQL Server von einem Remotestandort aus verwenden zu können, sind entsprechende Berechtigungen für die Persistenzdatenbank für die Orchestrierung erforderlich. Wenn Sie die Identität für das XLANG-Ablaufplanungsmodul nicht neu konfiguriert haben, werden dem Benutzer, der während der Installation von BizTalk Server 2002 angemeldet war, Rechte gewährt. Wenn Sie die Identität entsprechend dem erstellten Dienstkonto oder einem anderen einmaligen Benutzerkonto neu konfiguriert haben, müssen Sie SQL-Berechtigungen einstellen, die mit der neu konfigurierten Identität übereinstimmen.
  20. Klicken Sie auf Fertig stellen.

  21. Klicken Sie auf der letzten Seite des Microsoft BizTalk Server 2002-Installations-Assistenten auf Infodatei anzeigen, um die neuesten Informationen zu BizTalk Server 2002 zu lesen, und klicken Sie dann auf Fertig stellen.

Vorsicht

  • Ändern Sie die angegebene Identitätswechselebene für COM+-Anwendungen nicht. Standardmäßig ist Identität wechseln festgelegt. Durch Ändern der Sicherheitseigenschaft in Anonym, Identifizieren oder Delegieren können Probleme bei der Installation auftreten.

  • Nachdem Sie BizTalk Server 2002 auf Ihrem Computer installiert haben, kann der Computername nicht mehr geändert werden. BizTalk Server 2002 verwendet den Computernamen intern. Wenn Sie diesen ändern, erkennt BizTalk Server 2002 einen anderen Namen und generiert eine Fehlermeldung. Wenn Sie den Computer umbenennen müssen, deinstallieren Sie BizTalk Server, benennen Sie den Computer um, und installieren Sie BizTalk Server erneut.

Wichtig

  • Wenn SQL Server auf einem Remotecomputer ausgeführt wird, müssen Sie festlegen, dass das SQL Server-Anmeldekonto Zugriffsrechte für die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen und die Überwachungsdatenbank hat. Weitere Informationen finden Sie unter Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken.

Anmerkung

  • Wenn Sie die Leistung der BizTalk-Orchestrierungsdienste verbessern möchten, suchen Sie im Windows Explorer nach Programme\Gemeinsame Dateien\System\ado, und doppelklicken Sie auf Adofre15.reg. Klicken Sie in dem Bestätigungsdialogfeld auf Ja und anschließend auf OK. Mit diesem Verfahren wird das ADO-Threadingmodell von Apartment threaded in Both geändert. Dies kann sich auch auf andere Anwendungen auswirken, die Microsoft® ActiveX® Data Objects (ADO) verwenden. Provider, die nicht threadsicher sind, können nicht verwendet werden.

Die folgenden Verfahren müssen nach der Installation abgeschlossen worden sein:

  • Vermeiden unnötiger Speicherplatzreservierung

  • Starten des WWW-Publishingdienstes

  • Konfigurieren der BizTalk-Dokumentüberwachung


Vermeiden unnötiger Speicherplatzreservierung

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft SQL Server 7.0 oder Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Servers, SQL Server-Gruppe, <Servername> und Datenbanken.

  3. Klicken Sie mit der rechten Maustaste auf die BizTalk-Messaging-Verwaltungsdatenbank, und klicken Sie auf Eigenschaften.

    Das Dialogfeld Eigenschaften der BizTalk-Messaging-Verwaltungsdatenbank wird angezeigt.

  4. Klicken Sie auf die Registerkarte Optionen.

  5. Aktivieren Sie im Bereich Einstellungen die Kontrollkästchen Protokoll bei Prüfpunkt abschneiden und Automatisch verkleinern, und klicken Sie auf OK.

    Anmerkung

    • Wenn Microsoft SQL Server 2000 installiert ist, aktivieren Sie das Kontrollkästchen Automatisch verkleinern, und ändern Sie das Wiederherstellungsmodell in Simple.
  6. Wiederholen Sie die Schritte 3 bis 5 für die Überwachungsdatenbank und die Datenbank für gemeinsam genutzte Warteschlangen.

Anmerkung

  • Bei der Installation erhält die BizTalk-Messaging-Verwaltungsdatenbank standardmäßig den Namen InterchangeBTM, die Überwachungsdatenbank den Namen InterchangeDTA und die Datenbank für gemeinsam genutzte Warteschlangen den Namen InterchangeSQ. Möglicherweise haben Sie diesen Datenbankobjekten während der Installation andere Namen gegeben.

Wichtig

  • BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ebenfalls ausgeführt wird. Weitere Informationen zum WWW-Publishingdienst finden Sie unter Starten des WWW-Publishingdienstes.


Starten des WWW-Publishingdienstes

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Klicken Sie in der Konsolenstruktur auf Dienste (Lokal).

  3. Klicken Sie im Detailfensterbereich mit der rechten Maustaste auf WWW-Publishingdienst, und klicken Sie auf Starten.


Konfigurieren der BizTalk-Dokumentüberwachung

Bei Installation der BizTalk-Dokumentüberwachung von der BizTalk Server 2002-CD wird auf dem lokalen Computer in der Programmgruppe für Microsoft BizTalk Server 2002 eine Verknüpfung erstellt, über die auf die BizTalk-Dokumentüberwachung-Webanwendung zugegriffen werden kann. Wird jedoch von einem Remotecomputer auf die BizTalk-Dokumentüberwachung-Webanwendung zugegriffen, müssen Sie manuell eine Verknüpfung oder einen Favoriten erstellen, um auf die Webanwendung zugreifen zu können. Sie müssen auf jeden Fall die Browsereinstellungen manuell so konfigurieren, dass dieser Webanwendung vertraut wird. Andernfalls werden Dialogfelder mit Sicherheitswarnungen angezeigt.

Konfigurieren der Internet Explorer-Sicherheitseinstellungen

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft BizTalk Server 2002, und klicken Sie auf BizTalk-Dokumentüberwachung.

    Anmerkungen

    • Wenn Sie in Microsoft Internet Explorer einen Favoriten erstellt haben, können Sie die BizTalk-Dokumentüberwachung-Webanwendung in Internet Explorer öffnen.

    • Wenn sich die Windows Common Controls und das Steuerelement BizTalk Dokumentüberwachung nicht auf Ihrem Computer befinden, werden Sie zum Installieren dieser Komponenten aufgefordert. Weitere Informationen finden Sie unter Erstmaliges Öffnen der BizTalk-Dokumentüberwachung.
  2. Kopieren Sie den Standort des BizTalk-Dokumentüberwachungsservers aus der Adressleiste in Internet Explorer in die Zwischenablage.

  3. Klicken Sie im Menü Extras auf Internetoptionen.

    Das Dialogfeld Internetoptionen wird angezeigt.

  4. Klicken Sie auf der Registerkarte Sicherheit auf Vertrauenswürdige Sites und dann auf Sites.

    Das Dialogfeld Vertrauenswürdige Sites wird angezeigt.

  5. Fügen Sie im Feld Diese Website zur Zone hinzufügen den Standort des Servers mit der BizTalk-Dokumentüberwachung ein.

  6. Deaktivieren Sie das Kontrollkästchen Für die Sites in dieser Zone ist eine Serverüberprüfung (https:) erforderlich.

  7. Klicken Sie auf Hinzufügen und dann zweimal auf OK, um die Dialogfelder zu schließen.


Toolsinstallation

Mit einer Microsoft BizTalk Server 2002-Toolsinstallation können Sie lediglich folgende Komponenten installieren:

  • BizTalk-Orchestrierungs-Designer

  • BizTalk-Editor

  • BizTalk-Mapper

  • MMC-Snap-In (Microsoft Management Console) BizTalk Server-Verwaltung

  • BizTalk Server 2002-Hilfe

Der Parser von BizTalk Server 2002, die Serialisierungskomponente, die Korrelationskomponente und die Laufzeitbinärdateien werden nicht installiert.

Ausführen einer Toolsinstallation von BizTalk Server 2002

  1. Legen Sie die Microsoft BizTalk Server 2002-CD in das CD-ROM-Laufwerk ein, um den Installations-Assistenten zu starten. Der Installations-Assistent führt Sie durch die Installation von BizTalk Server 2002. Dabei müssen Sie die in den folgenden Schritten beschriebenen Einstellungen vornehmen.

  2. Geben Sie auf der Seite Kundeninformationen im Feld Benutzername Ihren Namen und im Feld Organisation den Namen Ihrer Firma ein. Klicken Sie anschließend auf Weiter.

  3. Klicken Sie auf der Seite Zielordner auf Weiter, um die BizTalk Server 2000-Tools am Standardspeicherort C:\Programme\Microsoft BizTalk Server zu installieren, oder klicken Sie auf Ändern, um einen anderen Speicherort auszuwählen.

  4. Klicken Sie auf der Seite Setup-Typ auf Tools, und klicken Sie dann auf Weiter.

  5. Klicken Sie auf der Seite Bereit zum Installieren des Programms auf Installieren.

  6. Klicken Sie auf der letzten Seite des Microsoft BizTalk Server 2002-Installations-Assistenten auf Infodatei anzeigen, um die neuesten Informationen zu dieser Version von BizTalk Server 2002 zu lesen.

  7. Klicken Sie auf Fertig stellen, um den Installationsprozess abzuschließen.


Benutzerdefinierte Installation

Bei einer benutzerdefinierten Microsoft BizTalk Server 2002-Installation können Sie alle Features von BizTalk Server 2002 installieren oder nur bestimmte Features.

Anmerkung

  • Bevor Sie die Serverkomponenten von BizTalk Server 2002 installieren können, müssen Sie Microsoft SQL Server installieren. Weitere Informationen finden Sie unter SQL Server-Vorbereitungen und Installationsanforderungen.

Vorsicht

  • Installieren Sie den BizTalk-Messaging-Manager, die Internet-Informationsdienste (IIS) und die BizTalk Server-Konfigurationsdatenbank nicht auf drei separaten Computern. Bei diesem Konfigurationstyp treten Authentifizierungsprobleme auf.

Ausführen einer benutzerdefinierten Installation von BizTalk Server 2002

  1. Legen Sie die Microsoft BizTalk Server 2002-CD in das CD-ROM-Laufwerk ein, um den Installations-Assistenten zu starten. Der Installations-Assistent führt Sie durch die Installation von BizTalk Server 2002. Dabei müssen Sie die in den folgenden Schritten beschriebenen Einstellungen vornehmen.

  2. Geben Sie auf der Seite Kundeninformationen im Feld Benutzername Ihren Namen und im Feld Organisation den Namen Ihrer Firma ein. Klicken Sie anschließend auf Weiter.

  3. Klicken Sie auf der Seite Zielordner auf Weiter, um BizTalk Server 2000 am Standardspeicherort C:\Programme\Microsoft BizTalk Server zu installieren, oder klicken Sie auf Ändern, um einen anderen Speicherort auszuwählen.

  4. Klicken Sie auf der Seite Setup-Typ auf Benutzerdefiniert, und klicken Sie dann auf Weiter.

  5. Folgen Sie auf der Seite Benutzerdefinierte Installation den Anweisungen auf dem Bildschirm, um die zu installierenden BizTalk Server 2002-Komponenten auszuwählen.

    Um einen anderen Installationstyp auszuführen, klicken Sie auf Zurück. Andernfalls klicken Sie auf Weiter. Abhängig von den ausgewählten Installationskomponenten werden weitere Seiten mit zusätzlichen Informationen angezeigt.

  6. Klicken Sie auf der Seite Bereit zum Installieren des Programms auf Installieren.

    Die benutzerdefinierte Installation von BizTalk Server 2002 kann einige Minuten in Anspruch nehmen.

  7. Klicken Sie auf der letzten Seite des Microsoft BizTalk Server 2002-Installations-Assistenten auf Infodatei anzeigen, um die neuesten Informationen zu dieser Version von Microsoft BizTalk Server 2002 zu lesen.

  8. Klicken Sie auf Fertig stellen, um den Installationsprozess abzuschließen.

Wichtig

  • BizTalk-Messaging-Manager wird nur ausgeführt, wenn der WWW-Publishingdienst ebenfalls ausgeführt wird. Weitere Informationen zum WWW-Publishingdienst finden Sie unter Starten des WWW-Publishingdienstes.

  • Wenn Sie die Leistung der BizTalk-Orchestrierungsdienste verbessern möchten, suchen Sie im Windows Explorer nach Programme\Gemeinsame Dateien\System\ado, und doppelklicken Sie auf adofre15.reg. Klicken Sie in dem Bestätigungsdialogfeld auf Ja und anschließend auf OK. Mit diesem Verfahren wird das ADO-Threadingmodell von Apartment threaded in Both geändert. Dies kann sich auch auf andere Anwendungen auswirken, die Microsoft® ActiveX® Data Objects (ADO) verwenden.

  • Verwenden Sie die Optionen Protokoll bei Prüfpunkt abschneiden und Automatisch verkleinern von Microsoft SQL Server, um unnötige Speicherplatzreservierungen zu vermeiden. Andernfalls können die SQL Server-Protokolle sehr viel Speicherplatz belegen. Weitere Informationen finden Sie unter Vermeiden unnötiger Speicherplatzreservierung.


Aktualisierungsinstallation

Im folgenden Abschnitt können Sie eine Aktualisierung auf die Microsoft BizTalk Server 2002-Dienste, -Tools und -Beispiele durchführen.

Vorläufige Installation

  • Es empfiehlt sich, vor der Aktualisierung auf BizTalk Server 2002 eine vollständige Sicherungskopie des aktuellen Systems anzulegen.

  • Es empfiehlt sich, vor der Aktualisierung auf BizTalk Server 2002 den IISAdmin-Dienst anzuhalten. Wenn Sie dies nicht tun, fehlen nach der Aktualisierung möglicherweise zwei DLLs (MscsCore.dll und MSCSAspHelp.dll). In diesem Fall müssen Sie die beiden DLL-Dateien (Dynamic Link Libraries) auf der BizTalk Server 2002-CD suchen, sie in das Verzeichnis Programme\Gemeinsame Dateien kopieren und die DLLs registrieren.

  • Sie müssen vor der Aktualisierung auf BizTalk Server 2002 alle vorherigen Betaversionen von Microsoft BizTalk Server entfernen.

  • BizTalk Server 2002 verwendet die Windows-Authentifizierung für den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die BizTalk-Dokumentüberwachung-Webanwendung. Stellen Sie sicher, dass der SQL Server-Authentifizierungsmodus in Windows festgelegt wurde, bevor Sie BizTalk Server 2002 installieren. Weitere Informationen finden Sie unter Festlegen des SQL-Authentifizierungsmodus für SQL Server 2000. Wenn SQL Server auf einem Remotecomputer installiert ist, überprüfen Sie, ob das verwendete Konto Mitglied der SQL Server-Administratorengruppe ist. Weitere Informationen finden Sie unter Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken.

Vorsicht

  • Alle vorhandenen BizTalk Server-Dateien werden bei der Aktualisierung entfernt. Außerdem geht die Konfiguration der BizTalk Server 2000-Dienste und COM+-Pakete bei der Aktualisierung auf BizTalk Server 2002 verloren.

Wichtig

  • BizTalk Server 2002 benötigt Microsoft XML Parser (MSXML), Version 3.0, mit Service Pack 1 (SP1). Bei dieser Version von BizTalk Server 2002 wird MSXML 3.0 SP1 automatisch installiert. Die Verwendung von BizTalk Server 2002 mit einer anderen Version von MSXML kann zu unerwarteten Ergebnissen führen. Wenn eine gleichzeitige Installation von MSXML 3.0 und 4.0 (oder höher) erforderlich ist, müssen Sie MSXML 4.0 vor der Installation von BizTalk Server 2002 deinstallieren und die Anwendung nach der Installation von BizTalk Server 2002 erneut installieren.

Ausführen einer Aktualisierungsinstallation von BizTalk Server 2002

  1. Legen Sie die Microsoft BizTalk Server 2002-CD in das CD-ROM-Laufwerk ein, um den Installations-Assistenten zu starten. Der Installations-Assistent führt Sie durch die Aktualisierung von BizTalk Server 2002. Dabei müssen Sie die in den folgenden Schritten beschriebenen Einstellungen vornehmen.

  2. Geben Sie auf der Seite Kundeninformationen im Feld Benutzername Ihren Namen und im Feld Organisation den Namen Ihrer Firma ein. Klicken Sie anschließend auf Weiter.

  3. Klicken Sie auf der Seite Zielordner auf Weiter, um die BizTalk Server-Installation im Standardverzeichnis zu aktualisieren.

  4. Klicken Sie auf der Seite Setup-Typ auf Vollständig, Tools oder Benutzerdefiniert, und klicken Sie dann auf Weiter.

    Anmerkung

    • Alle vorhandenen BizTalk Server-Dateien werden beim Aktualisieren entfernt und lediglich die ausgewählten Features installiert.
  5. Übernehmen Sie auf der Seite Administratorzugriff für BizTalk Server konfigurieren den Standardnamen, BizTalk Server-Administratoren, oder geben Sie im Feld Gruppenname den Gruppennamen ein, den Sie verwenden möchten.

    Wichtig

    • Sie dürfen diese Gruppe nicht umbenennen, ohne nicht auch den Wert "AdminGroupName" in der Windows-Registrierung unter HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0\NTGroups zu ändern. BizTalk Server 2002 verwendet diesen Registrierungsschlüssel, um die Gruppe zu finden.

    Anmerkung

    • Beim Festlegen von Gruppennamen gelten die folgenden Beschränkungen:

      Der Gruppenname darf nicht mit einem anderen Gruppen- oder Benutzernamen auf diesem Computer übereinstimmen.

      Der Gruppenname darf keines der folgenden Zeichen enthalten: ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , . ?

      Der Gruppenname darf nicht nur aus Punkten (.) oder Leerzeichen bestehen.

  6. Übernehmen Sie auf der Seite Anmeldeeigenschaften des BizTalk Server-Dienstes die Standardeinstellung Dieses Konto, um ein Dienstkonto festzulegen. Unter diesem Konto wird der BizTalk-Messagingdienst ausgeführt. Damit BizTalk-Messaging ordnungsgemäß ausgeführt wird, benötigt dieses Konto Zugriff auf SQL Server. Geben Sie in das Feld Kennwort ein gültiges Kennwort ein.

    Sollen die BizTalk-Dienste nicht unmittelbar nach Abschluss der Installation gestartet werden, deaktivieren Sie das Kontrollkästchen Dienst nach Abschluss der Installation starten. Die BizTalk Server-Messagingdienste werden nicht automatisch gestartet.

    Anmerkungen

    • Während der BizTalk Server-Installation werden dem auf der Seite Anmeldeeigenschaften des BizTalk Server-Dienstes angegebenen Konto die Berechtigungen Als Dienst anmelden und Einsetzen als Teil des Betriebssystems erteilt.

    • Wenn Sie Dieses Konto auswählen und in Ihrer BizTalk Server-Implementierung öffentliche oder private Schlüsselzertifikate verwenden möchten, müssen Sie ein Konto festlegen, das zur Windows 2000-Administratorengruppe auf dem lokalen Computer gehört. Um Zertifikate für die S/MIME-Komponenten mithilfe des BizTalk Messaging-Managers zu konfigurieren, müssen Sie sich ebenfalls mit einem Konto anmelden, das zur Windows 2000-Administratorengruppe gehört.
  7. Klicken Sie auf der Seite Bereit zum Installieren des Programms auf Installieren.

  8. Wenn die Seite Willkommen beim Einrichtungs-Assistenten für BizTalk Server 2002-Messagingdatenbanken angezeigt wird, klicken Sie auf Weiter.

  9. Klicken Sie auf der Seite BizTalk-Messaging-Verwaltungsdatenbank konfigurieren auf Vorhandene Datenbank auswählen oder Neue BizTalk-Messaging-Verwaltungsdatenbank erstellen.

    Anmerkungen

    • Die BizTalk-Messaging-Verwaltungsdatenbank (InterchangeBTM), die Überwachungsdatenbank (InterchangeDTA) und die Datenbank für gemeinsam genutzte Warteschlangen (InterchangeSQ) werden beim Aktualisieren nicht entfernt. Wenn Sie eine neue Datenbank erstellen, müssen Sie die Datenbanknamen ändern.

    • Wenn Sie die vorhandenen Datenbanken beibehalten, werden Sie aufgefordert, die Aktualisierung des Schemas und der gespeicherten Prozeduren zu bestätigen, bevor die Installation fortgesetzt wird. Die vorhandenen Datenbankschemas und gespeicherten Prozeduren sind mit BizTalk Server 2002 nicht kompatibel. Klicken Sie zum fortfahren auf Ja.
  10. Geben Sie auf der Seite BizTalk Server-Gruppe konfigurieren im Feld Gruppenname den gewünschten Namen für die BizTalk Server-Gruppe ein, oder übernehmen Sie die Standardeinstellung (BizTalk Server-Gruppe), und klicken Sie dann auf Weiter.

    Wichtig

    • Auf allen Servern in einer Gruppe muss dieselbe Version und Sprache von BizTalk Server installiert sein. Wenn Server mit unterschiedlichen Versionen von BizTalk Server (BizTalk Server 2000, BizTalk Server 2000 Service Pack 1, BizTalk Server 2002 Enterprise Edition oder eine andere Sprachversion von BizTalk Server) in einer Gruppe installiert sind, funktionieren die Datenbanken nicht ordnungsgemäß.
  11. Wiederholen Sie auf den Seiten Überwachungsdatenbank konfigurieren und Datenbank für gemeinsam genutzte Warteschlangen konfigurieren das Verfahren in Schritt 9, und klicken Sie auf Weiter.

  12. Überprüfen Sie auf der Seite BizTalk Server-Gruppe überprüfen, ob die Informationen im Feld Eigenschaften der BizTalk Server-Gruppe korrekt sind, und klicken Sie auf Weiter.

  13. Klicken Sie auf der letzten Seite des Einrichtungs-Assistenten für BizTalk Server 2002-Messagingdatenbanken auf Fertig stellen, um die Konfiguration der BizTalk-Messaging-Verwaltungsdatenbank, der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen abzuschließen.

  14. Klicken Sie auf der Seite Willkommen beim Einrichtungs-Assistenten für Persistenzdatenbanken für BizTalk Server 2002-Orchestrierung auf Weiter, um die Persistenzdatenbank für die Orchestrierung zu installieren.

  15. Klicken Sie auf der Seite Standard-Persistenzdatenbank für die Orchestrierung konfigurieren auf Vorhandene Datenbank auswählen oder Neue BizTalk-Messaging-Verwaltungsdatenbank erstellen.

  16. Klicken Sie auf Fertig stellen, um den Aktualisierungsprozess abzuschließen.

Vorsicht

  • Nachdem Sie BizTalk Server 2002 auf Ihrem Computer installiert haben, kann der Computername nicht mehr geändert werden. BizTalk Server 2002 verwendet den Computernamen intern. Wenn Sie diesen ändern, erkennt BizTalk Server 2002 einen anderen Namen und generiert eine Fehlermeldung. Wenn Sie den Computer umbenennen müssen, deinstallieren Sie BizTalk Server, nennen Sie den Computer um, und installieren Sie BizTalk Server erneut.


Unbeaufsichtigte Installation

Microsoft Windows Installer (Msiexec.exe) ist ein ausführbares Programm, das Pakete interpretiert und Produkte installiert. Msiexec erlaubt Ihnen das Festlegen von Eigenschaftswerten in der Befehlszeile. Diese Methode gibt Ihnen die Möglichkeit, Microsoft BizTalk Server 2002 ohne Aufsicht (d. h. ohne ständige Interaktion oder Aufforderungen) zu installieren. Eine unbeaufsichtigte Installation von BizTalk Server 2002 ist ideal für Testszenarien oder bei einer unternehmensweiten Installation.

Ausführen einer unbeaufsichtigten Installation von BizTalk Server 2002

  1. Klicken Sie im Startmenü auf Ausführen.

  2. Geben Sie cmd in das Feld Öffnen ein, und klicken Sie auf OK.

  3. Geben Sie an der Eingabeaufforderung folgende Syntax ein, um eine unbeaufsichtigte Installation von BizTalk Server 2002 durchzuführen:
    msiexec /I "\\server\folder\Microsoft BizTalk Server.msi"
/qb /Lv* "C:\Temp\install.log" INSTALLLEVEL=200
ALLUSERS=1
DSNCONFIG="C:\Temp\BizTalkInstall.ini"

Wichtig

  • Fügen Sie den Parameter ALLUSERS=1 hinzu, um die Installation für alle Benutzer abzuschließen. Darüber hinaus wird durch diesen Parameter sichergestellt, dass die Dienste die Registrierungseinstellungen sehen können.

  • Bei der unbeaufsichtigten Installation wird standardmäßig ein lokales Systemkonto verwendet. Wenn SQL Server auf einem Remotecomputer installiert ist, müssen Sie diesem Konto Zugriffsrechte für den Computer mit SQL Server gewähren. Bei Nichtbeachtung kommt es zu einem Dienstversagen, und beim Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank treten Fehler auf.

Anmerkungen

  • Zum Ausführen von Msiexec in Schritt 3 werden die folgenden Befehlszeilenoptionen verwendet:
    • /I ist die Befehlszeile für die Installation oder Konfiguration eines Produkts.

    • /qb ist die Befehlszeile für die Darstellung einer einfachen Benutzeroberfläche (nur Statusanzeige).

    • /Lv* erstellt eine Protokolldatei.

    • INSTALLLEVEL=200 installiert den Server. Wenn Sie für INSTALLLEVEL keinen Wert angeben, wird der Standardwert 100 verwendet, welcher der Toolsinstallation von BizTalk Server 2002 entspricht.

    • DSNCONFIG="C:\Temp\BizTalkInstall.ini" stellt Installationsinformationen für den Setup-Assistenten bereit.

In der Befehlszeile können Sie verschiedene Optionen angeben, um Eigenschaften für eine BizTalk Server 2002-Installation festzulegen. Für Eigenschaften, die nicht festgelegt wurden, werden die Standardwerte verwendet. Spezielle BizTalk Server 2002-Eigenschaften werden in der folgenden Tabelle aufgelistet.

Öffentliche Eigenschaft | Wert | Beschreibung
USERNAME (vorgegebene Installer-Eigenschaft) | <Name> Standard: {LogonUser} | Der Name des Benutzers, der die Installation durchführt. Dialogfeld Kundeninformationen; Bearbeitungsfeld Benutzername.
COMPANYNAME (vorgegebene Installer-Eigenschaft) | <Organisation> Standard: {LogonCompany} | Der Name der Organisation, welcher der Benutzer, der die Installation durchführt, angehört. Dialogfeld Kundeninformationen; Bearbeitungsfeld Organisation.
INSTALLLEVEL (vorgegebene Installer-Eigenschaft) | <Installationsebene> Standard: 100 | Die Installationsebene. Für die BizTalk Server 2002-Installation gilt: 100=Client-Setup-Typ und 200=Server-Setup-Typ.
INSTALLDIR (vorgegebene Installer-Eigenschaft) | <Installationspfad> Standard: "{Programme} \Microsoft BizTalk Server" | Der Zielordner für die Installation.
BTS_GROUP_NAME (Nur vollständige Installation) | <Gruppenname> Standard: "BizTalk Server-Administratoren" | Der Name der BizTalk Server 2002 Windows NT®-Gruppe. Dialogfeld Administratorzugriff für BizTalk Server konfigurieren; Bearbeitungsfeld Gruppenname.
BTS_GROUP_DESCRIPTION (Nur vollständige Installation) | <Gruppenbeschreibung> Standard: "Members can fully administer Microsoft BizTalk Server" | Die Beschreibung der BizTalk Server 2002 Windows NT®-Gruppe. Dialogfeld Administratorzugriff für BizTalk Server konfigurieren; Bearbeitungsfeld Beschreibung.
BTS_USERNAME (Nur vollständige Installation) | <Benutzername> Standard: "" | Der Domänenanmeldename für den BizTalk Server 2002-Dienst. Dialogfeld Anmeldeeigenschaften des BizTalk Server-Dienstes; Bearbeitungsfeld Benutzername.
BTS_PASSWORD (Nur vollständige Installation) | <Kennwort> Standard: "" | Das Anmeldekennwort für den BizTalk Server 2002-Dienst. Dialogfeld Anmeldeeigenschaften des BizTalk Server-Dienstes; Bearbeitungsfeld Kennwort.
BTS_SERVER (Vollständige und Toolsinstallation) | <Servername> Standard: "localhost" | Der Name des BizTalk-Servers, der von einem Remotestandort aus verwaltet werden soll. Dialogfeld BizTalk-Messaging-Manager konfigurieren; Bearbeitungsfeld Servername.
BTS_SDK_SERVER (Vollständige und Toolsinstallation) | <Servername> Standard: ""localhost"" | Der Name des BizTalk-Servers, der von DCOM verwendet werden soll. Dialogfeld DCOM für das BizTalk Server SDK konfigurieren; Bearbeitungsfeld Servername.
DSNCONFIG (Initialisierungsdatei) | <Pfadname> Standard: "" | Der Pfad für die Initialisierungsdatei, den die Datenbankeinrichtungs-Assistenten BTSsetupDB.exe und XLANGsetupDB.exe verwenden sollen.

Anmerkungen

  • Die DSNCONFIG-Eigenschaft ist für eine unbeaufsichtigte Installation von BizTalk Server 2002 erforderlich. Der in der Befehlszeile angegebene Initialisierungsdateipfad wird an die Datenbankeinrichtungs-Assistenten BTSsetupDB.exe und XLANGsetupDB.exe weitergeleitet. Wählen Sie einen der folgenden Befehlszeilenwerte aus:
    • DSNCONFIG="Vollständiger Pfad zur INI-Datei für BTSsetupDB.exe und XLANGsetupDB.exe"

      Oder

    • BTSSETUPDB.INI="Vollständiger Pfad zur INI-Datei für BTSsetupDB.exe" und XLANGSETUPDB.INI="Vollständiger Pfad zur INI-Datei für XLANGsetupDB.exe"
  • Der Datenbankeinrichtungs-Assistent verarbeitet den Inhalt dieser Initialisierungsdatei unter Verwendung der folgenden Regeln:
    • Alle [Abschnitte] und Schlüssel= sind optional; fehlt ein Schlüssel, wird der Standardwert in der Beispielinitialisierungsdatei verwendet.

    • Ist der Gruppenname in der angegebenen BizTalk-Messaging-Verwaltungsdatenbank vorhanden, werden die Abschnitte [InterchangeDTA] und [InterchangeSQ] ignoriert, da die Werte durch die Gruppe definiert werden.

    • Angegebene Datenbanken werden erstellt, sofern Sie auf dem entsprechenden Server nicht bereits vorhanden sind.
  • Die Installation der BizTalk-Messaging-Verwaltungsdatenbank und die Installation der Persistenzdatenbank für die Orchestrierung laufen unabhängig voneinander ab.

  • Abhängig von den installierten Features werden bei der Installation eine, keine oder beide der folgenden Komponenten konfiguriert:
    • BizTalk-Messaging-Verwaltungsdatenbank. Diese wird nur konfiguriert, wenn die BizTalk-Messagingdienste und die zugehörigen Komponenten installiert sind.

    • Persistenzdatenbank für die Orchestrierung. Diese wird nur konfiguriert, wenn die BizTalk-Orchestrierungsdienste installiert sind.
  • In der Befehlszeile werden die folgenden Eigenschaften verwendet:
    • DSNCONFIG. Gibt den Speicherort der INI-Datei an, die von BTSsetupDB.exe und XLANGsetupDB.exe verwendet werden soll.

      Oder

      BTSSETUPDB.INI. Gibt den Speicherort der INI-Datei an, die von BTSsetupDB.exe verwendet werden soll.

    • XLANGSETUPDB.INI. Gibt den Speicherort der INI-Datei an, die von XLANGsetupDB.exe verwendet werden soll.

Beispielinitialisierungsdatei mit sämtlichen [Abschnitten], Schlüsseln= und Standardwerten

Es folgt ein Beispiel für eine INI-Datei, die für eine unbeaufsichtigte Installation von BizTalk Server 2002 benötigt wird. Diese Befehlszeileneigenschaften sind für eine erstmalige Installation von BizTalk Server 2002 mithilfe des Microsoft Windows Installer erforderlich.

Beispiel für SetupDB.ini

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Messaging Management database
; Required section used by BTSsetupDB.exe only.
; Specify new or existing database.
;
[InterchangeBTM]
Server=localhost
Username=sa
Password=
Database=InterchangeBTM

;----------------------------------------------------------------------
; Name for BizTalk Server Group
; Required section used by BTSsetupDB.exe only.
; Specify new or existing server group.
;
[Group]
GroupName=BizTalkGroup

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Tracking database
; Required section used by BTSsetupDB.exe only.
; Optional if existing server group specified.
;
[InterchangeDTA]
Server=localhost
Username=sa
Password=
Database=InterchangeDTA

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Shared Queue database
; Required section used by BTSsetupDB.exe only.
; Optional if existing server group specified.
;
[InterchangeSQ]
Server=localhost
Username=sa
Password=
Database=InterchangeSQ

;----------------------------------------------------------------------
; SQL Server connection parameters for Orchestration database
; Required section used by XLANGsetupDB.exe only.
; Specify new or existing Orchestration database.
;
[Orchestration]
Server=localhost
Database=XLANG

In der folgenden Tabelle werden die Eigenschaften und Werte der Beispielinitialisierungsdatei BizTalkDB.ini beschrieben.

Eigenschaft | Wert | Beschreibung
[InterchangeBTM] Server=BIZTALK Melden Sie sich an diesem ersten SQL-Server mit dem Standardbenutzernamen und -kennwort an.
Database=BizTalkBTM

Erstellen Sie diese BizTalk-Messaging-Verwaltungsdatenbank, wenn sie nicht bereits auf dem Server vorhanden ist.
[Group] | GroupName=BizTalkServerGroup | Ist diese Gruppe bereits vorhanden, werden die übrigen Werte ignoriert.
[InterchangeDTA] Server=DTA-SERVER Melden Sie sich an diesem zweiten SQL-Server mit dem Standardbenutzernamen und -kennwort an.
Database=BizTalkDTA

Erstellen Sie diese Überwachungsdatenbank, wenn sie nicht bereits auf dem Server vorhanden ist.
[InterchangeSQ] Server=SQ-SERVER Melden Sie sich an diesem dritten SQL-Server mit dem Standardbenutzernamen und -kennwort an.
Database=BizTalkSQ

Erstellen Sie diese Datenbank für gemeinsam genutzte Warteschlangen, wenn sie nicht bereits auf dem Server vorhanden ist.
[Orchestration] Server=localhost Melden Sie sich an diesem vierten SQL-Server mit dem Standardbenutzernamen und -kennwort an.
Database=BizTalkXLANG

Erstellen Sie diese Persistenzdatenbank für die Orchestrierung, wenn sie nicht bereits auf dem Server vorhanden ist.

Befehlszeilenoptionen für Microsoft Windows Installer

Microsoft Windows Installer (Msiexec.exe) ist ein Programm, das Pakete interpretiert und Produkte installiert. Darüber hinaus wird eine Fehlerebene für die Rückgabe festgelegt, die den Microsoft Win32®-Fehlercodes entspricht. In der folgenden Tabelle werden die Befehlszeilenoptionen für dieses Programm beschrieben, die Sie zusätzlich zu den oben aufgeführten Eigenschaften und Werten verwenden können.

Option | Parameter | Bedeutung
/I | Package|ProductCode | Installiert oder konfiguriert ein Produkt.
/f [p|o|e|d|c|a|u|m|s|v] Package|ProductCode Repariert ein Produkt. Bei dieser Option werden sämtliche Eigenschaftswerte in der Befehlszeile ignoriert. Die Standardargumentliste für diese Option ist "pecms". Diese Option verwendet dieselbe Argumentliste wie die Option REINSTALLMODE property.

p - Erneute Installation nur dann, wenn die Datei fehlt.

o - Erneute Installation, wenn die Datei fehlt oder eine ältere Version der Datei installiert ist.

e - Erneute Installation, wenn die Datei fehlt oder eine gleich alte oder ältere Version der Datei installiert ist.

d - Erneute Installation, wenn die Datei fehlt oder eine andere Version der Datei installiert ist.

c - Erneute Installation, wenn die Datei fehlt oder die gespeicherte Prüfsumme nicht mit dem berechneten Wert übereinstimmt. Reparatur von Dateien nur dann, wenn die Attributspalte der File table den Wert msidbFileAttributesChecksum enthält.

a - Erneute Installation aller Dateien.

u - Neuschreibung aller erforderlichen benutzerspezifischen Einträge in der Registrierung.

m - Neuschreibung aller erforderlichen computerspezifischen Einträge in der Registrierung.

s - Überschreibung aller vorhandenen Verknüpfungen.

v - Start von der Quelle aus und erneute Zwischenspeicherung des lokalen Pakets.
/a | Package | Option Administrative installation. Installiert ein Produkt im Netzwerk.
/x | Package|ProductCode | Deinstalliert ein Produkt.
/j [u|m]Package

Oder

[u|m]Package /t Transform List

Oder

[u|m]Package /g LanguageID

 Kündigt ein Produkt an. Bei dieser Option werden sämtliche Eigenschaftswerte in der Befehlszeile ignoriert.

u - Ankündigung an den aktuellen Benutzer.

m - Ankündigung an alle Benutzer des Computers.

t -Anwendung der Transformation auf das angekündigte Paket.

g - Sprachkennung.
/L [i|w|e|a|r|u|c|m|o|p|v|+|!]Logfile Gibt den Pfad der Protokolldatei an. Mit den folgenden Flags können Sie festlegen, welche Informationen protokolliert werden sollen:

i - Statusmeldungen

w - Mittelschwere Warnungen

e - Alle Fehlermeldungen

a – Start von Aktionen

r - Aktionsspezifische Aufzeichnungen

u - Benutzeranfragen

c - Ursprüngliche Benutzeroberflächenparameter

m - Nicht genügend Arbeitsspeicher oder Abbruchinformation

o - Meldungen bei nicht ausreichendem Datenträgerspeicherplatz

p - Eigenschaften des Terminals

v - Ausführliche Ausgabe

+ - Anhang an vorhandene Datei

! - Aufzeichnung jeder Zeile im Protokoll

"*" - Platzhalter; Protokollierung aller Daten mit Ausnahme der Option v. Soll die Option v verwendet werden, geben Sie "/l*v" ein.
/m filename Generiert eine Systems Management Server-Statusdatei mit der Dateierweiterung MIF. Muss mit der Option für die Installation (-i), die Entfernung (-x), die Admin-Installation (-a) oder die erneute Installation (-f) verwendet werden. Die Datei Ismif32.dll wird als Teil von SMS installiert und muss sich unter diesem Pfad befinden.

Die Felder der Statusdatei mit der Dateierweiterung MIF enthalten die folgenden Informationen:

  • Hersteller - Autor

  • Produkt - Revision number

  • Version - Subject

  • Gebietsschema - Template

  • Seriennummer - Nicht festgelegt

  • Installation - In der Datei Ismif32.dll auf "Datum/Uhrzeit" festgelegt

  • Installationsstatus - "Erfolg" oder "Fehler"

  • Beschreibung - Fehlermeldungen in der folgenden Reihenfolge: 1) Vom Installer generierte Fehlermeldungen; 2) Ressource aus Msi.dll, wenn die Installation nicht gestartet werden kann oder der Benutzer den Vorgang abbricht 3) Datei mit Systemfehlermeldungen; 4) Formatierte Meldung: "Installationsfehler %i", wobei %i für den von Msi.dll zurückgegebenen Fehler steht.
/p PatchPackage Wendet einen Patch an. Um einen Patch auf ein installiertes Admin-Image anzuwenden, kombinieren Sie die folgenden Optionen:

/p <Patchpaket> /a <Paket>
/q n|b|r|f Legt die user interface level (UI) fest.

q , qn - Keine Benutzeroberfläche.

qb - Basic UI.

qr - Reduced UI mit einem modalen Dialogfeld am Ende der Installation.

qf - Full UI mit einem modalen Dialogfeld am Ende der Installation.

qn+ - Keine Benutzeroberfläche, mit Ausnahme eines modalen Dialogfeldes am Ende der Installation.

qb+ - Basic UI mit einem modalen Dialogfeld am Ende der Installation. Das modale Dialogfeld wird nicht angezeigt, wenn der Benutzer die Installation abbricht.

qb- - Basic UI ohne modale Dialogfelder. /qb+- ist keine unterstützte Benutzeroberflächenebene.
/?

Oder

/h

 Zeigt Copyrightinformationen zum Windows Installer an.
/y module Ruft den systemeigenen API DllRegisterServer auf, um die Module in der Befehlszeile automatisch zu registrieren. Zum Beispiel: msiexec /y MeineDatei.dll.

Diese Option wird lediglich bei Registrierungsinformationen angewandt, die nicht anhand der Registrierungstabellen der MSI-Datei hinzugefügt werden konnten.
/z module Ruft den systemeigenen API DllUnRegisterServer auf, um die Registrierung der Module in der Befehlszeile aufzuheben. Zum Beispiel: msiexec /z MeineDatei.dll.

Diese Option wird lediglich bei Registrierungsinformationen angewandt, die nicht anhand der Registrierungstabellen der MSI-Datei entfernt werden konnten.

Anmerkung

  • Für die in der obigen Tabelle beschriebenen Optionen gilt Folgendes:
    • Die Optionen /i, /x, /f[p|o|e|d|c|a|u|m|s|v], /j[u|m], /a, /p, /y und /z dürfen nicht zusammen verwendet werden. Die einzige Ausnahme von dieser Regel ist, dass bei Auswahl einer Admin-Installation sowohl /p als auch /a erforderlich sind.

    • Die Optionen /t und /g sollten nur zusammen mit /j verwendet werden.

    • Die Optionen /l und /q können mit /i, /x, /f[p|o|e|d|c|a|u|m|s|v], /j[u|m], /a und /p verwendet werden.

Syntaxregeln für Eigenschaften und Werte

Nur öffentliche Eigenschaften können mithilfe der Befehlszeile geändert werden. Alle Eigenschaftsnamen in der Befehlszeile werden als Großbuchstaben interpretiert, während beim Wert die Groß-/Kleinschreibung beachtet wird. Wenn Sie beispielsweise in einer Befehlszeile MyProperty eingeben, überschreibt der Installer den Wert MYPROPERTY und nicht den Wert MyProperty in der Eigenschaftentabelle. Verwenden Sie die folgende Befehlszeilensyntax, um ein Produkt zu installieren, bei dem für PROPERTY die Einstellung VALUE gilt. Die Eigenschaft kann an jeder beliebigen Stelle in der Befehlszeile eingefügt werden, nur nicht zwischen einer Option und ihrem Argument.

Richtige Syntax:

msiexec /i A:\Example.msi PROPERTY=VALUE

Falsche Syntax:

msiexec /i PROPERTY=VALUE A:\Example.msi

Eigenschaftswerte, die Zeichenfolgen enthalten, müssen in Anführungszeichen eingeschlossen werden. Die Zeichenfolge zwischen den Anführungszeichen kann auch Leerräume enthalten.

msiexec /i A:\Example.msi PROPERTY="Embedded White Space"

Um eine öffentliche Eigenschaft mithilfe der Befehlszeile zu löschen, geben Sie als Wert eine leere Zeichenfolge ein.

msiexec /i A:\Example.msi PROPERTY=""

Enthalten Teile der Zeichenfolge selbst Anführungszeichen, setzen Sie diese in doppelte Anführungszeichen.

msiexec /i A:\Example.msi PROPERTY="Embedded ""Quotes"" White Space"

Es folgt ein Beispiel für eine komplexe Befehlszeile:

msiexec /i testdb.msi INSTALLLEVEL=3 /l* msi.log COMPANYNAME="Acme ""Widgets"" and ""Gizmos."""

Das folgende Beispiel illustriert Ankündigungsoptionen. Bei Schaltern muss keine Groß-/Kleinschreibung beachtet werden.

msiexec /JM msisample.msi /T transform.mst /G langid /LIME logfile.txt

Weitere Informationen zu Microsoft Windows Installer finden Sie in der Microsoft® MSDN®-Website (msdn.microsoft.com/downloads/).


Entfernen von BizTalkServer2002

BizTalk Server 2002 ~ Installation

Entfernen von BizTalk Server 2002

Verwenden Sie das Software-Dienstprogramm von Microsoft Windows 2002, um Microsoft BizTalk Server 2000 zu entfernen.

Anmerkungen

  • Beim Deinstallieren von BizTalk Server werden die SQL-Datenbank oder Zuordnungen und Schemas, die in WebDAV verwendet wurden, nicht entfernt. Außerdem bleiben sämtliche Dateien, die Sie zum BizTalk Server-Verzeichnis hinzugefügt haben, ebenfalls erhalten.

  • Stellen Sie in einer Clusterumgebung vor dem Deinstallieren von BizTalk Server 2002 sicher, dass der Computer mit dem Host-Computer für die BizTalk Server-Datenbanken und allen anderen BizTalk-Servern in der Gruppe vernetzt ist. Sollten bei der Deinstallation Fehler auftreten, können die folgenden COM+-Anwendungen manuell entfernt werden:
    • BizTalk Server-Austauschanwendung

    • BizTalk Server-Dienstprogramme

    • XLANG-Ablaufplanung (XLANG Scheduler)

    • XLANG-Hilfsprogramm für Ablaufplanungspersistenz

Entfernen von BizTalk Server 2002

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Klicken Sie auf Software.

    Das Dialogfeld Software wird angezeigt.

  3. Klicken Sie auf Microsoft BizTalk Server 2002 und dann auf Entfernen.

  4. Folgen Sie den Anweisungen auf dem Bildschirm, und klicken Sie auf Ja, wenn Sie gefragt werden, ob BizTalk Server 2002 entfernt werden soll.


Grundlegendes zur Sicherheit

Microsoft® BizTalk™ Server 2002 ermöglicht Unternehmen einen sicheren Datenaustausch mit Handelspartnern, da er die Vorteile der Sicherheitsfunktionen nutzt, die durch Microsoft Windows® 2000-Sicherheit geboten werden.

Zu den von BizTalk Server verwendeten Windows 2000-Sicherheitsfunktionen zählen folgende Funktionen:

  • Windows-Kontensicherheit und lokale Richtlinien

  • Integrierte Windows- und Microsoft SQL Server-Anmeldesicherheit

  • Microsoft-Komponentendienstesicherheit und Rollen

  • Infrastruktur öffentlicher Schlüssel (Public-key infrastructure, PKI)

  • CryptoAPI

  • Smartcards

  • Kerberos-Protokoll

BizTalk Server steuert den Zugriff auf Tools (z. B. die BizTalk Server-Verwaltungskonsole), APIs (z. B. Windows Management Instrumentation), COM+-Anwendungen und andere Ressourcen durch das Erteilen des Zugriffs auf diese Ressourcen an bestimmte Benutzerkonten. Eine Methode, um Benutzerkonten Rechte zu erteilen, ist das Hinzufügen dieser Konten zu den von BizTalk Server erstellten Windows-Gruppen. Bei der Installation von BizTalk Server werden zwei lokale Windows-Gruppen erstellt: BizTalk Server-Administratoren und Benutzer des BizTalk Server-Berichts. Durch das Hinzufügen von Benutzerkonten zu diesen Gruppen auf BizTalk Server-Computern werden diesen Konten bestimmte Rechte auf BizTalk Server erteilt. So müssen Sie sich z. B. mit einem Konto aus der Gruppe BizTalk Server-Administratoren anmelden, um den BizTalk-Messaging-Manager oder die BizTalk Server-Verwaltungskonsole auf diesem Computer zu öffnen.

Außerdem müssen bestimmte Rechte u. U. auf der Betriebssystemebene erteilt werden, um bestimmte Aufgaben durchführen zu können. So müssen Sie beispielsweise dem BizTalk Server-Messagingdienstkonto vollständige Rechte auf dem Namespace von Windows Management Instrumentation (WMI) erteilen, damit dieses WMI-Ereignisse für die Angehalten-Warteschlange generieren kann.

BizTalk Server steuert den Zugriff auf SQL Server basierend auf der integrierten SQL Server-Sicherheit. Bei der integrierten Sicherheit von SQL Server verwendet SQL Server die Windows-Authentifizierung, um Zugriff auf SQL-Ressourcen zu erteilen. Standardmäßig müssen alle Konten, die auf eine der von BizTalk Server verwendeten SQL Server-Datenbanken zugreifen müssen, eine integrierte SQL Server-Anmeldung sowie Zugriff auf die Datenbank erhalten. Weitere Informationen finden Sie unter Interaktionen zwischen SQL Server und BizTalk Server 2000-Datenbanken . Mit Ausnahme der Verbindungen zur Persistenzdatenbank für die Orchestrierung, kann der Datenbankzugriff über BizTalk Server-Tools und Laufzeitdienste ausschließlich für die Verwendung integrierter Sicherheit konfiguriert werden.

Die Komponentendienste, eines der Windows 2000-Verwaltungsprogramme, bieten umfassende Komponentenfunktionen, z. B. die automatische Unterstützung von Transaktionen, um einen Datenintegritätsschutz und eine einfache und doch leistungsstarke, auf Rollen basierende Sicherheit bereitzustellen.

BizTalk Server steuert die Sicherheit zwischen Handelspartnern über die Verwendung von PKIs und S/MIME (Secure Multipurpose Internet Mail Extensions). Durch den Austausch von öffentlichen und privaten Schlüsselzertifikaten können Handelspartner sich gegenseitig identifizieren und Kommunikation durch die Verwendung von mit X.509 digital signierten Nachrichten und S/MIME verschlüsseln (bzw. die benutzerdefinierte Verschlüsselung mithilfe eigener Komponenten verwenden). Weitere Informationen finden Sie unter Zertifikate - Übersicht.

Da BizTalk Server Windows 2000-SSL (Secure Sockets Layer) verwendet, können Webseiten erstellt und von Handelspartnern verwendet werden, um Daten sicher über das Internet auszutauschen. Bei der in Internet-Informationsdienste (IIS, Internet Information Services) implementierten SSL-Technologie handelt es sich um ein Protokoll, das Datensicherheit zwischen einem Webclient und einem Webserver bereitstellen soll. Das Protokoll beginnt mit einer Handshakephase, in der ein Verschlüsselungsalgorithmus ausgehandelt wird, die (öffentlichen und privaten) Schlüssel überprüft werden und der Server beim Client authentifiziert wird. Nach Abschluss des Handshakes und dem Beginn der Anwendungsdatenübertragung werden alle Daten mit den Sitzungsschlüsseln verschlüsselt, die während des Handshakes ausgehandelt wurden. Durch die Unterstützung offener PKI-Standards und sicherer Protokolle, z. B. IPSec, L2TP, SSL/TLS und S/MIME, kann ein Netzwerk schnell um Lieferanten und Handelspartner erweitert und gleichzeitig vor Datenmissbrauch, Datendiebstahl und unberechtigten Hackerangriffen geschützt werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Anmeldeeigenschaften

  • Lokale Richtlinien

  • Sicherheitsrichtlinien

  • BizTalk Server-Administratoren (Gruppe)

  • BizTalk-Messagingdienst

  • BizTalk Server Interchange Application-Sicherheit

  • Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

  • Benutzer des BizTalk-Serverberichts (Gruppe)

  • Transportdienste

  • Zertifikate - Übersicht

  • CryptoAPI

  • Collaborative Data Objects (CDOs)

  • Konfigurieren von Firewalls

Verwandtes Thema

Administratorrechte


Anmeldeeigenschaften

Die Anmeldeeigenschaften bilden die erste Sicherheitsebene von BizTalk Server 2002. Diese Eigenschaften kontrollieren die Möglichkeit eines Benutzers, sich an einem bestimmten Computer bzw. einer bestimmten Domäne anzumelden und bestimmte Aufgaben auf diesem Computer bzw. in der Domäne durchzuführen. Die Anmeldeeigenschaften erfordern die Angabe eines Benutzernamens und Kennwortes, bevor auf Ressourcen, z. B. eine Dateifreigabe oder Nachrichtenwarteschlange, zugegriffen werden kann. Über HTTP oder SMTP empfangene Nachrichten verwenden ebenfalls die Anmeldeeigenschaften, um die Sicherheit zu gewährleisten. Eine ASP-Seite, auf die über HTTP zugegriffen wird, kann z. B. die Eingabe eines Benutzernamens und Kennwortes erfordern, ehe der Inhalt der Webseite angezeigt wird.

BizTalk Server kann Internet-Informationsdienste (Internet Information Services, IIS) und ASP-Seiten zum Empfangen von Dokumenten verwenden. ASP-Seiten (genau genommen der Code hinter den Seiten) stellen für BizTalk Server eine Sicherheitsebene zur Verfügung, indem über IIS SSL-Signaturen (Secure Sockets Layer) überprüft werden und die Sicherheit, z. B. durch Zertifikate, weiter maximiert wird. Weitere Informationen zur IIS-Sicherheit finden Sie in der Windows 2000-Hilfe unter "Internet-Informationsdienste".

Verwandtes Thema

Administratorrechte


Lokale Richtlinien

Die Funktion Lokale Richtlinien, die zur Konsole Lokale Sicherheitseinstellungen gehört, legt die Sicherheitsoptionen eines Benutzers oder Dienstkontos fest. Lokale Richtlinien basieren auf dem Computer, bei dem ein Benutzer angemeldet ist, sowie auf den Rechten, über die der Benutzer auf dem entsprechenden Computer verfügt. Zur Einstellung lokaler Richtlinien zeigen Sie im Startmenü auf Einstellungen, klicken auf Systemsteuerung, doppelklicken zuerst auf Verwaltung und dann auf Lokale Sicherheitsrichtlinie. Erweitern Sie den Ordner Lokale Richtlinien.

Mithilfe lokaler Richtlinien werden die Berechtigungen und Rechte von BizTalk Server 2002-Benutzern definiert. Lokale Richtlinien kann verwendet werden, um Folgendes zu konfigurieren:

  • Überwachungsrichtlinien. Bestimmt, welche Sicherheitsereignisse im Sicherheitsprotokoll auf dem Computer protokolliert werden (erfolgreiche Versuche, misslungene Versuche oder beides). (Das Sicherheitsprotokoll ist Teil der Ereignisanzeige.)

  • Zuweisen von Benutzerrechten. Bestimmt, welche Benutzer oder Gruppen über Rechte zum Anmelden oder Ausführen von Aufgaben auf dem Computer verfügen.

  • Sicherheitsoptionen. Aktiviert oder deaktiviert die Sicherheitseinstellungen für den Computer. Hierzu zählen z. B. digitale Signaturen von Daten, Namen von Administrator- und Gastkonten, der Zugriff auf Disketten- und CD-ROM-Laufwerke, Treiberinstallation und Anmeldeaufforderungen.

In der Konsole Lokale Sicherheitseinstellungen können weitere Richtlinien konfiguriert werden, um die Integrität der Daten zu erhalten. Mithilfe von Kontorichtlinien kann z. B. Folgendes konfiguriert werden:

  • Kennwortrichtlinien. Bestimmt bei lokalen Benutzerkonten die Einstellungen für Kennwörter, z. B. das Erzwingen und die Gültigkeitsdauer.

  • Kontosperrungsrichtlinien. Bestimmt bei lokalen Benutzerkonten, wann und für wen ein Konto gesperrt wird.

Wichtig

  • Lokale Richtlinien gelten per Definition nur lokal auf einem Computer. Wenn diese Einstellungen in ein Gruppenrichtlinienobjekt in Active Directory importiert werden, wirken sie sich auf die lokalen Sicherheitseinstellungen aller Computerkonten aus, auf die dieses Gruppenrichtlinienobjekt angewendet wird. Aus diesem Grund muss die Prioritätsreihenfolge für Sicherheitsrichtlinien beachtet werden. Sicherheitsrichtlinien, die Gruppenrichtlinien (Organisationseinheiten) zugeordnet sind, setzen auf der lokalen Ebene definierte Richtlinien außer Kraft. Richtlinien der Domäne setzen lokal definierte Richtlinien ebenfalls außer Kraft. In jedem Fall gelten die Rechte für das Benutzerkonto nicht mehr, wenn diese Privilegien durch vorhandene lokale Richtlinieneinstellungen außer Kraft gesetzt werden. Dies ist von Bedeutung, da sich das Verhalten von Microsoft Windows 2000 und Microsoft Windows NT wesentlich unterscheiden kann. Wenn z. B. Kennwortrichtlinien für die Gruppenrichtlinie Domäne konfiguriert sind (Standardeinstellung), wirken sie sich auf alle Computer in dieser Domäne aus. Das bedeutet, dass die lokalen Kontodatenbanken (auf einzelnen Arbeitsstationen) in der Domäne über dieselben Kennwortrichtlinien verfügen wie die Domäne selbst.

Anmerkung

  • Legen Sie Lokale Richtlinien nicht für öffentliche Schlüssel fest. Öffentliche Schlüssel stellen einen Sicherheitsschutz für BizTalk Server bereit. Öffentliche Schlüssel sind eine Komponente der Zertifikate, die zum Ver- und Entschlüsseln von Daten verwendet werden. Wenn einem öffentlichen Schlüssel weitere Richtlinien hinzugefügt werden, kann BizTalk Server das zugeordnete Zertifikat nicht verwenden.

Verwandtes Thema

Administratorrechte


Sicherheitsrichtlinien

BizTalk Server 2002 verwendet statt SQL Server-Anmeldeinformationen integrierte Windows NT-Sicherheit für den Zugriff auf SQL Server. Das bedeutet, dass BizTalk Server die Anmeldeinformationen des aktuell angemeldeten Benutzers verwendet, um die SQL Server-Privilegien zu ermitteln. Aus diesem Grund müssen bei der Installation und Konfiguration von BizTalk Server-Verwaltungskomponenten folgende Sicherheitsaspekte berücksichtigt werden.

BizTalk Server-Funktion | Sicherheitsrichtlinien
BizTalk Server-Verwaltung
  • Benutzer müssen zur Gruppe BizTalk Server-Administratoren gehören. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".

  • Benutzer müssen vollen Zugriff auf die Datenbank für gemeinsam genutzte Warteschlangen und auf die BizTalk-Messaging-Verwaltungsdatenbank haben und Mitglieder der Rolle db_owner für diese Datenbanken sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.
BizTalk-Messaging-Manager
  • Benutzer müssen zur Gruppe BizTalk Server-Administratoren gehören. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".

  • Benutzer müssen vollen Zugriff auf die Datenbank für gemeinsam genutzte Warteschlangen und auf die BizTalk-Messaging-Verwaltungsdatenbank haben und Mitglieder der Rolle Datenbankbesitzer für diese Datenbanken sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.
BizTalk-Messaging-Konfigurationsobjektmodell
  • Benutzer müssen zur Gruppe BizTalk Server-Administratoren gehören. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".

  • Benutzer müssen vollen Zugriff auf die Datenbank für gemeinsam genutzte Warteschlangen und auf die BizTalk-Messaging-Verwaltungsdatenbank haben und Mitglieder der Rolle Datenbankbesitzer für diese Datenbanken sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.
BizTalk-Messagingdienst
  • Dem BizTalk Server-Messagingdienstkonto müssen Sicherheitsrichtlinien zum Anmelden als Dienst zugewiesen werden.

  • Dem BizTalk Server-Messagingdienstkonto müssen vollständige Rechte auf dem Namespace Root\MicrosoftBizTalkServer von Windows Management Instrumentation (WMI) erteilt werden. Weitere Informationen finden Sie unter Erteilen von WMI-Namespacerechten an ein Windows-Konto.

  • Benutzer müssen vollen Zugriff auf die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungs- und auf die BizTalk-Messaging-Verwaltungsdatenbank haben und Mitglieder der Rolle db_owner für diese Datenbanken sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.

  • Falls für eine Empfangsfunktion ein Benutzername/Kennwort angegeben wurde, müssen dem Benutzerkonto der Empfangsfunktion die Sicherheitsrichtlinien Lokal anmelden und Einsetzen als Teil des Betriebssystems erteilt werden.

  • Wurden HTTP-Empfangsfunktionen erstellt, erfordern die dazugehörigen BizTalk ISAPI-Erweiterungen eine zusätzliche Sicherheitskonfiguration. Weitere Informationen finden Sie unter Konfigurieren von Zugriffsrechten basierend auf der IIS-Schutzebene.
BizTalk Server Interchange Application (COM+)
  • Das Anwendungsidentitätskonto muss vollständige Berechtigungen auf dem WMI-Namespace Root\MicrosoftBizTalkServer erhalten. Weitere Informationen finden Sie unter Erteilen von WMI-Namespacerechten an ein Windows-Konto.

  • Das Anwendungsidentitätskonto muss vollen Zugriff auf die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungs- und auf die BizTalk-Messaging-Verwaltungsdatenbank haben und Mitglied der Rolle db_owner für diese Datenbanken sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.
Benutzeroberfläche der BizTalk Server-Dokumentüberwachung
  • Benutzerkonto muss vollen Zugriff auf die Überwachungsdatenbank haben und Mitglied der Rolle db_owner für diese Datenbank sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.

  • Benutzerkonto muss zur Gruppe Benutzer des BizTalk-Serverberichts gehören.
XLANG Scheduler (COM+)
  • Wenn der Datenquellenname (DSN) für den Zugriff auf die Persistenzdatenbank für die Orchestrierung mit Windows-Authentifizierung konfiguriert ist (Standard), dann müssen die Anmeldeinformationen des Benutzers, der mit einer XLANG-Ablaufplaninstanz interagiert, vollen Zugriff auf die Persistenzdatenbank für die Orchestrierung haben und Mitglied der Rolle db_owner für diese Datenbank sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.

  • Ist der DSN mit SQL-Authentifizierung konfiguriert, muss die verwendete SQL-Anmeldung vollen Zugriff auf die Persistenzdatenbank für die Orchestrierung haben und Mitglied der Rolle db_owner für diese Datenbank sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.

  • Benutzer, die mit einer XLANG-Ablaufplaninstanz interagieren, müssen Mitglied der Rolle XLANG-Ablaufplanbenutzer unter der COM+-Konfiguration der entsprechenden BizTalk-XLANG Scheduler-Anwendung sein. Weitere Informationen finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen
BizTalk-SEED-Assistent
  • Benutzer müssen zur Gruppe BizTalk Server-Administratoren gehören. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".

  • Benutzer müssen vollen Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank haben und Mitglied der Rolle db_owner für diese Datenbank sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.
BizTalk-Bereitstellung mit Application Center 2000
  • Benutzer müssen zur Gruppe BizTalk Server-Administratoren gehören. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".

  • Benutzer müssen vollen Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank haben und Mitglied der Rolle Datenbankbesitzer für diese Datenbank sein. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.
XLANG-Monitor
  • Benutzer müssen Mitglied der Rolle XLANG-Ablaufplanersteller für XLANG Schedule und für die COM+-Anwendungen sein, die als Host für XLANG-Ablaufpläne dienen. Weitere Informationen finden Sie unter Hinzufügen einer Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application); wenn Sie jedoch dieses Verfahren durchführen, müssen Sie die Austauschanwendung durch die COM+-Anwendung ersetzen, die als Host für XLANG-Ablaufpläne dient.
Anwendungs-Designer | Keine Sicherheitsanforderungen.
BizTalk-Editor und BizTalk-Mapper | Keine Sicherheitsanforderungen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.

  • Erteilen von WMI-Namespacerechten an ein Windows-Konto


Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung

Damit ein von BizTalk Server verwendetes Konto auf die SQL Server-Datenbanken zugreifen kann, muss der Zugriff diesem Konto explizit gewährt werden.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Servers, erweitern Sie SQL Server-Gruppe und dann den jeweiligen Server mit der BizTalk-Messagingverwaltungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen.

  3. Erweitern Sie den Ordner Sicherheit, klicken Sie mit der rechten Maustaste auf Benutzernamen, und klicken Sie dann auf Neuer Benutzername.

    Das Dialogfeld SQL Server-Anmeldungseigenschaften - Neuer Benutzername wird angezeigt.

  4. Geben Sie in das Feld Name den Namen des Windows-Kontos ein, für das Sie eine SQL-Anmeldung erstellen wollen.

  5. Stellen Sie sicher, dass im Bereich Authentifizierung die Option Windows-Authentifizierung ausgewählt ist, und geben Sie dann die Domäne des Windows-Kontos an. Klicken Sie auf OK.

  6. Klicken Sie auf die Registerkarte Datenbankzugriff, aktivieren Sie das Kontrollkästchen Zulassen für die Datenbank, für die Sie die Berechtigung ändern wollen, und wählen Sie dann Datenbankbesitzer aus der Liste In Datenbankrolle zulassen aus.

  7. Aktivieren Sie das Kontrollkästchen Zulassen für die Datenbank für gemeinsam genutzte Warteschlangen, wählen Sie Datenbankbesitzer aus der Liste In Datenbankrolle zulassen aus, und klicken Sie dann auf OK.


Erteilen von WMI-Namespacerechten an ein Windows-Konto

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

    Die Konsole der Computerverwaltung wird angezeigt.

  2. Erweitern Sie Dienste und Anwendungen, klicken Sie mit der rechten Maustaste auf WMI-Steuerung, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von WMI-Steuerung wird angezeigt.

  3. Klicken Sie auf die Registerkarte Sicherheit, doppelklicken Sie auf den Stammknoten, und klicken Sie dann auf den Namespace MicrosoftBizTalkServer.

  4. Klicken Sie auf die Schaltfläche Sicherheit.

    Das Dialogfeld Sicherheit für ROOT\MicrosoftBizTalkServer wird angezeigt.

  5. Klicken Sie auf die Schaltfläche Hinzufügen.

    Das Dialogfeld Benutzer oder Gruppen auswählen wird angezeigt.

  6. Geben Sie den Namen des Windows-Kontos ein, dem Sie eine WMI-Namespaceberechtigung erteilen möchten, und klicken Sie dann auf OK.

  7. Stellen Sie sicher, dass für alle Berechtigungen das Kontrollkästchen Zulassen aktiviert ist.

  8. Klicken Sie auf OK.

  9. Klicken Sie auf OK, um das Dialogfeld Eigenschaften von WMI-Steuerung zu schließen.


BizTalk Server-Administratoren (Gruppe)

Während der Installation erstellt BizTalk Server 2002 eine Windows-Gruppe auf dem lokalen Computer, deren Mitglieder administrative und andere Rechte für BizTalk Server erhalten. Standardmäßig heißt diese Gruppe BizTalk Server-Administratoren, allerdings können Benutzer diesen Namen während der Installation ändern. Nach der Installation ist eine Änderung des Namens jedoch nicht mehr möglich. Bei der Installation fügt BizTalk Server die integrierte Gruppe der lokalen Administratoren sowie das aktuell angemeldete Benutzerkonto zu dieser Gruppe hinzu.

Hauptzweck der Gruppe BizTalk Server-Administratoren ist die Steuerung des Zugriffs auf Tools und APIs (Application Programming Interfaces), die von BizTalk Server bereitgestellt werden. Weitere Informationen zu den Ressourcen, bei denen Benutzer Mitglied dieser Gruppe sein müssen, finden Sie unter Sicherheitsrichtlinien.

Anmerkung

  • Das Dienstkonto, unter dem der BizTalk-Messagingdienst ausgeführt wird, muss nicht Mitglied dieser Gruppe sein, damit BizTalk Server einwandfrei ausgeführt werden kann.


BizTalk-Messagingdienst

Der BizTalk-Messagingdienst ist ein Windows-Dienst, der die Basis der Laufzeitfunktionen von BizTalk-Messaging bereitstellt. Als Windows-Dienst wird der BizTalk-Messagingdienst in einem eigenen Sicherheitskontext ausgeführt, entweder als Lokales System oder als ein vom Benutzer erstelltes Dienstkonto, dem so genannten BizTalk Server-Messagingdienstkonto. Bei einem Dienstkonto handelt es sich um ein Windows-Benutzerkonto, dem die besonderen Berechtigungen Einsetzen als Teil des Betriebssystems und Als Dienst anmelden erteilt wurden. Während der Installation erteilt BizTalk Server diese Berechtigungen an das vom Benutzer als BizTalk Server-Messagingdienstkonto angegebene Konto. Weitere Informationen erhalten Sie unter Installationsanweisungen.

Die beiden wichtigsten Gründe für eine Verwendung von Lokales System anstelle eines lokalen Windows-Kontos bzw. eines Domänendienstkontos hängen im Wesentlichen von zwei Faktoren ab:

  1. SQL Server-Topologie. Dem BizTalk Server-Messagingdienstkonto muss Zugriff auf die von BizTalk Server verwendete SQL Server-Datenbank erteilt werden, damit es funktionieren kann. Wenn Sie BizTalk Server auf demselben Computer wie die von BizTalk Server verwendeten SQL Server-Datenbanken ausführen, können Sie ein beliebiges Konto verwenden. Wenn Sie jedoch einen SQL-Server auf einem anderen Computer verwenden, als der, auf dem BizTalk Server ausgeführt wird, sollten Sie ein Windows-Domänenkonto als BizTalk Server-Messagingdienstkonto verwenden. Wenn Sie BizTalk Server für die Verwendung desselben Domänenkontos konfigurieren, wird allen BizTalk-Servern durch das Erteilen des Zugriffs auf dieses eine Domänenkonto gleichzeitig Zugriff auf SQL Server erteilt.

  2. Verwendung digitaler Zertifikate. Wenn Sie die Funktionen zur digitalen Signatur und Verschlüsselung/Entschlüsselung von BizTalk Server nutzen möchten, muss das BizTalk Server-Messagingdienstkonto Mitglieder der integrierten Gruppe der lokalen Windows-Administratoren sein. Dies ist erforderlich, um auf die digitalen Zertifikatspeicher des lokalen Computers zugreifen zu können.

Anmerkung

  • Das BizTalk Server-Messagingdienstkonto muss kein Mitglied der Gruppe BizTalk Server-Administratoren für BizTalk Server sein, um einwandfrei zu funktionieren.


BizTalkServer Interchange Application

BizTalk Server 2002 ~ Sicherheit

BizTalk Server Interchange Application

Die COM+-Schnittstelle, die für das programmgesteuerte Senden von Dokumenten an BizTalk Server 2002 verwendet wird, befindet sich in einer COM+-Anwendung, die von BizTalk Server während der Installation erstellt wird, der BizTalk Server Interchange Application. Standardmäßig wird die Identität dieser Anwendung als Interaktiver Benutzer erstellt. Wird dies nicht geändert, müssen Benutzer jedoch stets angemeldet sein, sobald programmgesteuerte Versendungen durchgeführt werden. Dies ist jedoch für die meisten Zwecke offensichtlich nicht akzeptabel. Informationen zum Konfigurieren der BizTalk Server Interchange Application für die Ausführung unter einem Dienstkonto finden Sie unter Ändern der Anwendungsidentität einer COM+-Anwendung.

Das programmgesteuerte Senden von Arbeitsobjekten an BizTalk Server 2002 durch einen Benutzer über die COM+-Schnittstelle IInterchange kann gesteuert werden, indem die COM+-Komponente BizTalk Server Interchange Application entsprechend konfiguriert wird. Um die Fähigkeit eines Benutzers zum programmgesteuerten Senden von Arbeitsobjekten zu steuern, muss zunächst eine Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) hinzugefügt werden. Dann muss die Rolle den Methoden Submit und SubmitSync zugeordnet werden, und schließlich muss das Benutzerkonto, dem Sie Zugriff auf die Methoden erteilen möchten, zur Rolle hinzugefügt werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Hinzufügen einer Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

  • Verknüpfen einer neuen Rolle mit den Methoden "Submit" und "SubmitSync"

Verwandtes Thema

Administratorrechte


Hinzufügen einer Rolle zur BizTalkServer Interchange Application

BizTalk Server 2002 ~ Sicherheit

Hinzufügen einer Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

Rollenmitgliedschaften müssen erstellt werden, um die Fähigkeit der verschiedenen Benutzer zu steuern, Arbeitsobjekte an die BizTalk Server-Austauschanwendung zu senden.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

    Die Konsole der Komponentendienste wird angezeigt.

  2. Erweitern Sie Komponentendienste, erweitern Sie Computer, dann Arbeitsplatz und anschließend COM+-Anwendungen.

  3. Klicken Sie mit der rechten Maustaste auf BizTalk Server Interchange Application , und klicken Sie auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server Interchange Application wird angezeigt.

  4. Klicken Sie auf die Registerkarte Erweitert, deaktivieren Sie unter Berechtigung das Kontrollkästchen Ändern deaktivieren. Klicken Sie auf OK, und klicken Sie dann im Meldungsdialogfeld auf Ja.

  5. Wiederholen Sie Schritt 3.

  6. Klicken Sie auf die Registerkarte Sicherheit, und aktivieren Sie unter Autorisierung das Kontrollkästchen Zugriffsüberprüfung für diese Anwendung erzwingen.

  7. Klicken Sie unter Sicherheitsstufe auf Zugriffsüberprüfung auf Prozess- und Komponentenebene durchführen. Die Sicherheitseigenschaft wird in den Objektkontext einbezogen. Der COM+-Sicherheitsaufruf ist verfügbar.

  8. Klicken Sie auf OK.

  9. Klicken Sie im Meldungsdialogfeld auf Ja.

  10. Erweitern Sie BizTalk Server Interchange Application.

  11. Doppelklicken Sie auf den Ordner Rollen, klicken Sie mit der rechten Maustaste auf den Ordner, zeigen Sie auf Neu, und klicken Sie dann auf Rolle.

    Das Dialogfeld Rolle wird angezeigt.

  12. Geben Sie einen Namen für die Rolle ein, und klicken Sie auf OK.

  13. Klicken Sie im Meldungsdialogfeld auf Ja.

  14. Erweitern Sie die zuvor erstellte Rolle, doppelklicken Sie auf den Ordner Benutzer, klicken Sie mit der rechten Maustaste auf Benutzer, zeigen Sie auf Neu, und klicken Sie dann auf Benutzer.

  15. Geben Sie in das Feld Benutzer oder Gruppen auswählen den vollständigen Namen des Benutzers ein, den Sie hinzufügen möchten.

  16. Klicken Sie nach dem Hinzufügen von Benutzerkonten zur Rolle auf OK.

Anmerkung

  • Für alle Benutzerkonten oder Gruppen, die der Rolle zugewiesen wurden, wird im Ordner Benutzer ein Symbol angezeigt. Die neue Rollenmitgliedschaft wird beim Starten der Anwendung aktiviert.

Verwandtes Thema

Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)


Verknüpfen einer neuen Rolle mit den Methoden "Submit" und "SubmitSync"

Sobald eine neue Rolle für die BizTalk Server-Austauschanwendung erstellt wurde, können die Methoden Submit und SubmitSync dieser zugeordnet werden.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

    Die Konsole der Komponentendienste wird angezeigt.

  2. Erweitern Sie Komponentendienste, Computer, Arbeitsplatz, COM+-Anwendungen, BizTalk Server Interchange Application, Komponenten, BizTalk.Interchange.1, Schnittstellen, IInterchange und dann Methoden.

  3. Klicken Sie mit der rechten Maustaste auf Submit und dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Submit wird angezeigt.

  4. Klicken Sie auf die Registerkarte Sicherheitseinstellungen.

  5. Aktivieren Sie unter Rollen explizit für ausgewählte Elemente festlegen das Kontrollkästchen der Rolle, die Sie zuvor unter Hinzufügen einer Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) erstellt haben, und klicken Sie auf OK.

  6. Klicken Sie mit der rechten Maustaste auf SubmitSync und dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von SubmitSync wird angezeigt.

  7. Klicken Sie auf die Registerkarte Sicherheitseinstellungen.

  8. Aktivieren Sie unter Rollen explizit für ausgewählte Elemente festlegen das Kontrollkästchen der Rolle, die Sie zuvor unter Hinzufügen einer Rolle zur BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) erstellt haben, und klicken Sie auf OK.

Verwandtes Thema

Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)


Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

Nach dem Installieren der BizTalk-Orchestrierungsdienste können Sie für Folgendes Sicherheitsebenen festlegen:

  • Erstellen neuer XLANG-Ablaufplaninstanzen

  • Interagieren mit vorhandenen XLANG-Ablaufplaninstanzen

  • Verwaltungsfunktionen für XLANG-Ablaufplaninstanzen

  • Anwendungen, die als Host für XLANG-Ablaufplaninstanzen dienen

Anwendungen, die als Host für XLANG-Ablaufplaninstanzen dienen, bauen auf der rollenbasierten Sicherheit auf, einem automatischen Dienst, der von COM+ bereitgestellt wird. Mithilfe der rollenbasierten Sicherheit können die Benutzer Zugriffsteuerungsrichtlinien für COM+-Anwendungen erstellen und erzwingen. Dank eines flexiblen und erweiterbaren Sicherheitskonfigurationsmodells bietet die rollenbasierte Sicherheit bedeutende Vorteile gegenüber dem Erzwingen der gesamten Sicherheit innerhalb von Komponenten. Es gibt zwei Standard-COM+-Anwendungen, die XLANG-Ablaufplanung (XLANG Scheduler) und XLANG-Hilfsprogrammkomponente für Ablaufplanungspersistenz (XLANG Scheduler Persistence Helper), die bei der Installation der BizTalk-Orchestrierungsdienste automatisch erstellt werden. Standardmäßig wird die Identität dieser Anwendungen als Interaktiver Benutzer konfiguriert. Wird dies nicht geändert, müssen Benutzer jedoch stets angemeldet sein, sobald Ablaufpläne aufgerufen werden bzw. auf diese zugegriffen wird. Dies ist jedoch für die meisten Zwecke offensichtlich nicht akzeptabel. Informationen zum Konfigurieren der BizTalk Server-Austauschanwendung für die Ausführung unter einem Dienstkonto finden Sie unter Ändern der Anwendungsidentität einer COM+-Anwendung.

Die COM+-Anwendung XLANG-Ablaufplanung (XLANG Scheduler) hat vier Rollen, mit denen die Sicherheit von Ablaufplaninstanzen ungeachtet der COM+-Anwendung gewährleistet werden kann, in der diese ausgeführt werden. Die Namen dieser vier Rollen lauten:

  • XLANG-Ablaufplanersteller. Mithilfe dieser Rolle können angegebene Benutzer XLANG-Ablaufplaninstanzen erstellen. Wenn ein Administrator einem Benutzer z. B. das Erstellen einer XLANG-Ablaufplaninstanz ermöglichen möchte, muss er den Benutzer zur Mitgliederliste dieser Rolle hinzufügen. Ein Benutzer, der nicht als Mitglied dieser Rolle aufgeführt ist, und versucht, eine XLANG-Ablaufplaninstanz zu erstellen, erhält eine Fehlermeldung, die besagt, dass der Zugriff verweigert wurde. Darüber hinaus wird im Ereignisprotokoll ein Eintrag mit entsprechenden Informationen generiert.

  • XLANG-Ablaufplanbenutzer. Mithilfe dieser Rolle können angegebene Benutzer mit XLANG-Ablaufplaninstanzen interagieren. Wenn ein Administrator einem Benutzer z. B. das Interagieren mit einer Ablaufplaninstanz ermöglichen möchte, muss er den Benutzer der Mitgliederliste dieser Rolle hinzufügen. Ein Benutzer, der nicht als Mitglied dieser Rolle aufgeführt ist und versucht, mit einer Ablaufplaninstanz zu interagieren, erhält eine Fehlermeldung, die besagt, dass der Zugriff verweigert wurde. Darüber hinaus wird im Ereignisprotokoll ein Eintrag mit entsprechenden Informationen generiert.

  • XLANG-Ablaufplanungsadministrator. Mithilfe dieser Rolle wird angegeben, wer über Administratorrechte für die folgenden Aufgaben verfügen soll:
    • Ermitteln, ob eine COM+-Anwendung als Host für XLANG-Ablaufplaninstanzen dienen kann.

    • Festlegen des DSN-Typs einer COM+-Anwendung, die als Host für XLANG-Ablaufplaninstanzen dient, und des Statusverwaltungswertes der Persistenzebene, die die COM+-Anwendung unterstützen muss.

    • Herunterfahren aller XLANG-Ablaufplaninstanzen.

    • Anhalten, Fortsetzen oder Beenden einer XLANG-Ablaufplaninstanz.
  • XLANG-Ablaufplanungsanwendung. Diese Rolle wird von der XLANG-Ablaufplanung für die Interaktion mit einer beliebigen vom Benutzer erstellen COM+-Anwendung verwendet. Aus diesem Grund muss die Rolle dieselbe Identität beinhalten, die von der COM+-Anwendung für die Ausführung verwendet wird.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Empfohlene Vorgehensweisen für das Sichern von COM+-Anwendungen

  • Sichern der Persistenzdatenbank für die Orchestrierung

  • Bestätigen der Absenderidentität

Verwandtes Thema

XLANG-Ablaufpläne


Empfohlene Vorgehensweisen für das Sichern von COM+-Anwendungen

Mithilfe von Rollen kann ein Administrator Autorisierungsrichtlinien für eine Anwendung erstellen und auswählen (ggf. bis hinunter auf die Methodenebene), welche Benutzer auf welche Ressourcen zugreifen dürfen. Da für alle XLANG-Ablaufpläne COM+Serveranwendungen als Host dienen, kann der Zugriff auf die installierten COM-Objekte eingeschränkt werden, indem für verschiedene Rollen Sicherheitseigenschaften konfiguriert werden.

Wichtig

  • Wenn auf der Komponentenebene Sicherheitseigenschaften hinzugefügt werden, werden einzelne Komponenten, Schnittstellen und Methoden, die auf den Rolleneinstellungen auf diesen Ebenen basieren, ebenfalls eingeschränkt. Weitere Informationen zur COM+-Sicherheit finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach der Seite "Security in COM+".

Empfehlungen für das Sichern von COM+-Anwendungen

Die folgenden Empfehlungen gelten in erster Linie für das Sichern bereitgestellter Anwendungen:

  • Konfigurieren Sie eine COM+-Anwendung nicht mit interaktiver Benutzeridentität. COM+-Anwendungen, welche die interaktive Benutzeridentität verwenden, können nur verwendet werden, wenn sich ein Benutzer bei dem Computer anmeldet, auf dem sich die Anwendung befindet. Ist kein Benutzer angemeldet, kann die COM+-Anwendung nicht ausgeführt werden. Wenn ein Benutzer eine COM+-Anwendung mithilfe der interaktiven Benutzeridentität erstellt, wird es schwieriger, den Zugriff auf die entsprechende Persistenzdatenbank und andere Ressourcen zu konfigurieren.

  • Konfigurieren Sie die Identität der XLANG-Ablaufplanung (XLANG Scheduler) neu. Während der Installation wird die XLANG-Ablaufplanung automatisch als Interaktiver Benutzer konfiguriert. Diese Konfiguration ist für die meisten Entwickler geeignet. In Produktionssystemen müssen Sie die Identitätseigenschaft der XLANG-Ablaufplanung (XLANG Scheduler) ändern, damit die Anwendung unter einem eindeutigen Benutzerkonto ausgeführt wird. Die Identität wird von allen Nachrichten verwendet, die von der XLANG-Ablaufplanung (XLANG Scheduler) gesendet werden.

    Anmerkung

    • Wenn der Client der Microsoft Windows 2000 Terminaldienste zum Initiieren eines XLANG-Ablaufplanes verwendet wird, muss die Identität der COM+-Anwendung, die als Host für das XLANG-Ablaufplanungsmodul dient, auf einen gültigen Windows 2000-Benutzer- oder -Gruppennamen festgelegt werden. Die Identität der COM+-Anwendung wird auf der Registerkarte Identität des Dialogfeldes für die Eigenschaften der Anwendung festgelegt. Die Identität darf nicht auf interaktiv festgelegt werden, wenn das XLANG-Ablaufplanungsmodul in einer Sitzung verwendet wird, für die die Terminaldienste als Host dienen.
  • Erstellen Sie eine neue COM+-Anwendung mit einer eindeutigen Identität für alle Hostanwendungen für XLANG-Ablaufplaninstanzen. Erstellen Sie für jeden Geschäftsprozess, z. B. Einkauf, eine neue COM+-Anwendung mit eindeutigen Sicherheitsanforderungen. Auf diese Weise können für jede Anwendung individuelle Sicherheitsebenen angeben werden. Darüber hinaus wird ein Schutz vor großen Schäden bereitgestellt, die durch instabilen Anwendungscode verursacht werden können. Auch das Überwachen der Operationen einzelner Anwendungen wird erleichtert.

  • Installieren Sie anwendungsspezifische Komponenten in die zugeordneten Geschäftsprozesse. Auf diese Weise werden Daten geschützt und Anwendungen ausgeschlossen, die keinen Zugriff auf diese Komponenten haben. Voraussetzung dafür ist, dass die Serveranwendung entsprechend geschützt ist.

    Anmerkung

    • Jede COM+-Anwendung muss mindestens eine Komponente enthalten. Wenn keine anwendungsspezifische Komponente installiert ist, muss in der Anwendung eine Platzhalterkomponente erstellt und installiert werden. Andernfalls steht die COM+-Anwendung nicht zur Verfügung.
  • Ändern Sie die Standardeinstellungen für die Mitgliederliste der Rollen der XLANG-Ablaufplanung (XLANG Scheduler), um die Sicherheit zu erhöhen. Bei der Installation von BizTalk Server wird die XLANG-Ablaufplanung (XLANG Scheduler) mit den folgenden Rollen und Standardeinstellungen erstellt und konfiguriert:
    • XLANG-Ablaufplanersteller. Standardeinstellung für die Rollenmitgliedschaft: Jeder.

    • XLANG-Ablaufplanbenutzer. Standardeinstellung für die Rollenmitgliedschaft: Jeder.

    • XLANG-Ablaufplanungsadministrator. Standardeinstellung für die Rollenmitgliedschaft: Administratoren.

    • XLANG-Ablaufplanungsanwendung. Standardeinstellung für die Rollenmitgliedschaft: Jeder.

Verwandte Themen

Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne

XLANG-Ablaufpläne


Sichern der Persistenzdatenbank für die Orchestrierung

Wenn eine COM+-Anwendung erstellt wird, die als Host für XLANG-Ablaufplaninstanzen dient, muss der COM+-Anwendung eine Persistenzdatenbank zugeordnet werden. Erstellen Sie deshalb zuerst in Microsoft SQL Server eine Persistenzdatenbank. Nach Erstellen der Datenbank müssen Benutzer, falls der Datenquellenname (DSN) der XLANG-COM+-Anwendungsdatenbank für die Verwendung integrierter Sicherheit konfiguriert ist, eine SQL-Anmeldung erstellen und dem Identitätskonto der COM+-Anwendung, die später erstellt wird, um als Host für XLANG-Ablaufplaninstanzen zu dienen, db_owner-Rechte erteilen. Stellen Sie sicher, dass die COM+-Anwendung über Berechtigungen zum Erstellen von Tabellen und Prozeduren in der zugeordneten Persistenzdatenbank verfügt. Standardmäßig basiert die Interaktion zwischen den BizTalk-Orchestrierungsdiensten und der BizTalk Server-Standardpersistenzdatenbank für die Orchestrierung auf dem Sicherheitsmodell von Windows 2000 und nicht auf dem von SQL Server.

Verwandtes Thema

Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)


Bestätigen der Absenderidentität

Während des Ablaufplanentwurfs können verschiedene Formen verwendet werden, um die Implementierungstechnologien zu beschreiben, die zum Implementieren eines Ports in einen Geschäftsprozess verwendet werden. Die folgenden Formen beschreiben diese Technologien:

  • Die COM-Komponente-Form stellt eine Technologie dar, mit der ein Port mithilfe eines Methodenaufrufs für jede Nachricht implementiert werden kann, die gesendet oder empfangen wird.

  • Mit der Skriptkomponente-Form kann mithilfe eines Methodenaufrufs für jede gesendete oder empfangene Nachricht ein Port implementiert werden.

  • Die Message Queuing-Form stellt eine Technologie dar, mit der ein Port implementiert wird. Die Message Queuing-Transportdienste werden zum Senden und Empfangen von Nachrichten verwendet.

Wird eine der drei Technologien hinzugefügt, kann ein Benutzer fordern, dass vor dem Empfang von Nachrichten die Absenderidentität bestätigt werden muss. Wird die Identität des Absenders benötigt, wird die Identität des Windows-Benutzerkontos (Domäne\Benutzer) der Person, die diese Komponente aufgerufen hat, im Absenderfeld der Nachricht platziert.

Weitere Informationen zu COM-Komponenten, Windows-Skriptkomponenten oder zur Message Queuing-Sicherheit für XLANG-Ablaufpläne finden Sie unter Implementieren eines Ports mithilfe einer COM-Komponente, Implementieren eines Ports mithilfe einer Windows Script-Komponente und Implementieren eines Ports mithilfe von Message Queuing.

Verwandte Themen

Verwenden der COM-Komponente-Form

Verwenden der Message Queuing-Form

Verwenden der Skriptkomponente-Form


Benutzer des BizTalk-Serverberichts (Gruppe)

BizTalk Server 2002 erstellt während der Installation eine Windows-Gruppe auf dem lokalen Computer, deren Mitgliedern Rechte zur Verwendung der Benutzeroberfläche der BizTalk-Dokumentüberwachung und zum Anzeigen der überwachten Dokumente erteilt werden. Standardmäßig heißt diese Gruppe Benutzer des BizTalk-Serverberichts, allerdings können Benutzer diesen Namen während der Installation ändern. Nach der Installation ist eine Änderung des Namens jedoch nicht mehr möglich. Bei der Installation fügt BizTalk Server die integrierte Gruppe der lokalen Administratoren sowie das aktuell angemeldete Benutzerkonto zu dieser Gruppe hinzu.

Außerdem erteilt BizTalk Server während der Installation Zugriffsberechtigungen für diese Gruppe, die Gruppe der lokalen Administratoren sowie für das aktuell angemeldete Benutzerkonto an das Dateiverzeichnis, in dem sich die webbasierte Benutzeroberfläche der BizTalk-Dokumentüberwachung befindet, nämlich \Programme\Microsoft BizTalk Server\BizTalkTracking.

Benutzer, die Zugriff benötigen, um die Benutzeroberfläche der BizTalk-Dokumentüberwachung verwenden und Überwachungsdokumente anzeigen zu können, müssen Mitglied der Gruppe Benutzer des BizTalk-Serverberichts sein und Zugriff auf die Überwachungsdatenbank haben, d. h. eine Anmeldung für den SQL-Server besitzen, der als Host für die Überwachungsdatenbank dient, und Mitglied der Rolle db_owner für diese Datenbank sein.


Transportdienste

Microsoft BizTalk Server 2002 unterstützt eine Kerngruppe von Transportdiensten. Unter Verwendung dieser Transportdienste kann ein Server Dokumente an Organisationen oder Anwendungen senden. Dabei ist es unerheblich, ob die Anwendungen mithilfe einer COM-Schnittstelle (Component Object Model) direkt mit dem Server kommunizieren können. BizTalk Server unterstützt die Netzwerkprotokolle HTTP, HTTPS und SMTP sowie Message Queuing.

Folgende Themen werden in diesem Abschnitt behandelt:

  • HTTP und HTTPS

  • SMTP

  • Message Queuing 2.0

  • Datei

Verwandte Themen

Auswählen eines Transporttyps

Festlegen von Transporteigenschaften


HTTP und HTTPS

HTTPS stellt eine zuverlässige Authentifizierung bereit, wenn mithilfe von Hypertext Transfer Protocol (HTTP) auf Webinhalte zugegriffen wird. Secure Hypertext Transfer Protocol (HTTPS) wird am häufigsten verwendet, um eine verschlüsselte Verbindung mit einem authentifizierten Webserver herzustellen. Wenn Clients versuchen, eine HTTPS-Verbindung herzustellen, wozu in der Regel ein mit https:// beginnender URL in den Browser eingegeben wird, handeln Client und Server gemeinsam das zu verwendende Sicherheitsprotokoll aus und tauschen anschließend die Authentifizierungsinformationen aus.

Microsoft Internet Explorer 5 oder höher unterstützt für HTTP-Transaktionen allgemein übliche sichere Kommunikationsprotokolle. Dazu zählen u. a. die folgenden Kommunikationsprotokolle:

  • Transport Layer Security (TLS, Version 1.0)

  • Secure Sockets Layer (SSL, Version 2 und 3)

  • Private Communications Technology (PCT, Version 1.0).

Diese Protokolle bieten Verschlüsselungsdienste (zum Schutz der Vertraulichkeit ausgetauschter Daten) und Authentifizierungsdienste (für die gegenseitige Identifikation zwischen Clients und Servern). Die SSL-Unterstützung, die über den integrierten HTTPS-Transportdienst bereitgestellt wird, fügt zu einem Austausch die Authentifizierungen zwischen Servern und die Verschlüsselung auf der Transportebene hinzu.

Mithilfe von BizTalk Server und HTTPS können Daten innerhalb einer Organisation oder mit einem Handelspartner über HTTP sicher ausgetauscht werden. Im Folgenden werden detaillierte Informationen dazu bereitgestellt, wie BizTalk Server 2002 HTTP und HTTPS zum Senden und Empfangen von Daten verwendet:

Senden

Der HTTP- und der HTTPS-Transportdienst können zum Schutz von Daten verwendet werden, die an eine Anwendung oder einen Handelspartner gesendet werden. Die Sicherheit dieser Transportdienste basiert auf Zertifikaten.

Vor dem Senden von Daten über HTTP sendet ein BizTalk Server-Administrator z. B. eine Kopie eines Clientzertifikats an einen Handelspartner. Der Handelspartner behält eine Kopie des Zertifikats im BizTalk-Speicher. Künftig wird das Zertifikat verwendet, um den Daten sendenden Handelspartner zu authentifizieren. Um ein Zertifikat an einen Handelspartner zu senden oder zu exportieren, muss eine eindeutige Zertifikatsverwaltung erstellt werden.

Empfangen

BizTalk Server verwendet Microsoft Internet-Informationsdienste (IIS, Internet Information Services) und ASP-Seiten, um die Übertragung von Daten über HTTP zu sichern. Beim Verwenden von HTTPS zum Verbinden mit IIS handeln Client und Browser ein gemeinsames Protokoll aus, um den Kanal zu sichern. In Fällen, in denen Server und Client mehrere Protokolle gemeinsam haben, schützt IIS den Kanal mit einem unterstützten Protokoll, z. B. SSL. Der Prozess zum Schützen von Daten, die von BizTalk Server über HTTP empfangen werden, ist identisch. Die ASP-Seite dient als Gateway für das Senden von Daten an BizTalk Server. Wenn die Daten sicher sind, empfängt BizTalk Server die Daten unter der Voraussetzung, dass der ASP-Code für einen Aufruf die Methoden Submit oder SubmitSync verwendet.

Verwandte Themen

Auswählen eines Transporttyps

Festlegen von Transporteigenschaften


SMTP

Simple Mail Transfer Protocol (SMTP) ist ein Protokoll für das Senden von E-Mail-Nachrichten zwischen Servern. SMTP ist ein verbreitetes Protokoll zum Senden von E-Mail über das Internet. Eine E-Mail-Nachricht kann mit einem E-Mail-Client mithilfe von Post Office Protocol (POP) oder Internet Message Access Protocol (IMAP) empfangen werden. Darüber hinaus wird SMTP zum Senden von Nachrichten von einem Mailclient an einen Mailserver verwendet. Bei der Konfiguration einer E-Mail-Anwendung müssen sowohl der POP-Server oder IMAP-Server als auch der SMTP-Server angegeben werden.

Mithilfe von SMTP können Daten innerhalb einer Organisation oder mit einem Handelspartner sicher ausgetauscht werden. BizTalk Server 2002 verwendet SMTP, um mithilfe der folgenden Methoden Daten zu senden und zu empfangen:

Senden

BizTalk Server implementiert ein Transportprotokoll, um Daten über SMTP zu senden. Die Mindestanforderung von SMTP ist, dass die Daten MIME-codiert sind. Durch diesen Prozess kann BizTalk Server identifizieren, wo eine Datenmenge endet und die nächste beginnt. Die MIME-Codierung bietet jedoch keine Datensicherheit. Die sichere Version von MIME ist S/MIME. Dokumente, die mithilfe integrierter S/MIME-Codierungskomponenten verschlüsselt werden, sichern die Dokumentintegrität, die Authentifizierung des Absenders und die Nutzlastverschlüsselung. BizTalk Server erstellt ein S/MIME-Dokument mit der verschlüsselten Nachricht als Textkörper des Dokuments. Der MIME-codierten Nachricht muss ein Zertifikat zugeordnet werden, um diese Sicherheitsebene hinzuzufügen. Die MIME-Codierung kann angegeben werden, wenn Messagingports im BizTalk-Messaging-Manager erstellt werden. Hier werden auch die Zertifikate angegeben.

Empfangen

Ein Administrator muss ein Empfangskonto für BizTalk Server erstellen, um die Sicherheit auf der Empfängerseite von SMTP unter Verwendung von Microsoft Exchange Server zu implementieren. Nach dem Einrichten des Kontos können Handelspartner ihre öffentlichen Schlüssel an Exchange Server senden, woraufhin die Anwendung den Absender (Handelspartner) authentifiziert. Die öffentlichen Schlüssel werden zum Exchange Server-Zertifikatspeicher hinzugefügt.

Wenn Exchange Server eine Nachricht empfängt, sendet die Submit-Methode die Daten an BizTalk Server. BizTalk Server überprüft das Zertifikat anhand des öffentlichen Schlüssels. Stimmen beide überein, entschlüsselt BizTalk Server die Daten und verarbeitet das Dokument.

Verwandte Themen

Messagingportelemente

Auswählen eines Transporttyps

Auswählen eines Verschlüsselungszertifikats

Festlegen von Transporteigenschaften


Message Queuing2.0

BizTalk Server 2002 ~ Sicherheit

Message Queuing 2.0

Message Queuing 2.0 unterstützt Datenschutz und Sicherheit durch folgende Funktionen:

  • Zugriffssteuerung

  • Überwachung

  • Verschlüsselung

  • Authentifizierung

Message Queuing verwendet auch das in Microsoft Windows 2000 enthaltene Sicherheitsprotokoll Kerberos V5 und unterstützt darüber hinaus die 128-Bit- und 40-Bit-Verschlüsselung. Message Queuing kann auch verwendet werden, um Anwendungen zu integrieren und um eine PUSH-orientierte Umgebung zwischen Anwendungen zur Übermittlung von Geschäftsereignissen zu implementieren. Außerdem können mithilfe von Message Queuing zuverlässige Anwendungen erstellt werden, die in nicht zuverlässigen, jedoch kostengünstigen Netzwerken eingesetzt werden.

Mithilfe von Message Queuing können Daten innerhalb einer Organisation oder mit einem Handelspartner sicher ausgetauscht werden. BizTalk Server 2002 verwendet Message Queuing, um mithilfe der folgenden Methoden Daten zu senden und zu empfangen:

Senden

Die erste Sicherheitsebene für Message Queuing bilden ein Benutzername und ein Kennwort, die angegeben werden müssen, um Daten in Message Queuing zu speichern oder daraus abzurufen. Darüber hinaus kann Message Queuing Daten speichern, die über ein Zertifikat verfügen. Im BizTalk-Messaging-Manager können die Benutzer ein Zertifikat für Daten angeben, die in einer Nachrichtenwarteschlange gespeichert sind.

Empfangen

Wenn ein Administrator für eine Nachrichtenwarteschlange Anmeldeeigenschaften erstellt, müssen zum Abrufen der Daten ein Benutzername und ein Kennwort angegeben werden. Das Erstellen von Anmeldeeigenschaften stellt eine grundlegende Sicherheitsebene dar. Wenn ein Handelspartner ein Zertifikat zu den Daten hinzugefügt hat, muss eine Kopie seines privaten Schlüssels empfangen werden, um die Daten zu entschlüsseln, bevor BizTalk Server das Paket verarbeiten kann.

Verwandte Themen

Hinzufügen einer Message Queuing-Empfangsfunktion

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"

Auswählen eines Transporttyps

Festlegen von Transporteigenschaften


Datei

Microsoft Windows 2000 sichert Daten- und Systemschutz durch die Definition einer wahlfreien Dateizugriffssteuerung. Das für BizTalk Server 2002 erforderliche Windows NTFS-Dateisystem kann Benutzer am Beschädigen von wichtigen System- und Anwendungsdateien hindern. NTFS bietet ferner einen zuverlässigen Schutz für die Hilfsdateien in einer Anwendung.

Mithilfe der Dateispeicherung können Daten innerhalb einer Organisation oder mit einem Handelspartner sicher ausgetauscht werden. Die Dateispeicherung kann auch verwendet werden, um Daten auf folgende Weise zu senden und zu empfangen:

Senden

Die erste Sicherheitsebene für die Dateispeicherung bilden ein Benutzername und ein Kennwort. Benutzername und Kennwort werden von jedem benötigt, der Daten in einem Ordner speichert bzw. aus diesem abruft. Darüber hinaus können in Ordnern Daten gespeichert werden, die über ein zugeordnetes Zertifikat verfügen. Erstellen Sie mit dem BizTalk Messaging Manager ein Zertifikat für die Daten, die in einem Ordner gespeichert werden sollen, um diese weitere Sicherheitsebene zu verwenden.

Empfangen

Wenn einem Ordner Anmeldeeigenschaften zugewiesen wurden, müssen zum Abrufen der Daten ein Benutzername und ein Kennwort angegeben werden. Der Administrator kann für bestimmte Benutzer verschiedene Zugriffsstufen (Lesen, Löschen usw.) für das Dateiverzeichnis bestimmen. Wenn ein Handelspartner ein Zertifikat zu den Daten hinzugefügt hat, muss eine Kopie seines privaten Schlüssels empfangen werden, um die Daten zu entschlüsseln, bevor BizTalk Server das Paket verarbeiten kann. Eingehende Dokumente können auch digital signiert werden, um sicherzustellen, dass der Absender das Senden des Dokuments nicht bestreiten kann.

Verwandte Themen

Hinzufügen einer Dateiempfangsfunktion

Konfigurieren von erweiterten Eigenschaften für Datei- oder Message Queuing-Empfangsfunktionen

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

Auswählen eines Transporttyps

Festlegen von Transporteigenschaften


Zertifikate - Übersicht

Digitale Zertifikate binden einen kryptografischen Schlüssel an ein oder mehrere Attribute eines Benutzers. Die von Zertifizierungstellen ausgestellten Zertifikate schützen das Internet, indem die Authentizität von Netzwerknachrichten zugesichert wird. Diese Technologie sowie die dazugehörigen digitalen Signaturen treiben gegenwärtig die Bereitstellung des E-Commerce im Internet voran.

In diesem Abschnitt werden folgende Themen und Verfahren behandelt:

  • Grundlegendes zu Zertifikaten

  • Von BizTalk Server benötigte Zertifikate

  • Beschränkungen für Zertifikatsnamen


Grundlegendes zu Zertifikaten

Microsoft BizTalk Server 2002 basiert grundlegend auf den von Zertifikaten bereitgestellten Sicherheitsfunktionen. Durch die Verwendung öffentlicher Schlüssel zur Verschlüsselung der Daten und privater Schlüssel zur Datenentschlüsselung kann BizTalk Server vertrauenswürdige Daten senden und die Sicherheit der verarbeiteten Daten gewährleisten. Die zur Microsoft Management Console (MMC) gehörenden Richtlinien öffentlicher Schlüssel ermöglichen die Konfiguration von Agents für die Wiederherstellung verschlüsselter Daten für das Verschlüsselnde Dateisystem (Encrypting File System, EFS), domänenweite Stammzertifizierungsstellen, vertrauenswürdige Zertifizierungsstellen usw. Zertifikate enthalten ferner digitale Signaturen, die auf Dokumente angewendet und bei eingehenden Dokumenten mithilfe der systemeigenen Unterstützung von BizTalk Server für digitale Signaturen überprüft werden können.

Zertifikate werden für die Authentifizierung und die Sicherheit des Austauschs von Informationen in ungesicherten Netzwerken, z. B. dem Internet, verwendet. Zertifikate können für einen Benutzer, einen Computer oder einen Dienst verwaltet werden. Der in Windows 2000 integrierte, auf X.509 basierende Zertifikatsserver für öffentliche Schlüssel ermöglicht Organisationen das Ausstellen von Zertifikaten öffentlicher Schlüssel für die Authentifizierung ihrer Benutzer, ohne von den Diensten kommerzieller Zertifizierungsstellen abhängig zu sein.

BizTalk Server unterstützt Zertifikate mithilfe des BizTalk-Messaging-Managers. Zertifikate erleichtern die Ver- und Entschlüsselung von Daten sowie ihre digitale Signatur. Die Verschlüsselung öffentlicher Schlüssel wird für alle Dokumente unterstützt, die mithilfe von BizTalk Server-Transportdiensten übermittelt werden. BizTalk Server unterstützt darüber hinaus die Entschlüsselung und Signaturüberprüfung für empfangene Dokumente.

Anmerkung

  • Bei der Verarbeitung von S/MIME-Nachrichten überprüft das BizTalk Server-Modul das Zertifikat, um sicherzustellen, dass es noch nicht abgelaufen ist. Zur Laufzeit wird von BizTalk Server jedoch nicht geprüft, ob ein Zertifikat widerrufen wurde oder ob ein Zertifikat ein gültiges und vertrauenswürdiges Stammzertifikat besitzt.

Computerschlüssel und Benutzerschlüssel: Vergleich

Beim Abrufen von Zertifikaten sollten dem Computer zugeordnete Computerschlüssel verwendet werden und nicht Benutzerschlüssel, die dem aktuell angemeldeten Benutzer zugeordnet sind. Wenn ein aktuell bei einem Server angemeldeter Benutzer ein Zertifikat mit Benutzerschlüsseln abruft, kann nur dieser Benutzer auf das Zertifikat zugreifen, da das Zertifikat Benutzerschlüssel die Anmeldeinformationen dieses Benutzers enthält. Wenn demnach ein Benutzer auf Zertifikate mit Benutzerschlüsseln in BizTalk Server zugreifen muss, muss BizTalk Server im Kontext dieses Benutzers ausgeführt werden. Damit alle Benutzer sich bei BizTalk Server anmelden und auf Schlüssel zugreifen können, müssen Zertifikate über Computerschlüssel verfügen.

Damit BizTalk Server auf die Zertifikate (Lokaler Computer) zugreifen kann, muss entweder BizTalk Server als Lokales System oder Administrator ausgeführt werden oder die Sicherheitseinstellungen des Registrierungsschlüssel HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates müssen geändert werden. Wenn Benutzerschlüssel verwendet werden, muss BizTalk Server außerdem im Kontext dieses Benutzers ausgeführt werden, der auch Administrator sein muss oder Berechtigungen für den erwähnten Registrierungsschlüssel erhalten muss.

Wenn Sie zum Ausführen von BizTalk Server kein Administratorkonto verwenden möchten, jedoch trotzdem Zertifikate verwenden müssen, erteilen Sie dem Konto, unter dem der BizTalk-Messagingdienst ausgeführt wird, vollständige Berechtigungen für den Registrierungsschlüssel HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates.

Folgendes Verfahren wird in diesem Abschnitt behandelt:

  • Konfigurieren von Registrierungsberechtigungen für Zertifikate


Konfigurieren von Registrierungsberechtigungen für Zertifikate

So ändern Sie die Registrierungsberechtigungen für Zertifikate in Windows 2000

  1. Klicken Sie auf Start, klicken Sie auf Ausführen, und geben Sie dann regedt32.exe ein.

  2. Klicken Sie auf OK.

  3. Suchen Sie den folgenden Registrierungsschlüssel:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates

  4. Klicken Sie im Menü Sicherheit auf Berechtigungen, und erteilen Sie dem entsprechenden Konto vollständige Kontrollberechtigungen für diesen Registrierungsschlüssel.

Warnung

  • Bevor Sie die Registrierung bearbeiten, sollten Sie sicher sein, dass Sie im Falle eines Problems wissen, wie Sie diese wiederherstellen können. Weitere Informationen finden Sie unter "Registrierungsschlüssel" und "Registrierungsverwaltung" in der Windows 2000-Hilfe. Beachten Sie, dass Sie die Registrierung vor der Bearbeitung sichern sollten. Wenn Sie Windows 2000 ausführen, sollten Sie außerdem die Notfalldiskette aktualisieren.

  • Die unsachgemäße Verwendung des Registrierungs-Editors kann zu ernsthaften Problemen führen, die eine Neuinstallation Ihres Betriebssystems erfordern können. Microsoft kann keine Garantie dafür übernehmen, dass Probleme, die durch die falsche Verwendung des Registrierungs-Editors verursacht werden, sich beheben lassen. Verwenden Sie den Registrierungs-Editor auf eigenes Risiko.


Von BizTalkServer benötigte Zertifikate

BizTalk Server 2002 ~ Sicherheit

Von BizTalk Server benötigte Zertifikate

Ein Zertifikatsserver speichert Zertifikate für einen Benutzer und einen Computer. Benutzer und Computer verfügen über eigene Zertifikatsspeicher. Wenn ein Benutzer ein Zertifikat erstellt, setzt Windows 2000 voraus, dass das Zertifikat für den Benutzer vorgesehen ist. Eine Organisation muss ihre Zertifikate im privaten Speicher ablegen, der in der Konsole Zertifikate unter Zertifikate (Lokaler Computer) zu finden ist. Wenn jedoch zur Entwurfszeit Messagingports und Kanäle erstellt werden, muss ein Benutzer über alle Handelspartnerzertifikate verfügen, die dem BizTalk-Speicher in der Konsole Zertifikate unter Zertifikate (Lokaler Computer) und nicht dem Benutzer zugeordnet sind.

Außerdem handelt es sich beim Angeben der Sicherheit, z. B. Verschlüsselung oder Signaturüberprüfung, für Handelspartner mithilfe des BizTalk-Messaging-Managers bei den angezeigten Zertifikaten um die Handelspartnerzertifikate im BizTalk-Speicher. Der BizTalk-Messaging-Manager zeigt die Zertifikate im privaten Speicher unter Zertifikate (Lokaler Computer) der Konsole Zertifikate an, wenn für SSL-Clients die Sicherheit angegeben wird, z. B. überprüfte Entschlüsselung und Signatur. Der Speicherort der Zertifikate spielt eine wichtige Rolle. Wenn nämlich ein Benutzer zur Laufzeit versucht, Dokumente mithilfe von BizTalk Server zu verarbeiten, fungiert der Computer als Hintergrunddienst, und gerade dieser Dienst muss auf die Zertifikate zugreifen können.

Es gibt zwei Möglichkeiten, Probleme hinsichtlich des Speicherortes von Zertifikaten zu beheben:

  • Wenn ein Benutzer bereits Zertifikate erstellt hat, wurden diese von Windows 2000 im Benutzerspeicher gespeichert. Die Zertifikate müssen aus dem Benutzerspeicher in den entsprechenden Speicher unter Zertifikate (Lokaler Computer) verschoben werden. Dieser Prozess erfolgt über die Zertifikatsverwaltung.

  • Wenn ein Benutzer ein Dienstkonto erstellt hat, werden alle Zertifikate dem Computer und nicht dem Benutzer zugeordnet.

Zertifikatsverwaltung über Windows 2000

Die Zertifikatsverwaltung in BizTalk Server erfolgt über Microsoft Windows 2000. Eng integriert in das Windows 2000-Sicherheitsmodell sind Internet-Informationsdienste 5.0 (IIS, Internet Information Services), die einen Zertifikatsserver enthalten. Dieser ermöglicht Organisationen das Ausstellen und Verwalten digitaler dem Internetstandard X.509 entsprechender Zertifikate. Neben den Schlüsselverwaltungsdiensten stellt IIS 5.0 auch den Microsoft Zertifikatsserver bereit, der anpassbare Dienste für das Ausstellen und Verwalten digitaler Zertifikate zur Verfügung stellt. Ein Zertifikatsserver spielt eine zentrale Rolle bei der Verwaltung von Softwaresicherheitssystemen und ermöglicht sichere Datenübertragungen über das Internet, über Firmennetzwerke und über andere ungesicherte Netzwerke.

Folgendes Verfahren wird in diesem Abschnitt behandelt:

  • Erstellen einer Zertifikatsverwaltung für BizTalk Server

Verwandte Themen

Auswählen eines Zertifikats für die ausgehende Signatur

Auswählen eines Zertifikats zum Überprüfen der Entschlüsselung eingehender Dokumente

Auswählen eines Zertifikats zum Überprüfen der Signatur eingehender Dokumente

Auswählen eines Verschlüsselungszertifikats


Erstellen einer Zertifikatsverwaltung für BizTalkServer

BizTalk Server 2002 ~ Sicherheit

Erstellen einer Zertifikatsverwaltung für BizTalk Server

BizTalk Server erfordert, dass alle Handelspartnerzertifikate dem BizTalk-Speicher in der Konsole Zertifikate unter Zertifikate (Lokaler Computer) und nicht dem Benutzer zugeordnet sind.

  1. Klicken Sie im Startmenü auf Ausführen, geben Sie mmc ein, und klicken Sie dann auf OK.

    Das Dialogfeld Konsole1 wird angezeigt.

  2. Klicken Sie im Menü Konsole auf Snap-In hinzufügen/entfernen.

    Das Dialogfeld Snap-In hinzufügen/entfernen wird angezeigt.

  3. Klicken Sie auf Hinzufügen.

    Das Dialogfeld Eigenständiges Snap-In hinzufügen wird angezeigt.

  4. Klicken Sie auf Zertifikate und dann auf Hinzufügen.

    Das Dialogfeld Zertifikat-Snap-In wird angezeigt.

  5. Klicken Sie auf Computerkonto, dann auf Weiter und anschließend auf Fertig stellen.

  6. Klicken Sie im Dialogfeld Eigenständiges Snap-In hinzufügen auf Zertifikate und dann auf Hinzufügen.

    Das Dialogfeld Zertifikat-Snap-In wird angezeigt.

  7. Wählen Sie Eigenes Benutzerkonto aus, und klicken Sie auf Fertig stellen. Klicken Sie dann auf Schließen. Klicken Sie auf OK, um das Dialogfeld zu schließen.

  8. Klicken Sie im Menü Konsole auf Speichern.

    Das Dialogfeld Speichern unter wird angezeigt.

  9. Wählen Sie den Speicherort aus, an dem Sie die Zertifikatsverwaltung speichern möchten (Standard ist der Ordner Verwaltung), geben Sie den gewünschten Namen für die Zertifikatsverwaltung ein, und klicken Sie dann auf Speichern.

Anmerkungen

  • Diese Aufgabe muss von einem Mitglied der Gruppe BizTalk Server-Administratoren durchgeführt werden.

  • Wenn Sie bereits über eine Zertifikatsverwaltung für Ihr Benutzerkonto verfügen, öffnen Sie die Zertifikatsverwaltung, und führen Sie die Schritte 2 bis 6 durch, um ein Computerkonto zu erstellen.

  • Sobald Zertifikate erstellt wurden, müssen sie aus dem Benutzerspeicher verschoben werden, um das Zertifikats-Snap-In für das Computerkonto hinzuzufügen.

Verwandtes Thema

Zertifikate - Übersicht


Beschränkungen für Zertifikatsnamen

In Microsoft BizTalk Server 2002 können keine identischen Namen für Zertifikate verwendet werden. Wenn Zertifikate mit gleichen Namen vorhanden sind, kann im BizTalk-Messaging-Manager nur eines der Zertifikate ausgewählt werden. Wenn z. B. eine Organisation zwei Zertifikate mit dem gleichen Namen und Verweis verwendet, kann die Organisation nicht beide Zertifikate verwenden. Wenn die Organisation eines der Zertifikate verwendet, wird das andere aus der Liste der verfügbaren Zertifikate im Dialogfeld Kanal entfernt.


CryptoAPI

Microsoft BizTalk Server 2002 verwendet CryptoAPI, um die verarbeiteten Daten zu sichern. Auf Grund aktueller Entwicklungen im Bereich der Kryptografie haben sich neue Funktionen ergeben, einschließlich Mechanismen für das Authentifizieren von Benutzern in einem Netzwerk, welche die Integrität übermittelter Informationen sicherstellen und Benutzer daran hindern, das Absenden von ihnen übermittelter Nachrichten zu bestreiten.

Alle Anwendungen, Nachrichten, Daten usw., welche die Verschlüsselung bzw. die Microsoft-spezifische Verschlüsselung verwenden, z. B. Microsoft Windows 2000 beim Erstellen von Zertifikaten, verwenden CryptoAPI. BizTalk Server verwendet CryptoAPI für Empfangsfunktionen, die ein Benutzer beim Verwenden einer benutzerdefinierten COM+-Komponente angibt, z. B. einer Präprozessorkomponente. Auf diese Weise kann BizTalk Server eindeutige Verschlüsselungskomponenten verarbeiten.


Collaborative Data Objects (CDOs)

Microsoft BizTalk Server 2002 unterstützt MIME-Codierung für das Senden und das Empfangen von Daten. Mithilfe der Collaborative Data Objects (CDOs), einer Technologie, die zur Microsoft Windows 2000-Umgebung gehört, können Daten codiert und von BizTalk Server verarbeitet werden. Bevor BizTalk Server z. B. einen Katalog senden kann, der Text und Grafiken enthält, muss der Datentyp der Grafikdaten zuerst von Binary in String geändert werden. CDOs können verwendet werden, um Text und Grafiken in ein Zeichenfolgenformat zu codieren, das BizTalk Server dann verarbeiten kann.


Konfigurieren von Firewalls

Firewalls bieten Unterstützung bei der Sicherung interner Netzwerke, führen jedoch zu Wartezeit und können unter Umständen zu Einzelpunktversagen führen. Selbst wenn ein Mechanismus für den Lastenausgleich verwendet wird, um das Einzelpunktversagen zu vermeiden, kann ein Firewall die Netzwerkleistung reduzieren.

Bei der Konfiguration einer BizTalk Server 2002-Umgebung mit einem Firewall werden zwei Hauptkonfigurationen empfohlen:

  • Konfiguration 1. Installieren Sie die Server in einem internen Firmennetzwerk. Wählen Sie einige dieser Server für die Kommunikation mit Handelspartnern in einem firmeneigenen Perimeternetzwerk aus (auch bekannt als Demilitarized Zone, DMZ). Eine Firma, die eigene Internetdienste verwalten möchte, ohne den unbefugten Zugang zu ihrem privaten Netzwerk zu ermöglichen, verwendet ein Perimeternetzwerk. Das Perimeternetzwerk stellt die Begrenzung zwischen dem Internet und der Abwehreinrichtung eines internen Netzwerkes dar. Üblicherweise handelt es sich dabei um eine Kombination aus Firewalls und Bastionshosts, d. h. Gateways zwischen internen und externen Netzwerken. Die Server im Perimeternetzwerk sollten lokale Transportdienste verwenden, wie z. B. HTTP, Message Queuing oder SMTP. In dieser Umgebung durchlaufen alle eingehenden und/oder ausgehenden Transaktionen einen Firewall. Die Server im Perimeternetzwerk senden Dokumente über einen weiteren Firewall an Microsoft SQL Server. Diese Konfiguration ermöglicht Servern, wie z. B. BizTalk Server und HTTP im Perimeternetzwerk, über einen internen Firewall mit Microsoft SQL Server zu kommunizieren.

  • Konfiguration 2. Installieren Sie die Server in einem Firmennetzwerk. Handelspartner, die Dokumente über das Internet austauschen, senden ihre Daten mithilfe von SMTP/HTTP-Servern im Perimeternetzwerk (erster Schutzfirewall). Diese Server senden die Daten dann über einen zweiten Firewall an die Server im Firmennetzwerk.

Konfiguration 1 und 2 beeinträchtigen die Leistung. Um einen nennenswerten Leistungsabfall zu vermeiden, können Sie den Firewall so einrichten, dass eine bestimmte Anzahl von Transaktionen zwischen einer Organisation und ihren Handelspartnern möglich ist.


Verbessern von Leistung und Skalierbarkeit

Wenn Sie mit den verschiedenen Komponenten von Microsoft® BizTalk™ Server 2002 vertraut sind, können Sie skalierbare Hochleistungslösungen erstellen. Zur Verbesserung der Leistung von BizTalk Server stehen zahlreiche Verfahren zur Verfügung. Hierzu zählen das Ermitteln potenzieller Engpässe, das Beobachten von Wartezeiten und das Verwalten von Datenbanken. Inwieweit Sie eine optimale Lösung erzielen können, richtet sich jedoch nach der Komplexität der Systemarchitektur Ihrer Organisation und nach den Budgetanforderungen.

Das Optimieren der folgenden BizTalk Server-Datenbanken ist wichtig, um höchste Leistung zu erreichen:

  • BizTalk-Messaging-Verwaltungsdatenbank

  • Datenbank für gemeinsam genutzte Warteschlangen

  • Überwachungsdatenbank

  • Persistenzdatenbank für die Orchestrierung

Weitere Informationen zum Optimieren der Datenbanken erhalten Sie unter Zentrales Skalieren der Datenbanken und Dezentrales Skalieren der Datenbanken.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Leistungsoptimierung

  • Skalieren von BizTalk Server


Leistungsoptimierung

Wenn Sie den Transaktionsanforderungen gerecht werden und die Leistung verbessern möchten, müssen Sie BizTalk Server 2002 optimieren. Neben BizTalk Server können zur Verbesserung der Leistung auch Microsoft® Windows® 2000 und Datenbankinteraktionen optimiert werden.

Nachdem Sie das System konfiguriert haben, sollten Sie es testen und anschließend die Ergebnisse auswerten, um zu ermitteln, ob die Anfangskonfiguration den Transaktionsanforderungen gerecht wird. Möglicherweise müssen Sie die Architektur neu konfigurieren, um eine optimale Leistung zu erzielen. Nach jeder Neukonfiguration sollten Sie die Architektur wiederum testen und die Ergebnisse auswerten. Sobald die gewünschten Ergebnisse erzielt wurden, sollten Sie einen Wartungsplan einrichten, da sich die Serverleistung im Laufe der Zeit ändert und sich die Menge und Art der Transaktionen, die in der Organisation bearbeitet werden, ebenfalls ändern kann.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Optimieren der Leistung Ihrer BizTalk Server-Architektur

  • Entwurf, Test und Analyse der Architektur

  • Bereitstellen der Leistung


Optimieren der Leistung Ihrer BizTalkServer-Architektur

BizTalk Server 2002 ~ Leistung und Skalierbarkeit

Optimieren der Leistung Ihrer BizTalk Server-Architektur

Dieser Abschnitt stellt allgemeine Empfehlungen zum Optimieren von Systemeinstellungen bereit. Darüber hinaus wird die Optimierung von BizTalk Server 2002 behandelt, mit der sich die Leistung verbessern lässt.

Beim Optimieren der Leistung und der Skalierbarkeit von BizTalk Server ist es wichtig, zunächst alle Eigenschaften des Systems zu kennen. Von einigen Ausnahmen abgesehen, liegt der Engpass in einem der folgenden Bereiche:

  • Datenträger-E/A

  • Prozessorgeschwindigkeit

  • Netzwerk-E/A

  • Eingabegeschwindigkeit (d. h., wie schnell Dokumente an BizTalk Server gesendet werden)

  • Benutzerdefinierter Code (z. B. Anwendungsintegrationskomponenten (Application Integration Components, AICs), Präprozessorkomponenten oder ASP-Seiten, an die Sie senden)

Die Themen in diesem Abschnitt helfen bei der Lösung dieser Probleme. Zunächst müssen Sie die Leistung Ihrer aktuellen Konfiguration analysieren, um zu ermitteln, wo das Problem liegt. Auch wenn Sie mit der aktuellen Leistung des Systems zufrieden sind, ist es wichtig, die Eigenschaften des Systems zu analysieren und zu verstehen, um bei der Problembehandlung oder bei der Aktualisierung Zeit zu sparen.

Zur Analyse der Leistung eines Systems werden die folgenden ersten fünf Schritte empfohlen:

  1. Überwachen Sie die Datenträger-E/A auf allen Computern in der BizTalk Server-Konfiguration, indem Sie den Leistungsindikator Festplattenleerlaufzeit % für das Datenobjekt Physikalischer Datenträger über den Windows-Systemmonitor oder Microsoft Operations Manager (MOM) überprüfen. Überwachen Sie diesen Leistungsindikator für alle Computer mit BizTalk Server und SQL Server sowie für alle weiteren Computer, die mit BizTalk Server interagieren, z. B. über Anwendungsintegrationskomponenten (Application Integration Components, AICs) oder HTTP-Sendungen. Weitere Informationen finden Sie unter Auswerten der Leistung einer Konfiguration

  2. Überwachen Sie die Prozessorauslastung auf allen Computern in der BizTalk Server-Konfiguration, indem Sie den Leistungsindikator Prozessorauslastung % über den Windows-Systemmonitor oder MOM überprüfen. Wenn Sie feststellen, dass der Prozessor auf einem Computer mit BizTalk Server überlastet ist, können Sie die Leistung optimieren, indem Sie Server-, Kanal- und Registrierungseinstellungen ändern. Weitere Informationen finden Sie unter Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe, Hinzufügen, Löschen und Konfigurieren einer Servergruppe, Optimieren der Registrierungseinstellungen und Horizontales Skalieren der BizTalk-Messagingdienste. In einem optimal konfigurierten BizTalk Server-System ist die Prozessorauslastung der einzige Punkt, an dem es zu Engpässen kommt.

  3. Lassen Sie die Teilnahme eines Servers an der Arbeitsobjektverwaltung nicht zu, und führen Sie Ihr Szenario erneut aus, so dass sich Elemente in der Verarbeitungswarteschlange ansammeln. Dies liefert einen eine zuverlässigen Hinweis darauf, wie schnell Dokumente empfangen werden. Nehmen Sie sich Zeit, um die ersten beiden Schritte erneut zu analysieren und weitere potenzielle Probleme zu untersuchen. Ein häufiges Problem ist eine langsame Eingaberate bei der Verwendung von ASP-Submit-Aufrufen. Häufig kann Internet-Informationsdienste (Internet Information Services, IIS) die Anforderungen nicht schnell genug verarbeiten, um BizTalk Server zu einer Spitzenleistung zu bringen. Bei der Verwendung eines ASP-Submit-Aufrufs sollten Sie zu den ISAPI-basierten HTTP-Empfangsfunktionen von BizTalk Server wechseln, da diese eine viel bessere Leistung bieten. In einem optimal konfigurierten BizTalk Server-System stellt die Prozessorauslastung den Engpass beim Empfangen von Dokumenten dar.

  4. Fahren Sie die Empfangsfunktionen herunter, oder beenden Sie den Aufruf der Submit-Methode, und lassen Sie die Teilnahme der Server an der Arbeitsobjektverwaltung mit Elementen zu, die sich bereits in der Verarbeitungswarteschlange befinden. Dadurch erhalten Sie einen zuverlässigen Hinweis darauf, wie schnell Dokumente verarbeitet und übertragen werden können. Analysieren Sie erneut die ersten beiden Schritte, und stellen Sie das System ein, bis die Prozessorauslastung Ihren Engpass darstellt. Um zu ermitteln, ob der Transport Ursache für die schlechtere Leistung ist, sollten Sie den Transporttyp der Ports ändern. Bei der Verwendung von Anwendungsintegrationskomponenten ist dies ein zuverlässiger Hinweis darauf, wie viel Arbeit noch notwendig ist, um eine maximale Leistung der Anwendungsintegrationskomponenten zu erzielen.

  5. Gleichen Sie die Ein- und Ausgabe des Systems aus. Wenn Sie alle Ressourcenengpässe beseitigt haben und die CPU-Auslastung Ihrer Server über 90 % liegt, sollten Sie die Empfangsrate und die Verarbeitungsrate ausgleichen, so dass sich stets zwischen 40 und 100 Dokumente in der Verarbeitungswarteschlange befinden. Weitere Informationen finden Sie unter Ausgleichen von Empfang und Verarbeitung.

In diesem Abschnitt werden folgende Themen behandelt:

  • Ausgleichen von Empfang und Verarbeitung

  • Optimieren der BizTalk-Orchestrierungsdienste

  • Optimieren der BizTalk-Messagingdienste

Verwandtes Thema

Skalieren von BizTalk Server


Ausgleichen von Empfang und Verarbeitung

Wenn Sie alle Ressourcenengpässe beseitigt haben und die CPU-Auslastung Ihrer Server über 90 % liegt, sollten Sie die Empfangsrate und die Verarbeitungsrate ausgleichen, so dass sich stets zwischen 40 und 100 Dokumente in der Verarbeitungswarteschlange befinden. Folgen Sie diesen Richtlinien, um die Anzahl von Dokumenten, die Sie empfangen, und die Anzahl von Dokumenten, die Ihr System verarbeitet, auszugleichen:

  • Im Allgemeinen können Sie nicht mehr Dokumente verarbeiten, als Sie empfangen. Wenn der Empfang von Dokumenten zu langsam ist, wird dadurch die Anzahl von Dokumenten eingeschränkt, die in einer bestimmten Zeit verarbeitet werden können. Anzeichen für einen langsamen Empfang von Dokumenten sind:
    • Die Verarbeitungswarteschlange ist häufig leer.

    • Bei der Überwachung des Leistungsindikators Verarbeitete Dokumente/Sek. stellen Sie fest, dass die Dokumentverarbeitung häufig gegen null geht.
  • Wenn Sie Ihr System für den Empfang von Dokumenten optimieren, können Sie u. U. die für die Verarbeitung von Dokumenten verfügbaren Ressourcen einschränken und den Durchsatz reduzieren. Anzeichen für unzureichende Ressourcen zur Verarbeitung von Dokumenten sind die Folgenden:
    • Die Anzahl von Dokumenten in der Verarbeitungswarteschlange steigt kontinuierlich an.

    • Der Systemmonitor zeigt an, dass Dokumente schneller empfangen als verarbeitet werden.

    Wichtig

    • Sie können sich auf die genannten Symptome verlassen, wenn jedes empfangene Dokument genau einem Kanal entspricht. Falls die Konfiguration ein einzelnes Dokument mehr als einem Kanal zuordnet, müssen Sie die Vergleiche anpassen. Wenn die Konfiguration z. B. jedes eingehende Dokument genau zwei Kanälen zuordnet, ist der maximale Dokumentendurchsatz doppelt so hoch, wie die Anzahl von empfangenen Dokumenten.


Optimieren der BizTalk-Orchestrierungsdienste

Mithilfe der BizTalk-Orchestrierungsdienste können XLANG-Ablaufpläne und der Inhalt dieser Ablaufpläne optimiert werden. Wenn Sie verstehen, wie Ablaufpläne den Speicher verwenden und wie die Struktur eines Geschäftsprozessablaufs die Leistung beeinflusst, können Sie Ablaufpläne entwerfen, die die Leistung der BizTalk-Orchestrierungsdienste verbessern. Zu den durch die BizTalk-Orchestrierungsdienste unterstützten Implementierungstechnologien zählen die BizTalk-Messagingdienste, COM-Komponenten, Message Queuing-Dienste und Windows-Skriptkomponenten. Durch Optimierung dieser Komponenten und Dienste lässt sich die Leistung der BizTalk-Orchestrierungsdienste weiter verbessern.

In diesem Abschnitt werden folgende Themen behandelt:

  • Optimieren von XLANG-Ablaufplänen

  • Optimieren des Inhalts von XLANG-Ablaufplänen


Optimieren von XLANG-Ablaufplänen

Ein XLANG-Ablaufplan kann eine große Anzahl interner Geschäftsprozesse enthalten. Bei den Geschäftsprozessen kann es sich um kurzlebige Transaktionen oder langlebige Transaktionen handeln. BizTalk Server steuert zwar nicht den Inhalt dieser Prozesse, verwaltet jedoch den Informationsfluss durch die Prozesse innerhalb eines XLANG-Ablaufplanes. Unabhängig davon, ob er kurzlebige oder langlebige Transaktionen enthält, sollten Sie beim Entwerfen eines XLANG-Ablaufplanes Folgendes berücksichtigen:

  • Eine XLANG-Ablaufplaninstanz wird immer dann im Speicher ausgeführt, wenn sie aufgerufen wird.

  • Mehrere XLANG-Ablaufpläne können auf dem gleichen Server ausgeführt werden.

  • Mehrere unterschiedliche XLANG-Ablaufpläne können parallel mit mehreren XLANG-Ablaufplaninstanzen ausgeführt werden.

Die Persistenzdatenbank für die Orchestrierung stellt ein als Pausierung bezeichnetes Verfahren bereit, mit dem der durch die Ausführung von XLANG-Ablaufplänen verwendete Speicher gesteuert wird. Eine Pausierung tritt ein, wenn eine XLANG-Ablaufplaninstanz auf eine Nachricht wartet und keine andere Aktivität innerhalb des XLANG-Ablaufplanes stattfindet. An diesem Punkt pausiert das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz, um die Leistung zu maximieren. Bei der Pausierung einer XLANG-Ablaufplaninstanz bleiben alle instanzspezifischen Zustände für eine Datenbank bestehen und die Instanz wird aus dem Speicher entfernt. Nur ein geringer Anteil der XLANG-Ablaufplaninstanz verbleibt im Speicher innerhalb des XLANG-Ablaufplanungsmoduls. Wenn eine Nachricht an einem Port für die XLANG-Ablaufplaninstanz ankommt, wird die Instanz aktiviert. Bei der Aktivierung einer XLANG-Ablaufplaninstanz wird die Instanz aus der Datenbank im Speicher wiederhergestellt.

Eine XLANG-Ablaufplaninstanz pausiert so lange, bis sie entweder wieder aktiviert oder explizit durch einen Administrator beendet wird. Auf diese Weise kann ein Geschäftsprozess für einen längeren Zeitraum zuverlässig ausgeführt werden. Weitere Informationen zu Pausierungs- und Aktivierungseinstellungen erhalten Sie unter Pausierung und Aktivierung. Die Pausierung und Aktivierung spart zwar Speicherplatz, beeinträchtigt jedoch die Leistung. Da die Pausierung und Aktivierung erfordern, dass Daten in die Persistenzdatenbank für die Orchestrierung geschrieben und aus der Datenbank gelesen werden, tritt Netzwerkwartezeit auf.

Wichtig

  • Um die Leistung der BizTalk-Orchestrierungsdienste deutlich zu steigern, navigieren Sie im Windows-Explorer zum Verzeichnis Programme\Gemeinsame Dateien\System\ado und doppelklicken dann auf Adofre15.reg. Klicken Sie in dem Bestätigungsdialogfeld auf Ja und anschließend auf OK. Beachten Sie, dass mit diesem Verfahren das ADO-Threadingmodell von Apartment threaded in Both geändert wird. Dies kann sich auch auf andere Anwendungen auswirken, die Microsoft® ActiveX® Data Objects (ADO) verwenden.


Optimieren des Inhalts von XLANG-Ablaufplänen

Ein XLANG-Ablaufplan beschreibt den Geschäftsprozess und die Bindung des Prozesses an Implementierungstechnologien. Die Leistung eines XLANG-Ablaufplanes spiegelt häufig die Leistungsstufe der darin enthaltenen Aktionen wider. Bei der Optimierung des Inhalts eines XLANG-Ablaufplanes ist eine Reihe relevanter Themen zu beachten. Einige dieser Aspekte beziehen sich speziell auf einen XLANG-Ablaufplan, während andere auch für die Erstellung einer beliebigen verteilten Anwendung gelten:

  • Zurücksetzen des Pausierungswertes, um Speicher für XLANG-Ablaufpläne zu sparen. Der Standardwert für diese Wartezeit ist 0 Sekunden. Sie können diesen Wert ändern. Jede Zeitangabe von weniger als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan nicht pausiert. Jede Zeitangabe von mehr als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan sofort pausiert. Weitere Informationen zu Wartezeiten und der Pausierung von XLANG-Ablaufplänen erhalten Sie unter Pausierung und Aktivierung und Synchrone und asynchrone Kommunikation.

  • Verwenden persistenter Komponenten. Persistente Komponenten, wie z. B. Komponenten, die IPersistStream oder IPersistStreamInit implementieren, bieten dem XLANG-Ablaufplanungsmodul die Möglichkeit, XLANG-Ablaufpläne flexibel zu pausieren.

  • Ausführen der COM-Objekte auf dem gleichen Server wie die Persistenzdatenbank für die Orchestrierung. Hierdurch wird sichergestellt, dass sich die Netzwerkwartezeit nicht auf den XLANG-Ablaufplan auswirkt.

  • In-Process-Ausführung von COM+-Paketen, um eine optimale Leistung zu erzielen. Obwohl sich die In-Process-Ausführung eines COM+-Pakets negativ auf die Stabilität der COM+-Anwendung auswirken kann (beispielsweise kann die gesamte Anwendung ausfallen, wenn eine Komponente innerhalb der Anwendung ausfällt), ist sie jedoch bedeutend schneller als die Out-Of-Process-Ausführung der Anwendung. Um diese potenzielle Instabilität zu vermeiden, sollten Sie die Komponenten der Anwendung unbedingt eingehend auf Stabilität hin prüfen, bevor die Anwendung in einer Produktionsumgebung bereitgestellt wird.

  • Zusammenfassen von Arbeitsobjekten in einer einzelnen Transaktion. Wenn der Zustand einer XLANG-Ablaufplaninstanz am Anfang und Ende einer Transaktion beibehalten wird, wirkt sich dies deutlich auf die Computerressourcen aus. Die Zusammenfassung von Arbeitsobjekten in einer einzelnen Transaktion reduziert die Leistungsbeeinträchtigung jedoch erheblich. Darüber hinaus kann ein XLANG-Ablaufplan nicht während einer MS DTC-Transaktion (Microsoft Distributed Transaction Coordinator) pausiert werden. MS DTC-Transaktionen sind schnell, setzen jedoch die Leistung herab. Gruppieren Sie mehrere Aktionen in einer einzelnen MS DTC-Transaktion, vorausgesetzt, die Aktionen können schnell durchgeführt werden.

  • Langlebige Transaktionen sollten asynchron durchgeführt werden, und XLANG-Ablaufpläne sollten so entworfen werden, dass sie COM-Aufrufe schnell ausführen. Ergebnisse asynchroner Arbeit können über Nachrichtenwarteschlangen oder COM-Aufrufe an die XLANG-Ablaufplaninstanz zurückgesendet werden. Bei Verwendung von COM kann der Name eines Ports für "Antworten" in Form eines Monikers übergeben werden, der auch bei einem Neustart des Computers gültig ist.

Verwandtes Thema

Monikersyntax


Optimieren der BizTalk-Messagingdienste

Zur Optimierung von BizTalk-Messagingdiensten senden Sie Dokumente an eine Servergruppe. BizTalk Server-Gruppen werden zur Verteilung von Arbeit auf mehrere Server verwendet. Um Daten an BizTalk Server zu senden, verwenden Sie die folgenden Verfahren:

  • Konfigurieren einer Empfangsfunktion (z. B. Message Queuing, HTTP oder Datei).

  • Aufrufen der Submit-Methode des Interchange-Objekts von BizTalk Server.

Die Verwendung von Empfangsfunktionen bietet eine bessere Leistung als die Verwendung der Submit-Methode, um das Interchange-Objekt aufzurufen. Empfangsfunktionen verwenden einen Threadpool und Batchverarbeitung, um die Empfangsleistung zu optimieren. Um eine vergleichbare Leistung in Clientcode zu erreichen, der IInterchange::Submit() aufruft, muss die Clientkomponente Multithreadapartment-Code verwenden, wobei jeder Thread einen separaten Zeiger für IInterchange besitzt. Bei der Verwendung von Singlethreadapartment-Code werden Nachrichten seriell an BizTalk Server gesendet, und es wird nicht dieselbe Durchsatzleistung erreicht wie bei der Verwendung von Empfangsfunktionen und Message Queuing.

Beim Aufruf des Interchange-Objekts für die Versendung anstelle der Verwendung der Empfangsfunktion werden mehr Ressourcen verwendet, da das Interchange-Objekt außerhalb des BizTalk Server-Prozesses erstellt werden muss. Bei Verwendung des Interchange-Objekts stehen jedoch zwei Verfahren für das Senden von Daten an die Server in einer Gruppe zur Verfügung:

  • Statische Konfiguration von Anteilen der gesamten Versendungen auf bestimmten Servern innerhalb der Gruppe. Dieses Verfahren stellt jedoch nur geringe Fehlertoleranz bereit, wenn der Server, auf dem sich ein Transportdienst befindet, statisch einem ausgefallenen BizTalk-Server zugeordnet ist.

  • Verwendung der Microsoft Application Center 2000-Funktion Komponentenlastenausgleich (Component Load Balancing, CLB) zur Verbesserung der Leistung. BizTalk Server-Gruppen stellen keinen Lastenausgleich für die Versendung von Dokumenten bereit. Neben dem Lastenausgleich stellt CLB Fehlertoleranz bereit. Weitere Informationen zu CLB erhalten Sie unter Komponentenlastenausgleich.

In diesem Abschnitt werden folgende Themen behandelt:

  • Erstellen und Optimieren von Spezifikationen

  • Erstellen und Optimieren von Zuordnungen

  • Optimieren von BizTalk Server-Gruppeneigenschaften

  • Optimieren der Servereigenschaften

  • Optimieren der Registrierungseinstellungen

  • Optimieren der Verschlüsselung

  • Optimieren der Kommunikation

  • Konfigurieren von Firewalls


Erstellen und Optimieren von Spezifikationen

Wenn die Standardeinstellungen für die globale Überwachung verwendet werden, kann BizTalk Server 2002 ein 20 MB großes XML-Dokument im Unicode-Format unterstützen. Bei anderen Dateitypen, z B. ANSI-Flatfile, unterstützt BizTalk Server die Dateigröße von 20 MB nicht, da eine Datei in einem anderen Format als XML in eine XML-Datei konvertiert werden muss. Im Konvertierungsprozess werden zu den Daten XML-Tags hinzugefügt, wodurch sich die Größe des Dokuments erhöht, das BizTalk Server verarbeiten muss. Andere Dateitypen müssen kleiner als 20 MB sein, damit eine optimale Leistung von BizTalk Server gewährleistet werden kann.

Der für die Verarbeitung eines in das XML-Format konvertierten Dokuments benötigte Speicher hängt von der Originalstruktur des Dokuments ab. Wenn globale Überwachungseinstellungen aktiviert sind, können XML-Dokumente im Unicode-Format verarbeitet werden, die größer als 20 MB sind, ohne dass die BizTalk Server-Leistung hiervon stark beeinträchtigt wird.

Anmerkung

  • Wird die Größenbeschränkung für die Überwachung von Austauschvorgängen überschritten, wirkt sich dies negativ auf die Leistung von BizTalk Server aus. Weitere Informationen zur Größenbeschränkung finden Sie unter Austausch- und Dokumentgrößenbeschränkung. Die Leistung wird ebenfalls durch die Dokumentprotokollierung beeinträchtigt. Weitere Informationen zur Dokumentprotokollierung erhalten Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.

Beim Entwerfen von Spezifikationen können Sie Gültigkeitsregeln innerhalb einer Spezifikation konfigurieren. Beispielsweise können Sie angeben, dass ein Feld einen bestimmten Datentyp enthalten muss (z. B. eine Zeichenfolge), oder komplexere Regeln erstellen (beispielsweise das Überprüfen eines Feldes anhand einer Liste mit 80 Werten). Im zweiten Fall müssen die Daten mit 80 Werten verglichen werden. Wenn sie keinem dieser Werte entsprechen, schlägt die Gültigkeitsüberprüfung der Spezifikation fehl. Die Spezifikationsüberprüfung ist in BizTalk Server standardmäßig aktiviert. Sie beeinträchtigt zwar die Leistung, stellt jedoch die Gültigkeit der gesendeten und empfangenen Daten sicher. Die Überprüfung kann deaktiviert werden. Dies steigert die Leistung und wirkt sich nicht nachteilig auf die Gültigkeit der Daten aus, da BizTalk Server über mehrere andere Mechanismen zur Überprüfung der Daten verfügt.

Wenn beispielsweise eine Zuordnung bestimmte Datentypen und Werte erfordert und die Spezifikationsüberprüfung deaktiviert ist, durchlaufen die Daten zwar erfolgreich die Analysephase, wenn während der Serialisierungsphase die Zuordnung angewendet wird, treten jedoch Fehler auf. Falls andere Mechanismen (z. B. Zuordnungen anhand gültiger Daten) verfügbar sind, kann die Spezifikationsüberprüfung deaktiviert werden, um die durch den Überprüfungsprozess hervorgerufenen potenziellen Leistungseinbußen zu verhindern. Alternativ empfiehlt sich die Wahl dieses Verfahrens auch, wenn Sie über gemeinsame Datenstandards mit Geschäftspartnern verfügen und die Transaktionen überprüft haben. Als weiterer Grund für dieses Verfahren ist zu nennen, dass Sie auf diese Weise die vollständige Kontrolle über die Art und Weise besitzen, wie die Daten gesendet werden (z. B. Transaktionen zwischen Anwendungen).

Sie können die Registrierungseinstellung NoValidation verwenden, um die Überprüfung zu deaktivieren. Wenn die Spezifikationsüberprüfung nicht erforderlich ist (Dokumente werden nicht anhand einer Spezifikation für Einstellungen wie z. B. Minimal-/Maximalwerte, Datentypen und/oder erforderliche Werte überprüft), legen Sie für diese Einstellung einen Wert ungleich 0 fest. Die Daten werden dann nicht überprüft. Auf diese Weise lässt sich zwar die Leistung verbessern, möglicherweise werden jedoch ungültige Daten gesendet. Das Ändern der Spezifikationsüberprüfung auf einen Wert ungleich 0 kann die richtige Option für Server sein, die Dokumente empfangen, über deren Struktur die Organisation die Kontrolle besitzt.

Die Registrierungseinstellung muss auf jedem einzelnen Server geändert werden. Bei aktivierter Spezifikationsüberprüfung wird jedes auf dem Server verarbeitete Dokument anhand seiner Spezifikation überprüft. Dieses Verfahren wird durch die Verwendung der Spezifikationsüberprüfung verlangsamt.

Empfohlene Lösungen für die Optimierung von Dokumentgröße und Spezifikationen

So optimieren Sie die Leistung von BizTalk Server

  • Nehmen Sie nicht mehr Felder und/oder Attribute in Spezifikationen auf als erforderlich. Bei umfangreichen Feldern und Attributen sind auch die Speicheranforderungen für BizTalk Server erhöht. Eine größere Spezifikation erfordert einen proportionalen Zuwachs im Speicher. Beispiel: Die im Lieferumfang von BizTalk Server enthaltenen EDI-Spezifikationen sind mit den EDI-Standards kompatibel. Normalerweise benötigen die meisten Organisationen, die EDI-Spezifikationen verwenden, ungefähr 10 % der gesamten Spezifikation. Wenn eine Organisation und ihre Handelspartner also nur 10 % der vollständigen Spezifikation verwenden, können die nicht benötigten Datensätze und Felder gelöscht werden, und die modifizierte Spezifikation kann für Transaktionen verwendet werden.

  • Wenn die Spezifikationsüberprüfung aktiviert ist, legen Sie keine Gültigkeitsregeln in Spezifikationen für Felder fest, die gültige Daten enthalten. Enthält beispielsweise ein Feld eine Zahl, wird jedoch nur als Zeichenfolge verarbeitet (z B. eine Telefonnummer), legen Sie das Feld nicht als numerisch fest. In diesem Fall ist es nicht notwendig, einen Datentyp anzugeben, da String der Standarddatentyp ist. Das Feld für den Datentyp kann daher leer bleiben. Beim Angeben akzeptabler Werte für ein Feld dauert die Überprüfung länger als bei einer einfachen Datentypüberprüfung.


Erstellen und Optimieren von Zuordnungen

Als Bestandteil einer Transaktion verringert die Konvertierung von Daten u. U. die Leistung von BizTalk Server 2002. Die Zuordnung von Spezifikationen kann CPU-intensiv sein, wodurch gegebenenfalls die Fähigkeit von BizTalk Server zur Verarbeitung der Gesamttransaktion reduziert wird. Wie stark BizTalk Server betroffen ist, richtet sich vor allem nach der Komplexität der für die Konvertierung verwendeten Zuordnung. Wird beispielsweise das Feld productID in der Quellspezifikation dem Feld itemID in der Zielspezifikation zugeordnet, wirkt sich dies nicht so stark aus wie eine komplexe mathematische Operation, die an den Daten durchgeführt wird, die konvertiert werden.

Empfohlene Lösungen für den Entwurf von Zuordnungen

  • Verwenden Sie Funktoide nur dann, wenn es notwendig ist. Funktoide verwenden Skripts, was dazu führt, dass BizTalk Server ein Skriptmodul lädt. Im Vergleich zu systemeigenen XML-Transformationen kann dies die Leistung herabsetzen.

  • Verwenden Sie das Funktoid Datenbanksuche nur dann, wenn es notwendig ist. BizTalk Server muss eine Datenbankverbindung einrichten, Datenabfragen durchführen, ein Recordset auffüllen und die Verbindung immer dann schließen, wenn das Funktoid verwendet wird. Dies kann die Leistung von BizTalk Server beeinträchtigen.

  • Vermeiden Sie, COM-Objekte innerhalb von Funktoidskripts aufzurufen, und verwenden Sie keine benutzerdefinierten Funktoide. Beide Verfahren veranlassen BizTalk Server, eine Instanz eines COM-Objekts zu instanziieren. Hierdurch wird die Leistung der Gesamtoperation negativ beeinflusst. Darüber hinaus wird die Leistung instanziierender COM-Objekte beeinflusst, je nachdem, wie die folgenden Fragen beantwortet werden:
    • Handelt es sich um ein In-Process-Objekt oder ein Out-Of-Process-Objekt?

    • Handelt es sich um ein lokales Objekt oder ein Remoteobjekt?

    • Wie fachgerecht wurde das Objekt erstellt?

    • Ist das Objekt transaktionsorientiert?
  • Analysieren Sie jede Zuordnung, um zu ermitteln, wie sich eine optimale Leistung erzielen lässt. Beispielsweise können zwei unterschiedliche Techniken verwendet werden, um 2 Quellfelder miteinander zu verketten und den Ergebniswert in 2 verschiedene Zielfelder einzufügen. Bei der ersten Verkettungstechnik wird ein Funktoid vom Typ Verkettung verwendet, dessen Ausgabe zwei Stellen zugeordnet wird. Bei der zweiten Verkettungstechnik werden 2 Funktoide verwendet, von denen jedes eine einzelne Ausgabeverknüpfung mit einem Zielfeld aufweist. Die erste Technik ist etwas effizienter, da das Skript, das als Bestandteil des Funktoids ausgeführt wird, nur einmal aufgerufen wird. Mithilfe von Tests können Sie ermitteln, welche Techniken die beste Leistung liefern.


Optimieren von BizTalkServer-Gruppeneigenschaften

BizTalk Server 2002 ~ Leistung und Skalierbarkeit

Optimieren von BizTalk Server-Gruppeneigenschaften

In der BizTalk Server-Verwaltung können Sie folgende Eigenschaften im Dialogfeld Eigenschaften der BizTalk Server-Gruppe festlegen:

  • Aktualisierungsintervall für Messaging-Verwaltungsobjektcache (Sek.). Für dieses Feld kann ein Maximalwert von 300 Sekunden festgelegt werden. BizTalk Server 2002 führt eine Zwischenspeicherung der Konfigurationen (z. B. Kanäle, Messagingports, Umschläge und Dokumentdefinitionen) im Arbeitsspeicher durch, um zu vermeiden, dass die Datenbank jedes Mal aufgerufen werden muss. Sofern die Objekte nicht regelmäßig geändert werden, legen Sie den Wert auf 300 fest, damit Daten weniger häufig in die Datenbank geschrieben und aus der Datenbank gelesen werden müssen. Da BizTalk Server die Verwaltungsobjekte alle 5 Minuten aktualisiert, muss der Dienst neu gestartet werden, damit die Änderungen sofort wirksam werden.

  • Deaktivieren der Dokumentüberwachung. Auf der Registerkarte Überwachen kann die Dokumentüberwachung aktiviert oder deaktiviert werden. Wird keine Überwachung durchgeführt, deaktivieren Sie dieses Feld, um die Anzahl der Schreib-/Lesevorgänge in der Datenbank für eine einzelne Transaktion zu minimieren. Wenn das Feld aktiviert ist, stellt BizTalk Server eine Verbindung zu der Datenbank her und protokolliert die Daten. Deaktivieren Sie das Feld nur, wenn keine Überwachung notwendig ist. Es wird jedoch dringend empfohlen, die Dokumentüberwachung nicht zu deaktivieren. Weitere Informationen zum Festlegen von Überwachungseigenschaften erhalten Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe.

    Anmerkung

    • Für die Überwachung von Austauschvorgängen existiert eine Größenbeschränkung. Wird diese überschritten, führt das zu Leistungseinbußen bei BizTalk Server. Weitere Informationen zur Größenbeschränkung finden Sie unter Austausch- und Dokumentgrößenbeschränkung. Die Leistung wird ebenfalls durch die Dokumentprotokollierung beeinträchtigt. Weitere Informationen zur Dokumentprotokollierung erhalten Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.
  • Aufrufreihenfolge für Server anordnen. Für BizTalk Server-Parser kann eine Prioritätsreihenfolge festgelegt werden, wenn eine Gruppe hauptsächlich einen bestimmten Dokumenttyp empfängt. BizTalk Server verfügt über 4 Parser für die Datenanalyse: XML, EDIFACT, X12 und Flatfile. Wenn BizTalk Server ein Dokument empfängt, wird versucht, das Dokument mit diesen Parsern in der Reihenfolge, in der sie aufgeführt sind, zu analysieren. Falls eine Organisation in erster Linie einen bestimmten Dokumenttyp erhält, sollte die Reihenfolge der Parser so geändert werden, dass der erste Parser dem Typ der hauptsächlich empfangenen Dokumente entspricht.

Verwandtes Thema

Horizontales Skalieren der BizTalk-Messagingdienste


Optimieren der Servereigenschaften

In der BizTalk Server-Verwaltung können Sie folgende Eigenschaften im Dialogfeld Eigenschaften von <Server> festlegen:

  • Erstellen mehrerer Instanzen von Empfangsfunktionen. Dadurch kann BizTalk Server mehrere Empfangsfunktionen für zu empfangende Dokumente abfragen. Um die Auslastung durch Dokumente auf verschiedene Computer zu verteilen, speichern Sie die Empfangsfunktionen auf separaten Computern. Jeder Abrufspeicherort muss eindeutig sein und eine separate Empfangsfunktion enthalten. Um die Überlastung einer einzelnen Empfangsfunktion zu verhindern, muss die Geschäftsanwendung, die Dokumente sendet, die Dokumente gleichmäßig auf die abrufenden Speicherorte aufteilen.

  • Maximale Anzahl von Empfangsfunktionsthreads. Sie können angeben, wie viele Arbeitsthreads einer Empfangsfunktion pro Prozessor für eine Empfangsfunktion vorhanden sein sollen. Wenn Sie einen zu niedrigen Wert festlegen, kann dies zu einer Verlangsamung von BizTalk Server führen, da die Anwendung E/A-Komplettierungsports verwendet. Das Festlegen eines zu hohen Wertes hat normalerweise keine ernsthaften Auswirkungen, führt jedoch u. U. zu Leistungseinbußen. Sie können diese Zahl ändern, um den optimalen Wert zu ermitteln. Der empfohlene Wert für die Maximale Anzahl von Empfangsfunktionsthreads beträgt 4.

  • Maximale Anzahl von Arbeitsthreads pro Prozessor. Sie können die Anzahl der Arbeitsthreads pro Prozessor für die verarbeitende Seite angeben. Durch die entsprechende Anpassung der Arbeitsthreads kann die Leistung verbessert werden. Klicken Sie in der BizTalk Server-Verwaltung mit der rechten Maustaste auf einen Server in der Konsolenstruktur, und klicken Sie dann auf Eigenschaften. Ändern Sie den Standardwert im Feld Maximale Anzahl von Arbeitsthreads pro Prozessor. Der Standardwert lautet 4. Der empfohlene Wert liegt zwischen 10 und 16, je nach Bereitstellung.


Optimieren der Registrierungseinstellungen

Um die Leistung von BizTalk Server zu verbessern, können Sie die folgenden Registrierungseinstellungsanpassungen implementieren.

Warnung

  • Eine falsche Verwendung des Registrierungs-Editors kann zu ernsthaften Problemen führen, die eine Neuinstallation des Betriebssystems erfordern können. Microsoft kann keine Garantie dafür übernehmen, dass Probleme, die durch die falsche Verwendung des Registrierungs-Editors verursacht werden, sich beheben lassen. Verwenden Sie den Registrierungs-Editor auf eigenes Risiko.

  • Weitere Informationen finden Sie unter "Ändern von Schlüsseln und Werten" und "Hinzufügen und Löschen von Informationen in der Registrierung" in der Windows 2000-Hilfe. Beachten Sie, dass Sie die Registrierung vor der Bearbeitung sichern sollten. Wenn Sie Windows 2000 ausführen, sollten Sie außerdem die Notfalldiskette aktualisieren.

Alle folgenden Schlüssel sollten als DWORD-Werte zu \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSVC hinzugefügt werden:

  • NoValidation. Verwenden Sie diesen Registrierungsschlüssel, um die Spezifikationsüberprüfung zu deaktivieren. Wenn die Spezifikationsüberprüfung nicht erforderlich ist (Dokumente werden beispielsweise nicht anhand einer Spezifikation für Minimal-/Maximalwerte, Datentypen oder erforderliche Werte überprüft), legen Sie für diese Einstellung einen Wert ungleich 0 fest. Die Daten werden dann nicht überprüft. Hierdurch wird zwar möglicherweise die Leistung verbessert, es kann jedoch auch dazu führen, dass ungültige Daten gesendet werden. Diese Einstellung eignet sich für Server, die Dokumente empfangen, deren Struktur durch die Organisation kontrolliert wird.

  • ParserRefreshInterval. Standardmäßig ist hierfür der Wert 60.000 (60 Sekunden) festgelegt. Dieser Wert gibt an, wie häufig BizTalk Server die Datenbank überprüfen soll, um festzustellen, ob ein neuer Parser hinzugefügt wurde (dies ist die einzige Eigenschaft auf Gruppenebene, die während der Ausführung des Servers aktualisiert wird). Wenn keine neuen Parser hinzugefügt werden, legen Sie diesen Wert auf 0 fest. BizTalk Server führt dann keine Überprüfung der Datenbank durch. Dieser Wert wird auch verwendet, um zu überprüfen, ob die Gruppeneinstellungen in der Überwachungsdatenbank geändert wurden und ob die Parserliste durch das Hinzufügen, Löschen oder Neuanordnen von Parsern geändert wurde.

  • CacheSize. Verwenden Sie diesen Registrierungsschlüssel, um festzulegen, wie weit der BizTalk Server-Verwaltungsobjektcache anwachsen darf. Der Standardwert beträgt 20. Sobald im BizTalk Server-Objektcache mehr als 20 Kanäle, Messagingports, Umschläge oder Dokumentdefinitionen enthalten sind, muss BizTalk Server einige Objekte aus dem Speicher löschen. Wenn ein Server ein umfangreiches Speichervolumen besitzt, kann hier ein höherer Wert (über 20) festgelegt werden. BizTalk Server bewahrt dann eine größere Anzahl von Objekten im Speicher auf. Dies wirkt sich nicht auf das Aktualisierungsintervall aus. BizTalk Server löscht die zwischengespeicherten Objekte und lädt sie neu, wenn sie abgelaufen sind.

  • BatchSize. Verwenden Sie diesen Wert nur zusammen mit einer Message Queuing-Empfangsfunktion. Als Standardwert für BatchSize ist 20 festgelegt. Um die Leistung zu verbessern, liest BizTalk Server bis zu 20 Objekte gleichzeitig aus der Warteschlange und sendet alle 20 Objekte innerhalb einer einzelnen Transaktion. Durch eine Reduzierung der Schreibzugriffe auf die Datenbank kann die Leistung erheblich verbessert werden. Falls ein Deadlock auftritt und BizTalk Server die Transaktion beendet, müssen die Objekte erneut gesendet werden. BizTalk Server verliert die Dokumente nicht. Werte über 20 wurden bisher nicht getestet. Legen Sie diesen Wert nicht auf 0 fest.

Sie können auch die Registrierungseinstellungen optimieren, um die Leistung der HTTP-Empfangsfunktion von BizTalk Server zu verbessern. Alle Schlüssel sollten als DWORD-Werte zu \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSVC\HTTPListener hinzugefügt werden. Um die Leistung zu verbessern, führen Sie die folgenden Anpassungen für Registrierungseinstellungen durch:

  • WorkerThreads. Verwenden Sie diesen Wert, um die Anzahl der Threads, die den Threadpool bedienen, zu ändern. Standardmäßig ist der Wert für WorkerThreads auf 6 festgelegt. Ist der Dokumentdurchsatz für die HTTP-Empfangsfunktion sehr hoch, muss u. U. der Wert für WorkerThreads sowie die folgende Einstellung QueueFactor erhöht werden. Ein Anzeichen, dass der Schlüssel WorkerThreads erhöht werden muss, ist die Anzeige der folgenden Fehlermeldung im Ereignisprotokoll:

    Die BizTalk HTTP-Empfangsfunktion <Name> konnte keinen Thread aus dem Threadpool abfragen.

  • QueueFactor. Der Faktor, mit dem die Anzahl der Threads im Pool multipliziert wird, um die Warteschlangengröße zu ermitteln. Mit anderen Worten, QueueFactor wirkt sich auf die Größe der vom Threadpool verwendeten Warteschlange aus. Standardmäßig ist der Wert für QueueFactor auf 3 festgelegt. Ist der Dokumentdurchsatz für die HTTP-Empfangsfunktion sehr hoch, muss u. U. der Wert für WorkerThreads und QueueFactor erhöht werden. Ein Anzeichen, dass der Parameter QueueFactor erhöht werden muss, ist die Anzeige der folgenden Fehlermeldung im Ereignisprotokoll:

    Die BizTalk HTTP-Empfangsfunktion <Name> konnte das Arbeitsobjekt nicht an den Threadpool senden. Versuchen Sie, die Länge der Threadpoolwarteschlange mit Hilfe des Registrierungsschlüssels "QueueFactor" zu erhöhen.

  • AsyncBufferSize. Dies ist die Größe des Puffers für die Ausführung von asynchronen IIS-Lesevorgängen und die empfohlene Puffergröße für die objektorientierte Programmierung (OOP). Der Standardwert für AsyncBufferSize ist auf 4.096 Bytes festgelegt. Werden Daten mit mehr als 48 Kilobytes (KB) empfangen, wird der über 48 KB hinausgehende Teil der Daten von IIS asynchron gelesen.

  • MaxSyncFileDropSize. Dies ist die maximale Datengröße, die synchron an eine Datei übergeben wird, d. h. der Schwellenwert, ab dem Daten in kleinen Stücken in eine Datei geschrieben werden. Empfangene Daten, deren Größe unter diesem Wert liegt, werden in den Speicher gelesen und dann in einem Versuch in die Datei geschrieben. Daten, die größer sind als dieser Wert, werden asynchron übergeben und somit nicht in den Speicher geladen. Standardmäßig ist der Wert für MaxSyncFileDropSize auf 1.048.576 Bytes festgelegt. Um die Leistung der Empfangsfunktion zu erhöhen, können Sie den Wert für MaxSyncFileDropSize verringern. Sind die Systemressourcen begrenzt, können Sie den Wert reduzieren, um die Speicherverwendung durch die HTTP-Empfangsfunktion zu beschränken.

  • MaxLargeAsyncBuffers. Verwenden Sie diesen Wert, um die Anzahl der für große Datenmengen zugeordneten Puffer zu ändern. Diese Puffer werden zwischengespeichert, wenn die Daten 48 KB überschreiten und unter MaxSyncFileDropSize für die Dateiübergabe betragen. Die Puffer werden verwendet, wenn die Daten direkt an BizTalk Server gesendet werden (asynchron oder synchron) oder wenn die Daten an eine Datei übergeben werden und die Datengröße kleiner ist als MaxSyncFileDropSize. Standardmäßig ist der Wert von MaxLargeAsyncBuffers auf 18 festgelegt. Sie können den Wert verringern, um die Speicherverwendung durch die HTTP-Empfangsfunktion zu reduzieren, allerdings hat dies eine negative Auswirkung auf die Leistung.

  • ConfigRefreshInt. Dieser Wert bestimmt das Zeitintervall (in Millisekunden) für den Abruf von Konfigurationsdaten aus der BizTalk-Messaging-Verwaltungsdatenbank. Standardmäßig ist der Wert für ConfigRefreshInt auf 60.000 Millisekunden festgelegt. Das Erhöhen bzw. Verringern des Wertes für ConfigRefreshInt ist abhängig davon, wie häufig die BizTalk-Messaging-Verwaltungsdatenbank aktualisiert wird.


Optimieren der Verschlüsselung

Wird die Verschlüsselung oder ein anderer Sicherheitsmechanismus verwendet, kann dies die Leistung von BizTalk Server beeinträchtigen. Beim Verwenden der Verschlüsselung wird Folgendes empfohlen:

  • Erhöhen der Serverzahl. Auf diese Weise können Sie die Leistung verbessern, indem Sie die verschiedenen BizTalk Server-Komponenten aufteilen und optimieren.

  • Verwenden einer schnelleren CPU. Erhöht die Verarbeitungsgeschwindigkeit.

  • Trennen von BizTalk Server-Funktionen. Beispielsweise können Sende- und Empfangsfunktionen auf separaten Servern platziert werden.

  • Verwenden eines virtuellen privaten Netzwerkes (VPN), wenn File, Message Queuing oder HTTP verwendet wird. Wenn ein VPN verfügbar ist, ist eine sichere Datenübertragung gewährleistet. Es ist nicht erforderlich, BizTalk Server-Transaktionen zu sichern, wenn alle mit Handelspartnern durchgeführten Datenübertragungen über ein VPN gesichert werden.

  • Erwerben von Beschleunigerkarten für Verschlüsselungshardware. Beschleunigerkarten stellen dedizierte Prozessoren bereit, die die negativen Auswirkungen beheben können, die Ver- und Entschlüsselung auf die Leistung der CPU eines Servers haben. Der Erwerb von Beschleunigerkarten ist weniger kostenintensiv als das Hinzufügen mehrerer CPUs.


Optimieren der Kommunikation

BizTalk Server stellt Integrationsmechanismen für die synchrone Kommunikation und die asynchrone Kommunikation bereit. BizTalk Server 2002 kann Dokumente über die COM-Integration oder über Serverempfangsfunktionen (Datei, Message Queuing oder HTTP) akzeptieren.

Wenn ein Dokument an BizTalk Server gesendet wird, wird es normalerweise in die Datenbank für gemeinsam genutzte Warteschlangen übernommen. BizTalk Server ruft die Datenbank ab und verarbeitet dann das Dokument. Bei diesem Prozess handelt es sich um einen asynchronen Kommunikationsmechanismus. Er verwendet die Prüfpunktinformationen in der Microsoft SQL Server-Datenbank als Warteschlange für den Abruf von Dokumenten, die auf die Verarbeitung warten. Diese zusätzliche Abstraktionsschicht ermöglicht dem Transportdienst das Senden von Dokumenten an BizTalk Server unabhängig von dem für die Dokumentübermittlung verwendeten Transportmechanismus.

Ein synchroner Kommunikationsaustausch umgeht alle Warteschlangen und verarbeitet alle vom Messagingport benötigten Komponenten auf dem aufrufenden Thread. Sofern verfügbar, wird für synchrone Kommunikationsprotokolle ein optionales Antwortdokument zurückgegeben. Dieses Verfahren kann nur für eine einzelne Kanalübereinstimmung und für einen einzelnen Messagingport (nicht für Verteilerlisten) durchgeführt werden.

Wenn aufgrund der festgelegten Parameter Übereinstimmungen für mehrere Kanäle vorhanden sind, gibt eine synchrone Kommunikationsversendung eine Fehlermeldung zurück, die angibt, dass für eine synchrone Kommunikationsversendung mehrere Kanalübereinstimmungen nicht zulässig sind. Dieses Verfahren kann nur für einzelne Dokumentaustauschvorgänge verwendet werden. Wenn die Versendung mehrere Dokumente enthält, wird bei synchronen Versendungen eine Fehlermeldung ausgegeben, die darüber informiert, dass mehrere Dokumentversendungen nicht erlaubt sind. Das Verfahren unterstützt keine Gruppen.

Die synchrone Kommunikation ist nicht skalierbar. Sie verwendet einen einzelnen Thread zur Verarbeitung einer Transaktion, und ein Lastenausgleich mit anderen Servern in der Gruppe ist nicht möglich, da der gesamte Prozess auf dem Server ausgeführt werden muss, der die Dokumente sendet.

Der synchrone Kommunikationsmechanismus sendet Dokumente direkt an BizTalk Server zur unmittelbaren Verarbeitung. BizTalk Server sperrt die Rückgabe an den Aufrufer der IInterchange::SubmitSync-Methode, bis die Verarbeitung abgeschlossen ist, wodurch ein Antwortdokument an den Aufrufer gesendet wird. Dieser Mechanismus steht nur für die COM-basierte Integrationsmethode zur Verfügung.

Empfohlene Lösungen für die Optimierung synchroner und asynchroner Kommunikation

Zur Erzielung optimaler Leistung und Skalierbarkeit wird dringend der Einsatz der asynchronen Kommunikation empfohlen. Die asynchrone Kommunikation ist in hohem Maße skalierbar und stellt einen hohen Durchsatz bereit. Synchrone Kommunikationsaufrufe stellen beinahe unmittelbare Antworten an den aufrufenden Prozess bei einer großen Anzahl von Transaktionen zur Verfügung, da jeder SubmitSync-Aufruf unter einem separaten Thread ausgeführt wird.

Wenn jedoch zahlreiche gleichzeitige Aufrufe vorhanden sind, führt dies zur Ausführung einer großen Anzahl von Threads auf einem einzelnen Server, wodurch die Gesamtleistung von BizTalk Server sinkt. Microsoft Windows 2000 führt Kontextumschaltungen zwischen allen Threads durch, was zu einer Verringerung der Gesamtleistung von BizTalk Server führt. Darüber hinaus führen die folgenden Kriterien dazu, dass zwar eine synchrone jedoch keine asynchrone Kommunikationsversendung fehlschlägt:

  • Die Transaktionskriterien stimmen mit mehreren Kanälen überein.

  • Der Austausch enthält mehrere Dokumente.


Entwurf, Test und Analyse der Architektur

Zu den Hauptkomponenten von BizTalk Server 2002 zählen die BizTalk-Dienste, die BizTalk Server-Datenbanken und die Transportdienste. Die mangelhafte Konfiguration einer Komponente kann die Leistung des gesamten Systems beeinträchtigen.

Dieser Abschnitt stellt Informationen zum Definieren, Testen und Verbessern der Architektur von BizTalk Server für die Optimierung der Leistung bereit.

In diesem Abschnitt werden folgende Themen behandelt:

  • Architekturentwurf

  • Test und Analyse der Architektur

Verwandtes Thema

Skalieren von BizTalk Server


Architekturentwurf

Es wird dringend empfohlen, vor der Implementierung von BizTalk Server 2002 in eine Produktionsumgebung eine Testumgebung zu installieren, in der Sie die verschiedenen Faktoren testen können, die sich auf die Leistung von BizTalk Server auswirken. Auf diese Weise können Sie auf der Basis der erwarteten Anforderungen ermitteln, welche BizTalk Server-Architekturkonfiguration für Ihr Unternehmen am besten ist. Das Testen der Leistung ist erfolgreich, wenn es mit kontrollierten Prozessen durchgeführt wird. Dabei ist es wichtig, mit wenigen Variablen zu beginnen und dann langsam weitere Variablen hinzuzufügen. Wenn die Leistung zu sinken beginnt, können Sie problemlos den Grund für die sinkende Leistung ermitteln.

Beim Ermitteln der besten BizTalk Server-Architektur für Ihre Organisation sollten Sie die folgenden Faktoren berücksichtigen, die sich auf die Anzahl der Dokumente auswirken, die von BizTalk Server verarbeitet werden können:

  • Spezifikationsüberprüfung

  • Anwendungsintegrationskomponenten (Application Integration Components, AICs)

  • Transportdienste

  • Verschlüsselung

  • BizTalk-Orchestrierungsdienste

  • Firewalls

  • Zuordnungen

Weiterhin müssen Sie die Größe der verarbeiteten Dokumente sowie die aktuelle Serverkonfiguration berücksichtigen.

In diesem Abschnitt werden folgende Themen behandelt:

  • Entwickeln von Transaktionskomponenten

  • Festlegen von Transportarten

  • Ausgangsarchitektur

Verwandte Themen

Verwalten von Servern und Anwendungen

BizTalk-Orchestrierungsdienste

Anwendungsintegrationskomponenten

Erstellen von Spezifikationen und Zuordnen von Daten

Verwenden des BizTalk-Mappers

Ausführung von XLANG-Ablaufplänen

Verwenden des BizTalk-Orchestrierungs-Designers


Entwickeln von Transaktionskomponenten

Bei der Entwicklung von Transaktionskomponenten müssen Benutzer Transaktionen entwerfen und Transaktionseigenschaften für Geschäftsprozesse festlegen. Weitere Informationen zum Entwerfen von Transaktionen und Festlegen von Transaktionseigenschaften erhalten Sie unter:

  • Entwerfen von Geschäftsprozessen

  • Entwerfen von Transaktionen

  • Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

Bei der Entwicklung von Transaktionskomponenten müssen Benutzer zunächst ermitteln, welche Transaktionstypen von den Komponenten verarbeitet werden. In einer Business-to-Business-Umgebung oder einer Umgebung, in der Daten zwischen Anwendungen ausgetauscht werden, müssen Sie die Transaktionsanforderungen und -profile bestimmen. Folgendes Szenario ist beispielsweise denkbar: Eine einzelne Transaktion empfängt einen benutzerdefinierten XML-Auftrag und ordnet diesen einem standardmäßigen EDI-Auftrag zu, der später von einer benutzerdefinierten internen Anwendung verarbeitet wird.

Das Szenario erfordert, dass Sie eine Spezifikation für den XML-Auftrag und eine Spezifikation für den EDI-Auftrag erstellen. Verwenden Sie zum Erstellen dieser Spezifikationen den BizTalk-Editor, der XML- und EDI-Vorlagen enthält. Da die Vorlagen alle potenziellen Datensätze und Felder enthalten, können Sie nicht benötigte Datensätze und Felder entfernen und die Vorlagen dann anschließend als finale Spezifikationen speichern. Während der Entwurfszeit wirken sich alle Felder in einer Spezifikation, die überprüft werden müssen, negativ auf die Leistung von BizTalk Server 2002 aus. Weitere Informationen zum Optimieren von Spezifikationen erhalten Sie unter Erstellen und Optimieren von Spezifikationen.

Zusätzlich zum Erstellen einer Spezifikation müssen Sie Daten zuordnen. Da es verschiedene Möglichkeiten zur Konvertierung von Daten in Zuordnungsdateien gibt (mithilfe von XSLT-Konvertierungen, Funktoiden oder einem benutzerdefinierten Skript), die alle die Leistung beeinträchtigen, ist es wichtig, die verschiedenen Konvertierungsmethoden zu testen. Durch den Vergleich der verschiedenen Verfahren zur Datenkonvertierung kann gegebenenfalls die Beeinträchtigung der Leistung von BizTalk Server aufgrund von Zuordnungen reduziert werden. Weitere Informationen erhalten Sie unter Erstellen und Optimieren von Zuordnungen.

Informationen zu Techniken, die Sie bei der Ermittlung der effizientesten Transaktionskonfiguration unterstützen können, erhalten Sie unter Auswerten der Leistung einer Konfiguration.

Anmerkung

  • Verschiedene Fehler, die innerhalb einer benutzerdefinierten Skriptfunktion vom Microsoft XML-Parser (MSXML) zurückgegeben werden, werden ggf. nicht an den Server übergeben. Fehler, die zu einem Dokument in der Angehalten-Warteschlange gehören, geben ggf. nicht den Fehler wieder, der in dem Skript zurückgegeben wurde.

Verwandte Themen

Entwerfen von Geschäftsprozessen

Entwerfen von Transaktionen

Festlegen von Transportarten

Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung


Festlegen von Transportarten

Wenn Sie festlegen möchten, wie Daten gesendet und empfangen werden sollen, müssen Sie berücksichtigen, ob folgende Komponenten verwendet werden:

  • Business-to-Business-Transaktionen

  • Transaktionen zwischen Anwendungen

  • Transportdienste (Senden und Empfangen)

  • Verschlüsselung

  • HTTPS oder S/MIME

Überlegen Sie basierend auf der Art der Transaktionen, die verarbeitet werden, ob verschiedene Transportarten benötigt werden. Ermitteln Sie, ob eindeutige Transportarten für Business-to-Business-Transaktionen und für Transaktionen zwischen Anwendungen erforderlich sind, oder ob für beide Transaktionstypen die gleichen Transportarten verwendet werden können.


Ausgangsarchitektur

Bei der erfolgreichen Planung einer Ausgangsarchitektur müssen Sie Folgendes berücksichtigen:

  • Ein Server mit Microsoft SQL Server und BizTalk Server kann verwendet werden, um eine geringe Anzahl von Transaktionen zu verarbeiten.

  • Bei einer mäßig hohen Anzahl von Transaktionen können BizTalk Server und SQL Server auf separaten Computern installiert werden.

  • Ein vorhandener SMTP-Transportdienst kann zum Senden und Empfangen von Daten verwendet werden. Für diesen Transporttyp wird empfohlen, den Dienst auf einem separaten Server zu platzieren.

  • HTTP-, Message Queuing- oder Dateitransportdienste können verwendet werden, um Daten auf Festplattenlaufwerke zurückzuschreiben, die sich auf anderen Servern als dem lokalen BizTalk-Server befinden. Hierdurch kann die Leistung von BizTalk Server verbessert werden.

Eine Ausgangsarchitektur sollte so viele separate Server wie notwendig enthalten. Beispielsweise kann innerhalb einer Firma eine bestimmte Person SMTP-Server und Message Queuing verwalten, während eine andere Person die Sicherheitsrichtlinien verwaltet. Das Ziel einer Ausgangsarchitektur besteht darin, zu ermitteln, wie viele Server erforderlich sind und welche Hardware von diesen Servern benötigt wird, um den voraussichtlichen Arbeitsanfall zu verarbeiten. Nachdem Sie die erforderliche Serveranzahl ermittelt haben, sollten Sie die Ausgangsarchitektur testen.

Verwandtes Thema

Test und Analyse der Architektur


Test und Analyse der Architektur

Vor dem Testen der Architektur müssen Sie Folgendes durchführen:

  • Definieren Sie die architektonischen Komponenten.

  • Ermitteln Sie die Transaktionsanforderungen und –profile.

  • Ermitteln Sie, welche Transaktionskomponenten entwickelt werden müssen.

  • Ermitteln Sie die notwendigen Transportdienste.

Sie starten diesen Prozess, indem Sie einen Basisplan erstellen, der Folgendes enthält:

  • Konfigurieren der BizTalk-Messagingdienste, Organisationen, Dokumentdefinitionen, Kanäle und Messagingports, die zur Verarbeitung von Transaktionen benötigt werden.

  • Konfigurieren der BizTalk-Orchestrierungsdienste.

  • Installieren und/oder Konfigurieren von COM+-Anwendungen, BizTalk Server-Kanälen, Datenbanken oder Nachrichtenwarteschlangen, die für XLANG-Ablaufpläne erforderlich sind.

Sobald ein Basisplan eingerichtet wurde, verarbeiten Sie Transaktionen mithilfe von BizTalk Server. Dies hilft Ihnen, Faktoren zu ermitteln, die die Leistung beeinträchtigen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Auswerten der Leistung einer Konfiguration

  • Verbessern der Architektur

Verwandte Themen

Architekturentwurf

Skalieren von BizTalk Server


Auswerten der Leistung einer Konfiguration

Mithilfe des Microsoft Windows 2000-Tools Leistung kann die Leistung der BizTalk-Messagingdienste getestet werden.

Wenn Sie das Tool Leistung verwenden möchten, zeigen Sie im Startmenü auf Programme und dann auf Verwaltung, und klicken Sie dann auf Systemmonitor. Systemmonitor, ein Bestandteil des Tools Leistung, bietet eine grafische Darstellung der Leistungsindikatoren und zeigt an, wie sie sich im Laufe der Zeit ändern. Einige Leistungsindikatoren sollten jedoch abhängig von den überwachten Systemkomponenten überwacht werden. Es stehen zahlreiche Whitepaper zur Verfügung, in denen erläutert wird, wie die Leistung von Windows 2000, Internet-Informationsdienste (Internet Information Services, IIS), SQL Server und Message Queuing überwacht wird. In den folgenden Tabellen sind nur einige der wichtigsten zu überwachenden Objekte und Leistungsindikatoren aufgeführt. Darüber hinaus enthalten die Tabellen spezifische Informationen im Hinblick auf die zu überwachenden Objekte und Datenquellen, um die Leistung der BizTalk-Messagingdienste zu ermitteln.

Objekt | Leistungsindikator | Überprüfung | Betroffene Komponente
Active Server Pages | Aktuelle Anforderungen | Mit Ausnahme von Spitzenzeiten sollte keine bedeutende Warteschlange vorhanden sein. | HTTP-Transportdienste, die ASP-Seiten verwenden
 | Anforderungen/Sek. | Gibt das Volumen der ASP-Anforderungen an, die HTTP-Transportdienste empfangen (sofern ASP verwendet wird). Wenn Dateien in einer HTTP-Seite bereitgestellt werden, stellt dieser Leistungsindikator keine relevanten Informationen zur Verfügung. | HTTP-Transportdienste, die ASP-Seiten verwenden
 | Anforderung-Wartezeiten | Nahe null. | HTTP-Transportdienste, die ASP-Seiten verwenden
Netzwerkschnittstelle | Empfangene Bytes/s / Bytes gesendet/s | Wenn dieser Wert bei mäßiger Prozessor- und Speicherauslastung fast so hoch ist wie die Verbindungskapazität, wird die Leistung möglicherweise durch die Verbindung beeinträchtigt. | Alle
Prozess, Inetinfo-Instanz | Private Bytes | Überwachen Sie diesen Leistungsindikator, um Speicherverluste aufzudecken, oder um festzustellen, ob der maximal verfügbare RAM-Speicher ausgenutzt wurde. | HTTP-Transportdienst
Arbeitsspeicher | Verfügbare Bytes | Die verfügbaren Bytes sollten dauerhaft nicht weniger als 10 MB ausmachen. Andernfalls veranlasst eine Speicherauslastungsspitze, dass die Auslagerung auf die Festplatte gestartet wird. | Alle
 | Seitenfehler/s, Speicher: Seiteneingabe/s, und Speicher: Seitenlesevorgänge/s | Werden hier niedrige Werte verzeichnet, reagiert der Server schnell auf Anforderungen. Bei hohen Werten muss u. U. der RAM-Speicher auf dem Server erhöht werden. | Alle
Physischer Datenträger | Lesevorgänge/s und Schreibvorgänge/s | Zusammen sollten die Werte dieser beiden Leistungsindikatoren deutlich unter der Maximalkapazität des Datenträgers liegen. Um diesen Leistungsindikator zu aktivieren, zeigen Sie im Startmenü zunächst auf Programme, dann auf Zubehör, und klicken Sie dann auf Eingabeaufforderung. Geben Sie an der Eingabeaufforderung diskperf –y ein. Starten Sie dann den Computer neu. | SQL Server, Message Queuing und Dateitransportdienste
 | Zeit (%) | Der Wert dieses Leistungsindikators sollte deutlich unter 100 % liegen. Bei einem höheren Wert (er kann bis in den Bereich von 1.000 % anwachsen), fügen Sie weitere physikalische Datenträger hinzu, oder verschieben Sie eine der Datenbanken auf einen anderen Server. Der Wert dieses Leistungsindikators ist von der RAID-Konfiguration abhängig. | SQL Server, Message Queuing und Dateitransportdienste
 | Leerlaufzeit (%) | Der Wert dieses Leistungsindikators sollte über 20 % liegen. Liegt der Wert darunter, fügen Sie weitere physische Datenträger hinzu, oder verschieben Sie eine der Datenbanken auf einen anderen Server. Der Leistungsindikator Festplattenleerlaufzeit (%) ist ein besserer Indikator als Auslastung (%), da er von der RAID-Konfiguration unabhängig ist. Ist eine Ihrer Festplatten überlastet, müssen Sie die Last auf andere physische Datenträger neu verteilen oder weitere Datenträger zum überlasteten Laufwerk hinzufügen. | SQL Server, Message Queuing und Dateitransportdienste
 | Aktuelle Warteschlangenlänge | Bei diesem Leistungsindikator handelt es sich um die Anzahl der anstehenden Anforderungen auf dem Datenträger, wenn die Leistungsdaten gesammelt werden. Der Wert dieses Leistungsindikators sollte im Durchschnitt weniger als 2 betragen, damit die Leistung zufriedenstellend ist. | BizTalk Server, SQL Server
SQL Server | Transaktionen/Sekunde | Gibt an, wie hoch die zurzeit von SQL Server ausgeführte Aktivität ist. | SQL Server
BizTalk Server | Verarbeitete Dokumente/Sek. | Gibt an, wie schnell BizTalk Server 2002 Dokumente aus der Verarbeitungswarteschlange abruft und versendet. | BizTalk-Messagingdienste
 | Empfangene Dokumente/Sek. | Gibt an, wie schnell BizTalk Server Dokumente an die Verarbeitungswarteschlange sendet. Dieser Wert gibt nur die Anzahl der Dokumente wieder, die BizTalk Server empfangen hat (hierzu zählen Dokumente, die nicht analysiert werden können), nicht die Anzahl der Dokumente, die BizTalk Server am Prüfpunkt für die gemeinsam genutzte Warteschlangen gespeichert hat. Die Anzahl der Dokumente, die am Prüfpunkt für die gemeinsam genutzte Warteschlangen gespeichert sind, entsprechen dem Wert des Leistungsindikators Verarbeitete Dokumente/Sek. | BizTalk-Messagingdienste
 | Synchrone Versendungsvorgänge/Sek., Asynchrone Versendungsvorgänge/Sek. | Gibt an, wie schnell Aufrufe der Submit-Methode und/oder der SubmitSync-Methode erfolgen. Da jeder Austausch eine beliebige Anzahl von Dokumenten enthalten kann, ist dieser Leistungsindikator nicht hilfreich bei der Ermittlung der verarbeiteten Dokumente. Bei exklusiver Verwendung von Pass-Through (Verarbeitung von Austauschvorgängen ohne Analyse) müssen Sie diesen Leistungsindikator überwachen, um die eingehende Leistung zu ermitteln. | BizTalk-Messagingdienste
Nachrichtenwarteschlange | Nachrichten in der Warteschlange | Dieser Wert sollte nicht zu stark ansteigen (über 50.000), da dies zu einer übermäßigen Speicherauslastung auf dem Message Queuing-Server führt und die Leistung des gesamten Systems hierdurch beeinträchtigt wird. | Message Queuing-Transportdienst
System | Prozessor-Warteschlangenlänge | Dieser Leistungsindikator zeigt die Anzahl der Threads an, die in der gemeinsam von allen Prozessoren des Systems verwendeten Warteschlange auf die Verarbeitung warten. Weist dieser Leistungsindikator einen anhaltenden Wert von zwei oder mehr Threads auf, beeinträchtigt der Prozessor die Leistung des gesamten Systems. | Alle
 | Kontextänderungen/s | Weist dieser Indikator für BizTalk Server einen hohen Wert auf, kann der Grund hierfür darin liegen, dass Sende- und Empfangsfunktionen auf dem gleichen Server ausgeführt werden. Ist dies der Fall, sollten Sie erwägen, die Sende- und Empfangsfunktionen auf verschiedene Server zu verschieben. | Alle
Prozessor | Prozessorzeit (%) | Wenn der Wert dieses Leistungsindikators hoch ist, während die Auslastung von Netzwerkadapterkarte und Datenträger-E/A deutlich unterhalb der Kapazitätsgrenze liegen, hat der Prozessor einen negativen Einfluss auf die Leistung. Überprüfen Sie diesen Leistungsindikator auf einem Computer mit mehreren Prozessoren, um ein eventuelles Ungleichgewicht festzustellen. Während die Spitzenauslastung 100 % betragen kann, sollte die andauernde Auslastung unter diesem Wert liegen. Alle Serverelemente können horizontal skaliert werden. | Alle
Webdienst | GET-Anforderungen/s oder POST-Anforderungen/s | Gibt das Volumen der über die HTTP-Methoden get/post empfangenen Dateien an. | HTTP-Transportdienst

Es wurden keine Leistungsindikatoren speziell für den SMTP-Transportdienst aufgeführt, da für diesen Dienst eine Vielzahl von Produkten zur Verfügung steht. Unabhängig vom verwendeten SMTP-Transportdienst sollten Sie das Volumen der an und von BizTalk Server gesendeten Nachrichten überwachen. Durch die Überwachung der in der Tabelle aufgeführten Leistungsindikatoren können Sie Leistungseinbußen ermitteln. Da alle Komponenten zusammenarbeiten, um zu ermitteln, ob ein System fehlerfrei funktioniert, sollten Sie aufgrund schlechter Leistung einer Komponente keine grundlegenden Änderungen an der Systemkonfiguration vornehmen.

Die durch die Leistungsüberwachung gewonnenen Daten sind auch hilfreich beim Feststellen von Symptomen, die möglicherweise zum Auftreten von Problemen beitragen. Beispielsweise kann eine hohe Datenträgeraktivität darauf hinweisen, dass SQL Server eine große Datenmenge auf den Datenträger schreibt. Sie kann jedoch auch anzeigen, dass das System häufig Daten auf die Festplatte auslagert. Werden übermäßig häufig Daten auf die Festplatte ausgelagert, ist dies normalerweise ein Anzeichen für zu geringen Arbeitsspeicher. In diesem Fall ist die Datenträgeraktivität ein Indikator für ein Problem, jedoch nicht das Problem selbst.

Verwandtes Thema

Skalieren von BizTalk Server


Verbessern der Architektur

Durch die Ermittlung von Bereichen, die sich negativ auf die Leistung auswirken, können Sie die Systemarchitektur verbessern, um optimale Ergebnisse zu erzielen. Beispielsweise muss möglicherweise die Hardware aktualisiert werden, oder es ist u. U. erforderlich, verschiedene Komponenten von BizTalk Server auf separate Server zu verschieben. Außerdem müssen Sie gegebenenfalls die BizTalk Server-Einstellungen anpassen. Weitere Informationen zum Anpassen von Einstellungen erhalten Sie unter Optimieren der Servereigenschaften.

Stellen Sie sicher, dass die Änderungen methodisch durchgeführt werden. Nachdem Sie eine Änderung vorgenommen haben (z. B. das Hinzufügen von CPUs, das Ändern einer Einstellung oder die Aufteilung von Funktionen auf separate Server), dokumentieren Sie die Änderung. Testen Sie dann die neue Konfiguration, um zu ermitteln, ob die Leistung gesteigert wurde. Wenn die neue Konfiguration die Leistung verbessert, können Sie mit der Änderung der Konfiguration fortfahren. Sinkt die Leistung jedoch, sollten Sie den früheren Zustand der Konfiguration wiederherstellen und die Daten analysieren, um zu ermitteln, welche Umstände möglicherweise zum Auftreten des Problems beitragen.

Verwandtes Thema

Auswerten der Leistung einer Konfiguration


Bereitstellen der Leistung

Erstellen Sie einen laufenden Wartungsplan, um die Fehlerfreiheit und zukünftige Leistung von BizTalk Server sicherzustellen. BizTalk Server verarbeitet im Laufe der Zeit wahrscheinlich eine wachsende Anzahl von Dokumenten. Wenngleich die anfängliche BizTalk Server-Architektur zunächst eine zufrieden stellende Leistung erbracht hat, kann sie möglicherweise nicht mehr die gleiche Leistung bereitstellen, wenn die Anzahl der Transaktionen im Laufe der Zeit angewachsen ist, es sei denn, die Systemarchitektur oder die Konfiguration wird geändert. Hardwarefehler oder Situationen, in denen nicht genügend Arbeitsspeicher vorhanden ist, können die Leistung eines Systems ebenfalls beeinträchtigen.

In diesem Abschnitt werden folgende Themen behandelt:

  • Erstellen eines Wartungsplanes zur Sicherstellung der Leistung

  • Verwenden von Application Center 2000


Erstellen eines Wartungsplanes zur Sicherstellung der Leistung

Ein erfolgreicher Überwachungsplan enthält folgende Komponenten und Aktionen:

  • Ein detaillierter Plan der zu überwachenden Leistungsindikatoren. Es gibt beispielsweise mehrere Leistungsindikatoren von Windows 2000-Systemmonitor mit gültigen Schwellenwerten, die überwacht werden müssen, sowie verschiedene Interpretationen der Probleme, auf die die Schwellenwerte gegebenenfalls hinweisen. Darüber hinaus können Sie Probleme auf Anwendungsebene überwachen, z. B., ob SQL Server-Abfragen gültige Daten oder Hardwareproblembedingungen zurückgeben sollten.

  • Festlegen von Prozessen zur Lösung von Leistungsproblemen. Beispielsweise kann eine Meldung im Windows 2000-Ereignisprotokoll aufgezeichnet oder eine E-Mail-Benachrichtigung aktiviert werden, oder ein benutzerdefiniertes Programm kann eine Reihe von Ereignissen starten.

  • Festlegen der Leistungsschwellenwerte, die eine Benachrichtigung generieren. Ein Überwachungstool kann beispielsweise so konfiguriert werden, dass ein Ereignis in das Windows 2000-Ereignisprotokoll geschrieben wird, wenn die CPU zu 90 % ausgelastet ist. Bleibt die 90 %ige CPU-Auslastung für mehr als 5 Minuten bestehen, wird eine E-Mail--Nachricht versendet. Wie verschiedene Aktionen für unterschiedliche Problemschweregrade festgelegt werden, richtet sich nach dem verwendeten Überwachungstool.

  • Definieren einer Aktion als Antwort auf in den Windows 2000-Ereignisprotokollen veröffentlichte Ereignisse. Windows 2000, BizTalk Server 2002, SQL Server und systemeigene Microsoft-Transportdienste, wie z. B. Message Queuing und HTTP, schreiben Ereignisse in das Windows 2000-Ereignisprotokoll. Das Ereignisprotokoll enthält wichtige Informationen, die möglicherweise auf bevorstehende Probleme auf einem der Server in einem BizTalk Server-System hinweisen. Wenn Sie sich frühzeitig darum kümmern, können Sie einen Systemausfall vermeiden, der die Leistung des gesamten Systems beeinträchtigen würde. In dem Plan sollte auch festgelegt werden, wie häufig Protokolle überwacht und archiviert werden und welche Personen für die Aufgaben verantwortlich sind. Mithilfe von Microsoft Operations Manager (MOM) können die Protokolle mehrerer Server zusammengefasst und für eine konsolidierte Analyse in einer Datenbank erfasst werden. Weitere Informationen zu Microsoft Operations Manager erhalten Sie unter Informationen zu Microsoft Operations Manager (MOM).

  • Festlegen der erforderlichen Tools für die Leistungsüberwachung. Das integrierte Tool Windows 2000-Systemmonitor überprüft Leistungsindikatoren und kann Aktionen durchführen, wenn vordefinierte Bedingungen eintreten. Weitere Informationen zur Konfiguration von Warnungen in Systemmonitor erhalten Sie in der Windows 2000-Hilfe unter "Einrichten einer Überwachungskonfiguration". Darüber hinaus bieten Microsoft Application Center 2000 sowie eine Reihe von Tools von Drittanbietern zusätzliche Funktionen für die Leistungsüberwachung, wie z. B. die Protokollierung einer Datenbank und die Durchführung von Tests auf Anwendungsebene.


Verwenden von Application Center2000

BizTalk Server 2002 ~ Leistung und Skalierbarkeit

Verwenden von Application Center 2000

Microsoft Application Center 2000 enthält ein Tool mit der Bezeichnung Health Monitor. Health Monitor bietet weitergehende Funktionen als das Windows 2000-Ereignisprotokoll und Systemmonitor. Dieses Tool ermöglicht Administratoren die Einrichtung von Monitoren. Mit diesen Monitoren werden TCP/IP, Schwellenwerte der Datenquellen von Systemmonitor, Ereignisprotokollfehler und WMI-Ereignisse (Windows Management Instrumentation) überprüft. Für diese Monitore können Bedingungen konfiguriert werden. Wenn z. B. der Schwellenwert von 90 % einer CPU erreicht oder überschritten wird, wird eine bestimmte Aktion durchgeführt, wie z. B. das Versetzen eines Servers in den Offlinemodus oder das Versenden einer E-Mail--Nachricht an einen Administrator. Diese Tools können zur proaktiven Überwachung und Wartung von BizTalk Server 2002 verwendet werden.

Wichtig

  • Führen Sie keine Replikation der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) oder beliebiger COM+-Anwendungen durch, die als Host für XLANG-Ablaufpläne dienen. Wird der Komponentenlastenausgleich (Component Load Balancing, CLB) verwendet, müssen diese COM+-Anwendungen auf jedem Server installiert werden. An XLANG-Ablaufpläne gebundene COM-Komponenten können repliziert werden.


Skalieren von BizTalkServer

BizTalk Server 2002 ~ Leistung und Skalierbarkeit

Skalieren von BizTalk Server

Wenn Sie die Leistung durch Optimieren der Systemeinstellungen und von BizTalk Server optimiert haben, kann es weiterhin zu Engpässen aufgrund einer hohen Prozessorauslastung kommen. In diesem Fall müssen Sie die BizTalk Server-Lösung skalieren, um eine höhere Leistung zu erzielen. Es gibt zwei Möglichkeiten, um eine BizTalk Server-Konfiguration zu skalieren. Sie können vertikal (zentral) skalieren, indem Sie die Anzahl der Prozessoren sowie die von den einzelnen Servern verwendete Speichermenge erhöhen, oder Sie skalieren horizontal (dezentral), indem Sie zu der BizTalk Server-Konfiguration weitere Server hinzufügen.

Die Verteilung der Hauptkomponenten auf mehrere Server wird dringend empfohlen. BizTalk Server 2002 enthält folgende Hauptkomponenten:

  • BizTalk-Dienste. Zu diesen Diensten zählen die BizTalk-Messagingdienste und die BizTalk-Orchestrierungsdienste. Weitere Informationen finden Sie unter BizTalk-Messagingdienste und BizTalk-Orchestrierungsdienste.

  • Datenbanken. Zu den Datenbanken zählen die BizTalk-Messaging-Verwaltungsdatenbank, die Überwachungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen und die Persistenzdatenbank für die Orchestrierung.

  • Transportdienste. Zu den Transportdiensten gehören HTTP-, SMTP- und Dateidienste sowie Message Queuing. Jede Komponente weist eindeutige Skalierungsanforderungen auf.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Vertikales Skalieren von BizTalk Server

  • Horizontales Skalieren von BizTalk Server

Verwandte Themen

Verwalten von BizTalk Server-Datenbanken

Verwalten der BizTalk-Messaging-Verwaltungsdatenbank

Persistenz

Festlegen von Transporteigenschaften

Datenbank für gemeinsam genutzte Warteschlangen

Überwachungsdatenbank


Vertikales Skalieren von BizTalkServer

BizTalk Server 2002 ~ Leistung und Skalierbarkeit

Vertikales Skalieren von BizTalk Server

Mithilfe mehrerer Prozessoren und eines großen Speichervolumens kann BizTalk Server 2002 vertikal skaliert werden (zentrale Skalierung). Die vertikale Skalierung von BizTalk Server erfordert zwar weniger Server und ermöglicht eine problemlosere Standortverwaltung, diese Art der Skalierung verursacht jedoch höhere Kosten als die horizontale Skalierung und die Verbesserung der Softwarearchitektur. Sobald die maximale Kapazität der vorhandenen Hardware erreicht ist, müssen Sie mit der horizontalen Skalierung des Systems beginnen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Zentrales Skalieren von BizTalk Server

  • Zentrales Skalieren der Datenbanken

  • Zentrales Skalieren der Transportdienste


Zentrales Skalieren von BizTalkServer

BizTalk Server 2002 ~ Leistung und Skalierbarkeit

Zentrales Skalieren von BizTalk Server

Für die vertikale Skalierung von BizTalk Server 2002 wird das Durchführen folgender Schritte empfohlen:

  • Einsatz eines größeren Prozessors (z. B. Pentium III und die entsprechenden Xeon-Ableitungen mit großem L2-Cache).

  • Verwenden von SMP-Servern (Symmetric Multiple Processing) mit maximal 8 CPUs.

  • Verwenden eines schnelleren Datenträgersystems.

  • Verringern von Datei-E/A- und Netzwerkengpässen. Weitere Informationen finden Sie unter Optimieren der Leistung Ihrer BizTalk Server-Architektur

Empfohlene Lösungen für die vertikale Skalierung von BizTalk Server

Um eine optimale Leistung in Verbindung mit BizTalk Server zu erzielen, wird die Verwendung folgender Komponenten empfohlen:

  • Ein PIII Xeon MHz-Prozessorsystem mit mehreren Prozessoren (die höchstmögliche Taktfrequenz (MHz) für maximale Leistung), das auf 8 CPUs erweitert werden kann.

  • Ein L2-Prozessorcache mit 1 bis 2 MB (verbessert die Analyseleistung).

  • 1 GB RAM (höherer RAM-Speicher, wenn eine Organisation Dokumente mit mehreren MB verarbeitet).

  • Mehrere Netzwerkkarten mit 100 Mbit/s (Megabits pro Sekunde) oder größer, Netzwerkkarten verbunden mit 100 MB/s-Switchports zur Erhöhung des Netzwerk-E/A-Durchsatzes.

  • Mehrere Datenträger und Controller für Message Queuing und DTC-Datei- und Protokolloperationen (Distributed Transaction Coordinator). Erstellen von DTC-Protokolloperationen auf einem zentralen Remoteserver, um den Datei-E/A-Inhalt auf den lokalen BizTalk Server zu laden.

  • Konfigurieren der Datenträger als RAID 0 und RAID 1 für eine bessere Leistung der Datenbank für gemeinsam genutzte Warteschlangen und von Message Queuing.

  • Verwenden von mehrfach vernetzten Netzwerkschnittstellenkarten (NICs) in den BizTalk-Servern, um HTTP-Prozesse von den dedizierten Microsoft® SQL Server™-Prozessen der Datenbank für gemeinsam genutzte Warteschlangen und der BizTalk-Messaging-Verwaltungsdatenbank zu trennen. Denken Sie außerdem über die Verwendung eines Switchnetzwerks nach, um den Verkehr zur Netzwerkkarte zu reduzieren.

  • Bei diesen Empfehlungen wird davon ausgegangen, dass BizTalk Server auf einem abhängigen Server ausgeführt wird. Wenn die BizTalk-Dienste den Server gemeinsam mit anderen Anwendungsdiensten verwenden, wird der Einsatz zusätzlicher Hardware empfohlen.


Zentrales Skalieren der Datenbanken

Wenn Sie die Datenbanken vertikal skalieren möchten, müssen Sie die Festplattenkonfiguration ermitteln. Hierbei müssen Sie Durchsatz, Failover und Kosten berücksichtigen.

In der folgenden Tabelle werden die verfügbaren Optionen aufgeführt und die einzelnen Optionen miteinander verglichen.

RAID-Stufe | Kosten | Effektive Festplattenauslastung (Prozent) | Geschwindigkeit | Fehlertoleranz
0 (Striping) | Niedrig | 100 | Schnell | Niedrig
1 (Spiegeln) | Hoch | 50 | Mittel | Hoch
5 (Striping mit Parität) | Mäßig | Der effektive Speicherplatz ist der gesamte Speicherplatz aller Festplatten im Array minus 1 (für die Parität) | Langsam | Mäßig (Leistung sinkt nur bei fehlerhafter Festplatte)
0 + 1 (Spiegeln eines Arrays von Stripesetdatenträgern) | Hoch | 50 | Schnell | Hoch

Zur Erzielung einer optimalen Leistung wird die Installation eines effizienten RAID-Controllers (Redundant Array of Independent Disks) für die Zwischenspeicherung mit einer schnellen CPU und umfangreichem permanenten RAM-Speicher empfohlen. Darüber hinaus können Sie auch mehrere RAID-Stufen miteinander kombinieren, um die gewünschte Leistung zu erreichen. Beispielsweise bietet RAID 0 die beste Leistung, stellt jedoch keine Fehlertoleranz zur Verfügung. RAID 1 stellt die bestmögliche Fehlertoleranz bereit, jedoch nicht die beste Leistung (da Daten nur auf eine Festplatte und nicht gleichzeitig auf mehrere Festplatten geschrieben werden). Um eine optimale Leistung zu erzielen, können Sie RAID 1 und RAID 0 kombinieren, indem Sie ein Array von RAID 0-Datenträgern spiegeln.

Anmerkungen

  • RAID 5 erreicht oder übersteigt weder die Geschwindigkeit noch die Kosten jeder anderen RAID-Stufe. RAID 5 stellt deutliche Vorteile bereit, ist jedoch beim Schreiben von Daten auf Festplatten langsamer als RAID 0 oder RAID 1.

  • Für jede Strategie ist die Anzahl der Festplattencontroller von großer Bedeutung. Die Gesamtleistung lässt sich deutlich verbessern, wenn Sie eine Festplatte pro Controller verwenden. Bei der Konfiguration von Festplatten ist die effektive Verwendung von Festplattenkanälen ebenfalls wichtig. Bei Festplattenkanälen handelt es sich um Festplatten, die den gleichen Controller verwenden. Die Festplatten können als eigenständige Festplatten konfiguriert oder als Teil eines Arrays ausgeführt werden. Wenn ein Server beispielsweise 10 Festplatten enthält, von denen jeweils 5 in 2 Arrays angeordnet sind und jedes Array mit einem eigenen Controller verbunden ist, sind 2 Festplattenkanäle vorhanden.

Idealerweise befinden sich die BizTalk-Messaging-Verwaltungsdatenbank, die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die Persistenzdatenbank für die Orchestrierung auf separaten Festplattenkanälen, da hierdurch der Zugriff auf die einzelnen Datenbanken verbessert wird. Falls die Systemumgebung der Organisation jedoch erfordert, dass sich die Datenbanken auf einzelnen Servern befinden, ist es wichtig, dass Sie mit der Verwendung jeder Datenbank vertraut sind, wenn Sie das Bereitstellungsszenario planen.

  • Die BizTalk-Messaging-Verwaltungsdatenbank enthält sämtliche Konfigurationsinformationen für BizTalk Server, z. B. Organisationen, Servergruppen, Server, Kanäle und Messagingports. Die Informationen werden gelesen und im Speicher von Microsoft SQL Server zwischengespeichert. Diese Datenbank erhält die geringste Aktivität der 4 Datenbanken und kann sich, falls erforderlich, auf dem gleichen Festplattenkanal befinden wie eine der anderen 3 Datenbanken.

  • Die Datenbank für gemeinsam genutzte Warteschlangen verwaltet die Daten für alle Warteschlangen. Jedes Dokument, für das die asynchrone Kommunikation verwendet wird, wird an die Datenbank für gemeinsam genutzte Warteschlangen gesendet und dort gespeichert. Wenn BizTalk Server bereit ist, das Dokument zu verarbeiten, wird es aus der Datenbank für gemeinsam genutzte Warteschlangen entfernt und verarbeitet. Da die Datenbank sämtliche Transaktionen verwaltet, werden häufig Daten in die Datenbank für gemeinsam genutzte Warteschlangen geschrieben und aus der Datenbank gelesen.

  • Die Überwachungsdatenbank überwacht Dokumente, die den Server durchlaufen, entweder einzeln oder als Batch. In dieser Datenbank werden sowohl die Daten als auch die Protokollinformationen gespeichert. Daher werden häufig Daten in die Überwachungsdatenbank geschrieben, jedoch nur selten Daten aus dieser Datenbank gelesen.

  • Die Persistenzdatenbank für die Orchestrierung speichert die Struktur der XLANG-Ablaufpläne, den Fortschritt der aktivierten XLANG-Ablaufplaninstanzen und die Nachrichten, die gesendet oder empfangen werden, wenn eine XLANG-Ablaufplaninstanz eine Transaktion beginnt oder beendet, das System heruntergefahren wird oder wenn die XLANG-Ablaufplaninstanz pausiert.

    Anmerkung

    • Die am häufigsten verwendeten Datenbanken sind die Überwachungsdatenbank und die Datenbank für gemeinsam genutzte Warteschlangen. Es wird empfohlen, diese für einen optimalen Lastenausgleich zwischen zwei Servern zu verteilen.

Empfohlene Optimierung für die vertikale Skalierung der Datenbanken

Berücksichtigen Sie Folgendes, um eine optimale Leistung der BizTalk Server-Datenbanken zu erzielen:

  • Ein PIII Xeon MHz-Prozessorsystem mit mehreren Prozessoren (die höchstmögliche Taktfrequenz (MHz) für maximale Leistung), das auf 8 CPUs erweitert werden kann.

  • 1 GB RAM (größerer RAM, wenn eine Organisation Dokumente mit mehreren Megabyte verarbeitet).

  • Optimieren der zugrunde liegenden Microsoft SQL Server-Datenbanken und -Protokolle basierend auf den Standardmethoden für Datenbanken. Weitere Informationen zu SQL Server erhalten Sie, wenn Sie im Startmenü zunächst auf Programme und dann auf Microsoft SQL Server zeigen und anschließend auf Onlinedokumentation klicken.

  • Wenn Sie zu Beginn planen, nur wenige Transaktionen durchzuführen, können Sie die Datenbanken auf dem gleichen Festplatten-E/A-Kanal installieren. Wenn weitere Transaktionen verarbeitet werden, fügen Sie Festplatten und/oder Controller auf einem Server hinzu, und verschieben Sie die Datenbanken auf die neuen Festplatten-E/A-Kanäle. Darüber hinaus kann eine einzelne Datenbank auf einen neuen Server verschoben werden. Weitere Informationen zum horizontalen Skalieren der Datenbanken erhalten Sie unter Dezentrales Skalieren der Datenbanken.

  • Falls die CPU-Auslastung 80 % übersteigt, fügen Sie weitere CPUs hinzu.

  • Falls die durchschnittliche Warteschlangenlänge des Datenträgers mehr als 1 beträgt oder die Datenträger-E/A-Auslastung an 100 % herankommt, sollten Sie weitere physische Datenträger hinzufügen.

  • Installieren Sie die Datenbank auf einem eigenen Festplatten-E/A-Kanal.

  • Erwerben Sie Datenträger mit der schnellsten Zugriffszeit und Controller mit dem höchsten Durchsatz.

  • Erwägen Sie den Einsatz von RAID 0, und führen Sie eine Spiegelung durch, um Fehlertoleranz zu erhalten.

So optimieren Sie die BizTalk-Messaging-Verwaltungsdatenbank

  • Installieren Sie die Datenbank auf einem eigenen Server oder Festplattenkanal.

  • Wenn eine Organisation sehr umfangreiche Datenmengen verarbeitet, sollten Sie erwägen, die Datenbank auf einem eigenen Festplatten-E/A-Kanal zu platzieren, damit die Leistung der Datenbank für gemeinsam genutzte Warteschlangen oder der Überwachungsdatenbank nicht beeinträchtigt wird.

So optimieren Sie die Überwachungsdatenbank

  • Fügen Sie weitere physische Datenträger hinzu, und erhöhen Sie den Festplattenspeicher der Datenbank für gemeinsam genutzte Warteschlangen.

  • Schätzen Sie die durchschnittliche Dokumentgröße für eine einzelne Transaktion. Multiplizieren Sie die Dokumentgröße mit der Anzahl der Anmeldungen des Dokuments an der Überwachungsdatenbank. Dieser geschätzte Wert gibt an, wie viel Dokumentspeicherplatz je Dokument in der Überwachungsdatenbank erforderlich ist. Multiplizieren Sie den Wert des Dokumentspeicherplatzes mit dem erforderlichen Durchsatz, um zu ermitteln, wie viel Speicher benötigt wird, bevor die Überwachungsdatenbank voll ist. Stellen Sie sicher, dass die Überwachungsdatenbank über ausreichend Speicher verfügt, um ein durchschnittlich großes Dokument zu protokollieren.

  • Installieren Sie die Datenbank auf einem eigenen Festplatten-E/A-Kanal, da umfangreiche Datenmengen in diese Datenbank geschrieben werden. Ein separater Festplatten-E/A-Kanal ist besonders wichtig in Umgebungen, in denen sehr viele Transaktionen durchgeführt werden.

  • Wählen Sie die mindestens erforderliche Überwachung für das System aus.

    Anmerkung

    • Für die Überwachung von Austauschvorgängen und Dokumenten existiert eine Größenbeschränkung. Wird diese überschritten, wirkt sich dies deutlich auf die Leistung von BizTalk Server aus. Weitere Informationen zur Größenbeschränkung finden Sie unter Austausch- und Dokumentgrößenbeschränkung.

So optimieren Sie die Persistenzdatenbank für die Orchestrierung

  • Da häufig Daten in diese Datenbank geschrieben und aus ihr gelesen werden, sollte die Datenbank über einen eigenen Festplatten-E/A-Kanal verfügen. Erwerben Sie möglichst Datenträger mit der schnellsten Zugriffszeit und Controller mit dem höchsten Durchsatz. Erwägen Sie den Einsatz von RAID 0, und führen Sie eine Spiegelung durch, um Fehlertoleranz zu erhalten.

  • Wenn die CPU-Auslastung 80 Prozent übersteigt, fügen Sie weitere CPUs hinzu.

  • Falls die durchschnittliche Warteschlangenlänge des Datenträgers mehr als 1 beträgt oder die Datenträger-E/A-Auslastung an 100 % herankommt, sollten Sie weitere physische Datenträger hinzufügen.

Verwandtes Thema

Skalieren von BizTalk Server


Zentrales Skalieren der Transportdienste

BizTalk Server 2002 unterstützt 4 Transportdienste. Jeder der Transportdienste kann vertikal skaliert werden.

  • HTTP/HTTPS

  • Datei

  • SMTP

  • Message Queuing

Folgende Themen werden in diesem Abschnitt behandelt:

  • Zentrales Skalieren von HTTP/HTTPS

  • Zentrales Skalieren von Dateien

  • Zentrales Skalieren von SMTP

  • Zentrales Skalieren von Message Queuing


Zentrales Skalieren von HTTP/HTTPS

Empfangen

Die HTTP-Empfangsfunktion sendet Dokumente entweder an das Dateisystem oder, durch das Aufrufen der Methode IInterchange::Submit() oder SubmitSync() des Interchange-Objekts von BizTalk Server, direkt in BizTalk Server. Die HTTP-Empfangsfunktion unterstützt HTTP- und HTTPS-Transportprotokolle. Die HTTP-Empfangsfunktion verwaltet einen konfigurierbaren Threadpool, der die bereitgestellten Dokumente verarbeitet.

Wird Secure Hypertext Transfer Protocol (HTTPS) in Umgebungen mit hohen Datenmengen zum Empfangen von Dokumenten verwendet, wird die Leistung aufgrund der Entschlüsselungsverarbeitung reduziert. Je nach Sicherheitsanforderungen einer Organisation müssen Daten gegebenenfalls unter Verwendung von HTTPS verschlüsselt werden. Diese zusätzliche Sicherheitsstufe kann sich ebenfalls auf die Leistung von BizTalk Server auswirken.

Senden

Beim Senden von Dokumenten mithilfe des HTTP-Transportdienstes gelten dieselben Sicherheits- und Leistungsaspekte wie beim Empfangen von Dokumenten mithilfe der HTTP-Empfangsfunktion.

Empfohlene Optimierung für die vertikale Skalierung von HTTP/HTTPS

So optimieren Sie die Leistung der HTTP-Empfangsfunktion und des HTTP/HTTPS-Transportdienstes und verbessern damit die Leistung von BizTalk Server

  • Erhöhen Sie die Taktfrequenz (MHz) der für BizTalk Server benötigten CPU (um dem zusätzlichen Bedarf für das Senden oder Empfangen von Dokumenten gerecht zu werden), und fügen Sie weitere CPUs hinzu, bis die gewünschte Leistungsstufe erreicht ist.

  • Wenden Sie empfohlene Vorgehensweisen an, wenn Sie ASP-Seiten mit dem HTTP/HTTPS-Sendedienst verwenden. Weitere Informationen zum Optimieren von ASP-Seiten und Internet-Informationsdienste erhalten Sie, wenn Sie die Hilfe zu Internet-Informationsdienste (Internet Information Services) aufrufen (localhost/iisHelp) und auf Active Server Pages-Handbuch klicken.


Zentrales Skalieren von Dateien

Empfangen

Wenngleich beim Verwenden einer Dateiempfangsfunktion für "Business-to-Business"-Transaktionen eine hohe Leistung erzielt wird, bietet eine Dateiempfangsfunktion nicht ausreichend Sicherheit für internetbasierte Transaktionen und wird daher nicht häufig verwendet. Bei Transaktionen zwischen Anwendungen innerhalb eines Unternehmens kann eine Dateiempfangsfunktion jedoch optimale Leistung bereitstellen, ohne die Sicherheit zu gefährden. Darüber hinaus ist es sicher, eine Dateiempfangsfunktion mit externen Handelspartnern zu verwenden, vorausgesetzt, sie wird mit einer weiteren Empfangsfunktion (z. B. SMTP oder HTTP) kombiniert. Die SMTP- oder HTTP-Empfangsfunktion kann ein Dokument von einem Handelspartner akzeptieren (mit HTTPS oder S/MIME, um die Sicherheit zu gewährleisten) und die Datei in ein internes Dateisystemverzeichnis übernehmen. Anschließend kann BizTalk Server das Dokument mit einer Dateiempfangsfunktion empfangen. Durch diese Kombination von Transportdiensten wird zwar nicht die Leistung erhöht, aber die Flexibilität und Sicherheit verbessert.

Anmerkung

  • Beim Verwenden von S/MIME wird die Leistung von BizTalk Server deutlich verringert.

Senden

Die im Zusammenhang mit der Dateiempfangsfunktion erläuterten Sicherheits- und Leistungsaspekte gelten auch für das Senden von Dokumenten mit einem Dateitransportdienst.

Empfohlene Optimierung für die vertikale Skalierung der Dateiempfangsfunktion und des Dateitransportdienstes

So optimieren Sie die Leistung der Dateiempfangsfunktion und des Dateitransportdienstes und verbessern damit die Leistung von BizTalk Server

  • Verwenden Sie ein lokales Dateiverzeichnis anstelle eines Remotedateiverzeichnisses, um die Netzwerkwartezeit zu reduzieren.

  • Verwenden Sie Festplattenarrays, um einen hohen Durchsatz zu erzielen. Weitere Informationen zur Geschwindigkeit von Festplattenarrays und zu redundanzbedingten Kompromissen erhalten Sie unter Zentrales Skalieren der Datenbanken.

  • Verwenden Sie Festplattencontroller mit Lesezwischenspeicherung, wenn Sie die Dateiempfangsfunktion verwenden.

  • Verwenden Sie Festplattencontroller mit permanenter Schreibzwischenspeicherung, wenn Sie den Dateitransportdienst verwenden.


Zentrales Skalieren von SMTP

Empfangen

Es ist keine systemeigene SMTP-Empfangsfunktion in BizTalk Server 2002 integriert. Eine SMTP-Empfangsfunktion kann ein Dokument über einen ereignisbasierten Mechanismus empfangen und das Dokument an BizTalk Server senden. Wenn eine SMTP-Empfangsfunktion vorhanden ist, akzeptiert BizTalk Server das MIME/SMIME-codierte Dokument und bereitet es für die Verarbeitung vor.

Senden

Beim Senden von Dokumenten mithilfe von SMTP als Transportdienst gelten dieselben Sicherheits- und Leistungsaspekte wie in den Abschnitten für eingehende S/MIME und ausgehende HTTP/HTTPS erläutert. Wenn ein Kanal SMTP als Transportdienst in einem Messagingport oder Port verwendet, verarbeitet der verarbeitende Server das Dokument und sendet es an die empfangende Anwendung.

Anmerkung

  • Die Leistung von BizTalk Server wird stark herabgesetzt, wenn ein digitales Zertifikat benötigt wird, um das ausgehende Dokument mit S/MIME zu codieren.

Empfohlene Optimierung für die vertikale Skalierung von SMTP

So optimieren Sie die Leistung des SMTP-Dienstes und verbessern damit die Leistung von BizTalk Server

  • Die erzielte Leistung hängt zum großen Teil von dem für den Dokumentempfang verwendeten SMTP-Dienst ab. Eine Organisation kann über einen SMTP-Server verfügen, der diese Funktion ausführt. Wenn jedoch kein SMTP-Server verfügbar ist und Microsoft Exchange Server oder ein Messagingsystem eines Drittanbieters verwendet wird, ist für den Server gegebenenfalls umfangreiche neue Hardware erforderlich, um eine adäquate Leistungsstufe für BizTalk Server beizubehalten. Der SMTP-Server muss in der Lage sein, einen ereignisbasierten Mechanismus aufzurufen, der Dokumente an BizTalk Server senden kann.

  • Wenn BizTalk Server in einer Organisation auf einem SMTP-Server ausgeführt wird, wird die CPU-Leistung hierdurch beeinträchtigt. Um die Leistungsbeeinträchtigung zu minimieren, verwenden Sie eine schnellere CPU.

  • Wird in einer Organisation S/MIME (Secure Multipurpose Internet Mail Extensions) verwendet, wird die Leistung von BizTalk Server erheblich verringert. Um die allgemeine Leistungsbeeinträchtigung von BizTalk Server aufgrund der Verwendung von S/MIME zu reduzieren, verwenden Sie schnellere CPUs.


Zentrales Skalieren von MessageQueuing

BizTalk Server 2002 ~ Leistung und Skalierbarkeit

Zentrales Skalieren von Message Queuing

Empfangen

Message Queuing verwendet zum Senden und Empfangen von Nachrichten umfangreiche Datenträger-E/A. Message Queuing ist transaktionsorientiert; dies wird zur Verbesserung der Fehlertoleranz unbedingt empfohlen. Die Transaktionsorientierung bezieht sich jedoch nur auf einen lokalen Server. Wenn Message Queuing zur Verbesserung der Fehlertoleranz verwendet wird, muss eine adäquate Anzahl von Festplatten auf jedem BizTalk-Server installiert werden, um die erhöhte Datenträger-E/A zu verarbeiten.

Senden

Beim Senden von Dokumenten mithilfe von Message Queuing treten die gleichen Sicherheits- und Leistungsprobleme auf wie beim Empfangen von Dokumenten mit Message Queuing.

Empfohlene Optimierung für die vertikale Skalierung von Message Queuing

So optimieren Sie die Leistung von Message Queuing und verbessern damit die Leistung von BizTalk Server:

  • Verwenden Sie Transaktionswarteschlangen (in BizTalk Server müssen lokale Warteschlangen anstelle von Remotewarteschlangen verwendet werden, damit Nachrichten in Transaktionswarteschlangen empfangen werden können) und einen schnellen Festplatten-E/A-Kanal. Anders als bei einer öffentlichen Nachrichtenwarteschlange muss eine lokale Warteschlange Microsoft® Active Directory™ nicht abfragen. Daher wird eine bessere Leistung erzielt, wenn Daten aus lokalen Nachrichtenwarteschlangen gelesen und in diese geschrieben werden. Mit nicht-transaktionsorientierten lokalen Warteschlangen kann eine bessere Leistung erreicht werden. Diese Warteschlangen stellen jedoch nicht die gleiche Zuverlässigkeit wie transaktionsorientierte Warteschlangen bereit. Außerdem wird zusätzlicher Speicher benötigt.

    Anmerkung

    • Weitere Informationen zur Festlegung der Hardwareanforderungen für Message Queuing erhalten Sie in der Windows 2000 Server-Hilfe unter "Auswählen der Message Queuing-Serverhardware".
  • Die maximale Größe für Message Queuing-Nachrichten beträgt 4 MB. Für Dokumente, die größer sind als 4 MB, kann der Message Queuing-Transportdienst nicht verwendet werden. Die Persistenzdatenbank für die Orchestrierung verfügt über eine Größenbeschränkung für Dokumente von 2 MB.

  • Message Queuing ist datenbankintensiv, wenn Journaleinträge verwendet werden. Stellen Sie bei der Einrichtung der Message Queuing-Transportdienste sicher, dass die Standardregeln für die Optimierung von Datenbanken angewendet werden.

  • Um einen maximalen Durchsatz zu erzielen, trennen Sie Daten und Protokolle, und verwenden Sie mehrere Festplatten und Controller.


Horizontales Skalieren von BizTalkServer

BizTalk Server 2002 ~ Leistung und Skalierbarkeit

Horizontales Skalieren von BizTalk Server

Bei einer erfolgreichen BizTalk Server 2002-Implementierung wird sowohl eine vertikale als auch eine horizontale (dezentrale) Strategie verwendet, um die Dienste zu optimieren. Während bei der vertikalen Skalierung die Anzahl der erforderlichen Server verringert wird, bietet die horizontale Skalierung folgende Vorteile:

  • Höhere Leistung. Die Leistung übertrifft die kosteneffektiv auf einem einzelnen Server erzielbare Leistung.

  • Fehlertoleranz des Servers. Wenn sich mehrere Server in einer Gruppe die Arbeitslast teilen, können beim Ausfall eines Servers die anderen Server in der Gruppe die Last aufnehmen.

  • Trennung und Optimierung der verschiedenen Komponenten. Die Leistung der BizTalk-Dienste, der Datenbanken und der Transportdienste kann gesteigert werden.

Bei der horizontalen Skalierung von Hardware werden im Vergleich zur vertikalen Skalierung die Kosten minimiert. Bei wachsender Komplexität der Standortverwaltung muss in der Organisation jedoch mit einer vertikalen Skalierung begonnen werden.

In diesem Abschnitt werden folgende Themen behandelt:

  • Horizontales Skalieren der BizTalk-Messagingdienste

  • Dezentrales Skalieren der Datenbanken

  • Dezentrales Skalieren der Transportdienste

Verwandtes Thema

Skalieren von BizTalk Server


Horizontales Skalieren der BizTalk-Messagingdienste

BizTalk-Messagingdienste können mithilfe von Servergruppen horizontal skaliert werden. Servergruppen sind Zusammenstellungen einzelner Server, die zentral verwaltet, konfiguriert und überwacht werden. Weitere Informationen zum Hinzufügen und Konfigurieren von Servergruppen erhalten Sie unter Gruppen und Server.

Server, die Mitglieder der gleichen Servergruppe sind, verwenden gemeinsam folgende Komponenten:

  • Eine Datenbank für gemeinsam genutzte Warteschlangen, die die Aktivität im BizTalk Server-Statusmodul überwacht.

  • Eine Überwachungsdatenbank, die die Dokumentaktivität protokolliert und Berichte generiert.

  • Eine BizTalk-Messaging-Verwaltungsdatenbank, in der Konfigurationsinformationen gespeichert sind.

  • Empfangsfunktionen.

  • Alle Komponenten, die der Server zur Laufzeit benötigt, wie z. B. Transportkomponenten und Anwendungsintegrationskomponenten (Application Integration Components, AICs) sowie Datenkonvertierung, Datenverschlüsselung und Signierung.

Eine BizTalk-Servergruppe stellt keinen Mechanismus zum Lastenausgleich für den Empfang eingehender Dokumente oder zur Vereinfachung der Dokumentversendung mithilfe von DCOM (Distributed Component Object Model) zur Verfügung. Sie können jedoch den Netzwerklastenausgleich mit der HTTP-Empfangsfunktion oder den Komponentenlastenausgleich (Component Load Balancing, CLB) verwenden, um die Arbeitslast auf die verschiedenen Server zu verteilen. BizTalk Server ermöglicht jedoch die Verarbeitung auf mehreren Servern. Sobald ein Dokument an die Datenbank für gemeinsam genutzte Warteschlangen gesendet wurde, kann jeder Server der Gruppe das Dokument verarbeiten, serialisieren und versenden. Aufgrund dieser Funktion kann ein Server in einer Gruppe ein Dokument senden, das ein anderer Server verarbeitet.

Eine Organisation kann mehrere Servergruppen verwenden, um Folgendes durchzuführen:

  • Gruppieren ähnlicher Transportdienste (HTTP oder File)

  • Verbessern der Sicherheit

  • Kategorisieren von Handelspartnern

Weiterhin können Servergruppen verwendet werden, um doppelte Konfigurationen für die Organisation sowie Kanäle und Messagingports zu vermeiden. Servergruppen verwenden gemeinsame Datenbanken. Die Konfigurationsinformationen für die Organisation sowie für Gruppen, Kanäle und Messagingports werden in der BizTalk-Messaging-Verwaltungsdatenbank gespeichert. Daher können zwei oder mehr BizTalk-Servergruppen die gleiche BizTalk-Messaging-Verwaltungsdatenbank verwenden.

Anmerkung

  • Wenn mindestens zwei BizTalk Server-Gruppen dieselbe BizTalk-Messaging-Verwaltungsdatenbank verwenden, muss jede Gruppe über eine eigene Datenbank für gemeinsam genutzte Warteschlangen, eine Überwachungsdatenbank und eine Persistenzdatenbank für die Orchestrierung verfügen, auf die alle Mitglieder der Gruppe zugreifen können.

Empfohlene Lösungen für die horizontale Skalierung von BizTalk Server

Zur Optimierung der BizTalk Server-Leistung können Sie Transportdienste und Emfpangsfunktionen trennen und Parser prioritisieren.

Trennen von Transportdiensten und Empfangsfunktionen

Durch die Aufteilung von Transportdiensten und Empfangsfunktionen auf BizTalk-Servergruppen lässt sich eine höhere Leistung erzielen. Die erreichte Leistung richtet sich nach der Anzahl und der Größe der verarbeiteten Dokumente und der Komplexität der Datenkonvertierung. BizTalk Server stellt separate Threadpools für den Empfang und die Verarbeitung von Daten bereit. Durch das Trennen von Transportdiensten und Empfangsfunktionen werden Kontextumschaltungen reduziert, da der Server nicht mehr zwischen Sende- und Empfangsoperationen wechseln muss.

Sämtliche Server verarbeiten standardmäßig Arbeitsobjekte. Hierbei wird ein Arbeitsobjekt aus der Datenbank für gemeinsam genutzte Warteschlangen entnommen, verarbeitet und mithilfe des Transportdienstes, für den der Kanal konfiguriert ist, versendet (Verarbeitung ausgehender Arbeitsobjekte). Durch diesen Prozess wird die Gesamtleistung der CPU herabgesetzt, wenn Sie außerdem Empfangsfunktionen und Transportdienste verwenden, da Kontextumschaltungen stattfinden müssen. Sofern zwei oder mehr Server verwendet werden, kann die Leistungsreduzierung vermieden werden, indem mindestens ein Server als Empfangsdienst eingesetzt wird. Um einen Server als Empfangsdienst zu konfigurieren, deaktivieren Sie in der BizTalk Server-Verwaltung die Funktion An Arbeitsobjektverwaltung teilnehmen und erstellen eine neue Empfangsfunktion für den Server.

Weitere Informationen zum Deaktivieren der Funktion An Arbeitsobjektverwaltung teilnehmen erhalten Sie unter Konfigurieren eines Servers in einer Gruppe. Weitere Informationen zum Einrichten einer Dateiempfangsfunktion erhalten Sie unter Hinzufügen einer Dateiempfangsfunktion. Weitere Informationen zum Einrichten einer Message Queuing-Empfangsfunktion erhalten Sie unter Hinzufügen einer Message Queuing-Empfangsfunktion. Weitere Informationen zum Einrichten einer HTTP-Empfangsfunktion erhalten Sie unter Hinzufügen einer HTTP-Empfangsfunktion.

Anmerkung

  • Beim Message Queuing können nur durchgeführte Lesevorgänge aus lokalen Warteschlangen verarbeitet werden. Daher kann nur ein einzelner Server aus dieser Warteschlange lesen.

BizTalk Server empfängt Dokumente, wenn eine der folgenden Bedingungen zutrifft:

  • Eine Empfangsfunktion wurde auf dem gleichen Server wie BizTalk Server konfiguriert.

  • Jeder Prozess ist so konfiguriert, dass die Submit-Methode auf dem Server aufgerufen wird, auf dem BizTalk Server installiert wurde.

Priorität von Parsern

Durch die Bevorzugung von Parsern kann die Leistung von BizTalk Server optimiert werden. BizTalk Server stellt 4 Datenparser bereit:

  • XML

  • EDIFACT

  • X12

  • Flatfile

Wenn BizTalk Server ein Dokument empfängt, wird versucht, das Dokument nach der Reihenfolge der vorhergehenden Liste zu analysieren. Die Leistung von BizTalk Server lässt sich verbessern, indem Sie die am häufigsten verwendeten Parser an die Spitze der Liste verschieben. Weitere Informationen zum Konfigurieren der Parserreihenfolge erhalten Sie unter Konfigurieren der Parserreihenfolge für eine Servergruppe.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Komponentenlastenausgleich


Komponentenlastenausgleich

Beim Komponentenlastenausgleich (Component Load Balancing, CLB) handelt es sich um ein Feature von Microsoft Application Center 2002. CLB kann nur verwendet werden, wenn Application Center 2002 auf demselben Server wie Microsoft BizTalk Server 2002 installiert ist. CLB ermöglicht Organisationen den Lastenausgleich der BizTalk.Interchange.1-Komponente im COM+-Dienste-Manager. Bei CLB handelt es sich um einen Lastenausgleichsmechanismus für COM-Komponenten. In einer BizTalk Server-Umgebung bietet CLB einem HTTP-Transportdienst die Möglichkeit, mit der Submit-Methode einen Cluster von Servern anstelle eines einzelnen Servers aufzurufen. Für die sendende Anwendung gleicht die Verwendung der Submit-Methode zum Aufrufen des Clusters der Versendung an einen Knoten.

Wenn beispielsweise eine benutzerdefinierte Anwendung verwendet wird, kann eine einzige Versendung einen beliebigen Server im Cluster erreichen. Ohne CLB muss die benutzerdefinierte Anwendung so konfiguriert werden, dass die Versendung an einen der drei Server erfolgt. Wenn im zweiten Szenario der Server ausfällt, an den die benutzerdefinierte Anwendung entsprechend ihrer Konfiguration sendet, muss die benutzerdefinierte Anwendung neu konfiguriert werden, um an einen anderen Server in der BizTalk-Servergruppe zu senden.

Wichtig

  • CLB kann nur zu Aktivierung von XLANG-Ablaufplänen verwendet werden. Alle XLANG-Ablaufpläne müssen auf dem Server enden, auf dem sie gestartet wurden.


Dezentrales Skalieren der Datenbanken

Wenn Sie die Datenbanken horizontal skalieren möchten, müssen Sie jede Datenbank auf einem eigenen Server installieren. In Umgebungen mit einer großen Anzahl von Transaktionen können durch das Installieren einer Datenbank auf einem eindeutigen Server die CPU, Datenträger-E/A und Speicherressourcen des Servers der entsprechenden Datenbank zugeordnet werden.

Empfohlene Optimierung für die horizontale Skalierung der Datenbanken

So optimieren Sie die Datenbankleistung von BizTalk Server

  • Verwenden Sie Xeon- anstelle von Pentium III-Prozessoren.

  • Installieren Sie jede Datenbank auf einem separaten Server mit einer schnelleren CPU. Installieren Sie keine der Datenbanken auf demselben Server wie BizTalk Server 2002.

  • Installieren Sie auf jedem Server in Ihrer Konfiguration eine Persistenzdatenbank.

  • Verwenden Sie mehrere Netzwerkkarten mit 100 Mbit/s (Megabits pro Sekunde) oder mehr verbunden mit 100 MBit/s-Switchports zur Erhöhung des Netzwerk-E/A-Durchsatzes.

  • Verwenden Sie für eine Organisation, die nur wenige Dokumente verarbeitet, eine problemlos aktualisierbare Datenbank. Wenn die Verarbeitungsanforderungen steigen, verschieben Sie die Datenbank für gemeinsam genutzte Warteschlangen, die Überwachungsdatenbank und die Persistenzdatenbank für die Orchestrierung auf eigene Server.

  • Installieren Sie für die Überwachungsdatenbank schnelle Netzwerkhardware, um die großen Mengen unkomprimierter Daten zu kompensieren, die zwischen BizTalk Server und der Datenbank ausgetauscht werden.

  • Denken Sie bei der dezentralen Skalierung der Datenbanken daran, dass das Verschieben der BizTalk-Messaging-Verwaltungsdatenbank schwieriger ist, da in dieser Datenbank alle BizTalk Server-Basiskonfigurationsinformationen gespeichert sind sowie die Informationen, die von den Servern für Empfangsfunktionen verwendet werden, Speicherorte anderer Datenbanken usw. Zum Verschieben der BizTalk-Messaging-Verwaltungsdatenbank müssen Sie einen benutzerdefinierten Prozess für die Replikation aller Informationen in Ihre neue Datenbank erstellen, um dann die Einstellungen aller Server manuell zu ändern, damit sie auf den neuen Standort verweisen. Es wird deshalb dringend empfohlen, dass der Server, auf dem die BizTalk-Messaging-Verwaltungsdatenbank gespeichert wird, ausreichend Festplattenspeicher und Arbeitsspeicher enthält, damit die Konfiguration bei steigenden Anforderungen an die Dokumentverarbeitung zwischengespeichert werden kann.

Verwandtes Thema

Skalieren von BizTalk Server


Dezentrales Skalieren der Transportdienste

BizTalk Server unterstützt 4 Transportdienste. Jeder dieser Transportdienste kann horizontal skaliert werden:

  • HTTP

  • Datei

  • SMTP

  • Message Queuing

Folgende Themen werden in diesem Abschnitt behandelt:

  • Dezentrales Skalieren von HTTP/HTTPS

  • Dezentrales Skalieren von Dateien

  • Dezentrales Skalieren von SMTP

  • Dezentrales Skalieren von Message Queuing


Dezentrales Skalieren von HTTP/HTTPS

Empfangen

Die HTTP-Empfangsfunktion kann mithilfe eines Webclusters horizontal skaliert werden. Beispielsweise kann ein Handelspartner ein Dokument an eine Adresse senden, wobei die Versendung jedoch an einen beliebigen Server im Cluster weitergeleitet werden kann. Webcluster sind ein Feature des in Microsoft Windows 2000 Advanced Server enthaltenen Netzwerklastenausgleichsdienstes (Network Load Balancing, NLB). Weitere Informationen zum Konfigurieren des Netzwerklastenausgleichs erhalten Sie in der Windows 2000 Advanced Server-Hilfe.

Um die Leistung von BizTalk Server zu verbessern, können Sie einen Webcluster konfigurieren, um die eingehenden Dokumente auf die mit HTTP-Empfangsfunktionen konfigurierten Server zu verteilen. Die HTTP-Empfangsfunktion ruft dann die Submit-Methode auf, um empfangene Dokumente in einem Dateiverzeichnis oder in einer Nachrichtenwarteschlange zu platzieren.

Senden

Die horizontale Skalierung des sendenden HTTP/HTTPS-Transportdienstes ist ein integriertes Feature im Zusammenhang mit der Verwendung mehrerer Server in einer Gruppe, die für die Teilnahme an der Arbeitsobjektverwaltung konfiguriert sind. Die HTTP/HTTPS-Sendefunktion kann nicht von dem Dokumente verarbeitenden Computer mit BizTalk Server getrennt werden, da die Sendefunktion auf jedem Server in der Gruppe verwendet wird, der für die Teilnahme an der Arbeitsobjektverwaltung konfiguriert ist.

Empfohlene Optimierung für die horizontale Skalierung von HTTP/HTTPS

So optimieren Sie den HTTP/HTTPS-Transportdienst und verbessern damit die Leistung von BizTalk Server

  • Erstellen Sie eine Gruppe mit Lastenausgleich aus Computern mit BizTalk Servern. Hierdurch wird die Leistung des empfangenden HTTP/HTTPS-Transportdienstes weiter verbessert, da horizontale Skalierungsredundanz bereitgestellt wird. Weitere Informationen zum Erstellen eines Webclusters mithilfe des Netzwerklastenausgleichs erhalten Sie in der Windows 2000 Advanced Server-Hilfe.

  • Arbeiten Sie mit Ihren Geschäftspartnern an der Anwendung empfohlener Vorgehensweisen, wenn Sie ASP-Seiten mit dem HTTP/HTTPS-Sendedienst verwenden. Weitere Informationen zum Optimieren von ASP-Seiten und Internet-Informationsdienste erhalten Sie, wenn Sie die Hilfe zu Internet-Informationsdienste (Internet Information Services) aufrufen (localhost/iisHelp) und auf Active Server Pages-Handbuch klicken.


Dezentrales Skalieren von Dateien

Empfangen

Wenngleich die Festlegung eines Computers mit BizTalk Server für die Dateiempfangsfunktion zu einer Minimierung der Leistungsbeeinträchtigung der Datenträger-E/A führen kann, wirkt sich die Netzwerkwartezeit negativ auf die Leistung aus, wenn versucht wird, die Datei abzurufen. Dieses Problem kann behoben werden, indem Dateien in einer Netzwerkfreigabe mit einer schnellen Karte platziert werden oder in ein lokales Verzeichnis auf einem der Server geschrieben werden, aus dem dann alle Server mit einer Dateiempfangsfunktion lesen.

Senden

Eine horizontale Skalierung wird erzielt, wenn mehrere Server in der Gruppe Dokumente verarbeiten und anschließend an den Dateitransportdienst senden. Die Leistung richtet sich danach, ob BizTalk Server als Empfangsfunktion verwendet wird oder ob BizTalk Server als separater Server für die Empfangsfunktion konfiguriert ist.

Empfohlene Optimierung für die horizontale Skalierung einer Dateiempfangsfunktion oder eines Dateitransportdienstes

So optimieren Sie eine Dateiempfangsfunktion oder einen Dateitransportdienst und verbessern die Leistung von BizTalk Server

  • 3Platzieren Sie die Dateien in einer Netzwerkfreigabe mit einer schnellen Karte, oder schreiben Sie in ein lokales Verzeichnis auf einem der Server, aus dem dann alle Server mit einer Dateiempfangsfunktion lesen.

  • Konfigurieren Sie eine Empfangsfunktion, die auf jedem Server in der Gruppe ausgeführt wird und dieselbe Dateiempfangsfunktion abruft, um sicherzustellen, dass alle Server in der Gruppe Dokumente zur Verarbeitung abrufen. Dateiempfangsdienste sind standardmäßig so konfiguriert, dass sie auf einem Server innerhalb einer Gruppe ausgeführt werden. Wenn eine Gruppe also 5 Server enthält und Sie eine Dateiempfangsfunktion für die Ausführung auf einem Server in der Gruppe konfigurieren, ruft nur dieser eine Server Dateien zur Verarbeitung ab, wenn unter \\receiveserver\receivelocation eine Dateiempfangsfunktion abgerufen wird. Hierdurch wird die Anzahl der dokumentverarbeitenden Server auf einen Server für die gesamte Gruppe begrenzt. Die verbleibenden 4 Server können keine Dateien von der zu analysierenden Empfangsfunktion abrufen. Weitere Informationen finden Sie unter Hinzufügen einer Dateiempfangsfunktion. Folgen Sie den Schritten zum Erstellen einer Dateiempfangsfunktion auf allen Servern in der Gruppe, und stellen Sie sicher, dass Sie für alle Empfangsfunktionen denselben Abrufspeicherort verwenden.

  • Lassen Sie die Teilnahme weiterer Server an der Arbeitsobjektverwaltung zu. Da es sich beim Senden und Empfangen von Dateien um unterschiedliche Prozesse handelt, versenden alle Server der Gruppe, die für die Teilnahme an der Arbeitsobjektverwaltung konfiguriert sind, Dateien. Die horizontale Skalierbarkeit des Dateitransportdienstes basiert nur auf der Anzahl der Server in der Gruppe, die für die Teilnahme an der Arbeitsobjektverwaltung konfiguriert sind.


Dezentrales Skalieren von SMTP

Empfangen

SMTP kann zwar Dokumente von BizTalk Server empfangen, jedoch keine Dokumente an BizTalk Server senden. Zum Senden eines Dokuments an BizTalk Server muss Ihre SMTP-Lösung die Submit-Methode verwenden, damit eine Datei- oder Message Queuing-Empfangsfunktion das Dokument verarbeiten kann. Die SMTP-Hosts, die diese ereignisbasierten Mechanismen bereitstellen können (Microsoft Exchange Server oder ein Messagingserver eines Drittanbieters) verwenden normalerweise umfangreiche Hardwareressourcen. Daher wird die Fähigkeit zur Verarbeitung von Dokumenten eines Server durch das Hinzufügen dieser Funktion reduziert. Weitere Informationen finden Sie in der Dokumentation zu Ihrer SMTP-Lösung.

Senden

Lightweight SMTP-Transportdienste ohne ereignisbasierten Mechanismus können zum Versenden von Dokumenten mit SMTP verwendet werden. Der SMTP-Transporthost, der das Dokument sendet, agiert einfach als ein Relay-Agent. Der ausgehende SMTP-Host ist auf Gruppenebene konfiguriert, nicht auf Serverebene. Wenn der SMTP-Transportdienst auf einem Server einer Gruppe existiert, verwendet daher der Server, der den SMTP-Transportdienst enthält, diesen zum Senden ausgehender Dokumente. Alle übrigen Server in der Gruppe verwenden den gleichen Server für ausgehende SMTP-Daten.

Empfohlene Optimierung für die horizontale Skalierung von SMTP

So optimieren Sie den SMTP-Dienst und verbessern damit die Leistung von BizTalk Server

  • Konfigurieren Sie den SMTP-Host so, dass er auf einem anderen Server als die BizTalk-Dienste ausgeführt wird (Sende- und Empfangsfunktion). In den meisten Fällen verfügt eine Organisation über einen SMTP-Host im Netzwerk, der für Sende- und Empfangsfunktionen verwendet werden kann.


Dezentrales Skalieren von MessageQueuing

BizTalk Server 2002 ~ Leistung und Skalierbarkeit

Dezentrales Skalieren von Message Queuing

Empfangen

Sie müssen festlegen, ob die Message Queuing-Empfangsfunktion auf demselben Server wie BizTalk Server oder auf einem anderen Server installiert werden soll. Wenn Sie eine Transaktionswarteschlange verwenden, muss sich die Message Queuing-Empfangsfunktion auf demselben Server befinden. Andernfalls kann sich die Message Queuing-Empfangsfunktion auch auf einem anderen Server befinden. Weiterhin müssen Sie entscheiden, welche Leistungsnachteile Sie in Kauf nehmen möchten: Leistungsbeeinträchtigungen durch Datenträger-E/A auf dem lokalen BizTalk-Server oder Netzwerkwartezeit bei der Kommunikation zwischen mehreren Servern. Im zweiten Fall ist weiterhin ein Bedarf nach Datenträger-E/A vorhanden, jedoch auf dem Remoteserver, nicht auf dem lokalen Server. Weitere Informationen zur Festlegung der Hardwareanforderungen für den Message Queuing-Dienst erhalten Sie in der Windows 2000 Server-Hilfe unter "Auswählen der Message Queuing-Serverhardware".

Senden

Beim Senden von Dokumenten mithilfe von Message Queuing treten die gleichen Sicherheits- und Leistungsprobleme auf wie beim Empfangen von Dokumenten mit Message Queuing. Sie können jedoch durchgeführte Lesevorgänge an eine Remotewarteschlange verarbeiten.

Empfohlene Optimierung für die horizontale Skalierung von Message Queuing

So optimieren Sie die Leistung für Message Queuing und verbessern damit die Leistung von BizTalk Server

  • Message Queuing ist ein datenträgerintensiver Prozess. Sehen Sie zum Optimieren von Message Queuing von der Verwendung einer Transaktionswarteschlange ab.


Verwalten von Servern und Anwendungen

Mit den Verwaltungsfeatures, die mit der Microsoft® BizTalk Server 2002-Hilfe bereitgestellt werden, können Administratoren alle Installationen von BizTalk Server 2002 effizient und effektiv verwalten. BizTalk Server verfügt über vier Verwaltungsbereiche:

  • Serververwaltung

  • Anwendungsverwaltung

  • Programmgesteuerte Verwaltung

  • Datenbankverwaltung

In diesem Abschnitt werden die Server- und die Anwendungsverwaltung behandelt. Weitere Informationen zur programmgesteuerten Verwaltung und zur Datenbankverwaltung finden Sie unter BizTalk Server-Verwaltungsmodell.

Die BizTalk Server-Verwaltung stellt eine zentrale Benutzeroberfläche bereit, auf der Sie folgende Aufgaben durchführen können:

  • Hinzufügen und Verwalten von Servern, die mit BizTalk Server in Servergruppen installiert wurden

  • Konfigurieren von Servergruppeneigenschaften, beispielsweise des Speicherortes der Datenbank für gemeinsam genutzte Warteschlangen und der Überwachungsdatenbank

  • Konfigurieren und Verwalten von Empfangsfunktionen

  • Anzeigen und Verwalten von Warteschlangen

Die Anwendungsverwaltung umfasst das Konfigurieren und Verwalten von COM+-Anwendungen, die als Host für XLANG-Ablaufpläne dienen, die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und die Persistenzdatenbank für die Orchestrierung.

In diesem Abschnitt werden folgende Themen behandelt:

  • Ausführliche Informationen zur BizTalk-Serververwaltung finden Sie unter Informationen zur Serververwaltung.

  • Eine Kurzübersicht darüber, warum bestimmte Aufgaben ausgeführt werden müssen, finden Sie unter Gründe für das Durchführen von BizTalk Server-Verwaltungsaufgaben.

  • Detaillierte Anweisungen zum Ausführen von Aufgaben finden Sie unter Durchführen von BizTalk Server-Verwaltungsaufgaben.

  • Anweisungen zur Lösung von Problemen finden Sie unter Problembehandlung - BizTalk Server-Verwaltung.

Verwandte Themen

BizTalk Server-Verwaltungsmodell

BizTalk Orchestration Services


Informationen zur BizTalk Server-Verwaltung

Dieser Abschnitt stellt detaillierte Informationen zu den Konzepten bereit, die wichtig für das Verständnis der BizTalk Server-Verwaltung sind. Behandelt werden Verwaltungsaufgaben wie das Erstellen von Servergruppen, das Definieren von Empfangsfunktionen und das Erstellen von Datenbanken zum Verwalten, Anzeigen und Protokollieren der Dokumentaktivität in Microsoft BizTalk Server 2002.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Gruppen und Server

  • BizTalk Server-Verwaltung - Umgebung

  • Verwaltungscache

  • Verwalten von BizTalk Server-Datenbanken

  • Behandeln von Serverfehlern

  • Empfangsfunktionen

  • Verwenden von Warteschlangen

  • Administratorrechte


Gruppen und Server

In einer Datenaustauschumgebung, die die Verarbeitung einer großen Anzahl von Dokumenten unterstützt, sind für dezentrale Skalierungslösungen möglicherweise mehrere Server und Datenbanken erforderlich, um die Verarbeitungsanforderungen zu erfüllen. Gleichzeitig benötigen Unternehmen eine Möglichkeit der Zentralisierung und Verwaltung des Dokumentaustauschs, um die Gesamtkosten der Lösung durch eine vereinfachte Verwaltung zu senken.

Durch das Zusammenfassen von Servern in Gruppen und das Verwalten und Konfigurieren der Servergruppen mithilfe der BizTalk Server-Verwaltung ermöglicht Microsoft BizTalk Server 2002 sowohl eine dezentrale als auch zentrale Verwaltung des Dokumentaustauschs.

In diesem Abschnitt werden folgende Themen behandelt:

  • BizTalk Server-Gruppen

  • Beziehung zwischen Gruppen und Servern

  • Gruppenstatus

  • BizTalk-Server


BizTalkServer-Gruppen

BizTalk Server 2002 ~ Verwaltung

BizTalk Server-Gruppen

Eine Servergruppe ist das grundlegende Organisationsprinzip der BizTalk Server-Verwaltung. Servergruppen sind Zusammenstellungen einzelner Server, die zentral verwaltet, konfiguriert und überwacht werden.

Server in einer BizTalk Server-Gruppe haben folgende gemeinsame Eigenschaften:

  • Eine Datenbank für gemeinsam genutzte Warteschlangen, in der alle Dokumente bis zu ihrer erfolgreichen Verarbeitung dauerhaft gespeichert werden.

  • Eine Überwachungsdatenbank, die zum Protokollieren der Dokument- und Austauschaktivität sowie zum Ausführen von Berichten verwendet wird.

  • Empfangsfunktionen.

  • Alle Komponenten, die der Server zum Verarbeiten von Dokumenten und Austauschvorgängen benötigt, z. B. Transportkomponenten und Anwendungsintegrationskomponenten (Application Integration Components, AICs).

Eine zentrale BizTalk-Messaging-Verwaltungsdatenbank verwaltet mehrere Gruppen und Server. So verwenden alle Gruppen und Server, die in einer einzelnen BizTalk Server-Implementierung definiert sind, dieselben Konfigurationsinformationen. Diese Konfigurationsinformationen geben die Dokumentverarbeitungslogik für die Server an.

Sie müssen die gleiche BizTalk-Messaging-Verwaltungsdatenbank für alle Serverinstallationen angeben, damit Sie jeden Server und jede Gruppe über die Verwaltungskonsole von einem Remotestandort aus verwalten können. Auch wenn Sie aus Gründen der Skalierbarkeit und besseren Leistung mehrere Servergruppen einrichten, dürfen Sie nur eine zentrale BizTalk-Messaging-Verwaltungsdatenbank verwenden. Andernfalls können diese Server nicht gemeinsam die gleiche BizTalk-Messaging-Verwaltungskonfiguration verwenden.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren einer Servergruppe

BizTalk-Server

Empfangsfunktionen

Beziehung zwischen Gruppen und Servern

Verwenden von Warteschlangen


Beziehung zwischen Gruppen und Servern

Jede Installation von BizTalk Server 2002 muss über mindestens eine Servergruppe verfügen. Die Beziehung zwischen Gruppen und Servern ist durch die folgenden Punkte definiert:

  • Ein einzelner Server darf nur zu einer Servergruppe gehören.

  • Alle Server in einer Gruppe verwenden gemeinsam dieselbe Datenbank für gemeinsam genutzte Warteschlangen.

  • Alle Empfangsfunktionen einer Gruppe müssen auf einem der Server in dieser Gruppe ausgeführt werden.

  • Alle Server in einer Gruppe verwenden gemeinsam die gleichen Komponenten, wie z. B. Transportkomponenten und Anwendungsintegrationskomponenten (Application Integration Components, AICs), um Austauschvorgänge und Dokumente zu verarbeiten.

Die folgende Abbildung veranschaulicht die Beziehung zwischen Servergruppen in BizTalk Server 2002.

Logische Konfiguration von Gruppen und Servern.

Die Server 1 bis 6 werden mit BizTalk Server 2002 installiert. Die Server A bis D werden mit Microsoft® SQL Server™ installiert und sind für die Datenbankverwaltung dediziert. Obwohl die Server A bis D entweder für die Überwachungsdatenbank oder die Datenbank für gemeinsam genutzte Warteschlangen vorgesehen sind, kann sich die BizTalk-Messaging-Verwaltungsdatenbank auf einem dieser Server befinden, da sie in der Regel klein ist und den Prozessor wenig belastet. Um einen maximalen Durchsatz zu erreichen, wird ausdrücklich empfohlen, dass sich die Datenbank für gemeinsam genutzte Warteschlangen und die Überwachungsdatenbank auf zwei separaten Server befinden, die für diese Funktionen vorgesehen sind.

Wichtig

  • Auf allen Servern in einer Gruppe muss dieselbe Version und Sprache von BizTalk Server installiert sein. Wenn Server mit unterschiedlichen Versionen von BizTalk Server (BizTalk Server 2000, BizTalk Server 2000 Service Pack 1, BizTalk Server 2002 Enterprise Edition oder eine andere Sprachversion von BizTalk Server) in einer Gruppe installiert sind, funktionieren die Datenbanken nicht ordnungsgemäß.

  • Wenn ein neuer Server zu einer BizTalk Server-Gruppe hinzugefügt wird, muss dieser neue Server vor dem Hinzufügen zu der Gruppe über dieselbe Version von BizTalk Server verfügen.

Verwandtes Thema

Verwalten von BizTalk Server-Datenbanken


Gruppenstatus

Die BizTalk Server-Verwaltung zählt Servergruppen auf und gibt für jede Gruppe an, ob sie Verbindungen mit der Überwachungsdatenbank und/oder der Datenbank für gemeinsam genutzte Warteschlangen herstellen kann. Wenn Sie auf Microsoft BizTalk Server 2002 klicken, wird der Gruppenstatus unter der Statusleiste im Detailfensterbereich angezeigt. Folgende Gruppenstatuswerte werden unterschieden:

  • Verbunden. Gibt an, dass die Gruppe mit der Überwachungsdatenbank und der Datenbank für gemeinsam genutzte Warteschlangen verbunden ist.

  • Überwachungsverbindungsfehler. Gibt an, dass die Gruppe nicht mit der Überwachungsdatenbank verbunden ist.

  • Fehler bei Verbindung zu gemeinsam genutzten Warteschlangen. Gibt an, dass die Gruppe nicht mit der Datenbank für gemeinsam genutzte Warteschlangen verbunden ist.

  • Fehler bei Überwachungsverbindung und Verbindung zu gemeinsam genutzten Warteschlangen. Gibt an, dass die Gruppe weder mit der Überwachungsdatenbank noch mit der Datenbank für gemeinsam genutzte Warteschlangen verbunden ist.


BizTalk-Server

BizTalk-Server sind Computer, auf denen BizTalk Server installiert und konfiguriert wurde. Ein Server in einer Servergruppe dient als Host für die entsprechende Funktionalität der BizTalk-Messagingdienste – wie Datenkonvertierung, Verschlüsselung, digitale Signatur und Dokumentüberwachung –, um den Dokumentaustausch zwischen anderen externen Servern und Anwendungen zu verwalten, die sich außerhalb der BizTalk Server-Gruppe befinden. Jeder Server übergibt eingehende und ausgehende Dokumente an die Datenbank für gemeinsam genutzte Warteschlangen bzw. ruft sie aus der Datenbank ab, wobei er die entsprechenden COM-Methoden (Component Object Model) aufruft, um Dokumente zu transformieren, zu serialisieren, zu signieren, zu ver- oder entschlüsseln und zu transportieren.

Je nach Geschäftsanforderungen können Sie alle Server in einer Gruppe sowohl für den Empfang als auch die Verarbeitung von Nachrichten konfigurieren. Auf diese Weise lassen sich Server in einer Gruppe auf einfache Weise hinzufügen und entfernen, die alle dieselben Funktionen ausführen. Alternativ können Sie zur Maximierung der Leistung einige Server in einer Gruppe ausschließlich für den Empfang von Dokumenten und andere ausschließlich für die Verarbeitung von Dokumenten konfigurieren.

In diesem Abschnitt werden folgende Themen behandelt:

  • Grundlegendes zu Servereigenschaften

  • Serverstatus

Verwandte Themen

BizTalk Server-Gruppen

Beziehung zwischen Gruppen und Servern


Grundlegendes zu Servereigenschaften

Beim Konfigurieren eines Servers in einer Gruppe müssen Sie ein Gleichgewicht zwischen maximalem Durchsatz und Serverleistung finden. Ihre Unternehmensanforderungen, die Serverkapazität und die Netzwerkbandbreite sind einige der Faktoren, die Einfluss darauf haben, wie Sie die Servereigenschaften konfigurieren. Es wird dringend empfohlen, mit verschiedenen Kombinationen in einer Testumgebung zu experimentieren, die Ihre Produktionsumgebung simuliert, um zu ermitteln, welche Lösung in Ihrer Installation am besten funktioniert. In der BizTalk Server-Verwaltung können Sie die folgenden Servereigenschaften festlegen und ändern.

Maximale Anzahl von Empfangsfunktionsthreads

Die maximale Anzahl von Empfangsfunktionsthreads wird auf Prozessorbasis festgelegt. Der Wertebereich für diese Option beträgt 1 bis 128. Passen Sie diesen Wert an, um die Leistung der auf dem Server ausgeführten Empfangsfunktionen zu optimieren. In den meisten Fällen bewirkt ein Erhöhen der Anzahl der Empfangsfunktionsthreads eine Erhöhung des Durchsatzes der Empfangsfunktionen auf dem Server.

An Arbeitsobjektverwaltung teilnehmen

Wenn das Kontrollkästchen An Arbeitsobjektverwaltung teilnehmen aktiviert ist, verarbeitet der Server Dokumente in der Verarbeitungswarteschlange. Wenn dieses Kontrollkästchen deaktiviert ist, verarbeitet der Server keine Dokumente in der Verarbeitungswarteschlange.

Der Hauptgrund für das Konfigurieren eines Servers für die Nichtteilnahme an der Arbeitsobjektverwaltung besteht darin, im Rahmen einer Gesamtstrategie zur Optimierung des Durchsatzes den Server ausschließlich für das Empfangen von Nachrichten zu reservieren. Angenommen, eine BizTalk Server-Gruppe enthält drei Server, von denen zwei für die Verarbeitung und einer für den Empfang reserviert sind. Auf diese Weise wird ein optimaler Durchsatz erzielt, da die Anzahl der unterschiedlichen Arten von Verarbeitungskontexten und -aktivitäten auf den Servern minimiert wird. Benchmarktests haben gezeigt, dass es sich hierbei um eine effektive Methode der Durchsatzoptimierung handelt.

Maximale Anzahl von Arbeitsthreads pro Prozessor

Die maximale Anzahl von Arbeitsthreads wird auf Prozessorbasis festgelegt. Der Wertebereich für diese Option beträgt 1 bis 128. Ist der festgelegte Wert zu niedrig, kann es in Situationen mit hohem Datenverkehr zu einem Engpass bei BizTalk Server führen, wodurch der Gesamtdurchsatz verringert wird. Wird ein zu hoher Wert festgelegt, kann aufgrund der überzähligen nicht verwendeten Threads ebenfalls kein optimaler Durchsatz erzielt werden. Wichtig ist es, diese Einstellung zu variieren und anschließend den Durchsatz zu messen, um die optimale Einstellung für die BizTalk Server-Implementierung bestimmen zu können.

Die Einstellungen von Maximale Anzahl von Arbeitsthreads pro Prozessor und Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung sind zwei Faktoren, die die Menge an Datenverkehr beeinflussen, die Microsoft SQL Server-Datenbanken verarbeiten muss. Sie können den Datenverkehr zu den SQL-Datenbanken beschränken, indem Sie den Wert für Maximale Anzahl von Arbeitsthreads pro Prozessor niedrig, für Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung dagegen höher festlegen. Gleichfalls können Sie den Verkehr zu den Datenbanken erhöhen, indem Sie den Wert für die maximale Anzahl von Arbeitsthreads erhöhen und die Einstellung für den Zeitraum zwischen Aufrufen der Ablaufplanung verringern.

Anmerkung

  • Deaktivieren Sie das Kontrollkästchen An Arbeitsobjektverwaltung teilnehmen, wenn Sie auf diesem Server keine Arbeitsobjekte verarbeiten möchten. Legen Sie die Option Maximale Anzahl von Arbeitsthreads pro Prozessor nicht auf Null fest.

Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung (ms)

Der Wertebereich für Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung beträgt 1 bis 4.294.967.295. Es gibt einen Thread, der verfügbare Elemente in der Verarbeitungswarteschlange abruft. Die Option Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung steuert, wie häufig der Thread die Verarbeitungswarteschlange abfragt. Wenn Sie nicht viele Daten empfangen, wählen Sie hierfür einen hohen Wert. Wenn Sie viele Daten empfangen, kann es sinnvoll sein, diesen Wert zu verringern.

Verwandtes Thema

Konfigurieren eines Servers in einer Gruppe


Serverstatus

Die BizTalk Server-Verwaltung zählt die Server in einer Servergruppe auf und gibt die Liste der Server zurück. Die BizTalk Server-Verwaltung kann die folgenden Statuswerte für Server unterhalb der Statusleiste im Detailfensterbereich zurückgeben:

  • Wird ausgeführt. Gibt an, dass der Server ausgeführt wird.

  • Zugriff verweigert. Gibt an, dass Sie auf einem Server nicht über Microsoft® Windows® 2000-Administratorrechte verfügen.

  • Fehler. Gibt an, ob auf einem bei einer Servergruppe registrierten Server BizTalk Server 2002 entfernt wurde.

  • Beendet. Gibt an, ob ein Administrator die Ausführung eines Servers beendet hat.

  • Unbekannt. Gibt an, ob ein bei einer Servergruppe registrierter Server aus einem nicht bekannten Grund nicht verfügbar ist. Wenn dieser Fall eintritt, ist es wahrscheinlich, dass die Serververbindung verloren wurde.

Verwandtes Thema

Administratorrechte


BizTalkServer-Verwaltung - Umgebung

BizTalk Server 2002 ~ Verwaltung

BizTalk Server-Verwaltung - Umgebung

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk Server-Verwaltung - Benutzeroberfläche

  • BizTalk Server-Verwaltung - Tastenkombinationen

  • Verwaltungsfunktionen einer Toolsinstallation von BizTalk Server


BizTalkServer-Verwaltung - Benutzeroberfläche

BizTalk Server 2002 ~ Verwaltung

BizTalk Server-Verwaltung - Benutzeroberfläche

Die BizTalk Server-Verwaltung – auch als Verwaltungskonsole bezeichnet – ist ein MMC-Snap-In (Microsoft Management Console), das eine visuelle Darstellung der Microsoft BizTalk Server 2002-Komponenten bereitstellt, die ein Systemadministrator verwalten kann. Die linke Seite der Verwaltungskonsole wird als Konsolenstruktur bezeichnet und besteht aus Ordnern und Unterordnern, die verschiedene Elemente darstellen, wie z. B. Servergruppen. Die rechte Seite der Verwaltungskonsole wird als Detailfensterbereich bezeichnet und enthält Informationen zu dem Element, das in der Konsolenstruktur ausgewählt ist.

Grafisch wird BizTalk Server als Unterelement des Konsolenstamms auf der linken Seite der Verwaltungskonsole angezeigt. Jede in BizTalk Server konfigurierte Servergruppe wird in einem getrennten Unterordner angezeigt und besteht aus den Warteschlangen und Empfangsfunktionen der jeweiligen Gruppe sowie aus den Namen der Server in der Gruppe. Erweitern Sie ein beliebiges Element in der Konsolenstruktur, um weitere Details über das Element im Detailfensterbereich der Verwaltungskonsole anzuzeigen. Sie können mit der rechten Maustaste auf jedes der Elemente klicken, um es zu konfigurieren oder neue Elemente zu erstellen.

Verwandtes Thema

Öffnen der BizTalk Server-Verwaltung


BizTalkServer-Verwaltung - Tastenkombinationen

BizTalk Server 2002 ~ Verwaltung

BizTalk Server-Verwaltung - Tastenkombinationen

Sie können in der BizTalk Server-Verwaltung Tastenkombinationen verwenden, um Aufgaben durchzuführen. Die folgende Tabelle enthält eine Kurzübersicht der Tastenkombinationen der Microsoft Management Console (MMC).

Anmerkung

  • Um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind, können Sie mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server- und Advanced Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Taste/Tastenkombination | Zweck
F5 | BizTalk Server-Verwaltung aktualisieren. Diese Taste aktualisiert das aktuelle Element, das in der Konsolenstruktur markiert ist.
ALT+F4 | BizTalk Server-Verwaltung schließen.
ALT+MINUSZEICHEN | Das Fenstermenü für das aktive Konsolenfenster anzeigen.
UMSCHALT+F10 | Menü Vorgang für das ausgewählte Element anzeigen.
ALT+O | Menü Vorgang für das ausgewählte Element anzeigen.
ALT+A | Menü Ansicht anzeigen.
F1 | Onlinehilfe für das ausgewählte Element anzeigen.
ALT+EINGABE | Dialogfeld Eigenschaften, falls vorhanden, für das ausgewählte Element anzeigen.

Verwandtes Thema

Öffnen der BizTalk Server-Verwaltung


Verwaltungsfunktionen einer Toolsinstallation von BizTalk Server

Mithilfe der Toolsinstallationsfunktion können Sie das MMC-Snap-In (Microsoft Management Console) der Verwaltungskonsole von Microsoft BizTalk Server 2002 auf Clientcomputern ohne BizTalk Server installieren. Wenn Sie eine Toolsinstallation von BizTalk Server 2002 auf einem Clientcomputer ausführen, unterscheiden sich einige Funktionen der Verwaltungskonsole von den Funktionen, die auf einem Computer mit einer vollständigen Installation verfügbar sind.

Bei Installation auf einem Clientcomputer ermöglicht die Verwaltungskonsole die Remoteverwaltung einer oder mehrerer BizTalk Server-Konfigurationsdatenbanken über denselben Computer und die gleiche Benutzeroberfläche.

Nach der ersten Installation der Verwaltungskonsole auf einem Client ist die durch den Client zu verwaltende BizTalk-Messaging-Verwaltungsdatenbank noch nicht bestimmt. Wenn Sie jedoch bei der ersten Verwendung der Verwaltungskonsole nach der Installation den Knoten BizTalk Server 2002 auswählen, wird das Dialogfeld Verwaltungsdatenbank auswählen angezeigt. In diesem Dialogfeld können Sie die zu verwaltende Remoteverwaltungsdatenbank auswählen, indem Sie den Namen der SQL-Datenbank und den Computer mit Microsoft SQL Server angeben, auf dem sich die Datenbank befindet. Sie können die zu verwaltende Datenbank jederzeit ändern. Weitere Informationen finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank, die in einer Toolsinstallation verwaltet wird.

Im Folgenden werden sind Unterschiede zwischen einer Toolsinstallation der Verwaltungskonsole und der Installation der Konsole bei einer vollständigen Installation von BizTalk Server aufgeführt:

  • Wenn Sie in der Konsolenstruktur den Knoten BizTalk Server 2002 bei einer Toolsinstallation auswählen, enthält das Menü Vorgang nicht die Option Eigenschaften. Bei einer Toolsinstallation können Sie verschiedene BizTalk-Messaging-Verwaltungsdatenbanken und BizTalk Server-Gruppen anzeigen und verwalten. Sie können jedoch nicht die BizTalk-Messaging-Verwaltungsdatenbank ändern, auf die alle zur ursprünglichen Datenbank gehörenden BizTalk-Server zeigen.

  • Die Registerkarte Parser wird im Dialogfeld Eigenschaften der ausgewählten BizTalk Server-Gruppe nicht angezeigt.

  • Wenngleich Sie über die Verwaltungskonsole einer Toolsinstallation vorhandene Empfangsfunktionen verwalten können, ist es nicht möglich, deren erweiterte Eigenschaften auszuwählen oder zu ändern bzw. neue Empfangsfunktionen zu erstellen.

Anmerkungen

  • Die Verwaltungskonsole kann auch bei einer benutzerdefinierten Installation ausgewählt werden. Bei einer Toolsinstallation sind dieselben Funktionen verfügbar wie einer benutzerdefinierten Installation.

  • Wenn alle Funktionen bei einer benutzerdefinierten Installation ausgewählt werden (wodurch es sich um eine vollständige Installation handelt), entsprechen die Funktionen der Verwaltungskonsole denen bei einer vollständigen Installation.


Verwaltungscache

Beim Start von Microsoft BizTalk Server 2002 werden alle Elemente der BizTalk Server-Verwaltung, z. B. Servergruppen, Servergruppeneigenschaften, Empfangsfunktionen sowie Verbindungen mit der Datenbank für gemeinsam genutzte Warteschlangen und der Überwachungsdatenbank im Verwaltungscache gespeichert. Standardmäßig werden alle Elemente im Cache, mit Ausnahme der Serverdatenbankverbindungen und der Servereigenschaften, alle 50 Sekunden aktualisiert. Dies bedeutet, dass Änderungen der allgemeinen Eigenschaften einer Servergruppe, wie z. B. des SMTP-Hosts oder des Antwort-URLs für Reliable Messaging, innerhalb von 50 Sekunden übernommen werden.

Wenn jedoch Servereigenschaften geändert werden, wie z. B. die Maximale Anzahl von Arbeitsthreads pro Prozessor, muss der Server, auf dem die Konfiguration geändert wurde, beendet und neu gestartet werden, damit die Änderung im Cache gespeichert werden kann. Ebenfalls müssen Sie beim Ändern einer Verbindung mit der BizTalk-Messaging-Verwaltungsdatenbank, der Überwachungsdatenbank oder der Datenbank für gemeinsam genutzte Warteschlangen die Server in der Gruppe beenden und neu starten und die BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) beenden.

Verwandte Themen

Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

Herunterfahren der BizTalk Server-Austauschanwendung

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Verwalten von BizTalkServer-Datenbanken

BizTalk Server 2002 ~ Verwaltung

Verwalten von BizTalk Server-Datenbanken

Die drei den BizTalk-Messagingdiensten zugeordneten Datenbanken sind die folgenden:

  • BizTalk-Messaging-Verwaltungsdatenbank

  • Überwachungsdatenbank

  • Datenbank für gemeinsam genutzte Warteschlangen

Die den BizTalk-Orchestrierungsdiensten zugeordnete Datenbank heißt:

  • Persistenzdatenbank für die Orchestrierung

Die BizTalk-Messaging-Verwaltungsdatenbank speichert Informationen für alle Serverkonfigurationen, einschließlich der Gruppen- und Servereinstellungen und der Empfangsfunktionen. Die Konfiguration dieser Verwaltungsobjekte erfolgt mithilfe der BizTalk Server-Verwaltung oder programmgesteuert mithilfe des WMI-Providers (Windows Management Instrumentation) von BizTalk Server. Zusätzlich zur Verwaltungskonfiguration speichert die BizTalk-Messaging-Verwaltungsdatenbank alle Informationen der Messagingkonfiguration für Kanäle, Messagingports und andere Messagingobjekte. Die Konfiguration der Objekte erfolgt entweder über den BizTalk-Messaging-Manager oder programmgesteuert mithilfe des BizTalk-Messaging-Konfigurationsobjektmodells. Weitere Informationen zum Konfigurieren von Kanälen, Messagingports usw. finden Sie unter Verwenden des BizTalk-Messaging-Managers oder Messaging Services Reference.

Die Überwachungsdatenbank führt ein Protokoll aller Austauschvorgänge, Dokumente und Empfangsbestätigungen, die von den BizTalk-Messaging-Diensten verarbeitet werden. Weitere Informationen zur Überwachungsdatenbank finden Sie unter Überwachungsdatenbank. Informationen zum Konfigurieren der Überwachungseinstellungen finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe. Informationen zum Überwachen bestimmter Felder oder Daten von Dokumentinstanzen finden Sie unter Festlegen von Kanaleigenschaften.

Die Datenbank für gemeinsam genutzte Warteschlangen bewahrt Dokumente auf, während diese verarbeitet werden oder auf die Verarbeitung warten. Dokumente werden später nach der Verarbeitung entfernt. Weitere Informationen zur Datenbank für gemeinsam genutzte Warteschlangen finden Sie unter Datenbank für gemeinsam genutzte Warteschlangen.

Die BizTalk Server-Persistenzdatenbank für die Orchestrierung speichert die Struktur von XLANG-Ablaufplänen, den Status aktivierter XLANG-Ablaufplaninstanzen und die Nachrichten, die während der Ausführung der XLANG-Ablaufplaninstanz versendet und empfangen werden. Weitere Informationen finden Sie unter BizTalk-Orchestrierungsdienste.

In diesem Abschnitt werden folgende Themen behandelt:

  • Verwalten der BizTalk-Messaging-Verwaltungsdatenbank

  • Verwalten von BizTalk Server-Gruppendatenbanken


Verwalten der BizTalk-Messaging-Verwaltungsdatenbank

In den meisten Unternehmensimplementierungen existiert eine zentrale BizTalk-Messaging-Verwaltungsdatenbank, die zum Konfigurieren mehrerer Servergruppen, Server, Kanäle, Messagingports usw. verwendet wird. Es gibt Ausnahmen von dieser Regel. Ein Drittanbieter von Anwendungsdiensten kann z. B. basierend auf den speziellen Geschäftsanforderungen verschiedener Kundentypen eine getrennte BizTalk-Messaging-Verwaltungsdatenbank für die einzelnen Kundentypen benötigen. In den meisten Fällen ist jedoch eine zentrale BizTalk-Messaging-Verwaltungsdatenbank für alle BizTalk Server-Gruppen ausreichend.

Von Zeit zu Zeit kann es erforderlich sein, die zentrale BizTalk-Messaging-Verwaltungsdatenbank zu ändern. Beispielsweise muss möglicherweise der Server gewartet werden, auf dem sich die BizTalk-Messaging-Verwaltungsdatenbank befindet. In diesem Fall müssen alle Servergruppen auf eine replizierte BizTalk-Messaging-Verwaltungsdatenbank verweisen, wenn der Betrieb der BizTalk Server-Organisation aufrechterhalten werden soll. Es kann außerdem erforderlich sein, Server innerhalb einer oder zwischen mehreren BizTalk-Messaging-Verwaltungsdatenbank(en) zu verschieben.

Angenommen, Sie sind ein Drittanbieter mit drei Kunden: A, B und C. Wenn die Geschäftsaktivitäten von Kunde A nachlassen, während die der Kunden B und C zunehmen, können Sie die Server, die der BizTalk-Messaging-Verwaltungsdatenbank von Kunde A zugeordnet waren, zu den Datenbanken verschieben, die den Kunden B und C zugeordnet sind.

In diesem Abschnitt werden folgende Themen behandelt:

  • Ändern der BizTalk-Messaging-Verwaltungsdatenbank

  • Entfernen von Servern aus der BizTalk-Messaging-Verwaltungsdatenbank

  • Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken

  • Verschieben von Remoteservern zwischen BizTalk-Messaging-Verwaltungsdatenbanken

  • Ändern des Kennwortes für das Dienstkonto


Ändern der BizTalk-Messaging-Verwaltungsdatenbank

Es gibt zwei Möglichkeiten zum Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank:

  • Verwenden der während der Installation verfügbaren Konfigurationsoptionen

  • Verwenden der BizTalk Server-Verwaltung zum Ändern des Servers im Knoten Microsoft BizTalk Server 2002.

Wenn Sie alle BizTalk-Server zentral über einen einzigen Server verwalten möchten, konfigurieren Sie alle Server während der Installation so, dass sie auf eine zentrale BizTalk-Messaging-Verwaltungsdatenbank verweisen. Wenn Sie auf diese Weise vorgehen, verweisen bei jedem Öffnen der BizTalk Server-Verwaltung auf jedem dieser BizTalk-Server die im Knoten Microsoft BizTalk Server 2002 aufgelisteten Server auf die gleiche BizTalk-Messaging-Verwaltungsdatenbank und können zentral verwaltet werden. Wenn eine Zusammenstellung von Servergruppen auf eine zentrale BizTalk-Messaging-Verwaltungsdatenbank verweist, müssen Sie normalerweise nicht zu einer anderen BizTalk-Messaging-Verwaltungsdatenbank wechseln.

Eine Ausnahme besteht, wenn diese Datenbank aus Wartungsgründen in den Offlinemodus versetzt werden muss. Verwenden Sie in dieser Situation die BizTalk Server-Verwaltung, um alle Servergruppen im Knoten Microsoft BizTalk Server 2002 auf ein Replikat der ursprünglichen zentralen Datenbank verweisen zu lassen. Lassen Sie nicht vorübergehend Servergruppen auf eine andere zentrale BizTalk-Messaging-Verwaltungsdatenbank verweisen, der andere Servergruppen zugeordnet sind. Ansonsten kann es schwierig sein, zur ursprünglichen Konfiguration der BizTalk-Messaging-Verwaltungsdatenbank zurückzukehren.

Anmerkung

  • Um die BizTalk-Messaging-Verwaltungsdatenbank ändern zu können, müssen Benutzer Mitglieder der Gruppe BizTalk Server-Administratoren sein.

Verwandte Themen

BizTalk Server-Gruppen

Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank

Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken

Sicherheitsrichtlinien


Entfernen von Servern aus der BizTalk-Messaging-Verwaltungsdatenbank

Wenn alle BizTalk-Server aus der zentralen BizTalk-Messaging-Verwaltungsdatenbank entfernt werden, bleibt der Inhalt der Datenbank erhalten. Wenn Sie gleichermaßen über mehr als eine BizTalk-Messaging-Verwaltungsdatenbank in Ihrem System verfügen und alle BizTalk-Server aus einer BizTalk-Messaging-Verwaltungsdatenbank entfernen, bleibt der Inhalt dieser Datenbank erhalten. Sie können neue BizTalk-Server zur BizTalk-Messaging-Verwaltungsdatenbank hinzufügen, indem Sie den BizTalk Server 2002-Datenbankeinrichtungs-Assistenten ausführen und auf der Seite BizTalk-Messaging-Verwaltungsdatenbank konfigurieren eine vorhandene Datenbank auswählen. Weitere Informationen zum Hinzufügen oder Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server.

Anmerkung

  • Um Server aus der BizTalk-Messaging-Verwaltungsdatenbank zu entfernen, müssen Benutzer Mitglieder der Gruppe BizTalk Server-Administratoren sein.

Verwandte Themen

Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

Sicherheitsrichtlinien


Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken

Wenn Sie beabsichtigen, einen BizTalk-Server vorübergehend aus einer BizTalk-Messaging-Verwaltungsdatenbank in eine andere zu verschieben, muss mindestens ein weiterer BizTalk-Server in einer der Servergruppen in der ursprünglichen Datenbank verbleiben. Dadurch kann der BizTalk-Server auf einfache Weise wieder in die ursprüngliche Datenbank aufgenommen werden. Andernfalls müssen Sie zum Hinzufügen eines neuen BizTalk-Servers zur Datenbank den BizTalk Server-Datenbankeinrichtungs-Assistenten ausführen und auf der Seite BizTalk-Messaging-Verwaltungsdatenbank konfigurieren eine vorhandene Datenbank auswählen. Weitere Informationen zum Hinzufügen oder Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server.

Anmerkung

  • Um Server zwischen BizTalk-Messaging-Verwaltungsdatenbanken zu verschieben, müssen Benutzer Mitglieder der Gruppe BizTalk Server-Administratoren sein.

Verwandte Themen

Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

Gruppen und Server

Sicherheitsrichtlinien


Verschieben von Remoteservern zwischen BizTalk-Messaging-Verwaltungsdatenbanken

Wenn Sie versuchen, einen Remoteserver zu einer BizTalk-Messaging-Verwaltungsdatenbank hinzuzufügen, und sich dieser Server ursprünglich in einer anderen zentralen BizTalk-Messaging-Verwaltungsdatenbank befand, wird im Windows-Ereignisprotokoll die folgende Fehlermeldung angezeigt:

Eine neue Instanz der WMI-Klasse MicrosoftBizTalkServer_Server kann nicht im WMI-Provider von BizTalk Server erstellt werden. Der Server <servername> gehört möglicherweise bereits zu einer anderen BizTalk Server-Installation.

Dieser Fehler bedeutet, dass ein Versuch unternommen wurde, einen Remoteserver hinzuzufügen, der sich ursprünglich in einer anderen zentralen Datenbank befand. Wenn dieses Verfahren in der BizTalk Server-Verwaltung durchgeführt wurde, versucht die Verwaltungskonsole zu ermitteln, ob der Remoteserver ebenfalls zu einer Gruppe in der zentralen Remotedatenbank gehört. Die Verwaltungskonsole fragt den WMI-Provider (Windows Management Instrumentation) des Remoteservers ab, um diese Ermittlung durchzuführen. Wenn der Server zu einer Servergruppe in der anderen zentralen Datenbank gehört, wird eine Fehlermeldung der Verwaltungskonsole angezeigt, die besagt, dass kein Remoteserver hinzugefügt werden kann, der bereits zu einer Gruppe in einer anderen zentralen Datenbank gehört.

Anmerkung

  • Um Remoteserver zwischen BizTalk-Messaging-Verwaltungsdatenbanken zu verschieben, müssen Benutzer Mitglieder der Gruppe BizTalk Server-Administratoren sein.

Verwandte Themen

  • Fehler beim Verschieben eines Remoteservers in eine andere BizTalk-Messaging-Verwaltungsdatenbank

Sicherheitsrichtlinien

Informationen zu WMI (Windows Management Instrumentation)


Ändern des Kennwortes für das Dienstkonto

Microsoft BizTalk Server 2002 unterstützt beim Datenbankzugriff nur die integrierte Microsoft® Windows NT®-Authentifizierung. Dies bedeutet, dass die BizTalk-Messagingdienste, die auf Servern mit BizTalk Server 2002 ausgeführt werden, unter einem Konto mit Berechtigungen für BizTalk Server und SQL Server ausgeführt werden müssen. Obgleich Sie ein lokales Computerkonto verwenden können, das ordnungsgemäß für den Zugriff auf alle Server in Ihrer Umgebung eingerichtet wurde, wird ein Domänenkonto in allen Situationen empfohlen, insbesondere wenn sich SQL Server und BizTalk Server auf verschiedenen Servern befinden, da hierdurch die Verwaltung vereinfacht wird.

BizTalk Server enthält ein Befehlszeilenprogramm, mit dem Sie das Kennwort immer dann ändern können, wenn sich das von den BizTalk-Messagingdiensten verwendete Kennwort für das Dienstkonto ändert, so dass Sie das Kennwort nicht auf allen Servern ändern müssen. Mithilfe dieses Befehlszeilenprogramms kann auch das Konto geändert werden, unter dem die BizTalk-Messagingdienste ausgeführt werden.

Die Befehlszeilensyntax hat das folgende Format:

BTS_SvcPW {/? | {/s:<BTM SQL Server Name> /d:<BTM Database Name> {/u:<domain>\<user name> [/n:<domain>\<user name>] | /n:<domain>\<user name>} /p:<new password>}}

Dabei gilt:

[] gibt an, dass der Inhalt optional ist

<> enthält den Namen einer variablen Zeichenfolge

| ist der binäre Operator OR

In der folgenden Tabelle wird das Verhalten der Parameter erläutert, die in der Befehlszeile verwendet werden können.

Parameter | Zweck
/? | Zeigt die Hilfe zur Syntax für das Dienstprogramm an. Falls angegeben, dürfen keine weiteren Argumente verwendet werden.
/s:<BTM SQL Server-Name> | Enthält den Namen des SQL-Servers, auf dem sich die BizTalk-Messaging-Verwaltungsdatenbank (BTM) befindet. Diese Datenbank enthält die Server, für die der Benutzer das BizTalk Server Messaging-Dienstkonto und/oder -Kennwort ändern möchte. Dies ist ein erforderliches Argument des Befehlszeilenprogramms.
/d:<BTM-Datenbankname> | Gibt den Namen der BizTalk-Messaging-Verwaltungsdatenbank auf dem angegebenen SQL-Server an. Dies ist ein erforderliches Argument des Befehlszeilenprogramms.
/u:<Domäne>\<Benutzername> | Gibt die Domäne und den Benutzernamen an, unter der/dem die BizTalk-Messagingdienste gegenwärtig ausgeführt werden. Dieser Eintrag ist erforderlich, um zu überprüfen, ob das in dieses Dienstprogramm eingegebene Kennwort für den aktuellen Benutzer gültig ist. Das Kennwort wird nur auf dem lokalen Server überprüft, auf dem das Dienstprogramm ausgeführt wird. Es können nur die BizTalk-Messagingdienste geändert werden, die dieses Konto verwenden. Dies ist ein optionales Argument des Befehlszeilenprogramms.
/n:<Domäne>\<Benutzername> | Gibt die Domäne und den Benutzernamen an, unter der/dem die BizTalk-Messagingdienste beim nächsten Start ausgeführt werden. Bei Verwendung dieses Arguments wird das angegebene Kennwort für dieses Konto und nicht für das Konto überprüft, das die BizTalk-Messagingdienste gegenwärtig verwenden. Dies ist ein optionales Argument des Befehlszeilenprogramms.
/p:<Neues Kennwort> | Gibt das neue Kennwort an, das die BizTalk-Messagingdienste beim nächsten Start zur Anmeldung verwenden werden. Dies ist ein optionales Argument des Befehlszeilenprogramms. Wird es jedoch nicht angegeben, wird der Benutzer zur Eingabe eines neuen Kennwortes aufgefordert.

Mithilfe der BizTalk-Messaging-Verwaltungsdatenbank, die durch die Argumente /s und /d angegeben wird, werden alle Server aufgezählt, die diese Konfiguration verwenden. Bei den aufgezählten Servern, die das durch das Argument /u angegebene Konto verwenden, werden das Kennwort und optional das Konto selbst durch die anderen Argumente in der Befehlszeile geändert.

Wird das Argument /u nicht angegeben, werden die aufgezählten Server mithilfe der Argumente /n und /p aktualisiert. Das Argument /n muss angegeben werden. Anschließend werden alle Messagingserver in der BizTalk Server-Konfigurationsdatenbank (gemäß der Angabe für das Argument /s) so geändert, dass das neue Konto und das neue Kennwort verwendet werden.

Das Konto der BizTalk Server-Messagingdienste kann nur in ein Konto geändert werden, das über Zugriffsrechte für SQL Server und BizTalk Server verfügt. Eine Fehlermeldung wird angezeigt, wenn es in ein Konto geändert wird, das über unzureichende Rechte für den Datenbankzugriff verfügt. Stellen Sie sicher, dass das neue Konto über die Berechtigung Anmelden als Dienst verfügt. Bei jeder Ausführung dieses Dienstprogramms muss ein Kennwort angegeben werden. Wird in der Befehlszeile kein Kennwort angegeben, fordert das Dienstprogramm den Benutzer zu dessen Eingabe auf. Wird ferner in der Befehlszeile das neue Kennwort nicht angegeben, fordert das Dienstprogramm den Benutzer auch zu dessen Eingabe auf.

Anmerkungen

  • Die Hilfe zur Syntax wird auch angezeigt, wenn der Benutzer gegen die Befehlssyntax verstößt.

  • Bei den Argumentqualifizierern /s, /d, /u, /n und /p wird die Groß-/Kleinschreibung nicht beachtet.

  • Alle Änderungen werden beim nächsten Start der geänderten BizTalk-Messagingdienste wirksam.

  • Bei der ersten Verwendung des Befehlszeilenprogramms oder nach dem Löschen der ursprünglichen Protokolldatei wird eine Protokolldatei erstellt. Nach Erstellung der Protokolldatei werden weitere Verwendungen des Befehlszeilenprogramms an die vorhandene Protokolldatei angefügt. Pfad und Name der Protokolldatei lauten \Programme\Microsoft BizTalk Server\BTS_SvcPW.log.


Verwalten von BizTalkServer-Gruppendatenbanken

BizTalk Server 2002 ~ Verwaltung

Verwalten von BizTalk Server-Gruppendatenbanken

Jede Servergruppe verwendet zwei Datenbanken, die Datenbank für gemeinsam genutzte Warteschlangen und die Überwachungsdatenbank. Die Datenbank für gemeinsam genutzte Warteschlangen enthält alle Dokumente und Austauschvorgänge, die zur Verarbeitung und Übertragung an Microsoft BizTalk Server 2002 versendet werden. Die Überwachungsdatenbank überwacht und speichert ein- und ausgehende Austauschvorgänge zu Zwecken der Überwachung, Schlichtung und Beilegung von Differenzen.

Um die logische Konfiguration von Servern und Gruppen zu vereinfachen, wenn sich die Datenbanken zweier oder mehrerer verschiedener Gruppen auf demselben Computer mit Microsoft SQL Server befinden, ist es wichtig, eindeutige Namen für die Datenbanken für gemeinsam genutzte Warteschlangen und die Überwachungsdatenbanken zu erstellen, die den einzelnen Servergruppen zugeordnet sind. Wenn Sie beispielsweise über zwei Servergruppen verfügen, eine mit dem Namen Gruppe1 und eine zweite mit dem Namen Gruppe2, und sich die Datenbanken auf demselben SQL-Server befinden, benennen Sie die Datenbanken der ersten Gruppe GemeinWart1 und Ueberwach1 und die Datenbanken der zweiten Gruppe GemeinWart2 und Ueberwach2.

Anmerkung

  • Die BizTalk-Messaging-Verwaltungsdatenbank ist eine von der Datenbank für gemeinsam genutzte Warteschlangen und der Überwachungsdatenbank getrennte Datenbank. Diese Datenbank wird verwendet, um Informationen zur Konfiguration mehrerer Gruppen und Server sowie zur Konfiguration der BizTalk-Messagingdienste zu speichern. Sie verarbeitet keine Dokument- und Austauschübertragungen und überwacht keine Dokument- und Austauschaktivitäten.

In diesem Abschnitt werden folgende Themen behandelt:

  • Datenbank für gemeinsam genutzte Warteschlangen

  • Überwachungsdatenbank


Datenbank für gemeinsam genutzte Warteschlangen

Alle Server in einer Servergruppe verwenden gemeinsam eine Datenbank für gemeinsam genutzte Warteschlangen. Alle Dokumente und Austauschvorgänge, die an die Server einer Gruppe versendet werden, werden in der Datenbank für gemeinsam genutzte Warteschlangen gespeichert, bis sie von BizTalk Server verarbeitet werden.

Die Datenbank für gemeinsam genutzte Warteschlangen wird in der BizTalk Server-Verwaltung grafisch als eine Reihe von Warteschlangen dargestellt, die Informationen zum Status eines Austauschvorgangs oder Dokuments in BizTalk Server bereitstellen. Austauschvorgänge und Dokumente befinden sich während der Verarbeitung durch BizTalk Server in einer der folgenden Warteschlangen:

  • Verarbeitungswarteschlange. Eine Liste von Austauschvorgängen und Dokumenten, die aktuell von BizTalk Server verarbeitet werden.

  • Geplant-Warteschlange. Eine Liste von Austauschvorgängen und Dokumenten, die von BizTalk Server verarbeitet wurden und auf die Übertragung entsprechend dem Dienstfenster warten. Weitere Informationen zum Dienstfenster finden Sie unter ServiceWindowInfo.

  • Wiederholungswarteschlange. Eine Liste von Austauschvorgängen und Dokumenten, die erneut gesendet werden, sowie Reliable Messaging-Nachrichten, die auf Empfangsbestätigungen warten.

  • Angehalten-Warteschlange. Eine Liste von Austauschvorgängen und Dokumenten, deren Verarbeitung aus einer Vielzahl von Gründen fehlgeschlagen ist, einschließlich Analyse-, Serialisierungs- oder Übertragungsfehler, oder für die keine gültige Kanalkonfiguration vorhanden ist.

Wenn BizTalk Server einen Austausch oder ein Dokument verarbeitet, wird die Verarbeitung beendet und ein Rollback der Datenbank für gemeinsam genutzte Warteschlangen durchgeführt. Dies erfolgt unter folgenden Voraussetzungen:

  • BizTalk Server kann nicht auf die Datenbank für gemeinsam genutzte Warteschlangen zugreifen. BizTalk Server wird z. B. von der Datenbank für gemeinsam genutzte Warteschlangen getrennt, weil der Server ausfällt, der als Host für die Datenbank für gemeinsam genutzte Warteschlangen fungiert.

  • Zu den möglichen SQL Server-Fehlern gehören Timeouts, abgebrochene Transaktionen und Deadlocks.

Für die Transaktion wird auch dann ein Rollback ausgeführt, wenn BizTalk Server die Verarbeitung nach der Übertragung des Austauschs oder des Dokuments beendet hat. Wenn die Datenbank für gemeinsam genutzte Warteschlangen wieder verfügbar ist, wird die Bezeichnung für alle mit "In Verarbeitung" gekennzeichneten Dokumente entfernt. Dies bedeutet, dass die Dokumente wieder verarbeitet und nicht in der Angehalten-Warteschlange abgelegt werden.

Wenn Sie Nachrichtenwarteschlangen für Transaktionen oder Reliable Messaging verwenden, wird genau eine einmalige Übermittlung von Austauschvorgängen oder Dokumenten garantiert. Wenn Sie nicht auf Transaktionen ausgelegte Übertragungen verwenden, sendet BizTalk Server 2002 dasselbe Dokument möglicherweise zweimal, sofern die in diesem Abschnitt beschriebenen Voraussetzungen erfüllt sind.

Anmerkung

  • Um Warteschlangen zu verwalten, die in der Datenbank für gemeinsam genutzte Warteschlangen gespeichert sind, müssen Benutzer Mitglieder der Gruppe BizTalk Server-Administratoren sein.

Verwandte Themen

Konfigurieren von Verbindungseigenschaften für eine Servergruppe

Gruppen und Server

Verwalten von Warteschlangen

Sicherheitsrichtlinien

Eigenschaft "ServiceWindowInfo"

Verwenden von Warteschlangen


Überwachungsdatenbank

Alle Server einer Servergruppe verwenden gemeinsam eine Überwachungsdatenbank, in der alle Informationen zur Austausch- und Dokumentaktivität in BizTalk Server gespeichert werden. Die Überwachungsdatenbank dient dem Überwachen des Status eines Austauschs oder Dokuments auf seinem Weg durch den Server. Wenn Sie beispielsweise überprüfen möchten, ob eine Bestellung an einen Handelspartner gesendet wurde, können Sie die Überwachungsdatenbank abfragen. Diese Datenbank kann außerdem verwendet werden, um zu überprüfen, ob Austauschvorgänge und Dokumente von BizTalk Server erfolgreich gesendet oder empfangen werden, oder um Informationen für Berichte bereitzustellen, wie z. B. Übertragungszeiten oder Empfangsbestätigungsantworten.

Definieren von Dokumentüberwachungs- und Protokollierungsparametern für die Überwachungsdatenbank

Sie können in der BizTalk Server-Verwaltung auswählen, ob Austauschvorgänge und Dokumente überwacht werden. Weitere Informationen zum Konfigurieren der Überwachungseinstellungen für eine Servergruppe finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe. Wenn Sie die Überwachung aktivieren, stehen die folgenden Optionen zur Verfügung:

  • Eingehenden Austausch protokollieren. Mit dieser Einstellung können Sie angeben, dass alle von BizTalk Server empfangenen Dokumente in der Überwachungsdatenbank gespeichert werden. Gespeicherte eingehende Dokumente stellen einen Aktivitätsdatensatz für die Beilegung von Differenzen bereit. Diese Option ist standardmäßig aktiviert.

  • Ausgehenden Austausch protokollieren. Mit dieser Einstellung können Sie angeben, dass alle von BizTalk Server gesendeten Dokumente in der Überwachungsdatenbank gespeichert werden. Diese Option ist standardmäßig aktiviert.

  • Ursprüngliche MIME-codierte Nachricht protokollieren. Mit dieser Einstellung können Sie angeben, dass MIME-codierte Dokumente in der Überwachungsdatenbank in ihrem ursprünglichen Nachrichtenformat gespeichert werden, bevor ihre Decodierung erfolgt. Diese Option ist standardmäßig nicht aktiviert.

Verwandte Themen

Konfigurieren von Verbindungseigenschaften für eine Servergruppe

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Sicherheitsrichtlinien

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe

Verwenden der BizTalk-Dokumentüberwachung


Behandeln von Serverfehlern

Sie können die Fehlerbehandlung in Microsoft BizTalk Server 2002 auf Serverebene mithilfe der Windows 2000-Ereignisanzeige konfigurieren, die in der BizTalk Server-Verwaltung enthalten ist. Die Windows 2000-Ereignisanzeige wird in der Konsolenstruktur der Verwaltungskonsole angezeigt.

Protokollieren von Ereignissen

Die Windows 2000-Ereignisanzeige zeigt ein Protokoll an, das Informationen zu Hardware-, Software- und Systemproblemen enthält. In der Verwaltungskonsole kann die Ereignisanzeige so angepasst werden, dass Anwendungsfehler angezeigt werden, die für die BizTalk-Messagingdienste und XLANG-Ablaufplanung (XLANG Scheduler) spezifisch sind, wodurch die Behandlung von BizTalk Server-Problemen effizienter wird. Weitere Informationen zum Anpassen der Ereignisanzeige für Fehler von BizTalk Server und der XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Verwalten der Ereignisanzeige.

Weitere Informationen zur Ereignisanzeige finden Sie in der Windows 2000 Server-Hilfe im Kapitel "Ereignisanzeige" unter "Verwenden der Ereignisanzeige".

Anmerkung

  • Alle mit BizTalk Server 2002 zusammenhängenden Anwendungsfehler sind als BizTalk Server-Fehler oder Fehler der XLANG-Ablaufplanung (XLANG Scheduler) definiert.

Verwandtes Thema

Verwalten der Ereignisanzeige


Empfangsfunktionen

Wenn Sie Dokumente von einem Empfangsspeicherort empfangen und an Microsoft BizTalk Server 2002 versenden müssen, können Sie zur Verarbeitung der Daten Empfangsfunktionen konfigurieren. Wenn Sie beispielsweise Dokumente von einer Unternehmensorganisation oder -anwendung empfangen müssen, die nicht direkt über eine COM-Schnittstelle mit BizTalk Server kommunizieren kann, können Sie eine Empfangsfunktion verwenden, um die Dokumente an BizTalk Server zu versenden. Auch wenn Sie ein Dokument aus einer Nachrichtenwarteschlange empfangen müssen, können Sie eine Empfangsfunktion verwenden, um das Dokument an BizTalk Server zu senden. BizTalk Server 2002 unterstützt drei Typen von Empfangsfunktionen:

  • Datei

  • Message Queuing

  • HTTP

Sie können eine allgemeine Empfangsfunktion für BizTalk Server 2002 in der Verwaltungskonsole erstellen, in der Sie den Namen der Empfangsfunktion, die Dokumentdefinition usw. definieren. Weitere Informationen zum Konfigurieren von Empfangsfunktionen finden Sie unter Verwalten von Empfangsfunktionen für eine Servergruppe. Weitere Informationen zu erweiterten Eigenschaften für Empfangsfunktionen finden Sie unter Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen.

Die folgende Abbildung zeigt die Beziehung zwischen der sendenden Unternehmensanwendung, dem Dateisystem und einer allgemeinen BizTalk Server-Empfangsfunktion.

Beziehung zwischen der sendenden Geschäftsanwendung, dem Dateisystem und einer generischen Empfangsfunktion von BizTalkServer

Anmerkung

  • Sie können Submit-Aufrufe auch programmgesteuert konfigurieren, um Dokumente zu empfangen und an BizTalk Server zu senden. Weitere Informationen zu Submit-Aufrufen finden Sie unter Submitting oder unter BizTalk-Dokumente.

In diesem Abschnitt werden folgende Themen behandelt:

  • Verfügbare Empfangsfunktionen

  • Korrelationstoken

  • Benutzerdefinierte Präprozessoren

  • Mehrere Instanzen von Empfangsfunktionstypen

  • Grundlegendes zu Empfangsfunktionen und Dokumentrouting

  • Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen


Verfügbare Empfangsfunktionen

Drei Typen von Empfangsfunktionen sind in BizTalk Server verfügbar: Datei, Message Queuing und HTTP. Welche Art von Empfangsfunktion Sie in welcher Situation verwenden, hängt von Ihren Geschäftsabläufen ab.

Dateiempfangsfunktion

Eine Dateiempfangsfunktion wird aktiviert, wenn in dem Verzeichnis, das die Empfangsfunktion überwacht, Aktivität auftritt. Um eine Dateiempfangsfunktion zu verwenden, müssen Sie in der Lage sein, das Verzeichnis zu ändern. Die Dateiempfangsfunktion entfernt die Dateien aus dem Verzeichnis und versendet sie an BizTalk Server 2002.

Message Queuing-Empfangsfunktion

Eine Message Queuing-Empfangsfunktion wird auf der Basis der Aktivität in einer Nachrichtenwarteschlange aktiviert. Diese Empfangsfunktion extrahiert den Austausch oder das Dokument aus der Warteschlange und versendet ihn/es an BizTalk Server 2002.

Wenn Sie den Abrufspeicherort für die Nachrichtenwarteschlange angeben, wählen Sie anstelle eines Pfades einen Formatnamen. BizTalk Server kann mit nicht bearbeiteten Message Queuing-APIs (Application Programming Interfaces, Anwendungsprogrammier-Schnittstellen) zusammenarbeiten. Die API-Aufrufe funktionieren nur mit der Formatnameneigenschaft. Verwenden Sie bei der Konfiguration einer Message Queuing-Empfangsfunktion den folgenden Formatnamen:

Direct=OS:<Servername>\<Warteschlangenname>

Anmerkung

  • Weitere Informationen zu Message Queuing und Formatnamen finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie nach dem Stichwort "Message Queuing Services".

HTTP-Empfangsfunktion

Eine HTTP-Empfangsfunktion ist eine ISAPI-Erweiterung (Internet Server Application Programming Interface), die ein sofort einsetzbares Dienstprogramm für den unmittelbaren Empfang von Dokumenten über HTTP (Hypertext Transfer Protocol) bei minimaler Konfiguration bereitstellt, ohne dass Webseiten oder zusätzliche DLLs (Dynamic-Link Libraries) entwickelt werden müssen.

Die HTTP-Empfangsfunktion sendet Dokumente entweder an das Dateisystem oder über einen COM-Aufruf an die Submit-Methode oder die SubmitSync-Methode direkt an BizTalk Server.

Verwandte Themen

Hinzufügen einer Dateiempfangsfunktion

Hinzufügen einer HTTP-Empfangsfunktion

Hinzufügen einer Message Queuing-Empfangsfunktion

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"

Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Dienste"


Korrelationstoken

Die HTTP-Empfangsfunktion verwendet ein Korrelationstoken, um das synchrone Verhalten bei einer asynchronen BizTalk Server-Versendung zu emulieren. Dies geschieht beispielsweise, indem ein Dokument an eine ASP-Seite in einem Peripherienetzwerk (auch als entmilitarisierte Zone oder überwachtes Teilnetz bekannt) versendet wird. Wenn die ASP-Seite eine HTTP-Empfangsfunktion zum Übergeben des Dokuments an die andere Seite des Firewalls verwendet, wird ein Korrelationstoken verwendet, um den Status der Dokumentverarbeitung zu überwachen und zu ermitteln, wann das Dokument an den Client zurückgegeben wird, der es ursprünglich gesendet hat. Mithilfe des Korrelationstokens wirkt der asynchrone Prozess für den Client synchron.

Anmerkung

  • Das von einer HTTP-Empfangsfunktion verwendete Korrelationstoken steht in keiner Beziehung zum Orchestrierungskorrelationsprozess.


Benutzerdefinierte Präprozessoren

Wenn Sie über Dokumente verfügen, die vor dem Versenden an BizTalk Server verarbeitet werden müssen, können Sie einen benutzerdefinierten Präprozessor erstellen und die Empfangsfunktion für das Aufrufen des Präprozessors konfigurieren. Wenn Sie beispielsweise komprimierte Daten senden und diese dekomprimieren müssen, bevor Sie sie für die Verarbeitung an BizTalk Server versenden, konfigurieren Sie die Empfangsfunktion so, dass sie den benutzerdefinierten Präprozessor aufruft, um die Daten zu dekomprimieren.

Verwandte Themen

Klassenbezeichner wird in der Präprozessorliste angezeigt

IBTSCustomProcess

Preprocessing Documents in a Receive Function


Mehrere Instanzen von Empfangsfunktionstypen

Es können mehrere Instanzen einer Empfangsfunktion vorhanden sein. Wenn beispielsweise mehrere Unternehmensanwendungen eine Dateiempfangsfunktion verwenden, um Dokumente und Austauschvorgänge an BizTalk Server 2002 zu versenden, können Sie entweder eine einzelne oder mehrere Instanzen der Dateiempfangsfunktion konfigurieren.

Anmerkungen

  • Stellen Sie sicher, dass jede der erstellten Empfangsfunktionen über einen eindeutigen Namen verfügt. Empfangsfunktionen dürfen keine identischen Namen zugewiesen werden.

  • Für alle HTTP-Empfangsfunktionen, die auf demselben Server ausgeführt werden, wird empfohlen, nur eine DLL (Dynamic-Link Library) oder nur ein virtuelles Verzeichnis zu verwenden. Bei Verwenden mehrerer DLLs oder virtueller Verzeichnisse kann es zu unerwarteten Ergebnissen kommen. Weitere Informationen zum Hinzufügen von HTTP-Empfangsfunktionen finden Sie unter Hinzufügen einer HTTP-Empfangsfunktion.

Verwandtes Thema

Verwalten von Empfangsfunktionen für eine Servergruppe


Grundlegendes zu Empfangsfunktionen und Dokumentrouting

Ermitteln Sie beim Konfigurieren einer Empfangsfunktion, ob die von der Empfangsfunktion empfangenen Dokumente automatisch oder nicht automatisch geroutet werden. Automatisch geroutete Dokumente enthalten alle erforderlichen Routinginformationen. Nicht automatisch gerouteten Dokumenten fehlen einige oder alle Routinginformationen.

Automatisch geroutete Dokumente

Automatisch geroutete Dokumente enthalten sämtliche Routinginformationen (Quellorganisationskennzeichen, Zielorganisationskennzeichen und Dokumentdefinition) in den Routingkennzeichen, die in der Dokumentspezifikation definiert oder hartcodiert im Dokument angegeben sind, wie im Fall von X12 und EDIFACT. Alle Dokumente, für die Sie im BizTalk-Editor eine Spezifikation erstellen können, können als automatisch geroutetes Dokument konfiguriert werden. Verbreitete Typen automatisch gerouteter Dokumente sind XML, X12 und EDIFACT. Sie müssen keine erweiterten Eigenschaften in der Empfangsfunktion konfigurieren, wenn ein Dokument automatisch geroutet wird, es sei denn, Sie möchten die im Dokument bereitgestellten Daten außer Kraft setzen.

Wenn dem Dokument das Quell- oder Zielorganisationskennzeichen oder die Dokumentdefinition fehlen, wird es in der Angehalten-Warteschlange abgelegt. Darüber hinaus verwendet BizTalk Server beim Fehlen des Quell- oder Zielorganisationskennzeichens den Standardwert von Organisationsname als Organisationskennzeichen und verweist auf den Namen, der in der BizTalk-Messaging-Verwaltungsdatenbank gespeichert ist.

Nicht automatisch geroutete Dokumente

Nicht automatisch gerouteten Dokumenten fehlen einige oder alle der erforderlichen Routinginformationen. Beim Konfigurieren der Empfangsfunktion müssen die folgenden Informationen im Dialogfeld Eigenschaften auf der Registerkarte Erweitert der Empfangsfunktion oder in dem der Empfangsfunktion zu übergebenden Dokument definiert werden:

  • Quellorganisationskennzeichen, Zielorganisationskennzeichen und Dokumentdefinition

    Oder

  • Kanal

Wenn Sie ein Dokument versenden, sucht BizTalk Server einen Kanal, um das Dokument zu verarbeiten. Dies kann auf zweierlei Weise geschehen: entweder durch Angabe eines Kanalnamens in der Empfangsfunktion oder durch Angabe von Quell- und Zielorganisationskennzeichen und Dokumentdefinition. Diese drei Eigenschaften unterstützen BizTalk Server beim Suchen des korrekten Kanals. Aus diesem Grund stehen beim Auswählen eines Kanals die Optionen für die Dokumentdefinition und die Informationen zu Quelle und Ziel nicht zur Verfügung, weil der Kanal alle erforderlichen Informationen bereitstellt, um das Dokument zu routen.

Verbreitete Typen nicht automatisch gerouteter Dokumente sind Dokumente, die aus mehreren Quellen stammen (offene Quelle) oder an mehrere Ziele gesendet werden (offenes Ziel).

Konfigurieren einer Empfangsfunktion für das Verwalten von Dokumenten aus mehreren Quellen

Sie können eine einzelne Empfangsfunktion, die nicht automatisch geroutete Dokumente verarbeitet, so konfigurieren, dass sie einen bestimmten Dokumenttyp von verschiedenen Quellen empfängt. Dies ist ein Szenario mit offener Quelle. Der Speicherort der Quellorganisation, die Zielorganisation und die Informationen der Dokumentdefinition müssen sich im Dokument oder in Parametern befinden, die zusammen mit dem Dokument versendet werden.

Wenn Sie beispielsweise beabsichtigen, Aufträge mehrerer Kunden zu empfangen, diese aber alle an die gleiche Zielanwendung gesendet werden sollen, legen Sie die Eigenschaften für Dokumentdefinition und Zielorganisationskennzeichen in der Empfangsfunktion fest. Wenn BizTalk Server das Dokument analysiert, sucht das Programm das Kennzeichen der bereitstellenden Organisation, kombiniert diese mit den Parametern in der Empfangsfunktion, sucht den richtigen Kanal und verarbeitet anschließend das Dokument.

Verwandte Themen

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

Verwalten von Empfangsfunktionen für eine Servergruppe

Festlegen von Eigenschaften für die Quellorganisation


Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen

Sie können erweiterte Eigenschaften verwenden, um besondere Typen von Empfangsfunktionen auf der Basis Ihrer Geschäftspraktiken zu konfigurieren.

Beispielsweise können Sie Empfangsfunktionen definieren, um Folgendes zu versenden:

  • Dokumente, bei denen die Eigenschaft Offene Quelle oder Offenes Ziel festgelegt ist.

  • Dokumente, bei denen die Eigenschaft Pass-Through festgelegt ist.

  • Dokumente, die einen Kanalnamen angeben.

  • Andere Typen nicht automatisch gerouteter Dokumente.

Definieren der Eigenschaft "Offenheitsgrad" in einem Dokument

Die folgenden Optionen definieren den Offenheitsgrad eines Dokuments:

  • Nicht geöffnet. Gibt an, dass Quelle und Ziel explizit in der Empfangsfunktion oder Dokumentinstanz deklariert sind.

  • Offenes Ziel. Gibt an, dass die Zielinformationen nicht explizit im Messagingport deklariert sind. Das Ziel wird dynamisch in der Dokumentinstanz oder in einem Versendeparameter angegeben. Sie müssen die Eigenschaften für Dokumentdefinition und Quellorganisationskennzeichen in der Empfangsfunktion oder Dokumentinstanz konfigurieren, damit BizTalk Server den korrekten Kanal findet.

  • Offene Quelle. Gibt an, dass die Quellinformationen nicht explizit im Kanal deklariert sind. Stattdessen wird die Quelle dynamisch in der Dokumentinstanz angegeben. Sie müssen die Eigenschaften für Dokumentdefinition und Zielorganisationskennzeichen in der Empfangsfunktion oder Dokumentinstanz konfigurieren, damit BizTalk Server den korrekten Kanal findet.

Konfigurieren von Empfangsfunktionen mit Pass-Through

Eine mit Pass-Through konfigurierte Empfangsfunktion umgeht die Analyse-, Entschlüsselungs-, Signaturüberprüfungs-, Transformations- und Decodierfunktionen von BizTalk Server. Wählen Sie diese Option, wenn Sie Binärdaten großer Objekte oder andere Austauschvorgänge senden, für die Analyse, Entschlüsselung und Decodierung nicht erforderlich sind. Wenn Sie eine Empfangsfunktion mit der Option Mit Pass-Through-Kennzeichen senden konfigurieren, müssen Sie einen Kanal angeben. Andernfalls kann BizTalk Server das Dokument nicht verarbeiten.

Umschlagsname

Wenn Sie den Empfang eines eingehenden Austauschs in einem Flatfileformat erwarten, geben Sie das Umschlagsformat in der Empfangsfunktion an. Der Umschlag verweist auf eine Spezifikation, die BizTalk Server anweist, wie der Austausch geöffnet und interpretiert werden soll. Wenn Sie mehrere Flatfiledateien in einem einzelnen Austausch erwarten, müssen die einzelnen Flatfiledateien durch ein Trennzeichen getrennt sein, das als Präfix oder Postfix dient. Infix wird nicht unterstützt. Das Trennzeichen muss im Stammknoten der Umschlagspezifikation und Dokumentspezifikation festgelegt werden, wenn die Analyseeigenschaften konfiguriert werden. Weitere Informationen zum Festlegen der Analyseeigenschaften für eine Flatfiledatei finden Sie unter Festlegen von Analyseeigenschaften. Suchen Sie nach der Tabelle Standard: CUSTOM, Struktur-Eigenschaft: Getrennt.

Kanalname

Alle Austauschvorgänge oder Dokumente, die an BizTalk Server versendet werden, erfordern verschiedene Regeln, die festlegen, wie diese verarbeitet werden sollen. Der Kanal enthält alle Informationen, die der Server benötigt, um den Austausch oder das Dokument zu verarbeiten. Alle Austauschvorgänge und Dokumente, die von BizTalk Server verarbeitet werden, müssen einen Kanal passieren. Es gibt zwei Möglichkeiten, einen Kanal zu bestimmen.

Kanäle können zum einen beim Versenden eines Austauschs oder Dokuments bestimmt werden. BizTalk Server analysiert zunächst das Dokument auf das Quell- und Zielkennzeichen und die Dokumentdefinition. Wenn sich diese Informationen nicht in der Dokumentinstanz befinden, untersucht BizTalk Server anschließend die Empfangsfunktion. Sobald Quell- und Zielbezeichner sowie Dokumentdefinition erkannt wurden, ermittelt BizTalk Server, welche Kanäle über die gleiche Kombination aus Dokumentdefinition, Quell- und Zielbezeichner verfügen wie das empfangene Dokument. Wenn BizTalk Server einen passenden Kanal findet, wird die Dokumentinstanz verarbeitet.

Kanäle können außerdem bestimmt werden, wenn sie in der Empfangsfunktion angegeben sind. In diesem Fall wird die Kanalsuche umgangen, und das empfangene Dokument wird schneller verarbeitet.

Dokumentdefinition, Quellorganisations- und Zielorganisationskennzeichen

Beim Empfang nicht automatisch gerouteter Dokumente können Sie die Dokumentdefinition, das Quellorganisationskennzeichen und/oder das Zielorganisationskennzeichen konfigurieren. Die im empfangenen Dokument enthaltenen Routinginformationen bestimmen, welche dieser Eigenschaften Sie in der Empfangsfunktion definieren.

Wenn Sie beispielsweise mehrere Dokumenttypen von der gleichen Quellorganisation empfangen und diese Dokumente immer an das gleiche Ziel senden, können Sie die Quell- und Zielorganisationskennzeichen in der Empfangsfunktion konfigurieren und die Dokumentdefinition dynamisch in der Dokumentinstanz definieren.

Verwandte Themen

Erstellen von Umschlägen

Festlegen von Eigenschaften für die Umschlagsinformationen

Festlegen von Analyseeigenschaften

Grundlegendes zu Kanälen

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Umschlägen

Grundlegendes zu Organisationen

Grundlegendes zu Empfangsfunktionen und Dokumentrouting

Verwenden von Umschlägen für die eingehende Verarbeitung


Verwenden von Warteschlangen

Microsoft BizTalk Server 2002 stellt in der BizTalk Server-Verwaltung Funktionalität für die Verwaltung gemeinsam genutzter Warteschlangen bereit. BizTalk Server-Administratoren können Dokumente aus allen anderen Warteschlangen in die Angehalten-Warteschlange verschieben. Aus der Angehalten-Warteschlange können Dokumente je nach Verarbeitungsstatus gelöscht, erneut gesendet oder angezeigt werden. BizTalk Server-Administratoren können Fehlermeldungen für Dokumente in der Angehalten-Warteschlange sortieren und anzeigen.

Die folgenden Warteschlangen werden für die Aufnahme eingehender und ausgehender Dokumente verwendet, die verschiedene Phasen des Routings und der Verarbeitung in BizTalk Server durchlaufen:

  • Verarbeitungswarteschlange

  • Geplant-Warteschlange

  • Wiederholungswarteschlange

  • Angehalten-Warteschlange

Anmerkung

  • Austauschvorgänge und Dokumente werden in der BizTalk Server-Verwaltung in der Reihenfolge "First in, First out" angezeigt. Das bedeutet, die ältesten Elemente in einer Warteschlange werden zuerst und die neuesten Elemente zuletzt angezeigt. Darüber hinaus werden bis zu 15.000 Austauschvorgänge und/oder Dokumente zugleich in einer Warteschlange angezeigt. Wenn sich mehr als 15.000 tatsächliche Elemente in einer Warteschlange befinden, müssen Sie aktuelle Elemente in der Warteschlange entfernen oder erneut senden, so dass neuere Elemente angezeigt werden können. Der Warteschlangenzähler in der Konsolenstruktur (die Zahl in Klammern neben dem Warteschlangennamen) zeigt an, wie viele tatsächliche Elemente sich in der Warteschlange befinden. Dokumente können gelöscht oder erneut gesendet werden, um sie aus einer Warteschlange zu entfernen.

Verwandtes Thema

Verwalten von Warteschlangen


Verarbeitungswarteschlange

Die Verarbeitungswarteschlange enthält Dokumente, die aktuell von BizTalk Server verarbeitet werden. Transaktionen in der Verarbeitungswarteschlange verbleiben nicht sehr lange in der Warteschlange, weil sie bei Ankunft verarbeitet werden. BizTalk Server-Administratoren können jedes beliebige Dokument in dieser Warteschlange auswählen und in die Angehalten-Warteschlange verschieben.

Verwandte Themen

Verschieben von Dokumenten in die Angehalten-Warteschlange

Verwenden von Warteschlangen


Geplant-Warteschlange

Die Geplant-Warteschlange enthält Arbeitsobjekte, die von BizTalk Server verarbeitet wurden und auf der Basis des Dienstfensters auf die Übertragung warten. BizTalk Server-Administratoren können jedes beliebige Dokument in dieser Warteschlange auswählen und in die Angehalten-Warteschlange verschieben. Weitere Informationen zum Dienstfenster finden Sie unter dem Benutzeroberflächenobjekt IBizTalkServiceWindowInfo.

Verwandte Themen

IBizTalkServiceWindowInfo

Verschieben von Dokumenten in die Angehalten-Warteschlange

Verwenden von Warteschlangen


Wiederholungswarteschlange

Die Wiederholungswarteschlange enthält Dokumente, die zur Übermittlung erneut gesendet werden, und Dokumente, die auf Reliable Messaging-Empfangsbestätigungen warten. Der Unterschied zwischen den beiden Übermittlungsarten ist nicht sichtbar. Standardmäßig werden fehlgeschlagene Übertragungen alle fünf Minuten bis zum Erreichen der maximalen Anzahl von drei Versuchen wiederholt, bevor sie in die Angehalten-Warteschlange verschoben werden. Diese Anzahl kann mithilfe des BizTalk-Messaging-Managers oder programmgesteuert geändert werden. Weitere Informationen zum Ändern der Anzahl der Wiederholungsversuche finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften oder den Eigenschaften RetryCount und RetryInterval.

BizTalk Server-Administratoren können jedes beliebige Dokument in dieser Warteschlange auswählen und in die Angehalten-Warteschlange verschieben.

Verwandte Themen

Verschieben von Dokumenten in die Angehalten-Warteschlange

RetryCount Property

RetryInterval Property

Festlegen erweiterter Konfigurationseigenschaften

Verwenden von Warteschlangen


Angehalten-Warteschlange

Die Angehalten-Warteschlange enthält Arbeitsobjekte, die aus einer Vielzahl von Gründen nicht verarbeitet werden konnten, z. B. aufgrund von Analyse-, Serialisierungs- und Übertragungsfehlern oder einer fehlenden Kanalkonfiguration. BizTalk Server-Administratoren können mit der rechten Maustaste auf jedes beliebige Dokument in dieser Warteschlange klicken, um eine der folgenden Optionen zu wählen:

  • Fehlerbeschreibung anzeigen. Ermöglicht BizTalk Server-Administratoren, Fehlerbeschreibungen anzuzeigen, die einen Hinweis darauf geben, warum das Dokument an die Angehalten-Warteschlange gesendet wurde.

  • Austausch anzeigen. Ermöglicht BizTalk Server-Administratoren, den Inhalt eines Austauschs anzuzeigen, dessen Verarbeitung aus einem von vielen möglichen Gründen fehlgeschlagen ist, z. B. aufgrund von Analyse- und Übertragungsfehlern. Austausch anzeigen steht für die folgenden Statuswerte zur Verfügung:
    • Initiale

    • Benutzerdefinierte Komponente

    • Analysiert

    • Codierung

    • Signiert

    • Verschlüsselt

    • Überträgt
  • Dokument anzeigen. Ermöglicht BizTalk Server-Administratoren, den Inhalt eines Dokuments anzuzeigen, dessen Verarbeitung aus einem von vielen möglichen Gründen fehlgeschlagen ist, z. B. aufgrund von Serialisierungsfehlern oder weil kein Kanal gefunden werden konnte. Dokument anzeigen steht für die folgenden Statuswerte zur Verfügung:
    • Dokumentüberprüfung

    • Kanalauswahl

    • Feldüberwachung

    • Zuordnung

    • Korreliert

    • Serialisiert
  • Löschen. Ermöglicht BizTalk Server-Administratoren das vollständige Entfernen eines Eintrags aus der Angehalten-Warteschlange. Diese Aktion kann nicht rückgängig gemacht werden. Wenn ein Dokument aus der Angehalten-Warteschlange gelöscht wurde, kann es nicht mehr abgerufen werden.

  • Erneut senden. Ermöglicht BizTalk Server-Administratoren das erneute Senden von Austauschvorgängen und Dokumenten zur Verarbeitung durch BizTalk Server.

Statuswerte der Angehalten-Warteschlange

Austauschvorgänge und Dokumente werden aus einer Vielzahl von Gründen in der Angehalten-Warteschlange abgelegt. Die folgende Tabelle erläutert die Statuswerte der Angehalten-Warteschlange, die ihnen zugeordneten Fehlermeldungen und die Aktionen, mit denen Sie reagieren können.

Statuswert der Angehalten-Warteschlange | Fehlermeldung | Fehlerbeschreibung und mögliche Aktion
Kanalauswahl oder Überträgt | Unerwarteter Fehler | Ein unerwarteter interner Serverfehler ist aufgetreten. Senden Sie das Dokument erneut.
Kanalauswahl oder Überträgt | Unbekannt | Der Austauschvorgang oder das Dokument als "In Verarbeitung" durch einen inaktiven Server markiert. Beim Neustart dieses Servers wurde das Element automatisch in die Angehalten-Warteschlange verschoben. Auf dem ursprünglichen Server ist möglicherweise ein Fehler aufgetreten. Wenden Sie sich an den Systemadministrator, um weitere Informationen zu erhalten. Wenn das Problem behoben ist, versenden Sie das Dokument oder den Austausch erneut.
Kanalauswahl oder Überträgt | Nicht genügend Arbeitsspeicher | Der Computer mit BizTalk Server verfügt nicht mehr über genügend Arbeitsspeicher. Starten Sie den Server neu, und senden Sie alle Austauschvorgänge und Dokumente in der Angehalten-Warteschlange erneut.
Analysiert | Analysefehler | BizTalk Server konnte die Daten nicht analysieren. Zeigen Sie den Inhalt des Austauschs an, um zu ermitteln, warum BizTalk Server diesen nicht analysieren konnte. Senden Sie den Austausch mithilfe von IInterchange oder einer Empfangsfunktion erneut. Weitere Informationen finden Sie unter Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt oder Analysefehler.
Analysiert | Fehlende Daten | Die aus den eingehenden Daten extrahierten Informationen enthielten nicht genügend Informationen, um einen Kanal zu finden. Zeigen Sie den Austausch an, und finden Sie heraus, welche Daten fehlen. Senden Sie den Austausch mithilfe von IInterchange oder einer Empfangsfunktion erneut. Weitere Informationen finden Sie unter Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt oder Analysefehler.
Analysiert | "expiresAt" abgelaufen | Der BizTalk Framework-Zeitstempel "expiresAt" ist abgelaufen. Dieses Dokument ist nicht mehr gültig. Weitere Informationen finden Sie unter Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt.
Kanalauswahl | Kein Kanal gefunden | BizTalk Server konnte keinen Kanal finden, der diesem Dokument entsprach. Erstellen Sie einen Kanal für das Dokument, oder korrigieren Sie das Dokument, und senden Sie es dann erneut.
Kanalauswahl | Kanal entfernt | Der diesem Dokument zugeordnete Kanal wurde gelöscht, nachdem das Dokument die Verarbeitungswarteschlange erreicht hatte. Konfigurieren Sie den Kanal erneut, oder konfigurieren Sie das Dokument für einen anderen Kanal, und senden Sie das Dokument dann erneut. Oder Versenden Sie das Dokument nicht, und löschen Sie es aus der Angehalten-Warteschlange.
Feldüberwachung oder Initiale | Kanal fehlt | Der durch die Empfangsfunktion oder den Submit-Aufruf angegebene Kanal konnte nicht gefunden werden. Konfigurieren Sie einen Kanal, oder konfigurieren Sie das Dokument neu, und senden Sie es dann erneut.
Kanalauswahl | Ungültiger Kanal | Der durch den Submit-Aufruf angegebene Kanal war ein offener Kanal. Offene Kanäle sind für Pass-Through-Submit-Aufrufe ungültig. Ändern Sie den Kanal, und senden Sie das Dokument erneut.
Zuordnung | Zuordnungsfehler | Die Zuordnung, auf die der Kanal verweist, ist falsch formatiert. Löschen Sie das Dokument aus der Angehalten-Warteschlange, korrigieren Sie die Zuordnung, und versenden Sie das Dokument als neues Dokument.
Serialisiert | Serialisierungsfehler | BizTalk Server konnte das Dokument nicht in das systemeigene Format konvertieren. Senden Sie das Dokument erneut.
Codierung | Codierungsfehler | BizTalk Server konnte diesen Austausch nicht codieren. Senden Sie den Austausch erneut.
Signiert | Signierfehler | BizTalk Server konnte diesen Austausch nicht signieren. Möglicherweise ist das Zertifikat abgelaufen. Weitere Informationen finden Sie im MMC-Snap-In (Microsoft Management Console) Zertifikate. Weitere Informationen zum Anzeigen des Snap-Ins Zertifikate finden Sie in der Windows 2000-Hilfe im Kapitel "Verwalten von Zertifikaten" unter "Hinzufügen des Snap-Ins Zertifikate zur MMC-Konsole".
Verschlüsselt | Verschlüsselungsfehler | BizTalk Server konnte diesen Austausch nicht verschlüsseln. Möglicherweise ist das Zertifikat abgelaufen. Weitere Informationen finden Sie im MMC-Snap-In (Microsoft Management Console) Zertifikate. Weitere Informationen zum Anzeigen des Snap-Ins Zertifikate finden Sie in der Windows 2000-Hilfe im Kapitel "Verwalten von Zertifikaten" unter "Hinzufügen des Snap-Ins Zertifikate zur MMC-Konsole".
Überträgt | Übertragungsfehler | BizTalk Server konnte den Austausch nicht übertragen. Überprüfen Sie die Transportadresse im Kanal. Korrigieren Sie das Problem, und senden Sie den Austausch erneut.
Überträgt | Timeoutfehler | BizTalk Server konnte die Verarbeitung dieses Austauschs vor dem Timeout nicht abschließen. Möglicherweise dauerte die Übertragung zu lange. Überprüfen Sie, ob dieser Austausch gesendet wurde oder ob Sie einen unzuverlässigen Transport verwenden, bevor Sie den Austausch erneut senden.
Überträgt | Benutzer verschoben | Ein BizTalk Server-Administrator hat dieses Dokument in die Angehalten-Warteschlange verschoben. Senden Sie den Austausch erneut.
Überträgt | Zeitstempel abgelaufen | Der BizTalk Framework-Zeitstempel "receiptRequiredBy" ist abgelaufen. Dieses Dokument ist nicht mehr gültig.
Dokumentüberprüfung | Ungültiges Dokument | Die Überprüfung des Dokuments anhand seiner Spezifikation ist fehlgeschlagen. Weitere Informationen finden Sie in der Fehlerbeschreibung im Ereignisprotokoll. Korrigieren Sie das Schema, und senden Sie das Dokument erneut.
Feldüberwachung | Feldüberwachungsfehler | BizTalk Server konnte die angeforderten Felder innerhalb des Dokuments nicht überwachen. Zeigen Sie das Dokument an, um zu überprüfen, ob die zu überwachenden Felder vorhanden sind, oder ändern Sie die Kanalkonfiguration für die Feldüberwachung. Senden Sie das Dokument anschließend erneut.
Benutzerdefinierte Komponente | Fehler bei einer benutzerdefinierten Komponente | Fehler bei einer benutzerdefinierten Komponente. Führen Sie eine Problembehandlung bei der benutzerdefinierten Komponente oder dem benutzerdefinierten Präprozessor durch, und senden Sie den Austausch erneut.
Korreliert | Korrelationsfehler | Fehler beim Korrelieren dieser Empfangsbestätigung.

Anmerkungen

  • Über das Überprüfen der Fehlermeldungen in der Angehalten-Warteschlange hinaus können Sie auch das Ereignisprotokoll überprüfen, um weitere Informationen zu erhalten. Weitere Informationen zum Ereignisprotokoll finden Sie unter Verwalten der Ereignisanzeige.

  • Nicht alle Dokumente in der Angehalten-Warteschlange können erneut versendet werden. In einigen Situationen müssen Sie das Dokument löschen und es erneut aus der ursprünglichen Anwendung oder Organisation heraus versenden.

Verwandte Themen

Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Verwalten der Ereignisanzeige

Verwalten von Warteschlangen

Analysefehler

Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen

Grundlegendes zu Empfangsfunktionen und Dokumentrouting

Verwenden von Warteschlangen


Administratorrechte

Um die BizTalk Server-Verwaltung anzuzeigen, müssen Sie Mitglied der Gruppe BizTalk Server-Administratoren sein. Wenn Sie nicht als BizTalk Server-Administrator angemeldet sind, können Sie keine Elemente im Ordner Microsoft BizTalk Server 2002 anzeigen. Wenn Sie Mitglied der Gruppe BizTalk Server-Administratoren, nicht jedoch Mitglied der Microsoft Windows 2000-Gruppe Administratoren sind, können Sie nur die folgenden Aufgaben ausführen:

  • Hinzufügen und Entfernen von Servergruppen

  • Anzeigen und Ändern von Gruppeneigenschaften

  • Verwalten aller Warteschlangen und ihrer Einträge

  • Hinzufügen und Entfernen von Empfangsfunktionen

  • Anzeigen und Ändern von Empfangsfunktionseigenschaften

Darüber hinaus müssen Sie zum Verwalten einer Servergruppe, die drei Server enthält, z. B. Server_1, Server_2 und Server_3, über Windows 2000-Administratorrechte auf allen drei Servern verfügen. Wenn die Windows 2000-Administratorrechte auf Server_1 geändert wurden und Sie nicht mehr über Administratorrechte verfügen, gibt die Verwaltungskonsole eine Liste aller drei der Gruppe angehörenden Server zurück und listet den Status der einzelnen Server auf. Der Status von Server_1 wird als "Zugriff verweigert" zurückgegeben.

Wenn Sie sowohl Mitglied der Gruppe BizTalk Server-Administratoren als auch der Windows 2000-Gruppe Administratoren sind, können Sie die folgenden zusätzlichen Aufgaben ausführen:

  • Hinzufügen von Servern zu und Entfernen von Servern aus einer Servergruppe

  • Anzeigen und Ändern von Servereigenschaften

  • Anzeigen des Serverstatus

  • Freigeben von Austauschvorgängen auf einem Server

Darüber hinaus müssen Sie für den Zugriff auf die Datenbanken Mitglied der SQL Server-Gruppe Administratoren sein.

Während der Installation wird der Benutzer, der die BizTalk Server-Installation ausführt, der Gruppe BizTalk Server-Administratoren hinzugefügt. Sie können der Gruppe BizTalk Server-Administratoren weitere Benutzer hinzufügen. Weitere Informationen finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".


Gründe für das Durchführen von BizTalkServer-Verwaltungsaufgaben

BizTalk Server 2002 ~ Verwaltung

Gründe für das Durchführen von BizTalk Server-Verwaltungsaufgaben

Dieser Abschnitt enthält eine Kurzübersicht über die Durchführung von BizTalk Server-Verwaltungsaufgaben. Die folgende Tabelle enthält Beschreibungen der Hauptaufgaben sowie der jeweiligen Unteraufgaben, Erläuterungen zum Zweck jeder Aufgabe und Links zu den entsprechenden Verfahren.

Aufgabe Zweck
  • Öffnen der BizTalk Server-Verwaltung
 Ausführen der meisten Verwaltungsaufgaben.
  • Öffnen der Komponentendienste
 Ausführen zusätzlicher Verwaltungsaufgaben.
  • Veröffentlichen von BizTalk Server 2002 in Active Directory
 Veröffentlichen von BizTalk Server in einer verteilten Umgebung.
  • Löschen von BizTalk Server 2002 aus Active Directory
 Entfernen der Registrierung des Computers aus Active Directory, so dass beim Abfragen von Active Directory nur die Computer, auf denen BizTalk Server weiterhin ausgeführt wird, ordnungsgemäß identifiziert werden.
  • Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren"
 Hinzufügen neuer Benutzer, die eine Verwaltungsberechtigung für BizTalk Server benötigen.
  • Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank
 Offlineschalten der BizTalk-Messaging-Verwaltungsdatenbank für Wartungszwecke.
  • Ändern der in einer Toolsinstallation verwalteten BizTalk-Messaging-Verwaltungsdatenbank
 Ändern der BizTalk-Messaging-Verwaltungsdatenbank von einem Clientcomputer aus.
  • Aktualisieren der Verwaltungskonsole
 Anzeigen des aktuellen Status von Servergruppen, Servern, Empfangsfunktionen, der Anzahl der Elemente in einer Warteschlange, usw.
Hinzufügen, Löschen und Konfigurieren einer Servergruppe:
  • Hinzufügen einer Servergruppe
 Hinzufügen einer neuen BizTalk Server-Gruppe, wenn ein zusätzliches dezentrales Skalieren erforderlich ist. BizTalk Server-Gruppen sind die Hauptfaktoren bei der Skalierbarkeit von BizTalk Server. Das Erstellen zusätzlicher Servergruppen ermöglicht die Erhöhung des Durchsatzes, da die Verarbeitung auf mehrere Computer verteilt wird.
  • Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe
  • Ändern des SMTP-Hosts, den eine BizTalk Server-Gruppe verwendet.

  • Ändern des URLs, den eine BizTalk Server-Gruppe verwendet, um Reliable Messaging-Bestätigungen zu empfangen.

  • Ändern, wie oft der BizTalk-Messaging-Verwaltungsobjektcache aktualisiert wird.

  • Hinzufügen und/oder Ändern des Proxyservers, den eine BizTalk Server-Gruppe verwendet.
  • Konfigurieren von Verbindungseigenschaften für eine Servergruppe
 Ändern der gemeinsam genutzten Warteschlange und/oder Überwachungsdatenbanken, mit denen die BizTalk Server-Gruppe verbunden ist. In der Regel müssen die Datenbanken nur geändert werden, wenn z. B. bei einer Wiederherstellung oder eines Sicherungsvorgangs zu einer anderen Datenbank oder einem anderen Datenbankserver gewechselt werden muss.
  • Konfigurieren von Überwachungseigenschaften für eine Servergruppe
 Ermöglichen verschiedener Ebenen der Dokumentüberwachung für die Servergruppe und Aktivieren/Deaktivieren der Überwachung.
  • Konfigurieren der Parserreihenfolge für eine Servergruppe
 Ändern der Parserreihenfolge oder Aktualisieren der Parserliste über die Registrierung. Die Reihenfolge der Parserliste kann z. B. geändert werden, um den Durchsatz zu erhöhen, wenn alle oder die meisten empfangenen Dokumente einen bestimmten Typ aufweisen. Wenn sich der Parser für diesen Dokumenttyp am Listenanfang befindet, verarbeitet BizTalk Server die Dokumente schneller, denn Analyseversuche mit anderen Parsern werden verhindert.
  • Löschen einer Servergruppe
 Entfernen einer vollständigen BizTalk Server-Gruppe. Wenn die Durchsatzanforderungen insgesamt verringert werden, führt das Löschen einer oder mehrerer Gruppen zur Freigabe von Hardwareressourcen, die für andere Zwecke verwendet werden können.
Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe:
  • Hinzufügen eines Servers zu einer Gruppe
 Hinzufügen eines neuen Servers zu einer vorhandenen BizTalk Server-Gruppe. Es ist nicht nur möglich, einer BizTalk Server-Implementierung Gruppen hinzuzufügen, jeder Gruppe kann darüber hinaus eine variable Anzahl von Servern zugeordnet werden. Der Durchsatz kann maximiert werden, indem die Anzahl der Server in der Gruppe entsprechend der Verarbeitungsleistung der Datenbankserver in der Gruppe optimiert wird.
  • Löschen eines Servers aus einer Gruppe
 Entfernen eines Servers aus einer BizTalk Server-Gruppe. Um einen Server von einer BizTalk Server-Gruppe zu einer anderen zu verschieben, müssen Sie ihn zunächst aus der aktuellen Gruppe löschen und ihn anschließend zu der neuen Gruppe hinzufügen.
  • Konfigurieren eines Servers in einer Gruppe
 Ändern der allgemeinen Eigenschaften eines Servers, z. B. der maximalen Anzahl der zulässigen Empfangsfunktionsthreads und der Teilnahme des Servers an der Arbeitsobjektverwaltung. Durch Erstellen von Empfangsfunktionen, die auf dem Server ausgeführt werden, und Markieren des Servers, so dass er nicht an der Verwaltung teilnimmt, kann der Server für den schnellstmöglichen Empfang von Austauschvorgängen optimiert werden und so zum Gesamtdurchsatz beitragen.
  • Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server
 Ändern der BizTalk-Messaging-Verwaltungsdatenbank, die ein Server verwendet. Dies ist normalerweise nur nötig, wenn eine dauerhafte Änderung an einer anderen Datenbank vorgenommen werden muss, z. B. bei einer Wiederherstellung oder beim Ersetzen des vorhandenen Datenbankservers durch einen anderen Datenbankserver.
Verwalten von Servern in einer Gruppe:
  • Starten eines Servers in einer Gruppe
 Starten eines BizTalk-Servers. Hiermit werden die BizTalk Server-Laufzeitdienste auf dem zugeordneten Server gestartet, damit er am Empfangen und/oder Verarbeiten von Austauschvorgängen teilnehmen kann.
  • Beenden eines Servers in einer Gruppe
 Beenden eines BizTalk-Servers. Hiermit werden die BizTalk Server-Laufzeitdienste auf dem zugeordneten Server beendet, damit er nicht mehr am Empfangen und/oder Verarbeiten von Austauschvorgängen teilnimmt.
  • Freigeben von Austauschvorgängen auf einem Server
 Freigeben von Austauschvorgängen auf einem Server, damit die Austauschvorgänge an andere Server in der Gruppe weitergegeben werden können, wenn der ursprüngliche Server beendet oder in den Offlinemodus versetzt wird.
  • Konfigurieren der Datenträgerzwischenspeicherung
 Aktivieren oder Deaktivieren der Datenträgerzwischenspeicherung. Wenn die Datenträgerzwischenspeicherung deaktiviert ist, wird der Datenverlust bei schwerwiegenden Fehlern, z. B. einem Stromausfall, vermieden.
Verwalten von Warteschlangen:
  • Verschieben von Dokumenten in die Angehalten-Warteschlange
 Verschieben eines Dokuments von der Verarbeitungs-, der Geplant- oder der Wiederholungswarteschlange zur Angehalten-Warteschlange. Dies geschieht normalerweise dann, wenn eine bestimmte Nachricht oder eine Gruppe von Nachrichten angehalten werden muss, weil ein Problem oder eine Ausnahmenbedingung aufgetreten ist, die die Nachricht selbst betrifft oder Systeme, an die die Nachricht möglicherweise hinterher gesendet wird, wenn sie nicht angehalten wird.
  • Anzeigen von Fehlerbeschreibungen
 Herausfinden, welcher Fehler dazu führte, dass ein Dokument in der Angehalten-Warteschlange abgelegt wurde. Dieses Verfahren ist in erster Linie für Problemlösungsszenarien vorgesehen.
  • Anzeigen von Austauschvorgängen
 Anzeigen eines Austauschvorgangs, der in die Angehalten-Warteschlange aufgenommen wurde. Dieses Verfahren ist in erster Linie für Problemlösungsszenarien vorgesehen.
  • Anzeigen von Dokumenten
 Anzeigen eines Dokuments, das in der Angehalten-Warteschlange abgelegt wurde. Dieses Verfahren ist in erster Linie für Problemlösungsszenarien vorgesehen.
  • Erneutes Senden von Dokumenten
 Erneutes Senden eines Dokuments, das sich zur Zeit in der Angehalten-Warteschlange befindet. Dieses Verfahren dient in der Regel zum erneuten Senden von Nachrichten, wenn der Grund für das Anhalten der Nachricht nicht mehr besteht. Wenn z. B. ein Transportproblem dazu geführt hat, dass mehrere Nachrichten angehalten wurden, werden die Nachrichten nach Beheben des Problems normalerweise erfolgreich übertragen.
  • Löschen von Dokumenten
 Löschen eines Dokuments, das in der Angehalten-Warteschlange abgelegt wurde. Hierbei wird vorausgesetzt, dass die Nachricht entweder nicht mehr benötigt wird oder vom Benutzer gespeichert wurde.
Verwalten von Datenbanken für eine Servergruppe:
  • Herunterfahren der BizTalk Server-Austauschanwendung
 Ändern einer Verbindung zu der BizTalk-Messaging-Verwaltungsdatenbank, der Überwachungsdatenbank oder der Datenbank für gemeinsam genutzte Warteschlangen.
  • Entfernen der Überwachungsdatenbank und der Datenbanken für gemeinsam genutzte Warteschlangen
 Entfernen der Überwachungsdatenbank oder der Datenbank für gemeinsam genutzte Warteschlangen. Dieses Verfahren wird normalerweise nur dann angewendet, wenn BizTalk Server für die Verwendung einer anderen Überwachungsdatenbank und/oder einer anderen Datenbank für gemeinsam genutzte Warteschlangen konfiguriert wurde. Wenn diese Datenbanken entfernt werden, ohne BizTalk Server zuerst für andere Datenbanken zu konfigurieren, kann BizTalk Server nicht mehr ordnungsgemäß ausgeführt werden.
  • Manuelles Wiederherstellen der Überwachungsdatenbank
 Bei fehlerhafter oder beschädigter Überwachungsdatenbank. Hierbei wird vorausgesetzt, dass zuvor eine Sicherungskopie erstellt wurde, mit der Sie die Datenbank wiederherstellen können.
  • Manuelles Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen
 Bei fehlerhafter oder beschädigter Datenbank für gemeinsam genutzte Warteschlangen. Hierbei wird vorausgesetzt, dass zuvor eine Sicherungskopie erstellt wurde, mit der Sie die Datenbank wiederherstellen können.
Verwalten von Empfangsfunktionen für eine Servergruppe:
  • Hinzufügen einer Dateiempfangsfunktion
 Erstellen einer Dateiempfangsfunktion.
  • Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"
 Konfigurieren der allgemeinen Eigenschaften einer Dateiempfangsfunktion, wie z. B. der Sicherheitsinformationen, und Aktivieren oder Deaktivieren der Funktion.
  • Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"
 Ändern des Servers, auf dem die Dateiempfangsfunktion ausgeführt wird, der Abrufinformationen oder des Präprozessors, der die Dateiempfangsfunktion verwendet.
  • Hinzufügen einer Message Queuing-Empfangsfunktion
 Erstellen einer Message Queuing-Empfangsfunktion.
  • Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"
 Konfigurieren der allgemeinen Eigenschaften einer Message Queuing-Empfangsfunktion, wie z. B. der Sicherheitsinformationen, und Aktivieren oder Deaktivieren der Funktion.
  • Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"
 Ändern des Servers, auf dem die Message Queuing-Empfangsfunktion ausgeführt wird, der Abrufinformationen oder des Präprozessors, der die Message Queuing-Empfangsfunktion verwendet.
  • Hinzufügen einer HTTP-Empfangsfunktion
 Erstellen einer HTTP-Empfangsfunktion. Auf diese Aufgabe muss die Aufgabe Konfigurieren von Zugriffsrechten basierend auf der IIS-Schutzebene folgen, damit der Empfangstransport ordnungsgemäß durchgeführt wird.
  • Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Allgemein"
 Aktivieren oder Deaktivieren der HTTP-Empfangsfunktion.
  • Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Dienste"
 Ändern der Dienstekonfiguration der HTTP-Empfangsfunktion, wie z. B. des Servers, auf dem die HTTP-Empfangsfunktion ausgeführt wird, des verwendeten virtuellen Verzeichnisses, an das die HTTP-Empfangsfunktion sendet, und der Verwendung eines Korrelationstokens.
  • Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen
 Konfigurieren von erweiterten Eigenschaften für Empfangsfunktionen. Diese Eigenschaften umfassen Offenheitsgrad, Umschlags- und Kanalname sowie Informationen zur Quell- und Zielorganisation. Sie können die erweiterten Eigenschaften beim Erstellen der Empfangsfunktion oder bei Bedarf konfigurieren.
  • Konfigurieren von Zugriffsrechten basierend auf der IIS-Schutzebene
 Diese Aufgabe muss nach der Erstellung einer HTTP-Empfangsfunktion ausgeführt werden, damit der Empfangstransport ordnungsgemäß durchgeführt wird.
  • Löschen einer Empfangsfunktion
 Endgültiges Löschen einer Empfangsfunktion.
Verwalten von BizTalk-Diensten:
  • Starten eines BizTalk-Dienstes
 Starten eines BizTalk-Dienstes auf dem zugeordneten Server. Durch Starten von Diensten wird die Verarbeitung von Nachrichten durch diesen Server ermöglicht. Der Server muss sich im beendeten Status befinden, damit er gestartet werden kann.
  • Beenden eines BizTalk-Dienstes
 Beenden von BizTalk-Diensten auf dem zugeordneten Server. Durch Beenden von Diensten wird die Verarbeitung von Nachrichten durch diesen Server angehalten. Der Server muss ausgeführt werden, damit er beendet werden kann. Dienste werden normalerweise verwendet, um die Verarbeitung vorübergehend anzuhalten, während Konfigurationsänderungen vorgenommen oder Probleme behoben werden.
Verwalten der Ereignisanzeige:
  • Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler
 Anzeigen der Ereignisse ausschließlich für BizTalk Server und/oder die XLANG-Ablaufplanung (XLANG Scheduler) im Anwendungsereignisprotokoll. Dieses Verfahren wird normalerweise angewendet, wenn es eine Vielzahl von nicht-BizTalk Server-Ereignissen gibt, die bei der Problembehandlung nicht angezeigt werden sollen.
  • Anzeigen von anwendungsbezogenen Fehlern in der Ereignisanzeige
 Anzeigen von Fehlermeldungen, die in der Ereignisanzeige protokolliert wurden.
Verwalten von XLANG-Anwendungen und -Datenbanken:
  • Löschen von Datensätzen mithilfe von Prozeduren aus der Persistenzdatenbank
 Löschen von alten Persistenzdokumenten aus der Persistenzdatenbank.
  • Herunterfahren aller XLANG-Anwendungen
 Durchführen eines kontrollierten Herunterfahrens für alle XLANG-Ablaufpläne, die allen XLANG COM+-Anwendungen zugeordnet sind. Dadurch wird der Status aller aktiven XLANG-Ablaufpläne in der Persistenzdatenbank gespeichert.
  • Neu starten aller XLANG-Anwendungen
 Durchführen eines kontrollierten Neustarts für alle XLANG COM+-Anwendungen.
Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler):
  • Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)
 Nach der ersten Installation von BizTalk Server ist die COM+-Anwendung XLANG-Ablaufplanung so konfiguriert, dass sie als interaktiver Benutzer ausgeführt wird. Damit das XLANG-Ablaufplanungsmodul verwendet werden kann, wenn kein interaktiver Benutzer angemeldet ist, muss die Anwendung so konfiguriert werden, dass sie als spezifisches Windows-Konto ausgeführt wird.
Verwalten von weiteren COM+-Hostanwendungen für XLANG-Ablaufpläne:
  • Erstellen einer neuen, leeren Persistenzdatenbank
 Erstellen einer neuen Persistenzdatenbank mit den Standardeinstellungen.
  • Ändern der Anwendungsidentität einer COM+-Anwendung
 Ändern des interaktiven Standardbenutzerkontos für eine COM+-Anwendung.
  • Ändern der DSN-Einstellungen für eine COM+-Anwendung
 Ändern der Einstellungen für den Datenquellennamen (Data Source Name, DSN) einer COM+-Anwendung und Generieren der Struktur für die neue, leere Persistenzdatenbank.
  • Herunterfahren einer COM+-Hostanwendung für XLANG-Ablaufpläne
 Durchführen eines kontrollierten Herunterfahrens aller XLANG-Ablaufpläne, die einer bestimmten XLANG COM+-Anwendung zugeordnet sind. Dadurch wird der Status der XLANG-Ablaufpläne in der Persistenzdatenbank gespeichert.
  • Überwachen von aktiven XLANG-Ablaufplänen
 Dieses Thema stellt Informationen über die Tools bereit, die zum Überwachen der Fehlerfreiheit der ausgeführten XLANG-Ablaufpläne verfügbar sind.


Durchführen von BizTalkServer-Verwaltungsaufgaben

BizTalk Server 2002 ~ Verwaltung

Durchführen von BizTalk Server-Verwaltungsaufgaben

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Verwenden der BizTalk Server-Verwaltung bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Informationen zur BizTalk Server-Verwaltung lesen, um alle Features und Fähigkeiten der BizTalk Server-Verwaltung vollständig zu verstehen.

In diesem Abschnitt werden folgende Verfahren und Themen behandelt:

  • Öffnen der BizTalk Server-Verwaltung

  • Öffnen der Komponentendienste

  • Veröffentlichen von BizTalk Server 2002 in Active Directory

  • Löschen von BizTalk Server 2002 aus Active Directory

  • Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren"

  • Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank

  • Ändern der in einer Toolsinstallation verwalteten BizTalk-Messaging-Verwaltungsdatenbank

  • Aktualisieren der Verwaltungskonsole

  • Hinzufügen, Löschen und Konfigurieren einer Servergruppe

  • Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

  • Verwalten von Servern in einer Gruppe

  • Verwalten von Warteschlangen

  • Verwalten von Datenbanken für eine Servergruppe

  • Verwalten von Empfangsfunktionen für eine Servergruppe

  • Verwalten von BizTalk-Diensten

  • Verwalten der Ereignisanzeige

  • Verwalten von XLANG-Anwendungen und -Datenbanken


Öffnen der BizTalk Server-Verwaltung

Die meisten BizTalk Server-Verwaltungsaufgaben werden im MMC-Snap-In (Microsoft Management Console) BizTalk Server-Verwaltung ausgeführt.

  • Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk Server-Verwaltung.


Öffnen der Komponentendienste

Bei einigen der Verwaltungsaufgaben sind die Komponentendienste erforderlich.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.


Veröffentlichten von BizTalkServer2002 in Active Directory

BizTalk Server 2002 ~ Verwaltung

Veröffentlichten von BizTalk Server 2002 in Active Directory

Nach der Installation von BizTalk Server 2002 können Sie BizTalk Server in Microsoft® Active Directory™ veröffentlichen, um die Verfügbarkeit von BizTalk Server in einer verteilten Umgebung zu ermitteln. So müssen Sie möglicherweise wissen, auf welchen Computern BizTalk Server ausgeführt wird. Dies können Sie ermitteln, indem Sie BizTalk Server 2002 in Active Directory veröffentlichen.

  1. Klicken Sie im Startmenü auf Ausführen.

  2. Geben Sie cmd im Feld Öffnen ein, und klicken Sie auf OK.

  3. Ändern Sie an der Eingabeaufforderung das Verzeichnis im BizTalk Server 2002-Installationsverzeichnis in den Ordner Setup.

    Beispiel: Geben Sie an der Eingabeaufforderung cd \Programme\Microsoft BizTalk Server\Setup ein, und drücken Sie die EINGABETASTE.

  4. Geben Sie an der Eingabeaufforderung cscript AD_registration.vbs ein, und drücken Sie die EINGABETASTE.

  5. Klicken Sie im Bestätigungsdialogfeld auf OK.

  6. Geben Sie an der Eingabeaufforderung exit ein, und drücken Sie die EINGABETASTE

Anmerkung

  • Das Skript AD_registration.vbs ist nicht für die Verwendung auf einem Remotecomputer vorgesehen. Es wird empfohlen, dieses Skript auf einem lokalen Computer auszuführen. Wenn Sie einen Remotecomputer registrieren müssen, ist folgende Änderung erforderlich:
    • Ändern Sie den Wert der Variablen ServerName im Skript AD_registration.vbs in den Namen des Remotecomputers. Dadurch fordert der lokale Computer den Anbieter für die Windows-Verwaltungsinstrumentation (Windows Management Instrumentation, WMI) auf, den Remotecomputer zu registrieren. Der WMI-Anbieter des Remotecomputers implementiert den entsprechenden Code.


Löschen von BizTalk Server 2002 aus Active Directory

Wenn Sie BizTalk Server 2002 von einem Computer entfernen, wird die zugehörige Registrierung nicht automatisch aus Active Directory entfernt. Sie müssen die Registrierung auf diesem Computer entfernen, so dass nur die Computer, auf denen BizTalk Server 2002 weiterhin ausgeführt wird, beim Abfragen von Active Directory ordnungsgemäß identifiziert werden.

  1. Klicken Sie im Startmenü auf Ausführen.

  2. Geben Sie cmd im Feld Öffnen ein, und klicken Sie auf OK.

  3. Ändern Sie an der Eingabeaufforderung das Verzeichnis im BizTalk Server 2002-Installationsverzeichnis in den Ordner Setup.

    Beispiel: Geben Sie an der Eingabeaufforderung cd \Programme\Microsoft BizTalk Server\Setup ein, und drücken Sie die EINGABETASTE.

  4. Geben Sie an der Eingabeaufforderung cscript AD_registration.vbs /u ein, und drücken Sie die EINGABETASTE.

  5. Klicken Sie im Bestätigungsdialogfeld auf OK.

  6. Geben Sie an der Eingabeaufforderung exit ein, und drücken Sie die EINGABETASTE


Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren"

Um Benutzer zur Gruppe BizTalk Server-Administratoren hinzuzufügen, müssen Sie Mitglied der lokalen Gruppe Administratoren unter Windows 2000 sein. Weitere Informationen zum Hinzufügen von Benutzern zur lokalen Gruppe Administratoren unter Windows 2000 finden Sie unter "Hinzufügen von Benutzern, zu Gruppe" in der Windows 2000-Hilfe.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

  2. Erweitern Sie System und Lokale Benutzer und Gruppen, und klicken Sie dann auf den Ordner Gruppen.

    Der Inhalt des Ordners wird im Detailfensterbereich angezeigt.

  3. Klicken Sie im Detailfensterbereich auf BizTalk Server-Administratoren.

  4. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie dann auf Mitglied hinzufügen.

    Das Dialogfeld Eigenschaften von BizTalk Server-Administratoren wird angezeigt.

  5. Klicken Sie auf Hinzufügen.

  6. Klicken Sie in Suchen in auf den Namen Ihrer Domäne oder den Ihres Computers.

  7. Klicken Sie in der Liste mit den Benutzern und Computern, die der Domäne oder dem Computer zugeordnet sind, die/den Sie in Schritt 6 ausgewählt haben, auf das hinzuzufügende Benutzerkonto, dann auf Hinzufügen und schließlich auf OK.

  8. Klicken Sie auf OK, um das Dialogfeld Eigenschaften von BizTalk Server-Administratoren zu schließen.

Verwandtes Thema

Administratorrechte


Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank

Mit diesem Verfahren können Sie die BizTalk-Messaging-Verwaltungsdatenbank für Wartungszwecke in den Offlinemodus versetzen. Damit BizTalk Server während der Wartung ohne Unterbrechung weiterarbeiten kann, müssen Sie die BizTalk-Messaging-Verwaltungsdatenbank replizieren und alle Server auf dieses Replikat verweisen.

Anmerkung

  • Wenn Sie die Server auf eine andere Datenbank verweisen, die kein Replikat der Originaldatenbank ist, ist die Rückkehr zur BizTalk-Messaging-Verwaltungsdatenbank im Anschluss an den Wartungsvorgang möglicherweise mit Schwierigkeiten verbunden. Von dieser Methode wird abgeraten.

Weitere Informationen zum Ändern der Datenbank finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank.

  1. Beenden Sie alle Server im Knoten Microsoft BizTalk Server 2002.

    Weitere Informationen finden Sie unter Beenden eines Servers in einer Gruppe.

  2. Klicken Sie in der BizTalk Server-Verwaltung auf Microsoft BizTalk Server 2002.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Microsoft BizTalk Server 2002 wird angezeigt.

  4. Auf der Registerkarte Allgemein können Sie folgende Eigenschaften ändern:
    • Name der SQL-Datenbank. Geben Sie den Namen des Replikats der BizTalk-Messaging-Verwaltungsdatenbank ein, das alle Servergruppen verwenden sollen, während die Originaldatenbank offline ist.

    • Name des SQL-Servers. Geben Sie den Namen des Servers ein, auf dem das Microsoft® SQL Server™-Datenbankreplikat gespeichert ist.
  5. Klicken Sie auf OK.

  6. Beenden Sie die BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application).

    Weitere Informationen finden Sie unter Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application).

  7. Starten Sie alle Server im Knoten Microsoft BizTalk Server 2002 neu.

    Weitere Informationen finden Sie unter Starten eines Servers in einer Gruppe.

  8. Starten Sie den BizTalk-Messagingdienst neu.

    Weitere Informationen finden Sie unter Starten eines BizTalk-Dienstes.

Anmerkungen

  • Wenn Sie die BizTalk-Messaging-Verwaltungsdatenbank ändern oder die Servergruppen auf einen anderen Microsoft SQL-Server verweisen, werden alle BizTalk-Server in der BizTalk-Messaging-Verwaltungsdatenbank mit den neuen Informationen aktualisiert.

  • Die BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application) wird automatisch neu gestartet, wenn Sie das nächste Mal eine Nachricht über die COM+-Schnittstelle IInterchange senden.

  • Microsoft BizTalk Server 2002 hängt von der in Microsoft Windows® integrierten Authentifizierung für den Zugriff auf SQL Server ab. Daher müssen BizTalk-Dienste unter einem Domänen- oder lokalen Konto ausgeführt werden, dem Zugriff auf SQL Server gewährt wurde. Wenn sich das Kennwort für das BizTalk Server-Messagingdienstkonto ändert, müssen Sie das für dieses Dienstkonto verwendete Kennwort mithilfe des bereitgestellten Befehlszeilenprogramms ändern. Weitere Informationen zum Ändern des Kennwortes für das Dienstkonto finden Sie unter Ändern des Kennwortes für das Dienstkonto.

Verwandte Themen

Ändern der BizTalk-Messaging-Verwaltungsdatenbank

Verwalten von BizTalk-Diensten

Herunterfahren der BizTalk Server-Austauschanwendung

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Ändern der in einer Toolsinstallation verwalteten BizTalk-Messaging-Verwaltungsdatenbank

Mit diesem Verfahren wird die BizTalk-Messaging-Verwaltungsdatenbank, die von einem Clientcomputer mit einer Toolsinstallation von BizTalk Server verwaltet wird, geändert. Dabei wird aber die BizTalk-Messaging-Verwaltungsdatenbank, auf die die BizTalk Server-Laufzeit verweist, nicht geändert. Informationen zum Ändern der BizTalk-Messaging-Verwaltungsdatenbank, auf die die BizTalk Server-Laufzeit verweist, finden Sie unter Konfigurieren der BizTalk-Messaging-Verwaltungsdatenbank.

  1. Klicken Sie in der BizTalk Server-Verwaltung auf Microsoft BizTalk Server 2002.

  2. Klicken Sie im Menü Vorgang auf Konf.-DB auswählen.

    Das Dialogfeld Verwaltungsdatenbank auswählen wird angezeigt.

  3. Geben Sie im Feld Name der SQL-Datenbank den Namen der BizTalk-Messaging-Verwaltungsdatenbank ein, die Sie vom Clientcomputer verwalten möchten.

  4. Geben Sie im Feld Name des SQL-Servers den Namen des Servers ein, auf dem die Microsoft SQL Server-Datenbank gespeichert ist, die wiederum die zu verwaltende BizTalk-Messaging-Verwaltungsdatenbank speichert.

  5. Klicken Sie auf OK.

Anmerkung

  • Diese Option ist nur in einer Toolsinstallation von BizTalk Server verfügbar.

Verwandtes Thema

Verwaltungsfunktionen einer Toolsinstallation von BizTalk Server


Aktualisieren der Verwaltungskonsole

Da es für die Verwaltungskonsole keinen automatischen Aktualisierungszyklus gibt, müssen Sie dieses Verfahren durchführen, um den aktuellen Status der folgenden Elemente anzuzeigen:

  • Knoten Microsoft BizTalk Server 2002

  • Servergruppen

  • Server

  • Warteschlangen

  • Empfangsfunktionen.
  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und erweitern Sie dann die Elemente in der Konsolenstruktur, bis Sie das Element finden, das aktualisiert werden soll.

  2. Sie müssen möglicherweise die Servergruppen, Warteschlangen, Empfangsfunktionen und Server erweitern, um das betreffende Element zu finden.

  3. Klicken Sie auf das Element, das Sie aktualisieren möchten.

  4. Klicken Sie im Menü Vorgang auf Aktualisieren.

Anmerkung

  • Dieses Verfahren können Sie für jedes Element in der Konsolenstruktur ausführen. Wenn Sie die Verwaltungskonsole auf der Stammebene aktualisieren, werden alle Elemente in der Verwaltungskonsole aktualisiert. Aktualisieren Sie eine Servergruppe, werden nur die Elemente in dieser Gruppe aktualisiert.

Verwandte Themen

Gruppen und Server

Empfangsfunktionen

Verwenden von Warteschlangen


Hinzufügen, Löschen und Konfigurieren einer Servergruppe

Servergruppen sind Zusammenstellungen einzelner Server, die zentral verwaltet, konfiguriert und überwacht werden. Servergruppen sind die Hauptfaktoren bei der Skalierbarkeit von BizTalk Server. Das Erstellen zusätzlicher Servergruppen ermöglicht die Erhöhung des Durchsatzes, da die Verarbeitung auf mehrere Computer verteilt wird. Server in einer BizTalk Server-Gruppe haben folgende gemeinsame Eigenschaften:

  • Eine Datenbank für gemeinsam genutzte Warteschlangen, in der alle Dokumente bis zu ihrer erfolgreichen Verarbeitung dauerhaft gespeichert werden.

  • Eine Überwachungsdatenbank, die zum Protokollieren der Dokument- und Austauschaktivität und zum Ausführen von Berichten verwendet wird.

  • Empfangsfunktionen.

  • Alle Komponenten, die der Server zum Verarbeiten von Dokumenten und Austauschvorgängen benötigt, z. B. Transportkomponenten und Anwendungsintegrationskomponenten (Application Integration Components, AICs).

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen einer Servergruppe

  • Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

  • Konfigurieren von Verbindungseigenschaften für eine Servergruppe

  • Konfigurieren von Überwachungseigenschaften für eine Servergruppe

  • Konfigurieren der Parserreihenfolge für eine Servergruppe

  • Löschen einer Servergruppe

Anmerkung

  • Wenn Sie aus Gründen der Skalierbarkeit und der besseren Leistung mehrere Servergruppen einrichten, sollten Sie nur eine BizTalk-Messaging-Verwaltungsdatenbank verwenden. Andernfalls können diese Server nicht gemeinsam die gleiche BizTalk-Messaging-Verwaltungskonfiguration verwenden.


Hinzufügen einer Servergruppe

Wenn sich Ihre Geschäftsanforderungen ändern, möchten Sie die BizTalk Server-Gruppen möglicherweise umstrukturieren, um die Leistung Ihren aktuellen Bedürfnissen entsprechend zu optimieren. Dabei müssen Sie gegebenenfalls neue Servergruppen hinzufügen, um Ihre Organisation besser zu verwalten.

  1. Klicken Sie in der BizTalk Server-Verwaltung auf Microsoft BizTalk Server 2002.

  2. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Gruppe.

    Das Dialogfeld Neue Gruppe wird angezeigt.

  3. Geben Sie im Feld Gruppenname den Namen der neuen Servergruppe ein.

  4. Im Bereich Überwachungsdatenbank:
    • Geben Sie im Feld Name der Überwachungsdatenbank den Namen der Überwachungsdatenbank für diese Servergruppe ein.

    • Geben Sie im Feld Name des SQL-Servers für die Überwachung den Namen des Servers ein, auf dem die Überwachungsdatenbank für diese Servergruppe gespeichert ist.
  5. Im Bereich Datenbank für gemeinsam genutzte Warteschlangen:
    • Geben Sie im Feld Name der Datenbank für gemeinsam genutzte Warteschlangen den Namen der Datenbank für gemeinsam genutzte Warteschlangen für diese Servergruppe ein.

    • Geben Sie im Feld Name des SQL-Servers für gemeinsam genutzte Warteschlangen den Namen des Servers ein, auf dem die Datenbank für gemeinsam genutzte Warteschlangen für diese Servergruppe gespeichert ist.
  6. Klicken Sie auf OK.

Wichtig

  • Verwenden Sie keines der folgenden Zeichen in dem Namen der Servergruppe:

    ~ ` ! @ # $ % ^ & * ( ) + = [ ] { } | ;\" '< > , . ?.

    Weitere Informationen zu ungültigen Zeichen finden Sie unter Informationen zu WMI (Windows Management Instrumentation).

Anmerkungen

  • Mit diesem Verfahren wird eine Servergruppe erstellt. Hinweise zum Konfigurieren der Servergruppe mit zusätzlichen Einstellungen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  • Wenn Sie aus Gründen der Skalierbarkeit und der besseren Leistung mehrere Servergruppen einrichten, sollten Sie nur eine zentrale BizTalk-Messaging-Verwaltungsdatenbank verwenden. Andernfalls können diese Server nicht gemeinsam die gleiche BizTalk-Messaging-Verwaltungskonfiguration verwenden.

  • Microsoft BizTalk Server 2002 hängt von der in Microsoft Windows integrierten Authentifizierung für den Zugriff auf SQL Server ab. Daher müssen BizTalk-Dienste unter einem Domänen- oder lokalen Konto ausgeführt werden, dem Zugriff auf SQL Server gewährt wurde. Wenn sich das Kennwort für das BizTalk Server-Messagingdienstkonto ändert, müssen Sie das für dieses Dienstkonto verwendete Kennwort mithilfe des bereitgestellten Befehlszeilenprogramms ändern. Weitere Informationen zum Ändern des Kennwortes für das Dienstkonto finden Sie unter Ändern des Kennwortes für das Dienstkonto.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

Gruppen und Server

Verwalten der BizTalk-Messaging-Verwaltungsdatenbank

Datenbank für gemeinsam genutzte Warteschlangen

Überwachungsdatenbank

Informationen zu WMI (Windows Management Instrumentation)


Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

Mit diesem Verfahren können Sie die allgemeinen Eigenschaften einer bestimmten Servergruppe so konfigurieren, dass die Verarbeitung auf verschiedene Servergruppen verteilt werden kann.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und klicken Sie auf die Servergruppe, die Sie konfigurieren möchten.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  3. Geben Sie im Feld SMTP-Host den Namen des SMTP-Hosts (Simple Mail Transfer Protocol) ein, den diese Servergruppe verwendet.

    Wichtig

    • Das Feld SMTP-Host ist optional. Sie müssen des Feld jedoch konfigurieren, wenn im BizTalk-Messaging-Manager SMTP als Transportdienst verwendet werden soll. Beispielsweise können Sie im BizTalk-Messaging-Manager SMTP nur dann als primären oder sekundären Transport auswählen, wenn Sie hier den SMTP-Host konfiguriert haben.
  4. Geben Sie im Feld Antwort-URL für Reliable Messaging den URL ein, den diese Servergruppe verwendet, um zuverlässige Messagingübermittlungsbestätigungen mithilfe eines der folgenden unterstützten Protokolle zu empfangen: Datei, Message Queuing, HTTP, HTTPS oder SMTP.
    Transportprotokoll | Zu verwendendes Präfix
    Datei | file://
    Message Queuing | queue://Direct=OS:<Servername>\<Warteschlangenname>
    Hypertext Transfer Protocol (HTTP) | http://
    Secure Hypertext Transfer Protocol (HTTPS) | https://
    Simple Mail Transfer Protocol (SMTP) | mailto:

    Falls Sie Message Queuing angeben, müssen Sie einen Formatnamen verwenden. Außerdem muss vor dem Formatnamen queue:// stehen. Weitere Informationen zu Formatnamen finden Sie unter Verfügbare Empfangsfunktionen.

  5. Klicken Sie in der Liste Aktualisierungsintervall für Messaging-Verwaltungsobjektcache (Sek.) auf die Anzahl der Sekunden zwischen Cacheaktualisierungen für diese Servergruppe.

    Der Bereich für diesen Wert liegt zwischen 1 und 300 Sekunden. In der Standardeinstellung aktualisiert der Server diesen Cache alle 50 Sekunden.

  6. Aktivieren Sie im Bereich Proxyserver das Kontrollkästchen Proxyserver verwenden, falls Sie BizTalk Server für die Verbindung zum Internet über einen Proxyserver konfigurieren möchten.

    Geben Sie die Adresse, den Port, den Benutzernamen und das Kennwort des Proxyservers ein, der verwendet werden soll.

  7. Klicken Sie auf OK.

  8. Führen Sie die folgenden Aktionen nur dann aus, wenn Sie im Bereich Proxyserver Änderungen vorgenommen haben:
    • Beenden Sie alle Server in der Gruppe, für die Sie die allgemeinen Eigenschaften konfiguriert haben. Weitere Informationen zum Beenden eines Servers finden Sie unter Beenden eines Servers in einer Gruppe.

    • Starten Sie alle Server in der Gruppe, für die Sie die allgemeinen Eigenschaften konfiguriert haben. Weitere Informationen zum Starten eines Servers finden Sie unter Starten eines Servers in einer Gruppe.

Anmerkungen

  • Reliable Messaging in BizTalk Server ist kompatibel mit BizTalk Framework 2.0. Weitere Informationen zu Reliable Messaging und BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk Server-Website (www.microsoft.com/biztalk/). Suchen Sie dort nach BizTalk Framework 2.0.

  • Verwenden Sie beim Konfigurieren des Antwort-URL für Reliable Messaging eine ASP-Seite (Active Server Pages) oder eine Nachrichtenwarteschlange mit einer Empfangsfunktion zur Überwachung. Falls Sie anfangs keine eigene ASP (Active Server Page) konfigurieren möchten, verwenden Sie die zum Lieferumfang von BizTalk Server gehörende Datei ReceiveStandard.asp. Sie finden diese ASP-Beispielseite unter \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts. Diese Seite dient dazu, Sendungen anzunehmen und an BizTalk Server zu übermitteln. Weitere Informationen zum Implementieren einer sicheren Site finden Sie in der MSDN Online Library-Website (www.msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach dem Artikel "Implementing a Secure Site with ASP".

  • Falls Sie im Feld Antwort-URL für Reliable Messaging dem URL localhost hinzufügen, kann die Empfangsfunktion nicht ordnungsgemäß ausgeführt werden. Geben Sie in diesem Feld nicht localhost an.

  • Die Antwort auf eine HTTP-Sendung muss Text sein. Falls die Antwort Binärdaten erfordert, codieren Sie die Binärdaten mithilfe von MIME oder UUEncode.

  • Die Empfangsbestätigung für Reliable Messaging muss mit Unicode codiert werden.

Verwandte Themen

Verwaltungscache

Verfügbare Empfangsfunktionen

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Konfigurieren von Verbindungseigenschaften für eine Servergruppe

Mit diesem Verfahren können Sie die Überwachungsdatenbank und die Datenbank für gemeinsam genutzte Warteschlangen ändern, die die BizTalk Server-Gruppe verwendet. In der Regel müssen die Datenbanken nur geändert werden, wenn z. B. bei einer Wiederherstellung oder der Sicherung eines Moduls zu einer anderen Datenbank oder einem anderen Server gewechselt werden muss.

  1. Beenden Sie alle Server in der BizTalk Server-Gruppe, die konfiguriert werden soll.

    Weitere Informationen finden Sie unter Beenden eines Servers in einer Gruppe.

  2. Beenden Sie die BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application).

    Weitere Informationen finden Sie unter Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application).

  3. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und klicken Sie auf die Servergruppe, die Sie konfigurieren möchten.

  4. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  5. Klicken Sie auf die Registerkarte Verbindung.

  6. Im Bereich Überwachungsdatenbank:
    • Geben Sie im Feld Name der Überwachungsdatenbank den Namen der Überwachungsdatenbank ein, die diese Servergruppe verwenden soll.

    • Geben Sie im Feld Name des SQL-Servers für die Überwachung den Namen des Microsoft SQL-Servers ein, auf dem die Überwachungsdatenbank gespeichert ist, die diese Servergruppe verwenden soll.
  7. Im Bereich Datenbank für gemeinsam genutzte Warteschlangen:
    • Geben Sie im Feld Name der Datenbank für gemeinsam genutzte Warteschlangen den Namen der Datenbank für gemeinsam genutzte Warteschlangen ein, die diese Servergruppe verwenden soll.

    • Geben Sie im Feld Name des SQL-Servers für gemeinsam genutzte Warteschlangen den Namen des Microsoft SQL-Servers ein, auf dem die Datenbank für gemeinsam genutzte Warteschlangen gespeichert ist, die diese Servergruppe verwenden soll.
  8. Klicken Sie auf OK.

  9. Starten Sie alle Server in der BizTalk Server-Gruppe, die Sie gerade konfiguriert haben, neu.

    Weitere Informationen finden Sie unter Starten eines Servers in einer Gruppe.

Anmerkungen

  • Microsoft BizTalk Server 2002 hängt von der in Microsoft Windows integrierten Authentifizierung für den Zugriff auf SQL Server ab. Daher müssen BizTalk-Dienste unter einem Domänen- oder lokalen Konto ausgeführt werden, dem Zugriff auf SQL Server gewährt wurde. Wenn sich das Kennwort für das BizTalk Server-Messagingdienstkonto ändert, müssen Sie das für dieses Dienstkonto verwendete Kennwort mithilfe des bereitgestellten Befehlszeilenprogramms ändern. Weitere Informationen zum Ändern des Kennwortes für das Dienstkonto finden Sie unter Ändern des Kennwortes für das Dienstkonto.

  • Falls Sie Werte im Bereich Überwachungsdatenbank ändern, müssen Sie die Verbindungszeichenfolge in der Datei Connection.vbs entsprechend den neuen Angaben zur Überwachungsdatenbank ändern. Sie finden die Datei Connection.vbs im Ordner \Programme\Microsoft BizTalk Server\BizTalkTracking\VBScripts. Die Initial Catalog-Eigenschaft in der Verbindungszeichenfolge enthält den Namen der Überwachungsdatenbank. Geben Sie in dieser Eigenschaft den Namen der aktuellen Überwachungsdatenbank an. Die Verbindungszeichenfolge in der Datei Connection.vbs lautet:
    Const g_ConnectionString = "Provider=SQLOLEDB.1;
Persist Security Info=False;Integrated Security=SSPI;
Initial Catalog=<databasename>;
Data Source=<servername>;Connect Timeout=15"

    Die Data Source-Eigenschaft in der Verbindungszeichenfolge enthält den Namen des SQL-Servers, der als Host der Überwachungsdatenbank dient. Diese Eigenschaft muss aktualisiert werden, damit sie den richtigen SQL Server-Namen für die Überwachungsdatenbank wiedergibt.

Verwandte Themen

Verfügbare Empfangsfunktionen

Gruppen und Server

Herunterfahren der BizTalk Server-Austauschanwendung

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Mit den Überwachungseinstellungen einer Servergruppe wird das Überwachen von Austauschvorgängen aktiviert oder deaktiviert. Nach der Installation von Microsoft BizTalk Server 2002 ist die Dokumentüberwachung automatisch aktiviert, sind die Optionen Eingehenden Austausch protokollieren und Ausgehenden Austausch protokollieren ausgewählt und werden Metadaten für Austauschvorgänge überwacht. Anhand dieses Verfahrens können Sie die Überwachungseigenschaften anpassen.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und klicken Sie auf die Servergruppe, die Sie konfigurieren möchten.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  3. Klicken Sie auf die Registerkarte Überwachen.

  4. Aktivieren Sie das Kontrollkästchen Dokumentüberwachung aktivieren sowie diejenigen der folgenden Optionen, die Sie verwenden möchten:
    • Aktivieren Sie das Kontrollkästchen Eingehenden Austausch protokollieren, wenn der eingehende Austausch protokolliert werden soll.

    • Aktivieren Sie das Kontrollkästchen Ausgehenden Austausch protokollieren, wenn der ausgehende Austausch protokolliert werden soll.

    • Aktivieren Sie das Kontrollkästchen Ursprüngliche MIME-codierte Nachricht protokollieren, wenn MIME-codierte Nachrichten protokolliert werden sollen.
  5. Klicken Sie auf OK.

Vorsicht

  • Sie können die Dokumentüberwachung deaktivieren, indem Sie das Kontrollkästchen Dokumentüberwachung aktivieren deaktivieren. In diesem Fall stehen jedoch wichtige Funktionen von BizTalk Server 2002 nicht zur Verfügung. Weitere Informationen zur Überwachung finden Sie unter Grundlegendes zu den Überwachungseinstellungen einer Servergruppe.

Anmerkung

  • Wenn das Kontrollkästchen Dokumentüberwachung aktivieren deaktiviert ist, sind auch die Kontrollkästchen Eingehenden Austausch protokollieren, Ausgehenden Austausch protokollieren und Ursprüngliche MIME-codierte Nachricht protokollieren nicht verfügbar.

Verwandte Themen

Gruppen und Server

Grundlegendes zu den Überwachungseinstellungen einer Servergruppe


Konfigurieren der Parserreihenfolge für eine Servergruppe

Wenn BizTalk Server ein Dokument empfängt, wird versucht, das Dokument nach der Reihenfolge der Parserliste zu analysieren. Sie können die Reihenfolge der Parserliste ändern, um den Durchsatz zu optimieren. Positionieren Sie hierzu den am häufigsten verwendeten Parser an erster Stelle in der Parserliste.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und klicken Sie auf die Servergruppe, für die Sie die Parserreihenfolge konfigurieren möchten.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  3. Klicken Sie auf die Registerkarte Parser.

    Die Parser werden im Feld Aufrufreihenfolge für Server anordnen in folgender Reihenfolge aufgeführt:

    • BizTalk.ParserXML.1

    • BizTalk.ParserEdifact.1

    • BizTalk.ParserX12.1

    • BizTalk.ParserFFile.1
  4. Klicken Sie im Feld Aufrufreihenfolge für Server anordnen auf den Parser, den Sie verschieben möchten, und klicken Sie entweder auf den Pfeil nach oben oder auf den Pfeil nach unten, um den ausgewählten Parser in der Aufrufreihenfolge für den Server nach oben oder nach unten zu verschieben.

  5. Wenn die Parser in der gewünschten Reihenfolge angeordnet sind, klicken Sie auf OK.

Anmerkungen

  • Durch Klicken auf die Schaltfläche Aktualisieren werden Parser angezeigt, die in der lokalen Registrierung neu registriert sind. Damit ein neuer Parser im Feld Aufrufreihenfolge für Server anordnen angezeigt wird, müssen Sie bei demjenigen Server auf die Schaltfläche Aktualisieren klicken, auf dem der Parser registriert ist.

  • Die Parserliste kann nicht von einem Remoteserver aus aktualisiert werden. Wenn Sie benutzerdefinierte Parser registrieren, können Sie die Parserliste nur von dem Server aus aktualisieren, auf dem sie registriert ist.

  • Die Registerkarte Parser ist nicht in einer Toolsinstallation von BizTalk Server verfügbar.

Verwandtes Thema

Parser


Löschen einer Servergruppe

Wenn sich Ihre Geschäftsanforderungen ändern, möchten Sie die BizTalk Server-Gruppen möglicherweise umstrukturieren, um die Leistung Ihren aktuellen Bedürfnissen entsprechend zu optimieren. In diesem Fall müssen möglicherweise einige Servergruppen gelöscht werden, damit die Server in dieser Gruppe in andere Bereiche des Produktionssystems verschoben werden können, die mehr Ressourcen benötigen.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und klicken Sie auf die Servergruppe, die Sie löschen möchten.

  2. Klicken Sie auf einen Server in der Servergruppe, die gelöscht werden soll.

  3. Klicken Sie im Menü Vorgang auf Beenden.

    Wiederholen Sie die Schritte 2 und 3 für jeden Server in der Gruppe, bis Sie alle Server in der Gruppe beendet haben.

  4. Klicken Sie auf die Servergruppe.

  5. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  6. Klicken Sie auf Ja.

Anmerkungen

  • Servergruppen, die einen oder mehrere aktive Server enthalten, können nicht gelöscht werden. Sie müssen über Windows 2000-Administratorberechtigungen für alle Server der Gruppe verfügen, um die Server zu beenden und die Servergruppe zu löschen.

  • Die Überwachungsdatenbank und die Datenbank für gemeinsam genutzte Warteschlangen, die der jeweiligen Servergruppe zugeordnet sind, verbleiben auch nach dem Löschen der Gruppe in Microsoft SQL Server. Um die Überwachungsdatenbank und die Datenbank für gemeinsam genutzte Warteschlangen zu entfernen, müssen Sie sie manuell löschen. Weitere Informationen zum Löschen dieser Datenbanken finden Sie unter Entfernen der Überwachungsdatenbank und der Datenbanken für gemeinsam genutzte Warteschlangen.

Verwandte Themen

Gruppen und Server

Entfernen der Überwachungsdatenbank und der Datenbanken für gemeinsam genutzte Warteschlangen

Beenden eines Servers in einer Gruppe


Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Server in einer Gruppe sind so konfiguriert, dass ein Gleichgewicht zwischen Serverleistung und höchstem Durchsatz erzielt wird. Wenn sich Ihre Geschäftsanforderungen ändern, möchten Sie die BizTalk Server-Gruppen möglicherweise umstrukturieren, um die Leistung Ihren aktuellen Bedürfnissen entsprechend zu optimieren. In diesem Fall müssen möglicherweise neue Server zu einer Gruppe hinzugefügt, Server von einer Gruppe zu einer anderen verschoben oder die Servereinstellungen angepasst werden, die beim Installieren von BizTalk Server konfiguriert wurden. Es kann z. B. sein, dass Dokumente schneller verarbeitet werden müssen oder dass Sie einen Server in einer Gruppe so konfigurieren müssen, dass er nur Austauschvorgänge und Dokumente empfängt.

Es wird dringend empfohlen, das Thema BizTalk-Server im Abschnitt Informationen zur BizTalk Server-Verwaltung zu lesen, um BizTalk-Server vollständig zu verstehen.

In diesem Abschnitt werden folgende Verfahren behandelt:

  • Hinzufügen eines Servers zu einer Gruppe

  • Löschen eines Servers aus einer Gruppe

  • Konfigurieren eines Servers in einer Gruppe

  • Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

Anmerkung

  • Es empfiehlt sich, beim Anpassen von Servereigenschaften in einer Testumgebung mit verschiedenen Kombinationen zu experimentieren, bevor Sie die Servereigenschaften der BizTalk-Produktionsserver ändern.


Hinzufügen eines Servers zu einer Gruppe

Diese Aufgabe ermöglicht es Ihnen, einen BizTalk-Server zu einer bereits konfigurierten BizTalk Server-Gruppe hinzuzufügen. Jeder Gruppe können unterschiedlich viele Server zugeordnet sein. Daher können Sie den Durchsatz maximieren, indem Sie die Anzahl der Server in einer Gruppe entsprechend der Verarbeitungsleistung der Server optimieren, auf denen die Datenbanken gespeichert sind.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und klicken Sie auf die Servergruppe, zu der Sie einen Server hinzufügen möchten.

  2. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie auf Server.

    Das Dialogfeld BizTalk-Server hinzufügen wird angezeigt.

  3. Geben Sie im Feld Name des BizTalk-Servers den Namen eines vorhandenen Servers ein, auf dem sich eine vollständige Installation von BizTalk Server 2002 befindet.

  4. Klicken Sie auf OK.

Wichtig

  • Auf allen Servern in einer Gruppe muss dieselbe Version und Sprache von BizTalk Server installiert sein. Wenn Server mit unterschiedlichen Versionen von BizTalk Server (BizTalk Server 2000, BizTalk Server 2000 Service Pack 1, BizTalk Server 2002 Enterprise Edition oder eine andere Sprachversion von BizTalk Server) in einer Gruppe installiert sind, funktionieren die Datenbanken nicht ordnungsgemäß.

Anmerkungen

  • Klicken Sie mit der rechten Maustaste auf die Gruppe, und klicken Sie auf Eigenschaften, um die globalen Eigenschaften für die Servergruppe anzuzeigen, zu der Sie den Server hinzugefügt haben.

  • Auf dem hinzuzufügenden Server muss die gleiche Version von BizTalk Server installiert sein wie in der Gruppe. Sonst kann er nicht zur Gruppe hinzugefügt werden.

Verwandte Themen

Gruppen und Server

Verwalten von Servern in einer Gruppe

Grundlegendes zu Servereigenschaften


Löschen eines Servers aus einer Gruppe

Wenn sich Ihre Geschäftsanforderungen ändern, möchten Sie die BizTalk Server-Gruppen möglicherweise umstrukturieren, um die Leistung Ihren aktuellen Bedürfnissen entsprechend zu optimieren. In diesem Fall müssen möglicherweise Server aus einer Servergruppe gelöscht werden, damit die Server in dieser Gruppe in andere Bereiche des Produktionssystems verschoben werden können, die mehr Ressourcen benötigen.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe des Servers, den Sie löschen möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

    Der Server beendet die Verarbeitung aller aktuellen Austauschvorgänge und Dokumente.

  3. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  4. Klicken Sie auf Ja.

Anmerkung

  • Ein Server kann nicht aus einer Servergruppe gelöscht werden, wenn mindestens eine Empfangsfunktion zur Verarbeitung von Dokumenten auf ihn verweist. Sie können die Empfangsfunktion(en) dahingehend ändern, dass sie auf andere Server verweisen, oder Sie können die Empfangsfunktion(en) löschen, falls sie nicht mehr verwendbar sind.

Verwandte Themen

Freigeben von Austauschvorgängen auf einem Server

Gruppen und Server

Verwalten von Empfangsfunktionen für eine Servergruppe

Verwalten von Servern in einer Gruppe


Konfigurieren eines Servers in einer Gruppe

Mit diesem Verfahren können Sie die allgemeinen Eigenschaften eines bestimmten Servers konfigurieren. Durch Erstellen von Empfangsfunktionen in Servern, die nicht an der Arbeitsobjektverwaltung teilnehmen, wird der Durchsatz von BizTalk Server verbessert.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe des Servers, den Sie konfigurieren möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

    Serverkonfigurationseinstellungen können nicht geändert werden, während der Server ausgeführt wird.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von <Name des Computers> wird angezeigt.

  4. Geben Sie im Feld Maximale Anzahl von Empfangsfunktionsthreads eine Zahl zwischen 1 und 128 ein.

    Der Standardwert ist 4. Weitere Informationen zum Konfigurieren dieser Option finden Sie unter Grundlegendes zu Servereigenschaften.

  5. Falls der Server Objekte in der Arbeitswarteschlange verarbeiten soll, aktivieren Sie das Kontrollkästchen An Arbeitsobjektverwaltung teilnehmen.

    Wenn dieses Kontrollkästchen aktiviert ist, verarbeitet der Server Dokumente in der Arbeitswarteschlange. Deaktivieren Sie dieses Kontrollkästchen, wenn der Server keine Dokumente in der Arbeitswarteschlange verarbeiten soll. Weitere Informationen zum Konfigurieren dieser Option finden Sie unter Grundlegendes zu Servereigenschaften.

  6. Geben Sie im Feld Maximale Anzahl von Arbeitsthreads pro Prozessor eine Zahl zwischen 1 und 128 ein.

    Der Standardwert ist 4. Weitere Informationen zum Konfigurieren dieser Option finden Sie unter Grundlegendes zu Servereigenschaften.

  7. Geben Sie im Feld Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung (ms) eine Zahl zwischen 1 und 4294967295 ein.

    Der Standardwert ist 2000. Weitere Informationen zum Konfigurieren dieser Option finden Sie unter Grundlegendes zu Servereigenschaften.

  8. Klicken Sie auf OK.

  9. Klicken Sie mit der rechten Maustaste auf den Server, den Sie konfiguriert haben, und klicken Sie dann auf Starten.

Anmerkung

  • Wenn das Kontrollkästchen An Arbeitsobjektverwaltung teilnehmen deaktiviert ist, sind auch die Felder Maximale Anzahl von Arbeitsthreads pro Prozessor und Zeitraum zwischen Aufrufen der BizTalk Server-Ablaufplanung (ms) nicht verfügbar.

Verwandte Themen

Gruppen und Server

Verwalten von Servern in einer Gruppe

Grundlegendes zu Servereigenschaften


Ändern der BizTalk-Messaging-Verwaltungsdatenbank für einen Server

Änderungen an der BizTalk Messaging-Verwaltungsdatenbank eines Servers sind normalerweise nur nötig, wenn eine dauerhafte Änderung an einer anderen Datenbank vorgenommen werden muss, z. B. bei einer Wiederherstellung oder beim Ersetzen des vorhandenen Datenbankservers durch einen anderen Datenbankserver.

Wichtig

  • Verwenden Sie dieses Verfahren, um einen Server einer anderen BizTalk-Messaging-Verwaltungsdatenbank zuzuordnen. Weitere Informationen zum Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken finden Sie unter Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken. Weitere Informationen zum Ändern der BizTalk-Messaging-Verwaltungsdatenbank für Servergruppen finden Sie unter Ändern der BizTalk-Messaging-Verwaltungsdatenbank.
  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, die Servergruppe des Servers, für den Sie die BizTalk-Messaging-Verwaltungsdatenbank ändern möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

  3. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  4. Klicken Sie auf Ja.

  5. Schließen Sie die BizTalk Server-Verwaltung.

  6. Zeigen Sie im Menü Start auf Programme, dann auf Zubehör, und klicken Sie auf Windows-Explorer.

  7. Suchen Sie den Ordner \Programme\Microsoft BizTalk Server\Setup.

  8. Klicken Sie auf BTSsetupDB.exe.

  9. Klicken Sie im Menü Datei auf Öffnen.

    Der Microsoft BizTalk Server 2002-Datenbankeinrichtungs-Assistent wird geöffnet.

  10. Klicken Sie auf der Seite Willkommen beim Einrichtungs-Assistenten für BizTalk Server 2002-Messagingdatenbanken auf Weiter.

  11. Klicken Sie auf der Seite BizTalk-Messaging-Verwaltungsdatenbank konfigurieren auf Neue BizTalk-Messaging-Verwaltungsdatenbank erstellen.

    Oder

    Klicken Sie auf Vorhandene Datenbank auswählen.

  12. Klicken Sie im Feld Servername auf den Namen des Servers, auf dem die neue BizTalk-Messaging-Verwaltungsdatenbank gespeichert werden soll bzw. auf dem sich die vorhandene Verwaltungsdatenbank befindet.

  13. Geben Sie im Feld Datenbank den Namen der neuen oder vorhandenen BizTalk-Messaging-Verwaltungsdatenbank ein.

  14. Klicken Sie auf Weiter.

  15. Klicken Sie auf der Seite BizTalk Server-Gruppe konfigurieren auf Neue BizTalk Server-Gruppe erstellen.

    Geben Sie im Feld Gruppenname den Namen der neuen Gruppe ein, und klicken Sie auf Weiter.

    Oder

    Klicken Sie auf Vorhandene BizTalk Server-Gruppe auswählen. Klicken Sie in der Liste Gruppenname auf den Namen der vorhandenen Gruppe, und klicken Sie auf Weiter.

    Sie können nur dann eine vorhandene BizTalk Server-Gruppe auswählen, wenn Sie in Schritt 11 eine vorhandene Datenbank ausgewählt haben.

  16. Klicken Sie gegebenenfalls auf Neue Überwachungsdatenbank erstellen, und klicken Sie dann auf Weiter.

    Oder

    Klicken Sie auf Vorhandene Datenbank auswählen. Klicken Sie in der Liste Servername auf einen Server, und klicken Sie auf Weiter.

    Klicken Sie gegebenenfalls auf Neue Datenbank für gemeinsam genutzte Warteschlangen erstellen, und klicken Sie auf Weiter.

    Oder

    Klicken Sie auf Vorhandene Datenbank auswählen. Klicken Sie in der Liste Servername auf einen Server, und klicken Sie auf Weiter.

  17. Überprüfen Sie auf der Seite BizTalk Server-Gruppe überprüfen die eingegebenen Informationen, und klicken Sie auf Weiter. Klicken Sie auf der Seite Der Einrichtungs-Assistent für BizTalk Server 2002-Messagingdatenbanken wird abgeschlossen auf Fertig stellen. Öffnen Sie die BizTalk Server-Verwaltung. Erweitern Sie Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe des Servers, für den Sie soeben die BizTalk-Messaging-Verwaltungsdatenbank geändert haben, und klicken Sie dann auf den Server.

  18. Klicken Sie im Menü Vorgang auf Starten.

    Verwandte Themen

    Ändern der BizTalk-Messaging-Verwaltungsdatenbank

    Verwalten von BizTalk Server-Datenbanken

    Verschieben von Servern zwischen BizTalk-Messaging-Verwaltungsdatenbanken


Verwalten von Servern in einer Gruppe

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Verwalten von Servern in einer BizTalk Server-Gruppe bereit. Es wird dringend empfohlen, das Thema BizTalk-Server im Abschnitt Informationen zur BizTalk Server-Verwaltung zu lesen, um BizTalk-Server vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Starten eines Servers in einer Gruppe

  • Beenden eines Servers in einer Gruppe

  • Freigeben von Austauschvorgängen auf einem Server

  • Konfigurieren der Datenträgerzwischenspeicherung


Starten eines Servers in einer Gruppe

Führen Sie dieses Verfahren zum Starten der BizTalk Server-Laufzeitdienste auf dem zugeordneten Server aus, damit er am Empfangen und/oder Verarbeiten von Austauschvorgängen teilnehmen kann.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe des Servers, den Sie starten möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Starten.

Anmerkungen

  • Das Starten eines Servers in einer Servergruppe bewirkt, dass der BizTalk-Messagingdienst auf diesem Server gestartet wird. Wenn der BizTalk-Messagingdienst ausgeführt wird, kann der Server Dokumente, die sich in der Warteschlange für Microsoft SQL Server-Datenbanken befinden, empfangen, übertragen, verarbeiten und überwachen.

  • Die Option Starten steht nur zur Verfügung, wenn der Server beendet wurde. Während der Server ausgeführt wird, ist der Befehl nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Verwaltungscache

Gruppen und Server

Beenden eines Servers in einer Gruppe


Beenden eines Servers in einer Gruppe

Führen Sie dieses Verfahren zum Beenden der BizTalk Server-Laufzeitdienste auf dem zugeordneten Server aus, damit er nicht mehr am Empfangen und/oder Verarbeiten von Austauschvorgängen teilnimmt.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe des Servers, den Sie beenden möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

Anmerkungen

  • Das Beenden eines Servers in einer Servergruppe bewirkt, dass der BizTalk-Messagingdienst auf diesem Server beendet wird. Nachdem der BizTalk-Messagingdienst beendet wurde, kann der Server Dokumente, die sich in der Warteschlange für Microsoft SQL Server-Datenbanken befinden, nicht mehr empfangen, übertragen, verarbeiten und überwachen.

  • Informationen zum Weitergeben von Austauschvorgängen, die einem beendeten Server zugeordnet sind, finden Sie unter Freigeben von Austauschvorgängen auf einem Server.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Verwaltungscache

Freigeben von Austauschvorgängen auf einem Server

Gruppen und Server


Freigeben von Austauschvorgängen auf einem Server

Dieses Verfahren wird verwendet, um Austauschvorgänge auf einem Server freizugeben, damit die Austauschvorgänge an andere Server in der Gruppe weitergegeben werden können, wenn der ursprüngliche Server beendet oder in den Offlinemodus versetzt wurde.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe des Servers, auf dem Sie Austauschvorgänge freigeben möchten, und klicken Sie dann auf den Server.

  2. Klicken Sie im Menü Vorgang auf Beenden.

  3. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie auf Austauschvorgänge freigeben.

  4. Klicken Sie im Menü Vorgang auf Starten.

Anmerkung

  • Diese Aufgabe kann nicht ausgeführt werden, wenn der Serverstatus Wird ausgeführt oder Zugriff verweigert ist.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Gruppen und Server

Beenden eines Servers in einer Gruppe


Konfigurieren der Datenträgerzwischenspeicherung

Führen Sie dieses Verfahren aus, um die Datenträgerzwischenspeicherung zu aktivieren oder zu deaktivieren. Wenn die Datenträgerzwischenspeicherung deaktiviert ist, wird der Datenverlust bei schwerwiegenden Fehlern, z. B. einem Stromausfall, vermieden. Allerdings wird dabei auch die Leistung von BizTalk Server beeinträchtigt.

  1. Zeigen Sie im Menü Start auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

  2. Erweitern Sie in der Konsolenstruktur der Computerverwaltung Geräte-Manager.

  3. Doppelklicken Sie auf der rechten Seite auf Datenträger.

  4. Klicken Sie mit der rechten Maustaste auf das Laufwerk, das Sie für Datenträgerzwischenspeicherung konfigurieren möchten, und klicken Sie anschließend auf Eigenschaften.

    Das Fenster Eigenschaften von <Datenträger> wird angezeigt.

  5. Klicken Sie auf die Registerkarte Datenträgereigenschaften.

  6. Deaktivieren Sie das Kontrollkästchen Schreibcache aktiviert.

Anmerkung

  • Bei dieser Prozedur handelt es sich um eine Änderung der Eigenschaften des Datenträgercaches, die für den gesamten Computer gilt.

Verwandte Themen

Hinzufügen, Löschen und Konfigurieren von Servern in einer Gruppe

Gruppen und Server

Beenden eines Servers in einer Gruppe


Verwalten von Warteschlangen

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Verwalten von Warteschlangen in einer BizTalk Server bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Verwenden von Warteschlangen lesen, um BizTalk Server-Warteschlangen vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Verschieben von Dokumenten in die Angehalten-Warteschlange

  • Anzeigen von Fehlerbeschreibungen

  • Anzeigen von Austauschvorgängen

  • Anzeigen von Dokumenten

  • Erneutes Senden von Dokumenten

  • Löschen von Dokumenten


Verschieben von Dokumenten in die Angehalten-Warteschlange

Ein beliebiges Element in der V erarbeitungs-, Geplant- oder Wiederholungswarteschlange kann zur Angehalten-Warteschlange verschoben werden. Verschieben Sie Austauschvorgänge und Dokumente nur dann in die Angehalten-Warteschlange, wenn sie nicht verarbeitet werden sollen. Nachdem Sie einen Austauschvorgang oder ein Dokument in die Angehalten-Warteschlange verschoben haben, können Sie den Austauschvorgang bzw. das Dokument löschen, erneut senden oder erneut an die Arbeitswarteschlange übertragen, um die Verarbeitung abzuschließen.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie dann die Gruppe mit dem Dokument, das Sie verschieben möchten, und erweitern Sie anschließend Warteschlangen.

  2. Erweitern Sie die Warteschlange, die das zu verschiebende Dokument enthält, und klicken Sie auf das Dokument.

  3. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie auf In Angehalten-Warteschlange verschieben.

Verwandte Themen

Angehalten-Warteschlange

Verwenden von Warteschlangen


Anzeigen von Fehlerbeschreibungen

Mit diesem Verfahren können Sie herausfinden, welcher Fehler dazu führte, dass ein Dokument in der Angehalten-Warteschlange abgelegt wurde.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und erweitern Sie die Gruppe, die das Dokument enthält, das Sie anzeigen möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailfensterbereich auf das Dokument, das angezeigt werden soll.

  3. Klicken Sie im Menü Vorgang auf Fehlerbeschreibung anzeigen.

Verwandte Themen

Angehalten-Warteschlange

Verwenden von Warteschlangen

Anzeigen von Dokumenten

Anzeigen von Austauschvorgängen


Anzeigen von Austauschvorgängen

Mit dieser Aufgabe können Sie ein separates Fenster öffnen, um den Inhalt eines Austauschvorgangs anzuzeigen, der aufgrund von Analyse- oder Übertragungsfehlern in der Angehalten-Warteschlange abgelegt wurde. Diese Aufgabe ist ungültig für Ausgangsvorgänge, die aufgrund von Vertragsproblemen fehlschlugen.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und erweitern Sie die Gruppe, die den Austausch enthält, den Sie anzeigen möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailfensterbereich auf den Austausch, der angezeigt werden soll.

  3. Klicken Sie im Menü Vorgang auf Austausch anzeigen.

    Das Dialogfeld Dokumentinhalt wird angezeigt.

Anmerkungen

  • Wenn Sie einen sehr umfangreichen Austausch anzeigen, werden eventuell Daten abgeschnitten. Im Dialogfeld Dokumentinhalt können bis zu 4 MB Daten angezeigt werden.

  • Falls BizTalk Server den Austausch nicht analysieren konnte, werden im Dialogfeld Dokumentinhalt unter Umständen Binärdaten angezeigt. Weitere Informationen zu Parserfehlern finden Sie unter Analysefehler.

  • Die Menüoption Austausch anzeigen ist bei folgenden Zuständen der Angehalten-Warteschlange verfügbar:
    • Benutzerdefinierte Komponente

    • Analysiert

    • Codierung

    • Signiert

    • Verschlüsselt

    • Überträgt
  • Die Optionen Austausch anzeigen und Dokument anzeigen werden im Menü Vorgang niemals gleichzeitig angezeigt.

  • Die Option Austausch anzeigen ist in einer Toolsinstallation von BizTalk Server nicht verfügbar.

Verwandte Themen

Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Angehalten-Warteschlange

Verwenden von Warteschlangen

Anzeigen von Dokumenten

Anzeigen von Fehlerbeschreibungen


Anzeigen von Dokumenten

Mit dieser Aufgabe können Sie ein separates Fenster öffnen, um den Inhalt eines Dokuments anzuzeigen, das aufgrund eines Problems mit einem Handelspartnervertrag in der Angehalten-Warteschlange abgelegt wurde. Diese Aufgabe ist ungültig für Dokumente, die aufgrund von Analyse- oder Übertragungsfehlern fehlschlugen.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und erweitern Sie die Gruppe, die das Dokument enthält, das Sie anzeigen möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailfensterbereich auf das Dokument, das angezeigt werden soll.

  3. Klicken Sie im Menü Vorgang auf Dokument anzeigen.

    Das Dialogfeld Dokumentinhalt wird angezeigt.

Anmerkungen

  • Wenn Sie ein sehr umfangreiches Dokument anzeigen, werden eventuell Daten abgeschnitten. Im Dialogfeld Dokumentinhalt können bis zu 4 MB Daten angezeigt werden.

  • Die Menüoption Dokument anzeigen ist bei folgenden Statuswerten der Angehalten-Warteschlange verfügbar:
    • Dokumentüberprüfung

    • Kanalauswahl

    • Zuordnung

    • Korreliert

    • Serialisiert
  • Die Optionen Dokument anzeigen und Austausch anzeigen werden im Menü Vorgang niemals gleichzeitig angezeigt.

  • Die Option Dokument anzeigen ist in einer Toolsinstallation von BizTalk Server nicht verfügbar.

Verwandte Themen

Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Angehalten-Warteschlange

Verwenden von Warteschlangen

Anzeigen von Fehlerbeschreibungen

Anzeigen von Austauschvorgängen


Erneutes Senden von Dokumenten

Mit diesem Verfahren können Sie ein Dokument, das in der Angehalten-Warteschlange abgelegt wurde, wieder an die Arbeitswarteschlange senden. Dies erfolgt normalerweise, nachdem die Ursache des Übertragungsfehlers behoben wurde.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und erweitern Sie die Gruppe, die das Dokument enthält, das Sie erneut senden möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailfensterbereich auf das Dokument, das erneut gesendet werden soll.

  3. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie auf Erneut senden.

Anmerkungen

  • Dieses Verfahren kann auch zum erneuten Übertragen von Dokumenten verwendet werden.

  • Nicht alle Dokumente in der Angehalten-Warteschlange können erneut gesendet werden. In einigen Situationen müssen Sie das Dokument löschen und es von der ursprünglichen Anwendung bzw. der Organisation aus erneut senden. Weitere Informationen zu Dokumenten in der Angehalten-Warteschlange finden Sie unter Angehalten-Warteschlange.

Verwandte Themen

Angehalten-Warteschlange

Verwenden von Warteschlangen


Löschen von Dokumenten

Mit diesem Verfahren können Sie ein Dokument aus der Angehalten-Warteschlange löschen. Dies erfolgt normalerweise, wenn die Nachricht nicht mehr benötigt wird oder Sie die Nachricht bereits gespeichert haben.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und erweitern Sie die Gruppe, die das Dokument enthält, das Sie löschen möchten. Erweitern Sie Warteschlangen, und klicken Sie dann auf Angehalten-Warteschlange.

  2. Klicken Sie im Detailfensterbereich auf das Dokument, das gelöscht werden soll.

  3. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  4. Klicken Sie auf Ja.

Verwandte Themen

Angehalten-Warteschlange

Verwenden von Warteschlangen


Verwalten von Datenbanken für eine Servergruppe

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Verwalten von Datenbanken für eine BizTalk Server-Gruppe bereit. Es wird dringend empfohlen, das Thema Verwalten von BizTalk Server-Gruppendatenbanken zu lesen, um BizTalk Server-Datenbanken vollständig zu verstehen.

In diesem Abschnitt werden folgende Verfahren behandelt:

  • Herunterfahren der BizTalk Server-Austauschanwendung

  • Entfernen der Überwachungsdatenbank und der Datenbanken für gemeinsam genutzte Warteschlangen

  • Manuelles Wiederherstellen der Überwachungsdatenbank

  • Manuelles Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen


Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application)

BizTalk Server 2002 ~ Verwaltung

Herunterfahren der BizTalk Server-Austauschanwendung (BizTalk Server Interchange Application

Die BizTalk Server-Austauschanwendung fungiert als Host für die Rollen, mit denen festgelegt wird, welche Benutzer Austauschvorgänge und Dokumente an BizTalk Server senden können. Diese Anwendung muss jedes Mal heruntergefahren werden, wenn die Verbindung zur BizTalk-Messaging-Verwaltungsdatenbank, Überwachungsdatenbank oder Datenbank für gemeinsam genutzte Warteschlangen geändert wird.

  1. Zeigen Sie im Menü Start auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste, erweitern Sie Computer, dann Arbeitsplatz und anschließend COM+-Anwendungen.

  3. Klicken Sie auf BizTalk Server Interchange Application.

  4. Klicken Sie im Menü Vorgang auf Herunterfahren.

Anmerkung

  • Sie können die BizTalk Server-Austauschanwendung (Interchange Application) auch von einem Remoteserver aus herunterfahren. Erweitern Sie in diesem Fall in Schritt 2 <remotecomputername> anstelle von Arbeitsplatz.

Verwandte Themen

Verwaltungscache

Konfigurieren von Verbindungseigenschaften für eine Servergruppe

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Gruppen und Server

Öffnen der Komponentendienste

Überwachungsdatenbank


Entfernen der Überwachungsdatenbank und der Datenbanken für gemeinsam genutzte Warteschlangen

Die Überwachungsdatenbank und die Datenbank für gemeinsam genutzte Warteschlangen werden normalerweise erst entfernt, wenn die BizTalk Server-Gruppen für die Verwendung einer anderen Überwachungsdatenbank und/oder Datenbank für gemeinsam genutzte Warteschlangen konfiguriert wurden. Wenn Sie die Überwachungsdatenbank und/oder Datenbank für gemeinsam genutzte Warteschlangen entfernen, bevor Sie die BizTalk Server-Gruppen für die Verwendung einer anderen Datenbank konfigurieren, kann BizTalk Server nicht ordnungsgemäß ausgeführt werden.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Servers, erweitern Sie SQL Server-Gruppe und dann den jeweiligen Server mit den Datenbanken, die gelöscht werden sollen.

  3. Erweitern Sie den Ordner Datenbanken, und klicken Sie auf die Datenbank, die Sie löschen möchten.

  4. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Datenbank löschen wird angezeigt.

  5. Deaktivieren Sie das Kontrollkästchen Sicherungs- und Wiederherstellungsverlauf für die Datenbank löschen, um den Sicherungs- und Wiederherstellungsverlauf für die Datenbank zu löschen.

  6. Klicken Sie auf Ja.

Anmerkung

  • Der Standardname für die Überwachungsdatenbank lautet InterchangeDTA. Der Standardname für die Datenbank für gemeinsam genutzte Warteschlangen lautet InterchangeSQ.

Verwandte Themen

Gruppen und Server

Datenbank für gemeinsam genutzte Warteschlangen

Beenden eines Servers in einer Gruppe

Überwachungsdatenbank


Manuelles Wiederherstellen der Überwachungsdatenbank

Verwenden Sie dieses Verfahren, wenn die Überwachungsdatenbank fehlerhaft oder beschädigt ist. Bei diesem Verfahren wird vorausgesetzt, dass zuvor eine Sicherung erstellt wurde.

Vorsicht

  • Beim manuellen Wiederherstellen der Überwachungsdatenbank gehen alle Daten verloren. Wenn Sie die Daten noch benötigen, sichern Sie sie vor dem Wiederherstellen der Überwachungsdatenbank.
  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Servers, erweitern Sie SQL Server-Gruppe und dann den Server, auf dem Sie die Datenbank wiederherstellen möchten.

  3. Klicken Sie auf Datenbanken.

  4. Klicken Sie im Menü Vorgang auf Neue Datenbank.

    Das Dialogfeld Datenbankeigenschaften wird angezeigt.

  5. Geben Sie auf der Registerkarte Allgemein im Feld Name einen Namen für die Überwachungsdatenbank ein, und klicken Sie auf OK.

  6. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Query Analyzer.

    Das Dialogfeld Verbindung mit SQL Server herstellen wird angezeigt.

  7. Wählen Sie im Feld SQL Server den Server aus, auf dem die Datenbank wiederhergestellt werden soll.

  8. Klicken Sie im Bereich Folgendes zur Verbindung verwenden auf die Option, die der Authentifizierungsmethode entspricht, die zum Herstellen einer Verbindung mit SQL Server verwendet werden soll.

  9. Klicken Sie auf OK.

  10. Falls Sie Microsoft SQL Server 7.0 verwenden, klicken Sie im Fenster Abfrage in der Liste DB auf den Namen der neuen Überwachungsdatenbank. Weiter mit Schritt 14.

    Oder

    Falls Sie Microsoft SQL Server 2000 verwenden, klicken Sie im Fenster Objektkatalog auf den Namen der neuen Überwachungsdatenbank.

  11. Klicken Sie im Menü Abfrage auf Datenbank ändern.

  12. Klicken Sie im Fenster Datenbank von <Servername> auswählen auf den Namen der neuen Überwachungsdatenbank.

  13. Klicken Sie auf OK.

  14. Klicken Sie auf die Schaltfläche SQL-Skript laden SQL-Skript laden .

  15. Suchen Sie den Ordner \Programme\Microsoft BizTalk Server\Setup.

  16. Klicken Sie auf BTS_Tracking_Schema.sql und dann auf Öffnen.

  17. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  18. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  19. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  20. Klicken Sie auf BTS_Reporting.sql und dann auf Öffnen.

  21. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  22. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  23. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  24. Klicken Sie auf BTS_Tracking_Logic.sql und dann auf Öffnen.

  25. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  26. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  27. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  28. Klicken Sie auf BTS_WorkflowEvents_Logic.sql und dann auf Öffnen.

  29. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  30. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  31. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  32. Klicken Sie auf BTS_WorkflowEvents_Schema.sql und dann auf Öffnen.

  33. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  34. Schließen Sie SQL Query Analyzer und SQL Server Enterprise Manager.

Verwandtes Thema

Manuelles Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen


Manuelles Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen

Verwenden Sie dieses Verfahren, wenn die Datenbank für gemeinsam genutzte Dateien fehlerhaft oder beschädigt ist. Bei diesem Verfahren wird vorausgesetzt, dass zuvor eine Sicherung erstellt wurde.

Vorsicht

  • Beim manuellen Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen gehen alle Daten verloren. Wenn Sie diese Daten noch benötigen, sichern Sie die Daten vor dem Wiederherstellen der Datenbank für gemeinsam genutzte Warteschlangen.
  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Servers, erweitern Sie SQL Server-Gruppe und dann den Server, auf dem Sie die Datenbank wiederherstellen möchten.

  3. Klicken Sie auf Datenbanken.

  4. Klicken Sie im Menü Vorgang auf Neue Datenbank.

    Das Dialogfeld Datenbankeigenschaften wird angezeigt.

  5. Geben Sie auf der Registerkarte Allgemein im Feld Name einen Namen für die Datenbank für gemeinsam genutzte Warteschlangen ein, und klicken Sie auf OK.

  6. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Query Analyzer.

    Das Dialogfeld Verbindung mit SQL Server herstellen wird angezeigt.

  7. Wählen Sie im Feld SQL Server den Server aus, auf dem die Datenbank wiederhergestellt werden soll.

  8. Klicken Sie im Bereich Folgendes zur Verbindung verwenden auf die Option, die der Authentifizierungsmethode entspricht, die zum Herstellen einer Verbindung mit SQL Server verwendet werden soll.

  9. Klicken Sie auf OK.

  10. Falls Sie Microsoft SQL Server 7.0 verwenden, klicken Sie im Fenster Abfrage in der Liste DB auf den Namen der neuen Datenbank für gemeinsam genutzte Warteschlangen. Weiter mit Schritt 14.

    Oder

    Falls Sie Microsoft SQL Server 2000 verwenden, klicken Sie im Fenster Objektkatalog Namen der neuen Datenbank für gemeinsam genutzte Warteschlangen.

  11. Klicken Sie im Menü Abfrage auf Datenbank ändern.

  12. Klicken Sie im Fenster Datenbank von <Servername> auswählen auf den Namen der neuen Datenbank für gemeinsam genutzte Warteschlangen.

  13. Klicken Sie auf OK.

  14. Klicken Sie auf die Schaltfläche SQL-Skript laden SQL-Skript laden .

  15. Suchen Sie den Ordner \Programme\Microsoft BizTalk Server\Setup.

  16. Klicken Sie auf BTS_Core_Schema.sql und dann auf Öffnen.

  17. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  18. Klicken Sie auf die Schaltfläche SQL-Skript laden.

  19. Überprüfen Sie, ob Sie sich im Ordner \Programme\Microsoft BizTalk Server\Setup befinden.

  20. Klicken Sie auf BTS_Core_Logic.sql und dann auf Öffnen.

  21. Klicken Sie auf die Schaltfläche Abfrage ausführen.

  22. Schließen Sie SQL Query Analyzer und SQL Server Enterprise Manager.

Verwandtes Thema

Manuelles Wiederherstellen der Überwachungsdatenbank


Verwalten von Empfangsfunktionen für eine Servergruppe

Empfangsfunktionen sind Funktionen, die in einer BizTalk Server-Gruppe eingerichtet wurden, um eingehende Austauschvorgänge mit einem bestimmten Protokoll zu verarbeiten. Diese Funktionen rufen letztendlich die Receive-Methoden des eingehenden Routerobjekts auf.

In diesem Abschnitt werden folgende Verfahren behandelt:

  • Hinzufügen einer Dateiempfangsfunktion

  • Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"

  • Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

  • Hinzufügen einer Message Queuing-Empfangsfunktion

  • Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"

  • Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"

  • Hinzufügen einer HTTP-Empfangsfunktion

  • Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Allgemein"

  • Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Dienste"

  • Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

  • Konfigurieren von Zugriffsrechten basierend auf der IIS-Schutzebene

  • Löschen einer Empfangsfunktion

Anmerkung

  • Wenn Sie eine Empfangsfunktion replizieren, die für die Verwendung eines Benutzernamens und Kennwortes konfiguriert wurde, wird die Empfangsfunktion aufgrund eines ungültigen Kennwortes deaktiviert. Um dieses Problem zu lösen, müssen Sie die Eigenschaftenseite jeder Empfangsfunktion öffnen, das Kennwort erneut eingeben und dann die Empfangsfunktion aktivieren.


Hinzufügen einer Dateiempfangsfunktion

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und erweitern Sie dann die Servergruppe, zu der Sie die Dateiempfangsfunktion hinzufügen möchten.

  2. Klicken Sie auf Empfangsfunktionen.

  3. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie dann auf Dateiempfangsfunktion.

    Das Dialogfeld Dateiempfangsfunktion hinzufügen wird angezeigt.

  4. Geben Sie im Feld Name den Namen der Empfangsfunktion ein.

  5. Fügen Sie im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  6. Klicken Sie in der Liste Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen eines Servers in der Gruppe.

  7. Geben Sie im Feld Abzurufende Dateitypen die Erweiterungen der Dateien ein, die BizTalk Server empfängt.

    Die Dateierweiterung muss gemäß folgender Syntax eingegeben werden:

    *.ext

    Beispiel: *.xml

  8. Geben Sie im Feld Abrufspeicherort entweder den logischen Pfad oder den UNC-Pfad (Universal Naming Convention) zu dem Verzeichnis ein, den diese Dateiempfangsfunktion als Speicherort für den Dateiempfang verwenden soll.

  9. Klicken Sie in der Liste Präprozessor auf den Namen des benutzerdefinierten Präprozessors.

    Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie das Feld leer.

  10. Falls erforderlich, geben Sie in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für die Verbindung zum Speicherort für den Dateiempfang ein.

    Dies ist nur dann erforderlich, wenn der Empfangsspeicherort geschützt ist und für die Verbindung zum Server ein gültiger Benutzername und ein gültiges Kennwort benötigt wird.

  11. Klicken Sie auf die Schaltfläche Erweitert, um die Empfangsfunktion für Dokumente anzupassen, die kein automatisches Routing unterstützen, oder um Optionen für Offenheitsgrad oder Pass-Through anzugeben.

    Weitere Informationen zu erweiterten Optionen finden Sie unter Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen.

Anmerkungen

  • Mit diesem Verfahren wird eine Dateiempfangsfunktion mit den Standardeinstellungen erstellt. Hinweise zum Konfigurieren der Dateiempfangsfunktion mit zusätzlichen Einstellungen finden Sie unter Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein".

  • Wenn mehrere verschiedene Dateitypen abrufbar sein sollen, verwenden Sie eines der üblichen Platzhalterformate.

    Beispiel: *.* oder *.x?l

  • Wenn Sie mehrere Dateiempfangsfunktionen zum Überwachen desselben Verzeichnisses konfigurieren, verwenden Sie Dateierweiterungen mit drei Buchstaben. Falls Sie Dateierweiterungen mit mehr als drei Buchstaben verwenden, stellen Sie sicher, dass die ersten drei Buchstaben eindeutig sind.

    Beispiel: *.xml, *.1xml, *.12xml

  • Dateiempfangsfunktionen können keine schreibgeschützten Dateien verarbeiten.

  • Stellen Sie sicher, dass jede Empfangsfunktion, die Sie erstellen, einen eindeutigen Namen hat. Empfangsfunktionen können keine identischen Namen zugewiesen werden.

  • Wenn Sie eine Empfangsfunktion replizieren, die für die Verwendung eines Benutzernamens und Kennwortes konfiguriert wurde, wird die Empfangsfunktion aufgrund eines ungültigen Kennwortes deaktiviert. Um dieses Problem zu lösen, müssen Sie die Eigenschaftenseite jeder Empfangsfunktion öffnen, das Kennwort erneut eingeben und dann die Empfangsfunktion aktivieren.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

Benutzerdefinierte Präprozessoren

Empfangsfunktionen


Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Allgemein"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe, für die Sie eine Dateiempfangsfunktion konfigurieren möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Dateiempfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  4. Fügen Sie im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  5. Geben Sie im Bereich Sicherheit in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für die Verbindung zu dieser Empfangsfunktion ein.

    Dies ist nur dann erforderlich, wenn der Empfangsspeicherort geschützt ist und für die Verbindung zum Server ein gültiger Benutzername und ein gültiges Kennwort benötigt wird.

  6. Wenn Sie die Funktionalität dieser Empfangsfunktion nicht deaktivieren möchten, aktivieren Sie das Kontrollkästchen Empfangsfunktion deaktivieren, und klicken Sie auf Ja, um Ihre Auswahl zu bestätigen.

Anmerkungen

  • Dateiempfangsfunktionen können keine schreibgeschützten Dateien verarbeiten.

  • Wenn Sie eine Empfangsfunktion replizieren, die für die Verwendung eines Benutzernamens und Kennwortes konfiguriert wurde, wird die Empfangsfunktion aufgrund eines ungültigen Kennwortes deaktiviert. Um dieses Problem zu lösen, müssen Sie die Eigenschaftenseite jeder Empfangsfunktion öffnen, das Kennwort erneut eingeben und dann die Empfangsfunktion aktivieren.

Verwandte Themen

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"


Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe, für die Sie eine Dateiempfangsfunktion konfigurieren möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Dateiempfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  4. Klicken Sie auf die Registerkarte Dienste.

  5. Klicken Sie in der Liste Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen des Servers.

  6. Geben Sie im Feld Abrufspeicherort entweder den logischen Pfad oder den UNC-Pfad (Universal Naming Convention) zu dem Verzeichnis ein, den diese Dateiempfangsfunktion als Speicherort für den Dateiempfang verwenden soll.

  7. Geben Sie im Feld Abzurufende Dateitypen die Erweiterungen der Dateien ein, die BizTalk Server empfängt.

    Die Dateierweiterung muss gemäß folgender Syntax eingegeben werden:

    *.ext

    Beispiel: *.doc

  8. Klicken Sie in der Liste Präprozessor auf den Namen des benutzerdefinierten Präprozessors.

    Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie das Feld leer.

  9. Klicken Sie auf OK.

Anmerkungen

  • Wenn Sie mehrere verschiedene Dateitypen empfangen möchten, verwenden Sie eines der üblichen Platzhalterformate.

    Beispiel: *.*

  • Wenn Sie mehrere Dateiempfangsfunktionen zum Überwachen desselben Verzeichnisses konfigurieren, verwenden Sie Dateierweiterungen mit drei Buchstaben. Falls Sie Dateierweiterungen mit mehr als drei Buchstaben verwenden, stellen Sie sicher, dass die ersten drei Buchstaben eindeutig sind.

    Beispiel: *.xml, *.1xml, *.12xml

  • Dateiempfangsfunktionen können keine schreibgeschützten Dateien verarbeiten.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

Benutzerdefinierte Präprozessoren


Hinzufügen einer Message Queuing-Empfangsfunktion

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und erweitern Sie dann die Servergruppe, zu der Sie die Message Queuing-Empfangsfunktion hinzufügen möchten.

  2. Klicken Sie auf Empfangsfunktionen.

  3. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie auf Message Queuing-Empfangsfunktion.

    Das Dialogfeld Message Queuing-Empfangsfunktion hinzufügen wird angezeigt.

  4. Geben Sie im Feld Name den Namen der Message Queuing-Empfangsfunktion ein.

  5. Fügen Sie im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  6. Klicken Sie in der Liste Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen eines Servers in der Gruppe.

  7. Geben Sie im Feld Abrufspeicherort den Namen des Servers und der Nachrichtenwarteschlange ein, die diese Empfangsfunktion als Empfangsspeicherort verwenden soll.

    Beispiel:

    Direct=OS:<servername>\<warteschlangenname>

    Wählen Sie den verarbeitenden Server aus, auf dem sich die Warteschlange befindet. Transaktionsmessaging wird nur von lokalen Warteschlangen unterstützt.

  8. Klicken Sie in der Liste Präprozessor auf den benutzerdefinierten Präprozessor.

    Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie das Feld leer.

  9. Geben Sie in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für die Verbindung zu Message Queuing ein.

    Dies ist nur dann erforderlich, wenn sich der Empfangsspeicherort nicht auf dem Server befindet, der die Austauschvorgänge und Dokumente verarbeitet.

  10. Klicken Sie auf die Schaltfläche Erweitert, um die Empfangsfunktion für Dokumente anzupassen, die kein automatisches Routing unterstützen, oder um Optionen für Offenheitsgrad und Pass-Through anzugeben.

    Weitere Informationen zu erweiterten Optionen finden Sie unter Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen.

Wichtig

  • Geben Sie im Feld Abrufspeicherort vor <Servername>\<Warteschlangenname> nicht das Präfix queue:// an. Hier verhält es sich anders als bei den allgemeinen Eigenschaften für eine Servergruppe, bei denen Sie das Präfix queue:// verwenden müssen. Weitere Informationen zur Message Queuing-Syntax finden Sie unter Verfügbare Empfangsfunktionen. Weitere Informationen zu den Eigenschaften für eine Servergruppe finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

Anmerkungen

  • Die Message Queuing-Empfangsfunktion akzeptiert keine Pass-Through-Versendung

  • Stellen Sie sicher, dass jede Empfangsfunktion, die Sie erstellen, einen eindeutigen Namen hat. Empfangsfunktionen können keine identischen Namen zugewiesen werden.

  • Message Queuing-Empfangsfunktionen können nur dann ordnungsgemäß ausgeführt werden, wenn der Benutzername und das Kennwort für einen BizTalk-Server angegeben werden, der über eine Leseberechtigung für die Warteschlange verfügt.

  • Um die Zuverlässigkeit sicherzustellen, müssen Transaktionswarteschlangen verwendet werden. Wenn Sie keine Transaktionswarteschlangen verwenden, können Nachrichten verloren gehen. Weitere Informationen zu Transaktionswarteschlangen finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp)). Suchen Sie in der Website nach dem Stichwort "Message Queuing".

  • Wenn Sie eine Empfangsfunktion replizieren, die für die Verwendung eines Benutzernamens und Kennwortes konfiguriert wurde, wird die Empfangsfunktion aufgrund eines ungültigen Kennwortes deaktiviert. Um dieses Problem zu lösen, müssen Sie die Eigenschaftenseite jeder Empfangsfunktion öffnen, das Kennwort erneut eingeben und dann die Empfangsfunktion aktivieren.

  • Weitere Informationen zu benutzerdefinierten Präprozessoren finden Sie unter Benutzerdefinierte Präprozessoren.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"

Benutzerdefinierte Präprozessoren

Empfangsfunktionen


Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Allgemein"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe, zu der Sie die Message Queuing-Empfangsfunktion hinzufügen möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Message Queuing-Empfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  4. Fügen Sie im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  5. Geben Sie im Bereich Sicherheit in den Feldern Benutzername und Kennwort einen gültigen Benutzernamen und ein gültiges Kennwort für die Verbindung zur Nachrichtenwarteschlange ein.

    Dies ist nur dann erforderlich, wenn sich der Empfangsspeicherort nicht auf dem verarbeitenden Server befindet.

  6. Wenn Sie die Funktionalität dieser Empfangsfunktion vorübergehend deaktivieren möchten, aktivieren Sie das Kontrollkästchen Empfangsfunktion deaktivieren, und klicken Sie auf Ja, um Ihre Auswahl zu bestätigen.

Anmerkung

  • Wenn Sie eine Empfangsfunktion replizieren, die für die Verwendung eines Benutzernamens und Kennwortes konfiguriert wurde, wird die Empfangsfunktion aufgrund eines ungültigen Kennwortes deaktiviert. Um dieses Problem zu lösen, müssen Sie die Eigenschaftenseite jeder Empfangsfunktion öffnen, das Kennwort erneut eingeben und dann die Empfangsfunktion aktivieren.

Verwandte Themen

Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"

Empfangsfunktionen


Konfigurieren einer Message Queuing-Empfangsfunktion: Registerkarte "Dienste"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe, zu der Sie die Message Queuing-Empfangsfunktion hinzufügen möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Message Queuing-Empfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  4. Klicken Sie auf die Registerkarte Dienste.

  5. Klicken Sie in der Liste Server, auf dem die Empfangsfunktion ausgeführt werden soll auf den Namen des Servers.

  6. Geben Sie im Feld Abrufspeicherort den Namen des Servers und der Nachrichtenwarteschlange ein, die diese Empfangsfunktion als Empfangsspeicherort verwenden soll.

    Beispiel:

    Direct=OS:<Servername>\<Warteschlangenname>

  7. Klicken Sie in der Liste Präprozessor auf den benutzerdefinierten Präprozessor.

    Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie diese Option leer.

  8. Klicken Sie auf OK.

Wichtig

  • Geben Sie im Feld Abrufspeicherort vor <Servername>\<Warteschlangenname> nicht das Präfix queue:// ein. Hier verhält es sich anders als bei den allgemeinen Eigenschaften für eine Servergruppe, bei denen Sie das Präfix queue:// verwenden müssen. Weitere Informationen zur Message Queuing-Syntax finden Sie unter Verfügbare Empfangsfunktionen. Weitere Informationen zu Servergruppeneigenschaften finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

Anmerkung

  • Weitere Informationen zu benutzerdefinierten Präprozessoren finden Sie unter Benutzerdefinierte Präprozessoren.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

Benutzerdefinierte Präprozessoren


Hinzufügen einer HTTP-Empfangsfunktion

Mit diesem Verfahren wird eine HTTP-Empfangsfunktion mit den Standardeinstellungen erstellt. Hinweise zum Konfigurieren der HTTP-Empfangsfunktion mit zusätzlichen Einstellungen finden Sie unter Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen.

Bevor Sie dieses Verfahren durchführen können, überprüfen Sie, ob IIS (Internetinformationsdienste) auf dem Server ausgeführt wird, auf dem die HTTP-Empfangsfunktion ausgeführt werden soll. Damit die HTTP-Empfangsfunktion ordnungsgemäß ausgeführt werden kann, müssen Sie außerdem ein virtuelles IIS-Verzeichnis mit Ausführungsberechtigungen verwenden. Weitere Informationen zum Erstellen eines virtuellen IIS-Verzeichnisses finden Sie in der IIS 5.0-Dokumentation.

Damit die HTTP-Empfangsfunktion ordnungsgemäß ausgeführt werden kann, wenn der Client das virtuelle Verzeichnis angibt, in dem die Daten über HTTP (Hypertext Transfer Protocol) an die HTTP-Empfangsfunktion gesendet werden, muss es sich bei der Abfragezeichenfolge um eine Multibyte-Zeichenfolge handeln, die mit der UTF-8-Codeseite codiert wurde. Beachten Sie des Weiteren, dass die HTTP-Empfangsfunktion standardmäßig USASCII verwendet, wenn der Header Content-Type nicht in einer eingehenden Anforderung festgelegt wurde. In diesem Fall werden die Instanzdaten beschädigt, wenn sie DBCS-Zeichen (Double-byte Character Set) enthalten. Weitere Informationen finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library). Suchen Sie in der Website nach "Support for Multibyte Character Sets" und "Encoding.UTF8 Property".

  1. Wechseln Sie in Windows Explorer zum Verzeichnis \Programme\Microsoft BizTalk Server\HTTP Receive\BizTalkHTTPReceive.dll auf dem Installationslaufwerk.

  2. Kopieren Sie BizTalkHTTPReceive.dll in das Verzeichnis, auf das das virtuelle IIS-Verzeichnis verweist.

  3. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und erweitern Sie dann die Servergruppe, zu der Sie die HTTP-Empfangsfunktion hinzufügen möchten.

  4. Klicken Sie auf Empfangsfunktionen.

  5. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie auf HTTP-Empfangsfunktion.

    Das Dialogfeld HTTP-Empfangsfunktion hinzufügen wird angezeigt.

  6. Geben Sie im Feld Name den Namen der HTTP-Empfangsfunktion ein.

  7. Fügen Sie im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  8. Wählen Sie in der Liste Server, auf dem die Empfangsfunktion ausgeführt wird den Namen des gewünschten Servers aus der Dropdownliste aus.

  9. Geben Sie im Feld Virtuelles Verzeichnis den Namen des virtuellen Verzeichnisses ein, an das die von der HTTP-Empfangsfunktion empfangenen Dokumente gesendet werden. Das virtuelle Verzeichnis enthält normalerweise den Namen der DLL der HTTP-Empfangsfunktion und eine optionale Abfragezeichenfolge.

    Die Namen von virtuellen Verzeichnissen können z. B. so aussehen:

    /<Virtuelles Verzeichnis>/BizTalkHTTPReceive.dll

    /<Virtuelles Verzeichnis>/BizTalkHTTPReceive.dll?Purchase%20Order

    Anmerkungen

    • Geben Sie im Feld Virtuelles Verzeichnis keinen Servernamen an. Der Server wurde bereits im Feld Server, auf dem die Empfangsfunktion ausgeführt wird angegeben.

    • Wenn das virtuelle Verzeichnis mit dem Namen der DLL der HTTP-Empfangsfunktion als einem der Standarddokumente konfiguriert wurde, müssen Sie die DLL (Dynamic-Link Library) zum Namen des virtuellen Verzeichnisses hinzufügen.

    • Bei dem im Feld Virtuelles Verzeichnis eingegebenen Wert muss die Zeichenfolge http:// ausgelassen werden.

    • Sie müssen mithilfe von Abfragezeichenfolgen mehrere Empfangsfunktionen erstellen, die das gleiche virtuelle Verzeichnis verwenden.

    • Die Abfragezeichenfolge im Feld Virtuelles Verzeichnis muss zum Codieren der Abfragezeichenfolge die URLEncode-Methode verwenden. Verwenden Sie die Zeichenfolge %20, um Leerstellen aufzunehmen.
  10. Wählen Sie im Feld Senden an aus, wohin (BizTalk/Datei) und wie (Synchron/Asynchron) die HTTP-Empfangsfunktion das Dokument sendet.

    Wenn Sie BizTalk-Synchron auswählen und ein Antwortdokument erwarten, geben Sie im Feld Inhaltstyp zurückgeben den Inhaltstyp ein, der zurückgegeben werden soll. Der Wert im Feld Inhaltstyp zurückgeben muss mit dem in den HTTP-Spezifikationen festgelegten Content-Type für HTTP übereinstimmen. Weitere Informationen zu HTTP-Spezifikationen finden Sie in der W3C-Website (www.w3.org).

    Oder

    Wenn Sie Datei auswählen, geben Sie im Feld Dateipfad und -name den Pfad- und Dateinamen ein, in den das empfangene Dokument geschrieben werden soll. Sie können im Dateinamen Variablen angeben, die zur Laufzeit ersetzt werden. Folgende drei Variablen werden unterstützt: %guid%, %server% und %datetime%. Sie können als Dateinamen und -pfad z. B. D:\Verzeichnis\Dateiname%guid%.xml angeben.

    Wichtig

    • Wenn ein Fehler auftritt, während die HTTP-Empfangsfunktion eine Datei sendet, wird die Nachricht nicht in der Angehalten-Warteschlange gespeichert.
  11. Aktivieren Sie das Kontrollkästchen Korrelationstoken zurückgeben, wenn an den Sender des Dokuments ein Korrelationstoken zurückgegeben werden soll.

    Beim Senden des Dokuments an BizTalk Server enthält das Korrelationstoken den Versendungs-GUID. Beim Senden des Dokuments an eine Datei enthält das Korrelationstoken den Dateinamen. Das Korrelationstoken kann z. B. wie folgt aussehen:

    <BizTalkHttpReceive><CorrelationToken TokenType= SUBMIT>{1a3e5678-a2c9-12d4-a8cd-12a456e89012}</CorrelationToken></BizTalkHttpReceive>

  12. Klicken Sie in der Liste Präprozessor auf den Namen des benutzerdefinierten Präprozessors.

    Anmerkung

    • Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie das Feld leer.

    Weitere Informationen finden Sie unter Preprocessing Documents in a Receive Function.

  13. Klicken Sie auf die Schaltfläche Erweitert, um die Empfangsfunktion für Dokumente anzupassen, die kein automatisches Routing unterstützen, oder um Optionen für Offenheitsgrad und Pass-Through anzugeben.

    Weitere Informationen zu erweiterten Optionen finden Sie unter Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen.

Damit die soeben erstellte HTTP-Empfangsfunktion ordnungsgemäß ausgeführt werden kann, müssen sich die verschiedenen Schutzebenen in IIS (Internetinformationsdienste) auf die richtigen Zugriffsberechtigungen in den COM+-Paketen auswirken.

Weiter mit Konfigurieren von Zugriffsrechten basierend auf der IIS-Schutzebene.

Anmerkungen

  • Stellen Sie sicher, dass jede Empfangsfunktion, die Sie erstellen, einen eindeutigen virtuellen Verzeichnisnamen, einschließlich der Abfragezeichenfolge, hat. Empfangsfunktionen können keine identischen Namen zugewiesen werden.

  • Es ist möglich, auf dem gleichen Server mehrere DLLs (Dynamic-Link Library) bereitzustellen, die verschiedenen virtuellen Verzeichnissen entsprechen. Außerdem können mehrere Verzeichnisse auf die gleiche DLL verweisen. Für eine bessere Leistung wird allerdings empfohlen, nur eine DLL zu verwenden.

  • Ein Client sendet unter Verwendung des URLs /VirtualDirectory an die HTTP-Empfangsfunktion. Bei IIS 5.0 und Windows 2000 Service Pack 2 (SP2) muss die DLL aber ebenfalls zum angegebenen URL gehören: /VirtualDirectory/BizTalkHTTPreceive.dll.

  • Nachdem Sie die HTTP-Empfangsfunktion erstellt haben, können Sie den grundlegenden Versendungstyp (BizTalk/Datei) nicht mehr ändern.

  • Wenn Sie für das Feld Senden an die Option BizTalk-Synchron auswählen und außerdem Korrelationstoken zurückgeben aktiviert ist, wird ein Korrelationstoken nur gesendet, wenn das Antwortdokument leer ist.

  • Das Korrelationstoken ist von der Orchestrierungskorrelation unabhängig Weitere Informationen finden Sie unter Korrelationstoken.

  • Wenn die HTTP-Empfangsfunktion synchron sendet und der Kanal die Nachricht durch einen Message Queuing-Port sendet, tritt möglicherweise folgender Fehler auf: "Invalid usage of transaction". Ursache hierfür ist, dass die HTTP-Empfangsfunktion nicht auf Transaktionen ausgelegt, Message Queuing aber transaktionsorientiert ist. Um diesen Fehler zu vermeiden, müssen Sie für den Kanal die Option Einzelnachricht auf Transaktionsebene auswählen. Weitere Informationen zu erweiterten Kanaleigenschaften finden Sie unter Außerkraftsetzen von Messagingportstandards.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Allgemein"

Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Dienste"

Benutzerdefinierte Präprozessoren

Empfangsfunktionen


Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Allgemein"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe, für die Sie eine HTTP-Empfangsfunktion konfigurieren möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die HTTP-Empfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  4. Fügen Sie auf der Registerkarte Allgemein im Feld Kommentar eine kurze Beschreibung hinzu (optional).

  5. Wenn Sie die Funktionalität dieser Empfangsfunktion vorübergehend deaktivieren möchten, aktivieren Sie das Kontrollkästchen Empfangsfunktion deaktivieren, und klicken Sie auf Ja, um Ihre Auswahl zu bestätigen.

Verwandte Themen

Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Dienste"

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen


Konfigurieren einer HTTP-Empfangsfunktion: Registerkarte "Dienste"

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe, für die Sie eine HTTP-Empfangsfunktion konfigurieren möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die HTTP-Empfangsfunktion, die Sie konfigurieren möchten.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  4. Klicken Sie auf die Registerkarte Dienste.

  5. Klicken Sie im Feld Server, auf dem die Empfangsfunktion ausgeführt wird auf den Namen des Servers.

  6. Geben Sie im Feld Virtuelles Verzeichnis den Namen des virtuellen Verzeichnisses ein, an das die von der HTTP-Empfangsfunktion empfangenen Dokumente gesendet werden.

    Die Namen der virtueller Verzeichnisse können z. B. wie folgt lauten:

    /<virtuelles Verzeichnis>/BizTalkHTTPReceive.dll

    /<virtuelles Verzeichnis>/BizTalkHTTPReceive.dll?Purchase%20Order

    Anmerkungen

    • Geben Sie im Feld Virtuelles Verzeichnis keinen Servernamen an. Der Server wurde bereits im Feld Server, auf dem die Empfangsfunktion ausgeführt wird angegeben.

    • Wenn das virtuelle Verzeichnis mit dem Namen der DLL der HTTP-Empfangsfunktion als einem der Standarddokumente konfiguriert wurde, müssen Sie die DLL (Dynamic-Link Library) zum Namen des virtuellen Verzeichnisses hinzufügen.

    • Bei dem im Feld Virtuelles Verzeichnis eingegebenen Wert muss die Zeichenfolge http:// ausgelassen werden.

    • Sie müssen mithilfe von Abfragezeichenfolgen mehrere Empfangsfunktionen erstellen, die das gleiche virtuelle Verzeichnis verwenden.

    • Die Abfragezeichenfolge im Feld Virtuelles Verzeichnis muss zum Codieren der Abfragezeichenfolge die URLEncode-Methode verwenden. Verwenden Sie die Zeichenfolge %20, um Leerstellen aufzunehmen.
  7. Wenn die HTTP-Empfangsfunktion an BizTalk Server sendet, wählen Sie im Feld Senden an die Versendungsmethode (Asynchron oder Synchron) aus.

    Wenn Sie BizTalk-Synchron auswählen, geben Sie im Feld Inhaltstyp zurückgeben den Inhaltstyp ein, der zurückgegeben werden soll. Der Wert im Feld Inhaltstyp zurückgeben muss mit dem in den HTTP-Spezifikationen festgelegten Content-Type für HTTP übereinstimmen. Weitere Informationen zu HTTP-Spezifikationen finden Sie in der W3C-Website (www.w3.org).

    Internationales Problem

    • Wenn der Header Content-Type nicht in einer eingehenden Anforderung festgelegt wurde, verwendet die HTTP-Empfangsfunktion standardmäßig USASCII. In diesem Fall werden die Instanzdaten beschädigt, wenn sie DBCS-Zeichen (Double-byte Character Set) enthalten.
  8. Klicken Sie in der Liste Präprozessor auf den Namen des benutzerdefinierten Präprozessors.

    Anmerkung

    • Falls Sie keinen benutzerdefinierten Präprozessor verwenden, lassen Sie das Feld leer.

    Weitere Informationen finden Sie unter Preprocessing Documents in a Receive Function.

  9. Wenn die HTTP-Empfangsfunktion an eine Datei sendet, geben Sie im Feld Dateipfad und -name den Pfad- und Dateinamen ein, in den das empfangene geschrieben werden soll. Sie können im Dateinamen Variablen angeben, die zur Laufzeit ersetzt werden. Folgende drei Variablen werden unterstützt: %guid%, %server% und %datetime%. Sie können als Dateinamen und -pfad z. B. D:\Verzeichnis\Dateiname%guid%.xml angeben.

  10. Aktivieren Sie das Kontrollkästchen Korrelationstoken zurückgeben, wenn an den Sender des Dokuments ein Korrelationstoken zurückgegeben werden soll.

    Beim Senden des Dokuments an BizTalk Server enthält das Korrelationstoken den Versendungs-GUID. Beim Senden des Dokuments an eine Datei enthält das Korrelationstoken den Dateinamen. Das Korrelationstoken kann z. B. wie folgt aussehen:

    <BizTalkHttpReceive><CorrelationToken TokenType= SUBMIT>{1a3e5678-a2c9-12d4-a8cd-12a456e89012}</CorrelationToken></BizTalkHttpReceive>

  11. Klicken Sie auf OK.

Anmerkungen

  • Bei einer Toolsinstallation von BizTalk Server unterstützt die Verwaltungskonsole nicht die Erstellung einer HTTP-Empfangsfunktion.

  • Das Korrelationstoken ist von der Orchestrierungskorrelation unabhängig Weitere Informationen finden Sie unter Korrelationstoken.

  • Nachdem Sie die HTTP-Empfangsfunktion erstellt haben, können Sie den grundlegenden Versendungstyp (BizTalk/Datei) nicht mehr ändern.

  • Wenn Sie für das Feld Senden an die Option BizTalk - Synchron auswählen und außerdem Korrelationstoken zurückgeben aktiviert ist, wird ein Korrelationstoken nur gesendet, wenn das Antwortdokument leer ist.

  • Ein Client sendet unter Verwendung des URLs /VirtualDirectory an die HTTP-Empfangsfunktion. Bei IIS 5.0 und Windows 2000 Service Pack 2 (SP2) muss die DLL aber ebenfalls zum angegebenen URL gehören: /VirtualDirectory/BizTalkHTTPreceive.dll.

  • Sie müssen mithilfe von Abfragezeichenfolgen mehrere Empfangsfunktionen erstellen, die das gleiche virtuelle Verzeichnis verwenden.

Verwandte Themen

Verfügbare Empfangsfunktionen

Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

Benutzerdefinierte Präprozessoren


Konfigurieren von erweiterten Eigenschaften für Datei-, Message Queuing- oder HTTP-Empfangsfunktionen

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe, für die Sie eine Empfangsfunktion konfigurieren möchten, erweitern Sie Empfangsfunktionen, und klicken Sie dann auf die Empfangsfunktion, die Sie konfigurieren möchten.

  2. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

  3. Klicken Sie auf die Registerkarte Erweitert.

  4. In der Liste Offenheitsgrad können Sie zwischen folgenden Optionen auswählen:
    • Nicht geöffnet. Klicken Sie auf diese Option, wenn Quelle und Ziel in der Empfangsfunktion oder in der Dokumentinstanz explizit deklariert sind und BizTalk Server das Dokument nicht auf diese Informationen hin analysieren muss.

    • Offenes Ziel. Klicken Sie auf diese Option, wenn die Zielinformationen am Messagingport nicht explizit deklariert sind. Das Ziel wird dynamisch in der Dokumentinstanz oder in einem Versendungsparameter angegeben.

    • Offene Quelle. Klicken Sie auf diese Option, wenn die Quellinformationen im Kanal nicht explizit deklariert sind. Die Quelle wird stattdessen in der Dokumentinstanz oder in einem Versendungsparameter dynamisch angegeben.
  5. Wenn Sie alle Verarbeitungsschritte, wie z. B. Decodierung, Entschlüsselung, Signaturüberprüfung, Analyse usw. umgehen und einen Austausch lediglich transportieren möchten, aktivieren Sie das Kontrollkästchen Mit Pass-Through-Kennzeichen senden.

    Falls Sie das Kontrollkästchen Mit Pass-Through-Kennzeichen senden aktivieren, müssen Sie einen Kanal auswählen.

  6. Klicken Sie in der Liste Umschlagsname auf den Namen einer Umschlagsdefinition.

    Wählen Sie einen Umschlag aus, wenn Sie Flatfiles empfangen möchten. Andernfalls lassen Sie dieses Feld leer.

  7. Klicken Sie in der Liste Kanalname auf den Namen eines Kanals.

  8. Klicken Sie in der Liste Dokumentdefinitionsname auf den Namen einer Dokumentdefinition.

  9. Klicken Sie im Bereich Quelle und Ziel unter Ausgewählte Quelle auf Durchsuchen.

    Das Dialogfeld Quelle auswählen wird angezeigt.

  10. Klicken Sie in der Liste Organisationsqualifizierer auf den Typ des Quellorganisationsqualifizierers.

  11. Klicken Sie in der Liste Organisationskennzeichenwert auf den Organisationskennzeichenwert der Quelle, und klicken Sie dann auf OK.

  12. Klicken Sie im Bereich Quelle und Ziel unter Ausgewähltes Ziel auf Durchsuchen.

    Das Dialogfeld Ziel auswählen wird angezeigt.

  13. Klicken Sie in der Liste Organisationsqualifizierer auf den Typ des Zielorganisationsqualifizierers.

    Wenn Sie Dokumente an eine Verteilerliste senden, müssen Sie in der Liste Organisationsqualifizierer die Option GROUP auswählen.

  14. Klicken Sie in der Liste Organisationskennzeichenwert auf den Organisationskennzeichenwert des Zieles, und klicken Sie auf OK.

  15. Klicken Sie auf OK.

Wichtig

  • Bevor Sie die Objekte in der folgenden Liste als erweiterte Eigenschaften einer Empfangsfunktion zuordnen können, müssen Sie sie zunächst erstellen. Diese Objekte werden entweder im BizTalk Messaging-Manager erstellt, oder sie werden programmgesteuert generiert und in der BizTalk-Messaging-Verwaltungsdatenbank gespeichert:
    • Umschläge

    • Kanäle

    • Dokumentdefinitionen

    • Quellqualifizierer

    • Organisationskennzeichenwerte der Quelle

    • Zielqualifizierer

    • Organisationskennzeichenwerte des Zieles

Anmerkungen

  • Wenn Sie in der Liste Offenheitsgrad auf Offene Quelle oder Offenes Ziel klicken, ist das Kontrollkästchen Mit Pass-Through-Kennzeichen senden nicht verfügbar.

  • Wenn das Kontrollkästchen Mit Pass-Through-Kennzeichen senden aktiviert ist, ist nur die Liste Kanalname verfügbar.

  • Wenn Sie Dokumente an eine Verteilerliste senden, müssen Sie im Dialogfeld Ziel auswählen in der Liste Organisationsqualifizierer die Option GROUP auswählen.

  • Alle erweiterten Empfangsfunktionseigenschaften sind optional und können leer gelassen werden. Weitere Informationen zum Senden von Dokumenten finden Sie unter Routing und unter Grundlegendes zu Empfangsfunktionen und Dokumentrouting.

  • Bei einer Pass-Through-Versendung werden die Analyse-, Entschlüsselungs- und Decodierungsfunktionen von BizTalk Server 2002 umgangen. Weitere Informationen zum Senden von Dokumenten mit aktiviertem Pass-Through-Kennzeichen finden Sie unter Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen. Weitere Informationen zum Senden finden Sie unter Submitting.

  • Die Registerkarte Erweitert ist für eine HTTP-Empfangsfunktion, die an eine Datei sendet, nicht verfügbar.

  • Die Registerkarte Erweitert für die Empfangsfunktionen ist in einer Toolsinstallation von BizTalk Server nicht verfügbar.

Verwandte Themen

Empfangsfunktionen

Routing

Submitting

Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen

Grundlegendes zu Empfangsfunktionen und Dokumentrouting


Konfigurieren von Zugriffsrechten basierend auf der IIS-Schutzebene

Nachdem Sie eine HTTP-Empfangsfunktion hinzugefügt haben, ist es wichtig, anhand der Isolationsebene des virtuellen Verzeichnisses bestimmte COM+-Pakete zu konfigurieren:

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

  2. Erweitern Sie in der Konsolenstruktur der Computerverwaltung Dienste und Anwendungen, erweitern Sie Internet-Informationsdienste, und erweitern Sie den Namen der Website mit dem von der HTTP-Empfangsfunktion verwendeten virtuellen Verzeichnis (die Standardeinstellung ist Standardwebsite).

  3. Klicken Sie mit der rechten Maustaste auf den Namen des virtuellen Verzeichnisses, und klicken Sie auf Eigenschaften.

  4. Beachten Sie auf der Registerkarte Virtuelles Verzeichnis die Ebene des Anwendungsschutzes.

    Wenn die Anwendungsschutzebene Niedrig (IIS-Prozess) ist, gehen Sie zu Schritt 5.

    Wenn die Anwendungsschutzebene Mittel (zusammengefasst) ist, gehen Sie zu Schritt 7.

    Wenn die Anwendungsschutzebene High (isoliert) ist, gehen Sie zu Schritt 9.

  5. Wenn für die Anwendungsschutzebene Niedrig (IIS-Prozess) konfiguriert wurde, öffnen Sie Komponentendienste, doppelklicken Sie auf Dienste, klicken Sie mit der rechten Maustaste auf WWW-Publishingdienst, und klicken Sie auf Eigenschaften.

  6. Konfigurieren Sie auf der Registerkarte Anmelden die Eigenschaft Anmelden als mit dem Benutzer, dessen Sicherheitsanmeldeinformationen den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank und die COM+-Pakete BizTalk Server-Austauschanwendung und interne BizTalk Server-Dienstprogramme ermöglichen.

  7. Wenn für die Anwendungsschutzebene des virtuellen Verzeichnisses Mittel (zusammengefasst) konfiguriert wurde, öffnen Sie Komponentendienste, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen, klicken Sie mit der rechten Maustaste auf IIS-Out-Of-Process-Pooled-Applications, und klicken Sie auf Eigenschaften.

  8. Konfigurieren Sie auf der Registerkarte Identität die Eigenschaft Konto mit dem Benutzer, dessen Anmeldeinformationen den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank und die COM+-Pakete BizTalk Server-Austauschanwendung und interne BizTalk Server-Dienstprogramme ermöglichen.

  9. Wenn für die Anwendungsschutzebene des virtuellen Verzeichnisses Hoch (isoliert) konfiguriert wurde, öffnen Sie Komponentendienste, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen, klicken Sie mit der rechten Maustaste auf IIS-{Standardwebsite//root/Name des virtuellen Verzeichnisses}, und klicken Sie auf Eigenschaften.

  10. Konfigurieren Sie auf der Registerkarte Identität die Eigenschaft Konto mit dem Benutzer, dessen Anmeldeinformationen den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank und die COM+-Pakete BizTalk Server-Austauschanwendung und interne BizTalk Server-Dienstprogramme ermöglichen.

Verwandtes Thema

Hinzufügen einer HTTP-Empfangsfunktion


Löschen einer Empfangsfunktion

Diese Aufgabe ermöglicht das Löschen einer Instanz einer Empfangsfunktion. Dabei wird die Verwaltungsobjektinstanz aus der Verwaltungsdatenbank entfernt. Dies hat keine Auswirkungen auf die tatsächlichen Komponenten und Skripts, die zu dieser Instanz gehören.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie die Servergruppe, in der Sie eine Empfangsfunktion löschen möchten, und erweitern Sie dann Empfangsfunktionen.

  2. Klicken Sie auf die Empfangsfunktion, die gelöscht werden soll.

  3. Klicken Sie im Menü Vorgang auf Löschen.

    Das Dialogfeld Benutzeraktionsbestätigung wird angezeigt.

  4. Klicken Sie auf Ja.

Verwandtes Thema

Empfangsfunktionen


Verwalten von BizTalk-Diensten

Wenn Sie eine grundlegende Änderungen an der BizTalk Server-Konfiguration vornehmen, z. B den Namen einer Datenbank ändern oder einen Webserver oder Firewall hinzufügen, verwendet ein aktiver Dienst möglicherweise auch weiterhin die Parameter der alten Konfiguration. Um alle Dienste für die neue Konfiguration zu synchronisieren, müssen Sie die BizTalk-Dienste, die von der Änderung betroffen sind, beenden und neu starten.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Starten eines BizTalk-Dienstes

  • Beenden eines BizTalk-Dienstes


Starten eines BizTalk-Dienstes

Mit dieser Aufgabe können Sie die BizTalk-Dienste, die einem bestimmten Server zugeordnet sind, starten.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie BizTalk Server Gruppe, und wählen Sie dann den Server aus, auf dem die BizTalk-Dienste gestartet werden sollen.

  2. Klicken Sie im Menü Vorgang auf Starten.

Verwandte Themen

Beenden eines BizTalk-Dienstes

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Beenden eines BizTalk-Dienstes

Mit dieser Aufgabe können Sie die BizTalk-Dienste, die einem bestimmten Server zugeordnet sind, beenden. BizTalk-Dienste werden normalerweise beendet, um die Verarbeitung anzuhalten, während Änderungen an der Konfigurationsdatenbank vorgenommen oder Probleme behoben werden.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, erweitern Sie BizTalk Server Gruppe, und wählen Sie dann den Server aus, auf dem die BizTalk-Dienste gestartet werden sollen.

  2. Klicken Sie im Menü Vorgang auf Beenden.

Verwandte Themen

Starten eines BizTalk-Dienstes

Starten eines Servers in einer Gruppe

Beenden eines Servers in einer Gruppe


Verwalten der Ereignisanzeige

Sie können die zur BizTalk Server-Verwaltung gehörende Ereignisanzeige als Hilfe zur Problembehandlung bei Server- und Dokumentverarbeitungsproblemen verwenden. Die Ereignisanzeige wird in der Konsolenstruktur der BizTalk Server-Verwaltung angezeigt. Alle anwendungsbezogenen Fehler bei BizTalk Server 2002 sind als BizTalk Server-Fehler gekennzeichnet. Alle auf die XLANG-Ablaufpläne bezogenen Fehler sind als Fehler der XLANG-Ablaufplanung (XLANG Scheduler) gekennzeichnet.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler

  • Anzeigen von anwendungsbezogenen Fehlern in der Ereignisanzeige

Anmerkung

  • Verschiedene Fehler, die innerhalb einer benutzerdefinierten Skriptfunktion vom Microsoft XML-Parser (MSXML) zurückgegeben werden, werden möglicherweise nicht in der Ereignisanzeige angezeigt. Fehler, die zu einem Dokument in der Angehalten-Warteschlange gehören, geben möglicherweise nicht den Fehler wieder, der in dem Skript zurückgegeben wurde.


Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler

Mit dieser Aufgabe können Sie die Ereignisanzeige so konfigurieren, dass nur die Ereignisse für BizTalk Server und/oder die XLANG-Ablaufplanung (XLANG Scheduler) angezeigt werden. Dieses Verfahren wird normalerweise angewendet, wenn es viele Fehler anderer Programmen gibt, die bei der Problembehandlung nicht angezeigt werden sollen.

  1. Erweitern Sie in der BizTalk Server-Verwaltung Ereignisanzeige.

  2. Klicken Sie auf Anwendung.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Anwendung wird angezeigt.

  4. Klicken Sie auf die Registerkarte Filter.

  5. Klicken Sie in der Liste Ereignisquelle auf eine der folgenden Optionen:
    • BizTalk Server. Diese Option filtert nach Ereignisquellen für Fehlernachrichten, die sich auf die BizTalk-Messagingdienste beziehen.

    • XLANG Scheduler. Diese Option filtert nach Ereignisquellen für Fehlernachrichten, die sich auf die BizTalk-Orchestrierungsdienste beziehen.
  6. Klicken Sie auf OK, um das Dialogfeld Eigenschaften von Anwendung zu schließen.


Anzeigen von anwendungsbezogenen Fehlern in der Ereignisanzeige

  1. Erweitern Sie in der BizTalk Server-Verwaltung Ereignisanzeige.

  2. Klicken Sie auf Anwendung.

    Anwendungsfehlermeldungen werden im Detailfensterbereich aufgeführt.

  3. Klicken Sie im Detailfensterbereich auf eine Nachricht.

  4. Klicken Sie im Menü Vorgang auf Eigenschaften.

Anmerkung

  • Bei diesem Verfahren wird vorausgesetzt, dass die Ereignisanzeige so konfiguriert ist, dass nur BizTalk Server-Fehler und Fehler der XLANG-Ablaufplanung (XLANG Scheduler) angezeigt werden. Weitere Informationen zum Anzeigen von BizTalk Server-Fehlern und Fehler der XLANG-Ablaufplanung(XLANG Scheduler) finden Sie unter Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler.


Verwalten von XLANG-Anwendungen und -Datenbanken

Dieser Abschnitt stellt Informationen zum Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) bereit, die beim Installieren von BizTalk Server 2002 installiert wird. Darüber hinaus enthält er Informationen zum Erstellen neuer COM+-Hostanwendungen für XLANG-Ablaufplaninstanzen und neue Persistenzdatenbanken zum Speichern von Statusinformation für XLANG-Ablaufpläne.

In diesem Abschnitt werden folgende Verfahren und Themen behandelt:

  • Löschen von Datensätzen mithilfe von Prozeduren aus der Persistenzdatenbank

  • Herunterfahren aller XLANG-Anwendungen

  • Neu starten aller XLANG-Anwendungen

  • Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

  • Verwalten von weiteren COM+-Hostanwendungen für XLANG-Ablaufpläne

  • Überwachen von aktiven XLANG-Ablaufplänen

Vorsicht

  • BizTalk Server 2002 stellt eine COM+-Anwendung mit der Bezeichnung XLANG-Hilfsprogramm für Ablaufplanungsbeständigkeit (Scheduler Persistence Helper) bereit, die von allen COM+-Anwendungen, die als Host für XLANG-Ablaufplaninstanzen dienen, verwendet wird. Nach Abschluss der Installation sollten Sie die Konfiguration des XLANG-Hilfsprogramms für Ablaufplanungsbeständigkeit in keiner Weise mehr ändern.

Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Onlinedokumentation, um weitere Informationen zu Microsoft SQL Server zu erhalten.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Component Services".

Verwandte Themen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen


Löschen von Datensätzen mithilfe von Prozeduren aus der Persistenzdatenbank

Die Persistenzdatenbank enthält sämtliche Persistenzinformationen für die aktiven XLANG-Ablaufpläne, deren Ausführung abgeschlossen werden muss. Da Daten für abgeschlossene XLANG-Ablaufpläne nicht aus der Datenbank gelöscht werden, wird diese Datenbank immer umfangreicher. Sie können Datensätze mithilfe folgender Prozeduren aus der Persistenzdatenbank löschen.

sp_CleanDoneInstances @CompletedBefore='<Datum und Zeit im GMT-Format>'

Die gespeicherte Prozedur sp_CleanDoneInstances löscht alle abgeschlossenen oder beendeten XLANG-Ablaufplaninstanzen. Der folgende Code ist ein Beispiel für das Verwenden dieser gespeicherten Prozedur:

exec sp_CleanDoneInstances @CompletedBefore='2000-10-25 19:34:49.000'

Anmerkungen

  • Die Zeit wird im Format Greenwich Mean Time (GMT) angegeben, da alle Datums- und Zeitinformationen in der Persistenzdatenbank für die Orchestrierung in diesem Format gespeichert werden.

  • Die Beendigungszeit gilt nur für Ablaufpläne auf Stammebene.

sp_CleanDoneModuleInstances @CompletedBefore='<Datum und Zeit im GMT-Format>', @ModuleGUID='<global eindeutiger Bezeichner>'

Die gespeicherte Prozedur sp_CleanDoneModuleInstances löscht alle abgeschlossenen oder beendeten XLANG-Ablaufplaninstanzen eines bestimmten Ablaufplanes. Der folgende Code ist ein Beispiel für das Verwenden dieser gespeicherten Prozedur:

exec sp_CleanDoneModuleInstances @CompletedBefore='2000-10-25 19:34:49.000',
@ModuleGUID='4C5842DA-40E5-40B8-AF03-BC5DD4B7E037'

Anmerkungen

  • Die Zeit wird im Format Greenwich Mean Time (GMT) angegeben, da alle Datums- und Zeitinformationen in der Persistenzdatenbank für die Orchestrierung in diesem Format gespeichert werden.

  • Die Beendigungszeit gilt nur für Ablaufpläne auf Stammebene.

  • @ModuleGUID ist die ModuleID eines Ablaufplanes.

    ModuleID ist ein eindeutiger Verweis auf einen bestimmten Typ eines XLANG-Ablaufplanes. Sie können den @ModuleGUID-Parameter verwenden, um nach dem Typ des XLANG-Ablaufplanes zu filtern. Der @CompletedBefore-Parameter filtert nach XLANG-Ablaufplaninstanzen, die vor einem bestimmten Zeitpunkt beendet wurden. Der @ModuleGUID-Parameter filtert nach XLANG-Ablaufplänen eines bestimmten Typs. Sie können XLANG Monitor verwenden, um ModuleID für einen XLANG-Ablaufplan zu ermitteln. ModuleID ist eine der Eigenschaften in den Ereignissen für ScheduleStart, ScheduleDone, ContextEnter, ContextLeave, TransactionBegin, und TransactionEnd. Sie können zum Abrufen von ModuleID auch die öffentliche Schnittstelle IWFWorkflowInstance::ModuleId Property zu XLANG-Ablaufplänen verwenden.

sp_CleanInstance@InstanceID='{<global eindeutiger Bezeichner>}'

Die gespeicherte Prozedur sp_CleanInstance löscht eine abgeschlossene oder beendete XLANG-Ablaufplaninstanz und alle untergeordneten Instanzen dieses Ablaufplanes. Dieser Löschvorgang ist auf Transaktionen ausgelegt. In dieser gespeicherten Prozedur ist @InstanceID der global eindeutige Bezeichner (Globally Unique Identifier, GUID), das heißt, der Instanzbezeichner für den Stamm-XLANG-Ablaufplan. BizTalk Server 2002 verwendet diese gespeicherte Prozedur. Sie müssen diese gespeicherte Prozedur nicht direkt aufrufen. Sie sollten stattdessen die Anweisungen zum Leeren der XLANG-Datenbank befolgen.

Anmerkung

  • Sie können SQL Server-Agent-Aufträge erstellen, um diese gespeicherten Prozeduren in regelmäßigen Abständen zu verwenden. Weitere Informationen erhalten Sie, indem Sie im Startmenü auf Programme zeigen, dann auf Microsoft SQL Server zeigen und anschließend auf Onlinedokumentation klicken.


Herunterfahren aller XLANG-Anwendungen

Sie müssen dieses Verfahren anwenden, damit ein kontrolliertes Herunterfahren aller COM+-Anwendungen ausgeführt wird. So können Sie alle aktiven XLANG-Ablaufpläne durch Speichern des Status in der Persistenzdatenbank herunterfahren. Weitere Informationen finden Sie unter Persistenz.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf XLANG Scheduler.

  4. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von XLANG Scheduler wird angezeigt.

  5. Klicken Sie auf der Registerkarte XLANG im Bereich Kontrolliertes Herunterfahren auf Alle XLANG-Anwendungen.

Vorsicht

  • Dagegen sollten Sie nicht mit der rechten Maustaste auf eine COM+-Anwendung klicken und auf Herunterfahren klicken. Dadurch können folgende Probleme auftreten:
    • Falls die aktiven XLANG-Ablaufpläne vollständig transaktional sind, werden bei einem unkontrollierten Herunterfahren alle gerade in Ausführung befindlichen Transaktionen abgebrochen.

    • Sind die aktiven XLANG-Ablaufpläne nicht vollständig transaktional, gehen in Verarbeitung befindliche Daten im Ablaufplan verloren.

Wichtig

  • Pausierende XLANG-Ablaufpläne können nicht neu gestartet werden, wenn der Datenquellenname (DSN) nicht verfügbar oder fehlerhaft konfiguriert ist. Weitere Informationen zum Konfigurieren eines DSN für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler).

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Component Services".

Verwandte Themen

Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Neu starten aller XLANG-Anwendungen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Herunterfahren einer COM+-Hostanwendung für XLANG-Ablaufpläne


Neu starten aller XLANG-Anwendungen

Sie müssen dieses Verfahren anwenden, damit ein kontrollierter Neustart aller COM+-Anwendungen ausgeführt wird.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf XLANG Scheduler.

  4. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von XLANG Scheduler wird angezeigt.

  5. Klicken Sie auf der Registerkarte XLANG im Bereich Pausierende XLANG-Anwendungen neu starten auf Alle XLANG-Anwendungen.

Wichtig

  • Pausierende XLANG-Ablaufpläne können nicht neu gestartet werden, wenn der Datenquellenname (DSN) nicht verfügbar oder fehlerhaft konfiguriert ist. Der Datenquellenname (DSN) muss mit dem Namen der COM+-Anwendung übereinstimmen. Wenn beispielsweise die COM+-Anwendung, die als Host für das XLANG-Ablaufplanungsmodul dient, den Namen XLANG-Ablaufplanung (XLANG Scheduler) trägt, muss der DSN ebenfalls XLANG-Ablaufplanung lauten.

  • Wenn Sie pausierende Anwendungen neu starten, startet dieser Vorgang die Aktivierung der pausierenden Ablaufpläne asynchron. Der Aktivierungsvorgang geschieht nicht sofort. Verwenden Sie den XLANG Event Monitor, um zu ermitteln, wann der Aktivierungsvorgang abgeschlossen ist. Weitere Informationen zum Tool XLANG Event Monitor finden Sie in der zur Anwendung gehörenden Datei Readme.htm. Der XLANG Event Monitor (XLANGMon.exe) und die vom Microsoft BizTalk Server 2002 Setup-Assistent installierte Infodatei befinden sich beide im folgenden Installationsverzeichnis: \Programme\Microsoft BizTalk Server\SDK\XLANG-Tools.

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Component Services".

Verwandte Themen

Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Herunterfahren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Herunterfahren aller XLANG-Anwendungen


Verwalten der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) dient als Host für die Standardinstanz des XLANG-Ablaufplanungsmoduls, das beim Installieren von BizTalk Server 2002 erstellt wurde. Auf Produktionssystemen oder Systemen mit Microsoft Terminal Server müssen Sie die Standardidentität dieser Anwendung ändern.

Weitere Informationen zu Sicherheits- und Leistungsaspekten in Bezug auf Änderungen an den Standardeinstellungen für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

In diesem Abschnitt wird das folgende Verfahren behandelt:

  • Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Onlinedokumentation, um weitere Informationen zu Microsoft SQL Server zu erhalten.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Component Services".

Verwandte Themen

Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen


Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Es wird empfohlen, das interaktive Standardbenutzerkonto für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) in ein Dienstkonto zu ändern. Wenn bei einem interaktiven Benutzerkonto ein Benutzer nicht angemeldet ist, wird die Anwendung nicht ausgeführt. Durch Ändern des interaktiven Kontos in ein Dienstkonto muss ein bestimmter Benutzer nicht die ganze Zeit angemeldet sein. Ein Dienstkonto ist ein Konto mit bestimmten Eigenschaften, durch die es als ein Teil des Betriebssystems fungieren kann. Weitere Informationen zu Sicherheits- und Leistungsaspekten in Bezug auf Änderungen der Standardeinstellungen für die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen. Weitere Informationen zum Einrichten eines Dienstkontos finden Sie unter Einrichten eines Dienstkontos.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf XLANG Scheduler.

  4. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von XLANG Scheduler wird angezeigt.

  5. Deaktivieren Sie auf der Registerkarte Erweitert im Bereich Berechtigung das Kontrollkästchen Ändern deaktivieren, und klicken Sie auf OK.

    Es wird eine Fehlermeldung mit ungefähr folgendem Wortlaut angezeigt:

    Die Anwendungen wurden durch ein oder mehrere externe Produkte erstellt. Sind Sie sicher, dass die Änderungen, die Sie vornehmen möchten, von diesen Produkten unterstützt werden?

  6. Klicken Sie auf Ja.

    Das Dialogfeld Eigenschaften von XLANG Scheduler wird geschlossen.

  7. Klicken Sie auf XLANG Scheduler.

  8. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von XLANG Scheduler wird angezeigt.

  9. Klicken Sie auf der Registerkarte Identität im Bereich Konto auf Dieser Benutzer.

  10. Geben Sie die Informationen für das Konto ein, das verwendet werden soll.

  11. Klicken Sie auf OK.

    Es wird eine Fehlermeldung mit ungefähr folgendem Wortlaut angezeigt:

    Die Anwendungen wurden durch ein oder mehrere externe Produkte erstellt. Sind Sie sicher, dass die Änderungen, die Sie vornehmen möchten, von diesen Produkten unterstützt werden?

  12. Klicken Sie auf Ja.

Anmerkungen

  • Beim Zugriff auf das Dialogfeld Eigenschaften von XLANG Scheduler über Microsoft Terminal Server wird die Registerkarte XLANG nicht angezeigt, wenn für das Konto der XLANG-Ablaufplanung (XLANG Scheduler) (auf der Registerkarte Identität) die Option Interaktiver Benutzer – der zurzeit angemeldete Benutzer festgelegt wurde und zurzeit kein Benutzer am Host BizTalk-Server angemeldet ist. Sie können dieses Problem mit den weiter oben beschriebenen Schritten beheben.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Component Services".

Verwandte Themen

Ändern der DSN-Einstellungen für eine COM+-Anwendung

Erstellen einer neuen, leeren Persistenzdatenbank

Erstellen einer Instanziierungsanwendung

Neu starten aller XLANG-Anwendungen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Herunterfahren aller XLANG-Anwendungen


Verwalten von weiteren COM+-Hostanwendungen für XLANG-Ablaufpläne

Obwohl Sie zur Ausführung von XLANG-Ablaufplänen die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) verwenden können, ist es aufgrund von Sicherheits-, Bereitstellungs- und Konfigurationsaspekten häufig nützlich, eine neue COM+-Anwendung zu erstellen, um Ablaufplaninstanzen auszuführen.

Sie können eine neue COM+-Anwendung erstellen, die als Host zum Verteilen der Verarbeitungslast für bestimmte Instanzen aktiver XLANG-Ablaufpläne dienen soll. Möglicherweise möchten Sie aber auch Anwendungen, die bestimmte XLANG-Ablaufplaninstanzen ausführen, von anderen XLANG-Ablaufplänen isolieren, die andere Anwendungen verwenden oder unter einer anderen Identität ausgeführt werden. Für die Anwendungen und die Ablaufpläne müssen sicherheits- und leistungsbezogene Anforderungen berücksichtigt werden. Weitere Informationen finden Sie unter Ausführung von XLANG-Ablaufplänen sowie unter Ausführen von XLANG-Ablaufplänen.

Damit Sie eine neue COM+-Anwendung erstellen können, die als Host für XLANG-Ablaufpläne dient, müssen Sie zunächst die Persistenzdatenbank erstellen, der diese neue COM+-Anwendung zugeordnet wird. Dann müssen Sie die neue COM+-Anwendung erstellen, die Standardeinstellungen für die Anwendungsidentität ändern, die Einstellungen des Datenquellennamens (DSN) für die COM+-Anwendung konfigurieren und schließlich die Tabellen für die neue Persistenztabelle initialisieren. Weitere Informationen zum Erstellen einer neuen COM+-Anwendung finden Sie unter Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer neuen, leeren Persistenzdatenbank

  • Ändern der Anwendungsidentität einer COM+-Anwendung

  • Ändern der DSN-Einstellungen für eine COM+-Anwendung

  • Herunterfahren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Onlinedokumentation, um weitere Informationen zu Microsoft SQL Server zu erhalten.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Component Services".


Erstellen einer neuen, leeren Persistenzdatenbank

Sie möchten möglicherweise eine neue Persistenzdatenbank erstellen, um die Ablaufplaninformationen für eine COM+-Anwendung zu speichern, die als Host von bestimmten Instanzen aktiver XLANG-Ablaufpläne dient.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft SQL Server, und klicken Sie dann auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Servers, erweitern Sie SQL Server-Gruppe, dann den Server, für den Sie eine neue Datenbank hinzufügen möchten, und anschließend Datenbanken.

  3. Klicken Sie auf Datenbanken.

  4. Klicken Sie im Menü Vorgang auf Neue Datenbank.

    Das Dialogfeld Datenbankeigenschaften wird angezeigt.

  5. Geben Sie auf der Registerkarte Allgemein im Feld Name einen Namen für die neue Datenbank ein, und klicken Sie auf OK.

Diese Aktion erstellt eine neue Datenbank mit den Standardeinstellungen. Sie können die Standardeinstellungen ändern.

Anmerkung

  • Weitere Informationen zu SQL Server erhalten Sie, wenn Sie im Startmenü zunächst auf Programme und dann auf Microsoft SQL Server zeigen und anschließend auf Onlinedokumentation klicken.

Verwandte Themen

Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Ändern der Anwendungsidentität einer COM+-Anwendung

Nach der Erstellung der neuen COM+-Anwendung, die als Host für den XLANG-Ablaufplan dient, müssen Sie die Benutzerinformationen ändern. Weitere Informationen zum Erstellen einer neuen COM+-Hostanwendung für XLANG-Ablaufpläne finden Sie unter Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf die COM+-Anwendung, deren Identität Sie ändern möchten, und klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Komponentenname für die ausgewählte COM+-Anwendung wird angezeigt.

  4. Stellen Sie sicher, dass auf der Registerkarte Erweitert im Bereich Berechtigung das Kontrollkästchen Ändern deaktivieren deaktiviert ist, und klicken Sie auf OK.

    Das Dialogfeld Eigenschaften wird geschlossen.

  5. Klicken Sie mit der rechten Maustaste erneut auf die COM+-Anwendung, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Komponentenname für die ausgewählten COM+-Anwendung wird angezeigt.

  6. Klicken Sie auf der Registerkarte Identität im Bereich Konto auf Dieser Benutzer.

  7. Geben Sie die Informationen für das Konto ein, das verwendet werden soll.

  8. Klicken Sie auf OK.

    Es wird eine Fehlermeldung mit ungefähr folgendem Wortlaut angezeigt:

    Die Anwendungen wurden durch ein oder mehrere externe Produkte erstellt. Sind Sie sicher, dass die Änderungen, die Sie vornehmen möchten, von diesen Produkten unterstützt werden?

  9. Klicken Sie auf Ja.

Anmerkungen

  • Weitere Informationen zu Sicherheits- und Leistungsaspekten und den Anwendungsidentitätseinstellungen bei COM+-Anwendungen, die als Host für XLANG-Ablaufpläne dienen, finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Component Services".

Verwandte Themen

Ändern der Anwendungsidentität der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler)

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Ändern der DSN-Einstellungen für eine COM+-Anwendung

Beim Erstellen einer neuen, leeren Persistenzdatenbank müssen Sie die Einstellungen des Datenquellennamens (DSN) für die COM+-Anwendung erstellen, die als Host der dieser neuen Persistenzdatenbank zugeordneten XLANG-Ablaufpläne dient. Außerdem müssen Sie die Datenbanktabellen initialisieren.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf die COM+-Anwendung, deren DSN-Einstellungen Sie ändern möchten.

  4. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften für die ausgewählten COM+-Anwendung wird angezeigt.

  5. Aktivieren Sie auf der Registerkarte XLANG das Kontrollkästchen Datei-DSN verwenden.

  6. Klicken Sie auf DSN erstellen.

    Das Dialogfeld ODBC-Datenquellenadministrator wird angezeigt.

  7. Lesen Sie die Informationen im Meldungsdialogfeldfeld Datenbank erforderlich, und klicken Sie auf OK.

    Die Seite Neue Datenquelle erstellen wird angezeigt.

  8. Wählen Sie den Datenquellentyp aus, der verwendet werden soll. Klicken Sie auf Weiter.

  9. Wählen Sie in der Liste Wählen Sie einen Treiber aus, für den Sie eine Datenquelle erstellen möchten die Option SQL Server aus, und klicken Sie auf Weiter.

  10. Stellen Sie sicher, dass der Datenquellenname mit dem Namen der COM+-Anwendung übereinstimmt, die als Host für XLANG-Ablaufpläne dient. Klicken Sie auf Weiter und dann auf Fertig stellen.

    Wichtig

    • Der DSN und die COM+-Anwendung müssen denselben Namen tragen. Wenn beispielsweise die COM+-Anwendung den Namen XLANG-Ablaufplanung1 (XLANG Scheduler1) trägt, muss der DSN ebenfalls XLANG-Ablaufplanung1 lauten.

    Die Seite Neue Datenquelle für SQL Server erstellen wird geöffnet.

  11. Wählen Sie den Server aus, auf dem sich die neue Persistenzdatenbank befindet, die dieser COM+-Anwendung zugeordnet wird, und klicken Sie auf Weiter.

  12. Aktivieren Sie das Kontrollkästchen Mit Windows NT-Authentifizierung anhand des Benutzernamens im Netzwerk, und klicken Sie auf Weiter.

  13. Aktivieren Sie das Kontrollkästchen Die Standarddatenbank ändern auf, und wählen Sie die neue Persistenzdatenbank aus, die als Host dieser COM+-Anwendung dient.

  14. Klicken Sie auf Weiter und anschließend auf Fertig stellen.

  15. Klicken Sie auf der Registerkarte XLANG auf Tabellen initialisieren.

    Vorsicht

    • Bei diesem Verfahren wird davon ausgegangen, dass Sie eine neue, leere Persistenzdatenbank verwenden. Klicken Sie nicht auf Tabellen initialisieren, wenn Sie eine vorhandene Persistenzdatenbank verwenden. Dadurch würden alle bereits vorhandenen Daten in der Datenbank gelöscht.
  16. Klicken Sie im Meldungsdialogfeld Datenbankinitialisierung bestätigen auf Ja.

Anmerkungen

  • Es ist möglich, für einen Benutzer-DSN und einen System-DSN den gleichen Namen zu verwenden. Wenn Sie dies tun, können Sie jedoch auf der Eigenschaftenseite der XLANG-Anwendung nicht zwischen den beiden DSNs unterscheiden.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Component Services".

  • Weitere Informationen zum Konfigurieren eines DSN und zum Verwenden von Datenquellen (ODBC) erhalten Sie, indem Sie im Dialogfeld ODBC-Datenquellenadministrator auf Hilfe klicken.

Verwandte Themen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Herunterfahren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Wenden Sie dieses Verfahren an, um eine bestimmte COM+-Anwendung herunterzufahren.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie auf die COM+-Anwendung, die als Host für XLANG-Ablaufpläne dient, die Sie herunterfahren möchten.

  4. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften für die ausgewählte COM+-Anwendung wird angezeigt.

  5. Klicken Sie auf der Registerkarte XLANG im Bereich Kontrolliertes Herunterfahren auf Diese XLANG-Anwendung.

Vorsicht

  • Sie sollten nicht mit der rechten Maustaste auf eine COM+-Anwendung klicken und auf Herunterfahren klicken. Dadurch können folgende Probleme auftreten:
    • Falls die aktiven XLANG-Ablaufpläne vollständig transaktional sind, werden bei einem unkontrollierten Herunterfahren sämtliche "Bei Fehler"- und "Kompensierung"-Fehlerbehandlungsverfahren ausgelöst.

    • Sind die aktiven XLANG-Ablaufpläne nicht vollständig transaktional, gehen in Verarbeitung befindliche Daten im Ablaufplan verloren.

Wichtig

  • Pausierende XLANG-Ablaufpläne können nicht neu gestartet werden, wenn der Datenquellenname (DSN) nicht verfügbar oder fehlerhaft konfiguriert ist. Weitere Informationen zum Konfigurieren eines DSNs für eine COM+-Anwendung, die als Host für XLANG-Ablaufpläne dient, finden Sie unter Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne.

Anmerkungen

  • Beim Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne ist die Option Pausierende XLANG-Anwendungen neu starten nicht verfügbar. Weitere Informationen zum erneuten Starten von pausierenden Anwendungen finden Sie unter Neu starten aller XLANG-Anwendungen.

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Component Services".

Verwandte Themen

Ausführen von XLANG-Ablaufplänen

Ausführung von XLANG-Ablaufplänen

Herunterfahren aller XLANG-Anwendungen


Überwachen von aktiven XLANG-Ablaufplänen

Zur Überwachung aktiver XLANG-Ablaufpläne können Sie entweder den XLANG Event Monitor oder die Windows 2000-Ereignisanzeige verwenden.

  • XLANG Event Monitor. Wenn das XLANG-Ablaufplanungsmodul XLANG-Ablaufpläne ausführt, werden verschiedene Arten von Ereignissen generiert, die den Status der Ablaufplaninstanzen anzeigen. Mithilfe des XLANG Event Monitors können Sie XLANG-Ablaufplanereignisse überwachen und den Fortschritt der Ablaufplaninstanzen anzeigen. Sie können alle XLANG-Ablaufplanungsanwendungen (XLANG Scheduler), einschließlich der Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) und benutzerdefinierter COM+-Anwendungen, überwachen, die Sie als Hosts für XLANG-Ablaufpläne erstellt haben. Der XLANG Event Monitor kann alle Ereignisse abonnieren, die von den Hostanwendungen auf beliebig vielen lokalen oder verteilten Computern veröffentlicht wurden. Für spätere Untersuchungen kann der XLANG Event Monitor diese Ereignisse auch in einer Datei speichern.

    Weiterführende Informationen zum XLANG Event Monitor finden Sie in der zur Anwendung gehörenden Datei Readme.htm. Der XLANG Event Monitor (XLANGMon.exe) und die vom Microsoft BizTalk Server 2002 Setup-Assistent installierte Infodatei befinden sich beide im folgenden Installationsverzeichnis: \Programme\Microsoft BizTalk Server\SDK\XLANG-Tools.

  • Windows 2000-Ereignisanzeige. Die Windows 2000-Ereignisanzeige veröffentlicht Ereignismeldungen bezüglich der XLANG-Ablaufpläne. Weitere Informationen zum Anzeigen von Fehlermeldungen mithilfe der Ereignisanzeige finden Sie unter den folgenden Themen:
    • Informationen zum Konfigurieren der Ereignisanzeige zum Filtern nach Fehlermeldungen bezüglich XLANG-Ablaufplänen finden Sie unter Konfigurieren der Ereignisanzeige für BizTalk Server-Fehler.

    • Allgemeine Informationen zur Ereignisanzeige finden Sie in der Windows 2000 Server-Hilfe im Kapitel über die Ereignisanzeige unter "Verwenden der Ereignisanzeige".

Verwandtes Thema

Orchestration Services Error Messages


Problembehandlung - BizTalkServer-Verwaltung

BizTalk Server 2002 ~ Verwaltung

Problembehandlung - BizTalk Server-Verwaltung

Dieser Abschnitt stellt einen zentralen Ort für Informationen zur Problembehandlung in der BizTalk Server-Verwaltung bereit. Wenn Fehlermeldungen angezeigt werden, versuchen Sie, in diesem Abschnitt eine Lösung zu finden.

Ergänzende Informationen zu Problemen, die nach der Veröffentlichung dieser Microsoft®-Dokumentation zu BizTalk™ Server 2002 entdeckt wurden, befinden sich in der Readme-Datei im Ordner \Programme\Microsoft BizTalk Server\Documentation.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Zugriffsverweigerungsfehler erfolgen beim Zugriff auf die Microsoft Management Console (MMC) der BizTalk Server-Verwaltung, den BizTalk-Messaging-Manager und das BizTalk-Messaging-Konfigurationsobjektmodell

  • Fehler beim Abrufen aller Gruppen aus einer Datenbank

  • Austausch- und Dokumentgrößenbeschränkung

  • Transaktionstimeout-Abweichung zwischen den Komponentendiensten und BizTalk Server 2002

  • Der BizTalk-Messagingdienst startet nicht

  • Der BizTalk Server-Dienst fährt nicht herunter, wenn dem Server zu wenig Arbeitsspeicher zur Verfügung steht

  • Verringerte Leistung beim Löschen einer großen Menge von Dokumenten aus der Angehalten-Warteschlange

  • Überprüfungsfehler bei Ausgabe

  • Der Server gibt in einem Flatfileaustausch nicht alle Dokumente zurück

  • Klassenbezeichner wird nicht in der Präprozessorliste angezeigt

  • Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

  • BizTalk Server hat die Verarbeitung von Dokumenten unterbrochen

  • Die Empfangsfunktion löscht das Dokument nicht

  • Bei der HTTP-Übertragung werden möglicherweise Dokumente dupliziert

  • Die HTTP-Empfangsfunktion funktioniert nicht

  • Es kann keine Verbindung mit einem SQL-Server auf einem Clusterserver hergestellt werden

  • Die Empfangsfunktionen haben die Verarbeitung von Dokumenten abgebrochen

  • Fehler beim Verschieben eines Remoteservers in eine andere BizTalk-Messaging-Verwaltungsdatenbank

  • Analysefehler

  • Authentifizierungsprobleme treten auf, wenn IIS, der BizTalk-Messaging-Manager und SQL Server auf drei verschiedenen Computern ausgeführt werden

  • Setup und Messagingdienst schlagen fehl, wenn BizTalk Server 2002 mit SQL Server auf einem Cluster kommuniziert

  • Beim Senden von DBCS-Daten über einen SMTP-Messagingport treten fehlerhafte Zeichen auf

  • Redundantes oder gleichzeitiges Versenden von Dokumenten führt möglicherweise zu doppelten Instanzen

Anmerkungen

  • Sie können außerdem die Fehlermeldungen in der Angehalten-Warteschlange überprüfen, um weitere Informationen zur Problembehandlung zu erhalten. Weitere Informationen zu der Angehalten-Warteschlange, Fehlermeldungen und möglichen Vorgehensweisen finden Sie unter Angehalten-Warteschlange.

  • Sie können darüber hinaus das Ereignisprotokoll auf detaillierte Informationen überprüfen, wie z. B. Fehler- und Warnmeldungen. Weitere Informationen zum Ereignisprotokoll finden Sie unter Verwalten der Ereignisanzeige.


Zugriffsverweigerungsfehler erfolgen beim Zugriff auf die Microsoft Management Console (MMC) der BizTalk Server-Verwaltung, den BizTalk-Messaging-Manager und das BizTalk-Messaging-Konfigurationsobjektmodell

Ursache: BizTalk Server 2002 Setup fügt der Gruppe BizTalk Server-Administratoren die lokale Gruppe BUILTIN\Administratoren hinzu. Einem Benutzer, der zur Gruppe BUILTIN\Administratoren gehört, jedoch nicht explizit Mitglied der Gruppe BizTalk Server-Administratoren ist, wird die Berechtigung zum Zugriff auf die Microsoft Management Console (MMC) der BizTalk Server-Verwaltung, den BizTalk-Messaging-Manager und das BizTalk-Messaging-Konfigurationsobjektmodell verweigert.

Lösung: Verwenden Sie die Konsole Computerverwaltung, um einzelne Benutzer zur Gruppe BizTalk Server-Administratoren explizit hinzuzufügen.


Fehler beim Abrufen aller Gruppen aus einer Datenbank

Ursache 1: Die nobr>BizTalk-Messaging-Verwaltungsdatenbank ist im Offlinemodus, wenn die folgende Meldung angezeigt wird:

Instanzen von Microsoft BizTalkServer_Group können nicht aufgezählt werden: Die Verbindung zur BizTalk-Messaging-Verwaltungsdatenbank konnte nicht geöffnet werden.

Lösung: Finden Sie heraus, warum der Server im Offlinemodus ist, und versuchen Sie erneut, die Verbindung herzustellen, wenn er wieder im Onlinemodus ist. Beispielsweise können Sie diese Meldung erhalten, wenn der Server, der als Host für die BizTalk-Messaging-Verwaltungsdatenbank dient, zu Wartungszwecken im Offlinemodus betrieben wird.

Ursache 2: Das Konto des BizTalk Server-Messagingdienstes hat keinen Zugriff auf Microsoft® SQL Server™.

Lösung: Stellen Sie sicher, dass dem Konto des BizTalk Server-Messagingdienstes Zugriff auf Microsoft® SQL Server™ gewährt wurde. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.


Austausch- und Dokumentgrößenbeschränkung

Die maximal unterstützte Größe für ein an BizTalk Server gesendetes Dokument beträgt 20 MB. Die maximal unterstützte Größe für einen an BizTalk Server gesendeten Austausch beträgt 20 MB.

Wenn Sie beabsichtigen, Austauschvorgänge im XML-Unicodeformat zu empfangen, die größer als 20 MB sind, ist es ratsam, die globalen Überwachungseinstellungen zu deaktivieren. Wenn Sie beabsichtigen, Austauschvorgänge im ANSI-Flatfileformat zu empfangen, die größer als 7-10 MB sind, ist es ratsam, die Überwachung des Austauschtextkörpers und des Dokumenttextkörpers sowie die Dokumentprotokollierung in den Kanalkonfigurationen zu deaktivieren. Weitere Informationen zur Konfiguration von Überwachungseinstellungen für eine Servergruppe finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe. Weitere Informationen zu den Eigenschaften der Dokumentprotokollierung finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.

Gleichzeitig ist es ratsam, die Einstellungen zur Dokumentprotokollierung im BizTalk-Messaging-Manager zu deaktivieren, wenn Sie beabsichtigen, Dokumentinstanzen im XML-Unicodeformat mit einer Größe von mehr als 20 MB zu empfangen. Ebenso empfiehlt sich das Deaktivieren der Einstellungen zur Dokumentprotokollierung im BizTalk-Messaging-Manager, wenn Sie beabsichtigen, ANSI-Flatfiles zu empfangen, die größer als 7-10 MB sind. Weitere Informationen zum Speichern von Kopien bestimmter Dokumentinstanzen finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.

Verwandte Themen

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Festlegen von Eigenschaften für die Dokumentprotokollierung


Transaktionstimeout-Abweichung zwischen den Komponentendiensten und BizTalkServer2002

BizTalk Server 2002 ~ Verwaltung

Transaktionstimeout-Abweichung zwischen den Komponentendiensten und BizTalk Server 2002

Zwischen den Komponentendiensten und BizTalk Server 2002 gibt es eine Transaktionstimeout-Abweichung. Beim Senden einer Datei, die den Standardwert von 60 Sekunden für die Transaktionstimeout-Abweichung über BizTalk Server 2002 überschreitet, verzeichnet BizTalk Server die Transaktion als gesendet, und die Datei geht ohne Fehler beim empfangenden Server ein. Die Komponentendienste verzeichnen die Transaktion als abgebrochen. Es kann kein Rollback von Transaktionen durchgeführt werden.


Der BizTalk-Messagingdienst startet nicht

Ursache: Das Konto des BizTalk Server-Messagingdienstes hat keinen Zugriff auf SQL Server™. Der BizTalk-Messagingdienst startet nicht, wenn BizTalk Server keine Verbindung zu dem SQL-Server herstellen kann, auf dem die BizTalk-Messaging-Verwaltungsdatenbank gespeichert ist.

Lösung: Überprüfen Sie die Verbindung von BizTalk Server zur BizTalk-Messaging-Verwaltungsdatenbank. Stellen Sie sicher, dass Microsoft SQL Server ordnungsgemäß ausgeführt wird. Möglicherweise müssen Sie ein Dienstkonto für die Ausführung von BizTalk Server erstellen. Weitere Informationen zum Erstellen eines Dienstkontos finden Sie in der Microsoft® Windows® 2000-Hilfe im Kapitel über Dienste unter "So wählen Sie ein Benutzerkonto für die Anmeldung eines Dienstes aus". Stellen Sie sicher, dass dem Konto des BizTalk Server-Messagingdienstes Zugriff auf Microsoft® SQL Server™ gewährt wurde. Weitere Informationen finden Sie unter Erstellen einer SQL-Anmeldung und Erteilen des Datenbankzugriffs für die Anmeldung.


Der BizTalk Server-Dienst fährt nicht herunter, wenn dem Server zu wenig Arbeitsspeicher zur Verfügung steht

Ursache: Wenn der Server, auf dem BizTalk Server installiert ist, über zu wenig Arbeitsspeicher verfügt, versucht der BizTalk-Messagingdienst weiter, Dokumente zu verarbeiten. Alle Dokumente werden in der Angehalten-Warteschlange abgelegt.

Lösung: Starten Sie den BizTalk-Messagingdienst neu.


Verringerte Leistung beim Löschen einer großen Menge von Dokumenten aus der Angehalten-Warteschlange

Ursache: Möglicherweise bemerken Sie eine verminderte Leistung, wenn eine große Menge von Dokumenten aus der Angehalten-Warteschlange gelöscht wird.

Lösung: Wenn Sie alle Dokumente in der Angehalten-Warteschlange löschen müssen, sollten Sie PurgeBizTalkSuspendedQueue.vbs verwenden, ein Microsoft® Visual Basic®-Beispielskript, das zu diesem Zweck bereitgestellt wird. Nach der Installation von BizTalk Server 2002 finden Sie dieses Skript im Ordner \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\Miscellaneous.

Vorsicht

  • Verwenden Sie dieses Skript nur, wenn Sie den gesamten Inhalt der Angehalten-Warteschlange für die angegebene BizTalk Server-Gruppe permanent löschen möchten.


Überprüfungsfehler bei Ausgabe

Ursache 1: Der Datentyp eines Feldes in der Quellspezifikation stimmt nicht mit dem Datentyp des Feldes überein, mit dem es in der Zielspezifikation verknüpft ist. Dieser Fehler wird in der Ereignisanzeige protokolliert.

Lösung: Korrigieren Sie den Datentyp entweder in der Quell- oder in der Zielspezifikation. Weitere Informationen zu Quell- und Zielspezifikationen finden Sie unter Erstellen und Überprüfen von Spezifikationen.

Ursache 2: Ein Funktoid ist mit einem Feld in der Zielspezifikation verknüpft, und die Eigenschaft des Felddatentyps ist keine Zeichenfolge.

Lösung: Ändern Sie den Felddatentyp in der Zielspezifikation in String. Senden Sie das Dokument für die Verarbeitung an BizTalk Server. Weitere Informationen zu Datentypen finden Sie unter Festlegen von Deklarationseigenschaften.

Ursache 3: In der Zielspezifikation ist einem Feld ein konstanter Wert zugewiesen, der einen anderen Datentyp als den diesem Feld bereits zugewiesenen Datentyp aufweist.

Lösung: Ändern Sie in der Zielspezifikation den diesem Feld zugewiesenen Datentyp. Senden Sie das Dokument für die Verarbeitung an BizTalk Server. Weitere Informationen zu Datentypen finden Sie unter Festlegen von Deklarationseigenschaften.

Ursache 4: In EDIFACT-Daten befinden sich Versionsindikatoren. Die Versionszeichen werden in der logischen Zeichenzahl beim Überprüfen der maximalen physischen Zeichenbeschränkung für ein Feld mit erfasst. Dieser Fehler wird in der Ereignisanzeige protokolliert.

Lösung: Verwenden Sie in EDIFACT-Daten keine Versionsindikatoren. BizTalk Server fügt in ausgehende Daten bei Bedarf automatisch Versionsindikatoren ein.

Verwandte Themen

Erstellen und Überprüfen von Spezifikationen

Festlegen von Deklarationseigenschaften


Der Server gibt in einem Flatfileaustausch nicht alle Dokumente zurück

Ursache: Eines der Dokumente im Austausch entspricht nicht der Dokumentspezifikation. In einem der Dokumente kann z. B. ein erforderliches Feld fehlen.

Lösung: Suchen Sie das Dokument, das nicht der Spezifikation entspricht, korrigieren Sie dieses, und versenden Sie den Austausch erneut. Obwohl für das Dokument, das nicht der Spezifikation entspricht, ein Fehler zurückgegeben wird, kann BizTalk Server nicht alle Dokumente im Austausch verarbeiten. Die Flatfilestruktur ist ein offenes Format und nicht für die Implementierung der Redundanzüberprüfung ausgelegt.


Klassenbezeichner wird nicht in der Präprozessorliste angezeigt

Ursache: Der benutzerdefinierte Präprozessor ist nicht ordnungsgemäß registriert.

Lösung: Registrieren Sie den benutzerdefinierten Präprozessor erneut, oder wählen Sie in der Liste einen anderen Präprozessor aus.

Verwandte Themen

Konfigurieren einer Dateiempfangsfunktion: Registerkarte "Dienste"

Benutzerdefinierte Präprozessoren

Preprocessing Documents in a Receive Function


Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Ursache 1: BizTalk Server konnte den Austausch oder das Dokument nicht analysieren.

Lösung: Löschen Sie das Dokument aus der Angehalten-Warteschlange. Stellen Sie sicher, dass der eingehende Austausch oder das eingehende Dokument ein Format aufweist, das BizTalk Server verarbeiten kann (XML, X12, EDIFACT oder FLATFILE). Senden Sie es/ihn erneut von der ursprünglichen Organisation oder Anwendung.

Wenn BizTalk Server ein Dokument nicht analysieren kann, wird es in der Angehalten-Warteschlange als Binärdaten angezeigt, weil BizTalk Server nicht über ausreichende Informationen verfügt, um das Dokument korrekt zu verarbeiten. Weitere Informationen zu Analysefehlern finden Sie unter Analysefehler.

Ursache 2: BizTalk Server konnte den Austausch oder das Dokument analysieren, der Dateninhalt war jedoch ungültig. Der Zeitstempel "expiresAt" ist abgelaufen, und das Dokument ist nicht mehr gültig. Dieser Fehler tritt in BizTalk Framework-Dokumenten auf, die das Feld expiresAt verwenden.

Lösung: Löschen Sie das Dokument aus der Angehalten-Warteschlange. Dieses Dokument ist nicht mehr gültig. Finden Sie heraus, warum das Dokument nicht mehr gültig ist.

Ursache 3: BizTalk Server konnte das Dokument nicht analysieren, weil das Schema für das Dokument nicht korrekt ist. Wenn Sie eine Flatfile empfangen und die Codepage für die Dokumentspezifikation auf UTF-8 festgelegt ist, kann BizTalk Server das Dokument nicht analysieren, weil UTF-8 nicht unterstützt wird.

Lösung: Wenn Sie eine Flatfile empfangen, überprüfen Sie, ob die Dokumentspezifikation korrekt ist. Wenn die Codepage für die Dokumentspezifikation auf UTF-8 festgelegt ist, kann BizTalk Server das Dokument nicht verarbeiten. Löschen Sie das Dokument aus der Angehalten-Warteschlange. Weitere Informationen finden Sie unter Festlegen von Verweiseigenschaften.

Verwandte Themen

Analysefehler

Festlegen von Verweiseigenschaften

Angehalten-Warteschlange


BizTalkServer hat die Verarbeitung von Dokumenten unterbrochen

BizTalk Server 2002 ~ Verwaltung

BizTalk Server hat die Verarbeitung von Dokumenten unterbrochen

Ursache 1: BizTalk Server kann die Verarbeitung von Dokumenten nicht fortsetzen, wenn die Verbindung zu einer der drei Datenbanken - BizTalk-Messaging-Verwaltung, Überwachung oder Gemeinsam genutzte Warteschlangen - unterbrochen ist oder auf die Datenbanken aus anderen Gründen nicht zugegriffen werden kann. Dies kann geschehen, wenn Microsoft SQL Server in Enterprise Manager heruntergefahren oder angehalten wird. Wenn Microsoft BizTalk Server 2002 auf diesen Fehler trifft, wird der BizTalk-Messagingdienst ordnungsgemäß beendet, um den Status der Verarbeitung und die Integrität im Moment des Versagens korrekt zu speichern. Es wird ein Fehler mit vollständiger Beschreibung der Ursache für das Herunterfahren des Dienstes in der Ereignisanzeige aufgezeichnet.

Lösung: Systemadministratoren können diesen Fehler für eine Benachrichtigung über Pagerbenachrichtigung oder per Statusmitteilung über E-Mail verwenden, dass BizTalk Server im Offlinemodus ist. Bei einer solchen Benachrichtigung muss der Administrator die BizTalk-Messagingdienste im Dienste-Snap-In der Microsoft Management Console (MMC) manuell neu starten und anschließend das Ereignisprotokoll erneut überprüfen, um zu ermitteln, ob der Fehler noch vorhanden ist. Wenn dies der Fall ist, muss der Administrator bestätigen, dass die SQL Server-Dienste für BizTalk Server verfügbar sind. Weitere Informationen zum Starten der BizTalk-Messagingdienste finden Sie unter Starten eines BizTalk-Dienstes.

Ursache 2: Wenn Sie Antivirensoftware auf dem Server verwenden, auf dem BizTalk Server 2002 installiert ist, sind die Standardeinstellungen in einem Messagingport möglicherweise nicht korrekt.

Lösung: Die Standardeinstellung für die File-Transportkomponente ist das Anhängen von Dateien. Wenn Sie den Dateitransporttyp mit Standardeinstellungen in einem Messagingport auswählen und auf dem Server, auf dem BizTalk Server 2002 installiert ist, Antivirensoftware verwenden und Sie außerdem mehrere Dateien mit exakt gleichem Namen gleichzeitig an denselben Dateispeicherort senden, hört BizTalk Server 2002 möglicherweise auf zu reagieren und muss neu gestartet werden. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Dateitransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern. Sie können dieses Problem auch beheben, indem Sie für jede verarbeitete Dokumentinstanz eine eindeutige Datei mithilfe des Dateipfadformats im Messagingport erstellen: file://C:\dir\file%tracking_id%.xml. Weitere Informationen finden Sie unter Angeben einer Transportadresse. Wenn Sie den Server neu starten müssen, finden Sie weitere Informationen unter Starten eines Servers in einer Gruppe.

Verwandte Themen

Angeben einer Transportadresse

Starten eines BizTalk-Dienstes

Starten eines Servers in einer Gruppe


Die Empfangsfunktion löscht das Dokument nicht

Ursache: Möglicherweise ist das Wiederholungsintervall im Rahmen der Verarbeitungskapazität für die Anzahl der generierten Dokumente zu klein gewählt.

Lösung: Verdoppeln Sie das Wiederholungsintervall, und senden Sie die Dokumente erneut an BizTalk Server. Weitere Informationen zum Konfigurieren des Wiederholungsintervalls finden Sie unter Festlegen von erweiterten Konfigurationseigenschaften.


Bei der HTTP-Übertragung werden möglicherweise Dokumente dupliziert

Ursache: Wenn BizTalk Server Nachrichten mit dem HTTP-Transportdienst sendet, gibt es Szenarien, bei denen BizTalk Server eine Fehlerbenachrichtigung erhält, obwohl die Übertragung erfolgreich war. Ein Beispiel hierfür ist ein Übertragungstimeout. Bei einem Timeout wird die Verbindung zum HTTP-Server unterbrochen und ein Fehler gemeldet, obwohl der HTTP-Server die Anfrage möglicherweise erfolgreich verarbeitet. Bei einem Fehler versucht BizTalk Server, die Übertragung zu wiederholen, weil die erste Übertragung fehlgeschlagen ist. Das Ergebnis ist dann u. U. ein dupliziertes Dokument.

Lösung: Verwenden Sie Reliable Messaging, um sicherzustellen, dass die Übertragung über Protokolle, die wie z. B. HTTP nicht auf Transaktionen ausgelegt sind, nur einmal erfolgt. Weitere Informationen finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.


Die HTTP-Empfangsfunktion funktioniert nicht

Ursache 1: Die Datei BizTalkHTTPReceive.dll wurde vor der Erstellung einer HTTP-Empfangsfunktion nicht ordnungsgemäß bereitgestellt.

Lösung: Stellen Sie die Datei BizTalkHTTPReceive.dll bereit, bevor Sie eine HTTP-Empfangsfunktion erstellen. Weitere Informationen zum Hinzufügen einer HTTP-Empfangsfunktion erhalten Sie unter Hinzufügen einer HTTP-Empfangsfunktion.

Ursache 2: Wenn die Isolationsebene für das virtuelle IIS-Verzeichnis, das die Datei BizTalkHTTPReceive.dll enthält, niedrig ist, wurden die Internet-Informationsdienste (IIS) möglicherweise nicht für die Ausführung unter der Identität eines Benutzers mit den richtigen Anmeldeinformationen für BizTalk Server konfiguriert.

Lösung: Konfigurieren Sie IIS so, dass der Dienst unter der Identität eines Benutzers, der sowohl auf BizTalk Server-SQL-Datenbanken als auch auf die BizTalk-COM+-Anwendungen (BizTalk Server-Austauschanwendung und interne BizTalk-Messagingdienstprogramme) Zugriff hat. Beenden Sie dann den IIS-Dienst, und starten Sie ihn neu.

Ursache 3: Der Client verwendet nicht das richtige URL-Format und/oder codiert nicht für das virtuelle Verzeichnis, in dem HTTP (Hypertext Transfer Protocol) Daten an die HTTP-Empfangsfunktion sendet.

Lösung: Damit die HTTP-Empfangsfunktion ordnungsgemäß funktioniert, wenn der Client den URL festlegt, in dem die Daten über HTTP an die HTTP-Empfangsfunktion gesendet werden, muss es sich bei der Abfragezeichenfolge um eine MBCS-Zeichenfolge (Multibyte Character String) handeln, die mit der UTF-8-Codeseite codiert wurde. Weitere Informationen finden Sie in der MSDN Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "Support for Multibyte Character Sets" und "Encoding.UTF8 Property".


Es kann keine Verbindung mit einem SQL-Server auf einem Clusterserver hergestellt werden

Ursache 1: Wenn Microsoft SQL Server auf einem Cluster installiert wird, kann SQL Server nur Clients unterstützen, die Verbindungen mithilfe von TCP/IP herstellen.

Lösung: Installieren Sie die SQL Server-Clienttools, und ändern Sie die Standardnetzwerkbibliothek in TCP/IP. Weitere Informationen zum Installieren der SQL Server-Clienttools finden Sie unter Installieren der SQL Server-Clienttools. Weitere Informationen zum Ändern der Standardnetzwerkbibliothek finden Sie unter Ändern der Standard-Netzwerkbibliothek in TCP/IP.

Ursache 2: Das BizTalk Server-Konto hat keinen Zugriff auf SQL Server™.

Lösung: Stellen Sie sicher, dass dem Konto des BizTalk Server-Messagingdienstes Zugriff auf Microsoft® SQL Server™ gewährt wurde. Weitere Informationen finden Sie unter Sicherheitsrichtlinien.

Internationales Problem

Ursache 3: Die Installation von BizTalk Server auf einem Computer, auf dem Microsoft SQL Server nicht installiert ist, und der Versuch der Einrichtung einer BizTalk Server-Datenbank auf einem Remotecomputer mit SQL Server, auf dem eine andere Standardsprachversion von SQL Server ausgeführt wird, kann zu einem Fehler führen. Beim Ausführen des BizTalk Server 2002-Datenbankeinrichtungs-Assistenten wird möglicherweise folgende Fehlermeldung angezeigt:

Die in der Anmeldung angeforderte Datenbank kann nicht geöffnet werden <Datenbankname>. Fehler bei der Anmeldung.

Lösung: Erstellen Sie vor der Installation von BizTalk Server einen Beispielbenutzer-Datenquellennamen (DSN), um dieses Problem zu vermeiden.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Datenquellen (ODBC).

    Das Dialogfeld ODBC-Datenquellen-Administrator wird angezeigt.

  2. Klicken Sie auf die Registerkarte Benutzer-DSN und auf Hinzufügen.

    Das Dialogfeld Neue Datenquelle erstellen wird geöffnet.

  3. Klicken Sie in der Liste Name auf SQL Server, und klicken Sie auf Fertig stellen.

    Der Assistent Neue Datenquelle für SQL Server erstellen wird geöffnet.

  4. Vervollständigen Sie den Assistenten Neue Datenquelle für SQL Server erstellen, und erstellen Sie einen Beispielbenutzer-DSN.

Verwandte Themen

Ändern der Standard-Netzwerkbibliothek in TCP/IP

Installieren der SQL Server-Clienttools


Die Empfangsfunktionen haben die Verarbeitung von Dokumenten abgebrochen

Ursache 1: Ein einzelner Remoteserver kann nicht mehr als 50 Empfangsfunktionen zur gleichen Zeit unterstützen.

Lösung: Weitere Informationen zum Unterstützen mehrerer Empfangsfunktionen finden Sie in der Microsoft Product Support Services-Website unter search.support.microsoft.com/kb/c.asp?DU=C&LNG=GER&SA=PER. Suchen Sie in der Knowledge Base nach folgendem Artikel:

  • "IIS Runs Out of Work Items and Causes RPC Failures When Connecting to a Remote UNC Path" (Artikelnummer Q221790)

Weitere Informationen finden Sie in den folgenden Knowledge Base-Artikeln:

  • "Local System Account and Null Sessions in Windows NT" (Artikelnummer Q132679)

  • "Service Running As System Account Fails Accessing Network" (Artikelnummer Q124184)

  • "PRB: Access Denied When Opening a Named Pipe from a Service" (Artikelnummer Q126645)

  • "FindFirstChangeNotification May Not Notify All Processes on File Changes" (Artikelnummer Q188321)

Ursache 2: Wenn Sie Dateiempfangsfunktionen verwenden und andere Prozesse laufen, die Dateien zeitgleich mit BizTalk Server verwenden, ist es möglich, dass eine oder mehrere Dateiempfangsfunktionen die Verarbeitung von Dokumenten abbrechen und nicht mehr zur Verfügung stehen. Dies geschieht, wenn BizTalk Server eine Datei erfolgreich verarbeitet hat, diese jedoch nicht löschen kann, da eine andere Anwendung auf die Datei zugreift. Die Dateiempfangsfunktion wird deaktiviert, um sicherzustellen, dass die Daten nicht ein zweites Mal verarbeitet werden, wenn die andere(n) Anwendung(en) das Verwenden der Datei beenden.

Lösung: Um dieses Problem zu vermeiden, stellen Sie sicher, dass Dateien, die in von Dateiempfangsfunktionen überwachten Ordnern abgelegt werden, von anderen Anwendungen nicht aktiv verwendet werden. Dazu können auch Virenschutzprogramme gehören, die eingehende Dateien überwachen.

Ursache 3: Wenn bei der Message Queuing-Empfangsfunktion ein Dokument eingeht, das als Pass-Through-Versendung gesendet wurde, wird die Empfangsfunktion beendet und folgende Fehlermeldung angezeigt:

"Ändern Sie diese Empfangsfunktion, so dass Direktversendungen akzeptiert werden, oder entfernen Sie das Dokument aus der Warteschlange".

Lösung: Die Message Queuing-Empfangsfunktion akzeptiert keine Pass-Through-Versendung. Schreiben Sie eine Anwendung, welche die Warteschlange für die AppSpecific-Eigenschaft von Nachrichten in der Warteschlange untersucht, um zu ermitteln, welches Dokument als Pass-Through-Versendung durchgelaufen ist. Entfernen Sie das Dokument, und starten Sie die Empfangsfunktion neu.


Fehler beim Verschieben eines Remoteservers in eine andere BizTalk-Messaging-Verwaltungsdatenbank

Ursache: Wenn Sie versuchen, einen Remoteserver zu einer BizTalk-Messaging-Verwaltungsdatenbank hinzuzufügen, und sich dieser Server ursprünglich in einer anderen zentralen BizTalk-Messaging-Verwaltungsdatenbank befand, wird im Windows-Ereignisprotokoll der folgende Fehler angezeigt:

Eine neue Instanz der WMI-Klasse "MicrosoftBizTalkServer_Server" kann nicht im WMI-Provider von BizTalk Server erstellt werden. Der Server <servername> gehört möglicherweise bereits zu einer anderen BizTalk Server-Installation.

Dieser Fehler bedeutet, dass ein Versuch unternommen wurde, einen Remoteserver hinzuzufügen, der sich ursprünglich in einer anderen zentralen Datenbank befand. Wenn dieses Verfahren in der BizTalk Server-Verwaltung durchgeführt wurde, versucht die Verwaltungskonsole zu ermitteln, ob der Remoteserver ebenfalls zu einer Gruppe in der Remote-Zentraldatenbank gehört. Die Verwaltungskonsole fragt den WMI-Provider (Windows Management Instrumentation) des Remoteservers ab, um diese Ermittlung durchzuführen. Wenn der Server zu einer Gruppe in der anderen Zentraldatenbank gehört, wird eine Fehlermeldung der Verwaltungskonsole angezeigt, die erläutert, dass kein Remoteserver hinzugefügt werden kann, der bereits zu einer Gruppe in einer anderen Zentraldatenbank gehört.

Lösung: Entfernen Sie zuerst den Server aus der vorhergehenden Datenbank, und fügen Sie ihn dann zur aktuellen Datenbank hinzu.

Verwandtes Thema

Informationen zu WMI (Windows Management Instrumentation)


Analysefehler

Ursache 1: Wenn Sie Nachrichten im RELIABLE-Format senden, sind die Standardeinstellungen in einem Port möglicherweise nicht korrekt. Die Standardeinstellung für die File-Transportkomponente ist das Anhängen von Dateien. Wenn Sie den Dateitransporttyp mit Standardeinstellungen wählen und einen Umschlag mit dem Umschlagformat RELIABLE in einem Messagingport auswählen und dann mehrere Dateien gleichzeitig an denselben Dateispeicherort senden, können unerwartete Ergebnisse beim Analysieren auftreten.

Lösung: Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Dateitransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern. Weitere Informationen zum Ändern der Standardeinstellungen in einem Messagingport finden Sie unter Außerkraftsetzen von Messagingportstandards.

Andere Ursachen: BizTalk Server kann Dokumente aus einer Vielzahl von Gründen nicht analysieren. Einige häufige Ursachen sind:

  • Der Austausch oder das Dokument liegt in einem Format vor, das BizTalk Server nicht interpretieren kann.

  • Das Schema für das Dokument ist nicht korrekt.

  • Ein Flatfileaustausch weist ein falsches oder ungültiges Schema auf.

  • Ein Flatfileaustausch enthält ungültige Zeichen.

  • In einem Flatfileaustausch fehlen Zeichen.

  • In einem Flatfileaustausch fehlen Trennzeichen.

  • Für ein BizTalk Framework 2.0-Dokument ist ein ungültiger Aliasname im Messagingport oder Kanal aufgelistet.

  • In einer benutzerdefinierten XML-Kopfzeile fehlt der Dokumentcontainerknoten.

  • In einem benutzerdefinierten XML-Dokument fehlt ein Attribut.

  • Eine EDI-Dokumentspezifikation stimmt nicht mit dem Umschlag überein.

Lösung: Zeigen Sie die Austausch- oder Dokumentdaten an, um zu ermitteln, warum BizTalk Server den Austausch oder das Dokument nicht analysieren konnte. Sie können folgendermaßen vorgehen, um die Daten des Austauschs oder Dokuments anzuzeigen:

  • Zeigen Sie die ersten 512 Byte der Austausch- oder Dokumentdaten an. Weitere Informationen zum Anzeigen von Austausch- und Dokumentdaten finden Sie unter Anzeigen von Austauschvorgängen oder Anzeigen von Dokumenten.

  • Zeigen Sie die Austauschdaten im Austauschdatensatz in der BizTalk-Dokumentüberwachung an. Weitere Informationen zum Anzeigen von Austauschvorgängen in der BizTalk-Dokumentüberwachung finden Sie unter Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen, Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen, Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen oder Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern.

  • Verwenden Sie die WMI-Schicht (Windows Management Instrumentation), um die Austauschdaten anzuzeigen. Weitere Informationen zum WMI-Anwendungsprogrammierung finden Sie auf der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach "WMI Application Programming".

Nachdem Sie ermittelt haben, warum BizTalk Server das Dokument nicht analysieren konnte, korrigieren Sie das Problem, und versenden Sie den Austausch oder das Dokument erneut mithilfe von IInterchange oder einer Empfangsfunktion.

Verwandte Themen

Ein Austausch oder Dokument wird in der Angehalten-Warteschlange als Binärdaten angezeigt

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

Angehalten-Warteschlange

Anzeigen von Dokumenten

Anzeigen von Austauschvorgängen


Authentifizierungsprobleme treten auf, wenn IIS, der BizTalk-Messaging-Manager und SQL Server auf drei verschiedenen Computern ausgeführt werden

Ursache: Wenn Sie den BizTalk-Messaging-Manager, Internet-Informationsdienste (IIS) und Microsoft SQL Server auf drei verschiedenen Computern installieren, treten möglicherweise Authentifizierungsprobleme auf. Ursache hierfür ist ein doppelter Hop, d. h. die Anmeldungsinformationen werden vom BizTalk-Messaging-Manager auf dem Remoteclientcomputer A an einen BizTalk Server mit IIS auf Computer B (erster Hop) gesendet, aber IIS kann die Informationen nicht an die SQL Server-Konfigurationsdatenbank auf Computer C (zweiter Hop) senden.

Lösung: Konfigurieren Sie den BizTalk-Messaging-Manager (Remoteclient), IIS und SQL Server auf zwei statt auf drei Computern. Die folgenden Konfigurationen werden unterstützt:

  • Der BizTalk-Messaging-Manager und IIS befinden sich auf dem gleichen Computer, und SQL Server befindet sich auf einem zweiten Computer.

  • Der BizTalk-Messaging-Manager befindet sich auf dem einem Computer, und IIS und SQL Server befinden sich auf einem zweiten Computer.

Weitere Informationen zur IIS-Authentifizierung mehrerer Empfangsfunktionen finden Sie in der Microsoft Product Support Services-Website unter search.support.microsoft.com/kb/c.asp?DU=C&LNG=GER&SA=PER. Suchen Sie in der Knowledge Base nach folgendem Artikel: "INFO: How IIS Authenticates Browser Clients" (Artikelnummer Q264921).

Vorsicht

  • BizTalk Server muss auf dem gleichen Computer wie IIS installiert sein.

Anmerkung

  • Dieses Authentifizierungsproblem aufgrund eines doppelten Hops tritt auch dann auf, wenn der BizTalk-Messaging-Manager und die SQL Server-Konfigurationsdatenbank auf dem gleichen Computer und BizTalk Server und IIS auf einem zweiten Computer installiert wurden. Beachten Sie, dass diese Konfiguration nicht unterstützt wird.


Setup und Messagingdienst schlagen fehl, wenn BizTalk Server 2002 mit SQL Server auf einem Cluster kommuniziert

Wenn BizTalk Server 2002 auf einem eigenständigen Computer mit SQL Server-Datenbanken auf einem Microsoft Clusterdienste-Cluster installiert ist, zeigt das Installationsprogramm während der Installation der BizTalk Messaging-Verwaltungsdatenbank den folgenden Fehler an:

BizTalk Server konnte mit den Datenbank-Verbindungsinformationen nicht auf die Datenbank <Name der BizTalk-Messaging-Verwaltungsdatenbank> auf Server <SQL Server> zugreifen.

Dies ist ein Problem mit dem OLE DB-Provider von SQL Server in MDAC 2.6. Aktualisieren Sie auf MDAC 2.7 (wenn diese Version verfügbar ist), um dieses Problem zu lösen.


Beim Senden von DBCS-Daten über einen SMTP-Messagingport treten fehlerhafte Zeichen auf

Internationales Problem

Ursache: Wenn Sie Microsoft Data Access Components (MDAC), Version 2.5, installiert und einen SMTP-Messagingport konfiguriert haben, um beim Senden von Doppelbyte-Zeichensatzdaten (Double-Byte Character Set, DBCS) über diesen Port eine MIME-Codierung (Multipurpose Internet Mail Extensions) zu ermöglichen, werden diese Daten beschädigt. (MDAC 2.5 ist im Lieferumfang aller Versionen von Service Packs für Windows 2000 enthalten.)

Lösung: Installieren Sie MDAC 2.6, um dieses Problem zu vermeiden. Sie können MDAC 2.6 folgendermaßen installieren:

  • Wenn Sie MDAC 2.6 direkt installieren möchten, öffnen Sie den Browser, und gehen Sie zur Microsoft Universal Data Access-Website (www.microsoft.com/data), um diese Version zu downloaden.

  • Installieren Sie die SQL Server 2000-Clientdienstprogramme, die MDAC 2.6 enthalten.

Zu diesem Zeitpunkt ist keine Problemlösung vorhanden, die Sie sowohl für MDAC 2.5 als auch auf MDAC 2.6 anwenden können.


Redundantes oder gleichzeitiges Versenden von Dokumenten führt möglicherweise zu doppelten Instanzen

Ursache: Wenn mehrere Benutzer oder mehrere Instanzen der BizTalk Server-Verwaltung Batches desselben Dokuments erneut versenden, werden doppelte Instanzen in der Verarbeitungswarteschlange erstellt.

Lösung: Versenden Sie nicht dieselben Gruppen von Dokumenten von mehreren Instanzen zur gleichen Zeit.


Überwachen von Dokumenten

Die BizTalk-Dokumentüberwachung ist eine eigenständige Webanwendung, mit der Sie den Status der von Microsoft® BizTalk™ Server 2002 verarbeiteten Dokumente anzeigen können. Sie können einfache oder erweiterte Abfragen erstellen, um die gewünschten Informationen aus der Überwachungsdatenbank in einem übersichtlichen Format abzurufen. In der BizTalk-Dokumentüberwachung können Sie z. B. erfasste Informationen zu Quelle und Ziel des Dokuments, zum Dokumentnamen und zum Dokumenttyp sowie relevante Daten- und Zeitparameter anzeigen. Ferner können Sie Abfragen erstellen, mit denen standardmäßige und benutzerdefinierte Suchfelder angezeigt werden, damit Sie Geschäftsabläufe untersuchen können. Für jeden Auftrag, der an einen Lieferanten gesendet wird, kann z. B. das Feld Auftragssumme gespeichert werden. Anhand dieser Daten können Sie dann über einen Zeitraum den monetären Gesamtwert von Aufträgen an einen oder mehrere Lieferanten untersuchen und in Berichtform ausgeben.

Darüber hinaus können Sie die BizTalk-Dokumentüberwachung so konfigurieren, dass Austausch und Dokumentdatensätze einzeln oder in Batches angezeigt werden. Mithilfe der BizTalk-Dokumentüberwachung können Sie auch vollständige Kopien ein- und ausgehender Dokumentinstanzen zur künftigen Bezugnahme anzeigen, untersuchen und speichern.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ausführliche Informationen zur BizTalk-Dokumentüberwachung finden Sie unter Informationen zur BizTalk-Dokumentüberwachung.

  • Eine Kurzübersicht darüber, warum bestimmte Aufgaben durchgeführt werden müssen, finden Sie unter Gründe für das Durchführen von BizTalk-Dokumentüberwachungsaufgaben.

  • Detaillierte Anweisungen zum Ausführen von Aufgaben finden Sie unter Durchführen von BizTalk-Dokumentüberwachungsaufgaben.

  • Anweisungen zum Beheben von Problemen finden Sie unter Problembehandlung - BizTalk-Dokumentüberwachung.

Wichtig

  • Da die BizTalk-Dokumentüberwachung als Webanwendung in Microsoft Internet Explorer geöffnet wird, erfolgt ein anderer Zugriff auf die Microsoft BizTalk Server 2002-Hilfe, deren Funktionalität etwas eingeschränkt ist. Die Registerkarten Inhaltsverzeichnis, Index, Suchen und Favoriten stehen nicht zur Verfügung. Sie können auf alle Themen über Verknüpfungen auf der Eröffnungsseite, über die Verknüpfungen Verwandte Themen und über die Schaltfläche Zurück im Browser zugreifen.

    Wenn Sie nach einem bestimmten Hilfethema suchen oder Informationen zu anderen Funktionen und Diensten von BizTalk Server 2002 wünschen, zeigen Sie im Startmenü auf Programme, dann auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk Server-Dokumentation. Damit die Hilfe im Startmenü zur Verfügung steht, muss BizTalk Server 2002 auf dem Computer installiert sein.

  • Da die BizTalk-Dokumentüberwachung Microsoft ActiveX®-Steuerelemente verwendet, kann während einer Auswahl oder Übermittlung von Abfragen ein Dialogfeld zum Download von ActiveX-Steuerelementen angezeigt werden. Klicken Sie in diesem Fall auf Ja, um fortzufahren.

Anmerkung

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zur Zone Vertrauenswürdige Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren von IIS-Einstellungen für BizTalk Server 2002.


Informationen zur BizTalk-Dokumentüberwachung

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des Überwachens von Dokumenten und Aktivitäten sind.

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-Dokumentüberwachung - Umgebung

  • Verwenden der BizTalk-Dokumentüberwachung

  • Grundlegendes zum Schema der Überwachungsdatenbank

  • Grundlegendes zum Suchen von Austauschvorgängen und dazugehörigen Dokumenten

  • Grundlegendes zu Abfrageergebnissen

  • Grundlegendes zum integrierten XLANG-Ablaufplanstatus eines Austauschs

Anmerkung

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zur Zone Vertrauenswürdige Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren von IIS-Einstellungen für BizTalk Server 2002.


BizTalk-Dokumentüberwachung - Umgebung

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-Dokumentüberwachung – Benutzeroberfläche

  • BizTalk-Dokumentüberwachung - Tastenkombinationen


BizTalk-Dokumentüberwachung - Benutzeroberfläche

BizTalk Server 2002 ~ Überwachen von Dokumenten

BizTalk-Dokumentüberwachung – Benutzeroberfläche

Die BizTalk-Dokumentüberwachung ist eine eigenständige Webanwendung, mit der Sie Austauschvorgänge und Dokumente anzeigen können, die für die Überwachung in Microsoft BizTalk Server konfiguriert wurden. Die Hauptseite enthält sechs Bereiche:

  • Zeitraum

  • Quellauswahl

  • Zielauswahl

  • Erweiterte Abfrage

  • Sortiersteuerung

  • Auswahl des Dokumenttyps

Sie können Abfrageparameter unter Zeitraum, Quellauswahl, Zielauswahl und Auswahl des Dokumenttyps konfigurieren.

Unten links auf der Seite finden Sie die Bereiche Erweiterte Abfrage und Sortiersteuerung. Unter Erweiterte Abfrage können Sie Parameter konfigurieren, um bestimmte Informationen oder benutzerdefinierte Suchfelder zu suchen. Unter Sortiersteuerung können Sie Optionen konfigurieren, um die Sortierreihenfolge auf der Seite Abfrageergebnisse anzugeben.

Wenn Sie auf der Hauptseite auf die Schaltfläche Abfrage klicken, wird die Seite Abfrageergebnisse angezeigt. Falls Datensätze in der Überwachungsdatenbank den Abfrageparametern entsprechen, werden Austauschdatensätze in einer Liste angezeigt. Die folgende Tabelle beschreibt die Symbole, die auf der Seite Abfrageergebnisse zur Verfügung stehen.

Symbol | Zweck
Symbol "Daten" | Zugreifen auf Austausch- oder Dokumentinstanzdaten. Wenn Sie im Austauschdatensatz auf das Datensymbol klicken, werden die Austauschdaten angezeigt. Wenn Sie im Dokumentinstanz-Datensatz auf das Datensymbol klicken, werden die Dokumentdaten angezeigt.
Symbol "Erweiternindikator" | Erweitern des Austauschdatensatzes, um den Dokumentinstanz-Datensatz anzuzeigen.
Symbol "Ausblendenindikator" | Ausblenden des Austauschdatensatzes, damit der Dokumentinstanz-Datensatz nicht angezeigt wird.
Symbol "XLANG-Ablaufplan" | Anzeigen des zu einem Austausch gehörenden Status eines XLANG-Ablaufplanes.
Symbol "Empfangsbestätigung" | Anzeigen einer neuen Seite Abfrageergebnisse mit dem Inhalt der Empfangsbestätigung. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu den Ergebnissen von Empfangsbestätigungen.
Symbol "Benutzerdefinierte Suche" | Anzeigen benutzerdefinierter Suchdaten.


BizTalk-Dokumentüberwachung - Tastenkombinationen

Auf verschiedene Aufgaben in der BizTalk-Dokumentüberwachung können Sie über Tastenkombinationen zugreifen. Die folgende Tabelle enthält eine Kurzreferenz zu den Tastenkombinationen, die auf der Hauptseite zur Verfügung stehen.

Anmerkung

  • Um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind, können Sie mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen. Weitere Informationen zu Mauszeiger in der Windows 2000 Server-Hilfe finden Sie unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen finden Sie in der Windows 2000 Professional-Hilfe unter "Verschieben des Zeigers mit der Bildschirmtastatur".
Press | Zweck
ALT+N | Seite Generator für erweiterte Abfragen öffnen.
ALT+D | Seite Erweiterte Abfragen öffnen.
ALT+A | Erweiterte Abfrage aus der aktuellen Abfragesitzung löschen.
ALT+S | Alle Organisationen und Anwendungen in der Liste Quellauswahl auswählen.
ALT+T | Liste Quellauswahl löschen.
ALT+E | Alle Organisationen und Anwendungen in der Liste Zielauswahl auswählen.
ALT+A | Löschen der Liste Zielauswahl.
ALT+T | Alle Dokumenttypen in der Liste Auswahl des Dokumenttyps anzeigen.
ALT+U | Alle Dokumenttypen in der Liste Auswahl des Dokumenttyps auswählen.
ALT+L | Liste Auswahl des Dokumenttyps löschen.
ALT+F | Seite Abfrageergebnisse öffnen.
ALT+O | BizTalk-Dokumentüberwachung schließen.
ALT+H | Onlinehilfe anzeigen.
ALT+Unterstrichener Buchstabe oder unterstrichene Nummer eines Feldnamens | Fokus auf dieses Feld verschieben. ALT+1 verschiebt den Fokus beispielsweise auf Sortierreihenfolge 1.

Die folgende Tabelle beschreibt die Tastenkombinationen, die auf der Seite Abfrageergebnisse zur Verfügung stehen. Drücken Sie auf der Hauptseite ALT+Q, um die Seite Abfrageergebnisse zu öffnen.

Tastenkombination | Zweck
ALT+A | Seite Abfrageergebnisse schließen.
ALT+H | Onlinehilfe anzeigen.
LEERTASTE | Öffnen oder Schließen eines Symbols. Sie müssen die TAB-TASTE verwenden, um den Fokus auf das Symbol zu verschieben, das Sie öffnen oder schließen möchten. Wenn Sie z. B. einen Austauschdatensatz erweitern möchten, drücken Sie die TAB-TASTE, bis sich der Fokus auf dem Erweiterungssymbol (+) des ausgewählten Austauschdatensatzes befindet. Drücken Sie dann die LEERTASTE.

Die folgende Tabelle beschreibt die Tastenkombinationen, die auf der Seite Generator für erweiterte Abfragen zur Verfügung stehen. Drücken Sie auf der Hauptseite ALT+N, um die Seite Generator für erweiterte Abfragen zu öffnen.

Tastenkombination | Zweck
ALT+N | Bedingung zum erweiterten Abfrageausdruck hinzufügen.
ALT+E | Bedingung bearbeiten.
ALT+T | Bedingung aus einem erweiterten Abfrageausdruck entfernen.
ALT+S | Ausdruck speichern.
ALT+O | Verwendung dieses Ausdrucks auf die aktuelle Abfragesitzung beschränken.
ALT+A | Seite Generator für erweiterte Abfragen schließen.
ALT+H | Onlinehilfe anzeigen.
ALT+Unterstrichener Buchstabe in einem Feldnamen | Fokus auf dieses Feld verschieben. ALT+W verschiebt den Fokus z. B. auf das Feld Wert.

Anmerkung

  • Wenn Sie den Eingabefokus in den Bereich Abfrage bewegen und dort mehr als eine Bedingung vorhanden ist, wählen Sie die gewünschte Bedingung mit den NACH-OBEN- und NACH-UNTEN-TASTEN aus.

Die folgende Tabelle beschreibt die Tastenkombinationen, die auf der Seite Erweiterte Abfragen zur Verfügung stehen. Drücken Sie auf der Hauptseite ALT+D (stellen Sie vorher sicher, dass der Bereich Erweiterte Abfrage erweitert ist), um die Seite Erweiterte Abfragen zu öffnen.

Tastenkombination | Zweck
ALT+E | Vorhandenen Ausdruck bearbeiten.
ALT+N | Seite Generator für erweiterte Abfragen öffnen.
ALT+L | Ausdruck löschen.
ALT+O | Ausdruck zur aktuellen Abfrage hinzufügen.
ALT+A | Seite Erweiterte Abfragen ohne Speichern der Änderungen schließen.
ALT+H | Onlinehilfe anzeigen.


Verwenden der BizTalk-Dokumentüberwachung

Die BizTalk-Dokumentüberwachung dient folgenden Zwecken:

  • Überwachen von Austauschvorgängen und dazugehörigen Dokumenten, die von Microsoft BizTalk Server 2002 verarbeitet werden.

  • Erfüllen rechtlicher und/oder von Normanforderungen an die Aufbewahrung von Kopien aller elektronischen Geschäftstransaktionen.

  • Das schnelle und einfache Beantworten von Kundenfragen. Wenn z. B. ein Kunde fragt: "Wann wurde an Handelspartner A eine Rechnung geschickt?", können Sie das Datum und die Uhrzeit ermitteln und feststellen, ob vom Handelspartner eine Empfangsbestätigung zurückgesendet wurde.

  • Hilfe bei der Problembehandlung.

  • Hilfe beim Lösen von Konflikten.

Dokumente können entweder in Batches oder als einzelne Transaktionen überwacht werden. Die BizTalk-Dokumentüberwachung speichert automatisch Metadaten, die mit einem Austausch verknüpft sind, wie z. B. Quell- und Zielinformationen, Dokumenttyp sowie Datums- und Zeitparameter. Metadaten werden automatisch gespeichert. Zusätzliche Felder, wie z. B. Auftragsdatum oder Auftragssumme, werden jedoch nur erfasst, wenn das BizTalk-Messaging-Konfigurationsobjektmodell oder der BizTalk-Messaging-Manager für die Erfassung dieser Informationen konfiguriert sind. Weitere Informationen zum Konfigurieren ausgewählter zu überwachender Felder finden Sie unter Festlegen von Kanaleigenschaften und Festlegen der Überwachung für Eigenschaften von eingehenden Dokumenten.

Alle Überwachungsinformationen, entweder die Metadaten oder die für die Überwachung konfigurierten Felder, werden in der Überwachungsdatenbank gespeichert, die Sie während der Installation oder bei der Einrichtung einer Servergruppe konfiguriert haben. Über die Benutzeroberfläche der BizTalk-Dokumentüberwachung können Sie auf die Daten zugreifen, die in der Überwachungsdatenbank gespeichert sind, welche einer bestimmten Servergruppe zugeordnet ist. Wenngleich nicht auf alle in der Überwachungsdatenbank gespeicherten Informationen zur Benutzeroberfläche zugegriffen werden kann, stehen die Metadaten und die für die Überwachung konfigurierten Felder unmittelbar zur Verfügung. Wenn Sie z. B. überwachen möchten, wann die Einkaufsanwendung C einen Auftrag an Handelspartner D gesendet hat und wann Handelspartner D auf den Auftrag reagiert hat, stellt Ihnen die BizTalk-Dokumentüberwachung alle gewünschten Informationen zur Verfügung.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu den Überwachungseinstellungen einer Servergruppe

  • Grundlegendes zu den Überwachungseinstellungen im BizTalk-Messaging-Manager

Anmerkung

  • Auf der Benutzeroberfläche der BizTalk-Dokumentüberwachung werden keine Reliable Messaging-Bestätigungen angezeigt.

Verwandte Themen

Festlegen von Kanaleigenschaften

Festlegen der Überwachung von Eigenschaften eingehender Dokumente

Überwachungsdatenbank


Grundlegendes zu den Überwachungseinstellungen einer Servergruppe

Die Überwachungseinstellungen einer Servergruppe ermitteln, ob das Überwachen von Austauschvorgängen aktiviert oder deaktiviert ist. Diese globale Überwachungseinstellung wird in der BizTalk Server-Verwaltung konfiguriert. Weitere Informationen zur Konfiguration von Überwachungseinstellungen für eine Servergruppe finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe. Wenn die Option Dokumentüberwachung aktivieren aktiviert ist, können Sie BizTalk Server so konfigurieren, dass eingehende und ausgehende Austauschvorgänge sowie ursprünglich MIME-codierte Nachrichten protokolliert werden.

Nach der Installation von Microsoft BizTalk Server 2002 ist die Dokumentüberwachung automatisch aktiviert, die Protokollieroptionen für ein- und ausgehende Austauschvorgänge sind ausgewählt und Metadaten für Austauschvorgänge werden überwacht, wie z. B.:

  • Quellorganisationsinformationen

  • Zielorganisationsinformationen

  • Dokumenttyp

  • Datum und Zeitpunkt der Verarbeitung des Austauschs durch BizTalk Server

  • Dokumentanzahl

  • Fehlerinformationen

  • Kontroll-ID

Zusätzlich zur Überwachung von Austauschvorgängen kann BizTalk Server auch für die Überwachung bestimmter Felder, wie z. B. Auftragssumme oder Rechnungssumme, konfiguriert werden. Weitere Informationen zur Überwachung bestimmter Felder finden Sie unter Grundlegendes zu den Überwachungseinstellungen im BizTalk-Messaging-Manager. Wenn Sie zum Zweck der Nichtabstreitbarkeit oder aus handelsrechtlichen Gründen eine Kopie von Austauschvorgängen im ursprünglichen Format benötigen, verwenden Sie die globalen Überwachungseinstellungen. Falls Sie für interne Zwecke eine Überwachungsliste erstellen möchten oder einen einfachen Zugriff auf Daten auf dokumentorientierter Basis benötigen, können Sie Überwachungseinstellungen im BizTalk-Messaging-Konfigurationsobjektmodell oder im BizTalk-Messaging-Manager konfigurieren. Allerdings kann dadurch die Größe der Überwachungsdatenbank rasch zunehmen, da Daten doppelt gespeichert werden.

Deaktivieren von Einstellungen der BizTalk-Dokumentüberwachung

Wenn Dokumente nicht überwacht werden müssen, können Sie die BizTalk-Dokumentüberwachung deaktivieren. Dadurch verzichten Sie allerdings auf wichtige Funktionen. Bei deaktivierter Dokumentüberwachung ist Folgendes z. B. nicht möglich:

  • Das Überwachen von Austauschvorgängen und dazugehörigen Dokumenten beim Durchlaufen von BizTalk Server 2002.

  • Das Erfüllen rechtlicher Anforderungen und/oder Normanforderungen an die Aufbewahrung von Kopien aller elektronischen Geschäftstransaktionen.

  • Das schnelle und einfache Beantworten von Kundenfragen. Wenn z. B. ein Kunde fragt: "Wann wurde an Handelspartner A eine Rechnung geschickt?", können Sie das Datum und die Uhrzeit ermitteln und feststellen, ob eine Empfangsbestätigung zurückgesendet wurde.

  • Hilfe bei der Problembehandlung.

  • Hilfe beim Lösen von Konflikten.

In der BizTalk Server-Verwaltung können Sie die Dokumentüberwachung aktivieren oder deaktivieren sowie die globalen Überwachungseinstellungen ändern. Weitere Informationen zur Konfiguration von Überwachungseinstellungen für eine Servergruppe finden Sie unter Konfigurieren von Überwachungseigenschaften für eine Servergruppe.

Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, auf Microsoft BizTalk Server 2002, und klicken Sie auf BizTalk Server-Verwaltung, um die BizTalk Server-Verwaltung zu öffnen.

  • Für das Überwachen von Austauschvorgängen und Dokumenten gibt es eine Größenbeschränkung. Weitere Informationen zur Größenbeschränkung finden Sie unter Austausch- und Dokumentgrößenbeschränkung.

Verwandte Themen

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Austausch- und Dokumentgrößenbeschränkung

Öffnen der BizTalk Server-Verwaltung

Grundlegendes zu den Überwachungseinstellungen im BizTalk-Messaging-Manager


Grundlegendes zu den Überwachungseinstellungen im BizTalk-Messaging-Manager

Konfigurieren Sie die Überwachungseinstellungen im BizTalk-Messaging-Manager, wenn Folgendes erforderlich ist:

  • Das Speichern vollständiger Kopien ein- und ausgehender Dokumentinstanzen.

  • Das Konfigurieren bestimmter zu erfassender Felder, wie z. B. Auftragssumme oder Auftragsdatum.

Im Gegensatz zur Überwachung der Eigenschaften einer Servergruppe ist das Überwachen bestimmter Felder oder Speichern von Kopien von Dokumentinstanzen nicht automatisch aktiviert. Sie müssen diese Optionen konfigurieren, wenn Sie den bzw. die entsprechenden Kanäle und/oder Dokumentdefinitionen im BizTalk-Messaging-Manager konfigurieren.

Weitere Informationen zum Speichern von Kopien ein- und ausgehender Dokumentinstanzen finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung. Weitere Informationen zum Überwachen bestimmter Felder finden Sie unter Auswählen von Spezifikationsfeldern in einem Kanal.

Anmerkungen

  • Zeigen Sie im Startmenü auf Programme, auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Messaging-Manager, um den BizTalk-Messaging-Manager zu öffnen.

  • Für das Überwachen und Speichern von Dokumenten gibt es eine Größenbeschränkung. Weitere Informationen zur Größenbeschränkung finden Sie unter Austausch- und Dokumentgrößenbeschränkung.

  • Beim Überwachen von Spezifikationsfeldern als Datentyp Integer, Real, Date oder Text werden die Namen von Spezifikationsfeldern mit mehr als 79 Zeichen abgeschnitten.

    Überwachen Sie diese Spezifikationsfelder als Custom-Datentyp. Dies führt dazu, dass die Feldnamen gemeinsam mit den Feldwerten in der SQL-Spalte ntext gespeichert werden, die eine maximale Länge von 2^30 - 1 (1.073.741.823) Zeichen erlaubt.

  • Wenn Sie Details und Empfangsbestätigungsstatus eines Dokuments nicht finden können, ist möglicherweise in der BizTalk Server-Verwaltung das Kontrollkästchen Dokumentverwaltung aktivieren nicht aktiviert. Wenn dieses Kontrollkästchen nicht aktiviert ist, können Empfangsbestätigungen nicht korreliert werden.

    Führen Sie folgende Schritte zum Aktivieren der Dokumentüberwachung durch:

    1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk Server-Verwaltung.

    2. Erweitern Sie Microsoft BizTalk Server 2002 in der BizTalk Server-Verwaltung, klicken Sie mit der rechten Maustaste auf die BizTalk-Servergruppe, für die Sie die Einstellungen für die Dokumentüberwachung ändern möchten, und klicken Sie dann auf Eigenschaften.

    3. Aktivieren Sie auf der Registerkarte Überwachen das Kontrollkästchen Dokumentüberwachung aktivieren.

    Wählen Sie alle anderen Optionen, die Sie verwenden möchten, aus.

Internationales Problem

  • Je nach Systemgebietsschema kann ein numerischer Wert in XML-Daten von BizTalk Server falsch interpretiert werden, wenn dieser als ganzzahliges Überwachungsfeld in der Überwachungsdatenbank protokolliert wird. Bei einem deutschen Gebietsschema wird der XML-Zahlenwert 4.0 in der Überwachungsdatenbank als 40 protokolliert, da das Dezimaltrennzeichen (.) als Symbol für die Zifferngruppierung falsch interpretiert wird.

    Für dieses Problem gibt es zwei Lösungen. Wenn Sie im Voraus wissen, dass der Element-/Attributwert eine Dezimalzahl speichert, können Sie den Element-/Attributdatentyp in Real (r4) oder Double Real (r8) ändern. Alternativ können Sie die Dokumentdefinition oder den Kanal so konfigurieren, dass ein Element/Attribut mit dem Datentyp Number als Real oder Integer protokolliert wird.

Verwandte Themen

Austausch- und Dokumentgrößenbeschränkung

Auswählen von Spezifikationsfeldern in einem Kanal

Festlegen von Eigenschaften für die Dokumentprotokollierung

Grundlegendes zu den Überwachungseinstellungen einer Servergruppe


Grundlegendes zum Schema der Überwachungsdatenbank

Alle Server einer Servergruppe verwenden gemeinsam eine Überwachungsdatenbank, in der alle Informationen zur Austausch- und Dokumentaktivität in BizTalk Server gespeichert werden. Die Überwachungsdatenbank dient dem Überwachen des Status eines Austauschs oder Dokuments auf seinem Weg durch den Server. Die drei Haupttabellen in der Überwachungsdatenbank heißen:

  • dta_interchange_details

  • dta_outdoc_details

  • dta_indoc_details

Die unterstützenden Tabellen heißen:

  • dta_group_details

  • dta_interchange_data

  • dta_document_data

  • dta_debug_data

  • dta_routing_details

  • dta_custom_field_names

  • dta_MIME_data

Die folgende Abbildung veranschaulicht das allgemeine Datenbankschema der Überwachungsdatenbank. Zur besseren Übersichtlichkeit sind in der Abbildung nur die Tabellennamen aufgeführt. Die Linien zwischen den Tabellen verdeutlichen, wie die Tabellen über Fremdschlüsselfelder verbunden sind. Diese Schlüsselfelder und ihre Beziehungen zu anderen Tabellen werden ausführlich unter den Themen Struktur der Haupttabellen für Metadaten und Struktur sekundärer Tabellen beschrieben.

Schema der Überwachungsdatenbank

Folgende Themen werden in diesem Abschnitt behandelt:

  • Haupttabellen für Metadaten

  • Sekundäre Tabellen

  • Struktur der Haupttabellen für Metadaten

  • Struktur sekundärer Tabellen

  • Verknüpfte Tabellen

  • Protokollieren von Austauschvorgängen und Dokumenten

  • Protokollieren von Empfangsbestätigungen

  • Protokollieren von Routinginformationen

  • Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank


Haupttabellen für Metadaten

Die Haupttabellen speichern die Metadaten von Austauschvorgängen, die von BizTalk Server verarbeitet werden. Zu den Metadaten zählen Informationen zur Quell- und Zielorganisation, der Dokumenttyp, Datum und Uhrzeit der Verarbeitung des Austauschs, die Dokumentanzahl, Fehlerinformationen und die Kontroll-ID.

Die Metadaten sind in der Überwachungsdatenbank in den folgenden drei Haupttabellen enthalten:

  • dta_indoc_details

  • dta_outdoc_details

  • dta_interchange_details

Die folgende Tabelle beschreibt die Funktion jeder Haupttabelle.

Tabellenname | Beschreibung
dta_indoc_details | Enthält einen Datensatz für jedes an BizTalk Server gesendete Dokument.
dta_outdoc_details | Enthält einen Datensatz für jedes von BizTalk Server generierte Dokument. Ein an BizTalk Server gesendetes Dokument kann aus einem oder mehreren generierten Dokumenten resultieren, die aufgrund mehrerer Kanalübereinstimmungen und Portgruppen an verschiedene Ziele übermittelt werden. Die Trennung von ein- und ausgehenden Dokumenten in zwei Tabellen ermöglicht eine physische Darstellung dieser 1:n-Beziehung.
dta_interchange_details | Enthält einen Datensatz für jeden von BizTalk Server verarbeiteten Austausch. Ein Richtungskennzeichen für diese Tabelle unterscheidet Versendungen von Übertragungen.

Verwandtes Thema

Struktur der Haupttabellen für Metadaten


Sekundäre Tabellen

Die sieben sekundären Tabellen, welche die Haupttabellen der Metadaten unterstützen, heißen:

  • dta_document_data

  • dta_debugdoc_data

  • dta_interchange_data

  • dta_routing_details

  • dta_group_details

  • dta_custom_field_names

  • dta_MIME_data

In diesen Tabellen werden unterstützende Informationen gespeichert, wie z. B. Dokumentdaten, Routinginformationen und Informationen zu benutzerdefinierten Suchen. Die folgende Tabelle beschreibt die Funktion jeder Tabelle.

Tabellenname | Beschreibung
dta_document_data | Enthält einen Datensatz für jedes an oder von BizTalk Server gesendete Dokument.
dta_debugdoc_data | Enthält für jedes inDoc- oder outDoc-Element, das (für das Messagingkanalobjekt) konfiguriert ist, eine Zeile, in der dessen XML-Zwischenformat aufgezeichnet wird.
dta_interchange_data | Enthält für jeden an oder von BizTalk Server gesendeten Austausch eine Zeile. In dieser Tabelle werden auch Antwortdokumente gespeichert, die an die IInterchange::SubmitSync aufrufende Anwendung zurückgegeben werden.
dta_routing_details | Fungiert als Spiegel der Messagingports, um eine datenbankübergreifende Abhängigkeit der BizTalk-Messaging-Verwaltungsdatenbank zu vermeiden. Insbesondere ist es erforderlich, die Quell- und Zielinformationen hinsichtlich der verarbeiteten Dokumente zu überwachen. Diese Informationen, die aus der BizTalk-Messaging-Verwaltungsdatenbank stammen, werden hier wiederholt, während neue Permutationen auftreten.
dta_group_details | Stellt Erweiterungskomponenten (Parser, Serialisierung und Empfangsbestätigungskorrelation) für Dokumentformate bereit, die verwandte Dokumentgruppen (z. B. X12 oder EDIFACT) innerhalb eines Austauschs verwenden. Diese Tabelle enthält für jede von diesen Komponenten analysierte oder serialisierte Gruppe eine Zeile.
dta_custom_field_names | Enthält für jedes getrennte Paar aus Erfassungsfeld-Knotennamen und Datentyp, das von BizTalk Server entdeckt wird, eine Zeile. Diese Tabelle ist ein Querverweis auf die dta_outdoc_details-Tabelle, die einen Fremdschlüssel für diese Tabelle für ihre Erfassungsfeldnamen verwendet. Die dta_indoc_details-Tabelle ist indirekt durch das Vorhandensein eines Fremdschlüssels mit diesen Feldnamen verbunden, der von der dta_outdoc_details-Tabelle auf seinen übergeordneten Schlüssel in der dta_indoc_details-Tabelle verweist.
dta_MIME_data | Enthält für jeden MIME-codierten Austausch, der an BizTalk Server gesendet wird, eine Zeile. Mithilfe dieser Tabelle können MIME-Daten überwacht werden, die Anlagen enthalten.

Verwandtes Thema

Struktur sekundärer Tabellen


Struktur der Haupttabellen für Metadaten

Die Hauttabellen für Metadaten sind, wie in diesem Abschnitt beschrieben, verknüpft und speichern die Metadaten aller Austauschvorgänge, die von BizTalk Server verarbeitet werden, wenn die Überwachungseinstellungen konfiguriert sind. Weitere Informationen zur Konfiguration von Überwachungseinstellungen für eine Servergruppe finden Sie unter Grundlegendes zu den Überwachungseinstellungen einer Servergruppe.

dta_indoc_details

Diese Tabelle hat eine 1:n-Beziehung mit der folgenden Tabelle:

  • dta_outdoc_details

Diese Tabelle hat eine n:1-Beziehung mit den folgenden Tabellen:

  • dta_group_details

  • dta_interchange_details

  • dta_error_message

  • dta_validity_values

Diese Tabelle hat eine 1:1-Beziehung mit den folgenden Tabellen:

  • dta_debugdoc_data

  • dta_document_data

Die dta_indoc_details-Tabelle enthält pro Dokument, das an BizTalk Server gesendet wird, eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_indoc_details-Tabelle.

Feldname | Beschreibung
nInDocKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nDocumentDataKey | Fremdschlüssel der dta_document_data-Tabelle.
nDebugDocDataKey | Fremdschlüssel der dta_debugDoc_data-Tabelle für das XML-Format des empfangenen Dokuments, auch wenn das empfangene Dokument XML-formatiert ist.
nGroupKey | Fremdschlüssel der dta_group_details-Tabelle.
nInterchangeKey | Fremdschlüssel der dta_interchange_details-Tabelle.
uidTrackingGUID | Wert des Hauptüberwachungsschlüssels, der auf einem globalen eindeutigen Bezeichner (GUID) basiert.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes.
nvcSyntax | Code der Dokumentsyntax (XML, X12, EDIFACT, HL7 usw.). Sollte die Syntax aufgrund eines Analysefehlers oder einer Pass-Through-Versendung nicht erkannt werden, hat dieses Feld den Wert UNBEKANNT.
nvcVersion | Version der Syntax.
nvcRelease | Release der Version.
nvcDocType | Dokumenttyp oder Bezeichner der Transaktionsmenge.
nvcControlID | Eindeutige Kontrollnummer für EDI-Dokumente und Funktionsgruppen.
nlsValid | Code, der Überprüfungsergebnisse angibt. Mögliche Werte sind 0 (ungültig), 1 (gültig) und 2 (Pass-Through).
nError | Code, der das Auftreten eines Fehlers meldet. Dies ist der Fremdschlüssel von dta_error_message, der Tabelle mit den Beschreibungen der Fehlermeldungen.

dta_outdoc_details

Diese Tabelle hat eine n:1-Beziehung mit den folgenden Tabellen:

  • dta_indoc_details

  • dta_interchange_details

  • dta_group_details

  • dta_debugDoc_data

  • dta_routing_details

  • dta_error_message

  • dta_ack_status

  • dta_data_level_values

  • dta_validity_values

Diese Tabelle hat eine 1:1-Beziehung mit der folgenden Tabelle:

  • dta_document_data

Diese Tabelle hat eine n:n-Beziehung mit den folgenden Tabellen:

  • dta_custom_field_names

  • dta_ack_status_values

Die dta_outdoc_details-Tabelle enthält pro Dokument, das von BizTalk Server gesendet wird, eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_outdoc_details-Tabelle.

Feldname | Beschreibung
nOutDocKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nInDocKey | Fremdschlüssel des übergeordneten dta_indoc_details-Datensatzes.
nDocumentDataKey | Fremdschlüssel der dta_document_data-Tabelle.
nDebugDocDataKey | Fremdschlüssel der dta_debugDoc_data-Tabelle für das XML-Format des ausgehenden Dokuments, auch wenn das ausgehende Dokument XML-formatiert ist. Wird ein ausgehendes Dokument an eine Portgruppe gesendet, wird nur eine Kopie des dta_debugDoc_data-Datensatzes gespeichert, auf den alle sich ergebenden dta_outdoc_details-Datensätze zeigen.
nGroupKey | Fremdschlüssel der dta_group_details-Tabelle.
nInterchangeKey | Fremdschlüssel der dta_interchange_details-Tabelle.
uidTrackingGUID | Wert des Hauptüberwachungsschlüssels, der auf einem globalen eindeutigen Bezeichner (GUID) basiert.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes.
nvcSyntax | Code der Dokumentsyntax (XML, X12, EDIFACT, HL7 usw.). Sollte die Syntax aufgrund eines Analysefehlers oder einer Pass-Through-Versendung nicht erkannt werden, hat dieses Feld den Wert UNBEKANNT.
nvcVersion | Version der Syntax.
nvcRelease | Release der Version.
nvcDocType | Dokumenttyp oder Bezeichner der Transaktionsmenge.
nvcControlID | Eindeutige Kontrollnummer für EDI-Dokumente und Funktionsgruppen.
nlsValid | Code, der Überprüfungsergebnisse angibt. Mögliche Werte sind 0 (ungültig), 1 (gültig) und 2 (Pass-Through).
nError | Code, der das Auftreten eines Fehlers meldet. Dies ist der Fremdschlüssel von dta_error_message, der Tabelle mit den Beschreibungen der Fehlermeldungen.
nAckStatus | Code des Empfangsbestätigungsstatus. Dies ist der Fremdschlüssel von dta_ack_status_values, der Tabelle mit den Beschreibungen der Statuswerte der Empfangsbestätigungen.
nRoutingKey | Fremdschlüssel der dta_routing_details-Tabelle.
nReceiptFlag | Ein Kennzeichen, das angibt, welcher Tabelle eine Empfangsbestätigung zugeordnet ist. Mögliche Werte sind 1 (Austausch), 2 (Gruppe), 4 (eingehendes Dokument), 8 (ausgehendes Dokument). Weitere Informationen zu Empfangsbestätigungen finden Sie unter Protokollieren von Empfangsbestätigungen.
nReceiptKey | Ein eindeutiger Wert zur Identifizierung der Empfangsbestätigung. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Protokollieren von Empfangsbestätigungen.
dtReceiptDueBy | Zeitstempel des Empfangsbestätigung-Endtermins, der entsprechend dem Verarbeitungszeitstempel berechnet wird.
nRealName1 | Fremdschlüssel der dta_custom_field_names-Tabelle.
rlRealValue1 | 1. Erfassungsfeld für reelle Zahlen. Dieses Feld muss einen reellen 8-Byte-Wert enthalten.
nRealName2 | Fremdschlüssel der dta_custom_field_names-Tabelle.
rlRealValue2 | 2. Erfassungsfeld für reelle Zahlen. Dieses Feld muss einen reellen 8-Byte-Wert enthalten.
nIntName1 | Fremdschlüssel der dta_custom_field_names-Tabelle.
nIntValue1 | Erstes Ganzzahl-Erfassungsfeld.
nIntName2 | Fremdschlüssel der dta_custom_field_names-Tabelle.
nIntValue2 | Zweites Ganzzahl-Erfassungsfeld.
nDateName1 | Fremdschlüssel der dta_custom_field_names-Tabelle.
dtDateValue1 | Erstes Datumserfassungsfeld.
nDateName2 | Fremdschlüssel der dta_custom_field_names-Tabelle.
dtDateValue2 | Zweites Datumserfassungsfeld.
nStrName1 | Fremdschlüssel der dta_custom_field_names-Tabelle.
nvcStrValue1 | Erstes Zeichenfolgen-Erfassungsfeld.
nStrName2 | Fremdschlüssel der dta_custom_field_names-Tabelle.
nvcStrValue2 | Zweites Zeichenfolgen-Erfassungsfeld.
nvcCustomSearch | BLOB für verkettete Zeichenfolgenerfassung als XML.

dta_interchange_details

Diese Tabelle hat eine 1:n-Beziehung mit den folgenden Tabellen:

  • dta_indoc_details

  • dta_outdoc_details

  • dta_group_details

  • dta_interchange_data

Diese Tabelle hat eine n:1-Beziehung mit den folgenden Tabellen:

  • dta_direction_values

  • dta_error_message

  • dta_transport_type_values

Die dta_interchange_details-Tabelle enthält pro Austausch, der von BizTalk Server verarbeitet wird, eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_interchange_details-Tabelle.

Feldname | Beschreibung
nInterchangeKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nInterchangeDataKey | Fremdschlüssel der dta_interchange_details-Tabelle.
nResponseDocDataKey | Fremdschlüssel der dta_document_data-Tabelle für das Antwortdokument, das vom Empfänger eines ausgehenden Transports zurückgegeben wird.
uidInterchangeGUID | Globaler eindeutiger Bezeichner (GUID) des Austauschs.
uidSubmissionGUID | Globaler eindeutiger Bezeichner (GUID) der übergeordneten Versendung. Enthält den Korrelationsbezeichner (correlationID), der von den BizTalk-Orchestrierungsdiensten bereitgestellt wird bzw. diesen bereitgestellt. Dieses Feld bleibt leer, wenn der Datensatz zu einem eingehenden Austausch gehört, der nicht von den BizTalk-Orchestrierungsdiensten stammt. Bei eingehenden Austauschvorgängen wird dieses Feld nur aufgefüllt, wenn der Austausch von den BizTalk-Orchestrierungsdiensten stammt. Bei eingehenden Austauschvorgängen wird dieses Feld stets aufgefüllt.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes.
nvcSyntax | Code der Dokumentsyntax (XML, X12, EDIFACT, HL7 usw.). Sollte die Syntax aufgrund eines Analysefehlers oder einer Pass-Through-Versendung nicht erkannt werden, hat dieses Feld den Wert UNBEKANNT.
nvcVersion | Version der Syntax.
nvcControlID | Eindeutige Kontrollnummer für EDI-Austauschvorgänge oder ein Bezeichner für BizTalk-Nachrichten vom Typ Reliable.
nDirection | Kennzeichen, das angibt, ob der Austausch ein- oder ausgehend ist. Mögliche Werte sind 0 (ausgehend) oder 1 (eingehend). Dies ist der Fremdschlüssel von dta_direction_values, der Tabelle mit den Richtungswerten.
dtTimeSent | Zeitstempel einer erfolgreichen Übertragung.
nError | Code, der das Auftreten eines Fehlers meldet. Dies ist der Fremdschlüssel von dta_error_message, der Tabelle mit den Beschreibungen der Fehlermeldungen.
nTestMode | Test- oder Produktionsanzeige. Dieses Feld ist reserviert und wird nicht verwendet.
nvcSrcAliasQualifer | Kennzeichnerwert des Absenders, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcSrcAliasId | Bezeichnerwert des Absenders, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcSrcAppName | Bezeichner der Austauschebene für die Quellanwendung, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcDestAliasQualifier | Empfängerqualifizierer, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcDestAliasID | Bezeichnerwert des Empfängers, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nvcDestAppName | Bezeichner der Austauschebene für die Zielanwendung, der aus dem versendeten oder übertragenen Austausch extrahiert wird.
nAckStatus | Code des Empfangsbestätigungsstatus. Dies ist der Fremdschlüssel von dta_ack_status_values, der Tabelle mit den Beschreibungen der Statuswerte der Empfangsbestätigungen.
nvcSMTPMessageID | SMTP-Transportmeldungsbezeichner (für EDIINT). Dieses Feld ist reserviert und wird nicht verwendet.
nDocumentsAccepted | Die Anzahl der in dem Austausch akzeptierten Dokumente.
nDocumentsRejected | Die Anzahl der in dem Austausch abgelehnten Dokumente.
nTransportType | Anzeigecode des Übertragungsprotokolls. Dies ist ein Fremdschlüssel der dta_transport_type_values-Tabelle.
nvcTransportAddress | Adresse des Transportzieles.
nvcServerName | Server, der den Austausch verarbeitet hat.
nNumberOfBytes | Größe des Austauschs in Byte. Dieses Feld stellt dar, was im dazugehörigen dta_interchange_data-Datensatz überwacht wird, und kann sich davon unterscheiden, was tatsächlich übertragen wird. Die Größe kann sich durch eine zusätzliche Umschlagverarbeitung und Datenformatkonvertierung während der Übertragung erhöhen.
nNumOfTransmitAttempts | Zähler der Übertragungsversuche.

Verwandtes Thema

Grundlegendes zu den Überwachungseinstellungen einer Servergruppe


Struktur sekundärer Tabellen

In den sekundären Tabellen werden die unterstützenden Daten der Haupttabellen in der Überwachungsdatenbank gespeichert. Dazu zählen z. B. die folgenden Informationen:

  • Suchdaten benutzerdefinierter Felder

  • Routinginformationen

  • Austauschdaten

  • Dokumentdaten

Datentypen

Die Datentypen Float und Real werden annähernde Datentypen genannt. Das Verhalten von Float und Real folgt der IEEE 754-Spezifikation für annähernde numerische Datentypen. Annähernde numerische Datentypen speichern nicht die für viele Zahlen angegebenen exakten Werte, sondern eine extrem nahe Annäherung an den Wert. In vielen Anwendungen spielt der minimale Unterschied zwischen dem angegebenen Wert und der gespeicherten Näherung keine Rolle. Es gibt jedoch Situationen, in denen der Unterschied deutlich ist. Verwenden Sie aufgrund des annähernden Charakters von Float und Real diese Datentypen nicht, wenn ein exaktes numerisches Verhalten erforderlich ist, wie z. B. in Finanzanwendungen, bei Vorgängen mit Rundungen oder bei Gleichheitsüberprüfungen. Verwenden Sie stattdessen die Datentypen Integer, Decimal, Money oder Smallmoney.

BizTalk Server erlaubt das Überwachen des Number-Datentyps als Integer-Datentyp. Wenn der Wert der Zahl im Dokument die Größe des Integer-Datentyps überschreitet, wird eine Warnmeldung angezeigt. Diese Warnmeldung enthält den Wert, der nicht überwacht werden konnte.

Überschreiten Sie nicht die Größe des Integer-Datentyps, wenn der Number-Datentyp als Integer überwacht wird.

Internationale Probleme

  • Je nach Systemgebietsschema kann ein numerischer Wert in XML-Daten von BizTalk Server falsch interpretiert werden, wenn dieser als ganzzahliges Überwachungsfeld in der Überwachungsdatenbank protokolliert wird. Bei einem deutschen Gebietsschema wird der XML-Zahlenwert 4.0 in der Überwachungsdatenbank als 40 protokolliert, da das Dezimaltrennzeichen (.) als Symbol für die Zifferngruppierung falsch interpretiert wird.

    Für dieses Problem gibt es zwei Lösungen. Wenn Sie im Voraus wissen, dass der Element-/Attributwert eine Dezimalzahl speichert, können Sie den Element-/Attributdatentyp in Real (r4) oder Double Real (r8) ändern. Alternativ können Sie die Dokumentdefinition oder den Kanal so konfigurieren, dass ein Element/Attribut mit dem Datentyp Number als Real oder Integer protokolliert wird.

  • Das Auswahlsteuerelement für Datum und Zeit, die Listenansicht und die Strukturansicht können keine Unicode-Zeichen anzeigen. Aus diesem Grund ist die Unterstützung mehrerer Sprachen begrenzt. Wenn z. B. ein Computer mit der Sprache Englisch auf einen Computer mit BizTalk Server zugreift, dessen BizTalk-Dokumentüberwachung Webseiten und Daten in einem Doppelbyte-Zeichensatz (DBCS) enthält, werden die Zeichen auf dem englischen Client als Fragezeichen (?) angezeigt.

dta_document_data

Diese Tabelle hat eine 1:1-Beziehung mit den folgenden Tabellen:

  • dta_indoc_details

  • dta_outdoc_details

Die dta_document_data-Tabelle ist das zentrale Repository für die Dokumentspeicherung. Die folgende Tabelle beschreibt die Felder der dta_document_data-Tabelle.

Feldname | Beschreibung
nDocumentDataKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nCodePage | Systemcodeseite (z. B. 1200-Unicode, 65001-UTF-8 usw.) der zeichencodierten gespeicherten Daten. Das Feld hat den Wert -1, wenn BizTalk Server über keine Codeseiteninformationen zu den Daten verfügt. In diesem Fall kann der Wert im Feld nBLOBType gegebenenfalls Informationen zur Interpretation der Daten bereitstellen.
nBLOBType | Kennzeichen, das den Typ der Daten angibt, die im Feld imgDocumentData gespeichert sind. Mögliche Werte sind 0 (Unbekannt) oder 1 (XMLDOM kann geladen werden). XMLDOM kann geladen werden bedeutet, dass die Daten in das MSXML DOMDocument-Objekt geladen und von diesem verarbeitet werden können. Dieses Feld ist ein Fremdschlüssel der dta_blobtype_values-Tabelle.
imgDocumentData | Speicherung eines Dokuments als BLOB (Binary Large Object).
nNumberOfBytes | Größe des Dokuments in Byte.
nNumberOfRecords | Die im Dokument enthaltenen Datensätze oder Segmente.

dta_debugdoc_data

Diese Tabelle hat eine 1:1-Beziehung mit der folgenden Tabelle:

  • dta_indoc_details

Diese Tabelle hat eine 1:n-Beziehung mit der folgenden Tabelle:

  • dta_outdoc_details

Die Tabelle ist das zentrale Repository für die Debug-Dokumentspeicherung. Die folgende Tabelle beschreibt die Felder der dta_debugDoc_data-Tabelle.

Feldname | Beschreibung
nDebugDocDataKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
ntxtDocumentData | Speicherung des Dokuments als BLOB (Binary Large Object). Diese erfolgt stets in Unicode.
nNumberOfBytes | Größe des Dokuments in Byte.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes.

dta_interchange_data

Diese Tabelle hat eine n:1-Beziehung mit der folgenden Tabelle:

  • dta_interchange_details

Die dta_interchange_data-Tabelle ist ein zentrales Repository für die Austauschspeicherung und enthält für jeden vom System verarbeiteten Austausch einen Datensatz. Für Austauschvorgänge, die nur an BizTalk Server gesendet werden, zeigt das Feld nlsFile an, ob die gespeicherten Daten ursprünglich aus dem Dateisystem stammten. Ist das Kennzeichen festgelegt, enthält das Feld nvcOriginalFileName einen UNC-Pfad (Universal Naming Convention) zum Dateisystemspeicherort, aus dem die Daten stammen. Das Feld imgInterchangeData enthält die gesendeten Daten ungeachtet des Ursprungs.

Feldname | Beschreibung
nInterchangeDataKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nCodePage | Systemcodeseite (z. B. 1200-Unicode, 65001-UTF-8 usw.) der zeichencodierten gespeicherten Daten. Hat den Wert -1, wenn BizTalk Server über keine Codeseiteninformationen zu den Daten verfügt oder die Daten als Folge einer Pass-Through-Versendung überwacht werden. In diesem Fall kann der Wert im Feld nBLOBType gegebenenfalls Informationen zur Interpretation der Daten bereitstellen.
nlsFile | Kennzeichen, das eine dateibasierte Datenversendung anzeigt. Mögliche Werte sind 0 (nicht dateibasiert) oder 1 (dateibasiert).
nvcOriginalFileName | UNC-Pfad zu der Datei, wenn das Feld nlsFile den Wert 1 hat.
nBLOBType | Kennzeichen, das den Typ der Daten angibt, die im Feld imgDocumentData gespeichert sind. Mögliche Werte sind 0 (Unbekannt) oder 1 (XMLDOM kann geladen werden). XMLDOM kann geladen werden bedeutet, dass die Daten in das MSXML DOMDocument-Objekt geladen und von diesem verarbeitet werden können. Dieses Feld ist ein Fremdschlüssel der dta_blobtype_values-Tabelle.
imgInterchangeData | Speicherung des Austauschs als BLOB (Binary Large Object).

dta_group_details

Diese Tabelle hat eine 1:n-Beziehung mit den folgenden Tabellen:

  • dta_indoc_details

  • dta_outdoc_details

Diese Tabelle hat eine n:1-Beziehung mit den folgenden Tabellen:

  • dta_interchange_details

  • dta_direction_values

Die dta_group_details-Tabelle erstellt pro Gruppe, die von Erweiterungskomponenten des elektronischen Datenaustauschs (EDI) (Electronic Data Interchange) verarbeitet wird, eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_group_details-Tabelle.

Feldname | Beschreibung
nGroupKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nInterchangeKey | Fremdschlüssel der dta_interchange_details-Tabelle.
dtProcessedTimeStamp | Zeitpunkt der Erstellung des Datensatzes.
nvcSyntax | Code der Dokumentsyntax (XML, X12, EDIFACT, HL7 usw.). Sollte die Syntax aufgrund eines Analysefehlers oder einer Pass-Through-Versendung nicht erkannt werden, hat dieses Feld den Wert UNBEKANNT.
nvcVersion | Version des Standards.
nvcRelease | Release der Version.
nvcFunctionalGroupID | Code des Typs der Dokumente in der Gruppe.
nvcControlID | Eindeutige Kontrollnummer für EDI-Dokumente und Funktionsgruppen.
nvcSrcAppName | Gruppenebenenbezeichner der Quellanwendung.
nvcDestAppName | Gruppenebenenbezeichner der Zielanwendung.
nAckStatus | Code des Empfangsbestätigungsstatus. Dies ist der Fremdschlüssel von dta_ack_status_values, der Tabelle mit den Beschreibungen der Statuswerte der Empfangsbestätigungen.
nDirection | Kennzeichen, das angibt, ob die Gruppe ein- oder ausgehend ist. Mögliche Werte sind 0 (ausgehend) oder 1 (eingehend). Dies ist ein Fremdschlüssel der dta_direction_values-Tabelle.
nDocumentsAccepted | In der Gruppe akzeptierte Transaktionen.
nDocumentsRejected | In der Gruppe zurückgewiesene Transaktionen.
nNumberOfBytes | Größe des Austauschs in Byte.

dta_routing_details

Diese Tabelle hat eine 1:n-Beziehung mit der folgenden Tabelle:

  • dta_outdoc_details

Die dta_routing_details-Tabelle enthält pro getrennter Quell- und Zielinformationsmenge eine Zeile. Zwei Dokumente können auf der Organisations- und der Anwendungsebene zwei identische Routingfeldwerte aufweisen. In diesem Fall werden diese Dokumente gemäß dem Dokumenttyp oder verschiedener anderer niedriger eingestufter Filter unterschieden. Wenn dies geschieht, enthält die dta_routing_details-Tabelle Zeilen, die mit Ausnahme eines Unterschieds in den entsprechenden übergeordneten Messagingports identisch sind. Diese Verknüpfung mit dem übergeordneten Messagingport wird verwendet, um eine Verbindung zwischen der Benutzeroberflächen-Funktionalität des BizTalk-Messaging-Managers und der Überwachung zu erleichtern. Die folgende Tabelle beschreibt die Felder der dta_routing_details-Tabelle.

Feldname | Beschreibung
nRoutingKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nvcSrcOrgName | Name der Quellorganisation entsprechend der Angabe im übergeordneten Kanalobjekt.
nvcSrcAppName | Name der Quellanwendung entsprechend der Angabe im übergeordneten Kanalobjekt.
nvcDestOrgName | Name der Zielorganisation entsprechend der Angabe im übergeordneten Messagingportobjekt.
nvcDestAppName | Name der Zielanwendung entsprechend der Angabe im übergeordneten Messagingportobjekt.
nvcDistributionName | Name der Verteilerliste.
uidChannelGUID | Eindeutiger Schlüssel des übergeordneten Kanals, der auf einem globalen eindeutigen Bezeichner (GUID) basiert. Wird als Kanalkorrelationsschlüssel für die BizTalk-Messaging-Verwaltungsdatenbank verwendet.
uidPortGUID | Eindeutiger Schlüssel des übergeordneten Ports, der auf einem globalen eindeutigen Bezeichner (GUID) basiert. Wird als Portkorrelationsschlüssel für die BizTalk-Messaging-Verwaltungsdatenbank verwendet.

dta_custom_field_names

Diese Tabelle hat eine n:1-Beziehung mit der folgenden Tabelle:

  • dta_outdoc_details

Die dta_custom_field_names-Tabelle enthält pro getrennt erfasstem Paar aus Knotennamen und Datentyp eine Zeile. Die folgende Tabelle beschreibt die Felder der dta_custom_field_names-Tabelle.

Feldname | Beschreibung
nNameKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
nvcName | Text des Knotennamens. Beispiel: /CommonPO/Total/@POTotal.
nDataType | In dem benannten Knoten enthaltener Datentyp.

dta_MIME_data

In der dta_MIME_data-Tabelle werden die eingehenden MIME-Daten gespeichert, die von BizTalk Server verarbeitet werden. Mithilfe dieser Tabelle können MIME-Daten überwacht werden, die Anlagen enthalten. Die folgende Tabelle beschreibt die Felder der dta_MIME_data-Tabelle.

Feldname | Beschreibung
nMIMEDataKey | Eindeutiger Datensatzbezeichner des Primärschlüssels.
uidSubmissionGUID | Globaler eindeutiger Bezeichner (GUID) der übergeordneten Versendung.
nCodePage | Systemcodeseite für zeichencodierte gespeicherte Daten im Feld imgMIMEData. Bei MIME-Daten ist der Wert 1252 (ASCII) oder 1200 (Unicode).
imgMIMEData | Speicherung des Dokuments als BLOB (Binary Large Object).


Verknüpfte Tabellen

Die Überwachungsdatenbank enthält 13 Zusatztabellen zur Unterstützung der Haupttabellen und der unterstützenden Tabellen. In diesen Tabellen werden Informationen wie Gruppen- und Austauschkorrelationsschlüssel, Statuswerte von Empfangsbestätigungen und Datenebenenwerte gespeichert. Die folgende Tabelle beschreibt die Tabellen und deren Funktionen.

Tabellenname | Funktion
dta_ack_status_values | Speichert die Statuswerte von Empfangsbestätigungen. Mögliche Werte sind Keine, Ausstehend, Überfällig, Akzeptiert, Mit Fehlern akzeptiert und Abgelehnt.
dta_blobtype_values | Speichert BLOB-Typen. Mögliche Werte sind Unbekannt oder XMLDOM kann geladen werden.
dta_data_level_values | Speichert die in BizTalk Server verwendeten Datenebenenwerte. Mögliche Werte sind Austausch, Gruppe, Eingehendes Dokument und Ausgehendes Dokument.
dta_direction_values | Speichert die Richtung des Austauschs. Mögliche Werte sind Eingehend oder Ausgehend.
dta_error_message Speichert die in der BizTalk-Dokumentüberwachung verwendeten Fehlermeldungen. Mögliche Werte sind:
  • Kein Fehler.

  • Eine benutzerdefinierte Komponente konnte nicht aufgerufen werden.

  • Der Austausch konnte nicht analysiert werden.

  • Der angegebene Kanal ist nicht vorhanden.

  • Der Austausch konnte nicht serialisiert werden.

  • Der Austausch konnte nicht codiert werden.

  • Der Austausch konnte nicht signiert werden.

  • Der Austausch konnte nicht verschlüsselt werden.

  • Fehler beim Übertragungsversuch (erneute Übertragung steht aus).

  • Fehler beim letzten Übertragungsversuch.

  • Das Dokument konnte nicht analysiert werden.

  • Das Dokument konnte nicht überprüft werden.

  • Es konnte kein gültiger Kanal gefunden werden.

  • Das Dokument konnte nicht zugeordnet werden.

  • Es konnte kein gültiger Messagingport gefunden werden.

  • Das Dokument konnte nicht serialisiert werden.
dta_group_correlation_keys | Speichert die Gruppenkorrelationsschlüssel. Die Werte werden dynamisch generiert, um während der Empfangsbestätigungskorrelation mögliche Gruppenkandidaten zu identifizieren.
dta_interchange_correlation_keys | Speichert die Austauschkorrelationsschlüssel. Die Werte sind eindeutig und werden dynamisch generiert, um während der Empfangsbestätigungskorrelation mögliche Gruppenkandidaten zu identifizieren.
dta_transport_type_values | Speichert die Transporttypwerte. Mögliche Werte sind Keine, HTTP, SMTP, DCOM, Anwendungsintegration, Message Queuing, Datei, HTTPS, Offenes Ziel, Loopback und Orchestrierungsaktivierung.
dta_ui_codepage_charset | Speichert die Systemcodeseiten für zeichencodierte Daten.
dta_ui_user_queries | Speichert die erweiterten Abfragen, die von einzelnen Benutzern erstellt und gespeichert werden.
dta_validity_values Speichert die Überprüfungswerte. Mögliche Wert sind Nicht gültig, Gültig und Pass-Through.

Der Wert Pass-Through bedeutet, dass das Dokument nicht analysiert wurde und keiner Überprüfung unterzogen wird. Weitere Informationen zu Pass-Through finden Sie unter Grundlegendes zu erweiterten Eigenschaften von Empfangsfunktionen.
dta_wf_EventData | Enthält für jede Eigenschaft, die in Relation zu einem überwachten COM+-Ereignis protokolliert wird, das von einem XLANG-Ablaufplan ausgelöst wird, einen Datensatz. Gruppen mehrerer Zeilen in dieser Tabelle haben einen gemeinsamen übergeordneten Datensatz in der dta_wf_WorkFlowEvent-Tabelle.
dta_wf_WorkFlowEvent | Enthält für jedes überwachte COM+-Ereignis, das von einem XLANG-Ablaufplan ausgelöst wird, einen Datensatz.


Protokollieren von Austauschvorgängen und Dokumenten

Die verschiedenen Verarbeitungsszenarien, wie z. B. Offene Quelle, Offenes Ziel und Pass-Through, werden in der Überwachungsdatenbank unterschiedlich protokolliert. Die sechs gängigsten Verarbeitungsszenarien sind Nicht geöffnet, Offene Quelle, Offenes Ziel, Loopback, Pass-Through sowie Erwartete Empfangsbestätigung und Empfangsbestätigung generieren (die letzten beiden werden als ein Szenario betrachtet). Die Verarbeitungsszenarien Erwartete Empfangsbestätigung und Empfangsbestätigung generieren werden unter Protokollieren von Empfangsbestätigungen beschrieben. Die verbleibenden Verarbeitungsszenarien werden in der folgenden Tabelle vorgestellt.

Verarbeitungsszenarien | Beschreibung
Nicht geöffnet | Tritt ein, wenn die Quelle und das Ziel explizit in der Empfangsfunktion, der Dokumentinstanz, der Submit-Methode oder der SubmitSync-Methode deklariert sind.
Offene Quelle | Tritt ein, wenn die Quellinformationen nicht explizit im Kanal deklariert sind. Der Kanal muss als offene Quelle markiert sein, und der Submit-Aufruf oder die Empfangsfunktion müssen den Offenheitsgrad der Quelle angeben.
Offenes Ziel | Tritt ein, wenn die Zielinformationen nicht explizit im Messagingport deklariert sind. Das Ziel wird in der Dokumentinstanz, der Submit-Methode oder der SubmitSync-Methode dynamisch angegeben. Der Port muss als offenes Ziel markiert sein, und der Submit-Aufruf oder die Empfangsfunktion muss den Offenheitsgrad des Zieles angeben.
Loopback | Tritt ein, wenn Loopback der in einem Kanal angegebene Transport ist. Loopback gibt das ausgehende Dokument eines Kanals an die Geschäftsanwendung, Komponente oder einen XLANG-Ablaufplan zurück, die/der das eingehende Dokument mithilfe der SubmitSync-Methode gesendet hat. Dieser Transporttyp ist nur für einen Messagingport verfügbar, der sich mit einer Anwendung verbindet, und steht nur über die SubmitSync-Methode zur Verfügung.
Pass-Through | Tritt ein, wenn Sie in der Empfangsfunktion die Option Mit Pass-Through-Kennzeichen senden auswählen oder in den Methoden Submit oder SubmitSync den Wert True für den Parameter Pass-Through festlegen. BizTalk Server verarbeitet das Dokument nicht. Dies bedeutet, dass das Dokument nicht analysiert, signiert, entschlüsselt, überprüft usw. wird. Das Dokument wird nur von BizTalk Server transportiert.

Die folgende Tabelle veranschaulicht, welche ausgehenden Datensätze in der Überwachungsdatenbank protokolliert werden.

Verarbeitungsszenarien | dta_interchange_details (outgoing) | dta_outdoc_details | Antwortdokument
Nicht geöffnet | X | X | X
Offene Quelle | X | X | X
Offenes Ziel | X | X | X
Loopback | X | X |
Pass-Through | X | X | X

Anmerkungen

  • Antwortdokumente werden nur bei Verwendung der folgenden Transporte generiert: Hypertext Transfer Protocol (HTTP), Secure Hypertext Transfer Protocol (HTTPS) oder Application Integration Component (AIC). Darüber hinaus muss die Empfängeradresse Rückgabedaten senden.

  • Beim Pass-Through-Szenario ist der Datensatz, der in der dta_outdoc_details-Tabelle protokolliert wird, leer. Das Feld nlsValid hat den Wert 2, um anzugeben, dass dieser Datensatz einem Pass-Through-Dokument zugeordnet ist. Das Feld nSyntax hat den Wert UNBEKANNT. Da BizTalk Server das Dokument nicht verarbeitet, kann BizTalk Server die meisten Felder dieser Tabelle nicht mit relevanten Daten auffüllen.

Die folgende Tabelle veranschaulicht, welche eingehenden Datensätze in der Überwachungsdatenbank protokolliert werden.

Verarbeitungsszenarien | dta_interchange_details (incoming) | dta_indoc_details | Antwortdokument
Nicht geöffnet | X | X | X
Offene Quelle | X | X | X
Offenes Ziel | X | X | X
Loopback | X | X |
Pass-Through | X | X | X

Anmerkungen

  • Antwortdokumente werden nur bei Verwendung der folgenden Transporte generiert: HTTP, HTTPS und AIC. Darüber hinaus muss die Empfängeradresse Rückgabedaten senden.

  • Beim Pass-Through-Szenario ist der Datensatz, der in der dta_indoc_details-Tabelle protokolliert wird, leer. Das Feld nlsValid hat den Wert 2, um anzugeben, dass dieser Datensatz einem Pass-Through-Dokument zugeordnet ist. Das Feld nSyntax hat den Wert UNBEKANNT. Da BizTalk Server das Dokument nicht verarbeitet, kann BizTalk Server die meisten Felder dieser Tabelle nicht mit relevanten Daten auffüllen.

Verwandtes Thema

Protokollieren von Empfangsbestätigungen


Protokollieren von Empfangsbestätigungen

Die folgende Abbildung veranschaulicht den Ablauf von Empfangsbestätigungen in Microsoft BizTalk Server 2002.

Die Verarbeitung von Empfangsbestätigungen mit Kanälen

In diesem Szenario gilt Folgendes:

  • Quell- und Zielsystem verwenden BizTalk Server.

  • Das Quellsystem sendet einen Auftrag an das Zielsystem. Das Quellsystem erwartet eine Empfangsbestätigung für den Auftrag vom Zielsystem.

  • Beide Systeme sind für das Erwarten und Generieren von Empfangsbestätigungen konfiguriert.

Wenn der Auftrag vom Quellsystem verarbeitet und an das Zielsystem gesendet wurde, wird ein Datensatz in der dta_outdoc_details-Tabelle protokolliert. Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in diesem Datensatz aussehen können.

Feldname | Beispielwert | Beschreibung
nOutDocKey | 1 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nAckStatus | 1 | Gibt an, dass eine Empfangsbestätigung für das Dokument aussteht.
nReceiptFlag |  | Wird zu diesem Zeitpunkt nicht ausgefüllt.
nReceiptKey |  | Wird zu diesem Zeitpunkt nicht ausgefüllt.

Wenn das Zielsystem den Auftrag empfangen und verarbeitet hat, werden in der dta_indoc_details-Tabelle ein Datensatz und in der dta_outdoc_details-Tabelle zwei Datensätze protokolliert. Der Datensatz in der dta_indoc_details-Tabelle enthält Informationen, die für den Auftrag relevant sind. Der Datensatz in der dta_outdoc_details-Tabelle enthält Informationen, die für den Auftrag relevant sind, der zweite Datensatz enthält Informationen, die für den Empfang des Auftrags relevant sind.

Die folgende Tabelle veranschaulicht, wie die für den Auftrag relevanten Felder in dem Datensatz der dta_indoc_details-Tabelle aussehen können.

Feldname | Beispielwert | Beschreibung
nInDocKey | 1 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nDocType | Standardauftrag | Gibt den Typ des empfangenen Dokuments an.

Der erste Datensatz, der in der dta_outdoc_details-Tabelle protokolliert wird, gehört zum von BizTalk Server verarbeiteten Auftrag. Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in diesem Datensatz aussehen können.

Feldname | Beispielwert | Beschreibung
nOutDocKey | 10 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nInDocKey | 1 | Verknüpft den Datensatz mit dem übergeordneten Datensatz in der dta_indoc_details-Tabelle.

Der zweite Datensatz, der in der dta_outdoc_details-Tabelle protokolliert wird, gehört zur Empfangsbestätigung, die vom Auftrag generiert wird. Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in diesem Datensatz aussehen können.

Feldname | Beispielwert | Beschreibung
nOutDocKey | 2 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nInDocKey | 1 | Verknüpft den Datensatz mit dem übergeordneten Datensatz in der dta_indoc_details-Tabelle.
nAckStatus | 0 | Gibt an, dass die Empfangsbestätigung im Gegenzug keine Empfangsbestätigung erwartet.
nReceiptFlag | 4 | Gibt an, dass die Empfangsbestätigung einem Datensatz in der dta_indoc_details-Tabelle zugeordnet ist.
nReceiptKey | 1 | Ein eindeutiger Wert zur Identifizierung des Datensatzes der Empfangsbestätigung.

Wenn das Quellsystem die vom Zielsystem generierte Empfangsbestätigung empfangen hat und ein Datensatz in der dta_indoc_details-Tabelle protokolliert wurde, wird der ursprünglich in der dta_outdoc_details-Tabelle protokollierte Datensatz aktualisiert. Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in dem Datensatz der dta_indoc_details-Tabelle aussehen können.

Feldname | Beispielwert | Beschreibung
nInDocKey | 9 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nDocType | 997 | Gibt den Typ des empfangenen Dokuments an.

Die folgende Tabelle veranschaulicht, wie die für Empfangsbestätigungen relevanten Felder in dem aktualisierten Datensatz der dta_outdoc_details-Tabelle aussehen können.

Feldname | Beispielwert | Beschreibung
nOutDocKey | 1 | Ein eindeutiger Wert zur Identifizierung des Datensatzes.
nAckStatus | 3 | Gibt an, dass eine Empfangsbestätigung empfangen wurde.
nReceiptFlag | 4 | Gibt an, dass die Empfangsbestätigung einem Datensatz in der dta_indoc_details-Tabelle zugeordnet ist.
nReceiptKey | 9 | Ein eindeutiger Wert zur Identifizierung des Datensatzes der Empfangsbestätigung.

Verwandtes Thema

Protokollieren von Austauschvorgängen und Dokumenten


Protokollieren von Routinginformationen

Die in der Überwachungsdatenbank protokollierten Routinginformationen variieren je nachdem, ob das Dokument ein- oder ausgehend ist und wie BizTalk Server die Daten verarbeitet. Wenn BizTalk Server bei eingehenden Austauschvorgängen ein Dokument empfängt, wird die Dokumentinstanz auf Routinginformationen untersucht. Anschließend überprüft BizTalk Server die Empfangsfunktion oder die in IInterchange::Submit angegebenen Routingparameter. Wenn in der Empfangsfunktion oder IInterchange::Submit Routinginformationen angegeben sind, werden diese Parameter zum Weiterleiten der Dokumentinstanz verwendet. Die in der Dokumentinstanz angegebenen Routinginformationen werden in der Überwachungsdatenbank in der dta_routing_details-Tabelle protokolliert.

Bei ausgehenden Austauschvorgängen stammen die Quell- und Zielinformationen stets vom Kanal und werden in der dta_routing_details-Tabelle protokolliert.

Dies wirkt sich darauf aus, welche Informationen auf der Benutzeroberfläche der BizTalk-Dokumentüberwachung für Aliasnamen angezeigt werden. Es hat keine Auswirkungen darauf, wie an BizTalk Server gesendete und von BizTalk Server übertragene Austauschvorgänge als einzelne Datenflussinstanz in Beziehung stehen.


Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank

Aktionsereignisse im Zusammenhang mit Nachrichten, die von einem XLANG-Ablaufplan verarbeitet werden und zwischen den BizTalk-Messagingdiensten und BizTalk-Orchestrierungsdiensten ausgetauscht werden, können in den entsprechenden Tabellen der Überwachungsdatenbank protokolliert werden. Die Aktionsereignisse können mithilfe der BizTalk-Dokumentüberwachung angezeigt werden. Das Überwachen und Anzeigen von Aktionsereignissen in Zusammenhang mit Nachrichten, die von einem XLANG-Ablaufplan verarbeitet werden, ist nach der Installation von BizTalk Server 2002 nicht automatisch aktiviert. Sie müssen die folgenden Schritte durchführen, um diese Funktion zu aktivieren:

  1. Registrieren Sie die DLL-Beispieldatei WorkFlowAudit.dll.

    Diese Beispieldatei finden Sie im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\bin.

  2. Führen Sie die Anwendung WorkFlowAuditClient.exe aus, um WorkFlowAudit.dll zu aktivieren.

    Diese Beispielanwendung finden Sie im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient.

    Weitere Informationen finden Sie in der Infodatei (Readme.txt) im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\Docs.

  3. Klicken Sie in der Anwendung WorkFlowAuditClient auf die Schaltfläche Start, um das Protokollieren von Aktionsereignissen in Zusammenhang mit einem XLANG-Ablaufplan in der Überwachungsdatenbank zu starten.

Wichtig

  • Datensätze werden nur dann in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert, wenn die Anwendung WorkFlowAuditClient gestartet wurde. Befolgen Sie zum Starten der Anwendung WorkFlowAuditClient die drei zuvor genannten Schritte. Wird WorkFlowAuditClient angehalten, werden keine Datensätze in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert.

Nach Durchführung dieser Schritte werden für Nachrichten, die zwischen den BizTalk-Messagingdiensten und BizTalk-Orchestrierungsdiensten ausgetauscht werden, Datensätze in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert. Der in der dta_wf_EventData-Tabelle im Feld nvcName protokollierte Wert dient als Verknüpfung zwischen den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent und der dta_interchange_details-Tabelle, einer Haupttabelle in der Überwachungsdatenbank. Weitere Informationen zu den Haupttabellen finden Sie unter Struktur der Haupttabellen für Metadaten.

Von den BizTalk-Orchestrierungsdiensten an die BizTalk-Messagingdienste gesendete Nachrichten

Alle von den BizTalk-Orchestrierungsdiensten an die BizTalk-Messagingdienste mithilfe der BizTalk-Messaging-Portimplementierung im BizTalk-Orchestrierungs-Designer gesendeten Nachrichten werden von einem globalen eindeutigen Bezeichner (GUID) identifiziert, der Korrelationsbezeichner (correlationID) genannt wird. Wird eine Nachricht von den BizTalk-Orchestrierungsdiensten an die BizTalk-Messagingdienste gesendet, wird der Korrelationsbezeichner im Feld uidSubmissionGUID der dta_interchange_details-Tabelle protokolliert. Zusätzlich werden Datensätze in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert. Dadurch können Sie mithilfe der BizTalk-Dokumentüberwachung die Aktionsereignisse anzeigen, die zu Nachrichten gehören, die von einem XLANG-Ablaufplan verarbeitet wurden.

Von den BizTalk-Messagingdiensten an die BizTalk-Orchestrierungsdienste gesendete Dokumente

Alle an die BizTalk-Messagingdienste gesendeten Dokumente werden von einem globalen eindeutigen Bezeichner (GUID) identifiziert, der Versendungshandle (SubmissionHandle) genannt wird. Weitere Informationen zum Versendungshandle finden Sie unter Submit Method. Wird das Dokument von den BizTalk-Messagingdiensten an die BizTalk-Orchestrierungsdienste gesendet, wird der Versendungshandle im Feld uidSubmissionGUID der dta_interchange_details-Tabelle aufgezeichnet. Darüber hinaus erfolgen beim Versenden eines Dokuments von den BizTalk-Messagingdiensten an die BizTalk-Orchestrierungsdienste die beiden folgenden Ereignisse:

  • Der Versendungshandle wird in die correlationID-Eigenschaft des Dokuments eingefügt, das an die BizTalk-Orchestrierungsdienste gesendet wird.

  • Datensätze werden in den Tabellen dta_wf_EventData und dta_wf_WorkFlowEvent protokolliert. Da das Dokument von den BizTalk-Messagingdiensten gesendet wurde, wird der Versendungshandle als Korrelationsbezeichner im Feld nvcName der dta_wf_EventData-Tabelle gespeichert.

Anzeigen von Aktionsereignissen

Sie müssen in der BizTalk-Dokumentüberwachung eine Abfrage erstellen und dann auf das Symbol XLANG-Ablaufplan klicken, um die BizTalk-Dokumentüberwachung zum Anzeigen von Aktionsereignissen zu verwenden, die zu Nachrichten gehören, welche von einem XLANG-Ablaufplan verarbeitet wurden. Weitere Informationen zum Erstellen von Abfragen und Anzeigen von XLANG-Ablaufplanereignissen finden Sie unter Verwenden von Abfragen zum Durchsuchen und Sortieren von Austausch- und Dokumentdaten.

Die dta_wf_EventData-Tabelle

Die folgende Tabelle enthält für jede Eigenschaft, die in Relation zu einem überwachten COM+-Ereignis protokolliert wird, das wiederum von einem XLANG-Ablaufplan generiert wird, einen Datensatz. Gruppen mehrerer Zeilen in dieser Tabelle haben einen gemeinsamen übergeordneten Datensatz in der dta_wf_WorkFlowEvent-Tabelle.

Feldname | Beschreibung
nEventDataId | Ganzzahliges Schlüsselfeld, das automatisch erhöht wird.
nWorkFlowEventId | Fremdschlüssel des übergeordneten Ereignisdatensatzes in dta_wf_EventData.
nvcName | Korrelationsbezeichner (correlationID).
nvcValue | Beliebiger Wert. Basiert in der Regel auf einem globalen eindeutigen Bezeichner (GUID).

Die dta_wf_WorkFlowEvent-Tabelle

Die folgende Tabelle ist die übergeordnete Tabelle der dta_wf_EventData-Tabelle und enthält für jedes überwachte COM+-Ereignis, das von einem XLANG-Ablaufplan generiert wird, einen Datensatz.

Feldname | Beschreibung
nWorkFlowEventId | Ganzzahliges Schlüsselfeld, das automatisch erhöht wird.
nvcEventId | Typ des Ereignisses.
nvcEventName | Name des Ereignisses.
nProcessId | Prozessbezeichner des auslösenden Ereignisses.
nvcApplicationId | XLANG-Ablaufplanbezeichner.
nvcInstanceId | Bezeichner der bestimmten Instanz des Ablaufplanes.
nEventTime | UTC-Zeit des Ereignisses in Sekunden seit 01.01.1970, 0:00 Uhr.
nEventSubTime | Zum ITime-Argument hinzugefügte Mikrosekunden für eine in Mikrosekunden aufzulösende Zeit.
nEventTick | Wert des hoch auflösenden Leistungsindikators bei Auslösung des Ereignisses.
nvcServerName | Server, auf dem das Ereignis entdeckt wurde.
dtDateEntered | Datum des Ereignisses.

Verwandte Themen

Integrieren der BizTalk-Dienste

Struktur der Haupttabellen für Metadaten

Submit Method

Grundlegendes zum integrierten XLANG-Ablaufplanstatus eines Austauschs


Grundlegendes zum Suchen von Austauschvorgängen und dazugehörigen Dokumenten

Mithilfe der BizTalk-Dokumentüberwachung können Sie unter Verwendung der von Ihnen angegebenen Abfrageparameter alle Austauschvorgänge und Dokumente anzeigen. Sie müssen mit Abfragen und deren Verwendung vertraut sein, um die Suchergebnisse zu optimieren und die Serverbelastung zu minimieren. Wenn Sie z. B. eine Abfrage mit sehr wenigen definierten Parametern erstellen, kann die Abfrage Tausende von Austauschdatensätzen zurückgeben. Dies ist sehr zeitaufwändig und belastet die Verarbeitungsleistung des Servers. Diese Situation wird noch verschlimmert, wenn mehrere Benutzer die Datenbank gleichzeitig abfragen.

BizTalk Server bietet zwei Abfragetypen: Abfragen und erweiterte Abfragen. Abfragen enthalten die gängigsten Kriterien, mit denen Abfrageergebnisse eingeengt werden. Erweiterte Abfragen ermöglichen eine Verfeinerung der Abfrageergebnisse, indem für die Suche nach bestimmten Daten Ausdrücke verwendet werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu Abfragen

  • Grundlegendes zu erweiterten Abfragen


Grundlegendes zu Abfragen

Die drei Standardabfrageparameter in der BizTalk-Dokumentüberwachung sind Zeitraum und Zeitzone, Quell- und Zielbezeichner und Dokumenttyp. Sie können nach Austausch- und Dokumentdatensätzen suchen, indem Sie in einer Abfrage eines oder mehrere dieser Kriterien angeben. Sie können z. B. nach allen Dokumenttypen in einem bestimmten Zeitraum suchen oder nach Austauschvorgängen und Dokumenten, die einem bestimmten Dokumenttyp entsprechen und mit den ausgewählten Quell- und Zielorganisationen übereinstimmen.

Zeitraum und Zeitzone

Die in der BizTalk-Dokumentüberwachung angegeben Datums- und Zeitinformationen geben an, wann das Dokument von BizTalk Server verarbeitet wurde. Sie können einen beliebigen Zeitraum für die Abfrage angeben. Standardmäßig stellt die BizTalk-Dokumentüberwachung die letzten sieben Werktage als Zeitraum bereit. Im Gegensatz zu den Listen Quellauswahl, Zielauswahl oder Auswahl des Dokumenttyps können Sie in der BizTalk-Dokumentüberwachung den Zeitraum nicht leer lassen, um datums- oder uhrzeitunabhängig nach Dokumenten zu suchen.

Sie können angeben, ob Datum und Uhrzeit gemäß der Ortszeit oder der UTC-Zeit angezeigt werden sollen. In der Regel wird mithilfe der Ortszeit nach Austauschvorgängen und Dokumenten gesucht. Wenn Sie jedoch mit jemandem in einer anderen Zeitzone zusammenarbeiten und gemeinsame Kriterien für das Senden oder Empfangen eines Dokuments definieren müssen, verwenden Sie die UTC-Zeit.

Anmerkung

  • Das Verwenden langer Datums- und Zeitformate kann zu Abschneidungen in der BizTalk-Dokumentüberwachung führen, da das Auswahlsteuerelement für Datum und Zeit nur kurze Formate unterstützt.

    Falls ein Problem mit dem Datums- und Zeitformat auftreten sollte, können Sie diese Formate auf dem Computer in der Systemsteuerung ändern, indem Sie auf Ländereinstellungen klicken.

Quell- und Zielorganisation

Sie können basierend auf der Quellorganisation, der Zielorganisation oder beiden nach Austauschvorgängen und Dokumenten suchen. Darüber hinaus können Sie im Rahmen einer Abfrage die Suche nach Dokumenten mit Filtern für eine, mehrere oder alle Organisationen festlegen. Sie können auch nach Austauschvorgängen und Dokumenten suchen, die aus einer Anwendung stammen, die einer Organisation zugeordnet ist. Wenn z. B. Quellorganisation A eine Tabellenkalkulationsanwendung verwendet, die Informationen an eine Datenbankanwendung in Zielorganisation B sendet, können Sie ermitteln, wann die Informationen gesendet und empfangen wurden.

Dokumenttyp

Sie können nach Austauschvorgängen und Dokumenten mit einem bestimmten Dokumenttyp suchen, wie z. B. Auftrag oder Rechnung. In einer Abfrage können Sie Dokumenttypkriterien mit Quell- und Zielbezeichnern kombinieren, um Austauschvorgänge und Dokumente zu suchen, die zwischen Ihnen und Ihren Handelspartnern gesendet und empfangen wurden. Diese Art von Abfrage kann Sie bei der Analyse der Geschäftsbeziehungen zwischen Ihnen und Ihren Handelspartnern unterstützen.

Sortiersteuerung

Es gibt sechs Sortiersteuerelemente, die ermitteln, in welcher Reihenfolge die Spalten auf der Seite Abfrageergebnisse sortiert werden. Die standardmäßige Sortierreihenfolge einer Abfrage ist wie folgt:

  • Quellorganisationsname. Der Name der Quellorganisation des Dokuments.

  • Quellanwendungsname. Der Name der Anwendung, aus der das Dokument stammt.

  • Zielorganisationsname. Der Name der Zielorganisation des Dokuments.

  • Zielanwendungsname. Der Name der Anwendung, an die das Dokument gesendet wird.

  • Dokumenttyp. Der Typ des Dokuments.

  • Verarbeitungszeitpunkt. Der Zeitpunkt, an dem das Dokument von BizTalk Server verarbeitet wurde.

Über das Kontrollkästchen Eingehende/ausgehende Austauschvorgänge gruppieren wird die Seite Abfrageergebnisse so konfiguriert, dass eingehende Austauschvorgänge mit dazugehörigen Austauschvorgängen gruppiert werden. Deaktivieren Sie dieses Kontrollkästchen, wenn eingehende Austauschvorgänge nicht mit dazugehörigen Austauschvorgängen angezeigt werden sollen.

Verwandtes Thema

Grundlegendes zu erweiterten Abfragen


Grundlegendes zu erweiterten Abfragen

Wenn Sie feststellen sollten, dass eine Abfrage zu viele Austausch- und Dokumentdatensätze zurückgibt, können Sie die Suche mithilfe von Abfrageausdrücken einengen. Im Dialogfeld Erweiterte Abfragen können Sie im Generator für erweiterte Abfragen einen neuen Abfrageausdruck erstellen oder eine Liste der Abfrageausdrücke durchsuchen, die Sie zuvor gespeichert haben. Ausdrücke sind SQL-Anweisungen, die durch die Erstellung bedingter Klauseln gebildet werden, welche zur Abfrage hinzugefügt werden. Mithilfe der folgenden Optionen können Sie eine erweiterte Abfrage erstellen:

  • Quellauswahl. Eine Liste der Felder, gemäß denen die Suche erfolgen soll. Wenn Sie im BizTalk-Messaging-Manager einen Kanal oder eine Dokumentdefinition für die Überwachung benutzerdefinierter Felder konfiguriert haben, werden diese Felder in der Liste Quellauswahl angezeigt. Wenn der BizTalk-Messaging-Manager nicht für die Überwachung von Feldern konfiguriert wurde, wird in der Liste Quellauswahl nur <Benutzerdefinierte Suche> angezeigt. Weitere Informationen zum Überwachen bestimmter Felder finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung und Auswählen von Spezifikationsfeldern in einem Kanal.

  • Operatoren. Eine Liste der verfügbaren Operatoren (z. B. >, <, =, enthält und enthält nicht).

  • Wert. Sie können in dieses Feld einen Wert eingeben, um den begrenzenden Wert für die erweiterte Abfrage anzuzeigen.

  • AND/OR. Eine Liste mit den Gruppierungsoperatoren (AND und OR), mit denen Suchbedingungen kombiniert werden.

  • Abfrage. Eine Liste der erstellten Abfragen.

  • Logische Gruppierung. Eine Beschreibung der kombinierten Suchbedingungen, die Sie mithilfe der Gruppierungsoperatoren AND und OR erstellt haben. Wenn Sie zu einer Abfrage Klauseln hinzufügen, werden Informationen zu Gruppierungsoperatoren im Feld Logische Gruppierung angezeigt. Das Feld Logische Gruppierung kann z. B. Folgendes enthalten:

    1 AND 2 AND (3 OR 4)

    In diesem Beispiel gelten die Bedingungen 1 und 2, und entweder Bedingung 3 oder 4 wird mit den Bedingungen 1 und 2 kombiniert.

Anmerkungen

  • Sie können mehrere Abfragen mit demselben Namen erstellen.

  • Beim Überwachen von Spezifikationsfeldern als Datentyp Integer, Real, Date oder Text werden die Namen von Spezifikationsfeldern mit mehr als 79 Zeichen abgeschnitten.

    Überwachen Sie diese Spezifikationsfelder als Custom-Datentyp. Dies führt dazu, dass die Feldnamen gemeinsam mit den Feldwerten in der SQL-Spalte ntext gespeichert werden, die eine maximale Länge von 2^30 - 1 (1.073.741.823) Zeichen erlaubt.

  • Wenn Sie Details und Empfangsbestätigungsstatus eines Dokuments nicht finden können, ist möglicherweise in der BizTalk Server-Verwaltung das Kontrollkästchen Dokumentverwaltung aktivieren nicht aktiviert. Wenn dieses Kontrollkästchen nicht aktiviert ist, können Empfangsbestätigungen nicht korreliert werden.

    Führen Sie folgende Schritte zum Aktivieren der Dokumentüberwachung durch:

    1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk Server-Verwaltung.

    2. Erweitern Sie Microsoft BizTalk Server 2002 in der BizTalk Server-Verwaltung, klicken Sie mit der rechten Maustaste auf die BizTalk-Servergruppe, für die Sie die Einstellungen für die Dokumentüberwachung ändern möchten, und klicken Sie dann auf Eigenschaften.

    3. Aktivieren Sie auf der Registerkarte Überwachen das Kontrollkästchen Dokumentüberwachung aktivieren.

    Wählen Sie alle anderen Optionen, die Sie verwenden möchten, aus.

Internationales Problem

  • Je nach Systemgebietsschema kann ein numerischer Wert in XML-Daten von BizTalk Server falsch interpretiert werden, wenn dieser als ganzzahliges Überwachungsfeld in der Überwachungsdatenbank protokolliert wird. Bei einem deutschen Gebietsschema wird der XML-Zahlenwert 4.0 in der Überwachungsdatenbank als 40 protokolliert, da das Dezimaltrennzeichen (.) als Symbol für die Zifferngruppierung falsch interpretiert wird.

    Für dieses Problem gibt es zwei Lösungen. Wenn Sie im Voraus wissen, dass der Element-/Attributwert eine Dezimalzahl speichert, können Sie den Element-/Attributdatentyp in Real (r4) oder Double Real (r8) ändern. Alternativ können Sie die Dokumentdefinition oder den Kanal so konfigurieren, dass ein Element/Attribut mit dem Datentyp Number als Real anstatt Integer protokolliert wird.

Verwandtes Thema

Grundlegendes zu Abfragen


Grundlegendes zu Abfrageergebnissen

Auf der Seite Abfrageergebnisse werden Abfrageergebnisse in zwei Ebenen unterteilt: Austauschdatensätze und Dokumentdatensätze. Die höchste Organisationsebene bilden die Austauschdatensätze. Ein Austauschdatensatz steht für einen Austausch, der an Microsoft BizTalk Server 2002 gesendet oder von BizTalk Server 2002 übertragen wurde. Austauschdatensätze sind die übergeordneten Datensätze von Dokumentinstanz-Datensätzen und dienen der nachvollziehbaren Strukturierung von Dokumentinstanz-Datensätzen. Weitere Informationen zu den Feldern eines Austauschdatensatzes finden Sie unter Grundlegendes zu den Ergebnissen von Austauschdatensätzen. Auf der Benutzeroberfläche werden Austauschdatensätze als Datenfeldzeilen mit einem Erweiterungssymbol am linken Ende jeder Zeile angezeigt.

Wenn Sie auf das Erweiterungssymbol klicken, werden die Dokumentinstanz-Datensätze angezeigt. Auf der Benutzeroberfläche werden Dokumentinstanz-Datensätze ebenfalls als Datenfeldzeilen angezeigt. In der Regel ist pro Austauschdatensatz ein Dokumentinstanz-Datensatz vorhanden. Wenn jedoch mehrere Dokumenttypen in einem einzelnen Austausch gesendet werden, gibt es für jeden in dem Austausch gesendeten Dokumenttyp einen Dokumentdatensatz. Weitere Informationen zu den Feldern in einem Dokumentinstanz-Datensatz finden Sie unter Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlagen des Überwachungsdatenbank-Schemas

  • Grundlegendes zu den Ergebnissen von Austauschdatensätzen

  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu den Ergebnissen von Empfangsbestätigungen

  • Grundlegendes zu den Ergebnissen misslungener Übertragungen


Grundlagen des Überwachungsdatenbank-Schemas

Sie müssen mit den Grundlagen des Schemas der Überwachungsdatenbank vertraut sein, um die auf der Seite Abfrageergebnisse angezeigten Informationen verstehen zu können. Die Überwachungsdatenbank enthält drei Haupttabellen, in denen Metadaten (wie z. B. Kennzeichen von Quell- und Zielorganisation, Datum, Uhrzeit und Dokumenttyp) für alle Austauschvorgänge und Dokumente gespeichert werden, die von BizTalk Server verarbeitet werden. Die Datenbanktabellen heißen:

  • dta_interchange_details

  • dta_indoc_details

  • dta_outdoc_details

dta_interchange_details

In der dta_interchange_details-Tabelle werden alle für Austauschvorgänge relevanten Daten gespeichert. Diese Tabelle ist die übergeordnete Tabelle der Tabellen dta_indoc_details table und dta_outdoc_details. Für jeden von BizTalk Server verarbeiteten Austausch wird in der Tabelle ein Datensatz gespeichert. Die Felder in den Austauschdatensätzen auf der Seite Abfrageergebnisse werden mit Daten dieser Tabelle aufgefüllt. Ein Feld in dieser Tabelle gibt an, ob der Austausch ein- oder ausgehend ist. Wenn Sie z. B. einen Austausch empfangen, wird dieser auf der Seite Abfrageergebnisse als eingehender Austauschdatensatz dargestellt. Wenn Sie dagegen einen Austausch senden, wird dieser auf der Seite Abfrageergebnisse als ausgehender Austauschdatensatz dargestellt Weitere Informationen zur dta_interchange_details-Tabelle finden Sie unter Haupttabellen für Metadaten und Struktur der Haupttabellen für Metadaten.

dta_indoc_details

Die dta_indoc_details-Tabelle speichert alle Daten für jedes Dokument, das an BizTalk Server gesendet wird. Diese Tabelle ist über einen Primärschlüssel mit der dta_interchange_details-Tabelle verknüpft. Die Felder in Dokumentinstanz-Datensätzen, die eingehenden Austauschdatensätzen auf der Seite Abfrageergebnisse zugeordnet sind, werden mit Daten dieser Tabelle aufgefüllt. Wenn Sie z. B. ein Dokument senden und auf der Seite Abfrageergebnisse die Überwachungsinformationen für dieses Dokument anzeigen möchten, müssen Sie zuerst den entsprechenden ausgehenden Austauschdatensatz bestimmen. Wenn Sie anschließend den Datensatz erweitern, wird der Dokumentinstanz-Datensatz angezeigt. Dieser Dokumentinstanz-Datensatz ist der dta_indoc_details-Tabelle zugeordnet und enthält Daten in den Feldern, die Sie für die Überwachung konfiguriert haben. Weitere Informationen zur dta_indoc_details-Tabelle finden Sie unter Haupttabellen für Metadaten und Struktur der Haupttabellen für Metadaten.

dta_outdoc_details

In der dta_outdoc_details-Tabelle werden alle Daten aller Dokumente gespeichert, die von BizTalk Server generiert wurden. Die dta_outdoc_details-Tabelle kann für jeden Datensatz in der dta_indoc_details-Tabelle mehrere Datensätze enthalten, da bei einer einzelnen Versendung mehrere Dokumente generiert werden können. Ein an BizTalk Server übermitteltes Dokument kann z. B. an eine 10 Ports umfassende Verteilerliste gesendet werden. In diesem Fall werden in der dta_indoc_details-Tabelle ein und in der dta_outdoc_details-Tabelle 10 Datensätze protokolliert. Demzufolge wird auf der Seite Abfrageergebnisse ein ausgehender Austauschdatensatz mit einem zugeordneten Dokumentinstanz-Datensatz angezeigt. Die Felder im Dokumentinstanz-Datensatz werden mit Daten der dta_outdoc_details-Tabelle aufgefüllt. Weitere Informationen zur dta_outdoc_details-Tabelle finden Sie unter Haupttabellen für Metadaten und Struktur der Haupttabellen für Metadaten.

Verwandte Themen

Protokollieren von Austauschvorgängen und Dokumenten

Haupttabellen für Metadaten

Struktur der Haupttabellen für Metadaten

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Grundlegendes zu den Ergebnissen von Empfangsbestätigungen

Grundlegendes zu den Ergebnissen misslungener Übertragungen

Grundlegendes zum Schema der Überwachungsdatenbank


Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Je nach angegebenen Abfrageparametern werden, falls Übereinstimmungen mit den Abfragekriterien gefunden werden, ein oder mehrere Austauschdatensätze angezeigt. Ein Austauschdatensatz repräsentiert einen Austausch, der an BizTalk Server 2002 gesendet oder von BizTalk Server 2000 übertragen wurde.

Ein Austauschdatensatz enthält die in der folgenden Tabelle gezeigten Informationen.

Spaltenüberschrift | Beschreibung
Daten | Eine Verknüpfung zur Anzeige des Austauschdatensatzes im systemeigenen Format.
Ablaufplan Eine Verknüpfung mit den Statusinformationen des XLANG-Ablaufplanes für den einzelnen Austausch, falls verfügbar. Wenn dem Austausch keine Statusinformationen für den XLANG-Ablaufplan zugeordnet sind, wird die folgende Meldung angezeigt:

Für diesen Austausch sind keine XLANG-Ablaufplaninformationen verfügbar.
Richtung | Gibt an, ob der Austausch an BizTalk Server gesendet (eingehend) oder von BizTalk Server übertragen (ausgehend) wird.
Fehler Gibt an, ob mit dem Dokument Fehler verbunden sind.

Mögliche Fehlermeldungen sind:

  • Kein Fehler.

  • Eine benutzerdefinierte Komponente konnte nicht aufgerufen werden.

  • Der Austausch konnte nicht analysiert werden.

  • Der angegebene Kanal ist nicht vorhanden.

  • Der Austausch konnte nicht serialisiert werden.

  • Der Austausch konnte nicht codiert werden.

  • Der Austausch konnte nicht signiert werden.

  • Der Austausch konnte nicht verschlüsselt werden.

  • Fehler beim Übertragungsversuch (erneute Übertragung steht aus).

  • Fehler beim letzten Übertragungsversuch.

  • Das Dokument konnte nicht analysiert werden.

  • Das Dokument konnte nicht überprüft werden.

  • Es konnte kein gültiger Kanal gefunden werden.

  • Das Dokument konnte nicht zugeordnet werden.

  • Es konnte kein gültiger Messagingport gefunden werden.

  • Das Dokument konnte nicht serialisiert werden.
Quellorganisation | Gibt den Namen der Quellorganisation an.
Quellanwendung | Gibt die Anwendungen an, aus der das Dokument stammt.
Zielorganisation | Gibt den Namen der Zielorganisation an.
Zielanwendung | Gibt die Zielanwendung für das Dokument an.
Dokumenttyp | Gibt den Typ des Dokuments an. Wenn ein Austausch mehr als einen Dokumenttyp enthält, wird in diesem Feld <MEHRERE> angezeigt.
Dokumentanzahl | Gibt die Anzahl der Dokumente in dem Austausch an.
Kontroll-ID | Gibt eine eindeutige Kontrollnummer für elektronische Datenaustauschvorgänge (EDI) oder einen Bezeichner für BizTalk Reliable Messages an.
Empfangsbestätigungsstatus | Gibt den Empfangsbestätigungsstatus an. Mögliche Werte für den Empfangsbestätigungsstatus sind Keine, Ausstehend, Überfällig, Akzeptiert, Mit Fehlern akzeptiert oder Abgelehnt.
Verarbeitungszeitpunkt | Gibt den Zeitpunkt der Verarbeitung des Austauschs an. Die Zeit wird festgelegt, wenn die Dokumentüberwachungs-Datensätze erstellt werden. Nachdem das Feld festgelegt wurde, wird es nicht aktualisiert.
Sendezeitpunkt | Gibt bei einer erfolgreichen Übertragung den Zeitpunkt an, an dem der Austausch gesendet wurde. Ist die Übertragung misslungen, ist der Wert Null. Bei eingehenden Übertragungen enthält das Feld stets den Wert Null.
Quell-ID-Qualifizierer | Gibt den Typ des Qualifizierers der Quellorganisation an. Dies ist der von BizTalk Server intern verwendete Qualifizierer.
Quellbezeichner | Gibt den Organisationskennzeichenwert der Quelle an. Dies ist der in den Daten angegebene Quellbezeichner, der zum Weiterleiten des Dokuments verwendet wird. Unterscheidet sich vom Quell-ID-Qualifizierer. Weitere Informationen zum Routing finden Sie unter Protokollieren von Routinginformationen.
Ziel-ID-Qualifizierer | Gibt den Typ des Qualifizierers der Zielorganisation an.
Zielbezeichner | Gibt den Organisationskennzeichenwert des Zieles an Weitere Informationen zum Routing finden Sie unter Protokollieren von Routinginformationen.

Verwandte Themen

Grundlagen des Überwachungsdatenbank-Schemas

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zum Suchen von Austauschvorgängen und dazugehörigen Dokumenten


Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Dokumentinstanz-Datensätze in einem Austausch werden als Zeilen mit Feldern angezeigt, welche die Dokumentinformationen beschreiben.

Die Ergebnisse eines Dokumentinstanz-Datensatzes enthalten die in der folgenden Tabelle gezeigten Informationen.

Spaltenüberschrift | Beschreibung
Daten | Eine Verknüpfung zum Anzeigen der Daten in der Dokumentinstanz im systemeigenen Format und im XML-Format.
Überwachungs-ID | Ein Überwachungsschlüssel, der auf einem globalen eindeutigen Bezeichner (GUID) basiert.
Dokumenttyp | Gibt den Dokumenttyp an. Wenn ein Austausch mehrere Dokumente enthält, gibt dieses Feld den Dokumenttyp an. Dieses Feld enthält stets nur einen Dokumenttyp. Weitere Dokumenttypen werden als getrennte Dokumentinstanz-Datensätze angezeigt.
Kompatibilität | Gibt an, ob das Dokument gültig ist. Mögliche Werte für die Kompatibilität sind Gültig und Ungültig.
Fehler Gibt an, ob mit dem Dokument Fehler verbunden sind. Mögliche Fehlermeldungen sind:
  • Kein Fehler.

  • Eine benutzerdefinierte Komponente konnte nicht aufgerufen werden.

  • Der Austausch konnte nicht analysiert werden.

  • Der angegebene Kanal ist nicht vorhanden.

  • Der Austausch konnte nicht serialisiert werden.

  • Der Austausch konnte nicht codiert werden.

  • Der Austausch konnte nicht signiert werden.

  • Der Austausch konnte nicht verschlüsselt werden.

  • Fehler beim Übertragungsversuch (erneute Übertragung steht aus).

  • Fehler beim letzten Übertragungsversuch.

  • Das Dokument konnte nicht analysiert werden.

  • Das Dokument konnte nicht überprüft werden.

  • Es konnte kein gültiger Kanal gefunden werden.

  • Das Dokument konnte nicht zugeordnet werden.

  • Es konnte kein gültiger Messagingport gefunden werden.

  • Das Dokument konnte nicht serialisiert werden.
Empfangsbestätigung | Bietet eine Verknüpfung mit Informationen zur Empfangsbestätigung.

Die folgenden Felder gelten nur für ausgehende Dokumente.

Empfangsbestätigungsstatus | Gibt den Empfangsbestätigungsstatus an. Mögliche Werte für den Empfangsbestätigungsstatus sind Keine, Ausstehend, Überfällig, Akzeptiert, Mit Fehlern akzeptiert oder Abgelehnt.
Real 1, Real 2 | Gibt die Daten an, die im Inhalt des Dokuments als reelle Zahlen erfasst wurden. Es gibt zwei Felder, die reelle Zahlen enthalten können.
Integer 1, Integer 2 | Gibt Daten an, die im Inhalt des Dokuments als ganzzahliger Wert erfasst wurden. Es gibt zwei Felder, die ganze Zahlen enthalten können.
Date 1, Date 2 | Gibt Daten an, die im Inhalt des Dokuments als Datumswert erfasst wurden. Es gibt zwei Felder, die Datumsangaben enthalten können.
String 1, String 2 | Gibt Daten an, die im Inhalt des Dokuments als Zeichenfolgenwert erfasst wurden. Es gibt zwei Felder, die Zeichenfolgen enthalten können.
Benutzerdefinierte Suche | Gibt weitere Daten an, die als ein Zeichenfolgenwert erfasst wurden. Dieses Feld ist auf 2 GB begrenzt.

Anmerkungen

  • Weitere Informationen zu den Informationen, die in ausgehenden Dokumenten überwacht werden sollen, finden Sie unter Auswählen von Spezifikationsfeldern in einer Dokumentdefinition und Auswählen von Spezifikationsfeldern in einem Kanal.

  • Wenn Sie in der Dokumentdefinition Felder (wie z. B. die Felder Integer, Real, String, Date oder benutzerdefinierte Felder) als optional und für die Überwachung konfigurieren und diese Felder nicht in der versendeten Dokumentinstanz vorhanden sind, werden die Felder nicht in den Abfrageergebnissen angezeigt. Die BizTalk-Dokumentüberwachung generiert keine Fehler- oder Warnmeldung, die Sie über das Fehlen von Daten in optionalen Feldern informiert.

  • Beim Überwachen von Spezifikationsfeldern als Datentyp Integer, Real, Date oder Text werden die Namen von Spezifikationsfeldern mit mehr als 79 Zeichen abgeschnitten.

    Überwachen Sie diese Spezifikationsfelder als Custom-Datentyp. Dies führt dazu, dass die Feldnamen gemeinsam mit den Feldwerten in der SQL-Spalte ntext gespeichert werden, die eine maximale Länge von 2^30 - 1 (1.073.741.823) Zeichen erlaubt.

Internationales Problem

  • Je nach Systemgebietsschema kann ein numerischer Wert in XML-Daten von BizTalk Server falsch interpretiert werden, wenn dieser als ganzzahliges Überwachungsfeld in der Überwachungsdatenbank protokolliert wird. Bei einem deutschen Gebietsschema wird der XML-Zahlenwert 4.0 in der Überwachungsdatenbank als 40 protokolliert, da das Dezimaltrennzeichen (.) als Symbol für die Zifferngruppierung falsch interpretiert wird.

    Für dieses Problem gibt es zwei Lösungen. Wenn Sie im Voraus wissen, dass der Element-/Attributwert eine Dezimalzahl speichert, können Sie den Element-/Attributdatentyp in Real (r4) oder Double Real (r8) ändern. Alternativ können Sie die Dokumentdefinition oder den Kanal so konfigurieren, dass ein Element/Attribut mit dem Datentyp Number als Real oder Integer protokolliert wird.

Verwandte Themen

Auswählen von Spezifikationsfeldern in einem Kanal

Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

Grundlagen des Überwachungsdatenbank-Schemas

Grundlegendes zum Suchen von Austauschvorgängen und dazugehörigen Dokumenten

Grundlegendes zu den Ergebnissen von Austauschdatensätzen


Grundlegendes zu den Ergebnissen von Empfangsbestätigungen

Die folgende Abbildung veranschaulicht den Ablauf von Empfangsbestätigungen in der BizTalk-Dokumentüberwachung. In der Abbildung wird Dokument 1 zuerst von BizTalk Server A verarbeitet und ist für die Erwartung einer Empfangsbestätigung gekennzeichnet (Dokument 1 mit festgelegtem Kennzeichen Erwartete Empfangsbestätigung). Anschließend nimmt BizTalk Server B das Dokument über eine Empfangsfunktion entgegen (Dokument 1 mit festgelegtem Kennzeichen Empfangsbestätigung generieren), verarbeitet das Dokument und generiert eine Empfangsbestätigung [Empfangsbestätigung für Dokument 1 (ausgehend)]. BizTalk Server A erhält dann die Empfangsbestätigung [Empfangsbestätigung für Dokument 1 (eingehend)]

Ablauf von Empfangsbestätigungen

Wenn Sie die Empfangsbestätigung für Dokument 1 mit festgelegtem Kennzeichen Erwartete Empfangsbestätigung anzeigen, suchen Sie zuerst auf der Seite Abfrageergebnisse den Austauschdatensatz, der Dokument 1 mit festgelegtem Kennzeichen Erwartete Empfangsbestätigung entspricht. Wenn Sie im Feld Empfangsbestätigung auf das Symbol Empfangsbestätigung klicken, wird eine neue Seite Abfrageergebnisse angezeigt. Diese enthält den Austauschdatensatz, den BizTalk Server A beim Verarbeiten von Dokument 1 mit festgelegtem Kennzeichen Erwartete Empfangsbestätigung generiert hat. Wenn Sie in der Spalte Daten auf das Symbol Daten klicken, wird der eigentliche Inhalt der Empfangsbestätigung angezeigt. In der obigen Abbildung entspricht der letzte Schritt Empfangsbestätigung für Dokument 1 (eingehend).

Wenn Sie die Empfangsbestätigung für Dokument 1 mit festgelegtem Kennzeichen Empfangsbestätigung generieren anzeigen, müssen Sie zuerst auf der Seite Abfrageergebnisse den Austauschdatensatz suchen, der Dokument 1 mit festgelegtem Kennzeichen Empfangsbestätigung generieren entspricht. Wenn Sie im Feld Empfangsbestätigung auf das Symbol Empfangsbestätigung klicken, wird eine neue Seite Abfrageergebnisse angezeigt. Diese enthält den Austauschdatensatz, den BizTalk Server B beim Verarbeiten von Dokument 1 mit festgelegtem Kennzeichen Empfangsbestätigung generieren generiert hat. Erweitern Sie den Austauschdatensatz, um die Dokumentinstanzdetails anzuzeigen. Wenn Sie im Feld Daten auf das Symbol Daten klicken, wird der eigentliche Inhalt der Empfangsbestätigung angezeigt. In der obigen Abbildung entspricht der letzte Schritt Empfangsbestätigung für Dokument 1 (ausgehend).

Anmerkungen

  • Das Senden und Empfangen von Empfangsbestätigungen funktioniert nur mit Parsern, die Empfangsbestätigungen verarbeiten können. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  • Auf der Benutzeroberfläche der BizTalk-Dokumentüberwachung werden keine Reliable Messaging-Bestätigungen angezeigt.

Verwandte Themen

Protokollieren von Empfangsbestätigungen

Grundlagen des Überwachungsdatenbank-Schemas


Grundlegendes zu den Ergebnissen misslungener Übertragungen

Misslingt eine Übertragung, wird dieses Ereignis in der Überwachungsdatenbank protokolliert. Es werden jedoch nicht alle Fehler, die in der Überwachungsdatenbank protokolliert werden, auf der Benutzeroberfläche der BizTalk-Dokumentüberwachung angezeigt. Fehler werden nur dann auf der Benutzeroberfläche angezeigt, wenn ein Datensatz in der dta_outdoc_details-Tabelle protokolliert wurde. Weitere Informationen zu den Haupttabellen finden Sie unter Grundlagen des Überwachungsdatenbank-Schemas und Haupttabellen für Metadaten.

Anmerkung

  • Die Überwachungsdatenbank protokolliert keinen Austauschanalysefehler, wenn der Austauschnachspann eines EDI-Austauschs falsch ist. Wenn ein Austausch ein gültiges Dokument enthält, der Austauschnachspann jedoch falsche Informationen aufweist, erkennt der Parser dies als nicht schwer wiegenden Fehler und sendet das Dokument zur Verarbeitung an Microsoft BizTalk Server. In der Ereignisanzeige wird im Gegensatz zur Überwachungsdatenbank ein Fehler protokolliert, da die Überwachungsdatenbank nicht zwischen schwer wiegenden und nicht schwer wiegenden Fehlern unterscheidet.

Die folgende Tabelle zeigt mögliche Fehlermeldungen und ob Datensätze in den verschiedenen Haupttabellen der Überwachungsdatenbank protokolliert werden.

Fehlermeldung | Protokollierung von Datensätzen in | Kommentar
Kein Fehler | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Die entsprechenden Felder werden in den drei Haupttabellen protokolliert.
Eine benutzerdefinierte Komponente konnte nicht aufgerufen werden. | Keine | Diese Fehlermeldung wird nur dann angezeigt, wenn Sie einer Empfangsfunktion einen benutzerdefinierten Präprozessor zugeordnet haben. In der Überwachungsdatenbank werden keine Datensätze protokolliert.
Der Austausch konnte nicht analysiert werden. | dta_interchange_details (incoming) | Bei einem Analysefehler werden der Austausch und die Daten protokolliert.
Der angegebene Kanal ist nicht vorhanden. | dta_indoc_details dta_interchange_details (incoming) | Keine.
Der Austausch konnte nicht serialisiert werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | In der dta_interchange_details (outgoing)-Tabelle wird ein leerer Datensatz protokolliert. Wenn der Austausch erneut und mit Erfolg gesendet wird, erfolgt eine Aktualisierung des Datensatzes.
Der Austausch konnte nicht codiert werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Keine.
Der Austausch konnte nicht signiert werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Keine.
Der Austausch konnte nicht verschlüsselt werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Keine.
Fehler beim Übertragungsversuch (erneute Übertragung steht aus). | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Keine.
Fehler beim letzten Übertragungsversuch. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Keine.
Das Dokument konnte nicht analysiert werden. | dta_indoc_details dta_interchange_details (incoming) | Keine.
Das Dokument konnte nicht überprüft werden. | dta_indoc_details dta_interchange_details (incoming) | Keine.
Es konnte kein gültiger Kanal gefunden werden. | dta_indoc_details dta_interchange_details (incoming) | Keine.
Das Dokument konnte nicht zugeordnet werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Der Datensatz in der dta_outdoc_details-Tabelle zeichnet den Protokollierfehler auf, und in der dta_interchange_details (outgoing)-Tabelle wird ein leerer Datensatz protokolliert.
Es konnte kein gültiger Messagingport gefunden werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Der Datensatz in der dta_outdoc_details-Tabelle zeichnet einen NoPort-Fehler auf, und in der dta_interchange_details (outgoing)-Tabelle wird ein leerer Datensatz protokolliert.
Das Dokument konnte nicht serialisiert werden. | dta_indoc_details dta_interchange_details (incoming) dta_interchange_details (outgoing) dta_outdoc_details | Datensätze in den Tabellen dta_indoc_details und dta_outdoc_details enthalten den Serialisierungsfehler.

Verwandte Themen

Konfigurieren von Überwachungseigenschaften für eine Servergruppe

Angehalten-Warteschlange

Grundlagen des Überwachungsdatenbank-Schemas

Grundlegendes zum Schema der Überwachungsdatenbank


Grundlegendes zum integrierten XLANG-Ablaufplanstatus eines Austauschs

Sie können den Status zusammengehörender XLANG-Ablaufpläne in der BizTalk-Dokumentüberwachung überwachen. Aktionen in den Ablaufplänen auf einem Server können überwacht und in den entsprechenden Tabellen in der Überwachungsdatenbank mit einem Bezeichner gespeichert werden, der diese in Beziehung zu bestimmten Nachrichteninstanzen setzt. Das Speicherschema der Überwachungsdatenbank und die Korrelation sind Teil von Microsoft BizTalk Server 2002, doch ist die Ereignisabonnementfunktion nach der Installation von BizTalk Server 2002 nicht implementiert. Dafür steht eine Beispiel für die Ausführung der Überwachungsintegration zur Verfügung. Nach der Installation von BizTalk Server können Sie den Quellcode für dieses Beispiel im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit finden. Darüber hinaus enthält der Unterordner Bin die DLL-Datei (WorkFlowAudit.dll) für dieses Beispiel. Die dazugehörige Dokumentation finden Sie im Unterordner Docs in der Datei Readme.txt. Eine Beispielclientanwendung finden Sie in \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient.


Gründe für das Durchführen von BizTalk-Dokumentüberwachungsaufgaben

Dieser Abschnitt stellt eine kurze Referenz zum Durchführen von BizTalk-Dokumentüberwachungsaufgaben bereit. Die folgende Tabelle enthält Beschreibungen der Hauptaufgaben sowie der jeweiligen Unteraufgaben, Erläuterungen zum Zweck jeder Aufgabe und Links zu den entsprechenden Verfahren.

Aufgabe Zweck
  • Erstmaliges Öffnen der BizTalk-Dokumentüberwachung
 Zum Anzeigen des Status der von Microsoft® BizTalk™ Server 2002 verarbeiteten Dokumente. Sie können einfache oder erweiterte Abfragen erstellen, um die gewünschten Informationen aus der Überwachungsdatenbank in einem übersichtlichen Format abzurufen.
  • Hinzufügen von Benutzern zur Gruppe "Benutzer des BizTalk-Serverberichts"
 Zum Anzeigen der Benutzeroberfläche der BizTalk-Dokumentüberwachung und zum Speichern von Ausdrücken für erweiterte Abfragen. Sie müssen Mitglied der Gruppe Benutzer des BizTalk-Serverberichts sein, um diese Aufgaben ausführen zu können.
Verwalten der Überwachungsdatenbank:
  • Erstellen einer Archiv-Überwachungsdatenbank
 Zum Erstellen eines Repository, in das alte Austausch- und Dokumentinstanz-Datensätze zur Verwahrung eingefügt werden. Das Erstellen einer Archiv-Überwachungsdatenbank ist das erste von vier Verfahren, die Sie nacheinander durchführen müssen, um die Dienstprogramme für das Warten der Überwachungsdatenbank zu installieren.
  • Erstellen des Schemas für die Archiv-Überwachungsdatenbank
 Um die Archiv-Überwachungsdatenbank zu verwenden, müssen Sie ihr Schema erstellen. Das Erstellen des Schemas für die Archiv-Überwachungsdatenbank ist das zweite von vier Verfahren, die Sie nacheinander durchführen müssen, um die Dienstprogramme für das Warten der Überwachungsdatenbank zu installieren.
  • Konfigurieren der Überwachungsdatenbank für einen SQL-Verbindungsserver
 Zum Archivieren der Überwachungsdatenbank und Erstellen einer Verknüpfung mit der Archiv-Überwachungsdatenbank. Sie müssen beide Datenbanken konfigurieren, vorausgesetzt, sie befinden sich auf verschiedenen Servern. Das Konfigurieren der Überwachungsdatenbank ist das dritte von vier Verfahren, die Sie nacheinander durchführen müssen, um die Dienstprogramme für das Warten der Überwachungsdatenbank zu installieren.
  • Installieren der gespeicherten Prozeduren in der Überwachungsdatenbank
 Zum Archivieren und/oder Löschen alter Austausch- und Dokumentinstanz-Datensätze müssen Sie bestimmte gespeicherte Prozeduren in der Überwachungsdatenbank installieren. Das Installieren der gespeicherten Prozeduren in der Überwachungsdatenbank ist das letzte von vier Verfahren, die Sie nacheinander durchführen müssen, um die Dienstprogramme für das Warten der Überwachungsdatenbank zu installieren.
  • Überwachen von Datenbankarchiven/Löschen der Verwendung von gespeicherten Prozeduren
 Zum Archivieren und/oder Löschen alter Austausch- und Dokumentinstanz-Datensätze müssen Sie bestimmte gespeicherte Prozeduren in der Überwachungsdatenbank verwenden.
Verwenden von Abfragen zum Durchsuchen und Sortieren von Austausch- und Dokumentdaten:
  • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen
 Zum Verwenden von Abfragen, um Austausch- und Dokumentinstanz-Datensätze sowie dazugehörige Daten unter Verwendung von Standardsuchkriterien wie Datum zu suchen, anzuzeigen und zu speichern.
  • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen
 Zum Verwenden von Abfragen, um Austausch- und Dokumentinstanz-Datensätze sowie dazugehörige Daten unter Verwendung von Standardsuchkriterien wie Quellorganisation zu suchen, anzuzeigen und zu speichern.
  • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen
 Zum Verwenden von Abfragen, um Austausch- und Dokumentinstanz-Datensätze sowie dazugehörige Daten unter Verwendung von Standardsuchkriterien wie Dokumentinformationen zu suchen, anzuzeigen und zu speichern.
  • Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern
 Zum Kombinieren der folgenden Abfrageparameter in einer einzelnen Abfragesitzung, um Austausch- und Dokumentinstanz-Datensätze sowie dazugehörige Daten zu suchen, anzuzeigen und zu speichern: Quell- und Zielauswahl, Dokumenttyp und Datum und Uhrzeit.
  • Löschen von Suchkriterien für Organisationen und Dokumenttypen
 Zum Löschen aller Suchkriterien und Zurückkehren zur Standardsuche nach allen Quell- und Zielorganisationen und allen Dokumenttypen.
  • Anpassen der Seite "Abfrageergebnisse"
 Zum Anzeigen und Sortieren eingehender Austauschvorgänge gruppiert mit den dazugehörigen ausgehenden Austauschvorgängen.
  • Anzeigen der Suchparameter für die Seite "Abfrageergebnisse"
 Zum Anzeigen der folgenden Suchparameter und der dazugehörigen Werte: Zeitraum, Zeitzone, Ausdrucksname, Sortierreihenfolge, Organisationsauswahl und Dokumenttypauswahl.
Verwenden von erweiterten Abfragen:
  • Erstellen von erweiterten Abfragen
 Zum Suchen nach bestimmten Daten, z. B. einer Dokumentinstanz mit einer bestimmten Auftragsnummer.
  • Suchen nach vorhandenen erweiterten Abfragen
 Zum Laden und Wiederverwenden vorhandener erweiterter Abfragen, die Sie bereits erstellt und gespeichert haben.
  • Bearbeiten von vorhandenen erweiterten Abfragen
 Zum Hinzufügen, Ändern oder Entfernen bestimmter Bedingungen, um die Dokumentsuche einzuengen.
  • Löschen von vorhandenen erweiterten Abfragen
 Zum Löschen einer vorhandenen erweiterten Abfrage müssen Sie den aktuellen Ausdruck entfernen.
  • Löschen von vorhandenen erweiterten Abfragen
 Wenn Sie die bereits erstellten erweiterten Abfragen nicht mehr benötigen, können Sie diese auswählen und löschen, um eine kürzere Liste vorhandener erweiterter Abfragen zu verwalten.
Speichern von Austausch-, Dokument- und benutzerdefinierten Suchdaten:
  • Speichern von Austauschdaten
 Zum Anzeigen der Daten offline. Dadurch können Sie Probleme in bestimmten Situationen behandeln oder Ihre Geschäftsabläufe untersuchen.
  • Speichern von Dokumentinstanzdaten
 Zum Anzeigen der Daten offline. Dadurch können Sie Probleme in bestimmten Situationen behandeln oder Ihre Geschäftsabläufe untersuchen.
  • Speichern von Suchdaten benutzerdefinierter Felder
 Zum Anzeigen der Daten offline. Dadurch können Sie Probleme in bestimmten Situationen behandeln oder Ihre Geschäftsabläufe untersuchen.


Durchführen von BizTalk-Dokumentüberwachungsaufgaben

Dieser Abschnitt stellt aufgabenspezifische Informationen bereit, die veranschaulichen, wie Sie Suchergebnisse für Austausch- und Dokumentinstanz-Datensätze sowie dazugehörige Daten suchen, anzeigen und speichern können. Es wird dringend empfohlen, den Abschnitt Informationen zur BizTalk-Dokumentüberwachung zu lesen, um die Suchfunktionen und erwarteten Abfrageergebnisse vollständig zu verstehen.

Die BizTalk-Dokumentüberwachung bietet zwei Suchfunktionsebenen: Abfrage und erweiterte Abfrage. Sie können Abfragen verwenden, wenn Sie Dokumente anhand standardmäßiger Suchkriterien, wie z. B. Quellorganisation, suchen möchten. Mithilfe erweiterter Abfragen können Sie bestimmte Informationen in Dokumenten suchen, wie z. B. Auftragssumme.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstmaliges Öffnen der BizTalk-Dokumentüberwachung

  • Öffnen der BizTalk-Dokumentüberwachung

  • Hinzufügen von Benutzern zur Gruppe "Benutzer des BizTalk-Serverberichts"
  • Verwalten der Überwachungsdatenbank

  • Verwenden von Abfragen zum Durchsuchen und Sortieren von Austausch- und Dokumentdaten

  • Verwenden von erweiterten Abfragen

  • Speichern von Austausch-, Dokument- und benutzerdefinierten Suchdaten


Erstmaliges Öffnen der BizTalk-Dokumentüberwachung

Wenn Sie die BizTalk-Dokumentüberwachung zum ersten Mal öffnen und Windows Common Controls und das Steuerelement BizTalk-Dokumentüberwachung nicht auf dem Computer installiert sind, werden Sie zur Installation dieser Komponenten aufgefordert. Wenn diese Komponenten installiert sind, siehe Öffnen der BizTalk-Dokumentüberwachung.

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft BizTalk Server 2002, und klicken Sie auf BizTalk-Dokumentüberwachung.

    Das Dialogfeld Web Page Dialog wird angezeigt und fordert Sie zur Installation der folgenden Komponenten auf:

    • Windows Common Controls

    • BizTalk-Installationssteuerelement für die Dokumentüberwachung
  2. Klicken Sie auf Fortsetzen, um die Windows Common Controls zu installieren.

    Das Dialogfeld Sicherheitswarnung wird angezeigt.

  3. Klicken Sie auf Ja, um das BizTalk-Installationssteuerelement für die Dokumentüberwachung zu installieren.

Anmerkung

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zur Zone Vertrauenswürdige Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren von IIS-Einstellungen für BizTalk Server 2002.

Verwandte Themen

Konfigurieren von IIS-Einstellungen für BizTalk Server 2002

Öffnen der BizTalk-Dokumentüberwachung


Öffnen der BizTalk-Dokumentüberwachung

  • Zeigen Sie im Startmenü auf Programme, dann auf Microsoft BizTalk Server 2002, und klicken Sie auf BizTalk-Dokumentüberwachung.

    Oder

    Wenn Sie in Microsoft Internet Explorer einen Favoriten erstellt haben, können Sie die BizTalk-Dokumentüberwachung in Internet Explorer öffnen.

Anmerkung

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zur Zone Vertrauenswürdige Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren von IIS-Einstellungen für BizTalk Server 2002.

Verwandte Themen

Konfigurieren von IIS-Einstellungen für BizTalk Server 2002

Erstmaliges Öffnen der BizTalk-Dokumentüberwachung


Hinzufügen von Benutzern zur Gruppe "Benutzer des BizTalk-Serverberichts"

Sie müssen Mitglied der Gruppe Benutzer des BizTalk-Serverberichts sein, um die Benutzeroberfläche der BizTalk-Dokumentüberwachung anzuzeigen und Erweiterte Abfrage-Ausdrücke zu speichern. Außerdem muss Ihr Benutzeranmeldungskonto zum SQL Server-Anmeldungskonto hinzugefügt werden und die Rollen public, db_owner und dta_ui_role in der Überwachungsdatenbank (InterchangeDTA) erhalten. Weitere Informationen zum Einstellen von SQL Server-Anmeldungskonten und Einrichten von Datenbankberechtigungen finden Sie unter Interaktionen zwischen SQL Server und BizTalk Server 2002-Datenbanken.

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Computerverwaltung.

  2. Erweitern Sie System und Lokale Benutzer und Gruppen, und klicken Sie dann auf den Ordner Gruppen.

  3. Klicken Sie im Detailbereich auf Benutzer des BizTalk-Serverberichts.

  4. Zeigen Sie im Menü Vorgang auf Alle Tasks, und klicken Sie dann auf Mitglied hinzufügen.

    Das Dialogfeld Eigenschaften von Benutzer des BizTalk-Serverberichts wird angezeigt.

  5. Klicken Sie auf Hinzufügen.

  6. Klicken Sie in Suchen in auf den Namen Ihrer Domäne oder den Ihres Computers.

  7. Klicken Sie in der Liste mit den Benutzern und Computern, die der Domäne oder dem Computer zugeordnet sind, die/den Sie in Schritt 6 ausgewählt haben, auf das hinzuzufügende Benutzerkonto, dann auf Hinzufügen und schließlich auf OK.

  8. Klicken Sie auf OK, um das Dialogfeld Eigenschaften von Benutzer des BizTalk-Serverberichts zu schließen.


Verwalten der Überwachungsdatenbank

BizTalk Server enthält Dienstprogramme zur Wartung der Überwachungsdatenbank. Wenn Sie BizTalk Server installieren, werden die entsprechenden Dateien in den Ordner \Programme\Microsoft BizTalk Server\Setup kopiert. Zum Aktivieren dieser Dienstprogramme müssen Sie die Anweisungen in diesem Abschnitt befolgen.

Anmerkung

  • Wenn Sie in Ihrer BizTalk Server-Installation keine Austauschvorgänge und Dokumente überwachen oder die in BizTalk Server enthaltenen SQL-Skripts nicht verwenden möchten, um die Überwachungsdatenbank zu archivieren und zu leeren, müssen Sie die in diesem Abschnitt beschriebenen Verfahren nicht durchführen.

Führen Sie die folgenden Verfahren in der aufgeführten Reihenfolge durch, um die Dienstprogramme zum Warten der Überwachungsdatenbank zu installieren:

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer Archiv-Überwachungsdatenbank

  • Erstellen des Schemas für die Archiv-Überwachungsdatenbank

  • Konfigurieren der Überwachungsdatenbank für einen SQL-Verbindungsserver

  • Installieren der gespeicherten Prozeduren in der Überwachungsdatenbank
  • Überwachen von Datenbankarchiven/Löschen der Verwendung von gespeicherten Prozeduren

Wichtig

  • Wenn Sie die folgenden Verfahren nicht durchführen können, überprüfen Sie, ob das zum Herstellen einer Verbindung mit dem Server mit Microsoft® SQL™ Server verwendete Benutzerkonto über ausreichende Berechtigungen zum Erstellen von gespeicherten Prozeduren und SQL Server-Agent-Aufträgen verfügt.

  • Der Standardname der Überwachungsdatenbank lautet InterchangeDTA. Hat Ihre Überwachungsdatenbank einen anderen Namen, müssen Sie alle Vorkommen der Zeichenfolge InterchangeDTA im Skript BTS_Tracking_Archive_Purge_Script.sql in den Namen Ihrer Überwachungsdatenbank ändern.

Anmerkungen

  • Um Speicherplatz nicht unnötig zu belegen, wird das Aktivieren der Option Protokoll bei Prüfpunkt abschneiden empfohlen. Weitere Informationen zum Konfigurieren dieser Option finden Sie unter Vermeiden unnötiger Speicherplatzreservierung.

  • Weitere Informationen zu den gespeicherten Prozeduren, mit denen das Dienstprogramm für die Überwachungsdatenbank gewartet wird, finden Sie unter Überwachen von Datenbankarchiven/Löschen der Verwendung von gespeicherten Prozeduren.


Erstellen einer Archiv-Überwachungsdatenbank

Führen Sie auf dem Server, der als Host der Archiv-Überwachungsdatenbank dienen soll, die folgenden Schritte durch.

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft SQL Server, und klicken Sie auf Enterprise Manager.

  2. Erweitern Sie Microsoft SQL Server, dann SQL Server-Gruppe, und klicken Sie auf den Server, auf dem Sie eine Archiv-Überwachungsdatenbank erstellen möchten.

  3. Zeigen Sie im Menü Vorgang auf Neu, und klicken Sie auf Datenbank.

  4. Geben Sie im Dialogfeld Datenbankeigenschaften einen Namen für die Archiv-Überwachungsdatenbank ein, und klicken Sie auf OK.


Erstellen des Schemas für die Archiv-Überwachungsdatenbank

  1. Zeigen Sie im Menü Start auf Programme, dann auf Microsoft SQL Server, und klicken Sie auf Query Analyzer.

  2. Klicken Sie in der Liste SQL Server auf den Namen des SQL-Servers, der als Host der in Erstellen einer Archiv-Überwachungsdatenbank, erstellten Archiv-Überwachungsdatenbank dient, geben Sie die entsprechenden Anmeldeinformationen ein, und klicken Sie auf OK.

  3. Falls Sie Microsoft SQL Server 7.0 verwenden, klicken Sie in der Liste DB auf den Namen der Archiv-Überwachungsdatenbank, und fahren Sie mit Schritt 5 fort.

    Oder

    Wenn Sie Microsoft SQL Server 2000 installiert haben, klicken Sie im Menü Abfrage auf Datenbank ändern.

  4. Klicken Sie auf den Namen der Archiv-Überwachungsdatenbank und anschließend auf OK.

  5. Klicken Sie im Menü Datei auf Öffnen.

  6. Wechseln Sie im Dialogfeld Abfragedatei öffnen im Dialogfeld Suchen in zu \Programme\Microsoft BizTalk Server\Setup.

  7. Klicken Sie auf BTS_Tracking_ArchiveDB_Schema.sql und dann auf Öffnen.

  8. Klicken Sie im Menü Abfrage auf Ausführen.


Konfigurieren der Überwachungsdatenbank für einen SQL-Verbindungsserver

Führen Sie auf dem Server mit SQL Server, der als Host der Überwachungsdatenbank dient, die folgenden Schritte durch.

  1. Öffnen Sie, falls erforderlich, Query Analyzer.

  2. Klicken Sie im Menü Datei auf Trennen.

  3. Klicken Sie im Menü Datei auf Verbinden.

  4. Klicken Sie in der Liste SQL Server auf den Namen des Servers mit SQL Server, der als Host der zu archivierenden Überwachungsdatenbank dient, geben Sie die geforderten Anmeldeinformationen ein, und klicken Sie auf OK.

  5. Falls Sie SQL Server 7.0 verwenden, klicken Sie in der Liste DB auf den Namen der zu archivierenden Überwachungsdatenbank und fahren mit Schritt 7 fort.

    Beispiel: InterchangeDTA

    Oder

    Wenn Sie SQL Server 2000 installiert haben, klicken Sie im Menü Abfrage auf Datenbank ändern.

  6. Klicken Sie auf den Namen der Überwachungsdatenbank und anschließend auf OK.

    Beispiel: InterchangeDTA

    Anmerkung

    • Wählen Sie die Überwachungsdatenbank und nicht die Archiv-Überwachungsdatenbank aus.
  7. Konfigurieren Sie die Archiv-Überwachungsdatenbank als SQL-Verbindungsserver.

    Es folgt ein Beispiel einer SQL-Anweisung für die Konfiguration eines Verbindungsservers. In diesem Beispiel ist der Remotedatenbankserver "Seattle2" ein Verbindungsserver auf dem lokalen Server mit SQL Server:

    EXEC sp_addlinkedserver N'Seattle2',
 N'SQL Server'
  8. Konfigurieren Sie gegebenenfalls eine Zuordnung zwischen den Anmeldungen für den lokalen und die SQL Server-Remoteverbindungsserver.

    Es folgt ein Beispiel einer SQL-Anweisung zum Erstellen einer Zuordnung zwischen der Systemadministratoranmeldung (sa) auf dem lokalen und den SQL Server-Remoteverbindungsservern. Im Beispiel wird davon ausgegangen, dass die Remoteanmeldung für sa das Kennwort abc123 aufweist.

    EXEC sp_addlinkedsrvlogin '<Name of remote SQL Server>',
 'FALSE', 'sa', 'sa', 'abc123'

Wichtig

  • Wenn sich die Überwachungsdatenbank und die Archiv-Überwachungsdatenbank auf demselben SQL-Server befinden, müssen Sie keine Verbindungsserver einrichten. Wenn sich die Datenbanken auf separaten SQL-Servern befinden, sollten Sie die Überwachungsdatenbank und die Archiv-Überwachungsdatenbank als Verbindungsserver konfigurieren. In diesem Fall müssen Verbindungsserver für die gespeicherte Prozedur dta_purge_old_records eingerichtet sein, um alte Datensätze in der Remotearchiv-Überwachungsdatenbank zu archivieren (EINFÜGEN). Wenn Sie nur Datensätze löschen möchten, sind keine Verbindungsserver erforderlich.

  • Der Standardname der Überwachungsdatenbank lautet InterchangeDTA. Hat Ihre Überwachungsdatenbank einen anderen Namen, müssen Sie alle Vorkommen der Zeichenfolge InterchangeDTA im Skript BTS_Tracking_Archive_Purge_Script.sql in den Namen Ihrer Überwachungsdatenbank ändern.

Anmerkung

  • Wenn das Systemadministratorkonto kein Kennwort aufweist, muss eine leere Zeichenfolge (") verwendet werden. Aus Sicherheitsgründen wird diese Konfiguration nicht empfohlen.


Installieren der gespeicherten Prozeduren in die Überwachungsdatenbank

Führen Sie auf dem Server mit SQL Server, der als Host der Überwachungsdatenbank dient, die folgenden Schritte durch. Dabei muss es sich um den Server handeln, den Sie zuvor konfiguriert haben.

  1. Öffnen Sie, falls erforderlich, Query Analyzer.

  2. Klicken Sie im Menü Datei auf Öffnen.

  3. Wechseln Sie im Dialogfeld Abfragedatei öffnen in der Liste Suchen in zu \Programme\Microsoft BizTalk Server\Setup.

  4. Klicken Sie auf BTS_Tracking_Archive_Purge_Script.sql und dann auf Öffnen.

  5. Klicken Sie im Menü Abfrage auf Ausführen.

    Das Skript erstellt die gespeicherte Prozedur dta_purge_old_records. Das Skript erstellt außerdem den SQL Server-Agent-Auftrag "Archive and Purge BizTalk Tracking database: <Name der Überwachungsdatenbank>." Der SQL Server-Agent-Auftrag ist standardmäßig nicht aktiviert.

  6. Öffnen Sie, falls erforderlich, Enterprise Manager.

  7. Erweitern Sie Microsoft SQL Server, dann SQL Server-Gruppe, danach den Server, der als Host der Überwachungsdatenbank dient, anschließend Verwaltung, schließlich SQL Server-Agent, und klicken Sie auf Aufträge.

  8. Klicken Sie im Detailbereich auf Archive and Purge BizTalk Tracking Database: <Name der Überwachungsdatenbank>.

  9. Klicken Sie im Menü Vorgang auf Eigenschaften.

  10. Stellen Sie sicher, dass dtaStep_execute_stored_proc auf der Registerkarte Schritte ausgewählt ist, und klicken Sie auf Bearbeiten.

  11. Legen Sie im Dialogfeld Auftragsschritte bearbeiten auf der Registerkarte Allgemein im Feld Befehl die Eingabeparameter fest.

    Es folgen Beispiele für die Konfiguration der Eingabeparameter, die an die gespeicherte Prozedur dta_purge_old_records übergeben werden. Weitere Informationen zu den gespeicherten Prozeduren, mit denen das Dienstprogramm für die Überwachungsdatenbank gewartet wird, finden Sie unter Überwachen von Datenbankarchiven/Löschen der Verwendung von gespeicherten Prozeduren.

    • Bearbeiten Sie den Auftrag wie folgt, um alle vollständig verarbeiteten Austauschvorgänge und Dokumente, die älter als ein Tag sind, ohne Archivierung zu löschen:
      USE InterchangeDTA
EXEC dta_purge_old_records 1, 24, 1,0
    • Bearbeiten Sie den Auftrag wie folgt, um alle Austauschvorgänge unabhängig davon, ob sie vollständig verarbeitet wurden, mit Ausnahme der letzten 1.000 Austauschvorgänge zu archivieren und zu löschen:
      USE InterchangeDTA
EXEC dta_purge_old_records 2, 1000, 0, 1,
 N'<Name of a SQL Server>',
 N'<Name of the archive Tracking database>'
  12. Klicken Sie auf OK.

  13. Überprüfen Sie, ob BizTalk Archive and Purge Schedule auf der Registerkarte Zeitpläne ausgewählt ist, und klicken Sie auf Bearbeiten.

  14. Klicken Sie im Dialogfeld Auftragsschritte bearbeiten im Feld Zeitplantyp auf Ändern.

  15. Ändern Sie im Dialogfeld Zeitplan für wiederkehrende Aufträge bearbeiten entsprechend das Vorkommen sowie die Häufigkeit und Dauer des SQL Server-Agent-Auftrags, und klicken Sie auf OK.

  16. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Aktiviert, und klicken Sie auf OK.

    Die Änderungen werden gespeichert, und der SQL Server-Agent-Auftrag wird aktiviert.

Anmerkung

  • Bei diesem Verfahren wird davon ausgegangen, dass der Installationsordner für BizTalk Server 2002 \Programme\Microsoft BizTalk Server heißt. Wenn Sie BizTalk Server 2002 in einem anderen Ordner installiert haben, weichen die Ordnerpfade möglicherweise von den hier aufgelisteten Ordnerpfaden ab.


Überwachen von Datenbankarchiven/Löschen der Verwendung von gespeicherten Prozeduren

In diesem Thema werden die Syntax und Argumente der SQL-Skripts für die Überwachungsdatenbank beschrieben.

Syntax

Der folgende Code zeigt die Syntax der gespeicherten Prozedur dta_purge_old_records.

[ @nPurgeType = ] nPurgeType,
[ @nPurgeValue = ] nPurgeValue,
[ @nCompletedInterchangesOnly = ] nCompletedInterchangesOnly,
[ @nArchiveFlag = ] nArchiveFlag
[ , [ @nvcArchiveDBServer = ] N'nvcArchiveDBServer' ]
[ , [ @nvcArchiveDBName = ] N'nvcArchiveDBName' ]

Argumente

Die Syntax verwendet folgende Argumente:

[ @nPurgeType = ] nPurgeType

Das Argument [ @nPurgeType = ] nPurgeType ist ein ganzzahliger Wert, der angibt, ob die zu löschenden Austauschvorgänge nach Zeitstempel oder nach Zeilenzahl ausgewählt werden. Wenn nPurgeType = 1, werden Datensätze nach dem Zeitstempel gelöscht. Wenn nPurgeType = 2, werden Datensätze nach der Zeilenanzahl gelöscht.

[ @nPurgeValue = ] nPurgeValue

Das Argument [ @nPurgeValue = ] nPurgeValue ist ein ganzzahliger Wert. Die Bedeutung dieses Arguments hängt vom Wert von nPurgeType ab.

Ist der Wert von nPurgeType = 1, entspricht nPurgeValue der Anzahl der Stunden, die von CURRENT_TIMESTAMP zu subtrahieren sind, um zu ermitteln, wie Austauschvorgänge archiviert werden sollen, die älter als ein bestimmtes Datum und eine bestimmte Uhrzeit sind. Wenn Sie z. B. als Wert für nPurgeValue 96 angeben, werden Austauschvorgänge archiviert, die älter als 96 Stunden (vier Tage) sind.

Ist der Wert von nPurgeType = 2, entspricht nPurgeValue der Anzahl von Austauschvorgängen, die in der Datenbank verbleiben, nachdem Datensätze archiviert und aus der Datenbank gelöscht wurden. Bei Angabe von 25.000 werden z. B. alle Austauschvorgänge unter den obersten 25.000 Zeilen archiviert.

[ @nCompletedInterchangesOnly = ] nCompletedInterchangesOnly

Das Argument [ @nCompletedInterchangesOnly = ] nCompletedInterchangesOnly ist ein ganzzahliger Wert, der festlegt, ob Austauschvorgänge, die eine zusätzliche Verarbeitung erfordern, aus der Datenbank gelöscht werden. Einige Austauschvorgänge oder Dokumente warten ggf. auf eine Bestätigung oder müssen erneut übermittelt werden.

Wenn Sie nCompletedInterchangesOnly = 0 konfigurieren, entfernt der Löschauftrag Austauschvorgänge und Dokumente gleichgültig davon, ob diese eine weitere Verarbeitung benötigen. Das Festlegen dieses Arguments auf 0 führt zum schnelleren Ausführen des Löschauftrags, da weniger Filtervorgänge erfolgen.

Wenn Sie nCompletedInterchangesOnly = 1 konfigurieren, entfernt der Löschauftrag keine Austauschvorgänge und Dokumente, die eine weitere Verarbeitung benötigen. Das Festlegen dieses Arguments auf 1 führt zum langsameren Ausführen des Löschauftrags, da mehr Filtervorgänge erfolgen.

[ @nArchiveFlag = ] nArchiveFlag

Das Argument [ @nArchiveFlag = ] nArchiveFlag ist ein ganzzahliger Wert, der angibt, ob die gespeicherte Prozedur Austausch- und Dokumentdatensätze archiviert, ehe diese gelöscht werden. Ist der Wert von nArchiveFlag = 0, archiviert die gespeicherte Prozedur keine Austauschvorgang- oder Dokumentdatensätze. Ist der Wert von nArchiveFlag = 1, archiviert die gespeicherte Prozedur die Austauschvorgang- und Dokumentdatensätze, ehe diese aus der Datenbank gelöscht werden.

[ @nvcArchiveDBServer = ] nvcArchiveDBServer

Das Argument [ @nvcArchiveDBServer = ] nvcArchiveDBServer ist optional. Konfigurieren Sie dieses Argument, wenn Sie nArchiveFlag auf 1 einstellen. Dieses Argument hat den Datentyp nvarchar(128) und gibt den Namen des Datenbankservers an, auf dem die gespeicherte Prozedur die Austauschvorgang- und Dokumentdatensätze archiviert.

[ @nvcArchiveDBName = ] nvcArchiveDBName

Das Argument [ @nvcArchiveDBName = ] nvcArchiveDBName ist optional. Konfigurieren Sie dieses Argument, wenn Sie nArchiveFlag auf 1 festlegen. Dieses Argument hat den Datentyp nvarchar(128) und gibt den Namen der Datenbank an, in der die gespeicherte Prozedur die Austauschvorgang- und Dokumentdatensätze archiviert.


Verwenden von Abfragen zum Durchsuchen und Sortieren von Austausch- und Dokumentdaten

Mithilfe von Abfragen können Sie Austausch- und Dokumentinstanz-Datensätze sowie dazugehörige Daten unter Verwendung von Standardsuchkriterien wie Dokumenttyp oder Quellorganisation suchen, anzeigen und speichern.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

  • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

  • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

  • Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

  • Löschen von Suchkriterien für Organisationen und Dokumenttypen

  • Anpassen der Seite "Abfrageergebnisse"

  • Anzeigen der Suchparameter für die Seite "Abfrageergebnisse"

Anmerkungen

  • Seien Sie bei der Auswahl der Abfrageparameter so spezifisch wie möglich. Dadurch werden die Serverbelastung und die benötigte Zeit zur Rückgabe der Abfrageergebnisse reduziert.

  • Ein Dialogfeld mit der folgenden Meldung wird bei der Auswahl oder Abfrageauswahl möglicherweise angezeigt:

    Diese Seite greift auf Daten einer anderen Domäne zu. Möchten Sie dies zulassen?

    Damit diese Meldung im Internet Explorer nicht mehr angezeigt wird, können Sie eine sichere Website zur Zone Vertrauenswürdige Sites auf der Registerkarte Sicherheit im Dialogfeld Internetoptionen hinzufügen.

    Fügen Sie die Webanwendung zur Liste der vertrauenswürdigen Sites im Internet Explorer hinzu, um die Browsereinstellungen manuell so zu konfigurieren, dass dieser Webanwendung vertraut wird. Weitere Informationen zum Hinzufügen der Webanwendung zur Liste der vertrauenswürdigen Sites finden Sie unter Konfigurieren von IIS-Einstellungen für BizTalk Server 2002.

  • Wenn Sie in der Systemsteuerung in Ländereinstellungen ein nicht standardmäßiges Format für Datum, Zahlen, Zeit, Währung usw. konfiguriert haben, können Sie u. U. keine neuen Abfragen speichern bzw. keine erweiterte Abfragen anzeigen, die Sie gespeichert haben. Weitere Informationen finden Sie unter Verwenden von erweiterten Abfragen.

    Wählen Sie nur die in den Listen in Ländereinstellungen vorhandenen Optionen, damit alle vorhandenen erweiterten Abfragen angezeigt werden können. Wählen Sie z. B. auf der Registerkarte Datum in der Liste Kurzes Datumsformat enthaltene Optionen. Fügen Sie zur Liste Kurzes Datumsformat nicht durch Eingabe oder per Ausschneiden und Einfügen andere Formate hinzu.


Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Zeitraum in der Liste Datum anzeigen auf Ortszeit oder UTC, um die Zeitzone der angezeigten Datumsangaben anzugeben.

  2. Geben Sie in die Liste Von das Anfangsdatum des zu überwachenden Zeitraumes ein, oder klicken Sie auf den Pfeil, um einen Kalender anzuzeigen, in dem Sie ein Datum auswählen können.

    Geben Sie die Anfangszeit in die Liste neben der Liste Von ein, oder klicken Sie auf den NACH OBEN- oder NACH UNTEN-Pfeil, um den Zeitpunkt zu ändern.

  3. Geben Sie in die Liste Bis das Enddatum des zu überwachenden Zeitraumes ein, oder klicken Sie auf den Pfeil, um einen Kalender anzuzeigen, in dem Sie ein Datum auswählen können.

    Geben Sie die Anfangszeit in die Liste neben der Liste Bis ein, oder klicken Sie auf den NACH OBEN- oder NACH UNTEN-Pfeil, um den Zeitpunkt zu ändern.

  4. Klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

  5. Suchen Sie den Austauschdatensatz mit den anzuzeigenden Daten, und klicken in der Spalte Daten auf das entsprechende Symbol Daten, um Austauschdaten anzuzeigen.

    Die Seite Austauschdaten anzeigen wird angezeigt.

  6. Klicken Sie in der Spalte Ablaufplan auf das Symbol Ablaufplan, um den XLANG-Ablaufplanstatus eines Austauschs anzuzeigen.

    Die Seite Zusammenfassung des XLANG-Ablaufplanes anzeigen wird angezeigt.

  7. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch, der den anzuzeigenden Dokumentinstanz-Datensatz enthält, um einen Dokumentinstanz-Datensatz anzuzeigen, der einem Austausch zugeordnet ist.

  8. Klicken Sie im Feld Daten auf das entsprechende Symbol Daten, um die einer Dokumentinstanz zugeordneten Daten anzuzeigen.

    Die Seite Daten der Dokumentinstanz anzeigen wird angezeigt.

  9. Klicken Sie auf Im systemeigenen Format anzeigen oder Im XML-Format anzeigen, um die Daten im systemeigenen oder im XML-Format anzuzeigen.

  10. Klicken Sie im Feld Empfangsbestätigung auf das Symbol Empfangsbestätigung, um die zu einer Dokumentinstanz gehörenden Empfangsbestätigungsdaten anzuzeigen.

    Eine neue Seite Abfrageergebnisse wird angezeigt.

  11. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch und dann im Feld Daten auf das Symbol Daten.

  12. Suchen Sie das entsprechende Dokument, dessen Daten Sie anzeigen möchten, um für eine Dokumentinstanz die Daten im Feld der benutzerdefinierten Suche anzuzeigen, klicken Sie auf die horizontale Bildlaufleiste, um das Feld Benutzerdefinierte Suche anzuzeigen, und klicken Sie dann auf das Symbol Benutzerdefinierte Suche.

    Die Seite Inhalt des Feldes für benutzerdefinierte Suche anzeigen wird angezeigt.

Anmerkungen

  • Der in der Liste Datum anzeigen ausgewählte Wert steuert die Suchzeiten und Anzeigeergebnisse. Wenn Sie z. B. in Datum anzeigen die Option UTC wählen und in das Zeitfeld 0800 eingeben, suchen Sie alle Daten, die um oder nach 08:00 Uhr im UTC-Format (Universal Time Coordinated) verarbeitet wurden. Dies entspricht nicht 0800 Ortszeit.

  • Die Standarddatumseinstellung ist sieben Tage vor dem aktuellen Datum.

  • Die Standarddatumsangaben sind die von BizTalk Server generierten Zeitstempel für die Metadaten der Dokumentinstanzen und Austauschvorgänge. Es handelt sich nicht um Datumsangaben für den tatsächlichen Dokumentinhalt. Erstellen Sie einen Erweiterte Abfrage-Ausdruck, um Dokumente nach dem tatsächlichen Dokumentdatum zu suchen. Weitere Informationen zu erweiterten Abfragen finden Sie unter Erstellen von erweiterten Abfragen.

  • Wenn Sie in einer Abfrage nur einen Zeitraum angeben, sucht die BizTalk-Dokumentüberwachung nach allen Quell- und Zielorganisationen sowie nach allen Dokumenttypen. Dieser einzelne Suchparameter wird jedoch nicht empfohlen. Optimale Ergebnisse erhalten Sie, indem Sie stets eine Abfrage mit sehr spezifischen Parametern erstellen, um die Anzahl der Austauschdatensätze zu beschränken, die auf der Seite Abfrageergebnisse angezeigt werden.

  • Der XLANG-Ablaufplanstatus umfasst das letzte entdeckte Ereignis, die verarbeitete Startzeit, die verarbeitete Endzeit usw.

  • Wenn Microsoft Internet Explorer 5 auf dem Computer installiert ist, kann der Mauszeiger beim Anzeigen von Dokumentinstanzdaten als Sanduhr anstatt als Pfeil oder Pipe-Zeichen angezeigt werden. Wenn dies geschieht, können Sie weiterhin Im systemeigenen Format anzeigen oder Im XML-Format anzeigen auswählen oder auf die Schaltflächen Speichern unter und Schließen klicken. Nach der Aktualisierung auf Microsoft Internet Explorer 5.5 wird der Mauszeiger als Pfeil oder Pipe-Zeichen angezeigt.

Verwandte Themen

Erstellen von erweiterten Abfragen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Grundlegendes zu Abfragen


Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung in der Liste Quellauswahl auf die Organisation(en), deren Austauschvorgänge und Dokumente Sie anzeigen möchten. Klicken Sie neben der Organisation auf das Erweiterungssymbol (+) und anschließend auf die gewünschte(n) Anwendung(en), um eine Anwendung auszuwählen, die einer Quellorganisation zugeordnet ist. Klicken Sie auf Alles auswählen, um alle Quellorganisationen auszuwählen.

    Oder

    Klicken Sie in der BizTalk-Dokumentüberwachung in der Liste Zielauswahl auf die Organisation(en), deren Austauschvorgänge und Dokumente Sie anzeigen möchten. Klicken Sie neben der Organisation auf das Erweiterungssymbol (+) und anschließend auf die gewünschte(n) Anwendung(en), um eine Anwendung auszuwählen, die einer Zielorganisation zugeordnet ist. Klicken Sie auf Alles auswählen, um alle Zielorganisationen auszuwählen.

    In den Listen Quellauswahl und Zielauswahl können Sie Organisationen und Anwendungen für dieselbe Abfrage auswählen.

  2. Klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt. Alle Austauschvorgänge, die den Abfragekriterien entsprechen, werden hier aufgeführt.

  3. Suchen Sie den Austauschdatensatz mit den anzuzeigenden Daten, und klicken Sie in der Spalte Daten auf das Symbol Daten, um Austauschdaten anzuzeigen.

    Die Seite Austauschdaten anzeigen wird angezeigt.

  4. Klicken Sie in der Spalte Ablaufplan auf das Symbol Ablaufplan, um den XLANG-Ablaufplanstatus eines Austauschs anzuzeigen.

    Die Seite Zusammenfassung des XLANG-Ablaufplanes anzeigen wird angezeigt.

  5. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch, der den anzuzeigenden Dokumentinstanz-Datensatz enthält, um einen Dokumentinstanz-Datensatz anzuzeigen, der einem Austausch zugeordnet ist.

  6. Klicken Sie im Feld Daten auf das Symbol Daten, um die einer Dokumentinstanz zugeordneten Daten anzuzeigen.

    Die Seite Daten der Dokumentinstanz anzeigen wird angezeigt.

  7. Klicken Sie auf Im systemeigenen Format anzeigen oder Im XML-Format anzeigen, um die Daten im systemeigenen oder im XML-Format anzuzeigen.

  8. Klicken Sie im Feld Empfangsbestätigung auf das Symbol Empfangsbestätigung, um die zu einer Dokumentinstanz gehörenden Empfangsbestätigungsdaten anzuzeigen.

    Eine neue Seite Abfrageergebnisse wird angezeigt.

  9. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch und dann im Feld Daten auf das Symbol Daten.

  10. Suchen Sie das entsprechende Dokument, dessen Daten Sie anzeigen möchten, um für eine Dokumentinstanz die Daten im Feld der benutzerdefinierten Suche anzuzeigen, klicken Sie auf die horizontale Bildlaufleiste, um das Feld Benutzerdefinierte Suche anzuzeigen, und klicken Sie dann auf das Symbol Benutzerdefinierte Suche.

    Die Seite Inhalt des Feldes für benutzerdefinierte Suche anzeigen wird angezeigt.

Anmerkungen

  • Wenn Sie keine bestimmten Quell- und Zielorganisationen auswählen, gibt die Abfrage Austausch- und Dokumentdatensätze aller Quell- und Zielorganisationen zurück. Die Optionen Alles löschen und Alles auswählen generieren auf der Seite Abfrageergebnisse dieselben Ergebnisse. Optimale Ergebnisse erhalten Sie, indem Sie stets eine Abfrage mit sehr spezifischen Parametern erstellen, um die Anzahl der Austauschdatensätze zu beschränken, die auf der Seite Abfrageergebnisse generiert werden.

  • Der XLANG-Ablaufplanstatus umfasst das letzte entdeckte Ereignis, die verarbeitete Startzeit, die verarbeitete Endzeit usw.

  • Wenn Microsoft Internet Explorer 5 auf dem Computer installiert ist, kann der Mauszeiger beim Anzeigen von Dokumentinstanzdaten als Sanduhr anstatt als Pfeil oder Pipe-Zeichen angezeigt werden. Wenn dies geschieht, können Sie weiterhin Im systemeigenen Format anzeigen oder Im XML-Format anzeigen auswählen oder auf die Schaltflächen Speichern unter und Schließen klicken. Nach der Aktualisierung auf Microsoft Internet Explorer 5.5 wird der Mauszeiger als Pfeil oder Pipe-Zeichen angezeigt.

Verwandte Themen

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Grundlegendes zu Abfragen


Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Auswahl des Dokumenttyps auf Dokumente anzeigen.

  2. Klicken Sie in der Liste Auswahl des Dokumenttyps auf den Dokumenttyp, den Sie suchen möchten. Klicken Sie auf Alles auswählen, um alle Dokumenttypen auszuwählen.

  3. Klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

  4. Suchen Sie den Austauschdatensatz mit den anzuzeigenden Daten, und klicken Sie in der Spalte Daten auf das Symbol Daten, um Austauschdaten anzuzeigen.

    Die Seite Austauschdaten anzeigen wird angezeigt.

  5. Klicken Sie in der Spalte Ablaufplan auf das Symbol Ablaufplan, um den XLANG-Ablaufplanstatus eines Austauschs anzuzeigen.

    Die Seite Zusammenfassung des XLANG-Ablaufplanes anzeigen wird angezeigt.

  6. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch, der den anzuzeigenden Dokumentinstanz-Datensatz enthält, um einen Dokumentinstanz-Datensatz anzuzeigen, der einem Austausch zugeordnet ist.

  7. Klicken Sie im Feld Daten auf das Symbol Daten, um die einer Dokumentinstanz zugeordneten Daten anzuzeigen.

    Die Seite Daten der Dokumentinstanz anzeigen wird angezeigt.

  8. Klicken Sie auf Im systemeigenen Format anzeigen oder Im XML-Format anzeigen, um die Daten im systemeigenen oder im XML-Format anzuzeigen.

  9. Klicken Sie im Feld Empfangsbestätigung auf das Symbol Empfangsbestätigung, um die zu einer Dokumentinstanz gehörenden Empfangsbestätigungsdaten anzuzeigen.

    Eine neue Seite Abfrageergebnisse wird angezeigt.

  10. Klicken Sie auf das Erweiterungssymbol (+) neben dem Austausch und dann im Feld Daten auf das Symbol Daten.

  11. Suchen Sie das entsprechende Dokument, dessen Daten Sie anzeigen möchten, um für eine Dokumentinstanz die Daten im Feld der benutzerdefinierten Suche anzuzeigen, klicken Sie auf die horizontale Bildlaufleiste, um das Feld Benutzerdefinierte Suche anzuzeigen, und klicken Sie dann auf das Symbol Benutzerdefinierte Suche.

    Die Seite Inhalt des Feldes für benutzerdefinierte Suche anzeigen wird angezeigt.

Anmerkungen

  • Wenn Sie zum Einengen der Suche nicht einen oder mehrere Dokumenttypen auswählen, gibt die Abfrage alle Dokumenttypen in der Liste zurück. Optimale Ergebnisse erhalten Sie, indem Sie stets eine Abfrage mit sehr spezifischen Parametern erstellen, um die Anzahl der Austauschdatensätze zu beschränken, die auf der Seite Abfrageergebnisse generiert werden.

  • Der XLANG-Ablaufplanstatus umfasst das letzte entdeckte Ereignis, die verarbeitete Startzeit, die verarbeitete Endzeit usw.

  • Wenn Microsoft Internet Explorer 5 auf dem Computer installiert ist, kann der Mauszeiger beim Anzeigen von Dokumentinstanzdaten als Sanduhr anstatt als Pfeil oder Pipe-Zeichen angezeigt werden. Wenn dies geschieht, können Sie weiterhin Im systemeigenen Format anzeigen oder Im XML-Format anzeigen auswählen oder auf die Schaltflächen Speichern unter und Schließen klicken. Nach der Aktualisierung auf Microsoft Internet Explorer 5.5 wird der Mauszeiger als Pfeil oder Pipe-Zeichen angezeigt.

Verwandte Themen

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

Grundlegendes zu den Ergebnissen von Austauschdatensätzen

Grundlegendes zu Abfragen


Suchen nach Austausch- und Dokumentinformationen durch Kombinieren von Abfrageparametern

  1. In der BizTalk-Dokumentüberwachung können Sie die folgenden Abfrageparameter in einer einzelnen Abfragesitzung kombinieren, um Austausch- und Dokumentinstanz-Datensätze und dazugehörige Daten zu suchen und anzuzeigen:
    • Quellauswahl. Weitere Informationen zum Erstellen von Abfragen mithilfe des Quellauswahlparameters finden Sie unter Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen.

    • Zielauswahl. Weitere Informationen zum Erstellen von Abfragen mithilfe des Zielauswahlparameters finden Sie unter Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen.

    • Dokumenttyp. Weitere Informationen zum Erstellen von Abfragen mithilfe des Dokumenttypparameters finden Sie unter Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen.

    • Datum und Zeit. Weitere Informationen zum Erstellen von Abfragen mithilfe der Datum- und Zeitparameter finden Sie unter Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen.
  2. Klicken Sie auf die Schaltfläche Abfrage.


Löschen von Suchkriterien für Organisationen und Dokumenttypen

  • Klicken Sie in der BizTalk-Dokumentüberwachung unter Quellauswahl, Zielauswahl oder Auswahl des Dokumenttyps auf Alles löschen.

Anmerkung

  • Wenn Sie auf Alles löschen klicken, kehrt die BizTalk-Dokumentüberwachung zur Standardsuche für alle Quell- und Zielorganisationen und alle Dokumenttypen zurück. Optimale Ergebnisse erhalten Sie, indem Sie stets eine Abfrage mit sehr spezifischen Parametern erstellen, um die Anzahl der Austauschdatensätze zu beschränken, die auf der Seite Abfrageergebnisse angezeigt werden.


Anpassen der Seite "Abfrageergebnisse"

  1. Aktivieren Sie in der BizTalk-Dokumentüberwachung unter Sortiersteuerung das Kontrollkästchen Eingehende/ausgehende Austauschvorgänge gruppieren.

    Durch diesen Schritt wird die Seite Abfrageergebnisse so konfiguriert, dass eingehende Austauschvorgänge mit dazugehörigen Austauschvorgängen gruppiert werden. Deaktivieren Sie dieses Kontrollkästchen, wenn eingehende Austauschvorgänge nicht mit dazugehörigen Austauschvorgängen angezeigt werden sollen.

  2. Klicken Sie unter Sortiersteuerung in der Liste Sortierreihenfolge 1 auf die erste Sortierfolgeoption, die Sie verwenden möchten. Wiederholen Sie diesen Schritt für alle Listen mit Sortierreihenfolgen, um die Sortierreihenfolge der Dokumente auf der Seite Abfrageergebnisse zu konfigurieren.

    Jede Sortierreihenfolge-Liste enthält die folgenden Optionen:

    • Quellorganisationsname

    • Quellanwendungsname

    • Zielorganisationsname

    • Zielanwendungsname

    • Dokumenttyp

    • Verarbeitungszeitpunkt


Anzeigen der Suchparameter für die Seite "Abfrageergebnisse"

  1. Legen Sie Parameter für eine Abfrage fest, und klicken Sie dann auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

    Weitere Informationen zum Erstellen von Abfragen bzw. erweiterter Abfragen finden Sie unter:

    • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Erstellen von erweiterten Abfragen
  2. Klicken Sie in der Leiste Suchparameter auf das Symbol Anzeigen.

    Unter Suchparameter werden die folgenden Suchparameter und dazugehörigen Werte aufgeführt:

    • Zeitraum

    • Zeitzone

    • Ausdrucksname

    • Sortierreihenfolge

    • Quellauswahl

    • Zielauswahl

    • Auswahl des Dokumenttyps

Verwandte Themen

Erstellen von erweiterten Abfragen

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen


Verwenden von erweiterten Abfragen

Wenn Sie bestimmte Daten suchen müssen, wie z. B. eine Dokumentinstanz mit einer bestimmten Auftragsnummer, können Sie dazu eine erweiterte Abfrage verwenden.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von erweiterten Abfragen

  • Suchen nach vorhandenen erweiterten Abfragen

  • Bearbeiten von vorhandenen erweiterten Abfragen

  • Löschen von vorhandenen erweiterten Abfragen

  • Löschen von vorhandenen erweiterten Abfragen

Anmerkungen

  • Wenn Sie in der Systemsteuerung in Ländereinstellungen ein nicht standardmäßiges Format für Datum, Zahlen, Zeit, Währung usw. gewählt haben, können Sie u. U. keine neuen Abfragen speichern bzw. keine erweiterte Abfragen anzeigen, die Sie gespeichert haben. Weitere Informationen finden Sie unter Verwenden von erweiterten Abfragen.

    Wählen Sie nur die in den Listen in Ländereinstellungen vorhandenen Optionen, damit alle vorhandenen erweiterten Abfragen angezeigt werden können. Wählen Sie z. B. auf der Registerkarte Datum in der Liste Kurzes Datumsformat enthaltene Optionen. Fügen Sie zur Liste Kurzes Datumsformat nicht durch Eingabe oder per Ausschneiden und Einfügen andere Formate hinzu.

  • Die Datentypen Float und Real werden annähernde Datentypen genannt. Das Verhalten von Float und Real folgt der IEEE 754-Spezifikation für annähernde numerische Datentypen. Annähernde numerische Datentypen speichern nicht die für viele Zahlen angegebenen exakten Werte, sondern eine extrem nahe Annäherung an den Wert. In vielen Anwendungen spielt der minimale Unterschied zwischen dem angegebenen Wert und der gespeicherten Näherung keine Rolle. Es gibt jedoch Situationen, in denen der Unterschied deutlich ist. Verwenden Sie aufgrund des annähernden Charakters von Float und Real diese Datentypen nicht, wenn ein exaktes numerisches Verhalten erforderlich ist, wie z. B. in Finanzanwendungen, bei Vorgängen mit Rundungen oder bei Gleichheitsüberprüfungen. Verwenden Sie stattdessen die Datentypen Integer, Decimal, Money oder Smallmoney.

  • BizTalk Server erlaubt das Überwachen des Number-Datentyps als Integer-Datentyp. Wenn der Wert der Zahl im Dokument die Größe des Integer-Datentyps überschreitet, wird eine Warnmeldung angezeigt. Diese Warnmeldung enthält den Wert, der nicht überwacht werden konnte.

    Überschreiten Sie nicht die Größe des Integer-Datentyps, wenn der Number-Datentyp als Integer überwacht wird.

Internationales Problem

  • Je nach Systemgebietsschema kann ein numerischer Wert in XML-Daten von BizTalk Server falsch interpretiert werden, wenn dieser als ganzzahliges Überwachungsfeld in der Überwachungsdatenbank protokolliert wird. Bei einem deutschen Gebietsschema wird der XML-Zahlenwert 4.0 in der Überwachungsdatenbank als 40 protokolliert, da das Dezimaltrennzeichen (.) als Symbol für die Zifferngruppierung falsch interpretiert wird.

    Für dieses Problem gibt es zwei Lösungen. Wenn Sie im Voraus wissen, dass der Element-/Attributwert eine Dezimalzahl speichert, können Sie den Element-/Attributdatentyp in Real (r4) oder Double Real (r8) ändern. Alternativ können Sie die Dokumentdefinition oder den Kanal so konfigurieren, dass ein Element/Attribut mit dem Datentyp Number als Real anstatt Integer protokolliert wird.


Erstellen von erweiterten Abfragen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Neu.

    Die Seite Generator für erweiterte Abfragen wird angezeigt.

  2. Klicken Sie in der Liste Quellauswahl auf eine Option, um die Quellauswahlkriterien anzugeben.

    Dies ist der Name des erfassten Feldes, nach dem Sie suchen.

  3. Klicken Sie in der Liste Operatoren auf einen Operator.

  4. Geben Sie in das Feld Wert einen Wert ein.

  5. Klicken Sie in der Liste AND/OR auf AND oder OR, um diese Bedingung mit einer anderen Bedingung zu kombinieren oder zu vergleichen. Dieser Schritt ist optional.

  6. Klicken Sie auf Fertig.

  7. Wiederholen Sie die Schritte 2 bis 6, bis alle gewünschten Bedingungen hinzugefügt sind.

  8. Führen Sie eines der folgenden Verfahren durch:
    • Klicken Sie auf OK, um die Verwendung dieses Ausdrucks auf die aktuelle Abfragesitzung zu beschränken.

    • Klicken Sie auf Speichern, um den Ausdruck für künftige Abfragesitzungen zu speichern. Geben Sie in das Dialogfeld BizTalk-Dokumentüberwachung den Ausdrucksnamen in das Feld Geben Sie den Ausdrucksnamen ein ein (beschränken Sie den Ausdrucksnamen auf 50 Zeichen), und klicken Sie auf OK.

Vorsicht

  • Stellen Sie sicher, dass Sie für Ihre Abfragen eindeutige Namen verwenden und die Groß-/Kleinschreibung berücksichtigen. Es werden keine neuen Datensätze für das Überwachungsfeld erstellt, wenn ein Vergleich ohne Unterscheidung von Groß-/Kleinschreibung mit einem vorhandenen Eintrag und dem Datentyp übereinstimmt. Sie können zwar Abfragen mit identischen Namen in die BizTalk-Dokumentüberwachung eingeben, um sie unterscheiden zu können, müssen Sie dann jedoch jede Abfrage öffnen und minimieren damit ihren Nutzen.

  • Geben Sie die benutzerdefinierten Felder stets genau so ein, wie sie im überwachten Dokument angezeigt werden.

Anmerkungen

  • Die Zusammenstellung einer oder mehrerer Bedingungen in einer erweiterten Abfrage wird Ausdruck genannt.

  • Wenn der Eingabefokus auf der Liste Quellauswahl ist und Sie auf eine Schaltfläche klicken, müssen Sie gegebenenfalls nochmals auf die Schaltfläche klicken, um sie zu aktivieren.

  • Wenn Sie im BizTalk-Messaging-Manager einen Kanal oder eine Dokumentdefinition für die Überwachung benutzerdefinierter Felder konfiguriert haben, werden diese Felder in der Liste Quellauswahl angezeigt. Wenn der BizTalk-Messaging-Manager nicht für die Überwachung von Feldern konfiguriert wurde, wird in der Liste Quellauswahl nur <Benutzerdefinierte Suche> angezeigt. Weitere Informationen zum Überwachen bestimmter Felder finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung und Auswählen von Spezifikationsfeldern in einem Kanal.

  • Wenn Sie Austauschvorgänge oder Dokumente mithilfe benutzerdefinierter Suchfelder überwachen und Sie einen Wert abfragen, werden nur die Austauschvorgänge bzw. Dokumente aus den benutzerdefinierten Suchfeldern auf der Seite Abfrageergebnisse angezeigt.

Verwandte Themen

Löschen von vorhandenen erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen

Bearbeiten von vorhandenen erweiterten Abfragen

Suchen nach vorhandenen erweiterten Abfragen


Suchen nach vorhandenen erweiterten Abfragen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Durchsuchen.

    Das Dialogfeld Erweiterte Abfragen wird angezeigt.

  2. Wählen Sie eine vorhandene Abfrage aus, und klicken Sie auf OK.

Anmerkung

  • Wenn der Eingabefokus auf der Liste Quellauswahl ist und Sie auf eine Schaltfläche klicken, müssen Sie gegebenenfalls nochmals auf die Schaltfläche klicken, um sie zu aktivieren.

Verwandte Themen

Erstellen von erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen

Bearbeiten von vorhandenen erweiterten Abfragen


Bearbeiten von vorhandenen erweiterten Abfragen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Durchsuchen.

    Das Dialogfeld Erweiterte Abfragen wird angezeigt.

  2. Wählen Sie eine vorhandene Abfrage aus, und klicken Sie auf Bearbeiten.

    Das Dialogfeld Generator für erweiterte Abfragen wird angezeigt.

  3. Führen Sie eines oder mehrere der folgenden Verfahren durch:
    • Klicken Sie auf Neu, um eine weitere Bedingung hinzuzufügen. Geben Sie Bedingungen für jedes der vier Felder an, und klicken Sie auf Fertig.

    • Klicken Sie auf eine vorhandene Bedingung, dann auf Bearbeiten, ändern Sie die vier Felder, und klicken Sie auf Fertig.

    • Wählen Sie eine vorhandene Abfrage aus, und klicken Sie auf Entfernen.
  4. Klicken Sie auf Speichern.

    Das Dialogfeld Erweiterte Abfragen wird angezeigt.

  5. Wählen Sie die zuvor bearbeitete Abfrage aus, und klicken Sie auf OK.

Anmerkung

  • Wenn der Eingabefokus auf der Liste Quellauswahl ist und Sie auf eine Schaltfläche klicken, müssen Sie gegebenenfalls nochmals auf die Schaltfläche klicken, um sie zu aktivieren.

Verwandte Themen

Erstellen von erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen

Suchen nach vorhandenen erweiterten Abfragen


Löschen von vorhandenen erweiterten Abfragen

  • Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Löschen, um den aktuellen Ausdruck aus dem Feld Ausdrucksname zu entfernen.

Anmerkung

  • Wenn Sie in Internet Explorer auf die Schaltfläche Aktualisieren klicken, wird die erweitere Abfrage nicht aus dem Feld Ausdrucksname gelöscht.

Verwandte Themen

Erstellen von erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen

Bearbeiten von vorhandenen erweiterten Abfragen

Suchen nach vorhandenen erweiterten Abfragen


Löschen von vorhandenen erweiterten Abfragen

  1. Klicken Sie in der BizTalk-Dokumentüberwachung unter Erweiterte Abfrage auf Durchsuchen.

    Die Seite Erweiterte Abfragen wird angezeigt.

  2. Wählen Sie eine Abfrage aus, und klicken Sie auf Löschen.

  3. Schließen Sie das Dialogfeld Erweiterte Abfragen, wenn Sie fertig sind.

Anmerkung

  • Wenn der Eingabefokus auf der Liste Quellauswahl ist und Sie auf eine Schaltfläche klicken, müssen Sie gegebenenfalls nochmals auf die Schaltfläche klicken, um sie zu aktivieren.

Verwandte Themen

Erstellen von erweiterten Abfragen

Löschen von vorhandenen erweiterten Abfragen aus einer Abfrage

Bearbeiten von vorhandenen erweiterten Abfragen

Suchen nach vorhandenen erweiterten Abfragen


Speichern von Austausch-, Dokument- und benutzerdefinierten Suchdaten

Wenn der BizTalk-Messaging-Manager, das BizTalk-Messaging-Konfigurationsobjektmodell und/oder die BizTalk Server-Verwaltung so konfiguriert sind, dass ein- und ausgehende Austauschvorgänge und die entsprechenden Dokumente gespeichert werden, können Sie Austauschvorgänge, Dokumentdaten und Suchdaten benutzerdefinierter Felder speichern, um diese im Offlinemodus anzuzeigen. Dadurch können Sie Probleme in bestimmten Situationen behandeln oder Ihre Geschäftsabläufe untersuchen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Speichern von Austauschdaten

  • Speichern von Dokumentinstanzdaten

  • Speichern von Suchdaten benutzerdefinierter Felder


Speichern von Austauschdaten

  1. Legen Sie Parameter für eine Abfrage fest, und klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

    Weitere Informationen zum Erstellen von Abfragen bzw. erweiterter Abfragen finden Sie unter:

    • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Erstellen von erweiterten Abfragen
  2. Klicken Sie im Feld Daten auf das Symbol Daten, um den Austauschdatensatz mit den gewünschten Austauschdaten zu suchen, die Sie speichern möchten.

    Die Seite Austauschdaten anzeigen wird angezeigt.

  3. Klicken Sie auf Speichern unter.

  4. Geben Sie in das Feld Dateiname einen Namen für die Datei ein, und klicken Sie auf Speichern.

Verwandte Themen

Erstellen von erweiterten Abfragen

Speichern von Suchdaten benutzerdefinierter Felder

Speichern von Dokumentinstanzdaten

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen


Speichern von Dokumentinstanzdaten

  1. Legen Sie Parameter für eine Abfrage fest, und klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

    Weitere Informationen zum Erstellen von Abfragen bzw. erweiterter Abfragen finden Sie unter:

    • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Erstellen von erweiterten Abfragen
  2. Suchen Sie den Austauschdatensatz mit den Dokumentinstanzdaten, die Sie speichern möchten, und klicken Sie links neben dem Austausch auf das Erweiterungssymbol (+).

  3. Klicken Sie im Feld Daten auf das Symbol Daten.

    Die Seite Daten der Dokumentinstanz anzeigen wird angezeigt.

  4. Klicken Sie auf Speichern unter.

  5. Geben Sie in das Feld Dateiname für die Datei einen Namen und eine Erweiterung ein (entweder die XML-Dateierweiterung oder die systemeigene Dateierweiterung des Dokuments), und klicken Sie auf Speichern.

Verwandte Themen

Erstellen von erweiterten Abfragen

Speichern von Suchdaten benutzerdefinierter Felder

Speichern von Austauschdaten

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen


Speichern von Suchdaten benutzerdefinierter Felder

  1. Legen Sie Parameter für eine Abfrage fest, und klicken Sie auf die Schaltfläche Abfrage.

    Die Seite Abfrageergebnisse wird angezeigt.

    Weitere Informationen zum Erstellen von Abfragen bzw. erweiterter Abfragen finden Sie unter:

    • Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

    • Erstellen von erweiterten Abfragen
  2. Klicken Sie links neben dem Austauschdatensatz mit dem Dokument, das Sie anzeigen möchten, auf das Erweiterungssymbol (+).

  3. Klicken Sie auf die horizontale Bildlaufleiste, um das Feld Benutzerdefinierte Suche für das Dokument einzublenden, das Sie anzeigen möchten, und klicken Sie auf das Symbol Benutzerdefinierte Suche.

    Die Seite Inhalt des Feldes für benutzerdefinierte Suche anzeigen wird angezeigt.

  4. Klicken Sie auf Speichern unter.

  5. Geben Sie in das Feld Dateiname einen Namen für die Datei ein, und klicken Sie auf Speichern.

Verwandte Themen

Erstellen von erweiterten Abfragen

Speichern von Dokumentinstanzdaten

Speichern von Austauschdaten

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen

Dokumenttypabhängiges Suchen nach Austausch- und Dokumentinformationen

Organisationsabhängiges Suchen nach Austausch- und Dokumentinformationen


Problembehandlung - BizTalk-Dokumentüberwachung

Dieser Abschnitt stellt allgemeine Informationen zur Problembehandlung in der BizTalk-Dokumentüberwachung bereit.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Probleme beim Anzeigen der Benutzeroberfläche der BizTalk-Dokumentüberwachung

  • Austauschvorgänge werden nicht gespeichert

  • Dokumente werden nicht gespeichert

  • Die Abfrageergebnisse sind leer

  • In den Abfrageergebnissen werden keine Überwachungsfelder angezeigt

  • Zu viele Suchargumente


Probleme beim Anzeigen der Benutzeroberfläche der BizTalk-Dokumentüberwachung

Ursache: Microsoft Office Web-Komponenten sind nicht installiert.

Lösung: Installieren Sie Microsoft Office Web-Komponenten.

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

  2. Doppelklicken Sie auf Software.

    Das Dialogfeld Software wird angezeigt.

  3. Klicken Sie auf Microsoft Office 2000 SR-1 Premium.

  4. Klicken Sie auf Ändern.

  5. Klicken Sie auf Features hinzufügen/entfernen.

  6. Klicken Sie auf das Erweiterungssymbol (+) neben Office Tools.

  7. Klicken Sie auf Office Web-Komponenten und dann auf die für Ihre Installation geeignete Option.

  8. Klicken Sie auf Jetzt aktualisieren.


Austauschvorgänge werden nicht gespeichert

Ursache: In der BizTalk Server-Verwaltung ist die Überwachung deaktiviert.

Lösung: Aktivieren Sie die Überwachung in der BizTalk Server-Verwaltung.

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk Server-Verwaltung.

  2. Erweitern Sie Microsoft BizTalk Server 2002, und klicken Sie auf die Servergruppe, deren Dokumente nicht gespeichert werden.

  3. Klicken Sie im Menü Vorgang auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalk Server-Gruppe wird angezeigt.

  4. Klicken Sie auf die Registerkarte Überwachen.

  5. Aktivieren Sie das Kontrollkästchen Dokumentüberwachung aktivieren.

  6. Wählen Sie eine oder mehrere der folgenden Optionen aus:
    • Eingehenden Austausch protokollieren

    • Ausgehenden Austausch protokollieren

    • Ursprüngliche MIME-codierte Nachricht protokollieren
  7. Klicken Sie auf OK.

Verwandtes Thema

Konfigurieren von Überwachungseigenschaften für eine Servergruppe


Dokumente werden nicht gespeichert

Ursache: Die Eigenschaften für die Dokumentprotokollierung wurden in den Kanalkonfigurationen im BizTalk-Messaging-Manager nicht richtig eingerichtet.

Lösung: Aktivieren Sie die entsprechenden Dokumentprotokollierungsoptionen in den Kanalkonfigurationen.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Messaging-Manager.

  2. Aktivieren Sie auf der Seite Dokumentprotokollierung des Kanal-Assistenten im Bereich Eingehendes Dokument protokollieren die entsprechenden Kontrollkästchen:

  3. Im systemeigenen Format. Speichert eingehende Dokumente für den Kanal im ursprünglichen Format. Dies ist die Standardeinstellung.

  4. Im XML-Format. Speichert eingehende Dokumente für den Kanal im XML-Format.

  5. Aktivieren Sie im Bereich Ausgehendes Dokument protokollieren die entsprechenden Kontrollkästchen:

  6. Im systemeigenen Format. Speichert ausgehende Dokumente für den Kanal im ursprünglichen Format.

  7. Im XML-Format. Speichert ausgehende Dokumente für den Kanal im XML-Format.

  8. Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

  9. Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen.

  10. Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.


Die Abfrageergebnisse sind leer

Ursache 1: Der Datums- und Zeitraum ist falsch.

Lösung: Überprüfen Sie, ob der Datums- und Zeitraum richtig ist. Wenn Sie z. B. ein Dokument in den vergangenen 5 Minuten gesendet haben und der Zeitbereich auf die Suche nach Dokumenten ab den vergangenen 10 Minuten oder mehr festgelegt ist, wird das Dokument nicht in den Abfrageergebnissen angezeigt.

Ursache 2: Die Daten wurden gegebenenfalls aus der Datenbank entfernt.

Lösung: Wenden Sie sich an den Datenbankadministrator.

Verwandtes Thema

Datumsabhängiges Suchen nach Austausch- und Dokumentinformationen


In den Abfrageergebnissen werden keine Überwachungsfelder angezeigt

Ursache: BizTalk Server konnte die Daten nicht konvertieren, oder es liegt ein arithmetischer Überlauffehler vor.

Lösung: Suchen Sie im Ereignisprotokoll die folgende Fehlermeldung:

<Pfad und Dateiname>: Das folgende Überwachungsfeld für Versendung <globaler eindeutiger Bezeichner> konnte nicht protokolliert werden:

Überwachungsfeld: <Name des Feldes>

Spezifikationsfeldname: <Name des Spezifikationsfeldes>/DTADataTypeTest/String/@_String

Tatsächlicher Wert: <Tatsächlicher Wert des Feldes>

Überprüfen und korrigieren Sie die Überwachungsfeldeinstellungen in der Dokument- oder Kanalkonfiguration.

Verwandte Themen

Auswählen von Spezifikationsfeldern in einem Kanal

Festlegen von Eigenschaften für die Dokumentprotokollierung


Zu viele Suchargumente

Ursache: Sie haben in der Liste Quellauswahl und/oder Zielauswahl zu viele Optionen angegeben.

Lösung: Geben Sie die Abfrage so genau wie möglich an. Reduzieren Sie in der Liste Quellauswahl und/oder Zielauswahl die Anzahl der ausgewählten Optionen, und klicken Sie auf Abfrage.

Verwandtes Thema

Verwenden von Abfragen zum Durchsuchen und Sortieren von Austausch- und Dokumentdaten


Überwachen von Dokumenten

Sie können Microsoft® BizTalk™ Server 2002 mithilfe von WMI (Windows Management Instrumentation) und Microsoft Operations Manager 2000 (MOM) überwachen. Mit diesen beiden Verwaltungstools können Sie die folgenden Aufgaben ausführen:

  • Überwachen von Standard- und benutzerdefinierten Warnbenachrichtigungen.

  • Verwenden von Microsoft Windows NT®-Ereignisprotokolleinträgen für BizTalk Server mithilfe der Toolrichtlinien.

  • Erstellen von Leistungsstatistiken für die XLANG-Ablaufplanung ohne Verwendung von Skripts.

  • Überwachen der grundlegenden BizTalk Server-Komponenten, wie z. B. BizTalk Server-Datenbanken und -Datenbanktabellen, instanzbezogenen Warteschlangen und Diensten.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Informationen zu WMI (Windows Management Instrumentation)

  • Informationen zu Microsoft Operations Manager (MOM)


Informationen zu WMI (Windows Management Instrumentation)

WMI (Windows Management Instrumentation) ist eine Datenverwaltungsschicht, die einen Bestandteil von Microsoft® Windows® 2000 bildet. Microsoft BizTalk Server 2002 verwendet die WMI-Schicht, um Verwaltungsfunktionen zu kapseln. Wenn die BizTalk Server-Verwaltung verwendet wird, um Gruppen-, Server- und Warteschlangeneinstellungen zu ändern, werden die neuen Werte über den WMI-Provider von BizTalk Server in der BizTalk-Messaging-Verwaltungsdatenbank gespeichert. In BizTalk Server 2002 verwendet dieser WMI-Provider eine Microsoft SQL Server™-Datenbank zum Speichern von Verwaltungsobjekten. WMI unterstützt eine einheitliche Skripting-API (Application Programming Interface, Schnittstelle für Anwendungsprogrammierung), die Anwendungen und Skripts den Zugriff auf den WMI-Provider auf einem lokalen Computer oder einem Remotecomputer erlaubt. Weitere Informationen und Beispiele zum Verwenden von WMI finden Sie unter BizTalk Managing and Monitoring.

Anmerkungen

  • In WMI existieren Einschränkungen hinsichtlich der Syntax und der gültigen Zeichen für WMI-Objektpfade. Im Folgenden werden die ungültigen Zeichen aufgelistet:

    ~` ! @ # $ % ^ & * ( ) + = [ ] { } | ;\" '< > , . ?

    Verwenden Sie keines dieser Zeichen, wenn Sie einen Servergruppennamen erstellen.

  • Alle Zeitstempel werden mithilfe der lokalen Zeit auf dem Computer mit SQL Server erstellt. Der WMI-Provider verweist jedoch auf alle Zeitstempel in UTC (Coordinated Universal Time). Die Verwaltungskonsole konvertiert anschließend die Zeitstempel für die Anzeige wieder in die lokale Zeit zurück.

  • Mithilfe der Datei InterchangeProvSchema.mof, die sich im Ordner C:\Programme\Microsoft BizTalk Server\Setup befindet, können Sie programmgesteuert auf die WMI-Datenbankschicht zugreifen. Diese Datei enthält die WMI-Klassen, die den Verwaltungsobjekten entsprechen. Weitere Informationen zur WMI-Anwendungsprogrammierung finden Sie auf der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie dort nach "WMI Application Programming".

  • Wenn Sie WMI-Abfragen über Microsoft Operations Manager (MOM) ausführen möchten, müssen Sie auf dem Server, auf dem die Abfrage ausgeführt werden soll, Mitglied der BizTalk Server-Gruppe Administratoren sein. Außerdem muss die Gruppe BizTalk Server-Administratoren über sämtliche Berechtigungen für den WMI-Namespace unter Root/MicrosoftBizTalkServer auf dem Server verfügen. Weitere Informationen zur Autorisierung von Benutzern für WMI finden Sie in der Windows 2000-Hilfe und unter Authorisieren von WMI-Benutzern und Festlegen von Berechtigungen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Benutzerdefinierte Leistungsindikatoren (Übersicht)

  • Angehalten-Warteschlange (Übersicht)

Verwandte Themen

BizTalk Managing and Monitoring

WMI (Windows Management Instrumentation)


Benutzerdefinierte Leistungsindikatoren (Übersicht)

Benutzerdefinierte Leistungsindikatoren stellen basierend auf einer erweiterten Abfrage der Überwachungsdatenbank eine programmgesteuerte Methode zum Definieren benutzerdefinierter WMI-Klasseninstanzen (Windows Management Instrumentation) bereit. Diese Abfragen können auf der Grundlage der folgenden Attribute erstellt werden:

  • Zeitraum

  • Dokumentquelle

  • Dokumentziel

  • Dokumenttyp

Diese Attribute können mithilfe regulärer Ausdrücke angegeben werden. Jede Abfrage gibt die Anzahl der Dokumente zurück, die mit den Kriterien übereinstimmen. Sie können zudem angeben, wie die Abfrageergebnisse sortiert werden sollen. Darüber hinaus können Sie eine Reihe von Kriterien (eine Abfrage) als eine neue Klasseninstanz angeben, die von Microsoft Operations Manager (MOM) verwendet werden kann und somit die Festlegung von Warnungen im Rahmen einer MOM-Regel ermöglicht.

WMI-Klassen ermöglichen Ihnen die Ausführung der folgenden Aufgaben:

  • Erstellen einer neuen Instanz einer WMI-Klasse, die eine bestimmte Überwachungsabfrage definiert.

  • Überprüfen der in der neuen WMI-Klasseninstanz erstellten Überwachungsabfrage für die Dokumentquelle und das Dokumentziel.

  • Ausführen der in der neuen WMI-Klasseninstanz definierten Abfrage, um die Anzahl der Dokumente in der Überwachungsdatenbank zu ermitteln, die mit der Abfrage übereinstimmen.

Weitere Informationen finden Sie unter Benutzerdefinierte Leistungsindikatoren.

Verwandte Themen

Creating a Custom Counter Using WMI

Custom Counter Query Properties

Validating the Custom Counter


Angehalten-Warteschlange (Übersicht)

Die Angehalten-Warteschlange enthält Arbeitselemente, die aus verschiedenen Gründen nicht erfolgreich verarbeitet wurden, einschließlich Analysefehler, Serialisierungsfehler, Übertragungsfehler oder eine fehlende Kanalkonfiguration. Dokumente aus der Angehalten-Warteschlange können entweder über die BizTalk Server-Verwaltungskonsole oder programmgesteuert über den WMI-Provider von BizTalk Server angezeigt und abgerufen werden. WMI-Abfragen können auf der Grundlage der folgenden Attribute erstellt werden:

  • Ziel

  • Quelle

  • Dokumentname

  • Status

  • Kanalhandle

  • Porthandle

  • Zeichenfolge der angehaltenen GUID

  • Grund

Weitere Informationen zum Anzeigen der Angehalten-Warteschlange über die Verwaltungskonsole finden Sie unter Angehalten-Warteschlange. Weitere Informationen zum Anzeigen der Angehalten-Warteschlange über den WMI-Provider finden Sie unter Accessing the Suspended queue.

Verwandte Themen

Accessing the Suspended queue

MicrosoftBizTalkServer_SuspendedQueue

Suspended Queue Monitoring


Informationen zu Microsoft Operations Manager (MOM)

Microsoft Operations Manager 2000 (MOM) umfasst eine Reihe von Tools für die Ereignisauflistung, Leistungsüberwachung und Berichterstellung für Serverbetriebssysteme und serverbasierte Anwendungen von Microsoft. Mit MOM können eine Vielzahl von Ressourcen zentral überwacht, verwaltet und gesichert werden. Zudem werden durch die proaktive Systemüberwachung in Echtzeit die Verfügbarkeit, Leistung und Sicherheit von Windows 2000-Netzwerken und -Anwendungen verbessert. MOM ermöglicht Ihnen die schnelle Identifizierung potentiell schwerwiegender Netzwerkprobleme, die Überwachung der Fortschritte bei der Lösung und die Bereitstellung von Lösungsinformationen innerhalb Ihrer Organisation.

Darüber hinaus haben Sie mit MOM die Möglichkeit, die Leistung des Netzwerkes mithilfe von WMI zu überwachen. Sie können Leistungsschwellenwerte überwachen und Beispieldaten für Trendanalysen sammeln. Außerdem können Sie anhand der Beispieldaten Grafiken erstellen und anzeigen und die Informationen zur Kapazitätsplanung verwenden.

MOM umfasst die folgenden Features:

  • Ereignisgesteuerte Überwachung von Operationen

  • Automatisch bereitgestellte, skalierbare Lösungen

  • Verbesserte Erzwingung von Sicherheitsrichtlinien und Überwachungsfunktionen

  • Verbesserte Systemverfügbarkeit und Leistungsüberwachung

  • Zahlreiche Methoden zum Anzeigen und Aufzeichnen von Daten

  • Gesteigerte Zuverlässigkeit und Verfügbarkeit

MOM verwendet verschiedene Daten von Computern mit BizTalk Server, einschließlich Leistungsindikatoren, WMI-Indikatoren und -Ereignisse sowie Windows NT-Ereignisse. MOM verwendet diese Daten bei der Erstellung von Providern, Servergruppen und Regeln. Provider sind einfach einzelne Datenquellen, die durch Benennen der Datenquelle (d. h. des Typs), des jeweiligen Providernamens und verschiedener anderer Attribute, die für diese Datenquelle spezifisch sind, definiert werden. Der folgende Provider überwacht beispielsweise die Warteschlangengröße für eine Warteschlange namens myQueue in Bytes:

Provider = Windows NT Performance Counter – MSMQ Queue-Bytes in Queue-myQueue-15.0-Minutes

Anmerkung

  • Die Beispielrate ist Teil der Providerdefinition für die Datenquelle Windows NT Performance Counter.

Im Anschluss an die Erstellung des Providers können Regeln erstellt werden, die Daten des Providers verarbeiten. Regeln gehören einer von drei Gruppen mit Verarbeitungsregeln in MOM an:

  • Ereignisverarbeitungsregeln. Diese Regeln können unterschiedliche Ereignisse auf einem Server verarbeiten und je nach Ereignis entsprechende Aktionen ausführen. Ereignisse sind z. B. Instanzen im Windows NT-Ereignisprotokoll, andere Standardprotokolldateien wie die vom IIS-Dienst (Internet Information Services, Internet-Informationsdienste) erstellten W3C-Protokolldateien von Internet-Informationsdienste und WMI-Ereignisse. Beispiele für Aktionen sind das Auslösen einer Warnung, das Senden einer E-Mail und das Ausführen eines Skripts.

  • Leistungsverarbeitungsregeln. Diese Regeln verarbeiten Leistungs- und Kapazitätstypindikatoren. Bei Leistungsregeln kann es sich um Mess- oder um Schwellenwertregeln handeln. Während Messregeln lediglich Statistiken für die Berichterstellung sammeln, können Schwellenwertregeln Warnungen auslösen. Dies gilt auch, wenn die Mess- und die Schwellenwertregeln denselben Provider aufweisen.

  • Warnungsverarbeitungsregeln. Ereignis- und Leistungsregeln können nicht verwendet werden, um direkt auf Warnungen zu reagieren. Stattdessen werden separate Warnungsregeln erstellt, um auf Warnungen zu reagieren, die von Ereignis- und Leistungsregeln ausgelöst wurden. Mithilfe einer Warnungsverarbeitungsregel können Sie einer großen Gruppe von Warnungen, die bestimmte Gemeinsamkeiten aufweisen, eine globale Reaktion zuordnen.

Ausführlichere Informationen zu MOM finden Sie in der Hilfe zu Microsoft Operations Manager.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • BizTalk Server 2002 Enterprise Edition Management Pack

Anmerkungen

  • MOM kann auf einem Computer mit BizTalk Server oder auf einem unabhängigen Computer ausgeführt werden, der für das Überwachen des Systems bestimmt ist.

  • MOM ist auf der BizTalk Server 2002-CD nicht enthalten. Es muss separat bezogen werden. Weitere Informationen zu MOM finden Sie in der Microsoft Operations Manager-Website (www.microsoft.com/germany/ms/serversuiten/mom/).

  • Um WMI-Abfragen über MOM ausführen zu können, müssen Sie auf dem Server, auf dem die Abfrage ausgeführt werden soll, Mitglied der Gruppe BizTalk Server-Administratoren sein.

Verwandtes Thema

Informationen zu WMI (Windows Management Instrumentation)


BizTalkServer2002 EnterpriseEdition ManagementPack

BizTalk Server 2002 ~ Überwachen von Dokumenten

BizTalk Server 2002 Enterprise Edition Management Pack

Zur Steigerung der Überwachungskapazitäten von Microsoft Operations Manager (MOM) enthält das Modul BizTalk Server 2002 Enterprise Edition Management Pack Computergruppierungs- und Verarbeitungsregeln. Ferner enthält es andere Informationen, mit denen Sie spezifische BizTalk Server 2002-Ereignisse überwachen können. Sie können das BizTalk Server 2002 Management Pack importieren, um Computer in der aktuellen Konfigurationsgruppe zu überwachen.

Das BizTalk Server 2002 Management Pack stellt einen ersten Satz von Regeln und Leistungsindikatoren bereit, der sämtliche Messaging- und Orchestrierungsfehlermeldungen, die BizTalk Server-Datenbanken, Windows NT-Ereignisse und Warteschlangen enthält. Sie können das Management Pack Ihren Überwachungsbedürfnissen entsprechend anpassen, um in Bereichen, die für Ihr Unternehmen von besonderem Interesse sind, ausführlichere Überwachungsinformationen zu erhalten.

Das BizTalk Server 2002 Management Pack enthält über 900 Regeln verschiedener Arten, beispielsweise die folgenden:

  • Eine Verarbeitungsereignisregel für jedes Windows-Anwendungsereignis, das vom BizTalk-Messaging und der BizTalk-Orchestrierung generiert werden kann.

  • Leistungsmessregeln für Leistungsindikatoren und Datenbank-Dateigrößen in BizTalk Server 2002. Diese Regeln unterstützen die 20 Leistungsansichten im Management Pack, die spezifisch für BizTalk Server sind.

  • Leistungsschwellen-Wertregeln für Leistungsindikatoren und Datenbank-Dateigrößen in BizTalk Server 2002 (eine für den Schweregrad von Fehlern und eine für den Schweregrad von Warnungen).

  • Benutzerdefinierte Leistungsindikatoren, die Angehalten-Warteschlange, und drei andere Beispielregeln, die zeigen, wie Sie spezielle Regeln für Ihre BizTalk Server 2002-Implementierung erstellen können.

Mithilfe dieser Regeln werden Systemadministratoren über die folgenden Vorgänge benachrichtigt:

  • Der BizTalk-Messagingdienst ist nicht verfügbar. Zudem erhalten sie Informationen darüber, wie lange der Dienst ausgeführt wurde.

  • Ein Windows-Ereignis wird vom BizTalk-Messaging oder der BizTalk-Orchestrierung generiert.

  • Dokumente an einen wichtigen Kunden werden angehalten. Außerdem werden sie darüber informiert, wie viele Dokumente während eines bestimmten Zeitraumes an einen wichtigen Kunden gesendet wurden.

  • Die BizTalk Server-Datenbanken werden zu umfangreich.

  • Die Anzahl der fehlgeschlagenen Ablaufpläne pro Zeiteinheit wird zu groß.

In diesem Abschnitt werden folgende Verfahren und Themen behandelt:

  • Konfigurieren von MOM zur Überwachung von BizTalk Server 2002

  • Importieren des BizTalk Server 2002 Management Pack

  • Benachrichtigungsgruppen

  • Ansichten

  • Vollständig konfigurierte Regeln

  • Benutzerdefinierte Regeln

Anmerkung

  • MOM 2000 muss vor dem Importieren von BizTalk Server 2002 Enterprise Edition Management Pack installiert werden.


Konfigurieren von MOM zur Überwachung von BizTalkServer2002

BizTalk Server 2002 ~ Überwachen von Dokumenten

Konfigurieren von MOM zur Überwachung von BizTalk Server 2002

Im Folgenden werden die Schritte beschrieben, die ausgeführt werden müssen, um Microsoft Operations Manager (MOM) für das Überwachen von Computern mit BizTalk Server 2002 einzurichten. Die Schritte werden in der Hilfe zu Microsoft Operations Manager ausführlicher beschrieben.

  1. Installieren Sie MOM 2000 auf dem Computer, der zum Überwachen Ihrer BizTalk Server-Konfiguration verwendet werden soll. Weitere Informationen finden Sie im Installationshandbuch zu Microsoft Operations Manager, das sich im Ordner Documentation auf der Installations-CD von MOM befindet.

    Anmerkung

    • Das Domänenkonto Consolidator/Agent Manager, das für MOM erforderlich ist, muss über Windows-Administratorrechte auf jedem zu überwachenden Computer mit BizTalk Server-Computer verfügen, einschließlich des Servers, der als Host für die von BizTalk Server verwendeten SQL Server-Datenbanken dient. Zu diesem Zweck können Sie das Konto zur Windows-Gruppe Administratoren auf jedem Server hinzufügen oder zu einer Domänengruppe, die Mitglied der lokalen Gruppe Administratoren ist, z. B. der Gruppe Domänenadministratoren.
  2. Importieren Sie das BizTalk Server 2002 Enterprise Edition Management Pack in MOM. Weitere Informationen finden Sie unter Importieren des BizTalk Server 2002 Management Pack oder unter "Importing a Management Pack Module" in der Hilfe zu Microsoft Operations Manager.

    Anmerkungen

    • Das BizTalk Server 2002 Enterprise Edition Management Pack befindet sich im Ordner MOM auf der Installations-CD von BizTalk Server 2002.

    • Beim Importieren des BizTalk Server 2002 Management Pack stellt MOM drei Verhaltensoptionen zur Verfügung:

      Merge, and retain changes that my company has made to rules.

      Merge, and always use the rules defined in the Management Pack. Preserve my company's knowledge base comments.

      Replace existing rule groups with those of the imported Management Pack.

      Wenn Sie das BizTalk Server Management Pack zum ersten Mal importieren, können Sie jede beliebige Option auswählen. Bei allen folgenden Importvorgängen ist es jedoch wichtig, dass Sie die Option auswählen, die dem gewünschten Verhalten entspricht.

    • Das BizTalk Server 2002 Enterprise Edition Management Pack enthält eine Computergruppe namens Microsoft BizTalk Server 2002 Enterprise Edition. Diese Gruppe beinhaltet alle von MOM verwalteten Computer, die den Registrierungsschlüssel HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0 enthalten.
  3. Nachdem MOM erfolgreich installiert wurde, weisen Sie die Computergruppe zu, die MOM überwachen und/oder in regelmäßigen Abständen auf neue BizTalk Server-Installationen abfragen soll. Weitere Informationen finden Sie unter "Understanding Agents", "Install Agents", "Configuring Agent Manager Properties", "Configuring Agent Deployment" und "Agent Managers Window" in der Hilfe zu Microsoft Operations Manager.

    Anmerkung

    • Indem Sie Regeln für verwaltete Computer einrichten und nach Computern scannen, die mit diesen Regeln übereinstimmen (vgl. die MOM-Dokumentation, auf die weiter oben verwiesen wurde), geben Sie für MOM die zu überwachende Computergruppe an. Diese Gruppe sollte alle Computer mit BizTalk Server 2002 sowie die zugehörigen Computer mit SQL Server enthalten, die überwacht werden sollen. Auf diese Weise wird ein lokaler Dienst namens One Point installiert, der als LocalSystem ausgeführt wird.
  4. Um zu überprüfen, ob die angegebenen Regeln die beabsichtigten Computer enthalten, führen Sie die folgenden Schritte durch:
    1. Überprüfen Sie, ob MOM seit der letzten Änderung der Regeln für verwaltete Computer einen Computerscan durchgeführt hat. Um dies festzustellen, rufen Sie den Scanvorgang am besten manuell auf. Weitere Informationen finden Sie unter "Scanning Managed Computers" in der Hilfe zu Microsoft Operations Manager.

      Vorsicht

      Wenn die Regeln für verwaltete Computer, die Sie für den Agent Manager definiert haben, eine große Anzahl übereinstimmender Computer umfassen, nimmt der Scanvorgang möglicherweise mehr Zeit in Anspruch als vorgesehen.

    2. Überprüfen Sie die Liste verwalteter Computer. Anweisungen zur Anzeige dieser Liste finden Sie unter "Viewing the Managed Computers List for an Agent Manager" in der Hilfe zu Microsoft Operations Manager.
  5. Konfigurieren Sie die Computergruppe Microsoft BizTalk Server 2002 Enterprise Edition, so dass diese separate Server enthält, auf denen BizTalk Server 2002 nicht installiert ist, die jedoch als Host für die von BizTalk Server verwendeten SQL Server-Datenbanken dienen. Weitere Informationen finden Sie unter "Excluding or Including Computers in a Computer Group" in der Hilfe zu Microsoft Operations Manager.

    Anmerkung

    • Das BizTalk Server 2002 Enterprise Edition Management Pack erstellt eine Computergruppe namens Microsoft BizTalk Server 2002 Enterprise Edition. Diese Gruppe beinhaltet alle von MOM verwalteten Computer, die den Registrierungsschlüssel HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0 enthalten. Sind separate Server vorhanden, auf denen BizTalk Server 2002 nicht installiert ist, die jedoch als Host für die von BizTalk Server verwendeten SQL Server-Datenbanken dienen, müssen die Namen dieser Server gesondert zur Computergruppe hinzugefügt werden.

Nachdem diese Schritte erfolgreich durchgeführt wurden, ist MOM für die Überwachung von BizTalk Server 2002 konfiguriert. Führen Sie die folgenden Schritte aus, um zu überprüfen, ob die zu überwachenden Computer zur Computergruppe BizTalk Server 2002 Enterprise Edition hinzugefügt wurden:

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft Operations Manager, und klicken Sie anschließend auf MOM Administration Console.

    Die MOM Administration Console wird angezeigt.

  2. Doppelklicken Sie auf den Stammknoten Microsoft Operations Manager, doppelklicken Sie auf Monitor, und klicken Sie dann auf All Computer Groups.

  3. Doppelklicken Sie im rechten Bereich auf Microsoft BizTalk Server 2002 Enterprise Edition.

  4. Alle Computer, die MOM zu dieser Computergruppe zählt, werden angezeigt.

    Anmerkung

    • Es kann mehrere Minuten dauern, bis MOM alle Computer der Gruppe entdeckt hat. Wenn die zu überwachenden Computer nicht innerhalb eines angemessenen Zeitraumes (abhängig von der Anzahl der gescannten Computer und anderen Faktoren) in der Computergruppe angezeigt werden, überprüfen Sie die Regeln für den Agent Manager und die Computergruppe, um sicherzustellen, dass die richtigen Computer berücksichtigt werden.


Importieren des BizTalkServer2002 ManagementPack

BizTalk Server 2002 ~ Überwachen von Dokumenten

Importieren des BizTalk Server 2002 Management Pack

Zum Überwachen des BizTalk Server-Systems müssen Sie das BizTalk Server 2002 Management Pack auf den Computer importieren, auf dem Microsoft Operations Manager (MOM) installiert ist.

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft Operations Manager, und klicken Sie anschließend auf MOM Administration Console.

  2. Erweitern Sie im linken Bereich Microsoft Operations Manager (default), erweitern Sie Rules, und klicken Sie dann auf Processing Rule Groups.

  3. Klicken Sie im Menü Action auf Import Management Pack.

    Das Dialogfeld Import Management Pack wird angezeigt.

  4. Suchen Sie im Bereich Management Pack nach der Microsoft BizTalk Server 2002-CD, suchen Sie nach dem Ordner MOM, und wählen Sie BizTalk2002.akm aus.

  5. Klicken Sie auf Open.

  6. Klicken Sie auf Import.

Anmerkungen

  • Das BizTalk Server 2002 Management Pack ist auf der BizTalk Server 2002-CD enthalten. MOM muss jedoch installiert sein, bevor das BizTalk Server 2002 Management Pack verwendet werden kann. Weitere Informationen zu MOM finden Sie in der Microsoft Operations Manager-Website (www.microsoft.com/germany/ms/serversuiten/mom/ ).

  • Weitere Informationen zum Installieren von MOM finden Sie in der Hilfe zu Microsoft Operations Manager.


Benachrichtigungsgruppen

Eine Benachrichtigungsgruppe in Microsoft Operations Manager (MOM) ist eine definierte Rolle, auf die eine Benachrichtigungskonfiguration angewendet wird. Die Konfiguration für eine Benachrichtigungsgruppe umfasst das Definieren des Mechanismus (beispielsweise E-Mail, Paging und Instant Messaging), durch den Mitglieder dieser Rolle benachrichtigt werden, sowie die einzelnen Mitglieder jeder Rolle. Wenn Warnungsregeln erstellt und Benachrichtigungen definiert werden, werden Benachrichtigungsgruppen als Ziel der Warnungsbenachrichtigungen angegeben.

Wahrscheinlich möchten Sie Ihre eigenen Benachrichtigungsgruppen definieren, Microsoft Operations Manager stellt jedoch auch einige vordefinierte Benachrichtigungsgruppen bereit:

  • IT Administrators Hierzu gehört die Gruppe der Betriebs- und IT-Managementexperten, die für das fehlerfreie Funktionieren des Systems auf technischer Ebene verantwortlich sind.

  • Database Administrators Eine spezielle Gruppe von IT-Administratoren, die die Verantwortung für die Pflege der Datenbanken tragen.

  • Business Administrators Diese Gruppe umfasst Personen, die Implementierungen von Geschäftsprozessen auf dem höchsten technischen Niveau nachvollziehen können und die Verantwortung für das Überwachen des Systemverhaltens auf Geschäftsebene tragen.

Anmerkung

  • Damit die Regeln funktionsfähig sind, muss ein Anwender oder Benutzer (Operator/User) zu den Benachrichtigungsgruppen hinzugefügt werden. Weitere Informationen finden Sie unter "Adding an Operator to a Notification Group" in der Hilfe zu Microsoft Operations Manager.


Ansichten

Die Ansichten in Microsoft Operations Manager (MOM) ermöglichen das Anzeigen spezieller Informationen aus der Datenbank, um das fehlerfreie Funktionieren des Systems zu überwachen und die Ausführung von Verwaltungsaufgaben zu erleichtern. Diese Ansichten werden alle 15 Minuten aktualisiert. Das BizTalk Server 2002 Management Pack stellt Ansichten zur Verfügung, die mit den folgenden, im Management Pack enthaltenen Leistungsindikatoren im Zusammenhang stehen:

  • Aktivierte Ablaufplaninstanzen

  • Asynchrone Versendungsvorgänge

  • Abgeschlossene Ablaufplaninstanzen

  • Größe der Datenbankdatei: BTM

  • Größe der Datenbankdatei: DTA

  • Größe der Datenbankdatei: SQ

  • Größe der Datenbankdatei: XLANG

  • Größe des Datenbankprotokolls: BTM

  • Größe des Datenbankprotokolls: DTA

  • Größe des Datenbankprotokolls: SQ

  • Größe des Datenbankprotokolls: XLANG

  • Pausierende Ablaufplaninstanzen

  • Verarbeitete Dokumente

  • Empfangene Dokumente

  • Fehlgeschlagene Ablaufplaninstanzen

  • Empfangene Austauschvorgänge

  • Angehaltene Elemente

  • Messagingbetriebszeit

  • Synchrone Versendungsvorgänge

  • Abgebrochene Transaktionen

Eine Beschreibung dieser Indikatoren finden Sie unter Leistungsindikatoren.

In Microsoft Operations Manager (MOM) haben Sie zwei Möglichkeiten zum Anzeigen der Ansichten:

  • Die Standardansicht enthält eine Liste der Leistungsindikatoren und Provider, denen Ansichten zugeordnet sind.

  • In der grafischen Ansicht können Sie die Leistung des System anhand von ausgewählten Leistungsindikatoren oder Providern über einen bestimmten Zeitraum hinweg darstellen. Der Wert des Indikators und/oder der Regel wird jeweils für die letzten zwei Stunden angezeigt und alle 15 Minuten aktualisiert.

Weitere Informationen zu den in MOM verfügbaren Standardansichten sowie zum Erstellen zusätzlicher Ansichten finden Sie in der Hilfe zu Microsoft Operations Manager.

Folgendes Verfahren wird in diesem Abschnitt behandelt:

  • Zugreifen auf BizTalk Server-Ansichten


Zugreifen auf BizTalkServer-Ansichten

BizTalk Server 2002 ~ Überwachen von Dokumenten

Zugreifen auf BizTalk Server-Ansichten

  1. Zeigen Sie im Startmenü auf Programme, dann auf Microsoft Operations Manager, und klicken Sie anschließend auf MOM Administration Console.

  2. Erweitern Sie im linken Bereich Microsoft Operations Manager (default), erweitern Sie Monitor, Public Views und Microsoft BizTalk Server, und erweitern Sie dann Microsoft BizTalk Server 2002 Enterprise Edition.

  3. Klicken Sie auf die Ansicht, auf die Sie zugreifen möchten.

Weitere Informationen zum Verwenden von Ansichten in MOM finden Sie in der Hilfe zu Microsoft Operations Manager.


Vollständig konfigurierte Regeln

Zur Erweiterung der Überwachungskapazitäten von Microsoft Operations Manager (MOM) enthält das BizTalk Server 2002 Management Pack grundlegende Regeln, die vollständig konfiguriert sind und für alle Windows NT-Anwendungsereignisse, die sich auf BizTalk Server beziehen, sowie für BizTalk Server-Leistungsindikatoren fertig zur Verfügung stehen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Windows NT-Ereignisregeln

  • Leistungsindikatoren

Verwandtes Thema

Benutzerdefinierte Regeln


WindowsNT-Ereignisregeln

BizTalk Server 2002 ~ Überwachen von Dokumenten

Windows NT-Ereignisregeln

Einer der vollständig konfigurierten Regeltypen, der im BizTalk Server 2002 Management Pack enthalten ist, ist der Regeltyp zur Überwachung des Windows NT-Ereignisprotokolls. Alle Windows NT-Anwendungsereignisse, die sich auf BizTalk Server beziehen, werden als grundlegende Regeln in Microsoft Operations Manager (MOM) importiert. Die überwachten Windows NT-Ereignisse werden als eine der folgenden Regeln kategorisiert:

  • Ein Ereignis, das eine Warnung auslöst und/oder eine individuelle Antwort erfordert.

  • Ein Ereignis, das als Filter verwendet werden soll.

  • Ein Ereignis, das mit ähnlichen Ereignissen konsolidiert werden soll.

In der MOM-Konsolenstruktur werden diese Regeln unter dem Microsoft BizTalk Server 2002-Knoten auf drei Typen von MOM-Regeln verteilt:

  • Ereignisverarbeitungsregeln

  • Warnungsverarbeitungsregeln

  • Leistungsverarbeitungsregeln

Weitere Informationen zu MOM-Regeln finden Sie in der Hilfe zu Microsoft Operations Manager.

Ereigniskennung

Im Allgemeinen besitzt jede Fehlermeldung, die im Ereignisprotokoll angezeigt wird, eine eindeutige Fehler-ID. Zuweilen bestehen jedoch auch Abhängigkeiten zwischen diesen Fehlermeldungen. Beispielsweise kann ein Anmeldefehler bewirken, dass der Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank fehlschlägt. Dies löst wiederum eine Reihe von Fehlermeldungen aus, da die Empfangsfunktionen keine Nachrichten senden können. In diesen Fällen erstellt BizTalk Server für Messagingfehler nur ein Fehlerprotokoll, in dem die Fehler unter einer Ereigniskennung zusammengefasst werden. Wenn Sie sich die Beschreibung des Fehlers im Ereignisprotokoll ansehen, werden Sie feststellen, dass sämtliche Fehlermeldungen aufgelistet sind, wobei die individuelle Ereigniskennung als erstes Element des Eintrags aufgeführt wird.

Microsoft Operations Manager (MOM) verwendet die Ereigniskennung der einzelnen Fehlermeldungen innerhalb der Ereignisbeschreibung, um jede Fehlermeldung eindeutig zu identifizieren.

Anmerkung

  • Zusammengefasste Fehlerprotokolle werden nur für Messagingfehler erstellt. Für die Orchestrierung wird jeder Fehler einzeln im Ereignisprotokoll aufgezeichnet, unabhängig davon, ob er durch einen der vorherigen Fehler verursacht wurde.

Verwandtes Thema

Windows NT-Ereignisregeln

Copyright © 1999–2001 Microsoft Corporation.
Alle Rechte vorbehalten.

Fanden Sie diese Informationen hilfreich? Bitte senden Sie Ihre Vorschläge und Anmerkungen zur Dokumentation an BizTalk Server Dokumentationsfeedback@microsoft.com


Leistungsindikatoren

Das BizTalk Server 2002 Management Pack enthält Provider und Regeln für die folgenden Leistungsindikatoren:

  • Messaging. Diese Leistungsindikatoren überwachen Ereignisse der BizTalk-Messagingdienste.

  • XLANG. Diese Leistungsindikatoren überwachen Ereignisse der BizTalk-Orchestrierungsdienste.

Werte für Leistungsindikatoren werden in regelmäßigen Abständen unter Verwendung von Messregeln gesammelt. Unter einer Messregel versteht man einen Leistungsregeltyp, der die Sammlung numerischer Werte von Leistungsindikatoren angibt.

In der folgenden Tabelle werden die Leistungsindikatoren aufgelistet und kurz beschrieben.

Messaging-Leistungsindikatoren

Leistungsindikator | Beschreibung
Asynchrone Versendungsvorgänge | Ganze Zahl, die angibt, wie viele Submit-Aufrufe seit dem letzten Start des BizTalk-Messagingdienstes abgeschlossen wurden.
Verarbeitete Dokumente | Ganze Zahl, die angibt, wie viele Dokumente seit dem letzten Start des BizTalk-Messagingdienstes verarbeitet wurden, d. h. aus der Verarbeitungswarteschlange abgerufen und an eine Portzieladresse gesendet wurden.
Empfangene Dokumente | Ganze Zahl, die die Gesamtzahl der von BizTalk Server empfangenen Dokumente angibt. Hierzu gehören sowohl Dokumente, die sich in der Verarbeitungswarteschlange befinden, als auch fehlgeschlagene Dokumente.
Empfangene Austauschvorgänge | Ganze Zahl, die die Anzahl der vom Messagingmodul empfangenen Austauschvorgänge angibt.
Angehaltene Elemente | Ganze Zahl, die angibt, wie viele angehaltene Elemente sich in der Angehalten-Warteschlange befinden.
Messagingbetriebszeit | Ganze Zahl, die angibt, wie lange der BizTalk-Messagingdienst seit dem letzten Start ausgeführt wurde.
Synchrone Versendungsvorgänge | Ganze Zahl, die die Anzahl der synchronen Versendungsvorgänge angibt.

XLANG-Leistungsindikatoren

Leistungsindikator | Beschreibung
Aktivierte Ablaufplaninstanzen | Ganze Zahl, die die Anzahl der aktivierten Ablaufplaninstanzen seit dem letzten Start der XLANG COM+-Prozesse angibt.
Abgeschlossene Ablaufplaninstanzen | Ganze Zahl, die angibt, wie viele XLANG-Ablaufplaninstanzen seit dem letzten Start der XLANG COM+-Prozesse für einen bestimmten Server erfolgreich abgeschlossen wurden.
Pausierende Ablaufplaninstanzen | Ganze Zahl, die die Gesamtzahl der pausierenden Ablaufplaninstanzen angibt.
Fehlgeschlagene Ablaufplaninstanzen | Ganze Zahl, die angibt, wie viele XLANG-Ablaufplaninstanzen für einen bestimmten Server fehlgeschlagen sind.
Abgebrochene Transaktionen | Ganze Zahl, die angibt, wie viele Transaktionen für XLANG COM+-Prozesse seit dem letzten Start der Prozesse abgebrochen wurden.

Anmerkung

  • Alle XLANG-Leistungsindikatoren sind kumulative Zähler für alle XLANG-Prozesse auf einem bestimmten Server.

Datenbank-Leistungsindikatoren

Regelindikator | Beschreibung
Größe der Datenbankdatei: BTM | Größe der Datenbankdateien in der BizTalk-Messaging-Verwaltungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer zugehörigen Ansicht verwendet.
Größe der Datenbankdatei - Fehler: BTM | Größe der Datenbankdateien in der BizTalk-Messaging-Verwaltungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer Fehlerantwort verwendet.
Größe der Datenbankdatei - Warnung: BTM | Größe der Datenbankdateien in der BizTalk-Messaging-Verwaltungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer Warnungsantwort verwendet.
Größe der Datenbankdatei: SQ | Größe der Datenbankdateien in der BizTalk Server-Datenbank für gemeinsam genutzte Warteschlangen in KB. Dieser Indikator wird zum Erstellen einer zugehörigen Ansicht verwendet.
Größe der Datenbankdatei - Fehler: SQ | Größe der Datenbankdateien in der BizTalk Server-Datenbank für gemeinsam genutzte Warteschlangen in KB. Dieser Indikator wird zum Erstellen einer Fehlerantwort verwendet.
Größe der Datenbankdatei - Warnung: SQ | Größe der Datenbankdateien in der BizTalk Server-Datenbank für gemeinsam genutzte Warteschlangen in KB. Dieser Indikator wird zum Erstellen einer Warnungsantwort verwendet.
Größe der Datenbankdatei: DTA | Größe der Datenbankdateien in der BizTalk Server-Überwachungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer zugehörigen Ansicht verwendet.
Größe der Datenbankdatei - Fehler: DTA | Größe der Datenbankdateien in der BizTalk-Überwachungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer Fehlerantwort verwendet.
Größe der Datenbankdatei - Warnung: DTA | Größe der Datenbankdateien in der BizTalk-Überwachungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer Warnungsantwort verwendet.
Größe der Datenbankdatei: XLANG | Größe der Datenbankdateien in der Persistenzdatenbank für die Orchestrierung in KB. Dieser Indikator wird zum Erstellen einer zugehörigen Ansicht verwendet.
Größe der Datenbankdatei - Fehler: XLANG | Größe der Datenbankdateien in der Persistenzdatenbank für die Orchestrierung in KB. Dieser Indikator wird zum Erstellen einer Fehlerantwort verwendet.
Größe der Datenbankdatei - Warnung: XLANG | Größe der Datenbankdateien in der Persistenzdatenbank für die Orchestrierung in KB. Dieser Indikator wird zum Erstellen einer Warnungsantwort verwendet.
Größe des Datenbankprotokolls: BTM | Größe der Protokolldateien für die BizTalk-Messaging-Verwaltungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer zugehörigen Ansicht verwendet.
Größe des Datenbankprotokolls - Fehler: BTM | Größe der Protokolldateien für die BizTalk-Messaging-Verwaltungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer Fehlerantwort verwendet.
Größe des Datenbankprotokolls - Warnung: BTM | Größe der Protokolldateien für die BizTalk-Messaging-Verwaltungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer Warnungsantwort verwendet.
Größe des Datenbankprotokolls: SQ | Größe der Protokolldateien für die BizTalk Server-Datenbank für gemeinsam genutzte Warteschlangen in KB. Dieser Indikator wird zum Erstellen einer zugehörigen Ansicht verwendet.
Größe des Datenbankprotokolls - Fehler: SQ | Größe der Protokolldateien für die BizTalk Server-Datenbank für gemeinsam genutzte Warteschlangen in KB. Dieser Indikator wird zum Erstellen einer Fehlerantwort verwendet.
Größe des Datenbankprotokolls - Warnung: SQ | Größe der Protokolldateien für die BizTalk Server-Datenbank für gemeinsam genutzte Warteschlangen in KB. Dieser Indikator wird zum Erstellen einer Warnungsantwort verwendet.
Größe des Datenbankprotokolls: DTA | Größe der Protokolldateien für die BizTalk-Überwachungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer zugehörigen Ansicht verwendet.
Größe des Datenbankprotokolls - Fehler: DTA | Größe der Protokolldateien für die BizTalk-Überwachungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer Fehlerantwort verwendet.
Größe des Datenbankprotokolls - Warnung: DTA | Größe der Protokolldateien für die BizTalk-Überwachungsdatenbank in KB. Dieser Indikator wird zum Erstellen einer Warnungsantwort verwendet.
Größe des Datenbankprotokolls: XLANG | Größe der Protokolldateien für die Persistenzdatenbank für die Orchestrierung in KB. Dieser Indikator wird zum Erstellen einer zugehörigen Ansicht verwendet.
Größe des Datenbankprotokolls - Fehler: XLANG | Größe der Protokolldateien für die Persistenzdatenbank für die Orchestrierung in KB. Dieser Indikator wird zum Erstellen einer Fehlerantwort verwendet.
Größe des Datenbankprotokolls - Warnung: XLANG | Größe der Protokolldateien für die Persistenzdatenbank für die Orchestrierung in KB. Dieser Indikator wird zum Erstellen einer Warnungsantwort verwendet.

Anmerkung

  • Während der Installation von BizTalk Server 2002 wird der Objektname der BizTalk-Messaging-Verwaltungsdatenbank standardmäßig in InterchangeBTM, der Objektname der Überwachungsdatenbank in InterchangeDTA, der Objektname der Datenbank für gemeinsam genutzte Warteschlangen in InterchangeSQ und der Objektname der Persistenzdatenbank für die Orchestrierung in XLANG geändert. Falls Sie diese Standardobjektnamen der Datenbanken geändert haben, müssen Sie die Datenbank-Leistungsindikatoren entsprechend anpassen, um sicherzustellen, dass sie auf die richtigen Datenbanken verweisen.
Regelindikator | Beschreibung
Größe der Angehalten-Warteschlange (Maßeinheit) | Größe der Angehalten-Warteschlange von BizTalk Server zu einem bestimmten Zeitpunkt. Dieser Indikator wird zum Erstellen einer Warnungsantwort verwendet.

Verwandte Themen

Vollständig konfigurierte Regeln

Benutzerdefinierte Regeln


Benutzerdefinierte Regeln

Das BizTalk Server 2002 Management Pack enthält zwar eine große Anzahl von vollständig konfigurierten Regeln zur Überwachung von BizTalk Server 2002, aber Sie möchten möglicherweise Ereignisse überwachen, die spezifisch für Ihre Systemkonfiguration sind und für die das BizTalk Server 2002 Management Pack keine Regeln bereitstellt. In diesem Fall können Sie benutzerdefinierte Regeln erstellen. Das Beispiel Suspended Queue Monitoring enthält Informationen zur Erstellung benutzerdefinierter Regeln für die BizTalk Server-Überwachung.

Weitere Informationen zum Erstellen benutzerdefinierter Regeln finden Sie in der Hilfe zu Microsoft Operations Manager.

Verwandte Themen

Vollständig konfigurierte Regeln

Suspended Queue Monitoring


BizTalk Server2002-Anwendungsentwicklung

BizTalk Server 2002 ~ Anwendungsentwicklung

BizTalk Server 2002-Anwendungsentwicklung

Microsoft BizTalk™ Server 2002 stellt Tools und Dienste bereit, mit denen Sie ausführbare Anwendungen zum Steuern von Geschäftsprozessen und zum Austausch von Daten zwischen Handelspartnern und Anwendungen innerhalb eines Unternehmens erstellen können.

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-SEED-Assistent

  • Bereitstellen von Anwendungen mit BizTalk Server-Ressource

  • Entwerfen von BizTalk-Orchestrierungen

  • Konfigurieren der BizTalk-Messagingdienste

  • Erstellen von Spezifikationen und Zuordnen von Daten

  • Integrieren der BizTalk-Dienste


BizTalk-SEED-Assistent

Mit dem BizTalk-SEED-Assistenten können Firmen ihre Microsoft® BizTalk™ Server 2002-Konfigurationen in einem SEED-Paket verpacken. Diese können über das Internet Handelspartnern zur Verfügung gestellt werden. Firmen, die SEED-Pakete erstellen, müssen BizTalk Server manuell für den Empfang von Dokumenten konfigurieren. Mithilfe des SEED-Pakets können Handelspartner BizTalk Server konfigurieren, ihre Konfiguration testen und Dokumente mit der Initiatorfirma austauschen. Ein SEED-Paket erleichtert Firmen die Durchführung von Geschäften mit Partnern. Es enthält:

  • Den Namen der Initiatorfirma.

  • Den Test-URL (Uniform Resource Locator) und Informationen zum Produktions-URL.

  • Einen Verweis auf Spezifikationen und Instanzdaten.

Nachdem ein SEED-Paket erstellt wurde, können Handelspartner (Empfänger) die Datei downloaden, sie installieren und anschließend mit zusätzlichen Informationen konfigurieren, z. B.:

  • Portinformationen (einschließlich des Testverzeichnisses)

  • Das Empfangsverzeichnis

Da die Beziehungen zwischen Handelspartnern individuell verschieden sind, muss der Empfänger diese eindeutigen Attribute angeben.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ausführliche Informationen zum BizTalk-SEED-Assistenten finden Sie unter Informationen zum BizTalk-SEED-Assistenten.

  • Eine Kurzübersicht darüber, warum bestimmte Aufgaben ausgeführt werden müssen, finden Sie unter Gründe für das Durchführen von BizTalk-SEED-Assistent-Aufgaben.

  • Detaillierte Anweisungen zum Ausführen von Aufgaben finden Sie unter Durchführen von BizTalk-SEED-Assistent-Aufgaben.

  • Anweisungen zum Behandeln von Problemen finden Sie unter Problembehandlung – BizTalk-SEED-Assistent.


Informationen zum BizTalk-SEED-Assistenten

Mithilfe des BizTalk-SEED-Assistenten kann eine Firma, im Assistenten als Initiator bezeichnet, ein SEED-Paket erstellen und dieses Handelspartnern, im Assistenten als Empfänger bezeichnet, zur Verfügung stellen. Der Empfänger kann das SEED-Paket öffnen, es konfigurieren und testen und dann Dokumente an die Testsite des Bereitstellungsinitiators senden. Wenn der Empfänger die Dokumente über die Site erfolgreich getestet hat, kann der Bereitstellungsinitiator die Konfiguration des SEED-Pakets in die Produktionsumgebung integrieren und Transaktionen mit dem Empfänger vornehmen.

In der folgenden Tabelle werden die Aufgaben aufgelistet, die ein schneller Bereitstellungsprozess umfasst.

Aufgabe | Wer führt die Aufgabe durch?
Erstellen eines SEED-Pakets | Initiator
Auswählen des zu sendenden SEED-Pakets | Initiator
Senden oder Speichern des SEED-Pakets | Initiator
Konfigurieren des BizTalk Server-Systems des Empfänger | Empfänger
Testen der Konfiguration auf dem lokalen System des Empfängers | Empfänger
Testen der Remoteverbindung | Empfänger
Verwenden der Konfiguration für den Übergang zur Produktion (ausgehend) | Initiator
Verwenden der Konfiguration für den Übergang zur Produktion (eingehend) | Empfänger

Nachdem der Empfänger das SEED-Paket konfiguriert hat, konfiguriert das SEED-Paket automatisch die entsprechenden Ports des Empfängersystems, so dass dieser Testtransaktionen mit der Initiatorfirma durchführen kann. Ports werden auf Dokumentbasis erstellt, nicht auf Paketbasis. Der Port wird erst erstellt, nachdem der Empfänger den Konfigurations- und Erstellungsprozess für ein bestimmtes Dokument abgeschlossen hat.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Initiieren eines SEED-Pakets

  • Empfangen eines SEED-Pakets

  • Beispiel für eine Initiator-Empfänger-Beziehung

  • Grundlegendes zu den ASP-Seiten in SEED


Initiieren eines SEED-Pakets

Ein SEED-Paket wird von einem Initiator mithilfe des BizTalk-SEED-Assistenten erstellt und über eine Website oder einen Dateifreigabespeicherort Empfängern zur Verfügung gestellt. Ein typisches Szenario ist das einer Firma, die mit mehreren Handelspartnern desselben Typs Geschäfte tätigt. Die zentrale Firma wird als "Initiator" und die Handelspartner werden als "Empfänger" bezeichnet.

Möchte ein Initiator eine neue Beziehung zu einem Empfänger einrichten oder neue Dokumente von einem bereits bestehenden Empfänger bearbeiten, erstellt er mithilfe des BizTalk-SEED-Assistenten ein SEED-Paket. Das SEED-Paket enthält die folgenden Informationen:

  • Initiatorname: Der Name der Firma, die die Verbindung initiiert. Diese Information gilt für das gesamte SEED-Paket; dagegen sind die folgenden Informationen dokumentspezifisch.

  • Test-URL: http://test.<Initiatorname>/invoice (Die Testsite, an die der Empfänger während der Remotetestphase Dokumente sendet.)

  • Produktions-URL: http://www.<Initiator-URL>/b2b/invoices

  • Spezifikation: C:\specification\invoice.xml

  • Daten: Die XML-Instanzdaten (Extensible Markup Language) für die Spezifikation.

Verwandtes Thema

Erstellen eines SEED-Pakets


Empfangen eines SEED-Pakets

Als Empfänger haben Sie möglicherweise ein SEED-Paket von einer Firma erhalten bzw. von der Website der Firma gedownloadet. Nachdem Sie das SEED-Paket auf Ihrem Computer gespeichert haben, können Sie die Konfiguration mithilfe des BizTalk-SEED-Assistenten durchführen und dann das Empfangen und Senden von Dokumenten testen.

Ist das SEED-Paket auf Ihrem Computer installiert, erstellt es die erforderlichen Ports, Kanäle, Dokumentdefinitionen und Empfangsfunktionen. Die Titel der Ports, Kanäle, Dokumentdefinitionen und Empfangsfunktionen beginnen jeweils mit dem Namen des SEED-Pakets. Durch diese Namensgebung wird sichergestellt, dass die SEED-Paketobjekte eindeutige Namen erhalten. Darüber hinaus lassen sich die Objekte dadurch von anderen SEED-Paketobjekten unterscheiden, die u. U. auf den BizTalk-Servern installiert sind.

Der BizTalk-SEED-Assistent zeigt auf der Seite Paketinstallation - Paketauswahl die folgenden Informationen über das SEED-Paket an:

  • Paket-ID. Die generierte GUID-Nummer (Global Unique Identification).

  • Organisation. Der Name, der von der Initiatorfirma, die das SEED-Paket erstellt hat, angegeben wurde.

  • Anzahl der Dokumente. Gibt die Anzahl der Dokumente innerhalb des SEED-Pakets an.

  • Empfohlene Operation. Gibt an, welche Aufgaben beim Konfigurieren, Erstellen und Testen des Pakets durchgeführt werden müssen. Folgende Status sind möglich:
    • Es muss wenigstens ein Dokument konfiguriert werden.

    • Es muss wenigstens ein Dokument installiert werden.

    • Es muss wenigstens ein Dokument lokal getestet werden.

    • Es muss wenigstens ein Dokument auf dem Remotecomputer getestet werden.

    • Es muss wenigstens ein Dokument für den Wechsel zur Produktion ausgewählt werden.

    • Das gesamte Paket ist installiert und in Produktion.

Darüber hinaus zeigt der Assistent sämtliche Dokumente, die mit dem SEED-Paket verbunden sind, auf der Seite Paketinstallation - Dokumentbereitstellung an. Für jedes Dokument müssen die folgenden Aufgaben durchgeführt werden, um die Konfiguration zu überprüfen und bereitzustellen:

  • Konfigurieren. Dieser Prozess konfiguriert die Porteigenschaften. Der Status ist entweder Konfigurieren Vollständig oder Konfigurieren Unvollständig.

  • Erstellen. Dieser Prozess erstellt die erforderlichen Objekte (z. B. Empfangsfunktionen, Ports und Kanäle). Der Status ist entweder Erstellen Weitergeleitet, d. h. die Objekte wurden erstellt, oder Erstellen Fehlgeschlagen, d. h. die Objekte wurden nicht erstellt.

  • Lokal testen. Wenn der Assistent einen lokalen Test durchführt, legt er die Instanzdaten für die Spezifikation entweder in dem Verzeichnis ab, das Sie als Empfangsspeicherort für eingehende Dokumente angegeben haben, oder er sendet sie synchron an den Remote-URL für ausgehende Dokumente. Handelt es sich um ein als eingehend gekennzeichnetes Dokument, nimmt BizTalk Server die Datei entgegen und legt sie zur Überprüfung des lokalen Tests im Testverzeichnis ab. Die Instanz wird vom BizTalk-SEED-Assistenten entgegengenommen und im Hinblick auf Format und Inhalt überprüft. Außerdem wird der Status der Spezifikation innerhalb des SEED-Pakets aktualisiert. Auf diese Weise wird sichergestellt, dass das Format des Dokuments korrekt ist. Ist das Instanzformat korrekt, wird der Status der Spezifikation innerhalb des SEED-Pakets aktualisiert. Ist das Dokument als ausgehend gekennzeichnet, wird SubmitSync aufgerufen. Anschließend verarbeitet BizTalk Server das Dokument und legt es im endgültigen Verzeichnis ab. Dort wird es vom BizTalk-SEED-Assistenten übernommen, der die Daten überprüft. Mögliche Statusmeldungen sind:
    • Lokaler Test In Bearbeitung. Die Instanz wird getestet.

    • Lokaler Test Weitergeleitet. Die Instanz wurde überprüft.

    • Lokaler Test Fehlgeschlagen. Die Instanz wurde nicht überprüft.
  • Remote testen. Führt der Assistent einen Remotetest für eingehende Dokumente aus, aktualisiert er die Transportadresse zum Test-URL des Initiators, die Bestandteil des SEED-Pakets ist. Anschließend wird das Dokument synchron an BizTalk Server gesendet. Die Website des Initiators sendet das Dokument in einer HTTP-Antwort zurück. Diese Antwort wird vom BizTalk-SEED-Assistenten überprüft. Für Dokumente, die als ausgehend gekennzeichnet sind, wird das Datum in XML-Header (Extensible Markup Language) eingeschlossen, die den Produktions-URL des Empfängers sowie den zur Verarbeitung des Dokuments verwendeten Kanal enthalten. Unter Verwendung des angegebenen Kanals ruft diese Seite die Submit-Methode auf, die das Dokument an den Produktions-URL (Localsubmit.asp) auf der Website des Initiators zurücksendet. Anschließend wird das Dokument im endgültigen Verzeichnis abgelegt, wo es vom BizTalk-SEED-Assistenten entgegengenommen und überprüft wird. Dieser Prozess sollte für jede der übrigen Spezifikationen wiederholt werden. Weitere Informationen zu ASP-Seiten finden Sie unter Grundlegendes zu den ASP-Seiten in SEED.

  • Bereitstellen. Sie können nur Dokumente bereitstellen, die als eingehend gekennzeichnet wurden. Der Status ist entweder Bereitstellen Weitergeleitet, d. h. die Konfiguration wurde bereitgestellt, oder Bereitstellen Fehlgeschlagen, d. h. die Konfiguration wurde nicht bereitgestellt.

Verwandtes Thema

Installieren eines SEED-Pakets


Beispiel für eine Initiator-Empfänger-Beziehung

Sie müssen die Beziehung zwischen einem Initiator und einem Empfänger kennen, um die einzelnen Komponenten des SEED-Pakets zu verstehen. (Bei dem in diesem Beispiel beschriebenen Szenario werden zwei fiktive Firmen als Initiator und Empfänger verwendet.) Ein typisches Szenario weist einen Initiator, in diesem Fall Northwind Traders, und einen oder mehrere Empfänger, in diesem Fall die Contoso AG, auf. Die Beschaffungsabteilung von Northwind Traders (Initiator des Bereitstellungsszenarios) erhält Rechnungen von mehreren Handelspartnern (Empfängern) für verschiedene Wartungsaufträge.

Die Beschaffungsabteilung verfügt über eine Website, auf der Rechnungen von Zulieferern (Empfängern) eingehen. Die an diesen Speicherort gesendeten Dokumente sind XML (Extensible Markup Language)-Dateien, die einer BizTalk-Editor-Spezifikation namens Invoice.xml entsprechen. Dokumente werden überprüft, wenn sie an diesem Speicherort und am Testspeicherort des Empfängers eingehen.

Darüber hinaus hat Northwind Traders eine Testsite eingerichtet, um Dokumente zu empfangen und diese anhand der Spezifikation zu überprüfen. Entspricht das Dokument der Spezifikation, werden die Daten an den Empfänger gesendet. Empfänger verwenden diese Testsite, um ihre Transaktionen zu testen, bevor sie die Dateien an die Produktionssite des Initiators zurücksenden. Empfänger senden Transaktionen an die Testsite des Initiators, bis die Transaktionen fehlerlos verarbeitet wurden. Durch dieses Verfahren wird gewährleistet, dass die über die Produktionssite vorgenommenen Transaktionen erfolgreich sind.

Northwind Traders erstellt das SEED-Paket und platziert es auf seiner Website, wo es die Empfänger downloaden können. Der Empfänger - die Contoso AG - downloadet das SEED-Paket und verwendet anschließend den BizTalk-SEED-Assistenten, um die Konfiguration durch Hinzufügen von Informationen zu Ports und gegebenenfalls Empfangsfunktionen abzuschließen.

Nachdem die Contoso AG das SEED-Paket konfiguriert hat, erstellt der BizTalk-SEED-Assistent den entsprechenden Kanal und Port, um die Site des Empfängers für die Kommunikation mit der Testsite des Initiators zu konfigurieren. Die Contoso AG testet die Beispielinstanz durch Senden dieser Instanz an den Kanal (und an den an diesen Kanal gebundenen Port), der sie wiederum an die Test-ASP-Seite sendet.

Nachdem der Test erfolgreich durchgeführt wurde, kann die Contoso AG über eine Live-Verbindung Dokumente senden.

Verwandte Themen

Initiieren eines SEED-Pakets

Empfangen eines SEED-Pakets


Grundlegendes zu den ASP-Seiten in SEED

Der BizTalk-SEED-Assistent enthält drei ASP-Seiten (Active Server Pages): Slingback.asp, Trigger.asp und Localsubmit.asp. Diese ASP-Seiten befinden sich im Ordner \Programme\Microsoft Biztalk Server\SEED. Bevor Sie ein SEED-Paket erstellen, müssen Sie eine Website einrichten und die Dateien Slingback.asp, Trigger.asp und Localsubmit.asp auf dieser Site platzieren. Diese Seiten dienen dazu, Sendungen anzunehmen. Weitere Informationen zum Implementieren einer sicheren Site finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach dem Artikel "Implementing a Secure Site with ASP".

Im Folgenden wird beschrieben, wie der BizTalk-SEED-Assistent die Dateien verwendet:

  • Slingback.asp. Diese ASP wird für Remotetests eingehender Dokumente verwendet. Beim Erstellen eines SEED-Pakets muss der Initiator diese Seite oder eine Seite mit derselben Funktion im Feld URL für Remotetest verwenden. Wenn der Empfänger auf die Schaltfläche Remote testen klickt, wird das Dokument synchron über Slingback.asp an BizTalk Server gesendet. Anschließend wird das Dokument an den Empfänger zurückgesendet, und der BizTalk-SEED-Assistent überprüft, ob das empfangene Dokument mit dem gesendeten Dokument übereinstimmt.

  • Trigger.asp. Diese ASP wird für Remotetests ausgehender Dokumente verwendet. Beim Erstellen eines SEED-Pakets muss der Initiator Trigger.asp im Feld URL für Remotetest für ausgehende Dokumente angeben. Das Dokument wird mit dem Produktions-URL vom Empfänger und dem Kanal, den der Empfänger zur Verarbeitung des Dokuments verwendet, an die Seite Trigger.asp gesendet. Alle diese Informationen sind in der XML (Extensible Markup Language)-Datei enthalten. Auf der Seite Trigger.asp (Initiatorseite) wird ein Submit-Aufruf für ein offenes Ziel mit dem Produktions-URL des Empfängers (im Allgemeinen Localsubmit.asp) als Transportadresse durchgeführt.

  • Localsubmit.asp. Diese ASP wird für Remotetests ausgehender Dokumente verwendet. Der Empfänger verwendet Localsubmit.asp als Produktions-URL. Nachdem Localsubmit.asp das Dokument empfangen hat, wird der Kanal aus der XML-Datei abgerufen, und das Dokument wird mit dem angegebenen Kanal an Biztalk Server gesendet.

Verwandtes Thema

Erstellen eines SEED-Pakets


Gründe für das Durchführen von BizTalk-SEED-Assistent-Aufgaben

Dieser Abschnitt stellt eine kurze Referenz zum Durchführen von BizTalk-SEED-Assistent-Aufgaben bereit. Die folgende Tabelle enthält Beschreibungen der wichtigsten Aufgaben, Erläuterungen zum Zweck jeder Aufgabe und Links zu den entsprechenden Verfahren.

Aufgabe Zweck
  • Erstellen eines SEED-Pakets
 Erstellen eines XML (Extensible Markup Language)-Pakets, das Ihre BizTalk Server 2002-Konfiguration (sowohl für aus- als auch für eingehende Dokumente) enthält. Diese Konfiguration können Sie Teams innerhalb Ihrer Organisation oder Handelspartnern zur Verfügung stellen, um Daten mit ihnen auszutauschen.
  • Installieren eines SEED-Pakets
 Installieren eines XML-Pakets, das die BizTalk Server 2002-Konfiguration (für aus- und eingehende Dokumente) des Initiators enthält. Diese Konfiguration kann zum Testen des Transaktionsprozesses verwendet werden, bevor Geschäfte innerhalb einer Produktionsumgebung getätigt werden.


Durchführen von BizTalk-SEED-Assistent-Aufgaben

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Installieren eines SEED-Pakets bereit.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen eines SEED-Pakets

  • Installieren eines SEED-Pakets


Erstellen eines SEED-Pakets

Bevor Sie ein SEED-Paket erstellen, müssen Sie eine Website einrichten und die Dateien Slingback.asp, Trigger.asp und Localsubmit.asp (die sich im Ordner \Programme\Microsoft BizTalk Server\SEED befinden) auf dieser Site platzieren. Diese Seiten dienen dazu, Sendungen anzunehmen. Weitere Informationen zum Implementieren einer sicheren Site finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach dem Artikel "Implementing a Secure Site with ASP".

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-SEED-Assistent.

    Der BizTalk-SEED-Assistent wird geöffnet.

  2. Wählen Sie SEED-Paket erstellen auf der Seite Willkommen beim BizTalk-SEED-Assistenten aus, und klicken Sie dann auf Weiter.

  3. Geben Sie auf der Seite Paketerstellung - Organisationsinformationen den Namen Ihrer Organisation in das entsprechende Feld ein.

    Oder

    Klicken Sie gegebenenfalls auf Durchsuchen, um nach einem vorhandenen SEED-Paket zu suchen. Das Dialogfeld Öffnen wird angezeigt. Klicken Sie auf das SEED-Paket, das Sie verwenden möchten, und klicken Sie dann auf Öffnen.

    Wichtig

    • Nachdem Sie Änderungen an einem vorhandenen SEED-Paket vorgenommen haben, steht die Schaltfläche Durchsuchen nicht mehr zur Verfügung. Sie können also nicht zur Seite Paketerstellung - Organisationsinformationen zurückgehen und das SEED-Paket erneut laden. Um dasselbe SEED-Paket noch einmal zu laden, nachdem Sie Änderungen daran vorgenommen haben, klicken Sie auf Abbrechen, um den Assistenten zu schließen. Öffnen Sie den BizTalk-SEED-Assistenten erneut, und suchen Sie auf der Seite Paketerstellung - Organisationsinformationen nach demselben SEED-Paket.
  4. Klicken Sie auf Weiter.

  5. Klicken Sie auf der Seite Paketerstellung - Dokumentspezifikationen auf Hinzufügen.

    Das Dialogfeld Dokument konfigurieren wird angezeigt.

  6. Klicken Sie auf die Schaltfläche Durchsuchen neben dem Feld Spezifikation, um nach einer bestimmten Spezifikation zu suchen.

    Das Dialogfeld Dokumentspezifikation aus dem WebDAV-Repository auswählen wird angezeigt.

  7. Suchen Sie nach dem Speicherort der Spezifikation, wählen Sie die Datei aus, und klicken Sie auf Öffnen.

  8. Klicken Sie auf die Schaltfläche Durchsuchen neben dem Feld Testinstanz, um nach einer bestimmten Dokumentinstanz zu suchen.

    Das Dialogfeld Öffnen wird angezeigt.

  9. Suchen Sie nach dem Speicherort der Dokumentinstanz, wählen Sie die Datei aus, und klicken Sie auf Öffnen.

  10. Wählen Sie entweder Eingehend an Initiator oder Ausgehend von Initiator aus.

  11. Geben Sie im Feld URL für Remotetest den Pfad für den Server ein, der die Datei Slingback.asp (wenn Sie in Schritt 10 Eingehend an Initiator ausgewählt haben) bzw. Trigger.asp (wenn Sie Ausgehend von Initiator ausgewählt haben) enthält. Wenn Sie in Schritt 10 Ausgehend von Initiator ausgewählt haben, klicken Sie auf OK. Wenn Sie Eingehend an Initiator ausgewählt haben, fahren Sie mit Schritt 12 fort.

    Anmerkung

    • Wenn Sie auf OK geklickt haben, wird die Seite Paketerstellung - Dokumentspezifikationen angezeigt. Führen Sie gegebenenfalls Schritt 13 aus. Andernfalls fahren Sie mit Schritt 14 fort.
  12. Wenn Sie Eingehend an Initiator ausgewählt haben, geben Sie im Feld Produktions-URL den Pfad für Ihren Produktionsserver ein, und klicken Sie auf OK.

    Die Seite Paketerstellung - Dokumentspezifikationen wird angezeigt. Führen Sie gegebenenfalls Schritt 13 aus. Andernfalls fahren Sie mit Schritt 14 fort.

  13. So bearbeiten Sie eine Dokumentkonfiguration:
    1. Wählen Sie eine Spezifikation in der Liste Dokumente aus, und klicken Sie dann auf Bearbeiten.

      Das Dialogfeld Dokument konfigurieren wird angezeigt.

    2. Nehmen Sie Änderungen an den Optionen vor, wie in den Schritten 3 bis 9 dargestellt.

    So entfernen Sie eine Spezifikation aus der Liste Dokumente:

    • Wählen Sie die Spezifikation in der Liste Dokumente aus, und klicken Sie dann auf Entfernen.
  14. Klicken Sie auf Weiter.

  15. Klicken Sie auf der Seite BizTalk-SEED-Assistent wird abgeschlossen gegebenenfalls auf Durchsuchen, um einen neuen Speicherort für das SEED-Paket anzugeben, und klicken Sie auf Fertig stellen, um das Paket an dem im Feld Pfad für SEED-Paket angegebenen Speicherort zu installieren.

    Das Meldungsfeld BizTalk-SEED-Assistent wird angezeigt.

  16. Klicken Sie auf OK.

Verwandtes Thema

Beispiel für eine Initiator-Empfänger-Beziehung

Initiieren eines SEED-Pakets

Installieren eines SEED-Pakets

Grundlegendes zu den ASP-Seiten in SEED


Installieren eines SEED-Pakets

Falls die Dateien noch nicht installiert wurden, installieren Sie sie (mit Ausnahme von Localsubmit.asp) in dem gewünschten Verzeichnis. Installieren Sie die Datei Localsubmit.asp in einem virtuellen Verzeichnis, auf das während der Konfiguration der in einem SEED-Paket enthaltenen ausgehenden Dokumente zugegriffen werden kann.

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-SEED-Assistent.

    Der BizTalk SEED-Assistent wird geöffnet.

  2. Wählen Sie SEED-Paket installieren auf der Seite Willkommen beim BizTalk-SEED-Assistenten aus, und klicken Sie dann auf Weiter.

  3. Klicken Sie auf der Seite Paketinstallation - Paketauswahl auf Durchsuchen, um nach dem SEED-Paket zu suchen.

    Das Dialogfeld Öffnen wird angezeigt.

  4. Suchen Sie nach dem Speicherort des SEED-Pakets, wählen Sie die Datei aus, und klicken Sie auf Öffnen.

  5. Klicken Sie auf Weiter.

  6. Geben Sie in den Feldern Timeout und Intervall auf der Seite Paketinstallation - Testinformationen jeweils eine Zahl ein, und klicken Sie dann auf Weiter.

    Wichtig

    • Enthält das SEED-Paket umfangreiche Dokumente, wird als Testergebnis möglicherweise der Status Zeitüberschreitung oder Fehlgeschlagen angezeigt.

    • Der Wert im Feld Timeout wird dem Wert im Verwaltungscache hinzugefügt, der in den BizTalk Server-Gruppeneinstellungen festgelegt wurde.
  7. Wählen Sie auf der Seite Paketinstallation - Dokumentbereitstellung im Feld Dokumente eine Spezifikation aus, und klicken Sie auf Konfigurieren.

    Wichtig

    • Wurde das Dokument während des Erstellungsprozesses als Eingehend an Initiator konfiguriert, wird das Dialogfeld Konfiguration eingehender Dokumente (an Initiator) angezeigt. Fahren Sie mit Schritt 9 fort.

    • Wurde das Dokument während des Erstellungsprozesses als Ausgehend von Initiator konfiguriert, wird das Dialogfeld Konfiguration ausgehender Dokumente (an Initiator) angezeigt. Fahren Sie mit Schritt 14 fort.
  8. Klicken Sie im Dialogfeld Konfiguration eingehender Dokumente (an Initiator) auf die Schaltfläche Durchsuchen neben dem Feld Speicherort, um einen Abrufspeicherort für die Empfangsfunktion anzugeben.

    Das Dialogfeld Ordner suchen wird angezeigt.

    Anmerkung

    • Der angegebene Speicherort darf nicht mit dem im Feld Testverzeichnis angegebenen Speicherort übereinstimmen.
  9. Wählen Sie einen Speicherort für die Empfangsfunktion aus, und klicken Sie auf OK.

  10. Geben Sie im Feld Abzurufende Dateitypen die Dateitypen ein, nach denen Sie suchen möchten.

    Anmerkung

    • Wenn Sie den Dateityp ändern möchten, muss der Standarddateityp im SEED-Paket enthalten sein.
  11. Klicken Sie auf die Schaltfläche Durchsuchen neben dem Feld Testverzeichnis, um ein Testverzeichnis anzugeben.

    Das Dialogfeld Ordner suchen wird angezeigt.

    Anmerkung

    • Der angegebene Speicherort darf nicht mit dem Speicherort übereinstimmen, der im Feld Speicherort im Bereich Empfangsfunktion angegeben wurde.
  12. Wählen Sie ein Testverzeichnis aus, und klicken Sie auf OK.

    Die Seite Paketinstallation - Dokumentbereitstellung wird angezeigt.

  13. Wurde das Dokument ursprünglich mithilfe der Option Konfiguration eingehender Dokumente (an Initiator) konfiguriert, fahren Sie mit Schritt 16 fort.

  14. Geben Sie im Feld Produktions-URL des Dialogfeldes Konfiguration ausgehender Dokumente (an Initiator) den Speicherort für die Seite Localsubmit.asp an.

  15. Klicken Sie im Feld Endgültiges Verzeichnis auf Durchsuchen, um das endgültige Verzeichnis zum Testen ausgehender Dokumente anzugeben, und klicken Sie auf OK.

  16. Klicken Sie auf Erstellen.

    Anmerkung

    • Nach Abschluss des Erstellungsprozesses ändert sich die Schaltfläche Erstellen in Entfernen.
  17. Klicken Sie auf Lokal testen, um nur die lokale Konfiguration zu überprüfen.

  18. Klicken Sie auf Remote testen, um die Remoteverbindung zum Initiator zu testen.

    Ist das Feld Initiator für das Dokument als Ausgehend gekennzeichnet, fahren Sie mit Schritt 20 fort.

  19. Klicken Sie auf Bereitstellen.

    Die Schaltfläche Bereitstellen ist nur aktiviert, wenn das Feld Initiator für das Dokument als Eingehend gekennzeichnet ist.

  20. Klicken Sie auf Weiter.

    Die Seite BizTalk-SEED-Assistent wird abgeschlossen wird angezeigt.

  21. Klicken Sie auf Fertig stellen.

  22. Klicken Sie auf OK, um das Dialogfeld Nachricht des BizTalk-SEED-Assistenten zu schließen.

Verwandtes Thema

Beispiel für eine Initiator-Empfänger-Beziehung

Empfangen eines SEED-Pakets


Problembehandlung - BizTalk-SEED-Assistent

Dieser Abschnitt enthält Informationen zur Problembehandlung bei SEED-Paketen.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Die Optionen "Lokal testen" oder "Remote testen" schlagen fehl bzw. zeigen ein Timeout an


Die Optionen "Lokal testen" oder "Remote testen" schlagen fehl bzw. zeigen ein Timeout an

Ursache: Die Optionen Lokal testen oder Remote testen für ausgehende Dokumente zeigen ein Timeout an.

Lösungen:

  1. Überprüfen Sie das Ereignisprotokoll. Ist kein Fehler für die Datei aufgezeichnet, erhöhen Sie die Zahl im Feld Timeout auf der Seite Paketinstallation - Testinformationen.

  2. Weist das Ereignisprotokoll Fehler für die Datei auf, beheben Sie die Fehler anhand der Informationen im Ereignisprotokoll.

  3. Besitzt die im SEED-Paket enthaltene Dokumentinstanz denselben Namen wie eine andere Datei im Testverzeichnis, hängt BizTalk Server die im SEED-Paket enthaltene Dokumentinstanz an die Datei an, die sich im Testverzeichnis befindet. Dies führt dazu, dass die Dokumentinstanz nicht mehr der im SEED-Paket enthaltenen Beispielinstanz entspricht. Benennen Sie die Datei im Testverzeichnis um, oder entfernen Sie sie, und klicken Sie dann auf Lokal testen oder Remote testen.

Ursache: Die Option Remote testen für eingehende Dokumente schlägt fehl.

Lösungen:

  1. Überprüfen Sie das Ereignisprotokoll. Ist kein Fehler für die Datei aufgezeichnet, erhöhen Sie die Zahl im Feld Timeout auf der Seite Paketinstallation - Testinformationen.

  2. Weist das Ereignisprotokoll Fehler für die Datei auf, beheben Sie die Fehler anhand der Informationen im Ereignisprotokoll.

  3. Besitzt die im SEED-Paket enthaltene Dokumentinstanz denselben Namen wie eine andere Datei im Testverzeichnis, hängt BizTalk Server die im SEED-Paket enthaltene Dokumentinstanz an die Datei an, die sich im Testverzeichnis befindet. Dies führt dazu, dass die Dokumentinstanz der im SEED-Paket enthaltenen Beispielinstanz nicht mehr entspricht. Benennen Sie die Datei im Testverzeichnis um, oder entfernen Sie sie, und klicken Sie dann auf Lokal testen oder Remote testen.

  4. Wird das Problem dadurch verursacht, dass das System des Initiators nicht reagiert, warten Sie einen Moment, und klicken Sie dann erneut auf Remote testen.


Bereitstellen von Anwendungen mit BizTalkServer-Ressourcen

BizTalk Server 2002 ~ Anwendungsentwicklung

Bereitstellen von Anwendungen mit BizTalk Server-Ressourcen

Microsoft® Application Center 2000 kann zum Bereitstellen einer Microsoft BizTalk™ Server 2002-Konfiguration aus einer Konfiguration in einer anderen verwendet werden, z. B. zum Verschieben einer Konfiguration aus einer Testumgebung in eine Produktionsumgebung. Wenn Application Center zum Bereitstellen von Umgebungen verwendet wird, werden die zum Verschieben der Konfigurationen benötigte Zeit und der mit dieser Verschiebung verbundene manuelle Konfigurationsaufwand deutlich verringert.

Der BizTalk Server-Replikationstreiber erweitert Application Center, um die Replikation von BizTalk-Ressourcen für alle Mitglieder eines Clusters und zwischen Clustern zu ermöglichen. Der Treiber verwendet die vorhandene Replikationsunterstützung von Application Center.

Dieser Treiber ersetzt die vorherige Bereitstellungsmethode (BTConfigAssistant) von BizTalk Server 2000. BTConfigAssistant, eine im Lieferumfang der ersten Version von BizTalk Server enthaltene Microsoft Visual Basic®-Beispielanwendung, hat Konfigurationsinformationen extrahiert und das Bereitstellen von Anwendungen für Unternehmen ermöglicht. Diese Methode steht auch in BizTalk Server 2002 zur Verfügung; zum Bereitstellen von Anwendungen wird jedoch die Verwendung von Application Center empfohlen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ausführliche Informationen zur Bereitstellung finden Sie unter Informationen zur BizTalk Server-Bereitstellung.

  • Eine Kurzübersicht darüber, warum bestimmte Aufgaben ausgeführt werden müssen, finden Sie unter Gründe für das Ausführen von BizTalk Server-Bereitstellungsaufgaben.

  • Detaillierte Anweisungen zum Ausführen von Aufgaben finden Sie unter Ausführen von BizTalk Server-Bereitstellungsaufgaben.

  • Anweisungen zum Beheben von Problemen finden Sie unter Problembehandlung - BizTalk Server-Bereitstellung.


Informationen zur BizTalkServer-Bereitstellung

BizTalk Server 2002 ~ Anwendungsentwicklung

Informationen zur BizTalk Server-Bereitstellung

Microsoft Application Center 2000, ein Bestandteil der .NET Enterprise Server-Produktfamilie, unterstützt die Bereitstellung mehrerer BizTalk Server-Ressourcen, wie z. B. Ports (einschließlich aller an Ports gebundenen Objekte wie z. B. Kanäle) und Portgruppen, zusammen mit Dateien, COM+-Anwendungen, Registrierungsschlüsseln, Websites und virtuellen Verzeichnissen sowie Datenquellen.

Eine typische BizTalk Server-Produktionsumgebung besteht aus einer BizTalk-Messaging-Verwaltungsdatenbank, in der die für die Messagingkonfiguration erforderlichen Informationen gespeichert sind, und einer Gruppe von Anwendungsservern, die diese Messagingkonfiguration gemeinsam nutzen. Jeder Server im Cluster enthält die erforderlichen XLANG-Ablaufpläne, mit den XLANG-Ablaufplänen verbundenen COM+-Anwendungen sowie Informationen dazu, welche BizTalk-Messaging-Verwaltungsdatenbank beim Bereitstellen einer Anwendung verwendet werden soll.

Beim Bereitstellen einer Anwendung muss die BizTalk-Messaging-Verwaltungsdatenbank auf dem Quell- und auf dem Zielcomputer verfügbar sein, da nur ein zentrales WebDAV-Repository unterstützt wird.

Wichtig

  • Sie müssen ein lokales Systemkonto (system\<Computername>) zu einer Remoteinstallation von Microsoft® SQL Server™ hinzufügen, damit der Application Center-Treiber bei einer Remoteausführung von SQL Server nicht fehlschlägt. Um den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank (InterchangeBTM) von einem Application Center-Cluster aus zu ermöglichen, muss die Datenbank für den Application Center-Clustercontroller lokal verfügbar sein oder sich außerhalb des Application Center-Clusters befinden. Der BizTalk Server-Replikationstreiber kann möglicherweise nicht auf die BizTalk-Messaging-Verwaltungsdatenbank zugreifen, falls sie sich auf einem Mitglied des Application Center-Clusters befindet.

Der BizTalk Server-Replikationstreiber von Application Center hat zwei wichtige Funktionen:

  1. Verschieben lokaler Ressourcen. Für diesen Task ist es erforderlich, dass der Quellserver auf seine lokalen Ressourcen verweist und sie auf einen Zielserver repliziert. Die automatische Replikation wird unterstützt.

  2. Verschieben freigegebener Ressourcen. Für diesen Task ist es erforderlich, dass die benötigten Informationen aus der BizTalk-Messaging-Verwaltungsdatenbank gesammelt und dann persistent gespeichert und an den Zielserver übertragen werden. Die automatische Replikation wird nicht unterstützt.

Zum Verschieben freigegebener Ressourcen stellt Application Center (unter Verwendung des BizTalk Server-Replikationstreibers) auf dem Quellserver den Kontakt zur BizTalk-Messaging-Verwaltungsdatenbank mithilfe des BizTalk-Messaging-Konfigurationsobjektmodells her, statt direkt aus der SQL Server-Datenbank zu lesen. Dieser Vorgang schützt vor zukünftigen Änderungen an der BizTalk Server-Konfiguration und stellt sicher, dass Einschränkungen des Objektmodells erzwungen werden.

In den folgenden drei Systemkonfigurationsszenarios stellt sich der Übertragungsvorgang für freigegebene Informationen wie folgt dar:

Zwei Cluster, die dieselbe Konfigurationsdatenbank gemeinsam nutzen.

In der vorherigen Abbildung sind zwei Cluster dargestellt. Jedes Mitglied in einem Cluster verweist auf dieselbe BizTalk-Messaging-Verwaltungsdatenbank. Wenn Daten zwischen Clustermitgliedern in einem der Cluster synchronisiert werden, müssen die Konfigurationsinformationen daher nicht übertragen werden. Beim Bereitstellen einer Anwendung müssen die Konfigurationsinformationen jedoch übertragen werden, da jeder Cluster eine eigene BizTalk-Messaging-Verwaltungsdatenbank verwendet.

Cluster, die eine BizTalk-Messaging-Verwaltungsdatenbank gemeinsam nutzen.

Die vorherige Abbildung zeigt die Bereitstellung einer Anwendung innerhalb eines Clusters, in dem die BizTalk-Messaging-Verwaltungsdatenbank freigegeben ist. In diesem Szenario wäre es auch bei einer Bereitstellung außerhalb des Clusters nicht erforderlich, freigegebene Ressourcen zu übertragen.

Cluster, die unterschiedliche BizTalk-Messaging-Verwaltungsdatenbanken verwenden.

In der vorherigen Abbildung verwenden einzelne Mitglieder innerhalb eines Clusters unterschiedliche BizTalk-Messaging-Verwaltungsdatenbanken. Da für jedes Clustermitglied mehrere Datenbanken vorhanden sind, müssten bei allen Synchronisierungsvorgängen sowohl lokale als auch freigegebene Informationen in den entsprechenden BizTalk-Messaging-Verwaltungsdatenbanken übertragen werden.

Wichtig

  • Das letzte Szenario wird in den aktuellen Versionen von Application Center und BizTalk Server nicht unterstützt. Diese Systemkonfiguration sollte jedoch ordnungsgemäß funktionieren, so dass Sie Anwendungen bereitstellen können.

Unabhängig von dem von Ihnen verwendeten Systemkonfigurationsszenario gilt das folgende Muster, wenn freigegebene Informationen zwischen Datenbanken übertragen werden müssen:

  1. Der BizTalk Server-Replikationstreiber auf dem Quellserver sendet eine Anforderung mit den Namen der freigegebenen Ressourcen, die auf dem Quellserver verfügbar sind, an die Zieldatenbank. Auf diese Weise kann ermittelt werden, welche Daten aktualisiert werden müssen.

  2. Der Treiber auf dem Zielserver gibt eine Aktionsliste mit den Hinzufügungen, Aktualisierungen und Löschungen zurück, die zum Synchronisieren der freigegebenen Ressourcen erforderlich sind.

  3. Der Quellserver liest die entsprechenden Informationen aus seiner Datenbank, indem er das BizTalk-Messaging-Konfigurationsobjektmodell verwendet, und generiert den Inhalt, der übertragen werden muss.

  4. Der BizTalk Server-Replikationstreiber auf dem Quellserver delegiert den Inhalt an den Replikationstreiber des Application Center-Dateisystems für die Übertragung an den Zielserver.

  5. Der Treiber auf dem Quellserver sendet eine Aktualisierungsliste mit den auf dem Zielserver vorzunehmenden Änderungen. Diese Liste enthält Verweise auf den Inhalt, der an den Zielserver weitergeleitet wurde.

  6. Auf dem Zielserver liest der BizTalk Server-Replikationstreiber den Inhalt und nimmt die entsprechenden Änderungen an der entsprechenden BizTalk-Messaging-Verwaltungsdatenbank vor.

Der grundlegende Vorgang für das Bereitstellen einer neuen oder vorhandenen Anwendung umfasst folgende Schritte:

  1. Bei Bedarf müssen Sie sowohl auf dem Computer, von dem aus Sie die Anwendung bereitstellen, als auch auf dem Computer, auf dem Sie die Anwendung bereitstellen, einen Cluster erstellen. Darüber hinaus müssen Sie einen Application Center-Cluster definieren, der einer BizTalk Server-Gruppe entspricht, und Sie müssen einen Computer als Controller dieses Clusters definieren.

  2. Erstellen Sie eine neue Anwendung, oder wählen Sie eine vorhandene Anwendung in Application Center aus.

  3. Fügen Sie bei Bedarf BizTalk-Ressourcen und andere Ressourcen wie z. B. Dateien, COM+-Anwendungen und Registrierungsschlüssel hinzu.

  4. Stellen Sie die Anwendung vom Quellcomputer auf dem Zielcomputer bereit.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Informationen zu Clustern

  • Erstellen neuer Anwendungen

  • Hinzufügen von Ressourcen

  • Bereitstellen von Anwendungen


Informationen zu Clustern

Mithilfe von Microsoft Application Center können Sie mehrere Cluster von einem Computer aus verwalten. Mit Application Center können Sie folgende Aktionen ausführen:

  • Erstellen von Clustern

  • Verbinden vorhandener Cluster

  • Hinzufügen und Entfernen von Clustermitgliedern

  • Bereitstellen von neuem Inhalt

  • Konfigurieren des Lastenausgleichs

  • Überwachen der Clusterleistung

Zudem steht durch Application Center ein einzelnes vereinheitlichtes Abbild des in einem Cluster installierten Inhalts zur Verfügung. Für die Verwendung dieses Inhalts stellt Application Center Assistenten (z. B. den New Cluster Wizard) zur Verfügung, um das Erstellen und Verwalten von Clustern sowie das Bereitstellen von Inhalt zu erleichtern.

Ein Application Center-Cluster kann Anforderungen von Clients in einem Unternehmensintranet oder von externen Internet-Clients verarbeiten. Bei der Clientsoftware kann es sich um "Thin-Client"-Anwendungen (wie z. B. Webbrowser) oder um "Thick-Client"-Anwendungen (wie z. B. Microsoft Visual Basic-Programme) handeln. Application Center-Cluster können aufgrund ihres Entwurfs sowohl die Webebene verwalten, die Anforderungen von HTTP-Clients verarbeitet, als auch die Geschäftslogikebene, die den DCOM-Datenverkehr (Distributed Component Object Model) verarbeitet.

Wichtig

  • Microsoft Application Center verwendet die Microsoft® Windows®-Authentifizierung für den Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank (InterchangeBTM) von einem Application Center-Cluster aus. Für diesen Vorgang muss die BizTalk-Messaging-Verwaltungsdatenbank für den Application Center-Clustercontroller lokal verfügbar sein, oder die BizTalk-Messaging-Verwaltungsdatenbank muss sich außerhalb des Application Center-Clusters befinden. Falls sich die BizTalk-Messaging-Verwaltungsdatenbank außerhalb des Application Center-Clusters befindet, müssen Sie ein lokales Systemkonto zu einer Remoteinstallation von SQL Server hinzufügen, damit der Application Center-Treiber bei einer Remoteausführung von SQL Server nicht fehlschlägt. Möglicherweise können Sie nicht auf die BizTalk-Messaging-Verwaltungsdatenbank zugreifen, falls SQL Server, mit dessen Hilfe lokal auf die Datenbank zugegriffen werden kann, zwar ein Mitglied des Application Center-Clusters, nicht jedoch der Clustercontroller ist. Ausführliche Anweisungen zum Hinzufügen eines SQL Server-Anmeldekontos finden Sie im Thema "Remoteanmeldekonto für SQL Server" unter Interaktionen zwischen SQL Server und BizTalk Server 2000-Datenbanken.

Anmerkung

  • Verwenden Sie Application Center zum Verwalten der Verfügbarkeit und Anwendungsbereitstellung auf eigenständigen (nicht gruppierten) Servern oder auf Servern, auf denen keine Websites ausgeführt werden. In diesen Fällen behandelt Application Center den eigenständigen Server als einen Cluster.


Erstellen neuer Anwendungen

Im Zusammenhang mit Microsoft Application Center stellt eine Anwendung Inhalt dar, in dem Ressourcen aufgeführt sind, die innerhalb eines Clusters synchronisiert bzw. in einem Cluster bereitgestellt sind. Eine Anwendung enthält Ressourcen, indem sie Verweise auf diese aufführt, daher können mehrere Anwendungen dieselbe Ressource aufführen. Beim Synchronisieren oder Bereitstellen einer Application Center-Anwendung werden auch die in der Anwendung aufgeführten Ressourcen synchronisiert oder bereitgestellt.

Durch das Erstellen neuer Application Center-Anwendungen können Sie das Synchronisieren und Bereitstellen für Ressourcen, einschließlich BizTalk-Ressourcen, verwalten. Weitere Informationen zum Erstellen neuer Application Center-Anwendungen finden Sie in der Hilfe zu Application Center 2000. Durch ein derartiges Verwenden von Anwendungen können Sie besser kontrollieren, welche Ressourcen zu welchem Zeitpunkt synchronisiert oder bereitgestellt werden. Zudem können Sie eine Anwendung erstellen, die eine Teilmenge einer Standardanwendung oder Ressourcen aufführt, die nicht in einer Standardanwendung aufgeführt sind.


Hinzufügen von Ressourcen

Mithilfe von Microsoft Application Center können Sie Ressourcen zu einer Anwendung hinzufügen. Eine BizTalk-Ressource ist wie ein Objekt mit einem eindeutigen Namen und einer Gruppe von Eigenschaften. Biztalk-Ressourcen, wie z. B. Ports, Portgruppen, benutzerdefinierte Zähler und Empfangsfunktionen, stellen die Konfiguration für eine bestimmte Anwendung dar, die auf Microsoft BizTalk Server vertraut. Sie geben an, welche Ressourcen mit der bereitzustellenden Anwendung verbunden sein sollen.

Wichtig

  • Das Pluszeichen (+) sollte in Ressourcennamen nicht verwendet werden, da es in ASP (auf dem Server) in ein Leerzeichen konvertiert wird. "BizTalkorg+port" würde z. B. in "BizTalkorg port" konvertiert. Falls Sie eine Anwendung bereitstellen, die einen Ressourcennamen mit einem Pluszeichen enthält, wird kein Inhalt generiert, und Dateien werden nicht übertragen. Application Center gibt jedoch an, dass die Anwendung erfolgreich bereitgestellt wurde. Falls Sie über eine Ressource mit Pluszeichen im Namen verfügen, ersetzen Sie das Zeichen auf dem Clientcomputer durch %2B.

In der folgenden Tabelle ist dargestellt, welche BizTalk-Ressourcentypen Sie zu einer Anwendung hinzufügen können und welche bestimmten Elemente automatisch eingeschlossen werden.

BizTalk-Ressource Automatisch hinzugefügte Elemente Anmerkungen
Port Alle verbundenen
  • Kanäle

  • Dokumentdefinitionen

  • Organisationen

  • Umschläge
  • Alle mit dem Port verbundenen Elemente werden bereitgestellt; nicht gebundene Elemente wie Dokumente und Umschläge werden nicht automatisch verschoben. Beispiele sind Umschläge und als Umschläge verwendete Dokumente, die zum Analysieren eingehender Flatfiles verwendet werden, sowie Dokumente, die zum Analysieren eingehender Empfangsbestätigungen verwendet werden.
Portgruppe

(Verteilergruppe)

 Alle Ports in der Gruppe.

Alle für einen Port hinzugefügten Elemente, für jeden Port in der Portgruppe.
  • Alle mit der Portgruppe verbundenen Elemente werden bereitgestellt; nicht gebundene Elemente wie Dokumente und Umschläge werden nicht automatisch verschoben. Beispiele sind Umschläge und als Umschläge verwendete Dokumente, die zum Analysieren eingehender Flatfiles verwendet werden, sowie Dokumente, die zum Analysieren eingehender Empfangsbestätigungen verwendet werden.
Empfangsfunktion Es werden keine zusätzlichen Elemente hinzugefügt.
  • Sie müssen bei Bedarf die Dateisystemressource, die von der Empfangsfunktion verwendet wird, manuell hinzufügen oder Message Queuing (auch als MSMQ bezeichnet) auf dem Zielserver erstellen.
Benutzerdefinierter Zähler Es werden keine zusätzlichen Elemente hinzugefügt.
  • Mehrere Eigenschaften und Einschränkungen müssen bei benutzerdefinierten Zählern beachtet werden. Weitere Informationen finden Sie unter Benutzerdefinierte Zähler, Creating a Custom Counter Using WMI und Custom Counter Query Properties.

Zusätzlich zu BizTalk-Ressourcen können Sie mit Application Center auch die folgenden Ressourcen hinzufügen:

  • Dateisystempfad

  • Registrierungsschlüssel

  • Websites und virtuelle Verzeichnisse

  • COM+-Anwendungen

  • Datenquellen

Dateisystempfad

Zeigt die Replikation von Dateisystemordnern an. Mithilfe der Ressource Dateisystempfad können Sie z. B. XLANG-Ablaufpläne oder Verzeichnisse bereitstellen, die von Empfangsfunktionen und zum Dateitransport verwendet werden.

Wichtig

  • Sie müssen XLANG-Ablaufpläne (SKX-Dateien) mithilfe der Ressource Dateisystempfad zur Anwendung, die Sie bereitstellen möchten, hinzufügen. XLANG-Ablaufpläne müssen lokal auf dem Computer gespeichert werden, auf dem sie ausgeführt werden sollen.

Registrierungsschlüssel

Ermöglicht den Zugriff auf die Registrierung. Das Synchronisieren einer gesamten Registrierung in einem Cluster kann schwerwiegende Konflikte bei den Clustermitgliedern verursachen. Daher wird diese Vorgehensweise nicht empfohlen.

Websites und virtuelle Verzeichnisse

Enthält eine Liste mit verfügbaren IIS-Websites (Internet Information Services, Internet-Informationsdienste) und virtuellen Verzeichnissen (einschließlich Dateien, Zertifikaten, Zertifikatsvertrauenslisten und ISAPI-Filter, auf die durch die Site oder das virtuelle Verzeichnis verwiesen wird). Wenn Sie diese Elemente angeben möchten, müssen Sie nur die Website oder das virtuelle Verzeichnis hinzufügen. Sie müssen nicht explizit die physischen Verzeichnisse oder Dateien angeben, aus denen die Website oder das virtuelle Verzeichnis bestehen. Beispiele sind HTTP-Empfangsfunktionen und Websites, auf die Handelspartner antworten.

Anmerkung

  • Application Center synchronisiert Ressourcen, die nur im lokalen Dateisystem angegeben sind. Ressourcen, die mit einem UNC-Pfad oder auf Wechselmedien angegeben sind, werden nicht synchronisiert.

COM+-Anwendungen

Zeigt alle verfügbaren COM+-Anwendungen, -Proxies und -Komponenten an. Verwenden Sie diese Ressource zum Verschieben von Anwendungsintegrationskomponenten (Application Integration Components, AICs) und Komponenten in Ablaufplänen, wenn es sich um COM+-Anwendungen handelt. Weitere Informationen finden Sie in der Hilfe zu Application Center 2000.

Wichtig

  • Sie müssen die Ressource COM+-Anwendungen zum Hinzufügen von COM+-Anwendungen verwenden, die an XLANG-Ablaufpläne für die bereitzustellenden Anwendungen gebunden sind.

  • Nur ordnungsgemäß registrierte COM+-Anwendungen können auf dem Computer hinzugefügt werden, auf dem sie ausgeführt werden. Dies gilt nur, wenn die Komponentendienste auf dem lokalen Server installiert sind. Falls eine COM+-Anwendung nicht im Application Center-Snap-In angezeigt wird, kann sie nicht zu einer Anwendung hinzugefügt werden. Um COM-Komponenten zu Anwendungslisten hinzuzufügen, müssen Sie diese in COM+-Anwendungen installieren.

Datenquellen

Gibt die verfügbaren System-Datenquellennamen (Data Source Names, DSNs) an. Nur Datenquellennamen auf dem lokalen Server stehen zum Hinzufügen zu Anwendungen zur Verfügung. Datenquellennamen auf Remoteservern stehen erst dann zur Verfügung, wenn Sie sie auf dem lokalen Server erstellen.


Bereitstellen von Anwendungen

Mit Bereitstellung wird der Vorgang bezeichnet, bei dem das ursprüngliche Abbild einer Microsoft Application Center-Anwendung von einem Cluster in einen anderen kopiert wird. In der Regel erfolgt die Bereitstellung von einem Stagingcluster auf einen Produktionscluster, der den Live-Inhalt enthält. Während der Bereitstellung wird das Anwendungsabbild auf den Clustercontroller des Empfängerclusters kopiert.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Planen der Bereitstellung

  • Prüfliste für die Zeit vor der Bereitstellung

  • Prüfliste für die Zeit nach der Bereitstellung

  • Nicht bereitgestellte und/oder replizierte Elemente

  • Synchronisierung der BizTalk-Ressourcen


Planen der Bereitstellung

BizTalk Server 2002 ~ Anwendungsentwicklung

Planen der Bereitstellung

Vor dem Bereitstellen von Anwendungen sollten Sie die Ressourcen identifizieren, aus denen die BizTalk-Anwendung besteht. Ressourcen können Folgendes sein:

  • Konfigurationsinformationen (die in der BizTalk-Messaging-Verwaltungsdatenbank gespeichert sind), einschließlich folgender Informationen:
    • Ports (verbundene Kanäle, Dokumentdefinitionen, Umschläge und Organisationen sind automatisch enthalten)

    • Verteilerlisten

    • Empfangsfunktionen

    • Benutzerdefinierte Zähler
  • Externe Komponenten (beispielsweise):
    • Dateien

    • Registrierungsschlüssel

    • Anwendungsintegrationskomponenten (Application Integration Components, AICs)

    • Zertifikate

    • Nachrichtenwarteschlangen (MSMQs)

    • XLANG-Ablaufpläne (SKX-Dateien)

    • Benutzerdefinierte Komponenten (Verschlüsselung, Codierung, Serialisierung)

Nachdem die Ressourcen identifiziert sind, gruppieren Sie die Ressourcen in Application Center-Anwendungen.


Prüfliste für die Zeit vor der Bereitstellung

BizTalk Server 2002 ~ Anwendungsentwicklung

Prüfliste für die Zeit vor der Bereitstellung

Bevor Sie eine Anwendung mit BizTalk-Ressourcen bereitstellen, stellen Sie sicher, dass Sie die folgenden Aspekte berücksichtigt haben.

Quellcluster

  • Stellen Sie sicher, dass der Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank möglich ist.

  • Stellen Sie sicher, dass der Zugriff auf das WebDAV-Repository möglich ist.

  • Es findet keine automatische Zuordnung von Variablen wie z. B. Transportadressen statt, da diese Variablentypen in verschiedenen Umgebungen unterschiedlich sind. Transportadressen müssen manuell geändert werden.

  • XLANG-Ablaufpläne (SKX-Dateien) müssen direkt in den Cluster kopiert werden, in dem die Anwendung bereitgestellt wird.

  • Das Starten und Anhalten von Diensten nach oder vor der Bereitstellung einer Anwendung muss abgeschlossen sein, wenn der Cache unmittelbar aktualisiert werden muss. Weitere Informationen finden Sie unter Starten eines Servers in einer Gruppe und Beenden eines Servers in einer Gruppe. Weitere Informationen zum Anpassen des Aktualisierungsintervalls für einen Server finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  • Ehe Sie eine bereits bereitgestellte Anwendung aktualisieren, die BizTalk-Ressourcen enthält, stellen Sie sicher, dass alle langlebigen Transaktionen abgeschlossen wurden.

Zielcluster

  • Stellen Sie sicher, dass der Zugriff auf die BizTalk-Messaging-Verwaltungsdatenbank möglich ist.

  • Stellen Sie sicher, dass der SMTP-Host (Simple Mail Transfer Protocol) für jede BizTalk Server-Gruppe und Antwort-URL für Reliable Messaging festgelegt ist. Verwenden Sie die Konsole BizTalk Server-Verwaltung.

  • Stellen Sie sicher, dass die erforderlichen Zertifikate vorhanden sind, da Zertifikate nicht automatisch bereitgestellt werden.

  • Stellen Sie sicher, dass der Zugriff auf das WebDAV-Repository möglich ist, ansonsten können Dokumentdefinitionen und Umschläge möglicherweise nicht repliziert werden.

  • Registrieren Sie die Anwendungsintegrationskomponenten (Application Integration Components, AICs) auf dem Zielserver.

  • Erstellen Sie die Nachrichtenwarteschlangen, die für die Message Queuing-Empfangsfunktionen erforderlich sind.

  • Halten Sie verarbeitende Server an.


Prüfliste für die Zeit nach der Bereitstellung

BizTalk Server 2002 ~ Anwendungsentwicklung

Prüfliste für die Zeit nach der Bereitstellung

Nachdem Sie eine Anwendung bereitgestellt haben, d. h. erfolgreich zum Zielcomputer hinzugefügt haben, müssen Sie manuell einige Änderungen vornehmen, um den Bereitstellungsvorgang für die nun auf dem Zielcomputer vorhandene Anwendung abzuschließen. In diesem Thema werden die Bereiche erläutert, in denen Sie abhängig von den mit der bereitgestellten Anwendung verbundenen Ressourcen möglicherweise Änderungen vornehmen müssen.

Datenbanken

Nach Abschluß der Bereitstellung müssen Sie geringfügige Anpassungen auf dem Zielcomputer vornehmen. Falls die Anwendung z. B. Korrelationsdatenbanken verwendet, müssen Sie die Korrelationsdatenbanken manuell in die SQL Server-Instanz des Zielcomputers kopieren. Schrittweise Anweisungen hierzu finden Sie unter "Anfügen der Datenbanken" im Abschnitt Vorläufige Installation des Beispiels für die elektronische Beschaffung. Sie können auch Data Transformation Services (DTS) von SQL Server zum Exportieren der Datenbanken zur SQL Server-Instanz des Zielcomputers verwenden.

Empfangsfunktionen

Möglicherweise müssen Sie alle von einer Anwendung verwendeten BizTalk-Empfangsfunktionen aktivieren. Die Aktivierung der Empfangsfunktionen erfolgt mithilfe der BizTalk Server-Verwaltung oder programmgesteuert mithilfe des WMI-Providers (Windows Management Instrumentation) von BizTalk Server. Die Aktivierung kann erforderlich sein, da die Empfangsfunktionen bereits vor den manuell zu erstellenden Nachrichtenwarteschlangen erstellt werden. BizTalk Server deaktiviert Empfangsfunktionen automatisch, wenn auf die entsprechenden Abrufspeicherorte (z. B. ein Verzeichnis) nicht zugegriffen werden kann.

Unter Umständen muss der verarbeitende Server der Empfangsfunktionen aktualisiert werden. Jede Empfangsfunktion ist mit einem verarbeitenden Server verbunden. Die Namen der verarbeitenden Server im Quellcluster werden dem Namen des Zielservers, in der Regel dem Clustercontroller, im Zielcluster zugeordnet. Sie können den verarbeitenden Server der Empfangsfunktionen mithilfe der BizTalk Server-Verwaltung oder programmgesteuert durch den WMI-Provider aktualisieren.

Wenn Sie Empfangsfunktionen replizieren, die für die Verwendung eines Benutzernamens und eines Kennwortes konfiguriert sind, wird die Empfangsfunktion wegen eines nicht vorhandenen Kennwortes deaktiviert. Zur Lösung dieses Problems müssen Sie für jede Empfangsfunktion die Eigenschaftenseite anzeigen, das Kennwort erneut eingeben und dann die Empfangsfunktion aktivieren.

Ports

Falls Sie eine Application Center-Anwendung mit BizTalk-Ports bereitgestellt haben, müssen die Ports auf dem Zielcomputer aktualisiert werden, so dass die primäre und sekundäre Portadresse auf die richtigen Speicherorte verweisen. So muss z. B. http://TestAURL gegebenenfalls in http://ProductionAURL geändert werden. Wenn Application Center die BizTalk Server-Konfiguration von einem Computer auf einem anderen bereitstellt, werden die BizTalk-Ports nicht geändert.

Anmerkung

  • Möglicherweise müssen Sie den BizTalk-Dienst starten und anhalten, damit die Änderungen in Kraft treten. Sie können den BizTalk-Dienst im Tool BizTalk Server-Verwaltung starten und anhalten. Weitere Informationen finden Sie unter Starten eines BizTalk-Dienstes und Beenden eines BizTalk-Dienstes.

Verarbeitende Server

Nach dem Bereitstellen einer Anwendung müssen verarbeitende Server gestartet werden.


Nicht bereitgestellte und/oder replizierte Elemente

BizTalk Server 2002 ~ Anwendungsentwicklung

Nicht bereitgestellte und/oder replizierte Elemente

Dokumente und Umschläge, die nicht an Ports gebunden sind, werden nicht bereitgestellt. Beispiele sind Umschläge und als Umschläge verwendete Dokumente, die zum Analysieren eingehender Flatfiles verwendet werden, und Dokumente, die zum Analysieren eingehender Empfangsbestätigungen verwendet werden. Zertifikate, die von Ports und Kanälen zur Verschlüsselung, Entschlüsselung und Signierung verwendet werden, werden nicht repliziert. Sie müssen direkt in den Cluster kopiert werden, in dem die Anwendung bereitgestellt wird. Dasselbe gilt für andere Objekte, die nicht repliziert werden, wie z. B. Zertifikate.

Objekte, die nicht repliziert werden, sollten vor der Bereitstellung einer Anwendung auf dem Zielserver vorhanden sein. Angenommen Sie verfügen über eine Application Center-Anwendung mit einem Kanal, der eine Anwendungsintegrationskomponente (Application Integration Component, AIC) verwendet. Beim Bereitstellen dieser Anwendung ist nicht sichergestellt, dass die COM+-Anwendung mit der Anwendungsintegrationskomponente erstellt wird, bevor der auf die Anwendungsintegrationskomponente verweisende Kanal erstellt wird.

Dateihierarchien für Empfangsfunktionen und Message Queuing-Warteschlangen werden ebenfalls nicht repliziert. Der Grund liegt darin, dass Empfangsfunktionen und Message Queuing-Warteschlangen mit bestimmten verarbeitenden Servern mit BizTalk Server verbunden sind, die nach Namen identifiziert werden. Beispielsweise müssten die Funktionen R1 und R2, die mit den Computern Test1 und Test2 in einer Testumgebung verbunden sind, mit den Computern ProdA und ProdB in einer Produktionsumgebung verbunden werden. An Ablaufpläne gebundenes Message Queuing muss direkt in den Cluster kopiert werden, in dem die Anwendung bereitgestellt wird.


Synchronisierung der BizTalk-Ressourcen

BizTalk Server 2002 ~ Anwendungsentwicklung

Synchronisierung der BizTalk-Ressourcen

Anders als die übrigen Application Center-Ressourcen werden BizTalk-Ressourcen nicht automatisch synchronisiert. Wenn Sie demnach Änderungen an einer BizTalk-Ressource für eine Application Center-Anwendung vornehmen, die bereits bereitgestellt wurde, müssen Sie die Application Center-Anwendung erneut bereitstellen. Weitere Informationen zum Bereitstellen einer Application Center-Anwendung, die BizTalk-Ressourcen enthält, finden Sie unter Bereitstellen einer Application Center-Anwendung auf einem Zielserver.


Gründe für das Ausführen von BizTalkServer-Bereitstellungsaufgaben

BizTalk Server 2002 ~ Anwendungsentwicklung

Gründe für das Ausführen von BizTalk Server-Bereitstellungsaufgaben

Dieser Abschnitt stellt eine kurze Referenz zum Ausführen von BizTalk Server-Bereitstellungsaufgaben bereit. Die folgende Tabelle enthält Beschreibungen der Hauptaufgaben sowie der jeweiligen Unteraufgaben, Erläuterungen zum Zweck jeder Aufgabe und Links zu den entsprechenden Verfahren.

Aufgabe Zweck
  • Erstellen einer Application Center-Anwendung mit BizTalk-Ressourcen
 Logisches Gruppieren von BizTalk-Konfigurationsinformationen wie Ports, Anwendungsintegrationskomponenten (AICs), XLANG-Ablaufplänen und anderen Ressourcen, die eine BizTalk-Anwendung zu einer bereitstellbaren Einheit machen.
  • Bereitstellen einer Application Center-Anwendung auf einem Zielserver
 Verschieben neu entwickelter BizTalk-Anwendungen aus einer Entwicklungsumgebung in eine Test- oder Produktionsumgebung.
  • Löschen von BizTalk-Ressourcen von einem Zielserver
 Entfernen von nicht verwendeten oder veralteten Ressourcen.


Ausführen von BizTalkServer-Bereitstellungsaufgaben

BizTalk Server 2002 ~ Anwendungsentwicklung

Ausführen von BizTalk Server-Bereitstellungsaufgaben

Dieser Abschnitt enthält aufgabenspezifische Informationen zum Erstellen einer neuen Application Center-Anwendung oder zum Ändern einer vorhandenen Application Center-Anwendung, die BizTalk-Ressourcen enthält. Darüber hinaus wird erläutert, wie die Application Center-Anwendung auf einem Zielcomputer bereitgestellt wird.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Erstellen einer Application Center-Anwendung mit BizTalk-Ressourcen

  • Bereitstellen einer Application Center-Anwendung auf einem Zielserver

  • Löschen von BizTalk-Ressourcen von einem Zielserver


Erstellen einer ApplicationCenter-Anwendung mit BizTalk-Ressourcen

BizTalk Server 2002 ~ Anwendungsentwicklung

Erstellen einer Application Center-Anwendung mit BizTalk-Ressourcen

Es wird empfohlen, dass Sie Ressourcen einzeln bereitstellen, statt einen Ordner mit den Ressourcen hinzuzufügen. Wenn Sie Ressourcen durch Auswählen eines Ordners bereitstellen und später eine dieser Ressourcen entfernen müssen, müssen Sie alle Ressourcen vom Bereitstellungscomputer entfernen. Weitere Informationen zum Löschen von Ressourcen finden Sie unter Löschen von BizTalk-Ressourcen von einem Zielserver.

  1. Zeigen Sie im Startmenü auf Programme, dann auf Verwaltung, und klicken Sie anschließend auf Application Center.

    Microsoft Application Center 2000 wird geöffnet.

  2. Erweitern Sie Application Center, erweitern Sie den Cluster, zu dem Sie die Application Center-Anwendung hinzufügen möchten, und klicken Sie dann auf Applications.

  3. Klicken Sie im Bereich Applications auf New. Sie können auch im Bereich Applications eine vorhandene Application Center-Anwendung aus der Name-Spalte auswählen.

    Das Dialogfeld Create a new application – Web Page Dialog wird angezeigt.

  4. Geben Sie im Feld Name einen Namen für die Application Center-Anwendung ein, und klicken Sie auf OK.

    Der Name der Application Center-Anwendung wird im Bereich Applications in der Name-Spalte angezeigt.

  5. Wählen Sie die gerade erstellte Application Center-Anwendung aus, und wählen Sie im Bereich Contents aus der Liste Resource Type die Option BizTalk aus, um BizTalk-Ressourcen hinzuzufügen. Klicken Sie dann auf Add.

    Das Dialogfeld Add Resource – Web Page Dialog wird angezeigt.

  6. Um alle Ressourcen für einen BizTalk-Ressourcentyp hinzuzufügen, wählen Sie den Ressourcentyp aus, und klicken Sie auf Add. Um einzelne Ressourcen auszuwählen, können Sie auf die hinzuzufügende Ressource (BizTalkCustomCounters, BizTalkPortGroups, BizTalkPorts oder BizTalkReceiveFunctions) doppelklicken.

    Das Dialogfeld Add Resource – Web Page Dialog wird angezeigt.

    Anmerkung

    • Im BizTalk-Messaging-Manager sind die Verteilerlisten mit BizTalkPortGroups-Ressourcentypen identisch.
  7. Wählen Sie die hinzuzufügende Ressource aus, und klicken Sie dann auf Add.

  8. Wiederholen Sie die Schritte 6 bis 7, bis alle gewünschten Ressourcen hinzugefügt sind. Wenn Sie einzelne Ressourcen hinzufügen, klicken Sie auf Close, wenn Sie alle erforderlichen Ressourcen hinzugefügt haben.

  9. Um XLANG-Ablaufpläne hinzuzufügen, wählen Sie im Bereich Contents aus der Liste Resource Type die Option File System Paths aus.

    Das Dialogfeld Add Resource – Web Page Dialog wird angezeigt.

  10. Gehen Sie zum Speicherort der Ablaufplandatei, markieren Sie sie, und klicken Sie auf Add. Wiederholen Sie diesen Vorgang, bis Sie die erforderlichen Ablaufplandateien hinzugefügt haben, und klicken Sie dann auf Close.


Bereitstellen einer ApplicationCenter-Anwendung auf einem Zielserver

BizTalk Server 2002 ~ Anwendungsentwicklung

Bereitstellen einer Application Center-Anwendung auf einem Zielserver

  1. Zeigen Sie im Startmenü auf Programme, dann auf Verwaltung, und klicken Sie anschließend auf Application Center.

    Microsoft Application Center 2000 wird geöffnet.

  2. Erweitern Sie Application Center, klicken Sie mit der rechten Maustaste auf den Cluster, der die bereitzustellende Application Center-Anwendung enthält, und klicken Sie dann auf New Deployment.

    Der New Deployment Wizard wird geöffnet.

  3. Klicken Sie auf Next.

  4. Geben Sie auf der Seite Deployment Target Options im Feld Deployment name einen Namen ein, oder übernehmen Sie den Standardnamen.

  5. Wählen Sie Deploy content outside the current cluster aus, und klicken Sie auf Next.

  6. Geben Sie auf der Seite Deployment Target Authentication in den Feldern User name, Password und Domain die entsprechenden Anmeldeinformationen ein, und klicken Sie auf Next.

  7. Geben Sie auf der Seite Deployment Target im Feld Target den Namen des Computers ein, auf dem Sie die Application Center-Anwendung bereitstellen möchten, oder klicken Sie auf Browse, um den entsprechenden Speicherort zu suchen.

    Anmerkung

    • BizTalk-Ressourcen müssen nur auf dem Application Center-Controller bereitgestellt werden.
  8. Klicken Sie auf Add.

  9. Wählen Sie auf der Seite Deployment Content entweder Deploy all applications and related cluster configurations oder Deploy one or more applications aus.

    Wenn Sie die Option Deploy one or more applications auswählen, wählen Sie die Application Center-Anwendung(en) aus der Liste aus, die bereitgestellt werden soll(en). Um mehrere Elemente auszuwählen, halten Sie die STRG-TASTE gedrückt, und klicken Sie dann auf die einzelnen Elemente.

  10. Klicken Sie auf Next.

  11. Aktivieren Sie auf der Seite Deployment Options das entsprechende Kontrollkästchen. Deaktivieren Sie bei Bedarf das Kontrollkästchen Deploy folder and file permissions (NTFS only).

  12. Klicken Sie auf Next.

  13. Klicken Sie auf der Seite Completing the New Deployment Wizard auf Finish.

Wichtig

  • Wenn Sie Empfangsfunktionen replizieren, die für die Verwendung eines Benutzernamens und eines Kennwortes konfiguriert sind, wird die Empfangsfunktion wegen eines nicht vorhandenen Kennwortes deaktiviert. Kennwörter müssen erneut eingegeben werden, da der BizTalk Server-Replikationstreiber Kennwörter aus Sicherheitsgründen nicht repliziert. Zur Lösung dieses Problems müssen Sie für jede Empfangsfunktion die Eigenschaftenseite anzeigen, das Kennwort erneut eingeben und dann die Empfangsfunktion aktivieren.


Löschen von BizTalk-Ressourcen von einem Zielserver

Wenn Sie bereits eine Application Center-Anwendung auf einem Zielserver bereitgestellt haben und Ressourcen löschen möchten, die mit dieser Application Center-Anwendung verbunden sind, gehen Sie folgendermaßen vor:

  1. Fügen Sie die einzelne Ressource hinzu, die Sie auf dem Computer löschen möchten, auf dem Sie die Bereitstellung ausführen möchten, und stellen Sie dann die Anwendung bereit. Weitere Informationen finden Sie unter Bereitstellen einer Application Center-Anwendung auf einem Zielserver.

  2. Löschen Sie die BizTalk-Ressourcen von dem Computer, den Sie zum Bereitstellen der Application Center-Anwendung verwendet haben. In der folgenden Tabelle wird erläutert, wie Sie bestimmte Ressourcen löschen können.
    Zu entfernendes Element | Verwendetes Element | Weitere Informationen
    BizTalkPortGroups-Ressourcen (auch als Verteilerlisten bezeichnet) | BizTalk-Messaging-Manager oder das BizTalk-Messaging-Konfigurationsobjektmodell (auf das mithilfe von Microsoft Visual Basic Scripting Edition (VBScript) zugegriffen werden kann) | Weitere Informationen finden Sie unter Löschen von Verteilerlisten.
    BizTalkPorts-Ressourcen | BizTalk-Messaging-Manager oder das BizTalk-Messaging-Konfigurationsobjektmodell (auf das mithilfe von VBScript zugegriffen werden kann) | Weitere Informationen finden Sie unter Löschen von Messagingports.
    BizTalkReceiveFunctions-Ressourcen | BizTalk Server-Verwaltung oder der WMI-Provider (Windows Management Instrumentation) von BizTalk Server (auf den mithilfe von VBScript zugegriffen werden kann) | Weitere Informationen finden Sie unter Löschen einer Empfangsfunktion.
    Ablaufplandatei-Ressourcen | Windows Explorer | Weitere Informationen finden Sie in der Hilfe zu Windows 2000.
    BizTalkCustomCounters-Ressourcen | BizTalk Server-Verwaltung oder der WMI-Provider von BizTalk Server | Keine

  3. Stellen Sie die Application Center-Anwendung erneut mit der Ressource bereit, die Sie von dem Computer entfernen möchten, auf dem Sie die Anwendung bereitstellen. Weitere Informationen finden Sie unter Bereitstellen einer Application Center-Anwendung auf einem Zielserver.


Problembehandlung - BizTalkServer-Bereitstellung

BizTalk Server 2002 ~ Anwendungsentwicklung

Problembehandlung – BizTalk Server-Bereitstellung

In diesem Abschnitt sind Informationen zusammengestellt, die mit der Problembehandlung bei der Bereitstellung von Microsoft Application Center 2000-Anwendungen mit BizTalk-Ressourcen verbunden sind. Wenn bei der Bereitstellung einer Application Center-Anwendung Probleme auftreten, können Sie in diesem Abschnitt nach einem Lösungsvorschlag suchen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Bereitgestellte Application Center-Anwendungen erfordern aktualisierte Ressourcen

  • Gemäß einer angezeigten Fehlermeldung sind Anmeldeinformationen mit Administratorrechten erforderlich


Bereitgestellte ApplicationCenter-Anwendungen erfordern aktualisierte Ressourcen

BizTalk Server 2002 ~ Anwendungsentwicklung

Bereitgestellte Application Center-Anwendungen erfordern aktualisierte Ressourcen

Ursache: Der URL für den Verweis auf das WebDAV-Repository (Web Distributed Authoring and Versioning) oder der Dateiname wurden für ein BizTalk-Dokument geändert, das als Teil einer Application Center-Anwendung bereitgestellt wurde (siehe im BizTalk-Messaging-Manager die Registerkarte Neue Dokumentdefinition).

Lösung: Löschen Sie die Ressourcen vom Zielcomputer, und stellen Sie die Application Center-Anwendung erneut bereit. Führen Sie hierzu folgende Schritte durch:

  1. Löschen Sie die Ressourcen von dem Computer, den Sie zum Bereitstellen der Application Center-Anwendung verwendet haben. In der folgenden Tabelle wird erläutert, wie Sie bestimmte Ressourcen löschen.
    Zu entfernendes Element | Verwendetes Element | Weitere Informationen
    BizTalkPortGroups-Ressourcen (auch als Verteilerlisten bezeichnet) | BizTalk-Messaging-Manager oder das BizTalk-Messaging-Konfigurationsobjektmodell (auf das mithilfe von Microsoft Visual Basic Scripting Edition (VBScript) zugegriffen werden kann) | Weitere Informationen finden Sie unter Löschen von Verteilerlisten.
    BizTalkPorts-Ressourcen | BizTalk-Messaging-Manager oder das BizTalk-Messaging-Konfigurationsobjektmodell (auf das mithilfe von VBScript zugegriffen werden kann) | Weitere Informationen finden Sie unter Löschen von Messagingports.
    BizTalkReceiveFunctions-Ressourcen | BizTalk Server-Verwaltung oder der WMI-Provider (Windows Management Instrumentation) von BizTalk Server (auf den mithilfe von VBScript zugegriffen werden kann) | Weitere Informationen finden Sie unter Löschen einer Empfangsfunktion.
    Ablaufplandatei-Ressourcen | Windows Explorer | Weitere Informationen finden Sie in der Hilfe zu Windows 2000.
    BizTalkCustomCounters-Ressourcen | BizTalk Server-Verwaltung oder der WMI-Provider von BizTalk Server | Keine

  2. Stellen Sie die Application Center-Anwendung erneut bereit. Weitere Informationen finden Sie unter Bereitstellen einer Anwendung auf einem Zielserver.

  3. Ändern Sie den URL für den Verweis auf das WebDAV-Repository oder den Dateinamen für das Dokument.

  4. Erstellen Sie einen Port und Kanal für das Dokument. Weitere Informationen finden Sie unter Erstellen von Messagingports und Erstellen von Kanälen.

  5. Stellen Sie die Application Center-Anwendung mit dem geänderten Dokument erneut bereit. Weitere Informationen finden Sie unter Bereitstellen einer Application Center-Anwendung auf einem Zielserver.


Gemäß einer angezeigten Fehlermeldung sind Anmeldeinformationen mit Administratorrechten erforderlich

Ursache: Wenn Sie die Application Center-Anwendung mit BizTalk-Ressourcen auf einem anderen Computer (Zielserver) bereitstellen möchten, wird eine Fehlermeldung angezeigt, dass Anmeldeinformationen mit Administratorrechten erforderlich sind. Die Fehlermeldung wird im Ereignisprotokoll des Controllers im Zielcluster angezeigt.

Lösung: Konfigurieren Sie Administratorrechte für BizTalk Server für den Zielserver, und stellen Sie die Application Center-Anwendung erneut bereit.

Anmerkung

  • Benutzer benötigen keine Administratorrechte für die BizTalk Server-Gruppe Administratoren; sie benötigen jedoch Administratorrechte für den Zielserver.


Entwerfen von BizTalk-Orchestrierungen

Der Microsoft® BizTalk™-Orchestrierungs-Designer ist ein auf Microsoft Visio® 2000 basierendes Entwurfsprogramm, mit dem Sie Geschäftsprozesszeichnungen erstellen können, die als XLANG-Ablaufpläne kompiliert und ausgeführt werden können. XLANG ist eine auf XML basierende Sprache. Ein XLANG-Ablaufplan beschreibt den Geschäftsprozess und die Anbindung des Prozesses an die Anwendungsdienste.

Mithilfe des BizTalk-Orchestrierungs-Designers können Sie Zeichnungen erstellen, die lang dauernde, lose gekoppelte, ausführbare Geschäftsprozesse abbilden. In diesen Zeichnungen werden in der Regel die im Verlauf des angegebenen Prozesses, z. B. einer Auftragsanforderung, durchgeführten Interaktionen und Verfahren beschrieben. Häufig werden diese Geschäftsprozesse nicht durch Zeitbeschränkungen eingeschränkt. Ferner sind die Schritte innerhalb eines Geschäftsprozesses lose gekoppelt. Die Beschreibung des Geschäftsprozesses erfolgt getrennt von der Implementierungslogik und -abfolge bei der Ausführung des Prozesses.

In diesem Abschnitt werden folgende Themen behandelt:

  • Ausführliche Informationen zum BizTalk-Orchestrierungs-Designer finden Sie unter Informationen zum BizTalk Orchestrierungs-Designer.

  • Eine Kurzübersicht darüber, warum bestimmte Aufgaben ausgeführt werden müssen, finden Sie unter Gründe für das durchführen von BizTalk Orchestrierungs-Designer-Aufgaben.

  • Detaillierte Anweisungen zum Ausführen von Aufgaben finden Sie unter Durchführen von BizTalk-Orchestrierungs-Designer-Aufgaben.


Informationen zum BizTalk-Orchestrierungs-Designer

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des BizTalk-Orchestrierungs-Designers sind. Er enthält detaillierte Informationen zu den folgenden Themen:

  • BizTalk-Orchestrierungsdienste

  • Erstellen von XLANG-Ablaufplanzeichnungen

  • Kompilieren von XLANG-Ablaufplänen

  • Debuggen von XLANG-Ablaufplänen

  • Ausführen von XLANG-Ablaufplänen

  • Pooling von XLANG-Ablaufplänen

  • Verwalten des Sitzungsstatus

  • Aktualisieren von XLANG-Ablaufplänen

Anmerkung

  • Es wird dringend empfohlen, dass Sie den Abschnitt Durchführen von BizTalk-Orchestrierungs-Designer-Aufgaben lesen, der aufgabenspezifische Informationen zur Verwendung des BizTalk-Orchestrierungs-Designers enthält.


BizTalk-Orchestrierungsdienste

BizTalk-Orchestrierungsdienste erweitern die Funktionen etablierter Informationsaustauschtechnologien. Benutzer können damit detaillierte Darstellungen von Geschäftsprozessen erstellen, die sich programmgesteuert in einer integrierten Entwurfsumgebung implementieren lassen.

Entwurf und Implementierung von Geschäftsprozessen wurden traditionell in zwei getrennten Phasen ausgeführt: die Phase des visuellen Entwurfs und die Codierungsphase. Die Phase des visuellen Entwurfs bestand gewöhnlich aus der Analyse vorhandener Geschäftsprozesse (z. B. der Unternehmensbeschaffung) und der Erstellung eines Workflowdiagramms oder eines Interaktionsdiagramms zur Veranschaulichung des Prozesses. Die Codierungsphase wurde im Allgemeinen getrennt ausgeführt. Bei diesem Beispiel wird ein abstraktes visuelles Modell eines Geschäftsprozesses geschaffen und das Modell dann einer Implementierungsumgebung zugeordnet.

Zu den wichtigen Features der BizTalk-Orchestrierung gehört die Integration dieser ehemals getrennten Phasen in einer vereinheitlichten Entwurfsumgebung. Diese Entwurfsumgebung stellt eine vielseitige Zeichenoberfläche und umfassende Implementierungstools bereit. Die BizTalk-Orchestrierung bietet folgende Möglichkeiten:

  • Erstellen von XLANG-Ablaufplanzeichnungen zur Beschreibung von Geschäftsprozessen.

  • Implementieren von Geschäftsprozessen durch die Verbindung bestimmter Aktionen innerhalb einer Zeichnung mit Ports, die Standorte darstellen, von denen Nachrichten gesendet oder empfangen werden. Ports sind benannte Standorte, und Nachrichten sind die Daten, die zwischen Aktionen und Ports gesendet bzw. empfangen werden.

  • Definieren des Datenflusses zwischen Nachrichten innerhalb von Geschäftsprozessen.

  • Kompilieren von XLANG-Ablaufplanzeichnungen in XLANG-Ablaufpläne. XLANG-Ablaufpläne sind ausführbare XML (Extensible Markup Language)-Darstellungen der in den Zeichnungen enthaltenen Informationen.

Neben der Integration von Entwurfs- und Implementierungsfunktionen stellt die BizTalk-Orchestrierung eine wichtige zusätzliche Funktion bereit: die Möglichkeit, robuste, langlebige Geschäftsprozesse mit flexiblen Verbindungen zu erstellen, die unternehmens-, plattform- und anwendungsübergreifend sind. Während eines asynchronen, flexibel verbundenen und langlebigen Geschäftsprozesses besteht die Möglichkeit, dass ein über das Internet bestelltes Produkt aus Teilen hergestellt werden muss, die sich im Lager befinden. Einige dieser Teile sind möglicherweise sogar nicht mehr vorrätig. Die Ausführung des gesamten Geschäftsprozesses kann unter Umständen Wochen oder Monate dauern. Im Gegensatz dazu beinhaltet ein eng verbundener Geschäftsprozess den synchronen Austausch von Nachrichten. Wenn ein Kunde beispielsweise Geld von einem Bankkonto abhebt, folgt die Aushändigung des Geldes unmittelbar auf die Belastung des Kontos.

Die BizTalk-Orchestrierung bietet folgende Möglichkeiten:

  • Erstellen einer visuellen Darstellung langlebiger Geschäftsprozesse.

  • Vereinfachen des Nachrichtenaustauschs durch die Verbindung von Aktionen in Ihrer visuellen Darstellung mit Ports, die durch eine bestimmte Technologie implementiert werden.

  • Kompilieren der abgeschlossenen Zeichnung in eine ausführbare XML-Darstellung der Zeichnung.

  • Zuverlässiges Ausführen von Geschäftsprozessen, die Wochen oder Monate dauern können.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu Geschäftsprozessen

  • BizTalk-Orchestrierungs-Designer - Umgebung

  • XLANG-Ablaufpläne

Verwandte Themen

Erstellen von XLANG-Ablaufplanzeichnungen

Grundlegendes zu Geschäftsprozessen


Grundlegendes zu Geschäftsprozessen

Geschäftsprozesse sind für das Unternehmensmanagement ebenso wichtig wie Fließbänder im Herstellungsbereich. Durch das Befolgen genau definierter, formalisierter Prozesse können Unternehmen ihre Produktivität erhöhen und Kosten reduzieren. Ein Geschäftsprozess definiert das Nachrichtenaustauschprotokoll zwischen allen verteilten Teilnehmern. Zum Definieren eines Geschäftsprozesses müssen Sie die logische Reihenfolge von Aktionen sowie den zugehörigen Ablauf von Nachrichten bestimmen. Ein Geschäftsprozess beinhaltet keine Definitionen der verteilten Teilnehmer, die diese Aktionen ausführen.

Die Reihenfolge der Schritte in einem langlebigen Geschäftsprozess ist normalerweise asynchron. Bei jedem Schritt handelt es sich um eine Aktion, die von einem oder mehreren unabhängigen, verteilten Teilnehmern ausgeführt werden kann. Diese Aktionen können das Senden und Empfangen von Nachrichten zwischen Teilnehmern zur Folge haben, die gegebenenfalls gar nicht entsprechende Aufgaben auszuführen haben. Bei einem verteilten Teilnehmer kann es sich um einen automatisierten Prozess handeln, der auf Eingaben reagiert, oder es handelt sich sogar um einen eigenen Geschäftsprozess. Sie müssen in der Lage sein, eine komplexe Vielfalt von Beziehungen und Abhängigkeiten zu visualisieren, um Geschäftsprozesse verstehen zu können. Modellierungstools für Geschäftsprozesse, z. B. Workflowdiagramme und Interaktionsdiagramme, wurden entwickelt, um die Beziehungen visuell zu veranschaulichen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Workflowdiagramme

  • Interaktionsdiagramme


Workflowdiagramme

Ein Workflow ist eine Entwurfstechnologie für Geschäftsprozesse, die Prozeduren innerhalb von Organisationen automatisiert und verbessert. Diese Technologie ist sehr nützlich für die Skizzierung der auszuführenden Schritte, der Abhängigkeiten, die erzwungen werden müssen, und der Zustimmungen, die während der Ausführung des Projekts eingeholt werden müssen. Sie können eine Workflowanwendung verwenden, um Teilnehmern Aufgaben zuzuweisen, individuelle Verantwortlichkeiten zu definieren und um die Beziehungen zwischen den Teilnehmern zu beschreiben. Sie können eine Workflowanwendung auch dazu verwenden, Zeitlimits für die Ausführung von Projekten und das Erreichen von Meilensteinen festzulegen. Die Workflowtechnologie ist jedoch im Allgemeinen stark zentralisiert. Teilnehmern werden Aufgaben zugewiesen und Termine gesetzt, das Workflowmodul ist jedoch verantwortlich für das Routing abgeschlossener Arbeitsobjekte von einem Teilnehmer zum nächsten sowie für das Erzwingen eines Ablaufplanes. Die BizTalk-Orchestrierung hingegen deckt einen größeren Bereich ab. Die Teilnehmer sind autonom, und die Verantwortung für das Routing eines Arbeitsobjekts von einem Teilnehmer zum anderen wird von den Teilnehmern und nicht von einer zentralisierten Anwendung bestimmt.

Verwandte Themen

Interaktionsdiagramme

Grundlegendes zu Geschäftsprozessen


Interaktionsdiagramme

Ein Interaktionsdiagramm beschreibt den Datenfluss innerhalb eines Geschäftsprozesses sowie die ausgetauschten Nachrichten. Die BizTalk-Orchestrierung erweitert das Konzept des Interaktionsdiagramms durch die Bereitstellung von Definitionen und Kontrolle für Entscheidungen, parallele Aktionen, Transaktionen und unterstützende Aktionen, die nicht in ein Interaktionsdiagramm aufgenommen werden können. Der Entwurf eines Geschäftsprozesses mithilfe der BizTalk-Orchestrierung führt zu einem kompilierten, ausführbaren Geschäftsprozess (einem XLANG-Ablaufplan). Im Gegensatz dazu sind Interaktionsdiagramme statische Darstellungen von Geschäftsprozessen.

Die folgende Abbildung zeigt ein typisches Interaktionsdiagramm für ein automatisiertes Beschaffungssystem.

Verwandte Themen

Grundlegendes zu Geschäftsprozessen

Workflowdiagramme


BizTalk-Orchestrierungs-Designer - Umgebung

Mit dem BizTalk-Orchestrierungs-Designer können Sie XLANG-Ablaufplanzeichnungen erstellen. Eine XLANG-Ablaufplanzeichnung ist eine Darstellung eines Geschäftsprozesses. Die Zeichnung wird als SKV-Datei gespeichert. Dabei handelt es sich um eine angepasste Version des Microsoft Visio 2000-Dateiformats. Die XLANG-Ablaufplanzeichnung kann dann in einen XLANG-Ablaufplan kompiliert werden. Dabei handelt es sich um eine XML-strukturierte SKX-Textdatei, die vom XLANG-Ablaufplanungsmodul verstanden wird. Mit dem BizTalk-Orchestrierungs-Designer können Sie XLANG-Ablaufplanzeichnungen erstellen, die Folgendes beinhalten:

  • Die visuelle Beschreibung eines Geschäftsprozesses. Dieser Aspekt einer XLANG-Ablaufplanzeichnung entspricht einem Workflowdiagramm oder einem Interaktionsdiagramm.

  • Eine visuelle Darstellung konfigurierbarer Ports. Dabei handelt es sich um den Implementierungsaspekt einer XLANG-Ablaufplanzeichnung.

  • Die visuelle Darstellung der Verbindungen zwischen Formen. Flussdiagrammformen können verbunden werden, um den Prozessablauf in einem Geschäftsprozess darzustellen, und Aktionen können mit Ports verbunden werden, um den Kommunikationsfluss in einem Geschäftsprozess darzustellen.

  • Die visuelle Darstellung des Flusses zwischen bestimmten Nachrichtenfeldern. Dieser Aspekt einer XLANG-Ablaufplanzeichnung bestimmt die Beziehung zwischen einem Nachrichtenfeld in einer Nachricht und einem weiteren Nachrichtenfeld in einer anderen Nachricht. Durch das Korrelieren dieser Beziehungen können Sie datengesteuertes Routing aktivieren.

Eine XLANG-Ablaufplanzeichnung ist eine Darstellung der Prozeduren, die während eines Geschäftsprozesses ausgeführt werden. Eine XLANG-Ablaufplanzeichnung kann Folgendes definieren:

  • Das Nachrichtenaustauschprotokoll, auf das sich die Handelspartner einigen.

  • Aktionen, die zum Senden oder Empfangen von Nachrichten verwendet werden, in denen die logische Reihenfolge von Aktionen beschrieben wird.

  • Die Implementierung von Ports sowie der Aktionen, mit denen diese verknüpft sind.

  • Der Datenfluss zwischen Nachrichtenfeldern.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Entwurfsseiten

  • Flussdiagrammformen

  • Implementierungsformen

  • Kommunikationsformen

  • BizTalk-Orchestrierungs-Designer - Tastenkombinationen


Entwurfsseiten

Im BizTalk-Orchestrierungs-Designer stehen vier Entwurfsseiten zur Verfügung. Sie können diese Entwurfsseiten verwenden, um verschiedene Aspekte Ihrer XLANG-Ablaufplanzeichnung zu erstellen.

  • Geschäftsprozessseite. Auf dieser Seite können Sie Flussdiagrammformen und Implementierungsformen verwenden, um einen Geschäftsprozess zu definieren. Weitere Informationen zur Verwendung dieser Formen finden Sie unter Flussdiagrammformen.

  • Datenseite. Auf dieser Seite können Sie Kommunikationsformen verwenden, um den Datenfluss zwischen Nachrichtenfeldern zu steuern. Der BizTalk-Orchestrierungs-Designer stellt diese Formen automatisch bereit. Weitere Informationen zur Verwendung dieser Formen finden Sie unter Kommunikationsformen.

  • Seite "Bei Fehler von Transaktion". Auf dieser Seite können Sie die Flussdiagramm- und Implementierungsformen verwenden, um einen alternativen Geschäftsprozess für eine fehlgeschlagene Transaktion zu entwerfen.

  • Seite "Kompensierung für Transaktion". Auf dieser Seite können Sie die Flussdiagramm- und Implementierungsformen verwenden, um einen Prozess für das Rückgängigmachen des Commits für eine geschachtelte Transaktion zu entwerfen. Weitere Informationen zu Transaktionen finden Sie unter Entwerfen von Transaktionen.

Verwandtes Thema

Behandeln von Ausnahmen


Flussdiagrammformen

Der BizTalk-Orchestrierungs-Designer stellt über die Flussdiagrammschablone acht Flussdiagrammformen bereit. Diese Formen werden verwendet, um Ihren Geschäftsprozess zu beschreiben. Mit den acht Formen auf der Flussdiagrammschablone lassen sich die Struktur und die Bedeutung von XLANG-Ablaufplänen beschreiben. XLANG ist eine XML-basierte Sprache zur Beschreibung von Geschäftsprozessinteraktionen.

Die folgende Tabelle enthält eine Liste und Beschreibungen der Flussdiagrammformen.

Name der Form Beschreibung
Beginn

Die Beginn-Form ist auf der Flussdiagrammschablone nicht verfügbar. Sie kann nicht gelöscht werden, und es können keine zusätzlichen Beginn-Formen erstellt werden. Die Beginn-Form stellt den Start einer XLANG-Ablaufplanzeichnung dar. Die Beginn-Form wird automatisch auf allen Geschäftsprozessseiten, sowie auf den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion erstellt. Die auf der Geschäftsprozessseite angezeigte Beginn-Form verfügt über konfigurierbare Eigenschaften. Die Beginn-Formen auf den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion besitzen keine konfigurierbaren Eigenschaften. Sie können keine Beginn-Form in eine Transaktion einschließen. Der Geschäftsprozess muss dem Ablauf von der Beginn-Form zur ersten Flussdiagrammform in der Zeichnung folgen.
Aktion

Die Aktion-Form stellt einen Prozess dar, der eine Nachricht von einem Port empfängt oder an einen Port sendet. Die Aktionen Sende oder Empfang können synchron oder asynchron sein, abhängig von der Komponente bzw. Implementierung, an die der Port gebunden ist.
Entscheidung

Die Entscheidung-Form stellt einen Prozess dar, der eine oder mehrere Regeln nacheinander auswertet.

Diese Form besitzt einen eingehenden Ablauf und einen oder mehrere ausgehende Abläufe. Jeder ausgehende Ablauf ist einer Regel zugeordnet, die auf den Wert TRUE oder FALSE auswertet. Die erste Regel, für die TRUE ausgewertet wird, bestimmt, welcher ausgehende Ablauf im Geschäftsprozess verfolgt wird. Der Geschäftsprozess folgt der ersten Regel, für die TRUE ausgewertet wird. Wenn für keine Regel TRUE ausgewertet wird, wird der Else-Ablauf verfolgt.

Die Entscheidung-Form muss mindestens eine Regel enthalten. Jede Regel muss einen Skriptausdruck enthalten.
While

Die While-Form enthält eine Regel und stellt einen Prozess dar, der wiederholt werden kann. Wenn für die Regel TRUE ausgewertet wird, wird der Ablauf der Regel bis zum Ende verfolgt und dieser dann wiederholt. Wenn für die Regel FALSE ausgewertet wird, wird der Continue-Ablauf verfolgt. Wenn der Geschäftsprozess dem Ablauf einer Regel in einer While-Form folgt, muss der Ablauf mit einer einzelnen Ende-Form abgeschlossen werden.

Für eine While-Schleife können Sie auch die Beibehaltung eines Status konfigurieren. Klicken Sie mit der rechten Maustaste auf eine While-Form, und klicken Sie dann auf Eigenschaften, um das Dialogfeld While-Eigenschaften anzuzeigen. Im Bereich Statuspersistenz können Sie Ja auswählen, um die Nachrichten, die bei jedem Schleifendurchlauf verwendet werden, als XLANG-Ablaufplanstatus zu speichern. Wenn die While-Schleife Teil einer Transaktion ist, die fehlschlägt, wird für jeden vollständig ausgeführten Schleifendurchlauf die Seite Bei Fehler von Transaktion oder Kompensierung für Transaktion aufgerufen. Wenn Sie Nein auswählen, werden nur Nachrichten, die im letzten Schleifendurchlauf verwendet wurden, als XLANG-Ablaufplanstatus gespeichert. Wenn die While-Schleife Teil einer Transaktion ist, die fehlschlägt, wird die Seite Bei Fehler von Transaktion oder Kompensierung für Transaktion nur einmal aufgerufen.

Wenn ein Geschäftsprozess dem Ablauf zu einer While-Form in einer geschachtelten Transaktion folgt, die fehlschlägt, stehen die Nachrichten und Ports, die auf der Seite Bei Fehler von Transaktion bzw. Kompensierung für Transaktion für die geschachtelte Transaktion erstellt wurden, der Seite Bei Fehler von Transaktion für die äußere Transaktion nicht zur Verfügung. Entwerfen Sie den Fehler- bzw. Kompensierungscode so, dass die gesammelten Nachrichten normal aus der geschachtelten Transaktion führen.
Verzweigung

Die Verzweigung-Form verwendet erstmals Parallelität für einen Geschäftsprozess. Ein Ablauf kann in eine Verzweigung eintreten, und bis zu 64 Abläufe können eine Verzweigung verlassen. Alle Abläufe, die eine Verzweigung verlassen, werden parallel (gleichzeitig) ausgeführt. Alle Geschäftsprozesse, die aus einer einzelnen Verzweigung-Form führen, müssen eine Verbindung zu einer einzelnen Verknüpfung-Form herstellen oder in einer Ende-Form enden.
Verknüpfung

Die Verknüpfung-Form synchronisiert parallele Abläufe in einem Geschäftsprozess. Bis zu 64 Abläufe können in eine Verknüpfung-Form eintreten, und nur ein Ablauf verlässt eine Verknüfung-Form. Mithilfe der logischen Operatoren AND und OR wird festgelegt, wie die Abläufe synchronisiert werden. Sie können die folgenden Verknüpfungseigenschaften festlegen:
  • OR. Der erste eintreffende Ablauf kann fortfahren. Die anderen Abläufe werden weiter ausgeführt.

  • AND. Synchronisiert alle eingehenden Abläufe, bevor der ausgehende Ablauf fortfahren kann.
Transaktion

Die Transaktion-Form stellt eine Auflistung von Aktionen dar, die entweder alle oder gar nicht ausgeführt werden. Es gibt drei Arten von Transaktionen:
  • Kurzlebige Transaktionen

  • Langlebige Transaktionen

  • Befristete, langlebige Transaktionen

Transaktionen werden verwendet, um eine Anwendung zuverlässiger zu machen und die Fehlerbehandlung bei großen Anwendungen zu vereinfachen.

Die Transaktion-Form ist auf einen eingehenden Pfad und einen ausgehenden Pfad beschränkt. Die Transaktion-Form kann keine Ende-Formen enthalten. Langlebige Transaktionen können geschachtelte Transaktionen enthalten, kurzlebige Transaktionen jedoch nicht. Transaktionswiederholungsversuche sind nur für kurzlebige Transaktionen zulässig. Wenn Sie einen Teil Ihres Geschäftsprozesses in eine kurzlebige Transaktion-Form einschließen, können Sie die Wiederholungsanzahl-Eigenschaft für die Transaktion konfigurieren. Wenn bei der kurzlebigen Transaktion ein Fehler auftritt, wird diese so häufig wiederholt, wie Sie angegeben haben.

Durch die Definition von Transaktionseigenschaften können Sie die Seite Kompensierung für Transaktion (für geschachtelte Transaktionen) oder die Seite Bei Fehler von Transaktion verfügbar machen. Auf beiden Seiten können Sie die für die Transaktion spezifischen Fehlerbehandlungsprozesse modellieren.

Anmerkung

  • Wenn die Ränder einer inneren Transaktion-Form mit den Rändern der äußeren Transaktion-Form überlappen, wird die innere Transaktion nicht geschachtelt. Verhindern Sie, dass die Ränder einer inneren Transaktion sich mit den Rändern einer äußeren Transaktion überlappen.
Ende

Die Ende-Form stellt den Abschluss eines Prozessablaufs dar. Eine Zeichnung kann mehrere Ende-Formen verwenden, wenn die Zeichnung Entscheidung-, While- und Verzweigung-Formen beinhaltet.
Abbruch

Die Abbruch-Form beendet die Ausführung innerhalb einer Transaktionsgruppe. Dadurch werden die Seiten Bei Fehler von Transaktion oder Kompensierung für Transaktion zur Fehlerbehandlung aktiviert oder der Transaktionsversuch wiederholt.

Anmerkungen

  • Bei den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion wird der Parameter Transaktion durch den Namen ersetzt, den Sie der zugehörigen Transaktion auf der Geschäftsprozessseite gegeben haben.

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Tokenname sein. Weitere Informationen zu XML-Token finden Sie in der W3C-Website (www.w3c.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.
  • Transaktionsnamen mit Zeichen aus einem Ein-Byte-Zeichensatz dürfen maximal 16 Zeichen lang sein. Transaktionsnamen mit Zeichen aus einem Zwei-Byte-Zeichensatz dürfen maximal 8 Zeichen lang sein.

  • Aktionen sind bis auf die Beschränkung der Namenslänge auf 32 Zeichen von allen Namenskonventionen ausgenommen.

  • Die folgenden Formen können nicht umbenannt werden: Abbruch, Beginn, Entscheidung, Ende, Verzweigung, Verknüpfung und While.

  • Suchen Sie nach einer WHILE-Schleife nicht nach vorhandenen Nachrichten. Das Testen des Systemfeldes MessageName.[__Exists__] nach einer WHILE-Schleife wird stets auf TRUE ausgewertet, wenn der in der WHILE-Schleife genommene Pfad die Nachricht aufgrund des gewählten Entscheidungszweiges oder eines Transaktionsabbruchs nicht erstellt. Verwenden Sie zum Erkennen des in der WHILE-Schleife gewählten Pfades eine statusbetonte Komponente, und verwenden Sie diese Informationen in der statusbetonten Komponente außerhalb der Schleife, um die Flusssteuerung zu überprüfen.

Verwandte Themen

Kommunikationsformen

Entwerfen von Transaktionen

Implementierungsformen


Implementierungsformen

Der BizTalk-Orchestrierungs-Designer stellt über die Implementierungsschablone vier Implementierungsformen bereit. Mit diesen Formen werden die Implementierungstechnologien beschrieben, die zur Implementierung eines Ports in einem Geschäftsprozess verwendet werden.

Die folgende Tabelle enthält eine Liste und Beschreibungen der Implementierung-Formen.

Name der Form | Beschreibung
COM-Komponente | Die COM-Komponente-Form stellt eine Technologie dar, mit der ein Port mithilfe eines Methodenaufrufs für jede Nachricht implementiert werden kann, die gesendet oder empfangen wird. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für COM-Komponenten auf die rechte Seite der Trennlinie. Weitere Informationen zur COM-Komponentenimplementierung finden Sie unter Verwenden der COM-Komponente-Form.
Skriptkomponente | Mit der Skriptkomponente-Form kann mithilfe eines Methodenaufrufs für jede gesendete oder empfangene Nachricht ein Port implementiert werden. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für Skriptkomponenten auf die rechte Seite der Trennlinie. Weitere Informationen zur Skriptkomponentenimplementierung finden Sie unter Verwenden der Skriptkomponente-Form.
Message Queuing | Mit der Message Queuing-Form kann ein Port implementiert werden. Message Queuing-Dienste dienen zum Senden oder Empfangen von Nachrichten. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für Message Queuing auf die rechte Seite der Trennlinie. Weitere Informationen zur Message Queuing-Implementierung finden Sie unter Verwenden der Message Queuing-Form.
BizTalk-Messaging | Mit der BizTalk-Messaging-Form kann ein Port implementiert werden. BizTalk-Messaging-Dienste dienen zum Senden oder Empfangen von Nachrichten. Ziehen Sie die Form zum Öffnen des BizTalk-Bindungs-Assistenten für Messaging auf die rechte Seite der Trennlinie. Weitere Informationen zur BizTalk-Messagingimplementierung finden Sie unter Verwenden der BizTalk-Messaging-Form.

Anmerkung

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Folgende Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Tokenname sein. Weitere Informationen zu XML-Token finden Sie in der W3C-Website (www.w3c.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.

Verwandte Themen

Kommunikationsformen

Flussdiagrammformen


Kommunikationsformen

Der BizTalk-Orchestrierungs-Designer stellt mehrere Kommunikationsformen bereit, die die Richtung des Datenflusses in und aus Nachrichten anzeigen. Der BizTalk-Orchestrierungs-Designer stellt die Kommunikationsformen automatisch bereit.

Die Formen Port References, Constants und Message befinden sich auf der Datenseite. Die Datenseite stellt den Datenfluss zwischen Nachrichten dar, die von der XLANG-Ablaufplaninstanz bei der Ausführung der Instanz verwendet werden. Zum Entwerfen des Datenflusses können Sie Verbindungen zwischen den Feldern innerhalb der Formen auf der Datenseite erstellen.

Die folgende Tabelle enthält eine Liste und Beschreibungen der Kommunikationsformen.

Name der Form | Beschreibung
Port | Ports sind benannte Standorte, an denen Nachrichten gesendet oder empfangen werden. Klicken Sie mit der rechten Maustaste auf die Trennlinie, und klicken Sie dann auf Neuen Port hinzufügen, um einen ungebundenen Port hinzuzufügen. Um einen gebundenen Port hinzuzufügen, ziehen Sie eine Implementierungsform auf die rechte Seite der Trennlinie. Jeder Port enthält Nachrichten, die mit den auf der Datenseite angezeigten Nachrichtenformen übereinstimmen. Eine Nachricht stellt die von einer Aktion gesendeten bzw. empfangenen Daten dar. Die Daten in einer Nachricht werden auf der Datenseite in eine Liste von Feldern aufgeteilt.
Port References | Die Nachricht Port References enthält eine Liste aller Ports, die auf der Geschäftsprozessseite erstellt werden. Sobald ein neuer Port auf der Geschäftsprozessseite hinzugefügt wird, wird ein neuer Verweis zu dieser Liste hinzugefügt. Mit der Nachricht Port References können Sie den Ursprung von Portstandorten angeben. Die Nachricht Port References enthält ein Portfeld für jeden Port im Geschäftsprozess.
Constants | Mit der Nachricht Constants können Sie den XLANG-Ablaufplan mit Daten initialisieren. Doppelklicken Sie auf die Nachricht Constants, um eine Konstante zur Nachricht Konstanten hinzuzufügen, oder doppelklicken Sie auf ein Feld in der Nachricht Constants , um das Dialogfeld Eigenschaften der Nachricht Constants zu öffnen.
Message | Nachrichtenformen enthalten eine Liste von Feldern mit Informationen zu den in der Nachricht gesendeten oder empfangenen Daten.

Anmerkung

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Folgende Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Tokenname sein. Weitere Informationen zu XML-Token finden Sie in der W3C-Website (www.w3c.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.

    • Nachrichtennamen können keine Systemfeldnamen sein. Systemfelder sind in der folgenden Tabelle aufgelistet.

Jede auf der Datenseite definierte Nachricht verfügt über zusätzliche Systemfelder, die vom XLANG-Ablaufplanungsmodul automatisch für jede Nachricht erstellt und beibehalten werden. Auf diese Felder kann verwiesen werden, um beschreibende Informationen zur Nachricht zu erhalten, und sie können in Skriptausdrücken für Regeln verwendet werden. Die folgende Tabelle enthält eine Zusammenfassung der Systemfelder, die automatisch erstellt werden.

Systemfeld Beschreibung
__Exists__ Mit diesem Feld lässt sich das Vorhandensein einer Nachricht testen. Das Vorhandensein einer Nachricht wird davon bestimmt, ob die Nachricht vom XLANG-Ablaufplanungsmodul empfangen oder gesendet wurde.

Dieses Feld wird nicht innerhalb der Nachrichten auf der Datenseite angezeigt. Es wird nur mit den Formen Entscheidung und While verwendet.
__Sender__ Dieses Feld enthält gegebenenfalls die Identität des Nachrichtenabsenders.

Dieses Feld wird innerhalb der Nachrichten auf der Datenseite angezeigt.
__Status__ Dieses Feld enthält den Status, der von einem COM-Methodenaufruf an einem Port zurückgegeben wird, der an eine COM-Komponente gebunden ist. Dieses Feld wird innerhalb der Nachrichten auf der Datenseite angezeigt.

Anmerkungen

  • Dieses Systemfeld wird nur mit Implementierungen der COM-Komponenten und Skriptkomponenten verwendet.

  • Der zurückgegebene Status ist stets ein HRESULT.
Document Dieses Feld enthält eine Zeichenfolge mit dem Nachrichtentext, der gesendet bzw. empfangen wird. Es verweist stets auf eine XML-Nachricht.

Anmerkung

  • Dieses Systemfeld wird nur mit Message Queuing- und BizTalk-Messaging-Implementierungen verwendet.

Wichtig

  • Jede Nachricht, die von einer XLANG-Ablaufplaninstanz gesendet wird, muss über eine definierte Quelle für jedes Datenfeld verfügen. Zur Definition der Quelle eines Datenfeldes muss eine Verbindung aus einem anderen Feld in einer anderen Nachricht oder aus einer Konstante auf das Feld zeigen.

Anmerkung

  • Das Kompilierungsmodul, das zum Erstellen eines XLANG-Ablaufplanes verwendet wird, überprüft, ob alle Nur-Eingabe-Felder einer Nachricht definiert sind. Wenn die Nur-Eingabe-Felder teilweise definiert sind, wird der Ablaufplan nicht kompiliert. Die Argumente für eine Methode können auf Eingabe, Ausgabe oder beides lauten. Das Kompilierungsmodul ignoriert die Definitionsanforderung für Argumente, die als Eingabe und Ausgabe definiert sind. Wenn keine eingehenden Verbindungen für Eingabe-Ausgabe-Felder definiert sind, wird der Ablaufplan kompiliert, auch wenn die Nachricht keine Definition für die Daten enthält.

Verwandte Themen

Datenverarbeitung

Flussdiagrammformen

Implementierungsformen


BizTalk-Orchestrierungs-Designer - Tastenkombinationen

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

BizTalk-Orchestrierungs-Designer – Tastenkombinationen

Für die Ausführung von Tasks im BizTalk-Orchestrierungs-Designer können Sie Tastenkombinationen verwenden. Die folgende Tabelle ist eine kurze Referenz zu diesen Tastenkombinationen.

Anmerkung

  • Um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind, können Sie mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server- und Advanced Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Tastenkombination | Zweck
ALT oder F10 | Menüleiste aktivieren.
ALT+F4 | Aktives Element schließen oder Programm beenden.
Alt+F7 | Fenster überlappen.
ALT+LEER | Systemmenü für das aktive Element anzeigen.
ALT+Unterstrichener Buchstabe in einem Menünamen | Entsprechendes Menü anzeigen.
Pfeiltasten | Ausgewählte Form in Pfeilrichtung verschieben.
STRG beim Ziehen eines Elements | Ausgewähltes Element kopieren.
STRG+A | Alles markieren.
STRG+C | Ausgewähltes Element auf der Entwurfsseite kopieren.
STRG+F4 | Aktive Zeichnung schließen.
STRG+I | Fenster in Originalgröße anzeigen.
STRG+N | Neue Zeichnung.
STRG+O | Vorhandene Zeichnung öffnen.
STRG+P | Dialogfeld Drucken öffnen.
STRG+Q | Programm beenden.
STRG+UMSCHALT zusammen mit einer der Pfeiltasten | Bildlauf durchführen.
STRG+UMSCHALT, dann Mausklick links | Vergrößern.
STRG+UMSCHALT, dann Mausklick rechts | Verkleinern.
STRG+UMSCHALT+TAB | Zwischen den Registerkarten eines Dialogfeldes von hinten nach vorn umschalten.
STRG+TAB | Zwischen den Registerkarten eines Dialogfeldes von vorn nach hinten umschalten.
STRG+V | Ausgewähltes Element auf der Entwurfsseite einfügen.
STRG+X | Ausgewähltes Element auf der Entwurfsseite ausschneiden.
STRG+Y | Wiederholen.
STRG+Z | Rückgängig machen.
ENTF | Ausgewähltes Element auf der Entwurfsseite löschen.
ESC | Aktuellen Vorgang abbrechen.
F1 | Onlinehilfe anzeigen.
F11 | Dialogfeld Zeichen anzeigen.
F8 | Ausgewählte Formen ausrichten.
NACH-LINKS-TASTE | Fokus nach links wechseln, wenn der Fokus sich auf einer Registerkarte in einem Dialogfeld befindet.
NACH-RECHTS-TASTE | Fokus nach rechts wechseln, wenn der Fokus sich auf einer Registerkarte in einem Dialogfeld befindet.
UMSCHALTTASTE beim Ziehen eines Elements | Element nur in einer geradlinigen horizontalen oder vertikalen Richtung ziehen.
UMSCHALT+TAB | Fokus gegen den Uhrzeigersinn im unteren Fenster von der Registerkarte zu den Fenstern oder Feldern darunter verschieben.
LEERTASTE | Aktivieren oder Deaktivieren eines Kontrollkästchens.
TAB | Fokus im Uhrzeigersinn im unteren Fenster von der Registerkarte zu den Fenstern oder Feldern darunter verschieben.
Unterstrichener Buchstabe eines Befehlsnamens in einem geöffneten Menü | Entsprechenden Befehl ausführen.


XLANG-Ablaufpläne

Die kompilierte Version einer XLANG-Ablaufplanzeichnung ist ein XLANG-Ablaufplan, und das XLANG-Ablaufplanungsmodul führt diesen Ablaufplan aus. Das XLANG-Ablaufplanungsmodul überwacht und steuert den im XLANG-Ablaufplan beschriebenen Geschäftsprozess auf der Grundlage der für den XLANG-Ablaufplan definierten Aktionen, Regeln und Fehlerbehandlungsprozesse.

Folgende Themen werden in diesem Abschnitt behandelt:

  • XLANG-Übersicht

  • Instanzenverwaltung

  • Persistenz

  • Pausierung und Aktivierung

  • Datenverarbeitung


XLANG-Übersicht

XLANG ist eine XML-basierte Sprache zur Beschreibung von Geschäftsprozessinteraktionen. Der BizTalk-Orchestrierungs-Designer kann XLANG-Ablaufplanzeichnungen in XLM-strukturierte XLANG-Ablaufplandateien kompilieren. Da XLANG XML-basiert ist, müssen XLANG-Ablaufpläne XML-Regeln für wohlgeformte Dokumente sowie einer Spezifikation oder einem Standardschema entsprechen.


Instanzenverwaltung

Sie sollten den Unterschied zwischen einer abstrakten Definition eines Geschäftsprozesses und mehreren aktiven Instanzen eines Geschäftsprozesses kennen, um die Instanzenverwaltung durch das XLANG-Ablaufplanungsmodul zu verstehen. Im BizTalk-Orchestrierungs-Designer können Sie eine Geschäftsprozessdefinition entwerfen und diese als XLANG-Ablaufplanzeichnung (eine SKV-Datei) speichern. Wenn Sie eine XLANG-Ablaufplanzeichnung erstellt haben, kompilieren Sie diese in einen XLANG-Ablaufplan (eine SKX-Datei). Wenn Sie den XLANG-Ablaufplan bereitstellen, werden wahrscheinlich mehrere Instanzen des Ablaufplanes gleichzeitig ausgeführt. Jede XLANG-Ablaufplaninstanz kann eine von der Lebensspanne der anderen Instanzen unabhängige Lebensspanne besitzen. Wenn Sie eine Anwendung zur Unterstützung mehrerer XLANG-Ablaufplaninstanzen entwerfen, sollten Sie Folgendes beachten:

  • Aktivieren neuer Instanzen von XLANG-Ablaufplänen beim Empfang von Nachrichten. Sie können Ihre Anwendung so entwerfen, dass eine neue XLANG-Ablaufplaninstanz durch die GetObject-COM-Funktion aktiviert wird, sobald eine Nachricht empfangen wird. Wenn Sie beispielsweise eine Active Server Page (ASP) verwenden, um eine Nachricht mit einem Auftrag oder einer Kundendienstanfrage zu empfangen, muss die ASP die GetObject-COM-Funktion verwenden, um einen XLANG-Ablaufplan zu aktivieren.

    Sie können auch den BizTalk-Bindungs-Assistenten für Messaging verwenden, um eine Portbindung zu erstellen, die als benannter Standort dienen kann, an den Nachrichten gesendet werden. BizTalk Server 2002 stellt einen automatisierten Mechanismus zur Aktivierung einer Instanz eines XLANG-Ablaufplanes bereit, wenn ein an BizTalk-Messaging gebundener Port eine Nachricht empfängt. Auf der Seite Informationen über die XLANG-Ablaufplanaktivierung des BizTalk-Bindungs-Assistenten für Messaging werden Sie aufgefordert zu bestätigen, ob der Kanal in den BizTalk-Messagingdiensten so konfiguriert wurde, dass nach der Aktivierung einer neuen Instanz dieses XLANG-Ablaufplanes eine Nachricht an diesen Port gesendet wird. Zur Ausführung dieses Prozesses müssen Sie den Messagingport-Assistenten im BizTalk-Messaging-Manager ausführen. Geben Sie auf der Seite Zielanwendung des Messagingport-Assitenten den Namen des Ports sowie den Namen und den Standort des XLANG-Ablaufplanes an.

  • Korrelieren von Nachrichten mit XLANG-Ablaufplaninstanzen. Jeder Instanz eines XLANG-Ablaufplane wird durch das XLANG-Ablaufplanungsmodul ein global eindeutiger Bezeichner (GUID) zugewiesen. Diese Instanz-ID kann zum Korrelieren von Nachrichten mit Ablaufplaninstanzen verwendet werden. Für die Korrelation gibt es zwei Möglichkeiten:

    Verwenden einer einzelnen Warteschlange. Sie können eine einzelne Warteschlange für alle Instanzen verwenden, um den Aufwand einer großen Anzahl von instanzbezogenen Warteschlangen zu vermeiden. Verwenden Sie dazu den GUID bzw. die Instanz-ID der Ablaufplaninstanz. Sie müssen die Instanz-ID des Ablaufplanes beim Senden einer Nachricht speichern, beim Empfangen einer Nachricht abrufen und zum Erstellen eines Mechanismus zum Korrelieren der eingehenden Nachricht mit der entsprechenden Ablaufplaninstanz verwenden. Sie haben dazu zwei Möglichkeiten:

    • Identifizieren eines Nachrichtenfeldes, das für die Korrelation verwendet werden kann. Dieses Feld muss garantiert eindeutig sein. Dabei kann es sich um ein spezielle zu diesem Zweck erstelltes Feld oder auch ein bereits im Dokumentformat vorhandenes Feld handeln.

      Zum Senden können Sie die Instanz-ID und den Wert des Korrelationsfeldes speichern. Die Pipelinekomponente kann Src_XLANG_InstanceID aus dem Wörterbuch abrufen und zusammen mit dem Wert des Korrelationsfeldes in einer lokalen Datenbank speichern.

      Zum Empfangen können Sie eine benutzerdefinierte Komponente schreiben, die das Korrelationsfeld aus der eingehenden Nachricht extrahiert, die entsprechende Instanz-ID in der Datenbank findet und den Wert verwendet, um Dest_XLANG_InstanceID im Wörterbuch für die anschließende Übermittlung der Nachricht an die richtige Instanz festzulegen.

    • Verwenden der Instanz-ID als Nachrichtenbezeichnung. Aktivieren Sie dazu das Kontrollkästchen Instanz-ID als Nachrichtenbezeichnung verwenden im Dialogfeld Informationen über den Nachrichtentyp des Assistenten für XML-Kommunikation, wenn Sie Aktionen und Ports binden. Weitere Informationen finden Sie unter Verwenden des Assistenten für XML-Kommunikation.

    Verwenden einer instanzbezogenen Warteschlange. Jeder Port in jeder aktiven Instanz eines XLANG-Ablaufplanes kann eindeutig adressiert werden. Dank dieser Adressierbarkeit können Sie mit bestimmten Ports in bestimmten XLANG-Ablaufplaninstanzen direkt kommunizieren, ohne benutzerdefinierten Code schreiben zu müssen, der die Korrelation für Sie übernimmt. Die erste von einer Ablaufplaninstanz gesendete Nachricht geht wahrscheinlich an einen statischen Port (einen benannten Standort). Wenn der XLANG-Ablaufplan aktiviert ist, sendet diese Instanz die Standorte ihrer dynamischen Ports (eindeutige Standorte auf Instanzebene) an Empfänger, die für die Kommunikation zurück an die Ports verantwortlich sind. Dies entspricht E-Mail-Nachrichten, die mit eindeutigen Antwortadressen gesendet werden. Die folgende Liste beschreibt die dynamische Bindungsunterstützung in den einzelnen BizTalk Server-Bindungstechnologien:

    • Wenn Sie auf der Seite Statische oder dynamische Kommunikation des Bindungs-Assistenten für COM-Komponenten oder für Skriptkomponenten die Option Statisch auswählen, erstellt das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz der Komponente. Wenn Sie Dynamisch auswählen, muss eine andere Anwendung vor der Instanziierung der Komponente einen Schnittstellenzeiger oder Moniker (als Feld in einer Nachricht) senden.

    • Sie können auch die Option Keine Instanziierung auswählen. Weitere Informationen zur Komponenteninstanziierung finden Sie unter Statische und dynamische Ports.

    • Wenn Sie auf der Seite Informationen über statische oder dynamische Warteschlangen des Bindungs-Assistenten für Message Queuing die Option Statische Warteschlange auswählen und auf Weiter klicken, wird die Seite Warteschlangeninformationen aufgerufen. Auf dieser Seite können Sie das Erstellen einer separaten instanzbezogenen Warteschlange für jede XLANG-Ablaufplaninstanz oder auch die Verwendung einer einzelnen Warteschlange für alle aktiven Instanzen festlegen.

    • Wenn Sie auf der Seite Informationen über statische oder dynamische Warteschlangen des Bindungs-Assistenten für Message Queuing die Option Dynamische Warteschlange auswählen, muss eine andere Anwendung vor dem Senden oder Empfangen von Nachrichten über den Port den Namen der Warteschlange (als Feld in einer Nachricht) senden.

    • Auf der Seite Informationen über statische oder dynamische Kanäle des BizTalk-Bindungs-Assistenten für Messaging können Sie wahlweise einen bestimmten Kanalnamen bereitstellen oder angeben, dass die BizTalk-Messagingdienste den richtigen Kanal zur Laufzeit anhand der Portkonfigurationsinformationen identifizieren. Weitere Informationen zum Nachrichtenaustausch finden Sie unter Integrieren der BizTalk-Dienste.
  • Skalieren der Anwendung. Alle XLANG-Ablaufplaninstanzen, die nicht im Speicher vorhanden sein müssen, sollten pausieren. Eine XLANG-Ablaufplaninstanz muss nicht im Speicher vorhanden sein, wenn eine XLANG-Ablaufplaninstanz auf das Eintreffen einer Nachricht wartet.

Anmerkungen

  • Alle Implementierungsformen zeigen einen Schatten an, um darauf hinzuweisen, dass der Standort dynamisch gebunden und zur Laufzeit definiert wird.

  • Jede von einer übergeordneten Instanz verzweigte untergeordnete Instanz besitzt unabhängig von der übergeordneten Instanz eine eigene, eindeutige Instanz-ID. Jede untergeordnete Instanz innerhalb einer WHILE-Schleife besitzt ebenfalls (bei jedem Schleifendurchlauf) eine eigene, eindeutige Instanz-ID.

Verwandte Themen

Datenverarbeitung

Pausierung und Aktivierung

Verwalten des Sitzungsstatus

Persistenz

XLANG Schedule Correlation


Persistenz

Das XLANG-Ablaufplanungsmodul speichert die folgenden Informationen in der Persistenzdatenbank:

  • Die Struktur der XLANG-Ablaufpläne.

  • Den Status aktivierter XLANG-Ablaufplaninstanzen.

  • Nachrichten, die bei der Ausführung einer XLANG-Ablaufplaninstanz gesendet oder empfangen werden.

Durch das persistente Speichern ermöglicht das XLANG-Ablaufplanungsmodul folgende Szenarien:

  • Pausieren und Aktivieren langlebiger Ablaufpläne. Während einer langlebigen Transaktion kann ein Systemfehler auftreten. Sobald das System wieder ausgeführt wird, greift das XLANG-Ablaufplanungsmodul auf die Persistenzdatenbank zurück, um festzustellen, wo der Ablaufplan fortgesetzt werden muss.

  • Wiederherstellen des Status einer Ablaufplaninstanz bei einem Transaktionsfehler. Während einer Transaktion kann ein Systemfehler auftreten, so dass die Transaktion abgebrochen wird. Sobald das System wieder ausgeführt wird, greift das XLANG-Ablaufplanungsmodul auf die Persistenzdatenbank zurück, um festzustellen, wo der Ablaufplan fortgesetzt werden muss.

  • Unterstützung für das Debuggen und Überwachen von aktiven Ablaufplänen. Debug- und Überwachungstools können Abfragen an die Persistenzdatenbank richten, um Informationen zum Status der Ablaufplaninstanzen bereitzustellen.

Die Unterstützung für das persistente Speichern des Status eines XLANG-Ablaufplanes vor dem Start und nach Beenden einer Transaktion sorgt für Beständigkeit und gewährleistet, dass alle Commits für Änderungen im System dauerhaft sind. Dadurch ist es auch möglich, eine Transaktion bei einem Fehler zu wiederholen. Der Status einer aktiven Ablaufplaninstanz wird unter den folgenden Bedingungen persistent gespeichert:

  • Zu Beginn einer Transaktion. Wenn der Geschäftsprozess zum Start einer Transaktion führt, muss die Wiederholungsanzahl der Transaktion in der Persistenzdatenbank aktualisiert werden. So kann das XLANG-Ablaufplanungsmodul die Wiederholungsanzahl überwachen, wenn bei einer Transaktion ein Systemfehler auftritt.

  • Am Ende einer Transaktion. Wenn der Geschäftsprozess aus einer Transaktion heraus führt, muss der Ablaufplanstatus aktualisiert werden, um gegebenenfalls ein Rollback zu ermöglichen. Diese Aktualisierung erfolgt im Rahmen der Transaktion, um eine unteilbare Datenbankpersistenz zu gewährleisten.

Verwandte Themen

Pausierung und Aktivierung

Instanzenverwaltung

Verwalten des Sitzungsstatus


Pausierung und Aktivierung

Wenn mehrere Instanzen eines XLANG-Ablaufplanes über einen langen Zeitraum gleichzeitig ausgeführt werden, ist es häufig unpraktisch, wenn alle Instanzen im Speicher verbleiben können. Das XLANG-Ablaufplanungsmodul stellt eine Pausierungs-/Aktivierungs-Infrastruktur bereit, um dieses Problem zu beheben.

Wenn eine XLANG-Ablaufplaninstanz für einen längeren Zeitraum auf eine Nachricht warten soll und keine andere Aktivität innerhalb des Ablaufplanes erfolgt, kann das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz pausieren lassen. Bei der Pausierung einer XLANG-Ablaufplaninstanz wird jeder instanzenspezifische Status in der Persistenzdatenbank persistent gespeichert und die Instanz aus dem Speicher entfernt. Wenn eine Nachricht bei einer Portadresse für die pausierende XLANG-Ablaufplaninstanz eintrifft, wird die Instanz aktiviert. Bei der Aktivierung einer XLANG-Ablaufplaninstanz wird die Instanz aus der Datenbank im Speicher wiederhergestellt.

Eine XLANG-Ablaufplaninstanz pausiert so lange, bis sie entweder wieder aktiviert oder explizit durch einen Administrator beendet wird. Auf diese Weise kann ein Geschäftsprozess für einen längeren Zeitraum zuverlässig ausgeführt werden.

Das XLANG-Ablaufplanungsmodul kann eine Wartezeiteinstellung verwenden, um die Zeitspanne festzulegen, die eine Aktion inaktiv bleiben kann, bevor die XLANG-Ablaufplaninstanz in der Persistenzdatenbank pausiert. Mit dieser Wartezeiteinstellung kann das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz in der Persistenzdatenbank pausieren und diese später aktivieren, wenn die Nachricht eintrifft. Es gibt jedoch einige Situationen, in denen die Wartezeiteinstellung nicht zum Pausieren eines Ablaufplanes führt:

  • Die Ablaufplaninstanz befindet sich nicht im Ruhezustand. Dies kann vorkommen, wenn für einen der aktuellen Prozessabläufe in der XLANG-Ablaufplaninstanz Aktionen ausgeführt werden. Alle Prozessabläufe in der Ablaufplaninstanz müssen denselben Status besitzen, bevor das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz pausieren lassen kann. Die Wartezeit für alle ausstehenden Aktionen muss einen bestimmten Schwellenwert überschreiten, bevor die Pausierung ausgeführt wird.

  • Es liegen ausstehende Transaktionen im DTC-Stil vor. Das XLANG-Ablaufplanungsmodul nimmt keine Pausierung des Ablaufplanes vor, wenn dieser eine Transaktion im DTC-Stil ausführt, da Transaktionen in diesem Stil normalerweise kurzlebig sind.

  • Die Instanz verfügt über Live-Ports, die nicht persistent gespeichert werden können. Ein Live-Port ist ein Portobjekt oder ein Port, der implementiert wurde und später in der Ablaufinstanz verwendet werden kann. Die Lebensdauer eines Ports ist ein wichtiger Aspekt bei der Ausführung einer Ablaufplaninstanz. Ports sind an Implementierungstechnologien, z. B. COM-Schnittstellen, gebunden. Wenn die Implementierungstechnologie, an die ein Port gebunden ist, nicht persistent gespeichert werden kann, und diese Implementierungstechnologie Statusinformationen beinhaltet, die später wieder verwendet werden, kann die Instanz nicht pausieren und dann wieder aktiviert werden. Wenn es zu einem Fehler in der Persistenzdatenbank kommt und diese später erneut ausgeführt wird, gehen die Statusinformationen verloren, und die Ausführung der Ablaufplaninstanz kann nicht von dem Status aus fortgesetzt werden, in dem die Instanz zuletzt pausiert hat.

Wenn das XLANG-Ablaufplanungsmodul beendet wird, werden so viele Informationen wie möglich in der Persistenzdatenbank gespeichert, einschließlich aller Informationen, die nicht im Kontext zur Transaktion stehen.

Verwandte Themen

Instanzenverwaltung

Verwalten des Sitzungsstatus

Persistenz

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Datenverarbeitung

In XLANG sind alle Daten in einer Gruppe eindeutig benannter Nachrichten enthalten. Wenn eine Nachricht von einer Aktion empfangen wird, gelangen neue Daten in eine XLANG-Ablaufplaninstanz.

Jede XLANG-Ablaufplanzeichnung besitzt eine Datenseite. Auf der Datenseite können Sie den Datenfluss in einem XLANG-Ablaufplan beschreiben. Zeichnen Sie einen Pfeil vom Quellnachrichtenfeld zum Zielnachrichtenfeld, um anzuzeigen, dass Daten in einem Nachrichtenfeld in ein anderes Nachrichtenfeld führen.

Außer der Nachricht Constants enthält keines der Nachrichtenfelder in den Nachrichten auf der Datenseite zu Anfang einen Wert. Die Nachricht Constants wird mit den auf der Datenseite angegebenen Werten initialisiert. Sie wird für jede neue XLANG-Ablaufplaninstanz automatisch initialisiert. Weitere Informationen zur Verwendung von Konstanten finden Sie unter Die Nachricht "Constants".

Die Werte der anderen angezeigten Nachrichten werden festgelegt, wenn die Nachricht in der XLANG-Ablaufplaninstanz gesendet oder empfangen wird. Eine Nachricht kann von mehreren Aktionen empfangen werden. Sobald eine Nachricht empfangen wird, werden die Werte für diese Nachricht überschrieben. Der Datenfluss in die empfangene Nachricht wird nicht verwendet, um die Werte für eine andere empfangene Nachricht festzulegen, auch wenn die Nachricht an einen anderen Punkt im XLANG-Ablaufplan gesendet wird. Exklusiv gesendete Nachrichten verwenden den Datenfluss, der auf der Datenseite angezeigt wird, um ihre Nachrichtenfelder festzulegen. Ein Ablaufplan wird erst dann kompiliert, wenn alle Felder für alle gesendeten Nachrichten festgelegt wurden.

Wenn ein Feld auf der Datenseite aus einem XPath stammt, der auf einen optionalen Knoten im XML-Schema verweist, verwenden Sie die folgenden Richtlinien:

  • Für empfangene Nachrichten, wenn der optionale Knoten existiert. Wenn diese Nachricht empfangen wird und der optionale Knoten im XML-Dokument existiert, speichert das Feld XPath den Knotenwert.

  • Für empfangene Nachrichten, wenn der optionale Knoten nicht existiert. Wenn diese Nachricht empfangen wird und der optionale Knoten nicht existiert, speichert das Feld XPath einen NULL-Wert. Sie müssen eine Entscheidungsregel mit dem Microsoft® Visual Basic® Scripting Edition (VBScript)-Ausdruck IsNull (Message.Field) für dieses Feld verwenden, um festzustellen, ob die empfangene Nachricht den optionalen Knoten enthält. Wenn Sie das Vorhandensein eines Wertes nicht überprüfen und dieses Feld einen Datenfluss in eine andere Nachricht bereitstellt, die gesendet wird, tritt ein Fehler auf, wenn das XLANG-Ablaufplanungsmodul versucht, die zu sendende Nachricht zu erstellen.

  • Für gesendete Nachrichten, wenn der optionale Knoten existiert. Wenn diese Nachricht (mit dem auf einen optionalen XML-Knoten verweisenden XPath-Knoten) gesendet wird, verwendet das XLANG-Ablaufplanungsmodul den Datenfluss, um die Nachricht zu erstellen. Wenn der Knoten im Feld Document der Nachricht vorhanden ist, wird er vom XLANG-Ablaufplanungsmodul mit dem Wert für den XPath überschrieben.

  • Für gesendete Nachrichten, wenn der optionale Knoten nicht existiert. Wenn diese Nachricht (mit dem auf einen optionalen XML-Knoten verweisenden XPath-Knoten) gesendet wird, verwendet das XLANG-Ablaufplanungsmodul den Datenfluss, um die Nachricht zu erstellen. Wenn der Knoten im bereitgestellten Feld Document nicht vorhanden ist, wird der Knoten vom XLANG-Ablaufplanungsmodul nicht erstellt, um überschrieben zu werden. Dies verursacht einen Fehler.

Verwenden Sie für Nachrichten, die von einer Nachrichtenwarteschlange empfangen oder gesendet werden, die folgenden Richtlinien:

  • Für empfangene Nachrichten. Wenn eine Aktion eine nicht auf XML basierende Nachricht von einer Nachrichtenwarteschlange empfangen soll, müssen Sie Nachrichten in der Warteschlange als Zeichenfolgen empfangen auf der Seite Informationen über die XML-Konvertierung des Assistenten für XML-Kommunikation auswählen. In dieser Konfiguration zeigt die Nachrichtenform auf der Datenseite ein neues StringData-Feld an. Dieses StringData-Feld enthält die nicht auf XML basierende Nachricht, die von der Warteschlange empfangen wurde. Das Feld Documents in der Nachricht enthält das StringData-Feld, umgeben von dem Standard-XML-Wrapper des XLANG-Ablaufplanungsmoduls.

  • Für gesendete Nachrichten. Wenn Aktion eine nicht auf XML basierende Nachricht an eine Nachrichtenwarteschlange senden soll, müssen Sie Nachrichten als Zeichenfolge an die Warteschlange senden auf der Seite Informationen über die XML-Konvertierung des Assistenten für XML-Kommunikation auswählen. In dieser Konfiguration zeigt die Nachrichtenform auf der Datenseite ein neues StringData-Feld an. Zur Vervollständigung dieser Konfiguration müssen Sie eine neue Konstante (mit dem Standard-XML-Wrapper des XLANG-Ablaufplanungsmoduls) in der Nachricht Constants auf der Datenseite erstellen. Der Name dieser Konstante ist nicht relevant, der Datentyp muss jedoch string und der Wert folgender sein: <?xml version="1.0" ?> <StringData> </StringData>. Wenn Sie diese neue Konstante erstellt haben , müssen Sie eine Datenflussverbindung von der neuen Konstante in der Nachricht Constants an das Feld Document in der Nachrichtenform zeichnen. Außerdem müssen Sie eine Datenflussverbindung von dem Feld mit der nicht auf XML basierenden Zeichenfolge zum neuen StringData-Feld in der Nachrichtenform zeichnen.

Anmerkungen

  • Die Datenflussrichtung ist unabhängig von der Richtung des Nachrichtenflusses. Der Nachrichtenfluss zeigt an, ob eine Nachricht gesendet oder empfangen wurde.

  • Wenn Sie möchten, dass der XLANG-Ablaufplan Daten mithilfe eines Methodenaufrufs empfangen kann, ohne die Komponente zu instanziieren, wählen Sie Keine Instanziierung auf der Seite Statische oder dynamische Kommunikation des Bindungs-Assistenten für COM- oder für Skriptkomponenten. Wenn Sie Keine Instanziierung auswählen, wird die Komponente nicht instanziiert und kein Code für den Methodenaufruf ausgeführt. Stattdessen gibt der XLANG-Ablaufplan diese Informationen als Antwort zurück, wenn er die Methodenanforderungsinformationen abfängt. Der Methodenaufruf wird umgangen.

  • Wenn eine Nachricht nur innerhalb des Nachrichtentextes einer While-Schleife verwendet wird, werden die Nachrichtenwerte nicht bei jedem Schleifendurchlauf initialisiert. Wenn eine Nachricht innerhalb und außerhalb des Nachrichtentextes einer While-Schleife verwendet wird, werden die Nachrichtenwerte bei jedem Schleifendurchlauf beibehalten. Die Nachrichtenwerte können auch beibehalten werden, bevor der Geschäftsprozess zur While-Form führt sowie danach.

  • Wenn eine Nachricht innerhalb der Prozesse Kompensierung für Transaktion oder Bei Fehler von Transaktion einer While-Schleife initialisiert wird, sind die Nachrichtenwerte außerhalb der Schleife nicht verfügbar.

  • Wenn ein Feld in einer XML-Nachricht (einschließlich der Nachricht Constants) mit dem char-Datentyp den Datenfluss in ein Methodennachrichtenfeld bereitstellt, wird das Feld für die Methode in den integer-Datentyp konvertiert. Wenn das Methodennachrichtenfeld den string-Datentyp besitzt, enthält die Zeichenfolge den ganzzahligen Wert, nicht das Zeichen. Wenn dieses Problem auftreten sollte und das Quellfeld Teil der Nachricht Constants ist, ändern Sie den Datentyp des Konstantenfeldes auf string. Wenn das Quellfeld Teil einer XML-Nachricht ist, müssen Sie eine Komponente verwenden, um den char-Datentyp in den string-Datentyp umzuwandeln.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Die Datenseite

  • Die Nachricht "Constants"

  • Die Nachricht "Port References"

  • Felddatentypen

  • Systemfelder

  • Knotenpfadfelder


Die Datenseite

Jede XLANG-Ablaufplanzeichnung besitzt eine Datenseite. Auf der Datenseite wird Folgendes angezeigt:

  • Eine Nachrichtenform für jede Nachricht im XLANG-Ablaufplan.

  • Eine Nachricht Constants.

  • Eine Nachricht Port References mit einem Portfeld für jeden Port in der XLANG-Ablaufplanzeichnung.

  • Grafische Verbindungen, die den Datenfluss zwischen den Nachrichtenfeldern zeigen.

Nachrichten bestehen aus eindeutig benannten Feldern, die jeweils ein Datenelement eines bestimmten Datentyps enthalten. Jede Nachricht im XLANG-Ablaufplan wird auf der Datenseite als Tabelle angezeigt. Jede Tabelle zeigt den Namen der Nachricht sowie eine Liste der Feldnamen und der entsprechenden Datentypen an. Systemfelder, die keinen Datenfluss erfordern, werden mit einem gelben Hintergrund angezeigt. Benutzerfelder und Systemfelder, die keinen Datenfluss erfordern, werden mit einem weißen Hintergrund angezeigt.

Verbindungen auf der Datenseite zeigen von der rechten Seite eines Quellnachrichtenfeldes zur linken Seite eines Zielnachrichtenfeldes. Diese Verbindung zeigt an, dass das Quellnachrichtenfeld die Daten für das Zielnachrichtenfeld bereitstellt. Wenn die Zielnachricht erstellt werden muss, kopiert das XLANG-Ablaufplanungsmodul die Daten zur Laufzeit vom Quellnachrichtenfeld in das Zielnachrichtenfeld. Ist die Quellnachricht noch nicht eingetroffen, tritt ein Laufzeitfehler auf.

Anmerkungen

  • Die folgenden Datentypen werden auf der Datenseite nicht unterstützt:
    • BinHex

    • BinBase64

    • I8

    • UI8

Wenn Sie in einem XML-Dokument einen Knoten vom Typ BinHex, BinBase64, I8 oder UI8 haben und Sie festlegen, dass der Knoten mithilfe des XPath zu diesem Knoten in den Bereich des XLANG-Ablaufplanungsmoduls auf der Datenseite gebracht werden soll, wird der Knoten in eine Zeichenfolge konvertiert.

  • Es besteht eine Begrenzung von 100 Zeichen für alle Feldnamen in XLANG-Ablaufplänen.

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Felddatentypen

Knotenpfadfelder

Die Nachricht "Port References"

Systemfelder


Die Nachricht "Constants"

Sie können die Nachricht Constants verwenden, um eine XLANG-Ablaufplaninstanz mit Daten zu initialisieren. Innerhalb des XLANG-Ablaufplanungsmoduls führt die Nachricht Constants eine eindeutige Funktion aus; sie wird weder gesendet noch empfangen. Sie wird für jede neue XLANG-Ablaufplaninstanz automatisch initialisiert. Doppelklicken Sie auf die Nachricht Constants, um eine Konstante zur Nachricht Constants hinzuzufügen, oder doppelklicken Sie auf ein Feld in der Nachricht Constants, um das Dialogfeld Eigenschaften der Nachricht Constants zu öffnen. Klicken Sie im Dialogfeld Eigenschaften der Nachricht Constants auf Hinzufügen, um das Dialogfeld Eigenschaften der Konstante zu öffnen. Im Dialogfeld Eigenschaften der Konstante können Sie die Konstante benennen, einen Datentyp für die Konstante auswählen und ihr einen Wert zuweisen.

Internationales Problem

  • XML verarbeitet keine Windows-Gebietsschemaeinstellungen für Datumsformate. Wenn Sie ein Datum für eine Konstante in einem lokalisierten Format zuweisen möchten, legen Sie für die Konstante den string-Datentyp fest. Wenn diese Konstante Daten für ein Feld mit dem date-Datentyp bereitstellt, übersetzt das XLANG-Ablaufplanungsmodul die Zeichenfolge in ein Datum und verwendet dabei das lokalisierte Format.

Verwandte Themen

Datenverarbeitung

Die Datenseite

Felddatentypen

Knotenpfadfelder

Die Nachricht "Port References"

Systemfelder


Die Nachricht "Port References"

Die Nachricht Port References enthält eine Liste aller Ports, die auf der Geschäftsprozessseite erstellt werden. Sobald ein neuer Port auf der Geschäftsprozessseite hinzugefügt wird, wird ein neuer Verweis zu dieser Liste hinzugefügt. Mit der Nachricht Port References können Sie den Ursprung von Portstandorten angeben. Die Nachricht Port References enthält ein Portfeld für jeden Port in der XLANG-Ablaufplanzeichnung.

Es gibt Szenarien, in denen Ports in einem XLANG-Ablaufplan zur Entwurfszeit nicht bekannt sind. Dies kann vorkommen, wenn das Ziel bzw. der Ursprung von Nachrichten vom Inhalt anderer Nachrichten bestimmt wird. Ein Geschäftsprozess kann beispielsweise eine Situation beschreiben, in der eine Aktion auf eine Nachricht mit einer Bestätigung an den Handelspartner reagieren muss, von dem die Nachricht stammt. In diesem Beispiel verfügt die empfangene Nachricht im Allgemeinen über ein Feld für die Antwortadresse, das die Ursprungsadresse der Nachricht enthält. Der XLANG-Ablaufplan muss den Inhalt des Feldes für die Antwortadresse mit der Zieladresse der Bestätigungsnachricht korrelieren können. Sie können die Nachricht Port References und eine Bestätigungsnachricht auf der Datenseite verwenden, um dieses Szenario zu implementieren. Weitere Informationen zum Nachrichtenaustausch finden Sie unter Integrieren der BizTalk-Dienste.

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Felddatentypen

Knotenpfadfelder

Systemfelder


Felddatentypen

Der BizTalk-Orchestrierungs-Designer zeigt alle Datentypen mit dem jeweiligen XML-Datentypnamen an. Die folgende Tabelle enthält eine Liste der OLE-Automatisierungs-, Visual Basic- und C-Programm-Äquivalente für die angezeigten XML-Datentypnamen.

XML-UI-Ansicht | OLE-Automatisierung | Visual Basic | C
Einfache Typen |  |  |
boolean | VT_BOOL | Boolean | VARIANT_BOOL
string | VT_BSTR | String | BSTR
cy | VT_CY | Currency | CURRENCY
date | VT_DATE | Date | DATE
dispatch | VT_DISPATCH | Objekt | IDispatch
error | VT_ERROR |  | SCODE
i1 | VT_I1 |  | signed char
i2 | VT_I2 | Integer | SHORT
i4 | VT_I1 | Long | LONG
int | VT_INT |  | INT
r4 | VT_R4 | Single | FLOAT
r8 | VT_R8 | Double | DOUBLE
ui1 | VT_UI1 | Byte | BYTE
ui2 | VT_UI2 |  | USHORT
ui4 | VT_UI4 |  | ULONG
uint | VT_UINT |  | UINT
unknown | VT_UNKNOWN | Objekt | IUnknown
variant | VT_VARIANT | Variant | VARIANT

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Die Datenseite

Knotenpfadfelder

Die Nachricht "Port References"

Systemfelder


Systemfelder

Jede Nachricht kann außerdem Systemfelder enthalten, die automatisch durch das XLANG-Ablaufplanungsmodul erstellt werden.

Systemfeldname | Wann wird das Systemfeld angezeigt? | Beschreibung
__Status__ | Wenn die Nachricht von einem Port empfangen wird, der an eine COM- oder Skriptbindung gebunden ist. | HRESULT des Methodenaufrufs.
__Sender__ | Wenn die Nachricht an einen Port gesendet bzw. von diesem empfangen wird. | Wenn eine Nachricht empfangen wird, ist dies eine Zeichenfolge mit der Absenderkennung, die von Message Queuing oder COM bereitgestellt wird. Wenn diese Nachricht gesendet wird, ist der Wert NULL.
Document | Wenn die Nachricht von einem Port gesendet wird, der an Message Queuing oder BizTalk-Messaging gebunden ist. | Eine Zeichenfolge mit dem Nachrichtentext, der gesendet bzw. empfangen wird.

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Felddatentypen

Knotenpfadfelder

Die Nachricht "Port References"


Knotenpfadfelder

Wenn ein an Message Queuing oder BizTalk-Messaging gebundener Port ein XML-Dokument empfängt, können Sie bestimmte Dokumentknoten in den Datenbereich des XLANG-Ablaufplanungsmoduls bringen. Wenn keine bestimmten Knoten ausgewählt werden, behandelt das XLANG-Ablaufplanungsmodul das XML-Dokument als verdeckte Zeichenfolge, die im Dokumentensystemfeld enthalten ist.

Sie können Dokumentknoten mithilfe der Seite Nachrichtenspezifikation im Assistenten für XML-Kommunikation in den Datenbereich des XLANG-Ablaufplanungsmoduls bringen. Wenn Sie eine XML-Spezifikation bereitstellen, sind die Schaltflächen Hinzufügen und Entfernen aktiviert.

Verwandte Themen

Die Nachricht "Constants"

Datenverarbeitung

Felddatentypen

Die Nachricht "Port References"

Systemfelder

Verwenden des Assistenten für XML-Kommunikation


Erstellen von XLANG-Ablaufplanzeichnungen

Es gibt fünf Aufgaben, die Sie ausführen müssen, wenn Sie einen XLANG-Ablaufplan entwerfen:

  • Zeichnen Sie eine Darstellung des Geschäftsprozesses, den der XLANG-Ablaufplan ausführen wird. Verwenden Sie Flussdiagrammformen, um den Geschäftsprozessablauf auf der linken Seite der Entwurfsseite zu beschreiben. Ihr primärer Geschäftsprozess wird auf der Geschäftsprozessseite gezeichnet. Alternative Prozesse werden auf den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion gezeichnet.

  • Definieren Sie Regeln für die Verzweigung von Entscheidungen und Prozessen, die innerhalb des Geschäftsprozesses wiederholt werden, definieren Sie parallele Prozesse, und entwerfen Sie die in dem Geschäftsprozess erforderlichen Transaktionen und untergeordneten Transaktionen.

  • Erstellen Sie die für den Geschäftsprozess erforderlichen Portimplementierungen. Es stehen vier Implementierungstechnologien zur Verfügung: COM-Komponenten, Windows-Skriptkomponenten, Message Queuing-Dienste und BizTalk-Messagingdienste.

  • Definieren Sie den Datenfluss zwischen Nachrichten. Der gesamte Datenfluss zwischen Nachrichten wird auf der Datenseite gezeichnet.

  • Zeichnen Sie erforderliche Geschäftsprozesse für fehlgeschlagene Transaktionen. Alternative Geschäftsprozesse werden auf den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion gezeichnet.

Anmerkung

  • Sie können Flussdiagrammformen und nobr>Implementierungsformen zu den Geschäftsprozess-, Kompensierungs- und Fehlerseiten hinzufügen. Diese Formen sind auf der Datenseite nicht verfügbar.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Entwerfen von Geschäftsprozessen

  • Behandeln von Ausnahmen

  • Implementieren von Geschäftsprozessen


Entwerfen von Geschäftsprozessen

Im BizTalk-Orchestrierungs-Designer befindet sich auf der linken Seite der Geschäftsprozessseite der Bereich, in dem Sie Geschäftsprozesse entwerfen können. Die Geschäftsprozessseite wird durch eine Trennlinie in einen Geschäftsprozess-Entwurfsbereich auf der linken und einen Implementierungsbereich auf der rechten Seite unterteilt.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Entwerfen von Aktionen

  • Entwerfen von Regeln

  • Entwerfen von Parallelität

  • Entwerfen von Transaktionen


Entwerfen von Aktionen

Der Geschäftsprozess muss dem Ablauf von der Beginn-Form zur ersten Flussdiagrammform in Ihrer XLANG-Ablaufplanzeichnung folgen. Gewöhnlich handelt es sich bei der ersten Flussdiagrammform in Ihrer XLANG-Ablaufplanzeichnung um eine Aktion-Form.

Es gibt zwei konfigurierbare Eigenschaften für eine Beginn-Form. Im Dialogfeld Beginneigenschaften können Sie die Transaktionsmodell-Eigenschaft konfigurieren, um festzulegen, ob Transaktion-Formen in einer XLANG-Ablaufplaninstanz unterstützt werden oder ob der XLANG-Ablaufplan aus der COM-Komponente einer Transaktion aktiviert wird. Mit der ersten Option wird die Unterstützung für Transaktion-Formen aktiviert, mit der zweiten Option wird die Unterstützung für Transaktion-Formen deaktiviert.

Sie können im Dialogfeld Beginneigenschaften außerdem die Transaktionsaktivierung-Eigenschaft und die XLANG-Identität-Eigenschaft konfigurieren. Weitere Informationen zur Transaktionsaktivierung finden Sie unter Entwerfen von Transaktionen.

Die XLANG-Identität-Eigenschaft ist schreibgeschützt. Sie enthält einen globalen eindeutigen Bezeichner (GUID), der zur Korrelation einer Version der XLANG-Ablaufplanzeichnung mit dem von dieser generierten XLANG-Ablaufplan verwendet wird. Der GUID wird automatisch erstellt, wenn eine neue Zeichnung erstellt wird. Ein neuer GUID wird erstellt, sobald eine XLANG-Ablaufplanzeichnung geändert wird.

Die einzige konfigurierbare Eigenschaft einer Aktion-Form ist der Name der Aktion. Der Name der Aktion darf maximal 32 Zeichen lang sein. Aktionsnamen haben keine Auswirkung auf das Verhalten eines XLANG-Ablaufplanes.

Verwandte Themen

Entwerfen von Parallelität

Entwerfen von Regeln

Entwerfen von Transaktionen

Flussdiagrammformen


Entwerfen von Regeln

Regeln sind Ausdrücke der Microsoft Visual Basic Scripting Edition (VBScript), die von Entscheidung- und While-Formen verwendet werden. Es gibt folgende Regeln:

  • Spezifische VBScript-Ausdrücke wie Date und Time.

  • Ausdrücke, die Daten in einem Nachrichtenfeld auswerten.

  • Ausdrücke, die bestimmen können, ob eine Nachricht vorhanden ist.

Eine Regel enthält die folgenden Eigenschaften, die das Verhalten der Form definieren:

  • Regelname. Eine erforderliche Eigenschaft, die in der XLANG-Ablaufplanzeichnung innerhalb der Form angezeigt wird, die die Regel verwendet. Durch den Namen wird die Regel eindeutig identifiziert. Eine einzelne, eindeutig benannte Regel kann in mehreren Entscheidung- und While-Formen verwendet werden. Die Breite der Entscheidung- oder While-Form, die die Regel verwendet, wird von der Regel mit dem längsten Namen in der Form bestimmt.

  • Regelbeschreibung Eine optionale Eigenschaft. Es handelt sich um eine Beschreibung der Regel.

  • Skriptausdruck. Ein erforderlicher VBScript-Ausdruck, der auf Daten in Nachrichten verweist. Der Ausdruck muss auf TRUE oder FALSE auswerten.

Wenn Sie eine XLANG-Ablaufplanzeichnung entwerfen, erstellen Sie die Regeln und stellen Namen und Regelbeschreibungen bereit. Wenn Sie Implementierungsformen zur Zeichnung hinzufügen, fügen Sie damit Skriptausdrücke hinzu.

Anmerkungen

  • Die Skriptausdruck-Eigenschaft ist nur beim Kompilieren der XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan erforderlich.

  • Es gibt ein Nachrichtenfeld mit dem Namen __Exists__, das nicht unter den Nachrichten auf der Datenseite angezeigt wird. Mit diesem Feld lässt sich das Vorhandensein einer Nachricht testen. Das Vorhandensein einer Nachricht wird davon bestimmt, ob die Nachricht vom XLANG-Ablaufplanungsmodul empfangen oder definiert wurde.

Verwandte Themen

Erstellen von Regeln

Entwerfen von Aktionen

Entwerfen von Parallelität

Entwerfen von Transaktionen

Flussdiagrammformen

Festlegen von Entscheidungsbedingungen


Entwerfen von Parallelität

Der BizTalk-Orchestrierungs-Designer unterstützt parallele Aktionen. Mit den Formen Verzweigung und Verknüpfung werden parallele (gleichzeitige) Prozessabläufe in einem XLANG-Ablaufplan implementiert. Mit der Verzweigung-Form können Sie parallele Prozessabläufe erstellen, und mit der Verknüpfung-Form können Sie parallele Prozessabläufe synchronisieren, die nicht durch eine Ende-Form beendet werden.

Verknüpfungseigenschaften

Für die Verknüpfung-Form können Sie zwei Eigenschaften festlegen. Diese Eigenschaften repräsentieren die folgenden logischen Operatoren:

  • AND. Der XLANG-Ablaufplan wartet, bis alle Prozessabläufe die Verknüpfung erreicht haben, bevor er mit der nächsten Aktion im Geschäftsprozess fortfährt.

  • OR. Der XLANG-Ablaufplan wartet, bis der erste Prozessablauf die Verknüpfung erreicht hat, und fährt dann mit der nächsten Aktion im Geschäftsprozess fort.

    Aktionen in anderen Abzweigen der Verzweigung führen ihre Prozesse aus, die OR-Verknüpfung wartet jedoch nicht, bis diese beendet sind. Wenn der Prozessablauf, der eine OR-Verknüpfung verlässt, eine Aktion beinhaltet, die einen Datenfluss von einer Verzweigung erfordert, der in die OR-Verknüpfung eintritt, und diese Aktion zum Zeitpunkt der Ausführung der Aktion, die die Verknüpfung verlässt, noch nicht beendet ist, tritt ein Fehler auf.

Gültige Verzweigungs- und Verknüpfungsprozessabläufe

Beachten Sie beim Entwerfen paralleler Abläufe in einem Geschäftsprozess die folgenden Richtlinien:

  • Alle verzweigten Abläufe müssen entweder mit einer Ende-Form enden oder mit einer Verknüpfung-Form in einen einzelnen Ablauf synchronisiert werden.

  • Aktionen mit verzweigten Abläufen können nicht miteinander kommunizieren. Eine Aktion in einer Verzweigung kann z. B. keine Nachricht an eine Warteschlange senden, wenn eine Aktion in einer anderen Verzweigung auf den Empfang einer Nachricht aus dieser Warteschlange wartet.

    Vorsicht

    • Wenn der Entwurf Ihrer XLANG-Ablaufplanzeichnung fälschlicherweise die Unterstützung der Kommunikation zwischen Aktionen in unterschiedlichen Verzweigungen vorsieht, kann es zu einem Fehler der XLANG-Ablaufplaninstanz zur Laufzeit kommen, ohne dass jedoch eine Fehlermeldung angezeigt wird.
  • Sie können Abläufe aus mehreren Verzweigungen nicht mit einer Verknüpfung synchronisieren. Die Verknüpfung-Form kann lediglich zum Synchronisieren der Abläufe aus einer übereinstimmenden Verzweigung verwendet werden. Zwischen der Verwendung der Verzweigung-Form und der Verknüpfung-Form besteht eine 1:1-Entsprechung.

    Die folgende Abbildung zeigt zwei Verzweigungen, die zum Erstellen paralleler Abläufe verwendet werden, sowie eine einzelne Verknüpfung, mit der diese Abläufe synchronisiert werden sollen. Diese Verbindung ist ungültig. Bei dieser Art von Verbindung erhalten Sie eine Fehlermeldung, wenn Sie den XLANG-Ablaufplan kompilieren.

    parallele Abläufe mit ungültiger Verbindung

    Die beiden folgenden Abbildungen zeigen zwei Beispiele für gültige Verknüpfungen.

    In der folgenden Abbildung werden zwei Verzweigungen gezeigt, die zwei Verknüpfungen zugeordnet sind. Das zweite Paar aus Verzweigung und Verknüpfung ist im ersten Paar geschachtelt.

    parallele Abläufe mit gültiger Verbindung

    In der folgenden Abbildung werden zwei Verzweigungen gezeigt, die zwei Verknüpfungen zugeordnet sind. Das zweite Paar aus Verzweigung und Verknüpfung ist im ersten Paar geschachtelt. Auch wenn ein paralleler Ablauf innerhalb des zweiten Paares aus Verzweigung und Verknüpfung durch eine Ende-Form endet, muss der andere parallele Ablauf trotzdem mit einer übereinstimmenden Verknüpfung synchronisiert werden, bevor sein Ablauf mit dem parallelen Ablauf aus dem ersten Paar synchronisiert werden kann.

    parallele Abläufe mit gültiger Verbindung

  • Wenn Sie mehrere parallele Abläufe mit einer OR-Verknüpfung synchronisieren, kann jeder Prozessablauf, der in die Verknüpfung eintritt, nur eine Aktion enthalten. Ein Ablauf, der mehr als eine Aktion enthält, ist nicht gültig.

    Die folgende Abbildung zeigt eine OR-Verknüpfung, die mehrere parallele Abläufe synchronisiert. Jeder Ablauf enthält nur eine Aktion.

    parallele Abläufe mit gültiger Verbindung

Wichtig

  • Aktionen in unterschiedlichen Abzweigen einer Verzweigung können nicht miteinander kommunizieren. Eine Aktion in einer Verzweigung kann z. B. keine Nachricht an eine Warteschlange senden, wenn eine Aktion in einer anderen Verzweigung auf den Empfang einer Nachricht aus dieser Warteschlange wartet. Wenn der Entwurf Ihrer XLANG-Ablaufplanzeichnung fälschlicherweise die Unterstützung der Kommunikation jeglicher Art zwischen Aktionen in unterschiedlichen Verzweigungen vorsieht, kann die XLANG-Ablaufplaninstanz zur Laufzeit fehlschlagen, ohne dass jedoch ein Fehler angezeigt wird.

Verwandte Themen

Entwerfen von Aktionen

Entwerfen von Regeln

Entwerfen von Transaktionen

Flussdiagrammformen

Festlegen von Parallelitätseigenschaften


Entwerfen von Transaktionen

Der BizTalk-Orchestrierungs-Designer bietet ein Transaktionsprogrammierungsmodell einschließlich Fehlerbehandlung und Wiederherstellung fehlgeschlagener Transaktionen. Sie können Transaktion-Formen konfigurieren, um zwei zusätzliche Seitentypen im BizTalk-Orchestrierungs-Designer zu erstellen: die Seite Bei Fehler von Transaktion und die Seite Kompensierung für Transaktion. Mithilfe dieser beiden Seiten können Geschäftsprozesse bei fehlgeschlagenen Transaktionen wiederhergestellt werden. Die Seiten Bei Fehler von Transaktion und Kompensierung für Transaktion können Transaktion-Formen enthalten, die auf zusätzliche Fehler- und Kompensierungsseiten verweisen. Auf den Seiten Bei Fehler von Transaktion und Kompensierung für Transaktion können dieselben Port-Formen und Implementierungsformen verwendet werden, die auf der Geschäftsprozessseite angezeigt werden.

Die von Ihnen mit dem BizTalk-Orchestrierungs-Designer entworfenen kurzlebigen Transaktionen verfügen über die vier ACID-Attribute. ACID ist ein Akronym, das sich aus den folgenden Eigenschaften zusammensetzt:

  • Unteilbarkeit (Atomicity). Eine Transaktion stellt eine atomare (unteilbare) Arbeitseinheit dar. Es werden entweder alle Änderungen der Transaktionsdaten oder keine der Änderungen ausgeführt.

  • Konsistenz (Consistency). Beim Commit muss eine Transaktion die Integrität der Daten innerhalb des Systems bewahren. Wenn eine Transaktion eine Datenänderung in einer Datenbank ausführt, die vor Beginn der Transaktion intern konsistent war, muss die Datenbank auch nach dem Commit der Transaktion intern konsistent sein. Für die Gewährleistung dieser Eigenschaft ist im Allgemeinen der Anwendungsentwickler verantwortlich.

  • Isolation. Änderungen, die von parallelen Transaktionen ausgeführt werden, müssen von allen Änderungen, die von anderen parallelen Transaktionen ausgeführt werden, isoliert sein. Isolierte Transaktionen, die parallel ausgeführt werden, führen Änderungen durch, bei denen die interne Datenbankkonsistenz genauso bewahrt wird wie bei der seriellen Ausführung der Transaktionen.

  • Beständigkeit (Durability). Nach dem Commit einer Transaktion sind standardmäßig alle Änderungen im System dauerhaft. Die Änderungen sind auch bei einem Systemfehler persistent gespeichert.

Im Gegensatz dazu wird bei langlebigen Transaktionen die Isolation geopfert, um Vorgänge bearbeiten zu können, deren Ausführung einen längeren Zeitraum in Anspruch nimmt.

Anmerkungen

  • Um das Ergebnis einer Transaktion zu testen, müssen Sie eine Nachricht verwenden, die in einem fehlerhaften Transaktionsprozess erstellt wurde. Testen Sie nicht das Transaktionsergebnis, indem Sie nach einer (möglicherweise geänderten) Nachricht suchen, die in der Transaktion verwendet wurde.

  • Beim Verwenden von COM+-BYOT-Funktionalität (Bring Your Own Transaction) mit COM-Komponenten für das XLANG-Ablaufplanungsmodul erstellen Sie eine Wrapperkomponente, die in eine COM+-Anwendung geschrieben und installiert wird. Diese Wrapperkomponente leitet alle Methodenaufrufe der Komponente weiter. Wird eine BYOT-Komponente in eine COM+-Anwendung importiert, kann sie herkömmliche COM-Komponenten nicht starten, da die Komponente, welche die Funktionalität bereitstellt, als herkömmliche COM-Komponente und nicht als COM+-Anwendung registriert ist.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

  • Transaktionseigenschaften für bestimmte Transaktion-Formen

  • Transaktionseigenschaften für eine Portimplementierung

  • Langlebige Transaktionen

  • Kurzlebige Transaktionen

Verwandte Themen

Entwerfen von Aktionen

Entwerfen von Parallelität

Entwerfen von Regeln

Flussdiagrammformen

Festlegen von Transaktionseigenschaften


Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

Klicken Sie mit der rechten Maustaste auf die Beginn-Form auf der Geschäftsprozessseite, und klicken Sie dann auf Eigenschaften, um das Dialogfeld Beginneigenschaften anzuzeigen. Sie können im Dialogfeld Beginneigenschaften folgende Eigenschaften konfigurieren:

  • Transaktionsmodell. Die Standardeinstellung für diese Eigenschaft lautet Transaktionen in den XLANG-Ablaufplan einschließen.
    • Wählen Sie Transaktionen in den XLANG-Ablaufplan einschließen aus, wenn Sie eine Auflistung gruppierter Aktionen in eine Transaktion-Form Ihrer XLANG-Ablaufplanzeichnung einschließen möchten. Durch die Auswahl dieser Option wird die Transaktionsaktivierung-Eigenschaft deaktiviert.

    • Wählen Sie XLANG-Ablaufplan als COM+-Komponente behandeln aus, wenn Sie den XLANG-Ablaufplan durch eine COM+-Komponente innerhalb seines COM+-Transaktionskontextes aktivieren möchten. Wenn Sie diese Option auswählen, können Sie keine Transaktionen in Ihre XLANG-Ablaufplanzeichnung einschließen, und die Verwendung der Verzweigung-Form zur Implementierung der Parallelität sollte eingeschränkt sein. Wenn Sie die Verzweigung-Form verwenden, sollten alle Aktionen mit Aufrufen an COM+-Komponenten auf eine einzelne ausgehende Verzweigung beschränkt sein. Diese Beschränkung gilt nicht, wenn die Aktionen in Ihrer XLANG-Ablaufplanzeichnung Aufrufe an COM-Komponenten enthalten. Außerdem sollten alle Transaktionsänderungen in einer einzelnen ausgehenden Verzweigung ausgeführt werden.

      Durch die Auswahl dieser Option wird die Transaktionsaktivierung-Eigenschaft aktiviert.

  • Transaktionsaktivierung. Die Standardeinstellung für diese Eigenschaft ist Nicht unterstützt.
    • Nicht unterstützt. Diese Auswahl gibt an, dass der XLANG-Ablaufplan keine Transaktionen unterstützt.

    • Unterstützt. Diese Auswahl gibt an, dass der XLANG-Ablaufplan möglicherweise an einer COM+-Transaktion teilnimmt.

    • Erforderlich. Diese Auswahl gibt an, dass der XLANG-Ablaufplan eine COM+-Transaktion erfordert.

    • Neue Transaktion erforderlich. Diese Auswahl gibt an, dass der XLANG-Ablaufplan möglicherweise an einer neuen Transaktion teilnimmt. Ist diese Einstellung aktiviert, initialisiert das XLANG-Ablaufplanungsmodul automatisch eine neue Transaktion, die sich von der Transaktion des aufrufenden Prozesses unterscheidet.
  • XLANG-Identität. Weitere Informationen zur XLANG-Identität-Eigenschaft finden Sie unter Flussdiagrammformen.

Verwandte Themen

Entwerfen von Transaktionen

Langlebige Transaktionen

Kurzlebige Transaktionen

Transaktionseigenschaften für eine Portimplementierung

Transaktionseigenschaften für bestimmte Transaktion-Formen


Transaktionseigenschaften für bestimmte Transaktion-Formen

Klicken Sie mit der rechten Maustaste auf der Geschäftsprozessseite auf eine Transaktion-Form, und klicken Sie dann auf Eigenschaften, um das Dialogfeld Eigenschaften der Transaktionen anzuzeigen. Sie können im Dialogfeld Eigenschaften der Transaktionen folgende Eigenschaften konfigurieren:

  • Typ. Diese Eigenschaft bestimmt den Typ der Transaktion, der für die ausgewählte Transaktion-Form verwendet wird. Die Standardeinstellung für diese Eigenschaft ist Kurzlebig, DTC-Stil.
    • Wählen Sie Kurzlebig, DTC-Stil, wenn Sie möchten, dass die Transaktion eine Auflistung von Aktionen gruppiert, die als einzelne logische Arbeitseinheit mit den vier Eigenschaften einer ACID-Transaktion ausgeführt werden. Weitere Informationen zu ACID-Transaktionen finden Sie unter Entwerfen von Transaktionen. Transaktionen mit der Kurzlebig, DTC-Stil-Eigenschaft sind auf der Entwurfsseite grau schattiert. Diese Option ist verfügbar für geschachtelte Transaktionen und eigenständige Transaktionen. Sie können die Option nicht für eine äußere Transaktion auswählen, die eine geschachtelte Transaktion enthält.

    • Wählen Sie Langlebig aus, wenn die Transaktion eine Auflistung von Aktionen gruppieren soll, die Nachrichten über einen unbegrenzten Zeitraum senden und empfangen. Sie können eine langlebige Transaktion außerdem so konfigurieren, dass sie eine Auflistung geschachtelter Transaktionen gruppiert. Transaktionen sind jedoch auf eine Verschachtelungsebene beschränkt. Langlebige Transaktionen sind auf der Entwurfsseite gelb schattiert. Diese Option ist für alle Transaktionen verfügbar.

    • Wählen Sie Befristete Transaktion aus, wenn Sie möchten, dass die langlebige Transaktion abgebrochen wird, wenn sie nicht in einer bestimmten Zeit abgeschlossen werden konnte. Befristete Transaktionen sind auf der Entwurfsseite blau schattiert. Diese Option ist für alle Transaktionen verfügbar.
  • Persistenter Status des Ablaufplanes. Diese Eigenschaft bestimmt, ob der Status des Ablaufplanes in der Persistenzdatenbank für die Orchestrierung gespeichert wird. Diese Option ist für befristete Transaktionen und für langlebige Transaktionen verfügbar. Wenn Sie die Informationen über den persistenten Status nicht benötigen, sollten Sie diese Eigenschaft deaktivieren, um den Durchsatz zu erhöhen.

  • Timeout. Diese Eigenschaft bestimmt die Zeit (in Sekunden), die der Transaktion für ihre Ausführung zur Verfügung steht, bevor sie abgebrochen wird. Diese Option ist für befristete Transaktionen und für kurzlebige Transaktionen im DTC-Stil verfügbar.

  • Wiederholungsanzahl. Diese Eigenschaft bestimmt, wie häufig ein Prozess in einer kurzlebigen Transaktion im DTC-Stil ausgeführt wird, wenn der Prozess in der Transaktion nicht beendet wird. Bei jeder Wiederholung wird der Status der Anwendung an den Anfangspunkt des Prozesses in der Transaktion zurückgesetzt.

  • Backoffzeit. Diese Eigenschaft bestimmt das Intervall zwischen den einzelnen Transaktionswiederholungsversuchen. Die Backoffzeit wird zusammen mit der Wiederholungsanzahl verwendet, um die Wartezeit bis zum nächsten Wiederholungsversuch der Transaktion zu ermitteln. Der Backoff-Wert wächst exponentiell. Ein Backoff-Wert von 2 resultiert in Intervallen von 2, 4, 8, 16 Sekunden usw. für die Zeit bis zum jeweils nächsten Wiederholungsversuch. Die Berechnungsformel lautet B**W ("B hoch W"), wobei B die Backoffzeit und W die aktuelle Wiederholungsanzahl bezeichnet. Wenn die Backoffzeit eines bestimmten Wiederholungsversuches für eine Transaktion über 180 Sekunden beträgt, muss die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank pausieren.

  • Isolationsebene. Die Isolationsebene bestimmt, in welchem Maß parallel Transaktionen auf Daten in den jeweils anderen Transaktionen zugreifen können. Diese Option ist nur für kurzlebige Transaktionen im DTC-Stil verfügbar. Sie sollten Folgendes auswählen:
    • Serializable, um parallele Transaktionen daran zu hindern, Änderungen an Daten vorzunehmen, bevor die ausgewählte Transaktion beendet ist. Von den vier Isolationsebenen ist diese die restriktivste.

    • Read Uncommitted, um parallele Transaktionen die Möglichkeit zu geben, Änderungen an Daten vorzunehmen, bevor die ausgewählte Transaktion beendet ist. Von den vier Isolationsebenen ist dies die am wenigsten restriktive.

    • Read Committed, um zu verhindern, dass die ausgewählte Transaktion auf Datenänderungen in parallelen Transaktionen zugreifen kann, bevor deren Commit ausgeführt wurde. Diese Option ist die Microsoft® SQL Server™-Standardeinstellung.

    • Repeatable Read, so dass Lesesperren erforderlich sind, bis die ausgewählte Transaktion beendet ist.
  • Bei Fehler. Klicken Sie auf Code hinzufügen, aktivieren Sie das Kontrollkästchen Aktiviert, und klicken Sie dann auf OK, wenn Sie die Seite Bei Fehler von Transaktion aktivieren möchten. Sie können dann die Seite Bei Fehler von Transaktion verwenden, um einen alternativen Geschäftsprozess für die Behandlung eines Fehlers der ausgewählten Transaktion zu entwerfen. Diese Option ist für alle Transaktionen verfügbar.

  • Kompensierung. Klicken Sie auf Code hinzufügen, aktivieren Sie das Kontrollkästchen Aktiviert, und klicken Sie dann auf OK, wenn Sie die Seite Kompensierung für Transaktion aktivieren möchten. Sie können dann die Seite Kompensierung für Transaktion zum Entwerfen eines alternativen Geschäftsprozesses verwenden, mit dem Sie die in einer geschachtelten Transaktion ausgeführte logische Arbeitseinheit rückgängig machen können, für die ein Commit bereits ausgeführt wurde. Diese Option ist nur für geschachtelte Transaktionen verfügbar.

Anmerkung

  • Das Abbrechen einer geschachtelten Transaktion verursacht nicht automatisch einen Abbruch der äußeren Transaktion. Dadurch können Sie eine äußere Transaktion entwerfen, die bei einem Fehler der geschachtelten Transaktion wiederhergestellt werden kann. Ein Fehler in einer geschachtelten Transaktion kann jedoch zu einem Fehler in einer äußeren Transaktion führen, wenn die Seite Bei Fehler von Transaktion bzw. Kompensierung für Transaktion der geschachtelten Transaktion einen Abbruch der äußeren Transaktion vorsieht.

Verwandte Themen

Entwerfen von Transaktionen

Langlebige Transaktionen

Kurzlebige Transaktionen

Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

Transaktionseigenschaften für eine Portimplementierung


Transaktionseigenschaften für eine Portimplementierung

Sie können auf den Seiten Erweiterte Porteigenschaften des Bindungs-Assistenten für COM-Komponenten und des Bindungs-Assistenten für Skriptkomponenten Transaktionseigenschaften für COM-Komponenten und Windows-Skriptkomponenten konfigurieren. Die Seite Erweiterte Porteigenschaften stellt eine Option zum Abbrechen der aktuellen Transaktion bereit, wenn ein Fehler von einer Methode in einer Komponente zurückgegeben wird. Auf der Seite Erweiterte Porteigenschaften können Sie folgende Transaktionseigenschaften konfigurieren:

  • Transaktionsunterstützung. Die Transaktionsunterstützungs-Eigenschaft gibt an, in welchem Maß Ihre Komponente Transaktionen erfordert, unterstützt oder ignoriert.
    • Deaktiviert. Diese Auswahl gibt an, dass die Komponente die COM-Transaktionsverwaltung ignoriert.

    • Nicht unterstützt. Diese Auswahl gibt an, dass die Komponente nicht an einer Transaktion teilnimmt bzw. die Transaktionen anderer Komponenten nicht weitergibt.

    • Unterstützt. Diese Auswahl gibt an, dass für den Fall, dass eine Transaktion eine Aktion enthält, die eine Verbindung mit dem Port hat, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Andernfalls hat die Komponente keine Transaktion.

    • Erforderlich. Diese Auswahl gibt an, dass für den Fall, dass eine Transaktion eine Aktion enthält, die eine Verbindung mit dem Port hat, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Gibt es keine Transaktion mit einer Aktion, die eine Verbindung mit dem Port hat, an den die Komponente gebunden ist, wird eine neue Transaktion für die Komponente erstellt.

    • Neue Transaktion erforderlich. Diese Auswahl gibt an, dass stets eine neue Transaktion für die Komponente erstellt wird.

Wichtig

  • Der BizTalk-Orchestrierungs-Designer verlässt sich auf das Transaktionsverhalten der Implementierungstechnologien, die in einer XLANG-Ablaufplanzeichnung verwendet werden. Er stellt kein Transaktionsverhalten für einen Geschäftsprozess bereit oder legt dieses fest, wenn die XLANG-Ablaufplanzeichnung eine Transaktion-Form enthält. Wenn eine COM-Komponente, Nachrichtenwarteschlange oder eine Skriptkomponente keinen Transaktionskontext hat, werden die Datenänderungen durch die XLANG-Ablaufplanzeichnung nicht als Transaktion ausgeführt.

Anmerkungen

  • Wenn Sie die Transaktionsmodell-Eigenschaft so festlegen, dass der XLANG-Ablaufplan als COM+-Komponente behandelt wird, verwenden Sie keine Transaktion-Formen in der XLANG-Ablaufplanzeichnung. Wenn Sie Transaktion-Formen verwenden und dann versuchen, die XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan zu kompilieren, kann der Kompilierungsprozess nicht ausgeführt werden. Sie müssen vor dem Kompilieren alle Transaktion-Formen aus der XLANG-Ablaufplanzeichnung entfernen.

  • Wenn eine COM-Komponente in mehreren Transaktionen verwendet wird, muss die COM-Komponente entweder keinen Status beibehalten oder den Status beibehalten und Persistenz unterstützen.

  • Wenn mehrere Aktionen mit einem an eine COM- oder Skriptkomponente gebundenen Port kommunizieren und diese Aktionen sich innerhalb mehrerer Transaktionen befinden, die nicht ineinander geschachtelt sind, werden die Komponenteninstanzen zerstört und vor jedem neuen Transaktionskontext wieder instanziiert. Wenn die Komponente den Status beibehält und Persistenz unterstützt, wird der Status durch die erneute Aktivierung wiederhergestellt. Wenn die Komponente den Status beibehält und Persistenz nicht unterstützt, geht der Status verloren. Wenn die Komponente von einer anderen Anwendung instanziiert wurde, kann das XLANG-Ablaufplanungsmodul die Komponente nur dann erneut aktivieren, wenn diese sich persistent speichern lässt. Wenn die Komponente von einer anderen Anwendung instanziiert wurde und sich nicht persistent speichern lässt, kann das XLANG-Ablaufplanungsmodul die Komponente nicht erneut instanziieren, und es kommt zu einem Fehler im XLANG-Ablaufplan.

Verwandte Themen

Entwerfen von Transaktionen

Langlebige Transaktionen

Kurzlebige Transaktionen

Transaktionseigenschaften für eine XLANG-Ablaufplanzeichnung

Transaktionseigenschaften für bestimmte Transaktion-Formen


Langlebige Transaktionen

Langlebige Transaktionen unterstützen keine Isolation, eines der vier ACID-Attribute. Eine Beschreibung dieser Attribute finden Sie unter Entwerfen von Transaktionen. Die Daten in einer langlebigen Transaktion sind nicht gesperrt und können von anderen Prozessen oder Anwendungen geändert werden. Wenn Ihre Daten konsistent sein müssen, sollten Sie ausschließlich ACID-Transaktionen verwenden. Da ACID-Transaktionen in einer Umgebung mit einer langen Wartezeit zu schweren Skalierbarkeitsproblemen führen, werden langlebige Transaktionen von XLANG-Ablaufplanzeichnungen unterstützt. Durch langlebige Transaktionen können Sie darauf verzichten, Datenbanken bei längeren Zeiträumen zu sperren. Bei einer langlebigen Transaktion werden Nachrichten über einen unbegrenzten Zeitraum gesendet und empfangen. Abhängig von den Anforderungen des Geschäftsprozesses, den Ihre XLANG-Ablaufplanzeichnung beschreibt, können Sie einen gesamten Geschäftsprozess (mit Ausnahme der Beginn-Form und einer Ende-Form) in eine langlebige Transaktion einschließen.

Im Allgemeinen enthält eine langlebige Transaktion mehrere geschachtelte kurzlebige Transaktionen. In einem einfachen Wire-Transfer-Szenario kann eine langlebige Transaktion beispielsweise die folgenden Aktionen in einer geschachtelten, kurzlebigen Transaktion enthalten:

  • Geld von einem Bankkonto abheben.

  • Wire-Transfer-Prozess initiieren.

Die folgende Abbildung zeigt Geld senden, eine kurzlebige Transaktion, die in einer langlebigen Transaktion namens Wire Transfer geschachtelt ist. Die geschachtelte Transaktion enthält die beiden Aktionen in dem einfachen Wire-Transfer-Szenario. Sobald die Wire Transfer initiieren-Aktion beendet wurde, verlässt der Geschäftsprozess die geschachtelte Transaktion. Wenn dies geschieht, wird das Commit für die geschachtelte Transaktion ausgeführt; das Geld wurde vom Bankkonto abgehoben und an ein Ziel gesendet. An diesem Punkt folgt der Geschäftsprozess der Warten auf Bestätigung-Aktion in der äußeren Transaktion.

In diesem Szenario wurde die Wire Transfer-Transaktion als befristete Transaktion konfiguriert. Wenn der Absender in dem angegebenen Zeitraum keine Bestätigung des Geldempfangs erhalten hat, wird die äußere Transaktion abgebrochen. Wenn dies geschieht, folgt der Geschäftsprozess dem Ablauf zur Seite Kompensierung für Geld senden für die geschachtelte Transaktion. Da das Commit für die geschachtelte Transaktion bereits ausgeführt wurde, muss der alternative Geschäftsprozess Aktionen beschreiben, die ausgeführt werden können, um den Geldbetrag dem Konto des Absenders gutzuschreiben. Wenn der auf der Seite Kompensierung für Geld senden beschriebene Geschäftsprozess ausgeführt wurde, folgt der Geschäftsprozess dem Ablauf zur Seite Bei Fehler von Wire Transfer für die äußere Transaktion. Diese Seite muss einen Geschäftsprozess enthalten, der die Ausnahmebehandlung für die äußere Transaktion beschreibt. In diesem Fall könnte der Geschäftsprozess darin bestehen, nachfolgend eine E-Mail zu senden, in der die Beteiligten über den Status der Übertragung informiert werden.

Verwandte Themen

Entwerfen von Transaktionen

Flussdiagrammformen

Kurzlebige Transaktionen


Kurzlebige Transaktionen

Eine kurzlebige Transaktion ist eine Sammlung gruppierter Aktionen, die als einzelne logische Arbeitseinheit ausgeführt werden. Diese logische Arbeitseinheit weist die vier Eigenschaften einer ACID-Transaktion auf. Weitere Informationen zu ACID-Transaktionen finden Sie unter Entwerfen von Transaktionen.

Verwandte Themen

Entwerfen von Transaktionen

Flussdiagrammformen

Langlebige Transaktionen


Behandeln von Ausnahmen

Das XLANG-Ablaufplanungsmodul kann Systemfehler auffangen. Mit dem BizTalk-Orchestrierungs-Designer können Sie XLANG-Ablaufpläne entwerfen, die auf XLANG-Ablaufplanfehler zur Laufzeit reagieren. Wenn Sie einen Teil eines Geschäftsprozesses in eine Transaktion-Form einschließen, können Sie einen alternativen Geschäftsprozess entwerfen, der ausgeführt wird, wenn ein Fehler auftritt oder eine Anforderung nicht erfüllt wird.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Systemfehler

  • Anwendungsfehler

Verwandtes Thema

Festlegen von Fehlerbehandlungseigenschaften


Systemfehler

Es gibt drei Schweregrade für Systemfehler, die bei der Ausführung des XLANG-Ablaufplanungsmoduls auftreten können. Die drei Schweregrade sind (in aufsteigender Reihenfolge):

  • Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können.

  • Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen.

  • Fehler, die einen Fehler des XLANG-Ablaufplanungsmoduls verursachen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können

  • Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen

  • Fehler, die einen Fehler des XLANG-Ablaufplanungmoduls verursachen


Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können

Das XLANG-Ablaufplanungsmodul kann die folgenden Systemfehler auffangen:

  • COM-Fehler beispielsweise, die ein Fehler-HRESULT verursachen, eine Nachricht, die besagt, dass der Zugriff verweigert wurde von COM, und die dazu führt, dass bei unzureichender Berechtigung eine Methode in einem XLANG-Ablaufplan aufgerufen wird. Dieses kann für COM- oder Skriptbindungen gelten.

  • Transaktionsabbrüche, die durch eingetragene Dienste verursacht werden, z. B. den Distributed Transaction Coordinator (DTC), der eine Transaktion abbricht, weil die Verbindung zu einer Datenbank verloren gegangen ist. Ein weiteres Beispiel ist der Message Queuing-Dienst, der eine Transaktion abbricht, weil er eine Nachricht nicht in eine Warteschlange einreihen kann.

Zur Behandlung eines Fehler-HRESULT mithilfe einer logischen Verzweigung muss die von einem Methodenaufruf stammende _out-Nachricht in einer Entscheidungsregel getestet werden. Der HRESULT-Wert wird im Feld __Status__ der _out-Nachricht gespeichert.

Zur Behandlung eines Fehler-HRESULT mithilfe von Transaktionsfehlerprozessen muss die Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt-Eigenschaft auf der letzten Seite der Bindungs-Assistenten für COM-Komponenten oder für Skriptkomponenten aktiviert werden. Dieses Kontrollkästchen kann nur aktiviert werden, wenn sich die Aktion in einer Transaktion befindet.

Wichtig

  • Diese Option bestimmt, ob Transaktionen, an denen die Komponente beteiligt ist, abgebrochen werden sollen, wenn Aufrufe von Methoden der Komponente ein HRESULT-Ergebnis zurückgeben, welches einen Fehler anzeigt. Die Option kann nur aktiviert werden, wenn die Kommunikationsaktion, welche diesen Port verwendet, innerhalb des Prozessablaufs einer Transaktion stattfindet.

Die Behandlung eines Fehlers in den Message Queuing- oder BizTalk-Messaging-Implementierungstechnologien kann nur mit Transaktionsfehlerprozessen ausgeführt werden. Dazu müssen Sie die Für diese Warteschlange sind Transaktionen erforderlich-Eigenschaft auf der letzten Seite des Bindungs-Assistenten für Message Queuing aktivieren.

Anmerkung

  • Eine von Message Queuing gesendete Aktion, die erfolgreich zurückgegeben wird, zeigt an, dass die Nachricht erfolgreich in der Warteschlange platziert wurde. Es zeigt nicht an, dass die Nachricht übermittelt wurde.

Verwandte Themen

Anwendungsfehler

Fehler, die einen Fehler des XLANG-Ablaufplanungmoduls verursachen

Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen

Behandeln von Ausnahmen

Systemfehler


Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen

Zu den Systemfehlern, die einen Fehler in einer XLANG-Ablaufplaninstanz verursachen, jedoch nicht in einem XLANG-Ablaufplan aufgefangen werden können, gehören:

  • Eine geplante Warteschlange, die nicht vorhanden ist.

  • Ein geplanter Kanal, der nicht vorhanden ist.

  • Datenfluss aus einer Nachricht, die noch nicht eingetroffen ist.

Verwandte Themen

Anwendungsfehler

Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können

Fehler, die einen Fehler des XLANG-Ablaufplanungmoduls verursachen

Behandeln von Ausnahmen

Systemfehler


Fehler, die einen Fehler des XLANG-Ablaufplanungmoduls verursachen

Systemfehler, die nicht vom XLANG-Ablaufplanungsmodul aufgefangen werden können, können zu einem Fehler des XLANG-Ablaufplanungsmoduls einschließlich aller XLANG-Ablaufplaninstanzen führen, die in derselben COM+-Anwendung ausgeführt werden. Zu diesen Systemfehlern gehören bestimmte Zugriffsverletzungen durch Komponenten, die im Prozessbereich des XLANG-Ablaufplanungsmodul ausgeführt werden. Das XLANG-Ablaufplanungsmodul versucht, diese Fehler aufzufangen, in vielen Fällen ist dies jedoch nicht möglich. Wenn Sie eine Komponente haben, die anfällig für diese Fehler ist, sollten Sie diese in einer separaten COM+-Anwendung platzieren, um das Problem zu umgehen.

Verwandte Themen

Anwendungsfehler

Fehler, die in einem XLANG-Ablaufplan aufgefangen werden können

Fehler, die zum Beenden einer XLANG-Ablaufplaninstanz führen

Behandeln von Ausnahmen

Systemfehler


Anwendungsfehler

Es gibt drei Möglichkeiten, Fehler zu behandeln, die XLANG-Ablaufplanfehler verursachen können:

  • Verwenden Sie Logische Verzweigungen.

  • Verwenden Sie Transaktionsabbruchprozesse.

  • Verwenden Sie Timeouts.


Logische Verzweigungen

Entscheidungen und Regeln können auf allen Prozessseiten (der Geschäftsprozessseite, allen Fehlerseiten und allen Kompensierungsseiten) zum Verzweigen eines Prozessablaufes verwendet werden. Die folgende Abbildung zeigt einen einfachen Test der Methodenausführung.

In diesem Beispiel besitzt die Clear_out-Nachricht ein Systemfeld mit dem Namen __Status__. In der Regel HRESULT Success wäre der Skriptausdruck Clear_out.[__Status__] >= 0, wobei ein negatives HRESULT einen Fehler und 0 oder ein positives HRESULT einen Erfolg anzeigt. Durch diese Art der Verwendung von Entscheidungen und Regel können alle Datenfelder in einer Nachricht (innerhalb des VBScript-Ausdrucks einer Regel) auf Ausnahmen, nicht ausschließlich auf HRESULTs, getestet werden.

Verwandte Themen

Behandeln von Ausnahmen

Timeouts

Transaktionsabbruchprozesse


Transaktionsabbruchprozesse

Im BizTalk-Orchestrierungs-Designer können Sie mithilfe von Transaktionen eine Auflistung von Aktionen gruppieren, die als einzelne logische Arbeitseinheit ausgeführt werden und sicherstellen, dass alle Aktionen in der Gruppe vollständig ausgeführt werden oder keine. Durch das Gruppieren von Geschäftsprozessen innerhalb von Transaktionen kann der BizTalk-Orchestrierungs-Designer ein Höchstmaß an Struktur und Zuverlässigkeit bereitstellen.

Der Prozessablauf in einer Transaktion wird normal ausgeführt, bis die Transaktion beendet ist oder ein Abbruchereignis eintritt. Ein Abbruchereignis kann folgenden Ursprung haben:

  • Erreichen der Abbruch-Form innerhalb des Prozessablaufs.

  • Ein HRESULT-Fehler, der angegeben wird, um einen Abbruch in einer Portbindung zu verursachen.

  • Jede Bindungstechnologie kann auf der Systemebene ein Fehlerereignis einleiten, das die Transaktion abbricht. So kann z. B. beim Message Queuing ein Fehler bei der Platzierung einer Nachricht in eine Warteschlange auftreten.

  • Das XLANG-Ablaufplanungsmodul kann einen Fehler entdecken, der zur Folge hat, dass es eine Transaktion in einer angegebenen Instanz abbricht. So kann z. B. ein DTC-Fehler auftreten.

  • Das Pausieren eines Ablaufplanes kann den Abbruch aller Transaktionen in diesem Ablaufplan erforderlich machen.

  • Ein Timeout in den Transaktionseigenschaften.

Wenn eine Transaktion abgebrochen wurde, wird je nach dem in der Wiederholungsanzahl-Eigenschaft festgelegten Wert der Transaktionsgruppe eine Wiederholung der Transaktion von vorn versucht. Wenn nach der angegebenen Anzahl von Wiederholungsversuchen weiterhin ein Fehler auftritt, wird der Geschäftsprozess Bei Fehler von Transaktion aufgerufen. Dieser Bei Fehler von Transaktion-Code stellt einen strukturierten Ort zur Behandlung eines Transaktionsfehlers bereit.

Der Bei Fehler von Transaktion-Code muss keine Arbeit innerhalb der Transaktion rückgängig machen. Wenn die Ports an Transaktionsressourcen gebunden sind, bearbeitet der Distributed Transaction Coordinator das Rollback aller eingetragenen Aktionen innerhalb der Transaktion. Für Nichttransaktionsressourcen wird kein Rollback ausgeführt. Wenn die Transaktion in einer äußeren Transaktion geschachtelt ist und für diese geschachtelte Transaktion bereits ein Commit ausgeführt wurde, folgt der Geschäftsprozess dem Ablauf zum Geschäftsprozess Kompensierung für Transaktion für die geschachtelte Transaktion. Der Geschäftsprozess Kompensierung für Transaktion wird auf der Seite Kompensierung für Transaktion beschrieben. Dieser alternative Geschäftsprozess muss Aktionen enthalten, die ausgeführt werden können, um die Arbeit in der geschachtelten Transaktion rückgängig zu machen.

Wenn der Code Kompensierung für Transaktion oder Bei Fehler von Transaktion ausgeführt wurde, folgt der Geschäftsprozess dem Ablauf aus dem unteren Teil der Transaktion-Form auf der Geschäftsprozessseite. Aktionen innerhalb des Geschäftsprozesses, die nach einer Transaktion eintreten, empfangen keinen expliziten Hinweis, ob die Transaktion ausgeführt oder abgebrochen wurde. Sie können in einem Nachrichtenfeld auf der Seite Bei Fehler von Transaktion oder der Seite Kompensierung für Transaktion ein Kennzeichen festlegen, um einen expliziten Hinweis zu aktivieren.

Verwandte Themen

Behandeln von Ausnahmen

Logische Verzweigungen

Timeouts


Timeouts

Wenn eine Aktion in einer Transaktion eine erwartete Nachricht von einem Handelspartner nicht empfängt, wird der Fehler als Anwendungsfehler behandelt. Verwenden Sie befristete Transaktionen als Test für diesen Fehler.

In einem einfachen Wire-Transfer-Szenario kann eine befristete Transaktion beispielsweise die folgenden Aktionen in einer geschachtelten Transaktion enthalten:

  • Geld von einem Bankkonto abheben.

  • Wire-Transfer-Prozess initiieren.

Die folgende Abbildung zeigt Geld senden, eine kurzlebige Transaktion, die in einer langlebigen Transaktion namens Wire Transfer geschachtelt ist. Die geschachtelte Transaktion enthält die beiden Aktionen in dem einfachen Wire-Transfer-Szenario. Sobald die Wire Transfer initiieren-Aktion beendet wurde, verlässt der Geschäftsprozess die geschachtelte Transaktion. Wenn dies geschieht, wird das Commit für die geschachtelte Transaktion ausgeführt; das Geld wurde vom Bankkonto abgehoben und an ein Ziel gesendet. An diesem Punkt folgt der Geschäftsprozess der Warten auf Bestätigung-Aktion in der äußeren Transaktion.

In diesem Szenario wurde die Wire Transfer-Transaktion als befristete Transaktion konfiguriert. Wenn der Absender in dem angegebenen Zeitraum keine Bestätigung des Geldempfangs erhalten hat, wird die äußere Transaktion abgebrochen. Wenn dies geschieht, folgt der Geschäftsprozess dem Ablauf zur Seite Kompensierung für Geld senden für die geschachtelte Transaktion. Da das Commit für die geschachtelte Transaktion bereits ausgeführt wurde, muss der alternative Geschäftsprozess Aktionen beschreiben, die ausgeführt werden können, um den Geldbetrag dem Konto des Absenders gutzuschreiben. Wenn der auf der Seite Kompensierung für Geld senden beschriebene Geschäftsprozess ausgeführt wurde, folgt der Geschäftsprozess dem Ablauf zur Seite Bei Fehler von Wire Transfer für die äußere Transaktion. Diese Seite muss einen Geschäftsprozess enthalten, der die Ausnahmebehandlung für die äußere Transaktion beschreibt. In diesem Fall könnte der Geschäftsprozess darin bestehen, nachfolgend eine E-Mail zu senden, in der die Beteiligten über den Status der Übertragung informiert werden.

Verwandte Themen

Behandeln von Ausnahmen

Logische Verzweigungen

Transaktionsabbruchprozesse


Implementieren von Geschäftsprozessen

Die Implementierungsschablone enthält vier Formen, die den Technologien entsprechen, mit denen die Portimplementierung in einen Geschäftsprozess ausgeführt werden kann. Da jede Aktion entweder eine Nachricht an einen Port sendet oder eine Nachricht von einem Port erhält, variiert die semantische Bedeutung des Sendens und Empfangens von Nachrichten entsprechend der spezifischen Implementierungstechnologie.

Die Verwendung von Implementierungsformen beinhaltet zwei unterschiedliche Prozesse. Im ersten Prozess wird ein Port an eine Implementierungstechnologie gebunden. Grundsätzlich ist ein Port ein abstrakter Standort, an den eine Nachricht gesendet oder von dem eine Nachricht empfangen wird. Bindung des Ports an eine Implementierung definiert den Typ des Standortes, an den der Port gebunden ist. Im zweiten Prozess wird eine Aktion mit dem Port verbunden. Dieser Prozess definiert das Schema der Nachricht, die an den Port gesendet bzw. von diesem empfangen wird.

Der BizTalk-Orchestrierungs-Designer unterstützt vier Implementierungstechnologien:

  • COM-Komponenten. Diese Technologie ermöglicht die synchrone Kommunikation.

  • Windows-Skriptkomponenten. Diese Technologie ermöglicht die synchrone Kommunikation.

  • Message Queuing-Dienste. Diese Technologie ermöglicht die asynchrone Kommunikation.

  • BizTalk-Messagingdienste. Diese Technologie ermöglicht die asynchrone Kommunikation.

Die Entwurfsseite des BizTalk-Orchestrierungs-Designers wird durch eine Trennlinie in einen Geschäftsprozess-Entwurfsbereich auf der linken und einen Implementierungsbereich auf der rechten Seite getrennt. Ziehen Sie eine der Implementierungsformen zum Öffnen des Bindungs-Assistenten für Ports auf die rechte Seite der Trennlinie. Sie können diese Aufgabe auf der Geschäftsprozessseite, der Seite Bei Fehler von Transaktion und auf der Seite Kompensierung für Transaktion ausführen.

Anmerkung

  • Sie können im BizTalk-Orchestrierungs-Designer keinen Umschlag konfigurieren. Wenn Sie eine Flatfile an die BizTalk-Orchestrierung senden möchten, verwenden Sie deshalb den BizTalk-Editor, um den Inhalt der Flatfile in XML zu übersetzen. Sie können die XML-Datei dann an die BizTalk-Orchestrierung senden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu Portimplementierungen

  • Synchrone und asynchrone Kommunikation


Grundlegendes zu Portimplementierungen

Ein Port ist ein benannter Standort, der eine bestimmte Implementierung verwendet. In einem XLANG-Ablaufplan vereinfachen Ports die synchrone und die asynchrone Kommunikation und werden dazu verwendet, Nachrichten in oder aus dem Ablaufplan zu übertragen.

Im BizTalk-Orchestrierungs-Designer wird ein Port durch den Standort definiert, an den Nachrichten gesendet bzw. von dem Nachrichten empfangen werden, sowie von der Technologie, die zur Implementierung der Kommunikationsaktion verwendet wird. Ports sind auf der linken Seite an Aktionen im Geschäftsprozessablauf des XLANG-Ablaufplanes und auf der rechten Seite an eine Implementierungstechnologie gebunden, die zur Vereinfachung der erforderlichen Aktion verwendet werden kann. Der Standort wird durch den Namen des Ports eindeutig identifiziert.

Der Standort eines Ports hängt teilweise von der zur Implementierung des Ports verwendeten Technologie ab. Die folgende Tabelle zeigt die verfügbaren Portimplementierungen und den Standort, der der jeweiligen Portimplementierung zugeordnet ist.

Portimplementierung | Portstandort
COM-Komponente | Ein Zeiger auf eine aktivierte Instanz eines Objekts.
Windows-Skriptkomponente | Ein Zeiger auf eine aktivierte Instanz eines Objekts.
Message Queuing | Ein Warteschlangenpfadname zu einer Nachrichtenwarteschlange.
BizTalk-Messaging | Ein Kanalname für einen bestimmten BizTalk-Messagingkanal.

Ports können auf zweifache Weise beschrieben werden:

  • Statische Ports. Ein statischer Port erfordert, dass alle Informationen zum Portstandort und zur Portimplementierung für einen XLANG-Ablaufplan zur Entwurfszeit bereitgestellt werden. Der Designer, der den XLANG-Ablaufplan erstellt, muss den Standort kennen, an den Nachrichten gesendet bzw. von dem Nachrichten empfangen werden, und die Technologie, die zur Implementierung der Kommunikationsaktion ausgewählt wurde.

  • Dynamische Ports. Ein dynamischer Port erfordert, dass bestimmte Standortinformationen für einen XLANG-Ablaufplan zur Laufzeit bereitgestellt werden. Die Implementierung für einen dynamischen Port wird zur Entwurfszeit ausgewählt, der Standort des Ports bleibt jedoch bis zur Ausführung des XLANG-Ablaufplanes unbekannt. Der Standort für einen dynamischen Port wird über eine Nachricht bereitgestellt, welche die Standortinformationen an den Verweis für den Port übergibt. Diese Nachricht muss an einem Punkt im Prozessablauf des XLANG-Ablaufplanes eintreffen, bevor die Kommunikation, die diese Portimplementierung nutzt, verwendet werden kann.

    Wenn Sie einen dynamischen Port für eine Kommunikation verwenden möchten, und der XLANG-Ablaufplan hat keine Nachricht mit dem Portverweis erhalten, bevor der Ablaufplan versucht, die Aktion zu beenden, wird ein Fehler generiert.

Sowohl statische als auch dynamische Ports stellen Optionen für die synchrone und die asynchrone Kommunikation bereit, die Portimplementierungen für diese Kommunikationsarten sind jedoch je nach der von Ihnen zur Portimplementierung verwendeten Technologie unterschiedlich.

Jeder Port kann entweder statisch oder dynamisch sein, es können jedoch nicht alle Ports die synchrone und die asynchrone Kommunikation implementieren. Wenn Sie eine synchrone Kommunikationsaktion erstellen möchten, müssen Sie eine Portimplementierung für COM- oder Skriptkomponenten verwenden. Wenn Sie eine asynchrone Kommunikationsaktion erstellen möchten, müssen Sie eine Portimplementierung für Message Queuing oder BizTalk-Messaging verwenden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Statische und dynamische Ports

  • Verwenden der COM-Komponente-Form

  • Verwenden der Skriptkomponente-Form

  • Verwenden der Message Queuing-Form

  • Verwenden der BizTalk-Messaging-Form

Anmerkung

  • Wenn nicht auf XML basierende Textdokumente von einem XLANG-Ablaufplan an einem Port empfangen werden, der von Message Queuing oder BizTalk-Messaging implementiert wurde, werden Zeilenumbruchzeichen aus dem Dokument entfernt. Wenn eine MIME-codierte Nachricht an einen Ablaufplan gesendet wird, der die Daten später senden oder an anderer Stelle verwenden muss, enthält das vom Ablaufplan gesendete Dokument keine Zeilenumbruchzeichen und scheint kein gültiges MIME-codiertes Dokument zu sein. Falls dies ein Problem für Sie darstellt, sollten Sie eine benutzerdefinierte Komponente schreiben, die vom Ablaufplan aufgerufen wird, um die Zeilenumbruchzeichen im Dokument wiederherzustellen.

Verwandtes Thema

Synchrone und asynchrone Kommunikation


Statische und dynamische Ports

Statisches und dynamisches Portverhalten variieren, je nachdem, welchen Implementierungstyp Sie verwenden.

Portimplementierungen, die COM- oder Skriptkomponenten verwenden

Für eine Portimplementierung, die COM- oder Skriptkomponenten verwendet, stellen die statischen und dynamischen Eigenschaften dar, wie eine Komponente instanziiert wird:

  • Statisch. Für einen XLANG-Ablaufplan, der einen statischen Port verwendet, instanziiert das XLANG-Ablaufplanungsmodul die Komponente, die für diese Portimplementierung definiert wird.

  • Dynamisch. Bei einem XLANG-Ablaufplan, der einen dynamischen Port verwendet, wird die Komponente nicht vom XLANG-Ablaufplanungsmodul instanziiert. Stattdessen wartet der XLANG-Ablaufplan, bis eine andere Anwendung die Komponente instanziiert. Die Objektinstanz muss als Feld in einer Nachricht an den XLANG-Ablaufplan zurückgesendet werden. Auf der Datenseite muss eine Verbindung zwischen diesem Nachrichtenfeld und dem Portverweis auf denjenigen Port gezogen werden, der diese Implementierung verwendet. Der XLANG-Ablaufplan fängt sowohl die Methodenanforderung als auch die Methodenantwort von der Komponente ab.

Neben Statisch und Dynamisch gibt es eine dritte Option:

  • Keine Instanziierung. Für einen XLANG-Ablaufplan, der einen Port ohne Instanziierung verwendet, wird die Komponente nicht instanziiert und kein Code für den Methodenaufruf ausgeführt. Stattdessen gibt der XLANG-Ablaufplan diese Informationen als Antwort zurück, wenn er die Methodenanforderungsinformationen abfängt. Der Methodenaufruf wird umgangen.

Portimplementierungen, die Message Queuing verwenden

In einer Portimplementierung, die Message Queuing verwendet, werden die statischen und dynamischen Eigenschaften als statische und dynamische Warteschlangen dargestellt.

  • Statische Warteschlange. Ein statischer Port verwendet als statische Warteschlange eine bekannte, vorgegebene Warteschlange. Sie können diese Warteschlange zur Entwurfszeit zuweisen.

    Wenn Sie eine statische Warteschlange verwenden, können Sie auswählen, ob Sie eine bekannte Warteschlange verwenden möchten, die sich nie ändert, oder Sie können jedes Mal, wenn der XLANG-Ablaufplan ausgeführt wird, eine neue Instanz derselben Warteschlange erstellen. Die Warteschlange auf Instanzebene wird durch eine eindeutige Kennung identifiziert, die an den Namen der Warteschlange angehängt wird.

  • Dynamische Warteschlange. Ein dynamischer Port verwendet eine dynamische Warteschlange, die zur Entwurfszeit unbekannt ist. Die Informationen für eine dynamische Warteschlange müssen zur Laufzeit in einem Nachrichtenfeld bereitgestellt werden. Sie müssen auf der Datenseite eine Verknüpfung zwischen einem Nachrichtenfeld und dem Portverweis auf diesen Port erstellen. Wenn eine Nachricht mit dem Warteschlangennamen eintrifft, kann der XLANG-Ablaufplan die zugewiesene Warteschlange verwenden. Die Nachricht mit dem Warteschlangennamen muss eintreffen, bevor die Kommunikation verwendet werden kann, die diese Portimplementierung verwendet.

Portimplementierungen, die BizTalk-Messaging verwenden

In einer Portimplementierung, die BizTalk-Messaging verwendet, werden die statischen und dynamischen Eigenschaften als statische und dynamische Kanäle dargestellt. Dynamische Kanäle können nur beim Senden von Nachrichten verwendet werden. Dynamische Kanäle können nicht zum Empfangen von Nachrichten verwendet werden.

  • Statischer Kanal. Ein statischer Port verwendet als statischen Kanal einen bekannten, vorgegebenen Kanal. Sie können diesen Kanal zur Entwurfszeit zuweisen, so dass er sich nicht mehr ändert.

  • Dynamischer Kanal. Ein dynamischer Port sendet ein Dokument an ein Ziel, das zur Entwurfszeit unbekannt ist. Der Zielwert muss zur Laufzeit in einem Nachrichtenfeld bereitgestellt werden. Sie müssen auf der Datenseite eine Verknüpfung zwischen einem Nachrichtenfeld und dem Portverweis auf diesen Port erstellen. Wenn die Nachricht mit dem Zielwert eintrifft, sendet der XLANG-Ablaufplan das Dokument an einen Messagingkanal, der einem offenen Zielport zugeordnet ist. Der Port sendet die Nachricht dann an den zur Laufzeit angegebenen Zielwert. Beachten Sie, dass der Messagingkanal auf Eigene Organisation festgelegt werden muss, und geben Sie dieselbe Dokumentdefinition wie die zu sendende Nachricht an. Die Nachricht mit dem Zielwert muss eintreffen, bevor die Kommunikation verwendet werden kann, die diese Portimplementierung verwendet.

Bei einem Port, der einen dynamischen Kanal verwendet, kann der XLANG-Ablaufplan eher bestimmen, wohin eine Nachricht zur Laufzeit gesendet werden soll, als zu erfordern, dass ein vorgegebenes Ziel zur Entwurfszeit definiert werden muss. Diese Eigenschaft definiert, welcher Kanal verwendet wird, wenn der XLANG-Ablaufplan die Nachricht an die BizTalk-Messagingdienste übergibt.

Der dynamische Kanal sollte nicht mit einem offenen Kanal verwechselt werden, der im BizTalk-Messaging-Manager konfiguriert wird. Mit einem offenen Kanal kann die Quellorganisation zur Laufzeit anhand der Informationen im Dokument oder der mit dem Dokument gesendeten Parameter bestimmt werden. Diese Eigenschaft definiert die Quelle der Dokumente. Weitere Informationen zu offenen Kanälen finden Sie unter Grundlegendes zu Kanälen.

Die Nachricht, die an einen Port mit einem dynamischen Kanal übergeben wird, kann entweder einen offenen Kanal angeben oder einen Kanal, der bei der Übergabe der Kanalinformationen an die BizTalk-Messagingdienste nicht offen ist.

Anmerkung

  • Bei der Verwendung eines dynamischen Kanals wird empfohlen, dass Sie eine Aktion in Ihrem Ablaufplan zur Überprüfung von Adressen oder zur benutzerdefinierten Fehlerbehandlung hinzufügen. Auf diese Weise vermeiden Sie mögliche Datenverluste durch Adressen mit ungültigen Formaten, z. B. eine schlecht geformte Adresse oder eine Adresse in einem anderen Protokoll als HTTP, HTTPS oder SMTP.

Verwandte Themen

Implementieren von Ports

Synchrone und asynchrone Kommunikation

Grundlegendes zu Kanälen

Verwenden der BizTalk-Messaging-Form

Verwenden der COM-Komponente-Form

Verwenden der Message Queuing-Form

Verwenden der Skriptkomponente-Form


Verwenden der COM-Komponente-Form

Mit der COM-Komponente-Form können Sie vorgegebene Komponenten oder Anwendungen für die Ausführung von Aktionen in einem XLANG-Ablaufplan verwenden. Da die COM-Technologie synchron ist, gibt es stets einen bidirektionalen Nachrichtenfluss, wenn eine Aktion ausgeführt wird. Im Gegensatz dazu verläuft der Nachrichtenfluss bei einer asynchronen Technologie in einer Richtung.

Das XLANG-Ablaufplanungsmodul unterstützt das Senden oder Empfangen von Nachrichten mithilfe von Aktion-Formen. Wenn Sie im BizTalk-Orchestrierungs-Designer einen Port an eine COM-Komponente binden, wird der Port an eine Schnittstelle gebunden, die durch eine auf Ihrem System registrierte COM-Komponente implementiert wird.

Eine mit diesem Port verbundene Sendeaktion zeigt den Aufruf eines bestimmten Methodenaufrufs durch das XLANG-Ablaufplanungsmodul. Die Parameter IN und IN/OUT werden an den Port gesendet. Dafür wird eine Nachricht mit einem Schema, das durch die Parameter IN/OUT und OUT des Methodenaufrufs definiert wird, vom Port empfangen. Der Methodenaufruf wird von der an den Port gebundenen Schnittstelle unterstützt.

Eine mit diesem Port verbundene Empfangsaktion wartet, bis eine externe Anwendung einen Methodenaufruf an den Port startet. Die Parameter IN und IN/OUT definieren das Schema der Nachricht, die vom Port empfangen wird, und die Parameter IN/OUT und OUT definieren das Schema der Nachricht, die von diesem Port gesendet wird.

Für jede Aktion, die mit einem Port verbunden und an eine COM-Komponente gebunden ist, werden zwei Nachrichten ausgetauscht. Die Nachrichten identifizieren die an der Schnittstelle aufgerufene Methode. Das Schema der Nachrichten entspricht den Parametern IN und IN/OUT (und den Parametern IN/OUT und OUT) der Methodensignatur. Da der Zugriff auf die Typenbibliothek für die Komponenten möglich ist, kann der BizTalk-Orchestrierungs-Designer das Schema für diese Nachrichten automatisch erstellen, ohne den Benutzer nach dieser Information fragen zu müssen.

Wichtig

  • Gehen Sie sorgfältig vor, wenn Sie bei der Implementierung eines langlebigen Geschäftsprozesses COM-Komponenten verwenden. Wenn Sie Komponenten, die den Status beibehalten, in einem XLANG-Ablaufplan verwenden, sollte es sich um Komponenten handeln, die mithilfe der Schnittstelle IPersistStream oder IPersistStreamInit gespeichert werden können. Dadurch wird gewährleistet, dass der XLANG-Ablaufplan seinen Status zusammen mit dem Status der Komponenten speichern kann. XLANG-Ablaufpläne müssen den Status beibehalten und über einen langen Zeitraum stabil ausführen können. Bei der Verwendung von Komponenten, die den Status nicht beibehalten, wird bei jeder Aktivierung des XLANG-Ablaufplanes eine neue Instanz der Komponente erstellt. Die Verwendung von Komponenten, die den Status nicht beibehalten, sollte jedoch keine Auswirkungen auf das Resultat des Ablaufplanes haben.

Bei der Bindung handelt es sich um den Prozess, mit dem die Technologie zur Implementierung eines Ports festgelegt wird. Der Bindungs-Assistent für COM-Komponenten setzt sich aus den folgenden Seiten zusammen:

Willkommen beim Bindungs-Assistenten für COM-Komponenten

Auf der Seite Willkommen beim Bindungs-Assistenten für COM-Komponenten können Sie einen Port erstellen und benennen, für den Sie eine Implementierung definieren möchten.

Statische oder dynamische Kommunikation

Auf der Seite Statische oder dynamische Kommunikation können Sie definieren, wie die Komponente instanziiert werden soll. Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die statische und dynamische Kommunikation.

Informationen über statische oder dynamische Kanäle | Beschreibung
Statisch | Wählen Sie diese Option aus, wenn Sie dem XLANG-Ablaufplanungsmodul alle zur Ausführung der Implementierung erforderlichen Informationen zur Entwurfszeit bereitstellen können.
Dynamisch | Wählen Sie diese Option aus, wenn das XLANG-Ablaufplanungsmodul zur Laufzeit zusätzliche Informationen benötigt, um die Implementierung ausführen zu können.
Keine Instanziierung | Wählen Sie diese Option aus, damit der XLANG-Ablaufplan Daten mithilfe eines Methodenaufrufs empfangen kann, ohne die Komponente zu aktivieren. Wenn Sie die Option Keine Instanziierung auswählen, werden Methodenaufrufe an diese Komponente abgefangen, die Argumente vom XLANG-Ablaufplanungsmodul gespeichert, und der Aufruf geht an den aufrufenden Prozess zurück. Die Komponente wird nie instanziiert.

Klasseninformationen

Auf der Seite Klasseninformationen können Sie eine Klasse aus einer Liste registrierter Komponenten oder von einem Moniker auswählen.

Schnittstelleninformationen

Auf der Seite Schnittstelleninformationen können Sie die Schnittstelle auswählen, die Sie verwenden möchten. Diese Seite wird nur dann angezeigt, wenn die ausgewählte Klasse mehrere Schnittstellen enthält. Visual Basic-Komponenten besitzen stets nur eine Schnittstelle.

Methodeninformationen

Auf der Seite Methodeninformationen können Sie die Methoden auswählen, die Sie verwenden möchten. Diese Seite wird nur dann angezeigt, wenn die ausgewählte Klasse mehrere Methoden enthält.

Erweiterte Porteigenschaften

Auf der Seite Erweiterte Porteigenschaften können Sie die Einstellungen für Sicherheit, Transaktionsunterstützung, Statusverwaltungsunterstützung und Fehlerbehandlung konfigurieren.

Zu den Eigenschaften für die Statusverwaltungsunterstützung der COM-Komponente-Form gehören:

  • Persistentes Speichern des Status eines XLANG-Ablaufplanes vor dem Start einer Transaktion und nach Beenden einer Transaktion. Durch die so gewährleistete Beständigkeit sind alle Datenänderungen nach dem Commit im System dauerhaft. Dadurch ist es auch möglich, eine Transaktion bei einem Fehler zu wiederholen.

  • Optimieren der Instanzenverwaltung, indem das XLANG-Ablaufplanungsmodul die Möglichkeit erhält, den XLANG-Ablaufplan pausieren zu lassen und nach dem Eintreffen der vom Ablaufplan erwarteten Nachricht wieder zu aktivieren.

Sie können mit der COM-Komponente-Form authentifizierte Benutzerinformationen für die empfangenen Nachrichten anfordern.

Bereich Sicherheit

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Absenderidentitätsbestätigung.

Absenderidentitätsbestätigung | Beschreibung
Nicht erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass der XLANG-Ablaufplan eine Nachricht empfangen kann, ohne die Identität des Absenders zu kennen.
Optional | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul den Absender identifiziert, wenn die Komponente eine Nachricht empfängt (falls die Informationen verfügbar sind).
Erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul eine Nachricht nur dann empfangen kann, wenn es den Absender identifizieren kann.

Bereich Transaktionsunterstützung

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Transaktionsunterstützung.

Transaktionsunterstützung | Beschreibung
Deaktiviert | Für alle Nicht-COM+-Komponenten. Diese Option gibt an, dass die Komponente die COM-Transaktionsverwaltung ignoriert.
Nicht unterstützt | Nur für COM+-Komponenten. Diese Option gibt an, dass die Komponente nicht an einer Transaktion teilnimmt bzw. die Transaktionen anderer Komponenten nicht weitergibt.
Unterstützt | Nur für COM+-Komponenten. Diese Option gibt an, dass für den Fall, dass eine Transaktion einem Port zugeordnet ist, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Andernfalls hat die Komponente keine Transaktion.
Erforderlich | Nur für COM+-Komponenten. Diese Option gibt an, dass für den Fall, dass eine Transaktion einem Port zugeordnet ist, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Ist dem Port, an den die Komponente gebunden ist, keine Transaktion zugeordnet, wird eine neue Transaktion für die Komponente erstellt.
Neue Transaktion erforderlich | Nur für COM+-Komponenten. Diese Option gibt an, dass stets eine neue Transaktion für die Komponente erstellt wird.

Bereich Statusverwaltungsunterstützung

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Statusverwaltungsunterstützung.

Statusverwaltungsunterstützung | Beschreibung
Behält den Status nicht bei | Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Komponenteninstanz beendet, wenn diese pausiert. Wenn Sie diese Einstellung auswählen, erstellt das XLANG-Ablaufplanungsmodul bei Bedarf eine neue Komponenteninstanz, wenn der Ablaufplan aktiviert wird.
Behält den Status bei, unterstützt aber keine Persistenz | Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Ausführung der Komponenteninstanz nicht beenden soll. Falls bei der Pausierung der Anwendung ein Systemfehler auftritt, geht jeder in dieser Komponente beibehaltene Status verloren.
Behält den Status bei und unterstützt Persistenz | Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Komponenteninstanz aus dem Speicher entfernt und sie dann im Speicher wiederherstellt, indem es IPersistStream oder IPersistStreamInit für die Komponente während der Pausierung und dann erneut bei der Aktivierung aufruft.

Bereich Fehlerbehandlung

Aktivieren Sie im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul die Transaktion abbricht, wenn von einer Methode in einer Komponente ein Fehler zurückgegeben wird.

Anmerkungen

  • Wenn eine Aktion mit einem an eine COM-Komponente gebundenen Port kommuniziert und die angegebene Methode in der Komponente nicht vorhanden ist, endet die XLANG-Ablaufplaninstanz mit einem FailFast , und es erfolgt ein Eintrag ins Ereignisprotokoll.

  • Der BizTalk-Orchestrierungs-Designer unterstützt keine Bindung an eine COM-Komponentenmethode, die einen von IDispatch abgeleiteten Parameter enthält. Der BizTalk-Orchestrierungs-Designer unterstützt jedoch die Bindung an COM-Komponentenmethoden, die Parameter vom Typ IDispatch enthalten.

  • Sie sollten die Namen von Systemfeldern nicht als Parameternamen in COM-Komponenten verwenden, da es zu Namenskonflikten kommen kann. Weitere Informationen finden Sie unter Systemfelder.

  • Wenn eine Anwendung einen Verweis auf eine COM-Komponente in einem XLANG-Ablaufplan mithilfe einer IUnknown-Schnittstelle besitzt, wird dieser Verweis nach der Pausierung und Aktivierung der XLANG-Ablaufplaninstanz ungültig. Alle persistent speicherbaren COM-Komponenten werden ordnungsgemäß in den Status aktiviert, in dem sie sich zum Zeitpunkt der Pausierung befanden, den Schnittstellen werden jedoch neue Adressen zugewiesen. Dieses Verhalten wird erwartet und gilt als normal. Wenn zwei oder mehrere Nachrichtenfelder in einer einzelnen XLANG-Ablaufplaninstanz Zeiger auf dieselbe COM-Komponente enthalten und der Ablaufplan pausiert, so enthalten diese Nachrichtenfelder nach der Aktivierung Zeiger auf eine einzelne COM-Komponente. Es handelt sich jedoch nicht um dieselbe COM-Komponente wie vor der Pausierung. Stattdessen wurde eine neue COM-Komponente erstellt, die der vor der Pausierung vorhandenen COM-Komponente entspricht. Wenn die ursprüngliche COM-Komponente persistent speicherbar ist, besitzt die neue COM-Komponente denselben Status wie die ursprüngliche COM-Komponente vor der Pausierung.

  • Die Eindeutigkeit von Komponenten wird über While-Schleifen hinweg nicht beibehalten. Wenn eine Nachricht in einer While-Schleife ein Feld mit einem Zeiger auf eine COM-Komponente enthält und eine andere Nachricht außerhalb der While-Schleife ein Feld mit einem Zeiger auf dieselbe COM-Komponente enthält, haben beide Nachrichtenfelder nach der Pausierung und Aktivierung keine Zeiger mehr auf eine einzelne COM-Komponente. Die beiden Nachrichtenfelder besitzen dann Zeiger auf zwei separate COM-Komponenten, die der ursprünglichen COM-Komponente entsprechen. Wenn die ursprüngliche COM-Komponente persistent speicherbar ist, behalten die beiden neuen COM-Komponenten denselben Status bei wie die ursprüngliche COM-Komponente vor der Pausierung.

  • Wenn Sie den Port an eine Microsoft Visual Basic-Komponente binden möchten, müssen Sie dies tun, wenn Visual Basic sich nicht im Debugmodus befindet. Andernfalls wird die Komponente nicht im Bindungs-Assistenten für COM-Komponenten aufgeführt.

Verwandte Themen

Statische und dynamische Ports

Synchrone und asynchrone Kommunikation

Verwenden der BizTalk-Messaging-Form

Verwenden der Message Queuing-Form

Verwenden des Methodenkommunikations-Assistenten

Verwenden der Skriptkomponente-Form


Verwenden der Skriptkomponente-Form

Mit der Skriptkomponente-Form können Sie vorgegebene Windows-Skriptkomponenten für die Ausführung von Aktionen in einem XLANG-Ablaufplan verwenden. Da die Skriptkomponente synchron ist, gibt es stets einen bidirektionalen Nachrichtenfluss, wenn eine Aktion ausgeführt wird. Im Gegensatz dazu verläuft der Nachrichtenfluss bei einer asynchronen Technologie in einer Richtung.

Eine mit dem Port verbundene Sendeaktion zeigt den Aufruf eines bestimmten Methodenaufrufs durch das XLANG-Ablaufplanungsmodul. Die Parameter IN und IN/OUT werden an den Port gesendet. Dafür wird eine Nachricht mit einem Schema, das durch die Parameter IN/OUT und OUT des Methodenaufrufs definiert wird, vom Port empfangen. Der Methodenaufruf wird durch die an den Port gebundene Schnittstelle unterstützt.

Eine mit diesem Port verbundene Empfangsaktion wartet, bis eine externe Anwendung einen Methodenaufruf an den Port startet. Die Parameter IN und IN/OUT definieren das Schema der Nachricht, die vom Port empfangen wird, und die Parameter IN/OUT und OUT definieren das Schema der Nachricht, die von diesem Port gesendet wird.

Für jede Aktion, die mit einem Port verbunden und an eine Skriptkomponente gebunden ist, werden zwei Nachrichten ausgetauscht. Die Nachrichten identifizieren die an der Schnittstelle aufgerufene Methode. Das Schema der Nachrichten entspricht den Parametern IN und IN/OUT (und den Parametern IN/OUT und OUT) der Methodensignatur. Da der Zugriff auf die Typenbibliothek für die Komponenten möglich ist, kann der BizTalk-Orchestrierungs-Designer das Schema für diese Nachrichten automatisch erstellen, ohne den Benutzer nach dieser Information fragen zu müssen.

Das XLANG-Ablaufplanungsmodul setzt den Geschäftsprozess erst nach Rückgabe der Methode fort. Zum Senden einer Nachricht ruft das XLANG-Ablaufplanungsmodul die angegebene Methode einer Windows-Skriptkomponente auf.

Ziehen Sie zum Erstellen einer neuen Skriptkomponentenbindung die Skriptkomponente-Form aus der Implementierungsschablone auf die BizTalk-Orchestrierungsentwurfsseite auf die rechte Seite der Trennlinie. Klicken Sie mit der rechten Maustaste auf die Skriptkomponente-Form, und klicken Sie dann auf Eigenschaften, um eine vorhandene Skriptkomponente zu bearbeiten. Durch beide Aktionen wird der Bindungs-Assistent für Skriptkomponenten gestartet. Bei der Bindung handelt es sich um den Prozess, mit dem die Technologie zur Implementierung eines Ports festgelegt wird. Der Bindungs-Assistent für Skriptkomponenten setzt sich aus den folgenden Seiten zusammen:

Willkommen beim Bindungs-Assistenten für Skriptkomponenten

Auf der Seite Willkommen beim Bindungs-Assistenten für Skriptkomponenten können Sie einen Port erstellen und benennen, für den Sie eine Implementierung definieren möchten.

Statische oder dynamische Kommunikation

Auf der Seite Statische oder dynamische Kommunikation können Sie definieren, wie die Komponente instanziiert werden soll. Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die statische und dynamische Kommunikation.

Informationen über statische oder dynamische Kanäle | Beschreibung
Statisch | Wählen Sie diese Option aus, wenn Sie dem XLANG-Ablaufplanungsmodul alle zur Ausführung der Implementierung erforderlichen Informationen zur Entwurfszeit bereitstellen können.
Dynamisch | Wählen Sie diese Option aus, wenn das XLANG-Ablaufplanungsmodul zur Laufzeit zusätzliche Informationen benötigt, um die Implementierung ausführen zu können.
Keine Instanziierung | Wählen Sie diese Option aus, damit der XLANG-Ablaufplan Daten mithilfe eines Methodenaufrufs empfangen kann, ohne die Komponente zu aktivieren. Wenn Sie die Option Keine Instanziierung auswählen, werden Methodenaufrufe an diese Komponente abgefangen, die Argumente vom XLANG-Ablaufplanungsmodul gespeichert, und der Aufruf geht an den Aufrufer zurück. Die Komponente wird nie instanziiert.

Skriptdatei angeben

Auf der Seite Skriptdatei angeben können Sie den Pfad zu der Windows-Skriptkomponentendatei (WSC) eingeben, die Sie verwenden möchten.

Informationen über Komponenteninstanziierung

Auf der Seite Informationen über Komponenteninstanziierung können Sie angeben, ob das XLANG-Ablaufplanungsmodul zur Instanziierung der Skriptkomponente einen Moniker oder eine Programm-ID verwenden soll.

Methodeninformationen

Auf der Seite Methodeninformationen können Sie die Methoden auswählen, die zur ausgewählten Klasse gehören.

Erweiterte Porteigenschaften

Auf der Seite Erweiterte Porteigenschaften können Sie die Einstellungen für Sicherheit, Transaktionsunterstützung und Fehlerbehandlung konfigurieren. Mit der Skriptkomponente-Form können sie authentifizierte Benutzerinformationen für die empfangenen Nachrichten anfordern.

Bereich Sicherheit

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Absenderidentitätsbestätigung.

Absenderidentitätsbestätigung | Beschreibung
Nicht erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass der XLANG-Ablaufplan eine Nachricht empfangen kann, ohne die Identität des Absenders zu kennen.
Optional | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul den Absender identifiziert, wenn die Komponente eine Nachricht empfängt (falls die Informationen verfügbar sind).
Erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul eine Nachricht nur dann empfangen kann, wenn es den Absender identifizieren kann.

Bereich Transaktionsunterstützung

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Transaktionsunterstützung.

Transaktionsunterstützung | Beschreibung
Deaktiviert | Für alle Nicht-COM+-Komponenten. Diese Option gibt an, dass die Komponente die COM-Transaktionsverwaltung ignoriert.
Nicht unterstützt | Diese Option ist nur verfügbar, wenn das Skript als COM+-Komponente installiert ist. Diese Auswahl gibt an, dass die Komponente nicht an einer Transaktion teilnimmt bzw. die Transaktionen anderer Komponenten nicht weitergibt.
Unterstützt | Diese Option ist nur verfügbar, wenn das Skript als COM+-Komponente installiert ist. Diese Option gibt an, dass für den Fall, dass eine Transaktion einem Port zugeordnet ist, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Andernfalls hat die Komponente keine Transaktion.
Erforderlich | Diese Option ist nur verfügbar, wenn das Skript als COM+-Komponente installiert ist. Diese Option gibt an, dass für den Fall, dass eine Transaktion einem Port zugeordnet ist, an den die Komponente gebunden ist, die Komponente in die Transaktion eingeschlossen wird. Ist dem Port, an den die Komponente gebunden ist, keine Transaktion zugeordnet, wird eine neue Transaktion für die Komponente erstellt.
Neue Transaktion erforderlich | Diese Option ist nur verfügbar, wenn das Skript als COM+-Komponente installiert ist. Diese Option gibt an, dass stets eine neue Transaktion für die Komponente erstellt wird.

Bereich Fehlerbehandlung

Aktivieren Sie im Fehlerbehandlungsbereich das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul die Transaktion abbricht, wenn von einer Methode in einer Komponente ein Fehler zurückgegeben wird. Wenn Sie die Seiten Bei Fehler von Transaktion und Kompensierung für Transaktion verwenden möchten, müssen Sie diese Option für das XLANG-Ablaufplanungsmodul auswählen. Wenn diese Option nicht ausgewählt ist, können keine der auf diesen Seiten definierten Wiederherstellungsprozesse für Fehler ausgeführt werden.

Wichtig

  • Bei Verwendung von Windows-Skriptkomponenten müssen die folgenden Regeln beachtet werden:
    • Argumente müssen per Deklaration als Referenzen und nicht als Werte übergeben werden.

    • VBScript-Subroutinen werden nicht unterstützt. Es werden nur Funktionen unterstützt.

    • Innerhalb einer einzelnen WSC-Datei können nicht mehrere Komponenten verwendet werden.

Anmerkungen

  • Wenn eine Aktion mit einem an eine Skriptkomponente gebundenen Port kommuniziert und die angegebene Methode in der Komponente nicht vorhanden ist, endet die XLANG-Ablaufplaninstanz mit einem FailFast , und es erfolgt ein Eintrag ins Ereignisprotokoll.

  • Vom XLANG-Ablaufplanungsmodul ausgeführte Skriptkomponenten können erst geändert werden, wenn das XLANG-Ablaufplanungsmodul und der Windows Script Host beendet wurden.

Verwandte Themen

Statische und dynamische Ports

Synchrone und asynchrone Kommunikation

Verwenden der BizTalk-Messaging-Form

Verwenden der COM-Komponente-Form

Verwenden der Message Queuing-Form

Verwenden des Methodenkommunikations-Assistenten


Verwenden der Message Queuing-Form

Mit der Message Queuing-Form kann ein XLANG-Ablaufplan mit einem anderen XLANG-Ablaufplan (oder mit einer Anwendung) mithilfe einer Warteschlange auf eine flexibel verbundene Weise kommunizieren. Nachrichten werden in einer Warteschlange abgelegt und dann gelesen, um die Kommunikation zwischen XLANG-Ablaufplänen und Anwendungen zu ermöglichen. Ein einzelner XLANG-Ablaufplan kann mehrere Ports verwenden, die an die Message Queuing-Form gebunden sind.

Wenn ein Port an eine Message Queuing-Form gebunden ist, ist er auch an eine Nachrichtenwarteschlange gebunden. Der Port kann an eine benannte Warteschlange oder an eine instanzbezogene Warteschlange gebunden sein. Wenn ein Port an eine Warteschlange auf Instanzebene gebunden ist, wird für jede Instanz dieses XLANG-Ablaufplanes eine eindeutige Warteschlange erstellt und verwendet. Warteschlangen auf Instanzebene bieten eine einfache Möglichkeit für einen XLANG-Ablaufplan, über eine separate Warteschlange für jede XLANG-Ablaufplaninstanz zu verfügen.

Wenn eine Aktion mit einem an eine Nachrichtenwarteschlange gebundenen Port verbunden ist, muss die von der Aktion gesendete bzw. empfangene Nachricht definiert werden. Da in einer Warteschlange mehrere Nachrichtentypen gespeichert werden können, hilft der Nachrichtentyp, den Typ der Nachricht zu identifizieren, die von der Aktion empfangen werden soll. Während einer Sendeaktion wird der Nachrichtentyp in der Bezeichnungseigenschaft der Nachricht markiert, wenn diese in die Warteschlange geschrieben wird.

Die Message Queuing-Form stellt den Message Queuing-Dienst zum Senden oder Empfangen von Nachrichten dar. Zum Empfang einer Nachricht benötigt das XLANG-Ablaufplanungsmodul den Namen der verwendeten Warteschlange sowie den Namen des Stammelements des in dieser Nachricht enthaltenen XML-Schemas. Zum Senden einer Nachricht benötigt das XLANG-Ablaufplanungsmodul den Namen der Warteschlange, die zum Übertragen von Nachrichten verwendet wird.

Wenn Sie eine XLANG-Ablaufplaninstanz zur Verwendung von Message Queuing für den Empfang von Nachrichten konfigurieren, können Sie den Verwenden des Assistenten für XML-Kommunikation verwenden, um XML oder Zeichenfolge als Zielformat festzulegen.

Ziehen Sie die Message-Queuing-Form zum Erstellen einer neuen Message Queuing-Bindung aus der Implementierungsschablone auf die BizTalk-Orchestrierungsentwurfsseite rechts neben die Trennlinie. Klicken Sie mit der rechten Maustaste auf die Message Queuing-Form, und klicken Sie dann auf Eigenschaften, um eine vorhandene Message Queuing-Implementierung zu bearbeiten. Durch beide Aktionen wird der Bindungs-Assistent für Message Queuing gestartet. Bei der Bindung handelt es sich um den Prozess, mit dem die Technologie zur Implementierung eines Ports festgelegt wird. Der Bindungs-Assistent für Message Queuing setzt sich aus den folgenden Seiten zusammen:

Willkommen beim Bindungs-Assistenten für Message Queuing

Auf der Seite Willkommen beim Bindungs-Assistenten für Message Queuing können Sie einen Port erstellen und benennen, für den Sie eine Implementierung definieren möchten, oder Sie wählen einen vorhandenen, ungebundenen Port aus.

Informationen über statische oder dynamische Warteschlangen

Auf der Seite Informationen über statische oder dynamische Warteschlangen können Sie angeben, ob die Nachrichtenwarteschlange zur Entwurfs- oder zur Laufzeit definiert werden soll. Wählen Sie eine der folgenden Optionen:

  • Wählen Sie Statische Warteschlange aus, wenn Sie Warteschlangeninformationen zur Entwurfszeit bereitstellen können.

  • Wählen Sie Dynamische Warteschlange aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul Informationen zur Bestimmung des Warteschlangennamens zur Laufzeit von einer externen Quelle erhalten soll.

Warteschlangeninformationen

Auf der Seite Warteschlangeninformationen können Sie eine neue Warteschlange erstellen oder eine vorhandene Warteschlange angeben. Wählen Sie eine der folgenden Optionen:

  • Wählen Sie Neue Warteschlange für jede Instanz erstellen, wenn das XLANG-Ablaufplanungsmodul eine Warteschlange für jede XLANG-Ablaufplaninstanz erstellen soll.

  • Wählen Sie Bekannte Warteschlange für alle Instanzen verwenden, wenn das XLANG-Ablaufplanungsmodul eine bekannte Warteschlange verwenden soll.

Erweiterte Porteigenschaften

Auf der Seite Erweiterte Porteigenschaften können Sie die Sicherheitseinstellungen konfigurieren und festlegen, ob die Transaktionsunterstützung aktiviert werden soll oder nicht. Sie können mit der Message Queuing-Form authentifizierte Benutzerinformationen für die empfangenen Nachrichten anfordern.

Bereich Sicherheit

Die folgende Tabelle enthält eine Liste und Beschreibungen der Einstellungen für die Absenderidentitätsbestätigung.

Absenderidentitätsbestätigung | Beschreibung
Nicht erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass der XLANG-Ablaufplan eine Nachricht empfangen kann, ohne die Identität des Absenders zu kennen.
Optional | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul den Absender identifiziert, wenn die Komponente eine Nachricht empfängt (falls die Informationen verfügbar sind).
Erforderlich | Wählen Sie diese Option aus, wenn Sie möchten, dass das XLANG-Ablaufplanungsmodul eine Nachricht nur dann empfangen kann, wenn es den Absender identifizieren kann.

Sie können auch das Kontrollkästchen Zum Steuern der Warteschlange eine Windows-Gruppe oder einen Benutzernamen verwenden aktivieren bzw. deaktivieren. Bei Aktivierung des Kontrollkästchens müssen Sie den Namen des Benutzers oder der Gruppe eingeben, für den oder die die Berechtigung gegeben ist, Nachrichten in die Warteschlange zu stellen. Diese Option ist nur bei Verwendung einer statischen Warteschlange verfügbar.

Bereich Transaktionsunterstützung

Aktivieren Sie im Bereich Transaktionsunterstützung das Kontrollkästchen Für diese Warteschlange sind Transaktionen erforderlich, um die Transaktionsunterstützung zu aktivieren.

Anmerkungen

  • Zurzeit ermöglicht das unterstützte Namensformat für Warteschlangen keinen Remotezugriff auf eine Warteschlange auf einem anderen Computer. Verwenden Sie öffentliche anstatt private Warteschlangen, wenn ein XLANG-Ablaufplan mit einer Anwendung auf einem Remotecomputer kommuniziert.

  • Wenn eine Aktion mit einem an Message Queuing gebundenen Port kommuniziert und die angegebene Warteschlange für die Bindung nicht vorhanden ist, wird die XLANG-Ablaufplaninstanz sofort beendet und es erfolgt ein Eintrag ins Ereignisprotokoll.

  • Es ist wichtig, dass das XLANG-Ablaufplanungsmodul in der Lage ist, festzustellen, ob es sich um eine Transaktionswarteschlange handelt oder nicht. Wenn sich eine Warteschlange in einem Transaktionskontext befindet und eine Nachricht an die Warteschlange gesendet wird, muss das XLANG-Ablaufplanungsmodul wissen, ob die Transaktion zur Kommunikation mit der Warteschlange verwendet werden soll. Wenn für die Portbindungskonfiguration das Kontrollkästchen Für diese Warteschlange sind Transaktionen erforderlich aktiviert ist, beendet das XLANG-Ablaufplanungsmodul sofort den XLANG-Ablaufplan mit einem FailFast, wenn zur Laufzeit festgestellt wird, dass die Warteschlange keinen Transaktionskontext besitzt.

Verwandte Themen

Statische und dynamische Ports

Synchrone und asynchrone Kommunikation

Verwenden der BizTalk-Messaging-Form

Verwenden der COM-Komponente-Form

Verwenden der Skriptkomponente-Form

Verwenden des Assistenten für XML-Kommunikation


Verwenden der BizTalk-Messaging-Form

Die BizTalk-Messaging-Form stellt BizTalk-Messagingdienste dar, mit denen Nachrichten zwischen BizTalk-Orchestrierungsdiensten und BizTalk-Messagingdiensten ausgetauscht werden. Das XLANG-Ablaufplanungsmodul benötigt die von den BizTalk-Messagingdiensten zum Empfangen von Dokumenten verwendete HTTP-URL-Adresse, den Namen des Kanals und den Nachrichtentyp der ausgehenden Dokumentdefinition, um eine Nachricht zu empfangen. Für das Empfangen von Dokumenten zur XLANG-Ablaufplanaktivierung ist lediglich der Nachrichtentyp der Dokumentdefinition erforderlich. Das XLANG-Ablaufplanungsmodul benötigt den Namen des Kanals und den Nachrichtentyp der eingehenden Dokumentdefinition, um eine Nachricht zu senden. Weitere Informationen zum Austausch von Nachrichten zwischen BizTalk-Orchestrierungsdiensten und BizTalk-Messagingdiensten finden Sie unter Integrieren der BizTalk-Dienste.

Wichtig

  • Wenn Sie einen Port konfigurieren, um beim Eintreffen einer Nachricht einen neuen XLANG-Ablaufplan zu aktivieren, müssen Sie folgende Einschränkungen berücksichtigen:
    • Es kann nur ein Port in einem Ablaufplan verwendet werden, um den XLANG-Ablaufplan beim Eintreffen der Nachricht zu aktivieren.

    • Es kann nur eine Aktion über diesen Port empfangen werden.

    • Diese eine Aktion darf sich nicht in einer Schleife befinden.

    • Sie können keine Datenflussverbindung vom Portverweis auf diesen Port zu einer anderen Nachricht im Ablaufplan zeichnen.

Ziehen Sie die BizTalk-Messaging-Form zum Erstellen einer neuen Message Queuing-Bindung aus der Implementierungsschablone auf die BizTalk-Orchestrierungsentwurfsseite rechts neben die Trennlinie. Klicken Sie mit der rechten Maustaste auf die BizTalk-Messaging-Form, und klicken Sie dann auf Eigenschaften, um eine vorhandene BizTalk-Messaging-Implementierung zu bearbeiten. Durch beide Aktionen wird der Bindungs-Assistent für BizTalk-Messaging gestartet. Bei der Bindung handelt es sich um den Prozess, mit dem die Technologie zur Implementierung eines Ports festgelegt wird. Der Bindungs-Assistent für BizTalk-Messaging setzt sich aus den folgenden Seiten zusammen:

Willkommen beim BizTalk-Bindungs-Assistenten für Messaging

Auf der Seite Willkommen beim BizTalk-Bindungs-Assistenten für Messaging können Sie einen Port erstellen und benennen, für den Sie eine Implementierung definieren möchten, oder Sie wählen einen vorhandenen, ungebundenen Port aus.

Kommunikationsrichtung

Auf der Seite Kommunikationsrichtung können Sie angeben, ob der Port für das Senden oder das Empfangen von Nachrichten konfiguriert werden soll.

Kommunikation über statische oder dynamische Kanäle

Die Seite Informationen über statische oder dynamische Kanäle wird nur angezeigt, wenn Sie auf der Seite Willkommen beim BizTalk-Bindungs-Assistenten für Messaging die Option Senden auswählen. Auf der Seite Informationen über statische oder dynamische Kanäle können Sie angeben, ob das XLANG-Ablaufplanungsmodul einen statischen Kanal verwenden soll, der zur Entwurfszeit definiert wird, oder einen dynamischen Kanal, der zur Laufzeit definiert wird.

Informationen über die XLANG-Ablaufplanaktivierung

Auf der Seite Informationen über die XLANG-Ablaufplanaktivierung können Sie angeben, ob bei dieser Empfangsaktion eine XLANG-Ablaufplaninstanz aktiviert werden soll. Wenn Sie Ja auswählen, wird der BizTalk-Bindungs-Assistent für Messaging beendet. Wenn Sie Nein auswählen, wird die Seite Kanalinformationen angezeigt.

Kanalinformationen

Auf der Seite Kanalinformationen können Sie den Namen des Kanals sowie die vom BizTalk-Messagingdienst zum Empfang von Dokumenten verwendete HTTP-URL-Adresse angeben.

Anmerkungen

  • Wenn eine Aktion mit einem über BizTalk-Messaging gebundenen Port kommuniziert und der für diese Bindung angegebene Kanal nicht existiert, endet die XLANG-Ablaufplaninstanz mit einem FailFast und einem Eintrag im Ereignisprotokoll.

  • Das Einschließen separater Sende- und Empfangsbindungen für BizTalk-Messaging in einer Transaktion kann zu einer Deadlocksituation führen, die ein Fehlschlagen der Transaktion verursacht.

  • Aktionsereignisse, die Nachrichten zugeordnet sind, die von einem XLANG-Ablaufplan verarbeitet und von BizTalk-Messagingdiensten gesendet oder empfangen werden, können in der Überwachungsdatenbank überwacht werden. Weitere Informationen finden Sie unter Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank.

Verwandte Themen

Statische und dynamische Ports

Synchrone und asynchrone Kommunikation

Verwenden der COM-Komponente-Form

Verwenden der Message Queuing-Form

Verwenden der Skriptkomponente-Form

Verwenden des Assistenten für XML-Kommunikation


Synchrone und asynchrone Kommunikation

Jede Kommunikation mit einer COM-Komponenten- oder Skriptkomponentenimplementierung ist synchron. Wenn Sie einen Kommunikationsfluss zu einem Port erstellen möchten, der eine COM-Komponenten- oder Skriptkomponentenimplementierung verwendet, müssen Sie den Methodenkommunikations-Assistenten verwenden.

Jede Kommunikation mit einem ungebundenen Port oder einer Message Queuing- oder BizTalk-Messaging-Implementierung ist asynchron. Wenn Sie einen Kommunikationsfluss zu einem Port erstellen möchten, der eine Message Queuing- oder BizTalk-Messaging-Implementierung verwendet, oder wenn Sie einen Kommunikationsfluss zu einem ungebundenen Port erstellen möchten, müssen Sie den Assistenten für XML-Kommunikation verwenden.

In der folgenden Abbildung und dem folgenden Text wird beschrieben, welche Funktionen der XLANG-Ablaufplan für die vier möglichen Kommunikationsaktionen ausführt.

synchrone und asynchrone Kommunikation - Übersicht

  1. Synchrone Empfangsaktion
    1. Der XLANG-Ablaufplan wartet, bis eine andere Anwendung einen Methodenaufruf sendet und eine Komponente instanziiert.

    2. Der Ablaufplan fängt den Methodenaufruf ab.

    3. Der Ablaufplan wartet, bis die Komponente die Methodenantwort zurückgibt.

    4. Der Ablaufplan fängt die Methodenantwort ab.

    5. Der Ablaufplan fährt mit der nächsten Aktion im Geschäftsprozessablauf fort.
  2. Synchrone Sendeaktion
    1. Der XLANG-Ablaufplan initiiert den Methodenaufruf und instanziiert die Komponente.

    2. Der Ablaufplan wartet, bis die Komponente die Methodenantwort zurückgibt.

    3. Der Ablaufplan empfängt die Methodenantwort.

    4. Der Ablaufplan fährt mit der nächsten Aktion im Geschäftsprozessablauf fort.
  3. Asynchrone Empfangsaktion
    1. Der XLANG-Ablaufplan wartet, bis eine andere Anwendung eine Nachricht an eine Nachrichtenwarteschlange oder einen BizTalk-Messagingkanal sendet.

    2. Der XLANG-Ablaufplan empfängt die Nachricht von der Nachrichtenwarteschlange oder vom Kanal.

    3. Der Ablaufplan fährt mit der nächsten Aktion im Geschäftsprozessablauf fort.
  4. Asynchrone Sendeaktion
    1. Der XLANG-Ablaufplan sendet eine Nachricht an eine Nachrichtenwarteschlange oder einen BizTalk-Messagingkanal.

    2. Der Ablaufplan fährt mit der nächsten Aktion im Geschäftsprozessablauf fort.

    3. Eine andere Anwendung empfängt die Nachricht von der Nachrichtenwarteschlange oder vom BizTalk-Messagingkanal.

Anmerkungen

  • Bei der synchronen Empfangsaktion gibt es einen Sonderfall. Wenn Sie Keine Instanziierung im Bindungs-Assistenten für COM- oder für Skriptkomponenten auswählen, wird die Komponente nicht instanziiert und kein Code für den Methodenaufruf ausgeführt. Stattdessen gibt der XLANG-Ablaufplan diese Informationen als Antwort zurück, wenn er die Methodenanforderungsinformationen abfängt. Der Methodenaufruf wird umgangen. Weitere Informationen zu statischen und dynamischen Ports und zum Bindungs-Assistenten für COM- und für Skriptkomponenten finden Sie in folgenden Themen:
    • Statische und dynamische Ports

    • Implementieren von Ports

    • Verwenden der COM-Komponente-Form

    • Verwenden der Skriptkomponente-Form
  • Aktionsereignisse, die Nachrichten zugeordnet sind, die von einem XLANG-Ablaufplan verarbeitet und von BizTalk-Messagingdiensten gesendet oder empfangen werden, können in der Überwachungsdatenbank überwacht werden. Weitere Informationen finden Sie unter Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank.

Dieser Abschnitt enthält Informationen zu folgenden Themen:

  • Verwenden des Methodenkommunikations-Assistenten

  • Synchrone Kommunikation

  • Verwenden des Assistenten für XML-Kommunikation

  • Asynchrone Kommunikation

Verwandte Themen

Implementieren von Ports

Statische und dynamische Ports

Verwenden der COM-Komponente-Form

Verwenden der Skriptkomponente-Form


Verwenden des Methodenkommunikations-Assistenten

Sie können den Methodenkommunikations-Assistenten auf der Geschäftsprozessseite, der Seite Bei Fehler von Transaktion und auf der Seite Kompensierung für Transaktion verwenden, um den Nachrichtenfluss zwischen einer Aktion-Form und einer der Formen COM-Komponente oder Skriptkomponente zu definieren. Wenn eine Nachricht gesendet wird, ruft der XLANG-Ablaufplan die Methode mit der _in-Nachricht auf und wartet dann auf den Empfang der _out-Nachricht von der Komponente. Wenn eine Nachricht empfangen werden soll, wartet der XLANG-Ablaufplan, bis eine andere Anwendung die _in-Nachricht an die Methode sendet (durch den Aufruf einer Methode am Port), und wartet dann, bis die _out-Nachricht der Komponente an die andere Anwendung zurückgesendet wird.

Anmerkungen

  • Hinweis für Visual Basic-Programmierer: die Parameter ByVal erscheinen nur in der _in-Nachricht. Alle anderen Parameter erscheinen in der _in- und der _out-Nachricht.

  • Hinweis für C-Programmierer: Die Parameter IN erscheinen in der _in-Nachricht, OUT in der _out-Nachricht, und die Parameter IN,OUT erscheinen in beiden Nachrichten.

  • Hinweis für Visual Basic-Programmierer und C-Programmierer: Wenn ein Parameter in der _in- und der _out-Nachricht erscheint, enthält die _in-Nachricht den Inhalt, der in die Methode gesendet wurde, und die _out-Nachricht enthält den Inhalt, der von der Methode zurückgegeben wurde.

Ziehen Sie das rechte Kontrollhandle ( Kontrollhandle) einer Aktion-Form auf den Verbindungspunkt ( Verbindungspunkt) eines an eine der Formen COM-Komponente oder Skriptkomponente gebundenen Ports, um den Methodenkommunikations-Assistenten zu starten. Der Methodenkommunikations-Assistent setzt sich aus den folgenden Seiten zusammen:

Willkommen beim Methodenkommunikations-Assistenten

Auf der Seite Willkommen beim Methodenkommunikations-Assistenten können Sie angeben, ob das XLANG-Ablaufplanungsmodul eine Methode aufrufen oder auf einen Methodenaufruf warten soll. Wenn Sie angeben, dass das XLANG-Ablaufplanungsmodul auf einen Methodenaufruf warten soll, können Sie einen Wert für die Wartezeit in Sekunden festlegen, die das XLANG-Ablaufplanungsmodul auf das Eintreffen der Nachricht warten soll. Wenn dieser Wert 180 Sekunden oder weniger beträgt, muss die XLANG-Ablaufplaninstanz nie in der Persistenzdatenbank pausieren. Ist der Wert höher als 180 Sekunden, muss die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank pausieren. Der Standardwert für die Wartezeit ist Null und weist darauf hin, dass das Eintreffen der Nachricht sofort erwartet wird.

Wenn eine XLANG-Ablaufplaninstanz aus einem anderen Grund aktiviert wird als aufgrund des Eintreffens einer von einer Aktion erwarteten Nachricht (und die XLANG-Ablaufplaninstanz dann in einen Ruhezustand eintritt), wird der angegebene Wartezeitwert verwendet, um zu bestimmen, ob die XLANG-Ablaufplaninstanz sofort pausiert. Dies kann beispielsweise dann der Fall sein, wenn eine parallele Verzweigung eine Nachricht empfängt, auf die sie gewartet hat, oder wenn der Neustart eines Computers dazu führt, dass alle XLANG-Ablaufplaninstanzen aktiviert werden. In dieser Situation wird der Wert der Wartezeit von dem Zeitpunkt an ausgewertet, an dem die XLANG-Ablaufplaninstanz in einen Ruhezustand eintritt. Wenn der Zeitraum vom Beginn der ursprünglichen Wartezeit (zusammen mit dem Wartezeitwert) des XLANG-Ablaufplanungsmoduls bis zu dem Zeitpunkt, an dem das XLANG-Ablaufplanungsmodul nach der Aktivierung in den Ruhezustand eingetreten ist, über 180 Sekunden beträgt, pausiert die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank. Dieser Punkt kann in der XLANG-Ablaufplaninstanz lange nach dem Beginn der Überwachung des Eintreffens einer Nachricht durch das XLANG-Ablaufplanungsmodul eintreten.

Nachrichteninformationen

Auf der Seite Nachrichteninformationen können Sie angeben, ob eine neue Nachricht oder ein Verweis auf eine vorhandene Nachricht erstellt werden soll. Wenn Sie festlegen, dass ein Verweis auf eine vorhandene Nachricht erstellt werden soll, können Sie aus einer Liste vorher erstellter Nachrichten wählen, die von Methoden gesendet bzw. empfangen wurden und bereits über entsprechende Nachrichtenformen verfügen. Wenn die gewünschte Nachricht in der Liste nicht enthalten ist, geben Sie an, dass eine neue Nachricht erstellt werden soll, und definieren Sie den Datenfluss der neuen Nachricht.

Informationen über die Nachrichtenspezifikation

Auf der Seite Informationen über die Nachrichtenspezifikation können Sie eine Nachrichtenspezifikation für die Nachricht auswählen, die Sie auf der Seite Nachrichteninformationen erstellt bzw. auf die Sie auf dieser Seite verwiesen haben.

Verwandte Themen

Asynchrone Kommunikation

Pausierung und Aktivierung

Persistenz

Synchrone und asynchrone Kommunikation

Synchrone Kommunikation

Verwenden des Assistenten für XML-Kommunikation


Synchrone Kommunikation

Die einzigen Methoden, die für die synchrone Kommunikation verfügbar sind, sind die für die Portimplementierung ausgewählten Methoden. Methoden aus anderen Portimplementierungen sowie XML-Nachrichten aus asynchronen Kommunikationsflüssen können nicht verwendet werden. Führen Sie den Methodenkommunikations-Assistenten erneut aus, um die verfügbaren Methoden zu ändern, und wählen Sie verschiedene Methoden aus.

Die Parameter IN und OUT werden automatisch durch die Parameteranforderungen der von Ihnen ausgewählten Methode bestimmt. Beide Parameterlisten enthalten jeweils den Namen und Datentyp des Parameters. Neben den der Methode zugeordneten Parametern enthält eine Nachricht auch bestimmte erforderliche Systemfelder. Eine synchrone Nachricht enthält stets die folgenden Systemfelder:

  • __Sender__

    Bei diesem Systemfeld handelt es sich um einen erforderlichen Parameter IN für die in einer synchronen Nachricht verwendete Methode.

  • __Status__

    Bei diesem Systemfeld handelt es sich um einen erforderlichen Parameter OUT für die in einer synchronen Nachricht verwendete Methode.

Synchrone Nachrichten

Beim Einrichten einer synchronen Kommunikation wird eine Nachricht auf der Datenseite erstellt. Diese Nachricht entspricht den Methoden und Parametern, die in dem Kommunikationsfluss verwendet werden. Die Nachricht enthält alle Parameter IN und OUT der Methode.

Eine Methode kann keine Parameter enthalten, die Nachricht enthält jedoch stets erforderliche Systemfelder. Das Nachrichtenschema wird im folgenden Beispiel dargestellt:

Method name_in
__Sender__   string
   parameter 1   Data type 1
   parameter 2   Data type 2
   parameter n   Data type n
Method name_out
__Status__   string
   Parameter 1   Data type 1
   Parameter 2   Data type 2
   Parameter n   Data type n

Die folgende Abbildung zeigt ein synchrones Nachrichtenpaar, das die Systemfelder __Sender__ und __Status__ sowie die Parameter IN und OUT für den Methodenaufruf enthält.

Ein asynchrones Nachrichtenpaar, das den Methodenaufruf und seine zugehörigen Werte enthält

Verwandte Themen

Pausierung und Aktivierung

Persistenz

Synchrone und asynchrone Kommunikation

Verwenden des Methodenkommunikations-Assistenten


Verwenden des Assistenten für XML-Kommunikation

Sie können den Assistenten für XML-Kommunikation auf der Geschäftsprozessseite und den Seiten Kompensierung für Transaktion und Bei Fehler von Transaktion verwenden, um den Nachrichtenfluss zwischen einer Aktion-Form und einer Message Queuing-Form, einer BizTalk-Messaging-Form oder einem ungebundenen Port zu definieren. Ziehen Sie das rechte Kontrollhandle ( Kontrollhandle) einer Aktion-Form auf den Verbindungspunkt ( Verbindungspunkt) eines ungebundenen Ports oder eines an eine Message Queuing- oder eine BizTalk-Messaging-Form gebundenen Ports, um den Assistenten für XML-Kommunikation zu starten. Der Assistent für XML-Kommunikation setzt sich aus den folgenden Seiten zusammen:

Willkommen beim Assistenten für XML-Kommunikation

Auf der Seite Willkommen beim Assistenten für XML-Kommunikation können Sie angeben, ob der Port eine Nachricht an eine Aktion senden oder eine Nachricht von einer Aktion empfangen soll. Wenn Sie die Kommunikation zwischen einer Aktion und einem Port erstellen, der mit der BizTalk-Messaging-Form implementiert wurde, ist die Kommunikationsrichtung bereits konfiguriert worden. Dies ist erfolgt, als die Portbindung mit dem BizTalk-Bindungs-Assistenten für Messaging erstellt wurde.

Wenn der Port zum Empfang von Nachrichten konfiguriert wurde, können Sie einen Wert für die Wartezeit in Sekunden festlegen, die das XLANG-Ablaufplanungsmodul auf das Eintreffen der Nachricht warten soll. Wenn dieser Wert 180 Sekunden oder weniger beträgt, muss die XLANG-Ablaufplaninstanz nie in der Persistenzdatenbank pausieren. Ist der Wert höher als 180 Sekunden, pausiert die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank. Der Standardwert für die Wartezeit ist null Sekunden und weist darauf hin, dass das Eintreffen der Nachricht sofort erwartet wird.

Wenn eine XLANG-Ablaufplaninstanz aus einem anderen Grund aktiviert wird als aufgrund des Eintreffens einer von einer Aktion erwarteten Nachricht (und die XLANG-Ablaufplaninstanz dann in einen Ruhezustand eintritt), wird der angegebene Wartezeitwert verwendet, um zu bestimmen, ob die XLANG-Ablaufplaninstanz sofort pausiert. Dies kann beispielsweise dann der Fall sein, wenn eine parallele Verzweigung eine Nachricht empfängt, auf die sie gewartet hat, oder wenn der Neustart eines Computers dazu führt, dass alle XLANG-Ablaufplaninstanzen aktiviert werden. In dieser Situation wird der Wert der Wartezeit von dem Zeitpunkt an ausgewertet, an dem die XLANG-Ablaufplaninstanz in einen Ruhezustand eintritt. Wenn der Zeitraum vom Beginn der ursprünglichen Wartezeit (zusammen mit dem Wartezeitwert) des XLANG-Ablaufplanungsmoduls bis zu dem Zeitpunkt, an dem das XLANG-Ablaufplanungsmodul nach der Aktivierung in den Ruhezustand eingetreten ist, über 180 Sekunden beträgt, pausiert die XLANG-Ablaufplaninstanz sofort in der Persistenzdatenbank. Dieser Punkt kann in der XLANG-Ablaufplaninstanz lange nach dem Beginn der Überwachung des Eintreffens einer Nachricht durch das XLANG-Ablaufplanungsmodul eintreten.

Nachrichteninformationen

Auf der Seite Nachrichteninformationen können Sie angeben, ob eine neue Nachricht oder ein Verweis auf eine vorhandene Nachricht erstellt werden soll. Wenn Sie angeben, dass eine neue Nachricht erstellt werden soll, definieren Sie den Datenfluss der neuen Nachricht. Weitere Informationen zum Datenfluss finden Sie unter Datenverarbeitung. Mit der Bezeichnungseigenschaft einer Nachricht können Sie die Leistung eines Ablaufplanes wie folgt optimieren:

  • Wenn die Bezeichnungseigenschaft der Nachricht dem XML-Stammelement entspricht, das beim Erstellen einer neuen Nachrichtenform angegeben wird, ruft das XLANG-Ablaufplanungsmodul die Nachricht ab.

  • Wenn die Bezeichnungseigenschaft nicht mit dem für das XML-Stammelement bereitgestellten Wert übereinstimmt, überprüft das XLANG-Ablaufplanungsmodul den Inhalt der Nachricht. Wenn der Wert des XML-Stammelements, das beim Erstellen einer neuen Nachrichtenform angegeben wird, mit dem eigentlichen XML-Stammelement übereinstimmt, ruft das XLANG-Ablaufplanungsmodul die Nachricht ab. Andernfalls lässt das XLANG-Ablaufplanungsmodul die Nachricht in der Warteschlange und überprüft die nächste Nachricht.

Informationen über die XML-Konvertierung

Auf der Seite Informationen über die XML-Konvertierung können Sie angeben, ob Nachrichten als XML-formatierte Daten oder als Textzeichenfolgen an die Warteschlange gesendet bzw. aus dieser empfangen werden sollen. Wenn Sie festlegen, dass Nachrichten als Textzeichenfolgen gesendet werden sollen, wird der Standard-XML-Wrapper des XLANG-Ablaufplanungsmoduls aus den Nachrichten entfernt.

Informationen über den Nachrichtentyp

Auf der Seite Informationen über den Nachrichtentyp können Sie eine Bezeichnung angeben, die das XLANG-Ablaufplanungsmodul zur Identifizierung von Nachrichten des von Ihnen definierten Typs verwenden soll. Der von Ihnen eingegebene Text wird zur Identifizierung der Nachrichten verwendet, welche von der Warteschlange empfangen werden sollen. Wenn Sie für zwei verschiedene Nachrichten denselben Nachrichtentyp auswählen, stellen Sie sicher, dass die Feldnamen, Feldtypen und XPath-Abfragen genau übereinstimmen. Das XLANG-Ablaufplanungsmodul meldet einen Fehler, falls eine Inkonsistenz zwischen Nachrichten desselben Nachrichtentyps an demselben Port besteht. Geben Sie auf der Seite Informationen über den Nachrichtentyp in das Feld Nachrichtentyp eine Bezeichnung für die Nachricht ein. Das XLANG-Ablaufplanungsmodul führt auf der Grundlage der von Ihnen bereitgestellten Informationen folgende Verfahren aus:

  • Das XLANG-Ablaufplanungsmodul versucht, die Informationen zum Nachrichtentyp mit der Nachrichtenbezeichnung in der Warteschlange abzugleichen. Wenn der Nachrichtentyp nicht übereinstimmt, wird die Nachricht ignoriert, und das XLANG-Ablaufplanungsmodul hält weiterhin Ausschau nach neuen eingehenden Nachrichten, die übereinstimmen könnten. Auf diese Weise können mehrere Aktionen mehrere Nachrichtentypen aus einer einzelnen Nachrichtenwarteschlange empfangen.

  • Wenn Sie die BizTalk Messaging-Form zur Aktivierung verwenden, verwendet das XLANG-Ablaufplanungsmodul den Namen der ausgehenden Dokumentdefinition des Aktivierungskanals als Nachrichtenbezeichnung, wenn es die Nachricht an die Warteschlange übermittelt. Die Aktion, die diese Nachricht verwendet, sollte ebenfalls den Namen der ausgehenden Dokumentdefinition des Aktivierungskanals für ihren Nachrichtentyp verwenden.

  • Falls die Nachricht in der Warteschlange das XML-Format besitzt, versucht das XLANG-Ablaufplanungsmodul, die Informationen zum Nachrichtentyp mit dem XML-Stammelement der Nachricht in der Warteschlange abzugleichen.

Sie können auch die Instanz-ID – den global eindeutigen Bezeichner (Globally Unique Identifier, GUID) der Ablaufplaninstanz – als Bezeichnung für die Nachricht verwenden, indem Sie das Kontrollkästchen Instanz-ID als Nachrichtenbezeichnung verwenden aktivieren. Auf diese Weise wird ein hilfreicher Korrelationsmechanismus bereitgestellt, wenn eine einzelne Warteschlange die Nachrichten alle Instanzen eines Ablaufplanes verarbeiten soll. Weitere Informationen zu diesem Thema erhalten Sie in der Beschreibung der Korrelation des Nachrichtenaustausches an XLANG-Ablaufplaninstanzen unter Instanzenverwaltung.

Informationen über die Nachrichtenspezifikation

Auf der Seite Informationen über die Nachrichtenspezifikation können Sie den Pfad zu der gewünschten Nachrichtenspezifikationsdatei (XML-Datei) eingeben oder diese suchen. Wenn es sich bei der ausgewählten Nachrichtenspezifikation um eine Spezifikation handelt, die mit dem BizTalk-Editor erstellt wurde, können Sie Felder zum Datenbereich des XLANG-Ablaufplanes hinzufügen. Sie können Nachrichten anhand der Spezifikation überprüfen, indem Sie das Kontrollkästchen Nachrichten anhand der Spezifikation überprüfen aktivieren. Wenn Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen klicken, wird das Dialogfeld Nach Spezifikation durchsuchen angezeigt. Mithilfe des Dialogfeldes Nach Spezifikation durchsuchen können Sie nach der gewünschten Spezifikation suchen.

Wenn Sie keine Spezifikation ausgewählt haben, klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Erstellen, um den BizTalk-Editor zu öffnen. Wenn Sie bereits eine Spezifikation ausgewählt haben, klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Bearbeiten, um den BizTalk-Editor mit der ausgewählten Spezifikation zu öffnen.

Wenn Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Hinzufügen klicken, wird das Dialogfeld Feldauswahl angezeigt. Sie können im Dialogfeld Feldauswahl in der Struktur Auswahlknoten alle Knoten nach Wunsch erweitern und dann auf das Feld klicken, das Sie hinzufügen möchten. Im Dialogfeld Feldauswahl können Sie den Namen und den Knotenpfad für Felder bearbeiten, die Sie zur Nachrichtenform des ausgewählten Ports hinzufügen möchten. Die Datentypfelder werden angezeigt, können jedoch nicht bearbeitet werden.

Anmerkungen

  • Die Überprüfung ist nur beim Empfang einer Nachricht verfügbar. Beim Senden einer Nachricht wird das Überprüfungskontrollkästchen ignoriert.

  • XML-Datentypen wie Enumeration und Number, die keine entsprechenden OLE-Automatisierungstypen besitzen, werden im BizTalk-Orchestrierungs-Designer und in XLANG in den Typ string konvertiert. Ein Feld dieses Typs wird bei der Überprüfung als Zeichenfolge erfasst. Eine vollständige Liste der OLE-Automatisierungstypen finden Sie unter Felddatentypen.

  • Wenn Sie in der Struktur Auswahlknoten auf ein Feld klicken, wird der Feldname automatisch zum Feld Feldname hinzugefügt.

  • Wenn Sie in der Struktur Auswahlknoten auf ein Feld klicken, wird der Knotenpfad automatisch zum Feld Knotenpfad hinzugefügt.

  • Sie können Felder nur von einem Schema auswählen, das im BizTalk-Editor erstellt oder in diesen importiert wurde, wenn Sie Nachrichtenfelder hinzufügen.

  • Die manuelle Bearbeitung eines Knotenpfades ist sehr nützlich, wenn Sie bestimmte Daten aus einem Feld extrahieren möchten. Wenn das Feld beispielsweise ein Array enthält, müssen Sie nicht das gesamte Array abrufen, sondern können ein einzelnes Element aus dem Array abrufen. Es wird jedoch davon abgeraten, den Knotenpfad für die Nachrichtenspezifikation manuell zu bearbeiten.

  • Sie können keinen Knoten auswählen, um ihn zur Liste Nachrichtenfelder hinzuzufügen. Es können nur Felder ausgewählt werden. Auf ein Feld kann auch als Endknoten verwiesen werden. Sie können z. B. die Knoten Verkäufer und Adresse nicht auswählen, weil diese Endknoten enthalten. Die Felder Name und Adresse können ausgewählt werden, weil es sich dabei um Felder handelt, die keine zusätzlichen Knoten enthalten.

  • Beim Warten auf den Empfang einer Nachricht aus einer Nachrichtenwarteschlange können einige Probleme (z. B. ungültige XML-Nachrichten oder eine unzureichende Authentifizierung) dazu führen, dass eine Warteschlange für unzustellbare Nachrichten dynamisch erstellt wird. Die Warteschlange für unzustellbare Nachrichten ist spezifisch für eine COM+-Anwendung. Die Warteschlange für unzustellbare Nachrichten erhält den Namen .\private$\Anwendungsname.DeadLetter. Wenn beispielsweise eine Nachricht mit ungültiger XML in der Warteschlange eintrifft und Sie auf der Seite Informationen über die XML-Konvertierung des Assistenten für XML-Kommunikation festgelegt haben, dass das XLANG-Ablaufplanungsmodul auf XML-Nachrichten aus der Warteschlange wartet, werden alle ungültigen XML-Nachrichten nach .\private$\Anwendungsname.DeadLetter verschoben.

  • Wenn zwei verschiedene XLANG-Ablaufpläne unterschiedliche Nachrichten aus derselben Nachrichtenwarteschlange empfangen, kann es vorkommen, dass eine Nachricht von der falschen XLANG-Ablaufplaninstanz verarbeitet wird. Verwenden Sie eine Nachrichtenwarteschlange für jeden Nachrichtentyp, der von einer XLANG-Ablaufplaninstanz empfangen wird, um dieses Problem zu vermeiden.

Verwandte Themen

Asynchrone Kommunikation

Synchrone und asynchrone Kommunikation

Synchrone Kommunikation

Verwenden des Methodenkommunikations-Assistenten


Asynchrone Kommunikation

Eine asynchrone Nachricht wird in einer Nachrichtenwarteschlange oder einem BizTalk-Messaging-Kanal platziert, und der XLANG-Ablaufplan setzt den Vorgang fort. Der Ablaufplan wartet nicht auf eine Antwort.

Die einzigen Nachrichten, die für eine asynchrone Kommunikation zur Verfügung stehen, sind XML-Nachrichten. Alle XML-Nachrichten sind verfügbar und können für mehr als einen Port festgelegt werden. Es ist nicht möglich, die synchronen Nachrichtenpaare, die mithilfe des Methodenkommunikations-Assistenten erstellt wurden, zu verwenden.

Asynchrone Nachrichten

Beim Generieren einer asynchronen Kommunikation wird eine Nachricht auf der Datenseite erstellt. Die Nachricht entspricht den im Kommunikationsfluss gesendeten bzw. empfangenen Informationen. In der Nachricht sind die erforderlichen Systemfelder sowie alle zusätzlich von Ihnen gewünschten Spezifikationsfelder enthalten.

Das Nachrichtenschema wird im folgenden Beispiel dargestellt:

Message name
__Sender__   string
Document   string
   Field 1   Data type 1
   Field 2   Data type 2
   Field n   Data type n

Die folgende Abbildung zeigt eine Nachricht mit dem Namen Nachricht_1. Die Systemfelder __Sender__ und Document werden automatisch bereitgestellt und sind in allen asynchronen Nachrichten vorhanden. Diese Nachricht enthält außerdem zwei vom Benutzer ausgewählte Spezifikationsfelder.

Eine Nachricht, die zwei Systemfelder und zwei benutzerdefinierte Felder enthält

Sie können Spezifikationsfelder mithilfe des Dialogfeldes Feldauswahl im Assistenten für XML-Kommunikation hinzufügen. Klicken Sie im Dialogfeld Feldauswahl auf die Struktur Auswahlknoten, um ein Spezifikationsfeld auszuwählen. Wenn Sie auf einen Knoten klicken, wird der Knotenpfad zum Feld Knotenpfad hinzugefügt. Sie müssen einen Endknoten auswählen. Ein Endknoten ist ein Knoten ohne untergeordnete Elemente. In der folgenden Abbildung ist der Knoten Name ein Endknoten, der Knoten Address (Adresse) jedoch nicht.

Ein Knotenpfad wird auch als XPath bezeichnet. Sie können den ausgewählten Knotenpfad verwenden oder zusätzliche Kriterien zum Pfad eingeben. Wenn Sie beispielsweise einen Knoten mit einem Array auswählen, müssen Sie nicht das gesamte Array abrufen, sondern können einen spezifischen Index im Array angeben, der abgerufen werden soll.

Anmerkung

  • Wenn Sie sich dafür entscheiden, eine XML-Nachricht als Zeichenfolge zu versenden oder zu empfangen, enthält die für diese Nachricht auf der Datenseite generierte Nachrichten-Form ein Feld namens StringData, und Sie können dieser Nachricht keine anderen Spezifikationsfelder hinzufügen.

Die folgende Abbildung zeigt das Dialogfeld Feldauswahl.

Das Dialogfeld Feldauswahl

Anmerkung

  • Weitere Informationen zum Auswählen von Spezifikationsfeldern und zum Verwenden von Knotenpfaden finden Sie in den folgenden Themen:
    • Erstellen und Überprüfen von Spezifikationen

    • Knotenpfadfelder

    • Senden oder Empfangen asynchroner Nachrichten

    • Verwenden des Assistenten für XML-Kommunikation

Verwandte Themen

Erstellen und Überprüfen von Spezifikationen

Pausierung und Aktivierung

Knotenpfadfelder

Persistenz

Senden oder Empfangen asynchroner Nachrichten

Synchrone und asynchrone Kommunikation

Verwenden des Assistenten für XML-Kommunikation


Kompilieren von XLANG-Ablaufplänen

Wenn Sie eine XLANG-Ablaufplanzeichnung erstellt haben, können Sie die Zeichnung in einen ausführbaren XLANG-Ablaufplan kompilieren. Bevor Sie die Zeichnung kompilieren, stellen Sie sicher, dass der Datenfluss zwischen Nachrichten auf der Datenseite definiert wurde. Ein XLANG-Ablaufplan beschreibt den Geschäftsprozess und die Bindung des Prozesses an eine Implementierungstechnologie.

Der BizTalk-Orchestrierungs-Designer soll so viele nützliche Informationen wie möglich bereitstellen, wenn während des Kompilierungsprozesses ein Problem im XLANG-Ablaufplan entdeckt wird. Wenn der BizTalk-Orchestrierungs-Designer einen Fehler entdeckt, markiert er die Form, die den Fehler enthält, zeigt eine Fehlermeldung an und bricht die Kompilierung des XLANG-Ablaufplanes ab.

Während der Kompilierung überprüft der BizTalk-Orchestrierungs-Designer jede Form im Hinblick auf Vollständigkeit und Richtigkeit. Das XLANG-Ablaufplanungsmodul verarbeitet zunächst die Beginn-Form auf der Geschäftsprozessseite und geht dann in absteigender Reihenfolge rekursiv durch die gesamte Zeichnung. Wenn das XLANG-Ablaufplanungsmodul einen Fehler entdeckt, so tritt dieser Fehler im Allgemeinen auf, wenn der Geschäftsprozess dem Ablauf zu einer Form in einer tief geschachtelten Position folgt. Um diesen Fehler zu melden, erstellt das XLANG-Ablaufplanungsmodul eine entsprechende Fehlermeldung. Wenn das XLANG-Ablaufplanungsmodul dann durch den Stapel nach oben zurückkehrt, hat jede Methode die Möglichkeit, ihre eigene Fehlermeldung mit der ursprünglichen Fehlermeldung zu verketten. Wenn keine der Methoden eine Fehlermeldung mit der ursprünglichen Fehlermeldung verkettet, fügt die oberste Kompilierungsmethode die folgende generische Fehlermeldung hinzu:

Der XLANG-Ablaufplan konnte nicht verarbeitet werden.

Der kompilierte XLANG-Ablaufplan enthält einen globalen eindeutigen Bezeichner (GUID), der mit der XLANG-Identität-Eigenschaft der Beginn-Form übereinstimmt. Mit dieser Identifizierung kann eine Version der XLANG-Ablaufplanzeichnung mit dem XLANG-Ablaufplan korreliert werden, der diese generiert hat.

Anmerkung

  • Es wird dringend empfohlen, dass Sie den Abschnitt Durchführen von BizTalk-Orchestrierungs-Designer-Aufgaben lesen, der aufgabenspezifische Informationen zur Verwendung des BizTalk-Orchestrierungs-Designers zum Erstellen von XLANG-Ablaufplanzeichnungen und ihrer Kompilierung in ausführbare XLANG-Ablaufpläne enthält.

Verwandte Themen

Kompilieren und Debuggen von XLANG-Ablaufplänen

Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

Debuggen von XLANG-Ablaufplänen


Debuggen von XLANG-Ablaufplänen

Der XLANG Event Monitor ist ein Tool, mit dem Sie aktive XLANG-Ablaufplaninstanzen überwachen können. Spezifische Informationen zur Verwendung des XLANG Event Monitors finden Sie in der zugehörigen Infodatei Readme.htm. Der XLANG Event Monitor (XLANGMon.exe) und die vom Microsoft BizTalk Server 2002 Setup-Assistent installierte Infodatei befinden sich beide im folgenden Installationsverzeichnis: \Programme\Microsoft BizTalk Server\SDK\XLANG-Tools.

Der XLANG Event Monitor beinhaltet die folgenden Features:

  • Er zeigt die Ausführung des XLANG-Ablaufplanungsmoduls in Echtzeit an.

  • Nach der ersten Enumeration der aktiven Ablaufpläne werden Ereignisse vom XLANG Event Monitor überwacht. Mithilfe des XLANG Event Monitors können aktive Instanzen angehalten und gestoppt werden.

  • Er verfügt über eine MDI-ähnliche Benutzeroberfläche (Multiple-Document Interface - MDI), mit der Sie gleichzeitig Ablaufverfolgungen für mehrere Instanzen anzeigen können.

  • Der XLANG Event Monitor kann gleichzeitig ausgewählte Anwendungen auf mehreren Computern überwachen.

  • Er stellt separate Aufzeichnungs- und Anzeigefilter bereit.

Verwandte Themen

Kompilieren und Debuggen von XLANG-Ablaufplänen

Kompilieren von XLANG-Ablaufplänen

Überwachen von aktiven XLANG-Ablaufplänen

Orchestration Services Error Messages


Ausführen von XLANG-Ablaufplänen

Bei der Installation des BizTalk-Orchestrierungs-Designers werden mehrere COM+-Anwendungen innerhalb der Microsoft Windows 2000 Komponentendienste installiert und konfiguriert, darunter auch der XLANG Scheduler. Diese Anwendung ist Host einer Standardinstanz des XLANG-Ablaufplanungsmoduls. Alle in den Komponentendiensten erstellten COM+-Anwendungen verfügen im Dialogfeld Eigenschaften über eine Registerkarte XLANG. Auf der Registerkarte XLANG können Sie die neue COM+-Anwendung als Host für das XLANG-Ablaufplanungsmodul aktivieren. Die spezifische COM+-Anwendung, in der ein neuer XLANG-Ablaufplan ausgeführt werden soll, kann über die zur Aktivierung einer XLANG-Ablaufplaninstanz verwendete Monikersyntax festgelegt werden.

Das XLANG-Ablaufplanungsmodul steuert die Aktivierung, Ausführung, Pausierung und erneute Aktivierung aktiver XLANG-Ablaufplaninstanzen. Sie können eine kleine Anwendung erstellen, die den Moniker eines XLANG-Ablaufplanes an das XLANG-Ablaufplanungsmodul weitergibt, um einen XLANG-Ablaufplan zu aktivieren. Das XLANG-Ablaufplanungsmodul führt die Aktionen innerhalb des XLANG-Ablaufplanes aus, und setzt den Geschäftsprozess fort, bis eine Pausierung des XLANG-Ablaufplanes erforderlich ist. Das Pausieren eines XLANG-Ablaufplanes tritt dann ein, wenn das XLANG-Ablaufplanungsmodul mit einer Wartezeit von über drei Minuten bis zum Empfang einer Nachricht rechnet. Wenn die Nachricht eintrifft, lässt das XLANG-Ablaufplanungsmodul die XLANG-Ablaufplaninstanz pausieren und fährt mit der Ausführung der Aktionen des Geschäftsprozesses fort, bis der Ablaufplan beendet ist oder das XLANG-Ablaufplanungsmodul auf eine weitere Nachricht warten muss. Sie müssen über eine konfigurierte Persistenzdatenbank verfügen, um die Pausierung zu unterstützen. Als Netzwerkbibliothek wird TCP/IP empfohlen.

Gehen Sie wie folgt vor, um Informationen zu den Komponentendiensten von Microsoft Windows 2000 anzuzeigen:

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie mit der rechten Maustaste auf die gewünschte COM+-Anwendung.

    Das Dialogfeld Eigenschaften von Name wird angezeigt.

Die Registerkarte XLANG im Dialogfeld Eigenschaften zeigt folgende Optionen an:

  • Diese Anwendung stellt einen Host für BizTalk-Ablaufplaninstanzen dar. Wenn diese Option aktiviert ist, kann die COM+-Anwendung Instanzen von XLANG-Ablaufplänen aktivieren. Verwenden Sie einen Moniker, der den Namen der Anwendung beinhaltet, um die Aktivierung einer Ablaufplaninstanz an eine bestimmte COM+-Anwendung zu leiten. Aktivieren Sie diese Option, wenn die Anwendung als Host für das XLANG-Ablaufplanungsmodul dienen soll.

  • Konfigurieren von DNS für Persistenz. In diesem Bereich können Sie Microsoft SQL Server konfigurieren, um die Pausierung und Aktivierung langlebiger Geschäftsprozesse zu unterstützen:
    • Über DSN erstellen wird der ODBC-Datenquellname (DSN) für die COM+Komponente erstellt, die als Host für das XLANG-Ablaufplanungsmodul dient. Ein Datei-DSN speichert Informationen zu einer Datenbankverbindung in einer Datei. Die Datei besitzt die Erweiterung DSN und wird standardmäßig im Verzeichnis ..\Programme\Gemeinsame Dateien\ODBC\Data Sources gespeichert. Klicken Sie auf die Schaltfläche DSN erstellen, um den Assistent zum Erstellen neuer Datenquellen zu starten.

    • Über DSN konfigurieren wird der ODBC-Datenquellen-Administrator geöffnet, mit dem die Datenquelle für XLANG-Ablaufpläne in dieser COM+-Anwendung verwaltet wird.

    • Über Tabellen initialisieren werden die erforderlichen Tabellen für die Unterstützung der Persistenz in der von Ihnen definierten SQL Server-Datenbank erstellt.

    Wichtig

    • Der im Dialogfeld Eigenschaften von XLANG Scheduler konfigurierte Datenquellenname muss mit dem Namen der COM+-Anwendung übereinstimmen.
  • Kontrolliertes Herunterfahren. In diesem Bereich können Sie eine gültige Methode zum Beenden der COM+-Anwendungen auswählen, die als Host für XLANG-Ablaufplaninstanzen dient:
    • Über die Option Alle XLANG-Anwendungen werden alle COM+-Anwendungen heruntergefahren, die als Host für aktive XLANG-Ablaufplaninstanzen dienen.

    Anmerkung

    • Wenn Sie eine andere Anwendung als die Standardanwendung ausgewählt haben, wird die Option Diese XLANG-Anwendung angezeigt.
  • Pausierende XLANG-Anwendungen neu starten. In diesem Bereich können Sie pausierende XLANG-Anwendungen verwalten:
    • Über die Option Alle XLANG-Anwendungen werden alle COM+-Anwendungen aktiviert, die als Host für aktive XLANG-Ablaufplaninstanzen dienen, und gegebenenfalls weiter ausgeführt.

Wichtig

  • Klicken Sie nicht mit der rechten Maustaste auf die COM+-Anwendung, um aktive Instanzen eines XLANG-Ablaufplanes herunterzufahren. Dadurch bleiben COM-Komponenten im Speicher geladen, anstatt richtig entladen zu werden. Verwenden Sie stattdessen den Bereich Kontrolliertes Herunterfahren auf der Registerkarte XLANG in den Eigenschaften für die XLANG Scheduler COM+-Anwendung.

Anmerkungen

  • Wenn der Client für Microsoft Windows 2000 Terminaldienste zur Initiierung eines XLANG-Ablaufplanes verwendet wird, muss die COM+-Anwendung, die als Host für das XLANG-Ablaufplanungsmodul dient, als Identität einen gültigen Windows 2000-Benutzer- oder Gruppennamen haben. Die Identität der COM+-Anwendung wird auf der Seite Identität des Dialogfeldes für die Eigenschaften der Anwendung festgelegt. Die Identität darf nicht auf interaktiv festgelegt werden, wenn das XLANG-Ablaufplanungsmodul in einer Sitzung verwendet wird, für die die Terminaldienste als Host dienen.

  • Aufgabenspezifische Informationen zur Ausführung eines XLANG-Ablaufplanes finden Sie unter Ausführen eines XLANG-Ablaufplanes

Folgende Themen werden in diesem Abschnitt behandelt:

  • Monikersyntax

  • Erstellen einer Instanziierungsanwendung


Monikersyntax

Moniker werden verwendet, um neue XLANG-Ablaufplaninstanzen zu erstellen oder um auf eine vorhandene XLANG-Ablaufplaninstanz zu verweisen. In beiden Fällen können Sie auf einen bestimmten Port innerhalb der Ablaufplaninstanz verweisen. Moniker bestimmen, welche COM+-Anwendung als Host des XLANG-Ablaufplanungsmoduls dienen soll.

Zum Erstellen einer neuen Instanz eines XLANG-Ablaufplanes muss ein Moniker für den XLANG-Ablaufplan an die COM+-Anwendung übergeben werden. Die COM+-Anwendung leitet den Moniker zur Auflösung sowie zur Aktivierung der XLANG-Ablaufplaninstanz mit einer Instanz des XLANG-Ablaufplanungsmoduls an den XLANG-Namensdienst weiter. Das folgende Codebeispiel zeigt die allgemeine Syntax für Moniker:

sked://[HostName][!GroupManager][/FilePath][/PortName]

Alle Segmente der Monikersyntax sind optional, abhängig davon, welchen Objekttyp Sie instanziieren möchten. Die folgende Tabelle enthält eine Liste und Beschreibungen der Monikersyntaxsegmente.

Monikersyntaxsegment | Beschreibung | Beispiele
HostName | Der Hostname des Computers mit dem XLANG-Ablaufplanungsmodul. Dieser wird auch als XLANG-System-Manager bezeichnet. Falls dieses Segment ausgelassen wird, wird "localhost" als Standardwert verwendet. Bei diesem Namen wird nicht zwischen Groß- und Kleinschreibung unterschieden. | sked:// sked://MyServer
GroupManager | Der Gruppen-Manager des XLANG-Ablaufplanungsmoduls, mit dem XLANG-Ablaufplaninstanzen verwaltet werden. Der Name des Gruppen-Managers stimmt mit dem Namen der COM+-Anwendung überein, die als XLANG-Host bestimmt ist. Falls dieses Segment ausgelassen wird, wird XLANG Scheduler als Standardwert verwendet. Bei diesem Namen wird zwischen Groß- und Kleinschreibung unterschieden, und er darf Leerzeichen enthalten. | sked:/// sked://AnotherServer!/ sked://AnotherServer!MyGroup/
FilePath | Der Pfad zu einer XLANG-Ablaufplanungsdatei (SKX-Datei), die aktiviert werden soll. Bei diesem Wert wird nicht zwischen Groß- und Kleinschreibung unterschieden. | sked://host1!MyGrp/C:\basic.skx sked:///C:\basic.skx
PortName | Der Namen eines Ports, der an eine COM-Komponente oder eine Windows-Skriptkomponente in einem XLANG-Ablaufplan gebunden ist. Bei diesem Namen wird zwischen Groß- und Kleinschreibung unterschieden. | sked:///C:\basiccom.skx/portA

Mit der Monikersyntax kann auf eine vorhandene XLANG-Ablaufplaninstanz verwiesen, ein XLANG-Ablaufplan gestartet oder ein Kommunikationskanal mit einem bestimmten Port in der neuen XLANG-Ablaufplaninstanz eingerichtet werden.

Moniker, die auf eine XLANG-Ablaufplaninstanz verweisen, werden vom XLANG-Ablaufplanungsmodul erstellt und durch das Erstellen einer Verbindung zwischen der Port References-Form und Nachrichten, die vom XLANG-Ablaufplan gesendet werden, verfügbar gemacht. Die genaue Form des Portverweises hängt von der Implementierungstechnologie ab, an die der Port gebunden ist, sowie vom Datentyp des Zielnachrichtenfeldes. Ports, die an Message Queuing- oder BizTalk-Messagingdienste gebunden sind, können nur mit Feldern vom Datentyp String verbunden werden. Das Zielfeld enthält den Namen des Warteschlangen- oder Messagingendpunktes, der an den Port in der aktuellen XLANG-Ablaufplaninstanz gebunden ist.

An COM-Komponenten gebundene Ports können mit Feldern vom Datentyp String, Object oder Unknown verknüpft werden. Wenn das Zielfeld den Datentyp String besitzt, wird ein Moniker erstellt, der auf einen Port in der aktuellen XLANG-Ablaufplaninstanz verweist. Dieser Moniker ist dauerhaft. Der Moniker kann mithilfe der GetObject-Funktion aufgelöst werden und bleibt nach einem Systemneustart gültig. Wenn das Zielfeld den Datentyp Object oder Unknown hat, wird ein COM-Verweis auf die Portinstanz an die Nachrichtenform übergeben. Wenn diese Art von Verweis an eine externe Komponente übergeben wird, ist sie nach einem Systemneustart nicht gültig.

Der Moniker mit einem Verweis auf eine aktive XLANG-Ablaufplaninstanz kann aus dem XLANG-Ablaufplaninstanzobjekt abgerufen werden, wie im folgenden Microsoft Visual Basic-Code dargestellt:

Dim oSchedule as IWFWorkflowInstance
Set oSchedule = GetObject("sked:///C:\temp\myschedule.skx")
dim sMoniker as string
sMoniker = oSchedule.FullyQualifiedName

Verwandte Themen

Erstellen einer Instanziierungsanwendung

Ausführen von XLANG-Ablaufplänen


Erstellen einer Instanziierungsanwendung

Eine Instanziierungsanwendung übergibt mithilfe der GetObject-COM-Funktion einen Moniker für die abgeschlossene XLANG-Ablaufplandatei an das XLANG-Ablaufplanungsmodul. Der folgende Microsoft Visual Basic-Code zeigt eine Möglichkeit, dies zu tun:

Dim objExecute As object
Dim strURL as string

strURL = "sked:///c:\temp\myschedule.skx"

' This instantiates an XLANG schedule and enables the XLANG Scheduler
' Engine to execute the XLANG schedule.
Set objExecute = GetObject(strURL)

Wenn Sie im Moniker keinen Port angegeben haben, können Sie mit der Port-Eigenschaft des Objekts, das durch die GetObject-Funktion zurückgegeben wird, einen Verweis auf einen Port abrufen, der an eine COM-Komponente gebunden ist. Ebenso können Sie mit der FullPortName-Eigenschaft den vollständigen, dauerhaften Namen eines Ports abrufen, der an eine Implementierungstechnologie gebunden ist.

Der folgende Code zeigt, wie ein Proxy für einen COM- oder Skriptport abgerufen wird. Dieses Codebeispiel ist eine Fortsetzung des vorherigen Codebeispiels:

Dim oPort as Object
Set oPort = objExecute.Port("SchedulePortName")
Call oPort.ComponentMethodName(arg1,arg2,...argN)

Anmerkung

  • Wenn der Port an ein COM-Objekt gebunden ist, das keine duale Schnittstelle unterstützt, muss die Variable oPort mit der entsprechenden Klasse deklariert werden.

Verwandte Themen

Monikersyntax

Ausführen von XLANG-Ablaufplänen


Pooling von XLANG-Ablaufplänen

Wenn das Datenverkehrsaufkommen hoch ist und viele Ablaufplaninstanzen gleichzeitig aktiv sind, können Sie durch das Pooling Ihrer Ablaufpläne die verfügbaren Ressourcen effektiv nutzen. BizTalk Server nutzt die Vorteile des COM-Objektpoolings und gibt Ihnen die Möglichkeit, die Anzahl von aktiven Ablaufplaninstanzen zu beschränken. Sie können die folgenden Eigenschaften für einen Objektpool festlegen:

  • Sie können eine maximale Anzahl von Ablaufplaninstanzen für einen Pool festlegen. Wird dieses Maximum erreicht, werden keine weiteren Instanzen von Ablaufplänen erstellt, die diesen Pool verwenden, bis ein Ablaufplan entweder beendet wird oder pausiert. Das Standardmaximum liegt bei 25 Instanzen.

  • Außerdem können Sie ein Timeout für einen Pool festlegen. Dabei handelt es sich um den Zeitraum, den eine Ablaufplaninstanz, deren Aktivierung aussteht, auf eine verfügbar werdende Lücke im Pool wartet. Die Standardtimeoutzeit beträgt 30.000 Millisekunden (30 Sekunden).

  • Sie können die Leistung verbessern, indem Sie eine Mindestpoolgröße festlegen. Die Mindestgröße bestimmt, wie viele Poolingobjekte im Arbeitsspeicher verwaltet werden, damit diese nicht jedes Mal, wenn eine Ablaufplaninstanz in diesem Pool aktiviert wird, bedarfsgesteuert erstellt werden müssen. Das Standardminimum liegt bei einem Objekt.

Unter Umständen sind diese Einstellungen für einen bzw. mehreren Ihrer Pools nicht optimal; Poolingeinstellungen sollten aus Effizienzgründen stets nach Ihren speziellen Bedürfnissen konfiguriert werden. So sollten kurzlebige Ablaufpläne mit hohem Datenverkehr generell so konfiguriert werden, dass sie in einem Objektpool mit einer relativ hohen maximalen Anzahl von Instanzen ausgeführt werden. Eine relative hohe Mindestanzahl könnte ebenfalls hilfreich sein; wenn Sie einen stetigen Datenverkehr erwarten, unterstützt eine im Vorhinein erstellte Anzahl von Objekten die Leistung. Der Timeout sollte in diesem Fall kurz sein und der Messagingwiederholungszähler hoch. Für einen länger ausgeführten Ablaufplan bei geringerem Datenverkehr sollten Sie einen längeren Timeout und eine kleineres Minimum und Maximum an Instanzen sowie einen niedrigeren Messsagingwiederholungszähler verwenden.

Anmerkungen

  • Sie können einem Pool mehrere Ablaufpläne zuweisen, sollten jedoch darauf achten, dass die Pooleinstellungen den Anforderungen aller ihm zugewiesenen Ablaufpläne erfüllen.

  • Beim Pooling bestehen keine Abwärtskompatibilitätsprobleme. Ablaufpläne, bei denen die Eigenschaft zum Zusammenfassen in einem Pool nicht gesetzt ist, erhalten keine Poolingeffekte.

  • Eine Ablaufplaninstanz in einem Pool, auf die der Benutzer einen Verweis besitzt, verbleibt nach erfolgter Ausführung im Pool, bis der Verweis auf diese Instanz ihre Geltung verliert oder explizit freigegeben wird, wie im folgenden Codebeispiel dargestellt:
    Set FSO = CreateObject("Scripting.FileSystemObject")
CurrentDirPath = FSO.GetAbsolutePathName(".")
SkedMoniker = "sked://localhost/" & CurrentDirPath & "\PoolingSample.skx"
While '(some condition)
    Set Sked = GetObject(SkedMoniker)
    '(some action)
    Set Sked = Nothing
Wend

Verwandtes Thema

Zusammenfassen eines XLANG-Ablaufplanes in einem Pool


Verwalten des Sitzungsstatus

Auf der Seite Erweiterte Porteigenschaften des Bindungs-Assistenten für COM-Komponenten können Sie einen Statusverwaltungswert für die Persistenzebene auswählen, die von der COM-Komponente unterstützt wird. Wählen Sie im Bereich Statusverwaltungsunterstützung eine der folgenden Optionen aus:

  • Behält den Status nicht bei. Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Komponenteninstanz beendet, wenn die Ablaufplaninstanz pausiert. Wenn Sie diese Einstellung auswählen, erstellt das XLANG-Ablaufplanungsmodul bei Bedarf eine neue Komponenteninstanz, wenn der Ablaufplan aktiviert wird.

  • Behält den Status bei, unterstützt aber keine Persistenz. Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Ausführung der Komponenteninstanz erst beenden soll, wenn es in der Ablaufplanausführung nicht mehr benötigt wird. Falls bei der Pausierung der Ablaufplaninstanz ein Systemfehler auftritt, geht jeder in dieser Komponente beibehaltene Status verloren.

  • Behält den Status bei und unterstützt Persistenz. Diese Option gibt an, dass das XLANG-Ablaufplanungsmodul die Komponenteninstanz aus dem Speicher entfernt und sie dann im Speicher wiederherstellt, indem es IPersistStream oder IPersistStreamInit für die Komponente während der Pausierung und dann erneut bei der Aktivierung aufruft.

Verwandtes Thema

Instanzenverwaltung


Aktualisieren von XLANG-Ablaufplänen

Es gibt zwei Möglichkeiten, einen XLANG-Ablaufplan zu aktualisieren. Sie können den ursprünglichen XLANG-Ablaufplan überschreiben oder einen neuen XLANG-Ablaufplan hinzufügen, der parallel mit dem ursprünglichen XLANG-Ablaufplan ausgeführt wird.

Wenn Sie den ursprünglichen XLANG-Ablaufplan überschreiben möchten, erstellen Sie mit dem BizTalk-Orchestrierungs-Designer eine neue XLANG-Ablaufplanzeichnung, und kompilieren Sie dann die XLANG-Ablaufplanzeichnung als XLANG-Ablaufplan mit demselben Namen wie dem des ursprünglichen XLANG-Ablaufplanes. Die XLANG-Ablaufplanzeichnung wird als SKV-Datei gespeichert. Dabei handelt es sich um eine angepasste Version des Microsoft Visio 2000-Dateiformats. Die XLANG-Ablaufplanzeichnung kann dann in einen XLANG-Ablaufplan kompiliert werden. Dabei handelt es sich um eine XML-strukturierte SKX-Textdatei, die vom XLANG-Ablaufplanungsmodul verstanden wird. Kopieren Sie die neue SKX-Datei über die ursprüngliche SKX-Datei, um den ursprünglichen XLANG-Ablaufplan zu aktualisieren.

Wenn Sie einen neuen XLANG-Ablaufplan hinzufügen möchten, der parallel mit dem ursprünglichen XLANG-Ablaufplan ausgeführt werden soll, erstellen Sie mit dem BizTalk-Orchestrierungs-Designer eine neue XLANG-Ablaufplanzeichnung, und kompilieren Sie dann die XLANG-Ablaufplanzeichnung als XLANG-Ablaufplan mit einem neuen Namen. Sie müssen den Aktivierungsmechanismus der XLANG-Ablaufplaninstanz ändern, damit dieser auf die neue und nicht auf die alte SKX-Datei verweist. Auf diese Weise stellen Sie sicher, dass der neue XLANG-Ablaufplan ordnungsgemäß aktiviert wird. Wenn Sie diesen Vorgang ausgeführt haben, werden Instanzen des neuen XLANG-Ablaufplanes von neuen XLANG-Ablaufplananfragen erstellt.

Da alle XLANG-Ablaufpläne und deren Komponenten im Allgemeinen auf der Basis einzelner Instanzen arbeiten, werden XLANG-Ablaufplaninstanzen, die bereits mit der Ausführung des ursprünglichen Ablaufplanes begonnen haben, bis zum Abschluss fortgesetzt. Dies gilt auch für XLANG-Ablaufplaninstanzen, die persistent gespeichert wurden, weil der Quellcode des ursprünglichen Ablaufplanes gespeichert wurde. In diesem Szenario folgt der Ausführungspfad weiter dem ursprünglichen Geschäftsprozess, und neue XLANG-Ablaufplananfragen erstellen Instanzen des neuen XLANG-Ablaufplanes.

Anmerkung

  • Wenn ein XLANG-Ablaufplan ein Objekt mit einer geänderten Schnittstelle verwendet, laden Sie die XLANG-Ablaufplanzeichnung (die SKV-Datei) in den BizTalk-Orchestrierungs-Designer kompilieren Sie eine neue SKX-Datei. Auf diese Weise werden die Bindungsinformationen in der SKX-Datei aktualisiert und so die Synchronisation mit der Typbibliothek der Komponente aktiviert.


Gründe für das Durchführen von BizTalk-Orchestrierungs-Designer-Aufgaben

Dieser Abschnitt stellt eine kurze Referenz zum Durchführen von Aufgaben des BizTalk-Orchestrierungs-Designers bereit. Die folgende Tabelle enthält Beschreibungen der Hauptaufgaben sowie der jeweiligen Unteraufgaben, Erläuterungen zum Zweck jeder Aufgabe und Links zu den entsprechenden Verfahren.

Aufgabe Zweck
  • Verwenden des BizTalk-Orchestrierungs-Designers
 Erstellen von Zeichnungen von Geschäftsprozessen, die als XLANG-Ablaufpläne kompiliert und ausgeführt werden können.
  • Öffnen und Speichern von XLANG-Ablaufplanzeichnungen
 Erstellen, Öffnen oder Speichern einer XLANG-Ablaufplanzeichnung von einem Geschäftsprozess.
Anzeigen von Entwurfsseiten, Formen und Schablonen
Anzeigen der Entwurfsseiten:
  • Anzeigen der Seite "Geschäftprozess"
 Anzeigen einer konzeptuellen Zeichnung eines Geschäftsprozesses.
  • Anzeigen der Seite "Daten"
 Anzeigen der Felder für Nachrichten und Portssowie der Konstanten und des Datenflusses zwischen ihnen.
  • Anzeigen der Geschäftsprozess- und Datenseiten
 Abrufen paralleler Ansichten der Seiten Geschäftsprozess und Daten.
  • Anzeigen der Seiten "Kompensierung für Transaktion"
 Anzeigen von Code, mit dem ein Rollback für die Ergebnisse einer geschachtelten Transaktion ausgeführt wird.
  • Anzeigen der Seiten "Bei Fehler von Transaktion"
 Anzeigen von Code für die Fehlerbehandlung für eine fehlgeschlagene Transaktion.
Anzeigen von Formen:
  • Anzeigen von Flussdiagrammformen
 Ausschließliches Anzeigen der Flussdiagrammformen, mit denen Geschäftsprozesse beschrieben werden.
  • Anzeigen von Flussdiagramm- und Kommunikationsformen
 Anzeigen der Flussdiagrammformen, mit denen Geschäftsprozesse und die Verbindungen zwischen Geschäftsprozessen beschrieben werden.
  • Anzeigen von Flussdiagramm-, Kommunikations- und Implementierungsformen
 Anzeigen von Flussdiagrammformen, mit denen Geschäftsprozesse beschrieben werden, von Implementierungsformen, mit denen Ports beschrieben werden, und der Verbindungen dazwischen.
Anzeigen von Schablonen:
  • Anzeigen der Flussdiagramm-Schablone
 Anzeigen von Formen, die Sie zum Beschreiben von Geschäftsprozessen verwenden können.
  • Anzeigen der Implementierung-Schablone
 Anzeigen von Formen, die Sie zum Implementieren von Kommunikationsports zwischen Geschäftsprozessen verwenden können.
  • Verwenden mehrerer Fenster
 Öffnen, nebeneinander oder überlappendes Anordnen von Fenstern oder Ändern des Fensterfokus, damit unterschiedliche Seiten eines XLANG-Ablaufplanes oder unterschiedliche Ausschnitte einer Seite gleichzeitig angezeigt werden.
  • Verwenden von Anmerkungen
 Hinzufügen, Bearbeiten oder Formatieren von Anmerkungen, die beschreibende Hinweise zu Geschäftsprozessen geben.
  • Anzeigen einer Seitenvorschau, Drucken oder Größenanpassung von XLANG-Ablaufplanzeichnungen
 Sie können eine XLANG-Ablaufplanzeichnung ausdrucken, sie vor dem Drucken anzeigen oder die Größe der Zeichnung anpassen.
  • Hinzufügen, Löschen und Verbinden von Formen
 Positionieren und logisches Verbinden von Formen, die für Aktionen in der XLANG-Ablaufplanzeichnung stehen.
  • Markieren einer Form
 Durch das Markieren einer Form können Sie Formeigenschaften bearbeiten, Ausschneide- und Einfügevorgänge mit der Form durchführen oder Verbindungen zwischen Formen erstellen.
  • Verbinden zweier Formen
 Darstellen des Prozessablaufs und Kommunikationsflusses, indem Aktionen mit anderen Aktionen oder mit Ports verbunden werden.
  • Verwenden des Verbindungstools
 Mit diesem Tool können leicht Verbindungen zwischen Aktionen gezeichnet werden.
  • Ausrichten von Formen entlang einer vertikalen oder horizontalen Achse
 Vertikales und horizontales Ausrichten von Formen, um so das Aussehen und die Übersichtlichkeit einer Ablaufplanzeichnung zu verbessern.
Festlegen von Bedingungseigenschaften:
  • Festlegen von Entscheidungsbedingungen
 Hinzufügen von Regeln zu einer Entscheidung-Form oder Bestimmen der Reihenfolge, in der die Regeln ausgewertet werden.
  • Festlegen von Bedingungen für While-Schleifen
 Hinzufügen einer Regel, die bestimmt, ob die Ausführung einer While-Schleife fortgesetzt wird.
  • Beibehalten des Status innerhalb einer While-Schleife
 Angeben, ob die in den Schleifendurchläufen verwendeten Nachrichten in den gespeicherten Status eines XLANG-Ablaufplanes aufgenommen werden.
Erstellen von Regeln:
  • Erstellen einer neuen Regel
 Auswerten von Bedingungen in Entscheidungen und While-Schleifen innerhalb des Geschäftprozesses.
  • Verwenden des Ausdrucks-Assistenten
 Hinzufügen der Namen von Nachrichten und Feldern zum Skriptausdruck innerhalb einer Regel.
  • Hinzufügen von Konstanten zu einer Regel
 Verwenden von Konstanten von der Seite Daten innerhalb eines Skriptausdrucks.
Festlegen von Parallelitätseigenschaften:
  • Erstellen paralleler Abläufe
 Erstellen von getrennten, aber parallelen logischen Abläufen oder Verzweigungen innerhalb des Geschäftsprozesses.
  • Festlegen der Verknüpfungstyp-Eigenschaft
 Angeben, ob alle parallelen Prozesse abgeschlossen sein müssen, bevor mit der nächsten Aktion fortgefahren wird.
  • Zusammenführen paralleler Abläufe
 Synchronisieren von parallelen Aktionen, so dass sie als eine Aktion fortgeführt werden.
  • Beenden eines parallelen Ablaufs
 Beenden eines parallelen Ablaufs, so dass er nicht wieder mit den anderen Abläufen zusammengefügt wird.
Festlegen von Transaktionseigenschaften
Festlegen von Transaktionseigenschaften für einen XLANG-Ablaufplan:
  • Festlegen des Transaktionsmodells
 Angeben, ob Transaktionen innerhalb des XLANG-Ablaufplanes zulässig sind oder ob der Ablaufplan als eine COM+-Komponente betrachtet wird. In diesem Fall kann der Ablaufplan im Kontext einer COM+-Komponente vorhanden sein.
  • Festlegen der Transaktionsaktivierung-Eigenschaft
 Angeben, wie sich der XLANG-Ablaufplan im Kontext einer COM+-Transaktion verhält. Sie können festlegen, dass der Ablaufplan COM+-Transaktionen ignoriert oder an ihnen beteiligt ist, oder Sie können festlegen, dass der Ablaufplan immer innerhalb einer Transaktion ausgeführt werden muss oder immer eine neue Transaktion erstellen muss, in der er ausgeführt wird.
Festlegen von Eigenschaften für einzelne Transaktionen:
  • Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion
 Platzieren von Formen oder Abläufen in einer Transaktion-Form, so dass sie wie eine Transaktion behandelt werden.
  • Entwerfen geschachtelter Transaktionen
 Platzieren einer Transaktion in einer anderen.
  • Erstellen von in Transaktionen eintretenden und von Transaktion verlassenden Abläufen
 Angeben der Abläufe, mit denen eine Transaktion begonnen und beendet wird, und Verbinden von Aktionen mit den entsprechenden Ports.
  • Benennen einer Transaktion
 Zuweisen eines Wertes zur Name-Eigenschaft einer Transaktion.
  • Festlegen der Transaktionstyp-Eigenschaft
 Angeben, ob es sich bei der Transaktion um eine befristete Transaktion, eine kurzlebige Transaktion im DTC-Stil oder eine langlebige Transaktion handelt.
  • Festlegen der Timeout-Eigenschaft
 Festlegen der Zeit (in Sekunden), die der Transaktion für ihre Ausführung zur Verfügung steht, bevor sie abgebrochen wird.
  • Festlegen der Wiederholungsanzahl-Eigenschaft
 Festlegen, wie häufig ein Prozess in einer kurzlebigen Transaktion im DTC-Stil erneut ausgeführt wird, wenn der Prozess nicht beendet wird.
  • Festlegen der Backoffzeit-Eigenschaft
 Festlegen der Zeitdauer zwischen den Wiederholungsversuchen einer Transaktion.
  • Festlegen der Isolationsebene-Eigenschaft
 Angeben des Grades, bis zu dem Daten in parallelen kurzlebigen Transaktionen im DTC-Stil füreinander verfügbar sind.
  • Festlegen der Eigenschaft für den persistenten Status des Ablaufplanes
 Angeben, ob der Status eines Ablaufplanes persistent gespeichert wird, bevor eine Transaktion beginnt.
Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing:
  • Beschreiben der Transaktionsunterstützungsebene durch eine COM-Komponente
 Angeben, ob Transaktionen für diese COM-Komponente deaktiviert sind, unterstützt oder nicht unterstützt werden, erforderlich sind oder neu sein müssen.
  • Beschreiben der Transaktionsunterstützungsebene durch eine Windows-Skriptkomponente
 Angeben, ob Transaktionen für diese Windows-Skriptkomponente deaktiviert sind, unterstützt oder nicht unterstützt werden, erforderlich sind oder neu sein müssen.
  • Beschreiben der Transaktionsunterstützung durch eine Nachrichtenwarteschlange
 Angeben, ob Transaktionen bei dieser Warteschlange erforderlich sind.
Festlegen von Fehlerbehandlungseigenschaften:
  • Abbrechen eines Prozessablaufs
 Wenn die Anwendung einer Regel zu einem unerwarteten oder falschen Wert führt, können Sie den Prozessablauf abbrechen.
Aktivieren der Transaktionsfehlerbehandlung:
  • Aktivieren der Bei Fehler von-Fehlerbehandlung
 Sie können diese Fehlerbehandlung aktivieren, damit der XLANG-Ablaufplan Bei Fehler von Transaktion-Code ausführen kann, um Fehler während einer Transaktion effektiv zu behandeln.
  • Aktivieren der Kompensierung für-Fehlerbehandlung
 Sie können diese Fehlerbehandlung aktivieren, damit der XLANG-Ablaufplan Kompensierung für Transaktion ausführen kann, um für die Ergebnisse einer geschachtelten Transaktion einen Rollback durchzuführen.
Aktivieren der Fehlerbehandlung durch Komponenten:
  • Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine COM-Komponente
 Angeben, ob eine Transaktion abgebrochen werden soll, wenn ein Methodenaufruf einer COM-Komponente ein Fehler-HRESULT zurückgibt.
  • Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine Windows-Skriptkomponente
 Angeben, ob eine Transaktion abgebrochen werden soll, wenn ein Methodenaufruf einer Windows-Skriptkomponente ein Fehler-HRESULT zurückgibt.
Implementieren von Ports:
  • Hinzufügen eines ungebundenen Ports zu einer XLANG-Ablaufplanzeichnung
 Sie können dies ausführen, um einen Port zu einem Ablaufplan hinzuzufügen, bevor Sie die Details einer Implementierung für den Port festlegen.
  • Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung
 Hinzufügen einer Portimplementierung direkt zum Ablaufplan.
  • Implementieren eines Ports mithilfe einer COM-Komponente
 Verwenden einer vorhandenen COM-Komponente oder Anwendung zum Ausführen einer Aktion.
  • Implementieren eines Ports mithilfe einer Windows-Skriptkomponente
 Verwenden einer vorhandenen Windows-Skriptkomponente zum Ausführen einer Aktion.
  • Implementieren eines Ports mithilfe von Message Queuing
 Ermöglichen der Kommunikation eines Ablaufplanes mit anderen Ablaufplänen oder Anwendungen über flexible Verbindungen.
  • Implementieren eines Ports mithilfe von BizTalk Messaging
 Ermöglichen, dass der Ablaufplan die BizTalk-Messagingdienste für die Kommunikation nutzen kann.
  • Ändern der Eigenschaften einer Portimplementierung
 Ändern einer Reihe von Eigenschaften, die den Typ und das Verhalten der Implementierung bestimmen.
Senden oder Empfangen von Nachrichten:
  • Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port
 Erstellen eines Kommunikationsflusses zwischen einer Aktion in Ihrem Geschäftsprozess und einem externen Geschäftsprozess.
  • Senden oder Empfangen synchroner Nachrichten
 Angeben eines synchronen Kommunikationsflusses zwischen einer Aktion in Ihrem Geschäftsprozess und einem externen Geschäftsprozess.
  • Senden oder Empfangen asynchroner Nachrichten
 Angeben eines asynchronen Kommunikationsflusses zwischen einer Aktion in Ihrem Geschäftsprozess und einem externen Geschäftsprozess.
  • Ändern des Kommunikationsflusses zwischen einer Aktion und einem Port
 Angeben, ob der Kommunikationsfluss synchron oder asynchron ist.
  • Festlegen des Datenflusses zwischen Nachrichten
 Sie können Dateninteraktionen beschreiben, indem Sie Nachrichten, deren Felder und Ports auswählen und den Datenfluss zwischen diesen Elementen zeichnen.
  • Verwenden von Konstanten
 Verwenden Sie auf der Seite Daten angegebene Konstanten, um Daten für Nachrichtenfelder bereitzustellen.
Ausführen von XLANG-Ablaufplänen
Kompilieren und Debuggen von XLANG-Ablaufplänen:
  • Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan
 Erstellen eines ausführbaren XLANG-Ablaufplan mithilfe der entsprechenden XLANG-Ablaufplanzeichnung eines Geschäftsprozesses.
  • Ausführen eines XLANG-Ablaufplanes
 Ausführen eines Geschäftsprozesses; die grundlegende Aktion von BizTalk Server.
  • Zusammenfassen eines XLANG-Ablaufplanes
 Steuern der Anzahl von XLANG-Ablaufplaninstanzen, die gleichzeitig im Arbeitsspeicher aktiv sein können, um so die Ressourcenverwendung zu optimieren.
  • Debuggen kompilierter Visual Basic-Komponenten
 Festlegen von Haltepunkten, Anzeigen von Code und Debuggen von mit Microsoft Visual Basic erstellten Komponenten.
  • Aktualisieren von Methodensignaturen
 Wenn Sie Parameter verfügbarer Methodenaufrufe geändert haben, verwenden Sie dieses Verfahren, um die Parameter der Methode dem Ablaufplan zur Verfügung zu stellen.
  • Herunterfahren aller aktiven XLANG-Ablaufpläne
 Ändern der von einem Ablaufplan verwendeten COM-Komponenten. Wenn eine Ablaufplaninstanz ausgeführt wird, wird die Datei mit der COM-Komponente gesperrt.
Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan:
  • Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne
 Für den Fall, dass es aufgrund von Sicherheits-, Bereitstellungs- oder Konfigurationsproblemen vorteilhafter ist, einen Ablaufplan über eine COM+-Anwendung auszuführen.
  • Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne
 Festlegen oder Ändern einer Reihe von COM+-Anwendungseigenschaften, die sich auf die Leistung und das Verhalten der Hostanwendung auswirken.


Durchführen von Aufgaben des BizTalk-Orchestrierungs-Designers

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen von XLANG-Ablaufplanzeichnungen und zum Kompilieren dieser XLANG-Ablaufplanzeichnungen in ausführbare XLANG-Ablaufpläne mithilfe des BizTalk-Orchestrierungs-Designers bereit. Dieser Abschnitt stellt außerdem Informationen zur Vorgehensweise beim Ausführen eines XLANG-Ablaufplanes bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Informationen zum BizTalk-Orchestrierungs-Designer lesen, um alle Features und Fähigkeiten des BizTalk-Orchestrierungs-Designers vollständig zu verstehen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden des BizTalk-Orchestrierungs-Designers

  • Ausführung von XLANG-Ablaufplänen

Anmerkung

  • Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln, Warteschlangen und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.


Verwenden des BizTalk-Orchestrierungs-Designers

Dieser Abschnitt enthält Verfahrensbeschreibungen, die erläutern, wie Sie mithilfe des BizTalk-Orchestrierungs-Designers neue XLANG-Ablaufplanzeichnungen entwerfen und diese in ausführbare XLANG-Ablaufpläne kompilieren.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Öffnen und Speichern von XLANG-Ablaufplanzeichnungen

  • Anzeigen von Entwurfsseiten, Formen und Schablonen

  • Hinzufügen, Löschen und Verbinden von Formen

  • Festlegen von Bedingungseigenschaften

  • Festlegen von Parallelitätseigenschaften

  • Festlegen von Transaktionseigenschaften

  • Festlegen von Fehlerbehandlungseigenschaften

  • Implementieren von Ports

  • Senden oder Empfangen von Nachrichten

  • Festlegen des Datenflusses zwischen Nachrichten

Anmerkungen

  • Falls eine oder mehrere Dateien im Ordner VBA beschädigt oder nicht ordnungsgemäß registriert wurden, können Sie den BizTalk-Orchestrierungs-Designer unter Umständen nicht öffnen. Dieses Problem kann beim Deinstallieren von Microsoft Office verursacht werden.
    • Wenn Office nicht installiert ist: Suchen Sie auf der Microsoft Office-CD die Datei Vba6.msi, klicken Sie mit der rechten Maustaste darauf, und klicken Sie dann auf Installieren.

    • Wenn Office installiert ist: Öffnen Sie Microsoft Access, erstellen Sie eine leere Datenbank, speichern Sie diese, und schließen Sie Access.
  • Wenn Sie beim Verwenden von Microsoft Visio die Standardsymbolleiste ausblenden, können Sie diese nicht beim Öffnen des Orchestrierungs-Designers sehen. Gehen Sie zum Anzeigen der Standardsymbolleiste folgendermaßen vor:
    1. Klicken Sie im Menü Datei auf Beenden, um den BizTalk-Orchestrierungs-Designer zu schließen. Zeigen Sie im Startmenü auf Programme, und klicken Sie dann auf Microsoft Visio.

    2. Zeigen Sie im Menü Ansicht auf Symbolleisten, und klicken Sie auf Standard.

    3. Klicken Sie im Menü Datei auf Beenden, um Visio zu schließen.

    4. Zeigen Sie im Startmenü auf Programme und auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Orchestrierungs-Designer.

      Die Symbolleiste wird angezeigt.

  • Nach dem Verwenden des BizTalk-Orchestrierungs-Designers kann beim Öffnen von Visio auf einige Menüs und Symbolleisten nicht mehr zugegriffen werden. Sie können das Kontextmenü in Visio verwenden, um Symbolleisten und Menüs anzupassen und die gewünschten Elemente zu reaktivieren.

Internationales Problem

  • In einigen Sprachen werden bestimmte Zeichen u. U. im BizTalk-Orchestrierungs-Designer nicht richtig angezeigt. Sie können angeben, dass Microsoft Visio 2002 stets die Standardschriftart des Systems verwenden muss, um dies zu beheben:
    1. Schließen Sie den BizTalk-Orchestrierungs-Designer.

    2. Zeigen Sie im Startmenü auf Programme, und klicken Sie dann auf Microsoft Visio.

    3. Klicken Sie im Menü Extras auf Optionen.

      Das Dialogfeld Optionen wird angezeigt.

    4. Klicken Sie auf die Registerkarte Ländereinstellungen, und klicken Sie im Bereich Basisschriftart des Dokuments auf Immer Standardschriftart verwenden.

    5. Schließen Sie Visio, und öffnen Sie den BizTalk-Orchestrierungs-Designer.


Öffnen und Speichern von XLANG-Ablaufplanzeichnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer neuen XLANG-Ablaufplanzeichnung

  • Öffnen einer vorhandenen XLANG-Ablaufplanzeichnung

  • Speichern einer XLANG-Ablaufplanzeichnung


Erstellen einer neuen XLANG-Ablaufplanzeichnung

Dieses Verfahren öffnet eine neue XLANG-Ablaufplanzeichnung im Entwurfsfenster. Die Seite Geschäftprozess ist die standardmäßig zuerst angezeigte Entwurfsseite. Die Schablonen Flussdiagramm und Implementierung werden beim Start einer neuen Zeichnung ebenfalls standardmäßig geöffnet.

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Datei auf Neu.

Anmerkung

  • Die Dateinamenerweiterung für eine XLANG-Ablaufplanzeichnung lautet SKV.

Verwandte Themen

Öffnen einer vorhandenen XLANG-Ablaufplanzeichnung

Speichern einer XLANG-Ablaufplanzeichnung


Öffnen einer vorhandenen XLANG-Ablaufplanzeichnung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Datei auf Öffnen.

    Das Dialogfeld XLANG-Ablaufplanzeichnung öffnen wird angezeigt.

  2. Suchen Sie nach der XLANG-Ablaufplanzeichnung, die Sie öffnen möchten, klicken Sie auf die Zeichnung und anschließend auf Öffnen.

Anmerkungen

  • Die Dateinamenerweiterung für eine XLANG-Ablaufplanzeichnung lautet SKV.

  • Die Dateinamenerweiterung für einen XLANG-Ablaufplan lautet SKX. Eine SKX-Datei kann nicht im BizTalk-Orchestrierungs-Designer geöffnet werden. Um eine SKX-Datei zu ändern oder zu aktualisieren, öffnen Sie die Quelldatei (SKV-Datei), nehmen die gewünschten Änderungen daran vor und kompilieren anschließend die SKV-Datei in eine SKX-Datei.

Verwandte Themen

Erstellen einer neuen XLANG-Ablaufplanzeichnung

Speichern einer XLANG-Ablaufplanzeichnung


Speichern einer XLANG-Ablaufplanzeichnung

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Datei auf Speichern.

Anmerkungen

  • Wenn Sie eine XLANG-Ablaufplanzeichnung speichern, wird die Zeichnung unter dem Standarddateinamen ZeichnungX.skv abgelegt, wobei X eine Zahl darstellt, die an den Namen der Zeichnung angehängt wird. Der Name der Datei kann beim Speichern der Zeichnung geändert werden.

  • Sie können auch im Menü Datei auf Speichern unter klicken. Dieser Befehl öffnet das Dialogfeld XLANG-Ablaufplanzeichnung speichern unter. Folgende Aktionen sind möglich:
    • Umbenennen der Datei.

    • Speichern der Datei unter einem anderen Pfad.
  • Die Dateinamenerweiterung für eine XLANG-Ablaufplanzeichnung lautet SKV.

  • Die Dateinamenerweiterung für einen XLANG-Ablaufplan lautet SKX. Eine SKX-Datei kann nicht im BizTalk-Orchestrierungs-Designer geöffnet werden. Um eine SKX-Datei zu ändern oder zu aktualisieren, öffnen Sie die Quelldatei (SKV-Datei), nehmen die gewünschten Änderungen daran vor und kompilieren anschließend die SKV-Datei in eine SKX-Datei.

Verwandte Themen

Erstellen einer neuen XLANG-Ablaufplanzeichnung

Öffnen einer vorhandenen XLANG-Ablaufplanzeichnung


Anzeigen von Entwurfsseiten, Formen und Schablonen

Der BizTalk-Orchestrierungs-Designer stellt mehrere Anzeigeoptionen bereit, mit deren Hilfe Sie die Zeichenfläche maximieren oder spezielle Formen oder Datenrelationen anzeigen können.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Anzeigen der Entwurfsseiten

  • Anzeigen von Formen

  • Anzeigen von Schablonen

  • Verwenden mehrerer Fenster

  • Verwenden von Anmerkungen

  • Anzeigen einer Seitenvorschau, Drucken oder Größenanpassung von XLANG-Ablaufplanzeichnungen


Anzeigen der Entwurfsseiten

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Anzeigen der Entwurfsseiten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Anzeigen der Seite "Geschäftprozess"

  • Anzeigen der Seite "Daten"

  • Anzeigen der Geschäftsprozess- und Datenseiten

  • Anzeigen der Seiten "Kompensierung für Transaktion"

  • Anzeigen der Seiten "Bei Fehler von Transaktion"

  • Anzeigen einer Seite

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen von Formen

Anzeigen von Schablonen


Anzeigen der Seite "Geschäftprozess"

  • Klicken Sie im Menü Ansicht auf Geschäftsprozessseite.

Anmerkung

  • Sie können auch auf die Registerkarte Geschäftsprozess klicken, die sich am unteren Rand der Entwurfsseiten befindet.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Daten"


Anzeigen der Seite "Daten"

  • Klicken Sie im Menü Ansicht auf Datenseite.

Anmerkung

  • Sie können auch auf die Registerkarte Daten klicken, die sich am unteren Rand der Entwurfsseiten befindet.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Geschäftprozess"


Anzeigen der Geschäftsprozess- und Datenseiten

  • Klicken Sie im Menü Ansicht auf Geschäftsprozess- und Datenseiten.

Anmerkung

  • Diese Anzeigeoption öffnet zwei Fenster für ein und denselben XLANG-Ablaufplan: ein Fenster Geschäftsprozess und ein Fenster Daten. Diese Funktion ähnelt der Funktion, die mithilfe des Befehls Neues Fenster zur Verfügung steht. Weitere Informationen zum Öffnen mehrerer Fenster finden Sie unter Verwenden mehrerer Fenster.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Seite "Geschäftprozess"

Anzeigen der Seite "Daten"


Anzeigen der Seiten "Kompensierung für Transaktion"

  • Klicken Sie am unteren Rand der Entwurfsseiten auf die Registerkarte Kompensierung für Transaktion der Seite, die Sie anzeigen möchten.

Anmerkungen

  • Der Platzhalter Transaktion im Namen der Seite wird ersetzt durch den Namen der Transaktion, mit der der Fehlerbehandlungsprozess verknüpft ist.

  • Informationen zur Vorgehensweise beim Hinzufügen einer Seite Kompensierung für Transaktion zu einer XLANG-Ablaufplanzeichnung finden Sie unter Aktivieren der Kompensierung für-Fehlerbehandlung.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Geschäftprozess"

Anzeigen der Seite "Daten"


Anzeigen der Seiten "Bei Fehler von Transaktion"

  • Klicken Sie am unteren Rand der Entwurfsseiten auf die Registerkarte Bei Fehler von Transaktion der Seite, die Sie anzeigen möchten.

Anmerkungen

  • Der Platzhalter Transaktion im Namen der Seite wird ersetzt durch den Namen der Transaktion, mit der der Fehlerbehandlungsprozess verknüpft ist.

  • Informationen zur Vorgehensweise beim Hinzufügen einer Seite Bei Fehler von Transaktion zu einer XLANG-Ablaufplanzeichnung finden Sie unter Aktivieren der Bei Fehler von-Fehlerbehandlung.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen einer Seite

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Geschäftprozess"

Anzeigen der Seite "Daten"


Anzeigen einer Seite

  • Klicken Sie auf die Registerkarte für die Seite, die Sie anzeigen möchten.

Anmerkung

  • Die Registerkarten für die einzelnen Seiten befinden sich am unteren Rand der Entwurfsseiten.

Verwandte Themen

Verwenden mehrerer Fenster

Anzeigen der Seiten "Kompensierung für Transaktion"

Anzeigen der Seiten "Bei Fehler von Transaktion"

Anzeigen von Formen

Anzeigen von Schablonen

Anzeigen der Geschäftsprozess- und Datenseiten

Anzeigen der Seite "Geschäftprozess"

Anzeigen der Seite "Daten"


Anzeigen von Formen

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Anzeigen von Formen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Anzeigen von Flussdiagrammformen

  • Anzeigen von Flussdiagramm- und Kommunikationsformen

  • Anzeigen von Flussdiagramm-, Kommunikations- und Implementierungsformen

Verwandte Themen

Anzeigen von Schablonen

Anzeigen der Entwurfsseiten


Anzeigen von Flussdiagrammformen

Bei Verwendung dieser Option werden auf der Entwurfsseite nur Flussdiagrammformen und die Verbindungen zwischen ihnen angezeigt. Diese Option blendet alle Ports, Portnachrichten, Portimplementierungen und Verbindungen zwischen Ports und Aktionen oder zwischen Ports und Implementierungen aus.

  • Klicken Sie im Menü Ansicht auf Flussdiagrammformen.

Anmerkungen

  • Diese Anzeigeoption kann nicht auf der Datenseite verwendet werden.

Verwandte Themen

Anzeigen von Flussdiagramm- und Kommunikationsformen

Anzeigen von Flussdiagramm-, Kommunikations- und Implementierungsformen

Anzeigen von Schablonen

Anzeigen der Entwurfsseiten


Anzeigen von Flussdiagramm- und Kommunikationsformen

Bei Verwendung dieser Option werden auf der Entwurfsseite Flussdiagrammformen und die Verbindungen zwischen ihnen angezeigt. Ports, Portnachrichten und die Verbindungen zwischen Ports und Aktionen werden ebenfalls angezeigt. Diese Option blendet alle Implementierungen und Verbindungen zwischen Ports und Implementierungen aus.

  • Klicken Sie im Menü Ansicht auf Flussdiagramm- und Kommunikationsformen.

Anmerkungen

  • Diese Anzeigeoption kann nicht auf der Datenseite verwendet werden.

Verwandte Themen

Anzeigen von Flussdiagramm-, Kommunikations- und Implementierungsformen

Anzeigen von Flussdiagrammformen

Anzeigen von Schablonen

Anzeigen der Entwurfsseiten


Anzeigen von Flussdiagramm-, Kommunikations- und Implementierungsformen

  • Klicken Sie im Menü Ansicht auf Flussdiagramm-, Kommunikations- und Implementierungsformen.

Anmerkungen

  • Alle Formen und die Verbindungen zwischen ihnen werden angezeigt.

  • Diese Anzeigeoption kann nicht auf der Datenseite verwendet werden.

Verwandte Themen

Anzeigen von Flussdiagramm- und Kommunikationsformen

Anzeigen von Flussdiagrammformen

Anzeigen von Schablonen

Anzeigen der Entwurfsseiten


Anzeigen von Schablonen

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Anzeigen von Schablonen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Anzeigen der Flussdiagramm-Schablone

  • Anzeigen der Implementierung-Schablone

Verwandte Themen

Anzeigen von Formen

Anzeigen der Entwurfsseiten


Anzeigen der Flussdiagramm-Schablone

  • Zeigen Sie im Menü Ansicht auf Schablonen, und klicken Sie auf Flussdiagramm, um die Flussdiagramm-Schablone ein- oder auszublenden.

Verwandte Themen

Anzeigen von Formen

Anzeigen der Entwurfsseiten

Anzeigen der Implementierung-Schablone


Anzeigen der Implementierung-Schablone

  • Zeigen Sie im Menü Ansicht auf Schablonen, und klicken Sie auf Implementierung, um die Implementierung-Schablone ein- oder auszublenden.

Verwandte Themen

Anzeigen von Formen

Anzeigen der Entwurfsseiten

Anzeigen der Flussdiagramm-Schablone


Verwenden mehrerer Fenster

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Verwenden mehrerer Fenster

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Öffnen eines neuen Fensters

  • Anordnen von Fenstern nebeneinander

  • Überlappendes Anordnen von Fenstern

  • Umschalten zwischen Fenstern

Verwandtes Thema

Anzeigen der Entwurfsseiten


Öffnen eines neuen Fensters

  • Klicken Sie im Menü Fenster auf Neues Fenster.

Anmerkung

  • Mehrere Fenster bieten zusätzliche Sichten desselben XLANG-Ablaufplanes. Auf diese Weise können Sie Folgendes durchführen:
    • Verschiedene Seiten desselben XLANG-Ablaufplanes zur selben Zeit anzeigen. Sie können z. B. Sichten für die Geschäftsprozessseite, die Datenseite und eine Seite Kompensierung für Transaktion öffnen.

    • Verschiedene Teile derselben Seite eines XLANG-Ablaufplanes zur selben Zeit anzeigen. Beispielsweise können Sie in der einen Sicht eine Vergrößerung anzeigen, um einen bestimmten Satz von Formen im XLANG-Ablaufplan zu betrachten; in einer anderen Sicht können Sie eine Verkleinerung anzeigen, um den gesamten Ablaufplan zu sehen.

Verwandte Themen

Überlappendes Anordnen von Fenstern

Umschalten zwischen Fenstern

Anordnen von Fenstern nebeneinander

Anzeigen der Entwurfsseiten


Anordnen von Fenstern nebeneinander

Sie können mehrere Fenster zur selben Zeit zu betrachten, indem Sie die Fenster nebeneinander anordnen.

  • Klicken Sie im Menü Fenster auf Nebeneinander.

Anmerkungen

  • Mehrere Fenster bieten zusätzliche Sichten desselben XLANG-Ablaufplanes. Auf diese Weise können Sie Folgendes durchführen:
    • Verschiedene Seiten desselben XLANG-Ablaufplanes zur selben Zeit anzeigen. Sie können z. B. Sichten für die Geschäftsprozessseite, die Datenseite und eine Seite Kompensierung für Transaktion öffnen.

    • Verschiedene Teile derselben Seite eines XLANG-Ablaufplanes zur selben Zeit anzeigen. Beispielsweise können Sie in der einen Sicht eine Vergrößerung anzeigen, um einen bestimmten Satz von Formen im XLANG-Ablaufplan zu betrachten; in einer anderen Sicht können Sie eine Verkleinerung anzeigen, um den gesamten Ablaufplan zu sehen.

Verwandte Themen

Überlappendes Anordnen von Fenstern

Umschalten zwischen Fenstern

Öffnen eines neuen Fensters

Anzeigen der Entwurfsseiten


Überlappendes Anordnen von Fenstern

Sie können eines der Fenster in den Vordergrund des Bildschirmes platzieren, indem Sie die Fenster überlappend anordnen. Sie können dann auf die Titelleisten der anderen Fenster klicken, um diese Fenster in den Vordergrund zu bringen.

  • Klicken Sie im Menü Fenster auf Überlappend.

Anmerkungen

  • Mehrere Fenster bieten zusätzliche Sichten desselben XLANG-Ablaufplanes. Auf diese Weise können Sie Folgendes durchführen:
    • Verschiedene Seiten desselben XLANG-Ablaufplanes zur selben Zeit anzeigen. Sie können z. B. Sichten für die Geschäftsprozessseite, die Datenseite und eine Seite Kompensierung für Transaktion öffnen.

    • Verschiedene Teile derselben Seite eines XLANG-Ablaufplanes zur selben Zeit anzeigen. Beispielsweise können Sie in der einen Sicht eine Vergrößerung anzeigen, um einen bestimmten Satz von Formen im XLANG-Ablaufplan zu betrachten; in einer anderen Sicht können Sie eine Verkleinerung anzeigen, um den gesamten Ablaufplan zu sehen.

Verwandte Themen

Umschalten zwischen Fenstern

Öffnen eines neuen Fensters

Anordnen von Fenstern nebeneinander

Anzeigen der Entwurfsseiten


Umschalten zwischen Fenstern

  • Klicken Sie im Menü Fenster auf den Namen des Fensters, zu dem Sie umschalten möchten.

Anmerkungen

  • Der Name eines Fensters ist der Name des XLANG-Ablaufplanes mit dem angehängten Namen einer Entwurfsseite (z. B. Schedule1.skv:Business Process oder Schedule1.skv:Data).

  • Mehrere Fenster bieten zusätzliche Sichten desselben XLANG-Ablaufplanes. Auf diese Weise können Sie Folgendes durchführen:
    • Verschiedene Seiten desselben XLANG-Ablaufplanes zur selben Zeit anzeigen. Sie können z. B. Sichten für die Geschäftsprozessseite, die Datenseite und eine Seite Kompensierung für Transaktion öffnen.

    • Verschiedene Teile derselben Seite eines XLANG-Ablaufplanes zur selben Zeit anzeigen. Beispielsweise können Sie in der einen Sicht eine Vergrößerung anzeigen, um einen bestimmten Satz von Formen im XLANG-Ablaufplan zu betrachten; in einer anderen Sicht können Sie eine Verkleinerung anzeigen, um den gesamten Ablaufplan zu sehen.

Verwandte Themen

Überlappendes Anordnen von Fenstern

Öffnen eines neuen Fensters

Anordnen von Fenstern nebeneinander

Anzeigen der Entwurfsseiten


Verwenden von Anmerkungen

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Verwenden von Anmerkungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Anmerkungen

  • Bearbeiten von Anmerkungen

  • Formatieren von Text in Anmerkungen

  • Löschen von Anmerkungen


Hinzufügen von Anmerkungen

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Symbolleiste auf die Schaltfläche Text einfügen/bearbeiten ( Schaltfläche Text einfügen/bearbeiten).

  2. Ziehen Sie den Mauszeiger auf den Bereich, in dem Sie eine Anmerkung erstellen möchten.

  3. Geben Sie die Anmerkung ein.

Anmerkungen

  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Standardzeiger ( Schaltfläche Standardzeiger), um das Texttool auszublenden.

  • Da der BizTalk-Orchestrierungs-Designer eine angepasste Microsoft Visio-Oberfläche verwendet, ist die Schaltfläche Text einfügen/bearbeiten in zwei Varianten verfügbar. Die Funktionalität beider Schaltflächen ist identisch:
    • Die Schaltfläche Text einfügen/bearbeiten ( Schaltfläche Text einfügen/bearbeiten)

    • Die Schaltfläche Textblock drehen ( Schaltfläche Textblock drehen)

Verwandte Themen

Löschen von Anmerkungen

Bearbeiten von Anmerkungen

Formatieren von Text in Anmerkungen


Bearbeiten von Anmerkungen

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Symbolleiste auf die Schaltfläche Text einfügen/bearbeiten ( Schaltfläche Text einfügen/bearbeiten).

  2. Klicken Sie auf die zu bearbeitende Anmerkung.

  3. Bearbeiten Sie die Anmerkung.

Anmerkungen

  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Standardzeiger ( Schaltfläche Standardzeiger), um das Texttool auszublenden.

  • Da der BizTalk-Orchestrierungs-Designer eine angepasste Microsoft Visio-Oberfläche verwendet, ist die Schaltfläche Text einfügen/bearbeiten in zwei Varianten verfügbar. Die Funktionalität beider Schaltflächen ist identisch:
    • Die Schaltfläche Text einfügen/bearbeiten ( Schaltfläche Text einfügen/bearbeiten)

    • Die Schaltfläche Textblock drehen ( Schaltfläche Textblock drehen)

Verwandte Themen

Hinzufügen von Anmerkungen

Löschen von Anmerkungen

Formatieren von Text in Anmerkungen


Formatieren von Text in Anmerkungen

  1. Markieren Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine oder mehrere Anmerkungen, die Sie formatieren möchten.

  2. Klicken Sie im Menü Format auf Text.

    Das Dialogfeld Zeichen wird angezeigt. Das Dialogfeld bietet mehrere Optionen zur Auswahl des Schriftgrades, der Schriftart und der Textgestaltung.

  3. Wählen Sie die Optionen aus, die Sie verwenden möchten, und klicken Sie auf OK.

Anmerkungen

  • Diese Optionen werden für alle Anmerkungen übernommen, die Sie in der XLANG-Ablaufplanzeichnung markiert haben, sowie für alle Anmerkungen, die Sie anschließend neu erstellen.

  • Anmerkungen können nicht formatiert werden, solange das Texttool aktiviert ist.

  • Um eine Anmerkung zu markieren, klicken Sie darauf. Soll mehr als eine Anmerkung markiert werden, klicken Sie bei gedrückter UMSCHALTTASTE auf die Anmerkungen, die Sie auswählen möchten.

Verwandte Themen

Hinzufügen von Anmerkungen

Löschen von Anmerkungen

Bearbeiten von Anmerkungen


Löschen von Anmerkungen

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf die Anmerkung, die Sie löschen möchten, und drücken Sie anschließend die ENTF-TASTE.

Anmerkung

  • Sie müssen das Texttool deaktivieren, bevor Sie eine Anmerkung in der XLANG-Ablaufplanzeichnung löschen können.

Verwandte Themen

Hinzufügen von Anmerkungen

Formatieren von Text in Anmerkungen


Anzeigen einer Seitenvorschau, Drucken oder Größenanpassung von XLANG-Ablaufplanzeichnungen

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Anzeigen einer Seitenvorschau, Drucken oder Größenanpassung von XLANG-Ablaufplanzeichnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Verwenden der Seitenansicht

  • Drucken einer XLANG-Ablaufplanzeichnung

  • Anpassen der Größe einer XLANG-Ablaufplanzeichnung


Verwenden der Seitenansicht

  • Klicken Sie im Menü Datei auf Seitenansicht.

Anmerkung

  • Wenn Sie die Einstellung der Option Layout von Querformat in Hochformat ändern, wird die folgende Meldung angezeigt:

    "Eines oder mehrere Zeichenblätter sind anders ausgerichtet, als unter Seite einrichten vorgegeben. Klicken Sie OK, um die Zeichnung auf mehrere Seiten verteilt auszudrucken, oder passen Sie die Ausrichtung entsprechend an. Ändern Sie die Seitenausrichtung für den Druck, um eine übereinstimmende Ausrichtung zu erreichen."

    Wenn Sie auf OK klicken und diese Änderung vornehmen, zeigt die Seitenansicht möglicherweise folgendes Verhalten an:

    • Wenn Sie auf Nächste Druckseite klicken, um vorwärts zu blättern, und anschließend auf Vorherige Druckseite klicken, um zur ersten Seite zurückzukehren, werden einige Formen in der Seitenansicht so angezeigt, als ob sie sich nicht auf der Seite befänden. Dieses Anzeigeverhalten ist kein Anlass zur Sorge. Der eigentliche Ausdruck des XLANG-Ablaufplanes erfolgt problemlos auch über mehrere Seiten hinweg.

Verwandte Themen

Drucken einer XLANG-Ablaufplanzeichnung

Anpassen der Größe einer XLANG-Ablaufplanzeichnung


Drucken einer XLANG-Ablaufplanzeichnung

  1. Klicken Sie im Menü Datei auf Drucken.

    Das Dialogfeld Drucken wird angezeigt.

  2. Legen Sie die gewünschten Optionen fest, und klicken Sie auf Drucken.

Anmerkung

  • Stellen Sie sicher, dass ein Drucker installiert ist, bevor Sie versuchen, eine XLANG-Ablaufplanzeichnung auszudrucken.

Verwandte Themen

Anpassen der Größe einer XLANG-Ablaufplanzeichnung

Verwenden der Seitenansicht


Anpassen der Größe einer XLANG-Ablaufplanzeichnung

  1. Zeigen Sie im BizTalk-Orchestrierungs-Designer im Menü Ansicht auf Zoom und klicken dann auf Ganzes Zeichenblatt.

  2. Drücken Sie STRG und halten Sie die Taste gedrückt, während Sie den Mauszeiger über den Seitenrand positionieren.

    Über dem Seitenrand ändert der Mauszeiger sein Aussehen und nimmt die Form eines Doppelpfeiles an.

  3. Klicken Sie auf den Seitenrand, und ziehen Sie den Seitenrand in geeigneter Weise, um die Größe der Seite anzupassen.

Verwandte Themen

Drucken einer XLANG-Ablaufplanzeichnung

Verwenden der Seitenansicht


Hinzufügen, Löschen und Verbinden von Formen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Formen

  • Benennen von Formen

  • Löschen von Formen

  • Löschen nicht verwendeter Ports und Nachrichten

  • Verbinden von Formen


Hinzufügen von Formen

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Flussdiagramm-Schablone auf eine Form, und ziehen Sie sie auf die Entwurfsseite.

Anmerkungen

  • Informationen zum Hinzufügen von Implementierungsformen zu einer XLANG-Ablaufplanzeichnung finden Sie unter Implementieren von Ports.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Jedes Mal, wenn eine Aktion mit einem Port verknüpft wird, werden automatisch neue Nachrichten auf der Datenseite generiert.

Verwandte Themen

Verbinden von Formen

Löschen von Formen

Löschen nicht verwendeter Ports und Nachrichten

Benennen von Formen

Anzeigen der Flussdiagramm-Schablone


Benennen von Formen

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Form wird angezeigt.

  2. Geben Sie in das Feld Name einen Wert ein.

Anmerkungen

  • Die Name-Eigenschaft einer jeden Form besitzt einen Standardwert, der sich aus der Bezeichnung der Form und einer angehängten Zahl zusammensetzt, z. B. Aktion 1. Sie können diesen Standardwert durch einen Namen Ihrer Wahl ersetzen.

  • Die folgenden Formen können nicht umbenannt werden: Abbruch, Beginn, Entscheidung, Ende, Verzweigung, Verknüpfung und While.

  • Für folgende Formen ist eine Umbenennung möglich: Aktion, Transaktion, Port, Nachricht und Regel.

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.
  • Transaktionsnamen mit Zeichen aus einem Ein-Byte-Zeichensatz dürfen maximal 16 Zeichen lang sein. Transaktionsnamen mit Zeichen aus einem Zwei-Byte-Zeichensatz dürfen maximal 8 Zeichen lang sein.

  • Aktionen sind bis auf die Beschränkung der Namenslänge auf 32 Zeichen von allen Namenskonventionen ausgenommen.

Verwandte Themen

Hinzufügen von Formen

Verbinden von Formen

Löschen von Formen

Löschen nicht verwendeter Ports und Nachrichten


Löschen von Formen

  • Klicken Sie auf die Form, die Sie löschen möchten, und drücken Sie ENTF.

Anmerkungen

  • Sie können eine Verbindung zwischen zwei Formen löschen, indem Sie auf die Verbindung klicken und anschließend ENTF drücken.

  • Wenn Sie eine Form löschen, die Verbindungen mit anderen Formen besitzt, werden auch diese Verbindungen gelöscht.

  • Wenn Sie eine Transaktion löschen, werden alle Formen, die von dieser Transaktion umschlossen sind, ebenfalls gelöscht.

  • Sie können eine BizTalk-Messaging- oder Message Queuing-Implementierung löschen, ohne damit auch die Ports zu löschen, mit denen diese Implementierungen verbunden sind.

  • Beim Löschen einer Implementierung einer COM-Komponente oder einer Windows Script-Komponente werden die Ports, mit der die Implementierung verbunden ist, ebenfalls gelöscht.

  • Sie können eine Nachricht löschen, indem Sie innerhalb eines Ports auf die Nachricht klicken und ENTF drücken. Die zugehörige Nachricht wird auf der Datenseite gelöscht.

    Sie können Nachrichten auch über die Datenseite löschen. Weitere Informationen finden Sie unter Löschen einer Nachricht.

  • Mithilfe des beschriebenen Verfahrens können Sie keine Regeln löschen. Weitere Informationen zum Löschen von Regeln finden Sie unter den folgenden Themen:
    • Entfernen einer Regel aus einer Entscheidung

    • Entfernen der Regel aus einer While-Schleife

    • Löschen nicht verwendeter Regeln

Verwandte Themen

Hinzufügen von Formen

Verbinden von Formen

Löschen einer Nachricht

Entfernen einer Regel aus einer Entscheidung

Entfernen der Regel aus einer While-Schleife

Löschen nicht verwendeter Ports und Nachrichten

Löschen nicht verwendeter Regeln

Benennen von Formen


Löschen nicht verwendeter Ports und Nachrichten

Dieses Verfahren entfernt alle nicht verwendeten Ports und alle in diesen Ports enthaltenen Nachrichten aus der XLANG-Ablaufplanzeichnung. Die entsprechenden Nachrichten auf der Datenseite werden ebenfalls entfernt.

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Extras auf Nicht verwendete Ports und Nachrichten löschen.

Verwandte Themen

Hinzufügen von Formen

Verbinden von Formen

Löschen von Formen

Benennen von Formen


Verbinden von Formen

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Verbinden von Formen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Markieren einer Form

  • Verbinden zweier Formen

  • Verwenden des Verbindungstools

  • Ausrichten von Formen entlang einer vertikalen oder horizontalen Achse

Verwandte Themen

Hinzufügen von Formen

Löschen von Formen

Löschen nicht verwendeter Ports und Nachrichten

Benennen von Formen


Markieren einer Form

Durch das Markieren einer Form können Sie Folgendes tun:

  • Kontrollhandles ( Kontrollhandle) aus dieser Form zu anderen Formen ziehen.

  • Verfügbare Formeigenschaften bearbeiten.

  • Formen ausschneiden, kopieren, einfügen, löschen und duplizieren.

Nicht alle der genannten Optionen stehen für jede Form zur Verfügung.

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf die zu markierende Form.

    Die markierte Form ist von einem grünen gestrichelten Rand umgeben. Alle für diese Form verfügbaren Kontrollhandles ( Kontrollhandle) sind aktiviert.

Anmerkung

  • Wenn Sie eine Aktion-Form kopieren, die mit einer Port-Form verbunden ist, besitzt die Kopie jener Aktion ebenfalls eine Verbindung mit demselben Port.

Verwandte Themen

Hinzufügen von Formen

Verbinden zweier Formen

Löschen von Formen

Verwenden des Verbindungstools


Verbinden zweier Formen

  1. Um zwei Formen zu verbinden, markieren Sie zunächst die erste Form.

    Die markierte Form ist von einem grünen gestrichelten Rand umgeben. Alle für diese Form verfügbaren Kontrollhandles ( Kontrollhandle) sind aktiviert.

  2. Ziehen Sie das entsprechende Kontrollhandle auf den Verbindungspunkt ( Verbindungspunkt) der zweiten Form.

  3. Wenn um den Verbindungspunkt ein rotes Feld ( Aktiver Verbindungspunkt) angezeigt wird, lassen Sie die Maustaste los, um die neue Verbindung festzulegen.

Anmerkungen

  • Prozessabläufe werden durch Verbinden der oberen und unteren Verbindungspunkte und Kontrollhandles von Formen dargestellt.

  • Kommunikationsflüsse werden durch Verbinden des rechten Kontrollhandles einer Aktion-Form mit dem linken Verbindungspunkt einer Port-Form dargestellt.

  • Sie können auch das Verbindungstool verwenden, um Formen miteinander zu verbinden. Weitere Informationen finden Sie unter Verwenden des Verbindungstools.

Verwandte Themen

Hinzufügen von Formen

Löschen von Formen

Markieren einer Form

Verwenden des Verbindungstools


Verwenden des Verbindungstools

  1. Klicken Sie auf der Symbolleiste auf die Schaltfläche Verbindungstool ( Schaltfläche Verbindungstool)).

  2. Bewegen Sie den Mauszeiger über ein Kontrollhandle ( Kontrollhandle) der Form, von der aus Sie eine Verbindung erstellen möchten.

    Das Kontrollhandle ist von einem roten Feld umgeben, welches anzeigt, dass Sie es ziehen können.

  3. Drücken und halten Sie die linke Maustaste, um das Kontrollhandle von der Form auf einen Verbindungspunkt ( Verbindungspunkt) der Form zu ziehen, zu der die gewünschte Verbindung führen soll.

  4. Wenn um den Verbindungspunkt der Form ein rotes Feld ( Aktiver Verbindungspunkt) angezeigt wird, lassen Sie die Maustaste los, um die neue Verbindung festzulegen.

Anmerkungen

  • Klicken Sie auf der Symbolleiste auf die Schaltfläche Standardzeiger ( Schaltfläche Standardzeiger), um das Verbindungstool auszublenden.

  • Sie sollten den Standardzeiger verwenden, um Aktion-Formen mit Port-Formen zu verbinden. Wenn Sie das Verbindungstool verwenden, um eine Verbindung zwischen einer Aktion und einem an eine COM-Komponente oder Skriptkomponente gebundenen Port zu erstellen, muss bei jeder anschließenden Aktivierung des entsprechenden Bindungs-Assistenten für Komponenten die Verbindung neu erstellt werden, auch wenn keine Eigenschaften geändert wurden.

  • Es ist möglich, zu einer Seite neue Formen hinzuzufügen und andere Operationen durchzuführen, während das Verbindungstool aktiviert ist. Allerdings erhalten Sie unter Umständen eine Fehlermeldung. Diese Fehlermeldung ist ungültig und ohne Bedeutung. Diese falsche Fehlermeldung wird in zukünftigen Versionen von Microsoft Visio behoben sein. Wenn Sie die erwähnte Fehlermeldung erhalten, klicken Sie auf OK, und setzen Sie den Vorgang fort. Die Fehlermeldung hat folgenden Wortlaut:

    "Interner Visio-Fehler: #-1

    Aktion 1246: Auf dem Zeichenblatt ablegen

    Versuchen Sie zuerst, die Datei zu schließen und wieder zu öffnen. Versuchen Sie dann, Visio neu zu starten."

Verwandte Themen

Hinzufügen von Formen

Verbinden zweier Formen

Löschen von Formen

Markieren einer Form


Ausrichten von Formen entlang einer vertikalen oder horizontalen Achse

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite den Mauszeiger um die Formen herum, die Sie an einer Achse ausrichten möchten.

  2. Klicken Sie auf der Symbolleiste auf die Schaltfläche Formen ausrichten ( Schaltfläche Formen ausrichten).

    Das Dialogfeld Shapes ausrichten wird angezeigt.

  3. Klicken Sie in einem der folgenden Bereiche auf die Ausrichtung, die Sie verwenden möchten.
    • Klicken Sie im Bereich Waagerechte Ausrichtung auf eine der folgenden Schaltflächen:

      Schaltfläche Horizontal oberer Rand Horizontal oberer Rand

      Schaltfläche Horizontal Mittellinie Horizontal Mittellinie

      Schaltfläche Horizontal unterer Rand Horizontal unterer Rand

    • Klicken Sie im Bereich Senkrechte Ausrichtung auf eine der folgenden Schaltflächen:

      Schaltfläche Vertikal linke Seite Vertikal linke Seite

      Schaltfläche Vertikale Mittellinie Vertikal Mittellinie

      Schaltfläche Vertikal rechte Seite Vertikal rechte Seite

Anmerkungen

  • Sie müssen Formen auf der Entwurfsseite markieren, um die Schaltfläche Formen ausrichten zu aktivieren.

  • Es wird empfohlen, Formen nur an einer Achse auszurichten. Die gleichzeitige Ausrichtung von Formen an beiden Achsen kann dazu führen, dass die Formen übereinander platziert werden. Drücken Sie STRG+Z, um alle unerwünschten Änderungen rückgängig zu machen.

  • Die Schaltfläche Keine Ausrichtung ( Schaltfläche Keine Ausrichtung) im Dialogfeld Formen ausrichten deaktiviert eine ausgewählte Ausrichtung.

  • Das Kontrollkästchen Führungslinie erstellen und Shapes ankleben ist nicht verfügbar.

  • Um mehrere Formen zu markieren, klicken Sie bei gedrückter UMSCHALTTASTE auf die Formen.


Festlegen von Bedingungseigenschaften

Folgende Themen werden in diesem Abschnitt behandelt:

  • Festlegen von Entscheidungsbedingungen

  • Festlegen von Bedingungen für While-Schleifen

  • Erstellen von Regeln

Verwandtes Thema

Entwerfen von Regeln


Festlegen von Entscheidungsbedingungen

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Festlegen von Entscheidungsbedingungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen einer Regel zu einer Entscheidung

  • Bearbeiten einer Regel einer Entscheidung

  • Entfernen einer Regel aus einer Entscheidung

  • Bestimmen der Auswertungsreihenfolge von Regeln

Verwandte Themen

Erstellen von Regeln

Entwerfen von Regeln


Hinzufügen einer Regel zu einer Entscheidung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Entscheidung-Form, zu der Sie eine Regel hinzufügen möchten, und klicken Sie anschließend auf Regel hinzufügen.

    Das Dialogfeld Regel hinzufügen wird angezeigt.

  2. Klicken Sie auf eine der folgenden Optionen:
    • Neue Regel erstellen

      Klicken Sie auf OK. Das Dialogfeld Eigenschaften der Regel wird angezeigt.

      Informationen zum Erstellen von Regeln finden Sie unter Erstellen von Regeln.

    • Vorhandene Regel hinzufügen

      Klicken Sie in der Liste Verfügbare Regeln auf die Regel, die Sie hinzufügen möchten, und klicken Sie anschließend auf OK.

      Das Dialogfeld Regel hinzufügen wird geschlossen und die Regel zu der Entscheidung hinzugefügt.

Anmerkungen

  • Wird zu einer XLANG-Ablaufplanzeichnung erstmalig eine Regel hinzugefügt, bewirkt das Klicken auf Regel hinzufügen das Öffnen des Dialogfeldes Eigenschaften der Regel. Das Dialogfeld Regel hinzufügen wird nur dann angezeigt, wenn Sie bereits eine oder mehrere Regeln erstellt haben, die Sie zu der Entscheidung hinzufügen können. Weitere Informationen zum Dialogfeld Eigenschaften der Regel finden Sie unter Erstellen von Regeln.

  • Sie können zu einer Entscheidung eine Regel auch dadurch hinzufügen, dass Sie mit der rechten Maustaste auf eine Entscheidung-Form klicken, dann auf Eigenschaften und anschließend auf den Befehl Hinzufügen klicken.

Verwandte Themen

Erstellen von Regeln

Entfernen einer Regel aus einer Entscheidung

Entwerfen von Regeln

Bestimmen der Auswertungsreihenfolge von Regeln

Bearbeiten einer Regel einer Entscheidung


Bearbeiten einer Regel einer Entscheidung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Entscheidung-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Entscheidungseigenschaften wird angezeigt.

  2. Klicken Sie auf die Regel, die Sie bearbeiten möchten, und klicken Sie anschließend auf Bearbeiten.

    Das Dialogfeld Eigenschaften der Regel wird angezeigt.

  3. Nehmen Sie die gewünschten Änderungen vor, und klicken Sie auf OK.

    Weitere Informationen zum Dialogfeld Eigenschaften der Regel finden Sie unter Erstellen von Regeln.

  4. Um eine weitere Regel zu bearbeiten, klicken Sie auf diese Regel und anschließend auf Bearbeiten.

    Oder

    Klicken Sie auf OK, um das Dialogfeld Entscheidungseigenschaften zu schließen.

Anmerkungen

  • Im Dialogfeld Entscheidungseigenschaften haben Sie auch die Möglichkeit, eine Regel hinzuzufügen, indem Sie auf Hinzufügen klicken.

  • Sie können eine Regel einer Entscheidung auch dadurch bearbeiten, dass Sie mit der rechten Maustaste auf eine Regel innerhalb einer Entscheidung-Form klicken und dann auf Eigenschaften klicken. Eine solche Aktion öffnet das Dialogfeld Eigenschaften der Regel.

Verwandte Themen

Hinzufügen einer Regel zu einer Entscheidung

Erstellen von Regeln

Entfernen einer Regel aus einer Entscheidung

Entwerfen von Regeln

Bestimmen der Auswertungsreihenfolge von Regeln


Entfernen einer Regel aus einer Entscheidung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Entscheidung-Form, aus der Sie eine Regel entfernen möchten, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Entscheidungseigenschaften wird angezeigt.

  2. Klicken Sie auf die Regel, die Sie löschen möchten, und klicken Sie anschließend auf Löschen.

Verwandte Themen

Hinzufügen einer Regel zu einer Entscheidung

Erstellen von Regeln

Entwerfen von Regeln

Bestimmen der Auswertungsreihenfolge von Regeln

Bearbeiten einer Regel einer Entscheidung


Bestimmen der Auswertungsreihenfolge von Regeln

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Entscheidung-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Entscheidungseigenschaften wird angezeigt.

  2. Klicken Sie auf die Regel, deren Auswertungsreihenfolge Sie ändern möchten.

  3. Klicken Sie im Bereich Reihenfolge auf den Pfeil nach oben oder nach unten, um die Regel zu verschieben und ihre Position innerhalb der Listenreihenfolge zu ändern.

Anmerkung

  • Es wird empfohlen, die Regeln in der Reihenfolge ihrer Prioritäten anzuordnen, wobei die Regel mit der höchsten Priorität an erster Stelle kommt. Regeln werden der Reihe nach ausgeführt, bis eine Regel zu TRUE ausgewertet wird. Der Prozessablauf folgt der ersten Regel, für die TRUE ausgewertet wird. Wenn für keine Regel TRUE ausgewertet wird, wird der Else-Ablauf verfolgt.

Verwandte Themen

Hinzufügen einer Regel zu einer Entscheidung

Erstellen von Regeln

Entfernen einer Regel aus einer Entscheidung

Entwerfen von Regeln

Bearbeiten einer Regel einer Entscheidung


Festlegen von Bedingungen für While-Schleifen

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Festlegen von Bedingungen für While-Schleifen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen einer Regel zu einer While-Schleife

  • Bearbeiten der Regel einer While-Schleife

  • Entfernen der Regel aus einer While-Schleife

  • Beibehalten des Status innerhalb einer While-Schleife

Verwandte Themen

Erstellen von Regeln

Entwerfen von Regeln


Hinzufügen einer Regel zu einer While-Schleife

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die While-Form, zu der Sie eine Regel hinzufügen möchten, und klicken Sie anschließend auf Regel hinzufügen.

    Das Dialogfeld Regel hinzufügen wird angezeigt.

  2. Klicken Sie auf eine der folgenden Optionen:
    • Neue Regel erstellen

      Klicken Sie auf OK. Das Dialogfeld Eigenschaften der Regel wird angezeigt.

      Informationen zum Erstellen von Regeln finden Sie unter Erstellen von Regeln.

    • Vorhandene Regel hinzufügen

      Klicken Sie in der Liste Verfügbare Regeln auf die Regel, die Sie hinzufügen möchten, und klicken Sie anschließend auf OK.

      Das Dialogfeld Regel hinzufügen wird geschlossen, und die Regel wird zur While-Schleife hinzugefügt.

Anmerkungen

  • Wird zu einer XLANG-Ablaufplanzeichnung erstmalig eine Regel hinzugefügt, bewirkt das Klicken auf Regel hinzufügen das Öffnen des Dialogfeldes Eigenschaften der Regel. Das Dialogfeld Regel hinzufügen wird nur dann angezeigt, wenn Sie bereits eine oder mehrere Regeln erstellt haben, die Sie zur While-Schleife hinzufügen können. Weitere Informationen zum Dialogfeld Eigenschaften der Regel finden Sie unter Erstellen von Regeln.

  • Sie können zu einer While-Schleife nur eine einzige Regel hinzufügen.

Verwandte Themen

Erstellen von Regeln

Entfernen der Regel aus einer While-Schleife

Entwerfen von Regeln

Bearbeiten der Regel einer While-Schleife

Beibehalten des Status innerhalb einer While-Schleife


Bearbeiten der Regel einer While-Schleife

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Regel einer While-Schleife, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Regel wird angezeigt.

  2. Nehmen Sie die gewünschten Änderungen vor, und klicken Sie auf OK.

    Weitere Informationen zum Dialogfeld Eigenschaften der Regel finden Sie unter Erstellen von Regeln.

Verwandte Themen

Hinzufügen einer Regel zu einer While-Schleife

Erstellen von Regeln

Entfernen der Regel aus einer While-Schleife

Entwerfen von Regeln

Beibehalten des Status innerhalb einer While-Schleife


Entfernen der Regel aus einer While-Schleife

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die While-Form, deren Regel Sie löschen möchten, und klicken Sie anschließend auf Regel löschen.

Verwandte Themen

Hinzufügen einer Regel zu einer While-Schleife

Erstellen von Regeln

Entwerfen von Regeln

Bearbeiten der Regel einer While-Schleife

Beibehalten des Status innerhalb einer While-Schleife


Beibehalten des Status innerhalb einer While-Schleife

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine While-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld While-Eigenschaften wird angezeigt.

  2. Klicken Sie im Bereich Statuspersistenz auf eine der folgenden Optionen:
    • Ja

      Die Nachrichten, die in den einzelnen Schleifendurchgängen verwendet werden, werden als Status des XLANG-Ablaufplanes gespeichert. Wenn die Schleife Bestandteil einer fehlschlagenden Transaktion ist, wird für jeden vollständigen Schleifendurchgang eine Seite Bei Fehler von Transaktion oder Kompensierung für Transaktion aufgerufen.

    • Nein

      Nur die im letzen Schleifendurchgang verwendeten Nachrichten werden als Status des XLANG-Ablaufplanes gespeichert. Wenn die Schleife Bestandteil einer Transaktion ist, die fehlschlägt, wird nur einmal eine Seite Bei Fehler von Transaktion oder Kompensierung für Transaktion aufgerufen.

Verwandte Themen

Hinzufügen einer Regel zu einer While-Schleife

Erstellen von Regeln

Entfernen der Regel aus einer While-Schleife

Entwerfen von Regeln

Bearbeiten der Regel einer While-Schleife


Erstellen von Regeln

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Erstellen von Regeln

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer neuen Regel

  • Verwenden des Ausdrucks-Assistenten

  • Hinzufügen von Konstanten zu einer Regel

  • Löschen nicht verwendeter Regeln

Verwandte Themen

Entwerfen von Regeln

Festlegen von Entscheidungsbedingungen

Festlegen von Bedingungen für While-Schleifen


Erstellen einer neuen Regel

Sie können Regeln erstellen, um innerhalb eines Geschäftsprozesses Bedingungen auszuwerten. Regeln werden in Entscheidungen und While-Schleifen eines XLANG-Ablaufplanes verwendet. Wenn Sie zu einer Entscheidung- oder While-Form eine Regel hinzufügen, wird das Dialogfeld Eigenschaften der Regel angezeigt.

  1. Geben Sie im Dialogfeld Eigenschaften der Regel in das Feld Regelname einen Namen für die Regel ein.

    Dieses Feld muss belegt sein.

  2. In das Feld Regelbeschreibung können Sie eine detaillierte Beschreibung der Regel eingeben.

    Dieses Feld ist optional.

  3. Platzieren Sie die Eingabemarke in das Feld Skriptausdruck, um den Ausdrucks-Assistenten zu aktivieren.

    Sie können den Skriptausdruck, den Sie verwenden möchten, eingeben oder ihn mithilfe des Ausdrucks-Assistenten bestimmen. Weitere Informationen zum Verwenden des Ausdrucks-Assistenten und zum Erstellen von Skriptausdrücken finden Sie unter Verwenden des Ausdrucks-Assistenten.

Wichtig

  • Da XML zwischen Groß- und Kleinschreibung unterscheidet, müssen Skriptausdrücke derselben Schreibweise folgen wie Nachrichten und deren Felder.

  • Sie müssen die Eingabemarke in das Feld Skriptausdruck platzieren, um den Ausdrucks-Assistenten zu aktivieren.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.
  • Die folgenden Formen können nicht umbenannt werden: Abbruch, Beginn, Entscheidung, Ende, Verzweigung, Verknüpfung und While.

  • Die Länge des längsten Regelnamens ermittelt die Breite der Entscheidung- oder While-Form, in der die Regel verwendet wird.

  • Sie können an beliebigen Stellen im Feld Skriptausdruck weitere Skriptausdrücke hinzufügen, indem Sie die Einfügemarke an die Stelle positionieren, an der Sie den Ausdruck hinzufügen möchten.

  • Skriptausdrücke können erst erstellt werden, wenn die Portimplementierungen und die Nachrichtenkommunikation zwischen Aktionen und Ports eingerichtet sind.

  • Bevor Sie die XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan kompilieren können, müssen Sie für alle Regeln des Planes vollständige Skriptausdrücke erstellen.

Verwandte Themen

Hinzufügen von Konstanten zu einer Regel

Entwerfen von Regeln

Festlegen von Entscheidungsbedingungen

Festlegen von Bedingungen für While-Schleifen

Verwenden des Ausdrucks-Assistenten


Verwenden des Ausdrucks-Assistenten

  1. Klicken Sie im Dialogfeld Eigenschaften der Regel im Bereich Ausdrucks-Assistent auf eine Nachricht in der Liste Nachricht.

  2. Klicken Sie im Bereich Ausdrucks-Assistent auf ein Feld in der Liste Feld.

  3. Klicken Sie auf Einfügen.

  4. Vervollständigen Sie den Ausdruck im Feld Skriptausdruck.

    Der Ausdrucks-Assistent fügt nur die ausgewählte Nachricht und das ausgewählte Feld hinzu. Zur Auswertung des Skriptausdrucks müssen Sie die Bedingung für die Regel angeben. Beispiel:

    PORequest.Total < 500

    Sie können Ausdrücke auch kombinieren, um komplizierte Bedingungen zu formulieren. Beispiel:

    PORequest.Total < 500 AND PORequest.Quantity < 20

Wichtig

  • Da XML zwischen Groß- und Kleinschreibung unterscheidet, müssen Skriptausdrücke derselben Schreibweise folgen wie Nachrichten und deren Felder.

  • Sie müssen die Eingabemarke in das Feld Skriptausdruck platzieren, um den Ausdrucks-Assistenten zu aktivieren.

  • Die verfügbaren Felder in der Liste Feld basieren auf der Nachricht, die Sie in der Liste Nachricht auswählen. Es können nur Felder verwendet werden, die in dieser Nachricht enthalten sind.

Anmerkungen

  • Die Liste Nachricht enthält alle Nachrichten und Konstanten, die auf der Datenseite zur Verfügung stehen.

  • Regeln können auch die Systemfelder verwenden, die auf der Datenseite bereitgestellt werden. Wird ein Systemfeld in einer Regel verwendet, ist es immer von eckigen Klammern eingeschlossen. Beispiel:

    Nachricht1.[__Exists__]

    Weitere Informationen zu Systemfeldern finden Sie unter Datenverarbeitung.

  • Innerhalb von Regeln ist es möglich, Microsoft® Visual Basic®-Funktionen wie z. B. Date und Time zu verwenden.

  • Ebenso ist es innerhalb von Regeln möglich, alle Operatoren für VBScript-Codeausdruckvergleiche (Visual Basic Scripting Edition) zu verwenden.

  • Sie können an beliebigen Stellen im Feld Skriptausdruck weitere Skriptausdrücke hinzufügen, indem Sie die Einfügemarke an die Stelle positionieren, an der Sie den Ausdruck hinzufügen möchten.

  • Bevor Sie die XLANG-Ablaufplanzeichnung in einen nobr>XLANG-Ablaufplan kompilieren können, müssen Sie für alle Regeln des Ablaufplanes vollständige Skriptausdrücke erstellen.

Verwandte Themen

Hinzufügen von Konstanten zu einer Regel

Erstellen einer neuen Regel

Entwerfen von Regeln

Festlegen von Entscheidungsbedingungen

Festlegen von Bedingungen für While-Schleifen


Hinzufügen von Konstanten zu einer Regel

Sie können den Skriptausdrücken einer Regel Konstanten hinzufügen. Um Konstanten verwenden zu können, müssen Sie zuerst dafür sorgen, dass solche Konstanten zur Verfügung stehen.

  1. Wenn keine Konstanten verfügbar sind, fügen Sie auf der Datenseite der Liste Constants neue Konstanten hinzu.

    Weitere Informationen zum Verwenden von Konstanten und Hinzufügen von Konstanten zur Liste Constants finden Sie unter Verwenden von Konstanten.

  2. Klicken Sie im Dialogfeld Eigenschaften der Regel in der Liste Nachricht auf Constants.

  3. Klicken Sie in der Liste Feld auf diejenige Konstante, die Sie verwenden möchten, und klicken Sie anschließend auf Einfügen.

Anmerkung

  • Alle Konstanten in der Liste Constants auf der Datenseite sind für die Verwendung in einer Regel verfügbar.

Verwandte Themen

Erstellen einer neuen Regel

Entwerfen von Regeln

Festlegen von Entscheidungsbedingungen

Festlegen von Bedingungen für While-Schleifen

Verwenden des Ausdrucks-Assistenten


Löschen nicht verwendeter Regeln

  • Klicken Sie im Menü Extras auf Nicht verwendete Regeln löschen.

Anmerkungen

  • Dieses Verfahren löscht jede Regel, die nicht in einer Entscheidung oder einer While-Schleife der XLANG-Ablaufplanzeichnung verwendet wird.

  • Es werden nur solche Regeln aus der XLANG-Ablaufplanzeichnung entfernt, die aktuell in keiner While- oder Entscheidung-Form Verwendung finden. Alle in While- oder Entscheidung-Formen verwendeten Regeln bleiben erhalten, selbst wenn diese Formen aktuell mit keiner anderen Form verbunden sind.

Verwandte Themen

Hinzufügen von Konstanten zu einer Regel

Erstellen einer neuen Regel

Verwenden des Ausdrucks-Assistenten


Festlegen von Parallelitätseigenschaften

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen paralleler Abläufe

  • Festlegen der Verknüpfungstyp-Eigenschaft

  • Zusammenführen paralleler Abläufe

  • Beenden eines parallelen Ablaufs

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Thema lesen.


Erstellen paralleler Abläufe

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Verzweigung-Form.

  2. Verbinden Sie das untere Kontrollhandle ( Kontrollhandle) der Verzweigung-Form mit dem oberen Verbindungspunkt ( Verbindungspunkt) einer nachfolgenden Form im Ablauf des Geschäftsprozesses.

  3. Wiederholen Sie die Schritte 1 und 2, um weitere parallele Abläufe zu erstellen.

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Thema lesen.

Anmerkungen

  • Nur ein einziger Ablauf kann vom oberen Verbindungspunkt aus in eine Verzweigung-Form einmünden.

  • Bis zu 64 verschiedene Abläufe können eine Verzweigung-Form verlassen, um parallele Prozesse zu starten.

  • Jedes Mal, wenn Sie einen weiteren Ablauf zeichnen möchten, müssen Sie erneut auf die Verzweigung-Form klicken, um sie zu markieren und deren Kontrollhandle zu aktivieren.

    Oder

    Sie können das Verbindungstool verwenden, wenn Sie mehrere parallele Abläufe erstellen möchten, um das Hinzufügen der Abläufe zu beschleunigen. Weitere Informationen zum Verbindungstool finden Sie unter Verwenden des Verbindungstools.

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Verbinden zweier Formen

Beenden eines parallelen Ablaufs

Zusammenführen paralleler Abläufe

Markieren einer Form

Festlegen der Verknüpfungstyp-Eigenschaft

Verwenden des Verbindungstools


Festlegen der Verknüpfungstyp-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Verknüpfung-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Verknüpfungseigenschaften wird angezeigt.

  2. Klicken Sie im Dialogfeld Verknüpfungseigenschaften auf eine der folgenden Optionen:
    • AND

    • OR

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Thema lesen.

Anmerkung

  • Wenn Sie für die Verknüpfung die OR-Option auswählen, kann den einzelnen Abläufen, die in die Verknüpfung-Form einmünden, jeweils nur eine einzige Aktion zugeordnet werden.

Verwandte Themen

Erstellen paralleler Abläufe

Beenden eines parallelen Ablaufs

Zusammenführen paralleler Abläufe


Zusammenführen paralleler Abläufe

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Form des Geschäftsprozesses, die einen parallelen Prozess ausführt.

  2. Verbinden Sie das untere Kontrollhandle ( Kontrollhandle) dieser Form mit dem oberen Verbindungspunkt ( Verbindungspunkt) der Verknüpfung-Form.

  3. Wiederholen Sie Schritt 1 und 2 für alle parallelen Abläufe, die in dieser bestimmten Verknüpfung zusammengeführt werden.

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Thema lesen.

Anmerkungen

  • Wenn Sie für die Verknüpfung die OR-Option auswählen, kann den einzelnen Abläufen, die in die Verknüpfung-Form einmünden, jeweils nur eine einzige Aktion zugeordnet werden.

  • Bis zu 64 verschiedene Abläufe können über den oberen Verbindungspunkt in eine Verknüpfung-Form einmünden.

  • Nur ein einziger Ablauf kann über den unteren Verbindungspunkt eine Verknüpfung-Form verlassen.

  • Sie können das Verbindungstool verwenden, wenn Sie mehrere parallele Abläufe zusammenführen möchten, um das Verknüpfen der Abläufe zu beschleunigen. Weitere Informationen zum Verbindungstool finden Sie unter Verwenden des Verbindungstools.

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Verbinden zweier Formen

Erstellen paralleler Abläufe

Beenden eines parallelen Ablaufs

Markieren einer Form

Festlegen der Verknüpfungstyp-Eigenschaft

Verwenden des Verbindungstools


Beenden eines parallelen Ablaufs

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Form des Geschäftsprozesses, die als ein paralleler Prozess ausgeführt wird.

  2. Verbinden Sie das untere Kontrollhandle ( Kontrollhandle) dieser Form mit dem oberen Verbindungspunkt ( Verbindungspunkt) der Ende-Form.

    Dies beendet den parallelen Prozess. Er vereinigt sich nicht mit anderen Abläufen des XLANG-Ablaufplanes.

Wichtig

  • Weitere Informationen zu parallelen Prozessen finden Sie unter Entwerfen von Parallelität. Es wird dringend empfohlen, dass Sie die Ausführungen zu diesem Thema lesen.

Anmerkung

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Verbinden zweier Formen

Erstellen paralleler Abläufe

Zusammenführen paralleler Abläufe

Markieren einer Form

Festlegen der Verknüpfungstyp-Eigenschaft

Verwenden des Verbindungstools


Festlegen von Transaktionseigenschaften

Folgende Themen werden in diesem Abschnitt behandelt:

  • Festlegen von Transaktionseigenschaften für einen XLANG-Ablaufplan

  • Festlegen von Eigenschaften für einzelne Transaktionen

  • Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing

Verwandtes Thema

Entwerfen von Transaktionen


Festlegen von Transaktionseigenschaften für einen XLANG-Ablaufplan

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Festlegen von Transaktionseigenschaften für einen XLANG-Ablaufplan

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen des Transaktionsmodells

  • Festlegen der Transaktionsaktivierung-Eigenschaft

Verwandtes Thema

Entwerfen von Transaktionen


Festlegen des Transaktionsmodells

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Beginn-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Beginneigenschaften wird angezeigt.

  2. Klicken Sie in der Liste Transaktionsmodell auf eine der folgenden Optionen:
    • Transaktionen in den XLANG-Ablaufplan einschließen

      Diese Option ermöglicht es einem XLANG-Ablaufplan, Transaktionen zu verwenden.

    • XLANG-Ablaufplan als COM+-Komponente behandeln

      Diese Option deaktiviert die Transaktionsunterstützung für einen XLANG-Ablaufplan. Eine COM-Komponente kann anschließend den XLANG-Ablaufplan im Kontext einer COM+-Transaktion aktivieren.

Anmerkungen

  • Wenn Sie für die Transaktionsmodell-Eigenschaft die Option XLANG-Ablaufplan als COM+-Komponente behandeln auswählen, ist die Liste Transaktionsaktivierung aktiviert.

  • Wenn Sie für die Transaktionsmodell-Eigenschaft die Option XLANG-Ablaufplan als COM+-Komponente behandeln auswählen, sollten Sie zu der XLANG-Ablaufplanzeichnung keine Transaktionen hinzufügen. Die XLANG-Ablaufplanzeichnung kann in diesem Fall nicht ordnungsgemäß kompiliert werden, und Sie erhalten eine Fehlermeldung.

  • Die XLANG-Identität-Eigenschaft ist eine eindeutige Kennung, die dazu dient, unterschiedliche Versionen einer XLANG-Ablaufplanzeichnung zu unterscheiden. Diese Eigenschaft ist schreibgeschützt und kann nicht geändert werden. Bei jeder Änderung einer XLANG-Ablaufplanzeichnung wird auch diese Identitätseigenschaft aktualisiert.

    Mithilfe der XLANG-Identität-Eigenschaft ist es möglich, Versionsübereinstimmungen zwischen einer XLANG-Ablaufplanzeichnung (SKV-Datei) und dem zugehörigen kompilierten XLANG-Ablaufplan (SKX-Datei) zu ermitteln.

  • Die Beginn-Form ist auf Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion verfügbar. Auf der Datenseite ist die Beginn-Form nicht verfügbar.

Verwandte Themen

Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing

Entwerfen von Transaktionen

Festlegen der Transaktionsaktivierung-Eigenschaft


Festlegen der Transaktionsaktivierung-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Beginn-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Beginneigenschaften wird angezeigt.

  2. Klicken Sie in der Liste Transaktionsmodell auf XLANG-Ablaufplan als COM+-Komponente behandeln.

    Bei Aktivierung dieser Option behandeln die Komponentendienste den XLANG-Ablaufplan als eine COM+-Komponente. Diese Option deaktiviert die Transaktionsunterstützung für einen XLANG-Ablaufplan. Eine COM-Komponente kann anschließend den XLANG-Ablaufplan im Kontext einer COM+-Transaktion aktivieren.

  3. Klicken Sie in der Liste Transaktionsaktivierung auf eine der folgenden Optionen:
    • Nicht unterstützt

      Der XLANG-Ablaufplan ignoriert eine gegebenenfalls im COM+-Objektkontext der die Ablaufplaninstanz erzeugenden Komponente präsente Transaktion. Keine der Aktionen des Ablaufplanes wird im Geltungsbereich einer Transaktion ausgeführt.

    • Unterstützt

      Der XLANG-Ablaufplan beteiligt sich an einer COM+-Transaktion, sofern eine solche Transaktion im COM+-Objektkontext der die Ablaufplaninstanz erzeugenden Komponente präsent ist.

    • Erforderlich

      Der XLANG-Ablaufplan muss im Geltungsbereich einer Transaktion ausgeführt werden. Ist eine solche Transaktion im COM+-Objektkontext der die Ablaufplaninstanz erzeugenden Komponente nicht präsent, initiiert das XLANG-Ablaufplanungsmodul automatisch eine neue Transaktion und verwendet sie.

    • Neue Transaktion erforderlich

      Der XLANG-Ablaufplan muss im Geltungsbereich einer neuen Transaktion ausgeführt werden. Das XLANG-Ablaufplanungsmodul initiiert automatisch eine neue Transaktion für den Ablaufplan, die sich von allen Transaktionen unterscheidet, die möglicherweise im COM+-Objektkontext der die Ablaufplaninstanz erzeugenden Komponente präsent gewesen sind.

Anmerkungen

  • Die XLANG-Identität-Eigenschaft ist eine eindeutige Kennung, die dazu dient, unterschiedliche Versionen einer XLANG-Ablaufplanzeichnung zu unterscheiden. Diese Eigenschaft ist schreibgeschützt und kann nicht geändert werden. Bei jeder Änderung einer XLANG-Ablaufplanzeichnung wird auch diese Identitätseigenschaft aktualisiert.

    Mithilfe der XLANG-Identität-Eigenschaft ist es möglich, Versionsübereinstimmungen zwischen einer XLANG-Ablaufplanzeichnung (SKV-Datei) und dem zugehörigen kompilierten XLANG-Ablaufplan (SKX-Datei) zu ermitteln.

  • Die Beginn-Form ist auf Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion verfügbar. Auf der Datenseite ist die Beginn-Form nicht verfügbar.

Verwandte Themen

Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing

Entwerfen von Transaktionen

Festlegen des Transaktionsmodells


Festlegen von Eigenschaften für einzelne Transaktionen

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Festlegen von Eigenschaften für einzelne Transaktionen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

  • Entwerfen geschachtelter Transaktionen

  • Erstellen von in Transaktionen eintretenden und von Transaktionen verlassenden Abläufen

  • Benennen einer Transaktion

  • Festlegen der Transaktionstyp-Eigenschaft

  • Festlegen der Timeout-Eigenschaft

  • Festlegen der Wiederholungsanzahl-Eigenschaft

  • Festlegen der Backoffzeit-Eigenschaft

  • Festlegen der Isolationsebene-Eigenschaft

  • Festlegen der Persistenter Status des Ablaufplans-Eigenschaft

Verwandtes Thema

Entwerfen von Transaktionen


Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine Transaktion-Form von der Flussdiagramm-Schablone auf die linke der Seite der Trennlinie.

  2. Passen Sie die Größe der Transaktion-Form so an, dass sie alle Formen umfasst, die Sie innerhalb der Transaktion platzieren möchten.

Anmerkungen

  • Jede Form und jeder Ablauf innerhalb der Begrenzungslinie einer Transaktion wird als Teil dieser Transaktion behandelt.

  • Um eine Form zu markieren, die sich innerhalb einer Transaktion befindet, klicken Sie auf die Form.

  • Wenn Sie eine Transaktion löschen, die innerhalb ihrer Begrenzungslinie Formen enthält, werden diese Formen ebenfalls gelöscht.

  • Transaktionstypen werden durch die folgenden Farben gekennzeichnet:
    • Blau. Diese Farbe kennzeichnet befristete Transaktionen.

    • Beige. Diese Farbe kennzeichnet langlebige Transaktionen.

    • Grau. Diese Farbe kennzeichnet kurzlebige Transaktionen (DTC-Stil).
  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Erstellen von in Transaktionen eintretenden und von Transaktionen verlassenden Abläufen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Benennen einer Transaktion


Entwerfen geschachtelter Transaktionen

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine Transaktion-Form aus der Flussdiagramm-Schablone heraus, und platzieren Sie sie innerhalb der Begrenzungslinien einer aktuellen Transaktion.

  2. Passen Sie die Größe der Transaktion-Form so an, dass sie alle Formen umfasst, die Sie innerhalb der Transaktion platzieren möchten.

Wichtig

  • Wenn Sie eine geschachtelte Transaktion erstellen, sind bestimmte Eigenschaften in der äußeren Transaktion deaktiviert:
    • Der Transaktionstyp Kurzlebig, DTC-Stil ist nicht verfügbar.

    • Alle Optionen im Bereich Transaktionsoptionen sind nicht verfügbar.

    • Die Timeout-Eigenschaft ist zwar noch aktiv, kann aber nicht mehr geändert werden, nachdem Sie eine geschachtelte Transaktion erstellt haben, es sei denn, Sie ändern den Transaktionstyp in Befristete Transaktion.

Anmerkungen

  • Jede Form und jeder Ablauf innerhalb der Begrenzungslinie einer Transaktion wird als Teil dieser Transaktion behandelt.

  • Um eine Form zu markieren, die sich innerhalb einer Transaktion befindet, klicken Sie auf die Form.

  • Wenn Sie eine Transaktion löschen, die innerhalb ihrer Begrenzungslinie Formen enthält, werden diese Formen ebenfalls gelöscht.

  • Transaktionstypen werden durch die folgenden Farben gekennzeichnet:
    • Blau. Diese Farbe kennzeichnet befristete Transaktionen.

    • Beige. Diese Farbe kennzeichnet langlebige Transaktionen.

    • Grau. Diese Farbe kennzeichnet kurzlebige Transaktionen (DTC-Stil).
  • Alle Flussdiagrammformen, die nicht vollständig innerhalb einer inneren Transaktion enthalten sind, werden als Teil der äußeren Transaktion behandelt.

  • Flussdiagrammformen innerhalb einer äußeren Transaktion sind möglicherweise zum Teil nicht sichtbar, wenn sie von einer inneren Transaktion teilweise überdeckt werden und nicht vollständig in dieser inneren Transaktion enthalten sind. Markieren Sie diese Formen, und positionieren Sie sie neu, damit sie einander nicht überlappen.

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Erstellen von in Transaktionen eintretenden und von Transaktionen verlassenden Abläufen

Entwerfen von Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion


Erstellen von in Transaktionen eintretenden und von Transaktionen verlassenden Abläufen

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Form, die einer Transaktion im Ablauf des Geschäftsprozesses vorausgeht.

  2. Verbinden Sie das untere Kontrollhandle ( Kontrollhandle) dieser Form mit dem oberen Verbindungspunkt ( Verbindungspunkt) der Transaktion-Form.

  3. Klicken Sie auf die Transaktion-Form, um sie zu markieren.

  4. Verbinden Sie das obere Kontrollhandle der Transaktion-Form mit dem oberen Verbindungspunkt der ersten Form innerhalb der Transaktion, die den Beginn des Transaktionsflusses repräsentiert.

  5. Setzen Sie den Ablauf fort, indem Sie von jener Anfangsform zur nächsten Form innerhalb der Transaktion verbinden.

  6. Verbinden Sie alle Abläufe innerhalb der Transaktion, und verbinden Sie alle Aktionen mit den Ports, für die Sie einen Kommunikationsfluss erstellen möchten.

  7. Setzen Sie den Ablauf fort, indem Sie das untere Kontrollhandle der letzten Form innerhalb der Transaktion mit dem unteren Verbindungspunkt der Transaktion-Form verbinden.

  8. Klicken Sie auf die Transaktion-Form, um sie zu markieren.

  9. Verbinden Sie das untere Kontrollhandle der Transaktion-Form mit dem oberen Verbindungspunkt der nächsten Form innerhalb des Geschäftsprozessablaufs außerhalb der Transaktion.

Anmerkungen

  • Um eine Form zu markieren, die sich innerhalb einer Transaktion befindet, klicken Sie auf die Form.

  • Sie können Flussdiagrammformen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Flussdiagrammformen nicht verfügbar.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Verbinden zweier Formen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Verwenden des Verbindungstools


Benennen einer Transaktion

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Geben Sie in das Feld Name einen Namen für die Transaktion ein.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.
  • Transaktionsnamen mit Zeichen aus einem Ein-Byte-Zeichensatz dürfen maximal 16 Zeichen lang sein. Transaktionsnamen mit Zeichen aus einem Zwei-Byte-Zeichensatz dürfen maximal 8 Zeichen lang sein.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Festlegen der Persistenter Status des Ablaufplans-Eigenschaft

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Timeout-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Festlegen der Transaktionstyp-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Klicken Sie im Bereich Typ auf eine der folgenden Optionen:
    • Befristete Transaktion

    • Kurzlebig, DTC-Stil

    • Langlebig

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Persistenter Status des Ablaufplans-Eigenschaft

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Timeout-Eigenschaft


Festlegen der Timeout-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Geben Sie im Bereich Transaktionsoptionen in das Feld Timeout einen Wert für ein Zeitintervall in Sekunden ein.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Persistenter Status des Ablaufplans-Eigenschaft

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Festlegen der Wiederholungsanzahl-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Geben Sie im Bereich Transaktionsoptionen in das Feld Wiederholungsanzahl eine Zahl ein, die festlegt, wie oft eine Transaktion wiederholt werden kann, bevor sie als fehlgeschlagen gilt.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Persistenter Status des Ablaufplans-Eigenschaft

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Timeout-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Festlegen der Backoffzeit-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Geben Sie im Bereich Transaktionsoptionen in das Feld Backoffzeit ein Zeitintervall in Sekunden ein.

Anmerkung

  • Die Backoffzeit-Eigenschaft ermittelt das Intervall zwischen den einzelnen Versuchen zur Wiederholung einer Transaktion. Diese Option ist nur für kurzlebige Transaktionen des DTC-Typs verfügbar. Die Backoffzeit wird zusammen mit der Wiederholungsanzahl verwendet, um die Wartezeit bis zum nächsten Wiederholungsversuch der Transaktion zu ermitteln. Der Backoff-Wert wächst exponentiell. Ein Backoff-Wert von 2 resultiert in Intervallen von 2, 4, 8, 16 Sekunden usw. für die Zeit bis zum jeweils nächsten Wiederholungsversuch. Die Berechnungsformel lautet BW ("B hoch W"), wobei B die Backoffzeit und W die aktuelle Wiederholungsanzahl bezeichnet.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Persistenter Status des Ablaufplans-Eigenschaft

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Timeout-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Festlegen der Isolationsebene-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Klicken Sie im Bereich Transaktionsoptionen in der Liste Isolationsebene auf eine der folgenden Optionen:
    • Serializable

    • Read Uncommitted

    • Read Committed

    • Repeatable Read

Anmerkung

  • Diese Eigenschaft kann nur für Transaktionen des Typs Kurzlebig, DTC-Stil festgelegt werden.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Persistenter Status des Ablaufplans-Eigenschaft

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Timeout-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Festlegen der Persistenter Status des Ablaufplans-Eigenschaft

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Aktivieren bzw. deaktivieren Sie im Bereich Transaktionsoptionen das Kontrollkästchen Status des Ablaufplans persistent speichern.

Anmerkung

  • Diese Eigenschaft kann für Transaktionen des Typs Kurzlebig, DTC-Stil nicht bearbeitet werden, da sie stets persistent gespeichert werden.

Verwandte Themen

Entwerfen von Transaktionen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Benennen einer Transaktion

Festlegen der Isolationsebene-Eigenschaft

Festlegen der Backoffzeit-Eigenschaft

Festlegen der Wiederholungsanzahl-Eigenschaft

Festlegen der Timeout-Eigenschaft

Festlegen der Transaktionstyp-Eigenschaft


Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Beschreiben der Transaktionsunterstützung durch Komponenten und Message Queuing

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Beschreiben der Transaktionsunterstützungsebene durch eine COM-Komponente

  • Beschreiben der Transaktionsunterstützungsebene durch eine Windows Script-Komponente

  • Beschreiben der Transaktionsunterstützung durch eine Nachrichtenwarteschlange

Verwandte Themen

Entwerfen von Transaktionen

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Beschreiben der Transaktionsunterstützungsebene durch eine COM-Komponente

Transaktionsunterstützung durch COM-Komponenten wird im Bindungs-Assistenten für COM-Komponenten festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für COM-Komponenten.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe einer COM-Komponente.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung auf eine der folgenden Optionen:
    • Deaktiviert

      Die Transaktionsunterstützung für die von dieser Portimplementierung verwendete COM+-Komponente wird deaktiviert.

    • Nicht unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente unterstützt keine Transaktionen.

    • Unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente erbt eine vorhandene Transaktion.

    • Erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente kann eine vorhandene Transaktion erben oder eine neue Transaktion initiieren.

    • Neue Transaktion erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente muss eine neue Transaktion initiieren.

Verwandte Themen

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Entwerfen von Transaktionen

Implementieren eines Ports mithilfe einer COM-Komponente

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Beschreiben der Transaktionsunterstützungsebene durch eine Windows Script-Komponente

Transaktionsunterstützung durch Windows-Skriptkomponenten wird im Bindungs-Assistenten für Skriptkomponenten festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für Skriptkomponenten.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe einer Windows Script-Komponente.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung auf eine der folgenden Optionen:
    • Deaktiviert

      Die Transaktionsunterstützung für die von dieser Portimplementierung verwendete COM+-Komponente wird deaktiviert.

    • Nicht unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente unterstützt keine Transaktionen.

    • Unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente erbt eine vorhandene Transaktion.

    • Erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente kann eine vorhandene Transaktion erben oder eine neue Transaktion initiieren.

    • Neue Transaktion erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente muss eine neue Transaktion initiieren.

Verwandte Themen

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Entwerfen von Transaktionen

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Beschreiben der Transaktionsunterstützung durch eine Nachrichtenwarteschlange

Transaktionsunterstützung durch Nachrichtenwarteschlangen wird im Bindungs-Assistenten für Message Queuing festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für Message Queuing.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe von Message Queuing.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung das Kontrollkästchen Für diese Warteschlage sind Transaktionen erforderlich.

Verwandte Themen

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Entwerfen von Transaktionen

Implementieren eines Ports mithilfe von Message Queuing

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Festlegen von Fehlerbehandlungseigenschaften

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Abbrechen eines Prozessablaufs

  • Aktivieren der Transaktionsfehlerbehandlung

  • Aktivieren der Fehlerbehandlung durch Komponenten

Verwandtes Thema

Behandeln von Ausnahmen


Abbrechen eines Prozessablaufs

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Flussdiagramm-Schablone auf die Abbruch-Form, und ziehen Sie sie auf die Entwurfsseite.

  2. Verbinden Sie den Prozessablauf ausgehend von einem logischen Abzweig einer Entscheidung-Form mit dem Verbindungspunkt ( Verbindungspunkt) auf der Abbruch-Form.

Wichtig

  • Abbruch-Formen dienen dem Zweck, einen Geschäftsprozess bei Verfolgung eines bestimmten logischen Abzweigs abzubrechen. Sie werden zusammen mit Entscheidungen verwendet.

    Ob die Abbruch-Form verwendet wird, hängt von den Erfordernissen des gegebenen Geschäftsprozesses ab. Die Regeln einer Entscheidung werden ausgewertet, bis für eine Regel TRUE ausgewertet wird. Wird für eine der Regeln TRUE ausgewertet, geht der Prozessablauf zur nächsten Aktion über. Wenn für keine Regel TRUE ausgewertet wird, haben Sie die Möglichkeit, den Prozessablauf abzubrechen.

    Die folgende Abbildung zeigt ein Beispiel für eine Entscheidungsbedingung, wo der Prozessablauf mit Aktion 3 fortgesetzt wird, falls für die Regel TRUE ausgewertet wird, und andernfalls abgebrochen wird.

    Die Verwendung einer Abbruch-Form in einer Verzweigung

Verwandte Themen

Aktivieren der Fehlerbehandlung durch Komponenten

Aktivieren der Transaktionsfehlerbehandlung

Behandeln von Ausnahmen

Logische Verzweigungen


Aktivieren der Transaktionsfehlerbehandlung

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Aktivieren der Transaktionsfehlerbehandlung

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Aktivieren der Bei Fehler von-Fehlerbehandlung

  • Aktivieren der Kompensierung für-Fehlerbehandlung

Verwandte Themen

Abbrechen eines Prozessablaufs

Behandeln von Ausnahmen


Aktivieren der Bei Fehler von-Fehlerbehandlung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Transaktion-Form, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Klicken Sie im Bereich Bei Fehler auf Code hinzufügen.

  3. Aktivieren Sie im Bereich Bei Fehler das Kontrollkästchen Aktiviert.

Anmerkungen

  • Durch das Klicken auf die Schaltfläche Code hinzufügen wird eine Fehlerseite (eine Seite Bei Fehler von Transaktion) erstellt, die mit dieser Transaktion verknüpft ist. Der Platzhalter Transaktion im Namen der Seite wird ersetzt durch den Namen der Transaktion, mit der der Fehlerbehandlungsprozess verknüpft ist.

  • Die Aktivierung des Kontrollkästchens Aktiviert versetzt den XLANG-Ablaufplan in die Lage, den Bei Fehler von-Code für diese Transaktion auszuführen. Auch wenn dieses Kontrollkästchen nicht aktiviert wird, ist es möglich, den Bei Fehler von-Code zu entwerfen. Dieser wird jedoch bei Ausführung des XLANG-Ablaufplanes nicht aktiviert.

Verwandte Themen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Behandeln von Ausnahmen


Aktivieren der Kompensierung für-Fehlerbehandlung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine innere Transaktion-Form einer geschachtelten Transaktionsgruppe, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Transaktionen wird angezeigt.

  2. Klicken Sie im Bereich Kompensierung auf Code hinzufügen.

  3. Aktivieren Sie im Bereich Kompensierung das Kontrollkästchen Aktiviert.

Anmerkungen

  • Durch das Klicken auf die Schaltfläche Code hinzufügen wird eine Fehlerseite (eine Seite Bei Fehler von Transaktion) oder eine Kompensierungsseite (eine Seite Kompensierung für Transaktion) erstellt, die mit dieser Transaktion verknüpft ist.

  • Durch das Aktivieren des Kontrollkästchens Aktiviert kann der XLANG-Ablaufplan den Bei Fehler von-Code oder den Kompensierung-Code für diese Transaktion ausführen. Auch wenn dieses Kontrollkästchen nicht aktiviert wird, ist es möglich, einen Bei Fehler von- oder Kompensierung für-Code zu entwerfen. Dieser wird jedoch bei Ausführung des XLANG-Ablaufplanes nicht aktiviert.

  • Der Platzhalter Transaktion im Namen der Seite wird ersetzt durch den Namen der Transaktion, mit der der Fehlerbehandlungsprozess verknüpft ist.

  • Transaktionstypen werden durch die folgenden Farben gekennzeichnet:
    • Blau. Diese Farbe kennzeichnet befristete Transaktionen.

    • Beige. Diese Farbe kennzeichnet langlebige Transaktionen.

    • Grau. Diese Farbe kennzeichnet kurzlebige Transaktionen (DTC-Stil).

Verwandte Themen

Entwerfen geschachtelter Transaktionen

Gruppieren von Aktionen und Abläufen innerhalb einer Transaktion

Behandeln von Ausnahmen


Aktivieren der Fehlerbehandlung durch Komponenten

BizTalk Server 2002 ~ Entwerfen von BizTalk-Orchestrierungen

Aktivieren der Fehlerbehandlung durch Komponenten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine COM-Komponente

  • Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine Windows Script-Komponente

Verwandte Themen

Abbrechen eines Prozessablaufs

Behandeln von Ausnahmen


Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine COM-Komponente

Transaktionsunterstützung durch COM-Komponenten wird im Bindungs-Assistenten für COM-Komponenten festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für COM-Komponenten.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe einer COM-Komponente.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Aktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt.

Wichtig

  • Diese Option ermittelt, ob kurzlebige Transaktionen im DTC-Stil, an denen die Komponente beteiligt ist, abgebrochen werden sollen, wenn Aufrufe von Methoden der Komponente ein HRESULT-Ergebnis zurückgeben, welches einen Fehler anzeigt.

    Die Option kann nur aktiviert werden, wenn die Kommunikationsaktion, die diesen Port verwendet, innerhalb des Prozessablaufs einer Transaktion stattfindet.

Verwandte Themen

Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine Windows Script-Komponente

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Behandeln von Ausnahmen

Implementieren eines Ports mithilfe einer COM-Komponente

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine Windows Script-Komponente

Transaktionsunterstützung durch Windows-Skriptkomponenten wird im Bindungs-Assistenten für Skriptkomponenten festgelegt.

  1. Öffnen Sie den Bindungs-Assistenten für Skriptkomponenten.

    Weitere Informationen zu diesem Assistenten finden Sie unter Implementieren eines Ports mithilfe einer Windows Script-Komponente.

  2. Folgen Sie den Anweisungen im Assistenten, bis Sie zur Seite Erweiterte Porteigenschaften gelangen.

  3. Aktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt.

Wichtig

  • Diese Option ermittelt, ob Transaktionen, an denen die Komponente beteiligt ist, abgebrochen werden sollen, wenn Aufrufe von Methoden der Komponente ein HRESULT-Ergebnis zurückgeben, welches einen Fehler anzeigt.

    Die Option kann nur aktiviert werden, wenn die Kommunikationsaktion, die diesen Port verwendet, innerhalb des Prozessablaufs einer Transaktion stattfindet.

Verwandte Themen

Abbrechen einer Transaktion bei Rückgabe eines Fehlers durch eine COM-Komponente

Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

Behandeln von Ausnahmen

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Ändern der Eigenschaften einer Portimplementierung

Festlegen der Transaktionsaktivierung-Eigenschaft

Festlegen des Transaktionsmodells


Implementieren von Ports

Der BizTalk-Orchestrierungs-Designer stellt vier Implementierungsformen zur Verfügung, die unterschiedliche Technologien zur Implementierung einer portgestützten Kommunikation repräsentieren. In der folgenden Tabelle werden diese Formen beschrieben.

Name der Form | Beschreibung
COM-Komponente | Die COM-Komponente-Form stellt eine Technologie dar, mit der ein Port mithilfe eines Methodenaufrufs für jede Nachricht implementiert werden kann, die gesendet oder empfangen wird. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für COM-Nachrichten auf die rechte Seite der Trennlinie.
Skriptkomponente | Mit der Skriptkomponente-Form kann mithilfe eines Methodenaufrufs für jede gesendete oder empfangene Nachricht ein Port implementiert werden. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für Skriptkomponenten auf die rechte Seite der Trennlinie.
Message Queuing | Mit der Message Queuing-Form kann ein Port implementiert werden. Message Queuing-Dienste dienen zum Senden oder Empfangen von Nachrichten. Ziehen Sie die Form zum Öffnen des Bindungs-Assistenten für Message Queuing auf die rechte Seite der Trennlinie.
BizTalk-Messaging | Mit der BizTalk-Messaging-Form kann ein Port implementiert werden. BizTalk-Messaging-Dienste dienen zum Senden oder Empfangen von Nachrichten. Für die Portimplementierung kann entweder ein BizTalk Server-Messagingport oder ein Kanal verwendet werden. Ziehen Sie die Form zum Öffnen des BizTalk-Bindungs-Assistenten für Messaging auf die rechte Seite der Trennlinie.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen eines ungebundenen Ports zu einer XLANG-Ablaufplanzeichnung

  • Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

  • Implementieren eines Ports mithilfe einer COM-Komponente

  • Implementieren eines Ports mithilfe einer Windows Script-Komponente

  • Implementieren eines Ports mithilfe von Message Queuing

  • Implementieren eines Ports mithilfe von BizTalk-Messaging

  • Ändern der Eigenschaften einer Portimplementierung

Verwandte Themen

Kommunikationsformen

Flussdiagrammformen

Implementierungsformen

Implementieren von Geschäftsprozessen

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Senden oder Empfangen von Nachrichten

Grundlegendes zu Portimplementierungen

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Hinzufügen eines ungebundenen Ports zu einer XLANG-Ablaufplanzeichnung

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf die Trennleiste, und klicken Sie anschließend auf Neuen Port hinzufügen.

Anmerkungen

  • Sie können einen Port zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Ports nicht verfügbar.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Ein ungebundener Port kann entweder mithilfe von Message Queuing oder von BizTalk Messaging implementiert werden. Wenn Sie zu der Seite eine der genannten Implementierungen hinzufügen, stellt der Implementierungs-Assistent die Möglichkeit bereit, einen der verfügbaren ungebundenen Ports auszuwählen.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk-Messaging

Implementieren eines Ports mithilfe von Message Queuing

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Senden oder Empfangen von Nachrichten


Hinzufügen eines gebundenen Ports zu einer XLANG-Ablaufplanzeichnung

  • Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine Implementierungsform von der Implementierung-Schablone auf die rechte Seite der Trennlinie, und folgen Sie den Anweisungen des Assistenten für die gewählte Implementierung.

Anmerkungen

  • Sie können einen Port zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Ports nicht verfügbar.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk-Messaging

Implementieren eines Ports mithilfe von Message Queuing

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Senden oder Empfangen von Nachrichten


Implementieren eines Ports mithilfe einer COM-Komponente

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine COM-Komponente-Form von der Implementierung-Schablone auf die rechte Seite der Trennlinie.

    Der Bindungs-Assistent für COM-Komponenten wird gestartet.

  2. Geben Sie auf der Seite Willkommen beim Bindungs-Assistenten für COM-Komponenten einen Namen für den neu zu erstellenden Port ein, und klicken Sie dann auf Weiter.

    Der BizTalk-Orchestrierungs-Designer setzt für jede neue Portimplementierung einen Standardportnamen ein, dem eine (aktualisierte) Zahl angehängt wird. Sie können diesen Namen ändern.

  3. Klicken Sie auf der Seite Statische oder dynamische Kommunikation auf eine der folgenden Optionen:
    • Statisch

      Die Komponente wird vom XLANG-Ablaufplanungsmodul instanziiert.

      Bei Auswahl der Option Statisch wird die Komponente automatisch gelöscht, wenn die XLANG-Ablaufplaninstanz endet.

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Dynamisch

      Bei Auswahl dieser Option wird die Komponente von einer anderen Anwendung instanziiert. Ein Moniker oder ein Zeiger auf die Objektinstanz muss an den XLANG-Ablaufplan in Form eines Feldes in einer Nachricht zurückgesendet werden. Auf der Datenseite muss eine Verbindung zwischen diesem Nachrichtenfeld und dem Portverweis auf denjenigen Port gezogen werden, der diese Implementierung verwendet. Weitere Informationen zum Senden einer Nachricht an einen bestimmten Port finden Sie unter Zuordnen einer bestimmten Nachricht zu einem bestimmten Port.

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

    • Keine Instanziierung

      Wählen Sie diese Option nur für das Empfangen von Daten aus. Diese Option gibt an, dass Daten mithilfe einer Methode in einen XLANG-Ablaufplan übergeben werden; es wird jedoch kein Code hinter dem Methodenaufruf ausgeführt. Weitere Informationen finden Sie unter Datenverarbeitung.

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

    Weitere Informationen zur statischen und dynamischen Kommunikation finden Sie unter den folgenden Themen:

    • Statische und dynamische Ports

    • Instanzenverwaltung

    • Verwenden der Skriptkomponente-Form
  4. Klicken Sie auf der Seite Klasseninformationen auf eine der folgenden Optionen:
    • Von einer registrierten Komponente

      Ein Strukturansicht-Steuerelement zeigt alle auf Ihrem Computer registrierten Komponenten an. Erweitern Sie die Ansicht für den Ordner der gewünschten Klasse, und klicken Sie auf die Klasse.

      Klicken Sie auf Weiter.

    • Von einem Moniker

      Geben Sie den Namen eines Standard-COM-Monikers ein, um den Standort der COM-Komponente zu bestimmen, die Sie instanziieren möchten. Bei Auswahl dieser Option kann die COM-Komponente nicht für Kommunikationsvorgänge verwendet werden, die innerhalb einer Transaktion des XLANG-Ablaufplanes stattfinden.

      Klicken Sie auf Weiter.

  5. Klicken Sie auf der Seite Schnittstelleninformationen auf die Schnittstelle, die Sie verwenden möchten, und klicken Sie dann auf Weiter.

    Anmerkungen

    • Wenn die COM-Komponente nur eine Schnittstelle besitzt, wird diese Seite übersprungen.

    • Wurde die COM-Komponente mit Microsoft Visual Basic erstellt, gibt es für jede Klasse in der Komponente eine Schnittstelle desselben Namens. Jeder Schnittstellenname beginnt mit einem vorangestellten Unterstrich(_).
  6. Wählen Sie auf der Seite Methodeninformationen die Methoden aus, die Sie verwenden möchten, und klicken Sie dann auf Weiter.

    Anmerkungen

    • Wenn die COM-Komponente nur eine Methode besitzt, wird diese Seite übersprungen.

    • Sie müssen mindestens eine Methode auswählen.

    • Es besteht die Möglichkeit, mehrere oder alle Methoden auszuwählen. Mithilfe der Schaltflächen Alle auswählen und Gesamte Auswahl aufheben können Sie alle Methoden auswählen oder diese Auswahl aufheben.
  7. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Sicherheit auf eine der folgenden Optionen:
    • Nicht erforderlich

      Es wird kein Versuch unternommen, die Identität des Absenders zu bestätigen.

    • Optional

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Identität des Absenders an. Das XLANG-Ablaufplanungsmodul setzt seine Ausführung unabhängig davon fort, ob die gewünschten Identitätsinformationen vorliegen oder nicht.

    • Erforderlich

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Identität des Absenders an. Die Identität des Absenders muss bekannt sein und der XLANG-Ablaufplan ignoriert die Nachricht, wenn diese Identitätsinformationen nicht vorliegen.

    Anmerkung

    • Wenn der XLANG-Ablaufplan einen eingehenden Methodenaufruf zurückweist, weil die angeforderte Identifizierung des Absenders nicht vorliegt, wird der Fehlercode E_ACCESSDENIED an den aufrufenden Prozess zurückgegeben.
  8. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung auf eine der folgenden Optionen:
    • Deaktiviert

      Die Transaktionsunterstützung für die von dieser Portimplementierung verwendete COM+-Komponente wird deaktiviert.

    • Nicht unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente unterstützt keine Transaktionen.

    • Unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente erbt eine vorhandene Transaktion.

    • Erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente kann eine vorhandene Transaktion erben oder eine neue Transaktion initiieren.

    • Neue Transaktion erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente muss eine neue Transaktion initiieren.

  9. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Statusverwaltungsunterstützung auf eine der folgenden Optionen:
    • Behält den Status nicht bei

      Die von dieser Portimplementierung verwendete Komponente behält den Status nicht über Methodenaufrufe hinweg bei.

    • Behält den Status bei, unterstützt aber keine Persistenz

      Die von dieser Portimplementierung verwendete Komponente behält den Status während der ganzen Lebensdauer der Komponente bei. Dieser Komponentenstatus kann jedoch nicht dauerhaft gesichert werden.

    • Behält den Status bei und unterstützt Persistenz

      Die von dieser Portimplementierung verwendete Komponente behält den Status bei. Dieser Status kann mithilfe einer der Schnittstellen IPersistStream oder IPersistStreamInit gespeichert werden. Die Verwendung von IPersistStream oder IPersistStreamInit ermöglicht es, den Status der Komponente für spätere Instanziierungen zu speichern, bei denen die Komponente mithilfe des gespeicherten Zustands neu angelegt wird.

  10. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt.

    Wichtig

    • Diese Option ermittelt, ob Transaktionen, an denen die Komponente beteiligt ist, abgebrochen werden sollen, wenn Aufrufe von Methoden der Komponente ein HRESULT-Ergebnis zurückgeben, welches einen Fehler anzeigt.

      Die Option kann nur aktiviert werden, wenn die Kommunikationsaktion, welche diesen Port verwendet, innerhalb des Prozessablaufs einer Transaktion stattfindet.

  11. Klicken Sie auf Fertig stellen.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.
  • Sie können Portimplementierungen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Ein neu erstellter Port wird immer so eingerichtet, dass er mithilfe einer COM-Komponente implementiert werden kann.

  • Wenn Sie eine vorhandene Portimplementierung bearbeiten, können Sie auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

Verwandte Themen

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk-Messaging

Implementieren eines Ports mithilfe von Message Queuing

Implementierungsformen

Implementieren von Geschäftsprozessen

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Grundlegendes zu Portimplementierungen

Verwenden der COM-Komponente-Form

Verwenden des Methodenkommunikations-Assistenten


Implementieren eines Ports mithilfe einer Windows Script-Komponente

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite eine Skriptkomponente-Form von der Implementierung-Schablone auf die rechte Seite der Trennlinie.

    Der Bindungs-Assistent für Skriptkomponenten wird geöffnet.

  2. Geben Sie auf der Seite Willkommen beim Bindungs-Assistenten für Skriptkomponenten einen Namen für den neu zu erstellenden Port ein, und klicken Sie dann auf Weiter.

    Der BizTalk-Orchestrierungs-Designer setzt für jede neue Portimplementierung einen Standardportnamen ein, dem eine (aktualisierte) Zahl angehängt wird. Sie können diesen Namen ändern.

  3. Klicken Sie auf der Seite Statische oder dynamische Kommunikation auf eine der folgenden Optionen und dann auf Weiter:
    • Statisch

      Die Komponente wird vom XLANG-Ablaufplanungsmodul instanziiert.

      Bei Auswahl der Option Statisch wird die Komponente automatisch gelöscht, wenn die XLANG-Ablaufplaninstanz endet.

    • Dynamisch

      Bei Auswahl dieser Option wird die Komponente von einer anderen Anwendung instanziiert. Ein Moniker oder ein Zeiger auf die Objektinstanz muss an den XLANG-Ablaufplan in Form eines Feldes in einer Nachricht zurückgesendet werden. Auf der Datenseite muss eine Verbindung zwischen diesem Nachrichtenfeld und dem Portverweis auf denjenigen Port gezogen werden, der diese Implementierung verwendet. Weitere Informationen zum Senden einer Nachricht an einen bestimmten Port finden Sie unter Zuordnen einer bestimmten Nachricht zu einem bestimmten Port.

    • Keine Instanziierung

      Wählen Sie diese Option nur für das Empfangen von Daten aus. Diese Option zeigt an, dass Daten mithilfe einer Methode in den XLANG-Ablaufplan übergeben werden; es wird jedoch kein Code hinter dem Methodenaufruf ausgeführt.

    Weitere Informationen zur statischen und dynamischen Kommunikation finden Sie unter den folgenden Themen:

    • Statische und dynamische Ports

    • Instanzenverwaltung

    • Verwenden der Skriptkomponente-Form
  4. Auf der Seite Skriptdatei angeben klicken Sie auf Durchsuchen.

    Das Dialogfeld Skriptdatei auswählen wird angezeigt.

  5. Suchen Sie nach der gewünschten WSC-Datei, klicken Sie auf die Datei, und klicken Sie dann auf Öffnen.

  6. Klicken Sie auf Weiter, und setzen Sie den Vorgang mit der Auswahl einer der beiden folgenden Möglichkeiten fort:
    • Wenn Sie in Schritt 3 die Option Statisch gewählt haben, fahren Sie mit Schritt 7 in diesem Verfahren fort.

    • Wenn Sie in Schritt 3 eine der Optionen Dynamisch oder Keine Instanziierung gewählt haben, fahren Sie mit Schritt 8 in diesem Verfahren fort.
  7. Klicken Sie auf der Seite Informationen über Komponenteninstanziierung auf eine der folgenden Optionen, und klicken Sie dann auf Weiter:
    • Mit dem Moniker der Skriptdatei

      Als Moniker werden automatisch der Pfad und der Dateiname der Skriptdatei bereitgestellt.

    • Mit Programm-ID "Prog ID"

      Die Programm-ID wird automatisch bereitgestellt und aus dem XML-Code in der Windows Script-Komponentendatei extrahiert. Diese Option wird empfohlen, da auf diese Weise der Pfad für die Skriptdatei nicht festgelegt wird.

  8. Wählen Sie auf der Seite Methodeninformationen die Methoden aus, die Sie verwenden möchten, und klicken Sie dann auf Weiter.

    Anmerkungen

    • Wenn die Windows Script-Komponente nur eine Methode besitzt, wird diese Seite übersprungen.

    • Sie müssen mindestens eine Methode auswählen.

    • Es besteht die Möglichkeit, mehrere oder alle Methoden auszuwählen. Mithilfe der Schaltflächen Alle auswählen und Gesamte Auswahl aufheben können Sie alle Methoden auswählen oder diese Auswahl aufheben.
  9. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Sicherheit auf eine der folgenden Optionen:
    • Nicht erforderlich

      Es wird kein Versuch unternommen, die Identität des Absenders zu bestätigen.

    • Optional

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Identität des Absenders an. Das XLANG-Ablaufplanungsmodul setzt seine Ausführung unabhängig davon fort, ob die gewünschten Identitätsinformationen vorliegen oder nicht.

    • Erforderlich

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Identität des Absenders an. Die Identität des Absenders muss bekannt sein und der XLANG-Ablaufplan ignoriert die Nachricht, wenn diese Identitätsinformationen nicht vorliegen.

    Anmerkung

    • Wenn der XLANG-Ablaufplan einen eingehenden Methodenaufruf zurückweist, weil die angeforderte Identifizierung des Absenders nicht vorliegt, wird der Fehlercode E_ACCESSDENIED an den aufrufenden Prozess zurückgegeben.
  10. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung auf eine der folgenden Optionen:
    • Deaktiviert

      Die Transaktionsunterstützung für die von dieser Portimplementierung verwendete COM+-Komponente wird deaktiviert.

    • Nicht unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente unterstützt keine Transaktionen.

    • Unterstützt

      Die von dieser Portimplementierung verwendete COM+-Komponente erbt eine vorhandene Transaktion.

    • Erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente kann eine vorhandene Transaktion erben oder eine neue Transaktion initiieren.

    • Neue Transaktion erforderlich

      Die von dieser Portimplementierung verwendete COM+-Komponente muss eine neue Transaktion initiieren.

  11. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Fehlerbehandlung das Kontrollkästchen Transaktion abbrechen, wenn die Methode ein Fehler-HRESULT zurückgibt.

    Wichtig

    • Diese Option ermittelt, ob Transaktionen, an denen die Komponente beteiligt ist, abgebrochen werden sollen, wenn Aufrufe von Methoden der Komponente ein HRESULT-Ergebnis zurückgeben, welches einen Fehler anzeigt.

      Die Option kann nur aktiviert werden, wenn die Kommunikationsaktion, welche diesen Port verwendet, innerhalb des Prozessablaufs einer Transaktion stattfindet.

  12. Klicken Sie auf Fertig stellen.

Wichtig

  • Bei Verwendung von Windows-Skriptkomponenten müssen die folgenden Regeln beachtet werden:
    • Argumente müssen per Deklaration als Referenzen und nicht als Werte übergeben werden.

    • Es werden keine Microsoft VBScript-Prozeduren, sondern nur Funktionen unterstützt.

    • Innerhalb einer einzelnen WSC-Datei können nicht mehrere Komponenten verwendet werden.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.
  • Sie können Portimplementierungen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Ein neu erstellter Port wird immer so eingerichtet, dass er mithilfe einer Windows Script-Komponente implementiert werden kann.

  • Wenn Sie eine vorhandene Portimplementierung bearbeiten, können Sie auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

  • Dateien mit Windows Script-Komponenten verwenden die Dateinamenerweiterung WSC. Weitere Informationen zu Windows-Skriptkomponenten finden Sie in der Windows Scripting Technologies-Website (msdn.microsoft.com/scripting/default.htm). Suchen Sie in der Website nach der Seite Windows Script Components.

  • Windows-Skriptkomponenten, die vom XLANG-Ablaufplanungsmodul ausgeführt wurden, können erst wieder modifiziert werden, nachdem das XLANG-Ablaufplanungsmodul und der Windows Script Host beendet wurden.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe von BizTalk-Messaging

Implementieren eines Ports mithilfe von Message Queuing

Implementierungsformen

Implementieren von Geschäftsprozessen

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Grundlegendes zu Portimplementierungen

Verwenden der Skriptkomponente-Form

Verwenden des Methodenkommunikations-Assistenten


Implementieren eines Ports mithilfe von Message Queuing

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite die Message Queuing-Form von der Implementierung-Schablone auf die rechte Seite der Trennlinie.

    Der Bindungs-Assistent für Message Queuing wird geöffnet.

  2. Klicken Sie auf der Seite Willkommen beim Bindungs-Assistenten für Message Queuing auf eine der folgenden Optionen, und klicken Sie auf Weiter:
    • Neuen Port erstellen

      Der BizTalk-Orchestrierungs-Designer setzt für jede neue Portimplementierung einen Standardportnamen ein, dem eine (aktualisierte) Zahl angehängt wird. Sie können diesen Namen ändern.

    • Vorhandener ungebundener Port

      Klicken Sie in der Liste Vorhandener ungebundener Port auf den Port, den Sie verwenden möchten.

      In dieser Liste erscheinen nur die Namen ungebundener Ports. Ein ungebundener Port besitzt keine definierte Implementierung.

  3. Klicken Sie auf der Seite Informationen über statische oder dynamische Warteschlangen auf eine der folgenden Optionen:
    • Statische Warteschlange

      Eine statische Warteschlange ist eine bekannte, vordefinierte, vorhandene Warteschlange. Diese Warteschlange muss bereits zur Entwurfszeit bekannt sein.

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Dynamische Warteschlange

      Bei Auswahl dieser Option müssen Sie auf der Datenseite eine Verknüpfung zwischen einem Nachrichtenfeld und dem Portverweis auf diesen Port erstellen.

      Der Name der Warteschlange muss von einer anderen Nachricht bereitgestellt werden, bevor die Kommunikationsaktion mithilfe dieser Portimplementierung stattfindet. Weitere Informationen zu den Vorgehensweisen zum Übermitteln einer bestimmte Nachricht an einen bestimmten Port finden Sie unter Zuordnen einer bestimmten Nachricht zu einem bestimmten Port.

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

      Weitere Informationen zu statischen und dynamischen Warteschlangen finden Sie unter Statische und dynamische Ports.

  4. Klicken Sie auf der Seite Warteschlangeninformationen auf eine der folgenden Optionen, und klicken Sie dann auf Weiter:
    • Neue Warteschlange für jede Instanz erstellen

      Sie müssen der Warteschlange ein Präfix zuweisen (Beispiel: .\Private$\PrivateQueuePrefix oder .\PublicQueuePrefix). Für jede neu erstellte Warteschlange wird an das Präfix eine eindeutige Kennung angehängt.

      Es gibt einen Standardnamen für dieses Warteschlangenpräfix. Sie können diesen Standardnamen ändern.

      Soll jemand in die Lage versetzt werden, über diesen Port zu antworten, muss ihm ein Verweis auf den Port in einer Nachricht übermittelt werden. Wählen Sie zu diesem Zweck die Option Neue Warteschlange für jede Instanz erstellen aus, und geben Sie einen Stammnamen für die Warteschlangen ein. Zur Laufzeit erstellt das XLANG-Ablaufplanungsmodul eine neue Warteschlange mit diesem Stammnamen für jede Instanz. Für jede neu erstellte Warteschlange wird dem Stammnamen eine Instanz-GUID angehängt. Diese Warteschlange wird gelöscht, sobald die Instanz endet.

      Wenn Sie keinen Verweis auf diesen Port versenden möchten, gibt es auch keine Notwendigkeit dafür, zu jeder Instanz eine Warteschlange zu erzeugen. Sie können in diesem Fall eine Warteschlange erzeugen, die für alle Instanzen verwendet wird.

    • Bekannte Warteschlange für alle Instanzen verwenden

      Geben Sie den Namen einer bekannten, vordefinierten und vorhandenen Warteschlange ein (zum Beispiel ".\private$\queuename").

  5. Klicken Sie auf der Seite Erweiterte Porteigenschaften im Bereich Sicherheit auf eine der folgenden Optionen:
    • Nicht erforderlich

      Es wird kein Versuch unternommen, die Identität des Absenders zu bestätigen. Der XLANG-Ablaufplan empfängt jede Nachricht mit einem leeren Absenderfeld (__Sender__). Dabei spielt es keine Rolle, ob die Nachricht authentifiziert wurde oder nicht.

    • Optional

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Bestätigung der Identität des Absenders an. Der XLANG-Ablaufplan empfängt eine Nachricht unabhängig davon, ob die Nachricht authentifiziert wurde oder nicht. Wenn die Nachricht authentifiziert wurde, enthält das Feld __Sender__ den Wert der SenderID-Eigenschaft der Message Queuing-Nachricht.

    • Erforderlich

      Das XLANG-Ablaufplanungsmodul fordert Informationen zur Bestätigung der Identität des Absenders an. Die Bestätigung der Absenderidentität ist notwendig. Wenn die Nachricht authentifiziert wurde, empfängt der XLANG-Ablaufplan die Nachricht und das Feld __Sender__ enthält den Wert der SenderID-Eigenschaft der Message Queuing-Nachricht.

      Wenn die Nachricht nicht authentifiziert wird, wird ein Eintrag im Anwendungs-Ereignisprotokoll hinzugefügt, und die Nachricht wird in eine andere Warteschlange verschoben, die neu erstellt und mit dem Namen .\private$\<Anwendungsname>.DeadLetter versehen wird.

  6. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Sicherheit das Kontrollkästchen Zum Steuern der Warteschlange eine Windows-Gruppe oder einen Benutzernamen verwenden.

    Bei Aktivierung des Kontrollkästchens müssen Sie den Namen des Benutzers oder der Gruppe eingeben, für den oder die die Berechtigung gegeben ist, Nachrichten in die Warteschlange zu stellen. Diese Option ist nur bei Verwendung einer statischen Warteschlange verfügbar.

  7. Aktivieren oder deaktivieren Sie auf der Seite Erweiterte Porteigenschaften im Bereich Transaktionsunterstützung das Kontrollkästchen Für diese Warteschlage sind Transaktionen erforderlich.

  8. Klicken Sie auf Fertig stellen.

Anmerkungen

  • Sie können Portimplementierungen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Wenn Sie eine vorhandene Portimplementierung bearbeiten, können Sie auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk-Messaging

Implementierungsformen

Implementieren von Geschäftsprozessen

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Grundlegendes zu Portimplementierungen

Verwenden der Message Queuing-Form

Verwenden des Assistenten für XML-Kommunikation


Implementieren eines Ports mithilfe von BizTalk-Messaging

  1. Ziehen Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite die BizTalk-Messaging-Form von der Implementierung-Schablone auf die rechte Seite der Trennlinie.

    Der BizTalk-Bindungs-Assistent für Messaging wird geöffnet.

  2. Klicken Sie auf der Seite Willkommen beim BizTalk-Bindungs-Assistenten für Messaging auf eine der folgenden Optionen, und klicken Sie dann auf Weiter:
    • Neuen Port erstellen

      Der BizTalk-Orchestrierungs-Designer setzt für jede neue Portimplementierung einen Standardportnamen ein, dem eine (aktualisierte) Zahl angehängt wird. Sie können diesen Namen ändern.

    • Vorhandener ungebundener Port

      Klicken Sie in der Liste Vorhandener ungebundener Port auf den Port, den Sie verwenden möchten.

      In dieser Liste erscheinen nur die Namen ungebundener Ports. Ein ungebundener Port besitzt keine definierte Implementierung.

  3. Klicken Sie auf der Seite Kommunikationsrichtung auf eine der folgenden Optionen:
    • Senden

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Empfangen

      Klicken Sie auf Weiter. Weiter mit Schritt 5 in diesem Verfahren.

    Anmerkung

    • Bei Auswahl der Option Empfangen ist es möglich, Nachrichten zu empfangen. Dies kann mithilfe eines HTTP-URLs als Zieladresse oder mithilfe eines von BizTalk-Messaging-Manager konfigurierten Messagingports geschehen, über den ein XLANG-Ablaufplan instanziiert wird, um an einen bestimmten Port dieses Ablaufplanes Nachrichten senden zu können. Weitere Informationen zum Empfangen von Nachrichten mithilfe eines HTTP-URLs finden Sie unter Integrieren der BizTalk-Dienste. Weitere Informationen zum Konfigurieren eines Messagingports mithilfe von BizTalk-Messaging-Manager finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  4. Klicken Sie auf der Seite Informationen über statische oder dynamische Kanäle auf eine der folgenden Optionen und dann auf Beenden:
    • Statischer Kanal

      Geben Sie den Namen eines bekannten, vordefinierten, vorhandenen Kanals ein.

    • Dynamischer Kanal

      Bei Auswahl dieser Option müssen Sie den Port so konfigurieren, dass er die Daten bereitstellt, die die BizTalk-Messaging-Dienste zur Laufzeit zur Identifizierung des richtigen Kanals für die Nachrichtenverarbeitung benötigen.

      Zusätzlich müssen Sie auf der Datenseite eine Verknüpfung zwischen einem Nachrichtenfeld einer zuvor empfangenen Nachricht und dem Portverweis auf diesen Port erstellen. Das Nachrichtenfeld muss eine Zieladresse enthalten, die die BizTalk-Messaging-Dienste als Zieladresse für einen offenen Messagingport verwenden können, der mit dem erwähnten Kanal verknüpft ist. Weitere Informationen finden Sie unter Integrieren der BizTalk-Dienste.

      Um den Kommunikationsfluss zwischen einer Aktion und diesem Port einzurichten, verwenden Sie den Assistenten für XML-Kommunikation. Sie müssen auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der dem Kanal zugeordneten Dokumentdefinition für eingehende Dokumente eingeben. Die BizTalk-Messaging-Dienste verwenden diese Angabe, um den richtigen Kanal zur Verarbeitung der Nachricht zu bestimmen. Weitere Informationen finden Sie unter Identifikation.

    Wichtig

    • Es muss mindestens einen mithilfe der BizTalk Messaging-Dienste konfigurierten Kanal geben, der die angegebene Dokumentdefinition für eingehende Dokumente verwendet. Wenn eine Aktion mit einem über BizTalk-Messaging gebundenen Port kommuniziert und der für diese Bindung angegebene Kanal nicht vorhanden ist, endet die XLANG-Ablaufplaninstanz mit einem Failfast und einem Eintrag im Ereignisprotokoll.

    • Es sollte nur einen mithilfe der BizTalk-Messaging-Dienste konfigurierten Kanal geben, der die angegebene Dokumentdefinition für eingehende Dokumente verwendet und für den XLANG-Ablaufplan als Quelle konfiguriert worden ist. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung. Jener Kanal muss außerdem mit einem offenen Messagingport verknüpft sein. Wenn eine Aktion mit einem über BizTalk-Messaging gebundenen Port kommuniziert, und es existieren für diese Bindung mehrere Kanäle, endet die XLANG-Ablaufplaninstanz ebenfalls mit einem Fehler und einem Eintrag im Ereignisprotokoll.
  5. Klicken Sie auf der Seite Informationen über die XLANG-Ablaufplanaktivierung auf eine der folgenden Optionen:
    • Ja

      Dieser Port kann nicht in mehreren Empfangsaktionen gleichzeitig oder innerhalb einer einzelnen Empfangsaktion in einer Schleife verwendet werden.

      Klicken Sie auf Fertig stellen.

    • Nein

      Klicken Sie auf Weiter.

  6. Geben Sie auf der Seite Kanalinformationen in das Feld Kanalname den Namen des Kanals ein, den Sie verwenden möchten. Weitere Informationen zu Kanälen finden Sie unter den Themen Grundlegendes zu Kanälen und Suchen nach Kanälen.

  7. Geben Sie auf der Seite Kanalinformationen in das Feld HTTP-URL-Adresse, über die der BizTalk-Messagingdienst Dokumente empfängt den URL ein, über den BizTalk Server die Dokumente für diesen Kanal empfängt.

  8. Klicken Sie auf Fertig stellen.

Wichtig

  • Wird ein Port per Konfigurierung veranlasst, beim Eintreffen einer Nachricht einen neuen XLANG-Ablaufplan zu aktivieren, sind dabei die folgenden Einschränkungen zu beachten:
    • Nur ein Port eines Ablaufplanes kann dazu verwendet werden, den Ablaufplan beim Eintreffen der Nachricht zu aktivieren.

    • Nur eine Aktion kann über diesen Port empfangen.

    • Diese eine Aktion darf sich nicht in einer Schleife befinden.

    • Es ist nicht möglich, eine Datenflussverbindung vom Portverweis auf diesen Port zu einer anderen Nachricht im Ablaufplan zu ziehen.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.
  • Sie können Portimplementierungen zu Geschäftsprozessseiten, zu den Seiten Kompensierung für Transaktion und zu den Seiten Bei Fehler von Transaktion hinzufügen. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Wenn Sie eine vorhandene Portimplementierung bearbeiten, können Sie auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

Internationales Problem

  • Wenn Nicht-ASCII-Zeichen in den Namen eines Nichtaktivierungs-Empfangskanals aufgenommen werden, kann es beim Senden von Dokumenten mit HTTP zu Fehlern kommen. Der Kanalname wird in den Abfragezeichenfolge-Teil des URLs eingegeben. Nicht-ASCII-Zeichen werden in den Abfragezeichenfolgen nicht unterstützt.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von Message Queuing

Implementierungsformen

Implementieren von Geschäftsprozessen

Integrieren der BizTalk-Dienste

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Ändern der Eigenschaften einer Portimplementierung

Suchen nach Kanälen

Grundlegendes zu Kanälen

Grundlegendes zu Portimplementierungen

Verwenden der BizTalk-Messaging-Form

Verwenden des Assistenten für XML-Kommunikation


Ändern der Eigenschaften einer Portimplementierung

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf eine Implementierungsform, die Sie ändern möchten.

  2. Klicken Sie auf Eigenschaften.

    Der Assistent für die gewählte Implementierungsform wird gestartet.

  3. Folgen Sie den Anweisungen des Assistenten, und nehmen Sie die gewünschten Änderungen an den Eigenschaften vor.

Anmerkungen

  • Sie können jede Portimplementierung auf den Geschäftsprozessseiten, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion ändern. Auf der Datenseite sind Portimplementierungen nicht verfügbar.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Für jeden neu erstellten Port wird automatisch ein Portverweis auf der Datenseite generiert.

  • Sie können auf der ersten Seite des Implementierungs-Assistenten mithilfe der Option Aktuellen Port umbenennen den Portnamen ändern.

Verwandte Themen

Implementieren eines Ports mithilfe einer COM-Komponente

Implementieren eines Ports mithilfe einer Windows Script-Komponente

Implementieren eines Ports mithilfe von BizTalk-Messaging

Implementieren eines Ports mithilfe von Message Queuing

Implementierungsformen

Implementieren von Geschäftsprozessen


Senden oder Empfangen von Nachrichten

Der BizTalk-Orchestrierungs-Designer stellt zwei Formen der Kommunikation zur Verfügung, mit deren Hilfe ein XLANG-Ablaufplan das Senden und Empfangen von Nachrichten bewerkstelligen kann:

  • Synchrone Kommunikation. Hierbei werden Methodenaufrufe verwendet, um Nachrichtenpaare synchron zu senden oder zu empfangen.

  • Asynchrone Kommunikation. Hierbei werden XML-Nachrichten verwendet, um einzelne Nachrichten asynchron zu senden oder zu empfangen.

Weitere Informationen finden Sie unter Synchrone und asynchrone Kommunikation.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

  • Senden oder Empfangen synchroner Nachrichten

  • Senden oder Empfangen asynchroner Nachrichten

  • Ändern des Kommunikationsflusses zwischen einer Aktion und einem Port

Verwandte Themen

Synchrone und asynchrone Kommunikation

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite auf eine Aktion-Form, um sie zu markieren.

  2. Ziehen Sie das rechte Kontrollhandle ( Kontrollhandle) der Aktion-Form auf den Verbindungspunkt ( Verbindungspunkt) einer Port-Form.

    Ein Kommunikations-Assistent wird gestartet.

  3. Weiter mit einem der folgenden Verfahren, je nach Art des zu erstellenden Kommunikationsflusses.
    • Wenn Sie einen synchronen Kommunikationsfluss zu einem Port erstellen möchten, der eine COM-Komponenten- oder Skriptkomponenten-Implementierung verwendet, verwenden Sie den Methodenkommunikations-Assistenten. Weiter mit Senden oder Empfangen synchroner Nachrichten.

    • Wenn Sie einen asynchronen Kommunikationsfluss zu einem Port erstellen möchten, der eine Message Queuing- oder BizTalk-Messaging-Implementierung verwendet, oder wenn Sie einen asynchronen Kommunikationsfluss zu einem ungebundenen Port erstellen möchten, verwenden Sie den Assistenten für XML-Kommunikation. Weiter mit Senden und Empfangen asynchroner Nachrichten.

Anmerkungen

  • Sie können auch das Verbindungstool verwenden, um Formen miteinander zu verbinden. Weitere Informationen finden Sie unter Verwenden des Verbindungstools.

  • Sie können einen Kommunikationsfluss zwischen einer Aktion und einem Port auf jeder Geschäftsprozessseite, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion einrichten. Auf der Datenseite sind Aktionen und Ports nicht verfügbar.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Jedes Mal, wenn eine Aktion mit einem Port verbunden wird, werden automatisch neue Nachrichten auf der Datenseite generiert.


Senden oder Empfangen synchroner Nachrichten

Nachdem Sie im BizTalk-Orchestrierungs-Designer einen Kommunikationsfluss zwischen einer Aktion und einem Port für eine synchrone Kommunikation eingerichtet haben, wird der Methodenkommunikations-Assistent gestartet. Weitere Informationen zum Einrichten eines Kommunikationsflusses finden Sie unter Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port.

  1. Klicken Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten auf eine der folgenden Optionen:
    • Synchronen Methodenaufruf initiieren

      Das XLANG-Ablaufplanungsmodul initiiert einen synchronen Methodenaufruf.

      In diesem Fall sendet das XLANG-Ablaufplanungsmodul einen Methodenaufruf an eine Komponente, wartet auf eine Antwort der Komponente und empfängt anschließend eine Antwort.

      Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

    • Auf synchronen Methodenaufruf warten

      Das XLANG-Ablaufplanungsmodul wartet auf einen Methodenaufruf, der von einer anderen Anwendung initiiert wird.

      In diesem Fall wartet das XLANG-Ablaufplanungsmodul darauf, dass eine andere Anwendung den Methodenaufruf initiiert. Diese separate Anwendung sendet einen Methodenaufruf an eine Komponente; das XLANG-Ablaufplanungsmodul wartet auf eine Antwort der Komponente und gibt dann eine Antwort zurück an die Anwendung. Der XLANG-Ablaufplan empfängt sowohl den Methodenaufruf als auch die Antwort der Methode.

      Weiter mit Schritt 2 in diesem Verfahren.

  2. Geben Sie auf der Seite Willkommen beim Methodenkommunikations-Assistenten die Zeit in Sekunden ein, die das XLANG-Ablaufplanungsmodul auf das Eintreffen einer Nachricht warten soll, und klicken Sie dann auf Weiter, um die Ausführung eines XLANG-Ablaufplanes zu optimieren.

    Der Standardwert für diese Wartezeit ist 0 Sekunden. Sie können diesen Wert ändern. Jede Zeitangabe von nicht mehr als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan nicht pausiert. Jede Zeitangabe von mehr als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan sofort pausiert. Weitere Informationen zu Wartezeiten und dem Pausieren eines XLANG-Ablaufplanes finden Sie unter den Themen Pausierung und Aktivierung und Verwenden des Methodenkommunikations-Assistenten.

  3. Klicken Sie auf der Seite Nachrichteninformationen auf eine der folgenden Optionen:
    • Neue Nachricht erstellen

      Der Name dieser Nachricht wird automatisch von der Methode ermittelt, die Sie auf der nächsten Seite dieses Assistenten auswählen. Der Datenfluss für eine neue Nachricht muss mit anderen Nachrichten auf der Datenseite verbunden sein.

      Klicken Sie auf Weiter. Weiter mit Schritt 4 in diesem Verfahren.

    • Verweis für ein vorhandenes synchrones Nachrichtenpaar hinzufügen

      Dem Kommunikationsfluss wird ein Verweis auf ein zuvor konfiguriertes Nachrichtenpaar hinzugefügt. Diese Nachrichtenpaare können nur innerhalb desselben Ports wieder verwendet werden. Sie können nicht von einer anderen Portimplementierung verwendet werden

      Klicken Sie auf Fertig stellen.

  4. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation in der Liste Methoden auf die Methode, die Sie verwenden möchten. Es kann immer nur eine Methode in der Liste ausgewählt werden.

    Die Auswahl einer Methode definiert die Nachrichten für diesen Kommunikationsfluss. Die Ein- und Ausgabeparameter werden automatisch durch die Parameteranforderungen der von Ihnen ausgewählten Methode ermittelt. Beide Parameterlisten enthalten jeweils den Namen und Datentyp des Parameters.

    Weitere Informationen zum Festlegen der in einem Kommunikationsfluss verwendeten Nachrichten finden Sie unter Synchrone Kommunikation.

  5. Klicken Sie auf Fertig stellen.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.
  • Die Eigenschaft zur Festlegung der Wartezeit ist nicht aktiviert, sofern Sie nicht auf die Option Auf synchronen Methodenaufruf warten klicken.

  • Die einzigen Methoden, die für eine synchrone Kommunikation verfügbar sind, sind diejenigen, die für die Portimplementierung ausgewählt wurden. Methoden anderer Portimplementierungen können nicht verwendet werden. Auch XML-Nachrichten von asynchronen Kommunikationsflüssen können nicht verwendet werden. Um andere Methoden zur Verfügung zu haben, müssen Sie den geeigneten Assistenten für die Portimplementierung erneut ausführen und andere Methoden auswählen.

  • Beim Einrichten einer synchronen Kommunikation wird eine Nachricht auf der Datenseite erstellt. Diese Nachricht entspricht den Methoden und Parametern, die in dem Kommunikationsfluss verwendet werden. Die Nachricht enthält alle IN-Parameter für die Methode.

    Eine Methode kann keine Parameter enthalten, die Nachricht enthält jedoch stets erforderliche Systemfelder. Weitere Informationen zum Festlegen der bei einer synchronen Kommunikation verwendeten Nachrichten finden Sie unter Synchrone Kommunikation.

Verwandte Themen

Pausierung und Aktivierung

Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

Implementieren von Ports

Senden oder Empfangen asynchroner Nachrichten

Synchrone Kommunikation

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Senden oder Empfangen asynchroner Nachrichten

  1. Klicken Sie auf der Seite Willkommen beim Assistenten für XML-Kommunikation auf eine der folgenden Optionen:
    • Senden

      Eine Nachricht wird asynchron versendet.

      Klicken Sie auf Weiter. Weiter mit Schritt 3 in diesem Verfahren.

    • Empfangen

      Das XLANG-Ablaufplanungsmodul setzt die Ausführung des XLANG-Ablaufplanes erst nach Empfang einer Nachricht fort.

      Weiter mit Schritt 2 in diesem Verfahren.

  2. Um die Ausführung eines XLANG-Ablaufplanes zu optimieren, geben Sie auf der Seite Willkommen beim Assistenten für XML-Kommunikation die Zeit in Sekunden ein, die das XLANG-Ablaufplanungsmodul auf das Eintreffen einer Nachricht warten soll, und klicken Sie dann auf Weiter.

    Der Standardwert für diese Wartezeit ist 0 Sekunden. Sie können diesen Wert ändern. Jede Zeitangabe von nicht mehr als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan nicht pausiert. Jede Zeitangabe von mehr als 180 Sekunden führt dazu, dass der XLANG-Ablaufplan sofort pausiert. Weitere Informationen zu Wartezeiten und dem Pausieren eines XLANG-Ablaufplanes finden Sie unter den Themen Pausierung und Aktivierung und Verwenden des Assistenten für XML-Kommunikation.

  3. Klicken Sie auf der Seite Nachrichteninformationen auf eine der folgenden Optionen:
    • Neue Nachricht erstellen

      Geben Sie in das Feld Nachrichtenname den Namen für die neue Nachricht ein. Ein Standardnachrichtenname mit einer angehängten Zahl wird bereitgestellt; Sie können diesen Namen jedoch ändern.

      Der Datenfluss für eine neue Nachricht muss mit anderen Nachrichten auf der Datenseite verbunden sein.

    • Verweis zu einer vorhandenen Nachricht hinzufügen

      Dem Kommunikationsfluss wird ein Verweis auf eine zuvor konfigurierte Nachricht hinzugefügt.

  4. Klicken Sie auf Weiter, und führen Sie einen der folgenden Schritte durch:
    • Wenn Sie auf der Seite Willkommen beim Assistenten für XML-Kommunikation die Option Senden ausgewählt haben, fahren Sie mit Schritt 5 in diesem Verfahren fort.

    • Wenn Sie auf der Seite Willkommen beim Assistenten für XML-Kommunikation die Option Empfangen ausgewählt haben, fahren Sie mit Schritt 8 in diesem Verfahren fort.
  5. Klicken Sie auf der Seite Informationen über die XML-Konvertierung auf eine der folgenden Optionen, und klicken Sie dann auf Weiter:
    • Nachrichten im XML-Format an die Warteschlange senden

    • Nachrichten als Zeichenfolge an die Warteschlange senden

      Das XLANG-Ablaufplanungsmodul muss in diesem Fall die Informationen des XML-Standardwrappers aus der Zeichenfolge entfernen.

    Der Datenfluss wird im XLANG-Ablaufplanungsmodul mithilfe von XML verarbeitet. Das Modul sendet selbsttätig XML-Nachrichten an Nachrichtenwarteschlangen. Das Modul ist auch in der Lage, eine Nachricht als Zeichenfolge zu senden, aus der es jedoch zuvor die Informationen des XML-Standardwrappers entfernen muss. Der Datenfluss muss eine Nachricht im richtigen Spezifikationsformat für diese Aktion übergeben.

    Wenn Sie sich dafür entscheiden, eine XML-Nachricht als Zeichenfolge zu versenden oder zu empfangen, enthält die für diese Nachricht auf der Datenseite generierte Nachrichten-Form ein Feld namens StringData, und Sie können zu dieser Nachricht keine anderen Spezifikationsfelder hinzufügen.

  6. Geben Sie auf der Seite Informationen über den Nachrichtentyp in das Feld Nachrichtentyp eine Bezeichnung für die Nachricht ein.

    Der von Ihnen eingegebene Text wird zum Bezeichnen der Nachricht verwendet, sobald sie zur Warteschlange gesendet wird.

  7. Um fortzufahren, wählen Sie eine der folgenden Möglichkeiten:
    • Wenn Sie auf der Seite Informationen über die XML-Konvertierung die Option Nachrichten im XML-Format an die Warteschlange senden ausgewählt haben, klicken Sie auf Weiter. Weiter mit Schritt 10 in diesem Verfahren.

    • Wenn Sie auf der Seite Informationen über die XML-Konvertierung die Option Nachrichten als Zeichenfolge an die Warteschlange senden ausgewählt haben, klicken Sie auf Fertig stellen.
  8. Klicken Sie auf der Seite Informationen über die XML-Konvertierung auf eine der folgenden Optionen, und klicken Sie dann auf Weiter:
    • Nachrichten in der Warteschlange als XML-Nachrichten empfangen

    • Nachrichten in der Warteschlange als Zeichenfolgen empfangen

      Das XLANG-Ablaufplanungsmodul muss in diesem Fall die Zeichenfolge um die Informationen des XML-Standardwrappers ergänzen.

    Der Datenfluss wird im XLANG-Ablaufplanungsmodul mithilfe von XML verarbeitet. Das Modul empfängt selbsttätig XML-Nachrichten von Nachrichtenwarteschlangen. Das Modul ist auch in der Lage, eine Nachricht als Zeichenfolge zu empfangen, die es jedoch zuvor um die Informationen des XML-Standardwrappers ergänzen muss.

  9. Geben Sie auf der Seite Informationen über den Nachrichtentyp in das Feld Nachrichtentyp eine Bezeichnung für die Nachricht ein.

    Der von Ihnen eingegebene Text wird zur Identifizierung der Nachrichten verwendet, welche von der Warteschlange empfangen werden sollen.

    Zuerst versucht das XLANG-Ablaufplanungsmodul, eine Übereinstimmung zwischen den Informationen zum Nachrichtentyp und der Nachrichtenbezeichnung in der Warteschlange zu finden.

    Sofern die Nachricht im XML-Format in der Warteschlange vorliegt, versucht das XLANG-Ablaufplanungsmodul als Nächstes, die Informationen zum Nachrichtentyp mit dem XML-Stammelement der Nachricht in der Warteschlange in Übereinstimmung zu bringen.

  10. Um fortzufahren, wählen Sie eine der folgenden Möglichkeiten:
    • Wenn Sie auf der Seite Informationen über die XML-Konvertierung die Option Nachrichten in der Warteschlange als XML-Nachrichten empfangen ausgewählt haben, klicken Sie auf Weiter. Weiter mit Schritt 11 diesem Verfahren.

    • Wenn Sie auf der Seite Informationen über die XML-Konvertierung die Option Nachrichten in der Warteschlange als Zeichenfolgen empfangen ausgewählt haben, klicken Sie auf Fertig stellen.
  11. Auf der Seite Informationen über die Nachrichtenspezifikation klicken Sie auf Durchsuchen.

    Das Dialogfeld Nach Spezifikation durchsuchen wird angezeigt.

  12. Suchen Sie nach der Spezifikation, die Sie verwenden möchten, klicken Sie darauf und anschließend auf Öffnen.

    Geben Sie auf der Seite Informationen über die Nachrichtenspezifikation in das Feld Nachrichtenspezifikation den Pfad und den Dateinamen der Spezifikation ein, die Sie ausgewählt haben.

    Anmerkungen

    • Wenn Sie nicht nach einer vorhandenen Spezifikation suchen, können Sie auf Erstellen klicken. Dieser Vorgang öffnet den BizTalk-Editor, der es Ihnen ermöglicht, eine Spezifikation auszuwählen und nach Bedarf zu modifizieren, um sie für diese Nachricht verwenden zu können, oder eine neue Spezifikation zu erstellen.

    • Wenn Sie eine Spezifikation per Durchsuchen ausgewählt haben, ändert sich die Beschriftung der Schaltfläche Erstellen in Bearbeiten. Klicken Sie auf Bearbeiten, um die ausgewählte Spezifikation zu modifizieren.
  13. Wenn Sie die Gültigkeit der Nachricht anhand ihrer Spezifikation überprüfen möchten, aktivieren Sie auf der Seite Informationen über die Nachrichtenspezifikation das Kontrollkästchen Nachrichten anhand der Spezifikation überprüfen.

    Anmerkung

    • Dieses Kontrollkästchen ist nur dann verfügbar, wenn Sie eine Spezifikation ausgewählt haben, die für eine Überprüfung verwendet werden kann.
  14. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Hinzufügen, wenn Sie zu der Liste Nachrichtenfelder weitere Felder hinzufügen möchten.

    Wichtig

    • Wenn Sie zusätzliche Felder für diese Nachrichtenspezifikation auswählen möchten, müssen Sie eine Spezifikation verwenden, die mithilfe des BizTalk-Editors erstellt wurde. Sie können jeden Standard und jedes Schema anpassen, indem Sie die entsprechende Datei zuerst in den BizTalk-Editor importieren und sie anschließend als BizTalk Server-Spezifikation speichern. Weitere Informationen finden Sie unter Erstellen und Überprüfen von Spezifikationen.
  15. Erweitern Sie im Dialogfeld Feldauswahl in der Strukturansicht Auswahlknoten alle erforderlichen Knoten, klicken Sie auf das Feld, das Sie hinzufügen möchten, und klicken Sie dann auf OK.

    Anmerkungen

    • Wenn Sie auf ein Feld in der Strukturansicht Auswahlknoten klicken, wird der Name des Feldes automatisch zu dem Feld Feldname hinzugefügt.

    • Wenn Sie auf ein Feld in der Strukturansicht Auswahlknoten klicken, wird der Knotenpfad des Feldes automatisch zu dem Feld Knotenpfad hinzugefügt. Dieser Pfad kann manuell bearbeitet werden. Weitere Informationen finden Sie unter Knotenpfadfelder.

    • Es ist nicht möglich, einen Datensatzknoten auszuwählen, um ihn zu der Liste Nachrichtenfelder hinzuzufügen. Es können nur Felder ausgewählt werden. Weitere Informationen finden Sie unter Knotenpfadfelder.

    • Sie müssen im Dialogfeld Feldauswahl ein Feld auswählen und auf OK klicken, um zu der Liste Nachrichtenfelder mehrere Felder hinzuzufügen. Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Hinzufügen, und wiederholen Sie den Vorgang, um ein weiteres Feld hinzuzufügen.
  16. Wenn Sie Felder aus der Liste Nachrichtenfelder auf der Seite Informationen über die Nachrichtenspezifikation entfernen möchten, klicken Sie in der genannten Liste auf ein Feld und anschließend auf Entfernen.

    Anmerkung

    • Erforderliche Felder können nicht gelöscht werden. Solche erforderlichen Felder werden in der Liste Nachrichtenfelder mit einem gelben Hintergrund dargestellt.
  17. Klicken Sie auf Fertig stellen.

Anmerkungen

  • Formennamen müssen bestimmte Benennungskonventionen erfüllen. Die folgenden Konventionen gelten für Transaktionen, Ports, Nachrichten, Regeln und Felder:
    • Der Name muss ein gültiger XML-Elementname sein. Weitere Informationen zu XML-Elementen finden Sie in der W3C-Website (www.w3.org).

    • Der Name darf nicht mit Unterstrichen (__) beginnen.

    • Der Name darf keinen Doppelpunkt (:) enthalten.

    • Der Name darf maximal 32 Zeichen lang sein.

    • Namen von Konstanten und Nachrichten dürfen nicht mit einem numerischen Zeichen beginnen.
  • Die Eigenschaft zur Festlegung der Wartezeit ist nicht aktiviert, sofern Sie nicht auf die Option Empfangen klicken.

  • Die einzigen Nachrichten, die sich für eine asynchrone Kommunikation eignen, sind XML-Nachrichten. Alle XML-Nachrichten stehen zur Verfügung und können für mehr als einen Port angegeben werden. Synchrone Nachrichtenpaare, die mithilfe des Methodenkommunikations-Assistenten erstellt werden, können nicht verwendet werden.

  • Wenn Sie diesen Kommunikationsfluss mit einem Port verbinden, der mithilfe von BizTalk-Messaging implementiert ist, wird die Richtung der Kommunikation (Senden oder Empfangen) durch die Portimplementierung ermittelt und kann nicht im Assistenten für XML-Kommunikation festgelegt werden. Die Option Senden oder Empfangen auf der ersten Seite des Assistenten wird in diesem Fall automatisch ausgewählt und kann nicht geändert werden. Sie müssen auf Weiter klicken und zur nächsten Seite des Assistenten übergehen, um die Konfigurierung des Kommunikationsflusses abzuschließen.

  • Beim Generieren einer asynchronen Kommunikation wird eine Nachricht auf der Datenseite erstellt. Diese Nachricht entspricht den im Kommunikationsfluss gesendeten oder empfangenen Informationen. In der Nachricht sind die erforderlichen Systemfelder sowie alle zusätzlich von Ihnen gewünschten Spezifikationsfelder enthalten. Weitere Informationen zum Festlegen der bei einer asynchronen Kommunikation verwendeten Nachrichten finden Sie unter Asynchrone Kommunikation.

Verwandte Themen

Asynchrone Kommunikation

Erstellen und Überprüfen von Spezifikationen

Erstellen von Spezifikationen und Zuordnen von Daten

Pausierung und Aktivierung

Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

Knotenpfadfelder

Senden oder Empfangen synchroner Nachrichten

Verwenden des Assistenten für XML-Kommunikation


Ändern des Kommunikationsflusses zwischen einer Aktion und einem Port

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf einer Entwurfsseite mit der rechten Maustaste auf den Kommunikationsfluss zwischen einer Aktion und einem Port, und klicken Sie dann auf Eigenschaften.

    Ein Kommunikations-Assistent wird gestartet.

  2. Folgen Sie den Anweisungen des Assistenten, und nehmen Sie die gewünschten Änderungen an den Eigenschaften vor.

  3. Weiter mit einem der folgenden Verfahren, je nach Art des zu erstellenden Kommunikationsflusses.
    • Wenn Sie einen synchronen Kommunikationsfluss zu einem Port erstellen möchten, der eine COM-Komponenten- oder Skriptkomponenten-Implementierung verwendet, verwenden Sie den Methodenkommunikations-Assistenten. Weiter mit Senden oder Empfangen synchroner Nachrichten.

    • Wenn Sie einen asynchronen Kommunikationsfluss zu einem Port erstellen möchten, der eine Message Queuing- oder BizTalk-Messaging-Implementierung verwendet, oder wenn Sie einen asynchronen Kommunikationsfluss zu einem ungebundenen Port erstellen möchten, verwenden Sie den Assistenten für XML-Kommunikation. Weiter mit Senden und Empfangen asynchroner Nachrichten.

Anmerkungen

  • Sie können einen Kommunikationsfluss zwischen einer Aktion und einem Port auf jeder Geschäftsprozessseite, den Seiten Kompensierung für Transaktion und den Seiten Bei Fehler von Transaktion einrichten. Auf der Datenseite sind Aktionen und Ports nicht verfügbar.

  • Zu der Datenseite können keine Formen hinzugefügt werden. Jedes Mal, wenn eine Aktion mit einem Port verbunden wird, werden automatisch neue Nachrichten auf der Datenseite generiert.

Verwandte Themen

Einrichten des Kommunikationsflusses zwischen einer Aktion und einem Port

Senden oder Empfangen asynchroner Nachrichten

Senden oder Empfangen synchroner Nachrichten

Verwenden des Methodenkommunikations-Assistenten

Verwenden des Assistenten für XML-Kommunikation


Festlegen des Datenflusses zwischen Nachrichten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Auswählen einer Nachricht

  • Auswählen eines Feldes innerhalb einer Nachricht

  • Festlegen des Datenflusses zwischen Nachrichten

  • Löschen einer Nachricht

  • Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

  • Verwenden von Konstanten

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung


Auswählen einer Nachricht

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite auf das graue Vorspannfeld der Nachricht, die Sie auswählen möchten.

    Die gesamte Nachricht ist nach ihrer Auswahl von einer grünen gestrichelten Randlinie umgeben.

Anmerkungen

  • Sie können die Liste Constants, die Liste Port References oder eine Nachrichten-Form auswählen.

  • Wenn Sie eine ganze Nachricht auswählen, können Sie die Nachricht durch Ziehen auf der Seite neu positionieren. Durch das Neupositionieren der Nachrichten können die Datenflüsse möglicherweise deutlicher hervortreten, die zwischen den Nachrichten festgelegt werden.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung

Löschen einer Nachricht

Festlegen des Datenflusses zwischen Nachrichten

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Auswählen eines Feldes innerhalb einer Nachricht

Verwenden von Konstanten


Auswählen eines Feldes innerhalb einer Nachricht

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite innerhalb einer Nachricht auf ein Feld, das Sie auswählen möchten.

    Das markierte Feld ist von einem grünen gestrichelten Rand umgeben. Alle für dieses Feld verfügbaren Kontrollhandles ( Kontrollhandle) sind aktiviert.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung

Löschen einer Nachricht

Festlegen des Datenflusses zwischen Nachrichten

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Auswählen einer Nachricht

Verwenden von Konstanten


Festlegen des Datenflusses zwischen Nachrichten

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite auf ein Feld innerhalb einer Nachricht, um dessen Kontrollhandles ( Kontrollhandle) zu aktivieren.

  2. Ziehen Sie das Kontrollhandle auf den Verbindungspunkt ( Verbindungspunkt) eines Feldes in einer anderen Nachricht, mit dem Sie eine Verbindung herstellen möchten.

  3. Wenn um den Verbindungspunkt ein rotes Feld ( Aktiver Verbindungspunkt) angezeigt wird, lassen Sie die Maustaste los, um die neue Verbindung festzulegen.

Anmerkung

  • Wenn Sie mehrere Datenflüsse erstellen möchten, können Sie das Verbindungstool verwenden, um das Hinzufügen der Datenflüsse zu beschleunigen. Weitere Informationen zum Verbindungstool finden Sie unter Verwenden des Verbindungstools.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung

Löschen einer Nachricht

Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

Auswählen eines Feldes innerhalb einer Nachricht

Auswählen einer Nachricht

Verwenden von Konstanten


Löschen einer Nachricht

  • Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite auf das graue Vorspannfeld der Nachricht, die Sie löschen möchten, und drücken Sie ENTF.

Anmerkungen

  • Sie können die Liste Port References nicht löschen.

  • Sie können die Liste Constants nicht löschen.

  • Wenn Sie ein einzelnes Feld innerhalb einer Nachricht markieren und ENTF drücken, wird nicht nur das Feld, sondern die gesamte Nachricht gelöscht.

Verwandte Themen

Hinzufügen, Löschen und Verbinden von Formen

Datenverarbeitung

Festlegen des Datenflusses zwischen Nachrichten

Auswählen eines Feldes innerhalb einer Nachricht

Auswählen einer Nachricht


Zuordnen einer bestimmten Nachricht zu einem bestimmten Port

  1. Klicken Sie auf das Feld in der Liste Port References, welches den Namen des Ports enthält, auf den Sie Bezug nehmen möchten.

  2. Ziehen Sie das Kontrollhandle ( Kontrollhandle) von jenem Feld auf den Verbindungspunkt ( Verbindungspunkt) desjenigen Feldes in einer Nachricht, dem Sie den Verweis auf den Port übergeben möchten.

Wichtig

  • Weitere Informationen zum Verknüpfen von Nachrichten und Portverweisen finden Sie unter den folgenden Themen:
    • Instanzenverwaltung

    • Datenverarbeitung

    • Grundlegendes zu Portimplementierungen

Verwandte Themen

Datenverarbeitung

Löschen einer Nachricht

Festlegen des Datenflusses zwischen Nachrichten

Implementieren von Ports

Instanzenverwaltung

Auswählen eines Feldes innerhalb einer Nachricht

Auswählen einer Nachricht

Grundlegendes zu Portimplementierungen

Verwenden von Konstanten


Verwenden von Konstanten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Konstanten

  • Bearbeiten von Konstanten

  • Löschen von Konstanten

Verwandte Themen

Datenverarbeitung

Felddatentypen

Zusammenfassung der Datentypen und Datentypwerte


Hinzufügen von Konstanten

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite, mit der rechten Maustaste auf die Liste Constants, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Nachricht Constants wird angezeigt.

  2. Klicken Sie auf Hinzufügen.

    Das Dialogfeld Eigenschaften der Konstante wird angezeigt.

  3. Geben Sie in das Feld Name einen Namen für die Konstante ein.

  4. Klicken Sie in der Liste Datentyp auf den Datentyp für die Konstante.

  5. Geben Sie in das Feld Wert den Wert für die Konstante ein.

  6. Klicken Sie auf OK und dann erneut auf OK.

Anmerkungen

  • Für jede Konstante, die Sie neu erstellen, wird automatisch ein Standardname mit einer angehängten Zahl eingetragen. Sie können diesen Namen ändern.

  • Der Bereich Datentypbeschreibung bietet schreibgeschützte Informationen zu dem von Ihnen ausgewählten Datentyp. Diese Informationen können ein Formatbeispiel oder die Angabe eines gültigen Wertebereiches für den Datentyp beinhalten.

Verwandte Themen

Datenverarbeitung

Löschen von Konstanten

Bearbeiten von Konstanten

Felddatentypen

Zusammenfassung der Datentypen und Datentypwerte


Bearbeiten von Konstanten

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite, mit der rechten Maustaste auf die Liste Constants, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Nachricht Constants wird angezeigt.

  2. Klicken Sie in der Liste Konstanten auf die Konstante, die Sie bearbeiten möchten.

  3. Klicken Sie auf Bearbeiten.

    Das Dialogfeld Eigenschaften der Konstante wird angezeigt.

  4. Bearbeiten Sie jede Konstanteneigenschaft, die Sie ändern möchten, und klicken Sie auf OK.

Anmerkungen

  • Detaillierte Informationen zu den im Dialogfeld Eigenschaften der Konstante verfügbaren Eigenschaften finden Sie unter Hinzufügen von Konstanten.

  • Für jede Konstante, die Sie neu erstellen, wird automatisch ein Standardname mit einer angehängten Zahl eingetragen. Sie können diesen Namen ändern.

  • Der Bereich Datentypbeschreibung bietet schreibgeschützte Informationen zu dem von Ihnen ausgewählten Datentyp. Diese Informationen können ein Formatbeispiel oder die Angabe eines gültigen Wertebereiches für den Datentyp beinhalten.

Verwandte Themen

Hinzufügen von Konstanten

Datenverarbeitung

Löschen von Konstanten

Felddatentypen

Zusammenfassung der Datentypen und Datentypwerte


Löschen von Konstanten

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer auf der Datenseite, mit der rechten Maustaste auf die Liste Constants, und klicken Sie anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften der Nachricht Constants wird angezeigt.

  2. Klicken Sie in der Liste Konstanten auf die Konstante, die Sie löschen möchten.

  3. Klicken Sie auf Löschen.

Verwandte Themen

Hinzufügen von Konstanten

Datenverarbeitung

Bearbeiten von Konstanten

Felddatentypen

Zusammenfassung der Datentypen und Datentypwerte


Ausführung von XLANG-Ablaufplänen

Dieser Abschnitt enthält Verfahren, die das Kompilieren und Debuggen von XLANG-Ablaufplänen erläutern und Ihnen erklären, wie Sie einen XLANG-Ablaufplan aktivieren und ausführen. Um XLANG-Ablaufpläne auszuführen, ist es möglicherweise auch erwünscht, eine COM+-Anwendung zu erstellen, die als Host für bestimmte Ablaufplaninstanzen dienen soll.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Kompilieren und Debuggen von XLANG-Ablaufplänen

  • Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Verwandte Themen

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Kompilieren und Debuggen von XLANG-Ablaufplänen

Wenn Sie einen XLANG-Ablaufplan erstellen, können Sie diesen Ablaufplan auch kompilieren, ausführen, testen und debuggen. BizTalk-Orchestrierungs-Designer stellt Funktionen bereit, die Sie dabei unterstützen.

Im BizTalk-Orchestrierungs-Designer stehen folgende Optionen zur Verfügung:

  • Kompilieren

  • Aktualisieren von Methodensignaturen

  • Beenden von in Ausführung befindlichen Instanzen von XLANG-Ablaufplänen

Außer diesen Optionen gibt es zwei Tools, die Ihnen beim Testen und Debuggen eines XLANG-Ablaufplanes behilflich sein können:

  • XLANG Event Monitor. Mit diesem Tool können Sie aktive XLANG-Ablaufplaninstanzen überwachen. Spezifische Informationen zum Verwendung des XLANG Event Monitors finden Sie in der zugehörigen Infodatei Readme.htm. Der XLANG Event Monitor (XLANGMon.exe) und die vom Microsoft BizTalk Server 2002 Setup-Assistent installierte Infodatei befinden sich beide im folgenden Installationsverzeichnis: \Programme\Microsoft BizTalk Server\SDK\XLANG-Tools.

  • Windows 2000-Ereignisanzeige. Mit diesem Tool können Sie XLANG-Ablaufplanfehler anzeigen. Weitere Informationen finden Sie unter den folgenden Themen:
    • Verwalten der Ereignisanzeige

    • Überwachen von aktiven XLANG-Ablaufplänen

    • Weitere Informationen zur Ereignisanzeige finden Sie in der Windows 2000 Server-Hilfe im Kapitel "Ereignisanzeige" unter "Verwenden der Ereignisanzeige".

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

  • Ausführen eines XLANG-Ablaufplanes

  • Zusammenfassen eines XLANG-Ablaufplanes in einem Pool

  • Debuggen kompilierter Visual Basic-Komponenten

  • Aktualisieren von Methodensignaturen

  • Herunterfahren aller aktiven XLANG-Ablaufpläne

Verwandte Themen

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

  1. Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Datei auf XLANG ZeichnungX.skx erstellen.

    Das Dialogfeld XLANG-Ablaufplan speichern unter wird angezeigt.

  2. Suchen Sie in der Liste Speichern in nach dem Verzeichnis, in dem Sie den XLANG-Ablaufplan speichern möchten.

  3. In der Liste Dateiname können Sie die Datei umbenennen.

  4. Klicken Sie auf Speichern.

Anmerkungen

  • Beim Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan können Kompilierungsfehler gemeldet werden. Die Fehlermeldung verweist auf ein mögliches Problem in der Zeichnung, und die betroffene Form wird mit einer grünen gestrichelten Randlinie hervorgehoben.

  • Wenn Sie eine XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan kompilieren, wird die kompilierte Zeichnung unter dem Standardnamen ZeichnungX.skx gespeichert. Dabei bezeichnet X eine Zahl, die dem Namen des Ablaufplanes angehängt wird. Der Name der Datei kann beim Kompilieren der Zeichnung geändert werden.

  • Die Dateinamenerweiterung für einen XLANG-Ablaufplan lautet SKX. Eine SKX-Datei ist eine XML-Datei, deren Inhalt in der Sprache XLANG formuliert ist. Eine SKX-Datei kann nicht im BizTalk-Orchestrierungs-Designer geöffnet werden. Um eine SKX-Datei zu ändern oder zu aktualisieren, öffnen Sie die Quelldatei (SKV-Datei), nehmen die gewünschten Änderungen daran vor und kompilieren anschließend die SKV-Datei in eine SKX-Datei.

  • Die Dateinamenerweiterung für eine XLANG-Ablaufplanzeichnung lautet SKV.

  • Wenn Microsoft® Visual InterDev® als Skriptdebugger festgelegt ist und die Einstellung "Just in time" aktiviert ist, wird der Debugger u. U. aktiviert, wenn Sie einen Ablaufplan mit Skript kompilieren, der auf Objekte verweist. Sie erhalten die folgende Meldung:

    Möchten Sie die Anwendung debuggen?

    Klicken Sie auf Nein, so dass das Skript den Debugger umgehen und der Ablaufplan normal kompiliert werden kann. (Wenn Sie auf Ja klicken, wird der Debugger gestartet. Um ihn anzuhalten, müssen Sie alle Prozesse trennen oder das Debuggen abbrechen, wodurch Microsoft Visio beendet wird und Sie wahrscheinlich einen ungespeicherten Ablaufplan verlieren.) Sie können dieses Problem umgehen, indem Sie die Debugeinstellung "Just in time" in der Registrierung durch die Einstellung von HKEY_CURRENT_USER\Software\Microsoft\Windows Script\Settings\JITDebug auf 1 deaktivieren.

Verwandte Themen

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Debuggen kompilierter Visual Basic-Komponenten

Verwalten von XLANG-Anwendungen und -Datenbanken

Öffnen und Speichern von XLANG-Ablaufplanzeichnungen

Aktualisieren von Methodensignaturen

Ausführen eines XLANG-Ablaufplanes

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

Herunterfahren aller aktiven XLANG-Ablaufpläne


Ausführen eines XLANG-Ablaufplanes

Um einen XLANG-Ablaufplan auszuführen, müssen Sie den XLANG-Ablaufplan aktivieren.

Hierfür stehen Ihnen im Wesentlichen zwei Verfahren zur Verfügung:

  • Sie konfigurieren die BizTalk-Orchestrierungsdienste und die BizTalk-Messaging-Dienste in geeigneter Weise, um mit ihrer Hilfe XLANG-Ablaufpläne zu aktivieren und auszuführen.

    Weitere Informationen finden Sie unter den folgenden Themen:

    • Integrieren der BizTalk-Dienste

    • Festlegen von Eigenschaften für die Zielanwendung
  • Sie aktivieren den XLANG-Ablaufplan per Programm, indem Sie eine Instanziierungsanwendung wie z. B. eine ASP erstellen.

    Weitere Informationen finden Sie unter den folgenden Themen:

    • Ausführen von XLANG-Ablaufplänen

    • Erstellen einer Instanziierungsanwendung

    • Monikersyntax

Verwandte Themen

Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Debuggen kompilierter Visual Basic-Komponenten

Verwalten von XLANG-Anwendungen und -Datenbanken

Monikersyntax

Aktualisieren von Methodensignaturen

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

Herunterfahren aller aktiven XLANG-Ablaufpläne


Zusammenfassen eines XLANG-Ablaufplanes in einem Pool

Sie können Ihre Ablaufpläne in einem Pool zusammenfassen, um Ressourcen effizienter zu verwenden, wenn das Datenverkehrsaufkommen hoch ist und viele Ablaufplaninstanzen gleichzeitig aktiviert werden. Gehen Sie wie folgt vor, um einem Ablaufplan einem Objektpool zuzuweisen:

  1. Klicken Sie mit der rechten Maustaste auf die Beginn-Form, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld Beginneigenschaften wird angezeigt.

  2. Wählen Sie im Feld Pool aus der Dropdownliste einen Pool aus.

Gehen Sie wie folgt vor, um die Eigenschaften für den Objektpool festzulegen:

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie in der Konsolenstruktur zuerst Komponentendienste, dann Computer, danach Arbeitsplatz und schließlich COM+-Anwendungen.

  3. Klicken Sie mit der rechten Maustaste auf XLANG Schedule Pool, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von XLANG Schedule Pool wird angezeigt.

  4. Klicken Sie auf die Registerkarte Erweitert.

  5. Deaktivieren Sie unter Berechtigungen das Kontrollkästchen Ändern deaktivieren, und klicken Sie auf OK.

  6. Erweitern Sie in der Konsolenstruktur XLANG Schedule Pool, dann Komponenten, und klicken Sie mit der rechten Maustaste auf SimpleSkedPool.SimplePoolN.1, wobei N die Nummer des Pools ist, den Sie im vorherigen Schritt aus der Dropdownliste ausgewählt haben, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von SimpleSkedPool.SimplePoolN.1 wird angezeigt.

  7. Klicken Sie auf die Registerkarte Aktivierung.

  8. Führen Sie im Bereich Objektpooling folgende Aktionen durch:
    • Minimale Poolgröße Ändern Sie die minimale Poolgröße, um die Mindestanzahl von Objekten anzugeben, die im Arbeitsspeicher verbleiben.

    • Maximale Poolgröße Ändern Sie die maximale Poolgröße, um die maximale Anzahl von Ablaufplaninstanzen anzugeben, die im Arbeitsspeicher verbleiben.

    • Erstellungstimeout (ms) Ändern Sie den Erstellungstimeout, um die Anzahl von Millisekunden (ms) anzugeben, die eine Ablaufplaninstanz auf die Aktivierung wartet.
  9. Klicken Sie auf OK, um das Dialogfeld Eigenschaften von SimpleSkedPool.SimplePoolN.1 zu schließen.

Anmerkung

  • Weitere Information zum Pooling finden Sie unter Pooling von XLANG-Ablaufplänen.


Debuggen kompilierter Visual Basic-Komponenten

Es können Situationen auftreten, in denen Sie Komponenten, die Sie mit Microsoft Visual Basic erstellt haben, debuggen müssen, nachdem Sie sie kompiliert haben.

  1. Öffnen Sie in Visual Basic 6.0 das Visual Basic-Projekt, das Sie debuggen möchten.

  2. Klicken Sie im Menü Datei auf <IhrProjekt>.dll erstellen.

    Das Dialogfeld Projekt erstellen wird angezeigt.

  3. Klicken Sie auf Optionen.

    Das Dialogfeld Projekteigenschaften wird angezeigt.

  4. Klicken Sie im Dialogfeld Projekteigenschaften auf die Registerkarte Kompilieren, klicken Sie auf Kompilieren zu System-Code und auf Keine Optimierung, und aktivieren Sie anschließend das Kontrollkästchen Debug-Informationen für symbolischen Debugger generieren.

  5. Klicken Sie auf OK und dann erneut auf OK, um das Projekt zu kompilieren.

  6. Öffnen Sie das Visual Basic-DLL-Projekt.

  7. Legen Sie die gewünschten Haltepunkte fest.

  8. Klicken Sie im Menü Ausführen auf Starten.

Wenn der XLANG-Ablaufplan das nächste Mal eine Methode der Visual Basic-Komponente aufruft, unterbricht der Visual Basic-Debugger die Ausführung an dem festgelegten Haltepunkt.

Wichtig

  • Beim Erstellen der Visual Basic-DLL muss das Kontrollkästchen Debug-Informationen für symbolischen Debugger generieren aktiviert sein.

  • Stellen Sie sicher, dass das XLANG-Ablaufplanungsmodul die DLL noch nicht in den Speicher geladen hat. Wenn die DLL bereits geladen ist, müssen Sie das Modul beenden und die Ausführung erneut starten.

Anmerkung

  • Weitere Informationen zum Debuggen von Komponenten oder zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie nach "Component Services".


Aktualisieren von Methodensignaturen

Verwenden Sie diese Option, wenn Sie zur gleichen Zeit COM+-Komponenten und einen XLANG-Ablaufplan erstellen und einen der Methodenparameter für den Aufruf einer der verfügbaren Methoden ändern. Auf diese Weise aktualisieren Sie die Daten des XLANG-Ablaufplanes über die verfügbaren Methodenparameter.

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Extras auf Methodensignaturen aktualisieren.

Anmerkungen

  • Beim Kompilieren eines XLANG-Ablaufplanes wird der Befehl Methodensignaturen aktualisieren automatisch ausgeführt.

Verwandte Themen

Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Debuggen kompilierter Visual Basic-Komponenten

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen eines XLANG-Ablaufplanes

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen

Herunterfahren aller aktiven XLANG-Ablaufpläne


Herunterfahren aller aktiven XLANG-Ablaufpläne

  • Klicken Sie im BizTalk-Orchestrierungs-Designer im Menü Extras auf Alle aktiven XLANG-Ablaufplaninstanzen herunterfahren.

Anmerkung

  • Während der Ausführung einer XLANG-Ablaufplaninstanz ist es nicht möglich, Änderungen an COM-Komponenten vorzunehmen, die von diesem XLANG-Ablaufplan verwendet werden. Diese Option beendet alle aktiven Instanzen des Ablaufplanes und hebt die Zugriffssperre für die Komponentendatei auf, so dass Sie Änderungen vornehmen können.

Verwandte Themen

Kompilieren einer XLANG-Ablaufplanzeichnung in einen XLANG-Ablaufplan

Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Erstellen einer Instanziierungsanwendung

Debuggen kompilierter Visual Basic-Komponenten

Verwalten von XLANG-Anwendungen und -Datenbanken

Aktualisieren von Methodensignaturen

Ausführen eines XLANG-Ablaufplanes

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Erstellen und Konfigurieren einer Hostanwendung für einen XLANG-Ablaufplan

Dieser Abschnitt enthält Verfahren, die das Aktivieren und Ausführen eines XLANG-Ablaufplanes erläutern. Obwohl Sie zur Ausführung von XLANG-Ablaufplänen die Standardanwendung XLANG-Ablaufplanung (XLANG Scheduler) verwenden können, ist es häufig nützlich, eine neue COM+-Anwendung zu erstellen, um Ablaufplaninstanzen auszuführen.

Aufgrund von Sicherheitsfragen, Belangen der Weitergabe und Konfigurationsproblemen müssen die meisten COM+-Anwendungen, die als Hosts für XLANG-Ablaufpläne dienen, zur selben Zeit wie der XLANG-Ablaufplan entwickelt werden. Sicherheits- und leistungsbezogene Anforderungen der Anwendungen und der Ablaufpläne müssen gleichzeitig berücksichtigt werden. Sie können eine neue COM+-Anwendung erstellen, die als Host für bestimmte Instanzen aktiver Ablaufpläne dienen soll. Möglicherweise möchten Sie aber auch Anwendungen, die bestimmte Ablaufinstanzen ausführen, von anderen XLANG-Ablaufplänen isolieren, die andere Anwendungen verwenden.

Weitere Informationen zu sicherheits- und leistungsbezogenen Themen im Zusammenhang mit dem Erstellen von XLANG-Ablaufplänen und dem Erstellen einer COM+-Anwendung für das Hosting der Ablaufpläne finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

Informationen zur Handhabung von COM+-Anwendungen nach ihrer Erstellung finden Sie unter Verwalten von XLANG-Anwendungen und -Datenbanken.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne

  • Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zum Debuggen von Komponenten oder zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie nach "Component Services".

Verwandte Themen

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz, und klicken Sie dann auf COM+-Anwendungen, um diesen Eintrag zu markieren.

    Sie müssen COM+-Anwendungen zuerst markieren und anschließend mit der rechten Maustaste darauf klicken. Wird der Eintrag nicht zuerst markiert, ist die Option Neu nicht verfügbar.

  3. Klicken Sie mit der rechten Maustaste auf COM+ Anwendungen, zeigen Sie auf Neu, und klicken Sie dann auf Anwendung.

    Der COM-Anwendungsinstallations-Assistent wird geöffnet.

  4. Auf der Seite Willkommen beim COM-Anwendungsinstallations-Assistenten klicken Sie auf Weiter.

  5. Auf der Seite Neue Anwendung erstellen oder installieren klicken Sie auf Eine leere Anwendung erstellen.

  6. Geben Sie auf der Seite Leere Anwendung erstellen einen Namen für die Anwendung ein, stellen Sie sicher, dass die Option Serveranwendung aktiviert ist, und klicken Sie anschließend auf Weiter.

  7. Legen Sie auf der Seite Anwendungs-ID festlegen für die Identität der Anwendung das geeignete Konto fest.

    Es wird empfohlen, ein eigenes Dienstekonto für COM+-Anwendungen einzurichten, die als Host für XLANG-Ablaufpläne dienen.

    Weitere Informationen zu sicherheits- und leistungsbezogenen Themen im Zusammenhang mit dem Erstellen einer Anwendungsidentität finden Sie unter Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen.

  8. Klicken Sie auf Weiter und anschließend auf Fertig stellen.

  9. Klicken Sie mit der rechten Maustaste auf die gerade erstellte COM+-Anwendung, und klicken Sie anschließend auf Eigenschaften.

  10. Aktivieren Sie auf der Registerkarte XLANG das Kontrollkästchen Diese Anwendung stellt einen Host für BizTalk-Ablaufplaninstanzen dar.

  11. Um die COM+-Anwendung zu konfigurieren, fahren Sie fort mit Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne.

Wichtig

  • Sie müssen mindestens eine COM-Komponente in Ihrer COM+-Anwendung installieren.

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zum Debuggen von Komponenten oder zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie nach "Component Services".

  • Sie sollten das Hosting von XLANG-Ablaufplänen nur für dedizierte Prozesse verwenden; die COM+-Anwendung, die als Host für den Ablaufplan dient, sollte nichts anderes tun.

  • Beim Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne ist die Option Pausierende XLANG-Anwendungen neu starten nicht verfügbar. Weitere Informationen zum erneuten Starten pausierender Anwendungen finden Sie unter Neu starten aller XLANG-Anwendungen.

Verwandte Themen

Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Konfigurieren einer COM+-Hostanwendung für XLANG-Ablaufpläne

  1. Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste.

  2. Erweitern Sie Komponentendienste in der Konsolenstruktur, erweitern Sie Computer, dann Arbeitsplatz und dann COM+-Anwendungen.

  3. Klicken Sie mit der rechten Maustaste auf die COM+-Anwendung, die Sie konfigurieren möchten, und klicken Sie anschließend auf Eigenschaften.

    Es wird dringend empfohlen, ein eigenes Dienstekonto für die Verwaltung von COM+-Anwendungen einzurichten, die als Host für XLANG-Ablaufpläne dienen. Wenn Sie beim Erstellen der COM+-Anwendung mit dem COM-Anwendungsinstallations-Assistenten die Standardeinstellungen übernommen haben, möchten Sie diese Einstellungen möglicherweise ändern. Weitere Informationen finden Sie unter Senden oder Empfangen synchroner Nachrichten.

  4. Konfigurieren Sie die DSN-Einstellungen für die COM+-Anwendung.

    Weitere Informationen finden Sie unter Ändern der DSN-Einstellungen für eine COM+-Anwendung.

  5. Konfigurieren Sie eine Datenbank zur Verwendung durch die COM+-Anwendung.

    Folgende Aktionen sind möglich:

    • Zeigen Sie auf eine vorhandene Datenbank. Weitere Informationen finden Sie unter Ändern der DSN-Einstellungen für eine COM+-Anwendung.

      Oder

    • Erstellen und konfigurieren Sie eine neue Datenbank. Weitere Informationen finden Sie unter Erstellen einer neuen, leeren Persistenzdatenbank und Ändern der DSN-Einstellungen für eine COM+-Anwendung.

Vorsicht

  • Wenn Sie eine neue Datenbank erstellen und konfigurieren, die von der COM+-Anwendung verwendet werden soll, müssen Sie die Tabellen der Datenbank initialisieren, nachdem Sie die DSN-Einstellungen (Data Source Name, Datenquellenname) für die COM+-Anwendung festgelegt haben.

    Um weitere Informationen zum Konfigurieren der DSN-Einstellungen und zum Verwenden von (ODBC-)Datenquellen zu erhalten, klicken Sie im Dialogfeld ODBC-Datenquellen-Administrator auf Hilfe.

    So initialisieren Sie neue Datenbanktabellen für die zu konfigurierende COM+-Hostanwendung:

    1. Klicken Sie mit der rechten Maustaste auf die COM+-Anwendung, und klicken Sie anschließend auf Eigenschaften.

    2. Klicken Sie auf die Registerkarte XLANG.

    3. Klicken Sie auf Tabellen initialisieren.
  • Klicken Sie nicht auf Tabellen initialisieren, wenn Sie eine COM+-Hostanwendung und einen DSN für eine vorhandene Datenbank konfigurieren. Dieser Vorgang löscht alle bereits vorhandenen Daten in der Datenbank.

Anmerkungen

  • Zeigen Sie im Startmenü auf Einstellungen, klicken Sie auf Systemsteuerung, doppelklicken Sie auf Verwaltung und dann auf Komponentendienste, um Hilfe zur Verwaltung der Komponentendienste zu erhalten. Klicken Sie in der Konsolenstruktur mit der rechten Maustaste auf Komponentendienste, und klicken Sie anschließend auf Hilfedatei anzeigen.

  • Weitere Informationen zum Debuggen von Komponenten oder zu den Komponentendiensten und COM+ finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library/default.asp). Suchen Sie nach "Component Services".

Verwandte Themen

Ändern der Anwendungsidentität einer COM+-Anwendung

Ändern der DSN-Einstellungen für eine COM+-Anwendung

Erstellen einer COM+-Hostanwendung für XLANG-Ablaufpläne

Erstellen einer neuen, leeren Persistenzdatenbank

Erstellen einer Instanziierungsanwendung

Verwalten von XLANG-Anwendungen und -Datenbanken

Ausführen von XLANG-Ablaufplänen

Sicherheit für Hostanwendungen für XLANG-Ablaufplaninstanzen


Konfigurieren der BizTalk-Messagingdienste

Microsoft® BizTalk™ Server 2002 stellt für den Austausch von Dokumenten zwischen Handelspartnern und Anwendungen innerhalb eines Unternehmens zwei Konfigurationsmethoden für die BizTalk-Messagingdienste bereit. Sie können entweder den BizTalk-Messaging-Manager, eine grafische Benutzeroberfläche (User Interface, UI), verwenden oder direkt auf das BizTalk-Messaging-Konfigurationsobjektmodell zugreifen.

Mithilfe des BizTalk-Messaging-Managers oder des BizTalk-Messaging-Konfigurationsobjektmodells können Sie Messagingports und Kanäle zum Verwalten des Datenaustauschs erstellen. Sie können außerdem Dokumentdefinitionen, Umschläge und Organisationen, die zur Erstellung von Messagingports und Kanälen verwendet werden, oder Verteilerlisten, bei denen es sich um Gruppen von Messagingports handelt, erstellen.

Sicherheitsanforderungen

Zum Verwenden von BizTalk-Messaging-Manager ist Folgendes erforderlich:

  • Zugehörigkeit zu einem Benutzerkonto in der Gruppe BizTalk Server-Administratoren, die während der Installation von BizTalk Server 2002 erstellt wird. Bei Bedarf können weitere Benutzer zu dieser Gruppe hinzugefügt werden. Weitere Informationen zum Hinzufügen eines Benutzerkontos finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".

  • Vollständiger Datenbankzugriff auf die BizTalk-Messaging-Verwaltungsdatenbank (InterchangeBTM). Dies bedeutet, dass Sie sich anmelden können und dass Ihnen die Datenbankrolle db_owner erteilt wurde. Weitere Informationen finden Sie im Abschnitt "Erteilen von Zugriff auf eine Datenbank für einen Windows-Benutzer oder eine Windows-Gruppe (Enterprise Manager)" in der Microsoft SQL Server-Onlinedokumentation.

Gründe für das Verwenden von BizTalk-Messaging-Manager oder der Konfigurationsobjektmodell-API von BizTalk

Mit BizTalk-Messaging-Manager können Sie auf das Konfigurationsobjektmodell von BizTalk-Messaging über eine grafische Benutzeroberfläche zugreifen. Ob Sie die Oberfläche verwenden, hängt vom Umfang und der Art der Informationen ab, die in der Datenbank verfügbar sind. Mit der Schnittstelle für Anwendungsprogrammierung (Application Programming Interface, API) des BizTalk Messaging-Konfigurationsobjektmodells können Sie den gesamten Konfigurationsprozess oder einen Teil davon automatisieren, statt die Daten für jede einzelne Entität im BizTalk-Messaging-Manager einzugeben. Allgemein gilt: Je mehr Geschäftspartner Sie haben, desto nützlicher ist es für Sie, die API zum Konfigurieren der Messagingdienste zu verwenden.

Stellen Sie sich z. B. einen großen Produktionsbetrieb vor (in einem Hub und Spoke-Beispiel (Nabe und Speiche) wäre dieser Produktionsbetrieb die Nabe), der mit 1.000 Lieferanten arbeitet und eine Datenbank mit Informationen zu diesen Lieferanten verwaltet. Während des Schrittes "Erstellen von Organisationen" kann relativ schnell und einfach Code für folgende Vorgänge geschrieben werden:

  • Extrahieren von Informationen aus der Datenbank.

  • Verwenden des BizTalk-Messaging-Konfigurationsobjektmodells, um diese 1.000 Organisationen programmgesteuert in der BizTalk-Messaging-Verwaltungsdatenbank zu erstellen.

Im Unterschied dazu dauert es deutlich länger, alle 1.000 Objekte nacheinander mit dem BizTalk-Messaging-Manager zu erstellen. (Sie müssten denselben Assistenten tausendmal ausführen.) Und damit erstellen Sie nur die Organisationen, nicht aber die Dokumentdefinitionen, Kanäle oder Messagingports.

Ein kleiner Zulieferbetrieb (eine Speiche), der nur zu wenigen Handelspartnern Beziehungen unterhält, würde jedoch das gesamte Messagingsystem mit BizTalk-Messaging-Manager konfigurieren, statt zeitaufwändig speziellen Code zu schreiben.

Weitere Informationen zum Zugreifen auf das BizTalk-Messaging-Konfigurationsobjektmodell direkt über die API finden Sie unter Introducing Messaging Services.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Verwenden des BizTalk-Messaging-Managers


Verwenden des BizTalk-Messaging-Managers

Der Microsoft® BizTalk™-Messaging-Manager ist eine grafische Benutzeroberfläche (User Interface, UI), mit der Sie den Austausch von Geschäftsdokumenten durch Konfigurieren der BizTalk-Messagingdienste verwalten können. Die BizTalk-Messagingdienste können auch mithilfe der Konfigurationsobjektmodell-API von BizTalk programmgesteuert konfiguriert werden. Weitere Informationen finden Sie unter Introducing Messaging Services.

Vorsicht

  • Verwenden Sie den BizTalk-Messaging-Manager, um die BizTalk-Messagingdienste vor dem Verarbeiten von Dokumenten zu konfigurieren. Das Zugreifen auf und Ändern von Objekten, die möglicherweise verwendet werden, während Microsoft BizTalk Server 2002 Dokumente verarbeitet, kann zu unerwarteten Ergebnissen führen.

Dokumente können zwischen Handelspartnern und Anwendungen innerhalb eines Unternehmens ausgetauscht werden. Der BizTalk-Messaging-Manager ist sowohl lokal auf dem Computer mit BizTalk Server 2002 als auch als Clientanwendung über ein Netzwerk verfügbar. Dies ermöglicht es Systemadministratoren, die Sicherheit und zentrale Steuerung des Servers beizubehalten, während Remotebenutzer auf den BizTalk-Messaging-Manager zugreifen können.

Die BizTalk Server 2002-Hilfe enthält Informationen zur Erstellung und Verwaltung der folgenden Objekte von BizTalk-Messaging-Manager:

  • Kanäle

  • Messagingports

  • Dokumentdefinitionen

  • Umschläge

  • Organisationen

Darüber hinaus enthält die BizTalk Server 2002-Hilfe Informationen zur Verwendung von Verteilerlisten.

BizTalk-Messaging-Manager-Objekte

Die folgende Abbildung zeigt die Beziehungen zwischen Objekten, die mithilfe des BizTalk-Messaging-Managers erstellt werden können.

Übersicht über BizTalk-Messaging-Manager

Die folgende Zusammenfassung stellt eine kurze Übersicht über die Objekte bereit, die mithilfe des BizTalk-Messaging-Managers erstellt werden können. Die Beziehung zwischen den Objekten wird ebenfalls erläutert. Detaillierte Informationen zu jedem Objekt finden Sie, wenn Sie auf die Verknüpfung am Ende der Beschreibung klicken, um zum Hilfethema für das entsprechende Objekt zu gelangen.

Kanäle

Kanäle sind die primären Objekte im BizTalk-Messaging-Manager. Der Zweck der anderen Objekte des BizTalk-Messaging-Managers ist entweder das Erstellen von Kanälen oder das Unterstützen von Kanaloperationen. Kanäle identifizieren die Dokumentenquelle, die eine Organisation, eine Anwendung innerhalb Ihres Unternehmens oder ein XLANG-Ablaufplan sein kann. Außerdem können Kanäle mithilfe von Dokumentdefinitionen eingehende und ausgehende Dokumente identifizieren. Weitere Informationen finden Sie unter Grundlegendes zu Kanälen.

Messagingports

Messagingports identifizieren ein Ziel für die Dokumente, die von einem Kanal verarbeitet werden. Das Ziel kann eine Organisation, eine Anwendung innerhalb Ihres Unternehmens oder ein XLANG-Ablaufplan sein. Ein Messagingport gibt eine Zieladresse an, an die die Dokumente gesendet werden. Weiterhin gibt er an, wie die Dokumente zu dieser Adresse übertragen werden und wie Dokumente gegebenenfalls gesichert und mit einem Umschlag versehen werden. Weitere Informationen finden Sie unter Grundlegendes zu Messagingports.

Organisationen

Organisationen stellen andere Handelspartner dar, mit welchen Dokumente ausgetauscht werden können. Ein bestimmter Organisationstyp, die eigene Organisation, stellt Ihr Unternehmen dar. Sie können Anwendungen für die eigene Organisation erstellen, die den internen Anwendungen in Ihrem Unternehmen entsprechen. Organisationen und Anwendungen dienen als Quelle für einen Kanal oder als Ziel für einen Messagingport. Weitere Informationen finden Sie unter Grundlegendes zu Organisationen.

Dokumentdefinitionen

Eine Dokumentdefinition stellt einen bestimmten Dokumenttyp dar, der von BizTalk Server 2002 verarbeitet wird. Eine Dokumentdefinition stellt einen Zeiger auf eine Spezifikation bereit. Spezifikationen definieren die Struktur, den Typ und die Version eines Dokuments. Kanäle legen eine eingehende und eine ausgehende Dokumentdefinition fest, um anzugeben, welche Dokumente der Server verarbeitet. Eine Dokumentdefinition kann für eine beliebige Anzahl von Kanälen verwendet werden. Weitere Informationen finden Sie unter Grundlegendes zu Dokumentdefinitionen.

Umschläge

Umschläge stellen für BizTalk Server 2002 die Informationen bereit, die der Server zum Öffnen eingehender oder Erstellen ausgehender Austauschvorgänge benötigt. Umschläge können innerhalb eines Messagingports ausgewählt werden, um den Server beim Erstellen ausgehender Austauschvorgänge zu steuern. Von einem Messagingport unabhängige Umschläge können von BizTalk Server 2002 zum Öffnen eingehender Austauschvorgänge verwendet werden. Weiter Informationen finden Sie unter Grundlegendes zu Umschlägen.

Verteilerlisten

Verteilerlisten sind Gruppen von Messagingports, mit denen das gleiche Dokument an eine Gruppe verschiedener Handelspartner oder an interne Anwendungen gesendet werden kann. Wie für einen einzelnen Messagingport müssen Sie auch für eine Verteilerliste mindestens einen Kanal erstellen. Weitere Informationen finden Sie unter Grundlegendes zu Verteilerlisten.

Anmerkungen

  • Objekte können entweder mithilfe des BizTalk-Messaging-Managers erstellt werden oder programmgesteuert mithilfe des Konfigurationsobjektmodells von BizTalk-Messaging. Weitere Informationen finden Sie unter Understanding Messaging Services.

  • Die mithilfe des BizTalk-Messaging-Managers erstellten Objekte können auch Objekte verwenden, die mit anderen Komponenten von BizTalk Server 2000 erstellt werden. Kanäle verwenden Zuordnungen, die mithilfe des BizTalk-Mappers erstellt werden. Dokumentdefinitionen verwenden Dokumentspezifikationen. Umschläge verwenden Umschlagspezifikationen. Spezifikationen können mithilfe des BizTalk-Editors erstellt werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ausführliche Informationen zum BizTalk-Messaging-Manager finden Sie unter Informationen zum BizTalk-Messaging-Manager.

  • Eine kurze Referenz zum Durchführen bestimmter Aufgaben finden Sie unter Gründe für das Durchführen von BizTalk-Messaging-Manager-Aufgaben.

  • Detaillierte Beschreibungen der Verfahren für diese Aufgaben finden Sie unter Durchführen von BizTalk-Messaging-Manager-Aufgaben.


Informationen zum BizTalk-Messaging-Manager

Dieser Abschnitt stellt detaillierte konzeptionelle Informationen bereit, die wichtig für das Verständnis des Microsoft BizTalk-Messaging-Managers sind. Er stellt Informationen zu den folgenden Themen bereit:

  • BizTalk-Messaging-Manager - Umgebung

  • Grundlegendes zu Kanälen

  • Grundlegendes zu Messagingports

  • Grundlegendes zu Organisationen

  • Grundlegendes zu Dokumentdefinitionen

  • Grundlegendes zu Umschlägen

  • Grundlegendes zu Empfangsbestätigungen

  • Grundlegendes zu Verteilerlisten


BizTalk-Messaging-Manager - Umgebung

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren der Optionen für den BizTalk-Messaging-Manager

  • BizTalk-Messaging-Manager - Benutzeroberfläche

  • BizTalk-Messaging-Manager - Tastenkombinationen

  • Sicherheit

Vorsicht

  • Sie sollten den BizTalk-Messaging-Manager verwenden, um die BizTalk-Messagingdienste zu konfigurieren, bevor Sie Dokumente verarbeiten. Das Zugreifen auf und Ändern von Objekten, die möglicherweise verwendet werden, während Microsoft BizTalk Server 2002 Dokumente verarbeitet, kann zu unerwarteten Ergebnissen führen.


Konfigurieren der Optionen für den BizTalk-Messaging-Manager

Dieser Abschnitt erläutert, wie die Optionen für den BizTalk-Messaging-Manager geändert werden. Die Optionen umfassen Folgendes:

  • Konfigurieren neuer Messagingports oder Kanäle.

  • Verwalten bereits konfigurierter Messagingports oder -kanäle.

  • Festlegen des Suche-Rückgabewertes.

  • Festlegen der Serververbindung.

  • Festlegen des Servertimeoutwertes.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Auswählen einer BizTalk-Messaging-Manager-Konfigurationsoption

  • Festlegen von Server-Verbindungsoptionen

Anmerkung

  • Die Positionen der Symbolleisten im BizTalk-Messaging-Manager können geändert werden; wenn die Anwendung jedoch neu gestartet wird, kehren die Symbolleisten an ihre ursprünglichen Positionen zurück.


Auswählen einer BizTalk-Messaging-Manager-Konfigurationsoption

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

    Das Dialogfeld BizTalk-Messaging-Manager wird angezeigt.

  2. Wählen Sie aus dem Bereich Konfigurationsoptionen eine der folgenden Optionen aus:
    • Wenn Sie einen neuen Messagingport zu einer Organisation erstellen und konfigurieren möchten, klicken Sie auf Neuen Messagingport zu einer Organisation konfigurieren, und klicken Sie auf OK.

      Weitere Informationen zum Erstellen und Konfigurieren eines neuen Messagingports zu einer Organisation finden Sie unter Erstellen von Messagingports.

    • Wenn Sie einen neuen Messagingport zu einer Anwendung erstellen und konfigurieren möchten, klicken Sie auf Neuen Messagingport zu einer Anwendung konfigurieren, und klicken Sie auf OK.

      Weitere Informationen zum Erstellen und Konfigurieren eines neuen Messagingports zu einer Anwendung finden Sie unter Erstellen von Messagingports.

    • Wenn Sie einen bestehenden Messagingport verwalten möchten, klicken Sie auf Bereits konfigurierte Messagingports verwalten, und klicken Sie auf OK.

      Weitere Informationen zum Verwalten bestehender Messagingports finden Sie unter Bearbeiten von Messagingports.

    • Wenn Sie bestehende Kanäle verwalten möchten, klicken Sie auf Bereits konfigurierte Kanäle verwalten, und klicken Sie auf OK.

      Weitere Informationen zum Erstellen und Konfigurieren von vorhandenen Kanälen finden Sie unter Bearbeiten von Kanälen.

Anmerkung

  • Wenn Sie nicht möchten, dass dieses Dialogfeld beim Öffnen des BizTalk-Messaging-Managers angezeigt wird, aktivieren Sie das Kontrollkästchen Dieses Dialogfeld nicht mehr anzeigen. Klicken Sie im Menü Extras auf Optionen, und aktivieren das Kontrollkästchen Dialogfeld "Start" anzeigen, um das Dialogfeld erneut anzuzeigen.

Verwandte Themen

Erstellen von Messagingports

Bearbeiten von Kanälen

Bearbeiten von Messagingports


Festlegen von Server-Verbindungsoptionen

  1. Klicken Sie dazu im BizTalk-Messaging-Manager im Menü Extras auf Optionen.

    Das Dialogfeld Optionen wird angezeigt.

  2. Führen Sie im Feld Maximale Anzahl von zurückzugebenden Elementen bei einer Suche einen der folgenden Schritte durch:
    • Geben Sie einen Wert für die Anzahl der Elemente ein, die bei einer Suche zurückgegeben werden sollen.

    • Klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.
  3. Geben Sie in das Feld Name des BizTalk-Servers, zu dem eine Verbindung hergestellt wird den Namen eines Servers ein, auf dem BizTalk Server 2002 installiert ist.

  4. Führen Sie in dem Feld Servertimeout in Sekunden einen der folgenden Schritte durch:
    • Geben Sie einen Wert für die Anzahl der Sekunden ein, bevor bei der Serververbindung ein Timeout eintritt.

    • Klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.
  5. Damit ein Eingangsdialogfeld angezeigt bzw. nicht angezeigt wird, wenn der BizTalk-Messaging-Manager gestartet wird, aktivieren oder deaktivieren Sie das Kontrollkästchen Dialogfeld "Start" anzeigen.

  6. Nachdem Sie alle Eigenschaften festgelegt haben, klicken Sie auf OK.

Anmerkungen

  • Der Server, zu dem Sie eine Verbindung herstellen, ermittelt die BizTalk-Messaging-Verwaltungsdatenbank, für die Sie neue Objekte mithilfe des BizTalk-Messaging-Managers suchen, bearbeiten oder erstellen. Die Serververbindung ist standardmäßig die zuletzt aufgebaute Verbindung. Der Server, der als Host für das WebDAV-Repository dient, das Sie zum Speichern und Abrufen von Spezifikationen für Dokumente, Zuordnungen und Umschläge verwenden, wird unabhängig in den Dialogfeldern festgelegt, die zum Auswählen von Spezifikationen verwendet werden. Die WebDAV-Verbindung ist standardmäßig die zuletzt aufgebaute Verbindung.

  • Standardmäßig werden bei einer Suche bis zu 500 Elemente zurückgegeben.

  • Standardmäßig tritt ein Timeout der Serververbindung nach 20 Sekunden ein.

  • Der Server, mit dem Sie aktuell verbunden sind, wird am oberen Rand des Suchfensters angezeigt, das sich am linken Rand des BizTalk-Messaging-Managers befindet.

  • Beim Verwenden von Internet Explorer 5.5 Service Pack 1 (SP1) wird u. U. die folgende Fehlermeldung angezeigt: "Das Antwortdokument ist kein gültiges Dokument." Geben Sie im Feld Name des BizTalk-Servers, zu dem eine Verbindung hergestellt wird den vollqualifizierten Domänennamen ein, um den Fehler zu beheben. Markieren Sie anschließend in Internet Explorer 5.5 SP1 die Proxyeinstellungen als Ausnahmen (Option Internetoptionen im Menü Extras, Registerkarte Verbindungen), oder fügen Sie sie als Sites hinzu (Option Internetoptionen im Menü Extras, Registerkarte Sicherheit). Weitere Informationen finden Sie in der Dokumentation zu Internet Explorer 5.5 SP1.


BizTalk-Messaging-Manager - Benutzeroberfläche

Die BizTalk-Messaging-Manager-Benutzeroberfläche verfügt über zwei Hauptbereiche.

Der linke Bereich zeigt an:

  • Den Namen eines Servers, mit dem BizTalk-Messaging-Manager verbunden ist.

  • Eine Liste der Objekte, nach denen Sie suchen können.

  • Suchkriterien, mit denen Sie Ihre Suche eingrenzen können.

Sie können alle Objekte suchen, die Sie mithilfe des BizTalk-Messaging-Managers erstellt haben. Sie können den Objekttyp wählen, nach dem Sie suchen möchten, indem Sie im Bereich Nach anderen Elementen suchen auf den Namen klicken. Die Suchkriterien richten sich jeweils nach dem ausgewählten Objekt.

Der rechte Bereich zeigt an:

  • Die Details der Elemente, die bei Ihrer letzten Suche zurückgegeben wurden.

Die Details der Elemente richten sich nach dem Objekttyp, nach dem Sie suchen.

Sie können die Elemente in dem Suchergebnisbereich in auf- oder absteigender Reihenfolge sortieren, indem Sie auf den Spaltenkopf klicken. Es kann jeweils nur auf der Basis einer Spalte sortiert werden.

Anmerkungen

  • Wenn eine große Anzahl eines bestimmten zu suchenden Objekttyps vorhanden ist, kann es mehrere Minuten dauern, bis alle Elemente zurückgegeben wurden. Mithilfe von Suchkriterien können Sie die bei einer Suche zurückgegebenen Elemente verringern.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Server-Verbindungsoptionen.

Verwandte Themen

BizTalk-Messaging-Manager - Tastenkombinationen

Suchen nach Kanälen

Suchen von Verteilerlisten

Suchen nach Dokumentdefinitionen

Suchen nach Umschlägen

Suchen nach Messagingports

Suchen nach Organisationen


BizTalk-Messaging-Manager - Tastenkombinationen

Sie können Tastenkombinationen verwenden, um Aufgaben im BizTalk-Messaging-Manager auszuführen. Die folgende Tabelle ist eine kurze Referenz zu diesen Tastenkombinationen.

Anmerkung

  • Um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind, können Sie mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server- und Advanced Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Tastenkombination | Zweck
STRG+A | Alles markieren.
STRG+C | Text kopieren.
STRG+X | Text ausschneiden.
STRG+V | Text einfügen.
STRG+Z | Textaktion rückgängig machen.
STRG+R | Einen neuen Messagingport zu einer Organisation erstellen.
STRG+R | Einen neuen Messagingport zu einer Anwendung erstellen.
STRG+L | Einen neuen Kanal von einer Organisation erstellen.
STRG+UMSCHALT+L | Einen neuen Kanal von einer Anwendung erstellen.
STRG+T | Eine neue Verteilerliste erstellen.
STRG+D | Eine neue Dokumentdefinition erstellen.
STRG+G | Eine neue Organisation erstellen.
ENTF | Ausgewähltes Element oder ausgewählten Text löschen.
UMSCHALT+F10 | Kontextmenü für das ausgewählte Element anzeigen.
UMSCHALT mit beliebiger Pfeiltaste | Mehr als ein Element in einem Fenster auswählen oder Text markieren.
TAB | Durch Drücken von TAB in einem Dialogfeld wird der Fokus zwischen den Schaltflächen und Feldern im Dialogfeld verschoben.
UMSCHALT+TAB | Durch Drücken von TAB in einem Dialogfeld wird der Fokus zwischen den Schaltflächen und Feldern im Dialogfeld verschoben.
STRG+TAB | Zwischen den Registerkarten eines Dialogfeldes von vorn nach hinten umschalten.
STRG+UMSCHALT+TAB | Zwischen den Registerkarten eines Dialogfeldes von hinten nach vorn umschalten.
LEERTASTE | Aktivieren oder Deaktivieren eines Kontrollkästchens. Die Leertaste verhält sich darüber hinaus wie ein Mausklick, wenn der Fokus sich auf einer Schaltfläche befindet.
ALT+LEER | Systemmenü für das aktive Fenster anzeigen.
ALT+Unterstrichener Buchstabe in einem Menünamen | Entsprechendes Menü anzeigen.
Unterstrichener Buchstabe eines Befehlsnamens in einem geöffneten Menü | Entsprechenden Befehl ausführen.
ALT+NACH-UNTEN | Dropdownliste für ein aktiviertes Listenfeld anzeigen.
EINGABETASTE | Befehl für die aktive Option oder Schaltfläche ausführen.
ESC | Aktuellen Vorgang abbrechen.
F1 | Onlinehilfe anzeigen.
ALT+F4 | Aktives Fenster schließen oder aktives Programm beenden.
NACH-LINKS-TASTE | Fokus zur Registerkarte links verschieben.
NACH-RECHTS-TASTE | Fokus zur Registerkarte rechts verschieben.
Eine beliebige Pfeiltaste | Einen Ordner oder eine Datei im Hauptfenster eines Dialogfeldes markieren, während sich der Fokus in diesem Fenster befindet. Diese Funktion steht in den Dialogfeldern Dokumentspezifikation aus dem WebDAV-Repository auswählen, Eine Umschlagspezifikation aus dem WebDAV-Repository auswählen und Eine Zuordnung aus dem WebDAV-Repository auswählen zur Verfügung. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation, Auswählen einer Umschlagspezifikation und Auswählen einer Zuordnung.

Verwandtes Thema

BizTalk-Messaging-Manager - Benutzeroberfläche


Sicherheit

Zum Zugreifen auf bzw. Erstellen von Objekten mit dem BizTalk-Messaging-Manager müssen folgende Bedingungen erfüllt sein:

  • Sie müssen über ein Benutzerkonto in der Gruppe BizTalk Server-Administratoren verfügen, die während der Installation von BizTalk Server 2002 automatisch erstellt wird. Bei Bedarf können weitere Benutzer zu dieser Gruppe hinzugefügt werden. Weitere Informationen zum Hinzufügen eines Benutzerkontos finden Sie unter Hinzufügen von Benutzern zur Gruppe "BizTalk Server-Administratoren".

  • Sie müssen vollen Datenbankzugriff auf die BizTalk-Messaging-Verwaltungsdatenbank (InterchangeBTM) besitzen, d. h., Sie können sich anmelden, und Ihnen wurde die Datenbankrolle db_owner erteilt. Weitere Informationen finden Sie unter "Erteilen von Zugriff auf eine Datenbank für einen Windows-Benutzer oder eine Windows-Gruppe (Enterprise Manager)" in der Microsoft SQL Server-Dokumentation.


Grundlegendes zu Kanälen

Ein Kanal ist eine Gruppe von Eigenschaften, die Sie verwenden können, um die BizTalk-Messagingdienste für das Verarbeiten eines empfangenen Dokuments zu konfigurieren. Kanäle können für einen Messagingport oder eine Verteilerliste erstellt werden. Nachdem ein Kanal ein Dokument verarbeitet hat, wird das Dokument an das im zugeordneten Messagingport angegebene Ziel oder an die in der zugeordneten Verteilerliste angegebenen Messagingports transportiert. Für einen Messagingport oder eine Verteilerliste können Sie einen oder mehrere Kanäle erstellen.

In einem Kanal wird die Quelle der Dokumente angegeben. Dabei kann es sich um eine Quellorganisation oder um eine Quellanwendung handeln. Bevor Sie eine Anwendung als Quelle für einen Kanal zuweisen können, müssen Sie eine Anwendung für die eigene Organisation erstellen, die eine tatsächliche interne Anwendung in Ihrem Unternehmen darstellt. Sie können außerdem einen XLANG-Ablaufplan als Quelle für einen Kanal zuweisen. Ein XLANG-Ablaufplan kann mithilfe des BizTalk-Orchestrierungs-Designers erstellt werden. Weitere Informationen finden Sie unter Entwerfen von BizTalk-Orchestrierungen. Weitere Informationen zum Integrieren von BizTalk-Messagingdiensten und BizTalk-Orchestrierungsdiensten finden Sie unter Integrieren der BizTalk-Dienste.

Darüber hinaus kann eine offene Quelle explizit zum Kanal deklariert werden. Dies bedeutet, dass die Quelle entweder im Dokument oder beim Versenden des Dokuments in einem Parameter angegeben sein muss. Dies wird als offener Kanal bezeichnet. Weitere Informationen finden Sie unter Submitting.

Darüber hinaus kann eine eingehende Dokumentdefinition angegeben werden, die ein eingehendes Dokument von einer internen Anwendung oder der Organisation eines Handelspartners darstellt. Ferner wird eine ausgehende Dokumentdefinition angegeben, die ein Dokument darstellt, das an das angegebene Ziel übermittelt werden soll. Weitere Informationen zur Dokumentdefinitionen finden Sie unter Grundlegendes zu Dokumentdefinitionen.

Wenn das Format oder die Struktur eines ausgehenden Dokuments vom Format oder der Struktur des eingehenden Dokuments abweicht, müssen Sie eine Zuordnung für den Kanal angeben. Eine Zuordnung wandelt das Format oder die Struktur des ursprünglichen eingehenden Dokuments in das ausgehende Dokumentformat oder die ausgehende Dokumentstruktur um, die von der Zielorganisation oder -anwendung benötigt wird. Wenn beispielsweise Ihre Buchhaltungsanwendung Aufträge in einem FLATFILE-Format mit Trennzeichen generiert, Ihr Handelspartner aber erwartet, dass Aufträge im X12-Format vorliegen, können Sie eine Zuordnung verwenden, um das Dokumentformat umzuwandeln. Weitere Informationen zu Zuordnungen finden Sie unter Verwenden des BizTalk-Mappers.

Für einen Messagingport oder eine Verteilerliste können mehrere Kanäle erstellt werden, von denen jeder eine andere Konfiguration aufweist. Nehmen Sie z. B. an, dass Sie über zwei interne Buchhaltungsanwendungen verfügen, die Aufträge in verschiedenen Formaten generieren, und dass Sie mit einem Handelspartner zusammenarbeiten, der Aufträge von Ihnen in einem dritten Format zu erhalten wünscht. Sie können einen einzelnen Messagingport zum Handelspartner erstellen. Anschließend können Sie für diesen Messagingport einen Kanal von jeder der Anwendungen erstellen. Die ausgehende Dokumentdefinition wäre für beide Kanäle die gleiche, und sie würde mit dem Format Ihres Handelspartners übereinstimmen. Jedoch würde jeder der Kanäle über eine andere Zuordnung verfügen, um die von den Anwendungen eingehenden Dokumentformate umzuwandeln. Da Sie verschiedene Kanäle erstellen können, die mit einem einzelnen Messagingport verbunden sind, können Sie alle Aufträge im gleichen Format senden.

Darüber hinaus können Sie innerhalb eines Kanals weitere Eigenschaften festlegen, um die folgenden Aktionen auszuführen:

  • Zuweisen von Spezifikationsfeldern, um die eingehende Dokumentdefinition zu überwachen. Alle zugewiesenen Felder werden in einer Überwachungsdatenbank für jede verarbeitete Dokumentinstanz protokolliert, die diesen bestimmten Kanal verwendet, anstelle der globalen Überwachungsfelder, die in der Dokumentdefinition zugewiesen sind. Weitere Informationen zu globalen Überwachungsfeldern finden Sie unter Überwachen von Dokumentdatenfeldern.

  • Erstellen eines Kanalfilterausdrucks, der bestimmt, ob BizTalk Server 2002 den Kanal auf der Basis des Wertes eines Feldes oder mehrerer Felder im verarbeiteten Dokument aufruft.

  • Konfigurieren von Empfangsbestätigungen. Sie können vom Ziel eine Empfangsbestätigung für ein gesendetes Dokument anfordern, und Sie können eine Empfangsbestätigung für die Quelle eines empfangenen Dokuments generieren. Weitere Informationen zum Verarbeiten von Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  • Konfigurieren von Sicherheitseigenschaften. Sie können angeben, dass der Server Verschlüsselung und Signatur bei einem eingehenden Dokument überprüft oder ein ausgehendes Dokument digital signiert.

  • Angeben von Protokollierungsoptionen für Dokumente. Sowohl eingehende als auch ausgehende Dokumente können in ihren ursprünglichen Formaten, im temporären XML-Format oder in beiden Formaten gespeichert werden.

  • Konfigurieren erweiterter Eigenschaften. Sie können für Dokumente in EDI-Formaten eine Gruppenkontrollnummer angeben, Zahl und Zeitintervall festlegen, die der Server zum erneuten Senden von Dokumenten verwendet, und die Transportkomponente und Umschlageigenschaften für den Messagingport oder die Verteilerliste außer Kraft setzen.

Darüber hinaus können Sie mithilfe des BizTalk-Messaging-Managers Empfangskanäle erstellen. Ein Empfangskanal ist ein besonderer Kanaltyp, der zum Senden einer Empfangsbestätigung an den Absender eines von den BizTalk-Messagingdiensten empfangenen Dokuments verwendet wird. Beim Erstellen eines Kanals zur Verarbeitung eines eingehenden Dokuments, für das eine Empfangsbestätigung angefordert ist, können Sie den Empfangskanal angeben, den der Server zum Verarbeiten der Empfangsbestätigung verwenden soll. Aus diesem Grund sollten Sie einen Messagingport und einen diesem zugeordneten Empfangskanal erstellen, bevor Sie einen Messagingport und einen Kanal zur Verarbeitung eines Dokuments erstellen, für das eine Empfangsbestätigung angefordert ist. Weitere Informationen zum Verarbeiten von Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Vorsicht

  • Beim Erstellen eines Empfangskanals ist sowohl die eingehende als auch die ausgehende Dokumentdefinition standardmäßig auf die BizTalk-Standardempfangsbestätigung festgelegt, und sie kann nicht mithilfe einer Zuordnung umgewandelt werden. Um für eine ausgehende Empfangsbestätigung ein anderes Format zu verwenden, müssen Sie eine eingehende Dokumentdefinition erstellen und auswählen, die auf die Standardempfangsbestätigungs-Spezifikation im WebDAV-Repository verweist. Darüber hinaus müssen Sie eine ausgehende Dokumentdefinition erstellen, die auf eine Spezifikation mit dem gewünschten Format für die ausgehende Empfangsbestätigung verweist, sowie eine Zuordnung, die das Format der Empfangsbestätigung umwandelt.

Wenn BizTalk Server 2002 ein Dokument empfängt, sucht das Programm den entsprechenden Kanal, der den Server anweist, wie das Dokument verarbeitet werden soll. Anschließend sucht der Server den Messagingport oder die Verteilerliste, der/die dem Kanal zugeordnet ist. Der Messagingport führt den Server durch die Abfolge von Schritten, die erforderlich sind, um das Dokument an das angegebene Ziel zu transportieren. Wenn der Kanal einer Verteilerliste zugeordnet ist, verwendet der Server die Eigenschaften jedes einzelnen Messagingports in der Verteilerliste, um das Dokument an die angegebenen Ziele zu transportieren.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Kanalelemente

  • Gültige Kombinationen aus Kanal und Messagingport


Kanalelemente

Kanäle bestehen aus den folgenden Elementen:

Quellorganisation oder -anwendung

Beim Erstellen eines Kanals weisen Sie entweder eine Anwendung oder eine Organisation als Quelle für Dokumente zu. Eine Quellanwendung stellt immer eine Geschäftsanwendung Ihrer eigenen Organisation dar. Dabei kann es sich um eine Buchhaltungsanwendung, ein Auftragserfassungssystem oder eine LOB-Anwendung (Line-of-Business Application, Geschäftsbereichsanwendung) handeln. Darüber hinaus können Sie einen XLANG-Ablaufplan als Quelle für Dokumente zuweisen. Ein XLANG-Ablaufplan kann mithilfe des BizTalk-Orchestrierungs-Designers erstellt werden. Eine Quellorganisation stellt immer einen externen Handelspartner dar.

Ein Kanal wird immer für einen Messagingport oder eine Verteilerliste erstellt. Das Ziel für die Dokumente, die Sie von der Quelle eines Kanals empfangen, ist im Messagingport oder in den in der Verteilerliste aufgeführten Messagingports zugewiesen, für den/die der Kanal erstellt wird.

Eingehende und ausgehende Dokumentdefinitionen

Dokumentdefinitionen in einem Kanal stellen die eingehenden und ausgehenden Dokumente dar, die von BizTalk Server 2002 verarbeitet werden. Eine Dokumentdefinition stellt einen Zeiger auf eine Spezifikation bereit, die das Dokument definiert. Die Spezifikation definiert Merkmale wie die Dokumentstruktur, den Dokumenttyp und die Version. Weitere Informationen finden Sie unter Grundlegendes zu Dokumentdefinitionen.

Wenn BizTalk Server 2002 ein Dokument empfängt, sucht das Programm den entsprechenden Kanal, um es zu verarbeiten. Der Server verwendet die Spezifikation der eingehenden Dokumentdefinition, um das eingehende Dokument in ein temporäres XML-Format zu übersetzen. Bei Bedarf ordnet der Server Format und Struktur des eingehenden Dokuments dem Format und der Struktur des ausgehenden Dokuments zu. Anschließend verwendet der Server die Spezifikation des ausgehenden Dokuments, um das ausgehende Dokument in das Format und die Struktur zu übersetzen, die von der Zielanwendung oder -organisation erkannt und verwendet werden können.

Zuordnen von Datenformaten

Format oder Struktur eines eingehenden Dokuments können von dem Format oder der Struktur abweichen, die für das ausgehende Dokument erforderlich sind. In diesem Fall kann eine Zuordnung verwendet werden, um das Format des eingehenden Dokuments in das Format des ausgehenden Dokuments umzuwandeln.

Wenn Sie z. B. über eine Buchhaltungsanwendung verfügen, die Rechnungen in einem FLATFILE-Format mit Kommas als Trennzeichen generiert, Ihr Handelspartner Rechnungen jedoch im X12-Format benötigt, können Sie eine Zuordnung im Kanal verwenden, um das Format umzuwandeln.

Eine Zuordnung kann darüber hinaus Inhalt und Struktur eines Dokuments umwandeln, das im gleichen Format vorliegt. Weitere Informationen finden Sie unter Verwenden des BizTalk-Mappers.

Überwachungs- und Filterungseigenschaften

Sie können für die eingehende Dokumentdefinition eines Kanals Spezifikationsfelder zuweisen, die in einer Überwachungsdatenbank protokolliert werden sollen. Die Spezifikationsfelder, die Sie in einem Kanal zuweisen, werden für jede mithilfe dieses Kanals verarbeitete Instanz eines Dokuments in einer Überwachungsdatenbank protokolliert. Diese Felder werden anstelle der globalen Überwachungsfelder protokolliert, die in der eingehenden Dokumentdefinition zugewiesen werden. Alle für die ausgehende Dokumentdefinition zugewiesenen globalen Überwachungsfelder werden ignoriert. Weitere Informationen finden Sie unter Überwachen von Dokumentdatenfeldern.

Ein Kanalfilterausdruck stellt eine weitere Möglichkeit bereit, zu ermitteln, welche Kanäle aufgerufen werden, wenn BizTalk Server 2002 ein Dokument empfängt. Für einen Kanalfilterausdruck erfolgt diese Ermittlung auf der Basis des Wertes eines angegebenen Feldes oder angegebener Felder in der Dokumentinstanz.

Wenn der Server ein Dokument verarbeitet, wird der Wert jedes der angegebenen Felder anhand des Wertes für den Kanalfilterausdruck ausgewertet. Wenn der Ausdruck sich als wahr (TRUE) erweist, wird der Kanal aufgerufen. Ist der Ausdruck falsch (FALSE), wird der Kanal nicht aufgerufen. Wenn beispielsweise der Kanalfilterausdruck erstellt wird, um nach einer Auftragssumme größer als 1.000 zu suchen, und das Summenfeld des Auftrags im Dokument den Wert 1.500 aufweist, wird der Kanal aufgerufen.

Eigenschaften der Dokumentprotokollierung

BizTalk Server 2002 übersetzt nicht auf XML-basierende eingehende Dokumente aus ihrem ursprünglichen systemeigenen Format für die Verarbeitung in ein temporäres Unicode-XML-Format. BizTalk Server 2002 übersetzt ausgehende Dokumente aus einem temporären Unicode-XML-Format in das für das angegebene Ziel erforderliche Format. Sie können auswählen, ob die Daten jedes eingehenden oder ausgehenden Dokuments entweder in einem von beiden oder in beiden Formaten gespeichert werden sollen.

Verwandte Themen

Erstellen und Verwalten von Kanälen

Grundlegendes zu Kanälen

Gültige Kombinationen aus Kanal und Messagingport


Gültige Kombinationen aus Kanal und Messagingport

Es können nur bestimmte Kombinationen aus Kanal (Quelle) und Messagingport (Ziel) erstellt werden, die für die Verwendung mit Microsoft BizTalk Server 2002 gültig sind.

Die folgenden gültigen Geschäftsszenarien zeigen auf, wie Messagingports mit den richtigen Zielzuweisungen und Kanäle mit den richtigen Quellzuweisungen konfiguriert werden, um Daten korrekt weiterzuleiten.

Szenario 1: Handelspartner zu einer internen Anwendung

In diesem Szenario erstellen Sie einen Messagingport mit einer Anwendung der eigenen Organisation als Ziel. Anschließend erstellen Sie für diesen Messagingport einen Kanal mit dem Handelspartner als Quelle.

Szenario 2: Interne Anwendung zu Handelspartner

In diesem Szenario erstellen Sie einen Messagingport mit der Organisation eines Handelspartners als Ziel. Anschließend erstellen Sie einen Kanal für diesen Messagingport mit einer Anwendung der eigenen Organisation als Quelle.

Szenario 3: Interne Anwendung zu interner Anwendung

In diesem Szenario erstellen Sie einen Messagingport mit einer Anwendung der eigenen Organisation als Ziel. Anschließend erstellen Sie einen Kanal für diesen Messagingport mit einer anderen Anwendung der eigenen Organisation als Quelle.

Szenario 4: Interne Anwendung zu Verteilerliste

In diesem Szenario erstellen Sie eine Verteilerliste, die eine Gruppe von vorhandenen Messagingports zu Organisationen oder Anwendungen umfasst. Anschließend erstellen Sie einen Kanal für diese Verteilerliste mit einer Anwendung der eigenen Organisation als Quelle.

Szenario 5: Interne Anwendung zu offenem Ziel

In diesem Szenario erstellen Sie einen Messagingport, den Sie als einen offenen Messagingport angeben. Anschließend erstellen Sie einen Kanal für diesen Messagingport mit einer Anwendung der eigenen Organisation als Quelle.

Szenario 6: Offene Quelle zu interner Anwendung

In diesem Szenario erstellen Sie einen Messagingport mit einer Anwendung der eigenen Organisation als Ziel. Anschließend erstellen Sie einen Kanal für diesen Messagingport, den Sie als einen offenen Kanal angeben.

Anmerkung

  • Ein Kanal, der als offener Kanal angegeben ist, kann nicht für einen Messagingport erstellt werden, der als offener Messagingport angegeben ist.

Szenario 7: Handelspartner über Zwischenstation zu Handelspartner

In diesem Szenario sendet ein Handelspartner Dokumente über den Computer mit BizTalk Server an einen anderen Handelspartner, wobei Ihr Unternehmen als Zwischenstation dient. Sie erstellen einen Messagingport mit der Organisation des einen Handelspartners als Ziel. Anschließend erstellen Sie einen Kanal für diesen Messagingport mit einem anderen Handelspartner als Quelle.

Verwandte Themen

Kanalelemente

Grundlegendes zu Kanälen


Grundlegendes zu Messagingports

Ein Messagingport ist eine Gruppe von Eigenschaften, die Sie verwenden können, um die BizTalk-Messagingdienste für das Transportieren von Dokumenten an ein angegebenes Ziel mithilfe eines angegebenen Transportdienstes zu konfigurieren. Die Dokumente, die ein Messagingport transportiert, stammen aus der Quelle, die Sie in einem zugeordneten Kanal angeben. Es können mehrere Kanäle für einen Messagingport erstellt werden, um Dokumente aus vielen Quellen an das gleiche Ziel zu senden.

Ein Messagingport kann so konfiguriert werden, dass er Dokumente an eine zugewiesene Zielorganisation, einen XLANG-Ablaufplan oder eine Zielanwendung sendet.

Wenn Sie einen Messagingport zu einer Organisation konfigurieren, können Sie entweder einen bestimmten Handelspartner als Ziel zuweisen oder ein offenes Ziel deklarieren. Dies wird als offener Messagingport bezeichnet. Ein offener Messagingport kann nur verwendet werden, um Dokumente an Organisationen von Handelspartnern zu transportieren. Die Informationen zur Zielorganisation für einen offenen Messagingport müssen entweder im Dokument oder in einem Parameter beim Versenden des Dokuments an BizTalk Server 2002 angegeben werden. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting. Weitere Informationen zu offenen Messagingports finden Sie unter Offenheitsgrad.

Wenn es sich bei der für einen offenen Messagingport angegebenen Adresse um eine SMTP-Adresse handelt, muss der Server über eine Absenderadresse für die eigene Organisation verfügen. Um diese Adresse abzurufen, verwendet der Server den Wert, der für ein besonderes Organisationskennzeichen der eigenen Organisation angegeben ist und als SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung bezeichnet wird. Weitere Informationen zum Konfigurieren dieses Organisationskennzeichens finden Sie unter Konfigurieren der eigenen Organisation.

Wenn Sie einen Messagingport zu einer Anwendung konfigurieren, können Sie entweder einen XLANG-Ablaufplan oder eine Anwendung der eigenen Organisation als Ziel zuweisen. Weitere Informationen zur eigenen Organisation finden Sie unter Grundlegendes zu Organisationen.

Ein Messagingport zu einem XLANG-Ablaufplan kann so konfiguriert werden, dass er eine neue Instanz eines angegebenen XLANG-Ablaufplanes aktiviert und das Dokument anschließend an einen angegebenen Messagingport dieses Ablaufplanes übermittelt. In diesem Fall muss der angegebene Ablaufplan einen Messagingport enthalten, der an die BizTalk-Messagingdienste gebunden ist. Bei der Angabe des Ablaufplanes wird auch der Messagingport benannt. Ferner können Sie einen Messagingport so konfigurieren, dass ein Dokument an eine aktuell ausgeführte Instanz eines XLANG-Ablaufplanes übermittelt wird. In diesem Fall muss das Dokument den Namen einer Warteschlange enthalten, an die das Dokument übermittelt werden soll und die vom Zielablaufplan überwacht wird. Weitere Informationen zum Integrieren von BizTalk-Messagingdiensten und BizTalk-Orchestrierungsdiensten finden Sie unter Integrieren der BizTalk-Dienste.

Mit den Messagingporteigenschaften werden außerdem eine bestimmte Adresse, an die Dokumente übermittelt werden, und der Transporttyp angegeben, mit dem Dokumente an dieses Ziel transportiert werden. Außerdem wird angegeben, wie Dokumente vor dem Transport gesichert und mit welchem Umschlag sie codiert werden.

Wenn BizTalk Server 2002 ein Dokument empfängt, sucht das Programm den entsprechenden Kanal, um es zu verarbeiten. Nach dem Verarbeiten des Dokuments verweist der Kanal den Server an den ihm zugeordneten Messagingport oder die ihm zugeordnete Verteilerliste, der/die den Server durch die Abfolge der erforderlichen Schritte führt, um das Dokument mit einem Umschlag zu codieren, es zu sichern und an das angegebene Ziel zu transportieren.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Messagingportelemente

  • Offene Messagingports


Messagingportelemente

Messagingports bestehen aus den folgenden Elementen:

Ziel

Das Ziel eines Messagingports kann die Organisation eines Handelspartners, ein XLANG-Ablaufplan oder eine Anwendung der eigenen Organisation sein.

Ein Messagingport zu einer Organisation kann explizit die Zielorganisation zuweisen oder alternativ als offener Messagingport deklariert sein. Bei offenen Messagingports wird die Zielorganisation zu dem Zeitpunkt ermittelt, an dem der Messagingport ein Dokument verarbeitet. Die Informationen zur Zielorganisation müssen entweder im Dokument angegeben sein oder beim Versenden des Dokuments in Parametern. Weitere Informationen finden Sie unter Submitting.

Ein Messagingport zu einem XLANG-Ablaufplan kann auf zwei Weisen konfiguriert werden. Sie können einen Messagingport so konfigurieren, dass eine neue Instanz eines XLANG-Ablaufplanes aktiviert wird, indem Sie den Pfad zu einem XLANG-Ablaufplan angeben. Wenn der Messagingport ein Dokument verarbeitet, aktiviert er diesen Ablaufplan und übermittelt das Dokument anschließend an einen Messagingport in diesem Ablaufplan, den Sie außerdem in den Eigenschaften des Messagingports angeben. Alternativ können Sie den Messagingport so konfigurieren, dass Dokumente an einen aktiven XLANG-Ablaufplan übermittelt werden. Diese Option kann nur verwendet werden, wenn Sie einem Handelspartner eine Nachricht senden und der Handelspartner eine Nachricht mithilfe eines HTTP-Transports an eine besonders konfigurierte ASP-Seite zurücksendet. Weitere Informationen finden Sie unter Integrieren der BizTalk-Dienste. Ein XLANG-Ablaufplan kann mithilfe des BizTalk-Orchestrierungs-Designers erstellt werden. Weitere Informationen finden Sie unter Entwerfen von BizTalk-Orchestrierungen.

Ein Messagingport kann außerdem Dokumente an eine Zielanwendung der eigenen Organisation transportieren. Bevor Sie eine Anwendung als Ziel eines Messagingports bestimmen können, müssen Sie die Anwendung zur eigenen Organisation hinzufügen. Weitere Informationen finden Sie unter Hinzufügen von Anwendungen.

Transporteigenschaften

Die für einen Messagingport angegebenen Transporteigenschaften bestimmen den Transportdienst, der zur Beförderung von Dokumenten an die Zielorganisation oder Zielanwendung verwendet wird, und die spezielle Adresse, an die die Dokumente gesendet werden.

Die Transporteigenschaften, die Sie für einen Messagingport festlegen, werden auf alle diesem Messagingport zugeordneten Kanäle angewendet. Nachdem BizTalk Server 2002 zum Verarbeiten eines Dokuments einen Kanal aufruft, bezieht sich der Server auf die Eigenschaften des Messagingports, der dem Kanal zugeordnet ist. Der Server sendet die Dokumente an die im Messagingport angegebene Adresse und verwendet dazu den im Messagingport angegebenen Transporttyp.

Darüber hinaus können Sie ein Dienstfenster angeben, das einen bestimmten Zeitraum zuweist, innerhalb dessen Dokumente transportiert werden können. Die Stunden des Dienstfensters werden im UTC-Format angezeigt und entsprechen der Zeit auf dem Server.

Umschlaginformationen

Umschläge sind Kopf- und gelegentlich Fußzeilen, die den transportierten Dokumenten voranstehen oder diese einkapseln. Eine Umschlagkopfzeile enthält Informationen zu den im Umschlag enthaltenen Dokumenten sowie Informationen zum Weiterleiten dieser Dokumente. Eine Umschlagkopfzeile enthält das Quellorganisationskennzeichen, das Zielorganisationskennzeichen und Informationen zum Typ der enthaltenen Dokumente.

BizTalk Server 2002 kann Austauschvorgänge empfangen und verarbeiten, die mehrere Dokumente und Gruppen von Dokumenten enthalten. Beim Transportieren von Dokumenten, die einen Umschlag verwenden, verwendet BizTalk Server für jedes Dokument einen eigenen Austauschvorgang.

Umschläge sind optional; wenn Sie jedoch die Verwendung eines Umschlags wählen, muss das Format des in einem Messagingport angegebenen Umschlags mit dem Format des enthaltenen Dokuments oder der enthaltenen Dokumente übereinstimmen. Das Dokumentformat wird durch die Spezifikation bestimmt, auf die die ausgehende Dokumentdefinition eines zugeordneten Kanals verweist. Wenn Sie beispielsweise einen Umschlag mit einem X12-Format für einen Messagingport auswählen, müssen Sie eine Dokumentdefinition für ausgehende Dokumente für den Kanal auswählen, die auf eine X12-Spezifikation zeigt. Wenn Sie umgekehrt eine ausgehende Dokumentdefinition in einem Kanal auswählen, muss der Messagingport, dem der Kanal zugeordnet ist, über einen Umschlag im entsprechenden Format verfügen. Wenn Sie z. B. eine ausgehende Dokumentdefinition auswählen, die über eine Spezifikation mit einem X12-Format verfügt, sollten Sie im Messagingport einen X12-Umschlag angeben.

Sicherheitseigenschaften

Die Sicherheitseigenschaften, die Sie einem Messagingport zuweisen, werden auf alle diesem Messagingport zugeordneten Kanäle angewendet. Wenn Sie z. B. S/MIME-Verschlüsselung (Secure Multipurpose Internet Mail Extensions) für einen Messagingport zuweisen, werden alle Dokumente, die von diesem Messagingport zugeordneten Kanälen verarbeitet werden, mit dem angegebenen Verschlüsselungsverfahren verschlüsselt.

Wenn Sie über Dokumente verfügen, die mithilfe eines anderen Verschlüsselungsverfahrens gesichert werden müssen oder keine Verschlüsselung benötigen, müssen Sie einen getrennten Messagingport mit den entsprechenden Sicherheitseigenschaften für diese Dokumente erstellen.

BizTalk Server 2002 unterstützt MIME-Codierung (Multipurpose Internet Mail Extensions)

Der MIME-Nachrichtenformatstandard gibt an, wie Nachrichten formatiert werden müssen, damit Clientprogramme komplexe Textkörper decodieren und anzeigen können, die RTF, mehrere Zeichensätze und binäre Anlagen, wie z. B. Grafiken, Klänge und Kalkulationstabellen, enthalten. MIME ist eine umfassendere und flexiblere Technologie als UUEncode und stellt allgemeine und flexible Mechanismen für das Aufnehmen von Inhalten in Nachrichten bereit. Mit MIME-Formatierung können Sie Folgendes durchführen:

  • Angeben alternativer Mechanismen der Inhaltscodierung für jeden Teil des Textkörpers.

  • Zusammenfassen von Gruppen aus mehreren Inhaltsteilen innerhalb einer Nachricht.

  • Verwenden anderer Zeichensätze als den US-ASCII-Zeichensatz in Textkörperteilen und Nachrichten-Kopfzeilenfeldern.

  • Angeben der beabsichtigten Anordnung eines Inhaltsteils (z. B. im Textfluss oder als Anlage).

BizTalk Server 2002 unterstützt die auf Zertifikaten basierende S/MIME-Verschlüsselung mit öffentlichen Schlüsseln

Verschlüsselung kann auf Geschäftsdaten angewendet werden, die Sie Ihren Handelspartnern übermitteln. Mithilfe eines Verschlüsselungszertifikats zum Sichern der Daten können Sie sicherstellen, dass nur der beabsichtigte Empfänger auf die Informationen zugreifen kann.

Um Geschäftsdaten zu verschlüsseln, muss die Quellorganisation über ein Exemplar des öffentlichen Schlüssels für das Verschlüsselungszertifikat der Zielorganisation verfügen. Die Quellorganisation verwendet diesen öffentlichen Schlüssel, um die Geschäftsdaten zu verschlüsseln, und leitet anschließend die verschlüsselten Daten an die Zielorganisation weiter. Die Zielorganisation kann dann den privaten Schlüssel ihres Verschlüsselungszertifikats verwenden, um die Geschäftsdaten zu entschlüsseln.

Für einen offenen Messagingport sind die Sicherheitseigenschaften, die die Verschlüsselung betreffen, deaktiviert, weil die Zielorganisation unbekannt ist.

BizTalk Server 2002 unterstützt die auf Zertifikaten basierende digitale Signatur mit öffentlichen Schlüsseln nach S/MIME-Standard

Weitere Informationen zu Zertifikaten finden Sie unter Grundlegendes zu Zertifikaten.

Digitale Signaturen können verwendet werden, um die Authentizität der Datenquelle sicherzustellen, um sicherzustellen, dass die Daten nicht geändert wurden, und um zu verhindern, dass die Datenquelle die Nachricht zurückweist.

Ein Signaturzertifikat wird verwendet, um digitale Signaturen zu erstellen, die die Echtheit von Daten bezeugen. Das Signieren von Daten ändert diese nicht, sondern generiert eine digitale Signaturzeichenfolge, die entweder mit den Daten gebündelt oder separat übertragen wird.

Zum digitalen Signieren eines Dokuments werden die Daten verarbeitet, um einen Nachrichtenhash zu erstellen. Hierbei handelt es sich um eine komprimierte Zeichenfolge, die aus einer Nachricht abgeleitet wurde. Anschließend wird der private Schlüssel der Quellorganisation verwendet, um den Nachrichtenhash zu verschlüsseln und die digitale Signatur zu bilden. Die Daten werden zusammen mit der digitalen Signatur an den Empfänger übertragen.

Der Empfänger muss über ein Exemplar des öffentlichen Schlüssels des Signaturzertifikats des Absenders verfügen, um eine digitale Signatur zu überprüfen. Der Empfänger entschlüsselt den Hash anhand der gesendeten digitalen Signatur und berechnet anschließend unabhängig einen Nachrichtenhash. Die Ergebnisse der beiden Hashs werden verglichen. Wenn sie identisch sind, wurden die Informationen nicht manipuliert.

Anmerkungen

  • Wenn Sie MIME-codierte Daten unter Verwendung von SMTP senden, enthält der Textkörper der Ausgabenachricht einen vom System generierten Dateinamen, und die Daten werden als Anlage angezeigt.

  • Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen und Verwalten von Messagingports

Offene Messagingports

Grundlegendes zu Messagingports


Offene Messagingports

Ein offener Messagingport ist ein Messagingport zu einer Organisation, für den nicht explizit eine bestimmte Zielorganisation deklariert wurde. Ein offener Messagingport kann keine Anwendung als Ziel haben.

Bei einem offenen Messagingport müssen die Ziel- und Transportinformationen entweder im Dokument oder beim Versenden des Dokuments an Microsoft BizTalk Server 2002 in Parametern bereitgestellt werden. Wenn Versendungsparameter verwendet werden, setzen diese die im Dokument enthaltenen Ziel- und Transportinformationen außer Kraft. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

Wenn Sie einen Kanal für einen offenen Messagingport erstellen und die Zielinformationen im Dokument bereitgestellt werden, muss die eingehende Dokumentdefinition für diesen Kanal auf eine Spezifikation verweisen, die korrekt konfiguriert ist. Weitere Informationen zum Konfigurieren einer Dokumentspezifikation zur Verarbeitung von Dokumenten für einen offenen Messagingport finden Sie unter Festlegen von Wörterbucheigenschaften.

Für einen offenen Messagingport sind die Verschlüsselung betreffenden Sicherheitseigenschaften deaktiviert, weil die Zielorganisation unbekannt ist. Zum Festlegen der Verschlüsselungseigenschaften muss ein Zertifikat einer bestimmten, bekannten Zielorganisation angegeben werden. Ein Verschlüsselungszertifikat wird verwendet, um Dokumente zu verschlüsseln, die an die bestimmte Zielorganisation transportiert werden.

Sie können einen offenen Messagingport verwenden, um standardisierte Dokumente an viele verschiedene Organisationen von aktuellen oder zukünftigen Handelspartnern zu senden, ohne für jedes Ziel einen Messagingport zu erstellen. Alle Dokumente haben die Umschlag-, Sicherheits- und Transporteigenschaften gemein, die im Messagingport eingerichtet sind.

Ein offener Messagingport unterscheidet sich in den folgenden Punkten von einer Verteilerliste:

  • Bei einem offenen Messagingport führt jedes Dokument von einem Kanal zur Übermittlung nur eines Dokuments an nur ein Ziel. Bei einer Verteilerliste kann jedes Dokument von einem Kanal die Übermittlung des Dokuments an mehrere Ziele zur Folge haben.

  • Bei einem offenen Messagingport müssen die Eigenschaften des Messagingports nicht geändert werden, um Informationen an die Organisation eines anderen Handelspartners zu senden. Bei einer Verteilerliste müssen Sie einen Messagingport hinzufügen, um Informationen an die Organisation eines anderen Handelspartners zu senden.

Wichtig

  • Wenn Sie einen Messagingport als offenen Messagingport deklarieren, sollten Sie keine Kanäle für den Messagingport erstellen, die über eine ausgehende Dokumentdefinition mit einer X12- oder EDIFACT-Spezifikation verfügen. Um einen X12- oder EDIFACT-Umschlag zu generieren, muss der Server über Organisationskennzeichen für Ziel und Quelle verfügen. Ein offener Messagingport gibt kein Zielorganisationskennzeichen an. Darüber hinaus muss in den Dokumenten für einen offenen Messagingport die Zieladresse innerhalb des Dokuments enthalten sein, X12- und EDIFACT-Dokumente enthalten diese Informationen jedoch nicht.

Verwandte Themen

Erstellen und Verwalten von Messagingports

Messagingportelemente

Grundlegendes zu Messagingports


Grundlegendes zu Organisationen

Die Organisationen, die Sie mithilfe des BizTalk-Messaging-Managers erstellen, stellen die Handelspartner dar, mit denen Sie Dokumente austauschen. Ein bestimmter Organisationstyp, die eigene Organisation, stellt Ihr Unternehmen dar.

Eigene Organisation

Der BizTalk-Messaging-Manager erstellt die eigene Organisation automatisch. Sie können die eigene Organisation beim Konfigurieren umbenennen, um sie leichter als Ihr Unternehmen kenntlich zu machen. Es gibt nur eine eigene Organisation, und sie kann nicht gelöscht werden.

Die eigene Organisation kann nicht als Quelle oder Ziel für Dokumente in einem Messagingport oder einem Kanal zugewiesen werden. Nur Anwendungen der eigenen Organisation können als Quelle oder Ziel für Dokumente innerhalb Ihres Unternehmens zugewiesen werden. Beispielsweise können Sie einen Messagingport erstellen, der die Organisation eines Handelspartners als Ziel für von Ihrem Unternehmen gesendete Dokumente zuweist. Anschließend, beim Erstellen eines Kanals für diesen Messagingport, weisen Sie nicht Ihre eigene Organisation als Quelle zu, sondern vielmehr eine bestimmte interne Anwendung in Ihrem Unternehmen, aus der die Dokumente stammen. Sie können außerdem eine Anwendung der eigenen Organisation als Quelle für Dokumente in einem Kanal zuweisen und eine andere Anwendung als Ziel in einem Messagingport.

Anwendungen der eigenen Organisation

Die zur eigenen Organisation hinzugefügten Anwendungen erlauben Ihnen, den Dokumentenfluss zwischen Microsoft BizTalk Server 2002 und den tatsächlichen internen Anwendungen in Ihrem Unternehmen zu identifizieren und überwachen. Das einfache Erstellen und Zuweisen einer Anwendung als Quelle oder Ziel im BizTalk-Messaging-Manager steuert oder aktiviert den Ablauf von Dokumenten zu oder von einer tatsächlichen internen Anwendung jedoch nicht. Um eine interne Anwendung in BizTalk Server 2002 zu integrieren und den Dokumentenfluss zu oder von der Anwendung zu steuern, müssen Sie den Server weiter konfigurieren.

Es gibt mehrere Möglichkeiten, um Dokumente von einer Ursprungsanwendung zu BizTalk Server zu transportieren. Die erforderliche Konfiguration, um eine Anwendung für den Transport von Dokumenten an den Server zu integrieren, erfolgt vollständig außerhalb des BizTalk-Messaging-Managers. Weitere Informationen finden Sie unter Submitting.

Die Dokumentübermittlung von BizTalk Server zu einer internen Anwendung kann Konfigurationen sowohl innerhalb als auch außerhalb des BizTalk-Messaging-Managers erfordern. Der in einem Messagingport angegebene Transporttyp und die angegebene Adresse können einen bestimmten Speicherort bestimmen, an den Dokumente übermittelt werden. Eine Anwendung oder eine separate Komponente muss dann konfiguriert werden, um an diesem Speicherort empfangene Dokumente für die Zielanwendung abzurufen. Alternativ können Sie in den Transporteigenschaften eines Messagingports eine Anwendungsintegrationskomponente angeben, die Dokumente direkt an eine Anwendung übermitteln kann. Weiter Informationen finden Sie unter Grundlegendes zu Messagingports.

Organisationen von Handelspartnern

Alle anderen Organisationen, die Sie mit dem BizTalk-Messaging-Manager erstellen, stellen externe Handelspartner oder Unternehmenseinheiten eines Handelspartners dar. Es kann eine beliebige Anzahl von Organisationen erstellt werden. Sie können die Organisation eines Handelspartners entweder als Quelle von Dokumenten in einem Kanal oder als Ziel für Dokumente in einem Messagingport zuweisen.

Ferner können Sie einen Handelspartner als Quelle von Dokumenten in einem Kanal und einen anderen als Ziel der Dokumente in einem Messagingport zuweisen. In diesem Fall dient Ihr Unternehmen als unabhängige Zwischenstation zwischen den beiden Handelspartnern.

Wie auch bei Anwendungen aktiviert das einfache Erstellen einer Organisation und das anschließende Zuweisen als Quelle oder Ziel im BizTalk-Messaging-Manager nicht den Dokumentenfluss zu oder von dieser Organisation. Sie müssen den Server weiter konfigurieren, um den Dokumentenfluss zwischen Ihren Partnerorganisationen und BizTalk Server 2002 zu steuern und zu lenken.

Es gibt verschiedene Methoden, mit denen ein externer Handelspartner als Quellorganisation Dokumente zu BizTalk Server transportieren kann. Die hierfür erforderliche Konfiguration ähnelt der für die Integration von Anwendungen für den Transport von Dokumenten zum Server und erfolgt ebenfalls vollständig außerhalb des BizTalk-Messaging-Managers. Weitere Informationen finden Sie unter Submitting.

Das Übermitteln von Dokumenten von BizTalk Server an einen externen Handelspartner als Zielorganisation kann Konfigurationen sowohl innerhalb als auch außerhalb des BizTalk-Messaging-Managers erfordern. Transporttyp und Adresse, die in einem Messagingport angegeben werden, ermitteln einen bestimmten Speicherort, an den Dokumente übermittelt werden. Die Zielorganisation, die über Zugriff auf diesen Speicherort verfügen muss, kann anschließend ihren eigenen BizTalk Server, eine ihrer internen Anwendungen oder eine separate Komponente für die Verarbeitung der an diesem Speicherort empfangenen Dokumente konfigurieren. Weitere Informationen zum Konfigurieren von Messagingports finden Sie unter Grundlegendes zu Messagingports.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Organisationskennzeichen


Organisationskennzeichen

Microsoft BizTalk Server 2002 und andere Handelspartner verwenden Organisationskennzeichen, um Organisationen eindeutig zu identifizieren. Eine Organisation kann über mehr als ein Organisationskennzeichen verfügen; jedes Kennzeichen muss jedoch für diese Organisation eindeutig sein. Beispielsweise können eine Telefonnummer, ein URL oder eine DUNS-Nummer (Data Universal Numbering System) eine Organisation eindeutig identifizieren, aber es können nicht zwei Organisationen die gleiche Telefonnummer als Organisationskennzeichen verwenden.

Ein Organisationskennzeichen besteht aus drei getrennten Elementen: einem Namen, einem Qualifizierer und einem Wert. Beispielsweise kann ein Unternehmen eine Telefonnummer verwenden, um sich eindeutig zu identifizieren. In diesem Beispiel ist der Name des Kennzeichens Telefonnummer, der Qualifizierer, der das Kennzeichen als Telefonnummer identifiziert, ist die Zahl 12, und der Wert der tatsächlichen Telefonnummer ist (801-555-1079). Der Name jedes Organisationskennzeichens besitzt einen eindeutigen Qualifizierer, der anstelle des Namens verwendet wird, um den Typ des Kennzeichens anzugeben. Beispielsweise ist der Standardqualifizierer für ein Telefonnummerkennzeichen 12. Wenn BizTalk Server 2002 Dokumente verarbeitet, werden nur der Qualifizierer und der Wert verwendet, um Organisationen zu identifizieren.

Jede Organisation muss mindestens über ein Kennzeichen verfügen. Wenn Sie eine Organisation erstellen, erstellt der BizTalk-Messaging-Manager ein Kennzeichen mit dem Namen Organisation. Der Qualifizierer für dieses Kennzeichen ist Organisationsname, und der Wert ist der Name, den Sie der Organisation geben. Dieses Kennzeichen wird auch als Standardkennzeichen festgelegt; es wird also verwendet, wenn kein anderes Kennzeichen angegeben wird. Sie können weitere Kennzeichen erstellen und jedes beliebige Kennzeichen als Standardkennzeichen zuweisen. Das Kennzeichen Organisationsname oder das zugewiesene Standardkennzeichen können nicht gelöscht werden. Das Standardkennzeichen wird verwendet, um eine Organisation zu identifizieren, sofern Sie es nicht durch Auswählen eines anderen Kennzeichens in einem Messagingport oder Kanal außer Kraft setzen.

Wenn BizTalk Server 2002 ein Dokument verarbeitet und transportiert, nimmt das Programm die Organisationskennzeichen der Zielorganisation und der Quellorganisation in die Umschlagkopfzeile auf. Wenn BizTalk Server 2002 Dokumente empfängt, durchsucht das Programm die Daten nach den Kennzeichen der Quellorganisation und der Zielorganisation. Anschließend verwendet der Server die Kennzeichen und den Namen der Dokumentdefinition, um zu ermitteln, welche Kanäle für die Verarbeitung der Dokumente verwendet werden sollen.

Austauschvorgänge mit einem EDI-Format weisen Einschränkungen bei Organisationskennzeichen auf. Wenn Sie ein Organisationskennzeichen für X12-Umschläge verwenden, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation verwenden oder ein anderes Kennzeichen, dessen Qualifizierer mehr als 2 Zeichen oder dessen Wert mehr als 15 Zeichen umfasst. Wenn Sie ein Organisationskennzeichen für EDIFACT-Umschläge verwenden, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation verwenden oder ein anderes Kennzeichen, dessen Qualifizierer mehr als 4 Zeichen oder dessen Wert mehr als 35 Zeichen umfasst.

Anmerkungen

  • Wenn der Server beim Verarbeiten eines eingehenden Dokuments im EDIFACT-Format einen leeren Qualifizierer und einen nicht leeren Wert findet, konvertiert er den leeren Qualifizierer in einen Bindestrich (-). Wenn Sie ein eingehendes Dokument im EDIFACT-Format verarbeiten möchten, das einen leeren Qualifizierer hat, oder einen ausgehenden Umschlag mit einem leeren Qualifizierer, müssen Sie ein benutzerdefiniertes Organisationskennzeichen erstellen, das einen Bindestrich als Qualifizierer hat. Für ein ausgehendes EDIFACT-Dokument konvertiert der Server den Bindestrich in einen leeren Qualifizierer.

  • Wenn der Server beim Verarbeiten eines eingehenden Dokuments mit einem anderen Format als EDIFACT einen leeren Qualifizierer und einen nicht leeren Wert findet, konvertiert er den leeren Qualifizierer zu Organisationsname.

Verwandte Themen

Erstellen und Verwalten von Organisationen

Grundlegendes zu Organisationen


Grundlegendes zu Dokumentdefinitionen

Eine Dokumentdefinition stellt einen speziellen Typ Dokument dar, der von Microsoft BizTalk Server 2002 verarbeitet wird. Eine Dokumentdefinition stellt den Typ des eingehenden oder ausgehenden Dokuments in einem Kanal dar und stellt einen Zeiger auf eine Dokumentspezifikation bereit. Die Dokumentdefinition definiert Struktur, Typ und Version des Dokuments. Die gleiche Dokumentspezifikation kann in einer beliebigen Anzahl von Dokumentdefinitionen verwendet werden, und die gleiche Dokumentdefinition kann in einer beliebigen Anzahl von Kanälen verwendet werden.

Wenn Format und Struktur des eingehenden und ausgehenden Dokuments in einem Kanal identisch sind, können Sie für beide die gleiche Spezifikation verwenden. Andernfalls müssen Sie eine Zuordnung angeben, die der Server verwendet, um das Format oder die Struktur des eingehenden Dokuments in das Format oder die Struktur des ausgehenden Dokuments umzuwandeln.

Wenn BizTalk Server 2002 ein Dokument empfängt, identifiziert das Programm den entsprechenden Kanal oder die entsprechenden Kanäle mit passenden eingehenden Dokumentdefinitionen. Die eingehende Dokumentdefinition für jeden Kanal verweist auf eine Spezifikation. Der Server verwendet die Spezifikation, um ein nicht auf XML-basierendes eingehendes Dokument aus seinem Ursprungsformat in ein temporäres XML-Format zu übersetzen und die Struktur des Dokuments auf ihre Gültigkeit zu prüfen. Die ausgehende Dokumentdefinition für einen Kanal verweist ebenfalls auf eine Spezifikation. Der Server verwendet die ausgehende Dokumentdefinition, um die Datenstruktur des ausgehenden Dokuments zu prüfen. Bei Bedarf kann der Server die Spezifikation darüber hinaus verwenden, um das ausgehende Dokument aus einem XML-Format in ein Format zu übersetzen, das die Zielorganisation oder Zielanwendung erkennen und verwenden kann. Das Ziel wird in dem Messagingport zugewiesen, dem der Kanal zugeordnet ist.

Eine Dokumentspezifikation für eine Dokumentdefinition ist optional. In den meisten Fällen ist die Auswahl einer Spezifikation jedoch empfehlenswert. Wenn Sie keine Spezifikation auswählen, geschieht Folgendes:

  • Die verarbeiteten Daten werden auf der eingehenden Seite nicht in XML bzw. auf der ausgehenden Seite nicht aus XML übersetzt.

  • Die Daten werden nicht anhand einer Spezifikation überprüft, um sicherzustellen, dass sie keine Fehler enthalten.

  • Struktur oder Format der Daten können nicht mithilfe einer Zuordnung in einem Kanal umgewandelt werden.

  • Es können keine globalen Überwachungsfelder oder Auswahlkriterien angegeben werden.

Eine Dokumentspezifikation ist nicht erforderlich, wenn Sie die Dokumentdefinition in einer Pass-Through-Versendung für Daten, die nicht im Unicode-XML-Format vorliegen, verwenden möchten. Ein Beispiel ist das Senden von Binärdaten mithilfe von BizTalk Server 2002 an ein Ziel, ohne dass die Daten in irgendeiner Weise geändert werden. In diesem Fall sollte weder für die eingehende noch für die ausgehende Dokumentspezifikation eine Dokumentdefinition des Kanals ausgewählt werden, der für die Pass-Through-Versendung verwendet wird.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Überwachen von Dokumentdatenfeldern

  • Grundlegendes zu Auswahlkriterien

Verwandte Themen

Erstellen und Verwalten von Dokumentdefinitionen

Verwenden des BizTalk-Editors

Zuordnen von Spezifikationen

Grundlegendes zu Kanälen


Überwachen von Dokumentdatenfeldern

In einer Dokumentspezifikation können in der Spezifikation enthaltene Felder zugewiesen werden, die in einer Überwachungsdatenbank protokolliert werden sollen. Die in einer Dokumentdefinition zugewiesenen Felder werden für alle Dokumentinstanzen überwacht, die von Kanälen verarbeitet werden, die die betreffende Dokumentdefinition als ihre eingehende Dokumentdefinition verwenden. Da diese Felder für alle Kanäle überwacht werden, werden sie als globale Überwachungsfelder bezeichnet.

Beim Auswählen einer eingehenden Dokumentdefinition für einen Kanal können Spezifikationsfelder für die Überwachung aus dem Kanal heraus zugewiesen werden. Die in einem Kanal zugewiesenen Spezifikationsfelder werden anstelle der globalen Überwachungsfelder für Dokumente überwacht, die von diesem bestimmten Kanal verarbeitet werden.

Die in einer Dokumentdefinition oder in einem Kanal für die Überwachung zugewiesenen Felder werden nur für die eingehende Dokumentdefinition des Kanals in einer Überwachungsdatenbank protokolliert. Felder, die in der ausgehenden Dokumentdefinition des Kanals für die Überwachung zugewiesen sind, werden nicht überwacht.

Mithilfe der Überwachungsdaten aus den verarbeiteten Dokumenten können Informationen zum Betrieb analysiert werden. Beispielsweise kann das Summenfeld des Rechnungsbetrags für alle Rechnungen überwacht werden, die Sie an Ihre Handelspartner senden. Mithilfe dieser Informationen können Sie den Gesamtbetrag der innerhalb eines bestimmten Zeitraums an alle Handelspartner gesendeten Rechnungen oder den Gesamtbetrag der Rechnungen für jeden einzelnen Handelspartner ermitteln.

Verwandte Themen

Erstellen und Verwalten von Dokumentdefinitionen

Verwenden der BizTalk-Dokumentüberwachung


Grundlegendes zu Auswahlkriterien

Auswahlkriterien sind eine eindeutige Gruppe von Name/Wert-Paaren, die Microsoft BizTalk Server 2002 ausschließlich für die Verarbeitung von EDI-Dokumenten verwendet. Für eingehende X12- oder EDIFACT-Dokumente verwendet der Server Auswahlkriterien, um eine Dokumentdefinition eindeutig zu identifizieren und auszuwählen, weil innerhalb einzelner EDI-Dokumente kein Dokumentdefinitionsname zur Verfügung steht.

Für ausgehende X12- oder EDIFACT-Dokumente werden Auswahlkriterien verwendet, um die funktionalen Informationen der Gruppenkopfzeile im Umschlag zu erstellen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden von Auswahlkriterien für eingehende Dokumente

  • Verwenden von Auswahlkriterien für ausgehende Dokumente


Verwenden von Auswahlkriterien für eingehende Dokumente

Für die Verarbeitung von eingehenden Dokumenten muss BizTalk Server 2002 über den Namen einer eingehenden Dokumentdefinition verfügen. Normalerweise erhält der Server den Namen der eingehenden Dokumentdefinition entweder aus einem Feld im eingehenden Dokument oder aus einem Parameter, der zusammen mit dem Dokument versendet wird. Weitere Informationen finden Sie unter Submitting.

Bei eingehenden X12- und EDIFACT-Austauschvorgängen können die Dokumente in der funktionalen Gruppe oder den Austauschkopfzeilen enthalten sein. BizTalk Server 2002 verarbeitet die in diesen Gruppen und Austauschvorgängen enthaltenen Dokumente einzeln. Da die dokumentbezogenen Informationen für jedes Dokument in der funktionalen Gruppe oder Austauschkopfzeile enthalten sind, kann der Server keinen Dokumentdefinitionsnamen aus den einzelnen Dokumenten abrufen. Ferner kann, da ein Austausch mehrere Gruppen mit verschiedenen Dokumenttypen enthalten kann, kein einzelner Dokumentdefinitionsname zum Identifizieren einer Dokumentdefinition als Versendungsparameter für den Server zur Verfügung gestellt werden.

In solchen Fällen kann BizTalk Server 2002 dokumentbezogene Daten aus der Kopfzeile der funktionalen Gruppe (der GS-Kopfzeile eines X12-Austauschs und der UNG-Kopfzeile eines EDIFACT-Austauschs) oder der Austauschkopfzeile in einem EDIFACT-Austausch ohne funktionale Gruppen extrahieren. Durch Vergleichen der Werte dieser Daten mit den Werten von Auswahlkriterien, die in einer Dokumentspezifikation angegeben sind, kann der Server die entsprechende Dokumentdefinition eindeutig identifizieren.

Damit BizTalk Server 2002 die Werte der Auswahlkriterien mit den entsprechenden Kopfzeilenelementen eines eingehenden Austauschs vergleichen kann, müssen die Namen der Auswahlkriterien exakt wie in der folgenden Tabelle eingegeben werden.

X12-Kopfzeilenelemente

Name | Anforderung | GS-Element
functional_identifier | Obligatorisch | GS01
application_sender_code | Obligatorisch | GS02
application_receiver_code | Obligatorisch | GS03
standards_version | Obligatorisch | GS08

EDIFACT-Kopfzeilenelemente

Name | Anforderung | UNH-Element | UNG-Element
functional_identifier | Obligatorisch | S009, 0065 | 0038
application_sender_code | Optional | Nicht verwendet | S006, 0040
application_receiver_code | Optional | Nicht verwendet | S007, 0044
standards_version_type | Obligatorisch | S009, 0052 | S008, 0052
standards_version_value | Obligatorisch | S009, 0054 | S008, 0054

Verwandte Themen

Erstellen und Verwalten von Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien

Verwenden von Auswahlkriterien für ausgehende Dokumente


Verwenden von Auswahlkriterien für ausgehende Dokumente

Bei der Verarbeitung eines ausgehenden X12- oder EDIFACT-Dokuments platziert BizTalk Server 2002 jedes Dokument in einem gültigen Umschlag des entsprechenden Formats. Um den Umschlag zu erstellen, fügt der Server die Wertdaten der Auswahlkriterien in den entsprechenden Feldern der Gruppen- und Nachrichtenkopfzeilen ein. Zum Erstellen der Kopfzeilen verwendet der Server die Werte der in der ausgehenden Dokumentdefinition für den Kanal enthaltenen Auswahlkriterien.

Nehmen Sie z. B. an, Sie erstellen eine Dokumentdefinition, die als eins ihrer Auswahlkriterien das Name/Wert-Paar functional_identifier/BESTELLUNGEN aufweist. Wenn Sie diese anschließend als ausgehende Dokumentdefinition in einem Kanal verwenden, wird der Wert des Feldes in der Gruppenkopfzeile, das dem Auswahlkriterium mit dem Namen functional_identifier entspricht, in der Umschlagkopfzeile auf BESTELLUNGEN festgelegt.

Damit BizTalk Server 2002 Werte von Auswahlkriterien in die entsprechenden Kopfzeilenelemente einfügen kann, müssen Sie die Namen der Auswahlkriterien exakt so eingeben, wie sie in den folgenden Tabellen aufgeführt sind.

X12-Kopfzeilenelemente

Name | Anforderung | GS-Element
functional_identifier | Obligatorisch | GS01
application_sender_code | Obligatorisch | GS02
application_receiver_code | Obligatorisch | GS03
standards_version | Obligatorisch | GS08

EDIFACT-Kopfzeilenelemente

Name | Anforderung | UNH-Element | UNG-Element
functional_identifier | Obligatorisch | S009, 0065 | 0038
application_sender_code | Optional | Nicht verwendet | S006, 0040
application_receiver_code | Optional | Nicht verwendet | S007, 0044
standards_version_type | Obligatorisch | S009, 0052 | S008, 0052
standards_version_value | Obligatorisch | S009, 0054 | S008, 0054

Verwandte Themen

Erstellen und Verwalten von Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien

Verwenden von Auswahlkriterien für eingehende Dokumente


Grundlegendes zu Umschlägen

Ein Umschlag kapselt elektronische Geschäftsdaten für den Transport. Standardmäßig besteht ein Umschlag aus Kopf- und Fußzeileninformationen oder nur aus Kopfzeileninformationen. Die angegebenen Umschlageigenschaften stellen Microsoft BizTalk Server 2002 die Informationen zur Verfügung, die der Server benötigt, um entweder eingehende Austauschvorgänge zu öffnen oder ausgehende Austauschvorgänge zu erstellen. Beim Erstellen eines Umschlags geben Sie ein Umschlagsformat an. Außerdem können Sie für bestimmte Formattypen eine Umschlagspezifikation auswählen.

Die von BizTalk Server 2002 unterstützten Umschlagsformate sind standardmäßiges XML, ANSI X12, EDIFACT, FLATFILE (mit Trennzeichen oder mit Feldern fester Breite), CUSTOM und RELIABLE. Das RELIABLE-Format verarbeitet Umschläge, die mit BizTalk Framework 2.0 kompatibel sind. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk Server-Website (www.microsoft.com/germany/biztalk/). Wenn Sie ein CUSTOM-Umschlagsformat angeben, müssen Sie eine benutzerdefinierte Parserkomponente erstellen und registrieren, um eingehende Umschläge zu verarbeiten, oder eine benutzerdefinierte Serialisierungskomponente, um ausgehende Umschläge zu verarbeiten. Weitere Informationen finden Sie unter Parser und Serializers.

CUSTOM XML- und FLATFILE-Formate

Um BizTalk Server 2002 die Verarbeitung von eingehenden Austauschvorgängen mit den Formaten CUSTOM XML oder FLATFILE zu ermöglichen, müssen Sie Umschläge in einem passenden Format erstellen. Sie müssen eine benutzerdefinierte Parserkomponente erstellen und registrieren, um BizTalk Server die Verarbeitung von eingehenden Austauschvorgängen in einem benutzerdefinierten Format zu ermöglichen. BizTalk Server kann eingehende Austauschvorgänge in den Formaten ANSI X12, UN/EDIFACT oder RELIABLE verarbeiten, ohne dazu einen mithilfe des BizTalk-Messaging-Managers erstellten Umschlag zu verwenden.

Zum Verarbeiten von ausgehenden Dokumenten in beliebigen Formaten müssen Sie einen Umschlag erstellen und ihn in einem Messagingport auswählen, um einen Austausch mit dem erforderlichen Umschlagsformat und den erforderlichen Kopfzeileninformationen zu erstellen. BizTalk Server platziert nur ein Dokument in jedem ausgehenden Austausch.

X12- und EDIFACT-Formate

Wenn Sie einen Umschlag mit einem X12- oder EDIFACT-Format in einem Messagingport auswählen, müssen Sie außerdem Trennzeichen und eine Austauschkontrollnummer angeben. Diese EDI-Eigenschaften wirken sich nur auf die Umschläge aus, die für die Verwendung mit diesem Messagingport ausgewählt sind. Wenn Sie einen Umschlag mit einem benutzerdefinierten Format auswählen, sind Trennzeichen und Austauschkontrollnummer optional und hängen von den Anforderungen der benutzerdefinierten Parser- oder Serialisierungskomponenten ab. Wenn Sie einen Kanal für einen Messagingport erstellen, der einen Umschlag mit den Formaten X12, EDIFACT oder CUSTOM verwendet, können Sie eine funktionale Gruppenkontrollnummer angeben, die nur auf Dokumente angewendet wird, die von dieser Kombination aus Kanal und Messagingport verarbeitet werden.

Das Format des in einem Messagingport ausgewählten Umschlags muss mit dem Format des ausgehenden Dokuments übereinstimmen, das er enthält. Das Format des ausgehenden Dokuments wird durch die Spezifikation bestimmt, auf die die ausgehende Dokumentdefinition eines Kanals verweist. Wenn Sie z. B. einen Umschlag mit einem X12-Format für einen Messagingport auswählen, müssen Sie beim Erstellen eines Kanals für diesen Messagingport eine ausgehende Dokumentdefinition auswählen, die auf eine Spezifikation verweist, die ebenfalls über ein X12-Format verfügt.

Wenn Sie beim Erstellen eines Messagingports keinen Umschlag angeben, werden die Daten ohne Kopfzeile im XML-Format gesendet.

Verarbeiten von DBCS-Zeichen

Internationales Problem

Der UNOX-Syntaxbezeichner in EDIFACT ist als Codeerweiterung definiert, um andere nicht Ein-Byte-Zeichen verarbeiten zu können. In einigen Ländern wurden jedoch eigene Standards definiert, bevor die UNOX-Syntax erstellt wurde. In Korea beispielsweise kennzeichnet der Standard KEDIFACT die Daten mit KECA anstatt mit UNO*. (Die UNO*-Syntax ist in den ISO 9735 EDIFACT-Systemregeln angegeben.) Die von BizTalk Server empfangenen EDIFACT-Daten weisen eine geänderte Kopfzeile auf (UNOA); die DBCS-Zeichen (Double Byte Character Set) bleiben jedoch weiterhin erhalten. UNOA besteht nur aus ASCII-Großbuchstaben und konvertiert die DBCS-Zeichen nicht ordnungsgemäß.

Der EDIFACT-Parser und die -Serialisierungskomponente wurden aktualisiert, um dieses Problem zu lösen. Wenn die Kopfzeile in UNOA-Zeichen vorliegt, akzeptieren EDIFACT-Parser und -Serialisierungskomponente einen Registrierungsschlüssel, um eine andere als die standardmäßige Codepage zu definieren, mit der die Daten konvertiert werden. Ein Registrierungswert mit der Bezeichnung EDIFACTUNOACodepage wurde zu den von BizTalk Server definierten Werten hinzugefügt. Dieser Registrierungswert weist den Standardwert 0 auf. Wenn er auf 0 festgelegt ist, verwendet er das BizTalk Server-Verhalten. Wenn für diesen Registrierungswert ein anderer Wert festgelegt wird, handelt es sich bei diesem Wert um den Codepagewert, der zum Konvertieren der resultierenden KEDIFACT-Daten verwendet wird.

Die Änderung der Codepage erfolgt global. Alle EDIFACT-Daten, die BizTalk Server durchlaufen, verarbeiten Daten in Übereinstimmung mit der Codepage EDIFACTUNOACodepage.

Wichtig

  • EDIFACT-Dokumente mit dem Syntaxbezeichner UNOX oder UNOY werden von BizTalk Server 2002 nicht unterstützt.

Anmerkungen

  • Eine Kontrollnummer kann übersprungen werden, wenn ein schwerwiegender Fehler auftritt, nachdem ein Dokument gesendet, aber bevor es aus der BizTalk Server-Verarbeitungswarteschlange entfernt wurde. Um die Serialisierung aller Threads zu vermeiden, wird die Kontrollnummer aus der BizTalk Server-Datenbank abgerufen und außerhalb der COM+-Transaktion, aber innerhalb ihrer lokalen SQL-Transaktion erhöht. Obwohl eine Kontrollnummer nur einmal verwendet wird, kann es daher sein, dass ein Thread mit der Kontrollnummer 1000 diese Nummer nicht abrufen kann. In diesem Fall wird für die Übertragung ein Rollback durchgeführt, wenn der Transport bereits erfolgt ist. Wenn die Transaktion noch nicht durchgeführt wurde, wurde die Nachricht beim Auftreten des Fehlers möglicherweise noch nicht gesendet. In beiden Fällen wird die dem Dokument zugeordnete Kontrollnummer übersprungen und nicht wieder verwendet.

  • Wenn Umschläge verarbeitet werden, die mit BizTalk Framework 2.0 kompatibel sind, sollte BizTalk Server 2002 in Bezug auf das Ablaufdatum als Endpunkt betrachtet werden. Wenn BizTalk Framework 2.0–kompatible Dokumente an BizTalk Server 2002 versendet werden, entweder von einer Anwendung oder von einem Handelspartner, werden gegebenenfalls die folgenden Felder überschrieben. Sind die folgenden Felder nicht vorhanden, werden sie erstellt:
    • Im Unterabschnitt mit den Eigenschaften:

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Im Unterabschnitt mit den Empfangsinformationen:

      <sendTo>

      <address>

      <sendReceiptBy>

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden von Umschlägen für die eingehende Verarbeitung

  • Verwenden von Umschlägen für die ausgehende Verarbeitung

Verwandte Themen

Erstellen und Verwalten von Umschlägen

Grundlegendes zu Messagingports


Verwenden von Umschlägen für die eingehende Verarbeitung

Microsoft BizTalk Server 2002 kann einen eingehenden Austausch in einem X12- oder EDIFACT-Format verarbeiten, ohne dazu einen mithilfe des BizTalk-Messaging-Managers erstellten Umschlag zu verwenden.

Damit BizTalk Server 2002 einen eingehenden Austausch mit einem FLATFILE-Format verarbeiten kann, müssen Sie mithilfe des BizTalk-Messaging-Managers einen Umschlag erstellen. Dieser Umschlag muss auf eine Spezifikation verweisen, die der Server zum Interpretieren und Öffnen des Austauschs verwenden kann. Der Name des Umschlags muss dem Server zur Verfügung gestellt werden, wenn der Austausch für die Verarbeitung versendet wird. Weitere Informationen finden Sie unter Submitting.

Damit BizTalk Server 2002 einen eingehenden Austausch mit einem CUSTOM XML-Format verarbeiten kann, müssen Sie mithilfe des BizTalk-Messaging-Managers einen Umschlag erstellen. Der Server kann jedoch den Umschlag mit dem CUSTOM XML-Format finden, den er für das Interpretieren und Öffnen des Austauschs benötigt, ohne dass ihm der Name des Umschlags beim Versenden zur Verfügung gestellt wird. Sie können dem Server den Namen des Umschlags beim Versenden zur Verfügung stellen, dies ist jedoch nicht erforderlich. Weitere Informationen finden Sie unter Submitting.

Damit BizTalk Server 2002 einen eingehenden Austausch mit einem benutzerdefinierten Format verarbeiten kann, müssen Sie einen benutzerdefinierten Parser erstellen, um den Austausch zu öffnen. Weitere Informationen finden Sie unter Parser.

Die Umschläge, die Sie für die Verarbeitung von eingehenden Austauschvorgängen erstellen, müssen nicht in einem Messagingport ausgewählt werden, der vom Server verwendet werden soll. Nur Umschläge für die Verarbeitung von ausgehenden Austauschvorgängen müssen in einem Messagingport ausgewählt werden.

Verwandte Themen

Erstellen und Verwalten von Umschlägen

Grundlegendes zu Umschlägen

Verwenden von Umschlägen für die ausgehende Verarbeitung


Verwenden von Umschlägen für die ausgehende Verarbeitung

Messagingports regulieren den ausgehenden Datenfluss von Microsoft BizTalk Server 2002 zu einem angegebenen Ziel. Beim Erstellen eines Messagingports können Sie einen Umschlag für die Dokumente auswählen, die von diesem Messagingport verarbeitet werden. Wenn Sie einen Umschlag auswählen, muss das Umschlagsformat mit dem Format der Dokumente übereinstimmen, die er enthält. Das Format der Dokumente wird durch die Spezifikation bestimmt, auf die die ausgehende Dokumentdefinition eines Kanals verweist. Nachdem Sie mithilfe des BizTalk-Messaging-Managers einen Umschlag erstellt haben, können Sie diesen in einer beliebigen Anzahl von Messagingports verwenden.

Wenn BizTalk Server 2002 ein ausgehendes Dokument verarbeitet, verwendet der Server die Eigenschaften des im Messagingport ausgewählten Umschlags, um einen Austausch zu erstellen, indem er das Dokument einkapselt oder mit einem Präfix versieht. Wenn Sie keinen Umschlag für einen Messagingport angeben, werden die Daten ohne Kopf- oder Fußzeile im XML-Format gesendet. Wenn Sie ein CUSTOM XML-Format angeben, jedoch keine Umschlagspezifikation auswählen, werden die Dateien im RELIABLE-Format gesendet. Das RELIABLE-Format verarbeitet Umschläge, die mit BizTalk Framework 2.0 kompatibel sind. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk Server-Website (www.microsoft.com/germany/biztalk/).

Damit BizTalk Server 2002 einen ausgehenden Austausch mit einem benutzerdefinierten Format verarbeiten kann, müssen Sie für das Erstellen eines Austauschs eine benutzerdefinierte Serialisierungskomponente erstellen. Weitere Informationen finden Sie unter Serializers.

Wenn Sie einen Umschlag mit einem X12- oder EDIFACT-Format auswählen, müssen Sie eine Austauschkontrollnummer und Trennzeichen angeben. Eine Austauschkontrollnummer wird für das Identifizieren und Überwachen von Dokumenten verwendet, die mithilfe des Messagingports verarbeitet werden. Die Austauschkontrollnummer wird bei jeder Verwendung des Umschlags und Messagingports erhöht. Trennzeichen geben die Zeichen an, die zum Trennen der Datensätze und Felder des Umschlags und des im Umschlag enthaltenen Dokuments verwendet werden. Bei Umschlägen mit einem benutzerdefinierten Format sind Austauschkontrollnummer und Trennzeichen optional.

Wichtig

  • Das Umschlagsformat für einen Messagingport muss mit dem Format des Dokumenttyps der Spezifikation übereinstimmen, auf die die ausgehende Dokumentdefinition für jeden der zugeordneten Kanäle verweist. Wenn Sie beispielsweise einen Umschlag mit einem X12-Format für einen Messagingport auswählen, müssen Sie eine Dokumentdefinition für ausgehende Dokumente für den Kanal auswählen, die auf eine X12-Spezifikation zeigt.

Verwandte Themen

Erstellen und Verwalten von Umschlägen

Grundlegendes zu Umschlägen

Verwenden von Umschlägen für die eingehende Verarbeitung


Grundlegendes zu Empfangsbestätigungen

Beim Austausch von Dokumenten mit einem Handelspartner erfordern Geschäftsvorgänge möglicherweise, dass Sie Empfangsbestätigungen für gesendete Dokumente erhalten oder Empfangsbestätigungen für Dokumente generieren, die ein Handelspartner an Ihr Unternehmen sendet.

Die BizTalk-Messagingdienste stellen zwei Verfahren für das Verarbeiten von Empfangsbestätigungen für Austauschvorgänge zur Verfügung. Bei Austauschvorgängen, die den X12- oder EDIFACT-Parser oder einen benutzerdefinierten Parser, der Empfangsbestätigungen erfordert, verwenden, können Sie den BizTalk-Messaging-Manager so konfigurieren, dass Kanaleigenschaften für die Verarbeitung von Empfangsbestätigungen verwendet werden. Bei Austauschvorgängen, die den XML-Parser verwenden, besteht die Möglichkeit, Reliable Messaging zu verwenden, das Empfangsbestätigungen automatisch verarbeitet, um die zuverlässige Übermittlung von Daten sicherzustellen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verarbeiten von Empfangsbestätigungen mithilfe von Kanälen

  • Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging


Verarbeiten von Empfangsbestätigungen mithilfe von Kanälen

Dieser Abschnitt erläutert, wie Sie die BizTalk-Messagingdienste für die Verwendung von Kanaleigenschaften zum Steuern der Verarbeitung von Empfangsbestätigungen konfigurieren können. Das Zielsystem ist für das Generieren (das Senden) von Empfangsbestätigungen an das Quellsystem konfiguriert. Das Quellsystem ist so konfiguriert, dass es Empfangsbestätigungen vom Zielsystem erwartet (empfängt) und sie mit den ursprünglichen Austauschvorgängen korreliert. Diese Konfiguration wird nur dann angewendet, wenn Sie Austauschvorgänge verarbeiten, die den X12- oder EDIFACT-Parser oder einen benutzerdefinierten Parser verwenden, der Empfangsbestätigungen erfordert. Weitere Informationen zum Erstellen benutzerdefinierter Parser finden Sie unter Parser. Wenn Sie Austauschvorgänge verarbeiten, die den XML-Parser verwenden, finden Sie weitere Informationen unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

Wenn Sie einen benutzerdefinierten Parser verwenden und Empfangsbestätigungen mit den ursprünglichen Austauschvorgängen korrelieren möchten, müssen Sie eine benutzerdefinierte Korrelationskomponente verwenden.

Damit das Quellsystem Empfangsbestätigungen empfängt, muss auch das Zielsystem für das Senden von Empfangsbestätigungen konfiguriert sein. Das Konfigurieren eines Kanals auf dem Quellsystem für das Entgegennehmen von Empfangsbestätigungen ist für den Empfang von Empfangsbestätigungen nicht ausreichend.

Die folgende Abbildung zeigt die Konfiguration sowohl für das Quell- als auch für das Zielsystem beim Verwenden von Kanaleigenschaften für die Verarbeitung von Empfangsbestätigungen.

Verarbeitung von Empfangsbestätigungen mithilfe von Kanälen:

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren des Quellsystems für Empfangsbestätigungen an einem Kanal

  • Konfigurieren des Zielsystems für Empfangsbestätigungen an einem Kanal


Konfigurieren des Quellsystems für Empfangsbestätigungen an einem Kanal

Dieses Thema erläutert die Konfiguration der BizTalk-Messagingdienste für das Senden eines Austauschs an einen Handelspartner und für die Verarbeitung einer Empfangsbestätigung mithilfe von Kanaleigenschaften.

Sie müssen einen Kanal und einen Messagingport erstellen, um einen Austausch zu verarbeiten und an das Zielsystem zu senden. Sie brauchen keinen Kanal und Messagingport zu erstellen, um die Empfangsbestätigung zu verarbeiten, die vom Zielsystem zurückgegeben wird. Sie müssen jedoch eine Dokumentdefinition erstellen, die der Server verwendet, um die Gültigkeit der Empfangsbestätigung bei der Rückgabe zu überprüfen.

Um die BizTalk-Messagingdienste für das Senden eines Austauschs an ein Zielsystem und das Verarbeiten einer Empfangsbestätigung mithilfe von Kanaleigenschaften zu konfigurieren, führen Sie die in der folgenden Tabelle aufgeführten Schritte aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die eingehenden und ausgehenden Dokumentdefinitionen für das ursprüngliche Dokument für den Austausch. Darüber hinaus müssen Sie eine Spezifikation für die Dokumentdefinition erstellen, die der Server verwendet, um die Gültigkeit der Empfangsbestätigung beim Empfang zu überprüfen.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkungen

    • Für die ausgehende Dokumentdefinition für den Kanal müssen Sie eine Spezifikation erstellen, die das vom Zielsystem erforderte Format verwendet. Beispielsweise X12.

    Wenn die BizTalk-Messagingdienste auf dem Zielsystem den Austausch verarbeiten und der Parser Empfangsbestätigungen erfordert, führt der Parser folgende Aktionen durch:

    • Extrahieren der Kopfzeilenelemente aus dem Austausch.

    • Generieren einer BizTalk-Standardempfangsbestätigung.

    • Einfügen der Elemente in die Standardempfangsbestätigung.

    Für das Quellsystem muss die Spezifikation für die ausgehende Dokumentdefinition des Kanals, der für die Verarbeitung des Austauschs verwendet wird, diese Felder ebenfalls enthalten. Auch die Spezifikation für die Dokumentdefinition zur Gültigkeitsprüfung der Empfangsbestätigung muss diese Felder enthalten. Das Quellsystem verwendet diese Elemente, um die Empfangsbestätigung mit dem ursprünglichen Austausch zu korrelieren.

    Es gibt folgende X12-Kopfzeilenelemente:

    • functional_identifier

    • standards_version

    Es gibt folgende EDIFACT-Kopfzeilenelemente:

    • functional_identifier

    • standards_version_type

    • standards_version_value
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie die eingehenden und ausgehenden Dokumentdefinitionen für das Erstellen des Kanals und eine Dokumentdefinition für die Empfangsbestätigung.
  • Erstellen von Dokumentdefinitionen

    Anmerkungen

    • In den Dokumentdefinitionen müssen Sie die zuvor erstellten Spezifikationen auswählen. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.

    • Sie müssen außerdem eine Dokumentdefinition für die Empfangsbestätigung erstellen.
  • Erstellen Sie einen Messagingport für das Transportieren der Empfangsbestätigung an das Quellsystem.
  • Erstellen von Messagingports

    Anmerkung

    • Sie müssen den Messagingport und seinen zugeordneten Empfangskanal für die Verarbeitung der Empfangsbestätigung zuerst erstellen. Wenn Sie den Kanal für die Verarbeitung des ursprünglichen Austauschs erstellen, müssen Sie den Empfangskanal angeben.
  • Erstellen Sie einen Messagingport für das Transportieren des Austauschs zum Zielsystem.
  • Erstellen von Messagingports
  • Erstellen Sie einen Kanal, um den ursprünglichen Austausch von Ihrem Handelspartner zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Aktivieren Sie auf der Seite Quellanwendung oder Quellorganisation des Kanal-Assistenten das Kontrollkästchen Erwartete Empfangsbestätigung.

    • Legen Sie im Bereich Erwartete Empfangsbestätigung im Feld Empfangsbestätigungsintervall in Minuten den Zeitraum fest, in dem bis zum Empfang der Empfangsbestätigung gewartet werden soll, bevor der ursprüngliche Austausch erneut gesendet wird. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung oder Festlegen von Eigenschaften für die Quellorganisation.
Verwenden der BizTalk-Dokumentüberwachung:
  • Der ursprüngliche Austausch wird in der Überwachungsdatenbank protokolliert, und das Statusfeld der Empfangsbestätigung (nACKStatus) wird auf Ausstehend festgelegt. Der Status der Empfangsbestätigung in der Überwachungsdatenbank ändert sich nachfolgend, um den Status des Empfangsprozesses wiederzugeben.
  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu Ergebnissen von Empfangsbestätigungen

Versenden von Empfangsbestätigungen auf dem Quellsystem

Empfangsbestätigungen werden an die BizTalk-Messagingdienste in der gleichen Weise versendet wie andere Dokumente. Nachdem eine Empfangsbestätigung versendet wurde, können die X12- und EDIFACT-Parser eine Empfangsbestätigung von anderen Dokumenten unterscheiden und den Server anweisen, die Empfangsbestätigung mit dem ursprünglichen Austausch zu korrelieren.

Wichtig

  • Empfangsbestätigungen müssen an die BizTalk-Messagingdienste ohne die Verwendung von Versendungsparametern versendet werden.


Konfigurieren des Zielsystems für Empfangsbestätigungen an einem Kanal

Dieses Thema erläutert die Konfiguration der BizTalk-Messagingdienste für die Verarbeitung eines Austauschs von einem Handelspartner und für das Generieren einer Empfangsbestätigung mithilfe von Kanaleigenschaften. Zu diesem Zweck müssen Sie einen Kanal und einen Messagingport erstellen, um den ausgehenden Austausch zu verarbeiten und ihn an das Zielsystem zu senden. Sie brauchen keinen Kanal oder Messagingport für die Verarbeitung der Empfangsbestätigung zu erstellen, die das Zielsystem zurückgibt. Ein Parser verarbeitet die Empfangsbestätigung mit nur einer Dokumentdefinition.

Um die BizTalk-Messagingdienste für das Verarbeiten eines Austauschs vom Quellsystem und das Senden einer Empfangsbestätigung mithilfe von Kanaleigenschaften zu konfigurieren, führen Sie die in der folgenden Tabelle aufgeführten Schritte aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die eingehenden und ausgehenden Dokumentdefinitionen, die zum Erstellen des Empfangskanals verwendet werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkungen

    • Für die eingehende Dokumentdefinition des Empfangskanals verwenden Sie die BizTalk-Standardempfangsbestätigungs-Spezifikation. Diese Spezifikation befindet sich im WebDAV-Repository.

    • Für die ausgehende Dokumentdefinition des Empfangskanals müssen Sie eine Spezifikation erstellen, die das von Ihren Geschäftsabläufen erforderte Format verwendet.

    Wenn die BizTalk-Messagingdienste auf dem Zielsystem einen eingehenden Austausch verarbeiten und der Parser Empfangsbestätigungen erfordert, führt der Parser folgende Aktionen durch:

    • Extrahieren von Gruppenkopfzeilen-Elementen.

    • Generieren einer BizTalk-Standardempfangsbestätigung.

    • Einfügen der Kopfzeilenelemente in die Standardempfangsbestätigung.

    Die ausgehende Dokumentspezifikation für den Empfangskanal muss Felder für diese Kopfzeilenelemente enthalten. Das Quellsystem verwendet die Kopfzeilenelemente, um die Empfangsbestätigung mit dem ursprünglichen Austausch zu korrelieren.

    Es gibt folgende X12-Kopfzeilenelemente:

    • functional_identifier

    • standards_version

    Es gibt folgende EDIFACT-Kopfzeilenelemente:

    • functional_identifier

    • standards_version_type

    • standards_version_value
  • Erstellen Sie die Spezifikationen für die eingehenden und ausgehenden Dokumentdefinitionen, die für die Erstellung des Kanals verwendet werden, der den ursprünglichen Austausch vom Quellsystem verarbeitet.
  • Erstellen und Überprüfen von Spezifikationen
Verwenden des BizTalk-Mappers:
  • Erstellen Sie eine Zuordnung für den Empfangskanal.
  • Erstellen neuer Zuordnungen

    Anmerkungen

    • Beim Erstellen des Empfangskanals müssen Sie eine Zuordnung angeben. Die Zuordnung wird verwendet, um die BizTalk-Standardempfangsbestätigung in den richtigen Dokumenttyp für das ausgehende Dokument umzuwandeln.

    • Sie können eine der im Lieferumfang von BizTalk Server 2002 enthaltenen Zuordnungen verwenden, wenn sie dem für Ihren Geschäftsablauf erforderlichen Format entspricht. Sie können diese Zuordnungen aus dem WebDAV-Repository abrufen.

      Oder

      Sie können eine eigene Zuordnung mithilfe der BizTalk-Standardempfangsbestätigungs-Spezifikation und einer Spezifikation erstellen, die dem für Ihren Geschäftsablauf erforderlichen Dokumenttyp entspricht.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie die Dokumentdefinitionen für den Empfangskanal und für den Kanal, den Sie zum Verarbeiten des ursprünglichen Austauschs verwenden.
  • Erstellen von Dokumentdefinitionen

    Anmerkungen

    • In den Dokumentdefinitionen müssen Sie die zuvor erstellten Spezifikationen auswählen. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.

    • Sie müssen außerdem die Dokumentdefinitionen für den Kanal erstellen, der für die Verarbeitung des ursprünglichen Austauschs verwendet wird. Deren Konfiguration unterscheidet sich in Abhängigkeit von Ihrem Geschäftsablauf.
  • Erstellen Sie einen Messagingport für das Transportieren der Empfangsbestätigung an das Quellsystem.
  • Erstellen von Messagingports

    Anmerkung

    • Sie müssen den Messagingport und den ihm zugeordneten Empfangskanal für die Verarbeitung der Empfangsbestätigung erstellen, bevor Sie die entsprechenden Komponenten für die Verarbeitung des ursprünglichen Austauschs erstellen. Wenn Sie den Kanal für die Verarbeitung des ursprünglichen Austauschs erstellen, müssen Sie den Empfangskanal angeben.
  • Erstellen Sie einen Empfangskanal aus einer Anwendung für die Verarbeitung der Empfangsbestätigung.
  • Erstellen von Kanälen

    Anmerkungen

    • Aktivieren Sie auf der Seite Allgemeine Informationen des Kanal-Assistenten das Kontrollkästchen Dies ist ein Empfangskanal.

    • Wählen Sie auf der Seite Quellanwendung des Kanal-Assistenten in der Liste Name eine Anwendung aus.

      Sie können eine Anwendung für die eigene Organisation erstellen, die Sie zum Zuweisen der von den Parsern generierten Empfangsbestätigungen verwenden.

    • Klicken Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten auf Durchsuchen, und suchen Sie die Dokumentdefinition, die Sie zuvor erstellt haben und die die BizTalk-Standardempfangsbestätigungs-Spezifikation verwendet.

    • Klicken Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten auf Durchsuchen, und suchen Sie nach der Dokumentdefinition, die Sie zuvor erstellt haben und die die Spezifikation für den von Ihrem Geschäftsablauf erforderten Dokumenttyp verwendet.
  • Erstellen Sie einen Messagingport für den Transport der im ursprünglichen Austausch enthaltenen Dokumente an das vorgesehene Ziel.
  • Erstellen von Messagingports

    Anmerkung

    • Dieser Messagingport benötigt keine besondere Konfiguration zum Verarbeiten von Empfangsbestätigungen.
  • Erstellen Sie einen Kanal, um den ursprünglichen Austausch von Ihrem Handelspartner zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Aktivieren Sie auf der Seite Quellorganisation des Kanal-Assistenten das Kontrollkästchen Empfangsbestätigung generieren.

    • Klicken Sie im Bereich Empfangsbestätigung generieren auf Durchsuchen, und wählen Sie den Empfangskanal aus, den Sie für die Verarbeitung der Empfangsbestätigung erstellt haben. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

    • Auf der Seite Erweiterte Konfiguration des Kanal-Assistenten können Sie im Bereich Wiederholungsoptionen die Anzahl der Wiederholungsversuche und das Intervall festlegen. Weitere Informationen finden Sie unter Festlegen erweiterter Konfigurationseigenschaften.
Verwenden der BizTalk-Dokumentüberwachung:
  • Der ursprüngliche Austausch und die Empfangsbestätigung werden in der Überwachungsdatenbank protokolliert.
  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu Ergebnissen von Empfangsbestätigungen


Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging

Dieser Abschnitt erläutert die Konfiguration der BizTalk-Messagingdienste für das Senden und Empfangen von Empfangsbestätigungen mithilfe von Reliable Messaging-Umschlägen, die Austauschvorgänge erstellen, die mit BizTalk Framework 2.0 kompatibel sind. Reliable Messaging erlaubt die automatische Verarbeitung von Empfangsbestätigungen, um die zuverlässige Übermittlung von Daten sicherzustellen. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk Server-Website (www.microsoft.com/germany/biztalk/). Informationen zum Senden und Empfangen von Austauschvorgängen, die den X12-, EDIFACT- oder einen benutzerdefinierten Parser verwenden, finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Kanälen.

Mithilfe des BizTalk-Messaging-Managers können Sie einen Messagingport für die Verwendung eines RELIABLE-Umschlagsformats für einen ausgehenden Austausch konfigurieren. Umschläge, die das Reliable Messaging-Format verwenden, müssen immer eine Antwort-URL-Adresse in der Kopfzeile enthalten. Die Antwortadresse wird vom Zielsystem verwendet, um eine Empfangsbestätigung an das Absendersystem des Austauschs zu senden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren des Quellsystems für Reliable Messaging-Empfangsbestätigungen

  • Konfigurieren des Zielsystems für Reliable Messaging-Empfangsbestätigungen


Konfigurieren des Quellsystems für Reliable Messaging-Empfangsbestätigungen

Um die BizTalk-Messagingdienste für das Senden eines Austauschs an ein Zielsystem und für das Verarbeiten einer Empfangsbestätigung mithilfe von Reliable Messaging zu konfigurieren, führen Sie die in der folgenden Tabelle aufgeführten Schritte durch. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden der BizTalk Server-Verwaltung:
  • Konfigurieren Sie die Eigenschaften der Antwortadresse für Reliable Messaging.
  • Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe

    Anmerkungen

    • Erweitern Sie in der BizTalk Server-Verwaltung Microsoft BizTalk Server 2002, und klicken Sie auf die zu konfigurierende Servergruppe.

    • Klicken Sie im Menü Vorgang auf Eigenschaften.

    • Geben Sie im Dialogfeld Eigenschaften von BizTalk Server-Gruppe im Feld Antwort-URL für Reliable Messaging den URL ein, den diese Servergruppe für den Empfang von Reliable Messaging-Empfangsbestätigungen verwendet.

      Wenn Sie einen ausgehenden Austausch erstellen, der einen Reliable Messaging-Umschlag verwendet, fügt der Server automatisch den Antwort-URL für Reliable Messaging in die Kopfzeile des ausgehenden Austauschs ein. Außerdem platziert der Server den ursprünglichen Austausch in der Wiederholungswarteschlange. Der Server verwendet die im Kanal angegebenen Wiederholungsoptionen, um die Anzahl der erneuten Sendeversuche des ursprünglichen Austauschs bis zum Empfang einer Empfangsbestätigung zu ermitteln.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie einen Umschlag, der das RELIABLE-Umschlagsformat verwendet.
  • Erstellen von Umschlägen

    Anmerkung

    • Klicken Sie im Dialogfeld Neuer Umschlag in der Liste Umschlagsformat auf RELIABLE.
  • Erstellen Sie einen Messagingport für das Transportieren des ursprünglichen Austauschs zum Zielsystem.
  • Erstellen von Messagingports

    Anmerkung

    • Wählen Sie auf der Seite Umschlagsinformationen des Messagingport-Assistenten im Bereich Umschlagsinformationen den zuvor erstellten Umschlag aus. Weitere Information finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.
  • Erstellen Sie einen Kanal für die Verarbeitung des ursprünglichen Austauschs.
  • Erstellen von Kanälen

    Anmerkungen

    • Legen Sie auf der Seite Quellanwendung oder Quellorganisation des Kanal-Assistenten keine Empfangsbestätigungseigenschaften fest.

    • Auf der Seite Erweiterte Konfiguration des Kanal-Assistenten können Sie im Bereich Wiederholungsoptionen die Anzahl der Wiederholungsversuche und das Intervall festlegen. Weitere Informationen finden Sie unter Festlegen erweiterter Konfigurationseigenschaften.
Verwenden der BizTalk-Dokumentüberwachung:
  • Auf dem Quellsystem wird der ursprüngliche ausgehende Austausch in der Überwachungsdatenbank protokolliert, die zurückgegebene Empfangsbestätigung jedoch nicht.
  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu Ergebnissen von Empfangsbestätigungen


Konfigurieren des Zielsystems für Reliable Messaging-Empfangsbestätigungen

Wenn die BizTalk-Messagingdienste für das Zielsystem einen Austausch im Reliable Messaging-Format empfangen, verwenden sie eine bestimmte Kombination aus Dokumentdefinition, Kanal und Messagingport, um eine Empfangsbestätigung zu verarbeiten und zum Quellsystem zu transportieren. Diese besonderen Systemobjekte werden im BizTalk-Messaging-Manager nicht angezeigt. Außerdem können Sie ähnliche Objekte nicht mithilfe der reservierten Systemnamen erstellen.

Der Server verwendet die in der Kopfzeile des ausgehenden Austauschs vorhandene Antwortadresse als Zieladresse für die Empfangsbestätigung.

Sie müssen die BizTalk-Messagingdienste nicht weiter konfigurieren, damit das Zielsystem eine Empfangsbestätigung für einen Austausch zurückgibt, der mit einem Reliable Messaging-Umschlag gesendet wird, es sei denn, das Quellsystem gibt eine SMTP-Adresse als Antwort-URL-Adresse für Reliable Messaging an. Um Empfangsbestätigungen an eine SMTP-Adresse zu senden, muss der Server so konfiguriert sein, dass er eine Absenderadresse in der Kopfzeile der Empfangsbestätigung enthält.

Bei der Installation von BizTalk Server 2002 wird ein Organisationskennzeichen für die eigene Organisation erstellt. Dieses Kennzeichen trägt den Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung und kann nicht entfernt werden. Beim Senden einer Reliable Messaging-Empfangsbestätigung an eine SMTP-Adresse fügt der Server den für dieses Organisationskennzeichen angegebenen Wert als Absenderadresse in die Austauschkopfzeile ein.

Um die BizTalk-Messagingdienste für das Senden einer Empfangsbestätigung an ein Zielsystem mithilfe einer SMTP-Antwortadresse für Reliable Messaging zu konfigurieren, führen Sie die in der folgenden Tabelle aufgeführten Schritte durch. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Messaging-Managers:
  • Konfigurieren Sie das Organisationskennzeichen für SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung der eigenen Organisation.
  • Konfigurieren der eigenen Organisation

    Anmerkungen

    • Öffnen Sie die eigene Organisation.

    • Klicken Sie im Dialogfeld Organisationseigenschaften auf die Registerkarte Bezeichner.

    • Klicken Sie in der Liste Organisationskennzeichen auf SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung, und klicken Sie dann auf Bearbeiten.

    • Geben Sie im Dialogfeld Bezeichnereigenschaften im Feld Wert einen Wert für das Kennzeichen ein. Weitere Informationen finden Sie unter Bearbeiten von Organisationskennzeichen.

    Wichtig

    • Ändern Sie nicht den Namen oder Qualifizierer dieses Kennzeichens, sondern nur seinen Wert.
  • Erstellen Sie einen Messagingport für das Transportieren des ursprünglichen Austauschs zum beabsichtigten Ziel.
  • Erstellen von Messagingports

    Anmerkung

    • Für diesen Messagingport ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie einen Kanal für die Verarbeitung des ursprünglichen Austauschs.
  • Erstellen von Kanälen

    Anmerkung

    • Für diesen Messagingport ist keine besondere Konfiguration erforderlich.
Verwenden der BizTalk-Dokumentüberwachung:
  • Auf dem Zielsystem wird der eingehende Austausch in der Überwachungsdatenbank protokolliert, nicht jedoch die Empfangsbestätigung.
  • Grundlegendes zu Ergebnissen von Dokumentinstanz-Datensätzen

  • Grundlegendes zu Ergebnissen von Empfangsbestätigungen


Grundlegendes zu Verteilerlisten

Eine Verteilerliste ist eine Gruppe von Messagingports, mit deren Hilfe Sie das gleiche Dokument an mehrere verschiedene Organisationen von Handelspartnern oder interne Anwendungen senden können.

Sie können eine Verteilerliste verwenden, um die gleichen Daten an mehrere Handelspartnerorganisationen oder interne Anwendungen Ihrer eigenen Organisation zu senden. Beispielsweise können Sie den gleichen Katalog, die gleiche Preisliste oder den gleichen Newsletter an mehrere Handelspartnerorganisationen senden, indem Sie die Informationen nur einmal an Microsoft BizTalk Server 2002 versenden.

Sie müssen zuerst einen Messagingport zu allen Handelspartnerorganisationen oder internen Anwendungen erstellen, die die Daten erhalten sollen. Fügen Sie anschließend die Messagingports zu einer Verteilerliste hinzu. Zu einer Verteilerliste können keine offenen Messagingports hinzugefügt werden. Sie können neue Messagingports zu weiteren Handelspartnerorganisationen oder internen Anwendungen erstellen und diese anschließend zu einer vorhandenen Verteilerliste hinzufügen. Weitere Informationen finden Sie unter Erstellen von Messagingports.

Sie müssen für jede Verteilerliste wenigstens einen Kanal erstellen, ansonsten ist die Verteilerliste nicht funktionsfähig. Weitere Informationen finden Sie unter Erstellen von Kanälen.

Wenn BizTalk Server 2002 einen Kanal aufruft, der einer Verteilerliste zugeordnet ist, wird nur der dieser Verteilerliste zugeordnete Kanal für die Verarbeitung der Daten aufgerufen. Keiner der Kanäle, die den einzelnen Messagingports in der Verteilerliste zugeordnet sind, wird aufgerufen. Der Server verwendet der Reihe nach die Eigenschaften jedes Messagingports, um die Daten an die in den Messagingports angegebenen Ziele zu transportieren.

Eine Verteilerliste unterscheidet sich in den folgenden Punkten von einem offenen Messagingport:

  • Bei einer Verteilerliste kann jedes Dokument von einem Kanal die Übermittlung des Dokuments an mehrere Ziele zur Folge haben. Bei einem offenen Messagingport führt jedes Dokument von einem Kanal zur Übermittlung nur eines Dokuments an nur ein Ziel.

  • Bei einer Verteilerliste müssen Sie einen Messagingport hinzufügen, um Informationen an die Organisation eines anderen Handelspartners zu senden. Bei einem offenen Messagingport müssen die Eigenschaften des Messagingports nicht geändert werden, um Informationen an die Organisation eines anderen Handelspartners zu senden.

Verwandtes Thema

Verwenden von Verteilerlisten


Gründe für das Durchführen von BizTalk-Messaging-Manager-Aufgaben

Dieser Abschnitt stellt eine kurze Referenz zum Durchführen von BizTalk-Messaging-Manager-Aufgaben bereit. Die folgende Tabelle enthält Beschreibungen der Hauptaufgaben sowie der jeweiligen Unteraufgaben, Erläuterungen zum Zweck jeder Aufgabe und Links zu den entsprechenden Verfahren.

Aufgabe Zweck
Erstellen und Verwalten von Kanälen:
  • Erstellen von Kanälen
 Verarbeiten von Dokumenten, die von den BizTalk-Messagingdiensten empfangen wurden.
  • Festlegen von Kanaleigenschaften
  • Zuweisen von Spezifikationsfeldern, um die eingehende Dokumentdefinition zu überwachen.

  • Erstellen eines Kanalfilterausdrucks, der ermittelt, ob BizTalk Server den Kanal auf der Basis des Wertes eines Feldes oder mehrerer Felder im verarbeiteten Dokument aufruft.

  • Konfigurieren von Empfangsbestätigungen, Sicherheitseigenschaften und Protokollierungsoptionen für Dokumente.

  • Festlegen einer Gruppenkontrollnummer für Dokumente mit EDI-Formaten (Electronic Data Interchange). Legen Sie die Zahl und das Zeitintervall fest, die der Server zum erneuten Senden von Dokumenten verwendet, oder setzen Sie die Transportkomponente und die Umschlagseigenschaften für den Messagingport oder die Verteilerliste außer Kraft.
Erstellen und Verwalten von Messagingports:
  • Erstellen von Messagingports
 Transportieren der von den BizTalk-Messagingdiensten empfangenen Dokumente an ein bestimmtes Ziel.
  • Festlegen von Messagingporteigenschaften
  • Zuweisen einer bestimmten Adresse, an die Dokumente übermittelt werden.

  • Festlegen des Transporttyps für die Übermittlung von Dokumenten an diesen Standort.

  • Angeben der Umschläge und der Art der Sicherung für die Dokumente vor dem Transport.
Erstellen und Verwalten von Organisationen:
  • Konfigurieren der eigenen Organisation
  • Ändern des Namens der eigenen Organisation, der vom BizTalk-Messaging-Manager zugewiesen wurde.

  • Ändern der Werte für das Kennzeichen der eigenen Organisation; diese Eigenschaften werden zum eindeutigen Identifizieren der eigenen Organisation verwendet.

  • Festlegen von Anwendungseigenschaften, die Ihnen das Identifizieren und Überwachen des Dokumentenablaufs zwischen BizTalk Server und internen Anwendungen innerhalb Ihrer Organisation ermöglichen.
  • Erstellen von Organisationen
 Zulassen des Dokumentaustauschs zwischen Ihrem Unternehmen und seinen Handelspartnern. Die eigene Organisation stellt Ihr Unternehmen dar und wird vom BizTalk-Messaging-Manager automatisch erstellt. Alle anderen Organisationen, die Sie erstellen, stellen externe Handelspartner oder Unternehmenseinheiten eines Handelspartners dar.
  • Festlegen von Organisationseigenschaften
  • Festlegen von Organisationskennzeichen; diese Eigenschaften werden zum eindeutigen Identifizieren von Organisationen verwendet.

  • Festlegen von Anwendungseigenschaften, die Ihnen das Identifizieren und Überwachen des Dokumentenablaufs zwischen Ihrem Unternehmen und seinen Handelspartnern ermöglichen.
Erstellen und Verwalten von Dokumentdefinitionen:
  • Erstellen von Dokumentdefinitionen
 Darstellen bestimmter Dokumenttypen, die von BizTalk Server verarbeitet werden.
  • Festlegen von Dokumentdefinitionseigenschaften
  • Erstellen einer Dokumentspezifikation, die Struktur, Typ und Version eines Dokuments definiert. Die gleiche Dokumentspezifikation kann in einer beliebigen Anzahl von Dokumentdefinitionen verwendet werden, und die gleiche Dokumentdefinition kann in einer beliebigen Anzahl von Kanälen verwendet werden.

  • Festlegen globaler Überwachungseigenschaften, damit Sie Dokumente mithilfe der Überwachungsdatenbank überwachen können.

  • Festlegen von Auswahlkriterien, die aus eindeutigen Name/Wert-Paaren bestehen, die BizTalk Server zur Verarbeitung von EDI-Dokumenten verwendet.
Erstellen und Verwalten von Umschlägen:
  • Erstellen von Umschlägen
 Kapseln von elektronischen Geschäftsdaten für den Transport. Die von Ihnen angegebenen Umschlagseigenschaften stellen BizTalk Server die Informationen zur Verfügung, die der Server benötigt, um eingehende Austauschvorgänge zu öffnen oder ausgehende Austauschvorgänge zu erstellen.
  • Auswählen einer Umschlagspezifikation
 Anwenden einer Spezifikation auf ein Umschlagsformat.
Verwenden von Verteilerlisten:
  • Erstellen von Verteilerlisten
 Senden des gleichen Dokuments an mehrere Handelspartnerorganisationen oder interne Anwendungen.


Durchführen von BizTalk-Messaging-Manager-Aufgaben

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Verwenden des BizTalk-Messaging-Managers bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Informationen zum BizTalk-Messaging-Manager lesen, um die Beziehungen zwischen Objekten vollständig zu verstehen, die mithilfe des BizTalk-Messaging-Managers erstellt werden können.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Erstellen und Verwalten von Kanälen

  • Erstellen und Verwalten von Messagingports

  • Erstellen und Verwalten von Organisationen

  • Erstellen und Verwalten von Dokumentdefinitionen

  • Erstellen und Verwalten von Umschlägen

  • Verwenden von Verteilerlisten


Erstellen und Verwalten von Kanälen

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Kanälen bereit. Es wird dringend empfohlen, das Thema Grundlegendes zu Kanälen im Abschnitt "Grundbegriffe" zu lesen, um Kanäle vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Kanälen

  • Suchen nach Kanälen

  • Bearbeiten von Kanälen

  • Löschen von Kanälen

  • Festlegen von Kanaleigenschaften


Erstellen von Kanälen

Sie müssen einen Messagingport oder eine Verteilerliste erstellen, bevor Sie einen Kanal erstellen können. Weitere Informationen finden Sie unter Erstellen von Messagingports oder Erstellen von Verteilerlisten.

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Klicken Sie im Bereich Nach anderen Elementen suchen auf Messagingports oder Verteilerlisten, und klicken Sie dann auf Jetzt suchen.

  3. Klicken Sie in der Liste Messagingportname auf den Messagingport, für den Sie einen Kanal erstellen möchten.

    Oder

    Klicken Sie in der Liste Verteilerlistenname auf die Verteilerliste, für die Sie einen Kanal erstellen möchten.

  4. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, zeigen Sie auf Kanal, und führen Sie dann einen der folgenden Schritte aus:
    • Um einen Kanal von einer Organisation zu erstellen, klicken Sie auf Von einer Organisation.

    • Um einen Kanal von einer Anwendung zu erstellen, klicken Sie auf Von einer Anwendung.

    Der Kanal-Assistent wird geöffnet.

  5. Legen Sie auf der Seite Allgemeine Informationen die Eigenschaften fest, und klicken Sie auf Weiter.

    Weitere Informationen finden Sie unter Festlegen allgemeiner Kanalinformationseigenschaften.

  6. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie einen Kanal von einer Organisation erstellen, legen Sie die Eigenschaften auf der Seite Quellorganisation fest, und klicken Sie dann auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

    • Wenn Sie einen Kanal von einer Anwendung erstellen, legen Sie die Eigenschaften auf der Seite Quellanwendung fest, und klicken Sie dann auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.
  7. Legen Sie auf der Seite Eingehendes Dokument die Eigenschaften fest, und klicken Sie dann auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

  8. Legen Sie auf der Seite Ausgehendes Dokument die Eigenschaften fest, und klicken Sie dann auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

  9. Legen Sie auf der Seite Dokumentprotokollierung die Eigenschaften fest, und klicken Sie dann auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.

  10. Legen Sie auf der Seite Erweiterte Konfiguration die Eigenschaften fest, und klicken Sie auf Fertig stellen.

    Weitere Informationen finden Sie unter Festlegen erweiterter Konfigurationseigenschaften.

  11. Nachdem Sie alle Kanaleigenschaften festgelegt haben, klicken Sie auf der Seite Erweiterte Konfiguration auf Fertig stellen, um den Kanal-Assistenten zu schließen.

Anmerkungen

  • Der reservierte Systemname Kanal für Reliable Messaging-Bestätigung darf beim Benennen eines Kanals nicht verwendet werden.

  • Sie können dieses Verfahren verwenden, um entweder einen Standardkanal oder einen Empfangskanal zu erstellen. Die Verfahren in diesem Abschnitt enthalten Anmerkungen, die erläutern, welche Kanaleigenschaften beim Erstellen von Empfangskanälen nicht zur Verfügung stehen.

  • Wenn Sie einen Messagingport und einen Kanal für eine Pass-Through-Versendung von Daten erstellen, können Sie nur das Dienstfenster, den Wiederholungszähler und die Intervallfeatures des Kanals sowie die Transportfeatures des zugeordneten Messagingports verwenden. Sie können die Überprüfung der Decodierung oder Entschlüsselung, das Filtern, die Dokumentüberwachung oder Zuordnungsfeatures des Kanals nicht verwenden.

  • Beim Speichern eines Kanals, der auf eine Zuordnung verweist, die sich außerhalb des lokalen Netzwerkes befindet und von einem Internetfirewall geschützt wird, kann aufgrund der Firewallkonfiguration eine Fehlermeldung angezeigt werden. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Löschen von Kanälen

Bearbeiten von Kanälen

Suchen nach Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Kanälen


Suchen nach Kanälen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Kanäle.

  2. Um nach allen Kanälen zu suchen, löschen Sie alle Suchkriterien, und klicken Sie dann auf Jetzt suchen.

  3. Führen Sie eine oder mehrere der folgenden Aktionen durch:
    • Um nach Kanälen mit einem bestimmten Namen zu suchen, geben Sie im Bereich Nach Kanälen suchen im Feld Kanalname den Namen des gesuchten Kanals ein, und klicken Sie dann auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, wobei die Suche alle möglichen Namen zurückgibt, die mit dem unvollständigen Namen übereinstimmen.

    • Um nach Kanälen aus einem bestimmten Quelltyp zu suchen, klicken Sie in der Dropdownliste Quelle auf einen Quelltyp, und klicken Sie dann auf Jetzt suchen.

    • Um nach Kanälen zu suchen, die einem bestimmten Messagingport oder einer bestimmten Verteilerliste zugeordnet sind, geben Sie im Feld Messagingport oder Verteilerliste zugeordnet den Namen des Messagingports oder der Verteilerliste ein, und klicken Sie dann auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, wobei die Suche alle möglichen Namen zurückgibt, die mit dem unvollständigen Namen übereinstimmen.

    • Um nach Kanälen zu suchen, die eine bestimmte Dokumentdefinition verwenden, geben Sie im Feld Dokumentdefinition verwenden den Namen einer Dokumentdefinition ein, und klicken Sie auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, wobei die Suche alle möglichen Namen zurückgibt, die mit dem unvollständigen Namen übereinstimmen.

Anmerkungen

  • Sie können mehr als ein Suchkriterium festlegen, bevor Sie auf Jetzt suchen klicken.

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Sie können ferner nach Kanälen suchen, die einem bestimmten Messagingport oder einer bestimmten Verteilerliste zugeordnet sind, indem Sie mit der rechten Maustaste auf den Messagingport oder die Verteilerliste klicken und dann auf Kanäle suchen klicken.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Sie können die Anzahl der in einer Suche zurückgegebenen Elemente verringern, indem Sie Suchkriterien verwenden.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diesen Wert können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

  • Sie können die folgenden Platzhalterzeichen für die Suchkriterien verwenden.
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Löschen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Kanälen


Bearbeiten von Kanälen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Kanalname auf den Kanal, den Sie bearbeiten möchten.

    Weitere Informationen zum Suchen nach Kanälen finden Sie unter Suchen nach Kanälen.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Der Kanal-Assistent wird geöffnet.

  3. Bearbeiten Sie auf der Seite Allgemeine Informationen die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen allgemeiner Kanalinformationseigenschaften.

    Nachdem Sie die Eigenschaften auf einer beliebigen Seite bearbeitet haben, können Sie auf Fertig stellen klicken, um den Kanal-Assistenten zu schließen, oder auf Weiter klicken, um weitere Kanaleigenschaften zu bearbeiten.

  4. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie einen Kanal von einer Organisation bearbeiten, bearbeiten Sie die entsprechenden Eigenschaften auf der Seite Quellorganisation. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

    • Wenn Sie einen Kanal von einer Anwendung aus bearbeiten, bearbeiten Sie die entsprechenden Eigenschaften auf der Seite Quellanwendung. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.
  5. Bearbeiten Sie auf der Seite Eingehendes Dokument die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

  6. Bearbeiten Sie auf der Seite Ausgehendes Dokument die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

  7. Bearbeiten Sie auf der Seite Dokumentprotokollierung die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Dokumentprotokollierung.

  8. Bearbeiten Sie auf der Seite Erweiterte Konfiguration die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen erweiterter Konfigurationseigenschaften.

Anmerkungen

  • Der reservierte Systemname Kanal für Reliable Messaging-Bestätigung darf beim Benennen eines Kanals nicht verwendet werden.

  • Beim Speichern eines Kanals, der auf eine Zuordnung verweist, die sich außerhalb der lokalen Domäne befindet, wird möglicherweise eine Fehlermeldung angezeigt. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Kanälen

Löschen von Kanälen

Suchen nach Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Kanälen


Löschen von Kanälen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Kanalname auf den Kanal, den Sie löschen möchten.

    Weitere Informationen zum Suchen nach Kanälen finden Sie unter Suchen nach Kanälen.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkung

  • Sie können den Empfangskanal erst löschen, nachdem alle Kanäle, die auf ihn verweisen, gelöscht wurden.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Suchen nach Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Kanälen


Festlegen von Kanaleigenschaften

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Konfigurieren der Eigenschaften eines Kanals bereit. Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen allgemeiner Kanalinformationseigenschaften

  • Festlegen von Eigenschaften für die Quellorganisation

  • Festlegen von Eigenschaften für die Quellanwendung

  • Festlegen von Eigenschaften für eingehende Dokumente

  • Festlegen von Eigenschaften für ausgehende Dokumente

  • Festlegen von Eigenschaften für die Dokumentprotokollierung

  • Festlegen erweiterter Konfigurationseigenschaften

  • Auswählen einer Quellorganisation

  • Auswählen eines Empfangskanals

  • Auswählen einer eingehenden Dokumentdefinition

  • Auswählen eines Zertifikats zum Überprüfen der Entschlüsselung eingehender Dokumente

  • Auswählen eines Zertifikats zum Überprüfen der Signatur eingehender Dokumente

  • Auswählen einer ausgehenden Dokumentdefinition

  • Auswählen einer Zuordnung

  • Auswählen eines Zertifikats für die ausgehende Signatur

  • Außerkraftsetzen von Messagingportstandards

  • Außerkraftsetzen von Verteilerlistenstandards

  • Festlegen der Überwachung von Eigenschaften eingehender Dokumente

  • Festlegen von Eigenschaften für die Kanalfilterung


Festlegen allgemeiner Kanalinformationseigenschaften

  1. Geben Sie auf der Seite Allgemeine Informationen des Kanal-Assistenten im Feld Name den Namen des Kanals ein.

  2. Geben Sie im Feld Kommentare gegebenenfalls Kommentare für den Kanal ein.

  3. Wenn Sie einen Empfangskanal erstellen möchten, aktivieren Sie das Kontrollkästchen Dies ist ein Empfangskanal.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkung

  • Sie können keinen Empfangskanal für einen offenen Messagingport oder eine Verteilerliste erstellen.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Empfangsbestätigungen


Festlegen von Eigenschaften für die Quellorganisation

  1. Führen Sie auf der Seite Quellorganisation des Kanal-Assistenten einen der folgenden Schritte aus:
    • Klicken Sie auf Offene Quelle, um einen offenen Kanal zu erstellen (die Quelle wird jetzt entweder von Daten im Dokument oder in Parametern bereitgestellt, die zusammen mit dem Dokument versendet werden), und klicken Sie dann auf Weiter.

      Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

    • Klicken Sie auf Organisation, um eine Handelspartnerorganisation als Quelle zuzuweisen, und fahren Sie dann mit Schritt 2 fort.
  2. Klicken Sie im Bereich Organisation auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf eine Organisation, und klicken Sie dann auf OK.

    Weitere Informationen finden Sie unter Auswählen einer Quellorganisation.

  4. Wenn Sie das standardmäßige Organisationskennzeichen für die Quellorganisation außer Kraft setzen möchten, klicken Sie in der Liste Organisationskennzeichen auf ein anderes Kennzeichen.

  5. Wenn Sie, wie im Messagingport angegeben, eine Empfangsbestätigung vom Ziel benötigen, aktivieren Sie das Kontrollkästchen Erwartete Empfangsbestätigung. Geben Sie im Feld Empfangsbestätigungsintervall in Minuten einen Wert ein, oder klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.

    Der Standardwert in Minuten ist 120. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  6. Wenn Sie eine Empfangsbestätigung für die Quelle generieren möchten, aktivieren Sie das Kontrollkästchen Empfangsbestätigung generieren, klicken Sie auf Durchsuchen, und wählen Sie dann einen Empfangskanal aus.

    Weitere Informationen finden Sie unter Auswählen eines Empfangskanals.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkungen

  • Wenn Sie ein Quellorganisationskennzeichen für die Verwendung mit X12-Umschlägen auswählen, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation oder ein anderes Kennzeichen auswählen, dessen Qualifizierer mehr als 2 Zeichen oder dessen Wert mehr als 15 Zeichen umfasst.

  • Wenn Sie ein Quellorganisationskennzeichen für die Verwendung mit EDIFACT-Umschlägen auswählen, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation oder ein anderes Kennzeichen auswählen, dessen Qualifizierer mehr als 4 Zeichen oder dessen Wert mehr als 35 Zeichen umfasst.

  • Wenn Sie einen Kanal von einer bestimmten Organisation bearbeiten, steht die Option Offene Quelle nicht zur Verfügung, und Sie können die Quellorganisation nicht ändern. Wenn Sie einen offenen Kanal bearbeiten, steht die Option Organisation nicht zur Verfügung.

  • Wenn Sie einen Empfangskanal erstellen oder bearbeiten, stehen die Eigenschaften Erwartete Empfangsbestätigung und Empfangsbestätigung generieren nicht zur Verfügung.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Empfangsbestätigungen


Festlegen von Eigenschaften für die Quellanwendung

  1. Führen Sie auf der Seite Quellanwendung des Kanal-Assistenten einen der folgenden Schritte aus:
    • Klicken Sie auf XLANG-Ablaufplan, um festzulegen, dass es sich bei der Quelle um einen XLANG-Ablaufplan handelt, und klicken Sie dann auf Weiter.

      Sie sollten diese Option nicht auswählen, wenn Sie einen Kanal für einen offenen Messagingport erstellen. Weitere Informationen zum Integrieren der BizTalk-Messagingdienste und der BizTalk-Orchestrierungsdienste finden Sie unter Integrieren der BizTalk-Dienste.

    • Klicken Sie auf Anwendung, um eine Anwendung der eigenen Organisation als Quelle zuzuweisen, und fahren Sie dann mit Schritt 2 fort.
  2. Klicken Sie in der Liste Name auf eine Anwendung.

  3. Wenn Sie das standardmäßige Organisationskennzeichen für die eigene Organisation außer Kraft setzen möchten, klicken Sie in der Liste Organisationskennzeichen auf ein anderes Kennzeichen.

  4. Wenn Sie eine Empfangsbestätigung vom Ziel erhalten möchten, aktivieren Sie das Kontrollkästchen Erwartete Empfangsbestätigung, und geben Sie im Feld Empfangsbestätigungsintervall in Minuten einen Wert ein, oder klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.

    Der Standardwert in Minuten ist 120. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  5. Wenn Sie eine Empfangsbestätigung für die Quelle generieren möchten, aktivieren Sie das Kontrollkästchen Empfangsbestätigung generieren, klicken Sie auf Durchsuchen, und wählen Sie dann einen Empfangskanal aus.

    Weitere Informationen finden Sie unter Auswählen eines Empfangskanals.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkungen

  • Ein XLANG-Ablaufplan kann mithilfe des BizTalk-Orchestrierungs-Designers erstellt werden.

  • Beim Erstellen oder Bearbeiten eines Empfangskanals oder eines Kanals, für den ein XLANG-Ablaufplan als Quelle angegeben ist, stehen die Eigenschaften Erwartete Empfangsbestätigung oder Empfangsbestätigung generieren nicht zur Verfügung.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Integrieren der BizTalk-Dienste

Festlegen von Kanaleigenschaften

Grundlegendes zu Empfangsbestätigungen


Festlegen von Eigenschaften für eingehende Dokumente

  1. Klicken Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten rechts neben dem Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  2. Klicken Sie auf eine Dokumentdefinition, und klicken Sie dann auf OK.

    Weitere Informationen finden Sie unter Auswählen einer eingehenden Dokumentdefinition.

  3. Wenn Sie die Entschlüsselung des eingehenden Dokuments überprüfen möchten, aktivieren Sie das Kontrollkästchen Entschlüsselungszertifikat des eingehenden Dokuments überprüfen. Klicken Sie dann rechts neben dem Feld Zertifikat zum Überprüfen der Entschlüsselung auf Durchsuchen.

    Das Dialogfeld Zertifikat zum Überprüfen der Entschlüsselung auswählen wird angezeigt.

  4. Wählen Sie ein Zertifikat aus.

    Weitere Informationen finden Sie unter Auswählen eines Zertifikats zum Überprüfen der Entschlüsselung eingehender Dokumente.

  5. Wenn Sie die digitale Signatur des eingehenden Dokuments überprüfen möchten, aktivieren Sie das Kontrollkästchen Signaturzertifikat des eingehenden Dokuments überprüfen. Klicken Sie dann rechts neben dem Feld Zertifikat zum Überprüfen der Signatur auf Durchsuchen.

    Das Dialogfeld Zertifikat zum Überprüfen der Signatur auswählen wird angezeigt.

  6. Wählen Sie ein Signaturzertifikat aus.

    Weitere Informationen finden Sie unter Auswählen eines Zertifikats zum Überprüfen der Signatur eingehender Dokumente.

  7. Wenn Sie Felder im eingehenden Dokument überwachen möchten, aktivieren Sie das Kontrollkästchen Eingehendes Dokument überwachen, und klicken Sie dann auf Überwachen.

    Das Dialogfeld Eingehende Dokumente überwachen wird angezeigt.

  8. Legen Sie die Überwachungseigenschaften fest.

    Weitere Informationen finden Sie unter Festlegen der Überwachung für Eigenschaften eingehender Dokumente.

  9. Wenn Sie einen Kanalfilterausdruck für das eingehende Dokument erstellen möchten, aktivieren Sie das Kontrollkästchen Eingehendes Dokument filtern, und klicken Sie dann auf Filtern.

    Das Dialogfeld Kanalfilterausdrücke wird angezeigt.

  10. Legen Sie die Filtereigenschaften fest.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Kanalfilterung.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkungen

  • Beim Erstellen eines Empfangskanals, der die BizTalk-Standardempfangsbestätigung für die eingehende Dokumentdefinition verwendet, stehen die Überwachungs- und Filtereigenschaften nicht zur Verfügung.

  • Wenn Sie einen Kanal für einen offenen Messagingport erstellen und die Zielinformationen im Dokument zur Verfügung gestellt werden, muss die eingehende Dokumentdefinition für diesen Kanal auf eine Spezifikation verweisen, die korrekt konfiguriert ist. Weitere Informationen zum Konfigurieren einer Dokumentspezifikation zur Verarbeitung von Dokumenten für einen offenen Messagingport finden Sie unter Festlegen von Wörterbucheigenschaften.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Wörterbucheigenschaften

Grundlegendes zu Empfangsbestätigungen


Festlegen von Eigenschaften für ausgehende Dokumente

  1. Klicken Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten rechts neben dem Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  2. Klicken Sie auf eine Dokumentdefinition, und klicken Sie dann auf OK.

    Weitere Informationen finden Sie unter Auswählen einer ausgehenden Dokumentdefinition.

  3. Wenn Sie eine Zuordnung angeben möchten, aktivieren Sie das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen. Klicken Sie dann rechts neben dem Feld Verweis zuordnen auf Durchsuchen.

    Das Dialogfeld Eine Zuordnung aus dem WebDAV-Repository auswählen wird angezeigt.

  4. Wählen Sie eine Zuordnungsspezifikation aus.

    Weitere Informationen finden Sie unter Auswählen einer Zuordnung.

  5. Wenn Sie das ausgehende Dokument digital signieren möchten, aktivieren Sie das Kontrollkästchen Ausgehendes Dokument signieren, und klicken Sie dann rechts neben dem Feld Signaturzertifikat auf Durchsuchen.

    Wenn Sie einen Kanal für einen Messagingport erstellen, für den die Eigenschaft Signatur auf der Seite Sicherheitsinformationen auf S/MIME festgelegt ist, ist das Kontrollkästchen Ausgehendes Dokument signieren automatisch aktiviert.

    Das Dialogfeld Signaturzertifikat auswählen wird angezeigt.

  6. Wählen Sie ein Signaturzertifikat aus.

    Weitere Informationen finden Sie unter Auswählen eines Zertifikats für die ausgehende Signatur.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Wichtig

  • Das Format eines Umschlags, das Sie in einem Messagingport angeben, muss mit dem Format des Dokuments oder der Dokumente im Umschlag übereinstimmen. Das Dokumentformat wird durch die Spezifikation bestimmt, auf die die ausgehende Dokumentdefinition eines zugeordneten Kanals verweist. Wenn Sie beispielsweise einen Umschlag mit einem X12-Format für einen Messagingport auswählen, müssen Sie eine Dokumentdefinition für ausgehende Dokumente für den Kanal auswählen, der auf eine X12-Spezifikation zeigt.

  • Wenn Sie einen Messagingport als offenen Messagingport deklarieren, sollten Sie keine Kanäle für den Messagingport erstellen, die über eine ausgehende Dokumentdefinition mit einer X12- oder EDIFACT-Spezifikation verfügen. Um einen X12- oder EDIFACT-Umschlag zu erstellen, muss der Server über Organisationskennzeichen für Ziel und Quelle verfügen. Ein offener Messagingport gibt kein Zielorganisationskennzeichen an. Darüber hinaus muss in den Dokumenten für einen offenen Messagingport die Zieladresse innerhalb des Dokuments enthalten sein. X12- und EDIFACT-Dokumente enthalten diese Informationen jedoch nicht.

  • Wenn Sie ein WebDAV-Repository-Dialogfeld zum ersten Mal öffnen, wird das WebDAV-Repository auf dem lokalen Server ausgewählt. Das ist auch dann der Fall, wenn der BizTalk-Messaging-Manager mit einer Datenbank auf einem Remoteserver verbunden ist. Wenn Sie zu einem WebDAV-Repository auf einem Remoteserver wechseln, ändert sich die Standardeinstellung auf diesen Server, bis Sie ein neues WebDAV-Repository auswählen. Der Standardserver für alle WebDAV-Repository-Dialogfelder ist der Server, zu dem zuletzt eine Verbindung hergestellt wurde.

Anmerkung

  • Eine Zuordnung wird verwendet, um das eingehende Dokumentformat in das ausgehende Dokumentformat umzuwandeln. Wenn der Spezifikationsverweis des eingehenden Dokuments dem des ausgehenden Dokuments entspricht, ist keine Zuordnung erforderlich. Das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen ist standardmäßig nicht aktiviert. Zuordnungen können mithilfe des BizTalk-Mappers erstellt werden. Weitere Informationen zu Zuordnungen finden Sie unter Verwenden des BizTalk-Mappers.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Grundlegendes zu Empfangsbestätigungen


Festlegen von Eigenschaften für die Dokumentprotokollierung

  1. Aktivieren Sie auf der Seite Dokumentprotokollierung des Kanal-Assistenten im Bereich Eingehendes Dokument protokollieren die entsprechenden Kontrollkästchen:
    • Im systemeigenen Format. Speichert eingehende Dokumente für den Kanal im ursprünglichen Format. Dies ist die Standardeinstellung.

    • Im XML-Format. Speichert eingehende Dokumente für den Kanal im XML-Format.
  2. Aktivieren Sie im Bereich Ausgehendes Dokument protokollieren die entsprechenden Kontrollkästchen:
    • Im systemeigenen Format. Speichert ausgehende Dokumente für den Kanal im ursprünglichen Format.

    • Im XML-Format. Speichert ausgehende Dokumente für den Kanal im XML-Format.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Anmerkungen

  • Bei Dokumenten, die Protokollierung verwenden, existiert eine Größenbeschränkung, deren Überschreiten die Leistung von BizTalk Server erheblich beeinträchtigt. Weitere Informationen zur Größenbeschränkung finden Sie unter Austausch- und Dokumentgrößenbeschränkung.

  • BizTalk Server übersetzt nicht auf XML basierende eingehende Dokumente aus ihrem ursprünglichen systemeigenen Format für die Verarbeitung in ein XML-Format und ausgehende Dokumente aus einem XML-Format in das erforderliche systemeigene Format des Zieles.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften


Festlegen erweiterter Konfigurationseigenschaften

  1. Geben Sie auf der Seite Erweiterte Konfiguration des Kanal-Assistenten beim Erstellen eines Kanals für einen Messagingport, der ein X12- oder EDIFACT-Umschlagformat angibt, im Feld Gruppenkontrollnummer einen Wert ungleich Null ein.

  2. Geben Sie im Bereich Wiederholungsoptionen im Feld Anzahl von Wiederholungen die Anzahl der Versuche ein, die der Server zum erneuten Senden des Dokuments unternehmen soll, wenn keine Empfangsbestätigung empfangen wurde. Geben Sie im Feld Intervall (Minuten) die Anzahl der Minuten zwischen den Wiederholungsversuchen ein.

    Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

  3. Wenn Sie die Transport- oder Umschlagskomponenteneinstellungen für einen Messagingport oder eine Verteilerliste außer Kraft setzen möchten, klicken Sie auf Erweitert.
    • Wenn Sie einen Kanal für einen Messagingport erstellen oder bearbeiten, wird das Dialogfeld Messagingportstandards außer Kraft setzen angezeigt. Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.

    • Wenn Sie einen Kanal für eine Verteilerliste erstellen oder bearbeiten, wird das Dialogfeld Verteilerlistenstandards außer Kraft setzen angezeigt. Weitere Informationen finden Sie unter Außerkraftsetzen von Verteilerlistenstandards.

Wenn Sie einen neuen Kanal erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Kanälen.

Wenn Sie einen vorhandenen Kanal bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Kanälen.

  • Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Wiederholungswarteschlange

Festlegen von Kanaleigenschaften

Grundlegendes zu Empfangsbestätigungen


Auswählen einer Quellorganisation

  1. Klicken Sie auf der Seite Quellorganisation des Kanal-Assistenten rechts neben dem Feld Name auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Organisationen auf eine Organisation und dann auf OK.

Weitere Informationen zum Festlegen von Quellorganisationseigenschaften finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für die Quellorganisation


Auswählen eines Empfangskanals

  1. Aktivieren Sie auf der Seite Quellanwendung oder Quellorganisation des Kanal-Assistenten das Kontrollkästchen Empfangsbestätigung generieren, und klicken Sie dann auf Durchsuchen.

    Das Dialogfeld Empfangskanal auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Empfangskanäle auf einen Empfangskanal, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen von Quellorganisationseigenschaften finden Sie unter Festlegen von Eigenschaften für die Quellorganisation.

Weitere Informationen zum Festlegen von Quellanwendungseigenschaften finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.

Anmerkung

  • Die Liste Verfügbare Empfangskanäle zeigt nur Empfangskanäle an, die Messagingports zugeordnet sind, deren Ziel identisch mit der Quelle für den Kanal ist, den Sie erstellen. Wenn BizTalk Server einen Kanal mit einem angegebenen Empfangskanal aufruft, gibt der Server der ursprünglichen Quelle des Dokuments mithilfe des angegebenen Empfangskanals eine Empfangsbestätigung zurück. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für die Quellanwendung

Festlegen von Eigenschaften für die Quellorganisation

Grundlegendes zu Empfangsbestätigungen


Auswählen einer eingehenden Dokumentdefinition

  1. Klicken Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten rechts neben dem Feld Definitionsname des eingehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Dokumentdefinitionen auf eine Dokumentdefinition, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Anmerkung

  • Beim Erstellen eines Empfangskanals ist sowohl die eingehende als auch die ausgehende Dokumentdefinition standardmäßig auf die BizTalk-Standardempfangsbestätigung festgelegt. Sie können nicht mithilfe einer Zuordnung umgewandelt werden. Um für eine ausgehende Empfangsbestätigung ein anderes Format zu verwenden, müssen Sie eine eingehende Dokumentdefinition erstellen und auswählen, die auf die Standardempfangsbestätigungs-Spezifikation im WebDAV-Repository verweist. Darüber hinaus müssen Sie eine ausgehende Dokumentdefinition erstellen, die auf eine Spezifikation mit dem gewünschten Format für die ausgehende Empfangsbestätigung verweist, sowie eine Zuordnung, die das Format der Empfangsbestätigung umwandelt. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Verwandte Themen

Erstellen von Kanälen

Erstellen von Dokumentdefinitionen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für eingehende Dokumente

Grundlegendes zu Empfangsbestätigungen


Auswählen eines Zertifikats zum Überprüfen der Entschlüsselung eingehender Dokumente

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Entschlüsselungszertifikat des eingehenden Dokuments überprüfen. Klicken Sie dann rechts neben dem Feld Zertifikat zum Überprüfen der Entschlüsselung auf Durchsuchen.

    Das Dialogfeld Zertifikat zum Überprüfen der Entschlüsselung auswählen wird angezeigt.

  2. Klicken Sie in der Liste Zertifikatname auf einen Zertifikatnamen, und klicken Sie auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Anmerkungen

  • Alle Zertifikate werden im Informationsspeicher des lokalen Computers gespeichert. Um Zertifikate für die S/MIME-Komponenten mithilfe des BizTalk-Messaging-Managers zu konfigurieren, müssen Sie über ein Benutzerkonto in der Windows 2000-Gruppe Administratoren verfügen, und die BizTalk-Messagingdienste müssen als lokales Systemkonto oder als Benutzerkonto in der Windows 2000-Gruppe Administratoren ausgeführt werden.

  • Dokumente werden beim Empfang durch BizTalk Server entschlüsselt, so dass der Server die erforderlichen Daten erhält, um den entsprechenden Kanal zu identifizieren. Das Zertifikat, das Sie im Kanal angeben, überprüft, ob die Entschlüsselung korrekt durchgeführt wurde.

  • Alle Zertifikate müssen mit einem eindeutigen Namen bezeichnet werden. Wenn zwei oder mehr Zertifikate denselben Namen haben, kann nur eines der Zertifikate ausgewählt werden. Nachdem eines der Zertifikate ausgewählt wurde, werden andere Zertifikate mit demselben Namen nicht mehr in der Liste angezeigt.

    Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für eingehende Dokumente


Auswählen eines Zertifikats zum Überprüfen der Signatur eingehender Dokumente

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Signaturzertifikat des eingehenden Dokuments überprüfen. Klicken Sie dann rechts neben dem Feld Zertifikat zum Überprüfen der Signatur auf Durchsuchen.

    Das Dialogfeld Zertifikat zum Überprüfen der Signatur auswählen wird angezeigt.

  2. Klicken Sie in der Liste Zertifikatname auf einen Zertifikatnamen, und klicken Sie auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Anmerkungen

  • Alle Zertifikate werden im Informationsspeicher des lokalen Computers gespeichert. Um Zertifikate für die S/MIME-Komponenten mithilfe des BizTalk-Messaging-Managers zu konfigurieren, müssen Sie über ein Benutzerkonto in der Windows 2000-Gruppe Administratoren verfügen, und die BizTalk-Messagingdienste müssen als lokales Systemkonto oder als Benutzerkonto in der Windows 2000-Gruppe Administratoren ausgeführt werden.

  • Alle Zertifikate müssen mit einem eindeutigen Namen bezeichnet werden. Wenn zwei oder mehr Zertifikate denselben Namen haben, kann nur eines der Zertifikate ausgewählt werden. Nachdem eines der Zertifikate ausgewählt wurde, werden andere Zertifikate mit demselben Namen nicht mehr in der Liste angezeigt.

    Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für eingehende Dokumente


Auswählen einer ausgehenden Dokumentdefinition

  1. Klicken Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten rechts neben dem Feld Definitionsname des ausgehenden Dokuments auf Durchsuchen.

    Das Dialogfeld Dokumentdefinition auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Dokumentdefinitionen auf eine Dokumentdefinition, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für ausgehende Dokumente finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

Anmerkung

  • Beim Erstellen eines Empfangskanals ist sowohl die eingehende als auch die ausgehende Dokumentdefinition standardmäßig auf die BizTalk-Standardempfangsbestätigung festgelegt. Sie können nicht mithilfe einer Zuordnung umgewandelt werden. Um für eine ausgehende Empfangsbestätigung ein anderes Format zu verwenden, müssen Sie eine eingehende Dokumentdefinition erstellen und auswählen, die auf die Standardempfangsbestätigungs-Spezifikation im WebDAV-Repository verweist. Darüber hinaus müssen Sie eine ausgehende Dokumentdefinition erstellen, die auf eine Spezifikation mit dem gewünschten Format für die ausgehende Empfangsbestätigung verweist, sowie eine Zuordnung, die das Format der Empfangsbestätigung umwandelt. Weitere Informationen zu Empfangsbestätigungen finden Sie unter Grundlegendes zu Empfangsbestätigungen.

Verwandte Themen

Erstellen von Kanälen

Erstellen von Dokumentdefinitionen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für ausgehende Dokumente

Grundlegendes zu Empfangsbestätigungen


Auswählen einer Zuordnung

  1. Aktivieren Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen, und klicken Sie dann rechts neben dem Feld Verweis zuordnen auf Durchsuchen.

    Das Dialogfeld Eine Zuordnung aus dem WebDAV-Repository auswählen wird angezeigt.

  2. Wenn Sie den Server ändern möchten, führen Sie im Feld Server eine der folgenden Aktionen aus:
    • Klicken Sie auf einen Server in der Liste.

    • Geben Sie den Namen eines Servers ein, und drücken Sie die EINGABETASTE.
  3. Doppelklicken Sie auf den Ordner, der die gewünschte Zuordnung enthält, klicken Sie auf die Zuordnung, und klicken Sie dann auf Öffnen.

Weitere Informationen zum Festlegen von Eigenschaften für ausgehende Dokumente finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

Wichtig

  • Wenn Sie ein WebDAV-Repository-Dialogfeld zum ersten Mal öffnen, wird das WebDAV-Repository auf dem lokalen Server ausgewählt. Das ist auch dann der Fall, wenn der BizTalk-Messaging-Manager mit einer Datenbank auf einem Remoteserver verbunden ist. Wenn Sie zu einem WebDAV-Repository auf einem Remoteserver wechseln, ändert sich die Standardeinstellung auf diesem Server, bis Sie ein neues WebDAV-Repository auswählen. Der Standardserver für alle WebDAV-Repository-Dialogfelder ist der Server, zu dem zuletzt eine Verbindung hergestellt wurde.

Anmerkungen

  • Wenn Sie http://localhost als Server auswählen, konvertiert der BizTalk-Messaging-Manager diesen automatisch in den Namen des lokalen Computers.

  • Beim Speichern eines Kanals, der auf eine Zuordnung verweist, die sich außerhalb der lokalen Domäne befindet, wird möglicherweise eine Fehlermeldung angezeigt. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Verwenden des BizTalk-Mappers

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für ausgehende Dokumente


Auswählen eines Zertifikats für die ausgehende Signatur

  1. Aktivieren Sie auf der Seite Ausgehendes Dokument des Kanal-Assistenten das Kontrollkästchen Ausgehendes Dokument signieren, und klicken Sie dann rechts neben dem Feld Signaturzertifikat auf Durchsuchen.

    Das Dialogfeld Signaturzertifikat auswählen wird angezeigt.

  2. Klicken Sie in der Liste Zertifikatname auf einen Zertifikatnamen, und klicken Sie auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für ausgehende Dokumente finden Sie unter Festlegen von Eigenschaften für ausgehende Dokumente.

Anmerkungen

  • Alle Zertifikate werden im Informationsspeicher des lokalen Computers gespeichert. Um Zertifikate für die S/MIME-Komponenten mithilfe des BizTalk-Messaging-Managers zu konfigurieren, müssen Sie über ein Benutzerkonto in der Windows 2000-Gruppe Administratoren verfügen, und die BizTalk-Messagingdienste müssen als lokales Systemkonto oder als Benutzerkonto in der Windows 2000-Gruppe Administratoren ausgeführt werden.

  • Alle Zertifikate müssen mit einem eindeutigen Namen bezeichnet werden. Wenn zwei oder mehr Zertifikate denselben Namen haben, kann nur eines der Zertifikate ausgewählt werden. Nachdem eines der Zertifikate ausgewählt wurde, werden andere Zertifikate mit demselben Namen nicht mehr in der Liste angezeigt.

    Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen von Eigenschaften für ausgehende Dokumente


Außerkraftsetzen von Messagingportstandards

  1. Klicken Sie auf der Seite Erweiterte Konfiguration des Kanal-Assistenten auf Erweitert.

    Wenn Sie einen Kanal für einen Messagingport erstellen oder bearbeiten, wird das Dialogfeld Messagingportstandards außer Kraft setzen angezeigt.

  2. Klicken Sie auf der Registerkarte Primärer Transport auf Eigenschaften.

    Das Dialogfeld BizTalk Komponente-Eigenschaften wird angezeigt.

  3. Ändern Sie die Eigenschaften der Transportkomponente, die Sie außer Kraft setzen möchten, und klicken Sie dann auf OK.

  4. Wenn der Messagingport über einen Umschlag verfügt, dessen Einstellungen Sie außer Kraft setzen möchten, klicken Sie auf die Registerkarte Umschlag, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld BizTalk Komponente-Eigenschaften wird angezeigt.

  5. Ändern Sie die Eigenschaften der Umschlagkomponente, die Sie außer Kraft setzen möchten, und klicken Sie dann auf OK.

Weitere Informationen zum Festlegen erweiterter Eigenschaften finden Sie unter Festlegen erweiterter Konfigurationseigenschaften.

Wichtig

  • Das Außerkraftsetzen der Transport- und Umschlageigenschaften für einen Messagingport ist ein erweitertes Feature. Wenn Sie über keine grundlegenden Kenntnisse in Bezug auf die Eigenschaften der Transport- und Umschlagkomponenten in diesen Dialogfeldern verfügen, sollten Sie diese nicht ändern.

  • Wenn Sie einen Umschlag mit einem benutzerdefinierten Format im Messagingport angegeben haben, müssen Sie die benutzerdefinierte Serialisierungskomponente mithilfe der erweiterten Konfigurationseigenschaften konfigurieren.

Anmerkungen

  • Wenn Sie Eigenschaften von Messagingports in einem Kanal außer Kraft setzen, wirken sich die Änderungen nur auf den betreffenden Kanal aus.

  • Die in einem Messagingport festgelegte Transportadresse kann nicht außer Kraft gesetzt werden.

  • Die Standardeinstellung für die HTTP-Transportkomponente ist die Verwendung des HTTP-Proxyservers. Dies ist die korrekte Einstellung, um Daten an Websites außerhalb des Firewalls Ihres Unternehmens zu transportieren. Um Daten an Websites zu transportieren, die sich innerhalb des Firewalls Ihres Unternehmens befinden (also im Intranet), verwenden Sie dieses Verfahren, um die Standardeinstellung außer Kraft zu setzen.

  • Für die HTTPS-Transportkomponente sollten Sie nur Zertifikate verwenden, die für die Clientauthentifizierung spezifiziert sind. Zertifikate, die für alle Zwecke angegeben sind, werden nicht in der Liste angezeigt.

  • Die Standardeinstellung für die Dateitransportkomponente ist das Anhängen von Dateien. Wenn Sie den Transporttyp File mit Standardeinstellungen in einem Messagingport auswählen und auf dem Computer, auf dem BizTalk Server installiert ist, Antivirensoftware verwenden und wenn Sie außerdem mehrere Dateien mit exakt dem gleichen Namen gleichzeitig an denselben Dateispeicherort senden, reagiert BizTalk Server möglicherweise nicht mehr und muss neu gestartet werden. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Dateitransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern. Sie können dieses Problem auch beheben, indem Sie für jede verarbeitete Dokumentinstanz eine eindeutige Datei mithilfe des Dateipfadformats im Messagingport erstellen: file://C:\dir\file%tracking_id%.xml. Weitere Informationen finden Sie unter Angeben einer Transportadresse.

  • Die Standardeinstellung für die Dateitransportkomponente ist das Anhängen von Dateien. Wenn Sie den Transporttyp File mit Standardeinstellungen und einen Umschlag mit dem Umschlagformat RELIABLE in einem Messagingport auswählen und dann mehrere Dateien gleichzeitig an denselben Dateispeicherort senden, können unerwartete Ergebnisse beim Analysieren auftreten. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Dateitransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern.

  • Wenn der im Messagingport angegebene Umschlag ein benutzerdefiniertes Format aufweist und Sie eine benutzerdefinierte Serialisierungskomponente erstellt und registriert haben, können Sie die Eigenschaften der benutzerdefinierten Serialisierungskomponente mithilfe dieses Verfahrens konfigurieren.

  • Der standardmäßige Syntaxbezeichner für einen EDIFACT-Umschlag ist UNOA (Großbuchstaben im lateinischen Alphabet). Wenn die Daten eine andere Syntax erfordern, wählen Sie mithilfe dieses Verfahrens einen anderen Syntaxbezeichner aus.

  • Wenn Sie EDIFACT-Versionsindikatoren verwenden, dürfen Sie in die Daten keine Versionsindikatorzeichen einschließen. Sollte dies doch der Fall sein, kann dies dazu führen, dass die Daten die Begrenzungen der physischen Zeichengröße für Felder überschreiten.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen erweiterter Konfigurationseigenschaften

Festlegen von Kanaleigenschaften


Außerkraftsetzen von Verteilerlistenstandards

  1. Klicken Sie auf der Seite Erweiterte Konfiguration des Kanal-Assistenten auf Erweitert.

    Wenn Sie einen Kanal für eine Verteilerliste erstellen oder bearbeiten, wird das Dialogfeld Verteilerlistenstandards außer Kraft setzen angezeigt.

  2. Wählen Sie in der Liste Messagingport auswählen einen Messagingport aus, den Sie außer Kraft setzen möchten, und klicken Sie dann auf Außer Kraft setzen.

    Das Dialogfeld Messagingportstandards außer Kraft setzen wird angezeigt.

  3. Setzen Sie die Eigenschaften der Transport- und Umschlagkomponente für den ausgewählten Messagingport außer Kraft.

    Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.

  4. Wenn Sie die außer Kraft zu setzenden Messagingports geändert haben, klicken Sie auf Schließen.

Weitere Informationen zum Festlegen erweiterter Eigenschaften finden Sie unter Festlegen erweiterter Konfigurationseigenschaften.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Außerkraftsetzen von Messagingportstandards

Festlegen erweiterter Konfigurationseigenschaften

Festlegen von Kanaleigenschaften


Festlegen der Überwachung von Eigenschaften eingehender Dokumente

Das Dialogfeld Eingehende Dokumente überwachen listet die Spezifikationsfelder für das eingehende Dokument sowie alle globalen Überwachungsfelder auf, die in der Dokumentdefinition ausgewählt sind.

Wenn Sie in diesem Dialogfeld Spezifikationsfelder auswählen, setzen diese Felder die globalen Überwachungsfelder außer Kraft, jedoch nur für diesen Kanal. Für jede verarbeitete Dokumentinstanz werden die im Kanal ausgewählten Felder in der Überwachungsdatenbank statt in den globalen Überwachungsfeldern protokolliert.

Dieser Abschnitt beschreibt das Auswählen oder Entfernen von Spezifikationsfeldern des eingehenden Dokuments in einem Kanal.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Auswählen von Spezifikationsfeldern in einem Kanal

  • Entfernen von Spezifikationsfeldern in einem Kanal

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Festlegen von Kanaleigenschaften

Festlegen globaler Überwachungseigenschaften

Festlegen von Eigenschaften für eingehende Dokumente


Auswählen von Spezifikationsfeldern in einem Kanal

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument überwachen, und klicken Sie dann auf Überwachen.

    Das Dialogfeld Eingehende Dokumente überwachen wird angezeigt.

  2. Doppelklicken Sie in der Struktur Spezifikationsfelder auf einen beliebigen Datensatz, um die Anzeige zu erweitern.

  3. Wählen Sie ein Spezifikationsfeld aus, das Sie zur Liste Zu überwachende Felder hinzufügen möchten, und führen Sie dann eins der folgenden Verfahren aus:
    Felddatentyp | Verfahren
    Integer | Klicken Sie auf Integer. Sie können zwei Felder als ganze Zahl hinzufügen.
    Real | Klicken Sie auf Real. Sie können zwei Felder als reelle Zahl hinzufügen.
    Date | Klicken Sie auf Date. Sie können zwei Felder als Datum hinzufügen.
    Text | Klicken Sie auf Text. Sie können zwei Felder als Text hinzufügen.
    Benutzerdefiniert | Klicken Sie auf Benutzerdefiniert. Sie können beliebig viele Felder als benutzerdefinierten Datentyp hinzufügen. Die Felder werden als verkettete XML-Zeichenfolge mit Tags für jedes Feld gespeichert.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Wichtig

  • Wenn Sie in diesem Dialogfeld Spezifikationsfelder auswählen, setzen diese Felder die globalen Überwachungsfelder außer Kraft, jedoch nur für diesen Kanal. Für jede verarbeitete Dokumentinstanz werden die im Kanal ausgewählten Felder in der Überwachungsdatenbank statt in den globalen Überwachungsfeldern protokolliert.

Anmerkungen

  • Diesem Feld muss in der Spezifikation der entsprechende Datentyp zugewiesen werden, um ein Spezifikationsfeld zur Überwachung als Datentyp Integer, Real oder Date auszuwählen. Weitere Informationen zum Zuweisen eines Datentyps zu einem Spezifikationsfeld finden Sie unter Festlegen von Deklarationseigenschaften.

  • Spezifikationsfelder, denen in der Spezifikation kein Datentyp zugewiesen wurde, können nur als Text- oder benutzerdefinierter Datentyp überwacht werden.

  • Wenn ein Spezifikationsfeld, das Sie überwachen möchten, den Character-Datentyp aufweist, können Sie dieses Feld nur als einen benutzerdefinierten Datentyp überwachen.

  • Es können nur zwei Spezifikationsfelder eines bestimmten Datentyps ausgewählt werden. Es kann eine unbeschränkte Anzahl von Feldern als benutzerdefinierter Datentyp ausgewählt werden.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Entfernen von Spezifikationsfeldern in einem Kanal

Festlegen von Kanaleigenschaften

Festlegen globaler Überwachungseigenschaften

Festlegen der Überwachung von Eigenschaften eingehender Dokumente

Überwachen von Dokumentdatenfeldern


Entfernen von Spezifikationsfeldern in einem Kanal

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument überwachen, und klicken Sie dann auf Überwachen.

    Das Dialogfeld Eingehende Dokumente überwachen wird angezeigt.

  2. Klicken Sie in der Liste Zu überwachende Felder auf das Spezifikationsfeld oder die Spezifikationsfelder, das bzw. die Sie entfernen möchten, und klicken Sie dann auf Entfernen.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Anmerkung

  • Wenn Sie ein Feld aus der Liste der zu überwachenden Felder entfernen, wird es nur aus der Liste in diesem Kanal und nicht aus der Spezifikation entfernt.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten von Kanälen

Auswählen von Spezifikationsfeldern in einem Kanal

Festlegen von Kanaleigenschaften

Festlegen globaler Überwachungseigenschaften

Festlegen der Überwachung von Eigenschaften eingehender Dokumente

Überwachen von Dokumentdatenfeldern


Festlegen von Eigenschaften für die Kanalfilterung

Ein Kanalfilterausdruck ist ein XPath-Ausdruck, mit dem bestimmt werden kann, ob ein Kanal auf der Grundlage eines angegebenen Feldes oder angegebener Felder im Dokument aufgerufen wird. Wenn Microsoft BizTalk Server ein Dokument verarbeitet, wird der Wert des angegebenen Feldes oder der angegebenen Felder im Vergleich zum Kanalfilterausdruck ausgewertet. Wenn der Ausdruck sich als wahr (TRUE) erweist, wird der Kanal aufgerufen. Ist der Ausdruck falsch (FALSE), wird der Kanal nicht aufgerufen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen eines Kanalfilterausdrucks

  • Bearbeiten eines Kanalfilterausdrucks

  • Entfernen eines Kanalfilterausdrucks

Verwandtes Thema

Festlegen von Eigenschaften für eingehende Dokumente


Hinzufügen eines Kanalfilterausdrucks

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument filtern, und klicken Sie dann auf Filtern.

    Das Dialogfeld Kanalfilterausdrücke wird angezeigt.

  2. Doppelklicken Sie in der Struktur Feld auswählen auf einen beliebigen Knoten, um die Anzeige zu erweitern.

  3. Klicken Sie auf ein Spezifikationsfeld, dass Sie zum Erstellen eines Filterausdrucks verwenden möchten, und klicken Sie dann auf Hinzufügen.

    Das Dialogfeld Ausdruckseigenschaften wird angezeigt.

  4. Klicken Sie in der Liste Operator auf einen Operator:
    Operator Symbol
    Gleich (Standard) =
    Ungleich !=
    Kleiner als <
    Kleiner gleich <=
    Größer als >
    Größer gleich >=

  5. Geben Sie im Feld Wert einen Wert für den Ausdruck ein, und klicken Sie auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Wichtig

  • Ein Kanalfilterausdruck muss ein gültiger XPath-Ausdruck sein. Die Schaltfläche Hinzufügen kann verwendet werden, um eine Klausel zu erstellen, die ein Spezifikationsfeld enthält, und um diese in einen Ausdruck einzufügen. Sie generiert jedoch nicht die korrekte Syntax, die für einen gültigen XPath-Ausdruck erforderlich ist. Weitere Informationen zu XPath-Ausdrücken finden Sie unter Kanalfilter sowie in der Microsoft-Website unter der Adresse (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach dem Schlüsselwort "XPath".

Anmerkungen

  • Sie können einen Ausdruck auch direkt in der Liste Ausdrücke eingeben.

  • Um ein Spezifikationsfeld für einen Kanalfilterausdruck auszuwählen, muss dem Feld in der Spezifikation ein Datentyp zugewiesen sein. Weitere Informationen zum Zuweisen eines Datentyps zu einem Feld finden Sie unter Festlegen von Deklarationseigenschaften.

  • Wenn das Spezifikationsfeld, das Sie zum Erstellen eines Ausdrucks verwenden, einen Boolean-Datentyp aufweist, können Sie die Textzeichenfolgen TRUE oder FALSE nicht im Wert des Ausdrucks verwenden. Stattdessen müssen Sie einen numerischen Wert verwenden , -1 für TRUE und 0 für FALSE.

  • Wenn das Spezifikationsfeld, das Sie zum Erstellen eines Ausdrucks verwenden, einen Date-Datentyp aufweist, müssen Sie den Wert im folgenden Format eingeben, einschließlich der Trennstriche: JJJJ-MM-TT.

  • Wenn Sie einen Filter für einen Date/Time-Datentyp (dateTime, dateTime.tz, time, time.tz) verwenden möchten, müssen Sie diesen manuell in den XPath-Ausdruck eingeben. Beispiel: self::node()[@ATTDATETIME = "2000-03-15T10:10:10"] where ATTDATETIME is the date/time format type.

Verwandte Themen

Erstellen von Kanälen

Bearbeiten eines Kanalfilterausdrucks

Bearbeiten von Kanälen

Entfernen eines Kanalfilterausdrucks

Festlegen von Eigenschaften für die Kanalfilterung

Festlegen von Kanaleigenschaften


Bearbeiten eines Kanalfilterausdrucks

  1. Aktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument filtern, und klicken Sie dann auf Filtern.

    Das Dialogfeld Kanalfilterausdrücke wird angezeigt.

  2. Bearbeiten Sie den Ausdruck in der Liste Ausdrücke, und klicken Sie auf OK.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Wichtig

  • Ein Kanalfilterausdruck muss ein gültiger XPath-Ausdruck sein. Weitere Informationen zu XPath-Ausdrücken finden Sie unter Kanalfilter sowie in der Microsoft-Website unter der Adresse (msdn.microsoft.com/library/default.asp). Suchen Sie in der Website nach dem Schlüsselwort "XPath".

Verwandte Themen

Hinzufügen eines Kanalfilterausdrucks

Entfernen eines Kanalfilterausdrucks

Festlegen von Eigenschaften für die Kanalfilterung


Entfernen eines Kanalfilterausdrucks

  • Deaktivieren Sie auf der Seite Eingehendes Dokument des Kanal-Assistenten das Kontrollkästchen Eingehendes Dokument filtern.

Weitere Informationen zum Festlegen von Eigenschaften für eingehende Dokumente finden Sie unter Festlegen von Eigenschaften für eingehende Dokumente.

Verwandte Themen

Hinzufügen eines Kanalfilterausdrucks

Erstellen von Kanälen

Bearbeiten eines Kanalfilterausdrucks

Bearbeiten von Kanälen

Festlegen von Eigenschaften für die Kanalfilterung

Festlegen von Kanaleigenschaften


Erstellen und Verwalten von Messagingports

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Messagingports bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundlegendes zu Messagingports lesen, um Messagingports vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Messagingports

  • Suchen nach Messagingports

  • Bearbeiten von Messagingports

  • Löschen von Messagingports

  • Festlegen von Messagingporteigenschaften


Erstellen von Messagingports

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Zeigen Sie im Menü Datei auf Neu, zeigen Sie auf Messagingport, und führen Sie dann einen der folgenden Schritte durch:
    • Klicken Sie auf Zu einer Organisation, um einen Messagingport zur Organisation eines Handelspartners zu erstellen.

    • Klicken Sie auf Zu einer Anwendung, um einen Messagingport zu einer internen Anwendung zu erstellen.

    Der Messagingport-Assistent wird geöffnet.

  3. Legen Sie auf der Seite Allgemeine Informationen die Eigenschaften fest, und klicken Sie auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Informationseigenschaften für den Messagingport.

  4. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie einen Messagingport zu einer bestimmten Organisation erstellen, legen Sie die Eigenschaften auf der Seite Zielorganisation fest, und klicken Sie auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

    • Wenn Sie einen offenen Messagingport erstellen, klicken Sie auf Offenes Ziel, und klicken Sie auf Weiter.

      Für einen offenen Messagingport müssen die Transport- und die Zielinformationen entweder im Dokument selbst oder in einem Parameter enthalten sein, der zusammen mit dem Dokument versendet wird. Weitere Informationen finden Sie unter Submitting.

    • Wenn Sie einen Messagingport zu einer Anwendung erstellen, legen Sie die Eigenschaften auf der Seite Zielanwendung fest, und klicken Sie auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  5. Legen Sie auf der Seite Umschlagsinformationen die Eigenschaften fest, und klicken Sie auf Weiter.

    Weitere Information finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

  6. Legen Sie auf der Seite Sicherheitsinformationen die Eigenschaften fest, und klicken Sie auf Weiter.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Sicherheitseinstellungen.

  7. Wenn Sie nicht direkt mit dem Erstellen eines Kanals im Kanal-Assistenten fortfahren möchten, deaktivieren Sie das Kontrollkästchen Kanal für diesen Messagingport erstellen. Klicken Sie andernfalls in der Liste Kanaltyp auf einen der folgenden Kanaltypen:
    • Von einer Organisation

    • Von einer Anwendung
  8. Klicken Sie auf der Seite Sicherheitsinformationen auf Fertig stellen, um den Messagingport-Assistenten zu schließen, nachdem Sie alle Eigenschaften des Messagingports festgelegt haben.

Wichtig

  • Wenn Sie einen Messagingport als einen offenen Messagingport festlegen, erstellen Sie für den Messagingport keine Kanäle, deren Definition für das ausgehende Dokument eine X12- oder EDIFACT-Spezifikation enthält. Der Server muss über ein Quell- und ein Zielorganisationskennzeichen verfügen, um einen X12- oder EDIFACT-Umschlag zu erstellen. Ein offener Messagingport gibt kein Zielorganisationskennzeichen an. Darüber hinaus muss in den Dokumenten für einen offenen Messagingport die Zieladresse innerhalb des Dokuments enthalten sein, X12- und EDIFACT-Dokumente enthalten diese Informationen jedoch nicht.

Anmerkungen

  • Sie können einen Messagingport nicht mit dem reservierten Systemnamen Port für Reliable Messaging-Bestätigung bezeichnen.

  • Wenn Sie einen Messagingport und einen Kanal für eine Pass-Through-Versendung von Daten erstellen, können Sie nur das Dienstfenster, den Wiederholungszähler und die Intervallfeatures des Kanals sowie die Transportfeatures des zugeordneten Messagingports verwenden. Sie können die Überprüfung der Decodierung oder Entschlüsselung, das Filtern, die Dokumentüberwachung und die Zuordnungsfeatures des Kanals nicht verwenden.

Verwandte Themen

Erstellen und Verwalten von Kanälen

Löschen von Messagingports

Bearbeiten von Messagingports

Suchen nach Messagingports

Festlegen von Messagingporteigenschaften

Grundlegendes zu Messagingports


Suchen nach Messagingports

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Klicken Sie im Bereich Nach anderen Elementen suchen auf Messagingports.

  3. Führen Sie eine oder mehrere der folgenden Aktionen durch:
    • Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um alle Messagingports zu suchen.

    • Geben Sie in das Feld Messagingportname den Namen des Messagingports ein, den Sie suchen möchten, und klicken Sie auf Jetzt suchen, um einen Messagingport mit einem bestimmten Namen zu suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Klicken Sie in der Liste Ziel auf einen Zieltyp, und klicken Sie auf Jetzt suchen, um einen Messagingport zu einem bestimmten Typ von Ziel zu suchen.

Anmerkungen

  • Sie können mehr als ein Suchkriterium festlegen, bevor Sie auf Jetzt suchen klicken.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Sie können die Anzahl der in einer Suche zurückgegebenen Elemente verringern, indem Sie Suchkriterien verwenden.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Sie können die folgenden Platzhalterzeichen für die Suchkriterien verwenden.
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Löschen von Messagingports

Bearbeiten von Messagingports

Grundlegendes zu Messagingports


Bearbeiten von Messagingports

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Klicken Sie in der Liste Messagingportname auf den Messagingport, den Sie bearbeiten möchten.

    Weitere Informationen zum Suchen nach Messagingports finden Sie unter Suchen nach Messagingports.

  3. Klicken Sie im Menü Datei auf Bearbeiten.

    Der Messagingport-Assistent wird geöffnet.

  4. Bearbeiten Sie auf der Seite Allgemeine Informationen die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Informationseigenschaften für den Messagingport.

    Nach dem Bearbeiten der Eigenschaften auf einer beliebigen Seite können Sie auf Fertig stellen klicken, um den Messagingport-Assistenten zu schließen, oder auf Weiter, um weitere Eigenschaften des Messagingports zu bearbeiten.

  5. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie einen Messagingport zu einer Organisation bearbeiten, bearbeiten Sie die erforderlichen Eigenschaften auf der Seite Zielorganisation, und klicken Sie auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

    • Wenn Sie einen Messagingport zu einer Anwendung bearbeiten, bearbeiten Sie die entsprechenden Eigenschaften auf der Seite Zielanwendung, und klicken Sie auf Weiter. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  6. Bearbeiten Sie auf der Seite Umschlagsinformationen die entsprechenden Eigenschaften, und klicken Sie auf Weiter.

    Weitere Information finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

  7. Bearbeiten Sie auf der Seite Sicherheitsinformationen die entsprechenden Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Sicherheitseinstellungen.

  8. Wenn Sie nicht direkt mit dem Erstellen eines Kanals im Kanal-Assistenten fortfahren möchten, deaktivieren Sie das Kontrollkästchen Kanal für diesen Messagingport erstellen. Klicken Sie andernfalls in der Liste Kanaltyp auf einen der folgenden Kanaltypen:
    • Von einer Organisation

    • Von einer Anwendung
  9. Nachdem Sie alle entsprechenden Eigenschaften des Messagingports bearbeitet haben, können Sie auf einer der Seiten auf Fertig stellen klicken, um den Messagingport-Assistenten zu schließen.

Anmerkung

  • Sie können einen Messagingport nicht mit dem reservierten Systemnamen Port für Reliable Messaging-Bestätigung bezeichnen.

Verwandte Themen

Erstellen und Verwalten von Kanälen

Erstellen von Messagingports

Löschen von Messagingports

Festlegen von Messagingporteigenschaften

Grundlegendes zu Messagingports


Löschen von Messagingports

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Klicken Sie in der Liste Messagingportname auf den Messagingport, den Sie löschen möchten.

    Weitere Informationen zum Suchen nach Messagingports finden Sie unter Suchen nach Messagingports.

  3. Klicken Sie im Menü Datei auf Löschen.

Anmerkungen

  • Wenn Sie Kanäle für einen Messagingport erstellt haben, können Sie den Messagingport nicht löschen, bevor nicht die ihm zugeordneten Kanäle gelöscht sind.

  • Sie können die einem Messagingport zugeordneten Kanäle suchen, indem Sie mit der rechten Maustaste auf den Messagingport klicken und dann auf Kanäle suchen klicken.

Verwandte Themen

Erstellen und Verwalten von Kanälen

Erstellen von Messagingports

Bearbeiten von Messagingports

Grundlegendes zu Messagingports


Festlegen von Messagingporteigenschaften

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Konfigurieren der Eigenschaften eines Messagingports bereit.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von allgemeinen Informationseigenschaften für den Messagingport

  • Festlegen von Eigenschaften für die Zielorganisation

  • Festlegen von Eigenschaften für die Zielanwendung

  • Festlegen von Eigenschaften für die Umschlagsinformationen

  • Festlegen von Eigenschaften für die Sicherheitseinstellungen

  • Auswählen einer Zielorganisation

  • Auswählen eines Verschlüsselungszertifikats

  • Festlegen von Transporteigenschaften

  • Festlegen von Umschlagstrennzeichen


Festlegen von allgemeinen Informationseigenschaften für den Messagingport

  1. Geben Sie im Messagingport-Assistenten auf der Seite Allgemeine Informationen in das Feld Name den Namen des Messagingports ein.

  2. Geben Sie in das Feld Kommentare einen Kommentar zu dem Messagingport ein, und klicken Sie auf Weiter.

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Verwandte Themen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften


Festlegen von Eigenschaften für die Zielorganisation

  1. Führen Sie im Messagingport-Assistenten auf der Seite Zielorganisation einen der folgenden Schritte durch:
    • Klicken Sie auf Offenes Ziel, um einen offenen Messagingport zu erstellen, und klicken Sie auf Weiter.

      Für einen offenen Messagingport müssen die Transport- und die Zielinformationen entweder im Dokument selbst oder in Parametern enthalten sein, die zusammen mit dem Dokument versendet werden. Weitere Informationen finden Sie unter Submitting.

    • Klicken Sie auf Organisation, um die Organisation eines bestimmten Handelspartners als Ziel anzugeben, und fahren Sie dann mit Schritt 2 fort.
  2. Klicken Sie im Bereich Organisation auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  3. Klicken Sie auf eine Organisation, und klicken Sie dann auf OK.

    Weitere Informationen finden Sie unter Auswählen einer Zielorganisation.

  4. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  5. Legen Sie die Eigenschaften des primären Transports fest.

    Weitere Informationen finden Sie unter Festlegen von Transporteigenschaften.

  6. Wenn Sie die Zeit begrenzen möchten, innerhalb derer Dokumente transportiert werden können, aktivieren Sie im Bereich Primärer Transport das Kontrollkästchen Dienstfenster.

    Klicken Sie dann in die Felder Von und Bis, und geben Sie einen Wert ein, oder klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.

  7. Wenn Sie einen sekundären Transport angeben möchten, klicken Sie im Bereich Sekundärer Transport auf Durchsuchen.

    Das Dialogfeld Sekundärer Transport wird angezeigt.

  8. Legen Sie die Eigenschaften des sekundären Transports fest.

    Weitere Informationen finden Sie unter Festlegen von Transporteigenschaften.

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Wichtig

  • Wenn Sie einen Messagingport als einen offenen Messagingport festlegen, erstellen Sie keine Kanäle für den Messagingport, die eine Definition für ausgehende Dokumente mit einer X12- oder EDIFACT-Spezifikation enthalten. Der Server muss über ein Quell- und ein Zielorganisationskennzeichen verfügen, um einen X12- oder EDIFACT-Umschlag zu erstellen. Ein offener Messagingport gibt kein Zielorganisationskennzeichen an. Darüber hinaus muss in den Dokumenten für einen offenen Messagingport die Zieladresse innerhalb des Dokuments enthalten sein, X12- und EDIFACT-Dokumente enthalten diese Informationen jedoch nicht.

Anmerkung

  • Die Stunden des Dienstfensters werden im UTC-Format angezeigt und entsprechen der Zeit auf dem Server.

Verwandte Themen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften


Festlegen von Eigenschaften für die Zielanwendung

  1. Führen Sie im Messagingport-Assistenten auf der Seite Zielanwendung einen der folgenden Schritte durch:
    • Klicken Sie auf Neuer XLANG-Ablaufplan, um einen Port in einer neuen Instanz eines bestimmten XLANG-Ablaufplanes als Ziel anzugeben. Geben Sie im Feld Moniker für Ablaufplan den Moniker des angegebenen Ablaufplanes ein, oder klicken Sie auf Durchsuchen, um den Pfad festzulegen. Geben Sie dann im Feld Portname den Namen des in diesem Ablaufplan vorgesehenen Ports ein, an den das Dokument gesendet werden soll.

      Die Syntax für Moniker für den Ablaufplan lautet wie folgt:

      sked://[localhost][!GroupManager][/DateiPfad][/PortName]

      Sie können XLANG-Ablaufpläne nur auf dem lokalen Computer aktivieren.

      Weitere Informationen zu Monikers finden Sie unter Monikersyntax.

    • Klicken Sie auf Aktiver XLANG-Ablaufplan, um eine aktive XLANG-Ablaufplaninstanz als Ziel festzulegen. Verwenden Sie diese Option nur, um eine Nachricht an einen aktiven XLANG-Ablaufplan zu transportieren, wenn ein Handelspartner die Nachricht mit einem HTTP-Transport an eine speziell konfigurierte ASP (Active Server Page) zurücksendet. Weitere Informationen finden Sie unter Integrieren der BizTalk-Dienste.

    • Klicken Sie auf Anwendung, um eine Anwendung der eigenen Organisation als Ziel festzulegen, und klicken Sie dann in der Liste Name auf eine Anwendung.
  2. Falls Sie eine Anwendung als Ziel ausgewählt haben, führen Sie die Schritte 3 bis 5 aus. Klicken Sie andernfalls auf Weiter.

  3. Klicken Sie im Bereich Primärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport wird angezeigt.

  4. Legen Sie die Eigenschaften des primären Transports fest.

    Weitere Informationen finden Sie unter Festlegen von Transporteigenschaften.

  5. Wenn Sie die Zeit begrenzen möchten, innerhalb derer Dokumente transportiert werden können, aktivieren Sie im Bereich Primärer Transport das Kontrollkästchen Dienstfenster.

    Klicken Sie dann in die Felder Von und Bis, und geben Sie einen Wert ein, oder klicken Sie auf den Pfeil nach oben oder den Pfeil nach unten, um den Wert zu erhöhen oder zu verringern.

  6. Wenn Sie einen sekundären Transport angeben möchten, klicken Sie im Bereich Sekundärer Transport auf Durchsuchen.

    Das Dialogfeld Sekundärer Transport wird angezeigt.

  7. Legen Sie die Eigenschaften des sekundären Transports fest.

    Weitere Informationen finden Sie unter Festlegen von Transporteigenschaften.

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Wichtig

  • Wenn Sie die Option Neuer XLANG-Ablaufplan wählen:
    • Der Port, den Sie angeben, muss mit BizTalk-Messaging im angegebenen Ablaufplan verbunden sein, und diese Bindung muss so konfiguriert sein, dass nach Eingang der Nachricht eine neue Ablaufplaninstanz aktiviert wird.

    • Sie sollten nur einen Port in einem Ablaufplan haben, der so konfiguriert ist, dass er eine neue Ablaufplaninstanz nach Eingang der Nachricht aktiviert, und dies sollte die erste Aktion in dem Ablaufplan sein. Weitere Informationen finden Sie unter Implementieren eines Ports mithilfe von BizTalk Messaging.

Anmerkungen

  • Wenn Sie einen XLANG-Ablaufplan als Ziel für einen Messagingport auswählen, liegt die Höchstgrenze für die Dokumente, die Sie mit diesem Messagingport verarbeiten können, bei 2 MB.

  • Der BizTalk-Orchestrierungs-Designer kann zum Erstellen der XLANG-Ablaufpläne verwendet werden.

  • Die Uhrzeiten des Dienstfensters werden im UTC-Format angezeigt und entsprechen der Zeit auf dem Server.

Verwandte Themen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften


Festlegen von Eigenschaften für die Umschlagsinformationen

  1. Wählen Sie im Messagingport-Assistenten auf der Seite Umschlagsinformationen im Bereich Umschlagsinformationen aus der Liste einen Umschlag aus.

    Wenn Sie einen Umschlag auswählen, der ein X12- oder EDIFACT-Format hat, sind die folgenden Schritte erforderlich. Wenn Sie einen Umschlag mit einem benutzerdefinierten Format auswählen, sind die folgenden Schritte optional.

    1. Klicken Sie auf Trennzeichen, und legen Sie die Eigenschaften der Trennzeichen fest.

      Weitere Informationen finden Sie unter Festlegen von Umschlagstrennzeichen.

    2. Geben Sie in das Feld Austauschkontrollnummer eine Austauschkontrollnummer ein.
  2. Wenn Sie das Standardorganisationskennzeichen für die Zielorganisation außer Kraft setzen möchten, klicken Sie in der Liste Organisationskennzeichen auf ein anderes Kennzeichen.

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Wichtig

  • Wenn Sie einen Umschlag mit einem RELIABLE-Format wählen, müssen Sie auch die Adresse Antwort-URL für Reliable Messaging im Dialogfeld Eigenschaften von BizTalk Server-Gruppe konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  • Das Format eines Umschlags, das Sie in einem Messagingport angeben, muss mit dem Format des Dokuments oder der Dokumente im Umschlag übereinstimmen. Das Dokumentformat wird durch die Spezifikation ermittelt, auf die in der Dokumentdefinition für ausgehende Dokumente eines zugeordneten Kanals verwiesen wird. Wenn Sie beispielsweise einen Umschlag mit einem X12-Format für einen Messagingport auswählen, müssen Sie eine Dokumentdefinition für ausgehende Dokumente für den Kanal auswählen, der auf eine X12-Spezifikation zeigt.

Anmerkungen

  • Wenn Umschläge verarbeitet werden, die mit BizTalk Framework 2.0 kompatibel sind, sollte BizTalk Server 2002 in Bezug auf das Ablaufdatum als Endpunkt betrachtet werden. Wenn BizTalk Framework 2.0–kompatible Dokumente von einer Anwendung oder einem Handelspartner an BizTalk Server 2002 versendet werden, werden die folgenden Felder gegebenenfalls außer Kraft gesetzt. Sind die folgenden Felder nicht vorhanden, werden sie erstellt:
    • Im Unterabschnitt mit den Eigenschaften:

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Im Unterabschnitt mit den Empfangsinformationen:

      <sendTo>

      <address>

      <sendReceiptBy>

  • Für einen Messagingport zu einer Anwendung sind die in der Liste Organisationskennzeichen verfügbaren Organisationskennzeichen die Kennzeichen der eigenen Organisation.

  • Wenn Sie den Transporttyp Loopback verwenden, können Sie keinen Umschlag mit dem RELIABLE-Format auswählen.

  • Wenn Sie ein Zielorganisationskennzeichen zur Verwendung mit X12-Umschlägen auswählen, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation oder ein anderes Kennzeichen auswählen, dessen Qualifizierer länger als 2 Zeichen oder dessen Wert länger als 15 Zeichen ist.

  • Wenn Sie ein Zielorganisationskennzeichen zur Verwendung mit EDIFACT-Umschlägen auswählen, sollten Sie nicht das Organisationskennzeichen mit dem Namen Organisation oder ein anderes Kennzeichen auswählen, dessen Qualifizierer länger als 4 Zeichen oder dessen Wert länger als 35 Zeichen ist.

  • Wenn Sie einen Umschlag im EDIFACT-Format auswählen, ist der Standardsyntaxbezeichner UNOA (Uppercase Latin Alphabet). Wenn die Daten eine andere Syntax erfordern, wählen Sie einen anderen Syntaxbezeichner aus, indem Sie die Standardwerte für den Messagingport im Kanal-Assistenten außer Kraft setzen. Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.

Verwandte Themen

Erstellen von Umschlägen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften

Grundlegendes zu Umschlägen


Festlegen von Eigenschaften für die Sicherheitseinstellungen

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Sicherheitsinformationen im Bereich Codierung in der Liste Typ auf eine der folgenden Optionen:
    • (Keine) Keine Codierung angegeben. Dies ist die Standardeinstellung.

    • MIME Gibt die Codierung an, die MIME (Multipurpose Internet Mail Extensions) verwendet.

    • Benutzerdefiniert Gibt die Codierung an, die eine benutzerdefinierte Codierungskomponente verwendet.

    Anmerkungen

    • Sie können nur dann eine benutzerdefinierte Codierungs-/Verschlüsselungs-/Signaturkomponente angeben und die CLSID konfigurieren, wenn Sie das BizTalk-Messaging-Konfigurationsobjektmodell verwenden. Der BizTalk-Messaging-Manager zeigt Benutzerdefiniert in der Liste Typ in den Bereichen Codierung/Verschlüsselung/Signatur nur an, wenn Sie einen Messagingport bearbeiten, für den eine benutzerdefinierte Komponente angegeben wurde.

    • Wenn Sie einen Umschlag angeben, der ein RELIABLE-Format verwendet, oder einen Umschlag, der ein CUSTOM XML-Format ohne eine Umschlagspezifikation verwendet, und wenn das Dokument keine Anlagen hat, ist Ihre Ausgabe nicht MIME-codiert, selbst wenn Sie die MIME-Codierung angegeben haben.

    • Wenn das eingehende Dokument MIME-codierte Shift-JIS-Daten enthält, sollten Sie im Textkörper des Dokuments nicht "encoding=Shift_jis" angeben. Geben Sie stattdessen "charset=shift-jis" im MIME-Header an.
  2. Klicken Sie im Bereich Verschlüsselung in der Liste Typ auf eine der folgenden Optionen:
    • (Keine) Keine Verschlüsselung angegeben. Dies ist die Standardeinstellung.

    • S/MIME Gibt die Codierung an, die S/MIME (Secure Multipurpose Internet Mail Extensions) verwendet.

    • Benutzerdefiniert Gibt die Codierung an, die eine benutzerdefinierte Verschlüsselungskomponente verwendet.

    Anmerkung

    • Sie können nur dann eine benutzerdefinierte Verschlüsselungskomponente angeben und die CLSID konfigurieren, wenn Sie das BizTalk-Messaging-Konfigurationsobjektmodell verwenden.
  3. Wenn Sie die S/MIME-Verschlüsselung auswählen, klicken Sie im Bereich Verschlüsselung auf Durchsuchen.

    Das Dialogfeld Verschlüsselungszertifikat auswählen wird angezeigt.

  4. Wählen Sie ein Verschlüsselungszertifikat aus.

    Weitere Informationen finden Sie unter Auswählen eines Verschlüsselungszertifikats.

  5. Klicken Sie im Bereich Signatur in der Liste Typ auf eine der folgenden Optionen:
    • (Keine) Keine Signatur angegeben. Dies ist die Standardeinstellung.

    • S/MIME Gibt eine Signatur an, die S/MIME (Secure Multipurpose Internet Mail Extensions) verwendet.

    • Benutzerdefiniert Gibt die Codierung an, die eine benutzerdefinierte Signaturkomponente verwendet.

    Anmerkung

    • Sie können nur dann eine benutzerdefinierte Signaturkomponente angeben und die CLSID konfigurieren, wenn Sie das BizTalk-Messaging-Konfigurationsobjektmodell verwenden.
  6. Wenn Sie nicht direkt mit dem Erstellen eines Kanals im Kanal-Assistenten fortfahren möchten, deaktivieren Sie das Kontrollkästchen Kanal für diesen Messagingport erstellen. Klicken Sie andernfalls in der Liste Kanaltyp auf einen der folgenden Kanaltypen:
    • Von einer Organisation

    • Von einer Anwendung

Wenn Sie einen neuen Messagingport erstellen, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Erstellen von Messagingports.

Wenn Sie einen vorhandenen Messagingport bearbeiten, klicken Sie auf Weiter. Anweisungen zum Fertigstellen des folgenden Schrittes finden Sie unter Bearbeiten von Messagingports.

Klicken Sie auf Fertig stellen, wenn Sie die Änderungen abgeschlossen haben.

Verwandte Themen

Erstellen von Kanälen

Erstellen von Messagingports

Bearbeiten von Messagingports

Festlegen von Messagingporteigenschaften


Auswählen einer Zielorganisation

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation auf Organisation, und klicken Sie dann auf Durchsuchen.

    Das Dialogfeld Organisation auswählen wird angezeigt.

  2. Klicken Sie in der Liste Verfügbare Organisationen auf eine Organisation, und klicken Sie dann auf OK.

Informationen zum Festlegen von weiteren Eigenschaften für eine Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

Verwandte Themen

Erstellen von Messagingports

Festlegen von Eigenschaften für die Zielorganisation

Festlegen von Messagingporteigenschaften


Auswählen eines Verschlüsselungszertifikats

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Sicherheitsinformationen im Bereich Verschlüsselung in der Liste Typ auf S/MIME und auf Durchsuchen:

    Das Dialogfeld Verschlüsselungszertifikat auswählen wird angezeigt.

  2. Klicken Sie in der Liste Zertifikatname auf einen Zertifikatnamen, und klicken Sie auf OK.

Informationen zum Festlegen von weiteren Sicherheitseigenschaften finden Sie unter Festlegen von Eigenschaften für die Sicherheitseinstellungen.

Anmerkung

  • Alle Zertifikate müssen mit einem eindeutigen Namen bezeichnet werden. Wenn zwei oder mehr Zertifikate denselben Namen haben, kann nur eines der Zertifikate ausgewählt werden. Nachdem eines der Zertifikate ausgewählt wurde, werden andere Zertifikate mit demselben Namen nicht mehr in der Liste angezeigt.

    Weitere Informationen zu Zertifikaten finden Sie unter Zertifikate - Übersicht.

Verwandte Themen

Erstellen von Messagingports

Festlegen von Messagingporteigenschaften

Festlegen von Eigenschaften für die Sicherheitseinstellungen


Festlegen von Transporteigenschaften

Zu den Transporteigenschaften gehört ein Transporttyp. Der Transporttyp gibt an, welchen Transportdienst Microsoft BizTalk Server 2002 zum Übertragen von Dokumenten an das im Messagingport festgelegte Ziel verwendet. Zu den Transporteigenschaften kann auch eine bestimmte Adresse gehören, an die die Daten gesendet werden. Die Adresseigenschaften hängen von dem ausgewählten Transporttyp ab.

Dieser Abschnitt beschreibt, wie die Eigenschaften für den primären und den sekundären Transport für einen Messagingport festgelegt werden.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Auswählen eines Transporttyps

  • Angeben einer Transportadresse

  • Auswählen einer Anwendungsintegrationskomponente

  • Ändern des Standardwertes des SMTP-Betreffs


Auswählen eines Transporttyps

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung oder Zielorganisation im Bereich Primärer Transport oder Sekundärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport oder Sekundärer Transport wird angezeigt.

  2. Klicken Sie in der Liste Transporttyp auf einen der folgenden Transporttypen:
    • Anwendungsintegrationskomponente Gibt einen Transport an, der eine Anwendungsintegrationskomponente (Application Integration Component, AIC) verwendet, die bei BizTalk Server 2002 registriert wurde.

    • File. Gibt einen Transport an, der die Komponente SendLocalFile verwendet.

    • HTTP. Gibt einen Transport an, der das Hypertext Transfer Protocol verwendet.

    • HTTPS. Gibt einen Transport an, der das Secure Hypertext Transfer Protocol verwendet.

    • Loopback. Gibt einen Transport an, der das ausgehende Dokument eines Kanals an eine Geschäftsanwendung, Komponente oder an einen XLANG-Ablaufplan zurückgibt, die bzw. der das eingehende Dokument mithilfe eines Synchronous Submit-Methodenaufrufs versendet hatte. Dieser Transporttyp steht nur für einen Messagingport zur Verfügung, der Dokumente an eine Anwendung sendet.

    • Message Queuing. Gibt einen Transport an, der den Message Queuing-Dienst verwendet.

    • SMTP. Gibt einen Transport an, der das Simple Mail Transfer Protocol verwendet.
  3. Führen Sie einen der folgenden Schritte durch:
    • Wenn Sie den Transporttyp Anwendungsintegrationskomponente auswählen, lesen Sie bitte im Abschnitt Auswählen einer Anwendungsintegrationskomponente weiter.

    • Wenn Sie den Transporttyp Loopback verwenden, ist keine Transportadresse erforderlich.

    • Wenn Sie einen anderen Transporttyp auswählen, lesen Sie bitte im Abschnitt Angeben einer Transportadresse weiter.

Anmerkungen

  • Wenn Sie den Transporttyp Message Queuing auswählen und keinen Umschlag verwenden, liegt die Höchstgrenze für Dokumente, die Sie mit diesem Messagingport verarbeiten können, bei 2 MB.

  • Wenn Sie den Transporttyp Message Queuing auswählen und einen Umschlag verwenden, liegt die Höchstgrenze für Dokumente, die Sie mit diesem Messagingport verarbeiten können, bei 4 MB.

  • Bevor Sie den Transporttyp SMTP auswählen können, müssen Sie den SMTP-Host in der BizTalk Server-Verwaltung konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  • Die Standardeinstellung für die HTTP-Transportkomponente ist die Verwendung des HTTP-Proxyservers. Dies ist die korrekte Einstellung, um Daten an Websites außerhalb des Firewalls Ihres Unternehmens zu transportieren. Setzen Sie die Standardeinstellung im Kanal außer Kraft, um Daten an Websites zu transportieren, die sich innerhalb des Firewalls Ihres Unternehmens (d. h. innerhalb Ihres Intranets) befinden. Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.

  • Der Transporttyp Loopback kann verwendet werden, um einem eingehenden Dokument ein anderes Format oder einen anderen Umschlag zuzuordnen oder um andere Sicherheit (Codierung, Verschlüsselung, digitale Signatur) auf eingehende Dokumente anzuwenden. Anschließend wird dann das ausgehende Dokument synchron an den Aufrufer als Antwortdokument zurückgegeben.

  • Wenn Sie den Transporttyp Loopback wählen, können Sie keinen Umschlag mit dem RELIABLE-Format verwenden.

Verwandte Themen

Erstellen von Messagingports

Auswählen einer Anwendungsintegrationskomponente

Festlegen von Messagingporteigenschaften

Festlegen von Transporteigenschaften

Angeben einer Transportadresse

Ändern des Standardwertes des SMTP-Betreffs


Angeben einer Transportadresse

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung oder Zielorganisation im Bereich Primärer Transport oder Sekundärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport oder Sekundärer Transport wird angezeigt.

  2. Klicken Sie in der Liste Transporttyp auf einen anderen Transporttyp als auf Loopback oder Anwendungsintegrationskomponente.

  3. Geben Sie im Feld Adresse eine Adresse für das Ziel ein.

  4. Wenn Sie den Transporttyp SMTP ausgewählt haben, geben Sie in das Feld E-Mail-Antwortadresse eine Adresse ein.

    Der Server verwendet diese Adresse als die Absenderadresse in der Kopfzeile des ausgehenden Dokuments und als Ziel für die Antwort-E-Mail.

Informationen zum Festlegen von weiteren Eigenschaften für eine Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

Wichtig

  • Beim Transporttyp File soll die Standardeinstellung der Transportkomponente neue Dateien an eine bestehende Datei im angegebenen Verzeichnis anhängen.

  • Wenn Sie den Transporttyp File zum Senden mehrerer Dateien mit demselben Namen an dasselbe Verzeichnis verwenden und die Dateien verschiedene Dokumentformate haben oder verschiedene Codeseiten verwenden, tritt bei den Daten in der angehängten Datei eine Datenkorruption auf.

  • Wenn Sie eine neue Datei für jede Dokumentinstanz erstellen möchten, müssen Sie das folgende Dateipfadformat verwenden:

    file://C:\dir\file%tracking_id%.xml

Anmerkungen

  • Für alle Transporttypen außer Message Queuing wird automatisch ein Präfix für die Adresse erstellt. Dieses Präfix ist unbedingt erforderlich und darf nicht gelöscht werden.

  • Für den Transporttyp Message Queuing müssen die folgenden Bedingungen erfüllt sein, damit die Adresse gültig ist:
    • Verwenden Sie nicht das Präfix queue:// in der Adresse.

    • Verwenden Sie einen Formatnamen statt eines Pfades. Gültige Formatnamen sind z. B.:

      DIRECT=OS:<ServerName>\<WarteschlangeName>

      PUBLIC=<WarteschlangeName GUID>

      DIRECT=TCP:<IPAdresse\WarteschlangeName>

      Wenn Sie den Formatnamen PUBLIC= verwenden, geben Sie die eckigen Klammern bei der GUID der Nachrichtenwarteschlange nicht an.

      Weitere Informationen zum Message Queuing finden Sie in der MSDN Online Library-Website (msdn.microsoft.com/library). Suchen Sie in der Website nach "Message Queuing".

  • Für den Transporttyp File müssen die folgenden Bedingungen erfüllt sein, damit die Adresse gültig ist:
    • Der von Ihnen angegebene Pfadname muss existieren. Der Dateipfad wird nicht automatisch erstellt, und Sie erhalten keine Warnung, wenn er nicht existiert.

    • Sie müssen einen Dateinamen mit einer Erweiterung angeben.

      Beispiel für einen gültigen Dateipfad:

      file://C:\dir\file.xml

  • Beim Transporttyp File können Sie Zeichen und Symbole verwenden, um den Dateinamen dynamisch zu ändern. Der vom Server erstellte Dateiname enthält alle statischen Zeichen, die Sie im Feld Adresse eingeben, zusammen mit dem Wert des Symbols. Wenn Sie z. B. im Feld Adresse die Eingabe file://C:\Bestellungen\Rechnung_%tracking_id%.xml vornehmen, kann es sein, dass der eigentliche Dateiname als C:\Bestellungen\Rechnung_{12345678-90AB-CDEF-1234-567890ABCDEF} angezeigt wird.

    Die folgende Tabelle enthält die Symbole, die Sie zusammen mit dem Transporttyp File verwenden können.

    Symbol | Beschreibung | Eindeutiger Dateiname
    %datetime% | Datum und Uhrzeit, in Millisekunden, der Dateierstellung. Die Zeit basiert nicht auf der Ortszeit, sondern auf der Greenwich Mean Time (GMT). | Nein
    %document_name% | Name der Dokumentdefinition, die zur Verarbeitung der Quelldatei verwendet wurde. | Nein
    %server% | Hostname des Servers, der das Dokument verarbeitet hat. | Nein
    %src_filename% | Name der Datei, die zur Verarbeitung versendet wird. | Nein
    %tracking_id% | Global einheitliche Überwachungsnummer. | Ja
    %uid% | Zähler, dessen Wert (in Millisekunden dargestellt) im Verlauf der Zeit erhöht wird. Diese Zahl wird zurückgesetzt, wenn der Server neu gestartet wird. | Nein

  • Die Standardeinstellung für die Dateitransportkomponente ist das Anhängen von Dateien. Wenn Sie den Transporttyp File mit Standardeinstellungen in einem Messagingport auswählen und auf dem Computer, auf dem BizTalk Server 2002 installiert ist, Antivirussoftware verwenden und wenn Sie außerdem mehrere Dateien mit exakt dem gleichen Namen an denselben Dateispeicherort senden, reagiert BizTalk Server 2002 möglicherweise nicht mehr und muss neu gestartet werden. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Dateitransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern. Sie können dieses Problem auch beheben, indem Sie für jede verarbeitete Dokumentinstanz eine eindeutige Datei mithilfe des Dateipfadformats im Messagingport erstellen: file://C:\dir\file%tracking_id%.xml. Weitere Informationen zum Außerkraftsetzen der Einstellung An Datei anhängen für die Dateitransportkomponente in den erweiterten Eigenschaften des Kanals finden Sie unter Außerkraftsetzen von Messagingportstandards.

  • Die Standardeinstellung für die Dateitransportkomponente ist das Anhängen von Dateien. Wenn Sie den Transporttyp File mit seinen Standardeinstellungen auswählen und einen Umschlag mit einem RELIABLE-Format in einem Messagingport auswählen und dann mehrere Dateien gleichzeitig an dasselbe Dateiverzeichnis senden, kann es zu unerwarteten Ergebnissen beim Parsen kommen. Sie können dieses Problem beheben, indem Sie die Standardeinstellung für die Dateitransportkomponente im Dialogfeld BizTalk SendLocalFile-Eigenschaften von An Datei anhängen in Datei überschreiben ändern. Weitere Informationen zum Außerkraftsetzen der Einstellung An Datei anhängen für die Dateitransportkomponente in den erweiterten Eigenschaften des Kanals finden Sie unter Außerkraftsetzen von Messagingportstandards.

  • Der Platzhalter %src_filepath% ist im Transportwörterbuch vorhanden, aber nicht funktionsfähig.

Verwandte Themen

Erstellen von Messagingports

Auswählen einer Anwendungsintegrationskomponente

Auswählen eines Transporttyps

Festlegen von Messagingporteigenschaften

Festlegen von Transporteigenschaften

Begriffszuordnung


Auswählen einer Anwendungsintegrationskomponente

  1. Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung oder Zielorganisation im Bereich Primärer Transport oder Sekundärer Transport auf Durchsuchen.

    Das Dialogfeld Primärer Transport oder Sekundärer Transport wird angezeigt.

  2. Klicken Sie in der Liste Transporttyp auf Anwendungsintegrationskomponente.

  3. Klicken Sie rechts vom Feld Komponentenname auf Durchsuchen.

    Das Dialogfeld Komponente auswählen wird angezeigt.

  4. Klicken Sie in der Liste Verfügbare Komponenten auf eine Komponente, und klicken Sie auf OK.

Informationen zum Festlegen von weiteren Eigenschaften für eine Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

Anmerkung

  • Eine Anwendungsintegrationskomponente (Application Integration Component, AIC) muss bei BizTalk Server 2002 registriert sein, bevor sie in der Liste Verfügbare Komponenten verfügbar ist. Weitere Information finden Sie unter Registering Custom Components.

Verwandte Themen

Erstellen von Messagingports

Auswählen eines Transporttyps

Festlegen von Messagingporteigenschaften

Festlegen von Transporteigenschaften

Angeben einer Transportadresse

Begriffszuordnung


Ändern des Standardwertes des SMTP-Betreffs

Der Standardwert für den SMTP-Betreff (Simple Mail Transfer Protocol) lautet <Dokumentname>-<Überwachungs-ID>. Damit können Dokumente auf der Basis des Dokumentdefinitionsnamens weitergeleitet werden.

  1. Zeigen Sie im Startmenü auf Programme und dann auf Microsoft BizTalk Server 2002, und klicken Sie anschließend auf BizTalk-Messaging-Manager.

  2. Klicken Sie im Bereich Nach anderen Elementen suchen auf Kanäle, und klicken Sie dann auf Jetzt suchen.

  3. Klicken Sie unter Kanalname auf den Kanal, für den Sie den SMTP-Betreff anzeigen möchten, und drücken Sie die EINGABETASTE.

    Der Kanal-Assistent wird geöffnet.

  4. Klicken Sie auf Weiter, um mit den Schritten des Assistenten fortzufahren, bis Sie zur Seite Erweiterte Konfiguration gelangen.

  5. Klicken Sie auf der Seite Erweiterte Konfiguration auf Erweitert.

  6. Klicken Sie im Dialogfeld Messagingportstandards außer Kraft setzen auf Eigenschaften.

  7. Geben Sie im Feld Betreff einen neuen Standardwert ein, und klicken Sie zweimal auf OK.

  8. Klicken Sie auf Fertig stellen.

    Die Änderung wird gespeichert.

Anmerkung

  • Wenn Sie einen Messagingport mit offenem Ziel erstellen, ist das Dialogfeld Messagingportstandards außer Kraft setzen nicht verfügbar. Wenn Sie SMTP als Transportdienst für Dokumente und Austauschvorgänge mit offenem Ziel verwenden, können Sie das Dokument basierend auf der Überwachungs-ID und dem Dokumentdefinitionsnamen weiterleiten.


Festlegen von Umschlagstrennzeichen

Die Eigenschaften der Trennzeichen geben an, welche Zeichen verwendet werden, um Daten innerhalb eines Umschlags und die Dokumente eines Austauschs zu trennen. Trennzeichen sind nur für Umschläge erforderlich, die die Formate X12 und EDIFACT verwenden. Sie sind optional für Umschläge, die ein benutzerdefiniertes Format verwenden.

Umschlagstrennzeichen werden festgelegt, wenn Sie einen Umschlag innerhalb eines Messagingports auswählen. Die für einen Messagingport festgelegten Trennzeichen gelten nur für diesen Messagingport. Es können unterschiedliche Trennzeichen für denselben Umschlag festgelegt werden, wenn dieser in einem anderen Messagingport verwendet wird. Dieser Abschnitt beschreibt, wie die Eigenschaften der Trennzeichen festgelegt werden.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von X12-Trennzeichen

  • Festlegen von EDIFACT-Trennzeichen

  • Festlegen von benutzerdefinierten Trennzeichen

  • Begriffszuordnung


Festlegen von X12-Trennzeichen

  1. Wählen Sie im Messagingport-Assistenten auf der Seite Umschlagsinformationen im Bereich Umschlagsinformationen einen Umschlag mit einem X12-Format aus, und klicken Sie auf Trennzeichen.

    Das Dialogfeld X12-Trennzeichen wird angezeigt.

  2. Geben Sie die Trennzeichenwerte entweder im Feld Zeichen oder Hexadezimal ein, und klicken Sie auf OK.

In der nachstehenden Tabelle sind die X12-Trennzeichen aufgeführt:

Trennzeichen | Beschreibung
Komponenten-Elementtrennzeichen | Gibt das Zeichen an, das verwendet wird, um Datenkomponenten innerhalb eines Verbunddatenfeldes zu trennen. Ein Verbunddatenfeld ist ein Feld, das aus mehreren Unterfeldern besteht.
Elementtrennzeichen | Gibt das Zeichen an, das verwendet wird, um Datenfelder innerhalb eines Datensatzes zu trennen.
Segmentabschlusszeichen | Gibt das Zeichen an, das verwendet wird, um das Ende eines Datensatzes anzuzeigen.

Informationen zum Festlegen weiterer Eigenschaften der Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

Anmerkung

  • Sie können für jedes Trennzeichen entweder ein Zeichen im Feld Zeichen oder zwei Zeichen im Feld Hexadezimal eingeben. Das Feld Hexadezimal kann verwendet werden, um nicht druckbare Zeichen als Trennzeichen einzugeben, z. B. die EINGABETASTE.

Verwandte Themen

Erstellen von Messagingports

Festlegen von benutzerdefinierten Trennzeichen

Festlegen von EDIFACT-Trennzeichen

Festlegen von Umschlagstrennzeichen

Festlegen von Eigenschaften für die Umschlagsinformationen

Festlegen von Messagingporteigenschaften

Begriffszuordnung


Festlegen von EDIFACT-Trennzeichen

  1. Wählen Sie im Messagingport-Assistenten auf der Seite Umschlagsinformationen im Bereich Umschlagsinformationen einen Umschlag mit einem EDIFACT-Format aus, und klicken Sie auf Trennzeichen.

    Das Dialogfeld EDIFACT-Trennzeichen wird angezeigt.

  2. Geben Sie die Trennzeichenwerte entweder im Feld Zeichen oder Hexadezimal ein, und klicken Sie auf OK.

In der nachstehenden Tabelle sind die EDIFACT-Trennzeichen aufgeführt:

Trennzeichen | Beschreibung
Komponenten-Elementtrennzeichen | Gibt das Zeichen an, das verwendet wird, um Datenkomponenten innerhalb eines Verbunddatenfeldes zu trennen. Ein Verbunddatenfeld ist ein Feld, das aus mehreren Unterfeldern besteht.
Elementtrennzeichen | Gibt das Zeichen an, das verwendet wird, um Datenfelder innerhalb eines Datensatzes zu trennen.
Versionsindikator | Gibt das Zeichen an, das verwendet wird, um anzuzeigen, dass das folgende Zeichen nicht als Trennzeichen auszuwerten ist.
Segmentabschlusszeichen | Gibt das Zeichen an, das verwendet wird, um das Ende eines Datensatzes anzuzeigen.

Anmerkungen

  • Wenn Sie EDIFACT-Versionsindikatoren verwenden, dürfen Sie in die Daten keine Versionsindikatorzeichen einschließen. Sollte dies doch der Fall sein, kann dies dazu führen, dass die Daten die Begrenzungen der physischen Zeichengröße für Felder überschreiten.

  • Sie können für jedes Trennzeichen entweder ein Zeichen im Feld Zeichen oder zwei Zeichen im Feld Hexadezimal eingeben. Das Feld Hexadezimal kann verwendet werden, um nicht druckbare Zeichen als Trennzeichen einzugeben, z. B. die EINGABETASTE.

  • Das EDIFACT-Dezimaltrennzeichen kann nicht verwendet werden.

Informationen zum Festlegen weiterer Eigenschaften der Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

Verwandte Themen

Erstellen von Messagingports

Festlegen von benutzerdefinierten Trennzeichen

Festlegen von Umschlagstrennzeichen

Festlegen von Eigenschaften für die Umschlagsinformationen

Festlegen von Messagingporteigenschaften

Festlegen von X12-Trennzeichen

Begriffszuordnung


Festlegen von benutzerdefinierten Trennzeichen

  1. Wählen Sie im Messagingport-Assistenten auf der Seite Umschlagsinformationen im Bereich Umschlagsinformationen einen Umschlag mit einem benutzerdefinierten Format aus, und klicken Sie auf Trennzeichen.

    Das Dialogfeld Benutzerdefinierte Trennzeichen wird angezeigt.

  2. Geben Sie die Trennzeichenwerte entweder im Feld Zeichen oder Hexadezimal ein, und klicken Sie auf OK.

In der nachstehenden Tabelle sind die benutzerdefinierten Trennzeichen aufgeführt:

Trennzeichen | Beschreibung
Unterfeld | Gibt das Zeichen an, das verwendet wird, um Datenkomponenten innerhalb eines Multipart-Datenfeldes zu trennen.
Feld | Gibt das Zeichen an, das verwendet wird, um die Datenfelder innerhalb eines Datensatzes zu trennen.
Escapezeichen | Gibt das Zeichen an, das verwendet wird, um anzuzeigen, dass das folgende Zeichen nicht als Trennzeichen auszuwerten ist.
Datensatz | Gibt das Zeichen an, das verwendet wird, um das Ende eines Datensatzes anzuzeigen.

Anmerkung

  • Sie können für jedes Trennzeichen entweder ein Zeichen im Feld Zeichen oder zwei Zeichen im Feld Hexadezimal eingeben. Das Feld Hexadezimal kann verwendet werden, um nicht druckbare Zeichen als Trennzeichen einzugeben, z. B. die EINGABETASTE.

Informationen zum Festlegen weiterer Eigenschaften der Zielorganisation finden Sie unter Festlegen von Eigenschaften für die Umschlagsinformationen.

Verwandte Themen

Erstellen von Messagingports

Festlegen von EDIFACT-Trennzeichen

Festlegen von Umschlagstrennzeichen

Festlegen von Eigenschaften für die Umschlagsinformationen

Festlegen von Messagingporteigenschaften

Festlegen von X12-Trennzeichen

Begriffszuordnung


Begriffszuordnung

BizTalk Server verwendet unterschiedliche Begriffe, um verschiedene Trennzeichen und Escapezeichen für X12/EDIFACT-Standards zu beschreiben. Die folgende Tabelle enthält Begriffe, die eine ähnliche Bedeutung haben, in XML-Tools (wie BizTalk-Editor) und Komponenten des BizTalk-Messaging-Managers jedoch unterschiedlich bezeichnet werden.

XML-Tools | BizTalk-Messaging-Manager
Datensatztrennzeichen | Segmentabschlusszeichen
Feldtrennzeichen | Elementtrennzeichen
Unterfeldtrennzeichen | Komponenten-Elementtrennzeichen
Escapezeichen | Versionsindikator

Verwandte Themen

Erstellen von Messagingports

Festlegen von benutzerdefinierten Trennzeichen

Festlegen von EDIFACT-Trennzeichen

Festlegen von Umschlagstrennzeichen

Festlegen von Eigenschaften für die Umschlagsinformationen

Festlegen von Messagingporteigenschaften

Festlegen von X12-Trennzeichen


Erstellen und Verwalten von Organisationen

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Organisationen bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundlegendes zu Organisationen lesen, um Organisationen vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Konfigurieren der eigenen Organisation

  • Erstellen von Organisationen

  • Suchen nach Organisationen

  • Bearbeiten von Organisationen

  • Löschen von Organisationen

  • Festlegen von Organisationseigenschaften


Konfigurieren der eigenen Organisation

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Aktivieren Sie im Bereich Nach Organisationen suchen das Kontrollkästchen Eigene Organisation, und klicken Sie auf Jetzt suchen.

  3. Doppelklicken Sie in der Liste Organisationsname auf Eigene Organisation (Standard).

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  4. Legen Sie auf der Registerkarte Allgemein die allgemeinen Eigenschaften der Organisation fest.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Organisationseigenschaften.

  5. Klicken Sie auf die Registerkarte Bezeichner, und legen Sie die Eigenschaften des Organisationskennzeichens fest.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für das Organisationskennzeichen.

  6. Klicken Sie auf die Registerkarte Anwendungen, und legen Sie die Eigenschaften der Anwendung fest.

    Weitere Informationen finden Sie unter Festlegen von Anwendungseigenschaften.

  7. Nachdem Sie alle erforderlichen Eigenschaften der eigenen Organisation festgelegt haben, klicken Sie auf OK, um das Dialogfeld Organisationseigenschaften zu schließen.

Wichtig

  • Ein Organisationskennzeichen mit dem Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung wird automatisch für die eigene Organisation erstellt. Dieses Kennzeichen kann nicht entfernt werden. Sie sollten den Namen oder Qualifizierer dieses Kennzeichens nicht ändern, aber Sie können den Wert ändern. Der Wert für dieses Kennzeichen wird beim Versenden von Reliable Messaging-Empfangsbestätigungen, die das SMTP-Transportprotokoll verwenden, als Absenderadresse verwendet. Weitere Informationen zu Empfangsbestätigungen beim Reliable Messaging finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

  • Der für das Organisationskennzeichen angegebene Wert (SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung) wird auch als Absenderadresse verwendet, wenn die Adresse, die für einen offenen Messagingport bereitgestellt wird, eine SMTP-Adresse ist. Weitere Informationen finden Sie unter Offenheitsgrad.

Anmerkungen

  • Sie können die eigene Organisation jederzeit in jeden beliebigen Namen umbenennen.

  • Im BizTalk-Messaging-Manager können Sie Anwendungen nur zur eigenen Organisation hinzufügen.

Verwandte Themen

Bearbeiten von Organisationen

Suchen nach Organisationen

Festlegen von Anwendungseigenschaften

Festlegen von Organisationseigenschaften

Grundlegendes zu Organisationen


Erstellen von Organisationen

  1. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, und klicken Sie auf Organisation.

    Das Dialogfeld Neue Organisation wird angezeigt.

  2. Legen Sie auf der Registerkarte Allgemein die allgemeinen Eigenschaften der Organisation fest.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Organisationseigenschaften.

  3. Klicken Sie auf die Registerkarte Bezeichner, und legen Sie die Eigenschaften des Organisationskennzeichens fest.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für das Organisationskennzeichen.

  4. Nachdem Sie alle erforderlichen Eigenschaften festgelegt haben, klicken Sie auf OK, um das Dialogfeld Neue Organisation zu schließen.

Verwandte Themen

Konfigurieren der eigenen Organisation

Löschen von Organisationen

Bearbeiten von Organisationen

Suchen nach Organisationen

Festlegen von Organisationseigenschaften

Grundlegendes zu Organisationen


Suchen nach Organisationen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Führen Sie eine oder mehrere der folgenden Aktionen durch:
    • Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um alle Organisationen zu suchen.

    • Zur Suche nach Organisationen eines bestimmten Namens geben Sie im Bereich Nach Organisationen suchen im Feld Organisationsname den Namen der Organisation ein, die Sie suchen möchten, und klicken Sie auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Aktivieren Sie das Kontrollkästchen Eigene Organisation, und klicken auf Jetzt suchen, um nur nach der eigenen Organisation zu suchen.

Anmerkungen

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Sie können die Anzahl der in einer Suche zurückgegebenen Elemente verringern, indem Sie Suchkriterien verwenden.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

  • Sie können die folgenden Platzhalterzeichen für die Suchkriterien verwenden.
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Löschen von Organisationen

Bearbeiten von Organisationen

Grundlegendes zu Organisationen


Bearbeiten von Organisationen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Organisationsname auf die Organisation, die Sie bearbeiten möchten.

    Weitere Informationen zum Suchen nach Organisationen finden Sie unter Suchen nach Organisationen.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  3. Bearbeiten Sie auf der Registerkarte Allgemein die Eigenschaften, die Sie ändern möchten.

    Weitere Informationen finden Sie unter Festlegen von allgemeinen Organisationseigenschaften.

  4. Klicken Sie auf die Registerkarte Bezeichner, und bearbeiten Sie alle Eigenschaften der Organisationskennzeichen, die Sie ändern möchten.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für das Organisationskennzeichen.

  5. Wenn Sie die eigene Organisation bearbeiten, klicken Sie auf die Registerkarte Anwendungen, und bearbeiten Sie die Eigenschaften der Anwendung, die Sie ändern möchten.

    Weitere Informationen finden Sie unter Festlegen von Anwendungseigenschaften.

  6. Nachdem Sie alle Eigenschaften bearbeitet haben, die Sie ändern möchten, klicken Sie auf OK, um das Dialogfeld Organisationseigenschaften zu schließen.

Wichtig

  • Ein Organisationskennzeichen mit dem Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung wird automatisch für die eigene Organisation erstellt. Dieses Kennzeichen kann nicht entfernt werden. Sie sollten den Namen oder Qualifizierer dieses Kennzeichens nicht ändern, aber Sie können den Wert ändern. Der Wert für dieses Kennzeichen wird beim Versenden von Reliable Messaging-Empfangsbestätigungen, die das SMTP-Transportprotokoll verwenden, als Absenderadresse verwendet. Weitere Informationen zu Empfangsbestätigungen beim Reliable Messaging finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

  • Der für das Organisationskennzeichen angegebene Wert (SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung) wird auch als Absenderadresse verwendet, wenn die Adresse, die für einen offenen Messagingport bereitgestellt wird, eine SMTP-Adresse ist. Weitere Informationen finden Sie unter Offenheitsgrad.

Anmerkung

  • Im BizTalk-Messaging-Manager können Sie Anwendungen nur zur eigenen Organisation hinzufügen.

Verwandte Themen

Erstellen von Organisationen

Löschen von Organisationen

Suchen nach Organisationen

Grundlegendes zu Organisationen


Löschen von Organisationen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Organisationsname auf die Organisation, die Sie löschen möchten.

    Weitere Informationen zum Suchen nach Organisationen finden Sie unter Suchen nach Organisationen.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkungen

  • Wenn eine Organisation in einem Messagingport oder in einem Kanal verwendet wird, können Sie diese nicht löschen. Sie müssen zunächst alle Kanäle und Messagingports löschen, die diese Organisation verwenden.

  • Sie können die eigene Organisation nicht löschen.

Verwandte Themen

Erstellen von Organisationen

Bearbeiten von Organisationen

Suchen nach Organisationen

Grundlegendes zu Organisationen


Festlegen von Organisationseigenschaften

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Konfigurieren der Eigenschaften einer Organisation bereit.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von allgemeinen Organisationseigenschaften

  • Festlegen von Eigenschaften für das Organisationskennzeichen

  • Festlegen von Anwendungseigenschaften


Festlegen von allgemeinen Organisationseigenschaften

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie auf Organisation, oder doppelklicken Sie in der Liste Organisationsname auf eine Organisation.

    Das Dialogfeld Neue Organisation bzw. Organisationseigenschaften wird angezeigt.

  2. Geben Sie auf der Registerkarte Allgemein in das Feld Organisationsname einen eindeutigen Namen für die Organisation ein.

  3. Geben Sie im Feld Kommentare beliebige Kommentare zur Organisation ein.

Verwandte Themen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationen

Festlegen von Organisationseigenschaften


Festlegen von Eigenschaften für das Organisationskennzeichen

Organisationskennzeichen werden dazu verwendet, Organisationen eindeutig zu kennzeichnen. Eine Organisation kann über mehr als ein Organisationskennzeichen verfügen, aber jedes Kennzeichen muss für diese Organisation eindeutig sein.

Wenn Sie eine neue Organisation erstellen, wird automatisch ein Organisationskennzeichen mit dem Namen Organisation erstellt. Der Qualifizierer für dieses Kennzeichen ist Organisationsname, und der Wert ist der Name, den Sie der Organisation geben. Dieser Server verwendet dieses Organisationskennzeichen als das Standardkennzeichen, sofern Sie nicht zusätzliche Kennzeichen erstellen und eines davon als Standardkennzeichen festlegen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Organisationskennzeichen

  • Bearbeiten von Organisationskennzeichen

  • Entfernen von Organisationskennzeichen

Verwandte Themen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationen

Organisationskennzeichen

Festlegen von Organisationseigenschaften


Hinzufügen von Organisationskennzeichen

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie auf Organisation, oder doppelklicken Sie in der Liste Organisationsname auf eine Organisation.

    Das Dialogfeld Neue Organisation bzw. Organisationseigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Bezeichner und auf Hinzufügen.

    Das Dialogfeld Neuer Bezeichner wird angezeigt.

  3. Führen Sie im Bereich Name einen der folgenden Schritte durch:
    • Klicken Sie auf Standard, und klicken Sie auf einen Namen in der Liste.

    • Klicken Sie auf Benutzerdefiniert, und geben Sie einen eindeutigen Namen in dem Feld ein. Geben Sie dann im Feld Qualifizierer einen Qualifizierer für das Kennzeichen ein.
  4. Geben Sie im Feld Wert einen Wert für das Kennzeichen ein.

  5. Wenn Sie dieses Kennzeichen als Standardkennzeichen für die Organisation festlegen möchten, aktivieren Sie das Kontrollkästchen Als Standard festlegen. Achten Sie andernfalls darauf, dass das Kontrollkästchen deaktiviert ist.

  6. Klicken Sie auf OK, um das Dialogfeld Neuer Bezeichner zu schließen.

Wichtig

  • Ein Organisationskennzeichen mit dem Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung wird automatisch für die eigene Organisation erstellt. Dieses Kennzeichen kann nicht entfernt werden. Sie sollten den Namen oder Qualifizierer dieses Kennzeichens nicht ändern, aber Sie können den Wert ändern. Der Wert für dieses Kennzeichen wird beim Versenden von Reliable Messaging-Empfangsbestätigungen, die das SMTP-Transportprotokoll verwenden, als Absenderadresse verwendet. Weitere Informationen finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

  • Der für das Organisationskennzeichen angegebene Wert (SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung) wird auch als Absenderadresse verwendet, wenn die Adresse, die für einen offenen Messagingport bereitgestellt wird, eine SMTP-Adresse ist. Weitere Informationen finden Sie unter Offenheitsgrad.

Anmerkungen

  • Es kann nur ein Kennzeichen als Standardkennzeichen für eine Organisation festgelegt werden. Das Standardkennzeichen wird zum Identifizieren einer Organisation verwendet, sofern Sie nicht ein anderes Organisationskennzeichen in einem Kanal oder Messagingport angeben.

  • Wenn Sie eine neue Organisation erstellen, wird automatisch ein Organisationskennzeichen mit dem Namen Organisation erstellt. Der Qualifizierer für dieses Kennzeichen ist Organisationsname, und der Wert ist der Name der Organisation. Sie können weitere Kennzeichen erstellen, aber dieses Kennzeichen kann weder geändert noch entfernt werden.

  • Wenn Sie ein Organisationskennzeichen für die Verwendung mit EDIFACT-Umschlägen erstellen, darf der Qualifizierer nicht mehr als 4 Zeichen lang sein, und der Wert darf nicht 35 Zeichen übersteigen.

  • Wenn Sie ein Organisationskennzeichen zur Verwendung mit X12-Umschlägen erstellen, darf der Qualifizierer nicht länger als 2 Zeichen sein, und der Wert darf nicht 15 Zeichen übersteigen.

Verwandte Themen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationskennzeichen

Bearbeiten von Organisationen

Organisationskennzeichen

Entfernen von Organisationskennzeichen

Festlegen von Eigenschaften für das Organisationskennzeichen


Bearbeiten von Organisationskennzeichen

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie auf Organisation, oder doppelklicken Sie in der Liste Organisationsname auf eine Organisation.

    Das Dialogfeld Neue Organisation bzw. Organisationseigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Bezeichner.

  3. Klicken Sie in der Liste Organisationskennzeichen auf das Organisationskennzeichen, das Sie bearbeiten möchten, und klicken Sie dann auf Bearbeiten.

    Das Dialogfeld Bezeichnereigenschaften wird angezeigt.

  4. Führen Sie im Bereich Name einen der folgenden Schritte durch:
    • Klicken Sie auf Standard, und klicken Sie auf einen Namen in der Liste.

    • Klicken Sie auf Benutzerdefiniert, und geben Sie einen eindeutigen Namen in dem Feld ein. Geben Sie dann im Feld Qualifizierer einen Qualifizierer für das Kennzeichen ein.
  5. Geben Sie im Feld Wert einen Wert für das Kennzeichen ein.

  6. Wenn Sie dieses Kennzeichen als Standardkennzeichen für die Organisation festlegen möchten, aktivieren Sie das Kontrollkästchen Als Standard festlegen. Achten Sie andernfalls darauf, dass das Kontrollkästchen deaktiviert ist.

  7. Klicken Sie auf OK, um das Dialogfeld Bezeichnereigenschaften zu schließen.

Wichtig

  • Ein Organisationskennzeichen mit dem Namen SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung wird automatisch für die eigene Organisation erstellt. Sie sollten den Namen oder Qualifizierer dieses Bezeichners nicht ändern, Sie können aber den Wert ändern. Dieses Kennzeichen kann nicht entfernt werden. Der Wert für dieses Kennzeichen wird beim Versenden von Reliable Messaging-Empfangsbestätigungen, die das SMTP-Transportprotokoll verwenden, als Absenderadresse verwendet. Weitere Informationen finden Sie unter Verarbeiten von Empfangsbestätigungen mithilfe von Reliable Messaging.

  • Der für das Organisationskennzeichen angegebene Wert (SMTP-"Von"-Adresse der Reliable Messaging-Bestätigung) wird auch als Absenderadresse verwendet, wenn die Adresse für einen bereitgestellten offenen Messagingport eine SMTP-Adresse ist. Weitere Informationen finden Sie unter Offenheitsgrad.

Anmerkungen

  • Es kann nur ein Kennzeichen als Standardkennzeichen für eine Organisation festgelegt werden. Das Standardkennzeichen wird verwendet, um eine Organisation zu bezeichnen, sofern Sie nicht ein anderes Organisationskennzeichen in einem Kanal oder Messagingport angegeben haben.

  • Wenn Sie eine neue Organisation erstellen, wird automatisch ein Organisationskennzeichen mit dem Namen Organisation erstellt. Der Qualifizierer für dieses Kennzeichen ist Organisationsname, und der Wert ist der Name der Organisation. Sie können weitere Kennzeichen erstellen, aber dieses Kennzeichen kann weder geändert noch entfernt werden.

  • Wenn Sie ein Organisationskennzeichen für die Verwendung mit EDIFACT-Umschlägen erstellen, darf der Qualifizierer nicht mehr als 4 Zeichen lang sein, und der Wert darf nicht 35 Zeichen übersteigen.

  • Wenn Sie ein Organisationskennzeichen zur Verwendung mit X12-Umschlägen erstellen, darf der Qualifizierer nicht länger als 2 Zeichen sein, und der Wert darf nicht 15 Zeichen übersteigen.

Verwandte Themen

Hinzufügen von Organisationskennzeichen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationen

Organisationskennzeichen

Entfernen von Organisationskennzeichen

Festlegen von Eigenschaften für das Organisationskennzeichen


Entfernen von Organisationskennzeichen

  1. Zeigen Sie im Menü Datei auf Neu, und klicken Sie auf Organisation, oder doppelklicken Sie in der Liste Organisationsname auf eine Organisation.

    Das Dialogfeld Neue Organisation bzw. Organisationseigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Bezeichner.

  3. Klicken Sie in der Liste Organisationskennzeichen auf das Kennzeichen, das Sie entfernen möchten, und klicken Sie auf Entfernen.

Anmerkungen

  • Das zugewiesene Standardorganisationskennzeichen kann nicht entfernt werden, bevor Sie nicht ein anderes Kennzeichen als Standardkennzeichen festgelegt haben.

  • Das Organisationskennzeichen mit dem Namen Organisation wird automatisch beim Erstellen einer Organisation erstellt. Dieses Organisationskennzeichen kann nicht entfernt werden.

Verwandte Themen

Hinzufügen von Organisationskennzeichen

Konfigurieren der eigenen Organisation

Erstellen von Organisationen

Bearbeiten von Organisationskennzeichen

Bearbeiten von Organisationen

Organisationskennzeichen

Festlegen von Eigenschaften für das Organisationskennzeichen


Festlegen von Anwendungseigenschaften

Im BizTalk-Messaging-Manager können Sie Anwendungen nur zur eigenen Organisation hinzufügen. Die Anwendungen, die Sie erstellen, ermöglichen Ihnen, den Ablauf der Dokumente zwischen BizTalk Server 2002 und internen Anwendungen innerhalb Ihrer Organisation zu ermitteln und zu überwachen. Sie können eine Anwendung der eigenen Organisation als eine Quellanwendung in einem Kanal oder eine Zielanwendung in einem Messagingport bestimmen.

Die eigene Organisation kann über eine beliebige Anzahl von Anwendungen verfügen. Jeder Anwendungsname muss eindeutig sein.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Anwendungen

  • Bearbeiten von Anwendungen

  • Entfernen von Anwendungen

Verwandte Themen

Konfigurieren der eigenen Organisation

Bearbeiten von Organisationen

Festlegen von Organisationseigenschaften


Hinzufügen von Anwendungen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Aktivieren Sie im Bereich Nach Organisationen suchen das Kontrollkästchen Eigene Organisation, und klicken Sie auf Jetzt suchen.

  3. Doppelklicken Sie in der Liste Organisationsname auf Eigene Organisation (Standard).

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  4. Klicken Sie auf der Registerkarte Anwendungen auf Hinzufügen.

    Das Dialogfeld Neue Anwendung wird angezeigt.

  5. Geben Sie im Feld Anwendungsname einen eindeutigen Namen für die Anwendung ein, und klicken Sie auf OK.

Anmerkung

  • Im BizTalk-Messaging-Manager können Sie Anwendungen nur für die eigene Organisation hinzufügen, bearbeiten und entfernen.

Verwandte Themen

Konfigurieren der eigenen Organisation

Bearbeiten von Anwendungen

Bearbeiten von Organisationen

Entfernen von Anwendungen

Festlegen von Anwendungseigenschaften


Bearbeiten von Anwendungen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Aktivieren Sie im Bereich Nach Organisationen suchen das Kontrollkästchen Eigene Organisation, und klicken Sie auf Jetzt suchen.

  3. Doppelklicken Sie in der Liste Organisationsname auf Eigene Organisation (Standard).

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  4. Klicken Sie auf der Registerkarte Anwendungen in der Liste Anwendungen auf die Anwendung, die Sie bearbeiten möchten, und klicken Sie auf Bearbeiten.

    Das Dialogfeld Anwendungseigenschaften wird angezeigt.

  5. Geben Sie im Feld Anwendungsname einen eindeutigen Namen für die Anwendung ein, und klicken Sie auf OK.

Anmerkung

  • Im BizTalk-Messaging-Manager können Sie Anwendungen nur für die eigene Organisation hinzufügen, bearbeiten und entfernen.

Verwandte Themen

Hinzufügen von Anwendungen

Konfigurieren der eigenen Organisation

Bearbeiten von Organisationen

Entfernen von Anwendungen

Festlegen von Anwendungseigenschaften


Entfernen von Anwendungen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Organisationen.

  2. Aktivieren Sie im Bereich Nach Organisationen suchen das Kontrollkästchen Eigene Organisation, und klicken Sie auf Jetzt suchen.

  3. Doppelklicken Sie in der Liste Organisationsname auf Eigene Organisation (Standard).

    Das Dialogfeld Organisationseigenschaften wird angezeigt.

  4. Klicken Sie auf der Registerkarte Anwendungen in der Liste Anwendungen auf die Anwendung, die Sie entfernen möchten, und klicken Sie auf Entfernen.

Anmerkung

  • Im BizTalk-Messaging-Manager können Sie Anwendungen nur für die eigene Organisation hinzufügen, bearbeiten und entfernen.

Verwandte Themen

Hinzufügen von Anwendungen

Konfigurieren der eigenen Organisation

Bearbeiten von Organisationen

Festlegen von Anwendungseigenschaften


Erstellen und Verwalten von Dokumentdefinitionen

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Dokumentdefinitionen bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundlegendes zu Dokumentdefinitionen lesen, um Dokumentdefinitionen vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Dokumentdefinitionen

  • Suchen nach Dokumentdefinitionen

  • Bearbeiten von Dokumentdefinitionen

  • Löschen von Dokumentdefinitionen

  • Festlegen von Dokumentdefinitionseigenschaften


Erstellen von Dokumentdefinitionen

  1. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, und klicken Sie dann auf Dokumentdefinition.

    Das Dialogfeld Neue Dokumentdefinition wird angezeigt.

  2. Legen Sie auf der Registerkarte Allgemein die allgemeinen Eigenschaften fest.

    Weitere Informationen finden Sie unter Festlegen von Dokumentdefinitionseigenschaften.

  3. Klicken Sie auf die Registerkarte Globale Überwachung, und legen Sie die Überwachungseigenschaften fest.

    Weitere Informationen finden Sie unter Festlegen von globalen Überwachungseigenschaften.

  4. Klicken Sie auf die Registerkarte Auswahlkriterien, und legen Sie die Eigenschaften für die Auswahlkriterien fest.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für Auswahlkriterien.

  5. Wenn Sie alle gewünschten Eigenschaften festgelegt haben, klicken Sie auf OK, um das Dialogfeld Neue Dokumentdefinition zu schließen.

Anmerkungen

  • Sie können Überwachungsfelder nur von einem Schema auswählen, das im BizTalk-Editor erstellt oder in diesen importiert wurde.

  • Sie können eine Dokumentdefinition nicht Kanal für Reliable Messaging-Bestätigung oder BizTalk-Standardempfangsbestätigung nennen, da es sich dabei um reservierte Systemnamen handelt.

  • Sie müssen eine Spezifikation auswählen, um globale Überwachungsfelder für die Dokumentdefinition festlegen zu können.

  • Wenn Sie eine Dokumentdefinition in einem Kanal auswählen, können Sie die globalen Überwachungsfelder außer Kraft setzen, indem Sie unterschiedliche zu überwachende Spezifikationsfelder auswählen. Weitere Informationen finden Sie unter Auswählen von Spezifikationsfeldern in einem Kanal.

  • Wenn Sie eine Dokumentdefinition speichern, die auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Löschen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Suchen nach Dokumentdefinitionen

Grundlegendes zu Dokumentdefinitionen


Suchen nach Dokumentdefinitionen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Dokumentdefinitionen.

  2. Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um nach allen Dokumentdefinitionen zu suchen.

    Oder

    Geben Sie im Bereich Nach Dokumentdefinitionen suchen in das Feld Name der Dokumentdefinition den Namen der gesuchten Dokumentdefinition ein, und klicken Sie auf Jetzt suchen, um nach einer Dokumentdefinition mit einem bestimmten Namen zu suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

Anmerkungen

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Sie können die Anzahl der in einer Suche zurückgegebenen Elemente verringern, indem Sie Suchkriterien verwenden.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Server-Verbindungsoptionen.

  • Sie können folgende Platzhalter in den Suchkriterien verwenden:
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Löschen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Grundlegendes zu Dokumentdefinitionen


Bearbeiten von Dokumentdefinitionen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Dokumentdefinitionsname auf die Dokumentdefinition, die Sie bearbeiten möchten.

    Weitere Informationen zum Suchen nach Dokumentdefinitionen finden Sie unter Suchen nach Dokumentdefinitionen.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Das Dialogfeld Dokumentdefinitionseigenschaften wird angezeigt.

  3. Bearbeiten Sie auf der Registerkarte Allgemein die allgemeinen Eigenschaften.

    Weitere Informationen finden Sie unter Festlegen von Dokumentdefinitionseigenschaften.

  4. Klicken Sie auf die Registerkarte Globale Überwachung, und bearbeiten Sie die Überwachungseigenschaften.

    Weitere Informationen finden Sie unter Festlegen von globalen Überwachungseigenschaften.

  5. Klicken Sie auf die Registerkarte Auswahlkriterien, und bearbeiten Sie die Eigenschaften für die Auswahlkriterien.

    Weitere Informationen finden Sie unter Festlegen von Eigenschaften für Auswahlkriterien.

  6. Wenn Sie alle gewünschten Eigenschaften bearbeitet haben, klicken Sie auf OK, um das Dialogfeld Dokumentdefinitionseigenschaften zu schließen.

Anmerkungen

  • Sie können eine Dokumentdefinition nicht Kanal für Reliable Messaging-Bestätigung oder BizTalk-Standardempfangsbestätigung nennen, da es sich dabei um reservierte Systemnamen handelt.

  • Sie müssen eine Spezifikation auswählen, um globale Überwachungsfelder für die Dokumentdefinition festlegen zu können.

  • Wenn Sie eine Dokumentdefinition speichern, die auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Löschen von Dokumentdefinitionen

Suchen nach Dokumentdefinitionen

Grundlegendes zu Dokumentdefinitionen


Löschen von Dokumentdefinitionen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Dokumentdefinitionsname auf die Dokumentdefinition, die Sie löschen möchten.

    Weitere Informationen zum Suchen nach Dokumentdefinitionen finden Sie unter Suchen nach Dokumentdefinitionen.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkung

  • Wenn eine Dokumentdefinition in einem Kanal verwendet wird, können Sie diese nicht löschen. Sie müssen zunächst alle Kanäle löschen, die diese Dokumentdefinition verwenden.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Suchen nach Dokumentdefinitionen

Grundlegendes zu Dokumentdefinitionen


Festlegen von Dokumentdefinitionseigenschaften

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Konfigurieren der Eigenschaften einer Dokumentdefinition bereit.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Festlegen von Dokumentdefinitionseigenschaften

  • Auswählen einer Dokumentspezifikation

  • Festlegen globaler Überwachungseigenschaften

  • Festlegen von Eigenschaften für Auswahlkriterien


Festlegen von Dokumentdefinitionseigenschaften

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Allgemein.

  2. Geben Sie in das Feld Dokumentdefinitionsname einen eindeutigen Namen für die Dokumentdefinition ein.

  3. Aktivieren Sie das Kontrollkästchen Dokumentspezifikation.

  4. Klicken Sie auf Durchsuchen, um eine Dokumentspezifikation auszuwählen.

    Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.

Anmerkungen

  • Eine Dokumentspezifikation ist optional. In den meisten Fällen ist die Auswahl einer Spezifikation jedoch empfehlenswert. Wenn Sie keine Spezifikation auswählen, geschieht Folgendes:
    • Die verarbeiteten Daten werden auf der eingehenden Seite nicht in XML bzw. auf der ausgehenden Seite nicht aus XML übersetzt.

    • Die Daten werden nicht anhand einer Spezifikation überprüft, um sicherzustellen, dass sie keine Fehler enthalten.

    • Sie können die Struktur bzw. das Format der Daten nicht mithilfe einer Zuordnung in einem Kanal transformieren.

    • Sie können keine globalen Überwachungsfelder für die Dokumentdefinition angeben.
  • Wenn Sie Daten verarbeiten, die nicht übersetzt, transformiert oder überprüft werden sollen, z. B. eine Binärdatei, sollten Sie keine Dokumentspezifikation auswählen.

  • Wenn Sie eine Dokumentspezifikation angeben, die nicht BizTalk Server-spezifisch ist, können Sie auf der Registerkarte Globale Überwachung keine Überwachungsfelder auswählen.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Festlegen von Dokumentdefinitionseigenschaften

Grundlegendes zu Dokumentdefinitionen


Auswählen einer Dokumentspezifikation

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Allgemein.

  2. Aktivieren Sie das Kontrollkästchen Dokumentspezifikation, und klicken Sie auf Durchsuchen.

    Das Dialogfeld Dokumentspezifikation aus dem WebDAV-Repository auswählen wird angezeigt.

  3. Wenn Sie den Server ändern möchten, führen Sie im Feld Server eine der folgenden Aktionen aus:
    • Klicken Sie auf einen Server in der Liste.

    • Geben Sie den Namen eines Servers ein, und drücken Sie die EINGABETASTE.
  4. Doppelklicken Sie auf den Ordner mit der Spezifikation, die Sie öffnen möchten, und doppelklicken Sie auf die Datei.

Wichtig

  • Wenn Sie zum ersten Mal ein WebDAV-Repository-Dialogfeld öffnen, wird das WebDAV-Repository auf dem lokalen Server ausgewählt, auch wenn der BizTalk-Messaging-Manager mit einer Datenbank auf einem Remoteserver verbunden ist. Wenn Sie ein WebDAV-Repository auf einem Remoteserver suchen, wechselt der Standard zu diesem Server, bis Sie ein neues WebDAV-Repository auswählen. Der Standardserver für alle WebDAV-Repository-Dialogfelder ist der Server, zu dem zuletzt eine Verbindung hergestellt wurde.

Anmerkungen

  • Wenn Sie http://localhost als Server auswählen, konvertiert der BizTalk-Messaging-Manager diesen automatisch in den Namen des lokalen Computers.

  • Wenn eine Dokumentdefinition als Dokumentdefinition für eingehende Dokumente in einem Kanal für einen offenen Messagingport verwendet wird, muss die Dokumentdefinition auf eine ordnungsgemäß konfigurierte Spezifikation verweisen, wenn die Zielinformation im Dokument bereitgestellt wird. Weitere Informationen zum Konfigurieren einer Dokumentspezifikation zur Verarbeitung von Dokumenten für einen offenen Messagingport finden Sie unter Festlegen von Wörterbucheigenschaften.

  • Eine Dokumentspezifikation ist optional. In den meisten Fällen ist die Auswahl einer Spezifikation jedoch empfehlenswert. Wenn Sie keine Spezifikation auswählen, geschieht Folgendes:
    • Die verarbeiteten Daten werden auf der eingehenden Seite nicht in XML bzw. auf der ausgehenden Seite nicht aus XML übersetzt.

    • Die Daten werden nicht anhand einer Spezifikation überprüft, um sicherzustellen, dass sie keine Fehler enthalten.

    • Sie können die Struktur bzw. das Format der Daten nicht mithilfe einer Zuordnung in einem Kanal transformieren.

    • Sie können keine globalen Überwachungsfelder für die Dokumentdefinition angeben.
  • Eine Dokumentspezifikation ist nicht erforderlich, wenn Sie die Dokumentdefinition in einer Pass-Through-Versendung verwenden möchten.

  • Wenn eine Dokumentspezifikation, Umschlagspezifikation oder Zuordnung mit dem BizTalk-Editor oder dem BizTalk-Mapper geändert und dann im Repository gespeichert wird, muss die Spezifikation oder Zuordnung wieder in die Nachrichtenverwaltung geladen werden, damit der Server die Änderungen erkennen und der Datenbankinhalt aktualisiert werden kann.

  • Wenn Sie das erste Mal eine Verbindung mit einem WebDAV-Repository auf einem Remoteserver herstellen, kann es zu Verzögerungen kommen.

  • Wenn Sie eine Dokumentdefinition speichern, die auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Festlegen von Dokumentdefinitionseigenschaften

Grundlegendes zu Dokumentdefinitionen


Festlegen von globalen Überwachungseigenschaften

In der Liste Spezifikationsfelder auf der Registerkarte Globale Überwachung wird eine Strukturansicht der Spezifikation angezeigt, die Sie für die Dokumentdefinition ausgewählt haben. Sie können die Liste erweitern, um alle Felder in der Spezifikation anzuzeigen und eine begrenzte Anzahl von Feldern zu bestimmen, die in der Überwachungsdatenbank protokolliert werden sollen.

Wenn die Dokumentdefinition als eingehende Dokumentdefinition für einen Kanal ausgewählt wird, werden diese Felder für alle Instanzen eines Dokuments überwacht, die von diesem Kanal verarbeitet werden. Diese Felder werden als globale Überwachungsfelder bezeichnet. Wenn Sie eine Dokumentdefinition in einem Kanal auswählen, haben Sie die Möglichkeit, die globalen Überwachungsfelder außer Kraft zu setzen, indem Sie für jede Dokumentinstanz, die nur von diesem Kanal verarbeitet wird, unterschiedliche zu überwachende Spezifikationsfelder auswählen.

Dieser Abschnitt beschreibt, wie Sie Spezifikationsfelder für eine Dokumentdefinition auswählen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

  • Entfernen von Spezifikationsfeldern aus einer Dokumentdefinition

Verwandte Themen

Überwachen von Dokumentdatenfeldern

Grundlegendes zu Dokumentdefinitionen


Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Globale Überwachung.

  2. Klicken Sie in der Liste Spezifikationsfelder auf das Erweiterungssymbol (+) neben einem Datensatz, oder doppelklicken Sie auf den Datensatz, um die Ansicht zu erweitern.

  3. Wählen Sie ein Spezifikationsfeld aus, das zur Liste Zu überwachende Felder hinzugefügt werden soll, und führen Sie dann eines der folgenden Verfahren aus:
    Felddatentyp | Verfahren
    Integer | Klicken Sie auf Integer. Sie können zwei Felder als ganze Zahl hinzufügen.
    Real | Klicken Sie auf Real. Sie können zwei Felder als reelle Zahl hinzufügen.
    Date | Klicken Sie auf Date. Sie können zwei Felder als Datum hinzufügen.
    Text | Klicken Sie auf Text. Sie können zwei Felder als Text hinzufügen.
    Benutzerdefiniert | Klicken Sie auf Benutzerdefiniert. Sie können beliebig viele Felder als benutzerdefinierten Datentyp hinzufügen. Die Felder werden als verkettete XML-Zeichenfolge mit Tags für jedes Feld gespeichert.

Anmerkungen

  • Diesem Feld muss in der Spezifikation der entsprechende Datentyp zugewiesen werden, um ein Spezifikationsfeld zur Überwachung als Datentyp Integer, Real oder Date auszuwählen. Weitere Informationen zum Zuweisen eines Datentyps zu einem Spezifikationsfeld finden Sie unter Festlegen von Deklarationseigenschaften.

  • Spezifikationsfelder, denen in der Spezifikation kein Datentyp zugewiesen wurde, können nur als Text- oder benutzerdefinierter Datentyp überwacht werden.

  • Wenn ein Spezifikationsfeld, das Sie überwachen möchten, über einen Character-Datentyp verfügt, können Sie dieses Feld nur als benutzerdefinierten Datentyp überwachen.

  • Wenn Sie eine Dokumentdefinition in einem Kanal auswählen, können Sie die globalen Überwachungsfelder außer Kraft setzen, indem Sie unterschiedliche zu überwachende Spezifikationsfelder auswählen. Weitere Informationen finden Sie unter Auswählen von Spezifikationsfeldern in einem Kanal.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Entfernen von Spezifikationsfeldern aus einer Dokumentdefinition

Festlegen von Dokumentdefinitionseigenschaften

Festlegen globaler Überwachungseigenschaften

Überwachen von Dokumentdatenfeldern

Grundlegendes zu Dokumentdefinitionen


Entfernen von Spezifikationsfeldern aus einer Dokumentdefinition

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Globale Überwachung.

  2. Wählen Sie aus der Liste Zu überwachende Felder das Spezifikationsfeld bzw. die Spezifikationsfelder aus, das/die Sie entfernen möchten, und klicken Sie auf Entfernen.

Anmerkung

  • Wenn Sie ein Feld aus der Liste der zu überwachenden Felder entfernen, wird es nur aus der Liste in dieser Dokumentdefinition entfernt und nicht aus der Spezifikation.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

Festlegen von Dokumentdefinitionseigenschaften

Festlegen globaler Überwachungseigenschaften

Überwachen von Dokumentdatenfeldern

Grundlegendes zu Dokumentdefinitionen


Festlegen von Eigenschaften für Auswahlkriterien

Auswahlkriterien bestehen aus eindeutigen Name/Wert-Paaren, die BizTalk Server nur zur Verarbeitung von EDI-Dokumenten verwendet. Für eingehende X12- oder EDIFACT-Dokumente verwendet der Server Auswahlkriterien, um eine Dokumentdefinition eindeutig zu identifizieren und auszuwählen, da innerhalb von einzelnen EDI-Dokumenten kein Dokumentdefinitionsname verfügbar ist.

Für ausgehende X12- oder EDIFACT-Dokumente werden Auswahlkriterien zum Erstellen der Informationen für Gruppenkopfzeilen verwendet.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Auswahlkriterien

  • Bearbeiten von Auswahlkriterien

  • Entfernen von Auswahlkriterien

Verwandte Themen

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien


Hinzufügen von Auswahlkriterien

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Auswahlkriterien und dann auf Hinzufügen.

    Das Dialogfeld Neuer Name und Wert wird angezeigt.

  2. Geben Sie in das Feld Name einen Namen für das Auswahlkriterium ein.

  3. Geben Sie im Feld Wert einen Wert für das Auswahlkriterium ein, und klicken Sie auf OK.

Wichtig

  • Damit BizTalk Server 2002 die Werte der Auswahlkriterien den entsprechenden Kopfzeilenelementen eingehender Austauschvorgänge zuordnen und die Werte in die richtigen Kopfzeilenelemente ausgehender Austauschvorgänge einfügen kann, müssen Sie die Namen der Auswahlkriterien genau wie in den folgenden Tabellen gezeigt eingeben.

    X12-Kopfzeilenelemente
    Name | Anforderung | GS-Element
    functional_identifier | Obligatorisch | GS01
    application_sender_code | Obligatorisch | GS02
    application_receiver_code | Obligatorisch | GS03
    standards_version | Obligatorisch | GS08

    EDIFACT-Kopfzeilenelemente
    Name | Anforderung | UNH-Element | UNG-Element
    functional_identifier | Obligatorisch | S009, 0065 | 0038
    application_sender_code | Optional | Nicht verwendet | S006, 0040
    application_receiver_code | Optional | Nicht verwendet | S007, 0044
    standards_version_type | Obligatorisch | S009, 0052 | S008, 0052
    standards_version_value | Obligatorisch | S009, 0054 | S008, 0054

  • Für ausgehende EDIFACT-Austauschvorgänge wird stets eine Nachrichtenkopfzeile (UNH) erstellt. Wenn Sie application_sender_code und application_receiver_code angeben, wird außerdem eine Gruppenkopfzeile (UNG) erstellt.

  • Die Gruppe von Name/Wert-Paaren für Auswahlkriterien, die Sie für die einzelnen Dokumentdefinitionen verwenden, muss über alle Dokumentdefinitionen gesehen eindeutig sein.

Verwandte Themen

Erstellen von Dokumentdefinitionen

Bearbeiten von Dokumentdefinitionen

Bearbeiten von Auswahlkriterien

Entfernen von Auswahlkriterien

Festlegen von Dokumentdefinitionseigenschaften

Festlegen von Eigenschaften für Auswahlkriterien

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien


Bearbeiten von Auswahlkriterien

  1. Klicken Sie im Dialogfeld Neue Dokumentdefinition oder Dokumentdefinitionseigenschaften auf die Registerkarte Auswahlkriterien.

  2. Klicken Sie in der Liste Auswahlkriterien auf das Auswahlkriterium, das Sie bearbeiten möchten, und klicken Sie dann auf Bearbeiten.

    Das Dialogfeld Eigenschaften von Namen und Wert wird angezeigt.

  3. Geben Sie in das Feld Name einen Namen für das Auswahlkriterium ein.

  4. Geben Sie im Feld Wert einen Wert für das Auswahlkriterium ein, und klicken Sie auf OK.

Wichtig

  • Damit BizTalk Server 2002 die Werte der Auswahlkriterien den entsprechenden Kopfzeilenelementen eingehender Austauschvorgänge zuordnen und die Werte in die richtigen Kopfzeilenelemente ausgehender Austauschvorgänge einfügen kann, müssen Sie die Namen der Auswahlkriterien genau wie in den folgenden Tabellen gezeigt eingeben.

    X12-Kopfzeilenelemente
    Name | Anforderung | GS Element
    functional_identifier | Obligatorisch | GS01
    application_sender_code | Obligatorisch | GS02
    application_receiver_code | Obligatorisch | GS03
    standards_version | Obligatorisch | GS08

    EDIFACT-Kopfzeilenelemente
    Name | Anforderung | UNH-Element | UNG-Element
    functional_identifier | Obligatorisch | S009, 0065 | 0038
    application_sender_code | Optional | Nicht verwendet | S006, 0040
    application_receiver_code | Optional | Nicht verwendet | S007, 0044
    standards_version_type | Obligatorisch | S009, 0052 | S008, 0052
    standards_version_value | Obligatorisch | S009, 0054 | S008, 0054

  • Für ausgehende EDIFACT-Austauschvorgänge wird stets eine Nachrichtenkopfzeile (UNH) erstellt. Wenn Sie application_sender_code und application_receiver_code angeben, wird außerdem eine Gruppenkopfzeile (UNG) erstellt.

  • Die Gruppe von Name/Wert-Paaren für Auswahlkriterien, die Sie für die einzelnen Dokumentdefinitionen verwenden, muss über alle Dokumentdefinitionen gesehen eindeutig sein.

Verwandte Themen

Hinzufügen von Auswahlkriterien

Entfernen von Auswahlkriterien

Festlegen von Eigenschaften für Auswahlkriterien

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien


Entfernen von Auswahlkriterien

  1. Klicken Sie im Dialogfeld Dokumentdefinitionseigenschaften auf die Registerkarte Auswahlkriterien.

  2. Klicken Sie in der Liste Auswahlkriterien auf das Auswahlkriterium, das Sie entfernen möchten, und klicken Sie dann auf Entfernen.

Verwandte Themen

Hinzufügen von Auswahlkriterien

Bearbeiten von Auswahlkriterien

Festlegen von Eigenschaften für Auswahlkriterien

Grundlegendes zu Dokumentdefinitionen

Grundlegendes zu Auswahlkriterien


Erstellen und Verwalten von Umschlägen

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen und Verwalten von Umschlägen bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundlegendes zu Umschlägen lesen, um das Erstellen und Verwalten von Umschlägen vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Umschlägen

  • Suchen nach Umschlägen

  • Bearbeiten von Umschlägen

  • Löschen von Umschlägen

  • Auswählen einer Umschlagspezifikation


Erstellen von Umschlägen

  1. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, und klicken Sie auf Umschlag.

    Das Dialogfeld Neuer Umschlag wird angezeigt.

  2. Geben Sie in das Feld Umschlagsname einen eindeutigen Namen für den Umschlag ein.

  3. Klicken Sie in der Liste Umschlagsformat auf eines der folgenden Umschlagsformate:
    • CUSTOM XML

      Sie müssen einen Umschlag mit einem CUSTOM XML-Format und einem Spezifikationsverweis erstellen, damit Microsoft BizTalk Server 2002 eingehende Austauschvorgänge mit einem CUSTOM XML-Format verarbeiten kann. Beim Senden von CUSTOM XML-Austauschvorgängen ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben. BizTalk Server 2002 kann den entsprechenden Umschlag ohne Namensverweis finden.

    • X12

      Sie müssen keinen Umschlag im X12-Format erstellen, damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem X12-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

    • EDIFACT

      Sie müssen keinen Umschlag im EDIFACT-Format erstellen, damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem EDIFACT-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

    • FLATFILE

      Sie müssen einen Umschlag mit einem FLATFILE-Format erstellen, damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem FLATFILE-Format verarbeiten kann. Wenn Sie eingehende Flatfiledokumente senden, müssen Sie den Umschlagsnamen in den Submit-Aufrufparametern angeben. Weitere Informationen finden Sie unter Submitting.

    • CUSTOM

      Damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem benutzerdefinierten Format verarbeiten kann, einem Format, das von BizTalk Server nicht direkt unterstützt wird, müssen Sie eine benutzerdefinierte Parserkomponente erstellen. Sie müssen nur dann einen Umschlag erstellen, wenn der benutzerdefinierte Parser diesen benötigt. Weitere Informationen finden Sie unter Parser.

      Damit BizTalk Server ausgehende Austauschvorgänge mit einem benutzerdefinierten Format verarbeiten kann, müssen Sie einen Umschlag mit einem benutzerdefinierten Format erstellen und den Umschlag in einem Messagingport auswählen. Außerdem müssen Sie eine benutzerdefinierte Serialisierungskomponente erstellen und registrieren. Weitere Informationen finden Sie unter Serializers. Sie können die benutzerdefinierte Serialisierung im Kanal auf der Seite Erweiterte Konfiguration des Kanal-Assistenten konfigurieren. Weitere Informationen finden Sie unter Festlegen erweiterter Konfigurationseigenschaften.

    • RELIABLE

      Sie müssen keinen Umschlag im RELIABLE-Format erstellen, damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem RELIABLE-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

      Das RELIABLE-Format verarbeitet Umschläge, die mit BizTalk Framework 2.0 kompatibel sind. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website (www.microsoft.com/germany/biztalk/).

      Wenn Sie das RELIABLE-Format auswählen, müssen Sie auch die Adresse Antwort-URL für Reliable Messaging im Dialogfeld Eigenschaften der BizTalk Server-Gruppe konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  4. Wenn Sie das CUSTOM XML-, das FLATFILE- oder ein benutzerdefiniertes Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Weitere Informationen finden Sie unter Auswählen einer Umschlagspezifikation.

Anmerkungen

  • Damit BizTalk Server 2002 ausgehende Austauschvorgänge in einem beliebigen Format verarbeiten kann, müssen Sie einen Umschlag erstellen.

  • Wenn Sie das CUSTOM XML-Format, aber keine Spezifikation auswählen, ist das Standardumschlagsformat RELIABLE.

  • Wenn Umschläge verarbeitet werden, die mit BizTalk Framework 2.0 kompatibel sind, sollte BizTalk Server 2002 in Bezug auf das Ablaufdatum als Endpunkt betrachtet werden. Wenn BizTalk Framework 2.0–kompatible Dokumente an BizTalk Server 2002 versendet werden, entweder von einer Anwendung oder von einem Handelspartner, werden gegebenenfalls die folgenden Felder überschrieben. Sind die folgenden Felder nicht vorhanden, werden sie erstellt:
    • Im Unterabschnitt mit den Eigenschaften:

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Im Unterabschnitt mit den Empfangsinformationen:

      <sendTo>

      <address>

      <sendReceiptBy>

  • Wenn Sie das Umschlagsformat ändern und eine Spezifikation ausgewählt haben, müssen Sie möglicherweise eine andere Spezifikation auswählen.

  • Wenn Sie einen Umschlag speichern, der auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Löschen von Umschlägen

Bearbeiten von Umschlägen

Suchen nach Umschlägen

Grundlegendes zu Umschlägen


Suchen nach Umschlägen

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Umschläge.

  2. Führen Sie eine oder mehrere der folgenden Aktionen durch:
    • Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um nach allen Umschlägen zu suchen.

    • Wenn Sie nach einem Umschlag mit einem bestimmten Namen suchen möchten, geben Sie im Bereich Nach Umschlägen suchen in das Feld Umschlagsname den Namen des gesuchten Umschlags ein, und klicken Sie auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Wenn Sie nach Umschlägen mit einem bestimmten Format suchen, klicken Sie in der Liste Format auf ein Format und dann auf Jetzt suchen.

Anmerkungen

  • Sie können mehr als ein Suchkriterium festlegen, bevor Sie auf Jetzt suchen klicken.

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Sie können die Anzahl der in einer Suche zurückgegebenen Elemente verringern, indem Sie Suchkriterien verwenden.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

  • Sie können folgende Platzhalter in den Suchkriterien verwenden:
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Löschen von Umschlägen

Bearbeiten von Umschlägen

Grundlegendes zu Umschlägen


Bearbeiten von Umschlägen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Umschlagsname auf den Umschlag, den Sie bearbeiten möchten.

    Informationen zum Suchen nach Umschlägen finden Sie unter Suchen nach Umschlägen.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Das Dialogfeld Umschlagseigenschaften wird angezeigt.

  3. Geben Sie in das Feld Umschlagsname einen eindeutigen Namen für den Umschlag ein.

  4. Klicken Sie in der Liste Umschlagsformat auf eines der folgenden Umschlagsformate:
    • CUSTOM XML

      Sie müssen einen Umschlag mit einem CUSTOM XML-Format und einem Spezifikationsverweis erstellen, damit Microsoft BizTalk Server 2002 eingehende Austauschvorgänge mit einem CUSTOM XML-Format verarbeiten kann. Beim Senden von CUSTOM XML-Austauschvorgängen ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben. BizTalk Server kann den entsprechenden Umschlag ohne Namensverweis finden.

    • X12

      Sie müssen keinen Umschlag im X12-Format erstellen, damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem X12-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

    • EDIFACT

      Sie müssen keinen Umschlag im EDIFACT-Format erstellen, damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem EDIFACT-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

    • FLATFILE

      Sie müssen einen Umschlag mit einem FLATFILE-Format erstellen, damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem FLATFILE-Format verarbeiten kann. Wenn Sie eingehende Flatfiledokumente senden, müssen Sie den Umschlagsnamen in den Submit-Aufrufparametern angeben. Weitere Informationen finden Sie unter Submitting.

    • CUSTOM

      Sie müssen möglicherweise einen Umschlag erstellen, damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem benutzerdefinierten Format verarbeiten kann, einem Format, das von BizTalk Server nicht direkt unterstützt wird. Sie müssen jedoch eine benutzerdefinierte Parserkomponente erstellen, um diese Austauschvorgänge zu verarbeiten, die möglicherweise einen Umschlag erfordern. Weitere Informationen finden Sie unter Parser.

      Damit BizTalk Server ausgehende Austauschvorgänge mit einem benutzerdefinierten Format verarbeiten kann, müssen Sie einen Umschlag mit einem benutzerdefinierten Format erstellen und den Umschlag in einem Messagingport auswählen. Außerdem müssen Sie eine benutzerdefinierte Serialisierungskomponente erstellen und registrieren. Weitere Informationen finden Sie unter Serializers. Sie können die benutzerdefinierte Serialisierung im Kanal auf der Seite Erweiterte Konfiguration des Kanal-Assistenten konfigurieren. Weitere Informationen finden Sie unter Festlegen erweiterter Konfigurationseigenschaften.

    • RELIABLE

      Sie müssen keinen Umschlag im RELIABLE-Format erstellen, damit BizTalk Server 2002 eingehende Austauschvorgänge mit einem RELIABLE-Format verarbeiten kann. Außerdem ist es nicht erforderlich, den Umschlagsnamen in den Submit-Aufrufsparametern anzugeben.

      Das RELIABLE-Format verarbeitet Umschläge, die mit BizTalk Framework 2.0 kompatibel sind. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website (www.microsoft.com/germany/biztalk/).

      Wenn Sie das RELIABLE-Format auswählen, müssen Sie auch die Adresse Antwort-URL für Reliable Messaging im Dialogfeld Eigenschaften der BizTalk Server-Gruppe konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

  5. Wenn Sie das CUSTOM XML-, das FLATFILE- oder ein benutzerdefiniertes Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Weitere Informationen finden Sie unter Auswählen einer Umschlagspezifikation.

Wichtig

  • Wenn Sie einen Umschlag mit dem RELIABLE-Format erstellen und diesen Umschlag in einem Messagingport auswählen, müssen Sie auch die Adresse Antwort-URL für Reliable Messaging im Dialogfeld Eigenschaften der BizTalk Server-Gruppe konfigurieren. Weitere Informationen finden Sie unter Konfigurieren von allgemeinen Eigenschaften für eine Servergruppe.

Anmerkungen

  • Damit BizTalk Server 2002 ausgehende Austauschvorgänge in einem beliebigen Format verarbeiten kann, müssen Sie einen Umschlag erstellen.

  • Wenn Sie das CUSTOM XML-Format, aber keine Spezifikation auswählen, ist das Standardumschlagsformat RELIABLE.

  • Wenn Umschläge verarbeitet werden, die mit BizTalk Framework 2.0 kompatibel sind, sollte BizTalk Server 2002 in Bezug auf das Ablaufdatum als Endpunkt betrachtet werden. Wenn BizTalk Framework 2.0–kompatible Dokumente an BizTalk Server versendet werden, entweder von einer Anwendung oder von einem Handelspartner, werden die folgenden Felder überschrieben, wenn sie vorhanden sind. Sind die folgenden Felder nicht vorhanden, werden sie erstellt:
    • Im Unterabschnitt mit den Eigenschaften:

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Im Unterabschnitt mit den Empfangsinformationen:

      <sendTo>

      <address>

      <sendReceiptBy>

  • Wenn Sie das Umschlagsformat ändern und eine Spezifikation ausgewählt haben, müssen Sie möglicherweise eine andere Spezifikation auswählen.

  • Wenn Sie einen Umschlag speichern, der auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Umschlägen

Löschen von Umschlägen

Suchen nach Umschlägen

Grundlegendes zu Umschlägen


Löschen von Umschlägen

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Umschlagsname auf den Umschlag, den Sie löschen möchten.

    Weitere Informationen zum Suchen nach Umschlägen finden Sie unter Suchen nach Umschlägen.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkung

  • Ein Umschlag, der in einem Messagingport verwendet wird, kann nicht gelöscht werden. Sie müssen zunächst alle Messagingports löschen, die den Umschlag verwenden.

Verwandte Themen

Erstellen von Umschlägen

Bearbeiten von Umschlägen

Suchen nach Umschlägen

Grundlegendes zu Umschlägen


Auswählen einer Umschlagspezifikation

  1. Aktivieren Sie im Dialogfeld Neuer Umschlag oder Umschlagseigenschaften das Kontrollkästchen Umschlagspezifikation, und klicken Sie auf Durchsuchen.

    Das Dialogfeld Eine Umschlagspezifikation aus dem WebDAV-Repository auswählen wird angezeigt.

  2. Wenn Sie den Server ändern möchten, führen Sie im Feld Server eine der folgenden Aktionen aus:
    • Klicken Sie auf einen Server in der Liste.

    • Geben Sie den Namen eines Servers ein, und drücken Sie die EINGABETASTE.
  3. Doppelklicken Sie auf den Ordner mit der Spezifikation, die Sie öffnen möchten, klicken Sie auf die Spezifikation, und klicken Sie dann auf Öffnen.

Wichtig

  • Wenn Sie ein WebDAV-Repository-Dialogfeld zum ersten Mal öffnen, wird das WebDAV-Repository auf dem lokalen Server ausgewählt. Das ist auch dann der Fall, wenn der BizTalk-Messaging-Manager mit einer Datenbank auf einem Remoteserver verbunden ist. Wenn Sie zu einem WebDAV-Repository auf einem Remoteserver wechseln, ändert sich die Standardeinstellung auf diesen Server, bis Sie ein neues WebDAV-Repository auswählen. Der Standardserver für alle WebDAV-Repository-Dialogfelder ist der Server, zu dem zuletzt eine Verbindung hergestellt wurde.

Anmerkungen

  • Wenn Sie http://localhost als Server auswählen, konvertiert der BizTalk-Messaging-Manager diesen automatisch in den Namen des lokalen Computers.

  • Wenn Sie das CUSTOM XML-Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Wenn Sie keine Spezifikation auswählen, ist das mit BizTalk Framework 2.0 kompatible Standardumschlagsformat RELIABLE. Weitere Informationen zu BizTalk Framework 2.0 finden Sie in der Microsoft BizTalk-Website (www.microsoft.com/germany/biztalk/).

  • Wenn Sie das FLATFILE-Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Wenn der Umschlag zum Öffnen eingehender Austauschvorgänge verwendet wird, müssen Sie eine Spezifikation auswählen. Wenn der Umschlag zum Erstellen ausgehender Austauschvorgänge verwendet wird, ist keine Spezifikation erforderlich.

  • Wenn eine Dokumentspezifikation, Umschlagspezifikation oder Zuordnung mit dem BizTalk-Editor oder dem BizTalk-Mapper geändert und dann im Repository gespeichert wird, muss die Spezifikation oder Zuordnung wieder in die Nachrichtenverwaltung geladen werden, damit der Server die Änderungen erkennen und der Datenbankinhalt aktualisiert werden kann.

  • Wenn Sie ein benutzerdefiniertes Format auswählen, können Sie eine Spezifikation für den Umschlag auswählen. Der von Ihnen erstellte benutzerdefinierte Parser bzw. die von Ihnen erstellte benutzerdefinierte Serialisierung bestimmt, ob eine Spezifikation erforderlich ist.

    Zum Verwenden des benutzerdefinierten Formats sind darüber hinaus folgende Schritte erforderlich:

    • Erstellen Sie eine benutzerdefinierte Parserkomponente zum Öffnen eingehender Austauschvorgänge mit diesem benutzerdefinierten Format. Weitere Informationen finden Sie unter Parser.

    • Erstellen und konfigurieren Sie eine benutzerdefinierte Serialisierungskomponente zum Erstellen ausgehender Austauschvorgänge mit diesem benutzerdefinierten Format. Weitere Informationen finden Sie unter Serializers.

    • Konfigurieren Sie die benutzerdefinierte Serialisierungskomponente mithilfe der Eigenschaften zum Außerkraftsetzen von Standards für Messagingports im Kanal-Assistenten. Weitere Informationen finden Sie unter Außerkraftsetzen von Messagingportstandards.
  • Wenn Sie einen Umschlag speichern, der auf eine Spezifikation außerhalb der lokalen Domäne verweist, erhalten Sie möglicherweise eine Fehlermeldung. Wenn eine Fehlermeldung angezeigt wird, downloaden und konfigurieren Sie das Dienstprogramm WinHTTP Proxy Configuration. Gehen Sie zum Downloaden des Dienstprogramms zur Microsoft MSDN-Website (msdn.microsoft.com/downloads/default.asp), und suchen Sie die Seite "WinHTTP Proxy Configuration Utility". Diese Seite befindet sich im Kapitel zu XML im Buch Web Development.

Verwandte Themen

Erstellen von Umschlägen

Bearbeiten von Umschlägen

Suchen nach Umschlägen

Grundlegendes zu Umschlägen


Verwenden von Verteilerlisten

Dieser Abschnitt stellt aufgabenspezifische Informationen zur Verwendung von Verteilerlisten bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Grundlegendes zu Verteilerlisten lesen, um Verteilerlisten vollständig zu verstehen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen von Verteilerlisten

  • Suchen von Verteilerlisten

  • Bearbeiten von Verteilerlisten

  • Löschen von Verteilerlisten


Erstellen von Verteilerlisten

  1. Zeigen Sie im BizTalk-Messaging-Manager im Menü Datei auf Neu, und klicken Sie auf Verteilerliste.

    Das Dialogfeld Neue Verteilerliste wird angezeigt.

  2. Geben Sie im Feld Verteilerlistenname einen eindeutigen Namen für die Verteilerliste ein.

  3. Wählen Sie in der Liste Verfügbare Messagingports die Messagingports aus, die Sie einschließen möchten, und klicken Sie auf Hinzufügen.

    Die ausgewählten Messagingports werden zur Liste Ausgewählte Messagingports hinzugefügt.

  4. Wählen Sie in der Liste Ausgewählte Messagingports die Messagingports aus, die Sie nicht einschließen möchten, und klicken Sie auf Entfernen.

  5. Nachdem Sie die erforderlichen Eigenschaften festgelegt haben, klicken Sie auf OK, um das Dialogfeld Neue Verteilerliste zu schließen.

Anmerkungen

  • Wenn Sie einen Messagingport aus einer Verteilerliste entfernen, wird dieser nur aus der Verteilerliste und nicht aus der Datenbank entfernt.

  • Eine Verteilerliste muss mindestens einen Messagingport enthalten.

  • Zu einer Verteilerliste können keine offenen Messagingports hinzugefügt werden.

  • 5Eine Verteilerliste benötigt mindestens einen Kanal, um funktionieren zu können. Weitere Informationen zu Kanälen finden Sie unter Erstellen und Verwalten von Kanälen.

Verwandte Themen

Löschen von Verteilerlisten

Bearbeiten von Verteilerlisten

Suchen von Verteilerlisten

Grundlegendes zu Verteilerlisten


Suchen von Verteilerlisten

  1. Klicken Sie im BizTalk-Messaging-Manager im Bereich Nach anderen Elementen suchen auf Verteilerlisten.

  2. Führen Sie eine oder mehrere der folgenden Aktionen durch:
    • Löschen Sie alle Suchkriterien, und klicken Sie auf Jetzt suchen, um alle Verteilerlisten zu suchen.

    • Geben Sie für die Suche nach einer Verteilerliste mit einem bestimmten Namen unter Nach Verteilerlisten suchen im Feld Verteilerlistenname den Namen der Verteilerliste ein, die Sie suchen, und klicken Sie auf Jetzt suchen. Sie können einen unvollständigen Namen eingeben, und die Suche gibt alle möglichen Namen zurück, die mit dem unvollständigen Namen übereinstimmen.

    • Geben Sie für die Suche nach Verteilerlisten, die einen bestimmten Messagingport enthalten, in der Liste Enthält Messagingport den Namen des Messagingports ein, und klicken Sie auf Jetzt suchen.

Anmerkungen

  • Klicken Sie auf Suche löschen, um die Suchkriterien und Suchergebnisse zu löschen.

  • Wenn nach einer großen Anzahl von Objekten gesucht werden soll, dauert es möglicherweise mehrere Minuten, bis alle Objekte zurückgegeben werden. Sie können die Anzahl der in einer Suche zurückgegebenen Elemente verringern, indem Sie Suchkriterien verwenden.

  • Die Standardanzahl von Elementen, die bei einer Suche zurückgegeben werden, ist 500. Diese Anzahl können Sie anpassen. Weitere Informationen finden Sie unter Festlegen von Serververbindungsoptionen.

  • Sie können folgende Platzhalter in den Suchkriterien verwenden:
    Platzhalter | Beschreibung | Beispiel
    % Eine Zeichenfolge aus null oder mehr Zeichen Der Eintrag %open% findet alle Namen, die das Wort "open" enthalten.
    _ (Unterstrich) | Beliebiges einzelnes Zeichen | Der Eintrag _ean findet alle Namen mit vier Buchstaben, die auf "ean" enden (Dean, Sean usw.).
    [ ] Beliebiges einzelnes Zeichen im angegebenen Bereich ([a-f]) oder in der angegebenen Menge ([abcdef]). Der Eintrag [C-P]arsen findet alle Namen, die auf "arsen" enden und mit einem beliebigen einzelnen Zeichen zwischen C und P beginnen, z. B.: Carsen, Larsen usw.
    [^] Beliebiges einzelnes Zeichen, das sich nicht im angegebenen Bereich ([^a-f]) oder in der angegebenen Menge ([^abcdef]) befindet. Der Eintrag de[^s]% findet alle Namen, die mit "de" beginnen und deren dritter Buchstabe nicht "s" ist.

Verwandte Themen

Erstellen von Verteilerlisten

Löschen von Verteilerlisten

Bearbeiten von Verteilerlisten

Grundlegendes zu Verteilerlisten


Bearbeiten von Verteilerlisten

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Verteilerlistenname auf die zu bearbeitende Verteilerliste.

    Weitere Informationen zum Suchen von Verteilerlisten finden Sie unter Suchen von Verteilerlisten.

  2. Klicken Sie im Menü Datei auf Bearbeiten.

    Das Dialogfeld Verteilerlisteneigenschaften wird angezeigt.

  3. Geben Sie im Feld Verteilerlistenname einen eindeutigen Namen für die Verteilerliste ein.

  4. Wählen Sie in der Liste Verfügbare Messagingports die Messagingports, die Sie einschließen möchten, und klicken Sie auf Hinzufügen, um sie zur Liste Ausgewählte Messagingports hinzuzufügen.

  5. Wählen Sie in der Liste Ausgewählte Messagingports die Messagingports aus, die Sie nicht einschließen möchten, und klicken Sie auf Entfernen.

  6. Nachdem Sie die erforderlichen Eigenschaften festgelegt haben, klicken Sie auf OK, um das Dialogfeld Verteilerlisteneigenschaften zu schließen.

Anmerkungen

  • Wenn Sie einen Messagingport aus einer Verteilerliste entfernen, wird dieser nur aus der Verteilerliste und nicht aus der Datenbank entfernt.

  • Eine Verteilerliste muss mindestens einen Messagingport enthalten.

  • Zu einer Verteilerliste können keine offenen Messagingports hinzugefügt werden.

Verwandte Themen

Erstellen von Verteilerlisten

Löschen von Verteilerlisten

Suchen von Verteilerlisten

Grundlegendes zu Verteilerlisten


Löschen von Verteilerlisten

  1. Klicken Sie im BizTalk-Messaging-Manager in der Liste Verteilerlistenname auf die zu löschende Verteilerliste.

    Weitere Informationen zum Suchen von Verteilerlisten finden Sie unter Suchen von Verteilerlisten.

  2. Klicken Sie im Menü Datei auf Löschen.

Anmerkungen

  • Sie können eine Verteilerliste erst dann löschen, wenn alle Kanäle gelöscht wurden, die der Verteilerliste zugeordnet sind.

  • Sie können nach Kanälen suchen, die einer Verteilerliste zugeordnet sind, indem Sie mit der rechten Maustaste auf die Verteilerliste klicken und dann auf Kanäle suchen klicken.

Verwandte Themen

Erstellen von Verteilerlisten

Suchen von Verteilerlisten

Grundlegendes zu Verteilerlisten


Erstellen von Spezifikationen und Zuordnen von Daten

Microsoft® BizTalk™ Server 2002 stellt Tools bereit, mit denen Sie die Struktur eines Dokuments definieren und Daten eines Formats einem anderen zuordnen können. Diese Tools basieren auf XML- (Extensible Markup Language) und verwandten Standards, z. B. XSL (Extensible Stylesheet Language) und XSLT (Extensible Stylesheet Language Transformation), und stellen die für einen Anwendungsintegrationsserver notwendige Datenkonvertierung bereit.

Mit dem BizTalk-Editor können Sie Spezifikationen erstellen, die auf Industriestandards und allgemeinen Schemas basieren; Sie können aber auch Spezifikationen erstellen, die nur für Ihre Organisation zutreffen.

Mit dem BizTalk-Mapper können Sie eine Zuordnung zwischen Datensätzen und Feldern von zwei verschiedenen Spezifikationen erstellen. Der Server verwendet die Zuordnung zum Verarbeiten und Konvertieren von Daten in Formate, die innerhalb der Organisation oder der Partnerorganisation gemeinsam verwendet werden können.

In diesem Abschnitt werden folgende Themen behandelt:

  • Verwenden des BizTalk-Editors

  • Verwenden des BizTalk-Mappers

  • Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Verwenden des BizTalk-Editors

Der Microsoft® BizTalk™-Editor ist ein Tool, mit dem Sie Spezifikationen erstellen, bearbeiten und verwalten können. Der BizTalk-Editor verwendet XDR-Syntax (XML-Data Reduced), die ein allgemeines Vokabular für die Verarbeitung von Überlappungen zwischen syntaktischen, Datenbank- und konzeptionellen Schemata bereitstellt.

Der BizTalk-Editor erstellt Spezifikationen durch die Interpretation der Eigenschaften von Datensätzen und Feldern, die in einer Datei enthalten sind. Spezifikationen bilden die strukturierten Daten ungeachtet des Ursprungsformats als XML (Extensible Markup Language) ab. Darüber hinaus enthalten im BizTalk-Editor erstellte oder geänderte Spezifikationen allgemeine Datenbeschreibungen, die der BizTalk-Mapper zum Transformieren von Daten verschiedener Formate verwenden kann. Die Spezifikationen ermöglichen eine geschäftsprozessübergreifende Übertragbarkeit von Daten. Eine mit dem BizTalk-Editor erstellte Spezifikation kann auf Folgendem basieren:

  • Wohlgeformtes XML

  • XDR-basierte Dokumentvorlagen

  • XDR-Schemas

  • Dokumenttypdefinitionen (Document Type Definitions, DTDs)

  • Als XML gespeicherte ADO-Datensätze (Microsoft ActiveX® Data Objects)

  • EDI (Electronic Data Interchange) (X12 und EDIFACT)

  • Flatfiles, einschließlich Flatfiles mit Trennzeichen und Flatfiles mit Feldern fester Breite (z. B. SAP IDOCs) oder kombinierte Flatfiles mit Trennzeichen und mit Feldern fester Breite

  • Strukturierte Dokumentformate

Im BizTalk-Editor können Sie eine leere Spezifikation ohne Struktur öffnen oder ein vorhandenes Schema bzw. eine vorhandene Spezifikation importieren. Sie können z. B. eine Dokumenttypdefinition importieren. Dies ist eine strukturierte Datei, in der Elemente und Attribute sowie Einschränkungen hinsichtlich Reihenfolge, Häufigkeit und Inhalt der Elemente und Attribute angegeben sind. Standardspezifikationen wie XML, X12 und EDIFACT können ebenfalls zum Erstellen neuer Spezifikationen verwendet werden.

Wird eine Instanz eines Dokuments importiert, interpretiert der BizTalk-Editor die Struktur des Dokuments und erstellt eine Spezifikation, bei der es sich um eine XDR-Darstellung des Dokuments handelt. Sie können alle erforderlichen Datensätze und Felder in der Spezifikationsstruktur des BizTalk-Editors bearbeiten und die Struktur dann als Spezifikation speichern. Die folgenden Dateitypen können importiert werden:

  • XDR-Schemas

  • Wohlgeformtes XML

  • Dokumenttypdefinitionen (DTDs)

Jede Spezifikation beschreibt die Struktur der Datei, wenn ein bestimmter Satz Tags angegeben ist. Der BizTalk-Editor stellt auch verschiedene Vorlagen bereit, die als Ausgangspunkt für das Erstellen von Spezifikationen für allgemeine Dokumente wie Aufträge, Rechnungen und Vorausversandanzeigen verwendet werden können.

Wenn BizTalk Server 2002 Dokumente verarbeitet, verwendet der Server eine mithilfe des BizTalk-Mappers erstellte Zuordnung, um ein- und ausgehende Daten von einem Spezifikationsformat in ein anderes zu konvertieren.

In diesem Abschnitt werden folgende Themen behandelt:

  • Ausführliche Informationen zum BizTalk-Editor finden Sie unter Informationen zum BizTalk-Editor.

  • Eine Kurzübersicht darüber, warum bestimmte Aufgaben ausgeführt werden müssen, finden Sie unter Gründe für das Durchführen von BizTalk-Editor-Aufgaben.

  • Detaillierte Anweisungen zum Ausführen von Aufgaben finden Sie unter Durchführen von BizTalk-Editor-Aufgaben.

  • Anweisungen zur Lösung von Problemen finden Sie unter Problembehandlung - BizTalk-Editor und BizTalk-Mapper.


Informationen zum BizTalk-Editor

BizTalk-Editor ist ein Grafiktool zum Definieren von Spezifikationen für das Initialisieren der Bestandteile von Microsoft BizTalk Server 2002, die Daten für Transaktionen zwischen Organisationen und Handelspartnern lesen und schreiben. Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des BizTalk-Editors sind.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Grundlegendes zu Spezifikationen

  • BizTalk-Editor - Umgebung

  • Importieren von Dateien

  • Exportieren von Dateien

  • Datensätze, Felder und Eigenschaften

  • Allzweck-Trigger

  • Namespaceunterstützung

  • Hinzufügen von SQL-Anmerkungen

  • Erstellen von XML- und systemeigenen Instanzen

  • Überprüfen von Instanzen und Spezifikationen


Grundlegendes zu Spezifikationen

Spezifikationen sind BizTalk Server-spezifische XML-Schemas (Extensible Markup Language), die vom BizTalk-Editor erstellt werden. Sie können Spezifikationen erstellen, die auf Industriestandards (wie beispielsweise XML, EDIFACT oder X12) oder auf Nicht-Industriestandards (wie z. B. Flatfiles mit Trennzeichen, Flatfiles mit Feldern fester Breite, Flatfiles mit Trennzeichen und mit Feldern fester Breite, leeren Spezifikationen oder vorhandenen Dateien) basieren.

Industriestandards

Industriestandards stellen einheitliche Verfahren für den elektronischen Datenaustausch in Unternehmen bereit. Die Verwendung einer gemeinsamen Geschäftssprache ermöglicht Computern die Kommunikation innerhalb einer Organisation oder zwischen Unternehmen. Industriestandards geben das Format und den Dateninhalt von elektronischen Geschäftstransaktionen an. Eine Spezifikation, die auf einem Industriestandard basiert, wird als Teilmenge des Standards angesehen. Sie können basierend auf einer Industriestandardspezifikation alle nicht benötigten Datensätze und Felder löschen, um eine Spezifikation zu erstellen, die Ihren Bedürfnissen entspricht. Darüber hinaus müssen Sie möglicherweise Eigenschaften für die verbleibenden Datensätze und Felder ändern.

EDI (Electronic Data Interchange) ist eine häufig verwendete Industriestandardspezifikation. Der BizTalk-Editor enthält eine Untermenge der EDI-Dokumentspezifikationen und eine zugeordnete Datenbank mit EDI-Codelisten. Diese Spezifikationen werden direkt aus den Daten generiert, die von den offiziell anerkannten Herausgebern der X12- und EDIFACT-Standards bereitgestellt werden. Sie sollten unbedingt die EDI-Instanzen anhand von Spezifikationen überprüfen, die vor der Produktionsimplementierung von Prozessen, die diese Spezifikationen verwenden, erstellt wurden. Weitere Informationen und Aktualisierungen zu EDI-Spezifikationen und Standards finden Sie auf der Microsoft BizTalk Server-Website (www.microsoft.com/germany/biztalk/).

Nicht-Industriestandards

In Spezifikationen, die auf Nicht-Industriestandards basieren, müssen Sie die Struktur des Dokuments im BizTalk-Editor definieren. Sie können den BizTalk-Editor für verschiedene Typen von Nicht-Industriestandards verwenden: Flatfiles mit Feldern fester Breite, Flatfiles mit Trennzeichen oder kombinierte Flatfiles mit Feldern fester Breite und mit Trennzeichen. Grundlegendes zur Verwendung von Flatfiles erfahren Sie in den Beispielen, die in BizTalk Server 2002 enthalten sind. Das Beispiel für Flatfiles mit Trennzeichen befindet sich im Ordner Flat-FileDelimited unter \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\. Das Beispiel für Flatfiles mit Feldern fester Breite befindet sich im Ordner Flat-FilePositional unter \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\.

Sie müssen auf der Registerkarte Analysieren die Struktur-Eigenschaft des Stammknotens auf Getrennt festlegen, wenn es sich um eine Flatfile mit Trennzeichen und mit Feldern fester Breite handelt. Weitere Datensatzeigenschaften werden je nach ihren Attributen auf Getrennt oder auf Feste Breite festgelegt.

Weitere Informationen zu Flatfiles finden Sie unter Verwenden von Flatfiles mit Feldern fester Breite und mit Trennzeichen.

Leere Spezifikationen

Eine leere Spezifikation enthält nur das Stammknotenelement. Wenn Sie von einer leeren Spezifikation ausgehen, müssen Sie die gesamte Spezifikationsstruktur erstellen. Benennen Sie das Stammelement um, und ändern Sie anschließend die gewünschten Eigenschaftswerte des Stammelements, wie z. B. die Überschrifteninformationen für die Spezifikation. Anschließend können Sie Datensätze und Felder sowie ihre Eigenschaften so hinzufügen, wie es Ihre Geschäftsprozesse erfordern.

Vorhandene BizTalk Server 2000-Dateien

Schemas aus BizTalk Server 2000 sind mit BizTalk Server 2002 kompatibel. Wenn Sie eine in BizTalk Server 2000 erstellte Spezifikation in BizTalk Server 2002 öffnen und speichern, wird das Dateiformat geändert, und die Spezifikation kann nicht mehr mit BizTalk Server 2000 geöffnet werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Spezifikationsstruktur

  • Unterstützen von Standards

  • Zusammenfassungsliste der im Lieferumfang enthaltenen, auf EDI basierenden Dokumente

  • Verwenden von Flatfiles mit Feldern fester Breite und mit Trennzeichen

  • Ungültige XML-Namenzeichen

  • Ungültige Zeichenbereiche

Verwandte Themen

Erstellen einer Spezifikation auf der Basis einer Flatfile

Erstellen einer Spezifikation auf der Basis einer leeren Vorlage

Erstellen einer Spezifikation auf der Basis einer vorhandenen Spezifikation

Erstellen einer Spezifikation auf der Basis eines Standards

Datensätze, Felder und Eigenschaften

Verwenden von Flatfiles mit Feldern fester Breite und mit Trennzeichen


Spezifikationsstruktur

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Spezifikationsstruktur

Im BizTalk-Editor erstellte Spezifikationen stellen wohlgeformten XML-Code dar. Spezifikationsstrukturen unterscheiden sich je nach dem Dateityp, den Sie als Basis für die Erstellung Ihrer Spezifikation wählen. Unabhängig vom Typ enthält jede Spezifikation die gleiche grundlegende Struktur. Beispielsweise beginnen alle Spezifikationen mit dem Tag <?xml version=""?> und werden mit Kopfzeileninformationen fortgesetzt, wie dem Namen der Datei und Namespacedaten. Anschließend wird die verbleibende Struktur basierend auf den in der Spezifikation enthaltenen Datensätzen und Feldern und den ihnen zugeordneten Attributen erstellt. Sie können den einer Spezifikation zugrunde liegenden Code anzeigen, indem Sie diese in Microsoft Internet Explorer 5 oder höher öffnen.

Mithilfe des BizTalk-Editors können Sie ein XDR-Schema (XML-Data Reduced) mit zusätzlichen BizTalk-spezifischen Anmerkungen erstellen. Um die Anmerkungen zu entfernen, können Sie im Menü Extras den Befehl XDR-Schema exportieren verwenden. Weitere Informationen finden Sie unter Exportieren von XDR-Schemas.

Sie können ein Extensible (XML) Structure Definitions (XSD)-Schema aus einem XDR-Schema erstellen, indem Sie im Menü Extras den Befehl XSD-Schema exportieren verwenden. Weitere Informationen finden Sie unter Exportieren von XSD-Schemas.

Verwandte Themen

Erstellen und Überprüfen von Spezifikationen

Exportieren von XDR-Schemas

Exportieren von XSD-Schemas


Unterstützen von Standards

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Unterstützen von Standards

EDI-Standards (Electronic Data Interchange), wie z. B. EDIFACT und X12, definieren einen großen Teil der möglichen Segmente und Elemente, aus denen die für Geschäftsdokumente benötigte Dateistruktur gebildet wird. Mithilfe des BizTalk-Editors können Sie mit diesen Strukturen als Basis für Ihre Spezifikation beginnen und anschließend die nicht benötigten Segmente und Elemente entfernen. Die endgültige Struktur ist eine Teilmenge des Standards, auf den Sie sich mit Ihren Handelspartnern oder einer anderen Person innerhalb Ihrer Organisation zum Austausch von Geschäftsdaten geeinigt haben.

Wenn Sie in einem EDIFACT- oder X12-Dokument Knoten erstellen oder verschieben, sollten Sie unbedingt den Dokumentstandard auf BENUTZERDEFINIERT festlegen. Darüber hinaus sollten Sie auch die Trennzeichentyp-Eigenschaft festlegen, um die geänderte Struktur mit dem Rest des Dokuments kompatibel zu gestalten. Beachten Sie, dass alle Trennzeichentyp-Einstellungen verloren gehen, wenn Sie den Dokumentstandard von BENUTZERDEFINIERT auf EDIFACT oder X12 zurücksetzen. Weitere Informationen zum Festlegen der BENUTZERDEFINIERT-Eigenschaft finden Sie unter Festlegen von Verweiseigenschaften. Weitere Informationen zum Festlegen der Trennzeichentyp-Eigenschaft finden Sie unter Festlegen von Analyseeigenschaften.

Der BizTalk-Editor unterstützt außerdem X12-Syntaxregeln. Diese stellen relationale Bedingungen dar, die zwischen zwei oder mehr Elementen für einen Datensatz bestehen. Wenn die Spezifikation Syntaxregeln enthält, werden diese während des Laufzeitprozesses des Servers bei der Überprüfung der Spezifikation erzwungen.

Es existieren fünf Arten von Regeln:

  • All

    Wenn TXI08 vorhanden ist, muss der folgende Knoten vorhanden sein:

    • TXI03
  • Grouped

    Wenn einer der folgenden Knoten vorhanden ist, muss Beides vorhanden sein:

    • TXI04

    • TXI05
  • Any

    Mindestens einer der folgenden Knoten muss vorhanden sein:

    • TXI02

    • TXI03

    • TXI06
  • One

    Höchstens einer der folgenden Knoten muss vorhanden sein:

    • TXI02

    • TXI03

    • TXI06
  • Any (conditional)

    Wenn PO413 vorhanden ist, muss mindestens einer der folgenden Knoten vorhanden sein:

    • PO410

    • PO411

    • PO412

Verwandte Themen

Erstellen und Überprüfen von Spezifikationen

Bearbeiten von Notizen und Anzeigen von Syntaxregeln

Festlegen von Verweiseigenschaften

Zusammenfassungsliste der im Lieferumfang enthaltenen, auf EDI basierenden Dokumente


Zusammenfassungsliste der im Lieferumfang enthaltenen, auf EDI basierenden Dokumente

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Zusammenfassungsliste der im Lieferumfang enthaltenen, auf EDI basierenden Dokumente

Der BizTalk-Editor unterstützt alle auf EDI basierenden Dokumente. Die folgende Tabelle listet die beim Erstellen einer neuen, auf einem Standard basierenden Spezifikation zur Verfügung stehenden Standardspezifikationen, Versionen und Dokumentstandards für auf EDI basierende Dokumente auf. Weitere Informationen finden Sie unter Erstellen einer Spezifikation auf der Basis eines Standards.

Standard Version Dokumentstandards
X12
  • 2040

  • 3010

  • 3060

  • 4010
  • 810

  • 832

  • 846

  • 850

  • 852 (in allen Versionen mit Ausnahme von 2040 verfügbar)

  • 855

  • 856

  • 861

  • 864

  • 867

  • 940 (nur zusammen mit den Versionen 3060 und 4010 verfügbar)

  • 944 (nur zusammen mit den Versionen 3060 und 4010 verfügbar)

  • 997
EDIFACT
  • D93A

  • D95A

  • D95B

  • D97B

  • D98A

  • D98B
  • APERAK (in allen Versionen mit Ausnahme von D93A verfügbar)

  • CONTRL (nur zusammen mit den Versionen D98A und D98B verfügbar)

  • DESADV

  • INVOIC

  • INVRPT

  • ORDERS

  • ORDRSP

  • PARTIN

  • PAYEXT

  • PRICAT

  • PRODAT (nur zusammen mit den Versionen D97B, D98A und D98B verfügbar)

  • RECADV (nur zusammen mit den Versionen D97B, D98A und D98B verfügbar)

  • SLSRPT
XML
  • N/V
  • BTF1-Umschlag

  • Standardempfangsbestätigung

  • Standardvorausversandanzeige

  • Standardlagerhaltungsanzeige

  • Standardrechnung

  • Standardgeschäftspartnerprofil

  • Standardauftrag

  • Standardauftragsbestätigung

  • Standardpreiskatalog

  • Standardversandanzeige

  • Standardversandauftrag

  • Einfacher SOAP-Umschlag

Verwandtes Thema

Erstellen einer Spezifikation auf der Basis eines Standards


Verwenden von Flatfiles mit Feldern fester Breite und mit Trennzeichen

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Verwenden von Flatfiles mit Feldern fester Breite und mit Trennzeichen

Der BizTalk-Editor vereinfacht das Erstellen von Spezifikationen mit Dateistrukturen mit Flatfiles mit Feldern fester Breite, Flatfiles mit Trennzeichen oder mit kombinierten Dateistrukturen mit Feldern fester Breite und mit Trennzeichen. Die folgenden Abschnitte stellen spezielle Details zu all diesen Dateistrukturen bereit.

Flatfiles mit Feldern fester Breite

Eine Flatfile mit Feldern fester Breite besteht aus Feldern, die eine identische feste Länge aufweisen, und Datensätzen, die über ein gemeinsames Datensatz-Abschlusszeichen verfügen. Die Struktur einer eingehenden Datei muss in den Datensätzen und Feldern der Quellspezifikation dargestellt sein, damit der auf Feldern fester Breite basierende Charakter der eingehenden Datei gewahrt bleibt. Daher müssen Sie, bevor Sie die Dokumentstruktur einer Quellspezifikation definieren, ein Schema der erforderlichen Datensätze und Felder ermitteln.

In der nachfolgenden Tabelle wird ein Beispiel für ein festes Format gezeigt.

Name | Adresse | Stadt | Telefon
Xxxxxxxxxx | Aaaaaaaaaa | Ccccccccccccccc | xxx-xxx-xxxx
Yyyyyyyyyy | Bbbbbbbbbb | Ddddddddddddd | xxx-xxx-xxxx

In das Feld Name können maximal 10 Zeichen, in das Feld Adresse maximal 10 Zeichen, in das Feld Stadt maximal 15 Zeichen und in das Feld Telefon maximal 12 Zeichen eingegeben werden. Das Datensatz-Abschlusszeichen ist ein Wagenrücklauf- und/oder Zeilenvorschubzeichen.

Mithilfe des BizTalk-Editors können Sie aufeinander folgende Datensätze und Felder erstellen. Sie können mehrere Datensatztypen erstellen und übergeordneten Datensätzen verschiedene Trennzeichen zuweisen. Bei Strukturen, die mehrere Datensatztypen enthalten, muss die Spezifikation der Typen und Datensatz-Abschlusszeichen ebenfalls in der Reihenfolge angegeben werden, in der sie im Dokument auftreten. Felder müssen durch Anfangsposition, Länge und Datentyp angegeben werden.

Wenn eine Spezifikation vom Typ mit Feldern fester Breite ist und Sie die Struktur in einen Typ mit Trennzeichen ändern, enthält die kompilierte Spezifikation die ursprüngliche Anfangs- und Endposition, die auf der Registerkarte Verweis angegeben ist. Wenn BizTalk Server 2002 eine Spezifikation analysiert, ignoriert der Parser diese Informationen jedoch und verarbeitet die Spezifikation als Datei mit Trennzeichen.

Ein Datensatz mit Feldern fester Breite muss immer ein untergeordneter Datensatz eines Datensatzes mit Trennzeichen sein. Das für den übergeordneten Datensatz mit Trennzeichen angegebene Trennzeichen darf in den Daten des untergeordneten Datensatzes mit Feldern fester Breite nicht auftreten. Es gibt keine Möglichkeit, das Trennzeichen des übergeordneten Datensatzes mit Trennzeichen in den Daten des untergeordneten Feldes mit fester Breite durch ein Escapezeichen zu kapseln. Weitere Informationen zu Trennzeichen und Escapezeichen finden Sie unter Festlegen von Analyseeigenschaften.

Grundsätzliches zur Verwendung von Flatfiles mit Feldern fester Breite erfahren Sie im entsprechenden Beispiel im Ordner Flat-FilePositional unter \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\.

Anmerkung

  • Sie müssen auf der Registerkarte Analysieren die Struktur-Eigenschaft des Stammknotens auf Getrennt festlegen, wenn es sich um eine Flatfile mit Trennzeichen und mit Feldern fester Breite handelt. Weitere Datensatzeigenschaften werden je nach ihren Attributen auf Getrennt oder auf Feste Breite festgelegt.

Flatfile mit Trennzeichen

Eine Flatfile mit Trennzeichen enthält einen oder mehrere Datensätze, die durch ein Trennzeichen getrennt sind. Der BizTalk-Editor liest Trennzeichen nicht als Teil der Daten. Wenn das Trennzeichen jedoch innerhalb der Daten angezeigt wird, können die Daten formatiert werden, so dass Daten und Trennzeichen unterschieden werden können. Beispielsweise kann das Feld, in dem ein Trennzeichen angezeigt wird, in Anführungszeichen eingeschlossen sein. Auf diese Weise wird anzeigt, dass das Trennzeichen als Teil der Daten und nicht als Trennzeichen behandelt werden soll.

Mithilfe des BizTalk-Editors können Sie bestimmte Felder und die ihnen zugeordneten Trennzeichen auswählen. Darüber hinaus können Sie Datensatz-Abschlusszeichen angeben. Um die Verwendung von Flatfiles mit Trennzeichen zu ermöglichen, unterstützt der BizTalk-Editor Folgendes:

  • Strukturen, die aus mehreren Datensatzgruppen bestehen.

  • Mehrere Datensatztypen, die durch Datensatztyp-Tags definiert sind.

  • Datensatz-Abschlusszeichen.

  • Umbruch- und Escapezeichen, um zwischen Felddaten und Trennzeichenwerten zu unterscheiden.

  • Feldanfangs-, Längen- und Typwerte.

  • Feldinhaltstags und Beschreibungen.

  • Die Möglichkeit, Flatfiles in Spezifikationen umzuwandeln, die vom BizTalk-Mapper verwendet werden können.

Grundsätzliches zur Verwendung von Flatfiles mit Trennzeichen erfahren Sie im entsprechenden Beispiel im Ordner Flat-FileDelimited unter \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\.

Anmerkung

  • Sie müssen auf der Registerkarte Analysieren die Struktur-Eigenschaft des Stammknotens auf Getrennt festlegen, wenn es sich um eine Flatfile mit Trennzeichen und mit Feldern fester Breite handelt. Weitere Datensatzeigenschaften werden je nach ihren Attributen auf Getrennt oder auf Feste Breite festgelegt.

Verwandtes Thema

Erstellen einer Spezifikation auf der Basis einer Flatfile


Ungültige XML-Namenzeichen

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Ungültige XML-Namenzeichen

Unicode-Zeichen im Bereich von xF900 bis xFFFE sind in XML-Namen (Extensible Markup Language) nicht gültig. Wenn Sie ein ungültiges Unicode-Zeichen in einem XML-Namen verwenden, wird dieses Zeichen bei der Anzeige in der Spezifikationsstruktur in eine durch Escapezeichen gekapselte numerische Einheit übersetzt. Die durch Escapezeichen gekapselte numerische Einheit wird als _xHHHH_ codiert, wobei HHHH für den vierstelligen hexadezimalen Unicode-Code steht. Beispielsweise enthält der Name Versand an in einer Auftragsspezifikation ein Leerzeichen und wird in der Spezifikationsstruktur als Versand_x0020_an angezeigt. Wenn Sie den Mauszeiger über einen Knoten bewegen, der ein codiertes Unicode-Zeichen enthält, wird eine QuickInfo angezeigt, die den Knotennamen mit nicht codiertem Unicode-Zeichen anzeigt. Dies tritt ein, wenn Sie eine Spezifikationsstruktur im BizTalk-Editor oder im BizTalk-Mapper anzeigen.

Verwandte Themen

Erstellen und Überprüfen von Spezifikationen

Überprüfen einer neuen Dokumentinstanz


Ungültige Zeichenbereiche

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Ungültige Zeichenbereiche

Sie können die Ausgabe eines Zeichens oder eines Zeichenbereichs durch BizTalk Server 2002 blockieren. Öffnen Sie zu diesem Zweck im BizTalk-Editor eine Spezifikation, die als Zielspezifikation verwendet werden soll. Öffnen Sie das Dialogfeld Ungültiger Zeichenbereich, und geben Sie die Zeichen oder Zeichenbereiche ein, die nicht von BizTalk Server ausgegeben werden sollen. Immer wenn BizTalk Server versucht, ein im Dialogfeld Ungültiger Zeichenbereich einer Ausgabespezifikation angegebenes Zeichen zu verarbeiten, hält die Verarbeitung an, und es wird eine Fehlermeldung angezeigt.

Anmerkung

  • Zeichenbereiche können nur für nicht auf XML (Extensible Markup Language) basierende Dokumente blockiert werden.

Verwandte Themen

Hinzufügen ungültiger Zeichenbereiche

Löschen ungültiger Zeichenbereiche

Bearbeiten ungültiger Zeichenbereiche

Verwenden des BizTalk-Mappers


BizTalk-Editor - Umgebung

Beim Öffnen des BizTalk-Editors wird eine grafische Benutzeroberfläche (User Interface, UI) angezeigt, mit deren Hilfe Sie auf einfache Art und Weise Spezifikationen erstellen und verwenden können.

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-Editor - Benutzeroberfläche

  • BizTalk-Editor - Menüs

  • BizTalk-Editor - Symbolleisten-Schaltflächen


BizTalk-Editor - Benutzeroberfläche

BizTalk Server 2002 ~ Erstellen von Spezifikationen

BizTalk-Editor - Benutzeroberfläche

Die Benutzeroberfläche des BizTalk-Editors verfügt über drei Hauptbereiche. Der linke Bereich zeigt die Spezifikationsstruktur an, bei der es sich um eine grafische Darstellung einer Spezifikation handelt. Der oberste Knoten in der Spezifikationsstruktur ist der Stammknoten; er wird durch ein Buchsymbol dargestellt. Stammknoten Datensätze und Felder werden in der Spezifikationshierarchie unterhalb des Stammknotens angezeigt. Datensätze werden durch ein Dokumentsymbol mit horizontalen grünen Linien dargestellt. Datensatzknoten Felder werden durch ein Dokumentsymbol mit vertikalen blauen Linien dargestellt. Feldknoten Weitere Informationen zu Datensätzen und Feldern finden Sie unter Datensätze, Felder und Eigenschaften. Sie können einen Knoten in der Spezifikationsstruktur erweitern oder reduzieren, indem Sie auf das Erweiterungssymbol (+) oder auf das Reduktionssymbol (-) links neben dem Knoten klicken.

Der rechte Bereich enthält sechs Registerkarten: Deklaration, Verweis, Analysieren, Namespace, Wörterbuch und Codeliste. Verwenden Sie diese Registerkarten, um Eigenschaftswerte, Namespaces, Wörterbucheigenschaften und Codelisten für Knoten in einer Spezifikation festzulegen. Weitere Informationen zu diesen Registerkarten finden Sie unter Festlegen von Eigenschaften für Datensätze und Felder.

Der untere Bereich enthält zwei Registerkarten: Ausgabe und Warnungen. Die Registerkarte Ausgabe zeigt eine XML-Dokumentinstanz (Extensible Markup Language) an, die beim Verwenden des Befehls XML-Instanz erstellen erstellt wird, oder eine Flatfile, wenn der Befehl Systemeigene Instanz erstellen im BizTalk-Editor verwendet wird. Weitere Informationen zum Erstellen einer XML-Dokumentinstanz aus einer Spezifikation finden Sie unter Erstellen einer neuen Dokumentinstanz oder Erstellen einer systemeigenen Instanz. Die Registerkarte Warnungen zeigt an, ob ein Versuch der Überprüfung einer Dokumentinstanz anhand einer Spezifikation erfolgreich war. Zudem zeigt die Registerkarte Warnungen im Zusammenhang mit einem nicht erfolgreichen Versuch der Dokumentüberprüfung an. Weitere Informationen finden Sie unter Überprüfen einer neuen Dokumentinstanz.

Verwandte Themen

Erstellen einer neuen Dokumentinstanz

Erstellen einer systemeigenen Instanz

Festlegen von Eigenschaften für Datensätze und Felder

Überprüfen einer neuen Dokumentinstanz


BizTalk-Editor - Menüs

BizTalk Server 2002 ~ Erstellen von Spezifikationen

BizTalk-Editor - Menüs

Die Menüs in BizTalk-Editor gruppieren Befehle unter logischen Gesichtspunkten und erleichtern so das Ausführen einer bestimmten Aufgabe. Beispielsweise können Sie die Befehle im Menü Ansicht verwenden, um alle Datensätze und Felder in der Spezifikationsstruktur anzuzeigen oder zu reduzieren.

Die folgenden Menüs stehen im BizTalk-Editor zur Verfügung:

  • Datei Verwenden Sie dieses Menü, um eine Spezifikation zu erstellen, zu öffnen, zu speichern oder zu schließen.

  • Bearbeiten Verwenden Sie dieses Menü, um Datensätze oder Felder in einer Spezifikation auszuschneiden, zu kopieren, einzufügen, umzubenennen oder zu löschen.

  • Ansicht Verwenden Sie dieses Menü für folgende Aktionen:
    • Auswählen von Ansichten im rechten Bereich der Benutzeroberfläche.

    • Auswählen von Ansichten im unteren Bereich der Benutzeroberfläche.

    • Auswählen einer Textgröße für die Anzeige des BizTalk-Editors.

    • Anzeigen des Dialogfeldes Ungültiger Zeichenbereich.

    • Erweitern oder Reduzieren der Spezifikationsstruktur.

    • Markieren der nächsten Warnung auf der Registerkarte Warnung.
  • Extras Verwenden Sie dieses Menü für folgende Aktionen:
    • Überprüfen einer Spezifikation.

    • Überprüfen einer Dokumentinstanz anhand einer Spezifikation.

    • Erstellen einer auf XML (Extensible Markup Language) basierenden Dokumentinstanz oder einer systemeigenen Instanz aus einer Spezifikation.

    • Importieren von Dateien.

    • Exportieren von XDR-Schemas (XML-Data Reduced) oder XSD-Schemas.

    • Anzeigen von Optionen für den BizTalk-Editor.
  • Hilfe Verwenden Sie dieses Menü, um Grundlageninformationen zu erhalten, die Bedeutung von Aufgaben kennenzulernen und Verfahrensweisen zur Verwendung des BizTalk-Editors anzuzeigen.

Verwandtes Thema

BizTalk-Mapper - Menüs


BizTalk-Editor - Symbolleisten-Schaltflächen

BizTalk Server 2002 ~ Erstellen von Spezifikationen

BizTalk-Editor - Symbolleisten-Schaltflächen

Der BizTalk-Editor stellt eine Symbolleiste zur Ergänzung der Menüleiste bereit. Alle Schaltflächen der Symbolleiste zeigen grafische Darstellungen der von ihnen ausgeführten Aufgaben an. Sie werden auf der Symbolleiste in der folgenden Reihenfolge angezeigt (von links nach rechts):

  • Neu

  • Öffnen

  • Speichern

  • Aus WebDAV abrufen

  • Im WebDAV speichern

  • Spezifikationsknoten ausschneiden

  • Spezifikationsknoten kopieren

  • Spezifikationsknoten einfügen

  • Spezifikationsknoten löschen

  • Neuer Datensatz

  • Neues Feld

  • Datensatz einfügen

  • Feld einfügen

  • Reduzieren

  • Erweitern


Importieren von Dateien

Mithilfe des BizTalk-Editors können Sie Dateien importieren. Der Editor erstellt die Dateistruktur. Sie müssen jedoch die Werte sämtlicher Datensatz- und Feldeigenschaften zuweisen. Die folgenden Dateitypen können in den BizTalk-Editor importiert werden:

  • Wohlgeformte XML-Instanzen

  • Dokumenttypdefinitionen (DTDs)

  • XDR- Schemas (XML-Data Reduced)

  • Microsoft Office-Dateien (mithilfe des Importmoduls für wohlgeformten XML-Code)

Das Importieren einer Datei, die einen externen Verweis auf eine andere Datei enthält, ist jedoch nicht möglich. Nach dem Importieren einer wohlgeformten XML-Instanz, einer Dokumenttypdefinition, eines XDR-Schemas oder einer Microsoft Office-Datei erstellt der BizTalk-Editor eine Struktur, die auf der importierten Datei basiert. Außerdem zeigt er eine Reihe von Datensätzen und Feldern an. Wenn die zu importierende Datei jedoch keine untergeordneten Elemente aufweist und über ein Element mit Inhalt verfügt, das in den Instanzdaten wiederholt wird, erstellt der BizTalk-Editor beim Importieren der Struktur dieses Element als Feld (und nicht als Datensatz). Nach dem Speichern der Datei im BizTalk-Editor wird die Datei zu einer Spezifikation. Diese Spezifikation weist die entsprechenden Kopfzeileninformationen auf und folgt einer angegebenen Struktur.

Der BizTalk-Editor kann ermitteln, welches Element als Stammknoten verwendet werden soll. Wenn der Editor das entsprechende Stammknotenelement jedoch nicht ermitteln kann, werden Sie in einem Dialogfeld aufgefordert, das als Stammknoten zu verwendende Element anzugeben. Falls für den <schema>-Knoten jedoch ein name="a_name"-Attribut festgelegt ist, verwendet der BizTalk-Editor diesen Elementnamen als Stammknoten und fordert Sie nicht zur Auswahl eines Stammknotens auf. Dies gilt auch, wenn mehrere Kandidaten vorhanden sind oder wenn der durch name angegebene Stamm Teil eines Zyklus ist. Wenn Sie einen Stammknoten auswählen möchten, müssen Sie die XDR-Datei öffnen und das name="a_name"-Attribut entfernen. Importieren Sie anschließend die Datei. Der BizTalk-Editor wird Sie dann zur Auswahl eines Stammelements auffordern.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Importieren von wohlgeformtem XML-Code

  • Importieren von DTDs

  • Importieren von XDR-Schemas

  • Importieren von Microsoft Office XP-Dateien

Verwandtes Thema

Erstellen einer Spezifikation auf der Basis einer importierten Datei


Importieren von wohlgeformtem XML-Code

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Importieren von wohlgeformtem XML-Code

Wohlgeformter XML-Code (Extensible Markup Language) schließt alle Microsoft Office-Dateien ein, die Sie importieren können. Falls Sie über eine wohlgeformte XML-Instanz verfügen, die ein XDR-Schema enthält, kann diese nicht importiert werden. Zudem kann der BizTalk-Editor beim Importieren von wohlgeformtem XML-Code keine Datentyp- oder Feldlängenparameter interpretieren. Der BizTalk-Editor kann nach dem Importieren einer wohlgeformten XML-Datei Warnungen anzeigen, die sich auf zyklische Verweise beziehen. In diesem Fall wird dringend empfohlen, dass Sie die in den Warnungen genannten Punkte beheben und die Spezifikation vor dem Fortsetzen speichern.

Beim Importieren einer wohlgeformten XML-Datei, die einen Namespace des Stammknotens enthält, wird dieser Namespace zum Zielnamespace und in den übrigen Teilen der Spezifikation nicht berücksichtigt. Weitere Informationen zu Zielnamespaces finden Sie unter Festlegen von Verweiseigenschaften.

Verwandtes Thema

Erstellen einer Spezifikation auf der Basis einer importierten Datei


Importieren von Dokumenttypdefinitionen

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Importieren von Dokumenttypdefinitionen

Beim Importieren von Dokumenttypdefinitionen (DTDs) kann der BizTalk-Editor keine Datentyp- oder Feldlängenparameter interpretieren. In einigen speziellen Fällen werden Datentypen eindeutig behandelt. In der folgenden Tabelle sind einige dieser Fälle aufgeführt.

Vorhandene Datentypen | Auswirkungen auf die DTD-Datei
entity und entities | Die Datei kann importiert werden, aber die Datentypen werden entfernt.
nmtoken und nmtokens | Die Datei kann importiert werden, aber die Datentypen werden entfernt.
notation | Die Datei kann importiert werden, aber der Datentyp wird als Aufzählungstyp importiert.

Wenn die letzte Zeile einer Dokumenttypdefinition ein Verweis auf eine Entität ist (beispielsweise "%xx"), kann die Dokumenttypdefinition nicht in den BizTalk-Editor importiert werden. Falls Sie eine neue Zeile am Ende der Dokumenttypdefinition erstellen, die ein Zeilenendezeichen enthält, importiert der BizTalk-Editor die Dokumenttypdefinition.

Wenn eine Dokumenttypdefinition über mehrere Stämme verfügt, gibt der BizTalk-Editor während des Importierens nicht notwendigerweise bei jeder Ersetzung eine Warnung aus.

Das Importieren einer Dokumenttypdefinition ist darüber hinaus nicht möglich, wenn deren Elemente Kommentare enthalten. Sie müssen die betreffenden Dateien bearbeiten und sämtliche Kommentare in Elementen entfernen, um diese Dokumenttypdefinitionen erfolgreich importieren zu können.

Verwandtes Thema

Erstellen einer Spezifikation auf der Basis einer importierten Datei


Importieren von XDR-Schemas

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Importieren von XDR-Schemas

Beim Importieren von XDR-Schemas (XML-Data Reduced) behandelt der BizTalk-Editor einige Datentypen eindeutig. In der folgenden Tabelle sind einige dieser Datentypen aufgeführt.

Vorhandene Datentypen | Auswirkungen auf die XDR-Schemadatei
entity und entities | Die Datei kann nicht importiert werden.
nmtoken und nmtokens | Die Datei kann importiert werden, aber die Datentypen werden entfernt.
notation | Die Datei kann nicht importiert werden.

Das Importieren eines XDR-Schemas ist nicht möglich, wenn der Standardwert für ein Attribut vom Typ IDREFS in der Attributdeklaration angegeben ist. Beispiel:

<AttributeType name="Field1" d:type="idrefs" default="a1 a2"> </AttributeType>
<attribute type="Field1" required="no"></attribute>

Um dieses Problem zu lösen, verschieben Sie den Standardwert in den Attributverweis im XDR-Schema, ehe sie diesen in den BizTalk-Editor importieren. Dies wird im folgenden Codebeispiel gezeigt:

<AttributeType name="Field1" d:type="idrefs"> </AttributeType>
<attribute type="Field1" required="no" default="a1 a2"></attribute>

Verwandtes Thema

Erstellen einer Spezifikation auf der Basis einer importierten Datei


Importieren von MicrosoftOfficeXP-Dateien

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Importieren von Microsoft Office XP-Dateien

Der BizTalk-Editor entfernt den Microsoft Office XP-Namespace ss, andere benutzerdefinierte Namespaces werden jedoch nicht entfernt. Die Präfixe benutzerdefinierter Namespaces werden jedoch ersetzt. 0:abc wird z. B. durch 0_abc ersetzt. Eine Microsoft Excel-Kalkulationstabelle (als XML-Datei gespeichert) enthält z. B. die folgenden Informationen:

<Workbook xmlns="urn:schemas-microsoft-com:office:spreadsheet"
 xmlns:o="urn:schemas-microsoft-com:office:office"
 xmlns:x="urn:schemas-microsoft-com:office:excel"
 xmlns:ss="urn:schemas-microsoft-com:office:spreadsheet"
 xmlns:html="http://www.w3.org/TR/REC-html40">

In diesem Fall erkennt der BizTalk-Editor, dass der Zielnamespace xmlns mit dem Namespace mit Präfix xmlns:ss übereinstimmt. Statt das ss-Präfix redundant im ganzen Schema zu verwenden, hat der BizTalk-Editor das ss-Präfix bei jedem Vorkommen gelöscht, da es sich um denselben exakten Namespace handelt, der als Zielnamespace definiert ist.

Verwandtes Thema

Erstellen einer Spezifikation auf der Basis einer importierten Datei


Exportieren von Dateien

Sie können neue und vorhandene Spezifikationen nur exportieren, wenn sie im BizTalk-Editor geöffnet sind. Beim Exportieren einer Spezifikation werden die BizTalk-spezifischen Anmerkungen aus der Struktur entfernt, und die sich ergebende Struktur wird als allgemeines Schema gespeichert, das von anderen Anwendungen verwendet werden kann. Sie können XDR-Schemas (XML-Data Reduced) und Extensible (XML) Structure Definitions (XSD)-Schemas exportieren.

Zudem können Sie aus einem XDR-Schema mithilfe eines Konvertierungsskripts, das bei einer vollständigen Installation von BizTalk Server 2002 bereitgestellt wird, ein XSD-Schema erstellen.

Verwandte Themen

Exportieren von XDR-Schemas

Export XSD schemas


Datensätze, Felder und Eigenschaften

Der BizTalk-Editor stellt eine Spezifikation als eine Strukturansicht von Datensätzen und Feldern in einer vorgegebenen Reihenfolge dar. Innerhalb dieser Struktur können mithilfe von Datensätzen und Feldern Beziehungen zwischen übergeordneten und untergeordneten Elementen erstellt werden. Datensätze können weitere Datensätze oder Felder enthalten, aber Felder können keine weiteren Felder oder Datensätze enthalten. Ein Datensatz ist immer ein Element, aber ein Feld kann ein Element oder ein Attribut sein.

Sie können Datensätze und Felder zu Datensätzen hinzufügen und darin einfügen sowie Datensätze und Felder in Felder einfügen. Datensätze oder Felder können nicht zu einem Feld hinzugefügt werden. In der folgenden Abbildung ist dargestellt, wie Datensätze und Felder in Beziehung zu einem bestimmten Knoten in der Struktur platziert werden.

Darstellung einer Datensatz- und Feldstruktur

Wenn Sie LeereSpezifikation auswählen und auf die Schaltfläche Neuer Datensatz klicken, wird Datensatz1 erstellt. Durch Klicken auf die Schaltfläche Neues Feld wird Feld1 erstellt. Dies ist in Abschnitt A der Abbildung dargestellt. Wenn Sie Datensatz1 auswählen und auf die Schaltfläche Neuer Datensatz klicken, wird Datensatz2 erstellt. Durch Klicken auf die Schaltfläche Neues Feld wird Feld1 (unter Datensatz2) erstellt. Dies ist in Abschnitt B der Abbildung dargestellt. Wenn Sie Datensatz1 auswählen und auf die Schaltfläche Datensatz einfügen klicken, wird Datensatz3 erstellt. Durch Klicken auf die Schaltfläche Feld einfügen wird Feld2 erstellt. Dies ist in Abschnitt C der Abbildung dargestellt.

Durch die Spezifikationsstruktur, die Datensätze und Felder als Knoten darstellt, können Sie auf einfache Weise, alle Datensätze und Felder in einer Spezifikation anzeigen, erstellen, bearbeiten und löschen. Jeder Knoten in der Spezifikationsstruktur weist eine Reihe von Eigenschaftsdefinitionen auf, die auf sechs Registerkarten im Hauptfenster des BizTalk-Editors dargestellt sind: Deklaration, Verweis, Analysieren, Namespace, Wörterbuch und Codeliste. Die Daten auf diesen Registerkarten sind für den BizTalk-Editor erforderlich, um ein Dokument aus seinem ursprünglichen Format in XML (Extensible Markup Language) zu übersetzen. Die Informationen definieren die Struktur des Dokuments, die Reihenfolge und Länge der Daten sowie deren Format. Zudem geben sie an, ob es sich um ein Dokument mit Feldern fester Breite oder mit Trennzeichen handelt.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Datensätze und ihre Eigenschaften

  • Unterstütztes Zeitformat für X12

  • Unterstützung für gemischten Inhalt

  • Felder und ihre Eigenschaften

  • Berechnen von Feldpositionen

  • Zeichenlängenbeschränkungen

  • Codelistenwerte und Beschreibungen

  • Auffüllzeichen

  • Eigenschaftsbereich

  • Zyklische Verweise

  • Integration von Standardwerten

  • Zusammenfassung der Datentypen und Datentypwerte


Datensätze und ihre Eigenschaften

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Datensätze und ihre Eigenschaften

Abhängig vom Typ der Spezifikation, die Sie erstellen, müssen Sie möglicherweise Datensätze hinzufügen und/oder entfernen. Nach dem Hinzufügen von Datensätzen zu einer Spezifikation müssen Eigenschaften angegeben werden. Beim Entfernen eines Datensatzes werden dessen Eigenschaften ebenfalls entfernt, zusammen mit allen untergeordneten Datensätzen und Feldern.

Wenn Ihre Spezifikation auf X12 oder EDIFACT basiert, können Sie nur Datensätze des Typs hinzufügen, der im betreffenden Standard vorhanden ist. Sie können jedoch beliebige Datensätze oder auch alle Datensätze entfernen. Wenn Sie eine Spezifikation erstellen, die auf einer leeren Spezifikation basiert, müssen Sie Datensätze hinzufügen. In einigen Fällen, z. B. beim Erstellen einer neuen Spezifikation, die auf einer vorhandenen Spezifikation basiert, müssen Sie möglicherweise Datensätze hinzufügen oder entfernen.

Beim Hinzufügen oder Einfügen eines Datensatzes können Sie sofort mit der Eingabe zum Umbenennen des Datensatzes beginnen. Sie können den Namen eines vorhandenen Datensatzes und dessen Eigenschaften bearbeiten, indem Sie den Datensatz auswählen und ihn entsprechend bearbeiten.

Wenn Sie in eine Spezifikation einen Datensatz einfügen, dessen Name mit dem Namen eines bereits vorhandenen Datensatzes identisch ist, wird eine Zahl am Ende des Namens für den eingefügten Datensatz angefügt.

Informationen zum Erstellen einer neuen Instanz eines vorhandenen Datensatzes finden Sie unter Erstellen einer neuen Instanz eines vorhandenen Datensatzes. Informationen zum Erstellen eines zyklischen Verweises finden Sie unter Erstellen von zyklischen Verweisen.

Verwandte Themen

Erstellen einer neuen Instanz eines vorhandenen Datensatzes

Erstellen von zyklischen Verweisen

Eigenschaftsbereich

Festlegen von Eigenschaften für Datensätze und Felder


Unterstütztes Zeitformat für X12

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Unterstütztes Zeitformat für X12

Im BizTalk-Editor lautet das unterstützte Zeitformat für die X12-Syntax HHMMSSDD. (Diese Syntax wird angegeben, wenn auf der Registerkarte Verweis für den Stammknoten des Schemas Standard=X12 angezeigt wird.) Dabei gilt Folgendes:

  • HH stellt die Stunden dar. Gültige Eingaben sind 00 bis 23.

  • MM stellt die Minuten dar. Gültige Eingaben sind 00 bis 59.

  • SS stellt ganze Sekunden dar. Gültige Eingaben sind 00 bis 59.

  • DD stellt die Dezimalsekunden dar. Dezimalsekunden können in einem der folgenden Formate gesendet werden:
    • D stellt die Zehntel einer Sekunde dar. Gültige Eingaben sind ist 0 bis 9.

    • DD stellt die Hundertstel einer Sekunde dar. Gültige Eingaben sind 00 bis 99.

      Wenn Sie die Zeit in Zehnteln oder Hundertsteln einer Sekunde angeben möchten, verwenden Sie den benutzerdefinierten Datentyp Benutzerdefiniertes Datum/Zeitformat (beschrieben unter Anwenden der Eigenschaft "Benutzerdefiniertes Datum/Zeitformat").

    Unter Verwendung dieses Formats können Daten, die die zuvor aufgeführten Einschränkungen für den Eingabebereich erfüllen, vier-, sechs-, sieben- oder achtstellig sein. Das Angeben von HHMMSSDD für ein Zeitformat bedeutet also, dass die Daten der Instanz mit HHMM, HHMMSS, HHMMSSD oder HHMMSSDD übereinstimmen müssen.

    Alle Zeitfelder, die das benutzerdefinierte Format HHMMSSDD verwenden, werden als Zeichenfolgen behandelt, weil XML keine Dezimalsekunden oder Hundertstelsekunden unterstützt. Mit dem Funktion Systemeigene Instanz erstellen wird kein benutzerdefiniertes HHMMSSDD-Format erstellt.


Unterstützung für gemischten Inhalt

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Unterstützung für gemischten Inhalt

Der BizTalk-Editor unterstützt gemischten Inhalt hauptsächlich für Organisationen, die XDR-Schemas unverändert verwenden. Falls ein Schema gemischten Inhalt enthält, bedeutet dies, dass ein Element sowohl Inhalt in Textform als auch untergeordnete Elemente enthält. Sie können den Inhalt des Schemas als gemischten Inhalt angeben, indem Sie auf der Registerkarte Deklaration für die Inhalt-Eigenschaft als Wert Gemischt festlegen. Dieses Attribut wird nur auf XML-Dokumenttypen (Extensible Markup Language) angewendet und kann nur für die Datensatzebene eines Schemas, nicht für die Feldebene angegeben werden.

Das folgende Beispiel zeigt ein Schemafragment für Inhalt, für den der Eigenschaftswert "mixed" (Gemischt) festgelegt ist:

<ElementType name="ProgramManager" content="mixed">
<element type="Name" >
<element type="OfficeNumber" >
</ElementType>

Im folgenden Beispiel wird ein Schemafragment gezeigt, das eine XML-Instanz darstellt:

<ProgramManager>
A program manager named <Name>Mike Hines</Name> works in office <OfficeNumber>2234</OfficeNumber>.
</ProgramManager>

Wenn im vorherigen Beispiel der Inhalt des <Program Manager>-Elements aus einer Quellspezifikationsstruktur im BizTalk-Mapper mit einem Datensatz in der Zielspezifikationsstruktur verknüpft wäre, lautete die Ausgabe folgendermaßen:

A program manager named Mike Hines works in office 2234.

Verwandtes Thema

Festlegen von Deklarationseigenschaften


Felder und ihre Eigenschaften

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Felder und ihre Eigenschaften

Abhängig vom Typ der Spezifikation, die Sie erstellen, müssen Sie möglicherweise Datensätze hinzufügen und/oder entfernen. Felder entsprechen EDI-Elementen (Electronic Data Interchange). Nach dem Hinzufügen von Feldern zu einer Spezifikation, einschließlich EDI-Dokumenten, müssen Sie Eigenschaftswerte angeben.

Wenn Ihre Spezifikation auf X12 oder EDIFACT basiert, können Sie nur Felder des Typs hinzufügen, der im betreffenden Standard vorhanden ist. Sie können jedoch beliebige Felder oder auch alle Felder entfernen. Wenn Sie eine Spezifikation erstellen, die auf einer leeren Spezifikation basiert, müssen Sie Felder hinzufügen. Unabhängig vom Dokumenttyp, können die Eigenschaften jedes Feldes geändert werden.

Wenn Sie ein neues Feld zu einer Spezifikation hinzufügen oder es in diese einfügen, ist die Typ-Eigenschaft, die Sie auf der Registerkarte Deklaration finden, standardmäßig auf Attribut festgelegt. Sie können diesen Wert für jedes Feld manuell in Element ändern. Informationen zum Erstellen von neuen Feldern, bei denen die Typ-Eigenschaft standardmäßig auf Element festgelegt ist, finden Sie unter Erstellen eines neuen Feldes als Element.

Beim Hinzufügen oder Einfügen eines Feldes können Sie sofort mit der Eingabe zum Umbenennen des Feldes beginnen. Sie können den Namen eines vorhandenen Feldes und dessen Eigenschaften bearbeiten, indem Sie das Feld auswählen und es entsprechend bearbeiten.

Wenn Sie in eine Spezifikation ein Elementfeld einfügen, dessen Name mit dem Namen eines bereits vorhandenen Elementfeldes identisch ist, wird eine Zahl am Ende des Namens für das eingefügte Feld angefügt. Wenn Sie in eine Spezifikation ein Feld mit demselben Namen wie dem eines vorhandenen gleichgeordneten Feldes einfügen (und beide Felder über denselben Typ-Wert verfügen), wird eine Zahl am Ende des Namens für das eingefügte Feld angefügt. Weitere Informationen zu Typ-Werten finden Sie unter Festlegen von Deklarationseigenschaften. Informationen zum Erstellen einer neuen Instanz eines vorhandenen Elementfeldes finden Sie unter Erstellen einer neuen Instanz eines vorhandenen Elementfeldes.

Verwandte Themen

Erstellen eines neuen Feldes als Element

Erstellen einer neuen Instanz eines vorhandenen Elementfeldes

Eigenschaftsbereich

Festlegen von Deklarationseigenschaften

Festlegen von Eigenschaften für Datensätze und Felder


Berechnen von Feldpositionen

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Berechnen von Feldpositionen

Der BizTalk-Editor kann die Anfangs- und Endpositionen für alle Felder in einem Datensatz mit Feldern fester Breite automatisch berechnen. Legen Sie zuerst auf der Registerkarte Deklaration für jedes Feld im Datensatz mit Feldern fester Breite einen Wert für Datentyp und einen Wert für Maximallänge fest. Klicken Sie anschließend mit der rechten Maustaste auf den Datensatz mit Feldern fester Breite, und klicken Sie dann im Kontextmenü auf Feldpositionen berechnen. Die Anfangs- und Endpositionen für die Felder im betreffenden Datensatz werden automatisch berechnet. Weitere Informationen finden Sie unter Automatisches Berechnen von Feldpositionen.

Die Feldpositionen eines Datensatzes werden vom ersten Feld im Datensatz der Reihe nach bis zum letzten Feld berechnet. Wenn beim Berechnen von Feldpositionen ein Feld gefunden wird, für dessen Maximallänge-Eigenschaft kein Wert festgelegt ist, werden die Anfangs- und Endposition für dieses Feld und alle nachfolgenden Felder des Datensatzes nicht berechnet. Die Anfangs- und Endpositionen eines Feldes mit dem Wert 1 für Maximallänge sind gleich. Wenn beim Berechnen von Feldpositionen ein gleichgeordneter Datensatz gefunden wird, werden die Anfangs- und Endpositionen aller auf den gleichgeordneten Datensatz folgenden Felder nicht berechnet.

Wenn für die Felder in einem Datensatz mit Feldern fester Breite Anfangs- und Endpositionen angegeben sind, werden alle diese Angaben mit Ausnahme der Anfangsposition des ersten Feldes beim Berechnen der Feldpositionen außer Kraft gesetzt. Beim Berechnen von Feldpositionen wird der Wert für Anfangsposition des ersten Feldes eines Datensatzes mit Feldern fester Breite auf 1 festgelegt, es sei denn, für das Feld wurde zuvor ein Wert für Anfangsposition festgelegt. Wenn für das erste Feld eines Datensatzes mit Feldern fester Breite bereits ein Wert für Anfangsposition festgelegt wurde, beginnt die Berechnung ausgehend von diesem Wert. Beim Berechnen von Feldpositionen für einen Datensatz mit Feldern fester Breite werden die Positionen von Feldern, die in abgeleiteten Datensätzen enthalten sind, ebenfalls berechnet. Die Positionen von gleichgeordneten Feldern, die vor einem Datensatz auftreten, werden berechnet. Positionen gleichgeordneter Felder, die nach einem Datensatz auftreten, werden hingegen nicht berechnet.

Die Feldpositionsberechnung berücksichtigt beim Berechnen von Feldpositionen den Quelltagbezeichner. Stellen Sie sich beispielsweise einen Datensatz mit Feldern fester Breite mit den folgenden Eigenschaften vor:

  • Der Wert für Quelltagbezeichner ist TAG.

  • Die Wert für Quelltagposition ist 10.

  • Es existieren vier Felder mit den Werten 2, 5, 8 und 6 für Maximallänge.

  • Für das erste Feld ist kein Wert für Anfangsposition festgelegt.

Die Anfangs- und Endpositionen der vier Felder sind:

  • Feld 1 = 1, 2

  • Feld 2 = 3, 7

  • Nicht verwendet = 8, 9

  • TAG = 10, 12

  • Feld 3 = 13, 20

  • Feld 4 = 21, 26

Falls Quelltagposition den Wert 1 hätte, wären die Anfangs- und Endpositionswerte von TAG die Zahlen 1 und 3 gewesen, und der Feldzähler hätte bei Position 4 begonnen.

Verwandtes Thema

Automatisches Berechnen von Feldpositionen


Zeichenlängenbeschränkungen

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Zeichenlängenbeschränkungen

Es existieren Beschränkungen für die Anzahl der Zeichen, die Sie in Namen und Eigenschaftswerten verwenden können. Die folgende Tabelle zeigt die Zeichenbeschränkungen im BizTalk-Editor.

Name oder Eigenschaftswert | Maximale Anzahl von Zeichen
Knotenname (der Name eines Stammknotens, eines Datensatzes oder eines Feldes) | 255
Namespacepräfix | 64
Zeichenfolgen-Eigenschaftswert | 1024
LONG-Eigenschaftswert | 11
ULONG-Eigenschaftswert | 10
CHAR-Eigenschaftswert | 1
Eigenschaftswert für EDI-Formate (Electronic Date Interchange) (der Wert einer EDI-spezifischen Formateigenschaft, wie z. B der Eigenschaftswert Benutzerdefiniertes Datum/Zeitformat auf der Registerkarte Analysieren für ein Feld in einer auf EDI basierenden Spezifikation) | 15
Zielnamespace | 255
Spezifikationsname | 255

Verwandte Themen

Festlegen von Deklarationseigenschaften

Festlegen von Verweiseigenschaften

Festlegen von Analyseeigenschaften

Deklarieren von Namespaces

Festlegen von Wörterbucheigenschaften


Codelistenwerte und Beschreibungen

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Codelistenwerte und Beschreibungen

Die auf der Registerkarte Codeliste enthaltenen Informationen geben X12- oder EDIFACT-Codewerte und ihre Beschreibungen an. Nur Spezifikationen, die auf einem X12- oder EDIFACT-Standard basieren, verfügen über Codelisten. Die Beschreibungen definieren die Bedeutung jedes Codes. Beispielsweise bedeutet der Codewert ST im Feld Address Qualifier Code vieler Standarddokumentspezifikationen, dass die angegebenen Informationen sich auf eine Versandadresse beziehen. Die Codes in der Liste können weder geändert noch gelöscht werden. Sie können lediglich auswählen, ob ein bestimmter Code einem Feld zugeordnet werden soll.

Nicht allen Feldern in einer Spezifikation, die auf X12 oder EDIFACT basiert, sind Codes zugeordnet. Eine vollständige Liste der für ein bestimmtes Feld verfügbaren Codes wird auf der Registerkarte Codeliste angezeigt, wenn das Feld einen Codelistenverweis enthält. Codes sind für ein Feld gültig, wenn das Kontrollkästchen in der Werte-Spalte neben dem Code aktiviert ist. Eine Beschreibung des Codes wird in der Beschreibung-Spalte angezeigt. Wenn Sie einen Code einem Feld zuordnen, muss der Wert Typ auf der Registerkarte Deklaration auf Attribut festgelegt sein.

Sie können die einem Feld zugeordneten Codes ein- oder ausschließen, indem Sie die Kontrollkästchen in der Wert-Spalte neben dem auf der Registerkarte Codeliste aufgelisteten Code aktivieren oder deaktivieren. Codes werden nach numerischen oder alphabetischen Werten oder anhand einer Kombination von numerischen und alphabetischen Werten aufgelistet. Der Wert stellt eine bestimmte Beschreibung dar. Sie können jedem beliebigen Feld in der Spezifikationsstruktur einen Codewert zuordnen. Beispielsweise können Sie im Feld BEG02 eines X12 850-Auftrags den Code OS auswählen, der ein Attribut zum Feld BEG02 hinzufügt, das anzeigt, dass das Feld besondere Auftragsinformationen enthält.

Auswirkungen einer "Custom"-Struktur auf Codelisten

Wenn Sie die Struktur einer auf X12 oder EDIFACT basierenden Spezifikation in BENUTZERDEFINIERT ändern und diese anschließend wieder in X12 oder EDIFACT zurück ändern, steht die Codeliste für ein bestimmtes Feld möglicherweise nicht mehr auf der Registerkarte Codeliste zur Verfügung. Wenn dies der Fall ist, speichern Sie die Spezifikation, und öffnen Sie sie anschließend erneut. Die Codeliste wird wieder auf der Registerkarte Codeliste für das entsprechende Feld angezeigt.

Speicherort der Codelisten-Datenbank

Codelistenwerte und Beschreibungen für die auf EDI basierenden Spezifikationsvorlagen, die in BizTalk Server 2002 bereitgestellt werden, befinden sich in der Microsoft Access-Datenbankdatei unter \Programme\Microsoft BizTalk Server\XML Tools\Databases\CodeLists\CodeListsX12a.mdb. Wenn Sie in dieser Datenbank neue Tabellen für neue Spezifikationsvorlagen erstellen, ist das Format für den Tabellennamen standard_version. Beispielsweise ist für eine D99A EDIFACT-Spezifikationsvorlage der entsprechende Tabellenname EDIFACT_D99A.

Wichtig

  • Wenn Sie in der CodeListsX12a.mdb-Datenbank eine neue Tabelle erstellen, verwenden Sie keine ungültigen XML-Zeichen (Extensible Markup Language) (Unicode-Zeichen im Bereich F900 bis FFFE) in der Werte-Spalte der Tabelle. Wenn Sie eine Spezifikation speichern, die ein Feld mit einem ausgewählten Codelistenwert enthält, der einem Wert in einer Tabelle mit einem ungültigen XML-Zeichen zugeordnet ist, können Sie die Spezifikation nicht öffnen.

Verwandte Themen

Codes löschen

Auswählen von Codes

Festlegen von Eigenschaften für Datensätze und Felder


Auffüllzeichen

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Auffüllzeichen

Der BizTalk-Editor ermöglicht die Verwaltung von Auffüllzeichen in Dokumenten mit Trennzeichen, um sicherzustellen, dass Sie die erwartete Ausgabe erhalten. Da jedes Dokument mit Trennzeichen, das von BizTalk Server 2002 verarbeitet wird, vor der Zuordnung XML (Extensible Markup Language) übersetzt werden muss, müssen Sie sicherstellen, dass Ihre Dokumentspezifikation BizTalk Server anweist, wie Auffüllzeichen in Dokumentinstanzen mit Trennzeichen zu verarbeiten sind. Beispielsweise kann in einer Dokumentinstanz mit Trennzeichen ein Feld wie das Folgende vorkommen:

Gruen*****

Der Dateninhalt des Feldes ist Gruen, das Feld ist linksbündig ausgerichtet, es existieren fünf Auffüllzeichen rechts neben dem Dateninhalt, und das Auffüllzeichen ist ein Sternchen (*).

Wenn Sie das Auffüllzeichen für das Feld nicht in der Spezifikation definieren, die dem Feld in der Dokumentinstanz entspricht, interpretiert BizTalk Server die fünf Sternchen als Teil des Dateninhalts des Feldes. Sie müssen überprüfen, ob die Eigenschaften auf der Registerkarte Analysieren für dieses Feld wie in der folgenden Tabelle festgelegt sind, um sicherzustellen, dass BizTalk Server die Auffüllzeichen in diesem Feld ordnungsgemäß verarbeitet.

Eigenschaft | Wert
Blocksatz | Nach links
Auffüllzeichen | *
Minimallänge mit Auffüllzeichen | Legen Sie diesen Eigenschaftswert fest, wenn die Länge des Feldes in der Ausgabeinstanz größer als oder gleich einer bestimmten Länge sein soll. BizTalk Server fügt Auffüllzeichen in das Feld ein, um die korrekte minimale Feldlänge in der Ausgabeinstanz zu erreichen.

Sie können die Auffüllzeichen-Eigenschaft verwenden, um sicherzustellen, dass Auffüllzeichen in einem Feld aus einer an BizTalk Server gesendeten Dokumentinstanz entfernt werden. Der Eigenschaftswert Minimallänge mit Auffüllzeichen stellt sicher, dass BizTalk Server bei Bedarf Auffüllzeichen in ein Feld in der Ausgabeinstanz einfügt. Die Blocksatz-Eigenschaft zeigt an, auf welcher Seite des Felddateninhalts die Auffüllzeichen entfernt (aus der Eingabedokumentinstanz) oder eingefügt (in die Ausgabeinstanz) werden. Schließende Auffüllzeichen werden zu einem Feld mit linksbündiger Ausrichtung hinzugefügt oder aus diesem entfernt, und führende Auffüllzeichen werden zu einem Feld mit rechtsbündiger Ausrichtung hinzugefügt oder aus diesem entfernt. Wenn die Auffüllzeichen-Eigenschaft für ein Feld nicht festgelegt ist, werden keine Auffüllzeichen zu diesem Feld hinzugefügt oder aus diesem entfernt.

Verwandtes Thema

Festlegen von Analyseeigenschaften


Eigenschaftsbereich

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Eigenschaftsbereich

Wenn Sie über zwei oder mehr Instanzen eines Datensatzes in einer Spezifikation verfügen, müssen die Werte bestimmter Eigenschaften für diese Instanzen identisch sein. Anders ausgedrückt ist der Bereich dieser Eigenschaften global. Der Bereich bestimmter Feldeigenschaften kann ebenfalls global sein, jedoch nur, wenn die Typ-Eigenschaft für das Feld auf Element festgelegt ist. Der Bereich eines Feldes, dessen Typ-Eigenschaft auf Attribut festgelegt ist, ist hingegen immer lokal.

Beispielsweise sind alle Eigenschaften auf den Registerkarten Deklaration und Analysieren für mehrere Instanzen eines Datensatzes oder Feldes identisch. Wenn Sie eine Deklaration- oder Analysieren-Eigenschaft für eine Instanz eines Datensatzes oder Feldes ändern, ändert sich diese Eigenschaft automatisch auch für alle anderen Instanzen des betreffenden Datensatzes oder Feldes. Die Eigenschaften auf den Registerkarten Verweis und Wörterbuch weisen jedoch keinen globalen Bereich auf, daher können die Werte dieser Eigenschaften für jede Instanz eines Datensatzes oder Feldes unabhängig festgelegt werden. Codelisten werden nur auf Felder angewendet, und ihr Bereich ist nicht global.

Anmerkung

  • Im BizTalk-Editor weisen nur ElementType-Deklarationen einen globalen Bereich auf. Wenn Sie ein Schema in den BizTalk-Editor importieren, das AttributeType-Deklarationen mit globalem Bereich enthält, und dieses Schema dann als Spezifikation speichern, wird der Bereich der AttributeType-Deklarationen automatisch in einen lokalen Bereich innerhalb der entsprechenden ElementType-Deklaration bzw. -Deklarationen umgewandelt.

Verwandte Themen

Festlegen von Deklarationseigenschaften

Festlegen von Analyseeigenschaften


Zyklische Verweise

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Zyklische Verweise

A Ein zyklischer Verweis in einer Spezifikation tritt auf, wenn ein Datensatz als Ableitung seiner selbst erstellt wird. Ein zyklischer Verweis kann nur auftreten, wenn der Wert der Standard-Eigenschaft auf der Registerkarte Verweis auf XML festgelegt ist. Der BizTalk-Editor stellt einen zyklischen Verweis durch ein Symbol dar Symbol "Zyklischer Verweis", das einen Datensatz mit einem gekrümmten Pfeil zeigt.

Die folgende Abbildung zeigt, wie ein zyklischer Verweis im BizTalk-Editor angezeigt wird.

Die Anzahl der Zyklen-Eigenschaft wird auf der Registerkarte Deklaration angezeigt und nur auf einen zyklischen Knoten angewendet. Der Standardwert ist 7. Die Anzahl der Zyklen zeigt an, wie viele Zyklen unterhalb des Basisdatensatzes zur Verfügung stehen. Beispielsweise gibt es in der vorherigen Abbildung eine Gesamtanzahl von vier Ebenen für Datensatz1: drei aus der Zykluszahl 3 und eine aus dem Basisdatensatz. Wenn Sie diese Spezifikation im BizTalk-Mapper öffnen, werden alle vier Ebenen von Datensatz1 angezeigt. Feld1 und Datensatz2 werden ebenfalls für jeden Datensatz vom Typ Datensatz1 angezeigt. Sie können auf jeder Ebene des Zyklus Verknüpfungen mit Knoten herstellen.

Es ist nicht möglich, Wörterbuch-Eigenschaftswerte für Felder festzulegen, die von einem zyklischen Knoten abgeleitet sind. Beispielsweise können Sie in der vorherigen Abbildung Wörterbuch-Eigenschaftswerte für Stamm/Datensatz1/Feld1 festlegen, nicht jedoch für die Verweise auf Feld1 im Zyklus unterhalb von Stamm/Datensatz1/Datensatz1.

Zyklische Verweise unterliegen den folgenden Einschränkungen:

  • Knoten in einem Zykluspfad (die Knoten, die zwischen dem ersten und dem letzten Datensatz eines zyklischen Verweises auftreten) können nicht an anderer Stelle in der Spezifikation angezeigt werden.

  • Elemente auf einem Zykluspfad können nicht Quelle oder Ziel von Drag & Drop-Vorgängen oder von Ausschneide- und Einfügevorgängen sein.

  • Zyklen können sich nicht überschneiden.

  • Der Stammdatensatz eines zyklischen Verweises kann nicht der Stammknoten der Spezifikation sein.

Wichtig

  • Die Minimalvorkommen-Eigenschaft auf der Registerkarte Verweis für den zyklischen Verweisknoten muss auf 0 festgelegt sein. Das Festlegen auf 1 bewirkt eine Endlosschleife.

  • Wenn Sie ein Schema importieren, das einen zyklischen Verweis enthält, überprüft der BizTalk-Editor den zyklischen Verweis nicht automatisch auf Gültigkeit.

Verwandte Themen

Erstellen von zyklischen Verweisen

Eigenschaftsbereich


Integration von Standardwerten

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Integration von Standardwerten

Wenn eine Quellspezifikation ein Feld vom Typ Attribut enthält und eine eingehende Dokumentinstanz, die auf der Quellspezifikation basiert, dieses Feld nicht enthält, kann es sinnvoll sein, dass die Spezifikation einen Standardwert für das Feld zur Verfügung stellt.

Wenn eine eingehende Dokumentinstanz das Feld nicht enthält, wird der Standardwert für das Feld bereitgestellt. Wenn eine eingehende Dokumentinstanz das Feld enthält, wird der Standardwert ignoriert.

Verwandtes Thema

Festlegen von Deklarationseigenschaften


Zusammenfassung der Datentypen und Datentypwerte

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Zusammenfassung der Datentypen und Datentypwerte

Die folgende Liste stellt Detailinformationen und Beispiele bereit, die Sie beim Angeben eines Wertes für die Datentyp-Eigenschaft auf der Registerkarte Deklaration unterstützen. Nach dem Auswählen einer der folgenden Optionen aus der Liste Datentyp müssen Sie möglicherweise einen Wert im Feld Datentypwerte angeben.

Datentyp

Character

Enthält eine Zeichenfolge mit einer Länge von einem Zeichen.

String

Enthält beliebigen Text.

Number

Enthält eine Zahl mit Dezimalstellen und kann über ein Vorzeichen, Nachkommastellen und einen Exponenten verfügen. Es wird die standardmäßige englische Zeichensetzung verwendet; beispielsweise 15, 3.14, -123.456E+10.

Integer (int)

Enthält eine Zahl und kann ein optionales Vorzeichen einschließen. Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise 1, 58502, -13.

Float

Enthält eine Zahl ohne Beschränkung der Dezimalstellen und kann über ein Vorzeichen, Nachkommastellen oder einen Exponenten verfügen.

Fixed Point (14.4)

Gleich wie Number, kann jedoch nicht mehr als 14 Stellen links vom Dezimalzeichen und nicht mehr als 4 Stellen rechts vom Dezimalzeichen enthalten; beispielsweise 12.0044. Dieser Datentyp kann für Währungswerte verwendet werden.

Boolean

Enthält einen Ausdruck, der entweder zu TRUE (1) oder zu FALSE (0) ausgewertet wird.

Date

Enthält ein Datum in einer Teilmenge des ISO 8601-Formats ohne Uhrzeitinformationen; beispielsweise 1988-04-07.

Date Time

Enthält ein Datum in einer Teilmenge des ISO 8601-Formats mit optionalen Uhrzeitinformationen und ohne optionale Zeitzoneninformationen. Sekundenbruchteile sind bis zum Nanosekundenbereich möglich; beispielsweise 1988-04-07T18:39:09.

Date Time.tz

Enthält ein Datum in einer Teilmenge des ISO 8601-Formats mit optionalen Uhrzeit- und optionalen Zeitzoneninformationen; Sekundenbruchteile sind bis zum Nanosekundenbereich möglich; beispielsweise 1988-04-07T18:39:09-08:00.

Time

Enthält eine Uhrzeit in einer Teilmenge des ISO 8601-Formats ohne Datums- und Zeitzoneninformationen; beispielsweise 08:15:27.

Time.tz

Enthält eine Uhrzeit in einer Teilmenge des ISO 8601-Formats ohne Datumsinformationen, jedoch mit optionalen Zeitzoneninformationen; beispielsweise 08:15:27-05:00.

Byte (i1)

Enthält eine Zahl und kann ein optionales Vorzeichen enthalten, wie z. B. ein Minuszeichen (-). Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise 1, 127, -128.

Word (i2)

Enthält eine Zahl und kann ein optionales Vorzeichen enthalten, wie z. B. ein Minuszeichen (-). Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise 1, 703, -32768.

Integer (i4)

Enthält eine Zahl und kann ein optionales Vorzeichen enthalten, wie z. B. ein Minuszeichen (-). Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise 1, 703, -32768, 148343, -1000000000.

Double Integer (i8)

Enthält eine Zahl und kann ein optionales Vorzeichen enthalten, wie z. B. ein Minuszeichen (-). Es sind keine Bruchzahlen oder Exponenten möglich; beispielsweise 1, 703, -32768, 148343, -1000000000.

Unsigned Byte (ui1)

Enthält eine Zahl. Es sind keine Zeichen, Bruchzahlen oder Exponenten möglich; beispielsweise 1, 255.

Unsigned Word (ui2)

Enthält eine Zahl. Es sind keine Zeichen, Bruchzahlen oder Exponenten möglich; beispielsweise 1, 255, 65535.

Unsigned Integer (ui4)

Enthält eine Zahl. Es sind keine Zeichen, Bruchzahlen oder Exponenten möglich; beispielsweise 1, 703, 3000000000.

Double Unsigned Integer (ui8)

Enthält eine Zahl. Es sind keine Zeichen, Bruchzahlen oder Exponenten möglich; beispielsweise 1, 703, 3000000000.

Real (r4)

Enthält eine Zahl mit einem Mindestwert von 1.17549435E-38F und einem Höchstwert von 3.40282347E+38F; beispielsweise 3.14285718E+2.

Double Real (r8)

Enthält eine Zahl mit einem Mindestwert von 2.2250738585072014E308 und einem Höchstwert von 1.7976931348623157E+308; beispielsweise .314159265358979E+1.

Universal Unique Identifier (uuid)

Enthält hexadezimale Stellen, die Oktetts darstellen, mit optionalen eingebetteten Trennstrichen, die ignoriert werden können; beispielsweise 333C7BC4-460F-11D0-BC04-0080C7055A83.

Uniform Resource Identifier (uri)

Enthält einen URI (Uniform Resource Identifier).

Binary (base64)

Enthält eine binäre Codierung von binärem Text in Zeichen; beispielsweise die Konvertierung einer GIF-Grafik (Graphic Interchange Format) in eine Textdarstellung.

Binary (hex)

Enthält eine binäre hexadezimale Stelle, die Oktetts darstellt; beispielsweise 0x0ffaa.

ID

Gibt das Feld als ID an.

IDREF

Gibt an, dass das Feld auf das Feld mit dem ID-Wert verweisen soll.

IDREFS

Gibt an, dass das Feld eine durch Leerzeichen getrennte Liste von IDs enthalten soll.

Enumeration

Weist einer Reihe von Werten eine Ordinalreihenfolge zu; beispielsweise können Montag, Dienstag, Mittwoch als 1 2 3 aufgezählt werden.

Anmerkung

  • Der Fixed Point (14.4)-Datentyp kann für Währungswerte verwendet werden.

  • Wenn Sie einen Filter für einen Date/Time-Datentyp (dateTime, dateTime.tz, time, time.tz) verwenden möchten, müssen Sie ihn manuell in den XPath-Ausdruck eingeben. Beispielsweise self::node()[@ATTDATETIME = "2000-03-15T10:10:10"], wobei ATTDATETIME der Datentyp für das Datum/Zeitformat ist.

Verwandtes Thema

Festlegen von Deklarationseigenschaften


Allzweck-Trigger

Der BizTalk-Editor stellt auf der Registerkarte Analysieren die Triggerfeld-Eigenschaft zur Verfügung, mit deren Hilfe ein Triggerfeld für einen beliebigen Segmenttyp für Microsoft® BizTalk™ Accelerator for HIPAA -Schemas identifiziert werden kann. Ein Triggerfeld stellt grundsätzlich eine Form der inhaltsqualifizierten Kennzeichnung dar. Der vorhandene Enumeration-Datentyp und das vorhandene Wert-Attribut geben die Werte an, die den zu identifizierenden Trigger auslösen. Der Parser interpretiert dieses Triggerfeld während der Analyse und ordnet den Instanzinhalt dem Knoten in dem Schema zu, das die entsprechenden Triggerwerte aufweist.

Es gibt 11 Segmenttypen, die Triggerfelder zur erweiterten Definition ihrer Bedeutung verwenden. Diese Segmenttypen und die entsprechenden Triggerfelder sind in der folgenden Tabelle aufgeführt.

Segment | Triggerfeld
AMT | AMT01
CRC | CRC01
DTM | DTM01
DTP | DTP01
ENT | ENT02
HI | HI01:01 (01 ist ein zusammengesetztes erstes Unterfeld)
N1 | N101
NM1 | NM01
NTE | NTE01
REF | REF01
RMR | RMR01

Der BizTalk-Editor lässt doppelte Peers zu, wenn alle Peers Triggerfelder mit sich gegenseitig ausschließenden Werten verwenden. Somit sind doppelte Peers weiterhin unzulässig sind, wenn sie nicht eindeutig sind.

Darüber hinaus erweitern Trigger die Schleifeninterpretation auf einfache Art und Weise, da das Triggersegment (d. h. das Segment mit dem Triggerfeld) immer das erste Segment in der Schleife ist. Trigger werden auch in Segmenten unterstützt, die innerhalb einer Schleife geschachtelt sein können.

Der BizTalk-Editor kann nicht überprüfen, ob sich Enumerationen im Triggerwert in demselben Quelltagbezeichner überlappen. Wenn Sie die Eigenschaften bearbeiten und dabei eine Überlappung erstellen, tritt ein Laufzeitfehler auf. Die von Ihnen hinzugefügten Anmerkungen, die zur Unterstützung der Segmentschachtelung erforderlich sind, gehen beim Speichern einer Spezifikation nicht verloren.

Zusätzlich zu den in der vorherigen Tabelle genannten Segmenttypen gibt es einen Sonderfall für das HL-Segment (Hierarchical Level). Weitere Informationen zu diesem Segment finden Sie unter Sonderfall für das HL-Segment.

Wichtig

  • Triggerfelder können nur Attribute des Datensatzes oder der Schleife sein, für den bzw. die ein Trigger ausgeführt wurde. Der Grund hierfür liegt darin, dass alle Felder in X12-Schemas mithilfe von Attributen dargestellt werden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Überprüfung von Triggerfeldern

  • Sonderfall für das HL-Segment

  • Einschränkungen der Instanzstruktur

  • HL-Überprüfung

Verwandtes Thema

Festlegen von Analyseeigenschaften


Überprüfung von Triggerfeldern

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Überprüfung von Triggerfeldern

Zur Entwurfszeit überprüft der BizTalk-Editor nur, ob das angegebene Triggerfeld vorhanden ist und ob es sich um ein Attribut handelt. Alle weiteren Überprüfungen finden zur Laufzeit statt. Alle verfügbaren HIPAA-Schemas werden zur Laufzeit überprüft. Für sie gelten folgende Überprüfungskriterien:

  • Peerelementknoten mit demselben Quelltagbezeichner müssen dieselbe Struktur haben und dasselbe Triggerfeld in ihren entsprechenden Hierarchien angeben.

  • Jeder Peerelementknoten definiert sich gegenseitig ausschließende Enumerationswerte für das gemeinsame Triggerfeld.

  • Instanzdaten, die nicht mit einem der möglichen Triggerwerte der Strukturen übereinstimmen, werden als unerwartete, in der Instanz gefundene Daten gekennzeichnet. Dies entspricht der Verhaltensweise in der Situation, wenn der Quelltagbezeichner nicht im Schema gefunden wird.

  • Falls geschachtelte Trigger im Schema vorhanden sind und der erste untergeordnete Datensatz der ausgelösten Schleife ebenfalls ausgelöst wird, kann dieser untergeordnete Datensatz nicht wiederholt werden.

  • Ebenso gilt für alle im Peer ausgelösten Segmente hinsichtlich der Einstellungen für ihr Minimal/Maximal-Vorkommen, dass 1/1s zuerst kommt, gefolgt von 1/*, gefolgt von 0/[1|*]. Wenn diese Anforderung nicht erfüllt wird, tritt ein Analysefehler auf.

Verwandtes Thema

Festlegen von Analyseeigenschaften


Sonderfall für das HL-Segment

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Sonderfall für das HL-Segment

Das Verwenden von HL-Segmenten (Hierarchical Level) stellt einen Sonderfall für Triggerfelder dar, da zusätzlich zur Interpretation der Werte von Triggerfeldern auch Beziehungen zwischen übergeordneten und untergeordneten Elementen beachtet werden müssen. Das HL-Segment enthält die folgenden Felder in der angegebenen Reihenfolge:

  1. Numerische Sequenz-ID von oben nach unten im Dokument, die bei "1" beginnt.

  2. Übergeordnete Sequenz-ID

  3. Ebenenindikator des Triggerfeldes (beispielsweise 22=Abonnenten, 23=Abhängig)

  4. Untergeordneter Indikator (0=Nein; 1=Ja)

Der Parser verwendet den Inhalt dieser Felder zum Erstellen einer Hierarchie für die gefundenen HL-Segmente. Während diese Hierarchie dem Schema nicht explizit widerspricht, verursacht der Inhalt des HL-Segments, dass der Parser die Struktur anders interpretiert.

Für HL-Segmente sind zudem Implikationen von Serialisierungskomponenten vorhanden. Während des Zuordnungsprozesses von BizTalk Server 2002 sollte es nicht erforderlich sein, dass Sie für die Felder 1 und 2 (die zuvor aufgeführt wurden) Inhalt erstellen müssen. Wenn Sie Inhalt für diese Felder erstellen, setzt die Serialisierungskomponente diesen Inhalt außer Kraft.

Verwandtes Thema

Festlegen von Analyseeigenschaften


Einschränkungen der Instanzstruktur

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Einschränkungen der Instanzstruktur

Der X12-Parser gibt zwei Einschränkungen für die Instanzstrukturpermutation im Hinblick auf HL-Segmente (Hierarchical Level) an:

  • No Skips (Kein Überspringen) Bei dieser Schemaeinschränkung muss sich ein HL-Segment/Schleife im Stamm genau eine Ebene unterhalb des zugehörigen übergeordneten HL-Segments/Schleife befinden, sofern eine übergeordnete Hierarchieebene vorhanden ist. HL1/N1/HL2 wird beispielsweise nicht unterstützt. Eine Reihenfolge von "x" verschachtelten HLs muss also genau "x" Generationen von Ebenen in der Struktur umfassen. Die folgenden Abbildungen zeigen Beispiele für zulässige und nicht zulässige HL-Segment/Schleife-Szenarien.

    Beispiele für zulässige und nicht zulässige HL-Segment/Schleife-Szenarien

  • No jumps (Keine Sprünge) Durch diese Dateneinschränkung wird verhindert, dass Sie eine fehlerhafte Hierarchie angeben. Für alle HLs, die auf eine übergeordnete HL verweisen, gilt, dass keine weiteren HLs zwischen ihnen in der Sequenz im Instanzdatenstrom vorhanden sein dürfen. Dies wird als "no jumps" bezeichnet, da die als Struktur gezeichnete eingeschränkte Aktion gleichbedeutend ist mit einem Sprung von einer Verzweigung zu einer anderen und anschließend einem Sprung zurück in die entsprechende HL-Sequenz. In der folgenden Tabelle ist die Einschränkung No jumps dargestellt.
    ID | Übergeordnete ID
    1 -
    2 | 1
    3 | 2
    4 | 3
    5 | 1
    6 | 4

    Beim Durchlaufen der HLs in der Reihenfolge, wie sie im Parserdatenstrom gefunden werden, ist jede HL eine untergeordnete HL der vorherigen HL, bis zu Nr. 5. Hierbei handelt es sich um ein wiederholtes Vorkommen von Nr. 2. Dies ist zulässig und wird erwartet. Danach folgt Nr. 6, das sich als ein untergeordnetes Element von Nr. 4 zu identifizieren versucht. Dies ist nicht zulässig, da sich Nr. 5 in der Reihenfolge zwischen Nr. 6 und der HL befindet, die sie als ihr übergeordnetes Element aufruft (Nr. 4).

Anmerkung

  • Die HIPAA-spezifischen Schemas, die im Lieferumfang von Microsoft BizTalk Accelerator für HIPAA enthalten sind, können mit dem BizTalk-Editor geändert werden. Stellen Sie beim Ändern der Schemas unbedingt sicher, dass Sie die unterschiedlichen Aspekte der Richtlinien für die HIPAA-Implementierung beachten.

Verwandtes Thema

Festlegen von Analyseeigenschaften


HL-Überprüfung

BizTalk Server 2002 ~ Erstellen von Spezifikationen

HL-Überprüfung

Zusätzlich zu den unter Überprüfung von Triggerfeldern erläuterten Überprüfungen von Triggerfeldern werden auch HL-Segmente (Hierarchical Level) überprüft. Die folgenden Überprüfungen werden zur Laufzeit ausgeführt:

  • No skips/no jumps (Kein Überspringen/Keine Sprünge). Wenn Schemas gefunden werden, die gegen diese Einschränkungen verstoßen, tritt ein Laufzeitfehler auf.

  • All HL schema fields must be attributes (Alle HL-Schemafelder müssen Attribute sein). Dies wird zur Laufzeit überprüft und führt zu einem Fehler, wenn gegen diese Einschränkung verstoßen wird.

  • HL02 must be optional (HL02 muss optional sein). Diese Einschränkung ist erforderlich, da nicht alle HLs über übergeordnete Elemente verfügen (beispielsweise HLs der obersten Ebene). In den Schemas erzwingt eine Syntaxregel das Vorhandensein dieses Feldes.

  • HL04 must be "0" or "1" (HL04 muss "0" oder "1" sein). Diese Einschränkung wird mithilfe eines Enumeration-Datentyps für dieses Feld erzwungen, der Wert ist 0 oder 1.

  • Data out of order (Falsche Reihenfolge der Daten). HL-Segmente müssen in der ordnungsgemäßen hierarchischen Reihenfolge ankommen. Diese Einschränkung stimmt mit No jumps überein, bei der es grundsätzlich erforderlich ist, dass den Verzweigungen der Struktur bis zu ihrem Abschluss gefolgt wird, ehe in eine andere Struktur eingetreten werden kann (hierarchisch betrachtet). Ebenso kann ein Verzweigungswechsel nicht rückgängig gemacht werden.

Verwandtes Thema

Festlegen von Analyseeigenschaften


Namespaceunterstützung

Der BizTalk-Editor unterstützt Namespaces. Ein XML-Namespace (Extensible Markup Language) ist eine Sammlung von Namen, die als Element- oder Attributsnamen in einem XML-Dokument verwendet werden können. Mithilfe des Namespaces werden Elementnamen eindeutig qualifiziert, um Konflikte zwischen Elementen mit dem gleichen Namen zu verhindern, die in demselben Dokument vorhanden sein können. Der Namespace wird durch einen URI (Universal Resource Identifier) entweder als URL (Uniform Resource Locator) oder als URN (Uniform Resource Name) identifiziert.

Bei Datenformaten, die nicht auf XML basieren, wird das XDR-Schema mit Elementen und Attributen versehen, die zum BizTalk Server 2002-Namespace gehören. Diese durch einen Namespace qualifizierten Elemente und Attribute enthalten Informationen zum Verarbeiten von nicht auf XML basierenden Formaten, wie z. B. EDI- und Flatfile-Dokumente. Mit Hilfe dieser Informationen können sie zu einer XML-Darstellung neu formatiert werden, die BizTalk Server zum Umwandeln, Protokollieren und Überwachen verwenden kann.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Namespacedeklarationen

  • Bewahren von Namespaces in importierten Dateien


Namespacedeklarationen

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Namespacedeklarationen

Namespaces, die in einer Spezifikation deklariert sind, werden auf der Registerkarte Namespace des BizTalk-Editors angezeigt. Die folgende Tabelle zeigt die Präfixe und Namespaces, die standardmäßig auf der Registerkarte Namespace angezeigt werden, wenn Sie eine Spezifikation im BizTalk-Editor öffnen. Diese Präfixe und Namespaces können nicht bearbeitet werden.

Präfix | Namespace
(Standard) | urn:schemas-microsoft-com:xml-data
b | urn:schemas-microsoft-com:BizTalkServer
d | urn:schemas-microsoft-com:datatypes

Anmerkung

  • Der folgende Namespace wird von BizTalk Server 2002 nicht unterstützt:

    SOAP-ENC=http://schemas.xmlsoap.org/soap/encoding/

Sie können benutzerdefinierte Namespaces in einer Spezifikation deklarieren, indem Sie ein Namespacepräfix in der Präfix-Spalte und einen Namespace in der Uniform Resource Name-Spalte der Registerkarte Namespace eingeben. Der BizTalk-Editor überprüft nicht den URN (Uniform Resource Name), den Sie für einen Namespace eingeben.

Darüber hinaus können Sie eine benutzerdefinierte Anmerkung zu jedem beliebigen Datensatz und Feld hinzufügen. Eine benutzerdefinierte Anmerkung besteht aus einem Präfix/Name-Paar und einem zugeordneten Wert. Die Syntax für ein Präfix/Name-Paar wird im folgenden Beispiel gezeigt:

präfix:name

Geben Sie auf der Registerkarte Deklaration oder Verweis ein Präfix/Name-Paar in der Eigenschaft-Spalte und einen Wert in der Werte-Spalte ein. Auf der Registerkarte Deklaration eingegebene Eigenschaftswerte weisen einen globalen Bereich auf, auf der Registerkarte Verweis eingegebene Eigenschaftswerte haben hingegen einen lokalen Bereich. Weitere Informationen zu globalen und lokalen Bereichen finden Sie unter Eigenschaftsbereich. Weitere Informationen zum Hinzufügen benutzerdefinierter Anmerkungen finden Sie unter Hinzufügen von benutzerdefinierten Anmerkungen.

Verwandte Themen

Hinzufügen von benutzerdefinierten Anmerkungen

Deklarieren von Namespaces

Bewahren von Namespaces in importierten Dateien

Eigenschaftsbereich


Bewahren von Namespaces in importierten Dateien

BizTalk Server 2002 ~ Erstellen von Spezifikationen

Bewahren von Namespaces in importierten Dateien

Drei Dateitypen können in den BizTalk-Editor importiert werden: XDR-Schemas (XML-Data Reduced), wohlgeformte XML-Instanzen und Dokumenttypdefinitionen (DTDs). Der BizTalk-Editor behandelt vorhandene Namespaces und Präfix/Name-Paare für jeden Dokumenttyp unterschiedlich.

Importieren eines XDR-Schemas

Beim Importieren von XDR-Schemas werden vorhandene Namespaces in folgender Weise behandelt:

  • Namespacedeklarationen werden als benutzerdefinierte Namespaces beibehalten und auf der Registerkarte Namespace unter den standardmäßigen Namespaces angezeigt.

  • Benutzerdefinierte Namespacepräfixe (mit Ausnahme derjenigen, die den Eigenschaften Name und Typ zugeordnet sind) werden nur beibehalten, wenn der zugeordnete Namespace deklariert ist.

Anmerkung

  • Der BizTalk-Editor kann kein XDR-Schema importieren, das ein Namespacepräfix aufweist, das der Eigenschaft Name oder Typ zugeordnet ist.

Importieren einer wohlgeformten XML-Instanz

Beim Importieren einer wohlgeformten XML-Dokumentinstanz werden Namespacedeklarationen aus dem Dokument entfernt, und das Präfix/Name-Trennzeichen wird von einem Doppelpunkt (:) in einen Unterstrich (_) geändert, so dass die ursprüngliche Absicht des Namespacepräfixes nicht verloren geht. Beispiel:

präfix_name

Wichtig

  • Wenn Sie eine wohlgeformte XML-Dokumentinstanz, die ein Namespacepräfix/Name-Paar enthält, importieren, die importierte Instanz als Spezifikation speichern und dann versuchen, die ursprüngliche Dokumentinstanz anhand der neuen Spezifikation zu überprüfen, schlägt die Überprüfung fehl. Löschen Sie in der neuen Spezifikation den Knoten, der das Präfix/Name-Paar enthält. Wählen Sie für den übergeordneten Datensatz dieses Knotens (auf der Registerkarte Deklaration) für die Modell-Eigenschaft den Wert Offen aus, und speichern Sie die Spezifikation. Sie können die Dokumentinstanz anhand dieser Spezifikation überprüfen.

Anmerkung

  • Der BizTalk-Editor kann kein Dokument importieren, das ein Namespacepräfix enthält, wenn der zugeordnete Namespace nicht im Dokument deklariert wurde.

Importieren einer Dokumenttypdefinition

Beim Importieren einer Dokumenttypdefinition, die ein Präfix/Name-Paar enthält, wird das Trennzeichen von einem Doppelpunkt (:) in einen Unterstrich (_) geändert. Dies geschieht, damit hinsichtlich der Platzierung in der Gesamtstruktur die ursprüngliche Absicht des Präfix nicht verloren geht, obwohl die Präfixnotation selbst nicht unterstützt wird. Beispiel:

präfix_name

Verwandtes Thema

Namespacedeklarationen


Hinzufügen von SQL-Anmerkungen

Sie können für jeden beliebigen Knoten in einer Spezifikation eine SQL-Anmerkung angeben. Beim Angeben einer SQL-Anmerkung auf der Registerkarte Deklaration wird eine Anmerkung mit globalem Bereich erstellt. Die Anmerkung wird innerhalb der ElementType- oder AttributeType-Deklaration in der Spezifikation gespeichert. Beim Angeben einer SQL-Anmerkung auf der Registerkarte Verweis wird eine Anmerkung mit lokalem Bereich erstellt. Die Anmerkung wird innerhalb des Element- oder Attribut-Verweises in der Spezifikation gespeichert.

Sie können eine SQL-Anmerkung in der Liste auswählen, die angezeigt wird, wenn Sie auf der Registerkarte Deklaration oder Verweis für einen Knoten in einer Spezifikation auf ein leeres Feld in der Eigenschaft-Spalte doppelklicken. Geben Sie einen Wert für die SQL-Anmerkung in das entsprechende Feld in der Werte-Spalte ein. Für alle SQL-Anmerkungen mit Ausnahme von "sql:relationship" und "sql:xpath-query" stellt der Wert gewöhnliche Zeichenfolgendaten dar. Weitere Informationen zum Hinzufügen von SQL-Anmerkungen und anderen benutzerdefinierten Anmerkungen finden Sie unter Hinzufügen von benutzerdefinierten Anmerkungen.

Die folgende Liste zeigt alle im BizTalk-Editor möglichen SQL-Anmerkungen:

  • sql:datatype

  • sql:field

  • sql:id

  • sql:id-prefix

  • sql:is-constant

  • sql:key-fields

  • sql:limit-field

  • sql:limit-value

  • sql:map-field

  • sql:is-mapping-schema

  • sql:overflow-field

  • sql:relation

  • sql:relationship

  • sql:target-namespace

  • sql:url-encode

  • sql:use-cdata

  • sql:xpath-query

Der Wert von "sql:relationship" besteht in einem oder mehreren Name/Wert-Paar(en), und der Name in jedem der Name/Wert-Paare muss der vier folgenden Namen sein: key, key-relation, foreign-key oder foreign-relation. Der Wert von "sql:xpath-query" besteht aus zwei Teilen: Der erste Teil besteht aus einem oder mehreren Name/Wert-Paar(en), die Attribute umfassen, und der zweite Teil ist der Inhalt von "sql:xpath-query" in der Form "content=...". Diese beiden Teile sind durch das Nummernzeichen (#) getrennt.

Die folgende Tabelle zeigt gültige Beispiele der SQL-Anmerkungen "sql:relationship" und "sql:xpath-query".

SQL-Anmerkung | Beispielwerte
sql:relationship | key="KundenID"
sql:relationship | key-relation="Kund"
sql:relationship | foreign-key="KundenID"
sql:relationship | foreign-relation="Auftraege"
sql:xpath-query | mapping-schema="Schema.xml" #content=Mitarbeiter

Anmerkungen

  • Der BizTalk-Editor beschränkt die Auswahl von SQL-Anmerkungen nicht auf Anmerkungen, die im aktuellen Kontext angemessen sind. Beispielsweise stehen "sql:relationship" und "xpath-query" auf der Registerkarte Deklaration zur Verfügung, obwohl ihre Verwendung nur auf der Registerkarte Verweis zulässig ist.

  • Beim Angeben einer SQL-Anmerkung wird automatisch ein Namespace mit einem Präfix sql und einem entsprechenden URN-Wert (Uniform Resource Name) auf der Registerkarte Namespace deklariert.

  • Wenn Sie einen Knoten mit auf der Registerkarte Verweis angegebenen SQL-Anmerkungen kopieren oder ausschneiden und diesen Knoten dann an einer anderen Stelle in der Spezifikation einfügen, sind die SQL-Anmerkungen im neuen Knoten nicht vorhanden.

Verwandte Themen

Hinzufügen von benutzerdefinierten Anmerkungen

Namespacedeklarationen

Eigenschaftsbereich


Erstellen von XML- und systemeigenen Instanzen

Um die erfolgreiche Verwendung von Microsoft BizTalk Server 2002 in Ihrer Produktionsumgebung sicherzustellen, stellt der BizTalk-Editor einen Mechanismus zum Testen der Spezifikationen vor der Verwendung in Ihrer Organisation bereit. Das Ändern von Instanzen schließt entweder das Testen einer Instanz anhand einer Spezifikation oder das Generieren einer Instanz auf der Grundlage einer Spezifikation ein, die Sie im BizTalk-Editor erstellt haben.

Mithilfe des BizTalk-Editors können Sie entweder XML-Instanzen (Extensible Markup Language) oder systemeigene Instanzen erstellen. Beim Verwenden von Flatfiles (sowohl mit Feldern fester Breite als auch mit Trennzeichen) müssen Sie keine Informationen zu Trennzeichen eingeben. Bei EDI-Dokumenten müssen Sie jedoch angeben, welches Trennzeichen verwendet werden soll.

Verwandte Themen

Erstellen einer neuen Dokumentinstanz

Erstellen einer systemeigenen Instanz


Überprüfen von Instanzen und Spezifikationen

Mithilfe des BizTalk-Editors können Sie eine Dokumentinstanz überprüfen. Beim Überprüfen einer Dokumentinstanz anhand einer Spezifikation, für die die Standard-Eigenschaft auf X12, EDIFACT oder BENUTZERDEFINIERT festgelegt wurde, muss die Dokumentinstanz über eine Dokumentstruktur verfügen, die dem Standard der Spezifikation entspricht. Beispielsweise können Sie eine X12-Dokumentinstanz nur anhand einer X12-Spezifikation überprüfen.

Eine Dokumentinstanz, die ein Feld mit einem leeren Attributwert ("") enthält, kann anhand einer Spezifikation erfolgreich überprüft werden, unabhängig von dem Wert, der für die Minimallänge-Eigenschaft dieses Feldes festgelegt wurde. Wenn eine Spezifikation beispielsweise über ein Feld verfügt, für dessen Minimallänge-Eigenschaft der Wert 4 festgelegt wurde, und Sie eine Dokumentinstanz, die ein entsprechendes Feld mit einem leeren Attributwert enthält, überprüfen möchten, schlägt die Überprüfung nur aufgrund dieser Diskrepanz nicht fehl. Der Grund hierfür ist, dass der MSXML-Parser, der dem Überprüfungsmodul zugrunde liegt, ein Attribut mit einem leeren Wert so behandelt, als wäre es nicht angegeben. Dieses Problem wird in der nächsten Version von BizTalk Server behoben.

Dokumenttrennzeichen

Mit dem BizTalk-Editor können Sie während der Überprüfung von Instanzen und Spezifikationen Trennzeichen angeben. Auf der Registerkarte Dokumenttrennzeichen können Sie Standardtrennzeichen angeben, die während der Überprüfung verwendet werden sollen. Zudem können Sie angeben, ob das Dialogfeld Dokumenttrennzeichen bei jeder Überprüfung einer Dokumentinstanz automatisch angezeigt werden soll. Sie können die Trennzeichen einmal festlegen, oder Sie geben an, dass der BizTalk-Editor Sie bei jedem Instanztest zum Festlegen bestimmter Trennzeichen auffordern soll.

In der nachstehenden Tabelle sind die Standardwerte für Trennzeichen aufgeführt:

Trennzeichen | Wert
Datensatztrennzeichen | ~ (0x7)
Feldtrennzeichen | * (0x2a)
Unterfeldtrennzeichen | > (0x3e)
Escape | ? (0x3f)

Umschlaginformationen

In manchen Fällen müssen Sie möglicherweise keine Trennzeichen angeben. Falls eine Instanz beispielsweise Umschlaginformationen enthält, zu denen auch Trennzeicheninformationen gehören, kann der BizTalk-Editor automatisch ermitteln, welche Trennzeichen verwendet werden sollen. Falls sich in der zu überprüfenden EDI-Instanz jedoch keine Kopfzeileninformationen befinden, zeigt der BizTalk-Editor das Dialogfeld Dokumenttrennzeichen an, in dem Sie Trennzeichen angeben können.

Überprüfen von Dokumenten in der Mitte von Austauschvorgängen

Der BizTalk-Editor überprüft nur das erste Dokument in einer Dokumentinstanz mit mehreren Dokumenten. Sie können jedoch auch ein Dokument überprüfen, das sich in der Mitte von Austauschvorgängen befindet, also nicht das erste Dokument im Austauschvorgang ist. Entfernen Sie hierzu die Kopfzeileninformationen und alle Dokumente vor dem zu überprüfenden Dokument.

Optionale und leere Felder innerhalb von Datensätzen

Falls die von Ihnen verwendete Dokumentinstanz über Felder in einem Datensatz verfügt, die sowohl optional als auch leer sind, müssen Sie ein Feldtrennzeichen vor dem Datensatztrennzeichen hinzufügen. Die folgende Dokumentinstanz hat z. B. eine Tilde (~) als Datensatztrennzeichen. Sie hat jedoch auch ein Pluszeichen (+) als Feldtrennzeichen für den ersten Datensatz. Dadurch ist es erforderlich, dass Sie im Dialogfeld Dokumenttrennzeichen die Datensatztrennzeichen-Eigenschaft auf die Tilde (~) und die Feldtrennzeichen-Eigenschaft auf das Pluszeichen (+) festlegen.

Dokumentinstanz mit einer Tilde als Datensatztrennzeichen

Wenn Sie die vorherige Dokumentinstanz anhand der folgenden Spezifikation überprüfen, wird der folgende Fehler angezeigt:

Beim Analysieren von Datensatz "Datensatz1" kann der Parser das erforderliche führende Trennzeichen nicht finden: "+" (0x002b).
Der Parser konnte das Dokument aufgrund von Verarbeitungsfehlern nicht konvertieren. Ausführliche Informationen finden Sie in den folgenden Meldungen.

Überprüfen einer Dokumentinstanz anhand einer Spezifikation

Fügen Sie zur Lösung dieses Problems ein Pluszeichen (+) zwischen "TTT" und der Tilde (~) in der Dokumentinstanz ein.

  • Es wird dringend empfohlen, vor der Verwendung einer Dokumentinstanz in einer Produktionsumgebung die Instanz anhand ihrer Quellspezifikation zu überprüfen und die auf der Registerkarte Warnungen angezeigten Probleme zu beheben.

Microsoft BizTalk Accelerator für HIPAA-Schemas

Im BizTalk-Editor besteht die Option, den Wert für Unterbrechung der Erstellung des Unterdokuments für BizTalk Accelerator für HIPAA-Schemas auf Ja festzulegen. In diesem Fall generiert der Parser mehrere XML-Dokumentinstanzen, die in der ursprünglichen Nutzlast enthalten sind. Die Überprüfung ist unter diesen Umständen mit der EDI-Überprüfung identisch. Beispielsweise werden Austauschvorgänge aufgeteilt und Schemas anhand des ersten Dokuments in der sich ergebenden Gruppe der aufgeteilten Dokumente überprüft.


Gründe für das Durchführen von BizTalk-Editor-Aufgaben

Dieser Abschnitt stellt eine kurze Referenz zum Durchführen von BizTalk-Editor-Aufgaben bereit. Die folgende Tabelle enthält Beschreibungen der Hauptaufgaben sowie der jeweiligen Unteraufgaben, Erläuterungen zum Zweck jeder Aufgabe und Links zu den entsprechenden Verfahren.

Aufgabe Zweck
  • Ändern von Optionen für den BizTalk-Editor
 Wenn Sie ein neues Feld als Element erstellen möchten. Oder wenn Sie standardmäßige Dokumenttrennzeichen angeben möchten, die bei Instanztests verwendet werden sollen. Darüber hinaus beschreibt diese Prozedur, wie Sie das Dialogfeld Dokumenttrennzeichen automatisch anzeigen, wenn Sie eine Dokumentinstanz überprüfen.
Erstellen und Überprüfen von Spezifikationen:
  • Erstellen einer Spezifikation auf der Basis eines Standards
 Wenn Sie einen Prozess mit einem Handelspartner einrichten und dazu Standards verwenden müssen, wie z. B. X12 oder EDIFACT.

Auch wenn Sie noch keine Vereinbarungen mit einem Handelspartner getroffen haben, jedoch von der Verwendung von Standards ausgehen, die veröffentlicht sind. Sie könnten z. B. planen, Ihre Organisation als Webdienst einzurichten.
  • Erstellen einer Spezifikation auf der Basis einer Flatfile
 Wenn Sie mit Legacysystemen arbeiten, die Flatfiles verwenden. Oder wenn Sie SAP (oder ähnliche Anwendungen, die standardmäßig Flatfiles verwenden) nutzen oder Handelspartner haben, die damit arbeiten.
  • Erstellen einer Spezifikation auf der Basis einer leeren Vorlage
 Dieser Vorlagentyp ist ideal, wenn Sie in Ihrer Organisation in erster Linie eine Integration von Unternehmensanwendungen durchführen. Mithilfe dieser Vorlage können Sie mit einem einzelnen Stammknoten beginnen und die benötigte Struktur von Grund auf erstellen.
  • Erstellen einer Spezifikation auf der Basis einer vorhandenen Spezifikation
 Möglicherweise arbeiten Sie mit einer vorhandenen Spezifikation, wenn die Integration von Unternehmens- oder B2B-Anwendungen (Business-to-Business) eine neue Aufgabe für Sie darstellt. Oder Sie tauschen möglicherweise Daten mit einer Organisation aus, die über eine vorhandene Spezifikation verfügt, die einfach geändert werden kann, wodurch Sie sich Zeit und Mühe ersparen.
  • Erstellen einer Spezifikation auf der Basis einer importierten Datei
 Wenn Sie mit einer vorhandenen Spezifikation arbeiten müssen.
  • Erstellen einer Spezifikation auf der Basis einer Microsoft Office-Datei
 Wenn Sie hauptsächlich in Ihrer Organisation oder mit Handelspartnern arbeiten, die für die Datenerfassung Anwendungen wie Microsoft Excel verwenden. Eine Spesenabrechnung kann z. B. ein Makro enthalten, das den Mitarbeitern die Eingabe von Spesen und Ihnen die Erstellung einer Spezifikation ermöglicht, die den eingegebenen Daten entspricht.
  • Überprüfen einer Spezifikation
 Sicherstellen, dass die Datensätze und Felder gültig sind, die Sie in der Spezifikation definiert haben. Wenngleich der BizTalk-Editor Rückmeldungen zur Gültigkeit Ihre Aktionen anzeigt, können Sie u. U. eine Datei importieren, die eine ungültige Struktur enthält. Der einzige Zeitpunkt, zu dem Sie über die Gültigkeit einer Struktur informiert werden, ist bei Überprüfung der Spezifikation.
Öffnen, Speichern und Exportieren von Spezifikationen:
  • Öffnen von vorhandenen Spezifikationen von einem lokalen Laufwerk
 Wenn Sie eine lokale Kopie einer Spezifikation bearbeiten möchten. Möglicherweise möchten Sie z. B. Änderungen vornehmen und die Spezifikation anschließend ohne Auswirkungen auf die gemeinsame Kopie testen, die in Web Distributed Authoring and Versioning (WebDAV) gespeichert ist.
  • Öffnen einer vorhandenen Spezifikation aus WebDAV
 Wenn Sie mit der gemeinsamen Kopie einer Spezifikation arbeiten müssen, auf die auch andere Benutzer zugreifen können, um sie gegebenenfalls zu ändern. Dies ist die Datei, die der BizTalk-Messaging-Manager bei der Verarbeitung von Transaktionen verwendet.
  • Öffnen einer vorhandenen Spezifikation aus Ordnern
 Wenn Sie eine lokale Kopie einer Spezifikation bearbeiten möchten. Möglicherweise möchten Sie z. B. Änderungen vornehmen und die Spezifikation anschließend ohne Auswirkungen auf die gemeinsame Kopie testen, die in WebDAV gespeichert ist.
  • Speichern neuer Spezifikationen
 Wenn Sie eine lokale Kopie einer Spezifikation speichern möchten, die Sie gerade erstellt haben. Möglicherweise möchten Sie z. B. eine kurz zuvor erstellte Spezifikation ohne Auswirkungen auf die gemeinsame Kopie speichern, die in WebDAV gespeichert ist.
  • Speichern von vorhandenen Spezifikationen
 Wenn Sie eine lokale Kopie einer Spezifikation speichern möchten, die Sie geändert haben. Möglicherweise möchten Sie z. B. eine bearbeitete Spezifikation ohne Auswirkungen auf die gemeinsame Kopie speichern, die in WebDAV gespeichert ist.
  • Speichern des XDR-Schemas in WebDAV
 Mit dem BizTalk-Editor können Sie reine XDR-Schemas (XML-Data Reduced) (Schemas, die nicht auf BizTalk Server basieren) nicht direkt in WebDAV speichern. Stellen Sie gegebenenfalls das XDR-Schema über WebDAV dem BizTalk-Messaging-Manager zur Verfügung. So können auf die Datei auch andere Benutzern zugreifen.
  • Speichern von Spezifikationen
 Wenn Sie eine Spezifikation über WebDAV dem BizTalk-Messaging-Manager zur Verfügung stellen müssen. So können auf die Datei auch andere Benutzern zugreifen.
  • Exportieren von XDR-Schemas
 Wenn Sie eine BizTalk Server-Spezifikation an einen Handelspartner senden müssen, der nicht über BizTalk Server verfügt. Die BizTalk Server-Spezifikationsanmerkungen werden während des Exportvorgangs entfernt, so dass der Handelspartner das endgültige Schema einfacher verwenden kann.
  • Exportieren von XSD-Schemas
 Wenn Sie die in Ihrer Spezifikation abgebildeten Daten an einen Handelspartner senden müssen, der mit Extensible Structure Definitions (XSD) arbeitet.
Verwalten von Datensätzen und Feldern:
  • Hinzufügen neuer Datensätze zu einem Stammknoten

  • Hinzufügen neuer Felder zu einem Stammknoten

  • Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  • Hinzufügen neuer Felder zu Datensätzen

  • Einfügen von Datensätzen

  • Einfügen von Feldern
 Erstellen einer neuen Struktur für eine Spezifikation oder Ändern einer vorhandenen Struktur.
  • Erstellen eines neuen Feldes als Element
 Wenn alle neuen Felder, die Sie hinzufügen möchten, wiederholt werden müssen oder eine Struktur erfordern.
  • Ändern von Feldern von Attributen in Elemente
 Wenn Sie bereits über ein Feld verfügen, das wiederholt werden muss oder eine Struktur erfordert. Elemente haben im Gegensatz zu Attributen eine Struktur.
  • Ändern von Feldern von Elementen in Attribute
 Wenn Sie möchten, dass ein Feld eine Struktur hat.
  • Verschieben von Datensätzen innerhalb einer Spezifikation

  • Verschieben von Feldern innerhalb einer Spezifikation

  • Verschieben von Datensätzen von einer Spezifikation in eine andere

  • Verschieben von Feldern von einer Spezifikation in eine andere
 Ändern der Struktur einer oder mehrerer Spezifikationen. Sie sparen Zeit, wenn Sie Datensätze und Felder aus einer Spezifikation in eine andere verschieben, anstatt diese samt Eigenschaften hinzuzufügen.
  • Kopieren von Datensätzen innerhalb einer Spezifikation

  • Kopieren von Feldern innerhalb einer Spezifikation

  • Kopieren von Datensätzen von einer Spezifikation in eine andere

  • Kopieren von Feldern von einer Spezifikation in eine andere
 Ändern der Struktur einer oder mehrerer Spezifikationen. Wenn Sie Datensätze und Felder kopieren, anstatt neue Datensätze und Felder zu erstellen, sparen Sie Zeit.
  • Erstellen von zyklischen Verweisen
 Wenn Sie wissen, dass die Daten, die von BizTalk Server verarbeitet werden, eine rekursive Struktur haben (was bedeutet, dass ein Knoten sich selbst als Ableitung enthält). Rekursive Strukturen treten häufig bei Elementen auf, die viele Komponenten und Unterkomponenten aufweisen.
  • Erstellen einer neuen Instanz eines vorhandenen Datensatzes
 Wenn Sie dieselbe Struktur als vorhandenen Datensatz schnell neu erstellen möchten.
  • Erstellen einer neuen Instanz eines vorhandenen Elementfeldes
 Wenn Sie dieselbe Struktur als vorhandenes Feld schnell neu erstellen möchten.
Angeben von Eigenschaften für Datensätze und Felder:
  • Festlegen von Dokumenttrennzeichen
 Wenn Sie über eine Struktur mit Trennzeichen verfügen, müssen Sie Dokumenttrennzeichen festlegen. Andernfalls kann BizTalk Server die Daten nicht verarbeiten.
  • Festlegen von Deklarationseigenschaften
 Steuern der Eigenschaften der Datenstruktur auf globaler Ebene.
  • Festlegen von Verweiseigenschaften
 Steuern der Eigenschaften der Datenstruktur auf lokaler Ebene.
  • Festlegen von Analyseeigenschaften
 Bereitstellen von Anweisungen zur Konvertierung von XML-fremden Daten.
  • Deklarieren von Namespaces
 Zuweisen von Anmerkungen zu verschiedenen Teilen einer Spezifikation. Dadurch wird die Verwendung des Standardnamespace, der möglicherweise mit der Spezifikation verknüpft ist, außer Kraft gesetzt.
  • Hinzufügen von benutzerdefinierten Anmerkungen
 Markieren einer Spezifikation mit spezifischen Anweisungen. Wenn Sie z. B. mit einem benutzerdefinierten Parser arbeiten, können Sie benutzerdefinierte Anmerkungen hinzufügen. Anmerkungen müssen Teil eines Namespace sein.
  • Festlegen von Wörterbucheigenschaften
 Jedes Arbeitsobjekt in BizTalk Server verfügt über eine zugeordnete Gruppe von Eigenschaften, die das Arbeitsobjekt beschreiben. Wenn Sie der Gruppe von Eigenschaften Inhalte hinzufügen möchten, müssen Sie Wörterbucheigenschaften festlegen. Sie möchten der Gruppe von Eigenschaften wahrscheinlich Eigenschaften hinzufügen, die sich auf das Routing oder Umschläge beziehen.
  • Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft
 Festlegen einer benutzerdefinierten Wörterbucheigenschaft. Siehe die Erläuterung weiter oben zur Aufgabe "Festlegen von Wörterbucheigenschaften".
  • Auswählen von Codes
 Wenn die Spezifikation auf einer X12- oder EDIFACT-Struktur basiert, können Sie Codes auswählen, um die Datentyp-Eigenschaft für ein Feld auf Enumeration und die Datentypwerte auf einen gültigen Code festzulegen.
  • Löschen von Codes
 Entfernen von Codes, die einem Feld hinzugefügt wurden.
  • Automatisches Berechnen von Feldpositionen
 Wenn Sie mit einer Spezifikation mit Feldern fester Breite arbeiten und alle Werte für Maximallänge vordefiniert haben, können Sie mithilfe dieser Option die Start- und Endpositionen aller Felder automatisch berechnen.
Bearbeiten von Notizen und Syntaxregeln:
  • Eingeben von Datensatznotizen
 Erstellen von Dokumentation für eigene Zwecke oder für eine andere Person, die möglicherweise mit der Spezifikation arbeitet.
  • Anzeigen von Syntaxregeln
 Gilt nur für auf einer X12-Struktur basierende Spezifikationen. Wählen Sie diese Option, wenn Sie eine X12-Spezifikation zuordnen und sicherstellen möchten, dass die Spezifikation nicht gegen Standardsyntaxregeln verstößt.
  • Eingeben von Feldnotizen
 Erstellen von Dokumentation für eigene Zwecke oder für eine andere Person, die möglicherweise mit der Spezifikation arbeitet.
Verwalten von Dokumentinstanzen:
  • Erstellen einer Dokumentinstanz
 Testen einer Spezifikation in Bezug auf eine XML- oder XML-fremde Dateninstanz.
  • Erstellen einer systemeigenen Dokumentinstanz
 Testen einer Spezifikation in Bezug auf eine XML-fremde Dateninstanz.
  • Überprüfen einer neuen Dokumentinstanz
 Sicherzustellen, dass die Spezifikation mit den Daten kompatibel ist, die die Spezifikation durchlaufen.
  • Verwalten ungültiger Zeichentabellen
 Wenn es Einschränkungen hinsichtlich der Zeichentypen gibt, welche die verwendende Anwendung verarbeiten kann, müssen Sie die ungültigen Zeichen angeben.
Verwalten von Ansichten und Verwenden von Tastenkombinationen:
  • Erweitern von Strukturelementen
 Anzeigen aller Datensätze und Felder in einer Spezifikation aus Sicht des Stammknoten-Datensatzes oder der Datensätze und Felder aus Sicht eines einzelnen Datensatzes.
  • Reduzieren von Strukturelementen
 Ausschließliches Anzeigen des Stammknoten-Datensatzes und/oder übergeordneter Datensätze.
  • Anzeigen von Registerkarten
 Anzeigen der Eigenschaften eines Datensatzes oder Feldes, der bzw. das mit den Registerkarten Deklaration, Verweis, Analysieren, Namespace, Wörterbuch oder Codeliste verknüpft ist.
  • Ändern der Textgröße
 Verkleinern oder Vergrößern der Schriftgröße von Text im BizTalk-Editor.
  • BizTalk-Editor - Tastenkombinationen
 Verwenden von Tastenkombinationen anstelle der Maus, um Aufgaben auszuführen.


Durchführen von BizTalk-Editor-Aufgaben

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Erstellen von Spezifikationen bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Informationen zum BizTalk-Editor lesen, um die Beziehung zwischen Datensätzen und Feldern vollständig zu verstehen. Zudem erfahren Sie, wie Sie Eigenschaften für einen bestimmten Spezifikationstyp angeben können, den Sie erstellen möchten.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ändern von Optionen für den BizTalk-Editor

  • Erstellen und Überprüfen von Spezifikationen

  • Öffnen von Spezifikationen

  • Speichern, Exportieren und Schließen von Spezifikationen

  • Verwalten von Datensätzen und Feldern

  • Festlegen von Eigenschaften für Datensätze und Felder

  • Bearbeiten von Notizen und Anzeigen von Syntaxregeln

  • Verwalten von Dokumentinstanzen

  • Verwalten ungültiger Zeichentabellen

  • Verwalten von Ansichten

  • BizTalk-Editor - Tastenkombinationen


Ändern von Optionen für den BizTalk-Editor

  1. Klicken Sie im Menü Extras auf Optionen, um Optionen im Dialogfeld Optionen für den BizTalk-Editor anzuzeigen.

  2. Auf der Registerkarte Allgemein können Sie das Kontrollkästchen Neues Feld als Element erstellen aktivieren.

    Weitere Informationen zu dieser Registerkarte finden Sie unter Erstellen eines neuen Feldes als Element.

  3. Auf der Registerkarte Dokumenttrennzeichen können Sie Standardtrennzeichen angeben, die bei Instanztests verwendet werden sollen, und Sie können festlegen, ob das Dialogfeld Dokumenttrennzeichen jedes Mal automatisch angezeigt werden soll, wenn Sie eine Dokumentinstanz überprüfen.

    Weitere Informationen zu dieser Registerkarte finden Sie unter Festlegen von Dokumenttrennzeichen.

Verwandte Themen

Erstellen eines neuen Feldes als Element

Festlegen von Dokumenttrennzeichen


Erstellen und Überprüfen von Spezifikationen

In diesem Abschnitt wird beschrieben, wie Sie je nach Art der verwendeten Daten eine Spezifikation erstellen. Wenn Sie beispielsweise mit einer Flatfile mit Trennzeichen arbeiten, müssen Sie eine Spezifikation auf der Grundlage dieser Flatfile erstellen. Es ist wichtig, dass Sie die mit ungültigen XML-Namenzeichen (Extensible Markup Language) verbundenen Probleme verstehen, wenn Sie mit Spezifikationen arbeiten. Wenn Sie nämlich ein ungültiges Unicode-Zeichen in einem XML-Namen verwenden, wird dieses Zeichen bei der Anzeige in der Spezifikationsstruktur in eine durch Escapezeichen gekapselte numerische Einheit übersetzt. Weitere Informationen finden Sie unter Ungültige XML-Namenzeichen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer Spezifikation auf der Basis eines Standards

  • Erstellen einer Spezifikation auf der Basis einer Flatfile

  • Erstellen einer Spezifikation auf der Basis einer leeren Vorlage

  • Erstellen einer Spezifikation auf der Basis einer vorhandenen Spezifikation

  • Erstellen einer Spezifikation auf der Basis einer importierten Datei

  • Erstellen einer Spezifikation auf der Basis einer Microsoft Office-Datei

  • Überprüfen einer Spezifikation


Erstellen einer Spezifikation auf der Basis eines Standards

  1. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Neue Dokumentspezifikation wird angezeigt.

  2. Klicken Sie auf XML, X12 oder EDIFACT, und klicken Sie dann auf OK.

    Falls Sie EDIFACT oder X12 auswählen, müssen Sie auch eine Version auswählen. Klicken Sie auf den Ordner für die gewünschte Version, und klicken Sie auf OK.

  3. Klicken Sie auf den Spezifikationstyp und dann auf OK.

  4. Löschen von Datensätzen (falls erforderlich).

  5. Löschen von Feldern (falls erforderlich).

  6. Codes löschen (falls erforderlich).

  7. Speichern neuer Spezifikationen.

Wichtig

  • Werden die mit der BizTalk Server-Installation bereitgestellten X12-Vorlagen im BizTalk-Editor verwendet, wird u. U. die folgende (oder eine ähnliche) Fehlermeldung angezeigt:

    Die Länge des Feldes "ITD05" ("") ist nicht gültig; sie muss zwischen 48 und -1 liegen. Dieses Dokument wird zurückgewiesen.

    Die X12-Vorlagen verwenden den impliziten Dezimaldatentyp Nx. Enthalten die Eingabedaten ein Dezimaltrennzeichen, stimmt die Ausgabe nicht mit dem benutzerdefinierten Datentyp N überein (d. h., sie enthält kein Dezimaltrennzeichen), und in der temporären XML-Datei werden ungültige Instanzen erstellt. In dieser Version von BizTalk Server erkennt die Serialisierungskomponente möglicherweise nicht, ob die temporäre XML-Datei ein Dezimaltrennzeichen für die Ausgabe des Datentyps N enthält. Um dieses Problem zu lösen, müssen Sie den impliziten Dezimaldatentyp in den X12-Vorlagen manuell in einen anderen numerischen Datentyp ändern.

Anmerkung

  • Eine Beschränkung für die vom X12-Parser unterstützten Instanzstrukturpermutationen beinhaltet, dass keine Generationssprünge in HL-Segmenten (Hierarchy Level) vorhanden sein dürfen. Bei dieser Beschränkung muss sich ein HL-Segment/Schleife im Stamm genau eine Ebene unterhalb des zugehörigen übergeordneten HL-Segments/Schleife befinden, sofern eine übergeordnete Hierarchieebene vorhanden ist. HL/NM1/HL wird beispielsweise nicht unterstützt. Eine vorgegebene Reihenfolge von 'x' verschachtelten HLs muss also genau 'x' Generationen von Ebenen in der Struktur umfassen.

Verwandte Themen

Verwalten von Datensätzen und Feldern

Festlegen von Eigenschaften für Datensätze und Felder

Grundlegendes zu Spezifikationen


Erstellen einer Spezifikation auf der Basis einer Flatfile

  1. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Neue Dokumentspezifikation wird angezeigt.

  2. Klicken Sie auf Leere Spezifikation, und klicken Sie dann auf OK.

  3. Markieren Sie den Stammknoten, und klicken Sie dann auf die Registerkarte Verweis.

  4. Doppelklicken Sie in der Zeile Standard auf das Feld Wert.

  5. Klicken Sie in der Liste Standard auf Benutzerdefiniert.

  6. Drücken Sie die EINGABETASTE.

  7. Klicken Sie auf Ja, um die Änderung zu bestätigen.

  8. Hinzufügen neuer Datensätze zu einem Stammknoten

  9. Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  10. Hinzufügen neuer Felder zu einem Stammknoten

  11. Hinzufügen neuer Felder zu Datensätzen

  12. Festlegen von Eigenschaften für Datensätze und Felder

  13. Speichern neuer Spezifikationen.

Anmerkungen

  • Auf der Registerkarte Analysieren müssen Sie die Struktur-Eigenschaft des Stammknotens auf Getrennt festlegen, wenn es sich um eine Flatfile mit Trennzeichen und mit Feldern fester Breite handelt. Für weitere Datensatzeigenschaften kann je nach Bedarf Getrennt oder Feste Breite festgelegt werden. Weitere Informationen finden Sie unter Verwenden von Flatfiles mit Feldern fester Breite und mit Trennzeichen.

  • Bei der Analyse von Flatfiles mit Feldern fester Breite wird ein optionales Element nicht unterdrückt, wenn es keine Daten enthält, die der Analyse von Flatfiles mit Trennzeichen ähneln. Darüber hinaus würde sich ein Element ohne Wert auf das Zuordnungsergebnis auswirken.

  • Flatfiles, die auf der UTF-8-Codepage basieren, werden vom BizTalk-Editor nicht unterstützt.

Internationale Probleme

  • Flatfiles mit Feldern fester Breite enthalten 2-Byte- oder 1-Byte-Zeichen für eine Codepage. Die meisten Anwendungen, die Flatfiles mit Feldern fester Breite (fester Länge) unterstützen, setzen voraus, dass die Zeichenfolgendaten in Byte und nicht in Zeichen ausgerichtet sind. Dies kann Probleme bei der Bearbeitung von Zeichenfolgendaten in Flatfiles mit Feldern fester Breite verursachen. Behandeln Sie Flatfiles mit Feldern fester Breite, die sowohl DBCS-Zeichen (Double-Byte Character Set) als auch SBCS-Zeichen (Single-Byte Character Set) enthalten, wie Flatfiles mit Trennzeichen, um das Problem zu lösen.

Verwandte Themen

Verwalten von Datensätzen und Feldern

Festlegen von Eigenschaften für Datensätze und Felder

Grundlegendes zu Spezifikationen

Verwenden von Flatfiles mit Feldern fester Breite und mit Trennzeichen


Erstellen einer Spezifikation auf der Basis einer leeren Vorlage

  1. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Neue Dokumentspezifikation wird angezeigt.

  2. Klicken Sie auf Leere Spezifikation, und klicken Sie dann auf OK.

  3. Hinzufügen neuer Datensätze zu einem Stammknoten

  4. Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  5. Hinzufügen neuer Felder zu einem Stammknoten

  6. Hinzufügen neuer Felder zu Datensätzen

  7. Festlegen von Eigenschaften für Datensätze und Felder

  8. Speichern neuer Spezifikationen.

Verwandte Themen

Verwalten von Datensätzen und Feldern

Festlegen von Eigenschaften für Datensätze und Felder

Grundlegendes zu Spezifikationen


Erstellen einer Spezifikation auf der Basis einer vorhandenen Spezifikation

  1. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld Dokumentspezifikation öffnen wird angezeigt.

  2. Suchen Sie nach einem Ordner, der eine vorhandene Spezifikation enthält.

  3. Klicken Sie auf eine Datei in der Liste und dann auf Öffnen.

  4. Ändern Sie die Spezifikation entsprechend Ihren Anforderungen.

  5. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld Dokumentspezifikation speichern unter wird angezeigt.

  6. Geben Sie im Feld Dateiname einen Namen für die Spezifikation ein.

  7. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Klicken Sie in der Liste Codierung auf UTF-8, wenn Sie eine Spezifikation erstellen möchten, die mit ASCII-Zeichen verbunden ist. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode für Spezifikationen, die mit Doppelbytezeichen verbunden sind.

  8. Verwalten von Datensätzen und Feldern

  9. Speichern neuer Spezifikationen.

Verwandte Themen

Codelistenwerte und Beschreibungen

Verwalten von Datensätzen und Feldern


Erstellen einer Spezifikation auf der Basis einer importierten Datei

  1. Klicken Sie im Menü Extras auf Importieren.

    Das Dialogfeld Importmodul auswählen wird angezeigt.

  2. Klicken Sie auf Wohlgeformte XML-Instanz, Document Type Definition oder XDR-Schema, und klicken Sie dann auf OK.

    Wichtig

    • Sie können eine wohlgeformte XML-Instanz nicht importieren, wenn sie ein XDR-Schema enthält.

    • Wenn Sie eine Microsoft Office-Datei importieren, klicken Sie auf Wohlgeformte XML-Instanz.

    • Falls Sie eine XDR-Datei (XML-Data Reduced) importieren, klicken Sie auf XDR-Schema.
  3. Suchen Sie im Dialogfeld Importmodul importieren nach dem Ordner, der die zu importierende Datei enthält, klicken Sie auf die Datei, und klicken Sie dann auf Öffnen.

    Wichtig

    • Das Dialogfeld Stammelement auswählen wird angezeigt, wenn der BizTalk-Editor nicht ermitteln kann, welches Element den Stammknoten darstellen soll. Wählen Sie ein Stammelement aus der Liste Stammelemente aus, und klicken Sie dann auf OK. Weitere Informationen finden Sie unter Importieren von Dateien.

    • Wenn Sie ein nicht aus BizTalk Server stammendes XDR-Schema im BizTalk-Editor öffnen, wird eine Fehler- und/oder Warnmeldung angezeigt, wenn das Schema Elementgruppen und/oder Namespaces enthält.
  4. Hinzufügen neuer Datensätze zu einem Stammknoten

  5. Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  6. Hinzufügen neuer Felder zu einem Stammknoten

  7. Hinzufügen neuer Felder zu Datensätzen

  8. Festlegen von Eigenschaften für Datensätze und Felder

  9. Speichern neuer Spezifikationen.

Wichtig

  • Enthält ein Schema einen Namespace-URN (Uniform Resource Name), der mit x-schema: beginnt, kann es im BizTalk-Editor möglicherweise nicht geöffnet werden. Entfernen Sie den x-schema-Verweis, und importieren Sie die Datei anschließend in den BizTalk-Editor.

  • Der BizTalk-Editor kann ein DTD-Schema (Document Type Definition) und/oder XDR-Schema (XML-Data Reduced), das einen zyklischen Verweis auf den Stammknoten enthält, nicht importieren. Ein wohlgeformtes XML-Dokument, das einen zyklischen Verweis auf den Stammknoten enthält, kann vom BizTalk-Editor importiert werden, obwohl eine Warnung angezeigt wird, dass zyklische Verweise nicht den Stammknoten eines Dokuments enthalten können. Weitere Informationen finden Sie unter Zyklische Verweise.

  • Wenn Sie für eine importierte Datei Unterstützung für gemischte Inhalte benötigen, muss die importierte Instanz gemischte Inhalte enthalten. Enthält sie keine gemischten Inhalte, wird der Wert Inhalt auf der Registerkarte Deklaration nicht auf Gemischt festgelegt.

Verwandte Themen

Importieren von Dateien

Verwalten von Datensätzen und Feldern

Festlegen von Eigenschaften für Datensätze und Felder


Erstellen einer Spezifikation auf der Basis einer Microsoft Office-Datei

  1. Klicken Sie im Menü Extras auf Importieren.

    Das Dialogfeld Importmodul auswählen wird angezeigt.

  2. Klicken Sie auf Wohlgeformte XML-Instanz, und klicken Sie dann auf OK.

  3. Suchen Sie im Dialogfeld Importmodul importieren nach dem Ordner, der die zu importierende Datei enthält, klicken Sie auf die Datei, und klicken Sie dann auf Öffnen.

    Wichtig

    • Das Dialogfeld Stammelement auswählen wird angezeigt, wenn der BizTalk-Editor nicht ermitteln kann, welches Element den Stammknoten darstellen soll. Wählen Sie ein Stammelement aus der Liste Stammelemente aus, und klicken Sie dann auf OK. Weitere Informationen finden Sie unter Importieren von Dateien.
  4. Hinzufügen neuer Datensätze zu einem Stammknoten

  5. Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  6. Hinzufügen neuer Felder zu einem Stammknoten

  7. Hinzufügen neuer Felder zu Datensätzen

  8. Festlegen von Eigenschaften für Datensätze und Felder

  9. Speichern neuer Spezifikationen.

Verwandte Themen

Importieren von Dateien

Verwalten von Datensätzen und Feldern

Festlegen von Eigenschaften für Datensätze und Felder


Überprüfen einer Spezifikation

  1. Öffnen Sie eine Spezifikation, oder importieren Sie ein Schema.

    Weitere Informationen finden Sie unter Öffnen von Spezifikationen oder Erstellen einer Spezifikation auf der Basis einer importierten Datei.

  2. Klicken Sie im Menü Extras auf Spezifikation überprüfen.

Auf der Registerkarte Warnungen werden Warnungen angezeigt, die auf Probleme bezüglich der Struktur der Spezifikation hinweisen. Sie können auf eine Warnung doppelklicken, um den Datensatz oder das Feld sowie die zugehörige Eigenschaft in den Fensterbereichen darüber rot anzuzeigen.

Verwandte Themen

Erstellen einer Spezifikation auf der Basis einer importierten Datei

Öffnen von Spezifikationen


Öffnen von Spezifikationen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Öffnen von vorhandenen Spezifikationen von einem lokalen Laufwerk

  • Öffnen einer vorhandenen Spezifikation aus WebDAV

  • Öffnen vorhandener Spezifikationen aus Ordnern


Öffnen von vorhandenen Spezifikationen von einem lokalen Laufwerk

  1. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld Dokumentspezifikation öffnen wird angezeigt.

  2. Suchen Sie nach dem Ordner, der die zu öffnende Spezifikation enthält, klicken Sie auf die Spezifikation, und klicken Sie dann auf Öffnen.

Anmerkung

  • Wenn Sie eine mit BizTalk Server 2000 erstellte Spezifikation nach der Installation von BizTalk Server 2002 öffnen, ändert sich beim Speichern das Dateiformat, und Sie können sie mit BizTalk Server 2000 nicht mehr öffnen.

Verwandtes Thema

Öffnen einer vorhandenen Spezifikation aus WebDAV


Öffnen einer vorhandenen Spezifikation aus WebDAV

  1. Klicken Sie im Menü Datei auf Aus WebDAV abrufen.

    Das Dialogfeld Aus WebDAV abrufen wird angezeigt.

  2. Geben Sie in der Liste Server den Servernamen ein, und drücken Sie die EINGABETASTE.

    Sie können auch einen Servernamen aus der Liste auswählen.

    Wichtig

    • Wenn der Proxyserverport nicht 80 ist, müssen Sie in der Liste Server Folgendes eingeben, um auf die in WebDAV gespeicherten Dateien zugreifen zu können: http://<Servername>:<Portnummer>

    • Sie können keine Dateien von einem sicheren Server abrufen. Lautet der Pfad des Servers beispielsweise https://<Servername>/biztalkserverrepository, können Sie nicht auf Dateien zugreifen.
  3. Suchen Sie nach dem Ordner, der die zu öffnende Spezifikation enthält, klicken Sie auf die Spezifikation, und klicken Sie dann auf Öffnen.

Wichtig

  • Bei dem Versuch, vorhandene Spezifikationen von WebDAV aus zu öffnen, wird u. U. die folgende (oder eine ähnliche) Fehlermeldung angezeigt: Auf "http://<Servername>/BizTalkServerRepository/DocSpecs" wurde kein BizTalk Server-Repository gefunden. Registrieren Sie in diesem Fall msdaipp.dll erneut, und starten Sie den Computer neu. Weitere Informationen zur erneuten Registrierung von msdaipp.dll finden Sie unter Erneutes Registrieren von MSDAIPP.DLL zum Abrufen oder Speichern von Zuordnungen in WebDAV.

  • Anmerkungen

  • Beim erstmaligen Herstellen einer Verbindung zu einem Remote-WebDAV-Server während einer Sitzung kann es zu Verzögerungen kommen.

  • Wenn Sie eine mit BizTalk Server 2000 erstellte Spezifikation nach der Installation von BizTalk Server 2002 öffnen, ändert sich beim Speichern das Dateiformat, und Sie können sie mit BizTalk Server 2000 nicht mehr öffnen.

Verwandte Themen

Öffnen von vorhandenen Spezifikationen von einem lokalen Laufwerk

Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Öffnen vorhandener Spezifikationen aus Ordnern

  1. Zeigen Sie im Startmenü auf Programme, dann auf Zubehör, und klicken Sie anschließend auf Windows-Explorer.

  2. Suchen Sie die Datei, die Sie im BizTalk-Editor anzeigen möchten.

    Klicken Sie bei Bedarf auf Verkleinern, um die Fenstergröße zu reduzieren, so dass das BizTalk-Editor-Fenster angezeigt wird.

  3. Ziehen Sie die Datei in den Fensterbereich der Spezifikationsstruktur.

Anmerkung

  • Wenn Sie eine mit BizTalk Server 2000 erstellte Spezifikation nach der Installation von BizTalk Server 2002 öffnen, ändert sich beim Speichern das Dateiformat, und Sie können sie mit BizTalk Server 2000 nicht mehr öffnen.


Speichern, Exportieren und Schließen von Spezifikationen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Speichern neuer Spezifikationen

  • Speichern von vorhandenen Spezifikationen

  • Speichern von XDR-Schemas in WebDAV

  • Speichern von Spezifikationen

  • Exportieren von XDR-Schemas

  • Exportieren von XSD-Schemas

  • Schließen von Spezifikationen


Speichern neuer Spezifikationen

  1. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld Dokumentspezifikation speichern unter wird angezeigt.

  2. Geben Sie im Feld Dateiname einen Namen für die Datei ein.

  3. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Klicken Sie in der Liste Codierung auf UTF-8, wenn Sie eine Spezifikation speichern möchten, die mit ASCII-Zeichen verbunden ist. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode für Spezifikationen, die mit Doppelbytezeichen verbunden sind.

Anmerkung

  • Wenn Sie eine mit BizTalk Server 2000 erstellte Spezifikation nach der Installation von BizTalk Server 2002 öffnen, ändert sich beim Speichern das Dateiformat, und Sie können sie mit BizTalk Server 2000 nicht mehr öffnen.


Speichern von vorhandenen Spezifikationen

  • Klicken Sie im Menü Datei auf Speichern.

Anmerkungen

  • Das Speichern einer Datei bewirkt, dass der BizTalk-Editor die Datei auf der Festplatte speichert. Um eine Datei in WebDAV zu speichern, müssen Sie über die Berechtigung verfügen, die Datei auf dem Server zu speichern.

  • Wenn Sie eine mit BizTalk Server 2000 erstellte Spezifikation nach der Installation von BizTalk Server 2002 öffnen, ändert sich beim Speichern das Dateiformat, und Sie können sie mit BizTalk Server 2000 nicht mehr öffnen.

Verwandtes Thema

Speichern von Spezifikationen


Speichern von XDR-Schemas in WebDAV

Mit dem BizTalk-Editor können Sie keine reinen XDR-Schemas (nicht aus BizTalk Server stammende Schemas) direkt in WebDAV speichern. Stattdessen müssen Sie das folgende Verfahren durchführen.

  1. Führen Sie die Schritte unter Speichern neuer Spezifikationen oder Speichern von vorhandenen Spezifikationen aus.

  2. Zeigen Sie im Startmenü auf Programme, dann auf Zubehör, und klicken Sie anschließend auf Windows-Explorer.

  3. Suchen Sie nach dem WebDAV-Speicherort, an dem Sie die Datei speichern möchten.

  4. Suchen Sie nach dem Speicherort, an dem das reine XDR-Schema gespeichert ist.

  5. Ziehen Sie die Datei von diesem Speicherort in den WebDAV-Ordner.

Internationale Probleme

  • Dateien können nur mit Unicode-Verschlüsselungen im WebDAV-Repository gespeichert werden. Das WebDAV-Repository kann jedoch keine Dateien mit Namen in verschiedenen Codeseiten speichern.

  • WebDAV unterstützt keine Unicode-Zeichen in Dateinamen.

  • Stellen Sie sicher, dass das Gebietsschema des Systems auf Ihre Sprache festgelegt ist. Internationale Benutzer, die die englische Version von BizTalk Server 2002 auf einem Computer unter der englischen Version von Windows installiert haben und Dateien mit Zeichen benennen möchten, die von der Codeseite Latin I (Windows 1252, einschließlich Englisch) nicht unterstützt werden, müssen das Gebietsschema des Systems in das Schema des Benutzers ändern.

  • Sie können Dateien, deren Namen aus Doppelbyte-Zeichensätzen (Double-Byte Character Sets, DBCS) gebildet werden, nur speichern, wenn das korrekte Gebietsschema festgelegt wurde. Informationen zur Behebung dieses Problems finden Sie unter Im WebDAV-Dialogfeld wird "???.xml" angezeigt.


Speichern von Spezifikationen

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

    Das Dialogfeld In WebDAV speichern wird angezeigt.

  2. Geben Sie in der Liste Server den Servernamen ein, und drücken Sie die EINGABETASTE.

    Sie können auch einen Servernamen aus der Liste auswählen.

    Wichtig

    • Wenn der Proxyserverport nicht 80 ist, müssen Sie in der Liste Server Folgendes eingeben, um Dateien in WebDAV zu speichern: http://<Servername>:<Portnummer>

    • Sie können Dateien nicht auf einem sicheren Server speichern. Lautet der Pfad des Servers beispielsweise https://<Servername>/biztalkserverrepository, können Sie keine Dateien speichern.
  3. Suchen Sie nach dem Ordner, in dem Sie die Spezifikation speichern möchten.

  4. Geben Sie im Feld Dateiname den Namen der Datei ein.

  5. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Klicken Sie in der Liste Codierung auf UTF-8, wenn Sie eine Spezifikation speichern möchten, die mit ASCII-Zeichen verbunden ist. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode für Spezifikationen, die mit Doppelbytezeichen verbunden sind.

Internationale Probleme

  • Dateien können nur mit Unicode-Verschlüsselungen im WebDAV-Repository gespeichert werden. Das WebDAV-Repository kann jedoch keine Dateien mit Namen in verschiedenen Codeseiten speichern.

  • WebDAV unterstützt keine Unicode-Zeichen in Dateinamen.

  • Stellen Sie sicher, dass das Gebietsschema des Systems auf Ihre Sprache festgelegt ist. Internationale Benutzer, die die englische Version von BizTalk Server 2002 auf einem Computer unter der englischen Version von Windows installiert haben und Dateien mit Zeichen benennen möchten, die von der Codeseite Latin I (Windows 1252, einschließlich Englisch) nicht unterstützt werden, müssen das Gebietsschema des Systems in das System des Benutzers ändern.

  • Sie können Dateien, deren Namen aus Doppelbyte-Zeichensätzen (Double-Byte Character Sets, DBCS) gebildet werden, nur speichern, wenn das korrekte Gebietsschema festgelegt wurde. Informationen zur Behebung dieses Problems finden Sie unter Im WebDAV-Dialogfeld wird "???.xml" angezeigt.

Wichtig

  • Bei dem Versuch, Spezifikationen in WebDAV zu speichern, wird u. U. die folgende (oder eine ähnliche) Fehlermeldung angezeigt: Auf "http://<Servername>/BizTalkServerRepository/DocSpecs" wurde kein BizTalk Server-Repository gefunden. Registrieren Sie in diesem Fall die Datei msdaipp.dll erneut, und starten Sie den Computer neu. Weitere Informationen zur erneuten Registrierung von msdaipp.dll finden Sie unter Erneutes Registrieren von MSDAIPP.DLL zum Abrufen oder Speichern von Zuordnungen in WebDAV.

Anmerkungen

  • Wenn Sie zum ersten Mal eine Verbindung zu einem Remote-WebDAV-Server herstellen, wird sich der Vorgang möglicherweise etwas verzögern.

  • Das Speichern einer Datei in WebDAV bewirkt, dass der BizTalk-Editor die Datei auf einem Server speichert. Klicken Sie im Menü Datei auf Speichern unter, um eine Datei auf der Festplatte zu speichern.

  • Wenn Sie eine mit BizTalk Server 2000 erstellte Spezifikation nach der Installation von BizTalk Server 2002 öffnen, ändert sich beim Speichern das Dateiformat, und Sie können sie mit BizTalk Server 2000 nicht mehr öffnen.

Verwandte Themen

Speichern von vorhandenen Spezifikationen

Speichern neuer Spezifikationen

Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Exportieren von XDR-Schemas

  1. Klicken Sie im Menü Extras auf XDR-Schema exportieren.

    Das Dialogfeld XDR-Schema exportieren als wird angezeigt.

  2. Suchen Sie nach dem Verzeichnis, in das Sie die XDR-Datei (XML-Data Reduced) exportieren möchten.

  3. Geben Sie im Feld Dateiname einen Namen für die Datei ein.

  4. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Klicken Sie in der Liste Codierung auf UTF-8, wenn Sie eine Spezifikation exportieren möchten, die mit ASCII-Zeichen verbunden ist. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode für Spezifikationen, die mit Doppelbytezeichen verbunden sind.

Verwandte Themen

Öffnen von Spezifikationen

Exportieren von XSD-Schemas


Exportieren von XSD-Schemas

Bevor Sie ein XSD-Schema (Extensible (XML) Structure Definitions) exportieren, sollten Sie die Datei speichern.

  1. Klicken Sie im Menü Extras auf XSD-Schema exportieren.

    Das Dialogfeld XSD-Schema exportieren wird angezeigt.

  2. Suchen Sie nach dem Verzeichnis, in das Sie die XSD-Datei exportieren möchten.

  3. Geben Sie im Feld Dateiname einen Namen für die Datei ein, und klicken Sie auf Speichern.

Anmerkungen

  • Wenn Ihre Spezifikation einen Zielnamespace enthält und Sie die Option XSD-Schema exportieren zum Exportieren der Datei verwenden, enthält das exportierte XSD-Schema keinen Zielnamespace. Öffnen Sie die exportierte XSD-Datei in Editor, und fügen Sie den Zielnamespace manuell hinzu, um das Problem zu beheben.

  • Exportierte XSD-Dateien weisen standardmäßig das UTF-16-Format auf.

Verwandte Themen

Öffnen von Spezifikationen

Exportieren von XDR-Schemas


Schließen von Spezifikationen

  • Klicken Sie im Menü Datei auf Schließen.


Verwalten von Datensätzen und Feldern

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen neuer Datensätze zu einem Stammknoten

  • Hinzufügen neuer Felder zu einem Stammknoten

  • Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  • Hinzufügen neuer Felder zu Datensätzen

  • Einfügen von Datensätzen

  • Einfügen von Feldern

  • Erstellen eines neuen Feldes als Element

  • Ändern von Feldern von Attributen in Elemente

  • Ändern von Feldern von Elementen in Attribute

  • Verschieben von Datensätzen innerhalb einer Spezifikation

  • Verschieben von Feldern innerhalb einer Spezifikation

  • Verschieben von Datensätzen von einer Spezifikation in eine andere

  • Verschieben von Feldern von einer Spezifikation in eine andere

  • Kopieren von Datensätzen innerhalb einer Spezifikation

  • Kopieren von Feldern innerhalb einer Spezifikation

  • Kopieren von Datensätzen von einer Spezifikation in eine andere

  • Kopieren von Feldern von einer Spezifikation in eine andere

  • Umbenennen eines einzelnen Datensatzes

  • Umbenennen eines einzelnen Feldes

  • Umbenennen aller Datensätze mit dem gleichen Namen

  • Löschen von Datensätzen

  • Löschen von Feldern

  • Erstellen von zyklischen Verweisen

  • Erstellen einer neuen Instanz eines vorhandenen Datensatzes

  • Erstellen einer neuen Instanz eines vorhandenen Elementfeldes


Hinzufügen neuer Datensätze zu einem Stammknoten

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Bearbeiten auf Neuer Datensatz.

    Nach dem letzten Knoten in der Spezifikationsstruktur wird ein untergeordneter Datensatz eingefügt.

  3. Geben Sie einen Namen für den Datensatz ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Für eine nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um das Tag in der nicht auf XML basierenden Quelldatei zu identifizieren.

  • Gleichgeordnete Datensätze können nicht denselben Namen besitzen.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandtes Thema

Festlegen von Eigenschaften für Datensätze und Felder


Hinzufügen neuer Felder zu einem Stammknoten

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Bearbeiten auf Neues Feld.

    Nach dem letzten Knoten in der Spezifikationsstruktur wird ein untergeordnetes Feld eingefügt.

  3. Geben Sie einen Namen für das Feld ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandte Themen

Ändern von Feldern von Elementen in Attribute

Erstellen eines neuen Feldes als Element

Festlegen von Eigenschaften für Datensätze und Felder


Hinzufügen neuer Datensätze zu vorhandenen Datensätzen

  1. Klicken Sie auf einen Datensatz.

  2. Klicken Sie im Menü Bearbeiten auf Neuer Datensatz.

    Nach dem ausgewählten Datensatz bzw. nach dem letzten untergeordneten Knoten des ausgewählten Datensatzes wird ein untergeordneter Datensatz eingefügt.

  3. Geben Sie einen Namen für den Datensatz ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Für eine nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um das Tag in der nicht auf XML basierenden Quelldatei zu identifizieren.

  • Gleichgeordnete Datensätze können nicht denselben Namen besitzen.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandtes Thema

Festlegen von Eigenschaften für Datensätze und Felder


Hinzufügen neuer Felder zu Datensätzen

  1. Klicken Sie auf einen Datensatz.

  2. Klicken Sie im Menü Bearbeiten auf Neues Feld.

    Nach dem ausgewählten Datensatz bzw. nach dem letzten untergeordneten Knoten des ausgewählten Datensatzes wird ein untergeordnetes Feld eingefügt.

  3. Geben Sie einen Namen für das Feld ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandte Themen

Ändern von Feldern von Elementen in Attribute

Erstellen eines neuen Feldes als Element

Festlegen von Eigenschaften für Datensätze und Felder


Einfügen von Datensätzen

  1. Klicken Sie auf einen Datensatz.

  2. Klicken Sie im Menü Bearbeiten auf Datensatz einfügen.

    Nach dem ausgewählten Datensatz bzw. nach dem letzten untergeordneten Knoten des ausgewählten Datensatzes wird ein gleichgeordneter Datensatz eingefügt.

  3. Geben Sie einen Namen für den Datensatz ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Gleichgeordnete Datensätze können nicht denselben Namen besitzen.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandtes Thema

Festlegen von Eigenschaften für Datensätze und Felder


Einfügen von Feldern

  1. Klicken Sie auf den Datensatz oder das Feld, nach dem Sie ein Feld einfügen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Feld einfügen.

    Nach dem ausgewählten Datensatz bzw. nach dem letzten untergeordneten Knoten des ausgewählten Datensatzes wird ein gleichgeordnetes Feld eingefügt.

  3. Geben Sie einen Namen für das Feld ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandte Themen

Ändern von Feldern von Elementen in Attribute

Erstellen eines neuen Feldes als Element

Festlegen von Eigenschaften für Datensätze und Felder


Erstellen eines neuen Feldes als Element

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Editor wird angezeigt.

  2. Aktivieren Sie das Kontrollkästchen Neues Feld als Element erstellen, und klicken Sie auf OK.

Anmerkungen

  • Ist dieses Kontrollkästchen deaktiviert, werden Felder als Attribute erstellt. Wenn Sie das Kontrollkästchen Neues Feld als Element erstellen jedoch aktivieren, werden alle neuen Felder als Elemente erstellt.

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Verwandtes Thema

Ändern von Feldern von Elementen in Attribute


Ändern von Feldern von Attributen in Elemente

  1. Klicken Sie auf ein Feld in der Spezifikationsstruktur.

  2. Doppelklicken Sie auf der Registerkarte Deklaration in der Zeile Typ auf das Feld Wert.

    Die aktuelle Einstellung lautet Attribut.

  3. Klicken Sie in der Liste Typ auf Element, und drücken Sie die EINGABETASTE.

  4. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Anmerkung

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Verwandte Themen

Ändern von Feldern von Elementen in Attribute

Erstellen eines neuen Feldes als Element


Ändern von Feldern von Elementen in Attribute

  1. Klicken Sie auf ein Feld in der Spezifikationsstruktur.

  2. Doppelklicken Sie auf der Registerkarte Deklaration in der Zeile Typ auf das Feld Wert.

    Die aktuelle Einstellung lautet Element.

  3. Klicken Sie in der Liste Typ auf Attribut, und drücken Sie die EINGABETASTE.

  4. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Anmerkung

  • Gleichgeordnete Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

Verwandtes Thema

Ändern von Feldern von Attributen in Elemente


Verschieben von Datensätzen innerhalb einer Spezifikation

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf den Datensatz, den Sie verschieben möchten, und ziehen Sie ihn zu einem anderen Knoten in der Struktur.

    Wenn Sie die Maustaste loslassen, während sich der Mauszeiger in der oberen Hälfte des markierten Knotentextes befindet, wird der Datensatz oberhalb des Knotens als gleichgeordneter Datensatz eingefügt. Befindet sich der Mauszeiger in der unteren Hälfte des markierten Knotentextes, wird der Datensatz unterhalb des Knotens als gleichgeordneter Datensatz eingefügt. Wird der Mauszeiger rechts neben dem markierten Knotentext angezeigt, wird der Datensatz unterhalb des ausgewählten Datensatzes als untergeordneter Datensatz eingefügt.

Verwandte Themen

Kopieren von Datensätzen von einer Spezifikation in eine andere

Kopieren von Datensätzen innerhalb einer Spezifikation

Verschieben von Datensätzen von einer Spezifikation in eine andere


Verschieben von Feldern innerhalb einer Spezifikation

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf das Feld, das Sie verschieben möchten, und ziehen Sie es zu einem anderen Knoten in der Struktur.

    Wenn Sie die Maustaste loslassen, während sich der Mauszeiger in der oberen Hälfte des markierten Knotentextes befindet, wird das Feld oberhalb des Knotens als gleichgeordneter Datensatz eingefügt. Befindet sich der Mauszeiger in der unteren Hälfte des markierten Knotentextes, wird das Feld unterhalb des Knotens als gleichgeordneter Datensatz eingefügt. Wird der Mauszeiger rechts neben dem markierten Knotentext angezeigt, wird das Feld unterhalb des Datensatzes als untergeordnetes Feld eingefügt.

Verwandte Themen

Kopieren von Feldern von einer Spezifikation in eine andere

Kopieren von Feldern innerhalb einer Spezifikation

Verschieben von Feldern von einer Spezifikation in eine andere


Verschieben von Datensätzen von einer Spezifikation in eine andere

  1. Klicken Sie auf den Stammknoten in der Spezifikation, die den Datensatz enthält, den Sie verschieben möchten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf den Datensatz, den Sie verschieben möchten, und klicken Sie dann im Menü Bearbeiten auf Ausschneiden.

  4. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Editor.

    Sie müssen eine zweite Instanz des BizTalk-Editors starten, um eine weitere Spezifikation zu öffnen.

  5. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld Dokumentspezifikation öffnen wird angezeigt.

  6. Suchen Sie nach dem Ordner, der die Spezifikation enthält, in die Sie den Datensatz verschieben möchten.

  7. Klicken Sie in der Liste auf die Datei, und klicken Sie dann auf Öffnen.

  8. Klicken Sie auf den Stammknoten in der Spezifikation.

  9. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  10. Klicken Sie auf den Stammknoten, den Datensatz oder das Feld, nach dem der Datensatz eingefügt werden soll.

  11. Klicken Sie im Menü Bearbeiten auf Einfügen.

Anmerkung

  • Falls Sie einen Datensatz verschieben, der über denselben Namen verfügt wie ein bereits vorhandener Datensatz, fügt der BizTalk-Editor automatisch am Ende des Datensatznamens eine Zahl hinzu.

Verwandte Themen

Kopieren von Datensätzen von einer Spezifikation in eine andere

Kopieren von Datensätzen innerhalb einer Spezifikation

Verschieben von Datensätzen innerhalb einer Spezifikation


Verschieben von Feldern von einer Spezifikation in eine andere

  1. Klicken Sie auf den Stammknoten der Spezifikation, die das zu verschiebende Feld enthält.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf das Feld, das Sie verschieben möchten, und klicken Sie dann im Menü Bearbeiten auf Ausschneiden.

  4. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Editor.

    Sie müssen eine zweite Instanz des BizTalk-Editors starten, um eine weitere Spezifikation zu öffnen.

  5. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld Dokumentspezifikation öffnen wird angezeigt.

  6. Suchen Sie nach dem Ordner, der die Spezifikation enthält, in die Sie den Datensatz verschieben möchten.

  7. Klicken Sie in der Liste auf die Datei, und klicken Sie dann auf Öffnen.

  8. Klicken Sie auf den Stammknoten der Spezifikation, in die Sie das Feld verschieben möchten.

  9. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  10. Klicken Sie auf den Stammknoten, den Datensatz oder das Feld, nach dem das Feld eingefügt werden soll.

  11. Klicken Sie im Menü Bearbeiten auf Einfügen.

Anmerkung

  • Falls Sie ein Feld verschieben, das über denselben Namen verfügt wie ein bereits vorhandenes Feld, fügt der BizTalk-Editor automatisch am Ende des Feldnamens eine Zahl hinzu.

Verwandte Themen

Kopieren von Feldern von einer Spezifikation in eine andere

Kopieren von Feldern innerhalb einer Spezifikation

Verschieben von Feldern innerhalb einer Spezifikation


Kopieren von Datensätzen innerhalb einer Spezifikation

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf den Datensatz, den Sie kopieren möchten, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

  4. Klicken Sie auf den Knoten, nach dem Sie den Datensatz einfügen möchten, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

    Ist der ausgewählte Knoten ein Datensatz, wird ein untergeordneter Datensatz direkt nach dem ausgewählten Knoten eingefügt. Handelt es sich bei dem ausgewählten Knoten dagegen um ein Feld, wird ein gleichgeordneter Datensatz direkt nach dem ausgewählten Knoten eingefügt.

Wichtig

  • Wenn es sich bei dem kopierten Datensatz um den Stammknoten-Datensatz handelt, werden alle untergeordneten Datensätze und Felder kopiert, nicht jedoch der Stammknoten-Datensatz selbst. Sie müssen diesen Datensatz manuell erstellen, wenn dieser in der Spezifikation enthalten sein soll.

Verwandte Themen

Kopieren von Datensätzen von einer Spezifikation in eine andere

Verschieben von Datensätzen von einer Spezifikation in eine andere

Verschieben von Datensätzen innerhalb einer Spezifikation


Kopieren von Feldern innerhalb einer Spezifikation

  1. Klicken Sie auf den Stammknoten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf das Feld, das Sie kopieren möchten, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

  4. Klicken Sie auf den Knoten, nach dem Sie das Feld einfügen möchten, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

    Ist der ausgewählte Knoten ein Datensatz, wird ein untergeordnetes Feld direkt nach dem ausgewählten Knoten eingefügt. Handelt es sich bei dem ausgewählten Knoten dagegen um ein Feld, wird ein gleichgeordnetes Feld direkt nach dem ausgewählten Knoten eingefügt.

Verwandte Themen

Kopieren von Feldern von einer Spezifikation in eine andere

Verschieben von Feldern von einer Spezifikation in eine andere

Verschieben von Feldern innerhalb einer Spezifikation


Kopieren von Datensätzen von einer Spezifikation in eine andere

  1. Klicken Sie auf den Stammknoten in der Spezifikation, die den Datensatz enthält, den Sie kopieren möchten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf den Datensatz, den Sie kopieren möchten, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

  4. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Editor.

    Sie müssen eine zweite Instanz des BizTalk-Editors starten, um eine weitere Spezifikation zu öffnen.

  5. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld Dokumentspezifikation öffnen wird angezeigt.

  6. Suchen Sie nach dem Ordner, der die Spezifikation enthält, in die Sie den Datensatz kopieren möchten.

  7. Klicken Sie in der Liste auf die Datei, und klicken Sie dann auf Öffnen.

  8. Klicken Sie auf den Stammknoten der Spezifikation, in die Sie den Datensatz kopieren möchten.

  9. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  10. Klicken Sie auf den Stammknoten, den Datensatz oder das Feld, nach dem Sie den Datensatz einfügen möchten, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

    Ist der ausgewählte Knoten ein Datensatz, wird ein untergeordneter Datensatz direkt nach dem ausgewählten Knoten eingefügt. Handelt es sich bei dem ausgewählten Knoten dagegen um ein Feld, wird ein gleichgeordneter Datensatz direkt nach dem ausgewählten Knoten eingefügt.

Wichtig

Wenn es sich bei dem kopierten Datensatz um den Stammknoten-Datensatz handelt, werden alle untergeordneten Datensätze und Felder kopiert, nicht jedoch der Stammknoten-Datensatz selbst. Sie müssen diesen Datensatz manuell kopieren, wenn dieser in der Spezifikation enthalten sein soll.

Anmerkung

  • Falls Sie einen Datensatz kopieren, der denselben Namen besitzt wie ein bereits vorhandener Datensatz, fügt der BizTalk-Editor automatisch am Ende des Datensatznamens eine Zahl hinzu.

Verwandte Themen

Kopieren von Datensätzen innerhalb einer Spezifikation

Verschieben von Datensätzen von einer Spezifikation in eine andere

Verschieben von Datensätzen innerhalb einer Spezifikation


Kopieren von Feldern von einer Spezifikation in eine andere

  1. Klicken Sie auf den Stammknoten in der Spezifikation, die das Feld enthält, das Sie kopieren möchten.

  2. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  3. Klicken Sie auf das Feld, das Sie kopieren möchten, und klicken Sie dann im Menü Bearbeiten auf Kopieren.

  4. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Microsoft BizTalk Server 2002, und klicken Sie dann auf BizTalk-Editor.

    Sie müssen eine zweite Instanz des BizTalk-Editors starten, um eine weitere Spezifikation zu öffnen.

  5. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld Dokumentspezifikation öffnen wird angezeigt.

  6. Suchen Sie nach dem Ordner, der die Spezifikation enthält, in die Sie das Feld verschieben möchten.

  7. Klicken Sie in der Liste auf die Datei, und klicken Sie dann auf Öffnen.

  8. Klicken Sie auf den Stammknoten der Spezifikation, in die Sie das Feld kopieren möchten.

  9. Klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

  10. Klicken Sie auf den Stammknoten, den Datensatz oder das Feld, nach dem Sie den Datensatz einfügen möchten, und klicken Sie dann im Menü Bearbeiten auf Einfügen.

    Ist der ausgewählte Knoten ein Datensatz, wird ein untergeordnetes Feld direkt nach dem ausgewählten Knoten eingefügt. Handelt es sich bei dem ausgewählten Knoten dagegen um ein Feld, wird ein gleichgeordnetes Feld direkt nach dem ausgewählten Knoten eingefügt.

Anmerkung

  • Falls Sie ein Feld kopieren, das denselben Namen besitzt wie ein bereits vorhandenes Feld, fügt der BizTalk-Editor automatisch am Ende des Feldnamens eine Zahl hinzu.

Verwandte Themen

Kopieren von Feldern innerhalb einer Spezifikation

Verschieben von Feldern von einer Spezifikation in eine andere

Verschieben von Feldern innerhalb einer Spezifikation


Umbenennen eines einzelnen Datensatzes

  1. Klicken Sie auf den Datensatz, den Sie umbenennen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Umbenennen.

  3. Geben Sie einen neuen Namen für den Datensatz ein, und drücken Sie die EINGABETASTE.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandte Themen

Umbenennen aller Datensätze mit dem gleichen Namen

Umbenennen eines einzelnen Feldes


Umbenennen eines einzelnen Feldes

  1. Klicken Sie auf das Feld, das Sie umbenennen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Umbenennen.

  3. Geben Sie einen neuen Namen für das Feld ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Felder, bei denen es sich um Elemente handelt, können nicht denselben Namen besitzen wie ein vorhandener Datensatz.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandte Themen

Umbenennen aller Datensätze mit dem gleichen Namen

Umbenennen eines einzelnen Datensatzes


Umbenennen aller Datensätze mit dem gleichen Namen

  1. Klicken Sie auf einen der Datensätze, die Sie umbenennen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Alle “<Datensatzname>“ umbenennen.

  3. Geben Sie einen neuen Namen für die Datensätze ein.

    Alle Datensätze mit diesem Namen werden umbenannt.

Anmerkungen

  • Dieser Befehl im Menü Bearbeiten steht nur zur Verfügung, wenn mindestens zwei Datensätze den gleichen Namen besitzen.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandte Themen

Umbenennen eines einzelnen Feldes

Umbenennen eines einzelnen Datensatzes


Löschen von Datensätzen

  1. Klicken Sie auf den Datensatz, den Sie löschen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Löschen.

  3. Klicken Sie im Bestätigungsdialogfeld auf Ja.

Vorsicht

  • Beim Löschen eines Datensatzes werden alle untergeordneten Datensätze und Felder ebenfalls gelöscht.

Verwandtes Thema

Löschen von Feldern


Löschen von Feldern

  1. Klicken Sie auf das Feld, das Sie löschen möchten.

  2. Klicken Sie im Menü Bearbeiten auf Löschen.

  3. Klicken Sie im Bestätigungsdialogfeld auf Ja.

Verwandtes Thema

Löschen von Datensätzen


Erstellen von zyklischen Verweisen

  1. Wählen Sie einen Datensatz aus, unter dem ein zyklischer Verweis erstellt werden soll.

    Dies ist der Basisdatensatz.

  2. Klicken Sie im Menü Bearbeiten auf Neuer Datensatz.

  3. Geben Sie dem neuen Datensatz denselben Namen wie dem Basisdatensatz, und drücken Sie die EINGABETASTE.

    Ein zyklischer Verweis Cyclical reference icon wird erstellt.

  4. Doppelklicken Sie auf der Registerkarte Deklaration in der Zeile Anzahl der Zyklen auf das Feld Wert.

  5. Geben Sie eine Zahl zwischen 1 und 7 ein, und drücken Sie die EINGABETASTE.

Wichtig

  • Für die Minimalvorkommen-Eigenschaft auf der Registerkarte Verweis muss 0 festgelegt werden. Die Einstellung 1 bewirkt eine Endlosschleife.

Anmerkung

  • Zyklische Verweise können nur in XML-Spezifikationen verwendet werden. Stellen Sie sicher, dass es sich um eine XML-basierte Spezifikation handelt.

Verwandtes Thema

Zyklische Verweise


Erstellen einer neuen Instanz eines vorhandenen Datensatzes

  1. Klicken Sie an der Stelle, an der Sie eine neue Instanz eines vorhandenen Datensatzes erstellen möchten, auf einen Knoten.

  2. Klicken Sie im Menü Bearbeiten auf Neuer Datensatz oder Datensatz einfügen.

    Anmerkung

    • Wenn Sie in Schritt 1 ein Feld ausgewählt haben, steht der Befehl Neuer Datensatz im Menü Bearbeiten nicht zur Verfügung.
  3. Geben Sie dem neuen Datensatz denselben Namen wie dem vorhandenen Datensatz, und drücken Sie die EINGABETASTE.

    Damit haben Sie zwei Instanzen desselben Datensatzes erstellt.

Wichtig

  • Eine neue Datensatzinstanz kann nicht über denselben Namen verfügen wie ein gleichgeordneter Datensatz.

  • Wenn Sie einem neuen Datensatz denselben Namen geben wie dem übergeordneten Datensatz, erstellen Sie einen zyklischen Verweis und keine neue Instanz des vorhandenen Datensatzes. Weitere Informationen finden Sie unter Zyklische Verweise.

Anmerkungen

  • Wenn Sie auf Neuer Datensatz klicken, wird die neue Datensatzinstanz in Abhängigkeit von dem ausgewählten Datensatz erstellt.

  • Wenn Sie dagegen auf Datensatz einfügen klicken, wird die neue Datensatzinstanz dem ausgewählten Datensatz oder Feld gleichgestellt.

  • Die Knotenstruktur unterhalb von Instanzen eines Datensatzes ist identisch; wenn Sie einen Knoten zu einer Datensatzinstanz hinzufügen bzw. aus einer Datensatzinstanz entfernen, wird dieser Vorgang für alle anderen Instanzen des Datensatzes ebenfalls durchgeführt. Einige Eigenschaften von Datensatzinstanzen stimmen überein, während andere für jede Instanz einzeln festgelegt werden können. Weitere Informationen zu identischen und nicht identischen Eigenschaften finden Sie unter Eigenschaftsbereich.

  • Sie können einem vorhandenen Datensatz nicht denselben Namen geben wie einem anderen vorhandenen Datensatz.

  • Sie können auch die STRG-TASTE drücken und einen vorhandenen Datensatz rechts neben den Knoten ziehen, unter dem die neue Datensatzinstanz eingefügt werden soll, um eine neue Instanz eines vorhandenen Datensatzes zu erstellen.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandte Themen

Zyklische Verweise

Eigenschaftsbereich


Erstellen einer neuen Instanz eines vorhandenen Elementfeldes

  1. Wählen Sie einen Knoten an der Stelle aus, an der Sie eine neue Instanz eines Elementfeldes erstellen möchten.

    Anmerkung

    • Mehrere Feldinstanzen können nur erstellt werden, wenn es sich um Felder des Typs Element handelt (auf der Registerkarte Deklaration). Bei Feldern des Typs Attribut sind mehrere Feldinstanzen nicht möglich. Wenn Sie zwei oder mehr Attributfelder mit demselben Namen erstellen, bleiben diese Felder unabhängig voneinander.
  2. Klicken Sie im Menü Bearbeiten auf Neues Feld oder Feld einfügen.

    Anmerkung

    • Wenn Sie in Schritt 1 ein Feld ausgewählt haben, steht der Befehl Neues Feld im Menü Bearbeiten nicht zur Verfügung.
  3. Geben Sie dem neuen Feld denselben Namen wie dem vorhandenen Feld, und drücken Sie die EINGABETASTE.

    Damit haben Sie zwei Instanzen desselben Feldes erstellt.

Wichtig

  • Sie können einer neuen Instanz eines Elementfeldes nicht denselben Namen geben wie einer gleichgeordneten Instanz eines Elementfeldes.

Anmerkungen

  • Wenn Sie auf Neues Feld klicken, wird die neue Feldinstanz in Abhängigkeit von dem ausgewählten Datensatz erstellt.

  • Wenn Sie dagegen auf Feld einfügen klicken, wird die neue Feldinstanz dem ausgewählten Datensatz oder Feld gleichgestellt.

  • Einige Eigenschaften von Feldinstanzen stimmen überein, während andere für jede Instanz einzeln festgelegt werden können. Weitere Informationen zu identischen und nicht identischen Eigenschaften finden Sie unter Eigenschaftsbereich.

  • Vorhandene Felder können nur dann denselben Namen haben, wenn die Typ-Eigenschaft eines Feldes auf Attribut und die Typ-Eigenschaft des anderen Feldes auf Element festgelegt ist.

  • Sie können auch die STRG-TASTE drücken und ein vorhandenes Elementfeld rechts neben den Knoten ziehen, unter dem die neue Feldinstanz eingefügt werden soll, um eine neue Instanz eines vorhandenen Elementfeldes zu erstellen.

Internationales Problem

  • Wenn Sie einen Eingabe-Editor (Input Method Editor, IME) zur Eingabe koreanischer Zeichen für Datensatz- oder Feldnamen verwenden, lässt der BizTalk-Editor doppelt vorhandene Namen zu, obwohl eine Fehlermeldung angezeigt wird, wenn Sie einen Datensatz oder ein Feld in einen vorhandenen Namen umzubenennen versuchen. Der BizTalk-Editor lässt beim Verwenden des IME für Koreanisch auch die Eingabe ungültiger Datensatz- oder Feldnamen zu, die ansonsten nicht zulässig sind. Löschen Sie den ungültigen Datensatz bzw. das ungültige Feld, um das Problem zu lösen.

Verwandte Themen

Zyklische Verweise

Eigenschaftsbereich


Festlegen von Eigenschaften für Datensätze und Felder

Dieser Abschnitt enthält Informationen zu folgenden Themen:

  • Festlegen von Dokumenttrennzeichen

  • Festlegen von Deklarationseigenschaften

  • Festlegen von Verweiseigenschaften

  • Festlegen von Analyseeigenschaften

  • Deklarieren von Namespaces

  • Hinzufügen von benutzerdefinierten Anmerkungen

  • Bearbeiten von benutzerdefinierten Anmerkungen

  • Löschen von benutzerdefinierten Anmerkungen

  • Festlegen von Wörterbucheigenschaften

  • Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

  • Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

  • Löschen einer Wörterbucheigenschaft

  • Löschen einer benutzerdefinierten Wörterbucheigenschaft

  • Auswählen von Codes

  • Codes löschen

  • Löschen einer Eigenschaft für ein beliebiges Feld in der Spalte "Wert"

  • Automatisches Berechnen von Feldpositionen


Festlegen von Dokumenttrennzeichen

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Editor wird angezeigt.

  2. Klicken Sie auf die Registerkarte Dokumenttrennzeichen.

  3. Wählen Sie aus den folgenden Listen je eine Option aus:
    • Datensatztrennzeichen

    • Feldtrennzeichen

    • Unterfeldtrennzeichen

    • Escapezeichen

    Wichtig

    • Wenn Sie eigene Trennzeichen angeben, sollten Sie Unicode-Zeichenwerte verwenden. Eine Liste mit gültigen Zeichen finden Sie auf der Seite Global Codepages der Microsoft Global Software Development-Website (www.microsoft.com/globaldev/reference/wincp.asp). Sie können ANSI-Zeichencodes verwenden, sofern diese – abgesehen von den zwei führenden Nullen – mit dem Unicode-Zeichencode übereinstimmen.
  4. Soll das Dialogfeld Dokumenttrennzeichen bei jeder Überprüfung einer Dokumentinstanz angezeigt werden, damit Sie eindeutige Dokumenttrennzeichen angeben können, aktivieren Sie Zur Eingabe von Trennzeichen bei Instanztests auffordern.

Wichtig

  • Wenn Sie bei Instanztests zur Eingabe von Trennzeichen aufgefordert werden, weil das Kontrollkästchen Zur Eingabe von Trennzeichen bei Instanztests auffordern aktiviert ist, werden die angegebenen Trennzeichen lediglich zum Testen dieser Instanz verwendet. Die auf der Registerkarte Dokumenttrennzeichen angegebenen Trennzeichen werden weiterhin als Standardtrennzeichen verwendet.

  • Null-Abschlusszeichen (Trennzeichen) werden nicht unterstützt. Entfernen Sie das Null-Trennzeichen aus der Flatfile.

Anmerkung

  • Enthält die Instanz mehrere Dokumente und Umschlagsinformationen (Header/Nachspann), wird nur das erste Dokument anhand der auf der Registerkarte Dokumenttrennzeichen angegebenen Dokumenttrennzeichen überprüft.


Festlegen von Deklarationseigenschaften

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine Eigenschaft festlegen möchten, und klicken Sie dann auf die Registerkarte Deklaration.

  2. Doppelklicken Sie in der Wert-Spalte auf das Feld, das mit Eigenschaft verknüpft ist, die Sie festlegen möchten.

  3. Nehmen Sie in dem Feld eine Eingabe vor, oder klicken Sie auf den nach unten zeigenden Pfeil, um unter den verfügbaren Optionen auszuwählen.

  4. Drücken Sie die EINGABETASTE, um die Änderungen zu bestätigen.

Die Registerkarte Deklaration enthält die Eigenschaften, die in den folgenden Tabellen beschrieben sind. Abhängig von dem ausgewählten Knoten werden die betreffenden Eigenschaften für den Stammknoten, einen Datensatz oder ein Feld festgelegt.

Registerkarte "Deklaration": Stammknoteneigenschaften

Eigenschaft | Wert
Name Der Name des Stammknotens.

Anmerkung

  • Wenn Sie den Wert Name auf der Registerkarte Deklaration ändern, wird der Name des Stammknotens in der Spezifikationsstruktur automatisch angepasst. Bei einer neu erstellten Spezifikation bewirkt das Ändern des Wertes Name auf der Registerkarte Deklaration, dass der Wert Spezifikationsname auf der Registerkarte Verweis ebenfalls geändert wird. Da der Spezifikationsname und der Stammknotenname jedoch unterschiedlich sein können, hat eine Änderung des Wertes Spezifikationsname keine Auswirkung auf den Wert Name oder den Namen des Stammknotens in der Spezifikationsstruktur. Nachdem der Wert Spezifikationsname bearbeitet wurde, hat eine Änderung des Wertes Name oder des Stammknotennamens keine Auswirkung auf den Wert Spezifikationsname.
Beschreibung | Die Beschreibung der Spezifikation.
Typ | Der Typ des Datensatzes. Für den Stammknoten ist immer Element festgelegt.
Modell Geschlossen. Gibt an, dass die in der Dokumentinstanz und der Spezifikationsstruktur enthaltenen Daten übereinstimmen.

Offen. Gibt an, dass die Daten in der Dokumentinstanz und der Spezifikationsstruktur möglicherweise nicht übereinstimmen.

Wichtig

  • Wenn Sie den Wert Inhalt von Nur Text in Nur Element und den Wert Modell von Geschlossen in Offen ändern, sind die Eigenschaftswerte auf der Registerkarte Wörterbuch nach wie vor der Spezifikation zugeordnet, und die Datei kann das BizTalk Server-Modul nicht erfolgreich durchlaufen.

Anmerkung

  • Wird für diese Eigenschaft kein Wert angegeben, lautet der Standardwert Offen.
Inhalt Nur Element. Gibt an, dass der Datensatz nur Elemente enthalten kann. Dies ist die Standardeinstellung für alle Datensätze, die untergeordnete Datensätze enthalten.

Gemischt. Gibt an, dass der Stammknoten gemischten Inhalt (Textinformationen und Unterelemente) enthalten kann. Diese Option steht nur zur Verfügung, wenn der Wert Standard auf XML festgelegt ist.

Wichtig

  • Für den Stammknoten muss der Wert Inhalt auf Nur Element oder Gemischt festgelegt werden, da er untergeordnete Datensätze enthält.

  • Das Element kann eine Mischung aus benannten Elementen und Text enthalten. Der Standardwert ist Gemischt. Wurde für das Inhaltsattribut Gemischt festgelegt, lösen die Attribute Minimalvorkommen und Maximalvorkommen keinen Überprüfungsfehler aus, wenn die Anzahl der untergeordneten Elemente außerhalb der angegebenen Begrenzung liegt.

  • Wenn ein Element gemischten Inhalt, z. B. mit untergeordneten Elementen durchsetzte Daten, enthält und Sie im BizTalk-Mapper Wert kopieren (Standard) auswählen, wird nur der Inhalt bis zum ersten untergeordneten Element kopiert. Beispiel:
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Ergebnisse in Item werden kopiert.

  • Wenn ein Element gemischten Inhalt, z. B. mit untergeordneten Elementen durchsetzte Daten, enthält und Sie im BizTalk-Mapper Text und untergeordnete Inhaltswerte kopieren auswählen, wird der gesamte Inhalt, einschließlich der untergeordneten Elemente, kopiert. Beispiel:
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Ergebnisse in Item1121314Number werden kopiert.

Anmerkung

  • Bei Auswahl von Gemischt müssen Sie Viele für den Eigenschaftswert Reihenfolge auswählen.
Reihenfolge Wurde Struktur auf XML festgelegt, wählen Sie einen der folgenden Werte aus:
  • Viele. Gibt an, dass null oder mehr Elemente in beliebiger Reihenfolge und Kombination angezeigt werden können.

  • Eins. Gibt an, dass nur ein Element angezeigt werden kann.

  • Reihenfolge. Gibt an, dass die Elemente in der angegebenen Reihenfolge angezeigt werden müssen.

Anmerkung

  • Bei Auswahl von Viele werden sämtliche Werte für Minimalvorkommen und Maximalvorkommen für untergeordnete Datensätze ignoriert.

Registerkarte "Deklaration": Datensatzeigenschaften

Eigenschaft | Wert
Name | Der Name des Datensatzes.
Beschreibung | Die Beschreibung des Datensatzes.
Typ | Der Typ des Datensatzes.
Datentyp Ein gültiger Datentyp. Eine Liste und Beschreibungen aller gültigen Datentypen finden Sie unter Zusammenfassung der Datentypen und Datentypwerte.

Wichtig

  • Wurde für die Inhalt-Eigenschaft Nur Text festgelegt, können Sie eine Datentyp-Eigenschaft angeben.
Datentypwerte Wenn Sie in der Liste Datentyp den Wert Enumeration auswählen, werden im Feld Datentypwerte standardmäßig die Datentypwerte a b c angezeigt. Sie können die Standardwerte durch benutzerdefinierte Werte ersetzen, die durch jeweils ein Leerzeichen getrennt sind.

Wenn Sie ein X12- oder EDIFACT-Dokument verwenden, das mit einem bestimmten Feld verknüpfte Codes enthält, werden diese Codes automatisch im Feld Datentypwerte angezeigt, und im Feld Datentyp wird der Wert Enumeration angezeigt.

Wichtig

  • Wurde für die Inhalt-Eigenschaft Nur Text festgelegt, können Sie die Datentypwerte-Eigenschaft angeben.

  • Das Nummernzeichen (#), das kaufmännische Und-Zeichen (&) und der Doppelpunkt (:) können nicht als Datentypwerte verwendet werden.
Modell Geschlossen. Gibt an, dass die in der Dokumentinstanz und der Spezifikationsstruktur enthaltenen Daten übereinstimmen.

Offen. Gibt an, dass die Daten in der Dokumentinstanz und der Spezifikationsstruktur möglicherweise nicht übereinstimmen.

Wichtig

  • Wenn Sie den Wert Inhalt von Nur Text in Nur Element und den Wert Modell von Geschlossen in Offen ändern, sind die Eigenschaftswerte auf der Registerkarte Wörterbuch nach wie vor der Spezifikation zugeordnet, und die Datei kann das BizTalk Server-Modul nicht erfolgreich durchlaufen.

Anmerkung

  • Wird für diese Eigenschaft kein Wert angegeben, lautet der Standardwert Offen.
Inhalt Nur Element. Gibt an, dass der Datensatz nur Elemente enthalten kann. Dies ist die Standardeinstellung für alle Datensätze, die untergeordnete Datensätze enthalten.

Leer. Gibt an, dass der Datensatz keine Unterelemente enthalten kann.

Nur Text. Gibt an, dass der Datensatz Text, aber keine Unterelemente enthalten kann.

Gemischt. Gibt an, dass der Stammknoten gemischten Inhalt (Textinformationen und Unterelemente) enthalten kann.

Wichtig

  • Für Datensätze mit untergeordneten Datensätzen kann der Wert Inhalt nur auf Nur Element oder Gemischt festgelegt werden. Verfügt ein Datensatz nicht über untergeordnete Datensätze, enthält die Liste außerdem Leer und Nur Text.

  • Das Element kann eine Mischung aus benannten Elementen und Text enthalten. Gemischt ist der Standardwert. Wurde für das Inhaltsattribut Gemischt festgelegt, lösen die Attribute Minimalvorkommen und Maximalvorkommen keinen Überprüfungsfehler aus, wenn die Anzahl der untergeordneten Elemente außerhalb der angegebenen Begrenzung liegt.

  • Wenn Sie den Wert Inhalt von Nur Text in Nur Element und den Wert Modell von Geschlossen in Offen ändern, sind die Eigenschaftswerte auf der Registerkarte Wörterbuch nach wie vor der Spezifikation zugeordnet, und die Datei kann das BizTalk Server-Modul nicht erfolgreich durchlaufen.

  • Wenn ein Element gemischten Inhalt, z. B. mit untergeordneten Elementen durchsetzte Daten, enthält und Sie im BizTalk-Mapper Wert kopieren (Standard) auswählen, wird nur der Inhalt bis zum ersten untergeordneten Element kopiert. Beispiel:
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Ergebnisse in Item werden kopiert.

  • Wenn ein Element gemischten Inhalt, z. B. mit untergeordneten Elementen durchsetzte Daten, enthält und Sie im BizTalk-Mapper Text und untergeordnete Inhaltswerte kopieren auswählen, wird der gesamte Inhalt, einschließlich der untergeordneten Elemente, kopiert. Beispiel:
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Ergebnisse in Item1121314Number werden kopiert.

Anmerkungen

  • Bei Auswahl von Nur Text können Sie die Eigenschaften Datentyp und Datentypwert angeben.

  • Bei Auswahl von Gemischt müssen Sie Viele für den Eigenschaftswert Reihenfolge auswählen.
Reihenfolge Wurde Struktur auf XML festgelegt, wählen Sie einen der folgenden Werte aus:
  • Viele. Gibt an, dass null oder mehr Elemente in beliebiger Reihenfolge und Kombination angezeigt werden können.

  • Eins. Gibt an, dass nur ein Element angezeigt werden kann.

  • Reihenfolge. Gibt an, dass die Elemente in der angegebenen Reihenfolge angezeigt werden müssen.

Anmerkung

  • Bei Auswahl von Viele werden sämtliche Werte für Minimalvorkommen und Maximalvorkommen für untergeordnete Datensätze ignoriert.
Anzahl der Zyklen Geben Sie die Anzahl der Zyklen ein, die unter dem Basisdatensatz angezeigt werden sollen. Weitere Informationen finden Sie unter Zyklische Verweise.

Anmerkung

  • Dieses Eigenschaftenfeld steht nur zur Verfügung, wenn Sie einen zyklischen Verweis erstellt haben. Der Standardwert ist 7.

Registerkarte "Deklaration": Feldeigenschaften

Eigenschaft | Wert
Name | Der Name des Feldes.
Beschreibung | Die Beschreibung des Feldes.
Typ Wählen Sie einen der folgenden Werte aus:
  • Element

  • Attribut

Anmerkung

  • Enthält Ihre Spezifikation Felder fester Breite, ist es nicht empfehlenswert, den Wert Typ auf Element festzulegen. Dies könnte dazu führen, dass die Überprüfung fehlschlägt.
Modell Geschlossen. Gibt an, dass die in der Dokumentinstanz und der Spezifikationsstruktur enthaltenen Daten übereinstimmen.

Offen. Gibt an, dass die Daten in der Dokumentinstanz und der Spezifikationsstruktur möglicherweise nicht übereinstimmen.

Anmerkungen

  • Wird für diese Eigenschaft kein Wert angegeben, lautet der Standardwert Offen.

  • Die Modell-Eigenschaft steht nur für Felder zur Verfügung, deren Wert Typ auf Element festgelegt wurde.
Inhalt Nur Text. Gibt an, dass das Feld Text, aber keine Unterelemente enthalten kann.

Anmerkungen

  • Die Inhalt-Eigenschaft steht nur für Felder zur Verfügung, deren Wert Typ auf Element festgelegt wurde.

  • Für die Inhalt-Eigenschaft eines Feldes kann nur der Wert Nur Text festgelegt werden.
Datentyp Ein gültiger Datentyp. Eine Liste und Beschreibungen aller gültigen Datentypen finden Sie unter Zusammenfassung der Datentypen und Datentypwerte.

Wichtig

  • Wurde die Standard-Eigenschaft auf der Registerkarte Verweis auf den Wert X12, EDIFACT oder BENUTZERDEFINIERT festgelegt, können Sie auf der Registerkarte Analysieren einen Wert für die Eigenschaft Benutzerdefinierter Datentyp festlegen. Wenn Sie für Benutzerdefinierter Datentyp einen Wert festlegen, wird der Wert Datentyp automatisch geändert, so dass er mit der Auswahl des Wertes für Benutzerdefinierter Datentyp übereinstimmt.

  • Wurde in einer Spezifikation ein Feld erstellt, für dessen Datentyp-Eigenschaft IDREF oder IDREFS festgelegt wurde, muss in dieser Spezifikation ein weiteres Feld mit dem Wert ID für die Datentyp-Eigenschaft erstellt werden.

  • Sie müssen diesem Feld in der Spezifikation einen Datentyp zuweisen, um im BizTalk-Messaging-Manager ein Feld zur Überwachung oder zur Verwendung in einem Kanalfilterausdruck auszuwählen.
Datentypwerte Wenn Sie den Wert Enumeration in der Liste Datentyp auswählen, werden im Feld Datentypwerte standardmäßig die Datentypwerte a b c angezeigt. Sie können die Standardwerte durch benutzerdefinierte Werte, die durch jeweils ein Leerzeichen getrennt sind, ersetzen.

Wenn Sie ein X12- oder EDIFACT-Dokument verwenden, das mit einem bestimmten Feld verknüpfte Codes enthält, werden diese Codes automatisch im Feld Datentypwerte angezeigt, und das Feld Datentyp erhält den Wert Enumeration.

Wichtig

  • Das Nummernzeichen (#) und das kaufmännische Und-Zeichen (&) können nicht als Datentypwerte verwendet werden.
Minimallänge Die minimale Anzahl von Zeichen, die das Feld enthalten kann.

Anmerkungen

  • Die Minimallänge-Eigenschaft kann nur für Felder mit den folgenden Datentyp-Werten festgelegt werden: String, Number, Binary (base64) und Binary (hex).

  • Wird für die Eigenschaft Benutzerdefinierter Datentyp ein impliziter Dezimaldatentyp angegeben, empfiehlt es sich nicht, einen Wert für Minimallänge anzugeben. Wenn Sie einen Wert für Minimallänge angeben müssen, sollte der Wert kleiner als Nx sein, wobei x für eine Zahl zwischen 1 und 9 steht. Der Wert Nx ist in der Liste für die Eigenschaft Benutzerdefinierter Datentyp enthalten.
Maximallänge Die maximale Anzahl von Zeichen, die das Feld enthalten kann.

Anmerkung

  • Die Maximallänge-Eigenschaft kann nur für Felder mit den folgenden Datentyp-Werten festgelegt werden: String, Number, Binary (base64) und Binary (hex).
Standardwert Geben Sie einen numerischen Wert ein. Weitere Informationen finden Sie unter Integration von Standardwerten.

Anmerkungen

  • Die Standardwert-Eigenschaft wird in Spezifikationen nur angezeigt, wenn für die Standard-Eigenschaft (auf der Registerkarte Verweis für den Stammknoten) der Wert XML und für die Typ-Eigenschaft (auf der Registerkarte Deklaration für das Feld) der Wert Attribut festgelegt wurde.

  • Die folgenden Zeichen können nicht verwendet werden:
    • Graviszeichen (`)

    • Apostroph (')

    • Sternchen (*)

    • Umgekehrter Schrägstrich (\)

    • Geschweifte Klammern links/rechts ({ })

    • Eckige Klammern links/rechts ([ ])

    • Zirkumflexzeichen (^)

    • Doppelpunkt (:)

    • Komma (,)

    • Dollarzeichen ($)

    • Gleichheitszeichen (=)

    • Ausrufezeichen (!)

    • Prozentzeichen (%)

    • Punkt (.)

    • Senkrechter Strich (|)

    • Pluszeichen (+)

    • Fragezeichen (?)

    • Semikolon (;)

    • Schrägstrich (/)

    • Tilde (~)

Verwandte Themen

Hinzufügen eines Kanalfilterausdrucks

Zeichenlängenbeschränkungen

Zyklische Verweise

Integration von Standardwerten

Auswählen von Spezifikationsfeldern in einem Kanal

Auswählen von Spezifikationsfeldern in einer Dokumentdefinition

Zusammenfassung der Datentypen und Datentypwerte


Festlegen von Verweiseigenschaften

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine Eigenschaft festlegen möchten, und klicken Sie dann auf die Registerkarte Verweis.

  2. Doppelklicken Sie in der Spalte Wert auf das Feld, das mit Eigenschaft verknüpft ist, die Sie festlegen möchten.

  3. Nehmen Sie in dem Feld eine Eingabe vor, oder klicken Sie auf den nach unten zeigenden Pfeil, um unter den verfügbaren Optionen auszuwählen.

Die Registerkarte Verweis enthält die Eigenschaften, die in den folgenden Tabellen beschrieben sind. Abhängig von dem ausgewählten Knoten werden die betreffenden Eigenschaften für den Stammknoten, einen Datensatz oder ein Feld festgelegt.

Registerkarte "Verweis": Stammknoteneigenschaften

Eigenschaft | Wert
Spezifikationsname | Der Name der Spezifikation. Dieser Name entspricht dem Wert des <Schema>-Tags in der Spezifikation.
Standard Wählen Sie einen der folgenden Werte aus:
  • XML zum Erstellen einer Spezifikation auf der Basis von XML (Extensible Markup Language).

  • X12 zum Erstellen einer Spezifikation auf der Basis von X12.

  • EDIFACT zum Erstellen einer Spezifikation auf der Basis von EDIFACT.

  • BENUTZERDEFINIERT zum Erstellen einer Spezifikation auf der Basis einer Flatfile oder zum Erstellen einer benutzerdefinierten Spezifikation, die mit einem benutzerdefinierten Parser analysiert werden soll.

Wichtig

  • Wenn Sie den Wert für die Standard-Eigenschaft von X12 in BENUTZERDEFINIERT ändern (z. B. für Flatfiles) und dann ein Feld auswählen und den Wert für Benutzerdefinierter Datentyp auf der Registerkarte Analysieren auf Number (N) bzw. Number (Nx) festlegen, wobei x für eine Zahl zwischen 1 und 9 steht, wird auf der Registerkarte Analysieren die Eigenschaft Benutzerdefinierte Maximallänge für das Feld nicht angezeigt. Daher müssen Sie den Wert für Maximallänge auf der Registerkarte Deklaration erhöhen, um die analysierte oder serialisierte Ausgabe berücksichtigen zu können, die sich durch die Umwandlung einer Spezifikation aus einem impliziten Dezimalformat bzw. in ein implizites Dezimalformat ergibt.
Standardversion | Die Version des Standards, beispielsweise X12, Version 4010, auf der die Spezifikation basiert.
Dokumenttyp | Der Dokumenttyp, beispielsweise 850, auf dem die Spezifikation basiert.
Version | Die Versionsnummer des Dokumentstandards, auf dem die Spezifikation basiert.
Standard-Datensatztrennzeichen Geben Sie ein Zeichen ein oder wählen Sie ein Zeichen aus, das als Trennzeichen für alle Knoten verwendet werden soll, für die die Trennzeichentyp-Eigenschaft auf der Registerkarte Analysieren auf Standard-Datensatztrennzeichen festgelegt ist.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Feld Standard auf der Registerkarte Verweis (für den Stammknoten) auf BENUTZERDEFINIERT festgelegt ist.
Standardfeldtrennzeichen Geben Sie ein Zeichen ein oder wählen Sie ein Zeichen aus, das als Trennzeichen für alle Knoten verwendet werden soll, für die die Trennzeichentyp-Eigenschaft auf der Registerkarte Analysieren auf Standardfeldtrennzeichen festgelegt ist.

Wichtig

  • Die Wiederholung von Trennzeichen auf Feldebene, die üblicherweise in ANSI X12, Version 4030 und höher, vorliegen, wird nicht unterstützt.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Feld Standard auf der Registerkarte Verweis (für den Stammknoten) auf BENUTZERDEFINIERT festgelegt ist.
Standardunterfeldtrennzeichen Geben Sie ein Zeichen ein oder wählen Sie ein Zeichen aus, das als Trennzeichen für alle Knoten verwendet wird, für die die Trennzeichentyp-Eigenschaft auf der Registerkarte Analysieren auf Standardunterfeldtrennzeichen festgelegt ist.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Feld Standard auf der Registerkarte Verweis (für den Stammknoten) auf BENUTZERDEFINIERT festgelegt ist.
Standardescapezeichen Geben Sie ein Zeichen ein oder wählen Sie ein Zeichen aus, das als Escapezeichen für alle Knoten verwendet werden soll, für die die Escapetyp-Eigenschaft auf der Registerkarte Analysieren auf Standardescapezeichen festgelegt ist.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Feld Standard auf der Registerkarte Verweis (für den Stammknoten) auf BENUTZERDEFINIERT festgelegt ist.
Codepage Wählen Sie einen der folgenden Werte:
  • Arabisch (1256)

  • Baltisch (1257)

  • Mitteleuropäisch (1250)

  • Kyrillisch (1251)

  • Griechisch (1253)

  • Hebräisch (1255)

  • Japanisch Shift-JIS (932)

  • Koreanisch (949)

  • Little-Endian-UTF16 (1200)

  • Vereinfachtes Chinesisch (936)

  • Thai (874)

  • Traditionelles Chinesisch (950)

  • Türkisch (1254)

  • Vietnamesisch (1258)

  • Westeuropäisch (1252)

Anmerkungen

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn das Feld Standard auf der Registerkarte Verweis (für den Stammknoten) auf Benuterdefiniert festgelegt ist.

  • UTF7 (65000) und UTF8 (65001) werden von BizTalk Server nicht unterstützt.

  • Wird für Codepage kein Wert angegeben, lautet der Standardwert Westeuropäisch (1252).
Empfangsbestätigung Wählen Sie eine der folgenden Optionen:
  • Ja. Gibt an, dass die Spezifikation als eingehende Empfangsbestätigung verwendet werden soll. Eine Korrelatorkomponente (X12, EDIFACT oder CUSTOM) stellt eine Verbindung zwischen der Empfangsbestätigung und dem ausgehenden Dokument, das diese bestätigt, her (d. h. dem Dokument, das zuvor an den Absender der Empfangsbestätigung gesendet wurde).

  • Nein. Gibt an, dass die Spezifikation nicht als eingehende Empfangsbestätigung verwendet werden soll.

Anmerkungen

  • Wird für Empfangsbestätigung kein Wert angegeben, lautet der Standardwert Nein.

  • Für Spezifikationen, die auf der Standardempfangsbestätigung basieren, und für Spezifikationen, denen die Standardempfangsbestätigung zugeordnet ist (beide werden beim Generieren einer ausgehenden Empfangsbestätigung verwendet), sollte die Empfangsbestätigung-Eigenschaft auf Nein festgelegt werden.
Umschlag Wählen Sie eine der folgenden Optionen:
  • Ja. Gibt an, dass es sich bei der Spezifikation um eine Austauschspezifikation handelt.

  • Nein. Gibt an, dass es sich bei der Spezifikation nicht um eine Austauschspezifikation handelt.

Anmerkungen

  • Diese Eigenschaft wird nur bei Flatfiles und XML-Dateien für Umschläge verwendet.

  • Wird für das Feld kein Wert angegeben, wird der Wert Nein verwendet.
Zielnamespace Wenn eine BizTalk Framework-Instanz erstellt und in dieser Instanz ein Namespace festgelegt wurde, muss der in der Instanz verwendete Namespace eingegeben werden.

Anmerkung

  • Wurde für den Zielnamespace einer Instanz der Wert x-schema verwendet, kann beim Testen der Instanz im BizTalk-Mapper ein Fehler auftreten.

Registerkarte "Verweis": Datensatzeigenschaften

Eigenschaft Wert
Minimalvorkommen Gibt an, wie oft ein Datensatz an seiner Position innerhalb der Knotenhierarchie minimal vorkommen kann. Mögliche Werte sind 0 oder 1.

Anmerkung

  • Wird für diese Eigenschaft kein Wert angegeben, lautet der Standardwert 1.
Maximalvorkommen Gibt an, wie oft ein Datensatz an seiner Position innerhalb der Knotenhierarchie maximal vorkommen kann. Mögliche Werte sind 1 und Sternchen (*).

Anmerkungen

  • Ein Sternchen (*) zeigt an, dass es sich bei dem Datensatz um einen Schleifendatensatz handelt. Bei Verwendung dieser Spezifikation im BizTalk-Mapper wird der Datensatz als Schleife kompiliert. Wenn Sie 1 eingeben, betrachtet der BizTalk-Mapper diesen Datensatz nicht als Schleifendatensatz.

  • Wird für diese Eigenschaft kein Wert angegeben, lautet der Standardwert 1.

Registerkarte "Verweis": Feldeigenschaften

Eigenschaft Wert
Erforderlich Wählen Sie eine der folgenden Optionen:
  • Ja. Gibt an, dass dieses Feld vorhanden sein muss.

  • Nein. Gibt an, dass dieses Feld nicht vorhanden sein muss.

Anmerkung

  • Wird für diese Eigenschaft kein Wert angegeben, lautet der Standardwert Nein.
Anfangsposition Eine Zahl, die die Anfangsposition des Feldes im Datensatz angibt.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn der übergeordnete Datensatz auf einer Struktur mit Feldern fester Breite basiert.
Endposition Eine Zahl, die die Endposition des Feldes im Datensatz angibt.

Anmerkung

  • Dieses Eigenschaftenfeld wird nur angezeigt, wenn der übergeordnete Datensatz auf einer Struktur mit Feldern fester Breite basiert.

Verwandte Themen

Berechnen von Feldpositionen

Zeichenlängenbeschränkungen

Grundlegendes zu Empfangsbestätigungen


Festlegen von Analyseeigenschaften

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine Eigenschaft festlegen möchten, und klicken Sie dann auf die Registerkarte Analysieren.

  2. Doppelklicken Sie in der Wert-Spalte auf das Feld, das mit Eigenschaft verknüpft ist, die Sie festlegen möchten.

  3. Nehmen Sie in dem Feld eine Eingabe vor, oder klicken Sie auf den nach unten zeigenden Pfeil, um unter den verfügbaren Optionen auszuwählen.

Die Registerkarte Analysieren enthält die Eigenschaften, die in den folgenden Tabellen beschrieben sind. Die verfügbaren Eigenschaften hängen von den verwendeten Eigenschaften Standard (X12, EDIFACT oder Benutzerdefiniert) und Struktur ab. Standardmäßig wird bei einer neuen Spezifikation, die auf einer leeren Spezifikation basiert, die XML-Standardeigenschaft (Extensible Markup Language) verwendet. Geben Sie für jede Eigenschaft den gewünschten Wert ein. Abhängig von dem ausgewählten Knoten werden die betreffenden Eigenschaften für den Stammknoten, einen Datensatz oder ein Feld festgelegt.

Standard: XML

Registerkarte "Analysieren": Stammknoten-, Datensatz- und Feldeigenschaften

Diese Eigenschaften werden nicht angezeigt.

Standard: X12 oder EDIFACT

Wichtig

  • Die Werte für Zeichen für Zeilenumbruch, Auffüllzeichen, Escapewert und Trennzeichenwert für einen Datensatz sowie die ihm untergeordneten Felder schließen sich gegenseitig aus.

Registerkarte "Analysieren": Stammknoten- oder Datensatzeigenschaften

Eigenschaft Wert
Struktur Für den Stammknoten wird automatisch der Standardwert Getrennt verwendet.

Anmerkung

  • Wurde auf der Registerkarte Verweis des Stammknotens einer Spezifikation für die Standard-Eigenschaft der Wert X12 oder EDIFACT festgelegt, können Sie den Wert für die Struktur-Eigenschaft auf der Registerkarte Analysieren des Stammknotens oder eines Datensatzes nicht bearbeiten. Sie müssen die Standard-Eigenschaft in BENUTZERDEFINIERT ändern, um die Struktur-Eigenschaft bearbeiten zu können.
Quelltagbezeichner Der Name des Quelltagbezeichners. Dieser Tagname wird verwendet, um dem Datensatz Daten zuzuordnen.

Wichtig

  • Wenn es sich um einen Schleifendatensatz handelt und die Instanzdaten keine Schleifenstruktur enthalten (d. h., die Struktur nicht explizit, sondern implizit ist), sollten Sie sicherstellen, dass für Quelltagbezeichner kein Wert angegeben ist.

Anmerkungen

  • Für eine nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um jedes beliebige Tag in der Originaldatei zu identifizieren. Ein Quelltagbezeichner darf keines der folgenden Zeichen enthalten: < > " &

  • Bei der Quelltagbezeichner-Eigenschaft muss die Groß-/Kleinschreibung beachtet werden.
Feldreihenfolge Wählen Sie eine der folgenden Optionen aus:
  • Präfix. Ein Präfixtrennzeichen wird vor jeder Komponente und jedem Mitglied einer Komponente in einer Serie angezeigt. Wenn beispielsweise ein Sternchen (*) das Trennzeichen ist, wird Folgendes angezeigt: *a*a*b*c.

  • Postfix. Ein Postfixtrennzeichen wird nach jeder Komponente und jedem Mitglied einer Komponente in einer Serie angezeigt. Wenn beispielsweise ein Sternchen (*) das Trennzeichen ist, wird Folgendes angezeigt: a*a*b*c*.

  • Infix. Ein Infixtrennzeichen wird zwischen Komponenten und Mitgliedern von Komponenten in einer Serie angezeigt. Wenn beispielsweise ein Sternchen (*) das Trennzeichen ist, wird Folgendes angezeigt: a*a*b*c.

Anmerkungen

  • Für nicht auf XML basierende Dateien sollte Feldreihenfolge für den Stammknoten auf Postfix und für Schleifendatensatzknoten auf Infix festgelegt werden. Anwendungsbeispiele finden Sie in den Ordnern Flat-FileDelimited und Flat-FilePositional unter \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\.

  • Wird für Feldreihenfolge kein Wert angegeben, lautet der Standardwert Präfix.
Trennzeichentyp Wählen Sie eine der folgenden Optionen aus, um ein Trennzeichen für die untergeordneten Knoten direkt unterhalb des aktuellen Knotens festzulegen:
  • Standard-Datensatztrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standard-Datensatztrennzeichen-Eigenschaft verwendet werden soll, der in der Dokumentinstanz definiert ist.

  • Standardfeldtrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standardfeldtrennzeichen-Eigenschaft verwendet werden soll, der in der Dokumentinstanz definiert ist.

  • Standardunterfeldtrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standardunterfeldtrennzeichen-Eigenschaft verwendet werden soll, der in der Dokumentinstanz definiert ist.
Escapetyp

(Wird auch als Freigabezeichen bezeichnet.)

 Wählen Sie die folgende Option aus, um ein Escapezeichen für die untergeordneten Knoten direkt unterhalb des aktuellen Knotens festzulegen:
  • Standardescapezeichen. Gibt an, dass in der Dokumentinstanz ein Wert für das Escapezeichen definiert wurde.

Ein Escapezeichen ist nützlich, wenn die Felddaten ein Zeichen enthalten, das als Trennzeichen für den übergeordneten Knoten des Feldes verwendet wird. Wenn die Felddaten folgendermaßen lauten und Sie ein Komma als Trennzeichenwert für den Knoten, der das Feld enthält, ausgewählt haben, interpretiert der BizTalk-Editor das Komma nach "Braun" als Trennzeichen, auch wenn es sich dabei um einen Teil der Felddaten handelt.

Braun,Robert,1231,ja

Sie können dieses Problem umgehen, indem Sie direkt vor das Trennzeichen, das Teil der Felddaten sein soll, ein Escapezeichen setzen. Wurde als Escapezeichen beispielsweise der umgekehrte Schrägstrich angegeben, können Sie diesen direkt vor ein Trennzeichen setzen, wie im folgenden Beispiel dargestellt:

Braun\,Robert,1231,ja

Der BizTalk-Editor interpretiert das Komma nach dem umgekehrten Schrägstrich als Teil der Felddaten und nicht als Trennzeichen.

Anmerkung

  • Die Escapetyp-Eigenschaft steht für X12-Spezifikationen nicht zur Verfügung.
Neue Zeile anfügen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Gibt an, dass die Serialisierungskomponente beim Erreichen des Datensatztrennzeichens automatisch eine neue Zeile anfügt (LF,0x0A).

  • Nein. Gibt an, dass die Serialisierungskomponente beim Erreichen des Datensatztrennzeichens im nächsten Datensatz mit derselben Zeile fortfährt.

Anmerkung

  • Wird für Neue Zeile anfügen kein Wert eingegeben, lautet der Standardwert Nein.
Wagenrücklauf überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Wagenrücklauf überspringen kein Wert angegeben, lautet der Standardwert Ja.
Zeilenvorschub überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Zeilenvorschub überspringen kein Wert angegeben, lautet der Standardwert Ja.
Datensatzanzahl ignorieren Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation nicht berücksichtigt werden soll.

  • Nein. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation berücksichtigt werden soll.

Anmerkungen

  • Stimmt die Anzahl der Datensätze in einer an BizTalk Server gesendeten Dokumentinstanz nicht mit der berechneten Anzahl der Datensätze in der Spezifikation überein, tritt ein Analysefehler auf. Weitere Informationen finden Sie unter Analysefehler.

  • Wird für Datensatzanzahl ignorieren kein Wert angegeben, lautet der Standardwert Ja.
Triggerfeld Wählen Sie eine Option aus der Liste aus. Die Optionen entsprechen den verfügbaren Triggerfeldern.

Wichtig

  • Diese Eigenschaft ist nur verfügbar, wenn der Wert für Standard auf X12 festgelegt wurde.

Anmerkung

  • Weitere Informationen zu Triggerfeldern finden Sie unter Allzweck-Trigger.
Triggerwert Dieser Wert entspricht dem Datentypwert für das Triggerfeld.

Wichtig

  • Diese Eigenschaft ist nur verfügbar, wenn der Wert für Standard auf X12 festgelegt wurde.

Anmerkung

  • Wenn Sie den Microsoft® BizTalk™-Beschleuniger für HIPAA-Schemas verwenden, sollten Sie die Werte für die Triggereigenschaften nicht ändern.
Unterbrechung der Erstellung des Unterdokuments Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser oder der Serialisierungskomponente mit, dass eine neue Instanz erstellt werden soll, die die dem Datensatz übergeordnete Hierarchie repliziert.

  • Nein. Teilt dem Parser oder der Serialisierungskomponente mit, dass keine neue Instanz erstellt werden soll, die die dem Datensatz übergeordnete Hierarchie repliziert.

Wichtig

  • Diese Eigenschaft wird nur angezeigt, wenn sie im Schema enthalten ist.

  • Diese Eigenschaft ist nur verfügbar, wenn der Wert für Standard auf X12 festgelegt wurde.

Anmerkung

  • Wenn Sie nicht Ja angeben, wird für die Eigenschaft Unterbrechung der Erstellung des Unterdokuments der Standardwert Nein verwendet, und dem Parser oder der Serialisierungskomponente wird mitgeteilt, dass keine neue Instanz erstellt werden soll, die die dem Datensatz übergeordnete Hierarchie repliziert.

Registerkarte "Analysieren": Feldeigenschaften

Eigenschaft | Wert
Benutzerdefinierter Datentyp Wählen Sie eine der folgenden Optionen aus:
  • String (AN). AN steht für alphanumerische Felder.

  • Binary Hexadecimal (B). B steht für binäre Felder.

  • Date (CY). CY steht für vierstellige Datumsfelder.

  • Number (D0-D4). D0 bis D4 (einschließlich) stehen für Dezimalfelder. Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Date (DT). DT steht für Datumsfelder.

  • String (ID). ID steht für Identifikationsfelder.

  • Number (N). N steht für Felder mit ganzen Zahlen.

  • Number (N1-9). N1 bis N9 (einschließlich) stehen für implizite Dezimalfelder (das Dezimaltrennzeichen wird in den Daten nicht angezeigt). Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

    Anmerkungen

    • Wenn eine Spezifikation aus einem impliziten Dezimalformat bzw. in ein implizites Dezimalformat umgewandelt wird, muss sichergestellt werden, das der Wert für die Eigenschaft Benutzerdefinierte Maximallänge die sich daraus ergebende analysierte oder serialisierte Ausgabe verarbeiten kann. Wurde Benutzerdefinierter Datentyp beispielsweise auf N2 festgelegt, muss für Benutzerdefinierte Maximallänge mindestens der Wert 3 festgelegt werden. Dies ist erforderlich, weil der Parser die Dezimalstelle während der Analyse einfügt und die Serialisierungskomponente sie entfernt und zudem die Anzahl der Stellen rechts vom Dezimalzeichen überprüft.

    • Wenn Sie auf der Registerkarte Verweis den Wert für die Standard-Eigenschaft von X12 in BENUTZERDEFINIERT ändern (z. B. für Flatfiles) und dann Number (N) bzw. Number (Nx) auswählen, wobei x für eine Zahl zwischen 1 und 9 steht, wird die Eigenschaft Benutzerdefinierte Maximallänge nicht angezeigt. Daher müssen Sie den Wert für Maximallänge auf der Registerkarte Deklaration erhöhen, um die analysierte oder serialisierte Ausgabe berücksichtigen zu können, die sich durch die Umwandlung einer Spezifikation aus einem impliziten Dezimalformat bzw. in ein implizites Dezimalformat ergibt.
  • Number (R). R steht für Felder mit reellen Zahlen.

  • Time (TM). TM steht für Zeitfelder.

Wichtig

  • Wenn Sie für Benutzerdefinierter Datentyp einen Wert angeben, wird der Wert für Datentyp auf der Registerkarte Deklaration automatisch geändert, so dass er mit der Auswahl für Benutzerdefinierter Datentyp übereinstimmt. Wenn Sie beispielsweise den Wert für Benutzerdefinierter Datentyp auf der Registerkarte Analysieren in Date (CY) ändern, wird der Wert für Datentyp auf der Registerkarte Deklaration automatisch in Date geändert.

Anmerkungen

  • Wurde für die Eigenschaft Benutzerdefinierter Datentyp der Wert Date (DT), Date (CY) oder Time (TM) angegeben, muss für die Eigenschaft Benutzerdefiniertes Datum/Zeitformat ebenfalls ein Wert festgelegt werden.

  • Alle Werte für benutzerdefinierte Datentypen werden in Spezifikationen, in denen die Standard-Eigenschaft auf X12 festgelegt wurde, unterstützt. Unterstützte Datentypen für Spezifikationen, in denen für die Standard-Eigenschaft EDIFACT festgelegt wurde, sind String (AN) und Number (N).
Benutzerdefiniertes Datum/Zeitformat Wurde für die Eigenschaft Benutzerdefinierter Datentyp der Wert Date (DT), Date (CY) oder Time (TM) festgelegt, klicken Sie auf eine Option in der Liste. Weitere Informationen finden Sie unter Anwenden der Eigenschaft "Benutzerdefiniertes Datum/Zeitformat". Weitere Informationen zu unterstützten Zeitformaten finden Sie unter Unterstütztes Zeitformat für X12.

Anmerkung

  • Dieses Eigenschaftenfeld steht nur zur Verfügung, wenn Date (DT), Date (CY) oder Time (TM) für Benutzerdefinierter Datentyp festgelegt wurde.

Wichtig

  • Parser in BizTalk Server erkennen bei eingehenden Dokumentinstanzen nicht das julianische Datumsformat. Ein julianisches Datumsformat umfasst drei Stellen zur Angabe des Tages (TTT). Obgleich es im BizTalk-Editor möglich ist, Spezifikationen zu erstellen, die das julianische Datumsformat verwenden, wird diese Funktion nur für benutzerdefinierte Parser bereitgestellt, die Dokumentinstanzen erkennen können, die das julianische Datumsformat verwenden. Verwenden Sie in einer Spezifikation oder Dokumentinstanz nicht das julianische Datumsformat, es sei denn, Sie verwenden einen benutzerdefinierten Parser, der das julianische Datumsformat erkennt.
Blocksatz Wählen Sie eine der folgenden Optionen aus:
  • Nach links. Richtet Daten in Flatfiles mit Feldern fester Breite am linken Rand aus, wenn die Daten die maximale Feldlänge unterschreiten. Außerdem werden Daten in Flatfiles mit Trennzeichen am linken Rand ausgerichtet, wenn die Datenmenge die minimalen Längenanforderungen nicht erfüllt.

  • Nach rechts. Richtet Daten in Flatfiles mit Feldern fester Breite am rechten Rand aus, wenn die Daten die maximale Feldlänge unterschreiten. Außerdem werden Daten in Flatfiles mit Trennzeichen am linken Rand ausgerichtet, wenn die Datenmenge die minimalen Längenanforderungen nicht erfüllt.

Anmerkung

  • Wird für Blocksatz kein Wert angegeben, lautet der Standardwert Nach links.
Auffüllzeichen | Geben Sie ein Zeichen ein, um das Feld aufzufüllen. Als Auffüllzeichen können Sie jedes beliebige Zeichen verwenden, einschließlich eines Leerzeichens oder einer Null. Weitere Informationen finden Sie unter Auffüllzeichen.
Zeichen für Zeilenumbruch Geben Sie ein Zeichen ein, um Felddaten einzuschließen. Diese Eigenschaft ist nützlich, wenn die Felddaten ein Zeichen enthalten, das als Trennzeichenwert für den übergeordneten Knoten des Feldes verwendet wird. Wenn die Felddaten folgendermaßen lauten und Sie ein Komma als Trennzeichenwert für den Knoten, der das Feld enthält, ausgewählt haben, interpretiert der BizTalk-Editor das Komma nach "Braun" als Trennzeichen, auch wenn es sich dabei um einen Teil der Felddaten handelt.

Braun,Robert,1231,ja

Sie können dieses Problem umgehen, indem Sie für die Eigenschaft Zeichen für Zeilenumbruch einen Wert festlegen und dann die Felddaten in das Umbruchzeichen einschließen. Beispielsweise können Sie als Umbruchzeichen für das erste Feld doppelte Anführungszeichen festlegen und anschließend die Felddaten folgendermaßen eingeben:

"Braun,Robert",1231,ja

Das Komma zwischen den doppelten Anführungszeichen wird vom BizTalk-Editor als Teil der Felddaten und nicht als Trennzeichenwert interpretiert.

Wichtig

  • Enthält ein Feld ein Umbruchzeichen, dürfen sich zwischen dem Umbruchzeichen und einem Trennzeichen, das vor oder nach dem Umbruchzeichen steht, keine Daten befinden.

Anmerkungen

  • Enthalten die Felddaten Zeichen, die auch als Umbruchzeichen verwendet werden, müssen Sie diese Zeichen in ein weiteres Umbruchzeichen einschließen.

    Im folgenden Beispiel wurde das doppelte Anführungszeichen als Umbruchzeichen festgelegt:

    "Braun,Robert ""Berti"""

    Der BizTalk-Editor analysiert dies als:

    Braun,Robert "Berti"
Minimallänge mit Auffüllzeichen Die minimale Länge eines Feldes in einer ausgehenden Dokumentinstanz, einschließlich Auffüllzeichen. Weitere Informationen zu Auffüllzeichen finden Sie unter Auffüllzeichen.

Anmerkungen

  • Diese Eigenschaft kann nur festgelegt werden, wenn das Auffüllzeichen für das Feld festgelegt wurde.

  • Wurde die Minimallänge-Eigenschaft auf der Registerkarte Deklaration für das Feld festgelegt, muss die Eigenschaft Minimallänge mit Auffüllzeichen größer als oder gleich dem Wert der Minimallänge-Eigenschaft sein. Wurde die Minimallänge-Eigenschaft nicht festgelegt, muss die Eigenschaft Minimallänge mit Auffüllzeichen größer als oder gleich 1 sein.
Benutzerdefinierte Maximallänge Geben Sie eine Zahl ein, die die maximal zulässige Anzahl an Zeichen für dieses Feld darstellt, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Mit dieser Eigenschaft können Sie Punkte, Bindestriche usw. im Feld für Zahlen verwenden.

  • Diese Eigenschaft wird nur angezeigt, wenn Benutzerdefinierter Datentyp auf Number (N), Number (Nx) oder Number (R) festgelegt wurde, wobei x einer Zahl zwischen 1 und 9 entspricht.

  • Der Wert für Benutzerdefinierte Maximallänge muss größer als x (wobei x einer Zahl zwischen 1 und 9 in Nx entspricht) für eine EDI-Instanz sein. Wurde Benutzerdefinierter Datentyp beispielsweise auf N2 festgelegt, muss für Benutzerdefinierte Maximallänge mindestens der Wert 3 festgelegt werden. Dies ist erforderlich, weil der Parser die Dezimalstelle während der Analyse einfügt und die Serialisierungskomponente sie entfernt und zudem die Anzahl der Stellen rechts vom Dezimalzeichen überprüft.

Standard: Benutzerdefiniert
Struktur-Eigenschaft: Getrennt

Wichtig

  • Die Werte für Zeichen für Zeilenumbruch, Auffüllzeichen, Escapewert und Trennzeichenwert für einen Datensatz sowie die ihm untergeordneten Felder schließen sich gegenseitig aus.

  • Sie sollten auf jeden Fall sicherstellen, dass das Umbruchzeichen und das Escapezeichen nicht identisch sind.

Registerkarte "Analysieren": Stammknoten- oder Datensatzeigenschaften

Eigenschaft | Wert
Struktur Wählen Sie die folgende Option für die Stammknoten-Eigenschaft aus:
  • Getrennt. Gibt an, dass der Stammknoten auf einer Dateistruktur mit Trennzeichen basiert. Individuelle Datensätze können auf Dateistrukturen mit Trennzeichen oder mit Feldern fester Breite basieren.

Wählen Sie eine der folgenden Optionen für Datensatz-Eigenschaften aus:

  • Getrennt. Gibt an, dass der Datensatz auf einer Dateistruktur mit Trennzeichen basiert. Einzelne abhängige Datensätze können auf Dateistrukturen mit Trennzeichen oder mit Feldern fester Breite basieren.

  • Feste Breite. Gibt an, dass der Datensatz auf einer Struktur mit Feldern fester Breite basiert. Datensätze mit Feldern fester Breite können keine untergeordneten Datensätze haben.

Anmerkungen

  • Damit ein Dokument sowohl Trennzeichen als auch Felder fester Breite enthalten kann, muss die Struktur-Eigenschaft des Stammknotens auf Getrennt festgelegt werden. Anschließend kann die Struktur-Eigenschaft für einzelne Datensätze je nach Bedarf auf Feste Breite oder Getrennt festgelegt werden.

  • Enthält Ihre Spezifikation Felder fester Breite, ist es nicht empfehlenswert, auf der Registerkarte Deklaration für Felder den Wert Typ auf Element festzulegen. Dies könnte dazu führen, dass die Überprüfung fehlschlägt.

  • Beim Wechseln von einer Struktur zu einer anderen wird ein Meldungsfeld angezeigt. Klicken Sie auf Ja, um die neue Struktur zu bestätigen. Unter Umständen werden einige neue Eigenschaften angezeigt, während bestimmte vorhandene Eigenschaften entfernt werden.

  • Wenn Sie mit der rechten Maustaste auf das Feld mit dem Wert für die Struktur-Eigenschaft eines Datensatzes mit Feldern fester Breite und dann auf Eigenschaft löschen klicken, interpretiert der BizTalk-Editor die Struktur des Datensatzes als Datensatz mit Trennzeichen. Unter Umständen werden einige neue Eigenschaften angezeigt, während bestimmte vorhandene Eigenschaften entfernt werden.

  • Wurde für die Standard-Eigenschaft eines neuen Dokuments der Wert BENUTZERDEFINIERT festgelegt, ist die Struktur-Eigenschaft für den Stammknoten und alle Datensätze standardmäßig leer. Wenn Sie die Struktur-Eigenschaft leer lassen, lautet der Wert Getrennt.
Quelltagbezeichner Der Name des Quelltagbezeichners. Dieser Tagname wird verwendet, um dem Datensatz Daten zuzuordnen.

Wichtig

  • Wenn es sich um einen Schleifendatensatz handelt und die Instanzdaten keine Schleifenstruktur enthalten (d. h., die Struktur ist nicht explizit, sondern implizit), sollten Sie für Quelltagbezeichner keinen Wert eingeben.

Anmerkungen

  • Für eine nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um jedes beliebige Tag in der Originaldatei zu identifizieren. Ein Quelltagbezeichner darf keines der folgenden Zeichen enthalten: < > " &

  • Bei der Quelltagbezeichner-Eigenschaft muss die Groß-/Kleinschreibung beachtet werden.
Feldreihenfolge Wählen Sie eine der folgenden Optionen aus:
  • Präfix. Ein Präfixtrennzeichen wird vor jeder Komponente und jedem Mitglied einer Komponente in einer Serie angezeigt. Wenn beispielsweise ein Sternchen (*) das Trennzeichen ist, wird Folgendes angezeigt: *a*a*b*c.

  • Postfix. Ein Postfixtrennzeichen wird nach jeder Komponente und jedem Mitglied einer Komponente in einer Serie angezeigt. Wenn beispielsweise ein Sternchen (*) das Trennzeichen ist, wird Folgendes angezeigt: a*a*b*c*.

  • Infix. Ein Infixtrennzeichen wird zwischen Komponenten und Mitgliedern von Komponenten in einer Serie angezeigt. Wenn beispielsweise ein Sternchen (*) das Trennzeichen ist, wird Folgendes angezeigt: a*a*b*c.

Anmerkungen

  • Für nicht auf XML basierende Dateien sollte Feldreihenfolge für den Stammknoten auf Postfix und für Schleifendatensatzknoten auf Infix festgelegt werden. Anwendungsbeispiele finden Sie in den Ordnern Flat-FileDelimited und Flat-FilePositional unter \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\.

  • Wird für die Feldreihenfolge kein Wert angegeben, lautet der Standardwert Präfix.
Trennzeichentyp Wählen Sie eine der folgenden Optionen aus, um ein Trennzeichen für die untergeordneten Knoten direkt unterhalb des aktuellen Knotens festzulegen:
  • Zeichen. Ermöglicht das Festlegen eines Trennzeichenwertes auf der Registerkarte Analysieren. Wenn Sie Zeichen auswählen, müssen Sie einen Trennzeichenwert angeben.

  • Standard-Datensatztrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standard-Datensatztrennzeichen-Eigenschaft auf der Registerkarte Verweis für den Stammknoten verwendet werden soll.

  • Standardfeldtrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standardfeldtrennzeichen-Eigenschaft auf der Registerkarte Verweis für den Stammknoten verwendet werden soll.

  • Standardunterfeldtrennzeichen. Gibt an, dass als Trennzeichen der Wert für die Standardunterfeldtrennzeichen-Eigenschaft auf der Registerkarte Verweis für den Stammknoten verwendet werden soll.
Trennzeichenwert | Geben Sie einen Zeichenwert für das Trennzeichen ein, oder wählen Sie einen aus. Sie müssen auf der Registerkarte Analysieren für die Trennzeichentyp-Eigenschaft den Wert Zeichen festlegen, um einen Trennzeichenwert angeben zu können.
Escapetyp

(Wird auch als Freigabezeichen bezeichnet.)

 Wählen Sie eine der folgenden Optionen aus, um ein Escapezeichen für die untergeordneten Knoten direkt unterhalb des aktuellen Knotens festzulegen:
  • Zeichen. Ermöglicht das Festlegen eines Escapewertes auf der Registerkarte Analysieren. Wenn Sie Zeichen auswählen, müssen Sie einen Escapewert angeben.

  • Standardescapezeichen. Gibt an, dass als Escapezeichen der Wert für die Standardescapezeichen-Eigenschaft auf der Registerkarte Verweis für den Stammknoten verwendet werden soll.

Ein Escapezeichen ist nützlich, wenn die Felddaten ein Zeichen enthalten, das als Trennzeichen für den übergeordneten Knoten des Feldes verwendet wird. Wenn die Felddaten folgendermaßen lauten und Sie ein Komma als Trennzeichenwert für den Knoten, der das Feld enthält, ausgewählt haben, interpretiert der BizTalk-Editor das Komma nach "Braun" als Trennzeichen, auch wenn es sich dabei um einen Teil der Felddaten handelt.

Braun,Robert,1231,ja

Sie können dieses Problem umgehen, indem Sie direkt vor das Trennzeichen, das Teil der Felddaten sein soll, ein Escapezeichen setzen. Wenn Sie beispielsweise den umgekehrten Schrägstrich als Escapezeichen angeben, können Sie diesen direkt vor ein Trennzeichen setzen, wie im folgenden Beispiel dargestellt:

Braun\,Robert,1231,ja

Der BizTalk-Editor interpretiert das Komma nach dem umgekehrten Schrägstrich als Teil der Felddaten und nicht als Trennzeichen.
Escapewert | Geben Sie einen Zeichenwert für das Escapezeichen ein, oder wählen Sie einen aus. Sie müssen auf der Registerkarte Analysieren für die Escapetyp-Eigenschaft den Wert Zeichen festlegen, um einen Escapezeichenwert angeben zu können.
Neue Zeile anfügen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Gibt an, dass die Serialisierungskomponente beim Erreichen des Datensatztrennzeichens automatisch eine neue Zeile anfügt (LF,0x0A).

  • Nein. Gibt an, dass die Serialisierungskomponente beim Erreichen des Datensatztrennzeichens im nächsten Datensatz mit derselben Zeile fortfährt.

Anmerkung

  • Wird für Neue Zeile anfügen kein Wert angegeben, lautet der Standardwert Nein.
Wagenrücklauf überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Wagenrücklauf überspringen kein Wert angegeben, lautet der Standardwert Ja.
Zeilenvorschub überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Zeilenvorschub überspringen kein Wert angegeben, lautet der Standardwert Ja.
Datensatzanzahl ignorieren Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation nicht berücksichtigt werden soll.

  • Nein. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation berücksichtigt werden soll.

Anmerkungen

  • Stimmt die Anzahl der Datensätze in einer an BizTalk Server gesendeten Dokumentinstanz nicht mit der berechneten Anzahl der Datensätze in der Spezifikation überein, tritt ein Analysefehler auf. Weitere Informationen finden Sie unter Analysefehler.

  • Wird für Datensatzanzahl ignorieren kein Wert angegeben, lautet der Standardwert Ja.

Registerkarte "Analysieren": Feldeigenschaften

Eigenschaft | Wert
Benutzerdefinierter Datentyp Wählen Sie eine der folgenden Optionen aus:
  • String (AN). AN steht für alphanumerische Felder.

  • Binary Hexadecimal (B). B steht für binäre Felder.

  • Date (CY). CY steht für vierstellige Datumsfelder.

  • Number (D0-D4). D0 bis D4 (einschließlich) stehen für Dezimalfelder. Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Date (DT). DT steht für Datumsfelder.

  • String (ID). ID steht für Identifikationsfelder.

  • Number (N). N steht für Felder mit ganzen Zahlen.

  • Number (N1-9). N1 bis N9 (einschließlich) stehen für implizite Dezimalfelder (das Dezimaltrennzeichen wird in den Daten nicht angezeigt). Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

    Anmerkungen

    • Wird eine Spezifikation aus einem impliziten Dezimalformat bzw. in ein implizites Dezimalformat umgewandelt, muss sichergestellt werden, das der Wert für die Eigenschaft Benutzerdefinierte maximale Länge die sich daraus ergebende analysierte oder serialisierte Ausgabe verarbeiten kann. Wurde Benutzerdefinierter Datentyp beispielsweise auf N2 festgelegt, muss für Benutzerdefinierte Maximallänge mindestens der Wert 3 festgelegt werden. Dies ist erforderlich, weil der Parser die Dezimalstelle während der Analyse einfügt und die Serialisierungskomponente sie entfernt und zudem die Anzahl der Stellen rechts vom Dezimalzeichen überprüft.

    • Wenn Sie auf der Registerkarte Verweis den Wert für die Standard-Eigenschaft von X12 in BENUTZERDEFINIERT ändern (z. B. für Flatfiles) und dann Number (N) bzw. Number (Nx) auswählen, wobei x für eine Zahl zwischen 1 und 9 steht, wird die Eigenschaft Benutzerdefinierte maximale Länge nicht angezeigt. Daher müssen Sie den Wert für Maximallänge auf der Registerkarte Deklaration erhöhen, um die analysierte oder serialisierte Ausgabe berücksichtigen zu können, die sich durch die Umwandlung einer Spezifikation aus einem impliziten Dezimalformat bzw. in ein implizites Dezimalformat ergibt.
  • Number (R). R steht für Felder mit reellen Zahlen.

  • Time (TM). TM steht für Zeitfelder.

Wichtig

  • Wenn Sie für Benutzerdefinierter Datentyp einen Wert festlegen, wird der Wert für Datentyp auf der Registerkarte Deklaration automatisch geändert, so dass er mit der Auswahl für Benutzerdefinierter Datentyp übereinstimmt. Wenn Sie beispielsweise den Wert für Benutzerdefinierter Datentyp auf der Registerkarte Analysieren in Date (CY) ändern, wird der Wert für Datentyp auf der Registerkarte Deklaration automatisch in Date geändert.

Anmerkung

  • Wurde für die Eigenschaft Benutzerdefinierter Datentyp der Wert Date (DT), Date (CY) oder Time (TM) angegeben, muss für die Eigenschaft Benutzerdefiniertes Datum/Zeitformat ebenfalls ein Wert festgelegt werden.
Benutzerdefiniertes Datum/Zeitformat Wurde für die Eigenschaft Benutzerdefinierter Datentyp der Wert Date (DT), Date (CY) oder Time (TM) festgelegt, klicken Sie auf eine Option in der Liste. Weitere Informationen finden Sie unter Anwenden der Eigenschaft "Benutzerdefiniertes Datum/Zeitformat". Weitere Informationen zu unterstützten Zeitformaten finden Sie unter Unterstütztes Zeitformat für X12.

Anmerkung

  • Dieses Eigenschaftenfeld steht nur zur Verfügung, wenn Date (DT), Date (CY) oder Time (TM) für Benutzerdefinierter Datentyp festgelegt wurde.
Blocksatz Wählen Sie eine der folgenden Optionen aus:
  • Nach links. Richtet Daten in Dateien mit Feldern fester Breite am linken Rand aus, wenn die Daten die maximale Feldlänge unterschreiten. Außerdem werden Daten in Dateien mit Trennzeichen am linken Rand ausgerichtet, wenn die Datenmenge die minimalen Längenanforderungen nicht erfüllt.

  • Nach rechts. Richtet Daten in Flatfiles mit Feldern fester Breite am rechten Rand aus, wenn die Daten die maximale Feldlänge unterschreiten. Außerdem werden Daten in Flatfiles mit Trennzeichen am linken Rand ausgerichtet, wenn die Datenmenge die minimalen Längenanforderungen nicht erfüllt.

Anmerkung

  • Wird für Blocksatz kein Wert angegeben, lautet der Standardwert Nach links.
Auffüllzeichen | Geben Sie ein Zeichen ein, um das Feld aufzufüllen, oder wählen Sie ein Zeichen aus. Als Auffüllzeichen können Sie jedes beliebige Zeichen verwenden, einschließlich eines Leerzeichens oder einer Null. Weitere Informationen finden Sie unter Auffüllzeichen.
Zeichen für Zeilenumbruch Geben Sie ein Zeichen ein, um Felddaten einzuschließen. Diese Eigenschaft ist nützlich, wenn die Felddaten ein Zeichen enthalten, das als Trennzeichenwert für den übergeordneten Knoten des Feldes verwendet wird. Wenn die Felddaten folgendermaßen lauten und Sie ein Komma als Trennzeichenwert für den Knoten, der das Feld enthält, ausgewählt haben, interpretiert der BizTalk-Editor das Komma nach "Braun" als Trennzeichen, auch wenn es sich dabei um einen Teil der Felddaten handelt.

Braun,Robert,1231,ja

Sie können dieses Problem umgehen, indem Sie für die Eigenschaft Zeichen für Zeilenumbruch einen Wert festlegen und dann die Felddaten in das Umbruchzeichen einschließen. Beispielsweise können Sie als Umbruchzeichen für das erste Feld doppelte Anführungszeichen festlegen und anschließend die Felddaten folgendermaßen eingeben:

"Braun,Robert",1231,ja

Das Komma zwischen den doppelten Anführungszeichen wird vom BizTalk-Editor als Teil der Felddaten und nicht als Trennzeichenwert interpretiert.

Anmerkungen

  • Enthalten die Felddaten Zeichen, die auch als Umbruchzeichen verwendet werden, müssen Sie diese Zeichen in ein weiteres Umbruchzeichen einschließen.

    Im folgenden Beispiel wurde das doppelte Anführungszeichen als Umbruchzeichen verwendet:

    "Braun,Robert ""Berti"""

    Der BizTalk-Editor analysiert dies als:

    Braun,Robert "Berti"

  • Enthalten die Felddaten in einer eingehenden Dokumentinstanz das Zeilenvorschubzeichen, auf das direkt das Wagenrücklaufzeichen folgt, schließen die entsprechenden Felddaten in der ausgehenden Dokumentinstanz nur das Zeilenvorschubzeichen ein, selbst wenn beide Zeichen von Umbruchzeichen eingeschlossen werden.
Minimallänge mit Auffüllzeichen Die minimale Länge eines Feldes in einer ausgehenden Dokumentinstanz, einschließlich Auffüllzeichen. Weitere Informationen finden Sie unter Auffüllzeichen.

Anmerkungen

  • Diese Eigenschaft kann für ein Feld nur festgelegt werden, wenn das Auffüllzeichen für dieses Feld festgelegt wurde.

  • Wurde die Minimallänge-Eigenschaft auf der Registerkarte Deklaration für das Feld festgelegt, muss die Eigenschaft Minimallänge mit Auffüllzeichen größer als oder gleich dem Wert der Minimallänge-Eigenschaft sein. Wurde die Minimallänge-Eigenschaft nicht festgelegt, muss die Eigenschaft Minimallänge mit Auffüllzeichen größer als oder gleich 1 sein.

Standard: BENUTZERDEFINIERT
Struktur-Eigenschaft: Feste Breite

Registerkarte "Analysieren": Stammknoten- oder Datensatzeigenschaften

Eigenschaft | Wert
Struktur Wählen Sie die folgende Option für die Stammknoten-Eigenschaft aus:
  • Feste Breite. Gibt an, dass der Stammknoten auf einer Struktur für Flatfiles mit Feldern fester Breite basiert.

Wichtig

  • Die empfohlene höchste Begrenzung für ein Feld ist 1 MB (Megabyte). Sie können diese Begrenzung zwar überschreiten, aber dies würde sich negativ auf die Leistung von BizTalk Server auswirken.

Anmerkungen

  • Enthält Ihre Spezifikation Felder fester Breite, ist es nicht empfehlenswert, auf der Registerkarte Deklaration für Felder den Wert Typ auf Element festzulegen. Dies könnte dazu führen, dass die Überprüfung fehlschlägt.

  • Ein Dokument mit einem Stammknoten mit Feldern fester Breite kann keine Datensätze haben.

  • Wenn Sie mit der rechten Maustaste auf das Feld mit dem Wert für die Struktur-Eigenschaft eines Stammknotens mit Feldern fester Breite und dann auf Eigenschaft löschen klicken, interpretiert der BizTalk-Editor die Struktur des Stammknotens als Stammknoten mit Trennzeichen. Unter Umständen werden einige neue Eigenschaften angezeigt, während bestimmte vorhandene Eigenschaften entfernt werden.

  • Wurde für die Standard-Eigenschaft eines neuen Dokuments der Wert BENUTZERDEFINIERT festgelegt, ist die Struktur-Eigenschaft für den Stammknoten und alle Datensätze standardmäßig leer. Wenn Sie die Struktur-Eigenschaft leer lassen, lautet der Wert Getrennt.
Quelltagbezeichner Der Name des Quelltagbezeichners. Dieser Tagname wird verwendet, um dem Datensatz Daten zuzuordnen.

Wichtig

  • Wenn es sich um einen Schleifendatensatz handelt und die Instanzdaten keine Schleifenstruktur enthalten (d. h., die Struktur ist nicht explizit, sondern implizit), sollten Sie für Quelltagbezeichner keinen Wert eingeben.

Anmerkungen

  • Für eine nicht auf XML basierende Datei, z. B. eine Flatfile, können Sie eine Quelltagbezeichner-Eigenschaft eingeben, um jedes beliebige Tag in der Originaldatei zu identifizieren. Ein Quelltagbezeichner darf keines der folgenden Zeichen enthalten: < > " &

  • Bei der Quelltagbezeichner-Eigenschaft muss die Groß-/Kleinschreibung beachtet werden.
Quelltagposition | Eine Zahl, die auf die Anfangsposition des Tags im Datensatz mit Feldern fester Breite verweist.
Neue Zeile anfügen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Gibt an, dass die Serialisierungskomponente beim Erreichen des Datensatztrennzeichens automatisch eine neue Zeile anfügt (LF,0x0A).

  • Nein. Gibt an, dass die Serialisierungskomponente beim Erreichen des Datensatztrennzeichens im nächsten Datensatz mit derselben Zeile fortfährt.

Anmerkung

  • Wird für Neue Zeile anfügen kein Wert angegeben, lautet der Standardwert Nein.
Wagenrücklauf überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Wagenrücklauf nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Wagenrücklauf überspringen kein Wert angegeben, lautet der Standardwert Ja.
Zeilenvorschub überspringen Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen übersprungen werden soll.

  • Nein. Teilt dem Parser mit, dass der Zeilenvorschub nach einem Trennzeichen nicht übersprungen werden soll.

Anmerkung

  • Wird für Zeilenvorschub überspringen kein Wert angegeben, lautet der Standardwert Ja.
Datensatzanzahl ignorieren Wählen Sie eine der folgenden Optionen aus:
  • Ja. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation nicht berücksichtigt werden soll.

  • Nein. Teilt dem Parser oder der Serialisierungskomponente mit, dass dieser Datensatz beim Zählen der Datensätze in der Spezifikation berücksichtigt werden soll.

Anmerkungen

  • Stimmt die Anzahl der Datensätze in einer an BizTalk Server gesendeten Dokumentinstanz nicht mit der berechneten Anzahl der Datensätze in der Spezifikation überein, tritt ein Analysefehler auf. Weitere Informationen finden Sie unter Analysefehler.

  • Wird für Datensatzanzahl ignorieren kein Wert angegeben, lautet der Standardwert Ja.

Registerkarte "Analysieren": Feldeigenschaften

Eigenschaft | Wert
Benutzerdefinierter Datentyp Wählen Sie eine der folgenden Optionen aus:
  • String (AN). AN steht für alphanumerische Felder.

  • Binary Hexadecimal (B). B steht für binäre Felder.

  • Date (CY). CY steht für vierstellige Datumsfelder.

  • Number (D0-D4). D0 bis D4 (einschließlich) stehen für Dezimalfelder. Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

  • Date (DT). DT steht für Datumsfelder.

  • String (ID). ID steht für Identifikationsfelder.

  • Number (N). N steht für Felder mit ganzen Zahlen.

  • Number (N1-9). N1 bis N9 (einschließlich) stehen für implizite Dezimalfelder (das Dezimaltrennzeichen wird in den Daten nicht angezeigt). Die einstellige Zahl zeigt die Anzahl der Stellen nach dem Dezimaltrennzeichen an.

    Anmerkungen

    • Wird eine Spezifikation aus einem impliziten Dezimalformat bzw. in ein implizites Dezimalformat umgewandelt, muss sichergestellt werden, das der Wert für die Eigenschaft Benutzerdefinierte maximale Länge die sich daraus ergebende analysierte oder serialisierte Ausgabe verarbeiten kann. Wurde Benutzerdefinierter Datentyp beispielsweise auf N2 festgelegt, muss für Benutzerdefinierte Maximallänge mindestens der Wert 3 festgelegt werden. Dies ist erforderlich, weil der Parser die Dezimalstelle während der Analyse einfügt und die Serialisierungskomponente sie entfernt und zudem die Anzahl der Stellen rechts vom Dezimalzeichen überprüft.

    • Wenn Sie auf der Registerkarte Verweis den Wert für die Standard-Eigenschaft von X12 in BENUTZERDEFINIERT ändern (z. B. für Flatfiles) und dann Number (N) bzw. Number (Nx) auswählen, wobei x für eine Zahl zwischen 1 und 9 steht, wird die Eigenschaft Benutzerdefinierte maximale Länge nicht angezeigt. Daher müssen Sie den Wert für Maximallänge auf der Registerkarte Deklaration erhöhen, um die analysierte oder serialisierte Ausgabe berücksichtigen zu können, die sich durch die Umwandlung einer Spezifikation aus einem impliziten Dezimalformat bzw. in ein implizites Dezimalformat ergibt.
  • Number (R). R steht für Felder mit reellen Zahlen.

  • Time (TM). TM steht für Zeitfelder.

Wichtig

  • Wenn Sie für Benutzerdefinierter Datentyp einen Wert festlegen, wird der Wert für Datentyp auf der Registerkarte Deklaration automatisch geändert, so dass er mit der Auswahl für Benutzerdefinierter Datentyp übereinstimmt. Wenn Sie beispielsweise den Wert für Benutzerdefinierter Datentyp auf der Registerkarte Analysieren in Date (CY) ändern, wird der Wert für Datentyp auf der Registerkarte Deklaration automatisch in Date geändert. Bei Angabe eines Wertes für Datentyp auf der Registerkarte Deklaration wird der Wert für Benutzerdefinierter Datentyp gelöscht.

Anmerkung

  • Wurde für die Eigenschaft Benutzerdefinierter Datentyp der Wert Date (DT), Date (CY) oder Time (TM) angegeben, muss für die Eigenschaft Benutzerdefiniertes Datum/Zeitformat ebenfalls ein Wert festgelegt werden.
Benutzerdefiniertes Datum/Zeitformat Wurde für die Eigenschaft Benutzerdefinierter Datentyp der Wert Date (DT), Date (CY) oder Time (TM) festgelegt, klicken Sie auf eine Option in der Liste. Weitere Informationen finden Sie unter Anwenden der Eigenschaft "Benutzerdefiniertes Datum/Zeitformat". Weitere Informationen zu unterstützten Zeitformaten finden Sie unter Unterstütztes Zeitformat für X12.

Anmerkung

  • Dieses Eigenschaftenfeld ist nur aktiv, wenn Date (DT), Date (CY) oder Time (TM) für Benutzerdefinierter Datentyp festgelegt wurde.
Blocksatz Wählen Sie eine der folgenden Optionen aus:
  • Nach links. Richtet Daten in Flatfiles mit Feldern fester Breite am linken Rand aus, wenn die Daten die maximale Feldlänge unterschreiten. Außerdem werden Daten in Flatfiles mit Trennzeichen am linken Rand ausgerichtet, wenn die Datenmenge die minimalen Längenanforderungen nicht erfüllt.

  • Nach rechts. Richtet Daten in Flatfiles mit Feldern fester Breite am rechten Rand aus, wenn die Daten die maximale Feldlänge unterschreiten. Außerdem werden Daten in Flatfiles mit Trennzeichen am linken Rand ausgerichtet, wenn die Datenmenge die minimalen Längenanforderungen nicht erfüllt.

Anmerkung

  • Wird für Blocksatz kein Wert angegeben, lautet der Standardwert Nach links.
Auffüllzeichen | Geben Sie ein Zeichen ein, das zum Auffüllen des Feldes verwendet werden soll. Als Auffüllzeichen können Sie jedes beliebige Zeichen verwenden, einschließlich eines Leerzeichens oder einer Null. Weitere Informationen finden Sie unter Auffüllzeichen.

Verwandte Themen

Zeichenlängenbeschränkungen

Auffüllzeichen


Anwenden der Eigenschaft "Benutzerdefiniertes Datum/Zeitformat"

Mit dem Datentyp Benutzerdefiniertes Datum/Zeitformat können Sie Informationen zu Datum und Uhrzeit im folgenden Format senden: HHMMSSDD. Weitere Informationen zur diesem Zeitformat finden Sie im vorherigen Abschnitt unter "Unterstütztes Zeitformat für X12".

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie die Eigenschaft Benutzerdefiniertes Datum/Zeitformat festlegen möchten, und klicken Sie dann auf die Registerkarte Analysieren.

  2. Doppelklicken Sie auf die Wert-Spalte neben Benutzerdefinierter Datentyp.

  3. Klicken Sie in der Liste der Optionen auf Time (TM), und drücken Sie die EINGABETASTE.

    Eine Warnmeldung wird angezeigt.

  4. Klicken Sie auf Ja.

  5. Doppelklicken Sie auf die Wert-Spalte neben Benutzerdefiniertes Datum/Zeitformat.

  6. Klicken Sie in der Liste mit den Werten auf HHMMSSDD, und drücken Sie die EINGABETASTE.

    Der neue benutzerdefinierte Datentyp Datum/Uhrzeit wird übernommen.

Wichtig

  • Wenn Sie die Zeit in Zehnteln oder Hundertsteln einer Sekunde angeben möchten, verwenden Sie den hier beschriebenen benutzerdefinierten Datentyp Datum/Uhrzeit.

Anmerkungen

  • Wenn Sie das benutzerdefinierte Datum/Zeitformat in HHMMSSDD ändern, wird der Datentyp für die benutzerdefinierte Eigenschaft Datum/Uhrzeit auf der Registerkarte Analysieren in String geändert.

  • Wenn Sie den benutzerdefinierten Datentyp Datum/Uhrzeit verwenden, können Sie die Uhrzeit in einem der folgenden Formate senden:
    • HHMM

    • HHMMSS

    • HHMMSSD

    • HHMMSSDD

    Der X12-Parser und die Serialisierungskomponente lesen den benutzerdefinierten Datentyp Datum/Uhrzeit von links nach rechts und geben keinen Fehler zurück, wenn das gesendete Datums- und Uhrzeitformat weniger als acht Zeichen umfasst. Die folgenden Datums- und Uhrzeitdaten sind beispielsweise gültig:

    • 2211

    • 221101
  • Wenn Sie den benutzerdefinierten Datentyp Datum/Uhrzeit verwenden, muss der Inhalt der Uhrzeitdaten immer mit einer geraden Anzahl an Ziffern gesendet und empfangen werden. Eine Ausnahme bilden hierbei Uhrzeitdaten, die in Zehntelsekunden ausgedrückt werden. 2211 ist beispielsweise ein gültiges Schema für Uhrzeitdaten, 22115 jedoch nicht.

  • Der benutzerdefinierte Datentyp Datum/Uhrzeit ist nur verfügbar, wenn der Standard, auf dem das Schema basiert, X12 lautet.

Verwandtes Thema

Unterstütztes Zeitformat für X12


Deklarieren von Namespaces

  1. Klicken Sie auf einen beliebigen Knoten in der Spezifikationsstruktur.

  2. Klicken Sie auf die Registerkarte Namespace.

  3. Klicken Sie mit der rechten Maustaste auf das erste leere Feld in der Präfix-Spalte, und klicken Sie dann auf Hinzufügen.

  4. Geben Sie ein Präfix für den Namespace ein, und drücken Sie die EINGABETASTE.

  5. Doppelklicken Sie rechts daneben auf das Feld in der Uniform Resource Name-Spalte.

  6. Geben Sie einen URN (Uniform Resource Name) ein, und drücken Sie die EINGABETASTE.

Wichtig

  • Der BizTalk-Editor überprüft nicht den URN, den Sie für einen Namespace eingeben.

  • Geben Sie keinen Namespace-URN an, der mit x-schema: beginnt. Wenn Ihre Spezifikation x-schema enthält, können Schemaverweise vom Laufzeitmodul nicht aufgelöst werden.

Weitere Informationen zu Namespaces finden Sie unter Namespacedeklarationen.

Verwandte Themen

Hinzufügen von benutzerdefinierten Anmerkungen

Zeichenlängenbeschränkungen

Löschen von benutzerdefinierten Anmerkungen

Bearbeiten von benutzerdefinierten Anmerkungen

Namespacedeklarationen


Hinzufügen von benutzerdefinierten Anmerkungen

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine benutzerdefinierte Anmerkung hinzufügen möchten.

    Anmerkung

    • Auf der Registerkarte Verweis können Sie keine benutzerdefinierte Anmerkung für den Stammknoten hinzufügen.
  2. Klicken Sie auf die Registerkarte Deklaration oder Verweis, je nachdem, wo Sie die benutzerdefinierte Anmerkung hinzufügen möchten.

  3. Klicken Sie mit der rechten Maustaste auf das erste leere Feld in der Eigenschaft-Spalte, und klicken Sie dann auf Hinzufügen.

    Der Bearbeitungsmodus wird für die Eigenschaft-Spalte aktiviert.

  4. Geben Sie ein präfix:name-Paar ein (z. B. bts:spezifikation, wobei bts das Präfix ist und spezifikation der Name). Sie müssen das Präfix und den Namen durch einen Doppelpunkt voneinander trennen, und drücken Sie dann die EINGABETASTE.

    Oder

    Klicken Sie auf eine der benutzerdefinierten Anmerkungen in der Liste, und drücken Sie die EINGABETASTE.

  5. Doppelklicken Sie rechts daneben auf das leere Feld in der Wert-Spalte.

  6. Geben Sie den Wert für die benutzerdefinierte Anmerkung ein, und drücken Sie die EINGABETASTE.

Wichtig

  • Damit die Spezifikation erfolgreich kompiliert werden kann, muss das in Schritt 4 verwendete Namespacepräfix in der Spezifikation deklariert werden. Weitere Informationen finden Sie unter Deklarieren von Namespaces.

Verwandte Themen

Hinzufügen von SQL-Anmerkungen

Deklarieren von Namespaces

Löschen von benutzerdefinierten Anmerkungen

Bearbeiten von benutzerdefinierten Anmerkungen

Namespacedeklarationen


Bearbeiten von benutzerdefinierten Anmerkungen

  1. Klicken Sie in der Spezifikationsstruktur auf den Knoten, der die benutzerdefinierte Anmerkung enthält, die Sie bearbeiten möchten.

  2. Klicken Sie auf die Registerkarte (Deklaration oder Verweis), die auf die benutzerdefinierte Anmerkung verweist, die Sie bearbeiten möchten.

  3. Doppelklicken Sie auf das Feld Eigenschaft der benutzerdefinierten Anmerkung, bearbeiten Sie das Feld, und drücken Sie dann die EINGABETASTE.

  4. Doppelklicken Sie auf das Feld Wert der benutzerdefinierten Anmerkung, bearbeiten Sie das Feld, und drücken Sie die EINGABETASTE.

Verwandte Themen

Hinzufügen von SQL-Anmerkungen

Deklarieren von Namespaces

Namespacedeklarationen


Löschen von benutzerdefinierten Anmerkungen

  1. Klicken Sie in der Spezifikationsstruktur auf den Knoten, der die benutzerdefinierte Anmerkung enthält, die Sie löschen möchten.

  2. Klicken Sie auf die Registerkarte (Deklaration oder Verweis), die auf die benutzerdefinierte Anmerkung verweist, die Sie löschen möchten.

  3. Klicken Sie mit der rechten Maustaste auf die benutzerdefinierte Anmerkung, und klicken Sie dann auf Löschen.

  4. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Verwandte Themen

Hinzufügen von benutzerdefinierten Anmerkungen

Hinzufügen von SQL-Anmerkungen

Deklarieren von Namespaces

Bearbeiten von benutzerdefinierten Anmerkungen

Namespacedeklarationen


Festlegen von Wörterbucheigenschaften

  1. Klicken Sie in der Spezifikationsstruktur auf den Stammknoten, den Datensatz oder das Feld, für den bzw. das Sie eine Eigenschaft angeben möchten, und klicken Sie dann auf die Registerkarte Wörterbuch.

  2. Aktivieren Sie in der Eigenschaft-Spalte das Kontrollkästchen für den Wert, den Sie mit dem Feld verknüpfen möchten.

Die Registerkarte Wörterbuch enthält die Eigenschaften, die in den folgenden Tabellen beschrieben sind. Wörterbucheigenschaften können nur für Spezifikationen festgelegt werden, für die die Standard-Eigenschaft auf der Registerkarte Verweis auf XML oder BENUTZERDEFINIERT festgelegt wurde.

Registerkarte "Wörterbuch": Stammknoten- oder Datensatzeigenschaften

Eigenschaft | Knotenpfad
Dokumentcontainerknoten | In einem Umschlagschema verweist der Dokumentknoten auf den Datensatz, der das Dokument enthält.

Anmerkung

  • Bei einer Flatfilespezifikation (bei der auf der Registerkarte Verweis die Standard-Eigenschaft auf den Wert BENUTZERDEFINIERT festgelegt ist), die mithilfe des Flatfileparsers von BizTalk Server analysiert wurde, hat das Aktivieren oder Deaktivieren des Kontrollkästchens für die Dokumentcontainerknoten-Wörterbucheigenschaft keine Auswirkungen. Diese Wörterbucheigenschaft steht zur Verfügung, falls Sie eine benutzerdefinierte Spezifikation und einen benutzerdefinierten Parser erstellen müssen, die die Dokumentcontainerknoten-Wörterbucheigenschaft verwenden.

Registerkarte "Wörterbuch": Feldeigenschaften

Eigenschaft | Knotenpfad
Dokumentname | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Dokumentnamen enthält.
Quelltyp | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Quelltyp enthält.
Quellwert | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Quellwert enthält.
Zieltyp | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Zieltyp enthält.
Zielwert | Zeigt den Pfad für das Feld einer Dokumentinstanz an, das den Zielwert enthält.

Anmerkungen

  • Beim Analysieren einer Spezifikation verwendet der Parser Informationen auf der Registerkarte Wörterbuch, um einen Kanal zu finden. Sie können einen Kanal mithilfe des BizTalk-Messaging-Managers erstellen. Weitere Informationen zu Kanälen und dem BizTalk-Messaging-Manager finden Sie unter Grundlegendes zu Kanälen.

  • Falls Sie eine Spezifikation verwenden, um Dokumente zu definieren, die an einen offenen Messagingport gesendet werden, müssen Sie auf der Registerkarte Wörterbuch den Zielwert für das Feld auswählen, das die Ziel- und Transportinformationen enthält. Bei Verwendung von Versendungsparametern werden die Zielinformationen in einem Dokument überschrieben. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

  • Sie können Wörterbucheigenschaften auch festlegen, indem Sie mit der rechten Maustaste auf ein Feld in der Eigenschaft-Spalte und dann auf Routinginformationen festlegen klicken.

Verwandte Themen

Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

Zeichenlängenbeschränkungen

Löschen einer Wörterbucheigenschaft

Löschen einer benutzerdefinierten Wörterbucheigenschaft

Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

Submitting

Grundlegendes zu Messagingports


Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

  1. Klicken Sie in der Spezifikationsstruktur auf das Feld, für das Sie eine benutzerdefinierte Wörterbucheigenschaft hinzufügen möchten.

  2. Klicken Sie auf die Registerkarte Wörterbuch.

  3. Doppelklicken Sie auf das erste leere Feld in der Eigenschaft-Spalte.

  4. Geben Sie einen Namen für die Eigenschaft ein, und drücken Sie die EINGABETASTE.

Anmerkungen

  • Verwenden Sie für jede benutzerdefinierte Eigenschaft, die Sie erstellen, einen eindeutigen Namen.

  • Die Standard-Eigenschaft (für den Stammknoten) darf nicht auf X12 oder EDIFACT festgelegt werden.

Verwandte Themen

Löschen einer Wörterbucheigenschaft

Löschen einer benutzerdefinierten Wörterbucheigenschaft

Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

Festlegen von Wörterbucheigenschaften


Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

  1. Klicken Sie auf die Registerkarte Wörterbuch.

  2. Klicken Sie mit der rechten Maustaste auf die benutzerdefinierte Eigenschaft, die Sie umbenennen möchten, und klicken Sie dann auf Umbenennen.

  3. Geben Sie einen Namen für die Eigenschaft ein, und drücken Sie die EINGABETASTE.

Anmerkung

  • Verwenden Sie für jede benutzerdefinierte Eigenschaft, die Sie erstellen, einen eindeutigen Namen.

Verwandte Themen

Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

Löschen einer Wörterbucheigenschaft

Löschen einer benutzerdefinierten Wörterbucheigenschaft

Festlegen von Wörterbucheigenschaften


Löschen einer Wörterbucheigenschaft

  1. Klicken Sie in der Spezifikationsstruktur auf den Knoten, für den Sie eine Wörterbucheigenschaft löschen möchten, und klicken Sie auf die Registerkarte Wörterbuch.

  2. Deaktivieren Sie in der Eigenschaft-Spalte das Kontrollkästchen für den Wert, dessen Verknüpfung mit dem Feld Sie aufheben möchten.

Anmerkungen

  • Sie können Werte für Wörterbucheigenschaften auch löschen, indem Sie mit der rechten Maustaste auf ein Feld in der Eigenschaft-Spalte und dann auf Routinginformationen löschen klicken.

  • Indem Sie eine Wörterbucheigenschaft in einem Knoten löschen, entfernen Sie die Routinginformationen.

Verwandte Themen

Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

Zeichenlängenbeschränkungen

Löschen einer benutzerdefinierten Wörterbucheigenschaft

Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

Festlegen von Deklarationseigenschaften


Löschen einer benutzerdefinierten Wörterbucheigenschaft

  1. Klicken Sie auf die Registerkarte Wörterbuch.

  2. Klicken Sie mit der rechten Maustaste auf die benutzerdefinierte Eigenschaft, die Sie löschen möchten, und klicken Sie dann auf Löschen.

  3. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Verwandte Themen

Hinzufügen einer benutzerdefinierten Wörterbucheigenschaft

Löschen einer Wörterbucheigenschaft

Umbenennen einer benutzerdefinierten Wörterbucheigenschaft

Festlegen von Wörterbucheigenschaften


Auswählen von Codes

  1. Klicken Sie auf ein Feld in einer Spezifikationsstruktur.

  2. Klicken Sie auf die Registerkarte Codeliste.

  3. Aktivieren Sie in der Wert-Spalte das Kontrollkästchen neben dem Code, den Sie verwenden möchten.

Anmerkungen

  • Codelisten stehen nur für Spezifikationen zur Verfügung, die auf X12 oder EDIFACT basieren. Allerdings sind nicht alle Felder in einer auf X12 oder EDIFACT basierenden Spezifikation mit Codes verknüpft. Auf der Registerkarte Codeliste wird eine vollständige Liste sämtlicher Codes für ein bestimmtes Feld angezeigt. Codes sind mit einem Feld verknüpft, wenn das Kontrollkästchen im Feld Wert neben dem Code aktiviert ist. Eine Beschreibung des Codes wird im Feld Beschreibung angezeigt.

  • Wenn Sie auf der Registerkarte Codeliste einen Code mit einem Feld verknüpfen, wird diese Verknüpfung auch auf der Registerkarte Deklaration angezeigt. Der Wert für Datentyp auf der Registerkarte Deklaration ist standardmäßig auf Enumeration festgelegt, und das Feld Datentypwerte zeigt die Codelistennummern an, die Sie auf der Registerkarte Codeliste ausgewählt haben. Wenn Sie den Wert für Datentyp auf der Registerkarte Deklaration löschen, sind auf der Registerkarte Codeliste keine Codes ausgewählt. Weitere Informationen finden Sie unter Löschen einer Eigenschaft für ein beliebiges Feld in der Spalte "Wert".

  • Aktivieren Sie das Kontrollkästchen neben einem Code, drücken Sie die UMSCHALTTASTE, und aktivieren Sie das Kontrollkästchen neben einem zweiten Code, um mehrere Codes auszuwählen. Alle Codes zwischen dem ersten und dem zweiten Code werden ausgewählt.

  • Vereinzelt werden doppelte Codewerte auf der Registerkarte Codeliste angezeigt. Abhängig von dem Dokumenttyp, mit dem der Codewert verknüpft ist, haben diese doppelten Codewerte unterschiedliche Beschreibungen. Bei der Überprüfung einer Dokumentinstanz muss immer nur ein Codewert ausgewählt werden. Es ist jedoch möglich, aus Versehen mehrere Codewerte auszuwählen. Die folgende Liste enthält einige Regeln zu doppelten Codelisten:
    • Bei Auswahl des obersten Codewertes in einem Satz doppelter Codewerte wird nur dieser Codewert ausgewählt.

    • Bei Auswahl eines Codewertes, der nicht der oberste Codewert in einem Satz doppelter Codewerte ist, wird dieser Codewert und gleichzeitig automatisch der oberste Codewert ausgewählt.

    • Der oberste Codewert in einem Satz doppelter Codewerte kann nicht gelöscht werden, während andere Codewerte in diesem Satz ausgewählt sind.

Verwandte Themen

Löschen einer Eigenschaft für ein beliebiges Feld in der Spalte "Wert"

Codes löschen

Codelistenwerte und Beschreibungen


Löschen von Codes

  1. Klicken Sie auf ein Feld in der Spezifikationsstruktur.

  2. Klicken Sie auf die Registerkarte Codeliste.

  3. Deaktivieren Sie in der Wert-Spalte das Kontrollkästchen neben dem Code, den Sie löschen möchten.

Anmerkungen

  • Codelisten stehen nur für Spezifikationen zur Verfügung, die auf X12 oder EDIFACT basieren. Allerdings sind nicht alle Felder in einer auf X12 oder EDIFACT basierenden Spezifikation mit Codes verknüpft. Auf der Registerkarte Codeliste wird eine vollständige Liste sämtlicher Codes für ein bestimmtes Feld angezeigt. Codes sind mit einem Feld verknüpft, wenn das Kontrollkästchen im Feld Wert neben dem Code aktiviert ist. Eine Beschreibung des Codes wird im Feld Beschreibung angezeigt.

  • Vereinzelt werden doppelte Codewerte auf der Registerkarte Codeliste angezeigt. Abhängig von dem Dokumenttyp, mit dem der Codewert verknüpft ist, haben diese doppelten Codewerte unterschiedliche Beschreibungen. Bei der Überprüfung einer Dokumentinstanz muss immer nur ein Codewert ausgewählt werden. Es ist jedoch möglich, aus Versehen mehrere Codewerte auszuwählen. Die folgende Liste enthält einige Regeln zu doppelten Codelisten:
    • Bei Auswahl des obersten Codewertes in einem Satz doppelter Codewerte wird nur dieser Codewert ausgewählt.

    • Bei Auswahl eines Codewertes, der nicht der oberste Codewert in einem Satz doppelter Codewerte ist, wird dieser Codewert und gleichzeitig automatisch der oberste Codewert ausgewählt.

    • Der oberste Codewert in einem Satz doppelter Codewerte kann nicht gelöscht werden, während andere Codewerte in diesem Satz ausgewählt sind.

Verwandte Themen

Codelistenwerte und Beschreibungen

Auswählen von Codes


Löschen einer Eigenschaft für ein beliebiges Feld in der Wert-Spalte

  1. Klicken Sie auf die Registerkarte mit der Eigenschaft, die Sie löschen möchten.

  2. Klicken Sie mit der rechten Maustaste auf das Feld in der Wert-Spalte, und klicken Sie auf Eigenschaft löschen.


Automatisches Berechnen von Feldpositionen

Wurde für Benutzerdefinierter Datentyp ein impliziter Dezimaldatentyp festgelegt, berechnen Sie die Feldpositionen manuell. Weitere Informationen finden Sie in den Abschnitten zu Anfangsposition und Endposition unter Festlegen von Verweiseigenschaften.

  1. Wählen Sie ein Feld in einem Datensatz mit Feldern fester Breite aus.

  2. Doppelklicken Sie auf das Feld Wert in der Zeile Datentyp.

  3. Klicken Sie in der Liste Datentyp auf einen Wert.

    Anmerkung

    • Sie müssen einen der folgenden Datentyp-Werte auswählen, um einen Wert für die Maximallänge-Eigenschaft festlegen zu können (Schritt 4 und 5): String, Number, Binary (base64) oder Binary (hex).
  4. Doppelklicken Sie auf das Feld Wert in der Zeile Maximallänge.

  5. Geben Sie im Feld Maximallänge einen Wert ein, und drücken Sie die EINGABETASTE.

  6. Wiederholen Sie die Schritte 1 bis 5 für jedes Feld im Datensatz.

  7. Klicken Sie mit der rechten Maustaste auf den Datensatz, und klicken Sie dann auf Feldpositionen berechnen.

    Die folgende Warnung wird angezeigt:

    Durch diese Aktion werden die Eigenschaften Anfangsposition und Endposition für die Felder im ausgewählten Datensatz geändert. Möchten Sie den Vorgang fortsetzen?

  8. Klicken Sie auf Ja.

    Die Anfangs- und Endpositionen der Felder im Datensatz werden berechnet. Weitere Informationen finden Sie unter Berechnen von Feldpositionen.


Bearbeiten von Notizen und Anzeigen von Syntaxregeln

Im Dialogfeld Knoteneigenschaften können Sie die folgenden Aufgaben durchführen:

  • Lesen und Bearbeiten von Notizen für Felder und Datensätze.

  • Lesen von Syntaxregeln für Datensätze.

Führen Sie die folgenden Schritte aus, um das Dialogfeld Knoteneigenschaften anzuzeigen:

  1. Klicken Sie in der Spezifikationsstruktur mit der rechten Maustaste auf einen Datensatz oder ein Feld, und klicken Sie auf Eigenschaften.

    Standardmäßig wird die Registerkarte Notizen angezeigt.

  2. Klicken Sie auf die Registerkarte Syntaxregeln, um Syntaxregeln für einen Datensatz anzuzeigen.

Anmerkung

  • Syntaxregeln werden nur auf Datensätze angewendet.

Weitere Informationen zur Verwendung dieses Dialogfeldes finden Sie in den folgenden Themen:

  • Eingeben von Datensatznotizen

  • Anzeigen von Syntaxregeln

  • Eingeben von Feldnotizen


Eingeben von Datensatznotizen

Weitere Informationen zum Öffnen des Dialogfeldes Knoteneigenschaften finden Sie unter Bearbeiten von Notizen und Anzeigen von Syntaxregeln.

Mithilfe von Notizen können Sie sämtliche Informationen aufzeichnen, die für den entsprechenden Datensatz relevant sind, z. B. den Zweck des Datensatzes oder den Grund für seine Erstellung.

  • Geben Sie den Text im Dialogfeld Knoteneigenschaften ein, und klicken Sie auf OK, um Notizen zu erstellen.

Anmerkungen

  • Zu dem Stammknoten können keine Notizen hinzugefügt werden.

  • Sie dürfen keine nicht druckbaren Zeichen (z. B. Kombinationen aus ALT und Nummerntasten) in Notizen eingeben. Wenn Sie beispielsweise ALT drücken und dann 75 eingeben, wird der Buchstabe K angezeigt.

Verwandte Themen

Eingeben von Feldnotizen

Anzeigen von Syntaxregeln


Anzeigen von Syntaxregeln

Weitere Informationen zum Öffnen des Dialogfeldes Knoteneigenschaften finden Sie unter Bearbeiten von Notizen und Anzeigen von Syntaxregeln.

Syntaxregeln enthalten Informationen zur Organisation der Spezifikationsstruktur. Sie werden nur für Spezifikationen festgelegt, die auf dem X12-Standard basieren.

  • Klicken Sie auf die Registerkarte Syntaxregeln, um Syntaxregeln für einen Datensatz anzuzeigen.

Anmerkung

  • Syntaxregeln werden nur auf Datensätze angewendet.

Verwandte Themen

Eingeben von Feldnotizen

Eingeben von Datensatznotizen


Eingeben von Feldnotizen

Weitere Informationen zum Öffnen des Dialogfeldes Knoteneigenschaften finden Sie unter Bearbeiten von Notizen und Anzeigen von Syntaxregeln.

Mithilfe von Notizen können Sie sämtliche Informationen aufzeichnen, die für das entsprechende Feld relevant sind, z. B. den Zweck des Feldes oder den Grund für seine Erstellung.

  • Geben Sie den Text im Dialogfeld Knoteneigenschaften ein, und klicken Sie auf OK, um Notizen zu erstellen.

Anmerkung

  • Sie dürfen keine nicht druckbaren Zeichen (z. B. Kombinationen aus ALT und Nummerntasten) in Notizen eingeben. Wenn Sie beispielsweise ALT drücken und dann 75 eingeben, wird der Buchstabe K angezeigt.

Verwandte Themen

Eingeben von Datensatznotizen

Anzeigen von Syntaxregeln


Verwalten von Dokumentinstanzen

Im BizTalk-Editor können Sie eine Dokumentinstanz auf der Basis einer Spezifikation erstellen oder anhand einer Spezifikation überprüfen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erstellen einer neuen Dokumentinstanz

  • Erstellen einer systemeigenen Instanz

  • Überprüfen einer neuen Dokumentinstanz


Erstellen einer neuen Dokumentinstanz

  1. Öffnen Sie die Spezifikation, auf der die Dokumentinstanz basieren soll.

  2. Klicken Sie im Menü Extras auf XML-Instanz erstellen.

    Das Dialogfeld Dokumentinstanz erstellen unter wird angezeigt.

  3. Suchen Sie nach dem Ordner, in dem Sie die Dokumentinstanz erstellen möchten.

  4. Geben Sie im Feld Dateiname einen Namen für die Dokumentinstanz ein, und klicken Sie auf Speichern.

    Die neue Dokumentinstanz wird auf der Registerkarte Ausgabe angezeigt.

Anmerkung

  • Das einzige Format, das für die Erstellung einer Dokumentinstanz zur Verfügung steht, ist Unicode.

Verwandtes Thema

Überprüfen einer neuen Dokumentinstanz


Erstellen einer systemeigenen Instanz

  1. Öffnen Sie eine Spezifikation.

  2. Klicken Sie im Menü Extras auf Systemeigene Instanz erstellen.

    Das Dialogfeld Systemeigene Dokumentinstanz erstellen als wird angezeigt.

  3. Suchen Sie nach dem Ordner, in dem Sie die systemeigene Instanz erstellen möchten.

  4. Geben Sie im Feld Dateiname einen Namen für die systemeigene Instanz ein, und klicken Sie auf Speichern.

    Das Dialogfeld Dokumenttrennzeichen wird angezeigt.

  5. Wählen Sie aus den folgenden Listen jeweils eine Option aus oder geben Sie ein Trennzeichen ein:
    • Datensatztrennzeichen

    • Feldtrennzeichen

    • Unterfeldtrennzeichen

    • Escapezeichen

    Wichtig

    • Wenn Sie eigene Trennzeichen angeben, sollten Sie Unicode-Zeichenwerte verwenden. Eine Liste gültiger Zeichen finden Sie auf der Seite Global Codepages der Microsoft Global Software Development-Website (www.microsoft.com/globaldev/reference/wincp.asp). Sie können ANSI-Zeichencodes verwenden, sofern diese - abgesehen von den zwei führenden Nullen - mit dem Unicode-Zeichencode übereinstimmen.

Wichtig

  • Sie können eine systemeigene Instanz zwar erstellen, aber eine spätere Instanzüberprüfung schlägt fehl, wenn Sie die Syntaxregeln nicht beachten.

  • Zeichenbereiche werden zunächst ignoriert. Sie können eine systemeigene Instanz daher zwar erstellen, auch wenn sie nicht den Zeichenbereichen entspricht. Wenn BizTalk Server die Transaktion jedoch zu analysieren versucht, tritt ein Fehler auf.

  • Das Feature Systemeigene Instanz erstellen erstellt nicht das benutzerdefinierte Format HHMMSSDD.

  • Eine systemeigene Instanz kann für eine Datei mit Feldern fester Breite möglicherweise nicht generiert werden, wenn eine der folgenden Bedingungen zutrifft:
    • Der Wert für Datentyp auf der Registerkarte Deklaration wurde nicht auf String, Number, Binary (base64) oder Binary (hex) festgelegt.

    • Für Maximallänge auf der Registerkarte Deklaration wurde kein Wert angegeben.


Überprüfen einer neuen Dokumentinstanz

  1. Öffnen Sie die Spezifikation, anhand derer Sie die Dokumentinstanz überprüfen möchten.

    Weitere Informationen finden Sie unter Öffnen von Spezifikationen.

  2. Klicken Sie im Menü Extras auf Instanz überprüfen.

    Das Dialogfeld Dokumentinstanz überprüfen wird angezeigt.

  3. Suchen Sie nach der zu überprüfenden Dokumentinstanz, und klicken Sie dann auf Öffnen.

  4. Wenn Sie eine Dokumentinstanz ohne Umschlag anhand einer Spezifikation überprüfen, die auf dem X12- oder dem EDIFACT-Standard basiert, wird das Dialogfeld Dokumenttrennzeichen angezeigt. Führen Sie einen der folgenden Schritte aus:
    • X12-basierte Spezifikationen. Wählen Sie das Trennzeichen für das Dokument aus, das Sie überprüfen möchten, und klicken Sie auf OK.

    • EDIFACT-basierte Spezifikationen. Wählen Sie das Trennzeichen und das Escapezeichen für das Dokument aus, das Sie überprüfen möchten, und klicken Sie auf OK.
  5. Lesen Sie die auf der Registerkarte Warnung angezeigte Meldung. Wird die Dokumentinstanz anhand der Spezifikation überprüft, wird die folgende Meldung angezeigt:

    Die Überprüfung der Dokumentinstanz war erfolgreich.

    Konnte die Überprüfung der Dokumentinstanz anhand der Spezifikation nicht durchgeführt werden, wird auf der Registerkarte Warnung eine entsprechende Meldung angezeigt. Außerdem werden Fehlerinformationen aufgelistet, denen Sie entnehmen können, warum die Dokumentinstanz nicht überprüft wurde. Lösen Sie die Warnungen auf, und überprüfen Sie die Dokumentinstanz erneut.

  6. Wenn Sie eine nicht auf XML basierende Dokumentinstanz anhand einer nicht auf XML basierenden Spezifikation überprüfen und die Dokumentinstanz überprüft wird, können Sie auf die Registerkarte Ausgabe klicken, um eine XML-Version (Extensible Markup Language) des Dokuments anzuzeigen.

Internationales Problem

  • Wenn Sie eine Dokumentinstanz erstellen, die ein Symbol für den japanischen Yen oder ein koreanisches Won-Zeichen enthält, und das Gebietsschema des Systems auf Japanisch oder Koreanisch festgelegt ist, wird das Symbol für Yen oder das Won-Zeichen auf der Registerkarte Ausgabe des BizTalk-Editors als schwarzer umgekehrter Schrägstrich (\) angezeigt. Dies trifft nur zu, wenn die Dokumentinstanz erfolgreich anhand der entsprechenden Spezifikation überprüft wurde. Um das Symbol für Yen oder das Won-Zeichen anstelle eines umgekehrten Schrägstriches anzuzeigen, können Sie die Quelle der Registerkarte Ausgabe anzeigen.
    1. Klicken Sie auf der Registerkarte Ausgabe, auf der ein umgekehrter Schrägstrich anstelle des Symbols für Yen oder des Won-Zeichens angezeigt wird, mit der rechten Maustaste an eine beliebige Stelle, und klicken Sie dann auf Quelle anzeigen.

    2. Klicken Sie im Menü Format von Editor auf Schriftart.

    3. Klicken Sie im Dialogfeld Schriftart unter Schriftart auf Tahoma und dann auf OK.

Anmerkungen

  • Es ist wichtig, dass Sie die mit ungültigen XML-Namenzeichen verbundenen Probleme verstehen, wenn Sie Instanzen überprüfen. Weitere Informationen finden Sie unter Ungültige XML-Namenzeichen.

  • Eine wohlgeformte XML-Dokumentinstanz, die Elemente enthält, die als XDR-Datentypen (XML-Data Reduced) eingegeben wurden, kann möglicherweise nicht anhand der entsprechenden Spezifikation überprüft werden. Stellen Sie sicher, dass für alle Elemente, die als XDR-Datentypen eingegeben wurden, die Modell-Eigenschaft auf Offen festgelegt wurde, damit eine solche Dokumentinstanz überprüft werden kann. Weitere Informationen zur Modell-Eigenschaft finden Sie unter Festlegen von Deklarationseigenschaften.

  • Nicht auf XML basierende Dokumentinstanzen, die in Unicode gespeichert wurden, können nur korrekt überprüft werden, wenn Sie das Kennzeichen für die Bytereihenfolge am Anfang der Datei entfernen. Das Kennzeichen für die Bytereihenfolge sind die ersten beiden Bytes jeder in Unicode gespeicherten Datei.

  • Eine Dokumentinstanz, die einen x-schema-Schemaverweis enthält, wird immer unter Verwendung dieses Schemaverweises überprüft, unabhängig von dem Schema, das im BizTalk-Editor geladen ist.

  • Eine ungültige Zeichentabelle ist kein Kriterium für die Instanzüberprüfung. Enthält eine Instanz beispielsweise Daten, die zwischen dem im Dialogfeld Ungültiger Zeichenbereich angegebenen Anfangs- und Endbereich liegen, kann die Überprüfung dennoch durchgeführt werden.

Verwandte Themen

Erstellen einer neuen Dokumentinstanz

Ungültige XML-Namenzeichen

Überprüfen von Instanzen und Spezifikationen


Verwalten ungültiger Zeichentabellen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen ungültiger Zeichenbereiche

  • Bearbeiten ungültiger Zeichenbereiche

  • Löschen ungültiger Zeichenbereiche


Hinzufügen ungültiger Zeichenbereiche

  1. Klicken Sie im Menü Ansicht auf Ungültige Zeichentabelle.

    Das Dialogfeld Ungültiger Zeichenbereich wird angezeigt.

  2. Klicken Sie auf die Schaltfläche Neuer Zeichenbereich Schaltfläche "Neuer Zeichenbereich".

    Das Dialogfeld Ungültigen Zeichenbereich eingeben wird angezeigt.

  3. Wählen Sie aus der Liste Ungültiger Anfangsbereich einen Wert aus, und drücken Sie TAB.

  4. Wählen Sie aus der Liste Ungültiger Endbereich einen Wert aus, und klicken Sie auf OK.

  5. Wiederholen Sie die Schritte 2 bis 4, um weitere ungültige Zeichenbereiche hinzuzufügen.

Wichtig

  • Ungültige Zeichenbereiche können nur für nicht auf XML basierende Dokumente festgelegt werden.

  • Der korrekte Hexadezimalwert für ein Fragezeichen (?) ist (0x3f). Die Standardeinstellung in der Liste Ungültiger Anfangsbereich und der Liste Ungültiger Endbereich ist ? (0x0). Verwenden Sie dieses Zeichen nicht als Satzzeichen. Um ein Fragezeichen einzugeben, wählen Sie den Wert ? (0x3f) aus der Liste aus.

Anmerkungen

  • Die Werte, die in den Listen Ungültiger Anfangsbereich und Ungültiger Endbereich angezeigt werden, sind Hexadezimalwerte. Wird die Spezifikation mithilfe einer Anwendung, wie z. B. Microsoft Internet Explorer 5 oder höher, als XML-Quelldatei (Extensible Markup Language) angezeigt, werden die Werte als Dezimalwerte angezeigt. Wenn Sie in den Feldern Ungültiger Anfangsbereich und Ungültiger Endbereich beispielsweise ein Semikolon (;) eingeben, wird der Wert als ; (0x3b) angezeigt. In einem Browser hingegen wird derselbe Wert als 59 angezeigt.

  • Um einen ungültigen Zeichenbereich einzugeben, können Sie auch in der Liste Ungültiger Anfangsbereich den Wert markieren, ein numerisches oder alphabetisches Zeichen eingeben und dann TAB drücken, um zur Liste Ungültiger Endbereich zu wechseln.

Verwandte Themen

Löschen ungültiger Zeichenbereiche

Bearbeiten ungültiger Zeichenbereiche


Bearbeiten ungültiger Zeichenbereiche

  1. Klicken Sie im Menü Ansicht auf Ungültige Zeichentabelle.

    Das Dialogfeld Ungültiger Zeichenbereich wird angezeigt.

  2. Wählen Sie den zu ändernden Zeichenbereich aus, und klicken Sie auf die Schaltfläche Zeichenbereich ändern Schaltfläche "Zeichenbereich ändern".

    Das Dialogfeld Ungültiger Zeichenbereich eingeben wird angezeigt.

  3. Wählen Sie einen Wert aus der Liste Ungültiger Anfangsbereich aus.

    Oder

    Wählen Sie einen Wert aus der Liste Ungültiger Endbereich aus.

  4. Klicken Sie auf OK.

  5. Wiederholen Sie die Schritte 2 bis 4, um weitere ungültige Zeichenbereiche zu ändern.

Wichtig

  • Ungültige Zeichenbereiche können nur für nicht auf XML basierende Dokumente festgelegt werden.

  • Der korrekte Hexadezimalwert für ein Fragezeichen (?) ist (0x3f). Die Standardeinstellung in der Liste Ungültiger Anfangsbereich und der Liste Ungültiger Endbereich ist ? (0x0). Verwenden Sie dieses Zeichen nicht als Satzzeichen. Um ein Fragezeichen einzugeben, wählen Sie den Wert ? (0x3f) in der Liste aus.

Anmerkungen

  • Die Werte, die in den Listen Ungültiger Anfangsbereich und Ungültiger Endbereich angezeigt werden, sind Hexadezimalwerte. Wird die Spezifikation mithilfe einer Anwendung, wie z. B. Microsoft Internet Explorer 5 oder höher, als XML-Quelldatei angezeigt, werden die Werte als Dezimalwerte angezeigt. Wenn Sie in den Feldern Ungültiger Anfangsbereich und Ungültiger Endbereich beispielsweise ein Semikolon (;) eingeben, wird der Wert als ; (0x3b) angezeigt. In einem Browser dagegen wird derselbe Wert als 59 angezeigt.

  • Um einen Zeichenbereich anzugeben, können Sie auch in der Liste Ungültiger Anfangsbereich auf den Wert klicken, ein numerisches oder alphabetisches Zeichen eingeben und dann die TAB-TASTE drücken, um zur Liste Ungültiger Endbereich zu wechseln.

Verwandte Themen

Hinzufügen ungültiger Zeichenbereiche

Löschen ungültiger Zeichenbereiche


Löschen ungültiger Zeichenbereiche

Wichtig

  • Ungültige Zeichenbereiche können nur für nicht auf XML basierende Dokumente festgelegt werden.
  1. Klicken Sie im Menü Ansicht auf Ungültige Zeichentabelle.

    Das Dialogfeld Ungültiger Zeichenbereich wird angezeigt.

  2. Klicken Sie auf den zu löschenden Zeichenbereich, und klicken Sie auf die Schaltfläche Zeichenbereich löschen Schaltfläche "Zeichenbereich löschen".

  3. Klicken Sie auf Ja, um die Änderung zu bestätigen.

Verwandte Themen

Hinzufügen ungültiger Zeichenbereiche

Bearbeiten ungültiger Zeichenbereiche


Verwalten von Ansichten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erweitern von Strukturelementen

  • Reduzieren von Strukturelementen

  • Anzeigen von Registerkarten

  • Ändern der Textgröße


Erweitern von Strukturelementen

  • Klicken Sie auf den Stammknoten oder Datensatz, den Sie erweitern möchten, und klicken Sie dann im Menü Ansicht auf Strukturelemente erweitern.

Anmerkung

  • Sie müssen auf den Stammknoten klicken, um die gesamte Struktur zu erweitern. Durch Klicken auf einen Datensatz erweitern Sie lediglich die untergeordneten Datensätze und Felder innerhalb des Datensatzes.

Verwandtes Thema

Reduzieren von Strukturelementen


Reduzieren von Strukturelementen

  • Klicken Sie auf den Stammknoten oder Datensatz, den Sie reduzieren möchten, und klicken Sie dann im Menü Ansicht auf Strukturelemente reduzieren.

Anmerkung

  • Sie müssen auf den Stammknoten klicken, um die gesamte Struktur zu reduzieren. Durch Klicken auf einen Datensatz reduzieren Sie lediglich die untergeordneten Datensätze und Felder innerhalb des Datensatzes.

Verwandtes Thema

Erweitern von Strukturelementen


Anzeigen von Registerkarten

  • Klicken Sie im Menü Ansicht auf eine der folgenden Registerkartennamen:
    • Deklaration

    • Verweis

    • Analysieren

    • Namespace

    • Wörterbuch

    • Codeliste


Ändern der Textgröße

  • Zeigen Sie im Menü Ansicht auf Textgröße, und klicken Sie auf die gewünschte Größe.


BizTalk-Editor - Tastenkombinationen

Sie können im BizTalk-Editor Tastenkombinationen verwenden, um Aufgaben durchzuführen. Die folgende Tabelle ist eine kurze Referenz zu diesen Tastenkombinationen.

Anmerkung

  • Um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind, können Sie mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server- und Advanced Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Tastenkombination | Zweck
STRG+UMSCHALTTASTE++ (Drücken Sie bei aktivierter NUM-FESTSTELLTASTE die PLUSTASTE (+) auf der Zehnertastatur, während Sie die UMSCHALTTASTE gedrückt halten.) Eine neue benutzerdefinierte Anmerkung hinzufügen, wenn der Fokus sich auf dem Namespace-Datenblatt im rechten Bereich befindet.

Oder

Eine neue benutzerdefinierte Eigenschaft auf der Registerkarte Deklaration, Verweis, Namespace oder Wörterbuch erstellen.

Oder

Eine benutzerdefinierte Eigenschaft in eine Spezifikation einfügen. Diese Funktion steht auf den Registerkarten Deklaration, Verweis, Namespace und Wörterbuch zur Verfügung, während eine Eigenschaft markiert ist.
TAB-TASTE | Zugreifen auf die Schaltflächen oben rechts im Dialogfeld Neue Dokumentspezifikation.
UMSCHALT+F10 | Öffnen des Kontextmenüs für markierte Elemente.
STRG+N | Eine neue Spezifikation öffnen.
STRG+O | Vorhandene Spezifikation öffnen.
STRG+S | Spezifikation speichern.
STRG+R | Einfügen eines neuen Datensatzes in eine Dokumentspezifikation.
STRG+R | Einen neuen Datensatz zu einem Datensatz hinzufügen.
STRG+F | Einfügen eines neuen Feldes in eine Dokumentspezifikation.
STRG+F | Ein neues Feld zu einem Datensatz hinzufügen.
ENTF | Einen Datensatz oder ein Feld löschen.
F4 | Die nächste Warnmeldung markieren.
F5 | Schema überprüfen.
STRG+C | Objekt kopieren.
STRG+X | Objekt ausschneiden.
STRG+V | Objekt einfügen.
F6 | Den Fokus im Uhrzeigersinn zum nächsten Fensterbereich verschieben.
Umschalt+F6 | Den Fokus entgegen dem Uhrzeigersinn zum nächsten Fensterbereich verschieben.
TAB | Fokus von der Registerkarte im rechten Bereich zum Datenblatt darunter umschalten. Durch Drücken von TAB in einem Dialogfeld wird der Fokus zwischen den Schaltflächen und Feldern im Dialogfeld verschoben.
LEERTASTE | Aktivieren oder Deaktivieren eines Kontrollkästchens. Die Leertaste verhält sich darüber hinaus wie ein Mausklick, wenn der Fokus sich auf einer Schaltfläche befindet.
F2 | Bearbeitungsmodus für einen markierten Knoten in der Spezifikationsstruktur aktivieren. Bearbeitungsmodus für eine markierte Zeile im Datenblatt des rechten Bereichs aktivieren.
UMSCHALT+F2 Bearbeitungsmodus für die folgenden Felder aktivieren:
  • Die Eigenschaft-Spalte einer markierten benutzerdefinierten Anmerkungszeile auf der Registerkarte Deklaration oder Verweis.

  • Die Präfix-Spalte einer markierten benutzerdefinierten Anmerkungszeile auf der Registerkarte Namespace.

  • Die Eigenschaft-Spalte einer markierten benutzerdefinierten Wörterbuchzeile auf der Registerkarte Wörterbuch.
ALT+NACH-UNTEN | Liste für ein aktives Listenfeld anzeigen.
UMSCHALT++ | Eine neue benutzerdefinierte Anmerkung hinzufügen, wenn der Fokus sich auf dem Namespace-Datenblatt im rechten Bereich befindet.
EINGABETASTE | Bearbeitung von Knoten und Werten bestätigen.
ESC | Bearbeitung von Knoten und Werten abbrechen.
F1 | Onlinehilfe anzeigen.
ALT+F4 | Programm schließen.
NACH-LINKS-TASTE | Registerkarte links aktivieren.
NACH-RECHTS-TASTE | Registerkarte rechts aktivieren.
Eine beliebige Pfeiltaste | Einen Ordner oder eine Datei im Hauptfensterbereich eines Dialogfeldes markieren, während sich der Fokus auf diesem Bereich befindet. Diese Funktion steht in den Dialogfeldern Neue Dokumentspezifikation, In WebDAV speichern und Aus WebDAV abrufen zur Verfügung. Weitere Informationen zum Dialogfeld Neue Dokumentspezifikation finden Sie unter Erstellen und Überprüfen von Spezifikationen. Weitere Informationen zu WebDAV finden Sie unter Öffnen einer vorhandenen Spezifikation aus WebDAV.

Verwenden der Tastaturmaus mit dem BizTalk-Editor

Für bestimmte Vorgänge im BizTalk-Editor stehen keine Tastenkombinationen zur Verfügung. Zur Durchführung der folgenden Vorgänge müssen Sie die Tastaturmaus verwenden:

  • Verschieben

  • Drag & Drop

  • Knoten kopieren


Verwenden des BizTalk-Mappers

Microsoft® BizTalk™-Mapper ist ein Konvertierungstool, mit dem Sie eine Entsprechung zwischen den Datensätzen und Feldern in zwei verschiedenen Spezifikationsformaten herstellen können. Der BizTalk-Mapper verwendet Verknüpfungen und Funktoide, um diese Konvertierung auszuführen. Funktoide führen Operationen aus, die von einfachen Berechnungen bis zur Erstellung komplexer Skripts reichen.

Mithilfe des BizTalk-Mappers können Sie die strukturellen Transformationsbeziehungen zwischen Datenelementen der Quellspezifikation und der Zielspezifikation grafisch darstellen. Diese Querverweis- und Datenbearbeitungsfunktionalität erstellt eine Zuordnung, die eine Reihe von Anweisungen bereitstellt, die die Beziehung zwischen zwei unterschiedlichen Spezifikationsformaten definiert. Die Spezifikationsformate werden mithilfe des BizTalk-Editors definiert.

Eine Zuordnung stellt Datentransformationen zwischen einer Quellspezifikation und einer Zielspezifikation dar. Microsoft BizTalk Server 2002 verwendet die in einer Zuordnung bereitgestellten Daten zum Generieren von XSLT-Transformationen (Extensible Stylesheet Language). Anschließend wird die XSLT-Ausgabe von Microsoft XML Parser (MSXML), Version 3.0, zum Transformieren des Schemas auf dem Server zur Laufzeit verwendet. Wenn Sie eine Zuordnung erstellen, kann XSLT auf der BizTalk-Mapper-Registerkarte Ausgabe angezeigt werden.

Der BizTalk-Mapper ermöglicht den offenen Austausch von Spezifikationen im XDR-Datenformat (XML-Data Reduced). Der BizTalk-Mapper kann nur die Spezifikationen öffnen, die im BizTalk-Editor gespeichert wurden. Der BizTalk-Mapper kann keine allgemeinen XML-Dateien (Extensible Markup Language) oder Nicht-XML-Dateien öffnen. Wenn Sie zwei allgemeine XML-Dateien konvertieren möchten, müssen Sie diese zuvor in den BizTalk-Editor importieren und als Spezifikationen speichern.

Der BizTalk-Mapper unterstützt eine Vielzahl von Zuordnungsszenarien, die von einfachen Strukturbeziehungen mit über- und untergeordneten Elementen bis zu detaillierten, komplexen Schleifen aus Datensätzen und Hierarchien reichen. Nach Abschluss des Zuordnungsprozesses verwendet eine Serialisierungskomponente die Spezifikation, um ein Dateiformat zu erstellen, das vom Handelspartner oder einer internen Anwendung erkannt wird. Der BizTalk-Mapper umfasst auch eine Kompilierungskomponente für Stylesheets, die aus der visuellen Darstellung der Zuordnung ein XSLT-Stylesheet erstellt.

Die folgende Abbildung veranschaulicht das Zuordnen einer Quell- zu einer Zielspezifikation. Die Quelldatei ist ein auf Electronic Data Interchange (EDI oder Elektronischer Datenaustausch) basierendes Dokument und die Zieldatei ein Flatfiledokument. Im vorliegenden Beispiel wird die Struktur des EDI-Dokuments in ein temporäres XML-Format konvertiert. Die Daten werden schließlich im Flatfileformat gespeichert. Ein datengesteuerter Parser (der die XDR-Spezifikation verwendet) erstellt eine XML-Version der EDI-Quellspezifikation. Das XSL-Modul transformiert anschließend diese XML-Quelldarstellung in eine XML-Darstellung des Zieldateiformats. Die Zielspezifikation wird schließlich in das systemeigene Format der Zieldatei serialisiert. Dies ist in diesem Beispiel das Flatfileformat.

Transformieren eines EDI-Dokuments in ein Flatfiledokument

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ausführliche Informationen zum BizTalk-Mapper finden Sie unter Informationen zum BizTalk-Mapper.

  • Eine Kurzübersicht darüber, warum bestimmte Aufgaben ausgeführt werden müssen, finden Sie unter Gründe für das Durchführen von BizTalk-Mapper-Aufgaben.

  • Detaillierte Anweisungen zum Ausführen von Aufgaben finden Sie unter Durchführen von BizTalk-Mapper-Aufgaben.

  • Anweisungen zur Lösung von Problemen finden Sie unter Problembehandlung - BizTalk-Editor und BizTalk-Mapper.


Der BizTalk-Mapper

Der BizTalk-Mapper ist ein grafisches Tool, das Quellspezifikationen und Zielspezifikationen nebeneinander anzeigt und das Definieren von Transformationen ermöglicht, indem zwischen Datensätzen, Feldern und Funktoiden Linien gezogen werden. Der BizTalk-Mapper verwendet den Internetstandard XSLT (Extensible Stylesheet Language Transformations). Diese Sprache dient dem Transformieren von XML-Dokumenten (Extensible Markup Language ) von einem XML-Schema in ein anderes.

Dieser Abschnitt stellt detaillierte Informationen zum Konzept bereit, die wichtig für das Verständnis des BizTalk-Mappers sind.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Zuordnen von Spezifikationen

  • Zuordnen von Szenarien

  • BizTalk-Mapper - Umgebung

  • Erstellen von Verknüpfungen

  • Zuordnen der Ebenen innerhalb der Knotenhierarchie

  • Anzeigen von Datensatz-, Feld-, Verknüpfungs- und Funktoideigenschaften

  • Grundlegendes zu Funktoiden

  • Integrieren der BizTalk-Dienste mithilfe von Zuordnungen

  • Kompilieren von Zuordnungen

  • Testen von Zuordnungen


Zuordnen von Spezifikationen

Eine Zuordnung identifiziert die Art und Weise, in der Daten des einen Formats in einem anderen Format dargestellt werden. Eine Zuordnung erfordert zwei Spezifikationen. Die eine Spezifikation dient als Quelle und die andere als Ziel. Das Zuordnen von Daten ist ein Prozess der Datenübersetzung, bei dem die Entsprechungen zwischen den Datensätzen und Feldern der Quellspezifikation und den Datensätzen und Feldern der Zielspezifikation definiert werden.

Es gibt zwei Arten von Zuordnungen:

  • Spezielle Zuordnung. Dieser Zuordnungstyp wurde entwickelt, um den individuellen Anforderungen eines Handelspartners zu entsprechen. Sollen die speziellen Datensätze und Felder eines bestimmten Handelspartners in einer Zuordnung erfasst werden, erstellen Sie eine Zuordnung, die sich nur auf diesen Handelspartner bezieht.

  • Allgemeine Zuordnung. Dieser Zuordnungstyp wurde entwickelt, um den Anforderungen mehrerer Handelspartner zu entsprechen. Bei allgemeinen Zuordnungen erfassen und gruppieren Sie die Anforderungen mehrerer Handelspartner innerhalb einer einzigen Zuordnung. Da mehrere Organisationen miteinander vernetzt sein und Sie dieselbe Zuordnung für mehrerer Handelspartner verwenden können, hilft Ihnen dieses Feature, wertvolle Ressourcen und Zeit zu sparen.

Der BizTalk-Mapper zeigt eine grafische Darstellung einer Zuordnung an, die sowohl einfache Übersetzungen, bei denen Werte kopiert werden und die als Verknüpfungen bezeichnet werden, als auch Elemente für die komplexe strukturelle Bearbeitung enthalten kann, die als Funktoide bezeichnet werden. Durch Kombinieren dieser Elemente können Sie auf einfache Weise eine Zuordnung zwischen den Daten einer Quellspezifikation und den Daten einer Zielspezifikation festlegen.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Zuordnen von Quell- und Zieldateien


Zuordnen von Quell- und Zieldateien

Zuordnungen sind Microsoft BizTalk Server-spezifische XML-Dateien (Extensible Markup Language), die vom BizTalk-Mapper erstellt werden. Sie können Zuordnungen erstellen, die auf Folgendem basieren:

  • Industriestandards (wie z. B. XML, EDIFACT oder X12)

  • Nicht-Industriestandards (wie z. B. Flatfiles mit Trennzeichen, Flatfiles mit Feldern fester Breite oder kombinierte Flatfiles mit Trennzeichen und Feldern fester Breite).

  • Vorhandene Dateien

Der BizTalk-Mapper unterstützt auch das Verwenden von Nicht-BizTalk Server-Schemas für die Erstellung von Zuordnungen. Zum Erstellen einer Zuordnung müssen Sie zwei Spezifikationen verwenden: eine für die Struktur der Quellspezifikation und eine für die Struktur der Zielspezifikation.

Vorhandene BizTalk Server 2000-Dateien

Aus BizTalk Server 2000 stammende Zuordnungen sind nahezu vollständig kompatibel mit BizTalk Server 2002. Wenn Sie in BizTalk Server 2002 eine mit BizTalk Server 2000 erstellte Zuordnung öffnen und speichern, wird das Dateiformat geändert, so dass Sie sie in BizTalk Server 2000 nicht mehr öffnen können.


Zuordnungsszenarios

Der BizTalk-Mapper unterstützt eine Vielzahl von Zuordnungsszenarios, die von einfachen Strukturbeziehungen mit über- und untergeordneten Elementen bis zu detaillierten, komplexen Schleifendatensätzen und Hierarchien reichen. Die Komplexität von Zuordnungsszenarios wird noch anspruchsvoller, da Formate wie XML (Extensible Markup Language) ein hohes Maß an Flexibilität beim Definieren strukturierter Formate ermöglichen.

Grundlegende Zuordnungsoperationen

Dies sind die gängigsten Zuordnungsoperationen. Sie umfassen das Zuordnen eines oder mehrerer Quellfelder aus einem übergeordneten Element in der Struktur der Quellspezifikation zu einem oder mehreren Feldern in der Struktur der Zielspezifikation, die zu einem übergeordneten Element gehören. Obwohl es bei diesem Zuordnungstyp viele verschiedene mögliche Transformationen gibt, wie z. B. Verwenden mehrerer oder kaskadierender Funktoide, ist das grundlegende Szenario im Vergleich zu anderen Szenarios nicht kompliziert. Grundlegende Zuordnungsoperationen umfassen auch das Zuordnen von Feldern aus zwei verschiedenen übergeordneten Elementen (die nur einmal vorkommen) zu Feldern in der Struktur der Zielspezifikation unter einem einzelnen übergeordneten Element.

Komplexe Zuordnungsoperationen

Diese Operationen können das Zuordnen von Feldern aus verschiedenen übergeordneten Elementen in der Struktur der Quellspezifikation (von denen eines mehrmals vorkommen kann) zu einem einzelnen übergeordneten Element in der Struktur der Zielspezifikation umfassen. Dieser Zuordnungstyp erfordert die ordnungsgemäße Auswahl eines Schleifenpfads, was im Allgemeinen beim Zuordnen von auf EDI (Electronic Data Interchange) basierenden Dokumenten erforderlich ist. In diesem Szenario muss der XSL-Stylesheet-Compiler (Extensible Stylesheet Language) den korrekten Schleifenpfad auswählen, über den die Iteration zum Erzeugen der gewünschten Ausgabe erfolgen muss. Weitere Informationen zu Schleifenpfaden finden Sie unter Schleifenpfade.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Schleifenpfade

  • Reihenfolge von Datensätzen und Feldern


Schleifenpfade

Ein Datensatz in einer Spezifikation ist ein Schleifendatensatz, wenn die Maximalvorkommen-Eigenschaft auf der Registerkarte Verweis für den Datensatz auf * (Sternchen) festgelegt ist. Weitere Informationen zur Maximalvorkommen-Eigenschaft finden Sie unter Festlegen von Verweiseigenschaften.

Ein Schleifenpfad tritt in einer Zuordnung auf, wenn ein Feld innerhalb eines Schleifendatensatzes der Quellspezifikation mit einem Feld innerhalb eines Schleifendatensatzes der Zielspezifikation verknüpft ist. Die folgende Abbildung zeigt zwei Schleifenpfade: einer führt von Stamm\Datensatz1\Feld1 (Root\Record1\Field1) nach Stamm\DatensatzA\Feld1 (Root\RecordA\Field1) und der andere von Stamm\Datensatz2\Feld2 (Root\Record2\Field2) nach \Stamm\DatensatzB\Feld3 (\Root\RecordB\Field3).

Die Registerkarte Eigenschaften zeigt, dass es sich bei Datensatz1 (Record1) und DatensatzA (RecordA) um Schleifendatensätze der Maximalvorkommen-Eigenschaft handelt. Auch Datensatz2 (Record2) und DatensatzB (RecordB) sind Schleifendatensätze .

Der folgende Code zeigt ein Beispiel für ein Eingabedokument:

<Root>
<Record1 Field1="Red">
<Record1 Field1="Green">
<Record1 Field1="Blue">
<Record2 Field2="50">
<Record2 Field2="100">
</Root>

Mithilfe der zuvor gezeigten Zuordnung würde dieses Eingabedokument dem folgenden Ausgabedokument zugeordnet werden:

<Root>
<RecordA Field1="Red">
<RecordA Field1="Green">
<RecordA Field1="Blue">
<RecordB Field3="50">
<RecordB Field3="100">
</Root>

Mehrfachschleifenpfad

Eine Zuordnung weist einen Mehrfachschleifenpfad auf, wenn Felder aus zwei oder mehr Schleifendatensätzen der Quellspezifikation mit Feldern eines einzelnen Schleifendatensatzes der Zielspezifikation verknüpft sind.

Die folgende Abbildung zeigt ein Beispiel für einen Mehrfachschleifenpfad.

Zuordnung mit einem Mehrfachschleifenpfad

Mehrfachschleifenpfade werden vom BizTalk-Mapper nicht unterstützt. Wenn Sie versuchen, eine Zuordnung zu kompilieren, die einen Mehrfachschleifenpfad enthält, zeigt die Registerkarte Warnungen an, dass der Zielknoten mehrere Quellschleifenpfade besitzt.

Verwandte Themen

Festlegen von Verweiseigenschaften

Verwenden des Funktoids "Schleife"


Reihenfolge von Datensätzen und Feldern

Eine implizite Reihenfolge der Datensätze und Felder in der Ausgabe wird von XSL (Extensible Stylesheet Language) nicht gewährleistet. Der Grund dafür ist, dass der BizTalk-Mapper zum Generieren der XSL-Spezifikation die Struktur der Zielspezifikation durchläuft und anschließend die Verknüpfungen über das Zuordnungsraster zurückverfolgt, um Werte aus der Quellspezifikationsstruktur zu extrahieren. Wenn Sie beispielsweise eine Ausgabedatei erstellen möchten, die zuerst alle Datensätze mit Rechnungsadressen (RechnungAn) und anschließend alle Datensätze mit Lieferadressen (LiefernAn) enthält, müssen Sie sicherstellen, dass in der Zielspezifikation der RechnungAn-Adressdatensatz vor dem LiefernAn-Adressdatensatz aufgeführt ist.

Die folgende Abbildung veranschaulicht diese Struktur.

Das Feld Kontakttyp enthält zwei gültige Codes (RA und LA), welche die Adressen entweder als RechnungAn- oder LiefernAn-Adresse identifizieren. Um die gewünschte Ausgabe zu erstellen, werden zum Zuordnungsraster Funktoide des Typs Gleich hinzugefügt und einerseits mit Feldern der Quellspezifikation sowie andererseits mit Datensätzen der Zielspezifikation verknüpft.

Das erste Funktoid überprüft für die Zuordnung die folgende Bedingung:

Hat Kontakttyp den Wert RA?

Wenn diese Bedingung erfüllt ist, wird ein Ausgabedatensatz des Typs RechnungAnAdresse erstellt und es werden ihm die erforderlichen Felder zugeordnet. Ist die Bedingung nicht erfüllt, muss der BizTalk-Mapper erneut alle Eingabe-Adressdatensätze durchlaufen, um der erforderlichen Bedingung zu entsprechen.

Wichtig

  • Die Reihenfolge, in der die Datensätze und Felder in einer Ausgabedokumentinstanz angezeigt werden, hängt von der Reihenfolge der Datensätze und Felder in der entsprechenden Ausgabespezifikation ab.


BizTalk-Mapper - Umgebung

Nach dem Öffnen des BizTalk-Mappers wird eine grafische Benutzeroberfläche angezeigt, auf der Sie leicht Zuordnungen erstellen und mit diesen arbeiten können.

Folgende Themen werden in diesem Abschnitt behandelt:

  • BizTalk-Mapper - Benutzeroberfläche

  • BizTalk-Mapper - Menüs

  • BizTalk-Mapper - Symbolleisten-Schaltflächen

  • BizTalk-Mapper - Funktoidpalette

  • Anpassen der Anzeige


BizTalk-Mapper - Benutzeroberfläche

Die beiden Spezifikationen, die für die Erstellung einer Zuordnung verwendet werden, werden im Hauptfenster des BizTalk-Mappers als Strukturansichten angezeigt. Die Quellspezifikation befindet sich auf der linken Seite. Von ihr ausgehend werden die Daten der Zielspezifikation auf der rechten Seite zugeordnet. Das zwischen den beiden Spezifikationen befindliche Zuordnungsraster veranschaulicht auf grafische Weise die strukturelle Datentransformation zwischen den beiden Spezifikationen. Verknüpfungen und Funktoide werden innerhalb des Zuordnungsrasters angezeigt. Bewegungen innerhalb des Zuordnungsrasters nach oben, unten, rechts oder links lassen sich problemlos durchführen, indem Sie den Mauszeiger über die Ränder des Zuordnungsrasters bewegen. Sie können auch weitere Rasterseiten hinzufügen, um Verknüpfungen und Funktoide zu gruppieren und die Ansicht der verschiedenen Bereiche einer Zuordnung zu vereinfachen. Sie können z. B. den Kopfzeilenabschnitt einer Zuordnung vom Textkörper trennen.

Sie können das Dialogfeld Rastervorschau verwenden, um innerhalb des Zuordnungsrasters schnell von einer Position zu einer anderen zu wechseln. Durch Ziehen der grünen Positionierungsleiste können Sie sich nach oben, unten, links oder rechts bewegen. Ein Funktoid des Zuordnungsrasters wird in der Rastervorschau als ein rotes Feld, das von einem schwarzen Rand umgeben ist, angezeigt. Sind zwei oder mehr Funktoide im Zuordnungsraster enthalten, werden sie grafisch als zwei rote Felder dargestellt, die miteinander verbunden und von einem schwarzen Rand umgeben sind.

Unterhalb der Strukturansichten und des Zuordnungsrasters befindet sich der untere Bereich. Dieser Bereich enthält vier Registerkarten:

  • Eigenschaften Bei Auswahl eines Knotens in der Struktur der Quell- oder Zielspezifikation zeigt die Registerkarte Eigenschaften die Eigenschaften und Eigenschaftswerte für diesen Knoten an.

  • Werte Diese Registerkarte enthält die beiden Textfelder Quelltestwert und Konstanter Wert für Ziel. Sie können ein Feld auswählen und anschließend einen Wert in das Feld Quelltestwert eingeben. Dadurch können Sie Zuordnungen mit den tatsächlichen Werten testen, die Sie den Feldern zugewiesen haben. Im Feld Konstanter Wert für Ziel können Sie einen Wert eingeben, der einem Feld der Zielstruktur zugewiesen werden soll. Es ist nicht möglich, eine Verknüpfung zwischen einem Funktoid oder einem Knoten der Quellspezifikation und einem Feld der Zielspezifikation zu erstellen, dem ein konstanter Wert zugewiesen wurde.

  • Ausgabe Diese Registerkarte zeigt ein kompiliertes XSL (Extensible Stylesheet Language)-Stylesheet an, wenn Sie eine Zuordnung kompiliert haben, und sie zeigt die Testausgabe an, wenn Sie eine Zuordnung getestet haben.

  • Warnungen Diese Registerkarte zeigt nach der Kompilierung einer Zuordnung Compilerwarnungen an. Wenn Sie in diesem Bereich eine Warnung auswählen, wird die dazugehörige Verknüpfung bzw. das dazugehörige Funktoid in der Zuordnung hervorgehoben, so dass Sie Fehler bestimmen und lösen können.

Verwandte Themen

Kompilieren von Zuordnungen

Testen von Zuordnungen

Anzeigen von Verknüpfungen und Funktoiden mithilfe der Rastervorschau


BizTalk-Mapper - Menüs

Die Menüs des BizTalk-Mappers bieten eine logische Zusammenfassung von Befehlen und vereinfachen auf diese Weise die Ausführung einer bestimmten Aufgabe. Sie können beispielsweise die Befehle im Menü Ansicht dazu verwenden, alle Datensätze und Felder der Struktur der Quellspezifikation anzuzeigen oder alle Datensätze und Felder in der Struktur der Zielspezifikation zu reduzieren.

Der BizTalk-Mapper verfügt über folgende Menüs:

  • Datei. Verwenden Sie dieses Menü, um eine Zuordnung zu erstellen, zu öffnen, zu speichern oder zu schließen.

  • Bearbeiten. Verwenden Sie dieses Menü, um die Quell- oder Zielspezifikation zu ersetzen, ein Objekt innerhalb des Zuordnungsrasters zu löschen oder Rasterseiten hinzuzufügen oder zu löschen.

  • Ansicht. Verwenden Sie dieses Menü, um die Funktoidpalette, die Eigenschaften von Funktoiden und die Rastervorschau anzuzeigen. Außerdem können Sie die Textgröße für die Anzeige im BizTalk-Mapper auswählen, die Registerkarten im unteren Fensterbereich aktivieren, die Strukturansichten der Spezifikationen erweitern oder reduzieren und die nächste Warnmeldung auf der Registerkarte Warnungen hervorheben.

  • Extras. Verwenden Sie dieses Menü, um Zuordnungen zu kompilieren und zu testen, und um die Optionen für den BizTalk-Mapper anzuzeigen.

  • Hilfe. Verwenden Sie dieses Menü, um detaillierte Informationen zum Konzept, der Bedeutung von Aufgaben und praktische Anleitungen zum Verwenden des BizTalk-Mappers anzuzeigen.

Verwandtes Thema

BizTalk-Editor - Menüs


BizTalk-Mapper - Symbolleisten-Schaltflächen

Der BizTalk-Mapper stellt als Ergänzung zur Menüleiste eine Symbolleiste zur Verfügung. Alle Schaltflächen der Symbolleiste zeigen grafische Darstellungen der Aufgaben, die sie ausführen. Sie werden auf der Symbolleiste in folgender Reihenfolge angezeigt (von links nach rechts):

  • Neu

  • Öffnen

  • Speichern

  • Aus WebDAV abrufen

  • Im WebDAV speichern

  • Löschen

  • Reduzieren

  • Erweitern

  • Funktoidpalette anzeigen

  • Zuordnung kompilieren

  • Testzuordnung

  • Seite hinzufügen

  • Seite löschen


BizTalk-Mapper - Funktoidpalette

Die Funktoidpalette enthält alle Funktoide, die im BizTalk-Mapper zur Verfügung stehen. Ein Funktoid beinhaltet Code, der Daten von einem Datensatz oder Feld der Quellspezifikation oder von einem anderen Funktoid (z. B. dem Funktoid Datum) übernimmt, diese Daten eigenständig verarbeitet und anschließend einen neuen Wert zurückgibt, der in einem Datensatz oder ein Feld der Zielspezifikation platziert wird. Weitere Informationen zur Funktoidpalette finden Sie unter Grundlegendes zu Funktoiden.

Verwandte Themen

Grundlegendes zu Funktoiden

Arbeiten mit Funktoiden


Anpassen der Anzeige

Zum Anpassen der Anzeige des BizTalk-Mappers gibt es verschiedene Möglichkeiten. Beispielsweise können Sie die Hintergrundfarben des Zuordnungsrasters ändern, neue Farben für Verknüpfungen und markierte Objekte angeben sowie die Farbe von Compilerwarnungen und die Größe des dargestellten Texts ändern. Folgende Elemente können angepasst werden:

  • Rastervordergrund. Die gestrichelten Linien des Zuordnungsrasters.

  • Rasterhintergrund. Die Hintergrundfarbe des Zuordnungsrasters.

  • Feste Verknüpfungen. Wertkopieverknüpfungen im Zuordnungsraster.

  • Elastische Verknüpfungen. Wertkopierverknüpfungen, die von der Struktur der Quellspezifikation zur Struktur der Zielspezifikation gezogen werden.

  • Teilverknüpfungen. Verknüpfungen mit einem Feld oder einem Datensatz, dessen übergeordneter Datensatzknoten reduziert ist.

  • Compilerverknüpfungen. Verknüpfungen von Compilerdirektiven, die automatisch erstellt werden, wenn Sie die Kompilierung durch Drücken von F5 auslösen.

  • Compilerwarnungen. Wenn Sie eine Warnung auswählen, die beim Kompilieren einer Zuordnung generiert wurde, wird auf der Registerkarte Warnungen die Verknüpfung bzw. das Funktoid in der für Compilerwarnungen angegebenen Farbe hervorgehoben.

  • Ausgewählte Objekte. Ein Objekt, wie z. B. ein Funktoid oder eine Verknüpfung, das Sie im Zuordnungsraster auswählen, wird in dieser Farbe anzeigt.

Diese Features sind im Dialogfeld Optionen für den BizTalk-Mapper verfügbar, auf das über das Menü Extras zugegriffen werden kann. Änderungen der Textgröße können über das Menü Ansicht vorgenommen werden.

Verwandtes Thema

Optionen für den BizTalk-Mapper: Registerkarte "Farben"


Erstellen von Verknüpfungen

Verknüpfungen haben die grundlegende Funktion, Daten aus Datensätzen und Feldern der Struktur der Quellspezifikation in Datensätze und Felder der Struktur der Zielspezifikation zu kopieren. Der BizTalk-Mapper unterstützt 1:1- und 1:n-Verknüpfungen. Eine Verknüpfung kann beispielsweise einen einzelnen Datensatz oder ein einzelnes Feld in der Struktur der Quellspezifikation mit einem einzelnen Datensatz oder Feld in der Struktur der Zielspezifikation verbinden. Es ist mithilfe einer Verknüpfung auch möglich, einen einzelnen Datensatz oder ein einzelnes Feld in der Struktur der Quellspezifikation mit mehreren Datensätzen oder Feldern in der Struktur der Zielspezifikation zu verbinden. Außerdem können Verknüpfungen auch dazu verwendet werden, mehrere Datensätze oder Felder in der Struktur der Quellspezifikation mit einem Funktoid zu verbinden, das anschließend mit einem einzelnen Datensatz oder Feld in der Struktur der Zielspezifikation verbunden wird. Mehrere Datensätze oder Felder in der Struktur der Quellspezifikation können mit einem einzelnen Datensatz oder Feld in der Struktur der Zielspezifikation verbunden werden.

Verwandtes Thema

Verwalten von Verknüpfungen


Zuordnen der Ebenen innerhalb der Knotenhierarchie

Der BizTalk-Mapper unterstützt die Verwendung von Compilerdirektiven. Mithilfe dieser Direktiven können Sie den Grad der Zuordnung zwischen der Hierarchie der Struktur der Quellspezifikation und der Hierarchie der Struktur der Zielspezifikation festlegen. Wenn Sie eine Verknüpfung zwischen einem Feld in der Struktur der Quellspezifikation und einem Feld in der Struktur der Zielspezifikation erstellen, fügt der BizTalk-Mapper automatisch Compilerverknüpfungen zur Zuordnung basierend auf den Optionen hinzu, die Sie im Dialogfeld Verknüpfungseigenschaften auf der Registerkarte Compiler im Bereich Zielspezifikationsverknüpfungen ausgewählt haben. Weitere Informationen dazu finden Sie unter Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen. Die folgenden Abbildungen zeigen die möglichen Zuordnungen zwischen den Ebenen der Knotenhierarchie:

  • Verknüpfungen vereinfachen. (Standard). In diesem Modus werden alle Quellhierarchien auf den übergeordneten Datensatz des Zielknotens vereinfacht. Im ersten gezeigten Fall ist die Quellspezifikation komplexer als die Zielspezifikation. Im zweiten gezeigten Fall ist die Zielspezifikation komplexer.

Modus Verknüpfungen vereinfachen für den Fall, dass die Quellspezifikation komplexer als die Zielspezifikation ist.

Modus Verknüpfungen vereinfachen für den Fall, dass die Zielspezifikation komplexer als die Quellspezifikation ist.

  • Verknüpfungen von oben nach unten zuordnen. Dieser Modus ordnet die Ebenen nacheinander von oben nach unten zu. Im ersten gezeigten Fall ist die Quellspezifikation komplexer als die Zielspezifikation. Im zweiten gezeigten Fall ist die Zielspezifikation komplexer.

Modus Verknüpfungen von oben nach unten zuordnen für den Fall, dass die Quellspezifikation komplexer als die Zielspezifikation ist.

Modus Verknüpfungen von oben nach unten zuordnen für den Fall, dass die Zielspezifikation komplexer als die Quellspezifikation ist.

  • Verknüpfungen von unten nach oben zuordnen. Dieser Modus ordnet die Ebenen nacheinander von unten nach oben zu. Im ersten gezeigten Fall ist die Quellspezifikation komplexer als die Zielspezifikation. Im zweiten gezeigten Fall ist die Zielspezifikation komplexer.

Modus Verknüpfungen von unten nach oben zuordnen für den Fall, dass die Quellspezifikation komplexer als die Zielspezifikation ist.

Modus Verknüpfungen von unten nach oben zuordnen für den Fall, dass die Zielspezifikation komplexer als die Quellspezifikation ist.

Die folgende Tabelle zeigt, wie der BizTalk-Mapper Verknüpfungen basierend auf dem verwendeten Direktiventyp behandelt.

Wenn Sie z. B. für Verknüpfungen von Feldern der Quellspezifikation mit Feldern der Zielspezifikation, die zum selben übergeordneten Datensatz gehören, eine Compilerdirektive des Typs Verknüpfungen vereinfachen, eine des Typs Verknüpfungen von oben nach unten zuordnen und eine des Typs Verknüpfungen von unten nach oben zuordnen verwenden, behandelt der BizTalk-Mapper alle Verknüpfungen so, als ob für sie die Compilerdirektive des Typs Verknüpfungen vereinfachen festgelegt wurde.

Vereinfachen | Von oben nach unten | Von unten nach oben | Ergebnis
1 | 1 | 1 | Der BizTalk-Mapper behandelt alle Verknüpfungen so, als wären diese auf die Compilerdirektive Verknüpfungen vereinfachen festgelegt.
1 oder mehr | 1 |  | Der BizTalk-Mapper behandelt alle Verknüpfungen so, als wären diese auf die Compilerdirektive Von oben nach unten festgelegt.
1 oder mehr |  | 1 | Der BizTalk-Mapper behandelt alle Verknüpfungen so, als wären diese auf die Compilerdirektive Von unten nach oben festgelegt.
 | 1 oder mehr | 1 oder mehr | Der BizTalk-Mapper behandelt alle Verknüpfungen so, als wären diese auf die Compilerdirektive Verknüpfungen vereinfachen festgelegt.

Verwandtes Thema

Kompilieren von Zuordnungen


Anzeigen von Datensatz-, Feld-, Verknüpfungs- und Funktoideigenschaften

Die Quellspezifikation und die Zielspezifikation zeigen alle Datensätze und Felder an, die einer Spezifikation zugeordnet sind. Diese Spezifikationen können Sie mithilfe des BizTalk-Editors erstellen oder in den BizTalk-Editor als wohlgeformtes XML, Dokumenttypdefinition (DTD) oder XDR Schema importieren. Sie können ein beliebiges XDR-Schema verwenden, das von einer unabhängigen Organisation erstellt wurde. Gruppen und Namespaces werden jedoch nicht unterstützt. Die Quellspezifikation wird links vom Zuordnungsraster, die Zielspezifikation rechts vom Zuordnungsraster angezeigt.

Datensatz- und Feldeigenschaften und deren Werte

Die Eigenschaften von Datensätzen und Feldern sowie die Werte dieser Eigenschaften werden auf der Registerkarte Eigenschaften angezeigt, die sich unterhalb des Hauptfensterbereichs befindet. Wenn Sie einen Datensatz oder ein Feld auswählen, werden die Haupteigenschaften und deren Werte aus den Eigenschaftsregisterkarten des BizTalk-Editors angezeigt.

Eigenschaften von Verknüpfungen und Funktoiden

Das Zuordnungsraster des BizTalk-Mappers veranschaulicht auf grafische Weise die Struktur der Datentransformation. Verknüpfungen werden als einzelne Linien angezeigt, die einen Datensatz oder ein Feld in der Struktur der Quellspezifikation mit einem Datensatz oder Feld in der Struktur der Zielspezifikation verbinden. Verknüpfungen werden auch zum Verbinden von Datensätzen oder Feldern mit Funktoiden verwendet. Funktoide werden als Symbole angezeigt. Eigenschaften von Verknüpfungen enthalten Informationen zu Quell- und Zieldaten sowie zu Compilerdirektiven. Eigenschaften von Funktoiden enthalten Informationen zu Eingabeparameter und zugehörigen Skripten.

Verwandte Themen

Datensätze, Felder und Eigenschaften

Grundlegendes zu Funktoiden


Grundlegendes zu Funktoiden

Der BizTalk-Mapper unterstützt komplexe strukturbezogene Transformationen von Datensätzen und Feldern in der Struktur der Quellspezifikation in Datensätze und Felder in der Struktur der Zielspezifikation. Funktoide führen Berechnungen mithilfe vordefinierter Formeln und bestimmter Werte aus, die als Argumente bezeichnet werden. Diese Berechnungen werden basierend auf der angegebenen Reihenfolge der Datensätze und Felder ausgeführt.

Sie können Daten hinzufügen oder verketten, Datums- oder Zeitangaben ändern und andere Operationen ausführen, indem ein Funktoid in der Funktoidpalette ausgewählt, auf das Zuordnungsraster gezogen und mit Elementen in der Struktur der Quell- und Zielspezifikation verknüpft wird. So bewirkt beispielsweise das Funktoid Addition die Addition von Werten.

Die Funktoidpalette umfasst die folgenden Registerkarten:

  • Zeichenfolge. Diese Funktoide bearbeiten Datenzeichenfolgen mithilfe von Zeichenfolgenfunktionen. Beispielsweise sucht das Funktoid Zeichenfolge suchen nach einer Textzeichenfolge innerhalb einer anderen Textzeichenfolge und gibt als Ergebnis die Position des ersten Zeichens der gefundenen Zeichenfolge zurück. Weitere Informationen zu den Parameteranforderungen der einzelnen Zeichenfolgenfunktoide finden Sie unter Zeichenfolgenfunktoide.

  • Mathematisch. Diese Funktoide führen Berechnungen mithilfe spezieller Werte aus, die als Argumente bezeichnet werden und in einer bestimmten Reihenfolge oder Kombination in die Berechnungen eingehen. Das Funktoid Addition z. B. addiert die Werte der angegebenen Felder oder Datensätze. Weitere Informationen zu den Parameteranforderungen der einzelnen mathematischen Funktoide finden Sie unter Mathematische Funktoide.

  • Logisch. Diese Funktoide führen bestimmte logische Tests aus. Wenn ein logisches Funktoid mit einem Datensatz in der Zielspezifikation verknüpft ist und den Wert TRUE zurückgibt, wird der entsprechende Datensatz im Ausgabedokument generiert. Wenn ein logisches Funktoid mit einem Datensatz der Zielspezifikation verknüpft ist und den Wert FALSE zurückgibt, wird der entsprechende Datensatz im Ausgabedokument nicht generiert. Die Ausgabe eines logischen Funktoids kann auch als Eingabe für andere Funktoide innerhalb einer Zuordnung verwendet werden. Wenn ein logisches Funktoid und ein Funktoid Schleife zuerst zusammen und anschließend mit einem Datensatz in der Struktur der Zielspezifikation verknüpft werden, wird das Funktoid Schleife nur verwendet, wenn die Ausgabe des logischen Funktoids TRUE ist. Weitere Informationen zu den Parameteranforderungen der einzelnen logischen Funktoide finden Sie unter Logische Funktoide.

    Wichtig

    • Wenn Sie zwei Datensätze oder Felder in der Struktur der Quellspezifikation mit zwei verschiedenen logischen Funktoiden verknüpfen und anschließend die logischen Funktoide mit demselben Datensatz in der Struktur der Zielspezifikation verknüpfen, wird in der generierten XSLT (Extensible Stylesheet Language Transformation) nur das erste logische Funktoid verwendet. Die zweite Verknüpfung im zweiten logischen Funktoid wird ignoriert.
  • Datum/Uhrzeit. Diese Funktoide bearbeiten datums- und zeitbezogene Daten oder fügen zu einem Datensatz oder Feld in der Zielspezifikation das aktuelle Datum und die aktuelle Zeit oder andere Datums- und Zeitdaten hinzu. Weitere Informationen zu den Parameteranforderungen der einzelnen Datums- und Zeitfunktoide finden Sie unter Datums- und Zeitfunktoide.

  • Konvertierung. Diese Funktoide ähneln weitgehend entsprechenden Hilfsfunktionen des Software Engineering wie z. B. DEC2HEX, die einen Hexadezimalwert für einen gegebenen Dezimalwert zurückgibt. Sie können auch dazu verwendet werden, ein Zeichen in dessen ASCII-Wert oder einen Wert in das entsprechende ASCII-Zeichen zu konvertieren. Weitere Informationen zu den Parameteranforderungen der einzelnen Konvertierungsfunktoide finden Sie unter Konvertierungsfunktoide.

  • Wissenschaftlich. Diese Funktoide konvertieren einen numerischen Wert in einen Wert einer mathematischen Funktion. Beispielsweise verwendet das Funktoid Kosinus den Wert eines Feldes oder Datensatzes als Winkel in Bogenmaß (Radiant) und gibt den Wert des Kosinus zurück. Weitere Informationen zu den Parameteranforderungen der einzelnen wissenschaftlichen Funktoide finden Sie unter Wissenschaftliche Funktoide.

  • Kumulativ. Diese Funktoide geben die Summe, den Mittelwert, das Minimum oder das Maximum der Eingabewerte eines Schleifendatensatzes zurück. Weitere Informationen zu den Parameteranforderungen der einzelnen kumulativen Funktoide finden Sie unter Kumulative Funktoide.

  • Datenbank. Diese Funktoide extrahieren Daten aus einer Datenbank. Weitere Informationen zu den Parameteranforderungen der einzelnen Datenbankfunktoide finden Sie unter Datenbankfunktoide.

  • Erweitert. Diese Registerkarte enthält mehrere Funktoide zur Ausführung verschiedener Bearbeitungen. Dazu zählen ein Funktoid, das ein benutzerdefiniertes Microsoft® Visual Basic®-Skript oder Microsoft JScript® verwenden kann, Funktoide für die Zuordnung von Werten, Funktoide vom Typ Schleife, Index und Iteration sowie Funktoide zum Verwalten und Extrahieren von Informationen aus Schleifendatensätzen. Weitere Informationen zu den Parameteranforderungen der einzelnen erweiterten Funktoide finden Sie unter Erweiterte Funktoide.

Sie können außerdem eigene, benutzerdefinierte Funktoide erstellen. Ein Beispiel eines benutzerdefinierten Funktoids finden Sie im Ordner \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\SampleFunctoid. Ein Beispiel eines auf Microsoft® .NET basierenden Funktoids finden Sie im Ordner Programme\Microsoft BizTalk Server\SDK\Messaging Samples\DateFunctoidNet, wenn auf dem Computer eine vollständige Installation von BizTalk Server oder eine benutzerdefinierte Installation durchgeführt wurde, bei der auch die Messagingbeispiele installiert wurden.

Wichtig

  • Wenn Sie ein benutzerdefiniertes Funktoid erstellen, müssen Sie dieses auf allen Computern registrieren, damit es auf diesen angezeigt und ordnungsgemäß verwendet werden kann. Wird ein benutzerdefiniertes Funktoid nicht auf einem Computer registriert ist und in einer Zuordnung verwendet, wird es mit den Buchstaben FT angezeigt. Sie können das Funktoid nicht verschieben, auch wenn es auf der Rasterseite angezeigt wird.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden von kaskadierenden Funktoiden

  • Verwenden von kumulativen Funktoiden

  • Verwenden von Datenbankfunktoiden

  • Verwenden des Funktoids "Datensatzanzahl"

  • Verwenden des Funktoids "Index"

  • Verwenden des Funktoids "Iteration"

  • Verwenden des Funktoids "Wertezuordnung"

  • Verwenden des Funktoids "Wertezuordnung (Flattening)"

  • Verwenden des Funktoids "Schleife"


Verwenden von kaskadierenden Funktoiden

Mit kaskadierenden Funktoiden können Sie Zuordnungen erstellen, bei denen Felder oder Datensätze mit mehreren Funktoiden verknüpft werden müssen, um das gewünschte Ergebnis in ein Feld oder einen Datensatz der Zielspezifikation zu übertragen. Kaskadierende Funktoide vereinfachen das Erstellen mehrerer aufeinander folgender Transformationen im Zuordnungsraster. Kaskadieren von Funktoiden bedeutet, dass ein Funktoid mit einem anderen Funktoid verknüpft wird, bevor es mit einem Datensatz oder Feld der Zielspezifikation verknüpft wird. So können Sie beispielsweise kaskadierende Funktoide dazu verwenden, aus zwei verketteten Zeichenfolgen eine dritte Zeichenfolge zu generieren, die anschließend in ein Feld der Zielspezifikation eingespeist wird. Die Anzahl der Funktoide, die Sie durch Kaskadieren im Zuordnungsraster kombinieren können, ist unbegrenzt. Allerdings können sich komplexe Kaskadierungen auf die Leistungsfähigkeit auswirken.


Verwenden von kumulativen Funktoiden

Kumulative Funktoide operieren im Kontext der Datensatzebene in der Quellspezifikation. In der Regel treten in einer Eingabedatei bestimmte Datensätze mehrmals auf. Beispielsweise kann ein Auftrag ("purchase order") mehr als einen Posten ("item") umfassen. Der Abschnitt für den einzelnen Posten kann Angaben zum Produkt, eine Beschreibung sowie Angaben zum Preis und zur Menge enthalten. Der folgende Code ist ein Beispiel für ein Auftragsdokument:

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Northwind Traders</To>
<LineItems>
  <Item>
    <Product>Computer A</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>Computer A Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>Cleaner A</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

Die folgende Abbildung zeigt diesen Auftrag, wie er im BizTalk-Editor angezeigt wird.

Die Maximalvorkommen-Eigenschaft auf der Registerkarte Verweis für den Item-Datensatz ist auf den Wert * (Sternchen) festgelegt. Dies gibt an, dass der Posten-Datensatz (Item) ein Schleifendatensatz ist und der BizTalk-Mapper diesen Datensatz als eine Schleife kompiliert.

Möglicherweise möchten Sie die Gesamtsumme aller Einzelposten des Auftrags ermitteln und die kumulative Summe per Zuordnung in ein Feld eines Ausgabedokuments übertragen. Zu diesem Zweck müssen Sie zuerst für jeden Posten-Datensatz (Item) des Auftrags den erweiterten Preis berechnen und anschließend die Summen der einzelnen Posten-Datensätze (Item) zusammenfassen, während der Zuordnungsprozess nacheinander alle Posten-Datensätze (Item) des Auftrags verarbeitet.

Die folgende Abbildung zeigt ein Funktoid Multiplikation und ein Funktoid Kumulative Summe, die dazu verwendet werden, die Beträge der Item-Datensätze eines eingehenden Auftrags zusammenzufassen und das Ergebnis in das Feld POTotal ("Auftragsumme") eines TotalsDocument-Dokuments auszugeben.

In diesem Beispiel werden alle Item-Datensätze, die unterhalb des LineItems-Datensatzes ("Einzelposten") eines eingehenden Auftrags vorhanden sind, von der kumulativen Operation berücksichtigt. Die Inhalte der Felder für Preis- und Mengenangaben (Price und Quantity) werden an das Funktoid Multiplikation gesendet. Die Ausgabe des Funktoids Multiplikation dient als Eingabe für das Funktoid Kumulative Summe. Die Ausgabe des Funktoids Kumulative Summe ist der akkumulierte Wert aller in dem eingegebenen Auftrag durchsuchten Item-Datensätze. Dieser Wert wird an das Feld POTotal des TotalsDocument-Dokuments gesendet und ist die Summe aller einzelnen Produkte aus Preis und Menge: (2000x1)+(50x2)+(2x100)=2300.

Anmerkungen

  • Die kumulative Zusammenfassung einer bestimmten Eingabe erfolgt auf der Ebene des übergeordneten Datensatzes, aus dem die Eingabeverknüpfung stammt. Diese Feststellung gilt auch für die Ausgaben eines Funktoids, die als Eingabe für ein kumulatives Funktoid dienen.

  • Kumulative Funktoide ignorieren nichtnumerische Eingaben. So wird z. B. der Eingabewert drei ignoriert.

Die Funktoide Kumulativer Durchschnitt, Kumulativer Minimalwert und Kumulativer Maximalwert verhalten sich ähnlich wie das Funktoid Kumulative Summe. Das Funktoid Kumulative Zeichenfolge zeigt insofern ein anderes Verhalten als die übrigen kumulativen Funktoide, als es Zeichenfolgen verkettet und keine numerischen Werte zusammenfasst.

Verwandte Themen

Hinzufügen von kumulativen Funktoiden

Kumulative Funktoide


Verwenden von Datenbankfunktoiden

Datenbankfunktoide extrahieren Daten aus einer Datenbank. Um die Funktionsweise von Datenbankfunktoiden zu verstehen, stellen Sie sich ein großes Einzelhandelsunternehmen mit vielen Niederlassungen vor, die sich über ein großes geografisches Gebiet verteilen. Jede Filiale wird durch einen numerischen Code identifiziert und an alle Partner wird eine entsprechende Adressliste verteilt. Die Adressliste könnte beispielsweise die folgende Struktur aufweisen:

Filialenkennung ("StoreID"): 123

Name ("Name"): Contoso, Ltd

Adresse ("Address"): 1234 Main Street

Ort ("City"): Denver, Colorado

PLZ ("PostalCode"): 97402

Telefon ("PhoneNumber"): 801-555-0179

Geschäftsführer ("StoreManager"): Anthony Chor

In nachfolgenden Transaktionen wird in einem Auftrag nur der numerische Code versendet, der die jeweilige Filiale darstellt. Der BizTalk-Mapper verwendet diesen Code, um die Adressinformationen aus einer Datenbank zu extrahieren. Die folgende Abbildung zeigt ein solches Szenario.

Zuordnung eines Datenbankfunktoids

In dieser Abbildung stellt die Quellspezifikation einen eingehenden Auftrag und die Zielspezifikation eine Rechnung dar. Das Funktoid Datenbanksuche Funktoid Datenbanksuche sucht in einer Datenbank in der entsprechenden Tabelle nach dem entsprechenden Datensatz. Die Ausgabe des Funktoids Datenbanksuche kann nur mit Funktoiden des Typs Wertextrahierer Funktoid Wertextrahierer verknüpft werden. Das Funktoid Wertextrahierer extrahiert aus dem Suchdatensatz den entsprechenden Spaltennamen. Das Funktoid Fehlerrückgabe Funktoid Fehlerrückgabe gibt eine Zeichenfolge aus, die Fehlerinformationen enthält, sofern zur Laufzeit Fehler (beispielsweise Verbindungsfehler) aufgetreten sind.

Das Funktoid Datenbanksuche erfordert vier Eingabeparameter in folgender Reihenfolge:

  1. Suchwert

  2. Verbindungszeichenfolge der Datenbank

  3. Tabellenname

  4. Spaltenname für den Suchwert

Informationen zum Einfügen, Löschen und Verschieben von Eingabeparametern finden Sie unter Eingabeparameter.

In dem vorhergehenden Beispiel wird der erste Eingabeparameter dem Feld StoreID des eingehenden Auftrags entnommen, während die übrigen drei Eingabeparameter Konstanten im Dialogfeld Funktoideigenschaften auf der Registerkarte Allgemein für das Funktoid Datenbanksuche darstellen. Es ist möglich, von der Struktur der Quellspezifikation ausgehende Verknüpfungen zu erstellen, um Werte für alle vier Eingabeparameter bereitzustellen. Weitere Informationen zum Einfügen, Löschen und Verschieben von Eingabeparametern finden Sie unter Eingabeparameter.

Das Funktoid Wertextrahierer erfordert die beiden folgenden Eingabeparameter in der angegebenen Reihenfolge:

  1. Eine Verknüpfung zum Funktoid Datenbanksuche

  2. Den Spaltennamen

Das Funktoid Fehlerrückgabe erfordert exakt einen Eingabeparameter: eine Verknüpfung zum Funktoid Datenbanksuche

Anmerkungen

  • Einige Microsoft® SQL Server™-Datentypen, wie z. B. text, ntext und image, können nicht als Suchwerte für das Funktoid Datenbanksuche verwendet werden.

  • Wenn mehr als ein Datensatz mit den Eingabeparametern des Funktoids Datenbanksuche übereinstimmt, extrahiert das Funktoid Wertextrahierer nur den ersten Datensatz in der Tabelle.

Verwandte Themen

Datenbankfunktoide

Eingabeparameter


Verwenden des Funktoids "Datensatzanzahl"

Das Funktoid Datensatzanzahl wird im Kontext der Datensatzebene der Quellspezifikation verwendet. In der Regel treten in einer Eingabedatei bestimmte Datensätze mehrmals auf. Beispielsweise kann ein Auftrag ("purchase order") mehr als einen Posten ("item") umfassen. Der Abschnitt für den einzelnen Posten kann Angaben zum Produkt, eine Beschreibung sowie Angaben zum Preis und zur Menge enthalten. Der folgende Code ist ein Beispiel für ein Auftragsdokument:

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Northwind Traders</To>
<LineItems>
  <Item>
    <Product>Computer A</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>Computer A Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>Clearner A</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

Die folgende Abbildung zeigt diesen Auftrag, wie er im BizTalk-Editor angezeigt wird.

Die Maximalvorkommen-Eigenschaft auf der Registerkarte Verweis für den Item-Datensatz ist auf den Wert * (Sternchen) festgelegt. Dies zeigt an, dass der Posten-Datensatz (Item) ein Schleifendatensatz ist und der BizTalk-Mapper diesen Datensatz als eine Schleife kompiliert.

Möglicherweise möchten Sie die Gesamtzahl aller Einzelposten des Auftrags ermitteln und diesen Wert mit einer Zuordnung in ein Feld eines Ausgabedokuments übertragen. Dieses Szenario unterscheidet sich von dem üblichen Zuordnungsszenario, bei dem der Inhalt des Quelldokuments dem Ausgabedokument zugeordnet wird. In diesem Fall generiert das Funktoid Anzahl der Datensätze den Wert, der dem Ausgabedokument zugeordnet wird.

Das Funktoid Datensatzanzahl hat einen Eingabe- und einen Ausgabewert. Als Eingabe dient eine Verknüpfung aus einem Schleifendatensatz der Quellspezifikation. Der Datensatz wird im ursprünglichen Eingabedokument mehrmals angezeigt. Die Ausgabe des Funktoids Anzahl der Datensätze ist eine Verknüpfung mit einem Feld der Zielspezifikation.

Die folgende Abbildung zeigt ein Funktoid Anzahl der Datensätze, das die Anzahl der Auftragsposten zählt, die in einem eingehenden Auftrag vorhanden sind, und diesen Wert in das Feld Number_Of_Items des POReport-Dokuments ausgibt.

Zuordnung des Funktoids Datensatzanzahl

Da in diesem Beispiel der eingehende Auftrag drei Posten umfasst, hat das Feld Number_Of_Items der Wert 3.

Verwandtes Thema

Erweiterte Funktoide


Verwenden des Funktoids "Index"

Das Funktoid Index wird im Kontext der Datensatzebene der Quellspezifikation verwendet. In der Regel treten in einer Eingabedatei bestimmte Datensätze mehrmals auf. Beispielsweise kann ein Wetterbericht ("Weather Report") für mehr als einen Tag eine Tagesvorhersage ("DailySummary") enthalten. Der Abschnitt für die Tagesvorhersage ("DailySummary") könnte Angaben über die Temperatur, den Luftdruck ("Pressure") und die Windgeschwindigkeit ("WindSpeed") enthalten. Der folgende Code ist ein Beispiel für einen Wetterbericht:

<WeatherReport>
  <DailySummary>
    <Temperature>20</Temperature>
    <Pressure>80</Pressure>
    <WindSpeed>10</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>23</Temperature>
    <Pressure>78</Pressure>
    <WindSpeed>20</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>24</Temperature>
    <Pressure>77</Pressure>
    <WindSpeed>16</WindSpeed>
  </DailySummary>
</WeatherReport>

Die folgende Abbildung zeigt diesen Wetterbericht, wie er im BizTalk-Editor angezeigt wird.

Im vorhergehenden Code ist die Maximalvorkommen-Eigenschaft auf der Registerkarte Verweis für dem DailySummary-Datensatz auf den Wert * (Sternchen) festgelegt. Dies zeigt an, dass der DailySummary-Datensatz ein Schleifendatensatz ist und der BizTalk-Mapper diesen Datensatz als eine Schleife kompiliert.

Möglicherweise möchten Sie die Wetterinformationen der ersten beiden DailySummary-Datensätze des Wetterberichts erfassen. Jedes Feld des DailySummary-Datensatzes der eingehenden Quellspezifikation kann im BizTalk-Mapper mit einem Funktoid Index verknüpft werden, und jedes Funktoid Index kann angeben, welchem DailySummary-Datensatz (dem ersten oder dem zweiten) die Informationen entnommen werden sollen. Die Funktoide des Typs Index können anschließend mit den entsprechenden Feldern einer Zielspezifikation verbunden werden.

Die folgende Abbildung zeigt Funktoide des Typs Index, die in dieser Weise verwendet werden.

Um eine zusammenfassende Vorhersage für den ersten Tag zu erhalten, müssen die drei oberen Funktoide des Typs Index den Indexwert 1 aufweisen. Um eine zusammenfassende Vorhersage für den zweiten Tag zu erhalten, müssen die drei unteren Funktoide des Typs Index den Indexwert 2 aufweisen.

Eingabewert für die Indexreihenfolge werden auf der Registerkarte Allgemein des Eigenschaftenblattes eines Funktoids Index als Eingabeparameter festgelegt. Doppelklicken Sie auf ein Funktoid Index, um das zugehörige Eigenschaftenblatt anzuzeigen. Der erste Eingabeparameter identifiziert das Feld in der Quellspezifikation, das mit dem Funktoid Index verknüpft wird. Der oder die nachfolgende(n) Eingabeparameter geben den oder die Indexwert(e) an.

Die folgende Abbildung zeigt das Eigenschaftenblatt des obersten Funktoids Index der zuvor abgebildeten Zuordnung an.

Eigenschaften des Funktoids Index

Anmerkungen

  • Ein Eingabeparameter eines Funktoids Index, dem der Wert einer nichtnumerischen Konstante zugewiesen wurde, wird vom BizTalk-Mapper als der Wert 1 interpretiert. Wenn z. B. in der vorhergehenden Abbildung der zweite Eingabeparameter durch einen Eingabeparameter mit dem Wert eine Zeichenfolge ersetzt würde, wäre das Zuordnungsergebnis das gleiche.

  • Obwohl die Eingabe für die Indexreihenfolge in der Regel ein konstanter Wert ist, der auf der Registerkarte Allgemein im Dialogfeld Funktoideigenschaften festgelegt wird, ist es auch möglich, die Eingabe für die Indexreihenfolge mithilfe einer Verknüpfung zu einem Knoten der Quellspezifikation bereitzustellen. Wenn diese Verknüpfung aus einem Schleifendatensatz stammt, der keinen übergeordneten Datensatz des ersten Eingabeparameters darstellt, bezieht sich der Eingabewert für die Indexreihenfolge auf die erste Instanz des Knotens im eingehenden Dokument.

  • Der Eingabewert der Indexreihenfolge ist stets relativ zum aktuellen Kontext im Quelldokument.

Enthält eine Eingabedatei mehrere Wetterberichte und umfasst jeder Wetterbericht mehrere tagesbezogene Vorhersagen, ist möglicherweise mehr als ein Indexwert anzugeben. Der folgende Code ist ein Beispiel für eine Eingabedatei mit mehreren Wetterberichten:

<WeatherReports>
  <WeatherReport1>
    <DailySummary>
      <Temperature>20</Temperature>
      <Pressure>80</Pressure>
      <WindSpeed>10</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>23</Temperature>
      <Pressure>78</Pressure>
      <WindSpeed>20</WindSpeed>
    </DailySummary>
  </WeatherReport1>
  <WeatherReport2>
    <DailySummary>
      <Temperature>24</Temperature>
      <Pressure>77</Pressure>
      <WindSpeed>16</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>22</Temperature>
      <Pressure>79</Pressure>
      <WindSpeed>21</WindSpeed>
    </DailySummary>
  </WeatherReport2>
</WeatherReports>

Ein Funktoid Index mit zwei Indexwerten, von denen der erste auf 1 und der zweite auf 2 festgelegt ist, bezieht seinen Feldwert aus der ersten Tagesvorhersage des zweiten Wetterberichts.

Wichtig

  • Ein Funktoid Index muss so viele Indexwerte besitzen, wie es übergeordnete Knoten zwischen der Feldebene und der ersten Ebene unterhalb des Stammknotens gibt. Beispielsweise sind für die Verarbeitung des Beispieldokuments mit mehreren Wetterberichten zwei Indexwerte erforderlich. Für das erste Beispieldokument, das einen Wetterbericht enthält, ist nur ein Indexwert erforderlich. Wird für ein Funktoid Index nicht die erforderliche Anzahl von Indexwerten bereitgestellt, wird eine Ausgabe basierend auf dem ersten Knoten im Quelldokument erstellt, der dem ersten Eingabeparameter des Funktoids Index entspricht.

Verwandtes Thema

Erweiterte Funktoide


Verwenden des Funktoids "Iteration"

Das Funktoid Iteration identifiziert, welche Reihenfolgenummer eines Schleifendatensatzes zu einem gegebenen Zeitpunkt zugeordnet wird. Die folgende Abbildung zeigt diese Art der Verwendung des Funktoids Iteration in Verbindung mit einem Funktoid Gleich.

Zuordnung des Funktoids Iteration

Für jeden der beiden Datensätze der Zielspezifikation gibt es jeweils ein Paar von Funktoiden (das Funktoid Iteration Funktoid Iteration und das Funktoid Gleich Funktoid Gleich). Die folgende Abbildung zeigt das Eigenschaftenblatt für das oberste Funktoid Gleich.

Eigenschaftenblatt des obersten Funktoids Gleich

Der folgende Code zeigt ein Beispiel für eine eingehende Dokumentinstanz, die mit der Struktur der Quellspezifikation übereinstimmt:

<Root>
<Record1 Field1="A"/>
<Record1 Field1="B"/>
</Root>

Während die eingehende Dokumentinstanz gemäß der Quellspezifikation verarbeitet wird, gibt das Funktoid Iteration den Wert 1 zurück, wenn der erste Datensatz zugeordnet wird, und den Wert 2, wenn der zweite Datensatz zugeordnet wird. Das Funktoid Gleich gibt den Wert TRUE zurück, wenn seine beiden Eingabeparameter identisch sind. Deshalb gibt das obere Funktoidpaar den Wert TRUE zurück, wenn der erste Datensatz der eingehenden Dokumentinstanz zugeordnet wird. Der Wert TRUE wird an den Datensatz Record2 der Zielspezifikation übergeben, und Record2 wird in das Ausgabedokument geschrieben. Wenn der zweite Eingabeparameter des unteren Funktoids Gleich einen Wert von 2 aufweist, verhält sich das untere Funktoidpaar in ähnlicher Weise wie das obere Funktoidpaar. Anders ausgedrückt: Wenn der zweite Datensatz der eingehenden Dokumentinstanz zugeordnet wird, wird Record3 der Zielspezifikation in die Ausgabedokumentinstanz geschrieben. Der folgende Code zeigt die Ausgabedokumentinstanz:

<Root2>
<Record2 Field2="A"/>
<Record3 Field3="B"/>
</Root2>

Verwandtes Thema

Erweiterte Funktoide


Verwenden des Funktoids "Wertezuordnung"

Das Funktoid Wertezuordnung Funktoid Wertezuordnung erfordert zwei Eingabeparameter und gibt den Wert des zweiten Eingabeparameters zurück, falls der erste Parameter den Wert TRUE aufweist. Die folgende Abbildung zeigt eine Zuordnung unter Verwendung des Funktoids Wertezuordnung.

Um die Zuordnung zu vervollständigen, müssen Sie für jedes Funktoid die Eingabeparameter festlegen. Die folgende Abbildung zeigt das für jedes der Funktoide Wertezuordnung identische Eigenschaftenblatt.

Eigenschaftenblatt des Funktoids Wertezuordnung

Die folgende Abbildung zeigt das Eigenschaftenblatt für das oberste Funktoid Gleich.

Eigenschaftenblatt des Funktoids Gleich

Das Eigenschaftenblatt des mittleren Funktoids Gleich ist ähnlich, hat aber als zweiten Eingabeparameter den konstanten Wert Y. Auch das Eigenschaftenblatt des untersten Funktoids Gleich ähnelt dem ersten, weist aber als zweiten Eingabeparameter den konstanten Wert Z auf.

Der folgende Code zeigt ein Beispiel einer Dokumentinstanz, die der Quellspezifikation der Zuordnung entspricht.

<Root>
  <Record1>
    <Record2 Name="X" Value="1"/>
    <Record2 Name="Y" Value="2"/>
    <Record2 Name="Z" Value="3"/>
  </Record1>
  <Record>
    <Record2 Name="X" Value="4"/>
    <Record2 Name="Y" Value="5"/>
    <Record2 Name="Z" Value="6"/>
  </Record>
  <Record1>
    <Record2 Name="X" Value="7"/>
    <Record2 Name="Y" Value="8"/>
    <Record2 Name="Z" Value="9"/>
  </Record1>
</Root>

Ein Name-Wert von X veranlasst das obere Funktoid Gleich der Zuordnung, den Wert TRUE zurückzugeben. Durch den vom Funktoid Gleich zurückgegebenen Wert TRUE gibt das mit ihm verknüpfte Funktoid Attributwert den Wert 1 zurück.

Durch das Verwenden dieser Zuordnung und dieser Quelldokumentinstanz gibt BizTalk Server die folgende Dokumentinstanz aus:

<Root>
<Record X="1"/>
<Record Y="2"/>
<Record Z="3"/>
<Record X="4"/>
<Record Y="5"/>
<Record Z="6"/>
<Record X="7"/>
<Record Y="8"/>
<Record Z="9"/>
</Root>

Wichtig

  • Das Funktoid Wertezuordnung akzeptiert boolesche Eingaben nur in Form der kleingeschriebenen Zeichenfolgen true und false. Wenn z. B. ein Feld einer eingehenden Dokumentinstanz einen Wert von TRUE aufweist und direkt mit dem obersten Eingabeparameter eines Funktoids Wertezuordnung verknüpft ist, wird der Wert des zweiten Eingabeparameters des Funktoids Wertezuordnung nicht an das Ausgabedokument weitergeleitet.

Verwandtes Thema

Erweiterte Funktoide

Verwenden des Funktoids "Wertezuordnung (Flattening)"


Verwenden des Funktoids "Wertezuordnung (Flattening)"

Ein übliches Szenario für Benutzer von Microsoft Commerce Server besteht darin, einen Commerce Server-Katalog einem Schema mit einer vereinfachten Hierarchie zuzuordnen. Das Funktoid Wertezuordnung (Flattening) ermöglicht diesen Zuordnungstyp. Der folgende Code ist ein Beispiel für einen Commerce Server-Katalog:

<Root>
  <Record1>
    <Record2 Name="X" Value="1"/>
    <Record2 Name="Y" Value="2"/>
    <Record2 Name="Z" Value="3"/>
  </Record1>
  <Record1>
    <Record2 Name="X" Value="4"/>
    <Record2 Name="Y" Value="5"/>
    <Record2 Name="Z" Value="6"/>
  </Record1>
  <Record1>
    <Record2 Name="X" Value="7"/>
    <Record2 Name="Y" Value="8"/>
    <Record2 Name="Z" Value="9"/>
  </Record1>
</Root>

Der folgende Code ist ein Beispiel für ein vereinfachtes Schema:

<Root>
  <Record X="1" Y="2" Z="3"/>
  <Record X="4" Y="5" Z="6"/>
  <Record X="7" Y="8" Z="9"/>
</Root>

In diesem Zuordnungsszenario ist es wichtig, die 1:1-Entsprechung zwischen den drei Datensätzen im Katalog und den drei Datensätze im vereinfachten Schema beizubehalten. Die folgende Abbildung zeigt eine Zuordnung, die diese Entsprechung beibehält.

In dieser Zuordnung stellt die Quellspezifikation die Struktur des eingehenden Katalogs dar, während die Zielspezifikation die Struktur des ausgehenden vereinfachten Schemas darstellt. Für jeden der drei Datensätze gibt es ein Funktoidpaar (das Funktoid Gleich Funktoid Gleich und das Funktoid Wertezuordnung (Flattening) Funktoid Wertezuordnung (Flattening)). Die folgende Abbildung zeigt das für jedes der Funktoide Wertezuordnung (Flattening) identische Eigenschaftenblatt.

Eigenschaftenblatt des Funktoids Wertezuordnung

Die folgende Abbildung zeigt das Eigenschaftenblatt für das oberste Funktoid Gleich.

Eigenschaftenblatt des Funktoids Gleich

Das Eigenschaftenblatt des mittleren Funktoids Gleich ist ähnlich, hat aber als zweiten Eingabeparameter den konstanten Wert Y. Auch das Eigenschaftenblatt des untersten Funktoids Gleich ähnelt dem ersten, weist aber als zweiten Eingabeparameter den konstanten Wert Z auf.

Das oberste Funktoidpaar arbeitet zusammen, um sicherzustellen, dass der Wert von X von jedem der drei Datensätze des Katalogs an jeden der drei Datensätze des vereinfachten Schemas übergeben wird. Das Funktoid Wertezuordnung (Flattening) gibt den Wert des zweiten Parameters seines Eigenschaftenblattes zurück, sofern der erste Parameter auf true festgelegt ist. Deshalb gibt das oberste Funktoid Wertezuordnung (Flattening) den Wert von /Root/Record/Field/@Value nur dann zurück, wenn ihm das Funktoid Gleich, mit dem es verknüpft ist, den Wert true zurückgibt. Das Funktoid Gleich, das mit ihm verknüpft ist, gibt den Wert TRUE nur für die Felder des eingehenden Katalogs zurück, die das Namensattribut X haben.

Das Funktoid Gleich des mittleren Funktoidpaars gibt den Wert TRUE nur für diejenigen Felder der eingehenden Spezifikation zurück, die das Namensattribut Y besitzen, so dass dieses Funktoidpaar sicherstellt, dass für jeden der drei Katalogdatensätze der Wert von Y in jeden der drei Datensätze im vereinfachten Schema übergeben wird. Das dritte Funktoidpaar verarbeitet in ähnlicher Weise den Wert von Z.

Wichtig

  • Das Funktoid Wertezuordnung (Flattening) akzeptiert boolesche Eingaben nur in Form der kleingeschriebenen Zeichenfolgen true und false. Wenn z. B. ein Feld in einer eingehenden Dokumentinstanz den Wert TRUE aufweist und direkt mit dem obersten Eingabeparameter eines Funktoids Wertezuordnung (Flattening) verknüpft ist, wird der Wert des zweiten Eingabeparameters des Funktoids Wertezuordnung (Flattening) nicht an das Ausgabedokument übergeben.

Anmerkung

  • Wenn ein Datensatz einer eingehenden Dokumentinstanz für einen Katalog mehr als ein Feld mit einem Attribut besitzt, das mit dem zweiten Eingabeparameter eines der Funktoide des Typs Gleich übereinstimmt, wird nur der letzte Datensatz mit dieser Übereinstimmung dem Ausgabedokument zugeordnet. Beispielsweise würde in dem vorhergehenden Beispiel eines Commerce Server-Katalogs nur das letzte von drei Feldelementen des ersten Datensatzes zugeordnet werden, wenn alle diese Felder ein Namensattribut mit dem Wert X aufweisen.

Informationen zum Zuordnen der Daten zwischen einem vereinfachten Schema und einem Commerce Server-Katalog (also genau in der umgekehrten Richtung der Zuordnung, wie sie in dem zuvor geschilderten Zuordnungsszenario definiert war) finden Sie unter Verwenden des Funktoids "Schleife"

Verwandte Themen

Erweiterte Funktoide

Verwenden des Funktoids "Wertezuordnung"


Verwenden des Funktoids "Schleife"

Das Funktoid Schleife Funktoid Schleife wird verwendet, um mehrere Datensätze und/oder Felder der Quellspezifikation in einem einzelnen Datensatz der Zielspezifikation zu kombinieren. Für jede Schleife, die als Schleife von einem Knoten in der Struktur der Quellspezifikation zum Funktoid Schleife dargestellt wird, geht der BizTalk-Mapper für jede untergeordnete Verknüpfung vom Knoten der Struktur der Quellspezifikation zum Knoten der Struktur der Zielspezifikation zurück und generiert die entsprechende XSLT (Extensible Stylesheet Language Transformation). Wenn jedoch eine Verknüpfung zu einem Knoten der Quellspezifikation vorhanden ist, die über eine übergeordnete Verknüpfung einer anderen Eingabequellverknüpfung verfügt (von einem Knoten in der Struktur der Quellspezifikation zum Funktoid Schleife), wird der Knoten der Zielspezifikation nicht erstellt.

Die folgende Abbildung zeigt diese Art der Verwendung des Funktoids Schleife.

Zuordnung des Funktoids Schleife

Der BillTo-Datensatz in der Struktur der Quellspezifikation und der Addresses-Datensatz der Zielspezifikation sind Schleifendatensätze, wie von der Einstellung * der Maximalvorkommen-Eigenschaft in den Abschnitten Quellattribute und Zielattribute auf der Registerkarte Eigenschaften angezeigt wird. In diesem Beispiel ist auch der Datensatz Header der Quellspezifikation ein Schleifendatensatz. Wenn eine eingehende Dokumentinstanz drei BillTo-Datensätze und zwei ShipTo-Datensätze enthält, würde das Funktoid Schleife aus diesen Elementen fünf Addresses-Datensätze im ausgehenden Dokument erstellen.

Der folgende Code zeigt ein Beispiel für eine eingehende Dokumentinstanz.

<Root>
<BillTo Name="Karin Zimprich" Address="345 North 63rd Street"
City="Boston" PostalCode="07458"></BillTo>
<BillTo Name="Wendy Wheeler" Address="7890 Broadway"
City="Columbus" PostalCode="46290"></BillTo>
<BillTo Name="Florian Voss" Address="1234 Main Street"
City="Denver" PostalCode="97402"></BillTo>
<ShipTo Name="Kelly Focht" Address="456 First Avenue"
City="Miami" PostalCode="81406"></ShipTo>
<ShipTo Name="Jim Kim" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103"></ShipTo>
<Header ID="01"></Header>
<Header ID="02"></Header>
<Header ID="03"></Header>
</Root>

Diese eingehende Dokumentinstanz würde die folgende ausgehende Dokumentinstanz produzieren, wenn sie durch die in der vorhergehenden Abbildung gezeigte Zuordnung verarbeitet wird:

<Root>
<Addresses Name="Karin Zimprich" Address="345 North 63rd Street"
City="Boston" PostalCode="07458" ID="01" />
<Addresses Name="Wendy Wheeler" Address="7890 Broadway"
City="Columbus" PostalCode="46290" ID="01" />
<Addresses Name="Florian Voss" Address="1234 Main Street"
City="Denver" PostalCode="97402" ID="01" />
<Addresses Name="Kelly Focht" Address="456 First Avenue"
City="Miami" PostalCode="81406" ID="01" />
<Addresses Name="Jim Kim" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103" ID="01" />
</Root>

Beachten Sie, dass in jedem Addresses-Datensatz, der in der ausgehenden Dokumentinstanz erstellt wird, das Feld ID den Wert 01 aufweist. Der Grund dafür ist, dass der Header-Datensatz nicht mit dem Funktoid Schleife verknüpft ist. Der Wert des ersten ID-Feldes der eingehenden Dokumentinstanz wird an jeden in der ausgehenden Dokumentinstanz erstellten Datensatz weitergegeben.

Wichtig

  • Unter bestimmten Bedingungen verhalten sich einige Funktoide möglicherweise nicht wie erwartet, wenn sie innerhalb einer Zuordnung mit einem Funktoid Schleife verwendet werden. Ein Funktoid liefert nicht die erwarteten Ergebnisse, wenn folgende Bedingung erfüllt ist:
    • Zwei oder mehrere der Quellspezifikationsverknüpfungen des Funktoids sind mit untergeordneten Feldern der Eingabedatensätze für das Funktoid Schleife verknüpft. Die untergeordneten Felder sind untereinander nicht gleichgeordnet.

    Wenn Sie ein Funktoid, für das diese Bedingungen erfüllt sind, zur vorhergehenden Zuordnung hinzufügen müssten, würde dieses Funktoid eine Quellspezifikationsverknüpfung mit dem Name-Feld unterhalb des BillTo-Datensatzes, eine andere Quellspezifikationsverknüpfung mit dem Name-Feld unterhalb des ShipTo-Datensatzes und eine Zielspezifikationsverknüpfung mit dem Name-Feld unterhalb des Addresses-Datensatzes aufweisen.

Bedingungsabhängige Schleifen

Bedingungsabhängig Schleifen ergeben sich, indem die Ausgabe eines Funktoids Schleife und eines logischen Funktoids zu demselben Zieldatensatz hinzugefügt wird. Die Zieldatensätze werden nur erstellt, wenn die logische Bedingung erfüllt ist.

In der vorhergehenden Abbildung vergleicht das erste logische Funktoid das Name-Feld unter BillTo mit "Cynthia Randall" und erstellt den Addresses-Zieldatensatz nur, wenn diese Bedingung erfüllt ist. Das zweite logische Funktoid vergleicht das Name-Feld unter ShipTo mit "Jay Adams" und erstellt den Addresses-Zieldatensatz nur, wenn diese Bedingung erfüllt ist. Wenn im Beispiel des Funktoids Schleife dieselben Quelldaten verwendet werden, sieht die Ausgabe dieses Beispiels so aus:

<Root>
<Addresses Name="Cynthia Randall" Address="345 ABC Street" City="Boston" PostalCode="70000" ID="01" />
<Addresses Name="Jay Adams" Address="567 ABC Avenue" City="Seattle" PostalCode="98000" ID="01" /> </Root>
</Root>

Zuordnen eines vereinfachten Schemas zu einem Commerce Server-Katalog

Sie können das Funktoid Schleife dazu verwenden, ein vereinfachtes Schema auf einen Microsoft Commerce Server-Katalog abzubilden. Weitere Informationen zu vereinfachten Schemas und Commerce Server-Katalogen finden Sie unter Verwenden des Funktoids "Wertezuordnung (Flattening)".

Die folgende Abbildung zeigt ein vereinfachtes Schema, das einem Commerce Server-Katalog zugeordnet ist.

Zuordnung einer Flatfile zum Katalog

Wichtig

  • Damit diese Zuordnung ordnungsgemäß funktioniert, müssen Sie Folgendes ausführen:
    • Für jede Verknüpfung mit dem Name-Feld der Zielspezifikation muss in den Eigenschaften für die Quellspezifikationsverknüpfungen die Option Namen kopieren festgelegt werden. Weitere Informationen finden Sie unter Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen.

    • Für jede Verknüpfung mit dem Value-Feld der Zielspezifikation muss in den Eigenschaften für die Quellspezifikationsverknüpfungen die Option Wert kopieren festgelegt werden. Weitere Informationen finden Sie unter Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen.

    • Für die Verknüpfung, die das Funktoid Schleife mit dem Datensatz Record1 in der Zielspezifikation verbindet, muss in den Eigenschaften für die Zielspezifikationsverknüpfungen die Option Verknüpfungen von oben nach unten zuordnen festgelegt werden. Weitere Informationen dazu finden Sie unter Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen.

    • Stellen Sie sicher, dass im Dialogfeld Optionen für den BizTalk-Mapper die Option Mehrere Eingaben in Zielstrukturknoten zulassen aktiviert ist. Weitere Informationen finden Sie unter Optionen für den BizTalk-Mapper: Registerkarte "Allgemein".

Verwandte Themen

Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen

Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen

Verwenden des Funktoids "Wertezuordnung (Flattening)"


Integrieren der BizTalk-Dienste mithilfe von Zuordnungen

Wenn Sie die BizTalk-Orchestrierungsdienste und die BizTalk-Messagingdienste mithilfe eines anderen Transports als HTTP integrieren, müssen Sie gegebenenfalls eine Zuordnung erstellen, um einen Pfadnamen in einen Formatnamen zu konvertieren. Weitere Informationen finden Sie unter Integrieren der BizTalk-Dienste.

Konvertieren eines Pfadnamens in einen Formatnamen

Der folgende Code ist ein Beispiel eines Pfadnamens einer Nachrichtenwarteschlange:

private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Sie müssen die folgende Zeichenfolge vor den Pfadnamen setzen, um diesen Pfadnamen in einen Formatnamen zu konvertieren:

queue://Direct=OS:

Dazu können Sie das Funktoid Verketten verwenden.

Die folgende Abbildung zeigt eine Zuordnung, bei der das Funktoid Verketten zum Verknüpfen von zwei oder mehreren Zeichenfolgen verwendet wird. Weitere Informationen zum Funktoid Verketten finden Sie unter Zeichenfolgenfunktoide.

Pfadname in Formatnamen

Wenn Sie auf das Funktoid Verketten doppelklicken, werden dessen Eigenschaften angezeigt. Die folgende Abbildung zeigt die Eigenschaften des Funktoids Verketten bei einer Zuordnung, die das Präfix queue://Direct=OS: zum Pfadnamen private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73} hinzufügt.

Weitere Informationen finden Sie unter Bearbeiten von Funktoideigenschaften.

Eigenschaften des Funktoids Verketten


Kompilieren von Zuordnungen

Wenn Sie Zuordnungen kompilieren, generiert die BizTalk Mapper-Compilerkomponente ein XSL-Stylesheet (Extensible Stylesheet Language). Dieser Prozess erstellt eine kompilierte Zuordnung, die ein Instanzdokument des Quellschemas in ein Instanzdokument des Zielschemas umwandeln kann. Das Kompilieren einer Zuordnung erzwingt die Anwendung der strukturbezogenen Regeln und Transformationen, die im Zuordnungsraster angegeben sind.

Transformationen, wie beispielsweise Verknüpfungen, werden in derselben Reihenfolge verarbeitet, in der die Datensätze und Felder innerhalb der Instanz der Zielstruktur angezeigt werden. Wenn der BizTalk-Mapper beispielsweise einen Zieldatensatz oder ein Zielfeld erreicht, dem eine Verknüpfung zugeordnet ist, kompiliert der BizTalk-Mapper die Eigenschaften der Verknüpfung. Die Aktion kann ein einfaches Kopieren von Werten aus einem Datensatz oder Feld in der Quellspezifikation sein. Sie kann aber auch die Berechnung von Werten sein, die basierend auf den Eigenschaften eines Funktoids aus einem oder mehreren Datensätzen und Feldern der Quelle gewonnen und in eines oder mehrere Datensatz- und Feldelemente des Ziels übertragen werden.

Der BizTalk-Mapper generiert auf der Registerkarte Warnungen eine Warnmeldung, wenn der Compiler eine Situation findet, die möglicherweise zu einer fehlerhaften Ausgabe führt. Wenn z. B. ein Funktoid, das einen Eingabeparameter erfordert, keine Eingabeparameter aufweist, generiert der BizTalk-Mapper bei der Kompilierung der Zuordnung eine entsprechende Warnmeldung auf der Registerkarte Warnungen. Es wird empfohlen, eine Zuordnung erst in einer Produktionsumgebung zu verwenden, wenn diese keine Warnungen mehr generiert.

Die kompilierte Zuordnung wird von BizTalk Server verwendet, um die eigentliche Übersetzung einer Eingabeinstanz in eine Ausgabeinstanz durchzuführen.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Compilerdirektiven

Verwandtes Thema

Zuordnen der Ebenen innerhalb der Knotenhierarchie


Compilerdirektiven

Beim Erstellen einer von einem Element ausgehenden Zuordnung sehen typische XSLTs (Extensible Stylesheet Language Transformation) so aus:

<xsl:attribute name='CatalogPurposeCode'>
<xsl:value-of select='BCT/BCT01/text()'/>
</xsl:attribute>

Wenn BCT01 gemischten Inhalt enthält, ermöglicht die Verwendung von text() den Zugriff auf den ersten Text nur bis zum ersten untergeordneten Elements. Wird text() in dieser XSLT-Anweisung nicht verwendet, ist das Ergebnis, dass der gesamte Textinhalt sowie sämtlicher Textinhalt der untergeordneten Elemente als eine Textzeichenfolge zugeordnet wird. Der BizTalk-Mapper bietet jedoch ein Feature, mit dem Sie das Kopieren von Werten der Knoten in der Struktur der Quellspezifikation steuern können.

Wenn Sie mit der rechten Maustaste auf eine Verknüpfung klicken, die mit einem Knoten in der Struktur der Quellspezifikation verbunden ist, und Eigenschaften auswählen, können Sie angeben, wie der BizTalk-Mapper die Transformation von Daten verarbeiten soll. Die folgenden Optionen sind verfügbar:

  • Wert kopieren (Standard). Kopiert den Wert des Knotens in die eingehende Dokumentinstanz. <Node>Hello<Name>Chris</Name>Cannon</Node> ergibt z. B. Hello.

  • Text und untergeordnete Inhaltswerte kopieren. Kopiert den verketteten Wert des Knotens und alle Werte nachfolgender Elemente in die eingehende Dokumentinstanz. <Node>Hello<Name>Chris</Name>Cannon</Node> ergibt z. B. HelloChrisCannon.

  • Namen kopieren. Kopiert den Namen des Knotens in die eingehende Dokumentinstanz.

Sie können nun auch steuern, wie Hierarchien im BizTalk-Mapper verarbeitet werden, indem Sie mit der rechten Maustaste auf eine Verknüpfung klicken, die mit einem Knoten in der Struktur der Zielspezifikation verbunden ist, und Eigenschaften auswählen. Weitere Informationen zu diesen Compilerdirektiven finden Sie unter Zuordnen der Ebenen innerhalb der Knotenhierarchie.

Verwandte Themen

Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen

Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen


Testen von Zuordnungen

Sie können während der Erstellung einer Zuordnung mithilfe des BizTalk-Mappers überprüfen, ob die von Ihnen entworfene Zuordnung die richtige Ausgabe liefert. Das Feature Zuordnung testen (eine Option im Menü Extras) generiert automatisch aus der Spezifikation eine Testinstanz des Quelldokuments. Dieses Feature verwendet Informationen aus der Quellspezifikation, wie z. B. die Anzahl des Auftretens eines Datensatzes und die Datentypen von Feldern, und generiert die Testinstanz. Sie können auf der Registerkarte Werte im Feld Quelltestwert für jeden Datensatz und jedes Feld einen Wert angeben und die Ergebnisse dieser Daten testen.

Der BizTalk-Mapper unterstützt Instanzen als Systemeigen oder XML (Extensible Markup Language). Darüber hinaus unterstützt der BizTalk-Mapper gegebenenfalls systemeigene Ausgaben des Zuordnungstests. Je nach Quell- und Zielspezifikation, die die Zuordnung bilden, stehen für den Test der Zuordnung eine oder mehrere Optionen in der folgenden Tabelle zur Verfügung.

Optionen zum Testen der Zuordnung | Beschreibung
Generiertes XML in XML | Eine Testinstanz des Quelldokuments wird erstellt und dem Stylesheet zugeführt. Die Ausgabe wird im Fenster Ausgabe als XML angezeigt.
Generiertes XML in Systemeigen | Eine Testinstanz des Quelldokuments wird erstellt und dem Stylesheet zugeführt. Die Ausgabe wird in das systemeigene Format serialisiert und im Fenster Ausgabe als systemeigene Daten angezeigt. Die Option steht nicht zur Verfügung, wenn das Ausgabeschema XML ist.
Instanz-XML in XML | Eine angegebene Instanzdatei wird zum Erstellen der Ausgabe verwendet, die im Fenster Ausgabe als XML angezeigt wird.
Instanz-XML in Systemeigen | Eine angegebene Instanzdatei wird zum Erstellen der Ausgabe verwendet, die im Fenster Ausgabe als systemeigene Daten angezeigt wird. Die Option steht nicht zur Verfügung, wenn das Ausgabeschema XML ist.
Systemeigene Instanz in XML | Eine angegebene systemeigene Instanzdatei wird zum Erstellen der Ausgabe verwendet, die im Fenster Ausgabe als XML angezeigt wird. Für das Format der angegebenen Instanz wird angenommen, dass es dem Standard des Eingabeschemas entspricht. Die Option steht nicht zur Verfügung, wenn das Eingabeschema XML ist.
Systemeigene Instanz in Systemeigen | Eine angegebene systemeigene Instanzdatei wird zum Erstellen der Ausgabe verwendet, die im Fenster Ausgabe als systemeigene Daten angezeigt wird. Für das Format der angegebenen Instanz wird angenommen, dass es dem Standard des Eingabeschemas entspricht. Die Option steht nicht zur Verfügung, wenn das Ein- oder Ausgabeschema XML ist.

Beim Testen einer Zuordnung kompiliert der BizTalk-Mapper diese automatisch. Es empfiehlt sich jedoch, zuerst die Zuordnung zu kompilieren und alle Warnungen und Fehler aufzulösen, bevor Sie die Zuordnung testen. Bevor der Test beginnt, werden Sie aufgefordert, die Zuordnungsdatei zu speichern. Das Speichern der Datei vor dem Testen ist eine Vorsichtsmaßnahme, die den Zweck hat, die Zuordnungsdaten für den Fall zu sichern, dass beim Testen unbeabsichtigt Probleme in der Zuordnung auftreten.

Der BizTalk-Mapper bietet die Möglichkeit, vor dem Zuordnungstest die Quellinstanzdaten mit der Quellspezifikation abzugleichen. Wenn eine der verwendeten Spezifikationen in der Zuordnung keine auf BizTalk Server basierende Spezifikation ist, wie z. B. eine XDR-Datei (XML-Data Reduced) und Sie das Inhaltsüberprüfungsfeature verwenden, kann die Überprüfung fehlschlagen. Wenn beim Öffnen der XDR-Datei Warnmeldungen angezeigt wurden, insbesondere zu Namespaces oder Elementgruppen, sollten Sie das Inhaltsüberprüfungsfeature nicht verwenden.

Der BizTalk-Mapper bietet auch die Möglichkeit, den Inhalt zu überprüfen, nachdem der Zuordnungsvorgang abgeschlossen ist. In diesem Fall gleicht der BizTalk-Mapper die Ausgabedaten mit der Zielspezifikation ab. Wenn wie bei der Funktionalität Inhalt vor Zuordnungstest überprüfen eine der verwendeten Spezifikationen in der Zuordnung eine nicht auf BizTalk Server basierende Spezifikation ist, wie z. B. eine XDR-Datei, und Sie das Inhaltsüberprüfungsfeature verwenden, kann die Überprüfung fehlschlagen. Wenn beim Öffnen der XDR-Datei Warnmeldungen angezeigt wurden, insbesondere zu Namespaces oder Elementgruppen, sollten Sie das Inhaltsüberprüfungsfeature nicht verwenden.

Nach dem Testen der Zuordnung werden die Ergebnisse des Tests auf der Registerkarte Ausgabe angezeigt. Die Testdaten entsprechen der Zielspezifikation.

Folgendes Thema wird in diesem Abschnitt behandelt:

  • Festlegen von Dokumenttrennzeichen

Verwandte Themen

Optionen für den BizTalk-Mapper: Registerkarte "Dokumenttrennzeichen"

Optionen für den BizTalk-Mapper: Registerkarte "Allgemein"

Testen von Zuordnungen

Testen von Eigenschaften für verknüpfte Datensätze und Felder testen


Festlegen von Dokumenttrennzeichen

Der BizTalk-Mapper ermöglicht während des Zuordnungstests das Angeben von Trennzeichen. Auf der Registerkarte Dokumenttrennzeichen können Sie Standardtrennzeichen angeben, die für die Tests verwendet werden. Sie können auch angeben, ob das Dialogfeld Dokumenttrennzeichen automatisch angezeigt werden soll, wenn Sie eine Zuordnung testen. Sie können eindeutige Trennzeichen für Datensätze und Felder in der Struktur der Quellspezifikation und der Zielspezifikation angeben. Sie können die Trennzeichen einmalig festlegen oder sich vom BizTalk-Mapper bei jedem Test zur Angabe bestimmter Trennzeichen auffordern lassen.

In der folgenden Tabelle sind die Standardwerte für Trennzeichen aufgeführt.

Trennzeichen | Wert
Datensatztrennzeichen | ~ (0x7e)
Feldtrennzeichen | * (0x2a)
Unterfeldtrennzeichen | > (0x3e)
Escape | ? (0x3f)


Gründe für das Durchführen von BizTalk-Mapper-Aufgaben

Dieser Abschnitt stellt eine kurze Referenz zum Durchführen von BizTalk-Mapper-Aufgaben bereit. Die folgende Tabelle enthält Beschreibungen der Hauptaufgaben sowie der jeweiligen Unteraufgaben, Erläuterungen zum Zweck jeder Aufgabe und Links zu den entsprechenden Verfahren.

Aufgabe Zweck
Ändern der Optionen für den BizTalk-Mapper:
  • Optionen für den BizTalk-Mapper: Registerkarte "Allgemein"
 Anpassen des Verhaltens des BizTalk-Mappers in Bezug auf das:
  • Empfangen von Warnungen

  • Anzeigen und Löschen von Compilerverknüpfungen

  • Zulassen von Verknüpfungen für Datensatzinhalte

  • Zulassen mehrerer Eingaben in die Struktur der Zielspezifikation

  • Speichern von Inhalten

  • Prüfen von Inhalten
  • Optionen für den BizTalk-Mapper: Registerkarte "Farben"
 Anpassen der Farben auf dem Zuordnungsraster.
  • Optionen für den BizTalk-Mapper: Registerkarte "Dokumenttrennzeichen"
 Wenn eine Spezifikation über eine Struktur mit Trennzeichen verfügt, müssen Sie für Instanztests Dokumenttrennzeichen festlegen. Dokumenttrennzeichen sind für Microsoft BizTalk Server 2002 erforderlich, um Daten in einer Produktionsumgebung zu verarbeiten.
  • Optionen für den BizTalk-Mapper: Registerkarte "XSLT-Ausgabe"
 Weglassen oder Einbeziehen einer XML-Deklaration bei der Datenausgabe.
Erstellen, Öffnen und Speichern von Zuordnungen:
  • Erstellen neuer Zuordnungen
 Ermöglichen der Verarbeitung von Datentransformationen von einer Quelle in eine andere mithilfe von Verknüpfungen und Funktoiden.
  • Öffnen von Zuordnungen von einer lokalen Festplatte
 Wenn Sie eine lokale Kopie einer Zuordnung bearbeiten möchten. Sie möchten z. B. Änderungen vornehmen und die Zuordnung anschließend ohne Auswirkungen für die gemeinsame Kopie testen, die in Web Distributed Authoring and Versioning (WebDAV) gespeichert ist.
  • Abrufen von Zuordnungen aus WebDAV
 Wenn Sie die gemeinsame Kopie einer Zuordnung bearbeiten möchten, auf die auch andere Benutzer zur Bearbeitung zugreifen können. Dies ist die Datei, die der BizTalk-Messaging-Manager bei der Verarbeitung von Transaktionen verwendet.
  • Öffnen einer vorhandenen Zuordnungen in einem Ordner
 Wenn Sie eine lokale Kopie einer Zuordnung bearbeiten möchten. Sie möchten z. B. Änderungen vornehmen und die Zuordnung anschließend ohne Auswirkungen für die gemeinsame Kopie testen, die in WebDAV gespeichert ist.
  • Speichern von neuen Zuordnungen
 Wenn Sie eine lokale Kopie einer Zuordnung speichern möchten, die Sie gerade erstellt haben. Sie möchten z. B. eine gerade erstellte Zuordnung ohne Auswirkungen für die gemeinsame Kopie speichern, die in WebDAV gespeichert ist.
  • Speichern von vorhandenen Zuordnungen
 Wenn Sie eine lokale Kopie einer Zuordnung speichern möchten, die Sie bearbeitet haben. Sie möchten z. B. eine bearbeitete Zuordnung ohne Auswirkungen für die gemeinsame Kopie speichern, die in WebDAV gespeichert ist.
  • Speichern von kompilierten Zuordnungen
 Erstellen einer Zuordnung, die von BizTalk Server dazu verwendet wird, zur Laufzeit die eigentliche Übersetzung einer Eingabeinstanz in eine Ausgabeinstanz durchzuführen. Der Kompilierungsprozess speichert alle Informationen zur Quellspezifikation und Zielspezifikation einschließlich aller Inhalte und Funktionen von Verknüpfungen und Objekten.
  • Speichern von Zuordnungen
 Wenn Sie eine Zuordnung über WebDAV dem BizTalk-Messaging-Manager zur Verfügung stellen müssen. Dadurch wird die Datei auch anderen Benutzern zur Verfügung gestellt.
Ersetzen von Spezifikationen:
  • Ersetzen von Quellspezifikationen
 Beim Erstellen einer Zuordnung ist es wahrscheinlich, dass die Quellspezifikation einer weiteren Bearbeitung unterzogen wird, z. B. durch Hinzufügen weiterer Datensätze oder Felder. Mithilfe dieser Funktion können Sie die Quellspezifikation ersetzen und alle (oder nahezu alle) Verknüpfungen und Funktoide beibehalten, die Sie in der Zuordnung zwischen der Quell- und der Zielspezifikation erstellt haben.
  • Ersetzen von Zielspezifikationen
 Beim Erstellen einer Zuordnung ist es wahrscheinlich, dass die Zielspezifikation einer weiteren Bearbeitung unterzogen wird, z. B. durch Hinzufügen weiterer Datensätze oder Felder. Mithilfe dieser Funktion können Sie die Zielspezifikation ersetzen und alle (oder nahezu alle) Verknüpfungen und Funktoide beibehalten, die Sie in der Zuordnung zwischen der Quell- und der Zielspezifikation erstellt haben.
Arbeiten mit Rasterseiten:
  • Hinzufügen von Rasterseiten
 Wenn Sie die Ansicht einer Zuordnung vereinfachen möchten. Wenn Sie eine Rasterseite hinzufügen, können Sie z. B. alle Verknüpfungen und Funktoide, die sich auf Kopfzeileninformationen auf einer Seite beziehen, auf einer Seite und Verknüpfungen und Funktoide, die sich auf den Textkörper der Zuordnung beziehen, auf einer anderen Seite ablegen. Darüber hinaus können Sie erstellte Rasterseiten umbenennen und löschen.
Hinzufügen von und Arbeiten mit Funktoiden:
  • Hinzufügen von Zeichenfolgenfunktoiden
 Bearbeiten von Datenzeichenfolgen. Beispielsweise sucht das Funktoid Zeichenfolge suchen nach einer Textzeichenfolge innerhalb einer anderen Textzeichenfolge und gibt als Ergebnis die Position des ersten Zeichens der gefundenen Zeichenfolge zurück.
  • Hinzufügen von mathematischen Funktoiden
 Durchführen von Berechnungen mithilfe spezieller Werte, die als Argumente bezeichnet werden, in einer bestimmten Reihenfolge oder Struktur. Das Funktoid Addition addiert z. B. die Werte der bezeichneten Felder oder Datensätze.
  • Hinzufügen von logischen Funktoiden
 Durchführen bestimmter logischer Tests. Wenn ein logisches Funktoid z. B. mit einem Datensatz der Zielspezifikation verknüpft ist und den Wert TRUE zurückgibt, wird der entsprechende Datensatz im Ausgabedokument generiert. Wenn ein logisches Funktoid mit einem Datensatz der Zielspezifikation verknüpft ist und den Wert FALSE zurückgibt, wird der entsprechende Datensatz im Ausgabedokument nicht generiert.

Sie müssen gegebenenfalls auch ein logisches Funktoid hinzufügen, das als Eingabewert für andere Funktoide in einer Zuordnung dient.

  • Hinzufügen von Datums- und Uhrzeitfunktoiden
 Bearbeiten datums- und zeitbezogener Daten oder Hinzufügen des aktuellen Datums und der aktuellen Zeit oder anderer Datums- und Zeitdaten zu einem Datensatz oder Feld der Zielspezifikation.
  • Hinzufügen von Konvertierungsfunktoiden
 Konvertieren von Daten. Diese Funktoide können beispielsweise auch dazu verwendet werden, ein Zeichen in dessen ASCII-Wert oder einen Wert in das entsprechende ASCII-Zeichen zu konvertieren. Konvertierungsfunktoide ähneln weitgehend entsprechenden Hilfsfunktionen des Software Engineering wie z. B. DEC2HEX, die einen Hexadezimalwert für einen gegebenen Dezimalwert zurückgibt.
  • Hinzufügen von wissenschaftlichen Funktoiden
 Konvertieren eines numerischen Wertes in einen Wert einer mathematischen Funktion. Beispielsweise verwendet das Funktoid Kosinus als Argument den Wert eines Feldes oder Datensatzes und gibt als Ergebnis den Kosinus dieses Wertes als Winkel in Bogenmaß (Radiant) zurück.
  • Hinzufügen von kumulativen Funktoiden
 Zurückgeben der Summe, des Mittelwertes oder des Minimums bzw. Maximums der Eingabewerte eines Schleifendatensatzes.
  • Hinzufügen von Datenbankfunktoiden
 Verarbeiten der Transformationen codierter Daten in uncodierte Daten. Angenommen, ein Unternehmen verwendet einen Code, der den Namen eines Geschäfts und eine Adresse repräsentiert. Ein Handelspartner muss anschließend den tatsächlichen Namen des Geschäfts und die Adresse kennen, um eine Transaktion zu verarbeiten. Mithilfe eines Datenbankfunktoids kann BizTalk Server einen Code in einer Datenbank suchen und diesen durch den tatsächlichen Wert des Codes ersetzen.
  • Hinzufügen des Funktoids "Skripterstellung"
 Verwenden benutzerdefinierter Microsoft Visual Basic-Skripts oder von Microsoft JScript zum Ausführen benutzerdefinierter Vorgänge, die mit den in der Funktoidpalette enthaltenen Funktoiden nicht möglich sind.
  • Hinzufügen des Funktoids "Anzahl der Datensätze"
 Bestimmen der Gesamtzahl der Objekte, die zu einem Schleifendatensatz gehören.

Das Funktoid Anzahl der Datensätze kann z. B. zum Zählen der Auftragsposten verwendet werden, die in einem eingehenden Auftrag enthalten sind, und diesen Wert in ein Feld in der ausgehenden Rechnung übertragen.
  • Hinzufügen des Funktoids "Index"
 Zugreifen auf ein bestimmtes Vorkommen eines Datensatzes, der wiederholt wird. Wenn z. B. ein Auftragsposten sechsmal wiederholt wird und Sie nur den Wert des dritten Vorkommens abrufen möchten, können Sie das Funktoid Index verwenden.
  • Hinzufügen des Funktoids "Iteration"
 Identifizieren, welche Reihenfolgenummer eines Schleifendatensatzes gerade einem gegebenen Zeitpunkt zugeordnet wird.
  • Hinzufügen des Funktoids "Wertezuordnung"
 Verschieben von Daten, die eine logische Anforderung wie TRUE oder FALSE erfüllen.
  • Hinzufügen des Funktoids "Wertezuordnung (Flattening)"
 Verschieben von Daten, die eine logische Anforderung wie TRUE oder FALSE erfüllen. Dieses Funktoid ähnelt dem Funktoid Wertzuordnung, doch wird in diesem Fall die Hierarchie vereinfacht. Dies bedeutet Folgendes: Wird ein Objekt in der Struktur der Quellspezifikation dreimal wiederholt, wird in der Struktur der Zielspezifikation nur ein Vorkommen erstellt.
  • Hinzufügen des Funktoids "Schleife"
 Erzwingen, dass der Compiler die Daten in der Struktur der Zielspezifikation gemäß dem Schleifenverhalten der Daten der Struktur der Quellspezifikation in einer Schleife durchläuft. Dies wird als paralleles Schleifenverhalten bezeichnet, das in der Regel explizit ist und automatisch erfolgen sollte. Bei einigen komplexen Zuordnungen kann es jedoch erforderlich sein, das Funktoid Schleife zu verwenden, um dieses Verhalten zu erzwingen.
  • Verschieben von Funktoiden und Verknüpfungen zwischen Rasterseiten
 Vereinfachen der Komplexität der Rasterseite, die bei zahlreichen Verknüpfungen und Funktoiden komplex werden kann.
  • Informationen zu Funktoidparametern
 Eindeutiges Angeben der Parameteranforderungen der einzelnen Funktoide.
  • Eingabeparameter
 Festlegen von Parametern, wie z. B. eines konstanten Wertes, für ein Funktoid. Sie können Eingabeparameter auch umbenennen oder nach oben oder unten verschieben (in Situationen, in denen die Reihenfolge der Parameter von Bedeutung ist), um die Verarbeitung der Parameter durch den BizTalk-Mapper zu ändern.
Hinzufügen von und Arbeiten mit Verknüpfungen:
  • Erstellen von Verknüpfungen zwischen Feldern
 Kopieren von Daten aus einem Feld der Struktur der Quellspezifikation in ein Feld der Struktur der Zielspezifikation.
  • Erstellen von Verknüpfungen zwischen Feldern und Funktoiden
 Kopieren von Daten aus einem Feld der Struktur der Quellspezifikation in ein Funktoid, was für die weitere Bearbeitung erforderlich ist, bevor die Ausgabe in die Struktur der Zielspezifikation erfolgt.
  • Erstellen von Verknüpfungen zwischen Datensätzen und Feldern
 Kopieren von Daten aus einem Datensatz der Struktur der Quellspezifikation in ein Feld der Struktur der Zielspezifikation.

Wichtig

  • Um diese Aufgabe durchzuführen, müssen Sie im Dialogfeld Optionen für den BizTalk-Mapper die Option Verknüpfungen von Datensatzinhalten zulassen aktivieren.
  • Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden
 Kopieren von Daten aus einem Datensatz der Struktur der Quellspezifikation in ein Funktoid, was für die weitere Bearbeitung erforderlich ist, bevor die Ausgabe in die Struktur der Zielspezifikation erfolgt.

Wichtig

  • Um diese Aufgabe durchzuführen, müssen Sie im Dialogfeld Optionen für den BizTalk-Mapper die Option Verknüpfungen von Datensatzinhalten zulassen aktivieren.
  • Erstellen von Verknüpfungen zwischen Funktoiden
 Ausführen von Aufgaben, für die mehrere Funktoide erforderlich sind, um die korrekte Ausgabe in der Struktur der Zielspezifikation zu generieren.
  • Zulassen von Verknüpfungen für Datensatzinhalte
 Ermöglichen der Erstellung von Verknüpfungen zwischen Datensätzen und Feldern oder zwischen Datensätzen und Funktoiden.
  • Umleiten von Verknüpfungen
 Wenn Sie beim Zeichnen einer Verknüpfung einen Fehler begangen haben und eine der Endpunktverknüpfungen neu zeichnen möchten.
  • Anzeigen von Verknüpfungen und Funktoiden im Zuordnungsraster
 Durchlaufen des Rasterbereichs, um alle Verknüpfungen und Funktoide anzuzeigen, die im Raster vorhanden sind.
  • Anzeigen von Verknüpfungen und Funktoiden mithilfe der Rastervorschau
 Anzeigen der Stellen, an denen sich die Funktoide im Zuordnungsraster befinden.
  • Anzeigen von Verknüpfungseigenschaften: Registerkarte "Allgemein"
 Anzeigen von Informationen zur Quelle und zum Ziel einer Verknüpfung.
  • Anzeigen von Verknüpfungseigenschaften: Registerkarte "Compiler"
 Anzeigen der festgelegten Compilereigenschaften für Quellspezifikationsverknüpfungen und der Compilereigenschaften für Zielspezifikationsverknüpfungen.
  • Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen
 Steuern, wie der Compiler die Ausgabestruktur durchsucht, wenn Sie beispielsweise Textwerte, Text und untergeordnete Inhaltswerte oder Namen aus der Struktur der Quellspezifikation kopieren möchten.
  • Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen
 Steuern, wie der Compiler die Ausgabestruktur durchsucht. Sie können z. B. Verknüpfungen vereinfachen oder Verknüpfungen von oben nach unten bzw. von unten nach oben abgleichen lassen. Weitere Informationen finden Sie unter Zuordnen der Ebenen innerhalb der Knotenhierarchie.
Erstellen und Verwalten kompilierter Zuordnungen:
  • Kompilieren von Zuordnungen
 Kompilieren einer Zuordnung, die von BizTalk Server dazu verwendet wird, zur Laufzeit die eigentliche Übersetzung einer Eingabeinstanz in eine Ausgabeinstanz durchzuführen. Der Kompilierungsprozess speichert alle Informationen zur Quell- und Zielspezifikation einschließlich aller Inhalte und Funktionen von Verknüpfungen und Objekten.
  • Auflösen von Warnungen und Beheben von Fehlern nach dem Kompilieren einer Zuordnung
 Suchen der Fehler in der Zuordnung und Bestimmen einer Behebungsmöglichkeit.
  • Hinzufügen von konstanten Werten
 Erstellen von Testdaten für ein Feld in der Struktur der Quellspezifikation oder Hinzufügen eines konstanten Laufzeitwertes zu einem Feld in der Struktur der Zielspezifikation.
Durchführen von Zuordnungstests:
  • Testen von Eigenschaften von Datensätzen und Feldern mit Verknüpfungen
 Prüfen, ob die in der Zuordnung enthaltenen Verknüpfungen die korrekte Ausgabe liefern.
  • Testen von Zuordnungen
 Prüfen, ob die erstellte Zuordnung die korrekte Ausgabe liefert. Geprüft werden z. B. die Anzahl der Vorkommen von Datensätzen, die Datentypen von Feldern usw. Der Vorgang umfasst das Generieren einer Testinstanz des Quelldokuments aus der Spezifikation.
Verwalten von Ansichten, Anpassen der Benutzeroberfläche und Verwenden von Tastenkombinationen:
  • Erweitern von Strukturelementen
 Anzeigen aller Datensätze und Felder in einer Spezifikation aus Sicht des Stammknoten-Datensatzes oder der Datensätze und Felder aus Sicht eines einzelnen Datensatzes.
  • Reduzieren von Strukturelementen
 Ausschließliches Anzeigen des Stammknoten-Datensatzes und/oder der übergeordneten Datensätze.
  • Anzeigen von Datensatz- und Feldeigenschaften
 Anzeigen der Eigenschaften eines Datensatzes oder Felds, der/das mit den Registerkarten Deklaration, Verweis, Analysieren, Namespace, Wörterbuch oder Codeliste im BizTalk-Editor verknüpft ist.
  • Anpassen der Fenstergröße für die Struktur der Quellspezifikation
 Vergrößern oder Verkleinern der Ansicht der Struktur der Quellspezifikation oder des Zuordnungsrasterbereichs.
  • Anpassen der Fenstergröße für die Struktur der Zielspezifikation
 Vergrößern oder Verkleinern der Ansicht der Struktur der Zielspezifikation oder des Zuordnungsrasterbereichs.
  • Ändern der Größe des unteren Fensters
 Vergrößern oder Verkleinern der Ansicht des Inhalts der Registerkarten Eigenschaften, Werte, Ausgabe und Warnungen.
  • Ändern der Farben des Zuordnungsrasters
 Ändern der Farbe des Bereichs Rastervordergrund, welche die gestrichelten Linien im Zuordnungsraster darstellt oder der Farbe des Bereichs Rasterhintergrund, welche die Hintergrundfarbe des Zuordnungsrasters darstellt.
  • Ändern der Farbe von Verknüpfungen
 Ändern der Farbe fester und elastischer sowie von Teil- und Compilerverknüpfungen.
  • Ändern der Farbe von ausgewählten Objekten
 Ändern der Farbe von Objekten, die Sie mit dem Mauszeiger auswählen.
  • Ändern der Farbe von Compilerwarnungen
 Ändern der Farbe der Datensätze und Felder, die markiert werden, wenn eine Warnung erzeugt wurde.
  • Wiederherstellen der Standardfarben
 Zurücksetzen aller Farboptionen auf die Standardeinstellungen.
  • Ändern der Textgröße
 Vergrößern oder Verkleinern des Schriftgrades von Text im BizTalk-Mapper.
  • BizTalk-Mapper - Tastenkombinationen
 Verwenden von Tastenkombinationen anstelle der Maus zum Ausführen von Aufgaben.


Durchführen von BizTalk-Mapper-Aufgaben

Dieser Abschnitt stellt aufgabenspezifische Informationen zum Zuordnen von Daten von einer Spezifikation zu einer anderen bereit. Es wird dringend empfohlen, dass Sie den Abschnitt Informationen zum BizTalk-Mapper lesen, um Verknüpfungen und Funktoide sowie andere Eigenschaften und Funktionalität der Zuordnung vollständig zu verstehen.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Ändern der Optionen für den BizTalk-Mapper

  • Erstellen neuer Zuordnungen

  • Öffnen von Zuordnungen

  • Speichern und Schließen von Zuordnungen

  • Ersetzen von Spezifikationen

  • Arbeiten mit Rasterseiten

  • Verwalten von Funktoiden

  • Verwalten von Verknüpfungen

  • Erstellen und Verwalten von kompilierten Zuordnungen

  • Ausführen von Zuordnungstests

  • Verwalten von Ansichten

  • Anpassen der Benutzeroberfläche

  • BizTalk-Mapper - Tastenkombinationen


Ändern der Optionen für den BizTalk-Mapper

Im Dialogfeld Optionen für den BizTalk-Mapper können Sie allgemeine Optionen festlegen und Farben für das Zuordnungsraster wählen.

  • Klicken Sie im Menü Extras auf Optionen, um das Dialogfeld Optionen für den BizTalk-Mapper aufzurufen.

    Die Registerkarte Allgemein wird als Standardregisterkarte angezeigt.

Weitere Informationen zur Verwendung des Dialogfeldes Optionen für den BizTalk-Mapper finden Sie unter den folgenden Verfahren:

  • Optionen für den BizTalk-Mapper: Registerkarte "Allgemein"

  • Optionen für den BizTalk-Mapper: Registerkarte "Farben"

  • Optionen für den BizTalk-Mapper: Registerkarte "Dokumenttrennzeichen"

  • Optionen für den BizTalk-Mapper: Registerkarte "XSLT-Ausgabe"


Optionen für den BizTalk-Mapper: Registerkarte "Allgemein"

Weitere Informationen zum Zugriff auf das Dialogfeld Optionen für den BizTalk-Mapper finden Sie unter Ändern der Optionen für den BizTalk-Mapper.

Die Registerkarte Allgemein stellt acht Optionen bereit, mit deren Hilfe Sie das Verhalten des BizTalk-Mappers benutzerdefiniert festlegen können.

  • Warnungen für einfache Verknüpfungsfehler (als Standardeinstellung ausgewählt). Sie erhalten eine Warnung, wenn Sie versuchen, eine Verknüpfung zwischen Knoten zu erstellen, deren Datentypen nicht zusammenpassen.

  • Compilerverknüpfungen anzeigen (als Standardeinstellung ausgewählt). Compilerverknüpfungen werden nach dem Kompilieren in einer Verknüpfung angezeigt.

  • Compilerverknüpfungen nach Benutzeraktion löschen (als Standardeinstellung deaktiviert). Compilerverknüpfungen werden nicht mehr angezeigt, nachdem im BizTalk-Mapper eine Aktion ausgeführt wurde.

  • Verknüpfungen von Datensatzinhalten zulassen (als Standardeinstellung aktiviert). Inhaltsverknüpfungen von Datensätzen zu Funktoiden können erstellt werden.

    Anmerkung

    • Bestimmte Funktoide arbeiten mit Ein- und/oder Ausgabe, die keinen Datensatzinhalt verwendet. Die Option Verknüpfungen von Datensatzinhalten zulassen hat in diesem Fall keine Auswirkung. Diese Ein- und Ausgabe besteht aus den logischen Funktoiden (Ausgabe): dem Funktoid Anzahl der Datensätze (Eingabe), dem Funktoid Iteration (Eingabe) und dem Funktoid Schleife (Eingabe und Ausgabe).
  • Mehrere Eingaben in Zielstrukturknoten zulassen (als Standardeinstellung deaktiviert). Zwei oder mehr Verknüpfungen können zu einem Knoten in der Verzeichnisstruktur der Zielspezifikation eingerichtet werden.

  • Vor dem Testen der Zuordnung zum Speichern auffordern (als Standardeinstellung aktiviert) Nachdem Sie im Menü Extras auf Zuordnung testen geklickt haben, zeigt der BizTalk-Mapper ein Dialogfeld an, das Sie fragt, ob Sie die Änderungen an der Zuordnungsdatei speichern möchten.

  • Inhalt vor Zuordnungstest überprüfen (als Standardeinstellung deaktiviert). Daten werden im Vergleich mit der Struktur der Quellspezifikation überprüft, bevor der Zuordnungsvorgang von der Quell- zur Zielspezifikation abgeschlossen ist.

    Anmerkung

    • Wenn eine der verwendeten Spezifikationen in der Zuordnung keine auf BizTalk Server basierende Spezifikation ist, wie z. B. eine XDR-Datei (XML-Data Reduced), und Sie die Inhaltsüberprüfungsfunktion verwenden, kann die Überprüfung misslingen. Wenn nach dem Öffnen der XDR-Datei Warnmeldungen angezeigt werden, insbesondere zu Namespaces oder Elementgruppen, sollten Sie die Inhaltsüberprüfungsfunktion nicht verwenden.
  • Inhalt nach Zuordnungstest überprüfen (als Standardeinstellung deaktiviert). Nachdem der Zuordnungsvorgang abgeschlossen ist, überprüft der BizTalk-Mapper die Daten in der Zielspezifikation.

    Anmerkung

    • Wenn eine der verwendeten Spezifikationen in der Zuordnung keine auf BizTalk Server basierende Spezifikation ist, wie z. B. eine XDR-Datei, und Sie die Inhaltsüberprüfungsfunktion verwenden, kann die Überprüfung misslingen. Wenn nach dem Öffnen der XDR-Datei Warnmeldungen angezeigt werden, insbesondere zu Namespaces oder Elementgruppen, sollten Sie die Inhaltsüberprüfungsfunktion nicht verwenden.

Verwandtes Thema

Optionen für den BizTalk-Mapper: Registerkarte "Farben"


Optionen für den BizTalk-Mapper: Registerkarte "Farben"

Weitere Informationen zum Zugriff auf das Dialogfeld Optionen für den BizTalk-Mapper finden Sie unter Ändern der Optionen für den BizTalk-Mapper.

Die Registerkarte Farben stellt Optionen bereit, mit denen Sie die Farben im Zuordnungsraster anpassen können. Weitere Informationen zu diesen Optionen finden Sie unter den folgenden Verfahren:

  • Ändern der Farben des Zuordnungsrasters

  • Ändern der Farbe von Verknüpfungen

  • Ändern der Farbe von ausgewählten Objekten

  • Ändern der Farbe von Compilerwarnungen

  • Wiederherstellen der Standardfarben

Verwandtes Thema

Optionen für den BizTalk-Mapper: Registerkarte "Allgemein"


Optionen für den BizTalk-Mapper: Registerkarte "Dokumenttrennzeichen"

Weitere Informationen zum Zugriff auf das Dialogfeld Optionen für den BizTalk-Mapper finden Sie unter Ändern der Optionen für den BizTalk-Mapper.

Die Registerkarte Dokumenttrennzeichen enthält Optionen zum Testen einer Zuordnung. Sie können für jeden Test eindeutige Trennzeichen angeben oder Standardtrennzeichen festlegen, um nicht während der Tests zur Angabe neuer Trennzeichen aufgefordert zu werden.

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Dokumenttrennzeichen.

  3. Wählen Sie im Bereich Trennzeichentyp entweder Quelltrennzeichen oder Zieltrennzeichen aus.

  4. Wählen Sie in den Dropdownlisten eine Option aus, oder geben Sie in die folgenden Felder eigene Trennzeichen ein:
    • Datensatztrennzeichen

    • Feldtrennzeichen

    • Unterfeldtrennzeichen

    • Escapezeichen

    Wichtig

    • Wenn Sie eigene Trennzeichen angeben, wählen Sie Unicode-Zeichenwerte. Eine Liste gültiger Zeichen finden Sie in der Microsoft Global Software Development-Website auf der Seite "Global codepages" (www.microsoft.com/globaldev/reference/wincp.asp). Sie können ANSI-Zeichencodes verwenden, wenn diese den Unicode-Zeichencodes entsprechen, von zwei führenden Nullen abgesehen.
  5. Wenn Sie nicht stets das Dialogfeld Dokumenttrennzeichen anzeigen möchten, wenn Sie eine Dokumentinstanz überprüfen, deaktivieren Sie das Feld Zur Eingabe von Trennzeichen bei Instanztests auffordern.

Wichtig

  • Das Null-Abschlusszeichen (Trennzeichen) wird nicht unterstützt. Wenn dieses unterstützt werden soll, müssen Sie das Null-Trennzeichen der Flatfile vor der Verarbeitung hinzufügen und nach der Verarbeitung aus dieser entfernen.

  • Wenn Sie im Verlauf eines Instanztests zur Angabe von Trennzeichen aufgefordert werden, da das Feld Zur Eingabe von Trennzeichen bei Instanztests auffordern aktiviert ist, werden die angegebenen Trennzeichen zum Testen dieser Instanz verwendet. Die auf der Registerkarte Dokumenttrennzeichen angegebenen Trennzeichen bleiben die Standardtrennzeichen.

  • Wenn das Feld Zur Eingabe von Trennzeichen bei Instanztests auffordern aktiviert ist und die getestete Instanz eine EDI-Datei mit Umschlaginformationen ist, wird das Dialogfeld Dokumenttrennzeichen nicht angezeigt, da der BizTalk-Mapper das benötigte Trennzeichen automatisch erkennt. Der BizTalk-Mapper zeigt das Feld Zur Eingabe von Trennzeichen bei Instanztests auffordern an, wenn Sie angegeben haben, dass es bei Instanztests angezeigt werden soll und die zu verwendenden Trennzeichen nicht ermittelt werden können.

Anmerkung

  • Wenn die Instanz mehrere Dokumente und Umschlaginformationen (Kopfzeile/Nachspann) enthält, wird nur das erste Dokument im Abgleich mit den auf der Registerkarte Dokumenttrennzeichen angegebenen Dokumenttrennzeichen überprüft.


Optionen für den BizTalk-Mapper: Registerkarte "XSLT-Ausgabe"

Weitere Informationen zum Zugriff auf das Dialogfeld Optionen für den BizTalk-Mapper finden Sie unter Ändern der Optionen für den BizTalk-Mapper.

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte XSLT-Ausgabe.

  3. Klicken Sie im Feld XML-Deklaration unterdrücken in der Dropdownliste auf Ja, um eine Deklaration zu unterdrücken, oder auf Nein, um die Deklaration einzubeziehen.

    Anmerkung

    • Dadurch wird angegeben, ob eine XML-Deklaration ausgegeben wird oder nicht. Wenn Sie Nein gewählt haben, wird eine XML-Deklaration wie die Folgende angezeigt:
      <?xml version="1.0" encoding="utf-8" ?
  4. Klicken Sie auf OK.


Erstellen neuer Zuordnungen

Um eine Zuordnung zu erstellen, müssen Sie sowohl eine Quell- als auch eine Zielspezifikation angeben.

  1. Klicken Sie im Menü Datei auf Neu.

    Das Dialogfeld Quellspezifikationstyp auswählen wird angezeigt.

  2. Doppelklicken Sie auf eine der folgenden Optionen:
    • Lokale Dateien, und gehen Sie zu Schritt 3.

    • Vorlagen, und gehen Sie zu Schritt 4.

    • WebDAV-Dateien, und gehen Sie zu Schritt 3.
  3. Suchen Sie den Ordner, der die Quellspezifikation enthält, die Sie öffnen möchten, und gehen Sie zu Schritt 5.

  4. Klicken Sie auf EDIFACT, X12 oder XML, und klicken Sie auf OK.

    Wenn Sie EDIFACT oder X12 auswählen, müssen Sie auch die Version auswählen, die Sie verwenden möchten. Klicken Sie auf den Ordner für die Version, die Sie verwenden möchten, klicken Sie auf OK, und gehen Sie dann zu Schritt 5.

    Wichtig

    • Wenn die X12-Vorlagen in der BizTalk Server-Installation im BizTalk-Mapper verwendet werden, kann eine Fehlermeldung wie die Folgende angezeigt werden:

      Die Länge des Feldes "ITD05" ("") ist nicht gültig; sie muss zwischen 48 und -1 liegen. Dieses Dokument wird zurückgewiesen.

      Die X12-Vorlagen verwenden den implizierten Dezimaldatentyp Nx. Wenn die Eingabedaten ein Dezimalkomma enthalten, entspricht die Ausgabe nicht dem benutzerdefinierten Datentyp N (der kein Dezimalkomma vorsieht), wodurch in der temporären XML-Datei ungültige Instanzen erstellt werden. In diesem Release von BizTalk Server erkennt die Serialisierungskomponente möglicherweise nicht, ob die temporäre XML-Datei für die Ausgabe des Datentyps N ein Dezimalkomma enthält. Sie müssen den implizierten Dezimaldatentyp in den X12-Vorlagen manuell in einen der anderen numerischen Datentypen ändern, um dieses Problem zu beheben.

  5. Wählen Sie die Quellspezifikation aus, und klicken Sie auf Öffnen bzw. OK.

    Das Dialogfeld Zielspezifikationstyp auswählen wird angezeigt.

  6. Doppelklicken Sie auf eine der folgenden Optionen:
    • Lokale Dateien, und gehen Sie zu Schritt 7.

    • Vorlagen, und gehen Sie zu Schritt 8.

    • WebDAV-Dateien, und gehen Sie zu Schritt 7.
  7. Suchen Sie den Ordner, der die Zielspezifikation enthält, die Sie öffnen möchten, und gehen Sie zu Schritt 9.

  8. Klicken Sie auf EDIFACT, X12 oder XML, und klicken Sie auf OK.

    Wenn Sie EDIFACT oder X12 auswählen, müssen Sie auch die Version auswählen, die Sie verwenden möchten. Klicken Sie auf den Ordner für die Version, die Sie verwenden möchten, klicken Sie auf OK, und gehen Sie dann zu Schritt 9.

  9. Wählen Sie die Zielspezifikation aus, und klicken Sie auf Öffnen bzw. OK.

  10. Wenn Sie ein XDR-Schema ausgewählt haben, kann das Dialogfeld Stammelement auswählen angezeigt werden. Ist dies der Fall, wählen Sie in der Liste Stammelemente ein Stammelement aus, und klicken Sie anschließend auf OK.

    Anmerkungen

    • Wenn das XDR-Schema (XML-Data Reduced) keinen Stamm enthält, müssen Sie einen von den möglichen Knoten im Schema angeben.

    • Wenn Sie im BizTalk-Mapper ein nicht auf BizTalk Server basierendes XDR-Schema öffnen, werden Fehler- und/oder Warnmeldungen angezeigt, wenn im Schema Elementgruppen und/oder Namespaces vorhanden sind. Das Ergebnis ist eine Zuordnung, die möglicherweise nicht wie erwartet angezeigt wird.

    • In der Struktur der Quell- bzw. der Zielspezifikation werden Gruppen nicht visuell abgebildet. Wenn eine Zuordnung Schemas mit Gruppen enthält, führt das Laufzeitmodul eine Überprüfung im Abgleich mit dem Gruppenattribut durch, ohne dass der BizTalk-Mapper Gruppierungsverweise grafisch darstellt.

Verwandte Themen

Ersetzen von Zielspezifikationen

Ersetzen von Quellspezifikationen


Öffnen von Zuordnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Öffnen von Zuordnungen von einer lokalen Festplatte

  • Abrufen von Zuordnungen aus WebDAV

  • Öffnen vorhandener Zuordnungen aus einem Ordner


Öffnen von Zuordnungen von einer lokalen Festplatte

  1. Klicken Sie im Menü Datei auf Öffnen.

    Das Dialogfeld Zuordnungsquelle öffnen wird angezeigt.

  2. Suchen Sie den Ordner, der die Zuordnung enthält, die Sie öffnen möchten.

  3. Klicken Sie auf eine Zuordnung in der Liste, und klicken Sie auf Öffnen.

Wichtig

  • Wenn die X12-Vorlagen in der BizTalk Server-Installation im BizTalk-Mapper verwendet werden, kann eine Fehlermeldung wie die Folgende angezeigt werden:

    Die Länge des Feldes "ITD05" ("") ist nicht gültig; sie muss zwischen 48 und -1 liegen. Dieses Dokument wird zurückgewiesen.

    Die X12-Vorlagen verwenden den implizierten Dezimaldatentyp Nx. Wenn die Eingabedaten ein Dezimalkomma enthalten, entspricht die Ausgabe nicht dem benutzerdefinierten Datentyp N (der kein Dezimalkomma vorsieht), wodurch in der temporären XML-Datei ungültige Instanzen erstellt werden. In diesem Release von BizTalk Server erkennt die Serialisierungskomponente möglicherweise nicht, ob die temporäre XML-Datei für die Ausgabe des Datentyps N ein Dezimalkomma enthält. Sie müssen den implizierten Dezimaldatentyp in den X12-Vorlagen manuell in einen der anderen numerischen Datentypen ändern, um dieses Problem zu beheben.

Anmerkung

  • Wenn Sie nach der Installation von BizTalk Server 2002 eine mit BizTalk Server 2000 erstellte Zuordnung öffnen, wird das Dateiformat geändert, wenn Sie die Datei speichern, so dass Sie sie in BizTalk Server 2000 nicht mehr öffnen können.

Verwandtes Thema

Abrufen von Zuordnungen aus WebDAV


Abrufen von Zuordnungen aus WebDAV

  1. Klicken Sie im Menü Datei auf Aus WebDAV abrufen.

    Das Dialogfeld Aus WebDAV abrufen wird angezeigt.

  2. Klicken Sie in der Liste Server auf einen Servernamen.

    Wichtig

    • Wenn der Proxyserveranschluss nicht 80 ist, müssen Sie Folgendes in die Liste Server eingeben, http://<Servername>:<Anschlussnummer>, um auf in WebDAV gespeicherte Zuordnungen zuzugreifen.

    • Zuordnungen können nicht von einem gesicherten Server abgerufen werden. Wenn der Server z. B. https://<Servername>/biztalkserverrepository heißt, können Sie auf keine Zuordnungen zugreifen.
  3. Suchen Sie den Ordner, der die Zuordnung enthält, die Sie abrufen möchten, und klicken Sie auf Öffnen.

Wichtig

  • Wenn Sie bei dem Versuch, vorhandene Zuordnungen aus WebDAV zu öffnen, eine Fehlermeldung wie "Auf http://<Servername>/BizTalkServerRepository/Maps wurde kein BizTalk Server-Repository gefunden" erhalten, registrieren Sie msdaipp.dll neu und starten dann den Computer neu. Weitere Informationen zum Neuregistrieren von msdaipp.dll finden Sie unter Erneutes Registrieren von MSDAIPP.DLL zum Abrufen oder Speichern von Zuordnungen in WebDAV.

  • Wenn die X12-Vorlagen in der BizTalk Server-Installation im BizTalk-Editor verwendet werden, kann eine Fehlermeldung wie die Folgende angezeigt werden:

    Die Länge des Feldes "ITD05" ("") ist nicht gültig; sie muss zwischen 48 und -1 liegen. Dieses Dokument wird zurückgewiesen.

    Die X12-Vorlagen verwenden den implizierten Dezimaldatentyp Nx. Wenn die Eingabedaten ein Dezimalkomma enthalten, entspricht die Ausgabe nicht dem benutzerdefinierten Datentyp N (der kein Dezimalkomma vorsieht), wodurch in der temporären XML-Datei ungültige Instanzen erstellt werden. In diesem Release von BizTalk Server erkennt die Serialisierungskomponente möglicherweise nicht, ob die temporäre XML-Datei für die Ausgabe des Datentyps N ein Dezimalkomma enthält. Sie müssen den implizierten Dezimaldatentyp in den X12-Vorlagen manuell in einen der anderen numerischen Datentypen ändern, um dieses Problem zu beheben.

Anmerkungen

  • Wenn Sie zum ersten Mal eine Verbindung mit einem Remote-WebDAV-Server herstellen, wird sich der Vorgang möglicherweise etwas verzögern.

  • Damit Sie eine Zuordnung in WebDAV abrufen können, müssen Sie über die Berechtigung verfügen, von dem Server Dateien abzurufen.

  • Wenn Sie nach der Installation von BizTalk Server 2002 eine mit BizTalk Server 2000 erstellte Zuordnung öffnen, wird das Dateiformat geändert, wenn Sie die Datei speichern, so dass Sie sie in BizTalk Server 2000 nicht mehr öffnen können.

Verwandte Themen

Öffnen von Zuordnungen von einer lokalen Festplatte

Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Öffnen vorhandener Zuordnungen aus einem Ordner

  1. Zeigen Sie im Startmenü auf Programme, dann auf Zubehör, und klicken Sie anschließend auf Windows-Explorer.

  2. Suchen Sie die Datei, die Sie im BizTalk-Mapper anzeigen möchten.

    Klicken Sie, falls erforderlich, auf Verkleinern, um die Fenstergröße so zu reduzieren, dass das BizTalk-Mapper-Fenster angezeigt wird.

  3. Ziehen Sie die Datei in den BizTalk-Mapper.

Wichtig

  • Wenn die X12-Vorlagen in der BizTalk Server-Installation im BizTalk-Editor verwendet werden, kann eine Fehlermeldung wie die Folgende angezeigt werden:

    Die Länge des Feldes "ITD05" ("") ist nicht gültig; sie muss zwischen 48 und -1 liegen. Dieses Dokument wird zurückgewiesen.

    Die X12-Vorlagen verwenden den implizierten Dezimaldatentyp Nx. Wenn die Eingabedaten ein Dezimalkomma enthalten, entspricht die Ausgabe nicht dem benutzerdefinierten Datentyp N (der kein Dezimalkomma vorsieht), wodurch in der temporären XML-Datei ungültige Instanzen erstellt werden. In diesem Release von BizTalk Server erkennt die Serialisierungskomponente möglicherweise nicht, ob die temporäre XML-Datei für die Ausgabe des Datentyps N ein Dezimalkomma enthält. Sie müssen den implizierten Dezimaldatentyp in den X12-Vorlagen manuell in einen der anderen numerischen Datentypen ändern, um dieses Problem zu beheben.

Anmerkung

  • Wenn Sie nach der Installation von BizTalk Server 2002 eine mit BizTalk Server 2000 erstellte Zuordnung öffnen, wird das Dateiformat geändert, wenn Sie die Datei speichern, so dass Sie sie in BizTalk Server 2000 nicht mehr öffnen können.


Speichern und Schließen von Zuordnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Speichern von neuen Zuordnungen

  • Speichern von vorhandenen Zuordnungen

  • Speichern von kompilierten Zuordnungen

  • Speichern von Zuordnungen

  • Schließen von Zuordnungen


Speichern von neuen Zuordnungen

  1. Klicken Sie im Menü Datei auf Speichern unter.

    Das Dialogfeld Zuordnungsquelle speichern unter wird angezeigt.

  2. Geben Sie im Feld Dateiname einen Namen für die Zuordnung ein.

  3. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Wenn Sie eine Spezifikation verwenden möchten, die mit ASCII-Zeichen zugewiesen ist, klicken Sie auf UTF-8. Für Spezifikationen, die mit Doppelbyte-Zeichensätzen zugewiesen sind, klicken Sie auf Unicode.

Anmerkungen

  • Wenn Sie eine Zuordnung speichern, kompiliert der BizTalk-Mapper diese automatisch. Sie können die Ergebnisse der kompilierten Zuordnung auf der Registerkarte Ausgabe anzeigen.

  • Wenn Sie eine Zuordnung speichern, speichert der BizTalk-Mapper die Zuordnung auf Ihrer Festplatte. Um eine Zuordnung in WebDAV zu speichern, müssen Sie über die Berechtigung verfügen, Dateien auf dem Server zu speichern.

  • Wenn Sie nach der Installation von BizTalk Server 2002 eine mit BizTalk Server 2000 erstellte Zuordnung öffnen, wird das Dateiformat geändert, wenn Sie die Datei speichern, so dass Sie sie in BizTalk Server 2000 nicht mehr öffnen können.

Verwandtes Thema

Speichern von Zuordnungen


Speichern von vorhandenen Zuordnungen

  • Klicken Sie im Menü Datei auf Speichern.

Anmerkungen

  • Wenn Sie eine Zuordnung speichern, kompiliert der BizTalk-Mapper diese automatisch. Sie können die Ergebnisse der kompilierten Zuordnung auf der Registerkarte Ausgabe anzeigen.

  • Wenn Sie eine Zuordnung speichern, speichert der BizTalk-Mapper die Zuordnung auf Ihrer Festplatte. Um eine Zuordnung in WebDAV zu speichern, müssen Sie über die Berechtigung verfügen, Dateien auf dem Server zu speichern.

  • Wenn Sie nach der Installation von BizTalk Server 2002 eine mit BizTalk Server 2000 erstellte Zuordnung öffnen, wird das Dateiformat geändert, wenn Sie die Datei speichern, so dass Sie sie in BizTalk Server 2000 nicht mehr öffnen können.

Verwandtes Thema

Speichern von Zuordnungen


Speichern von kompilierten Zuordnungen

  1. Klicken Sie im Menü Datei auf Kompilierte Zuordnung speichern unter.

    Das Dialogfeld Kompilierte Zuordnung speichern unter wird angezeigt.

    Anmerkung

    • Diese Option ist nur verfügbar, wenn Sie eine Zuordnung kompiliert haben.
  2. Geben Sie im Feld Dateiname einen Namen für die Datei ein, und klicken Sie auf Speichern.

Anmerkung

  • Wenn Sie nach der Installation von BizTalk Server 2002 eine mit BizTalk Server 2000 erstellte Zuordnung öffnen, wird das Dateiformat geändert, wenn Sie die Datei speichern, so dass Sie sie in BizTalk Server 2000 nicht mehr öffnen können.

Verwandtes Thema

Speichern von Zuordnungen


Speichern von Zuordnungen

  1. Klicken Sie im Menü Datei auf In WebDAV speichern.

    Das Dialogfeld In WebDAV speichern wird angezeigt.

  2. Klicken Sie in der Liste Server auf einen Servernamen.

    Wichtig

    • Wenn der Proxyserveranschluss nicht 80 ist, müssen Sie Folgendes in die Liste Server eingeben, http://<Servername>:<Anschlussnummer>, um Zuordnungen in WebDAV zu speichern.

    • Zuordnungen können nicht auf einem gesicherten Server gespeichert werden. Wenn der Server z. B. https://<Servername>/biztalkserverrepository heißt, können Sie keine Zuordnungen speichern.
  3. Gehen Sie zu dem Ordner, in dem Sie Ihre Zuordnung speichern möchten, und geben Sie in das Feld Dateiname den Namen der Datei ein.

  4. Klicken Sie in der Liste Codierung auf UTF-8 oder Unicode, und klicken Sie auf Speichern.

    Wenn Sie eine Spezifikation verwenden möchten, die mit ASCII-Zeichen zugewiesen ist, klicken Sie auf UTF-8. Für Spezifikationen, die mit Doppelbyte-Zeichensätzen zugewiesen sind, klicken Sie auf Unicode.

Internationale Probleme

  • Dateien können im WebDAV-Repository nur mit Unicode-Verschlüsselungen gespeichert werden. Im WebDAV-Repository können jedoch Dateien mit Namen in verschiedenen Codeseiten nicht gespeichert werden.

  • WebDAV unterstützt in Dateinamen keine Unicode-Zeichen.

  • Stellen Sie sicher, dass das Systemgebietsschema auf Ihre Sprache festgelegt ist. Internationale Benutzer, die z. B. die englische Version von BizTalk Server 2002 auf einem Computer mit englischem Microsoft® Windows® installieren und Dateien mit Zeichen benennen möchten, die von der Codeseite Latin I (Windows 1252) nicht unterstützt werden, müssen das Systemgebietsschema in das des Benutzers ändern.

  • Sie können Dateien, deren Dateinamen Doppelbyte-Zeichensätze enthalten, nicht speichern, wenn Ihre Ländereinstellung nicht korrekt ist. Weitere Informationen finden Sie unter Im WebDAV-Dialogfeld wird "???.xml" angezeigt.

Wichtig

  • Wenn Sie bei dem Versuch, Zuordnungen in WebDAV zu speichern, eine Fehlermeldung wie "Auf http://<Servername>/BizTalkServerRepository/Maps wurde kein BizTalk Server-Repository gefunden" erhalten, registrieren Sie msdaipp.dll neu und starten dann den Computer neu. Weitere Informationen zum Neuregistrieren von msdaipp.dll finden Sie unter Erneutes Registrieren von MSDAIPP.DLL zum Abrufen oder Speichern von Zuordnungen in WebDAV.

Anmerkungen

  • Wenn Sie zum ersten Mal eine Verbindung mit einem Remote-WebDAV-Server herstellen, wird sich der Vorgang möglicherweise etwas verzögern.

  • Damit Sie eine Zuordnung in WebDAV speichern können, müssen Sie über die Berechtigung verfügen, auf dem Server Dateien zu speichern.

  • Wenn Sie nach der Installation von BizTalk Server 2002 eine mit BizTalk Server 2000 erstellte Zuordnung öffnen, wird das Dateiformat geändert, wenn Sie die Datei speichern, so dass Sie sie in BizTalk Server 2000 nicht mehr öffnen können.

Verwandtes Thema

Problembehandlung - BizTalk-Editor und BizTalk-Mapper


Schließen von Zuordnungen

  • Klicken Sie im Menü Datei auf Schließen.


Ersetzen von Spezifikationen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Ersetzen von Quellspezifikationen

  • Ersetzen von Zielspezifikationen


Ersetzen von Quellspezifikationen

  1. Klicken Sie im Menü Bearbeiten auf Quellspezifikation ersetzen.

    Wenn Sie Ihre Zuordnung nicht gespeichert haben, werden Sie aufgefordert, die Änderungen an der Zuordnungsquelle zu speichern.

    Das Dialogfeld Quellspezifikationstyp auswählen wird angezeigt.

  2. Doppelklicken Sie auf eine der folgenden Optionen:
    • Lokale Dateien, und gehen Sie zu Schritt 3.

    • Vorlagen, und gehen Sie zu Schritt 4.

    • WebDAV-Dateien, und gehen Sie zu Schritt 3.
  3. Suchen Sie den Ordner, der die Quellspezifikation enthält, und gehen Sie zu Schritt 5.

  4. Klicken Sie auf EDIFACT, X12 oder XML, und klicken Sie auf OK.

    Wenn Sie EDIFACT oder X12 auswählen, müssen Sie auch die Version auswählen, die Sie verwenden möchten. Klicken Sie auf den Ordner für die Version, klicken Sie auf OK, und gehen Sie dann zu Schritt 5.

  5. Wählen Sie die Quellspezifikation aus, und klicken Sie auf Öffnen bzw. OK.

Anmerkungen

  • Die Quelltestwerte bleiben erhalten, wenn Sie eine Quellspezifikation ersetzen, sofern die diesen Werten zugewiesenen Felder in der neuen Spezifikation vorhanden sind.

  • Die Registerkarte Warnungen führt alle Warnungen auf, die sich auf die Verknüpfungen beziehen, die infolge des Ersetzens der Quellspezifikation verloren gehen könnten. Wenn eine Warnung angezeigt wird, kann sich das Problem auf mehrere Rasterseiten beziehen.

    Wenn z. B. die Rasterseite 1 mit dem Datensatz Item in der Struktur der Quellspezifikation mit dem Datensatz Number in der Struktur der Zielspezifikation verknüpft ist und auf Rasterseite 2 der Datensatz Product in der Struktur der Quellspezifikation mit demselben Datensatz Number in der Struktur der Zielspezifikation verknüpft ist, wird eine Warnmeldung erzeugt, die besagt, dass mehrere Eingaben in denselben Datensatz erfolgen. Wenn Sie jedoch die Rasterseite 1 anzeigen, wird nur eine Eingabe in den Datensatz Number angezeigt.

Verwandtes Thema

Ersetzen von Zielspezifikationen


Ersetzen von Zielspezifikationen

  1. Klicken Sie im Menü Bearbeiten auf Zielspezifikation ersetzen.

    Wenn Sie Ihre Zuordnung nicht gespeichert haben, werden Sie aufgefordert, die Änderungen an der Zuordnungsquelle zu speichern.

    Das Dialogfeld Zielspezifikationstyp auswählen wird angezeigt.

  2. Doppelklicken Sie auf eine der folgenden Optionen:
    • Lokale Dateien, und gehen Sie zu Schritt 3.

    • Vorlagen, und gehen Sie zu Schritt 4.

    • WebDAV-Dateien, und gehen Sie zu Schritt 3.
  3. Suchen Sie den Ordner, der die Zielspezifikation enthält, und gehen Sie zu Schritt 5.

  4. Klicken Sie auf EDIFACT, X12 oder XML, und klicken Sie auf OK.

    Wenn Sie EDIFACT oder X12 auswählen, müssen Sie auch die Version auswählen, die Sie verwenden möchten. Klicken Sie auf den Ordner für die Version, klicken Sie auf OK, und gehen Sie dann zu Schritt 5.

  5. Wählen Sie die Zielspezifikation aus, und klicken Sie auf Öffnen bzw. OK.

Anmerkungen

  • Die konstanten Werte für das Ziel bleiben erhalten, wenn Sie eine Zielspezifikation ersetzen, sofern die diesen Werten zugewiesenen Felder in der neuen Spezifikation vorhanden sind. Weitere Informationen zu konstanten Werten für das Ziel finden Sie unter Hinzufügen von konstanten Werten.

  • Die Registerkarte Warnungen führt alle Warnungen auf, die sich auf die Verknüpfungen beziehen, die infolge des Ersetzens der Zielspezifikation verloren gehen könnten. Wenn eine Warnung angezeigt wird, kann sich das Problem auf mehrere Rasterseiten beziehen.

    Wenn z. B. die Rasterseite 1 mit dem Datensatz Item in der Struktur der Quellspezifikation mit dem Datensatz Number in der Struktur der Zielspezifikation verknüpft ist und auf Rasterseite 2 der Datensatz Product in der Struktur der Quellspezifikation mit demselben Datensatz Number in der Struktur der Zielspezifikation verknüpft ist, wird eine Warnmeldung erzeugt, die besagt, dass mehrere Eingaben in denselben Datensatz erfolgen. Wenn Sie jedoch die Rasterseite 1 anzeigen, wird nur eine Eingabe in den Datensatz Number angezeigt.

Verwandte Themen

Hinzufügen von konstanten Werten

Ersetzen von Quellspezifikationen


Arbeiten mit Rasterseiten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Rasterseiten

  • Umbenennen von Rasterseiten

  • Löschen von Rasterseiten


Hinzufügen von Rasterseiten

  • Klicken Sie im Menü Bearbeiten auf Seite hinzufügen.

Anmerkung

  • Die maximale Anzahl von Rasterseiten, die Sie hinzufügen können, ist 20.


Umbenennen von Rasterseiten

  • Doppelklicken Sie auf den Namen der Rasterseite, geben Sie einen neuen Namen ein, und drücken Sie die EINGABETASTE.

Anmerkung

  • Die automatische Vervollständigungsfunktion zeigt während der Eingabe automatisch eine Liste vorheriger übereinstimmender Einträge an.


Löschen von Rasterseiten

  • Klicken Sie im Menü Bearbeiten auf Seite löschen.

Anmerkung

  • Sie können bis auf eine alle Rasterseiten löschen.


Verwalten von Funktoiden

Folgende Themen werden in diesem Abschnitt behandelt:

  • Arbeiten mit Funktoiden

  • Informationen zu Funktoidparametern

  • Bearbeiten von Funktoideigenschaften


Arbeiten mit Funktoiden

Die Funktoidpalette enthält die im BizTalk-Mapper verfügbaren Funktoide. Sie können das gewünschte Funktoid in der Funktoidpalette suchen und in das Zuordnungsraster ziehen. Die verschiedenen Typen von Funktoiden sind auf Registerkarten angeordnet. Möglicherweise müssen Sie auf den Pfeil nach rechts oder den Pfeil nach links klicken, um die verborgenen Registerkarten anzuzeigen.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Hinzufügen von Zeichenfolgenfunktoiden

  • Hinzufügen von mathematischen Funktoiden

  • Hinzufügen von logischen Funktoiden

  • Hinzufügen von Datums- und Uhrzeitfunktoiden

  • Hinzufügen von Konvertierungsfunktoiden

  • Hinzufügen von wissenschaftlichen Funktoiden

  • Hinzufügen von kumulativen Funktoiden

  • Hinzufügen von Datenbankfunktoiden

  • Hinzufügen des Funktoids "Skripterstellung"

  • Hinzufügen des Funktoids "Anzahl der Datensätze"

  • Hinzufügen des Funktoids "Index"

  • Hinzufügen des Funktoids "Iteration"

  • Hinzufügen des Funktoids "Wertezuordnung"

  • Hinzufügen des Funktoids "Wertezuordnung (Flattening)"

  • Hinzufügen des Funktoids "Schleife"

  • Verschieben von Funktoiden und Verknüpfungen zwischen Rasterseiten

  • Auswählen mehrerer Verknüpfungen und Funktoide

  • Löschen von Funktoiden

Verwandte Themen

BizTalk-Mapper - Funktoidpalette

Grundlegendes zu Funktoiden


Hinzufügen von Zeichenfolgenfunktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Zeichenfolge.

  3. Ziehen Sie ein Funktoid Zeichenfolge aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Zeichenfolgenfunktoiden finden Sie unter Zeichenfolgenfunktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder ein Feld in der Struktur der Zielspezifikation.

Wichtig

  • Sie müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren, um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen von mathematischen Funktoide

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Mathematisch.

  3. Ziehen Sie ein mathematisches Funktoid aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten mathematischen Funktoiden finden Sie unter Hinzufügen von mathematischen Funktoiden.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder ein Feld in der Struktur der Zielspezifikation.

Internationales Problem

  • Viele Gebietsschemas verwenden als Dezimaltrennzeichen ein Komma (,). Eine Zahl, die ein Komma als Dezimaltrennzeichen enthält, kann nicht mit dem Microsoft XML-Parser (MSXML) überprüft werden, da MSXML einen Punkt (.) als Dezimaltrennzeichen erwartet. Ändern Sie folgendermaßen in den Ländereinstellungen das Dezimaltrennzeichen in einen Punkt, um dieses Problem zu beheben.
    1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie dann auf Systemsteuerung.

    2. Doppelklicken Sie auf Ländereinstellungen.

      Die Konsole Ländereinstellungen wird angezeigt.

    3. Klicken Sie auf die Registerkarte Zahlen.

    4. Geben Sie in das Feld Dezimaltrennzeichen Folgendes ein: .

    5. Klicken Sie auf Übernehmen und dann auf OK.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen von logischen Funktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Logisch.

  3. Ziehen Sie ein logisches Funktoid aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten logischen Funktoiden finden Sie unter Logische Funktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster. Ziehen Sie dann das Funktoid auf einen Datensatz in der Struktur der Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkungen

  • Logische Funktoide reagieren beim Vergleich von zwei Zeichenfolgen auf die Groß- und Kleinschreibung. Beispielsweise sind "Abc" und "abc" nicht identisch. Ausgenommen von dieser Regel ist der Vergleich von Zeichenfolgen, welche die booleschen Werte TRUE und FALSE enthalten, durch logische Funktoide. Beispielsweise sind "True" und "true" identisch.

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen von Datums- und Uhrzeitfunktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Datum/Uhrzeit.

  3. Ziehen Sie ein Funktoid Datum und Uhrzeit aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Datums- und Zeitfunktoiden finden Sie unter Datums- und Zeitfunktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder ein Feld in der Struktur der Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkungen

  • Die Funktoide Datum, Uhrzeit und Datum und Uhrzeit benötigen nur eine Verknüpfung zu einem Feld oder einem Datensatz in der Struktur der Zielspezifikation.

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen von Konvertierungsfunktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Konvertierung.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie ein Funktoid Konvertierung aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Konvertierungsfunktoiden finden Sie unter Konvertierungsfunktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder ein Feld in der Struktur der Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen von wissenschaftlichen Funktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Wissenschaftlich.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie ein wissenschaftliches Funktoid aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten wissenschaftlichen Funktoiden finden Sie unter Wissenschaftliche Funktoide.

  4. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie das Funktoid auf einen Datensatz oder ein Feld in der Struktur der Zielspezifikation.

Wichtig

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen von kumulativen Funktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Kumulativ.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie ein kumulatives Funktoid aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten kumulativen Funktoiden finden Sie unter Kumulative Funktoide.

  4. Ziehen Sie ein Feld (mit einem übergeordneten Schleifendatensatz) aus der Struktur der Quellspezifikation auf das Funktoid im Zuordnungsraster, und ziehen Sie dann das Funktoid auf einen Datensatz oder ein Feld in der Struktur der Quellspezifikation.

    Weitere Informationen zu Schleifendatensätze finden Sie unter Verwenden von kumulativen Funktoiden.

Wichtig

  • Weitere Informationen zum Kontext dieses Verfahrens finden Sie unter Verwenden von kumulativen Funktoiden.

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen von Datenbankfunktoiden

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Datenbank.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie ein Funktoid Datenbank aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Datenbankfunktoiden finden Sie unter Datenbankfunktoide.

Wichtig

  • Weitere Informationen zur Verwendung der Funktoide Datenbank zum Extrahieren von Informationen aus einer Datenbank finden Sie unter Verwenden von Datenbankfunktoiden.

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Skripterstellung"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Skripterstellung Funktoid "Skripterstellung" in das Zuordnungsraster.

    Detaillierte Informationen zu bestimmten Funktoiden vom Typ Skripterstellung finden Sie unter Erweiterte Funktoide.

  4. Doppelklicken Sie auf das Funktoid Skripterstellung.

    Das Dialogfeld Funktoideigenschaften wird angezeigt.

  5. Klicken Sie auf die Registerkarte Skript.

  6. Wählen Sie im Bereich Skriptsprache entweder VBScript oder JScript aus, geben Sie das gewünschte Skript in den Bereich Funktoidskript ein, und klicken Sie dann auf OK.

  7. Ziehen Sie einen Datensatz oder ein Feld aus der Struktur der Quellspezifikation auf das Funktoid Skripterstellung im Zuordnungsraster, und ziehen Sie das Funktoid Skripterstellung dann auf einen Datensatz oder ein Feld in der Struktur der Zielspezifikation.

Wichtig

  • Wenn es in einem Funktoid Skripterstellung mehrere Funktionen gibt, ist die erste Funktion die Hauptfunktion oder primäre Funktion. Für diese Funktion müssen Parameter festgelegt sein, falls Verknüpfungen zum Funktoid vorhanden sind.

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Verwalten von Ansichten


Hinzufügen des Funktoids "Anzahl der Datensätze"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Anzahl der Datensätze Funktoid "Anzahl der Datensätze" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Anzahl der Datensätze finden Sie unter Erweiterte Funktoide.

  4. Ziehen Sie einen Schleifendatensatz aus der Struktur der Quellspezifikation auf das Funktoid Anzahl der Datensätze im Zuordnungsraster, ziehen Sie dann das Funktoid Anzahl der Datensätze auf ein Feld in der Struktur der Zielspezifikation.

    Weitere Informationen zu Schleifendatensätze finden Sie unter Verwenden des Funktoids "Datensatzanzahl".

Wichtig

  • Weitere Informationen zum Kontext dieses Verfahrens finden Sie unter Verwenden des Funktoids "Datensatzanzahl".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Index"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Index Funktoid "Index" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Index finden Sie unter Erweiterte Funktoide.

  4. Ziehen Sie ein Feld (mit einem übergeordneten Schleifendatensatz) aus der Struktur der Quellspezifikation auf das Funktoid Index im Zuordnungsraster, und ziehen Sie dann das Funktoid Index auf ein Feld in der Struktur der Quellspezifikation.

    Weitere Informationen zu Schleifendatensätze finden Sie unter Verwenden des Funktoids "Index".

  5. Doppelklicken Sie auf das Funktoid Index, um seine Eigenschaftenseite aufzurufen.

  6. Klicken Sie auf die Schaltfläche Neuen Parameter einfügen Schaltfläche "Neuen Parameter einfügen", geben Sie den Indexwert ein, und drücken Sie dann die EINGABETASTE.

  7. Wiederholen Sie ggf. Schritt 6.

  8. Klicken Sie auf OK.

Wichtig

  • Weitere Informationen zum Kontext dieses Verfahrens finden Sie unter Verwenden des Funktoids "Index".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Iteration"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Iteration Funktoid "Iteration" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Iteration finden Sie unter Erweiterte Funktoide.

Wichtig

  • Weitere Informationen zur Verwendung des Funktoids Iteration finden Sie unter Verwenden des Funktoids "Iteration".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Wertezuordnung"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Wertezuordnung Funktoid "Wertezuordnung" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Wertezuordnung finden Sie unter Erweiterte Funktoide.

Wichtig

  • Weitere Informationen zur Verwendung des Funktoids Wertezuordnung finden Sie unter Verwenden des Funktoids "Wertezuordnung".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Hinzufügen des Funktoids "Wertezuordnung (Flattening)"

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Wertezuordnung (Flattening)"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Wertezuordnung (Flattening) Funktoid "Wertezuordnung (Flattening)" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Wertezuordnung (Flattening) finden Sie unter Erweiterte Funktoide.

Wichtig

  • Weitere Informationen zur Verwendung des Funktoids Wertezuordnung (Flattening) finden Sie unter Verwenden des Funktoids "Wertezuordnung (Flattening)".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Hinzufügen des Funktoids "Wertezuordnung"

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Hinzufügen des Funktoids "Schleife"

  1. Klicken Sie im Menü Ansicht auf Funktoidpalette.

  2. Klicken Sie auf der Funktoidpalette auf die Registerkarte Erweitert.

    Möglicherweise müssen Sie auf der Funktoidpalette auf den Pfeil nach rechts klicken, um die Registerkarte anzuzeigen.

  3. Ziehen Sie das Funktoid Schleife Funktoid "Schleife" aus der Funktoidpalette in das Zuordnungsraster.

    Detaillierte Informationen zum Funktoid Schleife finden Sie unter Erweiterte Funktoide.

Wichtig

  • Unter bestimmten Bedingungen verhalten sich einige Funktoide möglicherweise nicht wie erwartet, wenn sie innerhalb einer Zuordnung verwendet werden, die mit dem Funktoid Schleife arbeitet. Ein Funktoid liefert nicht die erwarteten Ergebnisse, wenn folgende Bedingungen erfüllt sind:
    • Das Funktoid besitzt mehr als eine Quellspezifikationsverknüpfung.

    • Zwei oder mehr der Quellspezifikationsverknüpfungen des Funktoids sind mit untergeordneten Feldern der Eingabedatensätze für das Funktoid Schleife verknüpft. Die untergeordneten Felder sind untereinander nicht gleichgeordnet.

    • Das Funktoid besitzt eine Zielspezifikationsverknüpfung, die auf ein untergeordnetes Feld eines Ausgabedatensatzes des Funktoids Schleife führt.
  • Weitere Informationen zur Verwendung des Funktoids Schleife finden Sie unter Verwenden des Funktoids "Schleife".

  • Um eine Verknüpfung zwischen einem Funktoid und einem Datensatz zu erstellen, müssen Sie die Eigenschaft Verknüpfungen von Datensatzinhalten zulassen aktivieren. Klicken Sie dazu im Menü Extras auf Optionen. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper auf der Registerkarte Allgemein das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

Anmerkung

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze oder Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Zulassen von Verknüpfungen für Datensatzinhalte

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

Grundlegendes zu Funktoiden


Verschieben von Funktoiden und Verknüpfungen zwischen Rasterseiten

  1. Wählen Sie das Funktoid oder die Verknüpfung, die Sie verschieben möchten, aus.

    Anmerkungen

    • Wenn Sie ein Funktoid auswählen, werden dessen zugeordnete Verknüpfungen ebenfalls ausgewählt und verschoben.

    • Sie können ein Funktoid erst dann verschieben, nachdem alle Verknüpfungen und verknüpften Funktoide in der Kette ausgewählt wurden.
  2. Klicken Sie bei Bedarf auf den rechten oder linken Pfeil, um die Registerkarte der Seite anzuzeigen, auf der Sie das Funktoid oder die Verknüpfung ablegen möchten.

  3. Ziehen Sie das Funktoid oder die Verknüpfung auf die Registerkarte der Seite, auf die das Objekt verschoben werden soll, und positionieren Sie das Objekt über der Registerkarte, bis die Rasterseite angezeigt wird.

  4. Ziehen Sie das Funktoid oder die Verknüpfung zu der Stelle im Raster, an der Sie das Objekt ablegen möchten.

Anmerkung

  • Bevor Sie ein Funktoid und seine Verknüpfungen von einer Seite auf eine andere verschieben können, müssen alle mit diesem verbundene Verknüpfungen angezeigt werden. Erweitern Sie die Quell- und Zielknoten mit den Verknüpfungen, die mit dem Funktoid verbunden sind, um die Verknüpfungen anzuzeigen.


Auswählen mehrerer Verknüpfungen und Funktoide

  • Ziehen Sie den Cursor über die Verknüpfungen und Funktoide, die Sie auswählen möchten.


Löschen von Funktoiden

  1. Klicken Sie mit der rechten Maustaste auf das Funktoid, das Sie entfernen möchten, und klicken Sie dann auf Löschen.

  2. Klicken Sie im Bestätigungsdialogfeld auf Ja.


Informationen zu Funktoidparametern

In diesem Abschnitt werden alle Funktoide in Microsoft BizTalk Server 2002 und ihre Parameter vorgestellt und beschrieben.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Zeichenfolgenfunktoide

  • Mathematische Funktoide

  • Logische Funktoide

  • Datums- und Zeitfunktoide

  • Konvertierungsfunktoide

  • Wissenschaftliche Funktoide

  • Kumulative Funktoide

  • Datenbankfunktoide

  • Erweiterte Funktoide


Zeichenfolgenfunktoide

Funktoid Parameter
Funktoid "Zeichenfolge suchen" Zeichenfolge suchen

Gibt die Position in einer Zeichenfolge zurück, an der eine andere angegebene Zeichenfolge beginnt.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Das erste Feld, das Sie mit dem Funktoid verknüpfen, ist die Zeichenfolge, welche die Position der zweiten Zeichenfolge ermittelt.
Functoid "Zeichenfolge von links" Zeichenfolge von links

Gibt eine angegebene Anzahl von Zeichen eines Textelements zurück, beginnend mit dem äußeren linken Zeichen.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Das erste Feld, das Sie mit dem Funktoid verknüpfen, ist die Zeichenfolge, welche die Ausgabezeichenfolge ermittelt. Das zweite Feld, das Sie mit dem Funktoid verknüpfen, ermittelt die Anzahl der Zeichen, die als Ausgabewert zurückgegeben werden. Das Ergebnis der Ausgabe ist eine Zeichenfolge, die eine Untermenge des ersten Feldes ist, das Sie mit dem Funktoid verknüpft haben.
Funktoid "Kleinbuchstaben" Kleinbuchstaben

Konvertiert ein Textelement in Kleinbuchstaben.

 Dieses Funktoid muss einen Eingabeparameter aufweisen.
Functoid "Zeichenfolge von rechts" Zeichenfolge von rechts

Extrahiert eine angegebene Anzahl von Zeichen eines Textelements, beginnend mit dem äußeren rechten Zeichen.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Das erste Feld, das Sie mit dem Funktoid verknüpfen, ist die Zeichenfolge, welche die Ausgabezeichenfolge ermittelt. Das zweite Feld, das Sie mit dem Funktoid verknüpfen, ermittelt die Anzahl der Zeichen, die als Ausgabewert zurückgegeben werden. Das Ergebnis der Ausgabe ist eine Zeichenfolge, die eine Untermenge des ersten Feldes ist, das Sie mit dem Funktoid verknüpft haben.
Funktoid "Zeichenfolgenlänge" Zeichenfolgenlänge

Gibt als ganze Zahl die Größe eines Objekts ohne Auffüllzeichen zurück.

 Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Ausgabewert gibt in Zeichen die Größe der im Eingabefeld enthaltenen Daten an.
Funktoid "Zeichenfolge extrahieren" Zeichenfolge extrahieren

Extrahiert eine Zeichenfolge, die durch die Anfangs- und Endposition einer Eingabezeichenfolge angegeben wird.

 Dieses Funktoid muss drei Eingabeparameter aufweisen.

Die Reihenfolge, in der Sie die Felder mit dem Funktoid verknüpfen, muss die Folgende sein:

  1. Feld Zeichenfolge

  2. Feld Anfangsposition

  3. Feld Endposition
Funktoid "Verketten" Verketten

Verkettet eine Reihe von Eingabezeichenfolgen.

 Dieses Funktoid darf mehrere Eingabeparameter aufweisen.
Funktoid "Zeichenfolge links kürzen" Zeichenfolge links kürzen

Entfernt führende Leerzeichen aus einem Textelement.

 Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Zeichenfolge rechts kürzen" Zeichenfolge rechts kürzen

Entfernt nachfolgende Leerzeichen aus einem Textelement.

 Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Großbuchstaben" Großbuchstaben

Konvertiert ein Textelement in Großbuchstaben.

 Dieses Funktoid muss einen Eingabeparameter aufweisen.


Mathematische Funktoide

Funktoid | Parameter
Funktoid "Absoluter Wert" Absoluter Wert Gibt den absoluten Wert einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Endwert ist ungeachtet des tatsächlichen Eingabewertes stets positiv.
Funktoid "Ganze Zahl" Ganze Zahl Gibt den ganzzahligen Teil einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid entfernt das Dezimalkomma sowie alle Stellen rechts des Dezimalkommas aus einer Zahl.
Funktoid "Maximalwert Maximalwert Gibt den maximalen Wert in einer Reihe numerischer Werte zurück. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Minimalwert Minimalwert Gibt den minimalen Wert in einer Reihe numerischer Werte zurück. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Modulo" Modulo Gibt den Restwert zurück, nachdem eine Zahl durch eine ganze Zahl geteilt wurde. | Dieses Funktoid muss zwei Eingabeparameter aufweisen. Dieses Funktoid gibt den Rest der Division einer ganzen Zahl zurück. Dieses Funktoid ist nützlich für Stückgutberechnungen, wie z. B. Versandmengen.
Funktoid "Runden" Runden Rundet eine Zahl auf eine angegebene Anzahl von Dezimalstellen oder auf eine ganze Zahl, wenn keine Dezimalstellen angegeben werden. | Dieses Funktoid muss zwei Eingabeparameter aufweisen. Die erste mit dem Funktoid verknüpfte Eingabe stellt den Wert dar. Die zweite mit dem Funktoid verknüpfte Eingabe stellt die Anzahl der Dezimalstellen dar, auf die der Wert gerundet werden soll. Das Funktoid nimmt Auf- und Abrundungen auf der Basis der standardmäßigen Berechnungsregeln vor.
Funktoid "Quadratwurzel" Quadratwurzel Gibt die Quadratwurzel einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Addition" Addition Berechnet die Summe einer Reihe von Zahlen. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Subtraktion" Subtraktion Subtrahiert eine Zahl von einer anderen Zahl. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Multiplikation" Multiplikation Multipliziert eine Zahl mit einer anderen Zahl. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Division" Division Dividiert eine Zahl durch eine andere Zahl. | Dieses Funktoid muss zwei Eingabeparameter aufweisen. Sie können dieses Funktoid mit reellen und ganzen Zahlen verwenden.


Logische Funktoide

Funktoid | Parameter
Funktoid "Größer als" Größer als Gibt TRUE zurück, wenn der erste Parameter größer als der zweite Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Größer als oder gleich" Größer als oder gleich Gibt TRUE zurück, wenn der erste Parameter größer als oder gleich dem zweiten Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Kleiner als" Kleiner als Gibt TRUE zurück, wenn der erste Parameter kleiner als der zweite Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Kleiner als oder gleich" Kleiner als oder gleich Gibt TRUE zurück, wenn der erste Parameter kleiner als oder gleich dem zweiten Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Gleich" Gleich Gibt TRUE zurück, wenn der erste Parameter gleich dem zweiten Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Ungleich" Ungleich Gibt TRUE zurück, wenn der erste Parameter ungleich dem zweiten Parameter ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Logische Zeichenfolge" Logische Zeichenfolge Gibt TRUE zurück, wenn es sich bei dem Parameter um einen Zeichenfolgenwert handelt. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Logisches Datum" Logisches Datum Gibt TRUE zurück, wenn es sich bei dem Parameter um einen Datumswert handelt. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Logischer numerischer Wert" Logischer numerischer Wert Gibt TRUE zurück, wenn es sich bei dem Parameter um einen numerischen Wert handelt. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Logisches OR" Logisches OR Gibt das logische OR von Parametern zurück. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Logisches AND" Logisches AND Gibt das logische AND von Parametern zurück. | Dieses Funktoid muss einen oder mehrere Eingabeparameter aufweisen.
Funktoid "Logische Existenz" Logische Existenz Gibt TRUE zurück, wenn der Eingabedatensatz oder das Eingabefeld im Quelldokument vorhanden sind. | Dieses Funktoid darf nur einen Eingabeparameter aufweisen.


Datums- und Zeitfunktoide

Funktoid | Parameter
Funktoid "Tage hinzufügen" Tage hinzufügen Fügt einem Datum eine angegebene Anzahl von Tagen hinzu. | Dieses Funktoid muss zwei Eingabeparameter aufweisen. Die erste Verknüpfung muss als Eingabe Datumsinformationen aufweisen. Die zweite Verknüpfung ermittelt die Anzahl der Tage, die zu dem Datum hinzugefügt werden soll.
Funktoid "Datum" Datum Gibt das aktuelle Datum zurück. | Für dieses Funktoid sind keine Eingabeparameter erforderlich. Das Ausgabeformat ist JJJJ-MM-TT.
Funktoid "Uhrzeit" Uhrzeit Gibt die aktuelle Uhrzeit zurück. | Für dieses Funktoid sind keine Eingabeparameter erforderlich. Das Ausgabeformat ist HH:MM:SS.
Funktoid "Datum und Uhrzeit" Datum und Uhrzeit Gibt das aktuelle Datum und die aktuelle Uhrzeit zurück. | Für dieses Funktoid sind keine Eingabeparameter erforderlich. Das Ausgabeformat ist JJJJ-MM-TTTHH:MM:SS.


Konvertierungsfunktoide

Funktoid | Parameter
Funktoid "ASCII aus Zeichen" ASCII aus Zeichen Gibt einen ASCII-Wert zurück, wenn ein Zeichen angegeben wurde. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid konvertiert einen zugrunde liegenden ASCII-Wertcode. Beispiel: A=97
Funktoid "Zeichen aus ASCII" Zeichen aus ASCII Gibt ein Zeichen zurück, wenn ein ASCII-Wert angegeben wurde. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid konvertiert einen Wert in dessen zugrunde liegenden ASCII-Wertcode. Beispiel: 98=B
Funktoid "Hexadezimal" Hexadezimal Gibt einen Hexadezimalwert zurück, wenn eine Dezimalzahl angegeben wurde. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid konvertiert einen Dezimal- in einen Hexadezimalwert. Beispiel: 10=A
Funktoid "Oktal" Oktal Gibt einen Oktalwert zurück, wenn eine Dezimalzahl angegeben wurde. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Dieses Funktoid konvertiert einen Dezimal- in einen Oktalwert. Beispiel: (Oktal 0-7), 8=10 und 10=12


Wissenschaftliche Funktoide

Funktoid | Parameter
Funktoid "Arcustangens" Arcustangens Gibt den Arcustangens einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Eingabewert muss in Radiant angegeben werden.
Funktoid "Kosinus" Kosinus Gibt den Kosinus einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Eingabewert muss in Radiant angegeben werden.
Funktoid "Sinus" Sinus Gibt den Sinus einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Eingabewert muss in Radiant angegeben werden.
Funktoid "Tangens" Tangens Gibt den Tangens einer Zahl zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen. Der Eingabewert muss in Radiant angegeben werden.
Funktoid "Natürliche Exponentialfunktion" Natürliche Exponentialfunktion Erhebt e in die angegebene Potenz. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Natürlicher Logarithmus" Natürlicher Logarithmus Gibt den Logarithmus (Basis e) eines Wertes zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
10^X Erhebt 10 in die angegebene Potenz | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Allgemeiner Logarithmus" Allgemeiner Logarithmus Gibt den Logarithmus (Basis 10) eines Wertes zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
X^Y Erhebt einen Wert in die angegebene Potenz. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Logarithmus mit angegebener Basis" Logarithmus mit angegebener Basis Gibt den Logarithmus der angegebenen Basis eines Wertes zurück. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.


Kumulative Funktoide

Funktoid Parameter
Funktoid "Kumulative Summe" Kumulative Summe

Addiert alle Werte für das verbundene Feld durch Iteration über den übergeordneten Datensatz.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Der zweite Parameter gibt die Hierarchieebene (aus der Sicht der Compilerverknüpfung) im Quellknoten an. Dieser Parameter muss eine Ganzzahl größer 0 und kleiner als die Knotentiefe des Stammknotens sein.

Anmerkung

  • Dieses Funktoid stellt die Abwärtskompatibilität mit Microsoft BizTalk Server 2000 bereit, das nur einen Eingabeparameter erforderte.

Weitere Informationen und ein Beispiel kumulativer Funktoide finden Sie unter Verwenden von kumulativen Funktoiden.
Funktoid "Kumulativer Durchschnitt" Kumulativer Durchschnitt

Berechnet den Durchschnitt aller Werte für das verbundene Feld durch Iteration über den übergeordneten Datensatz.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Der zweite Parameter gibt die Hierarchieebene (aus der Sicht der Compilerverknüpfung) im Quellknoten an. Dieser Parameter muss eine Ganzzahl größer 0 und kleiner als die Knotentiefe des Stammknotens sein.

Anmerkung

  • Dieses Funktoid stellt die Abwärtskompatibilität mit BizTalk Server 2000 bereit, das nur einen Eingabeparameter erforderte.

Weitere Informationen und ein Beispiel kumulativer Funktoide finden Sie unter Verwenden von kumulativen Funktoiden.
Funktoid "Kumulativer Minimalwert" Kumulativer Minimalwert

Gibt die minimale Eingabe zurück, die den übergeordneten Datensatz umfasst.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Der zweite Parameter gibt die Hierarchieebene (aus der Sicht der Compilerverknüpfung) im Quellknoten an. Dieser Parameter muss eine Ganzzahl größer 0 und kleiner als die Knotentiefe des Stammknotens sein.

Anmerkung

  • Dieses Funktoid stellt die Abwärtskompatibilität mit BizTalk Server 2000, das nur einen Eingabeparameter erforderte.

Weitere Informationen und ein Beispiel kumulativer Funktoide finden Sie unter Verwenden von kumulativen Funktoiden.
Funktoid "Kumulativer Maximalwert" Kumulativer Maximalwert

Gibt die maximale Eingabe zurück, die den übergeordneten Datensatz umfasst.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Der zweite Parameter gibt die Hierarchieebene (aus der Sicht der Compilerverknüpfung) im Quellknoten an. Dieser Parameter muss eine Ganzzahl größer 0 und kleiner als die Knotentiefe des Stammknotens sein.

Anmerkung

  • Dieses Funktoid stellt die Abwärtskompatibilität mit BizTalk Server 2000 bereit, das nur einen Eingabeparameter erforderte.

Weitere Informationen und ein Beispiel kumulativer Funktoide finden Sie unter Verwenden von kumulativen Funktoiden.
Funktoid "Kumulative Zeichenfolge" Kumulative Zeichenfolge

Gibt die verkettete Zeichenfolge von Zeichenfolgenwerten für das verbundene Feld durch Iteration über den übergeordneten Datensatz zurück.

 Dieses Funktoid muss zwei Eingabeparameter aufweisen. Der zweite Parameter gibt die Hierarchieebene (aus der Sicht der Compilerverknüpfung) im Quellknoten an. Dieser Parameter muss eine Ganzzahl größer 0 und kleiner als die Knotentiefe des Stammknotens sein.

Anmerkung

  • Dieses Funktoid stellt die Abwärtskompatibilität mit BizTalk Server 2000 bereit, das nur einen Eingabeparameter erforderte.

Weitere Informationen und ein Beispiel kumulativer Funktoide finden Sie unter Verwenden von kumulativen Funktoiden.


Datenbankfunktoide

Funktoid | Parameter
Funktoid "Datenbanksuche" Datenbanksuche Sucht einen bestimmten Wert in einer Datenbank, ruft den Datensatz ab, der den Wert enthält, und speichert ihn als ADO-Recordset (Microsoft ActiveX® Data Objects). | Dieses Funktoid muss exakt vier Eingabeparameter aufweisen.
Funktoid "Wertextrahierer" Wertextrahierer Gibt einen Wert aus einer bestimmten Spalte in einem ADO-Recordset zurück, das zuvor durch das Funktoid Datenbanksuche abgerufen wurde. | Dieses Funktoid muss exakt zwei Eingabeparameter aufweisen.
Funktoid "Fehlerrückgabe" Fehlerrückgabe Gibt, falls vorhanden, die Fehlerzeichenfolge zurück, die beim Verwenden des Funktoids Datenbanksuche durch ODBC (Open Database Connectivity ) zurückgegeben wird. | Dieses Funktoid muss exakt einen Eingabeparameter aufweisen.


Erweiterte Funktoide

Funktoid | Parameter
Funktoid "Skripterstellung" Skripterstellung Gibt benutzerdefiniertes Microsoft® Visual Basic® Scripting Edition (VBScript) oder benutzerdefiniertes Microsoft JScript® zurück. | Die Anzahl der Eingabeparameter für dieses Funktoid kann, basierend auf einem benutzerdefinierten Skript, konfiguriert werden.
Funktoid "Anzahl der Datensätze" Anzahl der Datensätze Gibt die Gesamtzahl der Datensätze zurück, die in der Instanz gefunden wurden. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Index" Index Gibt den Wert eines Datensatzes oder Feldes bei einem angegebenen Index zurück. | Dieses Funktoid muss mindestens zwei Eingabeparameter aufweisen. Die maximale Anzahl der Eingabeparameter wird durch die Anzahl der Ebenen in der Spezifikationshierarchie beschränkt.
Funktoid "Iteration" Iteration Gibt die Iterationsnummer (in einer Schleife) des Quelldatensatzes zurück. | Dieses Funktoid muss einen Eingabeparameter aufweisen.
Funktoid "Wertezuordnung" Wertezuordnung Gibt den Wert des zweiten Parameters zurück, wenn der Wert des ersten Parameters TRUE ist. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Wertezuordnung (Flattening)" Wertezuordnung (Flattening) Gibt den Wert des zweiten Parameters zurück, wenn der Wert des ersten Parameters TRUE ist, und vereinfacht die Hierarchie des Quelldokuments. | Dieses Funktoid muss zwei Eingabeparameter aufweisen.
Funktoid "Schleife" Schleife Erstellt mehrere Ausgabedatensätze durch Iteration über jeden Datensatz. | Dieses Funktoid muss mindestens einen Eingabeparameter aufweisen. Die maximale Anzahl der Eingabeparameter ist unbegrenzt.


Bearbeiten von Funktoideigenschaften

  • Klicken Sie mit der rechten Maustaste auf ein Funktoid im Zuordnungsraster und dann auf Eigenschaften, um das Dialogfeld Funktoideigenschaften aufzurufen.

    Oder

    Doppelklicken Sie auf ein Funktoid, um seine Eigenschaften anzuzeigen.

Anmerkung

  • Die Registerkarte Allgemein zeigt Informationen zu den Eingabeparametern an. Die Registerkarte Skript zeigt Skriptinformationen an.

Weitere Informationen zur Verwendung dieses Dialogfeldes finden Sie in den folgenden Themen:

  • Eingabeparameter

  • Funktoidskripts


Eingabeparameter

Weitere Informationen zum Zugriff auf das Dialogfeld Funktoideigenschaften finden Sie unter Bearbeiten von Funktoideigenschaften.

Die Eingabeparameter für viele Funktoide können auf der Registerkarte Allgemein des Dialogfeldes Funktoideigenschaften hinzugefügt, gelöscht und nach oben und unten verschoben werden.

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Einfügen von Eingabeparametern

  • Löschen von Eingabeparametern

  • Verschieben von Eingabeparametern

  • Umbenennen von Eingabeparametern

Anmerkung

  • Bei einigen Funktoiden ist die Anzahl der Parameter, die diese haben können, begrenzt. Information dazu, wie viele Parameter ein bestimmtes Funktoid haben kann, finden Sie jeweils im Dialogfeld Funktoideigenschaften auf der Registerkarte Allgemein im Bereich Eingabeparameter für dieses Funktoid.


Einfügen von Eingabeparametern

  1. Doppelklicken Sie auf ein Funktoid im Zuordnungsraster.

    Das Dialogfeld Funktoideigenschaften wird angezeigt.

  2. Klicken Sie auf der Registerkarte Allgemein auf die Schaltfläche Neuen Parameter einfügen Schaltfläche "Neuen Paramete einfügen. Geben Sie die Informationen für den neuen Parameter ein, und drücken Sie die EINGABETASTE.

    Anmerkungen

    • Falls die Schaltfläche Neuen Parameter einfügen nicht verfügbar ist, akzeptiert oder benötigt das Funktoid keine Eingabeparameter.

    • Neue Parameterinformationen werden auf der Registerkarte Skript gezeigt.
  3. Wiederholen Sie Schritt 2, um ggf. weitere Parameter hinzuzufügen.

  4. Klicken Sie auf OK.

Wichtig

  • Wenn Sie die Registerkarte Skript auswählen und einen Eingabeparameter manuell bearbeiten, werden zusätzliche Eingabeparameter nicht auf der Registerkarte Skript angezeigt und zur Laufzeit nicht implementiert.

  • Doppelte Fragezeichen werden in einem konstanten Wert für einen Eingabeparameter nicht unterstützt.

Verwandte Themen

Löschen von Eingabeparametern

Verschieben von Eingabeparametern

Umbenennen von Eingabeparametern

Funktoidskripts


Löschen von Eingabeparametern

  1. Doppelklicken Sie auf ein Funktoid im Zuordnungsraster.

  2. Klicken Sie auf der Registerkarte Allgemein im Bereich Eingabeparameter auf den Eingabeparameter, den Sie löschen möchten.

  3. Klicken Sie auf die Schaltfläche Ausgewählten Parameter löschen [image] , und klicken Sie auf OK.

Verwandte Themen

Einfügen von Eingabeparametern

Verschieben von Eingabeparametern

Umbenennen von Eingabeparametern


Verschieben von Eingabeparametern

  1. Doppelklicken Sie auf ein Funktoid im Zuordnungsraster.

  2. Klicken Sie auf der Registerkarte Allgemein im Bereich Eingabeparameter auf den Eingabeparameter, den Sie verschieben möchten.

  3. Klicken Sie auf die Schaltfläche Ausgewählten Parameter nach oben verschieben [image] , um den Parameter nach oben zu verschieben, oder klicken Sie auf die Schaltfläche Ausgewählten Parameter nach unten verschieben Schaltfläche "Ausgewählten Parameter nach unten verschieben", um den Parameter nach unten zu verschieben, und klicken Sie auf OK.

Verwandte Themen

Löschen von Eingabeparametern

Einfügen von Eingabeparametern

Umbenennen von Eingabeparametern


Umbenennen von Eingabeparametern

  1. Doppelklicken Sie auf ein Funktoid im Zuordnungsraster.

  2. Klicken Sie auf der Registerkarte Allgemein im Bereich Eingabeparameter mit der rechten Maustaste auf den Eingabeparameter, den Sie umbenennen möchten, und klicken Sie auf Wert ändern.

  3. Geben Sie einen neuen Parameternamen ein, und klicken Sie auf OK.

Verwandte Themen

Löschen von Eingabeparametern

Einfügen von Eingabeparametern

Verschieben von Eingabeparametern


Funktoidskripts

Weitere Informationen zum Zugriff auf das Dialogfeld Funktoideigenschaften finden Sie unter Bearbeiten von Funktoideigenschaften.

Auf der Registerkarte Skript im Dialogfeld Funktoideigenschaften können Sie Skripts anzeigen oder bearbeiten.

Anmerkung

  • Sie können das Skript für jedes beliebige Funktoid anzeigen, jedoch nur das Skript eines Funktoids vom Typ Skripterstellung bearbeiten.

Verwandtes Thema

Eingabeparameter


Verwalten von Verknüpfungen

Folgende Themen werden in diesem Abschnitt behandelt:

  • Erstellen von Verknüpfungen zwischen Feldern

  • Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

  • Erstellen von Verknüpfungen zwischen Datensätzen und Feldern

  • Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

  • Erstellen von Verknüpfungen zwischen Funktoiden

  • Zulassen von Verknüpfungen für Datensatzinhalte

  • Umleiten von Verknüpfungen

  • Löschen von Verknüpfungen


Erstellen von Verknüpfungen zwischen Feldern

  • Ziehen Sie ein Feld aus der Struktur der Quellspezifikation auf ein Feld in der Struktur der Zielspezifikation.

Wichtig

  • Der Datentyp eines Feldes in der Struktur der Quellspezifikation muss dem Datentyp des Feldes entsprechen, mit dem es in der Struktur der Zielspezifikation verknüpft ist.

  • BizTalk-Mapper überprüft vor dem Generieren von XSLT das Vorhandensein eines Attributs oder Elements für eine direkte Verknüpfung zwischen Quelle und Ziel. Wenn demnach das Quellfeld nicht im Instanzdokument angezeigt wird (weil es optional ist), wird ein leeres Zielfeld erstellt. Dieses Verhalten ist unzulässig, weil das Zielfeld nur erstellt werden sollte, wenn das Quellfeld vorhanden ist. Um dieses Problem zu lösen, prüfen Sie, ob das verknüpfte Feld im Quellschema optional ist. Ist dies der Fall, generiert BizTalk Server eine <xsl:if>-Klausel, um das Vorhandensein des Quellfeldes vor dem Erstellen des Zielfeldes zu überprüfen. Damit wird sichergestellt, dass das Zielfeld nicht erstellt wird, wenn kein Quellfeld in der Quellinstanz vorhanden ist. Wenn die Quellinstanz das Feld enthält, wird das Zielfeld erwartungsgemäß erstellt.

Anmerkungen

  • Sie können keine Verknüpfung mit einem Knoten in der Zielspezifikation erstellen, dem ein konstanter Wert für das Ziel zugeordnet ist.

  • Sie können keine Verknüpfung zu einem erforderlichen Feld in der Zielspezifikation erstellen, dem ein Standardwert zugeordnet ist. Weitere Informationen dazu, wie Sie ein Feld als erforderliches Feld definieren, finden Sie unter Festlegen von Verweiseigenschaften. Weitere Informationen zum Festlegen des Standardwertes eines Feldes finden Sie unter Festlegen von Deklarationseigenschaften.

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Hinzufügen von konstanten Werten

Verwalten von Ansichten

Festlegen von Deklarationseigenschaften

Festlegen von Verweiseigenschaften

Zusammenfassung der Datentypen und Datentypwerte


Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

  • Ziehen Sie ein Feld aus der Struktur der Quellspezifikation oder der Zielspezifikation auf ein Funktoid im Zuordnungsraster.

    Oder

    Ziehen Sie das Funktoid aus dem Zuordnungsraster auf ein Feld in der Struktur der Quellspezifikation oder der Zielspezifikation.

Wichtig

  • Ein Feld mit einer bestimmten Datentypeigenschaft in der Struktur der Zielspezifikation einer Zuordnung sollte nicht mit einem Funktoid verknüpft werden, das eine Ausgabe mit einem anderen Datentyp erzeugt.

Anmerkungen

  • Sie müssen zuerst ein Funktoid zum Zuordnungsraster hinzufügen, bevor Sie eine Verknüpfung aus einem Feld zum Funktoid hinzufügen können. Weitere Informationen zum Hinzufügen eines Funktoids zum Zuordnungsraster finden Sie unter Arbeiten mit Funktoiden.

  • Sie können keine Verknüpfung mit einem Knoten (in der Zielspezifikation) erstellen, dem ein konstanter Wert für das Ziel zugeordnet ist.

  • Sie können keine Verknüpfung zu einem erforderlichen Feld (in der Zielspezifikation) erstellen, dem ein Standardwert zugeordnet ist. Weitere Informationen dazu, wie Sie ein Feld als erforderliches Feld definieren, finden Sie unter Festlegen von Verweiseigenschaften. Weitere Informationen zum Festlegen des Standardwertes eines Feldes finden Sie unter Festlegen von Deklarationseigenschaften.

Verwandte Themen

Hinzufügen von konstanten Werten

Verwalten von Ansichten

Festlegen von Deklarationseigenschaften

Festlegen von Verweiseigenschaften

Arbeiten mit Funktoiden


Erstellen von Verknüpfungen zwischen Datensätzen und Feldern

  1. Klicken Sie im Menü Extras auf Optionen.

  2. Aktivieren Sie im Dialogfeld Optionen für den BizTalk-Mapper das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

  3. Ziehen Sie einen Datensatz aus der Struktur der Quellspezifikation auf ein Feld in der Struktur der Zielspezifikation.

    Oder

    Ziehen Sie einen Datensatz aus der Struktur der Zielspezifikation auf ein Feld der Struktur der Quellspezifikation.

Anmerkungen

  • Sie können keine Verknüpfung mit einem Knoten in der Zielspezifikation erstellen, dem ein konstanter Wert für das Ziel zugeordnet ist.

  • Sie können keine Verknüpfung zu einem erforderlichen Feld in der Zielspezifikation erstellen, dem ein Standardwert zugeordnet ist. Weitere Informationen dazu, wie Sie ein Feld als erforderliches Feld definieren, finden Sie unter Festlegen von Verweiseigenschaften. Weitere Informationen zum Festlegen des Standardwertes eines Feldes finden Sie unter Festlegen von Deklarationseigenschaften.

  • Möglicherweise müssen Sie die Spezifikationsstrukturen erweitern, um die Datensätze und Felder anzuzeigen, die Sie zuordnen möchten. Weitere Informationen finden Sie unter Erweitern von Strukturelementen.

Verwandte Themen

Hinzufügen von konstanten Werten

Verwalten von Ansichten

Festlegen von Deklarationseigenschaften

Festlegen von Verweiseigenschaften


Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Aktivieren Sie das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

  3. Ziehen Sie einen Datensatz aus der Struktur der Quellspezifikation oder der Zielspezifikation auf ein Funktoid im Zuordnungsraster.

    Oder

    Ziehen Sie das Funktoid aus dem Zuordnungsraster auf einen Datensatz in der Struktur der Quellspezifikation oder der Zielspezifikation.

Anmerkungen

  • Sie müssen zuerst ein Funktoid zum Zuordnungsraster hinzufügen, bevor Sie eine Verknüpfung von einem Datensatz zum Funktoid hinzufügen können.

  • Sie können keine Verknüpfung mit einem Knoten in der Zielspezifikation erstellen, dem ein konstanter Wert für das Ziel zugeordnet ist. Weitere Informationen zu konstanten Werten für das Ziel finden Sie unter BizTalk-Mapper - Benutzeroberfläche.

Verwandte Themen

Hinzufügen von konstanten Werten

Verwalten von Ansichten


Erstellen von Verknüpfungen zwischen Funktoiden

  • Ziehen Sie ein Funktoid auf ein anderes Funktoid im Zuordnungsraster.

Anmerkung

  • Verknüpfungen werden im Zuordnungsraster von links nach rechts verarbeitet. Sie können keine Verknüpfung von einem Funktoid zu einem anderen Funktoid direkt darunter oder darüber erstellen.

Verwandte Themen

Erstellen von Verknüpfungen zwischen Feldern und Funktoiden

Erstellen von Verknüpfungen zwischen Datensätzen und Funktoiden


Zulassen von Verknüpfungen für Datensatzinhalte

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Aktivieren Sie das Kontrollkästchen Verknüpfungen von Datensatzinhalten zulassen, und klicken Sie auf OK.

  3. Ziehen Sie einen Datensatz aus der Struktur der Quellspezifikation auf einen Datensatz in der Struktur der Zielspezifikation.


Umleiten von Verknüpfungen

  1. Klicken Sie im Zuordnungsraster auf eine Verknüpfung, um diese zu markieren.

    Die Endpunkte der Verknüpfungen sind mit kleinen blauen Kästchen markiert.

  2. Ziehen Sie einen der Endpunkte zum Funktoid oder Knoten, mit dem Sie eine Verbindung herstellen möchten.

    Wenn Sie den Endpunkt ziehen, verwandelt sich der Mauszeiger in ein Fadenkreuz. Wenn Sie auf ein Objekt zeigen, mit dem keine Verknüpfung hergestellt werden kann, verwandelt sich der Zeiger in einen diagonal durchgestrichenen Kreis.

Wichtig

  • Wenn zwei oder mehrere Quellverknüpfungen mit einem Funktoid verbunden sind und Sie eine oder mehrere dieser Quellverknüpfungen zu unterschiedlichen Knoten in der Struktur der Quellspezifikation umleiten, bleibt die Reihenfolge der Eingabeparameter des Funktoids möglicherweise nicht erhalten. Doppelklicken Sie auf das Funktoid, um seine Eingabeparameter anzuzeigen, und stellen Sie sicher, dass diese in der korrekten Reihenfolge stehen.


Löschen von Verknüpfungen

  1. Klicken Sie mit der rechten Maustaste auf die Verknüpfung, die Sie löschen möchten, und klicken Sie dann auf Löschen.

  2. Klicken Sie im Bestätigungsdialogfeld auf Ja.


Anzeigen von Rasterverknüpfungen und Funktoiden

Folgende Themen werden in diesem Abschnitt behandelt:

  • Anzeigen von Verknüpfungen und Funktoiden im Zuordnungsraster

  • Anzeigen von Verknüpfungen und Funktoiden mithilfe der Rastervorschau


Anzeigen von Verknüpfungen und Funktoiden im Zuordnungsraster

  1. Bewegen Sie den Cursor im Zuordnungsraster entlang des Randes in die Richtung, in die Sie blättern möchten.

    Der Cursor verwandelt sich von einem Zeiger oder einem senkrechten Balken in einen großen Pfeil.

  2. Klicken Sie mit der linken Maustaste, und halten Sie diese gedrückt, um in die Richtung zu blättern, in die der Zeiger zeigt.

Anmerkung

  • Sie können auch blättern, indem Sie in den Hintergrund des Zuordnungsrasters klicken und dann mit den PFEILTASTEN in alle vier Richtungen blättern.

Verwandte Themen

BizTalk-Mapper - Benutzeroberfläche

Anzeigen von Verknüpfungen und Funktoiden mithilfe der Rastervorschau


Anzeigen von Verknüpfungen und Funktoiden mithilfe der Rastervorschau

  1. Klicken Sie im Menü Ansicht auf Rastervorschau.

    Das Fenster Rastervorschau wird geöffnet und stellt dar, wo sich die Funktoide im Zuordnungsraster befinden.

  2. Ziehen Sie die grüne Positionierungsleiste im Dialogfeld Rastervorschau an einen neuen Ort.

    Wenn Sie die grüne Positionierungsleiste verschieben, werden die Verknüpfungen und Funktoide im Zuordnungsraster ebenfalls verschoben.

Anmerkung

  • Die Rastervorschau ist hilfreich für das Navigieren im Zuordnungsraster, wenn viele Funktoide über das Zuordnungsraster verteilt sind.

Verwandte Themen

BizTalk-Mapper - Benutzeroberfläche

Anzeigen von Verknüpfungen und Funktoiden im Zuordnungsraster


Bearbeiten von Verknüpfungseigenschaften

  • Klicken Sie mit der rechten Maustaste auf eine Verknüpfung im Zuordnungsraster und dann auf Eigenschaften, um das Dialogfeld Verknüpfungseigenschaften aufzurufen.

    Die Registerkarte Allgemein wird als Standardregisterkarte angezeigt.

Weitere Informationen zur Verwendung dieses Dialogfeldes finden Sie in den folgenden Themen:

  • Anzeigen von Verknüpfungseigenschaften: Registerkarte "Allgemein"

  • Anzeigen von Verknüpfungseigenschaften: Registerkarte "Compiler"

Anmerkung

  • Sie können auf eine Verknüpfung auch doppelklicken, um ihre Eigenschaften anzuzeigen.

Verwandte Themen

Kompilieren von Zuordnungen

Verwalten von Verknüpfungen


Anzeigen von Verknüpfungseigenschaften: Registerkarte "Allgemein"

Weitere Informationen zum Zugriff auf das Dialogfeld Verknüpfungseigenschaften finden Sie unter Bearbeiten von Verknüpfungseigenschaften.

Die Registerkarte Allgemein zeigt Informationen zur Quelle und zum Ziel einer Verknüpfung an. Der Bereich Quelle zeigt den Datensatzpfad, den Feldpfad oder den Namen des Funktoids für die Verknüpfungsquelle an, je nachdem, ob die Verknüpfungsquelle ein Datensatz, ein Feld oder ein Funktoid ist. Der Bereich Ziel zeigt den Datensatzpfad, den Feldpfad oder den Funktoidnamen für das Verknüpfungsziel an, je nachdem, ob das Verknüpfungsziel ein Datensatz, ein Feld oder ein Funktoid ist.

Verwandtes Thema

Anzeigen von Verknüpfungseigenschaften: Registerkarte "Compiler"


Anzeigen von Verknüpfungseigenschaften: Registerkarte "Compiler"

Weitere Informationen zum Zugriff auf das Dialogfeld Verknüpfungseigenschaften finden Sie unter Bearbeiten von Verknüpfungseigenschaften.

Die Registerkarte Compiler stellt einen Bereich zum Festlegen der Compilereigenschaften für Quellspezifikationsverknüpfungen und einen Bereich für das Festlegen der Compilereigenschaften für Zielspezifikationsverknüpfungen bereit. Weitere Informationen zum Ändern dieser Einstellungen finden Sie in den folgenden Themen:

  • Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen

  • Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen

Verwandtes Thema

Anzeigen von Verknüpfungseigenschaften: Registerkarte "Allgemein"


Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen

  1. Klicken Sie mit der rechten Maustaste auf eine Verknüpfung im Zuordnungsraster, die mit einem Knoten in der Struktur der Quellspezifikation verbunden ist, und klicken Sie auf Eigenschaften.

    Das Dialogfeld Verknüpfungseigenschaften wird angezeigt.

  2. Klicken Sie auf die Registerkarte Compiler, und klicken Sie auf eine der folgenden Optionen im Bereich Quellspezifikationsverknüpfungen:
    • Wert kopieren (Standard). Kopiert den Wert des Knotens in die eingehende Dokumentinstanz.<Node>Hello<Name>Chris</Name>Cannon</Node> ergibt beispielsweise "Hello"

    • Text und untergeordnete Inhaltswerte kopieren. Kopiert den verketteten Wert des Knotens und alle davon abgeleiteten Werte in die eingehende Dokumentinstanz. <Node>Hello<Name>Chris</Name>Cannon</Node> ergibt beispielsweise "Hello Chris Cannon"

    • Namen kopieren. Kopiert den Namen des Knotens in die eingehende Dokumentinstanz.
  3. Klicken Sie auf OK.

Wichtig

  • Wenn ein Element gemischte Inhalte enthält, z. B. Daten mit eingefügten untergeordneten Elementen, und Sie Wert kopieren (Standard) auswählen, wird nur der Inhalt kopiert, der bis zum ersten untergeordneten Element vorhanden ist. Beispiel:
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    führt zum Kopieren von Item.

  • Wenn ein Element gemischte Inhalte enthält, z. B. Daten mit eingefügten untergeordneten Elementen, und Sie Text und untergeordnete Inhaltswerte kopieren auswählen, wird der gesamte Inhalt einschließlich der untergeordneten Elemente kopiert. Beispiel:
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    führt zum Kopieren von Item1121314Number.

Verwandtes Thema

Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen


Auswählen von Compilereigenschaften für Zielspezifikationsverknüpfungen

  1. Klicken Sie mit der rechten Maustaste auf eine Verknüpfung im Zuordnungsraster, die mit einem Knoten in der Zielspezifikation verbunden ist, und klicken Sie auf Eigenschaften.

  2. Klicken Sie auf die Registerkarte Compiler, und klicken Sie auf eine der folgenden Optionen im Bereich Zielspezifikationsverknüpfungen:
    • Verknüpfungen vereinfachen (Standard). In diesem Modus werden alle Quellhierarchien auf den übergeordneten Knoten des Zielknotens vereinfacht.

    • Verknüpfungen von oben nach unten zuordnen. Dieser Modus ordnet die Ebenen nacheinander von oben nach unten zu.

    • Verknüpfungen von unten nach oben zuordnen. Dieser Modus ordnet die Ebenen nacheinander von unten nach oben zu.
  3. Klicken Sie auf OK.

Anmerkungen

  • Wenn Sie für Verknüpfungen von Feldern in der Struktur der Quellspezifikation mit Feldern in der Struktur der Zielspezifikation, die demselben übergeordneten Datensatz angehören, eine Compilerdirektive des Typs Verknüpfungen vereinfachen, eine Compilerdirektive des Typs Verknüpfungen von oben nach unten zuordnen und eine Compilerdirektive des Typs Verknüpfungen von unten nach oben zuordnen verwenden, behandelt der BizTalk-Mapper alle Verknüpfungen so, als ob für sie die Compilerdirektive des Typs Verknüpfungen vereinfachen festgelegt wurde.

  • Wenn Sie für Verknüpfungen von Feldern in der Struktur der Quellspezifikation mit Feldern in der Struktur der Zielspezifikation, die demselben übergeordneten Datensatz angehören, eine oder mehrere Compilerdirektiven des Typs Verknüpfungen vereinfachen und eine Compilerdirektive des Typs Verknüpfungen von oben nach unten zuordnen verwenden, behandelt der BizTalk-Mapper alle Verknüpfungen so, als ob für sie die Compilerdirektive Verknüpfungen von oben nach unten zuordnen festgelegt wurde.

  • Wenn Sie für Verknüpfungen von Feldern in der Struktur der Quellspezifikation mit Feldern in der Struktur der Zielspezifikation, die demselben übergeordneten Datensatz angehören, eine oder mehrere Compilerdirektiven des Typs Verknüpfungen vereinfachen und eine Compilerdirektive des Typs Verknüpfungen von unten nach oben zuordnen verwenden, behandelt der BizTalk-Mapper alle Verknüpfungen so, als ob für sie die Compilerdirektive Verknüpfungen von unten nach oben zuordnen festgelegt wurde.

  • Wenn Sie für Verknüpfungen von Feldern in der Struktur der Quellspezifikation mit Feldern in der Struktur der Zielspezifikation, die demselben übergeordneten Datensatz angehören, eine oder mehrere Compilerdirektiven des Typs Verknüpfungen von oben nach unten zuordnen und eine oder mehrere Compilerdirektiven des Typs Verknüpfungen von unten nach oben zuordnen verwenden, behandelt der BizTalk-Mapper alle Verknüpfungen so, als ob für sie die Compilerdirektive Verknüpfungen vereinfachen festgelegt wurde.

Verwandte Themen

Zuordnen der Ebenen innerhalb der Knotenhierarchie

Auswählen von Compilereigenschaften für Quellspezifikationsverknüpfungen


Erstellen und Verwalten von kompilierten Zuordnungen

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Kompilieren von Zuordnungen

  • Auflösen von Warnungen und Beheben von Fehlern nach dem Kompilieren einer Zuordnung

  • Hinzufügen von konstanten Werten


Kompilieren von Zuordnungen

  • Klicken Sie im Menü Extras auf Zuordnung kompilieren.

Vorsicht

  • Der BizTalk-Mapper generiert eine Warnung auf der Registerkarte Warnungen, wenn der Compiler auf einen Umstand stößt, der zu fehlerhaften Ergebnissen führt. Eine Zuordnung kann erst dann als für eine produktive Umgebung einsatzbereit betrachtet werden, wenn sie keine Warnungen mehr generiert.

Anmerkung

  • Wenn eine Warnung angezeigt wird, kann sich das Problem auf mehrere Rasterseiten beziehen. Wenn z. B. die Rasterseite 1 mit dem Datensatz Item in der Struktur der Quellspezifikation mit dem Datensatz Number in der Struktur der Zielspezifikation verknüpft ist und auf Rasterseite 2 der Datensatz Product in der Struktur der Quellspezifikation mit demselben Datensatz Number in der Struktur der Zielspezifikation verknüpft ist, wird eine Warnmeldung erzeugt, die besagt, dass mehrere Eingaben in denselben Datensatz erfolgen. Wenn Sie jedoch die Rasterseite 1 anzeigen, wird nur eine Eingabe in den Datensatz Number angezeigt.

Verwandtes Thema

Auflösen von Warnungen und Beheben von Fehlern nach dem Kompilieren einer Zuordnung


Auflösen von Warnungen und Beheben von Fehlern nach dem Kompilieren einer Zuordnung

Wenn eine Warnung angezeigt wird, kann sich das Problem auf mehrere Rasterseiten beziehen. Wenn z. B. die Rasterseite 1 mit dem Datensatz Item in der Struktur der Quellspezifikation mit dem Datensatz Number in der Struktur der Zielspezifikation verknüpft ist und auf Rasterseite 2 der Datensatz Product in der Struktur der Quellspezifikation mit demselben Datensatz Number in der Struktur der Zielspezifikation verknüpft ist, wird eine Warnmeldung erzeugt, die besagt, dass mehrere Eingaben in denselben Datensatz erfolgen. Wenn Sie jedoch die Rasterseite 1 anzeigen, wird nur eine Eingabe in den Datensatz Number angezeigt.

  1. Doppelklicken Sie auf der Registerkarte Warnungen auf eine Warnung.

    Die Verknüpfung , das Funktoid oder der Knoten, auf die/das/den sich die Warnung oder der Fehler bezieht, wird im Zuordnungsraster markiert hervorgehoben.

  2. Ändern Sie die Verknüpfung, das Funktoid oder den Knoten den Anforderungen entsprechend.

  3. Wiederholen Sie die Schritte 1 und 2 für jede Warnung.

  4. Klicken Sie im Menü Extras auf Zuordnung kompilieren.

Verwandtes Thema

Kompilieren von Zuordnungen


Hinzufügen von konstanten Werten

  1. Wählen Sie einen Datensatz oder ein Feld in der Struktur der Zielspezifikation aus, und klicken Sie auf die Registerkarte Werte.

  2. Geben Sie in das Feld Konstanter Wert für Ziel einen Wert ein, den Sie dem Datensatz oder Feld zuordnen möchten.

Anmerkungen

  • Sie können keine Verknüpfung zu einem Datensatz oder Feld erstellen, dem ein konstanter Wert zugeordnet ist.

  • Sie können einem Datensatz nur dann einen konstanten Wert zuordnen, wenn seine Eigenschaft Inhalt auf Nur Text oder Gemischt festgelegt wurde. Weitere Informationen zur Eigenschaft Inhalt finden Sie unter Festlegen von Deklarationseigenschaften.

Verwandtes Thema

Festlegen von Deklarationseigenschaften


Ausführen von Zuordnungstests

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Testen von Eigenschaften von Datensätzen und Feldern mit Verknüpfungen

  • Testen von Zuordnungen


Testen von Eigenschaften von Datensätzen und Feldern mit Verknüpfungen

Wichtig

  • Kompilieren Sie eine Zuordnung immer, bevor Sie diese testen, damit Sie Warnungen auflösen und Fehler beheben können. Weitere Informationen finden Sie unter Kompilieren von Zuordnungen.
  3. Klicken Sie auf ein Feld in der Struktur der Quellspezifikation, die mit einer Verknüpfung verbunden ist.

  4. Klicken Sie auf die Registerkarte Werte.

  5. Geben Sie einen Wert in das Feld Quelltestwert ein.

  6. Zeigen Sie im Menü Extras auf Zuordnung testen, und klicken Sie auf die gewünschte Option.

    Wichtig

    • Bevor der Test beginnt, werden Sie aufgefordert, die Zuordnungsdatei zu speichern. Speichern Sie die Datei vor dem Testen als Sicherheitsmaßnahme für den Fall, dass unvorhergesehene Fehler in der Datei auftreten.
  7. Klicken Sie auf Ja, um die Zuordnung zu aktualisieren.

  8. Überprüfen Sie die Ergebnisse auf der Registerkarte Ausgabe.

Anmerkung

  • Falls die Eigenschaft Maximalvorkommen für einen Datensatz ein Sternchen (*) ist, gibt dies an, dass dies ein Schleifendatensatz ist. Die eingehende Dokumentinstanz, die der BizTalk-Mapper generiert, um die Zuordnung zu testen, enthält den Datensatz zweimal.

Verwandte Themen

Kompilieren von Zuordnungen

Testen von Zuordnungen


Testen von Zuordnungen

Wichtig

  • Kompilieren Sie eine Zuordnung immer, bevor Sie diese testen, damit Sie Warnungen auflösen und Fehler beheben können. Weitere Informationen finden Sie unter Kompilieren von Zuordnungen.

  • Wenn Sie den Inhalt vor dem Testen einer Zuordnung überprüfen möchten:
    1. Klicken Sie im Menü Extras auf Optionen.

      Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

    2. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Inhalt vor Zuordnungstest überprüfen, und klicken Sie auf OK.

    Anmerkung

    • Wenn eine der verwendeten Spezifikationen in der Zuordnung keine auf BizTalk Server basierende Spezifikation ist, wie z. B. eine XDR-Datei (XML-Data Reduced) und Sie die Inhaltsüberprüfungsfunktion verwenden, kann die Überprüfung misslingen. Wenn nach dem Öffnen der XDR-Datei Warnmeldungen angezeigt werden, insbesondere zu Namespaces oder Elementgruppen, sollten Sie die Inhaltsüberprüfungsfunktion nicht verwenden.
  • Wenn Sie den Inhalt nach dem Testen einer Zuordnung überprüfen möchten:
    1. Klicken Sie im Menü Extras auf Optionen.

      Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

    2. Aktivieren Sie auf der Registerkarte Allgemein das Kontrollkästchen Inhalt nach Zuordnungstest überprüfen, und klicken Sie auf OK.

    Anmerkung

    • Wenn eine der verwendeten Spezifikationen in der Zuordnung keine auf BizTalk Server basierende Spezifikation ist, wie z. B. eine XDR-Datei (XML-Data Reduced) und Sie die Inhaltsüberprüfungsfunktion verwenden, kann die Überprüfung misslingen. Wenn nach dem Öffnen der XDR-Datei Warnmeldungen angezeigt werden, insbesondere zu Namespaces oder Elementgruppen, sollten Sie die Inhaltsüberprüfungsfunktion nicht verwenden.
  1. Zeigen Sie im Menü Extras auf Zuordnung testen, und klicken Sie auf die gewünschte Option.

    Wichtig

    • Bevor der Test beginnt, werden Sie aufgefordert, die Zuordnungsdatei zu speichern. Speichern Sie Ihre Datei vor dem Testen als Sicherheitsmaßnahme für den Fall, dass unvorhergesehene Fehler in der Datei auftreten.
  2. Klicken Sie auf Ja, um die Zuordnung zu aktualisieren.

  3. Wenn während des Kompilierungsprozesses Warnungen erzeugt werden, wird ein Meldungsfeld angezeigt. Klicken Sie auf Ja, um fortzufahren.

  4. Wenn Sie Generiertes XML in Systemeigen aktiviert haben und das Ausgabeschema eine auf EDI basierende Struktur ist, müssen Sie im Dialogfeld Dokumenttrennzeichen Trennzeichen angeben. Ausführliche Informationen zum Angeben von Trennzeichen finden Sie unter Optionen für den BizTalk-Mapper: Dokumenttrennzeichen.

    Oder

    Wenn Sie Instanz-XML in XML oder Instanz-XML in Systemeigen aktiviert haben, wird das Dialogfeld XML-Instanzdatei laden angezeigt. Suchen Sie eine Instanzdatei, und klicken Sie auf Öffnen.

    Oder

    Wenn Sie Systemeigene Instanz in XML oder Systemeigene Instanz in Systemeigen aktiviert haben, wird das Dialogfeld Systemeigene Instanzdatei laden angezeigt. Suchen Sie eine Instanzdatei, und klicken Sie auf Öffnen.

    Anmerkungen

    • Die Optionen Generiertes XML in Systemeigen und Instanz-XML in Systemeigen sind nicht verfügbar, wenn das Ausgabeschema XML ist.

    • Die Option Systemeigene Instanz in Systemeigen ist nicht verfügbar, wenn das Ein- oder Ausgabeschema XML ist.

    • Wenn ein EDI-Austausch mehrere Dokumente enthält, wird nur die erste Dokumentinstanz in der Testzuordnung verwendet.

    • Wenn das Feld Zur Eingabe von Trennzeichen bei Instanztests auffordern aktiviert ist und die getestete Instanz eine EDI-Datei mit Umschlaginformationen ist, wird das Dialogfeld Dokumenttrennzeichen nicht angezeigt, da der BizTalk-Mapper das benötigte Trennzeichen automatisch erkennt. Der BizTalk-Mapper zeigt das Feld Zur Eingabe von Trennzeichen bei Instanztests auffordern nur an, wenn er die zu verwendenden Trennzeichen nicht ermitteln kann. Dies gilt auch, wenn Sie angegeben haben, dass es bei Instanztests angezeigt werden soll.
  5. Überprüfen Sie die Ergebnisse auf der Registerkarte Ausgabe.

Wichtig

  • In seltenen Fällen kann der BizTalk-Mapper in einer einzelnen Transformation Daten nicht zuordnen. BizTalk Server bietet jedoch die Möglichkeit, ein Dokument synchron zweimal zuzuordnen, und zwar mithilfe zweier Iterationen unter Verwendung von SubmitSync und LoopBack als primäre Transporte in der Portkonfiguration. Auf diese Weise können Sie eine Zuordnung in verschiedene Phasen aufteilen, indem verschiedene Kanäle wieder verwendet und kombiniert werden. Weitere Informationen dazu finden Sie im Beispielordner Mapping Twice in \Programme\Microsoft BizTalk Server\SDK\Messaging Samples.

  • Zeichenbereiche werden ignoriert. Wenn Sie Zeichenbeschränkungen für eine Zuordnung aktiviert haben und diese nicht eingehalten werden, wird dennoch angezeigt, dass die Testzuordnung erfolgreich war. Wenn BizTalk Server jedoch versucht, die Transaktion zu analysieren, misslingt dieser Vorgang.

  • Obgleich Sie möglicherweise eine systemeigene Instanz erfolgreich erstellen können, misslingt diese, wenn Sie später die Instanzüberprüfung abschließen und die Syntaxregeln nicht eingehalten werden.

Verwandte Themen

Kompilieren von Zuordnungen

Testen von Zuordnungen

Copyright © 1999–2001 Microsoft Corporation.
Alle Rechte vorbehalten.

Fanden Sie diese Informationen hilfreich? Bitte senden Sie Ihre Vorschläge und Anmerkungen zur Dokumentation an BizTalk Server Dokumentationsfeedback@microsoft.com


Verwalten von Ansichten

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Erweitern von Strukturelementen

  • Reduzieren von Strukturelementen

  • Anzeigen von Datensatz- und Feldeigenschaften

  • Anpassen der Fenstergröße für die Struktur der Quellspezifikation

  • Anpassen der Fenstergröße für die Struktur der Zielspezifikation

  • Ändern der Größe des unteren Fensters


Erweitern von Strukturelementen

  • Klicken Sie auf den Stammknoten oder einen Datensatz in der Spezifikationsstruktur, den Sie erweitern möchten, und klicken Sie im Menü Ansicht auf Strukturelemente erweitern.

    Oder

    Klicken Sie mit der rechten Maustaste auf einen Stammknoten oder einen Datensatz in einer Struktur, und klicken Sie auf Strukturelemente erweitern.

Verwandtes Thema

Reduzieren von Strukturelementen


Reduzieren von Strukturelementen

  • Klicken Sie auf den Stammknoten oder einen Datensatz in der Spezifikationsstruktur, den Sie reduzieren möchten, und klicken Sie im Menü Ansicht auf Strukturelemente reduzieren.

Anmerkung

  • Sie können auch mit der rechten Maustaste auf den Stammknoten oder einen Datensatz in einer Struktur klicken und dann auf Strukturelemente reduzieren klicken.

Verwandtes Thema

Erweitern von Strukturelementen


Anzeigen von Datensatz- und Feldeigenschaften

  • Klicken Sie auf einen Datensatz oder ein Feld entweder in der Struktur der Quellspezifikation oder in der Struktur der Zielspezifikation, und klicken Sie im Menü Ansicht auf Eigenschaften.

    Oder

    Wählen Sie einen Datensatz oder ein Feld in einer der Strukturen aus, und klicken Sie auf die Registerkarte Eigenschaften.

Anmerkung

  • Sie müssen möglicherweise die Bildlaufleiste auf der Registerkarte Eigenschaften ziehen, um eine bestimmte Eigenschaft und den ihr zugeordneten Wert zu sehen.


Anpassen der Fenstergröße für die Struktur der Quellspezifikation

  1. Positionieren Sie den Cursor an den rechten Fensterrand der Struktur der Quellspezifikation, bis sich der Cursor in einen Pfeil mit zwei Spitzen verwandelt.

  2. Ziehen Sie den Rand nach rechts, um die Fenstergröße zu vergrößern, oder nach links, um die Fenstergröße zu verringern.

Anmerkung

  • Doppelklicken Sie auf den Rand, um seine Standardposition wiederherzustellen.

Verwandte Themen

Anpassen der Fenstergröße für die Struktur der Zielspezifikation

Ändern der Größe des unteren Fensters


Anpassen der Fenstergröße für die Struktur der Zielspezifikation

  1. Positionieren Sie den Cursor an den linken Fensterrand der Struktur der Zielspezifikation, bis sich der Cursor in einen Pfeil mit zwei Spitzen verwandelt.

  2. Ziehen Sie den Rand nach links, um die Fenstergröße zu vergrößern, oder nach rechts, um die Fenstergröße zu verringern.

Anmerkung

  • Doppelklicken Sie auf den Rand, um seine Standardposition wiederherzustellen.

Verwandte Themen

Anpassen der Fenstergröße für die Struktur der Quellspezifikation

Ändern der Größe des unteren Fensters


Ändern der Größe des unteren Fensters

  1. Positionieren Sie den Cursor an den oberen Rand des unteren Fensters, bis sich der Cursor in einen Pfeil mit zwei Spitzen verwandelt.

  2. Ziehen Sie das Fenster nach oben, um die Fenstergröße zu vergrößern, oder nach unten, um die Fenstergröße zu verringern.

Anmerkung

  • Doppelklicken Sie auf den Rand, um seine Standardposition wiederherzustellen.

Verwandte Themen

Anpassen der Fenstergröße für die Struktur der Zielspezifikation

Anpassen der Fenstergröße für die Struktur der Quellspezifikation


Anpassen der Benutzeroberfläche

Folgende Verfahren werden in diesem Abschnitt behandelt:

  • Ändern der Farben des Zuordnungsrasters

  • Ändern der Farbe von Verknüpfungen

  • Ändern der Farbe von ausgewählten Objekten

  • Ändern der Farbe von Compilerwarnungen

  • Wiederherstellen der Standardfarben

  • Ändern der Textgröße


Ändern der Farben des Zuordnungsrasters

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Farben.

  3. Klicken Sie auf das Kästchen neben Rastervordergrund, das die gestrichelten Linien im Zuordnungsraster darstellt. Wählen Sie aus der Farbpalette eine neue Farbe aus.

    Oder

    Klicken Sie auf das Kästchen neben Rasterhintergrund, das die Hintergrundfarbe des Zuordnungsrasters darstellt. Wählen Sie aus der Farbpalette eine neue Farbe aus.

  4. Klicken Sie auf OK.

Verwandte Themen

Ändern der Farbe von Compilerwarnungen

Ändern der Farbe von Verknüpfungen

Ändern der Farbe von ausgewählten Objekten

Wiederherstellen der Standardfarben


Ändern der Farbe von Verknüpfungen

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Farben.

  3. Klicken Sie auf das Kästchen neben einer der folgenden Optionen:
    • Feste Verknüpfungen. Feste Verknüpfungen sind einfache wertekopierende Verknüpfungen im Zuordnungsraster.

    • Elastische Verknüpfungen. Elastische Verknüpfungen sind einfache Wertkopierverknüpfungen, die aus der Struktur der Quellspezifikation in die Struktur der Zielspezifikation gezogen werden. Nach dem Erstellen der Verknüpfung ändert sich die Farbe der Verknüpfung in die zuvor festgelegte Farbe für Verknüpfungen.

    • Teilverknüpfungen. Teilverknüpfungen sind Verknüpfungen, die für ein Feld oder einen Datensatz bestehen, dessen übergeordneter Datensatz reduziert ist.

Compilerverknüpfungen. Compilerverknüpfungen sind Compilerdirektivverknüpfungen. Dies sind festgelegte Verknüpfungen, die automatisch generiert werden, wenn eine Verknüpfung zwischen einem Feld der Quellspezifikationsstruktur und einem Feld der Zielspezifikationsstruktur definiert wird.

    4. Wählen Sie aus der Farbpalette eine neue Farbe aus.

    5. Wiederholen Sie Schritt 3, um ggf. weitere Farben zu ändern.

    6. Klicken Sie auf OK.

    Verwandte Themen

    Ändern der Farben des Zuordnungsrasters

    Ändern der Farbe von Compilerwarnungen

    Ändern der Farbe von ausgewählten Objekten

    Wiederherstellen der Standardfarben


Ändern der Farbe von ausgewählten Objekten

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Farben.

  3. Klicken Sie in das Kästchen neben Ausgewählte Objekte, und wählen Sie aus der Farbpalette eine neue Farbe aus.

  4. Klicken Sie auf OK.

Verwandte Themen

Ändern der Farben des Zuordnungsrasters

Ändern der Farbe von Compilerwarnungen

Ändern der Farbe von Verknüpfungen

Wiederherstellen der Standardfarben


Ändern der Farbe von Compilerwarnungen

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Farben.

  3. Klicken Sie in das Kästchen neben Compilerwarnungen, und wählen Sie aus der Farbpalette eine neue Farbe aus.

  4. Klicken Sie auf OK.

Verwandte Themen

Ändern der Farben des Zuordnungsrasters

Ändern der Farbe von Verknüpfungen

Ändern der Farbe von ausgewählten Objekten

Wiederherstellen der Standardfarben


Wiederherstellen der Standardfarben

  1. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Optionen für den BizTalk-Mapper wird angezeigt.

  2. Klicken Sie auf die Registerkarte Farben.

  3. Klicken Sie auf Standardfarben wiederherstellen, und klicken Sie auf OK.

Verwandte Themen

Ändern der Farben des Zuordnungsrasters

Ändern der Farbe von Compilerwarnungen

Ändern der Farbe von Verknüpfungen

Ändern der Farbe von ausgewählten Objekten


BizTalk-Mapper - Tastenkombinationen

Der BizTalk-Mapper bietet verschiedene Tastenkombinationen zum Ausführen von Aufgaben . Die folgende Tabelle ist eine kurze Referenz zu diesen Tastenkombinationen.

Anmerkung

  • Sie können mithilfe der Zehnertastatur den Mauszeiger mit der Tastaturmaus bewegen, um Funktionen zu verwenden, die in dieser Liste nicht enthalten sind. Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Server- und Advanced Server-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastatur". Weitere Informationen zur Tastaturmaus finden Sie in der Windows 2000 Professional-Hilfe unter "Bewegen des Mauszeigers mithilfe der Tastaturmaus".
Taste/Tastenkombination | Zweck
STRG+N | Eine neue Spezifikation öffnen.
STRG+O | Eine vorhandene Zuordnung öffnen.
STRG+S | Eine Zuordnung speichern.
STRG+F5 | Eine Zuordnung testen.
F4 | Die nächste Warnmeldung markieren.
F5 | Eine Zuordnung kompilieren.
STRG+A | Eine Rasterseite hinzufügen.
Auf dem Namen einer Rasterseite, F2 | Eine Rasterseite umbenennen.
STRG+D | Eine Rasterseite löschen.
ENTF | Ein Objekt im Zuordnungsraster löschen.
F6 | Den Fokus im Uhrzeigersinn zum nächsten Fensterbereich verschieben.
UMSCHALT+F6 | Den Fokus entgegen dem Uhrzeigersinn zum nächsten Fensterbereich verschieben. Durch Drücken von UMSCHALT+F6 nach dem Öffnen der Funktoidpalette wird der Fokus zur Registerkarte Zeichenfolge verschoben; mit der linken oder rechten Pfeiltaste können die anderen Registerkarten angezeigt werden.
UMSCHALT+F10 | Öffnen des Kontextmenüs für markierte Elemente.
TAB | Fokus im Uhrzeigersinn im unteren Fensterbereich von der Registerkarte zu den Fensterbereichen oder Feldern darunter verschieben. Durch Drücken von TAB in einem Dialogfeld wird der Fokus zwischen den Schaltflächen und Feldern im Dialogfeld verschoben. Darüber hinaus können Sie dadurch auf die Schaltflächen oben rechts im Dialogfeld Quellspezifikationstyp auswählen zugreifen.
UMSCHALT+TAB | Fokus entgegen dem Uhrzeigersinn im unteren Fensterbereich von der Registerkarte zu den Fensterbereichen oder Feldern darunter verschieben.
LEERTASTE | Aktivieren oder Deaktivieren eines Kontrollkästchens. Die Leertaste verhält sich darüber hinaus wie ein Mausklick, wenn der Fokus sich auf einer Schaltfläche befindet.
F1 | Onlinehilfe anzeigen.
ALT+F4 | Programm schließen.
PFEILTASTEN | Den Fokus in das Fenster Rastervorschau verschieben.
NACH-LINKS-TASTE | Registerkarte links aktivieren.
NACH-RECHTS-TASTE | Registerkarte rechts aktivieren.
Eine beliebige Pfeiltaste | Einen Ordner oder eine Datei im Hauptfensterbereich eines Dialogfeldes markieren, während sich der Fokus auf diesem Bereich befindet. Diese Funktion steht in den Dialogfeldern In WebDAV speichern und Aus WebDAV abrufen zur Verfügung. Weitere Informationen finden Sie unter Abrufen von Zuordnungen aus WebDAV.

Verwenden der Tastaturmaus mit BizTalk-Mapper

Verschiedenen Vorgängen in BizTalk-Mapper sind keine Tastenkombinationen zugeordnet. Wenn Sie die folgenden Vorgänge durchführen möchten, müssen Sie die Tastaturmaus verwenden.

  • Verschieben

  • Funktoide auswählen

  • Funktoide ziehen

  • Verknüpfen


Problembehandlung - BizTalk-Editor und BizTalk-Mapper

Dieser Abschnitt stellt einen zentralen Ort für Informationen zur Problembehandlung von Microsoft® BizTalk™-Editor und BizTalk-Mapper bereit. Wenn Sie Schwierigkeiten mit dem BizTalk-Editor oder BizTalk-Mapper haben sollten, können Sie hier möglicherweise eine Lösung finden.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Beim Herstellen einer Verbindung zu einem Remote-WebDAV-Server ist ein Kennwort erforderlich

  • Fehler beim Herstellen einer Verbindung zu WebDAV bzw. beim Speichern von Dateien in WebDAV

  • Im WebDAV-Dialogfeld wird "???.xml" angezeigt

  • Im Dialogfeld "Aus WebDAV abrufen" wird der Ordner "BizTalkServerRepositoryMaps" angezeigt

  • Das Dialogfeld "Aus WebDAV abrufen" bzw. "In WebDAV speichern" ist leer

  • Fehler beim Herstellen einer Verbindung zu "http://localhost"

  • Eine an BizTalk Server gesendete Flatfile wurde nicht vollständig analysiert

  • Leerzeichen in an BizTalk Server gesendeten Flatfiles werden nicht beibehalten

  • Fehler beim Testen der Zuordnung

  • Fehler beim DTD-Import

  • Beim Verwenden des Datums- oder Uhrzeitfeldes schlägt die Instanzüberprüfung fehl

  • Erneutes Registrieren von MSDAIPP.DLL zum Abrufen oder Speichern von Zuordnungen in WebDAV

  • Der Parser kann das erforderliche führende Trennzeichen nicht finden

  • Speichern einer Datei in WebDAV schlägt fehl

  • Importieren einer XDR-Datei schlägt fehl

  • Die Instanzüberprüfung schlägt fehl, wenn ein Komma zum Ausdrücken einer Dezimalzahl verwendet wird

  • Große Datensegmente in einem IDOC-Dokument werden nicht an ein SAP-System übermittelt

  • Unicode-Beschränkungen in WebDAV

  • X12-Vorlagen enthalten ein impliziertes Dezimalkomma

  • Das Umwandeln koreanischer in chinesische Zeichen verursacht einen BizTalk-Editor-Fehler

  • BizTalk-Editor oder BizTalk-Mapper kann nicht geöffnet werden


Beim Herstellen einer Verbindung zu einem Remote-WebDAV-Server ist ein Kennwort erforderlich

Ursache: Möglicherweise hat der Benutzer keinen Zugriff auf den Ordner BizTalkServerRepository.

Lösung: Stellen Sie dem Benutzer Zugriff auf den Ordner BizTalkServerRepository bereit. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Internetdienste-Manager.

  2. Erweitern Sie in der Konsolenstruktur den Namen des Computers.

  3. Erweitern Sie Standardwebsite.

  4. Klicken Sie mit der rechten Maustaste auf BizTalkServerRepository und anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalkServerRepository wird angezeigt.

  5. Klicken Sie auf die Registerkarte Verzeichnissicherheit.

  6. Klicken Sie im Bereich Steuerung des anonymen Zugriffs und der Authentifizierung auf Bearbeiten.

  7. Aktivieren Sie das Kontrollkästchen Anonyme Anmeldung, und klicken Sie zweimal auf OK.


Fehler beim Herstellen einer Verbindung zu WebDAV bzw. beim Speichern von Dateien in WebDAV

Ursache 1: Wenn Sie versuchen, eine Zuordnung oder Spezifikation aus WebDAV abzurufen bzw. in WebDAV zu speichern, wird unter Umständen eine der folgenden Meldungen angezeigt:

Die Datei kann nicht im WebDAV-Repository gespeichert werden. Der Server ist zurzeit möglicherweise nicht verfügbar.

Im aktuellen Bereich wurde kein Schlüssel gefunden, der den beschriebenen Eigenschaften entspricht.

Diese Meldungen werden angezeigt, wenn die Einstellung Anonym für das Benutzerkonto auf dem Webserver nicht über Schreibrechte für das Microsoft® Windows 2000®-Verzeichnis verfügt, in dem sich das Repository befindet.

Lösung: Gewähren Sie dem Benutzer Zugriff auf das Repository. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Menü Start auf Programme, dann auf Zubehör, und klicken Sie auf Windows-Explorer.

  2. Navigieren Sie zu dem Speicherort, an dem Sie Microsoft BizTalk Server 2002 installiert haben.

  3. Erweitern Sie das Verzeichnis Microsoft BizTalk Server, klicken Sie mit der rechten Maustaste auf BizTalkServerRepository, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld Eigenschaft von BizTalkServerRepository wird angezeigt.

  4. Klicken Sie auf die Registerkarte Sicherheitseinstellungen.

  5. Klicken Sie auf Hinzufügen, und geben Sie dann den Domänennamen und den Benutzernamen der Person ein, die Berechtigungen für das Repository erhalten soll. Verwenden Sie dabei das folgende Format: Domänenname\Benutzername.

  6. Klicken Sie zweimal auf OK.

Ursache 2: Wenn Sie versuchen, eine Zuordnung oder Spezifikation aus WebDAV abzurufen bzw. in WebDAV zu speichern, wird möglicherweise die folgende Meldung angezeigt:

Auf http://localhost/BizTalkServerRepository/DocSpecs wurde kein BizTalk Server-Repository gefunden. Geben Sie einen anderen Servernamen ein, um die Verbindung zu WebDAV erneut herzustellen.

Diese Meldung wird angezeigt, wenn Microsoft FrontPage®-Servererweiterungen auf dem Webserver aktiviert sind.

Lösung: Deaktivieren Sie FrontPage-Servererweiterungen. Wird der WWW-Publishingdienst ausgeführt, beenden Sie diesen, und starten Sie ihn neu.

Anmerkung

  • Dieses Problem kann auch auftreten, wenn der WWW-Publishingdienst auf dem Hostcomputer für das WebDAV-Repository nicht ausgeführt wird.

So deaktivieren Sie FrontPage-Servererweiterungen

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Internetdienste-Manager.

  2. Doppelklicken Sie im Detailbereich auf <Name des Computers>, klicken Sie mit der rechten Maustaste auf Standardwebsite, und klicken Sie dann auf Eigenschaften.

    Das Dialogfeld Eigenschaften von Standardwebsite wird angezeigt.

  3. Deaktivieren Sie auf der Registerkarte Servererweiterungen das Kontrollkästchen Dokumenterstellung aktivieren, und klicken Sie auf OK.

So beenden Sie den WWW-Publishingdienst und starten ihn neu

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Komponentendienste.

  2. Klicken Sie in der Konsolenstruktur auf Dienste (lokal).

  3. Klicken Sie im Detailbereich mit der rechten Maustaste auf WWW-Publishingdienst, und klicken Sie auf Beenden.

  4. Klicken Sie mit der rechten Maustaste auf WWW-Publishingdienst, und klicken Sie auf Starten.


Im WebDAV-Dialogfeld wird "???.xml" angezeigt

Internationales Problem

Ursache: Der für Ihren Computer angezeigte Zeichensatz hängt von dem in BizTalk Server angegebenen Gebietsschema ab.

Lösung: Geben Sie für Ihren Computer denselben Zeichensatz an wie für das Gebietsschema in BizTalk Server. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Einstellungen, und klicken Sie auf Systemsteuerung.

  2. Doppelklicken Sie auf Ländereinstellungen.

  3. Aktivieren Sie im Bereich Spracheinstellungen für das System auf der Registerkarte Allgemein das Kontrollkästchen für die gewünschte Sprache, und klicken Sie auf Standard festlegen.

    Das Dialogfeld Systemgebietsschema wählen wird angezeigt.

  4. Klicken Sie auf das gewünschte Gebietsschema und dann zweimal auf OK.

    Das Dialogfeld Ländereinstellungen ändern wird angezeigt.

  5. Klicken Sie auf Ja, um die Änderungen zu akzeptieren, und starten Sie den Computer neu.

Anmerkung

  • Nach dem Neustart des Computers wird die ausgewählte Sprache im Dialogfeld Ländereinstellungen folgendermaßen angezeigt: Sprache (Standard).

Verwandte Themen

Speichern von Zuordnungen

Speichern von Spezifikationen


Im Dialogfeld "Aus WebDAV abrufen" wird der Ordner "BizTalkServerRepositoryMaps" angezeigt

Ursache: Im Feld Lokaler Pfad des Dialogfeldes Eigenschaften von BizTalkServerRepository wird am Ende ein umgekehrter Schrägstrich angezeigt.

Lösung: Entfernen Sie den umgekehrten Schrägstrich im Bearbeitungsfeld Lokaler Pfad des Dialogfeldes Eigenschaften von BizTalkServerRepository. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Verwaltung, klicken Sie auf Internetdienste-Manager, und erweitern Sie Standardwebsite.

  2. Klicken Sie mit der rechten Maustaste auf BizTalkServerRepository und anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalkServerRepository wird angezeigt.

  3. Entfernen Sie aus dem Bearbeitungsfeld Lokaler Pfad den umgekehrten Schrägstrich, und klicken Sie auf OK.

Mit diesem Verfahren wird der Ordner BizTalkServerRepositoryMaps aus dem Dialogfeld Aus WebDAV abrufen entfernt. Es wird empfohlen, diesen Ordner zu entfernen, da er nicht verwendet werden kann.


Das Dialogfeld "Aus WebDAV abrufen" bzw. "In WebDAV speichern" ist leer

Ursache: Die Funktion zum Durchsuchen von Verzeichnissen im Dialogfeld Eigenschaften von BizTalkServerRepository ist deaktiviert.

Lösung: Aktivieren Sie die Funktion zum Durchsuchen von Verzeichnissen im Dialogfeld Eigenschaften von BizTalkServerRepository. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Startmenü auf Programme, zeigen Sie auf Verwaltung, und klicken Sie anschließend auf Internetdienste-Manager.

  2. 08Erweitern Sie den Computer, für den Sie eine Problembehandlung durchführen.

  3. Erweitern Sie Standardwebsite.

  4. Klicken Sie mit der rechten Maustaste auf BizTalkServerRepository und anschließend auf Eigenschaften.

    Das Dialogfeld Eigenschaften von BizTalkServerRepository wird angezeigt.

  5. Aktivieren Sie auf der Registerkarte Virtuelles Verzeichnis das Kontrollkästchen Verzeichnis durchsuchen.

  6. Stellen Sie sicher, dass Lesen und Schreiben ebenfalls aktiviert sind, und klicken Sie auf OK.


Fehler beim Herstellen einer Verbindung zu "http://localhost"

Ursache: Das Kontrollkästchen Proxyserver verwenden ist aktiviert, das Kontrollkästchen Proxyserver für lokale Adressen umgehen jedoch nicht.

Lösung: Behalten Sie die Einstellung Proxyserver verwenden bei, und schalten Sie Proxyserver für lokale Adressen umgehen ein. Führen Sie hierzu folgende Schritte durch:

  1. Zeigen Sie im Menü Start auf Programme, und klicken Sie dann auf Internet Explorer.

  2. Klicken Sie im Menü Extras auf Internetoptionen.

    Das Dialogfeld Internetoptionen wird angezeigt.

  3. Klicken Sie auf die Registerkarte Verbindungen und dann auf LAN-Einstellungen.

    Das Dialogfeld Einstellungen für lokales Netzwerk (LAN) wird angezeigt.

  4. Aktivieren Sie im Bereich Proxyserver das Kontrollkästchen Proxyserver für lokale Adressen umgehen.

  5. Klicken Sie zweimal auf OK.

Anmerkung

  • Dieser Fehler tritt nicht auf, wenn Sie eine Verbindung zu http://<Name des Computers> herstellen.


Eine an BizTalk Server gesendete Flatfile wurde nicht vollständig analysiert

Ursache: Eine an BizTalk Server gesendete Flatfile mit Trennzeichen kann einen Analysefehler aufweisen, wenn die Datei den Namen des Stammknotens als Zeichenfolge im Namen eines anderen Knotens in der Datei enthält.

Lösung: Geben Sie dem Stammknoten einen neuen Namen, der nicht im Namen eines anderen Knotens in der Spezifikation enthalten ist.


Leerzeichen in an BizTalk Server gesendete Flatfiles werden nicht beibehalten

Ursache: Beim Senden einer Flatfile an BizTalk Server werden Leerzeichen möglicherweise entfernt. Der Grund hierfür ist, dass der zugrunde liegende MSXML-Parser Leerzeichen in einem Feld, für dessen Typ-Eigenschaft (auf der Registerkarte Deklaration) Element festgelegt wurde, standardmäßig nicht beibehält.

Lösung: Sollen die Leerzeichen in einem in einer Flatfile enthaltenem Feld beibehalten werden, legen Sie im BizTalk-Editor auf der Registerkarte Deklaration den Wert Attribut für die Typ-Eigenschaft des Feldes in der Quellspezifikation fest.

Verwandtes Thema

Festlegen von Deklarationseigenschaften


Fehler beim Testen der Zuordnung

Ursache: Wenn Sie eine Zuordnung testen, kompiliert der BizTalk-Mapper die Zuordnung, bevor diese getestet wird. Wird während des Kompiliervorgangs eine Warnung ausgegeben, kann die Zuordnung möglicherweise nicht getestet werden. Folgende Fehlermeldung wird angezeigt:

Fehler bei der XSL-Transformation mithilfe der Testinstanz des Dokuments für die Quellspezifikation.

Lösung: Lösen Sie sämtliche Compilerwarnungen auf, und kompilieren Sie die Zuordnung erneut. Um eine Compilerwarnung aufzulösen, führen Sie folgende Schritte durch:

  1. Doppelklicken Sie auf der Registerkarte Ausgabe auf das Wort Warnung.

    Auf diese Weise wird die Verknüpfung oder das Funktoid, mit der bzw. dem die Warnung verbunden ist, markiert.

  2. Lösen Sie die Warnung auf.

Um die Zuordnung neu zu kompilieren, gehen Sie folgendermaßen vor:

  • Klicken Sie im Menü Extras auf Zuordnung kompilieren.

Verwandtes Thema

Testen von Zuordnungen


Fehler beim DTD-Import

Ursache: Beim Import einer Dokumenttypdefinition (DTD), die einen externen Verweis auf eine andere Datei enthält, wird unter Umständen die folgende Meldung angezeigt:

DTD enthält ungültiges Zeichen.

Lösung: Entfernen Sie vor dem Import sämtliche externen Verweise in einer DTD.


Beim Verwenden des Datums- oder Uhrzeitfeldes schlägt die Instanzüberprüfung fehl

Ursache: Wenn BizTalk Server eine eingehende Dokumentinstanz verarbeitet, kann die Instanzüberprüfung fehlschlagen, wenn eine Verknüpfung zwischen einem Funktoid oder Feld in der Struktur der Quellspezifikation mit einem Knoten in der Struktur der Zielspezifikation besteht, für dessen Datentyp-Eigenschaft Date, Date Time, Date Time.tz, Time oder Time.tz festgelegt wurde, und wenn die beim Zielknoten eingehenden Daten nicht im ISO 8601-Format vorliegen.

Lösung: Wenn Sie eine Verknüpfung zu einem Feld in der Struktur der Zielspezifikation herstellen, für dessen Datentyp-Eigenschaft Date, Date Time, Date Time.tz, Time oder Time.tz festgelegt wurde, sollten Sie sicherstellen, dass die mit diesem Feld verknüpften Daten (unabhängig davon, ob Sie aus einem Funktoid oder einem Knoten in einer eingehenden Dokumentinstanz stammen) im ISO 8601-Format vorliegen. Die folgende Tabelle enthält das korrekte ISO 8601-Format für sämtliche Werte, die für die Datentyp-Eigenschaft festgelegt werden können.

Datentyp-Eigenschaft | ISO 8601-Format
Date | YYYY-MM-DD (1988-04-07)
Date Time | YYYY-MM-DDTHH:MM:SS (1988-04-07T18:39:09)
Date Time.tz | YYYY-MM-DDTHH:MM:SS-TZH:TZM (1988-04-07T18:39:09-08:00)
Time | HH:MM:SS (08:15:27)
Time.tz | HH:MM:SS-TZH:TZM (08:15:27-05:00)


Erneutes Registrieren von MSDAIPP.DLL zum Abrufen oder Speichern von Zuordnungen in WebDAV

Ursache: Wenn Sie versuchen, eine Zuordnung oder Spezifikation aus WebDAV abzurufen bzw. in WebDAV zu speichern, wird möglicherweise die folgende Meldung angezeigt:

Auf http://<Servername>/BizTalkServerRepository/DocSpecs wurde kein BizTalk Server-Repository gefunden.

Lösung: Führen Sie folgende Schritte zum Beheben dieses Problems aus:

  1. Wechseln Sie im Windows-Explorer zu \Programme\Gemeinsame Dateien\System\Ole DB\, und doppelklicken Sie auf MSDAIPP.DLL.

    Das Dialogfeld Vorsicht wird angezeigt.

  2. Klicken Sie auf Öffnen mit.

    Das Dialogfeld Öffnen mit wird angezeigt.

  3. Klicken Sie auf Andere.

    Das Dialogfeld Öffnen mit wird angezeigt.

  4. Wechseln Sie zu \WINNT\system32\, und doppelklicken Sie auf regsvr32.exe.

    Das Dialogfeld Öffnen mit wird angezeigt.

  5. Stellen Sie sicher, dass Microsoft© Register Server ausgewählt ist, und klicken Sie auf OK.

    Ein Meldungsfeld wird angezeigt.

  6. Klicken Sie auf OK.


Der Parser kann das erforderliche führende Trennzeichen nicht finden

Ursache: Wenn die verwendete Dokumentinstanz Felder in einem Datensatz enthält, die sowohl optional als auch leer sind, müssen Sie vor dem Datensatztrennzeichen ein Feldtrennzeichen hinzufügen. Die folgende Dokumentinstanz enthält z. B. als Datensatztrennzeichen eine Tilde (~). Als Feldtrennzeichen für den ersten Datensatz wird jedoch auch ein Plus-Zeichen (+) angezeigt. Dadurch müssen Sie auf der Registerkarte Dokumenttrennzeichen die Option Datensatztrennzeichen auf ~ und die Option Feldtrennzeichen auf + festlegen.

Dokumentinstanz mit einer Tilde (~) als Datensatztrennzeichen

Wenn Sie die vorherige Dokumentinstanz mit der folgenden Spezifikationsabbildung abgleichen, wird der folgende Fehler angezeigt:

Beim Analysieren von "Datensatz 1" kann der Parser das erforderliche führende Trennzeichen "+" 0x002b) nicht finden

Abgleichen einer Dokumentinstanz mit einer Spezifikation

Lösung: Um dieses Problem zu lösen, fügen Sie in der Dokumentinstanz zwischen "TTT" und "~" ein "+" hinzu.


Speichern einer Datei in WebDAV schlägt fehl

Ursache: Wenn eine Datei im BizTalk-Editor oder BizTalk-Mapper nicht im WebDAV-Repository gespeichert werden kann (z. B. wenn dem Benutzer die Berechtigung verweigert wird oder die Datei schreibgeschützt ist), wird eine entsprechende Fehlermeldung angezeigt. Wenn Sie jedoch die Datei schließen und sie erneut aus WebDAV abrufen, wird die lokal zwischengespeicherte Datei anstelle der Datei im WebDAV-Repository angezeigt. Die Datei ist dann anscheinend im WebDAV-Repository gespeichert, obwohl das Dialogfeld Berechtigung verweigert angezeigt wird.

Lösung: Löschen Sie den Internet Explorer-Cache. Gehen Sie zum Löschen des Caches folgendermaßen vor:

  1. Zeigen Sie im Menü Start auf Programme, und klicken Sie dann auf Internet Explorer.

  2. Klicken Sie im Menü Extras auf Internetoptionen.

    Das Dialogfeld Internetoptionen wird angezeigt.

  3. Klicken Sie auf Dateien löschen.


Importieren einer XDR-Datei schlägt fehl

Ursache: Ein XDR-Import schlägt fehl, wenn der Standardwert eines Attributs des Typs idrefs in der Attributdeklaration angegeben ist (siehe das folgende Codebeispiel):

<AttributeType name="Field1" d:type="idrefs" default="a1 a2"> </AttributeType>
<attribute type="Field1" required="no"></attribute>

Lösung: Verschieben Sie den Standardwert in den Attributverweis im XDR-Schema, bevor sie diesen in den BizTalk-Editor importieren (siehe das folgende Codebeispiel):

<AttributeType name="Field1" d:type="idrefs"> </AttributeType>
<attribute type="Field1" required="no" default="a1 a2"></attribute>


Die Instanzüberprüfung schlägt fehl, wenn ein Komma zum Ausdrücken einer Dezimalzahl verwendet wird

Ursache: Wenn ein Komma (,) anstatt eines Punkts (.) zum Ausdrücken einer Dezimalzahl in einer Dokumentinstanz verwendet wird, kann die Instanzüberprüfung fehlschlagen. Dies geschieht, da der Parser die Dokumentinstanz in ein XML-Dokument konvertiert und anschließend das XML DOM (Document Object Model) verwendet, um das XML-Dokument mit der Dokumentspezifikation abzugleichen. Das XML DOM lässt das Komma nicht als Dezimaltrennzeichen zu. Weitere Informationen finden Sie in der MSDN Online Library (msdn.microsoft.com/library/default.asp), indem Sie nach "XML Data Types Reference" suchen.

Lösung: Verwenden Sie einen Punkt, wenn Sie Dezimalzahlen in einer Dokumentinstanz ausdrücken.


Große Datensegmente in einem IDOC-Dokument werden nicht an ein SAP-System übermittelt

Ursache: Wenn große Datensegmente in einem IDOC-Dokument verwendet werden, das zur Verarbeitung an ein SAP-System weitergeleitet wird, werden einige Daten möglicherweise nicht verarbeitet. Dies kann von einem im SAP-System konfigurierten Timeoutwert verursacht werden.

Lösung: Ändern Sie den Timeoutwert im SAP-System.


Unicode-Beschränkungen in WebDAV

Internationales Problem

Ursache: WebDAV unterstützt in Dateinamen keine Unicodezeichen. Die Dateien selbst können jedoch im Repository nur mit Unicode-Verschlüsselungen gespeichert werden.

Lösung: Stellen Sie sicher, dass das auf dem Computer festgelegte Systemgebietsschema Ihre Sprache unterstützt. Internationale Benutzer, die z. B. die englische Version von BizTalk Server 2002 auf einem Computer mit englischem Microsoft® Windows® installieren und Dateien mithilfe von Zeichen benennen möchten, die von der Codeseite Latin I (Windows 1252) nicht unterstützt werden, müssen das Systemgebietsschema in das des Benutzers ändern.

Für Koreanisch und Chinesisch müssen Sie ferner sicherstellen, dass der Internetbrowser nicht auf das Senden von URLs als UTF-8 festgelegt ist. Um sicherzustellen, dass diese Option nicht festgelegt ist, gehen Sie folgendermaßen vor:

  1. Zeigen Sie im Menü Start auf Programme, und klicken Sie dann auf Internet Explorer.

  2. Klicken Sie im Menü Extras auf Optionen.

    Das Dialogfeld Internetoptionen wird angezeigt.

  3. Deaktivieren Sie auf der Registerkarte Erweitert das Kontrollkästchen URLs immer als UTF-8 senden.


X12-Vorlagen enthalten ein impliziertes Dezimalkomma

Ursache: Wenn die X12-Vorlagen von BizTalk Server 2002 im BizTalk-Editor oder BizTalk-Mapper verwendet werden, kann diese oder eine ähnliche Fehlermeldung angezeigt werden:

Die Länge des Feldes "ITD05" ("") ist nicht gültig; sie muss zwischen 48 und -1 liegen. Dieses Dokument wird zurückgewiesen.

Die X12-Vorlagen verwenden den implizierten Dezimaldatentyp Nx, der sich auf die Überprüfung und Zuordnung auswirkt. Wenn die Eingabedaten ein Dezimalkomma enthalten, entspricht die Ausgabe nicht dem benutzerdefinierten Datentyp Nx (der kein Dezimalkomma vorsieht), wodurch in der temporären XML-Datei ungültige Dokumentinstanzen erstellt werden.

Lösung: Ändern Sie den implizierten Dezimaldatentyp in den X12-Vorlagen manuell in einen anderen numerischen Datentyp.


Das Umwandeln koreanischer in chinesische Zeichen verursacht einen BizTalk-Editor-Fehler

Internationales Problem

Das Umwandeln koreanischer in chinesische Zeichen mithilfe der Taste CHINESE auf einer koreanischen Tastatur verursacht einen BizTalk-Editor-Fehler. Sie können chinesische Zeichen jedoch direkt in den BizTalk-Editor eingeben (z. B. durch Kopieren eines chinesischen Zeichens aus dem Editor).


BizTalk-Editor oder BizTalk-Mapper kann nicht geöffnet werden

Ursache: Beim Verwenden des XML-Parsers können Sie den BizTalk-Editor oder BizTalk-Mapper nicht öffnen.

Lösung: Es wird ausdrücklich empfohlen, den Microsoft XML (MSXML) Parser, Version 3.0, mit Ihrer Installation von BizTalk Server 2002 zu verwenden. Außerdem wird empfohlen, den MSXML-Parser im Modus Seite-an-Seite zu verwenden. Wenn Sie den MSXML-Parser durch Installieren von xmlinst.exe für den Betrieb im Ersetzungsmodus konfigurieren, treten möglicherweise Probleme mit BizTalk Server auf. Wenn Sie den MSXML-Parser durch Installieren von xmlinst.exe oder durch Ändern der Registrierungsschlüssel für den Betrieb im Ersetzungsmodus konfigurieren, wird Ihre Installation von BizTalk Server nicht unterstützt.

Im folgenden Verfahren wird beschrieben, wie Sie den MSXML-Parser für den Betrieb im Modus Seite-an-Seite konfigurieren können, wenn er derzeit für den Betrieb im Ersetzungsmodus konfiguriert ist.

  1. Klicken Sie im Startmenü auf Ausführen.

  2. Geben Sie cmd in das Feld Öffnen ein, und klicken Sie auf OK.

  3. Wechseln Sie in das Verzeichnis, in dem sich die Datei xmlinst.exe befindet, geben Sie an der Eingabeaufforderung xmlinst –u ein, und drücken Sie die EINGABETASTE.

  4. Geben Sie an der Eingabeaufforderung %WINDIR%\system32\regsvr32 msxml.dll ein, und drücken Sie die EINGABETASTE.

  5. Geben Sie an der Eingabeaufforderung %WINDIR%\system32\regsvr32 msxml2.dll ein, und drücken Sie die EINGABETASTE.

  6. Geben Sie an der Eingabeaufforderung %WINDIR%\system32\regsvr32 msxml3.dll ein, und drücken Sie die EINGABETASTE.

  7. Geben Sie an der Eingabeaufforderung exit ein, und drücken Sie die EINGABETASTE

Weitere Informationen zum Verwenden von xmlinst.exe finden Sie im folgenden Artikel der Microsoft Knowledge Base, "PRB: Application Errors Occur After You Run Xmlinst.exe on Production Servers" (support.microsoft.com/support/kb/articles/Q302/5/12.asp).


Integrieren der BizTalk-Dienste

Durch Integrieren der Microsoft® BizTalk™-Orchestrierungsdienste und BizTalk-Messagingdienste können Sie den Austausch von Dokumenten und Nachrichten zwischen Ihren Handelspartnern und internen Anwendungen mit mehreren Transportdiensten steuern. Darüber hinaus bieten die Dienste folgende Möglichkeiten:

  • Steuerung komplexer, langlebiger Transaktionen und Geschäftsprozesse.

  • Zuverlässige Übermittlung von Dokumenten und Nachrichten.

  • Datenüberprüfung durch Abgleichen jeder Dokumentinstanz mit einer Spezifikation.

  • Datenzuordnung mithilfe von Zuordnungen zum Transformieren der Dokumentstruktur und des Dokumentformats.

  • Datensicherheit und –integrität mithilfe von Verschlüsselung und digitaler Signaturzertifikate.

  • Unterstützung für die Generierung und Korrelation von Empfangsbestätigungen.

Die BizTalk-Orchestrierungsdienste und BizTalk-Messagingdienste können auf verschiedene Weise integriert werden, dieser Abschnitt zeigt jedoch das übliche Szenario.

Bei diesem Szenario konfigurieren Sie eine XLANG-Ablaufplaninstanz im Quellsystem, um eine Nachricht zu initiieren und an ein Zielsystem eines Handelspartners zu senden; dann warten Sie, bis Sie von dem Partner eine Antwortnachricht erhalten und senden die Antwortnachricht an dieselbe XLANG-Ablaufplaninstanz, die die Ausgangsnachricht gesendet hat. Ein Beispiel für einen häufigen Geschäftsprozesses, bei dem Sie diese Konfiguration anwenden können, ist das Versenden einer Bestellung und das Abwarten der Bestätigung, bevor der Geschäftsprozess fortgeführt wird.

Die Themen in diesem Abschnitt erläutern die erforderlichen Konfigurationsschritte für den Austausch von Nachrichten zwischen Ihrem Unternehmen und einem Handelspartner mithilfe eines HTTP-Transports (Hypertext Transfer Protocol) und eines Nicht-HTTP-Transports. Sie können jedoch eine ähnliche Konfiguration verwenden, um den Austausch von Nachrichten zwischen Anwendungen innerhalb Ihres Unternehmens zu steuern.

Da Microsoft BizTalk Server 2002 als das Quellsystem dienen kann, das die Ausgangsnachricht sendet, oder als Zielsystem, das die Antwortnachricht sendet, stellt dieser Abschnitt die erforderlichen Konfigurationsschritte für beide Varianten bereit. Auf diese Weise erhalten Sie einen Überblick über die gesamte erforderliche Konfiguration.

Beispiele für XLANG-Ablaufpläne, die diese Konfigurationen widerspiegeln, und andere verwandte Dateien finden Sie im Ordner \Programme\Microsoft BizTalk Server\SDK\XLANG Samples\Integrating BizTalk Services.

Anmerkungen

  • Die Begriffe Messagingport, der in den BizTalk-Messagingdiensten verwendet wird, und Port, der in den BizTalk-Orchestrierungsdiensten verwendet wird, haben eine vollkommen unterschiedliche Bedeutung:
    • Ein Messagingport ist eine Gruppe von Eigenschaften, die die BizTalk-Messagingdienste anweisen, Dokumente mithilfe eines angegebenen Transportdienstes an ein bestimmtes Ziel zu transportieren.

    • Ein Port ist ein benannter Standort, der eine bestimmte Implementierung verwendet. In einem XLANG-Ablaufplan ermöglichen Ports die synchrone und asynchrone Kommunikation und werden verwendet, um Nachrichten in den und aus dem Ablaufplan zu senden.
  • 8Aktionsereignisse, die Nachrichten zugeordnet sind, die von einem XLANG-Ablaufplan verarbeitet und von BizTalk-Messagingdiensten gesendet oder empfangen werden, können in der Überwachungsdatenbank überwacht werden. Weitere Informationen finden Sie unter Überwachen von XLANG-Ablaufplanereignissen in der Überwachungsdatenbank.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Verwenden eines HTTP-Transports

  • Verwenden eines Nicht-HTTP-Transports

Verwandte Themen

Funktionsweise von BizTalk Server

Instanzenverwaltung


Verwenden eines HTTP-Transports

Dieser Abschnitt erläutert, wie die BizTalk-Orchestrierungsdienste und die BizTalk-Messagingdienste sowohl für das Quellsystem als auch für das Zielsystem integriert und konfiguriert werden, so dass folgende Aktionen ausgeführt werden:

  • Das Quellsystem generiert und sendet eine Nachricht mithilfe einer bestimmten XLANG-Ablaufplaninstanz an das Zielsystem eines Handelspartners.

  • Das Zielsystem sendet eine Antwortnachricht mithilfe eines HTTP-Transports.

  • Das Quellsystem erhält eine Antwortnachricht und leitet sie an dieselbe XLANG-Ablaufplaninstanz weiter, die die Ausgangsnachricht generiert und versendet hat.

Informationen zum Konfigurieren beider Systeme, so dass das Zielsystem einen Nicht-HTTP-Transport zum Versenden der Antworten verwenden kann, finden Sie unter Verwenden eines Nicht-HTTP-Transports.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports

  • Konfigurieren des Zielsystems für das Verwenden eines HTTP-Transports


Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports

Die Schritte in diesem Thema erläutern, wie das Quellsystem konfiguriert werden muss, damit es eine Nachricht generiert und versendet, die eine HTTP-URL-Antwortadresse enthält. Das Zielsystem des Handelspartners verwendet die in der Ausgangsnachricht enthaltene Antwortadresse, um mithilfe eines HTTP-Transports eine Antwortnachricht an eine ASP-Seite in der Website des Quellsystems zu senden. Informationen zum Konfigurieren des Quellsystems, so dass das Zielsystem einen Nicht-HTTP-Transport zum Versenden der Antworten verwenden kann, finden Sie unter Konfigurieren des Quellsystems für das Verwenden eines Nicht-HTTP-Transports. Die für einen sicheren HTTPS-Transport (Hypertext Transfer Protocol Secure) erforderlichen Konfigurationsschritte werden weiter unten in diesem Thema behandelt.

Der HTTP-URL, der in dieser Konfiguration als Antwortadresse verwendet wird, wird vom XLANG-Ablaufplan basierend auf den Daten aus den Porteigenschaften generiert. Er besteht aus den folgenden Elementen:

  • Die Adresse einer ASP-Seite in der Website des Quellsystems, an die eine Antwortnachricht gesendet wird.

  • Eine Abfragezeichenfolge, die den Namen des Kanals in den BizTalk-Messagingdiensten für das Quellsystem enthält, der zum Verarbeiten der Antwortnachricht verwendet wird, und ein vollständiger Pfadname einer instanzbezogenen Warteschlange, die die XLANG-Ablaufplaninstanz erstellt und an die die Antwortnachricht gesendet wird.

Nachfolgend ein Beispiel für eine HTTP-URL-Antwortadresse:

http://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\ChannelForReply{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Die Antwortnachricht, die die ASP-Seite im Quellsystem erhält, enthält ein Skript, das die folgenden Schritte ausführt:

  • Extrahieren von Kanalnamen und Informationen zum Warteschlangenpfad aus der Abfragezeichenfolge.

  • Konvertieren des Warteschlangenpfades von einem Pfadnamen in einen Formatnamen und Einfügen des Präfixes queue://, das von den BizTalk-Messagingdiensten benötigt wird.

  • Versenden einer Antwortnachricht an die BizTalk-Messagingdienste für das Quellsystem, wobei der Kanalname und die Informationen zum Warteschlangenpfad als Versendungsparameter verwendet werden. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

Die BizTalk-Messagingdienste für das Quellsystem verwenden den festgelegten Kanal, um Antwortnachrichten zu verarbeiten und verwenden den zugeordneten Messagingport, der den Warteschlangenpfad verwendet, um die Antwortnachricht an dieselbe aktive XLANG-Ablaufplaninstanz zu transportieren, die die Ausgangsnachricht generiert hat.

Damit die Konfiguration dieses Quellsystems korrekt funktioniert, muss auch das Zielsystem des Handelspartners korrekt konfiguriert sein. Weitere Informationen zum Konfigurieren des Zielsystems finden Sie unter Konfigurieren des Zielsystems für das Verwenden eines HTTP-Transports.

Um das Quellsystem so zu konfigurieren, dass ein HTTP-Transport verwendet wird, führen Sie die Schritte in der folgenden Tabelle aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen, die für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals benötigt werden, der die Ausgangsnachricht verarbeiten wird.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Sie müssen in jeder dieser Spezifikationen ein Feld für die Antwortadresse hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden, die Adresse muss jedoch mit dem Handelspartner abgestimmt werden und den Spezifikationen im Zielsystem des Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
  • Erstellen Sie die Spezifikationen, die für die eingehenden und ausgehenden Dokumentdefinitionen des Kanals benötigt werden, der die Antwortnachricht verarbeiten wird.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Für diese Spezifikationen ist keine besondere Konfiguration erforderlich.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie eine Organisation, die für den Handelspartner und das Zielsystem steht.
  • Erstellen von Organisationen

    Anmerkung

    • Für diese Organisation ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie die Dokumentdefinitionen, die zum Erstellen des Kanals benötigt werden, mit dem Sie die Ausgangsnachricht verarbeiten.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die Spezifikationen aus, die ein Antwortfeld haben. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie die Dokumentdefinitionen, die zum Erstellen des Kanals benötigt werden, mit dem Sie die Antwortnachricht verarbeiten.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Für diese Dokumentdefinitionen ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie einen Messagingport zu einer Organisation, um die Ausgangsnachricht zum Zielsystem zu transportieren.
  • Erstellen von Messagingports

    Anmerkung

    • Dieser Messagingport kann kein offener Messagingport sein.
  • Erstellen Sie einen Kanal von einer Anwendung, um die ausgehende Nachricht vom XLANG-Ablaufplan zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Klicken Sie im Kanal-Assistenten auf der Seite Quellanwendung auf XLANG-Ablaufplan. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentdefinition für eingehende Dokumente. Diese Namen werden zum Konfigurieren der BizTalk-Orchestrierungsdienste verwendet.
  • Erstellen Sie einen Messagingport zu einer Anwendung, um die Antwortnachricht an die aktive XLANG-Ablaufplaninstanz zu transportieren, welche die ausgehende Nachricht generiert hat.
  • Erstellen von Messagingports

    Anmerkung

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung auf Aktiver XLANG-Ablaufplan. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  • Erstellen Sie einen Kanal von einer Organisation, um die Antwortnachricht vom Zielsystem zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkung

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentdefinition für ausgehende Dokumente, die Sie verwenden. Diese Namen werden zum Konfigurieren der BizTalk-Orchestrierungsdienste verwendet.
Verwenden des BizTalk-Orchestrierungs-Designers:
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Senden der Ausgangsnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkung

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über statische oder dynamische Kanäle auf Statischer Kanal, und geben Sie im Feld Geben Sie den Namen eines bekannten, vorgegebenen Kanals ein den Namen des Kanals im BizTalk-Messaging-Manager ein, den Sie zum Verarbeiten der Ausgangsnachricht verwenden.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Ausgangsnachricht sendet.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden, aber wenn Sie den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal verwenden, wird deutlicher, welche Nachricht Sie versenden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal ein, den Sie zum Verarbeiten der Nachricht verwenden.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen, und suchen Sie die Spezifikation, die Sie für die Definition eingehender Dokumente des Kanals verwenden, mit dem Sie die Ausgangsnachricht verarbeiten.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation in den Bereich Nachrichtenfelder, klicken Sie auf Hinzufügen, und fügen Sie das Feld in der Spezifikation hinzu, das erstellt wurde, um die Antwortadresse in der Ausgangsnachricht aufzunehmen.
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zu implementieren, mit dem Sie eine Antwortnachricht empfangen.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkungen

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über die XLANG-Ablaufplanaktivierung auf Nein.

    • Geben Sie auf der Seite Kanalinformationen im Feld Kanalname den Namen des Kanals im BizTalk-Messaging-Manager ein, mit dem Sie die Antwortnachricht verarbeiten werden.

      Der BizTalk-Orchestrierungs-Designer verwendet den Kanalnamen und eine GUID, um eine instanzbezogene Warteschlange zu erstellen und zu benennen, an die die Antwortnachricht gesendet wird.

    • Geben Sie auf der Seite Kanalinformationen in das Feld HTTP-URL-Adresse, über die der BizTalk-Messagingdienst Dokumente empfängt die Adresse der ASP-Seite ein, an die der Handelspartner eine Antwortnachricht senden kann.

      Der BizTalk-Orchestrierungs-Designer verwendet die Adresse und den Kanalnamen, die bzw. den Sie zuvor eingegeben haben, um eine HTTP-URL-Adresse mit einer Abfragezeichenfolge zu erstellen, die den Kanalnamen und den Warteschlangenpfad der instanzbezogenen Warteschlange enthält.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, an dem Sie eine Antwortnachricht empfangen.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden, aber wenn Sie den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal verwenden, wird deutlicher, welche Nachricht Sie empfangen.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal ein, den Sie zur Verarbeitung der Antwortnachricht verwenden.

      Alle Nachrichten, die von den BizTalk-Messagingdiensten an eine XLANG-Ablaufplaninstanz gesendet werden, werden an eine Nachrichtenwarteschlange gesendet. Die Nachrichtenbezeichnung für diese Nachrichten ist der Name der Dokumentdefinition für ausgehende Dokumente des Kanals.
  • Richten Sie den Datenfluss ein, um die Portverweisdaten an das Feld für die Antwortadresse weiterzuleiten.
  • Festlegen des Datenflusses zwischen Nachrichten

    Anmerkungen

    • Klicken Sie auf die Registerkarte Daten.

    • Klicken Sie auf der Datenseite in der Portverweise-Nachricht auf den Portverweis für den Port, der die Antwortnachricht empfangen wird. Ziehen Sie dann das Kontrollhandle auf den Verbindungspunkt des Feldes für die Antwortadresse in der Ausgangsnachricht.

      Dadurch werden die Portverweisdaten in das Feld für die Antwortadresse der ausgehenden Ausgangsnachricht weitergeleitet. Der Portverweis ist eine HTTP-URL-Adresse einer ASP-Seite, die eine Abfragezeichenfolge mit einem Kanalnamen und den Warteschlangenpfad der instanzbezogenen Warteschlange für den Port enthält.
Verwenden der ASP-Seite:
  • Sie können die Beispiel-ASP-Seite verwenden, die zusammen mit BizTalk Server 2002 bereitgestellt wird, oder eine ASP-Seite, die dasselbe Skript wie die Beispielseite verwendet.
 Anmerkungen
  • Um die Beispiel-ASP-Seite zu verwenden, gehen Sie zu \Programme\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts auf dem Installationslaufwerk, um das Beispiel ReceiveResponse.asp zu suchen. Speichern Sie diese Datei in dem entsprechenden Verzeichnis für die Website des Quellsystems.

  • Wenn die Beispiel-ASP-Seite eine Antwortnachricht empfängt, extrahiert ihr Skript den Kanalnamen und den Warteschlangenpfad aus der Abfragezeichenfolge in der Adresse des HTTP-Headers. Die ASP-Seite konvertiert außerdem den Warteschlangenpfad von einem Pfadnamen in einen Formatnamen und fügt ein Präfix queue:// hinzu. Die Seite verwendet dann diese Daten als Parameter, um die Antwortnachricht an die BizTalk-Messagingdienste für das Quellsystem zu versenden. Weitere Informationen zum Versenden von Dokumenten finden Sie unter Submitting.

Verwenden eines sicheren HTTPS-Transports

Falls Ihr Geschäftsprozess einen sicheren Transport für den Austausch von Nachrichten mit einem Handelspartner erfordert, müssen Sie einen HTTPS-Transport verwenden.

Die einzige Änderung, die Sie an der Konfiguration des Quellsystems vornehmen müssen, damit ein HTTPS-Transport verwendet werden kann, besteht in der Änderung der URL-Adresse für den Port, an dem Sie die Antwortnachricht empfangen.

Wenn Sie den Port implementieren, der die Antwortnachricht empfängt, muss der URL, den Sie für die Antwortadresse eingeben, statt eines HTTP-Präfixes ein HTTPS-Präfix aufweisen.

Nachfolgend ein Beispiel für eine Antwortadresse, die HTTPS verwendet:

https://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\ChannelForReply{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Für das Zielsystem sind keine weiteren Änderungen an der Konfiguration erforderlich.

Verwandtes Thema

Integrieren der BizTalk-Dienste


Konfigurieren des Zielsystems für das Verwenden eines HTTP-Transports

Die Schritte in diesem Thema erläutern, wie das Zielsystem konfiguriert werden muss, damit es eine Nachricht empfängt, die eine HTTP-URL-Antwortadresse enthält, und mithilfe eines HTTP-Transports eine Antwortnachricht an das Quellsystem sendet. Informationen zum Konfigurieren der Systeme, so dass das Zielsystem einen Nicht-HTTP-Transport für das Versenden der Antwortnachrichten verwendet, finden Sie unter Konfigurieren des Zielsystems für das Verwenden eines Nicht-HTTP-Transports. Die Überlegungen zur Konfiguration für das Verwenden eines HTTPS-Transports werden weiter unten in diesem Thema behandelt.

Wenn die BizTalk-Messagingdienste für das Zielsystem die Ausgangsnachricht empfangen, ist diese so konfiguriert, dass sie eine neue Instanz eines angegebenen XLANG-Ablaufplanes aktiviert und die Nachricht an einen angegebenen Port in dieser XLANG-Ablaufplaninstanz sendet.

Der XLANG-Ablaufplan ist so konfiguriert, dass er die Daten der Antwortadresse, die sich in einem Feld der Ausgangsnachricht befinden, an das Portverweisfeld für den Port weiterleitet, der zum Senden der Antwortnachricht verwendet wird. Der XLANG-Ablaufplan versendet dann mit der Option Dynamischer Kanal die Antwortnachricht an die BizTalk-Messagingdienste.

Für die Option Dynamischer Kanal werden spezifische Portdaten als Versendungsparameter weitergeleitet, wenn die Nachricht an die BizTalk-Messagingdienste versendet wird. Die Portverweisdaten, in diesem Fall die Antwortadresse, werden an den Zielbezeichnerparameter und der Nachrichtentyp für den Port wird als Parameter für den Dokumentdefinitionsnamen weitergeleitet. Weitere Informationen zu Versendungsparametern finden Sie unter Submitting. Die Versendungsparameter ermöglichen den BizTalk-Messagingdiensten das Festlegen eines bestimmten Kanals zur Verarbeitung der Antwortnachricht. Weitere Informationen finden Sie unter Identifikation.

Wenn Sie die Option Dynamischer Kanal verwenden, muss dem Kanal in den BizTalk-Messagingdiensten ein offener Messagingport zugewiesen sein. Der offene Messagingport transportiert die Antwortnachricht zum Quellsystem des Handelspartners, indem die Antwortadresse verwendet wird, die als Zielbezeichnerparameter weitergeleitet wird. Da dies die HTTP-URL einer ASP-Seite im Quellsystem ist, wird der HTTP-Transport verwendet. Weitere Informationen zu offenen Messagingports finden Sie unter Offene Messagingports.

Damit die Konfiguration dieses Zielsystems korrekt funktioniert, muss auch das Quellsystem des Handelspartners korrekt konfiguriert sein. Weitere Informationen zum Konfigurieren des Quellsystems finden Sie unter Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports.

Um das Zielsystem so zu konfigurieren, dass ein HTTP-Transport verwendet wird, führen Sie die Schritte in der folgenden Tabelle aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals, mit dem Sie die Ausgangsnachricht verarbeiten werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Sie müssen in jeder dieser Spezifikationen ein Feld für die Antwortadresse hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden, die Adresse muss jedoch mit dem Handelspartner abgestimmt werden und den Spezifikationen im Quellsystem des Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
  • Erstellen Sie die Spezifikationen, die für die eingehenden und ausgehenden Dokumentdefinitionen des Kanals benötigt werden, der die Antwortnachricht verarbeiten wird.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Für diese Spezifikationen ist keine besondere Konfiguration erforderlich.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie eine Organisation, die für den Handelspartner mit dem Quellsystem steht.
  • Erstellen von Organisationen

    Anmerkung

    • Für diese Organisation ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie die Dokumentdefinitionen, die für das Erstellen eines Kanals benötigt werden, der die Ausgangsnachricht verarbeitet, und eines Kanals, der die Antwortnachricht verarbeitet.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die zuvor erstellten Spezifikationen aus. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie einen Messagingport zu einer Anwendung, um eine neue XLANG-Ablaufplaninstanz zu aktivieren und um die Ausgangsnachricht an einen Port in der XLANG-Ablaufplaninstanz zu transportieren.
  • Erstellen von Messagingports

    Anmerkungen

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung auf Neuer XLANG-Ablaufplan.

    • Geben Sie im Feld Moniker für Ablaufplan den Moniker des angegebenen Ablaufplanes ein, oder klicken Sie auf Durchsuchen, um den Pfad festzulegen.

    • Geben Sie im Feld Portname den Namen des in diesem Ablaufplan vorgesehenen Ports ein, an den das Dokument gesendet wird.

      Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.
  • Erstellen Sie einen Kanal von einer Organisation, um die Ausgangsnachricht vom Handelspartner zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkung

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentdefinition für ausgehende Dokumente, die Sie verwenden. Diese Namen werden zum Konfigurieren der BizTalk-Orchestrierungsdienste verwendet.
  • Erstellen Sie einen offenen Messagingport zu einer Organisation, um die Antwortnachricht zum Quellsystem zu transportieren.
  • Erstellen von Messagingports

    Anmerkung

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation auf Offenes Ziel. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

      Für einen offenen Messagingport müssen die Zielinformationen im Dokument enthalten sein oder von den Versendungsparametern bereitgestellt werden. Wenn der XLANG-Ablaufplan die Antwortnachricht an die BizTalk-Messagingdienste versendet, leitet er die Daten der Antwortadresse, die in der Ausgangsnachricht enthalten waren, als Versendungsparameter für den Zielbezeichner weiter.
  • Erstellen Sie einen Kanal von einer Anwendung, um die Antwortnachricht vom XLANG-Ablaufplan zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkung

    • Klicken Sie im Kanal-Assistenten auf der Seite Quellanwendung auf XLANG-Ablaufplan. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.
Verwenden des BizTalk-Orchestrierungs-Designers:
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Empfangen der Antwortnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkungen

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Kommunikationsrichtung auf Empfangen.

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über die XLANG-Ablaufplanaktivierung auf Ja.

    Wichtig

    • Wenn Sie auf Ja klicken, wird der Port so konfiguriert, dass eine neue Ablaufplaninstanz aktiviert wird, wenn eine Nachricht ankommt. Weitere wichtige Informationen zu dieser Option finden Sie in den Themen, auf die in Zusammenhang mit diesem Schritt verwiesen wird.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Anfangsnachricht empfängt.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden, aber wenn Sie den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal verwenden, wird deutlicher, welche Nachricht Sie senden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal ein, den Sie zur Verarbeitung der Antwortnachricht verwenden.

      Alle von BizTalk-Messaging an den XLANG-Ablaufplan weitergeleiteten Nachrichten verwenden eine Nachrichtenwarteschlange. Die Bezeichnung für diese Nachrichten ist der Name der Dokumentdefinition für ausgehende Dokumente des Kanals.
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Senden der Antwortnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkungen

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über statische oder dynamische Kanäle auf Dynamischer Kanal.

    • Wenn Sie einen Port erstellen, der einen dynamischen Kanal verwendet, wird der Kanal, den die BizTalk-Messagingdienste zum Verarbeiten der Nachricht verwenden, aufgrund der Portdaten ermittelt, die als Versendungsparameter weitergeleitet wurden. Dies wird weiter unten in der Tabelle beschrieben.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der zum Versenden der Antwortnachricht verwendet wird.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden, aber wenn Sie den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal verwenden, wird deutlicher, welche Nachricht Sie versenden.

    • Auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp müssen Sie den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal eingeben, den Sie zum Verarbeiten der Nachricht verwenden.

      Die Daten der Dokumentdefinition für eingehende Dokumente werden als Versendungsparameter an die BizTalk-Messagingdienste weitergeleitet. Dies wird weiter unten in der Tabelle beschrieben.
  • Richten Sie den Datenfluss ein, um das Antwortfeld an den Portverweis des Ports weiterzuleiten, der die Antwortnachricht sendet.
  • Festlegen des Datenflusses zwischen Nachrichten

    Anmerkungen

    • Klicken Sie auf die Registerkarte Daten.

    • Klicken Sie in der Ausgangsnachricht auf der Datenseite Daten auf das Feld für die Antwortadresse. Ziehen Sie dann das Kontrollhandle auf den linken Verbindungspunkt des Portverweises in der Nachricht Port References für den Port, der zum Senden einer Antwortnachricht verwendet wird.

    Wichtig

    • Sie müssen das Feld für die Antwortadresse mit dem linken Verbindungspunkt des Portverweises verbinden. Ein linker Verbindungspunkt an einem Portverweis ist nur verfügbar, wenn ein Port konfiguriert wird, der einen dynamischen Kanal zum Senden von Nachrichten verwendet.

      Für einen Port, der einen dynamischen Kanal verwendet, müssen die Daten für den Portverweis aus einem Feld in einer zuvor empfangenen Nachricht weitergeleitet werden.

      In diesem Szenario werden die Daten der Antwortadresse aus der Ausgangsnachricht an das Portverweisfeld für den Port weitergeleitet, der zum Versenden der Antwort verwendet wird. Die Antwortadresse ist der HTTP-URL, an den die Antwort gesendet wird.

      Wenn ein Port, der einen dynamischen Kanal verwendet, eine Nachricht an die BizTalk-Messagingdienste weiterleitet, werden die Portverweisdaten als Zielbezeichnerparameter weitergegeben und die Nachrichtentypdaten werden als Dokumentdefinitionsparameter weitergeleitet. Mithilfe der Parameter können die BizTalk-Messagingdienste feststellen, welcher Kanal zum Verarbeiten der Nachricht aufgerufen werden soll. Weitere Informationen finden Sie unter Identifikation und Submitting.

      Wenn ein Port so konfiguriert wird, dass ein dynamischer Kanal verwendet wird, werden die Informationen zum Ziel als Parameter in einer Versendung an ein offenes Ziel weitergeleitet. Deshalb muss ein Kanal, der von einem Port aufgerufen wird, der einen dynamischen Kanal verwendet, einem offenen Messagingport zugewiesen sein.

Verwenden eines sicheren HTTPS-Transports

Da der zum Transport von Antworten verwendete Messagingport ein offener Messagingport ist, ist es nicht möglich, ein Verschlüsselungszertifikat zum Verschlüsseln von Dokumenten zu verwenden.

Wenn für den Geschäftsprozess ein sicherer Transport für den Austausch von Nachrichten mit einem Handelspartner erforderlich ist, muss das Quellsystem einen HTTPS-URL statt eines HTTP-URL in den ursprünglich an Sie gesendeten Nachrichten als Antwortadresse angeben.

Weitere Informationen finden Sie unter Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports.


Verwenden eines Nicht-HTTP-Transports

Dieser Abschnitt erläutert, wie die BizTalk-Orchestrierungsdienste und die BizTalk-Messagingdienste sowohl für das Quellsystem als auch für das Zielsystem integriert und konfiguriert werden, so dass folgende Aktionen ausgeführt werden:

  • Das Quellsystem generiert und sendet eine Nachricht mithilfe einer bestimmten XLANG-Ablaufplaninstanz an das Zielsystem eines Handelspartners.

  • Das Zielsystem empfängt die Ausgangsnachricht, aktiviert eine XLANG-Ablaufplaninstanz, die eine Antwortnachricht generiert, und sendet dann die Antwortnachricht an das Quellsystem mithilfe eines Nicht-HTTP-Transports.

Informationen zum Konfigurieren beider Systeme , so dass das Zielsystem einen HTTP-Transport zum Versenden der Antwortnachrichten verwenden kann, finden Sie unter Verwenden eines HTTP-Transports.

Folgende Themen werden in diesem Abschnitt behandelt:

  • Konfigurieren des Quellsystems für das Verwenden eines Nicht-HTTP-Transports

  • Konfigurieren des Zielsystems für das Verwenden eines Nicht-HTTP-Transports


Konfigurieren des Quellsystems für das Verwenden eines Nicht-HTTP-Transports

Die Schritte in diesem Thema erläutern, wie das Quellsystem konfiguriert werden muss, damit es eine Nachricht generiert und versendet, die den Pfad einer statischen Warteschlange enthält. Das Zielsystem des Handelspartners ist so konfiguriert, dass es den Warteschlangenpfad in einer Nachricht in ein Feld einer Antwortnachricht weiterleitet und diese mithilfe eines Nicht-HTTP-Transports an das Quellsystem sendet. Informationen zum Konfigurieren des Quellsystems, so dass das Zielsystem einen HTTP-Transport zum Versenden der Antwortnachrichten verwendet, finden Sie unter Konfigurieren des Quellsystems für das Verwenden eines HTTP-Transports.

Wenn das Quellsystem die Antwortnachricht empfängt, versendet es die Nachricht an die BizTalk-Messagingdienste. Die BizTalk-Messagingdienste transportieren die Antwortnachricht zur Warteschlange, die im Warteschlangenpfad im Dokumentfeld angegeben ist. Diese Warteschlange wird von derselben XLANG-Ablaufplaninstanz überwacht, welche auch die Ausgangsnachricht generiert hat, und der Ablaufplan ruft die Nachricht aus der Warteschlange ab.

Damit die Konfiguration dieses Quellsystems korrekt funktioniert, muss auch das Zielsystem des Handelspartners korrekt konfiguriert sein. Weitere Informationen zum Konfigurieren des Zielsystems finden Sie unter Konfigurieren des Zielsystems für das Verwenden eines Nicht-HTTP-Transports.

Um das Quellsystem so zu konfigurieren, dass ein Nicht-HTTP-Transport verwendet wird, führen Sie die in der folgenden Tabelle aufgeführten Schritte aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals, mit dem Sie die Ausgangsnachricht verarbeiten werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Sie müssen in jeder dieser Spezifikationen ein Feld für den Warteschlangenpfad hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden, die Adresse muss jedoch mit dem Handelspartner abgestimmt werden und den Spezifikationen im Zielsystem des Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
  • Erstellen Sie die Spezifikationen für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals, mit dem Sie die Antwortnachricht verarbeiten werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkungen

    • Sie müssen in der Spezifikation für eingehende Dokumente einen Warteschlangenpfad hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden, die Adresse muss jedoch mit dem Handelspartner abgestimmt werden und den Spezifikationen im Zielsystem des Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.

    • Das Feld zur Angabe des Warteschlangenpfades in der Spezifikation für eingehende Dokumente muss als der Zielwert in den Eigenschaften festgelegt sein. Weitere Informationen finden Sie unter Festlegen von Wörterbucheigenschaften.

      Wenn die Antwortnachricht empfangen und an die BizTalk-Messagingdienste im Quellsystem versendet wird, wird der Warteschlangenpfad erkannt und als Zielbezeichnerparameter behandelt. Weitere Informationen finden Sie unter Submitting. Der Messagingport transportiert die Antwortnachricht an die von diesem Warteschlangenpfad angegebene Warteschlange. Der XLANG-Ablaufplan überwacht diese Warteschlange und ruft die Antwort ab.

Verwenden des BizTalk-Mappers:
  • Erstellen Sie eine Zuordnung, die in dem Kanal verwendet wird, der die Ausgangsnachricht verarbeitet.
  • Erstellen neuer Zuordnungen

    Wichtig

    • Die Syntax für den Namen des Warteschlangenpfades, den der XLANG-Ablaufplan generiert, muss von einem Pfadnamen in einen Formatnamen geändert werden, und es muss das Präfix queue:// hinzugefügt werden. Bei dem HTTP-Transportszenario übernimmt das Skript in der ASP-Seite diese Änderung. Um diese Änderung für das Nicht-HTTP-Transportszenario vorzunehmen, müssen Sie ein Verketten-Funktoid in einer Zuordnung verwenden. Weitere Informationen finden Sie unter Integrieren der BizTalk-Dienste mithilfe von Zuordnungen.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie eine Organisation, die für den Handelspartner mit dem Zielsystem steht.
  • Erstellen von Organisationen

    Anmerkung

    • Für diese Organisation ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie die Dokumentdefinitionen, die für das Erstellen eines Kanals benötigt werden, der die Ausgangsnachricht verarbeitet, und eines Kanals, der die Antwortnachricht verarbeitet.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die zuvor erstellten Spezifikationen aus. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie einen Messagingport zu einer Organisation, um die Ausgangsnachricht zum Zielsystem zu transportieren.
  • Erstellen von Messagingports

    Anmerkung

    • Für diesen Messagingport ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie einen Kanal von einer Anwendung, um die Ausgangsnachricht vom XLANG-Ablaufplan zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Klicken Sie im Kanal-Assistenten auf der Seite Quellanwendung auf XLANG-Ablaufplan. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.

    • Aktivieren Sie auf der Seite Ausgehendes Dokument das Kontrollkästchen Eingehendes Dokument ausgehendem Dokument zuordnen, und klicken Sie rechts neben dem Feld Verweis zuordnen auf Durchsuchen. Suchen Sie dann die Zuordnung, die Sie zuvor erstellt haben, und klicken Sie auf Öffnen.

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentdefinition für eingehende Dokumente, die Sie verwenden. Mit diesen Namen werden die BizTalk-Orchestrierungsdienste konfiguriert.
  • Erstellen Sie einen offenen Messagingport zu einer Organisation, um die Antwortnachricht zur aktiven XLANG-Ablaufplaninstanz zu transportieren, die die Ausgangsnachricht generiert hat.
  • Erstellen von Messagingports

    Anmerkungen

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation auf Offenes Ziel. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielorganisation.

    • Für dieses Szenario erstellen Sie einen Messagingport zu einer Organisation, selbst wenn Sie die Antwortnachricht an eine Anwendung, nämlich an einen XLANG-Ablaufplan, senden.

      Dadurch können Sie einen offenen Messagingport verwenden, um die Antwortnachricht mithilfe der Warteschlangeninformationen als Versendungsparameter zu versenden. Weitere Informationen finden Sie unter Submitting.

      Der offene Messagingport transportiert die Antwortnachricht zur statischen Warteschlange, die in dem Warteschlangenpfad angegeben ist, wobei der XLANG-Ablaufplan so konfiguriert ist, dass er diese abruft.
  • Erstellen Sie einen Kanal von einer Organisation, um die Antwortnachricht vom Zielsystem zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Die Dokumentdefinition für eingehende Dokumente für diesen Kanal muss die Dokumentdefinition verwenden, die die zuvor erstellte Spezifikation verwendet, in der Sie das Feld zum Angeben des Warteschlangenpfades als den Zielwert in den Wörterbucheigenschaften festgelegt haben.

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentdefinition für eingehende Dokumente, die Sie verwenden. Diese Namen werden zum Konfigurieren der BizTalk-Orchestrierungsdienste verwendet.
Verwenden des BizTalk-Orchestrierungs-Designers:
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Senden der Ausgangsnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkung

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über statische oder dynamische Kanäle auf Statischer Kanal, und geben Sie im Feld Geben Sie den Namen eines bekannten, vorgegebenen Kanals ein den Namen des Kanals im BizTalk-Messaging-Manager ein, den Sie zum Verarbeiten der Ausgangsnachricht verwenden.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Ausgangsnachricht sendet.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden, aber wenn Sie den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal verwenden, wird deutlicher, welche Nachricht Sie versenden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal ein, den Sie zum Verarbeiten der Nachricht verwenden.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen, und suchen Sie die Spezifikation, die Sie für die Definition eingehender Dokumente des Kanals für die Ausgangsnachricht verwenden.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation im Bereich Nachrichtenfelder auf Hinzufügen, und fügen Sie das Feld in der Spezifikation hinzu, das erstellt wurde, um den Warteschlangenpfad aufzunehmen.
  • Verwenden Sie eine BizTalk-Message Queuing-Form, um einen Port zu implementieren, an dem Sie eine Antwortnachricht empfangen.
  • Implementieren eines Ports mithilfe von Message Queuing

    Anmerkungen

    • Bei diesem Szenario verwenden Sie eine Message Queuing-Portbindung, obwohl Sie eine Nachricht von den BizTalk-Messagingdiensten empfangen.

    • Klicken Sie im Bindungs-Assistenten für Message Queuing auf der Seite Informationen über statische oder dynamische Warteschlangen auf Statische Warteschlange.

    • Klicken Sie auf der Seite Warteschlangeninformationen auf Neue Warteschlange für jede Instanz erstellen, und geben Sie in das Feld Geben Sie das Warteschlangenpräfix ein den Namen des Präfixes ein, das zur Erstellung des Warteschlangennamens verwendet werden soll.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, an dem Sie eine Antwortnachricht empfangen.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Willkommen beim Assistenten für XML-Kommunikation auf Empfangen.

    • Klicken Sie auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden, aber wenn Sie den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal verwenden, wird deutlicher, welche Nachricht Sie empfangen.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal ein, den Sie zur Verarbeitung der Antwortnachricht verwenden.

      Alle von BizTalk-Messaging an den XLANG-Ablaufplan weitergeleiteten Nachrichten verwenden eine Nachrichtenwarteschlange. Die Bezeichnung für diese Nachrichten ist der Name der Dokumentdefinition für ausgehende Dokumente des Kanals.
  • Richten Sie den Datenfluss vom empfangenden Portverweis zum Feld des Warteschlangenpfades ein.
  • Festlegen des Datenflusses zwischen Nachrichten

    Anmerkungen

    • Klicken Sie auf die Registerkarte Daten.

    • Klicken Sie auf der Datenseite in der Nachricht Port References auf das Feld für den Port, der die Antwortnachricht empfängt. Ziehen Sie dann das Kontrollhandle zum Verbindungspunkt des Feldes zum Angeben des Warteschlangenpfades in der Ausgangsnachricht.

      Dadurch werden die Verweisreferenzdaten in das Warteschlangenfeld der Ausgangsnachricht eingefügt. Der Portverweis ist der Warteschlangenpfad der statischen Warteschlange für den Port, mit dem Sie eine Antwortnachricht empfangen.


Konfigurieren des Zielsystems für das Verwenden eines Nicht-HTTP-Transports

Die Schritte in diesem Thema erläutern, wie das Zielsystem konfiguriert werden muss, damit es eine Nachricht empfängt, die einen Warteschlangenpfad enthält, und eine Antwortnachricht an denselben Warteschlangenpfad zum Quellsystem mithilfe eines Nicht-HTTP-Transports sendet. Informationen zum Konfigurieren des Zielsystems, so dass das Zielsystem einen HTTP-Transport zum Versenden der Antwortnachrichten verwendet, finden Sie unter Konfigurieren des Zielsystems für das Verwenden eines HTTP-Transports.

Wenn die BizTalk-Messagingdienste für das Zielsystem die Ausgangsnachricht empfangen, ist diese so konfiguriert, dass sie eine neue Instanz eines angegebenen XLANG-Ablaufplanes aktiviert und die Nachricht an einen angegebenen Port in dieser XLANG-Ablaufplaninstanz weiterleitet.

Der XLANG-Ablaufplan ist so konfiguriert, dass er die Daten im Feld des Warteschlangenpfades der Ausgangsnachricht an ein passendes Feld der Antwortnachricht weiterleitet und die Antwortnachricht dann an einen Kanal in den BizTalk-Messagingdiensten versendet.

Die BizTalk-Messagingdienste verwenden den angegebenen Kanal, um die Antwortnachricht zu verarbeiten und sie an einen Messagingport weiterzuleiten. Dieser Messagingport ist so konfiguriert, dass die Antwortnachricht an eine Adresse transportiert wird, die mit dem Handelspartner, der für das Quellsystem zuständig ist, vereinbart wurde. Dieser Messagingport kann kein offener Messagingport sein.

Damit die Konfiguration dieses Zielsystems korrekt funktioniert, muss auch das Quellsystem des Handelspartners korrekt konfiguriert sein. Weitere Informationen zum Konfigurieren des Quellsystems finden Sie unter Konfigurieren des Quellsystems für das Verwenden eines Nicht-HTTP-Transports.

Um das Zielsystem so zu konfigurieren, dass ein Nicht-HTTP-Transport verwendet wird, führen Sie die in der folgenden Tabelle aufgeführten Schritte aus. Verweise werden für jedes Verfahren bereitgestellt, und Anmerkungen weisen auf bestimmte Konfigurationsprobleme hin. Andere Einstellungen für Eigenschaften, die zum Abschließen der Konfiguration erforderlich sind, hängen von der einzelnen Geschäftssituation ab und sind hier nicht angegeben.

Schritt Verweise und Anmerkungen
Verwenden des BizTalk-Editors:
  • Erstellen Sie die Spezifikationen für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals, mit dem Sie die Ausgangsnachricht verarbeiten werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Sie müssen in jeder dieser Spezifikationen ein Feld für den Warteschlangenpfad hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden, die Adresse muss jedoch mit dem Handelspartner abgestimmt werden und den Spezifikationen im Quellsystem des Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
  • Erstellen Sie die Spezifikationen für die Dokumentdefinitionen für ein- und ausgehende Dokumente des Kanals, mit dem Sie die Antwortnachricht verarbeiten werden.
  • Erstellen und Überprüfen von Spezifikationen

    Anmerkung

    • Sie müssen in jeder dieser Spezifikationen ein Feld für den Warteschlangenpfad hinzufügen. Dieses Feld kann auf jeder Ebene hinzugefügt werden, die Adresse muss jedoch mit dem Handelspartner abgestimmt werden und den Spezifikationen im Quellsystem des Handelspartners entsprechen. Weitere Informationen finden Sie unter Verwalten von Datensätzen und Feldern.
Verwenden des BizTalk-Messaging-Managers:
  • Erstellen Sie eine Organisation, die für den Handelspartner mit dem Quellsystem steht.
  • Erstellen von Organisationen

    Anmerkung

    • Für diese Organisation ist keine besondere Konfiguration erforderlich.
  • Erstellen Sie die erforderlichen Dokumentdefinitionen für das Einrichten eines Kanals, um die Ausgangsnachricht zu verarbeiten.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die zuvor erstellten Spezifikationen aus. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie die erforderlichen Dokumentdefinitionen für das Einrichten eines Kanals, um die Antwortnachricht zu verarbeiten.
  • Erstellen von Dokumentdefinitionen

    Anmerkung

    • Wählen Sie in den Dokumentdefinitionen die zuvor erstellten Spezifikationen aus. Weitere Informationen finden Sie unter Auswählen einer Dokumentspezifikation.
  • Erstellen Sie einen Messagingport zu einer Anwendung, um eine neue XLANG-Ablaufplaninstanz zu aktivieren, und transportieren Sie die Ausgangsnachricht an einen Port in dieser XLANG-Ablaufplaninstanz.
  • Erstellen von Messagingports

    Anmerkungen

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielanwendung auf Neuer XLANG-Ablaufplan.

    • Geben Sie im Feld Moniker für Ablaufplan den Moniker des angegebenen Ablaufplanes ein, oder klicken Sie auf Durchsuchen, um den Pfad festzulegen.

    • Geben Sie im Feld Portname den Namen des in diesem Ablaufplan vorgesehenen Ports ein, an den das Dokument gesendet wird.

      Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Zielanwendung.

      Um diesen Schritt abzuschließen, brauchen Sie den Pfad eines XLANG-Ablaufplanes und den Namen des Ports im Ablaufplan, an den die Ausgangsnachricht gesendet wird. Deshalb müssen Sie zunächst den XLANG-Ablaufplan erstellen und seinen Port konfigurieren, wie weiter unten in dieser Tabelle beschrieben.
  • Erstellen Sie einen Kanal von einer Organisation, um die Ausgangsnachricht vom Handelspartner zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkung

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentdefinition für ausgehende Dokumente, die Sie verwenden. Mit diesen Namen werden die BizTalk-Orchestrierungsdienste konfiguriert.
  • Erstellen Sie einen Messagingport zu einer Organisation, um die Antwortnachricht zum Quellsystem zu transportieren.
  • Erstellen von Messagingports

    Anmerkungen

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation auf Organisation. Klicken Sie rechts vom Feld Name auf Durchsuchen.

    • Wählen Sie im Dialogfeld Organisation auswählen die Organisation aus, die Sie zuvor erstellt haben und die für den Handelspartner und das Quellsystem steht. Weitere Informationen finden Sie unter Auswählen einer Zielorganisation.

    • Klicken Sie im Messagingport-Assistenten auf der Seite Zielorganisation im Bereich Primärer Transport auf Durchsuchen.

    • Wählen Sie im Dialogfeld Primärer Transport aus der Liste Transporttyp den Transporttyp aus, und geben Sie im Feld Adresse eine Adresse ein.

      Der Transporttyp und die Adresse müssen mit dem Handelspartner abgestimmt werden und den Spezifikationen im Quellsystem des Handelspartners entsprechen.

    • Sie können keinen offenen Messagingport zum Senden der Antwortnachricht verwenden.
  • Erstellen Sie einen Kanal von einer Anwendung, um die Antwortnachricht vom XLANG-Ablaufplan zu verarbeiten.
  • Erstellen von Kanälen

    Anmerkungen

    • Klicken Sie im Kanal-Assistenten auf der Seite Quellanwendung auf XLANG-Ablaufplan. Weitere Informationen finden Sie unter Festlegen von Eigenschaften für die Quellanwendung.

    • Notieren Sie sich den Kanalnamen und den Namen der Dokumentdefinition für eingehende Dokumente, die Sie verwenden. Diese Namen werden zum Konfigurieren der BizTalk-Orchestrierungsdienste verwendet.
Verwenden des BizTalk-Orchestrierungs-Designers:
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Empfangen der Antwortnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkungen

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Kommunikationsrichtung auf Empfangen.

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über die XLANG-Ablaufplanaktivierung auf Ja.

    Wichtig

    • Wenn Sie auf Ja klicken, wird der Port so konfiguriert, dass eine neue Ablaufplaninstanz aktiviert wird, wenn eine Nachricht ankommt. Weitere wichtige Informationen zu dieser Option finden Sie in den Themen, auf die in Zusammenhang mit diesem Schritt verwiesen wird.

      Notieren Sie sich den Namen, den Sie diesem Port geben und den Speicherort, an dem Sie den kompilierten XLANG-Ablaufplan speichern. Sie brauchen diese Informationen, um einen Messagingport in den BizTalk-Messagingdiensten zu konfigurieren, wie weiter oben in dieser Tabelle beschrieben.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Anfangsnachricht empfängt.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden, aber wenn Sie den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal verwenden, wird deutlicher, welche Nachricht Sie versenden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für ausgehende Dokumente für den Kanal ein, den Sie zur Verarbeitung der Antwortnachricht verwenden.

      Alle von BizTalk-Messaging an den XLANG-Ablaufplan weitergeleiteten Nachrichten verwenden eine Nachrichtenwarteschlange. Die Bezeichnung für diese Nachrichten ist der Name der Dokumentdefinition für ausgehende Dokumente des Kanals.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen, und suchen Sie die Spezifikation, die Sie für die Definition ausgehender Dokumente des Kanals für die Ausgangsnachricht verwenden.

    • Klicken Sie im Bereich Nachrichtenfelder auf Hinzufügen, und fügen Sie das Feld in der Spezifikation hinzu, das erstellt wurde, um die Adresse des Warteschlangenpfades für die Ausgangsnachricht aufzunehmen.
  • Verwenden Sie eine BizTalk-Messaging-Form, um einen Port zum Senden der Antwortnachricht zu implementieren.
  • Implementieren eines Ports mithilfe von BizTalk Messaging

    Anmerkungen

    • Klicken Sie im BizTalk-Bindungs-Assistenten für Messaging auf der Seite Informationen über statische oder dynamische Kanäle auf Statischer Kanal, und geben Sie im Feld Geben Sie den Namen eines bekannten, vorgegebenen Kanals ein den Namen des Kanals im BizTalk-Messaging-Manager ein, den Sie zum Verarbeiten der Antwortnachricht verwenden.

    • Da dieser Port einen statischen Kanal verwendet, erfolgt kein Zielversendungsaufruf an BizTalk-Messaging. Daher kann der angegebene Kanal keinem offenen Messagingport zugewiesen werden.
  • Richten Sie den Kommunikationsfluss zwischen einer Aktion-Form und dem Port ein, der die Antwortnachricht sendet.
  • Senden oder Empfangen asynchroner Nachrichten

    Anmerkungen

    • Klicken Sie im Assistenten für XML-Kommunikation auf der Seite Nachrichteninformationen auf Neue Nachricht erstellen, und geben Sie im Feld Nachrichtenname einen Namen für die Nachricht ein.

      Sie können jeden Namen verwenden, aber wenn Sie den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal verwenden, wird deutlicher, welche Nachricht Sie versenden.

    • Geben Sie auf der Seite Informationen über den Nachrichtentyp im Feld Nachrichtentyp den Namen der Dokumentdefinition für eingehende Dokumente für den Kanal ein, den Sie zur Verarbeitung der Nachricht verwenden.

    • Klicken Sie auf der Seite Informationen über die Nachrichtenspezifikation auf Durchsuchen, und suchen Sie die Spezifikation, die Sie für die Definition eingehender Dokumente des Kanals verwenden, mit dem Sie die Antwortnachricht verarbeiten.

    • Klicken Sie im Bereich Nachrichtenfelder auf Hinzufügen, und fügen Sie das Feld in der Spezifikation hinzu, das erstellt wurde, um die Adresse des Warteschlangenpfades für die Antwortnachricht aufzunehmen.
  • Richten Sie den Datenfluss vom Feld zur Angabe des Warteschlangenpfades in der Ausgangsnachricht zum Feld zur Angabe des Warteschlangenpfades in der Antwortnachricht ein.
  • Festlegen des Datenflusses zwischen Nachrichten

    Anmerkungen

    • Klicken Sie auf die Registerkarte Daten.

    • Klicken Sie auf der Datenseite auf das Feld zum Angeben des Warteschlangenpfades in der Ausgangsnachricht. Ziehen Sie dann das Kontrollhandle auf den Verbindungspunkt des Feldes zum Angeben des Warteschlangenpfades in der Antwortnachricht.

      Dadurch werden die Daten zum Warteschlangenpfad von der Ausgangsnachricht an die Antwortnachricht weitergeleitet.


BizTalk Server 2002 Developer Solutions

You can programmatically integrate applications with Microsoft® BizTalk™ Server 2002 by using the BizTalk Messaging Configuration object model, or by extending and customizing the functionality of the server to suit your business and information-exchange needs. The developer solutions provide all the information necessary for Microsoft Visual Basic® and C++ developers to use or extend BizTalk Server 2002. This section also includes a complete list of interfaces, objects, enumerations, code samples, and possible error messages.

BizTalk Server 2002 supports programmatic application integration by accessing the BizTalk Messaging Configuration object model and submitting documents by calling the methods of the IInterchange interface. BizTalk Server 2002 also supports the use of extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server 3.0, Commerce Edition.

Developer Solutions is divided into the following sections:

BizTalk Messaging Services

This section provides information about how to access the BizTalk Messaging Configuration object model, including all the reference pages for the supported interfaces. This information is provided for both C++ and Visual Basic developers. For more information, see BizTalk Messaging Services.

BizTalk Documents

This section covers submitting documents to BizTalk Server 2002, using the synchronous and asynchronous methods of the IInterchange interface. It shows how to move a document after the trading partner relationships are set up, and how to track documents moving through BizTalk Server 2002. For more information, see BizTalk Documents.

BizTalk Custom Components

This section covers BizTalk Server 2002 support for extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server 3.0, Commerce Edition.

This allows developers to do the following:

  • Enable business applications to receive business documents by using AICs.

  • Extend the functionality of BizTalk Server 2002 by developing components to perform digital signatures and verification, encryption and decryption, parsing, and transport.

For more information, see BizTalk Custom Components.

BizTalk Orchestration Services

This section provides information about the interfaces that can be used to access a running instance of a specific XLANG schedule, or to perform system-wide administrative tasks in the XLANG Scheduler run-time environment. This information is provided for both C++ and Visual Basic developers. For more information, see BizTalk Orchestration Services.

BizTalk Managing and Monitoring

This section covers the Windows Management Instrumentation (WMI) classes that allow you to perform administrative functions that support the management of systems in an enterprise. This information is provided for C++, Visual Basic, and Visual Basic Scripting Edition (VBScript) developers. For more information, see BizTalk Managing and Monitoring.

BizTalk Server Developer's Toolbox

This section provides code solutions to problems commonly encountered by developers working with BizTalk Server. For more information, see BizTalk Server Developer's Toolbox.

BizTalk Server Samples

This section provides documentation and instructions for running the samples included in the BizTalk Server SDK. For more information, see BizTalk Server Samples.

BizTalk Server Reference

This section documents the BizTalk Server application programming interfaces (APIs) and error messages. For more information, see BizTalk Server Reference.


BizTalk Messaging Services

This section provides information about how to access the BizTalk Messaging Configuration object model programmatically. It shows how to manage trading partner relationships and set up messaging ports and channels for the exchange of data, using Microsoft® BizTalk™ Server 2002. This section also shows how to create document definitions and envelopes, and how to set organization properties. For additional information, see the following sections:

  • For introductory information about the BizTalk Messaging Configuration object model, see Introducing Messaging Services.

  • For general background information, see Understanding Messaging Services.

  • For information about COM interfaces, enumerations, and error messages, see the Messaging Services Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.

The BizTalk Messaging Configuration object model can also be configured by using the BizTalk Messaging Manager graphical user interface. For more information, see Using BizTalk Messaging Manager.


Introducing Messaging Services

The BizTalk Messaging Configuration object model provides an easy way for applications to set up, maintain, and retrieve messaging ports and channels for trading partner relationships and application-to-application integration. The BizTalk Messaging Configuration object model can also create envelopes and document definitions, and set organization properties.

The BizTalk Messaging Configuration object model uses a Structured Query Language (SQL) database to store the port configurations and other relational data. ActiveX® Data Objects (ADO) recordsets are returned when querying for lists of object instances (for example, messaging ports or organizations).

The BizTalk Messaging Configuration object model consists of Component Object Model (COM) objects that expose the configuration data required for Microsoft BizTalk Server 2002 to configure the interchange of structured documents between applications and trading partners. The COM objects represent instances of data in memory that can be stored in the database.

All object properties are read/write, except where noted.

Related Topics

Messaging Configuration Objects

Referential Integrity

Security


Messaging Configuration Objects

The following table shows the objects of the BizTalk Messaging Configuration object model.

Object | Description
IBizTalkChannel | Contains the configuration related to the source entity and its binding with an IBizTalkPort object.
IBizTalkConfig | Creates and retrieves other BizTalk objects, such as channels, document specifications, and messaging ports.
IBizTalkDocument | Identifies and describes the specification of a document.
IBizTalkEnvelope | Identifies the envelope format and/or the envelope schema used for documents. Envelopes are required for documents using the X12 or EDIFACT format.
IBizTalkOrganization | Identifies the source or destination point for the exchange of electronic data. An organization can represent an external trading partner, your own company, or a business unit of a trading partner or your company. An organization can designate a source application in a channel or a destination application in a port.
IBizTalkPort | Defines the destination-related attributes of a document submission.
IBizTalkPortGroup | Configures a port group. This is a group of complete IBizTalkPort objects for sending the same document, such as a catalog, a price list, or a newsletter, to a group of trading partners.

Caution

  • Do not access the database directly. Do not directly call the stored procedures. Make all changes to the database by using the methods and properties of the BizTalk Messaging Configuration object model. Making changes to the database directly bypasses many constraints enforced by the BizTalk Messaging Configuration object model and either causes the server to function incorrectly or corrupts the database.

  • The BizTalk Messaging Configuration object model should be accessed only at design time. Accessing objects in use while BizTalk Server is processing documents can produce unexpected results.

  • BizTalk Server 2002 treats all variables with a BSTR data type as NULL-terminated strings. Any data contained in a BSTR after the NULL character is ignored. Documents containing embedded NULL characters must be submitted to BizTalk Server by using pass-through mode.

Related Topics

Channels

Document Definitions

Envelopes

Messaging Ports

Organizations


Referential Integrity

Referential dependency must be considered when instantiating objects in BizTalk Server 2002. Referential dependency indicates that one object refers to, and is dependent upon, another object. For example, an IBizTalkChannel object refers to an IBizTalkPort object.

To maintain referential integrity, an object instance cannot be deleted if it is referred to by another object instance. Referential integrity is maintained when the object that is referred to exists in the database.

Remove objects from the database in the reverse order of their creation. If an object instance that is referred to by another object instance is removed, a constraint error is returned. Using the preceding example, a constraint error is returned if an IBizTalkPort object that is being used by an IBizTalkChannel object is removed.

The following sequence shows the preferred order for creating objects to maintain the referential integrity of the objects:

  1. IBizTalkOrganization

  2. IBizTalkDocument

  3. IBizTalkEnvelope (if required)

  4. IBizTalkPort
    • The IBizTalkPort object requires the IBizTalkOrganization object.

    • The IBizTalkPort object conditionally uses the IBizTalkEnvelope object.
  5. IBizTalkChannel
    • The IBizTalkChannel object requires the IBizTalkPort object.

    • The IBizTalkChannel object requires the IBizTalkDocument object.

    • The IBizTalkChannel object requires the IBizTalkOrganization object.

    • The IBizTalkChannel object conditionally uses the IBizTalkPortGroup object if the channel is created for port groups.
  6. IBizTalkPortGroup (if used)
    • The IBizTalkPortGroup object requires the IBizTalkPort object.


Security

When accessing or creating objects in the BizTalk Messaging Configuration object model, the script or application must be run in the context of a user account in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2002 is installed. Additional users can be added to this group as necessary. For additional information, see Add users to the BizTalk Server Administrators group.


Understanding Messaging Services

This section provides detailed conceptual information that is important to understanding how to access the BizTalk Messaging Configuration object model. The following topics are covered in this section:

  • Channels

  • Messaging Ports

  • Openness

  • Organizations

  • Document Definitions

  • Envelopes

  • Certificates

For information about code samples that use the BizTalk Messaging Configuration object model, see BizTalk Messaging Services Code Samples.


Channels

The IBizTalkChannel object contains the configuration information related to the source entity and its binding with an IBizTalkPort object. When BizTalk Server 2002 receives a document, a specific IBizTalkChannel object, along with the properties configured in its associated IBizTalkPort object or an associated IBizTalkPort object within an IBizTalkPortGroup, directs the server through the steps necessary to process that document. Note that multiple channels might be bound to the same IBizTalkPort object. This represents multiple source entities that exchange documents with the same destination.

The IBizTalkChannel object identifies the map used for document transformation if the type of the input IBizTalkDocument object is different from the type of the output IBizTalkDocument object. It also points to the specification that contains fields for BizTalk document tracking and selects the type of logging desired.

The following topics are covered in this section:

  • Identification

  • Document Processing

  • Configuring

  • Channel Filtering

  • Document Storage

  • Document Tracking


Identification

BizTalk Server 2002 determines the appropriate IBizTalkChannel object for processing the input document by one of the following methods:

  • The source organization identifier, qualifier, and value; the destination organization identifier, qualifier, and value; and the name of the IBizTalkDocument object are parameters of the Submit or the SubmitSync method of the IInterchange object.

  • The source and destination organization identifiers, qualifiers, and values; and the name of the IBizTalkDocument object are specified in the header fields of the document instance.

  • The name of the IBizTalkChannel object is a parameter of the Submit or the SubmitSync method call.

When BizTalk Server 2002 receives a document, it first identifies all IBizTalkChannel objects that support the specified IBizTalkDocument object. The server then looks up each IBizTalkPort object and determines if the source organization and destination organization properties identify the source and destination IBizTalkOrganization objects specified by the organization identifiers in the document or in the parameters of Submit when the document is submitted. This includes any open messaging ports that match either the specified source organization or the destination organization.

This identification process can be bypassed by specifying the name of an IBizTalkChannel object to be used as a parameter of Submit or SubmitSync.

Related Topic

Submitting


Document Processing

When BizTalk Server 2002 identifies an IBizTalkChannel object, the server processes this object, which directs the server in the steps to process the document. To direct the server, the IBizTalkChannel object follows its own rules and the rules of its associated IBizTalkPort object.

An input IBizTalkDocument object is related to an output IBizTalkDocument object by an IBizTalkChannel object. The IBizTalkPort object must be created before an associated IBizTalkChannel object can be created.

When BizTalk Server 2002 processes an IBizTalkChannel object, the server calls upon each associated IBizTalkPort object to provide the document-processing rules needed by the server. The rules set by the properties of the IBizTalkChannel object direct the server in the initial steps of document processing, such as determining which input and output IBizTalkDocument objects to use, which map file to use, and what fields to track. After a document is in its final output format, the properties of the IBizTalkPort object direct the server in the steps to prepare and transport the document according to the rules agreed to by the source and destination organizations.

When a document is submitted, the server can identify multiple IBizTalkPort and IBizTalkChannel objects that match the source organization, the destination organization, and the specified IBizTalkDocument object. Therefore, it is possible for one input document to generate multiple output documents. It is also possible for each output document to be transmitted to a different location by using different transport properties in the matching IBizTalkPort objects, and for each output document instance to include a different subset of data from the original input document by using different map files.


Configuring

An IBizTalkChannel object consists of the internal document processing data for the specified input and output IBizTalkDocument objects. To be fully configured, an IBizTalkChannel object must have one complete IBizTalkPort object identified by its Port property. Input and output IBizTalkDocument objects must be specified. After the InputDocument and OutputDocument properties are selected for use in this IBizTalkChannel object, an IBizTalkPort object or an IBizTalkPortGroup object must be selected.

The name of an IBizTalkChannel object must be unique across the database for all objects of its type.

The following properties are required before an IBizTalkChannel object can be saved:

  • InputDocument

  • Port (or PortGroup)

  • OutputDocument

  • Name

After an IBizTalkChannel object has been created or saved, only the following properties can be changed:

  • Comments

  • ControlNumberValue

  • MapReference

  • Name

  • TrackFields


Channel Filtering

Channel filtering enables the user to build a filtering expression to select an IBizTalkChannel object for processing a document instance. The server uses these expressions to select the correct IBizTalkChannel object. The Expression property contains an XPath expression that evaluates to a Boolean value. If the expression evaluates to true, the channel is used to process the document. Otherwise, the channel is not invoked to process the document.

XPath expressions can be used to obtain the value of a specific element, attribute, or collection of these items within an XML document. Consider the following XML document:

<INVOICE>

<DATE>12/31/2000</DATE>

<BILLTO>Blue Yonder Airlines</BILLTO>

<SUMMARY>

<ITEM PARTNUMBER="10001" QUANTITY="10"/>

<ITEM PARTNUMBER="20002" QUANTITY="20"/>

<TOTAL VALUE="550"/>

</SUMMARY>

</INVOICE>

Based on this document, the following XPath expression can be created to ensure that this channel only processes invoices that exceed $500:

myChannel.Expression = "/INVOICE/SUMMARY/TOTAL[@VALUE>""500""]"

In this example, the channel would process the XML document instance because the total is greater than $500. For more information about XPath expressions, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Note

  • You can use BizTalk Messaging Manager to generate XPath channel filtering expressions. For more information, see Add a channel filtering expression.


Document Storage

You can choose how to log the activity of a document instance by using the IBizTalkLoggingInfo object. The default is to log the document in its native form.

For document storage, you have the options shown in the following table.

Property | Description
All properties empty | Store no copies of the document.
LogNativeInputDocument | Store input native format (default setting).
LogNativeOutputDocument | Store output native format.
LogXMLInputDocument | Store input XML format.
LogXMLOutputDocument | Store output interim (XML) format.
Any combination of these choices | Store the options as described above.

Note

  • There is a size limit for interchanges and documents that use logging, which if exceeded greatly affects the performance of BizTalk Server. For more information about the size limit, see Interchange and document size limit.


Document Tracking

An IBizTalkChannel object points to the specification that contains fields to track the instance of the document. The designated fields are logged to the Tracking database for each instance of a document that is processed. When you assign an input IBizTalkDocument object for an IBizTalkChannel object, you can designate fields to track within the document on this channel.

When BizTalk Server 2002 runs an IBizTalkChannel object, it uses the input IBizTalkDocument object to process an input document. The fields that you have designated for tracking are captured and logged for each instance of that document. Any fields designated for tracking in the output IBizTalkDocument object of the associated IBizTalkChannel object are ignored. To retrieve the information that is tracked during document processing, use the methods of the IBizTalkTrackData object.

By logging important data from the input documents that are processed, you can track and analyze detailed information about your operation. For example, an invoice-total field can be logged for every invoice that is sent to your trading partners. You can then determine the total dollar amount of invoices sent to all trading partners over time or determine the total dollar amount of invoices to each individual trading partner.

For additional information about document tracking, see Understanding the Tracking Database Schema.


Messaging Ports

Conceptually, a messaging port is a set of rules that trading partner organizations accept for sending documents to one another. It includes information regarding the destination, transport type, security, and envelope. It identifies the source and destination IBizTalkOrganization objects and the source and destination aliases. It also identifies any applications associated with the organization, if applicable.

An IBizTalkPort object identifies a specific destination organization unless it is designated as an open messaging port, in which case the destination organization is not specified. For open messaging ports, the IBizTalkPort object is valid only if the associated document or the parameters on the Submit or the SubmitSync method of the IInterchange object contain the destination transport and address information.

The IBizTalkPort object also identifies delimiter definitions and the EDI interchange control number. Delimiters are used to separate the records and fields of the envelope and the documents within the envelope. An interchange control number is used to identify and track documents that are sent using the envelope. The interchange control number is incremented with each use of the envelope at run time.

An IBizTalkPort object also identifies the encoding, encryption, and signature type, if required.

Note

  • After an IBizTalkPort object has been created and saved, the destination organization and the openness associated with the endpoint cannot be changed.

Related Topics

Openness

Port Groups


Port Groups

The IBizTalkPortGroup object configures a group of complete IBizTalkPort objects for sending the same document to a group of trading partners. For example, you can use this when you want to send a document, such as a catalog, a price list, or a newsletter, that contains identical data to a group of trading partners. One document is sent to a list of partners by calling a single Submit method on the IInterchange object.

The IBizTalkPortGroup object must contain at least one IBizTalkPort object. You can add or remove IBizTalkPort objects to or from an IBizTalkPortGroup by calling the AddPort or the RemovePort method.

An IBizTalkPortGroup object must be associated with at least one IBizTalkChannel object. After the port group has been created, associate a channel with the port group by using the PortGroup property available on the IBizTalkChannel object. When BizTalk Server 2002 invokes a channel related to a port group, it invokes only the channel that is associated with the port group to process the data. None of the channels that are associated with the individual ports in the port group are invoked. The server uses the properties of each port successively to transport the data to the destinations specified in the ports.

Notes

  • Open messaging ports cannot be added to a port group.

  • BizTalk Messaging Manager refers to port groups as distribution lists.

Related Topic

Submitting


Openness

The Openness property of the IBizTalkEndPoint object determines whether the messaging port or channel is open. An open IBizTalkPort object is a messaging port without a specified destination. An open IBizTalkChannel object is a channel without a specified source. The missing information for an open messaging port or channel must be supplied by the associated document or by the parameters on the Submit or the SubmitSync method of the IInterchange object.

If an open channel is specified by using BIZTALK_OPENNESS_TYPE_EX_SOURCE or an open messaging port is specified by using BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Usage, Reference, and Store properties cannot be specified on the IBizTalkCertificateInfo object.

Note

  • If an open messaging port is used with the SMTP transport type, the value specified for the IBizTalkOrganization identifier Reliable Messaging Acknowledgement SMTP From Address is used as the From address.

Related Topic

Submitting


Organizations

IBizTalkOrganization objects serve as sources or destinations for the exchange of electronic data. An organization can represent an external trading partner, your own company, or a business unit of a trading partner or your company. The home organization can designate a source application in a channel or a destination application in a messaging port.

Applications are properties of the home organization. An applications can be designated as a source application in an IBizTalkChannel object or as a destination application in an IBizTalkPort object.

Aliases

An alias is an organization identifier for the IBizTalkOrganization object. An IBizTalkOrganization object must always have one and only one default alias, but it can have multiple aliases. An alias is autogenerated for each IBizTalkOrganization object. The default alias and the autogenerated alias cannot be removed.

For more information, see Create and Manage Organizations.


Document Definitions

The IBizTalkDocument object describes and identifies the document specification used to describe the document sent or received. The document specification defines the structure of a document, as well as any validation rules and descriptions for the individual elements of the document specification. The IBizTalkDocument object includes the version and type of the specification and, optionally, a reference to the Web Distributed Authoring and Versioning (WebDAV) location of the specification. For more information about document specifications, see Create and Validate Specifications.

Notes

  • The document Content and NameSpace properties are not valid until you set the Reference property.

  • When creating a new IBizTalkDocument object that uses a namespace that is already registered with BizTalk Server, the new document inherits the Reference property of that namespace. The namespace must be unique (case insensitive) for a new Reference to be created.

The IBizTalkDocument object also contains the electronic data interchange (EDI) selection criteria by which BizTalk Server 2002 extracts information from the functional group header of the document to identify this object when the name of the IBizTalkDocument object is not available.

An IBizTalkDocument object points to the specification that contains fields to track the instance of the document. The designated fields are logged to the Tracking database for each document that is processed.

Selection criteria

For some EDI input interchanges, documents are contained within functional group envelopes. When BizTalk Server 2002 processes such documents, it cannot obtain the name of the IBizTalkDocument object from a field within each document. Also, because there are multiple types of documents involved, a single name cannot be specified as a parameter of the Submit method of the IInterchange object. In such cases, the server can locate document-related data within the functional group header (for example, in the GS header of an X12 interchange). By comparing this data to matching selection criteria specified in the PropertySet property on the IBizTalkDocument object, the server can uniquely identify an IBizTalkDocument object. After the IBizTalkDocument object is identified, the server can obtain the name and then identify and instantiate the appropriate IBizTalkChannel object.

Selection criteria also help BizTalk Server 2002 create the header of the EDI document when it is output.

Global tracking

An IBizTalkDocument object points to the specification from which fields can be selected for tracking. The designated fields in the input document specification are tracked for each document that is processed using that specification. Any fields designated for tracking in the output document specification are ignored. If an IBizTalkChannel object that specifies tracking fields is used with an input document specification containing fields designated for tracking, only the fields specified by the channel are used for tracking.

By logging important data from the input documents that are processed, you can track and analyze detailed information about your operation. For example, an invoice-total field can be logged for every invoice that is sent to your trading partners. You can then determine the total dollar amount of invoices sent to all trading partners over time or determine the total dollar amount of invoices to each individual trading partner.

Related Topics

Document Storage

Document Tracking


Envelopes

The IBizTalkEnvelope object consists of two pieces of information:

  • The type of envelope is specified in the Format property. The document Type should match the envelope Format for "flatfile", "custom xml", "x12", "edifact", and "reliable" document types.

  • The actual envelope file used is specified in the Reference property.

Input document envelopes

An envelope is required if the input document Type is "flatfile" because the envelope contains information about how to parse the document into XML and which parser should process the document. Input "flatfile" documents without an envelope are not processed. For all other input document types, an envelope is optional.

Output document envelopes

Envelopes are used to wrap an output document instance that has been transformed into the native format. The envelope used with an output document is specified on the IBizTalkPort object. An envelope is required if the output document Type is "x12" or "edifact". However, the Reference property is ignored for these format types because indicating that a document is X12 or EDIFACT is sufficient to serialize the document. For output documents with a Type of "custom xml", the Reference property is used if specified. If the Reference property is not specified, "custom xml" documents are submitted for processing in the transformed XML format.

Notes

  • Multiple IBizTalkPort objects can refer to an envelope.

  • The envelope Content and NameSpace properties are not valid until you set the Reference property.

  • When creating a new IBizTalkEnvelope object that uses a namespace that is already registered with BizTalk Server, the new document inherits the Reference property of that namespace. The namespace must be unique (case insensitive) for a new Reference to be created.


Certificates

An IBizTalkCertificateInfo object is automatically created when an IBizTalkPort or an IBizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the IBizTalkConfig object.

For output documents, access the IBizTalkCertificateInfo object by using the EncryptionCertificateInfo property of the IBizTalkPort object. For input documents, access the IBizTalkCertificateInfo object by using the SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo property of the IBizTalkChannel object. To obtain the set of all existing IBizTalkCertificateInfo objects, use the Certificates property of the IBizTalkConfig object.

Note

  • All certificates are stored in the local computer store. To configure certificates for the S/MIME components, the script or application accessing the object model must be run in the context of a user account in the BizTalk Server Administrators group.


BizTalk Documents

This section provides information about how to submit documents to Microsoft BizTalk Server 2002. For additional information, see the following sections:

  • For help with specific tasks, see Using Documents.

  • For general background information, see Understanding Documents.

  • For information about COM interfaces and enumerations, see the Documents Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.


Understanding Documents

This section provides detailed conceptual information that is important to understanding how to submit documents to Microsoft® BizTalk™ Server 2002. The following topics are covered in this section:

  • Submitting

  • Routing


Submitting

All documents must be sent to Microsoft BizTalk Server 2002 by using the Submit or SubmitSync method of the IInterchange interface in order to be processed. If an application is based on Microsoft Windows® and is capable of invoking methods on COM objects, it can submit a document directly. The business application calls the Submit or SubmitSync method of the IInterchange interface, passing in the document or the file path of the document as a string supplied as a parameter. This is the simplest approach because no additional configuration is necessary. However, this method requires that the business application be designed to support direct calls to BizTalk Server 2002.

If the application is not capable of invoking methods on COM objects, receive functions can be used to submit documents to BizTalk Server. Receive functions enable applications to post documents or interchanges to specific locations that BizTalk Server 2002 is monitoring. These locations are defined according to the specific receive function. Each receive function uses event-based monitoring to recognize the presence of a document or interchange. After the data is received by the function, it submits the data to BizTalk Server. For example, a File receive function can be configured to submit a document to BizTalk Server when the business application can save a document as a file but cannot submit it directly. For more information about adding and configuring receive functions, see Manage Receive Functions for a Server Group.

The receive functions are configured to continuously monitor a specific directory or queue for a file to appear and then be submitted to BizTalk Server. HTTP and SMTP protocols are configured outside BizTalk Server. You must create script pages for these transport services.

Notes

  • There is a size limit for interchanges and documents that use logging, which, if exceeded, greatly affects the performance of BizTalk Server. For more information about the size limit, see Interchange and document size limit.

  • A script or application that uses the IInterchange interface to submit documents to BizTalk Server can be run in any user account.

  • When processing envelopes that are compliant with BizTalk Framework 2.0, BizTalk Server should be considered the endpoint with regard to the expiration time. When BizTalk Framework 2.0-compliant documents are submitted to BizTalk Server, either from an application or from a trading partner, the following fields are overwritten if present, or created if absent:
    • In the properties subsection:

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • In the receipt information subsection:

      <sendTo>

      <address>

      <sendReceiptBy>

For examples of code, see BizTalk Messaging Services Code Samples.

Sending documents to BizTalk Server 2002 asynchronously

Applications that submit documents asynchronously to BizTalk Server call Submit. Receive functions also call Submit. Submit returns after sending the document. No response document is returned, because the protocol does not support it.

Submit accepts only a string buffer or a file path as the document or interchange. BizTalk Server supports Universal Naming Convention (UNC) and local file path formats.

Sending documents to BizTalk Server 2002 synchronously

Applications that submit documents synchronously to BizTalk Server call SubmitSync.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols, an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

SubmitSync accepts only a string buffer or a file path as the document or interchange. BizTalk Server supports UNC and local file path formats.

Error handling with the Submit and SubmitSync methods

When an error occurs when submitting interchanges or documents to BizTalk Server, an event log entry is created and/or an error is returned to the caller, depending on which method is called and the nature of the failure. Documents submitted can end up in the Suspended queue due to a number of possible conditions. The following table describes what happens when one or more of the documents or interchanges submitted are placed in the Suspended queue due to an error during submission.

Method called | Error returned to caller | Event log entry
Submit | Document failure error | For every document that fails in processing
SubmitSync | Document failure error | None

Related Topics

Routing

Submitting a Document

Documents Reference


Routing

To process a document, Microsoft BizTalk Server 2002 must load the rules that govern how the incoming document instance is to be processed. These rules are known as the channel. A specific IBizTalkChannel object is associated with an IBizTalkPort object and connects two organizations.

To find the channel to process the received document, the server must have the source organization, the destination organization, and the document definition. The server can obtain this information by one of the following methods:

  • This information can be found in the content of the document itself from the data contained in the routing fields (self-routing documents).

  • This information can be explicitly declared in the parameter list of the Submit method of the IInterchange interface (call-based routing).

  • This information can be explicitly declared in the properties of a custom receive function. For more information about receive functions, see Understanding Receive Functions and Document Routing.

  • You can choose to specify the channel to use when calling Submit. This causes the server to bypass the channel selection process.

After the server has this information, it searches for the messaging port/channel pair that matches these routing criteria. If more than one channel matches, each of the channels is processed, possibly resulting in multiple output documents.

Call-based routing

In call-based routing, the source organization identifier (SourceID), the destination organization identifier (DestID), and the name of the document definition (DocName) are specified as parameters of Submit. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. If the Openness flag is set to OpenDest, the DestID is used as the destination address. If SourceID, DestID, or DocName is left blank, the missing information must be provided by the routing information contained within the document. If one of these parameters/fields is not in Submit or in the document, the document goes to the Suspended queue.

Note

  • Note that the queue:// prefix must be used with an open messaging port when a message queue is specified as the destination address.

Self-routing documents

Self-routing documents have the source organization identifier (SourceID), the destination organization identifier (DestID), and the name of the document definition (DocName) defined in the routing tags defined by the document specification, which are contained within the <SelectionFields> tag. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The BizTalk Framework specification also defines the routing tags for BizTalk Framework–compliant messages. These tags are defined as the <to> and <from> tags under the <endpoint> tag, which is contained in the <header> tag under the root <biztalk> tag. The first tag under the <body> tag determines the document type. For more information, see the BizTalk Framework 2.0 Independent Document Messaging Specification. For X12 or EDIFACT routing, the locations of the routing fields are hard-coded and are not specified in a document specification.


Using Documents

This section provides task-specific information about how to submit documents to Microsoft BizTalk Server 2002. It is highly recommended that you review the Understanding Documents topic as well.

The following topics are covered in this section:

  • Submitting a Document

  • Submitting a Document from a Remote Client

  • Reading the Tracking Database

  • Preprocessing Documents in a Receive Function

  • Accessing the Suspended Queue


Submitting a Document

Use the following steps as a guideline when submitting documents to Microsoft BizTalk Server 2002 with the IInterchange interface.

  1. Determine whether the source organization, destination organization, and document definition name are in the parameters of the Submit or the SubmitSync method of the IInterchange interface or are included in the document; it might be a combination of the two.
    • This information can be explicitly declared in the parameter list of Submit or SubmitSync (call-based routing).

      One or more of these parameters can be left blank and the missing information can be provided by the routing information contained within the document.

    • This information can be found in the content of the document itself from the data in the routing fields (self-routing documents).

    • The user can choose to explicitly call out the specific channel to use when calling Submit. This causes the server to bypass channel selection.

    • This information can be explicitly declared in the properties of a custom receive function.
  2. Decide whether to submit asynchronously or synchronously.
    • Call Submit, passing in the document or the file path of the document as a string supplied as a parameter. BizTalk Server supports URL, UNC, and drive: format for the file path.

      Submit accepts only a string variable as the document or interchange.

    • Call SubmitSync, passing in the document or the file path of the document as a string supplied as a parameter.
      • A response document is returned to the user, if available.

      • This method is valid only for a single channel match.

      • This method can be used only for single-document interchanges.
  3. Decide whether to call some of the Suspended queue methods. (This is optional and can be implemented in the same application or in a different application.)
    • Call the CheckSuspendedQueue method of the IInterchange interface.
      • Retrieve items from the Suspended queue.

      • This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.
    • Call GetSuspendedQueueItemDetails.

      Retrieve the details about a particular item in the Suspended queue.

    • Call DeleteFromSuspendedQueue.

      Remove items from the Suspended queue.


Submitting a Document from a Remote Client

A document can be submitted to Microsoft BizTalk Server 2002 from a remote client running an application that uses the IInterchange interface. To accomplish this, follow these steps:

  1. Using a computer that has Microsoft BizTalk Server 2002 installed, go to the Start menu, point to Programs, point to Administrative Tools, and then click Component Services.

  2. In the tree pane, click Component Services, expand Computers, expand My Computer, expand COM+ Applications, and then click BizTalk Server Interchange Application.

  3. On the Action menu, click Export.

  4. In the Welcome to the COM Application Export Wizard dialog box, enter the name of an export installation package to be created.

  5. In the Export as area, click the Application proxy option and click Next to finish the wizard.

The COM Application Export Wizard creates a Windows Installer Package file with an .msi extension and its associated cabinet file with a .cab extension. Copy these files to the remote client and run the Windows Installer Package file. Now the remote client can run applications that use the IInterchange interface.

Notes

  • The remote client must be running Microsoft Windows 2000.

  • The computer used to create the installation package acts as an "interchange server" for the remote client that is submitting documents. Therefore, all documents submitted on the remote client are routed through that server.

  • You can also create a remote client during the BizTalk Server 2002 installation.


Reading the Tracking Database

The purpose of the tracking interface, IBizTalkTrackData, is to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2002. This complements the IInterchange interface so that returns from IInterchange calls can be fed to the IBizTalkTrackData methods to access data about the activity of documents submitted to BizTalk Server 2002.

There can be a one-to-one or a one-to-many relationship between input and output documents. In a normal document flow, one document is submitted to the server, is tracked and possibly transformed, and one document results as output from the server. However, the messaging port can be configured so that one document submitted can result in many documents as output to several destinations.

To read and use information from the Tracking database, perform the following steps:

  1. Get the SubmissionHandle return from the Submit method of the IInterchange interface.

  2. Call the GetInterchanges method, using the SubmissionHandle return as the input. This method returns a list of interchanges contained in that submission, including all the data from the Tracking database. Because transport-specific information (delivery times, receipt flags, and so on) appears in the interchange data, you can look here to confirm or check status on delivery, for example.

  3. Call the GetInDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were included in that submission. You can look here to find information about an input document (whether a document was valid, how many bytes it contained, and so on).

  4. Call the GetOutDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were generated as a result of the submission. You can look here to find information about an output document (for example, looking for PO #123456 from a submission made earlier today).

Related Topic

Documents Reference


Preprocessing Documents in a Receive Function

Documents can be submitted to Microsoft BizTalk Server 2002 for processing by using a receive function. Using this mechanism, other applications can send their output files to a specified directory or message queue. BizTalk Server continually monitors the specified location at regular intervals and processes the files or messages placed in that location. BizTalk Server provides interfaces that allow you to create custom preprocessing components. These components process the file or message picked up by the receive function prior to submitting the data to BizTalk Server for processing.

A custom preprocessor component is required to implement the category identifier (CATID) CATID_BIZTALK_CUSTOM_PROCESS in the registry. This allows the BizTalk Server Administration user interface, or administration console, to recognize the custom preprocessor and display it in the Preprocessor list, where it can be selected.

For additional information, see IBTSCustomProcess and IBTSCustomProcessContext.

Transaction Support

If a preprocessing component supports transactions, you must explicitly enable transaction support for that component. To enable transactions with custom preprocessor components, add a registry key by following these steps:

  1. Open the registry editor.

  2. Find the custom component in the registry.

  3. Right-click the component.

  4. Click New and then click DWORD Value.

  5. In the Name field, type UseTxForCustPreProcessor.

  6. Double-click the new UseTxForCustPreProcessor key.

    The Edit DWORD Value dialog box appears.

  7. In the Value data field, type 1.

  8. Click OK.

Related Topics

BizTalk Server Administration User Interface

Receive Functions


Accessing the Suspended Queue

The Suspended queue contains work items that have failed processing for a variety of reasons, including parsing errors, serialization errors, failed transmissions, or the inability to find a channel configuration. You can retrieve or delete items from the queue using the interfaces provided.

Note

  • When accessing or deleting items in the Suspended queue, the script or application must be run in the context of a user account in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2002 is installed. Additional users can be added to this group as necessary.

Retrieving items from the Suspended queue

To retrieve items from the Suspended queue, applications call the CheckSuspendedQueue method of the IInterchange interface.

CheckSuspendedQueue retrieves a list of items in the Suspended queue that meet the search criteria specified by the parameters of the method. This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.

Getting item details from the Suspended queue

CheckSuspendedQueue returns a list of handles to items in the Suspended queue. To process these items, you must get the item details associated with each item in the Suspended queue by using GetSuspendedQueueItemDetails.

GetSuspendedQueueItemDetails retrieves the details about an item in the Suspended queue. If this method does not return individual details about this item (because the item has been removed between the time CheckSuspendedQueue was called and the call to this method, for example), each parameter that cannot be determined is returned.

Removing items from the Suspended queue

To remove items from the Suspended queue, applications call DeleteFromSuspendedQueue.

DeleteFromSuspendedQueue removes from the Suspended queue a list of items that meet the search criteria specified by the parameters of the method.


BizTalk Custom Components

This section provides information about how to create custom components and extend Microsoft® BizTalk™ Server 2002 to integrate line-of-business applications and to add features such as encryption and decryption or digital signature. With this information, you can do the following:

  • Create application integration components (AICs) that enable your applications to receive business documents by using BizTalk Server 2002.

  • Extend the functionality of BizTalk Server 2002 by developing custom components to perform digital signature, encryption and decryption, parsing, serializing, and transport of documents.

For additional information, see the following sections:

  • For help with specific tasks, see Using Custom Components.

  • For general background information, see Understanding Custom Components.

  • For information about COM interfaces, see Custom Components Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.


Understanding Custom Components

This section provides detailed conceptual information that is important to understanding how to extend Microsoft® BizTalk™ Server 2002. BizTalk Server 2002 can perform data transformation, digital signature, encryption and decryption, parsing, serializing, and transport of documents. In addition, you can create your own application integration components (AICs) to extend the capabilities of BizTalk Server 2002.

The following topics are covered:

  • Custom Component Types

  • Application Integration Components

  • Parsers

  • Serializers


Custom Component Types

Custom components can be created for application integration (AICs), encryption, encoding, signing, parsing, and serializing. The following interfaces must be implemented for each component type:

Component types | Interfaces to be implemented
Pipeline components:

AIC
Encryption
Encoding
Signing

 IPipelineComponent, IPipelineComponentAdmin
AIC (lightweight) | IBTSAppIntegration
Parsing IBizTalkParserComponent

By default, BizTalk Server registers the following parser components, listed by ProgID:

  • Edifact: BizTalk.ParserEdifact

  • Flat File: BizTalk.ParserFFile

  • X12: BizTalk.ParserX12

  • XML: BizTalk.ParserXML
Serializing IBizTalkSerializerComponent, IPipelineComponentAdmin (optional)

By default, BizTalk Server registers the following serializer components, listed by ProgID:

  • Edifact: BizTalk.SerializerEdifact

  • Flat File: BizTalk. SerializerFFile

  • X12: BizTalk. SerializerX12

  • XML: BizTalk. SerializerXML


Application Integration Components

When creating an application integration component (AIC), you can implement either the pipeline model using the IPipelineComponent interface or the lightweight model using the IBTSAppIntegration interface.

Application integration components are COM objects that the BizTalk Server state engine calls to deliver data to an application. If a messaging port is configured in BizTalk Server 2002 to include the use of an AIC for application integration, this component is automatically instantiated and passed the requisite data. The component then determines how to handle communicating this data back to the application. This can be done using private API calls, invoking other COM objects, using database writes, and so on.

This section contains the following topics:

  • Pipeline Application Integration Components

  • Lightweight Application Integration Components

By default, AICs run in the LocalSystem account. If another security context is required, set it as part of the implementation of the AIC. However, if an AIC is installed as a COM+ application, an administrator can configure security of the AIC by using the Component Services console.

When developing an AIC using Microsoft Visual Basic®, ensure that all Visual Basic components set the Unattended Execution and Retain in Memory project settings.

Related Topic

Registering Custom Components


Pipeline Application Integration Components

One approach for application integration with BizTalk Server 2002 is the creation of a pipeline component. This is the same model used in Microsoft Site Server 3.0 Commerce Edition for application integration with the Commerce Interchange pipeline (CIP) and the Order Processing pipeline (OPP). BizTalk Server 2002 supports this method so that pipeline components written for application integration for CIP and OPP are compatible. This is also a useful technique when the component requires configuration properties.

The primary entry point for a pipeline component is the Execute method of the IPipelineComponent interface. This is the method that BizTalk Server 2002 calls to transfer control and to pass the data to the component. It is in the implementation of this method that the component does its work.

Related Topics

Lightweight Application Integration Components


Lightweight Application Integration Components

BizTalk Server 2002 supports an additional model for application developers who want a lighter-weight model for application integration, one that does not support a design-time user interface or configuration properties. This model requires a single interface that contains a single method as an entry point. The component is implemented, and the document is passed to it through the ProcessMessage method of the IBTSAppIntegration interface.

IBTSAppIntegration is for applications that do not need properties for their component and need only an entry point for receiving a document. This is a simpler approach to application integration than pipeline components. BizTalk Server 2002 queries for this interface first. If it does not find this interface implemented, it queries for the pipeline component interfaces.


Parsers

The parser has two responsibilities:

  • Convert the documents to XML for later processing.

  • Get the parameters necessary to select the channel (these are the source qualifier, source identifier, destination qualifier, destination identifier, and document definition name). These returned fields are combined with the parameters of the Submit method of the IInterchange interface to select the channels necessary to process the documents.

This interface gets information from the component for one interchange. If the incoming data stream represents multiple interchanges, the server selects the component at every interchange boundary. This simplifies construction of a component because it deals with only one interchange at a time. There is one component instance per thread. No single object needs to be safe for multiple threads. This interface is supported only in C++.

If the ProbeInterchangeFormat method of the IBizTalkParserComponent interface returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

Related Topics

Registering Custom Components

Working with Parsers


Serializers

The serializer converts the document from XML back to its native format. This interface is intended to work on a single interchange and is designed to get information from the component for one interchange. This simplifies the construction of this component because it has to deal with only one interchange at a time. There is only one instance per thread. No single object needs to be safe for multiple threads. The IBizTalkSerializerComponent interface is supported only in C++.

Related Topics

Registering Custom Components

Working with Serializers


Using Custom Components

This section provides task-specific information about how to create server components. It is highly recommended that you review the Understanding Custom Components topic as well.

The following topics are covered:

  • Creating Pipeline Components

  • Creating Receipt Correlator Components

  • Working with Parsers

  • Working with Serializers

  • Registering Custom Components

  • Handling Data Passed to AICs

  • Supporting the Tracking Database with Parser and Serializer Components


Creating Pipeline Components

Use the following steps to create a pipeline component:

  1. Create an Active Template Library (ATL) wizard–generated Inproc server project.

  2. Add a simple COM object.

  3. Go to the Projectname.idl file and remove the dual or custom interface generated by the wizard in step 2.

  4. Verify that the resulting IDL file looks like the code examples that follow. You might choose to implement your own set of interfaces from the ones defined in Pipecomp.idl.

// SimplePipeComponent.idl : IDL source for SimplePipeComponent.dll

//

import "oaidl.idl";

import "ocidl.idl";

import "pipecomp.idl";

[

uuid(D26A52F6-63A0-42B1-8C88-3C71C66BB189),

version(1.0),

helpstring("SimplePipeComponent 1.0 Type Library")

]

library SIMPLEPIPECOMPONENTLib

{

importlib("stdole32.tlb");

importlib("stdole2.tlb");

[

uuid(E66CAF06-18D8-4C70-9D39-5ED9756C21AD),

helpstring("MySimplePipelineComponent Class")

]

coclass MySimplePipelineComponent

{

[default] interface IPipelineComponentAdmin;

interface IPipelineComponent;

interface IPipelineComponentDescription;

};

};

  5. One of the implementations of MySimplePipelineComponent [coclass] is defined in the header file as follows:

// MySimplePipelineComponent.h : Declaration of the

// CMySimplePipelineComponent

#ifndef __MYSIMPLEPIPELINECOMPONENT_H_

#define __MYSIMPLEPIPELINECOMPONENT_H_

#include "resource.h" // main symbols

/////////////////////////////////////////////////////////////////////////////

// CMySimplePipelineComponent

class ATL_NO_VTABLE CMySimplePipelineComponent :

public CComObjectRootEx<CComSingleThreadModel>,

public CComCoClass<CMySimplePipelineComponent, &CLSID_MySimplePipelineComponent>,

public ISupportErrorInfo,

public IDispatchImpl<IPipelineComponentAdmin, &IID_IPipelineComponentAdmin, &LIBID_SIMPLEPIPECOMPONENTLib>,

public IDispatchImpl<IPipelineComponent, &IID_IPipelineComponent, &LIBID_SIMPLEPIPECOMPONENTLib>,

public IDispatchImpl<IPipelineComponentDescription, &IID_IPipelineComponentDescription, &LIBID_SIMPLEPIPECOMPONENTLib>

{

public:

CMySimplePipelineComponent()

{

}

DECLARE_REGISTRY_RESOURCEID(IDR_MYSIMPLEPIPELINECOMPONENT)

DECLARE_PROTECT_FINAL_CONSTRUCT()

BEGIN_COM_MAP(CMySimplePipelineComponent)

COM_INTERFACE_ENTRY2(IDispatch,IPipelineComponentAdmin)

COM_INTERFACE_ENTRY(IPipelineComponentAdmin)

COM_INTERFACE_ENTRY(IPipelineComponent)

COM_INTERFACE_ENTRY(IPipelineComponentDescription)

COM_INTERFACE_ENTRY(ISupportErrorInfo)

END_COM_MAP()

// ISupportsErrorInfo

STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);

public://IPipelineComponentAdmin

STDMETHODIMP GetConfigData(IDispatch** ppDict );

STDMETHODIMP SetConfigData(IDispatch* pDict );

public://IPipelineComponent

STDMETHODIMP Execute(IDispatch* pdispObject,IDispatch* pdispContext,LONG lFlags,LONG* plErrorLevel);

STDMETHODIMP EnableDesign(BOOL fEnable);

public: //IPipelineComponentDescription

STDMETHODIMP ValuesRead(VARIANT* pvar);

STDMETHODIMP ValuesWritten(VARIANT* pvar);

STDMETHODIMP ContextValuesRead(VARIANT* pvar);

};

#endif //__MYSIMPLEPIPELINECOMPONENT_H_

Related Topics

Application Integration Components

IPipelineComponent

IPipelineComponentAdmin


Creating Receipt Correlator Components

Receipt correlator components can be implemented to correlate documents, groups of documents, and interchanges with their receipts. To use a receipt correlator, you must implement a custom parser by using the IBizTalkParserComponent interface. This is required because the server can obtain only the progID of the receipt correlator to be used by calling the GetNextDocument method on the IBizTalkParserComponent interface.

In addition, with BizTalk Server on the receiver side where the receipt is being generated, the parser component is responsible for putting the acknowledgment status, as well as sufficient information, on the receipt (a Canonical Receipt to begin with, but it can be mapped into other receipt document schemas, such as AK997 in EDI) to allow the correlator component on the sender side to uniquely identify the original outbound interchange, group, or document record. For an XML document, using the GUID is usually sufficient. But for EDI interchanges, because GUID cannot be used (there is no placeholder for any GUID in an EDI interchange), a combination of EDI-specific fields is needed for this unique identifier. For instance, the default X12 correlator component uses a combination of the following fields for this purpose: version, release, functional group ID, control ID, source application name, and destination application name.

Whenever the server receives a receipt as an inbound document, the parser component's responsibility is to detect the inbound document as being a receipt, to extract all relevant information needed for correlation, and to place the receipt onto the transport dictionary. Upon returning from the GetNextDocument method call, the parser should set the DocIsReceipt parameter to TRUE and the CorrelationCompProgID parameter to the progID of the corresponding correlator component.

The server calls the Correlate method on the IBizTalkCorrelation interface, and passes in a pointer to the IBizTalkAcknowledge object and the transport dictionary containing the receipt as the working data. Then the receipt correlator's implementation of the Correlate method extracts all relevant information about the document, document group, or interchange that should have been set by the parser component from the transport dictionary. Using this information, the Correlate method then calls AckDocument, AckGroup, or AckInterchange on the IBizTalkAcknowledge interface and sets the DTA_ACK_STATUS value for that document, group, or interchange.

Note that the server does not immediately call IBizTalkCorrelation. The receipt document and the correlation progID are stored to the database for later correlation. When the document is picked up for processing, the correlation component is created and invoked with the transport dictionary that was given by the parser component and a pointer to IBizTalkAcknowledge.

Related Topics

Submitting Documents with Receipts

Understanding Receipts


Working with Parsers

The following tables show the possible sequence of calling the methods of the IBizTalkParserComponent interface, based on the following sample interchanges.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | True
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to False.
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to True.

If you have an interchange with two documents, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | False
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A

Related Topics

Parsers

IBizTalkParserComponent

Supporting the Tracking Database with Parser and Serializer Components


Working with Serializers

To create a custom serializer component, you need to perform the following tasks:

  • Create a COM component that implements the IBizTalkSerializerComponent and IPipelineComponentAdmin interfaces.

  • Register this component and include the category identifiers CATID_BIZTALK_COMPONENT and CATID_BIZTALK_SERIALIZER in the registry. For more information, see Registering Custom Components.

  • Create Active Server Pages (ASP) files for setting custom property values on your serializer component by using the pre-defined user interface management functions. These functions are available in the ASP include files located in the folder \Microsoft BizTalk Server\Messaging Manager\pipeline on the BizTalk Server installation drive. For more information about the ASP file format, see "ASP file formats" that follows.

  • Place the ASP files in the pipeline folder and name the files using these formats:
    File name | Description
    BizTalk_ComponentName_1.asp | Displays a dialog box that reads the serializer key values from the IDictionary object. These values are displayed to the user for modification.
    BizTalk_ComponentName_1_post.asp | Updates the serializer dictionary with the new key values set by the user.

  • Use the SetConfigComponent method to associate the custom serializer component with a channel.

After these tasks are completed, the user can access these settings by clicking Advanced on the Channel Properties page in BizTalk Messaging Manager. For more information, see Set advanced configuration properties.

ASP file formats

When using the functions provided in the ASP include files located in the folder \Microsoft BizTalk Server\Messaging Manager\pipeline on the BizTalk Server installation drive, use the following general format:

<!--#INCLUDE FILE="pe_edit_header.asp" -->

<-- optional HTML formatting tags here -->

<%

optional calls to input functions here

%>

<!--#INCLUDE FILE="pe_edit_footer.asp" -->

The following functions can be used in the ASP pages for displaying text or retrieving specific types of information from the user. These functions are defined in the file pe_global_edit.asp:

  • DisplayReadonlyText

  • GetLabelAccel

  • InputArrayAccel

  • InputCheckBoxAccel

  • InputFloatAccel

  • InputNumberAccel

  • InputPasswordAccel

  • InputRadioAccel

  • InputSimpleListAccel

  • InputTextAccel

Method Sequences

The following tables show the possible sequence of calling the methods of the IBizTalkSerializerComponent interface, based on the following sample interchanges.

If you have an interchange with one document, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 0.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with one group, with one document in the group, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 1.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence (this assumes support of batching):

Method | Return
Init | The numdocs parameter is set to 3.
AddDocument | The handle parameter is set to 0.
AddDocument | The handle parameter is set to 1.
AddDocument | The handle parameter is set to 2.
GetInterchangeInfo | The numGroups parameter is set to 2.
GetGroupInfo | The numdocs parameter is set to 2.
GetDocInfo | The handle parameter is set to 1.
GetDocInfo | The handle parameter is set to 0.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The handle parameter is set to 2.

Related Topics

Serializers

Supporting the Tracking Database with Parser and Serializer Components


Registering Custom Components

To use a custom component in BizTalk Server 2002, the component must be registered with the category IDs for all pipeline components and for the specific type of pipeline component.

Register the component as an out-of-process component to provide better isolation. A component can be registered as an in process (inproc) component to increase its performance. However, an inproc component that fails to respond during an error condition might cause BizTalk Server to fail. Therefore, a component should be thoroughly tested before registering it as an inproc component.

Note

  • An out-of-process component registered as a COM+ application must be configured to run in an identity other than the interactive user. For more information about Component Services and COM+, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to Component Services in the Platform SDK.

BizTalk Server category identifiers

Custom components that are used in BizTalk Server must be associated with one or more category identifiers (CATID). The following table shows the category identifiers defined by BizTalk Server.

CATID | GUID | Description
CATID_BIZTALK_ AIC | BD193E1D-D7DC-4B7C-B9D2-92AE0344C836 | Identifies the component as an application integration component (AIC).
CATID_BIZTALK_ COMPONENT | 5C6C30E7-C66D-40E3-889D-08C5C3099E52 | Identifies the component as a BizTalk Server component. All components that are used with BizTalk Server must implement this category identifier.
CATID_BIZTALK_ CUSTOM_PROCESS | 20E8080F-F624-4401-A203-9D99CF18A6D9 | Identifies the component as a custom preprocessor for a receive function.
CATID_BIZTALK_ IDocSpecExtension | 711E279C-DE24-11D2-974B-00C04F680FE7 | Identifies the component as an extension module for importing XML documents.
CATID_BIZTALK_ MapEditFunctoids | 2560F3BF-DB47-11D2-B3AE-00C04F72D6C1 | Identifies the component as a custom functoid that is displayed in the functoid palette.
CATID_BIZTALK_ PARSER | C0DCDF4E-692C-11D2-89E7-00C04F79DBAA | Identifies the component as a parser that is used to process inbound documents.
CATID_BIZTALK_ SERIALIZER | AFCC065F-E0A6-47A6-B0A8-ECAA2FEEE2F4 | Identifies the component as a serializer that is used to process outbound documents.

Assigning affinity

Each component must be associated with two category IDs. One category ID marks the component as a BizTalk Server component. A component so marked appears in a list of components in the BizTalk Server administration console. The second category ID indicates the type or purpose of the component. This second association is called affinity, which allows BizTalk Server to determine the context in which the component can be used. For example, only those components whose affinity is registered as an application integration component (AIC) appear in the list of available components when an AIC transport type has been selected in BizTalk Messaging Manager.

To register affinity for an AIC created with Microsoft Visual C++® using ATL, include the following code in your header file:

#include "bts_sdk_guids.h"

// Implement the Component and AIC Category IDs (CATID)

BEGIN_CATEGORY_MAP(AIC_ClassName)

IMPLEMENTED_CATEGORY(CATID_BIZTALK_COMPONENT)

IMPLEMENTED_CATEGORY(CATID_BIZTALK_AIC)

END_CATEGORY_MAP()

To register affinity for an AIC created with Microsoft Visual Basic:

  1. After registering your component using Regsvr32.exe, search the registry for the CLSID of your AIC under the following key:

    HKEY_CLASSES_ROOT\CLSID

  2. Expand the Implemented Categories key of your AIC.

  3. Add two new keys with the following names:

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{5C6C30E7-C66D-40e3-889D-08C5C3099E52}

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{BD193E1D-D7DC-4b7c-B9D2-92AE0344C836}

These GUIDs can be found in bts_sdk_guids.h in the Program Files\Microsoft BizTalk Server\SDK\Include folder. The first key shown in step 3 above identifies the AIC as a BizTalk Server component (CATID_BIZTALK_COMPONENT). The second key shown in step 3 above identifies the component as an AIC (CATID_BIZTALK_AIC).

Testing affinity

To test affinity, use BizTalk Messaging Manager to create a port that uses the AIC. For more information, see Select an application integration component.

Related Topics

IFunctoid Interface

ISchemaImporter Interface

IBTSCustomProcess

Parsers

Serializers


Handling Data Passed to AICs

The proper method for handling data returned by an application integration component (AIC) depends on several factors, including programming language, the characteristics of the channel being used, and the document being passed.

For an AIC written in Visual Basic, you receive a buffer that contains Unicode characters, ANSI characters, or bytes.

The Direct Integration sample contains an ATL component that unpacks binary buffers returned as BSTR data. The component defines and implements the IConvertBstr interface, which defines a single method called Convert:

HRESULT Convert([in] BSTR bstrData, [out,retval] VARIANT* psaData);

When a buffer is passed as a BSTR to this method, the component creates a safe array of characters. The size of the array is the size of the buffer passed in the BSTR. A simple operation of memory copying helps translate the BSTR data to a safe array. Convert can be used by an AIC to convert the data to a format that can be iterated, as shown in the following code:

STDMETHODIMP CConvertBstr::Convert(BSTR bstrData, VARIANT *psaData) {

HRESULT hr = S_OK;

SAFEARRAY *psa = NULL;

BYTE HUGEP*psaBuffer = NULL;

SAFEARRAYBOUND rgsaBound[1];

UINT nDataLength = 0;

Determine if the arguments passed to Convert are valid, as shown in the following code:

if (!psaData || !bstrData)

return E_FAIL;

Clear the variant data type, as shown in the following code:

hr = VariantClear(psaData);

if (FAILED(hr))

return hr;

The client code must initialize the variant. Then, retrieve the length of the allocated BSTR, in bytes, as shown in the following code:

nDataLength = SysStringByteLen(bstrData);

At this point, construct a SAFEARRAY that will contain the bytes from the input BSTR data type, as shown in the following code:

rgsaBound[0].lLbound = 0;

rgsaBound[0].cElements = (ULONG)nDataLength;

psa = SafeArrayCreate(VT_UI1, 1, rgsaBound) ;

if (!psa)

return E_FAIL;

SafeArrayAccessData(psa, (void HUGEP**) &psaBuffer);

memcpy(psaBuffer, bstrData, nDataLength);

SafeArrayUnaccessData(psa);

Finally, return the SAFEARRAY through the output parameter, as shown in the following code:

V_VT(psaData) = VT_ARRAY | VT_UI1;

V_ARRAY(psaData) = psa;

return hr;

}

In addition, all pipeline AICs receive an IDictionary object, containing a set of fields. Every IDictionary object contains a working_data field. Several other fields could be present, including the following string values supplied by the server for all AICs:

  • Src_ID_Type: The type of identifier used for the source organization.

  • Src_ID_Value: The value of the source organization identifier.

  • Dest_ID_Type: The type of identifier used for the destination organization.

  • Dest_ID_Value: The value of the destination organization identifier.

  • Document_Name: The name of the input document definition.

  • Tracking_ID: A key value that is based on the globally unique identifier (GUID) and used for tracking.

  • Src_Filename: The name of the source document.

  • Src_Filepath: The file path of the source document.

  • Out_Codepage: The codepage used by the component to interpret the BSTR data.

Related Topics

Supporting the Tracking Database with Parser and Serializer Components

Execute Method


Supporting the Tracking Database with Parser and Serializer Components

When creating a custom parser or serializer, you might want your component to support the BizTalk Server Tracking database. To accomplish this, the component must use the IDictionary interface to add key/value pairs into the database.

Interchange table

The following table contains the list of keys that can be used to support the Tracking database from the interchange level with a custom component. The table used in the database is dta_interchange_details.

Dictionary key | Inbound or outbound | Column logged in Tracking database | Description
Src_ID_Type | Both | *nvcSrcAliasQualifier | This is the qualifier for the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Src_ID_Value | Both | *nvcSrcAliasId | This contains the value of the qualifier of the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Src_ID_App | Inbound | nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Dest_ID_Type | Both | *nvcDestAliasQualifier | This is the qualifier for the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Dest_ID_Value | Both | *nvcDestAliasId | This contains the value of the qualifier of the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Dest_ID_App | Inbound | nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_id | Inbound | nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_version | Inbound | nvcVersion | This is the version of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Out_Src_ID_App | Outbound | *nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
Out_Dest_ID_App | Outbound | *nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_id | Outbound | *nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. The serializer usually generates this unique value. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_version | Outbound | *nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.

Note

  • The columns of the dta_interchange_details table marked with an asterisk (*) are used for receipt correlation.

Group table

The following table contains the list of keys that can be used to support the Tracking database from the group level with a custom component. The table used in the database is dta_group_details. This table applies to both inbound and outbound documents.

Dictionary key | Column logged in Tracking database | Description
group_id | *nvcControlID | This is the unique control number of a group instance within an EDI interchange. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. For outbound document processing, the serializer usually generates this value.
functional_identifier | *nvcFunctionalGroupID | This is the code for the type of documents in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
application_sender_code | *nvcSrcAppName | This is the group level identifier for the source application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
application_receiver_code | *nvcDestAppName | This is the group level identifier for the destination application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
standards_version | *nvcVersion | This is the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.
standards_release | *nvcRelease | This is the release of the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.

Note

The columns of the dta_group_details table marked with an asterisk (*) are used for receipt correlation.

Inbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_indoc_details. This table applies to inbound documents only.

Dictionary key | Column logged in Tracking database | Description
doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_version | nvcVersion | This is the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_release | nvcRelease | This is the release of the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
doc_type | nvcDocType | This is the document type or transaction set identifier. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.

Outbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_outdoc_details. This table applies to outbound documents only.

Dictionary key | Column logged in Tracking database | Description
out_doc_doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_syntax | nvcSyntax | This is the code for document syntax, such as XML, X12, EDIFACT, H7, and so on. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_standards_version | nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
out_doc_standards_release | nvcRelease | This is the release of the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
out_doc_doc_type | nvcDocType | This is the document type or transaction set identifier. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
Tracking_ID | uidTrackingGUID | This is the tracking identifier of the document for which a receipt is generated.

Note

  • The Tracking_ID key is used when calling the AckDocument method.

Interchange and document tables

The following table contains the list of keys that can be used to support the Tracking database from the interchange and document level with a custom component. The table used in the database for interchange data is dta_interchange_data. The table used in the database for document data is dta_document_data.

Dictionary key | Inbound or outbound | Column logged in Tracking database | Description
in_codepage | Inbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the parser sets the value with this dictionary key, the value is logged in the data record related to the inbound interchange/document in the Tracking database.
out_codepage | Outbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the serializer sets the value with this dictionary key, the value is logged in the data record related to the outbound interchange/document in the Tracking database.

Related Topic

Understanding the Tracking Database Schema


BizTalk Orchestration Services

The interfaces in this section provide access to XLANG Scheduler System Managers, XLANG group managers, XLANG schedule instances, and XLANG ports.

The XLANG Scheduler System Manager provides moniker resolution and maintains a collection of group managers. A group manager runs in every COM+ application that has been designated as an XLANG schedule host, and maintains a collection of XLANG schedule instances. An XLANG schedule instance represents a running XLANG schedule that can be queried for information, such as the schedule's completion status. For XLANG schedules with a COM-bound port, a proxy object can be used to obtain a reference to the interface specified in the port binding.

  • For help with specific tasks, see Using Orchestration Services.

  • For general background information, see Understanding Orchestration Services.

  • For information about COM interfaces and error messages, see the Orchestration Services Reference.

Related Topic

Moniker Syntax


Understanding Orchestration Services

This section provides detailed conceptual information that is important to understanding how to access and work with BizTalk Orchestration Services. The following topics are covered in this section:

  • XLANG Interfaces

  • XLANG Schedule Correlation

The interfaces described in this section provide access to XLANG Scheduler System Managers, XLANG group managers, XLANG schedule instances, and XLANG ports.


XLANG Interfaces

The XLANG Scheduler System Manager provides moniker resolution and maintains a collection of group managers. A group manager runs in every COM+ application that has been designated as an XLANG schedule host, and maintains a collection of XLANG schedule instances. An XLANG schedule instance represents a running XLANG schedule that can be queried for information, such as the schedule's completion status. For XLANG schedules with a COM-bound port, a proxy object can be used to obtain a reference to the interface specified in the port binding.

The following illustration shows the relationship between the XLANG interfaces covered in this section, and the corresponding monikers.

XLANG Scheduler interfaces

The following XLANG schedule interfaces are available:

Administrator interfaces:

  • IWFGroupAdmin

  • IWFSystemAdmin

Schedule instance interfaces:

  • IWFProxy

  • IWFWorkflowInstance


XLANG Schedule Correlation

XLANG schedule correlation enables you to use a single message queue shared across multiple XLANG schedule instances, allowing incoming messages on that queue to be correlated to the correct running XLANG schedule instance. Src_XLANG_InstanceID and Dest_XLANG_InstanceID are dictionary keys created to take advantage of XLANG schedule correlation. The XLANG Scheduler Engine supports the ability to set the globally unique identifier (GUID) assigned to the schedule instance, or InstanceID, as the message label on received Message Queuing messages. These keys are provided by BizTalk Messaging Services to supply a simple mechanism to save and retrieve the data from the XLANG Scheduler Engine. By using these keys, you do not need to write code to retrieve and look up the InstanceIDs in the XLANG schedule, and you can leverage the existing BizTalk Messaging transports.

The Src_XLANG_InstanceID dictionary key appears on messages that originate from the BizTalk Messaging binding in an XLANG schedule instance, as long as the message is declared to send the InstanceID. This information can be used by a component in the messaging port to store the InstanceID to a custom database with a business-level correlation ID.

When a response message is received for a business interaction, the messaging port bound to the running XLANG schedule instance must contain the InstanceID in order to send the data to the correct running XLANG schedule instance. To do this, the Dest_XLANG_InstanceID key is extracted by BizTalk Messaging Services and placed on the Message Queuing label for the receiving queue. The key is set by custom pipeline components that look up the XLANG schedule InstanceID based on the business-level correlation ID.

Note

  • The tracking dictionary does not use these keys and they are not defined in a database table. To capture the correlation state, you need to implement a custom database.

For more information, run the E-Procurement Sample, which demonstrates the XLANG schedule correlation feature.

Related Topic

Instance Management


Using Orchestration Services

This section provides task-specific information about how to use BizTalk Orchestration Services. It is highly recommended that you review the Understanding Orchestration Services topic as well.

The following topics are covered in this section:

  • Activating an XLANG Schedule Instance

  • Accessing a Running XLANG Schedule Instance

  • Accessing the XLANG Scheduler System Manager

  • Accessing Group Managers


Activating an XLANG Schedule Instance

Use IWFProxy to obtain a schedule instance. If IWFProxy is used on a non-COM port binding, an error is returned.

A reference to IWFProxy can be obtained from:

  • The Port property available on the IWFWorkflowInstance interface.

  • An XLANG schedule moniker that specifies the port name.

The following Microsoft Visual Basic code sample shows how to activate an XLANG schedule on the local computer by using a moniker, and obtain a reference to the named port on that XLANG schedule instance.

Dim oPort As Object

Set oPort = GetObject("sked:///C:\schedules\test.skx/PortA")

At this point, the oPort variable contains a reference to the COM object bound in PortA of the schedule instance.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.


Accessing a Running XLANG Schedule Instance

Use IWFWorkflowInstance to gather information about a specific running schedule instance.

A reference to IWFWorkflowInstance can be obtained from:

  • The WorkflowInstance property available on the IWFProxy interface.

  • The collection of IWFWorkflowInstance objects returned by the IWFGroupAdmin object.

  • An XLANG schedule moniker.

The following Microsoft Visual Basic code sample shows how to instantiate an XLANG schedule on the local computer and obtain a reference to that schedule instance.

Dim oWFI As IWFWorkflowInstance

Set oWFI = GetObject("sked:///C:\schedules\test.skx")

To obtain a reference to all currently running schedule instances in a group manager, you can access the collection of IWFWorkflowInstance objects contained by the IWFGroupAdmin object. The following Microsoft Visual Basic code displays the fully qualified name of each schedule instance running in the default XLANG Scheduler Group Manager.

Dim oGM As IWFGroupAdmin

Dim oWFI As IWFWorkflowInstance

Set oGM = GetObject("sked://!XLANG Scheduler")

For Each oWFI In oGM

MsgBox ("XLANG Schedule: " + oWFI.FullyQualifiedName)

Next

When using multiple group managers, you can determine the group manager associated with any schedule instance by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFWorkflowInstance object.

  2. Parse the group manager name out of the moniker string returned.

    This is the portion that begins with an exclamation point (!) and ends with a slash (/).

  3. Obtain a reference to the IWFGroupAdmin object using a moniker created with the group manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Notes

  • When using C++, the COM CoGetObject function is used in place of GetObject.

  • When accessing this object in Microsoft Visual Basic, you must declare your object variable with the appropriate type information rather than using the Object type. For example:

Dim myInstance As IWFWorkflowInstance


Accessing the XLANG Scheduler System Manager

Use IWFSystemAdmin to start, stop, and retrieve information about the group managers.

To obtain a reference to this object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the XLANG Scheduler System Manager on the local computer.

Dim oSM As SysMgr

Set oSM = GetObject("sked://")

This object also enumerates a collection of the IWFGroupAdmin objects that represent the group managers associated with this XLANG Scheduler System Manager.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.


Accessing Group Managers

To obtain a reference to an IWFGroupAdmin object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the default XLANG Scheduler Group Manager on the local computer.

Dim oGM As IWFGroupAdmin

Set oGM = GetObject("sked://!XLANG Scheduler")

To obtain a reference to other group managers, replace "XLANG Scheduler" with the name of the COM+ application that has been designated as an XLANG Scheduler Engine host or group manager. You can determine whether a COM+ application is a group manager by using the IsWorkflowHost method on IWFSystemAdmin.

You can also obtain a reference to all group managers associated with the XLANG Scheduler System Manager through the collection of IWFGroupAdmin objects contained by the SysMgr object. The following Microsoft Visual Basic code displays the fully qualified name of each group manager.

Dim oSM As SysMgr

Dim oGM As IWFGroupAdmin

Set oSM = GetObject("sked://")

For Each oGM In oSM

MsgBox ("Group Manager: " + oGM.FullyQualifiedName)

Next

The IWFGroupAdmin object also enumerates a collection of the IWFWorkflowInstance objects that represent currently running schedule instances for this group manager.

You can determine the XLANG Scheduler System Manager associated with any group manager by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFGroupAdmin object.

  2. Parse the XLANG Scheduler System Manager name out of the moniker string returned.

    This is the portion between the sked:// prefix and the exclamation point (!).

  3. Obtain a reference to the IWFSystemAdmin object using a moniker created with the XLANG Scheduler System Manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.


BizTalk Managing and Monitoring

Windows Management Instrumentation (WMI) is a data-management layer included in Microsoft® Windows® 2000. Microsoft BizTalk™ Server 2002 uses the WMI layer to encapsulate administrative functions that support the management of systems in an enterprise.

  • For help with specific tasks, see Using Managing and Monitoring.

  • For general background information, see Understanding Managing and Monitoring.

  • For information about COM interfaces, see the Managing and Monitoring Reference.

This section contains sample code in Microsoft Visual Basic® and Visual Basic Script.


Understanding Managing and Monitoring

When you use the BizTalk Server Administration Microsoft Management Console (MMC) snap-in (the administration console) to change group, server, queue, and database management settings, the new values are stored in the BizTalk Messaging Management database through the BizTalk Server WMI provider. In BizTalk Server 2002, this WMI provider uses a Microsoft® SQL Server™ database to store administrative objects. All timestamps are created by using the local time on the computer that is running SQL Server. However, the WMI provider refers to all timestamps in coordinated universal time (UTC). The administration console then converts the timestamps back to local time for display.

The WMI provider acts as an intermediary between WMI and the administration console MMC snap-in. The WMI provider gathers information from a resource (managed object) and makes it available to management applications through the WMI API.

The BizTalk Server schema classes are registered and defined by using Managed Object Format (MOF), which is a compiled language based on the Interface Definition Language (IDL). You place this information in an .mof file that you submit to the MOF compiler, Mofcomp.exe.

This section contains the following topics:

  • BizTalk Server Namespace

  • BizTalk Server Provider and Registration

  • Custom Counters

The MOF code examples in the following topics are taken from the InterchangeProvSchema.mof file found in the \Program Files\Microsoft BizTalk Server\Setup folder. This file, along with SrvEvents.mof, contains the BizTalk Server namespace, provider, provider registration, and schema class definitions.

To access the WMI database layer programmatically, see Managing and Monitoring Reference, which documents the BizTalk Server WMI schema classes that correspond to the Administration objects.


BizTalk Server Namespace

Every WMI namespace contains a set of system classes, including __NAMESPACE. A namespace groups a collection of classes into logical units. Every computer has a defined namespace at the top of the hierarchy called the Root namespace. The location of a namespace is described by a path.

In the following MOF code, "MicrosoftBizTalkServer" is specified as the value for the Name property of the __NAMESPACE system class for BizTalk Server:

#pragma namespace ("\\\\.\\Root")

instance of __Namespace

{

Name = "MicrosoftBizTalkServer";

}

BizTalk Server defines the "MicrosoftBizTalkServer" namespace as a sibling of the Root namespace, logically distinguishing the BizTalk Server–managed environment from other managed environments.


BizTalk Server Provider and Registration

When WMI receives a request from a BizTalk Server management application, it forwards the request to the WMI provider, "InterchangeProv." The WMI provider retrieves, modifies, deletes, and/or enumerates instances of the BizTalk Server schema classes.

"InterchangeProv" is a custom provider designed to interact with the managed objects in the BizTalk Server environment. For a complete reference of these managed objects and their properties and methods, see Managing and Monitoring Reference.

The BizTalk Server instance provider supports data retrieval, data modification, data deletion, data enumeration, and query processing.

For more information about how to author and interpret .mof files, see the article "Managed Object Format (MOF) Language," in the WMI SDK on the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp).

The BizTalk Server WMI classes are defined in text files by using the Managed Object Format (MOF). Note that each class has a key property qualifier. The key property qualifier tells you that any instance of that class (or any instance of a derived class) can be uniquely identified by the value of the key property qualifier. This is a concept borrowed from database technologies.

To access the functionality provided by WMI you call a set of DCOM interfaces, including IWbemClassObject and IWbemServices. These interfaces make it possible to write management applications that work with classes and instances that are managed by WMI.

In addition, you can access WMI from environments that support Automation objects through scripting objects that wrap the DCOM interfaces. For example, the SWbemObject class wraps the IWbemClassObject interface, and SWbemServices wraps IWbemServices. When using WMI with the BizTalk Server schema classes, you can get complete access to WMI through Microsoft Visual Basic or Visual Basic Scripting Edition (VBScript). Visual Basic projects can access these objects by adding Microsoft WMI Scripting V1.1 Library in the Reference dialog box.

The Component Object Model (COM) API is available directly to C/C++ programmers. You can use the Scripting API to develop script and applications based on Microsoft Visual Basic that you can use to view or control managed objects.

For a description of the interfaces in the WMI COM API, see the article "COM API for WMI," in the WMI SDK on the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp).

For a description of the interfaces in the Scripting API, see the article "Scripting API for WMI," in the WMI SDK on the MSDN Online Library Web site.


Custom Counters

Custom counters are WMI class instances based on custom queries of the Tracking database. After they are created, these custom counters can be consumed by user-defined rules in Microsoft Operations Manager 2000 (MOM).

This section contains the following topics:

  • Custom Counter Query Properties

  • Custom Counters Validation

To programmatically create, delete, and update custom counters, see Creating a Custom Counter Using WMI.

For information about using BizTalk Server 2002 together with MOM, see About Microsoft Operations Manager.

The BizTalk Server 2002 Management Pack module includes a sample custom counter performance processing rule called "Sample - Custom Counter." This sample executes the query defined in the WMI custom counter class to acquire the number of documents in the Tracking database.

Notes

  • Unless you want to construct a regular expression when working with custom counters, there are a list of characters that need special consideration:

    [ ], ^, %, _

    You should enclose these characters in [ ] braces. For example, the string "Org%ani^za_tio[n", should be replaced by "Org[%]ani[^]za[_]tio[[]n".

  • Only the following custom counter setting properties can accept regular expressions: DocType, DestOrgName, SrcOrgName, DestQualifier, DestQualifierValue, SrcQualifier, and SrcQualifierValue.


Custom Counter Query Properties

When you create a new custom counter class instance, you provide values for properties that determine the query executed by the custom counter.

Values for the following query properties can be specified, when creating an instance of the MSBTS_CustomCounterSetting class:

  • Custom Counter Name. Name of the new class instance being created.

  • Source Organization. Name of the organization that is the source for the channel through which the document is processed, as defined in the BizTalk Messaging Management configuration.

  • Source Qualifier. Qualifier for the source organization identifier for the channel through which the document is processed.

  • Source Value. Value for the source organization identifier for the channel through which the document is processed.

  • Destination Organization. Name of the organization that is the destination for the channel through which the document is processed, as defined in the BizTalk Messaging Management configuration.

  • Destination Qualifier. Qualifier for the destination organization identifier for the channel through which the document is processed.

  • Destination Value. Value for the organization identifier defined in the BizTalk Messaging Management configuration as the destination for the channel through which the document is processed.

  • Document Type. Name of the root element from the document schema.

  • Time Interval. Interval of time, in seconds, over which to accumulate the custom counter value.

  • BizTalk Server Group Name. Name of the BizTalk Server group against which the custom counter query is to be executed.

For an example of programmatically setting these properties, see Creating a Custom Counter Using WMI and the Custom Counters sample.

Notes

  • In BizTalk Server 2002, organizations can be assigned an identifier alias. Identifiers consist of a name, qualifier, and value. When creating an organization, a default qualifier of OrganizationName is used along with a user-assigned name string as the identifier value. You can then create additional organization identifiers for specific tracking or routing purposes.

  • When tracking documents during processing, BizTalk Server records the qualifier and value for each channel source and destination organization. When creating a new custom counter class instance, it is possible to specify just the source and destination organization name or a qualifier-value pair. However, organization names and qualifier-value pairs cannot be specified at the same time.

  • When only the source and/or destination organization name is provided, the custom counter will include all documents that were processed through channels with any of the identifiers for the specified organization. When qualifier-value pairs are provided, only the documents processed by channels configured with those qualifier-value pairs are included.

  • To count only documents whose processing channel(s) had only the default qualifier-value pair configured, the qualifier should be OrganizationName and the value should be the name of the organization.

  • Wild-card expressions can be used for the following arguments when creating a new custom-counter class instance:
    • Source Organization

    • Source Qualifier

    • Source Value

    • Destination Organization

    • Destination Qualifier

    • Destination Value

    • Document Type


Custom Counters Validation

Validation of custom counters is optional and is provided through the IsValid method on the custom counter setting class, MSBTS_CustomCounterSetting.


Using Managing and Monitoring

This section provides task-specific information about how to manage and monitor by using Microsoft BizTalk Server 2002. Topics illustrate how to create and manipulate the BizTalk Server Administration objects by using WMI. It is highly recommended that you review the Understanding Managing and Monitoring topic as well.

The following topics are covered:

  • Creating an Event Consumer Using WMI

  • Creating a Custom Counter Using WMI

  • Handling WMI Errors


Creating an Event Consumer Using WMI

WMI provides a powerful event architecture that enables modifications in management information to be identified, aggregated, and associated with other management information, which can then be forwarded to local or remote management applications. Event handling and notification is a key benefit provided by WMI that provides a mechanism for identifying and dealing with hardware or software events and errors.

After an event occurs, a notification is delivered to one or more registered recipients, knows as event consumers. Event consumers can register to receive certain types of notifications. Event consumers register to receive notifications without any knowledge of how events and notifications are provided. To register, event consumers specify a filter that is created by using the WMI Query Language (WQL). The query describes the conditions under which the consumer receives the event notification.

In addition to DCOM interfaces, WMI supports a uniform scripting application programming interface (API) that gives applications and scripts access to the WMI provider on either a local computer or a remote computer.

This section shows the basic steps necessary to write a temporary WMI event consumer with Microsoft Visual Basic script, although some of the associated DCOM interfaces are mentioned.

This section contains the following topics:

  • Declaring Variables

  • Connecting to the Microsoft BizTalk Server Namespace

  • Creating the Event Object

  • Monitoring Events

Note

  • If you have Health Monitor installed (either from Microsoft Application Center 2000 or Microsoft BackOffice® Server), you can configure Health Monitor through its Microsoft Management Console (MMC) user interface (UI) (or its WMI class) to consume events.


Declaring Variables

To write an event consumer using WMI, you will need to obtain a locator object, a services object, an event object, and an object to represent a WMI class instance.

First, declare the variables, as shown in the following code:

Dim wbemLocat

Dim wbemSrvcs

Dim wbemEvent

Dim wbemObject

The locator object variable, wbemLocat, of type SwbemLocator, is used to connect to WMI. To connect to the "MicrosoftBizTalkServer" namespace under the Root namespace (Root/MicrosoftBizTalkServer), you set the services object variable, wbemSrvcs, of type SWbemServices. The event object variable, wbemEvent, of type SwbemEventSource, is needed to execute a query to receive events. To retrieve an event from the event query, you set the wbemObject variable of type SwbemObject.


Connecting to the Microsoft BizTalk Server Namespace

After you declare the variables, you need to retrieve the locator object. If you are using the scripting API, create a WbemScripting.SwbemLocator object, as shown in the following code:

Set wbemLocat = CreateObject("WbemScripting.SWbemLocator")

Note that the first step for any application using WMI is to retrieve a locator object. If you are using the DCOM interfaces in C/C++, you would retrieve an IWBEMLocator pointer by using the COCreateInstance method with the CLSID_WbemLocator class identifier, as shown in the following code:

IWbemLocator* piWMI = NULL;
HRESULT hr;

    hr = CoCreateInstance(
        CLSID_WbemLocator,
        NULL,
        CLSCTX_INPROC_SERVER,
        IID_IWbemLocator,
        (LPVOID*) &piWMI
    );

Using the locator object and the ConnectServer method, you can request a connection to the WMI service. The following code attempts to connect to WMI by specifying the Root namespace on the local computer. In the following code, replace the string "ComputerName" with the name of the server that publishes the event:

Set wbemSrvcs = wbemLocat.ConnectServer("ComputerName", "root\MicrosoftBizTalkServer")

If Err.number is equal to 0, then the connection to the WMI namespace is established. Specify both the computer name and the namespace; otherwise, if these fields are left blank, you will be connected to the default namespace on the local computer.

The returned SWbemServices object provides a communication path to the SQL Server database that is used to store administrative objects.


Creating the Event Object

Now that you have connected to the "MicrosoftBizTalkServer" namespace, you need to create the event object. The following code generates an event object to receive event notifications:

Set wbemEvent = wbemSrvcs.ExecNotificationQuery("Select * from DocSuspendedEvent")

The filter used in the SWbemServices.ExecNotificationQuery method call is "Select * from DocSuspendedEvent", which is written using WQL. Like SQL queries, WQL queries can be refined to return a specific set of properties, or a subset of instances that satisfy some criteria.

When the consumer submits this query, it requests to be notified of all occurrences of the event represented by the DocSuspendedEvent class. This request includes a request for notification on all of the event's system and nonsystem properties. When the event provider submits the query, it registers support for generating notifications whenever an event represented by the DocSuspendedEvent class occurs.


Monitoring Events

Now that you have created the event object for the DocSuspendedEvent class, you need to set up the mechanism to monitor events represented by that class. First, set wbemObject of type SWbemObject to Empty, as shown in the following code:

wbemObject = Empty

Then, if an event is available, the SWbemEventSource.NextEvent method retrieves the event from an event query, as shown in the following code:

Set wbemObject = wbemEvent.NextEvent(Timeout)

The SWbemObject object supports generic properties and methods that apply to all WMI objects, as well as exposing the properties and methods of the object as dynamic automation properties and methods of this object.

Use the following code to retrieve the globally unique identifier (GUID) for the item in the suspended queue event:

EventSuspendedQueueWaitForEvent = wbemObject.Properties_.Item("stringSuspendedGuid").Value

If the wbemObject is not set to Empty, then the GUID for the item in the Suspended queue event is retrieved; otherwise; a time-out error occurs while waiting for the Suspended queue event.

Note that stringSuspendedGuid is a property of the DocSuspendedEvent class. The Properties_ property returns an SWbemPropertySet object that is a collection of the properties for the current class or instance, in this case the DocSuspendedEvent class. The Item method then retrieves an SWbemProperty from the collection, in this case the stringSuspendedGuid property.

For more information about WMI Application Programming in BizTalk Server, see Handling WMI Errors.


Creating a Custom Counter Using WMI

This section shows the basic steps necessary to create a custom counter using organizations, and to perform a Tracking database query.

This section contains the following topics:

  • Declaring Variables

  • Setting the Security Level

  • Setting the Query Properties

  • Creating or Updating the Custom Counter

  • Validating the Custom Counter

  • Executing the Custom Counter Query

The code examples in this section use Microsoft Windows Instrumentation (WMI) and Microsoft Visual Basic script.

For an example of how to create a custom counter using qualifier and value pairs instead of organizations, see the Custom Counters sample.


Declaring Variables

To write a custom counter using WMI, define the following constants:

Const wbemChangeFlagUpdateOnly = 1

Const wbemChangeFlagCreateOnly = 2

Const CUSTCOUNTER_SETTING_NAMESPACE = "MSBTS_CustomCounterSetting"

In addition, you will need to obtain a locator object, a services (or namespace) object, and objects to represent WMI class instances.

Declare the variables, as shown in the following code:

Dim WBEMLocator

Dim WBEMNameSpace

Dim objCustomCounterFactory

Dim objCustomCounterSetting

Dim objCustomCounter


Setting the Security Level

Before setting the security level, you need to connect to the "MicrosoftBizTalkServer" namespace under the Root namespace (Root/MicrosoftBizTalkServer), as shown in the following code:

Set WBEMLocator = CreateObject("WbemScripting.SWbemLocator")

Set WBEMNameSpace = WBEMLocator.ConnectServer(, "root/MicrosoftBizTalkServer")

Then, set the security level for the namespace, as show in the following code:

WBEMNameSpace = GetObject("Winmgmts:{impersonationlevel=impersonate}!root/" & "MicrosoftBizTalkServer")


Setting the Query Properties

Before setting the query properties, you need to create a new instance of a custom counter setting class, as shown in the following code:

Set objCustomCounterFactory = WBEMNameSpace.Get(CUSTCOUNTER_SETTING_NAMESPACE)

Set objCustomCounterSetting = objCustomCounterFactory.SpawnInstance_

After the call to SpawnInstance_, objCustomCounterSetting contains an instance of MSBTS_CustomCounterSetting. This class is used to create, delete, and update custom counters.

In this example, the custom counter query is based on the source and destination organizations. To set the query properties, set the properties of the MSBTS_CustomCounterSetting instance, as shown in the following code:

objCustomCounterSetting.Name = "My Custom Counter"

objCustomCounterSetting.SrcOrgName = "SourceOrg"

objCustomCounterSetting.DestOrgName = "DestinationOrg

objCustomCounterSetting.DocType = "PORequest"

objCustomCounterSetting.TimeInterval = 300

objCustomCounterSetting.GroupName = "BizTalk Server Group"

So, the custom counter will count the number of documents passing from the source organization ("SourceOrg") to the destination organization ("DestinationOrg") using a document schema with the root element "PORequest". Also, note that the custom counter will only query the Tracking database for document entries from the previous 300 seconds.


Creating or Updating the Custom Counter

After setting the query properties, you should create or update the custom counter setting.

To create the custom counter setting, specify the wbemChangeFlagCreateOnly flag, as shown in the following code:

objCustomCounterSetting.Put_(wbemChangeFlagCreateOnly)

To update the custom counter setting, specify the wbemChangeFlagUpdateOnly flag, as shown in the following code:

objCustomCounterSetting.Put_(wbemChangeFlagUpdateOnly)

Note

  • When calling the Put_ method to create or update the custom counter setting, the wbemChangeFlagCreateOrUpdate flag is not supported. Instead, you must specify either wbemChangeFlagCreateOnly or wbemChangeFlagUpdateOnly, depending on whether you want to create or update the custom counter setting.


Validating the Custom Counter

After setting the query properties and creating or updating the custom counter, you should validate your custom counter.

You can validate on the following properties:

  • Source Organization

  • Source Organization Identifier

  • Destination Organization

  • Destination Organization Identifier

  • BizTalk Server Group

Note

  • The document type is not validated, because the value of the document type is not always known until the actual document is received.

Validate the custom counter settings, as shown in the following code:

objCustomCounterSetting.IsValid bSrcOrg, bSrcOrgId, bDestOrg, bDestOrgId, bGroup

As an example, you can use a message box to ensure that your query properties are valid, as shown in the following code:

WScript.Echo "ValidityCheck: " & vbCrLf & _

"SrcOrg " & CStr(bSrcOrg) & vbCrLf & _

"SrcId " & CStr(bSrcOrgId) & vbCrLf & _

"DestOrg " & CStr(bDestOrg) & vbCrLf & _

"DestId " & CStr(bDestOrgId) & vbCrLf & _

"Group " & CStr(bGroup)


Executing the Custom Counter Query

To execute the custom counter query, you need to retrieve an instance on the MSBTS_CustomCounter class. Since both the custom counter setting Name property and the custom counter Name property are key properties and share the same value, you can use their Name properties to retrieve the custom counter object, as shown in the following code:

Set objCustomCounter = WBEMNameSpace.Get("MSBTS_CustomCounter.Name=""" & _

objCustomCounterSetting.Name & """")

After retrieving the custom counter object, you can query the MatchCount property to view the results of the query, as shown in the following code:

WScript.Echo "Counter Information: " & objCustomCounter.Name & vbCrLf & _

"Matching Documents: " & objCustomCounter.MatchCount


Handling WMI Errors

This section uses Microsoft Visual Basic code to illustrate how to determine whether a WMI method returns an error, and if so, how to decipher the meaning of the error.

First, you declare two variables: an SWbemLastError object to contain and manipulate error objects, and an array of String objects to contain the numerical value, parameter information, and text description of the error, as shown in the following code:

Dim objWMIError As SWbemLastError

Dim strError(0 To 2) As String

To determine whether WMI raises an error, check the Err object. If the Err object is not equal to 0, then an error has been raised. Then, you can try to set the SWbemLastError object to a new instance.

Note that the TypeName function is used to return information about the objWMIError variable. If it is equal to Nothing, error information is not available, and the attempt to create the error object has failed.

If the call succeeds and an error object returns, the status of the object is reset and the members of the string array are set to meaningful values, as shown in the following code:

If Err <> 0 Then

strError(0) = Hex(Err.Number)

Set objWMIError = New SwbemLastError

If TypeName(objWMIError) <> "Nothing" Then

strError(1) = objWMIError.ParameterInfo

strError(2) = objWMIError.Description

Else

Err.Clear

strError(1) = ""

strError(2) = ""

End If

Else

strError(0) = 0

strError(1) = ""

strError(2) = ""

End If


BizTalk Server Developer's Toolbox

This section uses Microsoft® Visual Basic®, C++, and Visual Basic script to provide a toolbox of solutions to common tasks encountered by BizTalk Server developers. These code examples are provided without robust error-handling functionality and should serve as an introduction to designing your own tools when working with BizTalk Server.

These code examples should not be used in a production environment.

This section contains the following topics:

  • BizTalk Messaging Services Tasks

  • BizTalk Orchestration Services Tasks

  • BizTalk Managing and Monitoring Tasks

  • Miscellaneous Tasks

Note that some of these solutions are not specific to BizTalk Server.


BizTalk Messaging Services Tasks

This section contains the following topics:

  • Clear BizTalk Messaging Configurations

  • Update Messaging Configurations with ADO Objects


Clear BizTalk Messaging Configurations

The following code clears the BizTalk Messaging Management database.

This example ClearBTMConfigurations method is written in Microsoft Visual Basic.

Sub ClearBTMConfigurations()

First, declare the variables, as shown in the following declaration:

    Dim Configuration, Obj, CurrObj, HomeOrgID

To delete all existing configurations, create a configuration object to access the messaging objects, as shown in the following code:

    Set Configuration = CreateObject("BizTalk.BizTalkConfig")

Then, loop through and delete all existing channels, as shown in the following code:

    Set Obj = Configuration.CreateChannel
    Set CurrObj = Configuration.Channels

    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing port groups, as shown in the following code:

    Set Obj = Configuration.CreatePortGroup
    Set CurrObj = Configuration.PortGroups
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing ports, as shown in the following code:

    Set Obj = Configuration.CreatePort
    Set CurrObj = Configuration.Ports
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing envelopes, as shown in the following code:

    Set Obj = Configuration.CreateEnvelope
    Set CurrObj = Configuration.Envelopes
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing document definitions, as shown in the following code:

    Set Obj = Configuration.CreateDocument
    Set CurrObj = Configuration.Documents
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing organizations, as shown in the following code:

    Set Obj = Configuration.CreateOrganization
    Set CurrObj = Configuration.Organizations
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)

Note the home (default) organization identifier, as shown in the following code:

        If Obj.IsDefault Then

Ensure that the home organization is not deleted and that it is saved for removing aliases, as shown in the following code.

            HomeOrgID = Obj.Handle
        ElseIf Obj.Name = "SEED Test Organization" Then

Do not perform any action at this point; only ensure that the SEED organization is not deleted.

        Else
            Obj.Remove
        End If

        CurrObj.MoveNext
    Wend

Clear the home organization aliases, except for the default alias and the alias with the organization name, as shown in the following code:

    Obj.load HomeOrgID
    Set CurrObj = Obj.Aliases

Then, reset the default alias, as shown in the following code:

    Obj.SaveAlias Obj.GetDefaultAlias, "sName" & Now(), False, "sQual" & Now(), "sValue" & Now()

    CurrObj.MoveFirst
    While Not CurrObj.EOF
        If CurrObj("qualifier") = "OrganizationName"  Then
            Obj.SaveAlias CurrObj(0), "Organization", True, "OrganizationName", Obj.Name
            Obj.Save
        Else

        If CurrObj("qualifier") <> "SMTP" then Obj.RemoveAlias CurrObj(0)
        End If

        CurrObj.MoveNext
    Wend

Loop through and delete all existing home organization applications, as shown in the following code:

    Set CurrObj = Obj.Applications
    While Not CurrObj.EOF
        Obj.RemoveApplication CurrObj("id")
        CurrObj.MoveNext
    Wend

    Obj.save

Finally, set all objects to Nothing to release memory back to the system, as shown in the following code:

    Set Obj = Nothing
    Set CurrObj = Nothing
    Set Configuration = Nothing
End Sub


Update Messaging Configurations with ADO Objects

The following code uses the Microsoft ActiveX® Data Objects (ADO) returned by the BizTalk Messaging Configuration object model to select a subset of existing channels, and to modify the configurations of those channels. In this sample, all existing channels using an input document definition name of "Invoice" will be selected, their RetryCount property will be updated to six retries, and their RetryInterval property will be set to ten minutes.

This example UpdateRetry method is written in Microsoft Visual Basic Scripting Edition (VBScript).

Sub UpdateRetry()

First, declare the variables, as shown in the following declaration:

    Dim objConfig
    Dim objChannel
    Dim objDoc
    Dim objADO

Then, create the channel and document objects, as shown in the following code:

    Set objConfig = CreateObject("BizTalk.BizTalkConfig")
    Set objChannel = objConfig.CreateChannel
    Set objDoc = objConfig.CreateDocument

Obtain a reference to the Channels recordset containing all existing channels in the BizTalk Messaging Management database, as shown in the following code:

    Set objADO = objConfig.Channels

Loop through all records in the recordset and load each channel by using the Handle provided in the first field of the record. Load the InputDocument associated with each channel to obtain the document definition name, and compare it to the string "Invoice" to select the appropriate records. When a record is selected, update the RetryCount and RetryInterval properties and Save the new channel configuration. This logic is shown in the following code:

    Do While NOT objADO.EOF
        objChannel.Load(objADO.Fields.Item(0))
        objDoc.Load(objChannel.InputDocument)
        If objDoc.Name = "Invoice" Then
            objChannel.RetryCount = 6
            objChannel.RetryInterval = 10
            objChannel.Save
        End If
        objADO.MoveNext
    Loop

Finally, set all objects to Nothing to release memory back to the system, as shown in the following code:

    Set objChannel = Nothing
    Set objConfig = Nothing
    Set objDoc = Nothing
    Set objADO = Nothing
End Sub


BizTalk Orchestration Services Tasks

This section contains the following topic:

  • Access a Messaging Port


Access a Messaging Port

The following code accesses a messaging port in an XLANG schedule instance:

This example is in Microsoft Visual Basic:

Dim oSked As IWFWorkflowInstance
Dim oPort

Set oSked = GetObject("sked://localhost/C:\temp\MySchedule.skx")
Set oPort = oSked.Port("PortIn")

This example is in VBScript:

Set oSked = GetObject("sked://localhost/C:\temp\MySchedule.skx")
Set oPort = oSked.Port("PortIn")


BizTalk Managing and Monitoring Tasks

This section contains the following topic:

  • WMI Tasks


WMI Tasks

To ensure that your Visual Basic projects can access the Windows® Management Instrumentation (WMI) objects used in the following topics, you need to add the Microsoft WMI Scripting V1.1 Library in the Reference dialog.

Then, you declare the following WMI locator and services variables:

Public g_objLocator As SWbemLocator
Public g_objService As SWbemServices

In addition, the following constants should be defined:

Public Const GROUP_NAMESPACE = "MicrosoftBizTalkServer_Group"
Public Const MGMT_NAMESPACE = "MicrosoftBizTalkServer_MgmtDB"
Public Const SERVER_NAMESPACE = "MicrosoftBizTalkServer_Server"
Public Const RECVSVC_NAMESPACE = "MicrosoftBizTalkServer_ReceiveFunction"
Public Const QUEUE_NAMESPACE = "MicrosoftBizTalkServer_Queue"
Public Const WORKQ_NAMESPACE = "MicrosoftBizTalkServer_WorkQueue"
Public Const SCHEDULEDQ_NAMESPACE = "MicrosoftBizTalkServer_ScheduledQueue"
Public Const RETRYQ_NAMESPACE = "MicrosoftBizTalkServer_RetryQueue"
Public Const SUSPENDEDQ_NAMESPACE = "MicrosoftBizTalkServer_SuspendedQueue"

You make the connection to WMI with the following code:

Set g_objLocator = New SWbemLocator
Set g_objService = g_objLocator.ConnectServer(, "root/MicrosoftBizTalkServer")

This section contains the following topics:

  • Documents and WMI

  • Groups and WMI

  • BizTalk Messaging Management Database and WMI

  • Receive Services and WMI

  • Servers and WMI

  • Queues and WMI


Documents and WMI

The code examples in this section are useful when working with documents and interchanges. An interchange is a collection of one or more document instances that makes up a single transmission.

This section presents functions that work together to convert variant data from a document or interchange into a string.

This section contains the following topic:

  • Displaying the Contents of a Document or an Interchange


Displaying the Contents of a Document or an Interchange

When you use the ViewDocument or ViewInterchange methods of the MicrosoftBizTalkServer_SuspendedQueue class, you might need to convert the returned byte array into a readable format.

The following function takes a code page and variant data and returns a string:

Function ConvertViewDocument(ByVal varData As Variant, ByVal codepage As Long) As String
    Dim varData2() As Byte
    Dim i As Long
    Dim strTemp As String
    Dim Dom As New DOMDocument

    On Error Resume Next
    ReDim varData2(UBound(varData))
    For i = LBound(varData) To UBound(varData)
        varData2(i) = varData(i)
        Next

    If codepage = -1 Then
        strTemp = CStr(varData2)
        Call Dom.loadXML(strTemp)
        If Err <> 0 Then
            ConvertViewDocument = ""
        ElseIf Dom.parseError.errorCode <> 0 Then
            ConvertViewDocument = ""
        Else
            ConvertViewDocument = Dom.xml
        End If
    Else
        ConvertViewDocument = ConvertVarToBstr(varData2, codepage)
    End If
End Function

The ConvertViewDocument function uses the following function to convert the variant data into a string:

Public Function ConvertVarToBstr(ByRef varData As Variant, ByVal strCodePage As String) As String
    Dim stm As New ADODB.Stream

    Select Case UCase(TypeName(varData))
        Case "STRING"
            ConvertVarToBstr = varData
        Case "BYTE()"
            stm.Type = adTypeBinary
            stm.Open
            stm.Write varData
            stm.Position = 0
            stm.Type = adTypeText
            stm.Charset = GetCharset(strCodePage)
            ConvertVarToBstr = stm.ReadText
            .Close
        Case Else
            ConvertVarToBstr = ""
    End Select
End Function

The ConvertVarToBstr function uses the following private function to return a character set:

Private Function GetCharset(ByVal codepage As String)
    Select Case codepage
        Case 932
            GetCharset = "shift-jis"
        Case 1252
            GetCharset = "us-ascii"
        Case 160001
            GetCharset = "utf-8"
        Case 1200
            GetCharset = "unicode"
    End Select
End Function


Groups and WMI

The code examples in this section are useful when working with groups. Server groups are collections of individual servers that are centrally managed, configured, and monitored.

This section presents functions that create a group, delete a group, retrieve a group by name, and retrieve all groups.

This section contains the following topics:

  • Creating a Group

  • Deleting a Group

  • Retrieving a Group by Name

  • Retrieving All Groups


Creating a Group

The following function creates a group:

Public Function CreateGroup(ByVal strGroupName As String, _
                ByVal strDocTrackDbLogon As String, _
                ByVal strDocTrackDbName As String, _
                ByVal strDocTrackDbPassword As String, _
                ByVal strDocTrackDbServer As String, _
                ByVal strQueueDbLogon As String, _
                ByVal strQueueDbName As String, _
                ByVal strQueueDbPassword As String, _
                ByVal strQueueDbServer As String, _
                Optional ByVal lAdminCacheRefreshInterval As Long, _
                Optional ByVal strSMTPHost As String, _
                Optional ByVal strReliableMessagingReplyToURL As String, _
                Optional UseProxyServer As Boolean, _
                Optional strProxyName As String, _
                Optional lProxyport As Long, _
                Optional lLoggingPointState As Integer) As Boolean
    Dim objBTGroup As SWbemObject
    Dim objBTGroupInstance As SWbemObject

    On Error Resume Next
    Set objBTGroup = g_objService.Get(GROUP_NAMESPACE)
    Set objBTGroupInstance = objBTGroup.SpawnInstance_

    CreateGroup = True

    objBTGroupInstance.Name = strGroupName
    objBTGroupInstance.DocTrackDbLogon = strDocTrackDbLogon
    objBTGroupInstance.DocTrackDbName = strDocTrackDbName
    objBTGroupInstance.DocTrackDbPassword = strDocTrackDbPassword
    objBTGroupInstance.DocTrackDbServer = strDocTrackDbServer
    objBTGroupInstance.QueueDbLogon = strQueueDbLogon
    objBTGroupInstance.QueueDbName = strQueueDbName
    objBTGroupInstance.QueueDbPassword = strQueueDbPassword
    objBTGroupInstance.QueueDbServer = strQueueDbServer

    If strReliableMessagingReplyToURL <> "" Then
        objBTGroupInstance.ReliableMessagingReplyToURL = strReliableMessagingReplyToURL
    End If
    If lAdminCacheRefreshInterval <> 0 Then
        objBTGroupInstance.ConfigurationCacheRefreshInterval = lAdminCacheRefreshInterval
    End If

    objBTGroupInstance.UseProxyServer = UseProxyServer
    objBTGroupInstance.ProxyHost = strProxyName

    If lProxyport = 0 Then
        objBTGroupInstance.ProxyPort = lProxyport
    Else
        objBTGroupInstance.ProxyPort = lProxyport
    End If

    objBTGroupInstance.LoggingPointState = lLoggingPointState
    objBTGroupInstance.SMTPHost = strSMTPHost
    objBTGroupInstance.Put_ (wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateGroup = False
    End If
End Function


Deleting a Group

The following function deletes a group:

Public Function DeleteGroup(ByVal strGroupName As String) As Boolean
    On Error Resume Next
    DeleteGroup = True
    Call g_objService.Delete(GROUP_NAMESPACE & ".NAME=""" & strGroupName & """")

    If Err <> 0 Then
        DeleteGroup = False
    End If
End Function


Retrieving a Group by Name

The following function retrieves a group by name:

Public Function GetGroupByName(ByVal strGroupName As String) As Object
    Dim objBTGroup As SwbemObject

    On Error Resume Next
    Set GetGroupByName = Nothing
    Set GetGroupByName = g_objService.Get(GROUP_NAMESPACE & ".NAME=""" & strGroupName & """")

    If Err <> 0 Then
    End If
End Function


Retrieving All Groups

The following function retrieves all groups:

Public Function GetAllGroups() As SWbemObjectSet
    Dim objBTGroup As SWbemObject

    On Error Resume Next
    Set GetAllGroups = Nothing
    Set objBTGroup = g_objService.Get(GROUP_NAMESPACE)
    Set GetAllGroups = objBTGroup.Instances_

    If Err <> 0 Then
    End If
End Function


BizTalk Messaging Management Database and WMI

The code examples in this section are useful when working with the BizTalk Messaging Management database. The BizTalk Messaging Management database stores information for all server configurations, including group and server settings, and receive functions.

This section presents functions that create the BizTalk Messaging Management database and retrieve the BizTalk Messaging Management database.

This section contains the following topics:

  • Creating the BizTalk Messaging Management Database

  • Retrieving the BizTalk Messaging Management Database


Creating the BizTalk Messaging Management Database

The following function creates the BizTalk Messaging Management database:

Public Function CreateMgmtDB(ByVal strMgmtDbLogon As String, _
                            ByVal strMgmtDBPassword As String, _
                            ByVal strMgmtDBServer As String, _
                            ByVal strMgmtDBDatabase As String, _
                            ByVal strLocalServer As String) As Boolean
    Dim objBTSMgmt As SWbemObject
    Dim objBTSMgmtInstance As SwbemObject

    On Error Resume Next
    CreateMgmtDB = True
    Set objBTSMgmt = g_objService.Get(GROUP_NAMESPACE)
    Set objBTSMgmtInstance = objBTGroup.SpawnInstance_
        objBTSMgmtInstance.MgmtDbLogon = strMgmtDbLogon
        objBTSMgmtInstance.MgmtDBPassword = strMgmtDBPassword
        objBTSMgmtInstance.MgmtDbServer = strMgmtDBServer
        objBTSMgmtInstance.MgmtDbDatabase = strMgmtDBDatabase
        objBTSMgmtInstance.localserver = strLocalServer
        objBTSMgmtInstance.Put_ (wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateMgmtDB = False
    End If
End Function


Retrieving the BizTalk Messaging Management Database

The following function retrieves the BizTalk Messaging Management database:

Public Function GetMgmtDB(ByVal strLocalServer As String) As SWbemObject
    Dim objBTSMgmt As SWbemObject
    Dim objSet_BTSMgmt As SWbemObjectSet
    Dim objBTSMgmtInstance As SWbemObject

    On Error Resume Next
    Set GetMgmtDB = Nothing
    Set objBTSMgmt = g_objService.Get(MGMT_NAMESPACE)
    Set objSet_BTSMgmt = objBTSMgmt.Instances_

    If objSet_BTSMgmt.Count <> 1 Then
        Exit Function
    End If

    Set GetMgmtDB = objSet_BTSMgmt.Item(MGMT_NAMESPACE & ".LocalServer=""" & strLocalServer & """")
End Function


Receive Services and WMI

The code examples in the section are useful when working with receive services. You create receive services to process data.

This section presents functions that create a File receive service, delete a File receive service, retrieve a receive service by name, retrieve all receive services, and retrieve all receive services by group.

This section contains the following topics:

  • Creating a File Receive Service

  • Deleting a File Receive Service

  • Retrieving a Receive Service by Name

  • Retrieving All Receive Services

  • Retrieving All Receive Services by Group


Creating a File Receive Service

The following function creates a File receive service:

Public Function CreateReceiveService(ByVal strRecvSvcName As String, _
                        ByVal strGroupName As String, _
                        ByVal strProcessingServer As String, _
                        ByVal strFileMask As String, _
                        ByVal fProtocolType As ProtocolType, _
                        ByVal strPollingLoc As String, _
                        Optional ByVal strPassword As String, _
                        Optional ByVal strUsername As String, _
                        Optional ByVal strDocumentName As String, _
                        Optional ByVal strSourceID As String, _
                        Optional ByVal strSourceQualifier As String, _
                        Optional ByVal strDestinationID As String, _
                        Optional ByVal strDestinationQualifier As String, _
                        Optional ByVal lOpenness As Integer, _
                        Optional ByVal lPassthrough As Integer, _
                        Optional ByVal strChannelName As String, _
                        Optional fDisabled As Boolean, _
                        Optional ByVal strEnvelopeName As String, _
                        Optional ByVal strComment As String, _
                        Optional ByVal strPreProcessor As String) As Boolean
    Dim objBTSRecvSvc As SWbemObject
    Dim objBTSRecvSvcInstance As SWbemObject

    On Error Resume Next
    CreateReceiveService = True
    Set objBTSRecvSvc = g_objService.Get(RECVSVC_NAMESPACE)
    Set objBTSRecvSvcInstance = objBTSRecvSvc.SpawnInstance_

        objBTSRecvSvcInstance.Name = strRecvSvcName
        objBTSRecvSvcInstance.groupName = strGroupName
        objBTSRecvSvcInstance.Comment = strComment
        objBTSRecvSvcInstance.FilenameMask = strFileMask
        objBTSRecvSvcInstance.ProcessingServer = strProcessingServer
        objBTSRecvSvcInstance.ProtocolType = fProtocolType
        objBTSRecvSvcInstance.PollingLocation = strPollingLoc
        objBTSRecvSvcInstance.password = strPassword
        objBTSRecvSvcInstance.UserName = strUsername
        objBTSRecvSvcInstance.DocumentName = strDocumentName
        objBTSRecvSvcInstance.SourceID = strSourceID
        objBTSRecvSvcInstance.SourceQualifier = strSourceQualifier
        objBTSRecvSvcInstance.DestinationID = strDestinationID
        objBTSRecvSvcInstance.DestinationQualifier = strDestinationQualifier
        objBTSRecvSvcInstance.EnvelopeName = strEnvelopeName
        objBTSRecvSvcInstance.DisableReceiveFunction = fDisabled
        objBTSRecvSvcInstance.PreProcessor = strPreProcessor

    If lOpenness <> 0 Then
        objBTSRecvSvcInstance.OpennessFlag = lOpenness
    End If

    If lPassthrough <> 0 Then
        objBTSRecvSvcInstance.IsPassThrough = lPassthrough
    End If

    If strChannelName <> "" Then
        objBTSRecvSvcInstance.ChannelName = strChannelName
    End If

        objBTSRecvSvcInstance.Put_ (wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateReceiveService = False
    End If
End Function


Deleting a File Receive Service

The following function deletes a File receive service:

Public Function DeleteReceiveSvc(ByVal strRecvSvcName As String) As Boolean
    On Error Resume Next
    DeleteReceiveSvc = True
    Call g_objService.Delete(RECVSVC_NAMESPACE & ".NAME=""" & strRecvSvcName & """")

    If Err <> 0 Then
        DeleteReceiveSvc = False
    End If
End Function


Retrieving a Receive Service by Name

The following function retrieves a receive service by name:

Public Function GetReceiveFunctionByName(ByVal strRecvFunction As String) As SWbemObject
    On Error Resume Next
    Set GetReceiveFunctionByName = Nothing
    Set GetReceiveFunctionByName = g_objService.Get(RECVSVC_NAMESPACE & ".NAME=""" & strRecvFunction & """")

    If Err <> 0 Then
    End If
End Function


Retrieving All Receive Services

The following function retrieves all receive services:

Public Function GetAllReceiveServices() As SWbemObjectSet
    Dim objBTSRecvSvc As SWbemObject

    On Error Resume Next
    Set GetAllReceiveServices = Nothing
    Set objBTSRecvSvc = g_objService.Get(RECVSVC_NAMESPACE)
    Set GetAllReceiveServices = objBTSRecvSvc.Instances_

    If Err <> 0 Then
    End If
End Function


Retrieving All Receive Services by Group

The following function retrieves all receive services by group:

Public Function GetAllReceiveSvcsByGroup(ByVal strGroupName As String)
    Dim strWMIQuery As String

    On Error Resume Next
    strWMIQuery = "select * from " & RECVSVC_NAMESPACE & " where groupname= '" & strGroupName & "'"
    Set GetAllReceiveSvcsByGroup = g_objService.ExecQuery(strWMIQuery)

    If Err <> 0 Then
    End If
End Function


Servers and WMI

The code examples in this section are useful when working with servers. A server in a server group hosts the appropriate BizTalk Messaging Services functionality to manage document exchange between other servers and applications that are external to the BizTalk Server group.

This section presents functions that create a server, delete a server, start a server, stop a server, retrieve a server by name, retrieve all servers, and retrieve all servers by group.

This section contains the following topics:

  • Creating a Server

  • Deleting a Server

  • Starting a Server

  • Stopping a Server

  • Retrieving a Server by Name

  • Retrieving All Servers

  • Retrieving All Servers by Group


Creating a Server

The following function creates a server:

Public Function CreateServer(ByVal strServerName As String, _
                        ByVal strGroupName As String, _
                        ByVal lMaxWorkerThreadsPerProcessor As Long, _
                        ByVal lSchedulerWaitTime As Double) As Boolean
    Dim objBTSSvr As SWbemObject
    Dim objBTSSvrInstance As SWbemObject

    On Error Resume Next
    CreateServer = True
    Set objBTSSvr = g_objService.Get(SERVER_NAMESPACE)
    Set objBTSSvrInstance = objBTSSvr.SpawnInstance_

        objBTSSvrInstance.Name = strServerName
        objBTSSvrInstance.groupName = strGroupName
        objBTSSvrInstance.MaxWorkerThreadsPerProcessor = lMaxWorkerThreadsPerProcessor
        objBTSSvrInstance.SchedulerWaitTime = lSchedulerWaitTime

    Call objBTSSvrInstance.Put_(wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateServer = False
    End If
End Function


Deleting a Server

The following function deletes a server:

Public Function DeleteServer(ByVal strServerName As String) As Boolean
    On Error Resume Next
    DeleteServer = True
    Call g_objService.Delete(SERVER_NAMESPACE & ".NAME=""" & strServerName & """")

    If Err <> 0 Then
        DeleteServer = False
    End If
End Function


Starting a Server

The following function starts a server:

Public Function StartServer(ByVal strServerName As String) As Boolean
    Dim strWMIPath As String
    Dim objBTSSvrs As SWbemObject

    On Error Resume Next
    StartServer = True
    strWMIPath = SERVER_NAMESPACE & ".NAME=""" & strServerName & """"
    Set objBTSSvrs = g_objService.ExecMethod(strWMIPath, "StartServer")

    If Err <> 0 And Hex(Err) <> "80070420" Then
        StartServer = False
    Else
        Err.Clear
    End If
End Function

Note that if Err is not equal to 0, and the hexadecimal value of the error is not equal to 80070420, then the service was already running.


Stopping a Server

The following function stops a server:

Public Function StopServer(ByVal strServerName As String) As Boolean
    Dim strWMIPath As String
    Dim objBTSSvrs As SWbemObject

    On Error Resume Next
    StopServer = True
    strWMIPath = SERVER_NAMESPACE & ".NAME=""" & strServerName & """"
    Set objBTSSvrs = g_objService.ExecMethod(strWMIPath, "StopServer")

    If Err <> 0 And Hex(Err) <> "80070426" Then
        StopServer = False
    Else
        Err.Clear
    End If
End Function

Note that if Err is not equal to 0, and the hexadecimal value of the error is not equal to 80070426, then the service was not running.


Retrieving a Server by Name

The following function retrieves a server by name:

Public Function GetServerByName(ByVal strServerName As String) As SWbemObject
    On Error Resume Next
    Set GetServerByName = Nothing
    Set GetServerByName = g_objService.Get(SERVER_NAMESPACE & ".NAME=""" & strServerName & """")
End Function


Retrieving All Servers

The following function retrieves all servers:

Public Function GetAllServers() As SWbemObjectSet
    Dim objBTSSvrs As SWbemObject

    On Error Resume Next
    Set objBTSSvrs = g_objService.Get(SERVER_NAMESPACE)
    Set GetAllServers = objBTSSvrs.Instances_
End Function


Retrieving All Servers by Group

The following function retrieves all servers by group:

Public Function GetAllServersByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Dim strWMIQuery As String

    On Error Resume Next
    strWMIQuery = "select * from " & SERVER_NAMESPACE & " where groupname= '" & strGroupName & "'"
    Set GetAllServersByGroup = g_objService.ExecQuery(strWMIQuery)
End Function


Queues and WMI

The code examples in this section are useful when working with queues. Queues are used to contain incoming and outgoing documents that are in various stages of routing and processing in BizTalk Server.

This section presents functions that retrieve queues by group and retrieve all queues.

This section contains the following topics:

  • Retrieving Queues by Group

  • Retrieving All Queues


Retrieving Queues by Group

This section illustrates functions that retrieve the Work, Retry, Suspended, or Scheduled queue by group.

The Work queue contains documents that are currently being processed by BizTalk Server. The following function retrieves the Work queue by group:

Public Function GetWorkQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetWorkQByGroup = GetXXXXQByGroup(strGroupName, WORKQ_NAMESPACE)
End Function

The Retry queue contains documents that are being resubmitted for delivery and documents that are waiting for reliable messaging receipts. The following function retrieves the Retry queue by group:

Public Function GetRetryQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetRetryQByGroup = GetXXXXQByGroup(strGroupName, RETRYQ_NAMESPACE)
End Function

The Suspended queue contains work items that have failed processing for a variety of reasons, including parsing errors, serialization errors, and failed transmissions. The following function retrieves the Suspended queue by group:

Public Function GetSuspendedQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetSuspendedQByGroup = GetXXXXQByGroup(strGroupName, SUSPENDEDQ_NAMESPACE)
End Function

The Scheduled queue contains work items that have been processed by BizTalk Server and are waiting for transmission. The following function retrieves the Scheduled queue by group:

Public Function GetScheduledQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetScheduledQByGroup = GetXXXXQByGroup(strGroupName, SCHEDULEDQ_NAMESPACE)
End Function

The following helper function is used by the previous functions to retrieve a given queue by group:

Public Function GetXXXXQByGroup(ByVal strGroupName As String, ByVal QueueNameSpace As String) As SWbemObjectSet
    Dim strWMIQuery As String

    On Error Resume Next
    strWMIQuery = "select * from " & QueueNameSpace & " where group= """ & strGroupName & """"
    Set GetXXXXQByGroup = g_objService.ExecQuery(strWMIQuery)
End Function


Retrieving All Queues

The following function retrieves all queues:

Public Function GetAllQueues() As SWbemObjectSet
    Dim objBTQueue As SWbemObject

    On Error Resume Next
    Set GetAllQueues = Nothing
    Set objBTQueue = g_objService.Get(QUEUE_NAMESPACE)
    Set GetAllQueues = objBTQueue.Instances_
End Function


Miscellaneous Tasks

This section contains the following topics:

  • Determine if BizTalk Server is Installed

  • Modify the XML Encoding

  • Retrieve BizTalk Server Product Information

  • Validate an XML Document


Determine if BizTalk Server is Installed

The following code determines if BizTalk Server is installed on the local machine.

Dim objService, objLocator, objConfig, strGroupName

Set objLocator = CreateObject("WbemScripting.SWbemLocator")

On Error Resume Next
Set objService = objLocator.ConnectServer(, "root/MicrosoftBizTalkServer")

PassFail "Unable to connect to BizTalk Server. Please verify that your BizTalk " & "Server is installed and functions properly."

Sub PassFail(strScope)
    If Err.Number <> 0 Then

MsgBox strScope & " Error: x" & Hex(Err.Number) & " Description: " & Err.Description & " Source: " & Err.Source

        Err.Clear
    Else

MsgBox "BizTalk Server appears to be installed."

    End If
End Sub


Modify the XML Encoding

BizTalk Server uses UTF-8 encoding in XML output files by default. Use the following Microsoft Visual Basic Scripting Edition (VBScript) code to specify a different encoding type:

set xmlObj = CreateObject("MSXML2.DomDocument.3.0")
wscript.echo wscript.arguments(1)

if wscript.arguments.count < 2 then
    wscript.echo "Usage: encoding.vbs XMLDocument Encoding"
    wscript.quit
end if

if xmlobj.load(wscript.arguments(0)) = False then
    wscript.echo "Unable to load the XML document."
    wscript.Echo "Error: " + xmlobj.ParseError.Reason + "Line: " + CStr(xmlobj.ParseError.Line)
    wscript.quit
end if

if (xmlObj.firstChild.nodeType = 7) and (xmlObj.firstChild.nodeName = "xml") then
    set child = xmlObj.firstChild
    xmlObj.removeChild child
end if

set pi = xmlObj.createProcessingInstruction("xml","version='1.0' encoding='" & wscript.arguments(1) & "'")
xmlObj.insertBefore pi, xmlObj.firstChild
xmlObj.save "newxml.xml"
wscript.echo "Done"

Notes

  • The "Usage" statement assumes that the script file containing this code is named encoding.vbs.

  • The first argument is the name of the XML document to be modified.

  • The second argument is a valid XML encoding value.

  • A new, modified version of the input XML file is created in the same folder with the name newxml.xml.

To run this script, open a Command Prompt window and use the following syntax:

C:\ > wscript encoding.vbs file.xml enctype

Where file.xml is the name of the XML file to be converted, and enctype is the encoding type to be used in the XML file.

To use this code with XML files created by BizTalk Server, you can create an application integration component (AIC) that incorporates similar XML document object model code. If you prefer to manually edit the file or run the script shown above, you can use the file transport protocol on the port to create the XML files to be converted.

Related Topics

Application Integration Components

Specify a transport address


Retrieve BizTalk Server Product Information

The following VBScript example uses the Microsoft Windows Installer Object Library to obtain information about BizTalk Server. In a Microsoft Visual Basic project, use the Microsoft Windows Installer Object Library (\system32\msi.dll).

Public objInstaller
Const gstrProductName = "Microsoft BizTalk Server 2002"

Sub Main()
    Dim guidProductCode

        On Error Resume Next
        Set objInstaller = CreateObject("WindowsInstaller.Installer")
        guidProductCode = GetProductGuid(gstrProductName)
        Wscript.echo "PRODUCT INFORMATION" & vbNewLine & vbNewLine & GetProductInfo(guidProductCode)
End Sub

Function GetProductGuid(sProductName)
    Dim sName
    Dim guidProductCode

        On Error Resume Next
        GetProductGuid = ""

        For Each guidProductCode In objInstaller.Products
            sName = objInstaller.ProductInfo(guidProductCode, "ProductName")

            If (LCase(sProductName) = LCase(sName)) Then
                GetProductGuid = CStr(guidProductCode)
                Exit For
            End If
        Next
End Function

Function GetProductInfo(guidProductCode)
    Dim s

    On Error Resume Next
    s = "ProductInfo for " & guidProductCode & vbNewLine
    s = s & vbNewLine
    s = s & "InstalledProductName: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstalledProductName") & vbNewLine
    s = s & "VersionString: " & vbTab & objInstaller.ProductInfo(guidProductCode, "VersionString") & vbNewLine
    s = s & "HelpLink:      " & vbTab & objInstaller.ProductInfo(guidProductCode, "HelpLink") & vbNewLine
    s = s & "HelpTelephone: " & vbTab & objInstaller.ProductInfo(guidProductCode, "HelpTelephone") & vbNewLine
    s = s & "InstallLocation: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstallLocation") & vbNewLine
    s = s & "InstallSource: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstallSource") & vbNewLine
    s = s & "InstallDate: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstallDate") & vbNewLine
    s = s & "Publisher: " & vbTab & objInstaller.ProductInfo(guidProductCode, "Publisher") & vbNewLine
    s = s & "LocalPackage: " & vbTab & objInstaller.ProductInfo(guidProductCode, "LocalPackage") & vbNewLine
    s = s & "URLInfoAbout: " & vbTab & objInstaller.ProductInfo(guidProductCode, "URLInfoAbout") & vbNewLine
    s = s & "URLUpdateInfo: " & vbTab & objInstaller.ProductInfo(guidProductCode, "URLUpdateInfo") & vbNewLine
    s = s & "VersionMinor: " & vbTab & objInstaller.ProductInfo(guidProductCode, "VersionMinor") & vbNewLine
    s = s & "VersionMajor: " & vbTab & objInstaller.ProductInfo(guidProductCode, "VersionMajor") & vbNewLine
    s = s & vbNewLine
    s = s & "Transforms: " & vbTab & objInstaller.ProductInfo(guidProductCode, "Transforms") & vbNewLine
    s = s & "Language: " & vbTab & objInstaller.ProductInfo(guidProductCode, "Language") & vbNewLine
    s = s & "ProductName: " & vbTab & objInstaller.ProductInfo(guidProductCode, "ProductName") & vbNewLine
    s = s & "AssignmentType: " & vbTab & objInstaller.ProductInfo(guidProductCode, "AssignmentType") & vbNewLine
    s = s & "PackageCode: " & vbTab & objInstaller.ProductInfo(guidProductCode, "PackageCode") & vbNewLine
    s = s & "Version:        " & vbTab & objInstaller.ProductInfo(guidProductCode, "Version") & vbNewLine
    s = s & "ProductIcon: " & vbTab & objInstaller.ProductInfo(guidProductCode, "ProductIcon") & vbNewLine
    GetProductInfo = s
End Function

Main


Validate an XML Document

The following code validates an XML document:

Dim xmlDoc As New Msxml2.DOMDocument

    xmlDoc.async = False
    xmlDoc.validateOnParse = True
    xmlDoc.Load "myXML.xml"


BizTalk Server Samples

Samples provided in the BizTalk Server SDK are located in the folder \Program Files\Microsoft BizTalk Server\SDK on the installation drive. These samples should not be used in a production environment.

Sample Requirements

The samples provided with BizTalk Server require one or more of the following applications:

  • Microsoft Visual Basic® is necessary to modify and compile the Visual Basic source files, such as .vbp files, that are included in the SDK. The Visual Basic runtime, VB6.exe, is also needed to run some of the executable files included in the SDK.

  • A compiler and source code editor, such as Microsoft Visual C++®, is necessary to modify and compile the C++ source files.

  • Microsoft Word or Wordpad is necessary to view some of the readme files that use a .doc file type extension.

  • An HTML browser, such as Microsoft Internet Explorer, is necessary to view some of the readme files that use an .htm file type extension.

This section contains the following topics:

  • BizTalk Messaging Services Code Samples

  • BizTalk Orchestration Services Code Samples

E-Procurement Sample


BizTalk Messaging Services Code Samples

Sample files are located in the Messaging Samples folder on the Microsoft BizTalk Server installation drive. Browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples on the installation drive to find the sample files. This is only a relative path. Depending on your installation of BizTalk Server 2002, you might need to modify this path.

  • Application Integration in Visual Basic

  • Application Integration in Visual C++

  • BizTalk Framework Developers' Toolkit

  • Configuration Assistant

  • Custom Counters

  • Custom Import Module

  • Custom Preprocessor in Visual Basic

  • Custom Preprocessor in Visual C++

  • Date Functoid

  • Date Functoid with .NET

  • Direct Integration

  • Distribution List

  • EDI and Receipts

  • EDI Introduction

  • Encryption and Decryption

  • Flat-File Delimited

  • Flat-File Positional

  • HTTP Receive Function

  • Mapping Twice

  • Message Queuing 4 MB Limit

  • Multi-part MIME Attachment

  • Pipeline Component in Visual Basic

  • Pipeline Component in Visual C++

  • Queue Sniffer

  • Receive Scripts

  • Refresh Messaging Manager

  • Reliable Messaging

  • Self Routing

  • Send To Remote Queue

  • Submitting Documents

  • Submitting Documents with Receipts

  • Submitting Documents to a Port Group

  • Suspended Queue Monitoring

  • Synchronous Orchestration Component

  • Tracking Database Tasks

  • Windows Management Instrumentation

Notes

  • When using C++, you need to add \Program Files\Microsoft BizTalk Server\SDK\Include to the include directory list.

  • Some of the samples have a dependency on the Pipecomplib.tlb file. For these samples, you need to add \Program Files\Common Files\Microsoft Shared\Enterprise Servers\Commerce to the include directory list.


Application Integration in Visual Basic

This sample demonstrates an application integration component (AIC) that implements the IBTSAppIntegration interface. The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the BizTalk Server WebDAV repository), instantiates a schedule (provided with this sample) and passes the document to the schedule. The schedule gets the document and sends it to the file C:\temp\WFOut.txt.

For a related sample, see Application Integration in Visual C++.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTSAppIntegration\VB

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual Basic component (this is optional because the DLL is provided with the sample).

  2. Register the component, its category IDs, and its setup configuration by running the script:

    cscript scenario.wsf //job:setup

    When prompted whether to register information from Affinity.reg, click Yes. The component progid is "BTSSamples_IBTSAppInt_VB AIC2Sched".

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_AIC2Sched" by using the script:

    cscript scenario.wsf //job:submit

    If the submission succeeds, the document appears in C:\temp\WFOut.txt.


Application Integration in Visual C++

This sample demonstrates an application integration component (AIC) that implements the IBTSAppIntegration interface by using the Active Template Library (ATL). The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the BizTalk Server WebDAV repository) and returns the first element of the document.

For a related sample, see Application Integration in Visual Basic.

Note

  • This sample requires the Microsoft XML Parser (MSXML) version 3.0 or higher.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTSAppIntegration\VC\ATL

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual C++ component.

  2. Set up the configuration by running the script:

    cscript scenario.wsf //job:setup

    The component progid is "BTSSamples.AtlIBTSAppInt".

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_ATL_IBTSAppInt_AIC" by using the script:

    cscript scenario.wsf //job:SubmitSync

    If the submission succeeds, it replies with the first element of the submitted document.


BizTalk Framework Developers' Toolkit

This sample demonstrates how to programmatically access the BizTalk Framework 2.0 tags in a message.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTFDevToolkit

User's Guide

Before running the sample, complete the following steps:

  1. Register one of the envelope objects using regsvr32. Depending on which version of the XML parser you have (version 2.0, version 2.6, or version 3.0), register BTFEnvelope20.dll, BTFEnvelope26.dll, or BTFEnvelope30.dll respectively. Note that only one of these libraries can be registered at a time because they share a common CLSID.
    2. Copy SchemaPluginGenerator.dll to $:\Microsoft Visual Studio\Common\MSDev98\AddIns and run regsvr32 on the DLL to register it. The AddIns folder path location can vary depending on where Microsoft Visual Studio® is installed.
  3. Copy the file pigen.ini to the same location as SchemaPluginGenertor.dll (the Visual Studio AddIns folder).

  4. Register the MSPlugin type library depending on which version of the XML parser you are running. Register the type library MSPlugin20.tlb, MSPlugin26.tlb, or MSPlugin30.tlb if you are using XML parser version 2.0, version 2.6, or version 3.0 respectively You can register this file by verifying, and updating if necessary, the TLB file location paths in Plugin2.reg. After the paths are correct, you can run the Plugin2.reg file by double-clicking it.

  5. Copy the following files to the Template\Classes folder in the Visual Basic program tree, $:\Microsoft Visual Studio\VB98\Template\Classes:
    • Microsoft Plugin class instance.cls

    • Microsoft Plugin collection instance.cls

    • Microsoft Plugin Main.cls

    Be sure that these files are not read-only.

  6. Copy the following file to the Template\Code folder in the Visual Basic program tree, $:\Microsoft Visual Studio\VB98\Template\Code:
    • modXMLHelper3.bas

    Be sure that this file is not read-only.

  7. Load the code generator. Open Visual Basic and run the Add-In manager. You should see the following available add-in: BTF Developers Toolkit Schema Plug-in Generator. Select the Loaded/Unloaded check box to load the add-in. It will appear in the Add-Ins drop-down menu.

To run the sample, you must have the following components installed:

  1. Visual Basic version 6.0 SP3 or SP4

  2. Microsoft XMLDOM typelib {F5078F18-C551-11D3-89B9-0000F81FE221}. There are components specifically targeted at all three versions (2.0, 2.6, and 3.0) of the Microsoft XML Parser (MSXML). Any one of these three versions of the document object model (DOM) will work. Read UsingPluginGenerator.doc for more information about the DOM-targeted versions of the BTFEnvelope component and the MSPlugin type library.

Programming Notes

The Resource Kit components consist of two core components and a type library:

  • Envelope object. This object provides programmatic access to the BTF2.0 header tags in the XML document, including management of the message body and the ability to add documents.

  • Plugin code generator. This takes an XDR schema and generates a "plugin" set of Microsoft Visual Basic COM components that provide programmatic access to the BODY tags in a BTF 2.0 message.

  • PlugIn2 interface. Exposed through the MSPlugin type library. This interface is implemented by the generated plugin component and called by the Envelope object. This interface is the link between the Envelope and the Plugin.

You can find further documentation on the Envelope and Plugin in the files UsingPluginGenerator.doc and EnvelopeAndPlugin.doc. The BizTalk Framework 2.0 (BTF) tag specification and the XML-Data Reduced (XDR) schema documentation can be found at http://msdn.microsoft.com/xml. It is highly recommended that you read the BTF specification and the UsingPluginGenerator documents before you use the components. You can obtain further architectural detail from the EnvelopeAndPlugin document.

Known Issues

  • The Plugin generator does not support XDR <group> structures when nested within another <group>. Generated code will work, but the embedded group will not have object model access code. In this scenario the IXMLDOMNode nodes will be available and the plugin is still usable and correct.

  • The generator will treat XDR order="one" attributes like order="many" because it does not know which child element will eventually be used. The programmer must set only one child element so that the resulting XML document will be valid.

  • The Visual Basic "Microsoft Plugin" template files located under $:\Microsoft Visual Studio\VB98\Template must not be read-only. If they are read-only, the generator will fail when adding modules to the targets Visual Basic project.

  • The BTFEnvelope object does not yet support BTF 2.0 Multipart MIME structures and Reliable Delivery structures. While this support is not directly developed into the component, the DOM nodes at each level are exposed so that they can easily be extended and customized.

  • The envelope can currently accept only one business document added to its body. Therefore it is not currently possible to add or access more than one business document nested in the body.


Configuration Assistant

This sample enables you to view all details of a BizTalk Server configuration and to export and import that configuration. The configuration export and import is completed as a package that includes all messaging objects such as document specifications, maps, custom parsers, serializers, and application integration components (AIC).

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTConfigAssistant

User's Guide

Detailed information is provided in the Readme.doc file located in the BTConfigAssistant folder.


Custom Counters

This sample allows you to create a custom counter that you can use to count the number of documents in the Tracking database (DTA) that match a specified set of criteria. This sample allows you to create two types of counters, one based on source and destination organization names, and one based on qualifier and value pairs. Each counter is validated after it is created.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Custom Counter

User's Guide

Before running the scripts, complete the following steps:

  1. On the C drive, create a folder called CustomCounterSample with two subfolders called SrcOrg and DestOrg.

  2. On the BizTalk Server installation drive, copy POReq.xml to \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

  3. Run CustomCounterConfig.vbs to configure BizTalk Messaging Services.

To run documents through the DTA, copy and paste PORequest.xml to the C:\CustomCounterSample\SrcOrg folder. You should see an output file, Output.xml, in the C:\CustomCounterSample\DestOrg folder. Each time you do this an additional record will be tracked in the DTA.

To create a custom counter based on source and destination organization names, run CreateCustomCounter_Organizations.vbs.

To create a custom counter based on qualifier and value pairs, run CreateCustomCounter_Identifiers.vbs.

The first time you run each script, you will be creating an instance of the counter classes. When you run the script again to view the number of matching documents in the DTA, you will update the class.

To run the sample, you need to remove the read-only property from the sample data file, PORequest.xml.

Important

  • When calling the Put_ method to create or update the custom counter setting object, the wbemChangeFlagCreateOrUpdate flag is not supported. Instead, you must specify either wbemChangeFlagCreateOnly or wbemChangeFlagUpdateOnly, depending on whether you want to create or update the custom counter setting object. As a result, you need to update the source code of CreateCustomCounter_Organizations.vbs or CreateCustomCounter_Identifiers.vbs accordingly.

    For example, the following code from both the sample scripts creates the custom counter setting object:

    objCustomCounterSetting.Put_(wbemChangeFlagCreateOnly)

    To update the existing custom counter setting object, modify the code by specifying the wbemChangeFlagUpdateOnly flag, as shown in the following code:

    objCustomCounterSetting.Put_(wbemChangeFlagUpdateOnly)

    When you run the script again, the existing custom counter setting object will be updated.

    When the sample scripts are first installed, they are set up to create a custom counter setting object, in order to update the custom counter setting object and query the MatchCount property, you will need to update the scripts as specified above.

  • For the value of the MatchCount property to be consumed by Microsoft Operations Manager (MOM), the MOM DAS account must be a member of the BizTalk Server Administration group.

Programming Notes

This sample uses the MSBTS_CustomCounterSetting and MSBTS_CustomCounter Windows Management Instrumentation (WMI) classes. To locate the definitions of these classes, view the InterchangeProvSchema.mof file. The MatchCount property of MSBTS_CustomCounter is incremented each time a document runs through the DTA.


Custom Import Module

This sample creates a custom import module that imports a flat file and displays it in BizTalk Editor. The imported file is a delimited flat file exported from an SQL table. It is an ANSI file that uses "{CR}{LF}" as the row delimiter and comma as the column delimiter. The first line contains column names. The custom import module first creates a schema root called "SQLFile". It then parses the first line of the input file, extracts each column name, and creates each column as a text-only element under the root. The import module returns an XDR schema with BizTalk Server annotations.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleImporter

User's Guide

To use this sample in BizTalk Editor, follow these steps:

  1. Register CustomImporter.dll (run regsvr32 CustomImporter.dll).

  2. Merge CustomImporter.reg (right-click CustomImporter.reg and then click Merge).

  3. In BizTalk Editor, on the Tools menu, click Import. The "Custom data" import module will appear in the "Select Import Module" window.

  4. Select 'sqlfile.txt'. The BizTalk Editor tree view window will display the schema structure that was created based on the input file.

  5. Select 'Blank.txt'. BizTalk Editor will display a dialog box that indicates a "column not found" error.

  6. Select 'FilewithWarning.txt'. BizTalk Editor will report warnings in the output window.

To remove this custom importer from BizTalk Editor, you need to unregister CustomImporter.dll by using the command: run regsvr32 /u CustomImporter.dll.


Custom Preprocessor in Visual Basic

This sample demonstrates a very simple implementation of a custom preprocessor to be used with a File receive function.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\VBCustPreProcessor

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual Basic project into VBCustPreProcessor.dll.

  2. Register VBCustPreProcessor.dll by using regsvr32.

To run the sample, follow these steps:

  1. Set up a File receive function.

  2. Submit a document to BizTalk Server.

  3. Submit a document to the receive function.

Programming Notes

The Execute method simply loads the file into the XML DOM and then returns the XML data to BizTalk Server. The files should therefore always contain XML for the purposes of this sample.

This sample also demonstrates how to obtain context information from BizTalk Server although it does not actually use this context information during processing.


Custom Preprocessor in Visual C++

This sample demonstrates a very simple implementation of a custom preprocessor to be used with either File or Message Queuing receive functions.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\CustomPreProcessor

User's Guide

Before running the sample, complete the following steps:

  1. Compile the source files provided in this folder into CustomPreProcessorps.dll.

  2. Register CustomPreProcessorps.dll by using regsvr32.

To run the sample, follow these steps:

  1. Set up either a File receive function or a Message Queuing receive function.

  2. Submit a document to the receive function.

Programming Notes

When used by a File receive function, the Execute method simply loads the file into the XML DOM and then returns the XML data to BizTalk Server. The files should therefore always contain XML for the purposes of this sample.

When used by a Message Queuing receive function, if the input data contains an array of bytes, it is converted to a BSTR. Alternatively, if the input data contains a BSTR, it is converted to an array of bytes.

This sample also demonstrates how to obtain context information from BizTalk Server although it does not actually use this context information during processing.


Date Functoid

This sample creates a custom functoid that converts date formats. It converts a date in ISO format (generated from Date(), Time(), Now() in Visual Basic or from Date, Time, DateTime functoids) to a date in mm-dd-yyyy format. This sample is similar to the Date Functoid with .NET sample that is written in Visual C#™ .NET.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleFunctoid

User's Guide

Before running the sample, complete the following steps:

  1. Register DateConversion.dll (run regsvr32 DateConversion.dll).

  2. Merge DateConversion.reg (right-click DateConversion.reg and then click Merge).

To run the sample in BizTalk Mapper:

  • Select the DateConversion functoid that appears in the functoid palette on the Date/Time tab.


Date Functoid with .NET

This sample creates a custom functoid that converts date formats. It converts a date in ISO format (generated from Date(), Time(), Now() in Visual Basic or from Date, Time, DateTime functoids) to a date in mm-dd-yyyy format. This sample is written in Visual C# .NET and shows how to write a functoid by using Microsoft .NET Framework. This sample is identical in functionality to the Date Functoid sample that is written in Visual Basic.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DateFunctoidNet

User's Guide

Before running the sample, complete the following steps:

  1. Register AssemblyPathFinder.dll by typing the following two commands:

    regasm AssemblyPathFinder.dll

    gacutil /i AssemblyPathFinder.dll

  2. Register AssemblyPathFinderProxy.dll by using the command:

    run regsvr32 AssemblyPathFinderProxy.dll

To run the sample with BizTalk Mapper, follow these steps:

  1. Run buildme.bat.

  2. Merge DateFunctoidNet.reg (right-click DateFunctoidNet.reg and then click Merge).

  3. The DateFunctoidNet functoid appears in the functoid palette on the Date/Time tab.

To remove this functoid from the BizTalk Mapper functoid palette, follow these steps:

  1. Run unreg.bat

  2. Delete the following key from the registry (by using regedit):

    HKEY_CLASSES_ROOT\CLSID\{722FF791-A0F8-42b9-B390-16C3F9238A5E}

Programming Notes

.NET Framework must be installed to run this sample.


Direct Integration

This sample demonstrates the use of IInterchange methods to submit documents to BizTalk Server. A user interface offers the ability to set parameters interactively before submitting a document.

The sample also contains the source code for a component that can be used to unpack binary buffers returned as BSTR. Buffers are converted to safe character arrays. The component is used by the main sample when saving data items from the Suspended queue to file.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DirectIntegration

User's Guide

Detailed information is provided in the Readme.doc file located in the DirectIntegration folder.


Distribution List

This sample consists of independent Visual Basic and Visual C++ samples that configure and run a DistributionList, or port group, scenario that sends documents to multiple trading partners. The two samples perform the same tasks and show how to implement those tasks by using two different programming languages.

The sample Submitting Documents to a Port Group contains related information.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DistributionList

User's Guide

Before running the sample, complete the following steps:

  1. In the C++ sample, compile the source files DistributionList.cpp and DistributionList.h into an executable file.

  2. In the Visual Basic sample, create an executable file from the DistributionList project (.bas) file.

To run the sample:

  • Run the .exe file that you created in the preceding steps.

Programming Notes

In the C++ sample, the code shows how to set up the BizTalk Messaging Management database to submit a CommonPO document to a distribution list (port group).

The distribution list consists of two ports:

Port "SRC -> DST Port" wraps the input document in a BizTalk Framework (BTF) 2.0 envelope and drops the output to the file "%HOMEDRIVE%\DL_SRCtoDST.TXT".

Port "SRC -> APP2 Port" transports the input document and drops it to the file "%HOMEDRIVE%\DL_SRCtoAPP2.TXT".

After configuring the BizTalk Messaging Management database, the sample submits a CommonPO to BizTalk Server and then checks that there are no entries in the Suspended queue and that the expected number of entries was tracked in the Tracking database during the last Submit call.

In the Visual Basic sample, the code shows how to set up the BizTalk Messaging Management database to submit a CommonPO document to a distribution list.

The distribution list consists of two ports:

Port "SRC -> DST Port" wraps the input document in a BTF 2.0 envelope and drops the output to the file "%HOMEDRIVE%\DL_SRCtoDST.TXT".

Port "SRC -> APP2 Port" transports the input document and drops it to the file "%HOMEDRIVE%\DL_SRCtoAPP2.TXT".


EDI and Receipts

This sample demonstrates how BizTalk Server can be used to support inbound X12 purchase order (850) messages from a trading partner and generate outbound X12 receipts (997) for those messages.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\EDI and Receipts

User's Guide

The sample scenario involves an external trading partner (Fabrikam, Inc.) submitting X12 purchase order (850) documents to the home organization (Microsoft). The inbound X12 electronic data interchange (EDI) documents are mapped to XML format and transported to the internal recipient application (MOLP). To signal that the X12 850 has been received, the home organization sends a functional acknowledgement (997) document to the external organization. The outbound X12 997 receipt is generated from a canonical receipt format that is shipped with BizTalk Server.

This sample uses only file transport to simulate the scenario, and does not use BizTalk Orchestration Services. X12 EDI documents from Fabrikam are dropped in one directory, and the transformed XML documents and receipt documents are generated as output in other directories on the local file system.

Note

  • If you have run setup.cmd on the EDI Introduction sample, you must run the setup on this sample for the scenario to work correctly.

To run the sample, follow these steps:

  1. Run setup.cmd in the sample folder to configure the scenario.

    Configuration involves the creation of the following BizTalk Server objects:

    • Organizations: Microsoft (default organization), Fabrikam

    • Document Definitions: Fabrikam850, Microsoft997, MicrosoftPO-MOLP, MyCanonicalReceipt

    • Envelope: EDItoFabrikam

    • Port: EDIPortToFabrikam, PortToMOLP

    • Channel: Channel997toFabrikam, Channel850toFabrikam

    • Receive Function: EDIFiles

    Files are copied onto the C drive. Make the necessary modifications in setup.cmd and ConfigureEDIReceipts.vbs if the C drive does not exist.

  2. With BizTalk Server running, navigate to c:\EDIReceipts\ and copy the file Fabrikam850.edi into c:\ EDIReceipts\Fabrikam.

    This file should be consumed by BizTalk Server, transformed, and submitted to C:\EDIIntroduction\Microsoft as the file xmlpotomolp_%tracking_id%.xml, where %tracking_id% is a unique ID value. A receipt file named EDItofabrikam_%tracking_id%.edi is then submitted to C:\EDIIntroduction\Fabrikam\Receipts.

To walk through how the sample is prepared, follow these steps:

  • Set Up Organizations and Associated Identifiers

  • Set Up and Verify Document Specifications

  • Set Up Map for Converting X12 to XML

  • Create Document Definitions

  • Create EDI Envelope

  • Create Ports

  • Create Channels

  • Create File Receive Function

  • Run the Sample Scenario

Programming Notes

The schemas and maps for this sample are completed and are available for review. It is also recommended that you complete the EDI Introduction sample for additional background.


Set Up Organizations and Associated Identifiers

This section creates the home organization (Microsoft), the application within the home organization (MOLP), and the destination organization (Fabrikam). It also sets up the organizational identifiers that uniquely determine how the EDI interchange is processed.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. If the BizTalk Messaging Manager dialog box appears, click Cancel.

  3. In the left frame, click Organizations, and then click Search Now.

  4. Ensure that Microsoft is the home organization.

    The home organization is indicated by (Default) next to the name. The dialog box that appears when you double-click the home organization should have three tabs.

  5. Click the Applications tab in the Organization Properties dialog box for Microsoft.

  6. Click Add, type MOLP, and then click OK.

  7. Click the Identifiers tab in the Organization Properties dialog box for Microsoft.

  8. Click Add, click Custom, and then type any name you like (for example, MyD&Bnumber) in the Custom text box.

  9. Enter 01 for Qualifier and 081466849 for Value. Click OK twice.

  10. To add the external trading partner organization Fabrikam, right-click the organization view window and click New Organization on the context menu.

  11. Click the Identifiers tab in the Organization Properties dialog box for Fabrikam.

  12. Click Add, click Custom, and then type any name you like in the Custom text box.

  13. Enter 01 for Qualifier and 0123456789 for Value. Click OK twice.


Set Up and Verify Document Specifications

In this section, you will set up, verify, and store to WebDAV the following document specifications:

  • schFabrikam850.xml - X12 850 purchase order sent from Fabrikam

  • schMicrosoftPO.xml - XML purchase order received by Microsoft

  • schMicrosoft997.xml - X12 997 receipt sent by Microsoft upon receiving 850

Note that the specification for a canonical receipt, CanonicalReceipt.xml, ships with BizTalk Server. It can be found in WebDAV in the Microsoft folder.

Set up EDI source specification

The file schFabrikam850.xml contains the document specification for the purchase order that is sent from Fabrikam. In this procedure you will examine an example X12 purchase order (850) that follows this specification (Fabrikam850.edi), validate the specification against a created test instance of the X12 850 (Fabrikam850NoEnvelope.edi), and store the specification to the WebDAV repository for future use.

  1. Using Notepad, open Fabrikam850.edi. (Right-click the file name, click Open With, and then select Notepad from the list of applications.) Leave Notepad active.

    You are looking at the EDI X12 purchase order (850). Note the delimiters needed to separate the records, fields, and subfields in the 850. They will be given in step 7 to validate the specification.

  2. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Editor.

  3. On the File menu, click Open, or use the toolbar icon to navigate to and select schFabrikam850.xml.

  4. Examine the specification. Select the nodes (for example, the root node X12_4010_850) and, on the View menu, click Expand Tree Items, or click the expand indicator (+).

  5. Using another instance of Notepad, open Fabrikam850NoEnvelope.edi. Compare this file with Fabrikam850.edi.

    As the file name indicates, Fabrikam850NoEnvelope.edi is the EDI X12 850 in step 1 with the header and trailer removed so that the BEG segment is at the top and the AMT segment followed by a carriage return/line feed is at the bottom. It will be used as a test validation instance of the EDI specification, because validation instances cannot contain envelope information.

  6. On the Tools menu, click Validate Instance and provide the file name Fabrikam850NoEnvelope.edi (in the same folder as other files used in this sample).

  7. In the Document Delimiters dialog box, specify ? (0x12), ~ (0x7e), and > (0x3e) for the Record, Field, and Subfield delimiters respectively. Click OK.

    If the instance test worked, the EDI will be transformed to XML and shown in the Output window at the bottom of BizTalk Editor, and the message "The document instance validation succeeded" will appear.

  8. On the File menu, click Store to WebDAV, and place the schema into the BizTalk Server WebDAV repository under the name schFabrikam850.xml.

Set up XML destination specification

The file schMicrosoftPO.xml contains the XML source specification for the purchase order that is received by Microsoft. Open this document, validate it, and store it to the WebDAV repository for future use.

  1. In BizTalk Editor, on the File menu, click Open, or use the toolbar icon to navigate to and select schMicrosoftPO.xml (in the same folder as other files used in this sample).

  2. On the Tools menu, click Validate Specification.

  3. On the File menu, click Store to WebDAV, and place the schema into the BizTalk Server WebDAV repository under the name schMicrosoftPO.xml.

Create receipt specification

An X12 functional acknowledgement (a 997) is sent from Microsoft to Fabrikam. The specification for this document, schMicrosoft977.xml, can be created from a template that is shipped with BizTalk Server.

  1. In BizTalk Editor, on the File menu, click New.

  2. In the New Document Specification dialog box, select X12, select 4010, and then select 997Schema.xml. Click OK.

  3. Select the document root node (X12_4010_997) and click the Reference tab in the right frame.

    The Receipt property on the Reference tab should be set to Yes to indicate that the specification is a receipt type.

  4. On the File menu, click Store to WebDAV, and then place the schema into the BizTalk Server WebDAV repository under the name schMicrosoft997.xml.


Set Up Map for Converting X12 to XML

The file mapFabrikam850toMicrosoftPO.xml specifies how the X12 source specification should be converted to the XML destination specification. Review and compile the map, and store it to WebDAV for future use. Note that no map needs to be constructed for the receipt response, because one is pre-built and included with BizTalk Server for this version of X12 (4010). A copy of this pre-built map (CanonicalReceiptTo4010-997.xml) is included in the same directory for reference.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Mapper.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select mapFabrikam850toMicrosoftPO.xml.

  3. On the Tools menu, click Compile Map, or press F5, or click the toolbar icon that is second from the right.

  4. Review the warnings that appear. Double-click a warning to see the problem that it refers to.

    The following types of warnings appear. Mapping will occur as expected even with these warnings, and they can be ignored.

    • "Warning: The required field 'X' has no incoming link or constant value"

      This type of warning can be ignored because the field's parent will not be created. Therefore the field itself cannot violate the validation criteria because it will not actually exist.

    • "Warning: The destination node 'X' has multiple source loop paths"

      This type of warning can be ignored in this case because the single occurrence of the input records in the instance will not cause a problem with the multiple loop paths. This map might not function as expected with document instances that differ greatly from the one in this sample.

    • "Warning: The destination node "X" has 3 input(s). The maximum number of possible inputs to this node is 1"

      This type of warning can be ignored because the mapper is not able to determine the presence of logical gating of the multiple inputs, which allows only one value to be selected from the multiple inputs.

  5. On the File menu, click Store to WebDAV, and then place the map into the BizTalk Server repository under the name mapFabrikam850toMicrosoftPO.xml.


Create Document Definitions

In this section, you will create the following document definitions:

  • Fabrikam850 - X12 850 purchase order sent from Fabrikam

  • MicrosoftPO-MOLP - XML purchase order received by Microsoft

  • MyCanonicalReceipt – Receipt document used to generate the outbound X12 997

  • Microsoft997 – Outbound X12 997 receipt sent by Microsoft upon receiving 850

Create EDI source document definition

In this procedure, you create the document definition Fabrikam850 for the Fabrikam X12 850 that is based on schFabrikam850.xml. Document tracking and selection criteria for the EDI document definition will be utilized.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. In the left frame, click Document Definitions, and then click Search Now.

  3. Right-click in the right frame and click New Document Definition on the context menu.

  4. For Document definition name type Fabrikam850.

  5. Select the Document specification check box.

  6. Click Browse and select schFabrikam850.xml from the repository list of schemas.

  7. Click the Global Tracking tab.

  8. Expand the BEG segment by clicking the expand indicator (+), select BEG03 (PO number), and then click Text to store this field for all instances processed through this document definition.

  9. Click the Selection Criteria tab.

  10. Click Add, type application_receiver_code for Name, type MAXCIM for Value, and then click OK.

  11. Repeat step 10 to create three more Selection Criteria name/value pairs:
    • application_sender_code / 0123456789

    • functional_identifier / PO

    • standards_version / 004010
  12. Click OK.

Create XML destination document definition

In this procedure, you create the document definition MicrosoftPO-MOLP for the XML purchase order that is received by Microsoft, based on schMicrosoftPO.xml. Document tracking will not be used in this case, and because this is not an EDI definition, defining the selection criteria is also not necessary.

  1. In BizTalk Messaging Manager, right-click in the Document Definitions right frame and click New Document Definition on the context menu.

  2. For Document definition name type MicrosoftPO-MOLP.

  3. Select the Document specification check box.

  4. Click Browse and select schMicrosoftPO.xml from the repository list of schemas.

  5. Click OK.

Create inbound (canonical) receipt document definition

When BizTalk Messaging Services on the home organization processes an inbound interchange from a trading partner, and receipts are required, the parser extracts header elements to generate a canonical receipt. In this procedure, you create the document definition MyCanonicalReceipt based on the canonical receipt specification CanonicalReceipt.xml that is shipped with BizTalk Server. This canonical receipt will then be used as the inbound document definition for the receipt channel (to be created) for delivery to Fabrikam. Neither document tracking nor selection criteria is necessary in defining MyCanonicalReceipt.

  1. In BizTalk Messaging Manager, right-click in the Document Definitions right frame and click New Document Definition on the context menu.

  2. For Document definition name type MyCanonicalReceipt.

  3. Select the Document specification check box.

  4. Click Browse and select CanonicalReceipt.xml from the Microsoft folder in the repository list of schemas.

  5. Click OK.

Create outbound receipt document definition

In this procedure, you create the document definition Microsoft997 based on schMicrosoft997.xml. This defines the outbound X12 997 receipt that Fabrikam expects from Microsoft. The receipt is generated by a mapping from MyCanonicalReceipt, with the map pre-built and included with BizTalk Server for this version of X12. Document tracking will not be utilized here, but defining the selection criteria is necessary.

  1. In BizTalk Messaging Manager, right-click in the Document Definitions right frame and click New Document Definition on the context menu.

  2. For Document definition name type Microsoft997.

  3. Select the Document specification check box.

  4. Click Browse and select schMicrosoft997.xml from the repository list of schemas.

  5. Click the Selection Criteria tab.

  6. Click Add, type application_receiver_code for Name and 0123456789 for Value, and then click OK.

  7. Repeat step 6 to create three more Selection Criteria name/value pairs:
    • application_sender_code / MAXCIM

    • functional_identifier / FA

    • standards_version / 004010
  8. Click OK.


Create EDI Envelope

This section will define the EDItoFabrikam envelope that will be used to wrap the X12 997 receipt from Microsoft to Fabrikam. Envelopes are needed whenever you are using non-XML documents.

  1. In BizTalk Messaging Manager, click Envelopes in the left frame and then click Search Now.

  2. Right-click in the right frame and click New Envelope on the context menu.

  3. Type EDItoFabrikam in the Name text box, click X12 on the Envelope Format drop-down menu, and then click OK.


Create Ports

This section will generate the two ports that are necessary for the inbound interchange and for the outbound receipt interchange.

Create port for internal application

This procedure will create the port PortToMOLP.

  1. In BizTalk Messaging Manager, click Messaging ports in the left frame and then click Search Now.

  2. Right-click in the right frame, click New Messaging Port on the context menu, and then click To Application.

  3. For Name enter PortToMOLP, leave Comments blank, and then click Next.

  4. The Applications option should be pre-selected. Click Name, select MOLP from the list, and then click OK.

  5. Create the directory c:\EDIReceipts\Microsoft\

    This is the location where Microsoft will receive the purchase order sent by Fabrikam and transformed to XML format.

  6. In the Primary Transport dialog box, click Browse, and then select File as the Transport Type.

  7. For the file name, type c:\EDIReceipts\Microsoft\xmlpotomolp_%tracking_id%.xml, click OK, and then click Next twice.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  8. Clear the Create a channel for this messaging port check box, and then click Finish.

Create port for external trading partner

This procedure will create the port EDIPortToFabrikam.

  1. In BizTalk Messaging Manager, right-click in the Messaging ports right frame, click New Messaging Port on the context menu, and then click To an Organization.

  2. For Name enter EDIPortToFabrikam, leave Comments blank, and then click Next.

  3. The Organization option should be pre-selected. Click Browse, select Fabrikam from the list, and then click OK.

  4. Create the directory c:\EDIReceipts\Fabrikam\Receipts.

    This is the location where Fabrikam receives the X12 997 documents.

  5. In the Primary Transport dialog box, click Browse, and then select File as the Transport Type.

  6. For the file name, type c:\EDIReceipts\Fabrikam\Receipts\EDItofabrikam_%tracking_id%.edi, click OK, and then click Next.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  7. Click EDItoFabrikam on the Envelope Information drop-down menu.

    Note that you can also create an envelope here if you forgot to do it earlier in Create EDI Envelope.

  8. Click Delimiters, enter the delimiters ~, *, and >, and then click OK.

    In this case, it does not matter what your delimiters are because there is no real business partner on the other end. In real scenarios, the delimiters are agreed upon between you and your business partners.

  9. In the Interchange Control Number dialog box, type a non-zero number.

  10. On the Organization Identifier drop-down menu, click 0123456789, and then click Next.

  11. Clear the Create a channel for this messaging port check box, and then click Finish.


Create Channels

This section will create the two channels for the inbound purchase order and outbound receipt interchanges. Note that the outbound receipt channel must be created first.

Create channel for outbound receipt

This procedure will create the receipt channel Channel997toFabrikam, with MyCanonicalReceipt as the inbound document definition and Microsoft997 as the outbound document definition. A pre-built map that is shipped with BizTalk Server (CanonicalReceiptTo4010-997.xml) will be used to transform the two definitions.

  1. Right-click EDIPortToFabrikam, click New Channel, and then click From an Application.

  2. For Name type Channel997toFabrikam.

  3. Select the This is a receipt channel check box, and click Next.

  4. The Application option should be pre-selected. Select MOLP from the drop-down list of application names.

  5. Select the 081466849 qualifier from the drop-down list, and then click Next.

  6. Under Inbound Document Definition Name click Browse, select the document definition called MyCanonicalReceipt, click OK, and then click Next.

  7. Under Outbound Document Definition Name click Browse, select the document definition called Microsoft997, and then click OK.

  8. The Map Inbound Document check box should be pre-selected. Click Browse to choose the map CanonicalReceiptTo4010-997.xml in the Microsoft folder of the WebDAV repository, click OK, and then click Next.

  9. Select any document storage options that interest you for the purpose of viewing in the BizTalk Document Tracking (see Start menu), and then click Next.

  10. Type an integer value in the Group Control Number text box.

    The value is not important, but you will note that repeated document flows through this channel will result in serially incremented values for this number.

  11. Click Finish.

Create channel for inbound purchase order

This procedure will create the channel Channel850toMOLP that will use Channel997toFabrikam as its associated receipt channel.

  1. In the left frame of BizTalk Messaging Manager, click Messaging ports, and then click Search Now.

  2. Right-click PortToMOLP, click New Channel, and then click From an Organization.

  3. For Name type Channel850toMOLP, and then click Next.

  4. The Organization option should be pre-selected. Click Browse, choose Fabrikam from the drop-down list, and then click OK.

  5. Select the Generate Receipt check box at the bottom of the dialog box.

  6. Click Browse, select Channel997toFabrikam, click OK, and then click Next.

  7. Under Inbound Document Definition Name, click Browse, select Fabrikam850, click OK, and then click Next.

  8. Under Outbound Document Definition Name, click Browse, select MicrosoftPO-MOLP, and then click OK.

  9. The Map Inbound Document check box should be pre-selected. Click Browse, select mapFabrikam850toMicrosoftPO.xml from the maps repository, click OK, and then click Next.

  10. Select any document storage options that interest you for the purpose of viewing in the BizTalk Document Tracking (see Start menu), click Next, and then click Finish.


Create File Receive Function

This section will create the File receive function EDIFiles for picking up Fabrikam purchase orders to send to Microsoft.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Server Administration.

  2. Expand the Microsoft BizTalk Server 2002 node in the left frame tree until the Queues and Receive Functions nodes are fully expanded.

  3. Add a new File receive function either by clicking the Receive Functions node and choosing Action | New | File Receive Function from the menu bar or by right-clicking the Receive Functions node and clicking New | File Receive Function on the context menu.

  4. Type EDIFiles for Name. Comments can be left blank.

    The machine you are working on should be pre-selected in the drop-down list titled Server on which.

  5. Type *.EDI in the File type to poll for text box.

  6. Verify the existence of the directory c:\EDIReceipts\Fabrikam.

    This is the location where Fabrikam will drop the X12 850 documents to be sent to Microsoft.

  7. Type c:\EDIReceipts\Fabrikam in the Polling Location text box.

  8. Click Advanced. In the Channel Name drop-down list, select Channel850toMOLP, and leave the defaults in the other data items.

  9. Click OK to close the Advanced dialog box, and then click OK to close the Add a File Receive Function dialog box.


Run the Sample Scenario

  1. The sample is run by placing the X12 instance Fabrikam850.edi into the Fabrikam folder and observing XML output to the Microsoft folder and the EDI receipt output to the Fabrikam/Receipts folder.

  2. Verify that the BizTalk service is running by making sure that a green arrow appears on your server icon in the BizTalk Server Administration MMC (server is immediately below Receive Functions in the tree); right-click the icon and click Start on the context menu if no green arrow is displayed.

  3. Copy Fabrikam850.edi to c:\EDIReceipts\Fabrikam and wait.

  4. Open the c:\EDIReceipts\Microsoft folder and look for a file called xmlpotomolp_%tracking_id%.xml, where the %tracking_id% symbol will be replaced with a GUID value.

  5. Open the c:\EDIReceipts\Fabrikam\Receipts folder and look for a file called EDItofabrikam_%tracking_id%.edi, where the %tracking_id% symbol will be replaced with a GUID value.


EDI Introduction

This sample demonstrates how to configure BizTalk Server to support XML documents flowing outbound from the home organization to an external trading partner using the EDI X12 855 document format.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\EDI Introduction

User's Guide

An internal application (MOLP) of the home organization (Microsoft) submits XML documents to BizTalk Server. These files are then mapped to an X12 EDI format and transported to the recipient trading partner (Fabrikam).

This sample uses only file transport to simulate the scenario, and does not use BizTalk Orchestration Services. XML documents from Microsoft are dropped in one directory, and the transformed X12 EDI documents are generated as output in another directory on the local file system.

Note

  • If you have run setup.cmd on the EDI and Receipts sample, you must run setup.cmd again on this sample for the scenario to work correctly.

To run the sample, follow these steps:

  1. Run setup.cmd in the sample directory to configure the scenario.

    Configuration involves the creation of the following BizTalk Server objects:

    • Organizations: Microsoft (default organization), Fabrikam

    • Document Definitions: Fabrikam855, MicrosoftPOAck

    • Envelope: EDItoFabrikam

    • Port: EDIPortToFabrikam

    • Channel: Channel855toFabrikam

    • Receive Function: XMLAcks

    Files are copied onto the C drive. Make the necessary modifications in setup.cmd and ConfigureEDI.vbs if the C drive does not exist.

  2. With BizTalk Server running, navigate to c:\EDIIntroduction\ and copy the file MOLPpoAck.xml into c:\EDIIntroduction\Microsoft.

    This file should be consumed by BizTalk Server, transformed, and submitted to C:\EDIIntroduction\Fabrikam as the file EDItoFabrikam_%tracking_id%.edi, where %tracking_id% is a unique ID value.

To walk through how the sample is prepared, follow these steps:

  • Set Up Organizations and Associated Identifiers

  • Set Up Source Specification

  • Set Up Destination Specification

  • Set Up Map for Converting XML to X12

  • Create Document Definition for Microsoft

  • Create Document Definition for Fabrikam

  • Define EDI Selection Criteria for Fabrikam

  • Create EDI Envelope

  • Create Port for Delivering EDI to Fabrikam

  • Create Channel from Microsoft to Fabrikam

  • Create File Receive Function

  • Run the Sample Scenario

  • Troubleshooting

Programming Notes

Electronic data interchange (EDI) is a set of standards for controlling the exchange of business documents (such as purchase orders and invoices) between computers. Although standardization efforts for EDI formats began in the 1960s, the expensive setup and operational costs of EDI server systems and the somewhat cryptic EDI document formats limited its use.

BizTalk Server supports the EDIFACT standard adopted in 1987 by the International Organization for Standardization (ISO) as well as the older X12 standard used primarily for American domestic trade. This sample goes through the transmission of a purchase order acknowledgement from Microsoft to Fabrikam using the X12 standard.

The schemas and maps for this sample are completed and are available for review to get a better understanding.


Set Up Organizations and Associated Identifiers

This section creates the home organization (Microsoft), the application within the home organization (MOLP), and the destination organization (Fabrikam). It also sets up the organizational identifiers that uniquely determine how the EDI interchange is processed.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and click BizTalk Messaging Manager.

  2. If the BizTalk Messaging Manager dialog box appears, click Cancel.

  3. In the left frame, click Organizations, and then click Search Now.

  4. Verify that Microsoft is the home organization.

    The home organization is indicated by (Default) next to the name. The dialog box that appears when you double-click the home organization should have three tabs.

  5. Click the Applications tab in the Organization Properties dialog box for Microsoft.

  6. Click Add, type MOLP, and then click OK.

  7. Click the Identifiers tab in the Organization Properties dialog box for Microsoft.

  8. Click Add, click Custom, and type any name you like (for example, MyD&Bnumber) in the Custom box.

  9. Enter 01 for Qualifier and 081466849 for Value. Click OK twice.

  10. Add the external trading partner organization Fabrikam by right-clicking the organization view window and clicking New Organization on the context menu.

  11. Click the Identifiers tab in the Organization Properties dialog box for Fabrikam.

  12. Click Add, click Custom, and type any name you like in the Custom box

  13. Enter 01 for Qualifier and 0123456789 for Value. Click OK twice.


Set Up Source Specification

The file schMicrosoftPOAck.xml contains the XML source specification for the purchase order acknowledgement that is sent from Microsoft. Look at this document, validate it against an instance (MOLPpoAck.xml), and store it to the WebDAV repository for future use.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Editor.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select schMicrosoftPOAck.xml.

  3. Examine the specification by clicking the nodes (for example, the root node MicrosoftPOAck) and clicking Expand Tree Items on the View menu or clicking the expand indicator (+).

  4. On the Tools menu, click Validate Instance and provide the file name MOLPpoAck.xml (in the same folder as other files used in this sample).

    The message "The document instance validation succeeded" is shown if the instance test worked.

  5. On the File menu, click Store to WebDAV and place the schema into the BizTalk Server repository under the name schMicrosoftPOAck.xml.


Set Up Destination Specification

The file schFabrikam855.xml contains the specification for the X12 version release 4010 purchase order acknowledgement (855) that Fabrikam expects to receive. Review this document, validate the specification, and store it to the WebDAV repository for future use.

  1. In BizTalk Editor, open schFabrikam855.xml and expand the specification tree as before.

  2. On the Tools menu, click Validate Specification.

  3. On the File menu, click Store to WebDAV and place the specification into the BizTalk Server WebDAV repository under the name schMicrosoftPOAck.xml.


Set Up Map for Converting XML to X12

The file mapMicrosoftPOAcktoFabrikam855.xml specifies how the XML source specification should be converted to the X12 destination specification. Review and compile the map, and store it to WebDAV for future use.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Mapper.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select mapMicrosoftPOAcktoFabrikam855.xml.

  3. On the Tools menu, click Compile Map, or press F5, or click the toolbar icon that is second from the right.

  4. Review warnings.

    One type of warning appears: "Warning: The required field 'X' has no incoming link or constant value." Mapping will occur as expected even with this warning. It can be ignored because the field's parent will not be created, and therefore the field itself cannot violate the validation criteria because it will not actually exist.

  5. On the File menu, click Store to WebDAV, and place the map into the BizTalk Server repository under the name mapMicrosoftPOAcktoFabrikam855.xml.


Create Document Definition for Microsoft

In this procedure, you create a document definition MicrosoftPOAck for the Microsoft purchase order acknowledgement that is based on schMicrosoftPOAck.xml.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. In the left frame, click Document Definitions, and then click Search Now.

  3. Right-click in the right frame and click New Document Definition on the context menu.

  4. Type MicrosoftPOAck in the Document definition name box.

  5. Select the Document specification check box.

  6. Click Browse and select schMicrosoftPOAck.xml from the repository list of schemas.

  7. Click OK.


Create Document Definition for Fabrikam

In this procedure, you create a document definition Fabrikam855 for the Fabrikam X12 855 based on schFabrikam855.xml. A document definition for EDI also involves specifying the selection criteria, which is the subject of the next section.

  1. Right-click in the right frame of BizTalk Messaging Manager and click New Document Definition on the context menu.

  2. Type Fabrikam855 in the Document definition name box.

  3. Select the Document specification box.

  4. Click Browse and select schFabrikam855.xml from the repository list of schemas.

  5. Click OK.


Define EDI Selection Criteria for Fabrikam

The selection criteria is a list of name/value pairs that will allow the BizTalk messaging engine to uniquely identify the appropriate document definition for an EDI document. This is necessary because multiple EDI documents can be contained in a single interchange and multiple document types can be mixed within an interchange.

  1. Click the Selection Criteria tab for the Fabrikam855 document definition.

  2. Click Add. For Name, type application_receiver_code, for Value, type 0123456789, and then click OK.

  3. Repeat step 2 to create three more Selection Criteria name/value pairs:
    • application_sender_code / MAXCIM

    • functional_identifier / PR

    • standards_version / 004010
  4. Click OK to complete the document definition.


Create EDI Envelope

This section will define the EDItoFabrikam envelope. Envelopes are needed whenever you are using non-XML documents. A particular envelope is associated with a particular type of document (for example, X12), and contains information that the BizTalk messaging engine needs to route the document.

  1. In BizTalk Messaging Manager, click Envelopes in the left frame, and then click Search Now.

  2. Right-click in the right frame and click New Envelope on the context menu.

  3. Type EDItoFabrikam in the Name box, choose X12 from the Envelope Format drop-down list, and then click OK.


Create Port for Delivering EDI to Fabrikam

This procedure will create the port EDIPortToFabrikam.

  1. In BizTalk Messaging Manager, click Messaging ports in the left frame and then click Search Now.

  2. Right-click in the right frame, point to New Messaging Port, and click To an Organization.

  3. Type EDIPortToFabrikam in the Name box, leave Comments blank, and then click Next.

  4. The Organization option button should be pre-selected. Click Browse to select the organization name Fabrikam from the list, and then click OK.

  5. Create the directory c:\EDIIntroduction\Fabrikam\. This will be the location where Fabrikam receives the X12 855 documents.

  6. In the Primary Transport dialog box, click Browse, and choose File as the Transport Type.

  7. Type (after file://) c:\EDIIntroduction\Fabrikam\EDItofabrikam_%tracking_id%.edi as the file name, click OK, and then click Next.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  8. Under Envelope Information, select EDItoFabrikam in the drop-down list.

    Note

    • You can also create an envelope at this point, if you did not do it previously in Create EDI Envelope.
  9. Click Delimiters and type the delimiters ~, *, and >. Click OK.

    In this case, it does not matter what your delimiters are because there is no real business partner on the other end. In real scenarios, the delimiters are agreed upon between you and your business partners.

  10. In the Interchange Control Number dialog box, type a non-zero number.

  11. Under Organization Identifier select the 0123456789 ID from the drop-down list, and then click Next.

  12. Clear the Create a channel for this messaging port check box, and click Finish.


Create Channel from Microsoft to Fabrikam

This procedure will create the channel Channel855toFabrikam.

  1. Right-click the EDIPortToFabrikam created previously, and click New Channel | From an Application.

    Alternatively, you could leave the Create a channel for this messaging port check box selected at the end of the New Messaging Port dialog

  2. For Name type Channel855toFabrikam, and then click Next.

  3. The Application option button should be pre-selected. Choose MOLP from the drop-down list of application names.

  4. Select the 081466849 qualifier from the drop-down list, and then click Next.

  5. Under Inbound Document Definition Name click Browse and select the document definition MicrosoftPOAck, click OK, and then click Next.

  6. Under Outbound Document Definition Name click Browse and select the document definition Fabrikam855, and then click OK.

  7. The Map Inbound Document check box should be pre-selected. Click Browse and choose MicrosoftPOAcktoFabrikam855.xml from the maps repository, click OK, and then click Next.

  8. Select any document storage options that interest you for the purpose of viewing in BizTalk Document Tracking (see Start menu), and then click Next.

  9. Type an integer value in the Group Control Number box.

    The value is not especially important. You will see that repeated document flows through this channel will result in serially incremented values for this number.

  10. Click Advanced, click the Envelope tab, and then click Properties. Review the dialog box where you will access the values to be used when creating the interchange envelope (no changes to these values are necessary for the sample).

  11. Click Finish.


Create File Receive Function

This section will create the File receive function XMLAcks for Microsoft documents.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Server Administration.

  2. Expand the Microsoft BizTalk Server 2002 node in the left frame tree until the Queues and Receive Functions nodes are fully expanded.

  3. To add a new File receive function, click the Receive Functions node.

  4. On the Action menu, point to New and click File Receive Function.

  5. Type XMLAcks in the Name box. Comments can be left blank.

    The machine you are working on should be pre-selected in the drop-down list titled Server on which.

  6. Type *.XML in the File type to poll for box.

  7. Create the directory c:\EDIIntroduction\Microsoft

    This is the location where Microsoft will drop the XML documents to be sent to Fabrikam.

  8. Type c:\EDIIntroduction\Microsoft in the Polling Location box.

  9. Click Advanced. In the Channel Name drop-down list, select Channel855toFabrikam, and leave the defaults in the other data items.

  10. Click OK to close the Advanced dialog box, and then click OK to close the Add a File Receive Function dialog box.


Run the Sample Scenario

The sample is run by placing the XML instance MOLPpoAck.xml into the Microsoft folder and observing the EDI output to the Fabrikam folder.

  1. Verify that the BizTalk service is running by making sure that a green arrow appears on your server icon in the BizTalk Server Administration MMC (the server is immediately below Receive Functions in the tree); right-click the icon and click Start on the context menu if no green arrow is displayed.

  2. Copy MOLPpoAck.xml to c:\EDIIntroduction\Microsoft.

  3. Open the c:\EDIIntroduction\Fabrikam folder and look for a file called EDItofabrikam_%tracking_id%.edi (from step 7 of "Create Port for Delivering EDI to Fabrikam"), where the %tracking_id% symbol is replaced with a GUID value.


Troubleshooting

If the MOLPpoAck.xml file is not picked up and deleted from c:\EDIIntroduction\Microsoft after a reasonable time period, check that the receive function XMLAcks in BizTalk Server Administration is correctly configured by right-clicking on the receive function and clicking Properties. Also make sure that the Disable receive function check box is cleared.

If MOLPpoAck.xml is picked up but there is no output in the c:\EDIIntroduction\Fabrikam directory, check the Suspended queue in BizTalk Server Administration for the error description.


Encryption and Decryption

This sample walks through the process of setting up a secure document exchange between two trading partners. This sample demonstrates the use of digital certificates to:

  • Encrypt an outgoing document

  • Sign an outgoing document

  • Decrypt an incoming document

  • Verify the signature on an incoming document

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Encryption

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup (setup.cmd)

  • Obtain and Install Digital Certificates

  • Create Secure Ports and Channels

  • Create File Receive Functions

  • Run the Sample Scenario

Programming Notes

The sample scenario simulates establishing secure communications between two organizations: Buyer and Home. These organizations can be considered as separate Web sites.

A flat-file purchase order, myPO.csv, is sent from Buyer to Home. Because the purchase order is considered sensitive, the information needs to be encrypted and signed by Buyer before it is transported. Encryption prevents documents from being viewed by unauthorized individuals. Signing ensures that a document is authentic and unaltered. Home decrypts, verifies, and transforms the purchase order as an XML document of decision factors.

This sample requires obtaining certificates for each organization to perform the encryption, decryption, and digital signature. It is recommended that you familiarize yourself with certificates before using this sample.


Preliminary Setup (setup.cmd)

Running setup.cmd in the sample directory performs the following tasks, which are described in detail in the following topics:

  • Create Folders

  • Create Organizations

  • Create Document Definitions

  • Set Up Map

  • Create Envelope

If you encounter errors, be sure to clear out all conflicting organizations, document definitions, and so on that are used in this scenario before running setup.cmd.


Create Folders

In this procedure, you create one folder that contains three subfolders. Each subfolder simulates an organization in the scenario.

To create the folders:

  1. In Windows Explorer, browse to the root directory of your C drive.

  2. Create a new folder on the root of the C drive; name the folder Encryption.

  3. Click the new Encryption folder and create three subfolders with the following names:
    • Buyer

    • Home

    • Approver


Create Organizations

In this procedure, you will create the three organizations in the scenario.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. If the BizTalk Messaging Manager dialog box appears, click Cancel.

  3. In the left frame, click Organizations, and then click Search Now.

  4. Right-click the organization view window and click New Organization on the context menu.

  5. Type Buyer in the Organization name box and click OK.

  6. Repeat steps 4 and 5 for the Home and Approver organizations.


Create Document Definitions

In this procedure, you will examine and store three document specifications to WebDAV and create three document definitions that are based on the following specifications:

  • BasicPO. The purchase order sent by Buyer for approval.

  • DecisionFactors. The decision factors extracted from the basic purchase order that are relevant for approval.

  • Response. The final approval response: yes or no.

  • To create the document definitions:
  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Editor.

  2. For each of the following document specifications, on the File menu, click Store to WebDAV, and store these document specifications in the same folder:

    defBasicPO.xml

    defDecisionFactors.xml

  3. In the left frame of BizTalk Messaging Manager, click Document definitions, and then click Search Now.

  4. Right-click in the right frame and click New Document Definition on the context menu.

  5. Type BasicPO in the Document definition name box.

  6. Select the Document specification check box and click Browse.

  7. Select defBasicPO.xml in the WebDAV repository and click Open.

  8. Click OK to close the New Document Definition dialog box.

  9. Repeat steps 4-8 for the document specification defDecisionFactors.xml, naming it DecisionFactors.


Set Up Map

The file mapBasicPO_DecisionFactors.xml specifies how the BasicPO source specification should be converted to the DecisionFactors destination specification. Review and compile the map, and store it to WebDAV for future use.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Mapper.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select mapBasicPO_DecisionFactors.xml.

  3. On the Tools menu, click Compile Map, or press F5, or click the toolbar icon that is second from the right.

  4. On the File menu, click Store to WebDAV, and place the map into the BizTalk Server repository under the name mapBasicPO_DecisionFactors.xml.


Create Envelope

In this procedure you will create the BasicPOEnv envelope that is used to wrap the flat-file purchase order that is sent from Buyer. Envelopes are needed whenever you are using non-XML documents.

  1. In the left frame of BizTalk Messaging Manager, click Envelopes and then click Search Now.

  2. Right-click in the right frame and click New Envelope on the context menu.

  3. Type BasicPOEnv in the Name text box.

  4. Select FLATFILE from the Envelope Format drop-down list.

  5. Select the Envelope specification check box and click Browse.

  6. Click defBasicPO.xml in the WebDAV repository and click Open.

  7. Click OK to close the New Envelope dialog box.


Obtain and Install Digital Certificates

This sample requires the use of two certificates. These certificates must either be obtained from a trusted certification authority (CA), or be created by using Microsoft Certificate Services. One certificate will be denoted as the Buyer certificate, and the other as the Home certificate. A purchase order will be encrypted and signed, and then decrypted and verified with these two certificates.

To create the certificates by using Microsoft Certificate Services, follow these guidelines. Note that these guidelines are subject to change. For more information about creating certificates, see the Certificate Services Help file that is available in the Certification Authority MMC snap-in.

  • Install Certificate Services

  • Request Certificates

  • Issue Certificates

  • Install MMC Certificates Snap-in

  • Install Certificates to Personal Store

  • Install Certificates to BizTalk Store


Install Certificate Services

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Add/Remove Programs.

  3. Click Add/Remove Windows Components, click Certificate Services, and then click Next.

  4. Complete the steps in the Certificate Services installation wizard.

    For this sample, it is sufficient to use the wizard's default selected options.


Request Certificates

  1. Use your browser to navigate to http://localhost/certsrv/default.asp.

  2. Click Request a certificate and then click Next.

  3. Select Advanced request and then click Next.

  4. Select Submit a certificate request to this CA using a form and then click Next.

  5. Under Identifying Information, enter Buyer as the Name.

    Enter other identifying information as desired.

  6. Under Key Options, select Mark keys as exportable and Use local machine store.

    Keeping these options selected ensures that the certificate gets installed on the local computer and can be exported to a file.

  7. Click Submit.

  8. Repeat steps 2 through 7, changing the certificate name to Home.


Issue Certificates

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Certification Authority.

  4. Fully expand the Certificate Authority tree and click the Pending Requests folder.

    Two new requests for certificates should appear.

  5. Select both new pending requests and right-click.

  6. Click All Tasks, and then click Issue.

    The requests should now disappear from the Pending Requests folder.

  7. Verify that the certificates now appear in the Issued Certificates folder.


Install MMC Certificates Snap-in

BizTalk Server uses the Local Computer certificate store to locate digital certificates. Install the MMC Certificates snap-in to be able to manage the certificates.

  1. On the Start menu, click Run, and then type mmc to start Microsoft Management Console.

  2. On the Console menu, click Add/Remove Snap-in.

    The Add/Remove Snap-in dialog box is displayed.

  3. Click Add and select Certificates.

  4. Select Computer account as the account for which the snap-in will manage certificates.

  5. Click Next to go to the Select Computer dialog box.

  6. The default Local computer should be selected. Click Finish.

  7. Click Close to close the Add Standalone Snap-in dialog box.

  8. Click OK to close the Add/Remove Snap-in dialog box.

  9. Keep the Console window open to verify installation in future steps.


Install Certificates to Personal Store

  1. Use your browser to navigate to http://localhost/certsrv/default.asp.

  2. Click Check on a pending certificate and then click Next.

  3. Click the first certificate request and then click Next.

  4. Click Install this certificate.

  5. Open the Microsoft Management Console window with the Certificates snap-in installed.

  6. Navigate to Certificates (Local Computer) | Personal | Certificates in the left frame.

  7. Verify that a new certificate with the name specified (for example, Buyer) has been installed.

  8. Repeat steps 2 through 7 to install the remaining certificate request.


Install Certificates to BizTalk Store

  1. In the Console window, right-click the Buyer certificate, and select All Tasks | Export.

    The Certificate Export Wizard appears.

  2. Click Next.

  3. In the Export Private Key dialog box, select No, do not export the private key, and then click Next.

    The BizTalk Server store does not require certificates with private keys.

  4. Click Next to get to the File to Export dialog box.

  5. Click Browse and enter a file name for the exported certificate (for example. c:\Encryption\buyer.cer).

    Remember the certificate location and file name for future steps.

  6. Click Next and then click Finish.

    A dialog should appear indicating that the export was successful.

  7. Repeat the preceding steps to export the Home certificate.

  8. In the left frame of the Console, right-click the BizTalk folder under Certificates (Local Computer).

  9. Click All Tasks, and then click Import.

    The Certificate Import Wizard appears.

  10. Click Next.

  11. Click Browse to navigate to and select the Buyer certificate.

  12. Click Next, click Next again, and then click Finish.

    A dialog should appear indicating that the import was successful.

  13. Repeat the preceding steps to import the Home certificate.

  14. Navigate to Certificates (Local Computer) | BizTalk | Certificates to verify that the two certificates have been imported.


Create Secure Ports and Channels

This section shows how to create ports and channels that carry out encryption, decryption, signing, and verification. Two ports and two channels will be created.

This section contains the following topics:

  • Create Port and Channel to Encrypt and Sign Outbound Files

  • Create Port and Channel to Receive Encrypted and Signed Files


Create Port and Channel to Encrypt and Sign Outbound Files

In this section, you will create the port BuyerEncryptPort and the associated channel BuyerEncryptChannel to encrypt and sign documents. Because the documents are sent from Buyer to Home, they need to be encrypted with Home's public key and signed with Buyer's private key. The certificates used for signing and encryption will be specified in the properties of both the port and the channel.

  1. In Biztalk Messaging Manager, on the File menu, click New, click Messaging Port, and then click To an Organization.

    The New Messaging Port Wizard opens.

  2. In the Name box, type BuyerEncryptPort and then click Next.

  3. On the Destination Organization page, in the Organization area, click Browse.

  4. Select Buyer from the list of available organizations, and then click Next.

  5. In the Primary Transport box, click Browse, and choose File as the Transport Type.

  6. Type (after file://) c:\Encryption\Buyer\Encrypted\myPO_%tracking_id%.txt as the file name.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  7. Click OK to close the Primary Transport dialog box.

  8. Click Next twice to get to the Security Information page.

  9. In the Encryption group box, select S/MIME from the Type drop-down list and click Browse.

    A list appears, showing certificates that are stored on the computer with public keys.

  10. Select the Home digital certificate and click OK.

  11. In the Signature group box, select S/MIME from the Type drop-down list.

    The digital certificate used to sign the document will be specified in the channel.

  12. Verify that the Create a channel for the messaging port check box is selected.

  13. Select "From an organization" as the Channel Type and click Finish.

    The New Channel Wizard opens.

  14. On the General Information page, in the Name box, type BuyerEncryptChannel and click Next.

  15. On the Source Organization page, in the Organization area, click Browse.

  16. Select Buyer from the list of available organizations, and then click Next.

  17. On the Inbound Document page, click Browse and select BasicPO as the document definition.

  18. Click Next.

  19. On the Outbound Document page, click Browse and again select BasicPO as the document definition.

  20. Select "Sign outbound document" and click Browse.

    A list appears, showing certificates that are stored on the computer with private keys.

  21. Select the Buyer digital certificate and click OK.

  22. Click Next twice, and then click Finish.


Create Port and Channel to Receive Encrypted and Signed Files

In this section, you will create the port SubmitPort and the associated channel BuyerHomeChannel for transporting an encrypted and signed purchase order from the Buyer to the Home organization. The flat-file purchase order has been signed with Buyer's private key and encrypted with Home's public key. Therefore, it needs to be verified with Buyer's public key and decrypted with Home's private key. The certificates that are used for verification and decryption will be specified in the properties of BuyerHomeChannel.

  1. In BizTalk Messaging Manager, on the File menu, click New, click Messaging Port, and then click To an Organization.

    The New Messaging Port Wizard opens.

  2. In the Name box, type SubmitPort and click Next.

  3. On the Destination Organization page, in the Organization area, click Browse.

  4. Select Home from the list of available organizations, and then click Next.

  5. In the Primary Transport box, click Browse, and choose File as the Transport Type.

  6. Type (after file://) c:\Encryption\Home\DecisionFactor_%tracking_id%.xml as the file name.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  7. Click OK to close the Primary Transport dialog box.

  8. Click Next twice.

  9. On the Security Information page, verify that the Create a channel for the messaging port check box is selected.

  10. Select "From an organization" as the Channel Type, and click Finish.

    The New Channel Wizard opens.

  11. On the General Information page, in the Name box, type BuyerHomeChannel and click Next.

  12. On the Source Organization page, in the Organization area, click Browse.

  13. Select Buyer from the list of available organizations, and then click Next.

  14. On the Inbound Document page, click Browse and select BasicPO as the document definition.

  15. Select Verify decryption on inbound document, and click Browse.

    A list appears, showing certificates that are stored on the computer with private keys.

  16. Select the Home digital certificate and click OK.

    Because Home's public key was used to encrypt the purchase order, Home's private key must be used to decrypt it.

  17. Select Verify signature on inbound document, and click Browse.

    A list appears, showing certificates that are stored on the computer with public keys.

  18. Select the Buyer digital certificate and click OK.

    Because Buyer's private key was used to sign the purchase order, Buyer's public key must be used to verify the signature.

  19. Click Next.

  20. On the Outbound Document page, click Browse and select DecisionFactors as the document definition.

  21. Make sure that "Map inbound document to outbound document" is selected.

  22. Click Browse in the Map reference area and select mapBasicPO_decisionfactors.xml.

  23. Click Next twice, and then click Finish.


Create File Receive Functions

This section will create two File receive functions, BuyerReceiveFunction and BuyerEncryptedReceiveFunction, for picking up documents in c:\Buyer and c:\Buyer\Encrypted, respectively.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Server Administration.

  2. Expand the Microsoft BizTalk Server 2002 item in the left frame tree until the Queues and Receive Functions nodes are fully expanded.

  3. Add a new File receive function either by clicking the Receive Functions node and choosing Action | New | File Receive Function from the menu bar or by right-clicking the Receive Functions node and choosing New | File Receive Function from the context menu.

  4. Type BuyerReceiveFunction in the Name box. Comments can be left blank. The computer you are working on should be pre-selected in the drop-down list titled Server on which.

  5. Type myPO.csv in the text box labeled File type to poll for.

  6. Type c:\Encryption\Buyer in the text box labeled Polling Location.

  7. Click Advanced.

  8. In the Envelope Name drop-down list, select BasicPOEnv.

  9. In the Channel Name drop-down list, select BuyerEncryptChannel.

  10. Click OK to close the Advanced dialog box, and OK to close the Add a File Receive Function dialog box.

  11. Add the second File receive function with the name BuyerEncryptReceiveFunction.

  12. Type myPO*.txt in the text box labeled File type to poll for.

  13. Type c:\Encryption\Buyer\Encrypted in the text box labeled Polling Location.

  14. Click Advanced.

  15. In the Envelope Name drop-down list, select BasicPOEnv.

  16. In the Channel Name drop-down list, select BuyerHomeChannel.

  17. Click OK to close the Advanced dialog box, and OK to close the Add a File Receive Function dialog box.


Run the Sample Scenario

To run the sample, put the comma-delimited purchase order myPO.csv into the c:\Encryption\Buyer folder. This file gets signed and encrypted, and finally is transformed as a decision factor output to the c:\Encryption\Home folder.

This section contains the following topics:

  • Disable Intermediate Receive Function

  • Encrypt and Sign an Outbound Document

  • Receive an Encrypted and Signed Purchase Order


Disable Intermediate Receive Function

Temporarily disabling the receive function BuyerEncryptReceiveFunction will allow the intermediate signed and encrypted purchase order to be viewed.

  1. In the left frame of BizTalk Server Administrator, expand the tree down to the level of the Receive Function nodes.

  2. Right-click the receive function BuyerEncryptReceiveFunction and click Properties.

  3. Select the Disable receive function check box on the General tab.

  4. Click Yes to confirm.

  5. Click OK to close the receive function properties.


Encrypt and Sign an Outbound Document

  1. With BizTalk Server running, navigate to c:\Encryption\ and copy the file myPO.csv into c:\Encryption\Buyer.

    This file should be consumed by BizTalk Server, transformed, and submitted to c:\Encryption\Buyer\Encrypted as the file myPO_%tracking_id%.txt, where %tracking_id% is a unique ID value.

  2. Open c:\Encryption\Buyer\Encrypted\myPO_%tracking_id%.txt in Notepad to see that the content has been encrypted and signed.

  3. Close c:\Encryption\Buyer\Encrypted\myPO_%tracking_id%.txt.


Receive an Encrypted and Signed Purchase Order

  1. Enable the BuyerEncryptReceiveFunction by clearing the Disable receive function check box under the Properties of the receive function.

    The file myPO_%tracking_id%.txt in the c:\Encryption\Buyer\Encrypted folder should be consumed.

  2. Open the c:\Encryption\Home folder and look for a file called decisionfactor_%tracking_id%.xml, where the %tracking_id% symbol will be replaced with a GUID value.

  3. Open decisionfactor_%tracking_id%.xml in Notepad or Internet Explorer to verify that the content is valid XML.


Flat-File Delimited

This sample translates an inbound delimited flat-file source document into an XML destination document.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Flat-File Delimited

User's Guide

Before running the sample, complete the following steps:

  1. On the C drive, create a folder called FlatFileDelimited.

  2. On the C drive, create a folder called XMLDest.

  3. Copy FlatFileDelimited.xml to the folder \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft on the installation drive.

  4. Run FlatFileDelimitedSetup.vbs to configure BizTalk Messaging Services.

Note

  • The BizTalk Messaging Services configuration script, FlatFileDelimitedSetup.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Channel: Flat File Delimited To XML Channel

    2. Port: Flat File Delimited to XML Port

    3. Organization: Flat File Delimited Sample Org

    4. Document definition: Flat File Delimited to XML

    5. Envelope: Flat File Delimited Envelope

    6. File receive function: FlatFileDelimited

To run the sample, follow these steps:

  1. Ensure that the FlatFileDelimitedSampleData.txt file is not read-only. To modify this property, right-click the file, click Properties, clear the Read-only attribute, and then click OK.

  2. Copy and paste the flat file, FlatFileDelimitedSampleData.txt, to the C:\FlatFileDelimited folder. You should see an output XML file in the C:\XMLDest folder.

Programming Notes

The same document specification, FlatFileDelimited.xml, is used for both the inbound and outbound documents, so a map is not required.

Related Topic

Working with Positional and Delimited Flat Files


Flat-File Positional

This sample translates an inbound positional flat-file source document into an XML destination document.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Flat-FilePositional

User's Guide

Before running the sample, complete the following steps:

  1. On the C drive, create a folder called FlatFilePosSample with two subfolders called SourceOrg and DestOrg.

  2. On the BizTalk Server installation drive, copy FlatFilePosSpec.xml to \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

  3. Run FlatFilePosConfig.vbs to configure BizTalk Messaging Services.

To run the sample, follow these steps:

  1. Ensure that the FlatFilePosSampleData.txt file is not read-only. To modify this property, right-click the file, click Properties, clear the Read-only attribute, and then click OK.

  2. Copy and paste the flat file, FlatFilePosSampleData.txt, to the C:\FlatFilePosSample\SourceOrg folder. You should see an output XML file in the C:\CustomCounterSample\DestOrg folder.

Note

  • The BizTalk Messaging Services configuration script, FlatFilePosConfig.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Channel: FlatFile Positional Channel

    2. Messaging Port: FlatFile Positional Port

    3. Organizations: FlatFilePos Source Organization, FlatFilePos Destination Organization

    4. Document Definition: FlatFilePosDef

    5. Envelope: FlatFilePosEnv

    6. File Receive Function: FlatFilePos

Programming Notes

The same document specification, FlatFilePosSpec.xml, is used for both the inbound and outbound documents, so a map is not required.

Related Topic

Working with Positional and Delimited Flat Files


HTTP Receive Function

This sample illustrates how an online buyer organization delivers a purchase order (PO) to a supplier organization through a Web-based front end. The information is converted to an XML document and is sent to BizTalk Server by using an HTTP receive function.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function

User's Guide

To prepare and run the sample, follow these steps:

  • Set Up the Web Site Environment

  • Run the HTTP Receive Function Sample

Note

  • This sample assumes that BizTalk Server is installed on your C drive. If this is not the case, you should make the appropriate path modifications.


Set Up the Web Site Environment

This section shows you how to set up the Web-based order entry screen, the IIS virtual directory, and the objects that are needed to create and deliver an XML document by using an HTTP receive function.

This section contains the following topics:

  • Create a Web Application

  • Configure the IIS COM+ Package

  • Examine Default.htm

  • Examine ProcessPO.asp

  • Create an HTTP Receive Function


Create a Web Application

In this procedure, you create a Web application to host the order entry form and send the contents to the HTTP receive function.

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Internet Services Manager.

    The Internet Services Manager console appears.

  4. In the Internet Services Manager console tree, expand the <your computer> node.

  5. Right-click Default Web Site.

  6. On the Action menu, click New, and then click Virtual Directory.

    The Virtual Directory Creation Wizard appears.

  7. On the Welcome to the Virtual Directory Creation Wizard page, click Next.

  8. On the Virtual Directory Alias page, in the Alias box, type PurchaseSite and then click Next.

  9. On the Web Site Content Directory page, click Browse.

  10. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function, click OK, and then click Next.

  11. On the Access Permissions page, make sure that the Execute (such as ISAPI applications or CGI) option is selected and then click Next.

  12. Click Finish to close the Virtual Directory Creation Wizard.

  13. Right-click PurchaseSite.

  14. On the menu that appears, click Properties.

  15. In the Virtual Directory section, make sure that Execute Permissions is set to Scripts and Executables.

  16. In the same section, change the Application Protection option to High (Isolated).

  17. Click OK.

  18. Copy the BizTalkHTTPReceive.dll file to the location that was specified on the Web Site Content Directory page during the creation of the virtual directory.


Configure the IIS COM+ Package

In this procedure, you modify the account under which the Internet Information Services component runs for PurchaseSite.

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Component Services.

  4. In the Component Services Manager console tree, expand the Component Services node.

  5. Expand Computers, and then expand COM+ Applications.

  6. Right-click IIS-{Default Web Site//Root/PurchaseSite}.

  7. Click Properties.

  8. The IIS-{Default Web Site//Root/PurchaseSite} Properties manager appears.

  9. Click the Identity tab.

  10. Change the account under which the application will run to Interactive user – the current logged on user, or to a user with the appropriate authority.


Examine Default.htm

Look at Default.htm. This HTML file is located in the HTTP Receive Function sample folder, and is a Web-based entry form that will post the information entered to the ProcessPO.asp file.


Examine ProcessPO.asp

Look at ProcessPO.asp. This .asp file is located in the HTTP Receive Function sample folder, and accepts the information that Default.htm sends to it. This .asp file takes the information that is entered in the HTTP form, converts the information into well-formed XML, and posts the XML to the PurchaseSiteFunc HTTP receive function.


Create an HTTP Receive Function

In this procedure, you create an HTTP receive function to process the purchase order.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  2. Expand Microsoft BizTalk Server, expand BizTalk Server Group, and then click Receive Functions.

  3. On the Action menu, point to New, and then click HTTP Receive Function.

    The Add an HTTP Receive Function dialog box appears.

  4. In the Name box, type PurchaseSiteFunc.

  5. In the Server on which the receive function will run box, click the name of a server in the BizTalk Server group.

  6. In the Virtual directory box, type PurchaseSite/biztalkhttpreceive.dll?PO.

  7. In the Submit to drop-down list box, select the File option.

    You can also configure the HTTP receive function to send the data received to BizTalk Server synchronously or asynchronously.

  8. In the File Path and Name box, type \Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function\PurchaseOrder_%guid%.xml.

    This is the path of the file that the HTTP receive function will create. Notice that the GUID is used as a unique identifier.

  9. Click OK to close the Add a File Receive Function dialog box.

  10. Close BizTalk Server Administration.


Run the HTTP Receive Function Sample

This section shows you how to run the HTTP receive function sample.

  1. Open your Web browser.

  2. Point your browser to the virtual directory that you created earlier (for example, http://localhost/PurchaseSite).

    This will bring up the HTTP Receive Function Sample Purchase Order Form.

  3. Enter information in the various fields and then click Submit.

    This will send the information that you just entered to the ProcessPO.asp file. This .asp file will convert the information into well-formed XML and then post the information to the PurchaseSiteFunc HTTP receive function that you created earlier.

  4. A reply message will be displayed stating that the BizTalk Server system has processed your order.

    You can verify this by looking in the \Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function directory for an XML file.


Mapping Twice

This sample demonstrates mapping a document from its source to its destination by using two iterations.

Biztalk Server allows you to map a document synchronously through two iterations by using SubmitSync and the Loopback transport service. You can break your mapping into various stages by reusing and combining different channels.

In this scenario, we will first map Input.xml (which is hard-coded in the Microsoft Visual Basic source) to an intermediate XML file by using 1stMap.xml. A message box will report the resulting IntermediateOutput.xml file. Then we will map IntermediateOutput.xml to the final destination, producing FinalOutput.xml.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Mapping Twice

User's Guide

Before running the sample, complete the following steps:

  1. In the Mapping Twice sample directory, double-click the DocSpecs folder.

  2. Copy the Microsoft folder and paste it into the DocSpecs repository at:

    \Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs

  3. In the Mapping Twice sample directory, double-click the Maps folder.

  4. Copy the Microsoft folder and paste it into the Maps Repository at:

    \Microsoft BizTalk Server\BizTalkServerRepository\Maps

  5. Double-click SetUp.vbs to run Setup.

To run the sample:

  • Run Mapping_Twice.exe.

Programming Notes

In the first mapping, the following files are used:

File name | Purpose
Input.xml | Source instance file
SourceDocSpec.xml | Source specification file
IntermediateDocSpec.xml | Intermediate specification file
1stMap.xml | Map source file
IntermediateOutput.xml | Intermediate instance after first mapping

In the second mapping, the following files are used:

File name | Purpose
IntermediateOutput.xml | Intermediate instance file
IntermediateDocSpec.xml | Intermediate specification file
DestinationDocSpec.xml | Destination specification file
2ndMap.xml | Map source file
FinalOutput.xml | Final instance after first mapping

When running the sample, the first Msgbox should correspond to /Data/IntermediateOutput.xml, and the second Msgbox should correspond to /Data/FinalOutput.xml.

The application will create two files in the Mapping Twice sample folder: SampleIntermediateOutput.xml and SampleFinalOutput.xml. These files hold the values in the two messages that are displayed when you run the Mapping_Twice.exe file.

The BizTalk Messaging Services configuration script, SetUp.vbs, should be run only once. If you want to run the script again, you must first delete the configuration objects, such as organizations, ports, channels, and so on, that were previously created by the script.


Message Queuing 4 MB Limit

This sample shows one way to process documents that exceed the Message Queuing maximum size limit. Depending on your requirements, this method might not be suitable.

Message Queuing is limited in the size of documents that can be processed. The maximum size document that Message Queuing supports is 4 MB if the document is in ASCII. The message queue can handle a maximum of 2 MB if the document is in Unicode.

In the Message Queuing 4 MB sample, a buyer organization delivers a large purchase order (PO) file, in excess of 4 MB, to a supplier organization by using the BizTalk Framework 2.0 reliable messaging protocol.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\MSMQ 4MB Limit

User's Guide

Before running the sample, complete the following steps:

  1. In the MSMQ 4MB Limit directory remove the read-only property on the following files:

    BigCustomerPO.xml

    CustomerPO.xml

    MSMQ 4MB Limit.skv

    MSMQ 4MB Limit.skx

  2. Copy the following files to the Biztalk Repository at \Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft:

    \Setup\Docs\customerid.xml

    \Setup\Docs\largeFileReceive.xml

  3. Create a private transactional queue named customeridq in the Computer Management tool. Be sure to modify the security settings for this queue to allow everyone full control.

  4. In the SetUp folder, run SetUp.cmd and follow the prompts.

  5. Close the Command window if it is still open.

  6. Install XML for SQL Server Web Release 1 (WR1) by finding the downloadable release at: www.microsoft.com/sql/downloads.

  7. Modify the CustomerPO.xml and BigCustomerPO.xml files so that they are editable. By default, the files are read-only. If the file attributes are not changed, the sample will not work correctly.

    XML for SQL Server is required for this sample.

Verify that the settings are correct:

  1. Open Biztalk Server Administration. Expand the Console Root until you see Receive Functions.

  2. Click filercv_CustomerPO. In the right pane, edit this File receive function by double-clicking filercv_CustomerPO.

  3. On the General tab, be sure that the Disable Receive Function check box is cleared.

  4. On the Services tab, be sure that the Polling Location is polling in the \POdrop folder in your Samples directory.

  5. Click OK.

  6. Click msmqrcv_CustomerID. In the right pane, edit this File receive function by double-clicking msmqrcv_CustomerID.

  7. On the General tab, be sure that the Disable Receive Function check box is cleared.

Modify the Orchestration schedule:

  1. Edit the Orchestration schedule by right-clicking MSMQ 4MB Limit.skv and selecting Edit With Orchestration Designer.

  2. Double-click the blue line connecting the port to the action "Receive CustomerID from Queue."

  3. Click Next four times until you see Message Specification Information.

  4. Click Browse and select the location of \Schemas\CustomerID.xml in the MSMQ 4MB Limit sample folder.

  5. Double-click the GetSQLData COM shape; this should open the COM Component Binding Wizard.

  6. Click Next twice.

  7. Under Class Information, double-click the GetSqlData folder to expand the component.

  8. Double-click the getData class.

  9. Click Finish.

    If a message box appears, click OK and perform the following steps:

    1. Double-click the red and blue lines connecting the port to the action "Call COM Object."

    2. Click Next.

    3. Click Finish.

    4. Click Yes in the dialog box.

    5. Open the Data Flow page by clicking the Data tab.

    6. Under the msg_CustomerID table, connect CustomerID to the strCust_ID in the getData_in table.

    7. Make the XLANG schedule by clicking Make XLANG MSMQ 4MB Limit.skx on the File menu.

    8. Be sure that XLANG MSMQ 4MB Limit.skx is being created in the MSMQ 4MB Limit samples directory.

    9. Click OK to replace the file.

Update the messaging port

  1. Open Biztalk Messaging Manager and search for all ports.

  2. Double-click the port_CustomerID port.

  3. Click Next.

  4. In the first input box under "New XLANG schedule" click Browse.

  5. Select MSMQ 4MB Limit.skx in your Samples directory.

  6. Click Finish.

To run the sample:

  • Copy CustomerPO.xml and paste it into \PODrop to run this sample. You should see a message box pop up momentarily. Check the Event Logs for errors. The CustomerPO.xml file is a small test file that will be processed in the same manner as a large file. To test a large file, copy the BigCustomerPO.xml file to the \PODrop directory. Processing a large file will take longer.

Programming Notes

The BizTalk Messaging Services configuration script, SetUp.cmd, should be run only once. If you want to run the script again, you must first delete the configuration objects, such as organizations, ports, channels, and so on, that were previously created by the script.

The following objects are created by the setup file:

Organizations

org_CustomerID

org_CustomerPO

Channels

channel_CustomerID

channel_CustomerPO

Document Definitions

docdef_CustomerID

docdef_CustomerPO

Messaging Ports

port_CustomerID

port_CustomerPO

Receive Functions (in BizTalk Server Administration):

filercv_CustomerPO

msmqrcv_CustomerID

Messaging Queues (in Computer Management)

customeridq

BizTalk Server Repository

largeFileReceive.xml

customerid.xml


Multi-Part MIME Attachment

This sample shows how BizTalk Server handles an inbound document that contains multiple MIME attachments.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Multi-Part MIME Attachment

User's Guide

Before running the sample, complete the following steps:

  1. On the Start menu, click Run.

  2. On the command line type CMD.

    This will bring up a Command Line window.

  3. Change the directory to the Multi-Part MIME Attachment sample directory.

  4. Type Config.wsf.

    This will create the MimeSampleSource->MimeSampleDest port, MimeSampleSource->MimeSampleDest channel, CommonPO document definition, BTFEnvelope envelope, and the MimeSample_DestinationOrg and MimeSample_SourceOrg organizations.

  5. Type Exit in the Command Line window to close it.

  6. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  7. Double-click Microsoft BizTalk Server 2002.

  8. Right-click BizTalk Server Group, click Properties, and then click the Tracking tab.

  9. Ensure that the Enable Document Tracking and Log the original MIME-encoded message check boxes are selected.

    These options instruct BizTalk Server to store in a table all incoming documents as well as the original MIME documents.

  10. Click OK.

  11. Close BizTalk Server Administration.

To run the sample, follow these steps:

  1. On the Start menu, click Run.

  2. On the command line type CMD.

    This will bring up a Command Line window.

  3. Change the directory to the Multi-Part MIME Attachment sample directory.

  4. Type Submit.vbs.

    This script file will use the Submit method to submit the CommonPOAttached.txt file to BizTalk Server. When the submission process is complete, a message box will appear stating that the submission was successful.

  5. Verify that a new file has been created in the Multi-Part MIME Attachment sample directory. This file will be named with a unique GUID and have a .txt extension (for example, {4DE29CC8-7631-46A7-BCA7-F92B910A2AD1}.txt).

  6. Type Exit in the Command Line window to close it.

    You can verify that the MIME attachments have been included by opening the .txt file. Note that the XML data within the multi-part MIME file is encapsulated by a SOAP envelope.

Programming Notes

This sample assumes that BizTalk Server is installed on your C drive. If this is not the case, you should make the appropriate path modifications.


Pipeline Component in Visual Basic

This sample demonstrates an application integration component (AIC) that implements the IPipelineComponent and IPipelineComponentAdmin interfaces in Microsoft Visual Basic. The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the Microsoft BizTalk Server repository), logs some of the properties passed to it in the dictionary, and copies the incoming message to a file.

For a related sample, see Pipeline Component in Visual C++.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\PipelineComponent\VB

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual Basic component (this is optional because the DLL is provided).

  2. Register the component, its category IDs, and its setup configuration by running:

    cscript scenario.wsf //job:setup

    When asked whether to register information from Affinity.reg, click "Yes." The component ProgID is "BTSSamples_VBPipeComp.PipelineComp".

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_VBPipeComp" by using the command:

    cscript scenario.wsf //job:submit

    If the submission succeeds, a log file, BTSSamples.log, and an output file, BTSSamples_pipe.out, will be created in the temporary system directory (C:\WINNT\temp).

Programming Notes

If you want to configure the component, you must' copy the ASP pages to the directory designated for property pages (for example, C:\Program Files\Microsoft BizTalk Server\MessagingManager\pipeline). You can then open the BizTalk Messaging Manager and edit the channel. The Advanced button in the last dialog box allows you to set the properties for the primary transport.


Pipeline Component in Visual C++

This sample demonstrates an application integration component (AIC) that implements the IPipelineComponent and IPipelineComponentAdmin interfaces by using the Active Template Library (ATL). The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the Microsoft BizTalk Server repository), logs some of the default dictionary properties to a file, C:\temp\BTSSamples_ATLPipeComp.log, and writes the incoming data to another file, C:\BTSSamples_ATLPipeComp.out.

For a related sample, see Pipeline Component in Visual Basic.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\PipelineComponent\VC\ATL

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual C++ component.

  2. Set up the configuration by running:

    cscript scenario.wsf //job:setup

    The component ProgID is "BTSSamples_AtlPipelineComp BTSPipelineComp".

  3. Copy ASP files to the configuration files for BizTalk Messaging Manager:

    C:\Program Files\Microsoft BizTalk Server\MessagingManager\pipeline

    You can now change the default settings for output and log files.

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_ATLPipelineComp" by using the command:

    cscript scenario.wsf //job:Submit

    If the submit succeeds, you will get two files:

    C:\temp\BTSSamples_ATLPipeComp.log

    C:\temp\BTSSamples_ATLPipeComp.out


Queue Sniffer

This sample enables you to view, forward, and remove messages in Message Queuing queues. This application supports the following features:

  • Displays the entire content of a message

  • Displays XML and flat text file formats

  • Accesses message queues on remote servers

  • Performs criteria-based searches for specific messages

  • Forwards messages to other message queues

  • Removes messages from a queue

  • Retrieves detailed message information

  • Displays journal messages

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Queue Sniffer

User's Guide

To use this application, perform the following steps:

  1. Run the executable file QueueSniffer.exe, located on the BizTalk Server installation drive at \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Queue Sniffer\QueueSniffer.exe.

  2. Type the name or TCP/IP address of a Message Queuing server in the Message Queuing Server text box that is located at the top of the window.

  3. Type a message queue name in the Message Queue text box.

  4. If the queue you are accessing is transactional, select the Use Transactional Queue check box.

  5. If you wish to view journal messages for the queue, select the Use Journal check box.

After you have entered the required information, you can perform one of the following actions:

  • View the next message in the queue. Click View Next Message to display the next message in the queue.

  • Search for a specific message in the queue. Enter search criteria in the Message Search Criteria section and click Search to display a message that matches your criteria. Click Search again to see the next message that matches your search criteria.

After a message is displayed in the Message Information area, you can remove the message from the queue by clicking Remove from Queue, or you can forward a copy of the message to another queue by clicking Forward Message.

Note

  • The information in the message label cannot be passed to a remote queue.


Receive Scripts

This sample demonstrates an HTTP receive function.

ReceiveResponse.asp is used as a page where the BizTalk Messaging Service receives documents to be sent to an existing Orchestration schedule. If you copy that page into your localhost location, you can use http://localhost/ReceiveResponse.asp as the HTTP URL address on the Channel Information page of the BizTalk Messaging Binding Wizard.

ReceiveStandard.asp is an example of an HTTP receive function. The document data posted to that page will be submitted as a self–routing document for a NOT OPEN configuration.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts

Programming Notes

The Exchange Server 5.5 folder contains an example SMTP receive function. The document data sent as an e-mail message will be deposited into C:\temp\RS_data.txt and then submitted as a self-routing document for a NOT OPEN configuration.

The Exchange Server 2000 folder contains an example of an event sink that intercepts e-mail messages and submits them to BizTalk Server. See the readme.doc file in that folder for more details.


Refresh Messaging Manager

This sample allows you to refresh objects in BizTalk Messaging Manager. You must refresh the objects in the Messaging Manager when a document definition, envelope, or channel is modified. This sample lets you choose whether to refresh all objects or individual objects.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Refresh Messaging Manager

User's Guide

To prepare and run the sample, follow these steps:

  1. Copy the BTM_RefreshV2.exe file to the BizTalk Server on which you are working.

    The BTM_RefreshV2.exe file can be copied to any BizTalk Server. The Refresh Messaging Manager application will only affect the BizTalk Server that it is currently running on.

  2. Open Windows Explorer and browse to the BTM_RefreshV2.exe file.

  3. Double-click the BTM_RefreshV2.exe file to start the application.

    Within the application are three windows that display the document definitions, envelopes, and channels that are available on the BizTalk Server.

  4. To refresh individual objects, highlight the objects and then click the corresponding button to refresh only the highlighted objects. To refresh all the listed objects (whether highlighted or not), click Update All.

  5. To exit, click Exit.

Note

  • This sample assumes that BizTalk Server is installed on your C drive. If this is not the case, you should make the appropriate path modifications.


Reliable Messaging

This sample illustrates how a buyer organization delivers a purchase order (PO) to a supplier organization by using the BizTalk Framework 2.0 reliable messaging protocol.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMessaging

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Enable Reliable Messaging

  • Run the Reliable Messaging Sample

Note

  • The BizTalk Messaging Services configuration script, ReliableMsgConfig.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Applications: PurchaserOrgApp, SupplierOrgApp

    2. Channels: PurchaserOrgOutgoingMsgChannel, SupplierOrgIncomingMsgChannel

    3. Messaging Ports: PurchaserOrgOutgoingPort, SupplierOrgIncomingPort

    4. Organization: Supplier Organization

    5. Document Definition: PurchaserOrgPO

    6. Envelope: PurchaserReliableEnvelope

    7. File Receive Functions: PurchaserOrgOutgoingFunc, SupplierOrgIncomingFunc

Programming Notes

BizTalk Framework 2.0 (BTF) guarantees only a single delivery of a message to the destination organization. After the supplier organization receives the message, the BizTalk Server in the supplier organization responds with a receipt to the purchaser organization. When the purchaser organization receives the receipt, the transmission is complete.

As a brief example, consider an application (PurchaserOrgApp) in the buyer organization, which sends a PO to BizTalk Server (PurchaserOrg), which, in turn, delivers the PO to the supplier organization application (SupplierOrgApp), as explained below:

BizTalk Server in the buyer organization

  1. BizTalk Server wraps the PO with a BTF reliable message envelope and sends the message to the supplier organization.

  2. BizTalk Server places a copy of the PO into the BizTalk Server Retry queue.

  3. BizTalk Server tries to send the PO to a supplier organization until a BTF receipt is received. The number of retries is based on the configuration and the interval between retries.

  4. When the number of retries is exhausted and the receipt has not been received, the PO is placed into the Suspended queue.

  5. If the receipt arrives before the number of retries is exhausted, BTF removes the PO from the Retry queue.

BizTalk Server in the supplier organization

  1. BizTalk Server removes the PO from the BTF envelope and sends an acknowledgement receipt to the source organization.

  2. The PO, without an envelope, is delivered to the supplier organization's internal application.

  3. BizTalk Server logs the PO in the document-tracking database. However, no log is created for the receipt.

When BizTalk Messaging Services on the supplier organization receives an interchange with a reliable messaging format, it uses a special document definition, channel, and messaging port to process and transport a receipt to the buyer organization. These special system objects are not viewable in BizTalk Messaging Manager, and you cannot create similar objects by using the reserved system names.

BizTalk Server uses the reply-to address that is included in the header of the inbound interchange as the destination address for the receipt. You do not need to further configure BizTalk Messaging Services for the supplier system to return a receipt for an interchange sent with the reliable messaging envelope.


Preliminary Setup

Before you begin the sample, you must complete the following tasks:

  • Create Folders

  • Copy Files

  • Run Setup Script


Create Folders

In this procedure, you create one folder that contains six subfolders. You use four of the subfolders as locations for messages as they move into and out of the buyer and seller systems, one as a repository for the reliable receipt and one as a document data folder.

To create the folders:

  1. In Windows Explorer, browse to the root directory of your C drive.

  2. Create a new folder on the root of the C drive; name the folder ReliableMessaging.

  3. Click the new ReliableMessaging folder and create two subfolders with the following names:
    • PurchaserOrg

    • SupplierOrg
  4. Click the new PurchaserOrg folder and create two subfolders with the following names:
    • InPurchaserOrg

    • ReliableReceipts
  5. Click the new SupplierOrg folder and create two subfolders with the following names:
    • InSupplierOrg

    • OutSupplierOrg


Copy Files

In this procedure, you copy the files that are needed to complete the sample.

  1. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMesssaging and copy POSpec.xml.

  2. Paste the file to \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

  3. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMesssaging and copy ReliableMsgReceipt.asp.

  4. Paste the file to C:\ReliableMesssaging\PurchaserOrg.


Run Setup Script

In this procedure, you run the script that sets up all the messaging configuration objects that are necessary for this sample.

  • Run ReliableMsgConfig.vbs to configure BizTalk Messaging Services.


Enable Reliable Messaging

This section shows you how to enable reliable messaging for the sample. It contains the following topics:

  • Create a Web Application

  • Examine ReliableMsgReceipt.asp

  • Define a Reliable Messaging Reply-to URL


Create a Web Application

In this procedure, you create a Web application to receive the reliable messaging receipt.

  1. On the Start menu, point to Settings and click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Internet Services Manager.

    The Internet Services Manager console appears.

  4. In the Internet Services Manager console tree, expand <your computer>.

  5. Right-click Default Web Site.

  6. On the Action menu, select New and click Virtual Directory.

    The Virtual Directory Creation Wizard appears.

  7. On the Welcome to the Virtual Directory Creation Wizard page, click Next.

  8. On the Virtual Directory Alias page, in the Alias box, type PurchaserOrg and click Next.

  9. On the Web Site Content Directory page, click Browse.

  10. Browse to C:\ReliableMessaging\PurchaserOrg, click OK, and then click Next.

  11. On the Access Permissions page, click Next.

  12. Click Finish to close the Virtual Directory Creation Wizard.


Examine ReliableMsgReceipt.asp

Look at ReliableMsgReceipt.asp. This ASP file is located in the PurchaserOrg directory, and is a standard receive page that delivers the receipt to the buyer organization, using BizTalk Framework 2.0.

For the call to Submit, the only parameters specified are the openness type and the document string, as shown in the following code:

SubmissionHandle = interchange.submit( 1, PostedDocument )

BizTalk Server understands the schema of the reliable message receipt, so you do not need to define a port or a channel to process the receipt.


Define a Reliable Messaging Reply-to URL

In this procedure, you define a reliable messaging reply-to URL.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

    The BizTalk Server Administration console appears.

  2. In the BizTalk Server Administration console tree, expand BizTalk Server.

  3. Right-click BizTalk Server Group.

  4. On the Action menu, right-click Properties.

    The BizTalk Server Group Properties dialog box appears.

  5. On the General tab, in the Reliable messaging repy-to URL box, type http://localhost/PurchaserOrg/ReliableMsgReceipt.asp, click Apply, and click OK.

    ReliableMsgReceipt.asp is an ASP file that uses the Submit method to deliver the receipt to the PurchaserOrg BizTalk Server.

    The URL that is specified is used by the supplier system BizTalk Server to deliver the receipt to the buyer system BizTalk Server.


Run the Reliable Messaging Sample

This section shows you how to run the reliable messaging sample. It contains the following topics:

  • Run the Sample with a Disabled Receive Function

  • Run the Sample with an Enabled Receive Function

To run the sample, you need to remove the read-only property from the sample data file, SamplePO.xml.


Run the Sample with a Disabled Receive Function

Run the sample with a disabled receive function to allow you to analyze the content of the inbound purchase order (PO) from the buyer system. You will be able to look at the purchase order wrapped with a BizTalk Framework 2.0 reliable envelope.

Before running the sample, disable the receive function in the seller system, so that you can view the content of the arriving purchase order (PO) from the buyer system. You will be able to analyze the PO wrapped with the BizTalk Framework 2.0 reliable envelope.

To disable the receive function:

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  2. Expand Microsoft BizTalk Server, expand BizTalk Server Group, and then click Receive Functions.

  3. Click the receive function named SupplierOrgIncomingFunc.

  4. On the Action menu, click Properties.

    The Properties dialog box appears.

  5. Select the Disable receive function check box, and then click Yes to confirm your choice.

  6. Click OK.

To submit the PO:

  1. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMesssaging and copy SamplePO.xml.

  2. Paste the file to C:\ReliableMesssaging\PurchaserOrg\InPurchaserOrg.

    In this step you place the sample purchase order (PO) to the directory that is being monitored by the buyer system receive function. The receive function will pick up the sample PO.

    At this point, you can view the sample PO in the Retry queue. Note the number of retries and the time interval between each retry.

  3. Browse to C:\ReliableMessaging\SupplierOrg\InSupplierOrg.

    In this directory, you can view the sample PO arriving from the buyer system. The message contains two parts, the SOAP envelope and the body. The body of the message contains the sample PO.


Run the Sample with an Enabled Receive Function

By enabling the receive function on the supplier system, you allow the inbound sample purchase order (PO) to be picked up. Then BizTalk Server removes the envelope, sends a receipt to the buyer system, and submits the PO to the supplier system application through the configured port and channel.

To enable the receive function:

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  2. Expand Microsoft BizTalk Server, expand BizTalk Server Group, and then click Receive Functions.

  3. Click the receive function named SupplierOrgIncomingFunc.

  4. On the Action menu, click Properties.

    The Properties dialog box appears.

  5. Clear the Disable receive function check box, and then click OK.

    After enabling the receive function, BizTalk Server delivers the reliable message receipt to the reply-to URL, http://localhost/PurchaserOrg/ReliableMsgReceipt.asp.

To complete the sample:

  1. Browse to C:\ReliableMessaging\SupplierOrg\OutSupplierOrg.

    In this directory, you can view the PO. Note that there is no envelope information, and that it is the same PO that was originally sent by the buyer system.

  2. Browse to C:\ReliableMessaging\PurchaserOrg\ReliableReceipts.

    In this directory, you can view the receipt file. The receipt file contains the reply-to URL and the from and to tags. Note that the receipt file contains no information on the PO.


Self-Routing

This sample demonstrates the BizTalk Server 2002 capability to route documents through BizTalk Server channels and ports based on the contents of the document being routed.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Self-Routing

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Run the Self-Routing Sample

Programming Notes

This sample walks through the process of setting up a self-routing document scheme that utilizes the routing capabilities of BizTalk Server 2002 and, in the process, demonstrates the following:

  • The use of dictionary properties that are added to document specifications by BizTalk Editor and are used by the BizTalk Server runtime to determine routing

  • The use of envelopes to parse and route differently formatted inbound flat files

  • The use of document selection criteria to determine routing

  • The use of receive functions in determining routing

In this sample, we will modify the business scenario and show how a single receive function can be used, with three different inbound file formats, channels, and maps, to send the same DecisionFactors document to the approver through the existing ApprovalMessagingPort port.

We modify the POApproval scenario by introducing the following business requirements:

  • Rather than one buyer organization, as in the original POApproval scenario, we now have two separate buyer departments, each of which has its own flat-file format for a purchase order. The buyer departments are divided by region: Northwest buyers (NWB) and Central buyers (CB).

  • Each buyer department has agreed to add a common header record, known as an inbound envelope, to each of their purchase orders before submitting them for approval. They have also agreed to a data content convention for the common header to properly route their documents.

  • We want to reuse our existing business logic, approver addresses, and wire protocols to route documents from both buyer departments with a minimum of additional effort.

  • We want to use a single share drop location on the network for both departments and a single receive function no matter how many buyer departments we add in the future. Note that we are assuming that all departments added in the future will send flat files with the common header.

Inbound Envelope

Each buyer department uses the inbound envelope to tell BizTalk Server the source of the document and which file format to expect. The envelope has the following format:

POHeader,999,XXX

The first field in the envelope is a constant string literal (that is, identical and unchanging in all documents) that is used to identify the record type when the inbound file is parsed. This is the primary mechanism that BizTalk Server uses at run time to separate individual purchase orders that are submitted in the same flat file.

The second and third fields correspond to the document Source Qualifier and Source Name respectively. In addition, the third field doubles as the Document Type property for the associated purchase order. Because each buyer department sends only one document format, the third field can be "overloaded" in this way.

The Northwest and Central buyer departments provide the Source Qualifier/Source Name pairs 10/NWB and 12/CB, respectively.

A document specification file is provided by the sample and contains the XML-Data Reduced (XDR) information for the envelope. The file name for this specification is defPOEnv.xml. If you look at this file in BizTalk Editor you will see that the string "POHeader" has been entered as the Source Tag Identifier for the record.

Buyer Department Document Specifications and Input Files

The sample provides the document specifications and sample input files for the buyer departments. The specifications are named defNWBPO.xml and defCBPO.xml for the Northwest and Central departments respectively. The sample input files are named NWBPOx.csv and CBPOx.csv, where x is the number of purchase orders in the file (that is, the number of common header records that you should expect to see).


Preliminary Setup

Before you begin the sample, you must complete the following tasks to set up the basic POApproval scenario:

  • Copy Self-Routing Document Specifications and Maps to the Repository

  • Create Two Private Transactional Message Queuing Queues

  • Create Folders

  • Copy Files

  • Remove Read-Only Property from .csv File

  • Run Setup Script

  • Check Receive Function


Copy Self-Routing Document Specifications and Maps to the Repository

  1. In the Self-Routing sample directory, double-click the DocSpecs folder.

  2. Copy the POApproval folder and paste it into the DocSpecs repository at:
    \Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs

  3. In the Self-Routing sample directory, double-click the Maps folder.

  4. Copy the POApproval folder and paste it into the Maps repository at:
    \Microsoft BizTalk Server\BizTalkServerRepository\Maps


Create Two Private Transactional Message Queuing Queues

  1. On the Start menu, point to Settings, click Control Panel, double-click Administrative Tools, and then double-click Computer Management.

  2. Expand the Services and Application node.

  3. Expand the Message Queuing node.

  4. Right-click the Private Queues folder, point to New, and then click Private Queue.

  5. In the Name text box, type approvalmsmq and select the Transactional check box.

  6. Click OK.

  7. Repeat steps 4 through 6 to create another new private queue named responsemsmq.


Create Folders

In this procedure, you create the folder that is necessary to run the sample.

  1. In Windows Explorer, browse to the root directory of your C drive.

  2. Create a new folder on the root of the C drive; name the folder Data.


Copy Files

In this procedure, you copy files that are needed to complete the sample.

  1. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Self-Routing and copy the following two folders: POApproval, SetUp.vbs.

  2. Paste the folders to C:\Data\.


Remove Read-Only Property from .csv File

  1. In the C:\Data\POApproval folder there are three files: NWBPO2.csv, NWBPO1.csv,and CBPO1.csv.

  2. While holding CTRL, select the three files.

  3. Right-click the selection and click Properties.

  4. On the General tab, in the Attributes area, clear the Read-only check box.

  5. Click OK.


Run Setup Script

In this procedure, you run the script that sets up all the ports, channels, document definitions, maps, and specifications that are necessary for this sample.

  1. On the Biztalk Server installation drive, browse to C:\Data and double-click the executable file SetUp.vbs. The command prompt window should appear detailing the configuration process.

  2. When the script finishes, the window should close.


Check Receive Function

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and click Biztalk Server Administration.

  2. From the Console Root navigate to \Microsoft BizTalk Server 2002\BizTalk Server Group\Receive Functions. Right-click ApprovalReceiveFunction and click Properties.

  3. Be sure that the Disable receive function check box is cleared.

  4. Click OK. You can now close Biztalk Server Administration.


Run the Self-Routing Sample

This sample demonstrates that each document is processed through the channel that is designed for that specific document, and that each document is delivered to the Approval queue, ready to be processed by the POApproval.skx schedule. Although the documents have differing sources and starting formats, they are processed by the POApproval scenario with little modification (only the receive function is modified).

This sample also shows how to use BizTalk Document Tracking to check the history and status of documents that pass through BizTalk Server.

This section contains the following topics:

  • Drop Inbound Purchase Orders for Approval

  • Use BizTalk Document Tracking to View Processing History

  • Check That Each Document Is Processed Through the Proper Channel

BizTalk Server needs five key pieces of information to select channels into which to route incoming documents: Source Qualifier, Source Name, Destination Qualifier, Destination Name, and Document Definition Name. Using this data, BizTalk Server queries the BizTalk Messaging Management database to acquire a list of appropriate channels.

An appropriate channel meets all of the following criteria:

  • Its source organization matches the source key values.

  • It is attached to a port with a destination organization that matches the destination key values.

  • It has an inbound document definition name that matches the document definition key name.

The following things happen when one of the self-routing documents is submitted to the receive function:

  • When the receive function loads the document from the monitored file share, it first determines the file type. It does this through a "snoop and loop" approach, testing for each file type in the order specified on the Parsers tab of the Properties dialog for the BizTalk Server Group in the BizTalk Administrator snap-in. In our case, the file is a flat file.

  • All flat files that are consumed by receive functions require an envelope. One of the primary purposes of the envelope is to determine individual document boundaries in the incoming file. Another purpose of the envelope is to act as a reliable way to provide routing information. In our case the source information and the selection criteria for our routing is in the header.

  • To determine the document definition name using the header information, BizTalk Server first uses the document schema (defined in BizTalk Editor and referenced by the document definition in BizTalk Messaging Manager) to parse the header, convert it to XML, and load it into the Document Object Model (DOM). Using the dictionary properties in the header schema, BizTalk Server retrieves three key pieces of information: the source qualifier, the source name, and the document type selection criteria.

  • Because the destination key values are provided to BizTalk Server by the receive function, we have four out of five key values. We still need the document definition to parse and convert the bulk (that is, the non-envelope) portions of the document. BizTalk Server accomplishes this by performing a query against the BizTalk Messaging Management database using the selection criteria, in our case, document_type. For example, BizTalk Server would query for all of the document definitions that have a selection criteria called document_type that is equal to the value pulled from the header, for example, "NWB".

  • After all five keys are determined, BizTalk Server makes the final query to find matching channels. Note that zero or more channels can be returned by this query. For example, finding more than one document with the matching selection criteria could result in more than one channel in the final query. If this happens, the document is submitted to all channels in the query results.


Drop Inbound Purchase Orders for Approval

To exercise the solution that we have now built for self-routing documents, we simply drop one or more of the instance documents provided in the demonstration.

  1. Using Windows Explorer (or other tool of your choice), navigate to c:\data\source and copy the file named NWBPO2.csv and paste it into c:\data\POApproval\PODrop.

  2. After you do this, you should see the VBScript message box that says "PO Approval Submitted for Approval".

  3. If you do not see the message box, then the receive function was unable to use the envelope to parse and route the document to the appropriate channel. Examine the Suspended queue and the Application Event Log for more information.


Use BizTalk Document Tracking to View Processing History

To determine how the documents are actually processed, we can use BizTalk Document Tracking as follows:

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and click BizTalk document tracking on localhost.

  2. In the tracking interface, under Source Selection, select one or both of the organizations that are used in the routing scenario (NWBuyers or CBuyers).

  3. Under Destination Selection, click Home Organization.

    Note that the only document definition that appears in the list is DecisionFactors because that is the only document that is currently configured as an inbound document on any channels that have the source and destination specified.

  4. Under Document Type Selection, click Show Documents.

  5. Click Query.

    Notice that in the Source Selection box, you see only the NWBuyer source. This is because the other sources have not yet sent any documents. Later, , you will see the other source, Cbuyer, appear in the Source Selection box.

  6. In the resulting list, note the key information (source, destination, and document definition name) that defines how the documents were processed. Also notice the time stamp and other information about the documents. Both inbound (native .csv) and outbound (.xml) documents are listed. In addition, you can click the icon in the data column to see the document contents.


Check That Each Document Is Processed Through the Proper Channel

Note that documents with a "2" in the name have two documents contained in the file. Notice that two documents are placed on the Approval queue when these documents are submitted because BizTalk Server breaks up the inbound file based on the flat-file envelope that is used.

  1. Submit each of the files: CBPO1.csv, NWBPO1.csv, and NWBPO2.csv, by dropping each into c:\Data\POApproval\PODrop.

  2. Use BizTalk Document Tracking to review how each document was processed, as described in the preceding topic.


Send to Remote Queue

This sample contains a COM object in the library SendToRemoteQueue.dll that can be used to send XLANG messages to a message queue on a remote server.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Send To Remote Queue

User's Guide

Before running the sample, register the library SendToRemoteQueue.dll on your system by using the RegSvr32 registration utility. This library must be registered on a computer that is running Microsoft BizTalk Server.

This sample provides a simple schedule (RemoteQueue.skv) that reads a common purchase order file (CommonPOSample.xml) from a local message queue, and then sends that purchase order to a remote message queue. To run this schedule, follow these steps:

  1. Create a private queue named .\private$\inbound on the local computer.

  2. Open the file RemoteQueue.skv in BizTalk Orchestration Designer.

  3. Click the Data tab at the bottom of the window.

  4. Double-click the Constants message to open the Constants Message Properties dialog box. Replace the values "RemoteServerName" and "RemoteServerQueue" with the real names of your remote server and queue.

  5. Verify that the QueueType and IsTxn constant values are correct for the remote queue. If not, update them accordingly.

  6. Compile the drawing into an XLANG schedule file (.skx).

  7. Run the XLANG schedule.

  8. Send a message to the .\private$\inbound queue that contains the purchase order data in the file CommonPOSample.xml. Note that the sample does not provide this functionality.

For additional information on compiling and running XLANG schedules, see the following topics:

  • Run XLANG Schedules

  • Compile an XLANG schedule drawing into an XLANG schedule

Programming Notes

To use the sample, add one or more bindings to this COM object in your existing XLANG schedule files. After the object is bound to a schedule, you also need to modify the data mapping in the schedule to specify the remote server and queue name destination for the message. The SendToRemoteQueue object contains the following input parameters for sending messages to a remote queue:

strMessage

String containing the message body.

strMSMQServerName

String containing the name of the remote server computer.

strMSMQQueueName

String containing the name of the remote message queue.

strMSMQQueueType

String containing the type of the remote queue. This value can be set to "PUBLIC" or "PRIVATE".

strMSMQMsgLabel

String containing the label of the message.

bollsQueueTransactional

Boolean that indicates whether the remote queue is transactional.

Note

  • The information in the message label cannot be passed to a remote queue.


Submitting Documents

This sample demonstrates how to set up a BizTalk Messaging Management database and call the Submit method of the Interchange object, which submits a business document to BizTalk Server 2002 from VBScript. The sample also demonstrates the creation and use of an open destination messaging port, organization aliases, custom envelopes, and the IBizTalkTrackData object.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Sample1

User's Guide

Before running the sample, complete the following steps:

  1. Start a Command Line window.

  2. Change the directory to:

    <Microsoft BizTalk Installation Path>\SDK\Messaging Samples\Sample1

To run the sample:

  • Run cscript Sample1.vbs.

Programming Notes

During execution Sample1 outputs messages indicating its progress. It performs the following steps:

  • First it reports the results of using BizTalk Messaging to configure one organization, two documents, one envelope, an open destination port, and a channel.

  • It then reports the results of the Submit method call, waits for 10 seconds, and outputs the content of the tracked business document.

  • Finally, Sample1 creates the file C:\temp\Sample1_<tracking_id_GUID>.txt, which contains a SOAP-enveloped document from the original Sample1.xml data file.

The input file, Sample1.xml, is an XML CommonPO document wrapped in a BizTalk Framework (BTF) 1.0 envelope.

The output file, C:\temp\Sample1_<tracking_id_GUID>.txt, is an XMLCommonPO document identical to Sample1.xml wrapped in a BTF 2.0 envelope, also known as a SOAP envelope.


Submitting Documents with Receipts

This sample shows how to set up a BizTalk Messaging Management database and explains one way of generating a receipt. This is accomplished by mapping a received purchase order (PO) to a PO acknowledgment without using a receipt channel.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Sample2

User's Guide

Before running the sample, complete the following steps:

  1. Start a Command Line window.

  2. Change the directory to

    <Microsoft BizTalk Installation Path>\SDK\Messaging Samples\Sample2

To run the sample:

  • Run cscript Sample2.vbs.

Programming Notes

There are three parties involved in this sample: the source application, the source organization, and the destination organization. The PO originates from the source application, is passed to the source organization, and then is passed from the source organization to the destination organization. The destination organization then sends the PO acknowledgment back to the source organization.

The sample uses local file transport. Two local File receive functions are configured for this sample.Both receive functions call the Submit method of the IInterchange object.

The setup section of the script creates three folders on the C drive. They are C:\temp\SRC, C:\temp\DST, and C:\temp\ACK. This script places the original PO in C:\temp\SRC, and the SRC receive function is configured to pick up files there. The SRC receive function moves the original PO to C:\temp\DST, and the DST receive function places the PO acknowledgment in the C:\temp\ACK folder.

This sample calls SubmitSync for the first submission and overwrites the component configurations on the channel.

The channels created can be described as follows:

SRC/APP->SRC/APP (C:\temp\SRC, used the script to drop a file)

OpenSrc->DST (C:\temp\DST, used receive function to drop a file)

DST->SRC (C:\temp\ACK, used receive function to drop a file)

During execution, Sample2 outputs messages indicating its progress. It performs the following steps:

  • First it copies CommonPOACKMAP.xml into the BizTalkServerRepository\Maps\Microsoft folder.

  • It then verifies the existence of the C:\temp, C:\temp\SRC, C:\temp\DST, and C:\temp\ACK folders, and creates two File receive functions: "SRC File Receive Function" and "DST File Receive Function."

  • The script then tries to remove all pre-existing Sample2-related configuration objects if Sample2 was previously executed. It configures the following Sample2 objects: two organizations, two documents, one envelope, one port, and three channels.

  • It then calls SubmitSync, verifies the response from SubmitSync, waits for one minute, and verifies that no Suspended queue items are present and that the C:\temp\ACK\Sample2ACK.xml file exists. This file should contain CommonPOAcknowledgment wrapped in SOAP envelope.

The input file, Sample2.xml, is an XML CommonPO document wrapped in a BizTalk Framework (BTF) 2.0 (SOAP) envelope.

The output file, C:\temp\ACK\Sample2ACK.xml, is a CommonPOAcknowledgment file mapped from CommonPO and wrapped in a SOAP envelope.


Submitting Documents to a Port Group

This sample sets up a BizTalk Messaging Management database and calls the Submit method of the IInterchange object, which submits the business document to BizTalk Server 2002 synchronously.

A distribution list in BizTalk Server is a way to send an identical business document, containing identical data, to a number of partners. The business document originates from the source application and is passed to the distribution list, which causes the same purchase order (PO) to be sent to the source application and to the destination organization. To verify that the documents have been processed correctly, look for Sample3_DST.txt and Sample3_SRCAPP.txt files in the C:\temp folder.

The sample Distribution List contains related information.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Sample3

User's Guide

To run the sample, follow these steps:

  1. Start a Command Line window.

  2. Change the directory to:

    <Microsoft BizTalk Installation Path>\SDK\Messaging Samples\Sample3

  3. Run cscript Sample3.vbs.

Programming Notes

During execution, Sample3 outputs messages indicating its progress. It performs the following steps:

  • First it copies Sample3.asp into the default Web site of Internet Information Services (IIS).

  • It then tries to remove all Sample3-related Configuration objects if they exist.

  • It configures the following objects: two organizations, one document, one envelope, two ports, one port group, and one channel pointing to the port group (distribution list).

  • It calls Submit, waits for 15 seconds, and verifies that the resulting C:\temp\Sample3_SRCAPP.txt and C:\temp\Sample3_DST.txt files exist.

The C:\temp\Sample3_DST.txt file is created as a result of posting the data to the Sample3.asp page. The C:\temp\Sample3_SRCAPP.txt file is created by a file transport configured in the source application port. The first line of C:\temp\Sample3_DST.txt indicates when the data was received by the destination organization. Both files contain SOAP-enveloped data from the original Sample3.xml.

The input file Sample3.xml is an XML CommonPO document wrapped in a BizTalk Framework (BTF) 2.0 (SOAP) envelope.

The output files are as follows:

  • C:\temp\Sample3_SRCAPP.txt is an XMLCommonPO document identical to the one from Sample3.xml wrapped in a BTF 2.0 envelope, also known as a SOAP envelope.

  • C:\temp\Sample3_DST.txt is an XMLCommonPO document identical to the one from Sample3.xml wrapped in a BTF 2.0 envelope, also known as SOAP envelope, with a first line containing "- Received at date/time -".


Suspended Queue Monitoring

This sample demonstrates how to raise an alert in Microsoft Operations Monitor (MOM) when a document is sent to the BizTalk Server Suspended queue.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Suspended Queue Monitoring

User's Guide

Complete the following steps to configure this sample:

  1. On your C drive, create a folder named ReceivePO.

  2. Run the configuration script, SuspendedQueueConfig.vbs, to configure BizTalk Messaging Services.

  3. Enable the event processing rule named "Suspended Queue Sample" in the BizTalk Server 2002 Management Pack that is installed in Microsoft Operations Monitor.

  4. Verify that the computer running BizTalk Server is a managed computer agent in Microsoft Operations Monitor.

Note

  • The BizTalk Messaging Services configuration script, SuspendedQueueConfig.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Channel: TestChannel

    2. Port: TestPort

    3. Organization: Dest Org

    4. Organization: Source Org

    5. Document Definition: PO

    6. File Receive Function: ReceivePurchaseOrders

To run the sample, complete the following steps:

  1. Ensure that the InvalidPO.xml file is not read-only. To modify this property, right-click the file, click Properties, clear the read-only attribute, and then click OK.

  2. Copy the file InvalidPO.xml into the file receive directory C:\ReceivePO. This will generate a Suspended queue event, which is displayed in the alerts for that agent computer in the Microsoft Operations Monitor console.

Important

  • For the Suspended queue event to be consumed by MOM, the MOM DAS account must be a member of the BizTalk Server Administration group.


Synchronous Orchestration Component

This sample demonstrates a synchronous method for invoking and interacting with an XLANG schedule.

A synchronous call into BizTalk Server expects a response document in return for a request document submitted through the SubmitSync method. For example, in a Web scenario where data flows through HTTP.Request into a Web page (for example, request-submit.asp) and is submitted to BizTalk Server through SubmitSync, the response from BizTalk Server is sent back to the HTTP client by mapping the response document to the HTTP.Response. If the application that produces the response document behind BizTalk Server is accessed through an XLANG schedule, BizTalk Server must implement a synchronous, or blocking, method of invoking and interacting with the XLANG schedule.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SOC

User's Guide

Before running the sample, complete the following steps:

  1. Open the SOC.dsw Visual C++ workspace. Compile the SOC and REQRES Visual C++ projects. The AIC will be registered with a ProgID of "BizTalk.SyncOrchestration".

  2. Open the XLANG schedule drawing RequestResponse.skv in the Schedule subfolder. Use the Make XLANG RequestResponse.skx command on the File menu to create an XLANG schedule.

  3. Copy the ASP files located in the ASP subfolder to the folder:

    \Program Files\Microsoft BizTalk Server\MessagingManager\pipeline

  4. Create a messaging port that uses an AIC transport type, and is referencing the new BizTalk.SyncOrchestration component.

  5. Create a channel for the messaging port, with any document specification, and a document instance generated from BizTalk Editor. On the Advanced Configuration page, click Advanced. On the Primary Transport tab, click Properties.

  6. On the BizTalk SyncOrchestration Properties page, enter the path and file name of the XLANG schedule in the Skedpath text box. Enter the XLANG port name SyncPort in the Skedport text box.

To run the sample:

Create the IInterchange object and call the SubmitSync method with the channel name and a sample document that uses the Inbound Document Definition specified on the channel. The response will appear as the out parameter of the SubmitSync method call.

Programming Notes

Synchronous COM calls into XLANG schedules are made by invoking a synchronous orchestration component, which is an application integration component (AIC) that implements the IPipelineComponent interface. A synchronous orchestration component uses a property page (.asp) configured with the path of the associated XLANG schedule, which will be used to process messages of a particular schema on the port. When a message arrives at the port through a channel, BizTalk Server invokes a predefined and configured synchronous orchestration component, passing the dictionary object to it. The custom synchronous orchestration component inspects the dictionary object and retrieves the schedule path. It then uses the path to invoke the XLANG schedule, passing along the document in the working_data field of the dictionary object.

The first action in the XLANG schedule is bound to the IRequestResponse::SetRequest(requestDoc) method. The synchronous orchestration component invokes this method and passes the request document to the XLANG schedule for processing. To receive the resulting response document from the XLANG schedule processing, the synchronous orchestration component makes two subsequent calls to the XLANG schedule instance. The first method invoked is IRequestResponse::CompleteProcessing, which sets the response document. Immediately thereafter, the synchronous orchestration component invokes the IRequestResponse::GetResponse method to retrieve the response document. The synchronous orchestration component is blocked until the XLANG schedule processing flows to the action that is bound to the SetResponse port. This call will time out after 120 seconds if no response is available. You can change this default time-out setting of 120 seconds by changing the constant MAX_TIMEOUT_SECS in RequestResponseExample.h.

Note

  • Because the client is blocked while awaiting a response, any issues with time-out limits must be addressed when implementing a synchronous process flow.

The response document is then returned by the synchronous orchestration component to BizTalk Server as a field in the dictionary. BizTalk Server then returns the response document to the Web page that called SubmitSync. The Web page in turn maps the response document to HTTP.Response. To provide COM activation and message delivery from BizTalk Messaging Services to an XLANG schedule, the XLANG schedule must have its first action bound to the IRequestResponse::SetRequest method and its last two actions bound to the actions that will allow the passing of a response document.

Notes

  • If outbound processing by BizTalk Server is required for the response document, the synchronous orchestration component can call into BizTalk Server by using SubmitSync before returning the results to the ASP page through BizTalk Messaging Services.

  • The synchronous orchestration component can be used as an orchestration activation and as a DCOM data delivery mechanism by modifying the synchronous orchestration component to call only SetRequest.


Tracking Database Tasks

This sample contains an SQL script for creating a sample SQL Server Agent job: dtaJob_receipt_monitor_<TrackingDatabaseName>

This job monitors expiring records in the dta_outdoc_details table that are expecting receipts to come back and whose waiting periods have a time-out. By default, this job runs every 30 minutes. It calls the dta_job_mark_expired_outdocs stored procedure.

For a related sample, see the file dta.vbs in the folder \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Miscellaneous.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SQLServerAgentJobs

User's Guide

Before running the sample, complete the following steps:

  1. In a text editor, open the DTA_SampleJobs.sql sample file.

  2. Find all instances of the string "%InterchangeDTA%" and replace them with the name of your BizTalk Server Tracking database.

  3. Save the file. You might need to remove the read-only attribute on the file before you can save it.

  4. Start the SQL Server Agent service if it has not already been started.

  5. Start SQL Query Analyzer. On the Start menu, click Programs, click Microsoft SQL Server, and then click Query Analyzer.

  6. In SQL Query Analyzer, connect to the SQL database server to which your BizTalk Server Tracking database belongs.

  7. Change the current database to your BizTalk Server Tracking database.

To run the sample:

  • Open the modified DTA_SampleJobs.sql file and execute a query (press F5).

Programming Notes

If you encounter errors, make sure that the database user account with which you are connecting to the database server has sufficient permissions to create stored procedures and SQL Server Agent jobs. Also make sure that the string find-and-replace in step 2 was done correctly.


Windows Management Instrumentation

This sample illustrates the use of Visual Basic scripts to configure administrative entities such as organizations, document definitions, ports, channels, and receive functions.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\WMI

User's Guide

The sample sets up a file-to-file scenario between two organizations. Each organization is simulated by a directory on the file system. BizTalk Server receives a document from the source organization, and then transforms it and submits it to the destination organization.

To prepare and run the sample, follow these steps:

  1. Run setup.cmd in the sample directory to configure the scenario and run the scripts.

  2. Run the sample scenario by navigating to C:\BizTalkWMI\ and copying the file SourceInstance.xml into C:\BizTalkWMI\SourceOrg.

    This file should be consumed by BizTalk Server, transformed, and submitted to C:\BizTalkWMI\DestinationOrg as the file OutDoc%tracking_id%.xml, where %tracking_id% is a unique ID value.

  3. Run Cleanup.vbs to clear the configuration changes that were made by the sample scripts and to delete c:\BizTalkWMI.

  4. To clear the files stored to WebDAV, navigate to Program Files\Microsoft BizTalk Server\BizTalkServerRepository on the file system and delete DocSpecs\WMISourcePOSchema.xml, DocSpecs\WMIDestPOSchema.xml, and Maps\WMIPOMap.xml.

The two setup scripts that are run in this sample are:

  • ConfigureBTC.vbs. This script creates the organizations for the source and destination, the documents for the source and destination specifications, and the port and channel that are needed for the scenario.

  • ReceiveFunction.vbs. This script configures the File receive function for the scenario.

For more information on these scripts, see the following topics:

  • Creating ConfigureBTC.vbs

  • Creating ReceiveFunction.vbs

These scripts have already been created, but the following programming notes are included to provide a better understanding of how the scripts work.

Programming Notes

The setup.cmd program creates the following folders on your computer:

  • c:\BizTalkWMI. The common folder where all the scenario-related files are copied

  • c:\BizTalkWMI\SourceOrg. The location where BizTalk Server receives documents that are to be sent to the destination organization

  • c:\BizTalkWMI\DestinationOrg. The location where BizTalk Server drops documents that were received from the source organization after processing them

The following files are used in the scenario. You might want to examine them to gain a better understanding. These files are copied to C:\BizTalkWMI and installed in WebDAV:

  • SourcePOSchema.xml. The specification for the source purchase order

  • DestPOSchema.xml. The specification for the destination purchase order

  • POMap.xml. The map that is used for transforming the source specification to the destination specification

The following sections walk through the process of creating ConfigureBTC.vbs and ReceiveFunction.vbs. Double-click the scripts to run them. To avoid name conflict errors, run Cleanup.vbs before attempting to rerun the two configuration scripts. The names of all objects that are created by the scripts in this sample start with "WMI".


Creating ConfigureBTC.vbs

This section walks through the steps that are necessary to set up the two organizations, two document definitions, one port, and one channel that are used in the scenario. After running the script, use BizTalk Messaging Manager to verify that these objects have indeed been added.

  1. Create the Configuration object.

    Calling CreateObject with the ProgID "BizTalk.BizTalkConfig" is the first step in any script that uses the SDK. All other BizTalk Messaging Configuration objects are accessed through this main Configuration object.

  2. Create the source organization.

    Create an Organization object and set its name attribute to the name desired for the source organization. Store the organization handle for use later while configuring the channel.

  3. Create the destination organization.

    Create an Organization object and set its name attribute to the name desired for the destination organization. Store the organization handle for use later while configuring the port.

  4. Add specifications and maps to WebDAV.

    Helper subroutines and functions are used to extract server information and to store the document specifications and map to WebDAV. A WebDAV URL is in the form http://SERVER_NAME/BizTalkServerRepository/. Note that document specifications must be stored in the DocSpecs folder and maps must be stored in the Maps folder under the WebDAV URL.

  5. Create the input document definition.

    Create a Document object that represents the input document specification. Set its name and set its reference to the WebDAV path of the source document specification. Store the document definition handle for use in configuring the channel.

  6. Create the output document definition.

    Create a Document object that represents the output document specification. Set its name and set its reference to the WebDAV path of the output document specification. Store the document definition handle for use in configuring the channel.

  7. Create the port.

    The port represents the destination of this configuration. Set its name, a handle to its destination organization, a constant to indicate its primary transport type (file), and a string to indicate its primary transport address (file://C:\BizTalkWMI\DestinationOrg\OutDoc%tracking_id%.xml). Store the port handle for use in configuring the channel.

  8. Create the channel.

    The channel contains the information that is involved in transforming the document from the source format to the destination format. Set its name, a handle to its source organization, a handle to its associated port, handles to its input and output document definitions, and a reference to the WebDAV path of the map that specifies the transformation.


Creating ReceiveFunction.vbs

This section walks through the steps that are necessary to set up the File receive function that monitors C:\BizTalkWMI\SourceOrg for XML files. After the XML files are picked up, they are processed and sent to the destination organization.

Note that it is important to run this script after the configuration script, because the receive function assumes the existence of an associated channel that is created in ConfigBTC.vbs. After running the script, check to see that the receive function has been created by opening up the BizTalk Server Administrator tool and navigating to the list of receive functions.

  1. Create the locator object.

    Calling CreateObject with the ProgID "WbemScripting.SWbemLocator" is the first step in any WMI-related script. This is the standard way to get an entry point into the WMI objects.

  2. Create the services object.

    To connect to and access a set of related services on a computer, the namespace that identifies that set of services must be given. The target computer defaults to the local computer, and the namespace for the BizTalk Server services is "root/MicrosoftBizTalkServer".

  3. Get the ReceiveFunction class object.

    Use either Get or ExecQuery to retrieve the receive function class. The name of the class is "MicrosoftBizTalkServer_ReceiveFunction".

  4. Spawn an instance of the receive function.

    Use the SpawnInstance_ method on the receive function class to set its attributes.

  5. Set the name of the receive function instance.

  6. Specify the protocol type for this receive function (as File).

    Because the receive function class represents all receive functions, its ProtocolType must be set to 1 (for ADMIN_PROTOCOL_TYPE_FILE) to indicate that it is a File receive function.

  7. Specify the processing server on which this receive function will run.

    In this case, helper functions are used to determine the local computer name.

  8. Specify the name of the group that is associated with this receive function.

    "BizTalk Server Group" is the default name that is set by the script.

  9. Specify the file name mask for this receive function.

    Setting *.xml indicates that all XML files should be picked up from the specified location.

  10. Specify the location to poll for this File receive function.

    This is the location on the file system where the receive function will monitor and pick up source document instances. In this scenario, the PollingLocation is "C:\BizTalkWMI\SourceOrg".

  11. Specify the name of the channel to use.

    This is the channel that was created earlier by ConfigureBTC.vbs.

  12. Set the flag to create the receive function as configured.

    Calling Put_ with the flag set to 2 (wbemChangeFlagCreateOnly) means that we are creating the receive function as configured. The value 2 is the only supported value in the SDK.


BizTalk Orchestration Services Code Samples

Sample files are located in the XLANG Samples folder on the Microsoft BizTalk Server installation drive. Browse to \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples on the installation drive to find the sample files. This is only a relative path. Depending on your installation of BizTalk Server 2002, you might need to modify this path.

  • BizTalk Framework Correlation

  • BizTalk Services Integration

  • Dispatcher Application

  • Dynamic Binding with COM

  • Dynamic Binding with Message Queuing

  • Exception Handling

  • Iteration

  • Nested Transactions

  • Orchestration Services Audit

  • Orchestration Services Audit Client

  • Personalized Queues

  • Queue Listener

  • While Shape

  • XLANG and ASP

  • XLANG Interfaces

  • XLANG Schedule Pooling

  • XLANG Submit Synchronously and Query Asynchronously

  • XLANG Trace

  • XML Translation


BizTalk Framework Correlation

This sample illustrates the use of BizTalk Framework (BTF) 2.0 and orchestration to accomplish stateful interoperability between two applications. It allows two (or more) applications to engage in a potentially long-lived exchange of messages. Each exchange is capable of referring back to the data passed in previous exchanges.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Integrating BizTalk Services

User's Guide

The sample contains the following directories:

  • App contains the BTS SimpleApproval schedule file.

  • BTM2BPO contains a combination application integration component (AIC) and utility component. The AIC part of the component allows a BTF-enveloped message, which includes the <prc> tag, to be sent to the correct existing instance of an orchestration through a message queue or a COM interface (ReceiveMsg). The port name and other options are set through the BizTalk Messaging Manager (Advanced-Properties). In addition to this AIC, this project also contains code needed to envelope an existing message and include the <prc> tag and 'reflect' an enveloped message.

  • ThirdPartyApp contains an application that simulates a third-party application.

  • FileSubmit is the polling location for the ReceiveNewApp receive function.

  • Schema is the directory containing the schema.

  • CorrUtil contains a utility component.

  • SetupFiles contains the scripts to install and uninstall the sample.

To run the sample, follow these steps:

  1. Run setup.cmd to install the sample.

  2. Run SubmitDoc.cmd to drop the NewAppInst.xml file into the FileSubmit directory.

  3. Run ThirdPartyApp\ThirdPartyApp.exe. The Get Message button will retrieve the next message from the RequestApproval queue. It should appear in the edit window. Press the Reflect button to prepare the message for sending back to the schedule. Press Approve to send it to the Approvals queue or Decline to send it to the Denials queue. Message Queuing receive functions will pass these messages back to BizTalk Server and through BTM2BPO back to the schedule.

    The BTS SimpleApproval schedule illustrates two ways in which the response document is delivered to the running schedule instance. The ReceiveApprovalPort port is a Message Queuing port and receives the document through a per-instance queue. The ReceiveDenialPort port is a COM port and receives the document as a parameter to the ReceiveMsg method of the IReceive interface.

  4. View the Application Log by using EventViewer for the name of the port to which the response document was delivered.

  5. Run remove.cmd to uninstall the sample.

Programming Notes

The sample uses:

  • Orchestration to maintain the state of the exchange and determine the sequence of exchanges.

  • BizTalk Framework 2.0 envelopes to pass a state identifier between the applications.

  • BizTalk Server 2002 messaging facilities to abstract individual applications from each other.

BTS SimpleApproval.skv provides a summary view of a sample orchestration using all of the above.


BizTalk Services Integration

Two samples are provided to demonstrate the integration of BizTalk Messaging Services and BizTalk Orchestration Services.

Paths

To locate the sample files for the sample using HTTP as a transport mechanism, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Integrating BizTalk Services\http

To locate the sample files for the sample using Message Queuing and File receive functions, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Integrating BizTalk Services\non-http

User's Guide

Detailed information regarding the HTTP-based sample is provided in the Setting Up HTTP Sample.doc file located in the http folder.

Detailed information regarding the Message Queuing sample is provided in the Setting Up Non-HTTP sample.doc file located in the non-http folder.


Dispatcher Application

This sample demonstrates a dispatcher application that sends and receives documents on behalf of a client application. When a document is sent, the dispatcher saves the "From address" in a database before sending the document and uses the saved address to route the response document to the correct sender.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Dispatcher

User's Guide

This sample consists of the following directories:

  • Apps contains the schedules, a data file, and VBScript files to run the sample.

  • ClientUtil contains a helper component for the ClientApp schedule.

  • DbUtil contains a helper component for simulating a database.

  • DestUtil contains a helper component for the DestApp schedule.

  • DispatchUtil contains a helper component for the DispatchApp schedule.

  • SendUtil contains a helper component for the SendApp schedule.

The setup script, "setup.cmd", does the following:

  • Registers the following components: ClientAppUtil, SendAppUtil, DestAppUtil, DispatchAppUtil, and DbComp.

  • Creates the Message Queuing queues SendDocs, RecvDocs, and UnknownDocs.

To remove the sample, run "remove.cmd".

To run the sample, first run "startDispatchApp.vbs" in the "Apps" directory. This starts the "DispatchApp" schedule and should be run only once. Then run "startClientApp.vbs" in the "Apps" directory. This starts the "ClientApp" and "DestApp" schedules.

The "ClientApp" schedule sends a document to the "SendApp" schedule along with the To Queue and From Queue paths and then waits on a per-instance queue for the response.

The "SendApp" schedule generates a unique token and saves the FromQueue (the per-instance queue of ClientApp) path and the token in a database. The token is added to the document, which is then sent to the To Queue (SendDocs).

The "DestApp" monitors the "SendDocs" queue, reads the document from the queue, extracts the token, creates a response document, adds the token to the response document, and sends the response document to the response queue "RecvDocs".

The "DispatchApp" schedule monitors the "RecvDocs" queue for any document. When the response document is available in the queue, it extracts the token from the document, gets the corresponding delivery queue path from the database, and sends the response document to the delivery queue. If the delivery queue cannot be determined, the document is sent to the "UnknownDocs" queue. After dispatching the document to the correct queue, the "DispatchApp" schedule starts another instance of itself to continue monitoring the "RecvDocs" queue.

The "ClientApp" that is waiting on the per-instance queue receives the response document and processes it.

The "startClientApp.vbs" script can be run any number of times. To terminate the "DispatchApp" schedule, shut down and restart the "XLANG Scheduler" COM+ application by using the Component Services MMC snap-in.

Programming Notes

The "ClientApp" schedule gets the document as an input parameter. The Get Constants action is used to get constant values into the schedule. The Display Input Doc action displays the input document. The Send Doc action uses a helper component to start the "SendApp" schedule and pass it the document, the path of the queue to send the document to, and the path of the per-instance queue where the response should be sent. The Get Response Doc action is used to wait on the per-instance response queue for the response document. The Display Response Doc action displays the received response document.

The "SendApp" schedule receives the document and the From Queue and To Queue paths from the Get Input action. The Save Return Address action generates a GUID token and saves the token and the From Queue address in a database. The token is then added to the document to be sent. The SendDoc action sends the document to the To Queue (SendDocs).

The "DestApp" schedule waits on the "SendDocs" queue for the document. The ReceiveDoc action gets the document from the queue. The CreateResponse action extracts the token from the document, creates a response document, and adds the token to the response document. The SendResponse action sends the response document to the "RecvDocs" queue.

The "DispatchApp" schedule waits on the "RecvDocs" queue for the document. The Get Doc From Queue action gets the document from the queue. The Get Delivery Queue action extracts the token from the document and retrieves the corresponding delivery queue path from the database. The SendDoc action sends the document to the delivery queue.

The "ClientAppUtil" helper component is used by the "ClientApp" schedule to get input parameters, get constants into the schedule, display a message box, start the "SendApp" schedule, and pass parameters to it.

The "SendAppUtil" helper component is used by the "SendApp" schedule to get input parameters and to save the delivery queue path in the database.

The "DestAppUtil" helper component is used by the "DestApp" schedule to extract the token from the input document, create the response document, and add the token to the response document.

The "DispatchAppUtil" helper component is used by the "DispatchApp" schedule to get input parameters, get the delivery queue path from the database, and restart the "DispatchApp" schedule.

The "DbComp" helper component is used by the "SendAppUtil" and "DispatchAppUtil" components to save and retrieve the delivery queue address from a file-based database. The database is simulated by using an XML file, "TrackDb.xml," that is created in the DbUtil directory.

Note

  • To simplify this sample, a file-based database is used. Therefore a transaction shape cannot be used with the database-related actions. Ideally one would use transaction shapes in conjunction with a transactional database to ensure proper recovery in case of failures. The QueueListener sample demonstrates how to use transactions to ensure that a schedule is restarted in the event of an abnormal termination.


Dynamic Binding with COM

This sample demonstrates how to bind dynamically to a COM component. The COM component that the schedule binds to is decided at run time.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Dynamic Binding\COM

User's Guide

The sample consists of the following directories:

  • ScrambleApp contains the scramble sample schedule and the VBScript file to run the sample.

  • ScrambleUtil contains a helper component used to create the COM component to bind to and display messages.

  • ScrambleInterface contains the type library for the IScramble interface.

  • HighSecurityScramble contains a COM component that implements the IScramble interface.

  • LowSecurityScramble contains a second COM component that implements the IScramble interface.

The setup script, "setup.cmd", does the following:

  • Registers the "Scramble" typelib.

  • Registers the following components: HighScramble, LowScramble, and ScrambleHelper.

To remove the sample, run "remove.cmd".

To run the sample, run "startit.vbs" in the "ScrambleApp" directory. The input data to be scrambled is passed to the schedule. When the message High Security Scramble for "Hello World!"? is displayed, click "Yes" to scramble the data by using the "HighScramble" component or click "No" to scramble the data by using the "LowScramble" component. The output is displayed in a message box.

Programming Notes

In this schedule, the "GetInput" action gets the data to be scrambled.

The "GetScrambler" action creates the scrambler component to use based on user selection.

The "ScrambleData" action scrambles the data by using the component created by the previous action. This action can bind to any component that implements the "IScramble" interface.

The "DisplayScrambledData" action displays the output of the "ScrambleData" action.

A helper component, "ScrambleHelper," is used to create the scrambler component and to display messages.


Dynamic Binding with Message Queuing

This sample demonstrates how to bind dynamically to a message queue. The queue path is specified at run time.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Dynamic Binding\Queue

User's Guide

The sample consists of the following directories:

  • QueueBindApp contains the queuebind sample schedule, data file, and VBScript files to run the sample.

  • QueueBindUtil contains a helper component used to process the data file and display messages.

The setup script, "setup.cmd", does the following:

  • Registers the "QueueBindUtil" component.

  • Creates Message Queuing queues named purchase_dept and marketing_dept.

To remove the sample, run "remove.cmd".

To run the sample, run "startit.vbs" in the "QueueBindApp" directory. The "MarketingDeptOrder.xml" data file is sent to the "purchase_dept" queue and the schedule is executed. The schedule reads the data file from the queue and sends an acknowledgment to the "marketing_dept" queue. A message box displays the acknowledgement generated and the reply queue.

Programming Notes

In this schedule, the incoming document received by the "GetOrder" action contains the reply queue location where the acknowledgement needs to be sent.

The "ProcessOrder" action builds the acknowledgement document and extracts the path of the reply queue from the incoming document.

The "DisplayAck" action displays the acknowledgement document and the reply queue location.

The "SendAck" action sends the acknowledgement document to the reply queue that was specified in the incoming document.

A helper component, "QueueBindUtil," is used to process the data file and to display messages.


Exception Handling

This sample demonstrates how to handle an exception.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Transaction Abort

User's Guide

The sample consists of the following modules:

  • A Visual Basic ActiveX DLL contains the component called by the schedule.

  • Abort.vbs contains the code to run the schedule.

The setup script, setup.cmd, registers the abortsample component.

To remove the sample, run remove.cmd.

To run the sample, run Abort.vbs. When you click OK in the dialog box, it sends the string to the schedule. If you have typed Abort, the transaction will be aborted, and you will be shown the appropriate messages.

Programming Notes

This sample demonstrates the use of an abort handler and auto return. When a method call returns a negative HRESULT, then the outer transaction is aborted and the abort handler code for the transaction starts executing. After the abort handler code completes, the command goes to the next action.

If the transaction is aborted then the document is put back on the Received_Doc_In queue (because Message Queuing is used in the transaction) and the abort handler drops a copy of the document into the aborted_doc_out_ queue.


Iteration

This sample demonstrates how to iterate through a list of items and process each item independently based on a condition.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Iteration

User's Guide

Before running the sample, run the setup script setup.cmd.

To run the sample, follow these steps:

  1. Browse to the LineItemsApp folder.

  2. Run the script file startit.vbs.

  3. When prompted, click OK on the message box to continue.

Programming Notes

When run, the "ItemList.xml" file is sent to the "items_in" queue. This file contains a list of items to be processed. The schedule picks up the file from the queue and processes the items in it. Each item is placed in a different "out" queue based on the item type. Any item of unknown type is placed in the "unknown_out" queue. A message box is displayed as each item is processed.

This sample uses a simple counted loop to iterate through the list of items. The GetItemCount action is used to get the maximum iteration count and the While shape is used to control the loop. The Decision shape uses different rules to determine the branch to execute. The Join shape uses an OR join type because only one of the branches will be executed at any given time.

A helper component, "LineItemHelper", is used to increment the loop count, process the data file, and display messages.

To remove this sample, run the script remove.cmd.


Nested Transactions

This sample illustrates nested transactions, aborting a transaction, and compensation.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\NestedTxns

User's Guide

To install this sample, register all the script components in the sample directory.

To run the sample, run the "NestedTxns.wsf" script file.

Programming Notes

The scenario for this sample is ordering an item, submitting payment, receiving the item, returning the item, and having the payment reversed. This scenario is based on a familiar shopping experience, where a merchant accepts returned merchandise and processes a credit-card credit. The credit slip looks like a credit-card debit slip except that it is usually printed in red ink.

The sample encapsulates the entire purchasing cycle in an outer transaction called "Purchase". Inside that transaction is a nested transaction called "Payment". The compensation block for "Payment" includes a transaction named "ReverseCharges". This sample has a total of three transaction envelopes.

The "Purchase" transaction includes an "Order" action; a "Payment" transaction; a "ReceiveItem" action; a decision about whether to keep the item; a branch to return the item, abort, and compensate the payment; and another branch to keep the item. The "Abort" action causes the entire "Purchase" transaction to abort, which, in turn, causes the nested "Payment" transaction to abort. The "Payment" transaction has a compensation block, itself transactional, that carries out the credit or reversal of charges.


Orchestration Services Audit

This sample demonstrates an orchestration audit component.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit

User's Guide

There is one interface, IUserEvent.

ServerName is the name of the server associated with your tracking database:

HRESULT Install( /*[in]*/ BSTR ServerName,

Datasource is the name of your tracking database:

/*[in]*/ BSTR Datasource,

/*[in]*/ BSTR Username,

/*[in]*/ BSTR Password,

/*[in,optional]*/ BSTR ApplicationFilter, /*[in,optional, defaultvalue(egAllEvents)]*/ EventGroupTypes EventFilter

HRESULT Uninstall();

Install installs the subscription into the COM+ catalog, and connects to the database. ApplicationFilter can be the name of a COM+ application or the GUID key for that application. EventGroupTypes can be any combination of the enumeration combined by using OR. The default is for all events.

Uninstall removes the subscription from the COM+ catalog and disconnects from the database.

A client should explicitly call Uninstall before releasing the component. Otherwise the subscription will be orphaned until the server is rebooted.

Programming Notes

The database tables and stored procedures are initially built by setup. If you want to restore these, you need to run files in the query analyzer after selecting your tracking database, in the following order:

<InstallationFolder>\Setup\BTS_WorkflowEvents_Schema.sql

<InstallationFolder>\Setup\BTS_WorkflowEvents_Logic.sql

Important

  • This orchestration audit component persists detected events into the InterchangeDTA (default name) database, which is the BizTalk Server Tracking data store. Two tables are used to contain the data for monitored events: dta_wf_WorkFlowEvent and dta_wf_EventData. The first of these contains a row for each event detected and the second contains one or more rows for each property related to a particular event in the first table. Note that the BizTalk Server Tracking user interface might show truncated event data because the columns in the second table (event data) that contain property name and value pairs are set to 100 characters, and actual names and values can exceed this length.


Orchestration Services Audit Client

This sample demonstrates an orchestration audit client.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient

User's Guide

To run this application, first register the WorkFlowAudit.dll file by typing regsvr32 WorkFlowAudit.dll at the command prompt. This file is in the <Installation Folder>\SDK\XLANG Samples\WorkflowAudit\bin folder.

After registering this component, run WorkflowAuditClient.exe. When the application is first run, it asks you to enter four parameters. Except for the database user password, the values are taken from the Windows Management Instrumentation (WMI) provider. If you want to change the default settings, type the new values.

When you click Start, the application calls the Install method of the interface in the WorkFlowAudit.dll. The events that are fired by the XLANG Scheduler will be monitored. Do not close the application while tracking the scheduler events. Doing so will terminate the monitoring process.


Personalized Queues

This sample uses a shared queue and per-instance queues. A shared queue called the new-user queue permanently resides at a URL. This queue is associated with the enterprise Web site and with a schedule for creating new users. The client goes to the well-known URL to create a new user account or to log on to an existing user account.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Personalized Queues

User's Guide

This sample uses the items described in the following paragraphs.

Queues

Queues can be inspected from the Management Console (right-click My Computer on the desktop, click Manage, navigate to Services and Applications, Message Queuing, Private Queues).

  • Fixed queue: .\private$\AmysNewUserAccount

  • Account queue: .\private$\AccountQueues{...fresh guid... }

Schedules

Schedules can be inspected with the XLANG Event Monitor that is installed with the BizTalk Server SDK.

  • AmysZoneTop.skv checks that a new user name has been deposited in the top-level queue. In a real application, this would set up user account database tables.

  • AccountSchedule.skv takes command messages in a loop from the per-instance account queue. The loop terminates when the command "Close" comes in.

Windows Batch Command Files

  • Run setup.cmd before running the sample.

  • Run remove.cmd to disable the sample and clean up.

Windows Script Files and Windows Script Components

  • RunMe.wsf runs the sample.

  • VerifyForm.wsc shows that the new user name was received by the new-user queue.

  • RecordQueueName.wsc records the user name and its associated per-instance account queue name in a text-file database.

  • CloseUserAccount.wsc removes the user name from the text-file database.

  • ReportUserCommand.wsc shows that the account schedule has received commands from the SessionWebPage.

  • CreateTopLevelQueue.vbs is run by setup.cmd.

  • DeleteTopLevelQueue.vbs is run by remove.cmd.

HTML pages

  • ClientWebPage.htm allows users to create new accounts or to log on to existing accounts.

  • SessionWebPage.htm feeds user commands to AccountSchedule.skv.

The sample setup script, setup.cmd, creates the unique shared new-user queue.

Note

  • This sample stores the user account database in a text file in the C:\winnt\system32 folder, and assumes that that folder exists. The folder name is hard-coded in only one place in the sample code, so fixing this limitation is easy. Simply edit RunMe.wsf, search for the string "winnt", and change the reference to match the name of your system folder.

To run the sample:

  • Run RunMe.wsf in the ClientApplication folder. Interact with its Web pages and dialogs.

  • Run the Microsoft Management Console (right-click My Computer on the desktop, and then click Manage) to inspect queues and the event log.

  • Run the XLANG Event Monitor to watch the schedules running.

  • Inspect the file C:\winnt\system32\AccountQueuesDB.txt to see the association of user names and per-instance queues.

To remove the sample, run remove.cmd.

Programming Notes

A new user account is represented by a new per-instance queue called the account queue. The account queue is bound to a very-long-lived schedule instance, the account schedule. The account schedule is born (instantiated) at account creation time and lives until account destruction time. Thus, its lifetime is the same as the lifetime of the user account, and this could be measured in years.

We have one new-user queue for the entire enterprise. The enterprise encompasses many user accounts, each with its own account schedule and account queue.

The user logs on to the account by interacting with the account schedule through the account queue. Conceivably, the same technique used to associate many users with one enterprise could be repeated one more level down to associate many sessions with each user. We do not do so in this sample, presuming that two levels of schedules and queues suffice to illustrate the point. However, if session schedules were used, then the account schedule would, in turn, create another per-instance queue called the session queue, which is bound to a session schedule that lives until the user logs off the account.

For now, we assume that each user gets one session, so we combine the functionality of the account with that of the session.

We call this sample Personalized Queues because there is one per-instance queue per user. The most interesting aspect of this application is that the account queue and schedule live as long as the user account. Such a schedule could encapsulate a considerable amount of persistent state information about the user.

The user first approaches the application through a script called RunMe.wsf in the ClientApplication directory. This script launches a Web page called ClientWebPage.htm. To create a new account, the user chooses a user name and a password and enters them into a form on this Web page. When the user clicks Create New User, the script, RunMe.wsf, deposits the new user name in the new-user queue and invokes the schedule in AmysZoneTop.skx.

The job of AmysZoneTop is to create the account queue and instantiate the account schedule, whose XLANG specification is stored in AccountSchedule.skx. Each instance of this schedule lives as long as the user account, and this time could be measured in years.

AccountSchedule creates a new queue for the user. The name of this queue is generated automatically by the system. AccountSchedule invokes a script component, RecordQueueName.wsc, to store the name of the new queue in a system database. For illustration purposes in this sample, the database is stored in a flat text file in the system directory. In a real application, it will be necessary to keep user names and queue names in a SQL Server database.

AccountSchedule then goes into an indefinite loop awaiting commands from the user to arrive on the user's personalized queue.

Note that no real processing of passwords is done in this sample. Password processing is a delicate and critical topic; however, it is beside the point of this sample, which is to illustrate very-long-lived per-instance queues. We therefore avoid the topic in this sample.

The user can also log on to the application by running RunMe.wsf. The script checks the user name in the database and changes to another Web page that allows the user to submit commands to the personalized queue. Some suggested commands appear on the Web page SessionWebPage.htm. These commands only generate pop-up confirmation dialogs.

The one exception is the command Close This User Account. This command removes the user name from the database and shuts down the AccountSchedule, also causing deletion of the personalized queue.

Note that multiple copies of RunMe.wsf can run at one time, and, up to the limitations of contention for the simple text-file "database," all operations of this sample can be interleaved in any way. With user names stored in a SQL Server database, this issue would go away.

The theory articulated here can be verified through the Management Console and XLANG Monitor tools, as well as by inspecting the AccountQueuesDB.txt file over time. Also look at the schedules AmysZoneTop.skv and AccountSchedule.skv in BizTalk Orchestration Designer.

There is one final point worth mentioning. Due to a known limitation of XLANG script binding, it is necessary to have two messages in Port_4 of AccountSchedule. This port reports the user's command to a pop-up dialog box. One of the two messages is outside the loop and corresponds to the first command issued by the user. The other message is inside the loop and corresponds to subsequent commands issued by the user. Two messages are required because XLANG script binding refreshes the contents of a sourced message instance only once. Each iteration of the loop creates a new instance of the message as long as the message is not also present outside the loop. If there were only one message, the pop-up would show only the first command issued by the user, over and over again. The workaround for the limitation is to have two messages of identical form. Note that the Message Queuing binding in Port_2 does not suffer from this limitation, so a single message specification can be used both inside and outside the loop body.


Queue Listener

This sample demonstrates how to continuously monitor a queue for data and start another schedule when new data is available.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\QueueListener

User's Guide

The sample consists of the following directories:

  • ListenerApp contains the sample schedules, a data file, and VBScript files to run the sample.

  • ListenerClientUtil contains a helper component used by the ClientApp schedule.

  • ListenerUtil contains a helper component used by the ListenerApp schedule.

The setup script, setup.cmd, does the following:

  • Registers the ListenerClient component.

  • Registers the ListenerComp component.

  • Creates the Message Queuing queue, Listener.

To remove the sample, run remove.cmd.

To run the sample, first run startListenerApp.vbs in the ListenerApp directory. This starts the ListenerApp schedule and should be executed only once. The ListenerApp schedule monitors the Listener queue for data. When data is available in the queue, it starts the ClientApp schedule, passes the data to it, and starts another instance of itself. To put the data file order.xml into the queue, run File2Queue.vbs in the ListenerApp directory.

The File2Queue.vbs script can be run any number of times. To terminate the queue listener schedule, shut down and restart the XLANG Scheduler COM+ application by using the Component Services MMC snap-in.

Programming Notes

In the ListenerApp, the GetSkedInfo action is used to pass in the path of the ClientApp and ListenerApp schedules. The Receive Doc From Queue action waits until the document is available on the queue. The Start Client App action uses the helper component to start the ClientApp schedule and pass it the document. The Restart Schedule action uses the helper component to start another instance of the ListenerApp schedule before the current instance terminates.

Two transaction shapes are used to ensure that the schedule recovers from any abnormal termination. Transaction1 ensures that the schedule is persisted at the point where it is waiting on the Listener queue. Transaction2 ensures that the schedule is persisted just after the document is read from the queue. If the schedule is terminated at any time, it will be restarted from the last persisted state. It is important to ensure that the database is set up correctly to support persistence.

The ClientApp schedule simply displays the document that is passed to it as input.

The ListenerComp helper component is used by ListenerApp to receive input parameters and start schedules.

The ListenerClient helper component is used by ClientApp to receive input parameters and display the input document.


While Shape

This sample demonstrates how to use the While shape to retry a business process a limited number of times. A loop counter component is used to track the number of times the loop has executed. The loop terminates when the retry count is reached or when the simulated work completes successfully.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Loop

User's Guide

The sample consists of the following directories:

  • RetryApp contains the retry sample schedule and associated script components. It also includes a small VBScript file to run the sample.

  • LoopControl contains a helper component that implements a simple loop counter and supports persistence.

  • LoopUtil contains another helper component to display message boxes indicating the status of the schedule and to prompt for success or failure of the simulated work.

The setup script, setup.cmd, registers the loopcontrol component.

To remove the sample, run remove.cmd.

To run the sample, run startit.vbs in the LoopApp directory. When the schedule runs, it displays a message box to simulate the work being attempted. Click Yes to simulate successful completion of the work, or No to simulate failure. If you click No, the schedule retries the operation and displays the message box again. The schedule proceeds to completion after you click Yes or after the retry limit is reached, and indicates whether the operation was successful.

Programming Notes

This sample is a variation on a simple counted loop. The loop can terminate when the count limit is reached (the retry count) or when the simulated work completes successfully. To exit the loop early, the schedule initializes the loop count to a negative number. The While shape's rule is constructed to exit the loop when the maximum count is reached or when the count is negative.

A "constants" script component is used to supply the schedule with several constant values that are passed to other components.


XLANG and ASP

This sample demonstrates how to call a schedule from an ASP script, passing in data and getting back the result. The script initiates the work and then waits for the result.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\ASP

User's Guide

The sample consists of the following directories:

  • CreditCheckApp contains the creditcheck sample schedule, the ASP page, and a VBScript file to run the sample.

  • CreditCheckUtil contains a helper component to input data into the schedule and return the result.

  • CreditChecker contains a helper component that simulates the credit checking functionality.

The setup script, setup.cmd, does the following:

  • Registers the CreditCheckUtil component.

  • Registers the CreditChecker component.

  • Creates a creditsample Web directory on the default Web site of the local machine.

To remove the sample, run remove.cmd.

To run the sample, follow these steps:

  1. Run startit.vbs in the CreditCheckApp directory. The creditcheck ASP page is displayed in the Web browser.

  2. Enter a number in the text box and click Submit.

Credit will be denied to any number starting with 1 and to any number less then four characters in length.

Programming Notes

This sample uses a Fork shape to start both the credit checks simultaneously and a Join shape to wait for both the credit checks to complete. The ASP script waits on the IsCreditApproved call until the schedule executes the IsCreditApproved action.

Two helper components are used. The CreditCheckUtil component is used to input data into the schedule and return the results to the calling ASP script. The CreditChecker component is used to simulate calls to two different credit agencies to approve the credit.


XLANG Interfaces

This sample demonstrates how to use the XLANG public interfaces to enumerate and manage the running schedule instances and the XLANG host applications.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\PublicInterfaces

User's Guide

When run with no arguments, the sked.vbs script displays its usage options:

usage: cscript sked.vbs <command> <args>

commands:

hosts [computer]

shutdown [computer[!group]]

startup [computer[!group]]

list [computer[!group]]

run [computer[!group]] <schedule path or query> [count]

kill [computer[!group]] <instanceId>

suspend [computer[!group]] <instanceId>

resume [computer[!group]] <instanceId>

The following table shows examples of managing the schedule instances in the default group (host application "XLANG Scheduler") in the local machine.

Option | Result
sked list | Show a snapshot of the running schedules.
sked suspend {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Suspend the schedule with the given ID.
sked resume {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Resume the schedule with the given ID.
sked run c:\MySchedule.skx | Run the Orchestration schedule with the given full path. If the schedule is successfully started, the ScheduleID will be shown.
sked run c:\MySchedule.skx 10 | Run 10 instances of the given schedule.

The following table shows examples of managing the XLANG host applications.

Option | Result
sked hosts | Show the COM+ applications that can host the XLANG schedules.
sked shutdown | Shut down all host applications.
sked startup | Start all host applications.
sked shutdown "!My Host App" | Shut down only the host application named "My Host App".
sked startup "!My Host App" | Start the application "My Host App". (If the default host "XLANG Scheduler" was shut down, it will start too.)
sked hosts OtherMachine | List the host applications on the remote computer OtherMachine.
sked shutdown OtherMachine | Shut down all host applications on the remote machine OtherMachine.
sked startup OtherMachine!MyApp | Start the application MyApp on the remote computer OtherMachine (and possibly the default host "XLANG Scheduler").

The following table shows examples of managing schedules on different host applications and different machines.

Option | Result
sked list "!My Host App" | List the schedules running in "My Host App".
sked list "OtherMachine!MyApp" | List the schedules running in the application "MyApp" on the remote computer OtherMachine.
sked list OtherMachine | List the schedules running in the default host application ("XLANG Scheduler") on the remote computer OtherMachine.
sked run !MyApp c:\MySked.skx | Run the schedule MySked.skx in the application MyApp on the local machine.
sked run OtherMachine!MyApp \\server\share\MySked.skx | Run the schedule MySked.skx in the application MyApp on the remote machine OtherMachine. Note that the .skx file should be accessible to the application, for example, on a public share.
sked suspend !MyApp {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Suspend the schedule with the given ID, which is running in the application MyApp on the local machine.
sked resume OtherMachine!MyApp {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Resume a schedule running in the application MyApp on the remote computer OtherMachine.
sked kill OtherMachine {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Terminate a schedule running in the default host on the remote computer OtherMachine.

Programming Notes

The XLANG public interfaces are available from the type library "XLANG Scheduler Runtime Type Library."

The sked.vbs script uses the public interfaces IWFSystemAdmin, IWFGroupAdmin, and IWFWorkflowInstance, as well as some COM+ admin interfaces and objects.

To list the running schedules or to suspend, resume, or terminate a schedule, the moniker for the Group Manager of the given application is constructed, and its IWFGroupAdmin interface is used.

To shut down or start all host applications, or to shut down a particular application, the IWFSystemAdmin interface is used.

To start a particular application, its moniker is constructed and used in GetObject.

To run a schedule, the proper moniker is constructed (for example, "sked://"+ the computer name +"!" + the application name +"/"+schedule path) and is used in GetObject. To obtain the ID and the module name of the newly started schedule, its IWFWorkflowInstance interface is used.

To list the XLANG host applications, the COM+ admin objects are used.


XLANG Schedule Pooling

This sample demonstrates how to use the pooling feature that is built into the XLANG Scheduler Engine. This feature helps running schedules to effectively use system resources. This sample also demonstrates the new BizTalk Server 2002 feature that makes the instance ID available.

BizTalk Server 2002 provides the capability to control the load on the XLANG Scheduler Engine by limiting the number of schedules that can be run simultaneously at any given time. If many schedules are active simultaneously, the server will constantly context switch and will use the operating system resources inefficiently.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Schedule Throttling

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Run the Sample

Programming Notes

The following instructions walk through the process of setting up the pooling sample that utilizes the load-limiting capabilities of the BizTalk Server 2002 XLANG Scheduler Engine.

This schedule contains an action that is bound to a method called MessageBox on the script component. That method takes the instance ID of the schedule instance as a parameter, demonstrating one use of the new BizTalk Server 2002 feature that makes the instance ID available. As its name implies, the method displays a message box containing the instance ID. After the user clicks the message box, the schedule completes.


Preliminary Setup

Before you run the sample, you must complete the following tasks:

  • Register the Script Component

  • Run the Setup Script


Register the Script Component

In this procedure, you register the script component that is used by the sample schedule.

  1. Right-click the icon that represents the script component ThrottlingSample.wsc.

  2. Click Register.


Run the Setup Script

In this procedure, you run the script that sets up the pooling properties.

  1. Double-click the script ThrottlingConfig.vbs. Input boxes appear and request configuration information.

  2. Provide the requested information in each box and then click OK. The script uses this information to set the activation properties of the pool in which the sample schedule will run.


Run the Sample

In this procedure, you run the sample that demonstrates the pooling feature.

  1. Double-click the script ThrottlingSample.vbs. An input box appears and asks for the number of schedule instances to run.

  2. Enter the desired number of schedule instances to run and click OK.

  3. Monitor the number of running XLANG schedule instances by using XLANG Event Monitor (XLANGMon.exe). This number should not exceed the maximum pool size that was configured by using the setup script.

    Clicking the message box that a schedule instance displays allows that instance to complete and thereby make room for one more instance in the pool. If the pool becomes full before all the requested schedule instances have been activated, the next instance cannot be activated and will eventually time out. Thus, if you allow schedule instances to fill the pool (by not clicking their message boxes), you will eventually see a different message box declaring that activation of the next schedule instance has timed out.

  4. To rerun the sample with different pooling properties, rerun the setup script, ThrottlingConfig.vbs, and then start again at step 1 of this procedure.


XLANG Submit Synchronously and Query Asynchronously

This sample shows how to make an ASP page submit information into a XLANG schedule and then retrieve information without having to be interlocked with the running schedule.

Note

This sample is an extension of the ASP sample that shows the interaction between an ASP page and an XLANG schedule.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Modifying the Default Configuration

  • Running the Sample


Preliminary Setup

Complete the steps outlined in this section to configure your computer to run the sample.

Configuring the Sample Objects and Web Pages

The default configuration of this sample assumes that BizTalk Server 2002 and SQL Server 2000 are installed on the local computer. If you need to change the configuration, modify the values of DBHost as described in Modifying the Default Configuration.

To set up the required table, register COM objects, and configure a virtual Web directory, run SETUP.CMD located at \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\setup.


Modifying the Default Configuration

For the ASP page to interact asynchronously with the XLANG schedule, this sample uses a shared SQL table to store state and XLANG-to-ASP return information. Both parts of the sample (the ASP page and the XLANG schedule) share the COM object in XLANG_SAMPLE_ASYNC_SQL.DLL to communicate to the SQL table. The default configuration of the sample is to use the instance of SQL Server on "localhost."

Note that both groups of steps must be performed.

To change the COM object configuration:

  1. Change the default read-only status of the files in \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\SQL_Object to read/write. (Alternatively, copy the files to another working directory and make that copy writable; note that later you will have to re-register the COM object for this new location.)

  2. Using Visual Basic, open the project XLANG_SAMPLE_ASYNC_SQL.VBP.

  3. Open the module "globals" (the file globals.bas).

  4. Modify the variable DBHost to reference the desired instance of SQL Server.

  5. Make the project to rebuild XLANG_SAMPLE_ASYNC_SQL.DLL.

  6. If you have moved its location, remember to re-register the DLL using regsvr32.

To build the shared database on a computer other than "localhost":

  1. Change the default read-only status of the file \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\SETUP/SETUP_DB.CMD to read/write.

  2. Edit the file and change the two instances of "-S localhost" to the appropriate computer name.

  3. Save and run this modified setup script.

Security

Note that the virtual Web directory created for this sample uses Windows NT Authentication. A user accessing the sample Web page and possibly the service account for BizTalk (service BTSSvc) needs to have permission to the shared database. Generally the user of this sample is part of the "BizTalk Administrators" group and is the creator of the table, so there should be no problem running the sample.

Any other configuration or situation might require adjustments of security permissions in the SQL Server Enterprise Manager.


Running the Sample

To run the sample, you can run \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\RUN_SAMPLE.CMD.

Alternatively you can access http://localhost/sync_async_xlang/async.asp.

You can also complete the following steps:

  1. From a remote computer substitute the appropriate host name for "localhost."

  2. For "name of fruit", enter apples (note that this program is case-sensitive).

  3. For the amount enter any number (there are 50 "apples" in the warehouse).

  4. Click Submit.

The Web page will update with a blank table with a button labeled Check_Details on WorkItem #. At this point the ASP page has broken free of the XLANG schedule. Clicking the Check_Details… button repeatedly will update the blank table.

Approximately 30 seconds after submitting (for "apples"), the state column will change from "0 processing" to "1 Complete" and return information will appear in the strSKU and iAmountAvailable columns.

To contrast this with the normal synchronous interaction with XLANG, access the page:

http://localhost/sync_async_xlang/async.asp

This page (and its associated XLANG schedule) will not completely reload until the XLANG schedule returns information.


Programming Notes

This sample addresses the fact that some workflows in an XLANG schedule can take a long time to complete, especially when a schedule has to send a document or message to another organization and wait for returned information. BizTalk Server can handle the long delays, but a user waiting for an order to complete on a Web page might not.

This sample shows a technique to allow the user to submit information to an XLANG schedule and then quickly separate from the processing. The user can then asynchronously query the state of the processing.

For this sample, the business model is a simulated fruit warehouse. The user will request an inventory check for, say, "234 apples" and the warehouse will return a document with the available number of apples and the order code (SKU) for an actual purchase. To make the sample interesting, the processing takes a different amount of time depending upon what type of fruit is selected, as follows:

  • Bananas take 10 seconds to check inventory.

  • Apples take 30 seconds.

  • Oranges take 50 seconds.

  • Anything else is not in stock, and takes 0 seconds.

Note

  • To simulate the processing delay, the business code uses the Sleep function. This function should not be used in a production COM object because it will do things like prevent the long-running XLANG process from being dehydrated. It is used here to simplify the non-essential part of the sample code.

Technique Used

To allow the ASP page to work asynchronously with the XLANG schedule, the sample does the following:

  • The user fills out the form on the ASP page and clicks Submit.

  • The ASP page invokes the XLANG schedule.

  • Synchronously, the ASP page passes the request information to the schedule through a shared COM object.

  • The XLANG schedule registers for a row in a shared SQL table. The unique key for this row is used as a token for the working instance. The row now contains information in a "not ready" state.

  • The ASP page synchronously retrieves the token from the XLANG schedule (through the shared COM object) and is now free from the XLANG schedule.

  • The ASP page can now query the shared SQL table at any time to check for the change of state of the row.

  • The XLANG schedule does its processing. When complete, it updates the row in the shared table with returned data and changes the state to "completed."

  • Eventually, the ASP page query of the row will get the updated state and the returned information.

The following paragraphs provide information about the modules used in this example.

Inventory_OBJECT\XLANG_sample_fruit.dll

This is the simulated business process. Rather than complicating the sample with a complex workflow, this COM object simulates a long-running process.

Public Sub check_storeroom(ByVal str_in_type As String, _

ByVal i_in_amount_requested As Integer, _

ByRef str_out_SKU As String, _

ByRef i_out_amount_available)

This takes a fruit name (str_in_type) and a desired amount (i_in_amount) and eventually returns an order code (str_out_SKU) and amount available (i_out_amount_available).

Note

  • To simulate the processing delay, the business code uses the Sleep function. This function should not be used in a production COM object because it will do things like prevent the long-running XLANG process from being dehydrated. It is used here to simplify the non-essential part of the sample code.

ASP_OBJECT\XLANG_sample_ASP.dll

This is the linking COM object between the ASP page and the XLANG schedules. It is similar to the object used in the XLANG_Samples\ASP example.

It performs two tasks:

  • Provides the synchronization points between the ASP page and the XLANG schedules

  • Persists returned information from XLANG for the ASP to use

Note that this COM object is shared between the blocking.asp sample and the async.asp sample.

Persisted data for blocking.asp are the variables:

Dim stored_SKU As String

Dim stored_amount_available As Integer

Persisted data for async.asp is the variable

Dim stored_WorkID As Integer

This stub function is used by both blocking.asp and async.asp to pass information into their associated XLANG schedules:

Public Sub Request_fruit_amount(ByVal fruit_type As String, _

ByVal amount As Integer)

Note

  • The body of this method is never used. The XLANG schedule performs a "wait for synchronous call." This means that the XLANG schedule provides the body for the method and will wait until another program (the ASP page sharing the COM object) calls the method. The XLANG implementation then provides the arguments that are provided to the data page of the schedule.

For the blocking.asp sample, this method is used by blocking_sample.skv to store return data into the persisted data area:

Public Sub Store_fruit_response(ByVal SKU As String, _

ByVal amount_available As Integer)

For the blocking.asp sample, these methods are used by the ASP page to retrieve the persisted data:

Public Function Get_fruit_SKU() As String

Public Function Get_fruit_amount_available() As Integer

Notes

  • The XLANG schedule blocking_sample.skv performs a "wait for synchronous call" on these methods. This must be done for the sked object that calls these methods so that the VBScript code in the ASP page can access them.

  • In the schedule, the order in which the XLANG schedule waits for these methods must match exactly the order in which the ASP page will call them.

Compared to the blocking.asp sample, the mechanism in async.asp to communicate between the XLANG and ASP is simpler.

The ASP page still calls the Request_fruit_amount method but then uses this method to get a token for the row in the shared table:

Public Function Get_async_WorkID() As Integer

The XLANG schedule async_sample.skv gets the token and stores it through this method:

Public Sub Store_async_WorkID(ByVal iWorkID As Integer)

The XLANG schedule async_sample.skv then synchronizes with the ASP page with Get_async_WorkID

Note

  • The XLANG schedule async_sample.skv synchronizes with the ASP page at only two places. One is at the beginning of the schedule to get the input information and the other is to immediately pass the token information through Get_async_WorkID. The schedule then runs asynchronously from this point onward.

SQL_object\XLANG_SAMPLE_ASYNC_SQL.dll

This is the shared COM object between async.asp and async_sample.skv that handles working with the common SQL table:

Function Register_for_work_id(ByVal strFruitType, _

ByVal iRequestAmount) As String

This method is used by the XLANG schedule async_sample.skv to create a new row in the shared table. The method populates it with the input information and sets the state column (iState) to 0 (processing). The method returns a unique key for the row (WorkID). Any references to the row must use this unique key.

Public Function Update_work_entry(ByVal iWorkID As Integer, _

ByVal iState As Integer, _

ByVal strSKU As String, _

ByVal iAmountAvailable As Integer)

This method is used by the XLANG schedule async_sample.skv when the processing is complete to update the row with the returned information.

Public Function GetWorkItemXML(ByVal iWorkID As Integer) As String

This method is used by async.asp to populate a frame with the state of the row. The returned sting is SQL XML format (SQL table was accessed as "FOR XML AUTO")

Async.asp

This is the user page that invokes the XLANG schedule and then can query for returned information asynchronously.

Note

  • The following code invokes the XLANG schedule and exposes the interface methods used to synchronize with it:

sSkedUrl = "sked:///" & sPath & "async_sample.skx/ASP_async_Interface"

This references the schedule file. Note the addition of the COM interface that should be exposed.

set sked = GetObject(sSkedUrl)

This actually starts the XLANG schedule, which now waits for the first call to request_fruit_amount.

sked.request_fruit_amount sText, sAmount

iWorkID = sked.Get_async_WorkID()

These two lines pass information in and retrieve the token from the schedule (the only synchronous operation with the schedule).

The rest of the ASP page creates a button to invoke Work_item_details.asp to fill the frame at the bottom of the page.

Work_item_details.asp

This ASP page calls GetWorkItemXML to retrieve the state of the schedule's operations and formats the XML for rendering as a table.

The rendering is done by an XSLtransform in workitem_details.xsl.


XLANG Trace

This sample uses a COM object in the library XLANG_TRACE.dll to insert tracing operations into an XLANG schedule. This COM object helps trace and debug problems in an XLANG schedule by writing data from the running schedule into a logging table. Any data that is used in the schedule can be sent to the logging table, including the XML documents being passed between actions in the schedule.

Note

  • This sample is intended only for debugging a specific XLANG schedule. In a production environment, the tracing COM object should not be used because it can significantly impact XLANG schedule processing performance.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE.

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Modifying the Default Configuration

  • Using the Tracing Component

  • Viewing the Trace Results

Programming Notes

After the XLANG_TRACE COM object is registered on a computer running BizTalk Server, you can add one or more bindings to this object in your existing XLANG schedule files. After the object is bound to a schedule, you need to modify the data mapping in the schedule to specify the data being traced. The XLANG_TRACE object contains the following input parameters for recording schedule data:

message_label

String to describe the name of the Action shape.

message_ID

String to hold a unique identifier for this schedule, such as the instance GUID of the schedule.

message_UserKey

String to store a unique document identifier, such as a purchase order number.

message_body

String to store a large amount of data, such as an entire XML document in a message.


Preliminary Setup

Complete the steps outlined in this section to configure your computer to run the XLANG tracing sample.

Configuring the Tracing Database

The default settings of the XLANG tracing sample require a database for storing the tracing data. However, you can modify these settings to use Event Logging instead of, or in addition to, a database. If you do not want to use a database, proceed to the next section, Modifying the Default Configuration.

To use a database for the tracing data, run the command script setup_db.cmd that is located on the installation drive at \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE\setup. This command script file creates the following items:

  • A database named XLANG_TRACE

  • A table in this database named trace_table

  • A stored procedure in this database named Log_text_message

Note

  • If you choose to run this file on a remote computer, you must modify the DBHost value in the Globals.bas file, as described in Modifying the Default Configuration.

Registering the Tracing Component

To register the XLANG_TRACE.dll component, run the command script register_COM.cmd that is located on the installation drive at \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE\setup. The COM object XLANG_TRACE.dll must be registered on each computer that uses it.


Modifying the Default Configuration

The XLANG_TRACE sample can be configured to output tracing information into an SQL table or to the system Event Viewer. By default, the XLANG_TRACE COM object (XLANG_TRACE.dll) is configured to store the trace information in a SQL Server database on the local computer ("localhost"). This configuration assumes that both BizTalk Server and SQL Server are running on the local computer.

To change the settings of the tracing object, you must edit the global variable values in the file Globals.bas, and recompile the Microsoft Visual Basic project named XLANG_TRACE.vbp. The following global variables can be modified:

DBHost

String containing the host name of the computer running SQL Server where the tracing data will be stored. An empty string ("") is used to indicate that tracing data will not be stored to a database. The default value is "localhost".

EventLogging

Boolean that indicates whether tracing data should be logged in the system Event Viewer. A value of True indicates that tracing data is logged in the Event Viewer. The default value is False.

The other variables in the Globals.bas module contain information about the database (DBTraceDatabase) and table (DBTraceTable) names. It is not necessary to modify these values. If these values are changed, the file dumptable.xsl will also require modification.

After you have modified the global variables and saved the Visual Basic project, recompile the project into a new DLL file.

Notes

  • If any changes are made to the COM object after its first use, you might need to stop and restart the XLANG Scheduler Engine to release the cached version of the COM object before the new version can be run. For information on stopping and restarting the XLANG Scheduler Engine, see the following topics in the BizTalk Server Help file:
    • Shut down all XLANG applications

    • Restart all XLANG applications
  • If the dumptable.asp page is used to view the tracing data before changes are made to the tracing object, Internet Information Services (IIS) might also use a cached version of the original object. For more information, see Restarting BizTalk Server and Internet Information Services.

  • When event logging is enabled, the events appear in the application log. The XLANG tracing entries will have a Type value of Information, and a Source value of VBRuntime.


Restarting Biztalk Server and Internet Information Services

If a BizTalk Server schedule or an ASP page references a COM object, it will be locked "in use" and cannot be replaced by a recompile. These services must be restarted to release the cached COM object and allow the COM object to be recompiled.

This procedure explains how to restart Internet Information Services (IIS).

  1. On the Start menu, point to Settings and click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Computer Management.

  4. In the Computer Management console tree, expand Services and Applications and then click Internet Information Services.

  5. On the Action menu, click Restart IIS.

    The Stop/Start/Reboot dialog box appears.

  6. Verify that Restart Internet Services on computer_name is selected.

  7. Click OK to restart IIS.

This procedure restarts the Biztalk Server service that will also hold onto a COM object.

  1. Still using Computer Management, click the Services node and click XLANG Schedule Restart Service near the bottom.

  2. On the Action menu, click Restart


Using the Tracing Component

After the tracing component has been configured and registered, you can add one or more references to it in any XLANG schedule. To add the tracing component to an XLANG schedule, complete the following steps:

  1. Open your XLANG schedule drawing (.skv) in BizTalk Orchestration Designer.

  2. Add a COM component implementation shape to the right side of the Business Process drawing.

  3. Complete the COM Component Binding Wizard and select the Logger class from XLANG_TRACE in the list of registered components.

  4. Add an Action shape to the left side of the Business Process drawing.

  5. Connect the process flow arrow from the bottom of the preceding shape into the top of the new Action shape.

  6. Connect the process flow arrow from the bottom of the new Action shape into the top of the following shape.

  7. Click the new Action shape to highlight it, and then drag the connection point on the right side of the Action shape to the connection point on the left side of the port that is associated with the XLANG_TRACE COM object.

  8. Complete the Method Communication Wizard.

  9. Re-map the data flow on the Data page. You can set the input values of the XLANG_TRACE LogStringMessage method by using other messages on the Data page or by using constants.

  10. Save and re-compile your XLANG schedule. It might be helpful to save the file as a separate tracing version by using a different name. For example, a new version of a file named myschedule.skv can be named myschedule_trace.skv.

  11. Run the new schedule and view the tracing information in the database or in Event Viewer, depending on your configuration.

For additional information about using BizTalk Orchestration Designer, see the BizTalk Server Help file.


Viewing the Trace Results

The tracing information that is stored in the database can be viewed directly through SQL Server. To view this data, follow these steps:

  1. On the Start menu, point to Programs, point to Microsoft SQL Server, and click Enterprise Manager.

  2. Expand the Microsoft SQL Servers tree, and expand the group and server name of the computer that is running the database for the XLANG tracing information.

  3. Expand the Databases folder, expand the XLANG_TRACE database, and then click Tables.

  4. Right-click the table named trace_table, and then point to Open Table and click Return all rows.

The tracing information that is stored in the database can also be accessed by using the file Dumptable.asp located in the folder \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE\ASP on the BizTalk Server installation drive.

Notes

  • To use the ASP file, you must either map the ASP folder as a virtual directory in Internet Information Services (IIS), or place the contents of the ASP folder into an existing virtual directory.

  • You might need to add the Internet user account (ISR_computername) to allow IIS access to the database.

Event Viewer logs can be accessed in the Computer Management console.


XML Translation

This sample demonstrates how to use the SubmitSync method of BizTalk Server to perform an XML transformation by using BizTalk Orchestration Services.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XML Translation

User's Guide

The sample consists of the following modules:

  • A Visual Basic ActiveX DLL contains the component called by the schedule to get the submission parameters.

  • The loopback.vbs script contains the code to run the schedule.

The setup script, setup.cmd, does the following:

  • Registers the ProcessDoc component

  • Creates message queues.

  • Creates BizTalk Configuration objects.

To remove the sample, run remove.cmd and delete the copied files from the directories.

To run the sample, run loopback.vbs. The script sends SamplePOData.xml to the received_in message queue and starts the loopback.skx schedule.

Programming Notes

This sample demonstrates the use of the SubmitSync call using BizTalk Orchestration Services to do the XML transformations. The schedule picks up the document from the received_in queue and then calls GetSubmitParams to get parameters for calling SubmitSync. When the SubmitSync call is returned, the transformed document is returned in the out parameter, which is displayed and then sent to the biztalk_out message queue.


BizTalk Server Reference

This section contains the following topics:

  • Messaging Services Reference

  • Documents Reference

  • Custom Components Reference

  • Orchestration Services Reference

  • Managing and Monitoring Reference

  • Error Messages


Messaging Services Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for accessing messaging services:

  • Interfaces

  • Enumerations

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented:

  • IBizTalkBase

  • IBizTalkCertificateInfo

  • IBizTalkChannel

  • IBizTalkConfig

  • IBizTalkDocument

  • IBizTalkEndPoint

  • IBizTalkEnvelope

  • IBizTalkLoggingInfo

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

  • IBizTalkServiceWindowInfo

  • IBizTalkTransportInfo

  • IDictionary

  • ISimpleList


IBizTalkBase

Defines common methods and properties inherited by several messaging services objects.

Hierarchy

IDispatch

|--IBizTalkBase

Declaration

[Visual Basic]

Class IBizTalkBase

[C++]

interface IBizTalkBase : IDispatch

Members

IBizTalkBase defines the following properties:

Property | Description
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
Name | Contains the name of the object.

IBizTalkBase defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Remarks

The following interfaces inherit properties and methods from IBizTalkBase:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Note

  • The methods and properties of IBizTalkBase are always invoked on the objects listed above, rather than by creating an actual IBizTalkBase object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Clear Method

Clears the object from memory.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Clear( )

[C++]

HRESULT Clear( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

After Clear is called, all member variables of the object in memory are initialized to their default values.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Create Method

Creates a new object in the database.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Function Create( ) As Long

[C++]

HRESULT Create(

long* BiztalkObjectHandle

);

Parameters

BiztalkObjectHandle

[out, retval] In C++, contains a handle to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a handle to the object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The Name property must be set before calling this method. Name must be unique across the database for each object type. Create updates the DateModified property.

When creating any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


DateModified Property

Contains the date and time at which the information in the object was created or last modified.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Property Declaration

[Visual Basic]

Property DateModified As String

[C++]

HRESULT get_DateModified(

BSTR* Modified

);

Parameters

Modified

[out, retval] In C++, contains the date modified. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the date modified.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The format for the Modified string is yyyy-mm-dd hh:mm:ss. The time is in coordinated universal time (UTC). The server sets this property when the Create or the Save method is called for the object.

The following objects support this property:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Handle Property

Contains the handle to the object.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Property Declaration

[Visual Basic]

Property Handle( ) As Long

[C++]

HRESULT get_Handle(

long* BiztalkObjectHandle

);

Parameters

BiztalkObjectHandle

[out, retval] In C++, contains the handle to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property contains the handle to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The following objects support this property:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Load Method

Loads a specified object in memory.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Load( _

BiztalkObjectHandle As Long _

)

[C++]

HRESULT Load(

long BiztalkObjectHandle

);

Parameters

BiztalkObjectHandle

[in] Contains the handle to the object to load.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Load calls the Clear method internally before loading the object.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


LoadByName Method

Loads a specified object by name in memory.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub LoadByName( _

Name As String_

)

[C++]

HRESULT LoadByName(

BSTR Name

);

Parameters

Name

[in] Contains the name of the object to load.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

LoadByName calls the Clear method internally before loading the object.

Names have a maximum length of 64 characters.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Name Property

Contains the name of the object.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--LoadLat_SDK_BTCOM_Base_GQNF

|--LoadByName

|--Name

|--Remove

|--Save

Property Declaration

[Visual Basic]

Property Name( ) As String

[C++]

HRESULT get_Name(

BSTR* Name

);

HRESULT put_Name(

BSTR Name

);

Parameters

Name

[out, retval], [in] In C++, contains the name of the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The server requires the Name property. It must be set before calling the Create or the Save method for the object. Name must be unique across a database for each object type and must be at least one character long. Names have a maximum length of 64 characters.

The following table lists names reserved for use by BizTalk Server:

Name | Object type
Reliable Message Acknowledgement Port | IBizTalkPort
Reliable Message Acknowledgement Channel | IBizTalkChannel
BizTalk Canonical Receipt | IBizTalkDocument
Reliable Messaging Acknowledgement | IBizTalkDocument
Reliable Messaging Acknowledgement SMTP From Address | IBizTalkOrganization
Home Organization | IBizTalkOrganization

The following objects support this property:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Remove Method

Removes the object from the database.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Remove( )

[C++]

HRESULT Remove( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The object cannot be removed if any other object refers to it.

A BizTalkOrganization object cannot be removed if it is the default organization. Before it can be removed, the IsDefault property must be set to False, and another organization must have the IsDefault property set to True.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Referential Integrity


Save Method

Saves the object in the database.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Save( )

[C++]

HRESULT Save( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The Save method updates the DateModified property.

When saving any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo

Configures a certificate associated with an IBizTalkPort or IBizTalkChannel object.

Hierarchy

IDispatch

|--IBizTalkCertificateInfo

Declaration

[Visual Basic]

Class BizTalkCertificateInfo

[C++]

interface IBizTalkCertificateInfo : IDispatch

Members

IBizTalkCertificateInfo defines the following properties:

Property | Description
Name | Contains the name of the certificate.
Reference | Contains a reference to the certificate in the certificate store.
Store | Contains the store type for the certificate.
Usage | Contains the type of use for the certificate.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Certificates


Name Property

Contains the name of the certificate.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Name As String

[C++]

HRESULT get_Name(

BSTR* Name

);

Parameters

Name

[out, retval] In C++, contains the name of the certificate. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the certificate.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Reference Property

Contains a reference to the certificate in the certificate store.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Reference As String

[C++]

HRESULT get_Reference(

BSTR* Reference

);

HRESULT put_Reference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the certificate reference. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate reference.

In C++, this property returns an HRESULT value, indicating success or failure.

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, the put method returns CryptoAPI errors. Additional information about CryptoAPI is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). A reference to a certificate should be obtained by using the Certificates property on the IBizTalkConfig object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Store Property

Contains the store type for the certificate.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Store As BIZTALK_STORE_TYPE

[C++]

HRESULT get_Store(

BIZTALK_STORE_TYPE* StoreType

);

HRESULT put_Store(

BIZTALK_STORE_TYPE StoreType

);

Parameters

StoreType

[out, retval], [in] In C++, contains the store type for the certificate. Valid values for this parameter are defined by the BIZTALK_STORE_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_STORE_TYPE enumeration.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The store, which contains the certificate, is determined by the use of the certificate as follows:

Certificate type | Store
Decryption | MY
Encryption | BIZTALK
Signature | MY
Verify signature | BIZTALK

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Usage Property

Contains the type of use for the certificate.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Usage As BIZTALK_USAGE_TYPE

[C++]

HRESULT get_Usage(

BIZTALK_USAGE_TYPE* UsageType

);

Parameters

UsageType

[out, retval] In C++, contains the usage type for the certificate. Valid values for this parameter are defined by the BIZTALK_USAGE_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_USAGE_TYPE enumeration.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel

Configures a channel for processing documents.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkChannel

Declaration

[Visual Basic]

Class BizTalkChannel

[C++]

interface IBizTalkChannel : IBizTalkBase

Members

IBizTalkChannel defines the following properties:

Property | Description
Comments | Contains user comments for the object.
ControlNumberValue | Contains the value of the group control number.
DateModified | Contains the date and time at which the information in the object was created or last modified.
DecryptionCertificateInfo | Contains information about the certificate that decrypts the input document.
ExpectReceiptTimeout | Contains the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.
Expression | Contains a complete set of equations that filter the selection of the object.
Handle | Contains the identifier of the object.
InputDocument | Contains the handle to the input IBizTalkDocument object that describes the input document specification.
IsReceiptChannel | Contains the flag that indicates whether the object is a receipt channel.
LoggingInfo | Contains information about logging the document.
MapContent | Contains the contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.
MapReference | Contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.
Name | Contains the name of the object.
OutputDocument | Contains the handle to the output IBizTalkDocument object that describes the output document specification.
Port | Contains the handle to the associated IBizTalkPort object.
PortGroup | Contains the handle to the associated IBizTalkPortGroup object.
ReceiptChannel | Contains the handle to the receipt channel for this object.
RetryCount | Contains the number of times to retry submitting a document when a destination connection failure occurs.
RetryInterval | Contains the amount of time, in minutes, between retry attempts when a destination connection failure occurs during document submission.
SignatureCertificateInfo | Contains information about the certificate that signs the output document.
SourceEndpoint | Contains information about the source.
TrackFields | Contains the IDictionary object that points to the specification that contains fields to track interchange data on input documents for this IBizTalkChannel object.
VerifySignatureCertificateInfo | Contains information about the certificate that verifies the signature of the input document.

IBizTalkChannel defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
GetConfigComponent | Retrieves the CLSID of the component associated with the IBizTalkPort object.
GetConfigData | Retrieves the configuration associated with the specified IBizTalkPort object.
Load | Loads an object in memory.
LoadByName | Loads an object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.
SetConfigComponent | Sets the CLSID of the component associated with the IBizTalkPort object.
SetConfigData | Sets the configuration information for the associated IBizTalkPort object.

Remarks

An IBizTalkChannel object requires an associated complete IBizTalkPort object. One or more IBizTalkChannel objects can be associated with an IBizTalkPort object. An IBizTalkChannel object can be associated with only one input IBizTalkDocument object and one output IBizTalkDocument object; however, an IBizTalkDocument object can be associated with more than one IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Channels

Document Processing


Comments Property

Contains the user comments for the object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property Comments As String

[C++]

HRESULT get_Comments(

BSTR* Comments

);

HRESULT put_Comments(

BSTR Comments

);

Parameters

Comments

[out, retval], [in] In C++, contains the user comments for the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the user comments for the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ControlNumberValue Property

Contains the value of the group control number.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property ControlNumberValue As String

[C++]

HRESULT get_ControlNumberValue(

BSTR* strControlNumberValue

);

HRESULT put_ControlNumberValue(

BSTR strControlNumberValue

);

Parameters

strControlNumberValue

[out, retval], [in] In C++, contains the value of the group control number. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the value of the group control number.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The ControlNumberValue property must contain a value between 1 and 999999999.

If the Format property of the IBizTalkEnvelope object for the associated IBizTalkPort object is set to X12, EDIFACT, or Custom, this property is required.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


DecryptionCertificateInfo Property

Contains information about the certificate that decrypts the input document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property DecryptionCertificateInfo As Object

[C++]

HRESULT get_DecryptionCertificateInfo(

IDispatch** DecryptionCertificateInfoDisp

);

HRESULT putref_DecryptionCertificateInfo(

IDispatch* DecryptionCertificateInfoDisp

);

Parameters

DecryptionCertificateInfoDisp

[out, retval], [in] In C++, contains the information about the certificate that decrypts the input document. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the information about the certificate that decrypts the input document.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the IBizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ExpectReceiptTimeout Property

Contains the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property ExpectReceiptTimeout As Long

[C++]

HRESULT get_ExpectReceiptTimeout(

long* Minutes

);

HRESULT put_ExpectReceiptTimeout(

long Minutes

);

Parameters

Minutes

[out, retval], [in] In C++, contains the time, in minutes, in which to expect the receipt for the current document before treating the document as expired. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of 0.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Expression Property

Contains a complete set of equations that filter the selection of the object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property Expression As String

[C++]

HRESULT get_Expression(

BSTR* Expression

);

HRESULT put_Expression(

BSTR Expression

);

Parameters

Expression

[out, retval], [in] In C++, contains a complete set of equations that filter the selection of the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a complete set of equations that filter the selection of the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). If the expression evaluates to true, the server selects the channel for processing the document.

The XPath expression must be based on the input document specification set in the InputDocument property.

Note

  • If the specification field that you are using to create an expression has a Boolean data type, you cannot use the text strings "true" or "false" as the expression value. You must use a numerical value instead: "-1" for true and "0" for false. For example, to filter a channel so it processes only approved purchase orders, your expression might look like this:

Channel1.Expression = "/PORequest/Total[IsApproved = -1]"

This sample assumes that the input document specification contains a Total subelement with a Boolean IsApproved field.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Channel Filtering


GetConfigComponent Method

Retrieves the CLSID of the component associated with the IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Function GetConfigComponent( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

PortHandle As Long _

) As String

[C++]

HRESULT GetConfigComponent(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long PortHandle,

BSTR* CLSID

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

PortHandle

[in] Contains the handle to the IBizTalkPort object.

CLSID

[out, retval] In C++, contains the CLSID of the component associated with the IBizTalkPort object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the CLSID of the component associated with the IBizTalkPort object.

In C++, this method returns an HRESULT value, indicating success or failure.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If the ConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated IBizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


GetConfigData Method

Retrieves the configuration associated with the specified IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Function GetConfigData( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

PortHandle As Long, _

Type As Variant _

)

[C++]

HRESULT GetConfigData(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long PortHandle,

VARIANT* Type,

VARIANT* Dictionary

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

PortHandle

[in] Identifies the handle to the associated IBizTalkPort object.

Type

[in, out] Contains the transport type.

Dictionary

[in, out] In C++, contains the IDictionary interface of an object that contains the primary transport configuration information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an IDictionary object that contains the primary transport configuration information.

In C++, this method returns an HRESULT value, indicating success or failure.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When reading serializer data, the IDictionary object returned by this method has specific string qualifiers used for EDIFACT and X12. The following tables describe these strings.

EDIFACT

Qualifier string | Description
SerializerEdifact_SenderIntID | Interchange sender internal identification
SerializerEdifact_SenderIntSubID | Interchange sender internal subidentification
SerializerEdifact_RecipientIntID | Interchange recipient internal identification
SerializerEdifact_RecipientIntSubID | Interchange recipient internal subidentification
SerializerEdifact_RecipientRefPwd | Recipient reference/password
SerializerEdifact_RecipientRefPwdQual | Recipient reference/password qualifier
SerializerEdifact_ApplicationRef | Application reference
SerializerEdifact_ProcPriCode | Processing priority code
SerializerEdifact_AckRequest | Acknowledgment request
SerializerEdifact_AgreementID | Interchange agreement identifier
SerializerEdifact_TestInd | Test indicator
SerializerEdifact_UNACtrl | "Send UNA Always" or "Send UNA Only When Required"
SerializerEdifact_SyntaxID | Syntax identifier

X12

Qualifier string | Description
SerializerX12_AuthInfoQual | Authorization information qualifier
SerializerX12_AuthInfo | Authorization information
SerializerX12_SecInfoQual | Security information qualifier
SerializerX12_SecInfo | Security information
SerializerX12_CtrlStdID | Interchange control standards identifier
SerializerX12_CtrlVerNum | Interchange control version number
SerializerX12_AckRequired | Acknowledgment required
SerializerX12_UseInd | Usage indicator

Note

  • For more information about the EDIFACT standard, see the United Nations Economic Commission for Europe Web site (www.unece.org).

  • For more information about the X12 standard, see the Data Interchange Standards Association Web site (www.disa.org).

If you override the transport properties of an IBizTalkPort object with this method and then change the transport properties in that IBizTalkPort object, you must call this method again.

If the ConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated IBizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty IDictionary object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


InputDocument Property

Contains the handle to the input IBizTalkDocument object that describes the input document specification.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property InputDocument As Long

[C++]

HRESULT get_InputDocument(

long* InDocHandle

);

HRESULT put_InputDocument(

long InDocHandle

);

Parameters

InDocHandle

[out, retval], [in] In C++, contains the handle of the input IBizTalkDocument object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle of the input IBizTalkDocument object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property.

This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Configuring

Document Definitions

Document Processing


IsReceiptChannel Property

Contains a flag that indicates whether the object is a receipt channel.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property IsReceiptChannel As Boolean

[C++]

HRESULT get_IsReceiptChannel(

VARIANT_BOOL* IsReceiptChannel

);

HRESULT put_IsReceiptChannel(

VARIANT_BOOL IsReceiptChannel

);

Parameters

IsReceiptChannel

[out, retval], [in] In C++, contains a value indicating whether or not the channel is a receipt channel. VARIANT_TRUE indicates that this channel is a receipt channel; VARIANT_FALSE indicates that this channel is not a receipt channel. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value indicating whether or not the channel is a receipt channel. True indicates that this channel is a receipt channel; False indicates that this channel is not a receipt channel.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

ReceiptChannel


LoggingInfo Property

Contains information about logging the document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property LoggingInfo As Object

[C++]

HRESULT get_LoggingInfo(

IDispatch** LoggingInfoDisp

);

HRESULT putref_LoggingInfo(

IDispatch* LoggingInfoDisp

);

Parameters

LoggingInfoDisp

[out, retval], [in] In C++, contains the logging fields. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the logging fields.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Information contained by this property includes the LogNativeInputDocument, LogNativeOutputDocument, LogXMLInputDocument, and LogXMLOutputDocument properties and is created and stored in memory in the IBizTalkLoggingInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


MapContent Property

Contains the contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property MapContent As String

[C++]

HRESULT get_MapContent(

BSTR* MapContent

);

onkeypress="expand(expand3, img3)" onclick="expand(expand3, img3)"> Parameters

MapContent

[in] In C++, contains the map contents. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the map contents.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). This is a read-only property. The Create and Save methods copy the text of the map specified by the MapReference property to this string, if empty.

Once you have created or saved a IBizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring IBizTalkChannel object. To update the IBizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the IBizTalkChannel object to its current value, and then call Save on the referring IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


MapReference Property

Contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property MapReference As String

[C++]

HRESULT get_MapReference(

BSTR* Reference

);

HRESULT put_MapReference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the map name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the map name.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). This is a required property if the InputDocument property refers to a different document specification than the OutputDocument property.

Once you have created or saved a IBizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring IBizTalkChannel object. To update the IBizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the IBizTalkChannel object to its current value, and then call Save on the referring IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


OutputDocument Property

Contains the handle to the IBizTalkDocument object that describes the output document specification.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property OutputDocument As Long

[C++]

HRESULT get_OutputDocument(

long* OutDocHandle

);

HRESULT put_OutputDocument(

long OutDocHandle

);

Parameters

OutDocHandle

[out, retval], [in] In C++, contains the handle to the output IBizTalkDocument object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the output IBizTalkDocument object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property. This property cannot be changed after the Create or the Save method is called.

If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_SOURCE, the InputDocument property can identify an input IBizTalkDocument object that has an X12 or an EDIFACT specification. If it does, however, OutputDocument must not identify an IBizTalkDocument object that has an X12 or an EDIFACT specification.

If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the OutputDocument property for this IBizTalkChannel object must not identify an output IBizTalkDocument object that has an X12 or an EDIFACT specification.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions


Port Property

Contains the handle to the associated IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property Port As Long

[C++]

HRESULT get_Port(

long* PortHandle

);

HRESULT put_Port(

long PortHandle

);

Parameters

PortHandle

[out, retval], [in] In C++, contains the handle to the IBizTalkPort object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the IBizTalkPort object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The following constraints are enforced:

  • Either the Port or the PortGroup property must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Messaging Ports


PortGroup Property

Contains the handle to the associated IBizTalkPortGroup object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property PortGroup As Long

[C++]

HRESULT get_PortGroup(

long* PortGroupHandle

);

HRESULT put_PortGroup(

long PortGroupHandle

);

Parameters

PortGroupHandle

[out, retval], [in] In C++, contains the handle to the associated IBizTalkPortGroup object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the associated IBizTalkPortGroup object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The following constraints are enforced:

  • Either the Port property or PortGroup must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Port Groups


ReceiptChannel Property

Contains the handle to the receipt channel for this object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property ReceiptChannel As Long

[C++]

HRESULT get_ReceiptChannel(

long* ReceiptChannelHandle

);

HRESULT put_ReceiptChannel(

long ReceiptChannelHandle

);

Parameters

ReceiptChannelHandle

[out, retval], [in] In C++, contains the handle to the receipt channel. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the receipt channel.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. An IBizTalkChannel object can specify a receipt channel only if it is not a receipt channel itself. The channel specified as the receipt channel must have the IsReceiptChannel property set to TRUE. In addition, the receipt channel must use a messaging port with a DestinationEndpoint that is the same as the SourceEndpoint on the channel using the receipt channel. This allows the receipt channel to send a receipt to the original source of the document.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RetryCount Property

Contains the number of times to retry submitting a document when a destination connection failure occurs.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property RetryCount As Long

[C++]

HRESULT get_RetryCount(

long* Count

);

HRESULT put_RetryCount(

long Count

);

Parameters

Count

[out, retval], [in] In C++, contains the number of retries. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of retries.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The RetryCount property must contain a value between 0 and 999. The default value is 3 retries.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RetryInterval Property

Contains the amount of time, in minutes, between retry attempts when a destination connection failure occurs during document submission.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property RetryInterval As Long

[C++]

HRESULT get_RetryInterval(

long* Interval

);

HRESULT put_RetryInterval(

long Interval

);

Parameters

Interval

[out, retval], [in] In C++, contains the retry interval, in minutes. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the retry interval, in minutes.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The RetryInterval property must contain a value between 1 and 63999. The default value is 5 minutes.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SetConfigComponent Method

Sets the CLSID of the component associated with the IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Sub SetConfigComponent( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

PortHandle As Long, _

CLSID As String _

)

[C++]

HRESULT SetConfigComponent(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long PortHandle,

BSTR CLSID

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

PortHandle

[in] Contains the handle.

CLSID

[in] Contains the CLSID of the component.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SetConfigData Method

Sets the configuration information for the associated IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Sub SetConfigData( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

ConfigDataHandle As Long, _

ConfigDataDisp As Object _

)

[C++]

HRESULT SetConfigData(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long ConfigDataHandle,

IDispatch* ConfigDataDisp

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

ConfigDataHandle

[in] Identifies the handle to the associated IBizTalkPort object.

ConfigDataDisp

[in] IDictionary object that contains information about the component specified in the ConfigType parameter.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The IDictionary object passed to this method has specific string qualifiers used for EDIFACT and X12. For a description of these qualifiers, see the GetConfigData Method.

When using the BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT or BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT enumeration value, the content of the transport dictionary varies according to the transport protocol used. The following tables list the transport dictionary fields for each protocol.

HTTP and HTTPS

Field name | Data type | Required | Description
URL | String | Yes | URL of the document destination.
ContentType | String | No | Value for the Content-Type HTTP/HTTPS property that appears in HTTP headers during transmission. The default value is an empty string ("").
ClientCert | String | No | Reference to the certificate used with SSL connections using HTTPS. The default value is an empty string ("").
ProxyName | String | No | URL of the proxy server used when sending documents outside a firewall.
ProxyPort | Integer | No | Port number used by the proxy server.
UseProxy | Boolean | No | Value that indicates whether the proxy server is used. The default value is True.

Local File

Field name | Data type | Required | Description
Filename | String | Yes | Name and path of the file to be created.
CopyMode | Integer | No | Value that indicates how the file should be written. Use a value of 0 for overwrite mode, a value of 1 for append mode, and a value of 2 to create a new file. The default value is append mode (1).
UserName | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").
Password | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").

Message Queuing

Field name | Data type | Required | Description
QueueName | String | Yes | Name of the Messaging Queue to which the document is sent.
MessageLabel | String | Yes | Value specified in the message label field on the queue.
Priority | Integer | No | Priority of the message placed in the queue. This must be a value between 0 and 7, where a higher value indicates a higher priority. The default value is 3
AuthLevel | Integer | No | Value indicating whether the message needs to be authenticated using a digital signature. Use a value of 0 to bypass authentication. A value of 1 indicates that authentication will be used. The default value is 0.
Delivery | Integer | No | Value indicating how a message is delivered to a queue. Use a value of 1 to indicate that the message should be backed up until it is delivered to the queue. A value of 0 indicates that the message is only resident in memory. The default value is 0.

Notes

  • When you override messaging port properties in a channel, the overrides apply only to that channel. No errors are generated as a result of overriding previous values.

  • You cannot override the transport address that was set in a messaging port.

  • The default setting for the HTTP transport component is to use the HTTP proxy server. This is the correct setting to transport data to Web sites outside your business's firewall. To transport data to Web sites that are inside your business's firewall (that is, within your intranet), modify the transport dictionary values to override the default setting.

  • For the HTTPS transport component, use only certificates that are specified for client authentication.

  • The default setting for the file transport component is to append files (CopyMode=1). If you choose the file transport type with its default settings in a messaging port and use antivirus software on the server on which BizTalk Server 2002 is installed, and you send multiple files that have exactly the same name to the same file location, at the same time, BizTalk Server 2002 might stop responding and must be restarted. You can eliminate this problem by changing the default setting for the file transport component to overwrite (CopyMode=0). You also can eliminate this problem by creating a unique file for each document instance processed by using %tracking_id% in the Address property of the IBizTalkTransportInfo object.

To access the properties in a custom component dictionary through BizTalk Messaging Manager, you must create ASP pages in the \Program Files\BizTalk Server\MessagingManager\pipeline folder. These ASP pages provide a dialog box for editing the properties of your custom component. This dialog box is displayed from the channel Advanced Configuration page when you click Advanced and then click Properties on the Primary Transport tab. For additional information about the ASP pages, see Working with Serializers. For a sample that uses SetConfigData with custom property pages, see Synchronous Orchestration Component.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SignatureCertificateInfo Property

Contains information about the certificate that signs the output document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property SignatureCertificateInfo As Object

[C++]

HRESULT get_SignatureCertificateInfo(

IDispatch** SignatureCertificateInfoDisp

);

HRESULT putref_SignatureCertificateInfo(

IDispatch* SignatureCertificateInfoDisp

);

Parameters

SignatureCertificateInfoDisp

[out, retval], [in] In C++, contains the certificate information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SourceEndpoint Property

Contains information about the source.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property SourceEndpoint As Object

[C++]

HRESULT get_SourceEndpoint(

IDispatch** SrcEndpointDisp

);

HRESULT putref_SourceEndpoint(

IDispatch* SrcEndpointDisp

);

Parameters

SrcEndpointDisp

[out, retval], [in] In C++, contains information about the source. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns information about the source.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Alias, Application, and Organization properties and is created and stored in memory in the IBizTalkEndPoint object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


TrackFields Property

Contains the IDictionary object that points to the specification that contains fields to track interchange data on input documents for this BizTalkChannel object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property TrackFields As Object

[C++]

HRESULT get_TrackFields(

IDispatch** TrackFieldsDisp

);

HRESULT putref_TrackFields(

IDispatch* TrackFieldsDisp

);

Parameters

TrackFieldsDisp

[out, retval], [in] In C++, contains the custom tracking fields. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the custom tracking fields.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The tracking fields specified by this property override the fields set in the TrackFields property on the IBizTalkDocument object.

The fields in the IDictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the IDictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the IDictionary object, and set the value to an ISimpleList object. The ISimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the IDictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Tracking


VerifySignatureCertificateInfo Property

Contains information about the certificate that verifies the signature of the input document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property VerifySignatureCertificateInfo As Object

[C++]

HRESULT get_VerifySignatureCertificateInfo(

IDispatch** VerifySignatureCertificateInfoDisp

);

HRESULT putref_VerifySignatureCertificateInfo(

IDispatch* VerifySignatureCertificateInfoDisp

);

Parameters

VerifySignatureCertificateInfoDisp

[out, retval], [in] In C++, contains the certificate information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the IBizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig

Creates channels, document specifications, envelopes, organizations, ports, and port groups.

Hierarchy

IDispatch

|--IBizTalkConfig

Declaration

[Visual Basic]

Class BizTalkConfig

[C++]

interface IBizTalkConfig : IDispatch

Members

IBizTalkConfig defines the following properties:

Property | Description
Certificates | Contains an ADO recordset that contains all specified certificates.
Channels | Contains an ADO recordset that contains all IBizTalkChannel objects.
Documents | Contains an ADO recordset that contains all IBizTalkDocument objects.
Envelopes | Contains an ADO recordset that contains all IBizTalkEnvelope objects.
Organizations | Contains an ADO recordset that contains all IBizTalkOrganization objects.
PortGroups | Contains an ADO recordset that contains all IBizTalkPortGroup objects.
Ports | Contains an ADO recordset that contains all IBizTalkPort objects.

IBizTalkConfig defines the following methods:

Method | Description
CreateChannel | Returns a new IBizTalkChannel object.
CreateDocument | Returns a new IBizTalkDocument object.
CreateEnvelope | Returns a new IBizTalkEnvelope object.
CreateOrganization | Returns a new IBizTalkOrganization object.
CreatePort | Returns a new IBizTalkPort object.
CreatePortGroup | Returns a new IBizTalkPortGroup object.

Remarks

Each object created by using one of the methods of this interface inherits the following common methods from IBizTalkBase:

  • DateModified

  • Handle

  • Name

  • Clear

  • Create

  • Load

  • LoadByName

  • Remove

  • Save

When IBizTalkPort and IBizTalkChannel objects are created, BizTalk Server automatically creates some associated subobjects. You can access these subobjects by using properties of the IBizTalkPort and IBizTalkChannel objects.

The relationship between objects, their subobjects, and the properties used to obtain the subobjects is shown in the following table.

Subobject | Associated object | Property to set
BizTalkEndPoint | BizTalkPort | DestinationEndpoint
BizTalkEndPoint | BizTalkChannel | SourceEndpoint
BizTalkLoggingInfo | BizTalkChannel | LoggingInfo
BizTalkTransportInfo | BizTalkPort | PrimaryTransport, SecondaryTransport
BizTalkServiceWindowInfo | BizTalkPort | ServiceWindowInfo
BizTalkCertificateInfo | BizTalkPort | EncryptionCertificateInfo
BizTalkCertificateInfo | BizTalkChannel | SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Certificates Property

Contains an ADO recordset that contains all specified certificates.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Certificates( _

StoreType As BIZTALK_STORE_TYPE, _

UsageType As BIZTALK_USAGE_TYPE, _

NamePrefix As String _

) As Object

[C++]

HRESULT get_Certificates(

BIZTALK_STORE_TYPE StoreType,

BIZTALK_USAGE_TYPE UsageType,

BSTR NamePrefix,

IDispatch** CertsDisp

);

Parameters

StoreType

[in] Determines the store type. Valid values for this parameter are defined by the BIZTALK_STORE_TYPE enumeration.

UsageType

[in] Determines the usage type. Valid values for this parameter are defined by the BIZTALK_USAGE_TYPE enumeration.

NamePrefix

[in] Contains a prefix used as the selection criteria for certificate names. Any certificate Name starting with this value is returned in the recordset. This value is case sensitive.

CertsDisp

[out, retval] Contains all specified certificates. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all specified certificates.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkCertificateInfo object in the database. The fields in each record contain the following information:

Field content | Item number
Name | 0
Reference | 1
Store | 2
Usage | 3

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Channels Property

Contains an ADO recordset that contains all IBizTalkChannel objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Channels As Object

[C++]

HRESULT get_Channels(

IDispatch** ChannelsDisp

);

Parameters

ChannelsDisp

[out, retval] Contains all IBizTalkChannel objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkChannel objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkChannel object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


CreateChannel Method

Returns a new IBizTalkChannel object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateChannel( ) As Object

[C++]

HRESULT CreateChannel(

IDispatch** ChannelDisp

);

Parameters

ChannelDisp

[out, retval] Contains a new IBizTalkChannel object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkChannel object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateDocument Method

Returns a new IBizTalkDocument object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateDocument( ) As Object

[C++]

HRESULT CreateDocument(

IDispatch** DocumentDisp

);

Parameters

DocumentDisp

[out, retval] Contains a new IBizTalkDocument object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkDocument object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateEnvelope Method

Returns a new IBizTalkEnvelope object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateEnvelope( ) As Object

[C++]

HRESULT CreateEnvelope(

IDispatch** EnvelopeDisp

);

Parameters

EnvelopeDisp

[out, retval] Contains a new IBizTalkEnvelope object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkEnvelope object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateOrganization Method

Returns a new IBizTalkOrganization object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateOrganization( ) As Object

[C++]

HRESULT CreateOrganization(

IDispatch** OrganizationDisp

);

Parameters

OrganizationDisp

[out, retval] Contains a new IBizTalkOrganization object. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkOrganization object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreatePort Method

Returns a new IBizTalkPort object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreatePort( ) As Object

[C++]

HRESULT CreatePort(

IDispatch** PortDisp

);

Parameters

PortDisp

[out, retval] Contains a new IBizTalkPort object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkPort object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreatePortGroup Method

Returns a new IBizTalkPortGroup object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreatePortGroup( ) As Object

[C++]

HRESULT CreatePortGroup(

IDispatch** PortGroupDisp

);

Parameters

PortGroupDisp

[out, retval] Contains a new IBizTalkPortGroup object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkPortGroup object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Documents Property

Contains an ADO recordset that contains all IBizTalkDocument objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Documents( ) As Objects

[C++]

HRESULT get_Documents(

IDispatch** DocumentsDisp

);

Parameters

DocumentsDisp

[out, retval] Contains all BizTalkDocument objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all BizTalkDocument objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkDocument object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Envelopes Property

Contains an ADO recordset that contains all IBizTalkEnvelope objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Envelopes( ) As Objects

[C++]

HRESULT get_Envelopes(

IDispatch** EnvelopesDisp

);

Parameters

EnvelopesDisp

[out, retval] Contains all IBizTalkEnvelope objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkEnvelope objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkEnvelope object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2
Format | 3

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Organizations Property

Contains an ADO recordset that contains all IBizTalkOrganization objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Organizations( ) As Objects

[C++]

HRESULT get_Organizations(

IDispatch** OrganizationsDisp

);

Parameters

OrganizationsDisp

[out, retval] Contains all IBizTalkOrganization objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkOrganization objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkOrganization object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2
IsDefault | 3

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


PortGroups Property

Contains an ADO recordset that contains all IBizTalkPortGroup objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property PortGroups( ) As Objects

[C++]

HRESULT get_PortGroups(

IDispatch** PortGroupsDisp

);

Parameters

PortGroupsDisp

[out, retval] Contains all IBizTalkPortGroup objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkPortGroup objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkPortGroup object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Ports Property

Contains an ADO recordset that contains all IBizTalkPort objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Ports( ) As Objects

[C++]

HRESULT get_Ports(

IDispatch** PortsDisp

);

Parameters

PortsDisp

[out, retval] Contains all IBizTalkPort objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkPort objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkPort object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


IBizTalkDocument

Identifies and describes the document specification of a document.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkDocument

Declaration

[Visual Basic]

Class BizTalkDocument

[C++]

interface IBizTalkDocument : IBizTalkBase

Members

IBizTalkDocument defines the following properties:

Property | Description
Content | Contains the content of the document specification described by the object.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
NameSpace | Contains the string that resolves naming conflicts between elements in a document.
PropertySet | Contains an IDictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input.
Reference | Contains the full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by this IBizTalkDocument object.
TrackFields | Contains an IDictionary object that stores the custom fields that Tracking uses to track all documents processed by the server, based on this document instance.
Type | Contains the type of document specification.
Version | Contains the version of the document standard.

IBizTalkDocument defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
LoadByPropertySet | Loads the document object by its PropertySet object.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Remarks

Each IBizTalkDocument object must have at least one associated IBizTalkChannel object. More than one IBizTalkDocument object can refer to the same document specification.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions


Content Property

Contains the content of the document specification described by the object.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Content As String

[C++]

HRESULT get_Content(

BSTR* Content

);

Parameters

Content

[out, retval] In C++, contains the content. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the content.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with a default value of an empty string ("").

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


LoadByPropertySet Method

Loads the document object by its PropertySet object.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Method Declaration

[Visual Basic]

Property LoadByPropertySet( _

PropSetDictionaryDisp As Object _

)

[C++]

HRESULT LoadByPropertySet(

IDispatch** PropSetDictionaryDisp

);

Parameters

PropSetDictionaryDisp

[in] In C++, contains the PropertySet. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the PropertySet.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


NameSpace Property

Contains the string that resolves naming conflicts between elements in a document.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property NameSpace As String

[C++]

HRESULT get_NameSpace(

BSTR* NameSpace

);

Parameters

NameSpace

[out, retval] In C++, contains the namespace. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the namespace.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with a default value of an empty string ("").

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and NameSpace is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating a document, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


PropertySet Property

Contains an IDictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property PropertySet As Object

[C++]

HRESULT get_PropertySet(

IDispatch** PropSetDisp

);

HRESULT putref_PropertySet(

IDispatch* PropSetDisp

);

Parameters

PropSetDisp

[out, retval], [in] In C++, contains the selection criteria. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the selection criteria.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

This is a required property if the document is an EDI document. The Delimiters property of the associated IBizTalkPort object must also be defined.

The following table shows whether names are required in the IDictionary object for PropertySet.

Selection criteria | X12 | EDIFACT
application_sender_code | Yes | Yes
application_receiver_code | Yes | Yes
functional_identifier | Yes | Yes
standards_version | Yes | No
standards_version_type | No | Yes
standards_version_value | No | Yes

Note

  • The name/value pairs contained in the IDictionary object cannot exceed a total of 450 bytes.

PropertySet can be set only if the Reference property is set.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions


Reference Property

Contains the full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by this IBizTalkDocument object.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Reference As String

[C++]

HRESULT get_Reference(

BSTR* Reference

);

HRESULT put_Reference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the reference. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the reference.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

If Reference is not set, the PropertySet and TrackFields properties must not be set.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


TrackFields Property

Contains an IDictionary object that stores the custom fields that Tracking uses to track all documents processed by the server, based on this document instance.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property TrackFields As Object

[C++]

HRESULT get_TrackFields(

IDispatch** TrackFieldsDisp

);

HRESULT putref_TrackFields(

IDispatch* TrackFieldsDisp

);

Parameters

TrackFieldsDisp

[out, retval], [in] In C++, contains the custom tracking fields. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the custom tracking fields.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

TrackFields can be set only if the Reference property is set. Tracking fields specified for an output IBizTalkDocument object are ignored.

An IBizTalkDocument object points to the specification that contains fields to track the document. The designated fields are logged to the Tracking database for each instance of a document that is processed. Tracking fields on the IBizTalkDocument object are global. The TrackFields property on the IBizTalkChannel object overrides the values specified by this property.

The fields in the IDictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the IDictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the IDictionary object and set the value to a SimpleList object. The SimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the IDictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions

Document Tracking


Type Property

Contains the version of the document standard.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Type As String

[C++]

HRESULT get_Type(

BSTR* Type

);

Parameters

Type

[out, retval] In C++, contains the document type. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the document type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with a default value of an empty string ("").

All document instances must have the same document type as the associated envelope. For example, if the Format property of the IBizTalkEnvelope object is set to X12, Type must also be X12.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Version Property

Contains the version of the document standard.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Version As String

[C++]

HRESULT get_Version(

BSTR* Version

);

Parameters

Version

[out, retval] In C++, contains the version. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the version.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint

Configures source information for an IBizTalkChannel object and destination information for an IBizTalkPort object.

Hierarchy

IDispatch

|--IBizTalkEndPoint

Declaration

[Visual Basic]

Class BizTalkEndpoint

[C++]

interface IBizTalkEndpoint : IDispatch

Members

IBizTalkEndPoint defines the following properties:

Property | Description
Alias | Contains a handle to the organization identifier type/value pair for the destination IBizTalkOrganization object for the associated IBizTalkPort object.
Application | Contains a handle to the associated application for the destination IBizTalkOrganization object for this IBizTalkPort object.
Openness | Contains an enumeration value that indicates whether the object has an open destination or source, or neither.
Organization | Contains a handle to the destination IBizTalkOrganization object for this IBizTalkPort object.

Remarks

The IBizTalkEndPoint object is automatically created when an IBizTalkPort object or an IBizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the IBizTalkConfig object.

For destination endpoints, access the IBizTalkEndPoint object by using the DestinationEndpoint property of the IBizTalkPort object. For source endpoints, access the IBizTalkEndPoint object by using the SourceEndpoint property of the IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Alias Property

Contains a handle to the organization identifier type/value pair for the destination IBizTalkOrganization object for the associated IBizTalkPort object.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Alias As Long

[C++]

HRESULT get_Alias(

long* AliasHandle

);

HRESULT put_Alias(

long AliasHandle

);

Parameters

AliasHandle

[out, retval], [in] In C++, contains the handle to the alias. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the alias.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Application Property

Contains a handle to the associated application for the destination IBizTalkOrganization object for this IBizTalkPort object.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Application As Long

[C++]

HRESULT get_Application(

long* AppHandle

);

HRESULT put_Application(

long AppHandle

);

Parameters

AppHandle

[out, retval], [in] In C++, contains the handle to the application. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the application.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Openness Property

Contains an enumeration value that indicates whether the object has an open destination or source, or neither.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Openness As BIZTALK_OPENNESS_TYPE_EX

[C++]

HRESULT get_Openness(

BIZTALK_OPENNESS_TYPE_EX* OpennessType

);

HRESULT put_Openness(

BIZTALK_OPENNESS_TYPE_EX OpennessType

);

Parameters

OpennessType

[out, retval], [in] In C++, contains a value indicating whether the object has an open destination or source, or neither. Valid values for this parameter are defined by the BIZTALK_OPENNESS_TYPE_EX enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_OPENNESS_TYPE_EX enumeration, indicating whether the object has an open destination or source, or neither.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_OPENNESS_TYPE_EX_NOTOPEN.

The IBizTalkPort object is valid only if the associated document or the parameters on the Submit or the SubmitSync method of IInterchange identify the missing information.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_SOURCE for an IBizTalkEndPoint object associated with a channel, the following constraints apply:

  • The SignatureType property must not be set.

  • The IBizTalkPort object cannot be included in a port group.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW on a channel, the associated IBizTalkOrganization object must be the default organization.

If Openness on the object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION for an IBizTalkEndPoint object associated with a messaging port, the following constraints apply:

  • The PrimaryTransportType property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • The EncryptionType property must not be set.

  • The document or the parameters on Submit or SubmitSync must specify the destination, transport type, and address.

  • The IBizTalkPort object cannot be included in a port group.

Note

  • This property cannot be changed on an existing port.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Openness


Organization Property

Contains a handle to the destination IBizTalkOrganization object for this IBizTalkPort object.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Organization As Long

[C++]

HRESULT get_Organization(

long* OrganizationHandle

);

HRESULT put_Organization(

long OrganizationHandle

);

Parameters

OrganizationHandle

[out, retval], [in] In C++, contains the handle to the organization. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the organization.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for this object to be complete unless the Openness property is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope

Configures the envelope format used with documents processed by BizTalk Server. An envelope is the header information for an interchange.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkEnvelope

Declaration

[Visual Basic]

Class BizTalkEnvelope

[C++]

interface IBizTalkEnvelope : IBizTalkBase

Members

IBizTalkEnvelope defines the following properties:

Property | Description
Content | Contains the contents of the selected envelope format specification.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Format | Contains a string that identifies the type of envelope.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
NameSpace | Contains a string that resolves naming conflicts between elements in an envelope specification.
Reference | Contains a full Web Distributed Authoring and Versioning (WebDAV) URL name of the envelope format specification file.
Version | Contains the version of the envelope format specification.

IBizTalkEnvelope defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Remarks

All document instances in an electronic data interchange (EDI) functional group must have the same format. All document instances must have the same document type as the associated envelope. For example, if Format is set to X12, the Type property of the IBizTalkDocument objects for the associated IBizTalkPort object must also be X12.

If you use an envelope with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier. To do this, use the CreateAlias method on the IBizTalkOrganization object. When an empty qualifier is encountered on an input EDIFACT envelope, the server converts the empty qualifier to a dash. For an output EDIFACT envelope, the server converts the dash to an empty qualifier.

The IBizTalkEnvelope object is required for input documents if the Type property of the IBizTalkDocument object is set to "flatfile" or "custom xml".

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Envelopes


Content Property

Contains the contents of the selected envelope format specification.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Content As String

[C++]

HRESULT get_Content(

BSTR* Content

);

Parameters

Content

[out, retval] In C++, contains the content. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the content.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Format Property

Contains a string that identifies the type of envelope.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Format As String

[C++]

HRESULT get_Format(

BSTR* Format

);

HRESULT put_Format(

BSTR Format

);

Parameters

Format

[out, retval], [in] In C++, contains the envelope format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the envelope format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The format value must be one of the following strings:

  • x12

  • edifact

  • custom xml (default)

  • custom

  • flatfile

  • reliable

Note

  • Any string other than the ones listed here will cause an error at run time.

If this property is set to "custom", the Reference property is required. Also, a custom parser component has to be registered with the server for input documents with this property set to "custom". For more information about custom parser components, see Parsers.

All document instances must have the same document type as the associated envelope. For example, if Format is set to "x12", the Type property of the IBizTalkDocument objects must also be "x12".

If Format is set to X12, edifact, or reliable, the Reference property should not be set.

For more information about envelope formats, see Create envelopes.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Envelopes


NameSpace Property

Contains a string that resolves naming conflicts between elements in an envelope specification.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property NameSpace As String

[C++]

HRESULT get_NameSpace(

BSTR* NameSpace

);

Parameters

NameSpace

[out, retval] In C++, contains the namespace. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the namespace.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value. The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and NameSpace is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating an envelope, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Reference Property

Contains a full Web Distributed Authoring and Versioning (WebDAV) URL name of the envelope format specification file.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Reference As String

[C++]

HRESULT get_Reference(

BSTR* Reference

);

HRESULT put_Reference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the reference. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the reference.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property if the Format property is set to "custom". Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Version Property

Contains the version of the envelope format specification.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Version As String

[C++]

HRESULT get_Version(

BSTR* Version

);

Parameters

Version

[out, retval] In C++, contains the version. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the version.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkLoggingInfo

Configures the document-logging information for an associated IBizTalkChannel object.

Hierarchy

IDispatch

|--IBizTalkLoggingInfo

Declaration

[Visual Basic]

Class BizTalkLoggingInfo

[C++]

interface IBizTalkLoggingInfo : IDispatch

Members

IBizTalkLoggingInfo defines the following properties:

Property | Description
LogNativeInputDocument | Contains a value that indicates whether the input document instance is saved and logged in its native format.
LogNativeOutputDocument | Contains a value that indicates whether the output document instance is saved and logged in its native format.
LogXMLInputDocument | Contains a value that indicates whether the XML input document is saved and logged.
LogXMLOutputDocument | Contains a value that indicates whether the XML output document is saved and logged.

Remarks

The IBizTalkLoggingInfo object is automatically created when an IBizTalkChannel object is instantiated with the CreateChannel method of the IBizTalkConfig object. You can access the IBizTalkLoggingInfo object by using the LoggingInfo property of the IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogNativeInputDocument Property

Contains a value that indicates whether the input document instance is saved and logged in its native format.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogNativeInputDocument As Boolean

[C++]

HRESULT get_LogNativeInputDocument(

VARIANT_BOOL* LogNativeInDoc

);

HRESULT put_LogNativeInputDocument(

VARIANT_BOOL LogNativeInDoc

);

Parameters

LogNativeInDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the input documents will be saved and logged in their native format. VARIANT_TRUE indicates that the input documents will be saved and logged in their native formats; VARIANT_FALSE indicates that the input documents will not be saved and logged in their native formats. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the input documents will be saved and logged in their native format. True indicates that the input documents will be saved and logged in their native formats; False indicates that the input documents will not be saved and logged in their native formats.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogNativeOutputDocument Property

Contains a value that indicates whether the output document instance is saved and logged in its native format.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogNativeOutputDocument As Boolean

[C++]

HRESULT get_LogNativeOutputDocument(

VARIANT_BOOL* LogNativeOutDoc

);

HRESULT put_LogNativeOutputDocument(

VARIANT_BOOL LogNativeOutDoc

);

Parameters

LogNativeOutDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the output documents will be saved and logged in their native format. VARIANT_TRUE indicates that the output documents will be saved and logged in their native formats; VARIANT_FALSE indicates that the output documents will not be saved and logged in their native formats. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the output documents will be saved and logged in their native format. True indicates that the output documents will be saved and logged in their native formats; False indicates that the output documents will not be saved and logged in their native formats.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogXMLInputDocument Property

Contains a value that indicates whether the XML input document is saved and logged.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogXMLInputDocument As Boolean

[C++]

HRESULT get_LogXMLInputDocument(

VARIANT_BOOL* LogXMLInDoc

);

HRESULT put_LogXMLInputDocument(

VARIANT_BOOL LogXMLInDoc

);

Parameters

LogXMLInDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the input documents will be saved and logged in XML format. VARIANT_TRUE indicates that the input documents will be saved and logged in XML format; VARIANT_FALSE indicates that the input documents will not be saved and logged in XML format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the input documents will be saved and logged in XML format. VARIANT_TRUE indicates that the input documents will be saved and logged in XML format; VARIANT_FALSE indicates that the input documents will not be saved and logged in XML format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogXMLOutputDocument Property

Contains a value that indicates whether the XML output document is saved and logged.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogXMLOutputDocument As Boolean

[C++]

HRESULT get_LogXMLOutputDocument(

VARIANT_BOOL* LogXMLOutDoc

);

HRESULT put_LogXMLOutputDocument(

VARIANT_BOOL LogXMLOutDoc

);

Parameters

LogXMLOutDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the output documents will be saved and logged in XML format. VARIANT_TRUE indicates that the output documents will be saved and logged in XML format; VARIANT_FALSE indicates that the output documents will not be saved and logged in XML format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the output documents will be saved and logged in XML format. VARIANT_TRUE indicates that the output documents will be saved and logged in XML format; VARIANT_FALSE indicates that the output documents will not be saved and logged in XML format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


IBizTalkOrganization

Configures an organization, its organization identifiers (aliases), and the applications within the organization that send and/or receive documents. The application indicates the ultimate source or destination of the document.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkOrganization

Declaration

[Visual Basic]

Class BizTalkOrganization

[C++]

interface IBizTalkOrganization : IBizTalkBase

Members

IBizTalkOrganization defines the following properties:

Property | Description
Aliases | Contains an ADO recordset of aliases that refer to the object.
Applications | Contains an ADO recordset of applications that refer to the object.
Comments | Contains user comments for the object.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
IsDefault | Contains a value that indicates whether the object is the default organization.
Name | Contains the name of the object.

IBizTalkOrganization defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
CreateAlias | Creates an alias for the object.
CreateApplication | Creates a new application.
GetDefaultAlias | Retrieves the default alias for the object.
Load | Loads a specified object in memory.
LoadAlias | Loads an existing alias for the object in memory.
LoadApplication | Loads an application in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
RemoveAlias | Removes an alias.
RemoveApplication | Removes an application.
Save | Saves the object in the database.
SaveAlias | Saves the alias.
SaveApplication | Saves the application.

Remarks

An IBizTalkOrganization object can have more than one application, but each application name must be unique for that object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


Aliases Property

Contains an ADO recordset of aliases that refer to the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property Aliases As Object

[C++]

HRESULT get_Aliases(

IDispatch** AliasesDisp

);

Parameters

AliasesDisp

[out, retval] Contains all aliases that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all aliases that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The alias for an object is the organization qualifier/value pair. BizTalk Messaging Manager refers to aliases as identifiers.

Each record in the ADO recordset returned by this property contains information about the aliases of an existing IBizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the alias.

  • Name specified in the CreateAlias method.

  • Boolean specified in the CreateAlias method.

  • Qualifier specified in the CreateAlias method.

  • Value specified in the CreateAlias method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


Applications Property

Contains an ADO recordset of applications that refer to the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property Applications As Object

[C++]

HRESULT get_Applications(

IDispatch** ApplicationsDisp

);

Parameters

ApplicationsDisp

[out, retval] Contains all applications that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all applications that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about the applications of an existing IBizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the application.

  • Name specified in the CreateApplication method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Comments Property

Contains user comments for the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property Comments As String

[C++]

HRESULT get_Comments(

BSTR* Comments

);

HRESULT put_Comments(

BSTR Comments

);

Parameters

Comments

[out, retval], [in] In C++, contains the comments. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the comments.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateAlias Method

Creates an alias for the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub CreateAlias( _

Name As String, _

Default As Boolean, _

Qualifier As String, _

Value As String _

)

[C++]

HRESULT CreateAlias(

BSTR Name,

VARIANT_BOOL Default,

BSTR Qualifier,

BSTR Value

);

Parameters

Name

[in] Contains the name of the alias.

Default

[in] In Visual Basic, contains a value that indicates whether or not this default alias overrides the previous default alias. True indicates that this default alias overrides the previous default alias; False indicates that this default alias should not override the previous default alias. If no alias is specified as the default, one is assigned when the Create method is called.

[in] In C++, contains a value that indicates whether or not this default alias overrides the previous default alias. VARIANT_TRUE indicates that this default alias overrides the previous default alias; VARIANT_FALSE indicates that this default alias should not override the previous default alias. If no alias is specified as the default, one is assigned when the Create method is called.

Qualifier

[in] Contains the qualifier. This parameter cannot be set to "group".

Value

[in] Contains the value.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The alias for an object is the organization identifier that contains a name and a qualifier/value pair.

More than one alias can be created for an IBizTalkOrganization object. The organization alias must contain a name that is unique for the specified IBizTalkOrganization object, and a qualifier/value pair that is unique across all IBizTalkOrganization objects. One of these aliases must be specified as the default alias for the object.

The server automatically creates an alias named Organization with a default identifier of OrganizationName and the value set to the organization's name for new organizations. If the organization name is changed, the value is automatically updated with the new name. This alias cannot be removed.

Note

  • When using envelopes with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


CreateApplication Method

Creates a new application.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub CreateApplication( _

Name As String _

)

[C++]

HRESULT CreateApplication(

BSTR Name

);

Parameters

Name

[in] Contains the name of the application.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If an IBizTalkOrganization object is associated with more than one application, each application name must be unique.

Notes

  • BizTalk Messaging Manager refers to the default organization as the home organization.

  • BizTalk Messaging Manager allows applications to be created for the home organization only. The BizTalk Messaging Configuration object model does not enforce this restriction. Therefore, if you create an application for an organization other than the default (home) organization, you cannot modify it using BizTalk Messaging Manager.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


GetDefaultAlias Method

Retrieves the default alias for the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Function GetDefaultAlias( ) As Long

[C++]

HRESULT GetDefaultAlias(

long* AliasHandle

);

Parameters

AliasHandle

[out, retval] Contains the handle. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the handle.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The default alias for an object is the default organization identifier type/value pair.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


IsDefault Property

Contains a value that indicates whether the object is the default organization.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property IsDefault( ) As Boolean

[C++]

HRESULT get_IsDefault(

VARIANT_BOOL* IsDefault

);

Parameters

IsDefault

In C++, contains a value that indicates whether or not this organization is the default organization. VARIANT_TRUE indicates that this organization is the default organization; VARIANT_FALSE indicates that this organization is not the default organization. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not this organization is the default organization. True indicates that this organization is the default organization; False indicates that this organization is not the default organization.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property. There must be one and only one default organization at any time.

Note

  • BizTalk Messaging Manager refers to the default organization as the home organization.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


LoadAlias Method

Loads an existing alias for the object in memory.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub LoadAlias( _

AliasHandle As Long, _

Name As Variant, _

Default As Variant, _

Qualifier As Variant, _

Value As Variant _

)

[C++]

HRESULT LoadAlias(

long AliasHandle,

VARIANT* Name,

VARIANT* Default,

VARIANT* Qualifier,

VARIANT* Value

);

Parameters

AliasHandle

[in] Contains the handle to the alias.

Name

[in, out] Contains the name of the organization identifier.

Default

[in, out] Contains the default flag.

Qualifier

[in, out] Contains the qualifier of the organization identifier.

Value

[in, out] Contains the value of the organization identifier.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The alias for an object is the organization qualifier/value pair.

The values used with the parameters of this method can be obtained from the Aliases property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


LoadApplication Method

Loads an application in memory.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub LoadApplication( _

ApplicationHandle As Long, _

Name As Variant _

)

[C++]

HRESULT LoadApplication(

long ApplicationHandle,

VARIANT* Name

);

Parameters

ApplicationHandle

[in] Contains the application handle.

Name

[in, out] Contains the name of the application.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The values used with the parameters of this method can be obtained from the Applications property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RemoveAlias Method

Removes an alias.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub RemoveAlias( _

AliasHandle As Long _

)

[C++]

HRESULT RemoveAlias(

long AliasHandle

);

Parameters

AliasHandle

[in] Contains the handle to the alias.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This record cannot be removed if any of the following conditions apply:

  • An IBizTalkPort or an IBizTalkChannel object refers to it.

  • It has been designated the default organization identifier.

  • This alias was autogenerated.

The alias handle can be obtained from the Aliases property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


RemoveApplication Method

Removes an application.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub RemoveApplication( _

ApplicationHandle As Long _

)

[C++]

HRESULT RemoveApplication(

long ApplicationHandle

);

Parameters

ApplicationHandle

[in] Contains the handle.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This record cannot be removed if an IBizTalkPort or an IBizTalkChannel object refers to it.

The application handle can be obtained from the Applications property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SaveAlias Method

Saves the alias.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub SaveAlias( _

AliasHandle As Long, _

Name As String, _

Default As Boolean, _

Qualifier As String, _

Value As String _

)

[C++]

HRESULT SaveAlias(

long AliasHandle,

BSTR Name,

VARIANT_BOOL Default,

BSTR Qualifier,

BSTR Value

);

Parameters

AliasHandle

[in] Contains the handle to the alias.

Name

[in] Contains the name of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

Default

[in] In Visual Basic, contains a value that indicates whether or not this is the default alias for the organization. True indicates that this is the default alias for the organization; False indicates that this is not the default alias for the organization.

[in] In C++, contains a value that indicates whether or not this is the default alias for the organization. VARIANT_TRUE indicates that this is the default alias for the organization; VARIANT_FALSE indicates that this is not the default alias for the organization.

Qualifier

[in] Contains the qualifier of the organization identifier. This parameter cannot be changed if this alias was autogenerated. This parameter cannot be set to "group".

Value

[in] Contains the value of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The alias for an object is the organization identifier type/value pair.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


SaveApplication Method

Saves the application.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub SaveApplication( _

ApplicationHandle As Long, _

Name As String _

)

[C++]

HRESULT SaveApplication(

long ApplicationHandle,

BSTR Name

);

Parameters

ApplicationHandle

[in] Contains the handle to the application.

Name

[in] Contains the name of the application.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort

Configures a one-way transfer of a document between organizations and applications. It identifies the source organization and/or application, the destination organization and/or application, the primary transport type, and, if selected, the associated envelope for transmission.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkPort

Declaration

[Visual Basic]

Class BizTalkPort

[C++]

interface IBizTalkPort : IBizTalkBase

Members

IBizTalkPort defines the following properties:

Property | Description
Channels | Contains an ADO recordset that includes information about all IBizTalkChannel objects that refer to the object.
Comments | Contains the user comments for the IBizTalkPort object.
ControlNumberValue | Contains the value of the interchange control number.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Delimiters | Contains an IDictionary object that includes all delimiters used in the document specification.
DestinationEndpoint | Contains information about the destination.
EncodingType | Contains an enumeration value that indicates the type of document encoding.
EncryptionCertificateInfo | Contains information about the certificate that encrypts the document.
EncryptionType | Contains an enumeration value that indicates the type of document encryption.
Envelope | Contains a handle to the IBizTalkEnvelope object associated with this IBizTalkPort object.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
PrimaryTransport | Contains the primary transport component information.
SecondaryTransport | Contains the secondary transport component information.
ServiceWindowInfo | Contains the service window information.
SignatureType | Contains an enumeration value that indicates the type of digital signing and verification.

IBizTalkPort defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Processing

Messaging Ports


Channels Property

Contains an ADO recordset that includes information about all IBizTalkChannel objects that refer to the object.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Channels( ) As Object

[C++]

HRESULT get_Channels(

IDispatch** ChannelsDisp

);

Parameters

ChannelsDisp

[out, retval] Contains the IBizTalkChannel objects that refer to the object.

Return Values

In Visual Basic, this property returns the IBizTalkChannel objects that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about the IBizTalkChannel objects in the database that are associated with this IBizTalkPort object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • A unique channel identifier, in GUID format.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Comments Property

Contains the user comments for the IBizTalkPort object.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Comments As String

[C++]

HRESULT get_Comments(

BSTR* Comments

);

HRESULT put_Comments(

BSTR Comments

);

Parameters

Comments

[out, retval], [in] In C++, contains the comments. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the comments.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ControlNumberValue Property

Contains the value of the interchange control number.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property ControlNumberValue As String

[C++]

HRESULT get_ControlNumberValue(

BSTR* ControlNumberValue

);

HRESULT put_ControlNumberValue(

BSTR ControlNumberValue

);

Parameters

ControlNumberValue

[out, retval], [in] In C++, contains the interchange control number. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property the interchange control number.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The ControlNumberValue property must contain a value between 1 and 999999999. This property has no default value.

This is a required property if the Format property of the associated IBizTalkEnvelope object is set to "x12", "edifact", or "custom". This constraint is not enforced for this release, but the server fails if it is not adhered to.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Delimiters Property

Contains an IDictionary object that includes all delimiters used in the document specification.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Delimiters As Object

[C++]

HRESULT get_Delimiters(

IDispatch** DelimitersDisp

);

HRESULT putref_Delimiters(

IDispatch* DelimitersDisp

);

Parameters

DelimitersDisp

[out, retval], [in] In C++, contains the delimiters. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the delimiters.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for the object to be complete if the Format property of the associated IBizTalkEnvelope object is set to "x12", "edifact", or "custom". Delimiters specifies which characters to use to separate data within the envelope and the documents that are sent using this envelope.

The PropertySet property of the associated IBizTalkDocument object must also be defined. The following table shows which names are required for the delimiters of the IDictionary object for various formats:

Delimiter | X12 | EDIFACT
Record_delim | Yes | Yes
Field_delim | Yes | Yes
Subfield_delim | Yes | Yes
Escape_char | No | Yes

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


DestinationEndpoint Property

Contains information about the destination.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property DestinationEndpoint As Object

[C++]

HRESULT get_DestinationEndpoint(

IDispatch** DestEndpointDisp

);

HRESULT putref_DestinationEndpoint(

IDispatch* DestEndpointDisp

);

Parameters

DestEndpointDisp

[out, retval], [in] In C++, contains information about the destination. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns information about the destination.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information provided by this property includes the Alias, Application, and Organization properties and is created and stored in memory in the IBizTalkEndPoint object.

Once an IBizTalkPort object has been created, the destination IBizTalkOrganization object cannot be changed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


EncodingType Property

Contains an enumeration value that indicates the type of document encoding.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property EncodingType As BIZTALK_ENCODING_TYPE

[C++]

HRESULT get_EncodingType(

BIZTALK_ENCODING_TYPE* EncodingType

);

HRESULT put_EncodingType(

BIZTALK_ENCODING_TYPE EncodingType

);

Parameters

EncodingType

[out, retval], [in] In C++, contains the encoding type. Valid values for this parameter are defined by the BIZTALK_ENCODING_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_ENCODING_TYPE enumeration, indicating the encoding type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_ENCODING_TYPE_NONE. The Clear method sets EncodingType to BIZTALK_ENCODING_TYPE_NONE.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


EncryptionCertificateInfo Property

Contains information about the certificate that encrypts the document.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property EncryptionCertificateInfo As Object

[C++]

HRESULT get_EncryptionCertificateInfo(

IDispatch** EncryptionCertificateInfoDisp

);

HRESULT putref_EncryptionCertificateInfo(

IDispatch* EncryptionCertificateInfoDisp

);

Parameters

EncryptionCertificateInfoDisp

[out, retval], [in] In C++, contains the certificate information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information provided by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the IBizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


EncryptionType Property

Contains an enumeration value that indicates the type of document encryption.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property EncryptionType As BIZTALK_ENCRYPTION_TYPE

[C++]

HRESULT get_EncryptionType(

BIZTALK_ENCRYPTION_TYPE* EncryptionType

);

HRESULT put_EncryptionType(

BIZTALK_ENCRYPTION_TYPE EncryptionType

);

Parameters

EncryptionType

[out, retval], [in] In C++, contains the encryption type. Valid values for this parameter are defined by the BIZTALK_ENCRYPTION_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_ENCRYPTION_TYPE enumeration, indicating the encoding type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_ENCRYPTION_TYPE_NONE. The Clear method sets EncryptionType to BIZTALK_ENCRYPTION_TYPE_NONE.

If the EncryptionType is set to BIZTALK_ENCRYPTION_TYPE_SMIME, then the EncryptionCertificateInfo property must be set.

For open messaging ports, EncryptionType must be set to BIZTALK_ENCRYPTION_TYPE_NONE.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Envelope Property

Contains a handle to the IBizTalkEnvelope object associated with this IBizTalkPort object.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Envelope As Long

[C++]

HRESULT get_Envelope(

long* EnvelopeHandle

);

HRESULT put_Envelope(

long EnvelopeHandle

);

Parameters

EnvelopeHandle

[out, retval], [in] In C++, contains the handle to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Envelopes


PrimaryTransport Property

Contains the primary transport component information.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property PrimaryTransport As Object

[C++]

HRESULT get_PrimaryTransport(

IDispatch** TransportInfoDisp

);

HRESULT putref_PrimaryTransport(

IDispatch* TransportInfoDisp

);

Parameters

TransportInfoDisp

[out, retval], [in] In C++, contains the primary transport component information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the primary transport component information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for the object.

Information provided by this property includes the Address, Parameter, and Type properties of the IBizTalkTransportInfo object.

The following constraints are enforced:

  • If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and PrimaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION. The IBizTalkServiceWindowInfo object cannot be used with open destination ports.

  • Once an IBizTalkPort object has been created, the Openness property of the associated IBizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • When using a Type of BIZTALK_TRANSPORT_TYPE_LOOPBACK, the primary and secondary transport Address property cannot be set, and the IBizTalkServiceWindowInfo object cannot be used.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SecondaryTransport Property

Contains the secondary transport component information.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property SecondaryTransport As Object

[C++]

HRESULT get_SecondaryTransport(

IDispatch** TransportInfoDisp

);

HRESULT putref_SecondaryTransport(

IDispatch* TransportInfoDisp

);

Parameters

TransportInfoDisp

[out, retval], [in] In C++, contains the secondary transport component information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the secondary transport component information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for the object to be complete.

Information provided by this property includes the Address, Parameter, and Type properties, and is created and stored in memory in the IBizTalkTransportInfo object.

The following constraints are enforced:

  • If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and SecondaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • Once an IBizTalkPort object has been created, the Openness property of the associated IBizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • The Type property cannot be set to BIZTALK_TRANSPORT_TYPE_LOOPBACK.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ServiceWindowInfo Property

Contains the service window information.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property ServiceWindowInfo As Object

[C++]

HRESULT get_ServiceWindowInfo(

IDispatch** ServiceWindowInfoDisp

);

HRESULT putref_ServiceWindowInfo(

IDispatch* ServiceWindowInfoDisp

);

Parameters

ServiceWindowInfoDisp

[out, retval], [in] In C++, contains the service window. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the service window.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information provided by this property includes the FromTime, IsEnabled, and ToTime properties and is created and stored in memory in the IBizTalkServiceWindowInfo object.

If this property is used, the IBizTalkServiceWindowInfo object must specify a valid time range by using the FromTime and ToTime properties.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SignatureType Property

Contains an enumeration value that indicates the type of digital signing and verification.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property SignatureType As BIZTALK_SIGNATURE_TYPE

[C++]

HRESULT get_SignatureType(

BIZTALK_SIGNATURE_TYPE* SignatureType

);

HRESULT put_SignatureType(

BIZTALK_SIGNATURE_TYPE SignatureType

);

Parameters

SignatureType

[out, retval], [in] In C++, contains the signature type. Valid values for this parameter are defined by the BIZTALK_SIGNATURE_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_SIGNATURE_TYPE enumeration, indicating the encoding type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_SIGNATURE_TYPE_NONE. The Clear method sets SignatureType to BIZTALK_SIGNATURE_TYPE_NONE.

IBizTalkPort objects associated with open channels cannot have a SignatureType.

If the SignatureType on an IBizTalkPort object is changed from BIZTALK_SIGNATURE_TYPE_NONE to BIZTALK_SIGNATURE_TYPE_SMIME, all channels associated with this IBizTalkPort object must have already been saved with SignatureCertificateInfo. Also, if a IBizTalkChannel contains a SignatureCertificateInfo object and the SignatureType of the IBizTalkPort is set to BIZTALK_SIGNATURE_TYPE_NONE, the signature will be ignored.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup

Configures port groups that are used to distribute the same document to many organizations.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkPortGroup

Declaration

[Visual Basic]

Class BizTalkPortGroup

[C++]

interface IBizTalkPortGroup : IBizTalkBase

Members

IBizTalkPortGroup defines the following properties:

Property | Description
Channels | Contains an ADO recordset that contains information about all IBizTalkChannel objects that refer to this object.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
Ports | Contains an ADO recordset that contains information about all IBizTalkPort objects that refer to this object.

IBizTalkPortGroup defines the following methods:

Method | Description
AddPort | Adds an IBizTalkPort object to this port group. There must be at least one IBizTalkPort object in the port group.
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
RemovePort | Removes an IBizTalkPort object from the port group. There must be at least one IBizTalkPort object in the port group.
Save | Saves the object in the database.

Remarks

There must always be at least one IBizTalkPort object and one IBizTalkChannel object associated with a IBizTalkPortGroupobject. The IBizTalkChannel object is associated with the IBizTalkPortGroup object, not the IBizTalkPort object within the group. Each IBizTalkPort object within the group has another IBizTalkChannel object or objects associated with it, but these are ignored when the port group channel is invoked.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Distribution List

Port Groups

Submitting Documents to a Port Group


AddPort Method

Adds an IBizTalkPort object to this port group. There must be at least one IBizTalkPort object in the port group.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Method Declaration

[Visual Basic]

Sub AddPort( _

PortHandle As Long _

)

[C++]

HRESULT AddPort(

long PortHandle

);

Parameters

PortHandle

[in] Contains the handle to the object.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The following constraints apply to this method:

  • There must be at least one IBizTalkPort in this IBizTalkPortGroup object.

  • The Openness property of the associated BizTalkEndPoint object to be added must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN.

  • The port group specified by this object cannot contain any duplicate IBizTalkPort objects.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Channels Property

Contains an ADO recordset that contains information about all IBizTalkChannel objects that refer to this object.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Property Declaration

[Visual Basic]

Property Channels As Object

[C++]

HRESULT get_Channels(

IDispatch** ChannelsDisp

);

Parameters

ChannelsDisp

[out, retval] Contains an ADO recordset that contains all IBizTalkChannel objects that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns an ADO recordset that contains all IBizTalkChannel objects that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Each record in the ADO recordset returned by this property contains information about the IBizTalkChannel objects in the database that are associated with this IBizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Ports Property

Contains an ADO recordset that contains information about all IBizTalkPort objects that refer to this object.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Property Declaration

[Visual Basic]

Property Ports As Object

[C++]

HRESULT Ports(

IDispatch** PortsDisp

);

Parameters

PortsDisp

[out, retval] Contains an ADO recordset that includes all IBizTalkPort objects that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values.

Return Values

In Visual Basic, this property returns an ADO recordset that includes all IBizTalkPort objects that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Each record in the ADO recordset returned by this property contains information about the IBizTalkPort objects in the database that are associated with this IBizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RemovePort Method

Removes an IBizTalkPort object from the port group. There must be at least one IBizTalkPort object in the port group.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Method Declaration

[Visual Basic]

Sub RemovePort( _

PortHandle As Long _

)

[C++]

HRESULT RemovePort(

long PortHandle

);

Parameters

PortHandle

[in] Contains the handle to the object to remove.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The last IBizTalkPort object associated with the object cannot be removed. An IBizTalkPort object cannot be removed if an IBizTalkChannel object refers to it.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo

Configures the service window for an associated IBizTalkPort object. The service window indicates a valid time range for transmitting documents.

Hierarchy

IDispatch

|--IBizTalkServiceWindowInfo

Declaration

[Visual Basic]

Class BizTalkServiceWindowInfo

[C++]

interface IBizTalkServiceWindowInfo : IDispatch

Members

IBizTalkServiceWindowInfo defines the following properties:

Property | Description
FromTime | Contains the earliest time that the interchange can be transmitted.
IsEnabled | Contains a value that indicates whether the service window is enabled.
ToTime | Contains the latest time that the interchange can be transmitted.

Remarks

The IBizTalkServiceWindowInfo object is automatically created when an IBizTalkPort object is instantiated with the CreatePort method of the IBizTalkConfig object. Access the properties of the IBizTalkServiceWindowInfo object by using the ServiceWindowInfo property of the IBizTalkPort object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


FromTime Property

Contains the earliest time that the interchange can be transmitted.

Member List

IBizTalkServiceWindowInfo

|--FromTime

|--IsEnabled

|--ToTime

Property Declaration

[Visual Basic]

Property FromTime As String

[C++]

HRESULT get_FromTime(

BSTR* FromTime

);

HRESULT put_Comments(

BSTR FromTime

);

Parameters

FromTime

[out, retval], [in] In C++, contains the earliest time that the interchange can be transmitted. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the earliest time that the interchange can be transmitted.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The FromTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified. Service window hours are displayed in the coordinated universal time (UTC) format and reflect the time on the database server.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IsEnabled Property

Contains a value that indicates whether the service window is enabled.

Member List

IBizTalkServiceWindowInfo

|--FromTime

|--IsEnabled

|--ToTime

Property Declaration

[Visual Basic]

Property IsEnabled As Boolean

[C++]

HRESULT get_IsEnabled(

VARIANT_BOOL* IsEnabled

);

HRESULT put_IsEnabled(

_BOOL IsEnabled

);

Parameters

IsEnabled

[out, retval], [in] In C++, contains a value that indicates whether or not a service window is enabled. VARIANT_TRUE indicates that the service window is enabled; VARIANT_FALSE indicates that the service window is not enabled. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not a service window is enabled. True indicates that the service window is enabled; False indicates that the service window is not enabled.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ToTime Property

Contains the latest time that the interchange can be transmitted.

Member List

IBizTalkServiceWindowInfo

|--FromTime

|--IsEnabled

|--ToTime

Property Declaration

[Visual Basic]

Property ToTime As String

[C++]

HRESULT get_ToTime(

BSTR* ToTime

);

HRESULT put_ToTime(

BSTR ToTime

);

Parameters

ToTime

[out, retval], [in] In C++, contains the latest time that the interchange can be transmitted. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the latest time that the interchange can be transmitted.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The ToTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified. Service window hours are displayed in the coordinated universal time (UTC) format and reflect the time on the database server.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo

Configures the transport service for an associated IBizTalkPort object.

Hierarchy

IDispatch

|--IBizTalkTransportInfo

Declaration

[Visual Basic]

Class BizTalkTransportInfo

[C++]

interface IBizTalkTransportInfo : IDispatch

Members

IBizTalkTransportInfo defines the following properties:

Property | Description
Address | Contains the destination address of the primary transport component.
Parameter | Contains the required return e-mail address for the associated source IBizTalkOrganization object if the Type property is BIZTALK_TRANSPORT_ TYPE_SMTP.
Type | Contains an enumeration value that indicates the type of transport component to be used for the primary transport.

Remarks

The IBizTalkTransportInfo object is automatically created when an IBizTalkPort object is instantiated with the CreatePort method of the IBizTalkConfig object.

Access the IBizTalkTransportInfo object by using the PrimaryTransport or SecondaryTransport property of the IBizTalkPort object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Address Property

Contains the destination address of the primary transport component.

Member List

IBizTalkTransportInfo

|--Address

|--Parameter

|--Type

Property Declaration

[Visual Basic]

Property Address As String

[C++]

HRESULT get_Address(

BSTR* TransportAddress

);

HRESULT put_Address(

BSTR TransportAddress

);

Parameters

TransportAddress

[out, retval], [in] In C++, contains the address. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the address.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, Address cannot be set, and the Type property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

Address must have one of the following prefixes, according to the Type property:

Transport type | Prefix | Example Address value
APPINTEGRATION | Not applicable | {11111111-1111-1111-1111-111111111111}
FILE | file:// | file://C:\Test\MyFile.xml
HTTP | http:// | http://www.adatum.com/repository/bts.asp
HTTPS | https:// | https://www.adatum.com/secure/btss.asp
LOOPBACK | Not applicable | Not applicable
MSMQ | Not applicable | DIRECT=OS:.\private$\myqueue
NONE | Not applicable | Not applicable
OPENDESTINATION | Not applicable | Not applicable
ORCHESTRATIONACTIVATION | Not applicable | C:\XLANG\Schedules\mysched.skx
SMTP | mailto: | mailto:patricia@adatum.com

Notes

  • The queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. For open messaging ports, the address is specified either in the document instance or as a parameter when submitting the document. For more information, see Routing.

  • When using the Orchestration Activation Component transport type, the Address property must contain the full path of the XLANG schedule on the local computer. The file:// prefix cannot be used when specifying the path of the XLANG schedule (.skx) file.

  • When using the HTTP or HTTPS transport types, BizTalk Server sends the data using a proxy server by default. This is the correct setting to transport data to computers outside of your company's firewall. However, when sending data within your company's intranet, you can bypass the use of a proxy server. To do this, you must set the UseProxy field to False in the transport dictionary. For more information, see SetConfigData.

When using the file:// transport type, you can include symbols to modify the file name. The file name created by the server contains any static characters you specified in the Address property, along with the actual value of the symbol. For example, if the Address property is set to "file://C:\Orders\Invoice_%tracking_id%.xml", the actual file name would use a format similar to: C:\Orders\Invoice_{12345678-90AB-CDEF-1234-567890ABCDEF}. The following table contains the symbols that can be used with the file:// transport type:

Symbol | Description | Unique file name
%datetime% | Date and time, in milliseconds, of the file creation. The time is based on Greenwich Mean Time (GMT) rather than local time. | No
%src_filename% | Name of the source document processed by BizTalk Server. | No
%src_filepath% | This value is not supported. | Not applicable
%document_name% | Name of the document definition used to process the source file. | No
%server% | Host name of the server that processed the document. | No
%tracking_id% | Globally unique tracking number. | Yes
%uid% | Counter that increases over time, represented in milliseconds. This number is reset when the server is rebooted. | No

When sending reliable messaging receipts that use the SMTP transport protocol, the value specified in the identifier named Reliable Messaging Acknowledgement SMTP From Address is used as the From address. This identifier is automatically created for the default IBizTalkOrganization object. This identifier cannot be removed. You should not modify the name or qualifier for this identifier, but you can modify the value. For more information, see Processing Receipts Using Reliable Messaging.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Parameter Property

Contains the required return e-mail address of the associated source IBizTalkOrganization object if the Type property is set to BIZTALK_TRANSPORT_TYPE_SMTP.

Member List

IBizTalkTransportInfo

|--Address

|--Parameter

|--Type

Property Declaration

[Visual Basic]

Property Parameter As String

[C++]

HRESULT get_Parameter(

BSTR* PrimaryTransportParameter

);

HRESULT put_Parameter(

BSTR PrimaryTransportParameter

);

Parameters

PrimaryTransportParameter

[out, retval], [in] In C++, contains the required return e-mail address. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the required return e-mail address.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

  • This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Type Property

Contains an enumeration value that indicates the type of transport component to be used for the primary transport.

Member List

IBizTalkTransportInfo

|--Address

|--Parameter

|--Type

Property Declaration

[Visual Basic]

Property Type As BIZTALK_TRANSPORT_TYPE

[C++]

HRESULT get_Type(

BIZTALK_TRANSPORT_TYPE* TransportType

);

HRESULT put_Type(

BIZTALK_TRANSPORT_TYPE TransportType

);

Parameters

TransportType

[out, retval], [in] In C++, contains the transport type. Valid values for this parameter are defined by the BIZTALK_TRANSPORT_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_TRANSPORT_TYPE enumeration, indicating the transport type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The following constraints are enforced:

  • If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the Address property cannot be set, and Type must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

When using the Message Queuing transport type (BIZTALK_TRANSPORT_TYPE_MSMQ), the following restrictions apply:

  • When using an envelope, the maximum size of a document submitted to BizTalk Server is 4MB.

  • When an envelope is not used, the maximum size of a document submitted to BizTalk Server is 2MB.

  • When using the BIZTALK_TRANSPORT_TYPE_SMTP, the Parameter property must be set to the reply-to SMTP address.

  • The transport Type of BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION is supported only when the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_TOWORKFLOW.

  • When using the Orchestration activation component type (BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION), the maximum size of a document sent to the port on the XLANG schedule is 2MB.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IDictionary

Supports the creation, storage, and retrieval of name/value pairs in memory. This collection object is used by several methods in the BizTalk Messaging Configuration object model.

Hierarchy

IDispatch

|--IDictionary

Declaration

[Visual Basic]

Class CDictionary

[C++]

interface IDictionary : IDispatch

Members

IDictionary defines the following properties:

Property | Description
Count | Contains the number of entries in the IDictionary object.
Prefix | Contains the prefix that is used to exclude all entries with that prefix when the contents of the IDictionary object are saved.
Value | Contains the value associated with an entry name.

IDictionary defines the following methods:

Method | Description
GetMultiple | Returns the values of multiple entries from the IDictionary object.
PutMultiple | Adds specified entries to the IDictionary object or changes them.

Remarks

An IDictionary object is designed to be a general-purpose collection. Therefore, it can be used for anything that is supported by its internal structure. Every value in an IDictionary object is a Variant. This means that an IDictionary object can be created that consists of almost any kind of value (including other IDictionary objects).

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Count Property

Contains the number of entries in the IDictionary object.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] In C++, contains the count. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the count.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property is read-only with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


GetMultiple Method

Returns the values of multiple entries from the IDictionary object.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Method Declaration

[Visual Basic]

Sub GetMultiple( _

NumberOfEntries As Long, _

Entries As String, _

Values As Variant _

)

[C++]

HRESULT GetMultiple(

long NumberOfEntries,

const LPOLESTR Entries[],

VARIANT Values[]

);

Parameters

NumberOfEntries

[in] Specifies the number of values to retrieve.

Entries

[in, size_is(cb)] Array of string values that identifies the Dictionary object entries for which the values should be retrieved.

Values

[out, size_is(cb)] Array of VARIANTs. When GetMultiple returns, this array contains the values associated with the Dictionary object entries identified by the Entries[] array.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Prefix Property

Contains the prefix that is used to exclude all entries with that prefix when the contents of the IDictionary object are saved.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Property Declaration

[Visual Basic]

Property Prefix As String

[C++]

HRESULT get_Prefix(

BSTR* Prefix

);

HRESULT put_Prefix(

BSTR Prefix

);

Parameters

Prefix

[out, retval], [in] In C++, contains the prefix. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the prefix.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Any name/value pair with a name beginning with the specified prefix is not saved to the database. The prefix default is an underscore (_). Therefore, any keywords that begin with an underscore are not saved unless the prefix is changed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


PutMultiple Method

Adds specified entries to the IDictionary object or changes them.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Method Declaration

[Visual Basic]

Sub PutMultiple( _

NumberOfEntries As Long, _

Entries As String, _

Values As Variant _

)

[C++]

HRESULT PutMultiple(

long NumberOfEntries,

const LPOLESTR Entries[],

const VARIANT Values[]

);

Parameters

NumberOfEntries

[in] Identifies the number of elements in the rgolestr and rgvar arrays.

Entries

[in, size_is(cb)] Array of strings that contains the names to add to the IDictionary object.

Values

[in, size_is(cb)] Array of VARIANTs that contains the values to add to the IDictionary object.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

A one-to-one mapping exists between the elements of the Entries[] and Values[] arrays. This means that Entries[n] is added to the IDictionary object and is initialized to Values[n]. If the element specified by Entries[n] is already in the IDictionary object, the value associated with the element is overwritten with the value stored in Values[n].

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Value Property

Contains the value associated with an entry name.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Property Declaration

[Visual Basic]

Property Value( _

Name As String _

)

[C++]

HRESULT get_Value(

BSTR Name,

VARIANT* Value

);

HRESULT put_Value(

BSTR Name,

VARIANT Value

);

Parameters

Name

[in] Contains the name.

Value

[out, retval] [in] In C++, contains the value. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property optionally returns the value.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The value of an IDictionary object can be read or written to without explicitly using the Value property by treating the named entry as a property of the IDictionary object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList

Creates an array of variants that supports enumeration.

Hierarchy

IDispatch

|--ISimpleList

Declaration

[Visual Basic]

Class CSimpleList

[C++]

interface ISimpleList : IDispatch

Members

ISimpleList defines the following properties:

Property | Description
Count | Contains the number of elements in the ISimpleList object.
Item | Contains a container for an element of the ISimpleList object.

ISimpleList defines the following methods:

Method | Description
Add | Adds the specified item to the ISimpleList object.
Delete | Deletes the specified item from the ISimpleList object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Add Method

Adds the specified item to the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Method Declaration

[Visual Basic]

Sub Add( _

Var As Variant _

)

[C++]

HRESULT Add(

VARIANT* Var

);

Parameters

Var

[in] Contains the object to add to the ISimpleList object.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Count Property

Contains the number of elements in the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] Contains the number of items in the ISimpleList object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of items in the ISimpleList object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property is read-only with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Delete Method

Deletes the specified item from the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Method Declaration

[Visual Basic]

Sub Delete( _

Index As Long _

)

[C++]

HRESULT Delete(

long Index

);

Parameters

Index

[in] Contains the index value of the item to delete.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Item Property

Contains a container for an element of the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Property Declaration

[Visual Basic]

Property Item( _

Index (ISimpleList, Item) As Long _

) As Variant

[C++]

HRESULT get_Item(

long Index (ISimpleList, Item),

VARIANT* Item (ISimpleList, Item)

);

HRESULT put_Item(

long Index,

VARIANT Item

);

HRESULT putref_Item(

long Index,

VARIANT Item

);

Parameters

Index

[in], [in] In C++, contains the index of the item.

Item

[out, retval], [in] In C++, contains the object used to return the item. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the object used to return the item.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The Item property is a read/write Variant that contains an element of the ISimpleList object. An initialized Variant is stored at a specified array index. If an item is already stored at the specified index, that item is overwritten by the put method.

In C++, When putting a value, use the putref_Item method if you are setting an object reference; use the put_Item method if you are setting a scalar value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Enumerations

The following enumerations provide possible property and parameter values:

  • BIZTALK_CONFIGDATA_TYPE

  • BIZTALK_ENCODING_TYPE

  • BIZTALK_ENCRYPTION_TYPE

  • BIZTALK_OPENNESS_TYPE

  • BIZTALK_OPENNESS_TYPE_EX

  • BIZTALK_SIGNATURE_TYPE

  • BIZTALK_STORE_TYPE

  • BIZTALK_TRANSPORT_TYPE

  • BIZTALK_USAGE_TYPE


BIZTALK_CONFIGDATA_TYPE

Configures messaging ports.

[Visual Basic]

Enum BIZTALK_CONFIGDATA_TYPE

[C++]

enum BIZTALK_CONFIGDATA_TYPE

Members

BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT

[0] Configures the primary transport on the messaging port.

BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT

[1] Configures the secondary transport on the messaging port.

BIZTALK_CONFIGDATA_TYPE_ENCRYPTION

[2] Configures the encryption certificate on the messaging port.

BIZTALK_CONFIGDATA_TYPE_ENCODING

[2] Configures the encoding type on the messaging port.

BIZTALK_CONFIGDATA_TYPE_SIGNATURE

[4] Configures the signature verification on the messaging port.

BIZTALK_CONFIGDATA_TYPE_SERIALIZER

[5] Configures the serializer on the messaging port.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

GetConfigComponent

GetConfigData

SetConfigComponent

SetConfigData

Using Custom Components


BIZTALK_ENCODING_TYPE

Specifies the encoding type.

[Visual Basic]

Enum BIZTALK_ENCODING_TYPE

[C++]

enum BIZTALK_ENCODING_TYPE

Members

BIZTALK_ENCODING_TYPE_NONE

[1] Specifies that encoding is not used.

BIZTALK_ENCODING_TYPE_MIME

[2] Specifies Multipurpose Internet Mail Extensions (MIME) encoding.

BIZTALK_ENCODING_TYPE_CUSTOM

[3] Specifies custom encoding.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

EncodingType


BIZTALK_ENCRYPTION_TYPE

Specifies the encryption type.

[Visual Basic]

Enum BIZTALK_ENCRYPTION_TYPE

[C++]

enum BIZTALK_ENCRYPTION_TYPE

Members

BIZTALK_ENCRYPTION_TYPE_NONE

[1] Specifies that encryption is not used.

BIZTALK_ENCRYPTION_TYPE_CUSTOM

[2] Specifies custom encryption.

BIZTALK_ENCRYPTION_TYPE_SMIME

[4] Specifies Secure Multipurpose Internet Mail Extensions (S/MIME) encryption.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

EncryptionType


BIZTALK_OPENNESS_TYPE

Specifies the openness type.

[Visual Basic]

Enum BIZTALK_OPENNESS_TYPE

[C++]

enum BIZTALK_OPENNESS_TYPE

Members

BIZTALK_OPENNESS_TYPE_NOTOPEN

[1] Specifies that this instance of the object is not open.

BIZTALK_OPENNESS_TYPE_SOURCE

[2] Specifies that the source organization of this instance of the object is open.

BIZTALK_OPENNESS_TYPE_DESTINATION

[4] Specifies that the destination organization of this instance of the object is open.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: (cisapi.tlb)

Related Topics

Openness

Submit

SubmitSync


BIZTALK_OPENNESS_TYPE_EX

Specifies the openness type.

[Visual Basic]

Enum BIZTALK_OPENNESS_TYPE_EX

[C++]

enum BIZTALK_OPENNESS_TYPE_EX

Members

BIZTALK_OPENNESS_TYPE_EX_NOTOPEN

[1] Specifies that this instance of the object is not open.

BIZTALK_OPENNESS_TYPE_EX_SOURCE

[2] Specifies that the source organization of this instance of the object is open.

BIZTALK_OPENNESS_TYPE_EX_DESTINATION

[4] Specifies that the destination organization of this instance of the object is open.

BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW

[8] Specifies that BizTalk Server is receiving a document from an XLANG schedule instance.

BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW

[16] Specifies that BizTalk Server is sending a document to an XLANG schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Openness


BIZTALK_SIGNATURE_TYPE

Specifies the signature type.

[Visual Basic]

Enum BIZTALK_SIGNATURE_TYPE

[C++]

enum BIZTALK_SIGNATURE_TYPE

Members

BIZTALK_SIGNATURE_TYPE_NONE

[1] Specifies that there is no signature.

BIZTALK_SIGNATURE_TYPE_CUSTOM

[2] Specifies the custom signature of the document.

BIZTALK_SIGNATURE_TYPE_SMIME

[4] Specifies the S/MIME signature of the document.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

SignatureType


BIZTALK_STORE_TYPE

Specifies the store type of the certificate.

[Visual Basic]

Enum BIZTALK_STORE_TYPE

[C++]

enum BIZTALK_STORE_TYPE

Members

BIZTALK_STORE_TYPE_MY

[1] Specifies that the certificate store is type MY. This store contains certificates authorized only by your organization.

BIZTALK_STORE_TYPE_BIZTALK

[2] Specifies that the certificate is stored in the dedicated BizTalk Server 2002 store.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Certificates

Store


BIZTALK_TRANSPORT_TYPE

Specifies the transport component type.

[Visual Basic]

Enum BIZTALK_TRANSPORT_TYPE

[C++]

enum BIZTALK_TRANSPORT_TYPE

Members

BIZTALK_TRANSPORT_TYPE_NONE

[1] Specifies that this instance of the object does not select a transport component.

BIZTALK_TRANSPORT_TYPE_HTTP

[4] Specifies that this instance of the object selects a Hypertext Transfer Protocol (HTTP) transport component.

BIZTALK_TRANSPORT_TYPE_SMTP

[8] Specifies that this instance of the object selects a Simple Mail Transfer Protocol (SMTP) transport component.

BIZTALK_TRANSPORT_TYPE_APPINTEGRATION

[32] Specifies that this instance of the object selects an application integration component (AIC) transport component.

BIZTALK_TRANSPORT_TYPE_MSMQ

[128] Specifies that this instance of the object selects a Microsoft Message Queuing transport component.

BIZTALK_TRANSPORT_TYPE_FILE

[256] Specifies that this instance of the object selects a file as a transport component.

BIZTALK_TRANSPORT_TYPE_HTTPS

[1024] Specifies that this instance of the object selects a Secure Hypertext Transfer Protocol (HTTPS) transport component.

BIZTALK_TRANSPORT_TYPE_OPENDESTINATION

[2048] Specifies that the messaging port is an open destination.

BIZTALK_TRANSPORT_TYPE_LOOPBACK

[4096] Specifies that the document submitted to the server with the SubmitSync method will be processed and then returned back as the response document of the method.

BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION

[8192] Specifies that the Address property contains the path of an XLANG schedule to be executed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Type


BIZTALK_USAGE_TYPE

Specifies the usage type of the certificate.

[Visual Basic]

Enum BIZTALK_USAGE_TYPE

[C++]

enum BIZTALK_USAGE_TYPE

Members

BIZTALK_USAGE_TYPE_ENCRYPTION

[1] Specifies that this is an encryption certificate.

BIZTALK_USAGE_TYPE_SIGNATURE

[2] Specifies that this is a signature certificate.

BIZTALK_USAGE_TYPE_BOTH

[4] Specifies that this certificate is used for both encryption and signature.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Certificates

Usage


Documents Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for working with documents:

  • Interfaces

  • Enumerations

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented:

  • IBizTalkTrackData

  • IBTSCustomProcess

  • IBTSCustomProcessContext

  • IInterchange


IBizTalkTrackData Interface

Use this object to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2002. This object complements the IInterchange object so that returns from IInterchange methods can be passed to these methods for reading tracking data about the documents submitted to BizTalk Server 2002.

Hierarchy

IDispatch

|--IBizTalkTrackData

Declaration

[Visual Basic]

Class BTSDocTracking

[C++]

interface IBizTalkTrackData : IDispatch

Members

IBizTalkTrackData defines the following methods:

Method | Description
GetInDocDetails | Returns an ADO recordset that contains a list of the documents that were submitted to BizTalk Server by using the Submit method.
GetInterchanges | Returns an ADO recordset that contains a list of interchanges that were submitted to BizTalk Server by using the Submit method, including all the data from the Tracking database.
GetOutDocDetails | Returns an ADO recordset that contains a list of the documents that were generated as a result of the Submit method.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema

Document Definitions

Reading the Tracking Database

Document Tracking


GetInDocDetails Method

Returns an ADO recordset that contains a list of the documents that were submitted to BizTalk Server by using the Submit method.

Member List

IBizTalkTrackData

|--GetInDocDetails

|--GetInterchanges

|--GetOutDocDetails

Method Declaration

[Visual Basic]

Function GetInDocDetails( _

SubmissionID As String _

) As Object

[C++]

HRESULT GetInDocDetails(

BSTR SubmissionID ,

IDispatch** Result

);

Parameters

SubmissionID

[in] Contains the SubmissionHandle string returned by Submit for this document instance.

Result

[out, retval] In C++, an IDispatch interface that contains a list of the documents that were included in the submission. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an Object that contains a list of the documents that were included in the submission.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method returns specific information for an input document.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema


GetInterchanges Method

Returns an ADO recordset that contains a list of interchanges that were submitted to BizTalk Server by using the Submit method, including all the data from the Tracking database.

Member List

IBizTalkTrackData

|--GetInDocDetails

|--GetInterchanges

|--GetOutDocDetails

Method Declaration

[Visual Basic]

Function GetInterchanges( _

SubmissionID As String _

) As Object

[C++]

HRESULT GetInterchanges(

BSTR SubmissionID ,

IDispatch** Result

);

Parameters

SubmissionID

[in] Contains the SubmissionHandle string returned by Submit for this interchange.

Result

[out, retval] In C++, an IDispatch interface that contains a list of the interchanges that were included in the submission, including all the data from the Tracking database. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method optionally returns an Object that contains a list of interchanges contained in this submission, including all the data from the Tracking database.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

You can check the Tracking database to confirm or check status on delivery because transport-specific information, such as delivery times and receipt flags, appears in the Tracking database.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema


GetOutDocDetails Method

Returns an ADO recordset that contains a list of the documents that were generated as a result of the Submit method.

Member List

IBizTalkTrackData

|--GetInDocDetails

|--GetInterchanges

|--GetOutDocDetails

Method Declaration

[Visual Basic]

Function GetOutDocDetails( _

SubmissionID As String _

) As Object

[C++]

HRESULT GetOutDocDetails(

BSTR SubmissionID ,

IDispatch** Result

);

Parameters

SubmissionID

[in] Contains the SubmissionHandle string returned by Submit for this document instance.

Result

[out, retval] In C++, an IDispatch interface that contains a list of the documents that were generated as a result of the submission. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an Object that contains a list of the documents that were generated as a result of the submission.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method returns specific information for an output document, for example, PO #123456 from a Submit call made on a specific date.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema


IBTSCustomProcess

Implement IBTSCustomProcess to create a custom preprocessor for BizTalk Server receive functions.

Hierarchy

IUnknown

|--IBTSCustomProcess

Declaration

[Visual Basic]

Class IBTSCustomProcess

[C++]

interface IBTSCustomProcess : IUnknown

Members

IBTSCustomProcess defines the following methods:

Method | Description
Execute | Performs the custom processing on data obtained from a receive function.
SetContext | Retrieves context information associated with the data being processed.

Remarks

For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Custom preprocessor components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Preprocessor components register themselves with the category ID CATID_BIZTALK_CUSTOM_PROCESS. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


Execute Method

Performs the custom processing on data obtained from a receive function.

Member List

IBTSCustomProcess

|--Execute

|--SetContext

Method Declaration

[Visual Basic]

Sub Execute( _

DataIn As Variant, _

CodePageIn As Long, _

IsFilePath As Boolean, _

CodePageOut As Variant, _

DataOut As Variant _

)

[C++]

HRESULT NAME(

VARIANT DataIn,

long CodePageIn,

VARIANT_BOOL IsFilePath,

VARIANT* CodePageOut,

VARIANT* DataOut

);

Parameters

DataIn

[in] In Visual Basic, contains the input data read by the receive function. For data read from a message queue, the data can be either an array or a String. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the IsFilePath parameter is set to True.

[in] In C++, contains the input data read by the receive function. For data read from a message queue, the data can be either an array or a BSTR. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the IsFilePath parameter is set to VARIANT_TRUE.

CodePageIn

[in] Contains the code page of the input data. The code page indicates the character set and keyboard layout used on a computer.

IsFilePath

[in] In Visual Basic, contains a value that indicates whether or not the DataIn parameter contains a file path. True indicates that the DataIn parameter contains a file path; False indicates that the DataIn parameter contains data from a message queue receive function.

[in] In C++, contains a value that indicates whether or not the DataIn parameter contains a file path. VARIANT_TRUE indicates that the DataIn parameter contains a file path; VARIANT_FALSE indicates that the DataIn parameter contains data from a message queue receive function.

CodePageOut

[in, out] Contains the code page of the output data. The code page indicates the character set and keyboard layout used on a computer.

DataOut

[in, out] In Visual Basic, contains the output data. For file receive functions, this will be a String. The data in this parameter is sent to BizTalk Server for processing.

[in, out] In C++, contains the output data. For file receive functions, this will be a BSTR. The data in this parameter is sent to BizTalk Server for processing.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If BizTalk Server fails to create the custom preprocessor component, or if the Execute method returns an error or invalid data, the document being processed is placed in the Suspended queue.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


SetContext Method

Retrieves information associated with a document submitted to BizTalk Server.

Member List

IBTSCustomProcess

|--Execute

|--SetContext

Method Declaration

[Visual Basic]

Sub SetContext( _

Ctx As IBTSCustomProcessContext _

)

[C++]

HRESULT SetContext(

IBTSCustomProcessContext* Ctx

);

Parameters

Ctx

[in] IBTSCustomProcessContext that contains information associated with the document being processed by BizTalk Server.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

For additional information about the custom process context object, see IBTSCustomProcessContext.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext

Retrieves information associated with data being processed by using a custom preprocessor component.

Hierarchy

IUnknown

|-- IBTSCustomProcessContext

Declaration

[Visual Basic]

Class IBTSCustomProcessContext

[C++]

interface IBTSCustomProcessContext: IUnknown

Members

IBTSCustomProcessContext defines the following properties:

Property | Description
ChannelName | Contains the name of the channel.used for processing the current document.
DestID | Contains the value of the destination organization qualifier.
DestQualifier | Contains the destination organization qualifier type.
DocName | Contains the name of the document definition used by the current document.
EnvelopeName | Contains the name of the envelope used with the current document.
Openness | Contains the openness value associated with the messaging port.
PassThrough | Contains a value indicating whether the document uses pass-through submission mode.
SourceID | Contains the value of the source organization qualifier.
SourceQualifier | Contains the source organization qualifier type.

Remarks

This object can be obtained by calling the SetContext method on the IBTSCustomProcess object. For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


ChannelName Property

Contains the name of the channel used for processing the current document.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property ChannelName As String

[C++]

HRESULT get_ChannelName(

BSTR* ChannelName

);

Parameters

ChannelName

[out, retval] In C++, contains the name of the channel used for processing the current document. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the channel.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


DestID Property

Contains the value of the destination organization qualifier.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property DestID As String

[C++]

HRESULT get_DestID(

BSTR* DestID

);

Parameters

DestID

[out, retval] In C++, contains the value of the destination organization qualifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the destination organization qualifier.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


DestQualifier Property

Contains the destination organization qualifier type.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property DestQualifier As String

[C++]

HRESULT get_DestQualifier(

BSTR* DestQualifier

);

Parameters

DestQualifier

[out, retval] In C++, contains the value of the destination organization type. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the destination organization qualifier type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


DocName Property

Contains the name of the document definition used by the current document.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property DocName As String

[C++]

HRESULT get_DocName(

BSTR* DocName

);

Parameters

DocName

[out, retval] In C++, contains the document definition name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the document definition.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


EnvelopeName Property

Contains the name of the envelope used with the current document.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property EnvelopeName As String

[C++]

HRESULT get_EnvelopeName(

BSTR* EnvName

);

Parameters

EnvName

[out, retval] In C++, contains the envelope name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the envelope.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


Openness Property

Contains the openness value associated with the messaging port.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property Openness As Long

[C++]

HRESULT get_Openness(

long* Openness

);

Parameters

Openness

[out, retval] In C++, indicates the openness on the messaging port. Valid values for this parameter are defined by the BIZTALK_OPENNESS_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_OPENNESS_TYPE enumeration.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


PassThrough Property

Contains a value indicating whether the document uses pass-through submission mode.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property PassThrough As Long

[C++]

HRESULT get_PassThrough(

long* PassThrough

);

Parameters

PassThrough

[out, retval] In C++, indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


SourceID Property

Contains the value of the source organization qualifier.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property SourceID As String

[C++]

HRESULT get_SourceID(

BSTR* SourceID

);

Parameters

SourceID

[out, retval] In C++, contains the value of the source organization qualifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the source organization qualifier.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


SourceQualifier Property

Contains the source organization qualifier type.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property SourceQualifier As String

[C++]

HRESULT get_SourceQualifier(

BSTR* SourceQualifier

);

Parameters

SourceQualifier

[out, retval] In C++, contains the value of the source organization type. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the source organization qualifier type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IInterchange

Use this object to exchange documents between applications and BizTalk Server 2002 directly or through a receive function

Hierarchy

IDispatch

|--IInterchange

Declaration

[Visual Basic]

Class Interchange

[C++]

interface IInterchange : IDispatch

Members

IInterchange defines the following methods:

Method | Description
CheckSuspendedQueue | Returns a list of documents from the Suspended queue that match the request criteria.
DeleteFromSuspendedQueue | Deletes all specified documents from the Suspended queue.
GetSuspendedQueueItemDetails | Retrieves information about a single entry in the Suspended queue.
Submit | Sends an interchange or document to BizTalk Server 2002 for asynchronous processing. BizTalk Server 2002 places the document in a queue until the next available server can process it.
SubmitSync | Sends an interchange or document to BizTalk Server 2002 for synchronous processing. An optional response document is returned to the caller.

Remarks

Using parameters with Submit and SubmitSync overrides certain fields in the header of a self-routing document.

For information about submitting documents from a remote client, see How To.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Direct Integration

Submitting

Routing

Submitting Documents

Submitting a Document


CheckSuspendedQueue Method

Returns a list of documents from the Suspended queue that match the request criteria.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Function CheckSuspendedQueue( _

DocName As String, _

SourceName As String, _

DestName As String_

)

[C++]

HRESULT CheckSuspendedQueue(

BSTR DocName,

BSTR SourceName,

BSTR DestName,

VARIANT* DocumentHandleList

);

Parameters

DocName

[in] Contains the name of the IBizTalkDocument object. This parameter narrows the search for items in the Suspended queue. If this parameter is omitted, this method matches all IBizTalkDocument objects. This is an optional parameter.

SourceName

[in] Contains the name of the source IBizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all IBizTalkOrganization objects. This is an optional parameter.

DestName

[in] Contains the name of the destination IBizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all IBizTalkOrganization objects. This is an optional parameter.

DocumentHandleList

[out, retval] In C++, contains a list of handles to all documents in the Suspended queue. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a list of handles to all documents in the Suspended queue.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The returned items are not deleted from the queue. To delete items from the Suspended queue, use the DeleteFromSuspendedQueue method.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Submitting a Document


DeleteFromSuspendedQueue Method

Deletes all specified documents from the Suspended queue.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Sub DeleteFromSuspendedQueue( _

DocumentHandleList As Variant _

)

[C++]

HRESULT DeleteFromSuspendedQueue(

VARIANT* DocumentHandleList

);

Parameters

DocumentHandleList

[in] Contains a full list of handles or a subset for documents to be deleted from the Suspended queue.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Submitting a Document


GetSuspendedQueueItemDetails Method

Retrieves information about a single entry in the Suspended queue.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Sub GetSuspendedQueueItemDetails( _

ItemHandle As String, _

SourceName As Variant, _

DestName As Variant, _

DocName As Variant, _

ReasonCode As Variant, _

ItemData As Variant

)

[C++]

HRESULT GetSuspendedQueueItemDetails(

BSTR ItemHandle,

VARIANT* SourceName,

VARIANT* DestName,

VARIANT* DocName,

VARIANT* ReasonCode,

VARIANT* ItemData

);

Parameters

ItemHandle

[in] Contains the handle of an item in the Suspended queue. This value can be obtained by calling the CheckSuspendedQueue method.

SourceName

[out] Contains the name of the source IBizTalkOrganization object.

DestName

[out] Contains the name of the destination IBizTalkOrganization object.

DocName

[out] Contains the name of the IBizTalkDocument object.

ReasonCode

[out] Contains the reason a document or interchange has been placed in the Suspended queue. For more information about this value, see the CISReasonToQueue enumeration.

ItemData

[out] Contains the document instance or interchange.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Submitting a Document


Submit Method

Sends an interchange or document to BizTalk Server 2002 for asynchronous processing. BizTalk Server 2002 places the document in a queue until the next available server can process it.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Function Submit( _

Openness As BIZTALK_OPENNESS_TYPE, _

Document As String, _

DocName As String, _

SourceQualifier As String, _

SourceID As String, _

DestQualifier As String, _

DestID As String, _

ChannelName As String, _

FilePath As String, _

EnvelopeName As String, _

PassThrough As Long

) As String

[C++]

HRESULT Submit(

BIZTALK_OPENNESS_TYPE Openness,

BSTR Document,

BSTR DocName,

BSTR SourceQualifier,

BSTR SourceID,

BSTR DestQualifier,

BSTR DestID,

BSTR ChannelName,

BSTR FilePath,

long EnvelopeName,

BSTR* PassThrough,

BSTR* SubmissionHandle

);

Parameters

Openness

[in] Indicates whether associated IBizTalkPort objects can be open. Valid values are defined by the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] Contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, IDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] Contains the name of the IBizTalkDocument object associated with the instance of the document being submitted. If the Openness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input IBizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output IBizTalkDocument must not have an X12 or EDIFACT specification. If Openness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the IBizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] Contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the Data Universal Numbering System (D-U-N-S) number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] Contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] Contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. You must specify a DestID. The default qualifier for all new organizations is OrganizationName and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] Contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] Contains the name of the IBizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] Specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2002 supports URL, UNC, and drive: format only. If the document is submitted as a file that is pointed to by the FilePath parameter, the call returns successfully after BizTalk Server 2002 has successfully copied the file to the Work queue. It is safe to delete the file from the specified path as soon as this method returns successfully. When a document is submitted to the server, using FilePath to specify the data, Submit can take 30 seconds or longer if the location of the file resides on a remote server that is unavailable, if the UNC path is invalid, or if the SQL server is down. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] Contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. When submitting a flat file to BizTalk Server 2002, you must create an envelope for this flat file and specify the name of the envelope in EnvelopeName. This is an optional parameter.

PassThrough

[in] Indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out, retval] In C++, contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned, yet the Tracking database enables the user to get the status of all child documents related to this interchange identifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Submitting a Document


SubmitSync Method

Sends an interchange or document to BizTalk Server 2002 for synchronous processing. An optional response document is returned to the caller.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Sub SubmitSync( _

Openness As BIZTALK_OPENNESS_TYPE, _

Document As String, _

DocName As String, _

SourceQualifier As String, _

SourceID As String, _

DestQualifier As String, _

DestID As String, _

ChannelName As String, _

FilePath As String, _

EnvelopeName As String, _

PassThrough As Long, _

SubmissionHandle As Variant, _

ResponseDocument As Variant

)

[C++]

HRESULT SubmitSync(

BIZTALK_OPENNESS_TYPE Openness,

BSTR Document,

BSTR DocName,

BSTR SourceQualifier,

BSTR SourceID,

BSTR DestQualifier,

BSTR DestID,

BSTR ChannelName,

BSTR FilePath,

long EnvelopeName,

BSTR* PassThrough,

VARIANT* SubmissionHandle,

VARIANT* ResponseDocument

);

Parameters

Openness

[in] Indicates whether associated IBizTalkPort objects can be open. Valid values are defined by the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] Contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, IDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] Contains the name of the IBizTalkDocument object associated with the instance of the document submitted. If the Openness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input IBizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output IBizTalkDocument must not have an X12 or EDIFACT specification. If Openness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the IBizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] Contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] Contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] Contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. You must specify a DestID parameter. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] Contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] Contains the name of the IBizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] Specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2002 supports URL, UNC, and drive: format only. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] Contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. This is an optional parameter.

PassThrough

[in] Indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out] Contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

ResponseDocument

[out] Contains the optional response document.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

SubmitSync returns an optional response document when provided. If no response is returned, the call returns successfully, but with no response and with an HRESULT value of S_FALSE. If the destination is another BizTalk Server, an ASP page must be used to return a response.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols (HTTP and AIC), an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Submitting a Document


Enumerations

The following enumeration provides possible property and parameter values:

  • CISReasonToQueue


CISReasonToQueue

Describes the reasons a document was placed in a queue.

[Visual Basic]

Enum CISReasonToQueue_tag

[C++]

enum CISReasonToQueue

Members

noReason

[0] Not supported for this release.

rtdlqParserFailure

[1] Specifies that the instance of the document was placed in the queue because of failure of the parser.

rtdlqParserDocFailure

[2] Specifies that the instance of the document was placed in the queue because the business document was invalid.

rtdlqDocValidation

[3] Specifies that the document was placed in the queue because document validation failed.

rtdlqChannelSelectFailure

[4] Specifies that the instance of the document was placed in the queue because of failure in selecting the correct IBizTalkChannel object.

rtdlqInvalidMap

[5] Specifies that the instance of the document was placed in the queue because the map referred to by the BizTalkChannel object was formatted incorrectly.

rtdlqFieldTrackingFailure

[6] Specifies that the instance of the document was placed in the queue because the server was unable to track the requested fields within the document.

rtdlqMappingFailure

[7] Specifies that the instance of the document was placed in the queue because of failure of transformation.

rtdlqSerializerFailure

[8] Specifies that the instance of the document was placed in the queue because the server could not convert this document to its native format.

rtdlqEncodingFailure

[9] Specifies that the instance of the document was placed in the queue because the server was unable to encode this interchange.

rtdlqSigningFailure

[10] Specifies that the instance of the document was placed in the queue because the server was unable to sign this interchange.

rtdlqEncryptionFailure

[11] Specifies that the instance of the document was placed in the queue because the server was unable to encrypt this interchange.

rtdlqTransmissionFailure

[12] Specifies that the instance of the document was placed in the queue because the server was unable to deliver this document.

rtdlqUserMove

[13] Specifies that the administrator moved this instance of the document to the queue.

rtdlqTimeout

[14] Specifies that the instance of the document was placed in the queue because a time-out occurred.

rtdlqCustomCompFailure

[15] Specifies that the instance of the document was placed in the queue because of failure of a custom component.

unkReason

[16] Specifies that this item was marked as "In process" by an inactive server. On restart of this server, this item was automatically moved to the Suspended queue. There was probably a catastrophic failure on the original server. Contact the system administrator for more information.

rtdlqNoChannel

[17] Specifies that the instance of the document was placed in the queue because the BizTalkChannel object was deleted.

rtdlqMissingChannel

[18] Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface was not found.

rtdlqInvalidChannel

[19] Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface specifies an open IBizTalkPort object. This is not permitted.

rtdlqOutOfMemory

[20] Specifies that your computer has run out of memory. Rebooting is recommended.

rtdlqBTFRecReqExpired

[21] Specifies that the document was placed in the queue because the BTF timestamp receiptRequiredBy expired.

rtdlqBTFExpiresAtExpired

[22] Specifies that the document was placed in the queue because the BTF timestamp expiresAt expired.

rtdlqCorrelationFailure

[23] Specifies that the document receipt failed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

GetSuspendedQueueItemDetails


Custom Components Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for working with custom components:

  • Interfaces

  • Enumerations

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented for C++ developers:

  • IBizTalkParserComponent

  • IBizTalkSerializerComponent

The following COM interfaces are documented for both C++ and Visual Basic developers:

  • IBizTalkAcknowledge

  • IBizTalkCorrelation

  • IBTSAppIntegration

  • IFunctoid

  • IPipelineComponent

  • IPipelineComponentAdmin

  • ISchemaImporter

  • ISchemaImporterError

  • ISchemaImporterErrorProvider


IBizTalkAcknowledge

Processes receipts sent to the server.

Hierarchy

IUnknown

|--IBizTalkAcknowledge

Declaration

[Visual Basic]

Class IBizTalkAcknowledge

[C++]

interface IBizTalkAcknowledge : IUnknown

Members

IBizTalkAcknowledge defines the following methods:

Method | Description
AckDocument | Processes receipts received for documents.
AckGroup | Processes receipts received for document groups.
AckInterchange | Processes receipts received for document interchanges.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Creating Receipt Correlator Components

How Receipts Are Logged

Understanding Receipts


AckDocument Method

Processes receipts received for documents.

Member List

IBizTalkAcknowledge

|--AckDocument

|--AckGroup

|--AckInterchange

Method Declaration

[Visual Basic]

Sub AckDocument( _

Syntax As String, _

TrackingId As String, _

AckStatus As DTA_ACK_STATUS _

)

[C++]

HRESULT AckDocument(

BSTR Syntax,

BSTR TrackingId,

DTA_ACK_STATUS AckStatus

);

Parameters

Syntax

[in] Contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT.

TrackingId

[in] Contains the globally unique identifier (GUID) for tracking the document. This value can be obtained from the Tracking_ID field in the dta_outdoc_details table. For more information, see Supporting the Tracking Database with Parser and Serializer Components.

AckStatus

[in] Indicates the receipt status. Valid values for this parameter are defined by the DTA_ACK_STATUS enumeration.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only for receipts on individual documents. If the receipt needs to be mapped, a document definition that points to CanonicalReceipt.xml shipped in WebDAV must be created for the receipt.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


AckGroup Method

Processes receipts received for document groups.

Member List

IBizTalkAcknowledge

|--AckDocument

|--AckGroup

|--AckInterchange

Method Declaration

[Visual Basic]

Sub AckGroup( _

Syntax As String, _

Version As String, _

Release As String, _

FunctionalGroupId As String, _

ControlId As String, _

SrcAppName As String, _

DestAppName As String, _

AckStatus As DTA_ACK_STATUS _

)

[C++]

HRESULT AckGroup(

BSTR Syntax,

BSTR Version,

BSTR Release,

BSTR FunctionalGroupId,

BSTR ControlId,

BSTR SrcAppName,

BSTR DestAppName,

DTA_ACK_STATUS AckStatus

);

Parameters

Syntax

[in] Contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

Version

[in] Contains the version of the syntax, used primarily for EDI.

Release

[in] Contains the release of the version of the syntax, used primarily for EDI.

FunctionalGroupId

[in] Contains the code for the type of documents in a group, used primarily for EDI.

ControlId

[in] Contains the unique identifier for the control number, used primarily for EDI.

SrcAppName

[in] Contains the name of the source application.

DestAppName

[in] Contains the name of the destination application.

AckStatus

[in] Indicates the receipt status. Valid values are defined by the DTA_ACK_STATUS enumeration.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only for receipts on document groups.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


AckInterchange Method

Processes receipts received for document interchanges.

Member List

IBizTalkAcknowledge

|--AckDocument

|--AckGroup

|--AckInterchange

Method Declaration

[Visual Basic]

Sub AckInterchange( _

Syntax As String, _

InterchangeId As String, _

Version As String, _

ControlId As String, _

SrcAliasQualifier As String, _

SrcAliasId As String, _

SrcAppName As String, _

DestAliasQualifier As String, _

DestAliasId As String, _

DestAppName As String, _

AckStatus As DTA_ACK_STATUS _

)

[C++]

HRESULT AckInterchange(

BSTR Syntax,

BSTR InterchangeId,

BSTR Version,

BSTR ControlId,

BSTR SrcAliasQualifier,

BSTR SrcAliasId,

BSTR SrcAppName,

BSTR DestAliasQualifier,

BSTR DestAliasId,

BSTR DestAppName,

DTA_ACK_STATUS AckStatus

);

Parameters

Syntax

[in] Contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

InterchangeId

[in] Contains the unique tracking identifier of the interchange. This value is a globally unique identifier (GUID).

Version

[in] Contains the version of the syntax, used primarily for EDI.

ControlId

[in] Contains the unique identifier for the control number, used primarily for EDI.

SrcAliasQualifier

[in] Contains the qualifier of the source organization. This indicates how the bstrSrcAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the Data Universal Numbering System (D-U-N-S) number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

SrcAliasId

[in] Contains the value of the qualifier of the source organization. For example, if the bstrSrcAliasQualifier parameter is Telephone, this value is the telephone number.

SrcAppName

[in] Contains the name of the source application.

DestAliasQualifier

[in] Contains the qualifier of the source organization. This indicates how the bstrDestAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

DestAliasId

[in] Contains the value of the qualifier of the source organization. For example, if the bstrDestAliasQualifier parameter is Telephone, this value is the telephone number.

DestAppName

[in] Contains the name of the destination application.

AckStatus

[in] Indicates the receipt status. Valid values are defined by the DTA_ACK_STATUS enumeration.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only for receipts on document interchanges.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


IBizTalkCorrelation

Creates receipt correlator components.

Hierarchy

IUnknown

|--IBizTalkCorrelation

Declaration

This interface is only supported in C++

interface IBizTalkCorrelation : IUnknown

Members

IBizTalkCorrelation defines the following method:

Method | Description
Correlate | Extracts all relevant information from the document, document group, or interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Creating Receipt Correlator Components


Correlate Method

Extracts all relevant information from the document, document group, or interchange.

Member List

IBizTalkCorrelation

|--Correlate

Method Declaration

This method is only supported in C++

HRESULT Correlate(

IUnknown* Acknowledge,

IDictionary* Dict

);

Parameters

Acknowledge

[in] An IBizTalkAcknowledge interface used to invoke and set the receipt flag.

Dict

[in] An IDictionary interface of an object that contains the receipt information.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h


IFunctoid

Creates custom mapping functions. IFunctoid defines the generic protocol for calling custom functions used by the mapping tool.

Hierarchy

IDispatch

|--IFunctoid

Declaration

[Visual Basic]

Class CannedFunctoid

[C++]

interface IFunctoid : IDispatch

Members

IFunctoid defines the following properties:

Property | Description
FunctionsCount | Contains the number of functions implemented by the functoid.
Version | Contains the version of the functoid.

IFunctoid defines the following methods:

Method | Description
GetFunctionDescripter | Retrieves information about a specific functoid.
GetFunctionParameter | Retrieves the connection-type bit flags for the specified parameter.
GetScriptBuffer | Retrieves the script code used to implement the functoid.

Remarks

Custom functoids must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Functoids register themselves with the category ID CATID_BIZTALK_MapEditFunctoids. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Each custom functoid can support multiple functions and can contain icons and names for each supported function. Function identifiers from 0 to 1000 are reserved for built-in functions in BizTalk Mapper. User-defined functions (custom functions) should use function identifiers 1001 and above.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


FunctionsCount Property

Contains the number of functions implemented by the functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Property Declaration

[Visual Basic]

Property FunctionsCount As Long

[C++]

HRESULT get_FunctionsCount(

long* Count

);

Parameters

Count

[out, retval] In C++, contains the number of functions implemented by the functoid. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of functions implemented by the functoid.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


GetFunctionDescripter Method

Retrieves information about a specific functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Method Declaration

[Visual Basic]

Function GetFunctionDescripter( _

Index As Long, _

FuncCategory As FUNC_CATEGORY, _

ScriptCategory As SCRIPT_CATEGORY, _

FuncType As FUNC_TYPE, _

Name As String, _

ToolTip As String, _

BitmapID As Long, _

ParmCount As Long _

) As Long

[C++]

HRESULT GetFunctionDescripter(

long Index,

FUNC_CATEGORY* FuncCategory,

SCRIPT_CATEGORY* ScriptCategory,

FUNC_TYPE* FuncType,

BSTR* Name,

BSTR* ToolTip,

long* BitmapID,

long* ParmCount,

FUNCID* FuncId

);

Parameters

Index

[in] Specifies the index number of the function.

FuncCategory

[in, out] Contains a value indicating the tab on the functoid palette on which the custom functoid will appear. Valid values for this parameter are defined by the FUNC_CATEGORY enumeration.

ScriptCategory

[in, out] Contains the scripting language used by the custom functoid. Valid values for this parameter are defined by the SCRIPT_CATEGORY enumeration.

FuncType

[in, out] Contains the function type information for the custom functoid. Valid values for this parameter are defined by the FUNC_TYPE enumeration.

Name

[in, out] Contains the function name.

ToolTip

[in, out] Contains the ToolTip that appears when the mouse pointer is paused over the custom functoid icon in the mapping tool.

BitmapID

[in, out] Contains a bitmap identifier of the bitmap used for the custom functoid icon displayed in the mapping tool.

ParmCount

[in, out] Contains the number of parameters implemented by the function.

FuncId

[out, retval] In C++, contains the function identifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the function identifier.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


GetFunctionParameter Method

Retrieves the connection-type bit flags for the specified parameter.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Method Declaration

[Visual Basic]

Function GetFunctionParameter( _

FuncId As Long, _

Parameter As Long _

) As Long

[C++]

HRESULT GetFunctionParameter(

FUNCID FuncId,

long Parameter,

long* ConnectionType

);

Parameters

FuncId

[in] Contains the function identifier.

Parameter

[in] Contains the function parameter number. For output parameters, a value of -1 is used.

ConnectionType

[out, retval] In C++, contains the connection type information of the specified parameter. Valid values for this parameter are defined by the CONNECTION_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the connection type information of the specified parameter. Valid values for this parameter are defined by the CONNECTION_TYPE enumeration.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


GetScriptBuffer Method

Retrieves the script code used to implement the functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Method Declaration

[Visual Basic]

Function GetScriptBuffer( _

FuncId As Long, _

InputParameters As Long _

) As String

[C++]

HRESULT GetScriptBuffer(

FUNCID FuncId,

long InputParameters,

BSTR* ScriptBuffer

);

Parameters

FuncId

[in] Contains the function identifier.

InputParameters

[in] Indicates the number of connected input parameters for the specified function.

ScriptBuffer

[out, retval] In C++, contains the script code used to implement the function. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the script code used to implement the function.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


Version Property

Contains the version of the functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Property Declaration

[Visual Basic]

Property Version As Long

[C++]

HRESULT get_Version(

long* Version

);

Parameters

Version

[out, retval] In C++, contains the custom functoid version. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the custom functoid version.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

If the custom functoid is modified in any way, the author should update the version number.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IBizTalkParserComponent

Converts a document to XML for later processing and identifies the IBizTalkChannel objects necessary to process the documents.

Hierarchy

IUnknown

|--IBizTalkParserComponent

Declaration

This interface is only supported in C++

interface IBizTalkParserComponent : IUnknown

Members

IBizTalkParserComponent defines the following methods:

Method | Description
GetGroupDetails | Gets details of the group for the Tracking database. This method is called only if there are groups in the interchange.
GetGroupSize | Gets the size of the group after all documents in the group are parsed. This method is called only if there are groups in the interchange.
GetInterchangeDetails | Gets information about the organization identifiers of the source and destination IBizTalkOrganization objects.
GetNativeDocumentOffsets | Identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.
GetNextDocument | Examines the data in a document and determines when to get the next document if this is not the last document.
GroupsExist | Determines whether the interchange contains groups.
ProbeInterchangeFormat | Identifies the format of the interchange.

Remarks

Custom parser components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Parser components register themselves with the category ID CATID_BIZTALK_PARSER. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Identification

Working with Parsers

Parsers


GetGroupDetails Method

Gets details of the group for the Tracking database. This method is called only if there are groups in the interchange.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetGroupDetails(

IDictionary* Dict

);

Parameters

Dict

[in] IDictionary interface of an object that contains details about the group. All information is returned as string types, no matter how it appears in the data.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only if groups are detected in the interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetGroupSize Method

Gets the size of the group after all documents in the group are parsed. This method is called only if there are groups in the interchange.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetGroupSize(

long* GroupSize,

BOOL* LastGroup

);

Parameters

GroupSize

[out] Contains the size of the interchange.

LastGroup

[out] Indicates whether the group is the last group in the interchange. If this parameter is set to TRUE, the next method called is GetGroupDetails for the next group in the data. If it is set to FALSE, the component is finished. When it is released, it leaves the IStream interface after the last byte it has read.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

After all documents in the group are called, the final details about the group are required. Both output parameters are added to the Tracking database for final logging.

This method is called only if there are groups in the interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetInterchangeDetails Method

Gets information about the organization identifiers of the source and destination IBizTalkOrganization objects.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetInterchangeDetails(

IDictionary* Dict

);

Parameters

Dict

[in] IDictionary interface of an object that contains information about the organization identifiers of the source and destination IBizTalkOrganization objects.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The minimum sets of fields are:

Field | Description
src_id_type | Source qualifier
src_id_value | Source ID
dest_id_type | Destination qualifier
dest_id_value | Destination ID

The parameters of the Submit method of the IInterchange interface override any fields set here.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetNativeDocumentOffsets Method

Identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetNativeDocumentOffsets(

BOOL SizeFromXMLDoc,

LARGE_INTEGER* StartOffset,

long* DocLength

);

Parameters

SizeFromXMLDoc

[out] Indicates whether the XML document passed in from the GetNextDocument method was used to determine the size. If this parameter is TRUE, the server fills in the StartOffset and DocLength values for the document just parsed. If this parameter is FALSE, the server ignores the values in StartOffset and DocLength.

StartOffset

[out] Contains the location of the beginning of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

DocLength

[out] Contains the length of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called immediately after GetNextDocument whether or not the document is valid (as long as the parser does not return an error value). These are offsets into the IStream object relative to the beginning of the stream, not the beginning of the interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetNextDocument Method

Examines the data in a document and determines when to get the next document if this is not the last document.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetNextDocument(

IDictionary* Dict,

BSTR DocSpecName,

BOOL* DocIsValid,

BOOL* LastDocument,

GeneratedReceiptLevel ReceiptGenerated,

BOOL* DocIsReceipt,

BSTR* CorrelationCompProgID

);

Parameters

Dict

[in] IDictionary interface of an object into which to set the XML instance created on parsing the current document. The parsed XML document is placed into the working_data field of the dictionary.

DocSpecName

[in] Contains the name of the BizTalk document specification used to generate the XML from the document's native format.

DocIsValid

[out] Indicates whether the document instance is valid. If it is invalid but the parser can recover from it, set this parameter to FALSE. This parameter and the LastDocument parameter are independent. Therefore, if there are no more documents and the last one is invalid, both flags are set. If the document is invalid and the parser cannot continue, it might return an error value. The server then stops at the current position of the IStream pointer. The component places the invalid data (if the parser can recover) in the working_data field for inspection by the system administrator if the document is invalid.

LastDocument

[out] Indicates whether this is the last document instance in the group or interchange. When the last document is found, the LastDocument flag is set to TRUE. If there are groups, this flag signals the last document in the group, and the GetGroupSize method is called. If there are no groups, this is the last call to get document data from the parser, and the IStream pointer is set appropriately.

ReceiptGenerated

[out] Contains the receipt status information. Valid values are defined by the GeneratedReceiptLevel enumeration.

DocIsReceipt

[out] Identifies whether or not this document is a receipt.

CorrelationCompProgID

[out] Contains the program ID for the correlation of documents.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GroupsExist Method

Determines whether the interchange contains groups.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GroupsExist(

BOOL* GrpsExist

);

Parameters

GrpsExist

[out, retval] Indicates whether the data format contains groups. If this parameter is set to FALSE, the GetGroupDetails and GetGroupSize methods are never called.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


ProbeInterchangeFormat Method

Identifies the format of the interchange.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT ProbeInterchangeFormat(

IStream* pData,

BOOL FromFile,

BSTR EnvName,

IStream* pReceiptData,

BSTR* Format

);

Parameters

pData

[in] IStream object that contains the data for the document interchange. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

FromFile

[in] Contains a value that indicates whether or not the data came from the FilePath parameter of the Submit or the SubmitSync method of the IInterchange interface. TRUE indicates that the data came from the file referred to by the FilePath parameter. FALSE indicates that the data came from the Document parameter of Submit or SubmitSync as a string. If the data is from a file, no conversion is made. If the data is a string, you can use UNICODE/MBCS techniques to understand it.

EnvName

[in] Contains the name of the envelope.

pReceiptData

[in] IStream object that contains the receipt document.

Format

[out] Contains the format of the data. If the server recognizes the format, it must fill in this parameter with a non-empty string and hold on to (add a reference count to) the IStream interface because it is not given back to the component. This IStream object is read-only; it supports only the Read, Stat, and Seek methods. All other methods return E_NOTIMPL. This method should not return a failure if it does not recognize the format. It returns S_FALSE or an empty or NULL Format string. If you do not recognize the format, you do not need to move the IStream pointer back to its original position; the server resets the IStream pointer. Unless your format requires it, do not assume that the pointer is at the beginning. The pointer can be somewhere in the middle during the probing stage.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is the first method that is called by the server. If ProbeInterchangeFormat returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


IBizTalkSerializerComponent

Converts a document from XML to the document's original native format.

Hierarchy

IUnknown

|--IBizTalkSerializerComponent

Declaration

This interface is only supported in C++

interface IBizTalkSerializerComponent : IUnknown

Members

IBizTalkSerializerComponent defines the following methods:

Method | Description
AddDocument | Adds an XML document for storage by the serializer component.
GetDocInfo | Gets details of the document.
GetGroupInfo | Gets details of the group, such as size and offset, for the Tracking database.
GetInterchangeInfo | Gets information about the interchange created.
Init | Outputs the document instance to the serializer component and indicates where it should be sent.

Remarks

Custom serializer components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Serializer components register themselves with the category ID CATID_BIZTALK_SERIALIZER. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


AddDocument Method

Adds an XML document for storage by the serializer component.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT AddDocument(

long DocHandle,

IDictionary* Transport,

BSTR TrackID,

long ChannelID

);

Parameters

DocHandle

[in] Contains the handle to the document that is stored by the component and later retrieved when calling the GetDocInfo method. This parameter supports out-of-order recreation of the interchange in case the documents need to be reordered (such as in X12).

Transport

[in] Contains an IDictionary interface of an object that contains the XML document to be stored. It is on the working_data field. This parameter cannot be set by the component. This is an optional parameter.

TrackID

[in] Contains the document tracking ID used by the server.

ChannelID

[in] Contains the IBizTalkChannel object associated with the current document.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only once per interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


GetDocInfo Method

Gets details of the document.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT GetDocInfo(

long* DocHandle,

BOOL* SizeFromXMLDoc,

LARGE_INTEGER* DocStartOffset,

long* DocLen

);

Parameters

DocHandle

[out] Contains the document handle. For each ID that is passed back, this address is assigned to the group record that was created when the GetGroupInfo method was called. This parameter also returns properties of the document, for example, size and length, unless the SizeFromXMLDoc parameter is set to TRUE, in which case the other parameters are ignored.

SizeFromXMLDoc

[out] Indicates that the document offset and length values are retrieved from the XML document. TRUE indicates that the server fills in the DocStartOffset and DocLen values for the document; FALSE indicates that the server ignores the values in DocStartOffset and DocLen.

DocStartOffset

[out] Contains the offset to the beginning of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

DocLen

[out] Contains the length of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called once for every document in a group (or interchange, if there are no groups).

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


GetGroupInfo Method

Gets details of the group, such as size and offset, for the Tracking database.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT GetGroupInfo(

long* NumDocs,

LARGE_INTEGER* GrpStartOffset,

long* GrpLen

);

Parameters

NumDocs

[out] Contains the number of documents in the group.

GrpStartOffset

[out] Contains the offset to the start of the group in the IStream interface.

GrpLen

[out] Contains the length of the group.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called the number of times returned by the GetInterchangeInfo method. Call the GetDocInfo method for each document in the group.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Serializers


GetInterchangeInfo Method

Gets information about the interchange created.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT GetInterchangeInfo(

BSTR* InterchangeID,

long* NumGroups

);

Parameters

InterchangeID

[out] Contains the interchange ID, which is placed in the Tracking database.

NumGroups

[out] Contains the number of groups generated in the interchange. This value can be either 0 or 1. A document can exist in only one group.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called after all the documents are passed in.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


Init Method

Outputs the document instance to the serializer component and indicates its destination.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT Init(

BSTR srcQual,

BSTR srcID,

BSTR destQual,

BSTR destID,

long envID,

IDictionary* Delimiters,

Istream* OutputStream,

long NumDocs

);

Parameters

srcQual

[in] Contains the source-organization identifier qualifier.

srcID

[in] Contains the source-organization identifier value.

destQual

[in] Contains the destination-organization identifier qualifier.

destID

[in] Contains the destination-organization identifier value.

EnvID

[in] Contains the envelope identifier value.

Delimiters

[in] Contains an IDictionary interface of an object that contains the delimiters used in the document.

OutputStream

[in] Contains an IStream interface that contains the data of this document. This IStream pointer is write-only. The only methods that are supported are Write and Stat; all other methods return E_NOTIMPL. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

NumDocs

[in] Contains the number of documents sent as part of this interchange. For this release, this parameter is set to 1.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


IBTSAppIntegration

Creates an entry point for receiving a document.

Hierarchy

IDispatch

|--IBTSAppIntegration

Declaration

[Visual Basic]

Class IBTSAppIntegration

[C++]

interface IBTSAppIntegration : IDispatch

Members

IBTSAppIntegration defines the following method:

Method | Description
ProcessMessage | Processes a document and returns a response document, if available. This method is called at run time when the server is sending a document to the component.

Remarks

Application integration components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)

Related Topics

Lightweight Application Integration Components

Application Integration in Visual Basic

Application Integration in Visual C++


ProcessMessage Method

Processes a document and returns a response document, if available. This method is called at run time when the server is sending a document to the component.

Member List

IBTSAppIntegration

|--ProcessMessage

Method Declaration

[Visual Basic]

Function ProcessMessage( _

Document As String _

) As String

[C++]

HRESULT ProcessMessage(

BSTR Document,

BSTR* ResponseDocument

);

Parameters

Document

[in] Contains the document to be processed.

ResponseDocument

[retval, out] In C++, contains the response document processed by the component, if available. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the response document, if available.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Components can return a response string to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface to send documents.

Components must raise an error if a problem with processing occurs so that the document can be retransmitted or sent to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IPipelineComponent

Creates custom pipeline components that can execute in Microsoft BizTalk Server 2002 to extend its functionality.

Hierarchy

IUnknown

|--IPipelineComponent

Declaration

[Visual Basic]

Class IPipelineComponent

[C++]

interface IPipelineComponent : IUnknown

Members

IPipelineComponent defines the following methods:

Method | Description
EnableDesign | Configures the component for execution in one of two modes: design mode or execution mode.
Execute | Executes the operation expected of the component, given the transport IDictionary object and other configuration settings.

Remarks

Application integration components must be properly registered so that BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topics

Application Integration Components

Pipeline Components in Visual Basic

Pipeline Components in Visual C++


EnableDesign Method

Configures the component for execution in one of two modes: design mode or execution mode.

Member List

IPipelineComponent

|--EnableDesign

|--Execute

Method Declaration

[Visual Basic]

Sub EnableDesign( _

Enable As Boolean _

)

[C++]

HRESULT EnableDesign(

BOOL Enable

);

Parameters

Enable

[in] Indicates the mode of the component. True specifies that the component runs in design mode. False specifies execution mode. The default value is False.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The pipeline component runs in execution mode by default.

This method is called when the Override messaging port defaults page is opened in the Channel Wizard's Advanced Configuration page. It is also called when the property page is closed and the Enable parameter is set to true. Design mode is not enabled unless this method has been called with the Enable parameter set to True.

Design-only fields are returned only when the Enable parameter is set to true. Otherwise, the IDictionary object passed to the server contains unnecessary information.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


Execute Method

Executes the operation expected of the component, given the transport IDictionary object and other configuration settings.

Member List

IPipelineComponent

|--EnableDesign

|--Execute

Method Declaration

[Visual Basic]

Function Execute( _

DispOrder As Object, _

DispContext As Object, _

Flags As Long _

) As Long

[C++]

HRESULT Execute(

IDispatch* DispOrder,

IDispatch* DispContext,

long Flags,

long* ErrorLevel

);

Parameters

DispOrder

[in] Transport IDictionary object.

DispContext

[in] Not supported for this release.

Flags

[in] Reserved.

ErrorLevel

[out, retval] Reserved.

Return Values

In Visual Basic, this method returns the error level.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Microsoft BizTalk Server 2002 calls this method, passing in the transport IDictionary object. The component can read these IDictionary object values, perform the necessary functions, and optionally write new values back to the transport IDictionary object for further processing.

For a component designed to run in BizTalk Server 2002, the first parameter is a Transport Dictionary object. The Transport Dictionary values can be read by the component for processing. The string values supplied by the server for all application integration components (AICs) are defined in the Handling Data Passed to AICs topic.

For a component that runs in a Commerce Server order-processing pipeline, the first parameter contains the OrderForm object.

This method is called at run time when the server is sending a document to the component. This method is called immediately after the SetConfigData method of the IPipelineComponentAdmin interface. The document is passed in the first parameter as a dictionary within the working_data field of the IDictionary object. Components can add the ResponseField key to the IDictionary object to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface.

The component must raise an error if a problem with processing occurs so that the server can retry transmission later and, after all retries, send the document to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


IPipelineComponentAdmin

Gets and sets configuration information for a component. Use IPipelineComponentAdmin between the component and the component user interface.

Hierarchy

IDispatch

|--IPipelineComponentAdmin

Declaration

[Visual Basic]

Class IPipelineComponentAdmin

[C++]

interface IPipelineComponentAdmin : IDispatch

Members

IPipelineComponentAdmin defines the following methods:

Method | Description
GetConfigData | Returns an IDictionary object that contains the configuration data for the component to be used to display these values.
SetConfigData | The SetConfigData method sets the configuration for a component, using the contents of an IDictionary object.

Remarks

Application integration components must be properly registered so that BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topics

Application Integration Components

Pipeline Components in Visual Basic

Pipeline Components in Visual C++


GetConfigData Method

Returns an IDictionary object that contains the configuration data for the component to be used to display these values.

Member List

IPipelineComponentAdmin

|--GetConfigData

|--SetConfigData

Method Declaration

[Visual Basic]

Function GetConfigData() As Object

[C++]

HRESULT GetConfigData(

IDispatch** ConfigDictionary

);

Parameters

ConfigDictionary

[out, retval] In C++, an IDictionary object from which the user interface can read the configuration data. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method optionally returns a CDictionary object from which the user interface can read the configuration data.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

GetConfigData enables the user interface component to read the current value from the component and display it on the property page initially.

When an IBizTalkPort object is first saved, this method is called to get the defaults for use in autoconfiguring the application integration component (AIC) from the IDictionary object provided. Components must provide defaults for all mandatory properties, whenever possible.

This method is called when the user selects the property page. It is used to supply property page defaults. It is called again when the property page is closed. The contents of this returned IDictionary object are not used.

Components must always return a valid dictionary pointer from GetConfigData.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


SetConfigData Method

The SetConfigData method sets the configuration for a component, using the contents of an IDictionary object.

Member List

IPipelineComponentAdmin

|--GetConfigData

|--SetConfigData

Method Declaration

[Visual Basic]

Sub SetConfigData( _

ConfigDictionary As Object _

)

[C++]

HRESULT SetConfigData(

IDispatch* ConfigDictionary

);

Parameters

ConfigDictionary

[in] Contains an IDictionary object that contains the configuration information.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

With this method, the user interface can set or change these values. SetConfigData enables the user interface to write the updated value from the property page to the component.

The server calls SetConfigData when the property page is saved. It is used to verify the values entered by the user on the property page. The contents of this provided IDictionary object are also stored in the database.

This method is called immediately before the Execute method of the IPipelineComponent interface at run time, when the server is ready to send a document to the component. Data stored during design time from autoconfiguration or from property-page updates is passed to the component to allow for property setup prior to calling Execute.

Components validate the properties provided in SetConfigData and raise an error if any of the properties are invalid or missing.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


ISchemaImporter

Handles the importing of DTDs, XDRs, and well-formed XML documents.

Hierarchy

IDispatch

|--ISchemaImporter

Declaration

[Visual Basic]

Class ISchemaImporter

[C++]

interface ISchemaImporter : IDispatch

Members

ISchemaImporter defines the following properties:

Property | Description
ImportFormatDescription | Contains descriptive text about a supported import format.
ImportFormatIcon | Contains an icon for a supported import format.
NumberOfSupportedImportFormats | Contains the number of supported data formats from which a schema can be extracted.

ISchemaImporter defines the following method:

Method | Description
ExtractXMLSchema | Extracts a schema from a document.

Remarks

Custom XML import components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Custom XML import components register themselves with the category ID CATID_BIZTALK_IDocSpecExtension. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ExtractXMLSchema Method

Extracts a schema from a document.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Method Declaration

[Visual Basic]

Function ExtractXMLSchema( _

FormatIndex As Long, _

DocumentPath As String _

) As Object

[C++]

HRESULT ExtractXMLSchema(

long FormatIndex ,

BSTR DocumentPath ,

IDispatch** SchemaDOM

);

Parameters

FormatIndex

[in] Contains an index value that specifies the type of document from which to import the schema. Use the value 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

DocumentPath

[in] Contains the path to the document from which to import the schema.

SchemaDOM

[out, retval] In C++, contains an IDispatch interface that contains the extracted XML schema. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an Object that contains information about the extracted XML schema.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ImportFormatDescription Property

Contains descriptive text about a supported import format.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Property Declaration

[Visual Basic]

Property ImportFormatDescription( _

FormatIndex As Long _

) As String

[C++]

HRESULT get_ImportFormatDescription(

long FormatIndex ,

BSTR* Description

);

Parameters

FormatIndex

[in] Contains an index value that specifies the type of document from which to import the schema. Use the value 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

Description

[out, retval] In C++, contains a textual description of the input document format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a textual description of the input document format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ImportFormatIcon Property

Contains an icon for a supported import format.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Property Declaration

[Visual Basic]

Property ImportFormatIcon( _

FormatIndex As Long _

) As Long

[C++]

HRESULT get_ImportFormatIcon(

long FormatIndex,

long* IconID

);

Parameters

FormatIndex

[in] Contains an index value that specifies the type of document from which to import the schema. Use the value 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

IconID

[out, retval] In C++, contains the icon identifier for the input format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the icon identifier for the input format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read only-property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


NumberOfSupportedImportFormats Property

Contains the number of supported data formats from which a schema can be extracted.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Property Declaration

[Visual Basic]

Property NumberOfSupportedImportFormats As Long

[C++]

HRESULT get_NumberOfSupportedImportFormats(

long* Number

);

Parameters

Number

[out, retval] In C++, indicates the number of supported import formats. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of supported import formats.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError

Identifies and deciphers errors or warnings.

Hierarchy

IDispatch

|--ISchemaImporterError

Declaration

[Visual Basic]

Class ISchemaImporterError

[C++]

interface ISchemaImporterError : IDispatch

Members

ISchemaImporterError defines the following properties:

Property | Description
IsWarning | Contains a value that identifies the object as an error or a warning.
NodePath | Contains the path to the node that generated the error or warning.
Text | Contains the error or warning message.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


IsWarning Property

Contains a value that identifies the object as an error or a warning.

Member List

ISchemaImporterError

|--IsWarning

|--NodePath

|--Text

Property Declaration

[Visual Basic]

Property IsWarning As Boolean

[C++]

HRESULT get_IsWarning(

VARIANT_BOOL* IsWarning

);

Parameters

IsWarning

[out, retval] In C++, contains a value that indicates whether or not the object is a warning. VARIANT_TRUE indicates that this is a warning object; VARIANT_FALSE indicates that this is an error object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the object is a warning. True indicates that this is a warning object; False indicates that this is an error object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


NodePath Property

Contains the path to the node that generated the error or warning.

Member List

ISchemaImporterError

|--IsWarning

|--NodePath

|--Text

Property Declaration

[Visual Basic]

Property NodePath As String

[C++]

HRESULT get_NodePath(

BSTR* NodePath

);

Parameters

NodePath

[out, retval] In C++, contains the fully qualified name of the node that generated the error or warning. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the fully qualified name of the node that generated the error or warning.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Text Property

Contains the error or warning message.

Member List

ISchemaImporterError

|--IsWarning

|--NodePath

|--Text

Property Declaration

[Visual Basic]

Property Text As String

[C++]

HRESULT get_Text(

BSTR* errText

);

Parameters

errText

[out, retval] In C++, contains the text associated with the error or warning. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the text associated with the error or warning.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterErrorProvider

Returns errors or warnings.

Hierarchy

IDispatch

|--ISchemaImporterErrorProvider

Declaration

[Visual Basic]

Class ISchemaErrorProvider

[C++]

interface ISchemaErrorProvider : IDispatch

Members

ISchemaImporterErrorProvider defines the following properties:

Property | Description
Error | Contains the error or warning.
NumberOfErrors | Contains the number of errors or warnings.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Error Property

Contains the error or warning.

Member List

ISchemaImporterErrorProvider

|--Error

|--NumberOfErrors

Property Declaration

[Visual Basic]

Property Error( _

Index As Long _

) As ISchemaImporterError

[C++]

HRESULT get_Error(

long Index,

IschemaImporterError** Error

);

Parameters

Index

[in] Contains the index of the error or warning.

Error

[out, retval] In C++, contains an ISchemaImporterError interface that contains the error or warning. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a SchemaImporterError object that contains the error or warning.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


NumberOfErrors Property

Contains the number of errors or warnings.

Member List

ISchemaImporterErrorProvider

|--Error

|--NumberOfErrors

Property Declaration

[Visual Basic]

Property NumberOfErrors As Long

[C++]

HRESULT get_NumberOfErrors(

long* NumberOfErrors

);

Parameters

NumberOfErrors

[out, retval] In C++, indicates the number of errors. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of errors.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Enumerations

The following enumerations provide possible property and parameter values:

  • CONNECTION_TYPE

  • DTA_ACK_STATUS

  • FUNC_CATEGORY

  • FUNC_TYPE

  • GeneratedReceiptLevel

  • SCRIPT_CATEGORY


CONNECTION_TYPE

Specifies the connection type.

[Visual Basic]

Enum CONNECTION_TYPE

[C++]

enum CONNECTION_TYPE

Members

CONNECT_TYPE_NONE

[0] The connection type is none.

CONNECT_TYPE_FIELD

[1] The connection type is field.

CONNECT_TYPE_RECORD

[2] The connection type is record.

CONNECT_TYPE_RECORD_CONTENT

[4] The connection type is record content.

CONNECT_TYPE_FUNC_STRING

[8] The connection type function is string.

CONNECT_TYPE_FUNC_MATH

[16] The connection type function is mathematical.

CONNECT_TYPE_FUNC_DATACONV

[32] The connection type function is data conversion.

CONNECT_TYPE_FUNC_DATETIME_FMT

[64] The connection type function is date/time format.

CONNECT_TYPE_FUNC_SCIENTIFIC

[128] The connection type function is scientific.

CONNECT_TYPE_FUNC_BOOLEAN

[256] The connection type function is Boolean.

CONNECT_TYPE_FUNC_SCRIPTER

[1024] The connection type function is script.

CONNECT_TYPE_FUNC_COUNT

[2048] The connection type function is count.

CONNECT_TYPE_FUNC_INDEX

[2048] The connection type function is index.

CONNECT_TYPE_FUNC_CUMULATIVE

[4096] The connection type function is cumulative.

CONNECT_TYPE_FUNC_VALUE_MAPPING

[8192] The connection type function is value mapping.

CONNECT_TYPE_FUNC_LOOPING

[16384] The connection type function is looping.

CONNECT_TYPE_FUNC_ITERATION

[32768] The connection type function is iteration.

CONNECT_TYPE_FUNC_DBLOOKUP

[65536] The connection type function is database lookup.

CONNECT_TYPE_FUNC_DBEXTRACT

[131072] The connection type function is database extraction.

CONNECT_TYPE_ALL

[-1] The connection type includes all connection types.

CONNECT_TYPE_ALL_EXCEPT_RECORD

[-3] The connection type includes all connection types except records.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionParameter


DTA_ACK_STATUS

Indicates the acknowledgement status.

[Visual Basic]

Enum DTA_ACK_STATUS

[C++]

enum DTA_ACK_STATUS

Members

DTA_ACK_NONE

[0] No receipt is expected.

DTA_ACK_PENDING

[1] The receipt is expected but has not yet arrived.

DTA_ACK_OVERDUE

[2] The receipt has timed out.

DTA_ACK_ACCEPTED

[3] The receipt has arrived with a status of accepted.

DTA_ACK_PARTIALLY_ACCEPTED

[4] The receipt has arrived with a status of accepted with errors.

DTA_ACK_REJECTED

[5] The receipt has arrived with a status of rejected.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

AckDocument

AckGroup

AckInterchange


FUNC_CATEGORY

Defines the values to specify the functoid palette on which the custom functoid will appear.

[Visual Basic]

Enum FUNC_CATEGORY

[C++]

enum FUNC_CATEGORY

Members

FUNC_CATEGORY_STRING

[3] The function category is string.

FUNC_CATEGORY_MATH

[4] The function category is mathematical.

FUNC_CATEGORY_DATACONV

[5] The function category is data conversion.

FUNC_CATEGORY_DATETIME_FMT

[6] The function category is date/time format.

FUNC_CATEGORY_SCIENTIFIC

[7] The function category is scientific.

FUNC_CATEGORY_BOOLEAN

[8] The function category is Boolean.

FUNC_CATEGORY_SCRIPTER

[9] The function category is script.

FUNC_CATEGORY_COUNT

[10] The function category is count. This value is not supported for this release.

FUNC_CATEGORY_INDEX

[11] The function category is index.

FUNC_CATEGORY_CUMULATIVE

[12] The function category is cumulative.

FUNC_CATEGORY_VALUE_MAPPING

[13] The function category is value mapping. This value is not supported for this release.

FUNC_CATEGORY_LOOPING

[14] The function category is looping. This value is not supported for this release.

FUNC_CATEGORY_ITERATION

[15] The function category is iteration. This value is not supported for this release.

FUNC_CATEGORY_DBLOOKUP

[16] The function category is database lookup. It is not recommended to add custom functoids to the Database tab on the functoid palette. See the note following this table for information on adding functoids to the Advanced tab.

FUNC_CATEGORY_DBEXTRACT

[17] The function category is database extraction. It is not recommended to add custom functoids to the Database tab on the functoid palette. See the note following this table for information on adding functoids to the Advanced tab.

FUNC_CATEGORY_UNKNOWN

[31] The function category is unknown.

Remarks

Custom functoids using a category value between 18 and 31 appear on the Advanced tab in the functoid palette.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionDescripter


FUNC_TYPE

Specifies the function type.

[Visual Basic]

Enum FUNC_TYPE

[C++]

enum FUNC_TYPE

Members

FUNC_TYPE_STD

[1] The function type is standard.

FUNC_TYPE_VARIABLEINPUT

[2] The function type is variable input.

FUNC_TYPE_SCRIPTOR

[3] The function type is script.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionDescripter


GeneratedReceiptLevel

Specifies the generated receipt level.

This enumeration is only supported in C++.

enum GeneratedReceiptLevel

Members

NoReceiptGenerated

[0] No receipt is created.

DocReceiptGenerated

[1] A receipt is generated for each document.

GroupReceiptGenerated

[2] A receipt is generated for each group.

InterchangeReceiptGenerated

[3] A receipt is generated for each interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

GetNextDocument


SCRIPT_CATEGORY

Specifies the script category.

[Visual Basic]

Enum SCRIPT_CATEGORY

[C++]

enum SCRIPT_CATEGORY

Members

SCRIPT_CATEGORY_VBSCRIPT

[0] The custom functoid function is written in the Microsoft Visual Basic Scripting Edition (VBScript) language.

SCRIPT_CATEGORY_JSCRIPT

[1] The custom functoid function is written in the Microsoft JScript language.

SCRIPT_CATEGORY_XSLSCRIPT

[2] The custom functoid function is written in the Extensible Stylesheet Language (XSL). This value is not supported for this release.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionDescripter


Orchestration Services Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, and properties exposed for accessing orchestration services:

  • Interfaces

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented:

  • IWFGroupAdmin

  • IWFProxy

  • IWFSystemAdmin

  • IWFWorkflowInstance


IWFGroupAdmin

Allows a client application to control running instances of an XLANG schedule. Use IWFGroupAdmin to stop, suspend, resume, and retrieve information about all the schedule instances associated with a group manager.

Hierarchy

IDispatch

|--IWFGroupAdmin

Declaration

[Visual Basic]

Class IWFGroupAdmin

[C++]

interface IWFGroupAdmin : IDispatch

Members

IWFGroupAdmin defines the following properties:

Property | Description
Count | Contains the number of running XLANG schedule instances associated with this group manager.
FullyQualifiedName | Contains the moniker of this group manager.
InstanceIsResident | Contains a value that indicates whether the specified XLANG schedule instance is currently resident in memory.
InstanceIsSuspended | Contains a value that indicates whether the specified XLANG schedule instance is currently in a suspended state.
Name | Contains the name of this group manager.
UseFileDSN | Contains a value that indicates whether a Data Source Name (DSN) file is used for dehydrating the XLANG schedule instances.

IWFGroupAdmin defines the following methods:

Method | Description
ResumeInstance | Resumes the execution of an XLANG schedule instance in a suspended state.
Shutdown | Stops the group manager and dehydrates all running XLANG schedule instances.
Startup | Starts all the dehydrated XLANG schedule instances for the current group manager.
SuspendInstance | Pauses the running XLANG schedule instance in its current state.
TerminateInstance | Stops execution of the running XLANG schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Accessing Group Managers

XLANG Interfaces


Count Property

Contains the number of running XLANG schedule instances associated with this group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] In C++, contains the number of running schedule instances associated with this group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of running schedule instances associated with this group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


FullyQualifiedName Property

Contains the moniker of this group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] In C++, contains the moniker of this group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of this group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Although a group manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the default XLANG Scheduler Group Manager, named XLANG Scheduler, is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com!XLANG Scheduler.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Moniker Syntax


InstanceIsResident Property

Contains a value that indicates whether the specified XLANG schedule instance is currently resident in memory.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property InstanceIsResident( _

InstanceId As String _

) As Boolean

[C++]

HRESULT get_InstanceIsResident(

BSTR InstanceId,

VARIANT_BOOL* IsResident

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance.

IsResident

[out, retval] In C++, contains a value that indicates whether or not the specified schedule instance is currently resident in memory. VARIANT_TRUE indicates that the specified schedule instance is currently resident in memory; VARIANT_FALSE indicates that the specified schedule instance is not currently resident in memory. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the specified schedule instance is currently resident in memory. True indicates that the specified schedule instance is currently resident in memory; False indicates that the specified schedule instance is not currently resident in memory.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


InstanceIsSuspended Property

Contains a value that indicates whether the specified XLANG schedule instance is currently in a suspended state.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property InstanceIsSuspended( _

InstanceId As String _

) As Boolean

[C++]

HRESULT get_InstanceIsSuspended(

BSTR InstanceId,

VARIANT_BOOL* IsSuspended

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance.

IsSuspended

[out, retval] In C++, contains a value that indicates whether or not the specified schedule instance is currently in a suspended state. VARIANT_TRUE indicates that the specified schedule instance is currently in a suspended state; VARIANT_FALSE indicates that the specified schedule instance is not currently in a suspended state. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the specified schedule instance is currently in a suspended state. VARIANT_TRUE indicates that the specified schedule instance is currently in a suspended state; VARIANT_FALSE indicates that the specified schedule instance is not currently in a suspended state.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

This property should be checked prior to calling the ResumeInstance method.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Name Property

Contains the name of this group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Name As String

[C++]

HRESULT get_Name(

BSTR* Name

);

[
Parameters

Name

[out, retval] In C++, contains the name of this group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of this group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

This property is the same as the name of the hosting COM+ application.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ResumeInstance Method

Resumes the execution of an XLANG schedule instance in a suspended state.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub ResumeInstance( _

InstanceId As String _

)

[C++]

HRESULT ResumeInstance(

BSTR InstanceId

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance to be resumed.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The schedule instance can be paused with the SuspendInstance method. Prior to calling the ResumeInstance method, the InstanceIsSuspended property should be checked.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Shutdown Method

Stops the group manager and dehydrates all running XLANG schedule instances.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub Shutdown( )

[C++]

HRESULT Shutdown( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Prior to stopping the group manager, all running schedule instances associated with this group manager are dehydrated to the database specified in the Data Source Name (DSN) file, and requests for activation of any new schedule instances are refused until shutdown is completed.

Any component that is bound in an XLANG schedule should not invoke this method to stop the group manager, as this can produce unexpected results.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Startup Method

Starts all the dehydrated XLANG schedule instances for the current group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub Startup( )

[C++]

HRESULT Startup( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The XLANG Scheduler System Manager normally calls this method. Users should not call this method directly.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


SuspendInstance Method

Pauses the running XLANG schedule instance in its current state.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub SuspendInstance( _

InstanceId As String _

)

[C++]

HRESULT SuspendInstance(

BSTR InstanceId

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance to be suspended.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The schedule instance can be restarted with the ResumeInstance method.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


TerminateInstance Method

Stops execution of the running XLANG schedule instance.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub TerminateInstance( _

InstanceId As String _

)

[C++]

HRESULT TerminateInstance(

BSTR InstanceId

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance to be stopped.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

A terminated schedule instance can never be restarted or resumed.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


UseFileDSN Property

Contains a value that indicates whether a Data Source Name (DSN) file is used for dehydrating the XLANG schedule instances.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property UseFileDSN As Boolean

[C++]

HRESULT get_UseFileDSN(

VARIANT_BOOL* UseFileDSN

);

Parameters

UseFileDSN

[out, retval] In C++, contains a value that indicates whether or not the group manager uses a DSN file for dehydrating schedule instances. VARIANT_TRUE indicates that the group manager uses a DSN file for dehydrating schedule instances; VARIANT_FALSE indicates that the group manager does not use a DSN file for dehydrating schedule instances. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the group manager uses a DSN file for dehydrating schedule instances. True indicates that the group manager uses a DSN file for dehydrating schedule instances; False indicates that the group manager does not use a DSN file for dehydrating schedule instances.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The value of this property is set when the group manager process is launched. The DSN setting in the COM+ catalog is changed either on the XLANG tab of the XLANG Scheduler Properties dialog box or by setting the UseFileDSN property on the IWFSystemAdmin interface. If the DSN value is changed while the group manager is running, the value of this property is not dynamically updated. The new value is not reflected until the next time the group manager is launched. Updates to this property require the caller to be in the XLANG Administrator role and are not normally performed by user code.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFProxy

Contains information about ports in an XLANG schedule instance that are bound to a COM component.

Hierarchy

IDispatch

|--IWFProxy

Declaration

[Visual Basic]

Class IWFProxy

[C++]

interface IWFProxy : IDispatch

Members

IWFProxy defines the following properties:

Property | Description
FullyQualifiedName | Contains the fully qualified name of a COM-bound port.
WorkflowInstance | Contains a reference to the current XLANG schedule instance.

Remarks

Use IWFProxy to obtain a schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Activating an XLANG Schedule Instance


FullyQualifiedName Property

Contains the fully qualified name of a COM-bound port.

Member List

IWFProxy

|--FullyQualifiedName

|--WorkflowInstance

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] Contains the moniker of the port. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of the port.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The moniker retrieved with this property can be used with the COM GetObject function to obtain a reference to the XLANG schedule instance. This moniker is valid as long as the schedule instance is running. If the schedule instance is dehydrated and rehydrated for any reason, such as rebooting the system, the moniker remains valid. Once the schedule instance completes, or ends by using the TerminateInstance method, the moniker can no longer be used.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


WorkflowInstance Property

Contains a reference to the current XLANG schedule instance.

Member List

IWFProxy

|--FullyQualifiedName

|--WorkflowInstance

Property Declaration

[Visual Basic]

Property WorkflowInstance As IWFWorkflowInstance

[C++]

HRESULT get_WorkflowInstance(

IWFWorkflowInstance** ScheduleInstance

);

Parameters

ScheduleInstance

[out, retval] Contains an IWFWorkflowInstance object that contains the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns an IWFWorkflowInstance object that contains the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFSystemAdmin

Provides a client application with system-wide administrative control over the XLANG Scheduler Engine.

Hierarchy

IDispatch

|--IWFSystemAdmin

Declaration

[Visual Basic]

Class SysMgr

[C++]

interface IWFSystemAdmin : IDispatch

Members

IWFSystemAdmin defines the following properties:

Property | Description
Count | Contains the number of group managers associated with this XLANG Scheduler System Manager.
FullyQualifiedName | Contains the fully qualified DNS-style name of the XLANG Scheduler System Manager.
IsWorkflowHost | Contains a value that indicates whether the COM+ server application is an XLANG Scheduler Engine host.
Item | Contains a reference to the named schedule group.
UseFileDSN | Contains a value that indicates whether a COM+ server application uses a Data Source Name (DSN) file for dehydrating the XLANG schedule instances.

IWFSystemAdmin defines the following methods:

Method | Description
ShutdownAll | Stops the group managers and terminates their associated COM+ applications.
ShutdownApp | Stops a specific group manager application and terminates the associated COM+ application.
Startup | Starts all group managers.
TestAdminStatus | Determines whether a caller on IWFGroupAdmin is an XLANG Scheduler Engine administrator.

Remarks

Use IWFSystemAdmin to start, stop, and retrieve information about the group managers.

All XLANG Scheduler System Manager objects must have an associated Data Source Name (DSN) to support the dehydration and rehydration of long-running business processes. Therefore, you must create a DSN for the XLANG Scheduler System Manager by using the ODBC Data Source Administrator. XLANG schedules run by an XLANG Scheduler System Manager without a DSN configured will generate an error. For more information about creating a DSN, see Change the DSN settings for a COM+ application.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)

Related Topics

Accessing the XLANG Scheduler System Manager

XLANG Interfaces


Count Property

Contains the number of group managers associated with this XLANG Scheduler System Manager.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] Contains the number of running group managers. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of running group managers.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


FullyQualifiedName Property

Contains the fully qualified DNS-style name of the XLANG Scheduler System Manager.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] Contains the moniker of this XLANG Scheduler System Manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of this XLANG Scheduler System Manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Although an XLANG Scheduler System Manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the XLANG Scheduler System Manager is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)

Related Topics

Moniker Syntax


IsWorkflowHost Property

Contains a value that indicates whether the COM+ server application is an XLANG Scheduler Engine host.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property IsWorkflowHost( _

AppName As String _

) As Boolean

[C++]

HRESULT get_IsWorkflowHost(

BSTR AppName,

VARIANT_BOOL* IsWorkflowHost

);

HRESULT put_IsWorkflowHost(

BSTR AppName,

VARIANT_BOOL IsWorkflowHost

);

Parameters

AppName

[in] Contains the COM+ server application name.

IsWorkflowHost

[out, retval], [in] In C++, contains a value that indicates whether or not the COM+ server application is hosting the XLANG Scheduler Engine. VARIANT_TRUE indicates that the COM+ server application is hosting the XLANG Scheduler Engine; VARIANT_FALSE indicates that the COM+ server application is not hosting the XLANG Scheduler Engine. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the COM+ server application is hosting the XLANG Scheduler Engine. True indicates that the COM+ server application is hosting the XLANG Scheduler Engine; False indicates that the COM+ server application is not hosting the XLANG Scheduler Engine.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property cannot be set on the XLANG Scheduler Engine application, or on any COM+ application marked as read-only.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


Item Property

Contains a reference to the named schedule group.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Item( _

GrpMgrName As String _

) As Unknown

[C++]

HRESULT get_Item(

BSTR GrpMgrName,

IUnknown** Item

);

Parameters

GrpMgrName

[in] Contains the group name corresponding to the hosting COM+ server application name. Group names are case sensitive and can contain spaces.

Item

[out, retval] Contains an object that refers to a group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns an object that refers to a group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


ShutdownAll Method

Stops the group managers and terminates their associated COM+ applications.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub ShutdownAll( )

[C++]

HRESULT ShutdownAll( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When the ShutdownAll method is called, new schedule activations are disabled and the shutdown notice is propagated to all running group managers. Once this method has completed, all group managers are stopped and the system can be safely rebooted.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


ShutdownApp Method

Stops a specific group manager application and terminates the associated COM+ application.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub ShutdownApp( _

AppName As String _

)

[C++]

HRESULT ShutdownApp(

BSTR AppName

);

Parameters

AppName

[in] Contains the COM+ server application name to be stopped.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When the ShutdownApp method is called, new schedule activations on the named application are disabled and all running XLANG schedule instances associated with that application are stopped. If this method is called on the default XLANG Scheduler Group Manager, all group managers are shut down. Calling this method on the default XLANG Scheduler Group Manager is equivalent to calling the ShutdownAll method.

Note

  • The COM+ application name of the default XLANG Scheduler Group Manager is XLANG Scheduler.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


StartUp Method

Starts all group managers.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub StartUp( )

[C++]

HRESULT StartUp( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When this method is invoked, rehydration is initiated for all group managers and, subsequently, all XLANG schedules. This method is asynchronous, and it can complete before all group managers and schedules are running.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


TestAdminStatus Method

Determines whether a caller on IWFSystemAdmin is an XLANG Scheduler Engine administrator.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub TestAdminStatus( )

[C++]

HRESULT TestAdminStatus( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is intended for internal use by the group managers.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


UseFileDSN Property

Contains a value that indicates whether a COM+ server application uses a Data Source Name (DSN) file for dehydrating the XLANG schedule instances.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property UseFileDSN( _

AppName As String _

) As Boolean

[C++]

HRESULT get_UseFileDSN(

BSTR AppName,

VARIANT_BOOL* UseFileDSN

);

HRESULT put_UseFileDSN(

BSTR AppName,

VARIANT_BOOL* UseFileDSN

);

Parameters

AppName

[in] Contains the COM+ server application name.

UseFileDSN

[out, retval], [in] In C++, contains a value that indicates whether or not the COM+ server application uses a DSN file for dehydrating schedule instances. VARIANT_TRUE indicates that the COM+ server application uses a DSN file for dehydrating schedule instances; VARIANT_FALSE indicates that the COM+ server application does not use a DSN file for dehydrating schedule instances. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the COM+ server application uses a DSN file for dehydrating schedule instances. True indicates that the COM+ server application uses a DSN file for dehydrating schedule instances; False indicates that the COM+ server application does not use a DSN file for dehydrating schedule instances.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If this property is changed while any group manager is running, the value of this property is not dynamically updated in the group managers. Therefore, the UseFileDSN property value exposed by IWFGroupAdmin contains an incorrect value. The updated value is not reflected until the next time the group manager is launched.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFWorkflowInstance

Allows a client application to navigate the ports of an XLANG schedule instance, check the completion status, and determine whether the schedule instance completed successfully.

Hierarchy

IDispatch

|--IWFWorkflowInstance

Declaration

[Visual Basic]

Class IWFWorkflowInstance

[C++]

interface IWFWorkflowInstance : IDispatch

Members

IWFWorkflowInstance defines the following properties:

Property | Description
CompletionStatus | Contains a value that indicates the success or failure of the XLANG schedule instance.
FullPortName | Contains the full name of a port in a form usable by the associated technology.
FullyQualifiedName | Contains the fully qualified name of this XLANG schedule instance.
InstanceId | Contains the globally unique identifier (GUID) assigned to the current XLANG schedule instance.
IsCompleted | Contains a value that indicates whether the XLANG schedule instance has finished executing.
ModuleId | Contains the globally unique identifier (GUID) of the XML module associated with the current XLANG schedule instance.
ModuleName | Contains the name of the XML module associated with the current XLANG schedule instance.
ParentInstanceID | Contains the globally unique identifier (GUID) assigned to the parent XLANG schedule instance of the current schedule instance.
Port | Contains a reference to the named port. This is applicable only to COM-based port bindings.

IWFWorkflowInstance defines the following method:

Method | Description
WaitForCompletion | Waits until the current XLANG schedule instance completes executing.

Remarks

Use IWFWorkflowInstance to gather information about a specific, running schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Accessing a Running XLANG Schedule Instance

XLANG Interfaces


CompletionStatus Property

Contains a value that indicates the success or failure of the XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property CompletionStatus As Long

[C++]

HRESULT get_CompletionStatus(

long* CompletionStatus

);

Parameters

CompletionStatus

[out, retval] Contains the completion status of the schedule instance. A value of 0 indicates success. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the completion status of the schedule instance. A value of 0 indicates success.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • A return value of S_OK does not indicate that the processes or applications associated with the schedule instance completed successfully. It indicates only that the schedule instance was completely processed by the XLANG Scheduler Engine, without errors.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


FullPortName Property

Contains the full name of a port in a form usable by the associated technology.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property FullPortName( _

Port As String _

) As String

[C++]

HRESULT get_FullPortName(

BSTR Port,

BSTR* FullPortName

);

Parameters

Port

[in] Contains the name of the port to be retrieved.

FullPortName

[out, retval] Contains the full port name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the full port name.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The full port name is returned in a form that is usable by the associated binding technology. For example, a port that is bound to a COM component returns a fully qualified moniker as the name of the port. For a port that is bound to Microsoft Message Queuing, this method returns the full path of the queue.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


FullyQualifiedName Property

Contains the fully qualified name of this XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] Contains the moniker of the schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of the schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


InstanceId Property

Contains the globally unique identifier (GUID) assigned to the current XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property InstanceId As String

[C++]

HRESULT get_InstanceId(

BSTR* InstanceId

);

Parameters

InstanceId

[out, retval] Contains the GUID of the schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the GUID of the schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


IsCompleted Property

Contains a value that indicates whether the XLANG schedule instance has finished executing.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property IsCompleted As Boolean

[C++]

HRESULT get_IsCompleted(

VARIANT_BOOL* IsCompleted

);

Parameters

IsCompleted

[out, retval], In C++, contains a value that indicates whether or not the schedule instance has finished executing. VARIANT_TRUE indicates that the schedule instance has finished executing; VARIANT_FALSE indicates the schedule instance has not finished executing. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the schedule instance has finished executing. True indicates that the schedule instance has finished executing; False indicates the schedule instance has not finished executing.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ModuleId Property

Contains the globally unique identifier (GUID) of the XML module associated with the current XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property ModuleId As String

[C++]

HRESULT get_ModuleId(

BSTR* ModuleId

);

Parameters

ModuleId

[out, retval] Contains the GUID of the XLANG module associated with the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the GUID of the XLANG module associated with the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ModuleName Property

Contains the name of the XML module associated with the current XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property ModuleName As String

[C++]

HRESULT get_ModuleName(

BSTR* ModuleName

);

Parameters

ModuleName

[out, retval] Contains the name of the XLANG module associated with the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the XLANG module associated with the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The module name is defined in the XLANG schedule (.skx) file.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ParentInstanceID Property

Contains the globally unique identifier (GUID) assigned to the parent XLANG schedule instance of the current schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property ParentInstanceID As String

[C++]

HRESULT get_ParentInstanceID(

BSTR* ParentInstanceID

);

Parameters

ParentInstanceID

[out, retval] Contains the GUID of the parent schedule instance of the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the GUID of the parent schedule instance of the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

In C++, the property returns a NULL value if no parent schedule instance exists.

In Visual Basic, the property returns a Nothing value if no parent schedule instance exists.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Port Property

Contains a reference to the named port. This is applicable only to COM-based port bindings.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property Port( _

Port As String _

) As Unknown

[C++]

HRESULT get_Port(

BSTR Port,

IUnknown** PortReference

);

Parameters

Port

[in] Contains the name of the port to which to obtain a reference.

PortReference

[out, retval] Contains a reference to a port in the current XLANG schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a reference to a port in the current XLANG schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The MK_E_NOOBJECT error code is returned if the moniker or port name passed in the Port parameter is incorrect.

In Visual Basic, the variable used for the port reference returned by using this property should be declared as a specific class or as a Variant. You can't obtain the port reference if you declare the variable as an Object since the port actually returns an IUnknown reference.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


WaitForCompletion Method

Waits until the current XLANG schedule instance completes executing.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Method Declaration

[Visual Basic]

Sub WaitForCompletion( )

[C++]

HRESULT WaitForCompletion( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Managing and Monitoring Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for working with managing and monitoring BizTalk Server:

  • WMI Classes

In addition, a complete list of Error Messages is provided.


WMI Classes

The following COM interfaces are documented:

  • DocSuspendedEvent

  • InterchangeProvError

  • MicrosoftBizTalkServer_Group

  • MicrosoftBizTalkServer_GroupReceiveFunction

  • MicrosoftBizTalkServer_GroupServer

  • MicrosoftBizTalkServer_MgmtDB

  • MicrosoftBizTalkServer_Queue

  • MicrosoftBizTalkServer_ReceiveFunction

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_Server

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

  • MSBTS_CustomCounter

  • MSBTS_CustomCounterSetting

  • ReceiveFunctionDisabledEvent


DocSuspendedEvent

Represents events raised by documents sent to the Suspended queue.

Hierarchy

__ExtrinsicEvent

|--DocSuspendedEvent

Declaration

[Visual Basic]

Class DocSuspendedEvent

[C++]

class DocSuspendedEvent : __ExtrinsicEvent

Members

DocSuspendedEvent defines the following properties:

Property | Description
ChannelHandle | Contains the handle of the channel through which the suspended document was to be processed.
Destination | Contains the name of the destination organization to which the suspended document was to be processed.
DocName | Contains the name of the document definition designated as the input or output document for the channel through which the suspended document was to be processed.
PortHandle | Contains the handle of the messaging port attached to the channel through which the suspended document was to be processed.
Reason | Contains a value that indicates why the document was placed in the Suspended queue.
Source | Contains the name of the source organization from which the suspended document was to be processed.
State | Contains a value that indicates the state of the suspended document.
stringSuspendedGuid | Contains the tracking key of the item in the Suspended queue event.

Remarks

DocSuspendedEvent inherits from the __ExtrinsicEvent system class, an abstract base class that serves as a superclass for all user-defined event types.

The purpose of this event is to raise a notification when a document is delivered to the suspended queue because of a server processing error.

In the event that an administrator intentionally moves a document to the suspended queue using one of the following methods, a document suspended event will not be raised:

  • MoveToSuspendedQueue

  • MoveToSuspendedQueue

  • MoveToSuspendedQueue

Requirements

Windows NT/ Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ChannelHandle Property

Contains the handle of the channel through which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ChannelHandle;

Parameters

None

Return Values

Returns the handle of the channel through which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Destination Property

Contains the name of the destination organization to which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Destination;

Parameters

None

Return Values

Returns the name of the destination organization to which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocName Property

Contains the name of the document definition designated as the input or output document for the channel through which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocName;

Parameters

None

Return Values

Returns the name of the document definition designated as the input or output document for the channel through which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PortHandle Property

Contains the handle of the messaging port attached to the channel through which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 PortHandle;

Parameters

None

Return Values

Returns the handle of the messaging port attached to the channel through which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Reason Property

Contains a value that indicates why the document was placed in the Suspended queue.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 Reason;

Parameters

None

Return Values

Returns a value that indicates why the document was placed in the Suspended queue. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value for this property corresponds to the Suspended queue Error Description column in BizTalk Server Administration. BizTalk Server Administration translates this value into an error string. For more information, see Suspended Queue.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Source Property

Contains the name of the source organization from which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Source;

Parameters

None

Return Values

Returns the name of the source organization from which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


State Property

Contains a value that indicates the state of the suspended document.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 State;

Parameters

None

Return Values

Returns a value that indicates the state of the suspended document. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The tables in this section show the possible processing states of a document or interchange in the Suspended queue.

Documents in the states listed in the following table are at the interchange level, so you should use the ViewInterchange method to view the data. In addition, interchanges in these states cannot be resubmitted, so in this case you should not call Resubmit.

Value | State
0 | Initial
1 | Custom component
2 | Parsing

Documents in the states listed in the following table are considered documents instead of interchanges, so you should use the ViewDocument method to view the data. In addition, documents in the document validation state (3) cannot be resubmitted, so for those documents you should not call Resubmit.

Value | State
3 | Document validation
4 | Channel selection
5 | Field tracking
6 | Correlating
7 | Mapping
8 | Serializing

Documents in the states listed in the following table are considered interchanges, so you should use the ViewInterchange method to view the data.

Value | State
9 | Encoding
10 | Signing
11 | Encrypting
12 | Transmitting

Note that the ViewErrorDescription method can be used to retrieve error description information about failed documents and interchanges.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


stringSuspendedGuid Property

Contains the tracking key of the item in the Suspended queue event.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string stringSuspendedGuid;

Parameters

None

Return Values

Returns the tracking key of the item in the Suspended queue event. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The tracking key of the item in the Suspended queue event is based on a GUID.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


InterchangeProvError

Represents error information returned by the interchange provider when creating class instances.

Hierarchy

__ExtendedStatus

|--InterchangeProvError

Declaration

[Visual Basic]

Class InterchangeProvError

[C++]

class InterchangeProvError : __ExtendedStatus

Members

InterchangeProvError defines the following property:

Property | Description
InterchangeProvName | Contains the name of the interchange provider returning error information.

Remarks

InterchangeProvError inherits from the __ExtendedStatus system class, which is used to report detailed status and error information.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


InterchangeProvName Property

Contains the name of the interchange provider returning error information.

Member List

InterchangeProvError

|--InterchangeProvName

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string InterchangeProvName;

Parameters

None

Return Values

Returns the name of the interchange provider returning error information.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_Group

Represents a logical grouping of a specific number of BizTalk Servers in an enterprise. It is the management abstraction for global BizTalk Server properties.

Hierarchy

MicrosoftBizTalkServer_Group

Declaration

[Visual Basic]

Class Group

[C++]

class MicrosoftBizTalkServer_Group

Members

MicrosoftBizTalkServer_Group defines the following properties:

Property | Description
ConfigurationCacheRefreshInterval | Contains a value that indicates how often the server refreshes the cache of the BizTalk Messaging Configuration objects, in seconds.
ConnectToDbStatus | Contains a value that indicates the status of the connection to the Tracking and Shared Queue databases.
DateModified | Contains a value that indicates the last modification date of the instance data.
DocTrackDbName | Contains the database name component of the connect string for the Tracking database.
DocTrackDbServer | Contains the server name component of the connect string for the Tracking database.
EnableDocumentTracking | Contains a value that indicates whether document tracking is enabled or disabled.
LoggingPointState | Contains a collection of flags that indicate the events that cause a Tracking entry to be logged.
Name | Contains the name of the server.
ParserOrder | Contains the CLSIDs of the parser components registered in the registry, sorted in parsing order.
ProxyHost | Contains the proxy host address.
ProxyLogon | Contains the proxy logon.
ProxyPassword | Contains the proxy password.
ProxyPort | Contains a value that indicates the proxy port number.
QueueDbName | Contains the database name component of the connect string for the Shared Queue database.
QueueDbServer | Contains the server name component of the connect string for the Shared Queue database.
ReliableMessagingReplyToURL | Contains the URL repository for reliable messaging.
RetryQueueCount | Contains a value that indicates the number of documents in the Retry queue.
ScheduledQueueCount | Contains a value that indicates the number of documents in the Scheduled queue.
SMTPHost | Contains the name of the Simple Mail Transfer Protocol (SMTP) host that is used for this group.
SuspendedQueueCount | Contains a value that indicates the number of documents in the Suspended queue.
UseProxyServer | Contains a value that indicates whether to use the proxy server.
WorkQueueCount | Contains a value that indicates the number of documents in the Work queue.

MicrosoftBizTalkServer_Group defines the following methods:

Method | Description
PurgeSuspendedQueue | Enables an administrator to remove all the documents in the Suspended queue.
RefreshParserListFromRegistry | Updates the list of parser components in the database, based on current components registered in the registry.

Remarks

MicrosoftBizTalkServer_Group is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ConfigurationCacheRefreshInterval Property

Contains a value that indicates how often the server refreshes the cache of the BizTalk Messaging Configuration objects, in seconds.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ConfigurationCacheRefreshInterval = 50;

Parameters

None

Return Values

Returns how often the server refreshes the cache of the BizTalk Messaging Configuration objects, in seconds.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

This property has a default value of 50.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ConnectToDbStatus Property

Contains a value that indicates the status of the connection to the Tracking and Shared Queue databases.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ConnectToDbStatus;

Parameters

None

Return Values

Returns the status of the connection to the Tracking and Shared Queue databases. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Permissible values for this property are "BothDbConnectOK", "DTAConnectFail", "SQConnectFail", and "BothConnectFail", which map to the integers 0, 1, 2, and 3, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the mapping:

Values {"BothDbConnectOK", "DTAConnectFail", "SQConnectFail",

"BothConnectFail"},

ValueMap{"0", "1", "2", "3"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DateModified Property

Contains a value that indicates the last modification date of the instance data.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime DateModified;

Parameters

None

Return Values

Returns the last modification date of the instance data.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocTrackDbName Property

Contains the database name component of the connect string for the Tracking database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocTrackDbName;

Parameters

None

Return Values

Returns the database name component of the connect string for the Tracking database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 123 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocTrackDbServer Property

Contains the server name component of the connect string for the Tracking database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocTrackDbServer;

Parameters

None

Return Values

Returns the server name component of the connect string for the Tracking database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 60 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


EnableDocumentTracking Property

Contains a value that indicates whether document tracking is enabled or disabled.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean EnableDocumentTracking = 1;

Parameters

None

Return Values

Returns a language-specific value representing true if document tracking is enabled; if data tracking is not enabled, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing true.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


LoggingPointState Property

Contains a collection of flags that indicate the events that cause a Tracking entry to be logged.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 LoggingPointState;

Parameters

None

Return Values

Returns a collection of flags that indicate the events that cause a Tracking entry to be logged. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "LogIncomingInterchange", "LogMIMEBlob", and "LogOutgoingInterchange", which map to the integers 0, 1, and 2, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the mapping:

Values{"LogIncomingInterchange", "LogMIMEBlob",

"LogOutgoingInterchange" },

BitMap{"0", "1", "2"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the server.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ParserOrder Property

Contains the CLSIDs of the parser components registered in the registry, sorted in parsing order.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ParserOrder[];

Parameters

None

Return Values

Returns the CLSIDs of the parser components registered in the registry, sorted in parsing order.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyHost Property

Contains the proxy host address.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProxyHost;

Parameters

None

Return Values

Returns the proxy host address.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyLogon Property

Contains the proxy logon.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProxyLogon;

Parameters

None

Return Values

Returns the proxy logon.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyPassword Property

Contains the proxy password.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProxyPassword;

Parameters

None

Return Values

Returns the proxy password.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-only. Due to security considerations, when you try to read this property, NULL is returned instead of the password value.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyPort Property

Contains a value that indicates the proxy port number.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ProxyPort = 80;

Parameters

None

Return Values

Returns the proxy port number.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 80.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PurgeSuspendedQueue Method

Enables an administrator to remove all the documents in the Suspended queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 PurgeSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QueueDbName Property

Contains the database name component of the connect string for the Shared Queue database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string QueueDbName;

Parameters

None

Return Values

Returns the database name component of the connect string for the Shared Queue database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 123 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QueueDbServer Property

Contains the server name component of the connect string for the Shared Queue database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string QueueDbServer;

Parameters

None

Return Values

Returns the server name component of the connect string for the Shared Queue database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 60 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RefreshParserListFromRegistry Method

Updates the list of parser components in the database, based on current components registered in the registry.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 RefreshParserListFromRegistry();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ReliableMessagingReplyToURL Property

Contains the URL repository for reliable messaging.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ReliableMessagingReplyToURL;

Parameters

None

Return Values

Returns the URL repository for reliable messaging.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 512 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RetryQueueCount Property

Contains a value that indicates the number of documents in the Retry queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 RetryQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Retry queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ScheduledQueueCount Property

Contains a value that indicates the number of documents in the Scheduled queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ScheduledQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Scheduled queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SMTPHost Property

Contains the name of the SMTP host that is used for this group.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SMTPHost;

Parameters

None

Return Values

Returns the name of the SMTP host that is used for this group.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SuspendedQueueCount Property

Contains a value that indicates the number of documents in the Suspended queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 SuspendedQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Suspended queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


UseProxyServer Property

Contains a value that indicates whether to use the proxy server.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean UseProxyServer = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if a proxy server is used; if a proxy server is not used, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


WorkQueueCount Property

Contains a value that indicates the number of documents in the Work queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 WorkQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Work queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_GroupReceiveFunction

Allows you to retrieve all the receive functions in a group.

Hierarchy

MicrosoftBizTalkServer_GroupReceiveFunction

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_GroupReceiveFunction

[C++]

class MicrosoftBizTalkServer_GroupReceiveFunction

Members

MicrosoftBizTalkServer_GroupReceiveFunction defines the following properties:

Property | Description
Antecedent | Contains references to the properties of the BizTalk Server group.
Dependent | Contains references to the properties of the receive function that is associated with the BizTalk Server group.

Remarks

MicrosoftBizTalkServer_GroupReceiveFunction is an association class.

Associations are instances of association classes and are used to represent relationships between other WMI objects.

MicrosoftBizTalkServer_GroupReceiveFunction is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Antecedent Property

Contains references to the properties of the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupReceiveFunction

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_Group ref Antecedent;

Parameters

None

Return Values

Returns a value that references the properties of the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_Group object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Dependent property uniquely identifies an instance of the class.

This property is the parent component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Dependent Property

Contains references to the properties of the receive function that is associated with the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupReceiveFunction

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_ReceiveFunction ref Dependent;

Parameters

None

Return Values

Returns a value that references the properties of the receive function that is associated with the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_ReceiveFunction object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Antecedent property uniquely identifies an instance of the class.

This property is the child component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_GroupServer

Allows you to retrieve all the servers in a group.

Hierarchy

MicrosoftBizTalkServer_GroupServer

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_GroupServer

[C++]

class MicrosoftBizTalkServer_GroupServer

Members

MicrosoftBizTalkServer_GroupServer defines the following properties:

Property | Description
Antecedent | Contains references to the properties of the BizTalk Server group.
Dependent | Contains references to the properties of the server that is associated with the BizTalk Server group.

Remarks

MicrosoftBizTalkServer_GroupServer is an association class.

Associations are instances of association classes and are used to represent relationships between other WMI objects.

MicrosoftBizTalkServer_GroupServer is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Antecedent Property

Contains references to the properties of the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupServer

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_Group ref Antecedent;

Parameters

None

Return Values

Returns a value that references the properties of the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_Group object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Dependent property uniquely identifies an instance of the class.

This property is the parent component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Dependent Property

Contains references to the properties of the server that is associated with the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupServer

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_Server ref Dependent;

Parameters

None

Return Values

Returns a value that references the properties of the server that is associated with the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_Server object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Antecedent property uniquely identifies an instance of the class.

This property is the child component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_MgmtDB

Represents the BizTalk Messaging Management database.

Hierarchy

MicrosoftBizTalkServer_MgmtDB

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_MgmtDB

[C++]

class MicrosoftBizTalkServer_MgmtDB

Members

MicrosoftBizTalkServer_MgmtDB defines the following properties:

Property | Description
LocalServer | Contains the name of the class, identifying the instance of the class.
MgmtDbName | Contains the initial catalog component of the BizTalk Messaging Management database connect string and represents the database name.
MgmtDbServer | Contains the data source part of the BizTalk Messaging Management database connect string.

Remarks

MicrosoftBizTalkServer_MgmtDB is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


LocalServer Property

Contains the name of the class, which identifies the instance of the class.

Member List

MicrosoftBizTalkServer_MgmtDB

|--LocalServer

|--MgmtDbName

|--MgmtDbServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string LocalServer;

Parameters

None

Return Values

Returns the name of the class, which identifies the instance of the class.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MgmtDbName Property

Contains the initial catalog component of the BizTalk Messaging Management database connect string and represents the database name.

Member List

MicrosoftBizTalkServer_MgmtDB

|--LocalServer

|--MgmtDbName

|--MgmtDbServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string MgmtDbName;

Parameters

None

Return Values

Returns the initial catalog component of the BizTalk Messaging Management database connect string and represents the database name.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 123 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MgmtDbServer Property

Contains the data source part of the BizTalk Messaging Management database connect string.

Member List

MicrosoftBizTalkServer_MgmtDB

|--LocalServer

|--MgmtDbName

|--MgmtDbServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string MgmtDbServer;

Parameters

None

Return Values

Returns the data source part of the BizTalk Messaging Management database connect string.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 60 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_Queue

Provides a set of properties inherited by Retry queue, Scheduled queue, Suspended queue, and Work queue objects.

Hierarchy

MicrosoftBizTalkServer_Queue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_Queue

[C++]

class MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_Queue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
Group | Contains the name of the group to which the queue belongs.
QID | Contains a value that identifies an instance of the class.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

Remarks

MicrosoftBizTalkServer_Queue serves only as a base for new classes. This class is abstract and should not be implemented.

The following interfaces inherit properties from MicrosoftBizTalkServer_Queue:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Destination Property

Contains the name of the organization or application that receives the document.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Destination;

Parameters

None

Return Values

Returns the name of the organization or application that receives the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 512 characters.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Group Property

Contains the name of the group to which the queue belongs.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Group;

Parameters

None

Return Values

Returns the name of the group to which the queue belongs.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the QID property uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QID Property

Contains a value that identifies an instance of the class.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 QID;

Parameters

None

Return Values

Returns a value that identifies an instance of the class.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Group property uniquely identifies an instance of the class.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Source Property

Contains the name of the organization or application that sends the document.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Source;

Parameters

None

Return Values

Returns the name of the organization or application that sends the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 64 characters.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Timestamp Property

Contains a value that indicates the last time the document was used or when it entered the queue.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime Timestamp;

Parameters

None

Return Values

Returns the last time the document was used or when it entered the queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_ReceiveFunction

Represents a service that is set up on a BizTalk Server to handle incoming interchanges by using a specific protocol such as File, Message Queuing, or Script.

Hierarchy

MicrosoftBizTalkServer_ReceiveFunction

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_ReceiveFunction

[C++]

class MicrosoftBizTalkServer_ReceiveFunction

Members

MicrosoftBizTalkServer_ReceiveFunction defines the following properties:

Property | Description
ChannelName | Contains the name of the channel that the receive function should pass to the Submit method call when the pass-through flag is enabled.
Comment | Contains user comments.
DateModified | Contains a value that indicates the last modification date of the instance data.
DestinationID | Contains the ID of the organization or application that receives the document.
DestinationQualifier | Contains the ID type of the organization or application that receives the document.
DisableReceiveFunction | Contains a value that indicates whether to enable or disable the receive function.
DocumentName | Contains the name of the document definition for the input document of a channel.
EnvelopeName | Contains the name of an envelope definition instance in the BizTalk Messaging Management database.
FilenameMask | Contains the file name mask to use for receive functions that pull files from the file system for input to BizTalk Server.
GroupName | Contains the name of the group to which the server belongs.
HttpReturnContentType | Contains the name of the document type.
HttpReturnCorrelationToken | Contains a value that indicates whether to return a correlation token.
HttpTransportType | Contains the enumeration value used to represent the method used by the HTTP receive function to submit an interchange.
IsPassThrough | Contains a value that indicates whether a Submit method call is made with the pass-through flag enabled or disabled.
Name | Contains the name of the component.
OpennessFlag | Contains a value that indicates the value of the Openness parameter that the receive function passes to the Submit method.
Password | Contains the password to use for File Transfer Protocol (FTP) or Message Queuing receive functions that require a user name and password.
PollingLocation | Contains the name of the directory to poll (directory, message queue, and so on) for receive functions that require polling.
PreProcessor | Contains a value that indicates any preprocessing that must be done for a received document.
ProcessingServer | Contains the name of the server that is currently processing the interchange.
ProtocolType | Contains the enumeration value used to represent the type of the receive function component.
SourceID | Contains the ID of the organization or application that sends the document.
SourceQualifier | Contains the ID type of the organization or application that sends the document.
TransportURL | Contains the transport URL, indicating how and where the HTTP receive function submits the document.
Username | Contains the user name to use for FTP or Message Queuing receive functions.

Remarks

MicrosoftBizTalkServer_ReceiveFunction is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ChannelName Property

Contains the name of the channel that the receive function should pass to the Submit method call when the pass-through flag is enabled.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ChannelName;

Parameters

None

Return Values

Returns the name of the channel that the receive function should pass to the Submit method call when the pass-through flag is enabled. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Comment Property

Contains user comments.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Comment;

Parameters

None

Return Values

Returns user comments.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DateModified Property

Contains a value that indicates the last modification date of the instance data.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime DateModified;

Parameters

None

Return Values

Returns the last modification date of the instance data.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestinationID Property

Contains the ID of the organization or application that receives the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestinationID;

Parameters

None

Return Values

Returns the ID of the organization or application that receives the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestinationQualifier Property

Contains the ID type of the organization or application that receives the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestinationQualifier;

Parameters

None

Return Values

Returns the ID type of the organization or application that receives the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DisableReceiveFunction Property

Contains a value that indicates whether to enable or disable the receive function.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean DisableReceiveFunction = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if the receive function is disabled; if the receive function is enabled, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocumentName Property

Contains the name of the document definition for the input document of a channel.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocumentName;

Parameters

None

Return Values

Returns the name of the document definition for the input document of a channel.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


EnvelopeName Property

Contains the name of an envelope definition instance in the BizTalk Messaging Management database.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string EnvelopeName;

Parameters

None

Return Values

Returns the name of an envelope definition instance in the BizTalk Messaging Management database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


FilenameMask Property

Contains the file name mask to use for receive functions that pull files from the file system for input to BizTalk Server.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string FilenameMask;

Parameters

None

Return Values

Returns the file name mask to use for receive functions that pull files from the file system for input to BizTalk Server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupName Property

Contains the name of the group to which the server belongs.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupName;

Parameters

None

Return Values

Returns the name of the group to which the server belongs.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


HttpReturnContentType Property

Contains the name of the document type.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string HttpReturnContentType;

Parameters

None

Return Values

Returns the name of the document type.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


HttpReturnCorrelationToken Property

Contains a value that indicates whether to return a correlation token.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean HttpReturnCorrelationToken = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if the correlation token is returned; if the correlation token is not returned, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


HttpTransportType Property

Contains the enumeration value used to represent the method used by the HTTP receive function to submit an interchange.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 HttpTransportType;

Parameters

None

Return Values

Returns the enumeration value used to represent the method used by the HTTP receive function to submit an interchange. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "File", "Submit", and "SubmitSync", which map to the integers 1, 2, and 3, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the values:

Values {"File", "Submit", "SubmitSync"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


IsPassThrough Property

Contains a value that indicates whether a Submit method call is made with the pass-through flag enabled or disabled.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean IsPassThrough = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if the pass-through flag is enabled; if the pass-through flag is disabled, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the component.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the component.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


OpennessFlag Property

Contains a value that indicates the value of the Openness parameter that the receive function passes to the Submit method.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 OpennessFlag;

Parameters

None

Return Values

Returns the value of the Openness parameter that the receive function passes to the Submit method. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "NotOpen", "OpenSource", and "OpenDestination", which map to the integers 0, 1, and 2, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the values:

Values {"NotOpen", "OpenSource", "OpenDestination"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Password Property

Contains the password to use for FTP or Message Queuing receive functions that require a user name and password.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Password;

Parameters

None

Return Values

Returns the password to use for FTP or Message Queuing receive functions that require a user name and password.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-only. Due to security considerations, when you try to read this property, NULL is returned instead of the password value.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PollingLocation Property

Contains the name of the directory to poll (directory, message queue, and so on) for receive functions that require polling.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string PollingLocation;

Parameters

None

Return Values

Returns the name of the directory to poll (directory, message queue, and so on) for receive functions that require polling.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 260 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PreProcessor Property

Contains a value that indicates any preprocessing that must be done for a received document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string PreProcessor;

Parameters

None

Return Values

Returns a value indicating any preprocessing that must be done for a received document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that is currently processing the interchange.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that is currently processing the interchange.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProtocolType Property

Contains the enumeration value used to represent the type of the receive function component.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ProtocolType;

Parameters

None

Return Values

Returns the enumeration value used to represent the type of the receive function component. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "File", "MSMQ", and "HTTP", which map to the integers 1, 2, and 3, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the values:

Values {"File", "MSMQ", "HTTP"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SourceID Property

Contains the ID of the organization or application that sends the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SourceID;

Parameters

None

Return Values

Returns the ID of the organization or application that sends the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SourceQualifier Property

Contains the ID type of the organization or application that sends the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SourceQualifier;

Parameters

None

Return Values

Returns the ID type of the organization or application that sends the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions. The value of this property can be a phone number, a Dunn & Bradstreet number, and so on.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


TransportURL Property

Contains the transport URL, indicating how and where the HTTP receive function submits the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string TransportURL;

Parameters

None

Return Values

Returns the transport URL, indicating how and where the HTTP receive function submits the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Username Property

Contains the user name to use for FTP or Message Queuing receive functions.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Username;

Parameters

None

Return Values

Returns the user name to use for FTP or Message Queuing receive functions.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_RetryQueue

Represents a logical grouping of interchanges in the Shared queue that are awaiting receipt correlation, or interchanges that are due to be sent to multiple destinations.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_RetryQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_RetryQueue

[C++]

class MicrosoftBizTalkServer_RetryQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_RetryQueue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
Group | Contains the name of the group to which the queue belongs.
LastRetryTime | Contains a value that indicates the last time the server attempted a transmission.
ProcessingServer | Contains the name of the server that last processed the document.
QID | Contains a value that identifies an instance of the class.
RemainingRetryCount | Contains a value that indicates the number of outstanding retries remaining.
RetryInterval | Contains a value that indicates the wait time between retry intervals, in minutes.
ServiceWindowFromTime | Contains a value that indicates the start time of the service window in which to send interchanges.
ServiceWindowToTime | Contains a value that indicates the end time of the service window in which to send interchanges.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_RetryQueue defines the following method:

Method | Description
MoveToSuspendedQueue | Enables the administrator to move the selected document to the Suspended queue.

Remarks

MicrosoftBizTalkServer_RetryQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


LastRetryTime Property

Contains a value that indicates the last time the server attempted a transmission.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime LastRetryTime;

Parameters

None

Return Values

Returns the last time the server attempted a transmission.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MoveToSuspendedQueue Method

Enables the administrator to move the selected document to the Suspended queue.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 MoveToSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

Calling this method will not raise a DocSuspendedEvent.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that last processed the document.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that last processed the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This is a read-only property.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RemainingRetryCount Property

Contains a value that indicates the number of outstanding retries remaining.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 RemainingRetryCount;

Parameters

None

Return Values

Returns the number of outstanding retries remaining.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RetryInterval Property

Contains a value that indicates the wait time between retry intervals, in minutes.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 RetryInterval;

Parameters

None

Return Values

Returns the wait time between retry intervals, in minutes.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowFromTime Property

Contains a value that indicates the start time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowFromTime;

Parameters

None

Return Values

Returns the start time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowToTime Property

Contains a value that indicates the end time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowToTime;

Parameters

None

Return Values

Returns the end time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_ScheduledQueue

Represents a logical grouping of interchanges in the Shared queue that are scheduled to be delivered at a later time based on a service window.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_ScheduledQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_ScheduledQueue

[C++]

class MicrosoftBizTalkServer_ScheduledQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_ScheduledQueue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
Group | Contains the name of the group to which the queue belongs.
ProcessingServer | Contains the name of the server that last processed the document.
QID | Contains a value that identifies an instance of the class.
ServiceWindowFromTime | Contains a value that indicates the start time of the service window in which to send interchanges.
ServiceWindowToTime | Contains a value that indicates the end time of the service window in which to send interchanges.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_ScheduledQueue defines the following method:

Method | Description
MoveToSuspendedQueue | Enables the administrator to move the selected document to the Suspended queue.

Remarks

MicrosoftBizTalkServer_ScheduledQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MoveToSuspendedQueue Method

Enables the administrator to move the selected document to the Suspended queue.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 MoveToSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

Calling this method will not raise a DocSuspendedEvent.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that last processed the document.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that last processed the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowFromTime Property

Contains a value that indicates the start time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowFromTime;

Parameters

None

Return Values

Returns the start time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in interval format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowToTime Property

Contains a value that indicates the end time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowToTime;

Parameters

None

Return Values

Returns the end time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in interval format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_Server

Represents specific Windows 2000 computers within a BizTalk Server group that are running BizTalk Messaging Services.

Hierarchy

MicrosoftBizTalkServer_Server

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_Server

[C++]

class MicrosoftBizTalkServer_Server

Members

MicrosoftBizTalkServer_Server defines the following properties:

Property | Description
DateModified | Contains the date of the last modification of the instance data.
GroupName | Contains the name of the group to which the server belongs.
MaxRecvSvcThreadsPerProcessor | Contains the maximum number of receive function threads that BizTalk Server can use per processor for asynchronous calls.
MaxWorkerThreadsPerProcessor | Contains the maximum number of worker threads that BizTalk Server can use per processor for asynchronous calls.
Name | Contains the name of the server.
ParticipateInWorkItemProcessing | Contains a value that indicates whether the server participates in work-item processing.
SchedulerWaitTime | Contains the time interval that BizTalk Server Scheduler waits between tries, in milliseconds.
ServiceState | Contains a value that indicates the state of the BizTalk services on a particular server.

MicrosoftBizTalkServer_Server defines the following methods:

Method | Description
FreeInterchanges | Frees interchanges that are currently assigned to a specific server if the server is stopped, removed, or in an error state, so that other servers can use these interchanges.
RegisterServerInAD | Registers the BizTalk Server in the Microsoft Active Directory.
StartServer | Starts the BizTalk services on a specific server.
StopServer | Stops the BizTalk services on a specific server.
UnregisterServerInAD | Unregisters the BizTalk Server in the Microsoft Active Directory.

Remarks

MicrosoftBizTalkServer_Server is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DateModified Property

Contains the date of the last modification of the instance data.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime DateModified;

Parameters

None

Return Values

Returns the date of the last modification of the instance data.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


FreeInterchanges Method

Frees interchanges that are currently assigned to a specific server if the server is stopped, removed, or in an error state, so that other servers can use these interchanges.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 FreeInterchanges();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupName Property

Contains the name of the group to which the server belongs.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupName;

Parameters

None

Return Values

Returns the name of the group to which the server belongs.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MaxRecvSvcThreadsPerProcessor Property

Contains the maximum number of receive function threads that BizTalk Server can use per processor for asynchronous calls.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 MaxRecvSvcThreadsPerProcessor = 4;

Parameters

None

Return Values

Returns the maximum number of receive function threads that BizTalk Server can use per processor for asynchronous calls.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 4.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MaxWorkerThreadsPerProcessor Property

Contains the maximum number of worker threads that BizTalk Server can use per processor for asynchronous calls.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 MaxWorkerThreadsPerProcessor = 4;

Parameters

None

Return Values

Returns the maximum number of worker threads that BizTalk Server can use per processor for asynchronous calls.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 4.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ParticipateInWorkItemProcessing Property

Contains a value that indicates whether the server participates in work-item processing.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean ParticipateInWorkItemProcessing = 1;

Parameters

None

Return Values

Returns a language-specific value representing true if the server participates in work-item processing; if the server does not participate in work-item processing, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is TRUE.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RegisterServerInAD Method

Registers the BizTalk Server in the Microsoft Active Directory.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 RegisterServerInAD();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SchedulerWaitTime Property

Contains the time interval that BizTalk Server Scheduler waits between tries, in milliseconds.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 SchedulerWaitTime = 2000;

Parameters

None

Return Values

Returns the time interval that BizTalk Server Scheduler waits between tries, in milliseconds.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 2,000 milliseconds.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceState Property

Contains a value that indicates the state of the BizTalk services on a particular server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ServiceState;

Parameters

None

Return Values

Returns the state of the BizTalk services on a particular server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


StartServer Method

Starts the BizTalk services on a specific server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 StartServer();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The execution of this method is valid any time the specific server is stopped.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


StopServer Method

Stops the BizTalk services on a specific server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 StopServer();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The execution of this method is valid any time the specific server is running.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


UnregisterServerInAD Method

Unregisters the BizTalk Server in the Microsoft Active Directory.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 UnregisterServerInAD();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_SuspendedQueue

Represents a logical grouping of interchanges in the Shared queue that could not be successfully processed.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_SuspendedQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_SuspendedQueue

[C++]

class MicrosoftBizTalkServer_SuspendedQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_SuspendedQueue defines the following properties:

Property | Description
ChannelHandle | Contains the handle of the channel used for processing the interchange or document in the Suspended queue.
Destination | Contains the name of the organization or application that receives the document.
DocName | Contains the name of the document definition related to the document in the queue.
ErrorDescription | Contains the first 64 characters of the error description.
Group | Contains the name of the group to which the queue belongs.
QGUID | Contains the submission GUID of the Suspended queue work item.
QID | Contains a value that identifies an instance of the class.
Size | Contains the approximate size of the interchange or document in the Suspended queue, in bytes.
Source | Contains the name of the organization or application that sends the document.
State | Contains a value that indicates the state of the document or interchange in the Suspended queue.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_SuspendedQueue defines the following methods:

Method | Description
Resubmit | Enables an administrator to resubmit the selected document to the server.
ViewDocument | Enables an administrator to view the contents of a selected document in the Suspended queue.
ViewErrorDescription | Enables the administrator to view a description of the error.
ViewInterchange | Enables the administrator to view the contents of a selected interchange in the Suspended queue.

Remarks

MicrosoftBizTalkServer_SuspendedQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ChannelHandle Property

Contains the handle of the channel used for processing the interchange or document in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ChannelHandle;

Parameters

None

Return Values

Returns the handle of the channel used for processing the interchange or document in the Suspended queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocName Property

Contains the name of the document definition related to the document in the queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocName;

Parameters

None

Return Values

Returns the name of the document definition related to the document in the queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ErrorDescription Property

Contains the first 64 characters of the error description.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ErrorDescription;

Parameters

None

Return Values

Returns the first 64 characters of the error description.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 64 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QGUID Property

Contains the submission GUID of the Suspended queue work item.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string QGUID;

Parameters

None

Return Values

Returns the submission GUID of the Suspended queue work item.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Resubmit Method

Enables an administrator to resubmit the selected document to the server.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 Resubmit();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This method enables an administrator to resubmit interchanges after problems have been fixed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Size Property

Contains the approximate size of the interchange or document in the Suspended queue, in bytes.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 Size;

Parameters

None

Return Values

Returns the approximate size of the interchange or document in the Suspended queue, in bytes.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


State Property

Contains a value that indicates the state of the document or interchange in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 State;

Parameters

None

Return Values

Returns the state of the document or interchange in the Suspended queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The tables in this section show the possible processing states of a document or interchange in the Suspended queue.

Documents in the states listed in the following table are at the interchange level, so you should use the ViewInterchange method to view the data. In addition, interchanges in these states cannot be resubmitted, so in this case you should not call Resubmit.

Value | State
0 | Initial
1 | Custom component
2 | Parsing

Documents in the states listed in the following table are considered documents instead of interchanges, so you should use the ViewDocument method to view the data. In addition, documents in the document validation state (3) cannot be resubmitted, so for those documents you should not call Resubmit.

Value | State
3 | Document validation
4 | Channel selection
5 | Field tracking
6 | Correlating
7 | Mapping
8 | Serializing

Documents in the states listed in the following table are considered interchanges, so you should use the ViewInterchange method to view the data.

Value | State
9 | Encoding
10 | Signing
11 | Encrypting
12 | Transmitting

Note that the ViewErrorDescription method can be used to retrieve error description information about failed documents and interchanges.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ViewDocument Method

Enables an administrator to view the contents of a selected document in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--QID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 ViewDocument(

uint8 Document[],

uint32 CodePage

);

Parameters

Document

[out] An array of bytes, representing the information in the document. This data may need to be converted into a readable format. The maximum size for this parameter is 4 MB. If the data exceeds 4 MB, the data will be truncated. For more information, see "Remarks".

CodePage

[out] The code page of the document. For more information, see "Remarks".

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The following table shows the possible values for the CodePage parameter and their meanings.

Value | Description
-1 | No code page available
0 | Default system code page
1200 | Unicode code page
1252 | ASCII code page

If the value returned in the CodePage parameter is 0 or 1200, the data can be displayed and no conversion is needed. However, if the value is -1, you should try loading the data into Microsoft XML (MSXML).

If the value returned in CodePage is 1252, you should try loading the data into MSXML. If this fails, you can use the MultiByteToWideChar function, passing in CodePage as the code page parameter to the Microsoft Win32® API.

If the data contained in the Document parameter is larger than 4 MB, C++ programmers can use the GetSuspendedQueueItemDetails method to retrieve the document.

ViewDocument is not available in a tools-only installation of BizTalk Server 2002.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ViewErrorDescription Method

Enables the administrator to view a description of the error.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 ViewErrorDescription(

string CompleteErrorDescription

);

Parameters

CompleteErrorDescription

[out] A string describing the error.

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ViewInterchange Method

Enables the administrator to view the contents of a selected interchange in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 ViewInterchange(

uint8 Interchange[],

uint32 CodePage

);

Parameters

Interchange

[out] An array of bytes, representing the information in the interchange. This data may need to be converted into a readable format. The maximum size for this parameter is 4 MB. If the data exceeds 4 MB, the data will be truncated. For more information, see "Remarks".

CodePage

[out] The code page of the interchange. For more information, see "Remarks".

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The following table shows the possible values for the CodePage parameter and their meanings.

Value | Description
-1 | No code page available
0 | Default system code page
1200 | Unicode code page
1252 | ASCII code page

If the value returned in the CodePage parameter is 0 or 1200, the data can be displayed and no conversion is needed. However, if the value is -1, you should try loading the data into MSXML.

If the value returned in CodePage is 1252, you should try loading the data into MSXML. If this fails, you can use the MultiByteToWideChar function, passing in CodePage as the codepage parameter to the Win32 API.

If the data contained in the Interchange parameter is larger than 4 MB, C++ programmers can use the GetSuspendedQueueItemDetails method to retrieve the interchange.

ViewInterchange is not available in a tools-only installation of BizTalk Server 2002.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_WorkQueue

Represents a logical grouping of interchanges in the Shared queue that are currently in process.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_WorkQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_WorkQueue

[C++]

class MicrosoftBizTalkServer_WorkQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_WorkQueue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
DocName | Contains the name of the document definition related to the document in the queue.
EngineState | Contains a value that indicates whether the work item is waiting for receipt correlation or waiting for transmission.
Group | Contains the name of the group to which the queue belongs.
ProcessingServer | Contains the name of the server that last processed the document.
QID | Contains a value that identifies an instance of the class.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_WorkQueue defines the following method:

Method | Description
MoveToSuspendedQueue | Enables the administrator to move the selected document to the Suspended queue.

Remarks

MicrosoftBizTalkServer_WorkQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocName Property

Contains the name of the document definition related to the document in the queue.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocName;

Parameters

None

Return Values

Returns the name of the document definition related to the document in the queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


EngineState Property

Contains a value that indicates whether the work item is waiting for receipt correlation or waiting for transmission.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 EngineState;

Parameters

None

Return Values

Returns a value that indicates whether the work item is waiting for receipt correlation or waiting for transmission.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The possible values for this property are defined by the BTSCoreQueueStates enumeration, as shown in the following code:

typedef enum {

Processing = STATE_TRANSLATION,

Correlation = STATE_RECEIPT_CORRELATION,

TransmissionWServiceWindow = STATE_FIND_TRANSMISSION,

Transmission = STATE_TRANSMISSION

} BTSCoreQueueStates;

The following table provides the numerical values of the constants defined in the BTSCoreQueueStates enumeration.

Value | Constant
29 | Processing
30 | Correlation
31 | TransmissionWServiceWindow
33 | Transmission

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MoveToSuspendedQueue Method

Enables the administrator to move the selected document to the Suspended queue.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

type name;

uint32 MoveToSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

Calling this method will not raise a DocSuspendedEvent.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that last processed the document.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that last processed the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MSBTS_CustomCounter

Retrieves the value of the custom counter query.

Hierarchy

CIM_ManagedSystemElement

|--CIM_LogicalElement

|--MSBTS_CustomCounter

Declaration

[Visual Basic]

Class MSBTS_CustomCounter

[C++]

class MSBTS_CustomCounter : CIM_LogicalElement

Members

MSBTS_CustomCounter defines the following properties:

Property | Description
GroupCounterName | Contains the Tracking database and custom counter names.
MatchCount | Contains the number of documents that match the criteria specified by the custom counter setting.
Name | Contains the name of the custom counter.

Remarks

MSBTS_CustomCounter is derived from CIM_LogicalElement.

MSBTS_CustomCounter is a dynamic class that is automatically created for every instance of MSBTS_CustomCounterSetting.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupCounterName Property

Contains the Tracking database and custom counter names.

Member List

MSBTS_CustomCounter

|--GroupCounterName

|--MatchCount

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupCounterName;

Parameters

None

Return Values

This property returns the Tracking database and custom counter names.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

For a custom counter with a GroupName property of "BizTalk Server Group" and a Name property of "My Custom Counter", the value for this property would be "BizTalk Server Group\MyCustomCounter".

This property is required to distinguish between custom counters with the same name that monitor different DTA databases.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MatchCount Property

Contains the number of documents that match the criteria specified by the custom counter setting.

Member List

MSBTS_CustomCounter

|--GroupCounterName

|--MatchCount

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 MatchCount;

Parameters

None

Return Values

This property returns the number of documents that match the query associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Note that this property counts both inbound and outbound documents. For example, if a single document passes through the system and no mapping is performed, then MatchCount will be incremented by two.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the custom counter.

Member List

MSBTS_CustomCounter

|--GroupCounterName

|--MatchCount

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

This property returns the name of the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

Both MSBTS_CustomCounter and MSBTS_CustomCounterSetting share the same value for their key property, Name.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MSBTS_CustomCounterSetting

Creates, deletes, and validates custom counters.

Hierarchy

CIM_Setting

|--MSBTS_CustomCounterSetting

Declaration

[Visual Basic]

Class MSBTS_CustomCounterSetting

[C++]

class MSBTS_CustomCounterSetting : CIM_Setting

Members

MSBTS_CustomCounterSetting defines the following properties:

Property | Description
DestOrgName | Contains the name of the destination organization associated with the custom counter.
DestQualifier | Contains the name of the destination qualifier type associated with the custom counter.
DestQualifierValue | Contains the value of the destination qualifier type associated with the custom counter.
DocType | Contains the name of the root element from the document schema.
GroupName | Contains the name of the BizTalk Server group against which the custom counter query executes.
Name | Contains the name of the custom counter.
SrcOrgName | Contains the name of the source organization associated with the custom counter.
SrcQualifier | Contains the name of the source qualifier type associated with the custom counter.
SrcQualifierValue | Contains the value of the source qualifier type associated with the custom counter.
TimeInterval | Contains the time over which to accumulate the custom counter query value, in seconds.

MSBTS_CustomCounterSetting defines the following method:

Method | Description
IsValid | Validates the custom counter creation parameters.

Remarks

MSBTS_CustomCounterSetting is derived from CIM_Setting.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestOrgName Property

Contains the name of the destination organization associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestOrgName;

Parameters

None

Return Values

This property returns the name of the destination organization associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

When the destination information is not explicitly declared in the messaging port the string value that is tracked for DstOrgName is "<OPEN DESTINATION>". For more information, see How Interchanges and Documents Are Logged.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestQualifier Property

Contains the name of the destination qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestQualifier;

Parameters

None

Return Values

This property returns the name of the destination qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestQualifierValue Property

Contains the value of the destination qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestQualifierValue;

Parameters

None

Return Values

This property returns the value of the destination qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocType Property

Contains the name of the root element from the document schema.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocType;

Parameters

None

Return Values

This property returns the name of the root element from the document schema.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

When a document specification is created using BizTalk Editor, you can specify the Document Type reference property to a user-defined string value. If the root XML element is not defined, the value of the Document Type reference property, if defined, will be tracked as the DocType value. For more information, see Set Reference Properties.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupName Property

Contains the name of the BizTalk Server group against which the custom counter query executes.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupName;

Parameters

None

Return Values

This property returns the name of the BizTalk Server group against which the custom counter query executes.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property is used to look up the database name, server, user name, and password, and to validate the custom counter parameters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


IsValid Method

Validates the custom counter creation parameters.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 IsValid(

boolean IsValidSrcOrg,

boolean IsValidSrcId,

boolean IsValidDestOrg,

boolean IsValidDestId,

boolean IsValidGroup

);

Parameters

IsValidSrcOrg

[out] Returns a language-specific value representing true if the source organization name is valid; otherwise, if the source organization name is not valid, this parameter returns a language-specific value representing false.

IsValidSrcId

[out] Returns a language-specific value representing true if the source identifier name is valid; otherwise, if the source identifier name is not valid, this parameter returns a language-specific value representing false.

IsValidDestOrg

[out] Returns a language-specific value representing true if the destination organization name is valid; otherwise, if the destination organization name is not valid, this parameter returns a language-specific value representing false.

IsValidDestId

[out] Returns a language-specific value representing true if the destination identifier name is valid; otherwise, if the destination identifier name is not valid, this parameter returns a language-specific value representing false.

IsValidGroup

[out] Returns a language-specific value representing true if the BizTalk Server group name is valid; otherwise, if the BizTalk Server group name is not valid, this parameter returns a language-specific value representing false.

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

This property returns the name of the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

Both MSBTS_CustomCounterSetting and MSBTS_CustomCounter share the same value for their key property, Name.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SrcOrgName Property

Contains the name of the source organization associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SrcOrgName;

Parameters

None

Return Values

This property returns the name of the source organization associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

When the source information is not explicitly declared in the channel, the string value that is tracked for SrcOrgName is "<OPEN SOURCE>". For more information, see How Interchanges and Documents Are Logged.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SrcQualifier Property

Contains the name of the source qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SrcQualifier;

Parameters

None

Return Values

Returns the name of the source qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SrcQualifierValue Property

Contains the value of the source qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SrcQualifierValue;

Parameters

None

Return Values

Returns the value of the source qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


TimeInterval Property

Contains the time over which to accumulate the custom counter query value, in seconds.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 TimeInterval;

Parameters

None

Return Values

Returns the time over which to accumulate the custom counter query value, in seconds.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ReceiveFunctionDisabledEvent

Represents events raised by disabled receive functions.

Hierarchy

__ExtrinsicEvent

|--ReceiveFunctionDisabledEvent

Declaration

[Visual Basic]

Class ReceiveFunctionDisabledEvent

[C++]

class ReceiveFunctionDisabledEvent : __ExtrinsicEvent

Members

ReceiveFunctionDisabledEvent defines the following property:

Property | Description
Name | Contains the name of the disabled receive function.

Remarks

ReceiveFunctionDisabledEvent inherits from the __ExtrinsicEvent system class, an abstract base class that serves as a superclass for all user-defined event types.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the disabled receive function.

Member List

ReceiveFunctionDisabledEvent

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the disabled receive function.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This event is raised when a receive function is disabled.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Error Messages

The properties and methods of the BizTalk™ Messaging Services and BizTalk Orchestration Services object models use standard Component Object Model (COM) HRESULT return values to communicate whether the operation was successful or not.

In C++, these values are the actual return values from the methods themselves (including property get_ and put_ methods). The program must explicitly perform error checking by examining these return values, or use some variation of structured error handling.

In Microsoft® Visual Basic®, and in Microsoft Visual Basic Scripting Edition (VBScript), these values are placed in the Number property of the global Err object. Error handling is either handled automatically, displaying a standard error dialog box, or explicitly by the program, checking the value of the Number property of the global Err object. The On Error Resume Next command disables automatic error handling, thereby enabling explicit error handling.

For additional information about error message values, see the following sections:

  • Messaging Services Error Messages

  • Orchestration Services Error Messages

  • Standard COM Error Messages


Messaging Services Error Messages

The BizTalk Messaging Services object model error messages defined by BizTalk Server can be used in your application by including the bts_config_errors.h file located in the BizTalk Server installation directory at \Program Files\Microsoft BizTalk Server\SDK\Include. These error messages, returned during design time by the methods and properties of the object model, contain a BTS_ prefix in the message name. All other errors occur during run time, while BizTalk Server is processing a document.

The following table contains both design time and run time errors.

Message name | Value | Description
CIS_E_OBJECT_NOT_FOUND | 0x0100 | The object was not found.
CIS_E_STATE_NOT_FOUND | 0x0101 | The state engine state was not found in the messaging port definition.
CIS_E_STATE_TRANSITION | 0x0103 | The state table contains a bad engine state transition.
CIS_E_BAD_ENGINE_CONFIG_FILE | 0x0105 | The string that describes the input state configuration is not valid.
CIS_E_CANNOT_ADD_STATE | 0x0106 | BizTalk Server could not add the user-defined state to the system.
CIS_E_NO_COMPONENT_FOUND | 0x0107 | There is no component in the state definition or the ProgID is wrong.
CIS_E_PIPECOMP_ADMIN_REQUIRED | 0x0108 | The required IPipelineComponentAdmin interface was not found on the component.
CIS_E_BAD_COMPONENT_TYPE | 0x0109 | The component type specified for the state engine is not recognized.
CIS_E_BAD_STATE_CONFIG | 0x010A | The state configuration is not valid.
CIS_E_BAD_STATE_TYPE | 0x010B | The specified state type is not recognized.
CIS_E_BAD_COMPONENT_CONFIG | 0x010C | The component configuration is not valid.
CIS_E_INTERNAL_FAILURE | 0x010F | An internal server failure occurred due to an unknown cause.
CIS_E_CREATE_SCHEDULER_FAILED | 0x0111 | The Queue Scheduler for the service could not be created.
CIS_E_AGREEMENT_SELECT_FAILED | 0x0112 | No channels matched the input criteria. Verify that a messaging port and a channel exist, and that they match the following fields: Source qualifier: "%1" Source identifier value: "%2" Source document name: "%3" Destination qualifier: "%4" Destination identifier value: "%5" Also verify that any expressions specified for the channels are compatible with this document.
CIS_E_ERROR | 0x0113 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1
CIS_E_SERVICE_INITIALIZATION_FAILURE | 0x0114 | The service failed to start. Verify that this server is enlisted in a BizTalk Server group.
CIS_E_SCHEDULER_FAILED | 0x0115 | The Queue Scheduler failed and has exited.
CIS_E_WORKER_THREAD_FAILED | 0x0116 | A worker thread failed and has exited.
CIS_E_SHARED_QUEUE_DB_EXEC_FAILED | 0x0117 | Execution against the Shared Queue database has failed.
CIS_E_CANT_READ_WORK_ITEM | 0x0119 | A work item in the Shared Queue database cannot be read.
CIS_E_CHECKPOINT_FAILED | 0x011c | Checkpointing the work item failed.
CIS_E_CREATE_DEAD_WORK_ITEM_FAILED | 0x011e | A new work item in the Suspended queue cannot be created.
CIS_E_GET_SNAPSHOT_FAILED | 0x0122 | A snapshot of the Shared Queue database cannot be taken.
CIS_E_FREE_INTERCHANGES_FAILED | 0x0124 | The specified interchanges cannot be freed.
CIS_E_DELETE_INTERCHANGE_FAILED | 0x0125 | The specified interchange cannot be deleted.
CIS_E_RECEIVING_INTERCHANGE_FAILED | 0x0127 | The specified interchange was not received.
CIS_E_GETTING_NEXT_SCHEDULED_WORK_ITEM_FAILED | 0x0128 | The next scheduled work item cannot be obtained for processing.
CIS_E_GET_COUNT_FAILED | 0x0129 | The count on the shared queues cannot be obtained.
CIS_E_TRANSMISSION_FAILED | 0x012a | All retry transmissions failed.
CIS_W_TRANSMISSION_ATTEMPT_FAILED | 0x012b | A transmission attempt failed.
CIS_W_TRANSMISSION_XFER_TO_SECONDARY | 0x012c | The primary transport for messaging port "%1" cannot transmit the data. The server will switch to the secondary transport.
CIS_E_RECEIPT_GENERATION_FAILED | 0x012e | After creating the work item, the attempt to generate a receipt failed.
CIS_E_RECEIPT_GENERATION_FAILED_NO_WORK_ITEM | 0x012f | The attempt to generate a receipt failed before the work item was created.
CIS_E_L1_RECEIPT_CORRELATION_FAILED | 0x0130 | Receipt correlation failed.
CIS_E_AGREEMENT_LACKING_PARAMS | 0x0133 | At least one of the fields necessary to select a channel is missing. Verify that your document and envelopes extract the proper fields for the parser, or specify the necessary fields upon submission. Channel selection fields: Source identifier type: "%1" Source identifier value: "%2" Source document name: "%3" Destination identifier type: "%4" Destination identifier value: "%5"
CIS_E_AGREEMENT_FAILED | 0x0134 | The channel cannot be selected.
CIS_E_ORIGINAL_L1_INTERCHANGE_MISSING | 0x0135 | When trying to correlate an incoming receipt, the original interchange and related document(s) are no longer present.
CIS_E_UNEXPECTED_DB_BEHAVIOR | 0x0136 | An unexpected return occurred. The database may need to be restarted.
CIS_E_AGREEMENT_INVALID_MAP | 0x0137 | The map specified by the reference "%1" is not valid. Verify that the reference points to a valid map created by BizTalk Mapper.
CIS_I_SERVICE_MSG | 0x0138 | 1%
CIS_E_AGREEMENT_MAP_FAILED | 0x0139 | The XML document could not be translated. The map specified by reference "%1" failed. Verify that the map is up to date.
CIS_E_XML_ERROR | 0x013A | The XML document could not be parsed on line: %2, position: %3 for the following reason: "%1"
CIS_E_AGREEMENT_PROCESSING_FAILED | 0x013f | The server could not finish processing the document.
CIS_E_AGREEMENT_PROCESSING_FAILED_W_NAME | 0x0140 | The following channel configuration setting is not valid: "%1"
CIS_E_AGREEMENT_INVALID_QUERY | 0x0141 | The "%2" query for the "%1" document tracking field is not a valid XSL pattern. This pattern must be removed or corrected.
CIS_I_SERVICE_START | 0x0142 | The service has started.
CIS_I_SERVICE_STOP | 0x0143 | The service has stopped.
CIS_E_ERROR_EX | 0x0144 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_E_ERROR_EX_HEAD | 0x0145 | An error occurred in BizTalk Server.
CIS_E_ERROR_EX_FOOT | 0x0146 |
CIS_E_INVALID_DATA_FORMAT | 0x0147 | The business document that was passed in is not in a recognized format and could not be parsed or decrypted.
CIS_E_CREATE_ENGINE | 0x0148 | BizTalk Server was unable to create a new instance of the processing engine to process a work item. This might be due to a failure to create a new COM+ transaction.
CIS_E_MISSING_DESTINATION_DOCUMENT_SPEC | 0x0149 | BizTalk Server has detected an incomplete messaging port. The destination specification is missing from the messaging port.
CIS_E_PROCESSING_THREAD_FAILED | 0x014A | The processing thread failed to start. This might be due to a failure to create the state engine.
CIS_E_NOSRCORG | 0x014B | No source organization that corresponds to the ID and Qualifier pair has been specified.
CIS_E_NODESTORG | 0x014C | No destination organization that corresponds to the Identifier and Qualifier pair has been specified.
CIS_E_NODOC | 0x014D | No document that corresponds to the document name has been specified.
CIS_E_NOPIPELINES | 0x014E | No channel that corresponds to the parameters has been specified.
CIS_E_NOT_RESUBMITTABLE | 0x014F | The state of the item in the Suspended queue does not allow resubmission.
CIS_E_PIPESELECT_POLICY_FAILED | 0x0150 | No channels matched the certificates that were found with the incoming data. The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_E_SUBMIT_INVALIDDOC | 0x0151 | The submitted document is not valid. See the following messages for more details.
CIS_E_SUBMITSYNC_TOOMANYDOCS | 0x0152 | The SubmitSync method failed because multiple documents where found within the data. Only one document is allowed per synchronous submission. If this is a structured flat-file submission, then the most common cause of failure is extra leading or trailing white space around the data.
CIS_E_SUBMITSYNC_TOOMANYPIPES | 0x0153 | The synchronous submission could not be completed because multiple valid channels matched the incoming document. Only one channel is allowed to match the incoming document.
CIS_E_XMIT_NOTRANSPORTCOMP | 0x0154 | This server could not create a component with the class ID "%1" for transport. Verify that this component is properly registered. The following error was returned:
CIS_E_XMIT_EMPTY_DOCUMENT | 0x0155 | Messaging port "%1" cannot transmit a zero-byte document.
CIS_E_XMIT_FAILED_W_NAME | 0x0156 | The server could not finish processing messaging port "%1".
CIS_E_XMIT_NO_INTERFACE | 0x0157 | The server could not obtain the "%1" interface from the transport component with CLSID "%2".
CIS_E_XMIT_NO_BTS_AIC_INTERFACES | 0x0158 | The server could not obtain either the "%1" or "%2" interfaces from the BizTalk Server application integration component with CLSID "%3".
CIS_E_XMIT_FAILED_W_DETAILS | 0x0159 | The server encountered a transport error while processing the messaging port "%1", which uses a transport component with a ProgID of "%2".
CIS_E_NOHDR_ERROR_EX | 0x015A | %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_W_COMP_NOACK | 0x015B | The correlation component "%1" could not find a document for which to send a receipt. No action will be taken.
CIS_E_CORRELATIONCOMP_FAILED | 0x015C | The correlation component "%1" returned an unexpected failure. The document will be placed in the Suspended queue.
CIS_E_CORRELATION_FAILED | 0x015D | Receipt correlation processing failed.
CIS_E_XML_VALIDATE_ERROR | 0x015E | The XML document has failed validation for the following reason: %1
CIS_E_CHANNEL_ACCESSDENIED | 0x015F | The submitted document does not have the necessary signature or encryption required by channel "%3". The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_I_SERVICE_RESTARTING | 0x0160 | The service is restarting.
BTS_E_CONSTRAINT | 0x1201 | Constraint Error
BTS_E_NOOBJECT | 0x1202 | The object was not found.
BTS_E_INTERNALFAILURE | 0x1203 | An internal failure occurred.
BTS_E_ENVELOPE_CONTROLNUMBER | 0x120C | If the envelope format is set to X12 or EDIFACT, the control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_DELIMETER | 0x120D | If the envelope format is set to X12, then delimiters are required and must be set.
BTS_E_ENCRYPTION_CUSTOM_NOCLSID | 0x120E | If the encryption type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_ENCODING_CUSTOM_NOCLSID | 0x120F | If the encoding type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_SIGNATURE_CUSTOM_NOCLSID | 0x1210 | If the signature type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_INVALIDCONTROLNUMBER | 0x1212 | The control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_INUSE | 0x1213 | The format of the envelope cannot be changed because it is used in a messaging port.
BTS_E_CHANNEL_MISSINGMAPSOURCE | 0x1215 | The channel is missing the MapSource node.
BTS_E_INVALID_CERT_USAGE | 0x1216 | The certificate is not valid for the current usage. An encryption certificate cannot be used for signing; nor can a signing certificate be used for encryption. Make sure that the correct certificate is selected.
BTS_E_MISSINGSMTPHOST | 0x1218 | The SMTP host is missing. The SMTP host can be configured in BizTalk Server Administration.
BTS_E_INVALID_ENCRYPT_STORE | 0x1219 | The encryption store type is not valid. The store type must be BIZTALK.
BTS_E_INVALID_SGNTCERT_STORE | 0x121A | The signature store type is not valid. The store type must be MY.
BTS_E_DATATOOLONG | 0x121B | The data length is too long.
BTS_E_INVALID_VERIFY_ENCRYPTCERT_STORE | 0x121C | The encryption verification store type is not valid. The store type must be MY.
BTS_E_INVALID_VERIFY_SGNTCERT_STORE | 0x121D | The signature verification store type is not valid. The store type must be BIZTALK.
BTS_E_ORGANIZATION_UNIQUE_ID | 0x121F | The organization identifier must be a unique identifier.
BTS_E_ORGANIZATION_UNIQUE_NAME | 0x1220 | The organization name must be a unique name.
BTS_E_OBJECT_ALREADY_EXISTS | 0x1221 | The object already exists. You cannot call the Create() method on a BizTalk Messaging Configuration object multiple times without also calling the Clear() or Remove() methods.
BTS_E_ALIAS_UNIQUE_ID | 0x1222 | The identifier must be a unique identifier.
BTS_E_ALIAS_UNIQUE_NAME | 0x1223 | The identifier name for this organization must be a unique name.
BTS_E_ALIAS_UNIQUE_QUALIFIERVALUE | 0x1225 | The identifier must have a unique qualifier-value pair.
BTS_E_ALIAS_FOREIGN_OWNERID | 0x1226 | The organization cannot be removed because it is referred to by an identifier.
BTS_E_XMLSHARE_UNIQUE_ID | 0x1227 | The primary identifier for the XML Share table in the SQL Server database must be a unique identifier.
BTS_E_XMLSHARE_UNIQUE_REFERENCE | 0x1228 | The reference for the XML Share table in the SQL Server database must be a unique reference.
BTS_E_DOCUMENT_UNIQUE_ID | 0x1229 | The document identifier must be a unique identifier.
BTS_E_DOCUMENT_UNIQUE_NAME | 0x122A | The document name must be a unique name.
BTS_E_DOCUMENT_FOREIGN_SHAREID | 0x122C | The XML Share table in the SQL Server database cannot be removed because it is referred to by a document.
BTS_E_ENVELOPE_UNIQUE_ID | 0x122D | The envelope identifier must be a unique identifier.
BTS_E_ENVELOPE_UNIQUE_NAME | 0x122E | The envelope name must be a unique name.
BTS_E_ENVELOPE_FOREIGN_SHAREID | 0x1230 | The XML Share table in the SQL Server database cannot be removed because it is referred to by an envelope.
BTS_E_CONTROLNUMBER_UNIQUE_ID | 0x1231 | The control-number identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_ID | 0x1232 | The distribution list identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_NAME | 0x1233 | The distribution list name must be a unique name.
BTS_E_MISSING_VALUE | 0x1235 | The identifier value property must have a value.
BTS_E_MISSING_SRCORGID | 0x1236 | The Channel SourceOrganization property must have a value.
BTS_E_APPLICATION_UNIQUE_ID | 0x1237 | The application identifier must be a unique identifier.
BTS_E_APPLICATION_FOREIGN_OWNERID | 0x1238 | The organization cannot be removed because it is referred to by an application.
BTS_E_APPLICATION_UNIQUE_NAME | 0x1239 | For applications within this organization, the application name must be a unique name.
BTS_E_CHANNEL_UNIQUE_ID | 0x123A | The channel identifier must be a unique identifier.
BTS_E_CHANNEL_UNIQUE_NAME | 0x123B | The channel name must be a unique name.
BTS_E_CHANNEL_FOREIGN_INPDOCID | 0x123D | The inbound document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_OUTDOCID | 0x123E | The output document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_PORTGROUPID | 0x123F | The distribution list cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_SRCORGID | 0x1240 | The source organization cannot be removed because it is used by a channel.
BTS_E_ENVELOPE_INVALIDFORMAT | 0x1241 | The only valid envelope-format strings are: Custom, Custom XML, EDIFACT, Flatfile, X12, and Reliable. The previously specified format will remain unchanged.
BTS_E_CHANNEL_FOREIGN_CONTROLNUMID | 0x1242 | The control number cannot be removed because it is used by an channel.
BTS_E_PORT_UNIQUE_ID | 0x1243 | The messaging port identifier must be a unique identifier.
BTS_E_PORT_UNIQUE_NAME | 0x1244 | The messaging port name must be a unique name.
BTS_E_CHANNEL_FOREIGN_SRCAPPID | 0x1247 | The source application cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTORGID | 0x1248 | The destination organization cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_DSTALIASID | 0x1249 | The destination identifier cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_ENVID | 0x124A | The envelope cannot be removed because it is used by a messaging port.
BTS_E_CHANNEL_FOREIGN_SRCALIASID | 0x124B | The source identifier cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTAPPID | 0x124C | The destination application cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_CONTROLNUMID | 0x124D | The control number cannot be removed because it is used by a messaging port.
BTS_E_DOCUMENT_MISSING_REFERENCE | 0x124E | The Reference property must have a value if the TrackingFields or PropertySet properties are specified.
BTS_E_DOCUMENT_REFERENCE_CANT_BE_CHANGED | 0x124F | A document reference cannot be modified if it is referred to by a channel.
BTS_E_PORTGROUP_NOTOPENGRP | 0x1251 | Messaging ports that are set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW) cannot be used in distribution lists.
BTS_E_PORTGROUP_DUPLICATEPORT | 0x1252 | A duplicate messaging port cannot be added to the distribution list.
BTS_E_OUTPUTCONFIG_UNIQUE_ID | 0x1255 | The output configuration identifier must be a unique identifier.
BTS_E_OUTPUTCONFIG_FOREIGN_PORTID | 0x1256 | The messaging port cannot be removed because it is used by a channel.
BTS_E_OUTPUTCONFIG_FOREIGN_CHANNELID | 0x1257 | The channel cannot be removed because it is used by a messaging port.
BTS_E_PORT_LOOPBACK_RELIABLE | 0x125F | A messaging port with the transport type Loopback cannot be associated with an envelope that uses the Reliable format.
BTS_E_ALIAS_RESERVEDWORD | 0x1262 | Group is a reserved word for qualifiers and cannot be used as the qualifier for an identifier.
BTS_E_DOCUMENT_NEEDMAPREF | 0x1268 | A map reference is required to transform the inbound document to the outbound document if the document specifications are different.
BTS_E_PORT_DESTORGNOTSPECIFIED | 0x126C | This messaging port must have a destination organization specified.
BTS_E_PORT_MISSING_PRITRANSTYPE | 0x126D | You must specify a primary transport type for this messaging port. The primary transport cannot be blank, and it cannot be an open destination.
BTS_E_PORT_MISSING_PRITRANSADDRESS | 0x126E | This messaging port must have a primary transport address specified.
BTS_E_PORT_INVALID_SECTRANSTYPE | 0x126F | The secondary transport type cannot be set to Open, Loopback, or to BizTalk Orchestration Activation.
BTS_E_PORT_MISSING_SECTRANSADDRESS | 0x1270 | The secondary transport address is missing, although the transport type has been defined.
BTS_E_PORT_INVALID_ORG | 0x1271 | The organization specified in this messaging port does not exist.
BTS_E_PORT_INVALID_ALIAS | 0x1272 | The identifier specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_APPLICATION | 0x1273 | The application specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_ENVELOPE | 0x1274 | The envelope specified in this messaging port does not exist.
BTS_E_PORT_OPEN_DESTORG_SPECIFIED | 0x127C | An open-destination messaging port cannot have a destination organization specified.
BTS_E_PORT_OPEN_DESTAPP_SPECIFIED | 0x127E | An open-destination messaging port cannot have a destination application specified.
BTS_E_PORT_OPEN_PRITRANSTYPEOPEN | 0x127F | An open-destination messaging port must specify a primary transport type as an open destination.
BTS_E_PORT_OPEN_PRITRANSADDRESS | 0x1280 | An open-destination messaging port cannot specify a primary transport address.
BTS_E_PORT_OPEN_PRITRANSPARAMETER | 0x1281 | An open-destination messaging port cannot specify a primary transport parameter.
BTS_E_PORT_OPEN_SECTRANSTYPE | 0x1282 | An open-destination messaging port cannot specify the secondary transport type.
BTS_E_PORT_OPEN_SECTRANSADDRESS | 0x1283 | An open-destination messaging port cannot specify a secondary transport address.
BTS_E_PORT_OPEN_SECTRANSPARAMETER | 0x1284 | An open-destination messaging port cannot specify a secondary transport parameter.
BTS_E_PORT_OPEN_ENCRYPTIONTYPE | 0x1285 | An open-destination messaging port cannot specify an encryption type.
BTS_E_PORT_OPEN_ENCRYPTIONREF | 0x1286 | An open-destination messaging port cannot specify an encryption reference.
BTS_E_PORT_SIGNATTYPEANDREFERENCE | 0x1287 | The signature type is specified; however, the signature reference is missing.
BTS_E_PORT_ENCRYPTIONTYPEANDREFERENCE | 0x1288 | The encryption type is specified; however, the encryption reference is missing.
BTS_E_ALIAS_DEFAULT | 0x128A | One and only one default identifier is required and permitted at all times. The default identifier cannot be missing, nor can it be duplicated.
BTS_E_ALIAS_AUTO | 0x128B | The alias, which uses the name "Organization" and the qualifier "OrganizationName," is a system-created alias. You cannot remove this alias, create another alias that uses the same name and qualifier, or change any fields of this alias.
BTS_E_TRANSPORT_SYNTAXAPPINT | 0x128E | Either the syntax of this address is incorrect for the Application Integration Component transport type property, or the component is not registered, or else the component is not a valid AIC component.
BTS_E_TRANSPORT_SYNTAXFILE | 0x128F | The syntax of this address is incorrect for the File transport type.
BTS_E_TRANSPORT_SYNTAXHTTP | 0x1291 | The syntax of this address is incorrect for the HTTP transport type.
BTS_E_TRANSPORT_SYNTAXHTTPS | 0x1292 | The syntax of this address is incorrect for the HTTPS transport type.
BTS_E_TRANSPORT_SYNTAXSMTP | 0x1293 | The syntax of this address is incorrect for the SMTP transport type.
BTS_E_TRANSPORT_SYNTAXNONE | 0x1294 | You cannot specify a transport address or a parameter when the transport type is set to None, or when the source or destination are Open.
BTS_E_TRANSPORT_LOCALHOST | 0x1295 | The transport address cannot contain the word "localhost". Replace it with the computer name instead.
BTS_E_PORTGROUP_LASTPORT | 0x1296 | The messaging port cannot be removed if it is the last remaining messaging port in a distribution list.
BTS_E_TRANSPORT_MISSING_PRISMTPPARAMETER | 0x1298 | A primary transport parameter is required for the SMTP transport type.
BTS_E_TRANSPORT_MISSING_SECSMTPPARAMETER | 0x1299 | A secondary transport parameter is required for the SMTP transport type.
BTS_E_NAMEREQ | 0x129A | The Name property must always be at least one character long.
BTS_E_INVALIDTIMEFORMAT | 0x129B | The time format is not valid. Enter the time, in hours, in a 24-hour format (from 0 to 23 hours). You can enter only hours, not minutes or seconds.
BTS_E_TIMESTAMP | 0x129C | This object cannot be saved or removed because the timestamp has changed.
BTS_E_PORTGROUP_MISSING_PORT | 0x129D | A distribution list must contain at least one messaging port.
BTS_E_ORGANIZATION_REMOVEDEFAULT | 0x129E | The home organization cannot be removed.
BTS_E_PORT_SERVICEWINDOW_EQUAL | 0x129F | The start time (FromTime) and end time (ToTime) for the service window cannot be equal.
BTS_E_ENVELOPE_REFERENCENOTALLOWED | 0x12A2 | The reference property cannot be set for this envelope format.
BTS_E_ENVELOPE_REFERRED | 0x12A3 | This envelope cannot be removed because it is used in a messaging port or channel.
BTS_E_TRANSPORT_LOOPBACK_SECTYPECONFLICT | 0x12A4 | The secondary transport type cannot be specified for the messaging port if the primary transport type is set to Loopback.
BTS_E_TRANSPORT_LOOPBACK_SECADDRESSCONFLICT | 0x12A5 | The secondary transport address cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_LOOPBACK_SERVICEWINDOW | 0x12A6 | The service window cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_OPEN_DESTALIAS_SPECIFIED | 0x12A7 | An open-destination messaging port cannot have a destination identifier specified.
BTS_E_PORT_OPEN_SERVICEWINDOW | 0x12A8 | The service window cannot be specified for the messaging port if the messaging port is an open-destination messaging port.
BTS_E_PORT_SERVICEWINDOWTIMES | 0x12AA | To use a service window, you must set both the From and To times or else, do not set either time.
BTS_E_TRANSPORT_LOOPBACK_PRIADDRESSCONFLICT | 0x12AC | A primary transport address cannot be specified for the messaging port if the transport type is Loopback.
BTS_E_PORT_ORGCHANGE | 0x12AD | The destination-organization identifier cannot be changed after it is created.
BTS_E_PORT_OPENNESSCHANGE | 0x12AE | The Openness property cannot be changed after it is created.
BTS_E_PORT_SIGNATURE_CHANNEL_CERTREF | 0x12AF | The signature-certification reference for a channel does not match the signature type for the port.
BTS_E_PORT_SIGNATURE_CHANNEL_OPEN | 0x12B0 | A messaging port that contains a signature type cannot be connected to an open-source channel. Also, a messaging port that is already connected to an open-source channel cannot have a signature type assigned to it.
BTS_E_CHANNEL_OPEN_SRCORG | 0x12B1 | An open-source channel cannot specify a source organization.
BTS_E_PORTGROUP_LOOPBACKPORT | 0x12B2 | A messaging port that uses the Loopback transport type cannot be added to a distribution list. Also, the transport type of a messaging port that is already included in a distribution list cannot be changed to Loopback.
BTS_E_CHANNEL_OPEN_SRCALIAS | 0x12B3 | An open-source channel cannot have a source identifier specified.
BTS_E_CHANNEL_OPEN_SRCAPP | 0x12B4 | An open-source channel cannot specify a source application.
BTS_E_CHANNEL_PORTORPORTGROUP | 0x12B5 | Either a messaging port or a distribution list, but not both, must be specified in a channel.
BTS_E_CHANNEL_MISSING_DOCUMENT | 0x12B6 | Both input and output documents are needed in a channel.
BTS_E_CHANNEL_INVALIDTYPE | 0x12B7 | A channel cannot be set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_CHANNEL_MISSING_OUTDOCREFERENCE | 0x12B8 | If the inbound document definition for a channel has a reference to a specification, the outbound document definition must also have a reference to a specification.
BTS_E_CHANNEL_TRACKFIELDSCANTBESET | 0x12B9 | If the inbound document definition for a channel does not have a reference to a specification, the tracking fields cannot be set.
BTS_E_CHANNEL_EXPRESSIONCANTBESET | 0x12BA | If the inbound document definition for a channel does not have a reference to a specification, the channel-filtering expressions cannot be set.
BTS_E_CHANNEL_MAPREFCANTBESET | 0x12BB | If the inbound document definition for a channel does not have a reference to a specification then a reference to a map cannot be set.
BTS_E_CHANNEL_NOTSAME_INPDOC_OUTDOC | 0x12BC | If the inbound document definition for a channel does not have a reference to a specification then the outbound document handle should be the same of inbound document handle.
BTS_E_CHANNEL_OPEN_RECEIPTCONFLICT | 0x12BD | Channels that are set from an open source or set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW) cannot be receipt channels.
BTS_E_CHANNEL_RECEIPT_RECEIPTTIMEOUT | 0x12BE | The Expect Receipt Timeout property cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CANTSETRECEIPTCHANNEL | 0x12BF | An identifier cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CONFLICT | 0x12C0 | In a receipt channel, the source specification from the original channel must be used as the destination specification, and the destination specification from the original channel must be used as the source specification.
BTS_E_CHANNEL_SRCORGDEFAULT | 0x12C1 | If the channel is set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW), the source organization must be the home organization.
BTS_E_CHANNEL_PORT_BOTHOPEN | 0x12C2 | Both the channel and messaging port cannot be set to Open.
BTS_E_CHANNEL_RECEIPT_INVALID | 0x12C3 | The Receipt Channel and Expect Receipt Timeout properties cannot be set for an open-source channel. These properties also cannot be set if the messaging port is set to an open destination, set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW), or if the messaging port uses the Loopback transport type.
BTS_E_CHANNEL_RECEIPTMATCHNOTFOUND | 0x12C4 | The corresponding receipt channel for this channel could not be found.
BTS_E_CHANNEL_RECEIPT_OPENPORT | 0x12C5 | A receipt channel can be connected only to messaging ports that are not open messaging ports.
BTS_E_CHANNEL_RECEIPT_LOOPBACKPORT | 0x12C6 | A receipt channel cannot be connected to a messaging port that uses the Loopback transport type. Also, the transport type of a messaging port that is already connected to a receipt channel cannot be changed to Loopback.
BTS_E_CHANNEL_CANNOTUPDATE | 0x12C8 | After a channel is created, the following properties cannot be changed: source organization, openness designation, messaging port, distribution list, and receipt channel designation.
BTS_E_PORT_INVALIDOPENNESS | 0x12C9 | A messaging port cannot be set to an open source; nor can it be set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW).
BTS_E_CHANNEL_CONTROLNUMBER_ENVELOPEFORMATMISMATCH | 0x12CA | If the envelope format for the messaging port is X12 or EDIFACT, the control-number value on the channel must be set.
BTS_E_PORT_ENVELOPE_SERIALIZERCLSID | 0x12CB | If the envelope format for the messaging port is set to Custom, a class identifier (CLSID) for the serializer component must be specified.
BTS_E_CHANNEL_AIC_TRANSPORTCLSID | 0x12CD | If the transport type associated with the channel is set to Application Integration Component, a class identifier (CLSID) must be specified for the primary transport.
BTS_E_CHANNEL_RECEIPT_PORTGROUP | 0x12CE | If a channel is connected to a distribution list, a receipt channel cannot be specified.
BTS_E_COMPONENTREQUIRES2AGGREGATEFTM | 0x12CF | To be a valid object in the BizTalk Object Model, this custom component must aggregate the free-threaded marshaler.
BTS_E_CERTREFNOTFOUND | 0x12D1 | Either the certificate reference could not be found in MY or BIZTALK stores or it is not valid.
BTS_E_NODOC | 0x12D2 | The Document Definition has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOENV | 0x12D3 | The envelope has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOCHANNEL | 0x12D4 | The channel has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_INVALIDREFERENCE | 0x12D5 | Either the WebDAV repository reference does not contain a valid HTTP address or it contains the text "localhost." Please provide either a valid HTTP address or replace the text "localhost" with the actual computer name.
BTS_E_CANNOTCONTAINSUBOBJECTS | 0x12D6 | The property set and delimiter objects cannot contain any subobjects.
BTS_E_INVALIDTRACKFIELDS | 0x12D7 | The "x_custom_search" field in the tracking field dictionary must be a simple list.
BTS_E_CHANNEL_INVALID_ORG | 0x12D8 | The organization specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_ALIAS | 0x12D9 | The identifier specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_APPLICATION | 0x12DA | The application specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_INPDOCID | 0x12DB | The input document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_OUTDOCID | 0x12DC | The output document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_PORTGROUP | 0x12DD | The distribution list specified in this channel does not exist.
BTS_E_OBJECT_NOT_XMLSERILIZABLE | 0x12DE | The given dictionary or simplelist object must implement IPersistXML methods.
BTS_E_CHANNEL_INVALID_PORT | 0x12E0 | At least one messaging port that is referenced in this channel either does not exist or it is not associated with this channel.
BTS_E_CHANNEL_RECEIPT_VERSIGN_DECRYPT | 0x12E1 | The Verify Signature or Decrypt Encryption properties cannot be set on a receipt channel.
BTS_E_INVALID_REQUEST_CHANNEL | 0x12E2 | A channel that is connected to a distribution list cannot be used as a request channel.
BTS_E_DESTINATION_NOT_FOUND | 0x12E3 | The destination URL is not specified, and the messaging port is an open destination. Either the destination URL or a destination for the messaging port must be specified.
BTS_E_DESTINATION_CONFLICT | 0x12E4 | Both a destination URL and a destination for the messaging port cannot be specified. Specify only one of these properties.
BTS_E_ASYNC_TRANSPORT | 0x12E5 | The transport type for the request channel is not valid. Only the HTTP, HTTPS, and Application Integration Component transport types are valid for a request channel.
BTS_E_INVALID_RESPONSE_CHANNEL | 0x12E6 | The response channel can be connected only to a messaging port with a transport type set to Loopback.
BTS_E_INVALID_VERSION | 0x12E7 | The database version is incompatible with the installed version of the server. Try running setup again.
BTS_E_INVALID_SCHEMA | 0x12E8 | The document or envelope specification is not valid. Open the specification in BizTalk Editor, and then on the Tools menu, click Validate Specification. Resolve any warnings to ensure that the specification is valid.
BTS_E_CHANNEL_RECEIPTCHANNEL_PORTGROUP | 0x12E9 | A receipt channel cannot be connected to a distribution list.
BTS_E_TRANSPORT_ORCHESTRATION_OPENNESS | 0x12EA | A messaging port that uses the BizTalk Orchestration Activation transport type must have the Openness Type property set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_TRANSPORT_ORCHESTRATION_ADDRESSPARAMETER | 0x12EB | Both a primary address and a parameter are required for a messaging port that uses a BizTalk Orchestration Activation transport type.
BTS_E_ORCHESTRATION_INVALIDORG | 0x12EC | A messaging port that uses a BizTalk Orchestration Activation transport type must have the home organization set as the destination organization.
BTS_E_INVALID_FILTEREXPRESSION | 0x12ED | The channel filtering expression is not valid. Make sure that the node-path expression is valid.
BTS_E_MULTIPLEDOCDEFSFORPROPSET | 0x12EE | Multiple document definitions were found for the given property set. Only a single document definition for a given property set is expected.
BTS_E_INVALID_PROPSET | 0x12EF | The PropertySet cannot contain non-string element values.
BTS_E_DBSCHEMA_MISMATCH | 0x1300 | The existing Database Schema is not compatible with the current version of the product. You must delete the existing database.
BTS_E_UNEXPECTED_INSTALL | 0x1301 | The existing Database Schema is newer than the current version that is installed. Setup will rollback the changes.
CIS_E_DOCSCHEMA_ATTRIB_MISSING | 0x1400 | The "%3" attribute is missing in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB_VALUE | 0x1401 | The "%3" attribute value "%4" is not valid. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_EMPTY_ELEMENT | 0x1402 | The "%3" element cannot be empty. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_CHILD_ELEMENT | 0x1403 | The "%3" element cannot be a child of the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MULTIPLE_INFO | 0x1404 | Only one record description or one field description is allowed for each element declaration. One of the descriptions must be removed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_FIELD_DECL | 0x1405 | The root node cannot contain a field. The root node of the document must contain a record. Verify that the root node in your document is declared as a record. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_LEN_DECL | 0x1406 | The minimum length value must be no greater than the maximum length value. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_POSLEN_DECL | 0x1407 | The value of the start position must be no greater than the value of the end position. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO_YET | 0x1408 | A field description or record description must be specified before references to other elements. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_SCHEMATYPE_XML | 0x1409 | Only non-XML document specifications are allowed for this format. The schema_type attribute has the value "xml". Verify that the specification selected is a non-XML specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO | 0x140A | No record information or field information was found in the "%3" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB | 0x140B | The "%3" attribute is not allowed in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MISSING_ELEM_DECL | 0x140C | There is no element with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_MISSING_ATTR_DECL | 0x140D | There is no attribute with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_INVALID_POSITIONAL_DECL | 0x140E | The "%1" record cannot be a child of the "%2" positional record. Only fields can be children of positional records.
CIS_E_DOCSCHEMA_INVALID_RECORD_CHILDREN | 0x140F | The children of the "%1" delimited record must either be all records or all fields. Records with no tag identifier cannot have mixed records and fields as children.
CIS_E_DOCSCHEMA_NO_RECORD_CHILDREN | 0x1410 | The "%1" delimited record must have at least one child. Records with no tag identifier must have at least one child, or else the record cannot be found in a non-XML format. Either add a child to the record, give the record a tag identifier, or remove the record from the specification.
CIS_E_DOCSCHEMA_MISSING_RECORD_TAG | 0x1411 | The "%1" delimited record is marked to repeat but it does not have a tag identifier. Only the last record in a document specification is allowed to have this property. If this record appears only once in the document, then mark it as a single occurrence. Otherwise, give the record a tag identifier that tells the server where to look for the next record in the specification.
CIS_E_DOCSCHEMA_NO_ROOT_ELEMENT | 0x1412 | The root-node name "%3" was not found in the specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ROOT_ELEMENT | 0x1413 | The "%3" element cannot be the root node of this document. Only <Schema> is allowed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_EMPTY_ATTRIBUTE | 0x1414 | The "%3" attribute in the "%4" element cannot be empty. Either specify a nonempty value or remove the attribute. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_REFERENCE | 0x1415 | The "%1" record has an illegal cyclic path through the "%2" record. The only cyclic reference allowed for a record is if the record has a tag identifier that allows the system to terminate the search. Either remove the cyclic reference or add an appropriate tag identifier to the document specification.
CIS_E_DOCSCHEMA_LOADFAILED | 0x1416 | The specification failed to load. See the following messages for details.
CIS_E_DOCSCHEMA_MISSING_NS | 0x1417 | Valid BizTalk Server specifications for non-XML documents must have the namespace declarations of "urn:schemas-microsoft-com:BizTalkServer", "urn:schemas-microsoft-com:datatypes", and "urn:schemas-microsoft-com:xml-data" in the root node of the specification.
CIS_E_DOCSCHEMA_INVALID_SCHEMA_USAGE | 0x1418 | The specification referenced in the "%1" document is not compatible with the "%2" format. Select a specification that is compatible with this format, or if this is a valid specification for the defined format, assign "%2" to the "standard" property on this specification.
CIS_E_DOCSCHEMA_MISSING_POSLEN_DECL | 0x1419 | The "%3" field is missing a start and end position, and is referenced in the "%4" positional record. Specify valid start and end positions for this field. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_DUPLICATE_NAMESPACE | 0x141A | The duplicate namespace declaration "%3" has been found. Please remove the duplicate reference to same namespace. Line: %1, Pos: %2.
CIS_E_PARSER_EOF | 0x1430 | The end of the file was reached prematurely.
CIS_E_PARSER_MISSING_TAG | 0x1431 | The required "%1" record was not found in the inbound document.
CIS_E_PARSER_MISSING_FIELD | 0x1432 | The required field "%1" in the "%2" record was not found in the inbound document.
CIS_E_PARSER_FAILURE | 0x1433 | The parser failed to convert the document due to processing errors. See the following messages for details.
CIS_E_PARSER_INVALIDDATA | 0x1434 | The parser cannot match the current position of the data with the specification. Verify that the version of this specification is consistent with the version of the data and that the root parsing tags match.
CIS_E_PARSER_NO_DATA | 0x1435 | There is no data that can be parsed on the dictionary. Verify that either the "working_data" field or the "file_path" field contains nonempty data.
CIS_E_PARSER_INVALID_ENVNAME | 0x1436 | The envelope name "%1" does not reference a valid envelope for the BizTalk Server parser. Either the envelope name does not exist or there is an envelope specification attached that is not valid.
CIS_E_PARSER_NO_COMPONENTS_FOUND | 0x1439 | No parser component recognizes the data. This might be caused by an interchange specification that is missing or not valid, or it might be caused by data that is not valid. Verify that both the interchange specification (if one is specified) and the data match.
CIS_E_PARSER_COMPONENT_FAILED | 0x1440 | While trying to process document #%4 during submission "%1", the parser component named "%2" failed on the method "%3" with the error code "%5". Possible causes are: the component found unexpected data in the incoming stream; a document specification could not be found given the data; or an internal component failure occurred. If this problem continues, remove this component from the valid list of parser components or contact your system administrator.
CIS_E_PARSER_DOCUMENT_FAILED | 0x1441 | Document #%4 within submission "%1" was returned as a document that was not valid from the parser component named "%2". The most frequent cause is a document specification that is not valid or else the component was unable to determine the necessary routing fields. Verify that the proper specification is defined for this data.
CIS_E_PARSER_INVALID_DATETIME | 0x1442 | The "%1" date or time format for the tag "%3" does not match the format of the "%2" data extracted from the incoming data.
CIS_E_PARSER_INVALID_COMPONENT | 0x1443 | Within submission "%1", the parser component named "%2" could not be loaded. Verify that this component can be run in a stand-alone executable and that the server has sufficient permissions to start it.
CIS_W_PARSER_SKIPPED_COMPONENT | 0x1444 | The parser was unable to probe the specified component. This component will be skipped.
CIS_E_PARSER_UNUSEABLE_DOCNAME | 0x1445 | The parser cannot use the document "%1" as it has no specification. Please attach a specification to this document or specify a different one.
CIS_E_PARSER_CONTROL_NUMBER_MISMATCH | 0x1446 | The control number of segment "%1" (%2) does not match that of segment "%3" (%4).
CIS_E_PARSER_DOCCOUNT_INCORRECT | 0x1447 | The document or segment count contained in tag "%1" (%2) does not match the number of documents or segments processed (%3).
CIS_E_PARSER_X12_ISA_PARSE_FAILED | 0x1448 | The parser cannot parse the ISA section of the X12 document. This segment is fixed-width; if fields in this segment do not have correct length, the parsing will fail because the delimiters are picked up from the wrong offsets.
CIS_E_PARSER_MIN_LENGTH | 0x1449 | The data contains a field value ("%1") that doesn't meet minimum length requirement for tag "%2" (minimum length is %3).
CIS_E_PARSER_MAX_LENGTH | 0x144A | The data contains a field value ("%1") that doesn't meet maximum length requirement for tag "%2" (maximum length is %3).
CIS_E_PARSER_NO_DATA_CONSUMED | 0x144B | No data was read by the parser. Make sure that the code page is set correctly for the data. If the data is UNICODE, make sure that there is no byte order mark (0xFFFE or 0xFEFF) appears at the beginning of the file.
CIS_E_PARSER_UNSUPPORTED_EDIFACT_SYNTAX | 0x144C | EDIFACT documents with the "UNOX" or the "UNOY" syntax identifier are not supported.
CIS_E_PARSER_DATA_REMAINING | 0x144D | Additional data in the document instance was not parsed. Make sure that the document instance you want to validate contains only one document.
CIS_E_PARSER_MISSING_DELIMITER | 0x144E | While parsing record "%1", the parser cannot find the required delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_LEADING_DELIMITER | 0x144F | While parsing record "%1", the parser cannot find the required leading delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_TRAILING_DELIMITER | 0x1450 | While parsing record "%1", the parser cannot find the required trailing delimiter: "%2" (%3).
CIS_E_VALIDATE_GROUP_RULE | 0x1451 | In record "%1", if any of the following fields exist, then all must exist: %2
CIS_E_VALIDATE_GROUP_ALL | 0x1452 | In record "%1", all of the following fields must exist: %2
CIS_E_VALIDATE_GROUP_ONE | 0x1453 | In record "%1", only one of the following fields can exist: %2
CIS_E_PARSER_INVALID_WRAP_CHAR_FOUND | 0x1454 | While parsing record "%1", the parser found an occurrence of a wrap character, "%2", that is not valid.
CIS_E_VALIDATE_GROUP_ANY | 0x1455 | In record "%1", one or more of the following fields must exist: %2
CIS_E_PARSER_EXTRA_DELIMITER | 0x1456 | While parsing record "%1", the parser found the following extra delimiter: "%2".
BTS_E_DOCUMENT_HAS_INVALID_MANIFEST | 0x1457 | Error parsing the manifest.
CIS_E_ADMIN_CACHE_PARSERS | 0x1504 | The latest modification date from the administration parser table could not be loaded.
CIS_E_ADMIN_INIT_CACHE | 0x1505 | The configuration data in the global cache could not be initialized.
CIS_E_ADMIN_RELOAD_CACHE | 0x1506 | The configuration data from the database could not be reloaded.
CIS_E_ADMIN_PARSER_GETCLSID | 0x1507 | The class identifiers (CLSIDs) of the parser records could not be loaded.
CIS_E_ADMIN_CACHE_OBJECTNOTCREATED | 0x1509 | The administration cache cannot be created.
CIS_E_ADMIN_CACHE_INITIALLOAD | 0x150A | The configuration cache data from the database could not be loaded.
CIS_E_ADMIN_ADD_SERVER_ACCESS_DENIED | 0x150B | Server "%1" cannot be added because access to the "%2" is denied.
CIS_E_ADMIN_ADD_SERVER_NO_SERVICE | 0x150C | Server "%1" cannot be added because BizTalk Server is not installed on the computer.
CIS_E_ADMIN_DELETE_SERVER_NO_ACCESS | 0x150D | The "%1" server cannot be deleted because access to the "%2" service is denied and the service cannot be stopped.
CIS_E_ADMIN_DELETE_GROUP_SERVER_RUNNING | 0x150E | This server group cannot be deleted because the "%1" server is still running.
CIS_E_ADMIN_DELETE_GROUP_SERVER_ACCESS_DENIED | 0x150F | This server group cannot be deleted because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_NOGROUP | 0x1512 | The specified administration group does not exist.
CIS_E_ADMIN_NOSERVER | 0x1513 | The specified administration server does not exist.
CIS_E_ADMIN_NORECEIVESERVICE | 0x1514 | The specified administration receive function does not exist in the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_RECEIVESERVICE | 0x1515 | An unexpected error occurred while trying to remove the "%1" receive function from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_GROUP | 0x1516 | An unexpected error occurred while trying to remove the "%1" group from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_SERVER | 0x1517 | An unexpected error occurred while trying to remove the "%1" server from the database.
CIS_E_ADMIN_NOTIMESTAMPS | 0x151A | The specified administration timestamps object does not exist in the database.
CIS_E_ADMIN_REFRESH_THREAD_ERROR | 0x151B | The configuration refresh thread encountered an error while loading the configuration data.
CIS_E_ADMIN_REFRESH_THREAD_EXIT | 0x151C | The configuration refresh thread cannot load the configuration data because of a previous error.
CIS_E_ADMIN_RECSVC_GENERAL | 0x151D | The configuration refresh thread cannot set up one or more receive functions. This might be because SQL Server is not started.
CIS_E_ADMIN_CREATE_GROUP | 0x1529 | The server group cannot be created because "%1".
CIS_E_ADMIN_LOAD_GROUP_PROPS | 0x152A | The group properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_GROUP_PROPS | 0x152B | The group properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_GROUP | 0x152C | The server group cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINGROUPS | 0x152D | All server groups cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERS | 0x152E | All servers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETRECEIVESERVICES | 0x152F | All receive functions for the "%1" group cannot be retrieved from database because "%2".
CIS_E_ADMIN_GETPARSERS_IN_GROUP | 0x1531 | All parsers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETLOCALSMTPHOST | 0x1538 | The local SMTP host cannot be retrieved because "%1".
CIS_E_ADMIN_CREATE_SERVER | 0x1539 | The server cannot be created because "%1".
CIS_E_ADMIN_LOAD_SERVER_PROPS | 0x153A | The server properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_SERVER_PROPS | 0x153B | The server properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_SERVER | 0x153C | The server cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINSERVRES | 0x153D | All servers cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERBYNAME | 0x153E | The server properties for "%1" cannot be retrieved because "%2".
CIS_E_ADMIN_DECRYPT_PASSWORD | 0x1540 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_EXEC_COMMMAND_ON_PARSER | 0x154F | The SQL command "%1" on the parser database table cannot be executed because "%2".
CIS_E_ADMIN_PREPOROCESSOR_NOT_SUPPORTED_BY_HTTP_RF | 0x155C | The "%1" property is not supported for the HTTP receive function in Submit to File mode.
CIS_E_ADMIN_CREATE_RECEIVESERVICE | 0x155D | The receive function cannot be created because "%1".
CIS_E_ADMIN_LOAD_RECEIVESERVICE_PROPS | 0x155E | The receive function properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_RECEIVESERVICE_PROPS | 0x155F | The receive function properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_RECEIVESERVICE | 0x1560 | The receive function cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICES | 0x1561 | All receive functions cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICESINSERVER | 0x1562 | All receive functions cannot be retrieved for the "%1" server because "%2".
CIS_E_ADMIN_LOAD_TIMESTAMPS | 0x1563 | All timestamps cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETSQCONNECT | 0x1570 | The Shared Queue database connection string cannot be retrieved from the database.
CIS_E_ADMIN_GETCOMPUTERNAME | 0x1571 | The name of the local computer cannot be retrieved. Internally, BizTalk Server is using "localhost" as the computer name.
CIS_E_ADMIN_MIN_CONSTRAINT | 0x1573 | The size of the "%1" property is less than the minimum required length for "%2".
CIS_E_ADMIN_MAX_CONSTRAINT | 0x1574 | The size of the "%1" property is greater than the maximum length allowed for "%2".
CIS_E_ADMIN_GET_MGMTDB_CONNECT_PROPS | 0x1575 | The BizTalk Messaging Management database properties cannot be retrieved.
CIS_E_ADMIN_KEY_EMPTY | 0x1576 | The key to the database table, property "%1", is empty.
CIS_E_ADMIN_COCREATE_IN_CREATE | 0x1577 | An instance of the "%1" object could not be created while creating a new "%2" object.
CIS_E_ADMIN_ADO_OPEN_CONNECTSTRING | 0x1578 | The connection to the BizTalk Messaging Management database could not be opened.
CIS_E_ADMIN_COCREATE_IN_LOAD | 0x1579 | An instance of the "%1" object could not be created while loading the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_SAVE | 0x1580 | An instance of the "%1" object could not be created while saving the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_REMOVE | 0x1581 | An instance of the "%1" object could not be created while trying to remove the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETALL | 0x1582 | An instance of the "%1" object could not be created while trying to get all instances of "%2".
CIS_E_ADMIN_COCREATE_IN_GETALL_INSERVER | 0x1583 | An instance of the "%1" object could not be created while trying to get all instances of the "%2" object in the "%3" server.
CIS_E_ADMIN_GET_PROP | 0x1584 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_CLOSE_ADO_CONNECTION | 0x1585 | The ADO connection cannot be closed.
CIS_E_ADMIN_CLOSE_ADO_RECORDSET | 0x1586 | The ADO record set cannot be retrieved.
CIS_E_ADMIN_ENCRYPT_PASSWORD | 0x1587 | The "%1" property cannot be processed.
CIS_E_ADMIN_COCREATE_IN_GETALLNAMES | 0x1588 | An instance of the "%1" object could not be created while trying to get the names of all the "%2" object instances.
CIS_E_ADMIN_COCREATE_IN_GETOTHERS_OF_GROUP | 0x1589 | An instance of the "%1" object could not be created while trying to get all instance of the "%2" object in the "%3" group.
CIS_E_ADMIN_COCREATE_IN_GET_SMTPHOST | 0x158A | An instance of the "%1" object could not be created while trying to get "%2" for the local server.
CIS_E_ADMIN_COCREATE_IN_GET_SQ_CONNECTSTRING | 0x158B | An instance of the "%1" object could not be created while trying to get the Shared Queue parameters of "%2" in order to connect to the database.
CIS_E_ADMIN_COCREATE_SERVER_BYNAME | 0x158C | An instance of the "%1" object could not be created while trying to get the properties of the "%2" server instance of the "%3" class.
CIS_E_ADMIN_GETSQCONNECT_IN_OPEN | 0x158D | The Shared Queue database connection string could not be retrieved from the database because "%1".
CIS_E_ADMIN_COCREATE_EXEC_SQL_COMMAND_ON_PARSER | 0x158E | An instance of the "%1" object could not be created while trying to execute a SQL command on the "%2" database table.
CIS_E_ADMIN_COCREATE_PARSER_CLSIDS_IN_GROUP | 0x158F | An instance of the "%1" object could not be created while retrieving the class identifiers (CLSIDs) for the parsers that belong to the "%2" group.
CIS_E_ADMIN_INVALID_ARGUMENT | 0x1590 | An unexpected internal error occurred. An invalid "%1" argument was used when calling the "%2" method.
CIS_E_ADMIN_MAX_ENUM_CONSTRAINT | 0x1591 | The value of the "%1" property is greater than the maximum value allowed for "%2".
CIS_E_ADMIN_MIN_ENUM_CONSTRAINT | 0x1592 | The value of the "%1" property is smaller than the minimum value allowed for "%2".
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BSTR | 0x1593 | The type of the "%1" property could not be changed to a string.
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BOOL | 0x1594 | The type of the "%1" property could not be changed to Boolean.
CIS_E_ADMIN_COCREATE_IN_ENUMINSTANCES | 0x1595 | An instance of the "%1" object could not be created while enumerating instances of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_PUTINSTANCE | 0x1596 | An instance of the "%1" object could not be created while setting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETOBJECT | 0x1597 | An instance of the "%1" object could not be created while getting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_DELETEINSTANCE | 0x1598 | An instance of the "%1" object could not be created while deleting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPROPS | 0x1599 | An instance of the "%1" object could not be created while loading properties for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPARSERS | 0x159B | An instance of the "%1" object could not be created while loading parsers from a database for an instance the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_REGISTRY | 0x159C | An instance of the "%1" object could not be created while setting parsers from the registry for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_CLIENT | 0x159D | An instance of the "%1" object could not be created while setting parsers from the client for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_REFRESHPARSERLIST | 0x159E | An instance of the "%1" object could not be created while refreshing the parser list for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_MOVETOSUSPENDED_Q | 0x159F | An instance of the "%1" object could not be created while moving an instance of "%2" to the Suspended queue.
CIS_E_ADMIN_COCREATE_IN_RESUBMIT | 0x15A0 | An instance of the "%1" object could not be created while resubmitting an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWDOC | 0x15A2 | An instance of the "%1" object could not be created while viewing a document instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWERRORDESC | 0x15A3 | An instance of the "%1" object could not be created while viewing the error description of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWINTERCHANGE | 0x15A4 | An instance of the "%1" object could not be created while viewing the interchanges of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_FREEINTERCHANGES | 0x15A5 | An instance of the "%1" object could not be created while freeing the interchanges for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STARTSERVER | 0x15A6 | An instance of the "%1" object could not be created while starting the server for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STOPSERVER | 0x15A7 | An instance of the "%1" object could not be created while stopping the server for an instance of a "%2".
CIS_E_ADMIN_NO_DELETE_SERVER_IN_RECVSERVICE | 0x15A8 | The "%1" server cannot be deleted because it is the processing server for at least one receive function.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_RUNNING | 0x15A9 | The server group properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_ACCESS_DENIED | 0x15AA | The server group properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_RUNNING | 0x15AC | The server properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_ACCESS_DENIED | 0x15AD | The server properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_READ_ONLY_PROP | 0x15AE | The "%1" property cannot be changed. It is a read only property.
CIS_E_ADMIN_DIFFERENT_ROOT | 0x15AF | The "%1" server may already belong to a different BizTalk Server installation.
CIS_E_ADMIN_NOT_RESUBMITABLE | 0x15B0 | This Suspended queue item cannot be submitted again.
CIS_E_ADMIN_DBCONNECT | 0x15B1 | BizTalk Server failed to access the "%1" database on the "%2" server with the database connection information.
CIS_E_ADMIN_PURGE_SUSPENDEDQ | 0x15B2 | An instance of the "%1" object could not be created while deleting documents from "%2".
CIS_E_ADMIN_REQ_PROP_MISSING | 0x15B3 | %1 cannot be NULL.
CIS_E_ADMIN_WMI_ERROR_HANDLING | 0x15B4 | The BizTalk Server WMI provider error-handling method failed. The original error description for the error that called the error-handling method is: "%1".
CIS_W_ADMIN_QUERY_FAILED | 0x15B5 | An attempt to get the Where clause values for a WMI Query failed.
CIS_E_ADMIN_INVALID_ENUM_CONSTRAINT | 0x15B6 | The value "%2" of the "%1" property is not valid.
CIS_E_ADMIN_OPENNESS_CONSTRAINT | 0x15B7 | The value "%2" of the "%1" property is not permitted when the value of the IsPassThrough property is set to TRUE.
CIS_E_ADMIN_RECEIVE_INVALID_SERVER_GROUP | 0x15B8 | the specified server and/or group is not valid
CIS_E_ADMIN_INVALID_INSTANCE_NAME | 0x15B9 | The specified instance name "%1" contains at least one of the following characters that is not valid: [ ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | \ ; " ' < > , . ? ]
BTS_E_ADMIN_GROUP_UNIQUE_NAME | 0x15BA | A BizTalk Server group with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_TIMESTAMPS_DATA_CORRUPTION | 0x15BB | Internal data corruption has been detected in the adm_TimeStamps table of the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_UNIQUE_NAME | 0x15BC | A BizTalk Server with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_FOREIGN_GROUPNAME | 0x15BD | This BizTalk Server does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_UNIQUE_NAME | 0x15BE | A BizTalk Server receive function with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_FOREIGN_GROUPNAME | 0x15BF | This BizTalk Server receive function does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_UNIQUE_HTTP_POLLING_LOCATION | 0x15C0 | An HTTP receive function polling from the same location already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_UNIQUE_ID | 0x15C1 | A BizTalk Server parser with the same CLSID and Group Name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_FOREIGN_GROUPNAME | 0x15C2 | This BizTalk Server parser does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
CIS_E_ADMIN_DB_SPROCVERSION | 0x15C3 | The "%1" database on the "%2" server does not contain the necessary database schema.
CIS_E_ADMIN_DB_VERSION | 0x15C4 | The "%1" database on the "%2" server is not compatible with the current version of the product.
CIS_E_ADMIN_CREATE_CUSTOM_COUNTER | 0x15D0 | The custom counter cannot be created because "%1".
CIS_E_ADMIN_LOAD_CUSTOM_COUNTER_PROPS | 0x15D1 | The custom counter cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_CUSTOM_COUNTER_PROPS | 0x15D2 | The custom counter cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_CUSTOM_COUNTER_PROPS | 0x15D3 | The custom counter cannot be removed because "%1".
CIS_E_ADMIN_NOCUSTOM_COUNTER | 0x15D4 | The specified custom counter could not be found. Verify that the name of the specified custom counter is correct.
CIS_E_ADMIN_UNEXPECTED_REMOVE_CUSTOM_COUNTER | 0x15D5 | An unexpected error occurred while trying to remove the "%1" custom counter from the database.
CIS_E_ADMIN_VALIDATE_COUNTER_PROPS | 0x15D6 | The custom counter cannot be validated because "%1".
CIS_E_ADMIN_GET_VALUE_CUSTOM_COUNTER_PROPS | 0x15D7 | The value of the custom counter cannot be evaluated because "%1".
CIS_E_ADMIN_UNEXPECTED_VALIDATE_CUSTOM_COUNTER | 0x15D8 | An unexpected error occurred while trying to validate the "%1" custom counter.
CIS_E_ADMIN_CUSTOM_COUNTER_ORG_CONSTRAIN | 0x15D9 | Either both %1 and %2 properties must be empty or %3 property must be empty.
CIS_E_ADMIN_WRONG_HTTP_POLLING_LOCATION | 0x15DA | The "%1" property is incorrect for the HTTP receive function ( http://... expected).
CIS_E_DTA_LOG_INTERCHANGE_DETAILS_FAILED | 0x1604 | The details of an interchange could not be logged.
CIS_E_DTA_LOG_DOCUMENT_DETAILS_FAILED | 0x1605 | The details of a document could not be logged.
CIS_E_DTA_LOG_GROUP_DETAILS_FAILED | 0x1606 | The details of a group could not be logged.
CIS_E_DTA_INIT_FAILED | 0x160A | The DTA object could not be initialized.
CIS_E_DTA_FAILED_TO_GET_ADMIN_PROPERTIES | 0x160E | The administration properties could not be obtained.
CIS_E_DTA_DATABASE_CONNECTION | 0x160F | The server could not establish connection to the Tracking database.
CIS_E_DTA_LOG_DOCUMENT_FAILED | 0x1619 | A copy of the document could not be logged.
CIS_E_DTA_LOG_INTERCHANGE_FAILED | 0x1620 | A copy of the interchange could not be logged.
CIS_E_DTA_OBJECT_IS_UNINITIALIZED | 0x1623 | The DTA initialization method must be explicitly invoked before any DTA method can be invoked.
CIS_E_DTA_FAILED_TO_COMMIT | 0x1625 | Changes could not be committed to the database.
CIS_E_DTA_FAILED_TO_LOG_SOURCE_XML | 0x1626 | The intermediate source XML could not be logged.
CIS_E_DTA_FAILED_TO_LOG_DEST_XML | 0x1627 | The intermediate destination XML could not be logged.
CIS_E_DTA_ACK_NO_ROW_FOUND | 0x162B | Acknowledgment correlation failed. The correlation key(s) given did not match any record in the Tracking database.
CIS_E_DTA_ACK_MULTIPLE_ROWS_FOUND | 0x162C | Acknowledgment correlation failed. The correlation key(s) given match more than one record in the Tracking database.
CIS_E_DTA_LOG_MIME_FAILED | 0x162D | The MIME data for submission "%1" could not be logged.
CIS_W_DTA_LOG_TRACKING_FIELD_FAILED | 0x162E | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 Actual value: %4 Possible causes are either a conversion error or an arithmetic overflow error. Check the tracking field settings in the document or channel configuration.
CIS_W_DTA_LOG_BINARY_TRACKING_FIELD_FAILED | 0x162F | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 The submission could not be logged because the corresponding XML element or attribute is set to binary type, which can only be tracked as custom type tracking field. Correct the tracking field settings in the document or channel configuration.
CIS_E_DTA_INIT_TRANSACTIONAL_SESSION | 0x1631 | The server could not create a transactional session for the Tracking object.
CIS_W_DTA_RECORD_UPDATE_FAILED | 0x1632 | An attempt to update a tracking record has failed. The record was probably deleted prior to the update action.
CIS_E_RESPONSE_DOM_LOAD_FAILED | 0x1701 | The XML-DOM could not be loaded from the response data.
CIS_E_RECEIVE_MSMQ_BYOT_CREATE_FAILED | 0x1702 | A Message Queuing receive function failed to create an IInterchange object using a Bring Your Own Transaction (BYOT) object. This may have been caused by editing the BizTalk Server COM+ application or configuring the BYOT object in its own COM+ application. This BizTalk Message Queuing receive function will be stopped.
CIS_E_RECEIVE_MSMQ_ZERO_BYTE_DOC | 0x1703 | A Message Queuing receive function read a zero byte document. This document has been discarded.
CIS_E_RECEIVE_SERVICE_FAILED | 0x1704 | There was a failure processing the "%1" receive function. Check your receive function configuration in BizTalk Server Administration.
CIS_E_INITWORKITEM | 0x1705 | There was a failure creating the internal work item. Make sure that SQL Server is running.
CIS_E_NOPIPELINE | 0x1706 | A channel with the name "%1" cannot be located.
CIS_E_OPEN_PASSTHROUGH | 0x1707 | The channel and messaging port openness type are not compatible with the submit method call.
CIS_E_DLQ_DETAILS | 0x1708 | Details about the Suspended queue could not be retrieved.
CIS_E_INVALID_OPENDEST | 0x1709 | The destination specified for the following open-destination messaging port was not valid: %1
CIS_E_SQL_MISSINGROWS | 0x170a | Rows were missing from the record returned by SQL OLEDB provider.
CIS_E_BTF_TIME_STAMP_EXPIRED | 0x170b | The BizTalk Framework document "%1" was received with an expired "%2" timestamp. This message will be discarded.
CIS_E_ACCESS_DENIED | 0x170c | The current process did not have administrative privileges and cannot access the Suspended queue.
CIS_E_BTF_ERROR_FINDING_TAG | 0x170d | The parser could either not find the BizTalk Framework tag "%1", or the tag did not have a value. This document will be moved to the Suspended queue.
CIS_E_INVALID_FORMAT | 0x170e | The "%1" envelope format is not recognized by the server. Specify a valid envelope format.
CIS_E_INVALID_MAP | 0x170f | The server could not load the map that is referenced by this channel.
CIS_E_MALFORMED_EXPR | 0x1710 | The expression "%1" is malformed and cannot be interpreted by the server.
CIS_E_DB_SHUTDOWN | 0x1711 | The server is shutting down because of a database failure.
CIS_E_SUBMIT_BLOCKED | 0x1712 | All submit calls have been blocked due to a database failure. After correcting this problem, please go to Component Services and shut down the 'BizTalk Server Interchange Application', before attempting to call any submit method.
CIS_E_CERT_NOT_FOUND | 0x1713 | The required certificate cannot be found in the certificate store.
CIS_E_NODATA | 0x1714 | The Submit method call did not contain a document or a file path.
CIS_E_TOOMUCH_DATA | 0x1715 | The Submit method call contained both a document and a file path.
CIS_E_INVALID_OPENFLAG | 0x1716 | The Submit method call was passed an openness type that is not valid. Refer to the BizTalk Server 200 Help documentation for the enumeration of these values.
CIS_E_PASSTHROUGH_PARAMS | 0x1717 | The Submit method call contained a channel along with source, destination, or document name information. Do not include source, destination, or document name information when passing the channel as a parameter within a Submit method call.
CIS_E_NOSRCID | 0x1718 | The Submit method call contained a source qualifier but no source identifier.
CIS_E_NODESTID | 0x1719 | The Submit method call contained a destination qualifier but no destination identifier.
MSG_TIMEBOMB_EXPIRED | 0x171A | Thank you for evaluating Microsoft BizTalk Server. The period for this evaluation version has ended. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server.
CIS_E_LOOPBACK | 0x171B | An attempt was made to submit a document that uses the Loopback transport type. The Loopback transport type can only be used when calling the SubmitSync method.
CIS_E_DBEXECUTE | 0x171C | The following stored procedure call failed: "%1".
CIS_E_MISSING_SMTPHOST | 0x171D | In order to use the SMTP transport, the SMTP host must be specified. To specify an SMTP host, in BizTalk Server Administration expand Microsoft BizTalk Server 200, right-click BizTalk Server Group, and then click Properties to open the BizTalk Server Group Properties dialog box. On the General tab, in the SMTP host box, specify the SMTP host that you want to use.
CIS_E_INVALIDHANDLE | 0x171E | This method expected a submission handle or an array of submission handles, but the incoming data was not valid. Verify that the parameters are correct.
CIS_E_DBCONNECT | 0x171F | BizTalk Server failed to initialize a connection to database: "%1" on server: "%2".
CIS_E_PASSTHROUGH_WITH_NOCHANNEL | 0x1720 | A valid channel name must be specified as a submission parameter on a Submit or SubmitSync method call when the pass-through flag is set to true.
CIS_W_DBFAILURE | 0x1721 | The database call failed and returned the following error string: "%1". If possible, we will attempt to retry this call.
CIS_E_GET_BTMPARAMS | 0x1722 | Unable to load connection parameters for BTM database. Please go to the Administration MMC to resolve this problem.
CIS_E_UNABLE_TO_CREATE_CUSTOM_PRE_PROC | 0x1723 | The custom preprocessing component for the receive function "%1" could not be created. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_FAILED | 0x1724 | The custom preprocessing component used by the receive function "%1" failed. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_NO_BSTR | 0x1725 | The custom preprocessing component used by the File receive function "%1" failed to return a valid BSTR. A valid BSTR is required. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA | 0x1726 | The custom preprocessing component used by the Message Queue receive function "%1" cannot be called because the message contains data that is not a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_CP | 0x1727 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid code page. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA_OUT | 0x1728 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid document, the document must be either a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_FILE_PRE_PROC_FAIL | 0x1729 | The custom preprocessing component used by the file receive function "%1" failed. The document "%2" will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_CANT_SET_CTX | 0x172A | The server was unable to set the context on the custom preprocessing component used by the receive function "%1". This document will be moved to the Suspended queue.
CIS_E_FILERCV_FILE_SHARE_DOWN | 0x172B | The file receive function "%1" was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_FILERCV_NETWORK_DOWN | 0x172C | The file receive function "%1" is experiencing network problems and was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_RECEIVE_FUNCTION_DISABLED | 0x172D | The receive function "%1" has experienced problems, it will be shut down and disabled. Once these problems have been corrected, re-enable this receive function in BizTalk Server Administration.
CIS_E_UNRECOVERABLE | 0x172E | There was a serious error within the BizTalk Server scheduler component. The server is being shut down. Resolve this problem and then restart the server.
CIS_E_RELIABLE_NOACK | 0x172F | The server has not received a receipt for the reliable message.
CIS_E_DLQ_ID | 0x1730 | Suspended Queue ID: "%1"
CIS_E_CANNOT_FIRE_EVENT | 0x1731 | The server cannot send a WMI event for the Suspended queue item "%1". The most likely cause is that the user configured for this submission has insufficient privileges to access WMI.
CIS_E_HTTP_L_INITIALIZATION | 0x1750 | The BizTalk HTTP receive function could not complete initialization. Verify that the security credentials of "BizTalkHTTPReceive.dll" include access to the BizTalk configuration database.
CIS_E_HTTP_L_NO_DATA_SEND | 0x1751 | The BizTalk HTTP receive function "%1" received a request with no data.
CIS_E_HTTP_L_NO_THREAD_FROM_POOL | 0x1752 | The BizTalk HTTP receive function "%1" could not retrieve a thread from the thread pool.
CIS_E_HTTP_L_NO_TRANSPORT | 0x1753 | The BizTalk HTTP receive function could not select a valid transport. Check the configuration of this receive function: Request URL="%1".
CIS_E_HTTP_L_SERVER_SUPP_FUNCT | 0x1754 | The BizTalk HTTP receive function "%1" made a call to IIS Server Support Function: "%2" which failed.
CIS_E_HTTP_L_POST_THREAD_POOL | 0x1755 | The BizTalk HTTP receive function "%1" could not post the work item to the thread pool. Try increasing the length of the thread pool queue using the registry key "QueueFactor".
CIS_E_HTTP_L_GET_FROM_THREAD_POOL | 0x1756 | The BizTalk HTTP receive function "%1" could not retrieve a work item from the thread pool.
CIS_E_HTTP_L_SEND_HEADERS | 0x1757 | The BizTalk HTTP receive function "%1" could not send the HTTP headers to the client.
CIS_E_HTTP_L_ASYNC_PROCESSING | 0x1758 | The BizTalk HTTP receive function "%1" failed during asynchronous processing of an IIS request.
CIS_E_HTTP_L_ASYNC_IIS_ERROR | 0x1759 | The BizTalk HTTP receive function "%1" received an error from IIS while processing an asynchronous request.
CIS_E_HTTP_L_DLL_LOAD_FAILURE | 0x175A | The BizTalk HTTP receive function could not load the DLL "%1".
CIS_E_HTTP_L_CREATION_FAILURE | 0x175B | The BizTalk HTTP receive function could not create "%1", error:"%2".
CIS_E_HTTP_L_TRANSPORT_URL | 0x175C | The BizTalk HTTP receive function could not extract a valid transport URL from the request URL. Error:"%1". Request URL="%2".
CIS_E_HTTP_L_TRANSPORT_URL_INVALID | 0x175D | The BizTalk HTTP receive function transport alias "%1" is not valid. Check the configuration of this receive function.
CIS_E_HTTP_L_TRANSPORT_HANDLE_INVALID | 0x175E | The BizTalk HTTP receive function transport handle for alias "%1" is not valid. Check the configuration of this receive function.
CIS_E_HTTP_L_FILE_CREATION_FAILURE | 0x175F | The BizTalk HTTP receive function "%1" could not create the file "%2".
CIS_E_HTTP_L_SET_FILE_POINTER_FAILURE | 0x1760 | The BizTalk HTTP receive function "%1" could not set the file pointer while writing to the file "%2".
CIS_E_HTTP_L_FILE_WRITE_FAILURE | 0x1761 | The BizTalk HTTP receive function "%1" could not write to the file "%2".
CIS_E_HTTP_L_FILE_LOCK_FAILURE | 0x1762 | The BizTalk HTTP receive function "%1" could not obtain a lock on the file "%2".
CIS_E_HTTP_L_BUILD_FILE_NAME_FAILURE | 0x1763 | The BizTalk HTTP receive function "%1" could not build a valid file name for "%2.
CIS_E_HTTP_L_FILE_DELETE_FAILURE | 0x1764 | The BizTalk HTTP receive function "%1" could not delete the file "%2".
CIS_E_HTTP_L_DETERMINING_CODE_PAGE | 0x1765 | The BizTalk HTTP receive function "%1" could not retrieve the code page for charset="%2".
CIS_E_HTTP_L_MSMQ_SEND_FAILURE | 0x1766 | The BizTalk HTTP receive function could not send a message to the message queue "%1", HR=%2, Request URL:"%3".
CIS_E_HTTP_L_MSMQ_OPEN_FAILURE | 0x1767 | The BizTalk HTTP receive function could not open the message queue "%1", HR=%2.
CIS_E_HTTP_L_REGISTRY_FAILURE | 0x1768 | The BizTalk HTTP receive function could not retrieve the configuration from the registry.
CIS_E_HTTP_L_CP_CONVERTION_FAILURE | 0x176A | The BizTalk HTTP receive function "%1" encountered an error converting the document to UNICODE.
CIS_E_HTTP_L_SUBMIT_FAILED | 0x176B | The BizTalk HTTP receive function "%1" failed to submit the document into BizTalk Messaging.
CIS_E_HTTP_L_SERVER_VARIABLE | 0x176C | The BizTalk HTTP receive function could not successfully retrieve the server variable "%1" from IIS, error:%2.
CIS_E_HTTP_L_BASE_URL_NOT_OBTAINABLE | 0x176D | The BizTalk HTTP receive function could not retrieve the URL from IIS.
CIS_E_HTTP_L_SUBMISSION_HANDLE_ERROR | 0x176E | The BizTalk HTTP receive function "%1" could not send the BizTalk correlation token to the client.
CIS_E_HTTP_L_GET_CONFIG_ERROR | 0x176F | The BizTalk HTTP receive function could not successfully retrieve the configuration information from the database, hr=%1.
CIS_E_HTTP_L_IMPERSNT_FAILED | 0x1770 | The BizTalk HTTP receive function could not get the appropriate security credentials to access the database.
CIS_E_HTTP_L_WRITE_RESPONSE_ERROR | 0x1771 | The BizTalk HTTP receive function "%1" could not send the HTTP response to the client.
CIS_E_HTTP_L_SUBMITSYNC_FAILED | 0x1772 | The BizTalk HTTP receive function "%1" could not synchronously submit the document to BizTalk Messaging.
CIS_E_HTTP_L_MOVETOSUSPENDQ_FAILED | 0x1773 | The BizTalk HTTP receive function "%1" could not move the document received to the Suspended Queue.
CIS_E_SERIALIZER_INVALID_DOCUMENT | 0x1800 | The document with the "%1" tracking identifier is invalid XML. The serializer cannot continue.
CIS_E_BTF_INVALID_ADDRESS_TYPE | 0x1801 | The BizTalk Framework document has an "type" specified that is not valid for the "%1" address field. This document will be moved to the Suspended queue.
CIS_E_RELIABLE_MSG_RECEIPT_REQ_BY | 0x1802 | The BizTalk Framework document "%1" will not be transmitted as it has an expired "receiptRequiredBy" timestamp. This message will be discarded.
CIS_E_CUSTOM_ENVELOPE_ERROR | 0x1803 | The custom envelope:"%1" had the property "%2" specified, but the custom envelope generator could not to locate the XML node. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_DATETIME | 0x1804 | The "%1" date or time format is not valid. Correct the format specification.
CIS_E_SERIALIZER_INVALID_DTDATA | 0x1805 | The "%1" date or time field is not a valid ISO8601 format. Make sure that the XML date or time is formatted correctly.
CIS_E_SERIALIZER_INVALID_DELIMITER | 0x1806 | The "%1" delimiter is either missing or has a value specified that is not valid. Update the delimiter value.
CIS_E_SERIALIZER_MISSING_PROPSET | 0x1807 | The "%1" document is missing the entire property set that is required for this serializer to run.
CIS_E_SERIALIZER_MISSING_PROP | 0x1808 | The property set for the "%1" document either is missing or does not contain a valid value for the "%2" property. Add or correct this property.
CIS_E_SERIALIZER_INVALIDARG | 0x1809 | Both source and destination qualifiers and values are required for this serializer to run. Specify qualifiers and values in the messaging port for this transaction.
CIS_E_SERIALIZER_MISMATCH_SPEC | 0x180A | The serialization produced no output. Verify that the document specification matches the outbound XML document.
CIS_E_SERIALIZER_FAILED | 0x180B | The serializer could not finish processing. See the following messages for details.
CIS_E_SERIALIZER_INVALID_SRCQUAL | 0x180C | The "%1" qualifier for the source identifier is too long to be placed in the outbound document header. Update the channel with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_SRCID | 0x180D | The "%1" value for the source identifier is too long to be placed in the output header. Update the channel with a shorter value.
CIS_E_SERIALIZER_INVALID_DESTQUAL | 0x180E | The "%1" qualifier for the destination identifier is too long to be placed in the output header. Update the port with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_DESTID | 0x180F | The "%1" value for the destination identifier is too long to be placed in the output header. Update the port with a shorter identifier.
CIS_E_SERIALIZER_INVALID_POSREC | 0x1810 | The "%1" positional record is defined to contain a record length of zero. This happens when there is no tag, and none of the fields in this record specify start and end positions. Update the fields to have valid start and end positions for this record.
CIS_E_SERIALIZER_NODELIMS | 0x1811 | This serializer component requires delimiters specified in the messaging port. Specify a valid delimiter set for this component.
CIS_E_SERIALIZER_INVALID_CHAR | 0x1812 | The serializer component has encountered a character, "%1", that is not valid. An entry specified in the InvalidCharacterMap tag of the document specification states that characters between "%2" and "%3" are not valid.
CIS_E_SERIALIZER_INVALID_LENGTH | 0x1813 | The length of the "%1" field ("%2") is not valid; it must be between %3 and %4. This document will be rejected.
CIS_E_SERIALIZER_SELECT_SINGLE_NODE_FAILED | 0x1814 | The serializer component cannot find the node using the query "%1". This document will be rejected.
CIS_E_SERIALIZER_RELIABLE_URL_MISSING | 0x1815 | The reply-to URL required for reliable messaging was not set. This document will be rejected.
CIS_E_SERIALIZER_CONTROL_NUMBER | 0x1816 | The serializer component cannot find a control number for %1 %2 in the BizTalk Management database. This document will be rejected.
CIS_E_CUSTOM_ENV_PARSE_TABLE_ERROR | 0x1817 | The serializer component failed to build the custom envelope ID:"%1", this was due to errors in the XML Schema supplied. This document will be moved to the Suspended queue.
CIS_E_SUBSYNC_RELIABLE_MSG | 0x1818 | The BizTalk Framework document that was submitted has "reliability" information specified. This information is not permitted in a synchronous call.
CIS_E_CUSTXML_BODY_NOT_FOUND | 0x1819 | The parser was unable to locate the XML document node by using the query specified in the XML specification: "%1".
CIS_E_BTF_ACK_BAD_MSG_ID | 0x181A | The BizTalk Framework receipt had a <prop:identity> tag that is not valid: "%1". This document will be moved to the Suspended queue.
CIS_E_BTF_MANIFEST_REF_MISSING | 0x181B | The BizTalk Framework document has a <manifest> tag without the mandatory <reference> tag. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_ENV_NO_DOC_NODE | 0x181C | The serializer failed to create the custom envelope because the Document Container Node property was not specified in the XML specification. This document will be moved to the Suspended queue.
CIS_E_BTF_INVALID_XSI_TYPE | 0x181D | The BizTalk Framework document contains an xsi:type attribute "%1" that is not valid. This attribute must not have spaces, and the first character must be alphabetical. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_SYNTAX_IDENTIFIER | 0x181E | The EDIFACT Syntax Identifier "%1" is not valid. Update the channel with a correct identifier.
CIS_E_SERIALIZER_INVALID_UNA_CONTROL | 0x181F | The EDIFACT UNA Control value "%1" is not valid. Update the channel with a correct value.
CIS_E_SERIALIZER_EXPECT_BSTR_VALUE | 0x1820 | The configuration data for the field "%1" must be a string. Update the data for this field.
BTS_E_XMLSERIALIZER_MISSING_DEST | 0x1821 | The BizTalk Framework header could not be generated because no destination identifier was specified.
BTS_E_XMLSERIALIZER_MISSING_SRC | 0x1822 | The BizTalk Framework header could not be generated because no source identifier was specified.
CIS_E_BTF_IDENTITY_MISSING | 0x1904 | The parser could not find the mandatory BizTalk Framework tag "identity". This document will be moved to the Suspended queue.
CIS_E_BTF_EXPIRESAT_MISSING | 0x1905 | The parser could not find the mandatory BizTalk Framework tag "expiresAt". This document will be moved to the Suspended queue.
CIS_E_MSMQ_NOT_INSTALLED | 0x1906 | The Message Queuing receive function could not be started because the Message Queuing service is not installed on the server.
CIS_W_FILE_RECEIVE_RETRY_FAILURE | 0x1907 | There are file(s) in the "%1" directory that cannot be accessed by the file receive function. The receive service will try again to access the file(s) in "%2" seconds.
CIS_E_FILE_RECEIVE_DELETE_FAILURE | 0x1909 | The following file could not be deleted after processing: "%1". Make sure that the file attribute is not set to read-only.
CIS_E_LOGON_USER_FAILURE | 0x190a | Unable to logon with the account %1. Make sure that %2 has been granted "logon locally" privilege on this server and that the BizTalk Server account has "act as part of the operating system" privilege.
CIS_E_MSMQ_RECEIVE_IMPERSONATION_FAILURE | 0x190b | The "%1" Message Queuing receive function could not impersonate the logged on user.
CIS_E_RECEIVE_CANNOT_CREATE_THREAD | 0x190c | A receive-function thread cannot be created due to a system error.
CIS_E_MSMQ_RECEIVE_OPENQ_FAILURE | 0x190d | The following Message Queuing queue cannot be opened: "%1" (Message Queuing error code: 0x%2=%3). Verify the existence and security setting of the queue.
CIS_E_MSMQ_RECEIVE_PEEKQ_FAILURE | 0x190e | The Message Queuing queue could not be read: "%1" (Message Queuing error code: 0x%2=%3).
CIS_E_MSMQ_RECEIVE_RETRIEVEQ_FAILURE | 0x190f | A message could not be retrieved from the following Message Queuing queue: '%1' (Message Queuing error: 0x%2=%3).
CIS_E_FILE_RECEIVE_FINDCHANGE_FAILURE | 0x1910 | The file-change notification cannot be set up on the following directory: "%1". Make sure that the path is correct.
CIS_E_SET_CURRENT_DIR_FAILURE | 0x1911 | The current directory cannot be set to: "%1". Make sure that the path is correct.
CIS_W_RECEIVE_SUBMIT_FAILURE | 0x1914 | A submit request initiated from the "%1" receive function has failed.
CIS_E_READONLY_FILE | 0x1915 | The "%1" receive function picked up the following file: '%2'. This file is marked as read-only and cannot be processed.
CIS_E_BAD_RECSVC | 0x1916 | There was a serious failure in the receive function "%1". This receive service will be shut down, please check the event log for additional error messages.
CIS_E_FILE_RECEIVE_IMPERSONATION_FAILURE | 0x1917 | The "%1" file receive function could not impersonate the logged on user.
CIS_E_MSMQ_RECEIVE_UNEXPECTED_PASSTHROUGH | 0x1918 | The ""%1"" Message Queuing receive function is not configured for a pass-through submission, but it has encountered a document that was submitted previously as a pass-through submission. Change this receive function to accept pass-through submissions or remove the pass-through document from the queue. This receive function will be shut down.
CIS_E_BTSDOCUMENT_INVALIDNAME | 0x1A00 | The document named "%1" does not exist. Correct the document name or add the document to the BizTalk Messaging Management database.
CIS_E_BTSDOCUMENT_INVALIDDOC | 0x1A01 | The server could not load any documents with the given criteria.
CIS_E_BTSDOCUMENT_AMBIGUOUS_NAMESPACE | 0x1A02 | The root node "%1" is ambiguous because documents "%2" and "%3" refer to different specifications with that name. Either change the specifications to remove this ambiguity or use the document name explicitly.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSET | 0x1A03 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSETSHAREID | 0x1A04 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set and have reference "%3".
CIS_E_BTSDOCUMENT_INVALIDPROPERTYSET | 0x1A05 | The following property set was specified: %1.
CIS_E_BTSDOCUMENT_EMPTYPROPERTYSET | 0x1A06 | The property set was empty.
CIS_E_BTSDOCUMENT_LOADFAILED | 0x1A07 | The document "%1" could not be loaded. Possible causes are using a non-envelope specification, or incorrectly configured tracking details.
CIS_E_BTSENVELOPE_LOADFAILED | 0x1A20 | The envelope "%1" could not be loaded. A possible cause is that the specification is not valid. Configure a valid envelope specification.
CIS_E_FAILED_TO_JOIN_TX | 0x1A21 | BizTalk Server failed to join a transaction. Ensure both the DTC and the SQL Server database are running.
MSG_COM_CREATE_FAILED | 0x1B01 | An instance of the %1 class cannot be created: %2.
MSG_CONNECT_WMI_FAILED | 0x1B02 | A connection to Windows Management on "%1" cannot be established: %2.
MSG_COSETPROXY_FAILED | 0x1B03 | The authentication credential cannot be set for the Windows Management connection: %1.
MSG_WMI_ENUMINST_FAILED | 0x1B04 | Instances of the BizTalk Server WMI provider class "%1" cannot be enumerated: %2.
MSG_WMI_GETPROP_FAILED | 0x1B05 | The property value of "%1" cannot be retrieved from the BizTalk Server WMI provider because of an unexpected error: %2.
MSG_WMI_EXECQUERY_FAILED | 0x1B06 | An unexpected error is preventing execution of the BizTalk Server WMI provider query "%1": %2.
MSG_WMI_GETOBJ_FAILED | 0x1B07 | The BizTalk Server WMI provider instance of "%1" cannot be retrieved because of an unexpected error: %2.
MSG_WMI_PUTPROP_FAILED | 0x1B08 | The property value of "%1" cannot be changed because of an unexpected error: %2.
MSG_WMI_PUTINST_FAILED | 0x1B09 | The property values of the BizTalk Server WMI provider instance "%1" cannot be updated because of an unexpected error: %2.
MSG_WMI_DELINST_FAILED | 0x1B0A | The BizTalk Server WMI provider instance "%1" cannot be deleted because of an unexpected error: %2.
MSG_WMI_CREATEINST_FAILED | 0x1B0B | A new instance of the WMI class "%1" cannot be created in the BizTalk Server WMI provider: %2.
MSG_WMI_CREATEGETOBJ_FAILED | 0x1B0C | A new instance of the BizTalk Server WMI provider class "%1" cannot be created because of an unexpected error: %2.
MSG_WMI_EXECMETHOD_GETOBJ_FAILED | 0x1B0D | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the class: %3.
MSG_WMI_EXECMETHODCLASS_FAILED | 0x1B0E | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the method information: %3.
MSG_WMI_EXECMETHODSPAWN_FAILED | 0x1B0F | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of an unexpected error: %3.
MSG_WMI_EXECMETHODPUTPARAM_FAILED | 0x1B10 | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to set the parameter value: %3.
MSG_WMI_EXECMETHOD_FAILED | 0x1B11 | The method "%1" of the WMI class "%2" cannot be executed by the BizTalk Server WMI provider: %3.
MSG_GET_HOSTNAME_FAILED | 0x1B12 | The local computer name cannot be obtained because of an unexpected error: %1.
MSG_OUT_OF_MEMORY | 0x1B14 | Insufficient memory.
MSG_FAIL_LOAD_BMP | 0x1B17 | At least one of the bitmaps cannot be loaded in the BizTalk Server Administration console: %1.
MSG_FAIL_SET_BMPSTRIP | 0x1B18 | At least one pair of bitmaps cannot be added to the image list of the BizTalk Server Administration console: %1.
MSG_ERROR_WMI_PATH_EMPTY | 0x1B19 | The requested operation cannot be completed because of a previous WMI failure. The WMI object path is empty in this case.
MSG_ERROR_BTM_GRP_ENUM_FAIL | 0x1B20 | Unknown problems are preventing the WMI provider from enumerating a list of server groups from the BizTalk Messaging Management database: %1.
MSG_ERROR_GRP_DTA_DB_FAIL | 0x1B21 | Unknown problems are preventing the WMI provider from accessing the Tracking database for the "%1" group.
MSG_ERROR_GRP_SQ_DB_FAIL | 0x1B22 | Unknown problems are preventing the WMI provider from accessing the Shared Queue database the "%1" group.
MSG_ERROR_GRP_BOTH_DB_FAIL | 0x1B23 | Unknown problems are preventing the WMI provider from accessing the Tracking and Shared Queue databases for the "%1" group.
MSG_ERROR_DECRYPT_FAIL | 0x1B24 | Password decryption failed: %1.
MSG_WARN_ENUM4ROOTUPD_FAILED | 0x1B27 | Unknown problems are preventing the WMI provider from retrieving following list of servers and their states to prepare for BizTalk Messaging Management database update: %1
MSG_ERROR_CHANGE_ROOTDB | 0x1B28 | The server "%1" cannot be updated with the new BizTalk Messaging Management database information: %2.
MSG_ERROR_CHANGE_ROOTDB_CONNECT | 0x1B29 | We cannot connect to the WMI namespace "%1" to update server "%2" with the new BizTalk Messaging Management database information: %3
MSG_CHANGE_ROOTDB_SUMMARY | 0x1B30 | The BizTalk Messaging Management database change request has been completed. %1%2 %3%4
MSG_CHANGE_ROOTDB_ON_LOCAL | 0x1B3A | Because the server and server group information cannot be retrieved from the original BizTalk Messaging Management database, the BizTalk Messaging Management database information will be updated only on the local computer "%1". The update has been successful.
MSG_ERROR_UNEXPECTED_ENDOFLIST | 0x1B3C | An unexpected end of list (EOL) for the "%1" class enumeration has been reached.
MSG_ERROR_ORG_QUALIFIERS_FROM_DB_FAILED | 0x1B3D | The organization qualifiers cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_ERROR_ORG_VALUES_FROM_DB_FAILED | 0x1B3E | The organization values cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_WARN_NOT_RESUBMITABLE | 0x1B3F | In the selected group of multiple items, at least one item cannot be submitted again.
MSG_WARNING_PROP_VALUES_CHANGED | 0x1B40 | %1 "%2" specified for receive function "%3" has been removed from the BizTalk Messaging Management database.
MSG_WARNING_QUALIFIER_CHANGED | 0x1B41 | The qualifier and identifier pair "%1" and "%2" specified for receive function "%3" is not valid in the BizTalk Messaging Management database.
MSG_WARNING_ORGANIZATION_CHANGED | 0x1B42 | Organization "%1" specified for receive function "%2" is not valid in the BizTalk Messaging Management database.
MSG_TIMEBOMB_DAYS_LEFT | 0x1B43 | Thank you for evaluating Microsoft BizTalk Server. The period for this evaluation version has %1 days left. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server.
INTERCHANGE_EVENT | 0x3005 | BizTalk Server: %1

Note

  • When an error occurs, the %n variables are replaced with relevant information, such as an object name.


Orchestration Services Error Messages

The BizTalk Orchestration Services object model error messages in the following table are returned when a running XLANG schedule generates the warning or error. These messages can be viewed in Windows® 2000 Event Viewer.

Message name | Value | Description
ID_W_NOT_CREATOR | 0x1000 | An unauthorized client attempted to create a new instance of an XLANG schedule. The remainder of the moniker string and the identity of the client are shown in the following message. The client's security identifier (SID) is included as binary data: %1%0
ID_W_NOT_USER | 0x2001 | An unauthorized client attempted to gain access to an existing instance of an XLANG schedule. The remainder of the moniker string identifying the instance and the identity of the client are shown in the following message. The client's security identifier (SID) is included as binary data: %1%0
ID_W_REHYDRATIONERROR | 0x2002 | An error was encountered while rehydrating an XLANG schedule. There might be a problem reading the database or a problem with the information stored, or your system might be low on resources. The operation will be retried. Detailed information is provided in the following message.%1%0
IDS_E_COMSVCS_INTERNAL_ERROR | 0x3000 | The XLANG Scheduler Engine has detected an inconsistency in its internal state. Please contact Microsoft Product Support Services to report this error: %1%0
IDS_COMSVCS_RESOURCE_ERROR | 0x3001 | The XLANG Scheduler Engine has detected the absence of a critical resource and has caused the process that hosted it to end: %1%0
IDS_COMSVCS_INTERNAL_ERROR_ASSERT | 0x3002 | COM+ internal error. Please contact Microsoft Product Support Services to report this error. Assertion failure: %1%0
ID_E_USER_EXCEPTION | 0x3003 | The system has called a scheduled component and that component has failed and generated an exception. This indicates a problem with the scheduled component. Notify the developer of this component that a failure has occurred and provide the following information: %1%2%0
ID_INITIALIZE_FOR_DTC | 0x3004 | The XLANG Scheduler Engine was unable to initialize for transactions that are required to support transactional components. Make sure that MS DTC is running: %1%0
ID_E_CANT_CREATE_COMPONENT | 0x3005 | The XLANG Scheduler Engine was unable to create a user component that is required by the running XLANG schedule. Detailed information is provided in the following message. %1%0
ID_E_PROGID_NOT_FOUND | 0x3006 | The XLANG Scheduler Engine was unable to convert the Programmatic ID in the following message to a COM class ID: %1%0
ID_E_CANT_CREATE_INTERCEPTOR | 0x3007 | The XLANG Scheduler Engine was unable to create an interceptor object for the interface ID shown in the following message. Probable causes for this are 1) the interface isn't registered properly; 2) no type library is provided for the interface; or 3) the file that contains the interface type information can't be loaded. The port name associated with this interceptor is: %1%0
ID_E_INTF_NOT_SUPPORTED | 0x3008 | The XLANG Scheduler Engine detected an inconsistency between the port implementation and the COM components to which it refers. A component listed in the port implementation has failed to support the expected interface. The class ID of the component and the IID that it failed to support are shown in the following message. The port name associated with this component is: %1%0
ID_E_UNKNOWN_METHOD | 0x3009 | The XLANG Scheduler Engine received a call to a method that was not specified in the port implementation for this XLANG schedule. The IID and method number are shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_UNKNOWN_IDISPATCH_METHOD | 0x300A | The XLANG Scheduler Engine received a call through the IDispatch::Invoke() interface to a method that no longer exists. The dispatch ID for the method is shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_NAMED_PARAMS | 0x300B | The XLANG Scheduler Engine received a call through the IDispatch::Invoke() interface to a method that contains named arguments. Use positional arguments instead. The dispatch ID for the method is shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_BAD_INVOKE_PARAMS | 0x300C | The XLANG Scheduler Engine received a call through the IDispatch::Invoke() interface to a method with an incorrect number of parameters. The IID and the dispatch ID for the method are shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_BAD_RETURN_POINTER | 0x300D | The XLANG Scheduler Engine received an incorrect Out parameter through the IDispatch::Invoke() interface from a method. The reference returned was either not valid (NULL or a bad pointer) or does not support the expected interface. The expected dispatch ID is shown in the following message. The name of the message containing the bad port reference is: %1%0
ID_E_ACCESS_CHECK_FAILURE | 0x300E | The XLANG Scheduler Engine was not able to authorize the client's moniker resolution request. Access is denied.%0
ID_E_BAD_INVOKE | 0x300F | The IDispatch::Invoke() interface call to a method failed. The dispatch ID for the method is shown in the following message. The name of the port on which the call was attempted is: %1%0
ID_E_INVOKED_METHOD | 0x3010 | The invoked method, whose dispatch ID is shown in the following message, reported an error. The name of the port on which the call was attempted is: %1%0
ID_E_CANT_GET_TYPEINFO | 0x3011 | The component whose port name and COM CLSID are shown in the following message was unable to supply required type information to the XLANG Scheduler Engine.%1%0
ID_E_CANT_INVOKE_METHOD | 0x3012 | The XLANG Scheduler Engine was unable to deliver a method call to the object associated with the port name shown in the following message. The interface and method name that are invoked are also shown.%1%0
ID_E_CANT_GET_CLASSINFO | 0x3013 | The component whose port name and COM CLSID are shown in the following message was unable to supply required type information to the XLANG Scheduler Engine through the IProvideClassInfo::GetClassInfo interface.%1%0
ID_E_SCRIPT_ERROR | 0x3014 | A scripted decision rule in an XLANG schedule instance could not be executed. The error returned by the script engine is shown in the following message. The script's source code and information about the schedule instance in which the error occurred is also provided.%1%0
ID_E_SCRIPT_ERROR_NOINFO | 0x3015 | A scripted decision rule in an XLANG schedule instance has failed. Detailed information regarding the error could not be obtained due to an internal error. The error code is shown in the following message.%1%0
ID_E_SCRIPT_BADCONV | 0x3016 | A scripted decision rule in an XLANG schedule instance referred to a message field whose type was incompatible with the VBScript Engine. The XLANG Scheduler Engine attempted to convert the field to a compatible type but was unable to do so. The information in the following message shows the script rule, message, and field involved, as well as the original field variant type and the type to which a conversion was attempted. The field's VARIANT data structure is attached to this log entry as binary data.%1%0
ID_E_SCRIPT_BADARRAY | 0x3017 | A scripted decision rule in an XLANG schedule instance referred to a message field containing an array type that is incompatible with the VB script engine. Only variant arrays are supported by Visual Basic Scripting. The information in the following message shows the script rule, message, and field involved. The field's VARIANT data structure is attached to this log entry as binary data.%1%0
ID_E_SCRIPT_BADEXPR | 0x3018 | A scripted decision rule in an XLANG schedule instance contained an expression that did not return a Boolean result. The information in the following message shows the script rule and expression involved. The VARIANT data structure returned by the expression is attached to this log entry as binary data.%1%0
ID_E_SCHEDULE_NOT_RUNNING | 0x3019 | The XLANG Scheduler Engine received a call to an object associated with a port in an XLANG schedule instance that is not running. The name of the port on which the call arrived is: %1%0
ID_E_INTERNAL_EXCEPTION | 0x301A | A COM+ internal exception occurred. Contact Microsoft Product Support Services to report this error, and provide them with the information in the following message.%1%2%0
ID_E_BAD_DATAFLOW_NOMESSAGE | 0x301B | There is a problem with the data-flow specification. A message that is indicated as a source of data does not currently exist while this XLANG schedule is running. Detailed information is provided in the following message.%1%0
ID_E_BAD_ARGUMENTVALUE | 0x301C | One of the fields that is used as a parameter for a COM method call has a bad value type in it. This is most likely caused by incorrect or missing data flow. Detailed information is provided in the following message.%1%0
ID_E_DEEP_VARIANT_NESTING | 0x301D | One of the fields that is used as a parameter for a COM method call has more than one nesting level of VARIANTs. The IID and the method's dispatch ID are shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_BAD_MAPPORTVALUE | 0x301E | A field carrying a mapped port is not valid. Detailed information is provided in the following message.%1%0
ID_E_BAD_CALLPARAMNUMBER | 0x301F | An incorrect number of parameters are being passed into a call. Detailed information is provided in the following message.%1%0
ID_E_EXECUTINGCALLEDSCHEDULE | 0x3020 | The XLANG schedule cannot be executed as a top-level schedule. Context parameters must be passed to it. Detailed information is provided in the following message.%1%0
ID_E_CANT_GET_SUPPORTERRORINFO | 0x3021 | The component whose port name and COM CLSID are shown in the following message was unable to return success from an interface that it claimed to support to the XLANG Scheduler Engine via ISupportErrorInfo::InterfaceSupportsErrorInfo.%1%0
ID_E_PERSIST_FAILURE | 0x3022 | The state of the schedule instance could not be saved to the database. Detailed information is provided in the following message.%1%0
ID_E_TRANSACTION_COMMIT_FAILURE | 0x3023 | The system failed to commit a transactional context. Detailed information is provided in the following message.%1%0
ID_E_TRANSACTION_ABORTED | 0x3024 | The system aborted a transactional context. Detailed information is provided in the following message.%1%0
ID_E_TRANSACTION_ABORT_FAILURE | 0x3025 | The system failed to abort a transactional context. The state of this transaction is not known. Detailed information is provided in the following message.%1%0
ID_E_PENDINGREHYDRATIONERROR | 0x3026 | The rehydration application encountered an error and is shutting down. Some of the rehydration requests will fail due to this shutdown. Restart the XLANG Scheduler Engine service. Detailed information is provided in the following message.%1%0
ID_E_REHYDRATIONONSTARTUPERROR | 0x3027 | One or more XLANG schedules could not be rehydrated because of a system error. There might be problems reading the database or problems with the data that was read. Detailed information is provided in the following message.%1%0
ID_E_REHYDRATIONERROR | 0x3028 | An error was encountered while rehydrating an XLANG schedule. There might be a problem reading the database, or there might be a problem with the information stored. It is probable that the XLANG schedule was not dehydrated properly. Detailed information is provided in the following message.%1%0
ID_E_FOUNDINITIALIZEDTHREAD | 0x3029 | The XLANG Scheduler Engine service encountered a critical thread-management error while processing an XLANG schedule. The schedule might fail to continue processing. Contact your technical support.%1%0
ID_E_CALLONCOMPLETEDSCHEDULE | 0x302A | The XLANG Scheduler Engine service received a call on a completed XLANG schedule instance. The schedule instance has already been removed from memory. The IID for the interface is shown in the following message.%1%0
IDS_MSG_TIMEBOMB_EXPIRED | 0x302B | Thank you for evaluating Microsoft BizTalk Server 2002. The period for this evaluation version has ended. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server 2002.%0
ID_E_FIELDPORTPERSISTENCEERROR | 0x302C | An error was encountered while attempting to persist an XLANG schedule instance. Detailed information is provided in the following message.%1%0
ID_E_FIELDPORTREHYDRATIONERROR | 0x302D | An error was encountered while attempting to restore a particular sub-component of an XLANG schedule instance from the database. Detailed information is provided in the following message.%1%0
ID_E_SCHEDULEDONE | 0x3030 | The XLANG Scheduler Engine encountered an error while marking the XLANG schedule instance as done. Either the database could not be updated or another error was encountered in the final stage. Detailed information is provided in the following message.%1%0
ID_E_COMPONENT_INCOMPATIBLE_TXN | 0x3031 | The XLANG Scheduler Engine encountered an error while attempting to instantiate a component. Either the component was previously enrolled in a different transaction, or the component was previously not enrolled in a transaction and the current instantiation requires a transaction. Detailed information is provided in the following message.%1%0
ID_E_SUSPEND_FAILURE | 0x3032 | The XLANG schedule instance could not be suspended. Detailed information is provided in the following message.%1%0
ID_E_INITNEW | 0x3033 | The XLANG Scheduler Engine received an error when doing IPersistStreamInit::InitNew. The class ID of the component and the error code are shown in the following message. The port name associated with this component is: %1%0
ID_E_POSSIBLEBYOTISSUE | 0x3034 | The component you requested could not be created. One possible reason for this is that you have configured the BYOT component inside a COM+ application on this machine. This setting is incompatible with the XLANG Scheduler service. The port name associated with this component is: %1%0
ID_E_FIELDPROCESSINGERROR | 0x3035 | The field value provided was not valid. Detailed information is provided in the following message.%1%0
ID_E_NO_OBJECT | 0x3036 | The XLANG schedule could not be instantiated. Detailed information is provided in the following message.%1%0
ID_E_STARTUP_FAILED | 0x3037 | One or more of the XLANG Group Managers failed to start up with the following error: %1%0
ID_E_NON_SCRIPT_BADEXPR | 0x3038 | An XLANG schedule instance has a rule comparing fields for data types that are not permitted. Detailed information is provided in the following message.%1%0
E_BTW_PERSIST_REACHEDEOF | 0x3039 | The recordset cannot return this row, because the end-of-file (EOF) has been reached.%1%0
ID_E_BAD_DATAFLOW_EMPTYFIELD | 0x3040 | There is a problem with the data-flow specification. A field indicated as a source of data is empty. This may be because it could not be persisted earlier. Detailed information is provided in the following message.%1%0
ID_E_CANT_OPEN_DEADLETTER_QUEUE | 0x3041 | The XLANG Scheduler Engine was unable to create or open the XLANG dead-letter queue for its host COM+ application. The name of the failing COM+ application is: %1%0
ID_E_CANT_XFER_TO_DEADLETTER_QUEUE | 0x3042 | The XLANG Scheduler Engine was unable to transfer an invalid message to the XLANG dead-letter queue for its host COM+ application. The name of the failing COM+ application is: %1%0
ID_E_CANT_LOADMODULE | 0x3043 | The XLANG Scheduler engine was unable to load a required module. This may have been due to compilation/semantic errors with the module. Detailed information is available in the following message: %1%0
ID_E_USER_DATA_EXCEPTION | 0x3044 | A value that was received from the client has caused an exception to be raised. This can be caused by incorrectly allocating memory for the data, by a reference counting mismatch, or other data corruption. The most likely source of the problem is in the client code. Detailed information is available in the following message: %1%2%0
E_BTW_INTERNAL_ERROR | 0x4001 | An internal error has occurred. %1%0
E_EXPORT_FAILED | 0x4002 | The XLANG schedule could not be processed.%0
E_BTW_UNKNOWN_SHAPE | 0x4003 | The compiler does not understand the shape. This shape is an unknown shape.%0
E_BTW_INCOMPLETE_FLOW | 0x4004 | The flow is incomplete because a connector is missing.%0
E_BTW_INCOMPLETE_FLOW_LEFT | 0x4005 | The flow is incomplete. The shape must have a flow connected to the left connector.%0
E_BTW_INCOMPLETE_FLOW_RIGHT | 0x4006 | The flow is incomplete. The shape must have a flow connected to the right connector.%0
E_BTW_INCOMPLETE_FLOW_LATERAL | 0x4007 | The flow is incomplete. The shape is not attached to anything on the side.%0
E_BTW_INCOMPLETE_FLOW_TOP | 0x4008 | The flow is incomplete. The shape must have a flow connected to the top connector.%0
E_BTW_INCOMPLETE_FLOW_BOTTOM | 0x4009 | The flow is incomplete. The shape must have a flow connected from the bottom connector.%0
E_BTW_INCOMPLETE_FLOW_ANYLINE | 0x400A | The flow is incomplete. Not connected to any shape.%0
E_BTW_MIRRORLIST_INCONSISTENT | 0x400B | Mirror shapes are not found in the On Failure or Compensation page. Retry after replacing the shape with a new one.%0
E_BTW_BEGIN_INSIDE_TRANSACTION | 0x4010 | The Begin shape must not be enclosed within a transaction.%0
E_BTW_END_MULTIPLE_LOOP | 0x4020 | Only one End shape can be used in the loop branch.%0
E_BTW_END_IN_TRANSACTION | 0x4021 | The End shape cannot be used in the context.%0
E_BTW_SYNCACTION_NO_PAIR | 0x4030 | Binding to a COM port requires actions to appear in pairs.%0
E_BTW_INCOMPLETE_FLOW_BINDING | 0x4031 | No binding for this action or port.%0
E_BTW_FIELD_TYPE_NOT_SUPPORTED | 0x4040 | Type (variant type=%1) is not supported.%0
E_BTW_ROLE_NOT_SUPPORTED | 0x4050 | Contracts (XLANG Schedules with Roles) cannot be compiled.%0
E_BTW_EMPTY_TRANSACTION | 0x4060 | The transaction contains no valid shapes.%0
E_BTW_TRANSACTION_NOT_PERMITTED | 0x4061 | Transaction shapes are not permitted when the XLANG schedule is treated as a COM+ component. Remove the transaction or edit the properties of the Begin shape to change the transaction model.%0
E_BTW_TRANSACTION_BOUNDARIES_CROSSED | 0x4062 | You cannot connect a flow from outside a transaction to a shape within a transaction without first connecting the flow to the transaction. Draw your flow to the top connection point of a transaction to connect it to the transaction. Then, click the transaction to highlight it. Draw another flow from the transaction connection point to the first shape within the transaction. To draw a flow that leaves the transaction, you must first connect the flow to the connection point at the bottom of the transaction. Then, click the transaction to highlight it. Draw another flow from the bottom connection point to the next shape in the business process.%0
E_BTW_TRANSACTION_TERMINATED_PREMATURELY | 0x4063 | At least one path within the transaction should flow out of the transaction.%0
E_BTW_NO_RULES_FOR_SWITCH | 0x4070 | Decision shapes must contain at least one rule.%0
E_BTW_CANNOT_WAIT_ON_ALL_SWITCH_BRANCHES | 0x40A0 | Cannot wait on "all" branches from the decision.%0
E_BTW_NO_BRANCH_FOUND | 0x40A1 | The join cannot find the corresponding fork or decision.%0
E_BTW_JOIN_MISMATCH | 0x40A2 | Only a single join may be used with a given fork or decision.%0
E_BTW_JOIN_SHARED | 0x40A3 | The same join cannot be used for flows coming from different forks or decisions.%0
E_BTW_CANNOT_WAIT_ON_SOME_SWITCH_BRANCHES | 0x40A4 | Not all paths from the decision come to the join.%0
E_BTW_CANNOT_WAIT_ANY_ON_FORK_BRANCHES | 0x40A5 | Cannot wait "Or". The branches contain process forms that might never finish, resulting in hung schedules.%0
E_BTW_DATAFLOW_DISALLOWED_ON_BTM_PORT | 0x40C0 | This port cannot be used in multiple receive actions or within a single receive action in a loop.%0
E_BTW_MESSAGE_TECH_NOT_FOUND | 0x4110 | The message is not bound to any port.%0
E_BTW_MESSAGE_TYPE_MISMATCH | 0x4111 | The message was used with conflicting types "%1" and "%2".%0
E_BTW_MISSING_TECHNOLOGY | 0x4120 | The list of available methods for this communication flow has changed. Re-run the Method Communication Wizard to select a different method and update this communication flow.%0
E_BTW_MISSING_PORT_DATAFLOW | 0x41A0 | The settings for this port indicate that it is created externally to the XLANG Scheduler Engine. You must designate the source of this port reference by drawing a connection from the appropriate message field.%0
E_BTW_CIRCULAR_DATAFLOW | 0x41A1 | There appears to be a circular path in the data-flow path for this XLANG schedule.%0
E_BTW_LOOP_NORULE | 0x41D0 | A rule has not been defined.%0
E_BTW_LOOP_BODY_EXITS_TRANSACTION | 0x41D1 | The body of the loop cannot exit the enclosing transaction.%0
E_BTW_LOOP_BODY_END_MISSING | 0x41D2 | The end of the body of the loop is not found.%0
E_BTW_ABORT_NOT_IN_TXN | 0x41E0 | Abort shapes must be associated with an enclosing transaction.%0
E_BTW_ABORT_CONTEXT_INVALID_SCOPE | 0x41E1 | Abort shapes can refer to current or parent contexts only.%0
E_BTW_END_MULTIPLE_ABORT | 0x41E2 | Multiple End shapes are not allowed on the On Failure page.%0
E_BTW_COMPILER_FAILED | 0x5000 | Compile failed on "%1".%0
E_BTW_PARSE_FAILED | 0x5001 | Parse failed.%0
E_BTW_FIXUP_FAILED | 0x5002 | Fixup failed.%0
E_BTW_VALIDATION_FAILED | 0x5003 | Validation failed.%0
E_BTW_NODE_FAILURE | 0x5004 | at node "%1" (%2!d!,%3!d!).%0
E_BTW_STACK_TOO_MANY_ITEMS | 0x5005 | Too many items were found on the stack.%0
E_BTW_STACK_UNEXPECTED_NODE | 0x5006 | An unexpected node was found.%0
E_BTW_XMLQUERY_RETURNED_ZERO_NODES | 0x5007 | The XML Query returned zero nodes.%0
E_BTW_XMLQUERY_RETURNED_MULTIPLE_NODES | 0x5008 | The XML Query returned multiple nodes.%1%0
E_BTW_XMLQUERY_MISSING_ATTRIBUTE | 0x5009 | Required attribute "%1" is missing its value.%0
E_BTW_LOAD_MODULE_FAILED | 0x500A | Failed to load module "%1".%0
E_BTW_XML_LOAD_FAILED | 0x500B | The XML-DOM returned an error at "%1!d!, %2!d!".%0
E_BTW_ERROR_LOADING_PACKAGE | 0x500C | 0x%1!X! error occurred while trying to load the following URL: "%2".%0
E_BTW_NAMED_LIST_HAS_DUPLICATE_ENTRIES | 0x500D | The list has duplicate entries with the name "%1".%0
E_BTW_REQUIRED_ELEMENT_MISSING | 0x500E | Required element "%1" is missing.%0
E_BTW_ELEMENT_MISSING_VALUE | 0x5100 | The element value is missing.%0
E_BTW_REFERENCE_RESOLVE_FAILED | 0x5110 | Unable to resolve "%1" with location value "%2".%0
E_BTW_CONTEXTREF_INVALID_REFERENCE | 0x5120 | Returning to or "releasing" from an independent (non-enclosing) context is not permitted.%0
E_BTW_CONTEXTREF_SELF_REFERENCE | 0x5121 | Return or Release referring to a context from within that context is not permitted.%0
E_BTW_ASYNC_ACTION_COM_NOT_ALLOWED | 0x5400 | An asynchronous action must refer to a non-COM port.%0
E_BTW_CONNECTION_PORT_HAS_TECH_BINDING | 0x5490 | The port "%1" used in a connection cannot have technology binding.%0
E_BTW_CONNECTION_PORT_REUSED | 0x5491 | The port "%1" used in a connection has been used before in the XLANG schedule.%0
E_BTW_TRANSACTIONS_NESTED | 0x54B0 | When transactions are nested, the outer transaction must be long-running.%0
E_BTW_TRANSACTIONS_NESTED_RETRY | 0x54B1 | When transactions are nested, the outer transaction cannot have retry count.%0
E_BTW_MESSAGE_HAS_NO_DECL | 0x5520 | Message "%1" has no associated declaration.%0
E_BTW_MESSAGE_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5521 | Message "%1" has unsatisfied data dependencies on "%2". The dependencies are either not getting created in the flow or are potentially expected on a port in which the "No instantiation" option has been selected.%0
E_BTW_PORT_HAS_NO_BINDING | 0x5570 | Port "%1" has no associated binding.%0
E_BTW_PORT_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5571 | Port "%1" has unsatisfied data dependencies on messages "%2". The dependencies are either not being created in the flow or are potentially expected on a port in which the "No instantiation" option has been selected.%0
E_BTW_RULE_HAS_NO_BINDING | 0x55B0 | Rule "%1" has no associated binding.%0
E_BTW_SCHEDULE_SUSPENDED | 0x55E0 | The XLANG schedule has been suspended.%0
E_BTW_SCHEDULE_STOPPED | 0x55E1 | The XLANG schedule has been stopped.%0
E_BTW_PERSIST_FAILED | 0x55E2 | The state of the XLANG schedule instance could not be saved to the database.%0
E_BTW_SUSPEND_FAILED | 0x55E3 | The XLANG schedule could not be suspended.%0
E_XLANG_SHUTTINGDOWN | 0x55E4 | The XLANG application is shutting down.%0
E_BTW_MISSING_MESSAGE_BINDING_ON_PORT | 0x5730 | The action uses port "%1" whose binding does not define the binding for message "%2".%0
E_BTW_MISSING_INCOMING_PORTREF | 0x5731 | The message used by this receive action contains a field (%1) that is connected to a port reference (%2) but the dataflow connections do not indicate that the port reference should be received.%0
E_BTW_SOURCE_PORT_HAS_NOINVOCATION | 0x5740 | The send action refers to port "%1", in which the "No instantiation" option has been selected.%0
E_BTW_MISSING_OUTGOING_PORTREF | 0x5741 | The message used by this source action contains a field (%1) that is connected to a port reference (%2) but the dataflow connections do not indicate that the port reference should be sent.%0
E_BTW_TASK_LIMIT | 0x5750 | The task has "%1!d!" actions. The current limit is "%2!d!".%0
E_BTW_SYNC_DIFFERENT_PORTS | 0x5760 | Synchronous action pair refers to different ports: "%1" and "%2".%0
E_BTW_SYNC_SAME_MESSAGE | 0x5761 | Synchronous action pair refers to the same message: "%1".%0
E_BTW_SYNC_ONLY_COM_ALLOWED | 0x5762 | Synchronous action pair must refer to COM port only.%0
E_BTW_SYNC_SECOND_MESSAGE_MUST_BE_OUT_FOR_FIRST_MESSAGE | 0x5763 | In a synchronous action pair the message in the second action must be the out message for the message in the first action.%0
E_BTW_INVALID_DELAY_TIME | 0x5770 | The delay time (%1!d!) is not valid. The delay time cannot be a negative number.%0
E_BTW_CALL_MESSAGE_SCHEMA_NAME_MISMATCH | 0x5800 | The message specification name "%1" for the message "%2" in the calling XLANG schedule does not match the specification name "%3" in the called XLANG schedule.%0
E_BTW_CALL_MESSAGE_SCHEMA_REPRESENTATION_MISMATCH | 0x5801 | The message specification representation for message "%1" in the calling XLANG schedule does not match the specification representation in the called XLANG schedule.%0
E_BTW_ASSIGNMENT_PORT_HAS_TECH_BINDING | 0x5830 | Port "%1" used in an assignment in a cut form cannot have technology binding.%0
E_BTW_PARTITION_LIMIT | 0x5850 | The partition has "%1!d!" process(es). The current limit is "%2!d!".%0
E_BTW_MESSAGE_USED_IN_PARALLEL | 0x5851 | Parallel actions or processes use the same message "%1".%0
E_BTW_PORT_USED_IN_PARALLEL | 0x5852 | Parallel actions or processes use the same port "%1".%0
E_BTW_INVALID_RETRY_COUNT | 0x5A30 | The retry count "%1!d!" is not valid. The retry count cannot be negative.%0
E_BTW_INVALID_BACKOFF_VALUE | 0x5A31 | The back-off value "%1!d!" is not valid. The back-off value cannot be negative.%0
E_BTW_INVALID_TIMEOUT_VALUE | 0x5A32 | The timeout value "%1!d!" is not valid. The timeout value cannot be negative.%0
E_BTW_FIELD_RESERVED_NAME | 0x5A50 | %1 is a reserved field name.%0
E_BTW_ELEMENT_TYPE_NOT_DEFINED | 0x5A51 | The element type "%1" is not defined.%0
E_BTW_ELEMENT_TYPE_INCOMPLETE | 0x5A70 | The element type definition is incomplete. Provide either subelements or dt:type.%0
E_BTW_MULTIPLE_PORTS | 0x5A90 | Distinct ports "%1" and "%2" are used on the same field.%0
E_XLANG_INVALID_COMPARE_TYPE | 0x5A91 | Comparison of this data type is not permitted.%0
E_BTW_FIELD_NOT_MATCHING_SCHEMA_ELEMENT | 0x5A92 | FieldBinding for "%1" does not have a matching element in the schema at position "%2!d!".%0
E_BTW_FIELD_HAS_AMBIGUOUS_DATAFLOW | 0x5A93 | A message field cannot have both a data flow from another message field and a reference to a port. One of the data flows must be removed.%0
E_BTW_PORT_TARGET_INVALID | 0x5A94 | The type of this field is inappropriate for use as a port reference. Ports bound to a COM component can be communicated as object references or strings. Ports bound to Message Queuing may only be transferred as strings. Internal ports can be communicated only as object references.%0
E_BTW_FIELD_TARGET_INVALID | 0x5A95 | The target field "%1", which is of variant type "%2", cannot get data from source field "%3", which is of variant type "%4".%0
E_BTW_INITIALIZED_MESSAGEFIELD_INVALID_OVERWRITE | 0x5A96 | The data in field "%1" of an initialized message "%2" cannot be overwritten with data from another message or port in the binding specification.%0
E_BTW_DATAFLOW_INCOMPLETE | 0x5AB1 | A source action accepting [in] parameters must have the corresponding fields populated by data flow (that is, "from").%0
E_BTW_DATAFLOW_FROM_SYSTEM_FIELD | 0x5AB2 | Port cannot be initialized from a system field.%0
E_BTW_DATAFLOW_FROM_CONSTANT_FIELD | 0x5AB3 | Port cannot be initialized from a constant message field.%0
E_BTW_MISSING_SCRIPT_EXPRESSION | 0x5AC0 | No script expression was supplied for the rule.%0
E_BTW_BAD_SCRIPT_EXPRESSION | 0x5AC1 | %1 %2 at character position %3!d! in "%4".%0
E_BTW_MAP_INVALID_BINDING | 0x5AE0 | The binding for message "%1" must contain a reference for mapped port "%2".%0
E_BTW_MESSAGE_BINDING_SCHEMA_MISMATCH | 0x5AE1 | There is a mismatch between the binding and schema for the message "%1".%0
E_BTW_MESSAGEDECL_INIT_DATA_UNAVAILABLE | 0x5B00 | Unable to obtain initialization data for field "%1".%0
E_BTW_LATENCY_INVALID_VALUE | 0x5B20 | The Latency property value must be a non-negative integer that is less than the maximum long integer "%1!d!".%0
E_BTW_PORT_LATENCY_ON_INTERNAL | 0x5B21 | Cannot specify latency on an internal port.%0
E_BTW_MESSAGE_TECHNOLOGY_MISMATCH | 0x5BB0 | There is a mismatch between the port "%1" technology "%2" and the message "%3" technology "%4".%0
E_BTW_FIELD_TECHNOLOGY_MISMATCH | 0x5BC0 | There is a mismatch between the message "%1" technology "%2" and the field "%3" technology "%4".%0
E_BTW_COM_PORT_NOT_CREATABLE | 0x5C10 | If a COM port can be invoked, it must have a CLSID, a ProgID, or a moniker.%0
E_BTW_AUTORETURN_COM_PORT_MUST_BE_USED_INSIDE_CONTEXT | 0x5C11 | The port "%1", which is configured to abort a transaction if a method returns a failure HRESULT, can only be used inside a transaction.%0
E_BTW_COM_PORT_GENERAL_ACCESS_FAILURE | 0x5C12 | A COM port can be invoked. Please refer to the Windows 2000 documentation.%1%0
E_BTW_COM_PARAMETERS_LIMIT | 0x5C20 | The method has "%1!d!" parameter(s). The current limit is "%2!d!".%0
E_BTW_COM_NO_MATCHING_RETURN | 0x5C21 | The COM method has no matching Return.%0
E_BTW_COM_NO_MATCHING_METHOD | 0x5C22 | The COM Return has no matching method.%0
E_BTW_INVALID_SLOT_NUMBER | 0x5C23 | The slot number "%1!d!" is not valid. Slot numbers cannot be less than the following value: SLOT_NONE(-1).%0
E_BTW_INVALID_INVOKE_KIND | 0x5C24 | The invokeKind value "%1!d!" is not valid. Acceptable values are: 1,2,3,4 and 8.%0
E_BTW_PROXY_DISCONNECTED | 0x5C25 | The proxy has been disconnected.%0
E_BTW_COM_DISPATCH_SLOT_SPECIFIED | 0x5C26 | A slot number cannot be specified for the dispatch interface.%0
E_BTW_COM_SPECIFY_DISPID_OR_SLOT | 0x5C27 | Valid values for dispid or slot must be specified.%0
E_BTW_COM_INVALID_BYREF_FOR_RETURN_MESSAGES | 0x5C30 | Byref should be "1" since "%1" is a <com:return> message.%0
E_BTW_COM_INVALID_NESTED_VARIANTS | 0x5C31 | More than one level of nesting for variants is not permitted.%0
E_BTW_COM_FIELD_INDEX_MUST_BE_NON_NEGATIVE | 0x5C32 | The index "%1!d!" for the field is not valid. The index must be a non-negative integer.%0
E_BTW_COM_FIELD_INDEX_REPEATED | 0x5C33 | The index "%1!d!" for the field has been used before on another field in the message.%0
E_BTW_COM_FIELD_INDEX_NOT_CONTIGUOUS | 0x5C34 | For synchronous action pair messages "%1" and "%2", the index "%3!d!" for a field is not valid. The field indices for these messages must form a contiguous block of non-negative numbers that start with zero.%0
E_BTW_MSMQ_NO_MQRT_DLL | 0x5D00 | The Message Queue DLL, MQRT.DLL, cannot be loaded.%0
E_BTW_MSMQ_CREATECHANNEL | 0x5D01 | MQBinder: CreateChannel failed for: %1.%0
E_BTW_MSMQ_NOT_CONFIGERED_PROPERLY | 0x5D02 | The Message Queuing Service is not configured properly. A queue object could not be opened %1.%0
E_BTW_MSMQ_NO_CERTIFICATE_AVAILABLE | 0x5D03 | The Message Queuing Service is not able to obtain a certificate.%1%0
E_BTW_MSMQ_NO_WELLKNOWN_QUEUE_NAME | 0x5D04 | A message cannot be sent to a known queue because the queue is not named in the XLANG schedule. You must provide a queue name in the XLANG schedule.%1%0
E_BTW_MSMQ_INVALID_FIELD_TYPE | 0x5D05 | The field type specified for message "%1" field "%2" is not valid.%0
E_BTW_MSMQ_PORT_NOT_BOUND | 0x5D06 | The Message Queuing port is not bound.%1%0
E_BTW_MSMQ_QUEUE_NOT_TRANSACTIONAL | 0x5D10 | The queue does not have the correct transactional properties.%1%0
E_BTW_MSMQ_OPEN_ACCESSDENIED | 0x5D11 | A Message Queuing access denied error occurred when opening the queue. Compare the accessRole specified for the queue in the XLANG schedule with the rights associated to the current user.%1%0
E_BTW_MSMQ_OPEN_GENERALFAILURE | 0x5D12 | A Message Queuing failure occurred when opening the queue. Refer to the Message Queuing Service documentation in Windows 2000 to look up the error code and diagnose as appropriate.%1%0
E_BTW_MSMQ_PORT_NOT_CREATABLE | 0x5D13 | A port that is implemented by using a message queue must have a queue name.%0
E_BTW_MSMQ_GENERAL_QUEUE_ACCESS_FAILURE | 0x5D14 | A Message Queuing failure occurred when accessing the queue. Refer to the Message Queuing Service documentation in Windows 2000 to look up the error code and diagnose as appropriate.%1%0
E_BTW_MSMQ_INVALID_MESSAGE_VT_TYPE | 0x5D20 | The Message Queuing message is of unknown format.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGETYPE | 0x5D21 | The Message Queuing message is of unknown message type. The message type could not be obtained from the message.%1%0
E_BTW_MSMQ_MESSAGE_UNAUTHENTICATED | 0x5D22 | The Message Queuing message is not authenticated but the port only accepts authenticated messages.%1%0
E_BTW_MSMQ_MESSAGE_INCORRECT_AUTHENTICATE_LEVEL | 0x5D23 | The Message Queuing message is not authenticated at the requested level.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGE | 0x5D24 | The Message Queuing message has a message body that is not valid.%1%0
E_BTW_MSMQ_MESSAGE_NOT_SEND | 0x5D25 | The Message Queuing message could not be sent.%1%0
E_BTW_MSMQ_MESSAGE_SCHEMAVALIDATION_FAILED | 0x5D26 | The Message Queuing message was not successfully validated against the schema that was provided. Check the schema and the schema path.%1%0
E_BTW_MSMQ_COULD_NOT_CREATE_MQMESSAGE | 0x5D27 | The message instance could not be converted to a Message Queuing message. %1%0
E_BTW_MSMQ_NO_TRUSTRELATIONSHIP_FOR_USER | 0x5D28 | The trust relationship for the provided user could not be established.%1%0
E_BTW_MSMQ_MESSAGE_EMPTY_MESSAGE | 0x5D29 | The Message Queuing message has an empty message body.%1%0
E_BTW_MSMQ_MESSAGE_ONLY_ONE_EMPTY_XPATH_ALLOWED | 0x5D2A | The Message Queuing message can have only one field with an empty node path (XPath).%0
E_BTW_MSMQ_MESSAGE_ONE_EMPTY_XPATH_NEEDED | 0x5D2B | The Message Queuing message must have one field with an empty node path (XPath).%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGEBODY | 0x5D2C | The Message Queuing message has a message body that is not valid.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGESTRING | 0x5D2D | The Message Queuing message has an invalid string for the message body.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGE | 0x5D2E | The Message Queuing message is an invalid or unknown message and was moved to the dead-letter queue.%1%0
E_BTW_MSMQ_MESSAGE_TYPE_CONFLICTING_SCHEMA | 0x5D2F | The Message Queuing messages "%1" and "%2", which are of type "%3" on port "%4", have conflicting specification representations. This could be because the name, type, or XPath query does not match for one of the fields in the two representations.%0
E_BTW_MSMQ_DOCUMENT_FIELD_TYPE_NOT_STRING | 0x5D30 | A Message Queuing message's field "%1", that has an empty node path (XPath), must be a string data type.%0
E_BTW_MSMQ_DOCUMENT_FIELD_CANNOT_CONVERT_TO_STRING | 0x5D31 | A Message Queuing message's field could not be converted to a string.%1%0
E_BTW_MSMQ_DOCUMENT_FIELD_CONVERTION_FAILURE | 0x5D32 | The Message Queuing message's field could not be converted.%1%0
E_BTW_CANT_DISPOSE_MESSAGE | 0x6001 | The XLANG schedule instance was bound to a queue that received a message that is not valid. The XLANG Scheduler Engine was unable to transfer this message to the dead-letter queue, so the schedule instance has been terminated.%0

Related Topic

Configure Event Viewer for BizTalk Server errors


Standard COM Error Messages

The following table shows the most common standard COM errors returned by the properties and methods of the BizTalk Server objects.

Constant | Value (32-bit) | Description
S_OK | 00000000 | The standard return value used to communicate successful completion.
S_FALSE | 00000001 | An alternate success value, typically used to communicate successful, but non-standard completion. The precise meaning depends on the method or property in question.
E_UNEXPECTED | 8000FFFF | Catastrophic failure error.
E_NOTIMPL | 80004001 | Not implemented error.
E_OUTOFMEMORY | 8007000E | Out of memory error.
E_INVALIDARG | 80070057 | One or more arguments are not valid error.
E_NOINTERFACE | 80004002 | Interface not supported error.
E_POINTER | 80004003 | Pointer not valid error.
E_HANDLE | 80070006 | Handle not valid error.
E_ABORT | 80004004 | Operation aborted error.
E_FAIL | 80004005 | Unspecified error.
E_ACCESSDENIED | 80070005 | General access denied error.
MK_E_NOOBJECT | 800401E5 | The object identified by this moniker could not be found.

Additional information may be available using the global Err object. In Visual Basic, the Description property of the Err object may contain a text description of the error.

In C++, call the OLE DB method GetErrorInfo on the IErrorRecords interface to retrieve the most recently set IErrorInfo pointer in the current logical thread. The GetDescription method of the IErrorInfo interface may return a text description of the error. For more information about the GetErrorInfo method, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to OLE DB Interfaces in the Platform SDK.


BizTalk Server-Glossar

A

Abbruch (abort)

Eine laufende Transaktion wird abgebrochen. In Orchestrierungsablaufplänen wird das XLANG-Ablaufplanungsmodul mithilfe von Abbruch-Formen angewiesen, Transaktionseinträge abzubrechen und die atomare Transaktion als fehlgeschlagen zu betrachten. Fehlgeschlagene Transaktionen können u. U. Bei Fehler von Transaktion-Code ausführen.

Siehe auch: Transaktion (transaction), Commit

Abfrage (query)

Ein Ausdruck, der zur Suche nach Informationen verwendet wird. In der BizTalk-Dokumentüberwachung ist eine Abfrage eine SQL-Anweisung, mit der Sie Überwachungsdaten unter Verwendung von Standardsuchkriterien, z. B. Quellorganisation, aus der Überwachungsdatenbank abrufen können.

Siehe auch: Erweiterte Abfrage (advanced query)

Aktion (action)

Eine Nachricht wird gesendet oder empfangen. Sende- oder Empfangsaktionen können synchron oder asynchron sein, abhängig von den in einem XLANG-Ablaufplan implementierten Anwendungsdiensten.

Aktivieren (rehydrate)

Ruft alle Statusinformationen für eine XLANG-Ablaufplaninstanz aus einer SQL Server-Datenbank ab, nachdem das XLANG-Ablaufplanmodul eine Nachricht erhalten hat.

Siehe auch: XLANG-Ablaufplanungsmodul (XLANG scheduler engine)

Angehalten-Warteschlange (Suspended queue)

Eine Tabelle innerhalb der Datenbank für gemeinsam genutzte Warteschlangen in Microsoft SQL Server. Die Angehalten-Warteschlange ist mit einer Servergruppe verbunden. Die Warteschlange enthält Arbeitselemente, bei denen während der Verarbeitung Fehler aufgetreten sind. Die Dokumente werden in der Warteschlange gespeichert, bis sie korrigiert, erneut verarbeitet oder gelöscht werden.

Siehe auch: Wiederholungswarteschlange (Retry queue), Geplant-Warteschlange (Scheduled queue), Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database), Verarbeitungswarteschlange (Work queue)

ANSI X12

EDI-Standard, der vom Accredited Standards Committee X12 festgelegt wurde. Diese Institution ist vom American National Standards Institute anerkannt.

Anwendungsintegrationskomponente (Application Integration Component, AIC)

Ein COM-Objekt, das vom BizTalk Server-Statusmodul aufgerufen wird, um Daten an eine Anwendung zu übermitteln. Wurde ein Messagingport in BizTalk Server 2002 für die Verwendung einer AIC zur Anwendungsintegration konfiguriert, wird diese Komponente automatisch instanziiert, und die erforderlichen Daten werden entsprechend weitergeleitet. Anschließend ermittelt die Komponente, wie diese Daten an die Anwendung zurückgegeben werden sollen. Dies kann durch Verwenden von privaten API-Aufrufen, Aufrufen von anderen COM-Objekten, Verwenden von Schreibvorgängen in der Datenbank usw. geschehen.

Application Center 2000

Ein Microsoft-Produkt, das das Migrieren von Anwendungen während des Entwicklungszyklus (von der Entwicklung über das Testen bis zur Produktion) erleichtert. Application Center stellt Konsistenz zwischen einer Entwicklungsanwendung, einer Testanwendung und einer Produktionsanwendung sicher. Da Application Center die Bereitstellung von Anwendungen von einem Server zu einem anderen automatisiert, wird die Übertragungszeit verkürzt, manuelle Fehler werden reduziert, und die Qualität der Versionen wird verbessert.

Application Center 2000-Cluster

Eine Gruppe unabhängiger Server, die als eine Computerressource zusammengefasst werden. Ein Application Center-Cluster greift nicht gemeinsam auf Ressourcen zu; stattdessen wird Verfügbarkeit bereitgestellt, indem fehlgeschlagene Clustermitglieder isoliert und ignoriert werden. Im Vergleich dazu stellt Microsoft Windows Clustering Zuverlässigkeit durch gemeinsamen Ressourcenzugriff und Failover bereit.

Asynchrone Kommunikation (asynchronous communication)

Eine Interaktion zwischen zwei oder mehreren Prozessen, bei der ein Prozess mit einem anderen kommuniziert und die Verarbeitung unabhängig von dem anderen Prozess fortsetzen kann.

Siehe auch: Synchrone Kommunikation (synchronous communication)

Attribut (attribute)

Ein Merkmal eines Datensatzes oder Feldes. Ein Attribut kann mehrere Eigenschaften umfassen.

Ausgabeinstanz (output instance)

Eine Datei, die sich aus der Verarbeitung einer Eingabeinstanz durch das kompilierte Stylesheet ergibt.

Siehe auch: Eingabeinstanz (input instance)

Äußere Transaktion (outer transaction)

Eine Transaktion, deren Prozessfluss eine oder mehrere andere Transaktionen enthält.

Siehe auch: Innere Transaktion (inner transaction), Langlebige Transaktion (long running transaction), Geschachtelte Transaktion (nested transaction), Transaktion (transaction)

Austausch (interchange)

Eine oder mehrere Dokumentinstanzen, die eine einzelne Übertragung bilden und zwischen Anwendungen innerhalb einer Organisation oder zwischen Handelspartnern ausgetauscht werden.

Auswahlkriterien (selection criteria)

Ein Name/Wert-Paar, das in einer Dokumentdefinition festgelegt wurde. Name/Wert-Paare werden verwendet, um eine Dokumentdefinition für eingehende EDI-Austauschvorgänge auf der Basis von Werten in der Funktionsgruppenkopfzeile eindeutig zu identifizieren und um Werte in der Funktionsgruppenkopfzeile für ausgehende EDI-Austauschvorgänge einzufügen.

Siehe auch: Dokumentdefinition (document definition), EDI (Electronic Data Interchange)

B

Benutzerdefinierte Leistungsindikatoren (custom counters)

Werte, mit denen Benutzer auf der Basis einer erweiterten Abfrage der Überwachungsdatenbank eigene WMI-Klasseninstanzen (Windows Management Instrumentation) erstellen können.

Benutzerdefinierte Regeln (user-defined rules)

MOM-Regeln (Microsoft Operations Manager), die vom Benutzer entworfen, erstellt und konfiguriert werden.

Siehe auch: Vollständig konfigurierte Regeln (fully configured rules)

Bindung (binding)

Ein Prozess, bei dem die zur Implementierung eines Ports zu verwendende Technologie festgelegt wird.

Siehe auch: Port

BizTalk Accelerator for HIPAA

Ein Add-On-Produkt zu Microsoft BizTalk Server 2002, mit dem Organisationen schnell und einfach HIPAA-Lösungen erstellen können. BizTalk Accelerator for HIPAA enthält mehrere Anwendungen, mit denen Gesundheitsversorgungsunternehmen, Zahler und Clearing Houses (die im Namen der Provider und Zahler handeln) HIPAA-spezifische Transaktionen austauschen, überwachen und kontrollieren können. Darüber hinaus stellt BizTalk Accelerator for HIPAA die erforderlichen Dokumentspezifikationen, Anwendungen und Komponenten bereit, um schnell BizTalk Server 2002-basierte Lösungen zu entwickeln, die HIPAA-spezifisch sind.

BizTalk-Dokumentüberwachung (BizTalk Document Tracking)

Eine webbasierte Benutzeroberfläche, die für den Zugriff auf Überwachungsinformationen zu BizTalk-Messagingdiensten verwendet wird. Darüber hinaus kann der XLANG-Ablaufplanzustand für BizTalk-Orchestrierungsdienste überwacht werden.

BizTalk-Editor

Ein Tool, mit dem Sie Spezifikation erstellen, bearbeiten und verwalten können. Mit dem BizTalk-Editor können Sie eine Spezifikation auf der Basis einer Spezifikationsvorlage, eines vorhandenen Schemas, bestimmter Typen von Dokumentinstanzen oder einer leeren Spezifikation erstellen.

BizTalk Framework

Ein plattformunabhängiges <nobr>E-Commerce-Framework</nobr>, das auf XML-Schemas (Extensible Markup Language) und Industriestandards basiert. Auf dieser Grundlage ist eine branchenübergreifende Integration zwischen Geschäftssystemen möglich, unabhängig von der Plattform, dem Betriebssystem oder der zugrunde liegenden Technologie. Das Framework besteht aus drei Komponenten: Schema, Produkten und Diensten. Weitere Informationen zu BizTalk Framework finden Sie in der BizTalk-Website (www.microsoft.com/biztalk/).

BizTalk-Mapper

Mit diesem Tool können Sie Zuordnungen erstellen, die die Entsprechungen zwischen den Datensätzen und Feldern in einer Spezifikation und den Datensätzen und Feldern in einer anderen Spezifikation definieren. Eine Zuordnung enthält ein XSL-Stylesheet (Extensible Stylesheet Language), mit dem BizTalk Server die in der Zuordnung beschriebene Transformation durchführt.

BizTalk-Messaging-Manager

Eine grafische Benutzeroberfläche, mit der BizTalk-Messagingdienste für den Austausch von Dokumenten zwischen Handelspartnern und Anwendungen der eigenen Organisation konfiguriert werden können.

Siehe auch: BizTalk-Messagingdienste (BizTalk Messaging Services)

BizTalk-Messaging-Verwaltungsdatenbank (BizTalk Messaging Management database)

Eine Microsoft SQL Server-Datenbank, die Informationen zu sämtlichen Serverkonfigurationen enthält, z. B. Gruppen- und Servereinstellungen, Empfangsfunktionen und alle Messagingkonfigurationsinformationen für Objekte, die mithilfe des BizTalk-Messaging-Managers oder durch Zugriff auf die BizTalk-Messaging-Konfigurationsobjektmodelle erstellt wurden.

BizTalk-Messagingdienste (BizTalk Messaging Services)

Diese Dienste umfassen das Senden, Empfangen, Analysieren und Überwachen von Dokumenten, die Generierung und Korrelation von Empfangsbestätigungen sowie die Datenzuordnung, -integrität und -sicherheit.

Siehe auch: BizTalk-Messaging-Manager

BizTalk-Orchestrierungs-Designer

Mit diesem Designtool können Sie Zeichnungen erstellen, die langlebige ausführbare Geschäftsprozesse mit flexiblen Verbindungen darstellen. Die XLANG-Ablaufplanzeichnung wird in einen XLANG-Ablaufplan kompiliert, der zur Ausführung automatischer Geschäftsprozesse verwendet wird.

BizTalk-Orchestrierungsdienste (BizTalk Orchestration Services)

Zu diesen Diensten gehören das Entwerfen, Kompilieren und Ausführen von XLANG-Ablaufplänen. Außerdem besteht die Möglichkeit, benutzerdefinierte COM+-Anwendungen für das Hosting dezidierter XLANG-Ablaufplaninstanzen zu erstellen sowie die Persistenz von XLANG-Ablaufplänen sicherzustellen.

BizTalk-SEED-Assistent (BizTalk SEED Wizard)

Ein Tool, das einer Firma die Erstellung eines XML-Pakets ermöglicht, welches die Konfiguration der Firma enthält. Nachdem das Paket erstellt wurde, können Handelspartner die Konfiguration mithilfe des BizTalk-SEED-Assistenten in ihrer Organisation installieren, so dass sie über das Internet Geschäfte mit der initiierenden Firma tätigen können.

BizTalk Server 2002

Ein Microsoft-Produkt für die Automatisierung von Geschäftsprozessen und die Anwendungsintegration in und zwischen Unternehmen. BizTalk Server 2002 stellt eine leistungsstarke webbasierte Entwicklungs- und Ausführungsumgebung bereit, die flexibel verbundene, langlebige Geschäftsprozesse sowohl innerhalb von Unternehmen und als auch zwischen Unternehmen integriert.

BizTalk Server 2002 umfasst die folgenden Features: die Komposition neuer und vorhandener XLANG-Ablaufpläne; die Integration zwischen vorhandenen Anwendungen; die Definition von Dokumentspezifikationen und Spezifikationstransformationen; die Überwachung und Protokollierung von Laufzeitaktivität.

Der Server stellt einen Standardgateway für das Senden und Empfangen von Dokumenten über das Internet bereit sowie eine Reihe von Diensten zum Sicherstellen der Datenintegrität, der Übermittlung, der Sicherheit und der Unterstützung für das BizTalk Framework und anderer wichtiger Dokumentformate.

BizTalk Server Accelerator for RosettaNet

Ein Add-On-Produkt zu Microsoft BizTalk Server 2002, mit dem Organisationen schnell und einfach RosettaNet-Lösungen erstellen können. BizTalk Server Accelerator for RosettaNet enthält mehrere Anwendungen, die Benutzern das Entwickeln, Verwalten und Testen von PIPs (Partner Interface Processes) ermöglichen, die mit RosettaNet-Standards kompatibel sind und als BizTalk Server 2002 XLANG-Ablaufpläne implementiert wurden.

BizTalk Server-Verwaltung (BizTalk Server Administration)

Eine MMC-Schnittstelle (Microsoft Management Console), die für die Verwaltung der BizTalk Server 2002-Servergruppe und ihre Eigenschaften, die Überwachung von Empfangsfunktionen und die Überwachung von Arbeitselementen in den von der Servergruppe verwendeten Microsoft SQL Server-Warteschlangen verwendet wird.

C

Cluster

Eine Gruppe unabhängiger Server, die als einzelnes System verwaltet werden, um die Verfügbarkeit, Verwaltbarkeit und Skalierbarkeit zu steigern. Für ein Servercluster müssen die folgenden Mindestanforderungen erfüllt sein: zwei Server, die über ein Netzwerk miteinander verbunden sind, eine Methode für jeden Server, über die dieser auf die Festplattendaten des anderen Servers zugreifen kann, und eine spezielle Clustersoftware, z. B. Windows Clustering. Die spezielle Software stellt Dienste, wie Fehlererkennung, Wiederherstellung und die Fähigkeit zur Verwaltung der Server, als ein System bereit.

Codeliste (code list)

Eine Liste von Codewerten, die als Abkürzungen für eine Vielzahl von Textinformationen verwendet werden. Beispielsweise steht der Wert ST in der Codeliste für Ship To und wird zur Angabe einer Adresse verwendet.

Commit

Implementiert alle Änderungen, die von einer anstehenden Transaktion angefordert wurden. Diese Aktion wird durchgeführt, wenn alle Aktionen innerhalb einer Transaktion erfolgreich abgeschlossen wurden.

Siehe auch: Abbruch (abort), Transaktion (transaction)

D

Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database)

Eine Microsoft SQL Server-Datenbank, die von allen Servern in einer Servergruppe gemeinsam verwendet wird. In der Datenbank für gemeinsam genutzte Warteschlangen sind sämtliche Prüfpunktinformationen gespeichert, die sich auf von BizTalk Server verarbeitete Dokumente beziehen. Im Fall eines Serverfehlers können andere Computer, die dieselbe Datenbank für gemeinsam genutzte Warteschlangen verwenden, weiterhin Nachrichten aus der Verarbeitungswarteschlange abrufen bzw. an diese senden. Auf diese Weise werden Redundanz und Prozesslastenausgleich bereitgestellt. Die Datenbank für gemeinsam genutzte Warteschlangen wird in der BizTalk Server-Verwaltung grafisch als eine Reihe verschiedener Warteschlangen dargestellt.

Siehe auch: Wiederholungswarteschlange (Retry queue), Geplant-Warteschlange (Scheduled queue), Angehalten-Warteschlange (Suspended queue), Verarbeitungswarteschlange (Work queue)

Datenkonvertierung (data translation)

Ein Prozess, bei dem Daten von einem Format in ein anderes konvertiert werden. Datenkonvertierungen werden zur Laufzeit von BizTalk Server durchgeführt. Die in der Zuordnung definierten Regeln werden verwendet, um Daten mit dem Format der Quellspezifikation in das Format der Zielspezifikation zu konvertieren und um gegebenenfalls erforderliche Operationen oder Berechnungen an den Daten durchzuführen.

Siehe auch: Kompilieren (compile), Datenzuordnung (data mapping), Zuordnung (map), XML (Extensible Markup Language)

Datenzuordnung (data mapping)

Im BizTalk-Mapper kann eine Entsprechung zwischen den Datensätzen und Feldern einer Quellspezifikation und Datensätzen und Feldern einer Zielspezifikation hergestellt werden.

Siehe auch: Kompilieren (compile), Datenkonvertierung (data translation)

Dokument mit automatischem Routing (self-routing document)

Ein Dokument, das alle erforderlichen Routinginformationen, z. B. Quellbezeichner und Zielorganisationskennzeichen und eine Dokumentdefinition in den Routingtags oder innerhalb des Dokuments enthält.

Dokument ohne automatisches Routing (non-self-routing document)

Ein Dokument, dem eine oder mehrere der folgenden Routinginformationen fehlen: Quellorganisationskennzeichen, Zielorganisationskennzeichen oder Dokumentdefinition.

Dokumentdefinition (document definition)

Eine Reihe von Eigenschaften, die ein bestimmtes Dokument repräsentiert. Dokumentdefinitionseigenschaften enthalten einen Verweis auf eine Dokumentspezifikation und können außerdem globale Überwachungsfelder und Auswahlkriterien enthalten.

Siehe auch: Globale Überwachungsfelder (global tracking fields), Auswahlkriterien (selection criteria)

Dokumentinstanz (document instance)

Eine Darstellung der tatsächlichen Daten, die an BizTalk Server gesendet wird. Der Unterschied zwischen einer Dokumentinstanz und einer Spezifikation besteht darin, dass die Spezifikation die Struktur der Daten definiert, während eine Dokumentinstanz die konkreten Daten innerhalb einer Struktur darstellt.

Siehe auch: Globale Überwachungsfelder (global tracking fields), Pass-Through-Versendung (pass-through submission)

Dokumentmessaging (document messaging)

Verwendet die BizTalk-Messagingdienste zum Senden, Empfangen, Analysieren und Überwachen von Nachrichtendokumenten.

Dokumentstandard (document standard)

Die Struktur, die eine Transaktionsmenge definiert, z. B. ein X12 850-Standard. Anhand eines Dokumentstandards kann ein Implementierungsbericht erstellt werden.

Dokumenttyp (document type)

Bezeichnung des Dokumenttyps, auf dem eine Spezifikation basiert. Wenn eine Spezifikation beispielsweise auf dem X12-Standard 850Schema.xml basiert und diese Spezifikation im BizTalk-Editor geöffnet wird, wird 850 im Feld Dokumenttyp auf der Registerkarte Verweis für den Stammknoten angezeigt.

Dokumenttypdefinition (document type definition, DTD)

Eine Standarddefinition, die angibt, welche Elemente und Attribute in anderen Elementen und Attributen enthalten sind, und die Beschränkungen bezüglich deren Reihenfolge, Häufigkeit und Inhalt festlegt.

Dynamische Warteschlange (dynamic queue)

Eine Warteschlange mit einer unbekannten Adresse. Ports, für die Message Queuing implementiert wurde, können eine dynamische Warteschlange verwenden, wenn der Standort der Warteschlange nicht bekannt ist. Die Adresse für diese Warteschlange muss durch eine Nachricht bereitgestellt werden, die die Warteschlangenadresse zur Laufzeit an den Portverweis (Port Reference) weiterleitet.

Siehe auch: Statische Warteschlange (static queue), Pro-Instanz-Warteschlange (per-instance queue)

Dynamischer Port (dynamic port)

Ein Port, der spezielle Standortinformationen für einen XLANG-Ablaufplan zur Laufzeit anfordert. Der Standort für einen dynamischen Port wird durch eine Nachricht bereitgestellt, die Standortinformationen zur Laufzeit an den Portverweis (Port Reference) weiterleitet.

Siehe auch: Statischer Port (static port), Port

E

EDI (Electronic Data Interchange)

Eine Reihe von Standards, über die die Übertragung von Dokumenten, z. B. Aufträge oder Rechnungen, zwischen Computern gesteuert wird.

Siehe auch: Auswahlkriterien (selection criteria)

EDIFACT

Steht für Electronic Data Interchange For Administration, Commerce, and Transport. Der internationale EDI-Standard, der von den Vereinten Nationen entwickelt wurde. Dieser Standard ist in Europa sowie in Japan und anderen asiatischen Ländern/Regionen verbreitet. Wird auch als UN/EDIFACT bezeichnet.

Eigene Organisation (home organization)

Ein Objekt, das Ihr Unternehmen im BizTalk-Messaging-Manager darstellt. Die eigene Organisation wird bei der Installation von BizTalk Server 2002 erstellt. Nur die eigene Organisation kann über Anwendungen verfügen.

Siehe auch: Zielanwendung (destination application), Verteilerliste (distribution list), Organisation (organization), Quellanwendung (source application), Handelspartner (trading partner)

Eingabeinstanz (input instance)

Ein Dokument mit Inhalten, das einem bestimmten Schema oder einer bestimmten Spezifikation entspricht.

Siehe auch: Ausgabeinstanz (output instance)

Element

Eine Reihe von Markuptags, die benannte Abschnitte von Informationen identifiziert. Die Tags in einem Element identifizieren den Namen sowie Anfang und Ende des Elements.

Empfänger (recipient)

Ein Handelspartner, der ein SEED-Paket von einer initiierenden Firma (Initiator) empfängt, um mit dieser Firma Geschäftsdokumente austauschen zu können. Ein typisches Szenario ist das einer Firma, die mit mehreren Handelspartnern desselben Typs Geschäfte tätigt; die zentrale Firma wird als "Initiator" und die Handelspartner werden als "Empfänger" bezeichnet.

Siehe auch: Initiator, SEED-Paket (SEED package)

Empfangsfunktionen (receive functions)

Funktionen, mit denen jeder BizTalk-Server Verzeichnisse überwachen und zu verarbeitende Dokumente an BizTalk Server versenden kann. BizTalk Server 2002 unterstützt Datei-, HTTP- und Message Queuing-Empfangsfunktionen.

Empfangskanal (receipt channel)

Ein Kanal, der Informationen enthält, die zur Verarbeitung einer Empfangsbestätigung erforderlich sind, welche an den Absender eines Dokuments zurückgegeben wird.

Siehe auch: Kanal (channel)

Entscheidung (decision)

Ein Prozess, bei dem eine oder mehrere Regeln nacheinander ausgewertet werden. Im BizTalk-Orchestrierungs-Designer wird eine Entscheidung durch die Entscheidung-Form dargestellt. Regeln sind VBScript-Ausdrücke (Microsoft Visual Basic Scripting Edition), die von Entscheidung- und While-Formen verwendet werden.

Ereignisempfänger (event consumer)

Der Empfänger von Benachrichtigungen zu System- und Anwendungsereignissen, z. B. WMI-Ereignissen (Windows Management Instrumentation) und Ereignissen des Windows NT-Ereignisprotokolls. MOM (Microsoft Operations Manager) ist beispielsweise ein Ereignisempfänger, der Ereignisbenachrichtigungen verwendet, um Warnungen auszulösen, Administratoren zu benachrichtigen und Skripts auszuführen.

Siehe auch: Provider

Erneutes Senden (resubmit)

Ein Verfahren, bei dem Austauschvorgänge oder Dokumente aus der Angehalten-Warteschlange an BizTalk Server gesendet werden. Das Dokument wird ab dem Einzelpunktversagen verarbeitet.

Erweiterte Abfrage (advanced query)

Ein Ausdruck, der zum Suchen nach bestimmten Informationen verwendet wird. In der BizTalk-Dokumentüberwachung ist eine erweiterte Abfrage eine SQL-Anweisung, mit der Sie bestimmte Überwachungsdaten mithilfe von benutzerdefinierten Suchkriterien, z. B. Auftragssumme, aus der Überwachungsdatenbank abrufen können.

Siehe auch: Abfrage (query)

F

Failfast

Die frühzeitige Beendigung eines Prozesses, nachdem ein interner Fehler oder eine Inkonsistenz entdeckt wurde. Auf diese Weise werden weitere Fehler vermieden, die u. U. schwerwiegend sind und eine Wiederherstellung unmöglich machen.

Flatfile mit Trennzeichen (delimited flat file)

Eine Datei, die einen oder mehrere Datensätze enthält, welche als eine Gruppe von Feldern mit Trennzeichen dazwischen dargestellt werden. Die Datensätze selbst werden ebenfalls durch Trennzeichen voneinander abgegrenzt.

Flussdiagrammformen (flowchart shapes)

Formen, die die Verteilungslogik in einer XLANG-Ablaufplanzeichnung darstellen. Diese Kategorie von Formen umfasst Abbruch-, Aktion-, Beginn-, Entscheidung-, Ende-, Verzweigung-, Verknüpfung-, Transaktion- und While-Formen.

Siehe auch: Flussdiagrammschablone (flowchart stencil), XLANG-Ablaufplanzeichnung (XLANG schedule drawing), Kommunikationsformen (communication shapes), Implementierungsformen (implementation shapes)

Flussdiagrammschablone (flowchart stencil)

Eine Zeichnungsschablone, die vom BizTalk-Orchestrierungs-Designer bereitgestellt wird. Die Flussdiagrammschablone enthält alle Formen, die für den Entwurf des Prozessflusses eines Geschäftsprozesses, der unter Verwendung eines XLANG-Ablaufplanes durchgeführt werden kann, zur Verfügung stehen.

Siehe auch: Implementierungsschablone (implementation stencil), Flussdiagrammformen

Funktoid (functoid)

Integrierte, wiederverwendbare Funktion, die komplexe Strukturbearbeitungsoperationen zwischen Quellspezifikationselementen, Zielspezifikationselementen und anderen Funktoiden ermöglicht.

Siehe auch: Verknüpfung (link)

Funktoidpalette (functoid palette)

Eine Toolbox, die sämtliche Funktoide enthält, die zur Herstellung von Beziehungen zwischen Quellspezifikationselementen und Zielspezifikationselementen verwendet werden können.

G

Gemischter Inhalt (mixed content)

Ein Element in XML, das sowohl Textinhalt als auch Unterelemente enthält. Das Element kann darüber hinaus über Attribute verfügen.

Geplant-Warteschlange (Scheduled queue)

Eine Tabelle innerhalb der Datenbank für gemeinsam genutzte Warteschlangen in Microsoft SQL Server. Die Geplant-Warteschlange ist einer Servergruppe mit Austauschvorgängen zugeordnet, die von BizTalk Server zwar empfangen, aber noch nicht verarbeitet wurden.

Siehe auch: Wiederholungswarteschlange (Retry queue), Angehalten-Warteschlange (Suspended queue), Verarbeitungswarteschlange (Work queue), Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database)

Geschachtelte Transaktion (nested transaction)

Eine oder mehrere Transaktionen, die im Prozessfluss einer umfangreicheren Transaktion enthalten sind.

Siehe auch: Innere Transaktion (inner transaction), Langlebige Transaktion (long running transaction), Äußere Transaktion (outer transaction), Transaktion (transaction)

Globale Überwachungsfelder (global tracking fields)

In einer Dokumentdefinition festgelegte Dokumentspezifikationsfelder, die für jede Instanz eines tatsächlich von den BizTalk-Messagingdiensten verarbeiteten Dokuments in einer Überwachungsdatenbank protokolliert werden.

Siehe auch: Dokumentdefinition (document definition), Dokumentinstanz (document instance)

H

Handelspartner (trading partner)

Eine externe Organisation, mit der die eigene Organisation elektronische Daten austauscht. Der Austausch von Dokumenten unter Handelspartnern wird durch die von Ihnen erstellten Messagingports, Verteilerlisten, Kanäle und XLANG-Ablaufpläne geregelt.

Siehe auch: Kanal (channel), Verteilerliste (distribution list), Eigene Organisation (home organization), Organisation (organization), Quellorganisation (source organization)

Hierarchieebenen (Hierarchical Level, HL)

Ein Segment in einer hierarchischen Struktur, das Ebenen von Detailinformationen identifiziert, z. B. Einzelpostendaten und Lieferungsdaten bzw. Verpackungsdaten und Einzelpostendaten einander zuordnet. Mithilfe von Hierarchieebenen können Sie die Abhängigkeiten zwischen und den Inhalt von Datensegmentgruppen identifizieren, die hierarchisch miteinander verbunden sind.

I

Implementierungsformen (implementation shapes)

Diese Formen repräsentieren die Technologien, die vom XLANG-Ablaufplanungsmodul unterstützt werden. Diese Kategorie von Formen umfasst BizTalk-Messaging-, COM-Komponente-, Message Queuing- und Skriptkomponente-Formen.

Siehe auch: Flussdiagrammformen (flowchart shapes), Implementierungsschablone (implementation stencil), Kommunikationsformen (communication shapes)

Implementierungsschablone (implementation stencil)

Eine Zeichnungsschablone, die vom BizTalk-Orchestrierungs-Designer bereitgestellt wird. Die Implementierungsschablone enthält alle Formen, die zur Bindung eines Ports an eine Implementierungstechnologie verwendet werden können.

Siehe auch: Flussdiagrammschablone (flowchart stencil), Implementierungsformen (implementation shapes)

Implementierungstechnologien (implementation technologies)

Technologien, die zur Implementierung eines Ports in einem XLANG-Ablaufplan verwendet werden. Die vom XLANG-Ablaufplanungsmodul unterstützten Technologien sind COM-Komponenten, Windows-Skriptkomponenten, Message Queuing-Dienste und BizTalk-Messagingdienste.

Inaktiver Status (quiescent state)

Dieser Status bezeichnet einen Prozess, der inaktiv oder ruhend ist bzw. sich im Standbymodus befindet.

Industriestandard (industry standard)

Ein definierter Standard, der zum Austausch von Informationen verwendet wird. Standards sind erweiterbar und folgen festgelegten Regeln oder einer bestimmten Syntax.

Inhalt (manifest)

Eine Textdarstellung (üblicherweise in XML) einer Reihe zusammengehöriger Konfigurationselemente, z. B. Kanal- und Portinformationen, die zusammengefasst werden, um eine oder mehrere Anwendungen aus einer Test- oder Stagingumgebung in einer Produktionsumgebung bereitzustellen.

Initiator

Eine Firma, die mithilfe des BizTalk-SEED-Assistenten ein SEED-Paket erstellt und dieses an Handelspartner (Empfänger) sendet, um mit diesen Geschäftsdokumente austauschen zu können. Ein typisches Szenario ist das einer Firma, die mit mehreren Handelspartnern desselben Typs Geschäfte tätigt; die zentrale Firma wird als "Initiator" und die Handelspartner werden als "Empfänger" bezeichnet.

Siehe auch: SEED-Paket (SEED package), Empfänger (recipient)

Innere Transaktion (inner transaction)

Eine Transaktion, die im Prozessfluss einer anderen Transaktion enthalten ist.

Siehe auch: Langlebige Transaktion (long running transaction), Geschachtelte Transaktion (nested transaction), Äußere Transaktion (outer transaction), Transaktion (transaction)

Integration von Unternehmensanwendungen (Enterprise Application Integration, EAI)

Ein System, das separaten Anwendungen die gemeinsame Nutzung elektronischer Daten ermöglicht. Mithilfe von EAI können Organisationen Integrationsaufgaben und individuelle Transaktionen durchführen.

K

Kanal (channel)

Eigenschaften, die Quellen von Dokumenten bezeichnen und bestimmte Verarbeitungsschritte definieren, welche von den BizTalk-Messagingdiensten durchgeführt werden, bevor ein Dokument an das vom Messagingport bestimmte Ziel oder die mit dem Kanal verbundene Verteilerliste übermittelt wird.

Siehe auch: Pass-Through-Versendung (pass-through submission), Empfangskanal (receipt channel), Quellanwendung (source application), Handelspartner (trading partner), Offener Kanal (open channel), Offener Messagingport (open messaging port), Quellorganisation (source organization)

Kanal-ID (channel ID)

Ein global eindeutiger Bezeichner (Globally Unique Identifier, GUID), der von BizTalk Server 2002 zugewiesen wird, um den Kanal, über den ein Dokument verarbeitet wird, eindeutig zu identifizieren.

Kanalfilterung (channel filtering)

Vergleicht den Wert von Feldern in einer Dokumentinstanz mit Feldern in Ausdrücken, die innerhalb eines Kanals festgelegt wurden. Durch diesen Vergleich wird die Auswahl des Kanals bzw. der Kanäle gefiltert, die der Server bei der Verarbeitung eines Dokuments aufruft.

Knotenpfad (node path)

Ein Ausdruck, der verwendet wird, um Informationen zu XML-Elementen und -Attributen abzurufen, Daten auszuwählen, die bestimmten Kriterien entsprechen, und Vergleiche für die abgerufenen Daten durchzuführen. Wird auch als Xpath bezeichnet.

Siehe auch: XPath

Knowledge Base

Eine Sammlung mit Regelkommentaren, die Informationen zur Bedeutung und Wichtigkeit von Ereignissen enthält. Die Microsoft Knowledge Base enthält vordefinierte Informationen von Microsoft. Die Knowledge Base einer Firma enthält Informationen, die der Benutzer von Microsoft Operations Manager 2000 eingegeben hat.

Kommunikationsformen (communication shapes)

Formen, die den exakten Inhalt einer Nachricht sowie den Typ des Anwendungsdienstes, der in der XLANG-Ablaufplanzeichnung implementiert wurde, identifizieren. Diese Kategorie von Formen umfasst Konstanten, Nachrichten, Ports und Port References.

Siehe auch: Flussdiagrammformen (flowchart shapes), Implementierungsformen (implementation shapes), XLANG-Ablaufplanzeichnung (XLANG schedule drawing)

Kompensierung (compensation)

Ein Prozess, bei dem eine Entschädigung für eine abgeschlossene Transaktion erfolgt. Kann beispielsweise ein Auftrag, für den die Zahlung bereits eingegangen ist, nicht erfüllt werden, wird dem Käufer der Zahlungsbetrag erstattet.

Kompilieren (compile)

Im BizTalk-Mapper wird eine XSLT-Version (Extensible Stylesheet Language Transformation) einer Zuordnung erstellt, die von BizTalk Server verwendet werden kann. Die Zuordnung wird im WebDAV-Repository gespeichert und von BizTalk Server eingesetzt, um ein Dokumentformat in ein anderes zu konvertieren.

Siehe auch: Zuordnung (map), Datenzuordnung (data mapping), Datenkonvertierung (data translation), XML (Extensible Markup Language)

Konfiguration (configuration)

Ein Paket mit Informationen, das die verschiedenen Komponenten von BizTalk Server 2002 definiert, einschließlich Ressourcen wie BizTalk-Ports, BizTalk-Portgruppen, BizTalk-Empfangsfunktionen, BizTalk-Ablaufpläne und die benutzerdefinierten Leistungsindikatoren von BizTalk.

Korrelation (correlation)

Die Verknüpfung eines eingehenden Dokuments mit der korrekten Ablaufplaninstanz.

Korrelationstoken (correlation token)

Ein variabler Parameter, der nach der erfolgreichen Versendung an die HTTP-Empfangsfunktion an den Client zurückgegeben wird. Der Parameter enthält entweder einen Versendungshandle oder den Dateinamen, je nachdem, ob das Dokument an BizTalk Server oder an eine Datei gesendet wird.

Kurzfristige Transaktion (short-lived transaction)

Eine Gruppe von Aktionen, die als einzelne logische Arbeitseinheit ausgeführt wird.

Siehe auch: Langlebige Transaktion (long running transaction), Transaktion (transaction)

L

Langlebige Transaktion (long running transaction)

Aktionen, die über einen unbegrenzten Zeitraum Nachrichten senden und empfangen. Üblicherweise enthalten langlebige Transaktionen mehrere geschachtelte, kurzfristige Transaktionen.

Siehe auch: Innere Transaktion (inner transaction), Geschachtelte Transaktion (nested transaction), Äußere Transaktion (outer transaction), Kurzlebige Transaktion (short-lived transaction), Transaktion (transaction)

Leistungsindikatoren (performance counters)

Werte, die bestimmte leistungsbezogene Parameter für BizTalk Server 2002 repräsentieren und die über die Microsoft Windows 2000-Infrastruktur für Leistungsindikatoren bereitgestellt werden. Leistungsindikatoren werden üblicherweise mithilfe des Standarddienstprogramms Windows 2000-Systemmonitor angezeigt, können jedoch auch von anderen Anwendungen, z. B. MOM (Microsoft Operations Manager), verwendet werden.

LOB-Anwendung (line-of-business application, LOB)

Die Hauptgeschäftsanwendung einer Organisation. BizTalk Server 2002 unterstützt zahlreiche Kommunikationsprotokolle, über die LOB-Anwendungen zuverlässig Informationen senden und empfangen können.

Loopback

Ein bestimmter Typ von Transportdienst, mit dem aktuelle Statusdaten an die Anwendung zurückgegeben werden können, von der die Daten ausgegeben wurden. Loopback verwendet den SubmitSync-Methodenaufruf, um die Statusdaten in der ursprünglichen Anwendung wiederherzustellen.

Siehe auch: Transportdienste (transport services)

M

Messagingport

Eine Reihe von Eigenschaften, die bestimmt, wie Dokumente codiert, gesichert und zu einer bestimmten Zielorganisation oder -anwendung transportiert werden.

Siehe auch: Verteilerliste (distribution list)

Metadaten (metadata)

Daten, die zur Beschreibung anderer Daten verwendet werden. Datentypen sind beispielsweise Metadaten, da sie eine Eigenschaft weiter beschreiben.

MOM (Microsoft Operations Manager)

Eine offene, hochgradig skalierbare Anwendung zur Verwaltung und Überwachung von Unternehmensvorgängen in Microsoft Windows 2000, die eine zentrale, dynamische Überwachung und automatische Problemlösung der Ereignisse ermöglicht, die von Benutzern, Anwendungssoftware, Servern und Desktops generiert werden.

MOM verwendet Regeln zur Überwachung und zur Generierung einer Antwort auf verschiedene Ereignisse. Bei der Antwort kann es sich z. B. um eine Benutzerbenachrichtigung oder eine automatische Lösung des Problems handeln.

Moniker

Ein Name, der für ein Objekt steht. Dieser kann den vollständigen Pfad oder die Adresse enthalten, die den Standort des Objekts bezeichnet.

Siehe auch: Port

N

Nachricht (message)

1. Ein Datenpaket, das von einem XLANG-Ablaufplan gesendet oder empfangen wird.

2. Im BizTalk-Orchestrierungs-Designer eine Form auf der Datenseite, die den Nachrichten in einem XLANG-Ablaufplan entspricht. Nachrichtenformen bestehen aus Feldern mit eindeutigen Namen, von denen jedes ein einzelnes Datenelement eines bestimmten Datentyps enthält.

O

Offener Kanal (open channel)

Ein Kanal, der für jede beliebige Quellorganisation explizit als offen deklariert wurde. Die Quelldaten für einen offenen Kanal werden entweder in einem Dokument oder in einem mit dem Dokument gesendeten Parameter an die BizTalk-Messagingdienste übergeben.

Siehe auch: Kanal (channel), Offenheitsgrad (openness), Quellorganisation (source organization)

Offener Messagingport (open messaging port)

Ein Messagingport, der für jede beliebige Zielorganisation explizit als offen deklariert wurde. Die Zieldaten für einen offenen Messagingport werden entweder in einem Dokument oder in einem mit dem Dokument gesendeten Parameter an die BizTalk-Messagingdienste übergeben.

Siehe auch: Kanal (channel), Offenheitsgrad (openness), Quellorganisation (source organization)

Offenheitsgrad (openness)

Ein Mangel an expliziten Informationen zu einer Quelle in einem Kanal bzw. einem Ziel in einem Messagingport. Kanäle enthalten Informationen, die die Quelle identifizieren. Messagingports dagegen enthalten Informationen, die das Ziel identifizieren. Wenn es sich bei einem Kanal um eine offene Quelle handelt, werden die Quellinformationen in dem Kanal nicht explizit deklariert, sondern auf andere Weise bereitgestellt. Normalerweise sind diese Informationen in der gesendeten Dokumentinstanz enthalten, oder sie werden in einem Submit-Methodenaufruf als Parameter festgelegt. Ebenso werden die Zielinformationen in einem Messagingport nicht explizit deklariert, wenn es sich bei dem Messagingport um ein offenes Ziel handelt. Stattdessen werden sie über die Dokumentinstanz oder die Parameter in einem Submit-Methodenaufruf bereitgestellt.

Siehe auch: Zielorganisation (destination organization), Offener Kanal (open channel), Offener Messagingport (open messaging port), Quellorganisation (source organization)

Organisation (organization)

Ein Handelspartner oder ein Geschäftszweig innerhalb eines Handelspartners bzw. Ihr Unternehmen, wenn es sich um die eigene Organisation handelt.

Siehe auch: Zielorganisation (target organization), Organisationskennzeichen (organization identifier), Handelspartner (trading partner), Eigene Organisation (home organization), Quellorganisation (source organization)

Organisationskennzeichen (organization identifier)

Eine Reihe von Eigenschaften, die eine Organisation eindeutig definiert. Eine Organisation kann über mehrere Organisationskennzeichen verfügen. Organisationskennzeichen bestehen aus folgenden Eigenschaften: einem Namen, einem Qualifizierer und einem Wert.

Siehe auch: Organisation (organization)

P

Parallelität (concurrency)

Zwei oder mehr Aktionen, die parallel ausgeführt werden.

Parser

Eine Komponente von BizTalk Server, die nicht auf XML basierende Dateien (z. B. X12, EDIFACT und Flatfile) in XML-Dateien konvertiert.

Pass-Through-Versendung (pass-through submission)

Eine Versendung, bei der die Verarbeitungsstufen Analyse, Decodierung, Entschlüsselung, Transformation und Signaturüberprüfung umgangen werden. Die Dokumentinstanz wird direkt an den Kanal weitergeleitet, der in den Versendungsparametern angegeben ist. Dieser Versendungstyp kann bei der Übertragung binärer Dateien ohne Datenbeschädigung oder für den Servertransport sowie globale Überwachungsfeatures verwendet werden.

Siehe auch: Kanal (channel), Dokumentinstanz (document instance)

Pausieren (dehydrate)

Speichert alle Statusinformationen für eine XLANG-Ablaufplaninstanz in einer SQL Server-Datenbank, während das XLANG-Ablaufplanungsmodul auf eine Nachricht wartet, bevor die nächste Aktion im Geschäftsprozess ausgeführt wird.

Siehe auch: XLANG-Ablaufplanungsmodul (XLANG scheduler engine)

Pausierender Ablaufplan (dehydrated schedule)

Ein Ablaufplan, der auf eine Nachricht wartet, bevor er die nächste Aktion in der Sequenz ausführt, und der zwischenzeitlich in einer Datenbank gespeichert wird. Sämtliche Statusinformationen zu dem Ablaufplan werden in der Datenbank gespeichert, bis dieser die Nachricht erhält. Pausierende Ablaufpläne reduzieren die Belastung für den Host des Ablaufplanes.

Persistenzdatenbank (persistence database)

Eine Datenbank, in der der XLANG-Ablaufplanzustand gespeichert wird, wenn der XLANG-Ablaufplan pausiert. Eine Standard-Persistenzdatenbank für die Orchestrierung wird während der Installation von BizTalk Server 2002 bereitgestellt.

Pipelinekomponente (pipeline component)

Eine Komponente, die die Integration von Anwendungen mit BizTalk Server 2002 ermöglicht. Entwickler können die IPipelineComponent-Schnittstelle, die IPipelineComponentAdmin-Schnittstelle oder die IBTSAppIntegration-Schnittstelle verwenden, um diese Komponenten zu entwickeln.

Pooling

Verwendung von COM+-Objektpools, um die Anzahl von Instanzen eines oder mehrerer Ablaufpläne zu begrenzen, die zu einem bestimmten Zeitpunkt aktiv und im Speicher vorhanden sind.

Port

Ein benannter Standort, der eine bestimmte Implementierung verwendet. Im BizTalk-Orchestrierungs-Designer ist ein Port durch den Standort, an den Nachrichten gesendet bzw. von dem Nachrichten empfangen werden, sowie die Technologie, die zur Implementierung der Kommunikationsaktion verwendet wird, definiert. Der Standort wird durch den Namen des Ports eindeutig identifiziert.

Siehe auch: Bindung (binding), Dynamischer Port (dynamic port), Moniker, Statischer Port (static port), Portimplementierung (port implementation), Portstandort (port location), Portname, Portverweis (port reference)

Port-ID

Ein global eindeutiger Bezeichner (GUID), der von BizTalk Server 2002 zugewiesen wird, um den Port, über den ein Dokument verarbeitet wird, eindeutig zu identifizieren.

Portgruppe (port group)

Eine Gruppe von Messagingports, über die dasselbe Dokument an verschiedene Organisationen oder Anwendungen von Handelspartnern gesendet werden kann. Im BizTalk-Messaging-Manager wird diese als Verteilerliste bezeichnet.

Portimplementierung (port implementation)

Eine bestimmte Technologie, die ein Port verwendet, um eine Kommunikationsaktion zu implementieren.

Siehe auch: Port,, Portstandort (port location), Portname, Portverweis (port reference)

Portname

Eine eindeutige Identifikation für einen Port. Diese Identifikation wird zum Korrelieren des Portstandorts mit einem bestimmten Port verwendet.

Siehe auch: Port, Portimplementierung (port implementation), Portstandort (port location), Portverweis (port reference)

Portstandort (port location)

Der mit einem bestimmten Port verbundene Standort. Der Standort hängt u. a. von der verwendeten Portimplementierung ab. Jede Implementierung stellt einen anderen Standorttyp für den Port bereit.

Siehe auch: Port, Portimplementierung (port implementation), Portname, Portverweis (port reference)

Portverweis (port reference)

Eine eindeutige Nachricht, die den Portstandort für jeden Port in einem XLANG-Ablaufplan enthält. Die Port References-Form befindet sich auf der Datenseite. Der Datenfluss in oder aus dieser Nachricht enthält den Portstandort für einen Port.

Siehe auch: Port, Portimplementierung (port implementation), Portstandort (port location), Portname

Positionsgebundene Flatfile (positional flat file)

Eine Datei, die Felder derselben Länge und Datensätze mit einem gemeinsamen Datensatz-Abschlusszeichen enthält.

Pro-Instanz-Warteschlange (per-instance queue)

Eine Warteschlange, die zur Verwendung mit jeder neuen Instanz eines XLANG-Ablaufplanes erstellt wird.

Siehe auch: Statische Warteschlange (static queue), Dynamische Warteschlange (dynamic queue)

Provider

Die Quelle der Informationen, die von MOM (Microsoft Operations Manager) gesammelt werden. Provider sind z. B. Systemereignisprotokolle und Leistungsindikatoren.

Siehe auch: Ereignisempfänger (event consumer)

Prüfpunkt (checkpoint)

Ein Speicherort in der Datenbank für gemeinsam genutzte Warteschlangen, an dem der aktuelle Status eines Arbeitselements gespeichert ist. Im Fall eines Serverfehlers können Dokumente, die sich in der Warteschlange des betreffenden Servers befinden, basierend auf den vom Prüfpunkt bereitgestellten Informationen aus der Datenbank für gemeinsam genutzte Warteschlangen abgerufen und an andere Server innerhalb der Servergruppe verteilt werden.

Q

Quellanwendung (source application)

Eine Anwendung der eigenen Organisation, die in einem Kanal als Quelle der Dokumente festgelegt wurde.

Siehe auch: Kanal, Eigene Organisation (home organization)

Quelle (source)

Der Name der Organisation, die als Quelle für den Kanal angegeben wurde, über den ein Dokument verarbeitet wird. Die Quelle wird in den BizTalk-Messagingdiensten definiert.

Quellorganisation (source organization)

Die Organisation eines Handelspartners, die in einem Kanal als Quelle der Dokumente festgelegt wurde.

Siehe auch: Kanal (channel), Zielorganisation (destination organization), Offener Kanal (open channel), Offener Messagingport (open messaging port), Offenheitsgrad (openness), Organisation (organization), Handelspartner (trading partner)

Quellspezifikation (source specification)

Die Spezifikation in einer Zuordnung, die das eingehende Dokument repräsentiert. Der BizTalk-Mapper ordnet eine Quellspezifikation einer Zielspezifikation zu.

Siehe auch: Zielspezifikation (destination specification)

R

Reliable Messaging

Ein Feature des BizTalk Framework 2.0-Protokolls, das die garantierte, einmalige Zustellung von Dokumenten in heterogenen Umgebungen über das Internet unterstützt.

Replikation (replication)

Der Prozess, der dem Kopieren von Daten innerhalb eines Servers zugrunde liegt. Nachdem ein Server den Replikationsprozess abgeschlossen hat, werden die Daten auf den anderen Servern synchronisiert.

S

Schema

Die Definition der Struktur einer XML-Datei. Ein Schema enthält Eigenschaftsinformationen, die sich auf die Datensätze und Felder innerhalb der Struktur beziehen.

Schleifendatensatz (looping record)

Eine Struktur, die mehr als einmal in Instanzdokumenten vorkommen kann. Bei der Struktur kann es sich entweder um einen Elementardatensatz handeln, der nur aus Feldern mit Inhalten besteht, oder es kann sich um eine Struktur handeln, die über eine geschachtelte, hierarchische Unterstruktur verfügt.

SEED-Paket (SEED package)

Ein XML-Paket enthält die Konfiguration für Geschäftsdokumente einer Firma und wurde mit dem BizTalk-SEED-Assistenten erstellt. Nachdem ein Paket erstellt wurde, können Handelspartner die Konfiguration mithilfe des BizTalk-SEED-Assistenten in ihrer Organisation installieren, so dass sie über das Internet Geschäfte mit der initiierenden Firma tätigen können.

Siehe auch: Initiator, Empfänger (recipient)

Serialisierungskomponente (serializer)

Eine Komponente von BizTalk Server, die XML-Dateien in nicht auf XML basierende Dateien (z. B. X12, EDIFACT und Flatfiles) konvertiert.

Servergruppe (server group)

Eine Gruppe individueller Server, die zentral verwaltet, konfiguriert und überwacht wird.

Spezifikation (specification)

Ein BizTalk Server-spezifisches XML-Schema. Spezifikationen werden im BizTalk-Editor erstellt und können auf Industriestandards (z. B. EDIFACT, X12 und XML) oder Flatfiles (mit Trennzeichen, positionsgebunden oder sowohl mit Trennzeichen als auch positionsgebunden) basieren. Der BizTalk-Mapper verwendet Spezifikationen, die als Quellspezifikationen und Zielspezifikationen geöffnet werden, um Zuordnungen zu erstellen.

Statische Warteschlange (static queue)

Eine Warteschlange mit einer bekannten Adresse. Ports, für die Message Queuing implementiert wurde, können eine statische Warteschlange verwenden, wenn der Standort der Warteschlange bekannt und unveränderlich ist.

Siehe auch: Dynamische Warteschlange (dynamic queue), Instanzbezogene Warteschlange (per-instance queue)

Statischer Port (static port)

Ein Port, der alle notwendigen Informationen für einen XLANG-Ablaufplan zur Entwurfszeit anfordert. Der Designer, der den XLANG-Ablaufplan erstellt, muss den Standort kennen, an den Nachrichten gesendet bzw. von dem Nachrichten empfangen werden, und die Technologie, die zur Implementierung der Kommunikationsaktion ausgewählt wurde.

Siehe auch: Dynamischer Port (dynamic port), Port

Status (state)

Der Zustand verschiedener Computerelemente zu einem bestimmten Zeitpunkt.

Siehe auch: XLANG-Ablaufplanzustand (XLANG schedule state)

Synchrone Kommunikation (synchronous communication)

Eine Interaktion zwischen zwei oder mehreren Prozessen, bei der ein Prozess mit einem anderen kommuniziert und die Verarbeitung erst fortsetzen kann, wenn er eine bestimmte Antwort von dem anderen Prozess erhält.

Siehe auch: Asynchrone Kommunikation (asynchronous communication)

Systemeigen (native)

Alle Daten, bei denen es sich nicht um XML-Daten (Extensible Markup Language) handelt.

Systemeigene Instanz (native instance)

Eine Instanz systemeigener Daten. Beispiel: EDI 850 (Auftrag).

T

Topologie (topology)

Die Organisationsbeziehungen zwischen Computern in einer Konfiguration. Eine typische Topologie in BizTalk Server umfasst beispielsweise mehrere verarbeitende Server, die gemeinsam auf eine BizTalk-Messaging-Verwaltungsdatenbank zugreifen.

Transaktion (transaction)

Eine diskrete Aktivität innerhalb eines Computersystems, z. B. die Eingabe eines Kundenauftrags oder die Aktualisierung eines Lagerteils. Die Aktivität besteht aus einer Gruppe von Operationen, die gemeinsam ausgeführt werden oder fehlschlagen. Schlägt eine Operation fehl, wird also ein Rollback für die gesamte Transaktion durchgeführt, und die Auswirkungen bereits ausgeführter Operationen werden rückgängig gemacht. Transaktionen sind im Allgemeinen mit der Datenbankverwaltung, der Auftragserfassung und anderen Onlinesystemen verbunden. Im BizTalk-Orchestrierungs-Designer werden Transaktionen als Aktionen dargestellt, die innerhalb einer Transaktion-Form gruppiert sind.

Siehe auch: Abbruch (abort), Innere Transaktion (inner transaction), Langlebige Transaktion (long running transaction), Geschachtelte Transaktion (nested transaction), Äußere Transaktion (outer transaction), Kurzlebige Transaktion (short-lived transaction), Commit

Transaktionsmenge (transaction set)

Segmente in einem EDI-Schema, die eine bestimmte Reihenfolge aufweisen und eine spezielle Bedeutung für eine bestimmte Geschäftstransaktion haben.

Transportdienste (transport services)

Eine Reihe von Diensten, z. B. Netzwerkprotokolle und Anwendungsintegrationskomponenten. BizTalk Server 2002 unterstützt eine Basismenge von Transportdiensten. Auf diese Weise ist der Server in der Lage, Dokumente an Organisationen oder Anwendungen zu senden, unabhängig davon, ob die Anwendungen über eine COM-Schnittstelle direkt mit dem Server kommunizieren können. BizTalk Server 2002 unterstützt Datei-, HTTP-, HTTPS- und SMTP-Netzwerkprotokolle sowie Message Queuing. Transportdienste werden auch als Transportkomponenten bezeichnet.

Siehe auch: Loopback, Wiederholungswarteschlange (Retry queue)

U

Überwachungsdatenbank (tracking database)

Eine Microsoft SQL Server-Datenbank, die mit einer Servergruppe verbunden ist, welche die Überwachung der vom Server verarbeiteten Dokumente entweder einzeln oder in Batches ermöglicht. Außerdem kann der XLANG-Ablaufplanzustand überwacht werden.

Umschlag (envelope)

1. Eine Reihe von Eigenschaften, die einen Umschlag definiert. Umschlageigenschaften enthalten ein Umschlagsformat und können außerdem einen Verweis auf eine Umschlagspezifikation umfassen.

2. Kopf- und Fußzeileninformationen, oder nur Kopfzeileninformationen, die zu transportierende Dokumentdaten enthalten oder ihnen vorangestellt sind.

Umschlagsformat (envelope format)

Dokumentformate, die ein Umschlag enthalten kann, z. B. XML oder X12.

V

Verarbeitungswarteschlange (Work queue)

Eine Tabelle innerhalb der Datenbank für gemeinsam genutzte Warteschlangen in Microsoft SQL Server. Die Verarbeitungswarteschlange ist mit einer Servergruppe verbunden. Sie enthält Austauschvorgänge, die derzeit von BizTalk Server 2002 verarbeitet werden.

Siehe auch: Wiederholungswarteschlange (Retry queue), Geplant-Warteschlange (Scheduled queue), Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database), Angehalten-Warteschlange (Suspended queue)

Verknüpfung (link)

Eine einfache BizTalk-Mapper-Operation zum Kopieren eines Wertes (oder eines Namens) von einem Feld in der Quellspezifikation in ein Feld in der Zielspezifikation oder in ein Funktoid.

Siehe auch: Funktoid (functoid)

Version

In BizTalk Server 2002 handelt es sich dabei entweder um eine bestimmte Versionsnummer für eine Spezifikation oder die Versionsnummer des Industriestandards, anhand dessen die Spezifikation erstellt wurde.

Verteilerliste (distribution list)

Eine Gruppe von Messagingports, über die dasselbe Dokument an verschiedene Organisationen von Handelspartnern oder Anwendungen der eigenen Organisation gesendet werden kann. Im BizTalk-Messaging-Konfigurationsobjektmodell wird diese als Portgruppe bezeichnet.

Siehe auch: Messagingport, Handelspartner (trading partner), Eigene Organisation (home organization)

Verteilungslogik (routing logic)

Eine Reihe von Regeln, die die Reihenfolge der Ausführung in einem XLANG-Ablaufplan ermittelt. Die Verteilungslogik wird von der Entscheidung-Form im BizTalk-Orchestrierungs-Designer implementiert.

Vollständig konfigurierte Regeln (fully configured rules)

MOM-Regeln (Microsoft Operations Manager), die vollständig vorkonfiguriert wurden und Bestandteil von Microsoft BizTalk Server 2002 Management Pack sind.

Siehe auch: Benutzerdefinierte Regeln (user-defined rules)

W

WebDAV (Web Distributed Authoring and Versioning)

Eine Erweiterung des Standards HTTP 1.1, die ein hierarchisches Dateispeichermedium, z. B. ein Dateisystem, über eine HTTP-Verbindung offen legt. WebDAV sperrt Dokumente, damit Benutzer nicht aus Versehen die Änderungen anderer Benutzer überschreiben. Es ermöglicht Benutzern die gemeinsame Bearbeitung serverbasierter Dokumente, unabhängig vom Dokumenterstellungstool, der Plattform oder des Webservertyps, auf dem die Dateien gespeichert sind.

Wiederholungswarteschlange (Retry queue)

Eine Tabelle innerhalb der Datenbank für gemeinsam genutzte Warteschlangen in Microsoft SQL Server. Die Wiederholungswarteschlange ist einer Servergruppe mit Arbeitsobjekten zugeordnet, die im Anschluss an den ersten Übertragungsversuch übertragen werden sollen.

Siehe auch: Angehalten-Warteschlange (Suspended queue), Verarbeitungswarteschlange (Work queue), Geplant-Warteschlange (Scheduled queue), Datenbank für gemeinsam genutzte Warteschlangen (Shared Queue database), Transportdienste (transport serviced)

WMI (Windows Management Instrumentation)

Eine Verwaltungsinfrastruktur in Microsoft Windows 2000, die die Überwachung und Steuerung von Systemressourcen über einen gemeinsamen Schnittstellensatz unterstützt und ein logisch organisiertes, konsistentes Modell für den Betrieb, die Konfiguration und den Status von Windows bereitstellt. BizTalk Server 2002 verwendet die WMI-Schicht, um Verwaltungsfunktionen einzukapseln.

Wörterbuch (dictionary)

Eigenschaften, die jedem von BizTalk Server verarbeiteten Arbeitsobjekt zugewiesen sind. Diese Eigenschaften sind im BizTalk-Editor offen gelegt, damit Benutzer BizTalk Server anweisen können, in Dokumentinstanzen Werte für Eigenschaften zu finden, die zur Suche nach einem Messagingport verwendet werden können.

Wohlgeformtes XML (well-formed XML)

Dieser Standard besagt, dass ein XML-Dokument, welches über einen einzelnen Stamm sowie über Elemente verfügt, entweder vollständig verschachtelt werden muss oder gar nicht verschachtelt werden kann.

X

XDR (XML-Data Reduced)

Ein XML-Schema, das von Microsoft vorgeschlagen und 1998 dem World Wide Web Consortium (W3C) vorgelegt wurde. Wie XML-Data ist XDR eine Syntax für XML-Schemas (Extensible Markup Language), die die Eigenschaften eines XML-Dokuments festlegt. XDR ist eine Teilmenge von XML-Data.

Siehe auch: XML (Extensible Markup Language)

XLANG-Ablaufplan (XLANG schedule)

Bestimmte Geschäftsprozesse, die in der XLANG-Sprache dargestellt werden. Ein XLANG-Ablaufplan wird mit der Dateierweiterung SKX gespeichert.

Siehe auch: XLANG-Ablaufplanungsmodul (XLANG scheduler engine), XLANG-Ablaufplanzeichnung (XLANG schedule drawing), XLANG-Ablaufplaninstanz (XLANG schedule instance)

XLANG-Ablaufplaninstanz (XLANG schedule instance)

Eine Abbildung eines Ablaufplanes. Ein XLANG-Ablaufplan stellt nur den Geschäftsprozess und die Implementierungsdienste dar. Das XLANG-Ablaufplanungsmodul kann eine einzige oder mehrere Instanzen eines XLANG-Ablaufplanes ausführen. Verschiedene Instanzen eines XLANG-Ablaufplanes enthalten unterschiedliche Nachrichten, aber alle Instanzen folgen denselben Geschäftsprozessregeln.

Siehe auch: XLANG-Ablaufplan (XLANG schedule), XLANG-Ablaufplanungsmodul (XLANG scheduler engine)

XLANG-Ablaufplanung (XLANG scheduler)

Die Standard-COM+-Anwendung, die bei der Installation von BizTalk Server 2002 installiert wird. Diese Anwendung dient als Host für ausgeführte Instanzen von XLANG-Ablaufplänen.

XLANG-Ablaufplanungsmodul (XLANG scheduler engine)

Ein Dienst, der XLANG-Ablaufplaninstanzen ausführt und die Ausführung, Pausierung und Aktivierung eines XLANG-Ablaufplanes steuert.

Siehe auch: Pausieren (dehydrate), Aktivieren (rehydrate), XLANG-Ablaufplan (XLANG schedule), XLANG-Ablaufplanzeichnung (XLANG schedule drawing), XLANG-Ablaufplaninstanz (XLANG schedule instance)

XLANG-Ablaufplanzeichnung (XLANG schedule drawing)

Eine Zeichnung, die einen Geschäftsprozess darstellt. Ist eine Zeichnung abgeschlossen, kann diese im BizTalk-Orchestrierungs-Designer kompiliert und als ein XLANG-Ablaufplan ausgeführt werden. Eine XLANG-Ablaufplanzeichnung wird mit der Dateierweiterung SKV gespeichert.

Siehe auch: XLANG-Ablaufplan (XLANG schedule), XLANG-Ablaufplanungsmodul (XLANG scheduler engine), Kommunikationsformen (communication shapes), Flussdiagrammformen (flowchart shapes)

XLANG-Ablaufplanzustand (XLANG schedule state)

Die in einer XLANG-Ablaufplaninstanz enthaltenen Informationen. Zu diesen Informationen gehören Nachrichten, die von dieser Instanz gesendet oder empfangen wurden, von dieser Instanz verwendete COM-Objekte sowie der Fortschritt dieser Instanz im Hinblick auf den Abschluss des Geschäftsprozesses.

Siehe auch: Status (state)

XLANG-Identität (XLANG identity)

Ein global eindeutiger Bezeichner, der zur Unterscheidung von Versionsinstanzen einer XLANG-Ablaufplanzeichnung verwendet wird. Diese Eigenschaft ist schreibgeschützt und kann nicht geändert werden. Bei Aktualisierung der XLANG-Ablaufplanzeichnung wird diese Identität ebenfalls aktualisiert. Die XLANG-Identität kann verwendet werden, um einen XLANG-Ablaufplan mit der Version einer XLANG-Ablaufplanzeichnung zu korrelieren, anhand derer der Ablaufplan kompiliert wurde.

XLANG-Sprache (XLANG language)

Eine Sprache, die die logische Sequenzierung von Geschäftsprozessen sowie die Implementierung dieser Geschäftsprozesse mithilfe verschiedener Implementierungstechnologien beschreibt. Die XLANG-Sprache wird in XML dargestellt.

XML (Extensible Markup Language)

Eine vom World Wide Web Consortium (W3C) entwickelte Spezifikation, die Designern die Erstellung von benutzerdefinierten Tags ermöglicht, die über die Fähigkeiten von Standard-HTML hinausgehen. Während HTML ausschließlich vordefinierte Tags verwendet, um Elemente einer Seite zu beschreiben, kann der Entwickler einer Seite in XML Tags definieren. Tags für jedes beliebige Datenelement, z. B. ein Produkt oder ein Fälligkeitsdatum, können für spezielle Anwendungen verwendet werden. Auf diese Weise können Webseiten als Datenbankeinträge fungieren.

Siehe auch: Kompilieren (compile), Datenkonvertierung (data translation), Zuordnung (map), XDR (XML-Data Reduced), XPath

XPath

Eine umfassende Sprache, die die Navigation durch die Hierarchie eines XML-Dokuments ermöglicht. Mit XPath-Ausdrücken können Sie Informationen zu XML-Elementen und -Attributen abrufen, Daten auswählen, die bestimmten Kriterien entsprechen, und Vergleiche für die abgerufenen Daten durchführen. Wird auch als Knotenpfad bezeichnet.

Siehe auch: XML (Extensible Markup Language), Knotenpfad (node path)

XSD (Extensible Structure Definition)

Eine Schemasprache. XSD wurde vom World Wide Web Consortium (W3C) für das Definieren von XML-Strukturen (Extensible Markup Language) empfohlen.

XSL (Extensible Stylesheet Language)

Ein Stylesheetformat für XML-Dokumente (Extensible Markup Language). XSL wird verwendet, um die Anzeige von XML zu definieren, ebenso wie CSS (Cascading Style Sheets) verwendet wird, um die Anzeige von HTML (Hypertext Markup Language) zu definieren. BizTalk Server verwendet XSL als Konvertierungssprache zwischen zwei Spezifikationen.

Z

Ziel (destination)

Der Name der Organisation für den Kanal, über den ein Dokument verarbeitet wird. Das Ziel wird in den BizTalk-Messagingdiensten definiert.

Zielanwendung (destination application)

Ein Anwendung der eigenen Organisation, die in einem Messagingport als Ziel für Dokumente festgelegt wurde.

Siehe auch: Eigene Organisation (home organization)

Zielorganisation (destination organization)

Die Organisation eines Handelspartners, die in einem Messagingport als Ziel für Dokumente festgelegt wurde.

Siehe auch: Offenheitsgrad (openness), Organisation (organization), Quellorganisation (source organization)

Zielspezifikation (destination specification)

Die Spezifikation in einer Zuordnung, die das ausgehende Dokument repräsentiert. Der BizTalk-Mapper ordnet eine Quellspezifikation einer Zielspezifikation zu.

Siehe auch: Quellspezifikation (source specification)

Zuordnen (mapping)

Der Prozess, der die Transformation der Daten einer Struktur in eine andere Struktur beschreibt.

Zuordnung (map)

Eine XML-Datei, die die Entsprechungen zwischen den Datensätzen und Feldern in einer Spezifikation und den Datensätzen und Feldern in einer anderen Spezifikation definiert. Eine Zuordnung enthält ein XSL-Stylesheet (Extensible Stylesheet Language), mit dem BizTalk Server die in der Zuordnung beschriebene Transformation durchführt. Zuordnungen werden im BizTalk-Mapper erstellt.

Siehe auch: Kompilieren (compile), Datenkonvertierung (data translation), XML (Extensible Markup Language)

Zyklischer Verweis (cyclical reference)

Ein Verweis in einer Spezifikation, der auftritt, wenn ein Datensatz als Ableitung seiner selbst erstellt wird. Ein zyklischer Verweis ist nur möglich, wenn für die Standard-Eigenschaft auf der Registerkarte Verweis im BizTalk-Editor der Wert XML festgelegt wurde.


.topic 5
Aktivieren Sie dieses Kontrollkästchen, damit die COM+-Anwendung XLANG-Ablaufplaninstanzen ausführen kann.

.topic 8
Aktivieren Sie dieses Kontrollkästchen um zum Verweisen auf die Persistenzdatenbank für diese COM+-Anwendung einen Datei-DSN zu verwenden. Wenn dieses Kontrollkästchen nicht aktiviert wird, wird ein System- oder Benutzer-DSN verwendet. Ein Dateidatenquellenname (DSN, Data Source Name) speichert Informationen über eine Datenbankverbindung in einer Datei. Die Datei hat standardmäßig die Erweiterung DSN und wird im Verzeichnis $\Programme\Gemeinsame Dateien\ODBC\Data Sources gespeichert.

.topic 3
Dieses Feld enthält den DSN-Namen, der für die Kommunikation mit der Persistenzdatenbank für diese COM+-Anwendung verwendet wird. Der DSN-Name muss immer mit dem Namen der COM+-Anwendung übereinstimmen.

.topic 2
Klicken Sie auf diese Schaltfläche, um den ODBC-Datenquellennamen (DSN) für die COM+-Hostanwendung für das XLANG-Ablaufplanungsmodul zu erstellen. Wichtig: Der im Dialogfeld "Eigenschaften von XLANG Scheduler" konfigurierte DSN-Name muss mit dem Namen der COM+-Anwendung übereinstimmen.

.topic 1
Klicken Sie auf diese Schaltfläche, um den ODBC-Datenquellenadministrator zu öffnen und die auf dem Computer definierten Datenquellen zu verwalten.

.topic 4
Klicken Sie auf diese Schaltfläche, um die für die Unterstützung der Persistenz für XLANG-Ablaufplaninstanzen erforderlichen Tabellen in einer SQL Server-Datenbank zu erstellen.

.topic 7
Klicken Sie auf diese Schaltfläche, um alle ausgeführten XLANG-Ablaufplaninstanzen erfolgreich zu beenden. Der Ablaufplanstatus für alle ausgeführten Ablaufpläne wird in der Persistenzdatenbank gespeichert.

.topic 6
Klicken Sie auf diese Schaltfläche, damit alle ausgeführten COM+-Hostanwendungen für XLANG-Ablaufplaninstanzen die Aktivierung der Ablaufplaninstanzen starten und wenn möglich, das Ausführen fortsetzen.


Support Online

Online Support
und Information

* | Microsoft BizTalk Server Website (Deutschsprachig)
* | Microsoft Support Website (Deutschsprachig)
* | Microsoft Product Support Services Website (Englischsprachig)
* | Microsoft COM Website (Englischsprachig)
* | Microsoft Message Queuing Website (Englischsprachig)
* | Microsoft SQL Server Website (Deutschsprachig)
* | Microsoft Windows Script Technologies Website (Englischsprachig)
* | Microsoft XML on MSDN Online (Englischsprachig)
* | MSDN Online (Deutschsprachig)
* | MSDN Library (Englischsprachig)
* | Microsoft Accessibility Website (Englischsprachig)


Rechtliche Informationen zu Microsoft® BizTalk™Server2002

BizTalk Server 2002 ~ Copyright

Rechtliche Informationen zu
Microsoft® BizTalk™ Server 2002

Die in diesen Unterlagen enthaltenen Angaben und Daten, einschließlich URLs und anderen Verweisen auf Internetwebsites, können ohne vorherige Ankündigung geändert werden. Sofern nichts anderes angegeben ist, sind die in den Beispielen verwendeten Firmen, Organisationen, Produkte, Domänennamen, E-Mail-Adressen, Logos, Personen, Orte und Ereignisse frei erfunden. Jede Ähnlichkeit mit bestehenden Firmen, Organisationen, Produkten, Personen oder Ereignissen ist rein zufällig. Die Benutzer/innen sind verpflichtet, sich an alle anwendbaren Urheberrechtsgesetze zu halten. Unabhängig von der Anwendbarkeit der entsprechenden Urheberrechtsgesetze darf ohne ausdrückliche schriftliche Erlaubnis der Microsoft Corporation kein Teil dieses Dokuments für irgendwelche Zwecke vervielfältigt oder in einem Datenempfangssystem gespeichert oder darin eingelesen werden, unabhängig davon, auf welche Art und Weise oder mit welchen Mitteln (elektronisch, mechanisch, durch Fotokopieren, Aufzeichnen, usw.) dies geschieht.

Microsoft Corporation kann Besitzer von Patenten oder Patentanträgen, Marken, Urheberrechten oder anderen Rechten über geistiges Eigentum sein, die den Inhalt dieses Dokuments betreffen. Die Bereitstellung dieses Dokuments erteilt keinerlei Lizenzrechte an diesen Patenten, Marken, Urheberrechten oder anderem geistigen Eigentum, ausgenommen, dies wurde explizit durch einen schriftlich festgehaltenen Lizenzvertrag mit der Microsoft Corporation vereinbart.

© 1999-2001 Microsoft Corporation. Alle Rechte vorbehalten.

Microsoft, Active Directory, ActiveX, BizTalk, FrontPage, JScript, MSDN, MS-DOS, Visio, Visual Basic, Visual C++, Visual C#, Visual InterDev, Visual Studio, Win32, Windows und Windows NT sind entweder eingetragene Marken oder Marken der Microsoft Corporation in den USA und/oder anderen Ländern.

Intel ist eine eingetragene Marke der Intel Corporation.

Die in diesem Dokument aufgeführten Produkt- und Firmennamen können geschützte Marken ihrer jeweiligen Inhaber sein.