Introduction à Microsoft BizTalk Server 2002

L'intégration des applications internes d'une entreprise a toujours été difficile. Leur intégration avec des clients et des fournisseurs externes l'est encore davantage. Microsoft® BizTalk™ Server 2002 vous permet de résoudre tous les problèmes d'intégration allant du cadre de votre entreprise à Internet. L'illustration suivante présente un exemple d'orchestration de vos activités depuis les applications internes jusqu'aux processus professionnels inter-entreprises.

BizTalk Server 2002 permet d'orchestrer vos activités depuis les applications internes jusqu'aux processus professionnels inter-entreprises.

Membre de la famille de produits Microsoft® .NET Enterprise Server, BizTalk Server 2002 réunit l'intégration EAI (Enterprise Application Integration) et l'intégration B2B (Business-to-Business) pour les entreprises. Que votre entreprise soit fournisseur, distributeur ou agrégateur de commerce électronique, BizTalk Server vous aide à orchestrer toutes ses activités, depuis les applications internes jusqu'aux processus professionnels inter-entreprises.

BizTalk Server facilite l'intégration

L'intérêt que vous portez à BizTalk Server indique que vous vous occupez d'intégration de près ou de loin. Vous êtes peut-être responsable de l'intégration du système de fonctionnement de votre entreprise avec d'autres applications internes. Vous avez peut-être été chargé d'intégrer vos récents systèmes de commerce basés sur le Web avec vos systèmes de fabrication et de distribution principaux. Ou encore, votre travail consiste à trouver un moyen d'utiliser Internet pour intégrer vos processus professionnels à ceux de fournisseurs et distributeurs importants.

Grâce à une prise en charge étendue de XML, HTTP, HTTPS, SMTP, SSL, S/MIME et des certificats x509v3, BizTalk Server est un puissant exemple d'application des technologies Internet standard à la résolution des problèmes d'intégration.

À propos de cette introduction

Cette introduction fournit une présentation de haut niveau de BizTalk Server 2002. Elle contient des illustrations, des liens et des définitions qui vous permettront de mieux comprendre comment utiliser BizTalk Server pour résoudre les problèmes de commerce électronique propres à votre entreprise ou à votre organisation.

Cette section traite des rubriques suivantes :

  • Mise en route

  • Aide de BizTalk Server 2002

Copyright © 1999–2001 Microsoft Corporation.
Tous droits réservés


Mise en route

Microsoft® BizTalk Server 2002 offre un environnement d'exécution et de développement puissant qui intègre des processus professionnels longs et faiblement couplés de l'entreprise à Internet. BizTalk Server peut prendre en charge des transactions qui sont exécutées pendant des semaines ou des mois aussi bien que celles qui ne durent que quelques minutes ou quelques heures.

Les fonctionnalités de BizTalk Server 2002 comprennent la possibilité de concevoir et exécuter des processus professionnels complets sous la forme de planifications XLANG, d'intégrer les applications existantes, de définir des spécifications de document et des transformations de ces spécifications, de contrôler et consigner l'activité d'exécution.

BizTalk Server fournit une passerelle standard pour l'envoi et la réception de documents sur Internet, de même qu'une gamme de services assurant l'intégrité, le transfert, la sécurité et la prise en charge des données de BizTalk Framework et d'autres formats de document importants comme XML (Extensible Markup Language), EDI (Electronic Data Interchange) et les fichiers plats.

Pour plus d'informations sur BizTalk Framework 2.0 et sur les ressources de BizTalk Server 2000 telles que les services de communauté, une bibliothèque de schémas exhaustives et les livres blancs, accédez au site Web de Microsoft BizTalk Server à l'adresse (www.microsoft.com/france/biztalk).

Pourquoi utiliser BizTalk Server ?

Parce que cela facilite la résolution des problèmes complexes. BizTalk Server intègre en un produit unique deux fonctionnalités clés : l'orchestration et les échanges. Tandis qu'un puissant moteur d'échanges prend en charge le transport et le mappage des messages, les services d'orchestration BizTalk peuvent orchestrer des processus professionnels constitués de composants et de messages envoyés et reçus à l'aide du service d'échanges BizTalk.

Par exemple, BizTalk Server vous permet d'effectuer les tâches suivantes :

  • Création de processus professionnels dynamiques. Grâce à l'infrastructure BizTalk Server, il est possible d'intégrer, de gérer et d'automatiser très rapidement les processus professionnels dynamiques en permettant l'échange des documents de l'entreprise entre les applications et au sein ou à l'extérieur des frontières organisationnelles. En fournissant tous les outils nécessaires à l'orchestration des processus de l'entreprise, BizTalk Server aide à la création de processus qui permettent aux applications et aux entreprises d'être accessibles sur Internet.

  • Intégration des applications et des partenaires commerciaux. Grâce à BizTalk Server, les développeurs peuvent facilement procéder à l'intégration mutuelles des applications et des entreprises. Les analystes de l'entreprise et les développeurs d'applications disposent d'outils graphiques pour construire un schéma des documents professionnels, transformer ce schéma, établir des relations de partenariat commercial et effectuer le suivi et l'analyse des données. Grâce à la prise en charge de XML et des technologies Internet standard, BizTalk Server étend les fonctionnalités du commerce électronique et de l'EDI classiques à des communautés de commerce électronique entières.

  • Garantie de l'interopérabilité grâce à l'utilisation de standards publics. Grâce à une prise en charge complète des standards et spécifications publics comme XML, EDI, HTTP et HTTPS ainsi que des normes de sécurité comme le cryptage de clé publique (PKI) et les signatures numériques, BizTalk Server garantit un niveau maximal d'interopérabilité et de sécurité avec vos applications et vos partenaires commerciaux.

BizTalk Server utilise XML en interne pour définir les données et la structure de vos documents commerciaux ; il utilise également des protocoles Internet standard comme HTTP (Hypertext Transfer Protocol) et SMTP (Simple Mail Transfer Protocol) pour transmettre ces documents vers leurs destinations, ce qui permet l'interopérabilité entre plusieurs applications quel que soit leur environnement d'exécution, à condition que ces applications prennent en charge les standards Internet. Vous pouvez envoyer des documents à BizTalk Server sous la forme de fichiers XML, EDI ou de fichiers plats.

Quels sont les problèmes spécifiques résolus par BizTalk Server ?

Les problèmes liés à l'intégration interne et externe.

Au fil du temps, les entreprises ont acquis des applications auprès de fournisseurs différents, ce qui aboutit à une grande diversité d'applications exécutées sur plusieurs plates-formes. Dans la mesure où chaque application était conçue pour remplir une tâche spécifique comme la gestion des entrepôts ou des relations clientèle, l'intégration avec d'autres applications n'était pas courante. Les entreprises qui décidaient d'intégrer leurs applications internes trouvaient par conséquent cette tâche longue et coûteuse.

Prenons quelques-unes des plaintes les plus fréquentes :

  • Disparité des applications : « Il est trop difficile d'intégrer des applications hétérogènes dans mon entreprise. »

  • Insuffisance des ressources de programmation : « Cela prend trop de temps de développer des solutions intégrées par rapport à la planification des ressources de l'entreprise. »

  • Hétérogénéité des rapports : « Il n'est pas possible de générer des rapports intégrés en temps voulu pour les diverses applications car le stockage des données est disséminé un peu partout. »

  • Difficultés de modification : « Une fois mes applications internes intégrées, il devient plus difficile et plus coûteux de les modifier. »

  • Absence de procédure établie : « Ma société n'a pas de méthode cohérente pour implémenter nos processus professionnels vitaux. »

  • Difficultés liées aux partenaires : « Il est trop difficile d'intégrer les processus professionnels de mon entreprise à ceux de mes partenaires. »

  • Changement de partenaire : « Si une autre entreprise me propose un marché plus intéressant, j'hésite à en profiter du fait de toute l'infrastructure informatique que cela implique. »

Le succès du World Wide Web a fait naître la perspective du commerce électronique, le commerce sur Internet. Cependant, si l'intégration des applications internes est complexe, les échanges commerciaux avec des clients et des fournisseurs via Internet est encore plus compliqué, principalement en raison des problèmes grandissant de sécurité et de fiabilité liés aux transactions effectuées en ligne. BizTalk Server est conçu pour vous aider à résoudre ces problèmes. Grâce à des outils comme le Concepteur d'orchestration BizTalk et l'Éditeur BizTalk, BizTalk Server vous permet de concevoir vos propres processus professionnels dans un environnement de création graphique. BizTalk Server exécute ensuite le diagramme visuel en assurant un développement rapide d'applications pour les processus professionnels.

Didacticiels

Vous pouvez acquérir rapidement une connaissance pratique de BizTalk Server 2002 en suivant les didacticiels fournis dans ce manuel :

  • Leçons sur BizTalk Server 2002 vous aide à mieux comprendre comment utiliser l'Éditeur BizTalk, le Mappeur BizTalk, le Gestionnaire d'échanges BizTalk, l'Administrateur BizTalk et le Concepteur d'Orchestration BizTalk pour configurer BizTalk Server en vue d'exécuter un processus d'approvisionnement automatisé B2B.

  • Le Didacticiel de BizTalk Server 2002 explique étape par étape comment configurer des processus BizTalk Server.

  • L'exemple d'approvisionnement électronique est un exemple de bout en bout qui utilise BizTalk Server, Internet et la corrélation pour montrer la manière d'automatiser le processus d'approvisionnement qui a lieu entre votre entreprise et ses fournisseurs.

Exemples

BizTalk Server 2002 comprend plus de 20 exemples qui illustrent la plupart des fonctionnalités de BizTalk Server. Les exemples fournis dans le kit de développement logiciel (SDK, Software Development Kit) de BizTalk Server se trouvent dans le dossier \Program Files\Microsoft BizTalk Server\SDK sur le lecteur où est installé BizTalk Server.

Les exemples de BizTalk Server sont organisés en deux catégories :

  • BizTalk Messaging Services Code Samples

  • BizTalk Orchestration Services Code Samples

Dans cette section

Cette section traite des rubriques suivantes :

  • Nouveautés dans BizTalk Server 2002

  • À qui s'adresse BizTalk Server ?

  • Comment fonctionne BizTalk Server ?

  • Fonctionnalités de BizTalk Server

  • Modèle d'application BizTalk Server

  • Modèle d'administration de BizTalk Server

Copyright © 1999–2001 Microsoft Corporation.
Tous droits réservés.

Ces informations vous ont-elles été utiles ? Veuillez envoyer vos suggestions et commentaires relatifs à la documentation à BizTalk Server Documentation Feedback@microsoft.com


Nouveautés de BizTalk Server 2002

Microsoft® BizTalk™ Server 2002 Édition Entreprise propose les améliorations suivantes :

  • Déploiement intra-entreprise des objets BizTalk Server. BizTalk Server 2002 améliore le déploiement intra-entreprise car il fournit un pilote de réplication BizTalk Server utilisable avec Microsoft Application Center 2000. Microsoft Application Center 2000 facilite le déploiement en automatisant la migration et la synchronisation des objets BizTalk Server dans des environnements disparates. Deux scénarios de déploiement clés sont disponibles :
    • Un scénario qui passe par le développement, se poursuit par la phase de test et se termine par la mise en production.

    • Un scénario appliqué sur un groupe de serveurs de production.
  • Déploiement inter-entreprises rapide et test des interfaces de documents publics vers les partenaires. Avec l'introduction des packages SEED, BizTalk Server 2002 fournit des fonctionnalités rationnelles de déploiement inter-entreprises. Les packages SEED contiennent les schémas de documents et les informations associées qu'une entreprise (l'initiateur) envoie et reçoit de ses partenaires commerciaux (le destinataire). Ils sont créés une seule fois, puis déployés vers plusieurs partenaires commerciaux. Le partenaire commercial ouvre le package SEED et indique les configurations requises de l'organisation. Ces informations de configuration sont créées automatiquement, testées localement dans l'environnement du partenaire commercial, puis testées sur un serveur distant. Une fois la configuration testée, les partenaires peuvent mettre la configuration en production. L'Assistant BizTalk SEED permet de réduire le temps que le partenaire commercial consacre à la configuration et le temps que l'initiateur du package SEED consacre aux tests.

  • Surveillance détaillée et gestion des événements. BizTalk Server 2002 inclut de nouveaux événements WMI (Windows Management Instrumentation) évolués qui permettent la gestion des processus professionnels. Afin que le plus grand bénéfice soit tiré de cette gestion améliorée des événements, BizTalk Server 2002 est livré avec un pack de gestion pour MOM (Microsoft Operations Manager), spécifique à BizTalk Server. Grâce au composant Management Pack de BizTalk Server 2002 Édition Entreprise, vous sélectionnez rapidement des alertes prédéfinies et des règles qui permettent d'adapter les applications à vos besoins et de récupérer des données précises à partir d'un événement unique ou d'un ensemble d'événements. Avec le composant MOM et la nouvelle classe WMI de compteurs BizTalk personnalisés, vous créez vos propres applications de surveillance pour obtenir des informations détaillées sur le fonctionnement interne de votre installation BizTalk Server.

  • Prise en charge étendue des services Web XML. Comme certaines applications sont créées à partir de systèmes disparates, notamment les services Web, le besoin de les gérer dans un processus professionnel est plus grand que jamais. BizTalk Server 2002 est livré avec le produit SOAP Toolkit 2.0 Service Pack 2 (SP2), qui permet d'orchestrer les processus professionnels incluant les services Web XML. Le produit SOAP Toolkit 2.0 SP2 se trouve dans le répertoire Web Services sur le CD-ROM d'installation de Microsoft BizTalk Server 2002.

  • Administration à distance. La console Administration de BizTalk Server fait désormais partie de l'installation Outils uniquement. La console d'administration peut être installée sur un ordinateur distant qui n'exécute pas BizTalk Server et vers laquelle n'importe quel serveur BizTalk Server de votre environnement peut pointer, ce qui simplifie l'administration.

  • Fonction de réception HTTP. BizTalk Server intègre maintenant une fonction de réception HTTP ISAPI à hautes performances, gérée et configurée directement depuis la console Administration de BizTalk Server.

  • Gestion des transactions distinctes et gestion des exceptions dans le Concepteur d'Orchestration BizTalk. Le Concepteur d'orchestration BizTalk offre maintenant une option qui permet de spécifier qu'une transaction est utilisée pour la gestion des exceptions. Les performances sont optimisées car l'activité de lecture et d'écriture dans la base de données est limitée.

  • Sécurité SQL intégrée. BizTalk Server 2002 utilise la sécurité Microsoft Windows® intégrée pour accéder à Microsoft SQL Server™. Cela signifie que BizTalk Server, au lieu de faire appel aux informations d'autorisation sécurisées SQL, utilise celles des utilisateurs Windows 2000 pour déterminer les privilèges SQL.

  • Gestion de base de données. De nombreux nouveaux utilitaires et scripts sont maintenant disponibles pour simplifier la gestion de la base de données de suivi et de la base de données de persistance XLANG.

  • Corrélation XLANG. Au démarrage d'un processus professionnel, il est désormais possible à plusieurs instances de planification d'utiliser une seule file d'attente de messages et aux messages entrant dans cette file d'attente d'être mis en corrélation avec une instance spécifique pour que le processus professionnel puisse se poursuivre. Par ailleurs, le processus de mise en corrélation avec les processus professionnels en cours d'exécution a été simplifié.

  • Réserve de planifications XLANG. Vous pouvez maintenant définir une « réserve de planifications », soit un nombre maximal d'instances de planification autorisé en mémoire au même moment. Ceci permet un niveau de contrôle élevé sur les ressources informatiques et se révèle particulièrement utile dans le cas où la configuration matérielle représenterait une contrainte importante. BizTalk Server 2002 utilise la mise en réserve d'objets COM+ et obtient ainsi des performances maximales.

  • Amélioration du Mappeur BizTalk. Le Mappeur BizTalk a été mis à jour pour inclure les fonctionnalités suivantes :
    • Prise en charge des contenus mixtes XML.

    • Test des instances de documents natives (XML et non-XML) directement dans le Mappeur BizTalk.

    • Modification de la grille pour permettre l'existence de plusieurs pages.

    • Ajout des fonctionnalités de glisser-déplacer.

    • Possibilité d'écrire des scripts de fonctoid à l'aide de Microsoft JScript®. De plus, il est possible d'écrire des ensembles de fonctoids personnalisés avec Microsoft Visual C#™ .NET et de Microsoft Visual Studio® .NET.
  • Amélioration de l'Éditeur BizTalk. L'Éditeur BizTalk a été mis à jour pour inclure les fonctionnalités suivantes :
    • Création d'une instance de document native.

    • Prise en charge de contenus mixtes XML.

    • Ajout de fonctionnalités de glisser-déplacer.

    • Validation de l'instance d'un document en fonction d'une spécification.

    • Prise en charge de la saisie des données d'enregistrement.

    • Exportation des schémas des définitions XSD directement depuis l'Éditeur BizTalk.
  • Plus de documentation. Plus de 500 nouvelles pages d'informations ont été ajoutées dans l'aide de BizTalk Server :
    • Nouvelle section Mise en route contenant les rubriques À qui est destiné BizTalk Server ?, Fonctionnement de BizTalk Server et Création d'une solution BizTalk Server.

    • Leçons sur BizTalk Server 2002 : sept leçons qui expliquent les notions fondamentales autour de BizTalk Server et qui contiennent des informations décrivant les outils et les processus nécessaires à la création de solutions avec BizTalk Server.

    • Exemple d'approvisionnement électronique : cet exemple s'appuie sur BizTalk Server 2002, Internet et sur le principe de mise en corrélation pour montrer comment automatiser le processus d'approvisionnement qui intervient entre une entreprise et ses fournisseurs.

    • Trousse à outils BizTalk Server Developer's Toolbox plus importante : cette trousse à outils fournit toutes les informations dont les programmeurs C++ et Microsoft Visual Basic® ont besoin pour utiliser BizTalk Server 2002 ou étendre son utilisation.
  • Un plus grand nombre d'exemples. BizTalk Server 2002 contient plus de 20 nouveaux exemples qui illustrent la plupart des nouvelles fonctionnalités du programme, notamment des exemples montrant comment :
    • Actualiser tous les objets d'échanges BizTalk stockés dans WebDAV (Web Distributed Authoring and Versioning). Voir Refresh Messaging Manager.

    • Suivre et consigner les planifications XLANG en vue du débogage. Voir XLANG Trace.

    • Soumettre des documents de plus de 4 méga-octets (Mo) aux services d'orchestration BizTalk. Voir Message Queuing 4 MB Limit.

    • Soumettre des pièces jointes au format MIME (Multipurpose Internet Mail Extensions) aux services d'échanges BizTalk. Voir Multi-Part MIME Attachment.

    • Soumettre plusieurs documents à des planifications XLANG de façon synchrone et procéder à des requêtes de façon asynchrone. Voir XLANG Submit Synchronously and Query Asynchronously.

    • Soumettre des documents avec auto-routage. Voir Self-Routing.

    • Surveiller la file d'attente interrompue. Voir Suspended Queue Monitoring.

    • Utiliser les échanges au format Reliable. Voir Reliable Messaging.

    • Utiliser une mise en réserve de planifications XLANG. Voir XLANG Schedule Pooling.

    • Utiliser des compteurs personnalisés. Voir Custom Counters.

    • Utiliser des échanges EDI (Electronic Data Interchange) et des réceptions EDI. Voir EDI and Receipts.

    • Utiliser des fichiers plats délimités et positionnels. Voir Flat-File Positional et Flat-File Delimited.

    Par ailleurs, l'Assistant Configuration de BizTalk Server, qui fournit un support simple pour le déploiement programmé des informations de configuration des échanges BizTalk Server, a été amélioré pour prendre en charge les fonctions de réception.

  • Adaptateurs pour les entreprises. La connexion de systèmes disparates et l'accès à des magasins de données hétérogènes est maintenant possible grâce aux adaptateurs. En utilisant ces adaptateurs pour permettre l'accès à vos systèmes et à vos données, vous réduisez sensiblement, voire éliminez la grande quantité de code qu'il est nécessaire d'écrire pour implémenter manuellement les connexions. Ces adaptateurs connectent BizTalk Server 2002 aux applications et aux données des tierces parties :
    • Bases de données

    • Protocole FTP (File Transfer Protocol)

    • Applications ERP (Enterprise Resource Planning)

    • Applications CRM (Customer Relationship Management)

    Pour obtenir la liste complète des adaptateurs BizTalk Server disponibles auprès de Microsoft et de ses partenaires, consultez la page BizTalk Server Adapters and Connectivity sur le site Web de Microsoft BizTalk Server à l'adresse suivante : www.microsoft.com/biztalk/evaluation/adapters.asp.


À qui est destiné BizTalk Server ?

BizTalk Server 2002 permet à un public varié de résoudre des problèmes d'intégration importants. Il peut s'agir de petits commerçants dont les moyens d'existence dépendent de partenariats exclusifs, ou bien d'entreprises qui entretiennent des centaines de partenariats et gèrent des milliers de documents à chaque seconde.

Les entreprises de plus petite taille peuvent utiliser BizTalk Server pour établir des connexions point-à-point, mais cette utilisation répond moins efficacement aux besoins des organisations plus importantes. Pour les entreprises de grande taille, il est possible de joindre plusieurs groupes BizTalk Server pour constituer un bus d'intégration distribué. Celles-ci sont généralement organisées en unités commerciales autonomes et en nombre limité, qui développent et gèrent leurs propres systèmes. Ces unités commerciales doivent à la fois partager des données avec des applications contrôlées par d'autres unités commerciales et communiquer avec des partenaires commerciaux externes.

L'illustration suivante montre comment partager les données dans une entreprise qui a conçu son architecture d'intégration point par point, au fur et à mesure de l'apparition des besoins. La partie droite indique la façon dont BizTalk Server 2002 optimise l'organisation et l'efficacité de l'échange des données.

BizTalk Server permet une intégration efficace et transparente des données

Les entreprises établies depuis longtemps estiment que BizTalk Server améliore l'efficacité de leurs anciens systèmes et que, grâce à lui, elles peuvent adapter leur architecture au commerce électronique B2B (business-to-business). Une entreprise nouvellement créée peut utiliser BizTalk Server dès le départ et en faire le produit central auquel intégrer tout nouveau système.

Citons quelques exemples concrets d'utilisation de BizTalk Server :

  • Un fabricant de produits médicaux utilise BizTalk Server pour interagir avec un éventail de plates-formes de commerce électronique.

  • Une entreprise privée qui développe et commercialise des solutions de commerce électronique B2B et d'automatisation de processus destinées aux marchés financiers recourt aux technologies BizTalk Server pour créer une infrastructure permettant une intégration des données transparente, moins coûteuse et plus efficace.

  • Un fabricant d'ordinateurs utilise BizTalk Server pour transmettre rapidement des données et des documents, et pour intégrer ses relations avec ses fournisseurs afin d'améliorer sa chaîne d'approvisionnement, d'augmenter son efficacité et fournir à ses clients un service dont le fonctionnement est parfait.

  • Une société de commerce électronique utilise Microsoft Windows 2000, Internet Information Services (IIS) et BizTalk Server, pour créer un concentrateur Internet et fournir un seul lieu d'achat pour les futurs étudiants, les conseillers d'orientation scolaires et les départements de recrutement et d'admissions des universités.

  • Une entreprise qui offre un ensemble de services financiers et comptables destinés aux PME utilise XML et BizTalk Server pour créer des services sur le Web basés sur sa suite d'applications internes SAP R/3.

Cette section traite des rubriques suivantes :

  • Intégration de BizTalk Server dans l'infrastructure informatique d'une organisation

  • Intégration de BizTalk Server dans la plate-forme .NET


Intégration de BizTalk Server dans l'infrastructure informatique d'une organisation

Quelle est l'infrastructure technique de votre entreprise ? Est-elle conçue sur une plate-forme unique Windows ou UNIX ? Cela n'est probablement pas le cas. La plupart des entreprises préfèrent adopter des systèmes mixtes. Même si votre entreprise est équipée d'une seule plate-forme « standard », il est fort probable que plusieurs autres environnements d'applications et de développement fonctionnent en parallèle afin que les objectifs commerciaux puissent être atteints.

Si votre configuration actuelle est une configuration éprouvée à laquelle a été consacré un investissement financier et humain important, il n'est pas nécessaire de la remplacer juste pour résoudre un nouveau problème. D'une façon générale, le remplacement des anciens systèmes est utile s'il existe une raison commerciale majeure.

BizTalk Server fournit un serveur central d'intégration piloté par données, un ensemble d'outils de productivité avancés ainsi que des services grâce auxquels vous pouvez créer et déployer des processus professionnels pour mener à bien une intégration EAI (Enterprise Application Integration) et effectuer des transactions B2B (business-to-business). Parce qu'il prend en charge plusieurs transports et plusieurs protocoles, BizTalk Server permet aux installations informatiques existantes d'évoluer vers XML et, ainsi, d'intégrer les nouvelles technologies sur lesquelles sont basées le commerce électronique.

Avec l'apport du XML, BizTalk Server améliore les installations informatiques pour les raisons exposées ci-dessous.

  • Il fournit le Mappeur BizTalk, un outil graphique de mappage de données pour la conversion des données XML depuis et vers les anciens formats de données avec différentes structures, telles que EDI et fichiers plats.

  • Il permet la prise en charge des transports et des protocoles aux normes industrielles, tels HTTP, HTTPS, SMTP, SSL, S/MIME et SOAP, pour intégrer vos installations informatiques existantes aux applications et services Web.

  • Il utilise les adaptateurs standard proposés par les principaux fournisseurs de l'industrie informatique pour l'accès aux applications de l'entreprise. Pour plus d'informations, consultez la page BizTalk Server Adapters and Connectivity sur le site Web Microsoft BizTalk Server à l'adresse suivante : www.microsoft.com/biztalk/evaluation/adapters.asp.

Il est possible d'installer BizTalk Server au sein de votre infrastructure informatique existante avec une configuration matérielle et logicielle minimale.

Pour plus d'informations sur les fonctionnalités de BizTalk Server, telles que les outils XML, le Gestionnaire d'échanges BizTalk et l'Assistant BizTalk SEED, voir Fonctionnalités de BizTalk Server.


Intégration de BizTalk Server dans la plate-forme .NET

La plate-forme Microsoft® .NET contient un ensemble complet de produits .NET développés selon les normes de l'industrie et les normes Internet qui offrent une solution à tous les aspects du développement (outils), de la gestion (serveurs), de l'utilisation (services de base et clients actifs) et de la pratique (étendues des fonctionnalités) des services Web XML.

La famille des produits .NET Enterprise Servers englobe à la fois des infrastructures d'entreprise générales et de commerce électronique. La famille de produits Windows 2000 Server représente une base solide pour la sécurité et l'évolutivité permettant l'exécution des produits .NET Enterprise Servers et des applications d'entreprise pour le commerce électronique.

La famille de produits .NET Enterprise Servers est constituée comme suit :

  • Application Center 2000 : déploiement et gestion d'applications Web dont le niveau de disponibilité et d'évolutivité est élevé.

  • BizTalk Server 2002 : création de processus professionnels basés sur XML, exécutés sur différentes applications et dans différentes organisations.

  • Commerce Server 2000 : création de solutions de commerce électronique évolutives.

  • Content Management Server 2001 : gestion du contenu dynamique des sites Web de commerce électronique.

  • Exchange 2000 Server : activation des échanges et de la collaboration.

  • Host Integration Server 2000 : création d'un lien entre les données et les applications des anciens systèmes.

  • Internet Security and Acceleration Server 2000 : connexions rapides et sécurisées à Internet.

  • Mobile Information 2001 Server : prise en charge d'applications sur les périphériques mobiles comme les téléphones cellulaires.

  • SharePoint Portal Server 2001 : recherche, partage et publication d'informations sur l'entreprise.

  • SQL Server 2000 : stockage, extraction et analyse des données XML structurées.

Microsoft SQL Server gère la logique d'entreprise de votre base de données tandis que Microsoft Commerce Server gère l'interface principale destinée aux clients.

BizTalk Server est le produit en arrière-plan qui permet le fonctionnement d'une solution de commerce électronique ou d'arrière-plan. Une fois qu'un client a passé une commande d'un produit grâce à une application d'achats, telle Microsoft Commerce Server, BizTalk Server traite le processus d'achat qui était auparavant effectué manuellement. BizTalk Server « achète » le produit auprès des fournisseurs, gère l'échange des ordres d'achat et, enfin, effectue l'intégration EAI (Enterprise Application Integration) interne. Une fois l'achat confirmé, les enregistrements du client sont complétés dans une application financière, qui émet un bon de commande à destination du programme de distribution.

Par ailleurs, Microsoft Host Integration Server et les adaptateurs système de l'hôte fournissent l'accès aux données essentielles à l'opération, lesquelles sont stockées sur un système central ou un ordinateur. Host Integration Server est conçu pour extraire les données à partir d'un système central et pour les transférer vers BizTalk Server ou Commerce Server, pour effectuer la transformation totale nécessaire pour le commerce électronique, sans convertir ou remplacer le matériel ou les logiciels.

Pour plus d'informations sur la famille de produits .NET Enterprise Servers, accédez au site Web de Microsoft .NET Enterprise Servers à l'adresse suivante : www.microsoft.com/france/serveurs/default.asp.

Pour plus d'informations sur BizTalk Framework 2.0 et sur les ressources de BizTalk Server, telles que les services de communauté, la grande bibliothèque de schémas et les livres blancs, accédez au site Web de Microsoft BizTalk Server à l'adresse suivante : www.microsoft.com/france/biztalk.

Services Web XML

La pratique du commerce électronique augmente dans les entreprises et chez les clients et c'est pourquoi l'industrie se penche sur un nouveau modèle informatique qui permette la création d'applications et de processus selon des méthodes normalisées pour se connecter au Web et y échanger des informations. Cette nouvelle méthodologie d'intégration basée sur Internet, appelée services Web XML, permet le fonctionnement commun des applications, des ordinateurs et des entreprises, ce qui n'a jamais été possible auparavant.

L'illustration suivante montre comment les services Web XML peuvent être combinés pour la pratique des utilisateurs.

Les services Web XML permettent le fonctionnement en commun des applications, des ordinateurs et des entreprises.

Grâce aux technologies basées sur XML telles SOAP, qui permet aux applications d'interagir avec les protocoles Internet et les normes UDDI (donnant ainsi aux entreprises une méthode standard de description de leurs services et de connexion automatique), les développeurs créent un nouveau type de logiciel utilisant XML pour fournir des services Web. (Pour plus d'informations sur la norme UDDI, accédez au site Web www.uddi.org.. Les services Web XML s'appuient sur des technologies souples qui relient des systèmes disparates par le biais de langages différents, en harmonisant les ordinateurs personnels, l'informatique des entreprises et le Web. Ces services Web XML sont programmables et réutilisables, à la façon des logiciels, à ceci près qu'ils sont disponibles sur Internet. Les programmes utilisant ce modèle peuvent s'exécuter sur plusieurs sites Web, récupérer des données et des services sur chacun d'eux, puis les associer et les transmettre sous un format personnalisé vers n'importe quel périphérique.

La plate-forme Microsoft .NET permet de générer, de déployer, d'exécuter et d'intégrer des services Web XML. Les quatre principes qui régissent les services Web XML sont présentés ci-après :

  1. Les systèmes doivent être connectés à Internet. Ce préalable est conseillé étant donné la haute disponibilité d'Internet et les coûts de connexion faibles.

  2. La recherche des services sur Internet que les entreprises peuvent utiliser doit être simple. La technologie UDDI est le résultat d'un important investissement du monde industriel auquel plusieurs entreprises majeures ont pris part. Elle permet de localiser les services fournis par d'autres entreprises et de les comprendre.

  3. Un langage commun doit être utilisé pour garantir l'échange des informations. Le langage XML rend cet échange possible. Il fournit un format de données commun qui permet de continuer à utiliser les données et les informations sans imposer aux partenaires commerciaux ou aux clients l'utilisation d'un langage de programmation, d'une application ou d'un système d'exploitation particulier pour interagir avec vos systèmes.

  4. Un moyen réel d'effectuer des échanges commerciaux doit exister. Il doit exister un moyen d'appeler un service, de prendre un rendez-vous, de commander une pièce ou de transmettre des informations via un protocole commun. Ce protocole, appelé SOAP, permet aux systèmes de communiquer entre eux et d'émettre des requêtes. Le protocole SOAP correspond au nouveau modèle d'intégration native pour Internet.

Le respect de ces quatre principes vous permet de vous connecter, d'effectuer des recherches, des conversions et des transactions sur des systèmes, des applications et des processus en vue de fournir des services Web XML.

Grâce à une interface graphique intégrée à des outils tels que le Mappeur BizTalk, l'Éditeur BizTalk et le Concepteur d'Orchestration BizTalk, BizTalk Server est un composant clé dans la conception de l'architecture des processus basés sur XML et appliqués aux applications et aux organisations. Pour plus d'informations sur les services Web XML et la plate-forme de produits Microsoft .NET, accédez au site www.microsoft.com/france/net.


Fonctionnement de BizTalk Server

Microsoft BizTalk Server 2002 comprend deux services principaux : les services d'échanges BizTalk, qui permettent d'échanger des messages entre les processus professionnels, et les services d'orchestration BizTalk, qui permettent la création des processus professionnels.

L'intégration et ses difficultés

Il ne fait aucun doute que l'intégration des applications dans une organisation a toujours été la source de grandes difficultés. Vous en avez sans doute fait l'expérience personnellement et avez déjà rencontré des applications fonctionnant sur des systèmes d'exploitation différents, écrites dans des langages différents et basées sur des modèles de programmation différents. Votre rôle consiste à faire communiquer toutes ces applications.

Le commerce électronique a considérablement compliqué ces tâches d'intégration. Non seulement vous devez intégrer vos systèmes internes, mais vous devez aussi intégrer leurs processus avec ceux des clients externes et des fournisseurs principaux (ce qui requiert l'utilisation de technologies ouvertes telles que les services Web XML, HTTP ou SMTP pour les échanges et XML pour le formatage des données), tout ceci devant être effectué sur Internet.

Les entreprises soucieuses de maintenir leur niveau de compétitivité doivent mener à bien les tâches d'intégration tant au niveau interne qu'externe. D'un point de vue historique, les différences entre l'intégration interne et externe ont toujours été envisagées comme des questions liées à des ensembles différents de connexions point-à-point. Mais les connexions ne sont qu'un moyen d'arriver à ses fins, la finalité réelle étant l'intégration des processus professionnels.

D'une façon générale, les entreprises utilisent en interne des formats de données propriétaires et ont toujours utilisé un système d'appel de procédure distante synchrone (RPC). Cependant, lorsque le nombre d'applications internes à intégrer augmente, le modèle synchrone pose des problèmes de fiabilité et de disponibilité. Pour contourner ce problème, les entreprises se tournent aujourd'hui vers un modèle asynchrone qui se comporte comme un modèle synchrone et que l'on appelle pour cette raison « sync on async ».

Par où commencer ? L'intégration des processus professionnels est une grande idée, mais il faut savoir que le seul fait de surveiller les connexions pour quelles fonctionnent correctement représente souvent un emploi à plein temps. À la fin de la journée, votre travail aura consisté à récupérer les bonnes informations au bon endroit et au bon moment.

C'est alors que BizTalk Server entre en jeu.

BizTalk Server permet l'intégration des processus professionnels

Avec BizTalk Server, les analystes, les informaticiens et les développeurs de l'entreprise travaillent dans un environnement commun dans lequel ils peuvent définir, concevoir et déployer rapidement des solutions intégrées disponibles dans les applications, les plates-formes et les organisations.

BizTalk Server facilite l'orchestration des processus professionnels dynamiques au sein des organisations et entre elles.

Plus précisément, BizTalk Server permet les tâches suivantes :

  • Simplification de l'intégration des applications. Créez, gérez et suivez facilement les processus professionnels distribués qui vont au delà des des applications, des organisations et du temps.

  • Diminution des délais de sortie sur le marché. Établissez rapidement des relations commerciales B2B fiables et sécurisées avec vos clients et vos principaux partenaires sur Internet.

  • Rationalisation des installations informatiques existantes. Intégrez à coût réduit les anciennes applications disparates en utilisant des standards, indépendamment de votre plate-forme.

Cette section traite des rubriques suivantes :

  • Services d'Échanges BizTalk

  • Services d'orchestration BizTalk

  • Création d'une solution BizTalk Server

  • Facilité de gestion, fiabilité et flexibilité

  • Accélérateurs BizTalk Server


Services d'Échanges BizTalk

Les services d'échanges BizTalk comprennent :

  • La réception des documents entrants.

  • L'analyse des documents pour déterminer leur format propre.

  • L'extraction des identificateurs clés et l'identification des règles de routage spécifiques.

  • Le transfert des documents vers leurs destinations respectives.

  • Le suivi des documents.

Ces services comprennent également le mappage des données, la génération et la mise en corrélation des accusés de réception, ainsi que des services assurant l'intégrité et la sécurité des données.

Pour accéder aux exemples de code utilisés par les services d'échanges BizTalk, voir BizTalk Messaging Services Code Samples.

Méthodes de configuration des échanges

BizTalk Server fournit deux méthodes de configuration des services d'échanges BizTalk pour gérer les échanges de documents entre les partenaires commerciaux et les applications internes de l'entreprise. Ces méthodes sont les suivantes :

  • Utilisation du Gestionnaire d'échanges BizTalk. Il s'agit d'une interface graphique utilisateur qui contient un Assistant d'échanges.

  • Utilisation du modèle d'objets de configuration des échanges BizTalk. Il s'agit d'un modèle auquel vous pouvez accéder directement.

Grâce au Gestionnaire d'échanges BizTalk ou au modèle d'objets de configuration des échanges BizTalk, vous pouvez créer des ports d'échanges et des canaux assurant la gestion des échanges de données. Vous pouvez également créer des définitions de document, des enveloppes et des organisations qui permettent de créer des ports d'échanges et des canaux, ainsi que des listes de distribution, autrement dit des groupes de ports d'échanges.

Configuration du service d'échanges

L'illustration suivante montre les étapes à suivre pour créer une spécification de document et configurer un service d'échanges.

Processus de configuration d'un service d'échanges.

La première étape consiste à utiliser l'Éditeur BizTalk pour créer graphiquement une spécification de document, c'est-à-dire un fichier XML (Extensible Markup Language) qui définit la structure d'un document, son type et sa version. Si votre partenaire commercial doit utiliser ce document dans un autre format, recourez au Mappeur BizTalk pour mapper les données à un format de document qui convient à votre partenaire commercial.

Pour configurer votre service d'échanges, vous devez créer une définition de document qui fait référence à la spécification que vous avez créée. Cette opération est possible au moyen du modèle d'objets de configuration des échanges BizTalk. Vous pouvez accéder à ce modèle soit par mode graphique, via le Gestionnaire d'échanges BizTalk, soit directement via l'API (Application Programming Interface). D'un point de vue conceptuel, une spécification XML est identique à une définition de document BizTalk. D'un point de vue technique cependant, elles diffèrent grandement par la façon dont elles sont créées et stockées. Les spécifications sont des documents créés par l'Éditeur BizTalk et stockés sous forme de fichiers XML dans le référentiel WebDAV (Web Distributed Authoring and Versioning). Les définitions de document sont des objets créés par le modèle d'objets de configuration des échanges BizTalk (via le Gestionnaire d'échanges BizTalk ou via l'API) et stockés dans la base de données Gestion d'échanges BizTalk, une base de données SQL Server utilisée par BizTalk Server. Les définitions de documents BizTalk Server peuvent être envisagées comme des spécifications XML qui ont été converties en une forme d'objet.

Cette section traite des rubriques suivantes :

  • Fonctions de réception

  • Services de transport

  • Parseurs de données

  • Validation des données

  • Échanges au format Reliable

  • Sécurité

Voir aussi

BizTalk Messaging Services Code Samples

Introducing Messaging Services

Utilisation du Gestionnaire d'échanges BizTalk


Fonctions de réception

BizTalk Server 2002 fournit des fonctions de réception permettant au serveur de contrôler les documents envoyés aux emplacements spécifiés. BizTalk Server prend en charge les fonctions de réception suivantes, configurées à l'aide du composant Administration de BizTalk Server :

  • Fichier

  • HTTP

  • Message Queuing

BizTalk Server 2002 prend également en charge les protocoles entrants suivants, configurés à l'aide des pages ASP ou d'un script Microsoft Exchange :

  • Protocole HTTP (Hypertext Transfer Protocol) utilisant une page .asp

  • Protocole HTTPS (Secure Hypertext Transfer Protocol) utilisant une page .asp

  • Protocole SMTP (Simple Mail Transfer Protocol) utilisant un script Microsoft Exchange

  • Protocole FTP (File Transfer Protocol) utilisant le service FTP IIS (Internet Information Services) et une fonction de réception de fichier

Voir aussi

Parseurs de données

Validation des données

Fonctions de réception

Échanges au format Reliable

Sécurité

Services de transport


Services de transport

BizTalk Server 2002 fournit des services de transport permettant de transmettre des documents à leurs destinations. BizTalk Server prend en charge les services de transport suivants :

  • Protocole HTTP (Hypertext Transfer Protocol)

  • Protocole HTTPS (Secure Hypertext Transfer Protocol)

  • Protocole SMTP (Simple Mail Transfer Protocol)

  • Fichier

  • Message Queuing

  • Composants d'intégration d'application (AIC)

  • Bouclage

Voir aussi

Parseurs de données

Validation des données

Fonctions de réception

Échanges au format Reliable

Sécurité

Services de transport

Copyright © 1999–2001 Microsoft Corporation.
Tous droits réservés.

Ces informations vous ont-elles été utiles ? Veuillez envoyer vos suggestions et commentaires relatifs à la documentation à BizTalk Server Documentation Feedback@microsoft.com


Parseurs de données

BizTalk Server 2002 prend en charge des parseurs de données pour une variété de normes de document de l'industrie, telles que les normes ANSI X12, EDIFACT, fichiers plats et XML (Extensible Markup Language) bien formé. De plus, vous pouvez développer, enregistrer et utiliser vos propres composants parseur au format Custom.

BizTalk Server prend également en charge BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk Server à l'adresse suivante : www.microsoft.com/france/biztalk/.

Voir aussi

Validation des données

Fonctions de réception

Échanges au format Reliable

Évolution horizontale des services d'échanges BizTalk

Sécurité

Services de transport


Validation des données

BizTalk Server 2002 assure la validation des données en vérifiant chaque instance d'un document par rapport à une spécification. Si le document n'est pas conforme aux règles de la spécification, il est placé dans une file d'attente interrompue pour subir ultérieurement une analyse ou être corrigé automatiquement.

Voir aussi

Parseurs de données

Fonctions de réception

Échanges au format Reliable

Sécurité

Services de transport


Échanges au format Reliable

BizTalk Server 2002 permet des échanges au format Reliable car il dispose de propriétés de services d'échanges BizTalk configurables. Ces propriétés incluent la définition de fenêtres Service pour l'envoi de documents, l'envoi ou la réception d'accusés de réception, la définition du nombre de tentatives et la définition du délai écoulé entre ces tentatives. BizTalk Server prend en charge l'utilisation d'enveloppes compatibles avec BizTalk Framework, qui fournissent les fonctionnalités d'échanges au format Reliable. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk Server à l'adresse suivante : www.microsoft.com/france/biztalk/. BizTalk Server centralise également les documents mis en file d'attente. En cas de défaillance d'un serveur, les mécanismes de substitution permettent aux nouveaux serveurs de prendre le contrôle des documents et de les traiter.

Voir aussi

Parseurs de données

Validation des données

Fonctions de réception

Sécurité

Services de transport


Sécurité

Microsoft BizTalk Server 2002 permet aux entreprises d'échanger des données en toute sécurité avec leurs partenaires commerciaux. BizTalk Server tire parti des fonctions de sécurité suivantes offertes par Microsoft Windows 2000 :

  • Sécurité des comptes Windows et stratégies locales

  • Sécurité intégrée de Windows et sécurité Microsoft SQL Server™ à l'ouverture de session

  • Sécurité et rôles des Microsoft Component Services

  • Infrastructure de clés publiques

  • CryptoAPI

  • Cartes à puce

  • Protocole Kerberos

BizTalk Server 2002 prend en charge le mode de cryptage S/MIME (Secure Multipurpose Internet Mail Extensions) utilisant les clés publiques et basé sur des certificats, ainsi que les signatures numériques pour tous les documents transmis au moyen des services de transport de BizTalk Server 2002. BizTalk Server gère en outre le décryptage et la vérification des signatures des documents reçus.

Voir aussi

Parseurs de données

Validation des données

Fonctions de réception

Échanges au format Reliable

Services de transport

Présentation de la sécurité


Services d'orchestration BizTalk

Avant de vous pencher sur les services d'orchestration de BizTalk, réfléchissez à la signification du mot « orchestrer ». Ce mot évoque pour vous la musique ? Si oui, il vous fait également certainement penser à un chef d'orchestre qui conduit des musiciens et applique les règles de son art pour les mener à l'harmonie. Sans le chef d'orchestre, les musiciens sont perdus. Avez-vous déjà entendu 40 musiciens répéter avant un concert ? Cela ressemble au chaos. Mais dès que le chef prend la tête de l'orchestre, la musique de ces 40 musiciens résonne dans la plus parfaite harmonie.

C'est de cette façon que BizTalk Server traite vos processus professionnels.

Un processus professionnel détermine l'ordre logique des actions

L'intégration des processus professionnels est souvent développée en fonction de la compréhension des interfaces externes que chaque système expose, ainsi que des formats et des spécifications de message utilisés pour transférer les messages. Souvent, elle tient également compte des considérations de sécurité, de codage des messages et d'échanges des messages au format Reliable. Toutefois, l'adressage, l'envoi et la réception des messages ne suffisent pas à eux seuls à constituer une solution pour l'intégration des processus professionnels.

De quelle façon le message d'origine est-il créé ? Comment reçoit-on un message, comment est-il traité et comment y répond-t-on ? Dans tous les cas, il s'agit de processus professionnels. Un processus professionnel détermine l'ordre logique des actions et le flux correspondant des messages. Il détermine également le protocole d'échange des messages entre les intervenants qui sont répartis.

De nos jours, la plupart des processus professionnels sont créés à l'aide d'un code personnalisé. De fait, les entreprises sont souvent contraintes de modifier rapidement l'implémentation de leurs processus professionnels pour refléter l'évolution de leurs besoins dans un environnement hautement évolutif. Les services d'orchestration BizTalk résolvent ce problème car ils éliminent l'aspect personnalisation du code dans la création des processus professionnels. Ainsi, l'environnement peut être modifié rapidement.

BizTalk Server permet l'orchestration des processus professionnels

Les services d'orchestration BizTalk représentent une nouvelle façon d'aborder la conception, le déploiement et la gestion des processus professionnels distribués. Ils servent à créer des processus professionnels qui gèrent la logique globale de l'entreprise. BizTalk Server vous permet d'orchestrer vos processus professionnels en associant un moteur d'exécution à un outil de conception appelé Concepteur d'Orchestration BizTalk. Grâce à ce Concepteur, vous pouvez coordonner visuellement toutes les orchestrations B2B sur un écran à partir d'une interface graphique Microsoft® Visio®. BizTalk Server enregistre ensuite le workflow dans un fichier exécutable, appelé planification XLANG, dont se sert un moteur d'exécution pour exécuter vos processus professionnels. Vous n'avez pas besoin d'écrire du code pour lier les processus professionnels. Le code se trouve dans les composants individuels de logique d'entreprise, et non dans l'implémentation qui les contient.

Les services d'orchestration BizTalk incluent l'intégration de processus professionnels de longue durée avec les applications qui exécutent ces processus. Cette intégration est fournie par la planification XLANG. D'autres services assurent le contrôle de l'exécution des instances de planification XLANG.

L'une des principales fonctionnalités des services d'orchestration de BizTalk Server est sa capacité à traiter des transactions complexes exécutées pendant des semaines ou des mois, pas seulement pendant quelques minutes ou quelques heures. Une autre consiste à implémenter des actions simultanées dans une planification XLANG unique. Par ailleurs, vous n'avez pas besoin d'écrire un code personnalisé pour gérer l'état de vos processus professionnels. Les services d'orchestration BizTalk s'en chargent à votre place.

Pour accéder aux exemples de code utilisés par les services d'orchestration BizTalk, voir BizTalk Orchestration Services Code Samples.

Cette section traite des rubriques suivantes :

  • Planifications XLANG

  • Technologies d'implémentation

  • Langage XLANG

Voir aussi

BizTalk Orchestration Services Code Samples

Conception des orchestrations BizTalk


Planifications XLANG

Une planification XLANG est un processus professionnel implémenté par la connexion de chaque étape du processus à un composant ou un service qui exécute l'étape. Une planification XLANG est ensuite exécutée par un service appelé moteur de XLANG Scheduler. Ce moteur contrôle l'instanciation, l'exécution, la mise en attente et la réalimentation d'une planification XLANG, ou de plusieurs instances d'une ou plusieurs planifications.

Voir aussi

Technologies d'implémentation

Langage XLANG

Planifications XLANG

Copyright © 1999–2001 Microsoft Corporation.
Tous droits réservés.

Ces informations vous ont-elles été utiles ? Veuillez envoyer vos suggestions et commentaires relatifs à la documentation à BizTalk Server Documentation Feedback@microsoft.com


Technologies d'implémentation

Les technologies d'implémentation prises en charge par les services d'orchestration BizTalk sont les suivantes :

  • Services d'Échanges BizTalk

  • Composants COM

  • Services Message Queuing

  • Composants Windows Script

  • Composants basés sur les produits de la famille Microsoft .NET, utilisant l'interopérabilité du modèle COM (Component Object Model)

Voir aussi

Implémentation de processus professionnels

Planifications XLANG

Langage XLANG


Langage XLANG

XLANG est un langage qui décrit le séquencement logique des processus professionnels ainsi que l'implémentation du processus professionnel à l'aide de différents composants ou services. Ce langage est exprimé en XML (Extensible Markup Language).

Voir aussi

Technologies d'implémentation

Planifications XLANG

XLANG Interfaces


Création d'une solution BizTalk Server

Avant de passer à la phase de création d'une solution BizTalk Server, il est conseillé de planifier une méthodologie ; autrement dit, vous devez déterminer la façon précise dont la solution va fonctionner pour vous assurer que vous répondez aux besoins de façon appropriée.

Par exemple, posez-vous les questions suivantes :

  • Faut-il transmettre des documents, recevoir des documents ou les deux ?

  • Quel est le type de document à transmettre ?

  • Quelle est la destination des documents ?

  • À quel moment doivent-ils arriver à destination ?

  • Quel format de document utiliser ?

  • Quels protocoles utiliser pour le transfert des documents ?

  • Existe-t-il d'anciens systèmes qui doivent être adaptés au nouveau système d'intégration ?

  • Quels types de fichiers ces systèmes utilisent-ils ?

Les décisions prises sur la base des réponses à ces questions, ou à d'autres questions, sont généralement prises au cours de la phase de conception d'un projet, puis implémentées sur une période de plusieurs semaines ou de plusieurs mois par une équipe de programmeurs. Avec BizTalk Server, vous pouvez utiliser le Concepteur d'orchestration BizTalk pour créer rapidement des processus professionnels dans le concepteur visuel.

Un scénario classique pour l'intégration de deux services est la mise en corrélation de messages au sein d'une même instance de planification XLANG en cours d'exécution. Plus précisément, pour que l'instance d'une planification XLANG envoie un message à une application interne ou à un partenaire commercial et attendre un message en retour. L'exemple qui illustre cette opération est celui de l'envoi d'un ordre d'achat et la réception d'un accusé de réception en retour.

Si vous utilisez les outils XML fournis avec BizTalk Server, vous suivrez fort probablement la séquence d'opérations décrite dans le tableau ci-après.

Tâche de développement | Méthode classique | Méthode BizTalk Server
Dessiner le diagramme des processus professionnels | Représentez le processus professionnel sur une feuille de papier ou sur un tableau blanc, ou bien utilisez un outil d'aide à la conception de logiciels. | Utilisez le Concepteur d'Orchestration BizTalk pour associer des formes géométriques dans un schéma de planification XLANG.
Implémenter les processus professionnels | Écrivez un code manuellement, qui reflète la logique d'entreprise souhaitée. | Associez votre planification XLANG à des composants pour appliquer un code exécutable pertinent à votre schéma.
Concevoir la structure des documents | Déterminez la structure des documents, transmettez ces informations au département de programmation et demandez aux programmeurs de choisir un langage et d'écrire un code manuellement qui reflète la structure du document. | Créez les spécifications de documents en utilisant l'Éditeur BizTalk.
Synchroniser ses données avec les données de son partenaire commercial | Écrivez un code manuellement, qui permet de lire et d'écrire les formats des données dans la structure des documents. | Mappez visuellement le format de vos données sur le format des données de votre partenaire à l'aide du Mappeur BizTalk.
Configurer les communications entre l'entreprise et son partenaire commercial | Écrivez un code manuellement, qui permet de transmettre et de recevoir des documents et des messages. Le cas échéant, écrivez un code qui configure et d'effectue la mise en file d'attente des messages. | Créez des canaux et des ports à l'aide du Gestionnaire d'échanges BizTalk.
Déployer la solution | Configurez votre système manuellement pour la réception de nouveaux documents émis par vos partenaires commerciaux, et demandez à ces partenaires d'écrire un code, de configurer et de déployer leurs systèmes de telle sorte que les interactions avec vous soient possibles. | Utilisez Microsoft Application Center 2000 pour le déploiement à l'intérieur de votre entreprise. Utilisez ensuite l'Assistant BizTalk SEED pour créer un package de votre configuration et le déployer chez un partenaire commercial.
Effectuer le suivi des documents | Écrivez un code manuellement, qui permet de contrôler et de suivre les documents, générez des statistiques relatives aux performances et enfin, générez des rapports sur votre code personnalisé. | Utilisez MOM (Microsoft Operations Manager) et la base de données de suivi pour contrôler les notifications d'alertes, créer des statistiques sur les performances et contrôler les bases de données.

Principe du RAD appliqué aux processus professionnels

Le concept de RAD (Rapid Application Development) est né du besoin de pouvoir créer et déployer rapidement une solution logicielle qui, une fois implémentée, soit toujours d'actualité. L'approche RAD, lorsqu'elle est mise en place de façon efficace, permet non seulement de réduire le temps de développement, mais aussi de diminuer les coûts de production.

BizTalk Server introduit le concept de RAD dans le développement des processus professionnels inter-entreprises en offrant des outils XML riches en fonctionnalités comme le Concepteur d'Orchestration BizTalk, l'Éditeur BizTalk et le Mappeur BizTalk.

BizTalk Server vous permet de maintenir vos infrastructures à long terme tout en tout donnant les moyens de relever à court terme les défis de votre entreprise.

Cette section traite des rubriques suivantes :

Intégration EAI (Enterprise Application Integration)

Intégration B2B (Business-to-Business)

Automatisation des processus professionnels


Intégration EAI (Enterprise Application Integration)

Dans une organisation, chaque application représente un système efficace et éprouvé. De nos jours, les entreprises comptent sur les applications pour exécuter les fonctions essentielles à la bonne marche des activités comme la commande de fournitures, la planification de la fabrication et l'exécution des commandes client. L'intégration EAI permet à des applications distinctes de partager des données électroniquement.

Du point de vue des échanges, les technologies EAI ont adopté un paradigme pour l'intégration des applications, qui crée des relations d'échanges un à plusieurs et plusieurs à un. Dans ces modèles, il n'est pas nécessaire que les applications se connaissent. Les données peuvent transiter par BizTalk Server et être routées vers les applications appropriées. Ce paradigme se concentre sur l'intégration des applications à l'infrastructure de distribution des données du domaine de l'entreprise plutôt que sur l'intégration des applications directement l'une à l'autre. Dans le modèle EAI, les applications sont connectées au bus de données du réseau de l'entreprise et participent ainsi au flux de processus professionnels sans que soient créées des dépendances étroites entre les systèmes.

BizTalk Server s'intègre aux autres applications grâce à la prise en charge des standards ouverts tels que XML et des anciens formats de fichiers comme les fichiers texte délimités et positionnels. Dans la plupart des cas, des adaptateurs pré-construits sont disponibles pour faciliter l'intégration entre des systèmes disparates. Un adaptateur est un ensemble d'API qui se servent du moteur d'échanges BizTalk pour faciliter les transactions entre BizTalk Server et d'autres applications. BizTalk Server fournit actuellement des adaptateurs pour plusieurs applications métier et un grand nombre est actuellement en cours de développement. Demandez aux adaptateurs de faire votre travail à votre place. Au lieu de passer du temps à écrire du code EAI de bas niveau, consacrez-vous au perfectionnement de vos processus professionnels. Pour obtenir la liste complète des adaptateurs BizTalk Server, consultez la page BizTalk Server Adapters and Connectivity sur le site Web Microsoft BizTalk Server à l'adresse suivante : www.microsoft.com/biztalk/evaluation/adapters.asp.

Voir aussi

Intégration B2B (Business-to-Business)

Automatisation des processus professionnels


Intégration B2B (Business-to-Business)

Le succès d'Internet dans les années 90 a favorisé l'émergence des processus B2B qui permettent à une entreprise d'échanger des données avec un partenaire ou un client. Si vous voulez intégrer vos processus professionnels à ceux d'un partenaire, il est logique que vous ayez besoin d'un format de document compatible dans lequel échanger des données.

BizTalk Server transforme et route les données sous la forme de messages au format XML au sein et entre les organisations, y compris celles issues de logiciels et de plates-formes matérielles disparates.

Toutefois, le processus B2B ne remplace pas l'intégration EAI. En fait, ils se complètent mutuellement. Presque toutes les transactions entre les entreprises impliquent deux transactions EAI : la première pour extraire le document et la seconde pour le transfert vers un autre ordinateur. Supposons, par exemple, que vous deviez transférer un ordre d'achat d'un système d'arrière-plan sur Internet vers le système d'arrière-plan de votre partenaire commercial. Si le processus B2B permet le transfert entre les deux entreprises, l'implémentation EAI doit encore être utilisée pour déplacer l'ordre d'achat de votre système d'arrière-plan vers votre serveur principal.

BizTalk Server vous permet d'orchestrer l'ensemble du processus.

Voir aussi

Automatisation des processus professionnels

Intégration EAI (Enterprise Application Integration)


Automatisation des processus professionnels

L'automatisation des processus professionnels offre une vue globale de l'ensemble du processus de développement. Ce point est important car le processus est vu dans son entier et non sous la forme de composants disparates interagissant d'une façon qui, auparavant, ne pouvait être décrite que sur papier. Dans le monde du commerce électronique, un processus n'est plus limité à une seule entreprise mais trouve toute sa force en étant réparti sur plusieurs organisations et systèmes. L'automatisation des processus professionnels s'empare de la propriété intellectuelle d'un projet et l'intègre dans le logiciel lui-même, ce qui vous permet de comprendre rapidement en quoi consiste un processus pour pouvoir par la suite le modifier.

Voir aussi

Intégration B2B (Business-to-Business)

Intégration EAI (Enterprise Application Integration)


Facilité de gestion, fiabilité et flexibilité

BizTalk Server fournit des outils pour définir et maintenir des processus professionnels gérés par le produit, et pour exploiter les fonctionnalités de gestion apportées par la plate-forme Windows 2000.

Cette section traite des rubriques suivantes :

  • Facilité de gestion

  • Fiabilité

  • Flexibilité


Facilité de gestion

BizTalk Server fournit le Gestionnaire d'échanges BizTalk pour la définition des processus professionnels distribués et la gestion des relations entre les applications, tant en interne qu'en externe, avec les partenaires commerciaux.

Par ailleurs, BizTalk Server :

  • Offre un composant logiciel enfichable MMC (Microsoft Management Console) pour surveiller les services et les files d'attente critiques sur lesquels repose le produit.

  • Inclut un fournisseur WMI (Windows Management Instrumentation) pour les accès de bas niveau à des informations d'événements, lequel consigne ensuite les entrées appropriées dans le journal des événements Windows.

  • Expose des attributs clés comme les compteurs de performances pour permettre aux personnes familières de l'environnement Windows 2000 de surveiller et de gérer les activités sur un serveur.

  • Fournit une interface basée sur le Web pour l'interrogation du sous-système d'analyse et de suivi des données, qui permet la recherche et l'accès aux données représentant l'activité ayant transité par le produit.

Vous pouvez aussi utiliser les produits MOM (Microsoft Operations Manager) 2000 et Microsoft Application Center 2000 pour surveiller les activités BizTalk Server.

Microsoft Operations Manager (MOM)

Microsoft Operations Manager 2002 est un outil de reporting, de surveillance des performances et de collection des événements conçu pour les systèmes d'exploitation Microsoft Server et les applications basées sur les serveurs. MOM centralise la surveillance, la gestion et la sécurité d'un large éventail de ressources, ce qui améliore la disponibilité, les performances et la sécurité des réseaux Windows 2000 et des applications car la surveillance du système est effectuée en temps réel et de façon proactive.

MOM fournit les fonctionnalités suivantes :

  • Contrôle des opérations pilotées par les événements

  • Solutions évolutives à déploiement automatique

  • Application des stratégies de sécurité avancées et audit des fonctionnalités

  • Disponibilité du système et suivi des performances améliorés

  • Méthodes multiples d'affichage des données et de génération de rapports

Microsoft Application Center 2000

Microsoft Application Center peut servir à déployer une nouvelle configuration de Microsoft BizTalk Server ; par exemple, pour passer d'un environnement de test à un environnement de production. Le fait de déployer un environnement à l'aide de Application Center permet de réduire considérablement le temps nécessaire au changement de configuration et au volume d'interventions manuelles associé à une telle opération.

Voir aussi

À propos de Microsoft Operations Manager

Flexibilité

Fiabilité

Utilisation de Microsoft Application Center 2000

Utilisation de Application Center pour le déploiement d'une solution d'approvisionnement électronique


Fiabilité

BizTalk Server 2002 a été conçu de façon à pouvoir gérer les besoins en traitement les plus pointus. BizTalk Server fonctionne plus spécifiquement sur le concept de « file d'attente partagée », dans laquelle plusieurs serveurs récupèrent des tâches à partir d'une file d'attente de travail centrale en vue de leur traitement. Toutes les tâches à traiter sont envoyées vers une seule file d'attente (qui peut être mise en cluster sur le serveur en arrière-plan pour la tolérance de panne), techniquement vers Microsoft SQL Server. Cette file d'attente est ensuite interrogée par un ou plusieurs serveurs de traitement.

Si un niveau d'évolutivité plus élevé est requis, il est possible d'ajouter des serveurs dans l'organisation. Une fois BizTalk Server installé, vous pouvez lui faire rejoindre un groupe de serveurs en le faisant pointer sur la file d'attente partagée. Cela permet la mise en place d'un scénario hautement évolutif (dit à « évolution horizontale »), qui autorise la réquisition d'un ou deux serveurs seulement pour les charges peu importantes, mais permet l'ajout de cinq, dix serveurs dans l'arrangement, voire davantage pour les charges de l'ordre de millions de documents par jour. Pour les besoins liés à l'évolution verticale sur un serveur ou sur plusieurs serveurs coopératifs, Windows 2000 Datacenter Server prend en charge BizTalk Server sur des systèmes équipés de 8 UC.

Intégration de la redondance

Une distinction importante doit être faite entre les serveurs redondants, qui ne conservent aucune données sur leurs disques durs locaux et les serveurs qui les conservent. BizTalk Server fournit des fonctions de redondance et d'évolutivité en permettant aux serveurs qui appartiennent à un groupe d'accéder à un serveur de base de données BizTalk Server unique sur le réseau. Si l'un des serveurs du groupe tombe en panne, les autres prennent le relais et continuent à accéder au serveur de base de données. Ceci est possible car aucun serveur du groupe ne conserve de données de travail sur son disque local. Si le serveur de base de données distant devient indisponible, tous les serveurs du groupe deviennent inactifs. Pour contourner ce problème et bénéficier d'une disponibilité totale, utilisez le service de cluster de Microsoft qui garantit la disponibilité constante du serveur de base de données central, même si l'un des serveurs enregistre une panne.

La décision d'utiliser le service de cluster dépend de deux facteurs :

  • Le délai d'interruption que votre entreprise peut supporter lorsque le serveur qui conserve des données importantes tombe en panne.

  • Le budget disponible pour l'acquisition de matériels et de logiciels supplémentaires afin de permettre une redondance satisfaisante.

Pour la mise en place d'un scénario simple de redondance, au moins deux serveurs sont requis.

Voir aussi

Facilité de gestion

Flexibilité


Flexibilité

L'utilisation de BizTalk Server est représentative de l'application des technologies à base de standards Internet pour résoudre les problèmes d'intégration. BizTalk Server a été conçu pour prendre en charge :

  • XML (Extensible Markup Language)

  • HTTP (Hypertext Transfer Protocol)

  • HTTPS (Secure Hypertext Transfer Protocol)

  • SMTP (Simple Mail Transfer Protocol)

  • SSL (Secure Sockets Layer)

  • S/MIME (Secure Multipurpose Internet Mail Extensions)

  • SOAP

  • Certificats x509v3

Les fonctionnalités de BizTalk Server peuvent être étendues par le biais de composants logiciels enfichables et de kits de développement de logiciels (SDK). De plus, la prise en charge des standards clés basés sur XML à tous les niveaux du produit permet l'intégration à des applications sur d'autres systèmes, indépendamment des systèmes d'exploitation, des modèles ou des langages de programmation.

Accélérateurs et adaptateurs

BizTalk Server prend en charge XML et de nombreux autres formats de données non-XML, tels que les formats EDI (Electronic Data Interchange) et les fichiers plats. Il peut toutefois prendre en charge toutes sortes de formats de fichiers et d'enveloppes par le biais des sérialiseurs et des parseurs personnalisés que vous pouvez récupérer parmi les accélérateurs de l'industrie informatique ou bien créer à l'aide de la trousse à outils BizTalk Server Developer's Toolbox. Pour plus d'informations, voir Accélérateurs BizTalk Server.

BizTalk Server prend en charge plusieurs adaptateurs tierces parties pré-construits facilitant l'intégration de systèmes disparates. Un adaptateur est un ensemble d'API qui permet l'utilisation du moteur d'échanges BizTalk pour faciliter les transactions entre BizTalk Server et d'autres applications. Pour obtenir la liste complète des adaptateurs BizTalk Server, consultez la page BizTalk Server Adapters and Connectivity sur le site Web de Microsoft BizTalk Server à l'adresse suivante : www.microsoft.com/biztalk/evaluation/adapters.asp.

Protocoles de transport, fonctoids et architecture

BizTalk Server prend en charge en mode natif de nombreux protocoles de transport comme DCOM, Message Queuing, HTTP, HTTPS, SMTP et FTP. Par ailleurs, BizTalk Server prend en charge les protocoles MQSeries et SNA via le composant logiciel enfichable Host Integration Server 2000 et l'adaptateur MQSeries.

BizTalk Server permet la transformation des documents au moyen des fonctions de conversion appelées fonctoids, qui peuvent être créées et réutilisées. Le Mappeur BizTalk fournit un ensemble complet de fonctoids, mais il est aussi possible de créer des fonctoids personnalisés à l'aide de la trousse à outils BizTalk Server Developer's Toolbox.

L'architecture BizTalk Server permet d'utiliser une combinaison appropriée de serveurs de base de données, de réception et de traitement pour répondre aux besoins de traitement.

XML et technologies associées

BizTalk Server prend en charge XML pour fournir des fonctionnalités d'intégration ouvertes avec les applications issues de différentes plates-formes.

Par ailleurs, BizTalk Server :

  • utilise XML comme format standard interne,

  • utilise le modèle DOM (Document Object Model) XML pour accéder aux documents dans la mémoire,

  • prend en charge XPath pour l'accès aux nœuds de documents XML,

  • utilise le standard XSLT (Extensible Stylesheet Language Transformation) pour la conversion des formats de document,

  • prend en charge l'espace de noms XML pour des raisons de clarté sémantique,

  • prend en charge les technologies de schéma XML (grâce au format XDR (XML Data Reduced), un sous-ensemble fonctionnel du schéma XML) pour la saisie des données, la prise en charge de l'espace de noms, ainsi qu'un modèle extensible.

Voir aussi

Facilité de gestion

Fiabilité


Accélérateurs BizTalk Server

Microsoft propose des accélérateurs susceptibles d'augmenter considérablement le développement et les performances des installations BizTalk Server 2002 dans le cadre de marchés et de secteurs d'activité spécifiques.

Microsoft propose actuellement les accélérateurs BizTalk Server pour :

  • Les caisses d'assurance maladie : Microsoft BizTalk Accelerator for HIPAA

  • Les chaînes d'approvisionnement multiples : Microsoft BizTalk Accelerator for Suppliers

  • Les standards des chaînes d'approvisionnement : Microsoft BizTalk Accelerator for RosettaNet


Microsoft BizTalk Accelerator for HIPAA

Microsoft BizTalk Accelerator for HIPAA rationalise le développement et le déploiement de solutions d'intégration pour l'échange des données de façon à les rendre conformes aux réglementations HIPAA (Health Insurance Portability and Accountability Act) de 1996. Les réglementations HIPAA ont été mises en vigueur principalement pour améliorer la portabilité et la continuité de la couverture sociale des individus et des groupes aux États-Unis. Les organismes médicaux ont l'obligation de se conformer aux directives HIPAA lorsqu'ils transmettent des informations électroniquement. L'objectif de ces directives est de réduire les coûts liés aux soins médicaux sans que cela se reporte sur les fournisseurs. Aujourd'hui, il existe plus de 400 formats de transmission différents avec un contenu différent, tout cela pour un seul type de transaction HIPAA : la demande de remboursement de soins. Lorsque les réglementations HIPAA auront été mises en place (mise en vigueur annoncée pour le 16 octobre 2002), il n'existera plus qu'un seul contenu et qu'un seul format que tous les patients devront accepter.

Microsoft, en collaboration avec l'entreprise WPC (Washington Publishing Company), expert dans ce domaine et éditeur exclusif des guides de mise en œuvre des réglementations HIPAA (www.wpc-edi.com/hipaa), propose Microsoft BizTalk Accelerator for HIPAA. Cet accélérateur doit aider les caisses d'assurance maladie à créer des solutions techniques basées sur les standards en vigueur et à réduire le temps et l'argent que les organismes médicaux dépensent pour se conformer aux réglementations HIPAA. Les organismes de soins médicaux et les organismes connexes concernés par les réglementations HIPAA peuvent utiliser les fonctionnalités d'intégration de BizTalk Server 2002, ainsi que les ressources HIPAA fournies par la société WPC, pour automatiser les processus professionnels et créer rapidement des solutions d'intégration. Ils peuvent ainsi se conformer à la législation tout en améliorant leurs installations informatiques existantes. L'interopérabilité entre BizTalk Server 2002 et les systèmes des organismes de soins médicaux et des organismes connexes, conjuguée aux schémas HIPAA de BizTalk, apporte à l'industrie médicale les outils qui lui permettent de mettre en vigueur les réglementations HIPAA.

Pour plus d'informations sur Microsoft BizTalk Accelerator for HIPAA, accédez au site Web www.microsoft.com/Partner/products/serverproducts/biztalkserver2000/btshipaafinal.asp.


Microsoft BizTalk Accelerator for Suppliers

Microsoft BizTalk Accelerator for Suppliers fournit une solution logicielle extensible qui permet aux fournisseurs de vendre plus efficacement par le biais de plusieurs canaux en ligne. Cet accélérateur est construit sur une architecture extensible qui offre aux organisations la possibilité de se connecter à leurs partenaires commerciaux B2B (business-to-business) ainsi qu'à des applications de gestion interne comme un système ERP (Enterprise Resource Planning), un système de gestion des chaînes d'approvisionnement ou un système CRM (Customer Relationship Management) de gestion des relations clientèle. Pour les fournisseurs, il est plus facile, grâce aux pages Web pré-construites, d'offrir aux clients une pratique unique du Web tout en rationalisant les standards du commerce à distance.

Les apports de Microsoft BizTalk Accelerator for Suppliers sont les suivants :

  • Augmentation du chiffre d'affaire et souplesse commerciale. Les entreprises peuvent augmenter leur chiffre d'affaire et renforcer leurs liens avec leurs clients tout en diminuant les coûts induits par les processus non informatisés. Elles peuvent également faire preuve d'une plus grande souplesse en disposant d'une méthode efficace pour accéder à des nouveaux marchés et répondre en temps et en heure aux nouveaux besoins. En outre, les entreprises peuvent interagir avec les nouveaux canaux de vente et les fonctionnalités basées sur différentes technologies et protocoles, formats de données et processus professionnels proposés par les accélérateurs.

  • Occasion de se démarquer des concurrents. BizTalk Accelerator for Suppliers fournit aux entreprises la possibilité d'exposer sur un support électronique la valeur réelle des offres commerciales et des marques de ses fournisseurs. Les entreprises peuvent désormais diminuer les coûts et accélérer le processus consistant à gagner de nouveaux clients, tout en augmentant le volume des activités commerciales réalisé avec la base actuelle de clients.

  • Réduction des coûts et possibilité d'améliorer les installations informatiques existantes. Amélioration et complémentarité des processus professionnels existants, investissement dans les techniques telles que l'ERP, les chaînes d'approvisionnement, la relation clientèle, la logistique et la collaboration.

Pour plus d'informations sur Microsoft BizTalk Accelerator for Suppliers, accédez au site Web à l'adresse suivante : www.microsoft.com/biztalk/evaluation/suppliers/default.asp.


Microsoft BizTalk Server Accelerator for RosettaNet

Microsoft BizTalk Server Accelerator for RosettaNet comprend plusieurs applications grâce auxquelles les utilisateurs développent, administrent et testent les planifications XLANG pour implémenter le processus PIP (Partner Interface Process) conforme au standard RosettaNet. Il existe deux applications supplémentaires pour la gestion des schémas et la configuration des échanges. Cette solution fournit des adaptateurs et la plate-forme serveur nécessaire à la création de solutions basées sur RosettaNet qui devront intégrer les applications, connecter les partenaires commerciaux aux chaînes d'approvisionnement et permettre l'orchestration des processus professionnels complexes de collaboration.

Ces applications contenues dans le produit Microsoft BizTalk Server Accelerator for RosettaNet, conjuguées à BizTalk Server 2002, permettent aux utilisateurs de rationaliser les pratiques d'approvisionnement et de collaborer avec les partenaires commerciaux et les fournisseurs à l'aide du standard RosettaNet. La liste suivante présente les applications contenues dans le produit Microsoft BizTalk Server Accelerator for RosettaNet :

  • PIP Administrator. Contient toutes les informations relatives aux mots de passe pour la base de données et permet aux utilisateurs de spécifier l'emplacement des planifications XLANG.

  • PIP XLANG Schedule Tester. Permet aux utilisateurs de tester les planifications XLANG.

  • PIP Schema Manager. Permet de fusionner des spécifications de documents.

  • Messaging Configuration Wizard. Permet aux utilisateurs de définir des organisations en tant que partenaires commerciaux. Cet Assistant permet de générer des scripts de configuration, qui appellent des objets de configuration d'échanges BizTalk à l'aide d'un programme pour créer et configurer les ports et les canaux requis.

Pour plus d'informations sur le produit Microsoft BizTalk Server Accelerator for RosettaNet, accédez au site Web à l'adresse suivante : www.microsoft.com/Partner/businessresources/SalesResources/factsheets/BTSRosettaNET.asp.


Fonctionnalités de BizTalk Server

Le tableau suivant contient des informations sur les fonctionnalités de BizTalk Server et leur utilisation.

Caractéristiques Fonction
Administration
  • Administration des serveurs et des applications

  • BizTalk Orchestration Services
  • Création et gestion de serveurs et de groupes de serveurs.

  • Configuration des propriétés globales de groupe de serveurs, telles que l'emplacement des bases de données de files d'attente partagées et de suivi.

  • Configuration des paramètres du serveur.

  • Configuration et gestion des fonctions de réception.

  • Affichage et gestion des files d'attente de documents.

  • Accès programmé au gestionnaire du système XLANG Scheduler, aux gestionnaires de groupe, aux instances de planification XLANG et aux ports XLANG.
Suivi des documents
  • Suivi de documents
  • Suivi de la progression du traitement des documents par Microsoft BizTalk Server 2002.

  • Recherche, affichage, visualisation et enregistrement de copies intégrales d'échanges ou de documents traités par BizTalk Server 2002.

  • Création de requêtes pour extraire des informations essentielles de la base de données de suivi dans un format facile à afficher.

  • Extraction, enregistrement et analyse de données utilisateur importantes contenues dans des documents.
Conception de l'orchestration
  • Conception des orchestrations BizTalk
  • Création de schémas décrivant les processus professionnels et implémentation programmée de ces schémas dans un environnement de conception intégré.

  • Compilation de schémas de planification XLANG en planifications XLANG.

  • Définir le flux de données entre les messages au sein des processus professionnels.
Échanges
  • Utilisation du Gestionnaire d'échanges BizTalk

  • Understanding Messaging Services
  • Gestion de l'échange de données localement ou à distance à l'aide du Gestionnaire d'échanges BizTalk.

  • Gestion de l'échange de données par programme à l'aide du modèle d'objet de configuration d'échanges BizTalk.

  • Création et gestion de canaux, de ports d'échanges, de définitions de document, d'enveloppes, d'organisations et de listes de distribution.
Outils XML
  • Utilisation de l'Éditeur BizTalk

  • Utilisation du Mappeur BizTalk
  • Création et gestion de spécifications de documents.

  • Création d'enregistrements et de champs, et définition de leurs propriétés.

  • Mappage d'enregistrements et de champs à partir d'une spécification source en enregistrements et champs d'une spécification de destination.

  • Utilisation de fonctoids pour implémenter de puissantes fonctionnalités de transformation de données.
Déploiement
  • Assistant BizTalk SEED
  • Rendre vos partenaires commerciaux rapidement opérationnels en utilisant les packages SEED qui mettent vos configurations à disposition sur Internet.


Modèle d'application BizTalk Server

Microsoft BizTalk Server 2002 propose des outils et des services visant à créer des applications exécutables pour contrôler les processus professionnels et l'échange des données entre les partenaires commerciaux et les applications d'une entreprise. Pour obtenir la liste des services fournis par BizTalk Server 2002, voir Fonctionnalités de BizTalk Server.

L'intégration des services d'orchestration BizTalk et des services d'échanges BizTalk permet de contrôler l'échange de documents et de messages entre vos partenaires commerciaux et vos applications internes grâce à plusieurs services de transport. Les fonctionnalités suivantes sont également fournies :

  • Contrôle des transactions de longue durée complexes et des processus professionnels.

  • Livraison fiable de documents et de messages.

  • Validation des données assurée par le contrôle de chaque instance de document par rapport à une spécification.

  • Mappage des données assuré par des mappages pour transformer la structure et le format des documents.

  • Sécurité et intégrité des données assurées par des certificats de cryptage et de signature numérique.

  • Prise en charge de la génération et de la corrélation d'accusés de réception.

Pour plus d'informations sur la configuration de BizTalk Server pour l'envoi ou la réception d'accusés de réception, voir Description des accusés de réception.

Pour plus d'informations sur l'intégration des services d'orchestration BizTalk et des services d'échanges BizTalk, voir Intégration des services BizTalk.


Modèle d'administration de BizTalk

BizTalk Server 2002 ~ Mise en route

Modèle d'administration de BizTalk Server

Le tableau suivant décrit les quatre principaux domaines d'administration de Microsoft BizTalk Server 2002 et les fonctions administratives appropriées à chaque domaine.

Domaine d'administration Description des fonctions administratives
Administration des serveurs
  • Configuration et gestion des groupes de serveurs et des serveurs.

  • Configuration et gestion des fonctions de réception.

  • Gestion des files d'attente.
Administration des applications
  • Configuration et gestion des applications COM+ qui hébergent les planifications XLANG.

  • Configuration et gestion de l'application XLANG Scheduler par défaut.
Administration de la programmation
  • Configuration des gestionnaires du système XLANG, des gestionnaires de groupe XLANG, des instances de planification XLANG et des ports XLANG.
Administration des bases de données
  • Configuration, gestion et maintenance des bases de données suivantes :
    • Base de données Gestion d'échanges BizTalk

    • Base de données de persistance

    • Base de données de suivi

    • Base de donées de files d'attente partagée

Administration des serveurs

Dans BizTalk Server 2002, l'administration des serveurs inclut des tâches telles que la gestion et la configuration des groupes de serveurs, l'ajout, la suppression et la configuration des serveurs, l'ajout et la configuration des fonctions de réception ainsi que la gestion de la file partagée pour chaque groupe de serveurs. Le tableau suivant contient les tâches administratives générales des serveurs, leur description et les rubriques contenant des informations supplémentaires.

Tâche administrative Description Pour obtenir des informations supplémentaires
Configuration des serveurs et des groupes de serveur
  • Configuration des connexions pour les bases de données de suivi et de files d'attente partagées.

  • Configuration de l'ordre des services de transport et du parseur.

  • Configuration des paramètres du serveur.
  • Ajout, suppression et configuration d'un groupe de serveurs

  • Ajout, suppression et configuration de serveurs dans un groupe
Gestion des files d'attente
  • Suppression et nouvelle soumission des échanges et des documents.

  • Affichage des données et des messages d'erreur.
  • Gestion des files d'attente
Gestion des fonctions de réception
  • Configuration des fonctions de réception.
  • Gestion des fonctions de réception d'un groupe de serveurs
Résolution des problèmes
  • Résolution des problèmes de traitement de serveur et de document.
  • Gestion de l'Observateur d'événements

  • Dépannage d'Administration de BizTalk Server

Administration des applications

L'administration d'application inclut la configuration et la gestion des applications COM+ qui hébergent des planifications XLANG, l'application XLANG Scheduler par défaut et la base de données de persistance d'orchestration créée lors de l'installation de BizTalk Server 2002. Le tableau suivant contient les tâches administratives générales d'application, leur description et les rubriques contenant des informations supplémentaires.

Tâche administrative Description Pour obtenir des informations supplémentaires
Gestion de l'application XLANG Scheduler par défaut
  • Modification des paramètres par défaut de l'application XLANG Scheduler.
  • Gestion de l'application et de la base de données XLANG Scheduler par défaut
Gestion des applications COM+
  • Création d'applications COM+ pour exécuter des planifications XLANG.
  • Gestion des autres applications COM+ hébergeant des planifications XLANG

Administration de la programmation

La gestion et l'administration des serveurs et des applications peuvent être programmées dans Microsoft BizTalk Server 2002. Le tableau suivant présente les tâches administratives générales programmées, leur description et indique également où se procurer plus d'informations.

Tâche administrative Description Pour obtenir des informations supplémentaires
Configuration et gestion du gestionnaire du système XLANG Scheduler, des gestionnaires de groupe, des instances de planification XLANG et des ports XLANG
  • Démarrage, arrêt et extraction d'informations sur le gestionnaire du système XLANG Scheduler et les gestionnaires de groupe.

  • Arrêt, interruption, reprise et extraction d'informations sur toutes les planifications associées à un groupe.
  • BizTalk Orchestration Services
Création de composants AIC (Application Integration Component)
  • Création de composants personnalisés.

  • Intégration d'applications métier.

  • Ajout de fonctions de cryptage, de décryptage et de signature numérique.
  • BizTalk Custom Components
Utilisation de documents et d'échanges
  • Accès à la file d'attente interrompue.

  • Lecture de la base de données de suivi.

  • Soumission de documents.

  • Affichage des données d'échange et de document.
  • BizTalk Documents

  • Documents and WMI

  • Displaying the Contents of a Document or an Interchange

  • WMI Tasks
Gestion des services de réception des fichiers
  • Exécution des fonctions de réception de fichiers, telles que la création, la suppression et l'extraction.
  • Receive Services and WMI

  • WMI Tasks
Gestion des files d'attente
  • Extraction des files d'attente par groupe.

  • Extraction de toutes les files d'attente.
  • Queues and WMI

  • WMI Tasks
Gestion des groupes de serveurs
  • Exécution des fonctions liées aux groupes de serveurs, telles que la création, la suppression et l'extraction.
  • Groups and WMI

  • WMI Tasks
Gestion des serveurs
  • Exécution des fonctions liées aux serveurs, telles que la création, la suppression, le démarrage, l'arrêt et l'extraction.
  • Servers and WMI

  • WMI Tasks
Gestion de la base de données Gestion d'échanges BizTalk
  • Création et extraction de la base de données Gestion d'échanges BizTalk.
  • BizTalk Messaging Management Database and WMI

  • WMI Tasks
Gestion des relations avec le partenaire commercial
  • Configuration des ports et des canaux d'échange pour l'échange des données.

  • Création des définitions de documents et des enveloppes.

  • Définition des propriétés de l'organisation
  • BizTalk Messaging Services

Pour plus d'informations sur l'utilisation de WMI (Windows Management Instrumentation) et de la programmation d'applications WMI, accédez au site Web de la bibliothèque MSDN en ligne à l'adresse suivante : msdn.microsoft.com/library/, puis recherchez « WMI Application Programming ».

Gestion de base de données

Outre la maintenance et l'administration régulières des bases de données, telles que la compression des fichiers de données et la sauvegarde de la base de données et des journaux de transactions, vous devez effectuer d'autres tâches relatives aux bases de données, comme la gestion de la connectivité entre BizTalk Server et Microsoft SQL Server, l'ajout, la suppression et la restauration de bases de données et, enfin, la configuration de nouvelles bases de données. Le tableau suivant contient les tâches administratives générales de base de données, leur description et les rubriques contenant des informations supplémentaires.

Tâche administrative Description Pour obtenir des informations supplémentaires
Gestion des bases de données
  • Configuration et/ou modification de la base de données Gestion d'échanges BizTalk.

  • Création et configuration de nouvelles bases de données de persistance.

  • Restauration et/ou suppression manuelle des bases de données de suivi et de files d'attente partagées.
  • Configuration de la base de données Gestion d'échanges BizTalk

  • Modification de la base de données Gestion d'échanges BizTalk d'un serveur

  • Création d'une base de données de persistance vide

  • Gestion des bases de données d'un groupe de serveurs
Surveillance du trafic vers les bases de données
  • Configuration des paramètres du serveur.
  • Description des propriétés d'un serveur

  • Optimisation des propriétés du serveur


Aide de Microsoft BizTalk Server 2002

Cette section comprend des informations relatives au système d'aide de Microsoft® BizTalk™ Server 2002.

Cette section traite des rubriques suivantes :

  • Pour obtenir des informations complètes sur l'aide de BizTalk Server 2002, voir À propos de l'Aide.

  • Pour obtenir des instructions détaillées sur les différentes procédures à exécuter, voir Comment utiliser l'Aide.


À propos de l'Aide

Le système d'aide de Microsoft BizTalk Server 2002 est mis en forme et présenté au format HTML. La Visionneuse de l'aide comporte une table des matières intégrée, un index et une fonction de recherche de texte intégral qui permet de trouver facilement les informations. Des icônes représentant des livres s'ouvrent pour laisser apparaître des sous-livres et des rubriques. Pour développer la table des matières et afficher les rubriques d'un livre, cliquez sur le signe plus (+) figurant en regard d'un titre de livre. Pour masquer les rubriques, cliquez sur le signe moins (-). La Visionneuse vous permet en outre de voir la table des matières, l'index ou les résultats d'une recherche pendant que vous examinez une rubrique d'aide.

La Visionneuse de l'aide contient l'onglet Favoris, grâce auquel vous pouvez identifier des rubriques à l'aide de signets. Ceci vous permet d'afficher rapidement les rubriques que vous consultez souvent.

Pour en savoir plus sur BizTalk Server 2002, vous pouvez utiliser la table des matières pour parcourir la documentation. Lorsque vous cliquez sur une rubrique dans la table des matières, les informations correspondantes sont affichées dans le volet de contenu de la fenêtre d'aide.

La table des matières est organisée en livres d'après les caractéristiques et fonctions principales de BizTalk Server 2002. Chaque livre comprend des chapitres reprenant les informations suivantes :

  • À propos de <caractéristique/fonction/concept associé>. Ces chapitres comportent des descriptions et des informations générales sur BizTalk Server 2002, ses fonctionnalités et les concepts qui lui sont associés.

  • Pourquoi utiliser <caractéristique/nom de fonction>. Ces chapitres contiennent des aide-mémoire expliquant les raisons pour lesquelles vous devez effectuer certaines tâches spécifiques.

  • Comment utiliser <caractéristique/nom de fonction>. Ces chapitres fournissent des informations sur les procédures et les tâches.

  • Dépannage de <caractéristique/nom de fonction>. Ces chapitres fournissent des instructions sur la résolution des problèmes.

Pour obtenir des informations sur la programmation, voir BizTalk Server 2002 Developer Solutions.

Voir aussi

Recherche d'une rubrique d'aide

Touches de raccourci de la Visionneuse de l'aide


Comment utiliser l'Aide

Cette section explique comment rechercher des informations dans le système d'aide de Microsoft BizTalk Server 2002. Vous pouvez, par exemple, effectuer une recherche dans l'aide, puis créer un signet pour la rubrique trouvée en ajoutant cette dernière à la liste de vos rubriques d'aide favorites dans l'onglet Favoris. Vous pouvez aussi copier les informations de l'aide dans un autre document ou les imprimer. Vous pouvez, enfin, modifier la taille de police pour améliorer la lisibilité des informations.

Cette section traite des procédures suivantes :

  • Recherche d'une rubrique d'aide

  • Copie d'une rubrique d'aide

  • Impression d'une rubrique d'aide

  • Modification de la taille de police

  • Touches de raccourci de la Visionneuse de l'aide


Recherche d'une rubrique d'aide

Dans la Visionneuse de l'aide, les onglets suivants permettent d'accéder à différentes options de navigation et de recherche :

  • Onglet Sommaire

  • Onglet Index

  • Onglet Rechercher

  • Onglet Favoris

Onglet Sommaire

Utilisez l'onglet Sommaire pour parcourir l'aide et prendre connaissance des différentes rubriques concernant BizTalk Server 2002.

  1. Pour parcourir la table des matières, cliquez sur l'onglet Sommaire.

  2. Double-cliquez sur les icônes de livre pour faire apparaître les titres de rubrique et les icônes de sous-livre.

  3. Cliquez sur une entrée de la table des matières pour afficher la rubrique correspondante.

Onglet Index

Utilisez l'onglet Index pour effectuer une recherche par sujet et afficher les rubriques correspondantes.

  1. Pour afficher la liste des entrées d'index, cliquez sur l'onglet Index, puis tapez un mot ou parcourez la liste.

    Les rubriques sont souvent indexées sous plusieurs entrées.

  2. Double-cliquez sur une entrée de l'index pour afficher la rubrique correspondante.

    — ou —

    Double-cliquez sur une entrée d'index de premier niveau, comportant des sous-entrées, pour afficher la liste de toutes les rubriques dans lesquelles figure ce mot.

    La boîte de dialogue Rubriques trouvées s'affiche.

    Cliquez sur la rubrique qui vous intéresse, puis cliquez sur Afficher.

Onglet Rechercher

Utilisez l'onglet Rechercher pour lancer une recherche sur toutes les occurrences d'un mot ou d'une expression dans l'aide.

  1. Pour rechercher toutes les occurrences d'un mot ou d'une expression, cliquez sur l'onglet Rechercher, tapez le mot ou l'expression que vous souhaitez rechercher, puis cliquez sur Rechercher.

    Pour affiner la recherche, vous pouvez utiliser les paramètres de recherche présentés dans le tableau suivant.

    Utilisez Pour rechercher Exemple
    AND, OR, NEAR ou NOT Plusieurs mots ou expressions. Cette méthode permet de trouver une combinaison de mots ou d'exclure certains mots. Échanges AND Orchestration

    Remarque

    • Vous pouvez aussi cliquer sur la flèche droite située en regard de la zone Entrez le(s) mots(s) à rechercher pour sélectionner une des options de la liste déroulante.
    Astérisque (*) Tous les mots commençant par les lettres placées avant l'astérisque. Vous trouverez des mots de différentes terminaisons. Admin*

    Specif*
    Guillemets (« ») Une expression ou un terme composé de plusieurs mots. Dans ce cas, vous ne trouverez que la combinaison des mots recherchés. Si, par exemple, vous tapez « Mappeur BizTalk », vous ne trouverez que les occurrences de la combinaison des deux mots et non toutes les occurrences de « Mappeur » et toutes celles de « BizTalk ». « Mappeur BizTalk »

    « fichier plat délimité »

    Toujours dans le but d'affiner la recherche, vous avez la possibilité d'activer les options suivantes, situées dans le bas de l'onglet Rechercher :

    • Rechercher les résultats précédents. Pour effectuer une recherche dans la liste affichée dans le volet de résultats avec les nouveaux paramètres de recherche que vous spécifiez.

    • Respecter les mots similaires. Pour lancer une recherche sur toutes les variantes du mot recherché. Si, par exemple, vous lancez une recherche sur « messagerie », vous obtiendrez également toutes les occurrences de « message ». Cette option est activée par défaut.

    • Rechercher uniquement dans les titres. Pour rechercher uniquement dans les titres des livres, des sous-livres ou des rubriques et non dans la totalité du texte.
  2. Double-cliquez sur une entrée des résultats de la recherche pour afficher la rubrique correspondante.

Remarque

  • Les mots ou expressions recherchés apparaissent en surbrillance dans le texte de la rubrique affichée. Pour désactiver cette fonction, sélectionnez Désactiver la mise en surbrillance dans le menu Options.

Onglet Favoris

Vous pouvez créer la liste de vos rubriques d'aide favorites ou de celles que vous consultez le plus souvent, en leur associant des signets dans l'onglet Favoris.

  1. Pour définir un signet pour une rubrique, utilisez l'onglet Sommaire, Index ou Rechercher pour rechercher, puis afficher une rubrique.

  2. Cliquez sur l'onglet Favoris puis cliquez sur Ajouter pour enregistrer le titre de la rubrique dans la liste Rubriques.

La Visionneuse de l'aide ajoute le titre de la rubrique à la liste Rubriques. Par la suite, vous pourrez retourner à cette liste et double-cliquer sur le signet pour afficher rapidement la rubrique.

Remarque

  • Pour supprimer un signet de la liste Rubriques, sélectionnez-le, puis cliquez sur Supprimer.

Voir aussi

Touches de raccourci de la Visionneuse de l'aide


Copie d'une rubrique d'aide

  1. Dans le volet des rubriques de la Visionneuse de l'aide, cliquez avec le bouton droit sur la rubrique que vous souhaitez copier, puis cliquez sur Sélectionner tout.

  2. Dans la rubrique, cliquez de nouveau avec le bouton droit, puis cliquez sur Copier.

    La rubrique est ainsi copiée dans le Presse-papiers.

  3. Ouvrez le document dans lequel vous souhaitez copier la rubrique.

  4. Dans le document, cliquez à l'endroit où vous souhaitez faire figurer les informations.

  5. Dans le menu Edition, cliquez sur Coller.

Remarques

  • Si vous ne voulez copier que partiellement une rubrique, sélectionnez la partie souhaitée, cliquez avec le bouton droit sur votre sélection, puis cliquez sur Copier.

  • Les numéros des étapes ne sont pas copiés dans le Presse-papiers.

Voir aussi

Recherche d'une rubrique d'aide

Impression d'une rubrique d'aide


Impression d'une rubrique d'aide

  1. Dans l'onglet Sommaire, sélectionnez une rubrique.

  2. Dans la barre d'outils, cliquez sur Imprimer.

    La boîte de dialogue Impression des rubriques s'affiche.

  3. Cliquez sur Imprimer la rubrique sélectionnée pour imprimer une seule rubrique, puis cliquez sur OK.

    -ou-

    Cliquez sur Imprimer le titre sélectionné et toutes les sous-rubriques pour imprimer toutes les rubriques d'un livre, puis cliquez sur OK.

    La boîte de dialogue Imprimer s'affiche.

  4. Cliquez sur Imprimer.

Important

  • Il est préférable de sélectionner l'orientation de page Paysage plutôt que Portrait ; sinon, les exemples de code, les grandes illustrations et le texte significatif risquent de ne pas être intégralement imprimés. Pour sélectionner Paysage, dans la boîte de dialogue Imprimer, cliquez sur l'onglet Disposition, puis cliquez sur Paysage dans la zone Orientation.

Voir aussi

Recherche d'une rubrique d'aide

Touches de raccourci de la Visionneuse de l'aide


Modification de la taille de police

You can increase the font size of text for easier viewing, or you can decrease the font size to see a representation of the layout of a page.Vous pouvez augmenter la taille de police du texte pour améliorer la lisibilité de l'affichage ou la diminuer pour disposer d'une représentation de la structure d'une page.

  • Dans la barre d'outils, cliquez sur le bouton Police ( Bouton Police) pour augmenter ou diminuer la taille du texte.

Lorsque vous fermez le fichier d'aide, les modifications apportées à la taille de police sont conservées de sorte que lorsque vous rouvrez ce fichier, il s'affiche dans la même taille de police.


Touches de raccourci de la Visionneuse de l'aide

Les touches de raccourci permettent d'effectuer un certain nombre de tâches dans la Visionneuse de l'aide de BizTalk Server 2002. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les touches souris dans l'aide de Microsoft® Windows® 2000 Server, voir « Utilisation du clavier pour déplacer le pointeur de la souris ». Dans l'aide de Windows 2000 Professionnel, consultez « Pour déplacer le pointeur de la souris en utilisant les touches souris ».

Touches de raccourci de la Visionneuse de l'aide

Appuyez sur | Pour
ALT+ESPACE | Afficher le menu Système.
MAJ+F10 Afficher le menu contextuel de la Visionneuse de l'aide.

Remarque

  • Utilisez ce raccourci lorsque le volet des rubriques est actif.
ALT+TAB | Passer de la Visionneuse de l'aide à d'autres fenêtres ouvertes.
ALT+O | Afficher le menu Options.
ALT+O, puis appuyer sur L | Masquer ou afficher le volet de navigation.
CTRL+TAB | Passer à l'onglet suivant dans le volet de navigation.
CTRL+MAJ+TAB | Passer à l'onglet précédent dans le volet de navigation.
FLÈCHE HAUT | Remonter d'une rubrique dans la table des matières, l'index ou la liste des résultats de la recherche.
FLÈCHE BAS | Descendre d'une rubrique dans la table des matières, l'index ou la liste des résultats de la recherche.
PAGE PRÉC | Remonter d'une page dans la table des matières, l'index ou la liste des résultats de la recherche.
PAGE SUIV | Descendre d'une page dans la table des matières, l'index ou la liste des résultats de la recherche.
F6 | Activer alternativement le volet de navigation et le volet des rubriques.
ALT+O, puis appuyer sur U | Actualiser la rubrique affichée dans le volet des rubriques.
FLÈCHE HAUT ou FLÈCHE BAS | Parcourir une rubrique.
CTRL+ORIGINE | Atteindre le début d'une rubrique.
CTRL+FIN | Atteindre la fin d'une rubrique.
CTRL+A | Mettre en surbrillance l'intégralité du texte affiché dans le volet des rubriques.
ALT+O, puis appuyer sur I | Imprimer une rubrique.
ALT+O, puis appuyer sur P | Retourner à la rubrique affichée précédemment.
ALT+O, puis appuyer sur S | Passer à la rubrique suivante (parmi les rubriques affichées précédemment).
TAB Se déplacer entre des rubriques apparentées

Remarque

  • Utilisez ce raccourci lorsque le volet des rubriques est actif.
ALT+F4 | Fermer la Visionneuse de l'aide.

Touches de raccourci de l'onglet Sommaire

Appuyez sur | Pour
ALT+S | Afficher l'onglet Sommaire.
FLÈCHE DROITE | Ouvrir un livre.
FLÈCHE GAUCHE | Fermer un livre.
RET.ARR | Retourner au livre ouvert précédemment.
FLÈCHE HAUT ou FLÈCHE BAS | Sélectionner une rubrique.
ALT+FLÈCHE GAUCHE | Retourner à la rubrique affichée précédemment.
ALT+FLÈCHE DROITE | Passer à la rubrique suivante (parmi les rubriques affichées précédemment).
ENTRÉE | Afficher la rubrique sélectionnée.

Touches de raccourci de l'onglet Index

Appuyez sur | Pour
ALT+I | Afficher l'onglet Index.
FLÈCHE HAUT ou FLÈCHE BAS | Sélectionner un mot clé dans la liste.
ALT+C ou ENTRÉE | Afficher la rubrique associée.

Touches de raccourci de l'onglet Rechercher

Appuyez sur | Pour
ALT+R | Afficher l'onglet Rechercher.
ALT+H | Lancer une recherche.
ALT+C ou ENTRÉE | Afficher la rubrique sélectionnée.

Touches de raccourci de l'onglet Favoris

Appuyez sur | Pour
ALT+V | Afficher l'onglet Favoris.
ALT+U | Ajouter une rubrique à la liste Rubriques.
ALT+Q Sélectionner une rubrique dans la liste Rubriques.

Remarque

  • Utilisez ce raccourci lorsque le volet des rubriques est actif et que vous souhaitez accéder à la liste Rubriques.
ALT+M | Supprimer une rubrique de la liste Rubriques.
ALT+C | Afficher une rubrique de la liste Rubriques.

Voir aussi

À propos de l'Aide


Accessibilité pour les personnes atteintes de handicaps

Microsoft s'engage à rendre ses produits plus faciles d'emploi pour tous. Pour plus d'informations sur les fonctionnalités améliorant Microsoft® BizTalk™ Server 2002, voir :

  • Touches de raccourci de la Visionneuse de l'aide

  • Touches de raccourci de la console Administration de BizTalk Server

  • Touche de raccourci de Suivi de documents BizTalk

  • Touches de raccourci du Concepteur d'Orchestration BizTalk

  • Touches de raccourci du Gestionnaire d'échanges BizTalk

  • Touches de raccourci de l'Éditeur BizTalk

  • Touches de raccourci du Mappeur BizTalk

Remarques

  • Pour plus d'informations sur les options d'accessibilité, dans l'aide de Microsoft Windows® 2000 Server, dans le livre Démarrer Windows 2000, voir Accessibilité pour les personnes atteintes de handicaps. Dans l'aide de Windows 2000 Professionnel, voir le chapitre Accessibilité pour des besoins particuliers.

  • Pour obtenir des informations sur les options d'accessibilité dans tous les produits Microsoft, accédez au site Web de Microsoft relatif à l'accessibilité (http://www.microsoft.com/france/accessibilite/).


Contact du support technique Microsoft

Nom du produit : Microsoft® BizTalk™ Server 2002

Options du support technique : Pour obtenir les informations les plus récentes sur les options de support technique disponibles, accédez au site Web du service de Support en ligne des produits Microsoft à l'adresse suivante : http://www.microsoft.com/france/support/default.asp.

  • Support international : Les options, les heures d'ouverture du service et le coût du service dans votre pays peuvent être différents de ceux des États-Unis ; renseignez-vous auprès de la filiale Microsoft qui dessert votre pays.

  • Conditions : Les services de Support Technique de Microsoft sont offerts selon les conditions tarifaires et contractuelles en vigueur et peuvent faire l'objet de modifications sans préavis.


Apprendre à utiliser BizTalk Server 2002

Cette section contient trois scénarios complets pour vous apprendre à utiliser et à mieux comprendre les outils et les services de Microsoft® BizTalk™ Server 2002 :

  • Le Didacticiel de BizTalk Server 2002 vous guide tout au long des procédures de configuration d'un processus d'approvisionnement professionnel, complet et automatisé. Le but de ce guide est de vous apprendre à utiliser le Mappeur BizTalk, l'Éditeur BizTalk, le Concepteur d'orchestration BizTalk, le Gestionnaire d'échanges BizTalk et l'Administration de BizTalk Server.

  • Les Leçons sur BizTalk Server 2002 sont une présentation générale des concepts fondamentaux qui sous-tendent les processus et les tâches de création d'un processus d'approvisionnement professionnel et automatisé avec BizTalk Server. Cette approche vous permet d'exécuter les scripts qui effectuent l'installation à votre place. Elle vous permet, par l'exploration, de comprendre le fonctionnement des services et des processus.

  • L'exemple d'approvisionnement électronique illustre de bout en bout l'utilisation de certaines nouvelles fonctionnalités de BizTalk Server. Il fournit une présentation de l'Assistant BizTalk SEED, du déploiement de Application Center 2000 et des fonctions de supervision avancées de MOM (Microsoft Operations Manager). Il inclut également une nouvelle corrélation XLANG utilisant les files d'attente communes au lieu des files d'attente par instance.


Didacticiel de BizTalk Server 2002

Approvisionnement automatisé inter-entreprises

Ce didacticiel vous apprend à configurer Microsoft BizTalk Server 2002 pour définir et exécuter un processus d'approvisionnement automatisé inter-entreprises.

Ce didacticiel vous explique également comment les composants et les services de BizTalk Server concourent ensemble à l'intégration de processus professionnels asynchrones de longue durée, à la fois au sein d'une même entreprise ou entre différentes entreprises.

Remarque

  • Le didacticiel BizTalk Server 2002 est également fourni au format Microsoft Word. Pour imprimer le didacticiel, vous devez utiliser la version de Word. Si Word n'est pas installé sur votre ordinateur, vous pouvez afficher le fichier à l'aide de Microsoft WordPad ou de l'afficheur Microsoft Word 97/2000. Le fichier Tutorial.doc se trouve dans \Program Files\Microsoft BizTalk Server\Tutorial\POtoInvoice\Lab, sur le lecteur où est installé BizTalk Server.

Conditions

Pour pouvoir suivre correctement ce didacticiel, vous devez installer BizTalk Server 2002 et tous les composants nécessaires associés. Microsoft Visual Basic® 6.0 est requis pour exécuter certaines procédures de l'annexe. Pour obtenir une liste complète des configurations matérielle et logicielle requises pour BizTalk Server 2002, voir Installation de BizTalk Server 2002.

Scénario

Le scénario utilisé dans ce didacticiel fournit une présentation complète des principaux éléments de BizTalk Server 2002, ainsi que les instructions pas à pas sur l'utilisation des outils et services BizTalk Server.

Dans ce scénario, Northwind Traders (désigné comme étant l'acheteur dans ce didacticiel) utilise BizTalk Server 2002 pour concevoir et implémenter un processus d'approvisionnement automatisé inter-entreprises avec Contoso, Ltd (désigné ici comme étant le vendeur). Lorsqu'une requête d'ordre d'achat est générée par Northwind Traders, elle doit répondre à certains critères avant d'être approuvée. Si la requête d'ordre d'achat est inférieure ou égale à 1000 euros, un ordre d'achat est généré et envoyé à Contoso, Ltd. Dans les autres cas, la requête d'ordre d'achat est abandonnée et le processus se termine. Northwind Traders permet d'automatiser ce processus à l'aide d'une planification XLANG afin de contrôler le flux des messages qui transitent par leur système.

Lorsque la requête d'ordre d'achat est approuvée, le système de l'acheteur utilise les services d'échanges BizTalk pour recevoir, acheminer et transformer l'ordre d'achat au format utilisé par Contoso, Ltd., puis il extrait les données. Le vendeur (Contoso, Ltd.) remplit la commande et envoie en retour une facture à l'acheteur (Northwind Traders). Lorsque l'acheteur reçoit la facture, le paiement est émis et envoyé au vendeur.

Le processus d'approvisionnement est automatisé à l'aides des outils et services BizTalk Server 2002. Les deux systèmes utilisent également une série de composants auxiliaires qui sont associés à BizTalk Server 2002 pour la réalisation de tâches clés en matière de traitement des données.

L'illustration suivante représente l'interaction du système d'approvisionnement automatisé inter-entreprises, mis en œuvre par Northwind Traders et Contoso, Ltd. Les flèches indiquent le flux des données entre les rôles et les entités.

Important

  • Pour les besoins de ce scénario, les systèmes de l'acheteur et du vendeur sont tous deux configurés sur une installation monoposte de BizTalk Server 2002.

L'illustration suivante montre le déplacement des documents à travers les deux systèmes. Vous pouvez également y observer l'interaction entre la planification XLANG, les services d'échanges BizTalk et les composants auxiliaires. Cette illustration constitue une référence utile que nous vous recommandons d'imprimer et de conserver auprès de vous, car elle est mentionnée dans plusieurs procédures des modules de ce didacticiel.

Présentation des systèmes de l'acheteur et du vendeur

Contenu

Module 1 - Modélisation des processus professionnels

Ce module vous apprend comment procéder pour :

  • utiliser le Concepteur d'orchestration BizTalk pour créer un schéma de planification XLANG qui définit et met en œuvre les processus d'approvisionnement de Northwind Traders. Pour plus d'informations, voir Conception des orchestrations BizTalk ;

  • compiler le schéma de planification XLANG en une planification XLANG. Pour plus d'informations, voir Compilation d'un schéma de planification XLANG dans une planification XLANG ;

  • exécuter la planification XLANG afin d'observer le déplacement du message au sein du système de l'acheteur.

Module 2 - Création de spécifications et de mappages

Ce module vous apprend comment procéder pour :

  • utiliser l'Éditeur BizTalk pour créer des spécifications de documents. Pour plus d'informations, voir Création et validation de spécifications ;

  • utiliser le Mappeur BizTalk pour créer des mappages. Pour plus d'informations, voir Création de nouveaux mappages.

Module 3 - Configuration des services d'échanges BizTalk

Ce module vous apprend comment procéder pour :

  • utiliser le Gestionnaires d'échanges BizTalk pour configurer les services d'échanges BizTalk pour Contoso, Ltd. Pour plus d'informations, voir Utilisation du Gestionnaire d'échanges BizTalk ;

  • utiliser l'Administration de BizTalk Server pour créer une fonction de réception de fichier pour Contoso, Ltd . Pour plus d'informations, voir Ajouter une fonction de réception de fichier.

Module 4 - Clôture de la planification XLANG

Ce module vous apprend comment procéder pour :

  • implémenter un port dans le schéma de planification XLANG commencé au module 2, via une implémentation d'échanges BizTalk. Pour plus d'informations sur les différences entre les ports et les ports d'échanges, voir Description des implémentations de ports et Description des ports d'échanges ;

  • terminer le schéma de planification XLANG et le compiler en une planification XLANG ;

  • exécuter la planification pour percevoir le déplacement complet des messages entre les systèmes de l'acheteur et du vendeur.

Raccourcis

  • Grâce aux raccourcis, vous pouvez économiser votre temps et votre énergie en utilisant une planification XLANG, une spécification de document, un mappage ou un script de configuration existants. L'utilisation de raccourcis vous permet de passer aux sections suivantes de ce didacticiel.

  • Pour utiliser les raccourcis, tous les composants du didacticiel doivent être installés sur le lecteur C. Vous ne pouvez pas exécuter le didacticiel sur un autre lecteur.

Passez à Installation préliminaire.


Installation préliminaire

Avant de commencer le didacticiel, vous devez créer les éléments suivants :

  • un dossier contenant quatre sous-dossiers ;

  • deux dossiers de sites Web locaux contenant des fichiers ASP ;

  • deux files d'attente de messages pour le système de l'acheteur.

Passez à Création des dossiers.


Création des dossiers

Cette procédure consiste à créer un dossier contenant quatre sous-dossiers. Deux sous-dossiers (Acheteur et Vendeur) doivent être réservés pour le stockage des messages qui entrent et sortent des systèmes de l'acheteur et du vendeur. Les deux autres dossiers stockeront le contenu des sites Web de l'acheteur et du vendeur.

Pour créer les dossiers :

  1. Dans l'Explorateur Windows, accédez au répertoire racine de votre lecteur C:\.

    Important

    • Vous devez créer les dossiers suivants sur votre lecteur C:\. Le didacticiel ne peut pas être exécuté sur un autre lecteur.

  2. Créez un nouveau dossier à la racine de votre lecteur C:\ et appelez-le TutorialFiles.

  3. Cliquez sur le nouveau dossier TutorialFiles et créez quatre sous-dossiers portant les noms suivants :

    • Buyer

    • Seller

    • SubmitPO

    • InvoiceToQueue

Passez à Copie des fichiers.


Copie des fichiers

Dans cette procédure, vous allez copier un mappage vers le référentiel de BizTalk Server pour une utilisation ultérieure et copier les fichiers ASP vers les dossiers de contenu Web de l'acheteur et du vendeur.

  1. Sur le lecteur où est installé BizTalk Server, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps et copiez le fichier POReqtoPO.xml.

  2. Collez le fichier dans le dossier \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft.

  3. Utilisez le tableau suivant pour copier et coller des fichiers supplémentaires dans les sous-dossiers du dossier TutorialFiles.
    Copier à partir de : Coller dans :
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\SubmitPO\Solution\SubmitNorthwindPO.asp | C:\TutorialFiles\SubmitPO
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\DropInvoicetoMSMQ.asp | C:\TutorialFiles\InvoiceToQueue
    \Program Files\Microsoft BizTalk Server\Tutorial\Components\InvoicetoQueue\Solution\Global.asa | C:\TutorialFiles\InvoiceToQueue

Passez à Création des dossiers de sites Web virtuels.


Création des dossiers de sites Web virtuels

Cette procédure consiste à créer deux répertoires virtuels dans les services IIS (Internet Information Services) et à les faire pointer vers les fichiers ASP. Le premier répertoire simule le site Web du vendeur qui reçoit les ordres d'achat. Le second répertoire simule le site Web de l'acheteur qui reçoit les factures.

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Outils d'administration.

  3. Double-cliquez sur Gestionnaire des services Internet.

    La console Gestion des services Internet (IIS) s'affiche.

  4. Dans l'arborescence de la console, développez <Poste de travail>, puis cliquez sur Site Web par défaut.

  5. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Répertoire virtuel.

    L'Assistant Création de répertoire virtuel s'ouvre.

  6. Sur la page Assistant Création de répertoire virtuel, cliquez sur Suivant.

  7. Sur la page Alias du répertoire virtuel, dans la zone Alias, tapez SubmitPO, puis cliquez sur Suivant.

  8. Sur la page Répertoire de contenu du site Web, cliquez sur Parcourir.

  9. Accédez à C:\TutorialFiles\SubmitPO, cliquez sur OK, puis sur Suivant.

  10. Sur la page Autorisations d'accès, cliquez sur Suivant.

  11. Cliquez sur Terminer pour fermer l'Assistant Création de répertoire virtuel.

  12. Dans l'arborescence de la console Gestion de l'ordinateur, cliquez sur Site Web par défaut.

  13. Pour créer le dossier simulant le site Web de l'acheteur, répétez les étapes 5 à 11 avec les variations suivantes :
    • À l'étape 7, dans la zone Alias, tapez InvoiceToQueue.

    • À l'étape 9, accédez à C:\TutorialFiles\InvoiceToQueue.

    Votre console Gestion de l'ordinateur doit apparaître comme dans l'illustration suivante.

    Console Gestion de l'ordinateur

  14. Fermez la console Gestion de l'ordinateur.

Passez à Création des files d'attente de messages.


Création des files d'attente de messages

Cette procédure consiste à créer deux files d'attente de messages afin de permettre au système de l'acheteur d'envoyer et de recevoir des messages. Northwind Traders utilise une application pour envoyer une requête d'ordre d'achat. La requête d'ordre d'achat est envoyée à la file d'attente ReceivePOReq pour la suite du traitement. Lorsque Contoso, Ltd. envoie une facture par l'intermédiaire d'une page ASP sur le site Web de l'acheteur, la page ASP transmet la facture à la file d'attente ReceiveInvoice pour la suite du traitement.

Remarque

  • Pour que cette procédure puisse être exécutée, Message Queuing doit être installé. Pour obtenir des instructions sur l'installation de Message Queuing, voir Installation de Message Queuing

Pour créer les files d'attente de messages

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Outils d'administration.

  3. Double-cliquez sur Gestion de l'ordinateur.

    La console Gestion de l'ordinateur s'affiche.

  4. Dans la console Gestion de l'ordinateur, développez Services et applications, développez Message Queuing, puis cliquez sur Files d'attente privées.

  5. Dans le menu Action, pointez sur Nouveau, puis cliquez sur File d'attente privée.

    La boîte de dialogue Nom de file d'attente s'affiche.

  6. Dans la zone Nom, tapez ReceivePoReq.

  7. Activez la case à cocher Transactionnel, puis cliquez sur OK.

  8. Pour créer la seconde file d'attente de messages, répétez les étapes 5 à 7 avec la variation suivante :
    • À l'étape 6, dans la zone Nom, tapez ReceiveInvoice.

    Votre console Gestion de l'ordinateur doit apparaître comme dans l'illustration suivante.

    Console Gestion de l'ordinateur

  9. Fermez la console Gestion de l'ordinateur.

Passez à Installation des composants auxiliaires.


Installation des composants auxiliaires

Cette procédure consiste en l'installation des composants auxiliaires suivants :

  • Vous installez sur le système du vendeur un composant AIC (Application Integration Component) qui permet de générer une facture basée sur les données de l'ordre d'achat de l'acheteur.

  • Vous installez sur le système de l'acheteur un composant de script Windows (WSC) qui permet d'implémenter un port vers une planification XLANG, et qui accepte l'état d'approbation ou de refus d'une requête d'ordre d'achat de la planification XLANG.

    Important

    • Si ces composants ont été précédemment installés sur votre ordinateur, vous devez tout d'abord les désinstaller. Pour désinstaller les composants, accédez à Désinstallation des composants auxiliaires.

    Question d'ordre international

  • Le didacticiel de BizTalk Server 2002 ne fonctionne pas avec des données non-ASCII. Si vous devez utiliser des données de type non-ASCII, modifiez le code pour permettre au composant de script (PORequestApproval.wsc) d'utiliser le modèle DOM (Document Object Model) XML pour écrire les données.

Pour installer les composants auxiliaires

  1. Sur le lecteur où est installé BizTalk Server, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Setup.

  2. Double-cliquez sur Install_POtoInvoice.vbs.

    Un message indiquant que le composant a été installé correctement s'affiche.

  3. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution et cliquez sur PORequestApproval.wsc.

  4. Dans le menu Fichier, cliquez sur Inscrire.

    Un message indiquant que le composant a été inscrit correctement s'affiche.

Passez au Module 1 - Modélisation des processus professionnels.


Désinstallation des composants auxiliaires

Attention

  • N'utilisez cette procédure que si vous supprimez une installation précédente des composants.
    1. Pour le composant POtoInvoice, accédez à \Program Files\Microsoft BizTalk Server\Tutorial\Setup sur le lecteur où est installé BizTalk Server.

    2. Double-cliquez sur Remove_POtoInvoice.vbs.

    Un message indiquant que le composant a été correctement désinstallé s'affiche.

    3. Pour le composant de script Windows, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution et cliquez sur PORequestApproval.wsc.

    4. Dans le menu Fichier, cliquez sur Désinscrire.

    Un message indiquant que l'inscription du composant a été correctement supprimée s'affiche.

Pour réinstaller les composants, accédez à Installation des composants auxiliaires.


Module 1 - Modélisation des processus professionnels

Dans ce module, vous utilisez le Concepteur d'orchestration BizTalk pour créer un schéma de planification XLANG qui définit et implémente le processus d'approvisionnement automatisé de Northwind Traders. Vous compilez ensuite le schéma de planification XLANG en une planification XLANG exécutable gérant le flux de messages pour le système de l'acheteur.

Objectifs

  • Créer un schéma de planification XLANG définissant le processus d'approvisionnement automatisé. Pour plus d'informations, voir Création de schémas de planification XLANG.

  • Connecter les actions dans une séquence logique définissant les processus professionnels. Pour plus d'informations, voir Connexion des formes.

  • Implémenter les processus professionnels en connectant des actions aux ports. Pour plus d'informations, voir Établissement du flux de communication entre une action et un port.

  • Ajouter une règle aux processus professionnels en écrivant une expression de script. Pour plus d'informations, voir Conception de règles.

  • Définir le flux de données pour les messages. Pour plus d'informations, voir Formes Communication.

  • Enregistrer le schéma de planification XLANG et le compiler en une planification XLANG. Pour plus d'informations, voir Compilation des planifications XLANG.

  • Exécuter la planification XLANG pour traiter le message dans BizTalk Server. Pour plus d'informations, voir Exécution des planifications XLANG.

Passez à Création de la planification XLANG pour l'acheteur.

Voir aussi

Conception des orchestrations BizTalk


Création de la planification XLANG pour l'acheteur

Dans les procédures suivantes, vous allez définir et mettre en œuvre les processus commerciaux de Northwind Traders (l'acheteur), puis créer et exécuter une planification XLANG.

Pour créer la planification XLANG, passez à Création des actions de l'acheteur.

Raccourci

  • Pour utiliser la planification XLANG existante, passez directement à Exécution de la planification XLANG.


Création des actions de l'acheteur

Vous allez dans un premier temps créer ce processus d'approvisionnement automatisé pour analyser le processus professionnel qui sera utilisé par Northwind Traders, puis vous allez créer un diagramme d'interactions décrivant ce processus. Cette procédure consiste à utiliser le Concepteur d'orchestration BizTalk pour créer une représentation du processus professionnel de Northwind Traders. Les formes Diagramme de flux permettent de définir les actions qui se produisent lorsqu'une requête d'ordre d'achat est reçue et qu'elle est acceptée ou refusée.

Pour plus d'informations sur les formes Diagramme de flux, voir Formes Diagramme de flux. Pour plus d'informations sur les processus professionnels, voir Description des processus professionnels.

Pour créer les actions de l'acheteur

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Concepteur d'Orchestration BizTalk.

  2. Faites glisser la forme Action du stencil Diagramme de flux situé dans la colonne la plus à gauche vers la page Processus professionnels.

    Positionnez la forme directement sous la forme Début.

  3. Cliquez avec le bouton droit sur la forme Action 1, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'action s'affiche.

  4. Dans la zone Nom, tapez Recevoir requête OA, puis cliquez sur OK.

    Attention

    • Pour que ce scénario fonctionne correctement, vous devez respecter exactement la saisie des noms indiquée. Les composants du didacticiel utilisent ces noms.
  5. Faites glisser la forme Décision du stencil Diagramme de flux situé dans la colonne la plus à gauche vers la page Processus professionnels.

    Positionnez cette forme sous l'action Recevoir requête OA.

  6. Cliquez avec le bouton droit sur la forme Décision, puis cliquez sur Ajouter une règle.

    La boîte de dialogue Propriétés de la règle s'affiche.

  7. Dans la zone Nom de règle, tapez Refusé, puis cliquez sur OK.

    La saisie d'informations dans la zone Description de la règle est facultative.

    Laissez la zone Expression de script vide. Plus loin dans ce module, vous ajouterez une expression de script implémentant la règle de décision, après avoir lié la forme Décision au composant de script, qui fournit les noms de message et de champ.

  8. Répétez les étapes 2 à 4 pour créer les trois actions suivantes :

    • Positionnez une seconde forme Action à la droite de la forme Décision. Appelez cette action Envoyer le refus.

    • Positionnez une troisième forme Action en dessous de la forme Décision. Appelez cette action Envoyer l'approbation.

    • Positionnez une quatrième forme Action sous l'action Envoyer l'approbation. Appelez cette action Écrire l'ordre d'achat sur le fichier.

  9. Faites glisser la forme Fin du stencil Diagramme de flux situé dans la colonne la plus à gauche vers la page Processus professionnels.

    Positionnez la forme en dessous de l'action Envoyer refus.

    Si la requête d'ordre d'achat n'est pas accordée, la planification XLANG affiche un message de refus et prend fin.

  10. Faites glisser la forme Fin du stencil Diagramme de flux situé dans la colonne la plus à gauche vers la page Processus professionnels.

    Positionnez la forme en dessous de l'action Écrire requête OA dans fichier.

    Si la requête d'ordre d'achat est accordée, la planification XLANG écrit la requête dans un répertoire de fichiers, affiche un message d'accord et prend fin.

Passez à Connexion des actions de l'acheteur dans une séquence.


Connexion des actions de l'acheteur dans une séquence

Après avoir créé les actions de Northwind Traders, vous devez définir la séquence d'événements en connectant les formes du Diagramme de flux de sorte que le processus professionnel commence à la réception d'une requête d'ordre d'achat et se termine lors de l'acceptation ou du rejet de la requête d'ordre d'achat. Vous devez ensuite enregistrer la représentation sous la forme d'un schéma de planification XLANG comportant l'extension de fichier .skv. Pour plus d'informations, voir Connexion de formes.

Pour connecter les actions de l'acheteur

  1. Cliquez sur la forme Début afin de mettre en évidence les poignées de contrôle.

    Forme Début mise en surbrillance

    Faites glisser la poignée de contrôle inférieure vers le point de connexion supérieur de l'action Recevoir requête OA.

    L'action Recevoir requête OA représente le début du processus professionnel. Lorsqu'une requête d'ordre d'achat est reçue, la planification XLANG démarre.

    Remarques

  2. Une poignée de contrôle est matérialisée par un losange jaune lorsqu'une forme est sélectionnée. Vous pouvez faire glisser les poignées de contrôle pour la connexion à une action.

  3. Un point de connexion est représenté par un X bleu sur une forme.

  4. Les points de connexion situés sur le côté d'une forme Action ne sont utilisés que pour la connexion aux ports. Ils ne servent pas pour la connexion aux autres formes Action.

  5. Répétez l'étape 1 pour créer une connexion à l'action suivante :

  6. Connectez l'action Recevoir Action OA à la forme Décision.

  7. Sélectionnez la règle Refusé dans la forme Décision et faites glisser la poignée de contrôle de droite de la règle Refusé vers le point de connexion supérieur de l'action Envoyer refus.

  8. Sélectionnez la règle Sinon de la forme Décision et faites glisser la poignée de contrôle de gauche de la règle Sinon vers le point de connexion supérieur de l'action Envoyer accord.

    Remarque

  9. Vous pouvez connecter les règles de la forme Décision aux actions Envoyer accord et Envoyer refus à partir de la poignée de contrôle de droite ou de gauche.

  10. Connectez l'action Envoyer accord à l'action Écrire requête OA dans fichier.

  11. Connectez l'action Écrire requête OA dans fichier à la forme Fin située en dessous.

  12. Connectez l'action Envoyer refus à la forme Fin située en dessous.

  13. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer un schéma de planification XLANG sous s'affiche.

    Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

  14. Dans la zone Nom de fichier, tapez Acheteur1 et cliquez sur Enregistrer.

Le schéma de planification XLANG que vous avez créé et enregistré doit apparaître comme dans l'illustration suivante.

Schéma de planification XLANG

Passez à Implémentation d'un port à l'aide de Message Queuing pour recevoir une requête d'ordre d'achat.


Implémentation d'un port à l'aide Message Queuing pour recevoir une requête d'ordre d'achat

Lors de l'installation préliminaire de ce didacticiel, vous avez créé la file d'attente ReceivePOReq. Cette procédure consiste à ajouter la forme Messaging Queuing au schéma XLANG et à implémenter un port pour la file d'attente de messages ReceivePOReq.

La forme Message Queuing représente le service Message Queuing qui est utilisé pour envoyer ou recevoir des messages. Le service est configuré pour contrôler la file d'attente de messages ReceivePOReq d'une requête d'ordre d'achat. Une fois la requête d'ordre d'achat insérée dans la file d'attente, la planification XLANG commence le traitement. Pour plus d'informations, voir Utilisation de la forme Message Queuing.

Pour plus d'informations sur l'utilisation des ports et des ports d'échanges, voir Intégration des services BizTalk.

Pour implémenter le port

  1. Faites glisser la forme Message Queuing du stencil Implémentation situé dans la colonne la plus à droite vers la page Processus professionnels.

    Positionnez la forme Message Queuing de sorte qu'elle soit alignée horizontalement par rapport à l'action Recevoir requêtes OA.

    L'Assistant Liaison de Message Queuing s'ouvre.

  2. Sur la première page de l'Assistant Liaison de Message Queuing, vérifiez que Créer un port est sélectionné.

  3. Dans la zone Créer un port, tapez RecevoirRequêteOA et cliquez sur Suivant.

  4. Sur la page Informations sur la file d'attente statique ou dynamique, vérifiez que File d'attente statique est sélectionné, puis cliquez sur Suivant.

  5. Sur la page Informations sur la file d'attente, cliquez sur Utiliser une file d'attente connue pour toutes les instances.

  6. Dans la zone Entrez le nom de la file d'attente, tapez .\private$\RecevoirReqOA et cliquez sur Suivant.

  7. Sur la page Propriétés avancées du port, cliquez sur Terminer.

    Le port RecevoirRequêteOA et l'implémentation Message Queuing associée apparaissent sur la page Processus professionnels.

Remarque

  • Une file d'attente statique est utilisée à la place d'une file d'attente dynamique, car nous connaissons l'emplacement de livraison de la requête d'ordre d'achat et nous avons déjà créé une file d'attente spécifique à cet effet.

Passez à Création du flux de communication pour l'action Recevoir requête OA.


Création du flux de communication pour l'action Recevoir requête OA

Cette procédure consiste à utiliser l'Assistant Communication XML pour faciliter la communication entre l'action Recevoir requête OA de la forme Action et le port RecevoirRequêteOA. Grâce à l'Assistant Communication XML, vous fournissez les informations et les spécifications utilisées par le moteur de XLANG Scheduler pour identifier et récupérer le message correct dans la file d'attente. Vous ajoutez également le champ de message POTtl qui permet d'activer le routage sensible aux données.

  1. Sélectionnez l'action Recevoir requête OA et faites glisser la poignée de contrôle située à sa droite vers le point de connexion de gauche du port RecevoirRequêteOA.

    L'Assistant Communication XML s'ouvre.

  2. Sur la page Assistant Communication XML, cliquez sur Recevoir, puis sur Suivant.

  3. Sur la page Informations sur le message, vérifiez que l'option Créer un message est sélectionnée.

  4. Dans la zone Nom du message, tapez ReqOA et cliquez sur Suivant.

  5. Sur la page Informations sur l'interprétation XML, vérifiez que Recevoir les messages XML de la file d'attente est sélectionné et cliquez sur Suivant.

  6. Sur la page Informations sur les types de message, dans la zone Type du message, tapez ReqOA et cliquez sur Suivant.

  7. Sur la page Informations sur la spécification du message, cliquez sur Parcourir.

    La boîte de dialogue Rechercher une spécification apparaît.

  8. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps sur le lecteur où est installé BizTalk Server.

  9. Cliquez sur PoReq.xml, puis sur Ouvrir.

  10. Cliquez sur Ajouter.

    La boîte de dialogue Sélection d'un champ apparaît.

  11. Dans la zone Sélectionner un nœud, développez Total, cliquez sur POTtl, puis sur OK.

    Dans la zone Champs de message, POTtl doit figurer dans la liste des champs de message.

  12. Cliquez sur Terminer.

Après avoir implémenté le port et créé le flux de communication, le schéma de planification XLANG doit apparaître comme dans l'illustration suivante.

Schéma de planification XLANG

Passez à Implémentation d'un port à l'aide d'un composant de script.


Implémentation d'un port à l'aide d'un composant de script

Dans cette procédure, vous allez utiliser le composant de script Windows (WSC), PORequestApproval.wsc, que vous avez installé et enregistré lors de l'installation préliminaire de ce didacticiel. Ce composant de script permet d'exécuter certaines actions dans la planification XLANG. Cette procédure consiste à implémenter le port ComposantApprobation afin que les actions d'approbation et de refus puissent être connectées au port et liées au composant de script. Pour plus d'informations, voir Utilisation de la forme Composant de script.

Le composant de script permet d'exécuter les actions suivantes dans la planification XLANG.

Si le total de la requête d'ordre d'achat est supérieur à 1000 EUR :

  • la forme Décision envoie un message de refus au port ;

  • le composant de script affiche un message qui informe l'utilisateur du refus ;

  • la planification XLANG prend fin.

Si le total de la requête d'ordre d'achat est inférieur ou égal à 1000 EUR :

  • la forme Décision envoie un message d'acceptation au port ;

  • le composant de script affiche un message qui informe l'utilisateur de l'accord ;

  • le composant de script écrit le message de la requête d'ordre d'achat dans un répertoire de fichiers local ;

  • la planification XLANG prend fin.

Pour implémenter le port

  1. Faites glisser la forme Composant de script du stencil Diagramme de flux situé dans la colonne la plus à droite vers la page Processus professionnels.

    Positionnez la forme de sorte qu'elle soit alignée horizontalement par rapport à la forme Décision.

    L'Assistant Liaison des composants de script s'ouvre.

  2. Sur la page Assistant Liaison de composants de script, dans la zone Créer un port, tapez ComposantApprobation et cliquez sur Suivant.

  3. Sur la page Communication statique ou dynamique, vérifiez que Statique est sélectionné et cliquez sur Suivant.

  4. Sur la page Sélectionnez le fichier de script, cliquez sur Parcourir.

  5. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Solution sur le lecteur où est installé BizTalk Server.

  6. Cliquez sur PORequestApproval.wsc, sur Ouvrir, puis sur Suivant.

  7. Sur la page Informations sur l'instanciation du composant, vérifiez que Utiliser Prog ID "BTSTutorial.PORequestApproval" est sélectionné et cliquez sur Suivant.

  8. Sur la page Informations sur la méthode, cliquez sur Sélectionner Tout, puis sur Suivant.

  9. Sur la page Propriétés avancées du port, cliquez sur Terminer.

Passez à Définition des propriétés de message pour le composant de script.


Définition des propriétés de message pour le composant de script

Cette procédure consiste à utiliser l'Assistant Communication de méthodes pour définir le flux des messages depuis les formes Action jusqu'au composant de script. Pour obtenir une description détaillée de chaque étape du processus, voir Envoi et réception de messages synchrones.

  1. Sélectionnez l'action Envoyer refus et faites glisser la poignée de contrôle située à droite vers le port Composant de script Windows ComposantApprobation.

    L'Assistant Communication de méthodes s'ouvre.

  2. Sur la page Assistant Communication de méthodes, vérifiez que l'option Lancer un appel de méthode synchrone est sélectionnée, puis cliquez sur Suivant.

  3. Sur la page Informations sur le message, vérifiez que Créer un message est sélectionné, puis cliquez sur Suivant.

  4. Sur la page Informations sur la spécification du message, dans la liste Méthodes, cliquez sur Envoyer refus et cliquez sur Terminer.

  5. Sélectionnez l'action Envoyer accord et faites glisser la poignée de contrôle située à droite de cette dernière vers le port ComposantApprobation.

    L'Assistant Communication de méthodes s'ouvre.

  6. Sur la page Assistant Communication de méthodes, vérifiez que l'option Lancer un appel de méthode synchrone est sélectionnée, puis cliquez sur Suivant.

  7. Sur la page Informations sur le message, vérifiez que Créer un message est sélectionné, puis cliquez sur Suivant.

  8. Sur la page Informations sur la spécification du message, dans la liste Méthodes, cliquez sur SendApproval, puis sur Terminer.

  9. Sélectionnez l'action Écrire requête OA dans fichier et faites glisser la poignée de contrôle située à droite de l'action Écrire requête OA dans fichier vers le port ComposantApprobation.

    L'Assistant Communication de méthodes s'ouvre.

  10. Sur la page Assistant Communication de méthodes, vérifiez que l'option Lancer un appel de méthode synchrone est sélectionnée, puis cliquez sur Suivant.

  11. Sur la page Informations sur le message, vérifiez que Créer un message est sélectionné, puis cliquez sur Suivant.

  12. Sur la page Informations sur la spécification du message, dans la zone Méthodes, vérifiez que WriteToFile est sélectionné et cliquez sur Terminer.

Passez à Écriture d'une expression de script pour la règle de décision.


Écriture d'une expression de script pour la règle de décision

Selon les règles commerciales de Northwind Traders, une requête d'ordre d'achat est refusée si elle est supérieure à 1 000 EUR. Le message doit être routé conformément à cette règle. La planification XLANG transmet la valeur du champ total POTtl de la requête d'ordre d'achat à la forme Décision. L'expression de script de la règle de décision dévie le chemin de la planification et envoie le message approprié à l'implémentation de port qui utilise le composant de script Windows (WSC). La règle de décision du refus contient l'expression de script qui définit le comportement de la forme Décision. L'expression de script prend la valeur TRUE ou FALSE. Elle définit également la logique et les noms de variable utilisés par la forme Décision.

Pour écrire l'expression de script

  1. Cliquez sur l'onglet Données situé en bas de la page.

    La page Données apparaît.

  2. Affichez le message ReqOA pour trouver le nom de champ.

    Pour écrire l'expression de script, il faut indiquer le nom du message et le nom du champ. Dans ce cas, le nom du message est ReqOA et celui du champ est POTtl.

  3. Cliquez sur l'onglet Processus professionnel situé en bas de la page.

    La page Processus professionnels apparaît.

  4. Cliquez avec le bouton droit sur la forme Décision et cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la décision apparaît.

  5. Vérifiez que Refusé est sélectionné et cliquez sur Modifier.

    La boîte de dialogue Propriétés de la règle s'affiche.

  6. Dans la zone Expression de script, tapez ReqOA.POTtl > 1000.

    Cela signifie que si le champ total de la requête d'ordre d'achat est supérieur à 1000 EUR, la requête est refusée.

  7. Cliquez sur OK pour fermer la boîte de dialogue Propriétés de la règle, puis de nouveau sur OK pour fermer la boîte de dialogue Propriétés de la décision.

Le schéma de planification XLANG doit apparaître comme dans l'illustration suivante.

Schéma de planification XLANG

Passez à Définition du flux de données.


Définition du flux de données

Pour définir le flux de données dans le processus professionnel, vous créez des connexions entre les champs des formes Message de la page Données. Les connexions indiquent que les données du champ de document de ReqOA seront transmises aux champs de document des messages SendDenial, SendApproval et WriteToFile. Le flux des données entre les messages doit être défini avant de pouvoir compiler la planification XLANG. Pour plus d'informations sur la page de données, voir Page Données.

Pour définir le flux de données

  1. Cliquez sur l'onglet Données situé en bas de la page.

    La page Données apparaît.

  2. Dans le message ReqOA, cliquez sur le champ Document et faites glisser la poignée de contrôle située à droite vers un point de connexion du champ Document du message SendDenial_in.

  3. Répétez l'étape 2 en cliquant sur le champ Document et en faisant glisser la poignée de contrôle sélectionnée à droite de la zone ReqOA vers un point de connexion des champs suivants :
    • le champ Document de la zone SendApproval_in.

    • le champ Document de la zone WriteToFile_in.

Remarque

  • Cliquez sur le champ Document du message ReqOA avant de faire glisser la poignée de contrôle vers les autres champs.

Une fois complétée, la page Données doit apparaître comme dans l'illustration suivante.

Passez à Enregistrement du schéma de planification XLANG.


Enregistrement du schéma de planification XLANG

  • Dans le menu Fichier, cliquez sur Enregistrer Acheteur1.skv.

Passez à Compilation de la planification XLANG.


Compilation de la planification XLANG

Cette procédure consiste à compiler le schéma de planification XLANG dans une planification XLANG qui est activée à la réception de la requête d'ordre d'achat. Lorsque vous compilez un schéma de planification XLANG, tous les problèmes du schéma sont identifiés. Pour plus d'informations, voir Compilation des planifications XLANG.

  1. Dans le menu Fichier, cliquez sur Créer XLANG Acheteur1.skx.

    La boîte de dialogue Enregistrer la planification XLANG vers apparaît.

  2. Vérifiez que la planification XLANG a été enregistrée dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server et cliquez sur Enregistrer.

  3. Dans le menu Fichier, cliquez sur Quitter pour fermer le Concepteur d'Orchestration BizTalk.

Passez à Exécution de la planification XLANG.


Exécution de la planification XLANG

Cette procédure consiste à exécuter une application qui dépose une requête d'ordre d'achat dans la file d'attente ReceivePOReq et active la planification XLANG.. Exécutez l'application deux fois pour afficher le processus professionnel créé dans le module 1. La première approbation de la requête d'ordre d'achat génère l'envoi d'un message et cette dernière est écrite dans un fichier. Lorsque l'application est exécutée pour la deuxième fois, l'ordre d'achat est refusé, un message est envoyé et le processus s'arrête.

Pour exécuter la planification XLANG

  1. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server.

  2. Double-cliquez sur ExecuteTutorial.exe.

    Cette application permet d'activer la planification XLANG à l'aide d'un moniker.

    L'application ExecuteTutorial s'ouvre.

  3. Cliquez sur Browse for Schedule.

    Raccourci

    • Si un serveur BizTalk Server et tous ses composants sont installés sur le lecteur C, vous pouvez utiliser la planification XLANG existante. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution et passez à l'étape 5.

  4. Si vous avez créé la planification XLANG Acheteur1, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

  5. Cliquez sur le fichier XLANG des planifications Acheteur1.skx, puis sur Ouvrir.

  6. Cliquez sur Browse for Data File et accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData.

  7. Cliquez sur POReqAccept.xml, puis cliquez sur Ouvrir.

  8. Cliquez sur Start XLANG Schedule.

    Dans la mesure où le total est inférieur à 1000 EUR, la requête d'ordre d'achat est approuvée. Un message s'affiche pour indiquer que l'application a transmis les données au moteur XLANG Scheduler. À ce stade, l'application est terminée. Un second message vous informe que la requête d'ordre d'achat a été approuvée. Cliquez sur OK pour fermer les messages.

  9. Cliquez sur End pour fermer l'application ExecuteTutorial.

    Important

    • Si vous rencontrez une erreur d'automatisation lors de l'exécution de l'application, assurez-vous que vous avez correctement configuré la file d'attente privée et que son nom est correct.
  10. Accédez au dossier C:\TutorialFiles\Buyer.

    Le nom de fichier est POReqXXXXX.xml, où XXXXX représente un ensemble unique de nombres. Double-cliquez sur le fichier pour l'ouvrir dans Microsoft Internet Explorer. Il s'agit d'une copie du fichier de la requête d'ordre d'achat que l'application a placé dans la file d'attente de messages. Après avoir affiché ce fichier, supprimez-le.

  11. Répétez les étapes 1 à 5 pour réexécuter l'application ExecuteTutorial.

  12. Cliquez sur Browse for Data File et accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData.

  13. Cliquez sur POReqDeny.xml, puis sur Ouvrir.

  14. Cliquez sur Start XLANG Schedule.

    Étant donné que son total dépasse 1000 EUR, la requête d'ordre d'achat est refusée. Un message s'affiche pour indiquer que l'application est terminée. Un second message indique que le refus du document a été reçu. Cliquez sur OK pour fermer les messages.

  15. Cliquez sur End pour fermer l'application ExecuteTutorial.

Le schéma ci-dessous illustre le flux de données lors de l'exécution de la planification XLANG.

Flux de données

Passez à Module 1 - Résumé.


Module 1 - Résumé

Ce module vous a appris comment procéder pour :

  • Créer le schéma de planification XLANG qui décrivait le processus d'approvisionnement automatisé. Pour plus d'informations, voir Création de schémas de planification XLANG.

  • Connecter les actions dans une séquence logique qui décrivait le processus professionnel. Pour plus d'informations, voir Connexion des formes.

  • Implémenter le processus professionnel en connectant des actions aux ports. Pour plus d'informations, voir Établissement du flux de communication entre une action et un port.

  • Ajouter une règle au processus professionnel en écrivant une expression de script. Pour plus d'informations, voir Conception de règles.

  • Définir le flux de données des messages. Pour plus d'informations, voir Formes Communication.

  • Enregistrer le schéma de planification XLANG et le compiler en planification XLANG. Pour plus d'informations, voir Compilation des planifications XLANG.

  • Exécuter la planification XLANG à deux reprises pour traiter la requête d'ordre d'achat par l'intermédiaire de BizTalk Server, en observant les actions d'approbation et de refus. Pour plus d'informations, voir Exécution des planifications XLANG.

Les zones mises en surbrillance dans la figure suivante illustrent les procédures que vous avez effectuées dans ce module.

Passez au Module 2 - Création de spécifications et de mappages.

Voir aussi

Conception des orchestrations BizTalk


Module 2 - Création de spécifications et de mappages

Après avoir conçu le processus professionnel et compris le fonctionnement du flux de communication dans ce modèle, vous devez définir la structure des documents professionnels envoyés et reçus. La structure des documents professionnels est définie dans les schémas XML, également appelés spécifications. Ce module utilise l'Éditeur BizTalk pour créer les spécifications de paiement et d'ordre d'achat pour l'acheteur, Northwind Traders.

Contoso, Ltd utilise un schéma commun pour la facture qu'elle envoie à Northwind Traders. Lorsque Northwind Traders reçoit la facture, les spécifications doivent être converties en spécifications de paiement. Vous utilisez le Mappeur BizTalk pour créer un mappage entre les enregistrements et les champs de spécifications de paiement que vous créez pour Northwind Traders et les spécifications CommonInvoice utilisées par Contoso, Ltd.

Objectifs

  • Créer une spécification. Pour plus d'informations, voir Utilisation de l'Éditeur BizTalk.

  • Ajouter de nouveaux enregistrements et champs à une spécification. Pour plus d'informations, voir Ajout de nouveaux champs aux enregistrements.

  • Créer un mappage. Pour plus d'informations, voir Utilisation de Mappeur BizTalk.

  • Créer des liens entre les champs d'un mappage. Pour plus d'informations, voir Création de liaisons.

  • Utiliser des fonctoids pour effectuer des manipulations mathématiques de valeurs dans un mappage. Pour plus d'informations, voir Présentation des fonctoids.

  • Enregistrer les spécifications et les mappages dans le référentiel WebDAV (Web Distributed Authoring and Versioning). Pour plus d'informations, voir Stockage de spécifications et Stockage de mappages.

Passez à Utilisation de l'Éditeur BizTalk.

Voir aussi

Création de spécifications et mappage de données


Utilisation de l'Éditeur BizTalk

Vous pouvez utiliser l'Éditeur BizTalk pour créer, modifier et gérer des spécifications.

Pour créer la spécification de paiement à l'aide de l'Éditeur BizTalk, passez à Création de la spécification de paiement.

Raccourci

  • Pour utiliser la spécification de paiement existante, passez directement à Utilisation de la spécification de paiement existante.


Utilisation de la spécification de paiement existante

  1. Copiez le fichier PaymentSpec.xml du dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps sur le lecteur où est installé BizTalk Server.

  2. Insérez ce fichier dans le dossier \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

Pour créer la spécification de la requête d'ordre d'achat à l'aide de l'Éditeur BizTalk, passez à Création de la spécification de la requête d'ordre d'achat.

Raccourci

  • Si un serveur BizTalk Server et tous ses composants sont installés sur le lecteur C, vous pouvez utiliser la spécification de la requête d'ordre d'achat existante. Passez à Utilisation de la spécification de la requête d'ordre d'achat existante.


Création de la spécification de paiement

Cette procédure consiste à créer un schéma XML ou des spécifications de paiement qui définissent la structure et les données utilisées par Northwind Traders pour l'envoi d'un paiement à Contoso, Ltd. Pour plus d'informations sur les spécifications, voir Définition des spécifications.

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2002, et cliquez sur Éditeur BizTalk.

  2. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Nouvelle spécification de document apparaît.

  3. Cliquez sur l'icône Spécification vide, puis cliquez sur OK.

  4. Dans le nœud racine, cliquez sur Spécification vide.

  5. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Nom, tapez Payment et appuyez sur ENTRÉE.

  6. Double-cliquez sur le champ Valeur de la ligne Modèle, cliquez sur Ouvrir et appuyez sur ENTRÉE.

Passez à Ajout de nouveaux enregistrements au nœud racine Payment de la spécification de paiement.


Ajout de nouveaux enregistrements au nœud racine Payment de la spécification de paiement

  1. Cliquez avec le bouton droit sur le nœud racine Payment et cliquez sur Nouvel enregistrement.

  2. Appelez cet enregistrement PaymentHeader et appuyez sur ENTRÉE.

  3. Suivez les étapes 1 et 2 pour créer et dénommer quatre enregistrements supplémentaires sous le nœud racine Payment.

    Il s'agit des enfants du nœud racine Payment. Appelez-les comme suit :

    • Seller

    • Buyer

    • Item

    • PaymentSummary

Passez à Ajout de nouveaux enregistrements aux enregistrements existants de la spécification de paiement.


Ajout de nouveaux enregistrements aux enregistrements existants de la spécification de paiement

  1. Cliquez avec le bouton droit sur l'enregistrement Seller et cliquez sur Nouvel enregistrement.

  2. Appelez cet enregistrement Address, puis appuyez sur ENTRÉE.

  3. Suivez les étapes 1 et 2 pour créer les enregistrements enfants des enregistrements parents répertoriés dans le tableau ci-dessous.
    Enregistrement parent | Nom des enregistrements enfants
    Seller | ContactInfo
    Buyer | Address
    Buyer | ContactInfo

Passez à Ajout de nouveaux champs aux enregistrements existants de la spécification de paiement.


Ajout de nouveaux champs aux enregistrements existants de la spécification de paiement

  1. Cliquez avec le bouton droit sur l'enregistrement PaymentHeader et cliquez sur Nouveau champ.

  2. Appelez ce champ PONumber et appuyez sur ENTRÉE.

  3. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Type de données, cliquez sur String et appuyez sur ENTRÉE.

  4. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Longueur minimale, tapez 1 et appuyez sur ENTRÉE.

  5. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Longueur maximale, tapez 22 et appuyez sur ENTRÉE.

  6. Suivez les étapes 1 à 5 pour créer des champs pour les enregistrements ou les enregistrements enfants répertoriés dans le tableau ci-dessous.

    Chaque enregistrement contient plusieurs champs.

    Il n'est pas nécessaire de créer des champs pour l'acheteur car il existe des noms d'enregistrement parallèles pour l'acheteur et le vendeur. Tous les enregistrements possédant le même nom contiennent les mêmes informations de champs et d'enregistrements. Si vous ajoutez des champs à l'enregistrement Seller/Address ou Seller/ContactInfo, l'enregistrement Buyer/Address ou Buyer/ContactInfo est automatiquement mis à jour avec les mêmes champs.

    Enregistrement parent | Nom du champ | Type de données | Longueur minimale | Longueur maximale
    PaymentHeader | Date | Date | Non applicable | Non applicable
    Seller/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Seller/ContactInfo | Name | String | 1 | 60
    Number | String | 1 | 60
    Item | Quantity | Real(r4) | Non applicable | Non applicable
    Price | Real(r4) | Non applicable | Non applicable
    Description | String | 1 | 80
    ExtendedPrice | Real(r4) | Non applicable | Non applicable
    PaymentSummary | Total | Real(r4) | Non applicable | Non applicable

Passez à Enregistrement de la spécification de paiement dans le référentiel WebDAV.


Enregistrement de la spécification de paiement dans le référentiel WebDAV

Lorsque vous enregistrez un fichier dans WebDAV (Web Distributed Authoring and Versioning), il est stocké sur le serveur et non pas sur le disque local. WebDAV verrouille les documents pour éviter que les utilisateurs n'écrasent les modifications apportées par d'autres utilisateurs. Il permet également aux utilisateurs de partager et de traiter des documents basés sur le serveur, quels que soient leurs outils de création de page Web, leurs plates-formes et le type des serveurs Web contenant les fichiers. Dans la procédure suivante, l'instance de document doit également être validée. Si l'instance de document n'est pas valide, l'onglet Avertissement indique qu'elle est incorrecte et affiche les erreurs à l'origine du problème.

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

    La boîte de dialogue Stocker dans WebDav s'affiche.

  2. Double-cliquez sur le dossier Microsoft.

  3. Dans la zone Nom de fichier, tapez PaymentSpec et cliquez sur Enregistrer.

  4. Dans le menu Outils, cliquez sur Valider l'instance.

    La boîte de dialogue Valider une instance de document s'affiche.

  5. Recherchez le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server.

  6. Cliquez sur payment_valid.xml, puis sur Ouvrir.

    Les avertissements ou les messages d'erreur apparaissent, le cas échéant, dans l'onglet Avertissements. Pour résoudre une erreur, sélectionnez le message d'avertissement.

La spécification de paiement doit apparaître comme dans l'illustration suivante.

Spécification de paiement

Pour créer la spécification de la requête d'ordre d'achat à l'aide de l'Éditeur BizTalk, passez à Création de la spécification de la requête d'ordre d'achat.

Raccourci

  • Si un serveur BizTalk Server et tous ses composants sont installés sur le lecteur C, vous pouvez utiliser la spécification de la requête d'ordre d'achat existante. Passez à Utilisation de la spécification de la requête d'ordre d'achat existante.


Utilisation de la spécification de la requête d'ordre d'achat existante

  1. Copiez le fichier POReq.xml du dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps sur le lecteur où est installé BizTalk Server.

  2. Insérez ce fichier dans le dossier \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

Passez à Utilisation de Mappeur BizTalk


Création de la spécification de la requête d'ordre d'achat

Cette procédure consiste à créer le nœud racine de la spécification de la requête d'ordre d'achat. La spécification de la requête d'ordre d'achat définit la structure et les données utilisées par Northwind Traders pour envoyer une requête d'ordre d'achat pour approbation.

Pour créer le nœud racine

  1. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Nouvelle spécification de document apparaît.

  2. Cliquez sur l'icône Spécification vide, puis cliquez sur OK.

  3. Dans le nœud racine, cliquez sur Spécification vide.

  4. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Nom, tapez POReq et appuyez sur ENTRÉE.

  5. Double-cliquez sur le champ Valeur de la ligne Modèle, cliquez sur Ouvrir et appuyez sur ENTRÉE.

Passez à Ajout de nouveaux enregistrements au nœud racine de la spécification de la requête d'ordre d'achat.


Ajout de nouveaux enregistrements au nœud racine de la spécification de la requête d'ordre d'achat

  1. Cliquez avec le bouton droit sur le nœud racine POReq et cliquez sur Nouvel enregistrement.

  2. Appelez cet enregistrement Header et appuyez sur ENTRÉE.

  3. Suivez les étapes 1 et 2 pour créer et dénommer cinq enregistrements supplémentaires sous le nœud racine POReq.

    Il s'agit des enregistrements enfants du nœud racine POReq. Appelez-les comme suit :

    • EmployeeInfo

    • BillTo

    • ShipTo

    • Item

    • Total

Passez à Ajout de nouveaux enregistrements aux enregistrements existants de la spécification de la requête d'ordre d'achat.


Ajout de nouveaux enregistrements aux enregistrements existants de la spécification de la requête d'ordre d'achat

  1. Cliquez avec le bouton droit sur l'enregistrement BillTo et cliquez sur Nouvel Enregistrement.

  2. Appelez cet enregistrement Address et appuyez sur ENTRÉE.

  3. Suivez les étapes 1 et 2 pour créer et dénommer un enregistrement enfant Address de l'enregistrement parent ShipTo.

Passez à Ajout de nouveaux champs aux enregistrements existants de la spécification de la requête d'ordre d'achat.


Ajout de nouveaux champs aux enregistrements existants de la spécification de la requête d'ordre d'achat

  1. Cliquez avec le bouton droit sur l'enregistrement Header et cliquez sur Nouveau Champ.

  2. Appelez ce champ Date et appuyez sur ENTRÉE.

  3. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Type de données, cliquez sur Date et appuyez sur ENTRÉE.

  4. Cliquez avec le bouton droit sur l'enregistrement EmployeeInfo et cliquez sur Nouveau Champ.

  5. Appelez ce champ EmpID et appuyez sur ENTRÉE.

  6. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Type de données, cliquez sur String et appuyez sur ENTRÉE.

  7. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Longueur minimale, tapez 1, puis appuyez sur ENTRÉE.

  8. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur de la ligne Longueur maximale, tapez 60 et appuyez sur ENTRÉE.

  9. Suivez les étapes 4 à 8 pour créer des champs pour les enregistrements ou les enregistrements enfants répertoriés dans le tableau ci-dessous.

    Chaque enregistrement contient plusieurs champs.

    Il n'est pas nécessaire de créer les champs de ShipTo car il existe des noms d'enregistrement parallèles pour BillTo et ShipTo. Tous les enregistrements possédant le même nom contiennent les mêmes informations de champs et d'enregistrements. Si vous ajoutez des champs à l'enregistrement BillTo/Address, l'enregistrement ShipTo/Address est mis à jour automatiquement avec les mêmes champs.

    Enregistrement parent | Nom du champ | Type de données | Longueur minimale | Longueur maximale
    EmployeeInfo | LastName | String | 1 | 30
    FirstName | String | 1 | 30
    BillTo/Address | Name | String | 1 | 60
    Address1 | String | 1 | 55
    Address2 | String | 1 | 55
    City | String | 2 | 30
    State | String | 2 | 2
    Zip | String | 3 | 15
    Country | String | 2 | 3
    Item | Quantity | Real(r4) | Non applicable | Non applicable
    Price | Real(r4) | Non applicable | Non applicable
    Description | String | 1 | 80
    UnitofMeasure | String | 2 | 2
    ExtendedPrice | Real(r4) | Non applicable | Non applicable
    Total | LineItemTtl | Real(r4) | Non applicable | Non applicable
    QtyTtl | Real(r4) | Non applicable | Non applicable
    POTtl | Real(r4) | Non applicable | Non applicable

Passez à Enregistrement de la spécification de la requête d'ordre d'achat.


Enregistrement de la spécification de la requête d'ordre d'achat

Comme dans la procédure précédente, Enregistrement de la spécification de paiement dans le référentiel WebDAV, vous souhaitez enregistrer le fichier dans WebDAV et non sur le disque local.

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

    La boîte de dialogue Stocker dans WebDav s'affiche.

  2. Vérifiez que le dossier Microsoft est ouvert.

  3. Dans la zone Nom de fichier, tapez POReq et cliquez sur Enregistrer.

  4. Dans le menu Outils, cliquez sur Valider l'instance.

    La boîte de dialogue Valider une instance de document s'affiche.

  5. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData sur le lecteur où est installé BizTalk Server.

  6. Cliquez sur POReqAccept.xml, puis cliquez sur Ouvrir.

    Les avertissements ou les messages d'erreur apparaissent, le cas échéant, dans l'onglet Avertissements.

    La spécification de la requête d'ordre d'achat doit apparaître comme dans l'illustration suivante.

    Requête d'ordre d'achat

  7. Dans le menu Fichier, sélectionnez Quitter pour fermer l'Éditeur BizTalk.

Passez à Utilisation de Mappeur BizTalk


Utilisation de Mappeur BizTalk

Cette procédure consiste à utiliser le Mappeur BizTalk pour créer un mappage qui transforme les données d'un message conforme aux spécifications CommonInvoice utilisées par Contoso, Ltd, en données d'un message conforme aux spécifications PaymentSpec que vous avez créées pour l'acheteur, Northwind Traders.

Le module suivant montre comment les services d'échanges BizTalk utilisent ce mappage dans un canal pour spécifier la façon dont les données d'un document utilisant un schéma XML sont transformées en document utilisant un schéma XML différent.

Si vous avez imprimé l'illustration générale présentée au début de ce didacticiel, vous pouvez revoir ce processus tel qu'il est décrit dans la section inférieure du schéma, dans la zone Services d'échanges BizTalk.

Pour créer le mappage à l'aide de Mappeur BizTalk, passez à Création du mappage InvoiceToPayment.

Raccourci

  • Si un serveur BizTalk Server et tous ses composants sont installés sur le lecteur C, vous pouvez utiliser la planification existante. Passez à Utilisation du mappage InvoiceToPayment existant.


Utilisation du mappage InvoiceToPayment existant

  1. Copiez le fichier InvoiceToPayment.xml du dossier \Program Files\Microsoft BizTalk Server\Tutorial\DocSpecsandMaps sur le lecteur où est installé BizTalk Server.

  2. Collez le fichier dans le dossier \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\Maps\Microsoft.

Passez au Module 3 - Configuration des services d'échanges BizTalk.


Création du mappage InvoiceToPayment

Avant de créer le mappage, vous devez ouvrir CommonInvoice.xml qui représente la spécification source et PaymentSpec.xml qui constitue la spécification de destination.

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2002 et cliquez sur Mappeur BizTalk.

  2. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Sélectionner le type de spécification source apparaît.

  3. Cliquez sur l'icône Fichiers WebDAV, puis sur OK.

    La boîte de dialogue Extraire la spécification source apparaît.

  4. Double-cliquez sur le dossier Microsoft.

  5. Cliquez sur CommonInvoice.xml, puis sur Ouvrir.

    La boîte de dialogue Sélectionner le type de spécification de destination apparaît.

  6. Cliquez sur l'icône Fichiers WebDAV, puis sur OK.

  7. Cliquez sur PaymentSpec.xml, puis sur Ouvrir.

Passez à Création de liens entre les champs.


Création de liens entre les champs

La procédure suivante consiste à lier des champs de la spécification source aux champs de la spécification de destination. Les liens servent essentiellement à copier des données depuis les champs et enregistrements de l'arborescence de spécification source vers les champs et enregistrements de l'arborescence de spécification de destination.

Pour créer des liens entre les champs

  1. Dans l'arborescence Spécification source, développez l'enregistrement InvoiceHeader afin d'afficher les champs associés.

    Pour plus d'informations, voir Développement des éléments de l'arborescence.

  2. Dans l'arborescence Spécification de destination, développez l'enregistrement PaymentHeader afin d'afficher les champs associés.

  3. Faites glisser le champ InvoiceHeader/Date de l'arborescence de spécification source vers le champ PaymentHeader/Date de l'arborescence de spécification de destination.

  4. Suivez les étapes 1 à 3 pour créer des liens entre les champs répertoriés dans les tableaux ci-dessous.
    Enregistrement/champ source | Enregistrement/champ de destination
    InvoiceHeader/Number | PaymentHeader/PONumber

    Seller/Address/Name | Seller/Address/Name
    Seller/Address/Address1 | Seller/Address/Address1
    Seller/Address/Address2 | Seller/Address/Address2
    Seller/Address/City | Seller/Address/City
    Seller/Address/State | Seller/Address/State
    Seller/Address/PostalCode | Seller/Address/Zip
    Seller/Address/Country | Seller/Address/Country

    Seller/ContactInfo/ContactName | Seller/ContactInfo/Name
    Seller/ContactInfo/ContactNumber | Seller/ContactInfo/Number

    Buyer/Address/Name | Buyer/Address/Name
    Buyer/Address/Address1 | Buyer/Address/Address1
    Buyer/Address/Address2 | Buyer/Address/Address2
    Buyer/Address/City | Buyer/Address/City
    Buyer/Address/State | Buyer/Address/State
    Buyer/Address/PostalCode | Buyer/Address/Zip
    Buyer/Address/Country | Buyer/Address/Country

    Buyer/ContactInfo/ContactName | Buyer/ContactInfo/Name
    Buyer/ContactInfo/ContactNumber | Buyer/ContactInfo/Number

    Item/ItemHeader/Quantity | Item/Quantity
    Item/ItemHeader/Price | Item/Price
    Item/ItemDescription/Description | Item/Description

    InvoiceSummary/InvoiceTotal/Amount PaymentSummary/Total

Passez à Création de liens à l'aide des fonctoids.


Création de liens à l'aide des fonctoids

Cette procédure consiste à utiliser un fonctoid pour multiplier le champ Quantity par le champ Price de la spécification source, et à placer cette valeur dans le champ ExtendedPrice de la spécification de destination.

Pour créer des fonctoids à l'aide de liens

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

    La Palette de fonctoids apparaît.

  2. Cliquez sur l'onglet Mathématique, faites glisser le fonctoid Multiplication Fonctoid Multiplication sur la grille de mappage et fermez la palette de fonctoids.

  3. Dans l'arborescence Spécification source, faites glisser le champ Item/ItemHeader/Quantity sur le fonctoid.

  4. Dans l'arborescence Spécification source, faites glisser le champ Item/ItemHeader/Price sur le fonctoid.

  5. Faites glisser le fonctoid Multiplication dans le champ Item/ExtendedPrice de l'arborescence Spécification de destination.

Passez à Compilation du mappage.


Compilation du mappage

Il est nécessaire de compiler un mappage avant de l'utiliser, afin de pouvoir résoudre les avertissements ou les erreurs éventuels.

  1. Dans le menu Outils, cliquez sur Compiler le fichier de mappage.

  2. Dans le volet inférieur, cliquez sur l'onglet Sortie.

    Les informations de l'onglet Sortie indiquent qu'un mappage XSL a été créé. Les avertissements ou les messages d'erreur apparaissent, le cas échéant, dans l'onglet Avertissements.

Passez à Enregistrement du mappage dans le référentiel WebDAV.


Enregistrement du mappage dans le référentiel WebDAV

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

    La boîte de dialogue Stocker dans WebDav s'affiche.

  2. Double-cliquez sur le dossier Microsoft.

  3. Dans la zone Nom de fichier, tapez InvoiceToPayment et cliquez sur Enregistrer.

    Le mappage que vous avez créé doit apparaître comme dans l'illustration suivante.

  4. Dans le menu Fichier, choisissez Quitter pour fermer le Mappeur BizTalk.

Passez à Module 2 - Résumé.


Module 2 - Résumé

Ce module vous a appris comment procéder pour :

  • Créer une spécification. Pour plus d'informations, voir Définition des spécifications ;

  • Ajouter des enregistrements et des champs à une spécification. Pour plus d'informations, voir Ajout de nouveaux champs aux enregistrements ;

  • Créer un mappage. Pour plus d'informations, voir Utilisation de Mappeur BizTalk.

  • Créer des liens entre les champs d'un mappage. Pour plus d'informations, voir Création de liaisons.

  • Utiliser des fonctoids pour manipuler des valeurs mathématiques dans un mappage. Pour plus d'informations, voir Présentation des fonctoids.

  • Enregistrer des spécifications et des mappages dans le référentiel WebDAV. Pour plus d'informations, voir Stockage de spécifications et Stockage de mappages.

Les zones mises en surbrillance dans la figure suivante illustrent les procédures que vous avez effectuées dans ce module.

Passez au Module 3 - Configuration des services d'échanges BizTalk.

Voir aussi

Création de spécifications et mappage de données


Module 3 - Configuration des services d'échanges BizTalk

À ce stade du didacticiel, vous avez conçu le processus professionnel et le flux de communication, puis défini la structure des documents envoyés et reçus. L'étape suivante consiste à configurer les services d'échanges BizTalk sur les systèmes de l'acheteur et du vendeur, pour permettre l'envoi et la réception des documents.

Dans ce module, vous allez apprendre à utiliser le Gestionnaire d'échanges BizTalk pour configurer des organisations, des canaux et des ports d'échanges pour les systèmes du vendeur et de l'acheteur. Vous pouvez allez également apprendre à utiliser la fonction Administration de BizTalk Server pour configurer une fonction de réception de fichier.

Objectifs

  • Créer des définitions de document. Pour plus d'informations, voir Création et gestion de définitions de document.

  • Créer des organisations. Pour plus d'informations, voir Création et gestion d'organisations.

  • Créer des ports d'échanges. Pour plus d'informations, voir Création et gestion des ports d'échanges et Intégration des services BizTalk.

  • Créer des canaux. Pour plus d'informations, voir Création et gestion de canaux.

  • Utiliser un mappage d'un canal pour transformer un document. Pour plus d'informations, voir Utilisation de Mappeur BizTalk.

  • Créer une fonction de réception. Pour plus d'informations, voir Fonctions de réception.

Passez à Configuration du système de l'acheteur.

Voir aussi

Utilisation du Gestionnaire d'échanges BizTalk


Configuration du système de l'acheteur

Vous utilisez le Gestionnaire d'échanges BizTalk pour créer des organisations représentant vos partenaires commerciaux.

Pour configurer le système de Northwind Traders à l'aide du Gestionnaire d'échanges BizTalk, passez à Création d'organisations pour le système de l'acheteur.

Raccourci

  • Si un serveur BizTalk Server et tous ses composants sont installés sur le lecteur C, vous pouvez utiliser un script pour configurer le système Northwind Traders. Passez à Configuration du système de l'acheteur à l'aide d'un script de configuration


Configuration du système de l'acheteur à l'aide d'un script de configuration

Ce script configure les éléments suivants :

  • une organisation source appelée Northwind Traders on Buyer sur le système de l'acheteur ;

  • une organisation de destination appelée Contoso on Buyer sur le système de l'acheteur ;

  • quatre définitions de document faisant référence aux spécifications de CommonPO, CommonInvoice, PaymentSpec et POReq ;

  • un port d'échanges et un canal définissant le déplacement d'une requête d'ordre d'achat du système de l'acheteur vers le système du vendeur à l'aide du service de transport HTTP dans un fichier ASP du système du vendeur ;

  • un port d'échanges et un canal définissant le déplacement d'une facture ayant été envoyée à l'acheteur et transformée en document de paiement sur le système du vendeur.

Attention

  • Si vous avez utilisé le Gestionnaire d'échanges BizTalk et le composant Administration de BizTalk Server pour configurer le système de l'acheteur, n'exécutez pas le script de configuration.

Pour exécuter le script de configuration des services d'échanges BizTalk pour le système de l'acheteur :

  1. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Setup\MessagingConfigurationScript sur le lecteur où est installé BizTalk Server.

  2. Double-cliquez sur ConfigureBuyer.VBS.

    Un message s'affiche pour indiquer que l'opération a réussi.

Passez à Configuration du système du vendeur.


Création d'organisations pour le système de l'acheteur

Le Gestionnaire d'échanges BizTalk permet de gérer les échanges de documents en configurant les services d'échanges BizTalk. Vous devez utiliser le Gestionnaire d'échanges BizTalk pour configurer les services d'échanges BizTalk avant de traiter des documents. Les organisations que vous créez agissent comme la source d'un canal ou la destination d'un port d'échanges. Le port d'échanges et le canal définissent le déplacement des documents entre les partenaires commerciaux. Pour plus d'informations, voir Description des organisations.

Cette procédure consiste à créer l'organisation source, Northwind Traders et l'organisation de destination, Contoso, Ltd sur le système Northwind Traders.

Important

  • Si vous avez utilisé le script de configuration, n'utilisez pas le Gestionnaire d'échanges BizTalk et le composant Administration de BizTalk Server pour configurer le système de l'acheteur. Passez à Configuration du système du vendeur.

Pour créer des organisations sur le système Northwind Traders :

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Si la boîte de dialogue Gestionnaire d'échanges BizTalk apparaît, cliquez sur Annuler.

  3. Dans le menu Fichier, pointez sur Nouveau, puis cliquez sur Organisation.

    La boîte de dialogue Nouvelle organisation apparaît.

  4. Dans la zone Nom de l'organisation, tapez Contoso on Buyer et cliquez sur OK.

  5. Répétez les étapes 3 et 4, en nommant la nouvelle organisation Northwind Traders on Buyer.

Passez à Création de définitions de document pour les systèmes de l'acheteur et du vendeur.


Création de définitions de document pour les systèmes de l'acheteur et du vendeur

Cette procédure consiste à créer quatre définitions de document qui font référence aux spécifications de document, CommonInvoice, CommonPO, PaymentSpec et POReq. Les systèmes de l'acheteur et du vendeur partagent ces définitions de documents qui leur permettent de comprendre le document professionnel en cours de transfert. Une définition de document représente le type de document entrant ou sortant dans un canal et fournit un pointeur vers la spécification correspondante. Pour plus d'informations, voir Description des définitions de documents.

Pour créer des définitions de document

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Définition de document.

    La boîte de dialogue Nouvelle définition de document s'affiche.

  2. Dans la zone Nom de la définition de document, tapez Ordre d'achat.

  3. Activez la case à cocher Spécification de document et cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une spécification de document dans le référentiel WebDAV apparaît.

  4. Double-cliquez sur le dossier Microsoft.

  5. Cliquez sur CommonPO.xml, puis sur Ouvrir.

  6. Cliquez sur OK pour fermer la boîte de dialogue Nouvelle définition de document.

  7. Répétez les étapes 1 à 6 pour créer une nouvelle définition de document avec les variations suivantes :
Nom de la définition de document | Spécification de document
Facture | CommonInvoice.xml
Requête d'ordre d'achat | POReq.xml
Paiement | PaymentSpec.xml

Passez à Création d'un port d'échanges sur Contoso, Ltd pour le système de l'acheteur.


Création d'un port d'échanges sur Contoso, Ltd pour le système de l'acheteur

Cette procédure consiste à créer un port d'échanges pour le système de l'acheteur. Le port d'échanges définit la destination d'un document.

Dans ce scénario, lorsqu'une requête d'ordre d'achat est acceptée, les services d'échanges BizTalk localisent le canal approprié pour la traiter. Une fois que le canal a traité le document, il pointe le serveur vers son port d'échanges associé qui, à son tour, amène le serveur tout au long de la séquence d'étapes nécessaires au transport du document vers l'organisation de destination spécifiée. Le port d'échanges créé dans cette procédure dispose d'une organisation de destination, appelée « Contoso on Buyer ». Vous créez le canal après avoir créé le port d'échanges.

Les propriétés de transport que vous spécifiez pour un port d'échanges déterminent le service de transport utilisé pour transmettre les documents à l'organisation de destination et à l'adresse à laquelle les documents sont envoyés. Pour ce port d'échanges, vous spécifiez le service de transport HTTP qui assure la livraison des documents dans un fichier ASP sur le site Web de Contoso.

Pour créer le port d'échanges

  1. Dans le menu Fichier, pointez sur Nouveau et sur Port d'échanges, puis cliquez sur Vers une organisation.

    L'Assistant Nouveau port d'échanges s'ouvre.

  2. Dans la zone Nom, tapez Port to Contoso via HTTP et cliquez sur Suivant.

  3. Sur la page Organisation de destination, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  4. Cliquez sur Contoso on Buyer, puis sur OK.

  5. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal apparaît.

  6. Dans la liste Type de transport, cliquez sur HTTP.

  7. Dans la zone Adresse, après le préfixe http://, tapez le nom de votre ordinateur suivi de /SubmitPO/SubmitNorthwindPO.asp, cliquez sur OK, puis sur Suivant.

    Par exemple, si ce message est destiné à une page ASP sur le site Web de Contoso, vous pouvez taper http://ContosoLtd/SubmitPO/SubmitNorthwindPO.asp.

    Pour rechercher le nom de votre ordinateur, procédez comme suit :

    1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

    2. Double-cliquez sur Outils d'administration.

    3. Double-cliquez sur Gestion de l'ordinateur.

      La console Gestion de l'ordinateur s'affiche.

    4. Dans le menu Action, cliquez sur Propriétés.

      La boîte de dialogue Propriétés de Gestion de l'ordinateur (local) apparaît.

    5. Cliquez sur l'onglet Identification réseau.

      Le nom de votre ordinateur s'affiche dans le champ Nom de l'ordinateur.

  8. Sur la page Informations d'enveloppe, cliquez sur Suivant.

  9. Sur la page Informations de sécurité, vérifiez que la case à cocher Créer un canal pour ce port d'échanges est activée.

  10. Dans la liste Type de canal, cliquez sur À partir d'une organisation, puis sur Terminer.

    L'Assistant Nouveau canal s'ouvre.

Passez à Création d'un canal à partir de Northwind Traders pour le système de l'acheteur.


Création d'un canal à partir de Northwind Traders pour le système de l'acheteur

Après avoir créé le port d'échanges, vous devez définir le canal qui lui est associé. Dans ce canal, nous allons identifier la source du document, « Northwind Traders on Buyer », et préciser que le document entrant est une requête d'ordre d'achat et que le document sortant sera un ordre d'achat. Nous allons utiliser le mappage POReqtoPO.xml pour transformer la requête d'ordre d'achat en ordre d'achat. Pour plus d'informations, voir Description des canaux.

Si vous avez imprimé l'illustration générale présentée au début de ce didacticiel, vous pouvez voir la présentation du canal et du port d'échanges créés dans ces procédures.

Pour créer le canal

  1. Sur la page Informations générales, dans la zone Nom, tapez Canal pour ReqOA vers OA et cliquez sur Suivant.

  2. Sur la page Organisation source, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  3. Cliquez sur Northwind Traders on Buyer, sur OK, puis sur Suivant.

  4. Sur la page Document entrant, à droite de la zone Nom de la définition du document entrant, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  5. Cliquez sur Requête d'ordre d'achat, sur OK, puis sur Suivant.

  6. Sur la page Document sortant, à droite de la zone Nom de la définition de document sortant, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  7. Cliquez sur Ordre d'achat, puis sur OK.

  8. Vérifiez que la case à cocher Mapper le document entrant sur le document sortant est activée.

  9. À droite de la zone Référence de mappage, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'un mappage dans le référentiel WebDAV s'affiche.

  10. Double-cliquez sur le dossier Microsoft.

  11. Cliquez sur POReqtoPO.xml, sur Ouvrir, puis sur Suivant.

  12. Sur la page Journalisation du document, cliquez sur Suivant.

  13. Sur la page Configuration avancée, cliquez sur Terminer.

Passez à Création d'un port d'échanges sur Contoso, Ltd dans le système de l'acheteur.


Création d'un port d'échanges sur Contoso, Ltd dans le système de l'acheteur

Cette procédure fournit un exemple d'utilisation du service de transport des fichiers. Les systèmes de l'acheteur et du vendeur étant situés sur le même ordinateur, nous pouvons simuler le dépôt d'un fichier à un emplacement sur le système du vendeur. Toutefois, dans la plupart des cas, l'acheteur ne dispose d'aucune autorisation d'accès pour placer un fichier sur le système du vendeur. En général, un autre mode de transport (HTTP par exemple) est utilisé pour envoyer des documents à un partenaire commercial.

Dans cette procédure, le port d'échanges envoie les documents traités par le système de Northwind Traders au système de Contoso, Ltd à l'aide du service de transport de fichier. Les documents sont envoyés vers le dossier spécifié (C:\TutorialFiles\Seller) dans l'adresse de destination du port d'échanges.

Pour créer le port d'échanges

  1. Dans le menu Fichier, pointez sur Nouveau et sur Port d'échanges, puis cliquez sur Vers une organisation.

    L'Assistant Nouveau port d'échanges s'ouvre.

  2. Dans la zone Nom, tapez Port vers Contoso via fichier local et cliquez sur Suivant.

  3. Sur la page Organisation de destination, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  4. Cliquez sur Contoso on Buyer, puis sur OK.

  5. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal apparaît.

  6. Dans la liste Type de transport, cliquez sur Fichier.

  7. Dans la zone Adresse, après file://, tapez C:\FichiersDidacticiel\Seller\payment%tracking_id%.xml.

    Par exemple, file://c:\FichiersDidacticiel\Seller\payment%tracking_id%.xml.

    Remarque

    • Pour le service de transport de fichiers, le paramètre par défaut du composant transport consiste à ajouter de nouveaux fichiers à un fichier existant dans le répertoire spécifié. Pour créer un nouveau fichier ayant un nom unique pour chaque instance de document, vous devez utiliser le format de chemin de fichier suivant :
      fichier://C:\dir\fichier%id_suivi%.xml.
  8. Cliquez sur OK pour fermer la boîte de dialogue Transport principal, puis cliquez sur Suivant.

  9. Sur la page Informations d'enveloppe, cliquez sur Suivant.

  10. Sur la page Informations de sécurité, vérifiez que la case à cocher Créer un canal pour ce port d'échanges est activée.

  11. Dans la liste Type de canal, cliquez sur À partir d'une organisation, puis sur Terminer.

    L'Assistant Nouveau canal s'ouvre.

Passez à Création d'un canal à partir de Contoso, Ltd pour le système de l'acheteur.


Création d'un canal à partir de Contoso, Ltd pour le système de l'acheteur

Le canal que vous créez dans cette procédure traite les factures reçues de Contoso, Ltd et utilise un mappage pour transformer la facture en paiement. Plus précisément, vous identifiez la source du document, Contoso on Buyer, et spécifiez que le document entrant est une facture et que le document sortant sera un paiement. Les services d'échanges BizTalk utilisent le mappage InvoiceToPayment.xml pour transformer une facture en paiement.

Si vous avez imprimé l'illustration générale présentée au début de ce didacticiel, vous pouvez revoir ce processus.

Pour créer le canal

  1. Sur la page Informations générales, dans la zone Nom, tapez Canal de la facture en paiement et cliquez sur Suivant.

  2. Sur la page Organisation source, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  3. Cliquez sur Contoso on Buyer, sur OK, puis sur Suivant.

  4. Sur la page Document entrant, à droite de la zone Nom de la définition du document entrant, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  5. Cliquez sur Facture, sur OK, puis sur Suivant.

  6. Sur la page Document sortant, à droite de la zone Nom de la définition de document sortant, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  7. Cliquez sur Paiement, puis sur OK.

  8. Vérifiez que la case à cocher Mapper le document entrant sur le document sortant est activée.

  9. À droite de la zone Référence de mappage, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'un mappage dans le référentiel WebDAV s'affiche.

  10. Double-cliquez sur le dossier Microsoft.

  11. Cliquez sur InvoicetoPayment.xml, sur Ouvrir, puis sur Suivant.

  12. Sur la page Journalisation du document, cliquez sur Suivant.

  13. Sur la page Configuration avancée, cliquez sur Terminer.

  14. Dans le menu Fichier, cliquez sur Quitter pour fermer le Gestionnaire d'échanges BizTalk.

Passez à Création d'une fonction de réception de fichiers pour le système de l'acheteur.


Création d'une fonction de réception de fichiers pour le système de l'acheteur

Cette procédure consiste à créer une fonction de réception de fichier qui extrait la requête d'ordre d'achat de l'acheteur d'un répertoire de fichiers local et la soumet aux services d'échanges BizTalk.

Les fonctions de réception permettent aux applications de publier des documents dans des emplacements spécifiques contrôlés par BizTalk Server 2002. Cette procédure consiste à définir l'emplacement C:\TutorialFiles\Buyer. La fonction de réception utilise un processus de contrôle basé sur les événements pour reconnaître la présence d'un document à cet emplacement. Lorsque la fonction reçoit les données du document, elle les envoie à BizTalk Server. Chaque document soumis à BizTalk Server nécessite un ensemble de règles précisant son mode de traitement. Cette procédure consiste à créer le canal entre la requête d'ordre d'achat (ReqOA) et l'ordre d'achat (OA). Ce canal contient toutes les informations dont le serveur a besoin pour traiter le document.

La relation entre l'application professionnelle d'envoi, le système de fichiers où le fichier est situé et la fonction de réception est représentée dans l'illustration suivante.

Fonction de réception de fichier

Pour plus d'informations sur les fonctions de réception, voir Description des fonctions de réception et du routage de documents.

Pour créer la fonction de réception de fichier

  1. Dans le menu Démarrer, pointez sur Programmes et Microsoft BizTalk Server 2002, puis cliquez sur Administration de BizTalk Server.

  2. Développez Microsoft BizTalk Server 2002, puis Groupe BizTalk Server et cliquez sur Fonctions de réception.

  3. Dans le menu Action, pointez sur Nouveau et cliquez sur Fonction de réception de fichier.

    La boîte de dialogue Ajouter une fonction de réception de fichier apparaît.

  4. Dans la zone Nom, tapez Fonction de réception de RequêteOA chez Northwind Traders.

  5. Dans la zone Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom d'un serveur du groupe de serveurs BizTalk.

  6. Dans la zone Types de fichiers à interroger, tapez *.xml.

  7. Dans la zone Emplacement de l'interrogation, tapez C:\TutorialFiles\Buyer.

  8. Cliquez sur Avancé.

    La boîte de dialogue Options de fonction de réception avancées apparaît.

  9. Dans la liste Nom du canal, cliquez sur Canal pour ReqOA vers OA, puis sur OK.

  10. Cliquez sur OK pour fermer la boîte de dialogue Ajouter une fonction de réception de fichier.

  11. Fermez Administration de BizTalk Server.

Passez à Configuration du système du vendeur.


Configuration du système du vendeur

Les procédures suivantes consistent à utiliser le Gestionnaire d'échanges BizTalk pour créer des organisations qui représentent les partenaires commerciaux sur le système de Contoso, Ltd. Vous allez également configurer les ports d'échanges et les canaux qui définissent le déplacement des documents sur ce système.

Passez à Création d'organisations pour le système du vendeur.


Création d'organisations pour le système du vendeur

Cette procédure consiste à créer sur le système Contoso, Ltd les organisations qui servent de source d'un canal ou de destination d'un port d'échanges. Pour plus d'informations, voir Description des organisations.

Remarque

  • Dans le cadre de ce didacticiel, les systèmes de l'acheteur et du vendeur sont configurés sur un ordinateur.
  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Si la boîte de dialogue Gestionnaire d'échanges BizTalk apparaît, cliquez sur Annuler.

  3. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation.

    La boîte de dialogue Nouvelle organisation apparaît.

  4. Dans l'onglet Général, dans la zone Nom de l'organisation, tapez Contoso on Seller et cliquez sur OK.

  5. Répétez les étapes 3 et 4, en nommant la nouvelle organisation Northwind Traders on Seller, puis cliquez sur OK.

Passez à Création d'un port d'échanges sur Contoso, Ltd pour le système du vendeur.


Création d'un port d'échanges sur Contoso, Ltd pour le système du vendeur

Cette procédure consiste à créer un port d'échanges qui définit la destination de l'ordre d'achat sur le système du vendeur. Ce port envoie des documents en interne dans le système du Contoso, Ltd en utilisant le composant d'intégration de l'application comme service de transport.

Un composant d'intégration de l'application sert généralement de point d'intégration entre BizTalk Server 2002 et une application principale. Dans ce scénario, ce composant fonctionne à la fois comme point d'intégration et application principale éventuelle. Le port d'échanges transmet l'ordre d'achat au composant d'intégration de l'application. Lorsqu'un ordre d'achat est envoyé à un vendeur, plusieurs processus professionnels supplémentaires peuvent se produire avant la génération d'une facture. Toutefois, dans la cadre de ce didacticiel, le composant d'intégration de l'application (AIC) effectue toutes les tâches nécessaires pour transformer l'ordre d'achat en facture et envoyer cette dernière au canal approprié dans les services d'échanges BizTalk du système du vendeur.

L'ordre d'achat peut également être transformé en facture à l'aide d'un mappage dans le canal, mais, pour montrer l'utilisation d'un autre service de transport, le composant d'intégration de l'application exécute cette fonction dans ce scénario.

Pour créer le port d'échanges

  1. Dans le menu Fichier, pointez sur Nouveau et sur Port d'échanges, puis cliquez sur Vers une organisation.

    L'Assistant Nouveau port d'échanges s'ouvre.

  2. Dans la zone Nom, tapez Port vers Contoso via AIC et cliquez sur Suivant.

  3. Sur la page Organisation de destination, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  4. Cliquez sur Contoso on Seller, puis sur OK.

  5. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal apparaît.

  6. Dans la liste Type de transport, vérifiez que Composant d'intégration Aux applications est sélectionné et cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un composant s'affiche.

  7. Cliquez sur POToINVAIC ConvertPOToInvoice, puis sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue Transport principal, puis cliquez sur Suivant.

  9. Sur la page Informations d'enveloppe, cliquez sur Suivant.

  10. Sur la page Informations de sécurité, vérifiez que la case à cocher Créer un canal pour ce port d'échanges est activée.

  11. Dans la liste Type de canal, cliquez sur À partir d'une organisation, puis sur Terminer.

    L'Assistant Nouveau canal s'ouvre.

Passez à Création d'un canal à partir de Northwind Traders pour le système du vendeur.


Création d'un canal à partir de Northwind Traders pour le système du vendeur

Cette procédure consiste à créer un canal pour le port d'échanges.

Le canal que vous créez possède son organisation source Northwind Traders on Seller qui représente l'acheteur sur le système Contoso, Ltd. Ce canal traite les ordres d'achat reçus de Northwind Traders. Étant donné que les définitions de document entrant et sortant sont identiques, aucune référence de mappage n'est requise pour ce canal et aucune transformation de document n'est opérée.

Si vous avez imprimé l'illustration générale présentée au début de ce didacticiel, vous pouvez voir comment le canal, le port d'échanges et le transport AIC traitent l'ordre d'achat.

Pour créer le canal

  1. Sur la page Informations générales, dans la zone Nom, tapez Canal pour OA et cliquez sur Suivant.

  2. Sur la page Organisation source, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  3. Cliquez sur Northwind Traders on Seller, sur OK, puis sur Suivant.

  4. Sur la page Document entrant, à droite de la zone Nom de la définition du document entrant, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  5. Sélectionnez Ordre d'achat, cliquez sur OK, puis sur Suivant.

  6. Sur la page Document sortant, à droite de la zone Nom de la définition de document sortant, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  7. Sélectionnez Ordre d'achat, cliquez sur OK, puis sur Suivant.

  8. Sur la page Journalisation du document, cliquez sur Suivant.

  9. Sur la page Configuration avancée, cliquez sur Terminer.

Passez à Création d'un port d'échanges sur Northwind Traders pour le système du vendeur.


Création d'un port d'échanges sur Northwind Traders pour le système du vendeur

Cette procédure consiste à créer un port d'échanges sur le système de Contoso, Ltd qui définit la destination de la facture. Ce port d'échanges envoie la facture du système Contoso, Ltd à l'acheteur, Northwind Traders. Le service de transport HTTP envoie la facture à une page ASP sur le serveur Web de Northwind Traders. La page ASP publie alors la facture dans la file d'attente des messages ReceiveInvoice sur le système de l'acheteur.

Pour créer le port d'échanges

  1. Dans le menu Fichier, pointez sur Nouveau et sur Port d'échanges, puis cliquez sur Vers une organisation.

    L'Assistant Nouveau port d'échanges s'ouvre.

  2. Sur la page Informations générales, dans la zone Nom, tapez Port vers Northwind Traders via HTTP et cliquez sur Suivant.

  3. Sur la page Organisation de destination, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  4. Cliquez sur Northwind Traders on Seller, puis sur OK.

  5. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal apparaît.

  6. Dans la liste Type de transport, cliquez sur HTTP.

  7. Dans la zone Adresse, après le préfixe http://, tapez le nom de votre ordinateur suivi de /InvoiceToQueue/DropInvoicetoMSMQ.asp, cliquez sur OK, puis sur Suivant.

    Par exemple, si ce message est envoyé à une page ASP sur le serveur Web de Northwind Traders, vous pouvez taper http://NorthwindTraders/InvoiceToQueue/DropInvoicetoMSMQ.asp.

    Pour rechercher le nom de votre ordinateur, procédez comme suit :

  8. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  9. Double-cliquez sur Outils d'administration.

  10. Double-cliquez sur Gestion de l'ordinateur.

    La console Gestion de l'ordinateur s'affiche.

  11. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de Gestion de l'ordinateur (local) apparaît.

  12. Cliquez sur l'onglet Identification réseau.

    Le nom de votre ordinateur s'affiche dans le champ Nom de l'ordinateur.

  13. Sur la page Informations d'enveloppe, cliquez sur Suivant.

  14. Sur la page Informations de sécurité, vérifiez que la case à cocher Créer un canal pour ce port d'échanges est activée.

  15. Dans la liste Type de canal, cliquez sur À partir d'une organisation, puis sur Terminer.

    L'Assistant Nouveau canal s'ouvre.

Passez à Création d'un canal à partir de Contoso, Ltd pour le système du vendeur.


Création d'un canal à partir de Contoso, Ltd pour le système du vendeur

Le canal que vous créez dans cette procédure dispose de sa propre organisation source « Contoso on Seller », car la facture provient d'une source interne une fois qu'elle a été traitée et convertie à partir d'un ordre d'achat. Ce canal traite les factures envoyées à Northwind Traders en interne sur le système du vendeur, selon les règles du port d'échanges que vous venez de créer, Port vers Northwind Traders via HTTP.Si vous avez imprimé l'illustration générale présentée au début de ce didacticiel, vous pouvez voir comment le canal, le port d'échanges et le service de transport HTTP traitent la facture.

Pour créer le canal

  1. Sur la page Informations générales, dans la zone Nom, tapez Canal de la facture et cliquez sur Suivant.

  2. Sur la page Organisation source, dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  3. Cliquez sur Contoso on Seller, sur OK, puis sur Suivant.

  4. Sur la page Document entrant, à droite de la zone Nom de la définition du document entrant, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  5. Cliquez sur Facture, sur OK, puis sur Suivant.

  6. Sur la page Document sortant, cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  7. Cliquez sur Facture, sur OK, puis sur Suivant.

  8. Sur la page Journalisation du document, cliquez sur Suivant.

  9. Sur la page Configuration avancée, cliquez sur Terminer.

  10. Dans le menu Fichier, cliquez sur Quitter pour fermer le Gestionnaire d'échanges BizTalk.

Passez à Module 3 - Résumé.


Module 3 - Résumé

Dans ce module, vous avez configuré les services d'échanges BizTalk sur les systèmes de l'acheteur et du vendeur. Il est important de noter l'ordre des événements. Vous devez d'abord établir les partenaires commerciaux sur chaque système en créant les organisations correspondantes, puis définir les documents que ces dernières enverront et recevront. Ensuite, vous devez configurer la destination et la source du document, puis (pour le système de l'acheteur) la fonction de réception qui reçoit le document et l'envoie aux services d'échanges BizTalk.

Ce module vous a appris comment procéder pour :

  • Créer des organisations. Pour plus d'informations, voir Création et gestion d'organisations.

  • Créer des définitions de document. Pour plus d'informations, voir Création et gestion de définitions de document.

  • Créer des ports d'échanges. Pour plus d'informations, voir Création et gestion des ports d'échanges.

  • Créer des canaux. Pour plus d'informations, voir Création et gestion de canaux.

  • Utiliser un mappage dans un canal pour transformer un document. Pour plus d'informations, voir Utilisation de Mappeur BizTalk.

  • Créer une fonction de réception de fichier. Pour plus d'informations, voir Fonctions de réception.

Pour afficher les définitions de document, les organisations, les ports d'échanges, les canaux et le mappage que vous avez créés dans ce module, utilisez le bouton Rechercher du Gestionnaire d'échanges BizTalk.

Les zones mises en surbrillance dans la figure suivante illustrent les procédures que vous avez effectuées dans ce module.

Passez au Module 4 - Clôture de la planification XLANG.

Voir aussi

Utilisation du Gestionnaire d'échanges BizTalk


Module 4 - Clôture de la planification XLANG

La représentation initiale du processus professionnel de Northwind Traders illustre uniquement le processus d'approbation d'un ordre d'achat. Les processus professionnels associés à un ordre d'achat incluent également l'envoi d'un ordre d'achat approuvé, la réception d'une facture et l'envoi d'un paiement en retour.

Ce module utilise le Concepteur d'orchestration BizTalk pour modifier la planification XLANG de l'acheteur afin d'inclure les actions de facturation et de paiement et pour implémenter les ports nécessaires. Ensuite, vous compilez et exécutez la planification XLANG terminée.

Objectifs

  • Ajouter des actions de facture et de paiement. Pour plus d'informations, voir Ajout de formes ;

  • Implémenter un port à l'aide des services d'échanges BizTalk. Pour plus d'informations, voir Utilisation de la forme Échanges BizTalk.

  • Compiler et exécuter la planification XLANG terminée. Pour plus d'informations, voir Compilation des planifications XLANG et Exécution des planifications XLANG.

Pour terminer la planification XLANG, passez à Ajout d'actions de facture et de paiement.

Raccourci

  • Si un serveur BizTalk Server et tous ses composants sont installés sur le lecteur C, vous pouvez utiliser la planification XLANG existante. Passez à Exécution de la planification XLANG terminée.

Voir aussi

Conception des orchestrations BizTalk


Ajout d'actions de facture et de paiement

Cette procédure consiste à modifier le processus professionnel Northwind Traders dans le Concepteur d'orchestration BizTalk en ajoutant une action qui reçoit la facture de l'acheteur et une autre action qui envoie à Contoso, Ltd le message de paiement.

Pour créer les actions

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Concepteur d'Orchestration BizTalk.

  2. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir un schéma de planification XLANG apparaît.

  3. Si vous utilisez le fichier Acheteur1.skv existant, dans la boîte de dialogue Ouvrir un schéma de planification XLANG, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server, cliquez sur Acheteur1.skv, puis sur Ouvrir.

    Si vous avez créé le fichier Acheteur1.skv dans le module 1, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server, cliquez sur Acheteur1.skv, puis sur Ouvrir.

    Remarque

  4. Vous pouvez fermer le schéma vierge qui s'affiche dans le Concepteur d'Orchestration BizTalk.

  5. Sélectionnez la connexion entre l'action Écrire requête OA dans fichier et l'action Fin, puis appuyez sur SUPPR.

  6. Déplacez l'action Fin vers le bas pour libérer de la place pour les deux nouvelles formes d'action.

  7. Faites glisser la forme Action du stencil Diagramme de flux situé dans la colonne la plus à gauche vers la page Processus professionnels.

    Positionnez la forme en dessous de l'action Écrire requête OA dans fichier.

  8. Cliquez avec le bouton droit sur la forme Action 1, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'action s'affiche.

  9. Dans la zone Nom, tapez RecevoirFacture et cliquez sur OK.

  10. Faites glisser la forme Action du stencil Diagramme de flux situé dans la colonne la plus à gauche vers la page Processus professionnels.

    Positionnez la forme directement en dessous de l'action RecevoirFacture.

  11. Cliquez avec le bouton droit sur la forme Action 1, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'action s'affiche.

  12. Dans la zone Nom, tapez EnvoyerPaiement et cliquez sur OK.

  13. Connectez l'action Écrire requête OA dans fichier à l'action RecevoirFacture.

  14. Connectez l'action RecevoirFacture à l'action EnvoyerPaiement.

  15. Connectez l'action EnvoyerPaiement à la forme Fin.

Passez à Liaison du service Message Queuing pour recevoir une facture.


Liaison du service Message Queuing pour recevoir une facture

Lors de l'installation préliminaire de ce didacticiel, vous avez créé la file d'attente de messages ReceiveInvoice pour permettre à Northwind Traders de recevoir les messages de facture. Cette procédure consiste à ajouter la forme Messaging Queuing au schéma XLANG et à implémenter un port pour la file d'attente des messages ReceiveInvoice. La forme Message Queuing représente le service Message Queuing qui est utilisé pour envoyer ou recevoir des messages. Le service est configuré pour contrôler une file d'attente de messages relatifs à une facture. L'action RecevoirFacture est liée à un service Message Queuing. Lorsqu'une facture est placée dans la file d'attente de messages ReceiveInvoice, elle active l'action RecevoirFacture. Pour plus d'informations, voir Utilisation de la forme Message Queuing.

Si vous avez imprimé l'illustration générale présentée au début de ce didacticiel, vous pouvez voir comment le fichier ASP, la file d'attente des messages et l'action RecevoirFacture facilitent le déplacement du document.

Pour lier le service Message Queuing

  1. Faites glisser la forme Message Queuing du stencil Implémentation situé dans la colonne la plus à droite vers la page Processus professionnels.

    Positionnez la forme Message Queuing de sorte qu'elle soit alignée horizontalement par rapport à l'action RecevoirFacture.

    L'Assistant Liaison de Message Queuing s'ouvre.

  2. Sur la première page de l'Assistant Liaison de Message Queuing, vérifiez que Créer un port est sélectionné.

  3. Dans la zone Créer un port, tapez RecevoirFacture et cliquez sur Suivant.

  4. Sur la page Informations sur la file d'attente statique ou dynamique, vérifiez que File d'attente statique est sélectionné et cliquez sur Suivant.

  5. Sur la page Informations sur la file d'attente, cliquez sur Utiliser une file d'attente connue pour toutes les instances.

  6. Dans la zone Entrez le nom de la file d'attente, tapez .\private$\RecevoirFacture et cliquez sur Suivant.

  7. Sur la page Propriétés avancées du port, cliquez sur Terminer.

Passez à Définition des propriétés de message du service Receive Invoice.


Définition des propriétés de message du service Receive Invoice

Cette procédure consiste à utiliser l'Assistant Communication XML pour faciliter la communication entre la forme de l'action RecevoirFacture et le port RecevoirFacture. L'Assistant Communication XML vous permet de fournir les informations et les spécifications utilisées par le moteur de XLANG Scheduler pour identifier et récupérer le message correct dans la file d'attente.

  1. Sélectionnez l'action RecevoirFacture et faites glisser la poignée de contrôle située à droite de cette dernière vers le port RecevoirFacture.

    L'Assistant Communication XML s'ouvre.

  2. Sur la page Assistant Communication XML, cliquez sur Recevoir, puis sur Suivant.

  3. Sur la page Informations sur le message, vérifiez que Créer un message est sélectionné.

  4. Dans la zone Nom du message, tapez CommonInvoice et cliquez sur Suivant.

  5. Sur la page Informations sur l'interprétation XML, vérifiez que Recevoir les messages XML de la file d'attente est sélectionné et cliquez sur Suivant.

  6. Sur la page Informations sur les types de messages, dans la zone Type de message, tapez CommonInvoice et cliquez sur Suivant.

  7. Sur la page Informations sur la spécification du message, cliquez sur Terminer.

Passez à Liaison des services d'échanges BizTalk.


Liaison des services d'échanges BizTalk

Cette procédure consiste à ajouter la forme BizTalk Messaging au schéma et à utiliser l'Assistant Liaison d'Échanges BizTalk pour nommer le port et spécifier l'envoi des documents plutôt que leur réception. La forme Échanges BizTalk représente les services d'échanges BizTalk utilisés pour l'échange des messages entre les services d'orchestration BizTalk Server et les services d'échanges BizTalk.

Cette procédure consiste à lier un service d'échanges BizTalk au schéma de la planification XLANG. Vous allez également identifier le canal des services d'échanges BizTalk qui permet de transformer la facture en paiement. Pour plus d'informations, voir Utilisation de la forme Échanges BizTalk.

Pour lier les services d'échanges BizTalk

  1. Faites glisser la forme Message Queuing du stencil Implémentation situé dans la colonne la plus à droite vers la page Processus professionnels.

    Positionnez la forme BizTalk Messaging de sorte qu'elle soit alignée horizontalement sur l'action EnvoyerPaiement.

    L'Assistant Liaison d'Échanges BizTalk s'ouvre.

  2. Sur la page Assistant Liaison d'Échanges BizTalk, vérifiez que Créer un port est sélectionné.

  3. Dans la zone Créer un port, tapez EnvoyerPaiement et cliquez sur Suivant.

  4. Sur la page Direction de la communication, vérifiez que Envoyer est sélectionné et cliquez sur Suivant.

  5. Sur la page Informations sur le canal statique ou dynamique, vérifiez que Canal statique est sélectionné.

  6. Dans la zone Entrez le nom d'un canal connu pré-existant, tapez Canal de la facture en paiement et cliquez sur Terminer.

    Notez que Canal de la facture en paiement a été créé dans le module 3.

Passez à Définition des propriétés de message des services d'échanges BizTalk.


Définition des propriétés de message des services d'échanges BizTalk

Cette procédure consiste à utiliser l'Assistant Communication XML pour faciliter la communication entre l'action EnvoyerPaiement et le port EnvoyerPaiement.

  1. Faites glisser la poignée de contrôle située à droite de l'action EnvoyerPaiement vers le port EnvoyerPaiement.

    L'Assistant Communication XML s'ouvre.

  2. Sur la page Assistant Communication XML, cliquez sur Suivant.

  3. Sur la page Informations sur le message, cliquez sur Ajouter une référence à un message existant, cliquez sur CommonInvoice, puis sur Suivant.

  4. Sur la page Informations sur l'interprétation XML, vérifiez que Envoyer des messages XML à la file d'attente est sélectionné et cliquez sur Suivant.

  5. Sur la page Informations sur les types de messages, cliquez sur Suivant.

  6. Sur la page Informations sur la spécification du message, cliquez sur Terminer.

Passez à Enregistrement du schéma de planification XLANG terminé.


Enregistrement du schéma de planification XLANG terminé

  1. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer un schéma de planification XLANG sous s'affiche.

  2. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

  3. Dans la zone Nom du fichier, tapez Acheteur2 et cliquez sur Enregistrer.

Passez à Compilation du schéma de planification XLANG terminé.


Compilation du schéma de planification XLANG terminé

Pour plus d'informations sur la compilation d'un schéma de planification XLANG en planification XLANG exécutable, voir Compilation des planifications XLANG.

  1. Dans le menu Fichier, cliquez sur Créer XLANG Acheteur2.skx.

    La boîte de dialogue Enregistrer la planification XLANG vers apparaît.

  2. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

  3. Dans la zone Nom du fichier, tapez Acheteur2 et cliquez sur Enregistrer.

    Le schéma de planification XLANG obtenu doit apparaître comme dans l'illustration suivante.

    Schéma de planification XLANG

  4. Dans le menu Fichier, cliquez sur Quitter.

Passez à Exécution de la planification XLANG terminée.


Exécution de la planification XLANG terminée

Vous avez terminé la configuration d'une solution d'approvisionnement automatisée inter-entreprises. Vous pouvez maintenant exécuter l'application qui active la planification XLANG.

Cette procédure consiste à utiliser l'application ExecuteTutorial qui active la planification XLANG en envoyant une requête d'ordre d'achat dans la file d'attente de messages contrôlée.

Pour exécuter la planification XLANG

  1. Recherchez le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server.

  2. Double-cliquez sur ExecuteTutorial.exe. Cette application permet d'activer la planification XLANG à l'aide d'un moniker.

    L'application ExecuteTutorial s'ouvre.

  3. Cliquez sur Browse for Schedule.

    Raccourci

    • Si un serveur BizTalk Server et tous ses composants sont installés sur le lecteur C, vous pouvez utiliser la planification XLANG existante. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution et passez à l'étape 5.
  4. Si vous avez créé la planification XLANG Acheteur2, accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab.

  5. Cliquez sur la planification XLANG Acheteur2.skx, puis sur Ouvrir.

  6. Cliquez sur Browse for Data File et accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\SampleData.

  7. Cliquez sur POReqAccept.xml, puis cliquez sur Ouvrir.

  8. Cliquez sur Start XLANG Schedule.

    Dans la mesure où le total est inférieur à 1000 EUR, la requête d'ordre d'achat est approuvée. Un message s'affiche pour indiquer que l'application a transmis les données au moteur XLANG Scheduler. À ce stade, l'application est terminée. Un second message vous informe que la requête d'ordre d'achat a été approuvée. Cliquez sur OK pour fermer les messages.

  9. Cliquez sur End pour fermer l'application ExecuteTutorial.

  10. Accédez au dossier C:\TutorialFiles\Seller.

    Il contient le fichier de paiement PaymentXXXX.xml, où XXXX est un ensemble unique de numéros. Double-cliquez sur le fichier pour l'ouvrir dans Microsoft Internet Explorer.

Vous avez soumis une requête d'ordre d'achat qui a été approuvée et envoyée au vendeur. L'ordre d'achat a été complété et une facture a été émise. Lorsque la facture a été reçue, un message de paiement a été publié sur le système du vendeur.

Passez à Module 4 - Résumé.


Module 4 - Résumé

Ce module vous a appris comment procéder pour :

  • Ajouter des actions de facture et de paiement. Pour plus d'informations, voir Connexion de formes.

  • Implémenter un port d'échanges à l'aide des services d'échanges BizTalk. Pour plus d'informations sur l'implémentation d'un port d'échanges à l'aide des services d'échanges BizTalk, voir Utilisation de la forme Échanges BizTalk.

  • Compiler et exécuter la planification XLANG terminée. Pour plus d'informations, voir Compilation des planifications XLANG et Exécution des planifications XLANG.

Les zones mises en surbrillance dans la figure suivante illustrent les procédures que vous avez effectuées dans ce module.

Passez à Didacticiel - Résumé.

Voir aussi

Conception des orchestrations BizTalk


Didacticiel - Résumé

Dans ce didacticiel, vous avez configuré Microsoft BizTalk Server 2002 pour la définition et l'exécution d'un processus d'approvisionnement automatisé inter-entreprises.

L'illustration suivante représente le flux de données dans BizTalk Server lors de l'exécution de la planification XLANG Acheteur2 à la fin du module 4.

Flux de données

Nous avons analysé le fonctionnement des composants et des services BizTalk Server pour l'intégration de processus professionnels asynchrones de longue durée, au sein des entreprises et entre elles.

Vous avez également appris à :

  • Utiliser le Concepteur d'orchestration BizTalk pour modéliser des processus professionnels en créant un schéma de planification XLANG.

  • Utiliser le Gestionnaire d'échanges BizTalk pour créer des organisations, des canaux, des ports d'échanges et des définitions de document.

  • Utiliser l'Éditeur BizTalk pour créer des spécifications.

  • Utiliser le Mappeur BizTalk pour créer des mappages.

  • Compiler et exécuter une planification XLANG.

Vous avez suivi le didacticiel avec succès.

Ressources supplémentaires

Pour plus d'informations détaillées sur la création des composants auxiliaires utilisés dans ce didacticiel, voir l'Annexe : création de composants auxiliaires.

Pour obtenir une présentation générale des concepts fondamentaux associés aux processus et tâches de création d'un processus d'approvisionnement automatisé inter-entreprises avec BizTalk Server, voir Leçons sur BizTalk Server 2002.

Pour visualiser un exemple d'utilisation de plusieurs nouvelles fonctionnalités de BizTalk Server 2002, voir Exemple d'approvisionnement électronique. BizTalk Server 2002 inclut, en autres, les nouvelles fonctionnalités suivantes :

  • Activation rapide des partenaires à l'aide de l'Assistant BizTalk SEED

  • Fonctionnalités de déploiement de Application Center

  • Fonctions de contrôle avancées à l'aide de Microsoft Operations Manager (MOM)

  • Nouvelle corrélation XLANG à l'aide de files d'attente communes au lieu de files d'attente par instance


Annexe : création de composants auxiliaires

Dans cette annexe, vous allez apprendre à créer des composants auxiliaires qui fonctionnent avec Microsoft BizTalk Server 2002 pour traiter des données. Chaque composant, son rôle et sa relation dans le processus sont décrits en détail.

Important

  • Microsoft Visual Basic 6.0 est nécessaire pour exécuter certaines procédures de l'annexe.

Plus particulièrement, vous allez créer :

  • une application sur le système de l'acheteur qui active une planification XLANG et envoie une requête d'ordre d'achat à une file d'attente de messages liée à la planification XLANG qui contrôle le flux des messages dans le système de l'acheteur ;

  • un composant de script Windows (WSC) sur le système de l'acheteur qui accepte l'état d'approbation ou de refus d'une requête d'ordre d'achat de la planification XLANG ; si la requête est accordée, ce composant affiche un message d'approbation et écrit la requête d'ordre d'achat dans un répertoire de fichiers local, d'où les services d'échanges BizTalk du système de l'acheteur l'extrait. Si la requête est refusée, le composant WSC affiche un message de refus et la planification prend fin ;

  • un composant d'intégration de l'application sur le système du vendeur qui génère une facture basée sur les données de l'ordre d'achat de l'acheteur.

Passez à Création de l'application.


Création de l'application

Dans cette rubrique, vous allez créer une application qui active une planification XLANG et place une requête d'ordre d'achat dans une file d'attente. Cette application permet de tester l'implémentation de la planification XLANG et la configuration du Gestionnaire d'échanges BizTalk.

Pour terminer cet atelier, modifiez le code dans l'exemple de projet. Vous allez prendre en compte le code permettant d'activer la planification XLANG et de placer un message dans une file d'attente. Le code auxiliaire vous est fourni.

Chaque étape correspond à un segment de code. Examinez les blocs de commentaires identiques à l'exemple ci-dessous :

''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''
'To Do: Step A
''''''''''''''''''''''''''''''''''''''''''''''''''''''''''''

Ce code est suivi de lignes contenant des points d'interrogation (?) qui identifient les espaces réservés dans lesquels vous devez effectuer une modification. Remplacez les points d'interrogation par le code approprié pour terminer l'atelier. Exemple :

Private g_MSMTxDisp As ?

doit être remplacé par :

Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenser

Remarque

  • Ces lignes de code contiennent des commentaires. Veillez à supprimer la marque de commentaire au début des lignes que vous voulez modifier. Les étapes ne sont pas nécessairement classées dans la fenêtre de code.

Passez à Ouverture de l'application.


Ouverture de l'application

  1. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

  2. Double-cliquez sur ExecuteTutorial.vbp.

Passez à Ajout des références requises à l'application.


Ajout des références requises à l'application

Cette procédure consiste à permettre à l'application d'implémenter les DLL requises pour utiliser Message Queuing, XML et Scripting Runtime.

  1. Dans le menu Projet, cliquez sur Références.

  2. Sélectionnez Microsoft Message Queue 2.0 Object Library.

    Le chemin complet de cette bibliothèque de types est \WINNT\System32\MQOA.dll.

  3. Sélectionnez Microsoft Scripting Runtime.

    Le chemin complet de cette DLL est \WINNT\System32\Scrrun.dll.

  4. Sélectionnez Microsoft XML, v 3.0.

    Le chemin complet de cette DLL est \WINNT\System32\msxml3.dll.

  5. Cliquez sur OK.

Passez à Définition et initialisation des objets Message Queue.


Définition et initialisation des objets Message Queue

Cette procédure consiste à ajouter le code approprié pour utiliser les bibliothèques de types choisies. Les étapes portant une lettre dans la liste ci-dessous correspondent à celles du code fourni.

  1. Dans la fenêtre Projet, développez Formulaires, puis cliquez sur Formulaire1 (ExecuteTutorial.frm).

  2. Dans le menu Affichage, cliquez sur Code.

  3. Dans la section Général Déclarations de l'étape A du code, créez les objets Message Queue comme indiqué dans l'exemple suivant :
    Private g_MSMTxDisp As MSMQ.MSMQTransactionDispenserPrivate g_MSMTxDisp As MSMQ.MSMQTransactionDispenser
Private g_MSMQQueue As MSMQ.MSMQQueuePrivate g_MSMQQueue As MSMQ.MSMQQueue
Private g_MSMQInfo As MSMQ.MSMQQueueInfoPrivate g_MSMQInfo As MSMQ.MSMQQueueInfo
  4. Dans la section des événements Form_Load de l'étape B du code, initialisez les objets Message Queue comme indiqué dans l'exemple suivant.
    Set g_MSMQInfo = CreateObject("MSMQ.MSMQQueueInfo")Set g_MSMQInfo = CreateObject("MSMQ.MSMQQueueInfo")
Set g_MSMTxDisp = CreateObject("MSMQ.MSMQTransactionDispenser")Set g_MSMTxDisp = CreateObject("MSMQ.MSMQTransactionDispenser")

Passez à Ajout de code pour placer des données dans une file d'attente.


Ajout de code pour placer des données dans une file d'attente

Cette procédure consiste à ajouter un nouveau sous-programme appelé ExecuteMSMQ. Celui-ci est appelé par l'événement cmdRunSked_Click. Vous ajoutez le code pour appeler ce sous-programme dans la procédure suivante.

  • Placez le code suivant à la fin de la fenêtre de code de votre projet à l'étape C :
    Public Sub ExecuteMSMQ(ByVal strQueuePath As String, DataToQueue As String)
    Dim QueueMsg As New MSMQMessage

    Dim strData As String
    Dim fSend As Boolean
    Dim txt As TextStream
    Dim mybyte() As Byte

    g_MSMQInfo.FormatName = strQueuePath
    Set g_MSMQQueue = g_MSMQInfo.Open(MQ_SEND_ACCESS, MQ_DENY_NONE)
    mybyte = StrConv(DataToQueue, vbFromUnicode)
    QueueMsg.Body = DataToQueue

    Set MSMQTx = g_MSMTxDisp.BeginTransaction
    QueueMsg.send g_MSMQQueue, MSMQTx
    MSMQTx.Commit

    Set QueueMsg = Nothing
    Set MSMQTx = Nothing

End Sub

Passez à Ajout de code pour activer la planification XLANG et appeler ExecuteMSMQ.


Ajout de code pour activer la planification XLANG et appeler ExecuteMSMQ

Cette procédure consiste à ajouter du code à l'événement cmdRunSked_Click qui active la planification XLANG et appelle le code qui envoie un message dans une file d'attente.

  1. Dans la section des événements cmdRunSked_Click de l'étape D du code, appelez ExecuteMSMQ, comme indiqué dans le code suivant :
    ExecuteMSMQ "DIRECT=OS:.\private$\ReceivePOReq", objfs.OpenTextFile(txtData.Text, ForReading).ReadAll
  2. Dans la section des événements cmdRunSked_Click de l'étape E du code, appelez GetObject pour instancier la planification XLANG par moniker, comme indiqué dans le code suivant :
    Set SendPAQ = GetObject(txtSked.Text)

Passez à Enregistrement et compilation de l'application.


Enregistrement et compilation de l'application

Cette procédure consiste à enregistrer et à compiler l'application.

  1. Dans le menu Fichier, cliquez sur Enregistrer le Projet.

  2. Dans le menu Fichier, cliquez sur Créer ExecuteTutorial.exe.

    La boîte de dialogue Créer le projet apparaît.

  3. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server et cliquez sur OK.

Vous pouvez maintenant lancer l'application pour exécuter la planification de l'acheteur des modules 1 et 4.

Passez à Création du composant de script Windows (WSC).


Création du composant de script Windows (WSC)

Dans cette rubrique, vous allez créer un composant de script Windows lié à la planification XLANG. Le rôle de ce composant est d'afficher un message indiquant l'état d'approbation ou de refus de la requête d'ordre d'achat, et d'écrire éventuellement la requête d'ordre d'achat dans un fichier local si elle est approuvée.

Passez à Ajout d'un script pour enregistrer le composant.


Ajout d'un script pour enregistrer le composant

Cette procédure consiste à ajouter un script permettant d'enregistrer le composant dans un fichier.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Accessoires, puis cliquez sur Bloc-notes.

  2. Ajoutez le script suivant :
    <?xml version="1.0"?>
<component>
<?component error="true" debug="true"?>
<registration
     description="PORequestApproval"
     progid="BTSTutorial.PORequestApproval"
     version="1.00"
     classid="{2938621b-40fc-48e2-827c-bed74e21a538}"
>
</registration>

    Étant donné que vous utilisez le même identificateur de classe que le composant prédéfini, l'ancien composant est remplacé dans le Registre.

Passez à Ajout d'un script pour implémenter des méthodes.


Ajout d'un script pour implémenter des méthodes

Ce composant fournit trois méthodes. La première méthode envoie à l'utilisateur un état d'approbation sous la forme d'un message. La deuxième envoie à l'utilisateur un état de refus, également sous la forme d'un message. Le choix de la décision relative à la méthode appelée est dicté par la règle de décision du schéma de planification XLANG. La dernière méthode écrit l'ordre d'achat dans un fichier local si la requête a été approuvée.

  1. Ajoutez les trois signatures de méthode à la fin du fichier :
    <public>
     <method name="SendApproval">
          <PARAMETER name="Document"/>
     </method>
     <method name="SendDenial">
          <PARAMETER name="Document"/>
     </method>
     <method name="WriteToFile">
          <PARAMETER name="Document"/>
          <PARAMETER name="FileName"/>
     </method>
</public>
  2. Ajoutez le script qui implémente les méthodes jusqu'à la fin du fichier :
    <implements type="Behavior" id="Behavior"/>

<script language="VBScript">
<![CDATA[

function SendApproval(Document)
     MsgBox "Scheduler Engine Accepted document :" + vbcrlf + + vbcrlf + Document, 0, "Document Approval Received"
end function

function SendDenial(Document)
     MsgBox "Scheduler Engine Denied document :" + vbcrlf + + vbcrlf + Document, 0, "Document Denied"
end function

function WriteToFile(Document, FileName)
     dim objFileSys, strTimeNow

     if FileName = "" then
            FileName = "c:\TutorialFiles\Buyer\POReq*.xml"
     end if

'Generate a Unique Number used to generate unique files using a mask
   strTimeNow = left(Replace(CStr(FormatDateTime(Now(), 3)),":",""), 6)

'Create File System Object
     Set objFileSys = CreateObject("Scripting.FileSystemObject")

'Create the Specified file, write the document data and close
     Set filestream = objFileSys.CreateTextFile(Replace(FileName, "*", strTimeNow), False)
     filestream.writeline Document
      filestream.close
end function

]]>
</script>

</component>
  3. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer sous apparaît.

  4. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab sur le lecteur où est installé BizTalk Server.

  5. Dans la zone Nom de fichier, tapez PORequestApproval.wsc.

  6. Dans la zone Type de fichier, cliquez sur Tous les fichiers, puis sur Enregistrer.

  7. Fermez le Bloc-notes.

  8. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POReqApproval\Lab.

  9. Cliquez avec le bouton droit sur PORequestApproval.wsc et cliquez sur Inscrire.

Ce composant peut être remplacé par le composant de script Windows (WSC) prédéfini dans le module 1. Pour utiliser ce dernier, vous devez supprimer la liaison WSC existante à partir de la planification et créer une nouvelle liaison de composant de script Windows qui pointe sur votre composant.

Passez à Suppression du composant de script Windows.


Suppression du composant de script Windows

Cette procédure consiste à supprimer le composant de script Windows du schéma de planification XLANG Acheteur2. Vous pouvez lier de nouveau le composant que vous avez créé.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Concepteur d'Orchestration BizTalk.

  2. Pour utiliser le schéma créé dans le module 4, ouvrez le fichier Acheteur2.skv contenu dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Lab sur le lecteur où est installé BizTalk Server.

    Pour utiliser le schéma Acheteur2 existant, ouvrez le fichier Acheteur2.skv contenu dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution.

  3. Cliquez sur la forme Composant de script et appuyez sur SUPPR.

  4. Cliquez sur l'onglet Données.

  5. Supprimez les messages SendApproval, SendDenial et WritetoFile.

Vous êtes maintenant prêt à utiliser votre composant de script Windows dans la planification. Procédez comme suit :

  1. Implémentez un port sur Acheteur2.skv à l'aide de votre composant de script Windows.

    Pour un exemple, voir Implémentation d'un port à l'aide d'un composant de script. Cependant, utilisez votre composant et non celui de la procédure.

  2. Définissez la communication de la méthode d'implémentation du port.

    Pour un exemple, voir Définition des propriétés de message du composant de script.

  3. Définissez le flux de données pour le port.

    Pour un exemple, voir Définition du flux de données.

  4. Enregistrez le fichier XLANG.

    Pour un exemple, voir Enregistrement du schéma de planification XLANG.

  5. Pour tester votre composant, exécutez l'application ExecuteTutorial qui se trouve dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk Server.

Passez à Création du composant d'intégration de l'application (AIC).


Création du composant d'intégration de l'application (AIC)

Dans cette rubrique, vous allez créer un nouveau composant d'intégration de l'application appelé POtoINVAIC qui convertit un document de type ordre d'achat en document de type facture à l'aide de MSXML DOM.

Passez à Création d'un projet DLL ActiveX pour le composant d'intégration de l'application.


Création d'un projet DLL ActiveX pour le composant d'intégration de l'application

  1. Démarrez Microsoft Visual Basic 6.0.

  2. Dans la boîte de dialogue Nouveau projet, cliquez sur l'onglet Nouveau, sur ActiveX DLL, puis sur Ouvrir.

    Un nouveau projet est créé pour votre composant, appelé Projet 1.

  3. Pour attribuer un nom plus significatif au projet et au contrôle, dans la fenêtre de l'arborescence du projet, cliquez sur Projet1 et, dans la fenêtre des propriétés, remplacez la propriété (Nom) par POtoInvAICLab.

  4. Dans la fenêtre de l'arborescence du projet, cliquez sur Class1(Class1) et, dans la fenêtre des propriétés, remplacez la propriété (Nom) par ConvertPOtoInvoice.

Passez à Ajout des références appropriées au composant d'intégration de l'application.


Ajout des références appropriées au composant d'intégration de l'application

Cette procédure consiste à permettre au composant d'implémenter les interfaces requises par BizTalk Server 2002.

  1. Dans le menu Projet, cliquez sur Références.

  2. Cliquez sur Microsoft BizTalk Server Application Interface Components 1.0 Type Library.

    Le chemin complet de cette bibliothèque de types est \Program Files\Microsoft BizTalk Server\btscomplib.tlb.

  3. Sélectionnez Microsoft BizTalk Server Interchange 1.0 Type Library.

    Le chemin complet de cette bibliothèque de types est \Program Files\Microsoft BizTalk Server\cisapi.tlb.

  4. Sélectionnez Microsoft Scripting Runtime.

    Le chemin complet de cette DLL est \WINNT\System32\Scrrun.dll. Utilisez cette bibliothèque pour créer un objet système de fichiers et ouvrir un flux de texte utilisé pour écrire un ordre d'achat sur le disque.

  5. Sélectionnez Microsoft XML, v 3.0.

    Le chemin complet de cette DLL est \WINNT\System32\msxml3.dll.

  6. Cliquez sur OK.

Passez à Implémentation de l'interface appropriée.


Implémentation de l'interface appropriée

Pour que BizTalk Server reconnaisse un composant comme composant d'intégration de l'application, il doit implémenter l'une des deux interfaces. Pour les besoins de ce didacticiel, vous allez implémenter l'interface IBTSAppIntegration.

  1. Dans la fenêtre Projet, cliquez sur le module de la classe ConvertPOtoInvoice.

  2. Dans le menu Affichage, cliquez sur Code.

  3. Ajoutez la ligne de code suivante en haut de la fenêtre de code pour vous assurer que toutes les variables sont explicitement déclarées afin de minimiser les erreurs simples :
    Option Explicit
  4. Implémentez l'interface requise en ajoutant la ligne de code suivante après l'instruction Option Explicit :
    Implements IBTSAppIntegration

Passez à Définition et initialisation des objets de classe.


Définition et initialisation des objets de classe

Cette procédure consiste à ajouter le code approprié pour définir les objets de classe MSXML permettant de créer les fichiers XML à l'aide de DOM. Vous allez créer une variable de chaîne pointant sur la feuille de style du projet qui convertit un ordre d'achat en facture.

  1. Placez le code suivant en dessous de l'instruction Implements IBTSAppIntegration :
    'Class Object Defines
Private m_DOMCommonPO As MSXML2.DOMDocument
Private m_DOMStylesheet As MSXML2.DOMDocument
Private m_objSubmit As BTSInterchangeLib.Interchange

'Embedded Project Stylesheet to Convert CommonPO to CommonInvoice
Private m_strStylesheet As String
  2. Ajoutez le code suivant pour initialiser les objets XML DOM qui vont convertir l'ordre d'achat en facture, ainsi que l'objet Interchange qui soumet le document de facture final à BizTalk Server :
    Private Sub Class_Initialize()
'Create DOM/Interchange Objects
    Set m_DOMCommonPO = New MSXML2.DOMDocument
    Set m_DOMStylesheet = New MSXML2.DOMDocument
    Set m_objSubmit = New BTSInterchangeLib.Interchange

'Configure DOM Objects to be Synchronous
    m_DOMCommonPO.async = False
    m_DOMStylesheet.async = False

'Fill Stylesheet Embedded String
    m_strStylesheet = m_strStylesheet + ""

End Sub

Passez à Implémentation de la méthode d'interface.


Implémentation de la méthode d'interface

La méthode ProcessMessage de l'interface IBTSAppIntegration prend en compte un document entrant d'ordre d'achat XML commun en provenance de BizTalk Server et interprète les données pour les convertir en un document de facture XML commun. Le document de facture commun est ensuite renvoyé à BizTalk Server. Le but est de simuler un système principal qui reçoit des ordres d'achat et renvoie éventuellement une facture correspondant à ces derniers.

  1. Ajoutez les variables de définition de fonction et de dimension, comme dans le code suivant :
    Private Function IBTSAppIntegration_ProcessMessage( _
                                ByVal bstrDocument As String) As String
    Dim bstrInvoiceDocument As String
    Dim objScripting As New Scripting.FileSystemObject
'Initialize ProcessMessage to null
    IBTSAppIntegration_ProcessMessage = ""
  2. Ajoutez le code pour charger les données reçues dans un objet DOM et s'assurer que le format est correct en ajoutant le code suivant en dessous de l'instruction IBTSAppIntegration_ProcessMessage :
        m_DOMCommonPO.loadXML bstrDocument

    If m_DOMCommonPO.parseError.errorCode <> 0 Then 'The data was not valid XML
'Raised errors are not caught in the component, and will be sent back to BizTalk Server
        Err.Raise m_DOMCommonPO.parseError.errorCode, "AICSample.ConvertPOToInvoice Component", _
            "The provided document was not valid XML and could not be processed because:" + _
            vbCrLf + vbCrLf + m_DOMCommonPO.parseError.reason + vbCrLf + " on line: " + _
            CStr(m_DOMCommonPO.parseError.Line) + vbCrLf + "at position: " + _
            CStr(m_DOMCommonPO.parseError.linepos)
    End If
  3. Ajoutez le code pour utiliser le fichier de ressource contenant le code XSL qui convertit un ordre d'achat en facture, en ajoutant le code suivant sous l'instruction End If :
        If m_strStylesheet = "" Then
        m_strStylesheet = StrConv(LoadResData(101, "CUSTOM"), vbUnicode)

    End If
    m_DOMStylesheet.loadXML m_strStylesheet
    bstrInvoiceDocument = m_DOMCommonPO.transformNode(m_DOMStylesheet)

    If bstrInvoiceDocument = "" Then ' Mapping Failed Raise an Error
        Err.Raise vbObjectError + 100, "AICSample.ConvertPOToInvoice Component", _
            "The provided CommonPO document could not be translated into a Common Invoice " + _
            "as the map produced blank output."
    End If
  4. Ajoutez le code pour soumettre le document de facture aux services d'échanges BizTalk en ajoutant le code suivant sous l'instruction End If :
    IBTSAppIntegration_ProcessMessage = m_objSubmit.Submit(BIZTALK_OPENNESS_TYPE_NOTOPEN, bstrInvoiceDocument, , , "Contoso on Seller", , "Northwind Traders on Seller")

End Function

    L'appel de soumission renvoie l'identification de soumission qui n'est pas utilisée dans le cas présent.

Passez à Clôture des objets de classe.


Clôture des objets de classe

Pour s'assurer que tous les objets sont libérés de la mémoire lorsque la classe est terminée, ajoutez ce code à la fin de votre projet :

Private Sub Class_Terminate()
    Set m_DOMCommonPO = Nothing
    Set m_DOMStylesheet = Nothing
    Set m_objSubmit = Nothing
End Sub

Passez à Création du fichier de ressources.


Création du fichier de ressources

Cette procédure consiste à ajouter le fichier de ressource contenant le XSL qui permet de transformer un ordre d'achat en une facture.

  1. Dans le menu Compléments, cliquez sur Gestionnaire de compléments.

    La boîte de dialogue Gestionnaire de compléments apparaît.

  2. Cliquez sur Éditeur de ressources VB 6.

  3. Dans la zone Comportement, cliquez sur Charger/Décharger pour charger l'Éditeur de ressources, cliquez sur Charger au Démarrage, puis sur OK.

  4. Dans le menu Outils, cliquez sur Éditeur de ressources.

  5. Cliquez sur l'icône Ajouter une ressource personnalisée de la barre d'outils.

    La boîte de dialogue Ouvrir une ressource personnalisée apparaît.

  6. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab sur le lecteur où est installé BizTalk Server, cliquez sur POtoINVAIC.txt, puis sur Ouvrir.

    Attention

    • Vérifiez que l'identificateur de votre ressource est 101. Cet identificateur comporte la valeur 101 par défaut pour la première ressource que vous créez, mais ce nombre s'incrémente de un si vous la modifiez. Pour attribuer la valeur 101 à l'identificateur de la ressource, cliquez avec le bouton droit sur l'identificateur et cliquez sur Propriétés. Dans la zone ID, tapez 101.
  7. Cliquez sur l'icône Enregistrer.

    La boîte de dialogue Enregistrer le fichier de ressources sous apparaît.

  8. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab.

  9. Dans la zone Nom de fichier, tapez POtoInvAICLab.RES et cliquez sur Enregistrer.

  10. Fermez l'Éditeur de ressources.

Passez à Création du composant et définition de la compatibilité binaire.


Création du composant et définition de la compatibilité binaire

Étant donné que vous créez un nouveau composant, vous devez le construire à ce stade, puis définir les propriétés du projet pour la compatibilité binaire avec la nouvelle DLL créée. La compatibilité binaire permet de s'assurer que chaque fois que vous compilez la DLL, vous ne générez pas un identificateur global unique (GUID) pour l'objet.

  1. Dans le menu Fichier, cliquez sur Enregistrer le projet sous.

    La boîte de dialogue Enregistrer le projet sous apparaît.

  2. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab sur le lecteur où est installé BizTalk Server.

  3. Dans la zone Nom de fichier, tapez ConvertPOtoInvoice.cls et cliquez sur Enregistrer.

    La boîte de dialogue Enregistrer le projet sous apparaît.

  4. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab.

  5. Dans la zone Nom de fichier, tapez POToInvAICLab et cliquez sur Enregistrer.

  6. Dans le menu Fichier, cliquez sur Make POToInvAICLab.dll.

    La boîte de dialogue Créer le projet apparaît.

  7. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab et cliquez sur OK.

  8. Dans le menu Projet, cliquez sur Propriétés de POToInvAICLab.

  9. Cliquez sur l'onglet Composant.

  10. Cliquez sur Compatibilité binaire.

  11. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POtoInvoice\Lab.

  12. Cliquez sur POToInvAICLab.dll, puis sur Ouvrir.

  13. Cliquez sur OK.

Passez à Enregistrement du composant d'intégration de l'application.


Enregistrement du composant d'intégration de l'application

Cette procédure consiste à enregistrer le composant de script Windows pour qu'il soit reconnu par BizTalk Server. Celui-ci examine la liste des composants COM enregistrés, puis il les interroge afin de déterminer celui qui implémente l'interface IBTSAppIntegration ou IPipelineComponent. Tous les composants qui répondent à ce critère sont affichés dans une liste de composants dans le Gestionnaire d'échanges BizTalk.

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Outils d'administration.

  3. Double-cliquez sur Services de composant.

    La console Services de composants s'affiche.

  4. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  5. Cliquez avec le bouton droit sur Applications COM+, pointez sur Nouveau et cliquez sur Application.

    L'Assistant Installation Application COM s'ouvre.

  6. Sur la page Bienvenue dans l'Assistant Installation Application COM, cliquez sur Suivant.

  7. Sur la page Installer ou créer une nouvelle application, cliquez sur Créer une application vide.

  8. Dans la zone Entrez un nom pour la nouvelle application, tapez POToInvAICLab.

  9. Dans la zone Type d'activation, cliquez sur Application serveur, puis sur Suivant.

  10. Dans la zone Compte, cliquez sur Utilisateur Interactif : l'utilisateur actuellement connecté, puis sur Suivant.

  11. Cliquez sur Terminer.

  12. Dans l'arborescence de la console, développez Applications COM+ et développez le nouveau module que vous avez créé, appelé POToInvAICLab.

  13. Cliquez sur Composants.

  14. Accédez au dossier \Program Files\Microsoft BizTalk Server\Tutorial\Components\POToInvoice\Lab sur le lecteur où est installé BizTalk Server.

  15. Faites glisser POToInvAICLab.dll dans le dossier Composants des Services de composants.

  16. Fermez Services de composants.

Vous pouvez maintenant reconfigurer le port pour utiliser le nouveau composant d'intégration de l'application, en procédant comme suit :

Remarque

  • L'utilisateur qui est connecté doit être membre du groupe d'administrateurs BizTalk Server et doit rester connecté pendant l'exécution de ce scénario.
  1. Ouvrez le Gestionnaire d'échanges BizTalk.

  2. Dans la zone Rechercher, cliquez sur Ports d'échanges, puis sur Rechercher.

  3. Dans la liste Nom du port d'échanges, double-cliquez sur Port to Contoso via AIC.

  4. Sur la page Informations générales, cliquez sur Suivant.

  5. Sur la page Organisation de destination, dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal apparaît.

  6. Cliquez sur Parcourir.

  7. Dans la liste Composants disponibles, cliquez sur POToInvAICLab ConvertPOtoInvoice, puis sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue Transport principal et cliquez sur Suivant.

  9. Testez votre composant en exécutant l'application qui se trouve dans le dossier \Program Files\Microsoft BizTalk Server\Tutorial\Schedule\Solution sur le lecteur où est installé BizTalk.


Leçons sur BizTalk Server 2002

Le contenu de ces leçons vous apprend comment Microsoft® BizTalk™ Server 2002 peut vous aider, dans le cadre de votre entreprise, à échanger une grande variété de documents commerciaux avec vos partenaires, ainsi qu'à intégrer des processus professionnels et des applications en interne.

Ces leçons expliquent tous les concepts fondamentaux liés à BizTalk Server et fournissent des informations qui vont vous aider à comprendre les outils et les processus dont vous avez besoin pour commencer à créer des solutions avec BizTalk Server.

Remarque

  • Pour savoir comment configurer les processus BizTalk Server en suivant un didacticiel, reportez-vous au Didacticiel de BizTalk Server 2002. Le Didacticiel de BizTalk Server vous apprend à utiliser l'Éditeur BizTalk, le Mappeur BizTalk, le Gestionnaire d'échanges BizTalk, la console Administration de BizTalk Server et le Concepteur d'Orchestration BizTalk pour configurer un processus d'approvisionnement automatisé interentreprises. Pour plus d'informations générales sur BizTalk Server, voir Introduction à Microsoft BizTalk Server 2002.

Conditions

Pour utiliser ce didacticiel, vous devez installer BizTalk Server et tous ses composants sur l'unité C de votre disque. Il est possible d'exécuter les fichiers à partir d'une autre unité de disque et d'un autre répertoire mais dans ce cas, des modifications importantes doivent être apportées aux fichiers source.

Avant de commencer ce didacticiel, vous devez également copier le répertoire LearnBizTalk sur l'unité C de votre disque :

  1. Copiez le répertoire \Program Files\Microsoft BizTalk Server\SDK\LearnBizTalk sur C:\LearnBizTalk.

  2. Accédez au dossier C:\LearnBizTalk\Documents.

  3. Tout en appuyant sur la touche CTRL, sélectionnez ReqToApprove.xml et ReqToDecline.xml.

  4. Cliquez avec le bouton droit sur cette sélection, puis cliquez sur Propriétés.

  5. Sous l'onglet Général, dans la zone Attributs, désactivez la case à cocher Lecture seule.

  6. Cliquez sur OK.

Important

  • Le répertoire C:\LearnBizTalk\Scripts contient plusieurs scripts. Pour exécuter ces fichiers de script, double-cliquez dessus. Ces scripts effectuent des modifications de configuration dans votre installation de BizTalk Server, pour vous permettre de mettre en pratique les leçons. L'exécution de ces scripts peut prendre plusieurs minutes. Un message s'affiche à la fin de l'exécution de chaque script.

  • Une fois le didacticiel terminé, exécutez le script CleanUp.vbs pour supprimer toutes les modifications.

Sommaire

  • Leçon 1 : Introduction à BizTalk Server

  • Leçon 2 : Configuration des services d'échanges BizTalk

  • Leçon 3 : Conception des services d'orchestration BizTalk

  • Leçon 4 : Présentation de l'implémentation

  • Leçon 5 : Utilisation du Mappeur BizTalk

  • Leçon 6 : Envoi et réception de documents

  • Leçon 7 : Fin de la transaction


Leçon 1 : Introduction à BizTalk Server

Cette leçon présente BizTalk Server et le scénario utilisé dans toutes les leçons.

Elle aborde les sujets suivants :

  • Qu'est-ce que BizTalk Server ?

  • Pourquoi utiliser BizTalk Server ?

  • Pourquoi utiliser le langage XML ?

  • Solutions intégrées

  • Installation de BizTalk Server

  • Scénario

  • Exécution du scénario


Qu'est-ce que BizTalk Server ?

Microsoft BizTalk Server 2002 offre un environnement d'exécution et de développement qui coordonne des processus professionnels au sein d'une entreprise et entre plusieurs d'entre elles. BizTalk Server peut gérer des transactions qui sont exécutées pendant des semaines ou des mois.

Parmi les fonctionnalités offertes par BizTalk Server 2002 figurent notamment la possibilité de définir des spécifications de documents professionnels et le mode de transformation de ces documents lorsqu'ils sont transférés d'une application à l'autre, ainsi que la faculté de surveiller et d'enregistrer l'activité du serveur.

Le serveur fournit une passerelle standard pour l'envoi et la réception de documents sur Internet, de même qu'une gamme de services assurant l'intégrité, le transfert et la sécurité des données.

Passez à Pourquoi utiliser BizTalk Server ?


Pourquoi utiliser BizTalk Server ?

Dans les environnements professionnels actuels, il est impératif de concevoir une solution conforme aux protocoles et aux formats de documents couramment utilisés. Il est également important de savoir que cette solution permettra l'intégration de l'éventail de partenaires et d'applications professionnels le plus large, qu'elle fonctionnera en toute sécurité sur Internet et qu'elle évoluera en fonction des besoins de votre entreprise. Microsoft BizTalk Server 2002 est conçu pour répondre à ces besoins.

Actuellement, les exigences du marché international impliquent la nécessité de fonctionner de manière efficace, 24 heures sur 24 et sept jours sur sept. Les clients, plus exigeants, veulent désormais rester informés en temps réel, ce qui se traduit par une accélération du rythme des transactions commerciales et par la nécessité d'adopter des processus de prise de décision plus rapides. En outre, la dynamique des relations commerciales ayant évolué d'une manière très pointue, les clients et les partenaires comptent sur une adaptation rapide des entreprises.

Il faut également prendre en charge plusieurs applications sur une grande diversité de plates-formes, et s'intégrer aux partenaires commerciaux par le biais d'Internet, d'extranets, d'échanges interentreprises (B2B) et d'autres ressources. Il est nécessaire de conserver les investissements en matière de technologie de l'information, ce qui suppose la possibilité de continuer à prendre en charge les anciens systèmes et les réseaux EDI (Electronic Data Interchange), tels que X12 et EDIFACT. Enfin, et c'est peut-être le point le plus important, pour maintenir un niveau de compétitivité suffisant sur le marché actuel, vous devez être capable de créer des solutions rapidement, en faisant appel à la technologie et aux standards ouverts d'Internet, de sorte à garantir une interopérabilité maximale. Pour plus d'informations, voir Prise en charge des normes.

BizTalk Server utilise le langage XML en interne pour définir les données et la structure de vos documents commerciaux, mais il fait appel aux protocoles Internet standard, tels que HTTP(Hypertext Transfer Protocol) et SMTP (Simple Mail Transfer Protocol) pour transmettre ces documents à leurs destinataires ; vous pouvez ainsi communiquer à l'aide d'une grande variété d'applications et dans n'importe quel environnement, dans la mesure où ces applications prennent en charge les normes Internet. Vous pouvez envoyer des documents à BizTalk Server dans les formats suivants : XML (Extensible Markup Language), EDI ou fichier plat.

Passez à Pourquoi utiliser le langage XML ?


Pourquoi utiliser le langage XML ?

Pour échanger des documents dans un environnement dans lequel aucune des deux parties ne veut dépendre de la technologie utilisée par l'autre, les entreprises doivent choisir un langage commun dans lequel écrire ces documents. Ce langage commun est le langage XML (Extensible Markup Language).

L'utilisation du langage XML est un moyen souple pour créer des formats d'informations communs et pour partager des formats et des données sur le Web. Un document écrit en langage XML peut être affiché et modifié dans n'importe quel éditeur de texte, et il est généralement d'une lisibilité correcte. Dans l'exemple suivant, une société appelée Northwind Traders commande deux moniteurs à la société Contoso, Ltd. Voici la demande d'achat interne de Northwind Traders, représentée en langage XML :

<NorthwindReq>
<Header reqNumber="IL0829" reqStatus="New" dateCreated="2000-10-24"/>
<Shipping
name="Brian H. Valentine"
addr1="1234 Main Street"
city="Anytown"
state="AL"
zip="12345"
country="USA"
phone="(555)555-0123" />
<Items count="2">
<Item partNo="270FS" description="27-inch flat screen monitor" qty="2" />
</Items>
</NorthwindReq>

Ce document est construit sur un format prédéfini, appelé un schéma. Un schéma est un document XML décrivant le format des autres documents XML. Contrairement aux autres documents XML, un schéma ne contient pas de données. Il contient uniquement les règles de mise en forme des éléments de document susceptibles de figurer dans un document XML correspondant.

Le langage XML a fait l'objet d'un processus de standardisation formel par le World Wide Web Consortium (W3C). Il a atteint le niveau de recommandation « W3C Recommendation », qui représente le niveau le plus élevé attribué par W3C. Pour plus d'informations sur la recommandation XML, consultez la page Extensible Markup Language (XML) sur le site Web du World Wide Web Consortium, à l'adresse suivante : (www.w3.org/XML).

Microsoft BizTalk Server 2002 définit également des documents à l'aide d'un format appelé XDR (XML-Data Reduced), un sous-ensemble fonctionnel du Schéma W3C XML, qui offre un grand nombre d'avantages du Schéma XML. Récemment, le Schéma W3C XML a atteint le niveau de recommandation « W3C Recommendation » et les prochaines versions de BizTalk Server prendront en charge le Schéma XML tout en assurant une migration en douceur du Schéma XDR existant. Pour plus d'informations sur le Schéma XML, consultez la page XML Schema sur le site Web du World Wide Web Consortium, à l'adresse suivante : (www.w3.org/XML/Schema).

Passez à Solutions intégrées.


Solutions intégrées

Microsoft BizTalk Server porte sur les deux principaux aspects de l'échange de documents : les échanges et l'orchestration.

Les services d'échanges BizTalk permettent d'envoyer des documents commerciaux en toute sécurité et fiabilité. Ce type de document peut être un bon de commande envoyé à votre fournisseur ou une demande de devis envoyée à plusieurs fournisseurs afin de choisir la meilleure offre.

Les services d'orchestration BizTalk permettent de définir les processus professionnels utilisés pour créer le message, puis de les implémenter en utilisant un environnement graphique étroitement intégré. La caractéristique principale des processus définis à l'aide des services d'orchestration est qu'ils sont facilement modifiables, au gré de l'évolution de l'entreprise, offrant ainsi une grande souplesse.

Étant donné que les processus professionnels impliquent l'envoi et la réception de documents et l'application des règles commerciales, les services d'échanges BizTalk et d'Orchestration BizTalk sont conçus pour fonctionner ensemble afin de vous permettre de créer des solutions intégrées.

Passez à Installation de BizTalk Server.


Installation de BizTalk Server

Dans les leçons suivantes, vous allez utiliser un exemple de scénario dans lequel la société Northwind Traders achète du matériel informatique à la société Contoso, Ltd. Ces leçons décrivent chaque étape du processus et vous expliquent comment définir des formats pour les documents commerciaux en langage XML dans l'Éditeur BizTalk, comment décrire des processus professionnels internes dans le Concepteur d'orchestration BizTalk et comment relier le tout. Bien qu'il n'existe pas de codage spécifique à l'intégration de BizTalk Server, vous devez créer les règles propres à votre entreprise ; cependant, le codage requis dans ces leçons est minime.

Les exemples utilisés dans les leçons sont destinés à être installés et exécutés sur un seul ordinateur, mais vous pouvez configurer le même scénario sur plusieurs serveurs.

Avant d'installer Microsoft BizTalk Server 2002, prenez le temps de lire les documents Readme.htm et Installation Guide.htm, et respectez les conditions préalables suivantes :

  • Vous devez être équipé d'un ordinateur doté de Microsoft® Windows® 2000 avec Service Pack 2 ou d'une version ultérieure (Windows 2000 Professionnel et Windows 2000 Server fonctionnent tous les deux), ainsi que des services IIS (Internet Information Services) et Message Queuing et d'un compte bénéficiant de droits administratifs sur cet ordinateur.

  • Microsoft SQL Server™ 7.0 avec Service Pack 3 ou SQL Server 2000 avec Service Pack 1 doivent être installés sur l'ordinateur. Vous devez configurer SQL Server pour l'authentification Windows.

  • Microsoft Visio® 2002 doit également être installé sur l'ordinateur sur lequel vous allez installer BizTalk Server.

  • Dans Outils d'administration, dans Gestionnaire des services Internet, la case à cocher Activer les opérations d'auteur située sous l'onglet Extensions serveur de la boîte de dialogue Propriétés de site Web par défaut doit être désactivée. Pour plus d'informations, voir Configuration des paramètres IIS de BizTalk Server 2002.

  • Pour exécuter les scripts de ces leçons, vous devez installer le composant Message Queuing de Windows 2000.

Pour des informations plus détaillées sur le processus d'installation, voir Installation de BizTalk Server 2002.

Passez au Scénario.


Scénario

Un grossiste en matériels informatiques, la société Northwind Traders, commande des pièces à un de ses fournisseurs, la société Contoso, Ltd. Une application d'approvisionnement interne à Northwind Traders crée une demande d'achat identique à celle qui est illustrée dans la rubrique Pourquoi utiliser le langage XML ?, et l'enregistre en tant que fichier sur un disque dur. Microsoft BizTalk Server 2002 surveille l'emplacement des fichiers et lorsqu'il détecte une demande d'achat, il transmet ce fichier au processus d'approbation automatisé des commandes de Northwind Traders. Si la demande est refusée, elle est marquée comme telle et enregistrée en tant que fichier sur un disque dur. Si elle est acceptée, un ordre d'achat est généré et envoyé à Contoso, Ltd par le biais d'un protocole HTTP. Dans ce scénario, une demande est toujours acceptée si elle est inférieure ou égale 1 000 EUR, sinon elle est refusée.

Dans ce scénario, les deux entreprises en jeu utilisent BizTalk Server. Bien que les serveurs sur lesquels BizTalk Server est installé fonctionnement correctement ensemble, vous pouvez aussi utiliser BizTalk Server pour travailler avec des entreprises qui n'utilisent pas cette application.

Une fois que le serveur BizTalk Server de Contoso, Ltd reçoit l'ordre d'achat (dans ce scénario, la même instance de BizTalk Server est utilisée pour effectuer les tâches des deux côtés), il transmet celui-ci au processus professionnel de Contoso, Ltd, qui génère une facture à envoyer à Northwind Traders, là aussi via HTTP. Enfin, le serveur BizTalk Server de Northwind Traders reçoit la facture et l'enregistre en tant que fichier sur un disque dur.

L'illustration suivante montre à quoi ressemble ce processus à un niveau élevé.

Présentation d'un processus pour les leçons du Didacticiel BizTalk

Passez à Exécution du scénario.


Exécution du scénario

Important

  • Pour exécuter correctement ce scénario, vous devez copier le répertoire LearnBizTalk sur l'unité C de votre disque et y installer tous les composants BizTalk Server. Il est possible d'exécuter les fichiers à partir d'une autre unité de disque et d'un autre répertoire mais dans ce cas, des modifications importantes doivent être apportées aux fichiers source. Pour plus d'informations sur ces conditions requises, voir Leçons sur BizTalk Server 2002.

Pour configurer BizTalk Server pour le didacticiel

  1. Accédez au dossier C:\LearnBizTalk\Scripts et double-cliquez sur le fichier Setup.vbs.

    Ce fichier de script configure BizTalk Server pour l'utiliser dans le cadre des leçons du didacticiel. En fonction de votre environnement de serveur, l'exécution de ce script peut prendre quelques minutes, ce qui sera indiqué dans un message.

  2. Accédez au dossier C:\LearnBizTalk\Documents et double-cliquez sur le fichier ReqToApprove.xml, puis sur le fichier ReqToDecline.xml pour les ouvrir dans Microsoft Internet Explorer.

    Remarquez que le champ reqStatus a la valeur New et notez les valeurs des champs totalPrice et reqNumber dans chaque document.

Pour que BizTalk Server traite le document

  1. Copiez le fichier ReqToDecline.xml du répertoire C:\LearnBizTalk\Documents dans le répertoire C:\LearnBizTalk\Pickup.

    Remarque

    • Ne déplacez pas le fichier, car après avoir été traité par BizTalk Server, il sera supprimé du répertoire \Pickup. Étant donné que le montant total de cette demande d'achat est supérieur à 1 000 EUR, celle-ci est refusée et un message s'affiche.
  2. Copiez le fichier ReqToApprove.xml du répertoire C:\LearnBizTalk\Documents dans le répertoire C:\LearnBizTalk\Pickup.

    Cette fois-ci, la demande est acceptée ; un ordre d'achat est alors généré et envoyé à Contoso, Ltd ; l'ordre d'achat est ensuite traité, une facture est créée puis renvoyée à Northwind Traders ; enfin, la facture est reçue par Northwind Traders et enregistrée en tant que fichier dans le répertoire C:\LearnBizTalk\Output.

  3. Dans le répertoire \Output, double-cliquez sur le fichier ContosoInvoice.xml pour l'ouvrir dans Internet Explorer.

    La valeur du champ referenceNumber est désormais identique à celle du champ d'origine reqNumber.

Les leçons suivantes approfondissent chaque étape du processus et expliquent comment configurer BizTalk Server pour effectuer toutes les tâches nécessaires.

Passez à la Leçon 2 : Configuration des services d'échanges BizTalk.


Leçon 2 : Configuration des services d'échanges BizTalk

Cette leçon étudie chaque étape du scénario qui a été configuré dans la Leçon 1. Dans les leçons suivantes, vous exécuterez des fichiers de script supplémentaires. Ces scripts modifient la configuration initiale de Microsoft BizTalk Server 2002, pour vous permettre de voir le résultat de chaque étape du processus, contrairement à la Leçon 1 qui présentait le processus dans sa globalité.

Cette leçon aborde les sujets suivants :

  • Configuration des services d'échanges BizTalk

  • Configuration des fonctions de réception de fichier

  • Configuration des ports d'échanges et des canaux

  • Définition des spécifications de document

  • Exécution du scénario


Configuration des services d'échanges BizTalk

Grâce aux services d'échanges BizTalk, vous pouvez échanger des documents entre des applications internes et entre des partenaires commerciaux externes. Les services d'échanges BizTalk permettent de définir le mode de réception, de traitement et de transmission des documents, et présentent des fonctionnalités essentielles telles que la validation de la structure de document, les signatures numériques et le cryptage, ainsi que la garantie de la transmission sur des transports non fiables.

Le fichier de script L2Prep.vbs modifie la configuration des services d'échanges BizTalk, de telle sorte qu'au lieu de transmettre le document aux services d'orchestration BizTalk, il l'enregistre en tant que fichier lisible.

Pour exécuter ce script

  • Accédez au dossier C:\LearnBizTalk\Scripts et double-cliquez sur L2Prep.VBS.

L'illustration suivante montre comment le document est traité.

Présentation du processus

Passez à Configuration des fonctions de réception de fichier.


Configuration des fonctions de réception de fichier

Les fonctions de réception de fichier vous permettent d'utiliser un fichier qui a été créé par une application interne avec les services d'échanges BizTalk. Un des avantages de l'utilisation d'un fichier de sortie est que l'application professionnelle interne qui crée ce fichier n'a pas besoin de communiquer avec BizTalk Server. Elle crée simplement un fichier contenant le document et l'envoie à un emplacement spécifique surveillé par BizTalk Server, puis BizTalk Server le sélectionne. Si vous pouvez créer des fichiers de sortie et des fichiers d'entrée de réception dans vos applications existantes, il est possible que vous puissiez les utiliser avec BizTalk Server sans aucune modification.

Un autre aspect important de l'utilisation des fonctions de réception de fichier est le traitement asynchrone. Asynchrone, qui signifie « pas en même temps », se rapporte aux processus qui se déroulent indépendamment les uns des autres. Le traitement asynchrone est important dans un environnement distribué, car il permet à chaque composant de la solution de fonctionner de manière autonome, sans être affecté par une indisponibilité temporaire d'un autre composant de la solution, que ce soit en raison d'une panne ou d'une maintenance programmée.

Par exemple, si vous êtes confronté à une brève panne réseau, la globalité de l'application n'est pas affectée, car les documents générés par vos applications professionnelles internes s'accumulent simplement sur le disque dur. Dès que le réseau est de nouveau disponible, BizTalk Server sélectionne tous les fichiers qu'il trouve dans le répertoire désigné, pour les traiter. Vous pouvez aussi ajouter des serveurs BizTalk Server et les configurer pour traiter les documents figurant dans le même répertoire, si le nombre de documents que vous générez est trop important pour qu'un seul serveur les traite à une vitesse acceptable.

Pour savoir comment la fonction de réception de fichier est configurée

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Administration de BizTalk Server.

  2. Développez Microsoft BizTalk Server 2002, puis Groupe BizTalk Server, puis Fonctions de réception, cliquez avec le bouton droit sur ReceiveReq, et cliquez sur Propriétés.

    La boîte de dialogue Propriétés de ReceiveReq s'affiche.

  3. Consultez l'onglet Général, puis sélectionnez l'onglet Services.

    L'illustration suivante représente l'onglet Services, qui indique que la fonction a été configurée en tant que fonction de réception de fichier et que le répertoire à interroger et les types de fichier à sélectionner ont été spécifiés.

    Boîte de dialogue Propriétés de ReceiveReq

    L'onglet Avancées spécifie à quel endroit BizTalk Server doit transmettre les fichiers qu'il trouve. Il identifie également un canal, auquel la fonction de réception transmettra les documents, appelé « Channel To Approval ». Les canaux et les ports d'échanges associés sont traités dans la section suivante. Pour plus d'informations, voir Description des propriétés avancées d'une fonction de réception.

  4. Fermez la boîte de dialogue Propriétés de ReceiveReq.

  5. Fermez Administration de BizTalk Server.

Remarque

  • Les fonctions de réception de fichier ne constituent pas le seul moyen pour soumettre des documents à BizTalk Server. En effet, vous pouvez également recevoir des documents du service Message Queuing, par courrier électronique (via SMTP), sous forme de pages Web (via HTTP/HTTPS), ainsi que d'un modèle d'objet COM (Component Object Model) provenant de vos applications. Pour plus d'informations, voir Fonctions de réception disponibles.

Passez à Configuration des ports d'échanges et des canaux.


Configuration des ports d'échanges et des canaux

Pour transmettre un document à une destination, vous devez définir cette dernière dans les services d'échanges BizTalk. Dans les services d'échanges BizTalk, les destinations sont appelées des ports d'échanges. Un port d'échanges comporte un ensemble de propriétés grâce auxquelles vous pouvez indiquer le mode de sécurité et de transport des documents vers leur destination, qu'il s'agisse d'une application interne ou d'un partenaire commercial externe.

Remarque

  • Vous pouvez regrouper les ports d'échanges en listes de distribution de sorte à envoyer un même document à plusieurs destinations différentes, qu'il s'agisse de partenaires commerciaux ou d'applications internes.

Le port d'échanges qui a été défini lorsque vous avez exécuté le script d'installation s'intitule Req Approval. Il s'agit d'un port d'échanges vers une application interne qui représente le processus professionnel de la société Northwind Traders pour l'acceptation des demandes.

Pour afficher les propriétés d'un port d'échanges

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Cliquez sur Ports d'échanges, puis sur Rechercher.

  3. Dans le volet droit, double-cliquez sur Port Req Approval pour le modifier.

    La page Propriétés du port d'échanges apparaît.

  4. Cliquez sur Suivant.

    La page Organisation de destination apparaît.

    Dans l'illustration suivante, la page Organisation de destination indique que ce document sera envoyé à un fichier.

    Page Organisation de destination de l'Assistant Propriétés du port d'échanges

Dans la Leçon 1, ce port d'échanges transmettait ce message à une planification XLANG, au sein des services d'orchestration BizTalk, qui met en œuvre le processus d'approbation. (Les services d'orchestration BizTalk sont traités en détail dans la leçon suivante.) Ceci a été modifié lorsque vous avez exécuté le script au début de la présente leçon, si bien que vous pouvez maintenant voir le résultat produit.

En effet, au lieu d'envoyer un document aux services d'orchestration Biztalk ou à un fichier, vous pouvez configurer un port d'échanges pour qu'il transmette les documents par le biais des protocoles pris en charge (par exemple, HTTP/HTTPS, SMTP, Message Queuing ou les composants d'intégration d'application).

Vous pouvez également configurer un port d'échanges avec des fonctionnalités de sécurité supplémentaires, en cryptant votre document et/ou en y ajoutant une signature numérique. Ces options sont facultatives.

Ensuite, vous devez définir un canal au travers duquel ce document doit être transmis. Un canal comporte un ensemble de propriétés identifiant l'organisation ou l'application source qui a émis le document, et définit les étapes spécifiques effectuées par BizTalk Server avant la transmission du document au port d'échanges auquel le canal est associé. L'illustration suivante représente les relations existant entre les fonctions de réception, les canaux et les ports d'échanges.

Fonctions de réception, canaux et ports d'échanges

Pour voir comment le canal qui transmet les demandes au processus d'approbation de Northwind Traders est configuré

  1. Ouvrez le Gestionnaire d'échanges BizTalk, si ce n'est pas déjà fait.

  2. Cliquez sur Canaux, puis sur Rechercher.

  3. Dans le volet droit, double-cliquez sur Channel To Approval pour le modifier.

    La page Propriétés du canal apparaît.

  4. Cliquez sur Suivant.

    Remarque

    • Pour sélectionner le port d'échanges Req To Approval, vous pouvez également cliquer dessus avec le bouton droit, puis cliquer sur Rechercher des canaux dans le menu Edition. Dans ce cas, la liste de tous les canaux s'affiche. Seul le canal Channel To Approval est connecté au port d'échanges Req To Approval.

    Dans les illustrations suivantes, remarquez que les documents à traiter par ce canal proviennent d'une application d'achat interne, et que le format de ces documents est décrit par une définition de document intitulée Northwind Req.

    Page Application source de l'Assistant Propriétés de canal

  5. Cliquez sur Annuler pour fermer la page Propriétés de canal.

  6. Fermez le Gestionnaire d'échanges BizTalk.

Remarque

  • Vous avez également la possibilité d'ordonner à un canal de convertir un document d'une définition de document dans une autre, et de spécifier les informations à consigner dans un journal à des fins de suivi, au cours de la transmission des documents. La Leçon 5 fournit des informations sur la traduction de documents à l'aide du Mappeur BizTalk.

Pour plus d'informations sur les ports d'échanges et les canaux, voir Description des ports d'échanges et Description des canaux.

La rubrique suivante décrit la définition de document et explique comment en créer une.

Passez à Définition des spécifications de document.


Définition des spécifications de document

La Leçon 1 expliquait les raisons pour lesquelles il est important que les entreprises utilisent le même langage pour décrire les documents qu'elles échangent. Ce langage commun est le langage XML. Bien que les documents XML soient stockés dans un format texte et puissent être ouverts dans n'importe quel éditeur de texte, leur création ou leur modification peut se révéler une tâche très ardue et génératrice d'erreurs. BizTalk Server fournit un outil appelé Éditeur BizTalk qui simplifie cette tâche.

Pour ouvrir le fichier NorthwindReq.xml

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2002, puis cliquez sur Éditeur BizTalk.

  2. Dans le menu Fichier, cliquez sur Ouvrir.

  3. Accédez au répertoire C:\LearnBizTalk\Documents, sélectionnez NorthwindReq.xml, puis cliquez sur Ouvrir.

    Le fichier, qui s'ouvre dans l'Éditeur BizTalk, apparaît tel qu'il est présenté dans l'illustration suivante.

    Fichier NorthwindReq.xml ouvert dans l'Éditeur BizTalk

L'Éditeur BizTalk facilite la gestion des spécifications, en permettant, notamment, de visualiser le format d'un document, de définir le type de données de chaque élément et attribut et de déterminer les champs de données obligatoires et ceux qui sont facultatifs. Ce schéma de document particulier représente un document XML, mais l'Éditeur BizTalk représente les schémas EDI (Electronic Data Interchange) et fichier plat de la même manière.

Étant donné que vous pouvez utiliser la spécification de document sur n'importe quelle station de travail sur laquelle l'Éditeur BizTalk est installé, une fois la spécification créée, elle doit aussi être ajoutée au référentiel WebDAV de BizTalk Server, afin que le serveur BizTalk Server puisse la récupérer.

Remarque

  • WebDAV (Web Distributed Authoring and Versioning) représente la norme EITF (Internet Engineering Task Force) pour les opérations d'auteur partagées sur le Web. Elle facilite la modification partagée et la gestion des fichiers entre des utilisateurs éloignés les uns des autres sur Internet. Pour plus d'informations sur WebDAV, consultez le document « HTTP Extensions for Distributed Authoring -- WEBDAV » sur le site Web de IETF, à l'adresse suivante : (ietf.org/rfc/rfc2518.txt).

Pour créer la définition de document, vous devez associer une spécification XML spécifique qui est créée dans l'Éditeur BizTalk et enregistrée dans le référentiel WebDAV avec un nom devant être utilisé par BizTalk Server.

Pour créer une définition de document

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Si le Gestionnaire d'échanges BizTalk apparaît, cliquez sur Annuler.

  3. Dans le menu Fichier, pointez sur Nouveau, puis cliquez sur Définition de document.

    La boîte de dialogue Nouvelle définition de document s'affiche.

  4. Dans la zone Nom de la définition de document, tapez un nom pour la définition de document.

  5. Activez la case à cocher Spécification de document, puis cliquez sur Parcourir.

    La boîte de dialogue Sélection d'une spécification de document dans le référentiel WebDAV apparaît.

  6. Double-cliquez sur le dossier Microsoft, cliquez sur le schéma de votre choix, puis cliquez sur Ouvrir.

    Dans cette boîte de dialogue, vous pouvez sélectionner un des schémas enregistrés dans le référentiel WebDAV de BizTalk Server.

  7. Cliquez sur OK pour enregistrer la nouvelle définition de document.

  8. Fermez le Gestionnaire d'échanges BizTalk.

Remarque

  • Vous pouvez créer plusieurs définitions de document basées sur le même schéma. Vous pouvez également définir des options de suivi de document global pour chaque document créé. Cette option est facultative. Pour plus d'informations, voir Description des définitions de documents.

Passez à Exécution du scénario.


Exécution du scénario

Important

  • Pour exécuter correctement ce scénario, vous devez copier le répertoire LearnBizTalk sur l'unité C de votre disque et y installer tous les composants BizTalk Server. Il est possible d'exécuter les fichiers à partir d'une autre unité de disque et d'un autre répertoire mais dans ce cas, des modifications importantes doivent être apportées aux fichiers source. Pour plus d'informations sur ces conditions requises, voir Leçons sur BizTalk Server 2002.

Pour lancer le scénario

  1. Copiez le fichier ReqToApprove.xml du répertoire C:\LearnBizTalk\Documents dans le répertoire C:\LearnBizTalk\Pickup.

    La fonction de réception de fichier ReceiveReq que vous avez définie préalablement sélectionnera ce fichier pour le transmettre au port d'échanges Req Approval via le canal Channel To Approval.

  2. Accédez au répertoire C:\LearnBizTalk\Output et double-cliquez sur le fichier NorthwindRequisition.xml pour l'ouvrir dans Internet Explorer.

    Vous remarquez qu'il s'agit du même document que vous avez copié dans le répertoire \Pickup. Au début de cette leçon, vous avez exécuté le script L2Prep.VBS pour modifier les définitions du canal et du port d'échanges. De sorte que, au lieu de transmettre la demande aux services d'orchestration BizTalk, le port d'échanges a enregistré le contenu du document dans un fichier appelé NorthwindRequisition.xml dans le répertoire \Output.

  3. Exécutez la même procédure, cette fois avec le fichier ReqToDecline.xml. Le fichier situé dans le répertoire \Output sera remplacé par la nouvelle demande que vous venez de soumettre.

Cette leçon vous a présenté le fonctionnement de base des services d'échanges BizTalk. Vous avez exécuté un script pour configurer les services, consulté les propriétés impliquées et sélectionné un fichier du système de fichiers dans un répertoire, pour le déposer dans un autre répertoire. Vous avez appris les concepts et la terminologie de base ; les leçons suivantes vous présenteront des fonctionnalités supplémentaires.

La leçon suivante explique comment définir le processus d'approbation de demande de Northwind Traders à l'aide des services d'orchestration BizTalk.

Passez à la Leçon 3 : Conception des services d'orchestration BizTalk.


Leçon 3 : Conception des services d'orchestration BizTalk

Cette leçon vous explique comment Northwind Traders implémente son processus d'approbation des demandes à l'aide des services d'orchestration BizTalk. L'illustration suivante présente une vue détaillée du processus d'approbation des demandes.

Leçon 3 : Présentation du processus

Cette section traite des rubriques suivantes :

  • Services d'orchestration BizTalk

  • Définition du processus professionnel

  • Implémentation du processus professionnel

  • Création du flux de communication

  • Exécution du scénario


Services d'orchestration BizTalk

Microsoft BizTalk Server 2002 résout deux problèmes : il vous permet d'accéder aux services d'échanges BizTalk pour envoyer des messages entre différents processus professionnels et aux services d'orchestration BizTalk pour créer vos processus professionnels. Dans la leçon précédente, vous avez appris à soumettre un document professionnel aux services d'échanges BizTalk. Cette leçon explique comment définir vos processus professionnels et comment les appliquer à l'aide des services d'orchestration BizTalk.

Avec les services d'orchestration BizTalk, vous pouvez créer une représentation détaillée de votre processus professionnel, et implémenter ce dernier par programmation au sein d'un environnement de conception intégré basé sur Microsoft Visio 2002. À l'origine, la conception et l'implémentation du processus professionnel représentaient deux phases distinctes. Une des fonctionnalités importantes des services d'orchestration BizTalk est l'intégration de ces deux phases en un environnement de conception graphique unique.

Ainsi, étant donné que les processus professionnels sont définis dans un environnement graphique, lorsque vous devez les modifier pour votre entreprise, les modifications sont implémentées plus rapidement.

Outre l'intégration de la conception et de l'implémentation, les services d'orchestration BizTalk permettent de créer non seulement des processus dotés de simultanéité (la possibilité d'effectuer plusieurs tâches en même temps), mais également des processus professionnels robustes et de longue durée au travers de diverses applications, plates-formes et organisations.

Pour créer des processus professionnels robustes et de longue durée, les services d'orchestration BizTalk enregistrent des instances des processus professionnels de longue durée qu'ils suspendent, ce qui épargne les ressources informatiques et procure davantage de fiabilité. Le serveur redémarrera ces processus ultérieurement, à partir du point exact auquel ils ont été interrompus, pour attendre la fin d'une opération longue. Même si, dans l'intervalle, l'ordinateur était éteint, les processus interrompus redémarreraient dès leur déclenchement. Une opération de longue durée peut être, par exemple, l'attente du paiement d'une facture, une opération qui s'effectue généralement sur une durée de 20 à 30 jours. Pour plus d'informations, voir Description des services d'orchestration.

Passez à Définition du processus professionnel.


Définition du processus professionnel

Dans cette leçon, vous devez ouvrir le schéma de planification XLANG, qui représente le processus professionnel de Northwind Traders pour l'approbation des demandes, afin de le consulter.

Pour consulter le processus professionnel de Northwind Traders

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server 2002, puis cliquez sur Concepteur d'Orchestration BizTalk.

  2. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir un schéma de planification XLANG apparaît.

  3. Accédez au répertoire C:\LearnBizTalk\Schedules, sélectionnez le fichier NorthWindApprovalL3.skv, puis cliquez sur Ouvrir.

Remarque

  • Vous pouvez fermer le schéma vierge qui s'affiche dans le Concepteur d'Orchestration BizTalk.

L'illustration suivante représente le schéma du processus d'approbation de Northwind Traders, qui a été conçu dans le Concepteur d'Orchestration BizTalk.

Processus d'approbation de Northwind Traders

Si vous avez déjà conçu des diagrammes dans Microsoft Visio, vous ne serez probablement pas dépaysé par le Concepteur d'Orchestration BizTalk. Dans le Concepteur d'Orchestration BizTalk, vous définissez votre processus professionnel en utilisant des formes Diagrammes de flux, par exemple Action, Décision et Tant que, à la place d'éléments plus complexes que sont les documents, spécifications, composants et messages. Le nombre et le nom des étapes de votre processus professionnel ne sont pas limités. En outre, vous pouvez utiliser des formes Branches pour diviser le processus en plusieurs chemins simultanés (par exemple pour demander un prix à plusieurs fournisseurs), puis réunir ultérieurement ces chemins dans une forme Jointure. Enfin, vous pouvez utiliser la forme Transaction pour regrouper plusieurs étapes du processus en une seule transaction, si nécessaire. Pour plus d'informations, voir Formes Diagrammes de flux.

Passez à Implémentation du processus professionnel.


Implémentation du processus professionnel

Une fois le processus professionnel défini, vous pouvez l'implémenter en configurant BizTalk Server afin qu'il effectue chacune des tâches définies dans le processus.

L'illustration suivante représente les formes Implémentation utilisées dans le processus d'approbation de Northwind Traders.

Formes Implémentation dans le Concepteur d'Orchestration BizTalk

Vous devez savoir comment utiliser la forme Échanges BizTalk, la forme Composant COM et la forme Message Queuing. Remarquez que pour regrouper les processus professionnels, vous n'avez pas besoin d'écrire du code ; le code figure dans les composants de la logique métier, et non dans l'implémentation qui les relie.

Lorsque, par exemple, vous faites glisser la forme Échanges BizTalk pour la déposer dans le schéma, vous ouvrez l'Assistant Liaison d'Échanges BizTalk qui vous guide parmi plusieurs pages sur lesquelles vous définissez le port d'échanges associé à une forme d'implémentation donnée. Un port d'échanges est un ensemble de propriétés associées à une destination de document particulière, et votre processus professionnel peut être cette destination. Pour plus d'informations, voir Formes Implémentation.

Pour des tâches plus simples, vous pouvez aussi créer des composants dans le langage de script de votre choix, tel que Microsoft® Visual Basic® Scripting Edition (VBScript). Un composant de ce type a été utilisé dans ce schéma de planification XLANG. Ce composant de script expose une méthode appelée DeclineReq, dont l'unique tâche consiste à afficher un message informant l'utilisateur du refus d'une demande. Pour plus d'informations, voir Création d'un composant de script.

La planification XLANG NorthwindApprovalL3.skv XLANG contient deux composants de script et une forme Échanges BizTalk.

Si un élément spécifique du processus professionnel vous oblige à effectuer des tâches spéciales, telles que l'accès à une base de données interne ou la liaison avec un gros système, vous souhaiterez vraisemblablement les implémenter dans un composant COM et appeler les méthodes appropriées des services d'orchestration BizTalk.

La leçon suivante traite du processus qui se cache derrière la création d'un composant de script.

Passez à Création du flux de communication.


Création du flux de communication

Chaque forme Diagramme de flux utilisée dans le stencil Diagramme de flux, de même que chaque forme Implémentation utilisée dans le stencil Implémentation, est munie d'une poignée de contrôle ( poignée de contrôle) sur le côté. Pour connecter une forme Action à gauche à une forme Implémentation à droite, tracez une ligne reliant la poignée de la forme Action à la poignée du port d'implémentation. Une fois les formes connectées, l'Assistant Communication XML s'ouvre et vous demande de répondre à quelques questions pour déterminer le mode de communication des formes. Pour plus d'informations, voir Utilisation de l'Assistant Communication XML.

Lorsque les formes Action et Implémentation sont connectées, la dernière étape, sur la page Données, consiste à définir de quelle manière le document professionnel sera transmis d'une action à l'autre. Pour afficher la page Données, cliquez sur l'onglet Données, situé en bas du schéma dans le Concepteur d'Orchestration BizTalk. Vous trouverez plus d'informations sur la page Données dans la leçon suivante.

Passez à Exécution du scénario.


Exécution du scénario

Important

  • Pour exécuter correctement ce scénario, vous devez copier le répertoire LearnBizTalk sur l'unité C de votre disque et y installer tous les composants BizTalk Server. Il est possible d'exécuter les fichiers à partir d'une autre unité de disque et d'un autre répertoire mais dans ce cas, des modifications importantes doivent être apportées aux fichiers source. Pour plus d'informations sur ces conditions requises, voir Leçons sur BizTalk Server 2002.

Pour tester le scénario

  1. Accédez au répertoire C:\LearnBizTalk\Scripts et double-cliquez sur L3Post.vbs.

    Ce script modifie temporairement le schéma de planification XLANG, de sorte que la demande ne soit pas encore transmise à la société Contoso, Ltd. La configuration initiale sera restaurée ultérieurement, mais pour le moment il est important d'effectuer cette modification pour vous permettre d'approfondir cette étape du processus.

  2. Copiez le fichier ReqToDecline.xml du répertoire C:\LearnBizTalk\Documents dans le répertoire C:\LearnBizTalk\Pickup.

    La fonction de réception de fichier sélectionne ce fichier et le transmet aux services d'échanges BizTalk. Les services d'échanges BizTalk, à leur tour, appellent le processus d'approbation de demande de Northwind Traders à l'aide des services d'orchestration BizTalk, car vous avez défini une planification XLANG comme étant la destination du port d'échanges qui a été créé pour ce processus professionnel. Enfin, les services d'orchestration BizTalk traitent la demande, puis affichent un message vous informant que cette demande est refusée.

  3. Exécutez de nouveau l'étape 2 en utilisant le fichier ReqToApprove.xml.

    Un message vous indique que la demande est acceptée.

La leçon 4 fournit des informations plus détaillées sur la configuration des formes Implémentation dans les services d'orchestration BizTalk, le développement d'un composant de script et sur ce que vous devez faire sur la page Données pour que votre document soit correctement transmis d'une action à l'autre.

Passez à la Leçon 4 : Présentation de l'implémentation.


Leçon 4 : Présentation de l'implémentation

Dans cette leçon, vous étendez planification XLANG de la leçon 3 et étudiez l'implémentation du processus d'approbation de demande de Northwind Traders.

Grâce aux services d'orchestration BizTalk, le processus d'approbation de demande est implémenté sous la forme d'une planification XLANG. Dans cette leçon, vous allez examiner les paramètres de configuration des différentes formes Implémentation, étudier le processus impliqué dans la création d'une implémentation de composant de script Windows et apprendre à utiliser la page Données dans le Concepteur d'Orchestration BizTalk pour garantir le flux d'informations approprié à l'entrée et à la sortie d'une planification XLANG.

Cette leçon aborde les sujets suivants :

  • Envoi et réception de documents dans les services d'orchestration BizTalk

  • Ajouts de champs à la spécification de message

  • Utilisation des composants COM

  • Création d'un composant de script

  • Page Données de Northwind Traders


Envoi et réception de documents dans les services d'orchestration BizTalk

La planification XLANG est l'emplacement dans lequel vous implémentez votre processus professionnel. Dans la plupart des cas, ce processus doit vérifier les différents champs d'un document entrant et prendre des décisions ou effectuer des actions en fonction des valeurs qu'il y trouve. Dans ce didacticiel, seule la valeur Total du document Requisition (la demande) est vérifiée et la demande est acceptée uniquement si ce total est inférieur à 1 000 EUR. Mais auparavant, le document doit être soumis au processus d'approbation.

Pour commencer cette leçon, ouvrez le fichier NorthwindApproval.skv dans le Concepteur d'Orchestration BizTalk. Ce fichier ressemble au fichier NorthwindApprovalL3.skv de la leçon 3, sauf qu'un des composants de script Windows a été remplacé par une forme Échanges BizTalk, portant la mention « Channel To Contoso », comme illustré ci-dessous.

Forme Échange BizTalk portant la mention « Channel To Contoso »

Une fois le processus professionnel du schéma de planification XLANG défini, et l'implémentation ajoutée, le diagramme doit être compilé dans une planification XLANG. Une planification est un fichier écrit en langage XLANG, qui est le langage utilisé par de nombreuses technologies pour décrire l'ordre logique des processus professionnels, ainsi que l'implémentation du processus professionnel. Le langage XLANG est exprimé en XML. La planification XLANG contient toutes les étapes à exécuter, les composants qui doivent être appelés, ainsi que les données qui doivent être transmises pour que le processus défini puisse être effectué. Une fois les deux côtés du diagramme terminés, vous pouvez compiler le schéma de planification XLANG en cliquant sur Créer XLANG <nom de fichier>.skx dans le menu Fichier du Concepteur d'Orchestration BizTalk.

Dans les leçons précédentes, vous avez appris à envoyer un message contenant un document professionnel à l'aide des services d'échanges BizTalk. Dans cette leçon, vous allez combiner le message et le processus professionnel.

Dans la Leçon 2, vous avez défini un port d'échanges que vous avez configuré pour transmettre le document Requisition (Demande) à une planification XLANG. Vous avez spécifié le nom d'une planification XLANG (le fichier XLANG) que les services d'échanges BizTalk devaient démarrer pour traiter la demande. Vous avez également spécifié le nom d'un port d'échanges pour recevoir la demande au sein de la planification. Ce port d'orchestration doit être configuré dans le Concepteur d'Orchestration BizTalk. Notez que le terme « port » utilisé désigne deux choses différentes : en effet, le port d'échanges défini dans le Gestionnaire d'Échanges BizTalk et le port d'orchestration défini dans le Concepteur d'Orchestration BizTalk ne sont pas la même chose.

Utilisation d'une implémentation Échanges BizTalk

La forme Échanges BizTalk sert à transmettre des documents des services d'échanges BizTalk aux services d'orchestration BizTalk.

Lorsque vous ajoutez une forme Échanges BizTalk à droite du schéma de planification XLANG, l'Assistant Liaison d'Échanges BizTalk s'ouvre. Pour modifier une implémentation d'Échanges BizTalk existante, double-cliquez sur la forme Échanges BizTalk. Dans cet Assistant, vous nommez le port d'orchestration (ce nom doit être le même que celui que vous avez spécifié dans le Gestionnaire d'Échanges BizTalk), et vous indiquez également si ce port doit recevoir des documents ou les envoyer, et s'il sert à démarrer un processus professionnel.

Si vous devez renvoyer un document aux services d'échanges BizTalk, ajoutez une forme Échanges BizTalk à droite du schéma de la planification XLANG et spécifiez le nom du canal auquel le document doit être envoyé. Sachez qu'il n'est pas nécessaire que ce canal existe lorsque vous créez votre schéma de planification XLANG, mais qu'il doit être présent lorsque vous exécutez la planification.

Une fois le port d'orchestration créé, connectez la forme Action au port et, dans l'Assistant Communication XML, spécifiez si le document est envoyé en XML ou en tant que chaîne, les informations sur le type de message, ainsi qu'une spécification XML (facultative) pour valider le document, exactement comme vous avez fait précédemment lorsque vous avez configuré les services d'orchestration BizTalk pour qu'ils reçoivent des documents des services d'échanges BizTalk. Pour plus d'informations, voir Utilisation de la forme Échanges BizTalk.

Utilisation d'une implémentation Message Queuing

Pour recevoir un document dans une planification XLANG, vous avez également la possibilité d'utiliser la forme Message Queuing. Lorsque vous ajoutez cette forme au schéma, l'Assistant Liaison de Message Queuing qui s'ouvre vous demande de spécifier le nom de la file d'attente de message privée ou publique à utiliser pour envoyer ou recevoir les documents. En revanche, contrairement aux services d'échanges BizTalk, si vous utilisez Message Queuing pour recevoir les documents, la planification ne démarre pas automatiquement. Vous devez la démarrer d'une autre manière, une fois le document envoyé à une file d'attente.

Lorsque vous connectez la forme d'action Receive Requisition sur la gauche du schéma au port ReceiveReq, l'Assistant Communication XML s'ouvre. Pour modifier une implémentation de Message Queuing existante et ouvrir l'Assistant Communication XML, double-cliquez sur la ligne bleue qui relie l'action Receive Requisition au port ReceiveReq.

L'Assistant Communication XML vous invite à créer un message qui servira à transporter le document dans le processus d'orchestration représenté par la planification XLANG. D'une manière plus spécifique, vous êtes invité à connecter ce message à d'autres messages sur la page Données, à spécifier si le document doit être traité en format XML, et à indiquer un type de message. Vous avez également la possibilité (en option) de spécifier le nom et l'emplacement d'un fichier XML, contenant votre spécification de document, afin que les services d'orchestration BizTalk puissent valider chaque document par rapport à cette spécification, avant de le traiter.

Vous pouvez également envoyer des documents d'une planification XLANG en utilisant Message Queuing. Dans ce cas, au lieu de spécifier le nom d'un canal, vous devez spécifier le nom d'une file d'attente privée ou publique à laquelle le document sera envoyé. Pour plus d'informations, voir Utilisation de la forme Message Queuing.

Une fois le processus professionnel du schéma de planification XLANG défini et l'implémentation ajoutée, le diagramme est compilé dans une planification XLANG. Pour plus d'informations, voir Compilation d'un schéma de planification XLANG dans une planification XLANG. La planification XLANG contient toutes les étapes à suivre, les composants à appeler, ainsi que les données à transmettre, pour répondre aux besoins du processus défini.

Maintenant que vous avez appris à envoyer et recevoir des documents des services d'échanges BizTalk, voyons comment utiliser ces documents dans les services d'orchestration BizTalk.

Passez à Ajout de champs aux spécifications de message.


Ajout de champs aux spécifications de message

Précédemment, vous avez configuré une communication XML pour un message et indiqué la spécification XML représentant le document en cours de réception. Maintenant, vous allez utiliser les services d'orchestration BizTalk pour extraire les valeurs des champs dans le document et transmettre les informations aux composants COM ou à d'autres messages.

  1. Ouvrez l'Assistant Communication XML pour le port ReceiveReq en double-cliquant sur la ligne bleue qui relie l'action Receive Requisition au port ReceiveReq.

  2. Cliquez sur Suivant quatre fois.

    La page Informations sur la spécification du message de l'Assistant s'ouvre.

  3. Vous remarquez que la zone Champs de message contient plusieurs entrées. L'une d'elles, nommée Document, est le champ qui représente la totalité d'un document transmis à la planification XLANG. Cliquez sur Ajouter.

    La boîte de dialogue Sélection d'un champ apparaît.

    Étant donné que vous avez spécifié que les documents transmis à la planification XLANG devaient correspondre à une spécification XML particulière, en l'occurrence la spécification Requisition de Northwind, vous pouvez maintenant sélectionner des champs de ce document en utilisant le langage d'interrogation XPath.

    Remarque

    • Xpath, langage destiné à l'adressage des éléments d'un document XML, est une norme publique gérée par le Consortium W3C. Pour plus d'informations, accédez à la page Xpath sur le site Web de W3C, à l'adresse suivante : (www.w3.org/TR/xpath.html).
  4. Développez le nœud Éléments et cliquez sur totalPrice.

    Le XPath du nœud apparaît dans la zone Chemin d'accès au nœud. L'illustration suivante présente la boîte de dialogue Sélection d'un champ, le champ totalPrice étant sélectionné.

    Boîte de dialogue Sélection d'un champ

    Pour ajouter d'autres champs de la spécification à votre message, vous pouvez procéder de la même manière. Tous les champs ajoutés dans cette boîte de dialogue deviennent disponibles sur la page Données du Concepteur d'Orchestration BizTalk, si bien que vous pouvez les utiliser dans des expressions et les transmettre en tant que paramètres aux composants.

  5. Cliquez sur Annuler pour fermer la boîte de dialogue Sélection d'un champ.

  6. Cliquez sur Annuler pour fermer l'Assistant Communication XML.

  7. Sur la partie gauche du schéma de planification XLANG, cliquez avec le bouton droit sur la forme Décision, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la décision apparaît.

  8. Cliquez sur Modifier.

    Une boîte de dialogue semblable à l'illustration suivante s'affiche.

    Boîte de dialogue Propriétés de la règle

    L'expression de script indique qu'il est possible d'accéder à la valeur du champ totalPrice en utilisant la notation MessageName.FieldName. Dans cet exemple, Message_1.totalPrice sert à obtenir la valeur du prix total du document Requisition.

Passez à Utilisation des composants COM.


Utilisation des composants COM

Maintenant que votre document figure dans la planification XLANG, vous pouvez appeler différents composants professionnels et transmettre le document en tant qu'un des paramètres. Ces composants peuvent effectuer diverses tâches, par exemple adresser les règles d'entreprise, accéder aux bases de données d'entreprise et aux anciens systèmes et envoyer des messages par courrier électronique. Ils peuvent également modifier le document lui-même et renvoyer ces modifications à la planification XLANG pour les transmettre à l'action suivante. Pour ce faire, vous devez implémenter la logique métier en composants COM standard, ajouter ces composants à la partie droite du schéma de planification XLANG, puis sélectionner les méthodes à appeler.

À ce stade du didacticiel, vous avez :

  • lu le document Requisition figurant sous forme de fichier sur le disque dur et l'avez transmis aux services d'échanges BizTalk (à l'aide d'une fonction de réception de fichier) ;

  • validé le document Requisition par rapport à une spécification XML (en utilisant un canal) et l'avez transmis aux services d'orchestration BizTalk ;

  • reçu le document à l'intérieur d'une planification XLANG et récupéré les valeurs de champs spécifiques (à l'aide de l'Assistant Communication XML) ;

  • utilisé les propriétés de règle d'une forme Décision pour évaluer les valeurs et créer votre logique métier.

Jusqu'à présent, le didacticiel n'a encore exigé aucune programmation pour créer et implémenter un processus professionnel. Toutefois, il peut être nécessaire d'écrire un composant professionnel pour implémenter certaines actions propres à votre entreprise (par exemple, la consultation des limites d'acceptation des demandes pour certains membres de votre personnel) ; c'est pourquoi la rubrique suivante explique comment écrire un composant de script Windows. Pour plus d'informations, voir Utilisation de la forme Composant COM.

Passez à Création d'un composant de script.


Création d'un composant de script

Les composants de script Microsoft Windows offrent la possibilité de créer des composants COM (Component Object Model) à l'aide des langages de script Microsoft Visual Basic Scripting Edition (VBScript) ou Microsoft® JScript®. Vous pouvez utiliser les composants de script exactement comme les autres composants COM dans toutes les applications prenant en charge le modèle d'objet COM.

Les composants de script fonctionnent différemment des composants compilés, car ils sont interprétés au moment de l'exécution, mais ils permettent de réaliser une interface pour un composant COM qui sera développée ultérieurement.

Pour faciliter la création de composant de script, Microsoft a mis au point l'Assistant Composant de script Windows. Vous pouvez télécharger cet Assistant sur le site Web MSDN, à l'adresse (http://www.microsoft.com/france/msdn/technologies/technos/scripting/default.asp). La création de l'embryon de code de votre composant est simple : Il suffit de choisir un nom pour le composant, de déterminer le langage de script à utiliser pour l'implémenter, de spécifier les propriétés et les méthodes dont votre composant sera doté, puis de cliquer sur Terminer. L'Assistant génère tout le code nécessaire à votre composant et l'enregistre dans un fichier portant l'extension .wsc. Ensuite, vous pouvez ouvrir le fichier dans l'éditeur de votre choix pour ajouter le code réel derrière les méthodes.

Le composant que vous allez utiliser ici possède deux méthodes, ApproveReq et DeclineReq. Chacune d'elles est dotée d'un paramètre unique : document. L'illustration suivante représente la page de l'Assistant Composant de script Windows sur laquelle vous adressez ces méthodes au fichier de script.

Étape 4 de l'Assistant Composant de script Windows

Le code suivant concerne le composant Requisition Approval (Approbation des demandes) :

<?xml version="1.0"?>
<component>

<registration
   description="Req Approval"
   progid=" LearnBizTalk.ProcessReq"
   version="1.00"
   classid="{AD454A9F-58FE-4877-B7CD-F61BD45988F5}">
</registration>

<public>
   <method name="ApproveReq">
      <PARAMETER name="Document"/>
   </method>
   <method name="DeclineReq">
      <PARAMETER name="Document"/>
   </method>
</public>

<script language="VBScript">
<![CDATA[

function ApproveReq(Document)function ApproveReq(Document)
MsgBox "Orchestration Engine Approved Requisition:"MsgBox "Le moteur d'Orchestration a accepté la demande :" & vbCrLf & vbCrLf & Document, 64, "Demande acceptée"
end functionend function

function DeclineReq(Document)function DeclineReq(Document)
MsgBox "Orchestration Engine Declined Requisition:"MsgBox "Le moteur d'Orchestration a refusé la demande :" & vbCrLf & vbCrLf & Document, 16, "Demande refusée"
end functionend function

]]>
</script></script>

</component></component>

Tous les éléments de ce fichier, à l'exception du code d'implémentation des méthodes ApproveReq et DeclineReq qui apparaissent en gras, sont générés par l'Assistant.

Le flux de vos processus professionnels peut être complexe, l'écriture et le test des composants COM créés par les développeurs pouvant prendre plusieurs semaines. Ceci ne vous empêche pas de concevoir et de tester votre schéma de planification XLANG avant que ces composants soient terminés. Utilisez l'Assistant Composant de script Windows pour créer des versions échantillon de vos composants COM complexes, terminez avec les propriétés et les méthodes qu'ils exposent, puis utilisez ces composants de script dans votre schéma de planification XLANG à la place des composants COM réels que vous exécuterez ultérieurement. Vous pouvez maintenant concevoir votre schéma de planification XLANG sans devoir attendre que les développeurs terminent le codage. Pour plus d'informations, voir Utilisation de la forme Composant de script.

Vous avez également la possibilité de tester l'intégration des services d'échanges BizTalk et des services d'orchestration BizTalk avec vos composants de script et de les remplacer ultérieurement par des composants COM développés dans un autre langage. Lorsque vous êtes prêt pour le remplacement des composants de script, ajoutez une forme Composant COM au schéma de planification XLANG. Ceci ouvre l'Assistant Liaison de composants COM, qui vous demande des informations pour créer un nouveau port d'orchestration. Ensuite, vous devez déconnecter la forme Action existante, qui était reliée à l'implémentation de port d'un composant de script, la reconnecter au nouveau port d'orchestration et recompiler la planification.

Passez à Page Données de Northwind Traders.


Page Données de Northwind Traders

Une fois le schéma de planification XLANG conçu et toutes les formes Implémentation connectées à leur équivalent Action, vous devez configurer le passage du flux à l'étape suivante du processus en utilisant la page Données dans les services d'orchestration BizTalk. Avant de travailler sur la page Données, celle-ci est similaire à l'illustration suivante.

Page Données de Northwind Traders

Remarquez que la page Données comporte plusieurs groupes de champs, chacun d'eux portant le nom du message qui effectue le transport du document à destination ou en provenance d'un port d'orchestration.

Ouvrez le fichier NorthwindApproval.skv dans le Concepteur d'Orchestration BizTalk, puis cliquez sur la page Données du menu Affichage. Remarquez de quelle manière le champ Document dans Message_1 est connecté au champ Document dans Message_2 et DeclineReq_in. Ceci indique que le document reçu des services d'échanges BizTalk par Message_1 a été transféré au message DeclineReq_in, qui est le message qui doit envoyer le document au composant de script, ainsi qu'à Message_2, qui doit ensuite retourner ce document aux services d'échanges BizTalk. Vous pouvez réorganiser les messages sur cette page, pour facilité la compréhension du schéma.

Pour afficher la page de données, cliquez sur l'onglet Données dans la partie inférieure des pages de conception. La page Données du fichier NorthwindApproval.skv doit être semblable à l'illustration suivante.

Page Données de Northwind Traders avec des connexions

Lorsque vous avez défini le flux de données entre les messages, vous pouvez compiler le schéma dans une planification XLANG exécutable.

Pour enregistrer et compiler un schéma de planification XLANG

  1. Dans le menu Fichier, cliquez sur Enregistrer <nom de fichier>.skv.

  2. Dans le menu Fichier, cliquez sur Créer <nom de fichier>.skx.

    La boîte de dialogue Enregistrer la planification XLANG vers apparaît.

  3. Vérifiez l'emplacement dans lequel la planification XLANG sera enregistrée, puis cliquez sur Enregistrer.

  4. Dans le menu Fichier, cliquez sur Quitter pour fermer le Concepteur d'Orchestration BizTalk.

    La planification XLANG est maintenant prête à être exécutée.

Pour plus d'informations, voir Compilation des planifications XLANG.

La leçon suivante vous apprend à préparer un document à transmettre au partenaire commercial, en le transformant à l'aide de mappages, et vous explique comment utiliser ces mappages avec les services d'échanges BizTalk.

Passez à la Leçon 5 : Utilisation du Mappeur BizTalk.


Leçon 5 : Utilisation du Mappeur BizTalk

Les leçons précédentes vous ont appris comment Microsoft BizTalk Server 2002 accepte les documents provenant d'applications métier et comment ces documents sont traités dans les services d'orchestration BizTalk.

La présente leçon vous explique comment le document Requisition est préparé avant l'envoi à Contoso, Ltd et quelles sont les étapes par lesquelles il passe au sein des services d'échanges BizTalk pour accomplir cette tâche.

Cette leçon aborde les sujets suivants :

  • Création du mappage

  • Utilisation du mappage

  • Exécution du scénario


Création du mappage

Le document Requisition que vous avez utilisé jusqu'à maintenant représente une demande d'achat interne générée par une application de Northwind Traders. Lorsque cette demande est acceptée par un processus professionnel (implémentée dans ce scénario à l'aide des services d'orchestration BizTalk), un ordre d'achat doit être envoyé à Contoso pour l'achat de la marchandise.

À ce stade, vous n'avez pas encore d'ordre d'achat, mais uniquement une demande. Cependant, la structure de l'ordre d'achat de Contoso et la plupart des données nécessaires à la création de ce document, telles que la liste des articles et l'adresse de facturation, figurent déjà dans la demande. Pour transformer les informations figurant dans la demande en ordre d'achat pour Contoso, Ltd, vous pouvez utiliser le Mappeur BizTalk. Le Mappeur BizTalk fait appel à une norme Internet appelée XSLT (Transformations XSLT), un langage destiné à transformer les documents XML d'un schéma XML dans un autre.

Remarque

  • XSLT est une recommandation W3C. Pour plus d'informations sur XSLT, accédez à la page XLST sur le site Web de W3C à l'adresse (www.w3.org/TR/xslt.html).

Pour utiliser le Mappeur BizTalk, vous n'avez pas besoin de tout savoir sur XSLT. Le Mappeur BizTalk est un outil hautement graphique qui affiche deux spécifications côte à côte pour vous permettre de définir les transformations en tirant simplement un trait entre les champs des spécifications. Pour plus d'informations, voir Spécifications de mappage.

Dans le cas où des règles simples, par exemple lorsque le Champ A du Document 1 correspond au Champ B du Document 2, ne suffisent pas, le Mappeur BizTalk fournit une série d'éléments de transformation puissants appelés des fonctoids. Le Mappeur BizTalk contient plus de 60 fonctoids pour vous permettre d'effectuer toutes sortes d'opérations (mathématiques, logiques, de chaîne, de date et d'heure, scientifiques, de base de données, etc.). Il fournit également un fonctoid de script pour écrire vos propres sous-programmes dans Microsoft Visual Basic Scripting Edition (VBScript), si aucun des fonctoids présents n'est approprié à l'opération. Le code VBScript obtenu est directement incorporé dans le XSLT généré par le Mappeur BizTalk. Pour plus d'informations, voir Présentation des fonctoids.

Remarque

  • Vous pouvez effectuer des opérations encore plus puissantes en créant des fonctoids en cascade ; cette méthode consiste à transmettre le résultat de l'exécution d'un fonctoid au fonctoid suivant. Vous pouvez également créer des fonctoids personnalisés dans Visual Basic, par exemple, et les ajouter à votre palette de fonctoids, en vue d'une utilisation ultérieure.

Pour notre scénario professionnel, vous avez créé un mappage qui traduit le document Requisition de Northwind Traders en ordre d'achat pour Contoso. Ce mappage est stocké dans le fichier ContosoPOMap.xml qui se trouve dans le répertoire C:\LearnBizTalk\Documents\. Si vous ouvrez ce mappage dans le Mappeur BizTalk, vous verrez l'écran représenté dans l'illustration suivante.

ContosoPOMap.xml ouvert dans le Mappeur BizTalk

La plupart des champs requis pour créer l'ordre d'achat pour Contoso figurent déjà dans le document Requisition, peut-être sous un autre nom. Certains champs, tels que PONumber, sont nouveaux et leur valeur doit donc être générée.

Comme vous pouvez le constater, nous avons utilisé trois fonctoids dans ce mappage :

  • un fonctoid de concaténation de chaînes qui combine deux champs d'adresse de la demande en un seul champ dans l'ordre d'achat ;

  • un fonctoid de date/heure qui génère l'horodatage actuel du champ created ;

  • un fonctoid de script qui implémente une règle professionnelle spécifique pour générer un numéro d'ordre d'achat (dans cet exemple, le fonctoid a choisi un numéro au hasard).

Étant donné que la valeur de certains champs de destination ne change pas dans le temps (par exemple, le nom et l'adresse de votre société), le Mappeur BizTalk vous permet de spécifier l'utilisation de valeurs constantes. Pour ce faire, mettez en surbrillance le champ pour lequel vous devez fournir une valeur constante, cliquez sur l'onglet Valeurs et tapez la valeur. L'onglet Valeurs est présenté dans l'illustration suivante.

Onglet Valeurs du Mappeur BizTalk

Remarque

  • Vous ne pouvez pas établir une liaison vers un nœud dans une spécification de destination qui possède une valeur de constante de destination associée.

Pour plus d'informations sur la création d'un mappage, reportez-vous au Module 2 du Didacticiel de BizTalk Server 2002.

Passez à Utilisation du mappage.


Utilisation du mappage

Maintenant que le mappage est créé, retournons au Gestionnaire d'Échanges BizTalk pour configurer le canal appelé Channel To Contoso, qui sert à transmettre l'ordre d'achat à Contoso, Ltd en utilisant le mappage.

Il s'agit du même canal que vous avez spécifié dans le schéma de planification XLANG décrit dans la Leçon 4 lorsque vous avez configuré le port qui a envoyé le document Requisition à Contoso, Ltd. Remarquez que la planification XLANG envoie le même document Requisition qu'elle a reçu et qu'elle ne détecte aucune transformation potentielle à ce document (par exemple, la traduction en ordre d'achat), qui s'effectuera ultérieurement dans les services d'échanges BizTalk. C'est grâce à cette séparation entre un processus professionnel utilisé pour l'acceptation de la demande et les détails techniques sous-jacents à la gestion du format de document et au mécanisme de transmission que la solution globale est si souple et si facilement adaptable.

Ici, l'élément clé est que les services d'orchestration BizTalk constituent la technologie de création des processus professionnels, alors que les services d'échanges BizTalk représentent la technologie pour envoyer en toute sécurité des documents entre des processus professionnels en vue de leur intégration.

À l'avenir, si Contoso, Ltd décide de changer le format de ses ordres d'achat, il vous suffira de mettre à jour la spécification pour les ordres d'achat de Contoso ainsi que le mappage pour refléter les modifications apportées à la spécification, au lieu de recréer la totalité du processus professionnel.

Lorsque vous configurez le canal dans le Gestionnaire d'Échanges BizTalk, si vous spécifiez une définition de document sortant différente de celle du document entrant, le Gestionnaire d'Échanges BizTalk vous demandera automatiquement de fournir un mappage pour traduire ces spécifications de document. L'illustration suivante indique où le mappage est identifié.

Page Document sortant de l'Assistant Propriétés de canal

Pour ouvrir le canal vers Contoso et afficher les propriétés du canal :

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Si le Gestionnaire d'échanges BizTalk apparaît, cliquez sur Annuler.

  3. Dans la zone Rechercher d'autres éléments, cliquez sur Canaux.

  4. Cliquez sur Rechercher.

Dans la liste Nom du canal, double-cliquez sur Channel to Contoso.

  5. Cliquez sur Suivant à trois reprises pour accéder à la page Document sortant.

Passez à Exécution du scénario.


Exécution du scénario

Important

  • Pour lancer avec succès ce scénario, vous devez copier le répertoire LearnBizTalk sur l'unité C de votre disque et y installer tous les composants BizTalk Server. Il est possible d'exécuter les fichiers à partir d'une autre unité de disque et d'un autre répertoire mais dans ce cas, des modifications importantes doivent être apportées aux fichiers source. Pour plus d'informations sur ces conditions requises, voir Leçons sur BizTalk Server 2002.

Pour lancer le scénario

  1. Accédez au répertoire C:\LearnBizTalk\Scripts\ et double-cliquez sur le fichier L5Post.vbs.

    Ce script supprime les modifications temporaires que vous avez apportées au processus d'orchestration à la fin de la Leçon 3 et permet aux services d'orchestration BizTalk d'envoyer le document aux services d'échanges BizTalk.

  2. Copiez le fichier ReqToDecline.xml du répertoire C:\LearnBizTalk\Documents\ dans le répertoire C:\LearnBizTalk\Pickup\.

    Comme auparavant, la demande est refusée et vous recevez un message pour vous en informer.

  3. Recommencez l'étape 2 avec, cette fois-ci, le fichier ReqToApprove.xml.

    La demande est acceptée et les services d'orchestration BizTalk l'envoient aux services d'échanges BizTalk.

    Le canal reçoit le document, le convertit en ordre d'achat Contoso en appliquant le mappage que vous avez spécifié, puis les services d'échanges BizTalk enregistrent le document obtenu sous le nom ContosoPO.xml dans le répertoire C:\LearnBizTalk\Output\.

    Remarque

    • Aucun message ne s'affiche pour indiquer que la demande est acceptée lorsque ce message est enregistré dans un fichier.
  4. Accédez au répertoire C:\LearnBizTalk\Output\ et double-cliquez sur le fichier ContosoPO.xml pour l'ouvrir dans Microsoft Internet Explorer.

    Consultez les valeurs du champ PONumber qui ont été générées au hasard par le fonctoid de script, le champ created contenant l'heure à laquelle ce fichier a été généré et le champ address contenant les valeurs des deux champs d'origine addr1 et addr2 concaténés par le fonctoid de chaîne.

Pour savoir comment utiliser le Mappeur BizTalk en suivant un didacticiel, reportez-vous au Module 2 du Didacticiel de BizTalk Server 2002.

Dans la leçon suivante, vous apprendrez différentes méthodes pour transmettre les documents à vos partenaires commerciaux et de quelle manière les protocoles Internet standard facilitent, là encore, l'exécution de cette opération.

Passez à la Leçon 6 : Envoi et réception de documents.


Leçon 6 : Envoi et réception de documents

La présente leçon concerne le processus utilisé par Northwind Traders pour envoyer l'ordre d'achat à Contoso, Ltd, ainsi que son mode de réception et de stockage par Contoso.

Cette leçon aborde les sujets suivants :

  • Choix d'un protocole

  • Réception de documents en utilisant le protocole HTTP

  • Utilisation de la file d'attente

  • Exécution du scénario


Choix d'un protocole

Une fois l'ordre d'achat généré, il faut l'envoyer à Contoso, Ltd qui doit le traiter. Lorsque vous choisissez un service de transport pour cette tâche, vous devez prendre en compte plusieurs points importants :

  • Le service de transport doit utiliser un protocole standard : en effet, votre partenaire commercial (Contoso) doit pouvoir recevoir des documents avec différents logiciels, sous n'importe quelle plate-forme.

  • Le service de transport que vous choisissez doit être fiable : vous voulez être certain que le document a été réellement reçu par votre partenaire commercial.

  • Le service de transport doit être sécurisé : vous souhaitez pouvoir crypter la totalité du processus de transmission, en cas de confidentialité.

Pour notre scénario, nous avons choisi un service de transport qui utilise le protocole HTTP (Hypertext Transfer Protocol). HTTP est un protocole standard utilisé par les navigateurs Internet pour récupérer des informations des serveurs Web. La plupart des administrateurs de pare-feu d'entreprise autorisent sans crainte la transmission de documents hors de la société via HTTP. Ceci est un aspect important dans le choix du service de transport approprié. Puisque votre serveur exécutant Microsoft BizTalk Server doit communiquer avec des applications internes, des bases de données et d'anciens systèmes, il doit être situé dans le pare-feu. Il peut avoir besoin, en même temps, d'envoyer et de recevoir des documents d'un partenaire externe, de préférence en utilisant un protocole connu, capable de traverser le pare-feu.

Du point de vue du transport, le protocole HTTP est fiable car il définit une méthode standard pour que la réception communique en retour l'état de la transmission à l'expéditeur. Du point de vue du processus professionnel, vous souhaitez pouvoir récupérer vos données en cas de panne de transmission, suite à des problèmes temporaires sur Internet. Le serveur BizTalk Server est capable de surveiller le processus de transmission, de relancer l'envoi des documents en fonction du nombre de tentatives que vous avez spécifiées dans la configuration et d'avertir l'administrateur si la transmission ne s'est pas déroulée correctement.

Enfin, la variante sécurisée de HTTP, le protocole HTTPS (Secure Hypertext Transfer Protocol), permet de crypter la totalité de la transmission à l'aide d'algorithmes standard. HTTPS crypte la totalité du flux de communication avec un partenaire commercial. Pour renforcer la sécurité, vous pouvez utiliser ce protocole en plus du cryptage et de la signature numérique des documents.

Remarque

  • Une autre méthode pour envoyer des documents aux partenaires commerciaux consiste à utiliser le service de transport de fichier pour enregistrer un document dans un fichier sur le disque dur, puis à demander à un autre processus de sélectionner le fichier pour le transmettre au partenaire à l'aide du numéroteur EDI-VAN ou d'un processus FTP.

Pour plus d'informations sur les services de transport pris en charge par BizTalk Server 2002, voir Services de transport.

Passez à Réception de documents en utilisant le protocole HTTP.


Réception de documents en utilisant le protocole HTTP

Voyons maintenant ce qu'il faut faire au niveau de la réception pour accepter un document transmis par BizTalk Server via HTTP, et pour le traiter. Pour notre scénario, nous supposons que Contoso, Ltd utilise également BizTalk Server pour recevoir les ordres d'achat et pour générer et envoyer les factures.

Étant donné que le serveur BizTalk Server s'exécute sur Microsoft Windows 2000 Server, une plate-forme sur laquelle Internet Information Services (IIS) 5.0 est installé, Contoso peut utiliser un script ASP (Active Server Pages) pour accepter les documents de BizTalk Server du côté de Northwind Traders et pour les envoyer à BizTalk Server du côté de Contoso, Ltd, en vue de leur traitement.

Remarque

  • Dans ce didacticiel, nous utilisons une instance unique de BizTalk Server pour simuler le traitement de Northwind Traders et celui de Contoso, Ltd. Dans un environnement de production réel, ce traitement serait effectué sur deux serveurs séparés, s'exécutant sur le site de chacune des deux sociétés.

Lorsqu'un script ASP reçoit le document, il doit éventuellement le renvoyer à BizTalk pour un traitement plus poussé. Pour ce faire, vous avez le choix entre plusieurs méthodes, mais nous tenons à souligner l'importance que représente la création d'une solution permettant de réaliser cette opération en toute sécurité.

Par exemple, si les serveurs de Contoso sont temporairement hors tension en raison d'une maintenance programmée ou d'une mise à jour, ou bien s'ils font face à une charge anormalement élevée de sorte que le traitement des ordres d'achat ne peut pas s'effectuer en temps réel, ceci ne doit pas affecter la capacité d'envoi des ordres d'achat de Northwind Traders ou d'un autre partenaire commercial. En effet, Northwind Traders est censé ne rien savoir sur ce qui se passe du côté de Contoso ou sur la technologie utilisée, excepté que l'ordre d'achat peut être transmis correctement. C'est la raison pour laquelle, bien que BizTalk Server offre une solution standard pour accepter les documents à l'aide de COM, cette approche n'est pas recommandée dans ce cas de figure.

Voici un meilleur moyen pour résoudre ce problème. Dès que le script ASP reçoit le document transmis, il doit l'enregistrer dans un fichier sur un disque dur, puis se fermer en indiquant que le document a été correctement transmis. Pendant ce temps, BizTalk Server peut récupérer le document enregistré et le traiter d'une manière totalement asynchrone. La Leçon 2 vous a présenté les fonctions de réception de fichier dans les services d'échanges BizTalk et vous a expliqué comment les utiliser pour envoyer un fichier vers un emplacement spécifique, sous la surveillance de BizTalk Server. C'est pourquoi, dans ce scénario, le script ASP peut enregistrer un document dans un fichier qui sera ultérieurement sélectionné par une fonction de réception de fichier. Ce type d'architecture offre une grande souplesse pour décider exactement à quel moment BizTalk Server doit traiter les documents et pour ajouter des serveurs BizTalk Server supplémentaires afin de traiter les documents, au gré de l'évolution de l'entreprise.

La rubrique suivante présente une autre solution pour obtenir les mêmes résultats fiables sans enregistrer les documents dans des fichiers. De plus, cette solution a l'avantage d'être transactionnelle.

Passez à Utilisation de la file d'attente.


Utilisation de la file d'attente

Message Queuing (également appelé MSMQ) est l'un des composants standard de Windows 2000 Server. Il permet d'une manière simple et fiable de créer une solution asynchrone, exactement comme celle que nous concevons ici.

Lorsque le document est reçu par un script ASP, au lieu de l'enregistrer dans un fichier sur un disque dur, vous pouvez l'envoyer en tant que message dans une file d'attente de messages, puis le transmettre aux services d'échanges BizTalk à l'aide d'une fonction de réception Message Queuing qui fonctionne de la même manière qu'une fonction de réception de fichier. Dans la plupart des configurations, Message Queuing peut être configuré comme étant transactionnel, pour renforcer la fiabilité.

L'illustration suivante représente la totalité du processus :

Leçon 6 : Présentation du processus

Pour créer une fonction de réception Message Queuing

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Administration de BizTalk Server.

  2. Développez Groupe BizTalk Server, cliquez avec le bouton droit sur Fonctions de réception, pointez sur Nouveau, puis cliquez sur Fonction de réception Message Queuing.

    La boîte de dialogue Ajouter une fonction de réception Message Queuing s'affiche.

  3. Dans la zone Nom, tapez un nom pour la fonction et, dans la zone Emplacement de l'interrogation, tapez le nom de la file d'attente correspondant à l'emplacement d'interrogation.

  4. Cliquez sur Avancé.

    La boîte de dialogue Options de fonction de réception avancées apparaît.

  5. Dans la zone Nom du canal, sélectionnez dans la liste déroulante le canal devant traiter les documents reçus par cette fonction.

    Remarques

    • Si vous utilisez une file d'attente de messages privée pour stocker les documents, entrez le nom de la file d'attente dans le format suivant : DIRECT=OS:.\private$\<NomFileAttente>.

    • Si vous utilisez une file d'attente publique, entrez le nom de la file d'attente dans le format suivant : DIRECT=OS:<NomServeur>\<NomFileAttente>.

Vous pouvez consulter les propriétés de la fonction de réception Message Queuing ReceivePO qui a été configurée au cours de l'installation. Cette fonction de réception traitera les ordres d'achat acceptés par le scripts ASP que vous avez étudié précédemment. Elle a été temporairement suspendue, afin que les documents restent dans la file d'attente pour vous permettre de les examiner. Vous pourrez la réactiver à la fin de cette leçon.

Ensuite, nous allons étudier le script à l'intérieur du fichier ContosoReceive.asp afin de voir toutes les étapes effectuées pour accepter les données transmises par BizTalk Server et pour les envoyer à une file d'attente. Ce code commence par utiliser la méthode BinaryRead d'un objet Request fourni par ASP pour lire toutes les données transmises. Ensuite, Microsoft® ActiveX® Data Objects (ADO) est utilisé pour transformer les données reçues du format binaire au format texte. Enfin, les fonctions Message Queuing sont utilisées pour créer un nouveau message de file d'attente et l'envoyer à la file d'attente privée de votre choix.

Vous pouvez voir la totalité du code source dans le fichier ContosoReceive.asp situé dans le répertoire C:\LearnBizTalk\ASP\.

Passez à Exécution du scénario.


Exécution du scénario

Important

  • Pour lancer avec succès ce scénario, vous devez copier le répertoire LearnBizTalk sur l'unité C de votre disque et y installer tous les composants BizTalk Server. Il est possible d'exécuter les fichiers à partir d'une autre unité de disque et d'un autre répertoire mais dans ce cas, des modifications importantes doivent être apportées aux fichiers source. Pour plus d'informations sur ces conditions requises, voir Leçons sur BizTalk Server 2002.

Pour lancer le scénario

  1. Accédez au répertoire C:\LearnBizTalk\Scripts\ et double-cliquez sur L6Post.vbs.

    Ce script restaure la configuration du port d'échanges Port To Contoso modifié précédemment et lui ordonne de transmettre les documents à Contoso, Ltd en utilisant un transport HTTP, et non en l'écrivant dans un fichier, comme c'était le cas dans la Leçon 5.

  2. Copiez le fichier ReqToApprove.xml du répertoire C:\LearnBizTalk\Documents dans le répertoire C:\LearnBizTalk\Pickup\.

    Le fichier est traité par une fonction de réception de fichier, envoyé par les services d'échanges BizTalk aux services d'orchestration BizTalk pour approbation, puis retourné aux services d'échanges BizTalk, et enfin transmis à Contoso à l'aide du protocole HTTP.

Un script ASP simulant la partie Contoso, Ltd lit les données transmises, les convertit en document, puis envoie ce dernier dans une file d'attente privée locale.

Ensuite, une fonction de réception Message Queuing doit récupérer le document dans la file d'attente pour l'envoyer aux services d'échanges BizTalk ; cependant, n'oubliez pas que nous avons désactivé temporairement cette fonction de réception pour vous permettre d'examiner le document envoyé dans la file d'attente.

Pour afficher les messages de la file d'attente

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Outils d'administration.

  3. Double-cliquez sur Gestion de l'ordinateur.

    La console Gestion de l'ordinateur s'affiche.

  4. Dans l'arborescence de la console Gestion de l'ordinateur, développez Services et applications, développez Message Queuing, développez Files d'attente privées, puis développez ContosoPOQueue.

  5. Cliquez sur Placer les messages dans une liste d'attente dans le volet gauche pour afficher tous les messages actuellement placés dans la file d'attente.

  6. Cliquez avec le bouton droit sur le message dans le volet droit, cliquez sur Propriétés, puis cliquez sur l'onglet Corps pour afficher le début du corps du message.

Après avoir examiné le message, supprimez-le de la file d'attente en cliquant avec le bouton droit sur Placer les messages dans une liste d'attente dans le volet gauche, puis en cliquant sur Toutes les tâches et sur Purger.

Pour plus d'informations, voir Description des fonctions de réception et du routage de documents.

La leçon suivante concerne les dernières étapes du scénario, à savoir le traitement de l'ordre d'achat par Contoso, la génération de la facture et sa transmission à Northwind Traders.

Passez à la Leçon 7 : Fin de la transaction.


Leçon 7 : Fin de la transaction

Dans cette leçon, vous allez apprendre de quelle manière Contoso, Ltd reçoit l'ordre d'achat envoyé par Northwind Traders sur Internet, traite ce document à l'aide des services d'échanges BizTalk et d'Orchestration BizTalk, génère la facture et la retourne à Northwind Traders. Enfin, vous verrez comment Northwind Traders reçoit la facture et l'enregistre, ce qui constitue la dernière étape de notre exemple de transaction de type acheteur-fournisseur.

L'illustration suivante représente les derniers éléments du scénario.

Leçon 7 : Présentation du processus

Cette leçon aborde les sujets suivants :

  • Message Queuing

  • Traitement de l'ordre d'achat

  • Exécution du scénario


Message Queuing

À la fin de la Leçon 6, un ordre d'achat reçu par un script ASP du côté Contoso, Ltd était envoyé dans une file d'attente de messages. Cette leçon vous a appris à configurer une fonction de réception Message Queuing, qui surveille dans la file d'attente l'arrivée des messages qu'elle transmet aux services d'orchestration BizTalk. Nous avons décidé d'enregistrer les ordres d'achat entrants dans une file d'attente de messages, plutôt que dans des fichiers, parce qu'une file d'attente offre un niveau de fiabilité supplémentaire, puisqu'elle prend en charge les transactions, contrairement au système de fichiers.

Lorsque la fonction de réception Message Queuing retire le document de la file d'attente, elle l'envoie au canal, qui à son tour le transmet au port d'échanges que nous avons créé pour le processus professionnel de Contoso. Ce port d'échanges est configuré pour transporter le document vers une planification XLANG, en indiquant qu'il démarrera une planification XLANG afin d'exécuter le processus professionnel de Contoso de la même manière que le document Requisition qui a été envoyé à la planification XLANG de Northwind Traders dans la Leçon 4.

Passez à Traitement de l'ordre d'achat.


Traitement de l'ordre d'achat

L'activité réelle que représente le traitement d'un véritable ordre d'achat n'est pas la même dans toutes les sociétés. C'est pourquoi, pour simplifier ce scénario, nous avons défini une forme Action unique (Do Some Work) dans le schéma de planification XLANG de Contoso, qui représente toutes les actions à effectuer par un fournisseur, telles que la vérification des niveaux de stock ou la communication à l'entrepôt des instructions d'expédition.

L'implémentation de la forme Action est un simple composant de script Windows, le fichier ProcessPO.wsc, qui affiche un message informant l'utilisateur qu'un ordre d'achat est en cours de traitement. Pour faciliter la création de ce composant, nous avons utilisé l'Assistant Composant de script Windows.

Évidemment, dans un système de production, aucun message ne doit être affiché par les composants des services d'orchestration BizTalk pour la simple raison qu'aucun utilisateur ne sera connecté au serveur à ce moment-là pour observer et accuser réception des messages. Or, tant que personne ne supprime ce message, la planification ne peut pas continuer à s'exécuter, ce qui risque de provoquer des effets indésirables. Un moyen de communication plus approprié consiste à envoyer des messages par courrier électronique ou d'écrire des entrées dans le journal des événements de Windows qui à leur tour peuvent déclencher d'autres actions.

Pour ouvrir le schéma de planification XLANG de Contoso, naviguez jusqu'au répertoire C:\LearnBizTalk\Schedules\ et double-cliquez sur le fichier ContosoInvoice.skv. L'illustration suivante représente le processus des services d'orchestration BizTalk pour Contoso, Ltd tel qu'il est défini dans le schéma de planification XLANG.

Processus des services d'orchestration BizTalk pour Contoso, Ltd

Dans ce schéma de planification XLANG, nous avons utilisé l'Assistant Communication XML pour extraire des valeurs individuelles des champs (à savoir les champs PONumber et Generated) de l'ordre d'achat et les transmettre au composant de script en tant que paramètres, sans qu'il soit nécessaire d'écrire du code. Cette opération est la même que celle que nous avons effectué pour extraire la valeur du champ RequisitionTotal du document Requisition dans la Leçon 4.

Sur la page Données du schéma de planification XLANG, nous avons connecté ces champs aux paramètres d'entrée de la méthode DoWork du composant de script. Comme vous pouvez le remarquer dans l'illustration suivante, la totalité de l'ordre d'achat n'a pas été transmise au composant, mais uniquement les deux champs que nous avons extraits.

Page Données de ContosoInvoice

Lorsque vous lancez ce scénario et cliquez sur OK dans la zone de message affichée par le composant de script, la planification XLANG renvoie l'ordre d'achat aux services d'échanges BizTalk, qui le transforment en facture au moyen d'un autre mappage, avant de l'envoyer à Northwind Traders via le transport HTTP (le même que celui que Northwind Traders a utilisé pour envoyer les ordres d'achat à Contoso, Ltd).

Dès qu'un script ASP du côté Northwind Traders reçoit la facture, il l'enregistre en tant que fichier en vue d'un traitement ultérieur. En situation réelle, ce type de traitement peut consister à faire correspondre la facture avec la demande d'origine et l'ordre d'achat, à mettre à jour les systèmes internes avec les informations de la facture, etc.

Passez à Exécution du scénario.


Exécution du scénario

Important

  • Pour lancer avec succès ce scénario, vous devez copier le répertoire LearnBizTalk sur l'unité C de votre disque et y installer tous les composants BizTalk Server. Il est possible d'exécuter les fichiers à partir d'une autre unité de disque et d'un autre répertoire mais dans ce cas, des modifications importantes doivent être apportées aux fichiers source. Pour plus d'informations sur les conditions préalable à l'exécution du scénario, voir Leçons sur BizTalk Server 2002.

Pour lancer le scénario :

  1. Accédez au répertoire C:\LearnBizTalk\Scripts\ et double-cliquez sur le fichier L7Post.vbs.

    Ce script réactivera la fonction de réception Message Queuing qui a été temporairement suspendue dans la Leçon 6.

  2. Copiez la demande ReqToApprove.xml dans le répertoire C:\LearnBizTalk\Documents, puis collez-la dans le répertoire C:\LearnBizTalk\Pickup.

Voici la liste chronologique des opérations impliquées dans ce scénario :

  1. La fonction de réception de fichier de Northwind Traders lit le fichier « ReqToApprove.xml » que vous avez placé dans le répertoire \Pickup et l'envoie aux processus des services d'orchestration BizTalk de Northwind Traders à l'aide des services d'échanges BizTalk.

  2. La planification XLANG extrait la valeur du champ RequisitionTotal et, puisque cette valeur est inférieure à 1 000 EUR, elle accepte la demande en la renvoyant aux services d'échanges BizTalk.

  3. Les services d'échanges BizTalk reçoivent la demande des services d'orchestration BizTalk et utilisent un mappage pour créer un ordre d'achat. Ce document est ensuite transmis à Contoso, Ltd en utilisant le protocole HTTP conforme aux normes industrielles.

  4. Un script ASP du côté Contoso, Ltd reçoit la transmission, extrait le document et le place en tant que message dans une file d'attente de messages.

  5. Une fonction de réception Message Queuing trouve un nouveau document dans la file d'attente, le récupère et utilise les services d'échanges BizTalk pour l'envoyer aux services d'orchestration BizTalk afin d'y être traité.

  6. La planification XLANG extrait la valeur des champs PONumber et Generated et appelle une méthode sur un composant de script, en affichant un message qui indique l'arrivée de l'ordre d'achat.

  7. La planification XLANG retourne l'ordre d'achat aux services d'échanges BizTalk en vue de la génération de la facture.

  8. Les services d'échanges BizTalk appliquent un mappage pour transformer l'ordre d'achat en facture et envoyer cette dernière à Northwind Traders en utilisant le protocole HTTP.

  9. Un script ASP chez Northwind Traders accepte la transmission, extrait le document et l'enregistre sous le nom de fichier C:\LearnBizTalk\Output\ContosoInvoice.xml.

Le processus d'intégration des processus professionnels et applications internes entre les deux exemples d'entreprise, Northwind Traders et Contoso, Ltd est terminé. L'illustration suivante représente les composants de ce processus, c'est-à-dire les deux planifications XLANG, les services d'échanges BizTalk, les fonctions de réception, les pages ASP et les files d'attente, ainsi que leurs relations.

Présentation du processus complet

Maintenant, si vous ouvrez le répertoire C:\LearnBizTalk\Output, vous y trouverez un fichier nommé ContosoInvoice.xml contenant la facture que la société Northwind Traders a reçue de Contoso, Ltd et qu'elle a enregistré dans ce fichier.

Passez à la Conclusion.


Conclusion

Tout au long de ces sept leçons, vous avez assisté à la création d'un scénario d'intégration totalement opérationnel entre un acheteur et un fournisseur.

Nous espérons que ces leçons vous ont aidé à mieux comprendre Microsoft BizTalk Server, et à prendre conscience à quel point BizTalk Server peut réduire la charge de travail engendrée par l'intégration de processus inter-entreprises.

Pour annuler les modifications de configuration apportées à votre installation de BizTalk Server par les scripts que vous avez exécutés dans le cadre de ces leçons, lancez le script Cleanup.vbs situé dans le répertoire C:\LearnBizTalk\Scripts\. Une fois ce script terminé, ce qui est indiqué dans un message, vous pouvez supprimer en toute sécurité le répertoire C:\LearnBizTalk et tous les fichiers qu'il contient.

Pour savoir comment configurer les processus BizTalk Server en suivant un didacticiel, reportez-vous au Didacticiel de BizTalk Server 2002. Le Didacticiel BizTalk Server vous aidera à mieux comprendre l'utilisation de l'Éditeur BizTalk, du Mappeur BizTalk, du Gestionnaire d'échanges BizTalk, de la console Administration de BizTalk Server et du Concepteur d'Orchestration BizTalk pour configurer BizTalk Server en vue d'exécuter un processus d'approvisionnement automatisé inter-entreprises.

Pour plus d'informations sur BizTalk Server 2002, accédez au site Web de Microsoft BizTalk Server à l'adresse suivante : www.microsoft.com/france/biztalk/. Vous trouverez sur ce site des informations techniques sur le produit, des livres blancs, des formations et événements ainsi que des offres de services d'autres sociétés.


Exemple d'approvisionnement électronique

Cet exemple illustre les nouvelles fonctionnalités de Microsoft® BizTalk™ Server 2002 :

  • Assistant BizTalk SEED - Activation rapide de partenaire

  • Déploiement de Application Center 2000

  • Fonctions de contrôle avancées à l'aide de MOM (Microsoft Operations Manager)

  • Nouvelle corrélation XLANG à l'aide de files d'attente communes au lieu de files d'attente par instance

  • Fonction de réception HTTP

Ce scénario analyse une situation commerciale dans laquelle votre entreprise achète des produits de plusieurs fournisseurs différents. À l'aide de Microsoft BizTalk Server 2002, d'Internet et des fonctionnalités de corrélation, elle définit une solution commerciale qui automatise le processus d'approvisionnement entre votre entreprise et ses fournisseurs. Il s'agit d'une solution d'approvisionnement électronique.

Dans ce scénario, vous définissez un concentrateur pour votre entreprise. Le concentrateur gère toutes les commandes, factures et paiements émis et reçus par les fournisseurs. L'application EprocSetup incluse dans cet exemple configure le concentrateur et un système de fournisseur pour utiliser BizTalk Server, Internet et les fonctions de corrélation pour gérer ces documents et exécuter le processus d'approvisionnement. Une fois la configuration effectuée, exécutez le script DocumentGenerator.vbs pour démarrer une transaction selon laquelle une commande est envoyée au fournisseur, une facture est émise par le fournisseur et le concentrateur envoie un paiement. Enfin, le fournisseur envoie un accusé de réception de paiement, ce qui clôt le processus d'approvisionnement. L'illustration suivante présente la transaction commerciale utilisée dans cet exemple.

Flux de données dans une transaction commerciale

Lorsque le modèle d'approvisionnement électronique fonctionne correctement, notre objectif est de déployer cette configuration vers d'autres serveurs à l'aide de Microsoft Application Center 2000, afin que cette configuration passe d'un environnement de test à un environnement de production. Nous expliquons également comment présenter la configuration du fournisseur en utilisant l'Assistant BizTalk SEED, afin qu'elle puisse être facilement récupérée à partir de votre site Web et mise en oeuvre par d'autres fournisseurs. Enfin, nous décrivons comment vous pouvez configurer Microsoft Operations Manager (MOM) pour contrôler les activités du concentrateur.

Les rubriques suivantes décrivent l'installation et les configurations nécessaires pour utiliser ce scénario :

  • Guide d'utilisation
    • Installation préliminaire

    • Exécution de l'exemple d'approvisionnement électronique
  • Notes de programmation

  • Procédures de contrôle et de déploiement optionnelles
    • Utilisation de Microsoft Application Center pour le déploiement d'une solution d'approvisionnement électronique

    • Création d'un package SEED

    • Création d'un compte MOM personnalisé pour l'exemple d'approvisionnement électronique


Guide d'utilisation

Avant d'exécuter cet exemple, vous devez attacher les bases de données de corrélation et exécuter le programme d'installation de la solution d'approvisionnement électronique.

Important

  • Les instructions dans cet exemple présupposent que cet exemple et BizTalk Server 2002 sont installés sur le même lecteur.

  • Les fichiers d'exemples eProcurement doivent être copiés dans le dossier eProcurementSample à la racine du lecteur. Ces fichiers d'exemples sont situés à la racine du CD-ROM BizTalk Server 2002, dans le dossier eProcurementSample.

  • Après avoir copié les fichiers sur votre lecteur, vérifiez que le dossier vide PaymentAckReceived est placé immédiatement sous le dossier ePprocurementSample. Créez le dossier PaymentAckReceived s'il n'existe pas.

Pour préparer et exécuter l'exemple d'approvisionnement électronique, effectuez les procédures suivantes :

  • Installation préliminaire

  • Exécution de l'exemple d'approvisionnement électronique


Installation préliminaire

Les étapes décrites dans cette section expliquent comment configurer votre système pour exécuter l'exemple d'approvisionnement électronique. Avant de l'exécuter, vous devez attacher les bases de données de corrélation et configurer le concentrateur et les systèmes fournisseurs. Dans ce scénario, le concentrateur et le fournisseur sont configurés sur une installation BizTalk Server. Dans un environnement de production réel, le concentrateur et le fournisseur sont deux entités complètement distinctes.

Conditions préalables

Cet exemple suppose que les composants suivants sont installés sur l'ordinateur exécutant BizTalk Server :

  • Microsoft BizTalk Server 2002

  • Microsoft SQL Server™

  • Message Queuing (également appelé MSMQ)

Remarque

  • Si vous souhaitez poursuivre avec la section Application Center de cet exemple, vous devez installer Application Center avant d'installer BizTalk Server.

  • Il est également recommandé d'exécuter cet exemple sur une nouvelle installation complète de BizTalk Server. Si vous souhaitez supprimer rapidement tous les objets BizTalk Server (ports, canaux, etc.), vous pouvez exécuter le script CleanBTM.vbs qui se trouve dans le répertoire eProcurementSample.

Important

  • Le script CleanBTM.vbs supprime toutes les informations de configuration de la base de données BizTalk Messaging Management. Ce script ne peut être exécuté que dans un environnement de test.

Attachement des bases de données

Dans cette procédure, vous définissez, à l'aide de Microsoft SQL Server 2000, les bases de données de corrélation utilisées avec l'exemple d'approvisionnement électronique. Si vous utilisez Microsoft SQL Server 7.0, reportez-vous à la section « Création des bases de données ». Il existe deux bases de données de corrélation, une pour le concentrateur et une pour le fournisseur. Ces bases de données capturent et contiennent l'identificateur unique global (GUID) et l'identificateur TransactionID généré lorsque la planification XLANG commence. Les identificateurs GUID et TransactionID permettent de corréler les documents envoyés et reçus dans cette transaction vers la planification XLANG correcte. L'identificateur TransactionID représente, par exemple, un numéro de commande ou un numéro de facture.

Remarque

Les instructions suivantes présupposent que SQL Server 2000 est installé sur le même ordinateur que BizTalk Server. Si ce n'est pas le cas, vous devrez les modifier pour qu'elles fonctionnent dans votre environnement. Avant de commencer cette procédure, vérifiez que les propriétés des bases de données CustomCorrelation_Data et SupplierCustomCorrelation_Data ne sont pas en lecture seule. Les fichiers de bases de données se trouvent dans le répertoire Databases, situé dans le répertoire eProcurementSample.

  1. Dans le menu Démarrer, pointez sur Programmes, sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

    SQL Server Enterprise Manager apparaît.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, ainsi que le serveur auquel vous voulez attacher la base de données.

  3. Cliquez sur Bases de données.

  4. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Attacher une base de données.

    La boîte de dialogue Attacher la base de données s'affiche.

  5. Cliquez sur le bouton (…).

    La boîte de dialogue Rechercher un fichier existant apparaît.

  6. Déplacez-vous jusqu'au répertoire Databases situé dans le répertoire eProcurementSample.

  7. Cliquez sur CustomCorrelation_Data.MDF, puis sur OK.

    Un message indiquant que le processus a été exécuté correctement s'affiche.

  8. Répétez lez étapes de cette procédure pour lier le fichier SupplierCustomCorrelation_Data.MDF qui se trouve dans le répertoire Databases, situé dans le répertoire eProcurementSample.

Création des bases de données

Exécutez la procédure suivante si vous utilisez Microsoft SQL Server 7.0 dans votre installation BizTalk Server.

  1. Dans le menu Démarrer, pointez sur Programmes, Microsoft SQL Server 7.0, puis cliquez sur Enterprise Manager.

    SQL Server Enterprise Manager apparaît.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, ainsi que le serveur auquel vous voulez lier la base de données.

  3. Cliquez sur Bases de données.

  4. Dans le menu Action, cliquez sur Nouvelle base de données.

    Vous pouvez alors choisir le menu Propriétés de la base de données.

  5. Dans la zone Nom, entrez le nom de la base de données : CustomCorrelation.

  6. Cliquez sur OK.

  7. Dans le menu Action, cliquez sur Nouvelle base de données.

  8. Le menu Propriétés de la base de données apparaît à l'écran.

  9. Dans la zone Nom, entrez le nom de la base de données : SupplierCustomCorrelation.

  10. Cliquez sur OK.

  11. Fermez SQL Server Enterprise Manager.

  12. Dans le menu Démarrer, pointez sur Programmes, Microsoft SQL Server 7.0, puis cliquez sur Analyseur de requêtes.

    Le menu Connexion à SQL Server s'affiche.

  13. Vérifiez que vous avez entré les informations correctes pour vous connecter à SQL Server. Cliquez sur OK.

  14. Dans la barre de menus, vérifiez que la valeur inscrite dans le champ DB est CustomCorrelation. Si tel n'est pas le cas, cliquez sur la zone de liste déroulante DB et sélectionnez CustomCorrelation.

  15. Dans le menu Fichier, cliquez sur Ouvrir.

  16. Déplacez-vous jusqu'au répertoire Databases situé dans le répertoire eProcurementSample.

  17. Cliquez sur le fichier CustomCorrelationTable.sql.

  18. Dans le menu Requête, cliquez sur Exécuter. Le fichier CustomCorrelationTable.sql est alors traité. Si vous avez exécuté le fichier SQL, le message suivant apparaît : La (les) commande(s) a (ont) réussi.

  19. Répétez les étapes de cette procédure pour le fichier SupplierCustomCorrelationTable.sql.

  20. Fermez Analyseur de requêtes.

Installation de l'exemple d'approvisionnement électronique

Cette procédure exécute l'application d'installation pour configurer BizTalk Server et permettre au concentrateur et au fournisseur d'exécuter l'exemple d'approvisionnement électronique.

Le programme d'installation accomplit les tâches suivantes :

  • Création des files d'attente de messages :

    .\private$\receiveinvoice

    .\private$\receivepayment

    .\private$\receivepaymentack

    .\private$\receivepo

    .\private$\receivepo2

    .\private$\supplierreceivepo

    .\private$\supplierreceivepo2

    Les files d'attente permettent de transférer des données entre les partenaires commerciaux représentés par les planifications XLANG exécutées au niveau du concentrateur et du fournisseur.

  • Création des répertoires virtuels

    Les répertoires virtuels utilisent les fonctions de réception HTTP pour permettre à un partenaire commercial d'envoyer les données à BizTalk Server.

    Une fois terminée, la structure de votre répertoire virtuel doit ressembler à l'illustration suivante :

    Alias | Structure du site Web | Chemin d'accès
    hub | Hub | \Program Files\Microsoft BizTalk Server\HTTP Receive
    paymentack | hub/paymentack | \Program Files\Microsoft BizTalk Server\HTTP Receive
    supplier | Supplier | \Program Files\Microsoft BizTalk Server\HTTP Receive
    payment | supplier/payment | \Program Files\Microsoft BizTalk Server\HTTP Receive

    Remarque

    • La valeur Protection d'application est définie sur Basse (Processus IIS) pour tous les répertoires virtuels utilisés dans cet exemple. La valeur par défaut est Moyenne (En file d'attente).
  • Création des canaux et des ports

    Chaque canal est configuré pour remplacer les valeurs par défaut des ports d'échange et associer le message à une instance de planification XLANG spécifique en utilisant l'étiquette du message.

  • Enregistrement des composants COM

  • Déplacement des spécifications des documents vers le dossier WebDAV (Web Distributed Authoring and Versioning)

  • Création des fonctions de réception HTTP

  • Configuration de la base de données Gestion d'échanges BizTalk

  • Enregistrement des DLL nécessaires

Avant d'exécuter l'application d'installation, vérifiez qu'aucune liste d'attente de messages recensée ci-dessus n'existe. L'installation de l'exemple d'approvisionnement électronique pourrait échouer.

Pour installer l'exemple d'approvisionnement électronique :

  1. Dans l'Explorateur Windows®, accédez au répertoire \COM Components\Setup situé dans le répertoire eProcurementSample.

  2. Double-cliquez sur eProcSetup.exe.

    La boîte de dialogue d'installation s'affiche.

  3. Cliquez sur eProcurement Setup.

    Une boîte de dialogue indiquant la réussite de l'installation s'affiche.

Poursuivez l'exécution de l'exemple d'approvisionnement électronique.


Exécution de l'exemple d'approvisionnement électronique

L'exemple d'approvisionnement électronique montre comment corréler les champs définis par l'utilisateur dans une planification XLANG. Ceci vous permet d'utiliser une valeur de données qui identifie de manière unique un document, comme un numéro de bon de commande, et d'associer cet identificateur à une instance de planification XLANG en cours d'exécution pour traiter un document à travers les étapes d'une transaction commerciale.

Pour exécuter cet exemple, procédez comme suit :

  1. Dans l'Explorateur Windows, accédez au répertoire eProcurementSample.

  2. Démarrez l'Observateur d'événements XLANG situé dans \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools.

  3. Double-cliquez sur DocumentGenerator.vbs.

Pour vérifier l'exécution correcte de la transaction, accédez au répertoire PaymentAckReceived dans le répertoire eProcurementSample. Ce répertoire doit contenir un fichier XML d'accusé de réception de paiement qui utilise la convention de désignation suivante : payack_[GUID].xml.

Pour exécuter cet exemple et faire en sorte que le bon de commande soit rejeté sur le concentrateur, modifiez le paramètre POTotal dans PO.xml en définissant une valeur supérieure à 1000. Pour exécuter cet exemple et faire en sorte que le bon de commande soit rejeté par le système d'approvisionnement, appliquez au paramètre POTotal dans PO.xml une valeur inférieure à 300. Le fichier PO.xml est situé dans le répertoire eProcurementSample.

Remarque

  • Par défaut, les planifications du concentrateur et du fournisseur sont liées au composant de script Windows situé dans C:\EprocurementSample\Script Components\Message.wsc. Si le composant n'existe pas à cet emplacement, la planification échoue. Pour résoudre ce problème, ouvrez les planifications dans le Concepteur d'orchestration BizTalk et utilisez l'Assistant Liaison des composants de script pour réassocier le fichier de script au lecteur et au chemin appropriés du composant.

Passez à Notes de programmation.


Notes de programmation

Activation de la planification XLANG d'approvisionnement électronique

Lorsque vous exécutez cet exemple, le fichier PO.xml est ignoré dans la file d'attente ReceivePO, une planification XLANG est activée et le processus d'approvisionnement électronique commence. Le port d'échanges HubReceivePO active une nouvelle instance du fichier hub.skx de planification XLANG, puis il fournit le document sur le port ReceivePO. Lorsque le bon de commande est approuvé, il est envoyé au concentrateur. Le concentrateur envoie le bon de commande au fournisseur et attend une facture en retour.

La fonction de réception HTTP permet de fournir le bon de commande au fournisseur. Lorsque le fournisseur reçoit le bon de commande, une planification XLANG est activée sur le système fournisseur et le processus commence sur ce dernier. Le port d'échange SupplierReceivePO active une nouvelle instance de supplier.skx de la planification XLANG, puis il remet le document au port ReceivePOfromHub. Lorsque le bon de commande est transformé en facture, il est renvoyé au concentrateur.

La fonction de réception HTTP permet de remettre la facture au concentrateur. Le concentrateur reçoit la facture et envoie un paiement. La fonction de réception HTTP permet de fournir le paiement au fournisseur. Lorsque le fournisseur reçoit le paiement, il envoie un accusé de réception. La transaction est terminée lorsque le concentrateur reçoit l'accusé de réception et que celui-ci est enregistré dans un fichier du répertoire \eProcurementSample\PaymentAckReceived.

Corrélation de la planification XLANG d'approvisionnement électronique

Le moteur de XLANG Scheduler affecte un identificateur global unique (GUID) à chaque instance d'une planification XLANG. Dans cet exemple, l'identificateur global unique est extrait du message, enregistré dans une base de données de corrélation et associé à un identificateur TransactionID, tel un numéro de bon de commande ou de facture.

Plus précisément, lorsque le concentrateur reçoit un bon de commande, l'identificateur global unique est extrait, enregistré dans la base de données CustomCorrelation et associé à un identificateur TransactionID. Lorsque le fournisseur reçoit le bon de commande, il voit l'identificateur TransactionID, mais il génère également un identificateur global unique (GUID) et son propre identificateur TransactionID qui doivent être stockés dans la base de données SupplierCustomCorrelation. Ces valeurs permettent de corréler les messages entrants et sortants avec l'instance de planification appropriée en cours d'exécution, tandis que la transaction évolue du bon de commande à la facture, de la facture au paiement, et se termine par l'accusé de réception de paiement. La corrélation commence réellement lorsque le concentrateur reçoit une facture et que cette dernière doit être associée au bon de commande et à la planification XLANG appropriés.

Pour plus d'informations sur la corrélation, voir :

Corrélation d'une planification XLANG

Gestion des instances

Désinstallation de l'exemple d'approvisionnement électronique

Aucun script n'est fourni pour supprimer les fichiers et les objets de configuration d'Échanges BizTalk, comme les ports et les canaux, qui sont créés par l'exécution de l'application d'installation. La liste suivante contient les objets, les fichiers, les dossiers et les bibliothèques de configuration d'échanges BizTalk utilisés par cet exemple. Ceux-ci peuvent être supprimés manuellement après l'exécution de cet exemple.

Organisations

Concentrateur, Fournisseur

Canaux

HubReceivePO, HubSendPO, SupplierReceivePO, HubReceiveInvoice, SupplierSendInvoice, HubSendPayment, SupplierReceivePayment, SupplierSendPaymentAck, HubReceivePaymentAck, HubSendPayAckToFile

Définitions de document

EcommonInvoice, EcommonPayment, EcommonPO, EPaymentAck

Ports d'échanges

HubReceivePO, HubSendPO, SupplierReceivePO, HubReceiveInvoice, SupplierSendInvoice, HubSendPayment, SupplierReceivePayment, SupplierSendPaymentAck, HubReceivePaymentAck, HubSendPayAckToFile

Fonctions de réception (dans Administration de BizTalk Server) :

HubReceiveInvoice, HubReceivePaymentAck, Receive PO, SupplierReceivePayment, SupplierReceivePO

Files d'attente de messages privées (dans le composant Gestion de l'ordinateur)

receiveinvoice, receivepayment, receivepaymentack, receivepo, receivepo2, supplierreceivepo, supplierreceivepo2

Fichiers du référentiel BizTalk Server (WebDAV)

ECommonInvoice.xml, eCommonPayment.xml, ECommonPO.xml, ePaymentAck.xml

Bibliothèques enregistrées

Correlation.dll, HubTransformation.dll, PaymentTransformation.dll, SuppCorrelation.dll, Transformation.dll

Dossiers dans \Microsoft BizTalk Server\HTTP Receive

Hub
Hub/PaymentAck
Supplier
Supplier/Payment

Remarque

  • Un répertoire virtuel IIS (Internet Information Services) est associé à chaque dossier.


Procédures de contrôle et de déploiement optionnelles

Vous devez configurer et exécuter l'exemple d'approvisionnement électronique avant de continuer. Toutefois, les procédures suivantes sont facultatives.

Les procédures de contrôle et de déploiement requièrent les conditions préalables suivantes :

  • Pour lancer la procédure de déploiement, Application Center 2000 doit être en cours d'exécution.

  • La procédure d'installation MOM (Microsoft Operations Manager) inclut la configuration de MOM pour exploiter les fonctions de contrôle avancées. Cette procédure requiert MOM 2000 et BizTalk Server 2002 Management Pack.

Cette section traite des rubriques suivantes :

  • Utilisation de Application Center pour le déploiement d'une solution d'approvisionnement électronique

  • Création d'un package SEED

  • Création d'un compte MOM personnalisé pour l'exemple d'approvisionnement électronique


Utilisation de Application Center pour le déploiement d'une solution d'approvisionnement électronique

Application Center 2000 peut être utilisé pour déployer une configuration de BizTalk Server entre deux environnements, notamment d'un environnement de test à un environnement de production. Le déploiement d'un environnement à l'aide de Application Center permet de réduire considérablement le temps nécessaire au changement de configuration et l'intervention de l'utilisateur associée à une telle opération.

Dans ce scénario, le concentrateur réside sur un serveur (la source), et nous allons déployer la configuration de BizTalk Server sur un autre serveur (la cible) au sein de l'organisation. Pour l'exemple d'approvisionnement électronique, les configurations du concentrateur et du fournisseur sont installées sur le même ordinateur. Ainsi, lors du déploiement de la configuration complète d'un environnement à l'autre, ceci inclut le concentrateur et le fournisseur. Dans un environnement de production, le concentrateur et le fournisseur sont installés sur des ordinateurs différents, et le fournisseur n'est pas inclus dans le déploiement.

Remarque

  • Vous devez installer Application Center avant d'installer BizTalk Server.

Les conditions suivantes sont requises pour effectuer un déploiement à l'aide de Application Center :

  • Si vous souhaitez utiliser Application Center pour déployer une solution d'approvisionnement électronique, vous devez installer Application Center 2000 sur deux ordinateurs. L'un agit comme ordinateur source et l'autre comme ordinateur cible. BizTalk Server 2002 doit être installé et exécuté sur les deux systèmes. L'exemple d'approvisionnement électronique doit également être installé sur l'ordinateur source et fonctionner normalement.

  • Après avoir installé Application Center 2000, vous devez installer SP1 pour Application Center 2000, qui se trouve dans le répertoire Application Center 2000 SP1 du CD-ROM d'installation de BizTalk Server 2002.

  • Si ce n'est déjà fait, vous devez créer les clusters sur les ordinateurs source et cible. Il est important que les ordinateurs source et cible soient installés sur des clusters distincts. Ainsi, l'exemple d'approvisionnement électronique peut simuler un déploiement entre deux environnements, par exemple, d'un environnement de test à un environnement de production.

Lorsque les ordinateurs source et cible sont correctement configurés, utilisez Application Center pour créer une application sur le cluster de l'ordinateur source. Pour plus d'informations, voir Utilisation de Microsoft Application Center 2000.

Les types de ressources suivants sont inclus pour ce cluster :

  • Chemins d'accès au système de fichiers
    • Site d'exemple d'approvisionnement électronique (par exemple, \eProcurementSample)
  • Sites Web et répertoires virtuels
    • Répertoire virtuel du concentrateur

    • Répertoire virtuel du fournisseur
  • BizTalk
    • BizTalkPorts

    • BizTalkReceiveFunctions

Après avoir créé l'application Application Center, vous pouvez la déployer de l'ordinateur source vers l'ordinateur cible. Pour plus d'informations, voir Déploiement d'une application Microsoft Application Center sur un serveur cible.

Étant donné que l'ordinateur cible appartient à un autre cluster, activez l'option Deploy content outside the current cluster sur la page Deployment Target Options de l'Assistant Déploiement. Cet Assistant fournit également une liste déroulante des applications disponibles pour le déploiement. Choisissez de déployer sur l'ordinateur cible l'application que vous venez de créer sur l'ordinateur source.

Une fois le déploiement terminé, vous devez effectuer quelques réglages sur l'ordinateur cible. Par exemple, si les bases de données de corrélation utilisées dans l'exemple d'approvisionnement électronique sont exécutées par SQL Server pendant le déploiement, elles ne peuvent pas être copiées sur l'ordinateur cible par le biais de Application Center.

Pour les copier manuellement sur l'instance SQL Server de l'ordinateur cible, utilisez la fonctionnalité Liaison des bases de données, décrite dans la section Installation préliminaire de l'exemple d'approvisionnement électronique. Vous pouvez également utiliser les services DTS (Data Transformation Services) de SQL Server pour exporter les bases de données vers l'instance SQL Server de l'ordinateur cible.

Par ailleurs, les DLL utilisées par l'exemple d'approvisionnement électronique sont copiées sur l'ordinateur cible par l'intermédiaire de Microsoft Application Center, mais elles ne sont pas enregistrées sur ce dernier. Pour les enregistrer, exécutez le fichier de script RegisterDLLs.vbs situé dans le répertoire \eProcurementSample\Application Center. Si vous déployez cet exemple sur l'ordinateur cible pour la première fois, les files d'attente des messages ne sont probablement pas créées sur ce dernier. Pour créer les files d'attente de messages requises, exécutez le fichier de script CreateQueues.vbs situé dans le répertoire \eProcurementSample\Application Center.

Remarque

  • Il peut s'avérer nécessaire d'activer toutes les fonctions de réception de BizTalk utilisées par l'exemple d'approvisionnement électronique. Les fonctions de réception peuvent être activées dans l'application BizTalk Server Administration. Vous pouvez être amené à effectuer cette opération, car les fonctions de réception sont créées avant les files d'attentes de messages. BizTalk Server désactive automatiquement les fonctions de réception si leurs emplacements d'interrogation correspondants (par exemple, un répertoire ou une file d'attente) ne sont pas disponibles.

Par ailleurs, vous devrez changer les ports BizTalk sur l'ordinateur cible pour que l'adresse du port principal désigne le serveur cible. Lorsque Application Center déploie la configuration de BizTalk Server d'un ordinateur à l'autre, il ne modifie pas les ports BizTalk. Ils pointent toujours sur le serveur source. Les ports suivants doivent être modifiés pour adresser le serveur cible :

  • HubSendPayment

  • HubSendPO

  • SupplierSendInvoice

  • SupplierSendPaymentAck

Remarque

  • Pour que ces modifications prennent effet, il peut être nécessaire de démarrer et d'arrêter le service BizTalk. Vous pouvez effectuer cette opération dans l'outil Administration de BizTalk Server.


Création d'un package SEED

Pour effectuer cette procédure, l'exemple d'approvisionnement électronique doit être installé sur ce serveur et fonctionner correctement.

Cet exemple explique comment un concentrateur crée un package SEED, un fournisseur l'installe et le fournisseur le teste.

Dans ce scénario, le concentrateur crée un package SEED qui inclut des spécifications de documents spécifiques à envoyer au partenaire commercial, similaires à celles de l'organisation du fournisseur dans cet exemple. Le partenaire commercial installe le package SEED. Dans la configuration de cet exemple d'approvisionnement électronique, le concentrateur et le fournisseur sont installés sur le même ordinateur. Les packages SEED sont conçus pour être utilisés dans deux environnements totalement distincts.

Cette section traite des rubriques suivantes :

  • Installation préliminaire du package SEED

  • Création du package SEED


Installation préliminaire du package SEED

Avant de créer le package SEED, vous devez créer un répertoire virtuel IIS (Internet Information Services) pour ce dernier et copier les fichiers .asp appropriés. Ceux-ci seront utilisés pour le site de test du concentrateur.

Création d'un répertoire virtuel IIS pour le package SEED

  1. Créez un répertoire appelé SEEDPackage sur BizTalk Server. Ce répertoire servira de répertoire de test du package SEED.

  2. Créez trois nouveaux répertoires dans le répertoire SEEDPackage, appelés SeedTestSite, SeedDropSite et SeedReceiveSite.

  3. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Gestionnaire des services Internet. Développez la liste actuelle des ordinateurs.

  4. Cliquez avec le bouton droit sur Site Web par défaut, pointez sur Nouveau, puis cliquez sur Répertoire virtuel. L'Assistant Création de répertoire virtuel s'affiche.

  5. Cliquez sur Suivant. Dans l'écran qui apparaît, vous êtes invité à préciser l'alias du répertoire virtuel. Dans le champ Alias, tapez SeedTestSite, puis cliquez sur Suivant.

  6. L'écran suivant vous demande d'indiquer l'emplacement vers lequel le répertoire virtuel va pointer. Utilisez le bouton Parcourir pour localiser le répertoire SeedTestSite que vous avez créé précédemment, ou entrez son chemin complet dans le champ Répertoire. Cliquez sur Suivant.

  7. Dans l'écran suivant, vous pouvez modifier les autorisations d'accès au répertoire virtuel. Conservez les valeurs par défaut et cliquez sur Suivant. Cliquez sur Terminer dans l'écran suivant.

Copie des fichiers requis

Copiez les fichiers .asp suivants à partir du répertoire SEED situé dans \Program Files\Microsoft BizTalk Server\SEED :

  • LocalSubmit.asp

  • SlingBack.asp

  • Trigger.asp

Collez ces fichiers dans le répertoire SeedTestSite que vous avez créé précédemment. Les fichiers SlingBack.asp et Trigger.asp sont utilisés par le concentrateur pour tester à distance les documents entrants et sortants. LocalSubmit.asp est utilisé par le fournisseur pour tester à distance les documents sortants. Pour plus d'informations sur l'utilisation des fichiers .asp, voir Définition des pages ASP dans SEED.

Passez à la section Création du package SEED.


Création du package SEED

Un package SEED est créé par le concentrateur et mis à la disposition des fournisseurs. Lorsque le concentrateur définit un partenariat avec un nouveau fournisseur, ce dernier télécharge le package SEED, l'installe et commence à envoyer des documents sur le site de test du concentrateur. Si cette opération se déroule normalement, le fournisseur peut intégrer cette configuration dans l'environnement de production et entreprendre une transaction d'approvisionnement électronique avec le concentrateur. Les procédures suivantes décrivent la configuration, l'installation et le test d'un package SEED.

Remarque

  • Dans la configuration de cet exemple d'approvisionnement électronique, le concentrateur et le fournisseur sont installés sur le même ordinateur. Les packages SEED sont conçus pour être utilisés dans deux environnements totalement distincts.

Pour implémenter l'utilisation d'un package SEED, effectuez les procédures suivantes :

  • Ajout de la spécification CommonPO

  • Ajout de la spécification CommonInvoice

  • Ajout de la spécification CommonPayment

  • Ajout de la spécification PaymentAcknowledgement

  • Achèvement de la création du package SEED

  • Installation du package SEED

  • Test des spécifications du package SEED


Ajout de la spécification CommonPO

Le package SEED créé par le concentrateur inclut les spécifications de document CommonPO.

  1. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2002 et cliquez sur Assistant BizTalk SEED.

  2. Le menu Assistant BizTalk SEED apparaît. La fonction Créer un package SEED est activée par défaut. Cliquez sur Suivant.

  3. Dans le champ Organisation, tapez Concentrateur et cliquez sur Suivant.

  4. Le menu Processus de création de package – Spécifications de documents s'affiche. Cliquez sur Ajouter.

  5. Cliquez sur Parcourir en regard du champ Spécification. Double-cliquez sur le répertoire eProcurement. Double-cliquez sur la spécification de document ECommonPO.xml. Ceci complète automatiquement le champ Spécification avec l'emplacement du fichier de schéma.

  6. Cliquez sur Parcourir en regard du champ Instance de test. Déplacez-vous jusqu'au répertoire eProcurementSample. Dans le répertoire eProcurementSample, double-cliquez sur le répertoire Instances. Dans le répertoire Instances, double-cliquez sur CommonPO_Instance.xml. L'emplacement du fichier de l'instance apparaît dans le champ Instance de test.

  7. Vérifiez que la case d'option Sortant (de l'initiateur) est activée.

  8. L'entrée qui figure dans le champ URL pour le test à distance doit pointer vers le répertoire virtuel du package SEED créé précédemment, ainsi que vers le fichier Trigger.asp. Cette entrée doit ressembler à ceci : http://<nom_serveur>/SeedTestSite/Trigger.asp. Le fichier Trigger.asp est utilisé pour le test des documents sortants.

  9. Cliquez sur OK.

Passez à la section Ajout de la spécification CommonInvoice.


Ajout de la spécification CommonInvoice

Le package SEED créé par le concentrateur inclut les spécifications de documents CommonInvoice.

  1. Dans le menu Processus de création de package – Spécifications de documents, cliquez sur Ajouter. Cette opération permet d'inclure un autre document dans le package SEED pour le test.

  2. Cliquez sur Parcourir en regard du champ Spécification. Double-cliquez sur le répertoire eProcurement. Double-cliquez sur la spécification de document ECommonInvoice.xml.

  3. Cliquez sur Parcourir en regard du champ Instance de test. Déplacez-vous jusqu'au répertoire eProcurementSample. Dans le répertoire eProcurementSample, double-cliquez sur le répertoire Instances. Dans le répertoire Instances, double-cliquez sur CommonInvoice_Instance.xml.

  4. Vérifiez que la case d'option Entrant (vers l'initiateur) est activée.

  5. L'entrée qui figure dans le champ URL pour le test à distance doit pointer sur le répertoire virtuel du package SEED créé précédemment, ainsi que sur le fichier SlingBack.asp. Cette entrée doit ressembler à ceci : http://<nom_serveur>/SeedTestSite/SlingBack.asp. Le fichier SlingBack.asp est utilisé pour le test des documents entrants.

  6. Le but de cet exercice est de vous montrer comment créer un exemple de package SEED. C'est la raison pour laquelle les entrées ne pointent pas vers un site de production réel. Dans le champ URL de production, vous pouvez copier la valeur qui se trouve dans le champ URL pour le test à distance. Si vous disposiez d'un environnement de production réel, vous saisiriez les informations concernant le site de production dans ce champ.

  7. Cliquez sur OK.

Passez à la section Ajout de la spécification CommonPayment.


Ajout de la spécification CommonPayment

Le package SEED créé par le concentrateur inclut les spécifications de document CommonPayment.

  1. Dans le menu Processus de création de package – Spécifications de documents, cliquez sur Ajouter. Cette opération permet d'inclure un autre document dans le package SEED pour le test.

  2. Cliquez sur Parcourir en regard du champ Spécification. Double-cliquez sur le répertoire eProcurement. Double-cliquez sur la spécification de document ECommonPayment.xml.

  3. Cliquez sur Parcourir en regard du champ Instance de test. Déplacez-vous jusqu'au répertoire eProcurementSample. Dans le répertoire eProcurementSample, double-cliquez sur le répertoire Instances. Dans le répertoire Instances, double-cliquez sur CommonPayment_Instance.xml.

  4. Vérifiez que la case d'option Sortant (de l'initiateur) est activée.

  5. L'entrée qui figure dans le champ URL pour le test à distance doit pointer vers le répertoire virtuel du package SEED créé précédemment, ainsi que vers le fichier Trigger.asp. Cette entrée doit ressembler à ceci : http://<nom_serveur>/SeedTestSite/Trigger.asp. Pour plus d'informations sur ce fichier, voir Définition des pages ASP dans SEED.

  6. Cliquez sur OK.

Passez à la section Ajout de la spécification PaymentAcknowledgement.


Ajout de la spécification PaymentAcknowledgement

Le package SEED créé par le concentrateur inclut les spécifications de document PaymentAcknowledgement.

  1. Dans le menu Processus de création de package – Spécifications de documents, cliquez sur Ajouter. Cette opération permet d'inclure un autre document dans le package SEED pour le test.

  2. Cliquez sur Parcourir en regard du champ Spécification. Double-cliquez sur le répertoire eProcurement. Double-cliquez sur la spécification de document EPaymentAck.xml.

  3. Cliquez sur Parcourir en regard du champ Instance de test. Déplacez-vous jusqu'au répertoire eProcurementSample. Dans le répertoire eProcurementSample, double-cliquez sur le répertoire Instances. Dans le répertoire Instances, double-cliquez sur PaymentAck_Instance.xml.

  4. Vérifiez que la case d'option Entrant (vers l'initiateur) est activée.

  5. L'entrée qui figure dans le champ URL pour le test à distance doit pointer vers le répertoire virtuel du package SEED créé précédemment, ainsi que vers le fichier SlingBack.asp. Cette entrée doit ressembler à ceci : http://<nom_serveur>/SeedTestSite/SlingBack.asp. Le fichier SlingBack.asp est utilisé pour le test des documents entrants. Pour plus d'informations sur ce fichier, voir Définition des pages ASP dans SEED.

  6. Le but de cet exercice est de vous montrer comment créer un exemple de package SEED. C'est la raison pour laquelle les entrées ne pointent pas vers un site de production réel. Dans le champ URL de Production, vous pouvez copier la valeur qui se trouve dans le champ URL pour le test à distance. Si vous disposiez d'un environnement de production réel, vous saisiriez les informations concernant le site de production dans ce champ.

  7. Cliquez sur OK.

Passez à la section Création du package SEED.


Achèvement de la création du package SEED

  1. Dans le menu Processus de création de package – Spécifications de documents, cliquez sur Suivant.

  2. Cliquez sur Parcourir et déplacez-vous jusqu'au répertoire SEEDPackage que vous avez créé précédemment. Nommez le package SEED SamplePackage.xml.

  3. Cliquez sur Terminer. Une zone de message vous informe que le package SEED a été créé normalement. Cliquez sur OK.

Passez à la section Installation du package SEED.


Installation du package SEED

Le concentrateur place le package SEED sur son site Web pour le mettre à la disposition de ses fournisseurs. Un fournisseur télécharge le package SEED, puis il utilise l'Assistant BizTalk SEED pour achever la configuration. L'exemple SEED est conçu pour être créé, installé et déployé sur un seul ordinateur. Dans un scénario réel, le package SEED est créé sur un ordinateur, puis installé sur un autre ordinateur.

Lorsque le package SEED est installé sur le système du fournisseur, il crée les ports, les canaux, les définitions de document et les fonctions de réception nécessaires. Le titre de chaque port, canal, définition de document et fonction de réception commence par le nom du package SEED. Ce schéma d'appellation supprime le risque d'affectation d'un nom en double à un objet du package SEED et de création d'un objet existant. Ce modèle de définition de nom permet de distinguer des autres objets, les objets de package SEED qui peuvent avoir été installés sur les serveurs BizTalk.

Cette procédure suppose que le package SEED est situé dans un référentiel accessible par le serveur.

  1. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2002 et cliquez sur Assistant BizTalk SEED.

  2. Le menu Assistant BizTalk SEED apparaît. Vérifiez que la case d'option Installer un package SEED est activée. Cliquez sur Suivant.

  3. Cliquez sur Parcourir en regard du champ Fichier de package. Déplacez-vous jusqu'au répertoire SEEDPackage. Double-cliquez sur le fichier SamplePackage.xml.

  4. Ceci affiche des informations sur le package SEED (identificateur du package, organisation, etc.). Cliquez sur Suivant. Acceptez les paramètres par défaut du menu Processus d'installation de package - Informations de test et cliquez sur Suivant.

  5. L'écran suivant affiche les documents qui font partie du package SEED. Mettez en surbrillance la spécification EcommonPO.xml, puis cliquez sur Configurer.

  6. Dans le champ URL de Production, tapez http://<nom_serveur>/SeedTestSite/localsubmit.asp. Le fichier localsubmit.asp est utilisé pour tester à distance les documents sortants. Pour plus d'informations sur ce fichier, voir Définition des pages ASP dans SEED.

  7. Cliquez sur Parcourir en regard du champ Emplacement de dépôt final. Accédez au répertoire SeedDropSite dans le répertoire SEEDPackage que vous avez créé précédemment. Assurez-vous que le répertoire SeedDropSite est sélectionné. Cliquez sur OK.

  8. Mettez en surbrillance la spécification ECommonInvoice.xml, puis cliquez sur Configurer.

  9. Cliquez sur Parcourir en regard du champ Emplacement. Accédez au répertoire SeedReceiveSite dans le répertoire SEEDPackage que vous avez créé précédemment. Assurez-vous que le répertoire SeedReceiveSite est affiché en surbrillance. Cliquez sur OK.

  10. Dans le champ Types de fichiers à interroger, entrez CommonInvoice_Instance.xml.

  11. Cliquez sur Parcourir en regard du champ Emplacement de dépôt final. Accédez au répertoire SeedDropSite dans le répertoire SEEDPackage que vous avez créé précédemment. Assurez-vous que le répertoire SeedDropSite est mis en surbrillance. Cliquez sur OK.

  12. Cliquez sur OK.

  13. Mettez en surbrillance la spécification ECommonPayment.xml, puis cliquez sur Configurer.

  14. Dans le champ URL de Production, tapez http://<nom_serveur>/SeedTestSite/localsubmit.asp. Le fichier localsubmit.asp est utilisé pour tester à distance les documents sortants. Pour plus d'informations sur ce fichier, voir Définition des pages ASP dans SEED.

  15. Cliquez sur Parcourir en regard du champ Emplacement de dépôt final. Accédez au répertoire SeedDropSite dans le répertoire SEEDPackage que vous avez créé précédemment. Assurez-vous que le répertoire SeedDropSite est sélectionné. Cliquez sur OK.

  16. Mettez en surbrillance la spécification EPaymentAck.xml, puis cliquez sur Configurer.

  17. Cliquez sur Parcourir en regard du champ Emplacement. Accédez au répertoire SeedReceiveSite dans le répertoire SEEDPackage que vous avez créé précédemment. Assurez-vous que le répertoire SeedReceiveSite est affiché en surbrillance. Cliquez sur OK.

  18. Dans le champ Types de fichiers à interroger, entrez PaymentAck_Instance.xml.

  19. Cliquez sur Parcourir en regard du champ Emplacement de dépôt final. Accédez au répertoire SeedDropSite dans le répertoire SEEDPackage que vous avez créé précédemment. Assurez-vous que le répertoire SeedDropSite est mis en surbrillance. Cliquez sur OK.

  20. Cliquez sur OK.

Passez à la rubrique Test des spécifications du package SEED.


Test des spécifications du package SEED

À ce stade, la configuration de toutes les spécifications de documents doit être terminée (état Configure Complete (Configuration complète)). L'application SEED n'a pas créé de nouveaux objets (fonctions de réception, ports, canaux, etc.). Pour tester le package SEED, le fournisseur doit accomplir les étapes suivantes.

  1. Mettez en surbrillance la spécification ECommonPO.xml. Cliquez sur Créer. Lorsque l'application SEED a créé les objets nécessaires, l'état de la spécification devient Create Passed (Réussite de la création). Ce processus doit être répété pour chaque spécification restante. Après chaque création d'une spécification, le bouton Tester localement est activé.

  2. Mettez en surbrillance la spécification ECommonPO.xml. Cliquez sur Tester localement. Lorsqu'une spécification a réussi le test local, elle passe à l'état Local Test Passed (Réussite du test local) et le bouton Tester à distance est activé. Lorsque l'application SEED exécute un test local, elle crée une instance de la spécification concernée et l'envoie directement au canal correspondant pour la vérifier. Dans cet exemple, le canal SamplePackage_EcommonPO est utilisé. Ceci garantit que le format du document est correct. Si le format de l'instance est correct, l'état de la spécification est mis à jour dans le package SEED. Ce processus doit être répété pour chaque spécification restante. Le processus Tester localement fonctionne d'une manière différente pour les documents entrants. Pour plus d'informations sur le test local d'une application SEED, voir Définition des pages ASP dans SEED.

  3. Mettez en surbrillance la spécification ECommonPO.xml. Cliquez sur Tester à distance. Lorsqu'une spécification entrante a réussi le test à distance, elle passe à l'état Remote Test Passed (Réussite du test à distance) et le bouton Déployer est activé. Ce bouton n'est pas activé pour les spécifications sortantes. Lorsque l'application SEED exécute un test à distance, elle crée une instance de la spécification concernée et l'envoie à l'URL de test à distance qui a été spécifiée lors de la création du package SEED par l'intermédiaire d'un envoi HTTP sur la page trigger.asp située sur le concentrateur. La page trigger.asp renvoie l'instance au fournisseur, où le format du document est vérifié. Si le format de l'instance est correct, l'état de la spécification est mis à jour dans le package SEED. Ce processus doit être répété pour chaque spécification restante. Le processus Tester à distance fonctionne d'une manière différente pour les documents entrants. Pour plus d'informations sur le test à distance d'une application SEED, voir Définition des pages ASP dans SEED.

  4. Mettez en surbrillance la spécification ECommonInvoice.xml. Cliquez sur Déployer. Lorsqu'une spécification a réussi le test de déploiement, elle passe à l'état Deploy Passed (Réussite du déploiement). Répétez ces étapes pour la spécification ePaymentAck.xml.

  5. Après avoir déployé les deux spécifications, cliquez sur Suivant. Cliquez sur Terminer.

Remarque

  • Les ports et les canaux créés par SEED dans cette procédure ne font pas partie de l'exemple d'approvisionnement électronique. Dans l'exemple d'approvisionnement électronique, les ports et les canaux sont déjà configurés. La procédure SEED décrite ici n'est fournie qu'à titre d'exemple.

    Dans un scénario réel, les clients définiraient à ce stade leurs planifications autour de la configuration d'échanges proposée par SEED. Dans le scénario d'approvisionnement électronique, la planification du fournisseur a déjà été développée autour de la configuration d'échanges nécessaire au développement des activités commerciales avec le concentrateur.


Création d'un compte MOM personnalisé pour l'exemple d'approvisionnement électronique

Les administrateurs du système du concentrateur peuvent souhaiter contrôler les transactions avec le fournisseur. Microsoft Operations Manager (MOM) permet aux administrateurs désignés sur les ordinateurs du concentrateur de définir des règles de comptage des documents reçus ou envoyés au fournisseur. Cette partie de l'exemple décrit en détail les étapes qui permettent aux règles MOM de conserver la trace et de suivre les documents CommonInvoice reçus du fournisseur.

Pour exécuter les procédures suivantes et utiliser les fonctionnalités avancées de surveillance, vous devez avoir installé Microsoft Operations Manager (MOM) et BizTalk Server 2002 Management Pack. Pour lire les résultats dans MOM, l'exemple d'approvisionnement électronique doit être configuré et en cours d'exécution.

Pour créer et utiliser un compteur personnalisé dans MOM, exécutez les procédures suivantes :

  • Configuration d'un compteur personnalisé

  • Création d'une règle MOM

  • Distribution d'une règle à un Agent

  • Lecture des résultats dans MOM


Configuration d'un compteur personnalisé

La procédure suivante crée le compteur client WMI (Windows Management Instrumentation) de BizTalk Server pour le document CommonInvoice. Le compteur personnalisé ainsi créé lit la base de données de suivi et renvoie le nombre de documents CommonInvoice traités pendant les 300 dernières secondes.

Remarque

  • Le script doit être exécuté sur l'ordinateur qui exécute BizTalk Server et l'Agent MOM.

Pour configurer un compteur personnalisé :

  1. Accédez au répertoire \eProcurementSample\Operations Manager.

  2. Double-cliquez sur CustomCounter_eProcurement_CommonInvoice.vbs.

  3. Un message de vérification de la validité apparaît. Cliquez sur OK.

Passez à la section Création d'une règle MOM.


Création d'une règle MOM

Pour effectuer les étapes décrites dans les procédures suivantes, vous devez avoir installé BizTalk Server 2002 Management Pack et être familiarisé avec les opérations MOM.

Pour créer une règle MOM, vous devez démarrer MOM Administrator Console. Toutes les opérations s'effectuent sur cette console.

Définition du groupe des règles de collection d'événements

Le dossier du groupe des règles de traitement Microsoft BizTalk Server n'est pas initialement associé à un groupe d'ordinateurs. Si cette affectation n'est pas définie, aucune règle placée dans ce dossier n'est étendue à un Agent MOM.

  1. Dans MOM Administrator Console, développez le noeud Rules, puis Processing Rule Groups.

  2. Cliquez avec le bouton droit sur le dossier Microsoft BizTalk Server, puis cliquez sur Properties.

    La boîte de dialogue Processing Rule Group Properties de ce dossier s'ouvre.

  3. Cliquez sur l'onglet Computer Groups.

    La liste des groupes d'ordinateurs connectés à ce dossier apparaît à l'écran.

  4. Si elle est vide, cliquez sur Add.

    La boîte de dialogue Select Item apparaît. Elle contient la liste de tous les groupes d'ordinateurs MOM.

  5. Sélectionnez Microsoft BizTalk Server 2002 Édition Entreprise.

  6. Cliquez sur OK pour fermer la boîte de dialogue.

  7. Cliquez sur OK pour fermer la boîte de dialogue Properties.

Création de la règle de traitement des alertes MOM

  1. Dans MOM Administrator Console, développez les nœuds Rules, Processing_Rule_Groups et Microsoft BizTalk Server.

  2. Cliquez avec le bouton droit sur Performance Processing Rules, pointez sur New, puis cliquez sur Performance Processing Rule.

    La boîte de dialogue Performance Processing Rule Type s'affiche.

  3. Mettez en surbrillance Compare Performance Data (Threshold).

  4. Cliquez sur Next.

    La boîte de dialogue Threshold Processing Rule Properties – Data Provider s'affiche.

  5. Cliquez sur New pour créer un nouveau fournisseur de données.

    La boîte de dialogue Select Provider Type apparaît.

  6. Mettez en surbrillance WMI Numeric Event et cliquez sur OK.

    La boîte de dialogue WMI Numeric Provider Properties s'affiche.

  7. Complétez les champs suivants :
    • Provider name : Compteur personnalisé pour les documents CommonInvoice

    • WMI Namespace : root\MicrosoftBiztalkServer

    • Class of Object to be measured : MSBTS_CustomCounter

    • Object Instance Expression : Nom = "compteur personnalisé pour les documents CommonInvoice"

    • Numeric property to sample : MatchCount

    • Text Property to be Instances : Nom

    • Sample Every : 10 secondes

Remarque

  • L'application d'un intervalle d'échantillonnage inférieur peut influer sur les performances de l'ordinateur qui agit comme consolidateur MOM et sur les ordinateurs exécutant les Agents MOM.
  8. Cliquez sur Next.

  9. Laissez la case à cocher Synchronize at non activée et cliquez sur Finish pour fermer la boîte de dialogue.

  10. Cliquez sur Suivant dans la boîte de dialogue Threshold Processing Rule Properties.

  11. Acceptez la valeur par défaut always process data sur la page specify optional schedule, puis cliquez sur Next.

  12. Acceptez la valeur par défaut (aucune case activée) sur la page select the properties you would like to match et cliquez sur Next.

  13. Acceptez la valeur par défaut affichée sur la page Specify the threshold value you would like to match.

    Ce paramètre indique au système MOM de générer une alerte lorsque le compteur affiche une valeur supérieure à 0.

  14. Cliquez sur Next.

  15. Sur la page Specify whether a match to this rule generates an alert, sélectionnez Generate Alert. Dans la liste Alert Severity, cliquez sur Success et tapez Exemple d'approvisionnement électronique dans la zone de texte Owner. Acceptez les valeurs affichées par défaut dans tous les autres champs.

  16. Cliquez sur Next.

  17. Sur la page Define the handling of duplicate alerts, désactivez la case à cocher suppress duplicate alerts si vous souhaitez générer une alerte chaque fois que la condition est vraie. Dans le cas contraire, une seule alerte est générée.

  18. Cliquez sur Next.

  19. Cliquez sur Next sur la page Define any response action.

  20. Cliquez sur Next sur la page Company Knowledge Base.

  21. Sur la page Specify the Comments for the Knowledge Base Entry, acceptez les valeurs par défaut et cliquez sur Next. Notez que cette page est disponible uniquement si la licence MOM Knowledge Authorizing est installée.

  22. Sur la page Specify the advanced setting properties, acceptez les valeurs par défaut et cliquez sur Next. Notez que cette page est disponible uniquement si la licence MOM Knowledge Authorizing est installée.

  23. Sur la page Enter a name for the processing rule, tapez eProcurement-CustomCounter for CommonInvoice et cliquez sur Finish.

Passez à la section Distribution d'une règle à un Agent.


Distribution d'une règle à un Agent

À ce stade, les règles sont mises à jour mais ne sont pas publiées sur les Agents MOM en vue de leur traitement. Pour distribuer une ou plusieurs règle(s) à un Agent, cliquez avec le bouton droit sur Rules dans la console MOM, puis cliquez sur Commit Configuration Changes. Le transfert des règles aux Agents par le système MOM peut prendre quelques minutes.

Passez à la section Lecture des résultats dans MOM.


Lecture des résultats dans MOM

Chaque fois que vous exécutez le script de l'exemple d'approvisionnement électronique, un document CommonInvoice est généré dans la planification du concentrateur. Par exemple, si vous exécutez DocumentGenerator.vbs trois fois de suite rapidement, les Agents MOM vont échantillonner la valeur CustomCounter et déclencher une alerte.

Pour afficher l'alerte, développez le dossier Monitor dans la console MOM, puis sélectionnez all open alerts. Ce dossier doit contenir au moins une alerte avec une coche verte et le niveau de gravité doit indiquer Success. La colonne Owner (Propriétaire) doit mentionner exemple d'approvisionnement électronique.


Administration de BizTalk Server 2002

L'administration de Microsoft® BizTalk™ Server 2002 est divisée de la manière suivante :

Installation de BizTalk Server 2002

Cette section fournit des informations sur l'installation de BizTalk Server 2002. Elle contient des directives sur la configuration matérielle et logicielle requise, ainsi que des instructions sur l’installation complète, l'installation d'outils et l'installation personnalisée. Pour plus d'informations, voir Installation de BizTalk Server 2002.

Présentation de la sécurité

Cette section explique comment les entreprises peuvent échanger des données en toute sécurité avec des partenaires commerciaux lorsqu'elles utilisent BizTalk Server 2002. BizTalk Server tire parti des fonctions de sécurité incluses dans Microsoft Windows® 2000. Pour plus d'informations, voir Présentation de la sécurité.

Amélioration des performances et de l'évolutivité

Cette section fournit des informations sur l'amélioration des performances de BizTalk Server et la création de solutions évolutives. Vous y trouverez des informations sur l'identification des goulots d'étranglement potentiels, la latence d'adressage et la gestion de bases de données. Pour plus d'informations sur la création d'une solution évolutive à hautes performances, voir Amélioration des performances et de l'évolutivité.

Administration des serveurs et des applications

Cette section présente le mode d’administration des serveurs et des applications associées à XLANG. Les rubriques qu’elle contient indiquent notamment comment centraliser la configuration et la gestion de serveurs en plusieurs groupes, configurer et gérer les fonctions de réception, configurer les files d'attente partagées et gérer les applications COM+ qui hébergent des planifications XLANG. Pour plus d'informations, voir Administration des serveurs et des applications.

Suivi de documents

Cette section fournit des informations sur le suivi d'échanges et de documents traités par BizTalk Server 2002. Les rubriques qu’elle contient indiquent notamment comment créer des requêtes simples et des requêtes avancées, comment enregistrer un échange, un document et des données de recherche personnalisée, et décrivent l'enregistrement d'échange, l'enregistrement de documents et les résultats de réception. Pour plus d'informations, voir Suivi des documents.

Contrôle des documents

Cette section fournit des informations sur BizTalk Server 2002 Enterprise Edition Management Pack for Microsoft Operations Manager (MOM). Ces informations concernent les compteurs de performances, les règles d'événements de Microsoft Windows NT®, les règles configurées par l'utilisateur et les affichages disponibles dans ce module de gestion et destinés à améliorer les performances du gestionnaire MOM en surveillant les événements spécifiques à BizTalk Server. Pour plus d'informations, voir Contrôle des documents.

Remarque

  • Le chemin d'accès aux fichiers permettant d'ouvrir divers services et outils Microsoft Windows 2000, tels que les services de composants et les outils d'administration, est différent selon que vous utilisez un ordinateur exécutant Windows 2000 Server ou Windows 2000 Professionnel. Pour plus d'informations, voir Ouverture des services de composants.

    Dans l'aide de Microsoft BizTalk Server 2002, les chemins d'accès à ces services et outils correspondent à une installation de Windows 2000 Server. Si vous utilisez Windows 2000 Professionnel, reportez-vous à l'aide correspondante pour plus d'informations sur l'ouverture du service ou de l'outil qui vous intéresse.

Voir aussi

Modèle d'administration de BizTalk Server


Installation de BizTalk Server 2002

Bienvenue dans le Guide d'installation de Microsoft® BizTalk™ Server 2002. Ce manuel offre des indications sur la configuration matérielle et logicielle requise, ainsi que des instructions complètes sur les options d'installation suivantes :

  • Installation complète : permet d'effectuer une installation complète de BizTalk Server 2002, qui inclut tous les exemples, outils et services de BizTalk.

  • Installation des outils : permet d'effectuer une installation complète des outils de BizTalk Server 2002, à savoir le Concepteur d'Orchestration BizTalk, l'Éditeur BizTalk, le Mappeur BizTalk, le composant logiciel enfichable Administration de BizTalk Server de la console MMC et l'aide de BizTalk Server 2002. Le parseur, le sérialiseur, la corrélation et les binaires d'exécution de BizTalk Server 2002 ne sont pas installés.

  • Installation personnalisée : permet d'effectuer une installation personnalisée incluant toute combinaison d'outils et de services de BizTalk Server 2002.

  • Mise à niveau : permet d'effectuer une mise à niveau des outils et services de BizTalk Server 2002 à partir des outils et services de BizTalk Server 2000.

  • Installation en mode silencieux : permet d'installer BizTalk Server 2002 en mode silencieux grâce à l'indication des valeurs de propriétés sur la ligne de commande.

  • Suppression de BizTalk Server 2002 : permet de supprimer l'installation de BizTalk Server 2002.

Les rubriques suivantes sont traitées dans ce guide :

  • Liste de vérification des tâches d'installation

  • Configuration matérielle et logicielle

  • Instructions d'installation


Liste de vérification des tâches d'installation

Cette liste de vérification décrit les étapes nécessaires pour effectuer une installation complète de Microsoft® BizTalk™ Server 2002 et de tous ses composants. Les instructions dont vous avez besoin pour les différentes étapes vous sont proposées. Pour vous faciliter la tâche, vous pouvez imprimer cette liste de vérification afin de vous y reporter pendant l'installation.

Étape | Référence
Vérification de la configuration requise. | Configuration matérielle requise
Vérification de la configuration logicielle. | Configuration logicielle requise
Affichage du fichier Lisezmoi pour connaître les informations les plus récentes. | Le fichier Lisezmoi est situé dans le répertoire racine du CD-ROM d'installation de BizTalk Server.
Installation du système d'exploitation Microsoft Windows® 2000. | Conditions préalables et configuration requise pour l'installation de Windows 2000
Installation de Message Queuing. | Installation de Message Queuing
Installation des services Internet (IIS). | Installation des services Internet (IIS)
Configuration des services Internet (IIS). | Configuration des paramètres IIS de BizTalk Server 2002
Installation du Service Pack de Windows 2000. | Installation de Windows 2000 Service Pack 2
Ajoutez votre compte d'utilisateur au groupe d'administrateurs Windows 2000 et créez un compte de services BizTalk Server. | Création d'un compte de services
Installation de Microsoft SQL Server™. | Conditions préalables et configuration requise pour SQL Server
Installation de SQL Server Service Pack. | Installation du Service Pack pour SQL Server
Vérification du fonctionnement de SQL Server. | Vérification du fonctionnement de SQL Server
Ajout d'un compte de connexion SQL Server (pour les installations SQL Server distantes). | Interactions entre les bases de données SQL Server et BizTalk Server 2002
Installation de Microsoft Visio® 2002. | Installation de Visio 2002
Installation de Microsoft Application Center 2000 SP1. | Installation de Microsoft Application Center 2000
Installation de BizTalk Server 2002. | Instructions d'installation
Établissement d'autorisations d'accès aux bases de données distantes si SQL Server est installé sur un ordinateur distant. | Interactions entre les bases de données SQL Server et BizTalk Server 2002
Configuration des applications COM+ en vue d'une exécution autre qu'en tant qu'utilisateur interactif. | Modification de l'identité d'une application COM+
Démarrage du service de publication Web. | Démarrage du service de publication Web
Configuration de Microsoft Internet Explorer pour le Suivi de documents BizTalk. | Configuration du Suivi de documents BizTalk


Configuration matérielle et logicielle

Cette section contient des informations sur la configuration matérielle minimale et les options de configuration requises pour installer Microsoft BizTalk Server 2002. Elle contient également des instructions d'installation des logiciels préalables requis pour BizTalk Server 2002.

Cette section traite des rubriques suivantes :

  • Configuration matérielle requise

  • Configuration recommandée pour optimiser les performances de Document Messaging

  • Configuration logicielle requise

  • Conditions préalables et configuration requise pour l'installation de Windows 2000

  • Conditions préalables et configuration requise pour l'installation de SQL Server

  • Installation de Visio 2002

  • Installation de Microsoft Application Center 2000


Configuration matérielle requise

La configuration matérielle minimale pour une installation complète de Microsoft BizTalk Server 2002 est la suivante :

  • Processeur compatible Intel® Pentium® d'une fréquence de 400 MHz ou supérieure

  • 256 Mo de mémoire RAM

  • Disque dur de 6 Go

  • Lecteur de CD-ROM

  • Carte réseau

  • Écran VGA ou Super VGA

  • Souris Microsoft ou dispositif de pointage compatible

Remarque

  • Lors de l'installation de BizTalk Server 2002, le programme d'installation détermine l'espace disponible sur le disque dur de votre ordinateur. Une installation complète requiert environ 52 Mo d'espace disque, sans compter l'espace requis pour les bases de données Gestion d'échanges BizTalk, de suivi, de files d'attente partagées et Persistance d'orchestration. L'installation des outils requiert environ 30 Mo d'espace libre sur le disque dur. Une installation personnalisée requiert de 2 à 52 Mo d'espace libre, sans compter l'espace requis pour les bases de données des services et des outils que vous installez.


Configuration recommandée pour optimiser les performances de Document Messaging

Vous trouverez ci-après des conseils qui vous permettront d'optimiser les performances de Microsoft BizTalk Server 2002 :

  • Créez une configuration constituée de trois ordinateurs. Dans cette configuration, installez BizTalk Server 2002 sur le premier ordinateur, la base de données de suivi sur le deuxième ordinateur et les bases de données Gestion d'échanges et de files d'attente partagées sur le troisième ordinateur.

  • Au lieu d'utiliser un seul serveur pour exécuter toutes les fonctions de traitement et de réception, vous pouvez configurer deux serveurs BizTalk Server 2002, l'un dédié au traitement et l'autre à la réception, afin d'optimiser les performances.

  • Installez la base de données de suivi sur un ordinateur disposant de plusieurs disques durs. La configuration optimale inclut quatre disques durs SCSI II et un contrôleur SCSI II. Le premier disque dur est dédié à l'enregistrement du suivi des documents ; le deuxième est dédié au fichier de page système Microsoft Windows® 2000 ; le troisième est dédié au journal des transactions de suivi et le quatrième au journal DTC (Distributed Transaction Coordinator).

  • Créez plusieurs instances des fonctions de réception pour contrôler plusieurs emplacements de réception des documents à traiter. Pour équilibrer la charge des documents sur plusieurs ordinateurs, placez les fonctions de réception sur des ordinateurs distincts. Chaque emplacement de contrôle doit être unique et comporter une fonction de réception distincte. Pour éviter de surcharger chaque fonction de réception, l'application professionnelle qui envoie les documents doit les répartir équitablement entre tous les emplacements de contrôle.

Important

  • N'installez pas l'outil Gestionnaire d'échanges BizTalk, Internet Information Services (IIS) et la base de données de configuration BizTalk Server sur trois ordinateurs différents. Ce type de configuration entraîne des problèmes d'authentification. Pour plus d'informations, voir Problème d'authentification lorsque IIS, le Gestionnaire d'échanges BizTalk et SQL Server sont installés sur trois ordinateurs différents.

  • Pour plus d'informations sur l'optimisation des performances de BizTalk Server, voir Amélioration des performances et de l'évolutivité.


Configuration logicielle requise

Le tableau suivant présente les logiciels à installer pour exécuter Microsoft BizTalk Server 2002.

Installation complète | Installation des outils | Installation personnalisée
Microsoft Windows 2000 avec Service Pack 2 (SP2)* et le système de fichiers NTFS | Microsoft Windows 2000 avec Service Pack 2 (SP2)* et le système de fichiers NTFS, ou Windows XP Professionnel ou version ultérieure | Microsoft Windows 2000 avec Service Pack 2 (SP2)* et le système de fichiers NTFS
Microsoft Internet Explorer 5.5 ou une version ultérieure | Microsoft Internet Explorer 5.5 ou une version ultérieure | Microsoft Internet Explorer 5.5 ou une version ultérieure
Microsoft Visio® 2002 (nécessaire pour utiliser le Concepteur d'Orchestration BizTalk) | Microsoft Visio 2002 (nécessaire pour utiliser le Concepteur d'Orchestration BizTalk) | Microsoft Visio 2002 (nécessaire pour utiliser le Concepteur d'Orchestration BizTalk)
Microsoft SQL Server 7.0 avec Service Pack 3 (SP3) ou SQL Server 2000 SP1 | Microsoft SQL Server 7.0 avec Service Pack 3 (SP3) ou SQL Server 2000 SP1
Remarque
  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication Web est actif.
 Remarque
  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication Web est actif.
 Remarque
  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication Web est actif.

*La console du système Windows 2000 doit être utilisée pour installer BizTalk Server 2002. L'utilisation des services Terminal Server pour installer BizTalk Server n'est pas prise en charge.

Remarques

  • Microsoft SQL Server est requis pour une installation personnalisée si vous installez les services principaux de BizTalk. Il n'est pas requis pour l'installation des outils.

  • Microsoft Application Center 2000 avec SP1 est requis uniquement si vous voulez bénéficier des fonctionnalités de déploiement de BizTalk Server 2002. Pour plus d'informations, voir Installation de Microsoft Application Center 2000.

  • Microsoft Operations Manager (MOM) 2000 est requis uniquement si vous envisagez d'installer BizTalk Server 2002 Management Pack pour utiliser les fonctionnalités avancées de surveillance. Pour plus d'informations sur BizTalk Server 2002 Management Pack, voir Import the BizTalk Server 2002 Management Pack.


Conditions préalables et configuration requise pour l'installation de Windows 2000

Microsoft Windows 2000 avec Service Pack 2 (SP2) est requis pour toutes les installations de Microsoft BizTalk Server 2002. Étant donné que BizTalk Server 2002 a fait l'objet de tests approfondis sous Windows 2000 SP2, ce Guide d'installation contient des informations sur la configuration requise de Windows 2000 Server, Windows 2000 Advanced Server et Windows 2000 Professionnel en association avec BizTalk Server. Vous devez également installer Message Queuing et les services Internet (IIS) en complément de Windows 2000. Pour plus d'informations, voir Installation de Message Queuing et Installation des services Internet (IIS). Si votre installation de Windows 2000 n'inclut pas le Service Pack 2, vous devez l'installer. Pour plus d'informations, voir Installation de Windows 2000 Service Pack 2.

Après avoir installé Windows 2000, vous devez ajouter un compte d'utilisateur Windows 2000 au groupe d'administrateurs avant d'installer tout logiciel.

Cette section traite des rubriques suivantes :

  • Installation de Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel

  • Installation de Message Queuing

  • Installation des services Internet (IIS)

  • Configuration des paramètres IIS de BizTalk Server 2002

  • Installation de Windows 2000 Service Pack 2

  • Création d'un compte de services


Installation de Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel

Si vous avez déjà installé Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel sur votre ordinateur, assurez-vous que les consignes présentées dans cette section sont respectées.

Si vous n'avez pas installé Windows 2000, insérez le CD-ROM de Windows 2000 dans votre lecteur et suivez les instructions qui s'affichent à l'écran. L'Assistant Installation vous guide lors des différentes étapes d'installation de Windows 2000.

Respectez les conditions suivantes :

  • Utilisez uniquement des caractères alphanumériques dans les noms d'ordinateurs car Microsoft SQL Server reconnaît un jeu de caractères limité dans ces noms.

  • Formatez la partition à l'aide du système de fichiers NTFS.

  • Sur la page Composants Windows 2000, dans la liste Composants, cliquez sur Services Message Queuing. Si vous installez Windows 2000 Professionnel, cliquez sur Services Internet (IIS) et sur Suivant. Sur la page Type de Message Queuing, cliquez sur Suivant.

  • Sur la page Paramètres de réseau, cliquez sur Paramètres par défaut.

Remarques

  • Si vous n'avez pas sélectionné Services Message Queuing sur la page Composants Windows 2000 lors de l'installation, vous devez procéder à son installation avant d'installer Windows 2000 Service Pack. Pour plus d'informations, voir Installation de Message Queuing.

  • Si vous n'avez pas sélectionné Services Internet (IIS) sur la page Composants Windows 2000 lors de l'installation de Windows 2000 Professionnel, vous devez procéder à son installation avant d'installer le Service Pack de Windows 2000. Pour plus d'informations, voir Installation des Services Internet (IIS).

  • Si votre installation n'inclut pas le Service Pack 2, vous devez l'installer. Pour plus d'informations, voir Installation de Windows 2000 Service Pack 2.

  • La partition Windows 2000 Server doit être convertie pour correspondre à la dernière version du système de fichiers NTFS. Le programme d'installation effectue automatiquement cette mise à jour si le système de fichiers existant est l'ancienne version de NTFS. Si la partition existante est de type FAT ou FAT32, vous avez la possibilité de passer à NTFS. Lorsque vous êtes invité à le faire, choisissez NTFS.

  • Après avoir installé Windows 2000 Server, Windows 2000 Advanced Server ou Windows 2000 Professionnel, vous devez ajouter un compte d'utilisateur Windows 2000 au groupe d'administrateurs avant d'installer tout logiciel.


Installation de Message Queuing

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

    La boîte de dialogue Ajout/Suppression de programmes apparaît.

  3. Cliquez sur Ajouter/Supprimer des composants Windows.

    L'Assistant Composants de Windows s'ouvre.

  4. Dans la liste Composants, activez la case à cocher Services Message Queuing et cliquez sur Suivant.

  5. Sur la page Type de Message Queuing, cliquez sur Suivant.

  6. Cliquez sur Terminer pour fermer l'Assistant.

Remarque

  • Acceptez les paramètres par défaut lors de l'installation du composant Services Message Queuing.


Installation des services Internet (IIS)

Remarques

  • Si vous n'avez pas sélectionné Services Internet (IIS) sur la page Composants Windows 2000 lors de l'installation de Windows 2000 Professionnel, vous devez procéder à son installation avant d'installer le Service Pack de Windows 2000. Windows 2000 Professionnel n'installe pas par défaut les Services Internet. Ce composant est installé uniquement si vous effectuez une mise à niveau vers Windows 2000 à partir d'une version antérieure de Windows et de Serveur Web personnel (PWS).

  • En revanche, Microsoft Windows 2000 Server installe par défaut le composant IIS.
  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

    La boîte de dialogue Ajout/Suppression de programmes apparaît.

  3. Cliquez sur Ajouter/Supprimer des composants Windows.

    L'Assistant Composants de Windows s'ouvre.

  4. Dans la liste Composants, activez la case à cocher Services Internet (IIS) et cliquez sur Suivant.

  5. Cliquez sur Terminer pour fermer l'Assistant.


Configuration des paramètres IIS de BizTalk Server 2002

Pour éviter les problèmes d'accès et d'enregistrement des spécifications dans le référentiel BizTalk Server 2002, vous devez désactiver l'option Activer les opérations d'auteur des services Internet (IIS).

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composant.

  2. Cliquez sur l'icône de l'identificateur de développement (+) du serveur IIS local.

  3. Cliquez avec le bouton droit sur Site Web par défaut et cliquez sur Propriétés.

    La boîte de dialogue Propriétés de Site Web par défaut apparaît.

  4. Cliquez sur l'onglet Extensions serveur et désactivez la case à cocher Activer les opérations d'auteur.


Installation de Windows NT 2000 Service Pack 2

  • Insérez le CD-ROM de Windows 2000 SP2 dans le lecteur et suivez les instructions qui s'affichent à l'écran.

    Vous pouvez également accéder à la zone de téléchargement du site Web de Microsoft Windows 2000 (www.microsoft.com/france/windows/2000/) pour télécharger Windows 2000 SP2 ou commander le CD-ROM.


Création d'un compte de services

Pour installer le logiciel, vous devez vous assurer que le compte qui effectue l'installation est le groupe Administrateurs Windows 2000 local du serveur sur lequel le logiciel est installé. Ceci inclut tout ordinateur SQL Server distant. En outre, vous pouvez créer un compte de services que le service d'échanges BizTalk utilise pour la connexion. Si vous ne souhaitez pas créer de compte de services, vous avez la possibilité lors de l'installation, de configurer le service d'échanges BizTalk pour une exécution sous le système local.

Remarque

  • Si vous prévoyez d'installer BizTalk Server et SQL Server sur deux ordinateurs différents, le compte de services de BizTalk Server doit disposer d'autorisations d'accès à l'ordinateur qui exécute SQL Server. Pour plus d'informations, voir Interactions entre les bases de données SQL Server et BizTalk Server 2002.
  1. Connectez-vous en tant qu'administrateur.

  2. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Gestion de l'ordinateur.

    La boîte de dialogue Gestion de l'ordinateur s'affiche.

  3. Dans l'arborescence de la console, développez Outils système, puis cliquez sur Utilisateurs et groupes locaux.

  4. Cliquez sur Utilisateurs, cliquez avec le bouton droit sur le volet des détails, puis cliquez sur Nouvel utilisateur.

    La boîte de dialogue Nouvel utilisateur apparaît.

  5. Dans le champ Nom d'utilisateur, tapez le nom du compte de services ; dans le champ Mot de passe, tapez un mot de passe puis tapez-le de nouveau dans le champ Confirmer le mot de passe.

  6. Désactivez la case à cocher L'utilisateur doit changer de mot de passe à la prochaine ouverture de session, cliquez sur Créer, puis sur Fermer.

  7. Fermez la fenêtre Gestion de l'ordinateur.

  8. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Stratégie de sécurité locale.

    La boîte de dialogue Paramètres de sécurité locale apparaît.

  9. Dans l'arborescence de la console, développez Stratégies locales, puis cliquez sur Attribution des droits utilisateur.

  10. Dans le volet des détails, double-cliquez sur Agir en tant que partie du système d'exploitation, cliquez sur Ajouter, cliquez sur le nom du compte de services que vous venez de créer dans la liste, cliquez sur Ajouter, puis sur OK à deux reprises.

  11. Répétez l'étape 10 pour la stratégie Connexion en tant que service.

    Important

    • Vous devez redémarrer votre ordinateur pour que ces autorisations prennent effet.

Si BizTalk Server 2002 est déjà installé et utilise le compte faisant partie du groupe Administrateurs, effectuez les opérations suivantes après avoir créé un compte de services.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services.

  2. Dans le volet des détails, double-cliquez sur Services d'échanges BizTalk.

    La boîte de dialogue Propriétés de Service d'échanges BizTalk (Ordinateur local) s'affiche.

  3. Cliquez sur l'onglet Connexion, puis sur Ce compte.

  4. Cliquez sur Parcourir, recherchez le compte de services que vous avez créé, puis double-cliquez sur son nom.

  5. Dans le champ Mot de passe, tapez le mot de passe que vous aviez associé au nom du compte de services ; dans le champ Confirmer le mot de passe, tapez de nouveau le mot de passe, puis cliquez sur OK.

  6. Un message apparaît ; cliquez sur OK.

  7. Redémarrez l'ordinateur.


Conditions préalables et configuration requise pour l'installation de SQL Server

Avant de procéder à l'installation de Microsoft BizTalk Server 2002, vous devez installer Microsoft SQL Server 7.0 avec le Service Pack 3 (SP3), ou bien Microsoft SQL Server 2000 avec le Service Pack 1 (SP1). Lors de l'installation de BizTalk Server 2002, quatre bases de données BizTalk Server 2002 sont créées dans SQL Server : base de données de persistance d'orchestration, de gestion d'échanges BizTalk, de files d'attente partagées et de suivi.

Important

  • Si vous envisagez d'installer BizTalk Server 2002 sur un ordinateur exécutant Microsoft Windows 2000 Professionnel, vous devez installer l'Édition Standard ou Entreprise de Microsoft SQL Server sur un autre ordinateur. Lorsque vous installerez les bases de données de BizTalk Server 2002, vous devrez indiquer le nom de l'ordinateur sur lequel SQL Server est installé. Vous ne pouvez pas installer l'Édition Standard ou l'Édition Entreprise de Microsoft SQL Server sous Windows 2000 Professionnel.

  • Si vous envisagez d'installer BizTalk Server et SQL Server sur deux ordinateurs différents, votre compte de connexion et le compte de services de BizTalk Server doivent disposer d'autorisations d'administrateur sur les deux ordinateurs. Pour plus d'informations, voir Interactions entre les bases de données SQL Server et BizTalk Server 2002.

Par défaut, lorsque vous installez SQL Server 2000, le mode d'authentification est défini pour Windows 2000 uniquement. BizTalk Server 2002 utilise l'authentification Windows pour accéder aux bases de données Gestion d'échanges BizTalk, de files d'attente partagées et de suivi, ainsi qu'à l'application de suivi de documents BizTalk sur le Web. Vérifiez que le mode d'authentification SQL Server est paramétré sur Windows avant d'installer BizTalk Server 2002. Pour plus d'informations, voir Définition du mode d'authentification SQL pour SQL Server 2000.

Un cluster est un ensemble de serveurs qui font office de serveur unique. Si vous installez SQL Server sur un cluster et prévoyez d'installer BizTalk Server 2002 sur un autre ordinateur, vous devez installer les outils clients de SQL Server sur l'ordinateur doté de BizTalk Server 2002. Pour plus d'informations, voir Installation des outils clients SQL Server. Une fois les outils installés, vous devez utiliser l'Utilitaire réseau client pour attribuer TCP/IP à la bibliothèque réseau par défaut des canaux nommés. Pour plus d'informations, voir Attribution de TCP/IP à la bibliothèque de réseau par défaut

Question d'ordre international

  • Lorsque vous installez SQL Server, il est important d'utiliser les paramètres de classement appropriés. Le terme classement fait référence à un ensemble de règles qui déterminent le mode de tri et de comparaison des données. Les données de type caractère sont triées d'après des règles qui définissent la séquence de caractères appropriée à l'aide d'options portant sur le respect de la casse, les accents, les caractères de type Kana ou la largeur des caractères. Par exemple, pour enregistrer des caractères japonais, sélectionnez l'ordre de tri faisant la distinction entre les majuscules et les minuscules pour différencier le japonais-Hiragana du japonais-Katakana lors de l'installation de SQL Server. Pour plus d'informations sur les paramètres de classement, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne. Les rubriques « Utilisation du classement SQL » et « Styles de tri des classements Windows » contiennent des informations supplémentaires.

Si SQL Server est configuré pour utiliser l'ordre de tri binaire, la casse est respectée.

Cette section traite des rubriques suivantes :

  • Installation de SQL Server 7.0 ou 2000

  • Recherche de la version du Service Pack de SQL Server

  • Installation du Service Pack de SQL Server

  • Installation des outils client SQL Server

  • Attribution de TCP/IP à la bibliothèque de réseau par défaut

  • Définition du mode d'authentification SQL pour SQL Server 2000

  • Vérification du fonctionnement de SQL Server

  • Interactions entre les bases de données SQL Server et BizTalk Server 2002


Installation de SQL Server 7.0 ou 2000

Pour installer SQL Server, insérez le CD-ROM de Microsoft SQL Server dans le lecteur de CD-ROM et suivez les instructions qui s'affichent à l'écran. L'Assistant Installation vous guide lors des étapes d'installation de SQL Server.

Respectez les conditions suivantes :

  • Sur la page Type d'installation, cliquez sur Par défaut.

  • Sur la page Comptes de services, utilisez un nom d'utilisateur de domaine (en cas de connexion à un réseau).

  • Lors de l'installation de SQL Server 2000, spécifiez le mode d'authentification Windows.

Important

  • Une fois SQL Server installé, vous devez procéder à l'installation du Service Pack de SQL Server le plus récent. Vous pouvez utiliser l'Analyseur de requêtes pour vérifier si le Service Pack le plus récent est installé. Pour plus d'informations, voir Recherche de la version du Service Pack de SQL Server. Pour plus d'informations sur l'installation des Service Packs de SQL Server, voir Installation du Service Pack de SQL Server.


Recherche de la version du Service Pack de SQL Server

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft SQL Server, puis cliquez sur Analyseur de requêtes.

    La boîte de dialogue Connexion à SQL Server s'affiche.

  2. Cliquez sur OK.

    Si le nom de votre serveur n'apparaît pas dans la liste SQL Server, tapez-le et cliquez sur OK.

  3. Dans la zone de texte Requête, tapez SELECT @@VERSION.

  4. Dans le menu Requête, cliquez sur Exécuter.

    La première ligne du résultat de la requête contient la version de SQL Server en cours d'exécution.


Installation du Service Pack de SQL Server

  1. Insérez le CD-ROM du Service Pack SQL Server dans le lecteur de CD-ROM.

  2. Exécutez le programme d'installation du Service Pack de SQL Server et suivez les instructions qui s'affichent à l'écran.

    Vous pouvez également accéder à la zone de téléchargement du site Web de Microsoft SQL Server (www.microsoft.com/france/sql/) pour télécharger les Service Packs de SQL Server ou pour commander le CD-ROM.


Installation des outils clients SQL Server

Important

  • Lorsque vous êtes dans un environnement de clusters, si SQL Server et BizTalk Server ne sont pas installés sur le même ordinateur, les outils clients SQL Server doivent être installés sur l'ordinateur sur lequel réside BizTalk Server 2002.

Pour installer les outils clients SQL Server, insérez le CD-ROM d'installation de Microsoft SQL Server dans le lecteur de CD-ROM, puis suivez les instructions qui s'affichent à l'écran. L'Assistant Installation vous guide durant les différentes étapes d'installation de SQL Server.

Respectez les conditions suivantes :

  • Sur la page Choix de l'installation, cliquez sur Créer une nouvelle instance de SQL Server ou installer des outils clients.

  • Sur la page Choix de l'installation, cliquez sur Outils clients uniquement.


Attribution de TCP/IP à la bibliothèque de réseau par défaut

Lorsque vous installez les utilitaires clients SQL Server, le programme d'installation de SQL Server installe des canaux nommés en tant que bibliothèque réseau client par défaut. BizTalk Server communique avec SQL Server via le protocole TCP/IP. Vous devez donc utiliser le protocole TCP/IP à la place de la bibliothèque réseau par défaut.

Pour modifier la bibliothèque réseau par défaut dans SQL Server 7.0 :

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server 7.0, puis cliquez sur Utilitaire Réseau Client.

    La boîte de dialogue Utilitaire Réseau Client SQL Server apparaît.

  2. Dans l'onglet Général, sélectionnez TCP/IP dans la liste Bibliothèque réseau par défaut.

  3. Cliquez sur OK.

Pour modifier la bibliothèque réseau par défaut dans SQL Server 2000 :

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Utilitaire Réseau Client.

  2. Dans l'onglet Général, assurez-vous que TCP/IP figure dans la liste Protocoles activés par ordre, puis cliquez sur FLÈCHE HAUT pour placer le protocole TCP/IP au sommet de la liste.


Définition du mode d'authentification SQL de SQL Server 2000

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, puis Groupe SQL Server.

  3. Cliquez avec le bouton droit sur le nom de votre serveur, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de SQL Server apparaît.

  4. Cliquez sur l'onglet Sécurité, sur Uniquement Windows, puis sur OK.


Vérification du fonctionnement de SQL Server

Avant d'installer BizTalk Server 2002, vérifiez que SQL Server fonctionne sur votre serveur. Cette opération est nécessaire car BizTalk Server 2002 doit créer quatre bases de données pendant l'installation.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server (si vous avez installé SQL Server 2000) ou sur Microsoft SQL Server 7.0 (si vous avez installé SQL Server 7.0), puis cliquez sur Gestionnaire de services.

    La boîte de dialogue Gestionnaire des services SQL Server apparaît.

  2. Dans la liste Serveur, vérifiez que le nom du serveur est celui de votre ordinateur.

    Dans le cas contraire, cliquez sur la flèche de la liste déroulante pour afficher la liste des serveurs disponibles et localisez votre serveur.

  3. Dans la liste Services, cliquez sur MSSQLServer (pour SQL Server 7.0) ou sur SQL Server (pour SQL Server 2000).

  4. Vérifiez que le service MSSQLServer ou SQL Server fonctionne.

    Le service fonctionne si le bouton Démarrer/Continuer de la boîte de dialogue n'est pas disponible. De plus, le message figurant au bas de la boîte de dialogue indique que le service fonctionne, par exemple : \\<nom_serveur>--MSSQLServer--Running.

  5. Si le service ne fonctionne pas, le bouton Démarrer/Continuer est disponible. Il vous suffit de cliquer dessus pour lancer le service.


Interactions entre SQL Server et les bases de données BizTalk Server 2002

BizTalk Server 2002 ~ Installation

Interactions entre les bases de données SQL Server et BizTalk Server 2002

Pour éviter l'allocation d'espace disque inutile, utilisez les fonctions Vider le journal au point de contrôle et Réduire automatiquement de Microsoft SQL Server. Si vous ne le faites pas, les connexions à SQL Server peuvent consommer une quantité importante d'espace disque. Vous devez toutefois installer BizTalk Server 2002 avant d'effectuer cette opération. Pour plus d'informations, voir Éviter l'allocation d'espace disque inutile. Pour plus d'informations sur l'installation de BizTalk Server 2002, voir Instructions d'installation.

BizTalk Server 2002 utilise l'authentification Windows pour accéder aux bases de données Gestion d'échanges BizTalk, de files d'attente partagées et de suivi, ainsi qu'à l'application de suivi de documents BizTalk sur le Web. Si vous ne souhaitez pas installer BizTalk Server et SQL Server sur le même ordinateur, le compte que vous utilisez doit bénéficier de privilèges d'administrateur sur l'ordinateur exécutant SQL Server et sur l'ordinateur exécutant BizTalk Server.

Question d'ordre international

  • BizTalk Server ne peut pas accéder aux bases de données créées dans une version de BizTalk Server écrite dans une autre langue.

Les procédures suivantes sont nécessaires pour établir des autorisations pour les installations SQL Server distantes et sur le serveur distant pour l'accès aux bases de données BizTalk Server appropriées.

Compte de connexion SQL Server à distance

Remarque

  • Si, par défaut, SQL Server et BizTalk Server 2002 sont installés sur l'ordinateur local et si le compte du services d'échanges BizTalk a été ajouté au groupe Administrateurs sur l'ordinateur local, les autorisations d'administrateur système sont déjà présentes dans SQL Server. Auquel cas, il n'est pas nécessaire d'effectuer les opérations suivantes. Si vous n'installez pas BizTalk Server et SQL Server sur le même ordinateur, vous devez effectuer les opérations suivantes pour que BizTalk Server 2002 soit en mesure d'accéder à SQL Server.
  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL et Groupe SQL Server, développez le serveur auquel vous voulez ajouter un compte de connexion SQL Server, puis développez Sécurité.

  3. Cliquez avec le bouton droit sur Connexions, puis cliquez sur Nouvelle connexion.

    La boîte de dialogue Propriétés de la connexion SQL Server – Nouvelle connexion apparaît.

  4. Dans l'onglet Général, dans la zone Nom, indiquez un nom de domaine et un nom de compte Windows.

    Par exemple : <DOMAINE>\<compte_de_services> spécifie le nom du compte sur lequel le service d'échanges BizTalk est exécuté.

  5. Dans l'onglet Rôles du serveur, dans la liste Rôles du serveur, activez la case à cocher Administrateurs système.

Remarque

  • Le compte de services du service d'échanges BizTalk peut fonctionner sans privilèges d'administrateur.
  6. Cliquez sur OK pour fermer la page Propriétés de connexion de SQL Server.

Établissement d'autorisations d'accès aux bases de données à distance

Une fois que vous avez installé BizTalk Server 2002, vous devez indiquer les bases de données auxquelles vous accédez par le biais du compte de connexion SQL Server. Reportez-vous aux étapes suivantes pour attribuer au compte de connexion SQL Server des autorisations d'accès aux bases de données Gestion d'échanges BizTalk, de files d'attente partagées et de suivi.

Remarque

  • Avant d'effectuer ces opérations, vous devez installer BizTalk Server.
  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, le serveur contenant les bases de données BizTalk Server et Sécurité, puis cliquez sur Connexions.

  3. Dans le volet des détails, double-cliquez sur le compte de connexion SQL Server que vous avez créé pour le compte des services d'échanges BizTalk.

    La page Propriétés de la connexion SQL Server apparaît.

  4. Dans l'onglet Accès aux bases de données, activez la case à cocher InterchangeBTM.

    Le nom de compte que vous avez indiqué apparaît dans la boîte de dialogue Utilisateur. Le champ Autoriser dans le rôle de base de données apparaît automatiquement au bas de cette page.

  5. Dans le champ Autoriser dans le rôle de base de données, activez les cases à cocher db_owner et dta_ui_role.

  6. Répétez les étapes 4 et 5 pour les bases de données InterchangeDTA et InterchangeSQ, en sélectionnant uniquement db_owner dans le champ Autoriser dans le rôle de base de données.

    Remarque

    • Pendant la phase d'installation, l'objet base de données Gestion d'échanges BizTalk prend par défaut le nom InterchangeBTM ; l'objet base de données de suivi prend par défaut le nom InterchangeDTA et l'objet base de données File d'attente partagée prend par défaut le nom InterchangeSQ. Vous pouvez avoir renommé ces objets bases de données par défaut pendant l'installation.


Installation de Microsoft Visio 2002

Dans le mesure où le Concepteur d'Orchestration BizTalk est une interface utilisateur reposant sur Microsoft Visio 2002, vous devez installer Visio 2002 avant d'utiliser le Concepteur d'Orchestration BizTalk. L'utilisation du Concepteur d'Orchestration BizTalk avec Visio 2002 a fait l'objet de tests approfondis.

Installez Visio 2002 Édition Standard

  1. Insérez le CD-ROM de Visio 2002 dans le lecteur de CD-ROM.

  2. Exécutez le programme d'installation de Visio 2002 et suivez les instructions qui s'affichent à l'écran.

Pour plus d'informations, reportez-vous à la documentation qui accompagne Microsoft Visio 2002.

Question d'ordre international

  • Dans certaines langues, certains caractères risquent de ne pas s'afficher correctement dans le Concepteur d'Orchestration BizTalk. Pour remédier à ce problème, spécifiez que Microsoft Visio 2002 utilise systématiquement la police par défaut du système :
    1. Dans le menu Démarrer, pointez sur Programmes, puis cliquez sur Microsoft Visio.

    2. Dans le menu Outils, cliquez sur Options.

    3. Cliquez sur l'onglet Options régionales, et dans la zone Police de base du document, cliquez sur Toujours utiliser la police système par défaut.

    4. Fermez Visio et ouvrez le Concepteur d'Orchestration BizTalk.


Installation de Microsoft Application Center 2000

Microsoft Application Center 2000 avec Service Pack 1 (SP1) est requis uniquement si vous voulez tirer profit des fonctionnalités de déploiement de BizTalk Server 2002.

Important

  • Vous devez installer Microsoft Application Center avant de procéder à l'installation de BizTalk Server, et les deux applications doivent être installées sur le même ordinateur.

  • Vous ne pouvez pas installer Microsoft Application Center 2000 sur un ordinateur exécutant Microsoft Windows 2000 Datacenter Server.

Installation de Microsoft Application Center 2000

  1. Insérez le CD-ROM de Microsoft Application Center 2000 dans le lecteur de CD-ROM.

  2. Exécutez le programme d'installation de Microsoft Application Center 2000 et suivez les instructions qui s'affichent à l'écran.

Important

  • Une fois que vous avez installé Application Center 2000, vous devez installer le Service Pack 1 de Microsoft Application Center 2000. Pour plus d'informations sur l'installation de ce correctif, consultez le fichier Lisezmoi enregistré dans le répertoire Application Center 2000 SP1.

  • Si vous n'installez pas Application Center avant de procéder à l'installation de BizTalk Server, le pilote et l'énumérateur sont installés dans le sous-répertoire AppCenter du répertoire d'installation de BizTalk Server et ne sont pas enregistrés.

    Pour enregistrer le pilote et l'énumérateur :

    1. Installez Microsoft Application Center 2000 et le Service Pack 1.

    2. Copiez les fichiers rdrvbts.dll et AcBtsEnm.dll du répertoire \Program Files\Microsoft BizTalk Server\AppCenter dans le répertoire d'installation de Microsoft Application Center.

    3. Copiez les fichiers GIF du répertoire \Program Files\Microsoft BizTalk Server\AppCenter\Images dans le dossier Admin\Images du répertoire d'installation de Microsoft Application Center.

    4. Pour enregistrer le pilote et l'énumérateur, exécutez « regsvr32.exe rdrvbts.dll » et « regsvr32.exe AcBtsEnm.dll » sur la ligne de commande. Vous devrez peut-être indiquer le chemin complet des fichiers DLL (Dynamic-Link Libraries).


Instructions d'installation

Vous pouvez installer Microsoft BizTalk Server 2002 à l'aide de l'Assistant Installation (Microsoft BizTalk Server.msi) ou de Microsoft Windows Installer (Msiexec.exe). L'Assistant Installation est une procédure pas à pas au cours de laquelle vous sélectionnez des options correspondant à des valeurs de propriété spécifiques. Microsoft Windows Installer vous permet d'indiquer des valeurs de propriétés sur la ligne de commande. Vous pouvez utiliser cette méthode pour installer BizTalk Server 2002 en mode silencieux (sans interaction ou invites de commande permanentes). Une installation de BizTalk Server 2002 en mode silencieux constitue une solution idéale pour les scénarios de test ou dans le cadre d'un déploiement à grande échelle au sein d'une entreprise.

Quel que soit le type d'installation choisi, il est recommandé de conserver un enregistrement des informations suivantes pour une utilisation ultérieure :

  • Noms de groupes de serveurs BizTalk Server
    Valeur par défaut : groupe BizTalk Server

  • Noms de serveurs Microsoft SQL
    Valeur par défaut : nom de l'ordinateur sur lequel SQL Server est installé

  • Noms d'utilisateur et mots de passe du compte de services BizTalk Server

  • Nom de la base de données Gestion d'échanges BizTalk
    Valeur par défaut : InterchangeBTM

  • Nom de la base de données de suivi
    Valeur par défaut : InterchangeDTA

  • Nom de la base de données de files d'attente partagées
    Valeur par défaut : InterchangeSQ

  • Nom de la base de données de persistance d'orchestration
    Valeur par défaut : XLANG

  • URL du référentiel WebDAV
    Valeur par défaut : \\localhost\BizTalkTracking

Important

  • Avant d'exécuter le programme d'installation de BizTalk Server 2002, vérifiez que vous êtes connecté à l'ordinateur avec un compte doté d'autorisations d'administrateur sur l'ordinateur local et sur tous les ordinateurs SQL Server que vous voulez configurer. Pour plus d'informations sur la création d'un compte de connexion SQL Server disposant de privilèges d'administrateur sur un ordinateur distant, voir Interactions entre les bases de données SQL Server et BizTalk Server 2002.

  • BizTalk Server 2002 nécessite l'analyseur Microsoft XML (MSXML) version 3.0 avec le Service Pack 1 (SP1). Cette version de BizTalk Server 2002 installe automatiquement l'analyseur Microsoft XML (MSXML) version 3.0 avec le Service Pack 1. Si vous utilisez BizTalk Server 2002 avec une autre version de MSXML, les résultats ne sont pas garantis. Si vous devez procéder à une installation en mode côte à côte de MSXML 3.0 et 4.0 (ou d'une version ultérieure), désinstallez MSXML 4.0 avant d'installer BizTalk Server 2002, puis réinstallez MSXML 4.0 une fois l'installation de BizTalk Server terminée.

  • Vous devez utiliser la console système Windows 2000 pour installer BizTalk Server 2002. L'utilisation des services Terminal Server pour installer BizTalk Server n'est pas prise en charge.

Remarques

  • Pour obtenir des informations détaillées sur les problèmes de sécurité de BizTalk Server, voir Instructions relatives à la sécurité.

  • Pour plus d'informations sur le déploiement de BizTalk Server 2002 dans un environnements de clusters, consultez le site Web de Microsoft BizTalk Server (www.microsoft.com/france/biztalk) et recherchez la page relative au déploiement qui figure dans la section des ressources techniques.

Cette section traite des rubriques suivantes :

  • Installation complète

  • Installation des outils

  • Installation personnalisée

  • Mise à niveau

  • Installation en mode silencieux

  • Suppression de BizTalk Server 2002


Installation complète

La section suivante permet d'effectuer une installation complète de Microsoft BizTalk Server 2002, qui inclut tous les services, outils et exemples de BizTalk Server.

Important

  • Avant d'installer BizTalk Server 2002, vous devez vous assurer que votre configuration logicielle et matérielle est adaptée. Pour vérifier que vous avez respecté les conditions préalables requises, voir Liste de vérification des tâches d'installation.

  • Pour être en mesure d'installer BizTalk Server, vous devez activer les services IIS. Le service démarrera lors du processus d'installation de BizTalk Server.

  • BizTalk Server 2002 utilise l'authentification Windows pour accéder aux bases de données Gestion d'échanges BizTalk, de files d'attente partagées et de suivi, ainsi qu'à l'application de suivi de documents BizTalk sur le Web. Vérifiez que le mode d'authentification Microsoft SQL Server est paramétré sur Windows avant d'installer BizTalk Server 2002. Pour plus d'informations, voir Définition du mode d'authentification SQL pour SQL Server 2000. Si SQL Server est installé sur un ordinateur distant, assurez-vous que le compte que vous utilisez est membre du groupe Administrateurs de SQL Server. Pour plus d'informations, voir Interactions entre les bases de données SQL Server et BizTalk Server 2002.

  • BizTalk Server 2002 nécessite l'analyseur Microsoft XML (MSXML) version 3.0 avec le Service Pack 1 (SP1).

  • Cette version de BizTalk Server 2002 installe automatiquement l'analyseur Microsoft XML (MSXML) version 3.0 avec le Service Pack 1. L'utilisation de BizTalk Server 2002 avec d'autres versions de MSXML risque de produire des résultats inattendus. Si vous devez procéder à une installation en mode côte à côte de MSXML 3.0 et 4.0 (ou d'une version ultérieure), désinstallez MSXML 4.0 avant d'installer BizTalk Server 2002, puis réinstallez MSXML 4.0 une fois l'installation de BizTalk Server terminée.

Installation complète de BizTalk Server 2002

  1. Insérez le CD-ROM de Microsoft BizTalk Server 2002 dans le lecteur de CD-ROM pour lancer l'Assistant Installation. L'Assistant Installation vous guide au cours des étapes nécessaires à l'installation de BizTalk Server 2002. Vous devez respecter les conditions mentionnées dans les étapes suivantes.

  2. Sur la page Informations client, tapez votre nom dans la zone Nom d'utilisateur, le nom de votre entreprise dans la zone Organisation, puis cliquez sur Suivant.

  3. Sur la page Dossier de destination, cliquez sur Suivant pour installer BizTalk Server 2002 dans le répertoire par défaut : C:\Program Files\Microsoft BizTalk Server ou cliquez sur Modifier pour sélectionner un autre emplacement.

  4. Dans la boîte de dialogue Type d'installation, cliquez sur Complète, puis sur Suivant.

  5. Sur la page Configurer l'accès administratif à BizTalk Server, acceptez le nom de groupe par défaut Administrateurs BizTalk Server ou tapez le nom du groupe que vous voulez utiliser dans la zone Nom du groupe.

    Important

    • Ne renommez pas ce groupe sans modifier également la valeur de « AdminGroupName » dans le Registre de Windows sous HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
      BizTalk Server\1.0\NTGroups      . BizTalk Server 2002 utilise cette clé de Registre pour rechercher le groupe.

    Remarque

    • Pour créer un nom de groupe, respectez les restrictions de désignation de groupe suivantes :

      Le nom du groupe doit être différent de tout autre nom de groupe ou d'utilisateur de cet ordinateur.

      Le nom du groupe ne peut pas contenir les caractères suivants : `~ ! @ # $ % ^ & * ( ) + = [ ] { } | ; \ " ' < > , . ?

      Le nom du groupe ne peut pas comprendre uniquement des points ( . ) ou des espaces.

  6. Dans la zone Description du groupe, tapez une nouvelle description du nom du groupe ou acceptez la valeur par défaut, puis cliquez sur Suivant.

  7. Sur la page Propriétés de connexion du service Microsoft BizTalk Server, acceptez la valeur par défaut Ce compte pour spécifier un compte de service. Il s'agit du compte sous lequel le service d'échanges BizTalk s'exécutera. Pour que ce compte fonctionne correctement, il doit bénéficier de l'accès à SQL Server. Dans la zone Mot de passe, tapez un mot de passe valide.

    Si vous ne voulez pas que les services BizTalk démarrent automatiquement à la fin de l'installation, désactivez la case à cocher Démarrer le service après la fin de l'installation. Ainsi, les services d'échanges BizTalk Server ne démarreront pas automatiquement.

    Remarques

    • L'installation de BizTalk Server accorde les droits Connexion en tant que service et Agir en tant que partie du système d'exploitation au compte spécifié sur la page Propriétés de connexion du service Microsoft BizTalk Server.

    • Si vous sélectionnez Ce compte, alors que vous avez l'intention d'utiliser des certificats de clés publiques ou privées dans votre implémentation de BizTalk Server, vous devez spécifier un compte faisant partie du groupe d'administrateurs de Windows 2000 sur l'ordinateur local. Pour configurer des certificats pour les composants S/MIME dans le Gestionnaire d'échanges BizTalk, vous devez également vous connecter en utilisant un compte qui fait partie du groupe d'administrateurs de Windows 2000 local.
  8. Cliquez sur Suivant.

  9. Sur la page Prêt à installer le programme, cliquez sur Installer.

    La procédure d'installation de BizTalk Server 2002 peut prendre plusieurs minutes.

  10. Lorsque la page Assistant Configuration des bases de données d'échanges Microsoft BizTalk Server 2002 apparaît, cliquez sur Suivant.

    Pendant l'installation des bases de données BizTalk Server 2002, vous êtes invité à indiquer des informations sur les bases de données et l'ordinateur SQL Server, afin de configurer les bases de données Gestion d'échanges BizTalk, de suivi et de files d'attente partagées.

    Attention

    • Ne modifiez pas le code, tel que les procédures stockées ou les déclencheurs, dans les bases de données Gestion d'échanges BizTalk, de suivi et de files d'attente partagées. N'accédez pas directement aux bases de données. N'appelez pas directement les procédures stockées. Effectuez toutes les modifications des bases de données via les méthodes et les propriétés du modèle d'objets de configuration d'échanges BizTalk. Si vous apportez directement des modifications aux bases de données, de nombreuses contraintes appliquées par le modèle d'objets de configuration d'échanges BizTalk ne sont pas respectées, ce qui entraîne un mauvais fonctionnement du serveur ou une altération de la base de données.
  11. Sur la page Configurer une base de données Gestion d'échanges BizTalk, acceptez la valeur par défaut Créez une nouvelle base de données Gestion d'échanges BizTalk, ou cliquez sur Sélectionnez une base de données existante et tapez le nom de votre serveur dans la zone de texte appropriée.

    Important

    • Si vous installez BizTalk Server 2002 sur un ordinateur exécutant Microsoft Windows 2000 Professionnel, le nom de serveur que vous devez indiquer correspond au nom de l'ordinateur sur lequel vous avez installé Microsoft SQL Server 7.0 ou Microsoft SQL Server 2000.

    • Pour créer une base de données ayant le même nom qu'une base de données existante sur le même serveur, il est recommandé de supprimer manuellement le contenu de la base de données. Pour plus d'informations sur la suppression du contenu d'une base de données, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne. Le programme d'installation de BizTalk Server vérifie uniquement si une procédure stockée requise par la base de données existe, au lieu de vérifier si toutes les variables requises par la base de données existent. Si la procédure stockée existe, le programme d'installation de BizTalk Server ne modifie pas la base de données. Si la procédure stockée n'existe pas, le programme d'installation de BizTalk Server supprime la base de données. Ensuite, il réinitialise les tables de la base de données Gestion d'échanges BizTalk. Ces informations s'appliquent également aux bases de données de files d'attente partagées et Suivi.

    • Si vous avez configuré plusieurs installations de BizTalk Server et souhaitez centraliser la gestion de la base de données Gestion d'échanges BizTalk, nous vous recommandons de revoir les informations sur la modification de la base de données Gestion d'échanges BizTalk. Pour plus d'informations, voir Modification de la base de données Gestion d'échanges BizTalk.
  12. Cliquez sur Suivant.

  13. Sur la page Configurer un groupe de serveurs BizTalk Server, tapez le nom que vous voulez utiliser comme groupe BizTalk Server dans la zone Nom du groupe ou acceptez la valeur par défaut (Groupe de serveurs BizTalk), puis cliquez sur Suivant.

    Si vous avez configuré d'autres groupes BizTalk Server, vous pouvez également cliquer sur Sélectionnez un groupe BizTalk Server et choisir un nom dans la liste Nom du groupe.

    Important

    • Le nom du groupe ne peut pas contenir les caractères suivants : `~ ! @ # $ % ^ & * ( ) + = [ ] { } | ; \ " '< > , . ?

    • Tous les serveurs d'un groupe doivent disposer de la même version de BizTalk Server, dans la même langue. Les bases de données ne fonctionneront pas correctement si des versions différentes de BizTalk Server (BizTalk Server 2000, BizTalk Server 2000 Service Pack 1, BizTalk Server 2002 Édition Entreprise ou une version de BizTalk Server dans une autre langue) sont installées sur les serveurs d'un même groupe.
  14. Sur la page Configurer une base de données de suivi, répétez la procédure de l'étape 11 et cliquez sur Suivant.

  15. Sur la page Configurer une base de données de files d'attente partagées, répétez la procédure de l'étape 11 et cliquez sur Suivant.

  16. Sur la page Vérifiez le groupe BizTalk Server, vérifiez que les informations de la zone Propriétés du groupe de serveurs BizTalk Server sont correctes et cliquez sur Suivant.

  17. Sur la dernière page de l'Assistant Configuration des bases de données d'échanges Microsoft BizTalk Server 2002, cliquez sur Terminer pour terminer la configuration des bases de données Gestion d'échanges BizTalk, de suivi et de files d'attente partagées.

  18. Sur la page Assistant Configuration des bases de données de persistance d'orchestration Microsoft BizTalk Server, cliquez sur Suivant pour installer la base de données Persistance d'orchestration.

    Remarque

    • Si vous cliquez sur Annuler, BizTalk Server 2002 est installé, mais pas la base de données Persistance d'orchestration et le nom DSN (Data Source Name). Vous pouvez installer la base de données et le nom DSN ultérieurement. Pour plus d'informations, voir Création d'une base de données de persistance, Gestion des autres applications COM+ hébergeant des planifications XLANG et Configuration d'une application COM+ pour héberger des planifications XLANG.
  19. Sur la page Configurez une base de données de persistance d'orchestration par défaut, acceptez le paramètre par défaut Créez une nouvelle base de données de persistance d'orchestration par défaut, ou bien cliquez sur Sélectionnez une base de données existante et choisissez le nom d'un ordinateur SQL Server et tapez les informations relatives à la base de données dans les zones de texte appropriées.

    Important

    • Si vous sélectionnez Créez une nouvelle base de données de persistance d'orchestration par défaut et choisissez une base de données ayant le même nom, sur le même serveur, comme base de données existante, le programme d'installation de BizTalk Server supprime le contenu de la base de données. Le programme d'installation de BizTalk Server réinitialise ensuite les tables de la base de données Persistance d'orchestration.

    • Si vous installez BizTalk Server 2002 sur un ordinateur exécutant Microsoft Windows 2000 Professionnel, le Nom du serveur que vous devez indiquer correspond au nom de l'ordinateur sur lequel vous avez installé Microsoft SQL Server.

    Remarques

    • La base de données Persistance d'orchestration est créée en fonction de l'identité de connexion de l'utilisateur.

    • Pour utiliser SQL Server à distance, vous devez disposer des autorisations appropriées pour la base de données Persistance d'orchestration. Si vous n'avez pas reconfiguré l'identité du moteur de XLANG Scheduler, les autorisations seront accordées à l'utilisateur qui s'était connecté lors de l'installation de BizTalk Server 2002. Si vous avez configuré l'identité du moteur de XLANG Scheduler pour qu'elle corresponde à un compte de services créé ou à un autre compte de services unique, vous devez faire en sorte que les autorisations SQL correspondent à l'identité reconfigurée.
  20. Cliquez sur Terminer.

  21. Sur la dernière page de l'Assistant Installation de Microsoft BizTalk Server 2002, cliquez sur Afficher le fichier Lisezmoi afin de lire les dernières informations importantes sur BizTalk Server 2002, puis cliquez sur Terminer.

Attention

  • Ne modifiez pas le niveau d'emprunt d'identité des applications COM+. Le niveau par défaut est Emprunter l'identité. Si vous attribuez la valeur Anonyme, Identifier ou Déléguer à cette propriété de sécurité, vous pourrez rencontrer des problèmes lors de l'installation.

  • Une fois BizTalk Server 2002 installé sur l'ordinateur, vous ne pouvez plus modifier le nom de ce dernier. BizTalk Server 2002 utilise le nom de l'ordinateur en interne ; c'est pourquoi, si vous le renommez, BizTalk Server 2002 détecte un autre nom et génère un message d'erreur. Toutefois, si vous avez besoin de renommer l'ordinateur, désinstallez BizTalk Server, renommez l'ordinateur, puis réinstallez BizTalk Server.

Important

  • Si SQL Server est exécuté sur un ordinateur distant, vous devrez indiquer que le compte de connexion SQL Server bénéficie d'autorisations d'accès aux bases de données Gestion d'échanges BizTalk, de files d'attente partagées et de suivi. Pour plus d'informations, voir Interactions entre les bases de données SQL Server et BizTalk Server 2002.

Remarque

  • Pour améliorer sensiblement les performances des services d'orchestration BizTalk, dans l'Explorateur Windows, accédez à Program Files\ Fichiers communs \System\ado, puis double-cliquez sur adofre15.reg. Dans la boîte de dialogue de confirmation, cliquez sur Oui, puis sur OK. Cette procédure remplace le modèle de thread ADO (Microsoft® ActiveX® Data Objects) « Threads cloisonnées » par « Les deux » et peut avoir une incidence sur d'autres applications qui utilisent ADO. Les fournisseurs qui ne sont pas sécurisés contre les threads ne peuvent être utilisés.

Veillez à effectuer les opérations suivantes après l'installation :

  • Éviter l'allocation d'espace disque inutile

  • Démarrage du service de publication Web

  • Configuration du suivi de documents BizTalk


Éviter l'allocation d'espace disque inutile

  1. Dans le menu Démarrer, pointez sur Programmes, sur Microsoft SQL Server 7.0 ou Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, <nom_serveur> et Bases de données.

  3. Cliquez avec le bouton droit sur la base de données Gestion d'échanges BizTalk et cliquez sur Propriétés.

    La boîte de dialogue de propriétés de la base de données Gestion d'échanges BizTalk s'affiche.

  4. Cliquez sur l'onglet Options.

  5. Dans la zone Paramètres, activez les cases à cocher Vider le journal au point de contrôle et Réduire automatiquement, puis cliquez sur OK.

    Remarque

    • Si vous avez installé Microsoft SQL Server 2000, activez la case à cocher Réduire automatiquement et remplacez Modèle dans la zone Récupération par Simple.
  6. Répétez les étapes 3 à 5 pour les bases de données de suivi et de files d'attente partagées.

Remarque

  • Pendant la phase d'installation, l'objet base de données Gestion d'échanges BizTalk prend par défaut le nom InterchangeBTM ; l'objet base de données de suivi prend par défaut le nom InterchangeDTA et l'objet base de données de files d'attente partagée prend par défaut le nom InterchangeSQ. Vous pouvez avoir renommé ces objets bases de données par défaut pendant l'installation.

Important

  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication Web est actif. Pour plus d'informations sur ce service, voir Démarrage du service de publication Web.


Démarrage du service de publication Web

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, cliquez sur Services (Locaux).

  3. Dans le volet des détails, cliquez avec le bouton droit sur Service de publication World Wide Web, puis cliquez sur Démarrer.


Configuration du suivi de documents BizTalk

Lorsque le suivi de documents BizTalk est installé à partir du CD-ROM de BizTalk Server 2002, un raccourci est créé sur l'ordinateur local dans le groupe de programmes de BizTalk Server 2002, pour permettre l'accès à l'application Web de suivi de documents BizTalk. Cependant, lorsque vous accédez à l'application Web de suivi de documents BizTalk depuis un ordinateur distant, vous devez créer un raccourci ou un favori manuellement pour accéder ultérieurement à l'application Web. Dans les deux cas, pour éviter l'affichage de boîtes de dialogue d'avertissement concernant la sécurité, vous devez configurer les paramètres de votre navigateur manuellement afin d'approuver l'application Web.

Configuration des paramètres de sécurité Internet Explorer

  1. Dans le menu Démarrer, pointez sur Programmes, sur Microsoft BizTalk Server 2002, puis cliquez sur Suivi de documents BizTalk.

    Remarques

    • Si vous avez créé un favori dans Microsoft Internet Explorer, vous pouvez ouvrir l'application Web de suivi de documents BizTalk à partir de Microsoft Internet Explorer.

    • Si vous n'avez pas installé les Contrôles communs Microsoft et le contrôle de Suivi de documents BizTalk, un message vous invite à installer les composants. Pour plus d'informations, voir Ouverture de Suivi de documents BizTalk pour la première fois.
  2. Copiez l'emplacement du serveur de suivi de documents BizTalk à partir de la barre d'adresses de Microsoft Internet Explorer dans le Presse-papiers.

  3. Dans le menu Outils, cliquez sur Options Internet.

    La boîte de dialogue Options Internet s'affiche.

  4. Dans l'onglet Sécurité, cliquez sur Sites de confiance, puis sur Sites.

    La boîte de dialogue Sites de confiance s'affiche.

  5. Dans Zone, collez l'emplacement du serveur de suivi de documents BizTalk à partir du Presse-papiers.

  6. Désactivez la case à cocher Vérifier le serveur (https:) pour tous les sites dans cette zone.

  7. Cliquez sur Ajouter, puis sur OK à deux reprises pour fermer les boîtes de dialogue.


Installation des outils

Une installation des outils Microsoft BizTalk Server 2002 vous permet d'installer uniquement les composants suivants :

  • Concepteur d'Orchestration BizTalk

  • Éditeur BizTalk

  • Mappeur BizTalk

  • Composant logiciel enfichable Administration BizTalk Server de la console MMC (Microsoft Management Console).

  • Aide de Microsoft BizTalk Server 2002

Le parseur, le sérialiseur, la corrélation et les binaires d'exécution de BizTalk Server 2002 ne sont pas installés.

Installation des outils de BizTalk Server 2002

  1. Insérez le CD-ROM de Microsoft BizTalk Server 2002 dans le lecteur approprié pour lancer l'Assistant Installation. L'Assistant Installation vous guide au cours des étapes nécessaires à l'installation de BizTalk Server 2002. Vous devez respecter les conditions mentionnées dans les étapes suivantes.

  2. Sur la page Informations client, tapez votre nom dans la zone Nom d'utilisateur, le nom de votre entreprise dans la zone Organisation, puis cliquez sur Suivant.

  3. Sur la page Dossier de destination, cliquez sur Suivant pour installer BizTalk Server 2002 dans le répertoire par défaut : C:\Program Files\Microsoft BizTalk Server ou cliquez sur Modifier pour sélectionner un autre emplacement.

  4. Dans la boîte de dialogue Type d'installation, cliquez sur Outils, puis sur Suivant.

  5. Sur la page Prêt à installer le programme, cliquez sur Installer.

  6. Sur la dernière page de l'Assistant Installation de Microsoft BizTalk Server 2002, cliquez sur Afficher le fichier Lisezmoi pour lire les dernières informations importantes sur cette version de BizTalk Server 2002.

  7. Cliquez sur Terminer pour achever le processus d'installation.


Installation personnalisée

Une installation personnalisée de Microsoft BizTalk Server 2002 permet d'installer toutes les fonctionnalités de BizTalk Server 2002 ou uniquement celles de votre choix.

Remarque

  • Pour installer les composants de serveur de BizTalk Server 2002, vous devez d'abord installer Microsoft SQL Server. Pour plus d'informations, voir Conditions préalables et configuration requise pour l'installation de SQL Server .

Attention

  • N'installez pas l'outil Gestionnaire d'échanges BizTalk, Internet Information Services (IIS) et la base de données de configuration BizTalk Server sur trois ordinateurs différents. Ce type de configuration entraîne des problèmes d'authentification.

Installation personnalisée de BizTalk Server 2002

  1. Insérez le CD-ROM de Microsoft BizTalk Server 2002 dans le lecteur approprié pour lancer l'Assistant Installation. L'Assistant Installation vous guide au cours des étapes nécessaires à l'installation de BizTalk Server 2002. Vous devez respecter les conditions mentionnées dans les étapes suivantes.

  2. Sur la page Informations client, tapez votre nom dans la zone Nom d'utilisateur, le nom de votre entreprise dans la zone Organisation, puis cliquez sur Suivant.

  3. Sur la page Dossier de destination, cliquez sur Suivant pour installer BizTalk Server 2002 dans le répertoire par défaut : C:\Program Files\Microsoft BizTalk Server ou cliquez sur Modifier pour sélectionner un autre emplacement.

  4. Dans la boîte de dialogue Type d'installation, cliquez sur Personnalisée, puis sur Suivant.

  5. Sur la page Installation personnalisée, suivez les instructions pour sélectionner les composants BizTalk Server 2002 que vous voulez installer.

    Pour effectuer un autre type d'installation, cliquez sur Précédent. Sinon, cliquez sur Suivant. D'autres pages s'affichent pour que vous puissiez entrer des informations complémentaires, selon les composants d'installation que vous avez sélectionnés.

  6. Sur la page Prêt à installer le programme, cliquez sur Installer.

    La procédure d'installation personnalisée de BizTalk Server 2002 peut prendre quelques minutes.

  7. Sur la dernière page de l'Assistant Installation de Microsoft BizTalk Server 2002, cliquez sur Afficher le fichier Lisezmoi afin de lire les dernières informations importantes sur cette version de Microsoft BizTalk Server 2002.

  8. Cliquez sur Terminer pour achever le processus d'installation.

Important

  • Le Gestionnaire d'échanges BizTalk ne peut fonctionner que si le service de publication Web est actif. Pour plus d'informations sur ce service, voir Démarrage du service de publication Web.

  • Pour améliorer sensiblement les performances des services d'orchestration BizTalk, dans l'Explorateur Windows, accédez à Program Files\ Fichiers communs \System\ado, puis double-cliquez sur adofre15.reg. Dans la boîte de dialogue de confirmation, cliquez sur Oui, puis sur OK. Cette procédure remplace le modèle de thread ADO (Microsoft ActiveX Data Objects) « Threads cloisonnées » par « Les deux » et peut affecter d'autres applications utilisant ADO.

  • Pour éviter l'allocation d'espace disque inutile, utilisez les fonctions Vider le journal au point de contrôle et Réduire automatiquement de Microsoft SQL Server. Sinon, les connexions à SQL Server peuvent consommer d'importantes quantités d'espace disque. Pour plus d'informations, voir Éviter l'allocation d'espace disque inutile.


Mise à niveau

La section suivante décrit comment effectuer une mise à niveau vers les services, outils et exemples de Microsoft BizTalk Server 2002.

Installation préliminaire

  • Avant de procéder à la mise à niveau vers BizTalk Server 2002, nous vous recommandons d'effectuer une sauvegarde complète de votre système actuel.

  • Nous vous conseillons également d'arrêter le service IISAdmin. Si vous n'effectuez pas cette opération, il est possible que deux DLL (MscsCore.dll et MSCSAspHelp.dll) ne soient plus présentes après la mise à niveau. Si cette situation se produit, recherchez les fichiers DLL sur le CD-ROM de BizTalk Server 2002, copiez-les dans le répertoire Program Files\Common Files, puis enregistrez les DLL.

  • Vous devez supprimer toutes les anciennes versions bêta de Microsoft BizTalk Server avant de procéder à la mise à niveau vers BizTalk Server 2002.

BizTalk Server 2002 utilise l'authentification Windows pour accéder aux bases de données Gestion d'échanges BizTalk, de files d'attente partagées et de suivi, ainsi qu'à l'application de suivi de documents BizTalk sur le Web. Vérifiez que le mode d'authentification SQL Server est paramétré sur Windows avant d'installer BizTalk Server 2002. Pour plus d'informations, voir Définition du mode d'authentification SQL de SQL Server 2000. Si SQL Server est installé sur un ordinateur distant, assurez-vous que le compte que vous utilisez est membre du groupe Administrateurs de SQL Server. Pour plus d'informations, voir Interactions entre les bases de données SQL Server et BizTalk Server 2002. Attention

  • Tous les fichiers existants du produit BizTalk Server seront supprimés lors du processus de mise à niveau. De plus, la configuration des services BizTalk Server 2000 et des applications COM+ sera perdue lorsque vous effectuerez une mise à niveau vers BizTalk Server 2002.

Important

  • BizTalk Server 2002 nécessite l'analyseur Microsoft XML (MSXML) version 3.0 avec le Service Pack 1 (SP1). Cette version de BizTalk Server 2002 installe automatiquement l'analyseur Microsoft XML (MSXML) version 3.0 avec le Service Pack 1. L'utilisation de BizTalk Server 2002 avec d'autres versions de MSXML risque de produire des résultats inattendus. Si vous devez procéder à une installation en mode côte à côte de MSXML 3.0 et 4.0 (ou d'une version ultérieure), désinstallez MSXML 4.0 avant d'installer BizTalk Server 2002, puis réinstallez MSXML 4.0 une fois l'installation de BizTalk Server terminée.

Mise à niveau vers BizTalk Server 2002

  1. Insérez le CD-ROM de Microsoft BizTalk Server 2002 dans le lecteur de CD-ROM pour lancer l'Assistant Installation. Ce dernier vous guide lors des étapes nécessaires à l'installation de BizTalk Server 2002. Vous devez respecter les conditions mentionnées dans les procédures suivantes.

  2. Sur la page Informations client, tapez votre nom dans la zone Nom d'utilisateur, le nom de votre entreprise dans la zone Organisation, puis cliquez sur Suivant.

  3. Sur la page Dossier de destination, cliquez sur Suivant pour effectuer une mise à niveau de l'installation de BizTalk Server située dans le répertoire par défaut.

  4. Dans la boîte de dialogue Type d'installation, cliquez sur Complète, Outils ou Personnalisée, puis cliquez sur Suivant.

    Remarque

    • Tous les fichiers existants de BizTalk Server seront supprimés lors de la mise à niveau. Seules les fonctionnalités que vous sélectionnez seront installées.
  5. Sur la page Configurer l'accès administratif à BizTalk Server, acceptez le nom de groupe par défaut Administrateurs BizTalk Server ou tapez le nom du groupe que vous voulez utiliser dans la zone Nom du groupe.

    Important

    • Ne renommez pas ce groupe sans modifier également la valeur de « AdminGroupName » dans le Registre de Windows sous HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\
      BizTalk Server\1.0\NTGroups      . BizTalk Server 2002 utilise cette clé du registre pour rechercher le groupe.

    Remarque

    • Pour créer un nom de groupe, respectez les restrictions de désignation de groupe suivantes :

      Le nom du groupe doit être différent de tout autre nom de groupe ou d'utilisateur de cet ordinateur.

      Le nom du groupe ne peut pas contenir les caractères suivants : `~ ! @ # $ % ^ & * ( ) + = [ ] { } | \\ ;\" '< > , . ?

      Le nom du groupe ne peut pas comprendre uniquement des points ( . ) ou des espaces.

  6. Sur la page Propriétés de connexion du service Microsoft BizTalk Server, acceptez la valeur par défaut Ce compte pour spécifier un compte de service. Il s'agit du compte sous lequel le service d'échanges BizTalk s'exécutera. Pour que ce compte fonctionne correctement, il doit bénéficier de l'accès à SQL Server. Dans la zone Mot de passe, tapez un mot de passe valide.

    Si vous ne voulez pas que les services BizTalk démarrent automatiquement à la fin de l'installation, désactivez la case à cocher Démarrer le service après la fin de l'installation. Ainsi, les services d'échanges BizTalk Server ne démarreront pas automatiquement.

    Remarques

    • L'installation de BizTalk Server accorde les droits Connexion en tant que service et Agir en tant que partie du système d'exploitation au compte spécifié sur la page Propriétés de connexion du service Microsoft BizTalk Server.

    • Si vous sélectionnez Ce compte, alors que vous avez l'intention d'utiliser des certificats de clés publiques ou privées dans votre implémentation de BizTalk Server, vous devez spécifier un compte faisant partie du groupe d'administrateurs de Windows 2000 sur l'ordinateur local. Pour configurer des certificats pour les composants S/MIME dans le Gestionnaire d'échanges BizTalk, vous devez également vous connecter en utilisant un compte qui fait partie du groupe d'administrateurs local de Windows 2000.
  7. Sur la page Prêt à installer le programme, cliquez sur Installer.

  8. Lorsque la page Assistant Configuration des bases de données d'échanges Microsoft BizTalk Server 2002 apparaît, cliquez sur Suivant.

  9. Sur la page Configurer une base de données Gestion d'échanges BizTalk, cliquez sur Sélectionner une base de données existante ou sur Créer une nouvelle base de données Gestion d'échanges BizTalk.

    Remarques

    • Les bases de données Gestion d'échanges BizTalk (InterchangeBTM), de suivi (InterchangeDTA) et de files d'attente partagées (InterchangeSQ) ne sont pas supprimées lors du processus de mise à niveau. Si vous créez une base de données, vous devrez changer les noms des bases de données.

    • Si vous conservez vos bases de données existantes, vous devrez confirmer que vous voulez mettre à niveau le schéma et les procédures stockées avant de poursuivre l'installation. Les procédures stockées et les schémas des bases de données ne seront pas compatibles avec BizTalk Server 2002. Cliquez sur Oui pour continuer.
  10. Sur la page Configurer un groupe de serveurs BizTalk Server, tapez le nom que vous voulez utiliser comme groupe BizTalk Server dans la zone Nom du groupe ou acceptez la valeur par défaut (Groupe de serveurs BizTalk), puis cliquez sur Suivant.

    Important

    • Tous les serveurs d'un groupe doivent disposer de la même version de BizTalk Server dans la même langue. Les bases de données ne fonctionneront pas correctement si des versions différentes de BizTalk Server (BizTalk Server 2000, BizTalk Server 2000 Service Pack 1, BizTalk Server 2002 Édition Entreprise ou une version de BizTalk Server dans une autre langue) sont installées sur les serveurs d'un même groupe.
  11. Sur les pages Configurer une base de données de suivi et Configurer une base de données de files d'attente partagées, répétez la procédure de l'étape 9, puis cliquez sur Suivant pour poursuivre.

  12. Sur la page Vérifiez le groupe BizTalk Server, vérifiez que les informations de la zone Propriétés du groupe de serveurs BizTalk Server sont correctes et cliquez sur Suivant.

  13. Sur la dernière page de l'Assistant Configuration des bases de données d'échanges Microsoft BizTalk Server 2002, cliquez sur Terminer pour terminer la configuration des bases de données Gestion d'échanges BizTalk, de suivi et de files d'attente partagées.

  14. Sur la page Assistant Configuration des bases de données de persistance d'orchestration Microsoft BizTalk Server, cliquez sur Suivant pour installer la base de données Persistance d'orchestration.

  15. Sur la page Configurer une base de données de persistance d'orchestration par défaut, cliquez sur Sélectionner une base de données existante ou sur Créer une nouvelle base de données Gestion d'échanges BizTalk.

  16. Cliquez sur Terminer pour achever le processus de mise à niveau.

Attention

  • Une fois BizTalk Server 2002 installé sur l'ordinateur, vous ne pouvez plus modifier le nom de ce dernier. BizTalk Server 2002 utilise le nom de l'ordinateur en interne ; c'est pourquoi, si vous le renommez, BizTalk Server 2002 détecte un autre nom et génère un message d'erreur. Si toutefois vous avez besoin de renommer l'ordinateur, désinstallez BizTalk Server, renommez l'ordinateur, puis réinstallez BizTalk Server.


Installation en mode silencieux

Microsoft Windows Installer (Msiexec.exe) est un programme exécutable qui interprète les packages et installe les produits. Microsoft Windows Installer vous permet d'indiquer des valeurs de propriétés sur la ligne de commande. Grâce à cette méthode, vous pouvez installer Microsoft BizTalk Server 2002 en mode silencieux (sans interaction ni invites constantes). Une installation de BizTalk Server 2002 en mode silencieux constitue une solution idéale pour les scénarios de test ou dans le cadre d'un déploiement à grande échelle au sein d'une entreprise.

Installation en mode silencieux de BizTalk Server 2002

  1. Dans le menu Démarrer, cliquez sur Exécuter.

  2. Dans la zone Ouvrir, tapez cmd et cliquez sur OK.

  3. Tapez la syntaxe suivante à l'invite de commande pour installer BizTalk Server 2002 en mode silencieux :
    msiexec /I "\\server\folder\Microsoft BizTalk Server.msi"
/qb /Lv* "C:\Temp\install.log" INSTALLLEVEL=200
ALLUSERS=1
DSNCONFIG="C:\Temp\BizTalkInstall.ini"

Important

  • Vous devez ajouter le paramètre ALLUSERS=1 pour terminer l'installation pour tous les utilisateurs. Ce paramètre permet de s'assurer que les services peuvent accéder aux paramètres du Registre.

  • Par défaut, le processus d'installation en mode silencieux utilise un compte système local. Si SQL Server réside sur un ordinateur distant, ce compte doit être autorisé à accéder à l'ordinateur sur lequel SQL Server est installé.

  • S'il ne bénéficie pas d'autorisations d'accès, le service échouera et des erreurs seront générées lors de l'accès à la base de données Gestion d'échanges BizTalk.

Remarques

  • Les options suivantes de la ligne de commande permettent d'exécuter Msiexec à l'étape 3 :
    • /I est la ligne de commande pour installer ou configurer un produit.

    • /qb est la ligne de commande pour présenter une interface utilisateur de base (barre de progression uniquement).

    • /Lv* génère un fichier journal.

    • INSTALLLEVEL=200 installe le serveur. Si vous ne spécifiez pas INSTALLLEVEL, la valeur par défaut est 100, ce qui correspond à l'installation des outils de BizTalk Server 2002.

    • DSNCONFIG="C:\Temp\BizTalkInstall.ini" fournit des informations d'installation à l'Assistant Installation.

Vous pouvez spécifier différentes options sur la ligne de commande pour définir les propriétés d'une installation de BizTalk Server 2002. Les propriétés non spécifiées correspondent aux valeurs par défaut. Les propriétés propres à BizTalk Server 2002 sont présentées dans le tableau ci-dessous.

Propriété publique | Valeur | Description
USERNAME (Propriété intégrée de Installer) | <nom> Valeur par défaut : {LogonUser} | Nom de l'utilisateur qui effectue l'installation. Boîte de dialogue Informations client ; zone d'édition Nom.
COMPANYNAME (Propriété intégrée de Installer) | <organisation> Valeur par défaut : {LogonCompany} | Nom de l'organisation pour laquelle l'utilisateur effectue l'installation. Boîte de dialogue Informations client ; zone d'édition Organisation.
INSTALLLEVEL (Propriété intégrée de Installer) | <niveau d'installation> Valeur par défaut : 100 | Niveau d'installation des fonctionnalités. Pour l'installation de BizTalk Server 2002, 100=Client et 200=Type d'installation serveur.
INSTALLDIR (Propriété intégrée de Installer) | <chemin d'installation> Valeur par défaut : "{ProgramFiles}\Microsoft BizTalk Server" | Dossier de destination de l'installation.
BTS_GROUP_NAME (Installation complète uniquement) | <Nom du groupe> Valeur par défaut : "Administrateurs BizTalk Server" | Nom du groupe BizTalk Server 2002 Windows NT®. Boîte de dialogue ConfigAdminGroup ; zone d'édition Nom du groupe.
BTS_GROUP_DESCRIPTION (Installation complète uniquement) | <Description du groupe> Valeur par défaut : "Les membres peuvent administrer totalement Microsoft BizTalk Server" | Description du groupe BizTalk Server 2002 Windows NT. Boîte de dialogue ConfigAdminGroup ; zone d'édition Description du groupe.
BTS_USERNAME (Installation complète uniquement) | <nomutilisateur> Valeur par défaut : "" | DOMAINE\nom d'ouverture de session du service BizTalk Server 2002. Boîte de dialogue ConfigServiceLogon ; zone d'édition Nom utilisateur.
BTS_PASSWORD (Installation complète uniquement) | <motdepasse> Valeur par défaut : "" | Mot de passe d'ouverture de session au service BizTalk Server 2002. Boîte de dialogue ConfigServiceLogon ; zone d'édition Mot de passe.
BTS_SERVER (Installation complète et installation des outils) | <nomserveur> Valeur par défaut : "hôtelocal" | Nom du serveur BizTalk à gérer à distance. Boîte de dialogue ConfigMgmtDesk ; zone d'édition Nom serveur.
BTS_SDK_SERVER (Installation complète et installation des outils) | <nomserveur> Valeur par défaut : ""hôtelocal"" | Nom du serveur BizTalk à utiliser pour DCOM. Boîte de dialogue ConfigSDK ; zone d'édition Nom serveur.
DSNCONFIG (Fichier d'initialisation) | <chemin d'accès> Valeur par défaut : "" | Chemin d'accès au fichier d'initialisation de BTSsetupDB.exe et XLANGsetupDB.exe que l'Assistant Installation va utiliser.

Remarques

  • L'installation en mode silencieux de BizTalk Server 2002 requiert la propriété DSNCONFIG. Le fichier d'initialisation indiqué sur la ligne de commande est transmis aux Assistants Configuration des bases de données BTSsetupDB.exe et XLANGsetupDB.exe. Sélectionnez l'une des valeurs de ligne de commande suivantes :
    • DSNCONFIG="Chemin d'accès complet au fichier .ini pour BTSsetupDB.exe et XLANGsetupDB.exe"

      -ou-

    • BTSSETUPDB.INI="Chemin d'accès complet au fichier .ini pour BTSsetupDB.exe" et XLANGSETUPDB.INI="Chemin d'accès complet au fichier .ini pour XLANGsetupDB.exe"
  • L'Assistant Configuration des bases de données traite le contenu du fichier d'initialisation en respectant les règles suivantes :
    • Toutes les [sections] et clés= sont facultatives ; en l'absence de clé, la valeur par défaut définie dans le fichier d'initialisation est utilisée.

    • Si GroupName existe dans la base de données Gestion d'échanges BizTalk, les sections [InterchangeDTA] et [InterchangeSQ] sont ignorées car le groupe définit les valeurs.

    • Les bases de données spécifiées sont créées si elles n'existent pas sur le serveur indiqué.
  • L'installation de la base de données Gestion d'échanges BizTalk et celle de la base de données Persistance d'orchestration sont indépendantes.

  • Selon les fonctionnalités que vous installez, le programme d'installation configure une des bases de données suivantes, aucune ou les deux :
    • Base de données de gestion d'échanges BizTalk : configurée uniquement si le Service d'échanges BizTalk et ses composants associés sont installés.

    • Base de données de persistance d'orchestration : configurée uniquement si les Services d'orchestration BizTalk sont installés.
  • Les propriétés suivantes sont utilisées sur la ligne de commande :
    • DSNCONFIG. Spécifie l'emplacement du fichier .ini qui sera utilisé par BTSsetupDB.exe et XLANGsetupDB.exe.

      -Ou-

      BTSSETUPDB.INI. Spécifie l'emplacement du fichier .ini qui sera utilisé par BTSsetupDB.exe.

    • XLANGSETUPDB.INI. Spécifie l'emplacement du fichier .ini qui sera utilisé par XLANGsetupDB.exe.

Exemple de fichier d'initialisation avec toutes les [sections], clés= et valeurs par défaut

Voici un exemple de format d'un fichier .ini requis pour l'installation en mode silencieux de BizTalk Server 2002. Ces propriétés de ligne de commande sont requises pour installer BizTalk Server 2002 à l'aide de Microsoft Windows Installer.

Exemple de SetupDB.ini

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Messaging Management databaseParamètres de connexion de SQL Server pour la base de données Gestion d'échanges BizTalk
; Required section used by BTSsetupDB.exe only.Section requise uniquement utilisée par BTSsetupDB.exe.
; Specify new or existing database.Spécifie la base de données nouvelle ou existante.
;
[InterchangeBTM]
Server=localhost
Username=sa
Password=
Database=InterchangeBTM

;----------------------------------------------------------------------
; Name for BizTalk Server GroupNom du groupe de serveurs BizTalk Server
; Required section used by BTSsetupDB.exe only.Section requise uniquement utilisée par BTSsetupDB.exe.
; Specify new or existing server group.Spécifie le groupe de serveurs nouveau ou existant.
;
[Group]
GroupName=BizTalkGroup

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Tracking databaseParamètres de connexion de SQL Server pour la base de données de suivi BizTalk
; Required section used by BTSsetupDB.exe only.Section requise uniquement utilisée par BTSsetupDB.exe.
; Optional if existing server group specified.Facultatif si le groupe de serveurs existant est indiqué.
;
[InterchangeDTA]
Server=localhost
Username=sa
Password=
Database=InterchangeDTA

;----------------------------------------------------------------------
; SQL Server connection parameters for BizTalk Shared Queue databaseParamètres de connexion de SQL Server pour la base de données de files d'attente partagées BizTalk
; Required section used by BTSsetupDB.exe only.Section requise uniquement utilisée par BTSsetupDB.exe.
; Optional if existing server group specified.Facultatif si le groupe de serveurs existant est indiqué.
;
[InterchangeSQ]
Server=localhost
Username=sa
Password=
Database=InterchangeSQ

;----------------------------------------------------------------------
; SQL Server connection parameters for Orchestration databaseParamètres de connexion de SQL Server pour la base de données d'orchestration BizTalk
; Required section used by XLANGsetupDB.exe only.Section requise uniquement utilisée par XLANGsetupDB.exe.
; Specify new or existing Orchestration database.Spécifie la base de données d'orchestration nouvelle ou existante.
;
[Orchestration]
Server=localhost
Database=XLANG

Les propriétés et les valeurs de l'exemple de fichier d'initialisation BizTalkDB.ini sont décrites dans le tableau ci-dessous.

Propriété | Valeur | Description
[InterchangeBTM] Server=BIZTALK Ouvrez une session sur ce premier serveur SQL Server à l'aide du nom d'utilisateur et du mot de passe par défaut.
Database=BizTalkBTMDatabase=BizTalkBTM

Créez cette base de données Gestion d'échanges BizTalk si elle n'existe pas sur le serveur.
[Group] | GroupName=BizTalkServerGroup | Les autres valeurs sont ignorées si ce groupe existe déjà.
[InterchangeDTA] Server=DTA-SERVER Ouvrez une session sur ce deuxième serveur SQL Server à l'aide du nom d'utilisateur et du mot de passe par défaut.
Database=BizTalkDTA Database=BizTalkDTA

Créez cette base de données de suivi si elle n'existe pas sur le serveur.
[InterchangeSQ] Server=SQ-SERVER Ouvrez une session sur ce troisième serveur SQL Server à l'aide du nom d'utilisateur et du mot de passe par défaut.
Database=BizTalkSQ Database=BizTalkSQ

Créez cette base de données de files d'attente partagée si elle n'existe pas sur le serveur.
[Orchestration] Server=localhost Ouvrez une session sur ce quatrième serveur SQL Server à l'aide du nom d'utilisateur et du mot de passe par défaut.
Database=BizTalkXLANGDatabase=BizTalkXLANG

Créez cette base de données de persistance d'orchestration si elle n'existe pas sur le serveur.

Options de ligne de commande de Microsoft Windows Installer

Microsoft Windows Installer (Msiexec.exe) est le programme qui interprète les packages et installe les produits. Il définit également un niveau d'erreur sur retour correspondant aux codes d'erreur Microsoft® Win32®. Le tableau suivant décrit les options de ligne de commande de ce programme que vous pouvez utiliser en plus des propriétés et des valeurs répertoriées ci-avant.

Option | Paramètres | Description
/I | Package|ProductCode | Installe ou configure un produit.
/f [p|o|e|d|c|a|u|m|s|v] Package|ProductCode Répare un produit. Cette option ignore toute valeur de propriété entrée sur la ligne de commande. La liste d'arguments par défaut de cette option est pecms. Cette option partage la même liste d'arguments que la propriété REINSTALLMODE.

p - Procède à la réinstallation uniquement si le fichier est absent.

o - Procède à la réinstallation uniquement si le fichier est absent ou si une version antérieure est installée.

e - Procède à la réinstallation uniquement si le fichier est absent ou si une version équivalente ou antérieure est installée.

d - Procède à la réinstallation si le fichier est absent ou si une version différente est installée.

c - Procède à la réinstallation si le fichier est absent ou si la somme de contrôle stockée ne correspond pas à la valeur calculée. Répare uniquement les fichiers dont la colonne Attributs de la table Fichier contient msidbFileAttributesChecksum.

a - Force la réinstallation de tous les fichiers.

u - Réécrit toutes les entrées de Registre spécifiques à l'utilisateur.

m - Réécrit toutes les entrées de Registre requises spécifiques à l'ordinateur.

s - Remplace tous les raccourcis existants.

v - Exécute à partir de la source et remet en mémoire cache le package local.
/a | Package | Option d'installation administrative. Installe un produit sur le réseau.
/x | Package|ProductCode | Désinstalle un produit.
/j [u|m]Package

ou

[u|m]Package /t Transform List

ou

[u|m]Package /g LanguageID

 Annonce un produit. Cette option ignore toute valeur de propriété entrée sur la ligne de commande.

u - Annonce à l'utilisateur en cours.

m - Annonce à tous les utilisateurs de l'ordinateur.

t - Applique la transformation au package d'installation annoncé.

g - Identificateur de langue.
/L [i|w|e|a|r|u|c|m|o|p|v|+|!]Logfile Indique le chemin d'un fichier journal ; les indicateurs précisent les données à consigner.

i - Messages d'état

w - Avertissements non critiques

e - Tous les messages d'erreur

a - Démarrage des actions

r - Enregistrements spécifiques à certaines actions

u - Requêtes de l'utilisateur

c - Paramètres d'interface utilisateur (UI) initiaux

m - Informations de mémoire insuffisante ou de sortie fatale

o - Messages de disque insuffisant

p - Propriétés du terminal

v - Mode documenté

+ - Ajouter au fichier journal existant

! ! - Forcer l'écriture de chaque ligne dans le fichier journal

"*" - Caractère générique ; enregistrer toutes les informations, à l'exception de l'option v. Pour inclure l'option v, spécifiez "/l*v".
/m filename Génère un fichier .mif d'état SMS (Systems Management Server). Doit être utilisé avec l'option d'installation (-i), de suppression (-x), d'installation administrative (-a) ou de réinstallation (-f). Ismif32.dll est installé dans le cadre de SMS et doit figurer dans le chemin d'accès.

Les champs du fichier .mif d'état sont complétés avec les informations suivantes :

  • Fabricant - Auteur

  • Produit - Numéro de révision

  • Version - Sujet

  • Paramètres régionaux - Modèle

  • Numéro de série - Non défini

  • Installation - Définie par Ismif32.dll sur "DateTime"

  • InstallStatus - "Success" ou "Failed"

  • Description - Messages d'erreur dans l'ordre suivant : 1) Messages d'erreur générés par Installer ; 2) Ressource de Msi.dll si l'installation n'a pas pu démarrer ou si l'utilisateur l'abandonne ; 3) Fichier des messages d'erreur système ; 4) Message mis en forme : "Erreur Installer %i", où %i est l'erreur est renvoyée par Msi.dll.
/p Package correctif Applique un correctif. Pour appliquer un correctif à une image administrative installée, vous devez utiliser les combinaisons d'options suivantes :

/p <PatchPackage> /a <Package>
/q n|b|r|f Définit le niveau d'interface utilisateur (UI).

q , qn - Pas d'interface utilisateur.

qb - Interface utilisateur de base.

qr - Interface utilisateur réduite avec affichage d'une boîte de dialogue modale à la fin de l'installation.

qf - Interface utilisateur intégrale avec affichage d'une boîte de dialogue modale à la fin.

qn+ - Aucune interface utilisateur à l'exception de l'affichage d'une boîte de dialogue modale à la fin.

qb+ - Interface utilisateur de base avec affichage d'une boîte de dialogue modale à la fin. Cette boîte de dialogue ne s'affiche pas si l'utilisateur annule l'installation.

qb- - Interface utilisateur de base sans boîtes de dialogue modales. /qb+- n'est pas un niveau d'interface utilisateur pris en charge.
/?

ou

/h

 Affiche les informations de copyright pour Windows Installer.
/y module y - Appelle le système API DllRegisterServer pour auto-enregistrer les modules passés sur la ligne de commande. Par exemple, msiexec /y my_file.dll.

Cette option est utilisée uniquement pour les informations de Registre qui ne peuvent pas être ajoutées à l'aide des tables de Registre du fichier .msi.
/z module z - Appelle le système API DllUnRegisterServer pour annuler l'enregistrement des modules passés sur la ligne de commande. Par exemple, msiexec /z my_file.dll.

Cette option est utilisée uniquement pour les informations du Registre qui ne peuvent pas être supprimées à l'aide des tables de Registre du fichier .msi.

Remarque

  • Dans le tableau précédent :
    • Les options /i, /x, /f[p|o|e|d|c|a|u|m|s|v], /j[u|m], /a, /p, /y et /z ne doivent pas être utilisées conjointement. Exception à cette règle : la correction d'une installation administrative requiert les options /p et /a.

    • Les options /t et /g ne doivent être utilisées qu'avec /j.

    • Les options /l et /q peuvent être utilisées avec /i, /x, /f[p|o|e|d|c|a|u|m|s|v], /j[u|m], /a et /p.

Règles de syntaxe des propriétés et des valeurs

Seules les propriétés publiques peuvent être modifiées sur la ligne de commande. Tous les noms de propriété de la ligne de commande sont interprétés en majuscules, mais la valeur conserve la distinction entre les majuscules et les minuscules. Si vous tapez MyProperty sur la ligne de commande, le programme Installer remplace la valeur de MYPROPERTY et non celle de MyProperty dans la table des propriétés. Pour installer un produit à l'aide de PROPERTY définie sur VALUE, utilisez la syntaxe suivante sur la ligne de commande. Vous pouvez placer la propriété n'importe où, sauf entre une option et son argument.

Syntaxe correcte :

msiexec /i A:\Example.msi PROPERTY=VALUE

Syntaxe incorrecte :

msiexec /i A:\Example.msi PROPERTY=VALUE

Les valeurs des propriétés qui sont des chaînes littérales doivent être placées entre guillemets. Incluez des espaces dans la chaîne entre ces marques.

msiexec /i A:\Example.msi PROPERTY="Embedded White Space"

Pour supprimer une propriété publique sur la ligne de commande, définissez sa valeur sous forme d'une chaîne vide.

msiexec /i A:\Example.msi PROPERTY=""

Pour les sections de texte définies séparément à l'aide de guillemets littéraux, placez la section dans une seconde paire de guillemets.

msiexec /i A:\Example.msi PROPERTY="Embedded ""Quotes"" White Space"

Voici un exemple de ligne de commande complexe.

msiexec /i testdb.msi INSTALLLEVEL=3 /l* msi.log COMPANYNAME="Acme ""Widgets"" and ""Gizmos."""

L'exemple suivant illustre les options d'annonce. Les commutateurs ne font pas la distinction entre les majuscules et les minuscules.

msiexec /JM msisample.msi /T transform.mst /G langid /LIME logfile.txt

Pour plus d'informations sur Microsoft Windows Installer, accédez au site Web Microsoft® MSDN® (microsoft.com/france/msdn/telecharge/).


Suppression de BizTalk Server 2002

Pour supprimer Microsoft BizTalk Server 2002, utilisez l'utilitaire Ajout/Suppression de programme de Microsoft Windows 2000.

Remarques

  • Le processus de désinstallation de BizTalk Server ne supprime pas les bases de données SQL ou les mappages et les schémas qui ont été stockés dans WebDAV. Tout fichier ayant été ajouté dans le répertoire de BizTalk Server est également préservé.

  • Dans un environnement de clusters, avant de procéder à la désinstallation de BizTalk Server 2002, vérifiez que l'ordinateur dispose d'une connexion réseau pour accéder à l'ordinateur hébergeant les bases de données BizTalk Server et à tous les autres serveurs BizTalk du groupe. Si des erreurs se produisent lors de la désinstallation, vous devrez peut-être supprimer manuellement les applications COM+ suivantes :
    • BizTalk Server Interchange

    • Utilitaires BizTalk Server internes

    • XLANG Scheduler

    • Programme d'assistance XLANG

Suppression de BizTalk Server 2002

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Cliquez sur Ajout/Suppression de programmes.

    La boîte de dialogue Ajout/Suppression de programmes apparaît.

  3. Cliquez sur Microsoft BizTalk Server 2002 et cliquez sur Supprimer.

  4. Suivez les instructions à l'écran et cliquez sur Oui lorsque vous êtes invité à supprimer BizTalk Server 2002.


Présentation de la sécurité

Microsoft® BizTalk Server 2002 permet aux entreprises d'échanger des données en toute sécurité avec leurs partenaires commerciaux, grâce aux fonctionnalités de sécurité offertes par Microsoft Windows® 2000.

Les fonctions de sécurité de Windows 2000 utilisées par BizTalk Server sont les suivantes :

  • Sécurité et stratégies locales du compte Windows

  • Sécurité d'ouverture de session intégrée avec Windows et Microsoft SQL Server™

  • Sécurité et rôles des Services de composants Microsoft

  • Infrastructure de clés publiques

  • CryptoAPI

  • Cartes à puce

  • Protocole Kerberos

BizTalk Server contrôle l'accès aux outils (tels que la console Administration de BizTalk Server), aux API (par exemple, WMI (Windows Management Instrumentation)), aux applications COM+ et à d'autres ressources en attribuant l'accès à ces ressources à des comptes d'utilisateur spécifiques. Une des méthodes d'attribution des privilèges aux comptes d'utilisateur consiste à ajouter ces comptes aux groupes Windows créés par BizTalk Server. Lorsque BizTalk Server est installé, il crée deux groupes Windows locaux : Le groupe Administrateurs de BizTalk Server et le groupe Utilisateurs d'états de BizTalk Server. L'ajout de comptes d'utilisateur à ces groupes sur les ordinateurs BizTalk Server permet d'accorder à ces comptes certains privilèges sur BizTalk Server. Par exemple, il est nécessaire d'être connecté avec un compte appartenant au groupe Administrateurs de BizTalk Server pour ouvrir le Gestionnaire d'échanges BizTalk ou la console Administration de BizTalk Server sur cet ordinateur.

En outre, des autorisations spécifiques peuvent être requises au niveau du système d'exploitation pour effectuer certaines tâches. Par exemple, vous devez accorder au compte de service d'échanges BizTalk Server tous les privilèges sur l'espace de noms WMI (Windows Management Instrumentation) de BizTalk Server afin qu'il génère des événements WMI dans la file d'attente interrompue.

BizTalk Server contrôle l'accès à SQL Server en exploitant la sécurité intégrée à SQL Server. Grâce à la sécurité intégrée à SQL Server, SQL Server dépend de l'authentification Windows pour accorder l'accès aux ressources SQL. Par défaut, tous les comptes ayant besoin d'accéder à l'une des bases de données SQL Server requises par BizTalk Server doivent être affectés d'une connexion intégrée à SQL Server et d'un accès aux bases de données. Pour plus d'informations, voir Interactions entre les bases de données SQL Server et BizTalk Server 2002 . À l'exception des connexions à la base de données de persistance d'orchestration, l'accès aux bases de données à l'aide des outils et des services d'exécution de BizTalk Server ne peut pas être configuré pour utiliser autre chose que la sécurité intégrée.

Les services de composant, l'un des outils d'administration de Windows 2000, offrent toutes les fonctionnalités de composant, telles que la prise en charge des transactions automatiques pour la protection de l'intégrité des données ainsi qu'une sécurité simple mais puissante qui repose sur les rôles.

BizTalk Server contrôle la sécurité entre les partenaires commerciaux grâce aux infrastructures de clés publiques et au cryptage S/MIME (Secure Multipurpose Internet Mail Extensions). En échangeant des certificats de clés publiques et privées, les partenaires commerciaux peuvent s'authentifier mutuellement et crypter leurs communications en utilisant les messages à signature numérique x.509 et le format S/MIME (ou le cryptage personnalisé avec leurs propres composants). Pour plus d'informations, voir Description des certificats.

Dans la mesure où BizTalk Server bénéficie de la fonction de sécurité SSL (Secure Sockets Layer) de Windows 2000, des pages Web peuvent être créées puis utilisées par les partenaires commerciaux pour échanger des données de manière sécurisée via Internet. Le protocole SSL, implémenté dans les services IIS (Internet Information Services), permet de garantir la confidentialité entre un client Web et un serveur Web. Le protocole débute avec une phase d'authentification qui négocie un algorithme de cryptage, vérifie les clés (publiques et privées) et authentifie le serveur pour le client. Une fois que le protocole d'authentification est terminé et que la transmission des données débute, toutes les données sont cryptées par le biais des clés de session négociées durant le protocole d'authentification. Grâce à la prise en charge des standards de type « open PKI » (infrastructure de clés publiques) et des protocoles sécurisés, tels que IPSec, L2TP, SSL/TLS et S/MIME, un réseau peut être rapidement étendu aux fournisseurs et aux partenaires, tout en garantissant une protection contre les imposteurs, le vol de données et les intrus malveillants.

Cette section traite des rubriques suivantes :

  • Propriétés de connexion

  • Stratégies locales

  • Instructions relatives à la sécurité

  • Groupe Administrateurs de BizTalk Server

  • Service d'échanges BizTalk

  • Sécurité de l'application Échange BizTalk Server

  • Sécurité des applications hébergeant des instances de planification XLANG

  • Groupe Utilisateurs d'états de BizTalk Server

  • Services de transport

  • Description des certificats

  • CryptoAPI

  • CDO (Collaborative Data Objects)

  • Configuration de pare-feu

Voir aussi

Privilèges d'administration


Propriétés de connexion

Les propriétés de connexion constituent le premier niveau de sécurité de BizTalk Server 2002. Ces propriétés contrôlent la capacité d'un utilisateur à se connecter à un ordinateur ou un domaine spécifique et à effectuer des tâches spécifiques sur cet ordinateur ou ce domaine. Vous devez fournir un nom d'utilisateur et un mot de passe avant d'accéder aux ressources, telles qu'un partage de fichiers ou une file d'attente de messages. Les messages reçus par le biais de HTTP et SMTP utilisent également des propriétés de connexion pour garantir la sécurité. Par exemple, si vous accédez à une page ASP via HTTP, vous devez entrer un nom d'utilisateur et un mot de passe pour être en mesure d'afficher le contenu de la page Web.

BizTalk Server utilise les services ISS (Internet Information Services) et les pages ASP pour recevoir les documents. Les pages ASP, ou plus exactement le code situé derrière ces pages, offrent une sécurité à BizTalk Server grâce à la vérification des signatures depuis SSL (Secure Sockets Layer) et à l'optimisation des options de sécurité supplémentaires, telles que les certificats, par le biais de IIS. Pour plus d'informations sur la sécurité IIS, reportez-vous à Internet Information Services dans l'aide de Windows 2000.

Voir aussi

Privilèges d'administration


Stratégies locales

Les stratégies locales, qui font partie de la console des paramètres de sécurité locaux, déterminent les options de sécurité d'un utilisateur ou d'un compte de services. Les stratégies locales sont fonction de l'ordinateur sur lequel vous avez ouvert une session et des droits dont vous bénéficiez sur cet ordinateur. Pour définir des stratégies locales, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Stratégie de sécurité locale, puis développez le dossier Stratégies locales.

Les stratégies locales définissent les autorisations et les droits des utilisateurs de BizTalk Server 2002. Les stratégies locales peuvent être utilisées pour configurer les éléments suivants :

  • Stratégie d'audit : détermine quels événements de sécurité sont consignés dans le fichier journal de l'ordinateur (les tentatives réussies, les tentatives échouées, ou les deux). (Le journal de sécurité fait partie de l'Observateur d'événements.)

  • Attribution des droits utilisateur : détermine quels utilisateurs ou groupes possèdent des privilèges d'ouverture de session ou d'exécution de tâches sur l'ordinateur.

  • Options de sécurité : active ou désactive les paramètres de sécurité pour l'ordinateur, tels que la signature numérique des données, les noms des comptes Administrateur et Invités, l'accès aux lecteurs de disquettes et de CD-ROM, l'installation des pilotes et les invites de commandes.

D'autres stratégies dans la console des paramètres de sécurité locaux peuvent être configurées pour préserver l'intégrité de vos données. Par exemple, les stratégies de comptes peuvent être utilisées pour configurer les éléments suivants :

  • Stratégie de mot de passe détermine des paramètres des mots de passe, tels que la vérification et les durées de vie, pour les comptes d'utilisateur local.

  • Stratégie de verrouillage du compte : détermine quand et pour qui un compte sera verrouillé hors du système pour les comptes d'utilisateur local.

Important

  • Les stratégies locales sont, par définition, locales sur un ordinateur. Une fois que ces paramètres sont importés dans un objet Stratégie de groupe dans Active Directory, ils affectent les paramètres de sécurité locale de tous les comptes d'ordinateur auxquels cet objet Stratégie de groupe est appliqué. Par conséquent, il est important de noter la priorité des stratégies de sécurité. Les stratégies de sécurité associées à la stratégie de groupe (unités d'organisation) remplacent les stratégies établies au niveau local. Les stratégies du domaine remplacent les stratégies définies localement. Dans les deux cas, les droits de votre compte d'utilisateur peuvent ne plus s'appliquer si un paramètre de stratégie locale est prioritaire par rapport à ces privilèges. Ceci est important car il existe d'importantes différences entre Microsoft Windows 2000 et Microsoft Windows NT. Par exemple, lorsque les stratégies de mot de passe sont configurées pour la stratégie de groupe Domaine (configuration par défaut), elles affectent chaque ordinateur appartenant à ce domaine. Par conséquent, les bases de données de compte local (sur les stations de travail individuelles) dans le domaine ont la même stratégie de mot de passe que le domaine proprement dit.

Remarque

  • Ne définissez pas les stratégies locales pour les clés publiques. Les clés publiques fournissent une protection en termes de sécurité pour BizTalk Server. Elles constituent un composant des certificats qui sont utilisés pour crypter et décrypter les données. Lorsque vous ajoutez des stratégies supplémentaires dans une clé publique, BizTalk Server n'est pas en mesure d'utiliser les certificats associés.

Voir aussi

Privilèges d'administration


Instructions relatives à la sécurité

Plutôt que d'utiliser les informations d'authentification de SQL Server, BizTalk Server 2002 fait appel à la sécurité intégrée de Windows NT pour accéder à SQL Server. Ceci signifie que BizTalk Server utilise les informations d'authentification de l'utilisateur actuellement connecté pour déterminer les privilèges SQL Server. C'est la raison pour laquelle, lors de l'installation et de la configuration des composants d'administration de BizTalk Server, il est nécessaire de prendre en considération un certain nombre de points de sécurité. Ces derniers sont répertoriés dans le tableau suivant :

Fonctionnalité de BizTalk Server | Instructions relatives à la sécurité
Administration de BizTalk Server
  • Les utilisateurs doivent être membres du groupe Administrateurs de BizTalk Server. Pour plus d'informations, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.

  • Les utilisateurs doivent bénéficier de l'accès complet aux bases de données de files d'attente partagées et de Gestion d'échanges BizTalk et être membres du rôle db_owner pour ces bases de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.
Gestionnaire d'échanges BizTalk
  • Les utilisateurs doivent être membres du groupe Administrateurs de BizTalk Server. Pour plus d'informations, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.

  • Les utilisateurs doivent bénéficier de l'accès complet aux bases de données de files d'attente partagées et Gestion d'échanges BizTalk et être membres du rôle db_owner pour ces bases de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.
Modèle d'objets de configuration d'échanges BizTalk
  • Les utilisateurs doivent être membres du groupe Administrateurs de BizTalk Server. Pour plus d'informations, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.

  • Les utilisateurs doivent bénéficier d'un accès complet aux bases de données de files d'attente partagées et Gestion d'échanges BizTalk et être membres du rôle db_owner pour ces bases de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.
Service d'échanges BizTalk
  • Le compte de service d'échanges BizTalk Server doit être affecté des stratégies de sécurité Connexion en tant que service.

  • Le compte de service d'échanges BizTalk Server doit bénéficier de toutes les autorisations sur l'espace de noms WMI (Windows Management Instrumentation) Root\MicrosoftBizTalkServer. Pour plus d'informations, voir Attribution des autorisations d'espace de noms WMI à un compte Windows.

  • Les utilisateurs doivent bénéficier de l'accès complet aux bases de données de files d'attente partagées, de suivi et Gestion d'échanges BizTalk et être membres du rôle db_owner pour ces bases de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.

  • Si un nom d'utilisateur/mot de passe est spécifié pour une fonction de réception, les stratégies de sécurité Connexion locale et Agir en tant que partie du système d'exploitation doivent être attribuées au compte d'utilisateur de la fonction de réception.

  • Si une ou plusieurs fonctions de réception HTTP ont été crées, les extensions ISAP BizTalk associées requièrent une configuration de sécurité supplémentaire. Pour plus d'informations, voir Configuration des privilèges d'accès selon le niveau de protection IIS.
Application Échange BizTalk Server (COM+)
  • Le compte d'identité de l'application doit bénéficier de toutes les autorisations sur l'espace de noms WMI Root\MicrosoftBizTalkServer. Pour plus d'informations, voir Attribution des autorisations d'espace de noms WMI à un compte Windows.

  • Le compte d'identité de l'application doit bénéficier de l'accès complet aux bases de données de files d'attente partagées, de suivi et Gestion d'échanges BizTalk et être membre du rôle db_owner pour ces bases de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'accès aux bases de données.
Interface utilisateur du Suivi de documents BizTalk
  • Le compte d'utilisateur doit bénéficier de l'accès complet à la base de données de suivi et être membre du rôle db_owner pour cette base de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.

  • Les utilisateurs doivent être membres du groupe Utilisateurs d'états de BizTalk Server.
Application XLANG Scheduler (COM+)
  • Si le nom de la source des données (DSN) est configuré pour accéder à la base de données de persistance d'orchestration est configuré avec l'authentification Windows (comme c'est le cas par défaut), les informations d'identification de l'utilisateur qui interagit avec une instance de planification XLANG doit bénéficier de l'accès complet à la base de données de persistance d'orchestration et être membre du rôle db_owner pour cette base de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.

  • Si le nom de la source des données est configuré avec l'authentification SQL, la connexion SQL utilisée doit bénéficier de l'accès complet à la base de données de persistance d'orchestration et être membre du rôle db_owner pour cette base de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.

  • L'utilisateur qui interagit avec une instance de planification XLANG doit être membre du rôle Utilisateur de la planification XLANG sous la configuration COM+ de cette application BizTalk XLANG Scheduler. Pour plus d'informations, voir Sécurité des applications hébergeant des instances de planification XLANG
Assistant BizTalk SEED
  • Les utilisateurs doivent être membres du groupe Administrateurs de BizTalk Server. Pour plus d'informations, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.

  • Les utilisateurs doivent bénéficier de l'accès complet à la base de données Gestion d'échanges BizTalk et être membres du rôle db_owner pour cette base de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.
Déploiement de BizTalk à l'aide de Microsoft Application Center 2000
  • Les utilisateurs doivent être membres du groupe Administrateurs de BizTalk Server. Pour plus d'informations, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.

  • Les utilisateurs doivent bénéficier de l'accès complet à la base de données Gestion d'échanges BizTalk et être membres du rôle db_owner pour cette base de données. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.
Observateur XLANG
  • Les utilisateurs doivent être membres du rôle Créateur de planifications XLANG pour la planification XLANG et pour les applications COM+ qui hébergent les planifications XLANG. Pour plus d'informations, voir Ajout d'un rôle à l'application Échange BizTalk Server ; mais, si vous exécutez cette procédure, vous devez remplacer l'application Échange par l'application COM+ qui héberge les planifications XLANG.
Concepteur d'applications | Aucune contrainte de sécurité n'est requise.
Éditeur BizTalk et Mappeur BizTalk | Aucune contrainte de sécurité n'est requise.

Cette section traite des procédures suivantes :

  • Création d'une connexion SQL et attribution d'un accès aux bases de données

  • Attribution des autorisations d'espace de noms WMI à un compte Windows


Création d'une connexion SQL et attribution d'un accès aux bases de données

Afin qu'un compte utilisé par BizTalk Server puisse accéder aux bases de données SQL Server, il est nécessaire d'attribuer de manière explicite un accès à ce compte.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, ainsi que le serveur contenant les bases de données Gestion d'échanges BizTalk et Files d'attentes partagées.

  3. Développez le dossier Sécurité, cliquez avec le bouton droit sur Connexion, puis cliquez sur Nouvelle connexion.

    La page Propriétés de la connexion SQL Server - Nouvelle connexion s'affiche.

  4. Dans la zone Nom, entrez le nom du compte Windows pour lequel vous voulez créer une connexion SQL.

  5. Dans la zone Authentification, assurez-vous que Authentification Windows est sélectionné, et entrez le domaine du compte Windows. Cliquez sur OK.

  6. Cliquez sur l'onglet Accès à la base de données, activez la case Autoriser correspondant à la base de données pour laquelle vous souhaitez modifier les autorisations, puis sélectionnez db_owner dans la liste Autoriser dans le rôle de base de données.

  7. Activez la case Autoriser correspondant à la base de données File d'attente partagée, sélectionnez db_owner dans la liste Autoriser dans le rôle de base de données, puis cliquez sur OK.


Attribution des autorisations d'espace de noms WMI à un compte Windows

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Gestion de l'ordinateur.

    La console Gestion de l'ordinateur s'affiche.

  2. Développez Services et applications, cliquez avec le bouton droit sur Contrôle WMI, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de Contrôle WMI s'affiche.

  3. Cliquez sur l'onglet Sécurité, double-cliquez sur le nœud Root, puis cliquez sur l'espace de noms MicrosoftBizTalkServer.

  4. Cliquez sur le bouton Sécurité.

    La boîte de dialogue Sécurité pour ROOT\MicrosoftBizTalkServer s'affiche.

  5. Cliquez sur le bouton Ajouter.

    La boîte de dialogue Sélectionnez Utilisateurs ou Groupes apparaît.

  6. Tapez le nom du compte Windows auquel vous voulez attribuer des autorisations d'espace de noms WMI et cliquez sur OK.

  7. Assurez-vous que les Autorisations sont activées comme Autoriser.

  8. Cliquez sur OK.

  9. Cliquez sur OK pour fermer la boîte de dialogue Propriétés de Contrôle WMI.


Groupe Administrateurs de BizTalk Server

Au cours de l'installation, BizTalk Server 2002 crée un groupe Windows sur l'ordinateur local dont les membres sont gratifiés des accès administratifs et autres privilèges sur BizTalk Server. Par défaut, ce groupe est intitulé Administrateurs de BizTalk Server, bien que l'utilisateur qui exécute le programme d'installation soit autorisé à le renommer. En revanche, il est impossible de le changer après l'installation. Lors de l'installation, BizTalk Server ajoute le groupe Administrateurs local intégré et le compte d'utilisateur actuellement connecté à ce groupe.

L'objectif principal du groupe Administrateurs de BizTalk Server est de contrôler l'accès aux outils et interfaces de programmation d'application (API) fournis par BizTalk Server. Pour déterminer quelles sont les ressources exigeant que les utilisateurs soient membres de ce groupe, voir Instructions relatives à la sécurité.

Remarque

  • Le compte de service sous lequel le service d'échanges BizTalk s'exécute n'a pas besoin d'être membre de ce groupe pour que BizTalk Server fonctionne correctement.


Service d'échanges BizTalk

Le service d'échanges BizTalk est un service Windows qui fournit toutes les fonctionnalités d'exécution des échanges BizTalk. En tant que service Windows, le service d'échanges BizTalk s'exécute dans son propre contexte de sécurité, comme Système local ou comme un compte de service créé par l'utilisateur et appelé le compte de service d'échanges BizTalk Server. Un compte de service est un compte d'utilisateur Windows qui est doté des privilèges spéciaux Agir en tant que partie du système d'exploitation et Connexion en tant que service. Au cours de l'installation, BizTalk Server accorde ces privilèges au compte spécifié par l'utilisateur pour le compte de service d'échanges BizTalk Server. Pour plus d'informations, voir Instructions d'installation.

Les deux raisons pour lesquelles il est préférable d'utiliser le compte Système local plutôt qu'un compte Windows local ou un compte de service de domaine dépend en partie des deux facteurs suivants :

  1. De la topologie de SQL Server. En effet, le compte de service d'échanges BizTalk Server doit bénéficier de l'accès aux bases de données SQL Server utilisées par BizTalk Server afin de fonctionner. Or, si vous exécutez BizTalk Server sur le même ordinateur que les bases de données SQL Server utilisées par BizTalk Server, n'importe quel compte peut être utilisé. En revanche, si vous utilisez un serveur SQL Server situé sur un autre ordinateur que celui sur lequel BizTalk Server s'exécute, il est beaucoup plus judicieux d'utiliser un compte de domaine Windows pour le compte de service d'échanges BizTalk Server. Ainsi, en configurant BizTalk Server de sorte qu'il utilise le même compte de domaine, l'attribution de l'accès de tous les serveurs BizTalk Server à SQL Server s'effectue en une seule étape qui consiste à attribuer l'accès à ce compte de domaine unique.

  2. De l'utilisation des certificats numériques. Si vous avez l'intention d'utiliser la signature numérique et les fonctionnalités de cryptage et de décryptage de BizTalk Server, le compte de service d'échanges BizTalk Server doit être membre du groupe intégré local Administrateurs Windows. Ceci est nécessaire afin de pouvoir accéder aux magasins de certificats numériques sur l'ordinateur local.

Remarque

  • Il n'est pas nécessaire que le compte de service d'échanges BizTalk Server soit membre du groupe Administrateurs de BizTalk Server pour que BizTalk Server fonctionne correctement.


Sécurité de l'application Échange BizTalk Server

L'interface COM+ utilisée pour soumettre par programme des documents à BizTalk Server 2002 réside dans une application COM+ créée par BizTalk Server au cours de l'installation et appelée l'application Échange BizTalk Server. Par défaut, l'identité de cette application est configurée en tant qu'Utilisateur interactif. Toutefois, si ce n'est pas modifié, un utilisateur doit être connecté à chaque fois que des envois par programme sont effectués. Bien évidemment, ceci n'est pas acceptable pour un bon nombre de raisons. Pour configurer l'application Échange BizTalk Server afin qu'elle s'exécute sous un compte de service, voir Modification de l'identité d'une application COM+.

Le contrôle de la capacité d'un utilisateur à envoyer par programme des opérations à BizTalk Server via l'interface COM+ IInterchange peut s'effectuer en configurant correctement le composant COM+ Application Échange BizTalk Server. Pour contrôler la capacité d'un utilisateur à envoyer par programme des opérations, un rôle doit d'abord être ajouté à l'application Échange BizTalk Server, puis ce rôle doit être associé aux méthodes Submit et SubmitSync et, enfin, le compte d'utilisateur auquel vous voulez attribuer l'accès aux méthodes doit être ajouté au rôle.

Cette section traite des rubriques suivantes :

  • Ajout d'un rôle à l'application Échange BizTalk Server

  • Association d'un nouveau rôle aux méthodes Submit et SubmitSync

Voir aussi

Privilèges d'administration


Ajout d'un rôle à l'application Échange BizTalk Server

Il est nécessaire de créer l'appartenance à des rôles pour contrôler la capacité de différents utilisateurs à envoyer des opérations à l'application Échange BizTalk Server.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

    La console Services de composants s'affiche.

  2. Développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez avec le bouton droit sur Application Échange BizTalk Server, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'application Échange BizTalk Server s'affiche.

  4. Cliquez sur l'onglet Avancé, désactivez la case à cocher Désactiver les modifications dans la zone Autorisation, cliquez sur OK puis, dans la boîte de dialogue de messages, cliquez sur Oui.

  5. Répétez l'étape 3.

  6. Cliquez sur l'onglet Sécurité, puis activez la case à cocher Appliquer les vérifications d'accès pour cette application dans la zone Autorisation.

  7. Dans la zone Niveau de sécurité, cliquez sur Effectuer les vérifications d'accès au niveau du processus et des composants. La propriété de sécurité sera incluse dans le contexte de l'objet. L'appel de sécurité COM+ est disponible.

  8. Cliquez sur OK.

  9. Dans la boîte de dialogue de confirmation, cliquez sur Oui.

  10. Développez Application Échange BizTalk Server.

  11. Double-cliquez sur le dossier Rôles, cliquez avec le bouton droit sur le dossier, pointez sur Nouveau, puis cliquez sur Rôle.

    La boîte de dialogue Rôle s'affiche.

  12. Entrez le nom du rôle, puis cliquez sur OK.

  13. Dans la boîte de dialogue de confirmation, cliquez sur Oui.

  14. Développez le rôle que vous avez créé, double-cliquez sur le dossier Utilisateurs, cliquez avec le bouton droit sur Utilisateurs, pointez sur Nouveau, puis cliquez sur Utilisateur.

  15. Dans la zone Sélectionnez Utilisateurs ou Groupes, entrez le nom complet de l'utilisateur que vous voulez ajouter.

  16. Lorsque vous avez ajouté les comptes d'utilisateur au rôle, cliquez sur OK.

Remarque

  • Pour chaque compte d'utilisateur ou groupe affecté au rôle, une icône apparaît dans le dossier Utilisateurs. L'appartenance au nouveau rôle est activée lorsque l'application démarre.

Voir aussi

Arrêt de l'application Échange BizTalk Server


Association d'un nouveau rôle aux méthodes Submit et SubmitSync

Dès qu'un nouveau rôle pour l'application Échange BizTalk Server est créé, vous pouvez y associer les méthodes Submit et SubmitSync.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

    La console Services de composants s'affiche.

  2. Développez Services de composant, Ordinateurs, Poste de travail, Applications COM+, Application Échange BizTalk Server, Composants, BizTalk.Interchange.1, Interfaces, IInterchange et Méthodes.

  3. Cliquez avec le bouton droit sur Submit, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de Submit s'affiche.

  4. Cliquez sur l'onglet Sécurité.

  5. Dans la zone Rôles explicitement définis pour les éléments sélectionnés, activez la case à cocher correspondant au rôle créé dans la procédure Ajout d'un rôle à l'application Échange BizTalk Server et cliquez sur OK.

  6. Cliquez avec le bouton droit sur SubmitSync, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de SubmitSync s'affiche.

  7. Cliquez sur l'onglet Sécurité.

  8. Dans la zone Rôles explicitement définis pour les éléments sélectionnés, activez la case à cocher correspondant au rôle créé dans la procédure Ajout d'un rôle à l'application Échange BizTalk Server et cliquez sur OK.

Voir aussi

Arrêt de l'application Échange BizTalk Server


Sécurité des applications hébergeant des instances de planification XLANG

Une fois que vous avez installé les services d'orchestration BizTalk, vous pouvez définir des niveaux de sécurité pour les éléments suivants :

  • Création de nouvelles instances de planification XLANG

  • Interaction avec les instances de planification XLANG existantes

  • Fonctions d'administration liées aux instances de planification XLANG

  • Applications hébergeant des instances de planification XLANG

Les applications qui hébergent des instances de planification XLANG s'appuient sur la sécurité liée aux rôles, laquelle constitue un service automatique fourni par COM+. La sécurité liée aux rôles permet aux utilisateurs de créer et de renforcer une stratégie de contrôle d'accès pour les applications COM+. Grâce à un modèle de configuration souple et modulable, la sécurité liée aux rôles est beaucoup plus avantageuse que la mise en œuvre de l'intégralité de la sécurité au sein des composants. Il existe deux applications COM+ par défaut, XLANG Scheduler et le programme d'assistance XLANG Scheduler Persistence Helper ; elles sont automatiquement créées lorsque les services d'orchestration BizTalk sont installés. Par défaut, l'identité de ces applications est configurée en tant qu'Utilisateur interactif. Toutefois, si ce n'est pas modifié, un utilisateur doit être connecté à chaque fois que des planifications sont appelées ou accédées. Bien évidemment, ceci est inacceptable pour bon nombre de raisons. Pour configurer l'application Échange BizTalk Server afin qu'elle s'exécute sous un compte de service, voir Modification de l'identité d'une application COM+.

L'application XLANG Scheduler COM+ comporte quatre rôles qui permettent d'assurer la sécurité des instances de planification, indépendamment de l'application COM+ dans laquelle ils sont exécutés. Ces quatre rôles sont les suivants :

  • Créateur de planification XLANG : ce rôle permet aux utilisateurs spécifiés de créer des instances de planification XLANG. Par exemple, si un administrateur souhaite qu'un utilisateur soit en mesure de créer une instance de planification XLANG, il doit ajouter cet utilisateur à la liste des membres de ce rôle. Si un utilisateur non-membre de ce rôle tente de créer une instance de planification XLANG, un message d'erreur l'avertit que l'accès lui est refusé. En outre, une entrée est générée dans le journal des événements, indiquant que l'accès est refusé.

  • Utilisateur de planification XLANG : ce rôle permet aux utilisateurs spécifiés d'interagir avec les instances de planification XLANG. Par exemple, si un administrateur souhaite qu'un utilisateur soit en mesure d'interagir avec une instance de planification, il doit ajouter cet utilisateur à la liste de membres de ce rôle. Si un utilisateur non-membre de ce rôle tente d'interagir avec une instance de planification, un message d'erreur l'avertit que l'accès lui est refusé. En outre, une entrée est générée dans le journal des événements, indiquant que l'accès est refusé.

  • Administrateur de XLANG Scheduler : ce rôle peut être utilisé pour spécifier quels utilisateurs disposent de droits d'administration pour les opérations suivantes :
    • Déterminer si une application COM+ est en mesure d'agir en tant qu'hôte pour les instances de planification XLANG.

    • Définir le type DSN d'une application COM+ hébergeant des instances de planification XLANG et définir la valeur de gestion de l'état correspondant au niveau de persistance que l'application COM+ doit prendre en charge.

    • Fermer toutes les instances de planifications XLANG.

    • Suspendre, reprendre ou mettre fin à une instance de planification XLANG.
  • Application XLANG Scheduler : ce rôle est utilisé par l'application XLANG Scheduler pour interagir avec les applications COM+ créées par un utilisateur. Par conséquent, l'identité du rôle doit être la même que celle utilisée par l'application COM+ pour l'exécution.

Cette section traite des rubriques suivantes :

  • Méthodes optimales pour la sécurisation des applications COM+

  • Sécurisation de la base de données de persistance d'orchestration

  • Confirmation de l'identité de l'expéditeur

Voir aussi

Planifications XLANG


Méthodes optimales pour la sécurisation des applications COM+

Grâce aux rôles, un administrateur peut construire une stratégie en fonction des droits d'administration pour une application, en choisissant (jusqu'au niveau de la méthode, si besoin est) les droits d'accès des différents utilisateurs aux différentes ressources. Dans la mesure où toutes les planifications XLANG sont hébergées dans des applications serveur COM+, il est possible de configurer les propriétés de la sécurité des différents rôles afin de limiter l'accès aux objets COM installés.

Important

  • Si les propriétés de la sécurité sont ajoutées au niveau des composants, les méthodes, les interfaces et les composants individuels basés sur les paramètres des rôles à ces niveaux sont également limités. Pour plus d'informations sur la sécurité COM+, accédez au site Web de la bibliothèque en ligne MSDN (msdn.microsoft.com/library/default.asp), puis consultez la page traitant de la sécurité dans les applications COM+.

Recommandations pour la sécurité des applications COM+

Les recommandations suivantes s'appliquent principalement à la sécurisation des applications déployées :

  • Ne pas configurer une application COM+ en tant qu'utilisateur interactif : les applications COM+ qui utilisent l'identité d'utilisateur interactif peuvent être utilisées uniquement si un utilisateur est connecté à l'ordinateur sur lequel réside l'application. Si aucun utilisateur n'est connecté, l'application COM+ ne peut pas être exécutée. De plus, si un utilisateur crée une application COM+ avec un utilisateur interactif, il sera plus difficile de configurer l'accès à sa base de données de persistance et aux autres ressources.

  • Reconfigurer l'identité de XLANG Scheduler : lors de l'installation, l'identité de XLANG Scheduler est automatiquement configurée en tant qu'utilisateur interactif. Cette configuration convient à la plupart des développeurs. Sur les systèmes de production, vous devez changer la propriété de l'identité de XLANG Scheduler pour que l'application s'exécute uniquement sous un compte d'utilisateur unique. L'identité est utilisée par tous les messages envoyés par l'application XLANG Scheduler.

    Remarque

    • Lorsque vous utilisez le client pour les services Terminal Server Microsoft Windows 2000 afin d'initier une planification XLANG, l'identité de l'application COM+ hébergeant le moteur de XLANG Scheduler doit correspondre à un nom d'utilisateur ou de groupe Windows 2000 valide. L'identité de l'application COM+ est définie dans l'onglet Identité de la boîte de dialogue des propriétés de cette application. L'identité ne peut être interactive lorsque vous utilisez le moteur de XLANG Scheduler dans une session hébergée par les services Terminal Server.
  • Créer une nouvelle application COM+ avec une identité unique pour chaque application hébergeant des instances de planification XLANG : créez une application COM+ qui comporte une identité unique pour chaque traitement professionnel (tel que l'achat) ainsi que des spécifications de sécurité uniques. Ainsi, le niveau de sécurité peut être spécifié séparément pour chaque application. De plus, les dommages pouvant découler des codes d'application non stables sont minimisés, et il est plus facile d'effectuer un audit des opérations des applications séparément.

  • Installer des composants propres aux applications dans leurs traitements professionnels associés : les données sont protégées et les applications qui n'ont pas accès à ces composants sont exclues, à condition que le serveur d'applications soit protégé correctement.

    Remarque

    • Chaque application COM+ doit contenir au minimum un composant. Si un composant propre à une application n'est pas installé, un composant fictif doit être créé et installé dans l'application, sinon l'application COM+ ne sera pas disponible.
  • Modifier les paramètres par défaut de la liste des membres des rôles de XLANG Scheduler afin d'offrir une sécurité renforcée : lors de l'installation de BizTalk Server, l'application XLANG Scheduler est créée et configurée avec les rôles suivants et les paramètres par défaut correspondants :
    • Créateur de planification XLANG : l'appartenance au rôle correspond par défaut à Tout le monde.

    • Utilisateur de planification XLANG : l'appartenance au rôle correspond par défaut à Tout le monde.

    • Administrateur de XLANG Scheduler : l'appartenance au rôle correspond par défaut à Administrateurs.

    • Application XLANG Scheduler : l'appartenance au rôle correspond par défaut à Tout le monde.

Voir aussi

Modification de l'identité de l'application XLANG Scheduler par défaut

Création d'une application COM+ pour héberger des planifications XLANG

Planifications XLANG


Sécurisation de la base de données de persistance d'orchestration

Lorsqu'une application COM+ hébergeant des instances de planification XLANG est créée, une base de données de persistance doit être associée à l'application COM+. Vous devez donc créer en premier lieu une base de données de persistance dans Microsoft SQL Server. Après la création de la base de données, si le nom de la source des données (DSN) de la base de données de l'application XLANG COM+ est configurée pour utiliser la sécurité intégrée, un utilisateur doit créer une connexion SQL et attribuer les privilèges db_owner au compte d'identité de l'application COM+ qui sera créée ultérieurement afin d'héberger les instances de planification XLANG. Assurez-vous que l'application COM+ dispose d'autorisations pour créer des tables et des procédures dans la base de données de persistance associée. Par défaut, l'interaction entre les services d'orchestration BizTalk et la base de données de persistance d'orchestration BizTalk Server par défaut repose sur le modèle de sécurité Windows 2000 plutôt que sur le modèle SQL Server.

Voir aussi

Gestion de l'application XLANG Scheduler par défaut


Confirmation de l'identité de l'expéditeur

Lors de la conception de la planification, différentes formes peuvent être utilisées pour décrire les technologies d'implémentation permettant d'implémenter un port dans un traitement professionnel. Les formes suivantes décrivent ces technologies :

  • La forme Composant COM représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu.

  • La forme Composant de script représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu.

  • La forme Message Queuing représente une technologie pouvant être utilisée pour implémenter un port. Les services de transport Message Queuing permettent d'envoyer ou de recevoir des messages.

Lorsque vous ajoutez l'une de ces trois technologies, vous pouvez exiger que l'identité de l'expéditeur soit confirmée avant la réception des messages. Lorsque l'identité de l'expéditeur est requise, l'identité du compte d'utilisateur Windows (domaine\utilisateur) de la personne qui a appelé ce composant est placée dans le champ _Expéditeur_ du message.

Pour plus d'informations sur les composants COM, les composants de script Windows ou la sécurité de Message Queuing pour les planifications XLANG, voir Implémentation d'un port en utilisant un composant COM, Implémentation d'un port en utilisant un composant de script Windows, et Implémentation d'un port à l'aide de Message Queuing.

Voir aussi

Utilisation de la forme Composant COM

Utilisation de la forme Message Queuing

Utilisation de la forme Composant de script


Groupe Utilisateurs d'états de BizTalk Server

Au cours de l'installation, BizTalk Server 2002 crée un groupe Windows sur l'ordinateur local dont les membres bénéficient de privilèges pour utiliser l'interface utilisateur suivi de documents BizTalk et afficher les documents faisant l'objet d'un suivi. Par défaut, ce groupe est intitulé Utilisateurs d'états de BizTalk Server, bien que l'utilisateur qui exécute le programme d'installation soit autorisé à changer ce nom. En revanche, il est impossible de le changer après l'installation. Lors de l'installation, BizTalk Server ajoute le groupe Administrateurs local intégré et le compte d'utilisateur actuellement connecté, à ce groupe.

De même, pendant l'installation, BizTalk Server accorde des autorisations d'accès à ce groupe, le groupe Administrateurs local, et le compte d'utilisateur actuellement connecté au répertoire de fichiers dans lequel réside l'interface utilisateur Web Suivi de documents BizTalk, soit \Program Files\Microsoft BizTalk Server\BizTalkTracking.

Les utilisateurs ayant besoin de droits d'accès pour utiliser l'interface utilisateur Suivi de documents BizTalk et afficher le suivi des documents doivent appartenir au groupe Utilisateurs d'états de BizTalk Server et bénéficier de l'accès à la base de données de suivi ; en d'autres termes, ils doivent obtenir un accès au serveur SQL Server qui héberge la base de données de suivi et être membres du rôle db_owner pour cette base de données.


Services de transport

Microsoft BizTalk Server 2002 prend en charge un groupe principal de services de transport. Ces services de transport permettent au serveur d'envoyer des documents aux organisations ou aux applications, qu'elles soient ou non en mesure de communiquer directement avec le serveur par le biais d'une interface COM (Component Object Model). BizTalk Server gère les protocoles réseau HTTP, HTTPS et SMTP, ainsi que Message Queuing.

Cette section traite des rubriques suivantes :

  • HTTP et HTTPS

  • SMTP

  • Message Queuing 2.0

  • File

Voir aussi

Sélection d'un type de transport

Définition des propriétés de transport


HTTP et HTTPS

Le protocole HTTPS permet d'offrir une authentification forte lorsque vous utilisez HTTP (Hypertext Transfer Protocol) pour accéder à des données sur le Web. HTTPS (Secure Hypertext Transfer Protocol) est utilisé le plus souvent pour assurer une connexion cryptée à un serveur Web qui requiert une authentification. Lorsque des clients tentent d'établir une connexion HTTPS (généralement par le biais d'une URL commençant par https://), le client et le serveur négocient un protocole de sécurité commun, puis échangent les informations d'authentification.

Microsoft Internet Explorer 5 (ou versions ultérieures) gère les principaux protocoles de communication sécurisés pour les transactions HTTP :

  • TLS version 1.0 (Transport Layer Security)

  • SSL versions 2 et 3 (Secure Sockets Layer)

  • PCT version 1.0 (Private Communications Technology)

Chaque protocole fournit des services de cryptage (pour garantir la confidentialité des données échangées) et des services d'authentification (pour garantir une identification mutuelle entre les clients et les serveurs). La prise en charge de SSL, par le biais du service de transport HTTPS intégré, ajoute une authentification de serveur à serveur et un cryptage de la couche de transport dans un échange.

BizTalk Server et HTTPS permettent d'échanger des données de manière sécurisée au sein d'une organisation ou avec un partenaire commercial par le biais de HTTP. Des informations détaillées sont fournies ci-après concernant l'utilisation de HTTP et de HTTPS pour envoyer et recevoir des données dans BizTalk Server 2002.

Envoi

Les services de transport HTTP et HTTPS permettent de sécuriser les données envoyées à une application ou à un partenaire commercial. La sécurité de ces services de transport repose sur les certificats.

Par exemple, avant d'envoyer des données sur HTTP, un administrateur BizTalk Server envoie une copie du certificat client à un partenaire commercial. Ce dernier garde une copie du certificat dans le magasin de certificats BizTalk. Par la suite, le certificat est utilisé pour authentifier le partenaire commercial qui envoie des données. Un gestionnaire de certificats unique doit être créé pour envoyer ou exporter un certificat vers un partenaire commercial.

Réception

Pour sécuriser les données sur HTTP, BizTalk Server utilise les services IIS (Microsoft Internet Information Services) et les pages ASP. Lorsque le protocole HTTPS est utilisé pour la connexion à IIS, le client et le navigateur négocient un protocole commun pour sécuriser le canal. Si le serveur et le client ont plusieurs protocoles en commun, IIS sécurise le canal avec un protocole reconnu, tel que SSL. Pour sécuriser les données qui sont reçues par BizTalk Server sur HTTP, la procédure est identique. La page ASP fait office de passerelle pour l'envoi des données à BizTalk Server. Si les données sont sécurisées, BizTalk Server reçoit les données dans la mesure où le code ASP utilise la méthode Submit ou SubmitSync pour effectuer un appel.

Voir aussi

Sélection d'un type de transport

Définition des propriétés de transport


SMTP

Le protocole SMTP (Simple Mail Transfer Protocol) est utilisé pour l'envoi de messages électroniques entre des serveurs. SMTP est un protocole couramment utilisé pour l'envoi de messages électroniques sur Internet. Un message électronique peut être récupéré avec un client de messagerie qui utilise un serveur POP (Post Office Protocol) ou IMAP (Internet Message Access Protocol). De plus, SMTP permet d'envoyer des messages d'un client de messagerie à un serveur de messagerie. Lors de la configuration d'une application de messagerie, le serveur POP ou IMAP et le serveur SMTP doivent être spécifiés.

SMTP permet d'échanger des données de manière sécurisée avec une organisation ou un partenaire commercial. BizTalk Server 2002 utilise SMTP pour envoyer et recevoir des données à l'aide des méthodes suivantes :

Envoi

BizTalk Server implémente un protocole de transport pour envoyer des données via SMTP. SMTP requiert au minimum un codage MIME des données. BizTalk Server peut ainsi identifier la fin d'un groupe de données et le début du groupe de données suivant. Cependant, le codage MIME ne garantit pas la sécurité des données. S/MIME est la version sécurisée de la version MIME. L'utilisation des composants de codage S/MIME intégrés permet de garantir l'intégrité des documents, l'authentification de l'expéditeur et le cryptage du transport de données. BizTalk Server crée un document S/MIME dans lequel le message crypté constitue le corps du document. Pour ajouter cette sécurité supplémentaire, un certificat doit être associé au message MIME. Le codage MIME peut être spécifié lorsque les ports d'échanges sont créés dans le Gestionnaire d'échanges BizTalk, lequel permet également de spécifier les certificats.

Réception

Pour implémenter la sécurité au niveau de la réception de SMTP à l'aide de Microsoft Exchange Server, un administrateur doit créer un compte de réception pour BizTalk Server. Une fois que le compte est configuré, les partenaires commerciaux transmettent leurs clés publiques à Exchange Server qui authentifie l'expéditeur (partenaire commercial). La clé publique est ajoutée au magasin de certificats d'Exchange Server.

Lorsque Exchange Server reçoit un message, la méthode Submit envoie les données à BizTalk Server BizTalk Server compare le certificat à la clé publique ; s'ils correspondent, BizTalk Server décrypte les données et traite le document.

Voir aussi

Éléments de port d'échanges

Sélection d'un type de transport

Sélection d'un certificat de cryptage

Définition des propriétés de transport


Message Queuing 2.0

Message Queuing 2.0 gère la confidentialité et la sécurité des données grâce aux procédures suivantes :

  • Contrôle d'accès

  • Audit

  • Cryptage

  • Authentification

Message Queuing tire également parti du protocole de sécurité Kerberos V5 de Microsoft Windows 2000. De plus, les cryptages 128 bits et 40 bits sont gérés. Message Queuing facilite l'instauration d'un environnement de diffusion d'événements métiers de type « push » et la création d'applications fiables fonctionnant sur des réseaux non sécurisés mais avantageux en termes de coûts.

Message Queuing permet d'échanger des données de manière sécurisée au sein d'une organisation et avec un partenaire commercial. BizTalk Server 2002 recourt à Message Queuing pour envoyer et recevoir les données à l'aide des méthodes suivantes :

Envoi

Le nom d'utilisateur et le mot de passe constituent le premier niveau de sécurité de Message Queuing, et ils sont requis pour stocker des données ou récupérer des données de Message Queuing. Message Queuing peut en outre stocker des données auxquelles est associé un certificat. Les utilisateurs peuvent recourir au Gestionnaire d'échanges BizTalk pour spécifier un certificat pour les données stockées dans une file d'attente de messages.

Réception

Si un administrateur crée des propriétés de connexion pour une file d'attente de messages, un nom d'utilisateur et un mot de passe sont nécessaires pour récupérer les données. La création de propriétés de connexion forme une sécurité fondamentale. Si l'un de vos partenaires commerciaux a ajouté un certificat aux données, vous devez recevoir une copie de sa clé privée pour décrypter les données avant que BizTalk Server puisse traiter le package.

Voir aussi

Ajout d'une fonction de réception Message Queuing

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Configuration d'une fonction de réception Message Queuing : onglet Général

Configuration d'une fonction de réception Message Queuing : onglet Services

Sélection d'un type de transport

Définition des propriétés de transport


File

Microsoft Windows 2000 garantit la protection des données et du système en définissant un contrôle d'accès conditionnel aux fichiers. Le système de fichiers NTFS de Windows, requis pour BizTalk Server 2002, peut empêcher les utilisateurs d'endommager le système de clés ou les fichiers d'application. NTFS offre également une sécurité importante pour les fichiers de prise en charge dans une application.

Le stockage de fichiers permet également d'échanger des données de manière sécurisée au sein d'une organisation et avec un partenaire commercial. Il permet également d'envoyer et de recevoir des données :

Envoi

Le nom d'utilisateur et le mot de passe constituent le premier niveau de sécurité pour le stockage des fichiers. Un nom d'utilisateur et un mot de passe sont requis pour le stockage ou la récupération des données dans un dossier. De plus, les dossiers peuvent stocker des données auxquelles est associé un certificat. Pour utiliser cette sécurité supplémentaire, utilisez le Gestionnaire d'échanges BizTalk afin de créer un certificat pour les données à stocker dans un dossier.

Réception

Si les propriétés de connexion à un dossier ont été appliquées, un nom d'utilisateur et un mot de passe sont nécessaires pour récupérer les données. Un administrateur peut également déterminer les niveaux d'accès (lecture, suppression, etc.) des différents utilisateurs au répertoire de fichiers. Si l'un de vos partenaires commerciaux a ajouté un certificat aux données, vous devez recevoir une copie de sa clé privée pour décrypter les données avant que BizTalk Server puisse traiter le package. Les documents entrants peuvent également disposer d'une signature numérique pour s'assurer que la source ne peut pas nier avoir envoyé le document.

Voir aussi

Ajout d'une fonction de réception de fichier

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Configuration d'une fonction de réception de fichier : onglet Général

Configuration d'une fonction de réception de fichier : onglet Services

Sélection d'un type de transport

Définition des propriétés de transport


Description des certificats

Les certificats numériques lient une clé de cryptage à un ou plusieurs attributs d'un utilisateur. Les certificats sont émis par des organismes de certification et ils protègent les échanges sur Internet en assurant l'authenticité des messages sur le réseau. Cette technologie ainsi que les signatures numériques sur lesquelles elle repose sont actuellement un facteur responsable de la croissance du commerce électronique sur Internet.

Cette section traite des rubriques et procédures suivantes :

  • Présentation des certificats

  • Certificats requis par BizTalk Server

  • Restrictions des noms de certificat


Présentation des certificats

La sécurité offerte par les certificats est un élément important de Microsoft BizTalk Server 2002. Grâce aux clés publiques qui cryptent les données et aux clés privées qui permettent le décryptage des données, BizTalk Server peut envoyer des données fiables et garantir que les données traitées sont sécurisées. Les stratégies de clés publiques, qui font partie de la console MMC (Microsoft Management Console), permettent aux utilisateurs de configurer des agents de récupération des données cryptées pour EFS (Encrypting File System), des autorités de certification racine au niveau du domaine, des autorités de certification de confiance, etc. Les certificats contiennent également des signatures numériques qui peuvent être appliquées aux documents et vérifiées pour les documents entrants grâce à la prise en charge native des signatures numériques par BizTalk Server.

Les certificats permettent d'authentifier et de sécuriser les données échangées sur des réseaux non sécurisés, comme Internet. Les certificats peuvent être gérés pour un utilisateur, un ordinateur ou un service. Certificate Server X.509 est intégré à Windows 2000 Server et permet aux organisations d'émettre des certificats avec clés publiques pour l'authentification de leurs utilisateurs, sans être tributaire des services des autorités de certification.

Dans BizTalk Server, les certificats sont pris en charge par le Gestionnaire d'échanges BizTalk. Les certificats facilitent le cryptage, le décryptage et la signature numérique des données. La technologie de cryptage avec clé publique est prise en charge pour tous les documents qui sont transmis par le biais des services de transport BizTalk Server. BizTalk Server gère en outre le décryptage et la vérification des signatures des documents reçus.

Remarque

  • Lorsqu'il traite les messages S/MIME, le serveur BizTalk Server vérifie la date d'expiration des certificats. En revanche, au moment de l'exécution, le serveur ne vérifie pas si les certificats sont révoqués ou s'ils disposent d'un certificat racine valide et fiable.

Comparaison entre MachineKeys et UserKeys

Pour obtenir des certificats, il est préférable d'utiliser MachineKeys, associé à l'ordinateur, plutôt que UserKeys, associé à l'utilisateur actuellement connecté. Si un utilisateur connecté à un serveur obtient un certificat à l'aide de UserKeys, lui seul peut accéder au certificat car le UserKey du certificat contient les informations de connexion le concernant. Par conséquent, si des utilisateurs souhaitent accéder dans BizTalk Server aux certificats à l'aide de UserKeys, BizTalk Server doit être exécuté dans le contexte de cet utilisateur. Pour permettre à tout utilisateur de se connecter à BizTalk Server et d'accéder aux clés, les certificats doivent détenir des MachineKeys.

Pour que BizTalk Server puisse accéder aux certificats (Ordinateur local),BizTalk Server doit s'exécuter en tant SystèmeLocal ou Administrateur ou les paramètres de sécurité de la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates doivent être modifiés. En outre, en cas d'utilisation des UserKeys, BizTalk Server doit s'exécuter dans le contexte de cet utilisateur, qui doit également être un administrateur ou bénéficier des autorisations sur la clé de Registre mentionnée précédemment.

Si vous ne souhaitez pas utiliser un compte d'administrateur pour exécuter BizTalk Server, tout en ayant besoin malgré cela d'utiliser les certificats, accordez au compte que le service d'échanges BizTalk exécute en Contrôle total les autorisations pour la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates.

Cette section traite de la procédure suivante :

  • Configuration des autorisations de Registre pour les certificats


Configuration des autorisations de Registre pour les certificats

Pour modifier les autorisations de Registre pour les certificats dans Windows 2000 :

  1. Cliquez sur Démarrer et sur Exécuter, puis tapez regedt32.exe.

  2. Cliquez sur OK.

  3. Recherchez la clé de Registre suivante :

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SystemCertificates

  4. Dans le menu Sécurité, cliquez sur Autorisations, puis donnez au compte en question les autorisations de contrôle total sur cette clé de Registre.

Avertissement

  • Avant de modifier le Registre, assurez-vous que vous serez en mesure de le restaurer en cas de problème. Pour plus d'informations, voir « Modifier des clés et des valeurs » et « Ajouter et supprimer des informations dans le Registre » dans l'aide de Windows 2000. N'oubliez pas de sauvegarder le Registre avant de le modifier. Si vous utilisez Windows 2000, vous devez également mettre à jour votre disquette de réparation d'urgence.

  • Une utilisation incorrecte de l'Éditeur du Registre peut provoquer des problèmes graves pouvant nécessiter la réinstallation de votre système d'exploitation. Microsoft ne peut garantir la résolution des problèmes résultat d'une utilisation incorrecte de l'Éditeur du Registre. L'utilisation de l'Éditeur du Registre est sous votre seule responsabilité.


Certificats requis par BizTalk Server

Un serveur de certificats stocke les certificats d'un utilisateur ou d'un ordinateur. Chaque utilisateur dispose d'un magasin de certificats, et chaque ordinateur dispose de ses propres magasins de certificats. Si un utilisateur crée un certificat, Windows 2000 suppose que le certificat est pour l'utilisateur. Une organisation doit stocker ses certificats dans le magasin Personnel situé sous Certificats (Ordinateur local) sur la console Certificats. En revanche, au cours de la conception, lorsque les ports d'échanges et les canaux sont créés, tous les certificats des partenaires commerciaux doivent être associés au magasin BizTalk, situé sous Certificats (Ordinateur local) sur la console Certificats, plutôt qu'à l'utilisateur.

En outre, lors de la spécification de la sécurité des partenaires commerciaux (telle que le cryptage ou la vérification de signatures) par le biais du Gestionnaire d'échanges BizTalk, les certificats affichés sont ceux des partenaires commerciaux, qui se trouvent dans le magasin BizTalk. Le Gestionnaire d'échanges BizTalk affiche les certificats qui se trouvent dans le magasin Personnel situé sous Certificats (Ordinateur local) sur la console Certificats lors de la spécification de la sécurité (la vérification du décryptage et de la signature notamment) pour les clients SSL. L'emplacement des certificats est important car lorsqu'un utilisateur tente de traiter des documents par le biais de BizTalk Server à l'exécution, l'ordinateur agit en tant que service d'arrière-plan, et c'est ce service qui doit accéder aux certificats.

Il existe deux méthodes pour résoudre les problèmes liés à l'emplacement de stockage des certificats :

  • Si un utilisateur possède déjà des certificats, Windows 2000 les a stockés dans le magasin de l'utilisateur. Les certificats doivent être déplacés du magasin de l'utilisateur vers le magasin BizTalk sous Certificats (Ordinateur local). Cette procédure est effectuée par le biais du Gestionnaire de certificats.

  • Si un utilisateur a créé un compte de services, tous les certificats sont associés à l'ordinateur et non à l'utilisateur.

Gestion des certificats par le biais de Windows 2000

BizTalk Server offre une gestion des certificats par le biais de Windows 2000. IIS 5.0 est étroitement intégré au modèle de sécurité de Windows 2000 et inclut un serveur de certificats. Ainsi, les organisations peuvent émettre et gérer les certificats numériques X.509 au standard Internet. Outre les services de gestion clés dans IIS 5.0, le serveur de certificats Microsoft dans in IIS 5.0 inclut des services personnalisables d'émission et de gestion de certificats numériques. Un serveur de certificats joue un rôle central dans la gestion des systèmes de sécurité des logiciels pour permettre des communications sécurisées sur Internet, les intranets d'entreprise et d'autres réseaux non sécurisés.

La procédure suivante est traitée dans cette section :

  • Création d'un gestionnaire de certificats pour BizTalk Server

Voir aussi

Sélection d'un certificat pour la signature sortante

Sélection d'un certificat pour vérifier le décryptage d'un document entrant

Sélection d'un certificat pour vérifier la signature d'un document entrant

Sélection d'un certificat de cryptage


Création d'un gestionnaire de certificats pour BizTalk Server

Dans BizTalk Server, tous les partenaires commerciaux doivent être associés au magasin BizTalk situé sous Certificat (ordinateur local) de la console Certificats, et non à l'utilisateur.

  1. Dans le menu Démarrer, cliquez sur Exécuter, tapez mmc, puis cliquez sur OK.

    La boîte de dialogue Console1 apparaît.

  2. Dans le menu Console, cliquez sur Ajouter/Supprimer un composant logiciel enfichable.

    La boîte de dialogue Ajouter/Supprimer un composant logiciel enfichable apparaît.

  3. Cliquez sur Ajouter.

    La boîte de dialogue Ajout d'un composant logiciel enfichable autonome s'affiche.

  4. Cliquez sur Certificats, puis sur Ajouter.

    La boîte de dialogue Composant logiciel enfichable Certificats s'affiche.

  5. Cliquez sur Le compte de l'ordinateur, sur Suivant, puis sur Terminer.

  6. Dans la boîte de dialogue Ajout d'un composant logiciel enfichable autonome, cliquez sur Certificats, puis sur Ajouter.

    La boîte de dialogue Composant logiciel enfichable Certificats s'affiche.

  7. Cliquez sur Mon compte d'utilisateur, Suivant, Terminer, Fermer, puis cliquez sur OK pour fermer les boîtes de dialogue.

  8. Dans le menu Console, cliquez sur Enregistrer.

    La boîte de dialogue Enregistrer s'affiche.

  9. Sélectionnez l'emplacement dans lequel vous voulez enregistrer le gestionnaire de certificats (l'emplacement par défaut se trouve dans le dossier Outils d'administration), attribuez-lui le nom de votre choix, puis cliquez sur Enregistrer.

Remarques

  • Cette opération doit être effectuée par un membre du groupe Administrateur de BizTalk Server.

  • Si votre compte d'utilisateur dispose déjà d'un gestionnaire de certificats, ouvrez ce dernier et exécutez les étapes 2 à 6 de la procédure pour créer un compte d'ordinateur.

  • Dès que les certificats sont créés, vous devez les retirer du magasin de l'utilisateur pour ajouter le composant logiciel enfichable Certificat pour le compte d'ordinateur.

Voir aussi

Description des certificats


Restrictions des noms de certificat

Les certificats ne peuvent pas porter le même nom dans Microsoft BizTalk Server 2002. Si plusieurs certificats portent le même nom, seul l'un d'entre eux peut être sélectionné dans le Gestionnaire d'échanges BizTalk. Par exemple, si une organisation utilise deux certificats qui partagent le même nom et la même référence, l'organisation ne peut pas utiliser les deux certificats. Si elle utilise l'un des certificats, l'autre disparaît de la liste des certificats disponibles dans la boîte de dialogue Canal.


CryptoAPI

Microsoft BizTalk Server 2002 utilise CryptoAPI pour sécuriser les données traitées. Les récentes évolutions en matière de cryptographie ont donné lieu à de nouvelles utilisations, notamment des mécanismes pour l'authentification des utilisateurs sur un réseau, ce qui permet de garantir l'intégrité des données transmises et d'empêcher les utilisateurs de nier qu'ils sont à l'origine des messages transmis.

Toutes les applications, toutes les données et tous les messages qui recourent au cryptage et au cryptage Microsoft (comme Microsoft Windows 2000 pour générer des certificats) utilisent CryptoAPI. BizTalk Server utilise CryptoAPI pour les fonctions de réception qu'un utilisateur spécifie lorsqu'il utilise un composant COM+ personnalisé, tel que le composant de prétraitement, ce qui permet à BizTalk Server de gérer des composants de cryptage uniques.


CDO (Collaborative Data Objects)

Microsoft BizTalk Server 2002 prend en charge le codage MIME pour l'envoi et la réception des données. Grâce aux objets CDO (Collaborative Data Objects), lesquels font partie de l'environnement Microsoft Windows 2000, les données peuvent être codées et traitées par BizTalk Server. Par exemple, pour que BizTalk Server puisse envoyer un catalogue contenant du texte et des graphiques, les données (graphiques) doivent d'abord passer de l'état binaire à l'état de chaîne. Les objets CDO peuvent être utilisés pour coder le texte et les graphiques dans un format de chaîne, afin que BizTalk Server puisse les traiter.


Configuration de pare-feu

Les pare-feu permettent de sécuriser les réseaux internes mais leur présence introduit un problème de latence et risquent de créer un point de défaillance unique. Même si un système d'équilibrage de la charge est utilisé pour réduire ce risque, la présence d'un pare-feu est susceptible de réduire les performances du réseau.

Lorsque vous configurez un environnement BizTalk Server 2002 avec un pare-feu, sachez que deux configurations principales sont conseillées :

  • Configuration 1. Installez les serveurs sur un réseau interne de l'entreprise. Sélectionnez certains serveurs pour qu'ils communiquent avec les partenaires commerciaux sur un réseau périphérique de l'entreprise (également appelé zone DMZ ou zone délimitarisée). Une entreprise qui souhaite héberger ses propres services Internet sans sacrifier aux accès non autorisés à son réseau privé, utilise un réseau périphérique. Un réseau périphérique est une frontière entre Internet et les lignes de défense d'un réseau interne. Il s'agit généralement d'une combinaison de pare-feu et de serveurs bastions, qui constituent des passerelles entre les réseaux internes et externes. Les serveurs du réseau périphérique doivent utiliser des services de transport locaux comme HTTP, Message Queuing ou SMTP. Dans un environnement de ce type, toutes les transactions entrantes et/ou sortantes transitent par un pare-feu. Les serveurs du réseau périphérique envoient les documents à Microsoft SQL Server via un autre pare-feu. Cette configuration permet aux serveurs, comme les serveurs BizTalk Server du réseau périphérique, de communiquer avec un serveur Microsoft SQL Server via un pare-feu interne.

  • Configuration 2. Installez les serveurs sur un réseau d'entreprise. Les partenaires commerciaux qui échangent des documents par Internet transmettent leurs données en utilisant des serveurs SMTP/HTTP dans le réseau périphérique (premier pare-feu de protection). Ces serveurs envoient ensuite les données aux serveurs qui résident sur le réseau de l'entreprise via un second pare-feu.

Le choix entre la configuration 1 et la configuration 2 influe sur les performances. Pour éviter une dégradation importante des performances, vous pouvez construire le pare-feu de façon à assurer un nombre courant de transactions entre une organisation et ses partenaires commerciaux.


Amélioration des performances et de l'évolutivité

La compréhension des différents composants de Microsoft® BizTalk™ Server 2002 vous permettra de créer des solutions évolutives et à haute performance. Il existe plusieurs méthodes pour augmenter les performances de BizTalk Server, comme l'identification des goulots d'étranglement potentiels, la résolution des problèmes de temps de latence et la gestion des bases de données. Toutefois, le degré d'optimisation que vous pouvez atteindre pour votre solution dépend de la complexité de l'architecture du système de votre organisation et des contraintes budgétaires.

L'optimisation des bases de données suivantes de BizTalk Server est essentielle pour obtenir des performances optimales :

  • Gestion d'échanges BizTalk

  • Base de données de files d'attente partagée

  • Base de données de suivi

  • Base de données de persistance

Pour plus d'informations sur l'optimisation des bases de données, voir Évolution verticale des bases de données et Évolution horizontale des bases de données.

Cette section traite des rubriques suivantes :

  • Optimisation des performances

  • Évolution de BizTalk Server


Optimisation des performances

Pour répondre aux besoins en transaction et améliorer les performances, vous devez optimiser BizTalk Server 2002. Outre BizTalk Server, vous pouvez également optimiser Microsoft® Windows® 2000 et les interactions des bases de données.

Après avoir configuré votre système, testez-le, puis évaluez-en les résultats pour déterminer si votre configuration d'origine répond aux besoins en transactions. Vous devrez certainement reconfigurer votre architecture afin d'obtenir des performances optimales. Après chaque reconfiguration, procédez à un nouveau test et évaluez les résultats. Une fois les résultats escomptés obtenus, lancez un plan de maintenance car les performances du serveur évoluent dans le temps. De plus, la quantité et le type de transaction traités dans votre organisation peuvent changer.

Cette section traite des rubriques suivantes :

  • Réglage des performances de l'architecture de BizTalk Server

  • Conception, test et analyse de l'architecture

  • Maintenance des performances


Réglage des performances de l'architecture de BizTalk Server

Cette section fournit des recommandations générales pour l'optimisation des paramètres système et comprend des rubriques consacrées à l'optimisation de BizTalk Server 2002 pour obtenir des performances accrues.

Avant d'entreprendre le réglage des performances et de l'évolutivité de BizTalk Server, il est important de comprendre toutes les caractéristiques de votre système. À quelques exceptions près, le goulot d'étranglement se situera dans l'une des zones suivantes :

  • E/S disque ;

  • vitesse de processeur ;

  • E/S réseau ;

  • vitesse en entrée (rapidité à laquelle vos documents sont envoyés au serveur BizTalk Server) ;

  • Code personnalisé (par exemple, composants d'intégration d'application, composants du préprocesseur ou pages ASP sur lesquelles vous effectuez vos publications).

Les rubriques de cette section vous aident à résoudre ces problèmes. Tout d'abord, vous devez analyser les performances de la configuration actuelle afin de déterminer l'origine du problème. Même si vous êtes satisfait des performances actuelles de votre système, l'analyse et la connaissance des propriétés de ce dernier constituent un élément important qui vous permettra de gagner du temps lors du dépannage ou de la mise à niveau.

Voici les premières cinq étapes recommandées pour analyser les performances d'un système:

  1. Surveillez les E/S disque sur tous les ordinateurs de la configuration BizTalk Server en vérifiant le compteur de performance %Durée d'inactivité du disque dans le Moniteur système de Windows ou dans MOM (Microsoft Operations Manager). Surveillez ce compteur de performance pour tous les serveurs BizTalk Server, SQL Server et tous les ordinateurs supplémentaires qui interagissent avec BizTalk Server, par exemple, via les composants d'intégration d'application ou un envoi HTTP. Pour plus d'informations, voir Évaluation des performances d'une configuration.

  2. Surveillez l'utilisation du processeur sur tous les ordinateurs de la configuration de BizTalk Server en vérifiant le compteur de performance %Utilisation du processeur dans le Moniteur système de Windows ou Microsoft Operations Manager. Si vous notez qu'un processeur est surchargé sur un serveur BizTalk Server, optimisez ses performances en modifiant les paramètres du serveur, du canal et du Registre. Pour plus d'informations, voir Ajout, suppression et configuration de serveurs dans un groupe, Ajout, suppression et configuration d'un groupe de serveurs, Optimisation des paramètres du Registre et Évolution horizontale des services d'échanges BizTalk. Dans un système BizTalk Server dont la configuration est optimale, l'utilisation du processeur est le seul point sur lequel un goulot d'étranglement peut se produire.

  3. N'autorisez aucun serveur à participer au traitement des éléments de travail et relancez votre scénario afin que les éléments s'accumulent dans la liste d'attente de travail. Vous pourrez ainsi vous rendre compte de la rapidité de réception des documents. Prenez du temps pour procéder de nouveau aux deux premières analyses, afin de détecter d'autres problèmes éventuels. Un problème assez général est le ralentissement en entrée lors de l'utilisation des appels soumis ASP. Souvent, étant donné que les services IIS (Internet Information Services) ne parviennent pas à traiter les requêtes suffisamment rapidement, BizTalk Server ne fonctionne pas à son niveau de performance optimal. Lorsque vous utilisez un appel soumis ASP, il est conseillé d'employer les fonctions de réception HTTP ISAPI de BizTalk Server, car elles fonctionnent beaucoup mieux. Dans un système BizTalk Server dont la configuration est optimale, l'utilisation du processeur constitue le goulot d'étranglement de la réception des documents.

  4. Fermez les fonctions de réception ou arrêtez d'appeler la méthode Submit et autorisez les serveurs à participer au traitement des éléments de travail déjà dans la file d'attente de travail. Vous pourrez ainsi vous rendre compte de la rapidité à laquelle le système peut traiter et transmettre les documents. De nouveau, procédez aux deux premières analyses et réglez le système jusqu'à ce que l'utilisation du processeur constitue votre goulot d'étranglement. Pour déterminer si le transport est la raison du ralentissement des performances, il est recommandé de modifier le type de transport des ports. L'utilisation des composants d'intégration d'application est un bon moyen pour déterminer ce qu'il vous reste à faire pour atteindre le niveau de performance maximal de ces composants.

  5. Équilibrez les entrées et les sorties du système. Après avoir éliminé tous les goulots d'étranglement de vos ressources et défini pour les serveurs un niveau d'utilisation de l'UC supérieur à 90 pour cent, il est important d'équilibrer la vitesse de réception et la vitesse de traitement, de sorte qu'il reste toujours entre 40 et 100 documents dans la file d'attente de travail. Pour plus d'informations, voir Équilibrage de la réception et du traitement.

Cette section traite des rubriques suivantes :

  • Équilibrage de la réception et du traitement

  • Optimisation des services d'orchestration BizTalk

  • Optimisation des services d'échanges BizTalk

Voir aussi

Évolution de BizTalk Server


Équilibrage de la réception et du traitement

Après avoir éliminé tous les goulots d'étranglement de vos ressources et défini pour les serveurs un niveau d'utilisation de l'UC supérieur à 90 pour cent, il est important d'équilibrer les vitesses de réception et de traitement de sorte qu'il reste toujours entre 40 et 100 documents dans la file d'attente de travail. Pour équilibrer correctement le nombre de documents que vous recevez et le nombre de documents traités par votre système, respectez les consignes suivantes :

  • De manière générale, vous ne pouvez pas traiter plus de documents que vous n'en recevez. Si la réception de document est trop lente, ceci limitera le nombre de documents pouvant être traité à un moment donné. Les signes révélant un ralentissement de la réception des documents sont les suivants :
    • La file d'attente de travail est souvent vide.

    • Lorsque vous surveillez le compteur de performance Documents traités/s, vous remarquez que le traitement des documents baisse fréquemment vers zéro.
  • En optimisant votre système pour la réception des documents, vous risquez de limiter les ressources disponibles pour le traitement des documents, et de réduire le débit. Les signes révélant que les ressources pour le traitement des documents sont insuffisantes sont les suivants :
    • Le nombre de documents dans la file d'attente de travail ne cesse de croître dans le temps.

    • Le moniteur système peut indiquer que vous recevez des documents plus rapidement que vous n'en traitez.

    Important

    • Vous pouvez vous fier à ces symptômes si chaque document reçu correspond exactement à un canal. Si dans votre configuration, un document correspond à plusieurs canaux, vous devez modifier vos réglages. Si par exemple, dans votre configuration, chaque document entrant correspond à exactement deux canaux, le début maximal des documents sera égal à deux fois le nombre de documents reçus.


Optimisation des services d'orchestration BizTalk

Si vous faites appel aux services d'orchestration BizTalk, vous pouvez optimiser les planifications XLANG et leur contenu. Moyennant une bonne compréhension de la façon dont les planifications utilisent la mémoire et dont la structure d'un processus professionnel affecte les performances, vous pouvez concevoir des planifications qui améliorent les performances des services d'orchestration BizTalk. Les technologies d'implémentation prises en charge par les services d'orchestration BizTalk incluent les services d'échanges BizTalk, les composants COM, les services Message Queuing et les composants Windows Script. En optimisant ces composants et ces services, vous pouvez aller encore plus loin dans l'amélioration des performances des services d'orchestration BizTalk.

Cette section traite des rubriques suivantes :

  • Optimisation des planifications XLANG

  • Optimisation des contenus des planifications XLANG


Optimisation des planifications XLANG

Une planification XLANG peut contenir un nombre important de processus professionnels internes. Les processus professionnels peuvent inclure des transactions de courte durée ou des transactions de longue durée. BizTalk Server 2002 ne contrôle pas le contenu de ces processus mais il gère le flux des données à travers ces processus dans une planification XLANG. Lorsque vous créez une planification XLANG et quelle consiste en plusieurs transactions de courte durée ou de longue durée, tenez compte des points suivants :

  • Une instance de planification XLANG s'exécute en mémoire à chaque fois qu'elle est appelée.

  • Plusieurs planifications XLANG peuvent fonctionner sur un même serveur.

  • Plusieurs planifications XLANG différentes peuvent fonctionner simultanément, avec plusieurs instances de planifications XLANG.

La base de données de persistance d'orchestration fournit un mécanisme appelé système de mise en attente, qui permet de contrôler la mémoire utilisée par les planifications XLANG en cours d'exécution. La mise en attente se produit lorsqu'une instance de planification XLANG attend un message et qu'aucune autre activité n'a lieu dans la planification XLANG. À ce stade, le moteur de XLANG Scheduler met en attente l'instance de planification XLANG afin de maximiser les performances. La mise en attente d'une instance de planification XLANG consiste à rendre permanent tous les états spécifiques d'une instance dans une base de données et à supprimer cette instance de la mémoire. Seule une petite portion de l'instance de planification XLANG reste en mémoire dans le moteur XLANG Scheduler. Lorsqu'un message parvient à un port pour l'instance de planification XLANG, l'instance est réalimentée. La réalimentation d'une instance de planification XLANG consiste à restaurer l'instance dans la mémoire, à partir de la base de données.

Une instance de planification XLANG reste en attente jusqu'à ce qu'elle soit réactivée ou qu'un administrateur l'interrompe explicitement. Ce système permet à un processus professionnel de fonctionner de manière fiable pendant une longue période. Pour plus d'informations sur la configuration des paramètres de mise en attente et de réalimentation, voir Mise en attente et réalimentation. Les processus de mise en attente et de réalimentation permettent d'économiser de la mémoire mais ils affectent les performances. Comme ces deux processus nécessitent la lecture et l'enregistrement des données dans la base de données de persistance d'orchestration, le réseau génère une latence.

Important

  • Pour augmenter considérablement les performances des services d'orchestration BizTalk, dans l'Explorateur Windows, accédez à Program Files\Common Files\System\ado, puis double-cliquez sur adofre15.reg. Dans la boîte de dialogue de confirmation, cliquez sur Oui, puis sur OK. N'oubliez pas que cette procédure fait passer le modèle de thread ADO de « Threads cloisonnées » à « Les deux » et peut affecter d'autres applications utilisant ADO (Microsoft® ActiveX® Data Objects).


Optimisation des contenus des planifications XLANG

Une planification XLANG décrit un processus professionnel et la liaison de ce processus aux techniques d'implémentation. La performance d'une planification XLANG reflète souvent le niveau de performance des actions qu'elle contient. Il existe un certain nombre de points pertinents qu'il est utile de prendre en considération pour l'optimisation des contenus d'une planification XLANG. Certains sont spécifiques aux planifications XLANG et d'autres concernent la création d'applications distribuées.

  • Rétablissez la valeur de mise en attente pour conserver de la mémoire pour les planifications XLANG. La valeur par défaut du délai d'attente est 0 seconde. Vous pouvez modifier cette valeur. Une valeur inférieure ou égale à 180 secondes fait que la planification XLANG n'est jamais mise en attente. Toute valeur supérieure à 180 secondes entraîne la réalimentation immédiate de la planification XLANG. Pour plus d'informations sur les temps d'attente et la mise en attente des planifications XLANG, voir Mise en attente et réalimentation et Communication synchrone et asynchrone.

  • Utilisez des composants permanents. Les composants permanents, tels que ceux qui implémentent IPersistStream ou IpersistStreamInit, permettent au moteur de XLANG Scheduler de mettre en attente les planifications XLANG de manière flexible.

  • Exécutez les objets COM sur le même serveur que la base de données de persistance d'orchestration. Ceci permet de garantir que la planification XLANG ne génère pas de latence au niveau du réseau.

  • Exécutez des applications COM+ intra-processus pour obtenir des performances optimales. Bien que l'exécution d'une application COM+ dans un processus puisse affecter la stabilité de cette application COM+ (par exemple, si un composant dans l'application présente une défaillance, toute l'application peut être défaillante), il est considérablement plus rapide de l'exécuter ainsi que de l'exécuter en dehors d'un processus. Pour éviter ce risque d'instabilité, assurez-vous de tester très soigneusement la stabilité des composants de l'application avant de déployer l'application dans un environnement de production.

  • Organisez les travaux dans une transaction unique. Le fait de rendre permanent l'état d'une instance de planification XLANG en début ou en fin de transaction affecte grandement les ressources de l'ordinateur. Cependant, l'organisation des éléments de travail dans une transaction unique réduit considérablement l'impact sur les performances. De plus, une planification XLANG ne peut pas être mise en attente au milieu d'une transaction du Coordinateur de transactions distribuées de Microsoft (MS DTC, Microsoft Distributed Transaction Coordinator). Les transactions MS DTC sont rapides mais elles dégradent les performances. Groupez plusieurs actions dans une transaction MS DTC unique, à condition que les actions puissent être achevées rapidement.

  • Les transactions de longue durée doivent être effectuées de façon asynchrone et les planifications XLANG doivent être conçues de façon à terminer rapidement les appels COM. Le résultat des travaux asynchrones peut être communiqué à l'instance de planification XLANG via des messages en files d'attente ou via des appels COM. Avec les appels COM, le nom d'un port de « réponse » peut être transmis sous la forme d'un moniker qui reste valide même après le redémarrage de l'ordinateur.

Voir aussi

Syntaxe du moniker


Optimisation des services d'échanges BizTalk

Pour optimiser les Services d'échanges BizTalk, envoyez les documents à un groupe de serveurs. Les groupes de serveurs BizTalk sont utilisés pour la distribution des travaux à travers plusieurs serveurs. Pour envoyer des données à BizTalk Server 2002, utilisez les méthodes suivantes :

  • Configuration d'une fonction de réception (comme Message Queuing, HTTP ou File).

  • Appel de la méthode Submit sur l'objet BizTalk Server Interchange.

L'utilisation des fonctions de réception procure de meilleures performances que l'utilisation de la méthode Submit pour appeler l'objet Interchange. Les fonctions de réception utilisent un pool de threads et le traitement en un seul lot pour optimiser les performances de réception. Pour obtenir le même niveau de performance dans le code client appelant IInterchange::Submit(), le composant client doit implémenter un code cloisonné multithread dans lequel chaque thread possède son propre pointeur vers IInterchange. Si un code cloisonné monothread est utilisé, il envoie des séries de messages à BizTalk Server, et n'obtient pas les performances de débit atteintes par les fonctions de réception et par Message Queuing.

L'appel de l'objet Interchange pour les envois plutôt que l'utilisation d'une fonction de réception nécessite davantage de ressources car l'objet Interchange doit être créé en dehors du processus BizTalk Server. Cependant, lorsque vous utilisez cet objet, vous disposez de deux méthodes pour envoyer des données aux serveurs d'un groupe :

  • Configuration statique des segments de tous les envois vers des serveurs spécifiques dans le groupe. Toutefois, cette opération ne permet pas de bénéficier d'un niveau élevé de tolérance de panne si le serveur, qui dispose d'un service de transport, est mappé de façon statique à un serveur BizTalk Server qui tombe en panne.

  • Utilisation de la fonctionnalité CLB de Microsoft Application Center 2000 pour améliorer les performances. Les groupes de serveurs BizTalk Server ne fournissent pas la fonctionnalité d'équilibrage de charge pour l'envoi des documents. Outre l'équilibrage de charge, la fonctionnalité CLB fournit la tolérance de panne. Pour plus d'informations sur la fonctionnalité CLB, voir Équilibrage de charge de composant.

Cette section traite des rubriques suivantes :

  • Création et optimisation des spécifications

  • Création et optimisation des mapping

  • Optimisation des propriétés du groupe de serveurs BizTalk Server

  • Optimisation des propriétés du serveur

  • Optimisation des paramètres du Registre

  • Optimisation du cryptage

  • Optimisation des communications

  • Configuration de pare-feu


Création et optimisation des spécifications

Lorsque les paramètres de suivi global par défaut sont utilisés, BizTalk Server 2002 peut prendre en charge un document au format XML (Extensible Markup Language) Unicode de 20 Mo. Pour les autres types de fichiers, comme les fichiers au format fichier plat ANSI, BizTalk Server ne prend pas en charge une taille de 20 Mo car un fichier qui n'est pas au format XML doit être converti en XML. Le processus de conversion consiste à ajouter des balises XML dans les données, ce qui augmente la taille du document que BizTalk Server doit traiter. Afin de maintenir des performances optimales pour BizTalk Server, la taille des autres types de fichiers doit être inférieure à 20 Mo.

La quantité de mémoire requise pour le traitement d'un document qui a été converti au format XML dépend de la structure d'origine du document. Lorsque les paramètres de suivi global sont activés, les documents au format XML Unicode dont la taille est supérieure à 20 Mo peuvent être traités sans que les performances du serveur BizTalk Server en soient grandement affectées.

Remarque

  • Le dépassement des limites de taille pour le suivi des échanges modifie les performances du serveur BizTalk Server. Pour plus d'informations sur les limites de taille, voir Limite de la taille des documents et des échanges. Les performances se trouvent également affectées par le processus de journalisation des documents. Pour plus d'informations sur la journalisation des documents, voir Définition des propriétés de journalisation de document.

Lorsque vous concevez des spécifications, vous pouvez configurer des règles de validation dans une spécification. Il est par exemple possible de spécifier qu'un champ contient un type particulier de données (comme une chaîne) ou de spécifier des règles plus complexes, comme la comparaison de la valeur d'un champ à 80 valeurs pour sa validation. Dans cet exemple, les données doivent être comparées à 80 valeurs et si elles ne correspondent à aucune d'entre elles, la validation de la spécification échoue. Dans BizTalk Server, la validation de spécification est activée par défaut ; cela affecte les performances mais garantit la validité des données envoyées ou reçues. Vous pouvez désactiver la validation, ce qui augmente les performances et ne nuit pas forcément de façon irrémédiable à la validité des données car BizTalk Server dispose de plusieurs autres systèmes pour la validation des données.

Par exemple, si un mapping nécessite certains types de données et certaines valeurs et que la validation de la spécification est désactivée, les données passent avec succès la phase d'analyse mais non la phase de sérialisation lorsque le mapping est appliqué. Si d'autres systèmes (tels que le mapping reposant sur des données valides) sont disponibles, la validation de la spécification peut être désactivée pour éviter la dégradation potentielle des performances causée par le processus de validation. Vous pouvez aussi choisir de procéder ainsi car vous êtes convenu d'appliquer des standards de données avec vos partenaires commerciaux et avez validé ces transactions. Vous pouvez également faire ce choix parce que vous contrôlez entièrement la façon dont les données sont envoyées (par des transactions d'application à application par exemple).

Pour désactiver la validation, vous pouvez utiliser le paramètre de Registre NoValidation. Lorsque la validation de la spécification n'est pas requise (c'est-à-dire lorsque les documents ne sont pas validés par rapport à une spécification pour des paramètres comme les valeurs minimales/maximales, les types de données et/ou les valeurs requises) affectez une valeur différente de zéro à ce paramètre et les données ne seront pas validées. Ceci peut aider à augmenter les performances mais des données non valides risquent d'être envoyées. L'affectation d'une valeur différente de zéro au paramètre de validation de la spécification peut représenter le bon choix pour les serveurs qui reçoivent des documents dont l'organisation contrôle la structure.

La définition des paramètres du Registre s'effectue au niveau de chaque serveur. Lorsque la validation de la spécification est activée, chaque document traité par le serveur est validé par rapport à sa spécification. Le traitement des documents est donc plus lent que dans le cas où aucune validation de spécification n'est utilisée.

Solutions recommandées pour l'optimisation de la taille des documents et des spécifications

Pour optimiser les performances de BizTalk Server :

  • N'incluez pas plus de champs et/ou d'attributs dans les spécifications que nécessaire. Plus le nombre de champs et d'attributs est important et plus les besoins en mémoire augmentent pour BizTalk Server. Une spécification plus importante nécessite une mémoire proportionnellement plus importante. Par exemple, les spécifications EDI incluses dans BizTalk Server sont conformes aux standards EDI. D'une façon générale, la plupart des organisations qui utilisent des spécifications EDI requièrent approximativement dix pour cent de toute la spécification. Par conséquent, lorsqu'une organisation et son partenaire commercial utilisent uniquement dix pour cent de la totalité d'une spécification, les enregistrements et les champs inutiles peuvent être supprimés et la spécification modifiée, utilisée pour les transactions.

  • Si la validation de la spécification est activée, n'indiquez pas de règles de validation dans les spécifications pour les champs qui contiennent des données valides. Par exemple, si un champ contient un nombre qui doit être traité uniquement en tant que chaîne (comme un numéro de téléphone), ne spécifiez pas qu'il doit être numérique. Dans ce type de cas, il n'est pas nécessaire de spécifier un type de données car le type de données par défaut est une chaîne. Par conséquent, le champ pour le type de données peut ne pas être complété. La validation de la spécification des valeurs autorisées pour un champ est plus longue que la simple validation d'un type de données.


Création et optimisation des mapping

La conversion de données comme opération faisant partie d'une transaction risque de réduire les performances de BizTalk Server 2002. Le mappage des spécifications peut nécessiter une utilisation intense de l'UC, ce qui risque également de limiter les capacités de BizTalk Server à traiter la transaction dans sa totalité. Le degré d'atteinte des performances de BizTalk Server dépend en grande partie de la complexité du mappage utilisé pour la conversion. Par exemple, le mappage d'un champ appelé IDproduit dans la spécification source à un champ appelé IDarticle dans la spécification de destination ne recourt pas à l'UC de façon aussi intensive qu'une opération mathématique complexe réalisée sur des données en cours de conversion.

Solutions recommandées pour la conception de mapping

  • Utilisez des fonctoids uniquement lorsque cela est nécessaire. Les fonctoids utilisent des scripts, ce qui demande à BizTalk Server de charger un moteur de script. Ceci risque de nuire aux performances contrairement aux transformations du XML (Extensible Markup Language) natif.

  • Utilisez le fonctoid Recherche dans la base de données uniquement lorsque cela est nécessaire. En effet, BizTalk Server doit établir la connexion à une base de données, rechercher des données, compléter un jeu d'enregistrements et mettre fin à la connexion à chaque fois que ce fonctoid est utilisé. Ceci risque de dégrader les performances de BizTalk Server.

  • Évitez d'appeler des objets COM dans des scripts de fonctoids et d'utiliser des fonctoids personnalisés. Ces deux techniques font que BizTalk Server instancie une instance d'un objet COM. Ceci affecte les performances de toute l'opération. De plus, les performances de l'opération d'instanciation des objets COM sont diminuées par les réponses aux questions suivantes :
    • L'opération est-elle effectuée au sein d'un processus ou en dehors d'un processus ?

    • L'objet est-il local ou distant ?

    • L'objet est-il correctement écrit ?

    • L'opération est-elle transactionnelle ?
  • Analysez chaque mapping pour déterminer la façon d'obtenir des performances optimales. Par exemple, il est possible d'utiliser deux techniques différentes pour concaténer deux champs sources et placer la valeur obtenue dans deux champs de destination différents. La première technique de concaténation consiste à utiliser un seul fonctoid de concaténation et à mapper le résultat à deux emplacements. La seconde technique de concaténation consiste à utiliser deux fonctoids, chacun avec une liaison unique du résultat à un champ source de destination. La première technique est légèrement plus efficace en raison du fait que le script, qui s'exécute en tant qu'élément du fonctoid, est appelé une fois seulement. En réalisant un test, vous pouvez déterminer les techniques qui offrent les meilleures performances.


Optimisation des propriétés du groupe de serveurs BizTalk Server

Dans la console Administration de BizTalk Server, vous pouvez spécifier les propriétés suivantes dans la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server :

  • Intervalle d'actualisation de cache d'objet de gestion d'échanges (en secondes). Ce champ peut être défini à 300 secondes au maximum. BizTalk Server 2002 enregistre en mémoire cache les configurations (comme les canaux, les ports d'échanges, les enveloppes et les définitions de document) pour ne pas devoir appeler la base de données à chaque fois. Si ces objets ne sont pas souvent modifiés, définissez cette valeur à 300 afin de réduire le nombre de fois auquel les données sont enregistrées puis lues dans la base de données. Comme BizTalk Server actualise les objets de gestion toutes les cinq minutes, le service doit être relancé pour que les modifications soient appliquées immédiatement.

  • Désactiver le suivi de document. Utilisez l'onglet Suivi pour activer ou désactiver le suivi des documents. Si vous choisissez de ne pas utiliser le suivi, désactivez ce champ pour réduire le nombre de lectures/écritures effectuées dans la base de données pour une seule transaction. Lorsque ce champ est activé, BizTalk Server se connecte à la base de données et consigne les données dans un journal. Ne désactivez pas ce champ, excepté si vous n'avez pas besoin de la fonction de suivi. Il est toutefois vivement recommandé de ne pas désactiver la fonction de suivi des documents. Pour plus d'informations, voir Configuration des propriétés de suivi d'un groupe de serveurs.

    Remarque

    • Il existe une limite de taille pour le suivi des échanges. Lorsque les limites de taille sont dépassées, les performances de BizTalk Server sont diminuées. Pour plus d'informations sur les limites de taille, voir Limite de la taille des documents et des échanges. Les performances se trouvent également affectées par le processus de journalisation des documents. Pour plus d'informations sur la journalisation des documents, voir Définition des propriétés de journalisation de document.
  • Organiser la séquence d'appels du serveur. Il est possible d'établir des priorités entre les parseurs de BizTalk Server lorsqu'un groupe reçoit principalement un certain type de document. BizTalk Server dispose de quatre parseurs qu'il utilise pour analyser les données : XML (Extensible Markup Language), EDIFACT, X12 et fichier plat. Lorsque BizTalk Server reçoit un document, il essaie de l'analyser en utilisant ces trois parseurs dans l'ordre dans lequel ils se présentent. Si une organisation reçoit essentiellement un type de document en particulier, le classement des parseurs doit être modifié de façon à ce que le premier parseur corresponde au type des documents reçus.

Voir aussi

Évolution horizontale des services d'échanges BizTalk


Optimisation des propriétés du serveur

Dans Administration de BizTalk Server, vous pouvez définir les propriétés suivantes dans la boîte de dialogue Propriétés <Serveur> :

  • Créez plusieurs instances de fonctions de réception. Ceci permettra à BizTalk Server 2002 de rechercher les documents à récupérer dans plusieurs fonctions de réception. Pour équilibrer la charge des documents sur plusieurs ordinateurs, placez les fonctions de réception sur des ordinateurs distincts. Chaque emplacement d'interrogation doit être unique et doit disposer d'une fonction de réception distincte. Pour éviter la surcharge des fonctions de réception, l'application métier qui envoie des documents doit distribuer de façon égale les documents entre tous les emplacements d'interrogation.

  • Nombre maximal de threads de fonction de réception autorisé. Vous pouvez choisir le nombre de threads de travail de fonction de réception par processeur que vous voulez pour une fonction de réception. Une quantité trop faible risque de ralentir BizTalk Server car celui-ci utilise des ports de terminaison d'E/S. Une quantité trop élevée n'entraîne pas d'effets graves mais les performances risquent d'être dégradées. Vous pouvez ajuster ce nombre et rechercher la valeur optimale qui convient à leur définition. La valeur recommandée pour le Nombre maximal de threads de fonction de réception autorisé est 4.

  • Nombre maximal de threads de travail autorisé par processeur Vous pouvez spécifier le nombre de threads de travail par processeur pour le côté traitement. En ajustant de façon adéquate le nombre de ces threads de travail, vous pouvez améliorer les performances. Dans Administration de BizTalk Server, cliquez avec le bouton droit sur un serveur dans l'arborescence de la console et cliquez sur Propriétés. Modifiez la valeur par défaut dans la zone Nombre maximal de threads de travail autorisé par processeur. La valeur par défaut est 4. La valeur conseillée est comprise entre 10 et 16, selon le déploiement.


Optimisation des paramètres du Registre

Pour améliorer les performances de BizTalk Server 2002, vous pouvez effectuer les ajustements de paramètres de Registre suivants :

Avertissement

  • Une utilisation incorrecte de l'Éditeur du Registre peut provoquer des problèmes graves pouvant nécessiter la réinstallation de votre système d'exploitation. Microsoft ne peut garantir la résolution des problèmes résultant d'une utilisation incorrecte de l'Éditeur du Registre. L'utilisation de l'Éditeur du Registre est sous votre seule responsabilité.

  • Pour plus d'informations, reportez-vous aux rubriques « Modifier des clés et des valeurs » et « Ajouter et supprimer des informations dans le Registre » dans l'aide de Windows 2000. N'oubliez pas de sauvegarder le Registre avant de le modifier. Si vous utilisez Windows 2000, vous devez également mettre à jour votre disquette de réparation d'urgence.

Toutes les clés suivantes doivent être ajoutées en tant que valeurs DWORD dans \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSVC :

  • NoValidation. Utilisez cette clé de Registre pour désactiver la validation de la spécification. Lorsque la validation de la spécification n'est pas requise (c'est-à-dire lorsque les documents ne sont pas validés par rapport à une spécification pour des paramètres comme les valeurs minimales/maximales, les types de données ou les valeurs requises) affectez une valeur différente de zéro et les données ne seront pas validées. Ceci peut améliorer les performances, mais des données non valides risquent d'être envoyées. Ce paramétrage est approprié pour des serveurs qui reçoivent des documents dont l'organisation contrôle la structure.

  • ParserRefreshInterval. Par défaut défini à 60 000 (60 secondes). Cette valeur indique la fréquence à laquelle BizTalk Server doit contrôler la base de données pour vérifier l'ajout d'un nouveau parseur (c'est la seule propriété de niveau groupe qui est actualisée lorsque le serveur est en fonctionnement). Si aucun parseur ne doit être ajouté, définissez cette valeur à 0 pour que BizTalk Server ne contrôle pas la base de données. Cette valeur sert également à vérifier si les paramètres de groupe ont été modifiés dans la base de données de suivi et si la liste des parseurs a été bouleversée par l'ajout, la suppression ou la réorganisation des parseurs.

  • CacheSize. Utilisez cette clé de Registre pour indiquer la taille que le cache de l'objet de gestion de BizTalk Server est autorisé à atteindre. La valeur par défaut est 20. Par conséquent, dès que le cache de l'objet BizTalk Server dépasse 20 canaux, ports d'échanges, enveloppes ou définitions de document, BizTalk Server doit supprimer certains éléments de la mémoire. Si un serveur dispose d'une quantité importante de mémoire, cette valeur peut être supérieure (supérieure à 20) et BizTalk Server peut stocker davantage d'éléments en mémoire. Cela n'affecte pas les intervalles d'actualisation. BizTalk Server supprime les objets mis en cache et les recharge lorsqu'ils ont expiré.

  • BatchSize. Utilisez cette valeur uniquement avec une fonction de réception Message Queuing. Par défaut la valeur BatchSize est définie à 20. Afin d'améliorer les performances, BizTalk Server lit simultanément jusqu'à 20 éléments dans la file d'attente et envoie ces 20 éléments dans une seule transaction. La réduction de la fréquence à laquelle les données sont enregistrées dans une base de données améliore considérablement les performances. Lorsqu'une étreinte fatale se produit et que BizTalk met fin à la transaction, il doit soumettre à nouveau les éléments. BizTalk Server ne perd pas les documents. Les valeurs supérieures à 20 n'ont pas été testées. Ne définissez pas cette valeur à 0.

Vous pouvez optimiser les paramètres du Registre pour améliorer les performances de la fonction de réception HTTP de BizTalk Server. Toutes les clés doivent être ajoutées en tant que valeurs DWORD dans \HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\BTSSVC\HTTPListener. Pour améliorer les performances, vous pouvez effectuer les ajustements de paramètres de Registre suivants :

  • WorkerThreads. Utilisez cette valeur pour modifier le nombre de threads desservant la réserve de threads. Par défaut, WorkerThreads est défini sur 6. Si le débit des documents pour la fonction de réception HTTP est très élevé, il peut être nécessaire d'augmenter la valeur de WorkerThreads et du paramètre QueueFactor, mentionné plus bas. Lorsque le message d'erreur suivant s'affiche dans le journal des événements, ceci indique qu'il est nécessaire d'augmenter la valeur du paramètre WorkerThreads :

    La fonction de réception HTTP BizTalk <nom> n'a pas pu récupérer de thread dans la réserve de threads.

  • QueueFactor. Coefficient par lequel le nombre de threads de la réserve est multiplié pour déterminer la taille de la file d'attente. En d'autres termes, QueueFactor affecte la taille de la file d'attente utilisée par la réserve de threads. La valeur par défaut de QueueFactor est 3. Si le débit des documents de la fonction de réception HTTP est très élevé, il peut être nécessaire d'augmenter la valeur de WorkerThreads et de QueueFactor. Lorsque le message d'erreur suivant s'affiche dans le journal des événements, ceci indique qu'il est nécessaire d'augmenter la valeur du paramètre QueueFactor :

    La fonction de réception HTTP BizTalk <nom> n'a pas pu envoyer l'opération dans la réserve de threads. Augmentez la longueur de la file d'attente de la réserve de threads à l'aide de la clé de registre « QueueFactor ».

  • AsyncBufferSize. Ce paramètre correspond à la taille de la mémoire tampon pour les lectures IIS asynchrones et à la taille recommandée de la mémoire tampon pour la programmation orientée objet (OOP). La valeur par défaut de AsyncBufferSize est définie sur 4 096 octets. Lorsque le volume des données reçues est supérieur à 48 Ko, la portion des données qui est supérieure aux 48 Ko est lue de manière asynchrone par IIS.

  • MaxSyncFileDropSize. Il s'agit de la taille maximale des données qui seront placées dans un fichier de manière synchrone ; en d'autres termes, cette valeur constitue le seuil au-dessus duquel les données sont enregistrées dans le fichier en petits morceaux. Les données reçues qui sont inférieures à cette valeur sont lues dans la mémoire, puis enregistrées dans un fichier, en une seule fois. En revanche, les données au-delà de ce seuil sont rejetées de manière asynchrone et ne sont donc pas chargées dans la mémoire. Par défaut, MaxSyncFileDropSize est défini sur 1 048 576 octets. Afin d'augmenter les performances de la fonction de réception, vous pouvez diminuer la valeur de MaxSyncFileDropSize. Si les ressources système sont limitées, vous pouvez réduire cette valeur de sorte à limiter l'utilisation de la mémoire par la fonction de réception HTTP.

  • MaxLargeAsyncBuffers. Utilisez cette valeur pour modifier le nombre de mémoires tampons allouées aux données volumineuses. Ces mémoires tampons sont mises en mémoire cache lorsque le volume des données est supérieur à 48 Ko et inférieur à la valeur de MaxSyncFileDropSize pour le rejet dans un fichier. Ces mémoires tampons sont sollicitées lorsque les données sont envoyées directement à BizTalk Server (de manière asynchrone ou synchrone) ou lorsqu'elles sont rejetées dans un fichier et que leur taille est inférieur à la valeur de MaxSyncFileDropSize. Par défaut, la valeur de MaxLargeAsyncBuffers est 18. Vous pouvez la réduire pour limiter la quantité d'utilisation de la mémoire de la fonction de réception HTTP, mais cela nuira aux performances.

  • ConfigRefreshInt. Cette valeur détermine le délai, en millisecondes, d'obtention des données de configuration de la base de données Gestion d'échanges BizTalk. Par défaut, la valeur de ConfigRefreshInt est définie sur 60 000 millisecondes. Le réglage de la valeur de ConfigRefreshInt dépend de la fréquence de mise à jour de la base de données Gestion d'échanges BizTalk.


Optimisation du cryptage

L'utilisation du cryptage ou d'un autre système de sécurité risque de diminuer les performances de BizTalk Server 2002. Lorsque vous utilisez le cryptage, les recommandations suivantes s'appliquent :

  • Augmentez le nombre de serveurs. La séparation et l'optimisant des différents composants de BizTalk Server permet d'améliorer les performances.

  • Utilisez une UC plus rapide. Cette opération augmente la vitesse de traitement.

  • Séparez les fonctionnalités de BizTalk Server. Par exemple, les fonctions de réception et d'envoi peuvent être placées sur des serveurs distincts.

  • Utilisez un réseau privé virtuel (VPN) si les services de transport de fichiers (File), Message Queuing ou HTTP sont utilisés. Lorsqu'un réseau VPN est disponible, le transfert des données est sécurisé. Il n'est pas nécessaire de sécuriser les transactions BizTalk Server lorsque tous les transferts de données réalisés avec les partenaires commerciaux sont sécurisés au moyen d'un réseau VPN.

  • Achetez des cartes d'accélérateur matériel pour le cryptage. Les cartes d'accélérateurs comportent des processeurs dédiés, capables d'éliminer les problèmes de performance dus au cryptage et au décryptage effectués sur l'UC d'un serveur. L'achat de cartes d'accélérateurs est moins onéreux que l'ajout de plusieurs UC.


Optimisation des communications

BizTalk Server fournit des systèmes d'intégration de communications synchrones et de communications asynchrones. BizTalk Server 2002 peut accepter des documents via l'intégration du modèle COM ou via les fonctions de réception du serveur (File, Message Queuing ou HTTP).

D'une façon générale, lorsqu'un document est envoyé à BizTalk Server, il est placé dans une base de données de files d'attente partagée. BizTalk Server interroge la base de données puis traite le document. Ce processus est un processus de communication asynchrone. Il utilise les informations relatives aux points de contrôle de la base de données Microsoft SQL Server en tant que file d'attente pour récupérer les documents en attente de traitement. Cette couche supplémentaire d'abstraction permet au service de transport d'envoyer des documents au serveur BizTalk Server indépendamment du système de transport utilisé pour la livraison des documents.

Un échange de communications synchrones ignore toutes les files d'attente et traite tous les composants requis par le port d'échanges sur la thread qui appelle. Pour les protocoles de communications synchrones, un document de réponse facultatif est renvoyé, s'il est disponible. Cette méthode est valide pour une seule correspondance de canaux et pour un seul port d'échanges (et non pour des listes de distribution).

Lorsque les paramètres définis font que plusieurs canaux se correspondent, un envoi effectué par un mode de communication synchrone renvoie une erreur, ce qui indique que les correspondances entre plusieurs canaux ne sont pas autorisées pour un envoi dans le cadre d'une communication synchrone. Cette méthode peut être utilisée uniquement pour les échanges de documents uniques. Si l'envoi contient plusieurs documents, une erreur est renvoyée pour les envois synchrones, ce qui indique que les envois de documents multiples ne sont pas autorisés. Cette méthode ne prend pas en charge les groupes.

Les communications synchrones ne peuvent pas évoluer. Les communications synchrones utilisent une thread unique pour traiter une transaction et ne peuvent pas faire l'objet d'un équilibrage de charge avec d'autres serveurs du groupe car tout le processus doit s'exécuter sur le serveur qui envoie les documents.

Le système de communications synchrones envoie des documents directement à BizTalk Server pour un traitement immédiat. BizTalk Server bloque le retour pour l'appelant de la méthode IInterchange::SubmitSync jusqu'à ce que le traitement soit terminé, puis une réponse est envoyée à l'appelant. Ce système est disponible uniquement pour la méthode d'intégration basée sur le modèle COM.

Solutions recommandées pour l'optimisation des communications synchrones et asynchrones

Il est hautement recommandé d'utiliser des communications asynchrones pour atteindre des performances et une évolutivité optimales. Les communications asynchrones sont hautement évolutives et offrent un niveau de débit élevé. Les appels de communications synchrones permettent l'émission de réponses presque immédiates vers l'appelant dans des environnements à grands volumes de transactions car chaque appel SubmitSync s'exécute sous une thread distincte.

Cependant, lorsque plusieurs appels sont lancés en même temps, cela signifie que plusieurs threads s'exécutent sur un même serveur et cela dégrade donc les performances générales de BizTalk Server. Microsoft Windows 2000 permet le changement de contextes entre toutes les threads mais cela entraîne des dégradations de performances au niveau de BizTalk Server. Par ailleurs, les situations suivantes entraînent l'échec d'un envoi par communication synchrone mais non l'échec d'un envoi par communication asynchrone :

  • Les critères de transaction correspondent à plusieurs canaux.

  • Un échange contient plusieurs documents.


Conception, test et analyse de l'architecture

Les composants clés de BizTalk Server 2002 incluent les services BizTalk, les bases de données BizTalk Server et les services de transport. Une configuration insuffisante des composants risque de dégrader les performances de tout le système.

Cette section présente des informations sur la définition, le test et l'affinage de l'architecture de BizTalk Server pour optimiser les performances.

Cette section traite des rubriques suivantes :

  • Conception de l'architecture

  • Test et analyse de l'architecture

Voir aussi

Évolution de BizTalk Server


Conception de l'architecture

Avant de mettre en œuvre BizTalk Server 2002 dans un environnement de production, il est fortement recommandé d'implémenter un environnement dans lequel vous pourrez tester les différents facteurs affectant les performances de BizTalk Server ; vous parviendrez ainsi à déterminer l'architecture de BizTalk Server la plus appropriée aux besoins de votre entreprise. Le test des performances est considéré réussi lorsqu'il est effectué avec des processus contrôlés. Il est important de commencer avec un petit nombre de variables puis d'en ajouter progressivement. Ainsi, lorsque les performances commencent à se dégrader, vous pouvez en identifier la cause.

Lorsque vous déterminez l'architecture la plus appropriée à votre organisation, il est important de prendre en compte les facteurs suivants, qui affectent le nombre de documents pouvant être traités par BizTalk Server :

  • Validation des spécifications

  • Composants d'intégration d'application

  • Services de transport

  • Cryptage

  • Services d'orchestration BizTalk

  • Pare-feu

  • Mappage

Vous devez également tenir compte de la taille des documents traités ainsi que de la configuration actuelle du serveur.

Cette section traite des rubriques suivantes :

  • Développement de composants de transaction

  • Identification des services de transport

  • Architecture de départ

Voir aussi

Administration des serveurs et des applications

Services d'orchestration BizTalk

Application Integration Components

Création de spécifications et mappage de données

Utilisation du Mappeur BizTalk

Exécuter les planifications XLANG

Utilisation du Concepteur d'Orchestration BizTalk


Développement de composants de transaction

Pour développer des composants de transaction, les utilisateurs doivent concevoir des transactions et définir des propriétés de transaction pour les processus professionnels. Pour plus d'informations sur la conception des transactions et la définition de leurs propriétés, voir :

  • Conception de processus professionnels

  • Conception de transactions

  • Propriétés des transactions d'un schéma de planification XLANG

Avant de développer des composants de transaction, vous devez déterminer les types de transactions traités par le composant. Dans un environnement de type application à application et/ou entreprise à entreprise (B to B), vous devez déterminer vos besoins en transactions et les profils de transactions. Par exemple, vous pouvez vous trouver dans le cas de figure dans lequel une transaction unique reçoit un bon de commande XML (Extensible Markup Language) personnalisé et le mappe à un bon de commande au format standard EDI, qui sera par la suite traité par une application interne personnalisée.

Ce cas de figure nécessite la création d'une spécification pour le bon de commande XML et d'une spécification pour le bon de commande EDI. Pour créer ces spécifications, utilisez l'Éditeur BizTalk, qui comporte des modèles XML et EDI. Comme ces modèles contiennent tous les enregistrements et les champs potentiellement utiles vous pouvez supprimer ceux dont vous n'avez pas besoin puis sauvegarder les modèles en tant que spécifications finales. Au cours de la conception, lorsque des champs d'une spécification nécessitent une validation, les performances de BizTalk Server 2002 risquent de s'en trouver affectées. Pour plus d'informations sur l'optimisation des spécifications, voir Création et optimisation des spécifications.

En plus de la création d'une spécification, vous devez mapper les données. Étant donné qu'il existe un certain nombre de méthodes pour convertir des données dans des fichiers de mappage (comme les conversions XSLT directes, les fonctoids et les scripts personnalisés) et que toutes ont un impact sur les performances, il est important de les tester. Le test d'une méthode de conversion de données pour la comparer à une autre favorise la dégradation des performances de BizTalk Server due au mapping. Pour plus d'informations, voir Création et optimisation des mapping.

Pour plus d'informations sur les techniques permettant de déterminer la meilleure configuration des transactions, voir Évaluation des performances d'une configuration.

Remarque

  • Il est possible que certaines erreurs renvoyées par le parseur Microsoft XML (MSXML) dans une fonction de script personnalisé ne soient pas transmises au serveur. Les erreurs associées à un document de la file d'attente interrompue peuvent ne pas refléter l'erreur renvoyée dans le script.

Voir aussi

Conception de processus professionnels

Conception de transactions

Identification des services de transport

Propriétés des transactions d'un schéma de planification XLANG


Identification des services de transport

Afin de déterminer comment envoyer et recevoir des données, vous devez savoir si les fonctionnalités suivantes sont utilisées :

  • Transactions B2B

  • Transactions d'application à application

  • Services de transport (envoi et réception)

  • Cryptage

  • HTTPS ou S/MIME

Déterminez si vous avez besoin de services de transport différents en vous basant sur le type de transaction que vous devez traiter. Déterminez si des services de transport uniques sont nécessaires pour les transactions B to B et les transactions d'application à application ou si les mêmes services de transport peuvent être utilisés pour ces deux types de transactions.


Architecture de départ

Afin de planifier correctement une architecture de départ, tenez compte des points suivants :

  • Il est possible d'utiliser un seul serveur avec Microsoft SQL Server et BizTalk Server 2002 pour traiter de faibles volumes de transactions.

  • L'installation de BizTalk Server et de SQL Server sur des machines distinctes peut s'envisager pour des volumes de transactions modérés.

  • Il est possible d'utiliser un service de transport SMTP existant pour envoyer et recevoir des données. Il est recommandé de placer ce service sur un serveur distinct pour ce type de transport.

  • Les services de transport HTTP, Message Queuing ou File peuvent être utilisés pour l'écriture des données sur des unités de disque situées sur d'autres serveurs que le serveur local BizTalk Server, ce qui peut aider à améliorer les performances de BizTalk Server.

L'architecture de départ doit contenir autant de serveurs distincts que possible. En effet, dans une entreprise, une personne peut par exemple administrer des serveurs SMTP et Message Queuing, tandis qu'une autre personne gère les stratégies de sécurité. En créant une architecture de départ, l'objectif est de déterminer le nombre de serveurs nécessaires et le matériel requis par ces serveurs pour traiter le volume de travail estimé. Lorsque vous avez déterminé le nombre de serveurs requis, testez l'architecture de départ.

Voir aussi

Test et analyse de l'architecture


Test et analyse de l'architecture

Avant de tester l'architecture, vous devez déterminer :

  • les composants de l'architecture,

  • les besoins en transactions et leurs profils,

  • quels composants de transaction vous devez développer,

  • les services de transport dont vous avez besoin.

Commencez ce processus en créant un plan de référence qui nécessite les actions suivantes :

  • Configuration des services d'échanges BizTalk, des organisations, des définitions de document, des canaux et des ports d'échanges requis pour traiter les transactions.

  • Configuration des services d'orchestration BizTalk.

  • Installation et/ou configuration des applications COM+, des canaux BizTalk Server 2002, des bases de données ou des files d'attente de message requis pour les planifications XLANG.

Une fois le plan de référence créé, traitez les transactions en utilisant BizTalk Server. Cette opération vous aide à identifier les facteurs qui affectent les performances.

Cette section traite des rubriques suivantes :

  • Évaluation des performances d'une configuration

  • Amélioration de l'architecture

Voir aussi

Conception de l'architecture

Évolution de BizTalk Server


Évaluation des performances d'une configuration

Vous pouvez utiliser l'outil de test des performances de Microsoft Windows 2000 pour tester les performances des services d'échanges BizTalk.

Pour utiliser cet outil de test, dans le menu Démarrer, pointez sur Programmes, pointez sur Outils d'administration, puis cliquez sur Performances. Le Moniteur système, qui fait partie des outils de test des performances, affiche un compteur graphique dont les données changent avec le temps. Plusieurs compteurs doivent être contrôlés selon le composant du système à contrôler. De nombreux livres blancs expliquent comment surveiller les performances de Windows 2000, des services IIS (Internet Information Services), de SQL Server et du service Message Queuing, mais les tableaux suivants répertorient uniquement certains des principaux objets et compteurs à surveiller. Ils fournissent en outre des informations spécifiques sur les objets et les compteurs à contrôler pour déterminer les performances des services d'échanges BizTalk.

Objet | Compteur | Commentaire | Composant concerné
ASP (Active Server Pages) | Requêtes en attente | La file d'attente ne doit pas contenir un nombre important d'éléments, excepté aux heures de pointe. | Services de transport HTTP utilisant des pages .asp
 | Requêtes/s | Indique le volume de requêtes ASP que les services de transport HTTP reçoivent (lorsqu'ils utilisent des pages ASP). Lorsque les fichiers sont déposés sur une page HTTP, ce compteur ne fournit pas d'informations pertinentes. | Services de transport HTTP utilisant des pages .asp
 | Temps d'attente des requêtes | Proche de zéro. | Services de transport HTTP utilisant des pages .asp
Segment de réseau | Octets reçus par seconde/Octets envoyés par seconde | Si ce nombre est proche de la capacité de la connexion et que le processeur et la mémoire sont réquisitionnés de façon modérée, la connexion risque d'affecter les performances. | Tous
Processus, instance Inetinfo | Nombre d'octets privés | Surveille cet objet pour détecter les pertes de mémoire ou une taille de mémoire approchant la RAM maximale disponible. | Service de transport HTTP
Mémoire | Nombre d'octets disponibles | La quantité d'octets disponibles ne doit pas se situer constamment au-dessous de 10 Mo. Lorsque cela est le cas, une pointe d'utilisation de la mémoire entraîne la pagination sur le disque. | Tous
 | Défauts de page/s, Mémoire Entrée de pages/s, Mémoire Lectures de pages/s | Lorsque ces données sont faibles, cela signifie que le serveur doit répondre rapidement aux requêtes. Si elles sont élevées, l'augmentation de la RAM sur le serveur risque d'être nécessaire. | Tous
Disque physique | Lecture disque/s et Écriture disque/s | Lorsqu'elles sont combinées, les données de ces deux compteurs doivent être nettement inférieures à la capacité maximale du périphérique disque. Pour activer ce compteur, dans le menu Démarrer, pointez sur Accessoires, puis cliquez sur Invite de commandes. Sur la ligne de commandes, tapez diskperf –y. Puis, redémarrez l'ordinateur. | SQL Server, services de transport Message Queuing et File.
 | % Temps du disque | Ce compteur doit indiquer une valeur nettement inférieure à 100 pour cent. Si la valeur est supérieure (et elle peut être comprise dans un intervalle allant jusqu'à 1 000 pour cent), ajoutez davantage de disques physiques ou déplacez l'une des bases de données vers un autre serveur. La valeur de ce compteur dépend de votre configuration RAID. | SQL Server, services de transport Message Queuing et File.
 | % Durée d'inactivité | Ce compteur doit indiquer une valeur supérieure à 20 pour cent. S'il indique une valeur inférieure, ajoutez des disques physiques ou déplacer une des bases de données vers un autre serveur. Le compteur % Durée d'inactivité du disque est un meilleur indicateur que le compteur % Utilisation du disque, car il est indépendant de votre configuration RAID. Si un de vos disques est surchargé, vous devez répartir la charge sur d'autres disques physiques ou ajouter des disques à l'unité en surcharge. | SQL Server, services de transport Message Queuing et File.
 | Longueur de la file d'attente du disque actuelle | Ce compteur indique le nombre de requêtes en attente sur le disque au moment où les données de performances sont collectées. Ce compteur doit en moyenne être inférieur à 2 pour indiquer de bonnes performances. | BizTalk Server, SQL Server
SQL Server | Transactions E/S/s | Indique la quantité d'activités effectuée par le serveur SQL. | SQL Server
BizTalk Server | Documents traités/s | Indique la vitesse à laquelle BizTalk Server 2002 recherche les documents dans sa file d'attente de travail et à quelle vitesse il les envoie. | Services d'échanges BizTalk
 | Documents reçus/s | Indique la vitesse à laquelle BizTalk Server envoie les documents à la file d'attente de travail. Cette valeur reflète uniquement le nombre de documents que BizTalk Server a reçus (y compris, les documents dont l'analyse a échoué) et non le nombre de documents que BizTalk Server dans le point de contrôle de la file d'attente partagée. Le nombre de documents stockés dans le point de contrôle de la file d'attente partagée est égal au nombre de documents indiqués dans le compteur Documents traités/s. | Services d'échanges BizTalk
 | Envois synchrones/s, Envois asynchrones/s | Indique à quelle vitesse sont effectués les appels de la méthode Submit et/ou SubmitSync. Parce que chaque échange peut contenir un nombre illimité de documents, ce compteur n'est pas utile pour déterminer les documents traités. Si vous utilisez exclusivement des échanges directs (échanges traités sans analyse), ce compteur est celui que vous devez contrôler pour déterminer les performances en entrée. | Services d'échanges BizTalk
Message Queue | Messages dans la file d'attente | Cette valeur ne doit pas augmenter de façon importante (elle ne doit pas dépasser les 50 000) car la mémoire risque d'être utilisée de façon excessive sur le serveur Message Queue et les performances de tout le système risque d'être dégradées. | Service de transport Message Queuing
Système | Longueur de file d'attente du processeur | Ce compteur indique le nombre de threads en attente d'exécution dans la file d'attente partagée par tous les processeurs du système. Si ce compteur indique en permanence une valeur égale à deux threads ou plus, cela signifie que le processeur participe à la dégradation des performances de tout le système. | Tous
 | Changements de contextes/s | Si le nombre indiqué est élevé sur le serveur BizTalk Server, cela est sans doute dû au fait que les fonctions de réception et d'envoi sont exécutées sur le même serveur. Si tel est le cas, envisagez de séparer les fonctions d'envoi et de réception et de les installer sur des serveurs distincts. | Tous
Processeur | % Temps processeur | Si la valeur indiquée par ce compteur est élevée et que la capacité de la carte réseau et des E/S de disque est dépassée, le processeur dégrade les performances. Sur un ordinateur équipé de plusieurs processeurs, examinez ce compteur pour identifier les déséquilibres. Par ailleurs, si cette valeur peut atteindre 100 pour cent lors des périodes de pointe, elle doit être inférieure pour les utilisations prolongées. Tous les éléments du serveur peuvent évoluer horizontalement. | Tous
Service Web | Récupération ou envoi de requêtes/s | Indique le volume de fichiers reçus par les méthodes HTTP de récupération ou d'envoi. | Service de transport HTTP

Aucun compteur spécifique au service de transport SMTP n'est mentionné car il existe un large éventail de produits SMTP disponibles. Quel que soit le service de transport SMTP utilisé, contrôlez le volume des messages envoyés et reçus de BizTalk Server. En contrôlant les compteurs cités dans ce tableau, vous pouvez identifier les dégradations des performances. Parce que la santé d'un système dépend du fonctionnement de l'ensemble des composants, ne modifiez pas de façon radicale la configuration de votre système en vous basant uniquement sur les faibles performances d'un seul composant.

Les données obtenues par le contrôle des performances sont également utiles à l'identification des symptômes qui risquent de poser des problèmes. Par exemple, une activité de disque élevée peut indiquer que SQL Server enregistre une grande quantité de données sur le disque mais cela peut également indiquer que le système effectue souvent des paginations sur le disque. Une pagination excessive sur le disque indique généralement que la mémoire est insuffisante. Dans ce cas, l'activité du disque est un indice signalant un problème, mais non un problème.

Voir aussi

Évolution de BizTalk Server


Amélioration de l'architecture

En identifiant les zones qui affectent les performances, vous pouvez parfaire l'architecture du système pour rechercher des résultats optimum. Par exemple, le matériel peut avoir besoin de subir une mise à niveau ou plusieurs composants de BizTalk Server 2002 doivent être déplacés vers des serveurs distincts. En outre, il vous faudra peut-être ajuster les paramètres de BizTalk Server. Pour plus d'informations sur l'ajustement des paramètres, voir Optimisation des propriétés du serveur.

Assurez-vous que les modifications sont apportées méthodiquement. Une fois les modifications apportées, comme l'ajout d'UC supplémentaires, la modification d'un paramètre ou la séparation des fonctions et leur installation sur des serveurs distincts, documentez les modifications puis testez la nouvelle configuration pour déterminer si les performances se sont améliorées. Si la nouvelle configuration entraîne une amélioration des performances, vous pouvez poursuivre la modification de la configuration. Cependant, si la nouvelle configuration dégrade les performances, reconfigurez le système pour le restituer dans son état précédent et analysez les données pour déterminer l'origine du problème.

Voir aussi

Évaluation des performances d'une configuration


Maintenance des performances

Afin de maintenir les performances, créez un plan de maintenance permanent qui conserve le bon fonctionnement actuel et garantisse les futures performances de BizTalk Server 2002. Il est fort probable qu'avec le temps BizTalk Server traite un nombre croissant de documents. Même si l'architecture de départ de BizTalk Server a suffi à un bon fonctionnement, si le nombre des transactions augmente avec le temps, elle risque de ne plus suffire au maintien du même niveau de performance, à moins que l'architecture ou la configuration du système soit modifiées. Des pannes matérielles ou des mémoires insuffisantes peuvent également affecter les performances d'un système.

Cette section traite des rubriques suivantes :

  • Création d'un plan de maintenance des performances

  • Utilisation de Microsoft Application Center 2000


Création d'un plan de maintenance des performances

Un plan de contrôle réussi inclut :

  • Un plan détaillé des compteurs à contrôler. Il existe par exemple, plusieurs compteurs du Moniteur système de Windows 200 contenant des seuils valides à contrôler ainsi que plusieurs interprétations possibles des problèmes qui peuvent être signalés par ces seuils. De plus, vous pouvez aussi contrôler les problèmes au niveau application comme vérifier si les requêtes SQL Server doivent renvoyer des données valides ou renvoyer des conditions de problèmes matériels.

  • Identification des processus pour la résolution des problèmes de performance. Il peut s'agir par exemple, de la consignation d'un message dans le journal des événements de Windows 2000, de l'activation d'une notification d'envoi de courrier électronique ou de l'exécution d'une série d'événements par un programme personnalisé.

  • Définition des seuils de performance qui doivent générer une notification. Il est par exemple possible de configurer un outil de contrôle pour l'écriture d'un événement dans le journal des événements de Windows 2000 lorsque la capacité d'utilisation de l'UC atteint 90 pour cent. Cependant, si la capacité d'utilisation de l'UC stagne à 90 pour cent pendant plus de 5 minutes, il est possible de générer l'envoi d'un message électronique. La définition de différentes actions en réponse à différents niveaux de gravité de problèmes dépend de l'outil de contrôle utilisé.

  • Définition des séries d'actions en réponse aux événements enregistrés dans le journal des événements de Windows 2000. Windows 2002, BizTalk Server 2000, SQL Server et les services de transport natifs de Microsoft comme Message Queuing et HTTP enregistrent des événements dans le journal des événements de Windows 2000. Ce journal d'événements contient des informations précieuses qui peuvent signaler la survenue de problèmes sur l'un des serveurs du système BizTalk Server. Si vous traitez ces problèmes suffisamment tôt, vous pouvez éviter une défaillance du système qui pourrait dégrader les performances de tout le système. Un plan de maintenance doit inclure la fréquence à laquelle les journaux sont contrôlés et archivés et inclure également le personnel responsable des tâches à accomplir. Il est possible d'utiliser MOM (Microsoft Operations Manager) pour cumuler les journaux de plusieurs serveurs et les enregistrer dans une base de données afin d'effectuer des analyses consolidées. Pour plus d'informations sur Microsoft Operations Manager, voir À propos de Microsoft Operations Manager.

  • Détermination des outils requis pour le contrôle des performances. L'outil Moniteur système de Windows 2000 examine les compteurs de performance et est capable de prendre des mesures lorsqu'une condition prédéfinie se présente. Pour plus d'informations sur la configuration d'alertes dans le Moniteur système, voir « Définition d'une configuration de contrôle » dans l'aide de Windows 2000. Par ailleurs, Microsoft Application Center 2000 ainsi qu'un certain nombre d'autres outils de tierces parties, met en œuvre cette fonctionnalité avec des fonctions supplémentaires comme la journalisation dans une base de données et les tests au niveau application.


Utilisation de Microsoft Application Center 2000

Microsoft Application Center 2000 contient un outil appelé Health Monitor. Health Monitor remplace la fonctionnalité du journal des événements de Windows 2000 et les outils de contrôle du système. Il permet aux administrateurs d'installer des moniteurs. Ces moniteurs incluent notamment le contrôle de TCP/IP, des seuils de compteurs pour le contrôle des performances, des erreurs consignées dans des journaux d'événements et des événements WMI (Windows Management Instrumentation). Il est possible de configurer des conditions pour ces moniteurs, en fonction de certains critères. Par exemple lorsqu'une UC atteint ou dépasse un seuil de 90 pour cent, une action est effectuée comme la déconnexion d'un serveur ou l'envoi d'un message par courrier électronique à un administrateur. Ces outils peuvent être utilisés pour contrôler et maintenir de façon proactive les performances de BizTalk Server 2002.

Important

  • Ne répliquez pas l'application XLANG Scheduler par défaut ou toute application COM+ qui héberge des planifications XLANG. Lorsque l'équilibrage de charge de composant est utilisé, ces applications COM+ doivent être installées sur chaque serveur. Vous pouvez répliquer les composants COM liés à des planifications XLANG.


Évolution de BizTalk Server

Même après avoir optimisé les performances en corrigeant vos paramètres système et BizTalk Server, il est possible que vous rencontriez toujours des goulots d'étranglement en raison d'une forte sollicitation du processeur. Afin d'améliorer les performances à ce stade, il est nécessaire de faire évoluer votre solution BizTalk Server. Pour faire évoluer votre configuration de BizTalk Server, vous avez le choix entre deux méthodes. L'évolution verticale, qui consiste à augmenter le nombre de processeurs et la quantité de mémoire utilisée par chaque serveur ou l'évolution horizontale, qui consiste à ajouter davantage de serveurs à la configuration actuelle de BizTalk Server.

Il est fortement recommandé de répartir les composants clés sur plusieurs serveurs. Les composants clés de BizTalk Server 2002 sont les suivants :

  • Services BizTalk. Ces services comprennent les services d'échanges BizTalk et les services d'orchestration BizTalk. Pour plus d'informations, voir Services d'échanges BizTalk et Services d'orchestration BizTalk.

  • Bases de données. Il s'agit des bases de données Gestion d'échanges BizTalk, Suivi, de files d'attente partagée et de persistance.

  • Services de transport. Les services de transport comprennent HTTP, File, SMTP et Message Queuing. Chaque composant a ses propres besoins d'évolution.

Cette section traite des rubriques suivantes :

  • Évolution verticale de BizTalk Server

  • Évolution horizontale de BizTalk Server

Voir aussi

Gestion des bases de données BizTalk Server

Gestion de la base de données Gestion d'échanges BizTalk

Persistance

Définition des propriétés de transport

Base de données de files d'attente partagées

Base de données de suivi


Évolution verticale de BizTalk Server

L'utilisation de plusieurs processeurs et d'une mémoire importante permet de faire évoluer BizTalk Server 2002 verticalement. L'évolution verticale de BizTalk Server nécessite un peu moins de serveurs et simplifie la gestion des sites mais elle entraîne des coûts plus élevés que l'évolution horizontale ou que l'amélioration de l'architecture logicielle. De plus, une fois la capacité du matériel existant maximisée, vous devez commencer à faire évoluer le système horizontalement.

Cette section traite des rubriques suivantes :

  • Évolution verticale de BizTalk Server

  • Évolution verticale des bases de données

  • Évolution verticale des services de transport


Évolution verticale de BizTalk Server

Pour faire évoluer BizTalk Server 2002 verticalement, il est recommandé d'effectuer les opérations suivantes :

  • Augmenter la taille du processeur (utiliser par exemple un Pentium III et les dérivés du processeur Xeon avec des mémoires cache de second niveau).

  • Utiliser des serveurs SMP (Symmetric multiple processing) qui hébergent jusqu'à huit unités centrales.

  • Utiliser un système disque rapide.

  • Diminuer les E/S de fichiers et les goulots d'étranglement du réseau. Pour plus d'informations, voir Réglage des performances de l'architecture de BizTalk Server.

Recommandations pour l'évolution verticale de BizTalk Server

Pour obtenir des performances optimales avec BizTalk Server, la configuration suivante est recommandée :

  • Système multiprocesseur Xeon PIII (avec la vitesse la plus élevée en MHz pour des performances maximales), qu'il est possible de faire évoluer à huit UC.

  • Cache de second niveau (L2) de 1 à 2 Mo pour le processeur (pour augmenter les performances d'analyse).

  • 1 Mo de RAM (davantage si une organisation traite des documents de plusieurs méga-octets).

  • Plusieurs cartes réseau de 100 Mbits/s (mégabits par seconde) ou plus, connectées à des ports de commutateur 100 Mbits/s pour augmenter le débit d'E/S du réseau.

  • Plusieurs disques et plusieurs contrôleurs pour les opérations de fichier et de journalisation du Coordinateur de transactions distribuées (DTC, Distributed Transaction Coordinator) et du système Message Queuing. Enregistrer les opérations de journalisation DTC sur un serveur distant central afin de décharger la contention d'E/S de fichiers sur le serveur BizTalk Server local.

  • Configurer les disques en RAID 0 et RAID 1 pour optimiser les performances de la base de données de files d'attente partagée et du service Message Queuing.

  • Utiliser des cartes interface réseau multi-résidentes NIC sur les serveurs BizTalk Server pour distinguer les processus HTTP des processus Microsoft SQL Server™ dédiés des bases de données de files d'attente partagées et Gestion d'échanges BizTalk. Enfin, envisager d'utiliser un réseau commuté afin de réduire le trafic vers la carte réseau.

  • Ces recommandations supposent que BizTalk Server fonctionne sur un serveur dédié. Si les services BizTalk partagent le serveur avec d'autres services d'applications, il est conseillé d'utiliser du matériel supplémentaire.


Évolution verticale des bases de données

Pour faire évoluer les bases de données verticalement, vous devez déterminer la configuration nécessaire pour le disque. La configuration du disque se détermine en fonction du débit, de la reprise après incident et des coûts.

Le tableau suivant identifie les options disponibles et propose une comparaison.

Niveau RAID | Coût | Pourcentage d'utilisation effective du disque | Vitesse | Tolérance de panne
0 (Agrégat par bandes) | Faible | 100 | Rapide | Faible
1 (Fonctionnement en miroir) | Élevé | 50 | Moyenne | Élevée
5 (Agrégat par bandes avec parité) | Modéré | L'espace disque effectif est l'espace total de tous les disques de l'ensemble moins 1 (pour la parité) | Faible | Modérée (uniquement car les performances se dégradent lorsqu'un disque est défaillant)
0 + 1 (Mise en miroir d'un groupe de disques à bandes) | Élevé | 50 | Rapide | Élevée

Pour obtenir des performances optimales, il est recommandé d'installer un contrôleur RAID (Redundant Array of Independent Disks) équipé d'une UC rapide et d'une grande quantité de mémoire RAM non volatile. Vous pouvez aussi combiner plusieurs niveaux RAID pour obtenir les performances recherchées. Par exemple, le niveau RAID 0 permet les meilleures performances mais ne fournit pas la tolérance de panne. Le niveau RAID 1 permet la meilleure tolérance de panne mais ne permet pas les meilleures performances (l'écriture des données se fait sur un seul disque et non sur plusieurs disques, simultanément). Pour obtenir des performances optimales, vous pouvez combiner les niveaux RAID 1 et RAID 0 en mettant en miroir un groupe de disques de niveau 0.

Remarques

  • Le niveau RAID 5 n'atteint pas la vitesse et le coût des autres niveaux RAID. Ce niveau apporte des avantages clés mais l'écriture des données sur les disques se fait plus lentement qu'avec le niveau RAID 0 ou RAID 1.

  • Quelle que soit la stratégie adoptée, le nombre de contrôleurs de disques est une donnée critique. Vous pouvez améliorer nettement les performances générales en utilisant un disque par contrôleur. Lors de la configuration des disques, il est important de penser à une utilisation efficace des canaux de disques. Les canaux de disques sont des disques qui partagent le même contrôleur. Il est possible de configurer ces disques comme des disques autonomes ou de les configurer comme des disques faisant partie d'un arrangement de disques. Par exemple, si vous disposez d'un serveur équipé de 10 disques, soit 5 disques dans deux arrangements de disques, et que chaque arrangement de disques est connecté à son propre contrôleur, vous disposez dès lors de 2 canaux de disques.

Idéalement, il est préférable de placer les bases de données Gestion d'échanges BizTalk, de suivi, de files d'attente partagées et de persistance dans des canaux de disques distincts, car ceci permet d'améliorer l'accès à chacune d'elles. Cependant, si l'environnement du système de votre organisation impose l'installation des bases de données sur des serveurs séparés, il est important de comprendre l'utilisation de chacune d'elles lorsque vous planifiez le scénario de déploiement.

  • La base de données Gestion d'échanges BizTalk contient toutes les données de configuration, telles que les données relatives aux groupes de serveurs des organisations, aux serveurs, aux canaux et aux ports d'échanges pour BizTalk Server. Ces données sont lues et mises en cache dans la mémoire Microsoft SQL Server. Cette base de données reçoit les dernières opérations des quatre bases de données et peut être installée, si nécessaire, sur le même canal de disques que l'une des trois autres bases de données.

  • La base de données de files d'attente partagées gère les données pour toutes les files d'attente. Tous les documents qui utilisent un mode de communication asynchrone sont transmis et stockés dans la base de données de files d'attente partagées. Lorsque BizTalk Server est prêt à traiter un document, celui-ci est retiré de la base de données de files d'attente partagées pour être traité. Du fait que cette base gère toutes les transaction, les données sont enregistrées et lues fréquemment à partir de la base de données de files d'attente partagées.

  • La base de données de suivi permet de suivre les documents qui transitent par le serveur, individuellement ou dans des lots. Cette base de données contient les données et les informations de journalisation les concernant. Par conséquent, les données sont souvent enregistrées dans la base de données de suivi mais elles y sont rarement lues.

  • La base de données de persistance d'orchestration par défaut stocke la structure des planifications XLANG, les données relatives à la progression des instances de planification XLANG activées et les messages envoyés ou reçus lorsqu'une instance de planification XLANG débute ou termine une transaction, lorsque le système est arrêté ou lorsque l'instance d'une planification XLANG est mise en attente.

    Remarque

    • Les bases de données dont l'utilisation est la plus intensive sont les bases de données de suivi et de files d'attente partagées. Il est recommandé de les répartir sur deux serveurs pour optimiser l'équilibrage de charge.

Optimisation recommandée pour l'évolution verticale des bases de données

Tenez compte des données suivantes pour obtenir des performances optimales avec les bases de données BizTalk Server :

  • Système multiprocesseur Xeon PIII (avec la vitesse la plus élevée en MHz pour des performances maximales), qu'il est possible de faire évoluer à huit UC.

  • 1 Go de RAM (davantage si une organisation traite des documents de plusieurs méga-octets).

  • Optimisez les bases de données Microsoft SQL Server sous-jacentes et les journaux en vous basant sur les meilleures méthodes adoptées pour les bases de données standard. Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

  • Si vous prévoyez tout d'abord d'effectuer uniquement un petit nombre de transactions, vous pouvez installer les bases de données sur le même canal d'E/S de disque. Au fur et à mesure que davantage de transactions sont traitées, ajoutez des disques et/ou des contrôleurs sur un serveur et déplacez les bases de données sur ces nouveaux canaux d'E/S de disque. En outre, il est possible de déplacer une base de données sur un nouveau serveur. Pour plus d'informations sur l'évolution horizontale des bases de données, voir Évolution horizontale des bases de données.

  • Si le taux d'utilisation de l'UC dépasse 80 pour cent, ajoutez des UC supplémentaires.

  • Si la file d'attente du disque est en moyenne supérieure à 1 ou si l'utilisation du disque en E/S approche 100 pour cent, ajoutez des disques physiques supplémentaires.

  • Installez la base de données sur son canal d'E/S de disque dédié.

  • Achetez des disques avec les temps d'accès les plus rapides et des contrôleurs avec le débit le plus élevé.

  • Envisagez d'utiliser le niveau RAID 0 et de le mettre en miroir pour disposer de la tolérance de panne.

Pour optimiser la base de données Gestion d'échanges BizTalk :

  • Installez la base de données sur son serveur ou sur son canal de disque dédié.

  • Si une organisation traite un volume important de données, vous devez envisager d'installer cette base de données sur son propre canal d'E/S de disque de façon à ne pas nuire aux performances des bases de données de files d'attente partagées et de suivi.

Pour optimiser la base de données de suivi :

  • Ajoutez plus de disques physiques et davantage d'espace disque par rapport à l'existant pour la base de données de files d'attente partagées.

  • Évaluez la taille moyenne des documents pour une seule transaction. Multipliez la taille du document par la fréquence à laquelle le document est consigné dans la base de données de suivi. Le résultat de ce calcul donne une estimation du volume de l'espace de stockage requis par document dans la base de données de suivi. Multipliez la valeur de l'espace de stockage des documents par la valeur du débit requis pour déterminer l'espace qui est nécessaire et ainsi éviter la saturation de la base de données de suivi. Assurez-vous que la base de données de suivi dispose de suffisamment d'espace pour accepter la journalisation d'un document de taille moyenne.

  • Installez cette base de données sur son propre canal d'E/S de disque car un volume important de données y est enregistré. Dans les environnements dans lesquels le volume des transactions est massif, il est particulièrement important de disposer d'un canal d'E/S de disque distinct.

  • Sélectionnez la quantité minimale de suivi nécessaire à votre système.

    Remarque

    • Il existe des limites de taille pour le suivi des échanges et des documents qui, si elles sont dépassées, nuisent grandement aux performances de BizTalk Server. Pour plus d'informations sur les limites de taille, voir Limite de la taille des documents et des échanges.

Pour optimiser la base de données de persistance d'orchestration :

  • Les données étant enregistrées et lues dans cette base de données de façon fréquente, il est conseillé de disposer d'un canal d'E/S de disque dédié pour cette base de données. Il est si possible préférable d'acheter des disques avec les temps d'accès les plus rapides et des contrôleurs avec le débit le plus élevé. Envisagez d'utiliser le niveau RAID 0 et de le mettre en miroir pour disposer de la tolérance de panne.

  • Si la capacité de l'UC dépasse 80 pour cent, ajoutez des UC supplémentaires.

  • Si la file d'attente du disque est en moyenne supérieure à 1 ou si l'utilisation du disque en E/S approche 100 pour cent, ajoutez des disques physiques supplémentaires.

Voir aussi

Évolution de BizTalk Server


Évolution verticale des services de transport

BizTalk Server 2002 prend en charge quatre services de transport. Il est possible de faire évoluer verticalement chacun de ces services de transport :

  • HTTP/HTTPS

  • File

  • SMTP

  • Message Queuing

Cette section traite des rubriques suivantes :

  • HTTP/HTTPS (évolution verticale)

  • File (évolution verticale)

  • SMTP (évolution verticale)

  • Message Queuing (évolution verticale)


HTTP/HTTPS (évolution verticale)

Réception

La fonction de réception HTTP envoie des documents au système de fichiers ou directement à BizTalk Server en appelant l'objet Interchange de BizTalk Server IInterchange::Submit() ou SubmitSync(). Cette fonction prend en charge les deux protocoles de transport HTTP et HTTPS. Elle gère une réserve de threads configurables qui est utilisé pour les documents envoyés.

Dans les environnements avec de grands volumes, si SSL (secure sockets layer, également appelé HTTPS) est utilisé pour recevoir les documents, les performances sont dégradées en raison du traitement du décryptage. Les besoins en sécurité d'une organisation rendent parfois nécessaire le cryptage des données avec HTTPS. Ce niveau de sécurité supplémentaire risque d'affecter les performances de BizTalk Server.

Envoi

L'envoi de documents à l'aide du service de transport HTTP est un sujet qui appelle les mêmes questions de sécurité et de performance que la réception de documents avec la fonction de réception HTTP.

Optimisation recommandée pour l'évolution verticale de HTTP/HTTPS

Pour optimiser les performances de la fonction de réception HTTP et du service de transport HTTP/HTTPS et ainsi améliorer les performances de BizTalk Server :

  • Augmentez la vitesse de l'UC nécessaire à BizTalk Server (afin de répondre aux besoins supplémentaires pour l'envoi ou la réception des documents) et ajoutez des UC supplémentaires jusqu'à atteindre le niveau de performance voulu.

  • Appliquez les méthodes conseillées lorsque vous utilisez des pages ASP avec le service d'envoi HTTP/HTTPS. Pour plus d'informations sur l'optimisation des pages ASP et des services IIS (Internet Information Services), consultez le site Web dédié à l'aide de Microsoft Internet Information Services Help (localhost/iisHelp) et cliquez sur Guide Active Server Pages.


File (évolution verticale)

Réception

Bien que les performances soient élevées lorsqu'une fonction de réception de fichier est utilisée pour les transactions entreprise à entreprise (B to B, business-to-business), cette fonction n'est pas sécurisée pour les transactions basées sur Internet et elle n'est donc pas largement utilisée. Cependant, dans le cadre des transactions d'application à application au sein d'une entreprise, la fonction de réception de fichier peut assurer des performances optimales sans nuire à la sécurité. De plus, il est possible d'utiliser une fonction de réception de fichier avec des partenaires commerciaux externes, à condition de l'associer à une autre fonction de réception telle que SMTP ou HTTP. La fonction de réception SMTP ou HTTP peut accepter un document émis par un partenaire commercial, en utilisant les services HTTPS ou S/MIME (Secure Multipurpose Internet Mail Extensions) et enregistrer le fichier dans un répertoire de système de fichiers externe. BizTalk Server peut ensuite utiliser une fonction de réception de fichier pour recevoir le document. Cette combinaison de services de transport peut ne pas augmenter les performances, mais permet une plus grande flexibilité et une plus grande sécurité.

Remarque

  • L'utilisation de S/MIME dégrade considérablement les performances de BizTalk Server.

Envoi

Les questions relatives à la sécurité et aux performances concernant une fonction de réception de fichier s'appliquent également à l'envoi des documents avec un service de transport File.

Optimisation recommandée pour l'évolution verticale de la fonction de réception de fichier et du service de transport File

Pour optimiser les performances de la fonction de réception de fichier et du service de transport File et ainsi améliorer les performances du serveur BizTalk Server :

  • Utilisez un répertoire de fichiers local de préférence à un répertoire de fichiers distant pour réduire les temps de latence du réseau.

  • Utilisez des arrangements de disques pour obtenir des débits élevés. Pour plus d'informations sur les compromis entre la vitesse des arrangements de disques et la redondance, voir Évolution verticale des bases de données.

  • Avec la fonction de réception de fichier, utilisez des contrôleurs de disque dotés d'une mémoire cache de type Lecture.

  • Avec le service de transport File, utilisez des contrôleurs de disque dotés d'une mémoire cache non volatile de type Écriture.


SMTP (évolution verticale)

Réception

Aucune fonction de réception SMTP native n'est intégrée à BizTalk Server 2002. Une fonction de réception SMTP permet de recevoir des documents via un système basé sur les événements et de les envoyer à BizTalk Server. Si une fonction de réception SMTP existe, BizTalk Server accepte les documents codés au format MIME/SMIME et les prépare en vue de leur traitement.

Envoi

Les questions relatives à la sécurité et aux performances abordées dans les sections traitant des services S/MIME entrants et des services HTTP/HTTPS sortants s'appliquent aussi à l'envoi de documents à l'aide du service de transport SMTP. Si un canal utilise le service SMTP comme service de transport dans un port d'échanges ou un port, le serveur de traitement traite le document et l'envoie à l'application destinataire.

Remarque

  • Les performances de BizTalk Server sont fortement dégradées lorsque des certificats numériques sont nécessaires pour codés les documents sortants au format S/MIME.

Optimisation recommandée pour l'évolution verticale de SMTP

Pour optimiser les performances du service SMTP et ainsi améliorer les performances du serveur BizTalk Server :

  • Le niveau de performance atteint dépend grandement du service SMTP utilisé pour la réception des documents. Une organisation peut disposer d'un serveur SMTP qu'elle utilise pour remplir cette fonction. Cependant, si aucun serveur SMTP n'est disponible et que l'organisation choisit d'utiliser Microsoft Exchange Server ou le système d'échanges d'une tierce partie, il est probable qu'il faille installer beaucoup plus de matériel sur le serveur pour maintenir un niveau de performance approprié pour BizTalk Server. Le serveur SMTP doit être capable d'appeler un système basé sur les événements, lequel doit pouvoir à son tour envoyer des documents à BizTalk Server.

  • Si une organisation choisit d'exécuter BizTalk Server sur un serveur SMTP, ce choix va avoir un impact sur les performances de l'UC. Pour minimiser l'impact sur les performances, utilisez une UC plus rapide.

  • Si une organisation utilise S/MIME, les performances de BizTalk Server se trouvent fortement dégradées. Afin de réduire l'impact sur les performances générales de S/MIME sur BizTalk Server, utilisez des UC plus rapides.


Message Queuing (évolution verticale)

Réception

Le service Message Queuing utilise généralement un volume important d'E/S disque pour recevoir et envoyer des messages. Le service Message Queuing est transactionnel, ce qui est fortement recommandé pour l'amélioration de la tolérance de panne. Cependant, il est transactionnel uniquement sur un serveur local. Si vous utilisez le service Message Queuing pour améliorer la tolérance de panne, vous devez installer des disques en quantité suffisante sur chaque serveur BizTalk Server afin de pouvoir traiter les E/S de disque en plus grand nombre.

Envoi

L'envoi de documents avec Message Queuing génère les mêmes questions de sécurité et de performance que la réception de documents avec Message Queuing.

Recommandations d'optimisation pour l'évolution verticale de Message Queuing

Pour optimiser les performances du service Message Queuing et ainsi améliorer les performances du serveur BizTalk Server :

  • Utilisez des files d'attente transactionnelles (vous devez utiliser des files d'attente locales sur BizTalk Server plutôt que des files d'attente distantes pour permettre la réception sur des files d'attente transactionnelles) ainsi qu'un canal d'E/S de disque rapide. Les files d'attente locales n'ont pas besoin d'interroger Microsoft® Active Directory™, ce qui n'est pas le cas des files d'attente de messages publiques. Par conséquent, la lecture et l'enregistrement des données dans les files d'attente locales entraînent de meilleures performances. Il est possible d'utiliser des files d'attente locales non transactionnelles pour obtenir de meilleures performances. Cependant, les files d'attente locales non transactionnelles n'offrent pas la même fiabilité que les files d'attente transactionnelles. De la mémoire est également requise en quantité supplémentaire.

    Remarque

    • Pour plus d'informations sur la façon de définir les besoins en matériel pour le service Message Queuing, voir « Sélection du matériel du serveur Message Queuing » dans l'aide de Windows 2000 Server.
  • Le volume maximal accepté pour les messages Message Queuing est de 4 Mo. Si les documents dépassent les 4 Mo, il est impossible d'utiliser le service de transport Message Queuing. La limite pour la taille des documents de la base de données de persistance d'orchestration est de 2 Mo.

  • Le service Message Queuing sollicite la base de données de façon intensive si la journalisation est utilisée. Assurez-vous que les règles standard pour l'optimisation des bases de données sont appliquées lors de la configuration des services de transport Message Queuing.

  • Pour maximiser le débit, séparez les données et les journaux et utilisez plusieurs disques et plusieurs contrôleurs.


Évolution horizontale de BizTalk Server

Une implémentation réussie de BizTalk Server 2002 fait appel à la fois à une stratégie verticale et horizontale pour optimiser les services. En effet, l'évolution verticale permet de réduire le nombre de serveurs requis, tandis que l'évolution horizontale apporte les avantages suivants :

  • Performances accrues. Les performances dépassent les performances coûteuses qui pourraient être obtenues sur un seul serveur.

  • Tolérance de panne sur le serveur. Du fait que plusieurs serveurs d'un groupe se partagent la charge de travail, lorsque l'un d'eux tombe en panne, les autres serveurs du groupe peuvent reprendre la charge.

  • Séparation et optimisation des différents composants. Les performances des services BizTalk, des bases de données et des services de transport peuvent être augmentées.

L'évolution horizontale du matériel réduit davantage les coûts que l'évolution verticale. Cependant, comme la gestion des sites est de plus en plus complexe, vous devez commencer par une évolution verticale pour votre organisation.

Cette section traite des rubriques suivantes :

  • Évolution horizontale des services d'échanges BizTalk

  • Évolution horizontale des bases de données

  • Évolution horizontale des services de transport

Voir aussi

Évolution de BizTalk Server


Évolution horizontale des services d'échanges BizTalk

Il est possible de faire évoluer les services d'échanges BizTalk horizontalement en utilisant des groupes de serveurs. Les groupes de serveurs sont des collections des serveurs individuels faisant l'objet d'une gestion, d'une configuration et d'une surveillance centralisées. Pour plus d'informations sur l'ajout et la configuration des groupes de serveurs, voir Groupes et serveurs.

Les serveurs membres d'un même groupe de serveurs partagent :

  • une base de données de files d'attente partagée qui contrôle l'activité dans le moteur d'état BizTalk Server,

  • une base de données de suivi qui consigne dans des journaux l'activité des documents et crée des rapports,

  • une base de données Gestion d'échanges BizTalk qui stocke les données de configuration,

  • des fonctions de réception,

  • tous les composants nécessaires au serveur au moment de l'exécution, comme les composants de transport et les composants d'intégration d'application , ainsi que la conversion de données, le cryptage des données et la signature.

Un groupe de serveurs BizTalk Server ne fournit pas de système d'équilibrage de la charge qui permet la réception des documents entrants ou qui facilite l'envoi des documents en utilisant un modèle d'objet DCOM (Distributed Component Object Model). En revanche, vous pouvez utiliser le service NLB (Network Load Balancing) avec la fonction de réception ou le service CLB (Component Load Balancing) pour répartir la charge de travail parmi les différents serveurs. BizTalk Server prend en charge le traitement des tâches sur plusieurs serveurs. Une fois le document transmis à une base de données de files d'attente partagées, il peut être traité, sérialisé et envoyé par n'importe quel serveur dans le groupe. Cette fonctionnalité autorise un serveur dans un groupe à envoyer un document qu'un autre serveur traite.

Une organisation peut utiliser plusieurs groupes de serveurs pour :

  • Regrouper des services de transport similaires (HTTP ou File).

  • Améliorer la sécurité.

  • Classer les partenaires commerciaux en catégories.

Vous pouvez également utiliser des groupes de serveurs pour éviter la duplication des configurations des organisations, des canaux et des ports d'échanges. Les groupes de serveurs partagent des bases de données. Les données de configuration pour les organisations, les groupes, les canaux et les ports d'échanges sont stockées dans la base de données Gestion d'échanges BizTalk. Par conséquent, plusieurs groupes de serveurs BizTalk Server peuvent partager la même base de données Gestion d'échanges BizTalk.

Remarque

  • Si plusieurs groupes de serveurs BizTalk Server partagent la même base de données Gestion d'échanges BizTalk, chaque groupe doit disposer de ses propres bases de données de files d'attente partagées, de suivi et bases de données de persistance d'orchestration qui sont partagées par tous les membres du groupe.

Recommandations pour l'évolution horizontale de BizTalk Server

Pour optimiser les performances de BizTalk Server, vous pouvez séparer les services de transport et les fonctions de réception et établir une priorité entre les parseurs.

Séparer les services de transport et les fonctions de réception

En séparant les services de transport et les fonctions de réception pour les groupes de serveurs BizTalk Server, vous pouvez obtenir des performances plus élevées. Le niveau de performance atteint dépend du nombre de documents traités et de la complexité de la conversion des données. BizTalk Server fournit des pools de threads distincts pour la réception et le traitement des données. La séparation des services de transport et des fonctions de réception permet de réduire le changement de contextes en éliminant le besoin, pour le serveur, d'alterner entre les opérations d'envoi et de réception.

Tous les serveurs traitent des éléments de travail par défaut, ce qui implique la récupération des travaux dans la base de données de files d'attente partagées, leur traitement et leur envoi au moyen du service de transport que le canal doit utiliser (traiter les travaux sortants). Ce processus diminue les performances générales de l'UC lorsque vous utilisez conjointement des fonctions de réception et des services de transport car un changement de contextes doit être effectué. Si vous utilisez plusieurs serveurs, vous pouvez éviter cette dégradation en configurant au moins un serveur pour qu'il fonctionne comme service de réception. Afin de configurer un serveur de façon à ce qu'il se comporte comme un service de réception, vous pouvez utiliser la console Administration de BizTalk Server pour désactiver la fonction Participer au traitement de l'élément de travail et créer une nouvelle fonction de réception pour le serveur.

Pour plus d'informations sur la désactivation de la fonction Participer au traitement de l'élément de travail, voir Configuration d'un serveur dans un groupe. Pour plus d'informations sur la définition d'une fonction de réception de fichier, voir Ajout d'une fonction de réception de fichier. Pour plus d'informations sur la définition d'une fonction de réception Message Queuing, voir Ajout d'une fonction de réception Message Queuing. Pour plus d'informations sur la définition d'une fonction de réception HTTP, voir Ajout d'une fonction de réception HTTP.

Remarque

  • Pour le service Message Queuing, seules des lectures transactionnelles peuvent être effectuées à partir de files d'attente locales et il n'est donc possible qu'à un seul serveur de lire à partir de cette file d'attente.

BizTalk Server reçoit des documents si l'une des conditions suivantes est présente :

  • Une fonction de réception a été configurée sur le même serveur que le serveur BizTalk Server.

  • Un processus a été configuré pour appeler la méthode Submit sur le serveur sur lequel BizTalk Server a été installé.

Établir une priorité entre les parseurs

En établissant des priorités entre les parseurs, vous pouvez optimiser les performances de BizTalk Server. BizTalk Server fournit quatre parseurs de données :

  • XML (Extensible Markup Language)

  • EDIFACT

  • X12

  • fichier plat

Lorsque BizTalk Server reçoit un document, il essaie de l'analyser dans l'ordre de la liste précédente. En déplaçant les parseurs les plus fréquemment utilisés en haut de la liste, vous pouvez améliorer les performances de BizTalk Server. Pour plus d'informations sur la configuration de l'ordre des parseurs, voir Configuration de l'ordre des parseurs d'un groupe de serveurs.

Cette section traite de la rubrique suivante :

  • Équilibrage de charge de composant


Équilibrage de charge de composant

L'équilibrage de charge de composant (CLB, Component Load Balancing) est une fonctionnalité de Microsoft Application Center 2000. Pour utiliser cette fonctionnalité, Application Center 2000 doit être installé sur le même serveur que Microsoft BizTalk Server 2000. La fonctionnalité CLB permet aux organisations d'équilibrer la charge du composant BizTalk.Interchange.1 dans le gestionnaire de services COM+. La fonctionnalité CLB est un système d'équilibrage de charge pour les composants COM. Dans un environnement BizTalk Server, la fonctionnalité CLB permet à un service de transport HTTP d'utiliser la méthode Submit pour appeler un cluster de serveurs au lieu d'appeler un seul serveur (pour l'application émettrice, l'utilisation de la méthode Submit pour appeler le cluster apparaît toujours comme l'envoi à un nœud).

Par exemple, si vous utilisez une application personnalisée, un envoi unique peut être dirigé vers n'importe lequel des serveurs du cluster. Sans la fonctionnalité CLB, les applications personnalisées doivent être configurées de façon à diriger les envois vers l'un des trois serveurs. Dans ce dernier scénario, si le serveur vers lequel l'application personnalisée a été configurée pour diriger les envois tombe en panne, l'application personnalisée devra être reconfigurée pour la transmission des documents vers un autre serveur du groupe de serveurs BizTalk Server.

Important

  • La fonctionnalité CLB peut être utilisée uniquement pour activer les planifications XLANG. Toutes les planifications XLANG doivent arriver sur le serveur sur lequel elles ont démarré.


Évolution horizontale des bases de données

Pour faire évoluer les bases de données horizontalement, installez chaque base de données sur son propre serveur. Dans les environnements avec de grands volumes de transactions, l'installation d'une base de données sur un serveur unique permet d'allouer des ressources d'UC, d'E/S de disque et de la mémoire du serveur à la base de données appropriée.

Optimisation recommandée pour l'évolution horizontale des bases de données

Pour optimiser les performances des bases de données de BizTalk Server :

  • Utilisez des processeurs Xeon à la place de processeurs Pentium III.

  • Installez chaque base de données sur un serveur distinct équipé d'une UC plus rapide. N'installez pas les bases de données sur le même serveur que BizTalk Server 2002.

  • Installez une base de données de persistance sur chaque serveur de votre configuration.

  • Utilisez plusieurs cartes réseau de 100 Mbits/s (mégabits par seconde) ou plus, connectées à des ports de commutateur 100 Mbits/s pour augmenter le débit d'E/S du réseau.

  • Si une organisation traite un petit nombre de documents, utilisez une base de données qu'il est facile de mettre à niveau. Si les besoins en traitement augmentent, déplacez la base de données de files d'attente partagée, la base de données de suivi et la base de données de persistance d'orchestration sur leurs propres serveurs.

  • Pour la base de données de suivi, installez du matériel de réseau rapide pour compenser le volume important des données non compressées échangées entre BizTalk Server et la base de données.

  • Lorsque vous procédez à l'évolution horizontale de ces bases de données, n'oubliez pas qu'il est plus difficile de déplacer la base de données Gestion d'échanges BizTalk, étant donné qu'elle contient toutes les informations de configuration de base de BizTalk Server, outre les informations utilisées par les serveurs pour les fonctions de réception et les emplacements des autres bases de données, entre autres. En effet, pour déplacer la base de données Gestion d'échanges BizTalk, il faudrait créer un processus personnalisé pour répliquer toutes les informations dans la nouvelle base de données, puis modifier manuellement chaque serveur de sorte qu'il pointe vers le nouvel emplacement. Il est donc fortement recommandé de veiller à ce que le serveur sur lequel est stockée la base de données Gestion d'échanges BizTalk dispose de suffisamment d'espace disque et de mémoire pour mettre la configuration dans le cache au fur et à mesure que les besoins en traitement des documents augmentent.

Voir aussi

Évolution de BizTalk Server


Évolution horizontale des services de transport

BizTalk Server prend en charge quatre services de transport. Il est possible de faire évoluer horizontalement chacun de ces services de transport :

  • HTTP

  • File

  • SMTP

  • Message Queuing

Cette section traite des rubriques suivantes :

  • HTTP/HTTPS (évolution horizontale)

  • File (évolution horizontale)

  • SMTP (évolution horizontale)

  • Message Queuing (évolution horizontale)


HTTP/HTTPS (évolution horizontale)

Réception

Il est possible de faire évoluer horizontalement la fonction de réception HTTP en utilisant un cluster Web. Par exemple, un partenaire commercial a la possibilité d'envoyer un document à une seule adresse mais l'envoi peut être routé vers n'importe quel serveur du cluster. Les clusters Web représentent l'une des caractéristiques du service d'équilibrage de charge de réseau (NLB, Network Load-Balancing) inclus dans Microsoft Windows 2000 Advanced Server. Pour plus d'informations sur la configuration de la fonctionnalité NLB, reportez-vous à l'aide de Windows 2000 Advanced Server.

Pour améliorer les performances de BizTalk Server 2002, vous pouvez configurer un cluster Web afin qu'il répartisse les documents entrants parmi les serveurs configurés avec les fonctions de réception HTTP. Ensuite, la fonction de réception HTTP appelle la méthode Submit pour placer les documents reçus dans un répertoire de fichiers ou une file d'attente de messages.

Envoi

L'évolution horizontale du service de transport HTTP/HTTPS pour les envois est une fonctionnalité propre à l'utilisation de plusieurs serveurs dans un groupe configuré pour participer au traitement de l'élément de travail. Il est impossible de séparer la fonctionnalité d'envoi HTTP/HTTPS du serveur BizTalk Server qui traite les documents car la fonctionnalité d'envoi est utilisée sur tous les serveurs du groupe configuré pour participer au traitement des éléments de travail.

Optimisation recommandée pour l'évolution horizontale du service HTTP/HTTPS

Pour optimiser le service de transport HTTP/HTTPS et ainsi améliorer les performances du serveur BizTalk Server :

  • Créez un groupe de serveurs BizTalk Server dont la charge est équilibrée. Cette opération améliore beaucoup les performances du service de transport de réception HTTP/HTTPS car elle permet la redondance de l'évolution horizontale. Pour plus d'informations sur l'utilisation du service NLB pour créer un cluster Web, reportez-vous à l'aide de Windows 2000 Advanced Server.

  • Collaborez avec vos partenaires commerciaux pour appliquer les méthodes conseillées lorsque vous utilisez des pages ASP avec le service d'envoi HTTP/HTTPS. Pour plus d'informations sur l'optimisation des pages ASP et des services IIS (Internet Information Services), consultez le site Web dédié à l'aide de Microsoft Internet Information Services Help (localhost/iisHelp) et cliquez sur Guide Active Server Pages.


File (évolution horizontale)

Réception

Même si le fait de dédier un serveur BizTalk Server à la fonction de réception de fichier peut réduire l'impact des performances sur les E/S de disque, la latence du réseau influe sur les performances lors de la tentative d'extraction du fichier. Pour résoudre ce problème, placez les fichiers sur un partage réseau équipé d'une carte rapide ou enregistrez-les dans un répertoire local sur un des serveurs, puis faites en sorte que tous les serveurs dotés d'une fonction de réception de fichier les lisent.

Envoi

L'évolution horizontale s'effectue au moyen de plusieurs serveurs du groupe qui traitent les documents puis les envoient au service de transport de fichiers. Les performances dépendent de l'utilisation ou non de BizTalk Server 2002 en tant que fonction de réception ou de la configuration ou non de BizTalk Server en tant que serveur distinct.

Optimisation recommandée pour l'évolution horizontale de la fonction de réception de fichier ou du service de transport de fichiers

Pour optimiser les performances de la fonction de réception de fichier et du service de transport de fichiers et ainsi améliorer les performances de BizTalk Server :

  • Placez les fichiers sur un partage réseau équipé d'une carte rapide ou enregistrez-les dans un répertoire local sur un des serveurs, puis faites en sorte que tous les serveurs dotés d'une fonction de réception de fichier les lisent.

  • Configurez l'exécution d'une fonction de réception sur chaque serveur du groupe qui recherche la même fonction de réception de fichier pour ainsi garantir que tous les serveurs du groupe extraient les documents à traiter. Les services de réception de fichier sont configurés par défaut pour s'exécuter sur un serveur au sein d'un groupe. Par conséquent, si vous disposez de cinq serveurs dans un groupe et que vous configurez l'exécution de la fonction de réception de fichier sur un seul serveur dans le groupe, lorsque la fonction de réception de fichier est appelée à l'adresse \\serveur_réception\emplacement_réception, seul un serveur sur cinq extrait les fichiers pour leur traitement. Ceci limite à un le nombre de serveurs capables de traiter des documents pour le groupe entier. Les quatre serveurs restants ne peuvent pas extraire des fichiers à analyser provenant de l'opération de réception. Pour plus d'informations, voir Ajout d'une fonction de réception de fichier et exécutez la procédure indiquée pour créer une fonction de réception de fichier sur chaque serveur du groupe, en veillant à utiliser le même emplacement d'interrogation pour toutes les fonctions de réception.

  • Autorisez plusieurs serveurs à participer au traitement de l'élément de travail. L'envoi et la réception de fichiers étant des processus différents, tous les serveurs du groupe configurés pour participer au traitement de l'élément de travail envoient des fichiers. L'évolutivité horizontale du service de transport File est basée uniquement sur le nombre de serveurs du groupe qui sont configurés pour participer au traitement de l'élément de travail.


SMTP (évolution horizontale)

Réception

Le service de transport SMTP est capable de recevoir des documents de BizTalk Server 2002 mais ne peut pas lui en envoyer. Pour envoyer un document à BizTalk Server, votre solution SMTP doit utiliser la méthode Submit afin qu'une fonction de réception File ou Message Queuing puisse traiter le document. Les serveurs hôtes SMTP, capables de fournir des systèmes basés sur ces événements (Microsoft Exchange Server ou des serveurs d'échanges tiers), utilisent généralement un volume important de ressources matérielles. Par conséquent, l'ajout de cette fonctionnalité sur un serveur diminue sa capacité à traiter des documents. Pour plus d'informations, reportez-vous à la documentation relative à votre solution SMTP.

Envoi

Les services de transport Lightweight SMTP qui ne possèdent pas de systèmes basés sur les événements peuvent être utilisés pour envoyer des documents en utilisant le service SMTP. Le serveur hôte de transport SMTP qui envoie le document fonctionne simplement comme un agent de relais. Le serveur hôte de transport SMTP sortant est configuré au niveau du groupe et non au niveau du serveur. Par conséquent, si le transport SMTP existe sur l'un des serveurs dans un groupe, le serveur contenant le service de transport SMTP l'utilise pour envoyer des documents sortants. Tous les autres serveurs du groupe utilisent le même serveur pour le service de transport SMTP sortant.

Optimisation recommandée pour l'évolution horizontale du service SMTP

Pour optimiser les performances du service SMTP et ainsi améliorer les performances de BizTalk Server :

  • Configurez le serveur hôte SMTP pour qu'il s'exécute sur un serveur distinct du serveur sur lequel sont installés les services BizTalk (pour les fonctions d'envoi et de réception). Dans la plupart des cas, une organisation dispose d'un serveur hôte SMTP sur son réseau, lequel peut être utilisé pour les fonctions d'envoi et de réception.


Message Queuing (évolution horizontale)

Réception

Vous devez décider d'installer la fonction de réception Message Queing sur le même serveur que BizTalk Server 2002 ou sur un serveur différent. Si vous utilisez une file d'attente transactionnelle, la fonction de réception Message Queing doit se trouver sur le même serveur. Cependant, si vous n'utilisez pas de file d'attente transactionnelle, la fonction de réception Message Queing peut se trouver sur un serveur distinct. Vous devez également décider si vous acceptez de subir les impacts sur les performances en ayant les E/S de disques sur le serveur BizTalk Server local ou de subir la latence engendrée sur le réseau pour les communications de plusieurs serveurs. Dans ce dernier exemple, le besoin en E/S de disque existe toujours mais il existe uniquement sur le serveur distant au lieu du serveur local. Pour plus d'informations sur la façon de définir les besoins en matériel pour le service Message Queuing, voir « Sélection du matériel du serveur Message Queuing » dans l'aide de Windows 2000 Server.

Envoi

L'envoi de documents avec Message Queuing est un sujet qui pose les mêmes questions de sécurité et de performance que la réception de documents avec Message Queuing. En revanche, vous pouvez effectuer des écritures transactionnelles dans une file d'attente distante.

Optimisation recommandée pour l'évolution horizontale de Message Queuing

Pour optimiser les performances du service Message Queuing et ainsi améliorer les performances de BizTalk Server :

  • Le service Message Queuing est un processus qui sollicite les disques de manière intensive.

  • Pour optimiser le service Message Queuing, utilisez une file d'attente non transactionnelle.


Administration des serveurs et des applications

Les fonctions d'administration fournies avec Microsoft® BizTalk™ Server 2002 permettent aux administrateurs de gérer efficacement toutes les installations de BizTalk Server 2002. L'administration porte sur quatre domaines :

  • administration des serveurs ;

  • administration des applications ;

  • administration de la programmation ;

  • administration des bases de données.

Cette section traite de l'administration des serveurs et des applications. Pour plus d'informations sur l'administration des serveurs et des bases de données, voir Modèle d'administration de BizTalk Server.

Administration de BizTalk Server inclut une interface utilisateur (IU) grâce à laquelle vous pouvez :

  • ajouter et gérer des serveurs équipés de BizTalk Server dans des groupes de serveurs ;

  • configurer les propriétés des groupes de serveurs, telles que l'emplacement de la base de données de suivi et de la base de données de files d'attente partagée ;

  • configurer et gérer les fonctions de réception ;

  • afficher et gérer les files d'attente.

L'administration des applications inclut la configuration et la gestion des applications COM+ qui hébergent des planifications XLANG, l'application XLANG Scheduler par défaut et la base de données de persistance d'orchestration par défaut.

Cette section traite des rubriques suivantes :

  • Pour plus d'informations sur le module Administration de BizTalk Server, voir À propos de Administration de BizTalk Server.

  • Pour plus d'informations sur les raisons pour lesquelles effectuer certaines tâches, voir Pourquoi utiliser Administration de BizTalk Server.

  • Pour prendre connaissance des procédures détaillées à suivre afin d'effectuer certaines tâches, voir Comment utiliser Administration de BizTalk Server.

  • Pour obtenir des instructions sur la résolution de problèmes, voir Dépannage de Administration de BizTalk Server.

Voir aussi

Modèle d'administration de BizTalk Server

BizTalk Orchestration Services


À propos de Administration de BizTalk Server

Cette section présente les concepts essentiels à la compréhension de la console Administration de BizTalk Server. Elles décrit des tâches administratives telles que la création d'un groupe de serveurs, la définition de fonctions de réception et la création de bases de données pour gérer, afficher et consigner les activités liées aux documents dans Microsoft BizTalk Server 2002.

Les concepts suivants sont abordés dans cette section :

  • Groupes et serveurs

  • Environnement de Administration de BizTalk Server

  • Cache d'administration

  • Gestion des bases de données BizTalk Server

  • Traitement des erreurs de serveur

  • Fonctions de réception

  • Utilisation des files d'attente

  • Privilèges d'administration


Groupes et serveurs

Dans un environnement d'échange de données qui prend en charge le traitement d'un grand nombre de documents, les solutions à évolution horizontale requièrent plusieurs serveurs et bases de données pour répondre aux besoins. Mais en même temps, les entreprises doivent disposer d'un moyen de centraliser et de gérer les échanges de documents pour réduire le coût total de possession des solutions en facilitant leur gestion.

Microsoft BizTalk Server 2002 offre une gestion horizontale et centralisée en rassemblant les serveurs dans des groupes et en gérant et configurant ces groupes de serveurs au moyen de la console Administration de BizTalk Server.

Cette section traite des rubriques suivantes :

  • Groupes BizTalk Server

  • Relations entre les groupes et les serveurs

  • États des groupes

  • Serveurs BizTalk


Groupes BizTalk Server

Le principe de regroupement des serveurs est un principe d'organisation clé dans la console Administration de BizTalk Server. Les groupes de serveurs sont des collections de serveurs individuels faisant l'objet d'une gestion, d'une configuration et d'une surveillance centralisées.

Les serveurs d'un groupe de serveurs BizTalk ont en commun les éléments suivants :

  • Une base de données de files d'attente partagée qui assure la persistance de tous les documents jusqu'à l'aboutissement de leur traitement.

  • Une base de données de suivi qui permet de consigner l'activité liée aux documents et aux échanges, et d'exécuter des rapports.

  • Des fonctions de réception.

  • Tous les composants dont le serveur a besoin lors du traitement des documents et des échanges, notamment les composants de transport et les composants d'intégration d'application (AIC).

Une base de données Gestion d'échanges BizTalk centrale qui gère plusieurs groupes et plusieurs serveurs. Ainsi, tous les groupes et tous les serveurs définis dans une implémentation BizTalk Server unique partagent les mêmes informations de configuration. Ces informations de configuration spécifient la logique de traitement des documents pour les serveurs.

Vous devez spécifier la même base de données Gestion d'échanges BizTalk pour chaque installation de serveur afin de pouvoir administrer à distance chaque serveur et chaque groupe à partir de la console d'administration. En outre, si vous définissez plusieurs groupes de serveurs par souci d'évolutivité et d'amélioration des performances, vous devez utiliser une seule base de données Gestion d'échanges BizTalk centrale. Sinon, ces serveurs ne peuvent pas partager la même configuration de Gestion d'échanges BizTalk.

Voir aussi

Ajout, suppression et configuration d'un groupe de serveurs

Serveurs BizTalk

Fonctions de réception

Relation entre les groupes et les serveurs

Utilisation des files d'attente


Relations entre les groupes et les serveurs

Chaque installation de BizTalk Server 2002 doit avoir au moins un groupe de serveurs. La relation entre les groupes et les serveurs est la suivante :

  • Un serveur individuel peut appartenir à un seul groupe de serveurs.

  • Tous les serveurs d'un groupe partagent la même base de données de files d'attente partagée.

  • Chaque fonction de réception dans un groupe doit fonctionner sur un seul serveur du groupe.

  • Tous les serveurs d'un groupe partagent les mêmes composants, tels que les composants de transport et les composants d'intégration d'application (AIC), pour traiter les échanges et les documents.

L'illustration suivante montre les relations entre des groupes de serveurs dans BizTalk Server 2002.

Configuration logique des groupes et des serveurs

Les serveurs 1 à 6 sont équipés de BizTalk Server 2002. Les serveurs A à D sont équipés de Microsoft® SQL Server™ et sont dédiés à la gestion des bases de données. Bien que les serveurs de A à D soient dédiés aux bases de données de suivi ou de files d'attente partagées, la base de données Gestion d'échanges BizTalk peut résider sur l'un de ces serveurs car elle est généralement petite et n'utilise pas le processeur de façon intensive. Pour obtenir le meilleur résultat, il est vivement recommandé d'installer les bases de données de files d'attente partagées et de suivi sur deux serveurs distincts dédiés aux fonctions respectives de ces bases.

Important

  • Tous les serveurs d'un groupe doivent disposer de la même version de BizTalk Server dans la même langue. Les bases de données ne fonctionneront pas correctement si des versions différentes de BizTalk Server (BizTalk Server 2000, BizTalk Server 2000 Service Pack 1, BizTalk Server 2002 Édition Entreprise, ou une version de BizTalk Server dans une autre langue) sont installées sur les serveurs d'un même groupe.

  • Avant d'ajouter un nouveau serveur à un groupe de serveurs BizTalk Server, vous devez y installer la version de BizTalk Server dont disposent déjà les autres serveurs.

Voir aussi

Gestion des bases de données BizTalk Server


États des groupes

La console Administration de BizTalk Server énumère les groupes de serveurs et indique si chaque groupe peut se connecter aux bases de données de suivi ou de files d'attente partagées. Lorsque vous cliquez sur Microsoft BizTalk Server 2002, les états des groupes apparaissent sous la barre d'état dans le volet des détails. Les états des groupes sont :

  • Connecté. Indique que le groupe est connecté aux bases de données de suivi et de files d'attente partagées.

  • Échec de la connexion de suivi. Indique que le groupe n'est pas connecté à la base de données de suivi.

  • Échec de la connexion des files d'attente partagées. Indique que le groupe n'est pas connecté à la base de données de files d'attente partagée.

  • Échec des connexions du suivi et des files d'attente partagées. Indique que le groupe n'est pas connecté aux bases de données de suivi et de files d'attente partagées.


Serveurs BizTalk

Les serveurs BizTalk sont des ordinateurs sur lesquels BizTalk Server a été installé et configuré. Chaque serveur dans un groupe de serveurs héberge les services d'échanges BizTalk appropriés, tels que la conversion de données, le cryptage, la signature numérique et le suivi des documents, pour gérer l'échange de documents entre d'autres serveurs et d'autres applications externes au groupe de serveurs BizTalk. Chaque serveur place en file d'attente et retire des files d'attente des documents entrants et sortants dans la base de données de files d'attente partagée, en appelant les méthodes COM (Component Object Model) appropriées pour transformer, sérialiser, signer, crypter ou décrypter et transporter des documents.

Selon les besoins de votre entreprise, vous pouvez configurer tous les serveurs d'un groupe de façon à ce qu'ils puissent à la fois recevoir et traiter des messages. Vous pouvez ajouter et supprimer facilement des serveurs d'un groupe puisqu'ils exécutent les mêmes fonctions. Ou bien, pour obtenir des performances maximales, vous pouvez dédier certains serveurs à la réception de documents et d'autres au traitement de documents.

Cette section traite des rubriques suivantes :

  • Description des propriétés d'un serveur

  • États d'un serveur

Voir aussi

Groupes BizTalk Server

Relation entre les groupes et les serveurs


Description des propriétés d'un serveur

Lorsque vous configurez un serveur dans un groupe, il convient de trouver un compromis entre l'optimisation du débit et les performances du serveur. Vos besoins professionnels, la capacité du serveur et la bande passante du réseau sont autant de facteurs dont il faut tenir compte lors de la configuration des propriétés d'un serveur. Nous vous recommandons d'expérimenter différentes combinaisons lors des tests de paramètres pour déterminer la configuration la mieux adaptée à votre installation. Vous pouvez définir et modifier les propriétés suivantes des serveurs dans le composant Administration de BizTalk Server.

Nombre maximal de threads de fonction de réception autorisé

Le nombre maximal de threads de fonctions de réception est défini au niveau d'un processeur. La plage de valeurs pour cette option est comprise entre 1 et 128. Ajustez cette valeur pour optimiser les performances des fonctions de réception utilisées sur le serveur. Dans la plupart des cas, l'augmentation du nombre de threads de fonctions de réception accroît le débit de ces fonctions sur le serveur.

Participer au traitement de l'élément de travail

Lorsque la case Participer au traitement de l'élément travail est activée, le serveur traite les documents dans la file d'attente de travail. Lorsqu'elle est désactivée, le serveur ne traite aucun document dans la file d'attente de travail.

La raison principale qui motive la configuration d'un serveur pour qu'il n'intervienne pas dans le traitement des éléments de travail, c'est la volonté de dédier ce serveur à la réception des messages, dans le cadre d'une stratégie générale permettant d'optimiser les performances. Prenons l'exemple d'un groupe BizTalk Server contenant trois serveurs : deux serveurs de traitement et un serveur de réception. En dédiant les serveurs à des tâches précises, le débit est optimisé car le nombre de types de contextes de traitements et d'activités sur les serveurs est réduit. Les tests de banc d'essai ont démontré que cette approche était efficace pour améliorer le débit.

Nombre maximal de threads de travail autorisé par processeur

Le nombre maximal de threads de travail est défini au niveau du processeur. Les valeurs possibles pour cette option sont comprises entre 1 et 128. Une valeur faible peut provoquer un goulot d'étranglement au niveau de BizTalk Server lorsque le trafic est élevé et réduire globalement le débit. L'affectation d'une valeur trop élevée peut également entraîner un débit peu satisfaisant en raison du temps perdu dans le traitement des threads non utilisées. Il est important de faire varier cette valeur et de mesurer le débit pour déterminer le paramétrage le plus approprié pour l'implémentation de BizTalk Server.

Les paramètres Nombre maximal de threads de travail autorisé par processeur et Intervalle entre appels de BizTalk Server Scheduler sont deux facteurs qui ont une incidence sur le volume du trafic dans les bases de données Microsoft SQL Server. Vous pouvez limiter le trafic vers les bases de données SQL Server en choisissant une valeur faible pour définir le paramètre Nombre maximal de threads de travail par processeur et une valeur élevée pour le paramètre Intervalle entre appels BizTalk Server Scheduler. De même, vous pouvez accroître le trafic vers les bases de données en augmentant le nombre maximal de threads de travail et en diminuant les valeurs des paramètres qui définissent les intervalles entre les appels du composant de planification.

Remarque

  • Désactivez la case Participer au traitement de l'élément travail si vous ne souhaitez pas traiter d'éléments de travail sur ce serveur. Ne mettez pas à zéro l'option Nombre maximal de threads de travail par processeur.

Intervalle entre appels de BizTalk Server Scheduler (en millisecondes)

La plage des valeurs qui définissent le paramètre Intervalle entre appels BizTalk Server Scheduler va de 1 à 4 294 967 295. Une thread interroge les éléments disponibles dans la file d'attente de travail. Le paramètre Intervalle entre appels BizTalk Server Scheduler permet de contrôler la fréquence à laquelle la thread interroge la file d'attente de travail. Si vous ne recevez pas beaucoup de données, choisissez une valeur élevée. Si vous en recevez beaucoup, choisissez une valeur peu élevée.

Voir aussi

Configuration d'un serveur dans un groupe


États d'un serveur

La console Administration de BizTalk Server répertorie les serveurs dans un groupe de serveurs et en renvoie la liste. Elle peut renvoyer les états suivants pour les serveurs sous la barre d'état dans le volet des détails :

  • En cours d'exécution. Indique que le serveur est en cours d'utilisation.

  • Accès refusé. Indique que vous ne disposez pas des privilèges d'administrateur Microsoft® Windows® 2000 sur un serveur.

  • Erreur. Indique si BizTalk Server 2002 a été désinstallé d'un serveur enregistré dans un groupe de serveurs.

  • Arrêté. Indique si un administrateur a arrêté un serveur.

  • Inconnu. Indique si un serveur enregistré dans un groupe de serveurs n'est pas disponible pour une raison inconnue. Lorsque cela se produit, il est probable que vous avez perdu toute connectivité avec le serveur.

Voir aussi

Privilèges d'administration


Environnement de Administration de BizTalk Server

Cette section traite des rubriques suivantes :

  • Interface utilisateur de la console Administration de BizTalk Server

  • Touches de raccourci de la console Administration de BizTalk Server

  • Fonctions d'administration de l'installation des outils de BizTalk Server


Interface utilisateur de la console Administration de BizTalk Server

La console Administration de BizTalk Server (également appelée console d'administration) est un composant logiciel enfichable MMC qui fournit une représentation visuelle des composants BizTalk Server 2002 gérés par un administrateur système. Le volet gauche de la console, appelé arborescence de console, est composé de dossiers et de sous-dossiers qui représentent différents éléments, tels que des groupes de serveurs. Le volet droit de la console, appelé volet des détails, contient des informations sur l'élément sélectionné dans l'arborescence de la console.

Graphiquement, BizTalk Server est affiché sous la forme d'un sous-élément de la racine de la console dans le volet gauche de la console d'administration. Chaque groupe de serveurs configuré dans BizTalk Server est affiché dans un sous-dossier séparé. Les groupes sont composés de files d'attente et de fonctions de réception pour ce groupe. Les noms des serveurs faisant partie des groupes sont également affichés. Développez un élément dans l'arborescence de la console pour afficher des détails complémentaires le concernant dans le volet des détails de la console d'administration. Vous pouvez cliquer avec le bouton droit sur n'importe quel élément pour le configurer ou pour créer de nouveaux éléments.

Voir aussi

Ouverture de Administration de BizTalk Server


Touches de raccourci de la console Administration de BizTalk Server

Les touches de raccourci permettent d'effectuer certaines tâches sur la console Administration de BizTalk Server. Le tableau suivant présente les touches de raccourci de la console MMC.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les touches souris dans l'aide de Windows 2000 Server et Advanced Server, reportez-vous à « Utiliser le clavier pour déplacer le pointeur de la souris ». Pour plus d'informations sur les touches souris dans l'aide de Windows 2000 Professionnel, reportez-vous à « Déplacer le pointeur de la souris en utilisant les Touches souris ».
Appuyez sur | Pour
F5 | Rafraîchir la console Administration de BizTalk Server. Cette touche de raccourci rafraîchit l'élément sélectionné dans l'arborescence de la console.
ALT+F4 | Fermer Administration de BizTalk Server.
ALT+- (signe moins) | Afficher le menu de la fenêtre pour la fenêtre de console active.
MAJ+F10 | Afficher le menu Action associé à l'élément sélectionné.
ALT+A | Afficher le menu Action associé à l'élément sélectionné.
ALT+H | Afficher le menu Affichage.
F1 | Afficher l'aide en ligne pour l'élément sélectionné.
ALT+ENTRÉE | Afficher la boîte de dialogue de propriétés de l'élément sélectionné, le cas échéant.

Voir aussi

Ouverture de Administration de BizTalk Server


Fonctions d'administration de l'installation des outils de BizTalk Server

La fonction d'installation des outils permet d'installer le composant logiciel enfichable MMC de Microsoft BizTalk Server 2002 (console d'administration) sur les ordinateurs clients qui ne sont pas des serveurs BizTalk. Lorsque vous effectuez une installation partielle et installez uniquement certains outils BizTalk Server 2002 sur un ordinateur client, certaines fonctions de la console d'administration sont différentes de celles disponibles sur un ordinateur sur lequel une installation complète a été effectuée.

Lorsqu'elle est installée sur un ordinateur client, la console d'administration permet d'administrer à distance une ou plusieurs bases de données de configuration de BizTalk Server à partir du même ordinateur et de la même interface utilisateur.

À la fin de l'installation de la console d'administration sur un client, la base de données Gestion d'échanges BizTalk qui doit être administrée par le client n'est pas déterminée. Toutefois, dès la première utilisation de la console d'administration suivant l'installation, lorsque vous sélectionnez le nœud BizTalk Server 2002, la boîte de dialogue Sélectionner une base de données de gestion qui s'affiche vous permet de déterminer cette base. Dans cette boîte de dialogue, vous pouvez sélectionner la base de données de gestion distante à administrer en spécifiant le nom de la base de données SQL et du serveur Microsoft SQL Server sur lequel la base de données est installée. Vous pouvez changer la base de données à administrer à tout moment. Pour plus d'informations, voir Modification de la base de données Gestion d'échanges BizTalk gérée dans une installation d'outils.

Les différences entre une installation Outils de la console d'administration et une installation complète de BizTalk Server peuvent être énoncées comme suit :

  • Lorsque vous sélectionnez le nœud BizTalk Server 2002 dans l'arborescence de la console pour une installation Outils, le menu Action ne contient pas l'option Propriétés. Lors d'une installation d'outils, bien que vous puissiez visualiser et gérer différentes bases de données Gestion d'échanges BizTalk et différents groupes BizTalk Server, vous ne pouvez pas changer la base de données Gestion d'échanges BizTalk vers laquelle pointent tous les serveurs BizTalk appartenant à la base d'origine.

  • La boîte de dialogue Propriétés correspondant au groupe BizTalk Server sélectionné ne contient pas l'onglet Parseurs.

  • Vous pouvez gérer les fonctions de réception existantes à partir de la console d'administration pour l'installation des outils, mais vous ne pouvez pas sélectionner ou modifier leurs propriétés avancées ou créer de nouvelles fonctions de réception.

Remarques

  • Il est également possible de sélectionner la console d'administration dans une installation personnalisée. Les fonctions disponibles pour l'installation d'outils sont également disponibles pour l'installation personnalisée.

  • Lorsque toutes les fonctions sélectionnées pour l'installation personnalisée (qui est alors une installation complète), les fonctions de la console d'administration sont les mêmes que celles d'une installation complète.


Cache d'administration

Lorsque vous démarrez BizTalk Server 2002, tous les éléments de la console Administration de BizTalk Server tels que les groupes de serveurs, les propriétés de groupes de serveurs, les fonctions de réception, les connexions aux bases de données de files d'attente partagées et aux bases de données de suivi, sont stockés dans le cache d'administration. Par défaut, tous les éléments du cache sont rafraîchis toutes les 50 secondes, à l'exception des connexions à la base de données du serveur et des propriétés du serveur. Cela signifie que si vous modifiez les propriétés générales d'un groupe de serveurs, telles que l'hôte SMTP ou l'URL de réponse d'échange fiable, les modifications sont prises en compte dans les 50 secondes.

Si toutefois vous modifiez des propriétés du serveur, telle que la propriété Nombre maximal de threads de travail autorisé par processeur, vous devez arrêter et redémarrer le serveur sur lequel vous avez modifié la configuration afin que la modification puisse être stockée dans le cache. Sinon, en cas de modification d'une connexion aux bases de données Gestion d'échanges BizTalk, de suivi ou de files d'attente partagées, vous devez arrêter et redémarrer les serveurs dans le groupe et fermer l'application Échange BizTalk Server.

Voir aussi

Configuration des propriétés générales d'un groupe de serveurs

Arrêt de l'application Échange BizTalk Server

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Gestion des bases de données BizTalk Server

Les trois bases de données associées aux services d'échanges BizTalk sont les suivantes :

  • Gestion d'échanges BizTalk

  • Base de données de suivi

  • Base de données de files d'attente partagée

La base de données associée aux services d'orchestration BizTalk est la base :

  • Base de données de persistance d'orchestration

La base de données Gestion d'échanges BizTalk stocke des informations sur toutes les configurations de serveur, notamment les paramètres de groupe et de serveur, ainsi que les fonctions de réception. La configuration de ces objets d'administration peut être effectuée soit via le composant Administration de BizTalk Server, soit à l'aide d'un programme en utilisant le fournisseur WMI (Windows Management Instrumentation) de BizTalk Server. En plus de la configuration administrative, la base de données Gestion d'échanges BizTalk stocke également toutes les informations de configuration d'échange pour les canaux, les ports d'échanges et autres objets d'échange. La configuration des objets est assurée par le Gestionnaire d'échanges BizTalk ou par programme par le biais du modèle d'objet de configuration d'échanges BizTalk. Pour plus d'informations sur la configuration des canaux, des ports d'échanges, etc., voir Utilisation du Gestionnaire d'échanges BizTalk ou Messaging Services Reference.

La base de données de suivi consigne un journal de tous les échanges, documents et réceptions traités par les services d'échanges de BizTalk Server. Pour plus d'informations sur la base de données de suivi, voir Base de données de suivi. Pour configurer les paramètres de suivi, voir Configuration des propriétés de suivi d'un groupe de serveurs. Pour suivre des champs ou des données d'instance de document spécifiques, voir Définition des propriétés de canal.

La base de données de files d'attente partagée contient des documents en cours ou en attente de traitement. Les documents sont supprimés ultérieurement, une fois traités. Pour plus d'informations sur la base de données de files d'attente partagée, voir Base de données de files d'attente partagée.

La base de données de persistance d'orchestration de BizTalk stocke la structure des planifications XLANG, l'évolution des instances des planifications XLANG activées et les messages envoyés ou reçus pendant que les instances des planifications XLANG sont en cours d'exécution. Pour plus d'informations, voir Services d'orchestration BizTalk.

Cette section traite des rubriques suivantes :

  • Gestion de la base de données Gestion d'échanges BizTalk

  • Gestion des bases de données de groupe de serveurs BizTalk


Gestion de la base de données Gestion d'échanges BizTalk

Dans la plupart des implémentations en entreprise, une seule base de données Gestion d'échanges BizTalk centrale est utilisée pour configurer plusieurs groupes de serveurs, serveurs, canaux, ports d'échanges, etc. Il existe cependant des exceptions à ce cas de figure. Il se peut par exemple, que les fournisseurs de services d'applications de tierces parties aient besoin d'utiliser une base de données Gestion d'échanges BizTalk distincte pour chacun de ses types de clients, en fonction de leurs besoins professionnels spécifiques. Toutefois, dans la plupart des autres cas, vous aurez besoin uniquement d'une base de données Gestion d'échanges BizTalk centrale pour tous les groupes de serveurs BizTalk.

Parfois, il peut être nécessaire de changer la base de données Gestion d'échanges BizTalk. Par exemple, pour effectuer la maintenance du serveur sur lequel votre base de données d'échanges BizTalk réside. Dans ce cas, tous les groupes de serveurs devront alors pointer sur une base de données Gestion d'échanges BizTalk répliquée pour que votre entreprise BizTalk Server puisse fonctionner correctement. Il vous faudra peut-être aussi déplacer des serveurs entre une ou plusieurs bases de données Gestion d'échanges BizTalk.

Supposons que vous êtes un fournisseur tiers avec trois clients : Les clients A, B et C. Si l'activité du client A diminue alors que celle des clients B et C augmentent, vous pouvez déplacer les serveurs qui étaient associés à la base de données Gestion d'échanges BizTalk du client A vers les bases de données associées aux clients B et C.

Cette section traite des rubriques suivantes :

  • Modification de la base de données Gestion d'échanges BizTalk

  • Suppression de serveurs de la base de données Gestion d'échanges BizTalk

  • Déplacement de serveurs entre les bases de données Gestion d'échanges BizTalk

  • Déplacement de serveurs distants entre les bases de données Gestion d'échanges BizTalk

  • Modification du mot de passe du compte de service


Modification de la base de données Gestion d'échanges BizTalk

Il existe deux méthodes pour configurer la base de données Gestion d'échanges BizTalk :

  • Utiliser les options de configuration disponibles pendant l'installation.

  • Utiliser la console Administration de BizTalk Server pour changer le serveur dans le nœud Microsoft BizTalk Server 2002.

Si vous souhaitez centraliser la gestion de tous vos serveurs BizTalk sur un serveur unique, pendant l'installation, configurez tous les serveurs pour qu'ils pointent sur une base de données Gestion d'échanges BizTalk centrale. De cette manière, chaque fois que vous ouvrirez la console Administration de BizTalk Server sur l'un de ces serveurs BizTalk, les serveurs répertoriés dans le nœud Microsoft BizTalk Server 2002 pointeront sur la même base de données Gestion d'échanges BizTalk et pourront faire l'objet d'une gestion centralisée. Une fois qu'une collection de groupes de serveurs pointe sur une base de données Gestion d'échanges BizTalk centrale, il n'est pas nécessaire de changer de base de données Gestion d'échanges BizTalk,

sauf pour déconnecter cette base de données à des fins de maintenance. Dans ce cas, utilisez la console Administration de BizTalk Server pour que tous les groupes de serveurs du nœud Microsoft BizTalk Server 2002 pointent sur une réplication de la base de données centrale d'origine. Ne pointez pas temporairement des groupes de serveurs sur une autre base de données Gestion d'échanges BizTalk centrale à laquelle d'autres groupes de serveurs sont associés, car il pourrait être difficile de rétablir la configuration de base de données Gestion d'échanges BizTalk d'origine.

Remarque

  • Pour pouvoir changer la base de données Gestion d'échanges BizTalk, l'utilisateur doit être membre du groupe Administrateurs de BizTalk Server.

Voir aussi

Groupes BizTalk Server

Modification de la base de données Gestion d'échanges BizTalk d'un serveur

Configuration de la base de données Gestion d'échanges BizTalk

Déplacement de serveurs entre les bases de données Gestion d'échanges BizTalk

Instructions relatives à la sécurité


Suppression de serveurs de la base de données Gestion d'échanges BizTalk

Si vous supprimez tous les serveurs BizTalk de la base de données Gestion d'échanges BizTalk, le contenu de la base de données reste intact. Ce contenu reste également inchangé si votre système comporte plusieurs bases de données Gestion d'échanges BizTalk et si vous supprimez tous les serveurs BizTalk de l'une d'entre elles. Vous pouvez ajouter de nouveaux serveurs BizTalk à la base de données Gestion d'échanges BizTalk en exécutant l'Assistant Configuration de base de données BizTalk Server 2002 et en sélectionnant une base de données existante dans la page Configurer une base de données Gestion d'échanges BizTalk. Pour plus d'informations sur l'ajout ou la modification de la base de données Gestion d'échanges BizTalk d'un serveur, voir Modification de la base de données Gestion d'échanges BizTalk d'un serveur.

Remarque

  • Pour pouvoir supprimer des serveurs d'une base de données Gestion d'échanges BizTalk, l'utilisateur doit être membre du groupe Administrateurs de BizTalk Server.

Voir aussi

Modification de la base de données Gestion d'échanges BizTalk d'un serveur

Instructions relatives à la sécurité


Déplacement de serveurs entre les bases de données Gestion d'échanges BizTalk

Si vous prévoyez de déplacer temporairement un serveur BizTalk d'une base de données Gestion d'échanges BizTalk à une autre, au moins un autre serveur BizTalk doit rester en place dans l'un des groupes de serveurs de la base de données d'origine. Cela vous permet de restaurer facilement le serveur BizTalk dans la base de données d'origine. Sinon, pour ajouter un nouveau serveur BizTalk à la base de données, vous devez exécuter l'Assistant Configuration de base de données BizTalk Server et sélectionner une base de données existante dans la page Configurer une base de données Gestion d'échanges BizTalk. Pour plus d'informations sur l'ajout ou la modification de la base de données Gestion d'échanges BizTalk d'un serveur, voir Modification de la base de données Gestion d'échanges BizTalk d'un serveur.

Remarque

  • Pour pouvoir déplacer des serveurs entre des bases de données Gestion d'échanges BizTalk, l'utilisateur doit être membre du groupe Administrateurs de BizTalk Server.

Voir aussi

Modification de la base de données Gestion d'échanges BizTalk d'un serveur

Groupes et serveurs

Instructions relatives à la sécurité


Déplacement de serveurs distants entre les bases de données Gestion d'échanges BizTalk

Si vous tentez d'ajouter à une base de données Gestion d'échanges BizTalk un serveur distant qui se trouvait à l'origine dans une autre base de données Gestion d'échanges BizTalk centrale, le message d'erreur suivant apparaît dans le journal d'événements de Windows :

Impossible de créer une nouvelle instance de la classe WMI « MicrosoftBizTalkServer_Server » dans le fournisseur BizTalk Server WMI. Il est possible que le serveur <nom du serveur> appartienne déjà à une autre installation BizTalk Server.

Cette erreur signifie qu'une tentative a été effectuée pour ajouter un serveur distant qui se trouvait initialement dans une autre base de données centrale. Si cette procédure a été effectuée dans le composant Administration de BizTalk Server, la console tente de déterminer si le serveur distant appartient à un groupe de la base de données centrale distante. Pour cela, elle interroge le fournisseur WMI (Windows Management Instrumentation) du serveur distant. Si le serveur appartient à un groupe de serveurs de l'autre base de données centrale, un message d'erreur de la console d'administration apparaît et indique que vous ne pouvez pas ajouter un serveur distant appartenant déjà à un groupe d'une autre base de données centrale.

Remarque

  • Pour pouvoir déplacer des serveurs distants entre des bases de données Gestion d'échanges BizTalk, l'utilisateur doit être membre du groupe Administrateurs de BizTalk Server.

Voir aussi

Erreur lors du déplacement d'un serveur distant vers une autre base de données Gestion d'échanges BizTalk

Instructions relatives à la sécurité

À propos de Windows Management Instrumentation


Modification du mot de passe du compte de service

Microsoft BizTalk Server 2002 prend en charge uniquement l'authentification de l'intégration Microsoft® pour l'accès aux bases de données, ce qui signifie que les services d'échanges BizTalk qui fonctionnent sur des serveurs BizTalk Server 2002 doivent le faire à partir de comptes disposant d'autorisations à la fois pour BizTalk Server et SQL Server. Bien qu'il soit possible d'utiliser le compte d'un ordinateur local qui a été correctement configuré pour qu'il puisse avoir accès à tous les serveurs de l'environnement, il est vivement recommandé d'utiliser le compte d'un domaine dans tous les cas et particulièrement, lorsque SQL Server et BizTalk Server résident sur des serveurs différents, car cela simplifie l'administration.

BizTalk Server fournit un utilitaire de ligne de commande qui permet de modifier le mot de passe, à chaque fois que change le mot de passe du compte du service utilisé par les services d'échanges BizTalk, ce qui évite d'avoir à modifier le mot de passe sur chaque serveur. Cet utilitaire de ligne de commande peut également être utilisé pour changer le compte sous lequel fonctionnent les services d'échanges BizTalk.

La syntaxe de la commande est la suivante :

BTS_SvcPW {/?BTS_SvcPW {/? | {/s:<nom_serveur_SQL_BTM> /d:<nom_base_de_données_BTM> {/u:<domaine>\<nom_utilisateur> [/n:<domaine>\<nom_utilisateur>] | /n:<domaine>\<nom_utilisateur>} /p:<nouveau_mot_de_passe>}}

Où :

[] = Spécifie que ce contenu est facultatif

<> = Contient le nom d'une chaîne de variable

| = OR opérateur binaire

Le tableau suivant décrit les fonctions des paramètres qui peuvent être utilisés dans la ligne de commande.

Tapez | Pour
/? | Appeler l'aide de l'utilitaire. Ce paramètre ne peut pas être spécifié en même temps qu'un autre argument.
/s:<nom_serveur_SQL_BTM> | Nom du serveur SQL sur lequel réside la base de données Gestion d'échanges BizTalk (BTM). Cette base de données contient les serveurs pour lesquels l'utilisateur souhaite modifier le compte du service d'Échanges BizTalk Server et/ou le mot de passe. Cet argument de ligne de commande est obligatoire.
/d:<nom_base_de_données_BTM> | Spécifie le nom de la base de données Gestion d'échanges BizTalk qui réside sur le serveur SQL Server spécifié. Cet argument de ligne de commande est obligatoire.
/u:<domaine>\<nom_utilisateur> | Spécifie le domaine et le nom de l'utilisateur sous lesquels les services d'échanges BizTalk sont actuellement en cours de fonctionnement. Cette saisie est requise pour valider que le mot de passe entré dans cet utilitaire est valide pour l'utilisateur courant. Le mot de passe est validé uniquement sur le serveur local sur lequel l'utilitaire est exécuté. Seuls les services d'échanges BizTalk qui utilisent ce compte peuvent être modifiés. Cet argument de ligne de commande est facultatif.
/n:<domaine>\<nom_utilisateur> | Spécifie le domaine et le nom de l'utilisateur sous lesquels les services d'échanges BizTalk seront lancés lors de leur prochain démarrage. Si cet argument est utilisé, le mot de passe indiqué est validé en fonction de ce compte et non en fonction du compte que les services d'échanges BizTalk utilisent actuellement. Cet argument de ligne de commande est facultatif.
/p:<nouveau_mot_de_passe> | Spécifie le nouveau mot de passe que les services d'échanges BizTalk utiliseront pour se connecter lors de leur prochain démarrage. Cet argument de ligne de commande est facultatif. Toutefois, si cet argument n'est pas indiqué, l'utilisateur sera invité à entrer un nouveau mot de passe.

En utilisant la base de données Gestion d'échanges BizTalk spécifiée par les arguments /s et /d, la liste de tous les serveurs qui utilisent cette configuration est générée. Pour générer la liste des serveurs qui utilisent le compte spécifié par l'argument /u, modifiez le mot de passe, et facultativement le compte lui-même, en utilisant les autres arguments sur la ligne de commande.

Si vous n'utilisez pas l'argument /u, les arguments /n et /p servent à mettre à jour la liste des serveurs répertoriés. Utilisez l'argument /n pour modifier les serveurs d'échanges de la base de données de configuration de BizTalk Server (spécifiée par l'argument /s) et définir le nouveau compte et le nouveau mot de passe qu'ils doivent utiliser.

Le compte du services d'échanges BizTalk Server peut être remplacé uniquement par un compte disposant de privilèges d'accès à SQL Server et à BizTalk Server. Un message d'erreur s'affiche si le compte modifié ne dispose pas des privilèges requis pour accéder aux bases de données. Vérifiez que le nouveau compte dispose bien des droits Connexion en tant que service. Un mot de passe doit être fourni à chaque exécution de l'utilitaire. Si aucun mot de passe n'est indiqué sur la ligne de commande, l'utilitaire invitera l'utilisateur à en fournir un. De la même façon, si le nouveau mot de passe n'est pas indiqué sur la ligne de commande, l'utilisateur devra le fournir.

Remarques

  • L'aide de l'utilitaire s'affiche également si l'utilisateur ne respecte pas la syntaxe d'usage.

  • Les qualificateurs des arguments /s, /d, /u, /n et /p sont indifférents à la casse.

  • Les modifications apportées prennent effet au prochain démarrage des services d'échanges BizTalk.

  • Un fichier journal est créé lors de la première utilisation de l'utilitaire de ligne de commande ou bien, si le fichier journal d'origine a été supprimé. Une fois le fichier journal créé, chaque nouvelle commande lancée à partir de l'utilitaire de ligne de commande vient s'ajouter au fichier journal existant. Ce fichier journal (BTS_SvcPW.log) est stocké dans \Program Files\Microsoft BizTalk Server\.


Gestion des bases de données de groupe de serveurs BizTalk

Chaque groupe de serveurs utilise deux bases de données, la base de données de files d'attente partagée et la base de données de suivi. La première contient tous les documents et échanges qui sont soumis à Microsoft BizTalk Server 2002 pour traitement et transmission. La seconde assure le suivi et le stockage des échanges entrants et sortants à des fins d'audit, de rapprochement et de résolution de conflits.

Pour simplifier l'organisation de la configuration logique de vos serveurs et de vos groupes lorsque les bases de données de plusieurs groupes différents résident sur le même serveur Microsoft SQL, il est important de donner des noms uniques aux bases de données de files d'attente partagées et de suivi qui sont associées à chaque groupe de serveurs. Par exemple, si vous avez deux groupes de serveurs, l'un nommé Group1, l'autre Group2 et que les bases de données résident sur le même serveur SQL, étiquetez les bases de données du premier groupe SharedQueue1 et Tracking1, celles du deuxième groupe SharedQueue2 et Tracking2.

Remarque

  • La base de données Gestion d'échanges BizTalk est différente des bases de données de files d'attente partagées et de suivi. Cette base de données permet de stocker des informations sur la configuration de plusieurs groupes et serveurs, ainsi que de stocker des informations sur la configuration des services d'échanges BizTalk. Elle ne traite ni les transmissions de documents et d'échanges, ni les activités de suivi de documents et d'échanges.

Cette section traite des rubriques suivantes :

  • Base de données de files d'attente partagée

  • Base de données de suivi


Base de données de files d'attente partagée

Tous les serveurs d'un groupe de serveurs partagent une base de données de files d'attente partagée unique. Tous les documents et échanges qui sont soumis aux serveurs d'un groupe sont stockés dans cette base de données jusqu'à ce qu'ils soient traités par BizTalk Server.

La base de données de files d'attente partagée est graphiquement représentée sur la console Administration de BizTalk Server sous la forme d'une série de files d'attente fournissant des informations sur l'avancement d'un échange ou d'un document dans BizTalk Server. Les échanges et les documents sont placés, pendant leur traitement, dans l'une des files d'attente suivantes :

  • File d'attente de travail. Liste d'échanges et de documents actuellement traités par BizTalk Server.

  • File d'attente planifiée. Liste d'échanges et de documents qui ont été traités par BizTalk Server et sont en attente de transmission conformément à la fenêtre de service. Pour plus d'informations sur la fenêtre de service, voir ServiceWindowInfo Property.

  • File d'attente de nouvel essai. Liste d'échanges et de documents soumis à nouveau et au format Reliable attendant des accusés de réception.

  • File d'attente interrompue. Liste d'échanges et de documents dont le traitement a échoué pour diverses raisons, notamment des erreurs d'analyse, des erreurs de sérialisation, des erreurs de transmission, ou encore l'absence d'une configuration de canal appropriée.

Si BizTalk Server traite un échange ou un document, il arrête le traitement et annule la base de données de files d'attente partagées dans les conditions suivantes :

  • BizTalk Server ne peut pas accéder à la base de données de files d'attente partagées. Par exemple, BizTalk Server perd la connexion avec la base de données de files d'attente partagées car le serveur qui héberge cette base a connu une défaillance.

  • Des erreurs SQL Server se produisent, comme l'expiration des délais, des transactions interrompues et des verrouillages.

La transaction est annulée même si BizTalk Server a arrêté le traitement après la transmission de l'échange ou du document. Lorsque la base de données de files d'attente partagées est de nouveau disponible, l'étiquette est supprimée pour tous les documents identifiés comme étant « en cours de traitement ». Autrement dit, les documents sont traités de nouveau au lieu d'être placés dans la file d'attente interrompue.

Avec les files d'attente de messages transactionnels ou les échanges de type Reliable, vous êtes assuré que l'échange ou le document ne sera remis qu'une seule fois. Avec les transmissions non transactionnelles, BizTalk Server 2002 peut envoyer le même document deux fois dans les situations décrites ci-dessus.

Remarque

  • Pour pouvoir gérer les files d'attente stockées dans la base de données de files d'attente partagée, l'utilisateur doit être membre du groupe Administrateurs de BizTalk Server.

Voir aussi

Configuration des propriétés de connexion d'un groupe de serveurs

Groupes et serveurs

Gestion des files d'attente

Instructions relatives à la sécurité

Propriété ServiceWindowInfo

Utilisation des files d'attente


Base de données de suivi

Tous les serveurs d'un groupe de serveurs partagent une base de données de suivi unique qui stocke toutes les informations relatives aux activités d'échanges et de documents dans BizTalk Server. La base de données de suivi est utilisée pour assurer le suivi de l'état d'un échange ou d'un document en transit dans le serveur. Si, par exemple, vous souhaitez vérifier qu'une commande a été envoyée à un partenaire commercial, vous pouvez interroger la base de données de suivi. Cette base de données vérifie également que l'envoi ou la réception d'échanges et de documents par BizTalk Server a abouti, ou peut fournir des informations pour des rapports, par exemple des temps de transmission ou des réponses de réception.

Définition des paramètres de suivi et de journalisation pour la base de données de suivi

Sur la console Administration de BizTalk Server, vous pouvez choisir de suivre ou non les échanges et les documents. Pour plus d'informations sur la configuration des paramètres de suivi pour un groupe de serveurs, voir Configuration des propriétés de suivi d'un groupe de serveurs. Si vous activez le suivi, les options suivantes sont disponibles :

  • Consigner l'échange entrant dans un journal. Ce paramètre permet de stocker dans la base de données de suivi les documents que BizTalk Server reçoit. Le stockage des documents entrants dans un enregistrement d'activité est utile pour la résolution de conflits. Cette option est activée par défaut.

  • Consigner l'échange sortant dans un journal. Les documents envoyés par BizTalk Server sont stockés dans la base de données de suivi. Cette option est activée par défaut.

  • Consigner le message MIME d'origine dans un journal. Les documents à codage MIME sont stockés dans la base de données de suivi dans leur format de message d'origine avant d'être décodés. Cette option est désactivée par défaut.

Voir aussi

Configuration des propriétés de connexion d'un groupe de serveurs

Configuration des propriétés de suivi d'un groupe de serveurs

Instructions relatives à la sécurité

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe

Utilisation de Suivi de documents BizTalk


Traitement des erreurs de serveur

Vous pouvez configurer le traitement des erreurs dans Microsoft BizTalk Server 2002 au niveau du serveur par le biais de l'Observateur d'événements Windows 2000, qui est inclus dans la console Administration de BizTalk Server. L'Observateur d'événements Windows 2000 apparaît dans l'arborescence de la console d'administration.

Journalisation des événements

L'Observateur d'événements Windows 2000 affiche un journal contenant des informations sur les incidents matériels, logiciels et système. Dans la console d'administration, vous pouvez personnaliser l'Observateur d'événements pour afficher les erreurs spécifiques aux services d'échanges BizTalk et à XLANG Scheduler, pour optimiser le dépannage de BizTalk Server. Pour plus d'informations sur la personnalisation de l'Observateur d'événements concernant les erreurs liées à BizTalk Server et XLANG Scheduler, voir Gestion de l'Observateur d'événements.

Pour plus d'informations sur l'Observateur d'événements, dans le chapitre « Observateur d'événements » de l'aide de Windows 2000 Server, reportez-vous à « Utilisation de l'Observateur d'événements ».

Remarque

  • Toutes les erreurs d'application relatives à BizTalk Server 2002 sont définies comme étant des erreurs BizTalk Server ou XLANG Scheduler.

Voir aussi

Gestion de l'Observateur d'événements


Fonctions de réception

Si vous devez recevoir des documents provenant d'un emplacement de réception et les soumettre ensuite à Microsoft BizTalk Server 2002, vous pouvez configurer les fonctions de réception pour qu'elles traitent les données. Si, par exemple, vous devez recevoir des documents d'une organisation ou d'une application commerciale ne pouvant pas communiquer directement avec BizTalk Server par le biais d'une interface COM, vous pouvez faire appel à une fonction de réception pour soumettre les documents à BizTalk Server. Sinon, si la réception doit se faire à partir d'une file d'attente de messages, vous pouvez utiliser une fonction de réception pour soumettre le document à BizTalk Server. BizTalk Server 2002 prend en charge trois types de fonction de réception :

  • Fichier

  • Message Queuing

  • HTTP

Vous pouvez créer une fonction de réception générique pour BizTalk Server 2002 dans la console d'administration, dans laquelle vous définissez notamment le nom de la fonction de réception et la définition de document. Pour plus d'informations sur la configuration des fonctions de réception, voir Gestion des fonctions de réception d'un groupe de serveurs. Pour plus d'informations sur les propriétés avancées des fonctions de réception, voir Description des propriétés avancées d'une fonction de réception.

L'illustration suivante montre la relation entre l'application professionnelle d'envoi, le système de fichiers et une fonction de réception BizTalk Server générique.

Relation entre une application professionnelle d'envoi, un système de fichiers et une fonction de réception BizTalk Server générique

Remarque

  • Vous pouvez aussi configurer les appels à l'aide d'un programme pour recevoir les documents et les soumettre à BizTalk Server. Pour plus d'informations sur les appels soumis, voir Submitting et BizTalk Documents.

Cette section traite des rubriques suivantes :

  • Fonctions de réception disponibles

  • Jeton de corrélation

  • Préprocesseurs personnalisés

  • Instances multiples de types de fonction de réception

  • Description des fonctions de réception et du routage de documents

  • Description des propriétés avancées d'une fonction de réception


Fonctions de réception disponibles

Trois types de fonctions de réception sont disponibles dans BizTalk Server : Fichier, Message Queuing et HTTP. Les pratiques de votre entreprise déterminent le type de fonction de réception à utiliser et quand les utiliser.

Fonction de réception Fichier

Une fonction de réception Fichier est activée en présence d'une activité dans le répertoire d'interrogation. Pour l'utiliser, vous devez pouvoir modifier le répertoire d'interrogation. La fonction de réception Fichier retire les fichiers du répertoire et les soumet à BizTalk Server 2002.

Fonction de réception Message Queuing

Une fonction de réception Message Queuing est activée en fonction de l'activité dans une file d'attente des messages. Cette fonction de réception extrait l'échange ou le document de la file d'attente et le soumet à BizTalk Server 2002.

Lorsque vous définissez l'emplacement des interrogations de la file d'attente des messages, utilisez un nom de format et non un chemin. BizTalk Server est conçu pour travailler avec des interfaces API de Message Queuing non modifiées, et l'API fonctionne uniquement avec la propriété de nom de format. Utilisez le nom de format suivant lorsque vous configurez une fonction de réception Message Queuing :

DIRECT=OS:<nom_serveur>\<nom_file_d'attente>

Remarque

  • Pour plus d'informations sur Message Queuing et les noms de formats, accédez au site Web de la bibliothèque en ligne MSDN (msdn.microsoft.com/library/), puis effectuez une recherche sur les mots clés « Message Queuing Services ».

Fonction de réception HTTP

Une fonction de réception HTTP est une extension ISAPI (Internet Server Application Programming Interface) qui fournit un utilitaire « prêt à l'emploi » pour permettre la réception immédiate des documents via le protocole HTTP (Hypertext Transfer Protocol) avec une configuration minimale, et sans qu'il soit nécessaire de développer des pages Web ou des DLL (Dynamic-Link Libraries) supplémentaires.

La fonction de réception HTTP soumet des documents au système de fichiers ou directement à BizTalk Server via un appel COM à Submit Method ou à SubmitSync Method.

Voir aussi

Ajout d'une fonction de réception de fichier

Ajout d'une fonction de réception HTTP

Ajout d'une fonction de réception Message Queuing

Configuration des propriétés avancées des fonctions de réception de fichier et Message Queuing

Configuration d'une fonction de réception de fichier : Onglet Général

Configuration d'une fonction de réception de fichier : onglet Services

Configuration d'une fonction de réception Message Queuing : Onglet Général

Configuration d'une fonction de réception Message Queuing : Onglet Services

Configurer une fonction de réception HTTP : Onglet Général

Configurer une fonction de réception HTTP : Onglet Services


Jeton de corrélation

La fonction de réception HTTP utilise un jeton de corrélation pour émuler la communication synchrone d'une communication asynchrone BizTalk Server. L'exemple typique qui permet de comprendre comment cela fonction est celui d'un document qui est soumis à une page ASP dans un réseau de périmètre (également connu sous le nom de zone DMZ et sous-réseau filtré). Si la page ASP utilise une fonction de réception HTTP pour transmettre le document de l'autre côté du pare-feu, un jeton de corrélation est utilisé pour surveiller l'avancement du traitement du document et pour déterminer le moment auquel il doit retourner sur le client à l'origine de l'envoi du document. En utilisant un jeton de corrélation, le processus asynchrone paraît synchrone pour le client.

Remarque

  • Le jeton de corrélation utilisé par une fonction de réception HTTP n'est pas lié au processus de corrélation d'Orchestration.


Préprocesseurs personnalisés

Si vous devez traiter des documents avant de les soumettre à BizTalk Server 2002, vous pouvez créer un préprocesseur personnalisé et configurer la fonction de réception pour appeler le préprocesseur. Si, par exemple, vous envoyez des données compressées et devez les décompresser avant de les soumettre à BizTalk Server pour traitement, configurez la fonction de réception de manière à appeler le préprocesseur personnalisé afin de décompresser les données.

Voir aussi

Identificateur de classe apparaissant dans la liste Préprocesseur

IBTSCustomProcess

Preprocessing Documents in a Receive Function


Instances multiples de types de fonction de réception

Il peut exister plusieurs instances d'une fonction de réception. Par exemple, si plusieurs applications professionnelles utilisent une fonction de réception de fichier pour soumettre des documents et des échanges à BizTalk Server 2002, vous pouvez configurer une instance unique ou des instances multiples de cette fonction.

Remarques

  • Vérifiez que le nom de chaque fonction de réception créée est unique. Vous ne pouvez pas attribuer le même nom à plusieurs fonctions de réception.

  • Pour l'ensemble des fonctions de réception HTTP qui fonctionnent sur un même serveur, il est recommandé d'utiliser une seule DLL ou un seul répertoire virtuel. Si vous utilisez plusieurs DLL ou plusieurs répertoires virtuels, vous risquez d'obtenir des résultats inattendus. Pour plus d'informations sur l'ajout de fonctions de réception HTTP, voir Ajout d'une fonction de réception HTTP.

Voir aussi

Gestion des fonctions de réception d'un groupe de serveurs


Description des fonctions de réception et du routage de documents

Lorsque vous configurez une fonction de réception, déterminez si les documents reçus par la fonction de réception bénéficient ou non d'un auto-routage. Les documents avec auto-routage contiennent toutes les informations de routage nécessaires alors que dans les documents sans auto-routage, tout ou partie des informations de routage sont absentes.

Documents avec auto-routage

Dans les documents avec auto-routage, toutes les informations de routage nécessaires (identificateur d'organisation source, identificateur d'organisation de destination et définition de document) figurent dans les balises de routage qui sont définies par la spécification> de documents ou codées en dur dans le document, comme c'est le cas de X12 et EDIFACT. Tout document pour lequel vous pouvez créer une spécification dans l'Éditeur BizTalk peut être configuré comme document avec auto-routage. Les types courants de documents avec auto-routage sont XML (Extensible Markup Language), X12 et EDIFACT. Il n'est pas nécessaire de configurer des propriétés avancées dans la fonction de réception si un document bénéficie d'un auto-routage, sauf pour remplacer les données fournies dans le document.

Si les qualificateurs de l'organisation source ou de destination, ou bien la définition de documents sont absents dans le document, celui-ci est placé dans la file d'attente interrompue. En outre, si vous ne spécifiez pas de qualificateur d'organisation source ou de destination, BizTalk Server utilise la valeur par défaut Nom de l'organisation comme qualificateur d'organisation et se réfère au nom de l'organisation stocké dans la base de données Gestion d'échanges BizTalk.

Documents sans auto-routage

Dans les documents sans auto-routage, tout ou partie des informations de routage nécessaires sont absentes. En configurant la fonction de réception, vous devez définir les informations suivantes dans l'onglet Avancé de la boîte de dialogue Propriétés ou dans le document à fournir à la fonction de réception :

  • Identificateur d'organisation source, identificateur d'organisation de destination et définition de document.

    — ou —

  • Canal

Lorsque vous soumettez un document, BizTalk Server localise un canal pour traiter le document. Cela peut être mis en œuvre de deux manières : en fournissant un nom de canal dans la fonction de réception ou en fournissant les identificateurs d'organisation source et de destination ainsi que la définition de document. Ces trois propriétés aident BizTalk Server à localiser le canal approprié. Par conséquent, si vous sélectionnez un canal, la définition de document et les options d'informations source et de destination ne sont pas disponibles car le canal fournit toutes les informations requises pour router le document.

Les types courants de documents sans auto-routage sont les documents provenant de sources multiples (source ouverte) ou ceux destinés à des destinations multiples (destination ouverte).

Configuration d'une fonction de réception pour gérer des documents provenant de sources multiples

Vous pouvez configurer une fonction de réception unique qui traite les documents sans auto-routage de façon à recevoir un type spécifique de documents provenant de sources multiples. Il s'agit d'un scénario de source ouverte. L'emplacement de l'organisation source, de l'organisation de destination, et les informations de définition de document doivent être contenus dans le document ou dans les paramètres soumis avec le document.

Si, par exemple, vous souhaitez recevoir des ordres d'achats de plusieurs clients, mais ne souhaitez pas tous les envoyer à la même application de destination, configurez les propriétés de définition de document et d'identificateur d'organisation de destination dans la fonction de réception. Lorsque BizTalk Server analyse le document, il localise l'identificateur d'organisation du fournisseur, combine ces informations aux paramètres de la fonction de réception, trouve le canal approprié, puis traite le document.

Voir aussi

Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP

Gestion des fonctions de réception d'un groupe de serveurs

Définition des propriétés d'une organisation source


Description des propriétés avancées d'une fonction de réception

Vous pouvez utiliser des propriétés avancées pour configurer des types spéciaux de fonctions de réception basés sur vos pratiques professionnelles.

Par exemple, vous pouvez définir des fonctions de réception pour soumettre :

  • des documents dont la propriété Source ouverte ou Destination ouverte est activée ;

  • des documents dont la propriété Pass-through est activée ;

  • des documents qui spécifient un nom de canal ;

  • d'autres types de documents sans auto-routage.

Définition de la propriété Openness dans un document

Les options suivantes définissent la propriété Openness d'un document :

  • Non ouvert : Indique que la source et la destination sont toutes deux explicitement déclarées dans la fonction de réception ou l'instance du document.

  • Destination ouverte : indique que les informations de destination ne sont pas explicitement déclarées dans le port d'échanges. La destination est spécifiée dynamiquement dans l'instance de document ou dans un paramètre d'envoi. Vous devez configurer la définition de document et les propriétés d'identificateur d'organisation source dans la fonction de réception ou dans l'instance de document afin de permettre à BizTalk Server de localiser le canal approprié.

  • Source ouverte : Indique que les informations source ne sont pas explicitement déclarées dans le canal. La source est plutôt dynamiquement spécifiée dans l'instance de document. Vous devez configurer la définition de document et les propriétés d'identificateur d'organisation de destination dans la fonction de réception ou dans l'instance de document pour permettre à BizTalk Server de localiser le canal approprié.

Configuration de fonction de réception avec transfert direct

Une fonction de réception configurée avec un transfert direct n'effectue pas l'analyse, le décryptage, la vérification de signature et les fonctions de décodage de BizTalk Server. Choisissez cette option lorsque vous envoyez des données d'objets binaires volumineux ou d'autres échanges n'imposant pas l'analyse, le décryptage et le décodage. Si vous configurez une fonction de réception en activant l'option Soumettre avec un indicateur direct, vous devez spécifier un canal. Sinon, BizTalk Server ne peut pas traiter le document.

Nom d'enveloppe

Si vous prévoyez de recevoir un échange entrant dans un fichier plat, spécifiez le format d'enveloppe dans la fonction de réception. L'enveloppe pointe sur une spécification indiquant à BizTalk Server comment ouvrir et interpréter l'échange. Si vous prévoyez de recevoir plusieurs fichiers plats dans un échange spécifique, les fichiers plats individuels doivent avoir des séparateurs (postfix ou préfixe). Infix n'est pas pris en charge. Cela doit être défini sur le nœud racine de la spécification d'enveloppe et de la spécification de document lors de la configuration des propriétés d'analyse. Pour plus d'informations sur la définition des propriétés d'analyse pour un fichier plat, voir Définition des propriétés d'analyse et consultez le tableau « Standard : Personnalisé, propriété de la structure : Délimité ».

Nom du canal

Chaque échange ou document soumis à BizTalk Server nécessite un ensemble de règles précisant son mode de traitement. Le canal contient toutes les informations dont le serveur a besoin pour traiter l'échange ou le document. Tous les échanges et tous les documents qui sont traités par BizTalk Server doivent emprunter un canal. La localisation d'un canal s'effectue de deux manières.

La première localisation d'un canal se produit lorsqu'un échange ou un document est envoyé. BizTalk Server analyse le document pour rechercher les identificateurs source et de destination ainsi que la définition du document. Si ces informations ne figurent pas dans l'instance de document, BizTalk Server analyse la fonction de réception. Une fois les identificateurs source et de destination et la définition de document découverts, BizTalk Server détermine quels canaux ont la même définition de document, les mêmes identificateurs d'organisation source et de destination que le document reçu. Lorsque BizTalk Server trouve un canal correspondant, l'instance de document est traitée.

Les canaux peuvent également être localisés lorsqu'ils figurent dans la fonction de réception. Dans ce cas, la recherche de canaux n'est pas effectuée et le document reçu est traité plus rapidement.

Définition de document, identificateurs d'organisation source et d'organisation de destination

Vous pouvez configurer la définition de document, l'identificateur d'organisation source, ou l'identificateur d'organisation de destination lorsque vous recevez des documents sans auto-routage. Les informations de routage incluses dans le document que vous recevez déterminent les propriétés à définir dans la fonction de réception.

Par exemple, si vous recevez plusieurs types de document de la même organisation source et si vous envoyez toujours ces documents à la même destination, vous pouvez configurer les identificateurs d'organisation source et de destination dans la fonction de réception et définir dynamiquement la définition de document dans l'instance de document.

Voir aussi

Création d'enveloppes

Définition des propriétés des informations d'enveloppes

Définition des propriétés d'analyse

Description des canaux

Description des définitions de document

Description des enveloppes

Description des organisations

Description des fonctions de réception et du routage de documents

Utilisation d'enveloppes pour le traitement entrant


Utilisation des files d'attente

Microsoft BizTalk Server 2002 offre la possibilité de gérer les files d'attente partagées dans la console Administration de BizTalk Server. Les administrateurs de BizTalk Server peuvent transférer des documents de n'importe quelle file d'attente à la file d'attente interrompue. Dans la file d'attente interrompue, des documents sont supprimés, soumis à nouveau ou affichés, selon l'état de traitement du document. Les administrateurs de BizTalk Server peuvent trier et afficher les messages d'erreur relatifs aux documents dans la file d'attente interrompue.

Les files d'attente suivantes sont employées pour contenir des documents entrants et sortants à diverses étapes de routage et de traitement dans BizTalk Server :

  • File d'attente de travail

  • File d'attente planifiée

  • File d'attente de nouvel essai

  • File d'attente interrompue

Remarque

  • Les échanges et les documents apparaissent dans la console Administration de BizTalk Server dans l'ordre « premier arrivé, premier sorti ». En d'autres termes, les plus anciens éléments d'une file d'attente apparaissent en premier, les plus récents en dernier. En outre, une file d'attente peut contenir un nombre maximal de 15 000 échanges ou documents. Si une file d'attente comporte plus de 15 000 éléments, vous devez supprimer ou soumettre à nouveau les éléments courants de la file d'attente afin que les éléments les plus récents puissent être affichés. Le nombre entre parenthèses figurant en regard de la file d'attente indique combien d'éléments sont actuellement contenus dans la file d'attente. Vous pouvez soumettre à nouveau ou supprimer des documents pour les retirer d'une file d'attente.

Voir aussi

Gestion des files d'attente


File d'attente de travail

La file d'attente de travail contient des documents en cours de traitement par BizTalk Server. Les transactions dans la file d'attente de travail n'y restent pas très longtemps car elles sont traitées dès leur arrivée. Les administrateurs de BizTalk Server peuvent sélectionner n'importe quel document dans cette file d'attente et le déplacer vers la file d'attente interrompue.

Voir aussi

Déplacement de documents vers la file d'attente interrompue

Utilisation des files d'attente


File d'attente planifiée

La file d'attente planifiée contient des éléments de travail qui ont été traités par BizTalk Server et attendent une transmission en fonction de la fenêtre de service. Les administrateurs de BizTalk Server peuvent sélectionner n'importe quel document dans cette file d'attente et le déplacer vers la file d'attente interrompue. Pour plus d'informations sur la fenêtre de service, reportez-vous à l'objet d'interface IBizTalkServiceWindowInfo.

Voir aussi

IBizTalkServiceWindowInfo

Déplacement de documents vers la file d'attente interrompue

Utilisation des files d'attente


File d'attente de nouvel essai

La file d'attente de nouvel essai contient des documents qui sont soumis à nouveau pour livraison et des documents en attente d'accusés de réception d'échanges fiables. Il est impossible de différencier les deux types de transmission. Par défaut, les transmissions qui n'ont pas abouti sont retentées toutes les cinq minutes, pour un maximum de trois tentatives avant d'être transférées dans la file d'attente interrompue. Ces nombres peuvent être modifiés par le biais du Gestionnaire d'échanges BizTalk ou par programme. Pour plus d'informations sur le changement du nombre de nouveaux essais, voir Définition des propriétés de configuration avancées ou Propriété RetryCount et Propriété RetryInterval.

Les administrateurs de BizTalk Server peuvent sélectionner n'importe quel document dans cette file d'attente et le déplacer vers la file d'attente interrompue.

Voir aussi

Déplacement de documents vers la file d'attente interrompue

Propriété RetryCount

Propriété RetryInterval

Définition des propriétés de configuration avancées

Utilisation des files d'attente


File d'attente interrompue

La file d'attente interrompue contient des éléments de travail dont le traitement a échoué pour diverses raisons, notamment des erreurs d'analyse, des erreurs de sérialisation, des échecs de transmission, ou l'incapacité de trouver une configuration de canal. Les administrateurs de BizTalk Server peuvent cliquer avec le bouton droit sur n'importe quel document dans cette file d'attente pour choisir l'une des options suivantes :

  • Afficher la description de l'erreur. Permet aux administrateurs de BizTalk Server d'afficher des descriptions d'erreur qui indiquent pourquoi le document a été envoyé à la file d'attente interrompue.

  • Afficher l'échange. Permet aux administrateurs de BizTalk Server d'afficher le contenu d'un échange dont le traitement a échoué pour diverses raisons, notamment des erreurs d'analyse ou des échecs de transmission. Afficher l'échange apparaît dans les états suivants :
    • Initial

    • Composant personnalisé

    • Analyse

    • Cryptage

    • Signature

    • Cryptage

    • Transmission en cours
  • Afficher le document. Permet aux administrateurs de BizTalk Server d'afficher le contenu d'un document dont le traitement a échoué pour diverses raisons, notamment des erreurs de sérialisation ou l'impossibilité de trouver un canal. Afficher l'échange apparaît dans les états suivants :
    • Validation du document

    • Sélection du canal

    • Suivi de champs

    • Mappage

    • Corrélation

    • Sérialisation
  • Suppression. Permet aux administrateurs de BizTalk Server de supprimer complètement une entrée de la file d'attente interrompue. Cette opération n'est pas récupérable. Après qu'un document a été supprimé de la file d'attente interrompue, vous ne pouvez pas le récupérer.

  • Soumettre à nouveau. Permet aux administrateurs de BizTalk Server de soumettre à nouveau des échanges et des documents à BizTalk Server pour traitement.

États de la file d'attente interrompue

Des échanges et des documents sont placés dans la file d'attente interrompue pour diverses raisons. Le tableau suivant présente les états de la file d'attente interrompue, leurs messages d'erreur associés, et l'action à entreprendre éventuellement.

État de la file d'attente interrompue | Message d'erreur | Description de l'erreur et action possible
Sélection du canal ou Transmission en cours | Erreur inattendue | Un incident de serveur interne s'est produit. Soumettez à nouveau le document.
Sélection du canal ou Transmission en cours | Inconnu | L'échange ou le document a été marqué comme étant « en traitement » par un serveur inactif. Lorsque le serveur a redémarré, cet élément a été automatiquement transféré dans la file d'attente interrompue. Un incident s'est probablement produit sur le serveur d'origine. Pour plus d'informations, contactez l'administrateur système. Une fois le problème corrigé, soumettez à nouveau le document ou l'échange.
Sélection du canal ou Transmission en cours | Mémoire insuffisante | L'ordinateur sur lequel BizTalk Server est exécuté n'a pas suffisamment de mémoire. Redémarrez le serveur et soumettez à nouveau tous les échanges et documents contenus dans la file d'attente interrompue.
Analyse | Échec de l'analyse | BizTalk Server n'a pas pu analyser les données. Affichez le contenu de l'échange pour déterminer pourquoi BizTalk Server n'a pas pu analyser les données. Soumettez à nouveau l'échange à l'aide de IInterchange ou d'une fonction de réception. Pour plus d'informations, voir Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue ou Erreurs d'analyse.
Analyse | Données manquantes | Les informations extraites à partir des données entrantes ne contenaient pas suffisamment de données pour permettre la recherche d'un canal. Affichez l'échange et identifiez les données manquantes. Soumettez à nouveau l'échange à l'aide de IInterchange ou d'une fonction de réception. Pour plus d'informations, voir Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue ou Erreurs d'analyse.
Analyse | « expiresAt » expiré | L'horodatage BizTalk Framework « expiresAt » a expiré. Ce document n'est plus valide. Pour plus d'informations, voir Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue.
Sélection du canal | Aucun canal trouvé | BizTalk Server n'a pas pu trouver de canal correspondant à ce document. Créez un canal pour le document, ou corrigez le document puis soumettez-le à nouveau.
Sélection du canal | Canal supprimé | Le canal associé à ce document a été supprimé après que le document a atteint la file d'attente de travail. Reconfigurez le canal, ou configurez le document pour un autre canal, puis soumettez à nouveau le document. — ou — Ne soumettez pas le document et supprimez-le de la file d'attente interrompue.
Suivi de champs ou Initial | Canal manquant | Le canal spécifié par la fonction de réception ou l'appel soumis est introuvable. Configurez un canal ou reconfigurez le document et soumettez-le à nouveau.
Sélection du canal | Canal non valide | Le canal spécifié par l'appel soumis était un canal ouvert. Les canaux ouverts ne sont pas valides pour les appels soumis directs. Changez le canal et soumettez à nouveau le document.
Mappage | Échec du mapping | Le format du mappage référencé par le canal est incorrect. Supprimez le document de la file d'attente interrompue, corrigez le mappage, puis soumettez à nouveau le document en tant que nouveau document.
Sérialisation | Échec de sérialisation | BizTalk Server n'a pas pu convertir le document dans son format natif. Soumettez à nouveau le document.
Codage | Échec du codage | BizTalk Server n'a pas pu coder cet échange. Soumettez à nouveau l'échange.
Signature | Échec de la signature | BizTalk Server n'a pas pu signer cet échange. Le certificat a peut-être expiré. Pour plus de détails, reportez-vous au composant logiciel enfichable Certificats de Microsoft Management Console (MMC). Pour plus d'informations sur l'affichage du composant logiciel enfichable Certificats dans l'aide de Windows 2000, reportez-vous à la rubrique « Ajouter le composant logiciel enfichable Certificats à la console MMC » du chapitre Gérer les certificats.
Cryptage | Échec du cryptage | BizTalk Server n'a pas pu crypter cet échange. Le certificat a peut-être expiré. Pour plus de détails, reportez-vous au composant logiciel enfichable Certificats de Microsoft Management Console (MMC). Pour plus d'informations sur l'affichage du composant logiciel enfichable Certificats dans l'aide de Windows 2000, reportez-vous à la rubrique « Ajouter le composant logiciel enfichable Certificats à la console MMC » du chapitre Gérer les certificats.
Transmission en cours | Échec de la transmission | BizTalk Server n'a pas pu livrer cet échange. Vérifiez l'adresse du transport dans le canal. Corrigez le problème et soumettez à nouveau l'échange.
Transmission en cours | Échec du délai d'expiration | BizTalk Server n'a pas pu terminer le traitement de cet échange avant la fin du délai d'expiration. Cet incident pourrait être causé par une transmission trop longue. Si vous utilisez un transport non fiable, vérifiez que l'échange a été envoyé avant de tenter de soumettre à nouveau l'échange.
Transmission en cours | Déplacement de l'utilisateur | Un administrateur BizTalk Server a déplacé ce document dans la file d'attente interrompue. Soumettez à nouveau l'échange.
Transmission en cours | Horodatage arrivé à expiration | L'horodatage de BizTalk Framework « receiptRequiredBy » a expiré. Ce document n'est plus valide.
Validation du document | Document incorrect | La validation du document par rapport à sa spécification a échoué. Recherchez l'erreur dans le journal des événements pour obtenir plus d'informations. Corrigez le schéma et soumettez à nouveau le document.
Suivi de champs | Échec du suivi des champs | BizTalk Server n'a pas pu effectuer le suivi des champs demandés dans le document. Affichez le document pour vérifier que les champs à suivre sont présents, ou changez la configuration de canal pour le suivi de champs. Puis soumettez à nouveau le document.
Composant personnalisé | Échec d'un composant personnalisé | Un composant personnalisé a échoué. Dépannez le composant personnalisé ou le préprocesseur personnalisé et soumettez l'échange.
Corrélation | Défaillance de la corrélation | Une défaillance s'est produite lors de la corrélation de cet accusé de réception.

Remarques

  • Outre les messages d'erreur dans la file d'attente interrompue, vous pouvez également vérifier le journal des événements pour obtenir d'autres informations. Pour plus d'informations sur le journal des événements, voir Gestion de l'Observateur d'événements.

  • Il n'est pas possible de soumettre à nouveau tous les documents présents dans la file d'attente interrompue. Dans certains cas, vous devez supprimer les documents et les soumettre de nouveau à partir de l'application ou de l'organisation d'origine.

Voir aussi

Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue

Gestion de l'Observateur d'événements

Gestion des files d'attente

Erreurs d'analyse

Description des propriétés avancées d'une fonction de réception

Description des fonctions de réception et du routage de documents

Utilisation des files d'attente


Privilèges d'administration

Pour afficher la console Administration de BizTalk Server, vous devez être membre du groupe des administrateurs de BizTalk Server. Si vous n'êtes pas connecté en tant qu'administrateur de BizTalk Server, vous ne pouvez pas afficher les éléments contenus dans le dossier Microsoft BizTalk Server 2002. Si vous êtes membre du groupe des administrateurs de BizTalk Server, mais n'êtes pas membre du groupe des administrateurs de Microsoft Windows 2000, vous pouvez uniquement effectuer les tâches suivantes :

  • ajouter et supprimer des groupes de serveurs ;

  • afficher et modifier des propriétés de groupe ;

  • gérer toutes les files d'attente et leurs entrées ;

  • ajouter et supprimer des fonctions de réception ;

  • afficher et modifier des propriétés de fonction de réception.

En outre, si vous administrez un groupe de serveurs qui contient trois serveurs, par exemple, Server_1, Server_2 et Server_3, vous devez avoir des privilèges d'administrateur Windows 2000 sur les trois serveurs. Si les privilèges d'administrateur Windows 2000 ont été changés sur Server_1, et si vous n'avez plus de privilèges d'administrateur, la console d'administration renvoie la liste des trois serveurs associés au groupe et indique l'état de chaque serveur. L'état renvoyé de Server_1 est maintenant Accès refusé.

Si vous êtes membre du groupe des administrateurs de BizTalk Server et du groupe des administrateurs de Windows 2000, vous pouvez effectuer les tâches supplémentaires suivantes :

  • ajouter ou supprimer des serveurs dans un groupe de serveurs ;

  • afficher et modifier des propriétés de serveur ;

  • afficher l'état d'un serveur ;

  • libérer des échanges sur un serveur.

Par ailleurs, vous devez également être membre du groupe Administrateurs de SQL Server pour être autorisé à accéder aux bases de données.

Pendant la configuration, l'utilisateur qui effectue l'installation de BizTalk Server est ajouté au groupe des administrateurs de BizTalk Server. Vous pouvez ajouter d'autres utilisateurs au groupe d'administrateurs de BizTalk Server. Pour plus d'informations, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.


Pourquoi utiliser Administration de BizTalk Server

Cette section explique en quelques mots pourquoi il est nécessaire d'effectuer des tâches sur la console Administration de BizTalk Server. Le tableau suivant présente les tâches principales et leurs sous-tâches. Il présente également l'objet de chaque tâche et contient des liens vers les procédures correspondantes.

Tâche Objet de la tâche
  • Ouverture de Administration de BizTalk Server
 Effectuer la plupart des tâches administratives.
  • Ouverture des services de composants
 Effectuer des tâches administratives supplémentaires.
  • Publication de BizTalk Server 2002 dans Active Directory
 Publier la disponibilité de BizTalk Server dans un environnement distribué.
  • Suppression de BizTalk Server 2002 de Active Directory
 Supprimer l'enregistrement de cet ordinateur pour que seuls les ordinateurs exécutant toujours BizTalk Server soient correctement identifiés lors de l'interrogation de Active Directory.
  • Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server
 Ajouter de nouveaux utilisateurs qui souhaitent obtenir l'autorisation d'administrer BizTalk Server.
  • Configuration de la base de données Gestion d'échanges BizTalk
 Placer la base de données Gestion d'échanges BizTalk hors connexion en vue de la maintenance.
  • Modification de la base de données Gestion d'échanges BizTalk gérée dans une installation d'outils.
 Modifier la base de données Gestion d'échanges BizTalk administrée à partir d'un ordinateur client.
  • Actualisation de la console d'administration
 Visualiser l'état actuel des groupes de serveurs, des serveurs, des fonctions de réception, du nombre d'éléments dans une file d'attente, etc.
Ajout, suppression et configuration d'un groupe de serveurs :
  • Ajout d'un groupe de serveurs
 Ajouter un nouveau groupe de serveurs BizTalk lorsqu'une évolution horizontale est nécessaire. Les groupes de serveurs BizTalk Server sont un facteur clé de l'évolutivité de BizTalk Server. En créant des groupes de serveurs supplémentaires, vous augmentez la vitesse du traitement qui est ainsi répartie entre les partitions d'un plus grand nombre d'ordinateurs.
  • Configuration des propriétés générales d'un groupe de serveurs
  • Modifier l'hôte SMTP utilisé par un groupe de serveurs BizTalk.

  • Modifier l'URL utilisée par le groupe de serveurs BizTalk pour recevoir des accusés de réception pour un échange au format Reliable.

  • Modifier la fréquence d'actualisation du cache d'objet de gestion des échanges BizTalk.

  • Ajouter et/ou modifier le serveur proxy utilisé par le groupe de serveurs BizTalk.
  • Configuration des propriétés de connexion d'un groupe de serveurs
 Modifier les bases de données de files d'attente partagées et/ou de suivi auxquelles le groupe de serveurs BizTalk se connecte. Généralement, ces dernières doivent être modifiées uniquement lorsqu'il est nécessaire de changer de base de données ou de serveur de base de données, par exemple suite à une récupération d'urgence après un désastre ou dans le cadre d'une sauvegarde.
  • Configuration des propriétés de suivi d'un groupe de serveurs
 Permettre divers niveaux de suivi de document pour le groupe de serveurs, puis activer et désactiver le suivi.
  • Configuration de l'ordre des parseurs d'un groupe de serveurs
 Modifier l'ordre des parseurs ou actualiser la liste des parseurs à partir du Registre. L'ordre de la liste des parseurs peut être modifié, par exemple, pour optimiser la vitesse de traitement lorsque tout ou partie des documents reçus est d'un type spécifique. En plaçant le parseur correspondant à ces documents en tête de liste, BizTalk Server traitera les documents plus rapidement, puisqu'il n'essaiera pas de les analyser avec d'autres parseurs.
  • Suppression d'un groupe de serveurs
 Supprimer la totalité d'un groupe de serveurs BizTalk. Si, par exemple, les performances globales de la vitesse de traitement sont réduites, la suppression d'un ou de plusieurs groupes peut libérer les ressources matérielles à d'autres fins.
Ajout, suppression et configuration de serveurs dans un groupe :
  • Ajout d'un serveur à un groupe
 Ajouter un nouveau serveur à un groupe de serveurs BizTalk existant. Outre l'ajout de groupes à une implémentation BizTalk Server, chaque groupe peut comporter un nombre variable de serveurs qui lui est associé. En optimisant le nombre de serveurs du groupe par rapport à la puissance de traitement des serveurs de base de données du groupe, la vitesse de traitement est maximalisée.
  • Suppression d'un serveur d'un groupe
 Supprimer un serveur d'un groupe de serveurs BizTalk. Pour déplacer un serveur d'un groupe de serveurs BizTalk à un autre, vous devez le supprimer du groupe actuel avant de l'ajouter au nouveau groupe.
  • Configuration d'un serveur dans un groupe
 Modifier les propriétés générales d'un serveur, telles que le nombre maximal de threads de fonction de réception autorisé, et spécifier si le serveur doit participer au traitement de l'élément de travail. En créant des fonctions de réception qui s'exécutent sur le serveur et en spécifiant que le serveur ne doit pas participer au traitement, vous optimisez la rapidité de réception des échanges du serveur, ce qui contribue à l'amélioration globale de la vitesse de traitement.
  • Modification de la base de données Gestion d'échanges BizTalk d'un serveur
 Modifier la base de données Gestion d'échanges utilisée par un serveur. Cette opération n'est généralement nécessaire que lorsqu'une modification permanente d'une autre base de données est requise, par exemple en cas de récupération d'urgence après un désastre ou lorsque le serveur de base de données existant est remplacé par un autre serveur de base de données.
Gestion de serveurs dans un groupe :
  • Démarrage d'un serveur dans un groupe
 Démarrer un serveur BizTalk Server. Cette tâche démarre les services d'exécution de BizTalk Server sur le serveur associé de sorte qu'il puisse participer à la réception et/ou au traitement des échanges.
  • Arrêt d'un serveur dans un groupe
 Arrêter un serveur BizTalk. Cette tâche arrête les services d'exécution de BizTalk Server sur le serveur associé de sorte qu'il cesse de participer à la réception et/ou au traitement des échanges.
  • Échanges libres à partir d'un serveur
 Libérer des échanges d'un serveur afin qu'ils puissent être redistribués vers d'autres serveurs du groupe si le serveur initial est arrêté ou mis hors connexion.
  • Configuration du cache disque
 Activer ou désactiver la mise en cache du disque. Lorsque la mise en cache du disque est désactivée, ceci permet d'éviter la perte des données en cas de panne catastrophique telle qu'une coupure de courant.
Gestion des files d'attente :
  • Déplacement de documents vers la file d'attente interrompue
 Déplacer un document des files d'attente de travail, planifiées ou de nouvel essai vers la file d'attente interrompue. En général, cette tâche s'effectue si un message spécifique ou un groupe de messages doit être interrompu en raison d'un type de problème particulier ou d'une condition d'exception relative soit au message lui-même, soit aux systèmes auxquels le message est susceptible d'être envoyé par la suite s'il n'est pas interrompu.
  • Affichage des descriptions d'erreur
 Déterminer l'erreur qui a généré le placement d'un document dans la file d'attente interrompue. Ceci est fourni en premier lieu pour prendre en charge les scénarios de résolution des incidents.
  • Affichage des échanges
 Visualiser un échange qui a été placé dans la file d'attente interrompue. Ceci est fourni en premier lieu pour prendre en charge les scénarios de résolution des incidents.
  • Affichage des documents
 Visualiser un document qui a été placé dans la file d'attente interrompue. Ceci est fourni en premier lieu pour prendre en charge les scénarios de résolution des incidents.
  • Renvoi de documents
 Renvoyer un document qui se trouve dans la file d'attente interrompue. Cette tâche s'effectue généralement pour renvoyer des messages une fois que la raison pour laquelle ils ont été interrompus est résolue. Par exemple, lorsqu'un problème de transport a entraîné l'interruption d'un certain nombre de messages, il suffit de les renvoyer une fois le problème résolu, pour que leur transmission s'effectue correctement.
  • Suppression de documents
 Supprimer un document placé dans la file d'attente interrompue. Ceci suppose que le message n'est plus nécessaire ou qu'il a été enregistré par l'utilisateur.
Gestion des bases de données d'un groupe de serveurs :
  • Arrêt de l'application Échange BizTalk Server
 Modifier une connexion aux bases de données Gestion des échanges BizTalk, de suivi ou de files d'attente partagées.
  • Suppression des bases de données de suivi et de files d'attente partagées
 Supprimer les bases de données de suivi et de files d'attente partagées. Généralement, cette tâche s'effectue uniquement si BizTalk Server a été configuré pour utiliser une base de données de suivi et/ou de files d'attente partagées différente. Si ces bases de données sont supprimées sans que BizTalk Server ait été préalablement configuré pour utiliser d'autres bases de données, BizTalk Server ne fonctionnera plus correctement.
  • Restauration manuelle de la base de données de suivi
 Si la base de données de suivi est altérée ou endommagée. Ceci suppose qu'une sauvegarde a été préalablement créée, afin de pouvoir restaurer la base de données.
  • Restauration manuelle de la base de données de files d'attente partagée
 Si la base de données de files d'attente partagées est altérée ou endommagée. Ceci suppose qu'une sauvegarde a été préalablement créée, afin de pouvoir restaurer les données.
Gestion des fonctions de réception d'un groupe de serveurs :
  • Ajout d'une fonction de réception de fichier
 Créer une fonction de réception de fichier.
  • Configuration d'une fonction de réception de fichier : onglet Général
 Configurer les propriétés générales d'une fonction de réception de fichier, par exemple des informations de sécurité, et activer ou désactiver la fonction.
  • Configuration d'une fonction de réception de fichier : onglet Services
 Modifier le serveur sur lequel s'exécute la fonction de réception de fichier, les informations d'interrogation ou le préprocesseur utilisé par la fonction de réception de fichier.
  • Ajout d'une fonction de réception Message Queuing
 Créer une fonction de réception Message Queuing.
  • Configuration d'une fonction de réception Message Queuing : onglet Général
 Configurer les propriétés générales d'une fonction de réception Message Queuing, telles que les informations de sécurité, et pour activer ou désactiver la fonction.
  • Configuration d'une fonction de réception Message Queuing : onglet Services
 Modifier le serveur sur lequel s'exécute la fonction de réception Message Queuing, les informations d'interrogation ou le préprocesseur utilisé par la fonction de réception Message Queuing.
  • Ajout d'une fonction de réception HTTP
 Créer une fonction de réception HTTP. Pour que le transport de réception fonctionne correctement, vous devez faire suivre cette tâche de la tâche Configuration des privilèges d'accès selon le niveau de protection IIS.
  • Configuration d'une fonction de réception HTTP : onglet Général
 Activer ou désactiver la fonction de réception HTTP.
  • Configuration d'une fonction de réception HTTP : onglet Services
 Modifier la configuration des services de la fonction de réception HTTP, telles que le serveur sur lequel s'exécute la fonction de réception, le répertoire virtuel utilisé, la destination d'envoi de la fonction de réception, et indiquer si un jeton de corrélation est utilisé.
  • Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP
 Configurer les propriétés avancées des fonctions de réception. Ces propriétés concernent le niveau d'ouverture, le nom d'enveloppe et de canal, ainsi que les informations relatives aux organisations source et de destination. Vous pouvez configurer les propriétés avances lors de la création de la fonction de réception et à tout moment.
  • Configuration des privilèges d'accès selon le niveau de protection IIS
 Pour que le transport de réception fonctionne correctement, vous devez effectuer cette tâche après la création de la fonction de réception HTTP.
  • Suppression d'une fonction de réception
 Supprimer de manière définitive une fonction de réception.
Gestion des services BizTalk :
  • Démarrage d'un service BizTalk
 Démarrer un service BizTalk sur le serveur associé. Le démarrage des services active le traitement des messages par ce serveur. Afin de pouvoir démarrer un serveur, celui-ci doit être arrêté.
  • Arrêt d'un service BizTalk
 Arrêter les services BizTalk sur le serveur associé. L'arrêt des services interrompt le traitement des messages par ce serveur. Afin de pouvoir être arrêté, un serveur doit être en cours d'exécution. L'arrêt des services s'effectue généralement pour interrompre temporairement le traitement afin de modifier la configuration ou résoudre des problèmes.
Gestion de l'Observateur d'événements :
  • Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server
 Afficher uniquement les événements liés à BizTalk Server et/ou à XLANG Scheduler dans le journal des événements d'applications. Cette tâche s'effectue généralement lorsqu'il y a un grand nombre d'événements non liés à BizTalk Server que vous ne souhaitez pas afficher lors de la résolution des problèmes.
  • Affichage des erreurs d'application dans l'Observateur d'événements
 Consulter les messages d'erreur consignés dans l'Observateur d'événements.
Gestion des applications et des bases de données XLANG :
  • Utilisation de procédures stockées pour supprimer des enregistrements de la base de données de persistance
 Supprimer les anciens documents de persistance de la base de données de persistance.
  • Arrêt de toutes les applications XLANG
 Effectuer un arrêt contrôlé de toutes les planifications XLANG associées à toutes les applications XLANG COM+. Vous enregistrez ainsi l'état de toutes les planifications XLANG en cours d'exécution dans la base de données de persistance.
  • Redémarrage de toutes les applications XLANG
 Effectuer un redémarrage contrôlé de toutes les applications XLANG COM+.
Gestion de l'application XLANG Scheduler par défaut :
  • Modification de l'identité de l'application XLANG Scheduler par défaut
 Lors de la première installation de BizTalk Server, l'application COM+ XLANG Scheduler est configurée pour s'exécuter en tant qu'utilisateur interactif. Avant que le moteur de XLANG Scheduler puisse être utilisé sans qu'aucun utilisateur interactif ne soit connecté, l'application doit être configurée pour s'exécuter en tant que compte Windows spécifique.
Gestion des autres applications COM+ hébergeant des planifications XLANG :
  • Création d'une base de données de persistance vide
 Créer une base de données de persistance avec les paramètres par défaut.
  • Modification de l'identité d'une application COM+
 Changer le compte d'utilisateur interactif par défaut d'une application COM+.
  • Modification des paramètres DSN d'une application COM+
 Modifier les paramètres de nom de la source des données (DSN) d'une application COM+ et générer la structure de la nouvelle base de données de persistance vide.
  • Arrêt d'une application COM+ hébergeant des planifications XLANG
 Effectuer un arrêt contrôlé de toutes les planifications XLANG associées à une application COM+ XLANG spécifique. Vous enregistrez ainsi l'état de toutes les planifications XLANG dans la base de données de persistance.
  • Surveillance de l'exécution des planifications XLANG
 Cette section fournit des informations sur les outils disponibles pour surveiller le bon fonctionnement des planifications XLANG.


Comment utiliser Administration de BizTalk Server

Cette section fournit des informations sur les procédures d'utilisation d'Administration de BizTalk Server. Il est vivement recommandé de prendre connaissance de la section À propos de Administration de BizTalk Server afin de comprendre parfaitement toutes les fonctionnalités et capacités de la console Administration de BizTalk.

Cette section traite des rubriques et procédures suivantes :

  • Ouverture de Administration de BizTalk Server

  • Ouverture des services de composants

  • Publication de BizTalk Server 2002 dans Active Directory

  • Suppression de BizTalk Server 2002 de Active Directory

  • Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server

  • Configuration de la base de données Gestion d'échanges BizTalk

  • Modification de la base de données Gestion d'échanges BizTalk gérée dans une installation d'outils.

  • Actualisation de la console d'administration

  • Ajout, suppression et configuration d'un groupe de serveurs

  • Ajout, suppression et configuration de serveurs dans un groupe

  • Gestion de serveurs dans un groupe

  • Gestion des files d'attente

  • Gestion des bases de données d'un groupe de serveurs

  • Gestion des fonctions de réception d'un groupe de serveurs

  • Gestion des services BizTalk

  • Gestion de l'Observateur d'événements

  • Gestion des applications et des bases de données XLANG


Ouverture de Administration de BizTalk Server

La plupart des tâches administratives de BizTalk Server s'effectuent dans le composant logiciel enfichable MMC (Microsoft Management Console) appelé Administration de BizTalk Server.

  • Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Administration de BizTalk Server.


Ouverture des services de composants

Certaines tâches administratives requièrent l'utilisation des services de composants.

  • Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Outils d'administration et sur Services de composants.


Publication de BizTalk Server 2002 dans Active Directory

Après avoir installé BizTalk Server 2002, vous pouvez le publier dans les services d'annuaire Microsoft® Active Directory™ pour déterminer la disponibilité de BizTalk Server dans un environnement distribué. Supposons, par exemple, que vous souhaitiez connaître les ordinateurs qui exécutent BizTalk Server. Pour cela, publiez BizTalk Server 2002 dans les services Active Directory.

  1. Dans le menu Démarrer, cliquez sur Exécuter.

  2. Dans la zone Ouvrir, tapez cmd et cliquez sur OK.

  3. À l'invite de commandes, changez le répertoire par le dossier Setup dans votre répertoire d'installation de BizTalk Server 2002.

    Exemple : à l'invite de commandes, tapez cd \Program Files\Microsoft BizTalk Server\Setup et appuyez sur ENTRÉE.

  4. À l'invite de commandes, tapez cscript AD_registration.vbs et appuyez sur ENTRÉE.

  5. Dans la boîte de dialogue de confirmation, cliquez sur OK.

  6. À l'invite de commandes, tapez exit et appuyez sur ENTRÉE.

Remarque

  • Le script AD_registration.vbs n'est pas conçu pour être utilisé sur un ordinateur distant. Il est conseillé de l'exécuter sur un ordinateur local. Si vous devez enregistrer un ordinateur distant, effectuez impérativement la modification suivante :
    • Remplacez la valeur de la variable Nom_serveur dans le script AD_registration.vbs par le nom de l'ordinateur distant. Ainsi, l'ordinateur local appelle le fournisseur WMI (Windows Management Instrumentation) sur l'ordinateur distant à enregistrer. Le fournisseur WMI de l'ordinateur distant implémente le code approprié.


Suppression de BizTalk Server 2002 de Active Directory

Lorsque vous supprimez BizTalk Server 2002 d'un ordinateur, son enregistrement n'est pas supprimé automatiquement des services d'annuaire Active Directory. Vous devez supprimer l'enregistrement de cet ordinateur pour que seuls les ordinateurs exécutant toujours BizTalk Server 2002 soient correctement identifiés lors de l'interrogation de Active Directory.

  1. Dans le menu Démarrer, cliquez sur Exécuter.

  2. Dans la zone Ouvrir, tapez cmd et cliquez sur OK.

  3. À l'invite de commandes, changez le répertoire par le dossier Setup dans votre répertoire d'installation de BizTalk Server 2002.

    Exemple : à l'invite de commandes, tapez cd \Program Files\Microsoft BizTalk Server\Setup et appuyez sur ENTRÉE.

  4. À l'invite de commandes, tapez cscript AD_registration.vbs /u et appuyez sur ENTRÉE.

  5. Dans la boîte de dialogue de confirmation, cliquez sur OK.

  6. À l'invite de commandes, tapez exit et appuyez sur ENTRÉE.


Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server

Pour ajouter des utilisateurs au groupe Administrateurs de BizTalk Server, vous devez être membre du groupe Administrateurs de Windows 2000 local. Pour plus d'informations sur l'ajout d'utilisateurs au groupe Administrateurs de Windows 2000 local, reportez-vous à « Ajout d'un utilisateur à un groupe » dans l'aide de Windows 2000.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Gestion de l'ordinateur.

  2. Développez Outils système, Utilisateurs et groupes locaux, puis cliquez sur le dossier Groupes.

    Le contenu du dossier apparaît dans le volet de détails.

  3. Dans le volet de détails, cliquez sur Administrateurs de BizTalk Server.

  4. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Ajouter au groupe.

    La boîte de dialogue Propriétés de Administrateurs de BizTalk Server s'affiche.

  5. Cliquez sur Ajouter.

  6. Dans la liste Regarder dans, cliquez sur votre domaine ou le nom de votre ordinateur.

  7. Dans la liste contenant les utilisateurs et les ordinateurs associés au domaine ou à l'ordinateur que vous avez sélectionné à l'étape 6, cliquez sur le compte utilisateur à ajouter, sur Ajouter, puis sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue Propriétés de Administrateurs de BizTalk Server.

Voir aussi

Privilèges d'administration


Configuration de la base de données Gestion d'échanges BizTalk

Utilisez cette procédure si vous devez mettre la base de données Gestion d'échanges BizTalk hors connexion pour des opérations de maintenance. Pour que BizTalk Server continue à fonctionner sans interruption pendant la maintenance, vous devez répliquer la base de données Gestion d'échanges BizTalk et pointer tous les serveurs vers ce réplica.

Remarque

  • Si vous pointez les serveurs vers une autre base de données qui n'est pas un réplica de l'original, vous risquez d'avoir des difficultés à retourner à la configuration d'origine de la base de données Gestion d'échanges BizTalk, une fois la maintenance terminée. Cette méthode est donc déconseillée.

Pour plus d'informations sur l'utilisation d'une autre base de données, voir Modification de la base de données Gestion d'échanges BizTalk.

  1. Arrêtez tous les serveurs du nœud Microsoft BizTalk Server 2002.

    Pour plus d'informations, voir Arrêt d'un serveur dans un groupe.

  2. Dans Administration de BizTalk Server, cliquez sur Microsoft BizTalk Server 2002.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de BizTalk Server 2002 s'affiche.

  4. L'onglet Général vous permet de modifier les propriétés suivantes :
    • Nom de base de données SQL. Entrez le nom du réplica de la base de données Gestion d'échanges BizTalk qui sera utilisé par tous les serveurs lors de mise hors connexion de la base de données d'origine.

    • Nom du serveur SQL. Tapez le nom du serveur qui stocke le réplica de base de données Microsoft® SQL Server™.
  5. Cliquez sur OK.

  6. Fermez l'application Échange BizTalk Server.

    Pour plus d'informations, voir Arrêt de l'application Échange BizTalk Server.

  7. Redémarrez tous les serveurs du nœud Microsoft BizTalk Server 2002.

    Pour plus d'informations, voir Démarrage d'un serveur dans un groupe.

  8. Redémarrez le service d'échanges BizTalk.

    Pour plus d'informations, voir Démarrage d'un service BizTalk.

Remarques

  • Lorsque vous utilisez une autre base de données Gestion d'échanges BizTalk ou que vous pointez les groupes de serveurs vers un autre serveur Microsoft SQL Server, tous les serveurs BizTalk de la base de données Gestion d'échanges BizTalk sont mis à jour avec les nouvelles informations.

  • L'application Échange BizTalk Server redémarrera automatiquement la prochaine fois qu'un message sera envoyé via l'interface COM+ IInterchange.

  • Dans Microsoft BizTalk Server 2002, l'accès au serveur SQL dépend de la fonction d'authentification intégrée de Microsoft Windows®. Par conséquent, les services BizTalk doivent fonctionner sous un domaine ou un compte local qui dispose des droits d'accès au serveur SQL. Si le mot de passe du compte de service Échanges utilisé par BizTalk Server change, vous devez utiliser, pour le modifier, l'utilitaire de ligne de commande fourni. Pour plus d'informations sur la modification du mot de passe d'un compte de service, voir Modification du mot de passe du compte de service.

Voir aussi

Modification de la base de données Gestion d'échanges BizTalk

Gestion des services BizTalk

Arrêt de l'application Échange BizTalk Server

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Modification de la base de données Gestion d'échanges BizTalk gérée dans une installation d'outils

Cette procédure remplace la base de données Gestion d'échanges BizTalk gérée à partir d'un ordinateur client par une installation d'outils de BizTalk Server. En revanche, elle ne modifie pas la base de données Gestion d'échanges BizTalk vers laquelle pointe l'exécution de BizTalk Server. Pour modifier la base de données d'échanges BizTalk vers laquelle pointe l'exécution de BizTalk Server, voir Configuration de la base de données Gestion d'échanges BizTalk.

  1. Dans Administration de BizTalk Server, cliquez sur Microsoft BizTalk Server 2002.

  2. Dans le menu Action, cliquez sur Sélectionner une BDD de config.

    La boîte de dialogue Sélectionner une base de données de gestion s'affiche.

  3. Dans la zone Nom de la base de données SQL, tapez le nom de la base de données Gestion d'échanges BizTalk que vous voulez gérer à partir de l'ordinateur client.

  4. Dans la zone Nom du serveur SQL, entrez le nom du serveur qui stocke la base de données Microsoft SQL Server sur laquelle la base de données Gestion d'échanges BizTalk à administrer est stockée.

  5. Cliquez sur OK.

Remarque

  • Cette option est disponible uniquement dans une installation d'outils de BizTalk Server.

Voir aussi

Fonctions d'administration de l'installation des outils de BizTalk Server


Actualisation de la console d'administration

Étant donné qu'il n'existe pas de cycle d'actualisation automatique pour la console d'administration, vous devez utiliser cette procédure pour afficher l'état actuel des éléments suivants :

  • Nœud Microsoft BizTalk Server 2002

  • Groupes de serveurs

  • Serveurs

  • Files d'attente

  • Fonctions de réception
  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis les éléments de l'arborescence de la console jusqu'à ce que vous trouviez l'élément à actualiser.

  2. Vous devrez peut-être développer Groupes de serveurs, Files d'attente, Fonctions de réception et Serveurs pour trouver l'élément que vous voulez actualiser.

  3. Cliquez sur l'élément que vous souhaitez actualiser.

  4. Dans le menu Action, cliquez sur Actualiser.

Remarque

  • Vous pouvez effectuer cette opération d'actualisation pour tous les éléments de l'arborescence de la console. Lorsque vous actualisez la console d'administration au niveau de la racine, tous les éléments de la console d'administration sont actualisés. En revanche, lorsque vous actualisez un groupe de serveurs, seuls les éléments de ce groupe sont actualisés.

Voir aussi

Groupes et serveurs

Fonctions de réception

Utilisation des files d'attente


Ajout, suppression et configuration d'un groupe de serveurs

Les groupes de serveurs sont des collections des serveurs individuels faisant l'objet d'une gestion, d'une configuration et d'une surveillance centralisées. Les groupes de serveurs sont un facteur clé de l'évolutivité de BizTalk Server. En créant des groupes de serveurs supplémentaires, vous augmentez la vitesse du traitement qui est ainsi répartie entre les partitions d'un plus grand nombre d'ordinateurs. Les serveurs d'un groupe de serveurs BizTalk ont les éléments suivants en commun :

  • Une base de données de files d'attente partagée qui assure la persistance de tous les documents jusqu'à l'aboutissement de leur traitement.

  • Une base de données de suivi qui permet de consigner l'activité liée aux documents et aux échanges, et d'exécuter des rapports.

  • Des fonctions de réception.

  • Tous les composants dont le serveur a besoin lors du traitement des documents et des échanges, notamment les composants de transport et les composants d'intégration d'application (AIC).

Cette section traite des procédures suivantes :

  • Ajout d'un groupe de serveurs

  • Configuration des propriétés générales d'un groupe de serveurs

  • Configuration des propriétés de connexion d'un groupe de serveurs

  • Configuration des propriétés de suivi d'un groupe de serveurs

  • Configuration de l'ordre des parseurs d'un groupe de serveurs

  • Suppression d'un groupe de serveurs

Remarque

  • Si vous configurez plusieurs groupes de serveurs par souci d'évolutivité et d'amélioration des performances, utilisez une seule base de données Gestion d'échanges BizTalk centrale. Sinon, ses serveurs ne peuvent pas partager la même configuration de Gestion d'échanges BizTalk.


Ajout d'un groupe de serveurs

Au fur et à mesure que les besoins de votre entreprise évoluent, vous pouvez avoir besoin de restructurer les groupes de serveurs BizTalk Server afin d'optimiser les performances qui permettront de répondre à ces nouveaux besoins. Vous pourrez ainsi ajouter de nouveaux groupes de serveurs pour optimiser la gestion de votre organisation.

  1. Dans Administration de BizTalk Server, cliquez sur Microsoft BizTalk Server 2002.

  2. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Groupe.

    La boîte de dialogue Nouveau groupe s'affiche.

  3. Dans la zone Nom du groupe, entrez le nom du nouveau groupe de serveurs.

  4. Dans la zone Base de données de suivi :
    • Dans la zone Nom de la base de données de suivi, entrez le nom de la base de données de suivi pour ce groupe de serveurs.

    • Dans la zone Nom du serveur SQL de suivi, entrez le nom du serveur sur lequel est stockée la base de données de suivi correspondant à ce groupe.
  5. Dans la zone Base de données de files d'attente partagées :
    • Dans la zone Nom de la base de données de files d'attente partagées, entrez le nom de la base de données de files d'attente partagées correspondant à ce groupe de serveurs.

    • Dans la zone Nom du serveur SQL de files d'attente partagées, entrez le nom du serveur sur lequel est stockée la base de données de files d'attente partagées correspondant à ce groupe de serveurs.
  6. Cliquez sur OK.

Important

  • N'utilisez pas les caractères suivants dans le nom du groupe de serveurs :

    ~ ` ! @ # $ % ^ & * ( ) + = [ ] { } | ;\" '< > , . ?.

    Pour plus d'informations sur les caractères non valides, voir À propos de Windows Management Instrumentation.

Remarques

  • Cette procédure crée un groupe de serveurs. Pour utiliser des paramètres supplémentaires pour la configuration du groupe de serveurs, voir Configuration des propriétés générales d'un groupe de serveurs.

  • Si vous configurez plusieurs groupes de serveurs par souci d'évolutivité et d'amélioration des performances, utilisez une seule base de données Gestion d'échanges BizTalk centrale. Sinon, ses serveurs ne peuvent pas partager la même configuration de Gestion d'échanges BizTalk.

  • Dans Microsoft BizTalk Server 2002, l'accès au serveur SQL dépend de la fonction d'authentification intégrée de Microsoft Windows. Par conséquent, les services BizTalk doivent fonctionner sous un domaine ou un compte local qui dispose des droits d'accès au serveur SQL. Si le mot de passe du compte de service d'échanges utilisé par BizTalk Server change, vous devez utiliser, pour le modifier, l'utilitaire de ligne de commande fourni. Pour plus d'informations sur la modification du mot de passe d'un compte de service, voir Modification du mot de passe du compte de service.

Voir aussi

Ajout, suppression et configuration de serveurs dans un groupe

Configuration des propriétés générales d'un groupe de serveurs

Groupes et serveurs

Gestion de la base de données Gestion d'échanges BizTalk

Base de données de files d'attente partagées

Base de données de suivi

À propos de Windows Management Instrumentation


Configuration des propriétés générales d'un groupe de serveurs

Cette procédure vous permet de configurer les propriétés générales d'un groupe de serveurs spécifiques afin de partitionner le traitement entre différents groupes de serveurs.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis cliquez sur le groupe de serveurs que vous voulez configurer.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  3. Dans la zone Hôte SMTP, entrez le nom de l'hôte SMTP que ce groupe de serveurs utilise.

    Important

    • Le champ Hôte SMTP ne doit pas obligatoirement être renseigné. Vous devez toutefois configurer ce champ si vous envisagez d'utiliser SMTP comme service de transport dans le Gestionnaire d'échanges BizTalk. Par exemple, vous ne pouvez pas choisir SMTP comme transport principal ou secondaire dans le Gestionnaire d'échanges BizTalk si vous n'avez pas configuré l'hôte SMTP à ce stade.
  4. Dans la zone URL de réponse d'échange de type Reliable, entrez l'URL que ce groupe de serveurs utilise pour recevoir les accusés de réception d'échanges au format Reliable via l'un des protocoles pris en charge ci-après : File, Message Queuing, HTTP, HTTPS ou SMTP.
    Transport | Préfixe
    File | file://
    Message Queuing | queue://Direct=OS:<nom_serveur>\<nom_file_d'attente>
    Protocole HTTP (Hypertext Transfer Protocol) | http://
    Protocole HTTPS (Secure Hypertext Transfer Protocol) | https://
    Protocole SMTP (Simple Mail Transfer Protocol) | mailto:

    Si vous spécifiez Message Queuing, vous devez utiliser un nom de format. En outre, queue:// doit précéder le nom de format. Pour plus d'informations sur les noms de format, voir Fonctions de réception disponibles.

  5. Dans la liste Intervalle d'actualisation de cache d'objet de gestion d'échanges (en secondes), cliquez sur le nombre de secondes écoulées entre les mises à jour de cache pour le groupe de serveurs.

    La plage de valeurs autorisées est comprise entre 1 et 300 secondes. Par défaut, le serveur met à jour ce cache toutes les 50 secondes.

  6. Dans la zone Serveur proxy, activez la case à cocher Utiliser un serveur proxy si vous voulez configurer la connexion Internet de BizTalk Server via un serveur proxy.

    Entrez l'adresse, le port, le nom d'utilisateur et le mot de passe du serveur proxy que vous voulez utiliser.

  7. Cliquez sur OK.

  8. Effectuez la procédure suivante uniquement si vous avez apporté des modifications dans la zone Serveur proxy.
    • Arrêtez chaque serveur du groupe de serveurs pour lequel vous avez configuré les propriétés générales. Pour plus d'informations sur l'arrêt d'un serveur, voir Arrêt d'un serveur dans un groupe.

    • Démarrez chaque serveur du groupe de serveurs pour lequel vous avez configuré les propriétés générales. Pour plus d'informations sur le démarrage d'un serveur, voir Démarrage d'un serveur dans un groupe.

Remarques

  • L'échange au format Reliable dans BizTalk Server est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk Server (www.microsoft.com/france/biztalk/) et recherchez BizTalk Framework 2.0.

  • Lorsque vous configurez l'URL de réponse d'échange de type Reliable, utilisez une page ASP (Active Server Page) ou une file d'attente de messages dotée d'une fonction de réception pour la surveillance. Si vous ne voulez pas configurer votre propre page ASP dès le départ, utilisez le fichier ReceiveStandard.asp inclus dans BizTalk Server. Cet exemple de page ASP se trouve dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts. Cette page est conçue pour enregistrer des envois et les transmettre à BizTalk Server. Pour plus d'informations sur l'implémentation d'un site sécurisé, accédez au site Web MSDN Online Library (en anglais) (msdn.microsoft.com/library/), puis recherchez l'article « Implementing a Secure Site with ASP ».

  • Si vous spécifiez que l'URL doit inclure localhost dans la zone URL de réponse d'échange de type Reliable, la fonction de réception ne fonctionnera pas correctement. Par conséquent, ne spécifiez pas localhost dans ce champ.

  • La réponse à un envoi HTTP doit être constituée de texte. Si la réponse nécessite des données binaires, codez ces données binaires au format MIME ou UUEncode.

  • L'accusé de réception d'un échange Reliable doit être codé au format Unicode.

Voir aussi

Cache d'administration

Fonctions de réception disponibles

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Configuration des propriétés de connexion d'un groupe de serveurs

Cette procédure vous permet de modifier les bases de données de suivi et de files d'attente partagées utilisées par le groupe de serveurs BizTalk. Généralement, ces bases de données doivent être modifiées lorsqu'il est nécessaire d'utiliser une autre base de données ou un autre serveur, notamment dans le cadre d'une récupération d'urgence ou de la sauvegarde d'un moteur.

  1. Arrêtez tous les serveurs du groupe de serveurs BizTalk Server que vous voulez configurer.

    Pour plus d'informations, voir Arrêt d'un serveur dans un groupe.

  2. Fermez l'application Échange BizTalk Server.

    Pour plus d'informations, voir Arrêt de l'application Échange BizTalk Server.

  3. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis cliquez sur le groupe de serveurs que vous voulez configurer.

  4. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  5. Cliquez sur l'onglet Connexion.

  6. Dans la zone Base de données de suivi :
    • Dans la zone Nom de la base de données de suivi, entrez le nom de la base de données de suivi que ce groupe de serveurs utilise.

    • Dans la zone Nom du serveur SQL de suivi, entrez le nom du serveur Microsoft SQL qui stocke la base de données de suivi que ce groupe de serveurs utilise.
  7. Dans la zone Base de données de files d'attente partagées :
    • Dans la zone Nom de la base de données de files d'attente partagées, entrez le nom de la base de données de files d'attente partagées que ce groupe de serveurs utilise.

    • Dans la zone Nom du serveur SQL de files d'attente partagées, entrez le nom du serveur Microsoft SQL qui stocke la base de données de files d'attente partagées que ce groupe de serveurs utilise.
  8. Cliquez sur OK.

  9. Redémarrez tous les serveurs du groupe de serveurs BizTalk que vous venez de configurer.

    Pour plus d'informations, voir Démarrage d'un serveur dans un groupe.

Remarques

  • Dans Microsoft BizTalk Server 2002, l'accès au serveur SQL dépend de la fonction d'authentification intégrée de Microsoft Windows. Par conséquent, les services BizTalk doivent fonctionner sous un domaine ou un compte local qui dispose des droits d'accès au serveur SQL. Si le mot de passe du compte de service d'échanges utilisé par BizTalk Server change, vous devez utiliser, pour le modifier, l'utilitaire de ligne de commande fourni. Pour plus d'informations sur la modification du mot de passe d'un compte de services, voir Modification du mot de passe du compte de service.

  • Si vous modifiez des valeurs dans la zone Base de données de suivi, vous devez mettre à jour la chaîne de connexion dans le fichier Connection.vb et la remplacer par les nouvelles informations de la base de données de suivi. Le fichier Connection.vb se trouve dans le dossier \Program Files\Microsoft BizTalk Server\BizTalkTracking\VBScripts. La propriété Catalogue initiale, dans la chaîne de connexion, contient le nom de la base de données de suivi. Mettez à jour cette propriété afin de mettre à jour le nom de la base de données de suivi. La chaîne de connexion dans le fichier Connection.vb est :
    Const g_ConnectionString = "Provider=SQLOLEDB.1;
Persist Security Info=False;Integrated Security=SSPI;
Initial Catalog=<databasename>;
Data Source=<servername>;Connect Timeout=15"

    La propriété Source de données, dans la chaîne de connexion, contient le nom du serveur SQL qui héberge la base de données de suivi. Cette propriété doit être mise à jour pour faire apparaître le nom du serveur SLQ approprié à la base de donnée de suivi.

Voir aussi

Fonctions de réception disponibles

Groupes et serveurs

Arrêt de l'application Échange BizTalk Server

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Configuration des propriétés de suivi d'un groupe de serveurs

Les paramètres de suivi d'un groupe de serveurs déterminent si le suivi des échanges est activé ou désactivé. Lorsque vous installez Microsoft BizTalk Server 2002, le suivi de documents est automatiquement activé, les options Consigner l'échange entrant dans un journal et Consigner l'échange sortant dans un journal sont activées, et les métadonnées pour les échanges sont suivies. La procédure suivante permet de personnaliser les propriétés de suivi.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis cliquez sur le groupe de serveurs que vous voulez configurer.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  3. Cliquez sur l'onglet Suivi.

  4. Activez la case à cocher Activer le Suivi de documents, puis sélectionnez, parmi les options suivantes, celles que vous voulez utiliser :
    • Activez la case à cocher Consigner l'échange entrant dans un journal pour consigner les échanges entrants.

    • Activez la case à cocher Consigner l'échange sortant dans un journal pour consigner les échanges sortants.

    • Activez la case à cocher Consigner le message MIME d'origine dans un journal pour consigner les messages MIME.
  5. Cliquez sur OK.

Attention

  • Vous pouvez désactiver le suivi de documents en désactivant la case à cocher Activer le Suivi de documents. Mais, dans ce cas, vous ne serez plus en mesure d'utiliser certaines fonctionnalités importantes de BizTalk Server 2002. Pour plus d'informations sur le suivi, voir Description des paramètres de suivi d'un groupe de serveurs.

Remarque

  • Si vous n'activez pas la case à cocher Activer le Suivi de documents, les cases à cocher Consigner l'échange entrant dans un journal, Consigner l'échange sortant dans un journal et Consigner le message MIME d'origine dans un journal ne sont pas disponibles.

Voir aussi

Groupes et serveurs

Description des paramètres de suivi d'un groupe de serveurs


Configuration de l'ordre des parseurs d'un groupe de serveurs

Lorsque BizTalk Server reçoit un document, il essaie de l'analyser dans l'ordre dans laquelle il figure dans la liste des parseurs. Pour optimiser la vitesse de traitement, vous pouvez modifier l'ordre de la liste des parseurs en plaçant le parseur le plus utilisé au début de la liste.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis cliquez sur le groupe de serveurs pour lequel vous voulez configurer l'ordre des parseurs.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  3. Cliquez sur l'onglet Parseurs.

    Les parseurs figurent dans la zone de liste Organiser la séquence d'appels du serveur, et ils apparaissent dans l'ordre suivant :

    • BizTalk.ParserXML.1

    • BizTalk.ParserEdifact.1

    • BizTalk.ParserX12.1

    • BizTalk.ParserFFile.1
  4. Dans la zone Organiser la séquence d'appels du serveur, cliquez sur le parseur que vous voulez déplacer, puis cliquez sur les flèches HAUT ou BAS pour que le parseur sélectionné apparaisse plus haut ou plus bas dans la séquence d'appels du serveur.

  5. Lorsque les parseurs sont organisés dans l'ordre de votre choix, cliquez sur OK.

Remarques

  • Le bouton Actualiser enregistre les nouveaux parseurs stockés dans le registre local. Si vous voulez qu'un nouveau parseur apparaisse dans la zone Organiser la séquence d'appels du serveur, vous devez cliquer sur le bouton Actualiser correspondant au serveur sur lequel le parseur est enregistré.

  • Vous ne pouvez pas actualiser la liste des parseurs à partir d'un serveur distant. Lorsque vous enregistrez un parseur personnalisé, vous pouvez actualiser la liste des parseurs uniquement à partir du serveur sur lequel il est enregistré.

  • L'onglet Parseur n'est pas disponible dans une installation d'outils de BizTalk Server.

Voir aussi

Parsers


Suppression d'un groupe de serveurs

Au fur et à mesure que les besoins de votre entreprise évoluent, vous pouvez restructurer les groupes de serveurs BizTalk Server afin d'optimiser les performances qui permettront de répondre à ces nouveaux besoins. Au cours de cette restructuration, il peut s'avérer nécessaire de supprimer des groupes de serveurs afin de replacer les serveurs de ce groupe dans des zones de votre système de production qui requièrent davantage de ressources.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis développez le groupe de serveurs que vous voulez supprimer.

  2. Cliquez sur un serveur dans le groupe de serveurs que vous voulez supprimer.

  3. Dans le menu Action, cliquez sur Arrêter.

    Répétez les étapes 2 et 3 pour chaque serveur du groupe, jusqu'à l'arrêt de tous les serveurs.

  4. Cliquez sur le groupe de serveurs.

  5. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  6. Cliquez sur Oui.

Remarques

  • Vous ne pouvez pas supprimer un groupe de serveurs qui contient un ou plusieurs serveurs en cours d'exécution. Pour arrêter les serveurs et supprimer le groupe de serveurs, vous devez disposer de droits d'administrateur dans Windows 2000 pour tous les serveurs du groupe.

  • Les bases de données de suivi et de files d'attente partagées qui sont associées au groupe de serveurs sont maintenues dans Microsoft SQL Server, même si vous supprimez le groupe. Pour supprimer les bases de données de files d'attente partagées et de suivi, vous devez effectuer une suppression manuelle. Pour plus d'informations sur la suppression de ces bases de données, voir Suppression des bases de données de suivi et de files d'attente partagées.

Voir aussi

Groupes et serveurs

Suppression des bases de données de suivi et de files d'attente partagées

Arrêt d'un serveur dans un groupe


Ajout, suppression et configuration de serveurs dans un groupe

Les serveurs d'un groupe de serveurs sont configurés pour équilibrer les performances et la vitesse de traitement entre eux. Au fur et à mesure que les besoins de votre entreprise évoluent, vous pouvez restructurer les groupes de serveurs BizTalk Server afin d'optimiser les performances qui permettront de répondre à ces nouveaux besoins. Au cours de cette restructuration, il peut s'avérer nécessaire d'ajouter des serveurs à un groupe, de déplacer des serveurs d'un groupe vers un autre ou de modifier les paramètres de serveur configurés lors de l'installation de BizTalk Server. Par exemple, vous pouvez avoir besoin de traiter davantage de documents, plus rapidement. Vous pouvez aussi être amené à configurer un serveur dans un groupe afin qu'il reçoive uniquement des échanges et des documents.

Nous vous recommandons vivement de consulter la section Serveurs BizTalk dans la rubrique À propos de Administration de BizTalk Server pour comprendre pleinement le fonctionnement des serveurs BizTalk Server.

Cette section traite des procédures suivantes :

  • Ajout d'un serveur à un groupe

  • Suppression d'un serveur d'un groupe

  • Configuration d'un serveur dans un groupe

  • Modification de la base de données Gestion d'échanges BizTalk d'un serveur

Remarque

  • Lors de la définition des propriétés des serveurs, essayez différentes combinaisons dans un environnement de test avant de les appliquer à votre environnement de production.


Ajout d'un serveur à un groupe

Cette opération vous permet d'ajouter un serveur BizTalk Server à un groupe de serveurs déjà configuré. Vous pouvez associer à chaque groupe un nombre de serveurs différent. Vous avez ainsi la possibilité d'améliorer la vitesse de traitement en optimisant le nombre de serveurs dans un groupe en fonction de la puissance de traitement des serveurs qui contiennent les bases de données.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis cliquez sur le groupe de serveurs auquel vous voulez ajouter un serveur.

  2. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Serveur.

    La boîte de dialogue Ajouter un serveur BizTalk s'affiche.

  3. Dans la zone Nom du serveur BizTalk Server, entrez le nom d'un serveur sur lequel vous avez effectué une installation complète de BizTalk Server 2002.

  4. Cliquez sur OK.

Important

  • Tous les serveurs d'un groupe doivent disposer de la même version de BizTalk Server dans la même langue. Les bases de données ne fonctionneront pas correctement si des versions différentes de BizTalk Server (BizTalk Server 2000, BizTalk Server 2000 Service Pack 1, BizTalk Server 2002 Édition Entreprise ou une version de BizTalk Server dans une autre langue) sont installées sur les serveurs d'un même groupe.

Remarques

  • Pour visualiser les propriétés globales du groupe de serveurs auquel vous avez ajouté le serveur, cliquez avec le bouton droit sur le groupe, puis cliquez sur Propriétés.

  • La version de BizTalk Server installée sur le serveur à ajouter doit être identique à celle du groupe de serveurs.

Voir aussi

Groupes et serveurs

Gestion de serveurs dans un groupe

Description des propriétés d'un serveur


Suppression d'un serveur d'un groupe

Au fur et à mesure que les besoins de votre entreprise évoluent, vous pouvez restructurer les groupes de serveurs BizTalk Server afin d'optimiser les performances qui permettront de répondre à ces nouveaux besoins. Au cours de cette restructuration, il peut s'avérer nécessaire de supprimer des serveurs d'un groupe de serveurs afin de les replacer dans des zones de votre système de production qui requièrent davantage de ressources.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002 et le groupe de serveurs contenant le serveur que vous voulez supprimer, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

    Le serveur termine le traitement de tous les échanges et documents en cours.

  3. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  4. Cliquez sur Oui.

Remarque

  • Vous ne pouvez pas supprimer un serveur d'un groupe de serveurs si une ou plusieurs fonctions de réception pointe sur ce serveur pour le traitement de documents. Vous pouvez modifier les fonctions de réception pour faire en sorte qu'elles pointent sur d'autres serveurs. Vous pouvez également supprimer les fonctions de réception si elles ne peuvent plus être utilisées.

Voir aussi

Échanges libres à partir d'un serveur

Groupes et serveurs

Gestion des fonctions de réception d'un groupe de serveurs

Gestion de serveurs dans un groupe


Configuration d'un serveur dans un groupe

Cette procédure vous permet de configurer les propriétés générales d'un serveur spécifique. La création de fonctions de réception sur des serveurs qui ne participent pas au traitement des éléments de travail améliore la vitesse de traitement de BizTalk Server.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002 et le groupe de serveurs contenant le serveur que vous voulez configurer, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

    Vous ne pouvez pas modifier les paramètres de configuration du serveur lorsque le serveur est en cours d'exécution.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés <nom d'ordinateur> s'affiche.

  4. Dans la zone Nombre maximal de threads de fonction de réception autorisé, entrez un nombre compris entre 1 et 128.

    La valeur par défaut est 4. Pour plus d'informations sur la configuration de cette option, voir Description des propriétés d'un serveur.

  5. Si vous voulez que le serveur traite les éléments dans la file d'attente de travail, activez la case à cocher Participer au traitement de l'élément de travail.

    Lorsque cette case à cocher est activée, le serveur traite les documents dans la file d'attente de travail. Désactivez cette case à cocher si vous ne voulez pas que le serveur traite les documents dans la file d'attente de travail. Pour plus d'informations sur la configuration de cette option, voir Description des propriétés d'un serveur.

  6. Dans la zone Nombre maximal de threads de fonction de réception autorisé, entrez un nombre compris entre 1 et 128.

    La valeur par défaut est 4. Pour plus d'informations sur la configuration de cette option, voir Description des propriétés d'un serveur.

  7. Dans la zone Intervalle entre appels de BizTalk Server Scheduler (en millisecondes), entrez un nombre compris entre 1 et 4294967295.

    La valeur par défaut est 2000. Pour plus d'informations sur la configuration de cette option, voir Description des propriétés d'un serveur.

  8. Cliquez sur OK.

  9. Cliquez avec le bouton droit sur le serveur que vous avez configuré, puis cliquez sur Démarrer.

Remarque

  • Si la case à cocher Participer au traitement de l'élément de travail est désactivée, les cases à cocher Nombre maximal de threads de travail autorisé par processeur et Intervalle entre appels de BizTalk Server Scheduler (en millisecondes) ne sont pas disponibles.

Voir aussi

Groupes et serveurs

Gestion de serveurs dans un groupe

Description des propriétés d'un serveur


Modification de la base de données Gestion d'échanges BizTalk d'un serveur

La modification de la base de données Gestion d'échanges BizTalk pour un serveur n'est généralement nécessaire que suite au passage définitif à une autre base de données en raison d'une récupération d'urgence ou d'une modification du serveur qui héberge la base de données.

Important

  • Utilisez cette procédure pour associer un serveur à une autre base de données Gestion d'échanges BizTalk. Pour plus d'informations sur le déplacement de serveurs entre les bases de données Gestion d'échanges BizTalk, voir Déplacement de serveurs entre les bases de données Gestion d'échanges BizTalk. Pour plus d'informations sur la modification de la base de données Gestion d'échanges BizTalk des groupes de serveurs, voir Modification de la base de données Gestion d'échanges BizTalk d'un serveur.
  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002 et le groupe de serveurs contenant le serveur dont vous voulez modifier la base de données Gestion d'échanges BizTalk, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

  3. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  4. Cliquez sur Oui.

  5. Fermez Administration de BizTalk Server.

  6. Dans le menu Démarrer, pointez sur Programmes et sur Accessoires, puis cliquez sur Synchroniser.

  7. Accédez à \Program Files\Microsoft BizTalk Server\Setup.

  8. Cliquez sur le fichier BTSsetupDB.exe.

  9. Dans le menu Fichier, cliquez sur Ouvrir.

    L'Assistant Configuration des bases de données d'échanges Microsoft BizTalk Server 2002 s'ouvre.

  10. Sur la page Assistant Installation des bases de données d'échanges Microsoft BizTalk Server 2002, cliquez sur Suivant.

  11. Sur la page Configurer une base de données Gestion d'échanges BizTalk, cliquez sur Créer une nouvelle base de données Gestion d'échanges BizTalk.

    — ou —

    Cliquez sur Sélectionner une base de données existante.

  12. Dans la zone Nom du serveur, cliquez sur le nom du serveur sur lequel se trouve la nouvelle base de données Gestion d'échanges BizTalk ou la base de données existante Gestion d'échanges BizTalk.

  13. Dans la zone Base de données, entrez le nom de la nouvelle base de données Gestion d'échanges BizTalk ou de la base de données Gestion d'échanges BizTalk existante.

  14. Cliquez sur Suivant.

  15. Sur la page Configurer un groupe de serveurs BizTalk, cliquez sur Nouveau groupe BizTalk Server.

    Dans la zone Nom du groupe, entrez le nom du nouveau groupe, puis cliquez sur Suivant.

    — ou —

    Cliquez sur Sélectionnez un groupe BizTalk Server existant. Dans la liste Nom du groupe, cliquez sur le nom du groupe existant, puis cliquez sur Suivant.

    Vous pouvez uniquement sélectionner un groupe BizTalk Server existant si vous avez sélectionné une base de données existante à l'étape 11.

  16. Si nécessaire, cliquez sur Créer une nouvelle base de données de suivi, puis sur Suivant.

    — ou —

    Cliquez sur Sélectionner une base de données existante. Dans la liste Nom du serveur, sélectionnez un serveur et cliquez sur Suivant.

  17. Si nécessaire, cliquez sur Créer une nouvelle base de données de files d'attente partagées, puis cliquez sur Suivant.

    — ou —

    Cliquez sur Sélectionner une base de données existante. Dans la liste Nom du serveur, sélectionnez un serveur et cliquez sur Suivant.

  18. Sur la page Vérifiez le groupe BizTalk Server, vérifiez les informations que vous avez entrées, puis cliquez sur Suivant.

  19. Sur la page Fin de l'Assistant Installation des bases de données d'échanges Microsoft BizTalk Server 2002, cliquez sur Terminer.

  20. Ouvrez Administration de BizTalk Server.

  21. Développez Microsoft BizTalk Server 2002 et le groupe de serveurs contenant le serveur pour lequel vous venez de modifier la base de données Gestion d'échanges BizTalk, puis cliquez sur le serveur.

  22. Dans le menu Action, cliquez sur Démarrer.

    Voir aussi

    Modification de la base de données Gestion d'échanges BizTalk

    Gestion des bases de données BizTalk Server

    Déplacement des serveurs entre les bases de données Gestion d'échanges BizTalk


Gestion de serveurs dans un groupe

Cette section fournit des informations spécifiques aux tâches concernant la gestion des serveurs dans un groupe de serveurs BizTalk. Nous vous recommandons vivement de consulter la section Serveurs BizTalk dans la rubrique À propos de Administration de BizTalk Server pour comprendre pleinement le fonctionnement des serveurs BizTalk Server.

Cette section traite des procédures suivantes :

  • Démarrage d'un serveur dans un groupe

  • Arrêt d'un serveur dans un groupe

  • Échanges libres à partir d'un serveur

  • Configuration du cache disque


Démarrage d'un serveur dans un groupe

Utilisez cette procédure pour démarrer les services d'exécution de BizTalk Server sur le serveur associé de sorte qu'il puisse participer à la réception et/ou au traitement des échanges.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002 et le groupe contenant le serveur que vous voulez démarrer, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Démarrer.

Remarques

  • Lorsque vous démarrez un serveur dans un groupe de serveurs, le service d'Échanges BizTalk démarre sur le serveur. Une fois que le service d'Échanges BizTalk est en cours d'exécution, le serveur peut recevoir, transmettre, traiter et effectuer un suivi des documents mis en file d'attente sur les bases de données Microsoft SQL Server.

  • L'option Démarrer est disponible uniquement si le serveur est arrêté. S'il est en cours d'exécution, la commande n'est pas disponible.

Voir aussi

Ajout, suppression et configuration de serveurs dans un groupe

Cache d'administration

Groupes et serveurs

Arrêt d'un serveur dans un groupe


Arrêt d'un serveur dans un groupe

Cette procédure permet d'arrêter les services d'exécution de BizTalk Server sur le serveur associé de sorte qu'il cesse de participer à la réception et/ou au traitement des échanges.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002 et le groupe de serveurs contenant le serveur que vous voulez arrêter, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

Remarques

  • L'arrêt d'un serveur dans un groupe de serveurs implique l'arrêt du service d'Échanges BizTalk sur le serveur. Une fois que le service d'Échanges BizTalk est arrêté, le serveur ne peut recevoir, transmettre, traiter ni effectuer un suivi des documents qui sont mis en file d'attente sur les bases de données Microsoft SQL Server.

  • Si vous voulez redistribuer les échanges associés à un serveur que vous avez arrêté, voir Échanges libres à partir d'un serveur.

Voir aussi

Ajout, suppression et configuration de serveurs dans un groupe

Cache d'administration

Échanges libres à partir d'un serveur

Groupes et serveurs


Échanges libres à partir d'un serveur

Cette procédure est utilisée pour libérer des échanges d'un serveur afin qu'ils puissent être redistribués vers d'autres serveurs du groupe si le serveur initial est arrêté ou mis hors connexion.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002 et le groupe contenant le serveur sur lequel vous voulez libérer des échanges, puis cliquez sur le serveur.

  2. Dans le menu Action, cliquez sur Arrêter.

  3. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Échanges libres.

  4. Dans le menu Action, cliquez sur Démarrer.

Remarque

  • Vous ne pouvez pas effectuer cette tâche lorsque l'état du serveur est En cours d'exécution ou Accès refusé.

Voir aussi

Ajout, suppression et configuration de serveurs dans un groupe

Groupes et serveurs

Arrêt d'un serveur dans un groupe


Configuration du cache disque

Utilisez cette procédure pour activer ou désactiver la mise en cache du disque. Lorsque la mise en cache du disque est désactivée, ceci permet d'éviter la perte des données en cas d'interruption du service en raison, par exemple, d'une panne de courant. En revanche, cette opération entraîne une dégradation des performances de BizTalk Server.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Gestion de l'ordinateur.

  2. Dans l'arborescence de la console Gestion de l'ordinateur, développez Gestionnaire de périphériques.

  3. Sur la droite, double-cliquez sur Lecteurs de disque.

  4. Cliquez avec le bouton droit sur le lecteur sur lequel vous voulez configurer la mise en cache du disque, puis cliquez sur Propriétés.

    La fenêtre Propriétés de <nom_périphérique> s'affiche.

  5. Cliquez sur l'onglet Propriétés du disque.

  6. Activez ou désactivez la case à cocher Cache en écriture activée.

Remarque

  • Cette procédure entraîne une modification des propriétés du cache du disque au niveau de l'ordinateur.

Voir aussi

Ajout, suppression et configuration de serveurs dans un groupe

Groupes et serveurs

Arrêt d'un serveur dans un groupe


Gestion des files d'attente

Cette section fournit des informations spécifiques aux tâches relatives à la gestion des files d'attente dans BizTalk Server. Il est vivement recommandé de consulter les informations de la rubrique Utilisation des files d'attente pour bien comprendre l'utilisation des files d'attente de BizTalk Server.

Cette section traite des procédures suivantes :

  • Déplacement de documents vers la file d'attente interrompue

  • Affichage des descriptions d'erreur

  • Affichage des échanges

  • Affichage des documents

  • Renvoi de documents

  • Suppression de documents


Déplacement de documents vers la file d'attente interrompue

Tout élément des files d'attente de travail, de nouvel essai ou planifiées peut être déplacé vers la file d'attente interrompue. En revanche, vous ne devez déplacer les échanges et les documents vers la file d'attente interrompue que si vous voulez empêcher leur traitement. Dès lors qu'un échange ou un document est déplacé vers la file d'attente interrompue, vous pouvez le supprimer, le renvoyer ou le retransmettre à la file d'attente de travail en vue de son traitement.

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe contenant le document à déplacer et les Files d'attente.

  2. Développez la file d'attente contenant le document que vous voulez déplacer, puis cliquez sur le document.

  3. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Déplacer vers la file interrompue.

Voir aussi

File d'attente interrompue

Utilisation des files d'attente


Affichage des descriptions d'erreur

Cette procédure permet de déterminer l'erreur qui a généré le placement d'un document dans la file d'attente interrompue.

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe contenant le document à afficher et Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet de détails, cliquez sur le document que vous voulez afficher.

  3. Dans le menu Action, cliquez sur Afficher la description de l'erreur.

Voir aussi

File d'attente interrompue

Utilisation des files d'attente

Affichage des documents

Affichage des échanges


Affichage des échanges

Cette tâche vous permet, en ouvrant une fenêtre d'affichage séparée, d'afficher le contenu d'un échange qui a été placé dans la file d'attente interrompue, suite à un problème d'analyse ou de transmission. Cette tâche ne concerne pas les échanges qui n'ont pas reçu l'accord de transmission.

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe contenant l'échange à afficher et les Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet des détails, cliquez sur l'échange que vous voulez afficher.

  3. Dans le menu Action, cliquez sur Afficher l'échange.

    La boîte de dialogue Contenu de document s'affiche.

Remarques

  • Si vous affichez un échange important, les données peuvent être tronquées. Vous pouvez afficher jusqu'à 4 Mo de données dans la boîte de dialogue Contenu de document.

  • Si BizTalk Server n'est pas en mesure d'analyser l'échange, des données binaires peuvent apparaître dans la boîte de dialogue Contenu de document. Pour plus d'informations sur les erreurs d'analyse, voir Erreurs d'analyse.

  • L'option de menu Afficher l'échange est disponible pour les états suivants de file d'attente interrompue :
    • Composant personnalisé

    • Analyse

    • Cryptage

    • Signature

    • Cryptage

    • Transmission en cours
  • Les options Afficher l'échange et Afficher le document n'apparaissent jamais simultanément dans le menu Action.

  • L'option Afficher l'échange n'est pas disponible dans une installation d'outils de BizTalk Server.

Voir aussi

Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue

File d'attente interrompue

Utilisation des files d'attente

Affichage des documents

Affichage des descriptions d'erreur


Affichage des documents

Cette tâche vous permet, en ouvrant une fenêtre d'affichage séparée, d'afficher le contenu d'un document qui a été placé dans la file d'attente interrompue en raison d'un problème d'accord du partenaire commercial. Cette tâche ne concerne pas les documents qui ont échoué en raison d'un problème d'analyse ou de transmission.

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe contenant le document à afficher et Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet de détails, cliquez sur le document que vous voulez afficher.

  3. Dans le menu Action, cliquez sur Afficher le document.

    La boîte de dialogue Contenu de document s'affiche.

Remarques

  • Si vous essayez d'afficher un document volumineux, les données risquent d'être tronquées. Vous pouvez afficher jusqu'à 4 Mo de données dans la boîte de dialogue Contenu de document.

  • L'option de menu Afficher le document est disponible pour les états suivants de file d'attente interrompue :
    • Validation du document

    • Sélection du canal

    • Mappage

    • Corrélation

    • Sérialisation
  • Les options Afficher l'échange et Afficher le document n'apparaissent jamais simultanément dans le menu Action.

  • L'option Afficher le document n'est pas disponible dans une installation d'outils de BizTalk Server.

Voir aussi

Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue

File d'attente interrompue

Utilisation des files d'attente

Affichage des descriptions d'erreur

Affichage des échanges


Renvoi de documents

Cette procédure vous permet de soumettre à nouveau dans la file d'attente de travail un document placé dans la file d'attente interrompue. Cette opération s'effectue généralement une fois que la cause du problème de transmission a été résolue.

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe contenant le document à renvoyer et les Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet de détails, cliquez sur le document que vous voulez renvoyer.

  3. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Soumettre à nouveau.

Remarques

  • Cette procédure permet également de retransmettre des documents.

  • Il n'est pas possible de renvoyer tous les documents de la file d'attente interrompue. Dans certains cas, il est nécessaire de supprimer le document, puis de le soumettre à nouveau à partir de l'application ou de l'organisation d'origine. Pour plus d'informations sur les documents de la file d'attente interrompue, voir File d'attente interrompue.

Voir aussi

File d'attente interrompue

Utilisation des files d'attente


Suppression de documents

Cette procédure vous permet de supprimer un document de la file d'attente interrompue. Cette opération s'effectue généralement lorsque le message n'est plus nécessaire ou si vous l'avez déjà enregistré.

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe contenant le document à supprimer et les Files d'attente, puis cliquez sur File d'attente interrompue.

  2. Dans le volet de détails, cliquez sur le document que vous voulez supprimer.

  3. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  4. Cliquez sur Oui.

Voir aussi

File d'attente interrompue

Utilisation des files d'attente


Gestion des bases de données d'un groupe de serveurs

Cette section fournit des informations spécifiques aux tâches sur la gestion des bases de données d'un groupe de serveurs BizTalk Server. Nous vous recommandons vivement de consulter la rubrique Gestion des bases de données de groupe de serveurs BizTalk pour bien comprendre le fonctionnement des bases de données BizTalk Server.

Cette section traite des procédures suivantes :

  • Arrêt de l'application Échange BizTalk Server

  • Suppression des bases de données de suivi et de files d'attente partagées

  • Restauration manuelle de la base de données de suivi

  • Restauration manuelle de la base de données de files d'attente partagée


Arrêt de l'application Échange BizTalk Server

L'application Échange BizTalk Server héberge les rôles qui limitent les autorisations d'envoi des échanges et des documents à BizTalk Server. Cette application doit être arrêtée chaque fois qu'une modification est apportée à la connexion vers les bases de données Gestion d'échanges BizTalk, de suivi ou de files d'attente partagées.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composants.

  2. Développez successivement Services de composants, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur l'application Échange BizTalk Server

  4. Dans le menu Action, cliquez sur Fermer.

Remarque

  • Vous pouvez fermer l'application Échange BizTalk Server à partir d'un serveur distant. Auquel cas, développez <nom de l'ordinateur distant> au lieu de Poste de travail à l'étape 2.

Voir aussi

Cache d'administration

Configuration des propriétés de connexion d'un groupe de serveurs

Configuration des propriétés de suivi d'un groupe de serveurs

Groupes et serveurs

Ouverture des services de composants

Base de données de suivi


Suppression des bases de données de suivi et de files d'attente partagées

Les bases de données de suivi et de files d'attente partagées sont généralement supprimées une fois que les groupes de serveurs BizTalk Server ont été configurés pour utiliser une autre base de données de suivi et/ou de files d'attente partagées. Si la base de données de suivi et/ou de files d'attente partagées est supprimée avant que vous ayez configuré les groupes de serveurs BizTalk pour utiliser une autre base de données, BizTalk Server ne fonctionnera pas correctement.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, ainsi que le serveur contenant les bases de données à supprimer.

  3. Développez le dossier Bases de données, puis cliquez sur la base de données que vous voulez supprimer.

  4. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Supprimer la base de données s'affiche.

  5. Pour enregistrer l'historique de sauvegarde et de restauration de la base de données, désactivez la case à cocher Supprimer la sauvegarde et l'historique de restauration de la base de données.

  6. Cliquez sur Oui.

Remarque

  • Le nom par défaut de la base de données de suivi est « InterchangeDTA ». Le nom par défaut de la base de données de files d'attente partagées est « InterchangeSQ ».

Voir aussi

Groupes et serveurs

Base de données de files d'attente partagées

Arrêt d'un serveur dans un groupe

Base de données de suivi


Restauration manuelle de la base de données de suivi

Utilisez cette procédure si la base de données de suivi est altérée ou endommagée. Cette procédure suppose qu'une sauvegarde a préalablement été créée.

Attention

  • Lorsque vous restaurez manuellement la base de données de suivi, vous perdez toutes les données. Si vous devez conserver ces données, faites-en une copie de sauvegarde avant de restaurer la base de données de suivi.
  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, ainsi que le serveur sur lequel vous voulez restaurer la base de données.

  3. Cliquez sur Bases de données.

  4. Dans le menu Action, cliquez sur Nouvelle base de données.

    La boîte de dialogue Propriétés de la base de données s'affiche.

  5. Dans la zone Nom de l'onglet Général, entrez un nom pour la base de données de suivi, puis cliquez sur OK.

  6. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Analyseur de requêtes.

    La boîte de dialogue Connexion à SQL Server s'affiche.

  7. Dans la zone SQL Server, sélectionnez le serveur sur lequel vous souhaitez restaurer la base de données.

  8. Dans la zone Se connecter en utilisant, activez l'option correspondant à la méthode d'authentification à utiliser pour la connexion au serveur SQL.

  9. Cliquez sur OK.

  10. Si vous disposez de Microsoft SQL Server 7.0, sélectionnez la fenêtre Requête, puis dans la liste des bases de données, cliquez sur le nom de la nouvelle base de données de suivi. Passez à l'étape 14.

    — ou —

    Si vous disposez de Microsoft SQL Server 2000, dans la fenêtre de l'Explorateur d'objets, cliquez sur le nom de la nouvelle base de données de suivi.

  11. Dans le menu Requête, choisissez Modifier la base de données.

  12. Dans la fenêtre Sélectionner la base de données de <nom_serveur>, cliquez sur le nom de la nouvelle base de données de suivi.

  13. Cliquez sur OK.

  14. Cliquez sur le bouton Charger le script SQL bouton Charger le script SQL.

  15. Accédez à \Program Files\Microsoft BizTalk Server\Setup.

  16. Cliquez sur BTS_Tracking_Schema.sql, puis cliquez sur Ouvrir.

  17. Cliquez sur le bouton Exécuter la requête.

  18. Cliquez sur le bouton Charger un script SQL.

  19. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  20. Cliquez sur BTS_Reporting.sql, puis sur le bouton Ouvrir.

  21. Cliquez sur le bouton Exécuter la requête.

  22. Cliquez sur le bouton Charger un script SQL.

  23. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  24. Cliquez sur BTS_Tracking_ArchiveDB_Schema.sql, puis sur Ouvrir.

  25. Cliquez sur le bouton Exécuter la requête.

  26. Cliquez sur le bouton Charger un script SQL.

  27. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  28. Cliquez sur BTS_WorkflowEvents_Logic.sql, puis sur le bouton Ouvrir.

  29. Cliquez sur le bouton Exécuter la requête.

  30. Cliquez sur le bouton Charger un script SQL.

  31. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  32. Cliquez sur BTS_WorkflowEvents_Schema.sql, puis sur le bouton Ouvrir.

  33. Cliquez sur le bouton Exécuter la requête.

  34. Fermez l'Analyseur de requêtes SQL ainsi que SQL Server Enterprise Manager.

Voir aussi

Restauration manuelle de la base de données de files d'attente partagée


Restauration manuelle de la base de données de files d'attente partagée

Utilisez cette procédure si la base de données de files d'attente partagée est altérée ou endommagée. Cette procédure suppose qu'une sauvegarde a préalablement été créée.

Attention

  • Lorsque vous restaurez manuellement la base de données de files d'attente partagées, vous perdez toutes les données. Si vous devez conserver ces données, faites-en une copie de sauvegarde avant de restaurer la base de données de files d'attente partagées.
  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL, Groupe SQL Server, ainsi que le serveur sur lequel vous voulez restaurer la base de données.

  3. Cliquez sur Bases de données.

  4. Dans le menu Action, cliquez sur Nouvelle base de données.

    La boîte de dialogue Propriétés de la base de données s'affiche.

  5. Dans la zone Nom de l'onglet Général, entrez un nom pour la base de données de files d'attente partagées, puis cliquez sur OK.

  6. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Analyseur de requêtes.

    La boîte de dialogue Connexion à SQL Server s'affiche.

  7. Dans la zone SQL Server, sélectionnez le serveur sur lequel vous souhaitez restaurer la base de données.

  8. Dans la zone Se connecter en utilisant, activez l'option correspondant à la méthode d'authentification à utiliser pour la connexion au serveur SQL.

  9. Cliquez sur OK.

  10. Si vous disposez de Microsoft SQL Server 7.0, sélectionnez la fenêtre Requête, puis dans la liste des bases de données, cliquez sur le nom de la nouvelle base de données de files d'attente partagées. Passez à l'étape 14.

    — ou —

    Si vous disposez de Microsoft SQL Server 2000, dans la fenêtre de l'Explorateur d'objets, cliquez sur le nom de la nouvelle base de données de files d'attente partagées.

  11. Dans le menu Requête, choisissez Modifier la base de données.

  12. Dans la fenêtre Sélectionner la base de données de <nom_serveur>, cliquez sur le nom de la nouvelle base de données de files d'attente partagées.

  13. Cliquez sur OK.

  14. Cliquez sur le bouton Charger le script SQL bouton Charger le script SQL.

  15. Accédez à \Program Files\Microsoft BizTalk Server\Setup.

  16. Cliquez sur BTS_Core_Schema.sql, puis sur le bouton Ouvrir.

  17. Cliquez sur le bouton Exécuter la requête.

  18. Cliquez sur le bouton Charger un script SQL.

  19. Vérifiez que vous êtes bien dans le dossier \Program Files\Microsoft BizTalk Server\Setup.

  20. Cliquez sur BTS_Core_Logic.sql, puis sur le bouton Ouvrir.

  21. Cliquez sur le bouton Exécuter la requête.

  22. Fermez l'Analyseur de requêtes SQL et SQL Server Enterprise Manager.

Voir aussi

Restauration manuelle de la base de données de suivi


Gestion des fonctions de réception d'un groupe de serveurs

Les fonctions de réception sont des fonctions qui sont configurées dans un groupe serveurs BizTalk pour gérer les échanges entrants avec un protocole spécifique. Ces fonctions servent essentiellement à appeler les méthodes Receive sur l'objet de routeur entrant.

Cette section traite des procédures suivantes :

  • Ajout d'une fonction de réception de fichier

  • Configuration d'une fonction de réception de fichier : onglet Général

  • Configuration d'une fonction de réception de fichier : onglet Services

  • Ajout d'une fonction de réception Message Queuing

  • Configuration d'une fonction de réception Message Queuing : onglet Général

  • Configuration d'une fonction de réception Message Queuing : onglet Services

  • Ajout d'une fonction de réception HTTP

  • Configuration d'une fonction de réception HTTP : onglet Général

  • Configuration d'une fonction de réception HTTP : onglet Services

  • Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP

  • Configuration des privilèges d'accès selon le niveau de protection IIS

  • Suppression d'une fonction de réception

Remarque

  • Si vous répliquez une fonction de réception qui est configurée pour utiliser un nom d'utilisateur et un mot de passe, la fonction de réception répliquée ne sera pas active car le mot de passe ne sera plus valide. Pour résoudre ce problème, vous devez ouvrir la page de propriétés de chaque fonction de réception, entrer de nouveau le mot de passe, puis activer la fonction de réception.


Ajout d'une fonction de réception de fichier

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis cliquez sur le groupe de serveurs auquel vous voulez ajouter la fonction de réception de fichier.

  2. Cliquez sur Fonctions de réception.

  3. Dans le menu Action, pointez sur Nouveau et cliquez sur Fonction de réception de fichier.

    La boîte de dialogue Ajouter une fonction de réception de fichier apparaît.

  4. Dans la zone Nom, entrez le nom de la fonction de réception de fichier.

  5. Dans la zone Commentaire, ajoutez éventuellement une brève description.

  6. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom d'un serveur du groupe.

  7. Dans la zone Types de fichiers à interroger, tapez l'extension des fichiers reçus par BizTalk Server.

    L'extension des types de fichiers doit respecter la syntaxe suivante :

    *.ext

    Exemple : *.xml

  8. Dans la zone Emplacement de l'interrogation, entrez le chemin logique ou le chemin UNC (Universal Naming Convention) vers le répertoire que cette fonction de réception utilise en tant qu'emplacement de la réception de fichier.

  9. Dans la liste Préprocesseur, cliquez sur le nom du préprocesseur personnalisé.

    Ne renseignez pas ce champ si vous n'utilisez pas de préprocesseur personnalisé.

  10. Dans les zones Nom d'utilisateur et Mot de passe, entrez un nom d'utilisateur et un mot de passe valides pour la connexion à l'emplacement de réception de fichier (facultatif).

    Ces informations sont requises uniquement si l'emplacement de réception est protégé et si la connexion au serveur requiert un nom d'utilisateur et un mot de passe valides.

  11. Pour personnaliser la fonction de réception de documents sans auto-routage ou pour spécifier des options openness ou directes, cliquez sur Avancé.

    Pour plus d'informations sur les options avancées, voir Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP.

Remarques

  • Cette procédure crée une fonction de réception de fichier avec les paramètres par défaut. Pour utiliser des paramètres supplémentaires pour la configuration de la fonction de réception, voir Configuration d'une fonction de réception de fichier : onglet Général.

  • Si vous voulez interroger plusieurs types de fichiers, utilisez n'importe quel format générique standard.

    Exemple : *.* ou *.x?l

  • Si vous configurez une ou plusieurs fonctions de réception de fichier pour surveiller le même répertoire, utilisez des extensions de fichier à trois lettres. Si vous utilisez des extensions de fichier de plus de trois lettres, vérifiez que les trois premières lettres sont uniques.

    Exemple : *.xml, *.1xml, *.12xml

  • Les fonctions de réception de fichier ne traitent pas les fichiers en lecture seule.

  • Vérifiez que le nom de chaque fonction de réception créée est unique. Vous ne pouvez pas attribuer le même nom à plusieurs fonctions de réception.

  • Si vous répliquez une fonction de réception qui est configurée pour utiliser un nom d'utilisateur et un mot de passe, la fonction de réception répliquée ne sera pas active car le mot de passe ne sera plus valide. Pour résoudre ce problème, vous devez ouvrir la page de propriétés de chaque fonction de réception, entrer de nouveau le mot de passe, puis activer la fonction de réception.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP

Configuration d'une fonction de réception de fichier : onglet Général

Configuration d'une fonction de réception de fichier : onglet Services

Préprocesseurs personnalisés

Fonctions de réception


Configuration d'une fonction de réception de fichier : onglet Général

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception de fichier et Fonctions de réception.

  2. Cliquez sur la fonction de réception de fichier que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Dans la zone Commentaire, ajoutez éventuellement une brève description.

  5. Dans les champs Nom d'utilisateur et Mot de passe de la zone Sécurité, entrez un nom d'utilisateur et un mot de passe valides pour vous connecter à cette fonction de réception.

    Ces informations sont requises uniquement si l'emplacement de réception est protégé et si la connexion au serveur requiert un nom d'utilisateur et un mot de passe valides.

  6. Si vous ne voulez pas arrêter la fonctionnalité de cette fonction de réception, désactivez la case à cocherDésactiver la fonction de réception, puis cliquez sur Oui pour confirmer votre choix.

Remarques

  • Les fonctions de réception de fichier ne traitent pas les fichiers en lecture seule.

  • Si vous répliquez une fonction de réception qui est configurée pour utiliser un nom d'utilisateur et un mot de passe, la fonction de réception répliquée ne sera pas active car le mot de passe ne sera plus valide. Pour résoudre ce problème, vous devez ouvrir la page de propriétés de chaque fonction de réception, entrer de nouveau le mot de passe, puis activer la fonction de réception.

Voir aussi

Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP

Configuration d'une fonction de réception de fichier : onglet Services


Configuration d'une fonction de réception de fichier : onglet Services

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception de fichier et Fonctions de réception.

  2. Cliquez sur la fonction de réception de fichier que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Cliquez sur l'onglet Services.

  5. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom du serveur.

  6. Dans la zone Emplacement de l'interrogation, entrez le chemin logique ou le chemin UNC (Universal Naming Convention) vers le répertoire que cette fonction de réception utilise en tant qu'emplacement de la réception de fichier.

  7. Dans la zone Types de fichiers à interroger, tapez l'extension des fichiers reçus par BizTalk Server.

    L'extension des types de fichiers doit respecter la syntaxe suivante :

    *.ext

    Exemple : *.doc

  8. Dans la liste Préprocesseur, cliquez sur le nom du préprocesseur personnalisé.

    Ne renseignez pas ce champ si vous n'utilisez pas de préprocesseur personnalisé.

  9. Cliquez sur OK.

Remarques

  • Si vous voulez recevoir plusieurs types de fichiers, utilisez n'importe quel format avec les caractères génériques standard.

    Exemple : *.*

  • Si vous configurez une ou plusieurs fonctions de réception de fichier pour surveiller le même répertoire, utilisez des extensions de fichier à trois lettres. Si vous utilisez des extensions de fichier de plus de trois lettres, vérifiez que les trois premières lettres sont uniques.

    Exemple : *.xml, *.1xml, *.12xml

  • Les fonctions de réception de fichier ne traitent pas les fichiers en lecture seule.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP

Préprocesseurs personnalisés


Ajout d'une fonction de réception Message Queuing

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe de serveurs auquel vous voulez ajouter une fonction de réception Message Queuing et Fonctions de réception.

  2. Cliquez sur Fonctions de réception.

  3. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Fonction de réception Message Queuing.

    La boîte de dialogue Ajouter une fonction de réception Message Queuing s'affiche.

  4. Dans la zone Nom, entrez le nom de la fonction de réception Message Queuing.

  5. Dans la zone Commentaire, ajoutez éventuellement une brève description.

  6. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom d'un serveur du groupe.

  7. Dans la zone Emplacement de l'interrogation, tapez le nom du serveur et de Message Queuing que cette fonction de réception utilise en tant qu'emplacement de réception.

    Exemple :

    Direct=OS:<nom du serveur>\<nom de la file d'attente>

    Sélectionnez le serveur de traitement sur lequel la file d'attente réside. L'échange transactionnel est uniquement pris en charge par les files d'attente locales.

  8. Dans la liste Préprocesseur, cliquez sur le préprocesseur personnalisé.

    Ne renseignez pas ce champ si vous n'utilisez pas de préprocesseur personnalisé.

  9. Dans les zones Nom d'utilisateur et Mot de passe, tapez un nom d'utilisateur et un mot de passe valides pour la connexion à Message Queuing.

    Ces informations sont requises uniquement lorsque l'emplacement de réception ne se trouve pas sur le serveur qui traite les échanges et les documents.

  10. Pour personnaliser la fonction de réception de documents sans auto-routage ou pour spécifier des options openness ou directes, cliquez sur Avancé.

    Pour plus d'informations sur les options avancées, voir Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP.

Important

  • N'ajoutez pas le préfixe « queue:// » à <nom du serveur>\<nom de la file d'attente> dans la zone Emplacement de l'interrogation. Ces propriétés sont différentes des propriétés générales d'un groupe de serveurs pour lequel vous ajoutez le préfixe « queue:// ». Pour plus d'informations sur la syntaxe de Message Queuing, voir Fonctions de réception disponibles. Pour plus d'informations sur les propriétés d'un groupe de serveurs, voir Configuration des propriétés générales d'un groupe de serveurs.

Remarques

  • La fonction de réception Message Queuing n'est pas configurée pour accepter les soumissions directes.

  • Vérifiez que le nom de chaque fonction de réception créée est unique. Vous ne pouvez pas attribuer le même nom à plusieurs fonctions de réception.

  • Pour qu'une fonction de réception Message Queuing fonctionne, le mot de passe et le nom d'utilisateur fournis au serveur sur lequel BizTalk Server s'exécute doivent vous accorder des autorisations en lecture sur la file d'attente.

  • Dans un souci de fiabilité, vous devez utiliser des files d'attente transactionnelles. Si vous utilisez des files d'attente non transactionnelles, les messages risquent d'être perdus. Pour plus d'informations sur les files d'attente transactionnelles, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les mots clés « Message Queuing ».

  • Si vous répliquez une fonction de réception qui est configurée pour utiliser un nom d'utilisateur et un mot de passe, la fonction de réception répliquée ne sera pas active car le mot de passe ne sera plus valide. Pour résoudre ce problème, vous devez ouvrir la page de propriétés de chaque fonction de réception, entrer de nouveau le mot de passe, puis activer la fonction de réception.

  • Pour plus d'informations sur le prétraitement personnalisé, voir Préprocesseurs personnalisés.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP

Configuration d'une fonction de réception Message Queuing : onglet Général

Préprocesseurs personnalisés

Fonctions de réception


Configuration d'une fonction de réception Message Queuing : onglet Général

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception Message Queuing et Fonctions de réception.

  2. Cliquez sur la fonction de réception Message Queuing que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Dans la zone Commentaire, ajoutez éventuellement une brève description.

  5. Dans les champs Nom d'utilisateur et Mot de passe de la zone Sécurité, entrez un mot de passe et un nom d'utilisateur valides pour vous connecter à la file d'attente de messages.

    Ces informations sont requises uniquement lorsque l'emplacement de réception ne se trouve pas sur le serveur de traitement.

  6. Si vous voulez arrêter temporairement cette fonction de réception, activez la case à cocher Désactiver la fonction de réception, puis cliquez sur Oui pour confirmer votre choix.

Remarque

  • Si vous répliquez une fonction de réception qui est configurée pour utiliser un nom d'utilisateur et un mot de passe, la fonction de réception répliquée ne sera pas active car le mot de passe ne sera plus valide. Pour résoudre ce problème, vous devez ouvrir la page de propriétés de chaque fonction de réception, entrer de nouveau le mot de passe, puis activer la fonction de réception.

Voir aussi

Configuration d'une fonction de réception Message Queuing : onglet Services

Fonctions de réception


Configuration d'une fonction de réception Message Queuing : onglet Services

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception Message Queuing et Fonctions de réception.

  2. Cliquez sur la fonction de réception Message Queuing que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Cliquez sur l'onglet Services.

  5. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom du serveur.

  6. Dans la zone Emplacement de l'interrogation, tapez le nom du serveur et de Message Queuing que cette fonction de réception utilise en tant qu'emplacement de réception.

    Exemple :

    Direct=OS:<nom du serveur>\<nom de la file d'attente>

  7. Dans la liste Préprocesseur, cliquez sur le préprocesseur personnalisé.

    Ne renseignez pas ce champ si vous n'utilisez aucun préprocesseur personnalisé.

  8. Cliquez sur OK.

Important

  • N'ajoutez pas le préfixe « queue:// » à <nom du serveur>\<nom de la file d'attente> dans la zone Emplacement de l'interrogation. Ces propriétés sont différentes des propriétés générales d'un groupe de serveurs pour lequel vous ajoutez le préfixe « queue:// ». Pour plus d'informations sur la syntaxe de Message Queuing, voir Fonctions de réception disponibles. Pour plus d'informations sur les propriétés d'un groupe de serveurs, voir Configuration des propriétés générales d'un groupe de serveurs.

Remarque

  • Pour plus d'informations sur le prétraitement personnalisé, voir Préprocesseurs personnalisés.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés générales d'un groupe de serveurs

Préprocesseurs personnalisés


Ajout d'une fonction de réception HTTP

Cette procédure crée une fonction de réception HTTP avec les paramètres par défaut. Pour configurer une fonction de réception HTTP avec des paramètres supplémentaires, voir la section Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP.

Avant de commencer cette procédure, assurez-vous que les services IIS (Internet Information Services) sont en cours d'exécution sur le serveur sur lequel la fonction de réception HTTP s'exécutera. En outre, pour que la fonction de réception HTTP fonctionne correctement, vous devez utiliser un répertoire virtuel IIS doté des autorisations d'exécution. Pour plus d'informations sur la création d'un répertoire virtuel IIS, consultez la documentation relative à IIS 5.0.

Pour que la fonction de réception HTTP fonctionne correctement, lorsque le client spécifie le répertoire virtuel vers lequel les données doivent être transmises via le protocole HTTP à destination de la fonction de réception HTTP, la chaîne de requête doit nécessairement être codée au format MBCS (Multibyte Character String) au moyen de la page de code UTF-8. Il est également important que savoir que si l'en-tête Type de contenu n'est pas défini dans une requête entrante, la fonction de réception adopte par défaut le format USASCII. Ici, les données de l'instance risquent d'être corrompues si elles contiennent un jeu de caractères codés sur deux octets (DBCS) imbriqué. Pour plus d'informations, accédez au site Web MSDN Online Library (en anglais) (msdn.microsoft.com/library/), puis effectuez une recherche sur « Support for Multibyte Character Sets » et sur « Encoding.UTF8 Property ».

  1. Dans l'Explorateur Windows, accédez au fichier \Program Files\Microsoft BizTalk Server\HTTP Receive\BizTalkHTTPReceive.dll sur le lecteur d'installation.

  2. Copiez BizTalkHTTPReceive.dll dans le répertoire vers lequel pointe le répertoire virtuel IIS.

  3. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis cliquez sur le groupe de serveurs auquel vous voulez ajouter la fonction de réception HTTP.

  4. Cliquez sur Fonctions de réception.

  5. Dans le menu Action, pointez sur Nouveau et cliquez sur Fonction de réception HTTP.

    La boîte de dialogue Ajouter une fonction de réception HTTP apparaît.

  6. Dans la zone Nom, entrez le nom de la fonction de réception HTTP.

  7. Dans la zone Commentaire, ajoutez éventuellement une brève description.

  8. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom du serveur souhaité.

  9. Dans la zone Répertoire virtuel, tapez le nom du répertoire virtuel dans lequel placer les documents reçus par la fonction de réception HTTP. Généralement, le répertoire virtuel contient le nom de la DLL de la fonction de réception HTTP et éventuellement une chaîne de requête.

    Exemples de noms de répertoires virtuels :

    /<répertoire_virtuel>/BizTalkHTTPReceive.dll

    /<répertoire_virtuel>/BizTalkHTTPReceive.dll?Purchase%20Order

    Remarques

    • N'indiquez pas le nom du serveur dans la zone Répertoire virtuel. Le serveur a déjà été indiqué dans la zone Serveur sur lequel sera exécutée la fonction de réception.

    • Si le répertoire virtuel est configuré avec le nom de la DLL de la fonction de réception HTTP comme un des documents par défaut, vous devez inclure le nom de la DLL dans le nom du répertoire virtuel.

    • La valeur tapée dans la zone Répertoire virtuel ne doit pas contenir la chaîne http://.

    • Utilisez des chaînes de requête pour créer plusieurs fonctions de réception utilisant le même répertoire virtuel.

    • La requête indiquée dans la zone Répertoire virtuel doit utiliser la méthode URLEncode pour coder la chaîne de requête. Pour inclure des espaces, utilisez la chaîne %20.
  10. Dans la zone Envoyer à, sélectionnez l'emplacement (BizTalk/Fichier) et le mode (Synchrone/Asynchrone) d'envoi des documents de la fonction de réception HTTP.

    Si vous sélectionnez l'option BizTalk - Mode synchrone et que vous attendez un document de retour, entrez le type de contenu de retour dans la zone Type de contenu renvoyé. La valeur indiquée dans la zone Type de contenu renvoyé doit être identique à celle définie pour le type de contenu HTTP dans les spécifications HTTP. Pour plus d'informations sur les spécifications HTTP, accédez au site Web de W3C à l'adresse www.w3.org.

    — ou —

    Si vous sélectionnez Fichier, entez le chemin d'accès et le nom du fichier dans lequel le document reçu doit être enregistré, dans la zone Chemin et nom de fichier. Vous pouvez spécifier dans le nom du fichier des variables qui doivent être remplacées au moment de l'exécution. Les trois variables acceptées sont les suivantes : %guid%, %server% et %datetime%. Vous pouvez par exemple spécifier le chemin d'accès et le nom de fichier suivant : D:\Répertoire\Nom_fichier%guid%.xml.

    Important

    • Si un problème se produit tandis que la fonction de réception HTTP effectue l'envoi vers un fichier, le message ne sera pas stocké dans la file d'attente interrompue.
  11. Activez la case à cocher Renvoyer un jeton de corrélation pour qu'un jeton de corrélation soit renvoyé à l'expéditeur du document.

    Lorsqu'un document est transmis à BizTalk Server, le jeton de corrélation contient un identificateur global unique de soumission (GUID). Lorsqu'un document est envoyé vers un fichier, le jeton de corrélation contient le nom de ce fichier. Le jeton de corrélation peut ressembler à ceci :

    <BizTalkHttpReceive><CorrelationToken TokenType= SUBMIT>{1a3e5678-a2c9-12d4-a8cd-12a456e89012}</CorrelationToken></BizTalkHttpReceive>

  12. Dans la liste Préprocesseur, cliquez sur le nom du préprocesseur personnalisé.

    Remarque

    • Ne renseignez pas ce champ si vous n'utilisez pas de préprocesseur personnalisé.

    Pour plus d'informations, voir Preprocessing Documents in a Receive Function.

  13. Pour personnaliser la fonction de réception de documents sans auto-routage ou pour spécifier des options openness ou directes, cliquez sur Avancé.

    Pour plus d'informations sur les options avancées, voir Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP.

Afin que la fonction de réception HTTP que vous venez de créer fonctionne, il est important de bénéficier des privilèges d'accès appropriés dans les suites COM+ affectées par différents niveaux de protection dans les services IIS (Internet Information Services).

Passez à Configuration des privilèges d'accès selon le niveau de protection IIS.

Remarques

  • Vérifiez que le nom de chaque fonction de réception créée possède un nom de répertoire unique, ainsi que la chaîne de requête. Vous ne pouvez pas attribuer le même nom à plusieurs fonctions de réception.

  • Plusieurs bibliothèques de liaison dynamique (DLL) correspondant à différents répertoires virtuels peuvent être déployées sur le même serveur. De même, plusieurs répertoires peuvent pointer vers la même DLL. En revanche, pour améliorer les performances, il est recommandé de n'utiliser qu'une seule DLL.

  • Les clients effectuent des envois vers la fonction de réception HTTP en utilisant l'URL /RépertoireVirtuel. Cependant, avec IIS 5.0 et Windows 2000 Service Pack 2 (SP2), la DLL doit aussi faire partie de l'URL spécifiée : /RépertoireVirtuel/BizTalkHTTPreceive.dll.

  • Une fois la fonction de réception HTTP créée, il n'est plus possible de modifier le type d'envoi de base (BizTalk/Fichier).

  • Si vous sélectionnez l'option BizTalk - Mode synchrone dans la zone Envoyer à, et si vous activez la case à cocher Renvoyer un jeton de corrélation, un jeton de corrélation est envoyé uniquement lorsque le document de retour est vide.

  • Le jeton de corrélation ne dépend pas de la corrélation d'orchestration. Pour plus d'informations, voir Jeton de corrélation.

  • Si la fonction de réception HTTP utilise le mode d'envoi synchrone et que le canal envoie le message via un port Message Queuing, il est possible que le message d'erreur suivant s'affiche : « Utilisation non valide de la transaction ». Ceci se produit parce que la fonction de réception HTTP est non transactionnelle alors que le service Message Queuing est transactionnel. Pour éviter ce problème, vous devez sélectionner l'option de niveau transactionnel Message unique pour le canal. Pour plus d'informations sur les propriétés avancées de canal, voir Remplacement des valeurs par défaut d'un port d'échanges.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP

Configuration d'une fonction de réception HTTP : onglet Général

Configuration d'une fonction de réception HTTP : onglet Services

Préprocesseurs personnalisés

Fonctions de réception


Configuration d'une fonction de réception HTTP : onglet Général

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception HTTP et Fonctions de réception.

  2. Cliquez sur la fonction de réception HTTP que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Dans la zone Commentaire de l'onglet Général, ajoutez éventuellement une brève description.

  5. Si vous voulez arrêter temporairement cette fonction de réception, activez la case à cocher Désactiver la fonction de réception, puis cliquez sur Oui pour confirmer votre choix.

Voir aussi

Configuration d'une fonction de réception HTTP : onglet Services

Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP


Configuration d'une fonction de réception HTTP : onglet Services

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe de serveurs pour lequel vous voulez configurer une fonction de réception HTTP et Fonctions de réception.

  2. Cliquez sur la fonction de réception HTTP que vous voulez configurer.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  4. Cliquez sur l'onglet Services.

  5. Dans la liste Serveur sur lequel sera exécutée la fonction de réception, cliquez sur le nom du serveur.

  6. Dans la zone Répertoire virtuel, tapez le nom du répertoire virtuel dans lequel placer les documents reçus par la fonction de réception HTTP.

    Exemples de noms de répertoires virtuels :

    /<répertoire_virtuel>/BizTalkHTTPReceive.dll

    /<répertoire_virtuel>/BizTalkHTTPReceive.dll?Purchase%20Order

    Remarques

    • N'indiquez pas le nom du serveur dans la zone Répertoire virtuel. Le serveur a déjà été indiqué dans la zone Serveur sur lequel sera exécutée la fonction de réception.

    • Si le répertoire virtuel est configuré avec le nom de la DLL de la fonction de réception HTTP comme un des documents par défaut, vous devez inclure le nom de la DLL dans le nom du répertoire virtuel.

    • La valeur tapée dans la zone Répertoire virtuel ne doit pas contenir la chaîne http://.

    • Utilisez des chaînes de requête pour créer plusieurs fonctions de réception utilisant le même répertoire virtuel.

    • La requête indiquée dans la zone Répertoire virtuel doit utiliser la méthode URLEncode pour coder la chaîne de requête. Pour inclure des espaces, utilisez la chaîne %20.
  7. Si la fonction de réception HTTP effectue des envois vers BizTalk Server, sélectionnez la méthode d'envoi (Mode asynchrone ou Mode synchrone) dans la zone Envoyer à.

    Si vous sélectionnez l'option BizTalk - Mode synchrone, indiquez le type de contenu de retour dans la zone Type de contenu renvoyé. La valeur indiquée dans la zone Type de contenu renvoyé doit être identique à celle définie pour le type de contenu HTTP dans les spécifications HTTP. Pour plus d'informations sur les spécifications HTTP, accédez au site Web de W3C à l'adresse www.w3.org.

    Question d'ordre international

    • Si l'en-tête Type de contenu n'est pas défini dans une requête entrante, la fonction de réception HTTP adoptera par défaut le format USASCII. Dans ce cas, les données de l'instance risquent d'être corrompues si elles contiennent un jeu de caractères codés sur deux octets (DBCS) imbriqué.
  8. Dans la liste Préprocesseur, cliquez sur le nom du préprocesseur personnalisé.

    Remarque

    • Ne renseignez pas ce champ si vous n'utilisez pas de préprocesseur personnalisé.

    Pour plus d'informations, voir Preprocessing Documents in a Receive Function.

  9. Si la fonction de réception effectue des envois dans un fichier, entrez le chemin d'accès et le nom du fichier dans lequel les documents reçus doivent être enregistrés, dans la zone Chemin et nom de fichier. Vous pouvez spécifier dans le nom du fichier des variables qui doivent être remplacées au moment de l'exécution. Les trois variables acceptées sont les suivantes : %guid%, %server% et %datetime%. Vous pouvez par exemple spécifier le chemin d'accès et le nom de fichier suivant : D:\Répertoire\Nom_fichier%guid%.xml.

  10. Activez la case à cocher Renvoyer un jeton de corrélation pour qu'un jeton de corrélation soit renvoyé à l'expéditeur du document.

    Lorsqu'un document est transmis à BizTalk Server, le jeton de corrélation contient un identificateur global unique de soumission (GUID). Lorsqu'un document est envoyé vers un fichier, le jeton de corrélation contient le nom de ce fichier. Le jeton de corrélation peut ressembler à ceci :

    <BizTalkHttpReceive><CorrelationToken TokenType= SUBMIT>{1a3e5678-a2c9-12d4-a8cd-12a456e89012}</CorrelationToken></BizTalkHttpReceive>

  11. Cliquez sur OK.

Remarques

  • Dans une installation d'outils de BizTalk Server, la console Administration ne prend pas en charge la création d'une fonction de réception HTTP.

  • Le jeton de corrélation ne dépend pas de la corrélation d'orchestration. Pour plus d'informations, voir Jeton de corrélation.

  • Une fois la fonction de réception HTTP créée, il n'est plus possible de modifier le type d'envoi de base (BizTalk/Fichier).

  • Si vous sélectionnez l'option BizTalk - Mode synchrone dans la zone Envoyer à et si vous activez la case à cocher Renvoyer un jeton de corrélation, un jeton de corrélation est envoyé uniquement lorsque le document de retour est vide.

  • Les clients effectuent des envois vers la fonction de réception HTTP à l'aide de l'URL /RépertoireVirtuel. Cependant, avec IIS 5.0 et Windows 2000 Service Pack 2 (SP2), la DLL doit également faire partie de l'URL spécifiée : /RépertoireVirtuel/BizTalkHTTPreceive.dll.

  • Utilisez des chaînes de requête pour créer plusieurs fonctions de réception utilisant le même répertoire virtuel.

Voir aussi

Fonctions de réception disponibles

Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP

Préprocesseurs personnalisés


Configuration des propriétés avancées des fonctions de réception de fichier, Message Queuing et HTTP

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002 et le groupe de serveurs pour lequel vous voulez configurer une fonction de réception, puis cliquez sur la fonction de réception.

  2. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés s'affiche.

  3. Cliquez sur l'onglet Avancé.

  4. Dans la liste Propriétés Openness, vous pouvez sélectionner :
    • Non ouvert : cliquez sur cette option lorsque la source et la destination sont déclarées explicitement dans la fonction de réception ou dans l'instance de document et lorsque BizTalk Server ne doit pas analyser le document pour vérifier ces informations.

    • Destination ouverte : cliquez sur cette option lorsque les informations de destination ne sont pas déclarées explicitement dans le port d'échanges. La destination est spécifiée dynamiquement dans l'instance de document ou dans un paramètre d'envoi.

    • Source ouverte : cliquez sur cette option lorsque les informations de la source ne sont pas explicitement déclarées dans le canal. La source est spécifiée dynamiquement dans l'instance de document ou dans un paramètre d'envoi.
  5. Si vous voulez ignorer les traitements tels que le décodage, le décryptage, la vérification de la signature et l'analyse, et soumettre uniquement un échange, activez la case à cocher Soumettre avec un indicateur direct.

    Vous devez sélectionner un canal si vous activez la case à cocher Soumettre avec un indicateur direct.

  6. Dans la liste Nom d'enveloppe, cliquez sur le nom d'une définition d'enveloppe.

    Choisissez une enveloppe si vous pensez recevoir des tables bidimensionnelles. Dans le cas contraire, ne renseignez pas ce champ.

  7. Dans la liste Nom du canal, cliquez sur le nom d'un canal.

  8. Dans la liste Nom de la définition de document, cliquez sur le nom d'une définition de document.

  9. Dans la zone Source et destination, cliquez sur Parcourir dans la zone Source sélectionnée.

    La boîte de dialogue Sélectionner la source apparaît.

  10. Dans la liste Qualificateur de l'organisation, cliquez sur le type de qualificateur de l'organisation source.

  11. Dans la liste Valeur de l'identificateur d'organisation, cliquez sur la valeur de l'identificateur de l'organisation source, puis cliquez sur OK.

  12. Dans la zone Source et destination, cliquez sur Parcourir dans la zone Destination sélectionnée.

    La boîte de dialogue Sélectionner la destination s'affiche.

  13. Dans la liste Qualificateur de l'organisation, cliquez sur le type de qualificateur de l'organisation de destination.

    Si vous envoyez des documents à une liste de distribution, dans la liste Qualificateur de l'organisation, vous devez choisir Groupe.

  14. Dans la liste Valeur de l'identificateur d'organisation, cliquez sur la valeur de l'identificateur de l'organisation de destination, puis cliquez sur OK.

  15. Cliquez sur OK.

Important

  • Vous devez créer les objets présentés ci-après pour pouvoir les affecter comme propriétés avancées d'une fonction de réception. Ces objets sont créés soit dans le Gestionnaire d'échanges BizTalk, soit en mode programmation, et sont stockés dans la base de données Gestion d'échanges BizTalk :
    • Enveloppes

    • Canaux

    • Définitions de documents

    • Qualificateurs source

    • Valeurs de l'identificateur d'organisation source

    • Qualificateurs de destination

    • Valeurs de l'identificateur d'organisation de destination

Remarques

  • Si vous cliquez sur Source ouverte ou Destination ouverte dans la liste Propriété Openness, la case à cocher Soumettre avec un indicateur direct n'est pas disponible.

  • Si la case à cocher Soumettre avec un indicateur direct est activée, seule la liste Canal est disponible.

  • Si vous voulez envoyer un document à une liste de distribution, vous devez sélectionner Groupe dans la liste Qualificateur de l'organisation de la boîte de dialogue Sélectionner la destination.

  • Toutes les propriétés avancées des fonctions de réception sont facultatives ; vous ne devez pas nécessairement les définir. Pour plus d'informations sur l'envoi de documents, voir Routing ou Description des fonctions de réception et du routage de documents.

  • Lorsque vous envoyez directement des documents, les fonctions d'analyse, de décryptage et de décodage de BizTalk Server 2002 ne sont pas utilisées. Pour plus d'informations sur l'envoi de documents avec l'indicateur direct, voir Description des propriétés avancées d'une fonction de réception. Pour plus d'informations sur l'envoi de documents, voir Submitting.

  • L'onglet Avancé n'est pas disponible pour une fonction de réception HTTP qui effectue des envois à un fichier.

  • L'onglet Avancé pour les fonctions de réception n'est pas disponible dans une installation d'outils de BizTalk Server.

Voir aussi

Fonctions de réception

Routing

Submitting

Description des propriétés avancées d'une fonction de réception

Description des fonctions de réception et du routage de documents


Configuration des privilèges d'accès selon le niveau de protection IIS

Après avoir ajouté une fonction de réception HTTP, il est important que certaines suites COM+ soient configurées en fonction du niveau d'isolement dont bénéficie le répertoire virtuel :

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Gestion de l'ordinateur.

  2. Dans l'arborescence de la console Gestion de l'ordinateur, développez successivement Services et applications et Services Internet (IIS), puis développez le nom du site Web dans lequel figure le répertoire virtuel utilisé par la fonction de réception HTTP (la valeur par défaut est Site Web par défaut).

  3. Cliquez avec le bouton droit sur le répertoire virtuel, puis cliquez sur Propriétés.

  4. Dans l'onglet Répertoire virtuel, consultez le niveau de protection d'application.

    Si le niveau de protection d'application est Basse (Processus IIS), passez à l'étape 5.

    Si le niveau de protection d'application est Moyenne (En file d'attente), passez à l'étape 7.

    Si le niveau de protection d'application est Élevée (Isolé), passez à l'étape 9.

  5. Si le niveau de protection d'application est configuré comme étant Basse (Processus IIS), ouvrez les Services de composants, double-cliquez sur Services, cliquez avec le bouton droit sur Service de publication World Wide Web, puis sélectionnez Propriétés.

  6. Dans l'onglet Connexion, configurez les propriétés de connexion de l'utilisateur pour lequel il existe des informations d'autorisation sécurisées permettant d'accéder à la base de données Gestion d'échanges BizTalk, à l'application COM+ Échange BizTalk Server, ainsi qu'aux utilitaires internes BizTalk Server.

  7. Si le niveau de protection d'application du répertoire virtuel est configuré comme étant Moyenne (En file d'attente), ouvrez les Services de composants, développez Applications COM+, cliquez avec le bouton droit sur IIS Out-of-Process Pooled Applications, puis sélectionnez Propriétés.

  8. Dans l'onglet Identité, configurez les propriétés de Compte de l'utilisateur pour lequel il existe des informations d'autorisation sécurisées permettant d'accéder à la base de données Gestion d'échanges BizTalk, à l'application COM+ Échange BizTalk Server, ainsi qu'aux utilitaires internes BizTalk Server.

  9. Si le niveau de protection d'application du répertoire virtuel est configuré comme étant Élevée (Isolé), ouvrez les Services de composants, développez Applications COM+, cliquez avec le bouton droit sur IIS_{Site Web par défaut//racine/nom du répertoire virtuel}, puis sélectionnez Propriétés.

  10. Dans l'onglet Identité, configurez les propriétés de Compte de l'utilisateur pour lequel il existe des informations d'autorisation sécurisées permettant d'accéder à la base de données Gestion d'échanges BizTalk, à l'application COM+ Échange BizTalk Server, ainsi qu'aux utilitaires internes BizTalk Server.

Voir aussi

Ajout d'une fonction de réception HTTP


Suppression d'une fonction de réception

Cette tâche vous permet de supprimer une instance d'une fonction de réception. Elle consiste en fait simplement à supprimer l'instance d'objet administratif de la base de données administrative. Elle ne concerne en rien les composants et scripts réels liés à l'instance.

  1. Dans Administration de BizTalk Server, développez successivement Microsoft BizTalk Server 2002, le groupe de serveurs dans lequel vous voulez supprimer une fonction de réception et Fonctions de réception.

  2. Cliquez sur la fonction de réception que vous voulez supprimer.

  3. Dans le menu Action, cliquez sur Supprimer.

    La boîte de dialogue Confirmation de l'action utilisateur s'affiche.

  4. Cliquez sur Oui.

Voir aussi

Fonctions de réception


Gestion des services BizTalk

Lorsque vous effectuez une modification fondamentale de la configuration de BizTalk Server, telle que le changement de nom d'une base de données ou l'ajout d'un serveur Web ou d'un pare-feu, il est possible qu'un service d'exécution continue à utiliser les paramètres qui s'appliquent à l'ancienne configuration. Pour synchroniser tous les services pour une nouvelle configuration, il est important d'arrêter, puis de redémarrer les services BizTalk concernés par la modification.

Cette section traite des procédures suivantes :

  • Démarrage d'un service BizTalk

  • Arrêt d'un service BizTalk


Démarrage d'un service BizTalk

Cette tâche vous permet de démarrer les services BizTalk associés à un serveur spécifique.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002 et Groupe BizTalk Server, puis sélectionnez le serveur sur lequel démarrer les services BizTalk.

  2. Dans le menu Action, cliquez sur Démarrer.

Voir aussi

Arrêt d'un service BizTalk

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Arrêt d'un service BizTalk

Cette tâche vous permet d'arrêter les services BizTalk associés à un serveur spécifique. Généralement, les services BizTalk sont arrêtés pour interrompre temporairement le traitement lors de la modification de la base de données de configuration ou de la résolution de problèmes.

  1. Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002 et Groupe BizTalk Server, puis sélectionnez le serveur sur lequel démarrer les services BizTalk.

  2. Dans le menu Action, cliquez sur Arrêter.

Voir aussi

Démarrage d'un service BizTalk

Démarrage d'un serveur dans un groupe

Arrêt d'un serveur dans un groupe


Gestion de l'Observateur d'événements

Vous pouvez utiliser l'Observateur d'événement inclus dans Administration de BizTalk Server pour faciliter la résolution des problèmes liés au serveur et au traitement des documents. L'Observateur d'événements apparaît dans l'arborescence de la console d'administration de BizTalk Server. Toutes les erreurs d'application de BizTalk Server 2002 sont considérées comme des erreurs de BizTalk Server. Toutes les erreurs de planification XLANG sont considérées comme des erreurs de XLANG Scheduler.

Cette section traite des procédures suivantes :

  • Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server

  • Affichage des erreurs d'application dans l'Observateur d'événements

Remarque

  • Il est possible que certaines erreurs renvoyées par le parseur Microsoft XML (MSXML) dans une fonction de script personnalisé ne soient pas affichées dans l'Observateur d'événements. Les erreurs associées à un document de la file d'attente interrompue peuvent ne pas refléter l'erreur renvoyée dans le script.


Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server

Cette tâche vous permet de configurer l'Observateur d'événements pour qu'il affiche uniquement les événements liés à BizTalk Server et/ou à XLANG Scheduler. Elle s'effectue généralement lorsque vous ne souhaitez pas afficher toutes les erreurs provenant d'autres programmes, lors de la résolution des problèmes.

  1. Dans BizTalk Server Administration, développez Observateur d'événements.

  2. Cliquez sur Application.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés d'application s'affiche.

  4. Cliquez sur l'onglet Filtre.

  5. Dans la liste Source d'événements, cliquez sur l'une des options suivantes :
    • BizTalk Server : filtre les sources d'événements des messages d'erreur liés aux services d'échanges BizTalk.

    • XLANG Scheduler : filtre les sources d'événements des messages d'erreur liés aux services d'orchestration BizTalk.
  6. Cliquez sur OK pour fermer la boîte de dialogue Propriétés d'application.


Affichage des erreurs d'application dans l'Observateur d'événements

  1. Dans BizTalk Server Administration, développez Observateur d'événements.

  2. Cliquez sur Application.

    Les messages d'erreur d'application figurent dans le volet de détails.

  3. Cliquez sur un message dans la liste.

  4. Dans le menu Action, cliquez sur Propriétés.

Remarque

  • Cette procédure implique que vous ayez configuré l'Observateur d'événements pour qu'il affiche uniquement les messages d'erreur de BizTalk Server et de XLANG Scheduler. Pour plus d'informations sur l'affichage des erreurs de BizTalk Server et de XLANG Scheduler, voir Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server.


Gestion des applications et des bases de données XLANG

Cette section explique comment gérer l'application XLANG Scheduler par défaut, créée lorsque vous installez BizTalk Server 2002. Elle explique également comment créer de nouvelles applications COM+ en vue d'héberger des instances de planification XLANG et de nouvelles bases de données de persistance pour stocker les informations relatives à l'état de la planification XLANG.

Cette section traite des rubriques et procédures suivantes :

  • Utilisation de procédures stockées pour supprimer des enregistrements de la base de données de persistance

  • Arrêt de toutes les applications XLANG

  • Redémarrage de toutes les applications XLANG

  • Gestion de l'application XLANG Scheduler par défaut

  • Gestion des autres applications COM+ hébergeant des planificactions XLANG

  • Surveillance de l'exécution des planifications XLANG

Attention

  • BizTalk Server 2002 propose une application COM+ appelée programme d'assistance XLANG, utilisée avec toutes les applications COM+ qui hébergent des instances de planification XLANG. Vous ne pouvez absolument pas modifier la configuration du programme d'assistance XLANG Scheduler Persistence Helper une fois l'installation terminée.

Remarques

  • Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

  • Pour accéder à l'aide de l'administration des services de composants, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composants. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

Voir aussi

Exécution des planifications XLANG

Exécuter les planifications XLANG


Utilisation de procédures stockées pour supprimer des enregistrements de la base de données de persistance

La base de données de persistance contient toutes les informations de persistance des planifications XLANG qui sont en cours d'exécution et celles qui sont terminées. Étant donné que les données des planifications XLANG terminées ne sont pas supprimées de la base de données, celle-ci continue à croître. Vous pouvez utiliser les procédures stockées suivantes pour supprimer des enregistrements de la base de données de persistance.

sp_CleanDoneInstances @CompletedBefore='<date et heure GMT>'

La procédure stockée sp_CleanDoneInstances supprime toutes les instances de planification XLANG terminées ou arrêtées. Le code suivant est un exemple d'utilisation de cette procédure :

exec sp_CleanDoneInstances @CompletedBefore='2000-10-25 19:34:49.000'

Remarques

  • L'heure est basée sur l'heure du méridien de Greenwich (GMT) car toutes les informations de date et d'heure sont stockées dans la base de données de persistance d'orchestration dans ce format.

  • L'heure de fin s'applique uniquement aux planifications de niveau racine.

sp_CleanDoneModuleInstances @CompletedBefore='<date et heure GMT>', @ModuleGUID='<identificateur global unique>'

La procédure stockée sp_CleanDoneModuleInstances supprime toutes les instances de planification XLANG terminées ou arrêtées d'un type de planification spécifique. Le code suivant est un exemple d'utilisation de cette procédure :

exec sp_CleanDoneModuleInstances @CompletedBefore='2000-10-25 19:34:49.000',
@ModuleGUID='4C5842DA-40E5-40B8-AF03-BC5DD4B7E037'

Remarques

  • L'heure est basée sur le format d'heure du méridien de Greenwich (GMT) car toutes les informations de date et d'heure sont stockées dans la base de données de persistance d'orchestration dans ce format.

  • L'heure de fin s'applique uniquement aux planifications de niveau racine.

  • @ModuleGUID est le ModuleID d'une planification.

    ModuleID est une référence unique à un type spécifique de planification XLANG. Vous pouvez utiliser le paramètre @ModuleGUID pour filtrer sur le type de planification XLANG. Le paramètre @CompletedBefore filtre les instances de planification XLANG qui se sont terminées avant une heure donnée tandis que le paramètre @ModuleGUID filtre les planifications XLANG d'un certain type. Vous pouvez utiliser l'Observateur XLANG pour déterminer le ModuleID d'une planification XLANG. Le ModuleID est l'une des propriétés des événements concernant ScheduleStart, ScheduleDone, ContextEnter, ContextLeave, TransactionBegin et TransactionEnd. Pour l'obtenir, vous pouvez également recourir à l'interface publique vers les instances de planification XLANG, IWFWorkflowInstance::ModuleId Property.

sp_CleanInstance@InstanceID='{<identificateur unique global>}'

La procédure stockée sp_CleanInstance supprime une planification XLANG terminée ou arrêtée ainsi que toutes les instances filles de cette planification. Cette opération de suppression est transactionnelle. Dans cette procédure stockée, @InstanceID est l'identificateur global unique (GUID), c'est-à-dire l'identificateur d'instance de la planification XLANG racine. BizTalk Server 2002 se sert de cette procédure stockée. Vous n'avez pas besoin d'appeler cette procédure directement. Il vaut mieux suivre les instructions pour purger la base de données XLANG.

Remarque

  • Vous pouvez créer des travaux de l'Agent SQL Server qui utiliseront ces procédures stockées à des intervalles réguliers. Pour plus d'informations, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.


Arrêt de toutes les applications XLANG

Vous devez suivre cette procédure pour effectuer un arrêt contrôlé de toutes les applications COM+. Elle vous permet de fermer toutes les planifications XLANG en cours d'exécution en enregistrant leur état dans la base de données de persistance. Pour plus d'informations, voir Persistance.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composants, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur XLANG Scheduler.

  4. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de XLANG Scheduler s'affiche.

  5. Dans la zone Arrêt contrôlé de l'onglet XLANG, cliquez sur Toutes les applications XLANG.

Attention

  • Ne cliquez pas avec le bouton droit sur une application COM+, mais cliquez sur Arrêter. L'une des actions suivantes peut se produire :
    • Si les planifications XLANG en cours sont entièrement transactionnelles, un arrêt non contrôlé provoque l'abandon de toutes les transactions en cours d'exécution.

    • Si les planifications XLANG en cours d'exécution ne sont pas entièrement transactionnelles, les données traitées dans la planification sont perdues.

Important

  • Vous ne pouvez pas redémarrer des planifications mises en attente si le nom de la source de données (DSN) n'est pas disponible ou n'est pas configuré correctement. Pour plus d'informations sur la configuration d'un DSN lié à l'application XLANG Scheduler par défaut, voir Modification de l'identité de l'application XLANG Scheduler par défaut.

Remarques

  • Pour accéder à l'aide de l'administration des services de composants, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composants. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

Voir aussi

Modification de l'identité de l'application XLANG Scheduler par défaut

Redémarrage de toutes les applications XLANG

Exécution des planifications XLANG

Exécuter les planifications XLANG

Arrêt d'une application COM+ hébergeant des planifications XLANG


Redémarrage de toutes les applications XLANG

Vous devez suivre cette procédure pour effectuer un redémarrage contrôlé de toutes les applications COM+.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composants, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur XLANG Scheduler.

  4. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de XLANG Scheduler s'affiche.

  5. Dans la zone Redémarrer les applications XLANG en attente de l'onglet XLANG, cliquez sur Toutes les applications XLANG.

Important

  • Vous ne pouvez pas redémarrer des planifications mises en attente si le nom de la source de données (DSN) n'est pas disponible ou n'est pas configuré correctement. Le nom de la source de données (DSN) et de l'application COM+ doivent être similaires. Par exemple, si l'application COM+ hébergeant le moteur de XLANG Scheduler porte le nom XLANG Scheduler, le DSN doit également porter le nom XLANG Scheduler.

  • Lorsque vous redémarrez des applications mises en attente, celles-ci sont réalimentées de manière asynchrone. Le processus de réalimentation n'est pas immédiat. Utilisez l'Observateur d'événements XLANG pour déterminer la fin du processus de réalimentation. Pour plus d'informations sur l'outil Observateur d'événements XLANG, reportez-vous au fichier Readme.htm correspondant. L'Observateur d'événements XLANG (XLANGMon.exe) et le fichier Readme installés par l'Assistant Installation de Microsoft BizTalk Server 2002 se trouvent dans le répertoire d'installation suivant : \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools.

Remarques

  • Pour accéder à l'aide de l'administration des services de composants, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composants. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

Voir aussi

Modification de l'identité de l'application XLANG Scheduler par défaut

Exécution des planifications XLANG

Exécuter les planifications XLANG

Arrêt d'une application COM+ hébergeant des planifications XLANG

Arrêt de toutes les applications XLANG


Gestion de l'application XLANG Scheduler par défaut

L'application XLANG Scheduler par défaut héberge l'instance par défaut du moteur de XLANG Scheduler créée au cours de l'installation de BizTalk Server 2002. Dans les systèmes de production ou les systèmes utilisant Microsoft Terminal Server, vous devez changer l'identité par défaut de cette application.

Pour plus d'informations sur la sécurité et les performances liées à la modification des paramètres par défaut de l'application XLANG Scheduler par défaut, voir Sécurité des applications hébergeant des instances de planification XLANG.

La procédure suivante est traitée dans cette section :

  • Modification de l'identité de l'application XLANG Scheduler par défaut

Remarques

  • Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

  • Pour accéder à l'aide de l'administration des services de composants, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composants. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

Voir aussi

Création d'une application COM+ pour héberger des planifications XLANG

Exécution des planifications XLANG

Exécuter les planifications XLANG


Modification de l'identité de l'application XLANG Scheduler par défaut

Il est conseillé de remplacer le compte d'utilisateur interactif par défaut de l'application XLANG Scheduler par défaut par un compte de services. En effet, avec un compte d'utilisateur interactif, si aucun utilisateur n'est connecté, l'application ne fonctionne pas. En remplaçant le compte interactif par un compte de service, un utilisateur spécifique n'est pas obligé de rester connecté tout le temps. Un compte de services est un compte doté de propriétés spécifiques qui lui permettent d'être considéré comme faisant partie du système d'exploitation. Pour plus d'informations sur la sécurité et les performances liées à la modification des paramètres par défaut de l'application XLANG Scheduler par défaut, voir Sécurité des applications hébergeant des instances de planification XLANG. Pour plus d'informations sur la configuration d'un compte de services, voir Création d'un compte de services.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composants, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur XLANG Scheduler.

  4. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de XLANG Scheduler s'affiche.

  5. Dans la zone Autorisation de l'onglet Avancé, désactivez la case à cocher Désactiver les modifications, puis cliquez sur OK.

    Le message suivant s'affiche :

    Les applications ont été créées par un ou plusieurs produits externes. Êtes-vous sûr que les modifications que vous allez effectuer sont prises en charge par ces produits ?

  6. Cliquez sur Oui.

    La boîte de dialogue Propriétés de XLANG Scheduler se ferme.

  7. Cliquez sur XLANG Scheduler.

  8. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de XLANG Scheduler s'affiche.

  9. Dans la zone Compte de l'onglet Identité, cliquez sur Cet utilisateur.

  10. Entrez les informations du compte que vous voulez utiliser.

  11. Cliquez sur OK.

    Le message suivant s'affiche :

    Les applications ont été créées par un ou plusieurs produits externes. Êtes-vous sûr que les modifications que vous allez effectuer sont prises en charge par ces produits ?

  12. Cliquez sur Oui.

Remarques

  • Si vous ouvrez la boîte de dialogue Propriétés de XLANG Scheduler dans Microsoft Terminal Server, l'onglet XLANG n'est pas visible si le compte XLANG Scheduler a la valeur Utilisateur interactif (dans l'onglet Identité) et si aucun utilisateur n'est connecté au serveur hôte BizTalk Server. Pour résoudre ce problème, exécutez la procédure précédente.

  • Pour accéder à l'aide de l'administration des services de composants, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composants. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

Voir aussi

Modification des paramètres DSN d'une application COM+

Création d'une base de données de persistance vide

Création d'une application d'instanciation

Redémarrage de toutes les applications XLANG

Exécution des planifications XLANG

Exécuter les planifications XLANG

Arrêt de toutes les applications XLANG


Gestion des autres applications COM+ hébergeant des planifications XLANG

Vous pouvez utiliser l'application XLANG Scheduler par défaut pour exécuter les planifications XLANG, mais il est souvent utile de créer une nouvelle application COM+ pour exécuter les instances de planification, pour résoudre les problèmes de sécurité, de déploiement et de configuration.

Vous pouvez créer une nouvelle application COM+ afin d'héberger des instances dédiées des planifications en cours d'exécution pour répartir la charge de traitement, ou bien isoler des applications exécutant des instances de planification XLANG spécifiques d'autres planifications XLANG qui utilisent des applications différentes ou qui s'exécutent sous différentes identités. Vous devez tenir compte des performances et de la sécurité des applications et des planifications. Pour plus d'informations, voir Exécution des planifications XLANG et Exécution des planifications XLANG.

Pour créer une nouvelle application COM+ afin d'héberger les planifications XLANG, vous devez d'abord créer la base de données de persistance à laquelle cette application COM+ sera associée. Ensuite, vous devez créer l'application COM+, modifier les paramètres d'identité d'application par défaut, configurer les paramètres DSN (nom de la source des données) de l'application COM+ et, enfin, initialiser les tables de la base de données de persistance. Pour plus d'informations sur la création d'une application COM+, voir Création d'une application COM+ pour héberger des planifications XLANG.

Cette section traite des procédures suivantes :

  • Création d'une base de données de persistance vide

  • Modification de l'identité d'une application COM+

  • Modification des paramètres DSN d'une application COM+

  • Arrêt d'une application COM+ hébergeant des planifications XLANG

Remarques

  • Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

  • Pour accéder à l'aide de l'administration des services de composants, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composants. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».


Création d'une base de données de persistance vide

Vous pouvez être amené à créer une base de données de persistance pour stocker les informations de planification d'une application COM+ hébergeant les instances dédiées des planifications XLANG en cours d'exécution.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez successivement Serveurs Microsoft SQL, Groupe SQL Server, le serveur auquel vous voulez ajouter une nouvelle base de données et Bases de données.

  3. Cliquez sur Bases de données.

  4. Dans le menu Action, cliquez sur Nouvelle base de données.

    La boîte de dialogue Propriétés de la base de données s'affiche.

  5. Dans la zone Nom de l'onglet Général, entrez le nom de la nouvelle base de données, puis cliquez sur OK.

Une nouvelle base de données est créée avec les valeurs par défaut, lesquelles peuvent être modifiées.

Remarque

  • Pour plus d'informations sur Microsoft SQL Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft SQL Server, puis cliquez sur Documentation en ligne.

Voir aussi

Modification de l'identité de l'application XLANG Scheduler par défaut

Exécution des planifications XLANG

Exécuter les planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG


Modification de l'identité d'une application COM+

Après avoir créé l'application COM+ destinée à héberger les planifications XLANG, vous devez modifier les informations utilisateur. Pour plus d'informations sur la création d'une application COM+ en vue d'héberger des planifications XLANG, voir Création d'une application COM+ pour héberger des planifications XLANG.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composants, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur l'application COM+ dont vous voulez modifier l'identité puis, dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'application COM+ sélectionnée s'affiche.

  4. Dans la zone Autorisation de l'onglet Avancé, assurez-vous que la case à cocher Désactiver les modifications est désactivée, puis cliquez sur OK.

    La boîte de dialogue Propriétés s'affiche.

  5. Cliquez avec le bouton droit sur l'application COM+, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'application COM+ sélectionnée s'affiche.

  6. Dans la zone Compte de l'onglet Identité, cliquez sur Cet utilisateur.

  7. Entrez les informations du compte que vous voulez utiliser.

  8. Cliquez sur OK.

    Le message suivant s'affiche :

    Les applications ont été créées par un ou plusieurs produits externes. Êtes-vous sûr que les modifications que vous allez effectuer sont prises en charge par ces produits ?

  9. Cliquez sur Oui.

Remarques

  • Pour plus d'informations sur la sécurité et les performances liées aux paramètres d'identité d'une application COM+ hébergeant des planifications XLANG, voir Sécurité des applications hébergeant des instances de planification XLANG.

  • Pour accéder à l'aide de l'administration des services de composants, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

Voir aussi

Modification de l'identité de l'application XLANG Scheduler par défaut

Exécution des planifications XLANG

Exécuter les planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG


Modification des paramètres DSN d'une application COM+

Lorsque vous créez une base de données de persistance vide, vous devez créer les paramètres DSN (nom de la source des données) de l'application COM+ hébergeant les planifications XLANG qui seront associées à cette nouvelle base de données de persistance. Vous devez également initialiser les tables de la base de données.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composants, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur l'application COM+ dont vous voulez modifier les paramètres DSN.

  4. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'application COM+ sélectionnée s'affiche.

  5. Dans l'onglet XLANG, activez la case à cocher Utiliser le DSN de fichier.

  6. Cliquez sur Créer un DSN.

    La boîte de dialogue Administrateur de la source de données ODBC s'affiche.

  7. Lisez les informations affichées dans le message Base de données requise, puis cliquez sur OK.

    La page Création d'une source de données s'affiche.

  8. Sélectionnez le type de source de données à utiliser. Cliquez sur Suivant.

  9. Dans la liste Sélectionnez un pilote pour lequel vous souhaitez définir une source de données, sélectionnez SQL Server, puis cliquez sur Suivant.

  10. Assurez-vous que le nom de la source des données est le même que celui de l'application COM+ qui hébergera les planifications XLANG, puis cliquez sur Suivant et enfin sur Terminer.

    Important

    • L'application COM+ et le DSN doivent être similaires. Par exemple, si l'application COM+ porte le nom XLANG Scheduler1, le DSN doit également porter le nom XLANG Scheduler1.

    La page Création d'une source de données dans SQL Server s'affiche.

  11. Sélectionne le serveur sur lequel réside la nouvelle base de données de persistance qui sera associée à cette application COM+, puis cliquez sur Suivant.

  12. Activez la cas à cocher Avec l'authentification Windows NT par l'ID de connexion réseau, puis cliquez sur Suivant.

  13. Activez la case à cocher Changer la base de données par défaut par, puis sélectionnez la nouvelle base de persistance vide qui hébergera cette application COM+.

  14. Cliquez sur Suivant, puis sur Terminer.

  15. Sous l'onglet XLANG, cliquez sur Initialiser les tables.

    Attention

    • Cette procédure implique que vous utilisiez une nouvelle base de données de persistance vide. Ne cliquez pas sur Initialiser les tables si vous utilisez une base de données de persistance existante. Cette action détruira toutes les données déjà enregistrées dans la base de données existante.
  16. Dans le message Confirmez l'initialisation de la base de données, cliquez sur Oui.

Remarques

  • Il est possible d'utiliser le même nom pour un DSN utilisateur et un DSN système. Toutefois, si vous utilisez le même nom pour deux DSN, vous ne parviendrez pas à les distinguer sur la page des propriétés de l'application.

  • Pour accéder à l'aide de l'administration des services de composants, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composants, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

  • Pour plus d'informations sur la configuration d'un DSN et l'utilisation des sources de données (ODBC), cliquez sur Aide dans la boîte de dialogue Administrateur de la source de données ODBC.

Voir aussi

Exécution des planifications XLANG

Exécuter les planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG


Arrêt d'une application COM+ hébergeant des planifications XLANG

Utilisez cette procédure pour arrêter une application COM+ spécifique.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composants, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez sur l'application COM+ qui héberge les planifications XLANG que vous voulez arrêter.

  4. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés de l'application COM+ sélectionnée s'affiche.

  5. Dans la zone Arrêt contrôlé de l'onglet XLANG, cliquez sur Cette application XLANG.

Attention

  • Ne cliquez pas avec le bouton droit sur une application COM+, mais cliquez sur Arrêter. L'une des actions suivantes peut se produire :
    • Si les planifications XLANG en cours d'exécution sont entièrement transactionnelles, un arrêt non contrôlé déclenche tous les traitements de gestion d'erreur Compensation et En cas d'échec.

    • Si les planifications XLANG en cours d'exécution ne sont pas entièrement transactionnelles, les données traitées dans la planification sont perdues.

Important

  • Vous ne pouvez pas redémarrer des planifications mises en attente si le nom de la source de données (DSN) n'est pas disponible ou n'est pas configuré correctement. Pour plus d'informations sur la configuration d'un DSN pour une application COM+ qui héberge des planifications XLANG, voir Configuration d'une application COM+ pour héberger des planifications XLANG.

Remarques

  • Lorsque vous créez une application COM+ pour héberger des planifications XLANG, l'option Redémarrer les applications XLANG en attente n'est pas disponible. Pour plus d'informations sur le redémarrage des applications en attente, voir Redémarrage de toutes les applications XLANG.

  • Pour accéder à l'aide de l'administration des services de composants, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composants. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composants, puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composants et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

Voir aussi

Exécution des planifications XLANG

Exécuter les planifications XLANG

Arrêt de toutes les applications XLANG


Surveillance de l'exécution des planifications XLANG

Vous pouvez utiliser l'Observateur d'événements XLANG ou l'Observateur d'événements de Windows 2000 pour surveiller les planifications XLANG en cours.

  • Observateur d'événements XLANG : Lorsque le moteur de XLANG Scheduler exécute des planifications XLANG, il génère différents types d'événements en indiquant la progression des instances de planification. Vous pouvez utiliser l'Observateur d'événements XLANG pour surveiller les événements de planifications XLANG et observer la progression des instances de planification. Vous pouvez surveiller l'application XLANG Scheduler par défaut, ainsi que l'application Planification XLANG par défaut et toutes les applications COM+ personnalisées que vous avez créées pour héberger les planifications XLANG. L'Observateur d'événements XLANG peut gérer tous les événements publiés par les applications hôte sur des ordinateurs locaux ou distribués. Il peut également stocker ces événements dans un fichier en vue de les analyser ultérieurement.

    Pour plus d'informations sur l'utilisation de l'Observateur d'événements XLANG, reportez-vous au fichier Readme.htm correspondant. L'Observateur d'événements XLANG (XLANGMon.exe) et le fichier Readme installés par l'Assistant Installation de Microsoft BizTalk Server 2002 se trouvent dans le répertoire d'installation suivant : \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools.

  • Observateur d'événements de Windows 2000 : l'Observateur d'événements de Windows 2000 publie des messages d'événements liés aux planifications XLANG. Pour plus d'informations sur l'utilisation de l'Observateur d'événements en vue d'afficher des messages d'erreur, consultez les références suivantes :
    • Pour plus d'informations sur la configuration de l'Observateur d'événements pour filtrer les messages d'erreur de planification XLANG, voir Configuration de l'Observateur d'événements pour les erreurs de BizTalk Server.

    • Pour obtenir des informations d'ordre général sur l'Observateur d'événements, dans l'aide de Windows 2000 Server, reportez-vous à la section « Utilisation de l'Observateur d'événements » du chapitre Observateur d'événements.

Voir aussi

Messages d'erreur des services d'orchestration


Dépannage d'Administration de BizTalk Server

Cette section regroupe toutes les informations relatives au dépannage du composant Administration de BizTalk Server. Si vous recevez des messages d'erreur, cherchez une solution dans cette section.

Des informations complémentaires portant sur les dysfonctionnements détectés après la publication de la documentation de Microsoft® BizTalk™ Server 2002 sont fournies dans le fichier Lisezmoi qui se trouve dans le dossier Program Files\Microsoft BizTalk Server\Documentation.

Cette section traite des rubriques suivantes :

  • Erreurs de refus d'autorisation se produisant lors de l'accès à la console MMC (Microsoft Management Console) du composant Administration de BizTalk Server ou du modèle objet de configuration d'échanges BizTalk

  • Erreur d'obtention de tous les groupes d'une base de données

  • Limite de la taille des documents et des échanges

  • Écart de délai d'expiration de transactions entre les services de composants et BizTalk Server 2002

  • Le service d'échanges BizTalk ne démarre pas

  • Le service d'échanges BizTalk ne s'arrête pas lorsque la mémoire du serveur est insuffisante

  • Performances ralenties lors de la suppression d'une grande quantité de documents de la file d'attente interrompue

  • Incident de validation de sortie

  • Le serveur ne renvoie pas tous les documents dans un échange de fichier plat

  • L'identificateur de classe n'apparaît pas dans la liste Préprocesseur

  • Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue

  • BizTalk Server a arrêté le traitement des documents

  • La fonction de réception ne supprime pas le document

  • La transmission HTTP risque de dupliquer les documents

  • La fonction de réception HTTP ne fonctionne pas

  • Connexion impossible à un serveur SQL Server installé sur un serveur en cluster

  • Des fonctions de réception ont arrêté le traitement des documents

  • Erreur lors du déplacement d'un serveur distant vers une autre base de données Gestion d'échanges BizTalk

  • Erreurs d'analyse

  • Problème d'authentification lorsque IIS, le Gestionnaire d'échanges BizTalk et SQL Server sont installés sur trois ordinateurs différents

  • L'installation n'aboutit pas et le service d'échanges échoue lorsque BizTalk Server 2002 communique avec un serveur SQL Server dans un cluster

  • Des caractères sont corrompus lorsque des données DBCS sont transmises via un port d'échanges SMTP

  • Le nouvel envoi redondant ou simultané des documents risque de créer des instances dupliquées

Remarques

  • D'autres informations de dépannage figurent dans les messages d'erreur de la file d'attente interrompue. Pour plus d'informations sur la file d'attente interrompue, les messages d'erreur et les actions possibles, voir File d'attente interrompue.

  • Des informations détaillées sont disponibles dans le journal des événements, telles que des messages d'erreur et d'avertissement. Pour plus d'informations sur le journal des événements, voir Gestion de l'Observateur d'événements.


Des erreurs de refus d'autorisation se produisent lors de l'accès à la console MMC (Microsoft Management Console) du composant Administration de BizTalk Server, du Gestionnaire d'échanges BizTalk ou du modèle objet de configuration d'échanges BizTalk.

BizTalk Server 2002 ~ Administration

Erreurs de refus d'autorisation se produisant lors de l'accès à la console MMC (Microsoft Management Console) du composant Administration de BizTalk Server ou du modèle objet de configuration d'échanges BizTalk

Cause : Le programme d'installation de BizTalk Server 2002 ajoute le groupe local BUILTIN\Administrators au groupe Administrateurs de BizTalk Server. Cependant, un utilisateur qui appartient au groupe Administrateurs mais qui n'appartient pas explicitement au groupe Administrateurs de BizTalk Server va rencontrer des erreurs de refus d'autorisations au moment de l'accès à la console MMC du composant Administration de BizTalk Server, au Gestionnaire d'échanges BizTalk ou au modèle objet de configuration d'échanges BizTalk.

Solution : Utilisez la console Gestion de l'ordinateur pour ajouter explicitement des utilisateurs individuels au groupe Administrateurs de BizTalk Server.


Erreur d'obtention de tous les groupes d'une base de données

Première cause : La base de données Gestion d'échanges BizTalk est déconnectée. C'est le cas si vous recevez le message suivant :

Impossible d'énumérer les instances de Microsoft BizTalkServer_Group : Impossible d'établir la connexion à la base de données Gestion d'échanges BizTalk.

Solution : Déterminez pourquoi le serveur est déconnecté et tentez de rétablir la connexion dès qu'il est de nouveau en ligne. Par exemple, vous pouvez recevoir ce message si le serveur qui héberge la base de données Gestion d'échanges BizTalk est déconnecté pour des raisons de maintenance.

Deuxième cause : Le compte du service d'échanges BizTalk Server ne possède pas de droits d'accès au serveur Microsoft® SQL Server™.

Solution : Assurez-vous que le compte du service d'échanges BizTalk Server dispose des droits d'accès à SQL Server. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.


Limite de la taille des documents et des échanges

La taille maximale acceptée pour un document envoyé à BizTalk Server 2002 est de 20 Mo. La taille maximale acceptée pour un échange soumis à BizTalk Server est de 20 Mo.

Si vous prévoyez de recevoir des échanges au format XML (Extensible Markup Language) Unicode d'une taille supérieure à 20 Mo, il est préférable de désactiver les paramètres de suivi global. Si vous prévoyez de recevoir des échanges au format ANSI de fichier plat d'une taille supérieure à 7-10 Mo, il est préférable de désactiver le suivi du corps des échanges et du corps des documents, et de désactiver la journalisation des documents dans les configurations du canal. Pour plus d'informations sur la configuration des paramètres de suivi d'un groupe de serveurs, voir Configuration des propriétés de suivi d'un groupe de serveurs. Pour plus d'informations sur les propriétés de la journalisation des documents d'un canal, voir Définition des propriétés de journalisation de document.

De même, si vous prévoyez de recevoir des instances de document au format XML Unicode d'une taille supérieure à 20 Mo, il est préférable de désactiver les paramètres de journalisation dans le Gestionnaire d'échanges BizTalk. Ou, si vous prévoyez de recevoir des fichiers plats ANSI d'une taille supérieure à 7-10 Mo, il est préférable de désactiver les paramètres de journalisation de documents dans le Gestionnaire d'échanges BizTalk. Pour plus d'informations sur le stockage de copies d'instances de document spécifiques, voir Définition des propriétés de journalisation de document.

Voir aussi

Configuration des propriétés de suivi d'un groupe de serveurs

Définition des propriétés de journalisation de document


Écart de délai d'expiration de transactions entre les services de composants et BizTalk Server 2002

Il existe un écart dans le délai d'expiration des fichiers entre les services de composants et BizTalk Server 2002. Lorsqu'un fichier est envoyé et que l'envoi dépasse les 60 secondes définies pour le délai d'attente dans BizTalk Server 2002, BizTalk Server enregistre la transaction en tant que transaction envoyée, et le serveur destinataire reçoit le fichier sans erreur. Les services de composants enregistrent la transaction comme étant abandonnée. Les transactions ne peuvent pas être annulées.


Le service d'échanges BizTalk ne démarre pas

Cause : Le compte de service d'échanges BizTalk Server ne possède pas de droits d'accès à SQL Server. Le service d'échanges BizTalk ne démarre pas si BizTalk Server ne peut pas se connecter au serveur SQL Server qui stocke la base de données Gestion d'échanges BizTalk.

Solution : Vérifiez la connexion de BizTalk Server à la base de données Gestion d'échanges BizTalk. Vérifiez que Microsoft SQL Server fonctionne correctement. Vous devrez éventuellement créer un compte de service sous lequel exécuter BizTalk Server. Pour plus d'informations sur la création d'un compte de service, dans l'aide de Microsoft® Windows® 2000, dans le chapitre Services, consultez « Sélectionner un compte d'utilisateur utilisé par un service pour ouvrir une session ». Assurez-vous que le compte du service d'échanges BizTalk Server dispose des droits d'accès à SQL Server. Pour plus d'informations, voir Création d'une connexion SQL et attribution d'un accès aux bases de données.


Le service d'échanges BizTalk ne s'arrête pas lorsque la mémoire du serveur est insuffisante

Cause : Si la mémoire du serveur sur lequel BizTalk Server 2002 est installé est insuffisante, le service d'échanges BizTalk tente malgré tout de traiter les documents. Tous les documents sont placés dans la file d'attente interrompue.

Solution : Redémarrez le service d'échanges BizTalk.


Performances ralenties lors de la suppression d'une grande quantité de documents de la file d'attente interrompue

Cause : Vous pouvez constater un ralentissement des performances lorsque vous supprimez une grande quantité de documents de la file d'attente interrompue.

Solution : Si vous devez supprimer tous les documents de la file d'attente interrompue, vous devrez éventuellement utiliser PurgeBizTalkSuspendedQueue.vbs, un exemple de script Microsoft® Visual Basic® fourni à cet effet. Après l'installation de BizTalk Server 2002, vous trouverez ce script dans le dossier \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Miscellaneous.

Attention

  • N'utilisez ce script que si vous souhaitez supprimer de façon permanente tout le contenu de la file d'attente interrompue pour le groupe BizTalk Server spécifié.


Incident de validation de sortie

Première cause : Le type de données d'un champ de la spécification source ne correspond pas au type de données du champ auquel il est lié dans la spécification de destination. Cet échec est consigné dans l'Observateur d'événements.

Solution : Corrigez le type de données dans la spécification source ou de destination. Pour plus d'informations sur les spécifications source et de destination, voir Création et validation des spécifications.

Deuxième cause : Un fonctoid est lié à un champ de la spécification de destination, et la propriété du type de données du champ n'est pas une chaîne.

Solution : Dans la spécification de destination, changez le type de données en Chaîne. Envoyez le document à BizTalk Server pour qu'il soit traité. Pour plus d'informations sur les types de données, voir Définition des propriétés de déclaration.

Troisième cause : Dans la spécification de destination, un champ prend une valeur de constante qui utilise un type de données différent de celui déjà affecté au champ.

Solution : Dans la spécification de destination, changez le type de données associé au champ. Envoyez le document à BizTalk Server pour qu'il soit traité. Pour plus d'informations sur les types de données, voir Définition des propriétés de déclaration.

Quatrième cause : Des indicateurs de libération sont inclus dans les données EDIFACT. Ces caractères de libération sont inclus dans le nombre de caractères logiques lors de la validation du nombre maximal de caractères physiques pour un champ. Cet échec est consigné dans l'Observateur d'événements.

Solution : N'utilisez pas d'indicateurs de libération dans les données EDIFACT. BizTalk Server insère automatiquement des indicateurs dans les données sortantes lorsque cela s'impose.

Voir aussi

Création et validation de spécifications

Définition des propriétés de déclaration


Le serveur ne renvoie pas tous les documents dans un échange de fichier plat

Cause : L'un des documents de l'échange ne respecte pas la spécification de document. Par exemple, un champ obligatoire est absent dans l'un des documents.

Solution : Localisez le document ne répondant pas à la spécification, corrigez-le, puis soumettez à nouveau l'échange. Bien qu'une erreur soit renvoyée pour le document ne répondant pas à la spécification, BizTalk Server ne peut pas traiter tous les documents dans l'échange. La structure de fichier plat est un format ouvert non conçu pour mettre en œuvre un contrôle redondant.


L'identificateur de classe n'apparaît pas dans la liste Préprocesseur

BizTalk Server 2002 ~ Administration

Identificateur de classe apparaissant dans la liste Préprocesseur

Cause : Le préprocesseur personnalisé n'est pas enregistré correctement.

Solution : Réenregistrez le préprocesseur personnalisé ou choisissez un autre préprocesseur dans la liste.

Voir aussi

Configuration d'une fonction de réception de fichier : onglet Services

Préprocesseurs personnalisés

Preprocessing Documents in a Receive Function


Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue

Première cause : BizTalk Server 2002 n'a pas pu analyser l'échange ou le document.

Solution : Supprimez le document de la file d'attente interrompue. Vérifiez que l'échange ou le document entrant est dans un format que BizTalk Server peut traiter (XML (Extensible Markup Language), X12, EDIFACT ou fichier plat). Renvoyez-le à BizTalk Server à partir de l'organisation ou de l'application d'origine.

Si BizTalk Server ne peut pas analyser un document, celui-ci apparaît sous forme de données binaires dans la file d'attente interrompue parce que BizTalk Server ne dispose pas d'assez d'informations pour lire et traiter le document correctement. Pour plus d'informations sur les erreurs d'analyse, voir Erreurs d'analyse.

Deuxième cause : BizTalk Server a pu analyser l'échange ou le document, mais le contenu des données n'était pas valide. L'horodateur « expiresAt » a expiré et le document n'est plus valide. Cet incident se produit dans les documents BizTalk Framework qui utilisent le champ « expiredAt ».

Solution : Supprimez le document de la file d'attente interrompue. Ce document n'est plus valide. Déterminez pourquoi.

Troisième cause : BizTalk Server n'a pas pu analyser le document parce que le schéma du document est incorrect. Si vous recevez un fichier plat et si la page de code de la spécification de document est définie sur UTF-8, BizTalk Server ne peut pas analyser le document car UTF-8 n'est pas pris en charge.

Solution : Si vous recevez un fichier plat, vérifiez la spécification de document. Si la page de code de la spécification de document est définie sur UTF-8, BizTalk Server ne peut pas traiter le document. Supprimez le document de la file d'attente interrompue. Pour plus d'informations, voir Définition des propriétés de référence.

Voir aussi

Erreurs d'analyse

Définition des propriétés de référence

File d'attente interrompue


BizTalk Server a arrêté le traitement des documents

Première cause : BizTalk Server 2002 ne peut pas continuer le traitement des documents si la connexion à l'une des trois bases de données (base de données Gestion d'échanges BizTalk, base de données de suivi ou base de données de files d'attente partagée) est rompue ou si ces bases de données s'avèrent inaccessibles. Cet incident peut se produire si Microsoft SQL Server est arrêté ou interrompu dans Enterprise Manager. Si Microsoft BizTalk Server 2002 rencontre cette erreur, le service d'échanges BizTalk s'arrête normalement pour conserver correctement l'état de traitement et assurer l'intégrité du système au moment de l'incident. Une erreur est consignée dans l'Observateur d'événements avec une description complète de l'erreur provoquant l'arrêt du service.

Solution : Les administrateurs système peuvent utiliser cette erreur pour envoyer une notification indiquant que BizTalk Server est déconnecté, au moyen d'une notification papier ou d'une communication d'état par courrier électronique. Lors d'une telle notification, l'administrateur doit redémarrer manuellement le service d'échanges BizTalk par le biais du composant logiciel enfichable MMC, puis revérifier le journal des événements pour déterminer si l'erreur persiste. Si c'est le cas, l'administrateur doit vérifier que BizTalk Server peut accéder aux services SQL Server. Pour plus d'informations sur le démarrage du service d'échanges BizTalk, voir Démarrage d'un service BizTalk.

Deuxième cause : Si le serveur sur lequel BizTalk Server 2002 est installé contient des logiciels anti-virus, la valeur par défaut d’un port de messagerie peut être incorrect.

Solution : La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez un type de transport de fichier configuré par défaut dans un port d’échanges, si vous utilisez un anti-virus sur le serveur sur lequel est installé BizTalk Server 2002 et si vous envoyez simultanément plusieurs fichiers portant le même nom vers le même emplacement, BizTalk Server 2002 cessera de répondre et devra être redémarré. Pour éliminer ce problème, vous pouvez modifier le paramétrage par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Vous pouvez également éliminer ce problème en créant un fichier unique pour chaque instance de document traitée à l’aide du format de chemin d’accès suivant dans le port d’échanges : fichier://C:\dir\fichier%id_suivi%.xml. Pour plus d'informations, voir Spécification d'une adresse de transport. Si vous devez redémarrer le serveur, voir Démarrage d'un serveur dans un groupe.

Voir aussi

Spécification d'une adresse de transport

Démarrage du service d'échanges BizTalk

Démarrage d'un serveur dans un groupe


La fonction de réception ne supprime pas le document

Cause : L'intervalle de nouvel essai doit être défini sous la capacité de traitement pour le nombre de documents générés.

Solution : Doublez l'intervalle de nouvel essai et renvoyez les documents à BizTalk Server. Pour plus d'informations sur la configuration de l'intervalle de nouvel essai, voir Définition des propriétés de configuration avancées.


La transmission HTTP risque de dupliquer les documents

Cause : Lorsque BizTalk Server utilise un service de transport HTTP pour envoyer des messages, il reçoit, dans certains cas, des notifications d'échec même si la transmission a abouti. Ceci se présente par exemple dans le cas du dépassement du délai d'attente d'une transmission. Lorsque le délai d'attente est dépassé, la connexion avec le serveur HTTP est interrompue et un échec de transmission est signalé, même si le serveur HTTP est parvenu à traiter la requête. À l'annonce de cet échec, BizTalk Server renouvelle la transmission car la première est considérée avoir échoué, et c'est pourquoi le document risque d'être dupliqué.

Solution : Pour vous assurer que les transmissions via des protocoles non-transactionnels tels que HTTP ne sont effectuées qu'une seule fois, utilisez des échanges de type Reliable. Pour plus d'informations, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.


La fonction de réception HTTP ne fonctionne pas

Première cause : Le fichier BizTalkHTTPReceive.dll n'a pas été déployé préalablement à la création de la fonction de réception HTTP.

Solution : Déployez le fichier BizTalkHTTPReceive.dll avant de créer la fonction de réception HTTP. Pour plus d'informations sur l'ajout d'une fonction de réception HTTP, voir Ajout d'une fonction de réception HTTP.

Deuxième cause : Si le niveau d'isolation du répertoire virtuel IIS (Internet Information Services) contenant BizTalkHTTPReceive.dll a la valeur Faible, cela signifie que IIS n'a peut-être pas été configuré correctement pour pouvoir fonctionner sous l'identité d'un utilisateur disposant des informations d'autorisation sécurisées appropriées pour BizTalk Server.

Solution : Configurez IIS de façon à ce qu'il puisse fonctionner sous l'identité d'un utilisateur autorisé à accéder à la fois aux bases de données BizTalk Server SQL et aux applications BizTalk COM+ (application Échange BizTalk Server et utilitaires internes BizTalk), puis arrêtez et redémarrez le service IIS.

Troisième cause : Le client n'utilise pas le format correct d'URL et/ou n'effectue pas le codage du contenu du répertoire virtuel dans lequel le protocole HTTP envoie les données à destination de la fonction de réception HTTP.

Solution : Pour que la fonction de réception HTTP fonctionne correctement, lorsque le client spécifie l'URL vers laquelle les données doivent être transmises via HTTP à destination de la fonction de réception HTTP, la chaîne de requête doit nécessairement être codée au format MBCS (Multibyte Character String) au moyen de la page de code UTF-8. Pour plus d'informations, rendez-vous sur le site Web MSDN Online Library (en anglais) msdn.microsoft.com/library/, puis effectuez une recherche sur « Support for Multibyte Character Sets » et « Encoding.UTF8 Property ».


Connexion impossible à un serveur SQL Server installé sur un serveur en cluster

Première cause : Lorsque Microsoft SQL Server est installé sur un cluster, SQL Server peut uniquement prendre en charge les clients connectés au moyen du protocole TCP/IP.

Solution : Installez les outils clients SQL Server et attribuez TCP/IP à la bibliothèque de réseau par défaut. Pour plus d'informations sur l'installation d'outils clients SQL Server, voir Installation des outils clients SQL Server. Pour plus d'informations sur la modification de la bibliothèque de réseau par défaut, voir Attribution de TCP/IP à la bibliothèque de réseau par défaut.

Deuxième cause : Le compte BizTalk Server ne possède pas de droits d'accès au serveur SQL.

Solution : Assurez-vous que le compte du service d'échanges BizTalk Server dispose des droits d'accès à SQL Server. Pour plus d'informations, voir Instructions relatives à la sécurité.

Problème lié à l'utilisation des langues

Troisième cause : Si vous tentez d'installer BizTalk Server sur un ordinateur non équipé de Microsoft SQL Server et de configurer une base de données BizTalk Server sur un ordinateur SQL Server distant exécutant une langue qui n'est pas celle de la version par défaut de SQL Server, une erreur risque de se produire. Le message d'erreur suivant risque d'apparaître lors de l'exécution de l'Assistant Configuration des bases de données BizTalk Server 2002 :

Impossible d'ouvrir la base de données <Nom de la base de données>. Échec de la connexion.

Solution : Pour éviter ce problème, créez un exemple de nom de source de données (DSN) utilisateur avant d'installer BizTalk Server.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Sources de données (ODBC).

    La boîte de dialogue Administrateur de la source de données ODBC s'affiche.

  2. Cliquez sur l'onglet DSN utilisateur, puis sur Ajouter.

    La boîte de dialogue Création d'une source de données s'affiche.

  3. Dans la liste Nom, cliquez sur SQL Server puis sur Terminer.

    L'Assistant Création d'une source de données dans SQL Server s'ouvre.

  4. Complétez les zones requises dans l'Assistant Création d'une source de données dans SQL Server pour créer un exemple de DSN utilisateur.

Voir aussi

Attribution de TCP/IP à la bibliothèque de réseau par défaut

Installation des outils clients SQL Server


Des fonctions de réception ont arrêté le traitement des documents

Première cause : Un serveur distant unique ne peut pas prendre en charge plus de 50 fonctions de réception à la fois.

Solution : Pour plus d'informations sur la prise en charge de plusieurs fonctions de réception, visitez le site Web du support technique Microsoft search.support.microsoft.com/kb/c.asp, et recherchez l'article suivant dans la Librairie d'informations techniques :

  • « IIS Runs Out of Work Items and Causes RPC Failures When Connecting to a Remote UNC Path » (article Q221790)

Pour plus d'informations, consultez les articles suivants de la Librairie d'informations techniques :

  • « Local System Account and Null Sessions in Windows NT » (article Q132679).

  • « Service Running As System Account Fails Accessing Network » (article Q124184).

  • « PRB: Access Denied When Opening a Named Pipe from a Service » (article Q126645).

  • « FindFirstChangeNotification May Not Notify All Processes on File Changes » (article Q188321).

Deuxième cause : Si vous utilisez les fonctions de réception de fichier et que d'autres processus utilisent les fichiers en même temps que BizTalk Server, une ou plusieurs fonctions de réception de fichier risquent d'interrompre le traitement des documents et de ne plus être disponibles. Cette situation se produit lorsque BizTalk Server traite correctement un fichier mais ne peut le supprimer car une autre application tente d'y accéder simultanément. La fonction de réception de fichier est alors désactivée pour éviter que les données ne sont pas traitées une seconde fois, au cas où les autres applications cesseraient d’utiliser le fichier.

Solution : Pour éviter ce problème, vérifiez que tous les fichiers placés dans les dossiers supervisés par les fonctions de réception de fichier ne sont pas utilisés activement par d'autres applications. Cela peut concerner certains logiciels de protection anti-virus qui contrôlent les fichiers entrants.

Troisième cause : Si la fonction de réception Message Queuing reçoit un document qui a été transmis par soumission directe, la fonction de réception s'interrompt et le message d'erreur suivant s'affiche :

Modifiez cette fonction de réception pour lui faire accepter les soumissions directes ou supprimez le document direct de la file d'attente.

Solution : La fonction de réception Message Queuing n'est pas configurée pour accepter les soumissions directes. Écrivez une application qui recherche la propriété AppSpecific dans la file d'attente des messages afin d'identifier les documents qui ont été transmis par soumission directe. Supprimez le document et redémarrez la fonction de réception.


Erreur lors du déplacement d'un serveur distant vers une autre base de données Gestion d'échanges BizTalk

Cause : Si vous tentez d'ajouter un serveur distant à une base de données Gestion d'échanges BizTalk, et si ce serveur se trouvait dans une autre base de données Gestion d'échanges BizTalk centrale, le message d'erreur suivant apparaît dans le journal d'événements de Windows :

Impossible de créer une nouvelle instance de la classe WMI « MicrosoftBizTalkServer_Server » dans le fournisseur BizTalk Server WMI. Il est possible que le serveur <nom du serveur> appartienne déjà à une autre installation BizTalk Server.

Cette erreur signifie qu'une tentative a été effectuée pour ajouter un serveur distant qui se trouvait initialement dans une autre base de données centrale. Si cette procédure a été effectuée dans Administration de BizTalk Server, la console d'administration tente de déterminer si le serveur distant appartient à un groupe dans la base de données centrale distante. Pour cela, elle interroge le fournisseur WMI (Windows Management Instrumentation) du serveur distant. Si le serveur n'appartient pas à un groupe dans l'autre base de données centrale, un message d'erreur de la console d'administration apparaît et indique que vous ne pouvez pas ajouter un serveur distant qui appartient déjà à un groupe dans une autre base de données centrale.

Solution : Supprimez tout d'abord le serveur de la base de données précédente, puis ajoutez-le dans la base de données courante.

Voir aussi

À propos de Windows Management Instrumentation


Erreurs d'analyse

Première cause : Si vous envoyez des messages de type Reliable, les valeurs par d'un port peuvent être incorrectes. La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez un type de transport de fichier configuré par défaut, un format d'enveloppe Reliable dans un port d'échanges, puis envoyez simultanément plusieurs fichiers vers le même emplacement, vous obtiendrez des résultats d'analyse inattendus.

Solution : Vous pouvez éliminer ce problème en modifiant la configuration par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Pour plus d'informations sur la modification des valeurs par défaut d'un port, voir Remplacement des valeurs par défaut d'un port d'échanges.

Autres causes : Plusieurs raisons peuvent empêcher BizTalk Server d'analyser un document. Les raisons les plus fréquentes sont les suivantes :

  • L'échange ou le document est dans un format que BizTalk Server ne peut pas interpréter.

  • Le schéma du document est incorrect.

  • Un échange de fichier plat possède un schéma erroné ou non valide.

  • Un échange de fichier plat contient des caractères incorrects.

  • Il manque des caractères dans un échange de fichier plat.

  • Il manque des séparateurs dans un échange de fichier plat.

  • Un document BizTalk Framework 2.0 comporte un alias non valide indiqué dans le port ou le canal.

  • Le nœud conteneur du document est manquant dans un en-tête XML personnalisé.

  • Un attribut est manquant dans un document XML personnalisé.

  • Une spécification de document EDI ne correspond pas à l'enveloppe.

Solution : Affichez les données de l'échange ou du document pour déterminer pourquoi BizTalk Server n'a pas pu analyser l'échange ou le document. Pour afficher les données de l'échange ou du document, vous pouvez :

  • Afficher les 512 premiers octets des données de l'échange ou du document. Pour plus d'informations sur l'affichage de données d'échange et de document, voir Affichage des échanges ou Affichage des documents.

  • Afficher les données d'échange de l'enregistrement d'échange dans le suivi de documents BizTalk. Pour plus d'informations sur l'affichage d'échanges dans le suivi de documents BizTalk, voir Recherche par date des informations relatives aux documents et aux échanges, Recherche par organisation des informations relatives aux documents et aux échanges, Recherche par type de documents des informations relatives aux documents et aux échanges ou Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête.

  • Utiliser la couche WMI (Windows Management Instrumentation) pour afficher les données d'échange. Pour plus d'informations sur la programmation d'applications WMI, visitez le site Web MSDN Online Library (en anglais) msdn.microsoft.com/library/, et recherchez « WMI Application Programming ».

Une fois que vous avez déterminé pourquoi BizTalk Server n'a pas pu analyser le document, corrigez le problème et soumettez à nouveau l'échange ou le document à l'aide de IInterchange ou d'une fonction de réception.

Voir aussi

Un échange ou un document apparaît sous forme de données binaires dans la file d'attente interrompue

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges

Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

File d'attente interrompue

Affichage des documents

Affichage des échanges


Problème d'authentification lorsque IIS, le Gestionnaire d'échanges BizTalk et SQL Server sont installés sur trois ordinateurs différents

Cause : Si vous installez le Gestionnaire d'échanges BizTalk, Internet Information Services (IIS) et Microsoft SQL Server sur trois ordinateurs différents, vous risquez de rencontrer des problèmes d'authentification. Les problèmes d'authentification sont liés au fait que la transmission s'effectue sur deux tronçons : les informations d'authentification sont transmises par le Gestionnaire d'échanges BizTalk depuis un ordinateur client distant A vers un ordinateur B BizTalk Server équipé de IIS (premier tronçon), mais IIS ne parvient pas à transmettre ces informations à la base de données de configuration SQL Server sur l'ordinateur C (second tronçon).

Solution : Installez le Gestionnaire d'échanges BizTalk (le client distant), IIS et SQL Server sur deux ordinateurs et non pas sur trois. Les configurations suivantes sont acceptées :

  • Le Gestionnaire d'échanges BizTalk et IIS sont installés sur le même ordinateur et SQL Server est installé sur un second ordinateur.

  • Le Gestionnaire d'échanges BizTalk est installé sur un premier ordinateur (l'ordinateur distant), tandis que IIS et SQL Server sont installés sur un second ordinateur.

Pour plus d'informations sur l'authentification IIS, visitez le site Web du support technique Microsoft search.support.microsoft.com/kb/c.asp, et recherchez l'article suivant (en anglais) dans la Librairie d'informations techniques : « INFO: How IIS Authenticates Browser Clients » (article Q264921).

Attention

  • BizTalk Server doit être installé sur l'ordinateur sur lequel est également installé IIS.

Remarque

  • Ce problème, dû à la transmission des informations d'authentification sur deux tronçons, se produit également lorsque le Gestionnaire d'échanges BizTalk et la base de données de configuration SQL Server sont installés sur le même ordinateur et que BizTalk Server et IIS sont installés sur un second ordinateur. Cette configuration n'est pas acceptée.


L'installation n'aboutit pas et le service d'échanges échoue lorsque BizTalk Server 2002 communique avec un serveur SQL Server dans un cluster

Lorsque BizTalk Server 2002 est installé sur un ordinateur autonome avec les bases de données SQL Server s'exécutant dans un cluster MSCS (Microsoft Cluster Service) le programme d'installation échoue pendant l'installation de la base de données Gestion d'échanges BizTalk et le message d'erreur suivant s'affiche :

BizTalk Server n'est pas parvenu à établir la connexion à la base de données <nom de la base de données Gestion d'échanges BizTalk> sur le serveur <serveur SQL> avec les informations de connexion de la base de données.

Ce problème survient avec le fournisseur SQLOLEDB dans MDAC 2.6. Pour le résoudre, évoluez vers MDAC 2.7 (dès sa disponibilité).


Des caractères sont corrompus lorsque des données DBCS sont transmises via un port d'échanges SMTP

Problème lié à l'utilisation des langues

Cause : Si vous installez les composants MDAC (Microsoft Data Access Components) 2.5 et que vous configurez un port d'échanges SMTP pour bénéficier du codage MIME (Multipurpose Internet Mail Extensions), les données DBCS (Double-Byte Character Set, codées sur deux octets) sont envoyées via ce port et sont endommagées. (MDAC 2.5 est livré avec toutes les versions du Service Pack de Windows 2000.)

Solution : Pour contourner ce problème, installez MDAC 2.6. Vous pouvez choisir l'une des méthodes d'installation suivantes :

  • Pour installer MDAC 2.6 directement, ouvrez votre navigateur et accédez au site Web Universal Data Access Web de Microsoft (www.microsoft.com/data) (site en anglais) pour le télécharger.

  • Installez les utilitaires client SQL Server 2000 incluant MDAC 2.6.

Aujourd’hui, aucun correctif fonctionnant à la fois sur MDAC 2.5 et sur MDAC 2.6 n’est disponible.


Le nouvel envoi redondant ou simultané des documents peut créer des instances dupliquées.

Cause : Si plusieurs utilisateurs ou instances de l'Administration BizTalk Server renvoient simultanément des lots de documents identiques, des instances dupliquées peuvent être créées dans la file d'attente de travail.

Solution : Ne procédez pas au renvoi simultané des mêmes groupes de documents provenant de plusieurs instances.


Suivi de documents

Suivi de documents BizTalk est une application Web autonome permettant de visualiser la progression des documents traités par Microsoft® BizTalk Server™ 2002. Vous pouvez créer des requêtes ou des requêtes avancées pour extraire des informations essentielles de la base de données de suivi dans un format facile à consulter. Par exemple, dans Suivi de documents BizTalk vous pouvez afficher des informations capturées sur la source et la destination du document, le nom du document ainsi que son type et les paramètres de date et d'heure correspondants. De plus, vous pouvez créer des requêtes qui affichent des champs de recherche standard et personnalisés afin de pouvoir analyser vos pratiques professionnelles. Par exemple, un champ Total de bon de commande peut être stocké pour chaque bon de commande envoyé à des fournisseurs. Vous pouvez ensuite utiliser ces données pour analyser et communiquer le volume monétaire des achats à un ou plusieurs fournisseurs sur une période donnée.

En outre, vous pouvez configurer Suivi de documents BizTalk pour afficher des enregistrements d'échange et de document individuellement ou par lots. Vous pouvez également utiliser Suivi de documents BizTalk pour afficher, visualiser et enregistrer des copies complètes des instances de document entrantes et sortantes pour y faire référence ultérieurement.

Cette section traite des rubriques suivantes :

  • Pour des informations complètes sur Suivi de documents BizTalk, voir À propos de Suivi de documents BizTalk.

  • Pour un aide-mémoire expliquant les raisons pour lesquelles vous devez effectuer des tâches spécifiques, voir Pourquoi utiliser Suivi de documents BizTalk.

  • Pour des informations détaillées sur les procédures à effectuer, voir Comment utiliser Suivi de documents BizTalk.

  • Pour obtenir des instructions sur la résolution de problèmes, voir Dépannage de Suivi de documents BizTalk.

Important

  • Suivi de documents BizTalk étant accessible sous forme d'application Web au moyen de Microsoft Internet Explorer, l'aide de Microsoft BizTalk Server 2002 s'utilise différemment et ses fonctionnalités sont légèrement restreintes. Les onglets Sommaire, Index, Rechercher et Favoris ne sont pas disponibles. Vous pouvez accéder à toutes les rubriques par le biais de liens sur la page d'ouverture, de liens Voir aussi et du bouton Précédent.

    Si vous souhaitez rechercher une rubrique spécifique, ou si vous voulez accéder à des informations sur des fonctions et des services de BizTalk Server 2002, dans le menu Démarrer, pointez sur Programmes, sur Microsoft BizTalk Server 2002, puis cliquez sur Documentation de BizTalk Server. Pour que l'aide soit disponible dans le menu Démarrer, BizTalk Server 2002 doit être installé sur votre ordinateur.

  • Comme Suivi de documents BizTalk utilise des contrôles Microsoft ActiveX®, une boîte de dialogue de téléchargement de contrôles ActiveX peut apparaître pendant les sélections ou les soumissions de requêtes. Dans ce cas, cliquez sur Oui pour continuer.

Remarque

  • Lors d'une sélection ou d'une sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé dans la zone Sites de confiance sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, voir Configuration des paramètres IIS de BizTalk Server 2002.


À propos de Suivi de documents BizTalk

Cette section présente les concepts essentiels à la compréhension du suivi des documents et des activités de supervision.

Cette section traite des rubriques suivantes :

  • Environnement de Suivi de documents BizTalk

  • Utilisation de Suivi de documents BizTalk

  • Présentation du schéma de la base de données de suivi

  • Recherche d'échanges et de documents associés

  • Présentation des résultats de requête

  • Présentation de l'état de la planification XLANG pour un échange

Remarque

  • Lors d'une sélection ou d'une sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé dans la zone Sites de confiance sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, voir Configuration des paramètres IIS de BizTalk Server 2002.


Environnement de Suivi de documents BizTalk

Cette section traite des rubriques suivantes :

  • Interface utilisateur de Suivi de documents BizTalk

  • Touches de raccourci de Suivi de documents BizTalk


Interface utilisateur de Suivi de documents BizTalk

Suivi de documents BizTalk est une application Web autonome qui sert à afficher des échanges et des documents que vous avez configurés pour être suivis dans Microsoft BizTalk Server. La page principale comporte six zones :

  • Plage de dates

  • Sélection de la source

  • Sélection de la destination

  • Requête avancée

  • Contrôle du tri

  • Sélection du type de document

Vous pouvez configurer des paramètres de requête dans les zones Plage de dates, Sélection de la source, Sélection de la destination et Sélection du type de document.

Le côté inférieur gauche de la page contient les zones Requête avancée et Contrôle du tri. Configurez des paramètres dans la zone Requête avancée pour trouver des informations spécifiques ou des champs de recherche personnalisée. Configurez des options dans la zone Contrôle du tri pour spécifier l'ordre de tri sur la page Résultats de la requête.

Lorsque vous cliquez sur le bouton Requête sur la page principale, la page Résultats de la requête apparaît. Si des enregistrements de la base de données de suivi correspondent à vos paramètres de requête, des enregistrements d'échange apparaissent dans une liste. Le tableau suivant répertorie et décrit les icônes disponibles dans la page Résultats de la requête.

Cliquez sur cette icône | Pour
Icône de données | Accéder aux données d'instance d'échange ou de document. Si vous cliquez sur l'icône de données dans l'enregistrement d'échange, les données de l'échange apparaissent. Si vous cliquez sur l'icône de données dans l'enregistrement de l'instance de document, les données du document apparaissent.
Icône d'indicateur de développement | Développer l'enregistrement d'échange pour afficher l'enregistrement d'instance de document.
Icône d'indicateur de réduction | Réduire l'enregistrement d'échange pour masquer l'enregistrement d'instance de document.
Icône de planification XLANG | Afficher l'état de planification XLANG associé à un échange.
Icône d'accusé de réception | Afficher une page Résultats de la requête pour afficher le contenu de l'accusé de réception. Pour plus d'informations sur les résultats de l'accusé de réception, voir Présentation des résultats d'accusé de réception.
Icône de recherche personnalisée | Afficher les données du champ de recherche personnalisée.


Touches de raccourci de Suivi de documents BizTalk

Vous pouvez utiliser des touches de raccourci pour effectuer certaines tâches dans Suivi de documents BizTalk. Le tableau suivant présente les touches de raccourci disponibles dans la page principale.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Server, reportez-vous à la rubrique « Utilisation du clavier pour déplacer le pointeur de la souris ». Dans l'aide de Windows 2000 Professionnel, reportez-vous à la rubrique « Pour déplacer le pointeur de la souris en utilisant les Touches souris ».
Appuyez sur | Pour
ALT+N | Ouvrir la page Générateur de requêtes avancées.
ALT+P | Ouvrir la page Requêtes avancées.
ALT+C | Effacer la requête avancée de la session de requête en cours.
ALT+S | Sélectionner toutes les organisations et applications dans la liste Sélection de la source.
ALT+O | Effacer la liste Sélection de la source.
ALT+L | Sélectionner toutes les organisations et applications dans la liste Sélection de la destination.
ALT+U | Effacer la liste Sélection de la destination.
ALT+I | Afficher tous les types de document dans la liste Sélection du type de document.
ALT+E | Sélectionner tous les types de document dans la liste Sélection du type de document.
ALT+T | Effacer la liste Sélection du type de document.
ALT+R | Ouvrir la page Résultats de la requête.
ALT+F | Fermer Suivi de documents BizTalk.
ALT+A | Afficher l'aide en ligne.
ALT+une lettre soulignée ou le numéro d'un nom de champ | Placer le focus sur ce champ. Par exemple, ALT+1 place le focus sur Ordre de tri 1.

Le tableau suivant répertorie et décrit les touches de raccourci disponibles dans la page Résultats de la requête. Pour ouvrir la page Résultats de la requête, sur la page principale, appuyez sur ALT+R.

Appuyez sur | Pour
ALT+F | Fermer la page Résultats de la requête.
ALT+A | Afficher l'aide en ligne.
BARRE ESPACE | Ouvrir ou fermer une icône. Vous devez utiliser la touche Tabulation pour placer le focus sur l'icône à ouvrir ou à fermer. Par exemple, si vous souhaitez développer un enregistrement d'échange, appuyez sur la touche TAB jusqu'à ce que le focus se trouve sur l'icône de développement (+) pour l'enregistrement d'échange sélectionné. Appuyez ensuite sur la BARRE ESPACE.

Le tableau suivant répertorie et décrit les touches de raccourci disponibles dans la page Générateur de requêtes avancées. Pour ouvrir la page Générateur de requêtes avancées, sur la page principale, appuyez sur ALT+N.

Appuyez sur | Pour
ALT+N | Ajouter une condition à l'expression de requête avancée.
ALT+E | Modifier une condition.
ALT+R | Supprimer une condition d'une expression de requête avancée.
ALT+S | Enregistrer l'expression
ALT+O | Limiter l'utilisation de l'expression à la session de requête en cours.
ALT+C | Fermer la page Générateur de requêtes avancées.
ALT+A | Afficher l'aide en ligne.
ALT+lettre soulignée d'un nom de champ | Placer le focus sur ce champ. Par exemple, ALT+V place le focus sur le champ Valeur.

Remarque

  • Si vous placez le focus sur la zone Requête et si celle-ci comporte plusieurs conditions, utilisez les touches flèches HAUT et BAS pour sélectionner la condition souhaitée.

Le tableau suivant répertorie et décrit les touches de raccourci disponibles sur la page Requêtes avancées. Pour ouvrir la page Requêtes avancées, sur la page principale, appuyez sur ALT+P.

Appuyez sur | Pour
ALT+E | Modifier une expression existante.
ALT+N | Ouvrir la page Générateur de requêtes avancées.
ALT+D | Supprimer une expression.
ALT+O | Ajouter l'expression à la requête en cours.
ALT+C | Fermer la page Requêtes avancées sans enregistrer vos modifications.
ALT+A | Afficher l'aide en ligne.


Utilisation de Suivi de documents BizTalk

Vous pouvez utiliser Suivi de documents BizTalk pour effectuer les opérations suivantes :

  • suivre des échanges et des documents associés traités par Microsoft BizTalk Server 2002 ;

  • satisfaire aux exigences juridiques ou standard imposant la conservation de copies de toutes les transactions de commerce électronique ;

  • répondre aux questions des clients rapidement et facilement ; par exemple, si un client demande « Quand avons-nous envoyé une facture à notre partenaire commercial A ? », vous pouvez localiser la date et l'heure de l'envoi et indiquer si un accusé de réception a été envoyé ;

  • aider au dépannage ;

  • aider à résoudre les conflits.

Les documents peuvent être suivis par lots ou sous forme de transactions individuelles. Suivi de documents BizTalk stocke automatiquement les métadonnées associées à un échange, telles que les informations de source et de destination, le type de document ainsi que les paramètres de date et d'heure. Les métadonnées sont stockées automatiquement ; cependant, des champs supplémentaires tels que Date de bon de commande ou Total de bon de commande, sont capturés uniquement si la configuration du modèle d'objets de configuration d'échanges BizTalk ou du Gestionnaire d'échanges BizTalk prévoit la capture de ces informations. Pour plus d'informations sur la configuration des champs sélectionnés à suivre, voir Définition des propriétés de canal et Définition du suivi pour les propriétés de document entrant.

Toutes les informations de suivi (les métadonnées ou les champs que vous avez configurés à suivre) sont stockées dans la base de données de suivi que vous avez configurée pendant l'installation ou lorsque que vous avez configuré un groupe de serveurs. Par le biais de l'interface utilisateur de Suivi de documents BizTalk, vous pouvez accéder aux données stockées dans la base de données de suivi associée à un groupe de serveurs particulier. Bien que certaines informations stockées dans la base de données de suivi ne soient pas accessibles par le biais de l'interface utilisateur, les métadonnées et les champs que vous avez configurés à suivre le sont. Par exemple, si vous devez suivre à quel moment l'application d'achat C a envoyé un bon de commande au partenaire commercial D et si ce dernier a répondu au bon de commande, vous pouvez le faire à l'aide de Suivi de documents BizTalk.

Cette section traite des rubriques suivantes :

  • Description des paramètres de suivi d'un groupe de serveurs

  • Description des paramètres de suivi du Gestionnaire d'échanges BizTalk

Remarque

  • Les accusés de réception d'échanges fiables ne s'affichent pas dans l'interface utilisateur de Suivi de documents BizTalk.

Voir aussi

Définition des propriétés de canal

Définition du suivi pour les propriétés de document entrant

Base de données de suivi


Description des paramètres de suivi d'un groupe de serveurs

Les paramètres de suivi d'un groupe de serveurs déterminent si le suivi des échanges est activé ou désactivé. Ce paramètre de suivi global est configuré dans Administration de BizTalk Server. Pour plus d'informations sur la configuration des paramètres de suivi d'un groupe de serveurs, voir Configuration des propriétés de suivi d'un groupe de serveurs. Si l'option Activer le suivi de documents est activée, vous pouvez configurer BizTalk Server pour consigner les échanges entrants, les échanges sortants ou les messages d'origine codés au format MIME.

Lorsque vous installez Microsoft BizTalk Server 2002, le suivi de documents est automatiquement activé, les options Consigner l'échange entrant dans un journal et Consigner l'échange sortant dans un journal sont activées ; de plus, les métadonnées pour les échanges sont suivies, comme par exemple :

  • les informations sur l'organisation source ;

  • les informations sur l'organisation de destination ;

  • le type de document ;

  • la date et l'heure de traitement de l'échange par BizTalk Server ;

  • le nombre de documents ;

  • les informations d'erreur ;

  • l'identificateur de contrôle.

Outre le suivi des échanges, vous pouvez également configurer BizTalk Server pour suivre des champs spécifiques, tels que Total de bon de commande ou Total de facture. Pour plus d'informations sur le suivi de champs spécifiques, voir Description des paramètres de suivi du Gestionnaire d'échanges BizTalk. Si vous devez conserver une copie des échanges dans leur format d'origine pour des problèmes de non-répudiation et des aspects juridiques commerciaux, utilisez les paramètres de suivi globaux. Si vous souhaitez créer une trace d'audit à des fins internes ou accéder facilement à des données par document, configurez les paramètres de suivi dans le modèle d'objets de configuration d'échanges BizTalk ou dans le Gestionnaire d'échanges BizTalk ; il se peut toutefois que cette opération génère un accroissement rapide de la base de données de suivi et le stockage des données dupliquées.

Désactivation des paramètres de Suivi de documents BizTalk

Si vous n'avez pas besoin de suivre des documents, vous pouvez désactiver Suivi de documents BizTalk. Cependant, vous perdrez ainsi une importante fonctionnalité. Par exemple, si le suivi de documents est désactivé, vous ne pouvez pas :

  • suivre les échanges et les documents associés lors de leur traitement dans BizTalk Server 2002 ;

  • satisfaire aux exigences juridiques ou standard imposant la conservation de copies de toutes les transactions de commerce électronique ;

  • répondre aux questions des clients rapidement et facilement ; par exemple, si un client demande « Quand avons-nous envoyé une facture à notre partenaire commercial A ? », vous ne pouvez pas localiser la date et l'heure de l'envoi, et indiquer si un accusé de réception a été envoyé ;

  • aider au dépannage ;

  • aider à résoudre les conflits.

Pour activer ou désactiver le suivi de documents, ou encore pour modifier les paramètres de suivi globaux, utilisez Administration de BizTalk Server. Pour plus d'informations sur la configuration des paramètres de suivi d'un groupe de serveurs, voir Configuration des propriétés de suivi d'un groupe de serveurs.

Remarques

  • Pour ouvrir Administration de BizTalk Server, dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Administration de BizTalk Server.

  • Une limite est imposée quant à la taille des échanges et des documents. Pour plus d'informations sur les limites de taille, voir Limite de la taille des documents et des échanges.

Voir aussi

Configuration des propriétés de suivi d'un groupe de serveurs

Limite de la taille des documents et des échanges

Ouverture de Administration de BizTalk Server

Description des paramètres de suivi du Gestionnaire d'échanges BizTalk


Description des paramètres de suivi du Gestionnaire d'échanges BizTalk

Configurez les paramètres de suivi dans le Gestionnaire d'échanges BizTalk si vous devez :

  • stocker des copies complètes des instances de documents entrantes et sortantes ;

  • configurer des champs spécifiques, tels que Total de bon de commande ou Date de bon de commande, à capturer.

Contrairement aux propriétés de suivi d'un groupe de serveurs, le suivi de champs spécifiques ou le stockage de copies d'instances de document n'est pas automatiquement activé. Vous devez configurer ces options lorsque vous définissez les canaux appropriés ou les définitions de document dans le Gestionnaire d'échanges BizTalk.

Pour plus d'informations sur le stockage d'instances de document entrantes ou sortantes, voir Définition des propriétés de journalisation de document. Pour plus d'informations sur le suivi de champs spécifiques, voir Sélection des champs de spécification dans un canal.

Remarques

  • Pour ouvrir le Gestionnaire d'échanges BizTalk, dans le menu Démarrer, pointez sur Programmes, choisissez Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  • Une limite est imposée pour le suivi et le stockage de documents. Pour plus d'informations sur les limites de taille, voir Limite de la taille des documents et des échanges.

  • Lors du suivi des champs de spécifications en tant que type de données Integer, Real, Date ou Text, les noms des champs de spécification dépassant 79 caractères sont tronqués.

    Suivez ces champs de spécification en tant que type de données Custom. En procédant ainsi, les noms de champ sont regroupés avec leurs valeurs de champ dans une colonne SQL ntext, dont la longueur maximale autorisée est de 2^30 - 1 (1 073 741823) caractères.

  • Si vous ne parvenez pas à trouver le détail et l'état de l'accusé de réception d'un document dans la console Administration de BizTalk Server, il est possible que la case à cocher Activer le Suivi de documents ne soit pas activée. Dans ce cas, les accusés de réception ne peuvent pas être mis en corrélation.

    Pour activer l'enregistrement des documents, procédez comme suit :

    1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Administration de BizTalk Server.

    2. Dans l'Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, cliquez avec le bouton droit sur le groupe BizTalk Server pour lequel vous souhaitez modifier les paramètres de suivi des documents, puis cliquez sur Propriétés.

    3. Dans l'onglet Suivi, activez la case à cocher Activer le Suivi de documents.

    Sélectionnez les autres options à votre convenance.

Question d'ordre international

  • En fonction de la langue du système, BizTalk Server peut mal interpréter une valeur numérique dans les données XML lorsque celle-ci est enregistrée comme champ de suivi d'entier dans la base de données de suivi. Par exemple, dans une version allemande, la valeur numérique de XML 4.0 est enregistrée en tant que 40 dans la base de données de suivi car le point décimal (.) est interprété à tort comme symbole de regroupement numérique.

    Il existe deux manières de contourner ce problème. Premièrement, si vous savez déjà que la valeur de l'élément ou de l'attribut contient un nombre décimal, vous pouvez modifier le type de données de l'élément ou de l'attribut XML en Real (r4) ou Double Real (r8). Deuxièmement, vous pouvez configurer la définition de document ou le canal en vue de l'enregistrement d'un élément ou d'un attribut avec un type de données Number égal à Real au lieu de Integer.

Voir aussi

Limite de la taille des documents et des échanges

Sélection des champs de spécification dans un canal

Définition des propriétés de journalisation de document

Description des paramètres de suivi d'un groupe de serveurs


Présentation du schéma de la base de données de suivi

Tous les serveurs d'un groupe de serveurs partagent une seule base de données de suivi qui stocke toutes les informations liées à l'activité des échanges et des documents dans Microsoft BizTalk Server 2002. Cette base de données permet de suivre l'état d'un échange ou d'un document au cours de son déplacement parmi les serveurs. Les trois principales tables de la base de données de suivi sont les suivantes :

  • dta_interchange_details

  • dta_outdoc_details

  • dta_indoc_details

Les tables de support sont les suivantes :

  • dta_group_details

  • dta_interchange_data

  • dta_document_data

  • dta_debug_data

  • dta_routing_details

  • dta_custom_field_names

  • dta_MIME_data

L'illustration suivante montre le schéma global de la base de données de suivi. Par souci de clarté, seuls les noms de table sont indiqués dans l'illustration suivante. Les lignes qui relient les tables indiquent comment les tables sont connectées par le biais de champs de clé étrangère. Ces champs de clé et leurs relations aux autres tables seront décrits de façon détaillée dans les rubriques Structure des tables de métadonnées principales et Structure des tables secondaires.

Schéma de la base de données de suivi

Cette section traite des rubriques suivantes :

  • Tables de métadonnées principales

  • Tables secondaires

  • Structure des tables de métadonnées principales

  • Structure des tables secondaires

  • Tables connexes

  • Consignation des échanges et des documents

  • Consignation des accusés de réception

  • Consignation des informations de routage

  • Suivi des événements de planification XLANG dans la base de données de suivi


Table de métadonnées principales

BizTalk Server 2002 ~ Suivi de documents

Tables de métadonnées principales

Les tables principales stockent les métadonnées des échanges traités par BizTalk Server. Les métadonnées contiennent des informations sur l'organisation source et l'organisation de destination, le type de document, la date et l'heure de traitement de l'échange, le nombre de documents, des informations d'erreur et une identification de contrôle.

Les trois tables suivantes forment les métadonnées principales de la base de données de suivi :

  • dta_indoc_details

  • dta_outdoc_details

  • dta_interchange_details

Le tableau suivant décrit la fonction de chaque table principale.

Nom de la table | Description
dta_indoc_details | Contient un enregistrement pour chaque document soumis à BizTalk Server.
dta_outdoc_details | Contient un enregistrement pour chaque document généré par BizTalk Server. Un document soumis à BizTalk Server peut entraîner la génération et la livraison d'un ou plusieurs documents à un ensemble de destinations respectives, du fait d'une correspondance de plusieurs canaux et de groupes de port. La séparation des documents en entrée et en sortie en deux tables permet une représentation physique de cette relation un à plusieurs.
dta_interchange_details | Contient un enregistrement pour chaque échange traité par BizTalk Server. Un indicateur de direction sur cette table permet la différenciation entre soumissions et transmissions.

Voir aussi

Structure des tables de métadonnées principales


Tables secondaires

Les sept tables secondaires prenant en charge les tables de métadonnées principales sont les suivantes :

  • dta_document_data

  • dta_debugdoc_data

  • dta_interchange_data

  • dta_routing_details

  • dta_group_details

  • dta_custom_field_names

  • dta_MIME_data

Ces tables stockent des informations de support, telles que des données de document, des informations de routage et des informations de recherche personnalisée. Le tableau suivant décrit la fonction de chaque table.

Nom de la table | Description
dta_document_data | Contient un enregistrement pour chaque document soumis à BizTalk Server ou envoyé par BizTalk Server.
dta_debugdoc_data | Contient une ligne pour chaque élément inDoc ou outDoc configuré (sur l'objet de canal d'échange) pour enregistrer son format XML temporaire.
dta_interchange_data | Contient une ligne pour chaque échange soumis à BizTalk Server ou envoyé par BizTalk Server. Cette table stocke également les documents de réponse renvoyés à l'application appelante IInterchange::SubmitSync.
dta_routing_details | Agit comme miroir des ports d'échanges dans le but d'éliminer toute dépendance de bases de données croisées sur la base de données Gestion d'échanges BizTalk. Spécifiquement, il est nécessaire de suivre les informations source et de destination relatives aux documents traités. Ces informations, qui proviennent de la base de données Gestion d'échanges BizTalk, sont répétées ici lorsque de nouvelles permutations sont rencontrées.
dta_group_details | Fournit des composants d'extensibilité (analyseur, sérialiseur et corrélateur de réception) pour des formats de document qui emploient des groupes de documents similaires (par exemple, X12 ou EDIFACT) dans un échange. Cette table contient une ligne pour chaque groupe analysé ou sérialisé par ces composants.
dta_custom_field_names | Contient une ligne pour chaque paire de nom de nœud de champ de capture et de type de données rencontrée par BizTalk Server. Cette table est une référence croisée pour la table dta_outdoc_details, qui utilise une clé étrangère dans cette table pour ses noms de champ de capture. La table dta_indoc_details est connectée à cet ensemble de noms de champ indirectement par l'existence d'une clé étrangère pointée de la table dta_outdoc_details à son parent dans la table dta_indoc_details.
dta_MIME_data | Contient une ligne pour chaque échange codé au format MIME soumis à BizTalk Server. Cette table permet de suivre des données MIME contenant des pièces jointes.

Voir aussi

Structure des tables secondaires


Structure des tables de métadonnées principales

Les tables de métadonnées principales sont reliées de la façon décrite dans cette section et stockent les métadonnées de tous les échanges traités par BizTalk Server, si les paramètres de suivi sont configurés. Pour plus d'informations sur la configuration des paramètres de suivi d'un groupe de serveurs, voir Description des paramètres de suivi d'un groupe de serveurs.

dta_indoc_details

Cette table a une relation un à plusieurs avec la table suivante :

  • dta_outdoc_details

Cette table a une relation plusieurs à un avec les tables suivantes :

  • dta_group_details

  • dta_interchange_details

  • dta_error_message

  • dta_validity_values

Cette table a une relation un à un avec les tables suivantes :

  • dta_debugdoc_data

  • dta_document_data

La table dta_indoc_details contient une ligne par document soumis à BizTalk Server. Le tableau suivant décrit les champs de la table dta_indoc_details.

Nom du champ | Description
nInDocKey | Identificateur d'enregistrement à clé primaire unique.
nDocumentDataKey | Clé étrangère vers la table dta_document_data.
nDebugDocDataKey | Clé étrangère vers la table dta_debugdoc_data pour le format XML du document reçu, même si le document reçu est XML.
nGroupKey | Clé étrangère vers la table dta_group_details.
nInterchangeKey | Clé étrangère vers la table dta_interchange_details.
uidTrackingGUID | Valeur de clé de suivi principale basée sur un identificateur global unique (GUID).
dtProcessedTimeStamp | Heure de création de l'enregistrement.
nvcSyntax | Code de la syntaxe du document (XML, X12, EDIFACT, HL7, etc.). Dans le cas d'une syntaxe non reconnue en raison d'un incident d'analyse ou d'une soumission directe, ce champ prend la valeur « UNKNOWN ».
nvcVersion | Version de la syntaxe.
nvcRelease | Diffusion de la version.
nvcDocType | Type de document ou identificateur du jeu de transactions.
nvcControlID | Numéro de contrôle unique pour des documents et groupes fonctionnels EDI (electronic data interchange).
nlsValid | Code qui indique des résultats de validation. Valeurs possibles sont 0 (non valide), 1 (valide) ou 2 (transfert).
nError | Code qui indique l'occurrence d'une erreur. Il s'agit de la clé étrangère vers dta_error_message, la table qui contient les descriptions des messages d'erreur.

dta_outdoc_details

Cette table a une relation plusieurs à un avec les tables suivantes :

  • dta_indoc_details

  • dta_interchange_details

  • dta_group_details

  • dta_debugDoc_data

  • dta_routing_details

  • dta_error_message

  • dta_ack_status

  • dta_data_level_values

  • dta_validity_values

Cette table a une relation un à un avec la table suivante :

  • dta_document_data

Cette table a une relation plusieurs à plusieurs avec les tables suivantes :

  • dta_custom_field_names

  • dta_ack_status_values

La table dta_outdoc_details contient une ligne par document envoyé par BizTalk Server. Le tableau suivant décrit les champs de la table dta_outdoc_details.

Nom du champ | Description
nOutDocKey | Identificateur d'enregistrement à clé primaire unique.
nInDocKey | Clé étrangère vers l'enregistrement parent de dta_indoc_details.
nDocumentDataKey | Clé étrangère vers la table dta_document_data.
nDebugDocDataKey | Clé étrangère vers la table dta_debugdoc_data pour le format XML du document sortant, même si le document sortant est XML. Lorsqu'un document sortant est envoyé à un groupe de ports, seule une copie de l'enregistrement dta_debugdoc_data est stockée, et tous les enregistrements dta_outdoc_details résultants pointent vers elle.
nGroupKey | Clé étrangère vers la table dta_group_details.
nInterchangeKey | Clé étrangère vers la table dta_interchange_details.
uidTrackingGUID | Valeur de clé de suivi principale basée sur un identificateur global unique (GUID).
dtProcessedTimeStamp | Heure de création de l'enregistrement.
nvcSyntax | Code de la syntaxe du document (XML, X12, EDIFACT, HL7, etc.). Dans le cas d'une syntaxe non reconnue en raison d'un incident d'analyse ou d'une soumission directe, ce champ prend la valeur « UNKNOWN ».
nvcVersion | Version de la syntaxe.
nvcRelease | Diffusion de la version.
nvcDocType | Type de document ou identificateur du jeu de transactions.
nvcControlID | Numéro de contrôle unique pour des documents et des groupes fonctionnels EDI.
nlsValid | Code qui indique des résultats de validation. Valeurs possibles sont 0 (non valide), 1 (valide) ou 2 (transfert).
nError | Code qui indique l'occurrence d'une erreur. Il s'agit de la clé étrangère vers dta_error_message, la table qui contient les descriptions des messages d'erreur.
nAckStatus | Code de l'état de la réception. C'est une clé étrangère vers dta_ack_status_values, la table qui contient des descriptions d'état d'accusé de réception.
nRoutingKey | Clé étrangère vers la table dta_routing_details.
nReceiptFlag | Indicateur précisant à quelle table un accusé de réception est associé. Les valeurs possibles sont 1 (échange), 2 (groupe), 4 (indoc), 8 (outdoc). Pour plus d'informations sur les accusés de réception, voir Consignations des accusés de réception.
nReceiptKey | Numéro unique qui identifie l'accusé de réception. Pour plus d'informations sur les accusés de réception, voir Consignations des accusés de réception.
dtReceiptDueBy | Horodatage d'échéance d'accusé de réception, calculé pour correspondre à l'horodatage de traitement.
nRealName1 | Clé étrangère vers la table dta_custom_field_names.
rlRealValue1 | Champ de capture réelle 1. Ce champ doit prendre une valeur réelle à 8 octets.
nRealName2 | Clé étrangère vers la table dta_custom_field_names.
rlRealValue2 | Champ de capture réelle 2. Ce champ doit prendre une valeur réelle à 8 octets.
nIntName1 | Clé étrangère vers la table dta_custom_field_names.
nIntValue1 | Champ de capture de nombre entier 1.
nIntName2 | Clé étrangère vers la table dta_custom_field_names.
nIntValue2 | Champ de capture de nombre entier 2.
nDateName1 | Clé étrangère vers la table dta_custom_field_names.
dtDateValue1 | Champ de capture de date 1.
nDateName2 | Clé étrangère vers la table dta_custom_field_names.
dtDateValue2 | Champ de capture de date 2.
nStrName1 | Clé étrangère vers la table dta_custom_field_names.
nvcStrValue1 | Champ de capture de chaîne 1.
nStrName2 | Clé étrangère vers la table dta_custom_field_names.
nvcStrValue2 | Champ de capture de chaîne 2.
nvcCustomSearch | Objet binaire volumineux pour capture de chaîne concaténée sous forme XML.

dta_interchange_details

Cette table a une relation un à plusieurs avec les tables suivantes :

  • dta_indoc_details

  • dta_outdoc_details

  • dta_group_details

  • dta_interchange_data

Cette table a une relation plusieurs à un avec les tables suivantes :

  • dta_direction_values

  • dta_error_message

  • dta_transport_type_values

La table dta_interchange_details contient une ligne par échange traité par BizTalk Server. Le tableau suivant décrit les champs dans la table dta_interchange_details.

Nom du champ | Description
nInterchangeKey | Identificateur d'enregistrement à clé primaire unique.
nInterchangeDataKey | Clé étrangère vers la table dta_interchange_data.
nResponseDocDataKey | Clé étrangère vers la table dta_document_data pour le document de réponse renvoyé par le destinataire d'un transport sortant.
uidInterchangeGUID | Identificateur global unique (GUID) de l'échange.
uidSubmissionGUID | Identificateur global unique (GUID) de la soumission du parent. Notez qu'il contient l'identificateur de corrélation (correlationID) fourni depuis les services d'orchestration BizTalk ou à ces services. Ce champ est vide si l'enregistrement est destiné à un échange entrant ne provenant pas des services d'orchestration BizTalk. Pour les échanges entrants, ce champ est rempli uniquement si l'échange provient des services d'orchestration BizTalk. Pour les échanges sortants, ce champ est toujours rempli.
dtProcessedTimeStamp | Heure de création de l'enregistrement.
nvcSyntax | Code de la syntaxe du document (XML, X12, EDIFACT, HL7, etc.). Dans le cas d'une syntaxe non reconnue en raison d'un incident d'analyse ou d'une soumission directe, ce champ prend la valeur « UNKNOWN ».
nvcVersion | Version de la syntaxe.
nvcControlID | Numéro de contrôle unique pour des échanges EDI (Electronic Data Interchange) ou identificateur pour les messages BizTalk au format Reliable.
nDirection | Indicateur précisant si l'échange est entrant ou sortant. Les valeurs possibles sont 0 (sortant) ou 1 (entrant). C'est une clé étrangère vers dta_direction_values, la table qui contient les valeurs de direction.
dtTimeSent | Horodatage d'une transmission réussie.
nError | Code qui indique l'occurrence d'une erreur. Il s'agit de la clé étrangère vers dta_error_message, la table qui contient les descriptions des messages d'erreur.
nTestMode | Indicateur de test ou de production. Ce champ est réservé et n'est pas utilisé.
nvcSrcAliasQualifer | Valeur de qualificateur de l'émetteur extraite de l'échange soumis ou transmis.
nvcSrcAliasId | Valeur de l'identificateur de l'émetteur extraite de l'échange soumis ou transmis.
nvcSrcAppName | Identificateur de niveau d'échange pour l'application source extrait de l'échange soumis ou transmis.
nvcDestAliasQualifier | Qualificateur du destinataire extrait de l'échange soumis ou transmis.
nvcDestAliasID | Valeur de l'identificateur du destinataire extraite de l'échange soumis ou transmis.
nvcDestAppName | Identificateur de niveau d'échange pour l'application de destination extrait de l'échange soumis ou transmis.
nAckStatus | Code de l'état de la réception. C'est une clé étrangère vers dta_ack_status_values, la table qui contient des descriptions d'état d'accusé de réception.
nvcSMTPMessageID | Identificateur du message de transport SMTP (pour EDIINT). Ce champ est réservé et n'est pas utilisé.
nDocumentsAccepted | Nombre de documents acceptés dans l'échange.
nDocumentsRejected | Nombre de documents refusés dans l'échange.
nTransportType | Code d'indicateur de protocole de transmission. C'est une clé étrangère vers la table dta_transport_type_values.
nvcTransportAddress | Adresse de la cible de transport.
nvcServerName | Serveur qui a traité l'échange.
nNumberOfBytes | Taille de l'échange, en octets. Ce champ représente ce qui est suivi dans l'enregistrement dta_interchange_data associé et peut être différent de ce qui est transmis en réalité. La taille peut être augmentée par un traitement d'enveloppe supplémentaire et par une conversion du format de données pendant la transmission.
nNumOfTransmitAttempts | Compteur de tentatives de transmission.

Voir aussi

Description des paramètres de suivi d'un groupe de serveurs


Structure des tables secondaires

Les tables secondaires stockent les données de support des tables principales dans la base de données de suivi. Par exemple, les tables secondaires stockent ces types d'informations :

  • données du champ de recherche personnalisée ;

  • informations de routage ;

  • données d'échange ;

  • données du document.

Types de données

Les types de données Float et Real sont des types de données approximatives. Leur comportement répond à la spécification IEEE 754 portant sur les types de données numériques approximatives. Les types de données numériques approximatives ne stockent pas les valeurs exactes spécifiées pour de nombreux nombres, mais en conservent une approximation très proche. Dans de nombreuses applications, la différence infime existant entre la valeur spécifiée et l'approximation stockée est négligeable. Il arrive cependant parfois que ça ne soit pas le cas. Compte tenu de la nature approximative des types de données Float et Real, n'utilisez pas ces types de données si vous avez besoin d'un comportement numérique exact, notamment dans les applications financières, les opérations impliquant l'arrondissement ou les contrôles d'égalité. Préférez l'utilisation des types de données Integer, Decimal, Money ou Smallmoney.

BizTalk Server permet au type de données Number d'être suivi en tant que type de données Integer. Si la valeur du nombre dans le document dépasse la taille du type de données Integer, un message d'avertissement s'affiche. Ce message contient la valeur qui n'a pu faire l'objet d'un suivi.

Ne dépassez pas la taille du type de données Integer en effectuant le suivi d'un type de données Number en tant que Integer.

Problèmes internationaux

  • En fonction de la langue du système, BizTalk Server peut mal interpréter une valeur numérique dans les données XML lorsque celle-ci est enregistrée comme champ de suivi d'entier dans la base de données de suivi. Par exemple, dans une version allemande, la valeur numérique de XML 4.0 est enregistrée en tant que 40 dans la base de données de suivi car le point décimal (.) est interprété à tort comme symbole de regroupement numérique.

    Il existe deux manières de contourner ce problème. Premièrement, si vous savez déjà que la valeur de l'élément ou de l'attribut contient un nombre décimal, vous pouvez modifier le type de données de l'élément ou de l'attribut XML en Real (r4) ou Double Real (r8). Deuxièmement, vous pouvez configurer la définition de document ou le canal en vue de l'enregistrement d'un élément ou d'un attribut avec un type de données Number égal à Real au lieu de Integer.

  • Le contrôle de sélection de la date et de l'heure, l'affichage des listes et l'arborescence ne peuvent pas afficher les caractères Unicode. Par conséquent, la prise en charge de plusieurs langues est limitée. Si, par exemple, un ordinateur en anglais accède à un serveur BizTalk Server avec des pages et des données Web de suivi de documents BizTalk incluant un jeu de caractères DBCS (Double Byte Character Set), ces caractères seront matérialisés par des points d'interrogation (?) sur le client en anglais.

dta_document_data

Cette table a une relation un à un avec les tables suivantes :

  • dta_indoc_details

  • dta_outdoc_details

La table dta_document_data constitue le référentiel central pour le stockage des documents. Le tableau suivant décrit les champs de la table dta_document_data.

Nom du champ | Description
nDocumentDataKey | Identificateur d'enregistrement à clé primaire unique.
nCodePage | Page de code système (par exemple, 1200-Unicode, 65001-UTF-8, etc.) pour les données codées au format caractères. Ce champ a une valeur de -1 si BizTalk Server n'a pas d'informations de page de code sur les données. Dans ce cas, la valeur du champ nBLOBType devrait fournir des informations sur le mode d'interprétation des données.
nBLOBType | Indicateur qui précise le type des données stockées dans le champ imgDocumentData. Les valeurs possibles sont 0 (unknown) ou 1 (XMLDOM chargeable). XMLDOM chargeable indique que les données peuvent être chargées et manipulées par l'objet MSXML DOMDocument. Ce champ est une clé étrangère vers la table dta_blobtype_values.
imgDocumentData | Stockage d'un document, sous forme d'objet binaire volumineux.
nNumberOfBytes | Taille du document, en octets.
nNumberOfRecords | Enregistrements ou segments contenus dans le document.

dta_debugdoc_data

Cette table a une relation un à un avec la table suivante :

  • dta_indoc_details

Cette table a une relation un à plusieurs avec la table suivante :

  • dta_outdoc_details

Cette table constitue le référentiel central pour le stockage des documents de débogage. Le tableau suivant décrit les champs de la table dta_debugdoc_data.

Nom du champ | Description
nDebugDocDataKey | Identificateur d'enregistrement à clé primaire unique.
ntxtDocumentData | Stockage du document, sous forme d'objet binaire volumineux. Toujours en Unicode.
nNumberOfBytes | Taille du document, en octets.
dtProcessedTimeStamp | Heure de création de l'enregistrement.

dta_interchange_data

Cette table a une relation plusieurs à un avec la table suivante :

  • dta_interchange_details

La table dta_interchange_data constitue un référentiel central pour le stockage des échanges et contient un enregistrement pour chaque échange traité par le système. Pour les échanges soumis à BizTalk Server uniquement, le champ nlsFile indique si les données stockées d'origine proviennent du système de fichiers. Si l'indicateur est activé, le champ nvcOriginalFileName est un chemin à convention d'affectation de noms (UNC) vers l'emplacement du système de fichiers d'où proviennent les données. Le champ imgInterchangeData contient les données soumises, quelle qu'en soit l'origine.

Nom du champ | Description
nInterchangeDataKey | Identificateur d'enregistrement à clé primaire unique.
nCodePage | Page de code système (par exemple, 1200-Unicode, 65001-UTF-8, etc.) pour les données codées au format caractères. Ce champ à une valeur -1 si BizTalk Server n'a pas d'informations de page de code sur les données ou si les données sont suivies à la suite d'une soumission directe. Dans ce cas, la valeur du champ nBLOBType devrait fournir des informations sur le mode d'interprétation des données.
nlsFile | Indicateurs précisant une soumission des données basée sur un fichier. Les valeurs possibles sont 0 (non basées sur un fichier) ou 1 (basées sur un fichier).
nvcOriginalFileName | Chemin à convention d'affectation de noms (UNC) vers le fichier, si le champ nlsFile a la valeur 1.
nBLOBType | Indicateur qui précise le type des données stockées dans le champ imgDocumentData. Les valeurs possibles sont 0 (unknown) ou 1 (XMLDOM chargeable). XMLDOM chargeable indique que les données peuvent être chargées et manipulées par l'objet MSXML DOMDocument. Ce champ est une clé étrangère vers la table dta_blobtype_values.
imgInterchangeData | Stockage de l'échange, sous forme d'objet binaire volumineux.

dta_group_details

Cette table a une relation un à plusieurs avec les tables suivantes :

  • dta_indoc_details

  • dta_outdoc_details

Cette table a une relation plusieurs à un avec les tables suivantes :

  • dta_interchange_details

  • dta_direction_values

La table dta_groug_details crée une ligne par groupe traité par les composants d'extensibilité pour l'EDI (Electronic Data Interchange). Le tableau suivant décrit les champs de la table dta_group_details.

Nom du champ | Description
nGroupKey | Identificateur d'enregistrement à clé primaire unique.
nInterchangeKey | Clé étrangère vers la table dta_interchange_details.
dtProcessedTimeStamp | Heure de création de l'enregistrement.
nvcSyntax | Code de la syntaxe du document (XML (Extensible Markup Language), X12, EDIFACT, HL7, etc.). Dans le cas d'une syntaxe non reconnue en raison d'un incident d'analyse ou d'une soumission directe, ce champ prend la valeur « UNKNOWN ».
nvcVersion | Version du standard.
nvcRelease | Diffusion de la version.
nvcFunctionalGroupID | Code pour le type de document dans le groupe.
nvcControlID | Numéro de contrôle unique pour des documents et des groupes fonctionnels EDI.
nvcSrcAppName | Identificateur de niveau de groupe pour l'application source.
nvcDestAppName | Identificateur de niveau de groupe pour l'application de destination.
nAckStatus | Code de l'état de la réception. C'est une clé étrangères vers dta_ack_status_values, la table qui contient des descriptions d'état d'accusé de réception.
nDirection | Indicateur précisant si le groupe est entrant ou sortant. Les valeurs possibles sont 0 (sortant) ou 1 (entrant). C'est une clé étrangère vers la table dta_direction_values.
nDocumentsAccepted | Transactions acceptées dans le groupe.
nDocumentsRejected | Transactions refusées dans le groupe.
nNumberOfBytes | Taille de l'échange, en octets.

dta_routing_details

Cette table a une relation un à plusieurs avec la table suivante :

  • dta_outdoc_details

La table dta_routing_details contient une ligne par jeux d'informations source ou de destination. Deux documents peuvent avoir des valeurs de champ de routage identique au niveau de l'organisation ou de l'application. Dans ce cas, ces documents sont différenciés par le type de document ou un autre filtre de niveau inférieur. Lorsque cela se produit, la table dta_routing_details contient des lignes identiques, à l'exception d'une différence dans leurs ports d'échanges parents respectifs. Ce lien au port d'échanges parent facilite la connexion entre les fonctionnalités d'interface utilisateur du Gestionnaire d'échanges BizTalk et le suivi. Le tableau suivant décrit les champs de la table dta_routing_details.

Nom du champ | Description
nRoutingKey | Identificateur d'enregistrement à clé primaire unique.
nvcSrcOrgName | Nom de l'organisation source, tel que spécifié sur l'objet de canal parent.
nvcSrcAppName | Nom de l'application source, tel que spécifié sur l'objet du canal parent.
nvcDestOrgName | Nom de l'organisation de destination, tel que spécifié sur l'objet du port d'échanges.
nvcDestAppName | Nom de l'application de destination, tel que spécifié sur l'objet du port d'échanges parent.
nvcDistributionName | Nom de la liste de distribution.
uidChannelGUID | Clé unique pour le canal parent basée sur un identificateur global unique (GUID). Ce champ est utilisé comme une clé de corrélation de canal dans la base de données Gestion d'échanges BizTalk.
uidPortGUID | Clé unique pour le port parent, basée sur un identificateur global unique (GUID). Ce champ est une clé de corrélation de port dans la base de données Gestion d'échanges BizTalk.

dta_custom_field_names

Cette table a une relation plusieurs à un avec la table suivante :

  • dta_outdoc_details

La table dta_custom_field_names contient une ligne par nom de nœud distinct et paire de types de données capturés. Le tableau suivant décrit les champs de la table dta_custom_field_names.

Nom du champ | Description
nNameKey | Identificateur d'enregistrement à clé primaire unique.
nvcName | Texte du nom de nœud, par exemple, /CommonPO/Total/@POTotal.
nDataType | Type des données contenues dans le nœud nommé.

dta_MIME_data

La table dta_MIME_data stocke les données MIME entrantes traitées par BizTalk Server. Cette table permet de suivre des données MIME contenant des pièces jointes. Le tableau suivant décrit les champs de la table dta_MIME_data.

Nom du champ | Description
nMIMEDataKey | Identificateur d'enregistrement à clé primaire unique.
uidSubmissionGUID | Identificateur global unique (GUID) de la soumission du parent.
nCodePage | Page de code système pour les données stockées codées au format caractères dans le champ imgMIMEData. Pour les données MIME, la valeur est 1252 (ASCII) ou 1200 (Unicode).
imgMIMEData | Stockage du document, sous forme d'objet binaire volumineux.


Tables connexes

Il existe 13 tables supplémentaires dans la base de données de suivi qui prennent en charge les tables principales ou les tables de support. Ces tables stockent des informations telles que les clés de corrélation de groupe et d'échange, des valeurs d'état d'accusé de réception et des valeurs de niveau de données. Le tableau suivant décrit chaque table et sa fonctionnalité.

Nom de la table | Fonction
dta_ack_status_values | Stocke les valeurs d'état d'accusé de réception. Les valeurs possibles sont Aucun, En attente, En retard, Accepté, Accepté avec les erreurs et Rejeté.
dta_blobtype_values | Stocke les types d'objet binaire volumineux. Les valeurs possibles sont « Unknown » et « XMLDOM chargeable ».
dta_data_level_values | Stocke les valeurs des niveaux de données employées dans BizTalk Server. Les valeurs possibles sont Échange, Grouper, Document entrant et Document sortant.
dta_direction_values | Stocke la direction de l'échange. Les valeurs possibles sont Entrant et Sortant.
dta_error_message Stocke les messages d'erreurs utilisés dans suivi de documents BizTalk. Les valeurs autorisées sont les suivantes :
  • Aucune erreur.

  • Impossible d'appeler un composant personnalisé.

  • Impossible d'analyser l'échange.

  • Le canal spécifié n'existe pas.

  • Impossible de sérialiser l'échange.

  • Impossible de coder l'échange.

  • Impossible de signer l'échange.

  • Impossible de crypter l'échange.

  • Échec de la tentative de transmission (une nouvelle tentative est en attente).

  • Échec de la dernière tentative de transmission.

  • Impossible d'analyser le document.

  • Impossible de valider le document.

  • Impossible de trouver un canal valide.

  • Impossible de mapper le document.

  • Impossible de trouver un port d'échanges valide.

  • Impossible de sérialiser le document.
dta_group_correlation_keys | Stocke les clés de corrélation de groupe. Les valeurs sont générées dynamiquement pour l'identification d'éventuels candidats de groupe pendant la corrélation de réception.
dta_interchange_correlation_keys | Stocke les clés de corrélation d'échange. Les valeurs sont uniques et générées dynamiquement pour l'identification d'éventuels candidats de groupe pendant la corrélation de réception.
dta_transport_type_values | Stocke les valeurs de types de transport. Les valeurs possibles sont Aucun, HTTP, SMTP, DCOM, Intégration de l'application, Message Queuing, Fichier, HTTPS, Destination ouverte, Bouclage et Activation d'orchestration.
dta_ui_codepage_charset | Stocke les pages de code système pour les données codées au format caractères.
dta_ui_user_queries | Stocke les requêtes avancées que les utilisateurs individuels créent et enregistrent.
dta_validity_values Stocke les valeurs de validité. Les valeurs possibles sont Non valide, Valide et Transfert.

La valeur Transfert indique que le document n'a pas été analysé et que la validité ne s'applique pas. Pour plus d'informations sur la valeur transfert, voir Description des propriétés avancées d'une fonction de réception.
dta_wf_EventData | Contient un enregistrement pour chaque propriété consignée en relation à un événement COM+ surveillé déclenché par une planification XLANG. Les ensembles de lignes multiples dans cette table partagent un parent commun dans la table dta_wf_WorkFlowEvent.
dta_wf_WorkFlowEvent | Contient un enregistrement pour chaque événement COM+ surveillé déclenché par une planification XLANG.


Consignation des échanges et des documents

Différents scénarios de traitement, tels que source ouverte, destination ouverte et transfert, sont consignés différemment dans la base de données de suivi. Les six scénarios de traitement courants sont Non ouvert, Source ouverte, Destination ouverte, Bouclage, Soumission directe, ainsi que Attendre un accusé de réception et Générer un accusé de réception (Attendre un accusé de réception et Générer un accusé de réception sont considérés comme un seul scénario). Les scénarios de traitement Attendre un accusé de réception et Générer un accusé de réception sont décrits dans Consignations des accusés de réception. Les autres scénarios de traitement sont décrits dans le tableau suivant.

Scénario de traitement | Description
Non ouvert | Se produit lorsque la source et la destination sont déclarées de façon explicite dans la fonction de réception, l'instance de document, la méthode Submit ou la méthode SubmitSync.
Source ouverte | Se produit lorsque les informations source ne sont pas explicitement déclarées dans le canal. Le canal doit être marqué comme source ouverte, et l'appel soumis ou la fonction de réception doit spécifier la propriété Openness de la source.
Destination ouverte | Se produit lorsque les informations de destination ne sont pas explicitement déclarées dans le port d'échanges. La destination est spécifiée dynamiquement dans l'instance de document, la méthode Submit ou méthode SubmitSync. Le port doit être marqué comme destination ouverte et l'appel soumis ou la fonction de réception doit indiquer la propriété Openness de la destination.
Bouclage | Se produit lorsqu'un bouclage est le transport spécifié dans un canal. Un bouclage renvoie le document sortant à une application professionnelle, un composant ou une planification XLANG qui a soumis le document entrant avec la méthode SubmitSync. Ce type de transport est disponible uniquement pour un port d'échanges qui se connecte à une application et est disponible uniquement par le biais de la méthode SubmitSync.
Transfert | Se produit lorsque vous sélectionnez l'option Soumettre avec un indicateur direct dans la fonction de réception ou spécifiez la valeur True dans le paramètre PassThrough de la méthode Submit ou la méthode SubmitSync. BizTalk Server ne traite pas le document. Cela signifie que le document n'est pas analysé, signé, décrypté, vérifié, etc. Le document est uniquement transporté par BizTalk Server.

Le tableau suivant présente les enregistrements sortants consignés dans la base de données de suivi.

Scénario de traitement | dta_interchange_details (sortant) | dta_outdoc_details | Document de réponse
Non ouvert | X | X | X
Source ouverte | X | X | X
Destination ouverte | X | X | X
Bouclage | X | X |
Transfert | X | X | X

Remarques

  • Les documents de réponse sont générés uniquement lorsque vous utilisez les transports suivants : HTTP (Hypertext Transfer Protocol), HTTPS (Secure Hypertext Transfer Protocol) ou un composant d'intégration d'application (AIC). En outre, l'adresse du destinataire doit envoyer des données retournées.

  • Pour le scénario de transfert, l'enregistrement consigné dans la table dta_outdoc_details est un enregistrement vide. Le champ nlsValid a une valeur de 2 pour indiquer que cet enregistrement est associé à un document direct, et le champ nSyntax prend la valeur « UNKNOWN ». Puisque BizTalk Server ne traite pas le document, BizTalk Server ne peut pas remplir la plupart des champs de cette table avec des données appropriées.

Le tableau suivant présente les enregistrements entrants consignés dans la base de données de suivi.

Scénario de traitement | dta_interchange_details (entrant) | dta_indoc_details | Document de réponse
Non ouvert | X | X | X
Source ouverte | X | X | X
Destination ouverte | X | X | X
Bouclage | X | X |
Transfert | X | X | X

Remarques

  • Les documents de réponse sont générés uniquement lorsque vous utilisez les transports suivants : HTTP, HTTPS ou AIC. En outre, l'adresse du destinataire doit envoyer des données retournées.

  • Pour le scénario de transfert, l'enregistrement consigné dans la table dta_indoc_details est un enregistrement vide. Le champ nlsValid a une valeur de 2 pour indiquer que cet enregistrement est associé à un document direct, et le champ nSyntax prend la valeur « UNKNOWN ». Puisque BizTalk Server ne traite pas le document, BizTalk Server ne peut pas remplir la plupart des champs de cette table avec des données appropriées.

Voir aussi

Consignations des accusés de réception


Consignations des accusés de réception

L'illustration suivante montre le flux d'accusé de réception dans Microsoft BizTalk Server 2002.

Traitement des accusés de réception en utilisant des canaux

Dans ce scénario :

  • Le système source et le système de destination utilisent BizTalk Server.

  • Le système source envoie un bon de commande au système de destination, et le système source attend un accusé de réception du système de destination pour le bon de commande.

  • Les deux systèmes sont configurés pour attendre et générer des accusés de réception.

Lorsque le bon de commande est traité par le système source et envoyé au système de destination, un enregistrement est consigné dans la table dta_outdoc_details. Le tableau suivant indique comment se présentent les champs se rapportant aux accusés de réception dans cet enregistrement.

Nom du champ | Exemple de valeur | Description
nOutDocKey | 1 | Est un numéro unique qui identifie l'enregistrement.
nAckStatus | 1 | Indique qu'un accusé de réception pour le document est en attente.
nReceiptFlag |  | N'est pas rempli pour le moment.
nReceiptKey |  | N'est pas rempli pour le moment.

Lorsque le système de destination reçoit et traite le bon de commande, un enregistrement est consigné dans la table dta_indoc_details et deux enregistrements sont consignés dans la table dta_outdoc_details. L'enregistrement dans la table dta_indoc_details suit les informations relatives au bon de commande. Le premier enregistrement dans la table dta_outdoc_details suit les informations relatives au bon de commande et le deuxième enregistrement suit les informations relatives à l'accusé de réception du bon de commande.

Le tableau suivant présente les champs relatifs au bon de commande dans l'enregistrement de la table dta_indoc_details.

Nom du champ | Exemple de valeur | Description
nInDocKey | 1 | Est un numéro unique qui identifie l'enregistrement.
nDocType | CommonPO | Identifie le type de document reçu.

Le premier enregistrement consigné dans la table dta_outdoc_details correspond au bon de commande traité par BizTalk Server. Le tableau suivant indique comment se présentent les champs se rapportant aux accusés de réception dans cet enregistrement.

Nom du champ | Exemple de valeur | Description
nOutDocKey | 10 | Est un numéro unique qui identifie l'enregistrement.
nInDocKey | 1 | Lie l'enregistrement à l'enregistrement parent dans la table dta_indoc_details.

Le deuxième enregistrement consigné dans la table dta_outdoc_details correspond à l'accusé de réception qui est généré par le bon de commande. Le tableau suivant indique comment se présentent les champs se rapportant aux accusés de réception dans cet enregistrement.

Nom du champ | Exemple de valeur | Description
nOutDocKey | 2 | Est un numéro unique qui identifie l'enregistrement.
nInDocKey | 1 | Lie l'enregistrement à l'enregistrement parent dans la table dta_indoc_details.
nAckStatus | 0 | Indique que l'accusé de réception n'attend pas d'accusé de réception en retour.
nReceiptFlag | 4 | Indique que l'accusé de réception est associé à un enregistrement dans la table dta_indoc_details.
nReceiptKey | 1 | Est un numéro unique qui identifie l'enregistrement d'accusé de réception.

Lorsque le système source reçoit et traite l'accusé de réception généré par le système de destination et qu'un enregistrement est consigné dans la table dta_indoc_details, l'enregistrement d'origine consigné dans la table dta_outdoc_details est mis à jour. Le tableau suivant présente les champs relatifs aux accusés de réception dans l'enregistrement de la table dta_indoc_details.

Nom du champ | Exemple de valeur | Description
nInDocKey | 9 | Est un numéro unique qui identifie l'enregistrement.
nDocType | 997 | Identifie le type de document reçu.

Le tableau suivant présente les champs relatifs aux accusés de réception dans l'enregistrement mis à jour dans la table dta_outdoc_details.

Nom du champ | Exemple de valeur | Description
nOutDocKey | 1 | Est un numéro unique qui identifie l'enregistrement.
nAckStatus | 3 | Indique qu'un accusé de réception a été reçu.
nReceiptFlag | 4 | Indique que l'accusé de réception est associé à un enregistrement dans la table dta_indoc_details.
nReceiptKey | 9 | Est un numéro unique qui identifie l'enregistrement d'accusé de réception.

Voir aussi

Consignation des échanges et des documents


Consignation des informations de routage

Les informations de routage consignées dans la base de données de suivi varient selon que le document est entrant ou sortant et selon le mode de traitement des données par BizTalk Server. Pour les échanges entrants, lorsque BizTalk Server reçoit un document, il affiche l'instance du document pour les informations de routage. BizTalk Server vérifie ensuite la fonction de réception ou les paramètres de routage spécifiés dans IInterchange::Submit. Si les informations de routage sont fournies dans la fonction de réception ou dans IInterchange::Submit, ces paramètres sont utilisés pour router l'instance du document. Cependant, les informations de routage fournies dans l'instance du document sont consignées dans la table dta_routing_details de la base de données de suivi.

Pour les échanges sortants, les informations de routage source et de destination proviennent toujours du canal, ces informations étant consignées dans la table dta_routing_details.

Cela affecte les informations affichées dans l'interface utilisateur de suivi de documents BizTalk pour les informations d'alias. Les échanges soumis à BizTalk Server et transmis depuis celui-ci sont toujours interprétés comme une instance de flux de données unique.


Suivi des événements de planification XLANG dans la base de données de suivi

Les événements d'action associés aux messages traités par une planification XLANG qui sont échangés entre les services d'échanges BizTalk et les services d'orchestration BizTalk peuvent être suivis dans les tables appropriées de la base de données de suivi. Les événements d'action peuvent être affichés en utilisant Suivi de documents BizTalk. Cependant, le suivi et l'affichage des événements d'action associés à des messages traités par une planification XLANG ne sont pas automatiquement activés lors de l'installation de BizTalk Server 2002. Pour activer cette fonction, vous devez procéder comme suit :

  1. Enregistrez l'exemple de fichier .DLL WorkFlowAudit.dll.

    Vous trouverez cet exemple de fichier dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\bin.

  2. Exécutez l'application WorkFlowAuditClient.exe pour activer WorkFlowAudit.dll.

    Vous trouverez cet exemple d'application dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient.

    Pour plus d'informations, vous pouvez afficher la documentation (Readme.txt) se trouvant dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit\Docs.

  3. Cliquez sur le bouton Démarrer de l'application WorkFlowAuditClient pour initialiser la consignation des événements d'action associés à une planification XLANG dans la base de données de suivi.

Important

  • Des enregistrements sont consignés dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent uniquement si l'application WorkFlowAuditClient est démarrée. Pour démarrer l'application WorkFlowAuditClient, vous devez effectuer les trois étapes indiquées dans cette rubrique. Si l'application WorkFlowAuditClient est arrêtée, aucun enregistrement n'est consigné dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent.

Une fois ces étapes effectuées, des enregistrements sont consignés dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent pour les messages qui seront échangés entre les services d'orchestration BizTalk et les services d'échanges BizTalk. La valeur consignée dans le champ nvcName de la table dta_wf_EventData sert de lien entre les tables dta_wf_EventData et dta_wf_WorkFlowEvent et la table dta_interchange_details, une table principale dans la base de données de suivi. Pour plus d'informations sur les tables principales, voir Structure des tables de métadonnées principales.

Messages envoyés des services d'orchestration BizTalk aux services d'échanges BizTalk

Tous les messages qui sont envoyés des service d'orchestration BizTalk aux services d'échanges BizTalk en utilisant l'implémentation du port d'échanges BizTalk dans le Concepteur d'Orchestration BizTalk sont identifiés par un identificateur global unique (GUID) qualifié d'identificateur de corrélation (correlationID). Lorsqu'un message est soumis des services d'orchestration BizTalk aux services d'échanges BizTalk, l'identificateur de corrélation est consigné dans le champ uidSubmissionGUID de la table dta_interchange_details. En outre, des enregistrements sont consignés dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent. Cela vous permet d'utiliser Suivi de documents BizTalk pour visualiser les événements d'action associés aux messages traités par une planification XLANG.

Documents envoyés des services d'échanges BizTalk aux services d'orchestration BizTalk

Tous les documents qui sont soumis aux services d'échanges BizTalk sont identifiés par un GUID appelé descripteur de dépôt (SubmissionHandle). Pour plus d'informations sur le descripteur de dépôt, voir Méthode Submit. Lorsque le document est envoyé des services d'échanges BizTalk aux services d'orchestration BizTalk, le descripteur de dépôt est enregistré dans le champ uidSubmissionGUID de la table dta_interchange_details. En outre, lorsqu'un document est envoyé des services d'échanges BizTalk aux services d'orchestration BizTalk, les deux événements suivants se produisent :

  • Le descripteur de dépôt est inséré dans la propriété correlationID du document qui est envoyé aux services d'orchestration BizTalk.

  • Les enregistrements sont consignés dans les tables dta_wf_EventData et dta_wf_WorkFlowEvent. Puisque le document est envoyé des services d'échanges BizTalk, la descripteur de dépôt est consigné comme l'identificateur de corrélation (correlationID) dans le champ nvcName de la table dta_wf_EventData.

Affichage d'événements d'action

Pour utiliser Suivi de documents BizTalk pour afficher des événements d'action associés aux messages traités par une planification XLANG, vous devez créer une requête dans Suivi de documents BizTalk, puis cliquer sur l'icône de planification XLANG. Pour plus d'informations sur la création de requêtes et l'affichage d'événements de planification XLANG, voir Utilisation des requêtes pour rechercher et trier les données d'échange et de document.

La table dta_wf_EventData

La table suivante contient un enregistrement pour chaque propriété consignée en relation à un événement COM+ surveillé qui est généré par une planification XLANG. Les ensembles de lignes multiples dans cette table partagent un parent commun dans la table dta_wf_WorkFlowEvent.

Nom du champ | Description
nEventDataId | Champ de clé de nombre entier incrémenté automatiquement.
nWorkFlowEventId | Clé étrangère vers l'enregistrement d'événement parent dans dta_wf_EventData.
nvcName | Identificateur de corrélation (correlationID).
nvcValue | N'importe quelle valeur. Elle est généralement basée sur un identificateur global unique (GUID).

La table dta_wf_WorkFlowEvent

La table suivante est la table parent de dta_wf_EventData et contient un enregistrement pour chaque événement COM+ surveillé qui est généré par une planification XLANG.

Nom du champ | Description
nWorkFlowEventId | Champ de clé de nombre entier incrémenté automatiquement.
nvcEventId | Type d'événement.
nvcEventName | Nom de l'événement.
nProcessId | Identificateur de traitement pour l'événement d'origine.
nvcApplicationId | Identificateur de planification XLANG.
nvcInstanceId | Identificateur pour l'instance particulière de la planification.
nEventTime | Heure universelle coordonnée (UTC) de l'événement sous forme de secondes écoulées depuis minuit, 1er janvier 1970.
nEventSubTime | Microsecondes ajoutées à l'argument ITime pour l'heure à une résolution aux microsecondes.
nEventTick | Valeur du compteur de performances haute résolution à l'origine de l'événement.
nvcServerName | Serveur sur lequel l'événement a été détecté.
dtDateEntered | Date de l'événement.

Voir aussi

Intégration des services BizTalk

Structure des tables de métadonnées principales

Méthode Submit

Présentation de l'état de la planification XLANG pour un échange


Recherche d'échanges et de documents associés

Vous pouvez utiliser Suivi de documents BizTalk pour afficher tous les échanges et documents en utilisant les paramètres de requête que vous spécifiez. Pour optimiser les résultats de recherche et pour réduire la charge sur le serveur, il est important de comprendre les requêtes et leur mode d'utilisation. Par exemple, si vous créez une requête avec un nombre réduit de paramètres définis, la requête pourrait renvoyer des milliers d'enregistrements d'échange. Cela vous crée beaucoup de travail et sollicite fortement les capacités de traitement du serveur. Cette situation empire lorsque plusieurs personnes interrogent simultanément la base de données.

Il existe deux niveaux de requêtes dans BizTalk Server : requêtes et requêtes avancées. Les requêtes incluent les critères les plus courants qui sont utilisés pour limiter les résultats de la requête. Les requêtes avancées vous permettent de mieux définir les résultats de requête en utilisant des expressions permettant de rechercher des données spécifiques.

Cette section traite des rubriques suivantes :

  • Présentation des requêtes

  • Présentation des requêtes avancées


Présentation des requêtes

Les trois paramètres de requête standard inclus dans Suivi de documents BizTalk sont les plages de dates et le fuseau horaire, les identificateurs source et de destination, ainsi que le type de document. Vous pouvez rechercher des enregistrements d'échange et de document en définissant un ou plusieurs de ces critères dans une requête. Vous pouvez, par exemple, rechercher tous les types de documents figurant dans une plage de dates spécifiée ou rechercher les échanges et les documents appartenant à un type de document particulier et correspondant à l'organisation source et à l'organisation de destination sélectionnées.

Plage de dates et fuseau horaire

La date et l'heure indiquées dans Suivi de documents BizTalk est l'heure à laquelle le document a été traité par BizTalk Server. Vous pouvez spécifier la plage de dates de votre choix pour la requête. Par défaut, l'application Suivi de documents BizTalk propose les sept jours précédents comme plage de dates. Contrairement aux listes Sélection de la source, Sélection de la destination et Sélection du type de document, Suivi de document BizTalk ne vous autorise pas à laisser la plage de dates vide pour rechercher les documents pour n'importe quelle date et heure.

Vous pouvez également spécifier si vous souhaitez afficher la date et l'heure dans le format d'heure locale ou dans le format d'heure universelle coordonnée (UTC). Le plus souvent, il convient d'afficher les échanges et les documents en utilisant l'heure locale. Cependant, si vous travaillez avec une personne se trouvant dans un autre fuseau horaire et si vous devez créer des critères communs pour la définition des périodes d'envoi et de réception, utilisez l'heure universelle coordonnée.

Remarque

  • L'utilisation de formats longs de date et d'heure peut créer des troncatures dans l'application Suivi de documents BizTalk car le contrôle de sélection de la date et de l'heure prend uniquement en charge les formats courts.

    Si vous rencontrez des problèmes avec le format de date et d'heure, vous pouvez modifier les formats utilisés par votre ordinateur dans le Panneau de configuration en cliquant sur Options régionales.

Organisation source et de destination

Vous pouvez rechercher des échanges et des documents basés sur l'organisation source, l' organisation de destination, ou bien les deux. En outre, lorsque vous créez une requête, vous pouvez filtrer des documents d'une ou de plusieurs organisations, ou de toutes les organisations. Vous pouvez également rechercher des échanges et des documents issus d'une application associée à une organisation. Par exemple, si l'organisation source A a une application de tableur qui envoie des informations à une application de base de données dans une organisation de destination B, vous pouvez déterminer à quel moment les informations ont été envoyées et reçues.

Type de document

Vous pouvez rechercher des échanges et des documents ayant un type de document spécifique, tel que des bons de commande ou des factures. Dans une requête, vous pouvez combiner des critères de type de document avec des qualificateurs source et de destination pour rechercher des échanges et des documents envoyés et reçus entre vous et vos partenaires commerciaux. Ce type de requête peut vous aider à analyser des relations professionnelles entre vous et vos partenaires commerciaux.

Contrôle du tri

Six contrôles du tri déterminent dans quel ordre les colonnes sont triées sur la page Résultats de la requête. L'ordre de tri par défaut d'une requête est le suivant :

  • Nom de l'organisation source. Le nom de l'organisation source pour le document.

  • Nom de l'application source. Le nom de l'application dans laquelle le document a été créé.

  • Nom de l'organisation de destination. Le nom de l'organisation de destination du document.

  • Nom de l'application de destination. Le nom de l'application à laquelle le document est envoyé.

  • Type de document. Le type du document.

  • Temps de traitement. L'heure à laquelle le document a été traité par BizTalk Server.

La case à cocher Grouper les échanges correspondants configure les Résultats de la requête pour afficher les échanges entrants groupés avec les échanges sortants associés. Décochez cette case si vous ne souhaitez pas afficher les échanges entrants avec les échanges sortants associés.

Voir aussi

Présentation des requêtes avancées


Présentation des requêtes avancées

Si vous trouvez qu'une requête renvoie trop d'enregistrements d'échanges et de documents, vous pouvez affiner votre recherche en mettant en œuvre des expressions de requête. Dans la boîte de dialogue Requêtes avancées, vous pouvez créer une nouvelle expression de requête dans le Générateur de requêtes avancées ou explorer une liste d'expressions de requête que vous avez précédemment enregistrées. Les expressions sont des instructions SQL formées par la création de clauses conditionnelles que vous ajoutez à la requête. Pour vous aider à créer une requête avancée, vous disposez des options suivantes :

  • Sélection de la source. Une liste des champs sur lesquels vous souhaitez effectuer une recherche. Dans le Gestionnaire d'échanges BizTalk, si vous avez configuré un canal ou une définition de document pour suivre un ou plusieurs champs personnalisés, ces champs apparaissent dans la liste Sélection de la source. Si vous n'avez pas configuré le Gestionnaire d'échanges BizTalk pour suivre des champs, seul "<Recherche personnalisée>" apparaît dans la liste Sélection de la source. Pour plus d'informations sur le suivi de champs spécifiques, voir Définition des propriétés de journalisation de document et Sélection des champs de spécification dans un canal.

  • Opérateurs. Une liste d'opérateurs disponibles (tels que >, <, =, contient, ou ne contient pas).

  • Valeur. Vous pouvez saisir une valeur dans cette zone pour indiquer la valeur limite pour la requête avancée.

  • AND/OR. Une liste qui contient les opérateurs de groupement (AND et OR) utilisés pour combiner des conditions de recherche.

  • Requête. Une liste des requêtes que vous avez créées.

  • Regroupement logique. Une description des conditions de recherche combinées que vous avez créées en utilisant les opérateurs de groupement AND et OR. Lorsque vous ajoutez des clauses à une requête, des informations sur les opérateurs de groupement apparaissent dans la zone Regroupement logique. Par exemple, la zone Regroupement logique pourrait afficher les éléments suivants :

    1 AND 2 AND (3 OR 4)

    Dans cet exemple, les conditions 1 et 2 s'appliquent, et la condition 3 ou la condition 4 est combinée aux conditions 1 et 2.

Remarques

  • Deux requêtes ne peuvent pas porter le même nom.

  • Lors du suivi des champs de spécifications en tant que type de données Integer, Real, Date ou Text, les noms des champs de spécification dépassant 79 caractères sont tronqués.

    Suivez ces champs de spécifications en tant que type de données Custom. En procédant ainsi, les noms de champ sont regroupés avec leurs valeurs de champ dans une colonne SQL ntext, dont la longueur maximale autorisée est de 2^30 - 1 (1 073 741823) caractères.

  • Si vous ne parvenez pas à trouver le détail et l'état de l'accusé de réception d'un document dans la console Administration de BizTalk Server, il est possible que la case à cocher Activer le Suivi de documents ne soit pas activée. Dans ce cas, les accusés de réception ne peuvent pas être mis en corrélation.

    Pour activer l'enregistrement des documents, procédez comme suit :

    1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Administration de BizTalk Server.

    2. Dans la console Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, cliquez avec le bouton droit sur le groupe BizTalk Server pour lequel vous souhaitez modifier les paramètres de suivi des documents, puis cliquez sur Propriétés.

    3. Dans l'onglet Suivi, activez la case à cocher Activer le Suivi de documents.

    Sélectionnez les autres options à votre convenance.

Question d'ordre international

  • En fonction de la langue du système, BizTalk Server peut mal interpréter une valeur numérique dans les données XML lorsque celle-ci est enregistrée comme champ de suivi d'entier dans la base de données de suivi. Par exemple, dans une version allemande, la valeur numérique de XML 4.0 est enregistrée en tant que 40 dans la base de données de suivi car le point décimal (.) est interprété à tort comme symbole de regroupement numérique.

    Il existe deux manières de contourner ce problème. Premièrement, si vous savez déjà que la valeur de l'élément ou de l'attribut contient un nombre décimal, vous pouvez modifier le type de données de l'élément ou de l'attribut XML en Real (r4) ou Double Real (r8). Deuxièmement, vous pouvez configurer la définition de document ou le canal en vue de l'enregistrement d'un élément ou d'un attribut avec un type de données Number égal à Real au lieu de Integer.

Voir aussi

Présentation des requêtes


Présentation des résultats de requête

Les résultats de requête sont organisés dans la page Résultats de la requête à deux niveaux, les enregistrements d'échanges et les enregistrements de documents. Les enregistrements d'échanges constituent le niveau d'organisation le plus élevé. Un enregistrement d'échange représente un échange soumis à Microsoft BizTalk Server 2002 ou envoyé par celui-ci. Les enregistrements d'échange sont les enregistrements parents des enregistrements d'instance de document et vous aident donc à organiser les enregistrements d'instance de document d'une manière cohérente. Pour plus d'informations sur les champs inclus dans un enregistrement d'échange, voir Présentation des résultats d'un enregistrement d'échange. Graphiquement, les enregistrements d'échange prennent la forme de lignes de champs de données avec un indicateur de développement situé à l'extrémité gauche de chaque ligne.

Si vous cliquez sur l'indicateur de développement, le ou les enregistrements de l'instance de document apparaissent. Graphiquement, l'enregistrement ou les enregistrements d'instance de document apparaissent également sous forme de lignes de champs de données. Généralement, à chaque enregistrement d'échange correspond un enregistrement d'instance de document. Cependant, si plusieurs types de document sont envoyés dans un échange individuel, il y a un enregistrement de document pour chaque type de document envoyé dans l'échange. Pour plus d'informations sur les champs inclus dans un enregistrement d'instance de documents, voir Présentation des résultats d'enregistrement d'instance de document.

Cette section traite des rubriques suivantes :

  • Principes de base du schéma de la base de données de suivi

  • Présentation des résultats d'un enregistrement d'échange

  • Présentation des résultats d'enregistrement d'instance de document

  • Présentation des résultats d'accusé de réception

  • Présentation des résultats pour échecs de transmission


Principes de base du schéma de la base de données de suivi

Pour comprendre le contenu de la page Résultats de la requête, il est important de comprendre les principes de base du schéma de la base de données de suivi. Trois tables principales de la base de données de suivi stockent les métadonnées (par exemple les identificateurs de l'organisation source et de l'organisation de destination, la date, l'heure et le type de document) pour chaque échange et document traité par BizTalk Server. Les tables de bases de données sont les suivantes :

  • dta_interchange_details

  • dta_indoc_details

  • dta_outdoc_details

dta_interchange_details

La table dta_interchange_details stocke toutes les données appropriées des échanges et constitue la table parent des tables dta_indoc_details et dta_outdoc_details. Un enregistrement est stocké dans la table pour chaque échange traité par BizTalk Server. Les champs dans les enregistrements d'échange sur la page Résultats de la requête sont remplis de données issues de cette table. Un champ dans cette table précise si l'échange est entrant ou sortant. Par exemple, si vous recevez un échange, il est représenté sur la page Résultats de la requête sous forme d'enregistrement d'échange entrant. Si vous envoyez un échange, il est représenté sur la page Résultats de la requête sous forme d'enregistrement d'échange sortant. Pour plus d'informations sur la table dta_interchange_details, voir Tables de métadonnées principales ou Structure des tables de métadonnées principales.

dta_indoc_details

La table dta_indoc_details stocke toutes les données pour chaque document soumis à BizTalk Server. Cette table est liée à la table dta_interchange_details par le biais d'une clé primaire. Les champs dans les enregistrements d'instance de document associés à des enregistrements d'échange entrants sur la page Résultats de la requête sont remplis avec des données issues de cette table. Par exemple, si vous envoyez un document et souhaitez visualiser les informations de suivi pour ce document sur la page Résultats de la requête, vous devez d'abord localiser l'enregistrement d'échange sortant approprié. Ensuite, développez l'enregistrement pour faire apparaître l'instance de document. L'enregistrement d'instance de document est associé à la table dta_indoc_details et affiche les données dans les champs que vous avez configurés à suivre. Pour plus d'informations sur la table dta_indoc_details, voir Tables de métadonnées principales ou Structure des tables de métadonnées principales.

dta_outdoc_details

La table dta_outdoc_details stocke toutes les données de chaque document généré par BizTalk Server. La table dta_outdoc_details pourrait comporter plusieurs enregistrements pour chaque enregistrement contenu dans la table dta_indoc_details parce que plusieurs documents peuvent être générés à partir d'une soumission unique. Par exemple, un document soumis à BizTalk Server pourrait être envoyé à une liste de distribution de 10 ports. Dans ce cas, un enregistrement unique est consigné dans la table dta_indoc_details et 10 enregistrements sont consignés dans la table dta_outdoc_details. Par conséquent, un enregistrement d'échange sortant avec un enregistrement d'instance de document associé apparaît sur la page Résultats de la requête. Les champs dans l'enregistrement d'instance de document sont remplis des données issues de la table dta_outdoc_details. Pour plus d'informations sur la table dta_outdoc_details, voir Tables de métadonnées principales ou Structure des tables de métadonnées principales.

Voir aussi

Consignation des échanges et des documents

Tables de métadonnées principales

Structure des tables de métadonnées principales

Présentation des résultats d'enregistrement d'instance de document

Présentation des résultats d'un enregistrement d'échange

Présentation des résultats d'accusé de réception

Présentation des résultats pour échecs de transmission

Présentation du schéma de la base de données de suivi


Présentation des résultats d'un enregistrement d'échange

En fonction des paramètres de requête que vous spécifiez, un ou plusieurs enregistrements d'échange sont renvoyés, si des correspondances pour vos critères de requête sont trouvées. Un enregistrement d'échange représente un échange soumis à Microsoft BizTalk Server 2002 ou envoyé par celui-ci.

Un échange contient les informations présentées dans le tableau suivant.

En-tête de colonne d'échange | Description
Données | Fournit un lien pour afficher les données d'échange dans leur format natif.
Planification Fournit un lien aux informations d'état de la planification XLANG pour l'échange individuel, s'il est disponible. Si aucune information d'état de planification XLANG n'est associée à l'échange, le message suivant apparaît :

Aucune information de planification XLANG n'est disponible pour cet échange.
Direction | Spécifie si l'échange est soumis à BizTalk Server (entrant) ou envoyé depuis BizTalk Server (sortant).
Erreur Spécifie si des erreurs sont associées au document.

Les messages d'erreur qui peuvent apparaître sont les suivants :

  • Aucune erreur.

  • Impossible d'appeler un composant personnalisé.

  • Impossible d'analyser l'échange.

  • Le canal spécifié n'existe pas.

  • Impossible de sérialiser l'échange.

  • Impossible de coder l'échange.

  • Impossible de signer l'échange.

  • Impossible de crypter l'échange.

  • Échec de la tentative de transmission (une nouvelle tentative est en attente).

  • Échec de la dernière tentative de transmission.

  • Impossible d'analyser le document.

  • Impossible de valider le document.

  • Impossible de trouver un canal valide.

  • Impossible de mapper le document.

  • Impossible de trouver un port d'échanges valide.

  • Impossible de sérialiser le document.
Organisation source | Spécifie le nom de l'organisation source.
Application source | Spécifie l'application d'où provient le document.
Organisation de destination | Spécifie le nom de l'organisation de destination.
Application de destination | Spécifie l'application de destination du document.
Type de document | Spécifie le type du document. S'il y a plusieurs types de document dans un échange, "<Multiple>" apparaît dans ce champ.
Nombre de documents | Spécifie le nombre de documents dans l'échange.
Identificateur de contrôle | Spécifie un numéro de contrôle unique pour les échanges EDI (Échanges de données électroniques) ou un identificateur pour les messages fiable BizTalk.
État de la réception | Spécifie l'état de l'accusé de réception. Les valeurs possibles de l'état de l'accusé de réception sont Aucun, En attente, En retard, Accepté, Accepté avec les erreurs et Rejeté.
Temps de traitement | Indique l'heure à laquelle l'échange a été traité. L'heure est définie au moment de la création des enregistrements de suivi de documents. Une fois que le champ est défini, il n'est pas mis à jour.
Heure d'envoi | Spécifie l'heure à laquelle l'échange a été envoyé si la transmission a abouti. Si la transmission n'a pas abouti, cette valeur est nulle. Pour les transmissions entrantes, ce champ a toujours une valeur nulle.
Qualificateur de l'ID source | Spécifie le type de qualificateur d'organisation source. Il s'agit du qualificateur que BizTalk Server utilise de façon interne.
Identificateur source | Spécifie la valeur de l'identificateur d'organisation source. Il s'agit de l'identificateur source désigné dans les données et utilisé pour router le document. Cette valeur est différente du Qualificateur de l'ID source. Pour plus d'informations sur le routage, voir Consignation des informations de routage.
Qualificateur de l'ID de destination | Spécifie le type de qualificateur d'organisation de destination.
Identificateur de destination | Spécifie la valeur de l'identificateur d'organisation de destination. Pour plus d'informations sur le routage, voir Consignation des informations de routage.

Voir aussi

Principes de base du schéma de la base de données de suivi

Présentation des résultats d'enregistrement d'instance de document

Recherche d'échanges et de documents associés


Présentation des résultats d'enregistrement d'instance de document

Les enregistrements d'instance de document dans un échange prennent la forme d'une ligne de champs décrivant les informations de document.

Les résultats d'enregistrement d'instance de document contiennent les informations présentées dans le tableau suivant.

En-tête de colonne de document | Description
Données | Fournit un lien pour afficher les données qui sont contenues dans l'instance de documents dans son format natif et XML.
ID de suivi | Indique une clé de suivi basée sur un identificateur global unique (GUID).
Type de document | Spécifie le type de document. S'il y a plusieurs documents dans un échange, ce champ spécifie le type de document. Plusieurs types de document ne sont jamais indiqués dans ce champ. Les types de document supplémentaires apparaissent sous la forme d'enregistrements d'instance de document séparés.
Conformité | Indique si le document est valide. Les valeurs possibles pour la compatibilité sont Valide ou Non valide.
Erreur Spécifie si des erreurs sont associées au document. Les messages d'erreur qui peuvent apparaître sont les suivants :
  • Aucune erreur.

  • Impossible d'appeler un composant personnalisé.

  • Impossible d'analyser l'échange.

  • Le canal spécifié n'existe pas.

  • Impossible de sérialiser l'échange.

  • Impossible de coder l'échange.

  • Impossible de signer l'échange.

  • Impossible de crypter l'échange.

  • Échec de la tentative de transmission (une nouvelle tentative est en attente).

  • Échec de la dernière tentative de transmission.

  • Impossible d'analyser le document.

  • Impossible de valider le document.

  • Impossible de trouver un canal valide.

  • Impossible de mapper le document.

  • Impossible de trouver un port d'échanges valide.

  • Impossible de sérialiser le document.
Accusé de réception | Fournit un lien aux informations d'accusé de réception.

Les champs suivants s'appliquent uniquement aux documents sortants.

État de la réception | Spécifie l'état de l'accusé de réception. Les valeurs possibles de l'état de l'accusé de réception sont Aucun, En attente, En retard, Accepté, Accepté avec les erreurs et Rejeté.
Réel 1, Réel 2 | Spécifie les données qui ont été capturées du contenu du document sous forme de nombre réel. Deux champs peuvent contenir des nombres réels.
Entier 1, Entier 2 | Spécifie les données qui ont été capturées du contenu du document sous forme de valeur entière. Deux champs peuvent contenir des entiers.
Date 1, Date 2 | Spécifie les données qui ont été capturées du contenu du document sous forme de valeur de date. Deux champs peuvent contenir des dates.
Chaîne 1, Chaîne 2 | Spécifie les données qui ont été capturées du contenu du document sous forme de valeur de chaîne. Deux champs peuvent contenir des chaînes.
Recherche personnalisée | Indique des données supplémentaires qui ont été capturées sous forme de valeur de chaîne. La limite de ce champ est de 2 Go.

Remarques

  • Pour configurer les informations à suivre dans les documents sortants, voir Sélection de champs de spécification dans une définition de document ou Sélection de champs de spécification dans un canal.

  • Si vous configurez des champs (tels que entiers, réels, chaînes, dates, ou champs personnalisés) dans la définition du document comme facultatifs, si vous configurez ces champs afin qu'ils soient suivis, et si ces champs ne sont pas inclus dans l'instance du document soumis, ces champs n'apparaissent pas dans les résultats de la requête. Suivi de documents BizTalk ne génère pas de message d'erreur ou d'avertissement pour vous indiquer que des données sont absentes dans des champs facultatifs.

  • Lors du suivi des champs de spécifications en tant que type de données Integer, Real, Date ou Text, les noms des champs de spécification dépassant 79 caractères sont tronqués.

    Suivez ces champs de spécifications en tant que type de données Custom. En procédant ainsi, les noms de champ sont regroupés avec leurs valeurs de champ dans une colonne SQL ntext, dont la longueur maximale autorisée est de 2^30 - 1 (1 073 741823) caractères.

Question d'ordre international

  • En fonction de la langue du système, BizTalk Server peut mal interpréter une valeur numérique dans les données XML lorsque celle-ci est enregistrée comme champ de suivi d'entier dans la base de données de suivi. Par exemple, dans une version allemande, la valeur numérique de XML 4.0 est enregistrée en tant que 40 dans la base de données de suivi car le point décimal (.) est interprété à tort comme symbole de regroupement numérique.

    Il existe deux manières de contourner ce problème. Premièrement, si vous savez déjà que la valeur de l'élément ou de l'attribut contient un nombre décimal, vous pouvez modifier le type de données de l'élément ou de l'attribut XML en Real (r4) ou Double Real (r8). Deuxièmement, vous pouvez configurer la définition de document ou le canal en vue de l'enregistrement d'un élément ou d'un attribut avec un type de données Number égal à Real au lieu de Integer.

Voir aussi

Sélection des champs de spécification dans un canal

Sélection des champs de spécification dans une définition de document

Principes de base du schéma de la base de données de suivi

Recherche d'échanges et de documents associés

Présentation des résultats d'un enregistrement d'échange


Présentation des résultats d'accusé de réception

L'illustration suivante montre le flux d'accusé de réception dans Suivi de documents BizTalk. Dans l'illustration, Document 1 est d'abord traité par BizTalk Server A et est indiqué pour attendre un accusé de réception (Document 1, avec indicateur Attendre un accusé de réception activé). Ensuite, BizTalk Server B récupère le document par le biais d'une fonction de réception (Document 1, avec l'indicateur Générer un accusé de réception activé), traite le document, puis génère un accusé de réception [Accusé de réception pour Document 1 (sortant)]. BizTalk Server A reçoit ensuite l'accusé de réception [accusé de réception pour le Document 1 (entrant)].

Flux d'accusé de réception

Lorsque vous affichez l'accusé de réception pour Document 1, Indicateur Attendre accusé de réception activé, vous localisez d'abord l'enregistrement d'échange approprié sur la page Résultats de la requête qui correspond à Document 1, Indicateur Attendre accusé de réception activé. Lorsque vous cliquez sur l'icône Accusé de réception dans le champ Accusé de réception, une nouvelle page Résultats de la requête apparaît. Elle contient l'enregistrement d'échange que BizTalk Server A a généré lorsqu'il a traité Document 1, Indicateur Attendre un accusé de réception activé. Lorsque vous cliquez sur l'icône de données dans la colonne Données, les données qui s'affichent représentent le contenu réel de l'accusé de réception. Dans l'illustration précédente, cette dernière étape correspond à Accusé de réception pour Document 1 (entrant).

Lorsque vous affichez l'accusé de réception pour Document 1, Indicateur Générer un accusé de réception activé, vous localisez d'abord l'enregistrement d'échange approprié dans la page Résultats de la requête qui correspond à Document 1, Indicateur Générer un accusé de réception activé. Lorsque vous cliquez sur l'icône Accusé de réception dans le champ Accusé de réception, une nouvelle page Résultats de la requête apparaît. Elle contient l'enregistrement d'échange que BizTalk Server B a généré lorsqu'il a traité Document 1, Indicateur Générer un accusé de réception activé. Développez l'enregistrement d'échange pour afficher le détail de l'instance de document. Lorsque vous cliquez sur l'icône de données dans le champ Données, les données qui s'affichent représentent le contenu réel de l'accusé de réception. Dans l'illustration précédente, cette dernière étape correspond à Accusé de réception pour Document 1 (sortant).

Remarques

  • L'envoi et la réception d'accusés de réception fonctionnent uniquement avec des analyseurs qui peuvent traiter des accusés de réception. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

  • Les accusés de réception d'échanges de type Reliable ne s'affichent pas dans l'interface utilisateur de Suivi de documents BizTalk.

Voir aussi

Consignations des accusés de réception

Principes de base du schéma de la base de données de suivi


Présentation des résultats pour échecs de transmission

Lorsqu'une transmission échoue, l'incident est consigné dans la base de données de suivi. Cependant, certaines erreurs qui sont consignées dans la base de données de suivi n'apparaissent pas dans l'interface utilisateur de Suivi de documents BizTalk. Des erreurs apparaissent dans l'interface utilisateur uniquement si un enregistrement a été consigné dans la table dta_outdoc_details. Pour plus d'informations sur les tables principales, voir Principes de base du schéma de la base de données de suivi ou Tables de métadonnées principales.

Remarque

  • La base de données de suivi ne consigne aucune erreur d'analyse d'échange lorsque le bas de page de l'échange est incorrect dans un échange EDI. Si un échange contient un document valide mais que le bas de page de l'échange contient des informations incorrectes, le parseur détecte une erreur non fatale et envoie le document à BizTalk Server pour traitement. En revanche, si une erreur est consignée dans l'Observateur d'événements, aucune erreur n'est enregistrée dans la base de données de suivi car celle-ci ne fait pas la différence entre les erreurs fatales ou non.

Le tableau suivant indique les messages d'erreur pouvant être obtenus et précise si des enregistrements sont consignés dans les diverses tables principales de la base de données de suivi.

Message d'erreur | Enregistrements consignés | Commentaires
Aucune erreur | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Les champs appropriés sont consignés dans les trois tables principales.
Impossible d'appeler un composant personnalisé. | Aucun | Cette erreur apparaît uniquement si un préprocesseur personnalisé est associé à une fonction de réception. Aucun enregistrement n'est consigné dans la base de données de suivi.
Impossible d'analyser l'échange. | dta_interchange_details (entrant) | L'échange et les données sont consignés en cas d'erreur d'analyse.
Le canal spécifié n'existe pas. | dta_indoc_details dta_interchange_details (entrant) | Aucun.
Impossible de sérialiser l'échange. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Un enregistrement vide est consigné dans la table dta_interchange_details (sortante). Si l'échange est resoumis et s'il aboutit, l'enregistrement est mis à jour.
Impossible de coder l'échange. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Aucun.
Impossible de signer l'échange. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Aucun.
Impossible de crypter l'échange. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Aucun.
Échec de la tentative de transmission (une nouvelle tentative est en attente). | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Aucun.
Échec de la dernière tentative de transmission. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Aucun.
Impossible d'analyser le document. | dta_indoc_details dta_interchange_details (entrant) | Aucun.
Impossible de valider le document. | dta_indoc_details dta_interchange_details (entrant) | Aucun.
Impossible de trouver un canal valide. | dta_indoc_details dta_interchange_details (entrant) | Aucun.
Impossible de mapper le document. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | L'enregistrement dans la table dta_outdoc_details enregistre l'erreur de consignation, et un enregistrement vide est consigné dans la table dta_interchange_details (sortante).
Impossible de trouver un port d'échanges valide. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | L'enregistrement dans la table dta_outdoc_details enregistre une erreur NoPort, et un enregistrement vide est consigné dans la table dta_interchange_details (sortante).
Impossible de sérialiser le document. | dta_indoc_details dta_interchange_details (entrant) dta_interchange_details (sortant) dta_outdoc_details | Les enregistrements des tables dta_indoc_details et dta_outdoc_details contiennent l'erreur de sérialisation.

Voir aussi

Configuration des propriétés de suivi d'un groupe de serveurs

File d'attente interrompue

Principes de base du schéma de la base de données de suivi

Présentation du schéma de la base de données de suivi


Présentation de l'état de la planification XLANG intégrée pour un échange

Vous pouvez suivre l'état de planifications XLANG associées dans Suivi de documents BizTalk. Les actions dans des planifications sur un serveur peuvent être surveillées et stockées dans les tables appropriées de la base de données de suivi avec un identificateur qui établit une corrélation entre elles et des instances de message spécifiques. Le schéma de stockage dans la base de données de suivi et la corrélation font partie de Microsoft BizTalk Server 2002, mais la fonctionnalité d'abonnement d'événements n'est pas mis en œuvre lorsque vous installez BizTalk Server 2002. Cependant, un exemple d'intégration de suivi est proposé. Après l'installation de BizTalk Server, vous trouverez le code source de cet exemple dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit. En outre, le sous-dossier bin contient la bibliothèque de liaison dynamique (WorkFlowAudit.dll), et le sous-dossier Docs contient la documentation (Readme.txt) de cet exemple. Vous trouverez un exemple d'application client dans le dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient.


Pourquoi utiliser Suivi de documents BizTalk

Cette section explique pourquoi il est nécessaire d'effectuer des tâches spécifiques dans Suivi de documents BizTalk. Le tableau suivant présente les tâches principales et leurs sous-tâches. Il présente également l'objet de chaque tâche et fournit des liens vers les procédures correspondantes.

Tâche Objet de la tâche
  • Ouverture de Suivi de documents BizTalk pour la première fois
 Visualiser la progression des documents traités par Microsoft BizTalk Server 2002. Vous pouvez créer des requêtes ou des requêtes avancées pour extraire des informations essentielles de la base de données de suivi dans un format facile à consulter.
  • Ajout d'utilisateurs au groupe d'utilisateurs d'états de BizTalk Server
 Afficher l'interface utilisateur de Suivi de documents BizTalk et enregistrer les expressions de requête avancée. Pour effectuer ces tâches, vous devez être membre du groupe Utilisateurs d'états de BizTalk Server.
Gestion de la base de données de suivi :
  • Création d'une base de données archive de suivi
 Créer un référentiel dans lequel sont insérées les anciennes instances d'échange et de document pour les conserver en sécurité. La création d'une base de données archive de suivi constitue la première des quatre procédures à effectuer successivement pour installer les utilitaires de gestion de la base de données de suivi.
  • Création du schéma de la base de données archive de suivi
 Pour utiliser la base de données archive de suivi, vous devez créer son schéma. La création du schéma de la base de données archive de suivi constitue la deuxième des quatre étapes à effectuer successivement pour installer les utilitaires de gestion de la base de donnée de suivi.
  • Configuration de la base de données de suivi en tant que serveur SQL lié
 Archiver la base de données de suivi et la relier à la base de données archive de suivi. Vous devez configurer les deux bases de données, dans la mesure où elles se trouvent sur différentes bases de données. La configuration de la base de données de suivi constitue la troisième des quatre procédures à effectuer successivement pour installer les utilitaires de gestion de la base de données de suivi.
  • Installation des procédures stockées dans la base de données de suivi
 Pour archiver et/ou supprimer d'anciens enregistrements d'instance d'échange et de document, vous devez installer des procédures stockées spécifiques dans la base de données de suivi. L'installation des procédures stockées dans la base de données de suivi constitue la dernière des quatre procédures à effectuer successivement pour installer les utilitaires de gestion de la base de données de suivi.
  • Utilisation des procédures stockées pour l'archivage et la suppression dans la base de données de suivi
 Pour archiver et/ou supprimer d'anciens enregistrements d'instance d'échange et de document, vous devez utiliser des procédures stockées spécifiques dans la base de données de suivi.
Utilisation des requêtes pour rechercher et trier les données d'échange et de document :
  • Recherche par date des informations relatives aux documents et aux échanges
 Utiliser des requêtes afin de rechercher, visualiser et enregistrer des enregistrements d'instance d'échange et de document ainsi que les données associées en utilisant des critères de recherche standard, tels la date.
  • Recherche par organisation des informations relatives aux documents et aux échanges
 Utiliser des requêtes afin de rechercher, visualiser et enregistrer des enregistrements d'instance d'échange et de document ainsi que les données associées en utilisant des critères de recherche standard, tels l'organisation source.
  • Recherche par type de document des informations relatives aux documents et aux échanges
 Utiliser des requêtes afin de rechercher, visualiser et enregistrer des enregistrements d'instance d'échange et de document ainsi que les données associées en utilisant des critères de recherche standard, tels les informations de document.
  • Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête
 Réunir les paramètres de requête suivants dans une seule session de requête afin de rechercher, visualiser et enregistrer des enregistrements d'instance d'échange et de documents ainsi que les données associées : les sélections de la source et de la destination, le type de document et la date et l'heure.
  • Annulation des critères de recherche pour les organisations et les types de documents
 Annuler tous les critères de recherche et retourner à la recherche par défaut pour toutes les organisations source et de destination et tous les types de document.
  • Personnalisation de la page Résultats de la requête
 Afficher et trier les échanges entrants regroupés avec les échanges sortants associés.
  • Affichage des paramètres de recherche pour la page Résultats de la requête
 Afficher les paramètres de recherche suivants et leurs valeurs associées : Plage de dates, Fuseau horaire, Nom d'expression, Ordre de tri, Sélection de l'organisation et Sélection du type de document.
Utilisation de requêtes avancées :
  • Création de requêtes avancées
 Rechercher des données spécifiques, telles qu'une instance de document comportant un numéro de bon de commande particulier.
  • Localisation de requêtes avancées existantes
 Charger et réutiliser des requêtes avancées existantes que vous avez précédemment créées et enregistrées.
  • Édition de requêtes avancées existantes
 Ajouter, modifier ou supprimer des conditions spécifiques afin d'affiner la recherche de documents.
  • Effacement de requêtes avancées existantes
 Pour effacer une requête avancée existante, vous devez supprimer l'expression courante.
  • Suppression de requêtes avancées existantes
 Si vous n'avez plus besoin de certaines requêtes avancées précréées, vous pouvez les sélectionner et les supprimer afin de conserver une liste de requêtes avancées plus petite.
Enregistrement d'un échange, d'un document et de données de recherche personnalisée :
  • Enregistrement des données d'échanges
 Pour afficher les données hors connexion. Cela simplifie le dépannage de certaines situations ou l'analyse de vos pratiques professionnelles.
  • Enregistrement des données d'une instance de document
 Pour afficher les données hors connexion. Cela simplifie le dépannage de certaines situations ou l'analyse de vos pratiques professionnelles.
  • Enregistrement des données du champ de recherche personnalisée
 Pour afficher les données hors connexion. Cela simplifie le dépannage de certaines situations ou l'analyse de vos pratiques professionnelles.


Comment utiliser Suivi de documents BizTalk

Cette section fournit des informations spécifiques de tâches indiquant comment rechercher, visualiser et enregistrer des résultats de recherche d'enregistrements d'instance d'échange et de document, et des données associées. Il est vivement recommandé de relire la section À propos de Suivi de documents BizTalk pour bien comprendre les possibilités de recherche et les résultats de requête attendus.

Suivi de documents BizTalk possède deux niveaux de possibilité de recherche : les requêtes et les requêtes avancées. Vous pouvez utiliser des requêtes lorsque vous souhaitez localiser des documents en employant des critères de recherche standard, par exemple une organisation source. Vous pouvez utiliser des requêtes avancées lorsque vous souhaitez localiser des données spécifiques dans des documents, par exemple un total de bon de commande.

Cette section traite des procédures suivantes :

  • Ouverture du Suivi de documents BizTalk pour la première fois

  • Ouverture de Suivi de documents BizTalk

  • Ajout d'utilisateurs au groupe d'utilisateurs d'états de BizTalk Server
  • Gestion de la base de données de suivi

  • Utilisation des requêtes pour rechercher et trier les données d'échange et de document

  • Utilisation de requêtes avancées

  • Enregistrement d'un échange, d'un document et de données de recherche personnalisée


Ouverture de Suivi de documents BizTalk pour la première fois

Si vous ouvrez Suivi de documents BizTalk pour la première fois et si vous n'avez pas installé sur votre ordinateur Contrôles communs Microsoft et le contrôle de Suivi de documents BizTalk, un message vous invite à installer les composants. Si vous avez installé ces composants sur votre ordinateur, voir Ouverture de Suivi de documents BizTalk

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Suivi de documents BizTalk.

    La boîte de dialogue Dialogue de page Web s'ouvre pour vous inviter à installer les composants suivants :

    • Contrôles communs Windows ;

    • contrôle d'installation de Suivi de documents BizTalk.
  2. Cliquez sur Continuer pour installer les contrôles communs Windows.

    La boîte de dialogue Avertissement de sécurité s'ouvre.

  3. Cliquez sur Oui pour installer le contrôle d'installation de Suivi de documents BizTalk.

Remarque

  • Lors d'une sélection ou d'une sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé dans la zone Sites de confiance sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, voir Configuration des paramètres IIS de BizTalk Server 2002.

Voir aussi

Configuration des paramètres IIS de BizTalk Server 2002

Ouverture de Suivi de documents BizTalk


Ouverture de Suivi de documents BizTalk

  • Dans le menu Démarrer, pointez sur Programmes, sur Microsoft BizTalk Server 2002, puis cliquez sur Suivi de documents BizTalk.

    — ou —

    Si vous avez créé un favori dans Microsoft Internet Explorer, vous pouvez ouvrir Suivi de documents BizTalk à partir de Internet Explorer.

Remarque

  • Lors d'une sélection ou d'une sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé dans la zone Sites de confiance sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, voir Configuration des paramètres IIS de BizTalk Server 2002.

Voir aussi

Configuration des paramètres IIS de BizTalk Server 2002

Ouverture du Suivi de documents BizTalk pour la première fois


Ajout d'utilisateurs au groupe des utilisateurs d'état de BizTalk Server

Pour visualiser l'interface utilisateur de Suivi de documents BizTalk et enregistrer des expressions de requête avancée, vous devez être membre du groupe d'utilisateurs d'états de BizTalk Server. En outre, votre compte d'utilisateur doit être ajouté au compte de connexion SQL Server et être doté des rôles publics db_owner et dta_ui_role dans la base de données de suivi (InterchangeDTA). Pour plus d'informations sur la définition des comptes de connexion SQL Server et la création des autorisations de base de données, voir Interactions entre les bases de données SQL Server et BizTalk Server 2002.

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Gestion de l'ordinateur.

  2. Développez Outils système, Utilisateurs et groupes locaux, puis cliquez sur le dossier Groupes.

  3. Dans le volet de détails, cliquez sur Utilisateurs d'états de BizTalk Server.

  4. Dans le menu Action, pointez sur Toutes les tâches, puis cliquez sur Ajouter au groupe.

    La boîte de dialogue Propriétés des utilisateurs d'états de BizTalk Server s'ouvre.

  5. Cliquez sur Ajouter.

  6. Dans la liste Regarder dans, cliquez sur votre domaine ou le nom de votre ordinateur.

  7. Dans la liste contenant les utilisateurs et les ordinateurs associés au domaine ou à l'ordinateur que vous avez sélectionné à l'étape 6, cliquez sur le compte utilisateur à ajouter, sur Ajouter, puis sur OK.

  8. Cliquez sur OK pour fermer la boîte de dialogue Propriétés des utilisateurs d'états de BizTalk Server.


Gestion de la base de données de suivi

BizTalk Server offre plusieurs utilitaires destinés à la gestion de la base de données de suivi. Lors de l'installation de BizTalk Server, les fichiers appropriés sont copiés dans le dossier \Program Files\Microsoft BizTalk Server\Setup. Pour activer les utilitaires, suivez les instructions figurant dans cette section.

Remarque

  • Si vous ne suivez pas les échanges et les documents dans votre installation BizTalk Server ou si vous n'utilisez pas les scripts SQL inclus dans BizTalk Server pour archiver et purger votre base de données de suivi, vous pouvez ignorer cette section.

Pour utiliser les utilitaires nécessaires à la gestion de la base de données de suivi, exécutez les procédures suivantes, dans l'ordre :

Cette section traite des procédures suivantes :

  • Création d'une base de données archive de suivi

  • Création du schéma de la base de données archive de suivi

  • Configuration de la base de données de suivi en tant que serveur SQL lié

  • Installation des procédures stockées dans la base de données de suivi

  • Utilisation des procédures stockées pour l'archivage et la suppression dans la base de données de suivi

Important

  • Si vous ne parvenez pas à exécuter les procédures qui suivent, vérifiez que le compte d'utilisateur utilisé pour vous connecter au serveur exécutant Microsoft® SQL Server™ dispose des autorisations suffisantes pour créer des procédures stockées et des travaux de l'Agent SQL Server.

  • Le nom par défaut de la base de données de suivi est InterchangeDTA. Si le nom de votre base de données de suivi est différent, vous devez remplacer toutes les instances de la chaîne InterchangeDTA dans le script BTS_Tracking_Archive_Purge_Script.sql par le nom de votre base de données de suivi.

Remarques

  • Pour éviter de gaspiller l'espace disque, il est recommandé d'activer l'option Vider le journal au point de contrôle. Pour plus d'informations sur la configuration de cette option, voir Éviter l'allocation d'espace disque inutile.

  • Pour plus d'informations sur les procédures stockées qui gèrent l'utilitaire de base de données de suivi, Utilisation des procédures stockées pour l'archivage et la suppression dans la base de données de suivi.


Création d'une une base de données archive de suivi

BizTalk Server 2002 ~ Suivi de documents

Création d'une base de données archive de suivi

Effectuez les étapes suivantes sur le serveur qui va héberger la base de données archive de suivi.

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft SQL Server, puis cliquez sur Enterprise Manager.

  2. Développez Serveurs Microsoft SQL et Groupe SQL Server, puis cliquez sur le serveur sur lequel vous voulez créer une base de données archive de suivi.

  3. Dans le menu Action, pointez sur Nouveau, puis cliquez sur Base de données.

  4. Dans la boîte de dialogue Propriétés de la base de données, tapez un nom pour la base de données archive de suivi, puis cliquez sur OK.


Création du schéma de la base de données archive de suivi

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft SQL Server, puis cliquez sur Analyseur de requêtes.

  2. Dans la liste SQL Server, cliquez sur le nom du serveur SQL Server qui va héberger la base de données archive de suivi que vous venez de créer dans la section Création d'une base de données archive de suivi, entrez les informations de connexion appropriées, puis cliquez sur OK.

  3. Si vous disposez de Microsoft SQL Server 7.0, dans la liste des bases de données, cliquez sur le nom de la base de données de suivi et passez à l'étape 5.

    — ou —

    Si vous disposez de Microsoft SQL Server 2000, dans le menu Requête, cliquez sur Modifier la base de données.

  4. Cliquez sur le nom de la base de données archive de suivi, puis sur OK.

  5. Dans le menu Fichier, cliquez sur Ouvrir.

  6. Dans la liste Rechercher dans de la boîte de dialogue Ouvrir le fichier requête, recherchez \Program Files\Microsoft BizTalk Server\Setup.

  7. Cliquez sur BTS_Tracking_ArchiveDB_Schema.sql, puis sur Ouvrir.

  8. Dans le menu Requête, cliquez sur Exécuter.


Configuration de la base de données archive de suivi en tant que serveur SQL lié

Effectuez les étapes suivantes sur le serveur SQL Server qui héberge la base de données de suivi.

  1. Vérifiez que l'Analyseur de requêtes est ouvert.

  2. Dans le menu Fichier, cliquez sur Déconnecter.

  3. Dans le menu Fichier, cliquez sur Connecter.

  4. Dans la liste SQL Server, cliquez sur le nom du serveur SQL Server qui héberge la base de données de suivi à archiver, entrez les informations de connexion appropriées, puis cliquez sur OK.

  5. Si vous disposez de Microsoft SQL Server 7.0, dans la liste des bases de données, cliquez sur le nom de la base de données de suivi que vous voulez archiver et passez à l'étape 7.

    Exemple : InterchangeDTA

    — ou —

    Si SQL Server 2000 est installé, dans le menu Requête, cliquez sur Modifier la base de données.

  6. Cliquez sur le nom de la base de données de suivi, puis sur OK.

    Exemple : InterchangeDTA

    Remarque

    • Vérifiez que la base de données de suivi est sélectionnée et non la base de données archive de suivi.
  7. Configurez la base de données archive de suivi comme serveur SQL lié.

    L'exemple suivant est une instruction SQL pour configurer un serveur lié. Un serveur de bases de données distant appelé « Seattle2 » est un serveur lié sur le serveur SQL Server local :

    EXEC sp_addlinkedserver N'Seattle2',
 N'SQL Server'N'SQL Server'
  8. Si nécessaire, configurez un mappage entre les connexions des serveurs SQL Server liés locaux et distants.

    L'exemple suivant est une instruction SQL pour créer un mappage entre la connexion de l'administrateur système (sa) sur l'ordinateur local et les serveurs SQL Server liés distants. Dans cet exemple, le mot de passe de la connexion sa distante est « abc123 ».

    EXEC sp_addlinkedsrvlogin '<Nom du serveur SQL distant>',
 'FALSE', 'sa', 'sa', 'abc123'

Important

  • Si la base de données de suivi et la base de données archive de suivi sont toutes les deux sur le même serveur SQL Server, il est inutile de configurer des serveurs liés. Si, en revanche, elles sont configurées sur deux serveurs SQL séparés, il est important de les configurer toutes les deux en tant que serveurs liés. Dans cette instance, les serveurs liés doivent être configurés pour la procédure stockée dta_purge_old_records afin de pouvoir archiver (INSERT) les anciens enregistrements dans la base de données archive de suivi distante. Si vous souhaitez purger uniquement les enregistrements, la liaison des serveurs n'est pas nécessaire.

  • Le nom par défaut de la base de données de suivi est InterchangeDTA. Si le nom de votre base de données de suivi est différent, vous devez remplacer toutes les instances de la chaîne InterchangeDTA dans le script BTS_Tracking_Archive_Purge_Script.sql par le nom de votre base de données de suivi.

Remarque

  • Si le compte de l'administrateur système n'a pas de mot de passe, il faut impérativement utiliser une chaîne vide (''). Pour des raisons de sécurité, cette configuration est déconseillée.


Installation des procédures stockées dans la base de données de suivi

Effectuez les étapes suivantes sur le serveur SQL Server qui héberge la base de données de suivi. Ce serveur doit être celui que vous avez configuré dans la procédure précédente.

  1. Vérifiez que l'Analyseur de requêtes est ouvert.

  2. Dans le menu Fichier, cliquez sur Ouvrir.

  3. Dans la liste Rechercher dans de la boîte de dialogue Ouvrir le fichier requête, recherchez \Program Files\Microsoft BizTalk Server\Setup.

  4. Cliquez sur BTS_Tracking_Archive_Purge_Script.sql, puis sur Ouvrir.

  5. Dans le menu Requête, cliquez sur Exécuter.

    Le script crée une procédure stockée appelée dta_purge_old_records. Il crée un travail de l'Agent SQL Server appelé « Archiver et purger la base de données de suivi BizTalk : <Nom de votre base de données de suivi> ». Par défaut, le travail de l'Agent SQL Server n'est pas activé.

  6. Si nécessaire, ouvrez Enterprise Manager.

  7. Développez successivement Serveurs Microsoft SQL, Groupe SQL Server, le serveur contenant la base de données de suivi, Gestion, Agent SQL Server, puis cliquez sur Travaux.

  8. Dans le volet de détails, cliquez sur Archiver et purger la base de données de suivi BizTalk : <Nom de votre base de données de suivi>.

  9. Dans le menu Action, cliquez sur Propriétés.

  10. Dans l'onglet Étapes, vérifiez que la procédure dtaStep_execute_stored_proc est sélectionnée, puis cliquez sur Modifier.

  11. Dans l'onglet Général de la boîte de dialogue Modifier les étapes du travail, définissez les paramètres d'entrée dans la zone Commande.

    Voici quelques exemples de configuration des paramètres d'entrée passés à la procédure stockée dta_purge_old_records. Pour plus d'informations sur la syntaxe et les arguments de cette procédure stockée, voir Utilisation des procédures stockées pour l'archivage et la suppression dans la base de données de suivi.

    • Pour supprimer sans archiver tous les échanges et documents traités complètement et antérieurs à une journée, modifiez le travail comme suit :
      USE InterchangeDTAUSE InterchangeDTA
EXEC dta_purge_old_records 1, 24, 1,0EXEC dta_purge_old_records 1, 24, 1,0
    • Pour archiver et supprimer tous les échanges indépendamment de savoir s'ils sont traités complètement ou non, sauf pour les 1 000 derniers échanges, modifiez le travail comme suit :
      USE InterchangeDTAUSE InterchangeDTA
EXEC dta_purge_old_records 2, 1000, 0, 1,EXEC dta_purge_old_records 2, 1000, 0, 1,
 N'<Name of a SQL Server>',N'<Nom du serveur SQL>',
 N'<Name of the archive Tracking database>'N'<Nom de la base de données archive de suivi>'
  12. Cliquez sur OK.

  13. Dans l'onglet Planifications, vérifiez que la planification Archiver et purger de BizTalk Server est sélectionnée et cliquez sur Modifier.

  14. Dans la boîte de dialogue Modifier la planification des travaux, cliquez sur Modifier dans la zone Type de planification.

  15. Dans la boîte de dialogue Modifier la planification périodique du travail, modifiez à votre convenance l'occurrence, la fréquence et la durée du travail de l'Agent SQL Server et cliquez sur OK.

  16. Dans l'onglet Général, activez la case à cocher Activé et cliquez sur OK.

    Les modifications sont enregistrées et le travail de l'Agent SQL Server est activé.

Remarque

  • Dans cette procédure, le dossier d'installation de BizTalk Server 2002 est \Program Files\Microsoft BizTalk Server. Si vous avez installé BizTalk Server 2000 dans un autre dossier, les chemins d'accès peuvent différer de ceux indiqués ici.


Utilisation des procédures stockées pour l'archivage et la suppression dans la base de données de suivi

Cette section décrit la syntaxe et les arguments des scripts SQL de la base de données de suivi.

Syntaxe

Le code suivant est la syntaxe utilisée dans la procédure stockée dta_purge_old_records :

[ @nPurgeType = ] nPurgeType,
[ @nPurgeValue = ] nPurgeValue,
[ @nCompletedInterchangesOnly = ] nCompletedInterchangesOnly,
[ @nArchiveFlag = ] nArchiveFlag
[ , [ @nvcArchiveDBServer = ] N'nvcArchiveDBServer' ]
[ , [ @nvcArchiveDBName = ] N'nvcArchiveDBName' ]

Arguments

Voici les arguments utilisés dans la syntaxe :

[ @nPurgeType = ] nPurgeType

L'argument [ @nPurgeType = ] nPurgeType est une valeur d'entier indiquant si les échanges sont sélectionnés pour la suppression par date ou par nombre de lignes. Si nPurgeType a pour valeur 1, les enregistrements sont supprimés par date. Si nPurgeType a pour valeur 2, les enregistrements sont supprimés par nombre de lignes.

[ @nPurgeValue = ] nPurgeValue

L'argument [ @nPurgeValue = ] nPurgeValue est une valeur d'entier. Sa signification dépend de la valeur de nPurgeType.

Si la valeur de nPurgeType est 1, nPurgeValue représente le nombre d'heures à soustraire de CURRENT_TIMESTAMP pour déterminer la façon d'archiver des échanges antérieurs à une date et une heure données. Par exemple, si vous spécifiez 96 comme valeur de nPurgeValue, vous archivez les échanges antérieurs à 96 heures (quatre jours).

Si la valeur de nPurgeType est 2, nPurgeValue représente le nombre d'échanges qui restent dans la base de données une fois les enregistrements archivés et supprimés de celle-ci. Par exemple, la spécification de 25 000 provoque l'archivage de tous les échanges de moins de 25 000 lignes.

[ @nCompletedInterchangesOnly = ] nCompletedInterchangesOnly

L'argument [ @nCompletedInterchangesOnly = ] nCompletedInterchangesOnly est une valeur d'entier qui définit si les échanges demandant un traitement supplémentaire sont supprimés ou non de la base de données. Par exemple, certains échanges ou documents peuvent attendre un accusé de réception ou doivent être renvoyés.

Si vous attribuez la valeur 0 à l'argument nCompletedInterchangesOnly, le travail de purge supprime les échanges et les documents, que ceux-ci aient besoin ou non d'un traitement supplémentaire. Le travail de purge est plus rapide car il y a moins de filtrage.

Si vous attribuez la valeur 1 à l'argument nCompletedInterchangesOnly, le travail de purge ne supprime pas les échanges et les documents nécessitant un traitement supplémentaire. Le travail de purge est moins rapide car le filtrage est plus important.

[ @nArchiveFlag = ] nArchiveFlag

L'argument [ @nArchiveFlag = ] nArchiveFlag est une valeur d'entier indiquant si la procédure stockée doit archiver les enregistrements d'échanges et de documents avant de les supprimer. Si la valeur de l'argument nArchiveFlag est 0, la procédure stockée n'archive aucun enregistrement d'échange ou de document. Si la valeur de l'argument nArchiveFlag est 1, la procédure stockée archive les enregistrements d'échange et de document avant qu'ils ne soient supprimés de la base de données.

[ @nvcArchiveDBServer = ] nvcArchiveDBServer

L'argument [ @nvcArchiveDBServer = ] nvcArchiveDBServer est facultatif. Configurez-le si vous affectez la valeur 1 à l'argument nArchiveFlag. Cet argument est un type de données nvarchar(128) ; il spécifie le nom du serveur de base de données sur lequel la procédure stockée archive les enregistrements d'échange et de document.

[ @nvcArchiveDBName = ] nvcArchiveDBName

L'argument [ @nvcArchiveDBName = ] nvcArchiveDBName est facultatif. Configurez-le si vous affectez la valeur 1 à l'argument nArchiveFlag. Cet argument est un type de données nvarchar(128) ; il spécifie le nom de la base de données dans laquelle la procédure stockée archive les enregistrements d'échange et de document.


Utilisation des requêtes pour rechercher et trier les données d'échange et de document

Vous pouvez utiliser des requêtes pour localiser, visualiser et enregistrer des enregistrements d'instance d'échange et de document ainsi que les données associées en utilisant des critères de recherche standard, tels un type de document ou une organisation source.

Cette section traite des procédures suivantes :

  • Recherche par date des informations relatives aux documents et aux échanges

  • Recherche par organisation des informations relatives aux documents et aux échanges

  • Recherche par type de document des informations relatives aux documents et aux échanges

  • Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

  • Annulation des critères de recherche pour les organisations et les types de document

  • Personnalisation de la page Résultats de la requête

  • Affichage des paramètres de recherche pour la page Résultats de la requête

Remarques

  • Lorsque vous sélectionnez les paramètres de requête, soyez le plus spécifique possible. Cela réduit la charge sur le serveur et le temps requis pour renvoyer les résultats de la requête.

  • Lors d'une sélection ou d'une sélection de requête, une boîte de dialogue peut afficher le message suivant :

    Cette page utilise des données situées dans un autre domaine. Voulez-vous continuer ?

    Pour éviter de recevoir ce message dans Internet Explorer, vous pouvez ajouter un site Web sécurisé dans la zone Sites de confiance sous l'onglet Sécurité de la boîte de dialogue Options Internet.

    Pour configurer manuellement les paramètres de votre navigateur afin de faire confiance à cette application Web, ajoutez l'application Web à la liste des sites fiables dans Internet Explorer. Pour plus d'informations sur l'ajout d'une application Web à la liste des sites fiables, voir Configuration des paramètres IIS de BizTalk Server 2002.

  • Si vous configurez un format non standard de date, de nombre, d'heure et de devise dans les Options régionales du Panneau de configuration, il est possible que vous ne puissiez ni enregistrer une nouvelle requête, ni afficher les requêtes avancées que vous avez enregistrées. Pour plus d'informations, voir Utilisation des requêtes avancées.

    Pour afficher les requêtes avancées existantes, choisissez uniquement les options disponibles dans les listes des Options régionales. Par exemple, dans l'onglet Date, dans la liste Format de date courte, choisissez les options figurant dans la liste. Évitez de taper, de copier et de coller les autres formats de la liste Format de date courte.


Recherche par date des informations relatives aux documents et aux échanges

  1. Dans Suivi de documents BizTalk, dans la zone Plage de dates, dans la liste Afficher les dates en, cliquez sur Heure locale ou UTC pour spécifier le fuseau horaire des dates d'affichage.

  2. Dans la liste Date de début, tapez la date de début de la période à suivre ou cliquez sur la flèche pour afficher un calendrier dans lequel vous pouvez sélectionner une date.

    Pour changer l'heure, tapez l'heure de début dans la liste en regard de la liste Date de début ou cliquez sur la flèche vers le haut ou vers le bas.

  3. Dans la liste Date de fin, tapez la date de fin de la période à suivre, ou cliquez sur la flèche pour afficher un calendrier dans lequel vous pouvez sélectionner une date.

    Pour changer l'heure, tapez l'heure de fin dans la liste en regard de la liste Date de fin ou cliquez sur la flèche vers le haut ou vers le bas.

  4. Cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

  5. Pour afficher les données d'échange, recherchez l'emplacement de l'enregistrement de l'échange contenant les données à afficher puis, dans la colonne Données, cliquez sur l'icône de données correspondante.

    La page Afficher les données d'échange s'affiche.

  6. Pour afficher l'état d'une planification XLANG pour un échange, dans la colonne Planification, cliquez sur une icône de planification.

    La page Afficher le résumé de la planification s'affiche.

  7. Pour afficher un enregistrement d'une instance de document associé à un échange, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange contenant l'enregistrement de l'instance de document à afficher.

  8. Pour afficher les données associées à une instance de document, dans le champ Données, cliquez sur une icône de données.

    La page Afficher les données d'instance du document s'affiche.

  9. Pour afficher les données dans leur format natif ou XML, cliquez sur Afficher le format natif ou Afficher le format XML.

  10. Pour afficher les données d'accusé de réception associées à une instance de document, dans le champ Accusé de réception, cliquez sur l'icône Accusé de réception.

    Une nouvelle page Résultats de la requête s'affiche.

  11. Cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange, puis cliquez sur l'icône de données dans le champ Données.

  12. Pour afficher les données du champ de recherche personnalisée pour une instance de document, recherchez le document pour lequel vous voulez les afficher, utilisez la barre de défilement horizontal pour afficher le champ Recherche personnalisée, puis cliquez sur l'icône Recherche personnalisée.

    La page Afficher le champ de recherche personnalisée s'affiche.

Remarques

  • La valeur que vous sélectionnez dans la liste Afficher les dates en contrôle l'intervalle de recherche et les résultats d'affichage. Par exemple, si vous sélectionnez UTC dans la liste Afficher les dates en puis spécifiez 0800 dans le champ d'heure, vous recherchez toutes les données traitées à ou après 0800 heures en heure universelle coordonnée (UTC). Cela est différent de 0800 heure locale.

  • La valeur de date par défaut est antérieure de sept jours à la date actuelle.

  • Les dates affichées sont les horodatages générés par BizTalk Server sur les métadonnées des instances de document et des échanges. Ce ne sont pas les dates du contenu réel du document. Pour localiser des documents en fonction de la date réelle du document, créez une expression Requête avancée. Pour plus d'informations sur les requêtes avancées, voir Création de requêtes avancées.

  • Si vous spécifiez uniquement une plage de dates dans une requête, Suivi de documents BizTalk recherche toutes les organisations source et de destination et tous les types de document. Il n'est pas recommandé d'utiliser ce paramètre de recherche unique. Pour optimiser les résultats, créez toujours une requête avec des paramètres très spécifiques afin de limiter les enregistrements d'échange renvoyés sur la page Résultats de la requête.

  • L'état de la planification XLANG est le dernier événement détecté, l'heure de début du traitement, l'heure de fin du traitement, etc.

  • Si Microsoft Internet Explorer 5 est installé sur votre ordinateur, lorsque vous affichez les données d'instance du document, le pointeur peut apparaître sous la forme d'un sablier au lieu d'une flèche ou d'un signe |. Dans ce cas, vous pouvez toujours sélectionner Afficher le format natif ou Afficher le format XML, ou bien cliquer sur les boutons Enregistrer sous et Fermer. Si vous évoluez vers Microsoft Internet Explorer 5.5, le pointeur apparaît sous la forme d'une flèche ou d'un signe |.

Voir aussi

Création de requêtes avancées

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges

Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

Présentation des résultats d'enregistrement d'instance de document

Présentation des résultats d'un enregistrement d'échange

Présentation des requêtes


Recherche par organisation des informations relatives aux documents et aux échanges

  1. Dans Suivi de documents BizTalk, dans la liste Sélection de la source, cliquez sur l'organisation ou les organisations pour lesquelles vous souhaitez voir des échanges et des documents. Pour sélectionner une application associée à une organisation source, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'organisation, puis cliquez sur l'application ou les applications souhaitées. Pour sélectionner toutes les organisations source, cliquez sur Sélectionner tout.

    — ou —

    Dans Suivi de documents BizTalk, dans la liste Sélection de la destination, cliquez sur l'organisation ou les organisations pour lesquelles vous souhaitez voir des échanges et des documents. Pour sélectionner une application associée à une organisation de destination, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'organisation, puis cliquez sur l'application ou les applications souhaitées. Pour sélectionner toutes les organisations de destination, cliquez sur Sélectionner tout.

    Vous pouvez choisir des organisations et des applications dans les listes Sélection de la source et Sélection de la destination pour la même requête.

  2. Cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche. Tous les échanges qui correspondent à vos critères de requête sont indiqués ici.

  3. Pour afficher les données d'échange, recherchez l'emplacement de l'enregistrement de l'échange contenant les données à afficher puis, dans la colonne Données, cliquez sur une icône de données.

    La page Afficher les données d'échange s'affiche.

  4. Pour afficher l'état d'une planification XLANG pour un échange, dans la colonne Planification, cliquez sur une icône de planification.

    La page Afficher le résumé de la planification s'affiche.

  5. Pour afficher un enregistrement d'une instance de document associé à un échange, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange contenant les enregistrements de l'instance de document à afficher.

  6. Pour afficher les données associées à une instance de document, dans le champ Données, cliquez sur une icône de données.

    La page Afficher les données d'instance du document s'affiche.

  7. Pour afficher les données dans leur format natif ou XML, cliquez sur Afficher le format natif ou Afficher le format XML.

  8. Pour afficher les données d'accusé de réception associées à une instance de document, dans le champ Accusé de réception, cliquez sur l'icône Accusé de réception.

    Une nouvelle page Résultats de la requête s'affiche.

  9. Cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange, puis cliquez sur l'icône Données dans le champ Données.

  10. Pour afficher les données du champ de recherche personnalisée pour une instance de document, recherchez le document pour lequel vous voulez les afficher, utilisez la barre de défilement horizontal pour afficher le champ Recherche personnalisée, puis cliquez sur l'icône Recherche personnalisée.

    La page Afficher le champ de recherche personnalisée s'affiche.

Remarques

  • Si vous ne sélectionnez pas des organisations source et de destination, la requête renvoie des enregistrements d'échange et de document pour toutes les organisations source et de destination. Les options Effacer tout et Sélectionner tout génèrent les mêmes résultats sur la page Résultats de la requête. Pour optimiser les résultats, créez toujours une requête avec des paramètres très spécifiques afin de limiter le nombre d'enregistrements d'échange générés sur la page Résultats de la requête.

  • L'état de la planification XLANG est le dernier événement détecté, l'heure de début du traitement, l'heure de fin du traitement, etc.

  • Si Microsoft Internet Explorer 5 est installé sur votre ordinateur, lorsque vous affichez les données d'instance du document, le pointeur peut apparaître sous la forme d'un sablier au lieu d'une flèche ou d'un signe |. Dans ce cas, vous pouvez toujours sélectionner Afficher le format natif ou Afficher le format XML, ou bien cliquer sur les boutons Enregistrer sous et Fermer. Si vous évoluez vers Microsoft Internet Explorer 5.5, le pointeur apparaît sous la forme d'une flèche ou d'un signe |.

Voir aussi

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

Présentation des résultats d'enregistrement d'instance de document

Présentation des résultats d'un enregistrement d'échange

Présentation des requêtes


Recherche par type de document des informations relatives aux documents et aux échanges

  1. Dans Suivi de documents BizTalk, dans la zone Sélection du type de document, cliquez sur Afficher les documents.

  2. Dans la liste Sélection du type de document, cliquez sur le ou les types de document à rechercher. Pour sélectionner tous les types de document, cliquez sur Sélectionner tout.

  3. Cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

  4. Pour afficher les données d'échange, recherchez l'emplacement de l'enregistrement de l'échange contenant les données à afficher puis, dans la colonne Données, cliquez sur une icône de données.

    La page Afficher les données d'échange s'affiche.

  5. Pour afficher l'état d'une planification XLANG pour un échange, dans la colonne Planification, cliquez sur une icône de planification.

    La page Afficher le résumé de la planification s'affiche.

  6. Pour afficher un enregistrement d'une instance de document associé à un échange, cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange contenant les enregistrements de l'instance de document à afficher.

  7. Pour afficher les données associées à une instance de document, dans le champ Données, cliquez sur une icône de données.

    La page Afficher les données d'instance du document s'affiche.

  8. Pour afficher les données dans leur format natif ou XML, cliquez sur Afficher le format natif ou Afficher le format XML.

  9. Pour afficher les données d'accusé de réception associées à une instance de document, dans le champ Accusé de réception, cliquez sur l'icône Accusé de réception.

    Une nouvelle page Résultats de la requête s'affiche.

  10. Cliquez sur l'icône de l'indicateur de développement (+) en regard de l'échange, puis cliquez sur l'icône Données dans le champ Données.

  11. Pour afficher les données du champ de recherche personnalisée pour une instance de document, recherchez le document pour lequel vous voulez les afficher, utilisez la barre de défilement horizontal pour afficher le champ Recherche personnalisée, puis cliquez sur l'icône Recherche personnalisée.

    La page Afficher le champ de recherche personnalisée s'affiche.

Remarques

  • Si vous ne sélectionnez pas un ou plusieurs types de documents pour cibler la recherche, la requête renvoie tous les types de document dans la liste. Pour optimiser les résultats, créez toujours une requête avec des paramètres très spécifiques afin de limiter le nombre d'enregistrements d'échange générés sur la page Résultats de la requête.

  • L'état de la planification XLANG est le dernier événement détecté, l'heure de début du traitement, l'heure de fin du traitement, etc.

  • Si Microsoft Internet Explorer 5 est installé sur votre ordinateur, lorsque vous affichez les données d'instance du document, le pointeur peut apparaître sous la forme d'un sablier au lieu d'une flèche ou d'un signe |. Dans ce cas, vous pouvez toujours sélectionner Afficher le format natif ou Afficher le format XML, ou bien cliquer sur les boutons Enregistrer sous et Fermer. Si vous évoluez vers Microsoft Internet Explorer 5.5, le pointeur apparaît sous la forme d'une flèche ou d'un signe |.

Voir aussi

Recherche par date des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges

Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

Présentation des résultats d'enregistrement d'instance de document

Présentation des résultats d'un enregistrement d'échange

Présentation des requêtes


Recherche des informations relatives aux documents et aux échanges par la combinaison de paramètres de requête

  1. Dans Suivi de documents BizTalk, vous pouvez combiner les paramètres de requête suivants dans une session de requête unique pour rechercher et afficher des enregistrements d'instance d'échange et de document ainsi que les données associées :
    • Sélection de la source. Pour plus d'informations sur la création de requêtes en utilisant le paramètre de sélection de la source, voir Recherche par organisation des informations relatives aux documents et aux échanges.

    • Sélection de la destination. Pour plus d'informations sur la création de requêtes en utilisant le paramètre de sélection de la destination, voir Recherche par organisation des informations relatives aux documents et aux échanges.

    • Type de document. Pour plus d'informations sur la création de requêtes en utilisant le paramètre de type de document, voir Recherche par type de document des informations relatives aux documents et aux échanges.

    • Date et heure. Pour plus d'informations sur la création de requêtes en utilisant les paramètres de date et d'heure, voir Recherche par date des informations relatives aux documents et aux échanges.
  2. Cliquez sur le bouton Requête.


Annulation des critères de recherche pour les organisations et les types de document

  • Dans Suivi de documents BizTalk, cliquez sur Effacer tout sous la liste Sélection de la source, Sélection de la destination ou Sélection du type de document.

Remarque

  • Lorsque vous cliquez sur Effacer tout, Suivi de documents BizTalk revient à la recherche par défaut pour toutes les organisations source et de destination et pour tous les types de document. Pour optimiser les résultats, créez toujours une requête avec des paramètres très spécifiques afin de limiter les enregistrements d'échange renvoyés sur la page Résultats de la requête.


Personnalisation de la page Résultats de la requête

  1. Dans Suivi de documents BizTalk, dans la zone Contrôle du tri, cochez la case Grouper les échanges correspondants.

    Cette étape configure la page Résultats de la requête pour afficher les échanges entrants groupés avec les échanges sortants associés. Décochez cette case si vous ne souhaitez pas afficher les échanges entrants avec les échanges sortants associés.

  2. Dans la zone Contrôle du tri, dans la liste Ordre de tri 1, cliquez sur la première option d'ordre de tri à utiliser. Répétez cette opération pour chaque liste d'ordre de tri pour configurer l'ordre de tri de vos documents sur la page Résultats de la requête.

    Chaque liste Ordre de tri contient les options suivantes :

    • Nom de l'organisation source

    • Nom de l'application source

    • Nom de l'organisation de destination

    • Nom de l'application de destination

    • Type de document

    • Temps de traitement


Affichage des paramètres de recherche pour la page Résultats de la requête

  1. Définissez les paramètres d'une requête, puis cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

    Pour plus d'informations sur la création de requêtes et de requêtes avancées, voir :

    • Recherche par date des informations relatives aux documents et aux échanges

    • Recherche par organisation des informations relatives aux documents et aux échanges

    • Recherche par type de document des informations relatives aux documents et aux échanges

    • Création de requêtes avancées
  2. Dans la barre Paramètres de recherche, cliquez sur l'icône Afficher.

    Les paramètres de recherche suivants et les valeurs associées sont indiquées dans la zone Paramètres de recherche :

    • Plage de dates

    • Fuseau horaire

    • Nom d'expression

    • Ordre de tri

    • Sélection de la source

    • Sélection de la destination

    • Sélection du type de document

Voir aussi

Création de requêtes avancées

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges


Utilisation de requêtes avancées

Si vous devez localiser des données spécifiques, telles qu'une instance de document avec un numéro de bon de commande spécifique, vous pouvez utiliser une requête avancée pour localiser ces informations.

Cette section traite des procédures suivantes :

  • Création de requêtes avancées

  • Localisation de requêtes avancées existantes

  • Édition de requêtes avancées existantes

  • Effacement de requêtes avancées existantes

  • Suppression de requêtes avancées existantes

Remarques

  • Si vous configurez un format non standard de date, de nombre, d'heure et de devise dans les Options régionales du Panneau de configuration, il est possible que vous ne puissiez ni enregistrer une nouvelle requête, ni afficher les requêtes avancées que vous avez enregistrées. Pour plus d'informations, voir Utilisation des requêtes avancées.

    Pour afficher les requêtes avancées existantes, choisissez uniquement les options disponibles dans les listes des Options régionales. Par exemple, dans l'onglet Date, dans la liste Format de date courte, choisissez les options figurant dans la liste. Évitez de taper, de copier et de coller les autres formats de la liste Format de date courte.

  • Les types de données Float et Real sont des types de données approximatives. Leur comportement répond à la spécification IEEE 754 portant sur les types de données numériques approximatives. Les types de données numériques approximatives ne stockent pas les valeurs exactes spécifiées pour de nombreux nombres, mais en conservent une approximation très proche. Dans de nombreuses applications, la différence infime existant entre la valeur spécifiée et l'approximation stockée est négligeable. Il arrive cependant parfois que ça ne soit pas le cas. Compte tenu de la nature approximative des types de données Float et Real, n'utilisez pas ces types de données si vous recherchez un comportement numérique exact, notamment dans les applications financières, les opérations impliquant l'arrondissement ou les contrôles d'égalité. Préférez l'utilisation des types de données Integer, Decimal, Money ou Smallmoney.BizTalk Server permet au type de données Number d'être suivi en tant que type de données Integer. Si la valeur du nombre dans le document dépasse la taille du type de données Integer, un message d'avertissement s'affiche. Ce message contient la valeur qui n'a pu faire l'objet d'un suivi.

    Ne dépassez pas la taille du type de données Integer en effectuant le suivi d'un type de données Number en tant que Integer.

Question d'ordre international

  • En fonction de la langue du système, BizTalk Server peut mal interpréter une valeur numérique dans les données XML lorsque celle-ci est enregistrée comme champ de suivi d'entier dans la base de données de suivi. Par exemple, dans une version allemande, la valeur numérique de XML 4.0 est enregistrée en tant que 40 dans la base de données de suivi car le point décimal (.) est interprété à tort comme symbole de regroupement numérique.

    Il existe deux manières de contourner ce problème. Premièrement, si vous savez déjà que la valeur de l'élément ou de l'attribut contient un nombre décimal, vous pouvez modifier le type de données de l'élément ou de l'attribut XML en Real (r4) ou Double Real (r8). Deuxièmement, vous pouvez configurer la définition de document ou le canal en vue de l'enregistrement d'un élément ou d'un attribut avec un type de données Number égal à Real au lieu de Integer.


Création de requêtes avancées

  1. Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Nouveau.

    La page Générateur de requêtes avancées apparaît.

  2. Dans la liste Sélection de la source, cliquez sur une option pour spécifier vos critères de sélection.

    Ce nom correspond au champ capturé que vous recherchez.

  3. Dans la liste Opérateurs, cliquez sur un opérateur.

  4. Dans la zone Valeur, saisissez une valeur.

  5. Dans la liste AND/OR, cliquez sur AND ou OR pour combiner ou comparer cette condition avec une autre. Cette étape est facultative.

  6. Cliquez sur Terminé.

  7. Répétez les étapes 2 à 6 jusqu'à ce que vous ayez ajouté toutes les conditions souhaitées.

  8. Exécutez une des procédures suivantes :
    • Cliquez sur OK pour limiter l'utilisation de cette expression à la session de requête actuelle.

    • Cliquez sur Enregistrer pour enregistrer l'expression en vue de futures sessions de requête. Dans la boîte de dialogue Suivi de documents BizTalk, saisissez le nom de l'expression dans la zone Tapez le nom de l'expression (limitez le nom de l'expression à 50 caractères), puis cliquez sur OK.

Attention

  • Pour les requêtes, assurez-vous de sélectionner des noms uniques, qui respectent la casse des caractères. Les nouveaux enregistrements pour le champ Suivi ne sont pas créés si un nom correspond à une entrée existante et au type de données, mais comporte une casse de caractères différente. Vous pouvez entrer des requêtes portant le même nom dans Suivi de documents BizTalk, mais le seul moyen de les différencier est d'ouvrir chacune d'elles, ce qui réduit leur utilité.

  • Entrez toujours les champs personnalisés exactement tels qu'ils apparaissent dans le document en cours de suivi.

Remarques

  • La collection d'une ou de plusieurs conditions dans une requête avancée est qualifiée d'expression.

  • Si vous cliquez sur un bouton lorsque la liste Sélection de la source est au premier plan, il se peut que vous deviez cliquer une deuxième fois sur le bouton afin de l'activer.

  • Dans le Gestionnaire d'échanges BizTalk, si vous avez configuré un canal ou une définition de document pour suivre un ou plusieurs champs personnalisés, ces champs apparaissent dans la liste Sélection de la source. Si vous n'avez pas configuré le Gestionnaire d'échanges BizTalk pour suivre des champs, seul "<Recherche personnalisée>" apparaît dans la liste Sélection de la source. Pour plus d'informations sur le suivi de champs spécifiques, voir Définition des propriétés de journalisation de document et Sélection des champs de spécification dans un canal.

  • Lorsque vous suivez des échanges ou des documents en utilisant des champs de recherche personnalisés et que vous recherchez une valeur, seuls les échanges ou les documents suivis à partir des champs de recherche personnalisés s'affichent sur la page Résultats de la requête.

Voir aussi

Effacement de requêtes avancées existantes

Suppression de requêtes avancées existantes

Édition de requêtes avancées existantes

Localisation de requêtes avancées existantes


Localisation de requêtes avancées existantes

  1. Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Parcourir.

    La boîte de dialogue Requêtes avancées apparaît.

  2. Sélectionnez une requête existante, puis cliquez sur OK.

Remarque

  • Si vous cliquez sur un bouton lorsque la liste Sélection de la source est au premier plan, il se peut que vous deviez cliquer une deuxième fois sur le bouton afin de l'activer.

Voir aussi

Création de requêtes avancées

Effacement de requêtes avancées existantes

Suppression de requêtes avancées existantes

Édition de requêtes avancées existantes


Édition de requêtes avancées existantes

  1. Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Parcourir.

    La boîte de dialogue Requêtes avancées apparaît.

  2. Sélectionnez une requête existante à modifier, puis cliquez sur Modifier.

    La boîte de dialogue Générateur de requêtes avancées apparaît.

  3. Exécutez une des procédures suivantes :
    • Cliquez sur Nouveau pour ajouter une nouvelle condition. Spécifiez des conditions pour chacun des quatre champs, puis cliquez sur Terminé.

    • Cliquez sur une condition existante, cliquez sur Modifier, modifiez l'un des quatre champs, puis cliquez sur Terminé.

    • Sélectionnez une condition existante, puis cliquez sur Supprimer.
  4. Cliquez sur Enregistrer.

    La boîte de dialogue Requêtes avancées apparaît.

  5. Sélectionnez la requête que vous venez de modifier, puis cliquez sur OK.

Remarque

  • Si vous cliquez sur un bouton lorsque la liste Sélection de la source est au premier plan, il se peut que vous deviez cliquer une deuxième fois sur le bouton afin de l'activer.

Voir aussi

Création de requêtes avancées

Effacement de requêtes avancées existantes

Suppression de requêtes avancées existantes

Localisation de requêtes avancées existantes


Effacement de requêtes avancées existantes

  • Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Effacer pour supprimer l'expression courante de la zone Nom d'expression.

Remarque

  • Si vous cliquez sur le bouton Actualiser dans Internet Explorer, la requête avancée n'est pas effacée de la zone Nom d'expression.

Voir aussi

Création de requêtes avancées

Suppression de requêtes avancées existantes

Édition de requêtes avancées existantes

Localisation de requêtes avancées existantes


Suppression de requêtes avancées existantes

  1. Dans Suivi de documents BizTalk, dans la zone Requête avancée, cliquez sur Parcourir.

    La page Requêtes avancées apparaît.

  2. Sélectionnez une requête, puis cliquez sur Supprimer.

  3. Fermez la boîte de dialogue Requêtes avancées lorsque vous avez terminé.

Remarque

  • Si vous cliquez sur un bouton lorsque la liste Sélection de la source est au premier plan, il se peut que vous deviez cliquer une deuxième fois sur le bouton afin de l'activer.

Voir aussi

Création de requêtes avancées

Effacement de requêtes avancées existantes d'une requête

Édition de requêtes avancées existantes

Localisation de requêtes avancées existantes


Enregistrement d'un échange, d'un document et de données de recherche personnalisée

Si vous avez configuré le Gestionnaire d'échanges BizTalk, le modèle d'objet de configuration d'échanges BizTalk, ou Administration de BizTalk Server pour stocker des échanges entrants et sortants et leurs documents, vous pouvez enregistrer des échanges, des données de documents et des données du champ de recherche personnalisée afin de pouvoir les afficher hors ligne. Cela simplifie le dépannage de certaines situations ou l'analyse de vos pratiques professionnelles.

Cette section traite des procédures suivantes :

  • Enregistrement des données d'échanges

  • Enregistrement des données d'une instance de document

  • Enregistrement des données du champ de recherche personnalisée


Enregistrement des données d'échanges

  1. Définissez les paramètres d'une requête et cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

    Pour plus d'informations sur la création de requêtes et de requêtes avancées, voir :

    • Recherche par date des informations relatives aux documents et aux échanges

    • Recherche par organisation des informations relatives aux documents et aux échanges

    • Recherche par type de document des informations relatives aux documents et aux échanges

    • Création de requêtes avancées
  2. Localisez l'enregistrement d'échange qui contient les données d'échange à enregistrer puis, dans le champ Données, cliquez sur l'icône des données.

    La page Afficher les données d'échange s'affiche.

  3. Cliquez sur Enregistrer sous.

  4. Dans la zone Nom de fichier, saisissez le nom du fichier, puis cliquez sur Enregistrer.

Voir aussi

Création de requêtes avancées

Enregistrement des données du champ de recherche personnalisée

Enregistrement des données d'une instance de document

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges


Enregistrement des données d'une instance de document

  1. Définissez les paramètres d'une requête et cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

    Pour plus d'informations sur la création de requêtes et de requêtes avancées, voir :

    • Recherche par date des informations relatives aux documents et aux échanges

    • Recherche par organisation des informations relatives aux documents et aux échanges

    • Recherche par type de document des informations relatives aux documents et aux échanges

    • Création de requêtes avancées
  2. Localisez l'enregistrement d'échange qui contient les données d'instance de document à enregistrer, puis cliquez sur l'icône de l'indicateur de développement(+) situé à gauche de l'échange.

  3. Dans le champ Données, cliquez sur l'icône des données.

    La page Afficher les données de document s'affiche.

  4. Cliquez sur Enregistrer sous.

  5. Dans la zone Nom de fichier, saisissez un nom et une extension (soit l'extension de fichier .xml, soit l'extension de fichier native du document) pour le fichier, puis cliquez sur Enregistrer.

Voir aussi

Création de requêtes avancées

Enregistrement des données du champ de recherche personnalisée

Enregistrement des données d'échanges

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges


Enregistrement des données du champ de recherche personnalisée

  1. Définissez les paramètres d'une requête et cliquez sur le bouton Requête.

    La page Résultats de la requête s'affiche.

    Pour plus d'informations sur la création de requêtes et de requêtes avancées, voir :

    • Recherche par date des informations relatives aux documents et aux échanges

    • Recherche par organisation des informations relatives aux documents et aux échanges

    • Recherche par type de document des informations relatives aux documents et aux échanges

    • Création de requêtes avancées
  2. Cliquez sur l'icône de l'indicateur de développement (+) situé à gauche de l'enregistrement d'échange qui contient le document à afficher.

  3. Utilisez la barre de défilement horizontale pour afficher le champ Recherche personnalisée du document à afficher, puis cliquez sur l'icône Recherche personnalisée.

    La page Afficher le champ de recherche personnalisée s'affiche.

  4. Cliquez sur Enregistrer sous.

  5. Dans la zone Nom de fichier, tapez le nom du fichier, puis cliquez sur Enregistrer.

Voir aussi

Création de requêtes avancées

Enregistrement des données d'une instance de document

Enregistrement des données d'échanges

Recherche par date des informations relatives aux documents et aux échanges

Recherche par type de document des informations relatives aux documents et aux échanges

Recherche par organisation des informations relatives aux documents et aux échanges


Dépannage de Suivi de documents BizTalk

Cette section fournit des informations générales sur le dépannage de Suivi de documents BizTalk.

Cette section traite des rubriques suivantes :

  • Problème d'affichage de l'interface utilisateur de Suivi de documents BizTalk

  • Des échanges ne sont pas stockés

  • Des documents ne sont pas stockés

  • Rien ne s'affiche dans les résultats de la requête

  • Des champs de suivi ne sont pas affichés dans les résultats de la requête

  • Trop d'arguments de recherche


Problème d'affichage de l'interface utilisateur de Suivi de documents BizTalk

Cause : Microsoft Office Web Components n'est pas installé.

Solution : Installez Microsoft Office Web Components.

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Ajout/Suppression de programmes.

    La boîte de dialogue Ajout/Suppression de programmes apparaît.

  3. Cliquez sur Microsoft Office 2000 SR-1 Premium.

  4. Cliquez sur Modifier.

  5. Cliquez sur Ajouter/supprimer des composants.

  6. Cliquez sur l'indicateur de développement (+) en regard de Outils Office.

  7. Cliquez sur Office Web Components puis cliquez sur l'option adaptée à votre installation.

  8. Cliquez sur Mettre à jour.


Des échanges ne sont pas stockés

Cause : Le suivi est désactivé dans Administration de BizTalk Server.

Solution : Activez le suivi dans Administration de BizTalk Server.

  1. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2002, puis cliquez sur Administration de BizTalk Server.

  2. Développez Microsoft BizTalk Server 2002 et cliquez sur le groupe de serveurs pour lequel des documents ne sont pas stockés.

  3. Dans le menu Action, cliquez sur Propriétés.

    La boîte de dialogue Propriétés du groupe de serveurs BizTalk Server s'affiche.

  4. Cliquez sur l'onglet Suivi.

  5. Activez la case à cocher Activer le Suivi de documents.

  6. Sélectionnez une ou plusieurs des options suivantes :
    • Consigner l'échange entrant dans un journal

    • Consigner l'échange sortant dans un journal

    • Consigner le message MIME d'origine dans un journal
  7. Cliquez sur OK.

Voir aussi

Configuration des propriétés de suivi d'un groupe de serveurs


Des documents ne sont pas stockés

Cause : Les propriétés de journalisation des documents n'ont pas été correctement définies dans les configurations de canal du Gestionnaire d'échanges BizTalk.

Solution : Activez les options de journalisation des documents, dans les configurations de canal.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Dans l'Assistant Canal, sur la page Journalisation de document, dans la zone Consigner le document entrant, activez la case à cocher appropriée :

  3. Au format natif. Stocke les documents entrants pour le canal sous le format d'origine. Il s'agit de la configuration par défaut.

  4. Au format XML. Stocke les documents entrants pour le canal sous le format XML.

  5. Dans la zone Consigner le document sortant, activez la case à cocher appropriée :

  6. Au format natif. Stocke les documents sortants pour le canal sous le format d'origine.

  7. Au format XML. Stocke les documents sortants pour le canal sous le format XML.

  8. Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

  9. Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux.

  10. Une fois vos modifications effectuées, cliquez sur Terminer.


Rien ne s'affiche dans les résultats de la requête

Première cause : La plage de dates et d'heure est incorrecte.

Solution : Vérifiez que la plage de dates et d'heure est correcte. Par exemple, si vous avez envoyé un document dans les 5 dernières minutes et si la plage d'heure est configurée pour rechercher des documents remontant à 10 minutes ou plus, votre document n'apparaîtra pas dans les résultats de la requête.

Deuxième cause : Les données peuvent avoir été supprimées de la base de données.

Solution : Contactez votre administrateur de base de données pour obtenir plus d'informations.

Voir aussi

Recherche par date des informations relatives aux documents et aux échanges


Des champs de suivi ne sont pas affichés dans les résultats de la requête

Cause : BizTalk Server n'a pas pu convertir les données ou il y a eu erreur de débordement arithmétique.

Solution : Recherchez le message d'erreur suivant dans le journal des événements :

<chemin et nom de fichier> : Impossible de consigner le champ de suivi pour la transmission <identificateur global unique> :

Champ de suivi : <Nom du champ>

Nom du champ de spécification : <nom du champ de spécifications>/DTADataTypeTest/String/@_String

Valeur réelle : <valeur réelle du champ>

Vérifiez les paramètres du champ de suivi définis dans la configuration du document ou du canal.

Voir aussi

Sélection des champs de spécification dans un canal

Définition des propriétés de journalisation de document


Trop d'arguments de recherche

Cause : Vous avez spécifié trop d'options dans les listes Sélection de la source ou Sélection de la destination.

Solution : Faites en sorte que votre requête soit la plus spécifique possible. Réduisez le nombre d'options sélectionnées dans les listes Sélection de la source ou Sélection de la destination, puis cliquez sur Requête.

Voir aussi

Utilisation des requêtes pour rechercher et trier les données d'échange et de document


Contrôle des documents

Vous pouvez utiliser WMI (Windows Management Instrumentation) et MOM (Microsoft Operations Manager) 2000 pour contrôler Microsoft® BizTalk™ Server 2002. Ces deux outils de gestion vous permettent d'effectuer les tâches suivantes :

  • Contrôler les notifications d'alerte standard et personnalisées.

  • Consommer et utiliser les entrées du journal des événements Microsoft Windows NT® qui concernent BizTalk Server, en bénéficiant d'une aide fournie par les directives des outils.

  • Créer des statistiques de performances pour XLANG Scheduler sans utiliser de scripts.

  • Contrôler les composants de base de BizTalk Server comme les bases de données et les tables de base de données, les files d'attente par instance et les services.

Cette section traite des rubriques suivantes :

  • À propos de Windows Management Instrumentation

  • À propos de Microsoft Operations Manager


À propos de Windows Management Instrumentation

L'infrastructure de gestion Windows ou WMI (Windows Management Instrumentation) est une couche de gestion de données incluse dans Microsoft® Windows® 2000. Microsoft BizTalk Server 2002 utilise la couche WMI pour encapsuler des fonctions administratives. Lorsque vous utilisez la console Administration de BizTalk Server pour changer des paramètres de groupe, de serveur et de file d'attente, les nouvelles valeurs sont stockées dans la base de données Gestion d'échanges BizTalk par le biais du fournisseur BizTalk Server WMI. Dans BizTalk Server 2002, ce fournisseur WMI utilise une base de données Microsoft SQL Server™ pour stocker des objets administratifs. WMI prend en charge une API de scripts uniforme qui permet aux applications et aux scripts d'accéder au fournisseur WMI sur un ordinateur local ou un ordinateur distant. Pour obtenir des informations et des exemples sur l'utilisation de WMI, voir BizTalk Managing and Monitoring.

Remarques

  • WMI impose des restrictions sur la syntaxe et les caractères valides d'un chemin d'objet WMI. Voici la liste des caractères non valides :

    ~` ! @ # $ % ^ & * ( ) + = [ ] { } | ;\" '< > , . ?

    N'utilisez pas ces caractères lors de la création d'un nom de groupe de serveurs.

  • Tous les horodatages sont créés en utilisant l'heure locale sur SQL Server. Le fournisseur WMI fait toutefois référence à tous les horodatages en heure UTC (Coordinated Universal Time). La console d'administration reconvertit ensuite les horodatages en heure locale pour affichage.

  • Pour accéder à la couche de base de données WMI par programme, vous pouvez utiliser le fichier InterchangeProvSchema.mof qui se trouve dans le dossier \Program Files\Microsoft BizTalk Server\Setup. Ce fichier contient les classes WMI correspondant aux objets Administration. Pour plus d'informations sur la programmation d'applications WMI, accédez au site Web MSDN Online Library (en anglais) msdn.microsoft.com/library/ et recherchez « WMI Application Programming ».

  • Pour exécuter des requêtes WMI via MOM (Microsoft Operations Manager), vous devez être membre du groupe des administrateurs de BizTalk Server sur le serveur où la requête sera exécutée. Vous devez également accorder au groupe des administrateurs de BizTalk Server toutes les autorisations concernant l'espace de noms WMI root/MicrosoftBizTalkServer du serveur. Pour plus d'informations sur l'octroi d'autorisations aux utilisateurs dans WMI, reportez-vous à l'aide de Windows 2000 et à la rubrique Attribution des autorisations d'espace de noms WMI à un compte Windows.

Cette section traite des rubriques suivantes :

  • Vue d'ensemble des compteurs personnalisés

  • Vue d'ensemble de la file d'attente interrompue

Voir aussi

BizTalk Managing and Monitoring

Windows Management Instrumentation


Vue d'ensemble des compteurs personnalisés

Les compteurs personnalisés fournissent un moyen de définir par programme des instances de classe WMI (Windows Management Instrumentation) sur la base d'une requête avancée concernant la base de données de suivi. Ces requêtes peuvent être construites à l'aide de l'ensemble fixe d'attributs suivant :

  • Intervalle de temps

  • Source du document

  • Destination du document

  • Type de document

Il est possible de spécifier ces attributs à l'aide d'expressions régulières. Chaque requête renvoie le nombre de documents répondant aux critères et vous pouvez spécifier le mode de tri des résultats. Par ailleurs, vous pouvez spécifier un ensemble de critères (une requête) en tant que nouvelle instance de classe pouvant être consommée par MOM (Microsoft Operations Manager), ce qui permet de définir les alertes dans le cadre d'une règle MOM.

Les classes WMI vous permettent d'effectuer les tâches suivantes :

  • Créer une nouvelle instance d'une classe WMI qui définit une requête de suivi spécifique.

  • Valider la requête de suivi créée dans la nouvelle instance de classe WMI comme source de document et destination de document.

  • Exécuter la requête définie dans la nouvelle instance de classe WMI pour obtenir le nombre de documents répondant à cette requête dans la base de données de suivi.

Pour plus d'informations, voir Custom Counters.

Voir aussi

Creating a Custom Counter Using WMI

Custom Counter Query Properties

Validating the Custom Counter


Vue d'ensemble de la file d'attente interrompue

La file d'attente interrompue contient des éléments de travail dont le traitement a échoué pour diverses raisons, notamment des erreurs d'analyse, des erreurs de sérialisation, des échecs de transmission ou l'incapacité de trouver une configuration de canal. Vous pouvez afficher et extraire des documents de la file d'attente interrompue soit à l'aide de la console Administration de BizTalk Server, soit par programme via le fournisseur WMI (Windows Management Instrumentation) de BizTalk Server. Les requêtes WMI peuvent être construites à l'aide de l'ensemble d'attributs fixe suivant :

  • Destination

  • Source

  • Nom du document

  • État

  • Descripteur du canal

  • Descripteur du port

  • GUID de la chaîne interrompue

  • Raison

Pour plus d'informations sur l'affichage de la file d'attente interrompue à l'aide de la console Administration, voir File d'attente interrompue. Pour plus d'informations sur l'affichage de la file d'attente interrompue à l'aide du fournisseur WMI, voir Accessing the Suspended Queue.

Voir aussi

Accessing the Suspended Queue

MicrosoftBizTalkServer_SuspendedQueue

Suspended Queue Monitoring


À propos de Microsoft Operations Manager

MOM (Microsoft Operations Manager) 2000 est un ensemble d'outils de collecte d'événements, de contrôle de performances et de création de rapports pour les systèmes d'exploitation Microsoft et les applications basées sur serveur. MOM centralise le contrôle, la gestion et la sécurisation d'un large éventail de ressources pour améliorer la disponibilité, les performances et la sécurité des réseaux et applications Windows 2000 en assurant un contrôle proactif du système en temps réel. MOM vous permet d'identifier rapidement des problèmes réseau pouvant être graves, de suivre l'avancement de leur résolution et de produire des informations de résolution utiles aux autres membres de votre organisation.

Microsoft Operations Manager vous permet également de contrôler les performances de votre réseau à l'aide de Windows Management Instrumentation (WMI). Vous pouvez suivre les seuils de performances et collecter des données échantillonnées en vue d'une analyse de tendance. Vous pouvez créer et afficher des graphiques des données échantillonnées et utiliser ces informations pour la planification de capacité.

MOM fournit les fonctionnalités suivantes :

  • Contrôle des opérations basées sur les événements

  • Solutions évolutives à déploiement automatique

  • Application des stratégies de sécurité avancées et audit des fonctionnalités

  • Disponibilité du système améliorée et suivi des performances

  • Méthodes multiples d'affichage des données et de génération de rapports

  • Fiabilité et disponibilité accrues

Microsoft Operations Manager consomme diverses données provenant de serveurs exécutant BizTalk Server, notamment des compteurs de performances, des compteurs et événements WMI ainsi que des événements Windows NT. Cette consommation passe par la création de fournisseurs, de groupes de serveurs et de règles. Les fournisseurs sont simplement des sources de données individuelles qui sont définies par le nom de la source de données (c'est-à-dire le type de fournisseur), le nom du fournisseur en question et divers autres attributs propres à la source de données. Par exemple, le fournisseur qui contrôle la taille en octets de la file d'attente nommée « myQueue » est défini comme suit :

Provider = Windows NT Performance Counter – MSMQ Queue-Bytes in Queue-myQueue-15.0-Minutes

Remarque

  • Le taux d'échantillonnage fait partie de la définition du fournisseur pour la source de données des compteurs de performances Windows NT.

Une fois les fournisseurs créés, il est possible de créer des règles pour traiter les données qu'ils fournissent. Ces règles sont contenues dans l'un des trois groupes de règles de traitement suivants de Microsoft Operations Manager :

  • Règles de traitement des événements. Ces règles peuvent traiter différents événements se produisant sur un serveur et entreprendre une action spécifiée sur la base d'un événement. Les événements en question sont notamment des instances du journal des événements de Windows NT, d'autres fichiers journaux standard comme ceux (au format W3C) créés par le service IIS (Internet Information Services) et des événements WMI. Les actions comprennent le déclenchement d'une alerte, l'envoi d'un message électronique et l'exécution d'un script.

  • Règles de traitement des performances. Ces règles traitent des compteurs de performances ou de capacité. Il peut s'agir de règles de mesure ou de règles de seuil. Les règles de mesure ne font que collecter des statistiques en vue de générer des rapports tandis que les règles de seuil peuvent déclencher des alertes. Cela est vrai même si les règles de mesure et de seuil ont exactement le même fournisseur.

  • Règles de traitement des alertes. Les règles de traitement des événements et des performances ne sont pas utilisées pour réagir directement aux alertes ; au lieu de cela, des règles distinctes sont créées pour réagir effectivement aux alertes déclenchées par les règles d'événements et de performances. Une règle de traitement d'alerte vous permet d'associer une réponse globale à un vaste ensemble d'alertes présentant une caractéristique commune.

Pour plus d'informations, reportez-vous à l'aide de Microsoft Operations Manager.

Cette section aborde la rubrique suivante :

  • BizTalk Server 2002 Enterprise Edition Management Pack

Remarques

  • Vous pouvez installer MOM sur un ordinateur qui exécute BizTalk Server ou sur un ordinateur indépendant dédié au contrôle de votre système.

  • MOM n'est pas inclus sur le CD-ROM BizTalk Server 2002. Vous devez vous le procurer séparément. Pour plus d'informations sur MOM, consultez le site Web de Microsoft Operations Manager à l'adresse suivante : www.microsoft.com/mom/.

  • Pour exécuter des requêtes WMI via MOM, vous devez faire partie du groupe des administrateurs de BizTalk Server sur le serveur où la requête est exécutée.

Voir aussi

À propos de Windows Management Instrumentation


BizTalk Server 2002 Enterprise Edition Management Pack

Pour renforcer les fonctionnalités de contrôle de MOM (Microsoft Operations Manager), le module de gestion de BizTalk Server 2002 Édition Entreprise contient des règles de traitement et de regroupement d'ordinateurs ainsi que d'autres informations permettant de contrôler des événements propres à BizTalk Server 2002. Vous pouvez importer BizTalk Server 2002 Management Pack pour contrôler les ordinateurs du groupe de configuration actuel.

BizTalk Server 2002 Management Pack fournit un ensemble initial de règles et de compteurs comprenant tous les messages d'erreur relatifs aux échanges et à l'orchestration, les bases de données BizTalk Server, les événements Windows NT et les files d'attente. Vous pouvez personnaliser le module de gestion pour qu'il réponde à vos besoins de contrôle et fournisse davantage de détails dans les domaines que votre organisation souhaite contrôler.

BizTalk Server 2002 Management Pack fournit plus de 900 règles de divers types, notamment :

  • Une règle de traitement d'événement pour tous les événements d'application Windows pouvant être générés à partir des échanges BizTalk et de l'orchestration BizTalk.

  • Des règles de mesure de performance pour les compteurs de performances et la taille des fichiers de base de données dans BizTalk Server 2002. Ces règles prennent en charge les 20 affichages de performances du module de gestion qui sont spécifiques à BizTalk Server.

  • Des règles de seuil de performance pour les compteurs de performances et la taille des fichiers de base de données dans BizTalk Server 2002 (une pour le niveau de gravité « erreur » et une autre pour le niveau de gravité « avertissement »).

  • Cinq exemples de règles (dont un de compteur personnalisé et un de file d'attente interrompue) qui montrent comment construire des règles personnalisées pour une implémentation spécifique de BizTalk Server 2002.

À l'aide de ces règles, les administrateurs système peuvent recevoir des notifications pour savoir :

  • à quel moment le service d'échanges BizTalk est hors service ou depuis combien de temps il s'exécute ;

  • à quel moment un événement Windows quelconque est généré à partir des échanges BizTalk ou de l'orchestration BizTalk ;

  • si des documents destinés à un client important sont interrompus et combien de documents destinés à un client important sont envoyés correctement par période de temps ;

  • quand la taille des bases de données BizTalk Server devient trop importante ;

  • à quel moment le nombre de planifications en échec par unité de temps devient trop important.

La procédure et les rubriques suivantes sont traitées dans cette section :

  • Configuration de MOM pour contrôler BizTalk Server 2002

  • Importer BizTalk Server 2002 Management Pack

  • Groupes de notification

  • Affichage

  • Règles configurées entièrement

  • Règles définies par l'utilisateur

Remarque

  • Avant toute tentative d'importation de BizTalk Server 2002 Enterprise Edition Management Pack, vérifiez que Microsoft Operations Manager 2000 est installé.


Configuration de MOM pour contrôler BizTalk Server 2002

Les étapes suivantes constituent les directives générales à observer pour configurer Microsoft Operations Manager (MOM) en vue de contrôler vos ordinateurs BizTalk Server 2002. La procédure détaillée est décrite dans l'aide de Microsoft Operations Manager.

  1. Installez MOM 2000 sur l'ordinateur qui sera utilisé pour contrôler votre configuration BizTalk Server. Pour plus d'informations, reportez-vous au « Microsoft Operations Manager Installation Guide » qui se trouve dans le dossier Documentation du CD-ROM d'installation de Microsoft Operations Manager.

    Remarque

    • Le compte de domaine Consolidator/Agent Manager requis par MOM doit avoir des privilèges d'administrateur Windows sur chaque ordinateur BizTalk Server que vous envisagez de contrôler, y compris les serveurs qui hébergent les bases de données SQL Server utilisées par BizTalk Server. Pour ce faire, vous pouvez ajouter ce compte soit au groupe Administrateurs Windows sur chaque serveur, soit à un groupe de domaine qui appartient au groupe des administrateurs locaux (par exemple, le groupe des administrateurs de domaines).
  2. Importez BizTalk Server 2002 Enterprise Edition Management Pack dans MOM. Pour plus d'informations, voir Importer BizTalk Server 2002 Management Pack ainsi que la rubrique « Importing a Management Pack Module » dans l'aide de Microsoft Operations Manager.

    Remarques

    • BizTalk Server 2002 Enterprise Edition Management Pack se trouve dans le dossier MOM sur le CD-ROM d'installation de BizTalk Server 2002.

    • Lors de l'importation de BizTalk Server 2002 Management Pack, MOM propose trois options de comportement :

      Merge, and retain changes that my company has made to rules (Fusionner et conserver les modifications apportées aux règles par l'entreprise).

      Merge, and always use the rules defined in the Management Pack (Fusionner et toujours utiliser les règles définies dans le module de gestion). Preserve my company's knowledge base comments (Conserver les commentaires de la base de connaissances de l'entreprise).

      Replace existing rule groups with those of the imported Management Pack (Remplacer les groupes de règles existants par ceux du module de gestion importé).

      Si vous importez BizTalk Server Management Pack pour la première fois, vous pouvez choisir n'importe laquelle de ces options. Lors des importations suivantes, en revanche, il est important de sélectionner l'option qui correspond au comportement que vous souhaitez.

    • BizTalk Server 2002 Enterprise Edition Management Pack contient un groupe d'ordinateurs appelé Microsoft BizTalk Server 2002 Édition Entreprise. Ce groupe contient tous les ordinateurs gérés par MOM sur lesquels se trouve la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0.
  3. Une fois Microsoft Operations Manager installé correctement, désignez le groupe d'ordinateurs que MOM doit contrôler ou interroger périodiquement pour découvrir les nouvelles installations de BizTalk Server. Pour plus d'informations, reportez-vous à « Understanding Agents », « Install Agents », « Configuring Agent Manager Properties », « Configuring Agent Deployment » et « Agent Managers Window » dans l'aide de Microsoft Operations Manager.

    Remarque

    • En configurant des règles pour les ordinateurs gérés et en recherchant les ordinateurs qui répondent à ces règles (comme l'explique la documentation MOM citée précédemment), vous indiquez à MOM l'ensemble d'ordinateurs à contrôler. Cet ensemble d'ordinateurs doit comprendre tous les serveurs BizTalk Server 2002 et les serveurs SQL associés que vous souhaitez contrôler. Vous installez ainsi un service local appelé One Point qui s'exécute en tant que LocalSystem (Système local).
  4. Pour vérifier que les règles que vous avez spécifiées englobent les ordinateurs voulus, procédez comme suit :
    1. Vérifiez que MOM a effectué une analyse de l'ordinateur depuis la dernière modification des règles pour les ordinateurs gérés. Pour ce faire, la méthode la plus efficace consiste à appeler manuellement l'analyse. Pour plus d'informations, reportez-vous à « Scanning Managed Computers » dans l'aide de Microsoft Operations Manager.

      Attention

      Si les règles relatives aux ordinateurs gérés que vous avez définies pour votre Agent Manager donnent un grand nombre d'ordinateurs, l'analyse peut prendre plus de temps que vous ne le souhaitez.

    2. Vérifiez la liste des ordinateurs gérés. Pour plus d'informations sur la manière d'afficher cette liste, reportez-vous à « Viewing the Managed Computers List for an Agent Manager » dans l'aide de Microsoft Operations Manager.
  5. Configurez le groupe d'ordinateurs Microsoft BizTalk Server 2002 Édition Entreprise pour qu'il englobe les serveurs qui hébergent des bases de données SQL Server utilisées par BizTalk Server mais sur lesquels BizTalk Server 2002 n'est pas installé. Pour plus d'informations, reportez-vous à « Excluding or Including Computers in a Computer Group » dans l'aide de Microsoft Operations Manager.

    Remarque

    • BizTalk Server 2002 Enterprise Edition Management Pack crée un groupe d'ordinateurs appelé Microsoft BizTalk Server 2002 Édition Entreprise. Ce groupe contient tous les ordinateurs gérés par MOM sur lesquels se trouve la clé de Registre HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\BizTalk Server\1.0. S'il existe d'autres serveurs qui hébergent des bases de données SQL Server utilisées par BizTalk Server mais sur lesquels BizTalk Server 2002 n'est pas installé, ces serveurs doivent être ajoutés explicitement au groupe d'ordinateurs par leur nom.

Une fois toutes ces étapes terminées, MOM est configuré pour contrôler BizTalk Server 2002. Pour vérifier que tous les ordinateurs que vous souhaitiez contrôler ont bien été ajoutés au groupe d'ordinateurs BizTalk Server 2002 Édition Entreprise, procédez comme suit :

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft Operations Manager, puis cliquez sur MOM Administration Console.

    La console MOM Administration Console s'affiche.

  2. Double-cliquez sur le nœud Microsoft Operations Manager de l'arborescence, double-cliquez sur Monitor, puis cliquez sur All Computer Groups.

  3. Dans le volet droit, double-cliquez sur Microsoft BizTalk Server 2002 Édition Entreprise.

  4. Tous les ordinateurs actuellement définis comme membres de ce groupe par Microsoft Operations Manager sont répertoriés.

    Remarque

    • MOM peut prendre quelques minutes ou davantage pour découvrir tous les ordinateurs du groupe. Si, au bout d'un délai raisonnable (qui dépend du nombre d'ordinateurs à examiner et d'autres facteurs), les ordinateurs que vous aviez l'intention de contrôler n'apparaissent pas dans ce groupe d'ordinateurs, vérifiez que vous avez inclus les ordinateurs souhaités dans les règles concernant votre Agent Manager et votre groupe d'ordinateurs.


Importer BizTalk Server 2002 Management Pack

Pour contrôler votre système BizTalk Server, vous devez importer BizTalk Server 2002 Management Pack sur l'ordinateur où est installé Microsoft Operations Manager (MOM).

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft Operations Manager, puis cliquez sur MOM Administrator Console.

  2. Dans le volet gauche, développez Microsoft Operations Manager (default), développez Rules, puis cliquez sur Processing Rule Groups.

  3. Dans le menu Action, cliquez sur Import Management Pack.

    La boîte de dialogue Import Management Pack s'affiche.

  4. Dans la zone Management Pack, naviguez jusqu'au CD-ROM de Microsoft BizTalk Server 2002, puis jusqu'au dossier MOM et sélectionnez BizTalk2002.akm.

  5. Cliquez sur Ouvrir.

  6. Cliquez sur Import.

Remarques

  • BizTalk Server 2002 Management Pack se trouve sur le CD-ROM de BizTalk Server 2002. Vous devez toutefois installer Microsoft Operations Manager avant d'utiliser BizTalk Server 2002 Management Pack. Pour plus d'informations sur MOM, consultez le site Web de Microsoft Operations Manager à l'adresse suivante : (www.microsoft.com/mom/).

  • Pour plus d'informations sur l'installation de MOM, reportez-vous à l'aide de Microsoft Operations Manager.


Groupes de notification

Dans Microsoft Operations Manager (MOM), un groupe de notification est un rôle défini auquel une configuration de notification s'applique. La configuration d'un groupe de notification consiste à définir les mécanismes (courrier électronique, radiomessagerie et messagerie instantanée) sur lesquels les membres de ce rôle recevront des notifications et les membres spécifiques à chaque rôle. Après avoir créé des règles d'alerte et défini des notifications, il convient de spécifier des groupes de notification comme cibles des notifications d'alerte.

En clair, vous devez définir vos propres groupes de notification. Microsoft Operations Manager fournit toutefois les groupes de notification suivants :

  • Administrateurs de systèmes informatiques. Il s'agit du groupe de professionnels de la logistique et de la gestion informatique qui est chargé d'assurer le fonctionnement des systèmes d'un point de vue technique.

  • Administrateurs de bases de données. Il s'agit d'un groupe particulier d'administrateurs de système informatique spécialisés dans la gestion des bases de données.

  • Administrateurs d'entreprise. Ce groupe représente les individus qui comprennent les processus professionnels implémentés par-dessus la technologie et qui sont chargés de contrôler le comportement du système du point de vue de l'activité de l'entreprise.

Remarque

  • Pour que les règles fonctionnent, il faut ajouter un Opérateur/Utilisateur aux groupes de notification. Pour plus d'informations, reportez-vous à « Adding an Operator to a Notification Group » dans l'aide de Microsoft Operations Manager.


Affichage

Pour contrôler la santé générale de votre système et faciliter les tâches de maintenance, les affichages proposés par MOM (Microsoft Operations Manager) permettent de consulter des informations spécifiques de la base de données. Ces affichages sont actualisés toutes les 15 minutes. BizTalk Server 2002 Management Pack offre des affichages concernant les compteurs de performances suivants :

  • Instances de planification activées

  • Envois asynchrones

  • Instances de planification terminées

  • Taille de fichier de base de données : BTM

  • Taille de fichier de base de données : DTA

  • Taille de fichier de base de données : SQ

  • Taille de fichier de base de données : XLANG

  • Taille de fichier journal de base de données : BTM

  • Taille de fichier journal de base de données : DTA

  • Taille de fichier journal de base de données : SQ

  • Taille de fichier journal de base de données : XLANG

  • Instances de planification en attente

  • Documents traités

  • Documents reçus

  • Échec des instances de planification

  • Échanges reçus

  • Éléments suspendus

  • Durée des échanges

  • Envois synchrones

  • Transactions abandonnées

Pour obtenir une description de ces compteurs, voir Compteurs de performances.

Microsoft Operations Manager (MOM) propose deux modes d'affichage :

  • Le mode d'affichage par défaut présente une liste des compteurs de performances et des fournisseurs auxquels sont associées des vues.

  • L'affichage graphique vous permet de voir les performances de votre système en traçant le compteur de performances ou le fournisseur dans le temps pour indiquer la valeur du compteur et/ou de la règle pendant les deux dernières heures avec mise à jour toutes les 15 minutes.

Pour plus d'informations sur les affichages par défaut disponibles dans MOM et la manière de créer d'autres affichages, reportez-vous à l'aide de Microsoft Operations Manager.

Cette section traite de la procédure suivante :

  • Accéder aux vues de BizTalk Server


Accéder aux vues de BizTalk Server

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft Operations Manager, puis cliquez sur MOM Administrator Console.

  2. Dans le volet gauche, développez successivement Microsoft Operations Manager (default), Monitor, Public Views, Microsoft BizTalk Server puis Microsoft BizTalk Server 2002 Édition Entreprise.

  3. Cliquez sur la vue à laquelle vous souhaitez accéder.

Pour plus d'informations sur l'utilisation des vues dans MOM, reportez-vous à l'aide de Microsoft Operations Manager.


Règles configurées entièrement

Pour améliorer encore les possibilités de contrôle de Microsoft Operations Manager (MOM), BizTalk Server 2002 Management Pack comprend des règles de base entièrement configurées pour tous les événements d'application Windows NT propres à BizTalk Server et pour les compteurs de performances de BizTalk Server.

Cette section traite des rubriques suivantes :

  • Règles d'événements Windows NT

  • Compteurs de performances

Voir aussi

Règles définies par l'utilisateur


Règles d'événements Windows NT

Les règles de contrôle du journal des événements de Windows NT font partie des types de règles configurées entièrement comprises dans BizTalk Server 2002 Management Pack. Tous les événements d'application Windows NT propres à BizTalk Server sont importés en tant que règles de base dans MOM (Microsoft Operations Manager). Les événements Windows NT contrôlés sont répartis en catégories correspondant aux règles suivantes :

  • Événement nécessitant le déclenchement d'une alerte et/ou exigeant une réponse individuelle.

  • Événement à utiliser comme filtre.

  • Événement à consolider avec d'autres événements similaires.

Dans l'arborescence de la console MOM, ces règles sont réparties entre les trois types de règles MOM suivants sous le nœud Microsoft BizTalk Server 2002 :

  • Règles de traitement des événements

  • Règles de traitement des alertes

  • Règles de traitement des performances

Pour plus d'informations sur les règles MOM, reportez-vous à l'aide de Microsoft Operations Manager.

ID d'événement

En général, chaque message d'erreur figurant dans le journal des événements est associé à un ID d'erreur unique. Il arrive cependant que les messages d'erreur soient liés entre eux. Par exemple, une erreur d'ouverture de session peut faire échouer l'accès à la base de données Gestion d'échanges BizTalk, ce qui entraîne une cascade de messages d'erreur parce que les fonctions de réception ne peuvent pas envoyer de messages. Dans ces situations, BizTalk Server 2002 produit pour les erreurs d'échanges un journal d'erreurs unique qui résume toutes les erreurs sous un seul ID d'événement. Si vous consultez la description de l'erreur dans le journal des événements, vous constatez que tous les messages d'erreur générés en cascade sont mentionnés avec leur ID d'événement individuel en première position dans l'entrée.

MOM (Microsoft Operations Manager) utilise l'ID d'événement de chaque message d'erreur individuel dans la description de l'événement pour identifier chaque message d'erreur de manière unique.

Remarque

  • Seuls les erreurs d'échanges donnent lieu à la création de journaux d'erreurs résumés. Pour l'orchestration, chaque erreur est consignée de façon autonome dans le journal d'événements, qu'elle soit ou non due à une erreur antérieure.

Voir aussi

Règles d'événements Windows NT

Copyright © 1999–2001 Microsoft Corporation.
Tous droits réservés.

Ces informations vous ont-elles été utiles ? Veuillez envoyer vos suggestions et commentaires relatifs à la documentation à BizTalk Server Documentation Feedback@microsoft.com


Compteurs de performances

BizTalk Server 2002 Management Pack contient des fournisseurs et des règles pour les compteurs de performances suivants :

  • Échanges. Ces compteurs de performances contrôlent les événements des services d'échanges BizTalk.

  • XLANG. Ces compteurs de performances contrôlent les événements des services d'orchestration BizTalk.

Les valeurs des compteurs sont collectées régulièrement au moyen de règles de mesure. Une règle de mesure est un type de règle de performance qui spécifie la collecte d'une valeur numérique à partir d'un compteur de performance.

Les tableaux suivants dressent la liste des compteurs de performances et fournissent pour chacun une description succincte.

Compteurs de performances des échanges

Compteurs de performances | Description
Envois asynchrones | Entier représentant le nombre d'appels soumis qui ont été effectués depuis le dernier démarrage du service d'échanges BizTalk.
Documents traités | Entier représentant le nombre de documents traités, c'est-à-dire tirés de la file d'attente de travail et envoyés vers l'adresse de destination d'un port, depuis le dernier démarrage du service d'échanges BizTalk.
Documents reçus | Entier représentant le nombre total de documents reçus par BizTalk Server. Il s'agit de tous les documents qui sont passés dans la file d'attente de travail mais aussi de ceux qui ne l'ont pas atteinte.
Échanges reçus | Entier représentant le nombre d'échanges reçus par le moteur d'échanges.
Éléments suspendus | Entier représentant le nombre d'éléments en suspens dans la file d'attente interrompue.
Durée des échanges | Entier représentant la durée de fonctionnement du service d'échanges BizTalk depuis son dernier démarrage.
Envois synchrones | Entier représentant le nombre d'envois synchrones.

Compteurs de performances XLANG

Compteurs de performances | Description
Instances de planification activées | Entier représentant le nombre d'instances de planification activées depuis le dernier démarrage des processus XLANG COM+.
Instances de planification terminées | Entier représentant le nombre d'instances de planification XLANG qui ont réussi depuis le dernier démarrage des processus XLANG COM+ pour un serveur spécifié.
Instances de planification en attente | Entier représentant le nombre total d'instances de planification en attente.
Échec des instances de planification | Entier représentant le nombre d'instances de planification XLANG qui ont échoué pour un serveur spécifié.
Transactions abandonnées | Entier représentant le nombre de transactions interrompues pour les processus XLANG COM+ depuis le dernier démarrage de ces processus.

Remarque

  • Tous les compteurs de performances XLANG indiquent des valeurs cumulées pour tous les processus XLANG exécutés sur un serveur spécifié.

Compteurs de performances des bases de données

Compteurs de règles | Description
Taille de fichier de base de données : BTM | Taille des fichiers de données, en kilo-octets, dans la base de données Gestion d'échanges BizTalk. Ce compteur est utilisé pour créer un affichage relatif.
Taille de fichier de base de données – Erreur : BTM | Taille des fichiers de données, en kilo-octets, dans la base de données Gestion d'échanges BizTalk. Ce compteur est utilisé pour générer une réponse d'erreur.
Taille de fichier de base de données – Avertissement : BTM | Taille des fichiers de données, en kilo-octets, dans la base de données Gestion d'échanges BizTalk. Ce compteur est utilisé pour générer une réponse d'avertissement.
Taille de fichier de base de données : SQ | Taille des fichiers de données, en kilo-octets, dans la base de données de files d'attente partagées de BizTalk Server. Ce compteur est utilisé pour créer un affichage relatif.
Taille de fichier de base de données – Erreur : SQ | Taille des fichiers de données, en kilo-octets, dans la base de données de files d'attente partagées de BizTalk Server. Ce compteur est utilisé pour générer une réponse d'erreur.
Taille de fichier de base de données – Avertissement : SQ | Taille des fichiers de données, en kilo-octets, dans la base de données de files d'attente partagées de BizTalk Server. Ce compteur est utilisé pour générer une réponse d'avertissement.
Taille de fichier de base de données : DTA | Taille des fichiers de données, en kilo-octets, dans la base de données de suivi de BizTalk Server. Ce compteur est utilisé pour créer un affichage relatif.
Taille de fichier de base de données – Erreur : DTA | Taille des fichiers de données, en kilo-octets, dans la base de données de suivi de BizTalk Server. Ce compteur est utilisé pour générer une réponse d'erreur.
Taille de fichier de base de données – Avertissement : DTA | Taille des fichiers de données, en kilo-octets, dans la base de données de suivi de BizTalk Server. Ce compteur est utilisé pour générer une réponse d'avertissement.
Taille de fichier de base de données : XLANG | Taille des fichiers de données, en kilo-octets, dans la base de données de persistance d'orchestration. Ce compteur est utilisé pour créer un affichage relatif.
Taille de fichier de base de données – Erreur : XLANG | Taille des fichiers de données, en kilo-octets, dans la base de données de persistance d'orchestration. Ce compteur est utilisé pour générer une réponse d'erreur.
Taille de fichier de base de données – Avertissement : XLANG | Taille des fichiers de données, en kilo-octets, dans la base de données de persistance d'orchestration. Ce compteur est utilisé pour générer une réponse d'avertissement.
Taille de fichier journal de base de données : BTM | Taille des fichiers journaux, en kilo-octets, de la base de données Gestion d'échanges BizTalk. Ce compteur est utilisé pour créer un affichage relatif.
Taille de fichier journal de base de données – Erreur : BTM | Taille des fichiers journaux, en kilo-octets, de la base de données Gestion d'échanges BizTalk. Ce compteur est utilisé pour générer une réponse d'erreur.
Taille de fichier journal de base de données – Avertissement : BTM | Taille des fichiers journaux, en kilo-octets, de la base de données Gestion d'échanges BizTalk. Ce compteur est utilisé pour générer une réponse d'avertissement.
Taille de fichier journal de base de données : SQ | Taille des fichiers journaux, en kilo-octets, de la base de données de files d'attente partagées de BizTalk Server. Ce compteur est utilisé pour créer un affichage relatif.
Taille de fichier journal de base de données – Erreur : SQ | Taille des fichiers journaux, en kilo-octets, de la base de données de files d'attente partagées de BizTalk Server. Ce compteur est utilisé pour générer une réponse d'erreur.
Taille de fichier journal de base de données – Avertissement : SQ | Taille des fichiers journaux, en kilo-octets, de la base de données de files d'attente partagées de BizTalk Server. Ce compteur est utilisé pour générer une réponse d'avertissement.
Taille de fichier journal de base de données : DTA | Taille des fichiers journaux, en kilo-octets, de la base de données de suivi de BizTalk Server. Ce compteur est utilisé pour créer un affichage relatif.
Taille de fichier journal de base de données – Erreur : DTA | Taille des fichiers journaux, en kilo-octets, de la base de données de suivi de BizTalk Server. Ce compteur est utilisé pour générer une réponse d'erreur.
Taille de fichier journal de base de données – Avertissement : DTA | Taille des fichiers journaux, en kilo-octets, de la base de données de suivi de BizTalk Server. Ce compteur est utilisé pour générer une réponse d'avertissement.
Taille de fichier journal de base de données : XLANG | Taille des fichiers journaux, en kilo-octets, de la base de données de persistance d'orchestration. Ce compteur est utilisé pour créer un affichage relatif.
Taille de fichier journal de base de données – Erreur : XLANG | Taille des fichiers journaux, en kilo-octets, de la base de données de persistance d'orchestration. Ce compteur est utilisé pour générer une réponse d'erreur.
Taille de fichier journal de base de données – Avertissement : XLANG | Taille des fichiers journaux, en kilo-octets, de la base de données de persistance d'orchestration. Ce compteur est utilisé pour générer une réponse d'avertissement.

Remarque

  • Pendant l'installation de BizTalk Server 2002, l'objet base de données Gestion d'échanges BizTalk prend par défaut le nom InterchangeBTM, l'objet base de données de suivi le nom InterchangeDTA, l'objet base de données File d'attente partagée le nom InterchangeSQ et l'objet base de données de persistance d'orchestration le nom XLANG. Si vous avez modifié les noms par défaut de ces objets, vous devez modifier les compteurs de performances des bases de données pour qu'ils pointent vers les bases de données correctes.
Compteurs de règles | Description
Taille de file d'attente interrompue (mesure) | Taille de la file d'attente interrompue de BizTalk Server à un moment donné. Ce compteur est utilisé pour générer une réponse d'avertissement.

Voir aussi

Règles configurées entièrement

Règles définies par l'utilisateur


Règles définies par l'utilisateur

Bien que BizTalk Server 2002 Management Pack fournisse un ensemble complet de règles configurées entièrement pour contrôler BizTalk Server 2002, il se peut que vous vouliez contrôler des événements propres à votre configuration système qui ne sont pas pris en compte dans le module de gestion. Le cas échéant, vous pouvez créer vos propres règles définies par l'utilisateur. L'exemple Suspended Queue Monitoring contient des informations sur la manière de créer des règles définies par l'utilisateur pour contrôler BizTalk Server.

Pour plus d'informations sur la création de règles définies par l'utilisateur, reportez-vous à l'aide de Microsoft Operations Manager.

Voir aussi

Règles configurées entièrement

Suspended Queue Monitoring


Développement d'applications BizTalk Server 2002

Microsoft® BizTalk™ Server 2002 propose des outils et des services permettant de créer des applications exécutables pour contrôler les processus de votre entreprise ainsi que l'échange des données entre des partenaires commerciaux et les applications de votre entreprise.

Cette section traite des rubriques suivantes :

  • Assistant BizTalk SEED

  • Déploiement des applications de ressource BizTalk Server

  • Conception des orchestrations BizTalk

  • Configuration des services d'échanges BizTalk

  • Création de spécifications et mappage de données

  • Intégration des services BizTalk


Assistant BizTalk SEED

L'Assistant BizTalk SEED permet aux entreprises de conditionner leurs configurations Microsoft® BizTalk™ Server 2002 sous la forme d'un package SEED mis à la disposition des partenaires commerciaux sur Internet. Les entreprises qui créent un package SEED doivent encore configurer manuellement BizTalk Server pour recevoir des documents. Toutefois, lors de cette opération, les partenaires commerciaux peuvent configurer BizTalk Server, tester leur configuration et commencer à échanger des documents avec l'entreprise initiatrice. Un package SEED permet aux entreprises de démarrer rapidement une activité commerciale avec leurs partenaires. Il contient les informations suivantes :

  • Nom de l'entreprise initiatrice.

  • Adresses de l'URL de test et de l'URL de production.

  • Référence aux spécifications et données d'instance.

Après la création d'un package SEED, les partenaires commerciaux (destinataires) peuvent télécharger le fichier, l'installer et le configurer avec d'autres informations, notamment :

  • Des informations sur le port (y compris l'emplacement de dépôt pour le test).

  • L'emplacement de dépôt des réceptions.

Étant donné le caractère particulier de chaque relation avec un partenaire commercial, le destinataire doit spécifier des attributs uniques.

Cette section traite des rubriques suivantes :

  • Pour plus d'informations sur l'Assistant BizTalk SEED, voir À propos de l'Assistant BizTalk SEED.

  • Pour connaître les raisons pour lesquelles vous devez effectuer certaines tâches, voir Pourquoi effectuer les tâches de l'Assistant BizTalk SEED ?

  • Pour des informations détaillées sur les procédures à effectuer, voir Comment effectuer les tâches de BizTalk SEED ?

  • Pour obtenir des instructions sur la résolution de problèmes, voir Dépannage de l'Assistant BizTalk SEED.


À propos de l'Assistant BizTalk SEED

L'Assistant BizTalk SEED permet à une entreprise, appelée initiateur dans l'Assistant, de créer un package SEED et de le mettre à la disposition des partenaires commerciaux, appelés destinataires dans l'Assistant. Un destinataire peut ouvrir un package SEED, le configurer et le tester, puis commencer à envoyer des documents vers le site test de l'initiateur du déploiement. Si le destinataire réussit à tester des documents avec le site, l'initiateur du déploiement peut intégrer la configuration du package SEED dans l'environnement de production et entreprendre des transactions avec le destinataire.

Le tableau suivant recense les tâches incluses dans un processus de déploiement rapide.

Tâche | Opérateur ou objet de la tâche
Création d'un package SEED | Initiateur
Sélection du package SEED à envoyer | Initiateur
Envoi ou stockage du package SEED | Initiateur
Configuration du système BizTalk Server du destinataire | Destinataire
Test local de la configuration sur le système du destinataire | Destinataire
Test de la connexion à distance | Destinataire
Utilisation de la configuration dans un environnement de production (sortant) | Initiateur
Utilisation de la configuration dans un environnement de production (entrant) | Destinataire

Lorsqu'un destinataire configure le package SEED, celui-ci configure automatiquement les ports appropriés sur le système du destinataire pour permettre au destinataire de commencer à tester les transactions avec l'entreprise initiatrice. Un port est créé en fonction d'un document et non pas d'un package. Le port est créé uniquement une fois que le destinataire a terminé le processus de configuration et de création d'un document spécifique.

Cette section traite des rubriques suivantes :

  • Initialisation d'un package SEED

  • Réception d'un package SEED

  • Exemple de relation initiateur-destinataire

  • Définition des pages ASP dans SEED


Initialisation d'un package SEED

Un package SEED est créé par un initiateur à l'aide de l'Assistant BizTalk SEED et mis à la disposition des destinataires sur un site Web ou un emplacement de partage de fichiers. Un scénario standard comprend une entreprise unique qui interagit avec plusieurs partenaires commerciaux du même type. L'entreprise centrale est l'initiateur et les partenaires commerciaux sont les destinataires.

Pour définir une nouvelle relation avec un destinataire ou tout simplement commencer à gérer les nouveaux documents d'un destinataire existant, l'initiateur utilise l'Assistant BizTalk SEED pour créer un package SEED. Le package SEED comprend les informations suivantes :

  • Nom de l'initiateur : Nom de l'entreprise qui initialise la connexion. Cette puce est globale au package SEED. Toutefois, les puces suivantes sont spécifiques à chaque document.

  • URL de test : http://test.<nom_initiateur>/invoice (site de test auquel le destinataire enverra les documents pendant la phase de test à distance.)

  • URL de production : http://www.<URL_initiateur>/b2b/invoices.

  • Spécification: c:\specification\invoice.xml.

  • Données : Données d'instance XML (Extensible Markup Language) pour la spécification.

Voir aussi

Création d'un package SEED


Réception d'un package SEED

En tant que destinataire, vous pouvez avoir reçu un package SEED d'une entreprise ou l'avoir téléchargé du site Web de l'entreprise. Après avoir enregistré le package SEED sur votre ordinateur, vous pouvez utiliser l'Assistant BizTalk SEED pour terminer la configuration et tester le processus de réception et d'envoi de documents.

Lorsque le package SEED est installé sur votre ordinateur, il crée les ports, les canaux, les définitions de documents et les fonctions de réception nécessaires. Le titre de chaque port, canal, définition de document et fonction de réception commence par le nom du package SEED. Cette convention d'appellation garantit l'unicité des noms attribués aux objets du package SEED. Elle permet également de distinguer des autres objets, les objets de package SEED qui peuvent avoir été installés sur les serveurs BizTalk.

L'Assistant BizTalk SEED affiche les informations suivantes concernant le package SEED sur la page Processus d'installation de package – Sélection du package :

  • ID de package. Numéro d'identification unique global (GUID) généré.

  • Organisation. Nom spécifié par l'entreprise initiatrice qui a créé le package SEED.

  • Nombre de documents. Spécifie le nombre de documents dans le package SEED.

  • Opération recommandée. Tâches impliquées dans la configuration, la création et le test du package. Les conditions suivantes sont possibles :
    • Il existe au moins un document à configurer.

    • Il existe au moins un document à installer.

    • Il existe au moins un document à tester localement.

    • Il existe au moins un document à tester à distance.

    • Il existe au moins un document prêt pour la production.

    • Le package entier est installé et est en production.

L'Assistant affiche également tous les documents associés à un package SEED sur la page Processus d'installation de package – Déploiement de document. Pour chaque document, vous devez effectuer les tâches suivantes pour vérifier et déployer la configuration :

  • Configurer. Ce processus définit les informations des propriétés du port. Il peut avoir l'état Configuration complète (Configure Complete) ou Configuration incomplète (Configure Incomplete).

  • Créer. Ce processus crée les objets nécessaires (par exemple, les fonctions de réception, les ports et les canaux). Son état indique Réussite de la création (Create Passed) lorsque les objets ont été créés ou Échec de la création (Create Failed) dans le cas contraire.

  • Tester localement. Lorsque l'Assistant effectue un test local, il dépose les données d'instance de la spécification dans le répertoire de réception que vous avez désigné pour les documents entrants, ou bien il les envoie de manière synchronisée à l'URL distante pour les documents sortants. Pour les documents identifiés comme étant de type entrant, BizTalk Server 2002 prélève le fichier et le place dans l'emplacement de dépôt pour le test afin d'effectuer une vérification du test local. L'instance est prélevée par l'Assistant BizTalk SEED, puis vérifiée au niveau du format et du contenu, et l'état de la spécification est mis à jour dans le package SEED. Ceci garantit que le format du document est correct. Si le format de l'instance est correct, l'état de la spécification dans le package SEED est mis à jour. Pour les documents identifiés comme étant de type sortant, le processus SubmitSync est d'abord appelé. Ensuite, BizTalk Server traite le document et le dépose dans l'emplacement de dépôt final. L'Assistant BizTalk SEED prélève alors le document de l'emplacement de dépôt final et vérifie les données. Les conditions suivantes sont possibles :
    • Test local en cours (Local Test in Process). L'instance est en cours de vérification.

    • Réussite du test local (Local Test Passed). L'instance a été vérifiée.

    • Échec du test local (Local Test Failed). L'instance n'a pas été vérifiée.
  • Tester à distance. Lorsque l'Assistant effectue un test à distance pour les documents entrants, il met à jour l'adresse de transport en lui appliquant l'URL de test qui fait partie du package SEED. Le document est ensuite renvoyé en mode synchrone à BizTalk Server. Le site Web de l'initiateur renvoie alors le document sous la forme d'une partie de la réponse HTTP. L'Assistant BizTalk SEED vérifie la réponse. Pour les documents sortants, la date est convertie dans les en-têtes XML (Extensible Markup Language) qui contiennent l'URL de production du destinataire et le canal utilisé pour traiter le document. En utilisant le canal spécifié, cette page appelle la méthode Submit qui publie le document de nouveau sur l'URL de production (localsubmit.asp), sur le site Web de l'initiateur. Le document est ensuite déposé dans l'emplacement de dépôt final où il est prélevé et vérifié par l'Assistant BizTalk SEED. Ce processus doit être répété pour chaque spécification restante. Pour plus d'informations sur les pages .asp, voir Définition des pages ASP dans SEED.

  • Déployer. Seuls les documents identifiés comme étant entrants peuvent être déployés. Ce processus indique l'état Réussite du déploiement (Deploy Passed) lorsque la configuration a été déployée ou Échec du déploiement (Deploy Failed) dans le cas contraire.

Voir aussi

Installation d'un package SEED


Exemple de relation initiateur-destinataire

Pour connaître les composants qui constituent un package SEED, vous devez d'abord comprendre la relation entre un initiateur et un destinataire. (Cet exemple décrit un scénario qui utilise deux entreprises fictives comme initiateur et destinataire.) Un scénario classique comporte un initiateur (la société Les Comptoirs dans notre exemple) et un ou plusieurs destinataires (Contoso, Ltd.). Le département d'approvisionnement de la société Les Comptoirs (initiateur du scénario de déploiement) reçoit les factures de plusieurs partenaires commerciaux (les destinataires) pour divers ordres de demande de maintenance.

Le service d'approvisionnement dispose d'un site Web où il reçoit les factures des fournisseurs (destinataires). Les documents envoyés à cet emplacement sont des fichiers XML (Extensible Markup Language) qui adhèrent à une spécification de l'Éditeur BizTalk appelée Invoice.xml. Les documents sont vérifiés dès leur réception à cet emplacement et à l'emplacement de test du destinataire.

La société Les Comptoirs dispose également d'un site de test configuré pour recevoir les documents et les valider par rapport à la spécification. Si le document correspond à la spécification, les données sont envoyées au destinataire. Le site de test est l'emplacement utilisé par tous les destinataires pour tester leurs transactions avant de renvoyer les fichiers au site de production de l'initiateur. Les destinataires envoient les transactions au site de test de l'initiateur jusqu'à ce que leur traitement s'effectue sans erreur. Cette procédure permet de s'assurer que l'échange des transactions sur le site de production se déroulera normalement.

La société Les Comptoirs crée le package SEED et le place sur son site Web pour le mettre à la disposition de ses destinataires. Le destinataire (la société Contoso, Ltd.) télécharge le package SEED, puis utilise l'Assistant BizTalk SEED pour terminer la configuration qui nécessite l'ajout d'informations sur le port et parfois sur la fonction de réception.

Une fois que Contoso, Ltd. a configuré le package SEED, l'Assistant BizTalk SEED crée le canal et le port appropriés pour configurer le site du destinataire afin qu'il puisse communiquer avec le site de test de l'initiateur. Contoso, Ltd. teste l'instance d'exemple en la soumettant au canal (et au port associé) qui l'envoie à son tour à la page ASP de test.

Une fois le test terminé sans erreur, Contoso, Ltd. peut passer à un environnement réel.

Voir aussi

Initialisation d'un package SEED

Réception d'un package SEED


Définition des pages ASP dans SEED

L'Assistant BizTalk SEED contient les trois pages ASP (Active Server Pages) suivantes : slingback.asp, trigger.asp et localsubmit.asp. Ces pages ASP sont situées dans le dossier \Program Files\Microsoft BizTalk Server\SEED. Avant de créer un package SEED, vous devez définir un site Web et y placer les fichiers Slingback.asp, Trigger.asp et Localsubmit.asp. Ces pages sont conçues pour enregistrer des envois. Pour plus d'informations sur l'implémentation d'un site sécurisé, consultez le site Web MSDN Online Library (en anglais) à l'adresse msdn.microsoft.com/library/, puis recherchez l'article « Implementing a Secure Site with ASP ».

Les paragraphes suivants expliquent comment l'Assistant BizTalk SEED utilise ces fichiers :

  • Slingback.asp. Cet ASP permet d'effectuer le test à distance des documents entrants. Lors de la création d'un package SEED, l'initiateur doit utiliser cette page ou une autre page offrant la même fonctionnalité dans la zone URL pour le test à distance. Lorsque le destinataire clique sur le bouton Tester à distance, le document est envoyé à BizTalk Server 2002 en mode synchrone par l'intermédiaire de slingback.asp. Une copie du document est ensuite renvoyée au destinataire, et l'Assistant BizTalk SEED vérifie que le document reçu en retour est conforme à celui envoyé.

  • Trigger.asp. Cet ASP est utilisé pour tester à distance les documents sortants. Lors de la création d'un package SEED, l'initiateur doit taper trigger.asp dans le champ URL pour le test à distance pour les documents sortants. Le document est transmis à la page trigger.asp avec l'URL de production du destinataire et le canal utilisé par le destinataire pour traiter le document, l'ensemble étant intégré dans un fichier XML (Extensible Markup Language). Sur la page trigger.asp (côté initiateur), une demande de destination ouverte est appelée avec l'URL de production du destinataire (en général localsubmit.asp) en tant qu'adresse de transport.

  • Localsubmit.asp. Cet ASP permet de tester à distance les documents sortants. Le destinataire utilise l'URL de production localsubmit.asp. Lorsque localsubmit.asp reçoit le document, le canal est extrait du fichier XML et le document est envoyé à BizTalk Server avec le canal spécifié.

Voir aussi

Création d'un package SEED


Pourquoi effectuer les tâches de l'Assistant BizTalk SEED ?

Cette section explique succinctement pourquoi il est nécessaire d'effectuer les tâches de l'Assistant BizTalk SEED. Le tableau suivant présente les tâches principales et l'objet de chaque tâche, en indiquant les liens vers les procédures correspondantes.

Tâche Objet de la tâche
  • Création d'un package SEED
 Créer un package XML (Extensible Markup Language) contenant votre configuration BizTalk Server 2002 (pour les documents sortants et entrants) que vous pouvez mettre à la disposition du personnel de votre organisation ou de vos partenaires commerciaux pour commencer le processus d'échange des données.
  • Installation d'un package SEED
 Installer un package XML contenant la configuration BizTalk Server 2002 de l'initiateur (pour les documents sortants et entrants) que vous pouvez utiliser pour tester le processus de transaction avant de mettre en place votre activité commerciale dans un environnement de production.


Comment effectuer les tâches de BizTalk SEED ?

Cette section fournit des informations spécifiques aux tâches relatives à la création et à l'installation d'un package SEED.

Cette section traite des procédures suivantes :

  • Création d'un package SEED

  • Installation d'un package SEED


Création d'un package SEED

Avant de créer un package SEED, vous devez définir un site Web et y placer les fichiers Slingback.asp, Trigger.asp et Localsubmit.asp (situés dans le dossier \Program Files\Microsoft BizTalk Server\SEED). Ces pages sont conçues pour enregistrer des envois. Pour plus d'informations sur l'implémentation d'un site sécurisé, consultez le site Web MSDN Online Library (en anglais) à l'adresse msdn.microsoft.com/library/, puis recherchez l'article « Implementing a Secure Site with ASP ».

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Assistant BizTalk SEED.

    L'Assistant BizTalk SEED s'ouvre.

  2. Sur la page Assistant BizTalk SEED, sélectionnez Créer un package SEED, puis cliquez sur Suivant.

  3. Sur la page Processus de création de package - Informations sur l'organisation, entrez le nom de votre organisation dans la zone correspondante.

    — ou —

    Cliquez sur Parcourir pour rechercher et utiliser un package SEED existant. La boîte de dialogue Ouvrir apparaît. Recherchez le package SEED que vous souhaitez utiliser et cliquez sur Ouvrir.

    Important

    • Lorsque vous modifiez un package SEED existant, le bouton Parcourir est désactivé. Vous ne pouvez pas revenir à la page Processus de création de package - Informations sur l'organisation et recharger le package SEED. Pour recharger le même package SEED après y avoir apporté des modifications, cliquez sur Annuler pour quitter l'Assistant. Ouvrez l'Assistant BizTalk SEED de nouveau et, sur la page Processus de création de package - Informations sur l'organisation, accédez au package SEED initial.
  4. Cliquez sur Suivant.

  5. Sur la page Processus de création de package - Spécifications de documents, cliquez sur Ajouter.

    La boîte de dialogue Configurer un document s'affiche.

  6. Cliquez sur Parcourir en regard de la zone Spécification pour localiser une spécification.

    La boîte de dialogue Sélection d'une spécification de document dans le référentiel WebDAV apparaît.

  7. Accédez à l'emplacement de la spécification, sélectionnez le fichier, puis cliquez sur Ouvrir.

  8. Cliquez sur Parcourir en regard de la zone Instance de test pour localiser une instance de document.

    La boîte de dialogue Ouvrir apparaît.

  9. Accédez à l'emplacement de l'instance du document, sélectionnez le fichier, puis cliquez sur Ouvrir.

  10. Sélectionnez Entrant (vers l'initiateur) ou Sortant (de l'initiateur).

  11. Dans la zone URL pour le test à distance, entrez le chemin d'accès au serveur qui contient la page Slingback.asp si vous avez sélectionné Entrant (vers l'initiateur) à l'étape 10 ou la page Trigger.asp si vous avez sélectionné Sortant (de l'initiateur) à cette même étape. Si vous avez sélectionné Sortant (de l'initiateur) à l'étape 10, cliquez sur OK. Si vous avez sélectionné Entrant (vers l'initiateur) à l'étape 10, passez à l'étape 12.

    Remarque

    • Si vous avez cliqué sur OK, la page Processus de création de package - Spécifications de documents apparaît. Si cela est nécessaire, effectuez les opérations de l'étape 13. Sinon, passez à l'étape 14.
  12. Si vous avez sélectionné Entrant (vers l'initiateur), dans la zone URL de production, tapez le chemin d'accès au serveur de production et cliquez sur OK.

    La page Processus de création de package - Spécifications de documents apparaît. Si cela est nécessaire, effectuez les opérations de l'étape 13. Sinon, passez à l'étape 14.

  13. Pour modifier la configuration d'un document :
    1. Sélectionnez une spécification dans la liste Documents et cliquez sur Modifier.

      La boîte de dialogue Configurer un document s'affiche.

    2. Modifiez les options telles qu'elles sont spécifiées dans les étapes 3 à 9.

    Pour supprimer une spécification dans la liste Documents :

    • Sélectionnez la spécification concernée dans la liste Documents et cliquez sur Supprimer.
  14. Cliquez sur Suivant.

  15. Sur la page Fin de l'Assistant BizTalk SEED, cliquez (si nécessaire) sur Parcourir pour indiquer le nouvel emplacement du package SEED, puis cliquez sur Terminer pour installer celui-ci à l'emplacement spécifié dans le champ Chemin d'accès au package SEED.

    La zone de message Assistant BizTalk SEED apparaît.

  16. Cliquez sur OK.

Voir aussi

Exemple de relation initiateur-destinataire

Initialisation d'un package SEED

Installation d'un package SEED

Définition des pages ASP dans SEED


Installation d'un package SEED

Si ce n'est déjà fait, installez tous les fichiers (à l'exception de Localsubmit.asp) dans le répertoire souhaité. Installez le fichier Localsubmit.asp dans un répertoire virtuel accessible pendant la configuration des documents sortants contenus dans un package SEED.

  1. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2002, puis cliquez sur Assistant BizTalk SEED.

    L'Assistant BizTalk SEED s'ouvre.

  2. Sur la page Assistant BizTalk SEED, sélectionnez Installer un package SEED, puis cliquez sur Suivant.

  3. Sur la page Processus d'installation de package - Sélection du package, cliquez sur Parcourir pour localiser le package SEED.

    La boîte de dialogue Ouvrir apparaît.

  4. Accédez à l'emplacement du package SEED, sélectionnez le fichier, puis cliquez sur Ouvrir.

  5. Cliquez sur Suivant.

  6. Sur la page Processus d'installation de package - Informations de test, tapez un nombre dans les zones Délai d'expiration et Intervalle, puis cliquez sur Suivant.

    Important

    • Si votre package SEED contient des documents importants, le résultat des tests peut indiquer l'état Délai d'expiration ou Échec.

    • La valeur affichée dans la zone Délai d'expiration est ajoutée à la valeur du cache d'administration spécifiée dans les paramètres de groupe BizTalk Server.
  7. Sur la page Processus d'installation de package - Déploiement de document, sélectionnez une spécification dans la zone Documents, puis cliquez sur Configurer.

    Important

    • Si le document a été initialement configuré comme Entrant (vers l'initiateur) pendant le processus de création, la boîte de dialogue Configuration du document entrant (vers l'initiateur) apparaît. Passez à l'étape 9.

    • Si le document a été initialement configuré comme Sortant (de l'initiateur) pendant le processus de création, la boîte de dialogue Configuration du document sortant (vers l'initiateur) apparaît. Passez à l'étape 14.
  8. Dans la boîte de dialogue Configuration du document entrant (vers l'initiateur), cliquez sur Parcourir en regard de la zone Emplacement pour indiquer l'emplacement d'interrogation de la fonction de réception.

    La boîte de dialogue Rechercher un dossier apparaît.

    Remarque

    • L'emplacement spécifié doit être différent de celui mentionné dans la zone Emplacement de dépôt pour le test.
  9. Sélectionnez l'emplacement de la fonction de réception et cliquez sur OK.

  10. Dans la zone Types de fichiers à interroger, indiquez le type de fichier à rechercher.

    Remarque

    • Si vous souhaitez modifier le type de fichier, vérifiez que le type de fichier par défaut est inclus dans le package SEED.
  11. Cliquez sur Parcourir en regard de la zone Emplacement de dépôt pour le test pour indiquer cet emplacement.

    La boîte de dialogue Rechercher un dossier apparaît.

    Remarque

    • L'emplacement spécifié doit être différent de celui indiqué dans le champ Emplacement de la zone Fonction de réception.
  12. Sélectionnez un emplacement de dépôt pour le test cliquez sur OK.

    La page Processus d'installation de package - Déploiement de document apparaît à l'écran.

  13. Si votre document a été initialement configuré à l'aide de l'option Configuration du document entrant (vers l'initiateur), passez à l'étape 16.

  14. Dans la boîte de dialogue Configuration du document sortant (vers l'initiateur), dans la zone URL de production, entrez l'emplacement de la page localsubmit.asp.

  15. Dans la zone Emplacement de dépôt final, cliquez sur Parcourir pour définir cet emplacement pour le test des documents sortants, puis cliquez sur OK.

  16. Cliquez sur Créer.

    Remarque

    • Le bouton Créer est remplacé par le bouton Supprimer lorsque le processus de création est terminé.
  17. Cliquez sur Tester localement pour vérifier la configuration locale uniquement.

  18. Cliquez sur Tester à distance pour vérifier la connectivité à distance vers l'initiateur.

    Si le champ Initiateur du document est de type Sortant, passez à l'étape 20.

  19. Cliquez sur Déployer.

    Le bouton Déployer est activé uniquement si le champ Initiateur du document est marqué Entrant.

  20. Cliquez sur Suivant.

    La page Fin de l'Assistant BizTalk SEED apparaît.

  21. Cliquez sur Terminer.

  22. Cliquez sur OK pour la zone Message de l'Assistant BizTalk SEED.

Voir aussi

Exemple de relation initiateur-destinataire

Réception d'un package SEED


Dépannage de l'Assistant BizTalk SEED

Cette section fournit des informations de dépannage des packages SEED.

Cette section traite de la rubrique suivante :

  • Échec ou expiration d'un test local ou à distance


Échec ou expiration d'un test local ou à distance

Cause : Les options Tester localement ou Tester à distance pour les documents sortants indiquent un délai d'expiration.

Solutions :

  1. Vérifiez le journal des événements. Si aucune erreur n'a été consignée pour le fichier, augmentez la durée indiquée dans la zone Délai d'expiration sur la page Processus d'installation de package - Informations de test.

  2. Si le fichier journal mentionne des erreurs pour ce fichier, corrigez-les en fonction des informations fournies.

  3. Si l'instance de document contenue dans le package SEED porte le même nom qu'un autre fichier stocké dans l'emplacement de dépôt pour le test, BizTalk Server l'ajoute au fichier qui existe dans cet emplacement. Par conséquent, l'instance de document ne correspond plus à l'instance exemple contenue dans le package SEED. Renommez le fichier qui existe dans l'emplacement de test ou supprimez-le et cliquez sur Tester localement ou Tester à distance.

Cause : L'option Tester à distance pour les documents entrants n'a pas fonctionné.

Solutions :

  1. Consultez le journal des événements. Si aucune erreur n'a été consignée pour le fichier, augmentez la durée indiquée dans la zone Délai d'expiration sur la page Processus d'installation de package - Informations de test.

  2. Si le fichier journal mentionne des erreurs pour ce fichier, corrigez-les en fonction des informations fournies.

  3. Si l'instance de document contenue dans le package SEED porte le même nom qu'un autre fichier stocké dans l'emplacement de dépôt pour le test, BizTalk Server l'ajoute au fichier qui existe dans cet emplacement. Par conséquent, l'instance de document ne correspond plus à l'instance exemple contenue dans le package SEED. Renommez le fichier qui existe dans l'emplacement de test ou supprimez-le et cliquez sur Tester localement ou Tester à distance.

  4. Si le problème provient de l'absence de réponse du système initiateur, patientez quelques instants, puis cliquez sur Tester à distance.


Déploiement des applications de ressources de BizTalk Server

Microsoft® Application Center 2000 peut être utilisé pour déployer une nouvelle configuration de Microsoft BizTalk™ Server 2002 ; par exemple, pour passer d'un environnement de test à un environnement de production. Le fait de déployer un environnement à l'aide de Application Center permet de réduire considérablement le temps nécessaire au changement de configuration et le volume de configuration manuelle associé à une telle opération.

Grâce au pilote de réplication BizTalk Server, Application Center réplique les ressources BizTalk vers tous les membres d'un cluster et entre les clusters. Ce pilote utilise le support de réplication de Application Center.

Il remplace la méthode de déploiement (BTConfigAssistant) offerte par BizTalk Server 2000. BTConfigAssistant, l'exemple d'application Microsoft Visual Basic®, inclus dans la première version de BizTalk Server, permettait aux entreprises d'extraire les informations de configuration pour déployer des applications. Bien que cette méthode soit encore disponible dans BizTalk Server 2002, il est recommandé d'utiliser Application Center pour le déploiement des applications.

Cette section traite des rubriques suivantes :

  • Pour obtenir des informations complètes sur le déploiement, voir À propos du déploiement de BizTalk Server.

  • Pour un aide-mémoire expliquant les raisons pour lesquelles effectuer certaines tâches, voir Pourquoi déployer BizTalk Server.

  • Pour prendre connaissance des procédures détaillées à suivre afin d'effectuer certaines tâches, voir Comment déployer BizTalk Server.

  • Pour obtenir des instructions sur la résolution de problèmes, voir Dépannage du déploiement de BizTalk Server.


À propos du déploiement de BizTalk Server

Microsoft Application Center 2000, membre de la famille de produits .NET Enterprise Servers, prend en charge le déploiement de plusieurs ressources BizTalk Server 2002, à savoir les ports (y compris tous les objets associés aux ports, tels que les canaux), les groupes de ports, ainsi que les fichiers, les applications COM+, les clés de registre, les sites Web et répertoires virtuels et les sources de données.

Un environnement de production BizTalk Server standard est constitué d'une base de données Gestion d'échanges BizTalk qui stocke les informations de configuration d'échange nécessaires, et d'un groupe de serveurs de réplication qui se partagent la configuration des échanges. Chaque serveur du cluster contient les planifications XLANG requises, les applications COM+ associées à ces dernières et les informations relatives à la base de données Gestion d'échanges, à utiliser pour déployer une application.

Lorsque vous déployez une application, la base de données Gestion d'échanges BizTalk doit être disponible sur l'ordinateur source, comme sur l'ordinateur cible, car seul le référentiel WebDAV (Web Distributed Authoring and Versioning) est pris en charge.

Important

  • Vous devez ajouter un compte système local (system\<nom d'ordinateur>) à un serveur Microsoft® SQL Server™ distant pour éviter que le pilote Application Center 2000 tombe en panne lorsque SQL Server est installé à distance. Pour accéder à la base de données Gestion d'échanges BizTalk (InterchangeBTM) à partir d'un cluster Application Center, celle-ci doit être installée, soit sur le même ordinateur que le contrôleur de cluster Application Center, soit en dehors du cluster Application Center. En effet, il est possible que le pilote de réplication BizTalk Server 2002 ne puisse pas accéder à la base de données Gestion d'échanges BizTalk, si celle-ci est hébergée sur un membre du cluster Application Center.

Le pilote de réplication BizTalk Server sur Application Center possède deux fonctions principales :

  1. Déplacement des ressources locales. Cette tâche suppose que le serveur source référence ses ressources locales pour les répliquer vers un serveur cible. La réplication automatique est prise en charge.

  2. Déplacement des ressources partagées. Cette tâche consiste à recueillir les informations appropriées dans la base de données Gestion d'échanges BizTalk, puis à conserver ces informations et à les transmettre au serveur cible. La réplication automatique n'est pas prise en charge.

Pour déplacer des ressources partagées, Application Center (à l'aide du pilote de réplication BizTalk Server) contacte, sur le serveur source, la base de données Gestion d'échanges BizTalk en utilisant le modèle d'objet de configuration d'échanges BizTalk, plutôt que de lire directement la base de données SQL Server. Ce procédé fournit une protection contre toute modification future de la configuration de BizTalk Server et garantit l'application des contraintes générées par le modèle d'objet.

En fonction des trois scénarios de configuration système ci-dessous, le processus de transfert des informations partagées serait le suivant :

Deux clusters partageant la même base de données de configuration.

L'illustration précédente représente deux clusters. Chaque membre d'un cluster se réfère à la même base de données Gestion d'échanges BizTalk. Par conséquent, lorsque les données sont synchronisées entre les membres de chaque cluster, les informations de configuration n'ont pas besoin d'être transférées. En revanche, lors du déploiement d'une application, les informations de configuration devront être transférées, car chaque cluster utilisera sa propre base de données Gestion d'échanges BizTalk.

Clusters partageant une base de données Gestion d'échanges BizTalk

L'illustration précédente montre comment une application est déployée au sein d'un cluster dans lequel la base de données Gestion d'échanges BizTalk est partagée. Dans ce scénario, même un déploiement « hors cluster » ne nécessite le transfert d'aucune ressource partagée.

Clusters utilisant différentes bases de données Gestion d'échanges BizTalk

Dans l'illustration précédente, chaque membre d'un cluster utilise différentes bases de données Gestion d'échanges BizTalk. Dans ce cas de figure, étant donné qu'il y a plusieurs bases de données pour chaque membre de cluster, toutes les synchronisations doivent nécessiter le transfert des informations locales et des informations partagées dans les bases de données Gestion d'échanges BizTalk respectives.

Important

  • Ce dernier scénario n'est pas pris en charge dans les versions actuelles d'Application Center et de BizTalk Server. Toutefois, cette configuration système devrait fonctionner correctement et vous permettre de déployer vos applications.

Mais, quel que soit le scénario de configuration système que vous utilisez, le transfert d'informations partagées entre des bases de données, se déroule de la façon suivante :

  1. Le pilote de réplication BizTalk Server sur le serveur source envoie à la base de données cible une requête comportant les noms des ressources partagées présentes sur le serveur source pour déterminer les données à mettre à jour.

  2. Le pilote sur le serveur cible renvoie une liste d'actions contenant les ajouts, mises à jour et suppressions nécessaires à la synchronisation des ressources partagées.

  3. Le serveur source lit les informations appropriées dans sa base de données à l'aide du modèle d'objet de configuration d'échanges BizTalk et génère un manifeste indiquant ce qui doit être transféré.

  4. Le pilote de réplication BizTalk Server sur le serveur source délègue le manifeste au pilote de réplication du système de fichiers Application Center pour le transférer au serveur source.

  5. Le pilote sur le serveur source envoie au serveur cible une liste de mises à jour contenant les modifications à appliquer. Cette liste comporte des références au manifeste propagé sur le serveur cible.

  6. Sur le serveur cible, le pilote de réplication BizTalk Server lit le manifeste et effectue les modifications appropriées dans ses bases de données Gestion d'échanges BizTalk correspondantes.

La procédure de base pour déployer une application nouvelle ou existante est la suivante :

  1. Si nécessaire, vous devez créer un cluster sur l'ordinateur à partir duquel vous effectuez le déploiement et sur celui vers lequel vous l'effectuez. En outre, vous devez définir un cluster Application Center correspondant à un groupe BizTalk Server, et définir un ordinateur comme étant le contrôleur de ce cluster.

  2. Créez une nouvelle application ou sélectionnez une application existante dans Application Center.

  3. Ajoutez les ressources BizTalk ainsi que d'autres ressources, telles que les fichiers, les applications COM+ et les clés de registre appropriés.

  4. Déployez l'application à partir de l'ordinateur source vers l'ordinateur cible.

Cette section traite des rubriques suivantes :

  • À propos des clusters

  • Création d'applications

  • Ajout de ressources

  • Déploiement d'applications


À propos des clusters

Microsoft Application Center 2000 permet de gérer plusieurs clusters à partir d'un seul ordinateur. Dans Application Center, vous pouvez :

  • créer des clusters ;

  • joindre des clusters existants ;

  • ajouter et supprimer des membres de cluster ;

  • déployer un nouveau contenu ;

  • configurer l'équilibrage de charge ;

  • surveiller les performances des clusters.

En outre, Application Center fournit une image unique et unifiée du contenu installé sur un cluster. Pour vous aider, Application Center fournit des Assistants (par exemple l'Assistant New Cluster) qui simplifient les procédures de création et de gestion des clusters et de déploiement de contenu.

Un cluster Application Center peut desservir les clients d'un intranet d'entreprise ou des clients externes sur Internet. Les logiciels clients peuvent être des applications clientes « légères » (par exemple, les navigateurs Web) ou « lourdes » (telles que les programmes Microsoft Visual Basic). Les clusters Application Center sont destinés à gérer à la fois la couche Web, qui dessert les clients HTTP, et la couche de logique d'entreprise, qui dessert le trafic DCOM (Distributed Component Object Model).

Important

  • Pour accéder à la base de données Gestion d'échanges BizTalk (InterchangeBTM) à partir d'un cluster Application Center, Microsoft Application Center utilise Microsoft® Windows® Authentication. Pour accéder à la base de données Gestion d'échanges BizTalk (InterchangeBTM) à partir d'un cluster Application Center, celle-ci doit être installée, soit sur le même ordinateur que le contrôleur de cluster Application Center, soit en dehors du cluster Application Center. Si la base de données Gestion d'échanges BizTalk est installée en dehors du cluster Application Center, vous devez ajouter un compte système local à un serveur SQL Server distant pour éviter que le pilote Application Center tombe en panne lorsque SQL Server est installé à distance. En effet, si le serveur SQL Server sur lequel est installée la base de données est membre du cluster Application Center et non du contrôleur de cluster, il est possible que vous ne puissiez pas accéder à la base de données Gestion d'échanges BizTalk. Pour des instructions détaillées sur l'ajout d'un compte de connexion SQL Server, reportez-vous à la rubrique « Compte de connexion SQL Server à distance » dans Interactions entre les bases de données SQL Server et BizTalk Server 2002.

Remarque

  • Vous pouvez utiliser Application Center pour gérer la disponibilité et le déploiement d'applications sur des serveurs autonomes (non architecturés en cluster) ou sur des serveurs qui n'exécutent pas de sites Web. Dans ces cas de figure, Application Center considère un serveur autonome comme un « cluster mono-serveur ».


Création d'applications

Dans le contexte de Microsoft Application Center 2000, une application est un manifeste qui répertorie les ressources synchronisées au sein d'un cluster ou déployées vers celui-ci. Une application contient des ressources, c'est-à-dire qu'elle répertorie les références à ces dernières, si bien que plusieurs applications peuvent répertorier une même ressource. Lorsque vous synchronisez ou déployez une application Microsoft Application Center, les ressources répertoriées dans l'application sont également synchronisées ou déployées.

La création de nouvelles applications Microsoft Application Center vous permet de gérer la synchronisation et le déploiement de vos ressources, ainsi que des ressources BizTalk. Pour plus d'informations sur la création d'applications Microsoft Application Center, reportez-vous à l'Aide de Application Server 2000. Ce mode d'utilisation des applications permet de contrôler plus facilement les ressources à synchroniser ou à déployer et le moment auquel effectuer ces opérations. Par ailleurs, vous pouvez créer une application pour répertorier un sous-ensemble d'applications par défaut ou les ressources qui ne figurent pas dans une application par défaut.


Ajout de ressources

Grâce à Microsoft Application Center 2000, vous avez la possibilité d'ajouter des ressources à une application. Une ressource BizTalk peut être considérée comme un objet comportant un nom unique et un ensemble de propriétés. Les ressources Biztalk (ports, groupes de ports, compteurs personnalisés et fonctions de réception), représentent la configuration d'une application spécifique qui repose sur Microsoft BizTalk Server 2002. Vous spécifiez les ressources à associer à l'application que vous souhaitez déployer.

Important

  • Dans les noms de ressource, n'utilisez pas le signe plus (+), étant donné que dans le format .asp (sur le serveur) il est converti en espace. Par exemple, « BizTalkorg+port » est converti en « BizTalkorg port ». Si vous déployez une application contenant un nom de ressource dans lequel figure le signe plus, aucun manifeste ne sera généré et aucun fichier ne sera transféré. Pourtant, Application Center indiquera que le déploiement de l'application s'est correctement déroulé. Lorsque le nom d'une ressource contient le signe plus, remplacez ce symbole par %2B sur l'ordinateur client.

Le tableau suivant décrit le type de ressources BizTalk qu'il est possible d'ajouter à une application et les éléments spécifiques qui sont automatiquement inclus.

Ressource BizTalk Éléments automatiquement ajoutés Remarques
Port Tous les éléments associés suivants :
  • Canaux

  • Définitions de document

  • Organisations

  • Enveloppes
  • Tous les éléments liés au port sont déployés ; en revanche, les éléments non liés, tels que les documents et les enveloppes, ne sont pas déplacés automatiquement. Les exemples comprennent des enveloppes et des documents. Ce sont des enveloppes qui sont utilisées pour analyser les fichiers plats entrants. Ils comprennent également des documents utilisés pour analyser les réceptions entrantes.
Groupe de ports

(Groupe de distribution)

 Tous les ports du groupe

Tous les éléments ajoutés correspondant à un port, pour chaque port du groupe.
  • Tous les éléments liés au groupe de ports sont déployés ; en revanche, les éléments non liés, tels que les documents et les enveloppes, ne sont pas déplacés automatiquement. Les exemples comprennent des enveloppes et des documents. Ce sont des enveloppes qui sont utilisées pour analyser les fichiers plats entrants. Ils comprennent également des documents utilisés pour analyser les réceptions entrantes.
Fonction de réception Aucun élément supplémentaire n'est ajouté.
  • Si nécessaire, vous devez ajouter manuellement la ressource Système de fichiers utilisée par la fonction de réception ou créer le service Message Queuing (également appelé MSMQ) sur le serveur cible.
Compteur personnalisé Aucun élément supplémentaire n'est ajouté.
  • Avec les compteurs personnalisés, il faut tenir compte d'un certain nombre de propriétés et de restrictions. Pour plus d'informations, voir Custom Counters, Creating a Custom Counter Using WMI et Custom Counter Query Properties.

Outre les ressources BizTalk, Application Center permet d'ajouter les ressources suivantes :

  • Chemin du système de fichiers

  • Clés du Registre

  • Sites Web et répertoires virtuels

  • Applications COM+

  • Sources de données

Chemin du système de fichiers

Affiche la réplication des dossiers du système de fichiers. Vous pouvez, par exemple, utiliser la ressource Chemin du système de fichiers pour déployer les planifications XLANG ou les répertoires utilisés par les fonctions de réception et le transport des fichiers.

Important

  • Vous devez utiliser la ressource Chemin du système de fichiers pour ajouter des planifications XLANG (fichiers .skx) à l'application que vous voulez déployer. Les planifications XLANG doivent être enregistrées en local sur l'ordinateur sur lequel elles s'exécuteront.

Clés du Registre

Cette ressource fournit un accès au Registre. La synchronisation de la totalité du Registre dans un cluster pouvant générer des conflits importants sur les membres du cluster, cette opération n'est pas recommandée.

Sites Web et répertoires virtuels

Cette ressource fournit la liste des sites Web IIS (Internet Information Services) et des répertoires virtuels disponibles (y compris les fichiers, certificats, listes d'approbation de certificats et filtres ISAPI référencés par le site ou le répertoire virtuel). Lorsque vous spécifiez ces informations, il suffit d'ajouter le site Web ou le répertoire virtuel. Il est, en effet, inutile de spécifier explicitement les répertoires physiques ou les fichiers qui constituent le site Web ou le répertoire virtuel. Par exemple, les fonctions de réception HTTP et les sites Web auxquels les partenaires commerciaux répondent.

Remarque

  • Application Center synchronise uniquement les ressources qui sont spécifiées sur le système de fichiers local et non les ressources spécifiées avec un chemin UNC ou sur un support amovible.

Applications COM+

Cette ressource affiche toutes les applications COM+, les proxy et les composants disponibles. Elle peut servir à déplacer les composants d'intégration d'application et les composants des planifications, dans la mesure où il s'agit d'applications COM+. Pour plus d'informations, reportez-vous à l'Aide de Application 2000.

Important

  • Vous devez utiliser la ressource Applications COM+ pour ajouter des applications COM+ qui ont été liées aux planifications XLANG en vue du déploiement des applications.

  • Seules les applications COM+ correctement enregistrées (sur l'ordinateur sur lequel elles sont exécutées) avec les services de composants, sur le serveur local, peuvent être ajoutées. Si une application COM+ n'apparaît pas dans le composant logiciel enfichable Application Center, vous ne pouvez pas l'ajouter à une application. Pour ajouter des composants COM aux listes d'applications, vous devez les installer dans les applications COM+.

Sources de données

Cette ressource spécifie les noms des sources de données système (DNS) disponibles. Seuls les DSN sur le serveur local peuvent être ajoutés aux applications. Les DSN sur les serveurs distants ne sont pas disponibles tant que vous ne les avez pas créés sur le serveur local.


Déploiement d'applications

Le déploiement est un processus qui consiste à copier l'image initiale d'une application Microsoft Application Center 2000 d'un cluster dans un autre. Généralement, le déploiement se produit depuis un cluster de test vers un cluster de production contenant le contenu réel. Au cours du déploiement, l'image de l'application est copiée dans le contrôleur de cluster du cluster destinataire.

Cette section traite des rubriques suivantes :

  • Planification d'un déploiement

  • Liste de vérification des tâches préalables au déploiement

  • Liste de vérification des tâches ultérieures au déploiement

  • Éléments non déployés et/ou non répliqués

  • Synchronisation des ressources BizTalk


Planification d'un déploiement

Avant de déployer des applications, identifiez les ressources qui constituent l'application BizTalk. Les ressources constituent l'un des types d'éléments suivants :

  • Des informations de configuration (stockées dans la base de données Gestion d'échanges BizTalk), comportant :
    • des ports (qui incluent automatiquement des canaux, définitions de document, enveloppes et organisations associés) ;

    • des listes de distribution ;

    • des fonctions de réception ;

    • des compteurs personnalisés.
  • Des composants externes, comprenant :
    • des fichiers ;

    • des clés de Registre ;

    • des composants d'intégration d’application ;

    • des certificats ;

    • des files d'attente de messages (MSMQ) ;

    • des planifications XLANG (fichiers .skx) ;

    • des composants personnalisés (cryptage, codage, sérialisation).

Une fois les ressources identifiées, regroupez-les en applications Microsoft Application Center.


Liste de vérification des tâches préalables au déploiement

Avant de déployer une application avec des ressources BizTalk, vérifiez les points suivants.

Cluster source

  • Assurez-vous que la base de données Gestion d'échanges BizTalk est accessible.

  • Veillez à ce que le référentiel WebDAV (Web Distributed Authoring and Versioning) soit accessible.

  • Il n'y a pas de mappage automatique des variables, telles que les adresses de transport, étant donné que ces types de variables varient d'un environnement à l'autre. Vous devez modifier manuellement les adresses de transport.

  • Vous devez copier directement les planifications XLANG (fichiers .skx) dans le cluster dans lequel l'application est déployée.

  • L'arrêt et le démarrage des services avant ou après le déploiement d'une application doivent être effectué si vous devez réactualiser le cache immédiatement. Pour plus d'informations, voir Démarrage d'un serveur dans un groupe ou Arrêt d'un serveur dans un groupe. Pour plus d'informations sur le réglage de la fréquence de réactualisation, voir Configuration des propriétés générales d'un groupe de serveurs.

  • Avant de mettre à jour une application déjà déployée qui contient des ressources BizTalk, assurez-vous que toutes les transactions de longue durée sont terminées.

Cluster cible

  • Assurez-vous que la base de données Gestion d'échanges BizTalk est accessible.

  • Veillez à ce que l'hôte SMTP (Simple Mail Transfer Protocol) soit défini pour chaque groupe de serveurs BizTalk et chaque URL de réponse d'échanges au format Reliable. Utilisez la console Administration de BizTalk Server.

  • Assurez-vous de la présence des certificats requis, car les certificats ne sont pas automatiquement déployés.

  • Veillez à ce que le référentiel WebDAV soit accessible, sinon, les définitions de document et les enveloppes risquent de ne pas se répliquer.

  • Enregistrez les composants d'intégration d'application sur le serveur cible.

  • Créez les files d'attente des messages requises par les fonctions de réception du service Message Queuing.

  • Arrêtez les serveurs de traitement.


Liste de vérification des tâches ultérieures au déploiement

Après avoir déployé une application, ce qui signifie qu'elle est correctement ajoutée à l'ordinateur cible, vous devez effectuer manuellement certaines modifications pour terminer le processus de déploiement de l'application qui est, désormais, présente sur l'ordinateur cible. Cette rubrique récapitule les zones dont vous pouvez avoir besoin, en fonction des ressources associées à l'application que vous avez déployée.

Bases de données

Une fois le déploiement terminé, vous devez effectuer quelques petits ajustements sur l'ordinateur cible. Par exemple, si l'application utilise des bases de données de corrélation, vous devez les copier manuellement dans l'instance SQL Server de l'ordinateur cible. Pour des instructions pas à pas sur cette procédure, reportez-vous à la fonctionnalité « Attach the databases » décrite dans la section Installation préliminaire de l'exemple d'approvisionnement électronique. Vous pouvez également utiliser les services DTS (Data Transformation Services) de SQL Server pour exporter les bases de données vers l'instance SQL Server de l'ordinateur cible.

Fonctions de réception

Il peut s'avérer nécessaire d'activer toutes les fonctions de réception de BizTalk utilisées par une application. L'activation des fonctions de réception peut s'effectuer dans le composant Administration de BizTalk Server ou à l'aide d'un programme, en utilisant le fournisseur WMI (Windows Management Instrumentation) de BizTalk Server. Vous pouvez être amené à effectuer cette opération, car les fonctions de réception sont créées avant les files d'attentes de messages, qui sont créées manuellement. BizTalk Server 2002 désactive automatiquement les fonctions de réception si leur emplacement d'interrogation correspondant (par exemple un répertoire) n'est pas disponible.

En effet, il peut être nécessaire de mettre à jour le serveur de traitement des fonctions de réception. Chaque fonction de réception est associée à un serveur de traitement. Les noms des serveurs de traitement du cluster source sont mappés sur le nom du serveur cible, généralement le contrôleur de cluster, dans le cluster cible. Vous pouvez mettre à jour le serveur de traitement des fonctions de réception dans la console Administration de BizTalk Server ou à l'aide d'un programme en utilisant le fournisseur WMI (Windows Management Instrumentation).

Si vous répliquez des fonctions de réception configurées pour utiliser un nom d'utilisateur et un mot de passe, la fonction de réception répliquée ne sera pas active car le mot de passe ne sera plus valide. Pour résoudre ce problème, vous devez ouvrir la page de propriétés de chaque fonction de réception, entrer de nouveau le mot de passe, puis activer la fonction de réception.

Ports

Si vous avez déployé une application Microsoft Application Center 2000 avec des ports BizTalk, les ports sur l'ordinateur cible doivent être mis à jour pour que les adresses de port principales et secondaires référencent les emplacements corrects. Il peut être nécessaire, par exemple, de changer http://TestAURL par http://ProductionAURL. Lorsque Application Center effectue le déploiement de la configuration de BizTalk Server 2002 d'un ordinateur vers un autre, il ne modifie pas les ports BizTalk.

Remarque

  • Pour que ces modifications prennent effet, il peut s'avérer nécessaire de démarrer et d'arrêter le service BizTalk. Vous pouvez effectuer cette opération dans l'outil Administration de BizTalk Server. Pour plus d'informations, voir Démarrage d'un service BizTalk et Arrêt d'un service BizTalk.

Serveurs de traitement

Après avoir déployé une application, vous devez démarrer les serveurs de traitement.


Éléments non déployés et/ou non répliqués

Les documents et les enveloppes qui ne sont pas liés à des ports ne sont pas déployés. Par exemple, les enveloppes et les documents qui sont des enveloppes, qui sont utilisés pour analyser les fichiers plats entrants, et les documents qui sont utilisés pour analyser les réceptions entrantes. Les certificats utilisés par les ports et les canaux pour le cryptage, le décryptage et la signature ne sont pas répliqués. Vous devez les copier directement dans le cluster dans lequel vous déployez l'application. Ceci s'applique également aux autres objets qui ne sont pas répliqués, tels que les certificats.

Les objets non répliqués doivent être présents sur le serveur cible avant le déploiement de l'application. Par exemple, lorsqu'une application Microsoft Application Center 2000 possède un canal utilisant un composant d'intégration d'application et que vous déployez l'application, rien ne garantit que l'application COM+ qui contient le composant d'intégration d'application ne soit créée avant la création du canal qui référence le composant.

De même, la hiérarchie des fichiers pour les listes d'attente des fonctions de réception et du service Message Queuing n'est pas répliquée. Ceci provient du fait que les files d'attente des fonctions de réception et du service Message Queuing sont associées à des serveurs de traitement BizTalk Server 2002 spécifiques, qui sont identifiés par leur nom. Par exemple, les fonctions de réception R1 et R2 associées aux ordinateurs Test1 et Test2 dans un environnement de test doivent être associées aux ordinateurs ProdA et ProdB dans un environnement de production. Le service Message Queuing lié aux planifications doit être copié directement dans le cluster dans lequel l'application est déployée.


Synchronisation des ressources BizTalk

Contrairement au reste des ressources Application Center 2000, les ressources BizTalk ne sont pas synchronisées automatiquement. C'est pourquoi, si vous modifiez une ressource BizTalk pour une application Microsoft Application Center qui est déjà déployée, vous devrez de nouveau déployer l'application Microsoft Application Center. Pour plus d'informations sur le déploiement d'une application Microsoft Application Center contenant des ressources BizTalk, voir Déploiement d'une application Microsoft Application Center sur un serveur cible.


Pourquoi déployer BizTalk Server

Cette section explique les raisons pour lesquelles il est nécessaire de déployer BizTalk Server. Le tableau suivant présente les tâches principales et leurs sous-tâches. Il présente également l'objet de chaque tâche et fournit des liens vers les procédures correspondantes.

Tâche Objet de la tâche
  • Création d'une application Microsoft Application Center contenant des ressources BizTalk
 Pour regrouper de manière logique les informations de configuration de BizTalk telles que les ports, les composants d'intégration d'application, les planifications XLANG et toutes les autres ressources grâce auxquelles une application BizTalk est prête pour son déploiement.
  • Déploiement d'une application Microsoft Application Center sur un serveur cible
 Pour déplacer les applications BizTalk récemment développées, de l'environnement de développement vers un environnement de test ou de production.
  • Suppression de ressources BizTalk d'un serveur cible
 Pour supprimer des ressources inutilisées ou obsolètes.


Comment déployer BizTalk Server

Cette section fournit des informations spécifiques aux tâches relatives à la création d'une nouvelle application Microsoft Application Center ou à la modification d'une application Microsoft Application Center existante contenant des ressources BizTalk ; elle explique également comment déployer l'application Microsoft Application Center sur un ordinateur cible.

Cette section traite des rubriques suivantes :

  • Création d'une application Microsoft Application Center contenant des ressources BizTalk

  • Déploiement d'une application Microsoft Application Center sur un serveur cible

  • Suppression de ressources BizTalk d'un serveur cible


Création d'une application Microsoft Application Center contenant des ressources BizTalk

Il est préférable de déployer les ressources individuellement, plutôt que d'ajouter un dossier les contenant. En effet, si vous déployez des ressources en sélectionnant un dossier, lorsque, ultérieurement, vous aurez besoin d'en supprimer une, vous devrez supprimer la totalité des ressources dans l'ordinateur de déploiement. Pour plus d'informations sur la suppression des ressources, voir Suppression de ressources BizTalk d'un serveur cible.

  1. Cliquez sur Démarrer, pointez sur Programmes et Outils d'administration, puis cliquez sur Application Center.

    Microsoft Application Center 2000 s'ouvre.

  2. Développez Application Center, développez le cluster auquel vous voulez ajouter l'application Microsoft Application Center, puis cliquez sur Applications.

  3. Dans le volet Applications, cliquez sur New ou, dans ce même volet, sélectionnez une application Microsoft Application Center existante dans la colonne Name.

    La boîte de dialogue Create a new application – Web Page Dialog s'affiche.

  4. Dans la zone Name, tapez un nom pour l'application, puis cliquez sur OK.

    Le nom de votre application Microsoft Application Center s'affiche dans la colonne Name du volet Applications.

  5. Sélectionnez l'application Microsoft Application Center que vous venez de créer et dans le volet Contents, sélectionnez BizTalk dans la liste Resource Type pour ajouter les ressources BizTalk, puis cliquez sur Add.

    La boîte de dialogue Add Resource – Web Page Dialog s'affiche.

  6. Pour ajouter toutes les ressources pour un type de ressource BizTalk, sélectionnez le type de ressource et cliquez sur Add ou, pour sélectionner des ressources individuelles, double-cliquez sur la ressource (BizTalkCustomCounters, BizTalkPortGroups, BizTalkPorts ou BizTalkReceiveFunctions) que vous souhaitez ajouter.

    La boîte de dialogue Add Resource – Web Page Dialog s'affiche.

    Remarque

    • Dans le Gestionnaire d'échanges BizTalk, les listes de distribution sont les mêmes que le type de ressource BizTalkPortGroups.
  7. Cliquez sur la ressource à ajouter, puis cliquez sur Add.

  8. Répétez les étapes 6 et 7 jusqu'à ce que vous ayez ajouté toutes les ressources souhaitées. Si vous ajoutez des ressources individuelles, cliquez sur Close lorsque vous avez terminé l'ajout de toutes les ressources nécessaires.

  9. Pour ajouter des planifications XLANG, dans le volet Contents, sélectionnez File System Paths dans la liste Resource Type.

    La boîte de dialogue Add Resource – Web Page Dialog s'affiche.

  10. Accédez à l'emplacement du fichier de planification, sélectionnez-le et cliquez sur Add. Répétez cette procédure pour tous les fichiers de planification nécessaires, puis cliquez sur Close.


Déploiement d'une application Microsoft Application Center sur un serveur cible

  1. Cliquez sur Démarrer, pointez sur Programmes et Outils d'administration, puis cliquez sur Application Center.

    Microsoft Application Center 2000 s'ouvre.

  2. Développez Application Center, cliquez avec le bouton droit sur le cluster contenant l'application Microsoft Application Center que vous souhaitez déployer, puis cliquez sur New Deployment.

    L'Assistant New Deployment s'ouvre.

  3. Cliquez sur Suivant.

  4. Sur la page Deployment Target Options, tapez un nom dans la zone Deployment name ou laissez le nom par défaut.

  5. Sélectionnez Deploy content outside the current cluster et cliquez sur Next.

  6. Sur la page Deployment Target Authentication, tapez les informations d'authentification appropriées dans les zones User name, Password et Domain, puis cliquez sur Next.

  7. Sur la page Deployment Target, dans la zone Target, tapez le nom de l'ordinateur sur lequel vous souhaitez déployer l'application Microsoft Application Center ou cliquez sur Browse pour naviguer jusqu'à l'emplacement.

    Remarque

    • Vous devez déployer les ressources BizTalk uniquement sur le contrôleur Application Center.
  8. Cliquez sur Ajouter.

  9. Sur la page Deployment Content, sélectionnez Deploy all applications and related cluster configurations ou Deploy one or more applications.

    Si vous activez l'option Deploy one or more applications, sélectionnez dans la liste une ou plusieurs applications Microsoft Application Center à déployer. Pour sélectionner plusieurs éléments, appuyez sur la touche CTRL et maintenez-la enfoncée, tout en cliquant sur chaque élément.

  10. Cliquez sur Suivant.

  11. Sur la page Deployment Options, activez l'option appropriée. Si nécessaire, désactivez l'option Deploy folder and file permissions (NTFS only).

  12. Cliquez sur Suivant.

  13. Sur la page Completing the New Deployment Wizard, cliquez sur Finish.

Important

  • Si vous répliquez des fonctions de réception configurées pour utiliser un nom d'utilisateur et un mot de passe, la fonction de réception sera désactivée du fait de l'absence de mot de passe. Vous devez ressaisir les mots de passe car, par souci de sécurité, le pilote de réplication BizTalk Server ne réplique pas les mots de passe. Pour résoudre ce problème, vous devez ouvrir la page de propriétés de chaque fonction de réception, entrer de nouveau le mot de passe, puis activer la fonction de réception.


Suppression de ressources BizTalk d'un serveur cible

Si vous avez déjà déployé une application Microsoft Application Center sur un serveur cible et que vous voulez supprimer des ressources associées à cette application, procédez de la façon suivante :

  1. Ajoutez chaque ressource que vous souhaitez supprimer de l'ordinateur sur lequel vous effectuez le déploiement, puis déployez l'application. Pour plus d'informations, voir Déploiement d'une application Microsoft Application Center sur un serveur cible.

  2. Supprimez les ressources BizTalk de l'ordinateur que vous avez utilisé pour déployer l'application Microsoft Application Center. Le tableau suivant présente la liste des fonctions à utiliser pour supprimer des ressources précises.
    Pour supprimer | Utilisez | Informations supplémentaires
    Des ressources BizTalkPortGroups (également appelées listes de distribution) | Le Gestionnaire d'échanges BizTalk ou le modèle objet de configuration d'échanges (accessible via Microsoft Visual Basic Scripting Edition (VBScript) | Pour plus d'informations, voir Suppression de listes de distribution.
    Des ressources BizTalkPorts | Le Gestionnaire d'échanges BizTalk ou le modèle objet de configuration d'échanges (accessible via VBScript) | Pour plus d'informations, voir Suppression de ports d'échanges.
    Des ressources BizTalkReceiveFunctions | La console Administration de BizTalk Server ou le fournisseur WMI de BizTalk Server (Windows Management Instrumentation) (accessible via VBScript) | Pour plus d'informations, voir Suppression d'une fonction de réception.
    Des ressources Fichiers de planification | L'Explorateur Windows | Pour plus d'informations, reportez-vous à l'Aide de Windows 2000.
    Des ressources BizTalkCustomCounters | La console Administration de BizTalk Server ou le fournisseur WMI de BizTalk Server | Aucune.

  3. Déployez de nouveau l'application Microsoft Application Center avec la ressource que vous souhaitez supprimer de l'ordinateur sur lequel vous effectuez le déploiement. Pour plus d'informations, voir Déploiement d'une application Microsoft Application Center sur un serveur cible.


Dépannage du déploiement de BizTalk Server

Cette section centralise toutes les informations nécessaires pour résoudre les problèmes de déploiement des applications Microsoft Application Center 2000 contenant des ressources BizTalk. Si vous avez des difficultés à déployer une application Microsoft Application Center, vous pouvez consulter cette section pour y rechercher une solution.

Cette section traite des rubriques suivantes :

  • Une application Microsoft Application Center demande des ressources mises à jour

  • Un message d'erreur indique que des informations d'authentification des privilèges administratifs sont nécessaires


Une application Microsoft Application Center demande des ressources mises à jour

Cause : L'URL de référence ou le nom de fichier du référentiel WebDAV (Web Distributed Authoring and Versioning) a été modifié pour un document BizTalk (reportez-vous à l'onglet Nouvelle définition de document dans le Gestionnaire d'échanges BizTalk) qui a été déployé dans le cadre d'une application Microsoft Application Center.

Solution : Supprimez les ressources dans l'ordinateur cible et déployez de nouveau l'application Microsoft Application Center. Pour effectuer cette opération :

  1. Supprimez les ressources de l'ordinateur que vous avez utilisé pour déployer l'application Microsoft Application Center. Le tableau suivant présente la liste des fonctions à utiliser pour supprimer des ressources précises.
    Pour supprimer | Utilisez | Informations supplémentaires
    Des ressources BizTalkPortGroups (également appelées listes de distribution) | Le Gestionnaire d'échanges BizTalk ou le modèle d'objet de configuration d'échanges (accessible via Microsoft Visual Basic Scripting Edition (VBScript) | Pour plus d'informations, voir Suppression de listes de distribution.
    Des ressources BizTalkPorts | Le Gestionnaire d'échanges BizTalk ou le modèle d'objet de configuration d'échanges (accessible via VBScript) | Pour plus d'informations, voir Suppression de ports d'échanges.
    Des ressources BizTalkReceiveFunctions | La console Administration de BizTalk Server ou le fournisseur WMI de BizTalk Server (Windows Management Instrumentation) (accessible via VBScript) | Pour plus d'informations, voir Suppression d'une fonction de réception.
    Des ressources Fichiers de planification | L'Explorateur Windows | Pour plus d'informations, reportez-vous à l'Aide de Windows 2000.
    Des ressources BizTalkCustomCounters | La console Administration de BizTalk Server ou le fournisseur WMI de BizTalk Server | Aucune.

  2. Déployez de nouveau l'application Microsoft Application Center. Pour plus d'informations, voir Déploiement d'une application Microsoft Application Center sur un serveur cible.

  3. Modifiez l'URL de référence ou le nom de fichier du référentiel WebDAV pour le document.

  4. Créez un port et un canal pour ce document. Pour plus d’informations, voir Création de ports d’échanges et Création de canaux.

  5. Déployez de nouveau l'application Microsoft Application Center contenant le document modifié. Pour plus d'informations, voir Déploiement d'une application Microsoft Application Center sur un serveur cible.


Un message d'erreur indique que des informations d'authentification des privilèges administratifs sont nécessaires

Cause : Lorsque vous tentez de déployer l'application Microsoft Application Center contenant des ressources BizTalk vers un autre ordinateur (le serveur cible), un message d'erreur s'affiche, indiquant que des informations d'authentification des privilèges administratifs sont nécessaires. Le message d'erreur s'affiche dans le journal des événements du contrôleur du cluster cible.

Solution : Configurez des privilèges administratifs pour BizTalk Server pour le serveur cible et redéployez l'application Microsoft Application Center.

Remarque

  • L'utilisateur n'a pas besoin de privilèges d'administrateur pour le groupe Administrateur de BizTalk Server ; en revanche, il a besoin de privilèges d'administrateur pour le serveur cible.


Conception des orchestrations BizTalk

Le Concepteur d'Orchestration Microsoft® BizTalk™ est un outil de conception basé sur Microsoft Visio® 2000 qui permet de créer des schémas de processus professionnels pouvant être compilés et exécutés sous forme de planifications XLANG. XLANG est un langage XML (Extensible Markup Language). Une planification XLANG décrit le processus professionnel et la liaison de ce processus aux services d'application.

Vous pouvez recourir au Concepteur d'Orchestration BizTalk pour créer des schémas décrivant des processus professionnels exécutables de longue durée et asynchrones. En règle générale, ces schémas décrivent le déroulement des interactions et des procédures pendant l'exécution d'un processus, tel qu'une requête d'ordre d'achat. Souvent, ces processus professionnels ne sont pas soumis à des délais. De même, les étapes d'un processus professionnel sont asynchrones. La description du processus professionnel est distincte de la logique et de la séquence d'implémentation utilisées pour exécuter ce processus.

Cette section traite des rubriques suivantes :

  • Pour plus d'informations sur le Concepteur d'Orchestration BizTalk, voir À propos du Concepteur d'Orchestration BizTalk.

  • Pour un aide-mémoire expliquant les raisons pour lesquelles vous devez effectuer des tâches spécifiques, voir Pourquoi utiliser le Concepteur d'Orchestration BizTalk.

  • Pour des informations détaillées sur les procédures à effectuer, voir Comment utiliser le Concepteur d'Orchestration BizTalk.


À propos du Concepteur d'Orchestration BizTalk

Cette section fournit des informations détaillées sur les concepts essentiels à la compréhension du Mappeur BizTalk. Elle contient des informations détaillées sur les rubriques suivantes :

  • Services d'orchestration BizTalk

  • Création de schémas de planification XLANG

  • Compilation des planifications XLANG

  • Débogage des planifications XLANG

  • Exécution des planifications XLANG

  • Création de réserves de planifications XLANG

  • Gestion de l'état de session

  • Mise à jour des planifications XLANG

Remarque

  • Il est recommandé de consulter la section Exécution des tâches du Concepteur d'Orchestration BizTalk pour accéder aux informations relatives à l'utilisation du Concepteur d'Orchestration BizTalk.


Services d'orchestration BizTalk

Les services d'orchestration BizTalk augmentent les possibilités des technologies d'échange d'informations établies. Ils permettent aux utilisateurs de créer des représentations détaillées de processus professionnels pouvant être implémentés par programmation au sein d'un environnement de conception intégré.

La conception et l'implémentation de processus professionnels s'effectuent généralement en deux phases distinctes, à savoir : la phase de conception visuelle et la phase de codage. En règle générale, la phase de conception visuelle comprend l'analyse d'un processus professionnel existant (par exemple l'approvisionnement de l'entreprise) et la création d'un diagramme de workflow ou d'un diagramme d'interaction décrivant le processus. La phase de codage est généralement effectuée séparément. Dans cet exemple, vous êtes amené à construire un modèle visuel abstrait d'un processus professionnel, puis à mapper ce modèle vers une structure d'implémentation.

Une des fonctionnalités importantes de l'orchestration BizTalk est l'intégration de ces phases distinctes en un environnement de conception unifié. Cet environnement de conception offre une surface de dessin polyvalente ainsi qu'un vaste ensemble d'outils d'implémentation. L'orchestration BizTalk vous permet d'effectuer les tâches suivantes :

  • Créer des schémas de planification XLANG décrivant les processus professionnels.

  • Implémenter des processus professionnels en connectant des actions spécifiques dans un schéma vers des ports représentant les emplacements vers lesquels les messages sont envoyés, ou à partir desquels les messages sont reçus. Les ports sont des emplacements nommés, tandis que les messages représentent les données envoyées ou reçues entre les actions et les ports.

  • Définir le flux de données entre les messages au sein des processus professionnels.

  • Compiler des schémas de planification XLANG en planifications XLANG. Les planifications XLANG sont des représentations XML (Extensible Markup Language) exécutables des informations contenues dans les schémas.

Outre l'intégration de la conception et de l'implémentation, l'orchestration BizTalk offre une fonctionnalité supplémentaire importante : la possibilité de créer des processus professionnels robustes, longs et librement couplés au travers de diverses organisations, plates-formes et applications. Dans un processus professionnel asynchrone librement couplé et long, il se peut qu'un produit commandé via Internet doive être assemblé à partir de pièces détachées en stock. Certaines de ces pièces détachées peuvent être temporairement en rupture de stock. Le processus professionnel complet peut durer des semaines ou des mois. À l'opposé, un processus professionnel fortement couplé implique l'échange synchrone de messages. Par exemple, lorsqu'un client retire de l'argent d'un compte bancaire, le débit du compte est immédiatement suivi de la livraison de l'argent.

L'orchestration BizTalk vous permet d'effectuer les tâches suivantes :

  • Créer une représentation visuelle de processus professionnels à exécution longue.

  • Faciliter l'échange des messages en connectant les actions de votre représentation visuelle à des ports implémentés par une technologie donnée.

  • Compiler le schéma terminé en une représentation XML exécutable du schéma.

  • Exécuter de manière fiable des processus professionnels pendant plusieurs semaines ou plusieurs mois.

Cette section traite des rubriques suivantes :

  • Description des processus professionnels

  • Environnement du Concepteur d'Orchestration BizTalk

  • Planifications XLANG

Voir aussi

Création de schémas de planification XLANG

Description des processus professionnels


Description des processus professionnels

Les processus professionnels sont aussi importants pour la gestion d'une entreprise que les lignes d'assemblage le sont pour la fabrication. Le respect d'un ensemble de processus bien définis et formalisés peut permettre à toute entreprise d'accroître sa productivité et de diminuer ses coûts. Un processus professionnel définit le protocole d'échange des messages entre tous les participants distribués. Pour définir un processus professionnel, vous devez déterminer l'ordre logique des actions ainsi que le flux correspondant des messages. Un processus professionnel n'inclut pas les définitions des participants distribués qui effectuent ces actions.

La séquence des étapes d'un processus professionnel à exécution longue est généralement asynchrone. Chaque étape est constituée d'une action qui peut être effectuée par un ou plusieurs participants distribués et indépendants. Ces actions peuvent provoquer l'envoi et la réception de messages entre les participants, lesquels peuvent être ou non les exécutants des tâches concernées. Un participant distribué peut être un processus automatique qui répond à une entrée ; le participant peut même être un processus professionnel totalement séparé. Pour comprendre les processus professionnels, vous devez pouvoir visualiser un ensemble complexe de relations et de dépendances. Des outils de modélisation de processus professionnels, tels que les diagrammes de workflow et les diagrammes d'interaction, ont été développés dans le but de décrire visuellement ces relations.

Cette section traite des rubriques suivantes :

  • Diagrammes de workflow

  • Diagrammes d'interaction


Diagrammes de workflow

La Gestion automatisée (ou workflow) est une technologie de conception de processus professionnels qui automatise et améliore les procédures au sein des organisations. Il s'agit d'une technologie utile permettant de représenter les étapes à effectuer, les contraintes à satisfaire, et les accords à obtenir pendant la réalisation des projets. Vous pouvez utiliser une application de Gestion automatisée (ou workflow) pour affecter les tâches aux membres de l'équipe, définir les responsabilités individuelles et décrire les relations entre les participants au projet. Vous pouvez également utiliser une application de Gestion automatisée (ou workflow) pour définir des limites de temps pour la réalisation des projets et le respect de leurs jalons. Cependant, la technologie de Gestion automatisée (ou workflow) est généralement fortement centralisée. Les participants se voient affectés des tâches et des délais, tandis que le moteur de Gestion automatisée (ou workflow) est responsable de l'acheminement des travaux terminés d'un participant à l'autre, et du respect du planning. Le champ d'application de l'orchestration BizTalk est plus étendu. Les participants y sont autonomes et la responsabilité du routage des travaux entre les différents participants est déterminée par ces derniers et non par une application centralisée.

Voir aussi

Diagrammes d'interaction

Description des processus professionnels


Diagrammes d'interaction

Un diagramme d'interaction décrit le flux de données dans un processus professionnel ainsi que les messages échangés. L'orchestration BizTalk étend le concept de diagramme d'interaction en fournissant définitions et contrôles de décisions, actions simultanées, transactions et actions prises en charge ne pouvant être incluses dans un diagramme d'interaction. La conception d'un processus professionnel à l'aide de l'orchestration BizTalk résulte en un processus professionnel compilé et exécutable (planification XLANG). En revanche, les diagrammes d'interaction sont des représentations statiques des processus professionnels.

Le diagramme d'interaction typique pour un système d'approvisionnement automatisé est présenté ci-après.

Voir aussi

Description des processus professionnels

Diagrammes de workflow


Environnement du Concepteur d'Orchestration BizTalk

Le Concepteur d'Orchestration BizTalk permet de créer des schémas de planification XLANG. Un schéma de planification XLANG est la représentation d'un processus professionnel. Le schéma est enregistré sous la forme d'un fichier .skv, qui est une version personnalisée du format de fichier Microsoft Visio 2000. Le schéma de planification XLANG peut ensuite être compilé en une planification XLANG, qui est un fichier texte .skx de structure XML, reconnu par le moteur de XLANG Scheduler. Le Concepteur d'Orchestration BizTalk permet de créer les schémas de planification XLANG suivants :

  • Description visuelle d'un processus professionnel Cet aspect d'un schéma de planification XLANG est similaire à un diagramme de workflow ou à un diagramme d'interaction.

  • Représentation visuelle de ports configurables Il s'agit de l'aspect d'implémentation d'un schéma de planification XLANG.

  • Représentation visuelle des connexions entre les formes Les formes Diagramme de flux peuvent être connectées pour représenter le flux de processus dans un processus professionnel, tandis que les actions peuvent être connectées aux ports pour représenter le flux de communication dans un processus professionnel.

  • Représentation visuelle du flux entre les champs de messages spécifiés Cet aspect d'un schéma de planification XLANG détermine la relation entre un champ d'un message et un autre champ d'un message différent. La mise en corrélation de ces relations permet d'activer le routage sensible aux données.

Un schéma de planification XLANG est une représentation des procédures exécutées pendant un processus professionnel. Un schéma de planification XLANG peut définir :

  • le protocole d'échange de messages que les partenaires commerciaux s'accordent à utiliser ;

  • les actions utilisées pour envoyer ou recevoir des messages décrivant la séquence logique dans laquelle les actions se produisent ;

  • l'implémentation des ports et les actions auxquelles ils sont liés ;

  • le flux de données entre les champs de messages.

Cette section traite des rubriques suivantes :

  • Pages de conception

  • Formes Diagramme de flux

  • Formes Implémentation

  • Formes Communication

  • Touches de raccourci du Concepteur d'Orchestration BizTalk


Pages de conception

Quatre pages de conception sont accessibles dans le Concepteur d'Orchestration BizTalk. Vous pouvez utiliser ces pages de conception pour créer différents aspects de votre schéma de planification XLANG.

  • Page Processus professionnel Sur cette page, vous pouvez utiliser les formes Diagramme de flux et les formes Implémentation pour définir un processus professionnel. Pour plus d'informations sur l'utilisation de ces formes, voir Formes Diagramme de flux et Formes Implémentation.

  • Page Données Sur cette page, vous pouvez utiliser les formes Communication pour contrôler la direction dans laquelle les messages sont envoyés. Le Concepteur d'Orchestration BizTalk fournit automatiquement ces formes. Pour plus d'informations sur l'utilisation de ces formes, voir Formes Communication.

  • Page En cas d'échec de Transaction Sur cette page, vous pouvez utiliser les formes Diagramme de flux et Implémentation pour concevoir un processus professionnel de remplacement en cas d'échec d'une transaction.

  • Page Compensation pour Transaction Sur cette page, vous pouvez utiliser les formes Diagramme de flux et Implémentation pour concevoir un processus d'annulation pour une transaction imbriquée validée. Pour plus d'informations sur les transactions, voir Conception de transactions.

Voir aussi

Gestion des exceptions


Formes Diagramme de flux

Le Concepteur d'Orchestration BizTalk fournit huit formes Diagramme de flux, disponibles sur le stencil Diagramme de flux. Ces formes servent à décrire votre processus professionnel. Les huit formes du stencil Diagramme de flux peuvent être utilisées pour décrire la structure et la signification des planifications XLANG. XLANG est un langage basé sur XML (Extensible Markup Language qui décrit les interactions entre les processus professionnels.

Les formes Diagramme de flux sont présentées au tableau suivant.

Nom de la forme Description
Début

La forme Début n'est pas disponible sur le stencil Diagramme de flux, elle ne peut pas être supprimée et vous ne pouvez pas créer de formes Début supplémentaires. La forme Début représente le début d'un schéma de planification XLANG. La forme Début est créée automatiquement sur chaque page Processus professionnel, Compensation pour Transaction et En cas d'échec de Transaction. La forme Début qui apparaît sur la page Processus professionnel possède des propriétés configurables. Les formes Début qui apparaissent sur les pages Compensation pour Transaction et En cas d'échec de Transaction ne possèdent pas de propriétés configurables. Vous ne pouvez pas inclure une forme Début dans une transaction. La séquence des processus professionnels doit relier la forme Début à la première forme Diagramme de flux de votre schéma.
Action

La forme Action représente un processus qui reçoit un message depuis un port ou envoie un message vers un port. L'action d'envoi ou de réception peut être synchrone ou asynchrone, en fonction du composant ou de l'implémentation à laquelle le port est lié.
Décision

La forme Décision représente un processus qui évalue séquentiellement une ou plusieurs règles.

Cette forme possède un flux entrant et un ou plusieurs flux sortants. Chaque flux sortant est associé à une règle dont le résultat est TRUE ou FALSE. La première règle dont le résultat est TRUE détermine le flux sortant qui est suivi dans le processus professionnel. La séquence du processus professionnel suit le flux à partir de la première règle dont le résultat est TRUE. Si aucune règle ne donne la valeur TRUE, le flux ELSE est suivi.

La forme Décision doit contenir au moins une règle. Chaque règle doit contenir une expression de script.
Tant que

La forme Tant que contient une règle et représente un processus qui peut être répété. Si la règle possède la valeur TRUE, le flux issu de la règle est suivi jusqu'à la fin, puis se répète. Si la règle possède la valeur FALSE, le flux Continuer est suivi. Si la séquence de processus professionnels est issue d'une règle dans une forme Tant que, la séquence doit se terminer dans une forme Fin unique.

Vous pouvez également configurer la conservation de l'état d'une boucle Tant que. Cliquez à l'aide du bouton droit sur une forme Tant que, puis cliquez sur Propriétés pour afficher la boîte de dialogue Propriétés Tant que. Dans la zone Persistance de l'état, choisissez Oui pour enregistrer les messages utilisés dans chaque itération de boucle en tant qu'état de planification XLANG. Si la boucle Tant que fait partie d'une transaction en échec, une page En cas d'échec de Transaction ou Compensation pour Transaction est appelée pour chaque itération de boucle terminée. Si vous choisissez Non, seuls les messages utilisés dans la dernière itération de boucle sont enregistrés en tant qu'état de planification XLANG. Si la boucle Tant que fait partie d'une transaction qui échoue, une page En cas d'échec de Transaction ou Compensation pour Transaction est appelée une seule fois.

Si une séquence de processus professionnels se dirige vers une forme Tant que contenue dans une transaction imbriquée en échec, les messages et ports qui ont été créés sur la page En cas d'échec de Transaction ou Compensation pour Transaction pour la transaction imbriquée ne sont pas disponibles sur la page En cas d'échec de Transaction pour la transaction externe. Concevez donc le code En cas d'échec ou Compensation de manière à forcer les messages collectés à s'écouler normalement de la transaction imbriquée.
Embranchement

La forme Branche introduit la simultanéité dans un processus professionnel. Un flux peut entrer dans une branche, et un maximum de 64 flux peut en sortir. Tous les flux quittant une branche sont exécutés simultanément. Toutes les séquences de processus professionnels issues d'une même forme Branche doivent être connectées à une même forme Jointure ou se terminer dans une forme Fin.
Jointure

La forme Jointure synchronise les flux simultanés dans un processus professionnel. Un maximum de 64 flux peut entrer dans une forme Jointure, mais seulement un flux peut en sortir. Les opérateurs logiques AND et OR sont utilisés pour déterminer le mode de synchronisation des flux. Vous pouvez définir les propriétés de Jointure suivantes :
  • OR. Permet au premier flux qui arrive de continuer. L'exécution des autres flux se poursuit.

  • AND. Synchronise tous les flux entrants avant que le flux sortant puisse continuer.
Transaction

La forme Transaction représente un ensemble d'actions dont la totalité ou aucune n'est exécutée. Il existe trois types de transactions :
  • Transactions de courte durée

  • Transactions de longue durée

  • Transactions de longue durée dont le délai a été dépassé

Les transactions sont utilisées pour rendre une application plus fiable et simplifier la gestion d'erreur dans de grandes applications.

La forme Transaction est limitée à un seul chemin d'accès d'entrée, et à un seul chemin d'accès de sortie. La forme Transaction ne peut pas contenir de formes Fin. Les transactions de longue durée peuvent contenir des transactions imbriquées, contrairement aux transactions de courte durée. Les tentatives de reprises de transactions ne sont autorisées que pour les transactions de courte durée. Si vous incluez une partie de votre processus professionnel dans une forme Transaction de courte durée, vous pouvez configurer la propriété Nombre de tentatives de la transaction. En cas d'échec de la transaction de courte durée, le nombre de tentatives spécifié est exécuté.

En définissant les propriétés des transactions, vous pouvez rendre disponible soit la page Compensation pour Transaction (pour les transactions imbriquées) soit la page En cas d'échec de Transaction. Chacune de ces pages vous permet de modéliser les processus de gestion d'erreur spécifiques à la transaction.

Remarque

  • Si les bordures d'une forme Transaction interne chevauchent une des bordures de la forme Transaction externe, la transaction interne ne sera pas imbriquée. Par conséquent, ne laissez pas les bordures d'une transaction interne chevaucher les bordures d'une transaction externe.
Fin

La forme Fin représente la fin d'un flux de processus. Un schéma peut utiliser plusieurs formes Fin s'il contient des formes Décision, Tant que ou Branche.
Abandon

La forme Abandon termine l'exécution d'un groupe de transactions. Elle fait apparaître une page de gestion d'erreur En cas d'échec de Transaction ou Compensation pour Transaction, ou fait recommencer la transaction.

Remarques

  • Dans le cas des pages Compensation pour Transaction et En cas d'échec de Transaction, le paramètre Transaction est remplacé par le nom attribué à la transaction associée sur la page Processus professionnel.

  • Les noms de formes doivent répondre à certaines conventions d'affectation de noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C, à l'adresse www.w3.org.

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Les noms de transactions dans des jeux de caractères codés sur un seul octet ne peuvent pas dépasser une longueur de 16 caractères. Les noms de transactions dans des jeux de caractères codés sur deux octets ne peuvent pas dépasser une longueur de 8 caractères.

  • Aucune convention d'affectation de noms ne s'applique aux actions, hormis la taille limite de 32 caractères.

  • Les formes suivantes ne peuvent pas être nommées : Abandon, Début, Décision, Fin, Branche, Jointure et Tant que.

  • Ne testez pas l'existence des messages après une boucle Tant que. Le test du champ système, MessageName.[__Exists__], après une boucle Tant que prend toujours la valeur TRUE lorsque la trajectoire suivie dans la boucle Tant que ne crée pas de message du fait de la branche de décision choisie ou de l'abandon d'une transaction. Pour vérifier le contrôle du flux, utilisez une branche donnée pour noter la trajectoire suivie dans la boucle Tant que et utilisez ces informations dans le composant en dehors de la boucle.

Voir aussi

Formes Communication

Conception de transactions

Formes Implémentation


Formes Implémentation

Le Concepteur d'Orchestration BizTalk fournit quatre formes Implémentation, disponibles sur le stencil Implémentation. Ces formes servent à la description des technologies d'implémentation utilisées pour implémenter un port dans un processus professionnel.

Les formes Implémentation sont présentées au tableau suivant.

Nom de la forme | Description
Composant COM | La forme Composant COM représente une technologie pouvant servir à implémenter un port à l'aide d'un appel de méthode pour chaque message envoyé ou reçu. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison de composants COM. Pour plus d'informations sur l'implémentation des composants COM, voir Utilisation de la forme Composant COM.
Composant de script Composant de script | La forme Composant de script représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison des composants de script. Pour plus d'informations sur l'implémentation des composants de script, voir Utilisation de la forme Composant de script.
Message Queuing | La forme Message Queuing représente une technologie pouvant être utilisée pour implémenter un port. Les services Message Queuing sont utilisés pour envoyer ou recevoir des messages. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison de Message Queuing. Pour plus d'informations sur l'implémentation de Message Queuing, voir Utilisation de la forme Message Queuing.
Échanges BizTalk | La forme Échanges BizTalk représente une technologie pouvant être utilisée pour implémenter un port. Les services d'échanges BizTalk sont utilisés pour envoyer ou recevoir des messages. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison d'échanges BizTalk. Pour plus d'informations sur l'implémentation des Échanges BizTalk, voir Utilisation de la forme Échanges BizTalk.

Remarque

  • Les noms de formes doivent répondre à certaines conventions d'affectation de noms. Les conventions suivantes s'appliquent aux transactions, aux ports, aux messages, aux règles et aux champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C, à l'adresse www.w3.org.

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.

Voir aussi

Formes Communication

Formes Diagramme de flux


Formes Communication

Le Concepteur d'Orchestration BizTalk fournit plusieurs formes Communication qui indiquent la direction du flux des données en provenance ou à destination des messages. Le Concepteur d'Orchestration BizTalk fournit automatiquement les formes Communication.

Les formes Références du port, Constantes et Message se situent sur la page Données. La page Données représente le flux de données entre les messages utilisés par l'instance de planification XLANG pendant l'exécution de l'instance. Pour concevoir le flux de données, vous pouvez créer des connexions entre les champs contenus dans les formes de la page Données.

Les formes Communication sont présentées au tableau suivant.

Nom de la forme | Description
Port | Les ports sont des emplacements nommés où les messages sont envoyés ou reçus. Cliquez à l'aide du bouton droit sur la barre de séparation, puis cliquez sur Ajouter un nouveau port pour ajouter un port non lié. Ou déplacez une forme Implémentation vers la droite de la barre de séparation pour ajouter un port lié. Chaque port contient des messages qui correspondent aux formes Message apparaissant sur la page Données. Un message représente les données envoyées ou reçues par une action. Les données d'un message sont contenues dans une liste de champs sur la page Données.
Références du port | Le message Port References contient la liste de tous les ports créés sur la page Processus professionnel. Une nouvelle référence est ajoutée à la liste chaque fois qu'un nouveau port est ajouté sur la page Processus professionnel. Le message Références des ports vous permet de spécifier l'origine des emplacements des ports. Le message Port References contient un champ pour chaque port du processus professionnel.
Constantes | Le message de constantes vous permet d'initialiser votre planification XLANG avec des données. Pour ajouter une constante au message de Constantes, double-cliquez sur ce message ou double-cliquez sur l'un de ses champs pour ouvrir la boîte de dialogue Propriétés des messages de constantes.
Message | Les formes Message contiennent la liste des champs avec des informations sur les données envoyées ou reçues dans le message.

Remarque

  • Les noms de formes doivent répondre à certaines conventions d'affectation de noms. Les conventions suivantes s'appliquent aux transactions, aux ports, aux messages, aux règles et aux champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C, à l'adresse www.w3.org.

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.

    • Les noms de message ne peuvent pas correspondre aux noms des champs système. Les champs système figurent dans le tableau suivant.

Chaque message défini sur la page Données possède des champs système supplémentaires que le moteur de XLANG Scheduler crée et conserve automatiquement pour chaque message. Ces champs peuvent être référencés afin de fournir des informations descriptives sur le message, et utilisés dans des expressions de script pour des règles. Les champs système créés automatiquement sont présentés au tableau suivant.

Champs système Description
__Exists__ Ce champ peut être utilisé pour vérifier l'existence d'un message. L'existence d'un message est déterminée par le fait que le message a été reçu ou envoyé par le moteur de XLANG Scheduler.

Ce champ ne figure pas parmi les messages affichés sur la page Données. Il est utilisé uniquement avec les formes Décision et Tant que.
__Sender__ Ce champ contient l'identité, si elle est connue, de l'émetteur d'un message.

Ce champ figure parmi les messages affichés sur la page Données.
__Status__ Ce champ contient l'état renvoyé depuis un appel de méthode COM sur un port lié à un composant COM. Ce champ figure parmi les messages affichés sur la page Données.

Remarques

  • Ce champ système est utilisé uniquement avec des implémentations de composants COM et de script.

  • L'état renvoyé est toujours un HRESULT.
Document Ce champ contient une chaîne incluant le corps du message envoyé ou reçu. Il se réfère toujours à un message XML.

Remarque

  • Ce champ système est utilisé uniquement avec des implémentations de type Message Queuing et Échanges BizTalk.

Important

  • La source de chaque champ de données doit être définie dans chaque message envoyé depuis une instance de planification XLANG. Pour définir la source d'un champ de données, une connexion doit pointer sur ce champ, soit depuis un autre champ d'un autre message, soit depuis une constante.

Remarque

  • Le moteur de compilation utilisé pour créer une planification XLANG vérifie si tous les champs d'entrée seule d'un message sont définis. La planification n'est pas compilée si les champs d'entrée seule ne sont que partiellement définis. Les arguments transmis à une méthode peuvent l'être en entrée, en sortie ou les deux. Le moteur de compilation ignore l'exigence de définition des arguments définis à la fois en entrée et en sortie. Si aucune connexion entrante n'est définie pour les champs d'entrée-sortie, la planification est compilée, même s'il n'existe aucune définition pour les données du message.

Voir aussi

Gestion des données

Formes Diagramme de flux

Formes Implémentation


Touches de raccourci du Concepteur d'Orchestration BizTalk

Vous pouvez utiliser les touches de raccourci pour effectuer des tâches dans le Concepteur d'Orchestration BizTalk. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Server et Advanced Server, reportez-vous à « Utiliser le clavier pour déplacer le pointeur de la souris ». Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Professionnel, reportez-vous à « Déplacer le pointeur de la souris en utilisant les Touches souris ».
Touches | Opération
ALT ou F10 | Activer la barre de menus.
ALT+F4 | Fermer l'élément actif ou quitter le programme.
ALT+F7 | Mettre les fenêtres en cascade.
ALT+ESPACE | Afficher le menu système pour l'élément actif.
ALT+lettre soulignée d'un nom de menu | Afficher le menu correspondant.
Touches de direction | Déplacer la forme sélectionnée dans le sens de la flèche.
CTRL tout en faisant glisser un élément | Copier l'élément sélectionné.
CTRL+A | Sélectionner tout.
CTRL+C | Copier l'élément sélectionné sur la page de conception.
CTRL+F4 | Fermer le schéma actif.
CTRL+I | Rétablir la taille réelle de la fenêtre.
CTRL+N | Créer un nouveau schéma.
CTRL+O | Ouvrir un schéma existant.
CTRL+P | Ouvrir la boîte de dialogue Imprimer.
CTRL+Q | Quitter le programme.
CTRL+MAJ avec une des touches de direction | Faire défiler l'affichage.
CTRL+MAJ, puis cliquez sur le bouton gauche de la souris | Effectuer un zoom avant.
CTRL+MAJ, puis cliquez sur le bouton droit de la souris | Effectuer un zoom arrière.
CTRL+MAJ+TAB | Activer et désactiver les onglets d'une feuille de propriétés de l'arrière vers l'avant.
CTRL+TAB | Activer et désactiver les onglets d'une feuille de propriétés de l'avant vers l'arrière.
CTRL+V | Coller l'élément sélectionné sur la page de conception.
CTRL+X | Couper l'élément sélectionné sur la page de conception.
CTRL+Y | Recommencer.
CTRL+Z | Annuler.
SUPPR | Supprimer l'élément sélectionné sur la page de conception.
ÉCHAP | Annuler la tâche en cours.
F1 | Consulter l'aide en ligne.
F11 | Afficher la boîte de dialogue de propriétés de texte.
F8 | Aligner les formes sélectionnées.
FLÈCHE GAUCHE | Déplacer le focus vers la gauche lorsque celui-ci se trouve sur un onglet d'une boîte de dialogue.
FLÈCHE DROITE | Déplacer le focus vers la droite lorsque celui-ci se trouve sur un onglet d'une boîte de dialogue.
MAJ tout en faisant glisser un élément | Faire glisser l'élément uniquement dans une direction horizontale ou verticale.
MAJ+TAB | Déplacer le focus dans le sens contraire des aiguilles d'une montre en partant de l'onglet vers les fenêtres ou les champs situés en dessous.
BARRE ESPACE | Activer et désactiver les cases à cocher.
TAB | Déplacer le focus dans le sens des aiguilles d'une montre en partant de l'onglet vers les fenêtres ou les champs situés en dessous.
Lettre soulignée dans un nom de commande d'un menu ouvert | Exécuter la commande correspondante.


Planifications XLANG

La version compilée d'un schéma de planification XLANG est une planification XLANG, exécutée par le moteur de XLANG Scheduler. Le moteur de XLANG Scheduler surveille et contrôle le processus professionnel décrit dans la planification XLANG, sur la base des actions, règles et processus de gestion d'erreur définis pour la planification XLANG.

Cette section traite des rubriques suivantes :

  • Vue d'ensemble de XLANG

  • Gestion des instances

  • Persistance

  • Mise en attente et réalimentation

  • Gestion des données


Vue d'ensemble de XLANG

XLANG est un langage basé sur XML (Extensible Markup Language) qui décrit les interactions entre les processus professionnels. Le Concepteur d'Orchestration BizTalk peut compiler des schémas de planification XLANG en fichiers de planification XLANG structurés en XML. Étant donné que XLANG est un langage basé sur XML, les planifications XLANG doivent se conformer aux règles XML en matière de documents bien formés ainsi qu'à une spécification ou à un schéma standard.


Gestion des instances

Pour comprendre comment le moteur de XLANG Scheduler effectue la gestion des instances, il faut faire la distinction entre une définition abstraite d'un processus professionnel et plusieurs instances d'exécution d'une définition de processus professionnel. Le Concepteur d'Orchestration BizTalk permet de concevoir une définition de processus professionnel et de l'enregistrer sous la forme d'un schéma de planification XLANG (fichier .skv). Après avoir créé un schéma de planification XLANG, vous pouvez le compiler en une planification XLANG (fichier .skx). Une fois la planification XLANG déployée, il se peut que plusieurs instances de la planification fonctionnent en même temps. Chaque instance de planification XLANG peut avoir une durée de vie indépendante de celle de toutes les autres instances. Lorsque vous concevez une application destinée à prendre en charge plusieurs instances de planification XLANG, vous devez veiller aux points suivants :

  • Activation de nouvelles instances de planification XLANG lors de la réception de messages. Vous pouvez concevoir votre application de manière à activer une nouvelle instance de planification XLANG en utilisant la fonction COM GetObject chaque fois qu'un message est reçu. Par exemple, si vous utilisez une page ASP (Active Server Page) pour recevoir un message contenant une commande d'achat ou une requête de prise en charge client, l'ASP doit utiliser la fonction COM GetObject pour activer une planification XLANG.

    Vous pouvez utiliser l'Assistant Liaison d'Échanges BizTalk pour créer une liaison de port pouvant servir d'emplacement nommé vers lequel les messages sont envoyés. BizTalk Server 2002 fournit un mécanisme automatique permettant d'activer une instance de planification XLANG lorsqu'un port lié au Gestionnaire d'Échanges BizTalk reçoit un message. Sur la page Informations sur l'activation de la planification XLANG de l'Assistant Liaison d'Échanges BizTalk, un message s'affiche pour vous demander de confirmer si le canal a été configuré dans les services d'échanges BizTalk pour envoyer un message vers ce port après l'activation d'une nouvelle instance de cette planification XLANG. Pour terminer ce processus, vous devez exécuter l'Assistant Nouveau port d'échanges du Gestionnaire d'échanges BizTalk. Sur la page Application de destination de l'Assistant Nouveau port d'échanges, spécifiez le nom du port ainsi que le nom et l'emplacement de la planification XLANG.

  • Corrélation de messages avec des instances de planification XLANG. Le moteur de XLANG Scheduler affecte un identificateur global unique (GUID) à chaque instance d'une planification XLANG. Cet ID d'instance peut être utilisé pour corréler des messages avec des instances de planification. La corrélation peut être effectuée de différentes manières, comme suit :

    Utilisation d'une seule file d'attente. Vous pouvez utiliser une seule file d'attente pour toutes les instances afin d'éviter la surcharge d'un grand nombre de files d'attente par instance. Pour ce faire, utilisez l'identificateur global unique (GUID), ou ID d'instance, de l'instance de planification. Vous devez enregistrer l'ID d'instance de la planification lorsque vous envoyez un message, l'extraire lors de la réception d'un message et l'utiliser pour créer un système de corrélation du message entrant avec l'instance de planification correcte. Il existe deux manières de procéder :

    • Identification d'un champ de message susceptible d'être utilisé pour la corrélation. Ce champ doit être unique. Il peut s'agir d'un champ créé spécialement dans ce but ou d'un champ qui existe déjà dans un format de document.

      Pour l'envoi, vous pouvez enregistrer l'ID d'instance et la valeur du champ de corrélation. Le composant de pipeline peut extraire Src_XLANG_InstanceID du dictionnaire et l'enregistrer, ainsi que la valeur du champ de corrélation, dans une base de données locale.

      Pour la réception, vous pouvez écrire un composant personnalisé qui devra extraire le champ de corrélation du message entrant, trouver l'ID d'instance correspondant dans la base de données et utiliser la valeur pour définir Dest_XLANG_InstanceID dans le dictionnaire en vue de la remise ultérieure du message à l'instance appropriée.

    • Utilisation de l'ID d'instance en tant qu'étiquette du message. Pour utiliser cette méthode, lorsque vous liez des actions et des ports, activez la case à cocher Utiliser l'ID d'instance comme étiquette de message dans la boîte de dialogue Informations sur les types de message de l'Assistant Communication XML. Pour plus d'informations, voir Utilisation de l'Assistant Communication XML.

    Utilisation d'une file d'attente par instance. Chaque port de chaque instance d'une planification XLANG en cours d'exécution ne peut se voir affecter qu'une seule adresse. Cette capacité d'adressage vous permet de bénéficier d'une communication directe avec des ports donnés sur des instances de planification données, sans qu'il ne soit nécessaire d'écrire du code personnalisé pour effectuer la corrélation. Le premier message envoyé par une instance de planification est probablement dirigé vers un port statique (un emplacement nommé). Lors de l'activation de la planification XLANG, cette instance envoie l'emplacement de ses ports dynamiques (emplacements uniques, par instance) aux destinataires, qui sont responsables de la communication en retour vers les ports. Cela correspond à des messages de courrier électronique envoyés avec des adresses de réponse uniques. La prise en charge de la liaison dynamique dans chacune des technologies de liaison de BizTalk Server est présentée ci-après :

    • Si vous choisissez l'option Statique sur la page Communication statique ou dynamique de l'Assistant Liaison de composants COM ou de l'Assistant Liaison de composants de script, le moteur de XLANG Scheduler crée l'instance de planification XLANG du composant. Si vous choisissez l'option Dynamique, une autre application doit envoyer un pointeur d'interface ou un moniker (sous la forme d'un champ dans un message) avant l'instanciation du composant.

    • Vous pouvez également choisir l'option Aucune instanciation. Pour plus d'informations sur l'instanciation des composants, voir Ports statiques et dynamiques.

    • Si vous choisissez l'option File d'attente statique, puis cliquez sur Suivant sur la page Informations sur la file d'attente statique ou dynamique de l'Assistant Liaison de Message Queuing, la page Informations sur la file d'attente s'affiche. Cette page vous permet de spécifier qu'une file d'attente par instance est créée pour chaque instance de planification XLANG, ou qu'une seule file d'attente est utilisée pour toutes les instances en cours d'exécution.

    • Si vous choisissez l'option File d'attente dynamique sur la page Informations sur la file d'attente statique ou dynamique de l'Assistant Liaison de Message Queuing, une autre application doit envoyer le nom de la file d'attente (sous la forme d'un champ dans un message) avant d'envoyer ou de recevoir des messages via le port.

    • Sur la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, vous pouvez choisir de fournir un nom de canal spécifique ou indiquer que les informations de configuration de port seront utilisées par les services d'échanges BizTalk pour identifier le canal correct au moment de l'exécution. Pour plus d'informations sur l'échange de messages, voir Intégration des services BizTalk.
  • Mise à l'échelle de l'application. Toutes les instances de planification XLANG qui ne doivent pas être en mémoire doivent être mises en attente. Il se peut qu'une instance de planification XLANG ne doive pas être en mémoire lorsqu'une instance de planification XLANG attend l'arrivée d'un message.

Remarques

  • Toutes les formes Implémentation affichent une ombre pour indiquer que l'emplacement sera lié dynamiquement et défini au moment de l'exécution.

  • Une instance enfant dérivée d'une instance parent est dotée d'un ID d'instance unique, différent de celui de son parent. De même, une instance enfant dans une boucle Tant que (sur chaque segment de la boucle) est dotée de son propre ID d'instance.

Voir aussi

Gestion des données

Mise en attente et réalimentation

Gestion de l'état de session

Persistance

XLANG Schedule Correlation


Persistance

Le moteur de XLANG Scheduler stocke les informations suivantes dans la base de données de persistance :

  • la structure des planifications XLANG ;

  • l'état d'avancement des instances de planification XLANG activées ;

  • les messages envoyés ou reçus pendant l'exécution d'une instance de planification XLANG.

Le moteur de XLANG Scheduler conserve les informations destinées à autoriser les scénarios suivants :

  • Permettre la mise en attente et la réalimentation des planifications longues Il se peut que le système échoue pendant une transaction de longue durée. Lorsque le système fonctionne de nouveau, le moteur de XLANG Scheduler doit se référer à la base de données de persistance pour déterminer où reprendre la planification.

  • Restaurer l'état d'une instance de planification lors de l'échec d'une transaction Il se peut que le système échoue pendant une transaction, provoquant l'abandon de celle-ci. Le moteur de XLANG Scheduler doit se référer à la base de données de persistance pour déterminer où reprendre la planification.

  • Prendre en charge le débogage et la surveillance des planifications en cours d'exécution Les outils de débogage et de surveillance peuvent demander à la base de données de persistance de leur fournir des informations sur l'état d'avancement des instances de planification.

La prise en charge de la persistance de l'état d'une planification XLANG, avant le début et après la fin d'une transaction, assure la durabilité et garantit que toutes les modifications validées resteront en permanence dans le système. Cela permet également de relancer une transaction en cas de défaillance. La persistance de l'état d'une instance de planification en cours d'exécution est assurée dans les circonstances suivantes :

  • Au début d'une transaction Lorsque la séquence des processus professionnels entame une transaction, le nombre de tentatives de la transaction doit être mis à jour dans la base de données de persistance. Cela permet au moteur de XLANG Scheduler de connaître ce nombre de tentatives en cas d'échec du système pendant la transaction.

  • À la fin d'une transaction Lorsque la séquence des processus professionnels termine une transaction, l'état de la planification doit être mis à jour afin de permettre la restauration si nécessaire. Cette mise à jour s'effectue dans le contexte de la transaction afin de garantir l'atomicité de la base de données de persistance.

Voir aussi

Mise en attente et réalimentation

Gestion des instances

Gestion de l'état de session


Mise en attente et réalimentation

Si plusieurs instances d'une planification XLANG fonctionnent simultanément pendant une longue période, il peut devenir impossible de les maintenir toutes en mémoire. Pour résoudre ce problème, le moteur de XLANG Scheduler offre une infrastructure de mise en attente/réalimentation.

Lorsque le moteur de XLANG Scheduler prévoit qu'une instance de planification XLANG va attendre un message pendant une longue période, et qu'aucune autre activité n'a lieu dans la planification, il peut décider de mettre en attente l'instance de planification XLANG. La mise en attente d'une instance de planification XLANG consiste à sauvegarder la totalité de l'état spécifique de l'instance dans la base de données de persistance et à supprimer l'instance de la mémoire. Lorsqu'un message arrive à une adresse de port correspondant à l'instance de planification XLANG mise en attente, l'instance est réalimentée. La réalimentation d'une instance de planification XLANG consiste à restaurer l'instance dans la mémoire, à partir de la base de données.

Une instance de planification XLANG reste en attente jusqu'à ce qu'elle soit réactivée ou qu'un administrateur l'interrompe explicitement. Ce système permet à un processus professionnel de fonctionner de manière fiable pendant une longue période.

Le moteur de XLANG Scheduler peut utiliser un paramètre de latence pour déterminer un délai pendant lequel une action peut rester inactive avant que l'instance de planification XLANG soit mise en attente dans la base de données de persistance. Le moteur de XLANG Scheduler utilise ce paramètre de latence pour mettre en attente l'instance de planification XLANG dans la base de données de persistance, puis la réalimente ultérieurement lors de l'arrivée du message. Toutefois, dans certaines situations présentées ci-après, le paramètre de latence ne provoque pas la réalimentation d'une planification.

  • L'instance de planification ne se trouve pas dans un état de repos. Cette situation peut se produire lorsque des actions sont en cours d'exécution sur un des flux de processus courants dans l'instance de planification XLANG. Tous les flux de processus dans l'instance de planification doivent être dans le même état avant que le moteur de XLANG Scheduler ne mette en attente l'instance de planification XLANG. Le temps de latence pour toutes les actions en attente doit être supérieur à un seuil donné, avant l'exécution de la mise en attente.

  • Il y a des transactions de style DTC en attente. Le moteur de XLANG Scheduler ne mettra pas la planification en attente si celle-ci exécute une transaction de style DTC, car les transactions de ce type sont généralement des transactions de courte durée.

  • L'instance contient des ports actifs qui ne peuvent pas être sauvegardés dans la base de données de persistance. Un port actif est un objet de port ou un port qui a été implémenté et qui peut être utilisé ultérieurement dans l'instance de planification. La durée de vie d'un port est un paramètre important lors de l'exécution d'une instance de planification. Les ports sont liés à des technologies d'implémentation, telles que des interfaces COM. Si la technologie d'implémentation à laquelle un port est lié ne peut pas être sauvegardée dans la base de données de persistance, et si la technologie d'implémentation contient des informations d'état réutilisées ultérieurement, l'instance ne peut pas être mise en attente, puis réalimentée. En cas d'échec puis de fonctionnement ultérieur de la base de données de persistance, les informations d'état seront perdues et l'exécution de l'instance de planification ne pourra pas reprendre à partir de l'état de celle-ci lors de sa dernière mise en attente.

Lors de l'arrêt du moteur de XLANG Scheduler, un maximum d'informations sont enregistrées dans la base de données de persistance, notamment toutes les informations ne figurant pas dans un contexte transactionnel.

Voir aussi

Gestion des instances

Gestion de l'état de session

Persistance

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Gestion des données

Dans XLANG, toutes les données sont contenues dans un ensemble de messages nommés de manière univoque. De nouvelles données entrent dans une instance de planification XLANG lorsqu'un message est reçu par une action.

Chaque schéma de planification XLANG possède une page Données. La page Données vous permet de décrire le flux de données dans une planification XLANG. Pour indiquer que les données d'un champ de message se dirigent vers un autre champ de message, tracez une flèche depuis le champ de message source jusqu'au champ de message de destination.

À l'exception du message de constantes, aucun des champs des messages de la page de données ne contient de valeur initiale. Le message de constantes est initialisé avec les valeurs indiquées sur la page de données. Il est automatiquement initialisé pour chaque nouvelle instance de planification XLANG. Pour plus d'informations sur l'utilisation des constantes, voir Message de constantes.

Les valeurs des autres messages affichés sont définies lorsque chaque message est envoyé ou reçu dans l'instance de planification XLANG. Un message peut être reçu par plusieurs actions. Chaque fois qu'un message est reçu, les valeurs de ce message sont remplacées. Le flux des données dans le message reçu n'est pas utilisé pour définir les valeurs d'un autre message reçu, même si le message est envoyé en un autre endroit de la planification XLANG. Les messages envoyés de manière exclusive reposent sur le flux de données affiché sur la page Données pour définir leurs champs de messages. La compilation d'une planification n'a pas lieu tant que tous les champs de tous les messages envoyés n'ont pas été définis.

Lorsqu'un champ de la page Données issu d'un champ XPath se réfère à un nœud facultatif du schéma XML, observez les points suivants :

  • Pour les messages reçus lorsque le nœud facultatif existe Si ce message est reçu et que le nœud facultatif existe dans le document XML, le champ XPath stocke la valeur du nœud.

  • Pour les messages reçus lorsque le nœud facultatif n'existe pas Si ce message est reçu et que le nœud facultatif n'existe pas, le champ XPath stocke une valeur NULL. Vous devrez utiliser une règle Décision avec l'expression Microsoft® Visual Basic® (VBScript) IsNull (Message.Champ) sur ce champ pour déterminer si le message reçu contient le nœud facultatif. Si vous ne contrôlez pas l'existence d'une valeur et que ce champ fournit un flux de données vers un autre message envoyé, une erreur se produit lorsque le moteur de XLANG Scheduler essaie de créer le message à envoyer.

  • Pour les messages envoyés lorsque le nœud facultatif existe Si ce message (avec le nœud XPath dirigé vers un nœud XML facultatif) est envoyé, le moteur de XLANG Scheduler se base sur le flux de données pour créer le message. Si le nœud existe dans le champ Document du message, le moteur de XLANG Scheduler le remplace par la valeur du nœud XPath.

  • Pour les messages envoyés lorsque le nœud facultatif n'existe pas Si ce message (avec le nœud XPath dirigé vers un nœud XML facultatif) est envoyé, le moteur de XLANG Scheduler se base sur le flux de données pour créer le message. Si le nœud n'existe pas dans le champ Document fourni, le moteur de XLANG Scheduler ne crée pas le nœud à remplacer. Une erreur survient.

Pour les messages à recevoir de ou à envoyer vers une file d'attente de messages, observez les points suivants :

  • Pour les messages reçus Si une action reçoit un message non-XML depuis une file d'attente de messages, vous devez sélectionner Recevoir les messages de chaîne de la file d'attente sur la page Informations sur l'interprétation XML de l'Assistant Communication XML. Dans cette configuration, la forme Message de la page Données affiche un nouveau champ StringData. Le champ StringData contient le message non-XML reçu de la file d'attente. Le champ Document du message contient le champ StringData, entouré par le wrapper XML standard du moteur de XLANG Scheduler.

  • Pour les messages envoyés Si une action envoie un message non-XML à une file d'attente de messages, vous devez sélectionner Envoyer des messages à la file d'attente sous forme de chaîne sur la page Informations sur l'interprétation XML de l'Assistant Communication XML. Dans cette configuration, la forme Message de la page Données affiche un nouveau champ StringData. Pour terminer cette configuration, vous devez créer une nouvelle constante (contenant le wrapper XML standard du moteur de XLANG Scheduler) dans le message de Constantes sur la page Données. Le nom de cette constante est sans importance, mais le type de données doit être string, et la valeur de la constante doit être <?xml version="1.0" ?> <StringData> </StringData>. Après avoir créé cette nouvelle constante, vous devez tracer une connexion de flux de données depuis la nouvelle constante du message de Constantes vers le champ Document de la forme Message. Vous devez également tracer une connexion de flux de données depuis le champ contenant la chaîne non-XML vers le nouveau champ StringData de la forme Message.

Remarques

  • La direction du flux de données est indépendante de celle du flux des messages. Le flux des messages indique si un message est envoyé ou reçu.

  • Pour permettre à la planification XLANG de recevoir des données à l'aide d'un appel de méthode sans instanciation du composant, sélectionnez Aucune instanciation sur la page Communication statique ou dynamique de l'Assistant Liaison de composants COM ou de l'Assistant Liaison de composants de script. Si vous sélectionnez Aucune instanciation, le composant n'est pas instancié et aucun code n'est exécuté pour l'appel de méthode. Au lieu de cela, lorsque la planification XLANG intercepte les informations de requête de méthode, elle renvoie ces informations en tant que réponse. L'appel de méthode est évité.

  • Si un message est utilisé uniquement dans le corps d'une boucle Tant que, les valeurs du message ne sont pas initialisées à chaque itération de la boucle. Si un message est utilisé à la fois à l'intérieur et à l'extérieur du corps d'une boucle Tant que, les valeurs du message sont conservées lors de chaque itération de la boucle. Il se peut également que les valeurs du message soient conservées avant et après que la séquence des processus professionnels atteindra la forme Tant que.

  • Si un message est initialisé dans le processus de compensation ou le processus en cas d'échec d'une transaction dans une boucle Tant que, les valeurs du message ne sont pas disponibles à l'extérieur de la boucle.

  • Si un champ d'un message XML (notamment le message de constantes) avec un type de données char fournit un flux de données vers un champ de message de méthode, le champ est converti en un type integer pour la méthode. Si le champ de message de méthode possède un type de données string, la chaîne contient la valeur entière ; elle ne contient pas le caractère. Si vous rencontrez ce problème, et que le champ source fait partie du message de constantes, modifiez le type de données du champ des constantes en string. Si le champ source fait partie d'un message XML, vous devrez utiliser un composant pour modifier le type de données char en type string.

Cette section traite des rubriques suivantes :

  • Page Données

  • Messages de constantes

  • Message Références des ports

  • Types de données de champs

  • Champs système

  • Champs du chemin d'accès au nœud


Page Données

Chaque schéma de planification XLANG possède une page de données. La page de données affiche :

  • Une forme Message pour chaque message dans la planification XLANG.

  • Un message de Constantes.

  • Un message Port References contenant un champ pour chaque port du schéma de planification XLANG.

  • Un diagramme des connexions illustrant le flux des données entre les champs de messages.

Les messages se composent d'un ensemble de champs à nom unique, chaque champ contenant une donnée d'un type spécifique. Chaque message de la planification XLANG est affiché dans la page de données sous la forme d'une table. Chaque table affiche le nom du message ainsi qu'une liste des noms de champs et leurs types de données correspondants. Les champs système qui ne requièrent pas de flux de données sont affichés avec un arrière-plan de couleur jaune. Les champs utilisateur et les champs système qui ne requièrent pas de flux de données sont affichés avec un arrière-plan de couleur blanche.

Les connexions affichées sur la page Données relient le côté droit d'un champ de message source au côté gauche d'un champ de message de destination. Cette connexion indique que le champ du message source fournit les données nécessaires au champ du message de destination. Au moment de l'exécution, le moteur de XLANG Scheduler copie les données depuis le champ du message source vers le champ du message de destination lorsque le message de destination doit être créé. Une erreur d'exécution se produit si le message source n'arrive pas à destination.

Remarques

  • Les types de données suivants ne sont pas pris en charge sur la page de données :
    • BinHex

    • BinBase64

    • I8

    • UI8

Si vous avez un nœud dans un document XML de type BOOL, BinHex, BinBase64, I8 ou UI8, et que vous spécifiez que ce nœud doit être inclus dans le champ d'application du moteur de XLANG Scheduler sur la page de données, en utilisant le XPath vers ce nœud, celui-ci sera converti en une chaîne.

  • Tous les noms de champs des planifications XLANG sont limités à 100 caractères.

Voir aussi

Message de constantes

Gestion des données

Types de données de champs

Champs du chemin d'accès au nœud

Message références des ports

Champs système


Message de constantes

Vous pouvez utiliser le message de Constantes pour initialiser une instance de planification XLANG avec des données. Le message de Constantes effectue une fonction unique au sein du moteur de XLANG Scheduler ; il n'est ni envoyé, ni reçu. Il est automatiquement initialisé pour chaque nouvelle instance de planification XLANG. Pour ajouter une constante au message de Constantes, double-cliquez sur ce message ou double-cliquez sur l'un de ses champs pour ouvrir la boîte de dialogue Propriétés des messages de constantes. Cliquez sur Ajouter dans la boîte de dialogue Propriétés des messages de constantes afin d'ouvrir la boîte de dialogue Propriétés des constantes. La boîte de dialogue Propriétés des constantes vous permet de nommer la constante, de choisir un type de données pour la constante, et d'affecter une valeur à la constante.

Question d'ordre international

  • XML ne manipule pas les paramètres locaux de Windows pour le formatage des dates. Si vous voulez affecter une date à une constante dans un format local, définissez le type de données de la constante à la valeur string. Si cette constante fournit des données à un champ avec un type de données date, le moteur de XLANG Scheduler convertit la chaîne en une date, conformément au format local.

Voir aussi

Gestion des données

Page de données

Types de données de champs

Champs du chemin d'accès au nœud

Message Références des ports

Champs système


Message Références des ports

Le message Références des ports contient la liste de tous les ports créés sur la page Processus professionnel. Une nouvelle référence est ajoutée à la liste chaque fois qu'un nouveau port est ajouté sur la page Processus professionnel. Le message Références des ports vous permet de spécifier l'origine des emplacements des ports. Le message Références des ports contient un champ pour chaque port du schéma de planification XLANG.

Dans certains scénarios, les ports d'une planification XLANG ne sont pas connus au moment de la conception. Cela peut se produire si la destination ou l'origine des messages est déterminée à partir du contenu des autres messages. Par exemple, il se peut qu'un processus professionnel décrive une situation dans laquelle une action doit répondre à un message avec un accusé de réception vers le partenaire commercial d'origine. Dans cet exemple, le message reçu contiendra généralement un champ adresse-de-réponse avec l'adresse d'origine du message. La planification XLANG doit être capable de corréler le contenu du champ adresse-de-réponse avec l'adresse de destination du message d'accusé de réception. Vous pouvez utiliser le message Références des ports et un message d'accusé de réception sur la page de données pour implémenter ce scénario. Pour plus d'informations sur l'échange de messages, Intégration des services BizTalk.

Voir aussi

Message de constantes

Gestion des données

Types de données de champs

Champs du chemin d'accès au nœud

Champs système


Types de données de champs

Le Concepteur d'Orchestration BizTalk affiche tous les types de données avec leur nom de type de données XML. Les équivalents Automation OLE, Visual Basic et C des noms des types de données XML affichés sont présentés au tableau suivant.

Vue UI XML | OLE Automation | Visual Basic | C
types simples |  |  |
boolean | VT_BOOL | Boolean | VARIANT_BOOL
string | VT_BSTR | String | BSTR
cy | VT_CY | Currency | CURRENCY
date | VT_DATE | Date | DATE
dispatch | VT_DISPATCH | Object | IDispatch
error | VT_ERROR |  | SCODE
i1 | VT_I1 |  | signed char
i2 | VT_I2 | Integer | SHORT
i4 | VT_I4 | Long | LONG
int | VT_INT |  | INT
r4 | VT_R4 | Single | FLOAT
r8 | VT_R8 | Double | DOUBLE
ui1 | VT_UI1 | Byte | BYTE
ui2 | VT_UI2 |  | USHORT
ui4 | VT_UI4 |  | ULONG
uint | VT_UINT |  | UINT
de type inconnu | VT_UNKNOWN | Object | IUnknown
variant | VT_VARIANT | Variant | VARIANT

Voir aussi

Message de constantes

Gestion des données

Page de données

Champs du chemin d'accès au nœud

Message Références des ports

Champs système


Champs système

Chaque message peut également contenir un ensemble de champs système qui sont automatiquement créés par le moteur de XLANG Scheduler.

Nom du champ système | Quand ce champ système est-il affiché ? | Description
__Status__ | Lors de la réception du message depuis un port lié à une liaison COM ou de script | HRESULT de l'appel de méthode
__Sender__ | Lors de l'envoi ou de la réception du message depuis n'importe quel port | Chaîne contenant le SenderID fourni par Message Queuing ou COM lorsqu'un message est reçu. Lorsque ce message est envoyé, la valeur est NULL.
Document | Lors de l'envoi ou de la réception du message depuis un port qui est lié à Message Queuing ou au Gestionnaire d'échanges BizTalk | Chaîne contenant le corps du message envoyé ou reçu

Voir aussi

Message de constantes

Gestion des données

Types de données de champs

Champs du chemin d'accès au nœud

Message Références des ports


Champs du chemin d'accès au nœud

Lorsqu'un port lié à Message Queuing ou au Gestionnaire d'échanges BizTalk reçoit un document XML, vous pouvez inclure des nœuds spécifiques du document dans le champ d'application des données du moteur de XLANG Scheduler. Si aucun nœud spécifique n'est sélectionné, le moteur de XLANG Scheduler traite le document XML comme une chaîne opaque dans le champ système du document.

Pour inclure des nœuds du document dans le champ d'application des données du moteur de XLANG Scheduler, vous pouvez utiliser la page Informations sur le message de l'Assistant Communication XML. Lorsque vous fournissez une spécification XML, les boutons Ajouter et Supprimer sont activés.

Voir aussi

Message de constantes

Gestion des données

Types de données de champs

Message Références des ports

Champs système

Utilisation de l'Assistant Communication XML


Création de schémas de planification XLANG

La conception d'une planification XLANG nécessite cinq tâches :

  • Dessiner une représentation du processus professionnel que la planification XLANG devra exécuter. Utiliser des formes Diagramme de flux pour décrire le flux du processus professionnel sur le côté gauche de la page de conception. Votre processus professionnel principal figure sur la page Processus professionnel. Les processus de remplacement figurent sur les pages Compensation pour Transaction et En cas d'échec de Transaction.

  • Définir des règles pour les décisions de branchement et les processus répétés au sein du processus professionnel ; définir des processus concurrents et concevoir les transactions et les transactions subordonnées requises dans le processus professionnel.

  • Créer les implémentations de ports requises par le processus professionnel. Quatre technologies d'implémentation sont disponibles : composants COM, composants de script Windows, services de Message Queuing et services d'échanges BizTalk.

  • Définir le flux de données entre les messages. Tous les flux de données entre les messages sont tracés sur la page de données.

  • Dessiner tous les processus professionnels nécessaires en cas d'échec de transactions. Les processus professionnels de remplacement figurent sur les pages Compensation pour Transaction et En cas d'échec de Transaction.

Remarque

  • Vous pouvez ajouter des formes Diagramme de flux et des formes Implémentation dans les pages Processus professionnel, Compensation pour Transaction et En cas d'échec de Transaction. Ces formes ne sont pas disponibles sur la page Données.

Cette section traite des rubriques suivantes :

  • Conception de processus professionnels

  • Gestion des exceptions

  • Implémentation de processus professionnels


Conception de processus professionnels

Dans le Concepteur d'Orchestration BizTalk, la partie gauche de la page Processus professionnel est la zone dans laquelle vous pouvez concevoir des processus professionnels. Une barre de séparation divise la page Processus professionnel en une zone de conception de processus professionnels du côté gauche et une zone d'implémentation du côté droit.

Cette section traite des rubriques suivantes :

  • Conception d'actions

  • Conception de règles

  • Conception concurrentielle

  • Conception de transactions


Conception d'actions

La séquence des processus professionnels doit s'écouler depuis la forme Début vers la première forme Diagramme de flux de votre schéma de planification XLANG. Généralement, la première forme Diagramme de flux de votre schéma de planification XLANG est une forme Action.

Une forme Début possède deux propriétés configurables. Dans la boîte de dialogue Propriétés de début, vous pouvez configurer la propriété Modèle de transaction pour déterminer si les formes Transaction sont prises en charge dans une instance de planification XLANG, ou si la planification XLANG est activée à partir d'un composant COM transactionnel. La première option active la prise en charge des formes Transaction ; la seconde désactive la prise en charge des formes Transaction.

La boîte de dialogue Propriétés de début vous permet également de configurer les propriétés Activation de la transaction et Identité XLANG. Pour plus d'informations sur l'activation des transactions, voir Conception de transactions.

La propriété Identité XLANG est une propriété en lecture seule. Elle contient un identificateur global unique (GUID) qui est utilisé pour corréler une version du schéma de planification XLANG avec la planification XLANG générée. Le GUID est généré automatiquement lorsqu'un nouveau schéma est créé, et un nouveau GUID est généré chaque fois que le schéma de planification XLANG est modifié.

La seule propriété configurable pour une forme Action est le nom de l'action. Le nom de l'action ne peut excéder 32 caractères. Les noms des actions n'ont aucun effet sur le comportement de la planification XLANG.

Voir aussi

Conception concurrentielle

Conception de règles

Conception de transactions

Formes Diagramme de flux


Conception de règles

Les règles sont des expressions Microsoft Visual Basic Scripting Edition (VBScript), utilisées par les formes Décision et Tant que. Les règles peuvent être :

  • des expressions VBScript intrinsèques, telles que Date et Time ;

  • des expressions qui évaluent des données dans un champ de message ;

  • des expressions qui peuvent déterminer si un message existe.

Une règle contient les propriétés suivantes qui définissent le comportement de la forme :

  • Nom de la règle. Il s'agit d'une propriété obligatoire, affichée sur le schéma de planification XLANG dans la forme qui utilise la règle. Le nom de la règle identifie la règle de manière univoque. Une règle unique et nommée de manière univoque peut être utilisée dans plusieurs formes Décision et Tant que. La largeur de la forme Décision ou Tant que qui utilise la règle est déterminée par la règle contenue dans la forme dont le nom est le plus long.

  • Description de la règle. Il s'agit d'une propriété facultative, décrivant la règle.

  • Expression de script. Il s'agit d'une expression VBScript obligatoire qui se réfère aux données contenues dans les messages. Cette expression possède soit la valeur TRUE soit la valeur FALSE.

Pour concevoir un schéma de planification XLANG, vous devez créer des règles et leur fournir un nom ainsi qu'une description. Pour ajouter des formes Implémentation au schéma, vous devez ajouter des expressions de script.

Remarques

  • La propriété Expression de script est obligatoire uniquement lors de la compilation du schéma de planification XLANG en une planification XLANG.

  • Le champ de message __Exists__ n'est pas affiché dans les messages sur la page Données. Ce champ peut être utilisé pour vérifier l'existence d'un message. L'existence d'un message est déterminée par le fait que le message a été reçu ou envoyé par le moteur de XLANG Scheduler.

Voir aussi

Création de règles

Conception d'actions

Conception concurrentielle

Conception de transactions

Formes Diagramme de flux

Définition des conditions de décision


Conception concurrentielle

Le Concepteur d'Orchestration BizTalk prend en charge les actions simultanées. Les formes Branche et Jointure sont utilisées pour implémenter des flux de processus simultanés au sein d'une planification XLANG. Vous pouvez utiliser la forme Branche pour créer des flux de processus simultanés, et la forme Jointure pour synchroniser tous les flux de processus simultanés qui ne se terminent pas par une forme Fin.

Propriétés des jointures

La forme Jointure possède deux propriétés que vous pouvez définir. Ces propriétés représentent les opérateurs logiques suivants :

  • AND. La planification XLANG attend que tous les flux de processus aient atteint la jointure avant de passer à l'action suivante du processus professionnel.

  • OR. La planification XLANG attend que le premier flux de processus ait atteint la jointure avant de passer à l'action suivante du processus professionnel.

    Les actions des autres ramifications de la branche vont terminer leurs processus ; toutefois, la jointure OR n'attend pas que ces processus soient terminés. Si le flux de processus qui sort d'une jointure OR comprend une action qui requiert un flux de données issu d'une branche entrant dans la jointure OR et dont l'action n'est pas encore terminée au moment où l'action qui sort de la jointure est exécutée, une erreur se produit.

Flux valides de processus de jointures et de branches

Observez les points suivants lors de la conception de flux simultanés dans un processus professionnel :

  • Tous les flux comprenant des branches doivent soit se terminer par une forme Fin ou être synchronisés en un flux unique à l'aide d'une forme Jointure.

  • Les actions contenues dans des flux comprenant des branches ne peuvent pas communiquer entre elles. Par exemple, une action d'une branche donnée ne peut pas envoyer de message vers une file d'attente si une action d'une autre branche attend de recevoir un message de cette même file d'attente.

    Attention

    • Si vous ne concevez pas correctement votre schéma de planification XLANG pour la prise en charge des communications entre les actions des différentes branches, il se peut que l'instance de planification XLANG échoue au moment de l'exécution ; cependant, aucun message d'erreur ne s'affiche.
  • Vous ne pouvez pas utiliser de jointure pour synchroniser des flux issus de plusieurs branches. La forme Jointure ne peut être utilisée que pour synchroniser des flux issus d'une branche correspondante. Il existe une correspondance de type un-à-un entre l'utilisation de la forme Branche et celle de la forme Jointure.

    L'illustration ci-dessous présente deux branches utilisées pour créer des flux simultanés, ainsi qu'une jointure unique utilisée dans une tentative de synchronisation de ces flux. Cette connexion n'est pas valide. Si vous tentez ce type de connexion, vous obtiendrez un message d'erreur lors de la compilation de la planification XLANG.

    Flux simultanés joints incorrectement

    Deux exemples de jointures valides sont présentés ci-après.

    Dans l'illustration suivante, deux branches correspondent à deux jointures. La deuxième paire branche/jointure est imbriquée dans la première paire branche/jointure.

    Flux simultanés joints correctement

    Dans l'illustration suivante, deux branches correspondent à deux jointures. La deuxième paire branche/jointure est imbriquée dans la première paire branche/jointure. Remarquez que même si un flux simultané dans la deuxième paire branche/jointure se termine par une forme Fin, l'autre flux simultané doit toujours être synchronisé par une jointure correspondante avant que son flux puisse être synchronisé avec le flux simultané issu de la première paire branche/jointure.

    Flux simultanés joints correctement

  • Lorsque vous synchronisez plusieurs flux simultanés avec une jointure OR, chaque flux de processus qui entre dans la jointure ne peut contenir qu'une seule action. Si un flux contient plusieurs actions, le flux n'est pas valide.

    L'illustration suivante présente une jointure OR synchronisant plusieurs flux simultanés. Chaque flux contient une seule action.

    Flux simultanés joints correctement

Important

  • Les actions des différentes ramifications d'une branche ne peuvent pas communiquer les unes avec les autres. Par exemple, une action d'une branche donnée ne peut pas envoyer de message vers une file d'attente si une action d'une autre branche attend de recevoir un message de cette même file d'attente. Si vous concevez de manière incorrecte votre schéma de planification XLANG pour la prise en charge de tout type de communication entre les actions des différentes ramifications, il se peut que l'instance de planification XLANG échoue au moment de l'exécution ; cependant, aucun message d'erreur ne s'affiche.

Voir aussi

Conception d'actions

Conception de règles

Conception de transactions

Formes Diagramme de flux

Définition des propriétés de simultanéité


Conception de transactions

Le Concepteur d'Orchestration BizTalk fournit un modèle de programmation transactionnel, incluant la gestion d'erreur et la récupération des transactions après un échec. Vous pouvez configurer des formes Transaction pour créer deux types de pages supplémentaires dans le Concepteur d'Orchestration BizTalk : la page En cas d'échec de Transaction et la page Compensation pour Transaction. Ces deux pages permettent aux processus professionnels de récupérer des transactions après un échec. Les pages En cas d'échec de Transaction et Compensation pour Transaction peuvent contenir des formes Transaction faisant référence à d'autres pages En cas d'échec de Transaction et Compensation pour Transaction. Les pages En cas d'échec de Transaction et Compensation pour Transaction peuvent utiliser les mêmes formes Port et formes Implémentation affichées sur la page Processus professionnel.

Les transactions de courte durée conçues à l'aide du Concepteur d'Orchestration BizTalk possèdent les quatre attributs ACID. ACID est un acronyme composé des propriétés suivantes :

  • Atomicité Une transaction représente une unité atomique de travail. Soit toutes les modifications d'une transaction sont effectuées, soit aucune modification n'est effectuée.

  • Cohérence Une fois validée, une transaction doit préserver l'intégrité des données dans le système. Si une transaction effectue une modification de données dans une base de données dont la cohérence interne était assurée avant le démarrage de la transaction, cette cohérence doit être conservée lorsque la transaction est validée. La garantie de cette propriété incombe en grande partie au développeur de l'application.

  • Isolement Les modifications effectuées par des transactions simultanées doivent être isolées des modifications effectuées par les autres transactions. Les transactions isolées qui sont exécutées simultanément effectuent des modifications préservant la cohérence interne de la base de données, exactement comme si ces transactions étaient effectuées en série.

  • Durabilité Lorsqu'une transaction est validée, toutes les modifications apportées au système par défaut sont permanentes. Les modifications subsistent même en cas d'échec du système.

Au contraire, les transactions de longue durée sacrifient l'isolement à la possibilité de gérer des opérations qui nécessitent une longue période d'exécution.

Remarques

  • Pour tester le résultat d'une transaction, vous devez utiliser un message créé dans le processus En cas d'échec de la transaction. Vous ne devez pas tester l'existence d'un message, qui peut avoir été modifié ou non, utilisé dans la transaction.

  • Lorsque vous utilisez la fonctionnalité COM+ BYOT (Bring Your Own Transaction) avec des composants COM du moteur de XLANG Scheduler, créez un composant wrapper écrit et installé dans une application COM+. Tous les appels de méthode du composant seront transmis à partir de ce composant. Si un composant BYOT est importé dans une application COM+, il ne pourra pas lancer les composants COM traditionnels, car le composant qui fournit la fonctionnalité est enregistré en tant que composant COM traditionnel et non en tant qu'application COM+.

Cette section traite des rubriques suivantes :

  • Propriétés des transactions d'un schéma de planification XLANG

  • Propriétés des transactions pour des formes de transaction spécifiques

  • Propriétés des transactions pour une implémentation de port

  • Transactions de longue durée

  • Transactions de courte durée

Voir aussi

Conception d'actions

Conception concurrentielle

Conception de règles

Formes Diagramme de flux

Définition des propriétés de transaction


Propriétés des transactions d'un schéma de planification XLANG

Pour afficher la boîte de dialogue Propriétés de début, cliquez avec le bouton droit sur la forme Début de la page Processus professionnel et cliquez sur Propriétés. La boîte de dialogue Propriétés de début vous permet de configurer les propriétés suivantes :

  • Modèle de transaction. La valeur par défaut de cette propriété est Inclure des transactions dans la planification.
    • Choisissez Inclure des transactions dans la planification si vous voulez englober une collection d'actions groupées dans une forme Transaction au sein de votre schéma de planification XLANG. Le choix de cette option désactive la propriété Activation de la transaction.

    • Choisissez Traiter la planification XLANG en tant que composant COM+ si vous voulez qu'un composant COM+ active votre planification XLANG dans son contexte transactionnel COM+. Si vous choisissez cette option, vous ne pourrez pas inclure de transactions dans votre schéma de planification XLANG, et votre utilisation de la forme Branche pour l'implémentation de la simultanéité devra être limitée. Si vous utilisez la forme Branche, toutes les actions contenant des appels à des composants COM+ devront êtres limitées à une simple branche sortante. Cette restriction ne s'applique pas si les actions de votre schéma de planification XLANG contiennent des appels à des composants COM. Aussi, toutes les modifications transactionnelles doivent être effectuées sur une seule branche sortante.

      Le choix de cette option active la propriété Activation de la transaction.

  • Activation de la transaction. La valeur par défaut de cette propriété est Non pris en charge.
    • Non pris en charge Cette sélection indique que la planification XLANG ne prend pas en charge les transactions.

    • Pris en charge Cette sélection indique que la planification XLANG peut participer à une transaction COM+.

    • Obligatoire Cette sélection indique que la planification XLANG requiert une transaction COM+.

    • Requiert une nouvelle Cette sélection indique que la planification XLANG doit participer à une nouvelle transaction. Si cette option est activée, le moteur de XLANG Scheduler initie automatiquement une nouvelle transaction qui est différente de celle de l'appelant.
  • Identité XLANG. Pour plus d'informations sur la propriété Identité XLANG, voir Formes Diagramme de flux.

Voir aussi

Conception de transactions

Transactions de longue durée

Transactions de courte durée

Propriétés des transactions pour une implémentation de port

Propriétés des transactions pour des formes de transaction spécifiques


Propriétés des transactions pour des formes de transaction spécifiques

Pour afficher la boîte de dialogue Propriétés de la transaction, cliquez avec le bouton droit sur la forme Transaction de la page Processus professionnel et cliquez sur Propriétés. La boîte de dialogue Propriétés de la transaction vous permet de configurer les propriétés suivantes :

  • Type Cette propriété définit le type de transaction utilisé pour la forme Transaction sélectionnée. La valeur par défaut de cette propriété est Style DTC, courte.
    • Choisissez Style DTC, courte si vous voulez que la transaction regroupe un ensemble d'actions effectuées comme une seule unité logique de travail possédant les quatre propriétés d'une transaction ACID. Pour plus d'informations sur les transactions, voir Conception de transactions. Les transactions de ce type sont indiquées en gris ombré sur la page de conception. Cette option est disponible pour les transactions imbriquées et les transactions autonomes. Vous ne pouvez pas appliquer cette option à une transaction externe contenant une transaction imbriquée.

    • Choisissez Longue si vous voulez que la transaction regroupe un ensemble d'actions qui envoient et reçoivent des messages sur une période de temps indéterminée. Vous pouvez également configurer une transaction longue de manière à regrouper un ensemble de transactions imbriquées ; cependant, les transactions sont limitées à un niveau d'imbrication. Les transactions de longue durée sont indiquées en jaune ombré sur la page de conception. Cette option est disponible pour toutes les transactions.

    • Choisissez Minutée si vous souhaitez l'abandon de la transaction si celle-ci n'a pas été exécutée après un temps donné. Les transactions minutées sont indiquées en bleu ombré sur la page de conception. L'option Timed est disponible pour toutes les transactions.
  • Maintenir l'état de la planification. Cette propriété détermine si l'état de la planification est enregistré ou non dans la base de données de persistance d'orchestration. Cette option est disponible pour les transactions Minutée et Longue. Si vous n'accordez pas d'importance aux informations sur l'état de persistance, vous pouvez désactiver cette option afin d'optimiser le débit.

  • Délai Cette propriété définit la durée d'exécution (en secondes) d'une transaction avant son abandon. Cette option est disponible pour les transactions Minutée et Style DTC, courte.

  • Nombre de tentatives Cette propriété définit le nombre d'exécutions d'un processus dans une transaction Style DTC, courte si le processus n'est pas terminé. À chaque tentative, l'état de l'application est réinitialisé au point de départ du processus dans la transaction.

  • Intervalle Cette propriété définit l'intervalle entre chaque tentative de la transaction. L'intervalle est utilisé avec la valeur du nombre de tentatives pour déterminer le délai avant la prochaine tentative de la transaction. La valeur de l'intervalle est exponentielle. Une valeur d'intervalle de 2 secondes correspond à un délai de 2, 4, 8, 16 secondes, et ainsi de suite, entre les tentatives. La formule est B**R (B élevé à la puissance R), où B = intervalle et R = nombre de tentatives. Si l'intervalle d'une tentative de transaction spécifique est supérieur à 180 secondes, l'instance de planification XLANG est immédiatement mise en attente dans la base de données de persistance.

  • Niveau d'isolation Le niveau d'isolation détermine dans quelle mesure les données des transactions simultanées sont accessibles les unes par rapport aux autres. Cette option est disponible uniquement pour les transactions de type Style DTC, courte. Choisissez :
    • Serializable pour empêcher les transactions simultanées de modifier les données avant la fin de la transaction sélectionnée. Il s'agit du niveau d'isolation le plus restrictif parmi les quatre niveaux disponibles.

    • Read Uncommitted pour autoriser les transactions simultanées à modifier les données avant la fin de la transaction sélectionnée. Il s'agit du niveau d'isolation le moins restrictif parmi les quatre disponibles.

    • Read Committed pour empêcher la transaction sélectionnée d'accéder aux modifications de données des transactions simultanées avant qu'elles aient été validées. Cette option est le paramètre par défaut de Microsoft® SQL Server™.

    • Repeatable Read pour requérir des verrous de lecture jusqu'à la fin de la transaction sélectionnée.
  • En cas d'échec Cliquez sur Ajouter un code, activez la case à cocher Activé, puis cliquez sur OK pour afficher la page En cas d'échec de Transaction. Vous pouvez utiliser la page En cas d'échec de Transaction pour concevoir un processus professionnel de remplacement en cas d'échec de la transaction sélectionnée. Cette option est disponible pour toutes les transactions.

  • Compensation Cliquez sur Ajouter un code, activez la case à cocher Activé, puis cliquez sur OK pour afficher la page Compensation pour Transaction. Vous pouvez utiliser la page Compensation pour Transaction pour concevoir un processus professionnel de remplacement destiné à annuler l'unité logique de travail qui a été effectuée dans une transaction imbriquée déjà validée. Cette option est disponible uniquement pour les transactions imbriquées.

Remarque

  • L'abandon d'une transaction imbriquée n'entraîne pas automatiquement celui de la transaction externe. Cela vous permet de concevoir une transaction externe pouvant être récupérée en cas d'échec d'une transaction imbriquée. Toutefois, l'échec d'une transaction imbriquée peut entraîner celui d'une transaction externe si la page En cas d'échec de Transaction ou Compensation pour Transaction de la transaction imbriquée a été conçue pour abandonner la transaction externe.

Voir aussi

Conception de transactions

Transactions de longue durée

Transactions de courte durée

Propriétés des transactions d'un schéma de planification XLANG

Propriétés des transactions pour une implémentation de port


Propriétés des transactions pour une implémentation de port

Vous pouvez configurer les propriétés des transactions pour les composants COM et Windows Script aux pages Propriétés avancées du port de l'Assistant Liaison de composants COM et de l'Assistant Liaison de composants de script. La page Propriétés avancées du port fournit une option permettant d'abandonner la transaction en cours lorsqu'une méthode d'un composant renvoie une erreur. La page Propriétés avancées du port vous permet également de configurer les propriétés transactionnelles suivantes :

  • Prise en charge des transactions La propriété Prise en charge des transactions indique dans quelle mesure votre composant va requérir, prendre en charge ou ignorer les transactions.
    • Désactivé Cette option indique que le composant ignore la gestion des transactions COM.

    • Non pris en charge Cette option indique que le composant ne va pas participer à une transaction ou propager les transactions d'autres composants.

    • Pris en charge Cette option indique que si une transaction contient une action connectée à un port auquel le composant est lié, le composant est inclus dans la transaction. Sinon, le composant n'a pas de transaction.

    • Obligatoire Cette option indique que si une transaction contient une action connectée au port auquel le composant est lié, le composant est inclus dans la transaction. Si aucune transaction ne contient une action connectée au port auquel le composant est lié, une nouvelle transaction est créée pour le composant.

    • Requiert une nouvelle Cette option indique qu'une nouvelle transaction est toujours créée pour le composant.

Important

  • Le Concepteur d'Orchestration BizTalk se base sur le comportement transactionnel des technologies d'implémentation utilisées dans un schéma de planification XLANG. Il ne fournit ni n'impose aucun comportement transactionnel sur un processus professionnel si le schéma de planification XLANG contient une forme Transaction. Si un composant COM, Message Queuing ou Script n'est pas transactionnel, les données manipulées par le schéma de planification XLANG ne seront pas modifiées de manière transactionnelle.

Remarques

  • Si vous définissez la propriété Modèle de transaction de manière à traiter la planification XLANG comme un composant COM+, n'utilisez pas de forme Transaction dans le schéma de planification XLANG. Si vous utilisez des formes Transaction, puis essayez de compiler le schéma de planification XLANG en une planification XLANG, le processus de compilation ne fonctionnera pas. Vous devez supprimer toutes les formes Transaction du schéma de planification XLANG avant de le compiler.

  • Si l'utilisation d'un composant COM a lieu dans plusieurs transactions, le composant COM doit, soit ne pas posséder d'état, soit posséder un état et prendre en charge la persistance.

  • Si plusieurs actions communiquent avec un port lié à un composant COM ou de script et que ces actions figurent dans plusieurs transactions non imbriquées les unes aux autres, les instances du composant seront détruites et instanciées à nouveau avant chaque nouveau contexte transactionnel. Si le composant possède un état et prend en charge la persistance, la réactivation restaurera cet état. Si le composant possède un état et ne prend pas en charge la persistance, l'état sera perdu. Si le composant a été instancié par une autre application, le moteur de XLANG Scheduler pourra réactiver le composant uniquement si celui-ci est persistant. Si le composant a été instancié par une autre application et n'est pas persistant, le moteur de XLANG Scheduler ne pourra pas instancier à nouveau le composant, et la planification XLANG échouera en générant une erreur.

Voir aussi

Conception de transactions

Transactions de longue durée

Transactions de courte durée

Propriétés des transactions d'un schéma de planification XLANG

Propriétés des transactions pour des formes de transaction spécifiques


Transactions de longue durée

Les transactions de longue durée ne prennent pas en charge l'isolement, qui est un des quatre attributs ACID décrits dans la section Conception de transactions. Les données des transactions de longue durée ne sont pas verrouillées ; d'autres processus ou applications peuvent modifier les données. Si vos données doivent être cohérentes, utilisez exclusivement des transactions ACID. Toutefois, les transactions ACID dans un environnement à temps de latence élevé provoquant de sérieux problèmes d'adaptabilité, les schémas de planification XLANG prennent en charge les transactions de longue durée. Les transactions de longue durée permettent d'éviter le verrouillage des bases de données pendant de longues périodes. Au cours d'une transaction de longue durée, les messages sont envoyés et reçus sur une période de temps indéterminée. En fonction des exigences du processus professionnel décrit par votre schéma de planification XLANG, vous pouvez inclure un processus professionnel complet (à l'exception des formes Début et Fin) dans une transaction longue.

D'une manière générale, une transaction de longue durée contient plusieurs transactions de courte durée imbriquées. Par exemple, dans un scénario de transfert électronique simple, une transaction de longue durée peut contenir les actions suivantes dans une transaction de courte durée imbriquée :

  • Retrait d'une somme d'argent d'un compte bancaire

  • Lancement du processus de transfert électronique

L'illustration ci-après présente la transaction Envoi d'argent, une transaction de courte durée imbriquée dans une transaction de longue durée appelée Transfert électronique. La transaction imbriquée contient les deux actions dans le scénario de transfert électronique simple. Une fois l'action Lancement du transfert électronique terminée, la séquence des processus professionnels quitte la transaction imbriquée. Dès lors, la transaction imbriquée est validée ; l'argent a été retiré d'un compte bancaire et envoyé à une destination. À ce stade, la séquence des processus professionnels passe à l'action Attente d'accusé de réception dans la transaction externe.

Transaction de longue durée

Dans ce scénario, la transaction Transfert électronique a été configurée comme une transaction minutée. Si l'émetteur n'a pas reçu d'accusé de réception de l'argent dans le délai spécifié, la transaction externe est abandonnée. Dans ce cas, la séquence des processus professionnels passe à la page Compensation pour envoi d'argent pour la transaction imbriquée. Étant donné que la transaction imbriquée a déjà été validée, le processus professionnel suppléant doit décrire des actions pouvant être exécutées afin de créditer le compte de l'émetteur. Une fois que le processus professionnel décrit à la page Compensation pour envoi d'argent a été exécuté, la séquence des processus professionnels passe à la page En cas d'échec du transfert électronique pour la transaction externe. Cette page doit contenir un processus professionnel décrivant la gestion des exceptions pour la transaction externe. Dans ce cas, le processus professionnel pourrait consister à envoyer un courrier électronique de suivi aux participants pour les informer du statut du transfert.

Voir aussi

Conception de transactions

Formes Diagramme de flux

Transactions de courte durée


Transactions de courte durée

Une transaction de courte durée est un ensemble d'actions regroupées et effectuées comme une seule unité logique de travail. Cette unité logique de travail présente les quatre propriétés d'une transaction ACID. Pour plus d'informations sur les transactions, voir Conception de transactions.

Voir aussi

Conception de transactions

Formes Diagramme de flux

Transactions de longue durée


Gestion des exceptions

Le moteur de XLANG Scheduler peut intercepter les erreurs système. Le Concepteur d'Orchestration BizTalk vous permet de concevoir des planifications XLANG qui réagiront à des erreurs d'application au moment de l'exécution. Si vous incluez une partie d'un processus professionnel dans une forme Transaction, vous pouvez concevoir un processus professionnel alternatif qui s'exécutera si une erreur survient ou si une exigence n'est pas remplie.

Cette section traite des rubriques suivantes :

  • Erreurs système

  • Erreurs d'application

Voir aussi

Définition des propriétés de gestion d'erreurs


Erreurs système

Trois niveaux de gravité d'erreurs système peuvent se présenter lors du fonctionnement du moteur de XLANG Scheduler. Ces trois niveaux sont les suivants, par ordre croissant de gravité :

  • Erreurs susceptibles d'être interceptées dans une planification XLANG.

  • Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG.

  • Erreurs susceptibles d'entraîner l'échec du moteur de XLANG Scheduler.

Cette section traite des rubriques suivantes :

  • Erreurs susceptibles d'être interceptées dans une planification XLANG

  • Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG

  • Erreurs susceptibles d'entraîner l'échec du moteur de XLANG Scheduler


Erreurs susceptibles d'être interceptées dans une planification XLANG

Le moteur de XLANG Scheduler peut intercepter les erreurs système suivantes :

  • Les erreurs COM qui provoquent des échecs de HRESULT ; par exemple un message Accès refusé issu de COM et entraînant un appel de méthode dans une planification XLANG avec une permission inadéquate. Application possible à des liaisons COM ou script.

  • Abandons de transactions provoqués par des services inscrits, par exemple le DTC (Distributed Transaction Coordinator) abandonnant une transaction suite à la perte de la connexion avec une base de données. Autre exemple : le service de Message Queuing abandonnant une transaction parce qu'il est incapable de placer un message dans une file d'attente.

Pour gérer un échec de HRESULT à l'aide d'un branchement logique, le message _out issu d'un appel de méthode doit être testé dans une règle de décision. La valeur HRESULT est stockée dans le champ __Status__ du message _out.

Pour gérer un échec de HRESULT à l'aide des processus d'échec de transaction, la propriété Abandonner la transaction si la méthode renvoie un échec de HRESULT doit être définie sur la dernière page de l'Assistant Liaison de composants COM ou de l'Assistant Liaison de composants de script. Cette propriété ne peut être définie que si l'action est contenue dans une transaction.

Important

  • Cette option détermine si les transactions dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT. Cette option peut uniquement être définie si l'action de communication utilisant ce port se trouve dans un flux de processus d'une transaction.

La gestion d'un échec dans les technologies d'implémentation Message Queuing ou Échanges BizTalk est possible uniquement à l'aide des processus d'échec de transaction. Pour cela, vous devez définir la propriété Utiliser des files d'attente de messages transactionnelles sur la dernière page de l'Assistant Liaison de Message Queuing (cette opération est effectuée automatiquement dans le cas des Échanges BizTalk).

Remarque

  • Une action d'envoi de Message Queuing qui revient avec succès indique que le message a été correctement placé dans la file d'attente. Cela n'indique pas que le message a été transmis.

Voir aussi

Erreurs d'application

Erreurs susceptibles d'entraîner l'échec du moteur de XLANG Scheduler

Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG

Gestion des exceptions

Erreurs système


Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG

Les erreurs système qui provoquent la fin d'une instance de planification XLANG mais ne peuvent être interceptées dans une planification XLANG sont les suivantes :

  • Une file d'attente planifiée inexistante.

  • Un canal planifié inexistant.

  • Un flux de données d'un message qui n'est pas encore arrivé.

Voir aussi

Erreurs d'application

Erreurs susceptibles d'être interceptées dans une planification XLANG.

Erreurs susceptibles d'entraîner l'échec du moteur de XLANG Scheduler

Gestion des exceptions

Erreurs système


Erreurs susceptibles d'entraîner l'échec du moteur de XLANG Scheduler

Les erreurs système qui ne peuvent pas être interceptées par le moteur de XLANG Scheduler peuvent provoquer l'échec du moteur de XLANG Scheduler ainsi que celui de toutes les instances de planification XLANG fonctionnant dans la même application COM+. Parmi ces erreurs système, il y a des violations d'accès par composants qui fonctionnent au sein de l'espace de processus du moteur de XLANG Scheduler. Le moteur de XLANG Scheduler va essayer d'intercepter ces erreurs, mais sans succès dans la plupart des cas. Dans le cas où un composant génère ce type d'erreur, il est conseillé de le placer dans une application COM+ distincte afin d'éviter cette situation problématique.

Voir aussi

Erreurs d'application

Erreurs susceptibles d'être interceptées dans une planification XLANG

Erreurs susceptibles de provoquer la fin d'une instance de planification XLANG

Gestion des exceptions

Erreurs système


Erreurs d'application

Il existe trois manières de traiter les erreurs pouvant provoquer des erreurs de planification XLANG :

  • Utilisation du branchement logique

  • Utilisation du processus d'abandon transactionnel

  • Utiliser Délais


Branchement logique

Des décisions et règles peuvent être utilisées pour ramifier un flux de processus sur n'importe quelle page de processus (page Processus professionnel ou toute page En cas d'échec de Transaction ou Compensation pour Transaction). L'illustration ci-dessous montre un test simple d'exécution de méthode.

Dans cet exemple, le message Clear_out possède un champ système nommé __Status__. Dans la règle HRESULT Success, l'expression du script serait Clear_out.[__Status__] >= 0, où une valeur négative de HRESULT indique un échec, et une valeur positive ou nulle de HRESULT indique un succès. En utilisant de cette manière des décisions et des règles, il est possible de tester la présence d'exceptions dans n'importe quel champ de données de n'importe quel message (dans l'expression VBScript d'une règle), et pas uniquement pour les valeurs HRESULT.

Voir aussi

Gestion des exceptions

Délais

Processus d'abandon transactionnel


Processus d'abandon transactionnel

Dans le concepteur d'Orchestration BizTalk, vous pouvez utiliser des transactions pour regrouper un ensemble d'actions exécutées sous la forme d'une seule unité logique de travail, et vous assurer que soit toutes les transactions, soit aucune des transactions du groupe ne sont menées à terme. En regroupant les processus professionnels au sein de transactions, le Concepteur d'Orchestration BizTalk atteint un niveau de structure et de fiabilité maximal.

Le flux des processus d'une transaction s'exécute normalement, jusqu'à ce que la transaction se termine ou qu'un événement d'abandon survienne. Un événement d'abandon peut avoir plusieurs causes :

  • Rencontre d'une forme Abandon dans le flux des processus.

  • Échec de HRESULT défini pour provoquer un abandon dans une liaison de port.

  • Toute technologie de liaison peut, au niveau système, introduire un événement d'échec entraînant l'abandon de la transaction. Par exemple, le placement d'un message dans une file d'attente par Message Queuing peut échouer.

  • Le moteur de XLANG Scheduler peut rencontrer une erreur provoquant l'abandon d'une transaction dans une instance donnée. Il peut par exemple s'agir d'une erreur DTC.

  • La mise en attente d'une planification peut nécessiter l'abandon de toutes les transactions de cette planification.

  • Présence d'un délai dans les propriétés des transactions.

En cas d'abandon, une transaction peut reprendre depuis le début, en fonction de la valeur de la propriété Nombre de tentatives du groupe de transactions. Si, après le nombre de tentatives spécifié, l'exécution de la transaction échoue encore, le système fait appel au processus professionnel En cas d'échec de Transaction. Ce code En cas d'échec de Transaction permet de structurer la gestion de l'échec d'une transaction.

Le code En cas d'échec de Transaction ne doit annuler aucun travail au sein de la transaction. Si les ports sont liés à des ressources transactionnelles, le DTC (Distributed Transaction Coordinator) gère la restauration de toutes les actions répertoriées dans la transaction. Les ressources non transactionnelles ne sont pas restaurées. Si la transaction est imbriquée dans une transaction externe et si cette transaction imbriquée a déjà été validée, la séquence des processus professionnels passe au processus professionnel Compensation pour Transaction pour la transaction imbriquée. Le processus professionnel Compensation pour Transaction est décrit sur la page Compensation pour Transaction. Ce processus professionnel de remplacement doit contenir des actions pouvant servir à annuler le travail au sein de la transaction imbriquée.

Lorsque le code Compensation pour Transaction ou En cas d'échec de Transaction a été exécuté, la séquence des processus professionnels quitte le bas de la forme Transaction sur la page Processus professionnel. Les actions de la séquence des processus professionnels qui se produisent après une transaction ne reçoivent pas d'indication explicite de la fin ou de l'abandon de la transaction. Pour permettre une telle indication explicite, vous pouvez définir un indicateur dans un champ de message sur la page En cas d'échec de Transaction ou Compensation pour Transaction.

Voir aussi

Gestion des exceptions

Branchement logique

Délais


Délais

Si une action dans une transaction ne reçoit pas un message attendu en provenance d'un partenaire commercial, cet échec est traité comme une erreur d'application. Pour tester ce type d'erreur, utilisez des transactions minutées.

Par exemple, dans un scénario de transfert électronique simple, une transaction minutée peut contenir les actions suivantes dans une transaction imbriquée :

  • Retrait d'une somme d'argent d'un compte bancaire

  • Lancement du processus de transfert électronique

L'illustration suivante présente la transaction Envoi d'argent, une transaction imbriquée dans une transaction minutée appelée Transfert électronique. La transaction imbriquée contient les deux actions dans le scénario de transfert électronique simple. Une fois l'action Lancement du transfert électronique terminée, la séquence des processus professionnels quitte la transaction imbriquée. Dès lors, la transaction imbriquée est validée ; l'argent a été retiré d'un compte bancaire et envoyé à une destination. À ce stade, la séquence des processus professionnels passe à l'action Attente d'accusé de réception dans la transaction externe.

Transaction de longue durée

Dans ce scénario, la transaction Transfert électronique a été configurée comme une transaction minutée. Si l'émetteur n'a pas reçu d'accusé de réception de l'argent dans le délai spécifié, la transaction externe est abandonnée. Dans ce cas, la séquence des processus professionnels passe à la page Compensation pour envoi d'argent pour la transaction imbriquée. Étant donné que la transaction imbriquée a déjà été validée, le processus professionnel suppléant doit décrire des actions pouvant être exécutées afin de créditer le compte de l'émetteur. Une fois que le processus professionnel décrit à la page Compensation pour envoi d'argent a été exécuté, la séquence des processus professionnels passe à la page En cas d'échec du transfert électronique pour la transaction externe. Cette page doit contenir un processus professionnel décrivant la gestion des exceptions pour la transaction externe. Dans ce cas, le processus professionnel pourrait consister à envoyer un courrier électronique de suivi aux participants pour les informer du statut du transfert.

Voir aussi

Gestion des exceptions

Branchement logique

Processus d'abandon transactionnel


Implémentation de processus professionnels

Le stencil Implémentation contient quatre formes qui correspondent aux technologies pouvant être utilisées pour implémenter un port dans un processus professionnel. Étant donné que chaque action envoie un message vers un port ou reçoit un message en provenance d'un port, la signification sémantique de l'envoi ou de la réception des messages varie en fonction de la technologie d'implémentation spécifique.

L'utilisation des formes Implémentation comprend deux processus distincts. Dans le premier processus, un port est lié à une technologie d'implémentation. De manière conceptuelle, un port est un emplacement abstrait vers lequel un message est envoyé ou depuis lequel un message est reçu. Lier le port à une implémentation définit le type d'emplacement auquel le port est lié. Dans le second processus, une action est connectée au port. Ce processus définit le schéma du message qui est envoyé vers ou reçu depuis le port.

Le Concepteur d'Orchestration BizTalk prend en charge quatre technologies d'implémentation :

  • Composants COM : cette technologie permet la communication synchrone.

  • Composants de script Windows : cette technologie permet la communication synchrone.

  • Services Message Queuing : cette technologie permet la communication asynchrone.

  • Services d'Échanges BizTalk : cette technologie permet la communication asynchrone.

La barre de séparation divise la page de conception du Concepteur d'Orchestration BizTalk en une zone de conception de processus professionnels du côté gauche et une zone d'implémentation du côté droit. Pour ouvrir un assistant de liaison de port, déplacez une des formes Implémentation sur la page de conception, à droite de la barre de séparation. Vous pouvez effectuer cette tâche sur la page Processus professionnel, sur la page En cas d'échec de Transaction et sur la page Compensation pour Transaction.

Remarque

  • Vous ne pouvez pas configurer une enveloppe dans le Concepteur d'Orchestration BizTalk. Par conséquent, si vous voulez soumettre un fichier plat au Concepteur d'Orchestration BizTalk, utilisez l'Éditeur BizTalk pour convertir le contenu du fichier plat en XML. Vous pourrez ensuite soumettre le fichier XML au Concepteur d'Orchestration BizTalk.

Cette section traite des rubriques suivantes :

  • Description des implémentations de ports

  • Communication synchrone et asynchrone


Description des implémentations de ports

Un port est un emplacement nommé qui utilise une implémentation spécifique. Dans une planification XLANG, les ports facilitent les communications synchrones et asynchrones et sont utilisés pour transmettre des messages vers ou depuis la planification.

Dans le Concepteur d'Orchestration BizTalk, un port est défini par l'emplacement vers lequel les messages sont envoyés ou à partir duquel les messages sont reçus, ainsi que par la technologie utilisée pour implémenter l'action de communication. Les ports sont liés sur la gauche aux actions dans le flux de processus professionnels de la planification XLANG ; de plus, ils sont liés sur la droite à une technologie d'implémentation qui peut faciliter l'action requise. L'emplacement est identifié de manière univoque par le nom du port.

L'emplacement d'un port dépend en partie de la technologie utilisée pour implémenter le port. Le tableau suivant présente les implémentations de ports disponibles ainsi que l'emplacement associé à chaque implémentation.

Implémentation du port | Emplacement du port
Composant COM | Un pointeur vers une instance activée d'un objet
Composant de script Windows | Un pointeur vers une instance activée d'un objet
Message Queuing | Un nom de chemin d'accès de file d'attente vers une file d'attente de messages
Échanges BizTalk | Un nom de canal pour un canal spécifique d'Échanges BizTalk

Il existe deux types de ports :

  • Ports statiques. Un port statique nécessite que toutes les informations relatives à l'emplacement et à l'implémentation du port soient fournies au moment de la conception pour une planification XLANG. Le concepteur qui crée la planification XLANG doit connaître l'emplacement vers lequel les messages sont envoyés ou à partir duquel les messages sont reçus, ainsi que la technologie choisie pour implémenter l'action de communication.

  • Ports dynamiques. Un port dynamique nécessite que des informations spécifiques sur l'emplacement du port soient fournies au moment de l'exécution pour une planification XLANG. Le choix de l'implémentation d'un port dynamique s'effectue au moment de la conception, mais l'emplacement de ce port n'est pas connu avant l'exécution de la planification XLANG. L'emplacement d'un port dynamique est fourni par un message qui transmet les informations relatives à cet emplacement à la référence du port. Ce message doit parvenir en un point du flux de processus de la planification XLANG avant que la communication qui utilise cette implémentation de port puisse être utilisée.

    Si vous voulez utiliser un port dynamique pour une communication, et que la planification XLANG n'a pas encore reçu de message contenant la référence du port lorsque la planification tente d'effectuer l'action, une erreur est générée.

Tant les ports statiques que les ports dynamiques fournissent des options pour les communications synchrones et asynchrones, mais les implémentations de ports pour ces communications diffèrent en fonction de la technologie utilisée pour implémenter le port.

Un port peut être statique ou dynamique ; cependant, tous les ports ne peuvent pas implémenter des communications synchrones et asynchrones. Pour créer une action de communication synchrone, vous devez utiliser une implémentation de port de composant COM ou de script. Pour créer une action de communication asynchrone, vous devez utiliser une implémentation de port de type Message Queuing ou Échanges BizTalk.

Cette section traite des rubriques suivantes :

  • Ports statiques et dynamiques

  • Utilisation de la forme Composant COM

  • Utilisation de la forme Composant de script

  • Utilisation de la forme Message Queuing

  • Utilisation de la forme Échanges BizTalk

Remarque

  • Lorsqu'une planification XLANG reçoit des documents de texte non-XML provenant d'un port implémenté par Message Queuing ou par l'application Échanges BizTalk, les retours chariot (CR) sont supprimés du document. Si un message codé au format MIME est envoyé à une planification qui doit utiliser ou envoyer ultérieurement les données à un autre emplacement, le document envoyé par la planification ne contient pas les caractères CR et n'apparaît pas comme un document codé au format MIME valide. Si cela vous pose un problème, vous devez écrire un composant personnalisé qui sera appelé depuis la planification afin de restaurer les caractères CR dans le document.

Voir aussi

Communication synchrone et asynchrone


Ports statiques et dynamiques

Le comportement des ports statiques et dynamiques varie en fonction du type d'implémentation utilisé.

Implémentations de ports utilisant des composants COM ou de script

Dans le cas d'une implémentation de port utilisant des composants COM ou de script, les propriétés statiques et dynamiques déterminent le mode d'instanciation d'un composant :

  • Statique. Dans le cas d'une planification XLANG qui utilise un port statique, le moteur de XLANG Scheduler instancie le composant qui est défini pour cette implémentation de port.

  • Dynamique. Dans le cas d'une planification XLANG qui utilise un port dynamique, le moteur de XLANG Scheduler n'instancie pas le composant. Au lieu de cela, la planification XLANG attend qu'une autre application instancie le composant. L'instance d'objet doit être renvoyée à la planification XLANG sous la forme d'un champ dans un message. Sur la page Données, une connexion doit être établie entre ce champ de message et la référence de port du port utilisant cette implémentation. La planification XLANG intercepte à la fois la requête de méthode ainsi que la réponse de la méthode issue du composant.

En plus des options Statique et Dynamique, il existe un troisième choix :

  • Aucune instanciation. Dans le cas d'une planification XLANG qui utilise un port sans instanciation, le composant n'est pas instancié et aucun code pour l'appel de méthode n'est exécuté. Au lieu de cela, lorsque la planification XLANG intercepte les informations de requête de méthode, elle renvoie ces informations en tant que réponse. L'appel de méthode est évité.

Implémentations de ports utilisant Message Queuing

Dans le cas d'une implémentation de port qui utilise Message Queuing, les propriétés statiques et dynamiques sont représentées sous la forme de files d'attente statiques et dynamiques :

  • File d'attente statique. Un port statique utilise une file d'attente statique connue et préexistante. Vous pouvez affecter cette file d'attente au moment de la conception.

    Si vous utilisez une file d'attente statique, vous pouvez utiliser une file d'attente connue qui ne change jamais, ou bien créer une nouvelle instance de la même file d'attente à chaque exécution de la planification XLANG. La file d'attente par instance est identifiée à l'aide d'un ID unique annexé au nom de la file d'attente.

  • File d'attente dynamique. Un port dynamique utilise une file d'attente dynamique qui est inconnue au moment de la conception. Les informations relatives à une file d'attente dynamique doivent être fournies au moment de l'exécution dans un champ de message. Sur la page Données, vous devez créer une liaison entre un champ de message et la référence de ce port. Lorsqu'un message contenant le nom de la file d'attente arrive, la planification XLANG peut utiliser la file d'attente affectée. Le message contenant le nom de la file d'attente doit arriver avant que la communication qui utilise cette implémentation de port puisse être utilisée.

Implémentations de ports utilisant Échanges BizTalk

Dans le cas d'une implémentation de port qui utilise Échanges BizTalk, les propriétés statiques et dynamiques sont représentées sous la forme de canaux statiques et dynamiques. Les canaux dynamiques ne peuvent être utilisés que lors de l'envoi de messages. Ils ne peuvent pas servir à la réception de messages.

  • Canal statique. Un port statique utilise un canal statique connu et préexistant. Vous pouvez affecter ce canal, qui ne variera jamais, au moment de la conception.

  • Canal dynamique. Un port dynamique envoie un document vers une destination qui est inconnue au moment de la conception. La valeur de cette destination doit être stipulée lors de l'exécution dans un champ de message. Sur la page Données, vous devez créer une liaison entre un champ de message et la référence de ce port. Lorsque le message contenant la valeur de la destination est reçu, la planification XLANG envoie le document à un canal d'échange qui est associé à un port de destination ouvert. Ce port envoie ensuite le message à la valeur de la destination spécifiée lors de l'exécution. Notez que le canal d'échange doit correspondre à Organisation d'origine et indiquer la même définition de document que le message devant être envoyé. Le message contenant la valeur de la destination doit arriver avant que la communication faisant appel à cette implémentation de port puisse être utilisée.

Un port qui utilise un canal dynamique permet à une planification XLANG de déterminer l'emplacement auquel envoyer un message au moment de l'exécution, plutôt que d'imposer la définition d'une destination prédéterminée au moment de la conception. Cette propriété définit l'identité du canal utilisé lorsque la planification XLANG transmet le message aux services d'échanges BizTalk.

Il ne faut pas confondre un canal dynamique avec un canal ouvert qui est configuré dans le Gestionnaire d'Échanges BizTalk. Un canal ouvert permet la détermination de l'organisation source au moment de l'exécution à partir des informations contenues dans le document ou dans les paramètres soumis avec celui-ci. Cette propriété définit la source des documents. Pour plus d'informations sur les canaux ouverts, voir Description des canaux.

Le message transmis à un port utilisant un canal dynamique peut spécifier soit un canal ouvert soit un canal non ouvert lors de la transmission des informations sur le canal aux services d'échanges BizTalk.

Remarque

  • Si vous utilisez un canal dynamique, il est recommandé d'ajouter une action dans votre planification pour effectuer la validation d'adresses ou la gestion personnalisée des erreurs. Cet ajout permet d'éviter des pertes potentielles de données issues d'un format d'adresse incorrect ; par exemple une adresse qui n'est pas valide ou une adresse utilisant un protocole autre que les protocoles HTTP, HTTPS ou SMTP.

Voir aussi

Implémentation de ports

Communication synchrone et asynchrone

Description des canaux

Utilisation de la forme Échanges BizTalk

Utilisation de la forme Composant COM

Utilisation de la forme Message Queuing

Utilisation de la forme Composant de script


Utilisation de la forme Composant COM

La forme Composant COM vous permet d'utiliser des applications ou des composants préexistants pour effectuer des actions dans une planification XLANG. La technologie COM étant synchrone, le flux de messages est toujours bidirectionnel lors de l'exécution d'une action. À l'opposé, le flux de messages pour une technologie asynchrone est unidirectionnel.

Le moteur de XLANG Scheduler prend en charge l'envoi et la réception des messages par le biais de l'utilisation des formes Action. Lorsque vous liez un port à un composant COM dans le Concepteur d'Orchestration BizTalk, le port est lié à une interface implémentée par un composant COM qui a été enregistré sur votre système.

Une action d'envoi connectée au port représente l'invocation d'un appel de méthode spécifique par le moteur de XLANG Scheduler. Les paramètres IN et IN/OUT sont envoyés au port. En retour, un message avec un schéma défini par les paramètres IN/OUT et OUT de l'appel de méthode est reçu depuis le port. L'appel de méthode est pris en charge par l'interface liée au port.

Une action de réception connectée au port attend qu'une application externe effectue un appel de méthode sur le port. Les paramètres IN et IN/OUT définissent le schéma du message reçu par le port ; les paramètres IN/OUT et OUT définissent le schéma du message envoyé depuis le port.

Pour chaque action connectée à un port et liée à un composant COM, deux messages sont échangés. Les messages identifient la méthode sur l'interface invoquée. Le schéma des messages correspond aux paramètres IN et IN/OUT (et aux paramètres IN/OUT et OUT) de la signature de la méthode. La bibliothèque de types pour les composants étant accessible, le Concepteur d'Orchestration BizTalk peut générer automatiquement le schéma de ces messages sans demander l'information à l'utilisateur.

Important

  • Utilisez les composants COM avec prudence lorsque vous implémentez un processus professionnel à exécution longue. Si vous utilisez des composants contenant un état dans une planification XLANG, nous vous recommandons d'utiliser des composants pouvant être enregistrés à l'aide de l'interface IPersist. De cette manière, la planification XLANG peut enregistrer son état en même temps que celui des composants. Les planifications XLANG doivent être capables de posséder un état et de fonctionner pendant une longue période. Si vous utilisez des composants qui ne possèdent pas d'état, une nouvelle instance du composant est créée lors de chaque réalimentation de la planification XLANG. Toutefois, l'utilisation de composants ne possédant pas d'état ne devrait pas affecter le résultat de la planification.

La liaison correspond au processus consistant à spécifier la technologie d'implémentation d'un port. L'Assistant Liaison de composants COM comprend les pages suivantes :

Bienvenue dans l'Assistant Liaison de composants COM

La page Bienvenue dans l'Assistant Liaison de composants COM vous permet de créer et de nommer un port pour lequel vous voulez définir une implémentation.

Communication statique ou dynamique

La page Communication statique ou dynamique vous permet de définir le mode d'instanciation du composant. Le tableau suivant présente les paramètres de la communication statique et de la communication dynamique.

Communication statique ou dynamique | Description
Statique | Sélectionnez cette option si vous pouvez fournir au moteur de XLANG Scheduler toutes les informations requises pour effectuer l'implémentation au moment de la création.
Curseur dynamique | Sélectionnez cette option si le moteur de XLANG Scheduler requiert d'autres informations au moment de l'exécution pour effectuer l'implémentation.
Aucune instanciation | Sélectionnez cette option pour permettre à la planification XLANG de recevoir des données via un appel de méthode sans activer le composant. Lorsque vous choisissez Aucune instanciation, les appels de méthode à ce composant sont interceptés, le moteur de XLANG Scheduler stocke les arguments, et l'appel est renvoyé à l'appelant. Le composant n'est jamais instancié.

Informations sur les cours

La page Informations sur les classes vous permet de sélectionner une classe à partir de la liste des composants enregistrés ou d'un moniker.

Informations sur l'interface

Sur la page Informations sur l'interface, vous pouvez sélectionner l'interface à utiliser. Cette page ne s'affiche que si la classe sélectionnée contient plusieurs interfaces. Les composants Visual Basic possèdent toujours une seule interface.

Informations sur la méthode

Sur la page Informations sur la méthode, vous pouvez sélectionner les méthodes à utiliser. Cette page ne s'affiche que si la classe sélectionnée contient plusieurs méthodes.

Propriétés avancées du port

Sur la page Propriétés avancées du port, vous pouvez configurer la sécurité, la prise en charge des transactions, la prise en charge de la gestion des états et la gestion d'erreur.

Les propriétés de la prise en charge de la gestion des états de la forme Composant COM comprennent :

  • La persistance de l'état d'une planification XLANG avant le début d'une transaction et après la fin de celle-ci. Cela assure la durabilité et garantit que toutes les modifications de données validées resteront en permanence dans le système. Cela permet également de relancer une transaction en cas de défaillance.

  • L'optimisation de la gestion des instances en permettant au moteur de XLANG Scheduler de mettre en attente puis de réalimenter la planification XLANG lors de l'arrivée du message attendu.

Vous pouvez utiliser la forme Composant COM pour requérir des informations utilisateur authentifiées pour les messages reçus.

Zone Sécurité

Le tableau suivant présente les paramètres de confirmation de l'identité de l'émetteur.

Confirmation de l'identité de l'émetteur | Description
Non requise | Sélectionnez cette option si vous souhaitez que la planification XLANG soit en mesure de recevoir un message sans connaître l'identité de l'émetteur.
Facultatif | Sélectionnez cette option si vous souhaitez que le moteur de XLANG Scheduler identifie l'émetteur lorsque le composant reçoit un message, si cette information est disponible.
Requis | Sélectionnez cette option si vous ne souhaitez pas que le moteur de XLANG Scheduler reçoive de message, sauf s'il peut identifier l'expéditeur.

Zone de prise en charge des transactions

Le tableau ci-dessous présente les paramètres de prise en charge des transactions.

Prise en charge des transactions | Description
Désactivé | Ceci convient pour tous les composants non COM+. Cette option indique que le composant ignore la gestion des transactions COM.
Non pris en charge | Ceci convient uniquement pour les composants COM+. Cette option indique que le composant ne va pas participer à une transaction, ou propager les transactions d'autres composants.
Pris en charge | Ceci convient uniquement pour les composants COM+. Cette option indique que si une transaction est associée à un port auquel le composant est lié, le composant est inclus dans la transaction. Sinon, le composant n'a pas de transaction.
Requis | Ceci convient uniquement pour les composants COM+. Cette option indique que si une transaction est associée à un port auquel le composant est lié, le composant est inclus dans la transaction. S'il n'y a pas de transaction associée au port auquel le composant est lié, une nouvelle transaction est créée pour le composant.
Requiert une nouvelle | Ceci convient uniquement pour les composants COM+. Ceci indique qu'une nouvelle transaction est toujours créée pour le composant.

Zone Prise en charge de la gestion des états

Le tableau suivant présente les paramètres de prise en charge de la gestion des états.

Prise en charge de la gestion des états | Description
Ne possède pas d'état | Cette option spécifie que le moteur de XLANG Scheduler termine l'instance du composant lorsqu'il est en attente. Si vous sélectionnez cette option, le moteur de XLANG Scheduler crée, si nécessaire, une nouvelle instance du composant, lorsque la planification est réalimentée.
Possède un état mais ne prend pas en charge la persistance | Cette option indique que le moteur de XLANG Scheduler est requis pour quitter l'instance du composant en cours d'exécution. En cas d'erreur système lors de la réalimentation de l'application, tout état stocké dans ce composant est perdu.
Possède un état et prend en charge la persistance | Cette option indique que le moteur de XLANG Scheduler supprime l'instance du composant de la mémoire, puis la restaure en mémoire en appelant l'interface IPersistStream ou IPersistStreamInit dans le composant lors de la mise en attente, puis à nouveau lors de la réalimentation.

Zone de gestion d'erreur

Dans la zone Gestion d'erreur, activez la case à cocher Abandonner la transaction si la méthode renvoie un échec de HRESULT si vous voulez que le moteur de XLANG Scheduler abandonne la transaction lorsqu'une erreur est renvoyée d'une méthode dans un composant.

Remarques

  • Lorsqu'une action communique avec un port lié à un composant COM et que la méthode spécifiée n'existe pas dans le composant, l'instance de planification XLANG échoue avec une entrée de journal d'événements.

  • Le Concepteur d'Orchestration BizTalk ne prend pas en charge la liaison à une méthode de composant COM qui contient un paramètre issu de IDispatch. Toutefois, le Concepteur d'Orchestration BizTalk prend en charge la liaison à des méthodes de composants COM qui contiennent des paramètres de type IDispatch.

  • Vous ne devez pas utiliser les noms de champs système en tant que noms de paramètres dans les composants COM en raison des noms dupliqués potentiels. Pour plus d'informations, voir Champs système.

  • Si une application présente une référence à un composant COM dans une planification XLANG par le biais de l'interface IUnknown, cette référence devient non valide après la mise en attente et la réalimentation de l'instance de planification XLANG. Tous les composants COM persistants seront correctement réalimentés dans l'état où ils se trouvaient au moment de leur mise en attente, mais de nouvelles adresses seront affectées aux interfaces. Il s'agit du comportement normal et attendu. Si deux ou plusieurs champs de messages, dans une quelconque instance de planification XLANG, contiennent des pointeurs vers le même composant COM, et si la planification a été mise en attente, ces champs de messages contiendront des pointeurs vers un composant COM unique après la réalimentation. Toutefois, le composant COM ne sera pas le même que celui d'avant la mise en attente. Il s'agira en effet d'un nouveau composant COM, similaire à celui qui existait avant la mise en attente. Si le composant COM d'origine est persistant, le nouveau composant COM possédera le même état que celui du composant COM d'origine avant la mise en attente.

  • L'unicité des composants n'est pas conservée dans les boucles Tant que. Si un message dans une boucle Tant que contient un champ avec un pointeur vers un composant COM, et qu'un autre message à l'extérieur de la boucle Tant que contient un champ avec un pointeur vers le même composant COM, ces deux champs de messages ne posséderont plus de pointeur vers un composant COM unique après la mise en attente et la réalimentation. Les deux champs de messages posséderont des pointeurs vers deux composants COM distincts, similaires au composant COM d'origine. Si le composant COM d'origine est persistant, les deux nouveaux composants COM posséderont le même état que celui du composant COM d'origine avant la mise en attente.

  • Si vous souhaitez lier le port à un composant Microsoft Visual Basic, vous devez effectuer cette opération lorsque Visual Basic n'est pas en mode de débogage ; dans le cas contraire, le composant n'apparaîtra pas dans l'Assistant Liaison de composants COM.

Voir aussi

Ports statiques et dynamiques

Communication synchrone et asynchrone

Utilisation de la forme Échanges BizTalk

Utilisation de la forme Message Queuing

Utilisation de l'Assistant Communication de méthodes

Utilisation de la forme Composant de script


Utilisation de la forme Composant de script

La forme Composant de script permet d'utiliser un composant de script Windows pré-existant pour effectuer des actions dans une planification XLANG. La forme Composant de script étant synchrone, le flux des messages est toujours bidirectionnel lors de l'exécution d'une action. À l'opposé, le flux de messages pour une technologie asynchrone est unidirectionnel.

Une action d'envoi connectée au port représente l'invocation d'un appel de méthode spécifique par le moteur de XLANG Scheduler. Les paramètres IN et IN/OUT sont envoyés au port. En retour, un message avec un schéma défini par les paramètres IN/OUT et OUT de l'appel de méthode est reçu depuis le port. L'appel de méthode est pris en charge par l'interface liée au port.

Une action de réception connectée au port attend qu'une application externe effectue un appel de méthode sur le port. Les paramètres IN et IN/OUT définissent le schéma du message reçu par le port ; les paramètres IN/OUT et OUT définissent le schéma du message envoyé depuis le port.

Pour chaque action connectée à un port et liée à un composant script, deux messages sont échangés. Les messages identifient la méthode sur l'interface invoquée. Le schéma des messages correspond aux paramètres IN et IN/OUT (et aux paramètres IN/OUT et OUT) de la signature de la méthode. La bibliothèque de types pour les composants étant accessible, le Concepteur d'Orchestration BizTalk peut générer automatiquement le schéma de ces messages sans demander l'information à l'utilisateur.

Le moteur de XLANG Scheduler attend le retour de la méthode avant de poursuivre le processus professionnel. Pour envoyer un message, le moteur de XLANG Scheduler invoque la méthode spécifiée d'un composant de script Windows.

Pour créer une nouvelle liaison de composant de script, déplacez la forme Composant script du stencil Implémentation vers la page de conception du Concepteur d'Orchestration BizTalk, à droite de la barre de séparation. Pour modifier un composant de script existant, cliquez à l'aide du bouton droit sur la forme Composant de script, puis cliquez sur Modifier les propriétés. Ces deux actions provoquent le démarrage de l'Assistant Liaison de composants de script. La liaison correspond au processus consistant à spécifier la technologie d'implémentation d'un port. L'Assistant Liaison de composants de script comprend les pages suivantes :

Assistant Liaison de Composants de script

La page Assistant Liaison de composants de script vous permet de créer et de nommer un port pour lequel vous voulez définir une implémentation.

Communication statique ou dynamique

La page Communication statique ou dynamique vous permet de définir le mode d'instanciation du composant. Le tableau suivant présente les paramètres de la communication statique et de la communication dynamique.

Communication statique ou dynamique | Description
Statique | Sélectionnez cette option si vous pouvez fournir au moteur de XLANG Scheduler toutes les informations requises pour effectuer l'implémentation au moment de la création.
Dynamique | Sélectionnez cette option si le moteur de XLANG Scheduler requiert d'autres informations au moment de l'exécution pour effectuer l'implémentation.
Aucune instanciation | Sélectionnez cette option pour permettre à la planification XLANG de recevoir des données via un appel de méthode sans activer le composant. Lorsque vous choisissez Aucune instanciation, les appels de méthode à ce composant sont interceptés, le moteur de XLANG Scheduler stocke les arguments, et l'appel est renvoyé à l'appelant. Le composant n'est jamais instancié.

Sélectionnez le fichier de script

La page Sélectionnez le fichier de script vous permet de taper le chemin d'accès du fichier du composant Windows Script (.wsc) à utiliser.

Informations sur l'instanciation du composant

La page Informations sur l'instanciation du composant vous permet de spécifier si le moteur de XLANG Scheduler va utiliser un moniker ou un Prog ID pour instancier le composant de script.

Informations sur la méthode

La page Informations sur la méthode vous permet de sélectionner les méthodes qui appartiennent à la classe choisie.

Propriétés avancées du port

Sur la page Propriétés avancées du port, vous pouvez configurer la sécurité, la prise en charge des transactions et la gestion d'erreur. Vous pouvez utiliser la forme Composant de script pour requérir des informations utilisateur authentifiées pour les messages reçus.

Zone Sécurité

Le tableau suivant présente les paramètres de confirmation de l'identité de l'émetteur.

Confirmation de l'identité de l'émetteur | Description
Non requis | Sélectionnez cette option si vous souhaitez que la planification XLANG soit en mesure de recevoir un message sans connaître l'identité de l'émetteur.
Facultatif | Sélectionnez cette option si vous souhaitez que le moteur de XLANG Scheduler identifie l'émetteur lorsque le composant reçoit un message, si cette information est disponible.
Requis | Sélectionnez cette option si vous ne souhaitez pas que le moteur de XLANG Scheduler reçoive de message, sauf s'il peut identifier l'expéditeur.

Zone de prise en charge des transactions

Le tableau ci-dessous présente les paramètres de prise en charge des transactions.

Prise en charge des transactions | Description
Désactivé | Ceci convient pour tous les composants non COM+. Cette option indique que le composant ignore la gestion des transactions COM.
Non pris en charge | Ceci est valable uniquement si le script est installé en tant que composant COM+. Cette option indique que le composant ne va pas participer à une transaction, ou propager les transactions d'autres composants.
Pris en charge | Ceci est valable uniquement si le script est installé en tant que composant COM+. Cette option indique que si une transaction est associée à un port auquel le composant est lié, le composant est inclus dans la transaction. Sinon, le composant n'a pas de transaction.
Requis | Ceci est valable uniquement si le script est installé en tant que composant COM+. Cette option indique que si une transaction est associée à un port auquel le composant est lié, le composant est inclus dans la transaction. S'il n'y a pas de transaction associée au port auquel le composant est lié, une nouvelle transaction est créée pour le composant.
Requiert une nouvelle | Ceci est valable uniquement si le script est installé en tant que composant COM+. Ceci indique qu'une nouvelle transaction est toujours créée pour le composant.

Zone de gestion d'erreur

Dans la zone de gestion d'erreur, activez la case à cocher Abandonner la transaction si la méthode renvoie un échec de HRESULT si vous voulez que le moteur de XLANG Scheduler démarre un processus d'abandon lorsqu'une erreur est renvoyée d'une méthode dans un composant. Cette option doit être sélectionnée pour le moteur de XLANG Scheduler si vous voulez utiliser les pages En cas d'échec de Transaction et Compensation pour Transaction. Si cette option n'est pas sélectionnée, les processus de récupération d'erreur définis sur ces pages ne seront pas exécutés.

Important

  • Lorsque vous utilisez des composants de script Windows, ils doivent respecter les règles suivantes :
    • Les déclarations d'arguments doivent être classées par référence et non par valeur.

    • Les sous-routines Visual Basic Scripting ne sont pas prises en charge. Seules les fonctions sont prises en charge.

    • Vous ne pouvez pas utiliser plusieurs composants dans un seul fichier .wsc.

Remarques

  • Lorsqu'une action communique avec un port lié à un composant de script et que la méthode spécifiée n'existe pas dans le composant de script, l'instance de planification XLANG échoue avec une entrée de journal d'événements.

  • Les composants de script qui ont été exécutés par le moteur de XLANG Scheduler ne peuvent pas être modifiés avant que le moteur de XLANG Scheduler et Windows Script Host soient arrêtés.

Voir aussi

Ports statiques et dynamiques

Communication synchrone et asynchrone

Utilisation de la forme Échanges BizTalk

Utilisation de la forme Composant COM

Utilisation de la forme Message Queuing

Utilisation de l'Assistant Communication de méthodes


Utilisation de la forme Message Queuing

La forme Message Queuing permet à une planification XLANG de communiquer avec une autre planification XLANG (ou avec une application), de manière librement couplée, à l'aide d'une file d'attente. Pour permettre la communication entre des planifications XLANG et des applications, les messages sont placés dans une file d'attente, puis lus. Une seule planification XLANG peut utiliser plusieurs ports qui sont liés à la forme Message Queuing.

Lorsqu'un port est lié à la forme Message Queuing, il est également lié à une file d'attente de messages. Le port peut être lié à une file d'attente nommée ou à une file d'attente par instance. Si un port est lié à une file d'attente par instance, une file d'attente unique est créée et utilisée pour chaque instance de cette planification XLANG. Les files d'attente par instance constituent une solution aisée pour une planification XLANG dans le but d'obtenir une file d'attente séparée pour chaque instance de planification XLANG.

Lorsqu'une action est connectée à un port lié à une file d'attente de messages, le message envoyé ou reçu par l'action doit être défini. Plusieurs types de messages étant stockés dans une file d'attente, le type du message aide à identifier le type de message qui doit être reçu par l'action. Lors d'une action Envoi, le type du message est indiqué sur la propriété d'étiquette du message au moment de son écriture dans la file d'attente.

La forme Message Queuing représente le service Message Queuing qui est utilisé pour envoyer ou recevoir des messages. Pour recevoir un message, le moteur de XLANG Scheduler doit connaître le nom de la file d'attente utilisée ainsi que le nom de l'élément racine du schéma XML contenu dans ce message. Pour envoyer un message, le moteur de XLANG Scheduler doit connaître le nom de la file d'attente utilisée pour la transmission des messages.

Si vous configurez une instance de planification XLANG de manière à utiliser Message Queuing pour la réception des messages, vous pouvez utiliser l'Assistant Communication XML pour spécifier un format de destination de type XML ou chaîne.

Pour créer une nouvelle liaison Message Queuing, déplacez la forme Message Queuing depuis le stencil Implémentation vers la page de conception du Concepteur d'Orchestration BizTalk, à droite de la barre de séparation. Pour modifier une implémentation Message Queuing existante, cliquez à l'aide du bouton droit sur la forme Message Queuing, puis cliquez sur Modifier les propriétés. Ces deux actions provoquent le démarrage de l'Assistant Liaison de Message Queuing. La liaison correspond au processus consistant à spécifier la technologie d'implémentation d'un port. L'Assistant Liaison de Message Queuing comprend les pages suivantes :

Assistant Liaison de Message Queuing

La page Assistant Liaison de Message Queuing vous permet de créer et de nommer un port pour lequel vous voulez définir une implémentation, ou de choisir un port existant non lié.

Informations sur la file d'attente statique ou dynamique

La page Informations sur la file d'attente statique ou dynamique permet de spécifier si la file d'attente des messages sera définie au moment de la conception ou de l'exécution. Choisissez l'une des options suivantes :

  • Choisissez File d'attente statique si vous pouvez fournir les informations associées à la file d'attente au moment de la conception.

  • Choisissez File d'attente dynamique si vous voulez que le moteur de XLANG Scheduler reçoive ces informations depuis une source externe au moment de l'exécution afin de déterminer le nom de la file d'attente.

Informations sur la file d'attente

La page Informations sur la file d'attente vous permet de créer une nouvelle file d'attente ou de spécifier une file d'attente existante. Choisissez l'une des options suivantes :

  • Choisissez Créer une nouvelle file d'attente pour chaque instance si vous voulez que le moteur de XLANG Scheduler crée une file d'attente pour chaque instance de planification XLANG.

  • Choisissez Utiliser une file d'attente connue pour toutes les instances si vous voulez que le moteur de XLANG Scheduler utilise une file d'attente connue.

Propriétés avancées du port

La page Propriétés avancées du port vous permet de configurer la sécurité et de choisir si vous voulez ou non activer la prise en charge des transactions. Vous pouvez utiliser la forme Message Queuing pour requérir des informations utilisateur authentifiées pour les messages reçus.

Zone Sécurité

Le tableau suivant présente les paramètres de confirmation de l'identité de l'émetteur.

Confirmation de l'identité de l'émetteur | Description
Non requis | Sélectionnez cette option si vous souhaitez que la planification XLANG soit en mesure de recevoir un message sans connaître l'identité de l'émetteur.
Facultatif | Sélectionnez cette option si vous souhaitez que le moteur de XLANG Scheduler identifie l'émetteur lorsque le composant reçoit un message, si cette information est disponible.
Requis | Sélectionnez cette option si vous ne souhaitez pas que le moteur de XLANG Scheduler reçoive de message, sauf s'il peut identifier l'expéditeur.

Vous pouvez également activer ou désactiver la case à cocher Utiliser un groupe Windows ou un nom d'utilisateur pour contrôler la file d'attente. Si vous activez cette case à cocher, tapez le nom de l'utilisateur ou du groupe autorisé à écrire des messages dans la file d'attente. Cette option est disponible uniquement lorsque vous utilisez une file d'attente statique.

Zone de prise en charge des transactions

Dans la zone de prise en charge des transactions, activez la case à cocher Des transactions sont requises avec cette file d'attente pour activer la prise en charge des transactions.

Remarques

  • À l'heure actuelle, le format des noms pris en charge ne permet pas l'activation de l'accès distant à une file d'attente sur un autre ordinateur. Utilisez les files d'attente publiques à la place des files d'attente privées lorsqu'une planification XLANG communique avec une application sur un ordinateur distant.

  • Lorsqu'une action communique avec un port lié à Message Queuing et que la file d'attente spécifiée pour la liaison n'existe pas, l'instance de planification XLANG échoue avec une entrée de journal d'événements.

  • Il est important que le moteur de XLANG Scheduler soit capable de déterminer si une file d'attente est transactionnelle ou non. Si une file d'attente se trouve dans un contexte transactionnel et qu'un message est envoyé à la file d'attente, le moteur de XLANG Scheduler doit savoir si la transaction doit être utilisée pour communiquer avec la file d'attente. Si la liaison du port est configurée avec la case à cocher Des transactions sont requises avec cette file d'attente activée, le moteur de XLANG Scheduler fera échouer la planification XLANG s'il est indiqué au moment de l'exécution que la file d'attente n'est pas transactionnelle.

Voir aussi

Ports statiques et dynamiques

Communication synchrone et asynchrone

Utilisation de la forme Échanges BizTalk

Utilisation de la forme Composant COM

Utilisation de la forme Composant de script

Utilisation de l'Assistant Communication XML


Utilisation de la forme Échanges BizTalk

La forme Échanges BizTalk représente les services d'échanges BizTalk utilisés pour l'échange des messages entre les services d'orchestration BizTalk Server et les services d'échanges BizTalk. Pour recevoir un message, le moteur de XLANG Scheduler a besoin de connaître l'adresse URL HTTP utilisée par le service d'échanges BizTalk pour la réception des documents, le nom du canal et le type de message de la définition de document sortant. La réception de documents pour l'activation de la planification XLANG ne nécessite que le type de message de la définition du document. Pour envoyer un message, le moteur de XLANG Scheduler doit connaître le nom du canal et le type de message de la définition du document sortant. Pour plus d'informations sur l'échange de messages entre les services d'orchestration BizTalk Server et les services d'échanges BizTalk, voir Intégration des services BizTalk.

Important

  • Si vous configurez un port dans le but d'activer une nouvelle planification XLANG lors de l'arrivée d'un message, vous devez respecter les restrictions suivantes :
    • Un seul port d'une planification peut être utilisé pour activer la planification XLANG lors de l'arrivée du message.

    • Une seule action peut être reçue via ce port.

    • Cette action unique ne peut pas se trouver dans le corps d'une boucle.

    • Vous ne pouvez pas tracer de connexion de flux de données depuis la référence de port correspondant à ce port vers tout autre message de la planification.

Pour créer une nouvelle liaison d'Échanges BizTalk, déplacez la forme Échanges BizTalk depuis le stencil Implémentation vers la page de conception du Concepteur d'Orchestration BizTalk, à droite de la barre de séparation. Pour modifier une implémentation d'Échanges BizTalk existante, cliquez à l'aide du bouton droit sur la forme Échanges BizTalk, puis cliquez sur Modifier les propriétés. Ces deux actions provoquent le démarrage de l'Assistant Liaison d'Échanges BizTalk. La liaison correspond au processus consistant à spécifier la technologie d'implémentation d'un port. L'Assistant Liaison d'Échanges BizTalk se compose des pages suivantes :

Assistant Liaison d'Échanges BizTalk

La page Assistant Liaison d'Échanges BizTalk vous permet de créer et de nommer un port pour lequel vous voulez définir une implémentation, ou de choisir un port existant non lié.

Direction de la communication

La page Direction de la communication vous permet de spécifier si vous voulez configurer le port d'échanges pour l'envoi ou la réception de messages.

Communication du canal statique ou dynamique

La page Informations sur le canal statique ou dynamique apparaît uniquement si vous choisissez Envoyer sur la page Assistant Liaison d'Échanges BizTalk. La page Informations sur le canal statique ou dynamique vous permet de spécifier si vous voulez que le moteur de XLANG Scheduler utilise un canal statique qui sera défini au moment de la conception ou un canal dynamique qui sera défini lors de l'exécution.

Informations sur l'activation de la planification XLANG

La page Informations sur l'activation de la planification XLANG vous permet de spécifier si une instance de planification XLANG sera activée lors de cette action de réception. Si vous choisissez Oui, l'exécution de l'Assistant Liaison d'Échanges BizTalk se termine. Si vous choisissez Non, la page Informations sur le canal apparaît.

Informations concernant le canal

La page Informations sur le canal vous permet d'indiquer le nom du canal, ainsi que l'adresse URL HTTP utilisée par le service d'échanges BizTalk pour la réception des documents.

Remarques

  • Lorsqu'une action communique avec un port lié à Échanges BizTalk et que le canal spécifié pour la liaison n'existe pas, l'instance de planification XLANG échoue avec une entrée de journal d'événements.

  • Le fait d'inclure des liaisons distinctes d'échanges BizTalk dans une transaction unique peut se traduire par une condition de verrouillage qui provoque l'échec de la transaction.

  • Les événements Action associés aux messages traités par une planification XLANG et qui sont soit envoyés, soit reçus des services d'échanges BizTalk, peuvent être tracés dans la base de données de suivi. Pour plus d'informations, voir Suivi des événements de planification XLANG dans la base de données de suivi.

Voir aussi

Ports statiques et dynamiques

Communication synchrone et asynchrone

Utilisation de la forme Composant COM

Utilisation de la forme Message Queuing

Utilisation de la forme Composant de script

Utilisation de l'Assistant Communication XML


Communication synchrone et asynchrone

Toutes les communications vers une implémentation de composant COM ou de script sont synchrones. Pour créer un flux de communication vers un port utilisant une implémentation de composant COM ou de script, vous devez utiliser l'Assistant Communication de méthodes.

Toutes les communications vers un port non lié ou vers une implémentation Message Queuing ou Échanges BizTalk sont asynchrones. Pour créer un flux de communication vers un port utilisant une implémentation Message Queuing ou Échanges BizTalk, ou pour créer un flux de communication vers un port non lié, vous devez utiliser l'Assistant Communication XML.

L'illustration et le texte ci-dessous décrivent les opérations effectuées par une planification XLANG pour chacune des quatre actions de communication possibles.

Présentation de la communication synchrone et asynchrone

  1. Action de réception synchrone
    1. La planification XLANG attend qu'une autre application envoie une requête de méthode et instancie un composant.

    2. La planification intercepte la requête de méthode.

    3. La planification attend que le composant renvoie la réponse de la méthode.

    4. La planification intercepte la réponse de la méthode.

    5. La planification passe à l'action suivante dans le flux des processus professionnels.
  2. Action d'envoi synchrone
    1. La planification XLANG initie la requête de méthode et instancie le composant.

    2. La planification attend que le composant renvoie la réponse de la méthode.

    3. La planification reçoit la réponse de la méthode.

    4. La planification passe à l'action suivante dans le flux des processus professionnels.
  3. Action de réception asynchrone
    1. La planification XLANG attend qu'une autre application envoie un message vers une file d'attente de messages ou vers un canal d'Échanges BizTalk.

    2. La planification XLANG reçoit le message depuis la file d'attente de messages ou le canal.

    3. La planification passe à l'action suivante dans le flux des processus professionnels.
  4. Action d'envoi asynchrone
    1. La planification XLANG envoie un message vers une file d'attente de messages ou vers un canal d'Échanges BizTalk.

    2. La planification passe à l'action suivante dans le flux des processus professionnels.

    3. Une autre application reçoit le message depuis la file d'attente de messages ou le canal d'Échanges BizTalk.

Remarques

  • Un cas spécial peut se présenter pour l'action de réception synchrone. Si vous choisissez Aucune instanciation dans l'Assistant Liaison de composants COM ou dans l'Assistant Liaison de composants de script, le composant n'est pas instancié et aucun code pour l'appel de méthode n'est exécuté. Au lieu de cela, lorsque la planification XLANG intercepte les informations de requête de méthode, elle renvoie ces informations en tant que réponse. L'appel de méthode est évité. Pour plus d'informations sur les ports statiques et dynamiques, ainsi que sur l'Assistant Liaison de composants COM et l'Assistant Liaison de composants de script, reportez-vous aux rubriques suivantes :
    • Ports statiques et dynamiques

    • Implémentation de ports

    • Utilisation de la forme Composant COM

    • Utilisation de la forme Composant de script
  • Les événements Action associés aux messages traités par une planification XLANG et qui sont soit envoyés, soit reçus des services d'échanges BizTalk, peuvent être tracés dans la base de données de suivi. Pour plus d'informations, voir Suivi des événements de planification XLANG dans la base de données de suivi.

Cette section contient des informations sur les rubriques suivantes :

  • Utilisation de l'Assistant Communication de méthodes

  • Communication synchrone

  • Utilisation de l'Assistant Communication XML

  • Communication asynchrone

Voir aussi

Implémentation de ports

Ports statiques et dynamiques

Utilisation de la forme Composant COM

Utilisation de la forme Composant de script


Utilisation de l'Assistant Communication de méthodes

Sur les pages Processus professionnel, Compensation pour Transaction et En cas d'échec de Transaction, vous pouvez utiliser l'Assistant Communication de méthodes pour définir le flux des messages entre une forme Action et une forme Composant COM ou une forme Composant script. Lors de l'envoi d'un message, la planification XLANG appelle la méthode avec le message _in, puis attend de recevoir le message _out du composant. Si un message doit être reçu, la planification XLANG attend qu'une autre application envoie le message _in à la méthode (en appelant une méthode sur le port), puis attend que le message _out soit renvoyé du composant vers l'autre application.

Remarques

  • Pour les programmeurs en Visual Basic, les paramètres ByVal n'apparaissent que dans le message _in. Tous les autres paramètres apparaissent à la fois dans le message _in et le message _out.

  • Pour les programmeurs en C, les paramètres IN apparaissent dans le message _in, les paramètres OUT apparaissent dans le message _out et les paramètres IN,OUT apparaissent dans les deux messages.

  • Pour les programmeurs en Visual Basic et en C, si un paramètre apparaît à la fois dans le message _in et le message _out, le message _in contient les données envoyées à la méthode tandis que le message _out contient les données renvoyées par la méthode.

Pour démarrer l'Assistant Communication de méthodes, faites glisser la poignée Poignée de contrôle de droite d'une forme Action vers le point de connexion Point de connexion sur un port lié à une forme Composant COM ou Composant script. L'Assistant Communication de méthodes comprend les pages suivantes :

Assistant Communication de méthodes

Sur la page Assistant Communication de méthodes, vous pouvez spécifier si le moteur de XLANG Scheduler appelle une méthode ou attend un appel de méthode. Si vous spécifiez l'attente d'un appel de méthode par le moteur de XLANG Scheduler, vous pouvez définir un temps de latence en secondes qui indique le délai pendant lequel le moteur de XLANG Scheduler devra probablement attendre avant l'arrivée d'un message. Si cette valeur est inférieure ou égale à 180 secondes, l'instance de planification XLANG ne sera jamais mise en attente dans la base de données de persistance. Si cette valeur est supérieure à 180 secondes, l'instance de planification XLANG sera immédiatement mise en attente dans la base de données de persistance. Par défaut, le temps de latence est égal à zéro, indiquant que le message est supposé arriver immédiatement.

Si une instance de planification XLANG est réalimentée pour une raison autre que l'arrivée d'un message attendu par une action (et si l'instance de planification XLANG entre ensuite dans un état de repos), la valeur de latence indiquée est utilisée pour déterminer si l'instance de planification doit être immédiatement mise en attente. Par exemple, ceci peut se produire si une branche simultanée reçoit un message qu'elle attendait ou si le redémarrage d'un ordinateur entraîne la réalimentation de toutes les instances de planification XLANG. D ans ce cas, la valeur de latence est évaluée à partir du moment où l'instance de planification XLANG entre dans l'état de repos. Si le délai entre le début de la période d'attente du moteur de XLANG Scheduler (combiné à la valeur de latence) est supérieur à 180 secondes à partir du moment où celui-ci entre en état de repos après la réalimentation, l'instance de planification XLANG sera immédiatement mise en attente dans la base de données de persistance. Ceci peut se produire dans l'instance de planification XLANG longtemps après le début de la surveillance de l'arrivée d'un message par le moteur de XLANG Scheduler.

Informations sur le message

Sur la page Informations sur le message, vous pouvez spécifier si un nouveau message ou une référence à un message existant doit être créé. Si vous spécifiez qu'une référence à un message existant doit être créée, vous pouvez effectuer votre sélection dans une liste de messages précédemment créés et envoyés ou reçus de méthodes, et qui possèdent déjà des formes Message correspondantes. Si le message à utiliser ne figure pas dans la liste, spécifiez qu'un nouveau message doit être créé et définissez le flux de données pour le nouveau message.

Informations sur la spécification du message

La page Informations sur la spécification du message vous permet de sélectionner une spécification pour le message créé ou référencé à la page Informations sur le message.

Voir aussi

Communication asynchrone

Mise en attente et réalimentation

Persistance

Communication synchrone et asynchrone

Communication synchrone

Utilisation de l'Assistant Communication XML


Communication synchrone

Les seules méthodes disponibles pour la communication synchrone sont celles qui ont été sélectionnées pour l'implémentation du port. Les méthodes issues d'autres types d'implémentation de port ne peuvent pas être utilisées, tout comme les messages XML provenant de flux de communication asynchrone. Pour modifier les méthodes disponibles, vous devez réexécuter l'assistant de liaison approprié et sélectionner de nouvelles méthodes.

Les paramètres IN et OUT sont déterminés automatiquement par les spécifications des paramètres de la méthode choisie. Les deux listes de paramètres contiennent le nom et le type de données des paramètres. En plus des paramètres associés à la méthode, un message contient également certains champs système obligatoires. Un message synchrone contient toujours les champs système suivants :

  • __Sender__

    Ce champ système est un paramètre IN obligatoire pour la méthode utilisée dans un message synchrone.

  • __Status__

    Ce champ système est un paramètre OUT obligatoire pour la méthode utilisée dans un message synchrone.

Messages synchrones

Lorsque vous créez une communication synchrone, un Message est créé dans la page Données. Le Message correspond à la méthode et aux paramètres utilisés dans le flux de communication. Le Message contient tous les paramètres IN et OUT pour la méthode.

Une méthode peut ne contenir aucun paramètre ; en revanche, le Message contient toujours les champs système requis. L'exemple ci-après illustre le schéma du Message :

Method name_inMethod name_in
__Sender__   string__Expéditeur__   chaîne
   parameter 1   Data type 1paramètre 1   Type de données 1
   parameter 2   Data type 2paramètre 2   Type de données 2
   parameter n   Data type nparamètre n   Type de données n
Method name_outMethod name_out
__Status__   string__État__   chaîne
   Parameter 1   Data type 1Paramètre 1   Type de données 1
   Parameter 2   Data type 2Paramètre 2   Type de données 2
   Parameter n   Data type nParamètre n   Type de données n

L'illustration suivante indique une paire de messages synchrones contenant les champs système __Sender__ et __Status__, ainsi que les paramètres IN et OUT pour l'appel de méthode.

Une paire de messages synchrones contenant un appel de méthode et ses valeurs associées.

Voir aussi

Mise en attente et réalimentation

Persistance

Communication synchrone et asynchrone

Utilisation de l'Assistant Communication de méthodes


Utilisation de l'Assistant Communication XML

Sur les pages Processus professionnel, Compensation pour Transaction et En cas d'échec de Transaction, vous pouvez utiliser l'Assistant Communication XML pour définir le flux des messages entre une forme Action et une forme Message Queuing, une forme Échanges BizTalk ou un port non lié. Pour démarrer l'Assistant Communication XML, faites glisser la poignée ( Poignée de contrôle) de droite d'une forme Action vers le point de connexion ( Point de connexion) sur un port non lié, ou sur un port lié à une forme Message Queuing ou Échanges BizTalk. L'Assistant Communication XML comprend les pages suivantes :

Assistant Communication XML

Sur la page Assistant Communication XML, vous pouvez spécifier si le port envoie un message vers une action, ou reçoit un message depuis une action. Si vous créez une communication entre une action et un port implémenté à l'aide de la forme Échanges BizTalk, la direction de la communication est déjà configurée. Cela se produit lorsque l'Assistant Liaison d'Échanges BizTalk a été utilisé pour créer la liaison du port.

Si le port est configuré pour la réception des messages, vous pouvez définir un temps de latence en secondes qui indique le délai pendant lequel le moteur de XLANG Scheduler attendra l'arrivée d'un message. Si cette valeur est inférieure ou égale à 180 secondes, l'instance de planification XLANG ne sera jamais mise en attente dans la base de données de persistance. Si cette valeur est supérieure à 180 secondes, l'instance de planification XLANG sera immédiatement mise en attente dans la base de données de persistance. Par défaut, le temps de latence est égal à zéro, indiquant que le message est supposé arriver immédiatement.

Si une instance de planification XLANG est réalimentée pour une raison autre que l'arrivée d'un message attendu par une action (et si l'instance de planification XLANG entre ensuite dans un état de repos), la valeur de latence indiquée est utilisée pour déterminer si l'instance de planification doit être immédiatement mise en attente. Par exemple, ceci peut se produire si une branche simultanée reçoit un message qu'elle attendait ou si le redémarrage d'un ordinateur entraîne la réalimentation de toutes les instances de planification XLANG. D ans ce cas, la valeur de latence est évaluée à partir du moment où l'instance de planification XLANG entre dans l'état de repos. Si le délai entre le début de la période d'attente du moteur de XLANG Scheduler (combiné à la valeur de latence) est supérieur à 180 secondes à partir du moment où celui-ci entre en état de repos après la réalimentation, l'instance de planification XLANG sera immédiatement mise en attente dans la base de données de persistance. Ceci peut se produire dans l'instance de planification XLANG longtemps après le début de la surveillance de l'arrivée d'un message par le moteur de XLANG Scheduler.

Informations sur le message

Sur la page Informations sur le message, vous pouvez spécifier si un nouveau message ou une référence à un message existant doit être créé. Si vous spécifiez la création d'un nouveau message, définissez le flux de données de celui-ci. Pour plus d'informations sur les flux de données, voir Gestion des données. Vous pouvez utiliser la propriété Étiquette d'un message pour optimiser les performances d'une planification de la manière suivante :

  • Si la propriété Étiquette du message est identique à l'élément racine XML spécifié lors de la création d'une nouvelle forme Message, le moteur de XLANG Scheduler récupère le message.

  • Si la propriété Étiquette ne correspond pas à la valeur fournie par l'élément racine XML, le moteur de XLANG Scheduler examine le contenu du message. Si la valeur de l'élément racine XML spécifié lors de la création d'une nouvelle forme Message correspond à l'élément racine XML réel, le moteur de XLANG Scheduler récupère le message. Sinon, le moteur de XLANG Scheduler laisse le message dans la file d'attente et inspecte le message suivant.

Informations sur l'interprétation XML

La page Informations sur l'interprétation XML vous permet de spécifier si vous voulez que les messages soient envoyés vers ou reçus de la file d'attente sous la forme de données formatées XML ou de chaînes de texte. Si vous spécifiez l'envoi des messages sous la forme de chaînes de texte, le wrapper XML standard du moteur de XLANG Scheduler est éliminé des messages.

Informations sur les types de messages

La page Informations sur les types de messages vous permet de spécifier l'étiquette que le moteur de XLANG Scheduler doit utiliser pour identifier les messages du type défini. Le texte que vous tapez va permettre d'identifier les messages corrects reçus de la file d'attente. Si vous sélectionnez le même type de message pour deux messages différents, assurez-vous que les noms des champs, les types des champs et les requêtes XPath correspondent exactement. Le moteur de XLANG Scheduler génère une erreur en cas d'incohérence entre les messages de même type sur un port donné. Dans la zone Type du message de la page Informations sur les types de message, tapez une désignation d'étiquette pour le message. Le moteur de XLANG Scheduler effectue les procédures suivantes, en fonction des informations fournies :

  • Le moteur de XLANG Scheduler essaie de faire correspondre les informations sur le type de message avec l'étiquette du message dans la file d'attente. Si le type de message ne correspond pas, le message est ignoré, et le moteur de XLANG Scheduler continue à regarder si les nouveaux messages entrants peuvent correspondre. Ce système permet à plusieurs actions de recevoir plusieurs types de messages depuis une même file d'attente de messages.

  • Lorsque vous utilisez la forme Échanges BizTalk pour l'activation, le moteur de XLANG Scheduler utilise le nom de la définition du document sortant du canal d'activation comme étiquette du message lorsqu'il transmet le message à la file d'attente. L'action qui utilisera ce message doit également utiliser le nom de la définition du document sortant du canal d'activation pour son type de message.

  • Si le message dans la file d'attente est au format XML, le moteur de XLANG Scheduler essaie de faire correspondre les informations sur le type de message avec l'élément racine XML du message de la file d'attente.

Vous pouvez également activer la case à cocher Utiliser l'ID d'instance comme étiquette de message afin d'utiliser l'ID d'instance — l'identificateur global unique (GUID) de l'instance de planification — comme étiquette du message. Ceci offre un système de corrélation utile si vous souhaitez utiliser une seule file d'attente pour gérer les messages de toutes les instances d'une planification. Pour plus d'informations, reportez-vous à la section sur la corrélation de l'échange de messages avec des instances de planification XLANG dans Gestion des instances.

Informations sur la spécification du message

La page Informations sur la spécification du message vous permet de taper le chemin d'accès du fichier de spécification du message (.xml) à utiliser, ou de parcourir les fichiers jusqu'au fichier choisi. Si la spécification du message sélectionnée est une spécification créée à l'aide de l'Éditeur BizTalk, vous pouvez ajouter des champs à l'étendue des données du moteur de XLANG Scheduler. Pour valider la spécification des messages, sélectionnez la case à cocher Valider les messages par rapport à la spécification. Cliquez sur Parcourir sur la page Informations sur la spécification du message pour afficher la boîte de dialogue Rechercher une spécification. Utilisez la boîte de dialogue Rechercher une spécification pour trouver la spécification à utiliser.

Si vous n'avez sélectionné aucune spécification, cliquez sur Créer sur la page Informations sur la spécification du message pour ouvrir l'Éditeur BizTalk. Si vous avez déjà sélectionné une spécification, cliquez sur Modifier sur la page Informations sur la spécification du message pour ouvrir l'Éditeur BizTalk avec la spécification sélectionnée.

Cliquez sur Ajouter sur la page Informations sur la spécification du message pour afficher la boîte de dialogue Sélection d'un champ. Dans l'arborescence Sélectionner un nœud de la boîte de dialogue Sélection d'un champ, vous pouvez développer tous les nœuds souhaités, puis cliquer sur le champ à ajouter. Dans la boîte de dialogue Sélection d'un champ, vous pouvez modifier le nom et le chemin d'accès au nœud des champs à ajouter à la forme de message pour le port sélectionné. Les champs de type de données sont affichés mais ne peuvent pas être modifiés.

Remarques

  • La validation est disponible uniquement lors de la réception d'un message. Lorsqu'un message est envoyé, la case à cocher de validation est ignorée.

  • Les types de données XML, tels que l'énumération et le numéro qui ne sont pas dotés de types Automation OLE correspondants, sont convertis au type String dans le Concepteur d'Orchestration BizTalk et XLANG. La validation d'un champ de ce type s'effectuera en tant que chaîne. Voir Types de données de champs pour connaître la liste complète des types Automation OLE.

  • Lorsque vous cliquez sur un champ dans l'arborescence Sélectionner un nœud, le nom du champ s'ajoute automatiquement à la zone Nom de champ.

  • Lorsque vous cliquez sur un champ dans l'arborescence Sélectionner un nœud, le chemin d'accès au nœud vers ce champ s'ajoute automatiquement à la zone Chemin d'accès au nœud.

  • Vous pouvez uniquement sélectionner les champs à partir d'un schéma créé ou importé dans l'Éditeur BizTalk lorsque vous ajoutez des champs de message.

  • La modification manuelle du chemin d'accès au nœud est utile lorsque vous voulez extraire des données spécifiques d'un champ. Par exemple, si le champ contient un tableau, il se peut que vous vouliez extraire juste un élément du tableau et non le tableau entier. Toutefois, nous vous recommandons de limiter la modification manuelle du chemin d'accès au nœud pour votre spécification de message.

  • Vous ne pouvez pas sélectionner un nœud à ajouter à la liste Champs de message. Seuls les champs peuvent être sélectionnés. Un champ peut également être référencé comme un nœud racine. Par exemple, vous ne pouvez pas sélectionner les nœuds Vendeur et Adresse car ils contiennent des nœuds feuille. Vous pouvez, en revanche, sélectionner les champs Nom et Adresse car ils ne contiennent pas de nœuds supplémentaires.

  • Lors de l'attente de la réception d'un message depuis une file d'attente de messages, certains problèmes (tels que des messages XML non valides ou une authentification insuffisante) provoqueront la création dynamique d'une file d'attente de lettres mortes. La file d'attente de lettres mortes est spécifique à une application COM+. Elle porte le nom de .\private$\ApplicationName.DeadLetter. Par exemple, si un message au format XML non valide arrive dans la file d'attente et que vous avez spécifié sur la page Informations sur l'interprétation XML de l'Assistant Communication XML que le moteur de XLANG Scheduler attend des messages XML de la file d'attente, tous les messages XML non valides seront déplacés vers .\private$\ApplicationName.DeadLetter.

  • Si vous concevez deux planifications XLANG différentes de sorte qu'elles reçoivent des messages distincts de la même file d'attente, il est possible qu'un message soit traité par la mauvaise instance de planification XLANG. Pour éviter ce problème, utilisez une file d'attente de messages pour chaque type de message reçu par une instance de planification XLANG.

Voir aussi

Communication asynchrone

Communication synchrone et asynchrone

Communication synchrone

Utilisation de l'Assistant Communication de méthodes


Communication asynchrone

Un message asynchrone est placé dans une file d'attente de messages ou un canal d'Échanges BizTalk, puis la planification XLANG se poursuit. Aucune réponse n'est attendue.

Les seuls messages disponibles pour une communication asynchrone sont les messages XML. Tous les messages XML peuvent être utilisés et spécifiés pour plusieurs ports. Vous ne pouvez utiliser aucune des paires de messages synchrones créées à l'aide de l'Assistant Communication de méthodes.

Messages asynchrones

Lorsque vous créez une communication asynchrone, un message est créé dans la page Données. Le message correspond aux informations envoyées ou reçues dans le flux des communications. Le message contient les champs système requis ainsi que tous les champs de spécifications supplémentaires souhaités.

L'exemple ci-après illustre le schéma du Message :

Message nameNom du message
__Sender__   string__Expéditeur__   chaîne
Document   stringDocument   string
   Field 1   Data type 1Champ 1   Type de données 1
   Field 2   Data type 2Champ 2   Type de données 2
   Field n   Data type nChamp n   Type de données n

L'illustration suivante présente un message nommé Message_1. Les champs système __Sender__ et Document sont fournis automatiquement et sont présents dans tous les messages asynchrones. Ce message contient également deux champs de spécifications sélectionnés par l'utilisateur.

Un message contenant deux champs ajoutés par le système et deux champs de spécification sélectionnés par l'utilisateur

Pour ajouter un champ de spécification, vous pouvez utiliser la boîte de dialogue Sélection d'un champ de l'Assistant Communication XML. Dans la boîte de dialogue Sélection d'un champ, sélectionnez un champ de spécification en cliquant sur un nœud de l'arborescence Sélectionner un nœud. Lorsque vous cliquez sur un nœud, le chemin d'accès au nœud est ajouté dans la zone Chemin d'accès au nœud. Vous devez sélectionner un nœud feuille. Un nœud feuille est un nœud sans enfant. Dans l'illustration suivante, le nœud Nom est un nœud feuille ; cependant, le nœud Adresse n'est pas un nœud feuille.

Un chemin d'accès de nœud porte également le nom de XPath. Vous pouvez utiliser le chemin d'accès du nœud tel qu'il est sélectionné, ou taper d'autres critères pour le chemin d'accès. Par exemple, si vous sélectionnez un nœud contenant un tableau, il se peut que vous vouliez indiquer un index spécifique dans le tableau à récupérer, plutôt que de récupérer la totalité du tableau.

Remarque

  • Si vous choisissez d'envoyer ou de recevoir un message XML en tant que chaîne, la forme Message créée dans la page Données pour ce message contient un champ nommé StringData, et vous ne pouvez pas ajouter de champs de spécification à ce message.

L'illustration suivante présente la boîte de dialogue Sélection d'un champ.

Boîte de dialogue Sélection d'un champ.

Remarque

  • Pour plus d'informations sur la sélection des champs de spécification et l'utilisation des chemins d'accès aux nœuds, consultez les rubriques suivantes :
    • Création et validation de spécifications

    • Champs du chemin d'accès au nœud

    • Envoi ou réception de messages asynchrones

    • Utilisation de l'Assistant Communication XML

Voir aussi

Création et validation de spécifications

Mise en attente et réalimentation

Champs du chemin d'accès au nœud

Persistance

Envoi ou réception de messages asynchrones

Communication synchrone et asynchrone

Utilisation de l'Assistant Communication XML


Compilation des planifications XLANG

Lorsqu'un schéma de planification XLANG est terminé, vous pouvez le compiler en une planification XLANG exécutable. Avant de compiler le schéma, assurez-vous que le flux de données entre les messages a été défini sur la page de données. Une planification XLANG décrit le processus professionnel ainsi que la liaison de ce processus vers une technologie d'implémentation.

Le Concepteur d'Orchestration BizTalk est conçu pour vous fournir un maximum d'informations utiles en cas de problème lors de la compilation de votre planification XLANG. Lorsque le Concepteur d'Orchestration BizTalk rencontre une erreur, il affiche en surbrillance la forme contenant l'erreur, affiche un message d'erreur et annule la compilation de la planification XLANG.

Pendant la compilation, le Concepteur d'Orchestration BizTalk examine chaque forme et détermine si elle est complète et correcte. Le moteur de XLANG Scheduler traite la forme Début sur la page Processus professionnel en premier lieu, puis parcourt de manière récursive la totalité du schéma. Les erreurs rencontrées par le moteur de XLANG Scheduler se produisent généralement lorsque le processus professionnel atteint une forme profondément imbriquée. Pour rendre compte de l'erreur, le moteur de XLANG Scheduler établit un message d'erreur approprié. Puis, lorsque le moteur de XLANG Scheduler remonte la pile, chaque méthode peut concaténer son propre message d'erreur dans le message d'erreur d'origine. Si aucune méthode ne concatène un message d'erreur dans le message d'erreur d'origine, la méthode de compilation de niveau supérieur ajoute le message d'erreur générique suivant :

Échec de traitement de la planification XLANG.

La planification XLANG compilée contient un identificateur global unique (GUID) qui correspond à la propriété Identité XLANG de la forme Début. Cette identification peut être utilisée pour corréler une version du schéma de planification XLANG avec la planification XLANG qui l'a généré.

Remarque

  • Il est vivement recommandé de consulter la section Exécution des tâches du Concepteur d'Orchestration BizTalk pour obtenir des informations spécifiques sur l'utilisation du Concepteur d'Orchestration BizTalk en vue de la création de schémas de planification XLANG et de leur compilation en des planifications XLANG exécutables.

Voir aussi

Compilation et débogage de planifications XLANG

Compilation d'un schéma de planification XLANG dans une planification XLANG

Débogage des planifications XLANG


Débogage des planifications XLANG

L'Observateur d'événements XLANG est un outil qui vous permet de surveiller les instances de planification XLANG en cours d'exécution. Pour des informations spécifiques sur l'utilisation de l'Observateur d'événements XLANG, consultez le fichier Lisezmoi.htm associé. L'Observateur d'événements XLANG (XLANGMon.exe) et le fichier Lisezmoi installés par l'Assistant Installation de Microsoft BizTalk Server 2002 se trouvent dans le répertoire d'installation suivant : \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools.

L'Observateur d'événements XLANG inclut les fonctionnalités suivantes :

  • Il affiche le fonctionnement du moteur de XLANG Scheduler en temps réel.

  • Après l'énumération initiale des planifications en cours d'exécution, il surveille les événements.

  • L'Observateur d'événements XLANG peut être utilisé pour interrompre et arrêter les instances en cours d'exécution.

  • Il possède une interface utilisateur de type MDI (multiple-document interface) vous permettant d'afficher simultanément plusieurs traces d'instance.

  • Il peut surveiller simultanément des applications sélectionnées sur plusieurs ordinateurs.

  • Il offre des filtres d'enregistrement et d'affichage séparés.

Voir aussi

Compilation et débogage de planifications XLANG

Compilation des planifications XLANG

Surveillance de l'exécution des planifications XLANG

Messages d'erreur des services d'orchestration


Exécution des planifications XLANG

Lors de l'installation du Concepteur d'Orchestration BizTalk, diverses applications COM+ sont installées et configurées dans les Services de composants de Microsoft Windows 2000, notamment l'application COM+ XLANG Scheduler. Cette application héberge une instance par défaut du moteur de XLANG Scheduler. Chaque nouvelle application COM+ créée dans les services de composants possède un onglet XLANG dans la boîte de dialogue Propriétés. Avec l'onglet XLANG, vous pouvez permettre à la nouvelle application COM+ d'héberger le moteur de XLANG Scheduler. L'application COM+ spécifique dans laquelle une nouvelle planification XLANG va s'exécuter peut être déterminée via la syntaxe du moniker utilisé pour activer une instance d'une planification XLANG.

Le moteur de XLANG Scheduler contrôle l'activation, l'exécution, la mise en attente et la réalimentation des instances de planification XLANG en cours d'exécution. Pour activer une planification XLANG, vous pouvez créer une petite application qui transmet le moniker d'une planification XLANG au moteur de XLANG Scheduler. Le moteur de XLANG Scheduler effectue les actions au sein de la planification XLANG et poursuit la séquence du processus professionnel jusqu'à ce qu'il soit nécessaire de mettre en attente la planification XLANG. La mise en attente d'une planification XLANG a lieu lorsque le moteur de XLANG Scheduler prévoit d'attendre plus de trois minutes avant de recevoir un message. Lorsque le message arrive, le moteur de XLANG Scheduler réalimente l'instance de planification XLANG et poursuit les actions de la séquence du processus professionnel jusqu'à la fin de la planification ou jusqu'à ce que le moteur de XLANG Scheduler doive attendre un autre message. Pour prendre en charge la mise en attente, vous devez posséder une base de données de persistance configurée. La bibliothèque réseau recommandée est TCP/IP.

Pour afficher les informations des services de composants de Microsoft Windows 2000, effectuez la procédure suivante :

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Outils d'administration et sur Services de composants.

  2. Dans l'arborescence de la console, développez successivement Services de composants, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez avec le bouton droit sur une application COM+.

    La boîte de dialogue Propriétés s'affiche.

L'onglet XLANG de la boîte de dialogue Propriétés affiche les options suivantes :

  • Utiliser l'application comme l'hôte des instances de planification XLANG Si cette option est sélectionnée, l'application COM+ peut activer les instances des planifications XLANG. Pour diriger l'activation d'une instance de planification vers une application COM+ particulière, utilisez un formulaire de moniker incluant le nom de l'application. Sélectionnez cette option si vous voulez que l'application serve d'hôte au moteur de XLANG Scheduler.

  • Utiliser le DSN de fichier Cette zone vous permet de configurer Microsoft SQL Server pour la prise en charge de la mise en attente et de la réalimentation des processus professionnels longs :
    • Créer un DSN crée le nom de source de données (DSN) ODBC de l'application COM+ hébergeant le moteur de XLANG Scheduler. Un fichier DSN stocke les informations sur une connexion de base de données. Le fichier possède l'extension .dsn et est enregistré par défaut dans le répertoire \Program Files\Common Files\ODBC\Data Sources. Cliquez sur le bouton Créer un DSN pour démarrer l'Assistant DSN.

    • Configurer un DSN ouvre l'administrateur de source de données ODBC pour gérer la source de données des planifications XLANG dans cette application COM+.

    • Initialiser les tables crée les tables nécessaires à la prise en charge de la persistance dans la base de données SQL Server définie.

    Important

    • Le nom de source de données configuré dans la boîte de dialogue Propriétés de XLANG Scheduler doit être le même que celui de l'application COM+.
  • Arrêt contrôlé Cette zone vous permet de sélectionner un moyen valide d'arrêter les applications COM+ hébergeant les instances de planification XLANG :
    • Toutes les applications XLANG arrête l'ensemble des applications COM+ hébergeant des instances de planification XLANG en cours d'exécution.

    Remarque

    • Si vous avez sélectionné une application autre que l'application par défaut, l'option Cette application XLANG est affichée.
  • Redémarrer les applications XLANG en attente. Cette zone vous permet de gérer les applications XLANG en attente :
    • Toutes les applications XLANG réalimente l'ensemble des applications COM+ hébergeant des instances de planification XLANG et, si possible, poursuit leur exécution.

Important

  • Ne cliquez pas à l'aide du bouton droit sur l'application COM+ pour arrêter des instances en cours d'exécution d'une planification XLANG. Cela laisserait les composants COM chargés en mémoire au lieu de les décharger correctement. Au lieu de cela, utilisez la zone Arrêt contrôlé de l'onglet XLANG de la boîte de dialogue des propriétés de l'application COM+.

Remarques

  • Si vous utilisez le client pour les services Microsoft Windows 2000 Terminal Server pour initier une planification XLANG, l'application COM+ hébergeant le moteur de XLANG Scheduler doit posséder un nom d'utilisateur ou de groupe Windows 2000 valide. L'identité de l'application COM+ est définie dans la page Identité de la boîte de dialogue des propriétés de cette application. L'identité ne peut être interactive lorsque vous utilisez le moteur de XLANG Scheduler dans une session hébergée par les services Terminal Server.

  • Pour des informations spécifiques sur l'exécution d'une planification XLANG, voir Exécution d'une planification XLANG.

Cette section traite des rubriques suivantes :

  • Syntaxe du moniker

  • Création d'une application d'instanciation


Syntaxe du moniker

Les monikers sont utilisés pour créer de nouvelles instances de planification XLANG ou se référer à une instance de planification XLANG existante. Dans l'un ou l'autre cas, vous pouvez vous référer à un port spécifique de l'instance de planification. Les monikers déterminent quelle application COM+ va héberger le moteur de XLANG Scheduler.

Pour créer une nouvelle instance d'une planification XLANG, il faut transmettre un moniker pour la planification XLANG à l'application COM+. L'application COM+ transmet ensuite le moniker au service d'affectation de noms XLANG en vue de sa résolution et active l'instance de planification XLANG avec une instance du moteur de XLANG Scheduler. L'exemple de code ci-après illustre la syntaxe générale des monikers :

sked://[HostName][!GroupManager][/FilePath][/PortName]

Chaque segment de la syntaxe du moniker est facultatif, en fonction du type d'objet à instancier. Le tableau suivant présente chacun de ces segments.

Segment de la syntaxe du moniker | Description | Exemple
HostName | Nom d'hôte de l'ordinateur exécutant le moteur de XLANG Scheduler. Il s'agit également du gestionnaire du système XLANG. Si ce segment est omis, le nom de l'hôte local est utilisé par défaut. Ce nom ne respecte pas la casse. | sked:// sked://MyServer
GroupManager | Gestionnaire de groupe du moteur de XLANG Scheduler utilisé pour la gestion des instances de planification XLANG. Le nom du gestionnaire de groupe est identique à celui de l'application COM+ désignée comme hôte XLANG. Si ce segment est omis, le nom XLANG Scheduler est utilisé par défaut. Ce nom respecte la casse et peut comporter des espaces. | sked:/// sked://AnotherServer!/ sked://AnotherServer!MyGroup/
FilePath | Chemin d'accès vers un fichier de planification XLANG (.skx) à activer. Cette valeur ne respecte pas la casse. | sked://host1!MyGrp/C:\basic.skx sked:///C:\basic.skx
PortName | Nom d'un port lié à un composant COM ou Windows Script sur une planification XLANG. Ce nom respecte la casse. | sked:///C:\basiccom.skx/portA

La syntaxe du moniker permet de se référer à une instance de planification XLANG existante, de démarrer une planification XLANG ou d'établir un canal de communication avec un port particulier de la nouvelle instance de planification XLANG.

Les monikers qui se réfèrent à une instance de planification XLANG sont créés par le moteur de XLANG Scheduler et sont rendus disponibles par la création d'une connexion entre la forme Références du port et les messages envoyés par la planification XLANG. La forme exacte de la référence de port dépend de la technologie d'implémentation liée au port et du type de données du champ de message cible. Les ports liés à Message Queuing ou aux services d'échanges BizTalk ne peuvent être connectés qu'à des champs de type de données String. Le champ cible contient le nom de la file d'attente ou du point d'arrivée du message lié au port dans l'instance de planification XLANG actuelle.

Les ports liés à des composants COM peuvent être connectés à des champs de type de données String, Object ou Unknown. Si le champ cible est de type de données String, un moniker se référant à un port dans l'instance de planification XLANG actuelle est créé. Ce moniker est durable. Il peut être résolu à l'aide de la fonction GetObject et reste valide après un redémarrage du système. Si le champ cible est de type de données Object ou Unknown, une référence COM à l'instance du port est transmise à la forme Message. Si une telle référence est transmise à un composant externe, elle n'est plus valide après un redémarrage du système.

Le moniker permettant de référencer une instance de planification XLANG en cours d'exécution peut être obtenu de l'objet d'instance de planification XLANG, comme indiqué dans le code Microsoft Visual Basic suivant :

Dim oSchedule as IWFWorkflowInstance
Set oSchedule = GetObject("sked:///C:\temp\myschedule.skx")
dim sMoniker as string
sMoniker = oSchedule.FullyQualifiedName

Voir aussi

Création d'une application d'instanciation

Exécution des planifications XLANG


Création d'une application d'instanciation

Une application d'instanciation transmet un moniker pour le fichier de planification XLANG terminé au moteur de XLANG Scheduler en utilisant la fonction COM GetObject. Le code Microsoft Visual Basic ci-après présente une manière d'effectuer cette opération :

Dim objExecute As objectDim objExecute As object
Dim strURL as stringDim strURL as string

strURL = "sked:///c:\temp\myschedule.skx"strURL = "sked:///c:\temp\myschedule.skx"

' This instantiates an XLANG schedule and enables the XLANG Scheduler' This instantiates an XLANG schedule and enables the XLANG Scheduler
' Engine to execute the XLANG schedule.' Engine to execute the XLANG schedule.
Set objExecute = GetObject(strURL)Set objExecute = GetObject(strURL)

Si vous n'avez pas spécifié de port dans le moniker, la propriété Port de l'objet renvoyé par la fonction GetObject permet d'obtenir une référence vers un port qui est lié à un composant COM. De même, la propriété FullPortName permet d'obtenir le nom complet et permanent d'un port lié à une technologie d'implémentation.

Le code ci-après indique comment obtenir un proxy vers un port COM ou de script. Cet exemple de code est la suite de l'exemple précédent :

Dim oPort as ObjectDim oPort as Object
Set oPort = objExecute.Port("SchedulePortName")Set oPort = objExecute.Port("SchedulePortName")
Call oPort.ComponentMethodName(arg1,arg2,...argN)Call oPort.ComponentMethodName(arg1,arg2,...argN)

Remarque

  • Si le port est lié à un objet COM qui ne prend pas en charge une interface double, la variable oPort doit être déclarée avec la classe appropriée.

Voir aussi

Syntaxe du moniker

Exécution des planifications XLANG


Création de réserves de planifications XLANG

BizTalk Server 2002 ~ Conception des orchestrations BizTalk

Création d'une réserve de planifications XLANG

Vous pouvez mettre en réserve vos planifications pour utiliser vos ressources de manière efficace lorsque le trafic est important et lorsque de nombreuses instances de planification sont activées en même temps. BizTalk Server tire parti du regroupement d'objets COM et vous permet de limiter le nombre d'instances de planification actives. Vous pouvez définir les propriétés suivantes sur une réserve d'objets :

  • Vous pouvez définir le nombre maximal d'instances de planification d'une réserve. Lorsque ce nombre maximal est atteint, aucune autre instance de planification qui utilise cette réserve n'est créée avant la fin ou la mise en attente d'une planification. La valeur maximale par défaut est 25 instances.

  • Vous pouvez également définir la durée du délai d'attente d'une réserve. Il s'agit du nombre de secondes pendant lequel une instance de planification attend qu'un emplacement soit disponible dans sa réserve. La période de délai par défaut est de 30 000 millisecondes (30 secondes).

  • Vous pouvez optimiser les performances en définissant une taille de réserve minimale. Celle-ci détermine le nombre d'objets de réserve qui sont conservés en mémoire, afin qu'il ne soit pas nécessaire de les créer à la demande chaque fois qu'une instance de planification est activée dans cette réserve. La valeur minimale par défaut est un objet.

Il est possible que ces paramètres ne soient pas optimaux pour l'une ou plusieurs de vos réserves ; vous devez configurer les paramètres afin qu'ils soient aussi efficaces que possible en fonction de vos besoins. Par exemple, les planifications courtes pour lesquelles le trafic est important doivent généralement être configurées pour une exécution dans une réserve d'objets dont le nombre maximal d'instances est relativement élevé. Un nombre minimal relativement important peut également être utile ; si vous estimez que le trafic sera régulier, les résultats seront meilleurs lorsque plusieurs objets sont créés à l'avance. Dans ce cas, le délai d'attente doit être court et le nombre de tentatives d'échanges élevé. Dans le cas d'une planification avec une durée d'exécution plus longue lorsque le trafic est moindre, vous pouvez utiliser un délai d'attente plus important et un nombre maximal et minimal d'instances plus faible, de même qu'un nombre de tentatives peu important.

Remarques

  • Vous pouvez affecter plusieurs planifications à une réserve si vous le souhaitez. Auquel cas, assurez-vous que les paramètres de la réserve répondent aux besoins de toutes les planifications incluses.

  • La création de réserves ne pose aucun problème de compatibilité en amont. Le regroupement ne sera pas effectif sur les planifications pour lesquelles la propriété de regroupement n'est pas définie.

  • Une fois que l'exécution d'une instance de planification soumise à un regroupement est terminée, l'instance reste dans la réserve jusqu'à ce que la référence de cette instance soit dépassée ou explicitement exclue, comme l'indique l'exemple de code suivant :
    Set FSO = CreateObject("Scripting.FileSystemObject")
CurrentDirPath = FSO.GetAbsolutePathName(".")
SkedMoniker = "sked://localhost/" & CurrentDirPath & "\PoolingSample.skx"
While '(some condition)While
    Set Sked = GetObject(SkedMoniker)
    '(some action)
    Set Sked = Nothing
Wend

Voir aussi

Création d'une réserve de planifications XLANG.


Gestion de l'état de session

La page Propriétés avancées de l'Assistant Liaison de composants COM permet de sélectionner une valeur de gestion d'état pour le niveau de persistance que votre composant COM prend en charge. Dans la zone Prise en charge de la gestion des états, choisissez l'une des options suivantes :

  • Ne possède pas d'état. Cette option spécifie que le moteur de XLANG Scheduler termine l'instance du composant si l'instance de planification est en attente. Si vous sélectionnez cette option, le moteur de XLANG Scheduler crée si nécessaire une nouvelle instance du composant, lorsque la planification est réalimentée.

  • Possède un état mais ne prend pas en charge la persistance. Cette option indique que le moteur de XLANG Scheduler devra laisser l'instance du composant s'exécuter jusqu'à ce qu'elle ne soit plus nécessaire dans l'exécution de la planification. Si une erreur au niveau du système venait à se produire lors de la réalimentation de l'instance de planification, tout état préalablement stocké dans ce composant serait perdu.

  • Possède un état et prend en charge la persistance. Cette option indique que le moteur de XLANG Scheduler supprime l'instance du composant de la mémoire, puis la restaure en mémoire en appelant l'interface IPersistStream ou IPersistStreamInit dans le composant lors de la mise en attente, puis à nouveau lors de la réalimentation.

Voir aussi

Gestion des instances


Mise à jour des planifications XLANG

Il existe deux manières de mettre à jour une planification XLANG. Vous pouvez remplacer la planification XLANG d'origine ou ajouter une nouvelle planification XLANG qui sera exécutée simultanément à la planification XLANG d'origine.

Pour remplacer la planification XLANG d'origine, utilisez le Concepteur d'Orchestration BizTalk pour créer un nouveau schéma de planification XLANG, puis compilez le schéma de planification XLANG en une planification XLANG qui possède le même nom que la planification XLANG d'origine. Le schéma de planification XLANG est enregistré sous la forme d'un fichier .skv, qui est une version personnalisée du format de fichier Microsoft Visio 2000. Vous pouvez ensuite compiler le schéma de planification XLANG en une planification XLANG, qui est un fichier texte .skx de structure XML, compris par le moteur de XLANG Scheduler. Pour mettre à jour la planification XLANG d'origine, copiez le nouveau fichier .skx à la place du fichier .skx d'origine.

Pour ajouter une nouvelle planification XLANG qui fonctionnera simultanément à la planification XLANG d'origine, utilisez le Concepteur d'Orchestration BizTalk pour créer un nouveau schéma de planification XLANG et compilez ce schéma en une planification XLANG avec un nouveau nom. Afin de vous assurer que la nouvelle planification XLANG sera correctement activée, vous devez modifier le mécanisme d'activation de l'instance de planification XLANG en lui indiquant le nouveau fichier .skx au lieu de l'ancien. Une fois ce processus terminé, les nouvelles requêtes de planifications XLANG créeront des instances de la nouvelle planification XLANG.

Toutes les planifications XLANG et leurs composants fonctionnant généralement sur une base par instance, les instances de planification XLANG qui exécutent la planification d'origine se poursuivent jusqu'à leur fin. C'est également le cas pour les instances de planification XLANG mises en persistance, car le code source de la planification d'origine a été enregistré. Dans ce scénario, le chemin d'exécution continue à suivre le processus professionnel d'origine, tandis que les nouvelles requêtes de planifications XLANG créent des instances de la nouvelle planification XLANG.

Remarque

  • Si une planification XLANG utilise un objet avec une interface modifiée, vous devez charger le schéma de planification XLANG (le fichier .skv) dans le Concepteur d'Orchestration BizTalk, puis compiler un nouveau fichier .skx. Vous mettrez ainsi à jour les informations de liaison dans le fichier .skx, autorisant la synchronisation avec la bibliothèque de types du composant.


Pourquoi effectuer les tâches du Concepteur d'Orchestration BizTalk ?

Cette section explique les raisons pour lesquelles il est nécessaire d'effectuer les tâches du Concepteur d'Orchestration BizTalk. Le tableau suivant présente les tâches principales et leurs sous-tâches. Il présente également l'objet de chaque tâche et fournit les liens vers les procédures correspondantes.

Tâche Objet de la tâche
  • Utilisation du Concepteur d'Orchestration BizTalk
 Dessiner les processus professionnels qui peuvent être compilés et exécutés sous la forme de planifications XLANG.
  • Ouverture et enregistrement des schémas de planification XLANG
 Créer, ouvrir ou enregistrer le schéma de planification XLANG d'un processus professionnel.
Affichage de pages, formes et stencils
Affichage des pages de conception :
  • Affichage de la page Processus professionnels
 Afficher le schéma conceptuel d'un processus professionnel.
  • Affichage de la page Données
 Afficher les champs des messages, les champs des ports, les constantes et le flux de données entre eux.
  • Affichage des pages Processus professionnels et Données
 Afficher simultanément les pages Processus professionnels et Données.
  • Affichage des pages Compensation pour transaction
 Afficher le code qui renvoie les résultats d'une transaction imbriquée.
  • Affichage des pages En cas d'échec de transaction
 Afficher le code de traitement d'erreur associé à une transaction ayant échoué.
Affichage des formes :
  • Affichage des formes Diagramme de flux
 Afficher uniquement les formes Diagramme de flux qui décrivent les processus professionnels.
  • Affichage des formes Diagramme de flux et Communication
 Afficher les formes Diagramme de flux qui décrivent les processus professionnels et leurs inter-connexions.
  • Affichage des formes Diagramme de flux, Communication et Implémentation
 Afficher les formes Diagramme de flux qui décrivent les processus professionnels et les formes Implémentation qui décrivent les ports et leurs inter-connexions.
Affichage des stencils :
  • Affichage du stencil Diagramme de flux
 Afficher les formes que vous pouvez utiliser pour décrire les processus professionnels.
  • Affichage du stencil Implémentation
 Afficher les formes que vous pouvez utiliser pour mettre en œuvre les ports de communication entre les processus professionnels.
  • Utilisation de plusieurs fenêtres
 Ouvrir les fenêtres et les disposer en mosaïque ou en cascade, changer le focus pour afficher en même temps les différentes pages d'une planification XLANG ou plusieurs parties d'une même page.
  • Utilisation des annotations
 Ajouter, modifier ou mettre en forme des annotations pour créer des notes descriptives de votre processus professionnel.
  • Aperçu, impression ou redimensionnement de schémas de planification XLANG
 Permet d'imprimer votre schéma de planification XLANG, de le prévisualiser avant impression ou de le redimensionner.
  • Ajout, suppression et connexion de formes
 Placer et connecter logiquement les formes qui représentent des actions dans votre schéma de planification XLANG.
  • Sélection d'une forme
 Permet de modifier les propriétés d'une forme, de couper et de coller une forme, ou encore de créer des connexions entre les formes.
  • Connexion de deux formes
 Représente le flux du processus et des communications, en connectant des actions à d'autres actions ou à des ports.
  • Utilisation de l'outil de connexion
 Méthode pratique pour tracer les connexions entre les actions.
  • Alignement de formes sur un axe vertical ou horizontal
 Aligner les formes dans le sens vertical ou horizontal pour améliorer la présentation et la clarté d'un schéma de planification.
Définition des propriétés conditionnelles :
  • Définition des conditions de décision
 Ajouter des règles à une forme Décision ou déterminer l'ordre d'évaluation des règles.
  • Définition des conditions de boucle Tant que
 Ajouter une règle qui détermine la poursuite ou non de l'exécution d'une boucle Tant que.
  • Conservation de l'état dans une boucle Tant que
 Spécifier l'inclusion ou non des messages utilisés dans chaque itération de boucle dans un état de planification XLANG enregistré.
Création de règles :
  • Création d'une règle
 Évaluer les conditions dans les décisions et les boucles Tant que au sein d'un processus professionnel.
  • Utilisation de l'Assistant d'expression
 Ajouter les noms des messages et des champs à l'expression de script dans une règle.
  • Ajout de constantes à une règle
 Utiliser les constantes de la page Données dans une expression de script.
Définition des propriétés de simultanéité :
  • Création de flux concurrents
 Créer des flux logiques distincts mais simultanés, ou des branches, dans votre processus professionnel.
  • Définition de la propriété Type de jointure
 Spécifier la fin d'exécution ou non de tous les processus simultanés avant de passer à l'action suivante.
  • Jointure de flux concurrents
 Synchroniser des actions concurrentes pour qu'elles produisent une action commune.
  • Fin d'un flux concurrent
 Terminer un flux concurrent afin qu'il ne soit pas joint aux autres.
Définition des propriétés des transactions
Définition des propriétés transactionnelles d'une planification XLANG :
  • Définition du modèle de transaction
 Autoriser ou non des transactions dans la planification XLANG ou considérer la planification comme un composant COM+ (dans ce dernier cas, la planification peut exister dans le contexte d'une transaction COM+).
  • Définition de la propriété d'activation de la transaction
 Spécifier le comportement de votre planification XLANG dans le contexte d'une transaction COM+. Permet de spécifier que la planification ignore les transactions COM+ ou y participe, qu'elle soit toujours exécutée dans une transaction ou qu'elle crée toujours une transaction dans laquelle elle est exécutée.
Définition de propriétés transactionnelles individuelles :
  • Actions et flux de groupe d'une transaction
 Placer des formes ou des flux dans une forme de type Transaction afin que ceux-ci soient traités comme une transaction.
  • Conception de transactions imbriquées
 Placer une transaction à l'intérieur d'une autre.
  • Création de flux de transaction entrants et sortants
 Spécifier les flux de début et de fin d'une transaction, et connecter les actions aux ports correspondants.
  • Affectation d'un nom à une transaction
 Affecter une valeur à la propriété Nom d'une transaction.
  • Définition de la propriété Type de transaction
 Spécifier si la transaction est minutée, de type DTC de courte durée, ou une transaction de longue durée.
  • Définition de la propriété Délai d'attente
 Définir en secondes la durée d'exécution d'une transaction avant son abandon.
  • Définition de la propriété Nombre de tentatives
 Définir le nombre d'exécutions d'un processus dans une transaction de type DTC de courte durée, lorsque le processus ne se termine pas.
  • Définition de la propriété Intervalle
 Définir l'intervalle entre plusieurs exécutions d'une transaction.
  • Définition de la propriété Niveau d'isolation
 Spécifier le niveau de disponibilité réciproque des données dans les transactions simultanées de type DTC de courte durée.
  • Définition de la propriété Maintenir l'état de la planification
 Spécifier si l'état d'une planification doit être maintenu ou non avant le début d'une transaction.
Description de la prise en charge de transaction de composant et de Message Queuing :
  • Description du niveau de prise en charge de transaction dans un composant COM
 Spécifier si les transactions pour ce composant COM sont désactivées, prises en charge ou non, requises ou nécessairement nouvelles.
  • Description du niveau de prise en charge des transactions dans un composant de script Windows
 Spécifier si les transactions pour ce composant de script Windows sont désactivées, prises en charge ou non, requises ou nécessairement nouvelles.
  • Description du niveau de prise en charge des transactions dans une file d'attente de messages
 Spécifier si les transactions sont requises ou non dans cette file d'attente.
Définition des propriétés de gestion d'erreurs :
  • Abandon d'un flux de processus
 Si l'application d'une règle produit une valeur inattendue ou incorrecte, vous pouvez choisir d'abandonner le flux du processus.
Activation de la gestion d'erreur de transaction :
  • Activation de la gestion d'erreur En cas d'échec
 Cette tâche permet à la planification XLANG d'exécuter le code En cas d'échec de transaction pour gérer efficacement les erreurs dans une transaction.
  • Activation de la gestion d'erreur de compensation
 Cette tâche permet à la planification XLANG d'exécuter le code Compensation pour Transaction pour annuler les résultats d'une transaction imbriquée.
Activation de la gestion d'erreur de composant :
  • Abandon d'une transaction si un composant COM renvoie un échec
 Spécifier si une transaction doit être abandonnée lorsqu'un appel de méthode vers un composant COM renvoie une erreur HRESULT.
  • Abandon d'une transaction si un composant de script Windows renvoie un échec
 Spécifier si une transaction doit être abandonnée lorsqu'un appel de méthode vers un composant de script Windows renvoie une erreur HRESULT.
Implémentation de ports :
  • Ajout d'un port non lié à un schéma de planification XLANG
 Cette tâche permet d'ajouter un port à une planification avant de choisir les détails de l'implémentation du port.
  • Ajout d'un port lié à un schéma de planification XLANG
 Ajouter directement l'implémentation du port dans la planification.
  • Implémentation d'un port à l'aide d'un composant COM
 Utiliser une application ou un composant COM existant pour effectuer une action.
  • Implémentation d'un port à l'aide d'un composant de script Windows
 Utiliser un composant de script Windows existant pour effectuer une action.
  • Implémentation d'un port à l'aide de Message Queuing
 Permettre à la planification de communiquer avec une autre planification ou application d'une manière faiblement couplée.
  • Implémentation d'un port à l'aide d'échanges BizTalk
 Permettre à la planification d'utiliser les services d'échanges BizTalk pour établir une communication.
  • Modification des propriétés d'implémentation d'un port
 Modifier les différentes propriétés qui gèrent le type et le comportement de votre implémentation.
Envoi ou réception de messages :
  • Établissement du flux de communication entre une action et un port
 Créer un flux de communication entre une action dans votre processus professionnel et un processus professionnel externe.
  • Envoi et réception de messages synchrones
 Spécifier un flux de communication synchrone entre une action dans votre processus professionnel et un processus professionnel externe.
  • Envoi ou réception de messages asynchrones
 Spécifier un flux de communication asynchrone entre une action dans votre processus professionnel et un processus professionnel externe.
  • Modification du flux de communication entre une action et un port
 Spécifier si un flux de communication est de type synchrone ou asynchrone.
  • Dessin du flux de données entre les messages
 Vous pouvez décrire les interactions entre les données en sélectionnant les messages et leurs champs, les ports, et en dessinant le flux de données entre ces derniers.
  • Utilisation des constantes
 Utilisez les constantes spécifiées sur la page Données pour renseigner les champs de messages.
Exécuter les planifications XLANG
Compilation et débogage de planifications XLANG :
  • Compilation d'un schéma de planification XLANG dans une planification XLANG
 Créer une planification XLANG exécutable à partir du schéma de planification XLANG correspondant d'un processus professionnel.
  • Exécution d'une planification XLANG
 Exécuter un processus professionnel (action de base de BizTalk Server).
  • Exécution d'une planification XLANG
 Contrôler le nombre d'instances d'une planification XLANG qui peuvent être actives en mémoire à n'importe quel moment, afin d'optimiser l'utilisation des ressources.
  • Débogage des composants Visual Basic compilés
 Définir des points d'arrêt, visualiser le code et déboguer les composants intégrés dans Microsoft Visual Basic.
  • Actualisation des signatures de méthode
 Si vous avez modifié certains paramètres des appels de méthodes disponibles, utilisez cette procédure pour rendre ces paramètres accessibles à la planification.
  • Fermeture de toutes les planifications XLANG en cours d'exécution
 Modifier les composants COM utilisés dans une planification. Lorsqu'une instance de planification est en cours d'exécution, le fichier qui contient le composant COM est verrouillé.
Création et configuration d'une application hôte de planification XLANG :
  • Création d'une application COM+ pour héberger des planifications XLANG
 Exécutez cette tâche si vous avez des problèmes de sécurité, de déploiement ou de configuration qui pourraient être évités par l'exécution d'une planification à partir d'une application COM+.
  • Configuration d'une application COM+ pour héberger des planifications XLANG
 Définir ou modifier les différentes propriétés d'une application COM+ qui affectent les performances et le comportement de votre application hôte.


Exécution des tâches du Concepteur d'Orchestration BizTalk

Cette section fournit des informations spécifiques aux tâches associées à l'utilisation du Concepteur d'orchestration BizTalk afin de créer des schémas de planification XLANG et de les compiler dans des planifications XLANG exécutables. Cette section fournit également des informations sur l'exécution des planifications XLANG. Il est vivement recommandé de prendre connaissance de la section Concepts afin de comprendre parfaitement toutes les fonctionnalités du Concepteur d'Orchestration BizTalk.

Cette section traite des rubriques suivantes :

  • Utilisation du Concepteur d'Orchestration BizTalk

  • Exécution des planifications XLANG

Remarque

  • Les conventions suivantes s'appliquent aux transactions, ports, messages, règles, files d'attente et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse www.w3.org.

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.


Utilisation du Concepteur d'Orchestration BizTalk

Cette section décrit les procédures d'utilisation du Concepteur d'orchestration BizTalk afin de créer des schémas de planification XLANG et de les compiler dans des planifications XLANG.

Cette section traite des rubriques suivantes :

  • Ouverture et enregistrement des schémas de planification XLANG

  • Affichage de pages, formes et stencils

  • Ajout, suppression et connexion de formes

  • Définition des propriétés conditionnelles

  • Définition des propriétés de simultanéité

  • Définition des propriétés de transaction

  • Définition des propriétés de gestion d'erreurs

  • Implémentation de ports

  • Envoi ou réception de messages

  • Dessin du flux de données entre les messages

Remarques

  • Si un ou plusieurs fichiers du dossier VBA n'ont pas été correctement enregistrés ou ont été endommagés, vous ne pourrez peut-être pas ouvrir le Concepteur d'Orchestration BizTalk. Ce problème peut être lié à la désinstallation de Microsoft Office.
    • Si Office n'est pas installé : Recherchez le fichier Vba6.msi sur le CD-ROM Microsoft Office, cliquez avec le bouton droit sur ce fichier, puis cliquez sur Installer.

    • Si Office est installé : Ouvrez Microsoft Access, créez une base de données vide et enregistrez-la, puis fermez Microsoft Access.
  • Si vous masquez la barre d'outils standard lorsque vous utilisez Microsoft Visio, la barre d'outils standard n'apparaîtra pas lors de l'ouverture du Concepteur d'Orchestration. Pour afficher la barre d'outils, procédez comme suit :
    1. Dans le menu Fichier, sélectionnez Quitter pour fermer le Concepteur d'Orchestration BizTalk. Dans le menu Démarrer, pointez sur Programmes, puis cliquez sur Microsoft Visio.

    2. Dans le menu Affichage, pointez sur Barre d'outils, puis cliquez sur Standard.

    3. Dans le menu Fichier, sélectionnez Quitter pour fermer Microsoft Visio.

    4. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Concepteur d'Orchestration BizTalk.

      La barre d'outils apparaît.

  • Après avoir utilisé le Concepteur d'Orchestration BizTalk, vous ne pourrez pas accéder à certains menus et à certaines barres d'outils lorsque vous ouvrirez Microsoft Visio. Vous pouvez utiliser le menu contextuel dans Microsoft Visio pour personnaliser les barres d'outils et les menus afin de réactiver les éléments de votre choix.

Question d'ordre international

  • Dans certaines langues, il est possible que des caractères ne s'affichent pas correctement dans le Concepteur d'Orchestration BizTalk. Pour pallier ce problème, vous pouvez spécifier que Microsoft Visio 2002 doit utiliser systématiquement la police du système par défaut :
    1. Fermez le Concepteur d'Orchestration BizTalk.

    2. Dans le menu Démarrer, pointez sur Programmes, puis cliquez sur Microsoft Visio.

    3. Dans le menu Outils, cliquez sur Options.

      La boîte de dialogue Options s'affiche.

    4. Dans la zone Police de base du document de l'onglet Options régionales, cliquez sur Toujours utiliser la police système par défaut.

    5. Fermez Visio et ouvrez le Concepteur d'Orchestration BizTalk.


Ouverture et enregistrement des schémas de planification XLANG

Cette section traite des procédures suivantes :

  • Création d'un nouveau schéma de planification XLANG

  • Ouverture d'un schéma de planification XLANG existant

  • Enregistrement d'un schéma de planification XLANG


Création d'un nouveau schéma de planification XLANG

Cette procédure ouvre un nouveau schéma de planification XLANG dans la fenêtre de conception. La page de conception par défaut est la page des processus professionnels. Les stencils Diagramme de flux et stencils Implémentation s'ouvrent également par défaut lorsque vous commencez un nouveau schéma.

  • Dans le menu Fichier du Concepteur d'Orchestration BizTalk, cliquez sur Nouveau.

Remarque

  • L'extension de fichier d'un schéma de planification XLANG est .skv.

Voir aussi

Ouverture d'un schéma de planification XLANG existant

Enregistrement d'un schéma de planification XLANG


Ouverture d'un schéma de planification XLANG existant

  1. Dans le menu Fichier du Concepteur d'Orchestration BizTalk, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir un schéma de planification XLANG apparaît.

  2. Sélectionnez le schéma de planification XLANG à ouvrir, puis cliquez sur Ouvrir.

Remarques

  • L'extension de fichier d'un schéma de planification XLANG est .skv.

  • L'extension de fichier d'une planification XLANG est .skx. Vous ne pouvez pas ouvrir un fichier .skx dans le Concepteur d'Orchestration BizTalk. Pour modifier ou mettre à jour un fichier .skx, ouvrez le fichier source .skv, modifiez-le et recompilez-le en tant que fichier .skx.

Voir aussi

Création d'un nouveau schéma de planification XLANG

Enregistrement d'un schéma de planification XLANG


Enregistrement d'un schéma de planification XLANG

  • Dans le menu Fichier du Concepteur d'Orchestration BizTalk, cliquez sur Enregistrer.

Remarques

  • Lorsque vous enregistrez un schéma de planification XLANG, celui-ci est enregistré sous le nom par défaut DrawingX.skv (X représentant le nombre ajouté au nom du schéma). Vous pouvez cependant modifier le nom du fichier lorsque vous enregistrez le schéma.

  • Dans le menu Fichier, vous pouvez également cliquer sur Enregistrer sous. Cette option ouvre la boîte de dialogue Enregistrer un schéma de planification XLANG sous. Vous pouvez :
    • renommer le fichier ;

    • enregistrer le fichier à un autre emplacement.
  • L'extension de fichier d'un schéma de planification XLANG est .skv.

  • L'extension de fichier d'une planification XLANG est .skx. Vous ne pouvez pas ouvrir un fichier .skx dans le Concepteur d'Orchestration BizTalk. Pour modifier ou mettre à jour un fichier .skx, ouvrez le fichier source .skv, modifiez-le et recompilez-le en tant que fichier .skx.

Voir aussi

Création d'un nouveau schéma de planification XLANG

Ouverture d'un schéma de planification XLANG existant


Affichage de pages, formes et stencils

Le Concepteur d'Orchestration BizTalk dispose de plusieurs options d'affichage que vous pouvez utiliser pour agrandir la zone de votre schéma ou pour afficher une forme spécifique ou des relations entre les données.

Cette section traite des rubriques suivantes :

  • Affichage des pages de conception

  • Affichage des formes

  • Affichage des stencils

  • Utilisation de plusieurs fenêtres

  • Utilisation des annotations

  • Aperçu, impression et redimensionnement de schémas de planification XLANG


Affichage des pages de conception

Cette section traite des procédures suivantes :

  • Affichage de la page Processus professionnels

  • Affichage de la page Données

  • Affichage des pages Processus professionnels et Données

  • Affichage des pages Compensation pour transaction

  • Affichage des pages En cas d'échec de transaction

  • Affichage d'une page

Voir aussi

Utilisation de plusieurs fenêtres

Affichage des formes

Affichage des stencils


Affichage de la page Processus professionnels

  • Dans le menu Affichage, cliquez sur Page des processus professionnels.

Remarque

  • Vous pouvez également cliquer sur l'onglet Processus professionnel dans la partie inférieure des pages de conception.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage des pages Compensation pour transaction

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage des pages Processus professionnels et Données

Affichage de la page Données


Affichage de la page Données

  • Dans le menu Affichage, cliquez sur Page de données.

Remarque

  • Vous pouvez également cliquer sur l'onglet Données dans la partie inférieure des pages de conception.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage des pages Compensation pour transaction

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage des pages Processus professionnels et Données

Affichage de la page Processus professionnels


Affichage des pages Processus professionnels et Données

  • Dans le menu Affichage, cliquez sur Page des processus professionnels et des données.

Remarque

  • Cette option d'affichage ouvre deux fenêtres d'une même planification XLANG : une fenêtre Processus professionnel et une fenêtre Données. Cette fonctionnalité est similaire à celle obtenue avec l'option Nouvelle fenêtre. Pour plus d'informations sur l'ouverture de plusieurs fenêtres, voir Utilisation de plusieurs fenêtres.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage des pages Compensation pour transaction

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage de la page Processus professionnels

Affichage de la page Données


Affichage des pages Compensation pour transaction

  • Dans la partie inférieure des pages de conception, cliquez sur l'onglet Compensation pour Transaction de la page que vous voulez afficher.

Remarques

  • Le paramètre Transaction, dans le nom de la page, est remplacé par le nom de la transaction à laquelle le processus de gestion d'erreur est associé.

  • Pour plus d'informations sur l'ajout d'une page Compensation pour Transaction à un schéma de planification XLANG, voir Activation de la gestion d'erreur de compensation.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage des pages Processus professionnels et Données

Affichage de la page Processus professionnels

Affichage de la page Données


Affichage des pages En cas d'échec de transaction

  • Dans la partie inférieure des pages de conception, cliquez sur l'onglet En cas d'échec de Transaction de la page que vous voulez afficher.

Remarques

  • Le paramètre Transaction, dans le nom de la page, est remplacé par le nom de la transaction à laquelle le processus de gestion d'erreur est associé.

  • Pour plus d'informations sur l'ajout d'une page En cas d'échec de Transaction à un schéma de planification XLANG, voir Activation de la gestion d'erreur en cas d'échec.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage d'une page

Affichage des pages Compensation pour transaction

Affichage des formes

Affichage des stencils

Affichage des pages Processus professionnels et Données

Affichage de la page Processus professionnels

Affichage de la page Données


Affichage d'une page

  • Cliquez sur l'onglet correspondant à la page que vous voulez afficher.

Remarque

  • Les onglets de chacune des pages se trouvent dans la partie inférieure des pages de conception.

Voir aussi

Utilisation de plusieurs fenêtres

Affichage des pages Compensation pour transaction

Affichage des pages En cas d'échec de transaction

Affichage des formes

Affichage des stencils

Affichage des pages Processus professionnels et Données

Affichage de la page Processus professionnels

Affichage de la page Données


Affichage des formes

Cette section traite des procédures suivantes :

  • Affichage des formes Diagramme de flux

  • Affichage des formes Diagramme de flux et Communication

  • Affichage des formes Diagramme de flux, Communication et Implémentation

Voir aussi

Affichage des stencils

Affichage des pages de conception


Affichage des formes Diagramme de flux

Si vous utilisez cette option, seules les formes Diagramme de flux et leurs connexions s'affichent sur la page de conception. Cette option masque tous les ports, les messages de ports, les implémentations et les connexions entre les ports et les actions ou entre les ports et les implémentations.

  • Dans le menu Affichage, cliquez sur Formes Diagramme de flux.

Remarques

  • Cette option d'affichage ne peut pas être utilisée dans la page Données.

Voir aussi

Affichage des formes Diagramme de flux et Communication

Affichage des formes Diagramme de flux, Communication et Implémentation

Affichage des stencils

Affichage des pages de conception


Affichage des formes Diagramme de flux et Communication

Si vous utilisez cette option, les formes Diagramme de flux et leurs connexions s'affichent sur la page de conception. Les ports, les messages de ports ainsi que les connexions entre les ports et les actions s'affichent également. Cette option masque toutes les implémentations et les connexions entre les ports et les implémentations.

  • Dans le menu Affichage, cliquez sur Formes Diagramme de flux et Communication.

Remarques

  • Cette option d'affichage ne peut pas être utilisée dans la page Données.

Voir aussi

Affichage des formes Diagramme de flux, Communication et Implémentation

Affichage des formes Diagramme de flux

Affichage des stencils

Affichage des pages de conception


Affichage des formes Diagramme de flux, Communication et Implémentation

  • Dans le menu Affichage, cliquez sur Formes Diagramme de flux, Communication et Implémentation.

Remarques

  • Toutes les formes et leurs connexions s'affichent.

  • Cette option d'affichage ne peut pas être utilisée dans la page Données.

Voir aussi

Affichage des formes Diagramme de flux et Communication

Affichage des formes Diagramme de flux

Affichage des stencils

Affichage des pages de conception


Affichage des stencils

Cette section traite des procédures suivantes :

  • Affichage du stencil Diagramme de flux

  • Affichage du stencil Implémentation

Voir aussi

Affichage des formes

Affichage des pages de conception


Affichage du stencil Diagramme de flux

  • Dans le menu Affichage, pointez sur Stencils et cliquez sur Diagramme de flux pour afficher ou masquer le stencil Diagramme de flux.

Voir aussi

Affichage des formes

Affichage des pages de conception

Affichage du stencil Implémentation


Affichage du stencil Implémentation

  • Dans le menu Affichage, pointez sur Stencils et cliquez sur Implémentation pour afficher ou masquer le stencil Implémentation.

Voir aussi

Affichage des formes

Affichage des pages de conception

Affichage du stencil Diagramme de flux


Utilisation de plusieurs fenêtres

Cette section traite des procédures suivantes :

  • Ouverture d'une nouvelle fenêtre

  • Fenêtres en mosaïque

  • Fenêtres en cascade

  • Modification du focus de la fenêtre

Voir aussi

Affichage des pages de conception


Ouverture d'une nouvelle fenêtre

  • Dans le menu Fenêtre, cliquez sur Nouvelle fenêtre.

Remarque

  • Plusieurs fenêtres offrent des vues complémentaires d'une même planification XLANG. Ainsi, vous pouvez effectuer les opérations suivantes :
    • Afficher simultanément plusieurs pages d'une même planification XLANG. Par exemple, vous pouvez ouvrir des vues des pages Processus professionnels, Données et Compensation pour transaction.

    • Afficher simultanément différentes parties d'une même page de planification XLANG. Par exemple, dans une vue, vous pouvez effectuer un zoom avant pour afficher un jeu de formes spécifique de la planification XLANG, et dans une autre effectuer un zoom arrière pour afficher la totalité de la planification.

Voir aussi

Fenêtres en cascade

Modification du focus de la fenêtre

Fenêtres en mosaïque

Affichage des pages de conception


Fenêtres en mosaïque

Cette option d'affichage vous permet d'afficher simultanément plusieurs fenêtres.

  • Dans le menu Fenêtre, cliquez sur Mosaïque.

Remarques

  • Plusieurs fenêtres offrent des vues complémentaires d'une même planification XLANG. Ainsi, vous pouvez effectuer les opérations suivantes :
    • Afficher simultanément plusieurs pages d'une même planification XLANG. Par exemple, vous pouvez ouvrir des vues des pages Processus professionnels, Données et Compensation pour transaction.

    • Afficher simultanément différentes parties d'une même page de planification XLANG. Par exemple, dans une vue, vous pouvez effectuer un zoom avant pour afficher un jeu de formes spécifique de la planification XLANG, et dans une autre effectuer un zoom arrière pour afficher la totalité de la planification.

Voir aussi

Fenêtres en cascade

Modification du focus de la fenêtre

Ouverture d'une nouvelle fenêtre

Affichage des pages de conception


Fenêtres en cascade

Cette option d'affichage vous permet d'afficher une fenêtre en premier plan. Vous pouvez cliquer sur les barres de titre des autres fenêtres pour les afficher en premier plan.

  • Dans le menu Fenêtre, cliquez sur Cascade.

Remarques

  • Plusieurs fenêtres offrent des vues complémentaires d'une même planification XLANG. Ainsi, vous pouvez effectuer les opérations suivantes :
    • Afficher simultanément plusieurs pages d'une même planification XLANG. Par exemple, vous pouvez ouvrir des vues des pages Processus professionnels, Données et Compensation pour transaction.

    • Afficher simultanément différentes parties d'une même page de planification XLANG. Par exemple, dans une vue, vous pouvez effectuer un zoom avant pour afficher un jeu de formes spécifique de la planification XLANG, et dans une autre effectuer un zoom arrière pour afficher la totalité de la planification.

Voir aussi

Modification du focus de la fenêtre

Ouverture d'une nouvelle fenêtre

Fenêtres en mosaïque

Affichage des pages de conception


Modification du focus de la fenêtre

  • Dans le menu Affichage, cliquez sur le nom de la fenêtre vers laquelle vous voulez faire basculer le focus.

Remarques

  • Le nom d'une fenêtre est le nom de la planification XLANG auquel est ajouté le nom d'une page de conception (par exemple, Schedule1.skv:Processus professionnels ou Schedule1.skv:Données).

  • Plusieurs fenêtres offrent des vues complémentaires d'une même planification XLANG. Ainsi, vous pouvez effectuer les opérations suivantes :
    • Afficher simultanément plusieurs pages d'une même planification XLANG. Par exemple, vous pouvez ouvrir des vues des pages Processus professionnels, Données et Compensation pour transaction.

    • Afficher simultanément différentes parties d'une même page de planification XLANG. Par exemple, dans une vue, vous pouvez effectuer un zoom avant pour afficher un jeu de formes spécifique de la planification XLANG, et dans une autre effectuer un zoom arrière pour afficher la totalité de la planification.

Voir aussi

Fenêtres en cascade

Ouverture d'une nouvelle fenêtre

Fenêtres en mosaïque

Affichage des pages de conception


Utilisation des annotations

Cette section traite des procédures suivantes :

  • Ajout d'annotations

  • Modification des annotations

  • Formatage du texte dans des annotations

  • Suppression d'annotations


Ajout d'annotations

  1. Dans la barre d'outils du Concepteur d'Orchestration BizTalk, cliquez sur le bouton Outil Texte [image] ().

  2. À l'aide du pointeur de la souris, déplacez le bouton vers la zone dans laquelle vous voulez créer une annotation.

  3. Tapez l'annotation.

Remarques

  • Pour désactiver le bouton Outil Texte, cliquez sur Outil Pointeur [image] () dans la barre d'outils.

  • Comme le Concepteur d'Orchestration BizTalk utilise une interface personnalisée Microsoft Visio, le bouton Outil Texte offre deux options. Les fonctionnalités de ces deux boutons sont identiques :
    • Bouton Outil Texte ( bouton Outil Texte )

    • Bouton Outil Bloc de texte ( bouton Bloc de texte )

Voir aussi

Suppression d'annotations

Modification des annotations

Mise en forme du texte dans les annotations


Modification des annotations

  1. Dans la barre d'outils du Concepteur d'Orchestration BizTalk, cliquez sur le bouton Outil Texte ( Outil Texte ).

  2. Cliquez sur l'annotation que vous voulez modifier.

  3. Modifiez l'annotation.

Remarques

  • Pour désactiver le bouton Outil Texte, cliquez sur Outil Pointeur ( bouton Outil Pointeur ) dans la barre d'outils.

  • Comme le Concepteur d'Orchestration BizTalk utilise une interface personnalisée Microsoft Visio, le bouton Outil Texte offre deux options. Les fonctionnalités de ces deux boutons sont identiques :
    • Bouton Outil Texte [image] ()

    • Bouton Outil Bloc de texte [image] ()

Voir aussi

Ajout d'annotations

Suppression d'annotations

Mise en forme du texte dans les annotations


Mise en forme du texte dans les annotations

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, sélectionnez des annotations à mettre en forme.

  2. Dans le menu Format, cliquez sur Texte.

    La boîte de dialogue Texte s'affiche. Cette boîte de dialogue propose plusieurs options pour la taille, la police et l'apparence du texte.

  3. Sélectionnez les options appropriées et cliquez sur OK.

Remarques

  • Ces options s'appliquent aux annotations mises en surbrillance dans le schéma de planification XLANG, ainsi qu'à toutes les nouvelles annotations créées.

  • Vous ne pouvez pas mettre en forme les annotations lorsque l'Outil Texte est activé.

  • Cliquez sur une annotation pour la sélectionner. Pour sélectionner plusieurs annotations, appuyez sur la touche MAJ et maintenez-la enfoncée, puis cliquez sur les annotations à sélectionner.

Voir aussi

Ajout d'annotations

Suppression d'annotations

Modification des annotations


Suppression d'annotations

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur l'annotation à supprimer, puis appuyez sur la touche SUPPR.

Remarque

  • Vous devez désactiver l'Outil Texte avant de supprimer une annotation d'un schéma de planification XLANG.

Voir aussi

Ajout d'annotations

Mise en forme du texte dans les annotations


Aperçu, impression et redimensionnement des schémas de planification XLANG

Cette section traite des procédures suivantes :

  • Utilisation de l'aperçu avant impression

  • Impression d'un schéma de planification XLANG

  • Redimensionnement d'un schéma de planification XLANG


Utilisation de l'aperçu avant impression

  • Dans le menu Fichier, cliquez sur Aperçu avant impression.

Remarque

  • Si vous remplacez l'option Orientation Paysage par Portrait, le message suivant s'affiche :

    L'orientation des pages de conception ne correspond pas à la configuration des pages pour l'impression. Cliquez sur OK pour imprimer votre schéma sur plusieurs pages. Pour faire correspondre les orientations, modifiez la configuration des pages pour l'impression.

    Si vous cliquez sur OK et vous effectuez cette modification, l'affichage de l'aperçu avant impression pourra être le suivant :

    • Lorsque vous cliquez sur Mosaïque suivante pour afficher la page suivante, puis sur Mosaïque précédente pour revenir à la première page, certaines formes peuvent apparaître dans l'aperçu avant impression comme si elles ne se trouvaient pas sur la page. Cet affichage est sans effet. L'impression de la planification XLANG en cours s'effectuera correctement sur plusieurs pages.

Voir aussi

Impression d'un schéma de planification XLANG

Redimensionnement d'un schéma de planification XLANG


Impression d'un schéma de planification XLANG

  1. Dans le menu Fichier, cliquez sur Imprimer.

    La boîte de dialogue Imprimer s'affiche.

  2. Définissez les options souhaitées, puis cliquez sur Imprimer.

Remarque

  • Confirmez qu'une imprimante est installée avant d'imprimer un schéma de planification XLANG.

Voir aussi

Redimensionnement d'un schéma de planification XLANG

Utilisation de l'aperçu avant impression


Redimensionnement d'un schéma de planification XLANG

  1. Dans le menu Affichage du Concepteur d'Orchestration BizTalk, cliquez sur Page entière.

  2. Appuyez sur la touche CTRL et maintenez-la enfoncée, puis déplacez le pointeur de la souris vers le bord de la page.

    Le pointeur se transforme en double flèche.

  3. Sélectionnez le bord de la page et déplacez-le pour redimensionner la page.

Voir aussi

Impression d'un schéma de planification XLANG

Utilisation de l'aperçu avant impression


Ajout, suppression et connexion de formes

Cette section traite des procédures suivantes :

  • Ajout de formes

  • Affectation d'un nom aux formes

  • Suppression de formes

  • Suppression de ports et messages inutilisés

  • Connexion de formes


Ajout de formes

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

  • Dans le stencil Diagramme de flux du Concepteur d'Orchestration BizTalk, cliquez sur une forme et faites-la glisser vers la page de conception.

Remarques

  • Pour plus d'informations sur l'ajout de formes Implémentation à un schéma de planification XLANG, voir Implémentation de ports.

  • Vous ne pouvez pas ajouter de formes à la page Données. De nouveaux messages sont créés automatiquement sur la page Données lors de chaque connexion d'une action à un port.

Voir aussi

Connexion de formes

Suppression de formes

Suppression de ports et messages inutilisés

Affectation d'un nom aux formes

Affichage du stencil Diagramme de flux


Affectation d'un nom aux formes

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de Forme s'affiche.

  2. Dans la zone Nom, tapez un nom.

Remarques

  • La propriété Nom de chaque forme contient une valeur par défaut qui correspond au nom de la forme, auquel est ajouté un numéro (par exemple Action 1). Vous pouvez remplacer la valeur par défaut par le nom de votre choix.

  • Les formes suivantes ne peuvent pas être nommées : Abandon, Début, Décision, Fin, Branche, Jointure et Tant que.

  • Les formes suivantes peuvent être nommées : Action, Transaction, Port, Message et Règle.

  • Les noms de formes doivent répondre à certaines conventions d'affectation de noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C à l'adresse www.w3.org.

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Les noms de transactions dans des jeux de caractères codés sur un octet ne peuvent pas excéder 16 caractères. Les noms de transactions dans des jeux de caractères codés sur deux octets ne peuvent pas excéder 8 caractères.

  • Aucune convention d'affectation de noms ne s'applique aux actions, hormis la taille limite de 32 caractères.

Voir aussi

Ajout de formes

Connexion de formes

Suppression de formes

Suppression de ports et messages inutilisés


Suppression de formes

  • Cliquez sur la forme à supprimer et appuyez sur la touche SUPPR.

Remarques

  • Pour supprimer une connexion entre deux formes, cliquez sur la connexion appropriée et appuyez sur la touche SUPPR.

  • Si une forme a des connexions avec d'autres formes, lorsque vous la supprimez, toutes les connexions sont également supprimées.

  • Toutes les formes incluses dans une transaction sont supprimées lorsque vous supprimez la transaction.

  • Vous pouvez supprimer des implémentations d'Échanges BizTalk ou de Message Queuing sans supprimer les ports auxquels ces implémentations sont connectées.

  • Lorsque vous supprimez une implémentation de composants COM ou de composants de script Windows, les ports auxquels ils sont connectés sont également supprimés.

  • Pour supprimer un message, cliquez sur le message d'un port et sur la touche SUPPR. Le message associé est supprimé dans la page Données.

    Vous pouvez également supprimer des messages à partir de la page Données. Pour plus d'informations, voir Suppression d'un message.

  • Vous ne pouvez pas supprimer de règles en utilisant cette procédure. Pour plus d'informations sur la suppression de règles, consultez les rubriques suivantes :
    • Suppression d'une règle dans une décision

    • Suppression d'une règle dans une boucle Tant que

    • Suppression des règles inutilisées

Voir aussi

Ajout de formes

Connexion de formes

Suppression d'un message

Suppression d'une règle dans une décision

Suppression d'une règle dans une boucle Tant que

Suppression de ports et messages inutilisés

Suppression des règles inutilisées

Affectation d'un nom aux formes


Suppression de ports et messages inutilisés

Cette procédure supprime du schéma de planification XLANG tous les ports non utilisés ainsi que tous les messages qu'ils contiennent. Les messages correspondants sont également supprimés de la page Données.

  • Dans le menu Outils du Concepteur d'Orchestration BizTalk, cliquez sur Supprimer les ports et les messages non utilisés.

Voir aussi

Ajout de formes

Connexion de formes

Suppression de formes

Affectation d'un nom aux formes


Connexion de formes

Cette section traite des procédures suivantes :

  • Choix d'une forme

  • Connexion de deux formes

  • Utilisation de l'outil de connexion

  • Alignement de formes sur un axe vertical ou horizontal

Voir aussi

Ajout de formes

Suppression de formes

Suppression de ports et messages inutilisés

Affectation d'un nom aux formes


Choix d'une forme

La sélection d'une forme vous permet d'effectuer les opérations suivantes :

  • Faire glisser les poignées de contrôle ( [image]) de cette forme vers d'autres formes.

  • Modifier les propriétés des formes disponibles.

  • Couper, copier, coller, supprimer et dupliquer les formes.

Ces options ne sont pas disponibles pour toutes les formes.

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme.

    La forme sélectionnée est entourée d'une bordure verte discontinue. Toutes les poignées de contrôle ( [image]) disponibles pour cette forme sont activées.

Remarque

  • Si vous copiez une forme Action connectée à une forme Port, la copie de cette action est également connectée à ce port.

Voir aussi

Ajout de formes

Connexion de deux formes

Suppression de formes

Utilisation de l'outil de connexion


Connexion de deux formes

  1. Pour connecter les deux formes, sélectionnez la première.

    La forme sélectionnée est entourée d'une bordure verte discontinue. Toutes les poignées de contrôle ( [image]) disponibles pour cette forme sont activées.

  2. Faites glisser la poignée de contrôle appropriée vers le point de connexion ( [image]) de la deuxième forme.

  3. Lorsque le point de connexion est en surbrillance avec une case rouge ( [image]), relâchez le bouton de la souris pour établir la connexion.

Remarques

  • Les flux de processus sont connectés à partir des points de connexion inférieur et supérieur et des poignées de contrôle des formes.

  • Les flux de communication sont connectés à partir de la poignée de contrôle droite d'une forme Action au point de connexion gauche d'une forme Port.

  • Vous pouvez également utiliser l'outil de connexion pour connecter les formes. Pour plus d'informations, voir Utilisation de l'outil de connexion.

Voir aussi

Ajout de formes

Suppression de formes

Choix d'une forme

Utilisation de l'outil de connexion


Utilisation de l'outil de connexion

  1. Dans la barre d'outils, cliquez sur le bouton Outil de connexion ( Bouton ).

  2. Pointez sur une poignée de contrôle ( [image]) de la forme à partir de laquelle vous voulez créer une connexion.

    La poignée de contrôle est entourée d'une case rouge pour indiquer que vous pouvez la faire glisser.

  3. Cliquez sur le bouton de la souris et maintenez-le enfoncé pour faire glisser la poignée de contrôle de la forme vers un point de connexion ( [image]) de la forme avec laquelle vous voulez créer une connexion.

  4. Lorsque le point de connexion de la forme est en surbrillance avec une case rouge ( [image]), relâchez le bouton de la souris pour établir la connexion.

Remarques

  • Pour désactiver le bouton Outil Texte, cliquez sur le bouton Outil Pointeur [image] () dans la barre d'outils.

  • Nous vous recommandons d'utiliser le bouton Outil Pointeur pour connecter des formes Action au formes Port. Si vous utilisez l'outil de connexion pour créer une connexion entre une action et un port lié à un composant COM ou de script, vous devez recréer la connexion (même si aucune propriété n'a été modifiée) chaque fois que vous activez l'Assistant Liaison de composants correspondant par la suite.

  • Vous pouvez ajouter des formes à une page et effectuer d'autres opérations lorsque l'outil de connexion est activé. Cependant, vous pouvez recevoir un message d'erreur. Ce message n'est pas valide et n'a aucune incidence. Le problème lié à l'apparition du message d'erreur sera corrigé dans les prochaines versions de Microsoft Visio. Si ce message d'erreur s'affiche, cliquez sur OK et continuez. Le texte du message est le suivant :

    Erreur interne Visio : #-1

    Action 1246 : Déplacement sur la page

    Essayez de fermer puis de rouvrir le fichier. Puis essayez de redémarrer Visio.

Voir aussi

Ajout de formes

Connexion de deux formes

Suppression de formes

Choix d'une forme


Alignement de formes sur un axe vertical ou horizontal

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser le pointeur de la souris sur les formes que vous voulez aligner sur un axe.

  2. Dans la barre d'outils, cliquez sur le bouton Aligner les formes [image] ().

    La boîte de dialogue Aligner les formes apparaît.

  3. Dans l'une des zones ci-après, cliquez sur l'alignement de votre choix :
    • Dans la zone Alignement en bas/en haut, cliquez sur l'un des boutons suivants :

      Bouton Alignement horizontal vers le haut Alignement horizontal en haut

      Bouton Alignement horizontal centré Alignement horizontal centré

      Bouton Alignement horizontal vers le bas Alignement horizontal en bas

    • Dans la zone Alignement à gauche/à droite, cliquez sur l'un des boutons suivants :

      Bouton Alignement vertical à gauche Alignement vertical à gauche

      Bouton Alignement vertical centré Alignement vertical centré

      Bouton Alignement vertical à droite Alignement vertical à droite

Remarques

  • Vous devez sélectionner des formes sur une page de conception pour activer le bouton Aligner les formes.

  • Il est recommandé d'aligner les formes sur un seul axe. Dans le cas contraire, les formes risquent d'être superposées. Appuyez sur CTRL+Z pour annuler les modifications qui ne vous conviennent pas.

  • Dans la boîte de dialogue Aligner les formes, le bouton Désactiver l'alignement [image] () supprime la sélection d'un alignement.

  • La case à cocher Créer un repère et coller les formes dessus n'est jamais disponible.

  • Vous pouvez appuyer sur la touche MAJ et la maintenir enfoncée, puis cliquer sur plusieurs formes pour les sélectionner.


Définition des propriétés conditionnelles

Cette section traite des rubriques suivantes :

  • Définition des conditions de décision

  • Définition des conditions de boucle Tant que

  • Création de règles

Voir aussi

Conception de règles


Définition des conditions de décision

Cette section traite des procédures suivantes :

  • Ajout d'une règle à une décision

  • Modification d'une règle dans une décision

  • Suppression d'une règle dans une décision

  • Définition de l'ordre d'évaluation des règles

Voir aussi

Création de règles

Conception de règles


Ajout d'une règle à une décision

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Décision à laquelle vous voulez ajouter une règle et cliquez sur Ajouter une règle.

    La boîte de dialogue Ajouter une règle s'affiche.

  2. Cliquez sur l'une des options suivantes :
    • Créer une règle

      Cliquez sur OK. La boîte de dialogue Propriétés de la règle s'affiche.

      Pour plus d'informations sur la création des règles, voir Création de règles.

    • Ajouter une règle existante

      Dans la liste Règles disponibles, sélectionnez la règle à ajouter et cliquez sur OK.

      La boîte de dialogue Ajouter une règle se ferme et la règle est ajoutée à la décision.

Remarques

  • Lorsque vous ajoutez une règle pour la première fois à un schéma de planification XLANG en cliquant sur Ajouter une règle, la boîte de dialogue Propriétés de la règle s'affiche. La boîte de dialogue Ajouter une règle s'affiche uniquement si vous disposez de règles créées précédemment afin de les ajouter à une décision. Pour plus d'informations sur la boîte de dialogue Propriétés de la règle, voir Création de règles.

  • Vous pouvez également ajouter une règle à une décision en cliquant avec le bouton droit sur une forme Décision, puis en cliquant sur Propriétés et sur Ajouter.

Voir aussi

Création de règles

Suppression d'une règle dans une décision

Conception de règles

Définition de l'ordre d'évaluation des règles

Modification d'une règle dans une décision


Modification d'une règle dans une décision

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Décision, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la décision apparaît.

  2. Cliquez sur la règle à modifier, puis sur Modifier.

    La boîte de dialogue Propriétés de la règle s'affiche.

  3. Effectuez les modifications souhaitées et cliquez sur OK.

    Pour plus d'informations sur la boîte de dialogue Propriétés de la règle, voir Création de règles.

  4. Pour modifier une autre règle, sélectionnez-la et cliquez sur Modifier.

    –Ou–

    Pour fermer la boîte de dialogue Propriétés de la décision, cliquez sur OK.

Remarques

  • Dans la boîte de dialogue Propriétés de la décision, vous pouvez également ajouter une règle en cliquant sur Ajouter.

  • Vous pouvez également modifier une règle en cliquant avec le bouton droit sur une règle d'une forme Décision, puis en cliquant sur Propriétés. La boîte de dialogue Propriétés de la règle s'affiche.

Voir aussi

Ajout d'une règle à une décision

Création de règles

Suppression d'une règle dans une décision

Conception de règles

Définition de l'ordre d'évaluation des règles


Suppression d'une règle dans une décision

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Décision pour laquelle vous voulez supprimer une règle et cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la décision apparaît.

  2. Cliquez sur la règle à supprimer, puis cliquez sur Ouvrir.

Voir aussi

Ajout d'une règle à une décision

Création de règles

Conception de règles

Définition de l'ordre d'évaluation des règles

Modification d'une règle dans une décision


Définition de l'ordre d'évaluation des règles

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Décision, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la décision apparaît.

  2. Cliquez sur la règle pour laquelle vous souhaitez modifier l'ordre d'évaluation.

  3. Dans la zone Ordre, cliquez sur la flèche HAUT ou BAS pour déplacer la règle afin de modifier son ordre d'apparition dans la liste.

Remarque

  • Il est recommandé de classer les règles par ordre de priorité. Les règles sont exécutées en séquence jusqu'à ce que l'une d'entre elles prenne la valeur TRUE. Le flux de processus est suivi pour la première règle qui prend la valeur TRUE. Si aucune règle ne prend la valeur TRUE, le flux Else est suivi.

Voir aussi

Ajout d'une règle à une décision

Création de règles

Suppression d'une règle dans une décision

Conception de règles

Modification d'une règle dans une décision


Définition des conditions de boucle Tant que

Cette section traite des procédures suivantes :

  • Ajout d'une règle à une boucle Tant que

  • Modification d'une règle dans une boucle Tant que

  • Suppression d'une règle dans une boucle Tant que

  • Conservation de l'état dans une boucle Tant que

Voir aussi

Création de règles

Conception de règles


Ajout d'une règle à une boucle Tant que

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Tant que à laquelle vous voulez ajouter une règle et cliquez sur Ajouter une règle.

    La boîte de dialogue Ajouter une règle s'affiche.

  2. Cliquez sur l'une des options suivantes :
    • Créer une règle

      Cliquez sur OK. La boîte de dialogue Propriétés de la règle s'affiche.

      Pour plus d'informations sur la création des règles, voir Création de règles.

    • Ajouter une règle existante

      Dans la liste Règles disponibles, sélectionnez la règle à ajouter et cliquez sur OK.

      La boîte de dialogue Ajouter une règle se ferme et la règle est ajoutée à la boucle Tant que.

Remarques

  • Lorsque vous ajoutez une règle pour la première fois à un schéma de planification XLANG en cliquant sur Ajouter une règle, la boîte de dialogue Propriétés de la règle s'affiche. La boîte de dialogue Ajouter une règle s'affiche uniquement si vous disposez de règles créées précédemment afin de les ajouter à une boucle Tant que. Pour plus d'informations sur la boîte de dialogue Propriétés de la règle, voir Création de règles.

  • Vous pouvez uniquement ajouter une règle à une boucle Tant que.

Voir aussi

Création de règles

Suppression d'une règle dans une boucle Tant que

Conception de règles

Modification d'une règle dans une boucle Tant que

Conservation de l'état dans une boucle Tant que


Modification d'une règle dans une boucle Tant que

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une règle contenue dans une forme Tant que, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la règle s'affiche.

  2. Effectuez les modifications souhaitées et cliquez sur OK.

    Pour plus d'informations sur la boîte de dialogue Propriétés de la règle, voir Création de règles.

Voir aussi

Ajout d'une règle à une boucle Tant que

Création de règles

Suppression d'une règle dans une boucle Tant que

Conception de règles

Conservation de l'état dans une boucle Tant que


Suppression d'une règle dans une boucle Tant que

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Tant que pour laquelle vous voulez supprimer une règle et cliquez sur Supprimer la règle.

Voir aussi

Ajout d'une règle à une boucle Tant que

Création de règles

Conception de règles

Modification d'une règle dans une boucle Tant que

Conservation de l'état dans une boucle Tant que


Conservation de l'état dans une boucle Tant que

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Tant que, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés Tant que s'affiche.

  2. Dans la zone Persistance de l'état, cliquez sur l'une des options suivantes :
    • Oui

      Les messages utilisés à chaque itération de boucle sont enregistrés comme des états de planification XLANG. Si la boucle appartient à une transaction qui échoue, une page En cas d'échec de Transaction ou Compensation pour Transaction est invoquée pour chaque itération de boucle achevée.

    • Non

      Seuls les messages utilisés lors de la dernière itération de boucle sont enregistrés comme états de planification XLANG. Si la boucle appartient à une transaction qui échoue, une page En cas d'échec de Transaction ou Compensation pour Transaction est invoquée une seule fois.

Voir aussi

Ajout d'une règle à une boucle Tant que

Création de règles

Suppression d'une règle dans une boucle Tant que

Conception de règles

Modification d'une règle dans une boucle Tant que


Création de règles

Cette section traite des procédures suivantes :

  • Création d'une règle

  • Utilisation de l'Assistant d'expression

  • Ajout de constantes à une règle

  • Suppression des règles inutilisées

Voir aussi

Conception de règles

Définition des conditions de décision

Définition des conditions de boucle Tant que


Création d'une règle

Vous pouvez créer des règles afin d'évaluer les conditions de vos processus professionnels. Les règles sont utilisées dans les décisions et les boucles Tant que dans une planification XLANG. Lorsque vous ajoutez une règle à une forme Décision ou Tant que, la boîte de dialogue Propriétés de la règle s'affiche.

  1. Dans la zone Nom de règle de la boîte de dialogue Propriétés de la règle, tapez le nom de la règle.

    Ce champ est obligatoire.

  2. Dans la zone Description de la règle, vous pouvez taper une description.

    Ce champ est facultatif.

  3. Vous devez positionner le curseur dans la zone Expression de script pour activer l'Assistant d'expression.

    Vous pouvez taper l'expression du script à utiliser ou faire appel à l'Assistant d'expression. Pour plus d'information sur l'utilisation de l'Assistant d'expression et la création d'expressions de script, voir Utilisation de l'Assistant d'expression.

Important

  • Comme le langage XML (Extensible Markup Language) respecte la casse, les expressions de script doivent utiliser la même casse que celles des messages et de leurs champs.

  • Vous devez positionner le curseur dans la zone Expression de script pour activer l'Assistant d'expression.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C (à l'adresse www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.
  • Les formes suivantes ne peuvent pas être nommées : Abandon, Début, Décision, Fin, Branche, Jointure et Tant que.

  • Le nom de règle le plus long détermine la largeur de la forme Décision ou Tant que dans laquelle la règle sera utilisée.

  • Vous pouvez ajouter des expressions de script à tout moment dans la zone Expression de script en positionnant le curseur à l'emplacement où vous voulez ajouter l'expression.

  • Vous ne pouvez pas créer d'expressions de script tant que vous n'avez pas créé les implémentations de ports et les communications de messages entre les actions et les ports.

  • Avant de compiler le schéma de planification XLANG dans une planification XLANG, vous devez compléter les expressions de script pour toutes les règles de la planification.

Voir aussi

Ajout de constantes à une règle

Conception de règles

Définition des conditions de décision

Définition des conditions de boucle Tant que

Utilisation de l'Assistant d'expression


Utilisation de l'Assistant d'expression

  1. Dans la zone Assistant d'expression de la boîte de dialogue Propriétés de la règle, cliquez sur un message dans la liste Message.

  2. Dans la zone Assistant d'expression, cliquez sur un champ dans la liste Champ.

  3. Cliquez sur Insérer.

  4. Dans la zone Expression de script, complétez l'expression.

    L'Assistant d'expression ajoute uniquement le message et le champ que vous avez sélectionnés. Pour évaluer l'expression de script, vous devez spécifier une condition pour la règle. Exemple :

    PORequest.Total < 500

    Vous pouvez également associer des expressions pour créer des conditions plus complexes. Exemple :

    PORequest.Total < 500 AND PORequest.Quantity < 20

Important

  • Comme le langage XML (Extensible Markup Language) respecte la casse, les expressions de script doivent utiliser la même casse que celles des messages et de leurs champs.

  • Vous devez positionner le curseur dans la zone Expression de script pour activer l'Assistant d'expression.

  • Les champs disponibles dans la liste Champ sont basés sur le message que vous avez sélectionné dans la liste Message. Seuls les champs contenus dans ce message peuvent être utilisés.

Remarques

  • La liste Message contient tous les messages et constantes disponibles dans la page Données.

  • Les règles peuvent utiliser les champs système fournis sur la page Données. Lorsqu'ils sont utilisés avec une règle, les champs système sont entre crochets. Exemple :

    Message1.[__Exists__]

    Pour plus d'informations sur les champs système, voir Gestion des données.

  • Vous pouvez utiliser les fonctions Microsoft® Visual Basic® telles que Date et Heure dans les règles.

  • Vous pouvez utiliser tous les opérateurs de comparaison d'expressions Visual Basic Scripting Edition (VBScript) dans les règles.

  • Vous pouvez ajouter des expressions de script à tout moment dans la zone Expression de script en positionnant le curseur à l'emplacement où vous voulez ajouter l'expression.

  • Avant de compiler le schéma de planification XLANG dans une planification XLANG, vous devez compléter les expressions de script pour toutes les règles de la planification.

Voir aussi

Ajout de constantes à une règle

Création d'une règle

Conception de règles

Définition des conditions de décision

Définition des conditions de boucle Tant que


Ajout de constantes à une règle

Vous pouvez ajouter des constantes aux expressions de script d'une règle. Pour utiliser des constantes, vous devez d'abord vous assurer qu'elles sont disponibles.

  1. Sur la page Données, ajoutez des constantes à la liste Constantes si aucune constante n'est indiquée.

    Pour plus d'informations sur l'utilisation des constantes et leur ajout à la liste Constantes, voir Utilisation des constantes.

  2. Dans la boîte de dialogue Propriétés de la règle, cliquez sur Constantes dans la liste Message.

  3. Dans la liste Champ, sélectionnez la constante à ajouter et cliquez sur Insérer.

Remarque

  • Toutes les constantes de la liste Constantes sur la page Données sont disponibles et peuvent être utilisées dans une règle.

Voir aussi

Création d'une règle

Conception de règles

Définition des conditions de décision

Définition des conditions de boucle Tant que

Utilisation de l'Assistant d'expression


Suppression des règles inutilisées

  • Dans le menu Outils, cliquez sur Supprimer les règles non utilisées.

Remarques

  • Cette procédure supprime les règles qui ne sont pas utilisées dans une décision ou dans une boucle Tant que de schéma de planification XLANG.

  • Seules les règles qui ne sont pas utilisées actuellement dans une forme Tant que ou Décision sont supprimées du schéma de planification XLANG. Les règles utilisées dans des formes Tant que ou Décision ne sont pas supprimées, même si elles ne sont pas connectées à d'autres formes.

Voir aussi

Ajout de constantes à une règle

Création d'une règle

Utilisation de l'Assistant d'expression


Définition des propriétés de simultanéité

Cette section traite des procédures suivantes :

  • Création de flux concurrents

  • Définition de la propriété Type de jointure

  • Jointure de flux concurrents

  • Fin d'un flux concurrent

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.


Création de flux concurrents

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme Branche.

  2. Connectez la poignée de contrôle inférieure ( [image]) de la forme Branche au point de connexion supérieur ( [image]) d'une branche successive dans le flux du processus professionnel.

  3. Répétez les étapes 1 et 2 pour créer des flux concurrents supplémentaires.

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.

Remarques

  • Seul un flux peut entrer dans une forme Branche à partir du point de connexion supérieur.

  • Un maximum de 64 flux peut sortir d'une forme Branche afin d'exécuter des processus concurrents.

  • Vous devez cliquer sur la forme Branche pour la sélectionner et activer la poignée de contrôle chaque fois que vous voulez créer un flux complémentaire.

    –Ou–

    Si vous voulez créer plusieurs flux concurrents, vous pouvez utiliser l'outil de connexion pour les ajouter plus rapidement. Pour plus d'informations sur l'outil de connexion, voir Utilisation de l'outil de connexion.

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Connexion de deux formes

Fin d'un flux concurrent

Jointure de flux concurrents

Choix d'une forme

Définition de la propriété Type de jointure

Utilisation de l'outil de connexion


Définition de la propriété Type de jointure

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit de la souris sur une forme Jointure, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la jointure s'affiche.

  2. Dans la liste Type de jointure, cliquez sur l'une des options suivantes :
    • AND

    • OR

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.

Remarque

  • Si vous sélectionnez l'option de jointure OR, une seule action peut être associée au flux pour tous les flux qui entrent dans la jointure.

Voir aussi

Création de flux concurrents

Fin d'un flux concurrent

Jointure de flux concurrents


Jointure de flux concurrents

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme du processus professionnel qui exécute un processus concurrent.

  2. Connectez la poignée de contrôle inférieure ( [image]) de la forme au point de connexion supérieur ( [image]) de la forme Jointure.

  3. Répétez les étapes 1 et 2 pour tous les flux concurrents qui rejoignent cette jointure.

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.

Remarques

  • Si vous sélectionnez l'option de jointure OR, une seule action peut être associée au flux pour tous les flux qui entrent dans la jointure.

  • Un maximum de 64 flux peut entrer dans une forme Jointure au point de connexion supérieur.

  • Seul un flux peut sortir d'une forme Jointure à partir du point de connexion inférieur.

  • Si vous voulez effectuer une jointure entre plusieurs flux concurrents, vous pouvez utiliser l'outil de connexion pour les joindre plus rapidement. Pour plus d'informations sur l'outil de connexion, voir Utilisation de l'outil de connexion.

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Connexion de deux formes

Création de flux concurrents

Fin d'un flux concurrent

Choix d'une forme

Définition de la propriété Type de jointure

Utilisation de l'outil de connexion


Fin d'un flux concurrent

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme du processus professionnel qui exécute un processus concurrent.

  2. Connectez la poignée de contrôle inférieure ( [image]) de la forme au point de connexion supérieur ( [image]) de la forme Fin.

    Ce processus concurrent s'arrête. Il ne rejoint pas les autres flux de la planification XLANG.

Important

  • Pour plus d'informations sur les processus concurrents, voir Conception concurrentielle.

Remarque

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Connexion de deux formes

Création de flux concurrents

Jointure de flux concurrents

Choix d'une forme

Définition de la propriété Type de jointure

Utilisation de l'outil de connexion


Définition des propriétés de transaction

Cette section traite des rubriques suivantes :

  • Définition des propriétés transactionnelles d'une planification XLANG

  • Définition des propriétés transactionnelles individuelles

  • Description de la prise en charge de transaction de composant et de Message Queuing

Voir aussi

Conception de transactions


Définition des propriétés transactionnelles d'une planification XLANG

Cette section traite des procédures suivantes :

  • Définition du modèle de transaction

  • Définition de la propriété d'activation de la transaction

Voir aussi

Conception de transactions


Définition du modèle de transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la forme Début, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de début s'affiche.

  2. Dans la liste Modèle de transaction, choisissez l'une des options suivantes :
    • Inclure des transactions dans la planification XLANG

      Cette option permet à une planification XLANG d'utiliser des transactions.

    • Traiter la planification XLANG en tant que composant COM+

      Cette option désactive la prise en charge des transactions d'une planification XLANG. Un composant COM peut alors activer la planification XLANG dans une transaction COM+.

Remarques

  • Si la propriété Modèle de transaction correspond à Traiter la planification XLANG en tant que composant COM+, la liste Activation de la transaction est activée.

  • Si la propriété Modèle de transaction correspond à Traiter la planification XLANG en tant que composant COM+, n'ajoutez pas de transaction au schéma de planification XLANG. Auquel cas, la compilation du schéma de planification XLANG ne s'effectuera pas et vous obtiendrez un message d'erreur.

  • La propriété Identité XLANG est un identificateur unique utilisé pour différencier les versions d'un schéma de planification XLANG. Cette propriété est en lecture seule et ne peut pas être modifiée. Lorsque vous mettez à jour un schéma de planification XLANG, cette identité est également mise à jour.

    Vous pouvez utiliser la propriété Identité XLANG pour faire correspondre les versions d'un schéma de planification XLANG (.skv) à la planification XLANG associée qui est compilée (.skx).

  • La forme Début figure sur les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. La forme Début n'est pas disponible dans la page Données.

Voir aussi

Description de la prise en charge de transaction de composant et de Message Queuing

Conception de transactions

Définition de la propriété d'activation de la transaction


Définition de la propriété d'activation de la transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la forme Début, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de début s'affiche.

  2. Dans la liste Modèle de transaction, cliquez sur Traiter la planification XLANG en tant que composant COM+.

    Si cette option est activée, les services Composant traitent la planification XLANG en tant que composant COM+. Cette option désactive la prise en charge des transactions d'une planification XLANG. Un composant COM peut alors activer la planification XLANG dans une transaction COM+.

  3. Dans la liste Activation de la transaction, choisissez l'une des options suivantes :
    • Non pris en charge

      Le cas échéant, la planification XLANG ignore la transaction dans le contexte d'objets COM+ de son auteur. Aucune action de la planification n'est exécutée dans l'étendue d'une transaction.

    • Pris en charge

      La planification XLANG participe à une transaction COM+ si une transaction fait partie du contexte d'objets COM+ de son auteur.

    • Requis

      La planification XLANG doit être exécutée dans l'étendue d'une transaction. Si aucune transaction n'est présente dans le contexte d'objets COM+ de l'auteur de la planification, une transaction est automatiquement créée et utilisée par le moteur de XLANG Scheduler.

    • Requiert une nouvelle

      La planification XLANG doit être exécutée dans l'étendue d'une nouvelle transaction. Le moteur de XLANG Scheduler crée automatiquement une nouvelle transaction pour la planification, distincte de toutes les transactions présentes dans le contexte d'objets COM+ de son auteur.

Remarques

  • La propriété Identité XLANG est un identificateur unique utilisé pour différencier les versions d'un schéma de planification XLANG. Cette propriété est en lecture seule et ne peut pas être modifiée. Lorsque vous mettez à jour un schéma de planification XLANG, cette identité est également mise à jour.

    Vous pouvez utiliser la propriété Identité XLANG pour faire correspondre les versions d'un schéma de planification XLANG (.skv) à la planification XLANG associée qui est compilée (.skx).

  • La forme Début est disponible sur les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. La forme Début n'est pas disponible dans la page Données.

Voir aussi

Description de la prise en charge de transaction de composant et de Message Queuing

Conception de transactions

Définition du modèle de transaction


Définition de propriétés transactionnelles individuelles

Cette section traite des procédures suivantes :

  • Actions et flux de groupe d'une transaction

  • Conception de transactions imbriquées

  • Création de flux de transaction entrants et sortants

  • Affectation d'un nom à une transaction

  • Définition de la propriété Type de transaction

  • Définition de la propriété Délai d'attente

  • Définition de la propriété Nombre de tentatives

  • Définition de la propriété Intervalle

  • Définition de la propriété Niveau d'isolation

  • Définition de la propriété Maintenir l'état de la planification

Voir aussi

Conception de transactions


Actions et flux de groupe d'une transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Transaction d'un stencil Diagramme de flux vers le côté gauche de la barre de séparation.

  2. Redimensionnez la forme Transaction afin d'entourer les formes à inclure dans la transaction.

Remarques

  • Les formes ou flux contenus dans les limites d'une transaction sont considérés comme faisant partie intégrante de cette transaction.

  • Pour sélectionner une forme dans une transaction, cliquez sur la forme.

  • Si vous supprimez une transaction contenant des formes dans ses limites, toutes les formes seront également supprimées.

  • Les types de transaction sont indiqués par les couleurs suivantes :
    • Bleu. Indique des transactions minutées.

    • Beige. Cette couleur indique des transactions de longue durée.

    • Gris. Cette couleur indique des transactions de courte durée, de style DTC.
  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction, et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Création de flux de transaction entrants et sortants

Conception de transactions

Conception de transactions imbriquées

Affectation d'un nom à une transaction


Conception de transactions imbriquées

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Transaction d'un stencil Diagramme de flux dans les limites de la transaction en cours.

  2. Redimensionnez la forme Transaction afin d'intégrer les formes à inclure dans la transaction.

Important

  • Lorsque vous créez des transactions imbriquées, certaines propriétés de transactions externes sont désactivées :
    • Le type de transaction Style DTC, courte n'est pas disponible.

    • Aucune option de la zone Options de transactions n'est disponible.

    • La propriété Délai est encore active, mais elle ne peut pas être modifiée une fois que vous avez créé une transaction imbriquée, sauf si le type de transaction correspond à Transaction minutée.

Remarques

  • Les formes ou flux contenus dans les limites d'une transaction sont considérés comme faisant partie intégrante de cette transaction.

  • Pour sélectionner une forme dans une transaction, cliquez sur la forme.

  • Si vous supprimez une transaction contenant des formes dans ses limites, toutes les formes seront également supprimées.

  • Les types de transaction sont indiqués par les couleurs suivantes :
    • Bleu. Indique des transactions minutées.

    • Beige. Cette couleur indique des transactions de longue durée.

    • Gris. Cette couleur indique des transactions de courte durée, de style DTC.
  • Les formes Diagramme de flux qui ne font pas partie d'une transaction interne sont considérées comme faisant partie d'une transaction externe.

  • Les formes Diagramme de flux contenues dans une transaction externe peuvent être masquées partiellement par une transaction interne superposée, si elles ne font pas partie intégrante de la transaction interne. Sélectionnez ces formes et repositionnez-les de façon à ce qu'elles ne se superposent pas.

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction, et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Création de flux de transaction entrants et sortants

Conception de transactions

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction


Création de flux de transaction entrants et sortants

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme qui précède une transaction dans le flux des processus professionnels.

  2. Connectez la poignée de contrôle inférieure ( [image]) de la forme au point de connexion supérieur ( [image]) de la forme Transaction.

  3. Cliquez sur la forme Transaction pour la sélectionner.

  4. Connectez la poignée de contrôle supérieure de la forme Transaction au point de connexion supérieur de la première forme de la transaction qui correspond au début du flux de transactions.

  5. À partir de cette forme, connectez le flux à la forme suivante de la transaction.

  6. Connectez tous les flux de la transaction et toutes actions aux ports pour lesquels vous voulez créer un flux de communication.

  7. À partir de la poignée de contrôle inférieure de la dernière forme de la transaction, connectez le flux au point de connexion inférieur de la forme Transaction.

  8. Cliquez sur la forme Transaction pour la sélectionner.

  9. Connectez la poignée de contrôle inférieure de la forme Transaction au point de connexion supérieur de la forme suivante du processus professionnel situé hors de la transaction.

Remarques

  • Pour sélectionner une forme dans une transaction, cliquez sur la forme.

  • Vous pouvez ajouter des formes Diagramme de flux aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les formes Diagramme de flux ne sont pas disponibles dans la page Données.

Voir aussi

Ajout, suppression et connexion de formes

Connexion de deux formes

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Utilisation de l'outil de connexion


Affectation d'un nom à une transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Nom, tapez un nom pour la transaction.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C (à l'adresse www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.
  • Les noms de transactions dans les jeux de caractères codés sur un octet ne peuvent pas excéder 16 caractères. Les noms de transactions dans les jeux de caractères codés sur deux octets ne peuvent pas excéder 8 caractères.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Définition de la propriété Maintenir l'état de la planification

Définition de la propriété Intervalle

Définition de la propriété Niveau d'isolation

Définition de la propriété Nombre de tentatives

Définition de la propriété Délai d'attente

Définition de la propriété Type de transaction


Définition de la propriété Type de transaction

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Type, cliquez sur l'une des options suivantes :
    • Transaction minutée

    • Style DTC, courte

    • Longue

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Maintenir l'état de la planification

Définition de la propriété Intervalle

Définition de la propriété Niveau d'isolation

Définition de la propriété Nombre de tentatives

Définition de la propriété Délai d'attente


Définition de la propriété Délai d'attente

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Délai d'attente de la zone Options de transactions, entrez un délai en secondes.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Maintenir l'état de la planification

Définition de la propriété Intervalle

Définition de la propriété Niveau d'isolation

Définition de la propriété Nombre de tentatives

Définition de la propriété Type de transaction


Définition de la propriété Nombre de tentatives

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Nombre de tentatives de la zone Options de transactions, entrez le nombre de fois où une transaction peut être tentée avant de pouvoir considérer qu'elle a échoué.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Maintenir l'état de la planification

Définition de la propriété Intervalle

Définition de la propriété Niveau d'isolation

Définition de la propriété Délai d'attente

Définition de la propriété Type de transaction


Définition de la propriété Intervalle

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Intervalle de la zone Options de transactions, entrez un délai en secondes.

Remarque

  • La propriété Intervalle détermine l'intervalle entre chaque tentative de transaction. Cette option est uniquement disponible pour les transactions de Style DTC, courtes. L'intervalle est utilisé avec la valeur du nombre de tentatives pour déterminer le délai avant la prochaine tentative de la transaction. La valeur de l'intervalle est exponentielle. Une valeur d'intervalle de 2 secondes correspond à un délai de 2, 4, 8, 16 secondes, et ainsi de suite, entre les tentatives. La formule est BR (B élevé à la puissance R), où B = intervalle et R = nombre de tentatives.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Maintenir l'état de la planification

Définition de la propriété Niveau d'isolation

Définition de la propriété Nombre de tentatives

Définition de la propriété Délai d'attente

Définition de la propriété Type de transaction


Définition de la propriété Niveau d'isolation

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la liste Niveau d'isolation de la zone Options de transactions, cliquez sur l'une des options suivantes :
    • Serializable

    • Read Uncommitted

    • Read Committed

    • Repeatable Read

Remarque

  • Cette propriété ne peut être définie que pour des transactions de style DTC, courtes.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Maintenir l'état de la planification

Définition de la propriété Intervalle

Définition de la propriété Nombre de tentatives

Définition de la propriété Délai d'attente

Définition de la propriété Type de transaction


Définition de la propriété Maintenir l'état de la planification

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Options de transactions, activez ou désactivez la case à cocher Maintenir l'état de la planification.

Remarque

  • Cette propriété ne peut pas être modifiée pour les transactions de courte durée, de style DTC, car leur état est toujours maintenu.

Voir aussi

Conception de transactions

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Affectation d'un nom à une transaction

Définition de la propriété Niveau d'isolation

Définition de la propriété Intervalle

Définition de la propriété Nombre de tentatives

Définition de la propriété Délai d'attente

Définition de la propriété Type de transaction


Description de la prise en charge de transaction de composant et de Message Queuing

Cette section traite des procédures suivantes :

  • Description du niveau de prise en charge des transactions dans un composant COM

  • Description du niveau de prise en charge de transaction dans un composant de script Windows

  • Description du niveau de prise en charge de transaction dans une file d'attente de messages

Voir aussi

Conception de transactions

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Description du niveau de prise en charge des transaction dans un composant COM

BizTalk Server 2002 ~ Conception des orchestrations BizTalk

Description du niveau de prise en charge des transactions dans un composant COM

La prise en charge des transactions pour les composants COM est définie dans l'Assistant Liaison de composants COM.

  1. Ouvrez l'Assistant Liaison de composants COM.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port à l'aide d'un composant COM.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Prise en charge des transactions de la page Propriétés avancées du port, cliquez sur l'une des options suivantes :
    • Désactivé

      La prise en charge des transactions pour le composant COM+ utilisé par cette implémentation de port est désactivée.

    • Non pris en charge

      Le composant COM+ utilisé par cette implémentation de port ne prend pas en charge les transactions.

    • Pris en charge

      Le composant COM+ utilisé par cette implémentation de port hérite d'une transaction existante.

    • Requis

      Le composant COM+ utilisé par cette implémentation de port peut hériter d'une transaction existante ou utiliser une nouvelle transaction.

    • Requiert une nouvelle

      Le composant COM+ utilisé par cette implémentation de port requiert une nouvelle transaction.

Voir aussi

Ajout d'un port lié à un schéma de planification XLANG

Conception de transactions

Implémentation d'un port à l'aide d'un composant COM

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Description du niveau de prise en charge des transaction dans un composant de script Windows

La prise en charge des transactions pour les composants de script Windows est définie dans l'Assistant Liaison de composants de script.

  1. Ouvrez l'Assistant Liaison de composants de script.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port à l'aide d'un composant de script Windows.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Prise en charge des transactions de la page Propriétés avancées du port, cliquez sur l'une des options suivantes :
    • Désactivé

      La prise en charge des transactions pour le composant COM+ utilisé par cette implémentation de port est désactivée.

    • Non pris en charge

      Le composant COM+ utilisé par cette implémentation de port ne prend pas en charge les transactions.

    • Pris en charge

      Le composant COM+ utilisé par cette implémentation de port hérite d'une transaction existante.

    • Requis

      Le composant COM+ utilisé par cette implémentation de port peut hériter d'une transaction existante ou utiliser une nouvelle transaction.

    • Requiert une nouvelle

      Le composant COM+ utilisé par cette implémentation de port requiert une nouvelle transaction.

Voir aussi

Ajout d'un port lié à un schéma de planification XLANG

Conception de transactions

Implémentation d'un port à l'aide d'un composant de script Windows

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Description du niveau de prise en charge des transactions dans une file d'attente de messages

La prise en charge des transactions pour les files d'attente de messages est définie dans l'Assistant Liaison de Message Queuing.

  1. Ouvrez l'Assistant Liaison de Message Queuing.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port à l'aide de Message Queuing.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Prise en charge de la transaction de la page Propriétés avancées du port, activez ou désactivez la case à cocher Des transactions sont requises avec cette file d'attente.

Voir aussi

Ajout d'un port lié à un schéma de planification XLANG

Conception de transactions

Implémentation d'un port à l'aide de Message Queuing

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Définition des propriétés de gestion d'erreurs

Cette section traite des procédures suivantes :

  • Abandon d'un flux de processus

  • Activation de la gestion d'erreur de transaction

  • Activation de la gestion d'erreur de composant

Voir aussi

Gestion des exceptions


Abandon d'un flux de processus

  1. Dans le stencil Diagramme de flux du Concepteur d'Orchestration BizTalk, cliquez sur la forme Abandon et faites-la glisser vers la page de conception.

  2. Connectez le flux de processus d'une branche logique qui existe dans une forme Décision au point de connexion ( [image]) de la forme Abandon.

Important

  • Les formes Abandon sont utilisées afin d'abandonner un processus professionnel dans une branche logique. Elles sont combinées aux décisions.

    L'utilisation de la forme Abandon dépend des besoins de vos processus professionnels. Les règles comprises dans une décision sont évaluées jusqu'à ce que l'une d'entre elles prenne la valeur TRUE. Si une règle prend la valeur TRUE, le flux du processus continue jusqu'à l'action suivante. Si aucune règle ne prend la valeur TRUE, vous pouvez abandonner le flux du processus.

    L'exemple suivant illustre une condition décisionnelle où, si la règle prend la valeur TRUE, le flux de processus continue jusqu'à l'Action 3. Dans le cas contraire, le flux de processus est abandonné.

Voir aussi

Activation de la gestion d'erreur de composant

Activation de la gestion d'erreur de transaction

Gestion des exceptions

Branchement logique


Activation de la gestion d'erreur de transaction

Cette section traite des procédures suivantes :

  • Activation de la gestion d'erreur En cas d'échec

  • Activation de la gestion d'erreur de compensation

Voir aussi

Abandon d'un flux de processus

Gestion des exceptions


Activation de la gestion d'erreur En cas d'échec

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme Transaction, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone En cas d'échec, cliquez sur Ajouter un code.

  3. Dans la zone En cas d'échec, activez la case à cocher Activé.

Remarques

  • Si vous cliquez sur le bouton Ajouter un code, vous créez la page En cas d'échec de Transaction associée à cette transaction. Le paramètre Transaction, dans le nom de la page, est remplacé par le nom de la transaction à laquelle le processus de gestion d'erreur est associé.

  • Si vous activez la case à cocher Activé, la planification XLANG est activée afin d'exécuter le code En cas d'échec de cette transaction. Si vous n'activez pas cette case à cocher, vous pouvez créer des processus En cas d'échec, mais ils ne s'exécuteront pas lors de l'exécution de la planification XLANG.

Voir aussi

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Gestion des exceptions


Activation de la gestion d'erreur de compensation

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur une forme interne Transaction d'un groupe de transactions imbriquées, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de la transaction s'affiche.

  2. Dans la zone Compensation, cliquez sur Ajouter un code.

  3. Dans la zone Compensation, activez la case à cocher Activé.

Remarques

  • Si vous cliquez sur le bouton Ajouter un code, vous créez la page En cas d'échec de Transaction ou Compensation pour Transaction associée à cette transaction.

  • Si vous activez la case à cocher Activé, la planification XLANG est activée afin d'exécuter le code En cas d'échec ou Compensation de cette transaction. Si vous n'activez pas cette case à cocher, vous pouvez créer un processus En cas d'échec ou Compensation, mais il ne s'exécute pas lors de l'exécution de la planification XLANG.

  • Le paramètre Transaction, dans le nom de la page, est remplacé par le nom de la transaction à laquelle le processus de gestion d'erreur est associé.

  • Les types de transaction sont indiqués par les couleurs suivantes :
    • Bleu. Indique des transactions minutées.

    • Beige. Cette couleur indique des transactions de longue durée.

    • Gris. Cette couleur indique des transactions de courte durée, de style DTC.

Voir aussi

Conception de transactions imbriquées

Actions et flux de groupe d'une transaction

Gestion des exceptions


Activation de la gestion d'erreur de composant

Cette section traite des procédures suivantes :

  • Abandon d'une transaction si un composant renvoie un échec

  • Abandon d'une transaction si un composant de script Windows renvoie un échec

Voir aussi

Abandon d'un flux de processus

Gestion des exceptions


Abandon d'une transaction si un composant renvoie un échec

La prise en charge des transactions pour les composants COM est définie dans l'Assistant Liaison de composants COM.

  1. Ouvrez l'Assistant Liaison de composants COM.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port à l'aide d'un composant COM.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Gestion d'erreur de la page Propriétés avancées du port, activez la case à cocher Abandonner la transaction si la méthode renvoie un HRESULT d'échec.

Important

  • Cette option détermine si les transactions DTC de courte durée dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT.

    Cette option ne peut être définie que si l'action de communication utilisant ce port se trouve dans le flux de processus d'une transaction.

Voir aussi

Abandon d'une transaction si un composant de script Windows renvoie un échec

Ajout d'un port lié à un schéma de planification XLANG

Gestion des exceptions

Implémentation d'un port à l'aide d'un composant COM

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Abandon d'une transaction si un composant de script Windows renvoie un échec

La prise en charge des transactions pour les composants de script Windows est définie dans l'Assistant Liaison de composants de script.

  1. Ouvrez l'Assistant Liaison de composants de script.

    Pour plus d'informations sur cet Assistant, voir Implémentation d'un port à l'aide d'un composant de script Windows.

  2. Suivez les instructions de l'Assistant jusqu'à la page Propriétés avancées du port.

  3. Dans la zone Gestion d'erreur de la page Propriétés avancées du port, activez la case à cocher Abandonner la transaction si la méthode renvoie un HRESULT d'échec.

Important

  • Cette option détermine si les transactions dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT.

    Cette option ne peut être définie que si l'action de communication utilisant ce port se trouve dans le flux de processus d'une transaction.

Voir aussi

Abandon d'une transaction si un composant renvoie un échec

Ajout d'un port lié à un schéma de planification XLANG

Gestion des exceptions

Implémentation d'un port à l'aide d'un composant de script Windows

Modification des propriétés d'implémentation d'un port

Définition de la propriété d'activation de la transaction

Définition du modèle de transaction


Implémentation de ports

Le Concepteur d'Orchestration BizTalk intègre quatre formes Implémentation qui représentent les technologies susceptibles d'être utilisées pour implémenter les communications des ports. Ces formes sont présentées au tableau suivant.

Nom de la forme | Description
Composant COM | La forme Composant COM représente une technologie pouvant servir à implémenter un port à l'aide d'un appel de méthode pour chaque message envoyé ou reçu. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison de composants COM.
Composant de script Composant de script | La forme Composant de script représente une technologie pouvant être utilisée pour implémenter un port en ayant recours à un appel de méthode pour chaque message envoyé ou reçu. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison des composants de script.
Message Queuing | La forme Message Queuing représente une technologie pouvant être utilisée pour implémenter un port. Les services Message Queuing sont utilisés pour envoyer ou recevoir des messages. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison de Message Queuing.
Échanges BizTalk | La forme Échanges BizTalk représente une technologie pouvant être utilisée pour implémenter un port. Les services d'échanges BizTalk sont utilisés pour envoyer ou recevoir des messages. Un port d'échanges ou un canal BizTalk Server peut être utilisé pour implémenter un port. Faites glisser cette forme du côté droit de la barre de séparation pour ouvrir l'Assistant Liaison d'échanges BizTalk.

Cette section traite des procédures suivantes :

  • Ajout d'un port non lié à un schéma de planification XLANG

  • Ajout d'un port lié à un schéma de planification XLANG

  • Implémentation d'un port à l'aide d'un composant COM

  • Implémentation d'un port à l'aide d'un composant de script Windows

  • Implémentation d'un port à l'aide de Message Queuing

  • Implémentation d'un port à l'aide d'Échanges BizTalk

  • Modification des propriétés d'implémentation d'un port

Voir aussi

Formes Communication

Formes Diagramme de flux

Formes Implémentation

Implémentation de processus professionnels

Correspondance entre un message et un port

Envoi ou réception de messages

Description des implémentations de ports

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Ajout d'un port non lié à un schéma de planification XLANG

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la barre de séparation, puis cliquez sur Ajouter un nouveau port.

Remarques

  • Vous pouvez ajouter un port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les ports ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement sur la page Données lorsque vous créez un nouveau port.

  • Vous pouvez implémenter un port non lié à l'aide de Message Queuing ou d'Échanges BizTalk. Lorsque vous ajoutez l'une de ces implémentations à une page, l'Assistant Implémentation fournit l'option permettant de sélectionner les ports non liés disponibles.

Voir aussi

Implémentation d'un port à l'aide d'un composant COM

Implémentation d'un port à l'aide d'un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Correspondance entre un message et un port

Modification des propriétés d'implémentation d'un port

Envoi ou réception de messages


Ajout d'un port lié à un schéma de planification XLANG

  • Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Implémentation du stencil Implémentation vers le côté droit de la barre de séparation et suivez les étapes de l'Assistant relatives à cette implémentation.

Remarques

  • Vous pouvez ajouter un port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les ports ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement sur la page Données lorsque vous créez un port.

Voir aussi

Implémentation d'un port à l'aide d'un composant COM

Implémentation d'un port à l'aide d'un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Correspondance entre un message et un port

Modification des propriétés d'implémentation d'un port

Envoi ou réception de messages


Implémentation d'un port à l'aide d'un composant COM

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Composant COM d'un stencil Implémentation vers le côté droit de la barre de séparation.

    L'Assistant Liaison de composants COM s'ouvre.

  2. Sur la page Bienvenue dans l'Assistant de Liaison de composants COM, tapez un nom pour le port que vous voulez créer, puis cliquez sur Suivant.

    Le Concepteur d'Orchestration BizTalk fournit par défaut un nom de port associé à un numéro pour chacune des nouvelles implémentations de port ajoutées. Vous pouvez modifier ce nom.

  3. Sur la page Communication statique ou dynamique, cliquez sur l'une des options suivantes :
    • Statique

      Le moteur de XLANG Scheduler instancie ce composant.

      Si vous cliquez sur l'option Statique, le composant est automatiquement détruit à la fin de l'instance de planification XLANG.

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • Curseur dynamique

      Si vous sélectionnez cette option, une autre application instancie le composant. Un moniker ou un pointeur vers l'instance de l'objet doit être renvoyé à la planification XLANG en tant que champ d'un message. Sur la page Données, une connexion doit être établie entre ce champ de message et la référence de port du port utilisant cette implémentation. Pour plus d'informations sur l'envoi d'un message vers un port spécifique, voir Correspondance entre un message et un port.

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

    • Aucune instanciation

      Sélectionnez cette option uniquement pour recevoir des données. Cette option indique que les données sont transmises à une planification XLANG à l'aide d'une méthode ; toutefois, le code sur lequel repose l'appel de la méthode ne sera pas exécuté. Pour plus d'informations, voir Gestion des données.

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

    Pour plus d'informations sur les communications statiques et dynamiques, consultez les rubriques suivantes :

    • Ports statiques et dynamiques

    • Gestion des instances

    • Utilisation de la forme Composant de script
  4. Sur la page Informations sur les cours, cliquez sur l'une des options suivantes :
    • À partir d'un composant enregistré

      Un contrôle arborescent affiche tous les composants enregistrés sur votre ordinateur. Développez le dossier du cours approprié, puis cliquez sur le cours.

      Cliquez sur Suivant.

    • À partir d'un moniker

      Tapez le nom d'un moniker COM standard afin de spécifier l'emplacement du composant COM que vous voulez instancier. Si vous activez cette option, le composant COM ne peut pas être utilisé avec les communications internes d'une transaction dans la planification XLANG.

      Cliquez sur Suivant.

  5. Sur la page Informations d'interface, cliquez sur l'interface à utiliser, puis cliquez sur Suivant.

    Remarques

    • Si un composant COM dispose d'une seule interface, cette page est ignorée.

    • Si le composant COM a été créé dans Microsoft Visual Basic, il existe une interface du même nom pour chaque cours du composant. Chaque nom d'interface est précédé d'un trait de soulignement (_).
  6. Sur la page Informations sur la méthode, sélectionnez les méthodes à utiliser et cliquez sur Suivant.

    Remarques

    • Si un composant COM dispose d'une seule méthode, cette page est ignorée.

    • Vous devez sélectionner au moins une méthode.

    • Vous pouvez sélectionner plusieurs méthodes ou toutes les méthodes. Vous pouvez sélectionner ou désélectionner l'ensemble des méthodes à l'aide des boutons Sélectionner tout et Désélectionner tout.
  7. Sur la page Propriétés avancées du port, dans la zone Sécurité, cliquez sur l'une des options suivantes :
    • Non requise

      Aucune tentative pour confirmer l'identité de l'expéditeur.

    • Facultatif

      Le moteur de XLANG Scheduler requiert l'identité de l'expéditeur. L'exécution de la planification XLANG se poursuit, que l'identité soit disponible ou non.

    • Requis

      Le moteur de XLANG Scheduler requiert l'identité de l'expéditeur. L'identité de l'expéditeur est requise et la planification XLANG ignore le message si l'identité n'est pas disponible.

    Remarque

    • Si la planification XLANG rejette un appel de méthode entrant lorsque l'identité est requise mais non disponible, le code d'erreur E_ACCESSDENIED est renvoyé à l'appelant.
  8. Dans la zone Prise en charge des transactions de la page Propriétés avancées du port, cliquez sur l'une des options suivantes :
    • Désactivé

      La prise en charge des transactions pour le composant COM+ utilisé par cette implémentation de port est désactivée.

    • Non pris en charge

      Le composant COM+ utilisé par cette implémentation de port ne prend pas en charge les transactions.

    • Pris en charge

      Le composant COM+ utilisé par cette implémentation de port hérite d'une transaction existante.

    • Requis

      Le composant COM+ utilisé par cette implémentation de port peut hériter d'une transaction existante ou utiliser une nouvelle transaction.

    • Requiert une nouvelle

      Le composant COM+ utilisé par cette implémentation de port requiert une nouvelle transaction.

  9. Sur la page Propriétés avancées du port, dans la zone Prise en charge de la gestion des états, cliquez sur l'une des options suivantes :
    • Ne possède pas d'état

      Le composant utilisé par cette implémentation de port ne possède pas d'état pour les appels de méthodes.

    • Possède un état mais ne prend pas en charge la persistance

      Le composant utilisé par cette implémentation de port possède un état pendant la durée de vie du composant, mais le composant ne peut pas être persistant.

    • Possède un état et prend en charge la persistance

      Le composant utilisé par cette implémentation de port possède un état et peut être enregistré à l'aide de l'interface IPersistStream ou IPersistStreamInit. L'interface IpersistStream ou IpersistStreamInit permet d'enregistrer l'état du composant pour des instanciations ultérieures et de recréer le composant à l'aide de cet état enregistré.

  10. Dans la zone Gestion d'erreur de la page Propriétés avancées du port, activez ou désactivez la case à cocher Abandonner la transaction si la méthode renvoie un HRESULT d'échec.

    Important

    • Cette option détermine si les transactions dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT.

      Cette option peut être définie uniquement si l'action de communication utilisant ce port se trouve dans un flux de processus d'une transaction.

  11. Cliquez sur Terminer.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C (à l'adresse www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Vous pouvez ajouter des implémentations de port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Un nouveau port est toujours créé afin d'être utilisé avec une implémentation de composants COM.

  • Si vous modifiez une implémentation de port existante, sur la première page de l'Assistant Implémentation, vous pouvez renommer le port à l'aide de l'option Renommer le port actuel.

Voir aussi

Implémentation d'un port à l'aide d'un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Formes Implémentation

Implémentation de processus professionnels

Correspondance entre un message et un port

Modification des propriétés d'implémentation d'un port

Description des implémentations de ports

Utilisation de la forme Composant COM

Utilisation de l'Assistant Communication de méthodes


Implémentation d'un port à l'aide d'un composant de script Windows

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Composant de script d'un stencil Implémentation vers le côté droit de la barre de séparation.

    L'Assistant Liaison des composants de script s'ouvre.

  2. Sur la page Assistant Liaison de composants de script, tapez un nom pour le port que vous voulez créer, puis cliquez sur Suivant.

    Le Concepteur d'Orchestration BizTalk fournit par défaut un nom de port associé à un numéro pour chacune des nouvelles implémentations de port ajoutées. Vous pouvez modifier ce nom.

  3. Sur la page Communication statique ou dynamique, cliquez sur l'une des options suivantes, puis sur Suivant :
    • Statique

      Le moteur de XLANG Scheduler instancie ce composant.

      Si vous cliquez sur l'option Statique, le composant est automatiquement détruit à la fin de l'instance de planification XLANG.

    • Curseur dynamique

      Si vous sélectionnez cette option, une autre application instancie le composant. Un moniker ou un pointeur vers l'instance de l'objet doit être renvoyé à la planification XLANG en tant que champ d'un message. Sur la page Données, une connexion doit être établie entre ce champ de message et la référence de port du port utilisant cette implémentation. Pour plus d'informations sur l'envoi d'un message vers un port spécifique, voir Correspondance entre un message et un port.

    • Aucune instanciation

      Sélectionnez cette option uniquement pour recevoir des données. Cette option indique que les données sont transmises à la planification XLANG à l'aide d'une méthode ; toutefois, le code sur lequel repose l'appel de la méthode ne sera pas exécuté.

    Pour plus d'informations sur les communications statiques et dynamiques, consultez les rubriques suivantes :

    • Ports statiques et dynamiques

    • Gestion des instances

    • Utilisation de la forme Composant de script
  4. Sur la page Sélectionnez le fichier de script, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un fichier de script s'affiche.

  5. Recherchez l'emplacement du fichier .wsc que vous voulez utiliser, cliquez sur le fichier, puis sur Ouvrir.

  6. Cliquez sur Suivant, puis continuez en procédant comme suit :
    • Si vous avez sélectionné Statique à l'étape 3, passez à l'étape 7 de cette procédure.

    • Si vous avez sélectionné Dynamique ou Aucune instanciation à l'étape 3, passez à l'étape 8 de cette procédure.
  7. Sur la page Informations sur l'instanciation du composant, cliquez sur l'une des options ci-dessous, puis cliquez sur Suivant :
    • Utiliser un moniker du fichier de script

      Le chemin d'accès et le nom du fichier de script sont automatiquement fournis comme moniker.

    • Utiliser Prog ID "Prog ID"

      Le Prog ID est fourni automatiquement. Il est extrait du composant XML dans le fichier de composants de script Windows. Cette option est recommandée car le chemin d'accès au fichier de script n'est pas codé en dur.

  8. Sur la page Informations sur la méthode, sélectionnez les méthodes à utiliser et cliquez sur Suivant.

    Remarques

    • Si un composant de script Windows dispose d'une seule méthode, cette page est ignorée.

    • Vous devez sélectionner au moins une méthode.

    • Vous pouvez sélectionner plusieurs méthodes ou toutes les méthodes. Vous pouvez sélectionner ou désélectionner l'ensemble des méthodes à l'aide des boutons Sélectionner tout et Désélectionner tout.
  9. Sur la page Propriétés avancées du port, dans la zone Sécurité, cliquez sur l'une des options suivantes :
    • Non requise

      Aucune tentative pour confirmer l'identité de l'expéditeur.

    • Facultatif

      Le moteur de XLANG Scheduler requiert l'identité de l'expéditeur. L'exécution de la planification XLANG se poursuit, que l'identité soit disponible ou non.

    • Requis

      Le moteur de XLANG Scheduler requiert l'identité de l'expéditeur. L'identité de l'expéditeur est requise et la planification XLANG ignore le message si l'identité n'est pas disponible.

    Remarque

    • Si la planification XLANG rejette un appel de méthode entrant lorsque l'identité est requise mais non disponible, le code d'erreur E_ACCESSDENIED est renvoyé à l'appelant.
  10. Dans la zone Prise en charge des transactions de la page Propriétés avancées du port, cliquez sur l'une des options suivantes :
    • Désactivé

      La prise en charge des transactions pour le composant COM+ utilisé par cette implémentation de port est désactivée.

    • Non pris en charge

      Le composant COM+ utilisé par cette implémentation de port ne prend pas en charge les transactions.

    • Pris en charge

      Le composant COM+ utilisé par cette implémentation de port hérite d'une transaction existante.

    • Requis

      Le composant COM+ utilisé par cette implémentation de port peut hériter d'une transaction existante ou utiliser une nouvelle transaction.

    • Requiert une nouvelle

      Le composant COM+ utilisé par cette implémentation de port requiert une nouvelle transaction.

  11. Dans la zone Gestion d'erreur de la page Propriétés avancées du port, activez ou désactivez la case à cocher Abandonner la transaction si la méthode renvoie un HRESULT d'échec.

    Important

    • Cette option détermine si les transactions dans lesquelles le composant est utilisé doivent être abandonnées lorsque des appels de méthodes sur le composant renvoient un échec de HRESULT.

      Cette option peut être définie uniquement si l'action de communication utilisant ce port se trouve dans un flux de processus d'une transaction.

  12. Cliquez sur Terminer.

Important

  • Lorsque vous utilisez des composants de script Windows, ils doivent respecter les règles suivantes :
    • Les déclarations d'arguments doivent être classées par référence et non par valeur.

    • Les sous-routines de script Microsoft Visual Basic ne sont pas prises en charge. Seules les fonctions sont prises en charge.

    • Vous ne pouvez pas utiliser plusieurs composants dans un seul fichier .wsc.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C (à l'adresse www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Vous pouvez ajouter des implémentations de port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Un nouveau port est toujours créé afin d'être utilisé avec une implémentation des composants de script Windows.

  • Si vous modifiez une implémentation de port existante, sur la première page de l'Assistant Implémentation, vous pouvez renommer le port à l'aide de l'option Renommer le port actuel.

  • Les fichiers de composants de script Windows ont l'extension .wsc. Pour plus d'informations sur les composants de script Windows, visitez le site Web des Technologies Microsoft Scripting (à l'adresse http://www.microsoft.com/france/msdn/technologies/technos/scripting/default.asp) et accédez à la page Windows Script Components.

  • Les composants de script Windows qui ont été exécutés par le moteur de XLANG Scheduler ne peuvent pas être modifiés tant que le moteur de XLANG Scheduler et Windows Script Host ne sont pas arrêtés.

Voir aussi

Implémentation d'un port à l'aide d'un composant COM

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Formes Implémentation

Implémentation de processus professionnels

Correspondance entre un message et un port

Modification des propriétés d'implémentation d'un port

Description des implémentations de ports

Utilisation de la forme Composant de script

Utilisation de l'Assistant Communication de méthodes


Implémentation d'un port à l'aide de Message Queuing

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Message Queuing d'un stencil Implémentation vers le côté droit de la barre de séparation.

    L'Assistant Liaison de Message Queuing s'ouvre.

  2. Sur la page Assistant Liaison de Message Queuing, cliquez sur l'une des options ci-après, puis sur Suivant :
    • Créer un port

      Le Concepteur d'Orchestration BizTalk fournit par défaut un nom de port associé à un numéro pour chacune des nouvelles implémentations de port ajoutées. Vous pouvez modifier ce nom.

    • Port non lié existant

      Dans la liste Port non lié existant, sélectionnez le port à utiliser.

      Seuls les noms des ports non liés existants s'affichent dans la liste Port non lié existant. Aucune implémentation n'est définie pour un port non lié.

  3. Sur la page informations sur la file d'attente statique ou dynamique, cliquez sur l'une des options suivantes :
    • File d'attente statique

      Une file d'attente statique est une file d'attente connue préexistante. Cette file d'attente doit être connue au moment de la conception.

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • File d'attente dynamique

      Si cette option est sélectionnée, sur la page Données, vous devez créer une liaison allant d'un champ de message à la référence de port.

      Le nom de la file d'attente des messages doit être transmis par un autre message avant l'action de communication qui doit être exécutée par cette implémentation de port. Pour plus d'informations sur la correspondance entre un message et un port spécifiques, voir Correspondance entre un message et un port.

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

      Pour plus d'informations sur les files d'attente statiques et dynamiques, voir Ports statiques et dynamiques.

  4. Sur la page Informations sur la file d'attente, cliquez sur l'une des options ci-après, puis sur Suivant :
    • Créer une nouvelle file d'attente pour chaque instance

      Vous devez affecter un préfixe à la file d'attente (par exemple : ".\Private$\PrivateQueuePrefix" ou ".\PublicQueuePrefix"). Un identificateur unique est ajouté au préfixe de chaque nouvelle file d'attente créée.

      Un préfixe de file d'attente est affecté par défaut. Vous pouvez modifier cette valeur.

      Si vous voulez autoriser les réponses sur ce port, les références du port doivent être transmises dans un message. Pour ce faire, sélectionnez Créer une nouvelle file d'attente pour chaque instance et entrez le nom de la file d'attente racine. Au moment de l'exécution, le moteur de XLANG Scheduler crée une nouvelle file d'attente avec ce nom racine pour chaque instance, et un identificateur unique universel est ajouté au nom racine de chaque file d'attente créée. Cette file d'attente est supprimée lorsque l'instance est terminée.

      Si vous ne prévoyez pas d'envoyer les références de ce port, une file d'attente par instance n'est pas nécessaire. Vous pouvez créer une file d'attente qui sera utilisée par toutes les instances.

    • Utiliser une file d'attente connue pour toutes les instances

      Entrez le nom d'une file d'attente préexistante connue (par exemple : ".\private$\queuename").

  5. Sur la page Propriétés avancées du port, dans la zone Sécurité, cliquez sur l'une des options suivantes :
    • Non requise

      Aucune tentative pour confirmer l'identité de l'expéditeur. La planification XLANG reçoit toujours le message avec un champ __Émetteur__ vide, que le message soit authentifié ou non.

    • Facultatif

      Le moteur de XLANG Scheduler envoie une requête pour obtenir la confirmation de l'identité de l'expéditeur. La planification XLANG reçoit le message, qu'il soit authentifié ou non. Si le message est authentifié, le champ __Émetteur__ contient la propriété SenderID du message de Message Queuing.

    • Requis

      Le moteur de XLANG Scheduler envoie une requête pour obtenir la confirmation de l'identité de l'expéditeur. L'identité de l'expéditeur doit être confirmée. Si le message est authentifié, la planification XLANG reçoit le message et le champ __Émetteur__ contient la propriété SenderID du message de Message Queuing.

      Si le message n'est pas authentifié, un journal d'événements de l'application est créé, et le message est déplacé vers une nouvelle file d'attente nommée private$\<ApplicationName>.DeadLetter.

  6. Dans la zone Sécurité de la page Propriétés avancées du port, activez ou désactivez la case à cocher Utiliser un groupe Windows ou un nom d'utilisateur pour contrôler la file d'attente.

    Si vous activez cette case à cocher, tapez le nom de l'utilisateur ou du groupe autorisé à écrire des messages dans la file d'attente. Cette option est disponible uniquement lorsque vous utilisez une file d'attente statique.

  7. Dans la zone Prise en charge de la transaction de la page Propriétés avancées du port, activez ou désactivez la case à cocher Des transactions sont requises avec cette file d'attente.

  8. Cliquez sur Terminer.

Remarques

  • Vous pouvez ajouter des implémentations de port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Si vous modifiez une implémentation de port existante, sur la première page de l'Assistant Implémentation, vous pouvez renommer le port à l'aide de l'option Renommer le port actuel.

Voir aussi

Implémentation d'un port à l'aide d'un composant COM

Implémentation d'un port à l'aide d'un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Formes Implémentation

Implémentation de processus professionnels

Correspondance entre un message et un port

Modification des propriétés d'implémentation d'un port

Description des implémentations de ports

Utilisation de la forme Message Queuing

Utilisation de l'Assistant Communication XML


Implémentation d'un port à l'aide d'Échanges BizTalk

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, faites glisser une forme Échanges BizTalk d'un stencil Implémentation vers le côté droit de la barre de séparation.

    L'Assistant Liaison d'échanges BizTalk s'ouvre.

  2. Sur la page Assistant Liaison d'échanges BizTalk, cliquez sur l'une des options ci-après, puis cliquez sur Suivant :
    • Créer un port

      Le Concepteur d'Orchestration BizTalk fournit par défaut un nom de port associé à un numéro pour chacune des nouvelles implémentations de port ajoutées. Vous pouvez modifier ce nom.

    • Port non lié existant

      Dans la liste Port non lié existant, sélectionnez le port à utiliser.

      Seuls les noms des ports non liés existants s'affichent dans la liste Port non lié existant. Aucune implémentation n'est définie pour un port non lié.

  3. Sur la page Direction de la communication, cliquez sur l'une des options suivantes :
    • Envoyer

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • Réception

      Cliquez sur Suivant. Passez à l'étape 5 de cette procédure.

    Remarque

    • Si vous sélectionnez Recevoir, les messages peuvent uniquement être reçus en utilisant une destination d'URL http ou le Gestionnaire d'échanges BizTalk afin de configurer un port d'échanges pour instancier une planification XLANG et envoyer des messages à un port spécifique de cette planification. Pour plus d'informations sur la réception de messages à l'aide d'une URL http, voir Intégration des services BizTalk. Pour plus d'informations sur l'utilisation du Gestionnaire d'échanges BizTalk pour configurer un port d'échanges, voir Définition des propriétés d'une application de destination.
  4. Sur la page Informations sur le canal statique ou dynamique, cliquez sur l'une des options ci-après, puis cliquez sur Terminer :
    • Canal statique

      Entrez le nom d'un canal connu préexistant.

    • Canal dynamique

      Si vous sélectionnez cette option, vous devez configurer le port de façon à fournir les données dont les services d'échanges BizTalk ont besoin au moment de l'exécution pour identifier le canal correct en vue du traitement du message.

      Sur la page Données, vous devez créer une liaison allant du champ de message d'un message précédemment reçu à la référence de port de ce port. Le champ de message doit contenir une adresse de destination que les services d'échanges BizTalk utilisent comme adresse de destination d'un port d'échanges ouvert associé à ce canal. Pour plus d'informations, voir Intégration des services BizTalk.

      Lorsque vous créez le flux de communication allant d'une action à ce port, vous utilisez l'Assistant de communication XML. Dans la zone Type du message de la page Informations sur les types de messages, vous devez taper le nom de la définition de document entrant de ce canal. Ces données permettent aux services d'échanges BizTalk d'identifier le canal correct pour traiter le message. Pour plus d'informations, voir Identification.

    Important

    • Au moins un canal utilisant la définition de document entrante spécifiée doit être configuré dans les services d'échanges BizTalk. Lorsqu'une action communique avec un port lié à Échanges BizTalk et que le canal spécifié pour la liaison n'existe pas, l'instance de planification XLANG échoue avec une entrée dans le journal d'événements.

    • Au moins un canal utilisant la définition de document entrante spécifiée et configuré avec la planification XLANG comme source doit être configuré dans les services d'échanges BizTalk. Pour plus d'informations, voir Définition des propriétés d'une application source. Ce canal doit être associé à un port d'échanges ouvert. Lorsqu'une action communique avec un port lié à Échanges BizTalk et que plusieurs canaux spécifiés pour la liaison existent, l'instance de planification XLANG échoue avec une entrée de journal des événements.
  5. Sur la page Informations sur l'activation de la planification XLANG, cliquez sur l'une des options suivantes :
    • Oui

      Ce port ne peut pas être utilisé dans plusieurs actions de réception ni dans une action de réception unique d'une boucle.

      Cliquez sur Terminer.

    • Non

      Cliquez sur Suivant.

  6. Dans la zone Nom du canal de la page Informations sur le canal, tapez le nom du canal que vous voulez utiliser. Pour plus d'informations sur les canaux, voir Description des canaux et Recherche de canaux.

  7. Dans la zone Adresse de l'URL http dans laquelle le service d'Échanges BizTalk reçoit les documents de la page Informations sur le canal, tapez l'adresse de l'URL à partir de laquelle BizTalk Server reçoit les documents pour ce canal.

  8. Cliquez sur Terminer.

Important

  • Si vous configurez un port afin d'activer une nouvelle planification XLANG lorsqu'un message arrive, vous devez respecter les restrictions suivantes :
    • Dans une planification, un seul port peut être utilisé afin d'activer la planification lorsque le message arrive.

    • Une seule action peut recevoir par le biais de ce port.

    • Cette action unique ne peut pas se trouver dans le corps d'une boucle.

    • Vous ne pouvez pas dessiner une connexion de flux de données des références d'un port vers un autre message de la planification.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C (à l'adresse www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • Vous pouvez ajouter des implémentations de port aux pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement dans la page Données lorsque vous créez un nouveau port.

  • Si vous modifiez une implémentation de port existante, sur la première page de l'Assistant Implémentation, vous pouvez renommer le port à l'aide de l'option Renommer le port actuel.

Question d'ordre international

  • Si le nom d'un canal de réception sans activation inclut des caractères non-ASCII, il est possible que l'envoi des documents via HTTP échoue. Le nom du canal est transmis dans la chaîne de requête d'une URL, et les caractères non-ASCII ne sont pas pris en charge dans les chaînes de requête.

Voir aussi

Implémentation d'un port à l'aide d'un composant COM

Implémentation d'un port à l'aide d'un composant de script Windows

Implémentation d'un port à l'aide de Message Queuing

Formes Implémentation

Implémentation de processus professionnels

Intégration des services BizTalk

Correspondance entre un message et un port

Modification des propriétés d'implémentation d'un port

Recherche de canaux

Description des canaux

Description des implémentations de ports

Utilisation de la forme Échanges BizTalk

Utilisation de l'Assistant Communication XML


Modification des propriétés d'implémentation d'un port

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur la forme Implémentation que vous voulez modifier.

  2. Cliquez sur Propriétés.

    L'Assistant de cette forme Implémentation s'ouvre.

  3. Suivez les étapes de l'Assistant et changez les propriétés que vous voulez modifier.

Remarques

  • Vous pouvez modifier des implémentations de port sur les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les implémentations de port ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Une référence de port est créée automatiquement sur la page Données lorsque vous créez un nouveau port.

  • Sur la première page de l'Assistant Implémentation, l'option Renommer le port actuel vous permet d'affecter un nouveau nom au port.

Voir aussi

Implémentation d'un port à l'aide d'un composant COM

Implémentation d'un port à l'aide d'un composant de script Windows

Implémentation d'un port à l'aide d'Échanges BizTalk

Implémentation d'un port à l'aide de Message Queuing

Formes Implémentation

Implémentation de processus professionnels


nvoi ou réception de messages

BizTalk Server 2002 ~ Conception des orchestrations BizTalk

Envoi ou réception de messages

Le Concepteur d'Orchestration BizTalk intègre deux formes de communication qui permettent à la planification XLANG d'envoyer ou de recevoir des messages :

  • Communication synchrone. Les appels de méthode permettent d'envoyer ou de recevoir des paires de messages synchrones.

  • Communication asynchrone. Les messages XML permettent d'envoyer ou de recevoir des messages asynchrones.

Pour plus d'informations, voir Communication synchrone et asynchrone.

Cette section traite des procédures suivantes :

  • Établissement du flux de communication entre une action et un port

  • Envoi et réception de messages synchrones

  • Envoi ou réception de messages asynchrones

  • Modification du flux de communication entre une action et un port

Voir aussi

Communication synchrone et asynchrone

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Établissement du flux de communication entre une action et un port

  1. Dans une page de conception du Concepteur d'Orchestration BizTalk, cliquez sur une forme Action pour la sélectionner

  2. Connectez la poignée de contrôle droite ( [image]) de la forme Action au point de connexion ( [image]) d'une forme Port.

    Un Assistant Communication s'ouvre.

  3. Passez à l'une des procédures suivantes, en fonction du type de flux de communication que vous voulez créer.
    • Si vous voulez créer un flux de communication synchrone avec un port utilisant une implémentation de composants COM ou de composants de script, recourez à l'Assistant Communication de méthodes. Passez à Envoi ou réception de messages synchrones.

    • Si vous voulez créer un flux de communication asynchrone vers un port utilisant l'implémentation de Message Queuing ou Échanges BizTalk, ou si vous voulez créer un flux de communication asynchrone vers un port non lié, utilisez l'Assistant Communication XML. Passez à Envoi ou réception de messages asynchrones.

Remarques

  • Vous pouvez également utiliser l'outil de connexion pour connecter les formes. Pour plus d'informations, voir Utilisation de l'outil de connexion.

  • Vous pouvez établir un flux de communication entre une action et un port dans les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les actions et les ports ne sont pas disponibles dans la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Les nouveaux messages sont créés automatiquement sur la page Données chaque fois qu'une action est connectée à un port.


Envoi et réception de messages synchrones

L'Assistant Communication de méthodes s'ouvre dans le Concepteur d'Orchestration BizTalk, lorsque vous avez créé un flux de communication entre une action et un port pour une communication synchrone. Pour plus d'informations sur la création d'un flux de communication, voir Établissement d'un flux de communication entre une action et un port.

  1. Sur la page Assistant Communication de méthodes, cliquez sur l'une des options suivantes :
    • Lancer un appel de méthode synchrone

      Le moteur de XLANG Scheduler lance un appel de méthode synchrone.

      Dans ce cas, le moteur de XLANG Scheduler envoie un appel de méthode à un composant, attend la réponse du composant, puis reçoit la réponse.

      Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

    • Attendre un appel de méthode synchrone

      Le moteur de XLANG Scheduler attend de recevoir un appel de méthode lancé par une autre application.

      Dans ce cas, le moteur de XLANG Scheduler attend qu'une autre application lance l'appel de méthode. Cette application distincte envoie un appel de méthode à un composant ; le moteur de XLANG Scheduler attend la réponse du composant, puis renvoie une réponse à l'application. La planification XLANG intercepte la requête et la réponse de la méthode.

      Passez à l'étape 2 de cette procédure.

  2. Afin d'optimiser l'exécution d'une planification XLANG, sur la page Assistant Communication de méthodes, entrez la durée (en secondes) pendant laquelle le moteur de XLANG Scheduler attend un message, puis cliquez sur Suivant.

    La valeur par défaut du délai d'attente est 0 seconde. Vous pouvez modifier cette valeur. Une valeur inférieure ou égale à 180 secondes fait que la planification XLANG n'est jamais mise en attente. Toute valeur supérieure à 180 secondes entraîne la réalimentation immédiate de la planification XLANG. Pour plus d'informations sur les délais d'attente et la réalimentation de la planification XLANG, voir Mise en attente et réalimentation et Utilisation de l'Assistant Communication de méthodes.

  3. Sur la page Informations sur le message, cliquez sur l'une des options suivantes :
    • Créer un message

      Le nom de ce message est déterminé automatiquement à l'aide de la méthode sélectionnée sur la page suivante de l'Assistant. Le flux de données correspondant à un nouveau message doit être connecté aux autres messages de la page Données.

      Cliquez sur Suivant. Passez à l'étape 4 de cette procédure.

    • Ajouter une référence à une paire de messages synchrones existante

      Une référence à une paire de messages précédemment configurée est ajoutée au flux de communication. Ces paires de messages peuvent uniquement être réutilisées dans le même port. Elles ne peuvent pas être utilisées par une autre implémentation de port.

      Cliquez sur Terminer.

  4. Dans la liste Méthodes de la page Informations sur la spécification du message, cliquez sur la méthode que vous voulez utiliser. Vous ne pouvez sélectionner qu'une seule méthode dans la liste.

    La méthode sélectionnée définie les messages du flux de communication. Les paramètres IN et OUT sont déterminés automatiquement par les spécifications des paramètres de la méthode choisie. Les deux listes de paramètres contiennent le nom et le type de données des paramètres.

    Pour plus d'informations sur la définition des messages utilisés dans un flux de communication, voir Communication synchrone.

  5. Cliquez sur Terminer.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C (à l'adresse www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • La propriété Délai d'attente n'est pas activée, sauf si vous cliquez sur Attendre un appel de méthode synchrone.

  • Les seules méthodes disponibles dans une communication synchrone sont celles sélectionnées pour l'implémentation du port. Ni les méthodes d'autres implémentations de ports, ni les messages XML de flux de communication asynchrone ne peuvent être utilisés. Pour modifier les méthodes disponibles, exécutez de nouveau l'Assistant Implémentation de port approprié et sélectionnez d'autres méthodes.

  • Lorsque vous créez une communication synchrone, un Message est créé dans la page Données. Le Message correspond à la méthode et aux paramètres utilisés dans le flux de communication. Le Message contient tous les paramètres IN pour la méthode.

    Une méthode peut ne contenir aucun paramètre ; en revanche, le Message contient toujours les champs système requis. Pour plus d'informations sur la définition des messages utilisés dans un flux de communication synchrone, voir Communication synchrone.

Voir aussi

Mise en attente et réalimentation

Établissement du flux de communication entre une action et un port

Implémentation de ports

Envoi ou réception de messages asynchrones

Communication synchrone

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Envoi ou réception de messages asynchrones

  1. Sur la page Assistant Communication XML, cliquez sur l'une des options suivantes :
    • Envoyer

      Un message est envoyé de façon asynchrone.

      Cliquez sur Suivant. Passez à l'étape 3 de cette procédure.

    • Réception

      Le moteur de XLANG Scheduler attend de recevoir un message avant de continuer la planification XLANG.

      Passez à l'étape 2 de cette procédure.

  2. Sur la page Assistant de communication XML, afin d'optimiser l'exécution d'une planification XLANG, tapez la durée (en secondes) pendant laquelle le moteur de XLANG Scheduler doit attendre l'arrivée d'un message, puis cliquez sur Suivant.

    La valeur par défaut du délai d'attente est 0 seconde. Vous pouvez modifier cette valeur. Une valeur inférieure ou égale à 180 secondes fait que la planification XLANG n'est jamais mise en attente. Toute valeur supérieure à 180 secondes entraîne la réalimentation immédiate de la planification XLANG. Pour plus d'informations sur les délais d'attente et la réalimentation de la planification XLANG, voir Mise en attente et réalimentation et Utilisation de l'Assistant Communication de méthodes.

  3. Sur la page Informations sur le message, cliquez sur l'une des options suivantes :
    • Créer un message

      Dans la zone Nom de message, entrez le nom du message. Un nom de message par défaut incluant un numéro est indiqué lorsque vous créez une constante. Vous pouvez cependant modifier ce nom.

      Le flux de données correspondant à un nouveau message doit être connecté aux autres messages de la page Données.

    • Ajouter une référence à un message existant

      Une référence à un message précédemment configuré est ajoutée au flux de communication.

  4. Cliquez sur Suivant, puis effectuez l'une des actions suivantes :
    • Si vous avez cliqué sur Envoyer sur la page Assistant Communication XML, passez à l'étape 5 de cette procédure.

    • Si vous avez cliqué sur Recevoir sur la page Assistant Communication XML, passez à l'étape 8 de cette procédure.
  5. Sur la page Informations sur l'interprétation XML, cliquez sur l'une des options ci-après, puis cliquez sur Suivant :
    • Envoyer des messages XML à la file d'attente

    • Envoyer des messages à la file d'attente sous forme de chaîne

      Le moteur de XLANG Scheduler doit supprimer le wrapper XML standard de la chaîne.

    Les flux de données du moteur de XLANG Scheduler sont gérés avec XML. Le moteur envoie des messages XML en mode natif dans les files d'attente. Il peut aussi les envoyer sous forme de chaîne, à partir de laquelle le moteur doit supprimer son wrapper XML. Le flux de données doit fournir un message dans le format correct de cette spécification pour cette action.

    Si vous choisissez d'envoyer ou de recevoir un message XML en tant que chaîne, la forme Message créée sur la page Données pour ce message contient un champ nommé StringData, et vous ne pouvez pas ajouter de champs de spécification à ce message.

  6. Dans la zone Type du message de la page Informations sur les types de message, tapez une désignation d'étiquette pour le message.

    Le texte que vous tapez permet d'étiqueter le message lors de son envoi dans la file d'attente.

  7. Pour continuer, effectuez l'une des opérations suivantes :
    • Si, sur la page Informations sur l'interprétation XML vous avez cliqué sur Envoyer des messages XML à la file d'attente, cliquez sur Suivant. Passez à l'étape 10 de cette procédure.

    • Si, sur la page Informations sur l'interprétation XML vous avez cliqué sur Envoyer des messages à la file d'attente sous forme de chaîne, cliquez sur Terminer.
  8. Sur la page Informations sur l'interprétation XML, cliquez sur l'une des options ci-dessous, puis cliquez sur Suivant :
    • Recevoir les messages XML de la file d'attente

    • Recevoir les messages de chaîne de la file d'attente

      Le moteur de XLANG Scheduler doit intégrer la chaîne dans le wrapper XML standard du moteur.

    Les flux de données du moteur de XLANG Scheduler sont gérés avec XML. Le moteur reçoit des messages XML provenant des files d'attente en mode natif. Il peut également recevoir un message sous forme d'une chaîne, qui sera ensuite transformée au format XML.

  9. Dans la zone Type du message de la page Informations sur les types de message, tapez une désignation d'étiquette pour le message.

    Le texte que vous tapez va permettre d'identifier les messages corrects reçus de la file d'attente.

    Tout d'abord, le moteur de XLANG Scheduler va tenter de faire correspondre les informations sur les types de messages à l'étiquette du message dans la file d'attente.

    Ensuite, si le message est au format XML dans la file d'attente, il va tenter de faire correspondre les informations sur les types de messages à l'élément racine XML du message dans la file d'attente.

  10. Pour continuer, effectuez l'une des opérations suivantes :
    • Si, sur la page Informations sur l'interprétation XML vous avez cliqué sur Recevoir les messages XML de la file d'attente, cliquez sur Suivant. Passez à l'étape 11 de cette procédure.

    • Si, sur la page Informations sur l'interprétation XML vous avez cliqué sur Recevoir les messages de chaîne de la file d'attente, cliquez sur Terminer.
  11. Sur la page Informations sur la spécification du message, cliquez sur Parcourir.

    La boîte de dialogue Rechercher une spécification apparaît.

  12. Recherchez la spécification que vous voulez utiliser, sélectionnez-la, puis cliquez sur Ouvrir.

    Le chemin d'accès au fichier et le nom du fichier de la spécification sélectionnée s'affichent dans la zone Spécification du message de la page Informations sur la spécification du message.

    Remarques

    • Si vous ne recherchez pas une spécification existante, vous pouvez cliquer sur Créer. Cette action ouvre l'Éditeur BizTalk et vous permet de sélectionner une spécification et de la modifier si nécessaire pour l'utiliser avec un message ou d'en créer une nouvelle.

    • Si vous sélectionnez une spécification après l'avoir recherchée, le bouton Créer se transforme en bouton Modifier. Cliquez sur Modifier pour modifier la spécification sélectionnée.
  13. Sur la page Informations sur la spécification du message, si vous voulez valider le message par rapport à la spécification, activez la case à cocher Valider les messages par rapport à la spécification.

    Remarque

    • Cette option n'est pas activée sauf si vous sélectionnez une spécification pour la validation.
  14. Sur la page Informations sur la spécification du message, si vous voulez ajouter des champs dans la liste Champs de message, cliquez sur Ajouter.

    Important

    • Si vous voulez sélectionner des champs complémentaires pour cette spécification de message, vous devez utiliser une spécification qui a été créée avec l'Éditeur BizTalk. Vous pouvez adapter tous les standards ou schémas en les important tout d'abord dans l'Éditeur BizTalk, puis en les enregistrant comme spécifications BizTalk Server. Pour plus d'informations, voir Création et validation de spécifications.
  15. Dans l'arborescence Sélectionner un nœud de la boîte de dialogue Sélection d'un champ, développez les nœuds appropriés, cliquez sur le champ que vous voulez ajouter, puis cliquez sur OK.

    Remarques

    • Lorsque vous cliquez sur un champ de l'arborescence Sélectionner un nœud, le nom du champ est ajouté automatiquement dans la zone Nom du champ.

    • Lorsque vous cliquez sur un champ de l'arborescence Sélectionner un nœud, le chemin d'accès au nœud est ajouté automatiquement dans la zone Chemin d'accès au nœud. Vous pouvez modifier ce chemin d'accès manuellement. Pour plus d'informations, voir Champs du chemin d'accès au nœud

    • Vous ne pouvez pas sélectionner un nœud d'enregistrement pour l'ajouter dans la liste Champs de message. Seuls les champs peuvent être sélectionnés. Pour plus d'informations, voir Champs du chemin d'accès au nœud

    • Si vous voulez ajouter plusieurs champs dans la liste Champs de message de la boîte de dialogue Sélection d'un champ, vous devez sélectionner un champ et cliquer sur OK. Sur la page Informations sur la spécification du message, cliquez sur Ajouter et répétez le processus pour ajouter d'autres champs.
  16. Sur la page Informations sur la spécification du message, si vous voulez supprimer des champs de la liste Champs de message, cliquez sur un champ de la liste puis sur Supprimer.

    Remarque

    • Vous ne pouvez pas supprimer les champs requis. Ceux-ci apparaissent dans la liste Champs de message sur fond jaune.
  17. Cliquez sur Terminer.

Remarques

  • Les noms de formes doivent répondre à certaines conventions d'affectation des noms. Les conventions suivantes s'appliquent aux transactions, ports, messages, règles et champs :
    • Le nom doit être un nom de jeton XML valide. Pour plus d'informations sur les jetons XML, accédez au site Web de W3C (à l'adresse www.w3.org).

    • Le nom ne peut pas commencer par des traits de soulignement (__).

    • Le nom ne peut pas comporter de caractères deux-points (:).

    • La longueur du nom doit être inférieure ou égale à 32 caractères.

    • Les noms de constante et de message ne peuvent pas commencer par un caractère numérique.
  • La propriété Délai d'attente n'est pas activée tant que vous n'avez pas cliqué sur Recevoir.

  • Seuls les messages XML sont disponibles afin d'être utilisés dans des communications asynchrones. Tous les messages XML sont disponibles et peuvent être spécifiés pour plusieurs ports. Vous ne pouvez pas utiliser les paires de messages synchrones créées à l'aide de l'Assistant Communication de méthodes.

  • Si vous connectez ce flux de communication à un port implémenté à l'aide d'Échanges BizTalk, la direction de la communication (Envoyer ou Recevoir) est déterminée par l'implémentation du port et ne peut pas être définie dans l'Assistant Communication XML. L'option Envoyer ou Recevoir de la première page de l'Assistant est sélectionnée automatiquement et n'est pas disponible. Vous devez cliquer sur Suivant pour passer à la page suivante de l'Assistant et terminer la configuration du flux de communication.

  • Lorsque vous créez une communication asynchrone, un message est créé sur la page Données. Le Message correspond aux informations envoyées ou reçues dans le flux de communication. Le message contient les champs système requis ainsi que tous les champs de spécifications supplémentaires souhaités. Pour plus d'informations sur la définition des messages utilisés dans un flux de communication asynchrone, voir Communication asynchrone.

Voir aussi

Communication asynchrone

Création et validation de spécifications

Création de spécifications et mapping de données

Mise en attente et réalimentation

Établissement du flux de communication entre une action et un port

Champs du chemin d'accès au nœud

Envoi et réception de messages synchrones

Utilisation de l'Assistant Communication XML


Modification du flux de communication entre une action et un port

  1. Sur une page de conception du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur le flux de communication entre une action et un port.

    Un Assistant Communication s'ouvre.

  2. Suivez les étapes de l'Assistant et modifiez les propriétés appropriées.

  3. Passez à l'une des procédures suivantes, en fonction du type de flux de communication que vous voulez créer.
    • Si vous voulez créer un flux de communication synchrone pour un port qui utilise une implémentation de composants COM ou de composants de script, utilisez l'Assistant Communication de méthodes. Passez à Envoi ou réception de messages synchrones.

    • Si vous voulez créer un flux de communication asynchrone vers un port utilisant l'implémentation de Message Queuing ou Échanges BizTalk, ou si vous voulez créer un flux de communication asynchrone vers un port non lié, utilisez l'Assistant Communication XML. Passez à Envoi ou réception de messages asynchrones.

Remarques

  • Vous pouvez établir un flux de communication entre une action et un port dans les pages Processus professionnels, Compensation pour Transaction et En cas d'échec de Transaction. Les actions et les ports ne sont pas disponibles sur la page Données.

  • Vous ne pouvez pas ajouter de formes à la page Données. Les nouveaux messages sont créés automatiquement sur la page Données, chaque fois qu'une action est connectée à un port.

Voir aussi

Établissement du flux de communication entre une action et un port

Envoi ou réception de messages asynchrones

Envoi et réception de messages synchrones

Utilisation de l'Assistant Communication de méthodes

Utilisation de l'Assistant Communication XML


Dessin du flux de données entre les messages

Cette section traite des procédures suivantes :

  • Sélection d'un message

  • Sélection de champ d'un message

  • Dessin de flux entre les messages

  • Suppression d'un message

  • Correspondance entre un message et un port

  • Utilisation des constantes

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données


Sélection d'un message

  • Sur la page Données du Concepteur d'Orchestration BizTalk, cliquez sur le champ d'en-tête gris du message que vous voulez sélectionner.

    Le message sélectionné est entouré d'une bordure verte discontinue.

Remarques

  • Vous pouvez sélectionner la liste Constantes, Port References ou un Message.

  • Lorsque vous sélectionnez un message, vous pouvez le repositionner sur la page en le faisant glisser. Repositionner les messages permet de clarifier les flux de données dessinés entre les messages.

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données

Suppression d'un message

Dessin de flux entre les messages

Correspondance entre un message et un port

Sélection de champ d'un message

Utilisation des constantes


Sélection de champ d'un message

  • Sur la page Données du Concepteur d'Orchestration BizTalk, cliquez sur le champ d'un message que vous voulez sélectionner.

    Le champ sélectionné est entouré d'une bordure verte discontinue. Toutes les poignées de contrôle ( [image]) disponibles pour ce champ sont activées.

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données

Suppression d'un message

Dessin de flux entre les messages

Correspondance entre un message et un port spécifiques

Sélection d'un message

Utilisation des constantes


Dessin de flux entre les messages

  1. Sur la page Données du Concepteur d'Orchestration BizTalk, cliquez sur un champ d'un message afin d'activer ses poignées de contrôle ( [image]).

  2. Faites glisser la poignée de contrôle vers le point de connexion ( [image]) d'un champ d'un autre message auquel vous voulez le connecter.

  3. Lorsque le point de connexion est en surbrillance avec une case rouge ( [image]), relâchez le bouton de la souris pour établir la connexion.

Remarque

  • Si vous voulez créer plusieurs flux de données, vous pouvez utiliser l'outil de connexion pour les ajouter plus rapidement. Pour plus d'informations sur l'outil de connexion, voir Utilisation de l'outil de connexion.

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données

Suppression d'un message

Correspondance entre un message et un port

Sélection de champ d'un message

Sélection d'un message

Utilisation des constantes


Suppression d'un message

  • Sur la page Données du Concepteur d'Orchestration BizTalk, cliquez sur le champ d'en-tête gris du message que vous voulez supprimer et appuyez sur SUPPRIMER.

Remarques

  • Vous ne pouvez pas supprimer la liste Port References.

  • Vous ne pouvez pas supprimer la liste Constantes.

  • Si vous sélectionnez le champ d'un message et appuyez sur SUPPRIMER, le message est supprimé et non pas uniquement le champ.

Voir aussi

Ajout, suppression et connexion de formes

Gestion des données

Dessin de flux entre les messages

Sélection de champ d'un message

Sélection d'un message


Correspondance entre un message et un port

  1. Cliquez sur le champ de la liste Références de port qui contient le nom du port auquel vous voulez vous référer.

  2. Faites glisser la poignée de contrôle [image] () de ce champ vers le point de connexion [image] () du champ d'un Message dans lequel vous voulez transférer la référence du port.

Important

  • Pour plus d'informations sur la corrélation des messages et des références de ports, voir les rubriques suivantes :
    • Gestion des instances

    • Gestion des données

    • Description des implémentations de ports

Voir aussi

Gestion des données

Suppression d'un message

Dessin de flux entre les messages

Implémentation de ports

Gestion des instances

Sélection de champ d'un message

Sélection d'un message

Description des implémentations de ports

Utilisation des constantes


Utilisation des constantes

Cette section traite des procédures suivantes :

  • Ajout de constantes

  • Modification de constantes

  • Suppression de constantes

Voir aussi

Gestion des données

Types de données de champs

Résumé des types de données et des valeurs de types de données


Ajout de constantes

  1. Sur la page Données du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la liste Constantes, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés des messages de constantes s'affiche.

  2. Cliquez sur Ajouter.

    La boîte de dialogue Propriétés des constantes s'affiche.

  3. Dans la zone Nom, tapez un nom pour la constante.

  4. Dans la liste Type de données, cliquez sur le type de données pour la constante.

  5. Dans la zone Valeur, tapez une valeur pour la constante.

  6. Cliquez sur OK, puis de nouveau sur OK.

Remarques

  • Un nom par défaut associé à un numéro vous est fourni lorsque vous créez une constante. Vous pouvez modifier ce nom.

  • La zone de texte Description du type de données fournit des informations en lecture seule sur le type de données sélectionné. Elle peut intégrer un exemple de format ou une plage de valeurs valides pour un type de données.

Voir aussi

Gestion des données

Suppression de constantes

Modification de constantes

Types de données de champs

Résumé des types de données et des valeurs de types de données


Modification de constantes

  1. Sur la page Données du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la liste Constantes, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés des messages de constantes s'affiche.

  2. Dans la liste Constantes, cliquez sur la constante que vous voulez modifier.

  3. Cliquez sur Modifier.

    La boîte de dialogue Propriétés des constantes s'affiche.

  4. Modifiez les propriétés de constantes appropriées et cliquez sur OK.

Remarques

  • Pour plus d'informations sur les propriétés disponibles dans la boîte de dialogue Propriétés des constantes, voir Ajout de constantes.

  • Un nom par défaut associé à un numéro vous est fourni lorsque vous créez une constante. Vous pouvez modifier ce nom.

  • La zone de texte Description du type de données fournit des informations en lecture seule sur le type de données sélectionné. Elle peut intégrer un exemple de format ou une plage de valeurs valides pour un type de données.

Voir aussi

Ajout de constantes

Gestion des données

Suppression de constantes

Types de données de champs

Résumé des types de données et des valeurs de types de données


Suppression de constantes

  1. Sur la page Données du Concepteur d'Orchestration BizTalk, cliquez avec le bouton droit sur la liste Constantes, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés des messages de constantes s'affiche.

  2. Dans la liste Constantes, cliquez sur la constante que vous voulez supprimer.

  3. Cliquez sur Supprimer.

Voir aussi

Ajout de constantes

Gestion des données

Modification de constantes

Types de données de champs

Résumé des types de données et des valeurs de types de données


Exécution des planifications XLANG

Cette section décrit les procédures permettant de compiler, de déboguer, d'activer et d'exécuter des planifications XLANG. Pour exécuter des planifications XLANG, vous pouvez également créer une application COM+ afin d'héberger les instances de planification dédiées.

Cette section traite des rubriques suivantes :

  • Compilation et débogage de planifications XLANG

  • Création et configuration d'une application hôte de planification XLANG

Voir aussi

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG


Compilation et débogage de planifications XLANG

Lorsque vous créez une planification XLANG, vous devez la compiler, l'exécuter, la tester et la déboguer. Le Concepteur d'orchestration BizTalk inclut des fonctionnalités qui vous aident au cours de ces opérations.

Le Concepteur d'Orchestration BizTalk intègre les options suivantes :

  • Compilation

  • Mise à jour des signatures de méthodes

  • Fermeture des instances de planification XLANG en cours d'exécution

En outre, deux outils vous permettent de tester et déboguer les planifications XLANG :

  • Observateur d'événements XLANG : Vous pouvez utiliser cet outil afin de contrôler les instances de planification XLANG. Pour des informations spécifiques sur l'utilisation de cet outil, consultez le fichier Lisezmoi.htm associé. L'Observateur d'événements XLANG (XLANGMon.exe) et le fichier Lisezmoi installés par l'Assistant Installation de Microsoft BizTalk Server 2002 se trouvent dans le répertoire d'installation suivant : \Program Files\Microsoft BizTalk Server\SDK\XLANG Tools.

  • Observateur d'événements de Windows 2000 : Vous pouvez utiliser cet outil afin de visualiser les erreurs de planification XLANG. Pour plus d'informations, consultez les rubriques suivantes :
    • Gestion de l'Observateur d'événements

    • Surveillance de l'exécution des planifications XLANG

    • Pour plus d'informations sur l'Observateur d'événements, dans le chapitre « Observateur d'événements » de l'aide de Windows 2000 Server, voir « Utilisation de l'Observateur d'événements ».

Cette section traite des procédures suivantes :

  • Compilation d'un schéma de planification XLANG dans une planification XLANG

  • Exécution d'une planification XLANG.

  • Création d'une réserve de planifications XLANG.

  • Débogage des composants Visual Basic compilés

  • Actualisation des signatures de méthode

  • Fermeture de toutes les planifications XLANG en cours d'exécution

Voir aussi

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG


Compilation d'un schéma de planification XLANG dans une planification XLANG

  1. Dans le menu Fichier du Concepteur d'Orchestration BizTalk, cliquez sur Créer XLANG DrawingX.skx.

    La boîte de dialogue Enregistrer la planification XLANG vers s'affiche.

  2. Dans la liste Enregistrer dans, recherchez l'emplacement où vous voulez enregistrer la planification XLANG.

  3. Dans la liste Nom du fichier, vous pouvez renommer le fichier.

  4. Cliquez sur Enregistrer.

Remarques

  • Lorsque vous compilez un schéma de planification XLANG dans une planification XLANG, vous pouvez recevoir des messages d'erreur de compilation. Les messages d'erreur indiquent les problèmes possibles dans le schéma et la forme concernée est mise en surbrillance avec une ligne verte discontinue.

  • Lorsque vous compilez un schéma de planification XLANG, celui-ci est compilé sous le nom par défaut DrawingX.skx, X représentant le nombre ajouté au nom de la planification. Vous pouvez cependant modifier le nom du fichier lorsque vous compilez le schéma.

  • L'extension de fichier d'une planification XLANG est .skx. Un fichier .skx est un fichier XML écrit en langage XLANG. Vous ne pouvez pas ouvrir un fichier .skx dans le Concepteur d'Orchestration BizTalk. Pour modifier ou mettre à jour un fichier .skx, ouvrez le fichier source .skv, modifiez-le et recompilez-le en tant que fichier .skx.

  • L'extension de fichier d'un schéma de planification XLANG est .skv.

  • Si Microsoft® Visual InterDev® est défini comme débogueur de script et le débogage « Just in time » est activé, le débogueur peut être activé lorsque vous compilez une planification contenant un script qui référence des objets. Le message suivant apparaît :

    Voulez-vous déboguer l'application ?

    Cliquez sur Non, afin que le débogueur ne soit pas utilisé et pour permettre la compilation normale de la planification. (Si vous cliquez sur Oui, le débogueur démarre. Pour l'arrêter, vous devez détacher tous les processus ou annuler le débogage, ce qui entraînera la fermeture de Microsoft Visio et probablement la perte des planifications non enregistrées.) Pour éviter ce problème, vous pouvez désactiver le débogage JIT dans le Registre. Pour ce faire, attribuez la valeur 1 à HKEY_CURRENT_USER\Software\Microsoft\Windows Script\Settings\JITDebug.

Voir aussi

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Débogage des composants Visual Basic compilés

Gestion des applications et des bases de données XLANG

Ouverture et enregistrement des schémas de planification XLANG

Actualisation des signatures de méthode

Exécution d'une planification XLANG.

Exécution des planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG

Fermeture de toutes les planifications XLANG en cours d'exécution


Exécution d'une planification XLANG

Pour exécuter une planification XLANG, vous devez créer un moyen de l'activer.

Il existe deux moyens principaux d'effectuer cette opération :

  • Configurer les services d'orchestration BizTalk et les services d'échanges BizTalk afin d'activer et d'exécuter les planifications XLANG.

    Pour plus d'informations, consultez les rubriques suivantes :

    • Intégration des services BizTalk

    • Définition des propriétés d'une application de destination
  • Activer la planification XLANG par le programme en créant une application d'instanciation telle qu'une page ASP.

    Pour plus d'informations, consultez les rubriques suivantes :

    • Exécution des planifications XLANG

    • Création d'une application d'instanciation

    • Syntaxe du moniker

Voir aussi

Compilation d'un schéma de planification XLANG dans une planification XLANG

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Débogage des composants Visual Basic compilés

Gestion des applications et des bases de données XLANG

Syntaxe du moniker

Actualisation des signatures de méthode

Exécution des planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG

Fermeture de toutes les planifications XLANG en cours d'exécution


Création d'une réserve de planifications XLANG

Vous pouvez regrouper vos planifications pour utiliser vos ressources de manière efficace lorsque le trafic est important et lorsque de nombreuses instances de planification sont activées en même temps. Pour affecter une réserve d'objets à une planification, effectuez l'une des opérations suivantes :

  1. Cliquez avec le bouton droit sur la forme Début, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de début s'affiche.

  2. Dans la zone Réserve, sélectionnez une réserve dans la liste déroulante.

Pour définir des propriétés sur la réserve d'objets, procédez comme suit :

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration et sur Services de composant.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Cliquez avec le bouton droit sur XLANG Schedule Pool, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de XLANG Schedule Pool s'affiche.

  4. Cliquez sur l'onglet Avancé.

  5. Dans la zone Autorisation, désactivez la case à cocher Désactiver les modifications, puis cliquez sur OK.

  6. Dans l'arborescence de la console, développez XLANG Schedule Pool puis Composants. Cliquez avec le bouton droit sur SimpleSkedPool.SimplePoolN.1 (N correspondant au numéro de la réserve sélectionnée dans la liste déroulante lors de l'étape précédente), puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de SimpleSkedPool.SimplePoolN.1 s'affiche.

  7. Cliquez sur l'onglet Activation.

  8. Dans la zone Pool d'objet, procédez comme suit :
    • Taille minimale du pool. Permet de modifier la taille minimale de la réserve pour spécifier le nombre minimal d'objets qui seront conservés dans la mémoire.

    • Taille maximale du pool. Permet de modifier la taille maximale de la réserve pour spécifier le nombre maximal d'instances de programmation susceptibles d'être actives en même temps.

    • Délai d'attente pour la création (ms). Permet de modifier le délai de création pour spécifier la durée d'attente (en millisecondes) avant l'activation d'une planification.
  9. Cliquez sur OK pour fermer la boîte de dialogue Propriétés de SimpleSkedPool.SimplePoolN.1.

Remarque

  • Pour plus d'informations sur les réserves, voir Création d'une réserve de planifications XLANG.


Débogage des composants Visual Basic compilés

Dans certaines situations, vous devrez peut-être déboguer des composants créés avec Microsoft Visual Basic après leur compilation.

  1. Dans Visual Basic 6.0, ouvrez le projet Visual Basic que vous voulez déboguer.

  2. Dans le menu Fichier, cliquez sur Créer <YourProject>.dll.

    La boîte de dialogue Créer le projet apparaît.

  3. Cliquez sur Options.

    La boîte de dialogue Propriétés du projet s'affiche.

  4. Dans la boîte de dialogue Propriétés du projet, sous l'onglet Compiler, cliquez sur Compiler en code natif et sur Pas d'optimisation, puis activez la case à cocher Générer les informations de débogage symbolique.

  5. Cliquez sur OK, puis de nouveau sur OK pour compiler le projet.

  6. Ouvrez le projet Visual Basic concerné.

  7. Sélectionnez les points d'arrêt que vous voulez utiliser.

  8. Dans le menu Exécuter, cliquez sur Démarrer.

Lorsque la planification XLANG appelle le composant Visual Basic, le débogueur Visual Basic s'arrête sur les points d'arrêt.

Important

  • Pour créer le projet .dll Visual Basic, vous devez activer la case à cocher Générer les informations de débogage symbolique.

  • Assurez-vous que le moteur de XLANG Scheduler n'a pas encore chargé le projet .dll. Si le projet .dll a été chargé, vous devez arrêter le moteur et réessayer.

Remarque

  • Pour plus d'informations sur les composants de débogage ou sur les services de composant et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis faites une recherche sur les termes « Component Services ».


Actualisation des signatures de méthode

Utilisez cette option si vous créez simultanément des composants COM+ et une planification XLANG et si vous modifiez des paramètres de méthode dans l'uns des appels de méthode disponibles. Ainsi, les paramètres de méthode sont actualisés dans la planification XLANG.

  • Dans le menu Outils du Concepteur d'Orchestration BizTalk, cliquez sur Actualiser les signatures de méthode.

Remarques

  • Lorsque vous compilez une planification XLANG, l'option Actualiser les signatures de méthode est exécutée automatiquement.

Voir aussi

Compilation d'un schéma de planification XLANG dans une planification XLANG

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Débogage des composants Visual Basic compilés

Gestion des applications et des bases de données XLANG

Exécution d'une planification XLANG

Exécution des planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG

Fermeture de toutes les planifications XLANG en cours d'exécution


Fermeture de toutes les planifications XLANG en cours d'exécution

  • Dans le menu Outils du Concepteur d'Orchestration BizTalk, cliquez sur Fermer toutes les instances de planification XLANG en cours d'exécution.

Remarque

  • Lorsque vous exécutez une instance de planification XLANG, vous ne pouvez pas modifier les composants COM utilisés par cette planification XLANG. Cette option ferme toutes les instances de planification en cours d'exécution et déverrouille le fichier de composant. Vous pouvez ainsi apporter les modifications appropriées.

Voir aussi

Compilation d'un schéma de planification XLANG dans une planification XLANG

Création et configuration d'une application hôte de planification XLANG

Création d'une application d'instanciation

Débogage des composants Visual Basic compilés

Gestion des applications et des bases de données XLANG

Actualisation des signatures de méthode

Exécution d'une planification XLANG

Exécution des planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG


Création et configuration d'une application hôte de planification XLANG

Cette section décrit les procédures d'activation et d'exécution d'une planification XLANG. Vous pouvez utiliser l'application XLANG Scheduler par défaut pour exécuter les planifications XLANG, mais il est souvent utile de créer une nouvelle application COM+ pour exécuter les instances de planification.

Pour des raisons de configuration, de déploiement et de sécurité, la plupart des applications COM+ qui hébergent des planifications XLANG doivent être créées lors du développement des planifications XLANG. Vous devez tenir compte des performances et de la sécurité des applications et des planifications. Vous pouvez créer une nouvelle application COM+ afin d'héberger des instances dédiées de planification en cours d'exécution ou isoler des applications qui exécutent des instances de planification spécifiques d'autres planifications XLANG qui utilisent des applications différentes.

Pour plus d'informations sur la sécurité et les performances liées à la création des planifications XLANG et des applications COM+ afin d'héberger des planifications, voir Sécurité des applications hébergeant des instances de planification XLANG.

Pour plus d'informations sur la gestion d'applications COM+ après leur création, voir Gestion d'applications XLANG et de base de données.

Cette section traite des procédures suivantes :

  • Création d'une application COM+ pour héberger des planifications XLANG

  • Configuration d'une application COM+ pour héberger des planifications XLANG

Remarques

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composant et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

Voir aussi

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG


Création d'une application COM+ pour héberger des planifications XLANG

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, puis double-cliquez sur Outils d'administration et sur Services de composant.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

    Sélectionnez d'abord Applications COM+, puis cliquez dessus avec le bouton droit. Si vous ne sélectionnez pas cette option, l'option Nouveau n'est pas disponible.

  3. Cliquez avec le bouton droit sur Applications COM+, pointez sur Nouveau, puis cliquez sur Application.

    L'Assistant Installation d'Applications COM s'ouvre.

  4. Sur la page Assistant Installation d'Applications COM, cliquez sur Suivant.

  5. Sur la page Installer ou créer d'une nouvelle application, cliquez sur Créer une application vide.

  6. Sur la page Créer une application vide, tapez un nom pour l'application, assurez-vous que l'option Application serveur est activée, puis cliquez sur Suivant.

  7. Sur la page Définir l'identité de l'application, définissez l'identité de l'application pour le compte approprié.

    Nous vous recommandons vivement de créer un compte de service afin de gérer les applications COM+ qui hébergent des planifications XLANG.

    Pour plus d'informations sur les problèmes de performances et de sécurité liés à la création de l'identité d'une application, voir Sécurité des applications hébergeant des instances de planification XLANG.

  8. Cliquez sur Suivant, puis sur Terminer.

  9. Cliquez avec le bouton droit sur l'application COM+ qui vient d'être créée et cliquez sur Propriétés.

  10. Sous l'onglet XLANG, activez la case à cocher Utiliser l'application comme l'hôte des instances de planification XLANG.

  11. Pour configurer une application COM+, voir Configuration d'une application COM+ pour héberger des planifications XLANG.

Important

  • Vous devez installer au moins un composant COM dans votre application COM+.

Remarques

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composant et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

  • Nous vous recommandons d'héberger des planifications XLANG uniquement dans des processus dédiés ; l'application COM+ qui héberge la planification ne doit pas avoir d'autre activité.

  • Lorsque vous créez une application COM+ pour héberger des planifications XLANG, l'option Redémarrer les applications XLANG en attente n'est pas disponible. Pour plus d'informations sur le redémarrage des applications mise en attente, voir Redémarrage de toutes les applications XLANG.

Voir aussi

Configuration d'une application COM+ pour héberger des planifications XLANG

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG


Configuration d'une application COM+ pour héberger des planifications XLANG

  1. Dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration, puis sur Services de composant.

  2. Dans l'arborescence de la console, développez successivement Services de composant, Ordinateurs, Poste de travail et Applications COM+.

  3. Double-cliquez avec le bouton droit sur l'application que vous voulez configurer et cliquez sur Propriétés.

    Nous vous recommandons vivement de créer un compte de service pour gérer les applications COM+ qui hébergent des planifications XLANG. Si vous avez accepté la configuration par défaut dans l'Assistant Installation Application COM lorsque vous avez créé l'application COM+, vous pouvez la modifier. Pour plus d'informations, voir Modification de l'identité d'une application COM+.

  4. Configurez les paramètres DSN pour l'application COM+.

    Pour plus d'informations, voir Modification des paramètres DSN d'une application COM+.

  5. Configurez une base de données pour l'application COM+ à utiliser.

    Vous pouvez :

    • Pointer sur une base de données existante. Pour plus d'informations, voir Modification des paramètres DSN d'une application COM+.

      –Ou–

    • Créer et configurer une nouvelle base de données. Pour plus d'informations, voir Création d'une nouvelle base de données de persistance et Modification des paramètres DSN d'une application COM+.

Attention

  • Si vous créez et configurez une nouvelle base de données à utiliser avec une application COM+, vous devez initialiser les tables de base de données après avoir configuré les paramètres DNS (Data Source Name) de l'application COM+.

    Pour plus d'informations sur la configuration d'un DSN et l'utilisation des sources de données (ODBC), cliquez sur Aide dans la boîte de dialogue Administrateur de la source de données ODBC.

    Pour initialiser de nouvelles tables de base de données pour l'application hôte COM+ configurée :

    6. Cliquez avec le bouton droit sur l'application COM+, puis cliquez sur Propriétés.

    7. Cliquez sur l'onglet XLANG.

    8. Cliquez sur Initialiser les tables.
  • Ne cliquez pas sur Initialiser les tables si vous configurez une application hôte COM+ et un DSN pour une base de données existante. Cette action entraîne la destruction de toutes les données déjà enregistrées dans la base de données existante.

Remarques

  • Pour accéder à l'aide de l'administration des services de composant, dans le menu Démarrer, pointez sur Paramètres, cliquez sur Panneau de configuration, double-cliquez sur Outils d'administration puis sur Services de composant. Dans l'arborescence de la console, cliquez avec le bouton droit sur Services de composant puis cliquez sur Aide.

  • Pour plus d'informations sur les services de composant et COM+, accédez au site Web MSDN Online Library (msdn.microsoft.com/library/), puis effectuez une recherche sur les termes « Component Services ».

Voir aussi

Modification de l'identité d'une application COM+

Modification des paramètres DSN d'une application COM+

Création d'une application COM+ pour héberger des planifications XLANG

Création d'une base de données de persistance vide

Création d'une application d'instanciation

Gestion des applications et des bases de données XLANG

Exécution des planifications XLANG

Sécurité des applications hébergeant des instances de planification XLANG


Configuration des services d'échanges BizTalk

Microsoft® BizTalk™ Server 2002 intègre deux méthodes de configuration des services d'échanges BizTalk, afin de gérer les échanges de documents entre les partenaires commerciaux et les applications internes à l'entreprise. Vous pouvez opter pour le Gestionnaire d'échanges BizTalk, qui est une interface utilisateur graphique, ou accéder directement au modèle d'objets de configuration d'échanges BizTalk.

Grâce au Gestionnaire d'échanges BizTalk ou au modèle d'objets de configuration d'échanges BizTalk, vous pouvez créer des ports d'échanges et des canaux assurant la gestion des échanges de données. Vous pouvez également créer des définitions de document, des enveloppes et des organisations, qui permettent de créer des ports d'échanges et des canaux, ainsi que des listes de distribution, qui sont des groupes de ports d'échanges.

Conditions requises pour la sécurité

Pour pouvoir utiliser le Gestionnaire d'échanges BizTalk, vous devez :

  • Appartenir à un compte d'utilisateur du groupe Administrateurs BizTalk Server, qui est créé lors de l'installation de BizTalk Server 2002. Le cas échéant, il est possible d'ajouter des utilisateurs supplémentaires à ce groupe. Pour plus d'informations sur l'ajout d'un compte d'utilisateur, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.

  • Disposer de tous les droits d'accès à la base de données Gestion d'échanges BizTalk (InterchangeBTM), ce qui signifie que vous pouvez ouvrir une session et disposer du rôle db_owner database. Pour plus d'informations, reportez-vous à la section qui traite de l'attribution de droits d'accès aux bases de données aux utilisateurs ou aux groupes Windows dans la documentation en ligne fournie avec Microsoft SQL Server.

Devez-vous utiliser le Gestionnaire d'échanges BizTalk ou l'API du modèle d'objets de configuration BizTalk ?

Le Gestionnaire d'échanges BizTalk permet d'accéder au modèle d'objets de configuration BizTalk par le biais d'une interface graphique utilisateur. L'utilisation ou non de cette interface dépend du volume et du type des données dont vous disposez dans votre base de données. L'API du modèle d'objets de configuration des échanges BizTalk permet d'automatiser tout ou partie du processus de configuration, et évite d'entrer des données pour chaque entité dans le Gestionnaire d'échanges BizTalk. D'une façon générale, plus vous avez de partenaires commerciaux, et plus il est intéressant d'utiliser cette API pour configurer votre service d'échanges.

Prenons l'exemple d'une très grande entreprise industrielle qui recourt à 1 000 fournisseurs et gère une base de données contenant des informations sur chacun d'entre eux. Au cours de la phase de création des organisations, il peut être relativement rapide et simple d'écrire un code qui effectue les opérations suivantes :

  • Extraction des données de la base de données.

  • Utilisation du modèle d'objets de configuration des échanges BizTalk pour créer, au moyen d'un programme, les 1 000 organisations dans la base de données Gestion d'échanges BizTalk.

En revanche, la création un à un des 1 000 objets à l'aide du Gestionnaire d'échanges BizTalk peut être beaucoup plus longue. (Imaginez exécuter le même Assistant 1 000 fois de suite.) Par ailleurs, tout ceci permet uniquement de créer les organisations. Les définitions de documents, les canaux et les ports d'échanges restent encore à créer.

Une entreprise de petite taille, qui gère ses relations avec quelques partenaires commerciaux, préfèrera probablement utiliser le Gestionnaire d'échanges BizTalk pour configurer la totalité de son système d'échanges plutôt que d'écrire un code spécifique.

Pour plus d'informations sur l'accès au modèle d'objets de configuration d'échanges BizTalk directement par le biais de l'API, voir Introducing Messaging Services.

Cette section traite de la rubrique suivante :

  • Utilisation du Gestionnaire d'échanges BizTalk


Utilisation du Gestionnaire d'échanges BizTalk

Le Gestionnaire d'échanges Microsoft® BizTalk™ est une interface graphique utilisateur qui vous permet de gérer l'échange de documents en configurant les services d'échanges BizTalk. Les services d'échanges BizTalk peuvent également être configurés au moyen d'un programme en utilisant l'API du modèle d'objets de configuration BizTalk. Pour plus d'informations, voir Introducing Messaging Services.

Attention

  • Vous devez utiliser le Gestionnaire d'échanges BizTalk pour configurer les services d'échanges BizTalk avant de traiter des documents. Si vous accédez à des objets ou modifiez des objets susceptibles d'être en cours d'utilisation lors du traitement de documents par Microsoft BizTalk Server 2002, des résultats inattendus peuvent se produire.

L'échange de documents peut avoir lieu entre des partenaires commerciaux et des applications au sein de votre entreprise. Le Gestionnaire d'échanges BizTalk est disponible à la fois en local à partir de l'ordinateur sur lequel BizTalk Server 2002 est installé et à distance en tant qu'application cliente. Dès lors, les administrateurs système sont en mesure d'assurer la sécurité et de centraliser le contrôle du serveur tout en permettant aux utilisateurs distants d'accéder au Gestionnaire d'échanges BizTalk.

L'Aide de BizTalk Server 2002 fournit des informations sur la création et la gestion des objets suivants du Gestionnaire d'échanges BizTalk :

  • Canaux

  • Ports d'échanges

  • Définitions de documents

  • Enveloppes

  • Organisations

L'Aide de BizTalk Server 2002 fournit des informations sur l'utilisation des listes de distribution.

Objets du Gestionnaire d'échanges BizTalk

L'illustration suivante montre les relations entre les objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk.

Vue d'ensemble du Gestionnaire d'échanges BizTalk

Le résumé suivant fournit une présentation succincte des objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk. Il explique aussi plus en détail la relation entre les objets. Pour des informations plus détaillées sur chaque objet, cliquez sur le lien apparaissant à la fin de chaque description pour accéder à la rubrique d'aide correspondante.

Canaux

Les canaux constituent les principaux objets du Gestionnaire d'échanges BizTalk. Tous les autres objets du Gestionnaire d'échanges BizTalk servent soit à créer des canaux, soit à permettre le fonctionnement de ceux-ci. Les canaux identifient la source des documents. Il peut s'agir d'une organisation, d'une application métier ou d'une planification XLANG. Les canaux identifient également les documents entrants et sortants à l'aide des définitions de documents. Pour plus d'informations, voir Description des canaux.

Ports d'échanges

Les ports d'échanges identifient une destination pour les documents traités par un canal. Cette destination peut être une organisation, une application métier ou une planification XLANG. Le port d'échanges indique une adresse de destination pour l'envoi des documents, définit le mode de transport vers cette adresse et détermine, le cas échéant, la procédure de sécurisation des documents et les paramètres des enveloppes. Pour plus d'informations, voir Description des ports d'échanges.

Organisations

Les organisations représentent d'autres partenaires commerciaux avec lesquels vous échangez des documents. Le type d'organisation spécial, appelé l'organisation d'origine représente votre entreprise. Pour l'organisation principale, vous pouvez créer des applications correspondant aux applications internes utilisées par votre entreprise. Les organisations et les applications font fonction de source pour un canal ou de destination pour un port d'échanges. Pour plus d'informations, voir Description des organisations.

Définitions de documents

Une définition de document représente un type spécifique de document traité par BizTalk Server 2002. Une définition de document fournit un pointeur sur une spécification. Les spécifications définissent la structure, le type et la version des documents. Les canaux spécifient une définition de document entrant et une définition de document sortant pour identifier les documents traités par le serveur. Une définition de document donnée peut être utilisée dans un nombre illimité de canaux. Pour plus d'informations, voir Description des définitions de documents.

Enveloppes

Les enveloppes fournissent à BizTalk Server 2002 les informations dont le serveur a besoin pour ouvrir des échanges entrants ou créer des échanges sortants. Des enveloppes peuvent être sélectionnées à partir d'un port d'échanges pour guider le serveur dans la création d'échanges sortants. Des enveloppes indépendantes d'un port d'échanges peuvent être utilisées par BizTalk Server 2002 pour ouvrir des échanges entrants. Pour plus d'informations, voir Description des enveloppes.

Listes de distribution

Les listes de distribution sont des groupes de ports d'échanges via lesquels vous pouvez envoyer le même document à un groupe comprenant différentes organisations de partenaires commerciaux ou différentes applications internes. Vous devez créer au moins un canal pour une liste de distribution, exactement comme pour un port d'échanges individuel. Pour plus d'informations, voir Description des listes de distribution.

Remarques

  • Les objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk peuvent également être créés par programme à l'aide du modèle d'objets de configuration d'Échanges BizTalk. Pour plus d'informations, voir Understanding Messaging Services.

  • Les objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk utilisent également des objets que vous pouvez créer à l'aide d'autres interfaces utilisateur des services d'échanges BizTalk. Les canaux utilisent des mappages, lesquels peuvent être créés à l'aide du Mappeur BizTalk. Les définitions de documents utilisent des spécifications de documents, et les enveloppes utilisent des spécifications d'enveloppes. L'Éditeur BizTalk vous permet de créer des spécifications.

Cette section traite des rubriques suivantes :

  • Pour plus d'informations détaillées sur le Gestionnaire d'échanges BizTalk, voir À propos du Gestionnaire d'échanges BizTalk.

  • Pour plus d'informations sur les raisons pour lesquelles effectuer certaines tâches, voir Pourquoi effectuer des tâches dans le Gestionnaire d'échanges BizTalk.

  • Pour prendre connaissance des procédures détaillées à suivre afin d'effectuer certaines tâches, voir Comment utiliser le Gestionnaire d'échanges BizTalk.


À propos du Gestionnaire d'échanges BizTalk

Cette section présente des concepts essentiels pour comprendre l'utilisation du Gestionnaire d'échanges Microsoft BizTalk. Elle contient des informations sur les rubriques suivantes :

  • Environnement du Gestionnaire d'échanges BizTalk

  • Description des canaux

  • Description des ports d'échanges

  • Description des organisations

  • Description des définitions de documents

  • Description des enveloppes

  • Description des accusés de réception

  • Description des listes de distribution


Environnement du Gestionnaire d'échanges BizTalk

Cette section traite des rubriques suivantes :

  • Configuration des options du Gestionnaire d'échanges BizTalk

  • Interface du Gestionnaire d'échanges BizTalk

  • Touches de raccourci du Gestionnaire d'échanges BizTalk

  • Sécurité

Attention

  • Vous devez utiliser le Gestionnaire d'échanges BizTalk pour configurer les services d'échanges BizTalk avant de traiter les documents. Si vous accédez à des objets ou modifiez des objets susceptibles d'être en cours d'utilisation lors du traitement de documents par Microsoft BizTalk Server 2002, des résultats inattendus peuvent se produire.


Configuration des options du Gestionnaire d'échanges BizTalk

Cette section explique comment modifier les options du Gestionnaire d'échanges BizTalk, Parmi ces options, citons :

  • la configuration des nouveaux ports d'échanges ou des canaux ;

  • la gestion des ports d'échanges ou des canaux déjà configurés ;

  • la définition de la valeur renvoyée pour la recherche ;

  • la configuration de la connexion du serveur ;

  • la définition de la valeur pour le délai d'expiration du serveur.

Cette section traite des procédures suivantes :

  • Sélection d'une option de configuration du Gestionnaire d'échanges BizTalk

  • Définition des options de connexion du serveur

Remarque

  • Les barres d'outils du Gestionnaire d'échanges BizTalk peuvent être déplacées ; cependant, après le redémarrage de l'application, les barres d'outils retrouvent leur emplacement d'origine.


Sélection d'une option de configuration du Gestionnaire d'échanges BizTalk

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

    La boîte de dialogue Gestionnaire d'échanges BizTalk s'affiche.

  2. Dans la zone Options de configuration, sélectionnez l'une des options suivantes :
    • Pour créer et configurer un nouveau port d'échanges pour une organisation, cliquez sur Configurer un nouveau port d'échanges pour une organisation, puis cliquez sur OK.

      Pour plus d'informations sur la création et la configuration d'un nouveau port d'échanges pour une organisation, voir Création de ports d'échanges.

    • Pour créer et configurer un nouveau port d'échanges pour une application, cliquez sur Configurer un nouveau port d'échanges pour une application, puis cliquez sur OK

      Pour plus d'informations sur la création et la configuration d'un nouveau port d'échanges pour une application, voir Création de ports d'échanges.

    • Pour gérer des ports d'échanges existants, cliquez sur Gérer les ports d'échanges déjà configurés, puis cliquez sur OK

      Pour plus d'informations sur la gestion des ports d'échanges existants, voir Modification de ports d'échanges.

    • Pour gérer des canaux existants, cliquez sur Gérer les canaux d'échanges déjà configurés, puis cliquez sur OK.

      Pour plus d'informations sur la création et la configuration des canaux existants, voir Modification de canaux.

Remarque

  • Si vous ne souhaitez pas que cette boîte de dialogue s'affiche à l'ouverture du Gestionnaire d'échanges BizTalk, activez la case à cocher Ne plus afficher cette boîte de dialogue. Pour que la boîte de dialogue s'affiche de nouveau, dans le menu Outils, cliquez sur Options et activez la case à cocher Afficher la boîte de dialogue de démarrage.

Voir aussi

Création de ports d'échanges

Modification de canaux

Modification de ports d'échanges


Définition des options de connexion du serveur

  1. Dans le Gestionnaire d'échanges BizTalk, cliquez sur Options dans le menu Outils.

    La boîte de dialogue Options s'affiche.

  2. Dans la zone Nombre maximal d'éléments à renvoyer lors d'une recherche, effectuez l'une des opérations suivantes :
    • Indiquez une valeur correspondant au nombre d'éléments à renvoyer dans le résultat d'une recherche.

    • Cliquez sur la flèche vers le haut ou vers le bas pour augmenter ou diminuer cette valeur.
  3. Dans la zone Nom du serveur BizTalk Server auquel vous souhaitez vous connecter, tapez le nom d'un serveur sur lequel BizTalk Server 2002 est installé.

  4. Dans la zone Délai d'expiration du serveur (s), effectuez l'une des opérations suivantes :
    • Tapez une valeur correspondant au nombre de secondes qui doit s'écouler avant que le délai d'expiration de la connexion du serveur ne soit atteint.

    • Cliquez sur la flèche vers le haut ou vers le bas pour augmenter ou diminuer cette valeur.
  5. Pour choisir d'afficher ou non la boîte de démarrage lors du lancement du Gestionnaire d'échanges BizTalk, activez ou désactivez la case à cocher Afficher la boîte de dialogue de démarrage.

  6. Une fois toutes les propriétés définies, cliquez sur OK.

Remarques

  • Le serveur auquel vous êtes connecté détermine la base de données Gestionnaire d'échanges BizTalk dans laquelle vous recherchez, modifiez ou créez des objets avec le Gestionnaire d'échanges BizTalk. Par défaut, les paramètres de la connexion du serveur sont ceux de la dernière connexion effectuée. Le serveur qui héberge le référentiel WebDAV et que vous utilisez pour stocker et extraire des spécifications pour les documents, les mappages et les enveloppes est défini séparément en complétant les zones de la boîte de dialogue utilisée pour sélectionner les spécifications. Par défaut, les paramètres de la connexion WebDAV sont ceux de la dernière connexion effectuée.

  • Le nombre d'éléments renvoyés par défaut dans le résultat d'une recherche est 500.

  • La durée par défaut qui s'écoule avant que le délai de connexion du serveur n'expire est de 20 secondes.

  • Le serveur auquel vous êtes connecté est indiqué dans la partie supérieure du volet Recherche situé dans la partie gauche du Gestionnaire d'échanges BizTalk.

  • Si vous utilisez Internet Explorer 5.5 Service Pack 1 (SP1), vous risquez de recevoir le message d'erreur suivant : Le document de réponse n'est pas valide. Pour corriger cette erreur, tapez le nom de domaine complet dans la zone Nom du serveur BizTalk Server auquel vous souhaitez vous connecter. Puis, dans Internet Explorer 5.5 SP1, marquez soit les paramètres proxy en tant qu'exceptions (dans le menu Outils, cliquez sur Options Internet et activez l'onglet Connexions) soit, ajoutez-les en tant que sites (dans le menu Outils, sélectionnez Options Internet et activez l'onglet Sécurité). Pour plus d'informations, reportez-vous à la documentation consacrée à Internet Explorer 5.5 SP1.


Interface du Gestionnaire d'échanges BizTalk

L'interface utilisateur du Gestionnaire d'échanges BizTalk est constituée de deux volets principaux.

Le volet gauche contient les éléments suivants :

  • le nom du serveur auquel le Gestionnaire d'échanges BizTalk est connecté ;

  • une liste d'objets parmi lesquels vous pouvez effectuer une recherche ;

  • des critères de recherche à utiliser pour affiner votre recherche.

Vous pouvez rechercher n'importe quel objet que vous avez créé en utilisant le Gestionnaire d'échanges BizTalk. Vous pouvez choisir le type d'objet à rechercher en cliquant sur un nom dans la zone Rechercher d'autres éléments. Les critères de recherche diffèrent selon l'objet sélectionné.

Le volet droit contient :

  • les informations relatives aux éléments renvoyés dans le dernier résultat de la recherche ;

les informations relatives à ces éléments diffèrent selon le type d'objet recherché.

Vous pouvez trier les éléments dans le volet de résultats de la recherche par ordre croissant ou décroissant en cliquant dans les en-têtes de colonne. Il vous est possible d'effectuer un tri sur une seule colonne à la fois.

Remarques

  • Si vous effectuez une recherche sur un nombre important d'objets d'un type particulier, vous devrez attendre plusieurs minutes avant d'obtenir le résultat. Vous pouvez limiter le nombre d'éléments renvoyés dans le résultat d'une recherche en utilisant des critères de recherche.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

Voir aussi

Touches de raccourci du Gestionnaire d'échanges BizTalk

Recherche de canaux

Recherche de listes de distribution

Recherche de définitions de document

Recherche d'enveloppes

Recherche de ports d'échanges

Recherche d'organisations


Touches de raccourci du Gestionnaire d'échanges BizTalk

Vous pouvez utiliser des touches de raccourci pour effectuer certaines tâches dans le Gestionnaire d'échanges BizTalk. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les touches souris dans l'aide de Windows 2000 Server et Advanced Server, voir « Utiliser le clavier pour déplacer le pointeur de la souris ». Pour plus d'informations sur les touches souris dans l'aide de Windows 2000 Professionnel, voir « Déplacer le pointeur de la souris en utilisant les Touches souris ».
Appuyez sur | Pour
CTRL+A | Sélectionner tout.
CTRL+C | Copier du texte.
Ctrl+X | Couper du texte.
CTRL+V | Coller du texte.
CTRL+Z | Annuler la dernière action sur le texte.
CTRL+R | Créer un port d'échanges pour une organisation.
CTRL+MAJ+R | Créer un port d'échanges pour une application.
CTRL+L | Créer un canal à partir d'une organisation.
CTRL+MAJ+SUPPR | Créer un canal à partir d'une application.
CTRL+T | Créer une liste de distribution.
CTRL+D | Créer une définition de document.
CTRL+G | Créer une organisation.
SUPPR | Supprimer l'élément ou le texte sélectionné.
MAJ+F10 | Afficher le menu contextuel associé à l'élément sélectionné.
Utilisation de la touche MAJ avec une touche de direction | Sélectionner plusieurs éléments dans une fenêtre ou sélectionner du texte.
TAB | La touche TAB permet de déplacer le focus d'un bouton ou d'un champ à l'autre dans la boîte de dialogue.
MAJ+TAB | La touche TAB permet de déplacer le focus d'un bouton ou d'un champ à l'autre dans la boîte de dialogue.
CTRL+TAB | Activer et désactiver les onglets d'une feuille de propriétés de l'avant vers l'arrière.
CTRL+MAJ+TAB | Activer et désactiver les onglets d'une feuille de propriétés de l'arrière vers l'avant.
ESPACE | Activer ou désactiver une case à cocher. L'utilisation de la barre d'espace entraîne le même résultat qu'un clic de souris lorsqu'un bouton est activé.
ALT+ESPACE | Afficher le menu Système pour la fenêtre active.
ALT+lettre soulignée d'un nom de menu | Afficher le menu correspondant.
Lettre soulignée dans un nom de commande d'un menu ouvert | Exécuter la commande correspondante.
ALT + FLÈCHE BAS | Afficher la liste déroulante d'une zone de liste active.
ENTRÉE | Exécuter la commande pour l'option active ou le bouton actif.
ÉCHAP | Annuler la tâche en cours.
F1 | Afficher l'aide en ligne.
ALT+F4 | Fermer la fenêtre active ou quitter le programme actif.
FLÈCHE GAUCHE | Déplacer le focus vers l'onglet de gauche.
FLÈCHE DROITE | Déplacer le focus vers l'onglet de droite.
N'importe quelle touche de direction | Mettre en surbrillance un dossier ou un fichier dans la fenêtre principale d'une boîte de dialogue lorsque cette fenêtre est active. Cette fonction est disponible dans les boîtes de dialogue Sélectionnez une spécification de document dans le référentiel WebDAV, Sélectionnez une spécification d'enveloppe dans le référentiel WebDAV et Sélectionnez un mappage dans le référentiel WebDAV. Pour plus d'informations, voir Sélection d'une spécification de document, Sélection d'une spécification d'enveloppe et Sélection d'un mappage.

Voir aussi

Interface du Gestionnaire d'échanges BizTalk


Sécurité

Pour accéder ou créer des objets à l'aide du Gestionnaire d'échanges BizTalk, vous devez :

  • Appartenir à un compte d'utilisateur du groupe Administrateurs BizTalk Server, qui est créé lors de l'installation de BizTalk Server 2002. Le cas échéant, il est possible d'ajouter des utilisateurs supplémentaires à ce groupe. Pour plus d'informations sur l'ajout d'un compte d'utilisateur, voir Ajout d'utilisateurs au groupe Administrateurs de BizTalk Server.

  • Disposer de tous les droits d'accès à la base de données Gestion d'échanges BizTalk (InterchangeBTM), ce qui signifie que vous pouvez ouvrir une session et disposer du rôle db_owner database. Pour plus d'informations, consultez la section qui traite de l'attribution de droits d'accès aux bases de données aux utilisateurs ou aux groupes Windows dans la documentation fournie avec Microsoft SQL Server.


Description des canaux

Un canal est un ensemble de propriétés que vous utilisez pour configurer les services d'échanges BizTalk afin de traiter les documents qu'il reçoit. Il est possible de créer des canaux pour un port d'échanges ou une liste de distribution. Lorsque le canal a terminé le traitement d'un document, le document est transmis à la destination spécifiée dans le port d'échanges associé ou aux ports d'échanges définis dans la liste de distribution associée. Vous pouvez créer un ou plusieurs canaux pour un port d'échanges ou une liste de distribution.

Dans le canal, spécifiez la source des documents, qui peut être une organisation source ou une application source. Avant de pouvoir désigner une application comme source pour un canal, vous devez créer une application pour l'organisation d'origine, qui représente une application interne à votre entreprise. Vous pouvez également désigner une planification XLANG comme source pour un canal. La création d'une planification XLANG s'effectue à l'aide du Concepteur d'orchestration BizTalk. Pour plus d'informations, voir Conception des orchestrations BizTalk. Pour plus d'informations sur l'intégration des services d'échanges BizTalk aux services d'orchestration BizTalk, voir Intégration des services BizTalk.

Vous avez également la possibilité de déclarer explicitement une source ouverte, ce qui signifie que la source doit être spécifiée dans le document ou dans un paramètre lorsque le document est envoyé. On parle alors de canal ouvert. Pour plus d'informations, voir Submitting.

Spécifiez également une définition de document entrant,, qui représente un document entrant provenant d'une application interne ou de l'organisation d'un partenaire commercial. Enfin, spécifiez une définition de document sortant, qui représente le document à transmettre à la destination indiquée. Pour plus d'informations sur les définitions de document, voir Description des définitions de documents.

Si un document sortant ne dispose pas des mêmes formats ou structures que le document entrant, vous devez spécifier un mappage pour le canal. Un mappage permet de transformer le format ou la structure du document d'origine entrant et de lui appliquer le format ou la structure du document sortant, requis par l'organisation ou l'application de destination. Par exemple, si votre application comptable génère des bons de commande au format fichier plat délimité mais que votre partenaire commercial utilise des bons de commande au format X12, vous pouvez utiliser un mappage pour modifier le format du document. Pour plus d'informations sur les mappages, voir Utilisation du Mappeur BizTalk.

Vous pouvez créer plusieurs canaux pour un port d'échanges ou une liste de distribution, chacun d'entre eux présentant une configuration différente. Supposez par exemple que vous possédez deux applications comptables internes qui génèrent des bons de commande dans des formats différents et que votre partenaire commercial souhaite recevoir des bons de commande dans un format encore différent. Vous pouvez créer un port d'échanges unique pour ce partenaire commercial. Ensuite, pour ce port d'échanges, vous pouvez créer un canal pour chaque application. La définition des documents sortants pour les deux canaux est ainsi identique et correspond au format de votre partenaire commercial. Cependant, chaque canal dispose d'un mappage différent pour modifier les formats des documents entrants des applications. La création de canaux différents, connectés à un port d'échanges unique, vous permet donc d'envoyer tous vos bons de commande dans un même format.

Par ailleurs, vous pouvez définir d'autres propriétés dans un canal pour effectuer les opérations suivantes :

  • Désigner des champs de spécification pour effectuer le suivi de la définition du document entrant. Les champs désignés sont consignés dans une base de données de suivi pour chaque instance de document traitée en utilisant ce canal spécifique, à la place des champs de suivi global désignés dans la définition de document. Pour plus d'informations sur les champs de suivi global, voir Suivi des champs de données d'un document.

  • Créer une expression de filtrage de canal, qui détermine si BizTalk Server 2002 doit appeler le canal et qui est basée sur la valeur attribuée à un ou plusieurs champs dans le document en cours de traitement.

  • Configurer des accusés de réception. Vous pouvez demander un accusé de réception au destinataire du document que vous envoyez et vous pouvez aussi en générer un pour l'expéditeur du document que vous recevez. Pour plus d'informations sur le traitement des accusés de réception, voir Description des accusés de réception.

  • Configurer les propriétés de sécurité. Vous pouvez demander la vérification, par le serveur, du cryptage et de la signature des documents entrants ou l'apposition d'une signature numérique sur les documents sortants.

  • Spécifier des options pour la consignation des documents. Vous pouvez stocker les documents entrants et sortants dans leur format d'origine, dans leur format XML intermédiaire ou dans les deux formats.

  • Définir les propriétés avancées. Vous pouvez spécifier un numéro de contrôle de groupe pour des documents au format EDI, définir le nombre de tentatives et la durée au bout de laquelle le serveur renvoie les documents et enfin, remplacer le composant de transport ainsi que les propriétés d'enveloppe pour le port d'échanges ou la liste de distribution.

Vous pouvez aussi créer des canaux d'accusé de réception en utilisant le Gestionnaire d'échanges BizTalk. Un canal d'accusé de réception est un type de canal particulier que vous utilisez pour renvoyer un accusé de réception à l'émetteur d'un document reçu par les services d'échanges BizTalk. Lorsque vous créez un canal pour traiter un document entrant qui requiert un accusé de réception, vous pouvez spécifier le canal d'accusé de réception que le serveur doit utiliser pour traiter l'accusé. Pour cela, vous devez donc créer un port d'échanges et un canal d'accusé de réception associé avant de créer un port d'échanges et un canal pour traiter un document qui nécessite un accusé de réception. Pour plus d'informations sur le traitement des accusés de réception, voir Description des accusés de réception.

Attention

  • Lorsque vous créez un canal d'accusés de réception, les définitions des documents entrant et sortant adoptent par défaut la valeur Accusé de réception standard BizTalk, et ne peuvent pas être transformées par un mappage. Pour utiliser un format différent pour un accusé de réception sortant, vous devez créer et sélectionner une définition de document entrant qui fait référence à la spécification standard pour les accusés de réception dans le référentiel WebDAV. Vous devez également créer une définition de document sortant qui se réfère à une spécification ayant le format que vous voulez attribuer à l'accusé de réception sortant et à un mappage qui transforme le format de l'accusé de réception.

À la réception d'un document, BizTalk Server 2002 localise le canal approprié, qui oriente le serveur sur la façon de traiter le document. Le serveur localise ensuite le port d'échanges ou la liste de distribution associée au canal. Le port d'échanges dirige le serveur à travers la séquence d'étapes nécessaires à la transmission du document vers la destination spécifiée. Si le canal est associé à une liste de distribution, le serveur utilise les propriétés de chaque port d'échanges de la liste de distribution pour transmettre le document aux destinations spécifiées.

Cette section traite des rubriques suivantes :

  • Éléments de canal

  • Combinaisons de canal et de port d'échanges valides


Éléments de canal

Les canaux sont constitués des éléments suivants :

Organisation ou application source

Lors de la création d'un canal, vous devez désigner une application ou une organisation comme source pour les documents. Une application source est toujours une application de gestion de votre organisation d'origine. Il peut s'agir d'une application comptable, d'un système de saisie des bons de commande ou d'une application de gestion. Vous pouvez également désigner une planification XLANG comme source des documents. La création d'une planification XLANG s'effectue en utilisant le Concepteur d'orchestration BizTalk. Une organisation source représente toujours un partenaire commercial externe.

Un canal est toujours créé pour un port d'échanges ou une liste de distribution. La destination des documents que vous recevez depuis la source d'un canal est désignée dans le port d'échanges, ou dans les ports d'échanges de la liste de distribution, pour lesquels le canal a été créé.

Définitions de documents entrants et sortants

Dans un canal, les définitions de document représentent les documents entrants et sortants traités par BizTalk Server 2002. La définition de document fournit un pointeur vers une spécification qui définit le document. La spécification définit des caractéristiques telles que la structure, le type et la version du document. Pour plus d'informations, voir Description des définitions de documents.

À la réception d'un document, BizTalk Server 2002 localise le canal approprié pour le traiter. Le serveur utilise la spécification de la définition du document entrant pour convertir le document entrant dans un format XML (Extensible Markup Language) intermédiaire. Le serveur mappe le format et la structure du document entrant au format et à la structure du document sortant, si nécessaire. Ensuite, le serveur utilise la spécification du document sortant pour le convertir dans le format et la structure que l'application ou l'organisation de destination peut reconnaître et utiliser.

Mappage des formats de données

Il se peut que le format ou la structure d'un document entrant soient différents du format ou de la structure requis pour le document sortant. Si tel est le cas, un mappage peut être utilisé pour convertir le format du document entrant au format du document sortant.

Par exemple, si votre application comptable génère des factures au format fichier plat délimité par des virgules, mais que votre partenaire commercial ne puisse recevoir que des factures au format X12, vous pouvez utiliser un mappage dans le canal pour modifier le format.

Un mappage peut également permettre de modifier le contenu et la structure d'un document qui utilise le même format. Pour plus d'informations, voir Utilisation du Mappeur BizTalk.

Suivi et filtrage des propriétés

Vous pouvez désigner des champs de spécification pour qu'ils soient consignés dans une base de données de suivi pour la définition d'un document entrant d'un canal. Les champs de spécification que vous désignez dans un canal sont consignés dans une base de données de suivi pour chaque instance d'un document traité en utilisant ce canal. Ces champs sont consignés à la place de tous les autres champs de suivi global désignés dans la définition du document entrant. Les champs de suivi global désignés pour la définition du document sortant sont ignorés. Pour plus d'informations, voir Suivi des champs de données d'un document.

L'utilisation d'une expression de filtrage de canal est une autre méthode permettant de déterminer les canaux appelés lorsque BizTalk Server 2002 reçoit un document. Dans le cas d'une expression de filtrage de canal, ils sont déterminés en fonction de la valeur d'un ou de plusieurs champs spécifiés dans l'instance du document.

Lorsque le serveur traite un document, la valeur de chaque champ spécifié est comparée à la valeur de l'expression de filtrage du canal. Si l'expression est vraie, le canal est appelé. Si l'expression est fausse, le canal n'est pas appelé. Par exemple, si l'expression de filtrage du canal est créée pour la recherche des bons de commande dont le total est supérieur à 1 000 et si le champ Total du bon de commande dans le document contient la somme 1 500, le canal est appelé.

Propriétés de consignation des documents

BizTalk Server 2002 convertit les documents entrants non-XML, de leur format d'origine vers un format XML Unicode intermédiaire, en vue de leur traitement. BizTalk Server 2002 convertit les documents sortants du format XML Unicode intermédiaire, dans le format requis pour la destination spécifiée. Vous pouvez choisir de stocker les données de chaque document entrant et sortant dans un seul format ou dans les deux.

Voir aussi

Création et gestion de canaux

Description des canaux

Combinaisons de canal et de port d'échanges valides


Combinaisons de canal et de port d'échanges valides

Seule la création de certaines combinaisons de canal (source) et de port d'échanges (destination) est autorisée pour leur utilisation avec Microsoft BizTalk Server 2002.

Les scénarios d'entreprise suivants montrent comment configurer des ports d'échanges avec une destination correcte ainsi que des canaux avec des désignations de sources valides pour transmettre correctement des données.

Scénario 1 : Partenaire commercial vers application interne

Dans ce scénario, vous créez un port d'échanges avec une application de l'organisation d'origine comme destination. Vous créez ensuite un canal pour ce port d'échanges avec l'organisation du partenaire commercial comme source.

Scénario 2 : Application interne vers partenaire commercial

Dans ce scénario, vous créez un port d'échanges avec l'organisation d'un partenaire commercial comme destination. Vous créez ensuite un canal pour ce port d'échanges avec une application de l'organisation d'origine comme source.

Scénario 3 : Application interne vers application interne

Dans ce scénario, vous créez un port d'échanges avec une application de l'organisation d'origine comme destination. Vous créez ensuite un canal pour ce port d'échanges avec une autre application de l'organisation d'origine comme source.

Scénario 4 : Application interne vers liste de distribution

Dans ce scénario, vous créez une liste de distribution, qui inclut un groupe de ports d'échanges existants pour des organisations ou des applications. Vous créez ensuite un canal pour cette liste de distribution avec une application de l'organisation d'origine comme source.

Scénario 5 : Application interne vers destination ouverte

Dans ce scénario, vous créez un port d'échanges que vous définissez en tant que port d'échanges ouvert. Vous créez ensuite un canal pour ce port d'échanges avec une application de l'organisation d'origine comme source.

Scénario 6 : Source ouverte vers application interne

Dans ce scénario, vous créez un port d'échanges avec une application de l'organisation d'origine comme destination. Vous créez ensuite un canal pour ce port d'échanges que vous spécifiez en tant que canal ouvert.

Remarque

  • Un canal défini comme canal ouvert ne peut pas être créé pour un port d'échanges défini en tant que port d'échanges ouvert.

Scénario 7 : Partenaire commercial vers partenaire commercial via un intermédiaire

Dans ce scénario, un premier partenaire commercial envoie des documents à un second partenaire commercial via votre système BizTalk Server et votre entreprise sert d'intermédiaire. Vous créez un port d'échanges avec l'organisation d'un partenaire commercial comme destination. Vous créez ensuite un canal pour ce port d'échanges avec un autre partenaire commercial comme source.

Voir aussi

Éléments de canal

Description des canaux


Description des ports d'échanges

Un port d'échanges est un ensemble de propriétés que vous pouvez utiliser pour configurer les services d'échanges BizTalk afin de transmettre des documents vers une destination spécifique à l'aide d'un service de transport spécifique. Les documents qu'un port d'échanges transporte proviennent de la source que vous avez définie dans un canal associé. Vous pouvez créer plusieurs canaux pour un seul port d'échanges afin d'envoyer des documents de sources différentes vers une destination unique.

Un port d'échanges peut être configuré pour l'envoi de documents vers une organisation de destination spécifiée, une planification XLANG ou une application de destination.

Lorsque vous configurez un port d'échanges vers une organisation, vous pouvez soit désigner un partenaire commercial spécifique comme étant la destination, soit déclarer une destination ouverte, qui est désignée comme étant le port d'échanges ouvert. Un port d'échanges ouvert peut être utilisé pour transmettre des documents uniquement aux organisations des partenaires commerciaux. Pour un port d'échanges ouvert, les données de l'organisation de destination doivent être indiquées dans le document ou dans un paramètre lors de l'envoi du document à BizTalk Server 2002. Pour plus d'informations sur l'envoi de documents, voir Submitting. Pour plus d'informations sur les ports d'échanges ouverts, voir Openness.

Lorsque l'adresse indiquée pour un port d'échanges ouvert est une adresse SMTP, le serveur doit disposer d'une adresse d'expédition pour l'organisation d'origine. Pour obtenir cette adresse, le serveur utilise la valeur spécifiée pour un identificateur d'organisation spécifique de l'organisation d'origine, dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable. Pour plus d'informations sur la façon de configurer cet identificateur d'organisation, voir Configuration de l'organisation d'origine.

Lorsque vous configurez un port d'échanges vers une application, vous pouvez désigner une planification XLANG ou une application de l'organisation d'origine comme destination. Pour plus d'informations sur l'organisation d'origine, voir Description des organisations.

Il est possible de configurer un port d'échanges pour une planification XLANG afin d'activer une nouvelle instance d'une planification XLANG spécifique, puis de transmettre le document vers un port d'échanges spécifique de cette planification. Dans ce cas, la planification spécifiée doit contenir un port d'échanges lié aux services d'échanges BizTalk. Lorsque vous spécifiez la planification, vous définissez également le port d'échanges. Vous pouvez aussi configurer un port d'échanges pour transmettre un document à une instance en cours d'une planification XLANG. Dans ce cas, le document doit contenir le nom d'une file d'attente vers laquelle transmettre le document, laquelle est contrôlée par la planification cible. Pour plus d'informations sur l'intégration des services d'échanges BizTalk avec les services d'orchestration BizTalk, voir Intégration des services BizTalk.

Les propriétés de port d'échanges servent également à désigner une adresse spécifique à laquelle envoyer des documents, le type de transport utilisé pour transmettre les documents vers cet emplacement et la façon dont les documents sont regroupés dans des enveloppes et protégés avant le transport.

À la réception d'un document, BizTalk Server 2002 localise le canal approprié pour le traiter. Une fois que le canal a traité le document, il dirige le serveur vers son port d'échanges ou sa liste de distribution associés, qui dirigent à leur tour le serveur à travers la séquence d'étapes nécessaires à la mise sous enveloppe, la protection et le transport du document vers la destination spécifiée.

Cette section traite des rubriques suivantes :

  • Éléments de port d'échanges

  • Ports d'échanges ouverts


Éléments de port d'échanges

Les ports d'échanges sont constitués des éléments suivants :

Destination

Pour un port d'échanges, la destination peut être l'organisation d'un partenaire commercial, une planification XLANG ou une application d'une organisation d'origine.

Un port d'échanges pour une organisation peut explicitement désigner l'organisation de destination, ou un port d'échanges peut être défini comme port d'échanges ouvert. Pour les ports d'échanges ouverts, l'organisation de destination est déterminée lors du traitement du document par le port d'échanges. Les informations relatives à l'organisation de destination doivent être spécifiées dans le document ou dans les paramètres lors de l'envoi du document. Pour plus d'informations, voir Submitting.

Un port d'échanges pour une planification XLANG peut être configuré de deux façons. Vous pouvez configurer un port d'échanges pour activer une nouvelle instance d'une planification XLANG en spécifiant le chemin d'accès à une planification XLANG. Lorsque le port d'échanges traite un document, il active cette planification puis transmet le document à un port d'échanges dans cette planification, que vous spécifiez également dans les propriétés du port d'échanges. Vous pouvez également configurer le port d'échanges pour transmettre des documents à une planification XLANG. Cette option doit être utilisée uniquement lorsque vous envoyez un message à un partenaire commercial et lorsque celui-ci renvoie un message sur une page ASP en utilisant un transport HTTP. Pour plus d'informations, voir Intégration des services BizTalk. La création d'une planification XLANG s'effectue à l'aide du Concepteur d'orchestration BizTalk. Pour plus d'informations, voir Conception des orchestrations BizTalk.

Un port d'échanges peut également transmettre des documents à une application de destination d'une organisation d'origine. Avant de pouvoir désigner une application comme application de destination pour un port d'échanges, vous devez l'ajouter à une organisation d'origine. Pour plus d'informations, voir Ajout d'applications.

Propriétés de transport

Les propriétés de transport que vous spécifiez pour un port d'échanges déterminent le service de transport utilisé pour transmettre les documents à l'organisation ou à l'application de destination, ainsi que l'adresse à laquelle les documents sont envoyés.

Les propriétés de transport définies pour un port d'échanges s'appliquent à tous les canaux associés à ce port d'échanges. Dès que BizTalk Server 2002 a appelé un canal pour traiter des documents, le serveur récupère les propriétés du port d'échanges associé à ce canal. Le serveur envoie les documents à l'adresse spécifiée dans le port d'échanges en utilisant le type de transport indiqué dans le port d'échanges.

Vous pouvez aussi définir une fenêtre de service, qui permet d'indiquer un intervalle de temps au cours duquel les documents peuvent être envoyés. Les heures figurant dans les fenêtres de service sont affichées aux format UTC (Universal Coordinated Time – Temps universel coordonné) et correspondent à l'heure définie sur le serveur.

Informations d'enveloppe

Les enveloppes sont des en-têtes et parfois des pieds de page utilisés pour ajouter un préfixe ou encapsuler les documents transmis. Un en-tête d'enveloppe contient des informations relatives aux documents qu'il contient et des informations sur la façon de les transporter. Un en-tête d'enveloppe contient l'identificateur de l'organisation source, l'identificateur de l'organisation de destination ainsi que des informations sur le type de document qu'il contient.

BizTalk Server 2002 peut recevoir et traiter des échanges qui contiennent plusieurs documents et groupes de documents. Lors du transport de documents utilisant une enveloppe, BizTalk Server inclut chaque document dans un échange distinct.

L'utilisation d'enveloppes est facultative, mais si vous choisissez d'en utiliser, le format d'enveloppe spécifié dans un port d'échanges doit être conforme au format du ou des documents qu'il contient. Le format de document est déterminé par la spécification à laquelle fait référence la définition de document sortant d'un canal associé. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, vous devez sélectionner une définition de document sortant pour le canal pointant vers une spécification X12. Inversement, si vous sélectionnez une définition de document sortant dans un canal, le port d'échanges auquel le canal est associé doit avoir une enveloppe avec un format compatible. Par exemple, si vous sélectionnez une définition de document sortant dont la spécification est au format X12, vous devez spécifier une enveloppe au format X12 dans le port d'échanges.

Propriétés de sécurité

Les propriétés de sécurité définies pour un port d'échanges s'appliquent à tous les canaux associés à ce port d'échanges. Par exemple, si vous choisissez le cryptage S/MIME (Secure Multipurpose Internet Mail Extensions) pour un port d'échanges, tous les documents traités par les canaux associés à ce port d'échanges sont cryptés au moyen du mode de cryptage spécifié.

Si vous disposez de documents qui doivent être sécurisés au moyen d'un autre mode de cryptage ou bien qu'il n'est pas nécessaire de crypter, vous devez créer un port d'échanges distinct avec les propriétés de sécurité destinées à ces documents.

BizTalk Server 2002 prend en charge le codage MIME (Multipurpose Internet Mail Extensions).

Le standard MIME pour le format des messages spécifie la façon de formater les messages pour que les programmes clients puissent décoder et afficher le contenu des messages complexes, lesquels peuvent contenir du texte enrichi, différents jeux de caractères et des pièces jointes en mode binaire telles que des images, des sons et des feuilles de calcul. La technologie MIME est plus évoluée et plus souple que la technologie uuencode et fournit des systèmes souples et génériques pour inclure du contenu dans des messages. Le formatage MIME permet les opérations suivantes :

  • spécifier des modes de codage de contenu différents pour chaque partie du corps du message ;

  • relier des groupes constitués de plusieurs parties de contenus dans un message ;

  • utiliser des jeux de caractères autres que les jeux de caractères ASCII-US dans des corps de messages et dans des champs d'en-têtes ;

  • spécifier la disposition souhaitée pour le contenu (par exemple, inséré ou joint).

BizTalk Server 2002 prend en charge le mode de cryptage S/MIME utilisant les clés publiques et basé sur des certificats.

Le cryptage peut être appliqué aux données d'entreprise que vous transmettez à vos partenaires commerciaux. En utilisant un certificat de cryptage pour sécuriser les données, vous pouvez vous assurer que seul le destinataire attendu accède aux informations.

Pour crypter les données d'entreprise, l'organisation source doit posséder une copie de la clé publique utilisée pour le certificat de cryptage de l'organisation de destination. L'organisation source utilise la clé publique du certificat pour crypter les données d'entreprise puis transmet les données cryptées à l'organisation de destination. L'organisation de destination peut ensuite utiliser la clé privée du certificat de cryptage pour décrypter ces données d'entreprise.

Pour les ports d'échanges ouverts les propriétés de sécurité pour le cryptage sont désactivées car l'organisation de destination n'est pas connue.

BizTalk Server 2002 prend en charge le mode de signature numérique S/MIME utilisant les clés publiques et basé sur des certificats. Pour plus d'informations sur les certificats, voir Présentation des certificats.

Les signatures numériques peuvent être utilisées pour garantir l'authenticité de la source des données, pour garantir que les données n'ont pas été modifiées et pour éviter que la source des données ne rejette le message.

Les certificats de signatures sont utilisés pour créer des signatures numériques qui permettent d'authentifier des données. La signature n'altère pas les données mais elle génère une chaîne pour la signature numérique, qui est envoyée avec les données ou transmise séparément.

Pour signer numériquement un document, les données sont traitées pour créer le digest d'un message. Il s'agit d'une chaîne de texte compressée qui a été créée à partir d'un message. La clé privée de l'organisation source est ensuite utilisée pour crypter le digest de message afin de former la signature numérique. Les données sont transmises avec la signature numérique au destinataire.

Pour pouvoir vérifier une signature numérique, le destinataire doit posséder une copie de la clé publique du certificat de signature de l'émetteur. Le destinataire décrypte le digest à partir de la signature qui a été envoyée, puis calcule indépendamment un digest de message. Les résultats des deux digests sont comparés ; s'ils sont identiques, cela signifie que les données n'ont pas été falsifiées.

Remarques

  • Si vous envoyez des données au format MIME en utilisant le protocole SMTP, un nom de fichier généré par le système apparaît dans le corps principal du message en sortie, et les données s'affichent sous la forme d'une pièce jointe.

  • Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création et gestion des ports d'échanges

Ports d'échanges ouverts

Description des ports d'échanges


Ports d'échanges ouverts

Un port d'échanges ouvert est un port d'échanges vers une organisation pour lequel vous n'avez pas déclaré explicitement une organisation de destination spécifique. Un port d'échanges ouvert ne peut pas avoir une application comme destination.

Pour un port d'échanges ouvert, les informations relatives à la destination et au transport doivent être fournies dans le document ou dans les paramètres lorsque le document est transmis à Microsoft BizTalk Server 2002. Lorsque des paramètres d'envoi sont utilisés, ils prévalent sur les informations de destination et de transport que le document contient. Pour plus d'informations sur l'envoi de documents, voir Submitting.

Lorsque vous créez un canal pour un port d'échanges ouvert et que les informations de destination sont fournies dans le document, la définition de document entrant pour ce canal doit référencer une spécification correctement configurée. Pour plus d'informations sur la configuration d'une spécification de document permettant de traiter les documents pour un port d'échanges ouvert, voir Définition des propriétés du dictionnaire.

Pour les ports d'échanges ouverts, les propriétés de sécurité pour le cryptage sont désactivées car l'organisation de destination n'est pas connue. Pour définir les propriétés de cryptage, vous devez indiquer un certificat appartenant à une organisation de destination spécifique et connue. Les certificats de cryptage permettent de crypter des documents transportés vers une organisation de destination précise.

Vous pouvez utiliser un port d'échanges ouvert pour envoyer un ou plusieurs documents standardisés à plusieurs organisations de partenaires commerciaux actuelles ou futures sans avoir à créer un port d'échanges pour chaque destination. Tous les documents partagent les mêmes propriétés d'enveloppe, de sécurité et de transport, qui sont définies dans le port d'échanges.

Un port d'échanges ouvert se distingue d'une liste de distribution pour les raisons suivantes :

  • Lorsqu'un port d'échanges est ouvert, les documents d'un canal sont diffusés un à un et vers une destination unique. L'utilisation d'une liste de distribution permet de diffuser les documents d'un canal vers plusieurs destinations.

  • Lorsqu'un port d'échanges est ouvert, vous n'avez pas besoin de modifier ses propriétés pour transmettre des données à l'organisation d'un autre partenaire commercial. Avec une liste de distribution, vous devez ajouter un port d'échanges pour envoyer des informations à une autre organisation d'un partenaire commercial.

Important

  • Lorsque vous déclarez un port d'échanges comme port d'échanges ouvert, vous ne devez pas créer de canaux pour le port d'échanges dont la définition du document sortant comporte une spécification X12 ou EDIFACT. Pour générer une enveloppe au format X12 ou EDIFACT, le serveur doit posséder un identificateur d'organisation source et de destination. Un port d'échanges ouvert ne spécifie pas l'identificateur de l'organisation de destination. De plus, les documents d'un port d'échanges ouvert doivent contenir l'adresse de destination, mais les documents X12 et EDIFACT n'incluent pas cette information.

Voir aussi

Création et gestion des ports d'échanges

Éléments de port d'échanges

Description des ports d'échanges


Description des organisations

Les organisations que vous créez en utilisant le Gestionnaire d'échanges BizTalk représentent les partenaires commerciaux avec lesquels vous échangez des documents. Le type d'organisation spécial, appelé l'organisation d'origine représente votre entreprise.

Organisation d'origine

Le Gestionnaire d'échanges BizTalk crée automatiquement l'organisation d'origine. Lorsque vous la configurez, vous pouvez la renommer pour la reconnaître plus facilement comme étant votre entreprise. Il existe une seule organisation d'origine et vous ne pouvez pas la supprimer.

Il est impossible de désigner l'organisation d'origine comme étant la source ou la destination des documents dans un port d'échanges ou dans un canal. Seules les applications de l'organisation d'origine peuvent être désignées comme la source ou la destination des documents dans votre entreprise. Par exemple, vous pouvez créer un port d'échanges qui désigne l'organisation d'un partenaire commercial comme la destination des documents que votre entreprise envoie. Ensuite, lorsque vous créez un canal pour ce port d'échanges, au lieu de désigner votre organisation d'origine comme étant la source, vous pouvez désigner une application interne spécifique à votre entreprise, d'où proviennent les documents. Vous pouvez également désigner une application de l'organisation d'origine comme étant la source des documents dans un canal et une autre application comme étant la destination dans un port d'échanges.

Applications de l'organisation d'origine

Les applications que vous ajoutez dans l'organisation d'origine vous permettent d'identifier et de suivre le flux des documents entre Microsoft BizTalk Server 2002 et les applications internes à votre entreprise. Toutefois, le simple fait de créer une application et de la désigner comme source ou destination dans le Gestionnaire d'échanges BizTalk ne permet pas de contrôler ou d'activer le flux des documents en provenance ou à destination d'une application interne. Pour intégrer une application interne à BizTalk Server 2002 et diriger le flux des documents en provenance ou à destination de cette application, vous devez configurer le serveur en conséquence.

Il existe plusieurs moyens de transmettre des documents d'une application source vers BizTalk Server. La configuration permettant d'intégrer une application pour qu'elle puisse transmettre des documents au serveur s'effectue entièrement en dehors du Gestionnaire d'échanges BizTalk. Pour plus d'informations, voir Submitting.

La transmission de documents en provenance de BizTalk Server vers une application interne peut nécessiter une configuration interne et externe au Gestionnaire d'échanges BizTalk. Le type de transport et l'adresse spécifiés dans un port d'échanges peuvent déterminer un emplacement spécifique auquel les documents sont transmis. Une application ou un composant distinct doit alors être configuré pour extraire les documents reçus à cet emplacement pour l'application de destination. Vous pouvez également, dans les propriétés de transport d'un port d'échanges, spécifier un composant pour l'intégration des applications qui est capable de transmettre directement les documents à une application. Pour plus d'informations, voir Description des ports d'échanges.

Organisations des partenaires commerciaux

Toutes les autres organisations que vous créez avec le Gestionnaire d'échanges BizTalk représentent les partenaires commerciaux externes ou les unités commerciales d'un partenaire. Vous pouvez créer un nombre illimité d'organisations. Vous avez également la possibilité de désigner l'organisation d'un partenaire commercial comme source des documents dans un canal ou comme destination des documents dans un port d'échanges.

Vous pouvez aussi désigner un premier partenaire commercial comme étant la source des documents dans un canal et un second comme étant la destination dans un port d'échanges. Dans ce cas, votre entreprise tient lieu d'intermédiaire entre les deux partenaires commerciaux.

Comme c'est également le cas pour les applications, le simple fait de créer une organisation et de la désigner comme source ou destination dans le Gestionnaire d'échanges BizTalk ne permet pas d'activer le flux des documents en provenance ou à destination de cette organisation. Pour contrôler et diriger le flux des documents entre les organisations de votre partenaire et BizTalk Server 2002, vous devez configurer le serveur en conséquence.

Un partenaire commercial externe agissant en tant qu'organisation source dispose de plusieurs moyens pour transmettre des documents à votre serveur BizTalk Server. La configuration nécessaire pour cela est similaire à celle permettant d'intégrer les applications pour qu'elles puissent transmettre des documents au serveur. Elle s'effectue également entièrement en dehors du Gestionnaire d'échanges BizTalk. Pour plus d'informations, voir Submitting.

La transmission des documents en provenance de votre serveur BizTalk Server à un partenaire commercial externe désigné comme étant l'organisation de destination peut nécessiter une configuration interne et externe au Gestionnaire d'échanges BizTalk. Le type de transport et l'adresse spécifiés dans un port d'échanges déterminent un emplacement spécifique auquel les documents sont remis. L'organisation de destination, qui doit avoir accès à cet emplacement, peut alors configurer son serveur BizTalk Server, l'une de ses applications internes ou un composant distinct pour traiter les documents reçus à cet emplacement. Pour plus d'informations sur la configuration des ports d'échanges, voir Description des ports d'échanges.

Cette section traite de la rubrique suivante :

  • Identificateurs d'organisation


Identificateurs d'organisation

Microsoft BizTalk Server 2002 et les partenaires commerciaux utilisent des identificateurs d'organisation pour identifier de façon unique des organisations. Une organisation peut posséder plusieurs identificateurs ; cependant, chaque identificateur doit être unique pour cette organisation. Par exemple, un numéro de téléphone, une adresse URL ou un numéro DUNS (Data Universal Numbering System) peuvent chacun identifier une organisation de façon unique, mais deux organisations ne peuvent pas utiliser le même numéro de téléphone comme identificateur d'organisation.

Un identificateur d'organisation se compose de trois éléments distincts : un nom, un qualificateur et une valeur. Ainsi, une entreprise peut utiliser un numéro de téléphone pour s'identifier de façon unique. Dans l'exemple donné ici, le nom de l'identificateur est « numéro de téléphone », le qualificateur qui identifie l'identificateur en tant que numéro de téléphone est le 12 et enfin, la valeur du numéro de téléphone est (01-21-85-94-66). Chaque nom d'identificateur d'organisation possède un qualificateur unique utilisé à la place du nom pour indiquer le type d'identificateur. Par exemple, le qualificateur standard pour un identificateur de numéro de téléphone est le 12. Lorsque BizTalk Server 2002 traite des documents, seuls le qualificateur et la valeur sont utilisés pour identifier les organisations.

Chaque organisation doit posséder au moins un identificateur. Lorsque vous créez une organisation, le Gestionnaire d'échanges BizTalk crée un identificateur avec le nom Organisation. Le qualificateur de cet identificateur est OrganisationNom et sa valeur correspond au nom de l'organisation. Cet identificateur est également défini en tant qu'identificateur par défaut, ce qui signifie qu'il est utilisé lorsque aucun autre identificateur n'est spécifié. Vous pouvez créer des identificateurs supplémentaires et désigner n'importe lequel d'entre eux comme l'identificateur par défaut. Il est impossible de supprimer l'identificateur OrganisationNom ou l'identificateur par défaut. L'identificateur par défaut sert à identifier une organisation, à moins que vous ne sélectionniez un autre identificateur d'organisation dans un port d'échanges ou un canal.

Lorsque BizTalk Server 2002 traite et transporte un document, il inclut les identificateurs d'organisation de l'organisation de destination et de l'organisation source dans l'en-tête d'enveloppe. Lorsque BizTalk Server 2002 reçoit des documents, il recherche les données relatives à l'organisation source et les identificateurs de l'organisation de destination. Le serveur utilise ensuite les identificateurs et le nom de la définition de document pour déterminer les canaux à utiliser afin de traiter les documents.

Les échanges effectués au format EDI présentent des restrictions quant à l'utilisation des identificateurs d'organisation. Lorsque vous utilisez un identificateur d'organisation pour des enveloppes au format X12, vous ne devez pas utiliser l'identificateur d'organisation nommé Organisation ni tout autre identificateur dont le qualificateur possède plus de 2 caractères ou dont la valeur est supérieure à 15 caractères. Lorsque vous utilisez un identificateur d'organisation pour des enveloppes au format EDIFACT, vous ne devez pas utiliser l'identificateur d'organisation nommé Organisation ni tout autre identificateur dont le qualificateur possède plus de 4 caractères ou dont la valeur est supérieure à 35 caractères.

Remarques

  • Si le serveur trouve un qualificateur vide et une valeur non vide lors du traitement d'un document entrant présentant un format EDIFACT, il convertit le qualificateur vide en un tiret (-). Si vous souhaitez traiter un document entrant au format EDIFACT comportant un qualificateur vide ou une enveloppe sortante avec un qualificateur vide, vous devez créer un identificateur d'organisation personnalisé dont le qualificateur correspond à un seul tiret. Pour un document EDIFACT sortant, le serveur convertit le tiret en un qualificateur vide.

  • Si le serveur trouve un qualificateur vide et une valeur non vide lors du traitement d'un document entrant présentant un format autre que EDIFACT, il convertit le qualificateur vide en OrganizationName.

Voir aussi

Création et gestion d'organisations

Description des organisations


Description des définitions de documents

Une définition de document est un type spécifique de document traité par Microsoft BizTalk Server 2002. Une définition de document représente le type de document entrant ou sortant dans un canal et fournit un pointeur vers une spécification de document. La spécification de document définit la structure, le type et la version du document. Une même spécification peut être utilisée dans un nombre illimité de définitions de document et une même définition de document peut être utilisée dans un nombre illimité de canaux.

Si le format et la structure du document entrant et du document sortant dans un canal sont identiques, vous pouvez utiliser la même spécification pour les deux. Dans le cas contraire, vous devez spécifier un mappage que le serveur utilise pour convertir le format ou la structure du document entrant dans celui ou celle du document sortant.

Lorsque BizTalk Server 2002 reçoit un document, il identifie le canal approprié ou les canaux qui possèdent les définitions de document entrant correspondantes. La définition de document entrant pour chaque canal pointe vers une spécification. Le serveur utilise cette spécification pour convertir un document non-XML entrant, de son format d'origine dans un format XML intermédiaire, ainsi que pour valider la structure du document. La définition de document sortant pour le canal pointe vers une spécification. Le serveur utilise la spécification de document sortant pour valider la structure des données du document sortant. Si nécessaire, le serveur peut aussi utiliser la spécification pour convertir le document sortant au format XML dans un format que l'organisation de destination ou que l'application de destination peut reconnaître et utiliser. La destination est désignée dans le port d'échanges avec lequel le canal est associé.

La spécification de document pour une définition de document est facultative ; toutefois, dans la plupart des cas, vous devez en sélectionner une. Si vous ne sélectionnez aucune spécification, vous pourrez constater les points suivants :

  • Les données que vous traitez ne seront pas converties au format XML du côté entrant, ni converties à partir du format XML du côté sortant.

  • Les données ne seront pas validées par rapport à une spécification afin de garantir qu'elles ne contiennent pas d'erreurs.

  • Vous ne pourrez pas transformer la structure ni le format des données en utilisant un mappage dans un canal.

  • Vous ne pourrez pas spécifier de champs de suivi global ni de critères de sélection.

Une spécification de document n'est pas requise si vous souhaitez utiliser la définition de document pour un envoi direct de données d'un autre format que XML Unicode. C'est le cas, par exemple, si vous voulez envoyer des données binaires via BizTalk Server 2002 vers une destination sans transformer ces données. Dans cet exemple, vous ne devez pas sélectionner de spécification de document pour la définition de document entrant ou sortant du canal qui est utilisé pour l'envoi direct.

Cette section traite des rubriques suivantes :

  • Suivi des champs de données d'un document

  • Description des critères de sélection

Voir aussi

Création et gestion de définitions de document

Utilisation de l'Éditeur BizTalk

Spécification de mappage

Description des canaux


Suivi des champs de données d'un document

Dans une définition de document, vous pouvez désigner des champs contenus dans une spécification pour qu'ils soient consignés dans une base de données de suivi. Les champs que vous désignez dans une définition de document sont suivis pour l'ensemble des instances de documents traitées par les canaux qui utilisent la définition de document comme définition de document entrant. Ces champs étant suivis pour tous les canaux, ils sont désignés comme étant des champs de suivi global.

Lorsque vous sélectionnez une définition de document entrant pour un canal, vous pouvez désigner des champs de spécification dans le canal à suivre. Les champs de spécification que vous indiquez dans un canal sont suivis à la place des champs de suivi global désignés pour les documents traités par ce canal.

Les champs désignés dans une définition de document ou un canal sont consignés dans une base de données de suivi uniquement pour la définition de document entrant du canal. Les champs désignés pour le suivi dans une définition de document sortant du canal ne sont pas suivis.

Le suivi des données des documents traités permet d'analyser les informations associées à vos opérations. Par exemple, le champ d'une facture contenant le montant total peut être suivi pour chaque facture envoyée à vos partenaires commerciaux. Vous pouvez ensuite déterminer le montant total, en francs, des factures envoyées à tous vos partenaires commerciaux pour une période définie ou le montant total en francs pour chacun d'entre eux.

Voir aussi

Création et gestion de définitions de documents

Utilisation de Suivi de documents BizTalk


Description des critères de sélection

Les critères de sélection correspondent à des ensembles de paires nom-valeur que Microsoft BizTalk Server 2002 utilise pour traiter des documents EDI. Pour les documents entrants au format X12 ou les documents EDIFACT, le serveur utilise des critères de sélection pour sélectionner et identifier de façon unique une définition de document car aucun nom de définition de document n'est disponible dans les documents EDI.

Pour les documents au format X12 ou EDIFACT, les critères de sélection permettent de créer les informations d'en-tête de groupe fonctionnel dans l'enveloppe.

Cette section traite des rubriques suivantes :

  • Utilisation de critères de sélection avec des documents entrants

  • Utilisation de critères de sélection avec des documents sortants


Utilisation de critères de sélection avec des documents entrants

Pour traiter des documents entrants, BizTalk Server 2002 doit disposer du nom d'une définition de document entrant. En règle générale, le serveur récupère le nom de la définition de document entrant, soit dans un champ du document entrant, soit à partir d'un paramètre transmis avec le document. Pour plus d'informations, voir Submitting.

Pour les échanges entrants X12 et EDIFACT, les documents peuvent être contenus dans un groupe fonctionnel ou dans des en-têtes d'échanges. BizTalk Server 2002 traite les documents contenus dans ces groupes et ces échanges un par un. Le serveur ne peut obtenir le nom de la définition de document à partir de chaque document car, pour chacun d'entre eux, les informations relatives au document sont contenues dans le groupe fonctionnel ou l'en-tête d'échange. De plus, comme un échange peut contenir plusieurs groupes de types de documents différents, il est impossible de fournir un nom unique de définition de document comme paramètre d'envoi, qui permettrait au serveur d'identifier une définition de document.

Dans ce cas de figure, BizTalk Server 2002 est capable d'extraire les données relatives au document à partir de l'en-tête de groupe fonctionnel (l'en-tête GS d'un échange X12 et l'en-tête UNG d'un échange EDIFACT) ou à partir de l'en-tête d'échange dans un échange EDIFACT sans groupe fonctionnel. En faisant correspondre les valeurs de ces données aux valeurs des critères de sélection spécifiés dans une définition de document, le serveur peut identifier de façon unique la définition de document appropriée.

Afin que BizTalk Server 2002 parvienne à faire correspondre les valeurs des critères de sélection avec les éléments d'en-tête correspondants d'un échange entrant, vous devez saisir les noms des critères de sélection tels qu'ils sont indiqués dans les tableaux ci-après.

Éléments d'en-tête X12

Nom | Condition | Élément GS
identificateur_fonctionnel | Obligatoire | GS01
code_expéditeur_application | Obligatoire | GS02
code_destinataire_application | Obligatoire | GS03
version_standards | Obligatoire | GS08

Éléments d'en-tête EDIFACT

Nom | Condition | Élément UNH | Élément UNG
identificateur_fonctionnel | Obligatoire | S009, 0065 | 0038
code_expéditeur_application | Facultatif | Non utilisé | S006, 0040
code_destinataire_application | Facultatif | Non utilisé | S007, 0044
type_version_standards | Obligatoire | S009, 0052 | S008, 0052
valeur_version_standards | Obligatoire | S009, 0054 | S008, 0054

Voir aussi

Création et gestion de définitions de documents

Description des critères de sélection

Utilisation de critères de sélection avec des documents sortants


Utilisation de critères de sélection avec des documents sortants

Pour traiter un document sortant au format ANSI X12 ou EDIFACT, BizTalk Server 2002 place chaque document dans une enveloppe valide au format approprié. Pour créer l'enveloppe, le serveur insère les données relatives aux valeurs des critères de sélection dans les champs correspondants du groupe et des en-têtes de message. Pour créer des en-têtes, le serveur utilise les valeurs des critères de sélection contenues dans la définition de document sortant pour le canal.

Supposons, par exemple, que vous créez une définition de document dont le critère de sélection est la paire nom-valeur de l'identificateur_fonctionnel/COMMANDES. Si vous l'utilisez ensuite comme définition de document sortant dans un canal, la valeur du champ d'en-tête de groupe qui correspond au critère de sélection nommé identificateur_fonctionnel est définie à COMMANDES dans l'en-tête d'enveloppe.

Afin que BizTalk Server 2002 insère les valeurs des critères de sélection dans les éléments d'en-tête correspondants, vous devez saisir les noms des critères de sélection tels qu'ils sont indiqués dans les tableaux ci-après.

Éléments d'en-tête X12

Nom | Condition | Élément GS
identificateur_fonctionnel | Obligatoire | GS01
code_expéditeur_application | Obligatoire | GS02
code_destinataire_application | Obligatoire | GS03
version_standards | Obligatoire | GS08

Éléments d'en-tête EDIFACT

Nom | Condition | Élément UNH | Élément UNG
identificateur_fonctionnel | Obligatoire | S009, 0065 | 0038
code_expéditeur_application | Facultatif | Non utilisé | S006, 0040
code_destinataire_application | Facultatif | Non utilisé | S007, 0044
type_version_standards | Obligatoire | S009, 0052 | S008, 0052
valeur_version_standards | Obligatoire | S009, 0054 | S008, 0054

Voir aussi

Création et gestion de définitions de documents

Description des critères de sélection

Utilisation de critères de sélection avec des documents entrants


Description des enveloppes

Une enveloppe encapsule des données d'entreprise électroniques en vue de leur transport. Une enveloppe contient des informations d'en-têtes et de pieds de page ou des informations d'en-tête uniquement. Les propriétés d'enveloppe que vous spécifiez fournissent à Microsoft BizTalk Server 2002 les informations nécessaires au serveur pour ouvrir des échanges entrants ou pour créer des échanges sortants. Lorsque vous créez une enveloppe, vous spécifiez un format d'enveloppe ; pour certains types de formats, vous pouvez également sélectionner une spécification.

Les formats d'enveloppe pris en charge par BizTalk Server 2002 sont les suivants : Custom XML (Extensible Markup Language), ANSI X12, EDIFACT, fichier plat (délimité et positionnel), Custom et Reliable. Le format Reliable permet de traiter les enveloppes dont le format est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk Server (www.microsoft.com/france/biztalk/). Si vous spécifiez le format d'enveloppe Custom, vous devez créer et enregistrer un composant parseur pour traiter les enveloppes entrantes ou un composant sérialiseur pour traiter les enveloppes sortantes. Pour plus d'informations, voir Parsers et Serializers.

Formats Custom XML et fichier plat

Pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format Custom XML ou fichier plat, vous devez créer des enveloppes avec un format correspondant. Pour permettre à BizTalk Server de traiter les échanges entrants au format Custom, vous devez créer et enregistrer un composant parseur au format Custom. BizTalk Server peut traiter les échanges entrants aux formats ANSI X12, UN/EDIFACT ou Reliable sans avoir à utiliser d'enveloppes créées avec le Gestionnaire d'échanges BizTalk.

Si vous souhaitez traiter des documents sortants dans n'importe quel format, vous devez créer une enveloppe et la sélectionner dans un port d'échanges afin de créer un échange avec le format d'enveloppe et les informations d'en-tête requis. BizTalk Server place un seul document dans chaque échange sortant.

Formats X12 et EDIFACT

Lorsque vous sélectionnez une enveloppe au format X12 ou EDIFACT dans un port d'échanges, vous devez également spécifier des séparateurs et un numéro de contrôle d'échanges. Ces propriétés EDI (Electronic Data Interchange) s'appliquent uniquement aux enveloppes sélectionnées pour ce port d'échanges. Lorsque vous sélectionnez une enveloppe au format Custom, les séparateurs et le numéro de contrôle d'échanges sont facultatifs et dépendent des composants parseur ou sérialiseur Custom. Lorsque vous créez un canal pour un port d'échanges qui utilise une enveloppe au format X12, EDIFACT ou Custom, vous pouvez spécifier un numéro de contrôle de groupe fonctionnel qui s'applique uniquement aux documents traités par ce canal et cette combinaison de ports d'échanges.

Le format d'enveloppe que vous sélectionnez dans un port d'échanges doit correspondre au format du document sortant qu'il contient. Le format du document sortant est déterminé par la spécification référencée dans la définition de document sortant du canal. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, lorsque vous créez un canal pour ce port d'échanges, vous devez sélectionner une définition de document sortant qui pointe vers une spécification qui soit également au format X12.

Si vous ne spécifiez pas d'enveloppe lors de la création d'un port d'échanges, les données sont envoyées au format XML sans en-tête.

Gestion des caractères DBCS

Problème lié à l'utilisation des langues

L'identificateur de syntaxe UNOX dans EDIFACT est défini comme une technique d'extension du code permettant de traiter les caractères qui ne sont pas codés sur un seul octet. Toutefois, certains pays avaient déjà défini leurs propres normes avant l'introduction de la syntaxe UNOX. Par exemple, en Corée, la norme appelée KEDIFACT marque les données par KECA à la place de UNO*. (La syntaxe UNO* est spécifiée dans les règles du système EDIFACT conformes à la norme ISO 9735.) Les données EDIFACT que BizTalk Server reçoit possèdent un en-tête modifié en caractères UNOA ; cependant les caractères DBCS (Double Byte Character Set, caractères codés sur deux octets) sont conservés. UNOA contient des caractères ASCII en majuscules uniquement et ne convertit pas, à proprement parler, les caractères DBCS.

Pour résoudre cela, le parseur et le sérialiseur EDIFACT ont été mis à jour. Si l'en-tête est en caractères UNOA, le parseur et le sérialiseur EDIFACT acceptent une clé de registre pour définir une page de code, autre que celle par défaut, qui convertit les données. Une valeur du Registre, appelée EDIFACTUNOACodepage, a été ajoutée à l'ensemble des valeurs que BizTalk Server définit. Si la valeur du Registre est 0 (valeur par défaut), BizTalk Server se comporte normalement. Si elle est différente, la valeur correspond à celle de la page de code par défaut utilisée pour convertir les données KEDIFACT résultantes.

Le changement de la page de code est global. Toutes les données EDIFACT passant par BizTalk Server traitent les données selon la page de code EDIFACTUNOACodepage.

Important

  • Les documents EDIFACT possédant l'identificateur de syntaxe UNOX ou UNOY ne sont pas pris en charge dans BizTalk Server 2002.

Remarques

  • Un numéro de contrôle peut être ignoré si une panne grave se produit après l'envoi d'un document, mais avant sa suppression de la file d'attente de travail de BizTalk Server. Pour éviter la sérialisation de toutes les threads, le numéro de contrôle de la base de données BizTalk Server est extrait et incrémenté en dehors de la transactions COM+ mais dans sa propre transaction SQL locale. Par conséquent, tandis qu'un numéro de contrôle peut être utilisé une seule fois, il est possible qu'une thread qui a reçu le numéro de contrôle 1 000 échoue après avoir extrait ce numéro. Dans un tel cas, si le transport est transactionnel, la transmission est annulée. Si la transaction n'a pas eu lieu, il se peut que le message n'ait pas encore été envoyé au moment où l'erreur s'est produite. Dans tous les cas, le numéro de contrôle associé au document est ignoré et n'est pas réutilisé.

  • Lors du traitement d'enveloppes compatibles avec BizTalk Framework 2.0, BizTalk Server 2002 doit être considéré comme étant le point final par rapport au délai d'expiration. Lorsque les documents compatibles avec BizTalk Framework 2.0 sont envoyés à BizTalk Server 2002 soit d'une application, soit d'un partenaire commercial, les champs ci-dessous sont remplacés s'ils sont présents et créés s'ils n'existent pas encore :
    • Dans la sous-section relative aux propriétés :

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Dans la sous-section relative aux informations de réception :

      <sendTo>

      <adresse>

      <sendReceiptBy>

Cette section traite des rubriques suivantes :

  • Utilisation d'enveloppes pour le traitement entrant

  • Utilisation d'enveloppes pour le traitement sortant

Voir aussi

Création et gestion d'enveloppes

Description des ports d'échanges


Utilisation d'enveloppes pour le traitement entrant

Microsoft BizTalk Server 2002 peut traiter un échange entrant au format X12 ou EDIFACT sans avoir à utiliser d'enveloppes créées avec le Gestionnaire d'échanges BizTalk.

Pour permettre à BizTalk Server 2002 de traiter un échange entrant au format fichier plat, vous devez créer une enveloppe en utilisant le Gestionnaire d'échanges BizTalk. Cette enveloppe doit pointer vers une spécification que le serveur est capable d'utiliser pour interpréter et ouvrir l'échange. Le nom de l'enveloppe doit être fourni au serveur lorsque l'échange est transmis pour traitement. Pour plus d'informations, voir Submitting.

Pour permettre à BizTalk Server 2002 de traiter un échange entrant au format Custom XML, vous devez créer une enveloppe en utilisant le Gestionnaire d'échanges BizTalk. Cependant, le serveur est capable de localiser l'enveloppe au format Custom XML qui lui est nécessaire pour interpréter et ouvrir l'échange sans posséder le nom de l'enveloppe fournie pour l'envoi. Vous pouvez fournir le nom de l'enveloppe au serveur lors de l'envoi, mais cela n'est pas obligatoire. Pour plus d'informations, voir Submitting.

Pour permettre à BizTalk Server 2002 de traiter un échange entrant au format Custom, vous devez créer un parseur au format Custom pour ouvrir l'échange. Pour plus d'informations, voir Parsers.

Il n'est pas nécessaire de sélectionner, dans un port d'échanges, les enveloppes que vous créez afin de traiter les échanges entrants pour que le serveur puisse les utiliser. Seules les enveloppes utilisées pour le traitement des échanges sortants doivent être sélectionnées dans un port d'échanges.

Voir aussi

Création et gestion d'enveloppes

Description des enveloppes

Utilisation d'enveloppes pour le traitement sortant


Utilisation d'enveloppes pour le traitement sortant

Les ports d'échanges régulent le flux des données sortant en provenance de Microsoft BizTalk Server 2002 et transmis vers une destination spécifique. Lorsque vous créez un port d'échanges, vous pouvez sélectionner une enveloppe pour les documents qui sont traités par le port d'échanges. Si vous sélectionnez une enveloppe, le format d'enveloppe doit correspondre au format des documents que l'enveloppe contient. Le format des documents est déterminé par la spécification référencée dans la définition de document sortant du canal. Une fois l'enveloppe créée avec le Gestionnaire d'échanges BizTalk, vous pouvez l'utiliser dans un nombre illimité de ports d'échanges.

Lorsque BizTalk Server 2002 traite un document sortant, le serveur utilise les propriétés de l'enveloppe sélectionnée dans le port d'échanges pour créer un échange en encapsulant le document ou en y ajoutant un préfixe. Si vous ne spécifiez pas d'enveloppe pour un port d'échanges, les données sont envoyées au format XML sans en-tête ni pied de page. Si vous spécifiez le format Custom XML et que vous ne sélectionnez pas de spécification d'enveloppe, les données sont envoyées au format Reliable. Le format Reliable permet de traiter les enveloppes dont le format est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk Server (www.microsoft.com/france/biztalk/).

Pour permettre à BizTalk Server 2002 de traiter un échange sortant au format Custom, vous devez créer un sérialiseur afin de créer l'échange. Pour plus d'informations, voir Serializers.

Lorsque vous sélectionnez une enveloppe au format X12 ou EDIFACT, vous devez spécifier un numéro de contrôle d'échanges ainsi que des séparateurs. Un numéro de contrôle d'échanges s'utilise pour identifier et suivre des documents traités au moyen d'un port d'échanges. Le numéro de contrôle d'échanges est incrémenté à chaque utilisation de l'enveloppe et du port d'échanges. Des séparateurs indiquent les caractères utilisés pour séparer les enregistrements et les champs de l'enveloppe et des documents contenus dans cette enveloppe. Les numéros de contrôle d'échanges et les séparateurs sont facultatifs pour les enveloppes au format Custom.

Important

  • Le format d'enveloppe pour un port d'échanges doit correspondre au format du type de document de la spécification référencée par la définition de document sortant pour les canaux associés. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, vous devez sélectionner une définition de document sortant pour le canal pointant vers une spécification X12.

Voir aussi

Création et gestion d'enveloppes

Description des enveloppes

Utilisation d'enveloppes pour le traitement entrant


Description des accusés de réception

Lors de l'échange de documents avec un partenaire commercial, il se peut que les processus définis pour votre entreprise exigent la réception d'accusés de réception pour les documents que vous envoyez ou la génération d'accusés de réception pour les documents que les partenaires commerciaux transmettent à votre entreprise.

Les services d'échanges BizTalk fournissent deux méthodes pour traiter les accusés de réception dans le cadre des échanges. Pour les échanges qui utilisent le parseur X12 ou EDIFACT, ou un parseur Custom qui requiert des accusés de réception, vous pouvez configurer le Gestionnaire d'échanges BizTalk de sorte qu'il utilise les propriétés de canal permettant de traiter les accusés de réception. Pour les échanges qui utilisent le parseur XML, vous pouvez utiliser des échanges au format Reliable, ce qui permet de traiter automatiquement les accusés de réception et de garantir une transmission fiable des données.

Cette section traite des rubriques suivantes :

  • Traitement des accusés de réception à l'aide de canaux

  • Traitement des accusés de réception à l'aide d'échanges au format Reliable


Traitement des accusés de réception à l'aide de canaux

Cette section explique comment configurer les services d'échanges BizTalk pour l'utilisation des propriétés de canal afin de contrôler le traitement des accusés de réception. Le système de destination est configuré pour générer (envoyer) des accusés de réception au système source. Le système source est configuré pour attendre (recevoir) des accusés de réception émis par le système de destination et pour les faire correspondre aux échanges d'origine. Cette configuration ne s'applique que si vous traitez des échanges utilisant le parseur X12 ou EDIFACT ou un parseur Custom qui nécessite des accusés de réception. Pour plus d'informations sur la création de parseurs Custom, voir Parsers. Si vous traitez des échanges qui utilisent le parseur XML, voir Traitement des accusés de réception à l'aide d'échanges au format Reliable.

Si vous utilisez un parseur Custom et que vous souhaitiez faire correspondre les accusés de réception aux échanges d'origine, vous devez créer un composant de corrélation au format Custom.

Afin que le système source puisse recevoir des accusés de réception, le système de destination doit également être configuré pour l'envoi des accusés de réception. La configuration d'un canal sur le système source pour l'attente des accusés de réception ne suffit pas pour les recevoir.

L'illustration suivante représente la configuration nécessaire, pour les systèmes source et de destination, effectuée en utilisant des propriétés de canal pour le traitement des accusés de réception.

Traitement des accusés de réception à l'aide de canaux

Cette section traite des rubriques suivantes :

  • Configuration du système source pour les accusés de réception des canaux

  • Configuration du système de destination pour les accusés de réception des canaux


Configuration du système source pour les accusés de réception des canaux

Cette rubrique explique comment configurer les services d'échanges BizTalk pour envoyer un échange à un partenaire commercial et pour traiter un accusé de réception en utilisant les propriétés d'un canal.

Vous devez créer un canal et un port d'échanges pour traiter et transmettre un échange au système de destination. Il n'est pas nécessaire de créer un canal et un port d'échanges pour traiter l'accusé de réception que le système de destination renvoie. Cependant, vous devez créer une définition de document, que le serveur utilise pour valider l'accusé de réception lorsque celui-ci est renvoyé.

Pour configurer les services d'échanges BizTalk afin qu'ils envoient un échange à un système de destination et qu'ils traitent les accusés de réception en utilisant les propriétés de canal, effectuez les opérations présentées au tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions de document entrants et sortants relatives au document d'origine et destinées à l'échange. Vous devez aussi créer une spécification pour la définition de document que le serveur utilise pour valider l'accusé de réception à sa réception.
  • Création et validation de spécifications

    Remarques

    • Pour la définition de document sortant pour le canal, vous devez créer une spécification qui utilise le format requis par le système de destination. Par exemple, le format X12.

    Lorsque les services d'échanges BizTalk traitent l'échange sur le système de destination et que le parseur demande des accusés de réception, le parseur procède de la façon suivante :

    • Il extrait les éléments d'en-tête de l'échange.

    • Il génère un accusé de réception standard.

    • Il insère les éléments dans l'accusé de réception standard.

    Pour le système source, la spécification de la définition du document sortant du canal, utilisé pour traiter l'échange, doit contenir ces champs. La spécification pour la définition de document nécessaire à la validation de l'accusé de réception doit contenir ces champs. Le système source utilise ces éléments pour faire correspondre l'accusé de réception à l'échange d'origine.

    Les éléments d'en-tête X12 sont les suivants :

    • identificateur_fonctionnel

    • version_standards

    Les éléments d'en-tête EDIFACT sont les suivants :

    • identificateur_fonctionnel

    • type_version_standards

    • valeur_version_standards
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez les définitions de documents entrants et sortants pour la création du canal et une définition de document pour l'accusé de réception.
  • Création de définitions de document

    Remarques

    • Dans les définitions de document, vous devez sélectionner les spécifications que vous avez créées précédemment. Pour plus d'informations, voir Sélection d'une spécification de document.

    • Vous devez également créer une définition de document pour l'accusé de réception.
  • Créez un port d'échanges pour la transmission de l'accusé de réception au système source.
  • Création de ports d'échanges

    Remarque

    • Vous devez créer le port d'échanges et son canal d'accusé de réception pour traiter tout d'abord l'accusé de réception. Lorsque vous créez le canal pour le traitement de l'échange d'origine, vous devez spécifier le canal d'accusé de réception.
  • Créez un port d'échanges pour la transmission de l'échange au système de destination.
  • Création de ports d'échanges
  • Créez un canal pour le traitement de l'échange d'origine provenant de votre partenaire commercial.
  • Création de canaux

    Remarques

    • À la page Application source ou Organisation source de l'Assistant Canal, activez la case à cocher Attendre un accusé de réception.

    • Dans la zone Intervalle des accusés de réception en minutes du champ Attendre un accusé de réception, renseignez le temps que vous souhaitez attendre pour recevoir un accusé de réception et qui doit s'écouler avant le renvoi de l'échange d'origine. Pour plus d'informations, voir Définition des propriétés d'une application source ou Définition des propriétés d'une organisation source.
Utilisation du composant Suivi de documents BizTalk
  • L'échange d'origine est consigné dans la base de données de suivi et le champ d'état (nACKStatus) de l'accusé de réception contient la valeur « Attendre ». L'état de l'accusé de réception, dans la base de données de suivi, sera modifié par la suite pour refléter l'état de l'accusé traité.
  • Présentation des résultats d'enregistrement d'instance de document

  • Description des résultats d'accusé de réception

Envoi d'accusés de réception au système source

Les accusés de réception sont envoyés aux services d'échanges BizTalk de la même façon que les autres types de documents. Une fois qu'un accusé de réception est envoyé, les parseurs X12 et EDIFACT peuvent le distinguer des autres documents et orienter le serveur pour qu'il établisse la correspondance entre l'accusé de réception et l'échange d'origine.

Important

  • Les accusés de réception doivent être envoyés aux services d'échanges BizTalk sans utiliser de paramètres d'envoi.


Configuration du système de destination pour les accusés de réception des canaux

Cette rubrique explique comment configurer les services d'échanges BizTalk pour traiter un échange issu d'un partenaire commercial ainsi que pour générer un accusé de réception à l'aide des propriétés d'un canal. Pour cela, vous devez créer un canal et un port d'échanges afin de traiter l'échange sortant et le transmettre au système de destination. Il n'est pas nécessaire de créer un canal ou un port d'échanges pour traiter l'accusé de réception que le système de destination renvoie. Un parseur traite l'accusé de réception en utilisant une seule définition de document.

Pour configurer les services d'échanges BizTalk afin qu'ils traitent un échange issu d'un système source et qu'ils envoient un accusé de réception en utilisant les propriétés de canal, effectuez les opérations présentées au tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions de documents entrants et sortants utilisées pour créer le canal d'accusé de réception.
  • Création et validation de spécifications

    Remarques

    • Pour la définition de document entrant du canal d'accusé de réception, vous devez utiliser la spécification d'accusé de réception standard. Cette spécification se trouve dans le référentiel WebDAV.

    • Pour la définition de document sortant du canal d'accusé de réception, vous devez créer une spécification qui utilise le format requis par les processus de votre entreprise.

    Lorsque les services d'échanges BizTalk, sur le système de destination, traitent un échange entrant et que le parseur demande des accusés de réception, le parseur procède de la façon suivante :

    • Il extrait les éléments d'en-tête de groupe.

    • Il génère un accusé de réception standard.

    • Il insère les éléments d'en-tête dans l'accusé de réception standard.

    La spécification destinée à la définition de document sortant pour le canal d'accusé de réception doit contenir des champs pour ces éléments d'en-tête. Le système source utilise ces éléments d'en-tête pour faire correspondre l'accusé de réception à l'échange d'origine.

    Les éléments d'en-tête X12 sont les suivants :

    • identificateur_fonctionnel

    • version_standards

    Les éléments d'en-tête EDIFACT sont les suivants :

    • identificateur_fonctionnel

    • type_version_standards

    • valeur_version_standards
  • Créez les spécifications pour les définitions de documents entrants et sortants qui sont utilisées pour la création du canal permettant le traitement de l'échange d'origine à partir du système source.
  • Création et validation de spécifications
Utilisation du Mappeur BizTalk :
  • Créez un mappage pour le canal d'accusé de réception.
  • Création de nouveaux mappages

    Remarques

    • Lorsque vous créez le canal d'accusé de réception, vous devez spécifier un mappage. Le mappage est utilisé pour convertir l'accusé de réception standard dans le type de document approprié au document sortant.

    • Vous pouvez utiliser l'un des mappages proposés dans BizTalk Server 2002 s'il correspond au type de document requis par vos processus d'entreprise. Vous pouvez extraire ces mappages du référentiel WebDAV.

      –Ou–

      Vous pouvez créer votre propre mappage en utilisant la spécification d'accusé de réception standard et une spécification qui correspond au type de document requis par vos processus d'entreprise.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez les définitions de document pour le canal d'accusé de réception et pour le canal que vous utilisez pour traiter l'échange d'origine.
  • Création de définitions de document

    Remarques

    • Dans les définitions de document, vous devez sélectionner les spécifications que vous avez créées précédemment. Pour plus d'informations, voir Sélection d'une spécification de document.

    • Vous devez également créer les définitions de document pour le canal utilisé pour le traitement de l'échange d'origine. La configuration varie en fonction des processus de votre entreprise.
  • Créez un port d'échanges pour la transmission de l'accusé de réception au système source.
  • Création de ports d'échanges

    Remarque

    • Vous devez créer un port d'échanges et son canal d'accusé de réception pour le traitement de l'accusé de réception avant de créer ceux utilisés pour l'échange d'origine. Lorsque vous créez le canal pour le traitement de l'échange d'origine, vous devez spécifier le canal d'accusé de réception.
  • Créez un canal d'accusé de réception à partir d'une application pour traiter l'accusé de réception.
  • Création de canaux

    Remarques

    • À la page Informations générales de l'Assistant Canal, activez la case à cocher Canal d'accusés de réception.

    • À la page Application source de l'Assistant Canal, sélectionnez une application dans la liste Nom.

      Vous pouvez créer une application pour l'organisation d'origine que vous utilisez pour désigner les accusés de réception générés par les parseurs.

    • À la page Document entrant de l'Assistant Canal, cliquez sur Parcourir et recherchez la définition de document que vous venez de créer et qui utilise la spécification d'accusé de réception standard.

    • À la page Document sortant de l'Assistant Canal, cliquez sur Parcourir et recherchez la définition de document que vous venez de créer et qui utilise la spécification avec le type de document requis par les processus de votre entreprise.
  • Créez un port d'échanges pour la transmission des documents contenus dans l'échange d'origine vers leur destination.
  • Création de ports d'échanges

    Remarque

    • Ce port d'échanges ne requiert pas de configuration particulière pour le traitement des accusés de réception.
  • Créez un canal pour le traitement de l'échange d'origine provenant de votre partenaire commercial.
  • Création de canaux

    Remarques

    • À la page Organisation source de l'Assistant Canal, activez la case à cocher Générer un accusé de réception.

    • Dans la zone Générer un accusé de réception, cliquez sur Parcourir et sélectionnez le canal d'accusé de réception que vous avez créé pour traiter l'accusé de réception. Pour plus d'informations, voir Définition des propriétés d'une organisation source.

    • À la page Configuration avancée de l'Assistant Canal, dans la zone Options de nouvel essai, vous pouvez définir un nombre d'essais et un intervalle. Pour plus d'informations, voir Définition des propriétés de configuration avancées.
Utilisation du composant Suivi de documents BizTalk
  • L'échange d'origine et l'accusé de réception sont consignés dans la base de données de suivi.
  • Présentation des résultats d'enregistrement d'instance de document

  • Description des résultats d'accusé de réception


Traitement des accusés de réception en utilisant des échanges au format Reliable

Cette section explique comment configurer les services d'échanges BizTalk pour envoyer et recevoir des accusés de réception en utilisant les enveloppes d'échanges au format Reliable, ce qui permet de créer des échanges compatibles avec BizTalk Framework 2.0. Les échanges au format Reliable permettent de traiter les accusés de réception automatiquement, garantissant ainsi un transfert fiable des données. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk Server (www.microsoft.com/france/biztalk/). Si vous envoyez et recevez des échanges qui utilisent un parseur X12, EDIFACT ou Custom, voir Traitement des accusés de réception à l'aide de canaux.

En utilisant le Gestionnaire d'échanges BizTalk, vous pouvez configurer un port d'échanges pour utiliser un format d'enveloppe Reliable pour un échange sortant. Les enveloppes qui utilisent le format d'échanges Reliable doivent toujours inclure une adresse URL de réponse dans l'en-tête. Cette adresse de réponse est utilisée par le système de destination pour envoyer un accusé de réception au système d'envoi des échanges.

Cette section traite des rubriques suivantes :

  • Configuration du système source pour les accusés de réception des échanges au format Reliable

  • Configuration du système de destination pour les accusés de réception des échanges au format Reliable


Configuration du système source pour les accusés de réception des échanges au format Reliable

Pour configurer les services d'échanges BizTalk afin qu'ils envoient un échange à un système de destination et qu'ils traitent les accusés de réception en utilisant un échange au format Reliable, effectuez les opérations présentées au tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de BizTalk Server Administration :
  • Configurez les propriétés de l'adresse de réponse pour les échanges au format Reliable.
  • Configuration des propriétés générales d'un groupe de serveurs.

    Remarques

    • Dans Administration de BizTalk Server, développez Microsoft BizTalk Server 2002, puis cliquez sur le groupe de serveurs à configurer.

    • Dans le menu Action, cliquez sur Propriétés.

    • Dans la zone URL de réponse d'échange de type Reliable de la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server, tapez l'URL que ce groupe de serveurs utilise pour recevoir l'accusé de réception pour les échanges au format Reliable.

      Lorsque vous créez un échange sortant qui utilise une enveloppeURL de réponse d'échange de type Reliable dans l'en-tête de l'échange sortant. Le serveur place également l'échange d'origine dans la file d'attente de nouvel essai. Le serveur utilise les options de nouvel essai spécifiées dans le canal pour déterminer combien de fois il doit renvoyer l'échange d'origine avant de recevoir un accusé de réception.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une enveloppe qui utilise le format Reliable.
  • Création d'enveloppes

    Remarque

    • Dans la liste Format d'enveloppe de la boîte de dialogue Nouvelle enveloppe, cliquez sur RELIABLE.
  • Créez un port d'échanges pour la transmission de l'échange d'origine au système de destination.
  • Création de ports d'échanges

    Remarque

    • À la page Informations d'enveloppe de l'Assistant Nouveau port d'échanges, sélectionnez l'enveloppe que vous venez de créer dans la zone Informations d'enveloppe. Pour plus d'informations, voir Définition des propriétés des informations d'enveloppe.
  • Créez un canal pour traiter l'échange d'origine.
  • Création de canaux

    Remarques

    • À la page Application source ou Organisation source de l'Assistant Canal, ne définissez aucune propriété d'accusé de réception.

    • À la page Configuration avancée de l'Assistant Canal, dans la zone Options de nouvel essai, vous pouvez définir un nombre d'essais et un intervalle. Pour plus d'informations, voir Définition des propriétés de configuration avancées.
Utilisation du composant Suivi de documents BizTalk
  • Dans le système source, l'échange sortant d'origine est consigné dans la base de données de suivi ; ; en revanche, l'accusé de réception qui est renvoyé ne l'est pas.
  • Présentation des résultats d'enregistrement d'instance de document

  • Description des résultats d'accusé de réception


Configuration du système de destination pour les accusés de réception des échanges au format Reliable

Lorsque les services d'échanges BizTalk du système de destination reçoivent un échange au format Reliable, ils utilisent une définition de document spéciale, un canal et un port d'échanges pour traiter et transmettre un accusé de réception au système source. Il n'est pas possible de visualiser ces objets système particuliers dans le Gestionnaire d'échanges BizTalk, ni de créer des objets similaires en utilisant les noms système réservés.

Le serveur utilise, pour l'accusé de réception, l'adresse de réponse qui est incluse dans l'en-tête de l'échange entrant comme adresse de destination.

Il n'est pas nécessaire de configurer spécifiquement les services d'échanges BizTalk pour que le système de destination renvoie un accusé de réception pour un échange transmis avec une enveloppe au format Reliable, excepté lorsque le système source spécifie une adresse SMTP comme adresse URL de réponse d'échange de type Reliable. Pour envoyer des accusés de réception à une adresse SMTP, votre serveur doit être configuré pour inclure une adresse d'expédition dans l'en-tête de l'accusé.

Lorsque BizTalk Server 2002 est installé, un identificateur d'organisation est créé pour l'organisation d'origine. Cet identificateur est nommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable et ne peut pas être supprimé. Lors de l'envoi d'un accusé de réception pour un échange de type Reliable à une adresse SMTP, le serveur insère la valeur que vous avez indiquée pour cet identificateur d'organisation dans l'en-tête d'échange comme adresse d'expédition.

Pour configurer les services d'échanges BizTalk de façon à ce qu'ils envoient des accusés de réception aux systèmes source en utilisant une adresse SMTP de réponse pour un échange de type Reliable, effectuez les opérations présentées dans le tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation du Gestionnaire d'échanges BizTalk :
  • Définissez l'identificateur d'organisation Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable de l'organisation d'origine.
  • Configuration de l'organisation d'origine

    Remarques

    • Ouvrez l'organisation d'origine.

    • Dans la boîte de dialogue Propriétés de l'organisation, cliquez sur l'onglet Identificateurs.

    • Dans la liste Identificateurs d'organisation, cliquez sur Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable puis sur Modifier.

    • Dans la zone Valeur de la boîte de dialogue Propriétés d'identificateur, tapez une valeur pour l'identificateur. Pour plus d'informations, voir Modification d'identificateurs d'organisation.

    Important

    • Ne modifiez pas le nom ou le qualificateur de cet identificateur, mais uniquement sa valeur.
  • Créez un port d'échanges pour la transmission de l'échange d'origine au système de destination.
  • Création de ports d'échanges

    Remarque

    • Ce port d'échanges ne requiert pas de configuration particulière.
  • Créez un canal pour traiter l'échange d'origine.
  • Création de canaux

    Remarque

    • Ce port d'échanges ne requiert pas de configuration particulière.
Utilisation du composant Suivi de documents BizTalk
  • Dans le système de destination, l'échange entrant est consigné dans la base de données de suivi mais l'accusé de réception ne l'est pas.
  • Présentation des résultats d'enregistrement d'instance de document

  • Description des résultats d'accusé de réception


Description des listes de distribution

Une liste de distribution est un groupe de ports d'échanges qui permet d'envoyer un même document à plusieurs organisations de partenaires commerciaux ou à des applications internes.

Vous pouvez utiliser une liste de distribution pour envoyer simultanément les mêmes données à plusieurs organisations de vos partenaires commerciaux ou aux applications internes de votre organisation d'origine. Vous pouvez par exemple, envoyer le même catalogue, les mêmes tarifs ou bulletins d'informations à différentes organisations en envoyant l'information une seule fois à Microsoft BizTalk Server 2002.

Pour cela, vous devez tout d'abord créer un port d'échanges vers chaque organisation du partenaire commercial ou vers les applications internes auxquelles vous souhaitez envoyer des données, puis ajouter ces ports d'échanges dans une liste de distribution. Les ports d'échanges ouverts ne peuvent pas être ajoutés à une liste de distribution. Vous pouvez créer des ports d'échanges pour des organisations ou des applications internes supplémentaires, puis les ajouter à une liste de distribution existante. Pour plus d'informations, voir Création de ports d'échanges.

Vous devez créer au moins un canal pour chaque liste de distribution pour que la liste de distribution soit fonctionnelle. Pour plus d'informations, voir Création de canaux.

Lorsque BizTalk Server 2002 appelle un canal associé à une liste de distribution, il appelle uniquement le canal associé à cette liste pour traiter les données. Les autres canaux associés à chaque port d'échanges de la liste de distribution ne sont pas appelés. Le serveur utilise les propriétés de chaque port d'échanges pour transmettre successivement les données aux destinations spécifiées dans les ports d'échanges.

Une liste de distribution se distingue d'un port d'échanges pour les raisons suivantes :

  • L'utilisation d'une liste de distribution permet de diffuser les documents d'un canal vers plusieurs destinations. Lorsqu'un port d'échanges est ouvert, les documents d'un canal sont diffusés un à un et vers une destination unique.

  • Avec une liste de distribution, vous devez ajouter un port d'échanges pour envoyer des informations à une autre organisation d'un partenaire commercial. Lorsqu'un port d'échanges est ouvert, vous n'avez pas besoin de modifier ses propriétés pour transmettre des données à l'organisation d'un autre partenaire commercial.

Voir aussi

Utilisation de listes de distribution


Pourquoi effectuer des tâches dans le Gestionnaire d'échanges BizTalk

Cette section explique pourquoi il est nécessaire d'effectuer des tâches dans le Gestionnaire d'échanges BizTalk. Le tableau suivant présente les tâches principales et leurs sous-tâches. Il présente également l'objet de chaque tâche et fournit des liens vers les procédures correspondantes.

Tâche Objet de la tâche
Création et gestion de canaux :
  • Création de canaux
 Traiter des documents reçus via les services d'échanges BizTalk.
  • Définition des propriétés de canal
  • Désigner des champs de spécification pour effectuer le suivi de la définition de document entrant.

  • Créer une expression de filtrage de canal, qui détermine si BizTalk Server doit appeler le canal et qui est basée sur la valeur attribuée à un ou plusieurs champs dans le document en cours de traitement.

  • Configurer les réceptions, les propriétés de sécurité et les options de journalisation des documents.

  • Spécifier un numéro de contrôle de groupe pour des documents au format EDI (Electronic Data Interchange), définir le nombre de tentatives et la durée au bout de laquelle le serveur renvoie les documents ou enfin, remplacer le composant de transport ainsi que les propriétés d'enveloppe pour le port d'échanges ou la liste de distribution.
Création et gestion des ports d'échanges :
  • Création de ports d'échanges
 Transmettre des documents reçus via les services d'échanges BizTalk vers une destination spécifiée.
  • Définition des propriétés d'un port d'échanges
  • Désigner une adresse spécifique à laquelle envoyer des documents.

  • Définir le type de transport utilisé pour transmettre les documents vers cet emplacement.

  • Spécifier la façon dont les documents sont regroupés dans des enveloppes et protégés avant le transport.
Création et gestion d'organisations :
  • Configuration de l'organisation d'origine
  • Remplacer le nom attribué par défaut par le Gestionnaire d'échanges BizTalk par le nom de votre organisation d'origine.

  • Modifier les valeurs des identificateurs de l'organisation d'origine, qui sont des propriétés utilisées pour identifier l'organisation d'origine de façon unique.

  • Définir les propriétés des applications que vous créez pour identifier et suivre le flux des documents entre BizTalk Server et les applications internes dans votre entreprise.
  • Création d'organisations
 Permettre les échanges de documents entre votre entreprise et ses partenaires commerciaux. L'organisation d'origine est votre entreprise. Elle est créée automatiquement pour vous par le Gestionnaire d'échanges BizTalk. Toutes les autres organisations que vous créez sont les partenaires commerciaux externes ou les unités commerciales d'un partenaire.
  • Définition des propriétés d'une organisation
  • Définir les identificateurs des organisations, qui sont des propriétés utilisées pour identifier les organisations de façon unique.

  • Définir les propriétés des applications pour identifier et suivre le flux des documents entre votre entreprise et ses partenaires commerciaux.
Création et gestion de définitions de documents :
  • Création de définitions de documents
 Représenter les types de documents spécifiques traités par BizTalk Server.
  • Définition des propriétés d'une définition de document
  • Créer une spécification de document qui définit la structure, le type et la version d'un document. Une même spécification peut être utilisée dans un nombre illimité de définitions de document et une même définition de document peut être utilisée dans un nombre illimité de canaux.

  • Définir des propriétés de suivi global pour suivre les documents par le biais de la base de données de suivi.

  • Définir des critères de sélection, c'est-à-dire un jeu unique de paires nom-valeur que BizTalk Server utilise pour traiter les documents EDI.
Création et gestion d'enveloppes :
  • Création d'enveloppes
 Encapsuler les données électroniques de l'entreprise en vue de leur transport. Les propriétés d'enveloppe que vous spécifiez fournissent à BizTalk Server les informations nécessaires au serveur pour ouvrir des échanges entrants ou pour créer des échanges sortants.
  • Sélection d'une spécification d'enveloppe
 Appliquer une spécification à un format d'enveloppe.
Utilisation de listes de distribution :
  • Création de listes de distribution
 Envoyer le même document à plusieurs organisations de partenaires commerciaux ou à plusieurs applications internes.


Comment utiliser le Gestionnaire d'échanges BizTalk

Cette section fournit des informations spécifiques aux tâches sur l'utilisation du Gestionnaire d'échanges BizTalk. Nous vous recommandons de consulter la rubrique À propos du Gestionnaire d'échanges BizTalk afin de bien comprendre les relations entre les objets que vous pouvez créer à l'aide du Gestionnaire d'échanges BizTalk.

Cette section traite des rubriques suivantes :

  • Création et gestion de canaux

  • Création et gestion de ports d'échanges

  • Création et gestion d'organisations

  • Création et gestion de définitions de documents

  • Création et gestion d'enveloppes

  • Utilisation de listes de distribution


Création et gestion de canaux

Cette section fournit des informations spécifiques aux tâches sur la création et la gestion des canaux. Il est vivement recommandé de consulter la rubrique Présentation des canaux pour comprendre parfaitement cette notion.

Cette section traite des procédures suivantes :

  • Création de canaux

  • Recherche de canaux

  • Modification de canaux

  • Suppression de canaux

  • Définition des propriétés de canal


Création de canaux

Vous devez créer un port d'échanges ou une liste de distribution avant de créer un canal. Pour plus d'informations, voir Création de ports d'échanges ou Création de listes de distribution.

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Dans la zone Rechercher d'autres éléments, cliquez sur Ports d'échanges ou Listes de distribution, puis sur Rechercher.

  3. Dans la liste Nom du port d'échanges, sélectionnez le port d'échanges pour lequel vous voulez créer un canal.

    –Ou–

    Dans la liste Nom de la liste de distribution, sélectionnez la liste pour laquelle vous voulez créer un canal.

  4. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et sur Canal, puis procédez comme suit :
    • Pour créer un canal à partir d'une organisation, cliquez sur À partir d'une organisation.

    • Pour créer un canal à partir d'une application, cliquez sur À partir d'une application.

    L'Assistant Nouveau canal s'ouvre.

  5. Sur la page Informations générales, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés générales d'un canal.

  6. Exécutez une des étapes suivantes :
    • Si vous créez un canal à partir d'une organisation, définissez les propriétés sur la page Organisation source, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés d'une organisation source.

    • Si vous créez un canal à partir d'une application, définissez les propriétés sur la page Application source, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés d'une application source.
  7. Sur la page Document entrant, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés d'un document entrant.

  8. Sur la page Document sortant, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés d'un document sortant.

  9. Sur la page Journalisation du document, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés de journalisation de document.

  10. Sur la page Configuration avancée, définissez les propriétés, puis cliquez sur Terminer.

    Pour plus d'informations, voir Définition des propriétés de configuration avancées.

  11. Lorsque vous avez défini toutes les propriétés du canal, sur la page Configuration avancée, cliquez sur Terminer pour fermer l'Assistant Nouveau canal.

Remarques

  • Vous ne pouvez pas nommer un canal à l'aide du nom système réservé, Canal des accusés de réception d'échanges au format Reliable.

  • Vous pouvez utiliser cette procédure pour créer un canal standard ou un canal d'accusés de réception. Les procédures de cette section contiennent des remarques décrivant les propriétés qui ne sont pas disponibles lorsque vous créez un canal d'accusés de réception.

  • Si vous créez un port d'échanges et un canal en vue d'une soumission directe de données, vous pouvez uniquement utiliser, pour le canal, la fenêtre de service ainsi que les fonctionnalités de compteur et d'intervalle pour les nouveaux essais. En ce qui concerne le port d'échanges associé, seules les fonctionnalités de transport sont disponibles. Vous ne pouvez utiliser ni la vérification de décodage ou de décryptage, ni le filtrage, ni le suivi de documents, ni les fonctions de mappage du canal.

  • Lorsque vous enregistrez un canal qui fait référence à un mappage en dehors de votre réseau local qui est protégé par un pare-feu Internet, vous risquez d'obtenir un message d'erreur en raison de la configuration du pare-feu. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (www.microsoft.com/france/msdn/telecharge/) et parcourez le chapitre XML du manuel Web Development jusqu'à la page WinHTTP Proxy Configuration Utility.

Voir aussi

Suppression de canaux

Modification de canaux

Recherche de canaux

Définition des propriétés de canal

Description des canaux


Recherche de canaux

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Canaux.

  2. Pour rechercher tous les canaux, effacez tous les critères de recherche, puis cliquez sur Rechercher.

  3. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher un canal portant un nom spécifique, dans la zone Rechercher les canaux, dans la zone Nom du canal, tapez le nom du canal à rechercher, puis cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher un canal à partir d'un type de source spécifique, dans la liste Source, sélectionnez un type de source, puis cliquez sur Rechercher.

    • Pour rechercher un canal associé à un port d'échanges ou à une liste de distribution spécifique, dans la zone Associé au port d'échanges ou à la liste de distribution, tapez le nom du port d'échanges ou de la liste de distribution, puis cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher un canal qui utilise une définition de document spécifique, dans la zone Utilisation de la définition de document, tapez le nom d'une définition de document, puis cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

Notes

  • Vous pouvez définir plusieurs critères de recherche avant de cliquer sur Rechercher.

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Vous pouvez également rechercher des canaux associés à un port d'échanges ou à une liste de distribution spécifique en cliquant avec le bouton droit sur le port d'échanges ou la liste de distribution, puis en cliquant sur Rechercher des canaux.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans vos critères de recherche.
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression de canaux

Modification de canaux

Définition des propriétés de canal

Description des canaux


Modification de canaux

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom du canal, sélectionnez le canal que vous voulez modifier.

    Pour plus d'informations sur la recherche de canaux, voir Recherche de canaux.

  2. Dans le menu Fichier, cliquez sur Edition.

    L'Assistant Propriétés du canal s'ouvre.

  3. Sur la page Informations générales, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés générales des informations de canal.

    Lorsque vous avez modifié les propriétés sur cette page, cliquez sur Terminer pour fermer l'Assistant Propriétés du canal ou sur Suivant pour modifier d'autres propriétés du canal.

  4. Exécutez une des étapes suivantes :
    • Si vous modifiez un canal à partir d'une organisation, modifiez les propriétés appropriées sur la page Organisation source. Pour plus d'informations, voir Définition des propriétés d'une organisation source.

    • Si vous modifiez un canal à partir d'une application, modifiez les propriétés appropriées sur la page Application source. Pour plus d'informations, voir Définition des propriétés d'une application source.
  5. Sur la page Document entrant, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés d'un document entrant.

  6. Sur la page Document sortant, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés d'un document sortant.

  7. Sur la page Journalisation du document, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés de journalisation de document.

  8. Sur la page Configuration avancée, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés de configuration avancées.

Remarques

  • Vous ne pouvez pas nommer un canal à l'aide du nom système réservé, Canal des accusés de réception d'échanges au format Reliable.

  • Lorsque vous enregistrez un canal qui fait référence à un mappage en dehors de votre domaine local, vous risquez d'obtenir un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (www.microsoft.com/france/msdn/telecharge/) et parcourez le chapitre XML du manuel Web Development jusqu'à la page WinHTTP Proxy Configuration Utility.

Voir aussi

Création de canaux

Suppression de canaux

Recherche de canaux

Définition des propriétés de canal

Description des canaux


Suppression de canaux

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom du canal, sélectionnez le canal que vous voulez supprimer.

    Pour plus d'informations sur la recherche de canaux, voir Recherche de canaux.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarque

  • Vous ne pouvez pas supprimer le canal d'accusés de réception tant que tous les canaux qui s'y réfèrent n'ont pas été supprimés.

Voir aussi

Création de canaux

Modification de canaux

Recherche de canaux

Définition des propriétés de canal

Description des canaux


Définition des propriétés de canal

Cette section fournit des informations spécifiques aux tâches portant sur la configuration des propriétés d'un canal. Cette section traite des procédures suivantes :

  • Définition des propriétés générales d'un canal

  • Définition des propriétés d'une organisation source

  • Définition des propriétés d'une application source

  • Définition des propriétés d'un document entrant

  • Définition des propriétés d'un document sortant

  • Définition des propriétés de journalisation de document

  • Définition des propriétés de configuration avancées

  • Sélection d'une organisation source

  • Sélection d'un canal d'accusés de réception

  • Sélection d'une définition de document entrant

  • Sélection d'un certificat pour vérifier le décryptage d'un document entrant

  • Sélection d'un certificat pour vérifier la signature d'un document entrant

  • Sélection d'une définition de document sortant

  • Sélection d'un mappage

  • Sélection d'un certificat pour la signature sortante

  • Remplacement des valeurs par défaut d'un port d'échanges

  • Remplacement des valeurs par défaut de la liste de distribution

  • Définition du suivi pour les propriétés de document entrant

  • Définition des propriétés de filtrage de canal


Définition des propriétés générales d'un canal

  1. Sur la page Informations générales de l'Assistant Canal, dans la zone Nom, tapez le nom du canal.

  2. Dans la zone Commentaires, tapez des commentaires sur le canal.

  3. Si vous voulez créer un canal d'accusés de réception, activez la case à cocher Canal d'accusés de réception.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux.

Une fois vos modifications effectuées, cliquez sur Terminer.

Remarque

  • Vous ne pouvez créer ni un canal d'accusés de réception pour un port d'échanges ouvert, ni une liste de distribution.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Description des réceptions


Définition des propriétés d'une organisation source

  1. Sur la page Organisation source de l'Assistant Canal, exécutez l'une des étapes suivantes :
    • Cliquez sur Ouvrir la source pour créer un canal ouvert, indiquant que la source est fournie par les données du document ou par les paramètres envoyés avec le document, puis cliquez sur Suivant.

      Pour plus d'informations sur l'envoi de documents, voir Submitting.

    • Cliquez sur Organisation pour désigner une organisation de partenaire commercial comme source, puis passez à l'étape 2.
  2. Dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  3. Cliquez sur une organisation, puis sur OK.

    Pour plus d'informations, voir Sélection d'une organisation source.

  4. Si vous voulez remplacer l'identificateur d'organisation par défaut de l'organisation source, sélectionnez-en un autre dans la liste Identificateur d'organisation.

  5. Si un accusé de réception à partir de la destination est nécessaire, comme spécifié dans le port d'échanges, activez la case à cocher Attendre un accusé de réception et dans la zone Intervalle des accusés de réception en minutes, tapez une valeur ou cliquez sur les flèches HAUT ou BAS pour augmenter ou diminuer la valeur.

    La valeur par défaut est 120 minutes. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

  6. Si vous voulez générer une réception à la source, cochez la case Générer un accusé de réception, cliquez sur Parcourir, puis sélectionnez un canal d'accusés de réception.

    Pour plus d'informations, voir Sélection d'un canal d'accusés de réception.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux.

Une fois vos modifications effectuées, cliquez sur Terminer.

Remarques

  • Si vous sélectionnez un identificateur d'organisation source à utiliser avec des enveloppes X12, ne sélectionnez pas l'identificateur nommé Organisation, ni tout autre identificateur dont le qualificatif comporte plus de 2 caractères, ni une valeur qui comporte plus de 15 caractères.

  • Si vous sélectionnez un identificateur d'organisation source à utiliser avec des enveloppes EDIFACT, ne sélectionnez pas l'identificateur nommé Organisation, ni tout autre identificateur dont le qualificatif comporte plus de 4 caractères, ni une valeur qui comporte plus de 35 caractères.

  • Si vous modifiez un canal à partir d'une organisation spécifique, l'option Ouvrir la source n'est pas disponible et vous ne pouvez pas modifier l'organisation source. Si vous modifiez un canal ouvert, l'option Organisation n'est pas disponible.

  • Si vous créez ou modifiez un canal d'accusés de réception, les propriétés Attendre un accusé de réception et Générer un accusé de réception ne sont pas disponibles.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Description des réceptions


Définition des propriétés d'une application source

  1. Sur la page Application source de l'Assistant Canal, exécutez l'une des étapes suivantes :
    • Cliquez sur Planification XLANG pour désigner la source correspondant à une planification XLANG, puis sur Suivant.

      Ne sélectionnez pas cette option si vous créez un canal pour un port d'échanges ouvert. Pour plus d'informations sur l'intégration des services d'échanges BizTalk aux services d'orchestration BizTalk, voir Intégration des services BizTalk.

    • Cliquez sur Application pour désigner une application de l'organisation d'origine comme source, puis passez à l'étape 2.
  2. Dans la liste Nom, sélectionnez une application.

  3. Si vous voulez remplacer l'identificateur d'organisation par défaut pour l'organisation d'origine, sélectionnez un autre identificateur dans la liste Identificateur d'organisation.

  4. Si vous souhaitez recevoir un accusé de réception de la destination, activez la case à cocher Attendre un accusé de réception et dans la zone Intervalle des accusés de réception en minutes, tapez une valeur ou cliquez sur les flèches HAUT ou BAS pour augmenter ou diminuer la valeur.

    La valeur par défaut est 120 minutes. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

  5. Si vous voulez générer une réception à la source, cochez la case Générer un accusé de réception, cliquez sur Parcourir, puis sélectionnez un canal d'accusés de réception.

    Pour plus d'informations, voir Sélection d'un canal d'accusés de réception.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux.

Une fois vos modifications effectuées, cliquez sur Terminer.

Remarques

  • Vous pouvez créer une planification XLANG à l'aide du Concepteur d'Orchestration BizTalk.

  • Si vous créez ou modifiez un canal d'accusés de réception ou un canal pour lequel une planification XLANG est spécifiée comme source, les propriétés Attendre un accusé de réception et Générer un accusé de réception ne sont pas disponibles.

Voir aussi

Création de canaux

Modification de canaux

Intégration des services BizTalk

Définition des propriétés de canal

Description des réceptions


Définition des propriétés d'un document entrant

  1. Sur la page Document entrant de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom de la définition du document entrant.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  2. Cliquez sur une définition de document puis sur OK.

    Pour plus d'informations, voir Sélection d'une définition de document entrant.

  3. Si vous voulez vérifier le décryptage d'un document entrant, activez la case à cocher Vérifier le certificat de décryptage du document entrant, située à droite de la zone Sélectionner un certificat pour vérifier le cryptage, puis cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un certificat pour vérifier le cryptage apparaît.

  4. Sélectionnez un certificat

    Pour plus d'informations, voir Sélection d'un certificat pour vérifier le décryptage du document entrant.

  5. Si vous voulez vérifier le décryptage d'une signature numérique pour un document entrant, activez la case à cocher Vérifier le certificat de signature du document entrant et, à droite de la zone Sélectionner un certificat pour vérifier la signature, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un certificat de signature apparaît.

  6. Sélectionnez un certificat de signature.

    Pour plus d'informations, voir Sélection d'un certificat pour vérifier la signature du document entrant.

  7. Si vous voulez suivre les champs du document entrant, activez la case à cocher Suivre le document entrant, puis cliquez sur Suivi.

    La boîte de dialogue Suivi du document entrant s'affiche.

  8. Définissez les propriétés de suivi.

    Pour plus d'informations, voir Définition des propriétés de suivi d'un document entrant.

  9. Si vous voulez créer une expression de filtrage de canaux pour le document entrant, activez la case à cocher Filtrer le document entrant, puis cliquez sur Filtrage.

    La boîte de dialogue Expressions de filtrage de canaux apparaît.

  10. Définissez les propriétés de filtrage.

    Pour plus d'informations, voir Définition des propriétés de filtrage de canaux.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux.

Une fois vos modifications effectuées, cliquez sur Terminer.

Notes

  • Si vous créez un canal d'accusés de réception qui utilise l'accusé de réception standard BizTalk par défaut pour la définition du document entrant, les propriétés Suivi et Filtrage ne sont pas disponibles.

  • Si vous créez un canal pour un port d'échanges ouvert, et si les informations sur la destination sont fournies dans le document, la définition du document entrant pour ce canal doit faire référence à une spécification dont la configuration est correcte. Pour plus d'informations sur la configuration d'une spécification de document permettant de traiter les documents pour un port d'échanges ouvert, voir Définition des propriétés du dictionnaire.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés du dictionnaire

Description des réceptions


Définition des propriétés d'un document sortant

  1. Sur la page Document sortant de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom de la définition du document sortant.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  2. Cliquez sur une définition de document puis sur OK.

    Pour plus d'informations, voir Sélection d'une définition de document sortant.

  3. Si vous souhaitez spécifier un mappage, activez la case à cocher Mapper le document entrant sur le document sortant, située à droite de la zone Référence de mappage, puis cliquez sur Parcourir .

    La boîte de dialogue Sélection d'un mappage dans le référentiel WebDAV s'affiche.

  4. Sélectionnez une spécification de mappage.

    Pour plus d'informations, voir Sélection d'un mappage.

  5. Pour signer un document sortant, activez la case à cocher Signer le document sortant, située à droite de la zone Certificat de signature, puis cliquez sur Parcourir.

    Si vous créez un canal pour un port d'échanges pour lequel la propriété Signature sur la page Informations de sécurité est définie sur S/MIME, la case à cocher Signer le document sortant est automatiquement activée.

    La boîte de dialogue Sélectionner un certificat de signature s'affiche.

  6. Sélectionnez un certificat de signature.

    Pour plus d'informations, voir Sélection d'un certificat pour une signature sortante.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux.

Une fois vos modifications effectuées, cliquez sur Terminer.

Important

  • Le format d'enveloppe que vous spécifiez dans un port d'échanges doit correspondre au format du ou des documents qu'il contient. Le format du document est déterminé par la spécification à laquelle il est fait référence dans la définition du document sortant d'un canal associé. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, vous devez sélectionner une définition de document sortant pour le canal pointant vers une spécification X12.

  • Lorsque vous déclarez un port d'échanges comme étant un port d'échanges ouvert, ne créez pas pour le port d'échanges des canaux dont la définition du document sortant comporte une spécification X12 ou EDIFACT. Pour générer une enveloppe X12 ou EDIFACT, le serveur nécessite un identificateur d'organisation pour la source et la destination. Un port d'échanges ouvert ne spécifie pas l'identificateur de l'organisation de destination. De plus, les documents d'un port d'échanges ouvert doivent contenir l'adresse de destination, mais les documents X12 et EDIFACT n'incluent pas cette information.

  • Lorsque vous ouvrez une boîte de dialogue du référentiel WebDAV pour la première fois, le programme sélectionne ce dernier sur le serveur local, même si le Gestionnaire d'échanges BizTalk est connecté à une base de données située sur un serveur distant. Si vous accédez à un référentiel WebDAV d'un serveur distant, celui-ci devient le serveur par défaut jusqu'à ce que vous sélectionniez un nouveau référentiel WebDAV. Le serveur par défaut de toutes les boîtes de dialogue Référentiel WebDAV est le dernier serveur avec lequel une connexion a été établie.

Remarque

  • Un mappage permet de transformer le format de document entrant en format de document sortant. Si la spécification du document entrant correspond à celle du document sortant, le mappage n'est pas nécessaire. Par défaut, la case à cocher Mapper le document entrant sur le document sortant est désactivée. Les mappages peuvent être créés à l'aide du Mappeur BizTalk. Pour plus d'informations sur les mappages, voir Utilisation du Mappeur BizTalk.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Description des réceptions


Définition des propriétés de journalisation d'un document

BizTalk Server 2002 ~ Configuration des services d'échanges BizTalk

Définition des propriétés de journalisation de document

  1. Dans l'Assistant Canal, sur la page Journalisation de document, dans la zone Consigner le document entrant, activez la case à cocher appropriée :
    • Au format natif. Stocke les documents entrants pour le canal sous le format d'origine. Il s'agit de la configuration par défaut.

    • Au format XML. Stocke les documents entrants pour le canal sous le format XML.
  2. Dans la zone Consigner le document sortant, activez la case à cocher appropriée :
    • Au format natif. Stocke les documents sortants pour le canal sous le format d'origine.

    • Au format XML. Stocke les documents sortants pour le canal sous le format XML.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux.

Une fois vos modifications effectuées, cliquez sur Terminer.

Remarques

  • Les documents qui utilisent la journalisation sont limités en taille ; si celle-ci est dépassée, les performances de BizTalk Server en seront affectées. Pour plus d'informations sur les limites de taille, voir Limite de la taille des documents et des échanges.

  • BizTalk Server convertit les documents non-XML entrants, du format natif d'origine au format XML pour le traitement, et les documents sortants, du format XML au format natif de destination requis.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal


Définition des propriétés de configuration avancées

  1. Sur la page Configuration avancée de l'Assistant Canal, si vous créez un canal pour un port d'échanges qui indique un format d'enveloppe X12 ou EDIFACT, tapez une valeur non nulle dans la zone Numéro de contrôle de groupe.

  2. Dans la zone Options de nouvel essai, entrez le nombre de fois où vous voulez que le serveur renvoie le document si un accusé de réception n'est pas reçu, et dans la zone Intervalle, entrez le nombre de minutes entre les essais.

    Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

  3. Si vous voulez remplacer les paramètres de transport ou de composant d'enveloppe pour un port d'échanges ou une liste de distribution, cliquez sur Avancé.
    • Si vous créez ou modifiez un canal pour un port d'échanges, la boîte de dialogue Ignorer les valeurs par défaut du port d'échanges apparaît. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

    • Si vous créez ou modifiez un canal pour une liste de distribution, la boîte de dialogue Remplacer les valeurs par défaut de la liste de distribution apparaît. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

Si vous créez un canal, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Création de canaux.

Si vous modifiez un canal existant, cliquez sur Suivant. Pour plus d'informations sur l'exécution de l'étape suivante, voir Modification de canaux.

  • Une fois vos modifications effectuées, cliquez sur Terminer.

Voir aussi

Création de canaux

Modification de canaux

File d'attente de nouvel essai

Définition des propriétés de canal

Description des réceptions


Sélection d'une organisation source

  1. Sur la page Organisation source de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom.

    La boîte de dialogue Sélectionner une organisation apparaît.

  2. Dans la liste Organisations disponibles, sélectionnez une organisation, puis cliquez sur Terminer.

Pour poursuivre la définition des propriétés de l'organisation source, allez dans Définition des propriétés d'une organisation source.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'une organisation source


Sélection d'un canal d'accusés de réception

  1. Sur la page Application source ou Organisation source de l'Assistant Canal, activez la case à cocher Générer un accusé de réception, puis cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un canal d'accusés de réception apparaît.

  2. Dans la liste Canaux d'accusés de réception disponibles, choisissez un canal d'accusés de réception, puis cliquez sur OK.

Pour poursuivre la définition des propriétés de l'organisation source, allez dans Définition des propriétés d'une organisation source.

Pour poursuivre la définition des propriétés de l'application source, voir Définition des propriétés d'une application source.

Remarque

  • La liste Canaux d'accusés de réception disponibles affiche uniquement les canaux d'accusés de réception associés aux ports d'échanges pour lesquels la destination est identique à la source pour le canal créé. Lorsque BizTalk Server invoque un canal avec un canal d'accusés de réception spécifié, le serveur renvoie un accusé de réception à la source initiale de ce document via le canal d'accusés de réception spécifié. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'une application source

Définition des propriétés d'une organisation source

Description des réceptions


Sélection d'une définition de document entrant

  1. Sur la page Document entrant de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom de la définition du document entrant.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  2. Dans la liste Définitions de documents disponibles, cliquez sur une définition de document, puis sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, voir Définition des propriétés d'un document entrant.

Remarque

  • Lorsque vous créez un canal d'accusés de réception, la définition du document entrant et celle du document sortant adoptent par défaut la valeur Accusé de réception standard BizTalk, et elles ne peuvent pas être transformées à l'aide d'un mappage. Pour utiliser un format différent pour un accusé de réception sortant, vous devez créer et sélectionner une définition de document entrant qui fait référence à la spécification standard pour les accusés de réception dans le référentiel WebDAV. Vous devez également créer une définition de document sortant qui se réfère à une spécification ayant le format que vous voulez attribuer à l'accusé de réception sortant et à un mappage qui transforme le format de l'accusé de réception. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

Voir aussi

Création de canaux

Création de définitions de document

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document entrant

Description des réceptions


Sélection d'un certificat pour vérifier le décryptage d'un document entrant

  1. Sur la page Document Entrant de l'Assistant Canal, activez la case à cocher Vérifier le certificat de décryptage du document entrant, située à droite de la zone Certificat de vérification du décryptage, puis cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un certificat pour vérifier le cryptage apparaît.

  2. Dans la liste Nom de certificat, choisissez un nom de certificat et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, voir Définition des propriétés d'un document entrant.

Remarques

  • Tous les certificats sont stockés dans la zone de stockage de l'ordinateur local. Pour configurer les certificats pour les composants S/MIME en utilisant le Gestionnaire d'échanges BizTalk, vous devez appartenir à un compte d'utilisateur dans le groupe Administrateurs de Windows 2000 et les services d'échanges BizTalk doivent fonctionner en tant que compte système local ou en tant que compte d'utilisateur dans le groupe Administrateurs de Windows 2000.

  • Les documents sont décryptés lorsque BizTalk Server les reçoit, afin que le serveur dispose des données nécessaires pour identifier le canal approprié. Le certificat spécifié dans le canal s'assure que le décryptage est effectué correctement.

  • Les certificats doivent porter un nom unique. Si plusieurs certificats ont le même nom, il n'est possible d'en sélectionner qu'un seul. Une fois le certificat sélectionné, les autres certificats portant le même nom disparaissent de la liste.

    Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document entrant


Sélection d'un certificat pour vérifier la signature d'un document entrant

  1. Sur la page Document entant de l'Assistant Canal, activez la case à cocher Vérifier le certificat de signature du document entant située à droite de la zone Certificat de vérification de la signature, puis cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un certificat pour vérifier la signature s'affiche.

  2. Dans la liste Nom de certificat, choisissez un nom de certificat et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, voir Définition des propriétés d'un document entrant.

Remarques

  • Tous les certificats sont stockés dans la zone de stockage de l'ordinateur local. Pour configurer les certificats pour les composants S/MIME en utilisant le Gestionnaire d'échanges BizTalk, vous devez appartenir à un compte d'utilisateur dans le groupe Administrateurs de Windows 2000 et les services d'échanges BizTalk doivent fonctionner en tant que compte système local ou en tant que compte d'utilisateur dans le groupe Administrateurs de Windows 2000.

  • Les certificats doivent porter un nom unique. Si plusieurs certificats ont le même nom, il n'est possible d'en sélectionner qu'un seul. Une fois le certificat sélectionné, les autres certificats portant le même nom disparaissent de la liste.

    Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document entrant


Sélection d'une définition de document sortant

  1. Sur la page Document sortant de l'Assistant Canal, cliquez sur le bouton Parcourir situé à droite de la zone Nom de la définition du document sortant.

    La boîte de dialogue Sélection d'une définition de document s'affiche.

  2. Dans la liste Définitions de documents disponibles, choisissez une définition de document, puis cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document sortant, voir Définition des propriétés d'un document sortant.

Remarque

  • Lorsque vous créez un canal d'accusés de réception, la définition du document entrant et celle du document sortant adoptent par défaut la valeur Accusé de réception standard BizTalk, et elles ne peuvent pas être transformées à l'aide d'un mappage. Pour utiliser un format différent pour un accusé de réception sortant, vous devez créer et sélectionner une définition de document entrant qui fait référence à la spécification standard pour les accusés de réception dans le référentiel WebDAV. Vous devez également créer une définition de document sortant qui se réfère à une spécification ayant le format que vous voulez attribuer à l'accusé de réception sortant et à un mappage qui transforme le format de l'accusé de réception. Pour plus d'informations sur les accusés de réception, voir Description des accusés de réception.

Voir aussi

Création de canaux

Création de définitions de document

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document sortant

Description des réceptions


Sélection d'un mappage

  1. Sur la page Document sortant de l'Assistant Canal, activez la case à cocher Mapper le document entrant sur le document sortant, puis cliquez sur le bouton Parcourir situé à droite de la zone Référence de mappage.

    La boîte de dialogue Sélection d'un mappage dans le référentiel WebDAV s'affiche.

  2. Dans la zone Serveur, procédez de l'une des façons suivantes pour changer de serveur.
    • Sélectionnez un serveur dans la liste.

    • Tapez le nom d'un serveur et appuyez sur ENTRÉE.
  3. Double-cliquez sur le dossier qui contient le mappage que vous voulez utiliser, sélectionnez le mappage, puis cliquez sur Ouvrir.

Pour poursuivre la définition des propriétés d'un document sortant, voir Définition des propriétés d'un document sortant.

Important

  • Lorsque vous ouvrez une boîte de dialogue du référentiel WebDAV pour la première fois, le programme sélectionne ce dernier sur le serveur local, même si le Gestionnaire d'échanges BizTalk est connecté à une base de données située sur un serveur distant. Si vous accédez à un référentiel WebDAV d'un serveur distant, celui-ci devient le serveur par défaut jusqu'à ce que vous sélectionniez un nouveau référentiel WebDAV. Le serveur par défaut de toutes les boîtes de dialogue Référentiel WebDAV est le dernier serveur avec lequel une connexion a été établie.

Remarques

  • Si vous sélectionnez l'adresse http://localhost pour le serveur, le Gestionnaire d'échanges BizTalk la transforme automatiquement en nom d'ordinateur local.

  • Lorsque vous enregistrez un canal qui fait référence à un mappage externe à votre domaine local, une erreur risque de se produire. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (www.microsoft.com/france/msdn/telecharge/) et parcourez le chapitre XML du manuel Web Development jusqu'à la page WinHTTP Proxy Configuration Utility.

Voir aussi

Création de canaux

Modification de canaux

Utilisation de Mappeur BizTalk

Définition des propriétés de canal

Définition des propriétés d'un document sortant


Sélection d'un certificat pour la signature sortante

  1. Sur la page Document sortant de l'Assistant Canal, activez la case à cocher Signer le document sortant, puis cliquez sur le bouton Parcourir situé à droite de la zone Certificat de signature.

    La boîte de dialogue Sélectionner un certificat de signature s'affiche.

  2. Dans la liste Nom de certificat, choisissez un nom de certificat et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document sortant, voir Définition des propriétés d'un document sortant.

Remarques

  • Tous les certificats sont stockés dans la zone de stockage de l'ordinateur local. Pour configurer les certificats pour les composants S/MIME en utilisant le Gestionnaire d'échanges BizTalk, vous devez appartenir à un compte d'utilisateur dans le groupe Administrateurs de Windows 2000 et les services d'échanges BizTalk doivent fonctionner en tant que compte système local ou en tant que compte d'utilisateur dans le groupe Administrateurs de Windows 2000.

  • Les certificats doivent porter un nom unique. Si plusieurs certificats ont le même nom, il n'est possible d'en sélectionner qu'un seul. Une fois le certificat sélectionné, les autres certificats portant le même nom disparaissent de la liste.

    Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés d'un document sortant


Remplacement des valeurs par défaut d'un port d'échanges

  1. Sur la page Configuration avancée de l'Assistant Canal, cliquez sur Avancé.

    Si vous créez ou modifiez un canal pour un port d'échanges, la boîte de dialogue Ignorer les valeurs par défaut du port d'échanges apparaît.

  2. Sous l'onglet Transport principal, cliquez sur Propriétés.

    La boîte de dialogue Propriétés des composants de BizTalk s'affiche.

  3. Modifiez les propriétés de composant de transport que vous voulez remplacer et cliquez sur OK.

  4. Si le port d'échanges comporte une enveloppe et si vous voulez modifier sa configuration, cliquez sur l'onglet Enveloppe, puis sur Propriétés.

    La boîte de dialogue Propriétés des composants de BizTalk s'affiche.

  5. Modifiez les propriétés de composant de l'enveloppe que vous voulez remplacer et cliquez sur OK.

Pour poursuivre la définition des propriétés avancées, allez dans Définition des propriétés de configuration avancées.

Important

  • La fonction de remplacement des propriétés de transport et d'enveloppe d'un port d'échanges est une fonction avancée. Si vous ne comprenez pas les propriétés de composant de transport ou d'enveloppe dans les boîtes de dialogue, ne les modifiez pas.

  • Si vous spécifiez une enveloppe avec un format personnalisé dans le port d'échanges, vous devez configurer le composant du sérialiseur à l'aide des propriétés de configuration avancées.

Remarques

  • Si vous remplacez les propriétés de port d'échanges dans un canal, ces modifications s'appliquent uniquement à ce canal.

  • L'adresse de transport définie dans un port d'échanges ne peut pas être remplacée.

  • La configuration par défaut pour le composant de transport HTTP doit utiliser le serveur proxy HTTP. Cette configuration est celle qui convient pour le transport des données vers des sites Web situés à l'extérieur du pare-feu de votre entreprise. Pour transporter des données vers des sites Web situés à l'intérieur du pare-feu de votre entreprise (c'est-à-dire sur votre intranet), utilisez cette procédure pour remplacer la configuration par défaut.

  • Pour le composant de transport HTTPS, utilisez uniquement les certificats spécifiés pour l'authentification du client. Les certificats spécifiés pour tous les rôles n'apparaissent pas dans la liste.

  • La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez un type de transport de fichier configuré par défaut dans un port d'échanges, si vous utilisez un anti-virus sur le serveur sur lequel est installé BizTalk Server et si vous envoyez simultanément plusieurs fichiers portant le même nom vers le même emplacement, BizTalk Server cessera de répondre et devra être redémarré. Pour éliminer ce problème, vous pouvez modifier la valeur par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Vous pouvez également éliminer ce problème en créant un fichier unique pour chaque instance de document traitée à l'aide du format de chemin d'accès suivant dans le port d'échanges : fichier://C:\dir\fichier%id_suivi%.xml. Pour plus d'informations, voir Spécification d'une adresse de transport.

  • La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez un type de transport de fichier configuré par défaut, un format d'enveloppe Reliable dans un port d'échanges, puis envoyez simultanément plusieurs fichiers vers le même emplacement, vous obtiendrez des résultats d'analyse inattendus. Vous pouvez éliminer ce problème en modifiant la configuration par défaut du composant de transport de fichiers en remplaçant l'option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile.

  • Si l'enveloppe spécifiée dans le port d'échanges a un format personnalisé et si vous avez créé et enregistré un composant de sérialiseur personnalisé, vous pouvez configurer les propriétés du composant de sérialiseur personnalisé à l'aide de cette procédure.

  • L'identificateur de syntaxe par défaut pour une enveloppe EDIFACT est UNOA (Uppercase Latin alphabet). Si une syntaxe différente est nécessaire pour vos données, sélectionnez un identificateur de syntaxe différent en utilisant cette procédure.

  • Si vous utilisez des indicateurs de libération EDIFACT, vos données ne doivent pas contenir de caractères faisant fonction d'indicateur de libération. Si vous procédez ainsi, les données risquent de dépasser les limites définies pour la taille physique des caractères autorisée pour les champs.

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de configuration avancées

Définition des propriétés de canal


Remplacement des valeurs par défaut de la liste de distribution

  1. Sur la page Configuration avancée de l'Assistant Canal, cliquez sur Avancé.

    Si vous créez ou modifiez un canal pour une liste de distribution, la boîte de dialogue Remplacer les valeurs par défaut de la liste de distribution apparaît.

  2. Dans la liste Sélectionnez un port d'échanges, sélectionnez un port d'échanges que vous voulez remplacer et cliquez sur Remplacer.

    La boîte de dialogue Ignorer les valeurs par défaut du port d'échanges apparaît.

  3. Remplacez les propriétés du composant de transport et d'enveloppe pour le port d'échanges sélectionné.

    Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

  4. Après avoir modifié les ports d'échanges, cliquez sur Fermer.

Pour poursuivre la définition des propriétés avancées, allez dans Définition des propriétés de configuration avancées.

Voir aussi

Création de canaux

Modification de canaux

Remplacement des valeurs par défaut d'un port d'échanges

Définition des propriétés de configuration avancées

Définition des propriétés de canal


Définition du suivi pour les propriétés de document entrant

La boîte de dialogue Suivi du document entrant fournit la liste des champs de spécification disponibles pour le document entrant, ainsi que des champs de suivi global sélectionnés dans la définition de document.

Si vous sélectionnez des champs de spécification dans cette boîte de dialogue, ils remplaceront les champs de suivi global uniquement pour ce canal. Pour chaque instance de document traitée, les champs sélectionnés dans le canal sont consignés dans la base de données de suivi, plutôt que dans les champs de suivi global.

Cette section décrit comment sélectionner ou supprimer des champs de spécification de document entrant dans un canal.

Cette section traite des procédures suivantes :

  • Sélection des champs de spécification dans un canal

  • Suppression de champs de spécification dans un canal

Voir aussi

Création de canaux

Modification de canaux

Définition des propriétés de canal

Définition des propriétés de suivi global

Définition des propriétés d'un document entrant


Sélection des champs de spécification dans un canal

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Suivre le document entrant et cliquez sur Suivi.

    La boîte de dialogue Suivi du document entrant s'affiche.

  2. Dans l'arborescence Champs de spécification, double-cliquez sur un enregistrement pour développer la vue.

  3. Sélectionnez un champ de spécification à ajouter dans la liste Champs à suivre et exécutez l'une des procédures suivantes :
    Ajout du champ en tant que | Suivez cette procédure
    Entier | Cliquez sur Entier. Vous pouvez ajouter deux champs pour les entiers.
    Réel | Cliquez sur Réel. Vous pouvez ajouter deux champs pour les nombres réels.
    Date | Cliquez sur Date. Vous pouvez ajouter deux champs pour les dates.
    Texte | Cliquez sur Texte. Vous pouvez ajouter deux champs pour le texte.
    Personnalisé | Cliquez sur Personnalisé. Vous pouvez ajouter un nombre de champs illimité pour le type Personnalisé. Les champs sont stockés sous forme de chaînes XML concaténées, avec des balises pour chaque champ.

Pour poursuivre la définition des propriétés d'un document entrant, voir Définition des propriétés d'un document entrant.

Important

  • Si vous sélectionnez des champs de spécification dans cette boîte de dialogue, ils remplaceront les champs de suivi global uniquement pour ce canal. Pour chaque instance de document traitée, les champs sélectionnés dans le canal sont consignés dans la base de données de suivi, plutôt que dans les champs de suivi global.

Remarques

  • Pour pouvoir sélectionner un champ de spécification pour le suivi de données de type entier, nombre réel ou date, ce type de données doit être attribué au champ dans la spécification. Pour plus d'informations sur l'affectation d'un type de données à un champ de spécification, voir Définition des propriétés de déclaration.

  • Les champs de spécification auxquels aucun type de données n'a été attribué dans la spécification peuvent uniquement faire l'objet d'un suivi sur les données de type texte ou personnalisé.

  • Si un type de données caractère a été attribué au champ de spécification dont vous voulez effectuer le suivi, celui-ci peut faire l'objet d'un suivi uniquement sur les données de type personnalisé.

  • Vous pouvez uniquement sélectionner deux champs de spécification pour un type de données spécifique. Un nombre illimité de champs peut être sélectionné comme type de données personnalisé.

Voir aussi

Création de canaux

Modification de canaux

Suppression de champs de spécification dans un canal

Définition des propriétés de canal

Définition des propriétés de suivi global

Définition du suivi pour les propriétés de document entrant

Suivi des champs de données d'un document


Suppression de champs de spécification dans un canal

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Suivre le document entrant et cliquez sur Suivi.

    La boîte de dialogue Suivi du document entrant s'affiche.

  2. Dans la liste Champs à suivre, sélectionnez les champs de spécification à supprimer et cliquez sur Supprimer.

Pour poursuivre la définition des propriétés d'un document entrant, voir Définition des propriétés d'un document entrant.

Remarque

  • Lorsque vous supprimez un champ de la liste des champs à suivre, celui-ci est uniquement supprimé du canal ; il n'est pas supprimé de la spécification.

Voir aussi

Création de canaux

Modification de canaux

Sélection des champs de spécification dans un canal

Définition des propriétés de canal

Définition des propriétés de suivi global

Définition du suivi pour les propriétés de document entrant

Suivi des champs de données d'un document


Définition des propriétés de filtrage de canal

Une expression de filtrage de canal est une expression XPath qui peut être utilisée pour déterminer si un canal est invoqué en fonction de la valeur du ou des champs spécifiés dans le document. Lorsque BizTalk Server traite un document, la valeur du ou des champs spécifiés dans chaque document est évaluée par rapport à l'expression de filtrage du canal. Si l'expression est vraie, le canal est appelé. Si l'expression est fausse, le canal n'est pas appelé.

Cette section traite des procédures suivantes :

  • Ajout d'une expression de filtrage à un canal

  • Modification d'une expression de filtrage d'un canal

  • Suppression d'une expression de filtrage d'un canal

Voir aussi

Définition des propriétés d'un document entrant


Ajout d'une expression de filtrage à un canal

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Filtrer le document entrant et cliquez sur Filtrage.

    La boîte de dialogue Expressions de filtrage de canaux apparaît.

  2. Dans l'arborescence Sélectionnez un champ, double-cliquez sur un nœud pour développer l'affichage.

  3. Cliquez sur un champ de spécification que vous voulez utiliser pour créer une expression de filtrage et cliquez sur Ajouter.

    La boîte de dialogue Propriétés d'expression s'affiche.

  4. Dans la liste Opérateur, sélectionnez un opérateur.
    Opérateur Symbole
    Égal à (valeur par défaut) =
    Différent de !=
    Inférieur à <
    Inférieur ou égal à <=
    Supérieur à >
    Supérieur ou égal à >=

  5. Dans la zone Valeur, tapez une valeur pour l'expression et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, voir Définition des propriétés d'un document entrant.

Important

  • Les expressions de filtrage de canal doivent correspondre à des expressions XPath valides. Le bouton Ajouter permet de créer une clause contenant un champ de spécification et de l'insérer dans une expression ; cependant, il ne génère pas la syntaxe correcte nécessaire pour une expression XPath valide. Pour plus d'informations sur les expressions XPath, voir Channel Filtering ; vous pouvez aussi accéder au site Web MSDN Online Library (msdn.microsoft.com/library/) et rechercher le mot-clé « XPath ».

Remarques

  • Vous pouvez entrer une expression directement dans la liste Expressions.

  • Pour sélectionner un champ de spécification pour une expression de filtrage de canal, un type de données doit être affecté au champ dans la spécification. Pour plus d'informations sur l'attribution d'un type de données à un champ de spécification, voir Définition des propriétés de déclaration.

  • Si le type de données Booléen est affecté au champ de spécification que vous utilisez pour créer une expression, vous ne pouvez pas utiliser la chaîne "vrai" ou "faux" dans la valeur de l'expression. Cette valeur doit être remplacée par une valeur numérique, "-1" pour vrai et "0" pour faux.

  • Si le type de données date est affecté au champ de spécification utilisé pour créer une expression, tapez la valeur au format suivant, tirets inclus : AAAA-MM-JJ.

  • Si vous voulez utiliser un filtre pour un type de date et/ou d'heure (dateTime, dateTime.tz, time, time.tz), vous devez le saisir manuellement dans l'expression XPath. Par exemple, self::node()[@ATTDATETIME = "2000-03-15T10:10:10"] où ATTDATETIME est le type de format de date/heure.

Voir aussi

Création de canaux

Modification d'une expression de filtrage d'un canal

Modification de canaux

Suppression d'une expression de filtrage d'un canal

Définition des propriétés de filtrage de canal

Définition des propriétés de canal


Modification d'une expression de filtrage d'un canal

  1. Sur la page Document entrant de l'Assistant Canal, activez la case à cocher Filtrer le document entrant et cliquez sur Filtrage.

    La boîte de dialogue Expressions de filtrage de canaux s'affiche.

  2. Dans la liste Expressions, modifiez l'expression et cliquez sur OK.

Pour poursuivre la définition des propriétés d'un document entrant, voir Définition des propriétés d'un document entrant.

Important

  • Les expressions de filtrage de canal doivent correspondre à des expressions XPath valides. Pour plus d'informations sur les expressions XPath, voir Channel Filtering ; vous pouvez aussi accéder au site Web MSDN Online Library (msdn.microsoft.com/library/) et rechercher le mot-clé « XPath ».

Voir aussi

Ajout d'une expression de filtrage à un canal

Suppression d'une expression de filtrage d'un canal

Définition des propriétés de filtrage de canal


Suppression d'une expression de filtrage d'un canal

  • Sur la page Document entrant de l'Assistant Canal, désactivez la case à cocher Filtrer le document entrant.

Pour poursuivre la définition des propriétés d'un document entrant, voir Définition des propriétés d'un document entrant.

Voir aussi

Ajout d'une expression de filtrage à un canal

Création de canaux

Modification d'une expression de filtrage d'un canal

Modification de canaux

Définition des propriétés de filtrage de canal

Définition des propriétés de canal


Création et gestion des ports d'échanges

Cette section fournit des informations spécifiques aux tâches quant à la création et à la gestion des ports d'échanges. Nous vous recommandons vivement de revoir la rubrique Description des ports d’échanges pour comprendre pleinement le concept des ports d'échanges.

Cette section traite des procédures suivantes :

  • Création de ports d'échanges

  • Recherche de ports d'échanges

  • Modification de ports d'échanges

  • Suppression de ports d'échanges

  • Définition des propriétés d'un port d'échanges


Création de ports d'échanges

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Dans le menu Fichier, pointez sur Nouveau, sur Port d'échanges, puis exécutez l'une des étapes suivantes :
    • Pour créer un port d'échanges vers l'organisation d'un partenaire commercial, cliquez sur Vers une organisation.

    • Pour créer un port d'échanges vers une application interne, cliquez sur Vers une application.

    L'Assistant Propriétés du nouveau port d'échanges s'ouvre.

  3. Sur la page Informations générales, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d'informations, voir Définition des propriétés des informations générales d'un port d'échanges.

  4. Exécutez une des étapes suivantes :
    • Si vous créez un port d'échanges vers une organisation spécifique, définissez les propriétés sur la page Organisation de destination, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés de l'organisation de destination.

    • Si vous créez un port d'échanges ouvert, cliquez sur Destination ouverte, puis sur Suivant.

      Pour un port d'échanges ouvert, les informations relatives au transport et à la destination doivent être fournies soit dans le document, soit dans un paramètre envoyé avec le document. Pour plus d'informations, voir Submitting.

    • Si vous créez un port d'échanges vers une application, définissez les propriétés sur la page Application de destination, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés de l'application de destination.
  5. Sur la page Informations d'enveloppe, définissez les propriétés, puis cliquez sur Suivant.

    Pour plus d’informations, voir Définition des propriétés des informations d'enveloppes.

  6. Sur la page Informations de sécurité, définissez les propriétés.

    Pour plus d'informations, voir Définition des propriétés des informations de sécurité.

  7. Si vous ne souhaitez pas passer directement à l'Assistant Canal pour créer un canal, désactivez la case à cocher Créer un canal pour ce port d'échanges ; dans le cas contraire, cliquez sur l'un des types de canal suivants dans la liste Type de canal :
    • À partir d'une organisation

    • À partir d'une application
  8. Après avoir défini toutes les propriétés du port d'échanges, sur la page Informations de sécurité, cliquez sur Terminer pour fermer l'Assistant Propriétés du nouveau port d'échanges.

Important

  • Lorsque vous déclarez un port d'échanges comme étant un port d'échanges ouvert, ne créez pas pour le port d'échanges des canaux dont la définition du document sortant comporte une spécification X12 ou EDIFACT. Pour générer une enveloppe X12 ou EDIFACT, le serveur nécessite un identificateur d'organisation pour la source et la destination. Un port d'échanges ouvert ne spécifie pas l'identificateur de l'organisation de destination. De plus, les documents d'un port d'échanges ouvert doivent contenir l'adresse de destination, mais les documents X12 et EDIFACT n'incluent pas cette information.

Remarques

  • Vous ne pouvez pas attribuer à un port d'échanges le nom système réservé, à savoir Port des accusés de réception d'échanges au format Reliable.

  • Si vous créez un port d'échanges et un canal en vue d'une soumission directe de données, vous pouvez uniquement utiliser, pour le canal, la fenêtre de service ainsi que les fonctionnalités de compteur et d'intervalle pour les nouveaux essais. En ce qui concerne le port d'échanges associé, seules les fonctionnalités de transport sont disponibles. Vous ne pouvez utiliser ni la vérification de décodage ou de décryptage, ni le filtrage, ni le suivi de documents, ni les fonctions de mappage du canal.

Voir aussi

Création et gestion de canaux

Suppression de ports d'échanges

Modification de ports d'échanges

Recherche de ports d'échanges

Définition des propriétés d'un port d'échanges

Description des ports d’échanges


Recherche de ports d'échanges

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Dans la zone Rechercher d'autres éléments, cliquez sur Ports d'échanges.

  3. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher tous les ports d'échanges, effacez tous les critères de recherche, puis cliquez sur Rechercher.

    • Pour rechercher un port d'échanges portant un nom spécifique, dans la zone Nom du port d'échanges, tapez le nom du port d'échanges que vous voulez rechercher et cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher des ports d'échanges en référence à un type spécifique de destination, dans la liste Destination, cliquez sur un type de destination, puis sur Rechercher.

Remarques

  • Vous pouvez définir plusieurs critères de recherche avant de cliquer sur Rechercher.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Vous pouvez utiliser les caractères génériques suivants dans vos critères de recherche.
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus. L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère. | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]). L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié. L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression de ports d'échanges

Modification de ports d'échanges

Description des ports d’échanges


Modification de ports d'échanges

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Dans la liste Nom du port d'échanges, cliquez sur le port d'échanges que vous voulez modifier.

    Pour des informations sur la recherche de ports d'échanges, voir Recherche de ports d'échanges.

  3. Dans le menu Fichier, cliquez sur Edition.

    L'Assistant Propriétés du port d'échanges s'ouvre.

  4. Sur la page Informations générales, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés des informations générales d'un port d'échanges.

    Après avoir modifié les propriétés sur une page, vous pouvez cliquer sur Terminer pour fermer l'Assistant Propriétés du port d'échanges ou sur Suivant pour modifier d'autres propriétés du port d'échanges.

  5. Exécutez une des étapes suivantes :
    • Si vous modifiez un port d'échanges vers une organisation, modifiez les propriétés nécessaires sur la page Organisation de destination, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés de l'organisation de destination.

    • Si vous modifiez un port d'échanges vers une application, modifiez les propriétés nécessaires sur la page Application de destination, puis cliquez sur Suivant. Pour plus d'informations, voir Définition des propriétés de l'application de destination.
  6. Sur la page Informations d'enveloppe, modifiez les propriétés nécessaires, puis cliquez sur Suivant.

    Pour plus d’informations, voir Définition des propriétés des informations d'enveloppes.

  7. Dans la page Informations de sécurité, modifiez les propriétés appropriées.

    Pour plus d'informations, voir Définition des propriétés des informations de sécurité.

  8. Si vous ne souhaitez pas passer directement à l'Assistant Canal pour créer un canal, désactivez la case à cocher Créer un canal pour ce port d'échanges ; dans le cas contraire, cliquez sur un des types de canal suivants dans la liste Type de canal :
    • À partir d'une organisation

    • À partir d'une application
  9. Après avoir modifié toutes les propriétés nécessaires pour le port d'échanges, vous pouvez cliquer sur Terminer sur n'importe quelle page pour fermer l'Assistant Propriétés du port d'échanges.

Remarque

  • Vous ne pouvez pas attribuer à un port d'échanges le nom système réservé, à savoir Port des accusés de réception d'échanges au format Reliable.

Voir aussi

Création et gestion de canaux

Création de ports d'échanges

Suppression de ports d'échanges

Définition des propriétés d'un port d'échanges

Description des ports d’échanges


Suppression de ports d'échanges

  1. Dans le menu Démarrer, pointez sur Programmes et sur Microsoft BizTalk Server 2002, puis cliquez sur Gestionnaire d'échanges BizTalk.

  2. Dans la liste Nom du port d'échanges, cliquez sur le port d'échanges que vous voulez supprimer.

    Pour des informations sur la recherche de ports d'échanges, voir Recherche de ports d'échanges.

  3. Dans le menu Fichier, cliquez sur Supprimer.

Remarques

  • Si vous avez créé des canaux pour un port d'échanges, vous ne pouvez pas supprimer ce port d'échanges tant que les canaux y étant associés n'ont pas été supprimés.

  • Pour rechercher des canaux associés à un port d'échanges, cliquez avec le bouton droit sur le port d'échanges et cliquez sur Rechercher des canaux.

Voir aussi

Création et gestion de canaux

Création de ports d'échanges

Modification de ports d'échanges

Description des ports d’échanges


Définition des propriétés d'un port d'échanges

Cette section fournit des informations spécifiques aux tâches quant à la configuration des propriétés d'un port d'échanges.

Cette section traite des procédures suivantes :

  • Définition des propriétés des informations générales d'un port d'échanges

  • Définition des propriétés de l'organisation de destination

  • Définition des propriétés d'une application de destination

  • Définition des propriétés des informations d'enveloppes

  • Définition des propriétés des informations de sécurité

  • Sélection d'une organisation de destination

  • Sélection d'un certificat de cryptage

  • Définition des propriétés de transport

  • Définition des séparateurs d'enveloppes


Définition des propriétés des informations générales d'un port d'échanges

  1. Sur la page Informations générales de l'Assistant Propriétés du port d'échanges, dans la zone Nom, tapez le nom du port d'échanges.

  2. Dans la zone Commentaires, tapez les éventuels commentaires que vous voulez définir pour le port d'échanges, puis cliquez sur Suivant.

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges.

Une fois vos modifications effectuées, cliquez sur Terminer.

Voir aussi

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges


Définition des propriétés de l'organisation de destination

  1. Sur la page Organisation de destination de l'Assistant Propriétés du port d'échanges, exécutez l'une des étapes suivantes :
    • Cliquez sur Destination ouverte pour créer un port d'échanges ouvert, puis cliquez sur Suivant.

      Pour un port d'échanges ouvert, les informations relatives au transport et à la destination doivent être fournies soit dans le document, soit dans des paramètres envoyés avec le document. Pour plus d'informations, voir Submitting.

    • Cliquez sur Organisation pour désigner comme destination l'organisation d'un partenaire commercial spécifique, puis passez à l'étape 2.
  2. Dans la zone Organisation, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  3. Cliquez sur une organisation, puis sur OK.

    Pour plus d'informations, voir Sélection d'une organisation de destination.

  4. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal apparaît.

  5. Définissez les propriétés du transport principal.

    Pour plus d'informations, voir Définition des propriétés de transport.

  6. Si vous voulez limiter la période de temps durant laquelle le transport de documents peut avoir lieu, dans la zone Transport principal, activez la case à cocher Fenêtre de service.

    Ensuite, dans les zones De et À, cliquez sur l'heure et entrez une valeur, ou cliquez sur la flèche haut ou bas pour augmenter ou diminuer la valeur.

  7. Si vous voulez spécifier un transport secondaire, dans la zone Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport secondaire s'affiche.

  8. Définissez les propriétés du transport secondaire.

    Pour plus d'informations, voir Définition des propriétés de transport.

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges.

Une fois vos modifications effectuées, cliquez sur Terminer.

Important

  • Lorsque vous déclarez un port d'échanges comme étant un port d'échanges ouvert, ne créez pas pour le port d'échanges des canaux dont la définition du document sortant comporte une spécification X12 ou EDIFACT. Pour générer une enveloppe X12 ou EDIFACT, le serveur nécessite un identificateur d'organisation pour la source et la destination. Un port d'échanges ouvert ne spécifie pas l'identificateur de l'organisation de destination. De plus, les documents d'un port d'échanges ouvert doivent contenir l'adresse de destination, mais les documents X12 et EDIFACT n'incluent pas cette information.

Remarque

  • Les heures figurant dans les fenêtres de service sont affichées aux format UTC (Universal Coordinated Time – Temps universel coordonné) et correspondent à l’heure définie sur le serveur.

Voir aussi

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges


Définition des propriétés d'une application de destination

BizTalk Server 2002 ~ Configuration des services d'échanges BizTalk

Définition des propriétés d’une application de destination

  1. Sur la page Application de destination de l'Assistant Propriétés du port d'échanges, exécutez l'une des étapes suivantes :
    • Cliquez sur Nouvelle planification XLANG pour désigner comme destination un port d'une nouvelle instance d'une planification XLANG spécifiée. Dans la zone Planifier le moniker, tapez le moniker de la planification spécifiée ou cliquez sur Parcourir pour définir le chemin d’accès. Ensuite, dans la zone Nom du port, tapez le nom du port spécifique de cette planification vers lequel le document est envoyé.

      Pour les monikers de planification, la syntaxe est la suivante :

      sked://[HôteLocal][!GestionnaireGroupe][/CheminFichier][/NomPort]

      Vous pouvez uniquement activer les planifications XLANG de l'ordinateur local.

      Pour plus d'informations sur les monikers, voir Syntaxe du moniker.

    • Cliquez sur Planification XLANG en cours pour désigner comme destination une instance de planification XLANG active. Utilisez cette option uniquement pour transporter un message vers une planification XLANG active lorsqu'un partenaire commercial renvoie le message à une page ASP spécialement configurée via un transport HTTP. Pour plus d’informations, voir Intégration des services BizTalk.

    • Cliquez sur Application pour désigner comme destination une application de l'organisation d'origine, puis cliquez sur une application dans la liste Nom.
  2. Si vous avez sélectionné une application comme destination, exécutez les étapes 3 à 5. Sinon, cliquez sur Suivant.

  3. Dans la zone Transport principal, cliquez sur Parcourir.

    La boîte de dialogue Transport principal s'affiche.

  4. Définissez les propriétés du transport principal.

    Pour plus d'informations, voir Définition des propriétés de transport.

  5. Si vous voulez limiter la période de temps durant laquelle le transport de documents peut avoir lieu, dans la zone Transport principal, activez la case à cocher Fenêtre de service.

    Ensuite, dans les zones De et À, cliquez sur l'heure et entrez une valeur, ou cliquez sur la flèche haut ou bas pour augmenter ou diminuer la valeur.

  6. Si vous voulez spécifier un transport secondaire, dans la zone Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport secondaire s'affiche.

  7. Définissez les propriétés du transport secondaire.

    Pour plus d'informations, voir Définition des propriétés de transport.

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges.

Une fois vos modifications effectuées, cliquez sur Terminer.

Important

  • Si vous choisissez l'option Nouvelle planification XLANG :
    • Le port que vous déterminez doit être lié aux services d'échanges BizTalk dans la planification spécifiée, et cette liaison doit être configurée de manière à activer une nouvelle instance de planification à l'arrivée des messages.

    • Dans une planification, un seul port doit être configuré de manière à activer une nouvelle instance de planification à l'arrivée des messages, et il doit s'agir de la première action de la planification. Pour plus d'informations, voir Implémentation d’un port à l’aide d’Échanges BizTalk.

Remarques

  • Si vous définissez une planification XLANG comme destination d'un port d'échanges, les documents que vous traitez via ce port d'échanges sont limités à 2 Mo.

  • Le Concepteur d'orchestration BizTalk vous permet de créer des planifications XLANG.

  • Les heures figurant dans les fenêtres de service sont affichées aux format UTC (Universal Coordinated Time – Temps universel coordonné) et correspondent à l’heure définie sur le serveur.

Voir aussi

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges


Définition des propriétés des informations d'enveloppes

  1. Sur la page Informations d'enveloppe de l'Assistant Propriétés du port d'échanges, dans la zone Informations d'enveloppe, sélectionnez une enveloppe dans la liste.

    Si vous sélectionnez une enveloppe présentant un format X12 ou EDIFACT, les étapes suivantes s'avèrent nécessaires. Si vous sélectionnez une enveloppe au format personnalisé, les étapes suivantes sont facultatives.

    1. Cliquez sur Séparateurs et définissez les propriétés des séparateurs.

      Pour plus d'informations, voir Définition des séparateurs d'enveloppes.

    2. Dans la zone Numéro de contrôle d'échange, tapez un numéro de contrôle d'échange.
  2. Si vous voulez remplacer l'identificateur d'organisation par défaut pour l'organisation de destination, cliquez sur un autre identificateur dans la liste Identificateur d'organisation.

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges.

Une fois vos modifications effectuées, cliquez sur Terminer.

Important

  • Si vous sélectionnez une enveloppe utilisant un format Reliable, vous devez également configurer l'adresse de l'URL de réponse d'échange de type Reliable dans la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

  • Le format d'enveloppe que vous spécifiez dans un port d'échanges doit correspondre au format du ou des documents qu'il contient. Le format de document est déterminé par la spécification à laquelle il est fait référence dans la définition de document sortant d'un canal associé. Par exemple, si vous choisissez une enveloppe au format X12 pour un port d'échanges, vous devez sélectionner une définition de document sortant pour le canal pointant vers une spécification X12.

Remarques

  • Lors du traitement d’enveloppes compatibles avec BizTalk Framework 2.0, BizTalk Server 2002 doit être considéré comme étant le point final par rapport au délai d’expiration. Lorsque les documents compatibles avec BizTalk Framework 2.0 sont envoyés à BizTalk Server 2002 soit d’une application, soit d’un partenaire commercial, les champs ci-dessous sont remplacés s’ils sont présents et créés s’ils n’existent pas encore :
    • Dans la sous-section relative aux propriétés :

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Dans la sous-section relative aux informations de réception :

      <sendTo>

      <adresse>

      <sendReceiptBy>

  • Pour un port d'échanges vers une application, les identificateurs d'organisation disponibles dans la liste Identificateur d'organisation sont ceux de l'organisation d'origine.

  • Si vous utilisez le type de transport Loopback, vous ne pouvez pas choisir une enveloppe au format Reliable.

  • Lorsque vous sélectionnez un identificateur d'organisation de destination destiné à être utilisé avec des enveloppes X12, vous ne pouvez pas sélectionner l'identificateur d'organisation dénommé Organisation ni tout autre identificateur dont le qualificateur excède 2 caractères ou dont la valeur dépasse 15 caractères.

  • Lorsque vous sélectionnez un identificateur d'organisation de destination destiné à être utilisé avec des enveloppes EDIFACT, vous ne pouvez pas sélectionner l'identificateur d'organisation dénommé Organisation ni tout autre identificateur dont le qualificateur excède 4 caractères ou dont la valeur dépasse 35 caractères.

  • Si vous sélectionnez une enveloppe au format EDIFACT, l'identificateur de syntaxe par défaut est « UNOA » (alphabet latin en majuscules). Si vos données requièrent une autre syntaxe, définissez un autre identificateur de syntaxe en modifiant les valeurs par défaut du port d'échanges dans l'Assistant Canal. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

Voir aussi

Création d'enveloppes

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges

Description des enveloppes


Définition des propriétés des informations de sécurité

  1. Sur la page Informations de sécurité de l'Assistant Propriétés du port d'échanges, dans la zone Codage, dans la liste Type, sélectionnez un des éléments suivants :
    • (Aucun). Spécifie l'absence de codage. Il s'agit de la configuration par défaut.

    • MIME. Spécifie un codage MIME (Multipurpose Internet Mail Extensions).

    • Personnalisé. Spécifie un codage utilisant un composant de codage personnalisé.

    Remarques

    • Vous pouvez spécifier un composant de signature, de codage ou de cryptage personnalisé et configurer l'identificateur de classe (CSLID) en utilisant simplement le modèle d'objets de configuration d'Échanges BizTalk. Le Gestionnaire d'échanges BizTalk affiche la mention « Personnalisé » dans la liste Type de la signature, du codage ou du cryptage, uniquement lorsque vous modifies un port d'échanges pour lequel un composant personnalisé a été spécifié.

    • Si vous spécifiez une enveloppe utilisant un format Reliable ou une enveloppe utilisant un format XML personnalisé sans spécification d'enveloppe et que votre document ne contient pas de pièces jointes, le codage MIME n'est pas appliqué à votre envoi, même si vous avez défini le paramétrage correspondant.

    • Si le document entrant comporte des données Shift-JIS codées au format MIME, ne spécifiez pas « encoding=Shift_jis » dans le corps du document. En revanche, spécifiez « charset=shift-jis » dans l'en-tête MIME.
  2. Dans la zone Cryptage, dans la liste Type, cliquez sur une des possibilités suivantes :
    • (Aucun). Spécifie l'absence de cryptage. Il s'agit de la configuration par défaut.

    • S/MIME. Spécifie un cryptage S/MIME (Secure Multipurpose Internet Mail Extensions).

    • Personnalisé. Spécifie un codage utilisant un composant de cryptage personnalisé.

    Remarque

    • Vous pouvez spécifier un composant de cryptage personnalisé et configurer l'identificateur de classe (CSLID) en utilisant simplement le modèle d'objets de configuration d'Échanges BizTalk.
  3. Si vous sélectionnez le cryptage S/MIME, dans la zone Cryptage, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un certificat de cryptage s'affiche.

  4. Sélectionnez un certificat de cryptage.

    Pour plus d'informations, voir Sélection d'un certificat de cryptage.

  5. Dans la zone Signature, dans la liste Type, cliquez sur un des éléments suivants :
    • (Aucun). Spécifie l'absence de signature. Il s'agit de la configuration par défaut.

    • S/MIME. Spécifie une signature S/MIME (Secure Multipurpose Internet Mail Extensions).

    • Personnalisé. Spécifie un codage utilisant un composant de signature personnalisé.

    Remarque

    • Vous pouvez spécifier un composant de signature personnalisé et configurer l'identificateur de classe (CSLID) en utilisant simplement le modèle d'objets de configuration d'Échanges BizTalk.
  6. Si vous ne souhaitez pas passer directement à l'Assistant Canal pour créer un canal, désactivez la case à cocher Créer un canal pour ce port d'échanges ; dans le cas contraire, cliquez sur un des types de canal suivants dans la liste Type de canal :
    • À partir d'une organisation

    • À partir d'une application

Si vous créez un nouveau port d'échanges, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Création de ports d'échanges.

Si vous modifiez un port d'échanges existant, cliquez sur Suivant. Pour obtenir des instructions sur l'exécution de l'étape suivante, voir Modification de ports d'échanges.

Une fois vos modifications effectuées, cliquez sur Terminer.

Voir aussi

Création de canaux

Création de ports d'échanges

Modification de ports d'échanges

Définition des propriétés d'un port d'échanges


Sélection d'une organisation de destination

  1. Sur la page Organisation de destination de l'Assistant Propriétés du port d'échanges, cliquez sur Organisation, puis sur Parcourir.

    La boîte de dialogue Sélectionner une organisation apparaît.

  2. Dans la liste Organisations disponibles, cliquez sur une organisation, puis sur OK.

Pour poursuivre la définition des propriétés de l'organisation de destination, voir Définition des propriétés de l'organisation de destination.

Voir aussi

Création de ports d'échanges

Définition des propriétés de l'organisation de destination

Définition des propriétés d'un port d'échanges


Sélection d'un certificat de cryptage

  1. Sur la page Informations de sécurité de l'Assistant Propriétés du port d'échanges, dans la zone Cryptage, dans la liste Type, cliquez sur S/MIME, puis sur Parcourir.

    La boîte de dialogue Sélectionner un certificat de cryptage s'affiche.

  2. Dans la liste Nom de certificat, choisissez un nom de certificat et cliquez sur OK.

Pour poursuivre la définition des propriétés de sécurité, accédez à Définition des propriétés des informations de sécurité.

Remarque

  • Les certificats doivent porter un nom unique. Si plusieurs certificats ont le même nom, il n’est possible d’en sélectionner qu’un seul. Une fois le certificat sélectionné, les autres certificats portant le même nom disparaissent de la liste.

    Pour plus d'informations sur les certificats, voir Description des certificats.

Voir aussi

Création de ports d'échanges

Définition des propriétés d'un port d'échanges

Définition des propriétés des informations de sécurité


Définition des propriétés de transport

Parmi les propriétés de transport figure le type de transport. Le type de transport spécifie le service de transport utilisé par Microsoft BizTalk Server 2002 pour transmettre les documents à la destination désignée dans le port d'échanges. Les propriétés de transport peuvent également comprendre une adresse spécifique pour l'expédition des données. Les propriétés d'adresse diffèrent en fonction du type de transport sélectionné.

Cette section décrit les procédures de définition des propriétés des transports primaire et secondaire pour un port d'échanges.

Cette section traite des procédures suivantes :

  • Sélection d'un type de transport

  • Spécification d'une adresse de transport

  • Sélection d'un composant d'intégration aux applications

  • Modification de la valeur par défaut de l'objet SMTP


Sélection d'un type de transport

  1. Sur la page Application de destination ou Organisation de destination de l’Assistant Propriétés du port d’échanges, dans la zone Transport principal ou Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport principal ou Transport secondaire s'affiche.

  2. Dans la liste Type de transport, cliquez sur l'un des types de transport suivants :
    • Composant d'intégration aux applications. Spécifie un transport utilisant un composant d'intégration aux applications enregistré avec BizTalk Server 2002.

    • Fichier. Spécifie un transport utilisant le composant SendLocalFile.

    • HTTP. Spécifie un transport utilisant le protocole HTTP (Hypertext Transfer Protocol).

    • HTTPS. Spécifie un transport utilisant le protocole HTTPS (Secure Hypertext Transfer Protocol).

    • Loopback. Spécifie un transport qui renvoie le document sortant d'un canal à une application professionnelle, à un composant ou à une planification XLANG ayant envoyé le document entrant via un appel d'envoi synchrone. Ce type de transport est uniquement disponible pour un port d'échanges envoyant des documents à une application.

    • Message Queuing. Spécifie un transport utilisant le service Message Queuing.

    • SMTP. Spécifie un transport utilisant le protocole SMTP (Simple Mail Transfer Protocol).
  3. Exécutez une des étapes suivantes :
    • Si vous sélectionnez le type de transport AIC (Compenent integration Application), voir Sélection d'un composant d'intégration aux applications.

    • Si vous sélectionnez le type de transport Loopback, aucune adresse de transport n'est requise.

    • Si vous sélectionnez tout autre type de transport, voir Spécification d'une adresse de transport.

Remarques

  • Si vous choisissez le type de transport Message Queuing et que vous n'utilisez pas d'enveloppe, les messages que vous traitez via ce port d'échanges sont limités à une taille de 2 Mo.

  • Si vous choisissez le type de transport Message Queuing et que vous utilisez une enveloppe, les messages que vous traitez via ce port d'échanges sont limités à une taille de 4 Mo.

  • Pour pouvoir utiliser le type de transport SMTP, vous devez configurer l'hôte SMTP dans la console Administration de BizTalk Server. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

  • La configuration par défaut pour le composant de transport HTTP doit utiliser le serveur proxy HTTP. Cette configuration est celle qui convient pour le transport des données vers des sites Web situés à l’extérieur du pare-feu de votre entreprise. Pour transporter des données vers des sites Web situés à l'intérieur du pare-feu de votre entreprise (c'est-à-dire, dans votre intranet), modifiez les paramètres par défaut dans le canal. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.

  • Le type de transport Loopback peut être utilisé pour mapper un document entrant sur un format ou une enveloppe différents ou pour sécuriser le document (codage, cryptage, signature numérique), pour ensuite renvoyer à l'appelant le document sortant en tant que document de réponse, et ce, d'une façon synchrone.

  • Si vous optez pour le type de transport Loopback, vous ne pouvez pas utiliser une enveloppe au format Reliable.

Voir aussi

Création de ports d'échanges

Définition d'un composant d'intégration aux applications

Définition des propriétés d'un port d'échanges

Définition des propriétés de transport

Spécification d'une adresse de transport

Modification de la valeur par défaut de l'objet SMTP


Spécification d'une adresse de transport

  1. Sur la page Application de destination ou Organisation de destination de l’Assistant Propriétés du port d’échanges, dans la zone Transport principal ou Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport principal ou Transport secondaire s'affiche.

  2. Dans la liste Type de transport, cliquez sur un type de transport autre que Loopback ou Composant d'intégration aux applications.

  3. Dans la zone Adresse, tapez une adresse pour la destination.

  4. Si vous avez sélectionné le type de transport SMTP, tapez une adresse dans la zone Adresse de messagerie de retour.

    Le serveur utilise cette adresse en tant qu'adresse d'expédition dans l'en-tête sortant et en tant que destination pour les messages de retour.

Pour poursuivre la définition des propriétés de l'organisation de destination, voir Définition des propriétés de l'organisation de destination.

Important

  • Pour le type de transport Fichier, la configuration par défaut du composant de transport consiste à ajouter de nouveaux fichiers à un fichier existant dans le répertoire spécifié.

  • Si vous utilisez le type de transport Fichier pour envoyer plusieurs fichiers portant le même nom dans le même répertoire et que ces fichiers présentent des formats de document différents ou utilisent des pages de code différentes, les données du fichier d'ajout seront endommagées.

  • Si vous voulez créer un nouveau fichier pour chaque instance de document, vous devez utiliser le format suivant pour le chemin d'accès au fichier :

    file://C:\dir\file%tracking_id%.xml

Remarques

  • Pour tous les types de transport à l'exception de Message Queuing, un préfixe est automatiquement créé pour l'adresse. Ce préfixe est requis et ne doit pas être supprimé.

  • Pour le type de transport Message Queuing, les conditions suivantes doivent être remplies pour que l'adresse soit valide :
    • N'utilisez pas le préfixe « file d'attente:// » dans l'adresse.

    • Utilisez un nom de format plutôt qu'un chemin d'accès. Exemples de noms de format valides :

      DIRECT=SO:<NomServeur>\<NomFileAttente>

      PUBLIC=<GUID NomFileAttente>

      DIRECT=TCP:<AdresseIP\NomFileAttente>

      Si vous utilisez PUBLIC= nom de format, n’insérez pas de crochets avec l’identificateur global unique (GUID) de la file d’attente des messages.

      Pour plus d'informations sur Message Queuing, accédez au site Web de la bibliothèque en ligne MSDN (msdn.microsoft.com/library) et recherchez les mots clés « Message Queuing ».

  • Pour le type de transport Fichier, les conditions suivantes doivent être remplies pour que l'adresse soit valide :
    • Le chemin d'accès au fichier que vous spécifiez doit exister. Le chemin d'accès au fichier n'est pas créé automatiquement, et vous n'obtenez pas d'avertissement vous indiquant qu'il n'existe pas.

    • Vous devez obligatoirement spécifier un nom de fichier avec une extension.

      Exemple de chemin d'accès valide :

      file://C:\dir\fichier.xml

  • Pour le type de transport Fichier, vous pouvez inclure des caractères et des symboles afin de modifier dynamiquement le nom de fichier. Le nom de fichier créé par le serveur contient tous les caractères statiques que vous tapez dans la zone Adresse, ainsi que la valeur du symbole. Par exemple, si vous tapez file://C:\Commandes\Facture_%tracking_id%.xml dans la zone Adresse, le nom de fichier réel pourrait correspondre à C:\Commandes\Facture_{12345678-90AB-CDEF-1234-567890ABCDEF}.

    Le tableau suivant contient les symboles que vous pouvez utiliser avec le type de transport Fichier.

    Symbole | Description | Nom de fichier unique
    %dateheure% | Date et heure, en millisecondes, de la création du fichier. L'heure est basée sur l'heure du méridien de Greenwich (GMT) plutôt que sur l'heure locale. | Non
    %nom_document% | Nom de la définition de document utilisée pour traiter le fichier source. | Non
    %serveur% | Nom d'hôte du serveur ayant traité le document | Non
    %nomfichier_src% | Nom du fichier soumis au traitement. | Non
    %id_suivi% | Numéro de suivi universel unique | Oui
    %uid% | Compteur qui augmente avec le temps, représenté en millisecondes. Ce nombre est réinitialisé lorsque le serveur est redémarré. | Non

  • La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez le type de transport Fichier avec ses paramètres par défaut dans un port d'échanges et que vous utilisez un logiciel antivirus sur le serveur sur lequel BizTalk Server 2002 est installé, alors, si vous envoyez simultanément, vers le même emplacement de fichier, plusieurs fichiers portant exactement le même nom, BizTalk Server 2002 risque de ne plus répondre et doit éventuellement être redémarré. Vous pouvez éliminer ce problème en modifiant la configuration par défaut du composant de transport de fichiers en remplaçant l’option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Vous pouvez également éliminer ce problème en créant un fichier unique pour chaque instance de document traitée à l’aide du format de chemin d’accès suivant dans le port d’échanges : fichier://C:\dir\fichier%id_suivi%.xml. Pour plus d'informations sur le remplacement du paramètre de concaténation pour le composant de transport de fichier dans les propriétés avancées du canal, voir Remplacement des valeurs par défaut d'un port d'échanges.

  • La configuration par défaut pour le composant de transport de fichiers est celle qui ajoute les fichiers. Si vous sélectionnez le type de transport Fichier avec ses paramètres par défaut et que vous sélectionnez une enveloppe au format Reliable dans un port d'échanges, alors, si vous envoyez simultanément plusieurs fichiers vers le même emplacement de fichier, vous risquez d'obtenir des résultats d'analyse inattendus. Pour éliminer ce problème, vous pouvez modifier la valeur par défaut du composant de transport de fichiers en remplaçant l’option Ajouter au fichier par Fichier de remplacement dans la boîte de dialogue Propriétés de BizTalk SendLocalFile. Pour plus d'informations sur le remplacement du paramètre de concaténation pour le composant de transport de fichier dans les propriétés avancées du canal, voir Remplacement des valeurs par défaut d'un port d'échanges.

  • Le paramètre générique %nomfichier_src% figure dans le dictionnaire de transport, mais il n'est pas disponible.

Voir aussi

Création de ports d'échanges

Sélection d'un composant d'intégration aux applications

Sélection d'un type de transport

Définition des propriétés d'un port d'échanges

Définition des propriétés de transport

Tableau de correspondances


Sélection d'un composant d'intégration aux applications

  1. Sur la page Application de destination ou Organisation de destination de l’Assistant Propriétés du port d’échanges, dans la zone Transport principal ou Transport secondaire, cliquez sur Parcourir.

    La boîte de dialogue Transport principal ou Transport secondaire s'affiche.

  2. Dans la liste Type de transport, cliquez sur Composant d'intégration aux applications.

  3. À droite de la zone Nom de composant, cliquez sur Parcourir.

    La boîte de dialogue Sélectionner un composant s'affiche.

  4. Dans la liste Composants disponibles, cliquez sur un composant, puis sur OK.

Pour poursuivre la définition des propriétés de l'organisation de destination, voir Définition des propriétés de l'organisation de destination.

Remarque

  • Un composant d'intégration aux applications doit être enregistré avec BizTalk Server 2002 avant d'être disponible dans la liste Composants disponibles. Pour plus d'informations, voir Registering Custom Components.

Voir aussi

Création de ports d'échanges

Sélection d'un type de transport

Définition des propriétés d'un port d'échanges

Définition des propriétés de transport

Spécification d'une adresse de transport

Tableau de correspondances


Modification de la valeur par défaut de l'objet SMTP

BizTalk Server 2002 ~ Configuration des services d'échanges BizTalk

Modification de la valeur par défaut de l’objet SMTP

La valeur par défaut de l’Objet SMTP (Simple Mail Transfer Protocol) est <nom_document>-<ID_suivi>. Elle vous permet de router les documents basés sur le nom de définition du document.

  1. Dans le menu Démarrer, pointez sur Programmes, pointez sur Microsoft BizTalk Server, puis cliquez sur Gestionnaire d’échanges BizTalk.

  2. Dans la zone Rechercher d’autres éléments, cliquez sur Canaux et sur Rechercher.

  3. Sous Nom du canal, cliquez sur le canal pour lequel vous souhaitez afficher l’objet SMTP, puis appuyez sur ENTRÉE.

    L’Assistant Propriétés du canal s’ouvre.

  4. Cliquez sur Suivant pour avancer dans l’Assistant jusqu’à la page Configuration avancée.

  5. Sur la page Configuration avancée, cliquez sur Avancée.

  6. Dans la boîte de dialogue Ignorer les valeurs par défaut du port d’échanges, cliquez sur Propriétés.

  7. Dans la zone Objet, entrez une nouvelle valeur par défaut et cliquez deux fois sur OK.

  8. Cliquez sur Terminer.

    La modification est enregistrée.

Remarque

  • Si vous créez un port d’échanges de destination ouvert, la boîte de dialogue Ignorer les valeurs par défaut du port d’échanges n’est pas disponible. Si vous utilisez SMTP comme service de transport des documents et des échanges de destination ouverts, vous pouvez router le document à partir de l’ID de suivi et du nom de définition du document.


Définition des séparateurs d'enveloppes

Les propriétés de séparateur déterminent les caractères utilisés pour séparer les données d'une enveloppe et les documents d'un échange. Les séparateurs sont uniquement requis pour les enveloppes qui utilisent les formats X12 et EDIFACT. Ils sont facultatifs pour les enveloppes utilisant un format personnalisé.

Les séparateurs d'enveloppe sont définis lorsque vous en sélectionnez une dans un port d'échanges. Les séparateurs définis pour un port d'échanges s'appliquent uniquement à celui-ci. Des séparateurs différents peuvent être définis pour la même enveloppe si celle-ci est utilisée dans un autre port d'échanges. Cette section décrit les procédures de définition des propriétés des séparateurs.

Cette section traite des procédures suivantes :

  • Définition des séparateurs X12

  • Définition des séparateurs EDIFACT

  • Définition des séparateurs personnalisés

  • Tableau de correspondances


Définition des séparateurs X12

  1. Sur la page Informations d'enveloppe de l'Assistant Propriétés d'un port d'échanges, dans la zone Informations d'enveloppe, sélectionnez une enveloppe au format X12 et cliquez sur Séparateurs.

    La boîte de dialogue Séparateurs X12 s'affiche.

  2. Spécifiez des valeurs de séparateurs soit dans la zone Caractère, soit dans la zone Hexadécimal, et cliquez sur OK.

Le tableau suivant décrit les séparateurs X12.

Séparateur | Description
Séparateur d'éléments de composant | Spécifie le caractère utilisé pour séparer des composants de données au sein d'un champ de données composite. Un champ de données composite est un champ constitué de plusieurs sous-champs.
Séparateur d'éléments | Spécifie le caractère utilisé pour séparer des champs de données au sein d'un enregistrement.
Terminateur du segment | Spécifie le caractère utilisé pour indiquer la fin d'un enregistrement.

Pour poursuivre la définition des propriétés de l'organisation de destination, voir Définition des propriétés des informations d'enveloppes.

Remarque

  • Pour chaque séparateur, vous pouvez taper soit un caractère dans la zone Caractère, soit deux caractères dans la zone Hexadécimal. La zone Hexadécimal peut être utilisée pour entrer des séparateurs correspondant à des caractères non imprimables, comme, par exemple, la touche ENTRÉE.

Voir aussi

Création de ports d'échanges

Définition des séparateurs personnalisés

Définition des séparateurs EDIFACT

Définition des séparateurs d'enveloppes

Définition des propriétés des informations d'enveloppes

Définition des propriétés d'un port d'échanges

Tableau de correspondances


Définition des séparateurs EDIFACT

  1. Sur la page Informations d'enveloppe de l'Assistant Propriétés du port d'échanges, dans la zone Informations d'enveloppe, sélectionnez une enveloppe au format EDIFACT et cliquez sur Séparateurs.

    La boîte de dialogue Séparateurs EDIFACT apparaît.

  2. Spécifiez des valeurs de séparateurs soit dans la zone Caractère, soit dans la zone Hexadécimal, et cliquez sur OK.

Le tableau suivant décrit les séparateurs EDIFACT.

Séparateur | Description
Séparateur d'éléments de composant | Spécifie le caractère utilisé pour séparer des composants de données au sein d'un champ de données composite. Un champ de données composite est un champ constitué de plusieurs sous-champs.
Séparateur d'éléments | Spécifie le caractère utilisé pour séparer des champs de données au sein d'un enregistrement.
Indicateur de libération | Spécifie le caractère utilisé pour indiquer que le caractère suivant ne doit pas être considéré comme un séparateur.
Terminateur du segment | Spécifie le caractère utilisé pour indiquer la fin d'un enregistrement.

Remarques

  • Si vous utilisez des indicateurs de libération EDIFACT, vos données ne doivent pas contenir de caractères faisant fonction d'indicateur de libération. Si vous procédez ainsi, les données risquent de dépasser les limites définies pour la taille physique des caractères autorisée pour les champs.

  • Pour chaque séparateur, vous pouvez taper soit un caractère dans la zone Caractère, soit deux caractères dans la zone Hexadécimal. La zone Hexadécimal peut être utilisée pour entrer des séparateurs correspondant à des caractères non imprimables, comme, par exemple, la touche ENTRÉE.

  • Le séparateur de spécification décimale EDIFACT ne peut pas être utilisé.

Pour poursuivre la définition des propriétés de l'organisation de destination, voir Définition des propriétés des informations d'enveloppes.

Voir aussi

Création de ports d'échanges

Définition des séparateurs personnalisés

Définition des séparateurs d'enveloppes

Définition des propriétés des informations d'enveloppes

Définition des propriétés d'un port d'échanges

Définition des séparateurs X12

Tableau de correspondances


Définition des séparateurs personnalisés

  1. Sur la page Informations d'enveloppe de l'Assistant Propriétés du port d'échanges, dans la zone Informations d'enveloppe, sélectionnez une enveloppe au format personnalisé et cliquez sur Séparateurs.

    La boîte de dialogue Séparateurs personnalisés apparaît.

  2. Spécifiez des valeurs de séparateurs soit dans la zone Caractère, soit dans la zone Hexadécimal, et cliquez sur OK.

Le tableau suivant décrit les séparateurs personnalisés.

Séparateur | Description
Sous-champ | Spécifie le caractère utilisé pour séparer des composants de données au sein d'un champ de données composite.
Champ | Spécifie le caractère utilisé pour séparer les champs de données au sein d'un enregistrement.
Caractère d'échappement | Spécifie le caractère utilisé pour indiquer que le caractère suivant ne doit pas être considéré comme un séparateur.
Enregistrement | Spécifie le caractère utilisé pour indiquer la fin d'un enregistrement.

Remarque

  • Pour chaque séparateur, vous pouvez taper soit un caractère dans la zone Caractère, soit deux caractères dans la zone Hexadécimal. La zone Hexadécimal peut être utilisée pour entrer des séparateurs correspondant à des caractères non imprimables, comme, par exemple, la touche ENTRÉE.

Pour poursuivre la définition des propriétés de l'organisation de destination, voir Définition des propriétés des informations d'enveloppes.

Voir aussi

Création de ports d'échanges

Définition des séparateurs EDIFACT

Définition des séparateurs d'enveloppes

Définition des propriétés des informations d'enveloppes

Définition des propriétés d'un port d'échanges

Définition des séparateurs X12

Tableau de correspondances


Tableau de correspondances

BizTalk Server utilise des termes différents pour décrire les divers séparateurs et caractères d'échappement des normes X12 et EDIFACT. Le tableau suivant dresse la liste des termes correspondant aux Outils XML (par exemple, l'Éditeur Biztalk) et au Gestionnaire d'échanges BizTalk. Leur signification est identique, mais leur appellation est différente.

Outils XML | Gestionnaire d'échanges BizTalk
Délimiteur d'enregistrement | Terminateur du segment
Délimiteur de champ | Séparateur d'éléments
Délimiteur de sous-champ | Séparateur d'éléments de composant
Caractère d'échappement | Indicateur de libération

Voir aussi

Création de ports d'échanges

Définition des séparateurs personnalisés

Définition des séparateurs EDIFACT

Définition des séparateurs d'enveloppes

Définition des propriétés des informations d'enveloppes

Définition des propriétés d'un port d'échanges

Définition des séparateurs X12


Création et gestion d'organisations

Cette section fournit des informations spécifiques aux tâches relatives à la création et à la gestion des organisations. Nous vous recommandons de consulter la rubrique Description des organisations pour bien comprendre le concept des organisations.

Cette section traite des procédures suivantes :

  • Configuration de l'organisation d'origine

  • Création d'organisations

  • Recherche d'organisations

  • Modification d'organisations

  • Suppression d'organisations

  • Définition des propriétés d'une organisation


Configuration de l'organisation d'origine

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Dans la zone Rechercher les organisations, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

  3. Dans la liste Nom de l'organisation, double-cliquez sur Organisation d'origine.

    La boîte de dialogue Propriétés d'organisation apparaît.

  4. Dans l'onglet Général, définissez les propriétés générales de l'organisation.

    Pour plus d'informations, voir Définition des propriétés générales d'une organisation.

  5. Cliquez sur l'onglet Identificateurs et définissez les propriétés des identificateurs d'organisation.

    Pour plus d'informations, voir Définition des propriétés des identificateurs d'organisation.

  6. Cliquez sur l'onglet Applications et définissez les propriétés des applications.

    Pour plus d'informations, voir Définition des propriétés des applications.

  7. Après avoir défini toutes les propriétés requises pour l'organisation d'origine, cliquez sur OK pour fermer la boîte de dialogue Propriétés d'organisation.

Important

  • Un identificateur d'organisation dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable est automatiquement créé pour l'organisation d'origine. Cet identificateur ne peut pas être supprimé. Vous ne pouvez pas modifier le nom ou le qualificateur de cet identificateur, mais vous pouvez modifier la valeur. La valeur spécifiée pour cet identificateur est utilisée comme adresse d'expédition lors de l'envoi d'accusés de réception d'échanges au format Reliable utilisant le protocole de transport SMTP. Pour plus d'informations sur les accusés de réception d'échanges au format Reliable, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.

  • La valeur spécifiée pour l'identificateur d'organisation (Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable) est également utilisée comme adresse d'expédition lorsque l'adresse fournie pour un port d'échanges ouvert est une adresse SMTP. Pour plus d'informations, voir Openness.

Remarques

  • Vous pouvez renommer l'organisation d'origine à tout moment et lui attribuer le nom de votre choix.

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout d'applications n'est autorisé que pour l'organisation d'origine.

Voir aussi

Modification d'organisations

Recherche d'organisations

Définition des propriétés des applications

Définition des propriétés d'une organisation

Description des organisations


Création d'organisations

  1. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation.

    La boîte de dialogue Nouvelle organisation apparaît.

  2. Dans l'onglet Général, définissez les propriétés générales de l'organisation.

    Pour plus d'informations, voir Définition des propriétés générales d'une organisation.

  3. Cliquez sur l'onglet Identificateurs et définissez les propriétés des identificateurs d'organisation.

    Pour plus d'informations, voir Définition des propriétés des identificateurs d'organisation.

  4. Après avoir défini toutes les propriétés requises, cliquez sur OK pour fermer la boîte de dialogue Nouvelle organisation.

Voir aussi

Configuration de l'organisation d'origine

Suppression d'organisations

Modification d'organisations

Recherche d'organisations

Définition des propriétés d'une organisation

Description des organisations


Recherche d'organisations

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher toutes les organisations, effacez tous les critères de recherche et cliquez sur Rechercher.

    • Pour rechercher des organisations portant un nom spécifique, dans la zone Rechercher les organisations, dans Nom de l'organisation, tapez le nom de l'organisation que vous souhaitez trouver et cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher l'organisation d'origine uniquement, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

Remarques

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans vos critères de recherche.
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère en dehors de l'intervalle ([^a-f]) ou de l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression d'organisations

Modification d'organisations

Description des organisations


Modification d'organisations

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de l'organisation, cliquez sur l'organisation que vous souhaitez modifier.

    Pour plus d'informations sur la recherche d'organisations, voir Recherche d'organisations.

  2. Dans le menu Fichier, cliquez sur Edition.

    La boîte de dialogue Propriétés d'organisation apparaît.

  3. Dans l'onglet Général, modifiez les propriétés requises.

    Pour plus d'informations, voir Définition des propriétés générales d'une organisation.

  4. Cliquez sur l'onglet Identificateurs et modifiez les propriétés d'identificateurs d'organisation requises.

    Pour plus d'informations, voir Définition des propriétés des identificateurs d'organisation.

  5. Si vous modifiez l'organisation d'origine, cliquez sur l'onglet Applications et modifiez les propriétés d'applications requises.

    Pour plus d'informations, voir Définition des propriétés des applications.

  6. Après avoir modifié toutes les propriétés nécessaires, cliquez sur OK pour fermer la boîte de dialogue Propriétés d'organisation.

Important

  • Un identificateur d'organisation dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable est automatiquement créé pour l'organisation d'origine. Cet identificateur ne peut pas être supprimé. Vous ne pouvez pas modifier le nom ou le qualificateur de cet identificateur, mais vous pouvez modifier la valeur. La valeur spécifiée pour cet identificateur est utilisée comme adresse d'expédition lors de l'envoi d'accusés de réception d'échanges au format Reliable utilisant le protocole de transport SMTP. Pour plus d'informations sur les accusés de réception d'échanges au format Reliable, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.

  • La valeur spécifiée pour l'identificateur d'organisation (Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable) est également utilisée comme adresse d'expédition lorsque l'adresse fournie pour un port d'échanges ouvert est une adresse SMTP. Pour plus d'informations, voir Openness.

Remarque

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout d'applications est uniquement autorisé pour l'organisation d'origine.

Voir aussi

Création d'organisations

Suppression d'organisations

Recherche d'organisations

Description des organisations


Suppression d'organisations

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de l'organisation, cliquez sur l'organisation que vous souhaitez supprimer.

    Pour plus d'informations sur la recherche d'organisations, voir Recherche d'organisations.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarques

  • Si une organisation est utilisée dans un port d'échanges ou dans un canal, vous ne pouvez pas la supprimer. Vous devez d'abord supprimer tous les canaux et ports d'échanges qui utilisent l'organisation.

  • Il est impossible de supprimer l'organisation d'origine.

Voir aussi

Création d'organisations

Modification d'organisations

Recherche d'organisations

Description des organisations


Définition des propriétés d'une organisation

Cette section fournit des informations spécifiques aux tâches quant à la configuration des propriétés d'une organisation.

Cette section traite des procédures suivantes :

  • Définition des propriétés générales d'une organisation

  • Définition des propriétés des identificateurs d'organisation

  • Définition des propriétés des applications


Définition des propriétés générales d'une organisation

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation ou, dans la liste Nom de l'organisation, double-cliquez sur une organisation.

    La boîte de dialogue Organisation apparaît.

  2. Dans l'onglet Général, dans la zone Nom de l'organisation, tapez un nom unique pour l'organisation.

  3. Dans la zone Commentaires, tapez les éventuels commentaires que vous souhaitez définir pour l'organisation.

Voir aussi

Configuration de l'organisation d'origine

Création d'organisations

Modification d'organisations

Définition des propriétés d'une organisation


Définition des propriétés des identificateurs d'organisation

Les identificateurs d'organisation servent à identifier les organisations d'une manière univoque. Une organisation peut posséder plusieurs identificateurs, mais chaque identificateur doit être unique pour cette organisation.

Lors de la création d'une nouvelle organisation, un identificateur d'organisation dénommé Organisation est automatiquement créé. Le qualificateur de cet identificateur est OrganizationName, et la valeur correspond au nom que vous attribuez à l'organisation. Le serveur utilise cet identificateur d'organisation en tant qu'identificateur par défaut à moins que vous ne créiez d'autres identificateurs et que vous en désigniez un comme identificateur par défaut.

Cette section traite des procédures suivantes :

  • Ajout d'identificateurs d'organisation

  • Modification d'identificateurs d'organisation

  • Suppression d'identificateurs d'organisation

Voir aussi

Configuration de l'organisation d'origine

Création d'organisations

Modification d'organisations

Identificateurs d'organisation

Définition des propriétés d'une organisation


Ajout d'identificateurs d'organisation

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation ou, dans la liste Nom de l'organisation, double-cliquez sur une organisation.

    La boîte de dialogue Organisation apparaît.

  2. Cliquez sur l'onglet Identificateurs, puis sur Ajouter.

    La boîte de dialogue Nouvel identificateur apparaît.

  3. Dans la zone Nom, exécutez l'une des étapes suivantes :
    • Cliquez sur Standard, puis cliquez sur un nom de la liste.

    • Cliquez sur Personnalisé et tapez un nom unique dans la zone. Ensuite, dans la zone Qualificateur, tapez un qualificateur pour l'identificateur.
  4. Dans la zone Valeur, tapez une valeur pour l'identificateur.

  5. Si vous souhaitez définir cet identificateur en tant qu'identificateur par défaut de l'organisation, activez la case à cocher Définir par défaut. Dans le cas contraire, assurez-vous que la case à cocher est désactivée.

  6. Cliquez sur OK pour fermer la boîte de dialogue Nouvel identificateur.

Important

  • Un identificateur d'organisation dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable est automatiquement créé pour l'organisation d'origine. Cet identificateur ne peut pas être supprimé. Vous ne pouvez pas modifier le nom ou le qualificateur de cet identificateur, mais vous pouvez modifier la valeur. La valeur spécifiée pour cet identificateur est utilisée comme adresse d'expédition lors de l'envoi d'accusés de réception d'échanges au format Reliable utilisant le protocole de transport SMTP. Pour plus d'informations, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.

  • La valeur spécifiée pour l'identificateur d'organisation (Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable) est également utilisée comme adresse d'expédition lorsque l'adresse fournie pour un port d'échanges ouvert est une adresse SMTP. Pour plus d'informations, voir Openness.

Remarques

  • Un seul identificateur peut être désigné comme identificateur par défaut d'une organisation. L'identificateur par défaut sert à identifier une organisation, sauf si vous spécifiez un autre identificateur d'organisation dans un canal ou un port d'échanges.

  • Lors de la création d'une nouvelle organisation, un identificateur d'organisation dénommé Organisation est automatiquement créé. Le qualificateur de cet identificateur est OrganizationName et la valeur correspond au nom de l'organisation. Vous pouvez créer des identificateurs supplémentaires, mais celui-ci ne peut être ni modifié, ni supprimé.

  • Lorsque vous créez un identificateur d'organisation destiné à être utilisé avec des enveloppes EDIFACT, le qualificateur ne peut pas dépasser 4 caractères et la valeur peut comporter au maximum 35 caractères.

  • Lorsque vous créez un identificateur d'organisation destiné à être utilisé avec des enveloppes X12, le qualificateur ne peut pas dépasser 2 caractères et la valeur peut comporter au maximum 15 caractères.

Voir aussi

Configuration de l'organisation d'origine

Création d'organisations

Modification d'identificateurs d'organisation

Modification d'organisations

Identificateurs d'organisation

Suppression d'identificateurs d'organisation

Définition des propriétés des identificateurs d'organisation


Modification d'identificateurs d'organisation

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation ou, dans la liste Nom de l'organisation, double-cliquez sur une organisation.

    La boîte de dialogue Organisation apparaît.

  2. Cliquez sur l'onglet Identificateurs.

  3. Dans la liste Identificateurs d'organisation, cliquez sur l'identificateur que vous souhaitez modifier et cliquez sur Modifier.

    La boîte de dialogue Propriétés d'identificateur s'affiche.

  4. Dans la zone Nom, exécutez l'une des étapes suivantes :
    • Cliquez sur Standard, puis cliquez sur un nom de la liste.

    • Cliquez sur Personnalisé et tapez un nom unique dans la zone. Ensuite, dans la zone Qualificateur, tapez un qualificateur pour l'identificateur.
  5. Dans la zone Valeur, tapez une valeur pour l'identificateur.

  6. Si vous souhaitez définir cet identificateur en tant qu'identificateur par défaut de l'organisation, activez la case à cocher Définir par défaut. Dans le cas contraire, assurez-vous que la case à cocher est désactivée.

  7. Cliquez sur OK pour fermer la boîte de dialogue Propriétés d'identificateur.

Important

  • Un identificateur d'organisation dénommé Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable est automatiquement créé pour l'organisation d'origine. Vous ne pouvez pas modifier le nom ou le qualificateur de cet identificateur, mais vous pouvez modifier la valeur. Cet identificateur ne peut pas être supprimé. La valeur spécifiée pour cet identificateur est utilisée comme adresse d'expédition lors de l'envoi d'accusés de réception d'échanges au format Reliable utilisant le protocole de transport SMTP. Pour plus d'informations, voir Traitement des accusés de réception en utilisant des échanges au format Reliable.

  • La valeur spécifiée pour l'identificateur d'organisation (Adresse d'expédition SMTP pour accusé de réception d'échanges au format Reliable) est également utilisée comme adresse d'expédition lorsque l'adresse fournie pour un port d'échanges ouvert est une adresse SMTP. Pour plus d'informations, voir Openness.

Remarques

  • Un seul identificateur peut être désigné comme identificateur par défaut d'une organisation. L'identificateur par défaut sert à identifier une organisation, sauf si vous spécifiez un autre identificateur d'organisation dans un canal ou un port d'échanges.

  • Lors de la création d'une nouvelle organisation, un identificateur d'organisation dénommé Organisation est automatiquement créé. Le qualificateur de cet identificateur est OrganizationName et la valeur correspond au nom de l'organisation. Vous pouvez créer des identificateurs supplémentaires, mais celui-ci ne peut être ni modifié, ni supprimé.

  • Lorsque vous créez un identificateur d'organisation destiné à être utilisé avec des enveloppes EDIFACT, le qualificateur ne peut pas dépasser 4 caractères et la valeur peut comporter au maximum 35 caractères.

  • Lorsque vous créez un identificateur d'organisation destiné à être utilisé avec des enveloppes X12, le qualificateur ne peut pas dépasser 2 caractères et la valeur peut comporter au maximum 15 caractères.

Voir aussi

Ajout d'identificateurs d'organisation

Configuration de l'organisation d'origine

Création d'organisations

Modification d'organisations

Identificateurs d'organisation

Suppression d'identificateurs d'organisation

Définition des propriétés des identificateurs d'organisation


Suppression d'identificateurs d'organisation

  1. Dans le menu Fichier, pointez sur Nouveau et cliquez sur Organisation ou, dans la liste Nom de l'organisation, double-cliquez sur une organisation.

    La boîte de dialogue Organisation apparaît.

  2. Cliquez sur l'onglet Identificateurs.

  3. Dans la liste Identificateurs d'organisation, cliquez sur l'identificateur que vous souhaitez supprimer et cliquez sur Supprimer.

Remarques

  • L'identificateur d'organisation désigné comme identificateur par défaut ne peut pas être supprimé tant que vous n'avez pas désigné un autre identificateur par défaut.

  • L'identificateur d'organisation dénommé Organisation est automatiquement créé lors de la création d'une organisation. Cet identificateur d'organisation ne peut pas être supprimé.

Voir aussi

Ajout d'identificateurs d'organisation

Configuration de l'organisation d'origine

Création d'organisations

Modification d'identificateurs d'organisation

Modification d'organisations

Identificateurs d'organisation

Définition des propriétés des identificateurs d'organisation


Définition des propriétés des applications

Dans le Gestionnaire d'échanges BizTalk, l'ajout d'applications n'est autorisé que pour l'organisation d'origine. Les applications que vous créez vous permettent d'identifier et de suivre le flux de documents entre BizTalk Server 2002 et les applications internes concrètes de votre entreprise. Une application de l'organisation d'origine peut être définie en tant qu'application source dans un canal ou en tant qu'application de destination dans un port d'échanges.

L'organisation d'origine peut comprendre un nombre illimité d'applications. Chaque nom d'application doit être unique.

Cette section traite des procédures suivantes :

  • Ajout d'applications

  • Modification d'applications

  • Suppression d'applications

Voir aussi

Configuration de l'organisation d'origine

Modification d'organisations

Définition des propriétés d'une organisation


Ajout d'applications

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Dans la zone Rechercher les organisations, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

  3. Dans la liste Nom de l'organisation, double-cliquez sur Organisation d'origine.

    La boîte de dialogue Propriétés d'organisation apparaît.

  4. Dans l'onglet Applications, cliquez sur Ajouter.

    La boîte de dialogue Nouvelle application apparaît.

  5. Dans la zone Nom de l'application, tapez un nom unique pour l'application, puis cliquez sur OK.

Remarque

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout, la modification et la suppression d'applications ne sont autorisés que pour l'organisation d'origine.

Voir aussi

Configuration de l'organisation d'origine

Modification d'applications

Modification d'organisations

Suppression d'applications

Définition des propriétés des applications


Modification d'applications

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Dans la zone Rechercher les organisations, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

  3. Dans la liste Nom de l'organisation, double-cliquez sur Organisation d'origine.

    La boîte de dialogue Propriétés d'organisation apparaît.

  4. Dans l'onglet Applications, dans la liste Applications, cliquez sur l'application que vous souhaitez modifier et cliquez sur Modifier.

    La boîte de dialogue Propriétés d'application s'affiche.

  5. Dans la zone Nom de l'application, tapez un nom unique pour l'application, puis cliquez sur OK.

Remarque

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout, la modification et la suppression d'applications ne sont autorisés que pour l'organisation d'origine.

Voir aussi

Ajout d'applications

Configuration de l'organisation d'origine

Modification d'organisations

Suppression d'applications

Définition des propriétés des applications


Suppression d'applications

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Organisations.

  2. Dans la zone Rechercher les organisations, activez la case à cocher Organisation d'origine, puis cliquez sur Rechercher.

  3. Dans la liste Nom de l'organisation, double-cliquez sur Organisation d'origine.

    La boîte de dialogue Propriétés d'organisation apparaît.

  4. Dans l'onglet Applications, dans la liste Applications, cliquez sur l'application que vous souhaitez supprimer et cliquez sur Supprimer.

Remarque

  • Dans le Gestionnaire d'échanges BizTalk, l'ajout, la modification et la suppression d'applications ne sont autorisés que pour l'organisation d'origine.

Voir aussi

Ajout d'applications

Configuration de l'organisation d'origine

Modification d'organisations

Définition des propriétés des applications


Création et gestion de définitions de documents

Cette section fournit des informations spécifiques aux tâches relatives à la création et à la gestion des définitions de document. Nous vous recommandons vivement de consulter la rubrique Description des définitions de documents pour bien comprendre le concept de définition de documents.

Cette section traite des procédures suivantes :

  • Création de définitions de documents

  • Recherche de définitions de documents

  • Modification de définitions de documents

  • Suppression de définitions de documents

  • Définition des propriétés d'une définition de document


Création de définitions de documents

  1. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et cliquez sur Définition de document.

    La boîte de dialogue Nouvelle définition de document s'affiche.

  2. Dans l'onglet Général, définissez les propriétés générales.

    Pour plus d'informations, voir Définition des propriétés générales d'une définition de document.

  3. Cliquez sur l'onglet Suivi global et définissez les propriétés de suivi.

    Pour plus d'informations, voir Définition des propriétés de suivi global.

  4. Cliquez sur l'onglet Critères de sélection et définissez les propriétés des critères de sélection.

    Pour plus d'informations, voir Définition des propriétés des critères de sélection.

  5. Après avoir défini toutes les propriétés requises, cliquez sur OK pour fermer la boîte de dialogue Nouvelle définition de document.

Remarques

  • Vous pouvez sélectionner les champs de suivi uniquement à partir d'un schéma créé dans l'Éditeur BizTalk ou importé à partir de cet éditeur.

  • Vous ne pouvez pas attribuer à une définition de document le nom Canal des accusés de réception d’échanges fiables ou Accusé de réception standard BizTalk car il s'agit de noms système réservés.

  • Vous ne pouvez spécifier des champs de suivi global pour une définition de document qu'à condition de sélectionner une spécification.

  • Lorsque vous sélectionnez une définition de document dans un canal, vous pouvez remplacer les champs de suivi global de ce canal en sélectionnant d'autres champs de spécification devant faire l'objet d'un suivi. Pour plus d'informations, voir Sélection des champs de spécification dans un canal.

  • Lorsque vous enregistrez une définition de document qui fait référence à une spécification en dehors de votre domaine local, vous risquez d’obtenir un message d’erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (www.microsoft.com/france/msdn/telecharge/) et parcourez le chapitre XML du manuel Web Development jusqu’à la page WinHTTP Proxy Configuration Utility.

Voir aussi

Suppression de définitions de documents

Modification de définitions de documents

Recherche de définitions de documents

Description des définitions de documents


Recherche de définitions de documents

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Définitions de document.

  2. Pour rechercher toutes les définitions de documents, effacez tous les critères de recherche et cliquez sur Rechercher.

    –Ou–

    Pour rechercher une définition de document portant un nom spécifique, dans la zone Rechercher les définitions de document, dans Nom de la définition de document, tapez le nom de la définition de document que vous souhaitez trouver et cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

Remarques

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans les critères de recherche :
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère en dehors de l'intervalle ([^a-f]) ou de l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression de définitions de documents

Modification de définitions de documents

Description des définitions de documents


Modification de définitions de documents

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de la définition de document, cliquez sur la définition de document que vous souhaitez modifier.

    Pour plus d'informations sur la recherche de définitions de documents, voir Recherche de définitions de documents.

  2. Dans le menu Fichier, cliquez sur Edition.

    La boîte de dialogue Propriétés de la définition de document s'affiche.

  3. Dans l'onglet Général, modifiez les propriétés générales.

    Pour plus d'informations, voir Définition des propriétés générales d'une définition de document.

  4. Cliquez sur l'onglet Suivi global et modifiez les propriétés de suivi.

    Pour plus d'informations, voir Définition des propriétés de suivi global.

  5. Cliquez sur l'onglet Critères de sélection et modifiez les propriétés des critères de sélection.

    Pour plus d'informations, voir Définition des propriétés des critères de sélection.

  6. Après avoir modifié toutes les propriétés nécessaires, cliquez sur OK pour fermer la boîte de dialogue Propriétés de la définition de document.

Remarques

  • Vous ne pouvez pas attribuer à une définition de document le nom Canal des accusés de réception d’échanges fiables ou Accusé de réception standard BizTalk car il s'agit de noms système réservés.

  • Vous ne pouvez spécifier des champs de suivi global pour une définition de document qu'à condition de sélectionner une spécification.

  • Lorsque vous enregistrez une définition de document qui fait référence à une spécification en dehors de votre domaine local, vous risquez d’obtenir un message d’erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (www.microsoft.com/france/msdn/telecharge/) et parcourez le chapitre XML du manuel Web Development jusqu’à la page WinHTTP Proxy Configuration Utility.

Voir aussi

Création de définitions de documents

Suppression de définitions de documents

Recherche de définitions de documents

Description des définitions de documents


Suppression de définitions de documents

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de la définition de document, cliquez sur la définition de document que vous souhaitez supprimer.

    Pour plus d'informations sur la recherche de définitions de documents, voir Recherche de définitions de documents.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarque

  • Si une définition de document est utilisée dans un canal, vous ne pouvez pas la supprimer. Vous devez d'abord supprimer tous les canaux qui utilisent cette définition de document.

Voir aussi

Création de définitions de documents

Modification de définitions de documents

Recherche de définitions de documents

Description des définitions de documents


Définition des propriétés d'une définition de document

Cette section fournit des informations spécifiques aux tâches relatives à la configuration des propriétés d'une définition de document.

Cette section traite des procédures suivantes :

  • Définition des propriétés générales d'une définition de document

  • Sélection d'une spécification de document

  • Définition des propriétés de suivi global

  • Définition des propriétés des critères de sélection


Définition des propriétés générales d'une définition de document

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Général.

  2. Dans la zone Nom de la définition de document, tapez un nom unique pour la définition de document.

  3. Activez la case à cocher Spécification de document.

  4. Cliquez sur Parcourir pour sélectionner une spécification de document.

    Pour plus d'informations, voir Sélection d'une spécification de document.

Remarques

  • Les spécifications de documents sont facultatives ; toutefois, dans la plupart des cas, vous devez en sélectionner une. Si vous ne sélectionnez aucune spécification, vous pourrez constater les points suivants :
    • Les données que vous traitez ne seront pas converties au format XML du côté entrant, ni converties à partir du format XML du côté sortant.

    • Les données ne seront pas validées par rapport à une spécification afin de garantir qu’elles ne contiennent pas d’erreurs.

    • Vous ne pouvez pas transformer la structure ou le format des données en utilisant un mappage dans un canal.

    • Vous ne pouvez pas spécifier de champs de suivi global pour la définition de document.
  • Si vous traitez des données que vous ne souhaitez ni convertir, ni transformer, ni valider, comme par exemple un fichier binaire, vous ne devez pas sélectionner de spécification de document.

  • Si vous entrez une spécification de document non-BizTalk Server, vous ne pouvez pas sélectionner de champs de suivi sous l'onglet Suivi global.

Voir aussi

Création de définitions de documents

Modification de définitions de documents

Définition des propriétés d'une définition de document

Description des définitions de documents


Sélection d'une spécification de document

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Général.

  2. Activez la case à cocher Spécification de document et cliquez sur Parcourir.

    La boîte de dialogue Sélectionnez une spécification de document dans le référentiel WebDAV s'affiche.

  3. Dans la zone Serveur, procédez de l’une des façons suivantes pour changer de serveur.
    • Sélectionnez un serveur dans la liste.

    • Tapez le nom d’un serveur et appuyez sur ENTRÉE.
  4. Double-cliquez sur le dossier contenant la spécification que vous souhaitez ouvrir, puis double-cliquez sur le fichier.

Important

  • Lorsque vous ouvrez pour la première fois une boîte de dialogue Référentiel WebDAV, le référentiel WebDAV du serveur local est sélectionné, même si le Gestionnaire d'échanges BizTalk est connecté à une base de données d'un serveur distant. Si vous accédez à un référentiel WebDAV d'un serveur distant, celui-ci devient le serveur par défaut jusqu'à ce que vous sélectionniez un nouveau référentiel WebDAV. Le serveur par défaut de toutes les boîtes de dialogue Référentiel WebDAV est le dernier serveur avec lequel une connexion a été établie.

Remarques

  • Si vous sélectionnez l’adresse http://localhost pour le serveur, le Gestionnaire d’échanges BizTalk la transforme automatiquement en nom d’ordinateur local.

  • Si une définition de document est utilisée en tant que définition du document entrant dans un canal pour un port d'échanges ouvert et que les informations de destination sont fournies dans le document, la définition de document doit faire référence à une spécification correctement configurée. Pour plus d'informations sur la configuration d'une spécification de document permettant de traiter les documents pour un port d'échanges ouvert, voir Définition des propriétés du dictionnaire.

  • Les spécifications de documents sont facultatives ; toutefois, dans la plupart des cas, vous devez en sélectionner une. Si vous ne sélectionnez aucune spécification, vous pourrez constater les points suivants :
    • Les données que vous traitez ne seront pas converties au format XML du côté entrant, ni converties à partir du format XML du côté sortant.

    • Les données ne seront pas validées par rapport à une spécification afin de garantir qu’elles ne contiennent pas d’erreurs.

    • Vous ne pouvez pas transformer la structure ou le format des données en utilisant un mappage dans un canal.

    • Vous ne pouvez pas spécifier de champs de suivi global pour la définition de document.
  • Une spécification de document n'est pas nécessaire si vous souhaitez utiliser la définition de document dans une soumission directe.

  • Si vous modifiez une spécification de document, une spécification d’enveloppe ou un mappage dans l’Éditeur ou le Mappeur BizTalk, puis l’enregistrez dans le référentiel, vous devez recharger la spécification ou le mappage dans le Gestionnaire d’échanges BizTalk, de sorte que le serveur puisse reconnaître les modifications et que la base de données soit mise à jour.

  • Il est possible que votre première connexion à un référentiel WebDAV sur un serveur distant prenne un certain temps.

  • Lorsque vous enregistrez une définition de document qui fait référence à une spécification en dehors de votre domaine local, vous risquez d’obtenir un message d’erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (www.microsoft.com/france/msdn/telecharge/) et parcourez le chapitre XML du manuel Web Development jusqu’à la page WinHTTP Proxy Configuration Utility.

Voir aussi

Création de définitions de documents

Modification de définitions de documents

Définition des propriétés d'une définition de document

Description des définitions de documents


Définition des propriétés de suivi global

Dans l'onglet Suivi global, la liste Champs de spécification fournit une arborescence correspondant à la spécification que vous avez sélectionnée pour la définition de document. Vous pouvez développer cette liste pour afficher les champs de la spécification et désigner un nombre limité de champs devant être consignés dans la base de données de suivi.

Lorsque la définition de document est sélectionnée en tant que définition du document entrant pour un canal, ces champs sont suivis pour chaque instance d'un document traitée par ce canal. Ces champs sont désignés par le terme « champs de suivi global ». Lorsque vous sélectionnez une définition de document dans un canal, vous avez la possibilité de remplacer les champs de suivi global en sélectionnant d'autres champs de spécification devant faire l'objet d'un suivi pour chaque instance de document traitée par ce canal uniquement.

Cette section décrit la procédure de sélection de champs de spécification pour une définition de document.

Cette section traite des procédures suivantes :

  • Sélection de champs de spécification dans une définition de document

  • Suppression de champs de spécification dans une définition de document

Voir aussi

Suivi des champs de données d'un document

Description des définitions de documents


Sélection de champs de spécification dans une définition de document

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Suivi global.

  2. Dans la liste Champs de spécification, cliquez sur le signe plus (+) en regard de chaque enregistrement ou double-cliquez sur l'enregistrement pour développer l'affichage.

  3. Sélectionnez un champ de spécification que vous souhaitez ajouter à la liste Champs à suivre, puis suivez l'une des procédures suivantes :
    Ajout du champ en tant que | Suivez cette procédure
    Entier | Cliquez sur Entier. Vous pouvez ajouter deux champs pour les entiers.
    Réel | Cliquez sur Réel. Vous pouvez ajouter deux champs pour les nombres réels.
    Date | Cliquez sur Date. Vous pouvez ajouter deux champs pour les dates.
    Texte | Cliquez sur Texte. Vous pouvez ajouter deux champs pour le texte.
    Personnalisé | Cliquez sur Personnalisé. Vous pouvez ajouter un nombre de champs illimité pour le type Personnalisé. Les champs sont stockés sous forme de chaînes XML concaténées, avec des balises pour chaque champ.

Remarques

  • Pour pouvoir sélectionner un champ de spécification pour le suivi de données de type entier, nombre réel ou date, ce type de données doit être attribué au champ dans la spécification. Pour plus d'informations sur l'affectation d'un type de données à un champ de spécification, voir Définition des propriétés de déclaration.

  • Les champs de spécification auxquels aucun type de données n’a été attribué dans la spécification peuvent uniquement faire l’objet d’un suivi sur les données de type texte ou personnalisé.

  • Si un champ de spécification que vous souhaitez suivre présente un type de données « caractère », le suivi pour ce champ peut uniquement avoir lieu en référence à un type personnalisé.

  • Lorsque vous sélectionnez une définition de document dans un canal, vous pouvez remplacer les champs de suivi global de ce canal en sélectionnant d'autres champs de spécification devant faire l'objet d'un suivi. Pour plus d'informations, voir Sélection des champs de spécification dans un canal.

Voir aussi

Création de définitions de documents

Modification de définitions de documents

Suppression de champs de spécification dans une définition de document

Définition des propriétés d'une définition de document

Définition des propriétés de suivi global

Suivi des champs de données d'un document

Description des définitions de documents


Suppression de champs de spécification dans une définition de document

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Suivi global.

  2. Dans la liste Champs à suivre, sélectionnez le ou les champs de spécification que vous souhaitez supprimer et cliquez sur Supprimer.

Remarque

  • Lorsque vous supprimez un champ de la liste des champs à suivre, celui-ci est supprimé uniquement de cette liste, dans cette définition de document ; il n'est pas supprimé de la spécification.

Voir aussi

Création de définitions de documents

Modification de définitions de documents

Sélection des champs de spécification dans une définition de document

Définition des propriétés d'une définition de document

Définition des propriétés de suivi global

Suivi des champs de données d'un document

Description des définitions de documents


Définition des propriétés des critères de sélection

Les critères de sélection correspondent à un jeu unique de paires nom-valeur que BizTalk Server utilise uniquement pour traiter les documents EDI. Pour les documents X12 ou EDIFACT entrants, le serveur utilise des critères de sélection pour identifier et sélectionner une définition de document d'une manière univoque, car aucun nom de définition de document ne figure dans les documents EDI individuels.

Pour les documents X12 ou EDIFACT sortants, les critères de sélection servent à créer les informations d'en-tête de groupe.

Cette section traite des procédures suivantes :

  • Ajout de critères de sélection

  • Modification de critères de sélection

  • Suppression de critères de sélection

Voir aussi

Description des définitions de documents

Description des critères de sélection


Ajout de critères de sélection

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Critères de sélection, puis cliquez sur Ajouter.

    La boîte de dialogue Nouveau nom et nouvelle valeur s'affiche.

  2. Dans la zone Nom, tapez un nom pour les critères de sélection.

  3. Dans la zone Valeur, tapez une valeur pour les critères de sélection et cliquez sur OK.

Important

  • Afin que BizTalk Server 2002 fasse correspondre les valeurs des critères de sélection aux éléments d'en-tête correspondants des échanges entrants, et pour qu'il puisse insérer les valeurs dans les éléments d'en-tête corrects des échanges sortants, vous devez taper les noms des critères de sélection tels qu'ils sont indiqués dans les tableaux suivants.

    Éléments d’en-tête X12
    Nom | Condition | Élément GS
    identificateur_fonctionnel | Obligatoire | GS01
    code_expéditeur_application | Obligatoire | GS02
    code_destinataire_application | Obligatoire | GS03
    version_standards | Obligatoire | GS08

    Éléments d’en-tête EDIFACT
    Nom | Condition | Élément UNH | Élément UNG
    identificateur_fonctionnel | Obligatoire | S009, 0065 | 0038
    code_expéditeur_application | Facultatif | Non utilisé | S006, 0040
    code_destinataire_application | Facultatif | Non utilisé | S007, 0044
    type_version_standards | Obligatoire | S009, 0052 | S008, 0052
    valeur_version_standards | Obligatoire | S009, 0054 | S008, 0054

  • Pour un échange EDIFACT sortant, un message header (UNH) est toujours créé. Si vous spécifiez une application_sender_code et une application_receiver_code, un group header (UNG) est également créé.

  • Le jeu de paires nom-valeur que vous utilisez comme critères de sélection pour chaque définition de document doit être unique pour toutes les définitions de documents.

Voir aussi

Création de définitions de documents

Modification de définitions de documents

Modification de critères de sélection

Suppression de critères de sélection

Définition des propriétés d'une définition de document

Définition des propriétés des critères de sélection

Description des définitions de documents

Description des critères de sélection


Modification de critères de sélection

  1. Dans la boîte de dialogue Nouvelle définition de document ou Propriétés de la définition de document, cliquez sur l'onglet Critères de sélection.

  2. Dans la liste Critères de sélection, cliquez sur les critères de sélection que vous souhaitez modifier et cliquez sur Modifier.

    La boîte de dialogue Propriétés de nom et de valeur s'affiche.

  3. Dans la zone Nom, tapez un nom pour les critères de sélection.

  4. Dans la zone Valeur, tapez une valeur pour les critères de sélection et cliquez sur OK.

Important

  • Afin que BizTalk Server 2002 fasse correspondre les valeurs des critères de sélection aux éléments d'en-tête correspondants des échanges entrants, et pour qu'il puisse insérer les valeurs dans les éléments d'en-tête corrects des échanges sortants, vous devez taper les noms des critères de sélection tels qu'ils sont indiqués dans les tableaux suivants.

    Éléments d’en-tête X12
    Nom | Condition | Élément GS
    identificateur_fonctionnel | Obligatoire | GS01
    code_expéditeur_application | Obligatoire | GS02
    code_destinataire_application | Obligatoire | GS03
    version_standards | Obligatoire | GS08

    Éléments d’en-tête EDIFACT
    Nom | Condition | Élément UNH | Élément UNG
    identificateur_fonctionnel | Obligatoire | S009, 0065 | 0038
    code_expéditeur_application | Facultatif | Non utilisé | S006, 0040
    code_destinataire_application | Facultatif | Non utilisé | S007, 0044
    type_version_standards | Obligatoire | S009, 0052 | S008, 0052
    valeur_version_standards | Obligatoire | S009, 0054 | S008, 0054

  • Pour un échange EDIFACT sortant, un message header (UNH) est toujours créé. Si vous spécifiez une application_sender_code et une application_receiver_code, un group header (UNG) est également créé.

  • Le jeu de paires nom-valeur que vous utilisez comme critères de sélection pour chaque définition de document doit être unique pour toutes les définitions de documents.

Voir aussi

Ajout de critères de sélection

Suppression de critères de sélection

Définition des propriétés des critères de sélection

Description des définitions de documents

Description des critères de sélection


Suppression de critères de sélection

  1. Dans la boîte de dialogue Propriétés de la définition de document, cliquez sur l'onglet Critères de sélection.

  2. Dans la liste Critères de sélection, cliquez sur le critère que vous souhaitez supprimer et cliquez sur Supprimer.

Voir aussi

Ajout de critères de sélection

Modification de critères de sélection

Définition des propriétés des critères de sélection

Description des définitions de documents

Description des critères de sélection


Création et gestion d'enveloppes

Cette section fournit des informations spécifiques aux tâches relatives à la création et la gestion des enveloppes. Nous vous recommandons vivement de consulter les informations de la rubrique Description des enveloppes pour bien comprendre le concept d'enveloppes.

Cette section traite des procédures suivantes :

  • Création d'enveloppes

  • Recherche d'enveloppes

  • Modification d'enveloppes

  • Suppression d'enveloppes

  • Sélection d'une spécification d'enveloppe


Création d'enveloppes

  1. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et cliquez sur Enveloppe.

    La boîte de dialogue Nouvelle enveloppe s'affiche.

  2. Dans la zone Nom d'enveloppe, tapez un nom unique pour l'enveloppe.

  3. Dans la liste Format d'enveloppe, choisissez l'un des formats d'enveloppe suivants :
    • CUSTOM XML

      Pour permettre à Microsoft BizTalk Server 2002 de traiter les échanges entrants au format Custom XML, vous devez créer une enveloppe au format Custom XML ainsi qu'une référence de spécification. Toutefois, lorsque vous envoyez des échanges Custom XML, il n'est pas nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis. BizTalk Server 2002 peut localiser l'enveloppe appropriée sans disposer d'une référence de nom.

    • X12

      Il n'est pas nécessaire de créer une enveloppe au format X12 pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format X12 et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

    • EDIFACT

      Il n'est pas nécessaire de créer une enveloppe au format EDIFACT pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format EDIFACT et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

    • FLATFILE

      Pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format FLATFILE (table bidirectionnelle), vous devez créer une enveloppe avec ce même format. Lorsque vous envoyez des documents FLATFILE entrants, vous devez spécifier le nom de l'enveloppe dans les paramètres d'appel soumis. Pour plus d'informations, voir Submitting.

    • CUSTOM

      Pour permettre à BizTalk Server 2002 de traiter les échanges entrants dont le format est personnalisé, format non directement pris en charge par BizTalk Server, vous devez créer un composant parseur personnalisé. Vous devez créer une enveloppe uniquement si le parseur personnalisé en requiert une. Pour plus d'informations, voir Parsers.

      Pour permettre à BizTalk Server de traiter les échanges sortants dont le format est personnalisé, vous devez créer une enveloppe au format personnalisé et sélectionner l'enveloppe dans un port d'échanges. Vous devez également créer et enregistrer un composant sérialiseur personnalisé. Pour plus d'informations, voir Serializers. Vous pouvez configurer le sérialiseur personnalisé dans le canal accessible sur la page Configuration avancée de l'Assistant Canal. Pour plus d'informations, voir Définition des propriétés de configuration avancées.

    • RELIABLE

      Il n'est pas nécessaire de créer une enveloppe au format Reliable pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format Reliable et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

      Le format Reliable permet de traiter les enveloppes dont le format est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : www.microsoft.com/france/biztalk/.

      Si vous choisissez le format Reliable, vous devez également configurer l'adresse de type URL de réponse d'échange de type Reliable dans la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

  4. Si vous choisissez le format Custom XML, FLATFILE ou CUSTOM, vous pouvez sélectionner une spécification pour l'enveloppe. Pour plus d'informations, voir Sélection d'une spécification d'enveloppe.

Remarques

  • Pour permettre à BizTalk Server 2002 de traiter les échanges sortants dans n'importe quel format, vous devez créer une enveloppe.

  • Si vous choisissez le format Custom XML et que vous ne sélectionniez pas de spécification, le format d'enveloppe correspondra par défaut au format Reliable.

  • Lors du traitement d'enveloppes compatibles avec BizTalk Framework 2.0, BizTalk Server 2002 doit être considéré comme étant le point final par rapport au délai d'expiration. Lorsque les documents compatibles avec BizTalk Framework 2.0 sont envoyés à BizTalk Server soit d'une application, soit d'un partenaire commercial, les champs ci-dessous sont remplacés s'ils sont présents et créés s'ils n'existent pas encore :
    • Dans la sous-section relative aux propriétés :

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Dans la sous-section relative aux informations de réception :

      <sendTo>

      <adresse>

      <sendReceiptBy>

  • Si vous modifiez le format d'enveloppe et que vous avez sélectionné une spécification, vous devez éventuellement sélectionner aussi une spécification différente.

  • Lorsque vous enregistrez une enveloppe qui fait référence à une spécification en dehors de votre domaine local, vous risquez d'obtenir un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (www.microsoft.com/france/msdn/telecharge/) et parcourez le chapitre XML du manuel Web Development jusqu'à la page WinHTTP Proxy Configuration Utility.

Voir aussi

Suppression d'enveloppes

Modification d'enveloppes

Recherche d'enveloppes

Description des enveloppes


Recherche d'enveloppes

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Enveloppes.

  2. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher toutes les enveloppes, désactivez toutes les cases à cocher en regard des critères de sélection et cliquez sur Rechercher.

    • Pour rechercher une enveloppe spécifique, dans la case Nom d'enveloppe de la zone Rechercher les enveloppes, tapez le nom de l'enveloppe recherchée, puis cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher des enveloppes avec un format spécifique, dans la liste Format, choisissez un format et cliquez sur Rechercher.

Remarques

  • Vous pouvez définir plusieurs critères de recherche avant de cliquer sur Rechercher.

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans les critères de recherche :
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Suppression d'enveloppes

Modification d'enveloppes

Description des enveloppes


Modification d'enveloppes

  1. Dans le Gestionnaire d'échanges BizTalk, cliquez sur l'enveloppe à modifier dans la liste Nom d'enveloppe.

    Pour plus d'informations sur la recherche d'enveloppes, voir Recherche d'enveloppes.

  2. Dans le menu Fichier, cliquez sur Edition.

    La boîte de dialogue Propriétés d'enveloppe s'affiche.

  3. Dans la zone Nom d'enveloppe, tapez un nom unique pour l'enveloppe.

  4. Dans la liste Format d'enveloppe, choisissez l'un des formats d'enveloppe suivants :
    • CUSTOM XML

      Pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format Custom XML, vous devez créer une enveloppe au format Custom XML ainsi qu'une référence de spécification. Toutefois, lorsque vous envoyez des échanges Custom XML, il n'est pas nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis. BizTalk Server peut localiser l'enveloppe appropriée sans disposer d'une référence de nom.

    • X12

      Il n'est pas nécessaire de créer une enveloppe au format X12 pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format X12 et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

    • EDIFACT

      Il n'est pas nécessaire de créer une enveloppe au format EDIFACT pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format EDIFACT et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

    • FLATFILE

      Pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format FLATFILE (table bidirectionnelle), vous devez créer une enveloppe avec ce même format. Lorsque vous envoyez des documents FLATFILE entrants, vous devez spécifier le nom de l'enveloppe dans les paramètres d'appel soumis. Pour plus d'informations, voir Submitting.

    • CUSTOM

      Pour permettre à BizTalk Server 2002 de traiter les échanges entrants dont le format est personnalisé, un format non directement pris en charge par BizTalk Server, il se peut que vous deviez créer une enveloppe. Cependant, vous devez créer un composant parseur personnalisé pour traiter ces échanges, lequel peut avoir besoin d'une enveloppe. Pour plus d'informations, voir Parsers.

      Pour permettre à BizTalk Server de traiter les échanges sortants dont le format est personnalisé, vous devez créer une enveloppe au format personnalisé et sélectionner l'enveloppe dans un port d'échanges. Vous devez également créer et enregistrer un composant sérialiseur personnalisé. Pour plus d'informations, voir Serializers. Vous pouvez configurer le sérialiseur personnalisé dan le canal accessible sur la page Configuration avancée de l'Assistant Canal. Pour plus d'informations, voir Définition des propriétés de configuration avancées.

    • RELIABLE

      Il n'est pas nécessaire de créer une enveloppe au format Reliable pour permettre à BizTalk Server 2002 de traiter les échanges entrants au format Reliable et il n'est pas non plus nécessaire de spécifier le nom de l'enveloppe dans les paramètres d'appel soumis.

      Le format Reliable permet de traiter les enveloppes dont le format est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : www.microsoft.com/france/biztalk/.

      Si vous choisissez le format Reliable, vous devez également configurer l'adresse de type URL de réponse d'échange de type Reliable dans la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

  5. Si vous choisissez le format Custom XML, FLATFILE ou CUSTOM, vous pouvez sélectionner une spécification pour l'enveloppe. Pour plus d'informations, voir Sélection d'une spécification d'enveloppe.

Important

  • Si vous créez une enveloppe au format Reliable et que vous sélectionnez cette enveloppe dans un port d'échanges, vous devez également configurer l'adresse URL de réponse d'échange de type Reliable dans la boîte de dialogue Propriétés du groupe de serveurs BizTalk Server. Pour plus d'informations, voir Configuration des propriétés générales d'un groupe de serveurs.

Remarques

  • Pour permettre à BizTalk Server 2002 de traiter les échanges sortants dans n'importe quel format, vous devez créer une enveloppe.

  • Si vous choisissez le format Custom XML et que vous ne sélectionniez pas de spécification, le format d'enveloppe correspondra par défaut au format Reliable.

  • Lors du traitement d'enveloppes compatibles avec BizTalk Framework 2.0, BizTalk Server 2002 doit être considéré comme étant le point final par rapport au délai d'expiration. Lorsque les documents compatibles avec BizTalk Framework 2.0 sont envoyés à BizTalk Server soit d'une application, soit d'un partenaire commercial, les champs ci-dessous sont remplacés s'ils sont présents et créés s'ils n'existent pas encore :
    • Dans la sous-section relative aux propriétés :

      <prop:identity>

      <prop:sentAt>

      <prop:expiresAt>

    • Dans la sous-section relative aux informations de réception :

      <sendTo>

      <adresse>

      <sendReceiptBy>

  • Si vous modifiez le format d'enveloppe et que vous avez sélectionné une spécification, vous devez éventuellement sélectionner aussi une spécification différente.

  • Lorsque vous enregistrez une enveloppe qui fait référence à une spécification en dehors de votre domaine local, vous risquez d'obtenir un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (www.microsoft.com/france/msdn/telecharge/) et parcourez le chapitre XML du manuel Web Development jusqu'à la page WinHTTP Proxy Configuration Utility.

Voir aussi

Création d'enveloppes

Suppression d'enveloppes

Recherche d'enveloppes

Description des enveloppes


Suppression d'enveloppes

  1. Dans le Gestionnaire d'échanges BizTalk, cliquez sur l'enveloppe à supprimer dans la liste Nom d'enveloppe.

    Pour plus d'informations sur la recherche d'enveloppes, voir Recherche d'enveloppes.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarque

  • Lorsqu'une enveloppe est utilisée dans un port d'échanges, vous ne pouvez pas la supprimer. Vous devez tout d'abord supprimer tous les ports d'échanges qui utilisent l'enveloppe.

Voir aussi

Création d'enveloppes

Modification d'enveloppes

Recherche d'enveloppes

Description des enveloppes


Sélection d'une spécification d'enveloppe

  1. Dans la boîte de dialogue Nouvelle enveloppe ou Propriétés d'enveloppe, activez la case à cocher Spécification d'enveloppe et cliquez sur Parcourir.

    La boîte de dialogue Sélectionnez une spécification d'enveloppe dans le référentiel WebDAV s'affiche.

  2. Dans la zone Serveur, procédez de l'une des façons suivantes pour changer de serveur.
    • Sélectionnez un serveur dans la liste.

    • Tapez le nom d'un serveur et appuyez sur ENTRÉE.
  3. Double-cliquez sur le dossier qui contient la spécification que vous voulez ouvrir, cliquez sur la spécification, puis cliquez sur Ouvrir.

Important

  • Lorsque vous ouvrez une boîte de dialogue du référentiel WebDAV pour la première fois, le programme sélectionne ce dernier sur le serveur local, même si le Gestionnaire d'échanges BizTalk est connecté à une base de données située sur un serveur distant. Si vous accédez à un référentiel WebDAV d'un serveur distant, celui-ci devient le serveur par défaut jusqu'à ce que vous sélectionniez un nouveau référentiel WebDAV. Le serveur par défaut de toutes les boîtes de dialogue Référentiel WebDAV est le dernier serveur avec lequel une connexion a été établie.

Remarques

  • Si vous sélectionnez l'adresse http://localhost pour le serveur, le Gestionnaire d'échanges BizTalk la transforme automatiquement en nom d'ordinateur local.

  • Si vous choisissez le format Custom XML, vous pouvez sélectionner une spécification pour l'enveloppe. Si vous ne sélectionnez pas de spécification, le format par défaut de l'enveloppe est le format Reliable, qui est compatible avec BizTalk Framework 2.0. Pour plus d'informations sur BizTalk Framework 2.0, accédez au site Web de Microsoft BizTalk à l'adresse suivante : www.microsoft.com/france/biztalk/.

  • Si vous choisissez le format FLATFILE, vous pouvez sélectionner une spécification pour l'enveloppe. Vous devez sélectionner une spécification si l'enveloppe est utilisée pour les échanges entrants ouverts. Il n'est pas nécessaire de sélectionner une spécification si l'enveloppe est utilisée pour la création d'échanges sortants.

  • Si vous modifiez une spécification de document, une spécification d'enveloppe ou un mappage dans l'Éditeur ou le Mappeur BizTalk, puis l'enregistrez dans le référentiel, vous devez recharger la spécification ou le mappage dans le Gestionnaire d'échanges BizTalk, de sorte que le serveur puisse reconnaître les modifications et que la base de données soit mise à jour.

  • Si vous choisissez un format personnalisé, vous pouvez sélectionner une spécification pour l'enveloppe. Le parseur ou le sérialiseur personnalisé que vous créez détermine la sélection ou non d'une spécification

    Pour utiliser le format personnalisé, vous devez :

    • Créer un composant parseur personnalisé pour les échanges entrants ouverts au format personnalisé. Pour plus d'informations, voir Parsers.

    • Créer et configurer un composant sérialiseur personnalisé pour créer des échanges sortants dont le format est personnalisé. Pour plus d'informations, voir Serializers.

    • Configurer le composant sérialiseur personnalisé en utilisant les propriétés du port d'échanges dans l'Assistant Canal. Pour plus d'informations, voir Remplacement des valeurs par défaut d'un port d'échanges.
  • Lorsque vous enregistrez une enveloppe qui fait référence à une spécification en dehors de votre domaine local, vous risquez d'obtenir un message d'erreur. S'il se produit une erreur, téléchargez et configurez l'utilitaire proxy WinHTTP. Pour télécharger cet utilitaire, accédez au site Web Microsoft MSDN (www.microsoft.com/france/msdn/telecharge/) et parcourez le chapitre XML du manuel Web Development jusqu'à la page WinHTTP Proxy Configuration Utility.

Voir aussi

Création d'enveloppes

Modification d'enveloppes

Recherche d'enveloppes

Description des enveloppes


Utilisation de listes de distribution

Cette section fournit des informations spécifiques aux tâches relatives à l'utilisation des listes de distribution. Nous vous recommandons vivement de consulter la rubrique Description des listes de distribution pour comprendre pleinement le concept des listes de distribution.

Cette section traite des procédures suivantes :

  • Création de listes de distribution

  • Recherche de listes de distribution

  • Modification de listes de distribution

  • Suppression de listes de distribution


Création de listes de distribution

  1. Dans le Gestionnaire d'échanges BizTalk, dans le menu Fichier, pointez sur Nouveau et cliquez sur Liste de distribution.

    La boîte de dialogue Nouvelle liste de distribution apparaît.

  2. Dans la zone Nom de la liste de distribution, tapez un nom unique pour la liste de distribution.

  3. Dans la liste Ports d'échanges disponibles, sélectionnez les ports d'échanges que vous souhaitez inclure et cliquez sur Ajouter.

    Les ports d'échanges sélectionnés sont ajoutés à la liste Ports d'échanges sélectionnés.

  4. Dans la liste Ports d'échanges sélectionnés, sélectionnez les ports d'échanges que vous ne voulez pas inclure et cliquez sur Supprimer.

  5. Après avoir défini toutes les propriétés requises, cliquez sur OK pour fermer la boîte de dialogue Nouvelle liste de distribution.

Remarques

  • Lorsque vous supprimez un port d'échanges d'une liste de distribution, celui-ci est supprimé de cette liste de distribution uniquement ; il n'est pas supprimé de la base de données.

  • Une liste de distribution doit contenir au moins un port d'échanges.

  • Les ports d'échanges ouverts ne peuvent pas être ajoutés à une liste de distribution.

  • Pour pouvoir fonctionner, une liste de distribution nécessite au moins un canal. Pour plus d'informations sur les canaux, voir Création et gestion de canaux.

Voir aussi

Suppression de listes de distribution

Modification de listes de distribution

Recherche de listes de distribution

Description des listes de distribution


Recherche de listes de distribution

  1. Dans le Gestionnaire d'échanges BizTalk, dans la zone Rechercher d'autres éléments, cliquez sur Listes de distribution.

  2. Effectuez une ou plusieurs des actions suivantes :
    • Pour rechercher toutes les listes de distribution, effacez tous les critères de recherche et cliquez sur Rechercher.

    • Pour rechercher une liste de distribution portant un nom spécifique, dans la zone Rechercher les listes de distribution, dans Nom de la liste de distribution, tapez le nom de la liste de distribution que vous souhaitez trouver et cliquez sur Rechercher. Si vous entrez un nom incomplet, la recherche renverra tous les noms possibles correspondant à votre entrée.

    • Pour rechercher des listes de distribution contenant un port d'échanges spécifique, dans la liste Contenant le port d'échanges, tapez le nom du port d'échanges en question, puis cliquez sur Rechercher.

Remarques

  • Pour effacer les critères et les résultats de la recherche, cliquez sur Effacer.

  • Si vous devez rechercher un grand nombre d'objets, le renvoi de tous les objets peut prendre plusieurs minutes. Vous pouvez limiter les objets renvoyés à la suite d'une recherche en définissant des critères de sélection.

  • Une recherche renvoie par défaut 500 objets, mais vous pouvez modifier ce nombre. Pour plus d'informations, voir Définition des options de connexion du serveur.

  • Vous pouvez utiliser les caractères génériques suivants dans les critères de recherche :
    Caractère générique | Description | Exemple
    % Toute chaîne de zéro caractère ou plus L'entrée '%ouvert%' renvoie tous les noms contenant le terme « ouvert ».
    _ (soulignement) | N'importe quel caractère | L'entrée « _ean » renvoie tous les noms de quatre lettres qui se terminent par « ean » (Dean, Sean, etc.).
    [ ] Tout caractère de l'intervalle ([a-f]) ou de l'ensemble spécifié ([abcdef]) L'entrée « [C-P]arsen » renvoie les noms se terminant par « arsen » et commençant par un caractère compris entre C et P (Carsen, Larsen, Karsen, etc.).
    [^] Tout caractère non compris dans l'intervalle ([^a-f]) ou l'ensemble (^abcdef]) spécifié L'entrée « de[^s]% » renvoie tous les noms commençant par « de » et dont la lettre suivante n'est pas un « s ».

Voir aussi

Création de listes de distribution

Suppression de listes de distribution

Modification de listes de distribution

Description des listes de distribution


Modification de listes de distribution

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de la liste de distribution, cliquez sur la liste de distribution que vous souhaitez modifier.

    Pour des informations sur la recherche de listes de distribution, voir Recherche de listes de distribution.

  2. Dans le menu Fichier, cliquez sur Edition.

    La boîte de dialogue Propriétés de la liste de distribution s'affiche.

  3. Dans la zone Nom de la liste de distribution, tapez un nom unique pour la liste de distribution.

  4. Dans la liste Ports d'échanges disponibles, sélectionnez les ports d'échanges que vous souhaitez inclure et cliquez sur Ajouter pour les ajouter à la liste Ports d'échanges sélectionnés.

  5. Dans la liste Ports d'échanges sélectionnés, sélectionnez les ports d'échanges que vous ne voulez pas inclure et cliquez sur Supprimer.

  6. Après avoir défini toutes les propriétés requises, cliquez sur OK pour fermer la boîte de dialogue Propriétés de la liste de distribution.

Remarques

  • Lorsque vous supprimez un port d'échanges d'une liste de distribution, celui-ci est supprimé de cette liste de distribution uniquement ; il n'est pas supprimé de la base de données.

  • Une liste de distribution doit contenir au moins un port d'échanges.

  • Les ports d'échanges ouverts ne peuvent pas être ajoutés à une liste de distribution.

Voir aussi

Création de listes de distribution

Suppression de listes de distribution

Recherche de listes de distribution

Description des listes de distribution


Suppression de listes de distribution

  1. Dans le Gestionnaire d'échanges BizTalk, dans la liste Nom de la liste de distribution, cliquez sur la liste de distribution que vous souhaitez supprimer.

    Pour plus d'informations sur la recherche de listes de distribution, voir Recherche de listes de distribution.

  2. Dans le menu Fichier, cliquez sur Supprimer.

Remarques

  • Vous ne pouvez pas supprimer une liste de distribution tant que tous les canaux associés à cette liste n'ont pas été supprimés.

  • Pour rechercher des canaux associés à une liste de distribution, cliquez avec le bouton droit sur la liste de distribution, puis cliquez sur Rechercher des canaux.

Voir aussi

Création de listes de distribution

Recherche de listes de distribution

Description des listes de distribution


Création de spécifications et mappage de données

Microsoft® BizTalk Server 2002 offre des outils qui vous permettent de définir la structure d'un document et de mapper des données d'un format à un autre. Reposant sur la technologie XML (Extensible Markup Language) et sur d'autres standards, tels que Extensible Stylesheet Language (XSL) Transformations (XSLT), ces outils permettent la traduction des données nécessaire à un serveur d'intégration d'applications.

L'Éditeur BizTalk permet de créer des spécifications basées sur les standards de l'industrie et des schémas communs, ou bien de créer des spécifications uniques pour votre organisation.

Grâce au Mappeur BizTalk, vous pouvez créer un mappage entre les enregistrements et les champs de deux spécifications distinctes. Le serveur recourt au mappage pour traiter et traduire les données dans des formats partageables dans l'entreprise ou avec les partenaires.

Cette section traite des rubriques suivantes :

  • Utilisation de l'Éditeur BizTalk

  • Utilisation du Mappeur BizTalk

  • Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Utilisation de l'Éditeur BizTalk

L'Éditeur Microsoft® BizTalk est un outil permettant de créer, de modifier et de gérer des spécifications. L'Éditeur BizTalk utilise la syntaxe XDR (XML-Data Reduced), qui fournit un vocabulaire commun permettant de gérer les chevauchements entre les schémas syntaxiques, de bases de données et conceptuels.

L'Éditeur BizTalk crée des spécifications en interprétant les propriétés des enregistrements et des champs contenus dans un fichier. Les spécifications représentent les données structurées au format XML (Extensible Markup Language), quel que soit leur format d'origine. Par ailleurs, les spécifications créées ou modifiées dans l'Éditeur BizTalk fournissent des descriptions de données communes que le Mappeur BizTalk peut utiliser pour convertir les données dans d'autres formats. Les spécifications permettent ainsi d'assurer la portabilité des données entre différents processus professionnels. Une spécification créée à l'aide de l'Éditeur BizTalk peut reposer sur l'un des formats suivants :

  • XML bien formé

  • Modèles de document compatibles XDR

  • Schémas XDR

  • DTD (Document Type Definition)

  • Jeux d'enregistrements Microsoft ActiveX® Data Objects (ADO) enregistrés au format XML

  • EDI (Electronic Data Interchange) (ANSI X12 et EDIFACT)

  • Fichiers plats, notamment les fichiers délimités et positionnels (par exemple, les IDOC SAP) ou les fichiers plats à la fois délimités et positionnels

  • Formats de documents structurés

L'Éditeur BizTalk vous permet d'ouvrir une spécification vide ne contenant aucune structure ou d'importer un schéma ou une spécification existante. Par exemple, vous pouvez importer une DTD, à savoir un fichier structuré définissant des éléments et attributs ainsi que les contraintes relatives à l'ordre, la fréquence et le contenu de ces éléments et attributs. Les spécifications standard, telles que XML, X12 ou EDIFACT, peuvent également être utilisées pour la création de nouvelles spécifications.

Lors de l'importation d'une instance de document, l'Éditeur BizTalk convertit la structure du document et génère une spécification qui est une représentation XDR de ce document. Vous pouvez modifier tous les enregistrements et champs nécessaires qui apparaissent dans l'arborescence de spécification de l'Éditeur BizTalk, puis enregistrer la structure en tant que spécification. Vous pouvez importer les types de fichiers suivants :

  • Schémas XDR

  • XML bien formé

  • DTD

Chaque spécification décrit la structure du fichier à l'aide d'un ensemble de balises bien définies. L'Éditeur BizTalk fournit également différents modèles pouvant servir de points de départ pour la création de spécifications relatives à des documents communs, tels que des commandes d'achat, des factures ou des bons d'expédition.

Lorsque BizTalk Server 2002 traite des documents, il utilise un mappage, que vous créez à l'aide du Mappeur BizTalk, pour traduire les données entrantes et sortantes depuis un format de spécification vers un autre.

Cette section traite des rubriques suivantes :

  • Pour une description complète de l'Éditeur BizTalk, voir À propos de l'Éditeur BizTalk.

  • Pour un aide-mémoire expliquant les raisons pour lesquelles vous devez effectuer des tâches spécifiques, voir Pourquoi utiliser l'Éditeur BizTalk.

  • Pour des informations détaillées sur les procédures à effectuer, voir Comment utiliser l'Éditeur BizTalk.

  • Pour des instructions sur la résolution des problèmes, voir Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk.


À propos de l'Éditeur BizTalk

L'Éditeur BizTalk est un outil graphique qui permet de définir les spécifications utilisées pour l'initialisation des parties de Microsoft BizTalk Server 2002 qui lisent et écrivent des données en vue d'effectuer des transactions entre des organisations et entre des partenaires commerciaux. Cette section fournit des informations détaillées sur les concepts essentiels à la compréhension de l'Éditeur BizTalk.

Cette section traite des rubriques suivantes :

  • Définition des spécifications

  • Environnement de l'Éditeur BizTalk

  • Importation de fichiers

  • Exportation de fichiers

  • Enregistrements, champs et propriétés

  • Déclencheurs généraux

  • Prise en charge des espaces de noms

  • Ajout d'annotations SQL

  • Création d'instances XML et d'instances natives

  • Validation d'instances et de spécifications


Définition des spécifications

Les spécifications sont des schémas XML (Extensible Markup Language), spécifiques à BizTalk Server 2002, créés à l'aide de l'Éditeur BizTalk. Vous pouvez créer des spécifications basées sur des normes industrielles (telles que XML, EDIFACT ou X12) ou non (par exemple des fichiers plats délimités, des fichiers plats positionnels, des fichiers plats à la fois délimités et positionnels, des spécifications vides ou des fichiers existants).

Normes industrielles

Les normes industrielles fournissent des méthodes uniformes permettant l'échange électronique de données entre les entreprises. L'utilisation d'un langage commun permet aux ordinateurs de communiquer au sein d'une organisation ou d'une entreprise à une autre. Les normes industrielles définissent le format et le contenu des données des transactions électroniques. Une spécification basée sur une norme industrielle est considérée comme étant un sous-ensemble de cette norme. Pour créer une spécification répondant à vos besoins, vous pouvez partir d'une spécification basée sur les normes industrielles, puis supprimer les enregistrements et les champs dont vous n'avez pas besoin. En outre, vous pouvez modifier les propriétés des enregistrements et champs restants.

La norme d'échange EDI (Electronic Data Interchange) est une spécification basée sur les normes industrielles couramment utilisée. L'Éditeur BizTalk contient un sous-ensemble de spécifications de documents EDI et une base de données de listes de codes EDI associée. Ces spécifications sont générées directement à partir des données brutes obtenues auprès des éditeurs de standards X12 et EDIFACT officiels. Il est vivement recommandé de valider les instances EDI par rapport aux spécifications créées avant le lancement en production des processus qui les utilisent. Pour plus d'informations sur les standards, les spécifications EDI et leur mise à jour, accédez au site Web de Microsoft BizTalk Server à l'adresse suivante : www.microsoft.com/france/biztalk/.

Normes non industrielles

Si les spécifications sont basées sur des normes non industrielles, vous devez définir la structure du document dans l'Éditeur BizTalk. Vous pouvez utiliser l'Éditeur BizTalk pour divers types de normes non industrielles : fichiers plats positionnels, fichiers plats délimités ou fichiers plats à la fois positionnels et délimités. Pour mieux comprendre comment utiliser des fichiers plats, consultez les exemples livrés avec BizTalk Server 2002 et qui se trouvent dans le dossier Flat-FileDelimited dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\. Le fichier plat positionnel exemple se trouve dans le dossier Flat-FilePositional dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\.

Dans l'onglet Analyser, vous devez attribuer à la propriété Structure du nœud racine la valeur Délimité si votre fichier plat est à la fois délimité et positionnel. Les propriétés supplémentaires des enregistrements ont la valeur Délimité ou Positionnel, en fonction de leurs attributs.

Pour plus d'informations sur les fichiers plats, voir Utilisation de fichiers plats délimités et positionnels.

Spécifications vides

Une spécification vide ne contient que l'élément nœud racine. Si vous partez d'une spécification vide, vous devez en construire la structure complète. Renommez l'élément racine, puis modifiez les valeurs des propriétés de l'élément racine à revoir, comme les informations d'en-tête de la spécification. Vous pouvez ensuite ajouter des enregistrements et des champs en fonction des besoins de vos applications professionnelles.

Fichiers BizTalk Server 2000 existants

Les schémas de BizTalk Server 2000 sont compatibles avec BizTalk Server 2002. Mais inversement, si vous ouvrez puis enregistrez dans BizTalk Server 2002 une spécification que vous avez créée dans BizTalk Server 2000, son format est modifié et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Cette section traite des rubriques suivantes :

  • Structure des spécifications

  • Prise en charge des normes

  • Liste récapitulative des documents EDI inclus

  • Utilisation de fichiers plats délimités et positionnels

  • Caractères de noms XML non valides

  • Plages de caractères non valides

Voir aussi

Création d'une spécification basée sur un fichier plat

Création d'une spécification basée sur un modèle vide

Création d'une spécification basée sur une spécification existante

Création d'une spécification basée sur une norme

Enregistrements, champs et propriétés

Utilisation de fichiers plats délimités et positionnels


Structure des spécifications

Les spécifications créées à l'aide de l'Éditeur BizTalk sont des instances XML bien formées. Les structures des spécifications varient en fonction du type de fichier choisi en guise de point de départ pour l'élaboration de votre spécification. Indépendamment du type, chaque spécification contient une même structure de base. Par exemple, toutes les spécifications commencent par la balise <?xml version=""?> et se poursuivent avec des informations d'en-tête comme le nom du fichier et des données d'espace de noms. Le reste de la structure s'appuie sur les enregistrements et les champs contenus dans la spécification, ainsi que sur les attributs qui leur sont associés. Vous pouvez afficher le code sous-jacent d'une spécification en l'ouvrant dans Microsoft Internet Explorer 5 ou version ultérieure.

L'Éditeur BizTalk permet de créer un schéma XDR (XML-Data Reduced) avec des annotations spécifiques BizTalk supplémentaires. Pour supprimer les annotations, utilisez l'option Exporter le schéma XDR du menu Outils. Pour plus d'informations, voir Exportation de schémas XDR.

Vous pouvez créer un schéma XSD (Extensible (XML) Structure Definitions) à partir d'un schéma XDR en utilisant l'option Exporter le schéma XSD du menu Outils. Pour plus d'informations, voir Exportation de schémas XSD.

Voir aussi

Création et validation de spécifications

Exportation de schémas XDR

Exportation de schémas XSD


Prise en charge des normes

Les normes EDI (Electronic Data Interchange), telles que EDIFACT et X12, définissent un grand nombre de segments et d'éléments possibles qui constituent la structure de fichier des documents professionnels. À l'aide de l'Éditeur BizTalk, vous pouvez élaborer votre spécification à partir de ces structures, puis supprimer les segments et les éléments dont vous n'avez pas besoin. La structure finale est un sous-ensemble de la norme que vous et vos partenaires commerciaux, ou que les membres de votre organisation, convenez d'utiliser pour l'échange des données.

Si vous créez ou déplacez des nœuds dans un document EDIFACT ou X12, nous vous recommandons de définir la norme du document à l'aide de la valeur Personnalisé. Vous devez également définir la propriété Type de délimiteur afin que la structure modifiée soit compatible avec le reste du document. Sachez que si vous choisissez d'abandonner la norme de document Personnalisé pour rétablir la norme EDIFACT ou X12, tous les paramètres Type de délimiteur seront perdus. Pour plus d'informations sur la définition de la propriété Personnalisé, voir Définition des propriétés de référence. Pour plus d'informations sur la définition de la propriété Type de délimiteur, voir Définition des propriétés d'analyse.

L'Éditeur BizTalk prend également en charge les règles syntaxiques X12, qui sont des conditions relationnelles existant entre deux ou plusieurs éléments de données d'un enregistrement. Si la spécification contient des règles syntaxiques, celles-ci sont appliquées pendant le processus d'exécution du serveur lors de la validation de la spécification.

Il existe cinq types de règles :

  • All

    Si TXI08 existe, le nœud suivant doit exister :

    • TXI03
  • Grouped

    Si l'un des nœuds suivants existe, ils doivent tous exister :

    • TXI04

    • TXI05
  • Any

    Au moins un des nœuds suivants doit exister :

    • TXI02

    • TXI03

    • TXI06
  • One

    Au plus un des nœuds suivants doit exister :

    • TXI02

    • TXI03

    • TXI06
  • Any (conditional)

    Si PO413 existe, alors au moins un des nœuds suivants doit exister :

    • PO410

    • PO411

    • PO412

Voir aussi

Création et validation de spécifications

Modification des notes et affichage des règles syntaxiques

Définition des propriétés de référence

Liste récapitulative des documents EDI inclus


Liste récapitulative des documents EDI inclus

L'Éditeur BizTalk prend en charge tous les documents de type EDI. Le tableau suivant indique les spécifications standard, versions et normes de documents pour les documents EDI disponibles lorsque vous créez une nouvelle spécification basée sur une norme. Pour plus d'informations, voir Création d'une spécification basée sur un standard.

Standard Version Normes de documents
X12
  • 2040

  • 3010

  • 3060

  • 4010
  • 810

  • 832

  • 846

  • 850

  • 852 (disponible dans toutes les versions sauf 2040)

  • 855

  • 856

  • 861

  • 864

  • 867

  • 940 (disponible uniquement avec les versions 3060 et 4010)

  • 944 (disponible uniquement avec les versions 3060 et 4010)

  • 997
EDIFACT
  • D93A

  • D95A

  • D95B

  • D97B

  • D98A

  • D98B
  • APERAK (disponible dans toutes les versions sauf D93A)

  • CONTRL (disponible uniquement avec les versions D98A et D98B)

  • DESADV

  • INVOIC

  • INVRPT

  • ORDERS

  • ORDRSP

  • PARTIN

  • PAYEXT

  • PRICAT

  • PRODAT (disponible uniquement avec les versions D97B, D98A et D98B)

  • RECADV (disponible uniquement avec les versions D97B, D98A et D98B)

  • SLSRPT
XML
  • Non applicable
  • Enveloppe BTF1

  • AccuséRéceptionStandard

  • AvisExpéditionAvancéeCommun

  • AvisInventaireCommun

  • FactureCommune

  • ProfilPartenaireCommun

  • OACommun

  • RécépisséOACommun

  • CataloguePrixCommun

  • AvisExpéditionCommun

  • BordereauExpéditionCommun

  • Enveloppe SOAP simple

Voir aussi

Création d'une spécification basée sur un standard


Utilisation de fichiers plats délimités et positionnels

L'Éditeur BizTalk est conçu pour permettre de créer aisément des spécifications avec une structure de fichiers plats positionnels, de fichiers plats délimités et de fichiers à la fois délimités et positionnels. Les sections suivantes fournissent des détails spécifiques à chacune de ces structures de fichiers.

Fichiers plats positionnels

Un fichier plat positionnel se compose de champs de même longueur fixe et d'enregistrements possédant un terminateur commun de fin d'enregistrement. La structure d'un fichier entrant doit être représentée dans les enregistrements et les champs de la spécification source de manière à conserver la nature positionnelle du fichier entrant. Par conséquent, avant de définir la structure de document d'une spécification source, il convient d'établir un schéma des enregistrements et des champs nécessaires.

Le tableau suivant présente un exemple de format fixe.

Nom | Adresse | Ville | Téléphone
Xxxxxxxxxx | Aaaaaaaaaa | Ccccccccccccccc | xxx-xxx-xxxx
Yyyyyyyyyy | Bbbbbbbbbb | Ddddddddddddd | xxx-xxx-xxxx

Les champs Nom, Adresse, Ville et Téléphone possèdent une longueur fixe respective de 10, 10, 15 et 12 caractères. Le terminateur de fin d'enregistrement est un caractère de retour chariot et/ou de saut de ligne.

Vous pouvez utiliser l'Éditeur BizTalk pour créer des enregistrements et des champs consécutifs. Vous pouvez créer plusieurs types d'enregistrements et affecter différents délimiteurs aux enregistrements parents. Pour les structures qui contiennent plusieurs types d'enregistrements, la spécification des types et terminateurs d'enregistrement doit également être spécifiée dans l'ordre de leur apparition dans le document. La position de départ, la longueur et le type de données des champs doivent être spécifiés.

Si une spécification est positionnelle et que vous modifiez la structure en délimitée, la spécification compilée inclut les positions d'origine de départ et de fin spécifiées dans l'onglet Référence. Toutefois, lorsque BizTalk Server 2002 analyse une spécification, le parseur ignore cette information et traite la spécification comme un fichier délimité.

Un enregistrement positionnel doit toujours être un enregistrement enfant ou délimité. Le caractère délimiteur spécifié pour l'enregistrement délimité parent ne doit pas apparaître dans les données de l'enregistrement positionnel enfant. Il n'y a aucun moyen d'éviter le caractère délimiteur de l'enregistrement délimité parent dans les données du champ positionnel enfant. Pour plus d'informations sur les délimiteurs et caractères d'échappement, voir Définition des propriétés d'analyse.

Pour mieux comprendre comment utiliser des fichiers plats positionnels, consultez le fichier exemple qui se trouve dans le dossier Flat-FilePositional dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\.

Remarque

  • Dans l'onglet Analyser, vous devez définir la propriété Structure du nœud racine à la valeur Délimité si votre fichier plat est à la fois délimité et positionnel. Les propriétés supplémentaires des enregistrements sont définies sur Délimité ou Positionnel, en fonction de leurs attributs.

Fichiers plats délimités

Un fichier plat délimité contient un ou plusieurs enregistrements séparés par un délimiteur. L'Éditeur BizTalk ne lit pas les délimiteurs comme faisant partie des données. Cependant, si le caractère délimiteur apparaît dans les données, celles-ci peuvent être formatées de manière à distinguer le délimiteur et les données. Par exemple, le champ dans lequel un caractère délimiteur apparaît peut être placé entre guillemets afin d'indiquer que le caractère délimiteur doit être traité comme une donnée et non comme un délimiteur.

À l'aide de l'Éditeur BizTalk, vous pouvez sélectionner des champs spécifiques ainsi que les délimiteurs associés. Vous pouvez également spécifier des délimiteurs de fin d'enregistrement. Afin de permettre l'utilisation de fichiers plats délimités, l'Éditeur BizTalk prend en charge :

  • Les structures composées de plusieurs groupes d'enregistrements.

  • Divers types d'enregistrements définis par des balises de type enregistrement.

  • Les délimiteurs de fin d'enregistrement.

  • Les caractères de retour à la ligne et d'échappement, afin de distinguer les données des champs des valeurs des délimiteurs.

  • Les valeurs de début, de longueur et de type des champs.

  • Les balises et descriptions de contenu des champs.

  • La possibilité de transformer des fichiers plats en spécifications utilisables par le Mappeur BizTalk.

Pour mieux comprendre comment utiliser des fichiers plats délimités, consultez le fichier exemple qui se trouve dans le dossier Flat-FileDelimited dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\.

Remarque

  • Dans l'onglet Analyser, vous devez définir la propriété Structure du nœud racine à la valeur Délimité si votre fichier plat est à la fois délimité et positionnel. Les propriétés supplémentaires des enregistrements sont définies sur Délimité ou Positionnel, en fonction de leurs attributs.

Voir aussi

Création d'une spécification basée sur un fichier plat


Caractères de noms XML non valides

Les caractères Unicode allant de xF900 à xFFFE ne peuvent pas être utilisés dans les noms XML (Extensible Markup Language). Si vous utilisez un caractère Unicode non valide dans un nom XML, ce caractère est traduit en une entité numérique d'échappement lorsque vous l'affichez dans l'arborescence de spécification. L'entité numérique d'échappement est codée sous la forme _xHHHH_, où HHHH représente le code Unicode hexadécimal à quatre chiffres. Par exemple, le nom Ship To dans une spécification d'ordre d'achat contient un caractère d'espacement, et apparaît dans l'arborescence de spécification sous la forme Ship_x0020_To. Si vous déplacez le pointeur de la souris sur un nœud contenant un caractère Unicode codé, une info-bulle apparaît et indique le nom du nœud avec le caractère Unicode non codé. Cela se produit lorsque vous affichez une arborescence de spécification dans l'Éditeur BizTalk ou dans le Mappeur BizTalk.

Voir aussi

Création et validation de spécifications

Validation d'une instance de document


Plages de caractères incorrectes

Vous pouvez empêcher BizTalk Server 2002 de générer un caractère ou une plage de caractères donnés. Pour ce faire, dans l'Éditeur BizTalk, ouvrez une spécification en vue de l'utiliser comme spécification de destination. Ouvrez la boîte de dialogue Plages de caractères incorrectes et entrez les caractères ou les plages de caractères à exclure. Lorsque BizTalk Server essaie de traiter un caractère spécifié dans la boîte de dialogue Plages de caractères incorrectes d'une spécification de sortie, le traitement s'interrompt et un message d'erreur s'affiche.

Remarque

  • Les plages de caractères ne peuvent être bloquées que pour des documents non-XML (Extensible Markup Language).

Voir aussi

Ajout de plages de caractères incorrectes

Suppression de plages de caractères incorrectes

Modification de plages de caractères incorrectes

Utilisation de Mappeur BizTalk


Environnement de l'Éditeur BizTalk

Lorsque vous ouvrez l'Éditeur BizTalk, vous découvrez une interface graphique qui vous permet de créer et d'utiliser des spécifications très facilement.

Cette section traite des rubriques suivantes :

  • Interface utilisateur de l'Éditeur BizTalk

  • Menus de l'Éditeur BizTalk

  • Boutons de la barre d'outils de l'Éditeur BizTalk


Interface utilisateur de l'Éditeur BizTalk

L'interface utilisateur de l'Éditeur BizTalk comprend trois volets principaux. Le volet de gauche affiche l'arborescence de spécification, à savoir une représentation graphique de la spécification.Le nœud supérieur dans l'arborescence de spécification est le nœud racine. Il est représenté par une icône symbolisant un livre.

Les différents enregistrements et champs sont affichés en dessous du nœud racine dans la hiérarchie de la spécification. Les enregistrements sont représentés par une icône de document dotée de lignes vertes horizontales.

Les champs sont représentés par une icône de document dotée de lignes bleues verticales.

Nœud de champ

Pour plus d'informations sur les enregistrements et les champs, voir Enregistrements, champs et propriétés. Pour développer ou réduire un nœud de l'arborescence de spécification, cliquez sur le signe plus (+) ou sur le signe moins (-) situé à gauche du nœud.

Le volet de droite contient six onglets : Déclaration, Référence, Analyser, Espace de noms, Dictionnaire et Liste de codes. Utilisez ces onglets pour définir les valeurs de propriétés, espaces de noms, propriétés de dictionnaires et listes de codes pour les nœuds d'une spécification. Pour plus d'informations sur ces onglets, voir Spécification de propriétés pour les enregistrements et les champs.

Le volet inférieur contient deux onglets : Sortie et Avertissement. L'onglet Sortie affiche une instance de document XML (Extensible Markup Language) créée avec la fonction Créer une instance XML ou affiche un fichier plat créé avec la fonction Créer une instance native dans l'Éditeur BizTalk. Pour plus d'informations sur la création d'une instance de document XML à partir d'une spécification, voir Création d'une instance de document ou Création d'une instance native. L'onglet Avertissement indique si une tentative de validation d'une instance de document a réussi, et affiche des messages d'avertissement en cas d'échec de la validation du document. Pour plus d'informations, voir Validation d'une instance de document.

Voir aussi

Création d'une instance de document

Création d'une instance native

Spécification de propriétés pour les enregistrements et les champs

Validation d'une instance de document


Menus de l'Éditeur BizTalk

Les menus de l'Éditeur BizTalk regroupent les commandes de manière logique, afin de faciliter l'exécution d'une tâche spécifique. Par exemple, vous pouvez utiliser les commandes du menu Afficher pour développer ou réduire tous les enregistrements et champs de l'arborescence de spécification.

Les menus de l'Éditeur BizTalk sont les suivants :

  • Fichier. Utilisez ce menu pour créer, ouvrir, enregistrer ou fermer une spécification.

  • Modifier. Utilisez ce menu pour couper, copier, coller, insérer, renommer ou supprimer des enregistrements ou des champs dans une spécification.

  • Vue. Utilisez ce menu pour :
    • Sélectionner des vues dans le volet droit de l'interface utilisateur.

    • Sélectionner des vues dans le volet inférieur de l'interface utilisateur.

    • Sélectionner la taille dans laquelle afficher du texte dans l'Éditeur BizTalk.

    • Afficher la boîte de dialogue Plages de caractères incorrectes.

    • Développer ou réduire l'arborescence de la spécification.

    • Mettre en surbrillance l'avertissement suivant dans l'onglet Avertissements.
  • Outils. Utilisez ce menu pour :
    • Valider une spécification.

    • Valider une instance de document en fonction d'une spécification.

    • Créer une instance de document XML (Extensible Markup Language) ou une instance native à partir d'une spécification.

    • Importer des fichiers.

    • Exporter des schémas XDR (XML-Data Reduced) ou XSD.

    • Afficher les options de l'Éditeur BizTalk.
  • Aide. Utilisez ce menu pour obtenir des informations contextuelles, pour comprendre l'utilité de certaines tâches et enfin, pour prendre connaissance des procédures d'utilisation de l'Éditeur BizTalk.

Voir aussi

Menus du Mappeur BizTalk


Bouton de la barre d'outils de l'Éditeur BizTalk

L'Éditeur BizTalk fournit une barre d'outils destinée à compléter la barre de menus. Tous les boutons de la barre d'outils affichent des représentations graphiques des tâches qu'ils effectuent. L'ordre d'apparition de gauche à droite est le suivant :

  • Nouvelle

  • Ouvrir

  • Enregistrer

  • Extraire à partir de WebDAV

  • Stocker dans WebDAV

  • Couper le nœud de la spécification

  • Copier le nœud de la spécification

  • Coller le nœud de la spécification

  • Supprimer le nœud de la spécification

  • Nouvel enregistrement

  • Nouveau champ

  • Insérer un enregistrement

  • Insérer un champ

  • Réduire

  • Développer


Importation de fichiers

L'Éditeur BizTalk permet l'importation de fichiers. Il crée la structure de fichiers, mais vous devez cependant affecter les valeurs de propriété de tous les enregistrements et de tous les champs. Il est possible d'importer les trois types de fichiers suivants dans l'Éditeur BizTalk :

  • Instances XML bien formées

  • DTD (Document Type Definition)

  • Schémas XDR (XML-Data Reduced)

  • Fichiers Microsoft Office (en utilisant le module d'importation XML bien formé)

Vous ne pouvez cependant pas importer un fichier qui contient une référence externe à un autre fichier. Après l'importation d'une instance XML bien formée, d'une DTD, d'un schéma XDR, ou d'un fichier Microsoft Office, l'Éditeur BizTalk crée une structure basée sur le fichier importé et affiche une série d'enregistrements et de champs. Toutefois, si le fichier importé contient un élément avec du contenu, s'il est récurrent dans les données de l'instance, et n'a pas d'enfant, l'Éditeur BizTalk le crée en tant que champ plutôt qu'en tant qu'enregistrement, lorsqu'il importe la structure. Lorsque vous enregistrez le fichier dans l'Éditeur BizTalk, ce fichier devient une spécification. Cette spécification possède des informations d'en-tête appropriées ainsi qu'une structure bien définie.

L'Éditeur BizTalk est capable de déterminer l'élément qui doit être le nœud racine. Toutefois, dans certains cas, s'il ne parvient pas à déterminer l'élément racine approprié, c'est l'utilisateur qui est invité à spécifier cet élément. Si le nœud <schéma> est associé à un attribut name="a_name", l'Éditeur BizTalk utilise ce nom d'élément comme nœud racine et l'utilisateur n'est pas invité à en sélectionner même s'il existe plusieurs éléments susceptibles d'être désignés comme nœud racine ou bien, si la racine indiquée par l'attribut name est impliquée dans un cycle. Si vous voulez pouvoir sélectionner un nœud racine, vous devez ouvrir le fichier XDR et supprimer l'attribut name="a_name". Importez ensuite le fichier et vous serez alors invité par l'Éditeur BizTalk à sélectionner un élément racine.

Cette section traite des rubriques suivantes :

  • Importation d'un document XML bien formé

  • Importation de DTD

  • Importation de schémas XDR

  • Importation de fichiers Microsoft Office XP

Voir aussi

Création d'une spécification basée sur un fichier importé


Importation d'un document XML bien formé

Les documents XML (Extensible Markup Language) bien formés incluent tous les fichiers Microsoft Office que vous pouvez être amené à importer. Si vous disposez d'une instance XML bien formée qui contient un schéma XDR, vous ne pouvez pas l'importer. Par ailleurs, lorsque l'Éditeur BizTalk importe des documents XML bien formés, il ne peut pas interpréter les paramètres de type de données ou de longueur de champ. Il se peut que l'Éditeur BizTalk affiche des avertissements concernant des références cycliques après l'importation d'un fichier XML bien formé. Si cela se produit, il est recommandé de résoudre le problème à l'origine des avertissements et d'enregistrer la spécification avant de poursuivre.

Si vous importez un fichier XML bien formé contenant un espace de noms sur le nœud racine, l'espace de noms devient l'espace de noms cible et est ignoré partout ailleurs dans la spécification. Pour plus d'informations sur les espaces de noms, voir Définition des propriétés de référence.

Voir aussi

Création d'une spécification basée sur un fichier importé


Importation de DTD

Lors de l'importation de DTD (Document Type Definition), l'Éditeur BizTalk ne peut pas interpréter les paramètres de type de données ou de longueur de champ. Il existe des cas spécifiques dans lesquels les types de données sont traités de façon unique. Le tableau suivant présente la liste de certains de ces cas.

Lorsque ces types de données existent | Le fichier DTD
entité et entités | Peut être importé, mais les types de données sont supprimés.
nmtoken et nmtokens | Peut être importé, mais les types de données sont supprimés.
notation | Peut être importé, mais le type de données est importé en tant que type d'énumération.

Si la dernière ligne d'une DTD est une référence d'entité (par exemple, "%xx"), la DTD ne peut pas être importée dans l'Éditeur BizTalk. Cependant, si vous créez une nouvelle ligne à la fin de la DTD qui contient un caractère de fin de ligne, l'Éditeur BizTalk pourra importer la DTD.

Lorsqu'une DTD compte plusieurs racines, l'Éditeur BizTalk n'émettra pas nécessairement un avertissement à chaque remplacement ayant lieu pendant l'importation.

De plus, vous ne pouvez pas importer une DTD qui contient des éléments avec des commentaires. Pour importer ces DTD, vous devez modifier les fichiers concernés afin de supprimer les commentaires des éléments.

Voir aussi

Création d'une spécification basée sur un fichier importé


Importation de schémas XDR

Lorsque vous importez des schémas XDR (XML-Data Reduced), certains types de données sont gérés de façon unique par l'Éditeur BizTalk. Le tableau suivant présente certains de ces types de données.

Lorsque ces types de données existent | Le fichier de schéma XDR
entité et entités | Ne peut pas être importé.
nmtoken et nmtokens | Peut être importé, mais les types de données sont supprimés.
notation | Ne peut pas être importé.

Vous ne pouvez importer un schéma XDR si la valeur par défaut d'un attribut de type IDREFS est spécifiée dans la déclaration de l'attribut. Exemple :

<AttributeType name="Field1" d:type="idrefs" default="a1 a2"> </AttributeType><AttributeType name="Field1" d:type="idrefs" default="a1 a2"> </AttributeType>
<attribute type="Field1" required="no"></attribute> <attribute type="Field1" required="no"></attribute>

Pour résoudre ce problème, amenez la valeur par défaut à la référence d'attribut du schéma XDR avant de l'importer dans l'Éditeur BizTalk, comme illustré dans le code suivant :

<AttributeType name="Field1" d:type="idrefs"> </AttributeType><AttributeType name="Field1" d:type="idrefs"> </AttributeType>
<attribute type="Field1" required="no" default="a1 a2"></attribute> <attribute type="Field1" required="no" default="a1 a2"></attribute>

Voir aussi

Création d'une spécification basée sur un fichier importé


Importation de fichiers Microsoft Office XP

L'Éditeur BizTalk supprime l'espace de noms Microsoft Office XP ss, mais ne supprime pas les autres espaces de noms personnalisés. Cependant, les préfixes des espaces de noms personnalisés sont remplacés. Par exemple, 0:abc est remplacé par 0_abc. Si vous enregistrez une feuille de calcul Microsoft Excel (au format XML) qui contient les données suivantes :

<Workbook xmlns="urn:schemas-microsoft-com:office:spreadsheet"
 xmlns:o="urn:schemas-microsoft-com:office:office"
 xmlns:x="urn:schemas-microsoft-com:office:excel"
 xmlns:ss="urn:schemas-microsoft-com:office:spreadsheet"
 xmlns:html="http://www.w3.org/TR/REC-html40">

L'Éditeur BizTalk reconnaît que l'espace de noms cible xmlns est identique à l'espace de noms préfixé xmlns:ss. Par conséquent, au lieu d'utiliser le préfixe ss de façon redondante dans tout le schéma, l'Éditeur BizTalk supprime le préfixe ss partout où il est utilisé parce que c'est exactement le même espace de noms qui est défini en tant qu'espace de noms cible.

Voir aussi

Création d'une spécification basée sur un fichier importé


Exportation des fichiers

Vous pouvez exporter des spécifications nouvelles et existantes uniquement lorsqu'elles sont ouvertes dans l'Éditeur BizTalk. Lorsque vous exportez une spécification, les annotations spécifiques à BizTalk sont supprimées de la structure, et la structure qui en résulte est enregistrée en tant que schéma général pouvant être utilisé par d'autres applications. Vous pouvez exporter à la fois des schémas XDR (XML-Data Reduced) et XSD (Extensible (XML) Structure Definitions).

Par ailleurs, vous pouvez créer un schéma XSD à partir d'un schéma XDR à l'aide d'un script de conversion, qui est disponible si vous choisissez l'installation complète de BizTalk Server 2002.

Voir aussi

Exportation de schémas XDR

Exportation de schémas XSD


Enregistrements, champs et propriétés

L'Éditeur BizTalk présente une spécification sous la forme d'une vue arborescente d'enregistrements et de champs dans un ordre donné. Dans cette structure, vous pouvez créer des relations parent-enfant à l'aide d'enregistrements et de champs. Les enregistrements peuvent contenir d'autres enregistrements ou champs, tandis que les champs ne peuvent pas contenir d'autres champs ou enregistrements. Un enregistrement est toujours un élément, mais un champ peut être soit un élément soit un attribut.

Vous pouvez ajouter et insérer des enregistrements et des champs dans des enregistrements et vous pouvez insérer des enregistrements et des champs dans des champs. Il est impossible d'ajouter des enregistrements ou des champs dans un champ. L'illustration suivante montre comment les enregistrements et les champs sont mis en relation avec un nœud précis dans l'arborescence.

Illustration des enregistrements et des champs d'une organisation

Pour créer l'enregistrement Record1, sélectionnez SpécificationVide et cliquez sur le bouton Nouvel enregistrement. À l'identique, pour créer le champ Field1, cliquez sur Nouveau champ. Cette opération est représentée dans la section A dans l'illustration. Pour créer l'enregistrement Record2, sélectionnez Record1 et cliquez sur le bouton Nouvel enregistrement, et pour créer le champ Field1 (celui situé sous Record2) cliquez sur Nouveau champ. Cette opération est représentée dans la section B dans l'illustration. Pour créer l'enregistrement Record3, sélectionnez Record1 et cliquez sur le bouton Insérer un enregistrement, et pour créer le champ Field2, cliquez sur Insérer un champ. Cette opération est représentée dans la section C dans l'illustration.

L'arborescence de spécification, qui représente les enregistrements et les champs sous forme de nœuds, permet de visualiser, de créer, de modifier et de supprimer aisément tous les enregistrements et les champs d'une spécification. Chaque nœud de l'arborescence de spécification possède un ensemble de définitions de propriétés, représentées sur les six onglets de la fenêtre principale de l'Éditeur BizTalk : Déclaration, Référence, Analyser, Espace de noms, Dictionnaire et Liste de codes. Les données contenues dans ces onglets sont nécessaires à l'Éditeur BizTalk pour convertir le format d'origine d'un document au format XML (Extensible Markup Language). Ces informations définissent la structure du document, que celui-ci soit positionnel ou délimité, ainsi que l'ordre, la longueur et le format des données.

Cette section traite des rubriques suivantes :

  • Enregistrements et propriétés associées

  • Format d'heure pris en charge pour la norme X12

  • Prise en charge de contenus mixtes

  • Champs et propriétés associées

  • Calcul des positions des champs

  • Limites de longueur des caractères

  • Valeurs et descriptions des listes de codes

  • Caractères tampon

  • Portée des propriétés

  • Références cycliques

  • Intégration des valeurs par défaut

  • Résumé des types de données et des valeurs de types de données


Enregistrements et propriétés associées

En fonction du type de spécification en cours d'élaboration, vous serez certainement amené à ajouter et/ou supprimer des enregistrements. Après l'ajout d'enregistrements à une spécification quelconque, vous devez définir des propriétés. Lorsque vous supprimez un enregistrement, ses propriétés sont également supprimées, ainsi que tous les enregistrements et champs enfants.

Si votre spécification est basée sur la norme X12 ou EDIFACT, vous ne pouvez ajouter que les types d'enregistrements qui existent dans cette norme, mais vous pouvez supprimer un ou tous les enregistrements. Si vous créez une spécification basée sur une spécification vide, vous devez ajouter des enregistrements. Dans certains cas, par exemple lors de l'élaboration d'une nouvelle spécification basée sur une spécification existante, il se peut que vous deviez ajouter et supprimer des enregistrements.

Lorsque vous ajoutez ou insérez un enregistrement, vous pouvez commencer immédiatement la saisie pour renommer l'enregistrement. Vous pouvez modifier le nom d'un enregistrement existant ainsi que ses propriétés en sélectionnant l'enregistrement et en effectuant les modifications appropriées.

Si vous collez dans une spécification un enregistrement dont le nom est identique à celui d'un enregistrement existant, un numéro est ajouté à la fin du nom de l'enregistrement.

Pour plus d'informations sur la création d'une nouvelle instance d'un enregistrement existant, voir Création d'une nouvelle instance d'un enregistrement unique. Pour plus d'informations sur la création d'une référence cyclique, voir Création de références cycliques.

Voir aussi

Création d'une nouvelle instance d'un enregistrement existant

Création de références cycliques

Portée des propriétés

Spécification de propriétés pour les enregistrements et les champs


Format d'heure pris en charge pour la norme X12

Dans l'Éditeur BizTalk, le format d'heure pris en charge pour la syntaxe X12 (indiqué lorsque standard=X12 dans l'onglet Référence du nœud racine du schéma) est HHMMSSDD :

  • HH représente les heures. L'entrée valide est comprise entre 00 et 23.

  • MM représente les minutes. L'entrée valide est comprise entre 00 et 59.

  • SS représente les secondes sous forme d'entier. L'entrée valide est comprise entre 00 et 59.

  • DD représente les secondes en décimales. Les secondes en décimales sont envoyées dans l'un des formats suivants :
    • D représente les dixièmes de seconde. L'entrée valide est comprise entre 00 et 9.

    • D représente les centièmes de seconde. L'entrée valide est comprise entre 00 et 99.

      Si vous souhaitez exprimer l'heure en dixièmes ou en centièmes de seconde, utilisez le type de données Date/Heure personnalisé décrit dans la rubrique qui traite de l'application correcte du format Date/Heure personnalisé.

    Grâce à ce format, les données respectant les restrictions de plages d'entrée indiquées plus haut peuvent comporter quatre, six, sept ou huit chiffres. En d'autres termes, la spécification de HHMMSSDD d'un format de date signifie que les données d'instance doivent correspondre à HHMM, HHMMSS, HHMMSSD ou HHMMSSDD.

  • Toutes les zones d'heure utilisant le format personnalisé HHMMSSDD seront traitées comme des chaînes car XML ne gère pas les dixièmes ou les centièmes de seconde. La fonction Créer une instance native ne crée pas de format HHMMSSDD personnalisé.


Prise en charge de contenus mixtes

L'Éditeur BizTalk prend en charge les contenus mixtes principalement pour les organisations qui utilisent les schémas XDR (XML Data Reduced) en natif. Si un schéma possède un contenu mixte, cela signifie qu'un élément contient à la fois un contenu textuel et un contenu de sous-élément. Pour spécifier que le contenu du schéma est mixte, sélectionnez Mixte comme valeur de Contenu dans l'onglet Déclaration. Cet attribut s'applique uniquement aux types de documents XML (Extensible Markup Language) et il peut être spécifié uniquement au niveau enregistrement d'un schéma, non au niveau champ.

L'exemple suivant montre un extrait de schéma dont le contenu a la valeur "mixte" :

<ElementType name="ProgramManager" content="mixed">
<element  type="Name" >
<element type="OfficeNumber" >
</ElementType>

L'exemple suivant montre un extrait de schéma représentant une instance XML :

<ProgramManager>
A program manager named <Name>Mike Hines</Name> works in office <OfficeNumber>2234</OfficeNumber>.
</ProgramManager>

Dans l'exemple précédent, si les contenus de l'élément <Program Manager> étaient liés à partir de la spécification Source dans un Mappeur BizTalk à un enregistrement de la spécification Destination, le résultat obtenu en sortie serait le suivant :

Le gestionnaire de programme Mike Hines travaille dans le bureau 2234.

Voir aussi

Définition des propriétés de déclaration


Champs et propriétés associées

En fonction du type de spécification en cours d'élaboration, vous serez certainement amené à ajouter et/ou supprimer des enregistrements. Les champs correspondent à des éléments EDI (Electronic Data Interchange). Après l'ajout de champs à une spécification quelconque, y compris des documents EDI, vous devez spécifier des valeurs de propriétés.

Si votre spécification est basée sur X12 ou EDIFACT, vous ne pouvez ajouter que les types de champs qui existent dans cette norme, mais vous pouvez supprimer un ou tous les champs. Si vous créez une spécification basée sur une spécification vide, vous devez ajouter des champs. Vous pouvez modifier les propriétés de n'importe quel champ, indépendamment du type de document.

Lorsque vous ajoutez ou insérez un nouveau champ dans une spécification, la propriété Type de l'onglet Déclaration est définie par défaut sur Attribut. Vous pouvez modifier manuellement cette valeur en Élément pour n'importe quel champ. Pour plus d'informations sur la création de champs avec la propriété Type définie par défaut sur Élément, voir Création d'un nouveau champ en tant qu'élément.

Lorsque vous ajoutez ou insérez un champ, vous pouvez commencer immédiatement la saisie pour renommer le champ. Vous pouvez modifier le nom d'un champ existant ainsi que ses propriétés en sélectionnant le champ et en effectuant les modifications appropriées.

Si vous collez dans une spécification un champ dont le nom est identique à celui d'un champ existant, un numéro est ajouté à la fin du nom du champ. Si vous collez dans une spécification un champ dont le nom est identique à celui d'un champ frère existant (et que les deux champs possèdent la même valeur Type), un numéro est ajouté à la fin du nom du champ. Pour plus d'informations sur les valeurs Type, voir Définition des propriétés de déclaration. Pour plus d'informations sur la création d'une nouvelle instance d'un champ existant, voir Création d'une nouvelle instance d'un champ d'élément existant.

Voir aussi

Création d'un nouveau champ en tant qu'élément

Création d'une nouvelle instance d'un champ d'élément existant

Portée des propriétés

Définition des propriétés de déclaration

Spécification de propriétés pour les enregistrements et les champs


Calcul des positions des champs

L'Éditeur BizTalk peut automatiquement calculer les positions de début et de fin de tous les champs dans un enregistrement positionnel. Définissez tout d'abord une valeur Type de données et une valeur Longueur maximale dans l'onglet Déclaration pour chaque champ dans l'enregistrement positionnel. Puis, cliquez avec le bouton droit sur l'enregistrement positionnel et, dans le menu contextuel, cliquez sur Calculer les positions des champs. Les positions de début et de fin de tous les champs de cet enregistrement sont automatiquement calculées. Pour plus d'informations, voir Calcul automatique des positions de champs.

Les positions des champs d'un enregistrement sont calculées séquentiellement depuis le premier jusqu'au dernier champ de l'enregistrement. Lors du calcul des positions des champs, si le système trouve un champ dont la propriété Longueur maximale n'est pas définie, les positions de début et de fin de ce champ et de tous les champs suivants de l'enregistrement ne sont pas calculées. Les positions de début et de fin d'un champ dont la valeur Longueur maximale est égale à 1 sont identiques. Si le système trouve un enregistrement frère lors du calcul des positions des champs, les positions de début et de fin de tous les champs situés après l'enregistrement frère ne sont pas calculées.

Si des positions de début et de fin sont spécifiées pour les champs d'un enregistrement positionnel, toutes les positions à l'exception de la position de début du premier champ sont remplacées lors du calcul des positions des champs. Lorsque vous calculez les positions des champs, la Position de début du premier champ d'un enregistrement positionnel est définie sur 1, sauf si la valeur Position de début a été préalablement définie pour ce champ. Si une valeur Position de début a déjà été définie pour le premier champ d'un enregistrement positionnel, les calculs commencent à partir de cette valeur. De plus, lors du calcul des positions des champs d'un enregistrement positionnel, les positions des champs contenus dans tous les enregistrements descendants sont également calculées. Les positions des champs frères situés avant un enregistrement sont calculées, mais les positions des champs frères situés après un enregistrement ne sont pas calculées.

Le calcul de la position des champs tient compte de l'Identifiant de la balise source. Considérez, par exemple, un enregistrement positionnel avec les propriétés suivantes :

  • L'Identificateur de la balise source est « TAG ».

  • La Position de la balise source est 10.

  • Il existe quatre champs avec les valeurs Longueur maximale 2, 5, 8 et 6.

  • Il n'existe pas de valeur Position de début définie pour le premier champ.

Les positions de début et de fin des quatre champs sont :

  • Field 1 = 1, 2

  • Field 2 = 3, 7

  • Unused = 8, 9

  • TAG = 10, 12

  • Field 3 = 13, 20

  • Field 4 = 21, 26

Si la Position de la balise source avait pris la valeur 1, « TAG » aurait eu les valeurs de position de début et de fin 1 et 3, et le comptage des champs aurait commencé à la position 4.

Voir aussi

Calcul automatique des positions des champs


Limites de longueur des caractères

Le nombre de caractères que vous pouvez utiliser dans les noms et les valeurs de propriétés est limité. Le tableau ci-dessous indique les limites de nombre de caractères utilisables dans l'Éditeur BizTalk.

Nom ou valeur de propriété | Nombre maximal de caractères
Nom de nœud (nom d'un nœud racine, d'un enregistrement ou d'un champ) | 255
Préfixe d'espace de noms | 64
Valeur de propriété de chaîne | 1024
Valeur de propriété LONG | 11
Valeur de propriété ULONG | 10
Valeur de propriété CHAR | 1
Valeur de propriété de format EDI (Electronic Data Interchange) (valeur d'une propriété de format spécifique EDI, telle que la valeur de propriété Date/Format d'heure personnalisés de l'onglet Analyser pour un champ d'une spécification basée sur le format EDI) | 15
Espace de noms cible | 255
Nom de la spécification | 255

Voir aussi

Définition des propriétés de déclaration

Définition des propriétés de référence

Définition des propriétés d'analyse

Déclaration des espaces de noms

Définition des propriétés du dictionnaire


Valeurs et descriptions des listes de codes

Les informations figurant dans l'onglet Liste de codes définissent les valeurs de code ANSI X12 ou EDIFACT ainsi que leurs descriptions. Seules les spécifications basées sur une norme X12 ou EDIFACT possèdent des listes de codes. Les descriptions définissent la signification de chaque code. Par exemple, la valeur de code ST dans le champ Address Qualifier Code de nombreuses spécifications de documents standards signifie que l'information donnée correspond à une adresse Ship To. Les codes de la liste ne peuvent être ni modifiés ni supprimés. Vous pouvez choisir d'associer ou non un code avec un champ.

Tous les champs d'une spécification basée sur X12 ou EDIFACT ne possèdent pas de codes qui leur sont associés. L'onglet Liste de codes présente la liste complète des codes disponibles pour un champ spécifique si ce champ possède une référence de liste de codes. Les codes sont valides pour un champ si la case à cocher de la colonne Valeur à côté du code est sélectionnée. Une description du code apparaît dans la colonne Description. Si vous associez un code à un champ, la valeur Type de l'onglet Déclaration doit être définie sur Attribut.

Vous pouvez inclure ou exclure des codes associés à un champ en activant ou en désactivant les cases à cocher dans la colonne Valeur en regard du code mentionné dans l'onglet Liste de codes. Les codes sont mentionnés par valeur numérique ou alphabétique, ou par une combinaison de valeurs numériques et alphabétiques. Cette valeur représente une description spécifique. Vous pouvez associer une valeur de code à n'importe quel champ de l'arborescence de spécification. Par exemple, dans le champ BEG02 d'un ordre d'achat X12 850, vous pouvez sélectionner le code OS, qui ajoute un attribut au champ BEG02 indiquant que le champ contient une information spéciale de commande.

Les structures personnalisées influent sur les listes de codes

Si vous remplacez la structure d'une spécification basée sur X12 ou EDIFACT par une structure de type PERSONNALISÉ, puis que vous la remplacez de nouveau par une structure X12 ou EDIFACT, la liste de codes d'un champ en particulier risque de ne plus être disponible dans l'onglet Liste de codes. Dans ce cas, enregistrez la spécification et ouvrez-la de nouveau. La liste de codes réapparaîtra dans l'onglet Liste de codes pour le champ concerné.

Emplacement de la base de données de la liste de codes

Les valeurs et descriptions des listes de codes pour les modèles de spécifications basés sur EDI qui sont fournis par BizTalk Server 2002 figurent dans le fichier de base de données Microsoft Access à l'emplacement \Program Files\Microsoft BizTalk Server\XML Tools\Databases\CodeLists\CodeListsX12a.mdb. Si vous créez de nouvelles tables dans cette base de données pour de nouveaux modèles de spécification, le format du nom des tables est standard_version. Par exemple, pour un modèle de spécification EDIFACT D99A, le nom de table correspondant est EDIFACT_D99A.

Important

  • Si vous créez une nouvelle table dans la base de données CodeListsX12a.mdb, ne placez pas de caractères XML (Extensible Markup Language) non valides (caractères Unicode compris entre F900 et FFFE) dans la colonne Valeur de la table. Si vous enregistrez une spécification contenant un champ doté d'une valeur de liste de codes sélectionnée associée à une valeur dans une table comportant un caractère XML non valide, vous ne pourrez pas ouvrir la spécification.

Voir aussi

Suppression de codes

Sélection de codes

Spécification de propriétés pour les enregistrements et les champs


Caractères tampon

L'Éditeur BizTalk permet de gérer les caractères tampon dans les documents délimités afin d'être sûr d'obtenir les résultats attendus. Chaque document délimité traité par BizTalk Server 2002 devant être traduit en XML (Extensible Markup Language) avant que le mappage ait lieu, vous devez vous assurer que la spécification de votre document indique à BizTalk Server comment manipuler les caractères tampon dans les instances de documents délimités. Par exemple, un champ d'une instance de document délimité pourrait ressembler à ceci :

Green*****

Le contenu des données du champ est Green, le champ est justifié à gauche, il y a cinq caractères tampon à droite du contenu du champ et le caractère tampon est un astérisque (*).

Si vous ne définissez pas de caractères tampon pour le champ de la spécification correspondant au champ de l'instance de document, BizTalk Server interprète les cinq astérisques comme faisant partie des données du champ. Afin de vous assurer que BizTalk Server manipule correctement les caractères tampon dans ce champ, vous devez vérifier que les propriétés de l'onglet Analyser pour ce champ correspondent aux valeurs indiquées dans le tableau ci-dessous.

Propriété | Valeur
Justification | Gauche
Caractère tampon | *
Longueur minimale avec des caractères tampon | Définissez cette valeur de propriété si vous voulez que la longueur du champ dans votre instance de sortie soit supérieure ou égale à une longueur donnée. BizTalk Server insère des caractères tampon dans le champ afin d'obtenir la longueur de champ minimale correcte dans l'instance de sortie.

Vous pouvez utiliser la propriété Caractère tampon pour vous assurer que les caractères tampon d'un champ sont supprimés d'une instance de document envoyée à BizTalk Server. La valeur de la propriété Longueur minimale avec des caractères tampon est le gage que BizTalk Server va insérer des caractères tampon dans un champ de l'instance de sortie, si l'utilisateur le souhaite. La propriété Justification indique de quel côté du contenu des données du champ les caractères tampon sont supprimés (de l'instance du document d'entrée) ou insérés (dans l'instance de sortie). Les caractères tampon sont ajoutés ou supprimés à droite dans un champ justifié à gauche, et à gauche dans un champ justifié à droite. Si la propriété Caractère tampon d'un champ n'est pas définie, aucun caractère tampon n'est ajouté ou supprimé dans ce champ.

Voir aussi

Définition des propriétés d'analyse


Portée des propriétés

Si une spécification possède deux ou plusieurs instances d'un enregistrement, les valeurs de certaines propriétés de ces instances doivent être identiques. En d'autres termes, la portée de ces propriétés est globale. La portée de certaines propriétés de champs peut également être globale, mais uniquement si la propriété Type du champ est définie sur Élément. En revanche, la portée d'un champ dont la propriété Type est définie sur Attribut est toujours locale.

Par exemple, toutes les propriétés des onglets Déclaration et Analyser sont identiques pour les instances multiples d'un enregistrement ou d'un champ. Si vous modifiez une propriété de déclaration ou d'analyse d'une instance d'un enregistrement ou d'un champ, cette propriété change automatiquement pour toutes les autres instances de cet enregistrement ou de ce champ. Les propriétés des onglets Référence et Dictionnaire ne possèdent cependant pas de champ d'application global, de sorte que les valeurs de ces propriétés peuvent être définies indépendamment pour chaque instance d'un enregistrement ou d'un champ. Les listes de codes s'appliquent uniquement aux champs, et ne possèdent pas de champ d'application global.

Remarque

  • Dans l'Éditeur BizTalk, seules les déclarations ElementType ont un champ d'application global. Si vous importez dans l'Éditeur BizTalk un schéma contenant des déclarations AttributeType qui possèdent un champ d'application global, et que vous enregistrez le schéma en tant que spécification, les déclarations AttributeType deviennent automatiquement de portée locale au sein de la ou des déclarations ElementType appropriées.

Voir aussi

Définition des propriétés de déclaration

Définition des propriétés d'analyse


Références cycliques

Une référence cyclique a lieu dans une spécification lorsqu'un enregistrement est créé en tant que descendant de lui-même. Une référence cyclique ne peut se produire que lorsque la valeur de la propriété Standard est XML dans l'onglet Référence. L'éditeur BizTalk illustre une référence cyclique par une icône Icône de référence cyclique représentant un enregistrement traversé par une flèche courbe.

L'illustration ci-dessous montre comment une référence cyclique apparaît dans l'Éditeur BizTalk.

Référence cyclique dans une spécification

La propriété Nombre de cycles apparaît dans l'onglet Déclaration et s'applique uniquement à un nœud cyclique. La valeur par défaut est 7. Le nombre de cycles indique combien de cycles sont disponibles en dessous de l'enregistrement de base. Par exemple, dans l'illustration précédente, il y a un total de quatre niveaux pour Record1 : trois à partir du nombre de cycles égal à 3 et un à partir de l'enregistrement de base. Si vous ouvrez cette spécification dans le Mappeur BizTalk, les quatre niveaux de Record1 apparaissent. Record2 et Field1 apparaissent également pour chaque Record1. Vous pouvez établir des liaisons vers les nœuds de chaque niveau du cycle.

Il n'est pas possible de définir des valeurs de propriétés de dictionnaire pour les champs qui descendent d'un nœud cyclique. Par exemple, dans l'illustration précédente, vous pouvez définir des valeurs de propriétés de dictionnaire pour Root/Record1/Field1, mais pas pour l'une des trois références Field1 situées sous Root/Record1/Record1.

Les références cycliques sont sujettes aux restrictions suivantes :

  • Les nœuds d'un chemin de cycle (nœuds situés entre le premier et le dernier enregistrement dans une référence cyclique) ne peuvent pas apparaître à un autre endroit de la spécification.

  • Les éléments d'un chemin de cycle ne peuvent être la source ou la cible d'une opération quelconque de glisser-déplacer ou de couper-coller.

  • Les cycles ne peuvent pas se chevaucher.

  • L'enregistrement de base d'une référence cyclique ne peut pas être le nœud racine de la spécification.

Important

  • La valeur de la propriété Occurrences minimales de l'onglet Référence pour le nœud de la référence cyclique doit être égale à 0. La valeur 1 provoque une boucle infinie.

  • Lorsque vous importez un schéma contenant une référence cyclique, l'Éditeur BizTalk ne vérifie pas automatiquement que la référence cyclique est valide.

Voir aussi

Création de références cycliques

Portée des propriétés


Intégration des valeurs par défaut

Si une spécification source contient un champ de type Attribut, et qu'une instance de document entrant basée sur la spécification source ne contient pas ce champ, vous voudrez certainement que la spécification fournisse une valeur par défaut pour ce champ.

Si une instance de document entrant ne contient pas le champ, la valeur par défaut du champ est fournie. Si une instance de document entrant contient le champ, la valeur par défaut est ignorée.

Voir aussi

Définition des propriétés de déclaration


Résumé des types de données et des valeurs de types de données

La liste ci-dessous fournit des détails et des exemples permettant de vous aider à spécifier une valeur pour la propriété Type de données de l'onglet Déclaration. Après avoir sélectionné une des options suivantes de la liste Type de données, vous devrez probablement spécifier une valeur dans la zone Valeurs des types de données.

Type de données

Character

Contient une chaîne de longueur égale à un caractère.

String

Contient une chaîne de texte.

Number

Contient un nombre de chiffres et peut inclure un signe à gauche, des fractions et un exposant. Ceci est conforme aux règles de ponctuation de l'anglais ; par exemple, 15, 3.14, -123.456E+10.

Integer (int)

Contient un nombre et peut inclure un signe en option. Ne peut contenir une fraction ou un exposant ; par exemple, 1, 58502, -13.

Float

Contient un nombre illimité de chiffres et peut inclure un signe à gauche, des fractions ou un exposant.

Fixed Point (14.4)

Identique au type Number, mais limité à 14 chiffres à gauche du point décimal et à 4 chiffres à droite de celui-ci ; par exemple, 12.0044. Ce type de données peut être utilisé pour les valeurs monétaires.

Boolean

Contient une expression égale à TRUE (1) ou FALSE (0).

Date

Contient une date au format ISO 8601, sans indication d'heure ; par exemple, 1988-04-07.

Date Time

Contient une date au format ISO 8601, avec une indication d'heure facultative et des informations de zone non facultatives. Les secondes exprimées sous forme de fraction peuvent être aussi précises que les nanosecondes ; par exemple 1988-04-07T18:39:09.

Date Time.tz

Contient une date au format ISO 8601, avec une indication d'heure en option et des informations de zone en option. Les secondes exprimées sous forme de fraction peuvent être aussi précises que les nanosecondes ; par exemple 1988-04-07T18:39:09-08:00.

Time

Contient une heure au format ISO 8601, sans indication de date et de zone ; par exemple, 08:15:27.

Time.tz

Contient une heure au format ISO 8601, sans indication de date mais avec des informations de zone facultatives ; par exemple, 08:15:27-05:00.

Byte (i1)

Contient un nombre et peut contenir un signe en option, comme un signe moins (-). Ne peut contenir une fraction ou un exposant ; par exemple, 1, 127, -128.

Word (i2)

Contient un nombre et peut contenir un signe en option, comme un signe moins (-). Ne peut contenir une fraction ou un exposant ; par exemple, 1, 703, -32768.

Integer (i4)

Contient un nombre et peut contenir un signe en option, comme un signe moins (-). Ne peut contenir une fraction ou un exposant ; par exemple, 1, 703, -32768, 148343, -1000000000.

Double Integer (i8)

Contient un nombre et peut contenir un signe en option, comme un signe moins (-). Ne peut contenir une fraction ou un exposant ; par exemple, 1, 703, -32768, 148343, -1000000000.

Unsigned Byte (ui1)

Contient un nombre. Ne peut contenir un signe, une fraction ou un exposant ; par exemple, 1, 255.

Unsigned Word (ui2)

Contient un nombre. Ne peut contenir un signe, une fraction ou un exposant ; par exemple, 1, 255, 65535.

Unsigned Integer (ui4)

Contient un nombre. Ne peut contenir un signe, une fraction ou un exposant ; par exemple, 1, 703, 3000000000.

Double Unsigned Integer (ui8)

Contient un nombre. Ne peut contenir un signe, une fraction ou un exposant ; par exemple, 1, 703, 3000000000.

Real (r4)

Contient un nombre de valeur minimale 1.17549435E–38F et de valeur maximale 3.40282347E+38F ; par exemple, 3.14285718E+2.

Double Real (r8)

Contient un nombre de valeur minimale 2.2250738585072014E308 et de valeur maximale 1.7976931348623157E+308 : par exemple, .314159265358979E+1.

Universal Unique Identifier (uuid)

Contient des chiffres hexadécimaux représentant des octets, avec des tirets en option pouvant être ignorés ; par exemple, 333C7BC4-460F-11D0-BC04-0080C7055A83.

Uniform Resource Identifier (uri)

Contient un identificateur URI (Uniform Resource Identifier).

Binary (base64)

Contient le codage binaire d'un texte binaire en caractères ;par exemple, la conversion d'une image GIF (Graphic Interchange Format) en une représentation texte.

Binary (hex)

Contient un chiffre hexadécimal binaire qui représente des octets ; par exemple, 0x0ffaa.

ID

Spécifie le champ en tant que ID.

IDREF

Spécifie que le champ est référencé vers le champ contenant la valeur ID.

IDREFS

Spécifie que le champ contient une liste des ID, ceux-ci étant séparés par un espace.

Enumeration

Affecte une séquence ordinale à une série de valeurs ; par exemple, la série Lundi, Mardi, Mercredi peut être énumérée en tant que 1 2 3.

Remarque

  • Le type de données Fixed Point (14.4) peut être utilisé pour les valeurs monétaires.

  • Si vous voulez utiliser un filtre pour un type de date/heure (dateTime, dateTime.tz, time, time.tz), vous devez le taper manuellement dans l'expression XPath. Par exemple, self::node()[@ATTDATETIME = "2000-03-15T10:10:10"] où ATTDATETIME correspond au type de format date/heure.

Voir aussi

Définition des propriétés de déclaration


Déclencheurs généraux

BizTalk Editor fournit une propriété appelée Champ déclencheur disponible dans l'onglet Analyser pour identifier un champ déclencheur pour tout type de segment pour les schémas Microsoft® BizTalk™ Accelerator for HIPAA. Un champ déclencheur est, en gros, une forme de balisage basée sur le contenu. Le type de données Enumeration existant et l'attribut Values permettent de spécifier la ou les valeurs qui entraînent l'identification du déclencheur. Le parseur interprète ce champ déclencheur pendant l'analyse et établit la correspondance entre le contenu de l'instance et le nœud dans le schéma qui possède la ou les valeurs de déclencheur correspondantes.

Il existe 11 types de segments qui utilisent des champs déclencheurs pour définir plus avant leurs significations. Le tableau suivant présente ces types de segments et les champs déclencheurs correspondants.

Segment | Champ déclencheur
AMT | AMT01
CRC | CRC01
DTM | DTM01
DTP | DTP01
ENT | ENT02
HI | HI01:01 (01 est un premier sous-champ composé)
N1 | N101
NM1 | NM01
NTE | NTE01
REF | REF01
RMR | RMR01

L'Éditeur BizTalk permet l'existence d'homologues dupliqués si tous utilisent des champs déclencheurs avec des valeurs qui s'excluent mutuellement. En d'autres termes, les homologues dupliqués sont toujours interdits s'ils introduisent une ambiguïté.

Les déclencheurs s'étendent facilement pour boucler l'interprétation également, car le segment déclencheur (c'est-à-dire, le segment contenant le champ déclencheur) est toujours le premier segment dans la boucle. Les déclencheurs sont également acceptés sur les segments qui peuvent être imbriqués dans une boucle.

L'Éditeur BizTalk ne peut pas valider le fait que les énumérations ne chevauchent pas la valeur du déclencheur sur le même identificateur de balise source. Si vous modifiez les propriétés et si vous créez un chevauchement, une erreur d'exécution se produit. Les annotations que vous ajoutez et qui sont requises pour la prise en charge de l'imbrication de segments sont conservées lorsque vous enregistrez une spécification.

En plus du type de segment mentionné dans le tableau précédent, il existe un cas spécial de segment à niveau hiérarchique. Pour plus d'informations sur ce type de segment, voir Cas spécial de segment à niveau hiérarchique.

Important

  • Les champs déclencheurs peuvent être des attributs uniquement pour l'enregistrement ou la boucle déclenchée. Ceci est dû au fait que tous les champs des schémas X12 sont représentés à l'aide d'attributs.

Cette section traite des rubriques suivantes :

  • Validation des champs déclencheurs

  • Cas spécial de segment à niveau hiérarchique

  • Limitations des structures des instances

  • Validation des niveaux hiérarchiques

Voir aussi

Définition des propriétés d'analyse


Validation des champs déclencheurs

Au moment de la conception, l'Éditeur BizTalk valide uniquement l'existence du champ déclencheur spécifié et valide qu'il s'agit d'un attribut. En dehors de cela, toutes les autres validations sont effectuées au moment de l'exécution. Tous les schémas HIPAA fournis sont validés au moment de l'exécution. Leurs critères de validation sont les suivants :

  • Les nœuds d'éléments d'homologues avec le même identificateur de balise source doivent avoir la même structure et doivent spécifier le même champ déclencheur dans leurs hiérarchies respectives.

  • Chaque nœud d'élément d'homologue définit des valeurs d'énumération mutuellement exclusives pour le champ déclencheur commun.

  • Les données d'instance qui ne correspondent à aucune des valeurs de déclenchement des structures possibles sont marquées en tant que données inattendues trouvées dans l'instance (ce comportement est le même que si l'identificateur de balise source était introuvable dans le schéma).

  • Si le schéma contient des déclencheurs imbriqués et si le premier enregistrement enfant de la boucle déclenchée est également déclenché alors, cet enregistrement enfant ne peut se répéter.

  • De la même façon, pour tous les segments homologues déclenchés, en fonction de leurs paramétrages d'occurrences minimum/maximum, le 1/1s vient en premier, suivi par 1/*, suivi par 0/[1|*]. Lorsque cette condition n'est pas remplie, une erreur d'analyse se produit.

Voir aussi

Définition des propriétés d'analyse


Cas spécial de segment à niveau hiérarchique

L'utilisation de segments à niveaux hiérarchiques est un cas spécial pour les champs déclencheurs car, en plus de l'interprétation des valeurs des champs déclencheurs, cela requiert également que la trace des relations parent/enfant soit conservée. Le segment à niveaux hiérarchiques contient les champs suivants :

  1. ID de séquence numérique du haut vers le bas du document, en commençant par « 1 »

  2. ID de séquence parent

  3. Indicateur de niveau du champ déclencheur (par exemple, 22 = Abonné, 23 = Dépendant)

  4. Indicateur enfant (0 = Non ; 1 = Oui)

Le parseur utilise les contenus de ces champs pour construire une hiérarchie pour les segments à niveaux hiérarchiques rencontrés. Cette hiérarchie n'est pas explicitement contraire au schéma, mais en revanche, les contenus des segments à niveaux hiérarchiques peuvent faire que le parseur interprète la structure différemment.

Il existe également des implications liées au sérialiseur pour les segments à niveaux hiérarchiques. Il est préférable de ne pas créer de contenus pour les champs 1 et 2 (mentionnés précédemment) dans le processus de mappage BizTalk Server 2002. Si vous créez des contenus pour ces champs, le sérialiseur ne les conservera pas.

Voir aussi

Définition des propriétés d'analyse


Limitations des structures des instances

Le parseur X12 impose deux restrictions pour la permutation de structure d'une instance en ce qui concerne les segments à niveaux hiérarchiques :

  • Aucun bond. Toute boucle ou segment HL doit se trouver exactement un niveau en dessous de la racine par rapport à sa boucle ou son segment parent HL, si un parent HL existe. Par exemple, HL1/N1/HL2 n'est pas pris en charge. En d'autres termes, une séquence « x » de niveaux d'imbrication doit répartir exactement les générations « x » de profondeur dans l'arborescence. Les illustrations suivantes montrent des exemples de scénarios de segments et de boucles HL autorisés et non autorisés.

    Exemples de scénarios de segments et de boucles HL autorisés et non autorisés

  • Aucun saut. Cette limitation permet d'éviter que vous ne spécifiez une hiérarchie qui n'est pas dans l'ordre. Pour tout niveau hiérarchique faisant référence à un parent HL, il ne peut exister aucun autre niveau hiérarchique entre eux en séquence dans le flux de données de l'instance. Cette limitation est appelée « aucun saut » car, si on la décrit comme un arbre généalogique, l'action prescrite revient à sauter d'une branche à une autre, puis à sauter de nouveau d'une branche à l'autre en suivant la séquence des niveaux hiérarchiques. Le tableau suivant représente cette limitation appelée « aucun saut ».
    ID | Parent
    1 -
    2 | 1
    3 | 2
    4 | 3
    5 | 1
    6 | 4

    Lorsque les niveaux hiérarchiques HL sont descendus en séquence, en suivant l'ordre dans lequel ils apparaissent dans le flux de données du parseur, chacun d'entre eux est l'enfant du précédent, jusqu'au niveau #5, qui est une occurrence répétée du niveau #2. Ce comportement est autorisé et attendu. Suit alors le niveau #6, qui tente de s'identifier en tant qu'enfant du #4. Ce comportement n'est pas autorisé car, dans la séquence, le niveau #5 se trouve entre le niveau#6 et le niveau hiérarchique qu'il appelle son parent (#4).

Remarque

  • Avec l'Éditeur BizTalk, il est possible de modifier les schémas HIPAA spécifiques fournis avec Microsoft BizTalk Accelerator for HIPAA. Soyez prudent lorsque vous modifiez les schémas et assurez-vous que vous suivez toujours scrupuleusement les guides d'implémentation HIPAA.

Voir aussi

Définition des propriétés d'analyse


Validation HL

Outre les validations des champs déclencheurs décrites dans la rubrique Validation des champs déclencheurs, il existe également des validations de segments à niveaux hiérarchiques (HL). Les validations suivantes sont effectuées au moment de l'exécution :

  • Aucun bond/aucun saut. Les schémas rencontrés lorsque ces restrictions ne sont pas respectées entraînent des erreurs d'exécution.

  • Tous les champs de schémas HL doivent être des attributs. Cette condition est contrôlée au moment de l'exécution et une erreur se produit si elle n'est pas respectée.

  • Le champ HL02 doit être facultatif. Cette condition est requise car tous les niveaux HL n'ont pas de parents (c'est par exemple le cas des niveaux HL en haut de la hiérarchie). Dans les schémas, une règle syntaxique impose l'existence de ce champ.

  • Le champ HL04 doit être égal à « 0 » ou « 1 ». Cette condition est imposée en utilisant le type de données Enumeration pour ce champ, avec les valeurs 0 ou 1.

  • Données dans le désordre. Les segments HL doivent se présenter dans l'ordre hiérarchique adéquat. Cette restriction est identique à la restriction appelée « aucun saut », qui requiert en fait que les branches de l'arbre généalogique soient suivies jusqu'à leur terme avant qu'un autre arbre puisse être créé (hiérarchiquement parlant). Par ailleurs, le retour à une branche qui a changé n'est pas possible.

Voir aussi

Définition des propriétés d'analyse


Prise en charge des espaces de noms

L'Éditeur BizTalk fournit la prise en charge des espaces de noms. Un espace de noms XML (Extensible Markup Language) est un ensemble constitué de noms qui peuvent être utilisés en tant que noms d'éléments ou d'attributs dans un document XML. Un espace de noms qualifie les noms d'éléments de façon unique afin d'éviter les conflits entre éléments de noms identiques qu'il serait possible de rencontrer dans un même document. L'espace de noms est identifié par des identificateurs URI (Universal Resource Identifier), soit en tant qu'URL (Uniform Resource Locator), soit en tant que nom de ressource uniforme (URN, Uniform Resource Name).

Dans le cas des formats de données non-XML, le schéma XDR (XML Data Reduced) est annoté avec les éléments et les attributs qui appartiennent à l'espace de noms de BizTalk Server 2002. Ces éléments et attributs contiennent des informations sur le traitement des documents non-XML, tels que les documents au format de fichier plat et EDI, qui permettent de les reformater dans une représentation XML que BizTalk Server peut utiliser pour les transformations, les journalisations et les suivis.

Cette section traite des rubriques suivantes :

  • Déclarations d'espaces de noms

  • Conservation des espaces de noms dans les fichiers importés


Déclarations d'espaces de noms

Les espaces de noms qui sont déclarés dans une spécification sont affichés dans l'onglet Espace de noms de l'Éditeur BizTalk. Le tableau suivant indique les préfixes et espaces de noms qui apparaissent par défaut dans l'onglet Espace de noms lors de l'ouverture d'une spécification dans l'Éditeur BizTalk. Vous ne pouvez pas modifier ces préfixes et espaces de noms.

Préfixe | Espace de noms
(par défaut) | urn:schemas-microsoft-com:xml-data
b | urn:schemas-microsoft-com:BizTalkServer
d | urn:schemas-microsoft-com:datatypes

Remarque

  • L'espace de noms suivant n'est pas pris en charge par BizTalk Server 2002 :

    SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"

Vous pouvez déclarer des espaces de noms personnalisés dans une spécification en tapant un préfixe d'espace de noms dans la colonne Préfixe et un espace de noms dans la colonne Nom de ressource uniforme de l'onglet Espace de noms. L'Éditeur BizTalk ne valide pas le nom de ressource uniforme introduit pour un espace de noms.

Vous pouvez également ajouter une annotation personnalisée à chaque enregistrement ou champ. Une annotation personnalisée se compose d'une paire préfixe-nom et d'une valeur associée. L'exemple ci-dessous illustre la syntaxe de la paire préfixe-nom :

préfixe:nom

Dans l'onglet Déclaration ou Référence, tapez une paire préfixe-nom dans la colonne Propriété et entrez une valeur dans la colonne Valeur. Les valeurs des propriétés entrées dans l'onglet Déclaration ont un champ d'application global, tandis que les valeurs des propriétés entrées dans l'onglet Référence ont un champ d'application local. Pour plus d'informations sur les champs d'application globaux et locaux, voir Portée des propriétés. Pour plus d'informations sur l'ajout d'annotations personnalisées, voir Ajout d'annotations personnalisées.

Voir aussi

Ajout d'annotations personnalisées

Déclaration des espaces de noms

Conservation des espaces de noms dans les fichiers importés

Portée des propriétés


Conservation des espaces de noms dans les fichiers importés

Vous pouvez importer trois types de fichiers dans l'Éditeur BizTalk : schémas XDR (XML-Data Reduced), instances XML bien formées et définitions de type de document (DTD). L'Éditeur BizTalk manipule différemment les espaces de noms et les paires préfixe-nom pour chaque type de document.

Importation d'un schéma XDR

Lorsque vous importez un schéma XDR, les espaces de noms existants sont manipulés de la manière suivante :

  • Les déclarations d'espaces de noms sont conservées en guise d'espaces de noms personnalisés et apparaissent dans l'onglet Espace de noms en dessous des espaces de noms par défaut.

  • Les préfixes d'espaces de noms personnalisés (à l'exception de ceux associés aux propriétés Nom et Type) sont préservés uniquement si l'espace de noms associé est déclaré.

Remarque

  • L'Éditeur BizTalk ne peut pas importer un schéma XDR avec un préfixe d'espace de noms associé à la propriété Nom ou Type.

Importation d'une instance XML bien formée

Lorsque vous importez une instance de document XML bien formée, les déclarations d'espaces de noms sont supprimées du document et le symbole séparateur préfixe-nom qui est le caractère deux points (:) est modifié en trait de soulignement (_), de manière à conserver l'intention originale du préfixe d'espace de noms. Exemple :

préfixe_nom

Important

  • Si vous importez une instance de document XML bien formée contenant une paire préfixe-nom d'espace de noms, que vous enregistrez l'instance importée en tant que spécification, et que vous essayez de valider l'instance du document d'origine avec la nouvelle spécification, la validation d'instance échoue. Dans la nouvelle spécification, supprimez le nœud qui contient la paire préfixe-nom. Pour l'enregistrement parent de ce nœud (sous l'onglet Déclaration), sélectionnez la valeur Ouvrir pour la propriété Modèle et enregistrez la spécification. Vous pouvez maintenant valider l'instance du document avec cette spécification.

Remarque

  • L'Éditeur BizTalk ne peut pas importer un document contenant un préfixe d'espace de noms si l'espace de noms associé n'a pas été déclaré dans le document.

Importation d'une DTD

Lorsque vous importez une DTD contenant une paire préfixe-nom, le symbole séparateur qui est le caractère deux points (:) est modifié en trait de soulignement (_). De cette manière, en termes de placement au sein de la structure globale, l'objectif initial du préfixe est maintenu même si la notation elle-même du préfixe n'est pas prise en charge. Exemple :

préfixe_nom

Voir aussi

Déclarations d'espaces de noms


Ajout d'annotations SQL

Vous pouvez spécifier une annotation SQL pour n'importe quel nœud d'une spécification. La spécification d'une annotation SQL dans l'onglet Déclaration crée une annotation dont le champ d'application est global. L'annotation est enregistrée dans la déclaration ElementType ou AttributeType de la spécification. La spécification d'une annotation SQL dans l'onglet Référence crée une annotation dont le champ d'application est local. L'annotation est enregistrée dans la référence Élément ou Attribut de la spécification.

Vous pouvez sélectionner une annotation SQL dans la liste qui apparaît lorsque vous double-cliquez sur un champ vide dans la colonne Propriété de l'onglet Déclaration ou de l'onglet Référence à l'endroit d'un nœud d'une spécification. Entrez une valeur pour l'annotation SQL dans le champ correspondant de la colonne Valeur. Pour toutes les annotations SQL à l'exception de « sql:relationship » et « sql:xpath-query », la valeur est habituellement une chaîne de caractères. Pour plus d'informations sur l'ajout d'annotations SQL et autres annotations personnalisées, voir Ajout d'annotations personnalisées.

La liste ci-dessous indique toutes les annotations SQL possibles dans l'Éditeur BizTalk :

  • sql:datatype

  • sql:field

  • sql:id

  • sql:id-prefix

  • sql:is-constant

  • sql:key-fields

  • sql:limit-field

  • sql:limit-value

  • sql:map-field

  • sql:is-mapping-schema

  • sql:overflow-field

  • sql:relation

  • sql:relationship

  • sql:target-namespace

  • sql:url-encode

  • sql:use-cdata

  • sql:xpath-query

La valeur de « sql:relationship » est une ou plusieurs paires nom-valeur, et le nom figurant dans chaque paire nom-valeur doit être un des quatre noms suivants : key, key-relation, foreign-key ou foreign-relation. La valeur de « sql:xpath-query » se compose de deux parties : la première partie est constituée d'une ou de plusieurs paires nom-valeur comprenant un ou des attributs, la seconde partie désignant le contenu de « sql:xpath-query », représenté par « contenu=... ». Ces deux parties sont séparées par le symbole numéro (#).

Le tableau ci-dessous illustre des exemples corrects d'annotations SQL « sql:relationship » et « sql:xpath-query ».

Annotation SQL | Exemples de valeurs
sql:relationship | key="CustomerID"
sql:relationship | key-relation="Cust"
sql:relationship | foreign-key="CustomerID"
sql:relationship | foreign-relation="Orders"
sql:xpath-query | mapping-schema="Schema.xml" #content=Employees

Remarques

  • L'Éditeur BizTalk ne limite pas la sélection des annotations SQL à celles qui sont adaptées dans le contexte en vigueur. Par exemple, « sql:relationship » et « xpath-query » sont disponibles dans l'onglet Déclaration, même si leur utilisation doit être limitée à l'onglet Référence.

  • Lorsque vous spécifiez une annotation SQL, un espace de noms avec un préfixe « sql » ainsi que la valeur URN correspondante sont automatiquement déclarés dans l'onglet Espace de noms.

  • Lorsque vous copiez ou coupez un nœud comportant des annotations SQL spécifiées dans l'onglet Référence, puis que vous collez ce nœud à un autre endroit de la spécification, les annotations SQL ne figurent plus dans le nouveau nœud.

Voir aussi

Ajout d'annotations personnalisées

Déclarations d'espaces de noms

Portée des propriétés


Création d'instances XML et d'instances natives

Pour garantir une utilisation réussie de Microsoft BizTalk Server 2002 dans votre environnement de production, l'Éditeur BizTalk fournit un système qui vous permet de tester les spécifications avant de les implémenter dans votre organisation. La manipulation d'une instance implique le test d'une instance par rapport à une spécification ou la génération d'une instance basée sur une spécification que vous avez créée dans l'Éditeur BizTalk.

L'Éditeur BizTalk permet de créer soit des instances XML (Extensible Markup Language), soit des instances natives. Lorsque vous utilisez des fichiers plats (à la fois positionnels et délimités), il est inutile de saisir des informations relatives aux délimiteurs. Toutefois, lorsque vous utilisez des documents EDI, vous devez indiquer le délimiteur à utiliser.

Voir aussi

Création d'une instance de document

Création d'une instance native


Validation d'instances et de spécifications

L'Éditeur BizTalk permet la validation d'instances de documents. Lorsque vous validez une instance de document par rapport à une spécification dont le standard est la norme X12, EDIFACT ou Personnalisé, l'instance de document doit avoir une structure de document conforme au standard de la spécification. Par exemple, vous pouvez uniquement valider une instance de document X12 par rapport à une spécification X12.

Une instance de document qui contient un champ avec une valeur d'attribut vide ("") peut être validée avec succès par rapport à une spécification, quelle que soit la valeur définie pour la propriété Longueur minimale pour ce champ. Par exemple, si la valeur de propriété Longueur minimale du champ d'une spécification est définie sur 4, si vous essayez de valider une instance de document disposant du champ correspondant avec une valeur d'attribut vide, la validation n'échouera pas en raison de cette incohérence. Le parseur MSXML sous-jacent du moteur de validation traite un attribut avec une valeur vide comme un attribut qui n'est pas spécifié. Ce problème sera corrigé dans la prochaine version de BizTalk Server 2002.

Délimiteurs de document

L'Éditeur BizTalk permet de spécifier des délimiteurs au cours de la validation d'instances et de spécifications. Utilisez l'onglet Délimiteurs de document pour spécifier des délimiteurs par défaut à utiliser au cours de la validation et également spécifier si la boîte de dialogue Délimiteurs de document doit s'afficher ou non automatiquement à chaque fois que vous validez une instance de document. Vous pouvez définir des délimiteurs une fois pour toute ou faire en sorte que l'Éditeur BizTalk affiche une invite lorsque vous testez chaque instance de façon à ce que vous puissiez spécifier des délimiteurs spécifiques.

Le tableau suivant répertorie les valeurs par défaut des délimiteurs.

Délimiteur | Valeur
Délimiteur d'enregistrement | ~ (0x7)
Délimiteur de champ | * (0x2a)
Délimiteur de sous-champ | > (0x3e)
Echappement | ? (0x3f)

Informations d'enveloppe

Selon les cas, vous pouvez être amené à ne pas spécifier de délimiteurs. Par exemple, si une instance contient des informations d'enveloppe qui incluent des informations de délimiteurs, l'Éditeur BizTalk peut alors déterminer automatiquement les délimiteurs requis à utiliser. Cependant, si les informations d'en-tête sont introuvables dans l'instance EDI en cours de validation, l'Éditeur BizTalk affiche la boîte de dialogue Délimiteurs de document qui permet de spécifier les délimiteurs.

Validation de documents au milieu d'échanges

L'Éditeur BizTalk valide uniquement le premier document dans une instance de document qui contient plusieurs documents. Vous pouvez toutefois valider un document qui existe au milieu d'un échange, ce qui signifie que le document n'est pas le premier dans l'échange. Pour cela, vous devez supprimer les informations d'en-tête et tous les documents qui précèdent celui qui est en cours de validation.

Champs vides et facultatifs dans des enregistrements

Si l'instance de document que vous utilisez contient dans un enregistrement des champs qui sont à la fois facultatifs et vides, vous devez ajouter un délimiteur de champ avant le délimiteur d'enregistrement. Par exemple, l'instance de document suivante contient un tilde (~) pour le délimiteur d'enregistrement. Toutefois, elle contient également le signe plus (+) qui indique le délimiteur de champ du premier enregistrement. Ceci suppose que vous définissiez le Délimiteur d'enregistrement sur ~ et le Délimiteur de champ sur + dans la boîte de dialogue Délimiteurs de document.

Instance de document contenant un tilde (~) pour le délimiteur d'enregistrement

Lorsque vous validez l'instance de document précédente en fonction de la spécification suivante, l'erreur suivante se produit :

While parsing record "Record1", the parser could not find the required leading delimiter:Lors de l'analyse de l'enregistrement "Record1", le parseur n'a pas trouvé le délimiteur de début requis : "+" (0x002b).
The parser failed to convert the document due to processing errors.Le parseur n'a pas pu convertir le document en raison d'erreurs de traitement. Voir les messages suivants pour plus de détails.

Valider une instance de document en fonction d'une spécification

Pour résoudre ce problème, ajoutez le caractère « + » entre « TTT » et le caractère « ~ » dans l'instance de document.

  • Avant d'utiliser une instance de document dans un environnement de production, il est vivement recommandé de valider cette instance en fonction de la spécification source et de résoudre les problèmes affichés sous l'onglet Avertissements.

Schémas Microsoft BizTalk Accelerator for HIPAA

Dans l'Éditeur BizTalk, vous pouvez affecter à l'option subdocument_creation_break la valeur « oui » pour les schémas de Microsoft BizTalk Accelerator for HIPAA. Dans cette instance, le parseur génère plusieurs instances de documents XML qui sont contenus dans le transport de données d'origine. Dans ces cas, la validation est identique aux validations EDI. Par exemple, les échanges sont répartis et les schémas sont validés en fonction du premier document de l'ensemble résultant de documents divisés.


Pourquoi effectuer des tâches dans l'Éditeur BizTalk

Cette section explique pourquoi il est nécessaire d'effectuer des tâches dans l'Éditeur BizTalk. Le tableau suivant présente les tâches principales et leurs sous-tâches. Il présente également l'objet de chaque tâche et fournit des liens vers les procédures correspondantes.

Tâche Objet de la tâche
  • Modification des options de l'Éditeur BizTalk
 Pour créer un nouveau champ en tant qu'élément. Ou bien, pour spécifier des délimiteurs de document par défaut à utiliser au cours du test d'une instance. La procédure présentée ici permet également d'afficher automatiquement la boîte de dialogue Délimiteurs de document à chaque fois que vous validez l'instance d'un document.
Création et validation de spécifications :
  • Création d'une spécification basée sur un standard
 Pour définir un processus conjointement avec un partenaire commercial et pour savoir comment utiliser les standards tels que X12 ou EDIFACT.

Ou bien, pour anticiper vos besoins en matière de standards pour la publication, si aucun accord ne régit encore vos relations avec vos partenaires commerciaux. Vous pouvez par exemple, envisager de définir votre organisation comme un service Web.
  • Création d'une spécification basée sur un fichier plat
 Si vous devez recourir à d'anciens systèmes qui utilisent des fichiers plats. Ou bien, si vous utilisez le système SAP (ou des applications similaires qui standardisent l'utilisation des fichiers plats) ou si ce sont vos partenaires commerciaux qui ont l'usage de telles applications.
  • Création d'une spécification basée sur un modèle vide
 Ce type de modèle est celui qui convient le mieux si vous procédez principalement à l'intégration EAI (Enterprise Application Integration) dans votre organisation. Ce modèle permet de commencer avec un seul nœud racine et de créer la structure requise en fonction des besoins réels.
  • Création d'une spécification basée sur une spécification existante
 Si vous ne maîtrisez pas les tâches permettant de mener une intégration EAI ou B2B (business-to-business), vous pouvez utiliser une spécification existante. Si vous échangez des données avec une organisation qui dispose d'une spécification existante facilement modifiable, son utilisation vous permettra de gagner du temps et d'éliminer les tâches inutiles.
  • Création d'une spécification basée sur un fichier importé
 Pour utiliser une spécification existante.
  • Création d'une spécification basée sur un fichier Microsoft Office
 Si vous utilisez principalement des applications telles que Microsoft Excel pour récupérer des données soit au sein de votre organisation, soit dans le cadre de vos échanges avec vos partenaires commerciaux. Par exemple, si vous souhaitez créer une spécification qui corresponde aux données saisies dans une note de frais par des employés au moyen d'une macro.
  • Validation d'une spécification
 Pour vous assurer que les enregistrements et les champs que vous avez définis dans votre spécification sont valides. Bien que l'Éditeur BizTalk signale la validité ou non de vos actions, il est possible que vous importiez un fichier dont la structure n'est pas valide. Vous êtes averti de la validité ou non d'une structure uniquement au moment où vous validez la spécification.
Ouverture, enregistrement et exportation de spécifications :
  • Ouverture de spécifications existantes à partir d'un disque local
 Si vous souhaitez travailler en local sur la copie d'une spécification. Vous pouvez par exemple, souhaiter modifier une spécification puis la tester sans modifier la copie partagée qui est stockée dans le référentiel WebDAV (Web Distributed Authoring and Versioning).
  • Ouverture de spécifications à partir de WebDAV
 Si vous devez travailler sur une copie partagée d'une spécification que d'autres utilisateurs peuvent également utiliser et modifier. Il s'agit du fichier que le Gestionnaire d'échanges de BizTalk utilise lorsqu'il traite des transactions.
  • Ouverture de spécifications existantes depuis des dossiers
 Si vous souhaitez travailler en local sur la copie d'une spécification. Vous pouvez par exemple, souhaiter modifier une spécification puis la tester sans modifier la copie partagée qui est stockée dans WebDAV.
  • Enregistrement de nouvelles spécifications
 Si vous souhaitez enregistrer en local la copie d'une spécification que vous venez de créer. Vous pouvez par exemple, souhaiter enregistrer la spécification que vous venez de créer sans que cela modifie la copie partagée qui est stockée dans WebDAV.
  • Enregistrement de spécifications existantes
 Si vous souhaitez enregistrer en local la copie de la spécification que vous venez de modifier. Vous pouvez par exemple, souhaiter enregistrer la spécification que vous venez de modifier sans que cela modifie la copie partagée qui est stockée dans WebDAV.
  • Stockage du schéma XDR dans WebDAV
 Vous ne pouvez pas stocker directement dans WebDAV des schémas purement XDR (XML-Data Reduced) (schémas non-BizTalk Server) en utilisant l'Éditeur BizTalk. Cependant, si vous devez le faire, faites en sorte que le schéma XDR soit utilisable dans le Gestionnaire d'échanges BizTalk via WebDAV. Le fichier sera ainsi également disponible pour les autres utilisateurs.
  • Stockage de spécifications
 Pour qu'une spécification soit disponible dans le Gestionnaire d'échanges BizTalk via WebDAV. Le fichier sera ainsi également disponible pour les autres utilisateurs.
  • Exportation de schémas XDR
 Pour envoyer une spécification BizTalk Server à un partenaire commercial qui ne dispose pas de BizTalk Server. Les annotations BizTalk Server des spécifications sont supprimées pendant le processus d'exportation, ce qui facilite au partenaire commercial l'utilisation du schéma final.
  • Exportation de schémas XSD
 Si vous devez envoyer des données que votre spécification présente à un partenaire commercial utilisant des Définitions XSD (eXtensible (XML) Structure Definitions).
Gestion d'enregistrements et de champs :
  • Ajout de nouveaux enregistrements au nœud racine

  • Ajout de nouveaux champs au nœud racine

  • Ajout de nouveaux enregistrements aux enregistrements existants

  • Ajout de nouveaux champs aux enregistrements

  • Insertion d'enregistrements

  • Insertion de champs
 Pour créer la structure d'une spécification ou modifier une structure existante.
  • Création d'un nouveau champ en tant qu'élément
 Si tous les nouveaux champs que vous ajoutez doivent être récurrents ou s'ils requièrent une structure.
  • Modification de champs d'attributs en éléments
 Si un champ existant doit être récurrent ou bien, s'il requiert une structure. Les éléments possèdent une structure, tandis que les attributs n'en ont pas.
  • Modification de champs d'éléments en attributs
 Si vous ne voulez pas qu'un champ ait une structure.
  • Déplacement d'enregistrements dans une spécification

  • Déplacement de champs dans une spécification

  • Déplacement d'enregistrements d'une spécification à une autre

  • Déplacement de champs d'une spécification à une autre
 Pour modifier la structure d'une ou de plusieurs spécifications. Choisir de déplacer des enregistrements et des champs d'une spécification vers une autre, plutôt que de les ajouter et d'ajouter des propriétés, permet de gagner du temps.
  • Copie d'enregistrements dans une spécification

  • Copie de champs dans une spécification

  • Copie d'enregistrements d'une spécification à une autre

  • Copie de champs d'une spécification à une autre
 Pour modifier la structure d'une ou de plusieurs spécifications. Choisir de copier des enregistrements et des champs, plutôt que d'en créer de nouveaux, permet de gagner du temps.
  • Création de références cycliques
 Si vous savez qu'il existe une structure récursive dans les données que BizTalk Server va traiter (c'est-à-dire, si un nœud est son propre descendant). Il est courant de rencontrer des structures récursives lors de l'utilisation d'éléments possédant plusieurs composants et sous-composants.
  • Création d'une nouvelle instance d'un enregistrement existant
 Si vous voulez recréer rapidement la même structure qu'un enregistrement existant.
  • Création d'une nouvelle instance d'un champ d'élément existant
 Si vous voulez recréer rapidement la même structure qu'un champ existant.
Spécification de propriétés pour les enregistrements et les champs :
  • Définition des séparateurs de document
 Si une structure est délimitée, vous devez définir des délimiteurs de document. Sinon, BizTalk Server ne peut pas traiter les données.
  • Définition des propriétés de déclaration
 Pour contrôler les propriétés des structures des données à un niveau global.
  • Définition des propriétés de référence
 Pour contrôler les propriétés des structures des données à un niveau local.
  • Définition des propriétés d'analyse
 Pour fournir des instructions relatives à la conversion des données non-XML.
  • Déclaration des espaces de noms
 Pour associer des annotations à plusieurs parties de votre spécification. Ceci évite d'utiliser l'espace de noms par défaut qui peut être associé à la spécification.
  • Ajout d'annotations personnalisées
 Pour noter qu'une spécification est associée à des instructions spécifiques. Par exemple, si vous utilisez un parseur, personnalisé, vous pouvez désirer ajouter des annotations personnalisées. Les annotations doivent faire partie d'un espace de noms.
  • Définition des propriétés du dictionnaire
 Toutes les opérations dans BizTalk Server sont associées à un ensemble de propriétés qui les décrivent. Si vous voulez ajouter un élément dans un ensemble de propriétés, vous devez définir des propriétés de dictionnaire. Vous souhaiterez vraisemblablement y ajouter des propriétés de routage ou d'enveloppe.
  • Ajout d'une propriété au dictionnaire personnalisé
 Pour définir une propriété personnalisée de dictionnaire. Reportez-vous à l'explication de la tâche « Définition des propriétés du dictionnaire ».
  • Sélection de codes
 Si votre spécification est basée sur une structure X12 ou EDIFACT, vous souhaiterez sélectionner des codes pour affecter à la propriété Type de données d'un champ la valeur Enumération et attribuer à Valeurs des types de données un code valide.
  • Suppression de codes
 Pour supprimer des codes ajoutés à un champ.
  • Calcul automatique des positions des champs
 Si vous utilisez une spécification avec une structure positionnelle et que vous avez prédéfini les valeurs de la propriété Longueur maximale, utilisez le calcul automatique des positions des champs pour calculer automatiquement le début et la fin de chaque champ.
Modification de notes et de règles syntaxiques :
  • Saisie de notes d'enregistrement
 Créez une documentation pour votre usage personnel et celui de la personne susceptible d'utiliser la spécification.
  • Affichage des règles syntaxiques
 Cet affichage est possible uniquement pour les spécifications basées sur des structures X12. Choisissez d'afficher ces informations si vous devez établir un mappage depuis ou vers une spécification X12 et que vous souhaitez vous assurer que la spécification respecte les règles syntaxiques standard.
  • Saisie de notes de champ
 Créez une documentation pour votre usage personnel et celui de la personne susceptible d'utiliser la spécification.
Gestion d'instances de document :
  • Création d'une instance de document
 Pour tester une spécification par rapport à une instance de données XML (Extensible Markup Language) ou non-XML.
  • Création d'une instance native
 Pour tester une spécification par rapport à une instance de données non-XML.
  • Validation d'une instance de document
 Pour s'assurer que la spécification est compatible avec les données qui doivent être transmises par son intermédiaire.
  • Gestion de tables de caractères incorrectes
 S'il existe des restrictions quant au type des caractères que l'application réceptrice peut gérer, vous souhaiterez spécifier les caractères qui ne sont pas autorisés.
Gestion des affichages et utilisation des touches de raccourci :
  • Développement des éléments de l'arborescence
 Pour visualiser l'ensemble des enregistrements et des champs d'une spécification à partir de l'enregistrement de nœud racine ou simplement les enregistrements et les champs à partir d'un seul enregistrement.
  • Réduction des éléments de l'arborescence
 Pour visualiser uniquement l'enregistrement du nœud racine et/ou les enregistrements parents.
  • Affichage des valeurs de propriétés
 Pour afficher les propriétés d'un enregistrement ou d'un champ définies au niveau des onglets Déclaration, Référence, Analyser, Espace de noms, Dictionnaire ou Liste de codes.
  • Modification de la taille du texte
 Pour augmenter ou réduire la taille du texte dans l'Éditeur BizTalk.
  • Touches de raccourci de l'Éditeur BizTalk
 Pour utiliser les touches de raccourci, au lieu de la souris, pour effectuer certaines tâches.


Comment utiliser l'Éditeur BizTalk

Cette section fournit des informations spécifiques aux tâches quant au mode de création de spécifications. Nous vous recommandons vivement de relire la rubrique À propos de l'Éditeur BizTalk, afin de comprendre parfaitement les relations entre les enregistrements et les champs ainsi que la méthode de définition des propriétés adaptées au type de spécifications que vous voulez créer.

Cette section traite des rubriques suivantes :

  • Modification des options de l'Éditeur BizTalk

  • Création et validation de spécifications

  • Ouverture de spécifications

  • Enregistrement, exportation et fermeture des spécifications

  • Gestion d'enregistrements et de champs

  • Spécification de propriétés pour les enregistrements et les champs

  • Modification des notes et affichage des règles syntaxiques

  • Gestion d'instances de document

  • Gestion de tables de caractères incorrectes

  • Gestion de vues

  • Touches de raccourci de l'Éditeur BizTalk


Modification des options de l'Éditeur BizTalk

  1. Pour afficher ou modifier les options dans la boîte de dialogue Options de l'Éditeur BizTalk, dans le menu Outils, cliquez sur Options.

  2. Dans l'onglet Général, vous pouvez activer la case à cocher Créer un nouveau champ en tant qu'élément.

    Pour plus d'informations sur cet onglet, voir Création d'un nouveau champ en tant qu'élément.

  3. Dans l'onglet Délimiteurs de document, vous pouvez spécifier des délimiteurs par défaut à utiliser au cours des tests d'instance et également spécifier si la boîte de dialogue Délimiteurs de document doit s'afficher ou non automatiquement à chaque fois que vous validez une instance de document.

    Pour plus d'informations sur cet onglet, voir Définition des délimiteurs de documents.

Voir aussi

Création d'un nouveau champ en tant qu'élément

Définition des délimiteurs de document


Création et validation de spécifications

Cette section explique comment créer une spécification en fonction du type de données utilisé. Par exemple, si vous utilisez un fichier plat délimité, vous devez créer une spécification basée sur ce fichier plat. Lorsque vous travaillez avec des spécifications, il est important de comprendre les questions se rapportant aux caractères non valides dans les noms XML (Extensible Markup Language) car si vous utilisez un caractère Unicode non valide dans un nom XML, ce caractère est converti en entité numérique d'échappement lorsque vous l'affichez dans l'arborescence de la spécification. Pour plus d'informations, voir Caractères de noms XML non valides.

Cette section traite des procédures suivantes :

  • Création d'une spécification basée sur un standard

  • Création d'une spécification basée sur un fichier plat

  • Création d'une spécification basée sur un modèle vide

  • Création d'une spécification basée sur une spécification existante

  • Création d'une spécification basée sur un fichier importé

  • Création d'une spécification basée sur un fichier Microsoft Office

  • Validation d'une spécification


Création d'une spécification basée sur un standard

  1. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Nouvelle spécification de document apparaît.

  2. Cliquez sur EDIFACT, X12 ou XML, puis cliquez sur OK.

    Si vous sélectionnez EDIFACT ou X12, vous devez également sélectionner une version. Cliquez sur le dossier de la version appropriée puis sur OK.

  3. Cliquez sur le type de spécification, puis sur OK.

  4. Suppression d'enregistrements, le cas échéant.

  5. Suppression de champs, le cas échéant.

  6. Suppression de codes, le cas échéant.

  7. Enregistrement de nouvelles spécifications.

Important

  • Si vous utilisez des modèles BizTalk Server au format X12 dans l'Éditeur BizTalk, vous risquez de rencontrer des problèmes et d'obtenir des messages d'erreur de ce type :

    La longueur du champ "ITD05" ("") n'est pas valide. Elle doit être comprise entre 48 et -1. Ce document va être rejeté.

    Les modèles X12 utilisent le type de données décimal implicite Nx. Si les données d'entrée contiennent un point décimal, les données de sortie ne correspondront pas au type de données personnalisé N, ce qui créera des instances non valides dans le fichier XML intermédiaire. Dans cette version de BizTalk Server, le sérialiseur risque de ne pas détecter, dans le fichier XML intermédiaire, la présence d'un point décimal dans les données de sortie de type N. Pour résoudre ce problème, remplacez manuellement le type de données décimal implicite dans les modèles X12 par n'importe quel autre type de données numérique.

Remarque

  • Les types de permutation de structure d'instance pris en charge par le parseur X12 présentent une restriction, à savoir qu'il ne peut y avoir de sauts de génération dans les segments HL (Hierarchy Level). Toute boucle ou segment HL doit se trouver exactement un niveau en dessous de la racine que sa boucle ou son segment parent HL, s'il en a un. Par exemple, HL/NM1/HL n'est pas pris en charge. En d'autres termes, une séquence 'x' donnée de niveaux d'imbrication doit répartir exactement les générations 'x' de profondeur dans l'arborescence.

Voir aussi

Gestion d'enregistrements et de champs

Spécification de propriétés pour les enregistrements et les champs

Définition des spécifications


Création d'une spécification basée sur un fichier plat

  1. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Nouvelle spécification de document apparaît.

  2. Cliquez sur Spécification vide, puis sur OK.

  3. Sélectionnez le nœud racine, puis cliquez sur l'onglet Référence.

  4. Double-cliquez dans le champ Valeur de la ligne Standard.

  5. Dans la liste Standard, cliquez sur PERSONNALISÉ.

  6. Appuyez sur ENTRÉE.

  7. Cliquez sur Oui pour confirmer la modification.

  8. Ajout de nouveaux enregistrements au nœud racine.

  9. Ajout de nouveaux enregistrements aux enregistrements existants.

  10. Ajout de nouveaux champs au nœud racine.

  11. Ajout de nouveaux champs aux enregistrements.

  12. Spécification de propriétés pour les enregistrements et les champs.

  13. Enregistrement de nouvelles spécifications.

Remarques

  • Dans l'onglet Analyse, vous devez définir la propriété Structure du nœud racine avec le paramètre Délimité si votre fichier plat est à la fois délimité et positionnel. Les propriétés supplémentaires des enregistrements sont définies sur Délimité ou Positionnel, comme requis. Pour plus d'informations, voir Utilisation de fichiers plats délimités et positionnels.

  • L'analyse des fichiers plats positionnels ne supprime pas un élément facultatif si celui-ci ne contient pas de données similaires à l'analyse des fichiers plats délimités. De plus, un élément sans valeur affecte le résultat du mappage.

  • Les fichiers plats basés sur la page de code UTF-8 ne sont pas pris en charge par l'Éditeur BizTalk.

Question d'ordre international

  • Les fichiers plats positionnels peuvent inclure des caractères codés sur 2 octets ou sur 1 octet dans une page de code. La plupart des applications qui prennent en charge les fichiers plats positionnels (de longue fixe) supposent que les chaînes de données sont alignées en octets et non en caractères. Ceci pose un problème pour traiter les chaînes de données dans les fichiers plats positionnels. Pour résoudre ce problème, considérez les fichiers positionnels dans lesquels figurent une combinaison de jeu de caractères codé sur deux octets (DBCS) et de jeu de caractères codés sur un octet (SBCS) comme étant délimités.

Voir aussi

Gestion d'enregistrements et de champs

Spécification de propriétés pour les enregistrements et les champs

Définition des spécifications

Utilisation de fichiers plats délimités et positionnels


Création d'une spécification basée sur un modèle vide

  1. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Nouvelle spécification de document apparaît.

  2. Cliquez sur Spécification vide, puis sur OK.

  3. Ajout de nouveaux enregistrements au nœud racine.

  4. Ajout de nouveaux enregistrements aux enregistrements existants.

  5. Ajout de nouveaux champs au nœud racine.

  6. Ajout de nouveaux champs aux enregistrements.

  7. Spécification de propriétés pour les enregistrements et les champs.

  8. Enregistrement de nouvelles spécifications.

Voir aussi

Gestion d'enregistrements et de champs

Spécification de propriétés pour les enregistrements et les champs

Définition des spécifications


Création d'une spécification basée sur une spécification existante

  1. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir la spécification de document s'affiche.

  2. Accédez à un dossier contenant une spécification existante.

  3. Cliquez sur un fichier dans la liste, puis sur Ouvrir.

  4. Le cas échéant, modifiez les spécifications.

  5. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer la spécification de document sous s'affiche.

  6. Dans la zone Nom de fichier, tapez le nom de la spécification.

  7. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez créer une spécification associée aux caractères ASCII, dans la liste Codage, cliquez sur UTF-8. Pour les spécifications associées aux caractères codés sur deux octets, dans la liste Codage, cliquez sur UTF-8 ou Unicode.

  8. Gestion d'enregistrements et de champs.

  9. Enregistrement de nouvelles spécifications.

Voir aussi

Valeurs et descriptions des listes de codes

Gestion d'enregistrements et de champs


Création d'une spécification basée sur un fichier importé

  1. Dans le menu Outils, cliquez sur Importer.

    La boîte de dialogue Sélectionnez le module d'importation s'affiche.

  2. Dans la boîte de dialogue Sélectionnez le module d'importation, cliquez sur Instance XML bien formée, Définition du type de document ou Schéma XDR, puis sur OK.

    Important

    • Vous ne pouvez pas importer une instance XML bien formée si elle contient un schéma XDR.

    • Si vous importez un fichier Microsoft Office, cliquez sur Instance XML bien formée.

    • Si vous importez un fichier réduit XDR (XML-Data Reduced), cliquez sur Schéma XDR.
  3. Dans la boîte de dialogue Importer, naviguez jusqu'au dossier dans lequel se trouve le fichier à importer, puis cliquez sur Ouvrir.

    Important

    • Si l'Éditeur BizTalk ne peut pas déterminer quel élément sera le nœud racine, la boîte de dialogue Sélectionnez l'élément racine s'affiche. Sélectionnez un élément racine dans la liste Éléments racine, puis cliquez sur OK. Pour plus d'informations, voir Importation de fichiers.

    • Lorsque vous ouvrez un schéma XDR non BizTalk Server dans l'Éditeur BizTalk, des messages d'erreur et/ou d'avertissement s'afficheront si des groupes d'éléments et/ou des espaces de noms sont présents dans le schéma.
  4. Ajout de nouveaux enregistrements au nœud racine.

  5. Ajout de nouveaux enregistrements aux enregistrements existants.

  6. Ajout de nouveaux champs au nœud racine.

  7. Ajout de nouveaux champs aux enregistrements.

  8. Spécification de propriétés pour les enregistrements et les champs.

  9. Enregistrement de nouvelles spécifications.

Important

  • Si un schéma contient un espace de noms URN (Uniform Resource Name) commençant par « x-schema: », il est possible que vous ne puissiez pas l'ouvrir dans l'Éditeur BizTalk. Vous devez alors supprimer la référence x-schema avant d'importer le fichier dans l'Éditeur BizTalk.

  • L'Éditeur BizTalk ne peut pas importer une DTD et/ou un schéma XDR contenant une référence cyclique figurant dans le nœud racine. Il peut importer un document XML correctement formé contenant une référence cyclique figurant dans le nœud racine, même si un avertissement s'affiche, indiquant que les références cycliques ne peuvent pas figurer dans le nœud racine d'un document. Pour plus d'informations, voir Références cycliques.

  • Si vous importez un fichier et que vous avez besoin d'une prise en charge de contenu mixte, l'instance que vous importez doit contenir un contenu mixte. Si ce n'est pas le cas, la valeur Contenu figurant dans l'onglet Déclaration ne sera pas définie sur Mixte.

Voir aussi

Importation de fichiers

Gestion d'enregistrements et de champs

Spécification de propriétés pour les enregistrements et les champs


Création d'une spécification basée sur un fichier Microsoft Office

  1. Dans le menu Outils, cliquez sur Importer.

    La boîte de dialogue Sélectionnez le module d'importation s'affiche.

  2. Cliquez sur Instance XML bien formée, puis sur OK.

  3. Dans la boîte de dialogue Importer, naviguez jusqu'au dossier dans lequel se trouve le fichier à importer, cliquez sur le fichier, puis cliquez sur Ouvrir.

    Important

    • Si l'Éditeur BizTalk ne peut pas déterminer quel élément sera le nœud racine, la boîte de dialogue Sélectionnez l'élément racine s'affiche. Sélectionnez un élément racine dans la liste Éléments racine, puis cliquez sur OK. Pour plus d'informations, voir Importation de fichiers.
  4. Ajout de nouveaux enregistrements au nœud racine.

  5. Ajout de nouveaux enregistrements aux enregistrements existants.

  6. Ajout de nouveaux champs au nœud racine.

  7. Ajout de nouveaux champs aux enregistrements.

  8. Spécification de propriétés pour les enregistrements et les champs.

  9. Enregistrement de nouvelles spécifications.

Voir aussi

Importation de fichiers

Gestion d'enregistrements et de champs

Spécification de propriétés pour les enregistrements et les champs


Validation d'une spécification

  1. Ouvrez une spécification ou importez un schéma.

    Pour plus d'informations, voir Ouverture de spécifications ou Création d'une spécification basée sur un fichier importé.

  2. Dans le menu Outils, cliquez sur Valider la spécification.

L'onglet Avertissements affiche les avertissements relatifs aux problèmes pouvant exister avec la structure de la spécification. Vous pouvez double-cliquer sur un avertissement pour afficher en rouge l'enregistrement ou le champ et la propriété associée dans les volets situés au-dessus.

Voir aussi

Création d'une spécification basée sur un fichier importé

Ouverture de spécifications


Ouverture de spécifications

Cette section traite des procédures suivantes :

  • Ouverture de spécifications existantes à partir d'un disque local

  • Ouverture de spécifications à partir de WebDAV

  • Ouverture de spécifications existantes depuis des dossiers


Ouverture de spécifications existantes à partir d'un disque local

  1. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir la spécification de document s'affiche.

  2. Recherchez le dossier contenant la spécification à ouvrir, cliquez sur la spécification puis sur Ouvrir.

Remarque

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez une spécification créée dans BizTalk Server 2000, puis l'enregistrez, le format du fichier sera modifié et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Ouverture de spécifications à partir de WebDAV


Ouverture de spécifications à partir de WebDAV

  1. Dans le menu Fichier, cliquez sur Extraire à partir de WebDav.

    La boîte de dialogue Extraire à partir de WebDav s'affiche.

  2. Dans la liste Serveur, tapez le nom du serveur et appuyez sur ENTRÉE.

    Vous pouvez également sélectionner le nom d'un serveur dans la liste.

    Important

    • Si le port du serveur proxy n'est pas 80, tapez la chaîne suivante dans la liste Serveur, http://<nom serveur>:<numéro port>, pour accéder aux fichiers stockés dans WebDAV.

    • Vous ne pouvez pas extraire des fichiers situés sur un serveur sécurisé. Par exemple, si le serveur est https://<nom serveur>/biztalkserverrepository, vous ne pourrez accéder à aucun fichier.
  3. Recherchez le dossier contenant la spécification à ouvrir, cliquez sur la spécification puis sur Ouvrir.

Important

  • Si, lorsque vous tentez d'ouvrir des spécifications existantes à partir de WebDAV, vous obtenez un message d'erreur du type : « Aucun référentiel BizTalk Server trouvé sur http://<nom serveur>/BizTalkServerRepository/DocSpecs », réenregistrez le fichier msdaipp.dll, puis redémarrez l'ordinateur. Pour plus d'informations sur le ré-enregistrement du fichier msdaipp.dll, voir Ré-enregistrement de msdaipp.dll pour extraire ou enregistrer des spécifications dans WebDAV.

  • Remarques

  • Il est possible que votre première connexion à un serveur WebDAV (Web Distributed Authoring and Versioning) distant soit lente lors d'une session.

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez une spécification créée dans BizTalk Server 2000, puis l'enregistrez, le format du fichier sera modifié et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Ouverture de spécifications existantes à partir d'un disque local

Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Ouverture de spécifications existantes à partir de WebDAV

  1. Cliquez sur Démarrer, pointez sur Programmes et sur Accessoires, puis cliquez sur Explorateur Windows.

  2. Recherchez le fichier à afficher dans l'Éditeur BizTalk.

    Si nécessaire, cliquez sur Niveau inférieur pour réduire la taille de la fenêtre de façon à voir la fenêtre de l'Éditeur BizTalk.

  3. Faites glisser le fichier vers le volet Arborescence de la spécification.

Remarque

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez une spécification créée dans BizTalk Server 2000, puis l'enregistrez, le format du fichier sera modifié et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.


Enregistrement, exportation et fermeture des spécifications

Cette section traite des procédures suivantes :

  • Enregistrement de nouvelles spécifications

  • Enregistrement de spécifications existantes

  • Stockage du schéma XDR dans WebDAV

  • Stockage de spécifications

  • Exportation de schémas XDR

  • Exportation de schémas XSD

  • Fermeture de spécifications


Enregistrement de nouvelles spécifications

  1. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer la spécification de document sous s'affiche.

  2. Dans la zone Nom de fichier, entrez un nom pour le fichier.

  3. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez enregistrer des spécifications associées aux caractères ASCII, dans la liste Codage, cliquez sur UTF-8. Pour les spécifications associées aux caractères codés sur deux octets, dans la liste Codage, cliquez sur UTF-8 ou Unicode.

Remarque

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez une spécification créée dans BizTalk Server 2000, puis l'enregistrez, le format du fichier sera modifié et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.


Enregistrement de spécifications existantes

  • Dans le menu Fichier, cliquez sur Enregistrer.

Remarques

  • Lorsque vous enregistrez un fichier, l'Éditeur BizTalk stocke le fichier sur votre disque dur. Pour enregistrer un fichier dans WebDAV (Web Distributed Authoring and Versioning), vous devez disposer de l'autorisation pour stocker le fichier sur le serveur.

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez une spécification créée dans BizTalk Server 2000, puis l'enregistrez, le format du fichier sera modifié et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Stockage de spécifications


Stockage du schéma XDR dans WebDAV

Vous ne pouvez pas stocker directement dans WebDAV des schémas purement XDR (schémas non-BizTalk Server) en utilisant l'Éditeur BizTalk. Pour cela, vous devez exécuter la procédure suivante.

  1. Exécutez la procédure relative à l'Enregistrement de nouvelles spécifications ou à l'Enregistrement de spécifications existantes.

  2. Cliquez sur Démarrer, pointez sur Programmes et sur Accessoires, puis cliquez sur Explorateur Windows.

  3. Naviguez jusqu'à l'emplacement WebDAV dans lequel vous voulez stocker le fichier.

  4. Accédez à l'emplacement dans lequel vous avez enregistré le schéma purement XDR.

  5. Faites glisser le fichier de l'emplacement dans lequel il est enregistré vers le dossier WebDAV.

Questions d'ordre international

  • Dans le référentiel WebDAV, les fichiers doivent être enregistrés en codages Unicode uniquement. Toutefois, le référentiel WebDAV ne peut pas stocker des fichiers ayant des noms dans différentes pages de code.

  • WebDAV ne prend pas en charge les caractères Unicode dans les noms de fichier.

  • Assurez-vous que les paramètres régionaux du système sont définis dans votre langue. Par exemple, les utilisateurs internationaux qui installent la version anglaise de BizTalk Server 2002 sur une version anglaise de Windows et souhaitent utiliser, dans les noms de fichier, des caractères qui ne sont pas pris en charge dans la page de code Latin I (Windows 1252 comprenant l'anglais), doivent modifier leurs paramètres régionaux système en paramètres régionaux utilisateur.

  • Vous ne pouvez pas stocker des fichiers dont les noms comportent des jeux de caractères codés sur deux octets si vos paramètres régionaux sont incorrects. Pour résoudre ce problème, voir ???.xml apparaît dans la boîte de dialogue WebDAV.


Stockage de spécifications

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

    La boîte de dialogue Stocker dans WebDav s'affiche.

  2. Dans la liste Serveur, tapez le nom du serveur et appuyez sur ENTRÉE.

    Vous pouvez également sélectionner le nom d'un serveur dans la liste.

    Important

    • Si le port du serveur proxy n'est pas 80, tapez la chaîne suivante dans la liste Serveur, http://<nom serveur>:<numéro port>, pour stocker les fichiers dans WebDAV.

    • Vous ne pouvez pas stocker des fichiers sur un serveur sécurisé. Par exemple, si le serveur est https://<nom serveur>/biztalkserverrepository, vous ne pourrez stocker aucun fichier.
  3. Sélectionnez le dossier dans lequel vous voulez stocker votre spécification.

  4. Dans la zone Nom de fichier, entrez le nom du fichier.

  5. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez stocker des spécifications associées aux caractères ASCII, dans la liste Codage, cliquez sur UTF-8. Pour les spécifications associées aux caractères codés sur deux octets, dans la liste Codage, cliquez sur UTF-8 ou Unicode.

Questions d'ordre international

  • Dans le référentiel WebDAV, les fichiers doivent être enregistrés en codages Unicode uniquement. Toutefois, le référentiel WebDAV ne peut pas stocker des fichiers ayant des noms dans différentes pages de code.

  • WebDAV ne prend pas en charge les caractères Unicode dans les noms de fichier.

  • Assurez-vous que les paramètres régionaux du système sont définis dans votre langue. Par exemple, les utilisateurs internationaux qui installent la version anglaise de BizTalk Server 2002 sur une version anglaise de Windows et souhaitent utiliser, dans les noms de fichier, des caractères qui ne sont pas pris en charge dans la page de code Latin I (Windows 1252 comprenant l'anglais), doivent modifier leurs paramètres régionaux système en paramètres régionaux utilisateur.

  • Vous ne pouvez pas stocker des fichiers dont les noms comportent des jeux de caractères codés sur deux octets si vos paramètres régionaux sont incorrects. Pour résoudre ce problème, voir ???.xml apparaît dans la boîte de dialogue WebDAV.

Important

  • Si, lorsque vous tentez de stocker des spécifications dans WebDAV, vous obtenez un message d'erreur du type : « Aucun référentiel BizTalk Server trouvé sur http://<nom serveur>/BizTalkServerRepository/DocSpecs », réenregistrez le fichier msdaipp.dll, puis redémarrez l'ordinateur. Pour plus d'informations sur le ré-enregistrement du fichier msdaipp.dll, voir Ré-enregistrement de msdaipp.dll pour extraire ou stocker des fichiers dans WebDAV.

Remarques

  • Il est possible que votre première connexion à un serveur WebDAV (Web Distributed Authoring and Versioning) distant soit lente.

  • Lorsque vous enregistrez un fichier dans WebDAV, l'Éditeur BizTalk l'enregistre sur un serveur. Pour enregistrer un fichier sur votre disque dur, dans le menu Fichier, cliquez sur Enregistrer sous.

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez une spécification créée dans BizTalk Server 2000, puis l'enregistrez, le format du fichier sera modifié et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Enregistrement de spécifications existantes

Enregistrement de nouvelles spécifications

Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Exportation de schémas XDR

  1. Dans le menu Outils, cliquez sur Exporter le schéma XDR.

    La boîte de dialogue Exporter le schéma XDR sous s'affiche.

  2. Naviguez jusqu'à l'emplacement vers lequel vous voulez exporter le fichier réduit XDR (XML-Data Reduced).

  3. Dans la zone Nom de fichier, entrez un nom pour le fichier.

  4. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez exporter des spécifications associées aux caractères ASCII, dans la liste Codage, cliquez sur UTF-8. Pour les spécifications associées aux caractères codés sur deux octets, dans la liste Codage, cliquez sur UTF-8 ou Unicode.

Voir aussi

Ouverture de spécifications

Exportation de schémas XSD


Exportation de schémas XSD

Avant d'exporter un schéma XSD (Extensible Structure Definitions), enregistrez le fichier.

  1. Dans le menu Outils, cliquez sur Exporter le schéma XSD.

    La boîte de dialogue Exporter le schéma XSD sous s'affiche.

  2. Naviguez jusqu'à l'emplacement vers lequel vous voulez exporter le fichier XSD.

  3. Dans la zone Nom de fichier, tapez le nom du fichier, puis cliquez sur Enregistrer.

Remarques

  • Si la spécification contient un espace de noms cible et si vous utilisez la fonctionnalité Exporter le schéma XSD pour exporter le fichier, le schéma XSD exporté ne contiendra pas d'espace de noms cible. Pour résoudre ce problème, ouvrez le fichier XSD exporté dans le Bloc-Notes et ajoutez-lui manuellement l'espace de noms cible.

  • Par défaut, les fichiers XSD exportés sont au format UTF-16.

Voir aussi

Ouverture de spécifications

Exportation de schémas XDR


Fermeture de spécifications

  • Dans le menu Fichier, cliquez sur Fermer.


Gestion d'enregistrements et de champs

Cette section traite des procédures suivantes :

  • Ajout de nouveaux enregistrements au nœud racine

  • Ajout de nouveaux champs au nœud racine

  • Ajout de nouveaux enregistrements aux enregistrements existants

  • Ajout de nouveaux champs aux enregistrements

  • Insertion d'enregistrements

  • Insertion de champs

  • Création d'un nouveau champ en tant qu'élément

  • Modification de champs d'attributs en éléments

  • Modification de champs d'éléments en attributs

  • Déplacement d'enregistrements dans une spécification

  • Déplacement de champs dans une spécification

  • Déplacement d'enregistrements d'une spécification à une autre

  • Déplacement de champs d'une spécification à une autre

  • Copie d'enregistrements dans une spécification

  • Copie de champs dans une spécification

  • Copie d'enregistrements d'une spécification à une autre

  • Copie de champs d'une spécification à une autre

  • Affectation d'un nouveau nom à un enregistrement unique

  • Affectation d'un nouveau nom à un champ unique

  • Affectation de nouveaux noms à tous les enregistrements dont le nom est identique

  • Suppression d'enregistrements

  • Suppression de champs

  • Création de références cycliques

  • Création d'une nouvelle instance d'un enregistrement existant

  • Création d'une nouvelle instance d'un champ d'élément existant


Ajout de nouveaux enregistrements au nœud racine

  1. Cliquez sur le nœud racine.

  2. Dans le menu Edition, cliquez sur Nouvel enregistrement.

    Un enregistrement enfant s'insère après le dernier nœud dans l'arborescence de la spécification.

  3. Tapez le nom de l'enregistrement, puis appuyez sur ENTRÉE.

Remarques

  • Dans le cas d'un fichier non-XML (un fichier plat par exemple), vous pouvez entrer une propriété Identifiant de la balise source afin d'identifier la balise dans le fichier source non-XML.

  • Des enregistrements frères ne peuvent pas porter le même nom.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Spécification de propriétés pour les enregistrements et les champs


Ajout de nouveaux champs au nœud racine

  1. Cliquez sur le nœud racine.

  2. Dans le menu Edition, cliquez sur Nouveau champ.

    Un champ enfant s'insère après le dernier nœud dans l'arborescence de la spécification.

  3. Tapez le nom du champ, puis appuyez sur ENTRÉE.

Remarques

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Modification de champs d'éléments en attributs

Création d'un nouveau champ en tant qu'élément

Spécification de propriétés pour les enregistrements et les champs


Ajout de nouveaux enregistrements aux enregistrements existants

  1. Cliquez sur un enregistrement.

  2. Dans le menu Edition, cliquez sur Nouvel enregistrement.

    Un enregistrement enfant s'insère directement après l'enregistrement sélectionné ou après le dernier nœud enfant de l'enregistrement sélectionné.

  3. Tapez le nom de l'enregistrement, puis appuyez sur ENTRÉE.

Remarques

  • Dans le cas d'un fichier non-XML (un fichier plat par exemple), vous pouvez entrer une propriété Identifiant de la balise source afin d'identifier la balise dans le fichier source non-XML.

  • Des enregistrements frères ne peuvent pas porter le même nom.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Spécification de propriétés pour les enregistrements et les champs


Ajout de nouveaux champs aux enregistrements

  1. Cliquez sur un enregistrement.

  2. Dans le menu Edition, cliquez sur Nouveau champ.

    Un enregistrement enfant s'insère directement après l'enregistrement sélectionné ou après le dernier nœud enfant de l'enregistrement sélectionné.

  3. Tapez le nom du champ, puis appuyez sur ENTRÉE.

Remarques

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Modification de champs d'éléments en attributs

Création d'un nouveau champ en tant qu'élément

Spécification de propriétés pour les enregistrements et les champs


Insertion d'enregistrements

  1. Cliquez sur un enregistrement.

  2. Dans le menu Edition, cliquez sur Insérer un enregistrement.

    Un enregistrement frère s'insère directement après l'enregistrement sélectionné ou après le dernier nœud enfant de l'enregistrement sélectionné.

  3. Tapez le nom de l'enregistrement, puis appuyez sur ENTRÉE.

Remarques

  • Des enregistrements frères ne peuvent pas porter le même nom.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Spécification de propriétés pour les enregistrements et les champs


Insertion de champs

  1. Cliquez sur l'enregistrement ou le champ après lequel vous souhaitez insérer un champ.

  2. Dans le menu Edition, cliquez sur Insérer un champ.

    Un champ frère s'insère directement après l'enregistrement sélectionné ou après le dernier nœud enfant de l'enregistrement sélectionné.

  3. Tapez le nom du champ, puis appuyez sur ENTRÉE.

Remarques

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Modification de champs d'éléments en attributs

Création d'un nouveau champ en tant qu'élément

Spécification de propriétés pour les enregistrements et les champs


Création d'un nouveau champ en tant qu'élément

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options de l'Éditeur BizTalk s'affiche.

  2. Activez la case à cocher Créer un nouveau champ en tant qu'élément et cliquez sur OK.

Remarques

  • Si cette case à cocher est désactivée, les champs sont créés en tant qu'attributs. Cependant, si vous l'activez, tous les nouveaux champs sont créés en tant qu'éléments.

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Voir aussi

Modification de champs d'éléments en attributs


Modification de champs d'attributs en éléments

  1. Cliquez sur un champ dans l'arborescence de la spécification.

  2. Dans l'onglet Déclaration, cliquez deux fois sur le champ Valeur de la ligne Type.

    Les paramètres en cours sont définis sur Attribut.

  3. Dans la liste Type, cliquez sur Élément et appuyez sur ENTRÉE.

  4. Cliquez sur Oui pour confirmer la modification.

Remarque

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Voir aussi

Modification de champs d'éléments en attributs

Création d'un nouveau champ en tant qu'élément


Modification de champs d'éléments en attributs

  1. Cliquez sur un champ dans l'arborescence de la spécification.

  2. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur dans la ligne Type.

    Les paramètres en cours sont définis sur Élément.

  3. Dans la liste Type, cliquez sur Attribut et appuyez sur ENTRÉE.

  4. Cliquez sur Oui pour confirmer la modification.

Remarque

  • Les champs frères ne peuvent pas porter le même nom, sauf si la propriété Type d'un champ correspond à Attribut et la propriété Type de l'autre champ correspond à Élément.

Voir aussi

Modification de champs d'attributs en éléments


Déplacement d'enregistrements dans une spécification

  1. Cliquez sur le nœud racine.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur l'enregistrement que vous voulez déplacer et faites-le glisser vers un autre nœud de l'arborescence.

    Lorsque vous relâchez le bouton de la souris, si le pointeur de la souris se trouve dans la partie supérieure de texte du nœud mis en surbrillance, l'enregistrement est inséré au-dessus du nœud en tant qu'enregistrement frère. Si le pointeur de la souris se trouve dans la partie inférieure de texte du nœud mis en surbrillance, l'enregistrement est inséré sous le nœud en tant qu'enregistrement frère. Si le pointeur de la souris se trouve dans la partie droite de texte du nœud mis en surbrillance, l'enregistrement est inséré sous le nœud en tant qu'enregistrement enfant.

Voir aussi

Copie d'enregistrements d'une spécification à une autre

Copie d'enregistrements dans une spécification

Déplacement d'enregistrements d'une spécification à une autre


Déplacement de champs dans une spécification

  1. Cliquez sur le nœud racine.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur le champ que vous voulez déplacer et faites-le glisser vers un autre nœud de l'arborescence.

    Lorsque vous relâchez le bouton de la souris, si le pointeur de la souris se trouve dans la partie supérieure de texte du nœud mis en surbrillance, le champ est inséré au-dessus du nœud en tant que champ frère. Si le pointeur de la souris se trouve dans la partie inférieure de texte du nœud mis en surbrillance, le champ est inséré sous le nœud en tant que champ frère. Si le pointeur de la souris se trouve dans la partie droite de texte du nœud mis en surbrillance, le champ est inséré sous le nœud en tant qu'enregistrement enfant.

Voir aussi

Copie de champs d'une spécification à une autre

Copie de champs dans une spécification

Déplacement de champs d'une spécification à une autre


Déplacement d'enregistrements d'une spécification à une autre

  1. Cliquez sur le nœud racine dans la spécification contenant l'enregistrement que vous voulez déplacer.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur l'enregistrement que vous voulez déplacer, puis dans le menu Edition, cliquez sur Couper.

  4. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2002, puis cliquez sur Éditeur BizTalk.

    Vous devez ouvrir une seconde instance de l'Éditeur BizTalk pour ouvrir une autre spécification.

  5. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir la spécification de document s'affiche.

  6. Naviguez jusqu'au dossier contenant la spécification dans laquelle vous voulez copier l'enregistrement.

  7. Sélectionnez le fichier dans la liste, puis cliquez sur Ouvrir.

  8. Cliquez sur le nœud racine dans la spécification.

  9. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  10. Cliquez sur un nœud racine, un enregistrement ou un champ après lequel vous voulez insérer l'enregistrement.

  11. Dans le menu Edition, cliquez sur Coller.

Remarque

  • Si vous déplacez un enregistrement qui porte le même nom qu'un enregistrement existant, l'Éditeur BizTalk ajoute automatiquement un chiffre après son nom.

Voir aussi

Copie d'enregistrements d'une spécification à une autre

Copie d'enregistrements dans une spécification

Déplacement d'enregistrements dans une spécification


Déplacement de champs d'une spécification à une autre

  1. Cliquez sur le nœud racine dans la spécification contenant le champ que vous voulez déplacer.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur le champ que vous voulez déplacer, puis dans le menu Edition, cliquez sur Couper.

  4. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2002, puis cliquez sur Éditeur BizTalk.

    Vous devez ouvrir une seconde instance de l'Éditeur BizTalk pour ouvrir une autre spécification.

  5. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir la spécification de document s'affiche.

  6. Naviguez jusqu'au dossier contenant la spécification dans laquelle vous voulez copier l'enregistrement.

  7. Sélectionnez le fichier dans la liste, puis cliquez sur Ouvrir.

  8. Cliquez sur le nœud racine dans la spécification vers laquelle vous souhaitez déplacer le champ.

  9. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  10. Cliquez sur le nœud racine, l'enregistrement ou le champ après lequel vous voulez insérer le champ.

  11. Dans le menu Edition, cliquez sur Coller.

Remarque

  • Si vous déplacez un champ qui porte le même nom qu'un champ existant, l'Éditeur BizTalk ajoute automatiquement un chiffre après son nom.

Voir aussi

Copie de champs d'une spécification à une autre

Copie de champs dans une spécification

Déplacement de champs dans une spécification


Copie d'enregistrements dans une spécification

  1. Cliquez sur le nœud racine.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Sélectionnez l'enregistrement que vous voulez copier, puis dans le menu Edition, cliquez sur Copier.

  4. Cliquez sur le nœud après lequel voulez insérer l'enregistrement, puis dans le menu Edition, cliquez sur Coller.

    Si le nœud sélectionné est un enregistrement, un enregistrement enfant est inséré directement après le nœud sélectionné. Si le nœud sélectionné est un champ, un enregistrement frère est inséré directement après le nœud sélectionné.

Important

  • Si l'enregistrement que vous copiez est l'enregistrement au niveau du nœud racine, tous les enregistrements et les champs enfants sont copiés, à l'exception de l'enregistrement au niveau du nœud racine lui-même. Si vous voulez que cet enregistrement soit inclus dans la spécification, vous devez le créer manuellement.

Voir aussi

Copie d'enregistrements d'une spécification à une autre

Déplacement d'enregistrements d'une spécification à une autre

Déplacement d'enregistrements dans une spécification


Copie de champs dans une spécification

  1. Cliquez sur le nœud racine.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur le champ que vous voulez copier, puis dans le menu Edition, cliquez sur Copier.

  4. Cliquez sur le nœud après lequel voulez insérer le champ, puis dans le menu Edition, cliquez sur Coller.

    Si le nœud sélectionné est un enregistrement, un champ enfant est inséré directement après le nœud sélectionné. Si le nœud sélectionné est un champ, un champ frère est inséré directement après le nœud sélectionné.

Voir aussi

Copie de champs d'une spécification à une autre

Déplacement de champs d'une spécification à une autre

Déplacement de champs dans une spécification


Copie d'enregistrements d'une spécification à une autre

  1. Cliquez sur le nœud racine dans la spécification contenant l'enregistrement que vous voulez copier.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Sélectionnez l'enregistrement que vous voulez copier, puis dans le menu Edition, cliquez sur Copier.

  4. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2002, puis cliquez sur Éditeur BizTalk.

    Vous devez ouvrir une seconde instance de l'Éditeur BizTalk pour ouvrir une autre spécification.

  5. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir la spécification de document s'affiche.

  6. Naviguez jusqu'au dossier contenant la spécification dans laquelle vous voulez copier l'enregistrement.

  7. Sélectionnez le fichier dans la liste, puis cliquez sur Ouvrir.

  8. Cliquez sur le nœud racine dans la spécification vers laquelle vous voulez copier l'enregistrement.

  9. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  10. Cliquez sur le nœud racine, l'enregistrement ou le champ après lequel vous voulez insérer l'enregistrement, puis dans le menu Edition, cliquez sur Coller.

    Si le nœud sélectionné est un enregistrement, un enregistrement enfant est inséré directement après le nœud sélectionné. Si le nœud sélectionné est un champ, un enregistrement frère est inséré directement après le nœud sélectionné.

Important

Si l'enregistrement que vous copiez est l'enregistrement au niveau du nœud racine, tous les enregistrements et les champs enfants sont copiés, à l'exception de l'enregistrement au niveau du nœud racine lui-même. Si vous voulez que cet enregistrement soit inclus dans la spécification, vous devez le créer manuellement.

Remarque

  • Si vous copiez un enregistrement qui porte le même nom qu'un enregistrement existant, l'Éditeur BizTalk ajoute automatiquement un chiffre après son nom.

Voir aussi

Copie d'enregistrements dans une spécification

Déplacement d'enregistrements d'une spécification à une autre

Déplacement d'enregistrements dans une spécification


Copie de champs d'une spécification à une autre

  1. Cliquez sur le nœud racine dans la spécification contenant le champ que vous voulez copier.

  2. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  3. Cliquez sur le champ que vous voulez copier, puis dans le menu Edition, cliquez sur Copier.

  4. Dans le menu Démarrer, pointez sur Programmes, Microsoft BizTalk Server 2002, puis cliquez sur Éditeur BizTalk.

    Vous devez ouvrir une seconde instance de l'Éditeur BizTalk pour ouvrir une autre spécification.

  5. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir la spécification de document s'affiche.

  6. Naviguez jusqu'au dossier contenant la spécification vers laquelle vous voulez déplacer le champ.

  7. Sélectionnez le fichier dans la liste, puis cliquez sur Ouvrir.

  8. Cliquez sur le nœud racine dans la spécification vers laquelle vous voulez copier le champ.

  9. Dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

  10. Cliquez sur le nœud racine, l'enregistrement ou le champ après lequel vous voulez coller l'enregistrement puis, dans le menu Edition, cliquez sur Coller.

    Si le nœud sélectionné est un enregistrement, un champ enfant est inséré directement après le nœud sélectionné. Si le nœud sélectionné est un champ, un champ frère est inséré directement après le nœud sélectionné.

Remarque

  • Si vous copiez un champ qui porte le même nom qu'un champ existant, l'Éditeur BizTalk ajoute automatiquement un chiffre après son nom.

Voir aussi

Copie de champs dans une spécification

Déplacement de champs d'une spécification à une autre

Déplacement de champs dans une spécification


Affectation d'un nouveau nom à un enregistrement unique

  1. Cliquez sur l'enregistrement que vous voulez renommer.

  2. Dans le menu Edition, cliquez sur Renommer.

  3. Tapez le nouveau nom de l'enregistrement, puis appuyez sur ENTRÉE.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Affectation de nouveaux noms à tous les enregistrements dont le nom est identique

Affectation d'un nouveau nom à un champ unique


Affectation d'un nouveau nom à un champ unique

  1. Cliquez sur le champ que vous souhaitez renommer.

  2. Dans le menu Edition, cliquez sur Renommer.

  3. Tapez le nouveau nom du champ, puis appuyez sur ENTRÉE.

Remarques

  • Les champs correspondant à des éléments ne peuvent pas porter le même nom qu'un enregistrement existant.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Affectation de nouveaux noms à tous les enregistrements dont le nom est identique

Affectation d'un nouveau nom à un enregistrement unique


Affectation de nouveaux noms à tous les enregistrements dont le nom est identique

  1. Sélectionnez un enregistrement dont vous voulez modifier le nom.

  2. Dans le menu Edition, cliquez sur Renommer tout <nom enregistrement>.

  3. Tapez un nouveau nom pour les enregistrements.

    Tous les enregistrements dont le nom est identique sont renommés.

Remarques

  • Cette commande est uniquement disponible dans le menu Edition si au moins deux enregistrements portent le même nom.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Affectation d'un nouveau nom à un champ unique

Affectation d'un nouveau nom à un enregistrement unique


Suppression d'enregistrements

  1. Cliquez sur l'enregistrement que vous voulez supprimer.

  2. Dans le menu Edition, cliquez sur Supprimer.

  3. Dans la boîte de dialogue de confirmation, cliquez sur Oui.

Attention

  • Lorsque vous supprimez un enregistrement, tous les enregistrements et champs enfants sont également supprimés.

Voir aussi

Suppression de champs


Suppression de champs

  1. Cliquez sur le champ que vous voulez supprimer.

  2. Dans le menu Edition, cliquez sur Supprimer.

  3. Dans la boîte de dialogue de confirmation, cliquez sur Oui.

Voir aussi

Suppression d'enregistrements


Création de références cycliques

  1. Sélectionnez un enregistrement sous lequel vous voulez créer une référence cyclique.

    Il s'agit de l'enregistrement de base.

  2. Dans le menu Edition, cliquez sur Nouvel enregistrement.

  3. Affectez au nouvel enregistrement un nom identique à celui de l'enregistrement de base et appuyez sur ENTRÉE.

    Une référence cyclique icône de référence cyclique est créée.

  4. Dans l'onglet Déclaration, double-cliquez sur le champ Valeur dans la ligne Nombre de cycles.

  5. Tapez un chiffre compris entre 1 et 7 et appuyez sur ENTRÉE.

Important

  • La propriété Occurrences minimales de l'onglet Référence pour le nœud de référence cyclique doit être définie avec la valeur 0. Une propriété définie avec la valeur 1 entraînera une boucle infinie.

Remarque

  • Les références cycliques ne peuvent pas être utilisées dans les spécifications non-XML. Assurez-vous que vous utilisez une spécification XML.

Voir aussi

Références cycliques


Création d'une nouvelle instance d'un enregistrement unique

  1. Cliquez sur un nœud où vous voulez créer une nouvelle instance d'un enregistrement existant.

  2. Dans le menu Edition, cliquez sur Nouvel enregistrement ou Insérer un enregistrement.

    Remarque

    • Si vous avez sélectionné un champ à l'étape 1, l'option Nouvel enregistrement n'est pas disponible dans le menu Edition.
  3. Affectez au nouvel enregistrement un nom identique à celui de l'enregistrement existant et appuyez sur ENTRÉE.

    Vous venez de créer deux instances du même enregistrement.

Important

  • Vous ne pouvez pas affecter à un nouvel enregistrement un nom identique à celui d'un enregistrement frère.

  • Si vous affectez à un nouvel enregistrement un nom identique à celui d'un enregistrement parent, vous créez une référence cyclique et non une nouvelle instance de l'enregistrement existant. Pour plus d'informations, voir Références cycliques.

Remarques

  • Si vous cliquez sur Nouvel enregistrement, la nouvelle instance de l'enregistrement est insérée en tant que descendant de l'enregistrement sélectionné.

  • Si vous cliquez sur Insérer un enregistrement, la nouvelle instance de l'enregistrement est insérée en tant que frère de l'enregistrement ou du champ sélectionné.

  • La structure des nœuds sous les instances d'un enregistrement est identique ; si vous supprimez ou ajoutez un nœud à une instance d'un enregistrement, cette modification est automatiquement répercutée dans toutes les autres instances de l'enregistrement. Certaines propriétés d'instances d'enregistrement sont identiques et d'autres peuvent être définies indépendamment pour chacune des instances. Pour plus d'informations sur les propriétés identiques ou indépendantes des instances d'enregistrement, voir Portée des propriétés.

  • Une nouvelle instance d'un enregistrement existant ne peut pas porter le même nom qu'un enregistrement existant.

  • Pour créer une nouvelle instance d'un enregistrement existant vous pouvez aussi appuyer sur CTRL et faire glisser un enregistrement existant vers la partie droite du nœud sous lequel vous voulez insérer la nouvelle instance.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Références cycliques

Portée des propriétés


Création d'une nouvelle instance d'un champ d'élément existant

  1. Sélectionnez un nœud où vous voulez créer une nouvelle instance d'un champ d'élément.

    Remarque

    • Vous pouvez uniquement créer plusieurs instances de champs de type Élément (dans l'onglet Déclaration). Vous ne pouvez pas créer plusieurs instances de champs de type Attribut. Si vous créez deux champs d'attribut ou plus de nom identique, ces champs demeurent totalement indépendants les uns des autres.
  2. Dans le menu Edition, cliquez sur Nouveau champ ou Insérer un champ.

    Remarque

    • Si vous avez sélectionné un champ à l'étape 1, l'option Nouveau champ n'est pas disponible dans le menu Edition.
  3. Affectez au nouveau champ un nom identique à celui du champ existant et appuyez sur ENTRÉE.

    Vous venez de créer deux instances du même champ.

Important

  • Une nouvelle instance de champ d'élément ne peut pas porter le même nom qu'une instance de champ d'élément frère.

Remarques

  • Si vous cliquez sur Nouveau champ, la nouvelle instance du champ est insérée en tant que descendant de l'enregistrement sélectionné.

  • Si vous cliquez sur Insérer un champ, la nouvelle instance du champ est insérée en tant que frère de l'enregistrement ou du champ sélectionné.

  • Certaines propriétés d'instances de champ sont identiques et d'autres peuvent être définies indépendamment pour chacune des instances. Pour plus d'informations sur les propriétés identiques ou indépendantes des instances de champ, voir Portée des propriétés.

  • Deux champs existants ne peuvent pas porter le même nom, sauf si la propriété Type de l'un est définie avec le paramètre Attribut et celle de l'autre avec Élément.

  • Pour créer une nouvelle instance d'un champ d'élément existant vous pouvez aussi appuyer sur CTRL et faire glisser un champ d'élément existant vers la partie droite du nœud sous lequel vous voulez insérer la nouvelle instance.

Question d'ordre international

  • Si vous utilisez l'éditeur IME pour taper des caractères coréens dans les noms de champ ou d'enregistrement de l'Éditeur BizTalk, celui-ci active les noms dupliqués même si un message d'erreur s'affiche lorsque vous tentez d'affecter un nom existant à l'enregistrement ou au champ. L'Éditeur BizTalk active également la saisie des noms d'enregistrement ou de champ incorrects avec l'éditeur IME coréen, ce qui, en temps normal, n'aurait pas été autorisé. Pour résoudre ce problème, supprimez l'enregistrement ou le champ non valide.

Voir aussi

Références cycliques

Portée des propriétés


Spécification de propriétés pour les enregistrements et les champs

Cette section contient des informations sur les rubriques suivantes :

  • Définition des délimiteurs de document

  • Définition des propriétés de déclaration

  • Définition des propriétés de référence

  • Définition des propriétés d'analyse

  • Déclaration des espaces de noms

  • Ajout d'annotations personnalisées

  • Modification d'annotations personnalisées

  • Suppression d'annotations personnalisées

  • Définition des propriétés du dictionnaire

  • Ajout d'une propriété au dictionnaire personnalisé

  • Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

  • Suppression d'une propriété du dictionnaire

  • Suppression d'une propriété du dictionnaire personnalisé

  • Sélection de codes

  • Suppression de codes

  • Suppression d'une propriété d'un champ dans la colonne Valeur

  • Calcul automatique des positions des champs


Définition des délimiteurs de document

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options de l'Éditeur BizTalk s'affiche.

  2. Cliquez sur l'onglet Délimiteurs de document.

  3. Sélectionnez une option dans chacune des listes suivantes :
    • Délimiteur d'enregistrement

    • Délimiteur de champ

    • Délimiteur de sous-champ

    • Caractère d'échappement

    Important

    • Si vous spécifiez vos propres délimiteurs, utilisez des valeurs en caractères Unicode. Pour obtenir la liste des caractères valide, accédez à la page Pages de code globales sur le site Web Microsoft Global Software Development ( www.microsoft.com/globaldev/reference/wincp.asp)). Vous pouvez utiliser des codes de caractères ANSI dans la mesure où ceux-ci sont identiques au code de caractères Unicode, à l'exception des deux zéros de tête.
  4. Si vous souhaitez afficher l'onglet Délimiteurs de document à chaque fois que vous validez une instance de document de façon à spécifier des délimiteurs de document uniques, cliquez sur Demander les délimiteurs au cours du test d'instance.

Important

  • Si vous êtes invité à spécifier les délimiteurs au cours du test d'une instance parce que la case Demander les délimiteurs au cours du test d'instance est activée, les délimiteurs que vous spécifiez sont utilisés uniquement pour tester l'instance concernée. Les délimiteurs spécifiés dans l'onglet Délimiteurs de document restent les délimiteurs par défaut.

  • La terminaison (ou délimiteur) Null n'est pas prise en charge. Supprimez le délimiteur Null du fichier plat.

Remarque

  • Si l'instance contient plusieurs documents et des informations d'enveloppe (en-tête et fin de document), seul le premier document est validé en fonction des délimiteurs de document spécifiés dans Délimiteurs de document.


Définition des propriétés de déclaration

  1. Dans l'arborescence de la spécification, cliquez sur le nœud racine, l'enregistrement ou le champ pour lequel vous voulez définir une propriété, puis cliquez sur l'onglet Déclaration.

  2. Double-cliquez sur le champ dans la colonne Valeur associée à la propriété que vous voulez définir.

  3. Entrez des données dans le champ ou cliquez sur la flèche BAS pour effectuer une sélection parmi une liste d'options disponibles.

  4. Appuyez sur ENTRÉE pour valider vos modifications.

L'onglet Déclaration contient les propriétés décrites dans les tables ci-après. Les propriétés que vous sélectionnez sont définies pour le nœud racine, pour un enregistrement ou un champ, suivant le nœud que vous avez sélectionné.

Onglet Déclaration : Propriétés du nœud racine

Propriété | Valeur
Nom Nom du nœud racine.

Remarque

  • Si vous modifiez la valeur Nom dans l'onglet Déclaration, le nom du nœud racine dans l'arborescence de la spécification sera automatiquement modifié en conséquence. Dans une nouvelle spécification, si vous modifiez la valeur Nom dans l'onglet Déclaration, la valeur Nom de la déclaration sera également modifiée dans l'onglet Référence. Cependant, comme un nom de spécification peut être différent de celui du nœud racine, une modification de la valeur Nom de la spécification n'a aucun effet sur la valeur Nom, ni sur le nom du nœud racine dans l'arborescence de la spécification. Lorsque la valeur Nom de la spécification a été modifiée, une modification de la valeur Nom ou du nom du nœud racine n'a aucun effet sur la valeur Nom de la spécification.
Description | Description de la spécification.
Type | Type d'enregistrement. Cette valeur est toujours définie sur Élément pour le nœud racine.
Modèle Fermé. Indique que les données contenues dans l'instance de document et la structure de la spécification correspondent.

Ouvert. Indique que les données contenues dans l'instance de document et la structure de la spécification risquent de ne pas correspondre.

Important

  • Si vous modifiez la valeur de Contenu de Texte seul par Élément seul et la valeur de Modèle de Fermé par Ouvert, les valeurs de propriété de l'onglet Dictionnaire resteront associées à la spécification et le fichier ne transitera pas correctement par le moteur de BizTalk Server.

Remarque

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est Ouvert.
Contenu Élément seul. Indique que l'enregistrement peut uniquement contenir des éléments. Il s'agit de la valeur par défaut lorsque l'enregistrement contient un enregistrement enfant.

Mixte. Indique que le nœud racine peut comporter un contenu mixte (des informations de texte ainsi que des sous-éléments). Cette propriété n'est disponible que si la valeur de Standard est XML.

Important

  • Le nœud racine peut avoir uniquement la valeur Contenu définie sur Élément seul ou Mixte car elle contient des enregistrements enfants.

  • L'élément peut contenir une combinaison d'éléments nommés et de texte. Mixte est la valeur par défaut. Si la valeur de l'attribut du contenu est mixte, les attributs Occurrences minimales et Occurrences maximales ne déclencheront pas d'erreur de validation si le nombre d'éléments enfants est supérieur à la limite spécifiée.

  • Lorsqu'un élément contient un contenu mixte, par exemple des données contenant des éléments enfants, et que vous avez sélectionné Copier la valeur texte (valeur par défaut) dans le Mappeur BizTalk, seul le contenu figurant jusqu'au premier élément enfant est copié. Exemple :
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Résultat de la copie de Item.

  • Lorsqu'un élément contient un contenu mixte, par exemple des données contenant des éléments enfants, et que vous vous avez sélectionné Copier le texte et la valeur du sous-contenu dans le Mappeur BizTalk, tout le contenu, y compris les éléments enfants, est copié. Exemple :
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Résultat de la copie de Item1121314Number.

Remarque

  • Si vous sélectionnez Mixte, vous devez sélectionner Plusieurs pour la valeur de la propriété Ordre.
Ordre Si la Structure est XML, sélectionnez une des valeurs suivantes :
  • Plusieurs. Indique que plusieurs éléments constitutifs peuvent apparaître, quel que soit l'ordre sélectionné.

  • Un. Indique qu'un seul des éléments constitutifs peut apparaître.

  • Séquence. Indique que les éléments constitutifs doivent apparaître dans l'ordre spécifié.

Remarque

  • Si Plusieurs est sélectionné, aucune valeur de Occurrence minimale et de Occurrence maximale n'est prise en compte pour les enregistrements enfants.

Onglet Déclaration : Propriétés des enregistrements

Propriété | Valeur
Nom | Nom de l'enregistrement.
Description | Description de l'enregistrement.
Type | Type d'enregistrement.
Type de données Type de données valide. Pour obtenir la liste et la description de tous les types de données valides, voir Résumé des types de données et des valeurs de types de données.

Important

  • Si la propriété du type Contenu est Texte seul, vous pouvez spécifier une propriété Type de données.
Valeurs des types de données Si vous sélectionnez Énumération dans la liste Type de données, les valeurs de type de données a b c s'affichent par défaut dans la zone Valeurs des types de données. Les valeurs par défaut peuvent être remplacées par des valeurs personnalisées séparées par des espaces.

Si vous utilisez un document X12 ou EDIFACT et intégrez des codes associés à un champ spécifique, ces codes s'affichent automatiquement dans la zone Valeurs des types de données, et la valeur Énumération s'affiche automatiquement dans la zone Type de données.

Important

  • Si la propriété du type Contenu est Texte seul, vous pouvez spécifier une propriété Valeur du type de données.

  • Vous ne pouvez pas utiliser le signe dièse (#), l'esperluette (&) ou les deux points (:) en tant que Valeurs des types de données.
Modèle Fermé. Indique que les données contenues dans l'instance de document et la structure de la spécification correspondent.

Ouvert. Indique que les données contenues dans l'instance de document et la structure de la spécification risquent de ne pas correspondre.

Important

  • Si vous modifiez la valeur de Contenu de Texte seul par Élément seul et la valeur de Modèle de Fermé par Ouvert, les valeurs de propriété de l'onglet Dictionnaire resteront associées à la spécification et le fichier ne transitera pas correctement par le moteur de BizTalk Server.

Remarque

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est Ouvert.
Contenu Élément seul. Indique que l'enregistrement peut uniquement contenir des éléments. Il s'agit de la valeur par défaut lorsque l'enregistrement contient un enregistrement enfant.

Vide. Indique que l'enregistrement ne peut pas contenir de sous-éléments.

Texte seul. Indique que l'enregistrement peut contenir du texte mais pas de sous-éléments.

Mixte. Indique que le nœud racine peut comporter un contenu mixte (des informations de texte ainsi que des sous-éléments).

Important

  • Les enregistrements avec des enregistrements enfants peuvent avoir uniquement la valeur Contenu définie sur Élément seul ou Mixte. Si un enregistrement ne possède pas d'enregistrements enfants, les valeurs Vide et Texte seule sont également disponibles dans la liste.

  • L'élément peut contenir une combinaison d'éléments nommés et de texte. Mixte est la valeur par défaut. Si la valeur de l'attribut du contenu est mixte, les attributs Occurrences minimales et Occurrences maximales ne déclencheront pas d'erreur de validation si le nombre d'éléments enfants est supérieur à la limite spécifiée.

  • Si vous modifiez la valeur de Contenu de Texte seul par Élément seul et la valeur de Modèle de Fermé par Ouvert, les valeurs de propriété de l'onglet Dictionnaire resteront associées à la spécification et le fichier ne transitera pas correctement par le moteur de BizTalk Server.

  • Lorsqu'un élément contient un contenu mixte, par exemple des données contenant des éléments enfants, et que vous avez sélectionné Copier la valeur texte (valeur par défaut) dans le Mappeur BizTalk, seul le contenu figurant jusqu'au premier élément enfant est copié. Exemple :
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Résultat de la copie de Item.

  • Lorsqu'un élément contient un contenu mixte, par exemple des données contenant des éléments enfants, et que vous vous avez sélectionné Copier le texte et la valeur du sous-contenu dans le Mappeur BizTalk, tout le contenu, y compris les éléments enfants, est copié. Exemple :
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Résultat de la copie de Item1121314Number.

Remarques

  • Si vous sélectionnez Texte seul, vous pouvez spécifier les propriétés Type de données et Valeurs des types de données.

  • Si vous sélectionnez Mixte, vous devez sélectionner Plusieurs pour la valeur de la propriété Ordre.
Ordre Si la Structure est XML, sélectionnez une des valeurs suivantes :
  • Plusieurs. Indique que plusieurs éléments constitutifs peuvent apparaître, quel que soit l'ordre sélectionné.

  • Un. Indique qu'un seul des éléments constitutifs peut apparaître.

  • Séquence. Indique que les éléments constitutifs doivent apparaître dans l'ordre spécifié.

Remarque

  • Si Plusieurs est sélectionné, aucune valeur de Occurrence minimale et de Occurrence maximale n'est prise en compte pour les enregistrements enfants.
Nombre de cycles Entrez le nombre de cycles qui seront disponibles sous l'enregistrement de base. Pour plus d'informations, voir Références cycliques.

Remarque

  • Ce champ de propriété s'affiche uniquement si vous avez créé une référence cyclique. La valeur par défaut est 7.

Onglet Déclaration : Propriétés des champs

Propriété | Valeur
Nom | Nom du champ.
Description | Description du champ.
Type Sélectionnez l'une des valeurs suivantes :
  • Élément

  • Attribut

Remarque

  • Si la structure de la spécification est positionnelle, il n'est pas recommandé de spécifier Élément en tant que valeur Type. Si vous procédez ainsi, la validation risque d'échouer.
Modèle Fermé. Indique que les données contenues dans l'instance de document et la structure de la spécification correspondent.

Ouvert. Indique que les données contenues dans l'instance de document et la structure de la spécification risquent de ne pas correspondre.

Remarques

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est Ouvert.

  • La propriété Modèle est disponible uniquement pour un champ dont la valeur Type est définie sur Élément.
Contenu Texte seul. Indique que le champ peut contenir du texte mais pas de sous-éléments.

Remarques

  • La propriété Contenu est disponible uniquement pour un champ dont la valeur Type est définie sur Élément.

  • Texte seul est la seule valeur disponible pour la propriété Contenu d'un champ.
Type de données Type de données valide. Pour obtenir la liste et la description de tous les types de données valides, voir Synthèse des types de données et des valeurs de types de données.

Important

  • Si la valeur de la propriété Standard dans l'onglet Référence est définie sur X12, EDIFACT ou Personnalisé, vous pouvez affecter une valeur Type de données personnalisé dans l'onglet Analyse. Si vous spécifiez une valeur Type de données personnalisé, la valeur de Type de données est automatiquement modifiée afin qu'elle corresponde à la valeur Type de données personnalisé que vous avez sélectionnée.

  • Dans une spécification, si vous créez un champ avec la propriété Type de données définie sur IDREF ou IDREFS, vous devez en créer un autre dans cette spécification avec le champ Type de données défini sur ID.

  • Pour sélectionner un champ pour le suivi ou l'utilisation d'une expression de filtrage dans le Gestionnaire d'échanges BizTalk, vous devez affecter un type de données à ce champ dans la spécification.
Valeurs des types de données Si vous sélectionnez Énumération dans la liste Type de données, les valeurs de type de données a b c s'affichent par défaut dans la zone Valeurs des types de données. Les valeurs par défaut peuvent être remplacées par des valeurs personnalisées séparées par des espaces.

Si vous utilisez un document X12 ou EDIFACT et intégrez des codes associés à un champ spécifique, ces codes s'affichent automatiquement dans la zone Valeurs des types de données, et la valeur Énumération s'affiche automatiquement dans la zone Type de données.

Important

  • Vous ne pouvez pas utiliser le signe dièse (#) ou l'esperluette (&) en tant que Valeurs des types de données.
Longueur minimale Nombre minimal de caractères pouvant être contenus dans le champ.

Remarques

  • La propriété Longueur minimale peut uniquement être définie pour les champs dont les valeurs Type de données sont les suivantes : Chaîne, Nombre, Binaire (base64) et Binaire (hex).

  • Si une décimale implicite est spécifiée pour la propriété Type de données personnalisé, il n'est pas recommandé de spécifier une valeur Longueur minimale. Si malgré tout vous devez spécifier une valeur Longueur minimale, celle-ci doit être inférieure à Nx, où x représente un nombre entre 1 et 9. La valeur Nx est disponible dans la liste des propriétés Type de données personnalisé.
Longueur maximale Nombre maximal de caractères pouvant être contenus dans le champ.

Remarque

  • La propriété Longueur maximale peut uniquement être définie pour les champs dont les valeurs Type de données sont les suivantes : Chaîne, Nombre, Binaire (base64) et Binaire (hex).
Valeur par défaut Tapez une valeur numérique. Pour plus d'informations, voir Intégration des valeurs par défaut.

Remarques

  • La propriété Valeur par défaut s'affiche dans les spécifications uniquement si la propriété Standard (dans l'onglet Référence pour le nœud racine) est définie sur XML, et la propriété Type (dans l'onglet Déclaration pour le champ) est définie sur Attribut.

  • Vous ne pouvez pas utiliser les caractères suivants :
    • L'accent grave (`)

    • L'apostrophe (')

    • L'astérisque (*)

    • La barre oblique inverse (\)

    • Les accolades ({ })

    • Les crochets ([ ])

    • Le signe d'insertion (^)

    • Les deux points (:)

    • La virgule (,)

    • Le signe dollar ($)

    • Le signe égal à (=)

    • Le point d'exclamation (!)

    • Le signe pour cent (%)

    • Le point (.)

    • La barre verticale (|)

    • Le signe plus (+)

    • Le point d'interrogation (?)

    • Le point-virgule (;)

    • La barre oblique (/)

    • Le tilde (~)

Voir aussi

Ajout d'une expression de filtrage à un canal

Limites de longueur des caractères

Références cycliques

Intégration des valeurs par défaut

Sélection des champs de spécification dans un canal

Sélection des champs de spécification dans une définition de document

Résumé des types de données et des valeurs de types de données


Définition des propriétés de référence

  1. Dans l'arborescence de la spécification, cliquez sur le nœud racine, l'enregistrement ou le champ pour lequel vous voulez définir une propriété, puis cliquez sur l'onglet Référence.

  2. Double-cliquez sur le champ dans la colonne Valeur associée à la propriété que vous voulez définir.

  3. Entrez des données dans le champ de la colonne Valeur ou cliquez sur la flèche BAS pour effectuer une sélection parmi une liste d'options disponibles.

L'onglet Référence contient les propriétés décrites dans les tables ci-après. Les propriétés que vous sélectionnez sont définies pour le nœud racine, pour un enregistrement ou un champ, suivant le nœud que vous avez sélectionné.

Onglet Référence : Propriétés du nœud racine

Propriété | Valeur
Nom de la spécification | Nom de la spécification. Celui-ci correspond à la valeur de la balise <Schema> dans la spécification.
Standard Sélectionnez l'une des valeurs suivantes :
  • XML pour créer une spécification XML (Extensible Markup Language).

  • X12 pour créer une spécification X12.

  • EDIFACT pour créer une spécification EDIFACT.

  • PERSONNALISÉ pour créer une spécification basée sur un fichier plat ou pour créer une spécification personnalisée à analyser avec un parseur personnalisé.

Important

  • Si vous modifiez la valeur de la propriété Standard de X12 par PERSONNALISÉ (par exemple, pour les fichiers plats), puis sélectionnez un champ et définissez la valeur Type des données personnalisé dans l'onglet Analyse sur Nombre (N) ou Nombre (Nx), où x représente un nombre compris entre 1 et 9, la propriété Longueur maximale personnalisée dans l'onglet Analyse correspondant au champ ne s'affiche pas. C'est pourquoi, vous devez augmenter la valeur de Longueur maximale dans l'onglet Déclaration pour pouvoir obtenir une sortie analysée ou sérialisée des résultats lorsqu'une spécification est convertie en format décimal implicite et vice versa.
Version du Standard | Version du standard, telle que la version X12 4010, sur laquelle est basée la spécification.
Type de document | Type de document, tel que 850, sur lequel est basée la spécification.
Version | Numéro de version du standard de document sur lequel est basée la spécification.
Délimiteur d'enregistrement par défaut Tapez ou sélectionnez un caractère à utiliser comme délimiteur dans un nœud pour lequel la propriété Type de délimiteur dans l'onglet Analyse est définie sur Délimiteur d'enregistrement par défaut.

Remarque

  • Ce champ de propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le nœud racine) est défini sur PERSONNALISÉ.
Délimiteur de champ par défaut Tapez ou sélectionnez un caractère à utiliser comme délimiteur dans un nœud pour lequel la propriété Type de délimiteur dans l'onglet Analyse est définie sur Délimiteur de champ par défaut.

Important

  • La succession des délimiteurs au niveau du champ, qui sont généralement au format ANSI X12 version 4030 et ultérieure, n'est pas prise en charge.

Remarque

  • Ce champ de propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le nœud racine) est défini sur PERSONNALISÉ.
Délimiteur de sous-champ par défaut Tapez ou sélectionnez un caractère à utiliser comme délimiteur dans un nœud pour lequel la propriété Type de délimiteur dans l'onglet Analyse est définie sur Délimiteur de sous-champ par défaut.

Remarque

  • Ce champ de propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le nœud racine) est défini sur PERSONNALISÉ.
Caractère d'échappement par défaut Tapez ou sélectionnez un caractère à utiliser comme caractère d'échappement dans un nœud pour lequel la propriété Type d'échappement dans l'onglet Analyse est définie sur Caractère d'échappement par défaut.

Remarque

  • Ce champ de propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le nœud racine) est défini sur PERSONNALISÉ.
Page de code Sélectionnez l'une des options suivantes :
  • Arabe (1256)

  • Balte (1257)

  • Europe centrale (1250)

  • Cyrillique (1251)

  • Grec (1253)

  • Hébreux (1255)

  • Japonais-Maj-JIS (932)

  • Coréen (949)

  • Little-Endian-UTF16 (1200)

  • Chinois simplifié-GBK (936)

  • Thaï 874

  • Chinois-tra-Big5 (950)

  • Turc (1254)

  • Vietnamien (1258)

  • Europe de l'Ouest (1252)

Remarques

  • Ce champ de propriété s'affiche uniquement si le champ Standard dans l'onglet Référence (pour le nœud racine) est défini sur PERSONNALISÉ.

  • BizTalk Server ne prend pas en charge les options UTF7 (65000) et UTF8 (65001).

  • Si aucune valeur Page de code n'est indiquée, la valeur par défaut est Europe de l'Ouest (1252).
Accusé de réception Choisissez une des options suivantes :
  • Oui. Indique que la spécification doit être utilisée comme accusé de réception d'un document entrant. Un composant de corrélation (X12, EDIFACT ou PERSONNALISÉ) doit effectuer une corrélation entre l'accusé de réception du document et le document sortant approprié (c'est-à-dire le document envoyé précédemment à l'expéditeur de l'accusé de réception).

  • Non. Indique que la spécification ne doit pas être utilisée comme accusé de réception d'un document entrant.

Remarques

  • Si la valeur d'accusé de réception est vide, la valeur par défaut est Non.

  • Pour les spécifications basées sur l'accusé de réception standard, et pour celles qui sont mappées sur l'accusé de réception standard (ces spécifications sont utilisées dans les scénarios de génération d'accusé de réception d'un document sortant), la propriété Accusé de réception doit avoir pour valeur Non.
Enveloppe Choisissez une des options suivantes :
  • Oui. Indique que la spécification est une spécification d'échange.

  • Non. Indique que la spécification n'est pas une spécification d'échange.

Remarques

  • Cette propriété concerne uniquement les fichiers plats et les fichiers XML pour les enveloppes.

  • Si la valeur est vide, la valeur par défaut est Non.
Espace de noms cible Si vous disposez d'une instance BizTalk Framework et si vous avez spécifié un espace de noms dans celle-ci, vous devez entrer l'espace de noms correspondant utilisé dans l'instance.

Remarque

  • La valeur d'espace de noms cible « x-schema » d'une instance peut entraîner une erreur lors du test de l'instance dans le Mappeur BizTalk.

Onglet Référence : Propriétés des enregistrements

Propriété Valeur
Occurrences minimales Nombre d'occurrences minimales d'un enregistrement à son emplacement dans la hiérarchie du nœud. Les valeurs possibles sont 0 et 1.

Remarque

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est 1.
Occurrences maximales Nombre d'occurrences maximales d'un enregistrement à son emplacement dans la hiérarchie du nœud. Les valeurs possibles sont 1 et l'astérisque (*).

Remarques

  • Si vous entrez un astérisque (*), l'enregistrement est considéré comme un enregistrement en boucle. Si cette spécification est utilisée dans le Mappeur BizTalk, celle-ci compile l'enregistrement en tant que boucle. Si vous entrez 1, le Mappeur BizTalk ne considère pas cet enregistrement comme un enregistrement de bouclage.

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est 1.

Onglet Référence : Propriétés des champs

Propriété Valeur
Requis Choisissez une des options suivantes :
  • Oui. Indique que le champ est requis.

  • Non. Indique que le champ n'est pas requis.

Remarque

  • Si aucune valeur n'est indiquée pour cette propriété, la valeur par défaut est Non.
Position de début Nombre indiquant la position de début du champ dans l'enregistrement.

Remarque

  • Le champ de cette propriété s'affiche uniquement si la structure de l'enregistrement parent est positionnelle.
Position de fin Nombre indiquant la position de fin du champ dans l'enregistrement.

Remarque

  • Le champ de cette propriété s'affiche uniquement si la structure de l'enregistrement parent est positionnelle.

Voir aussi

Calcul des positions des champs

Limites de longueur des caractères

Description des accusés de réception


Définition des propriétés d'analyse

  1. Dans l'arborescence de la spécification, cliquez sur le nœud racine, l'enregistrement ou le champ pour lequel vous voulez définir une propriété, puis cliquez sur l'onglet Analyse.

  2. Double-cliquez sur le champ dans la colonne Valeur associée à la propriété que vous voulez définir.

  3. Entrez des données dans le champ ou cliquez sur la flèche BAS pour effectuer une sélection parmi une liste d'options disponibles.

L'onglet Analyse contient les propriétés décrites dans les tables ci-après. Les propriétés disponibles dépendent du standard (X12, EDIFACT ou PERSONNALISÉ) et de la propriété de la structure utilisés. Par défaut, les nouvelles spécifications basées sur une spécification vide possèdent une propriété du standard XML (Extensible Markup Language). Pour chaque propriété, entrez la valeur appropriée. Les propriétés que vous sélectionnez sont définies pour le nœud racine, pour un enregistrement ou un champ, suivant le nœud que vous avez sélectionné.

Standard : XML

Onglet Analyse : Nœud racine, enregistrement et propriétés du champ.

Ces propriétés ne s'affichent pas.

Standard : X12 ou EDIFACT

Important

  • Les valeurs Retour de ligne, Caractères tampon, Caractères d'échappement et Délimiteur d'un enregistrement et de ses champs enfants s'excluent mutuellement.

Onglet Analyse : Nœud racine ou propriétés de l'enregistrement

Propriété Valeur
Structure Par défaut, cette valeur est définie sur Délimité pour le nœud racine.

Remarque

  • Si la valeur de la propriété Standard est définie sur X12 ou EDIFACT dans l'onglet Référence pour le nœud racine d'une spécification, vous ne pouvez pas modifier la valeur de la propriété Structure dans l'onglet Analyse pour le nœud racine ou les enregistrements. Pour modifier la valeur de la propriété Structure, vous devez définir le standard sur PERSONNALISÉ.
Identifiant de la balise source Le nom de l'identifiant de la balise source. Correspond au nom de balise utilisé pour faire correspondre l'enregistrement avec les données.

Important

  • Lorsque vous avez un enregistrement en boucle et que les données de l'instance ne contiennent pas de structure en boucle (c'est-à-dire que la structure est implicite et non explicite), assurez-vous que la valeur de Identificateur de la balise source est vide.

Remarques

  • Dans le cas d'un fichier non-XML, comme un fichier plat, vous pouvez introduire une propriété Identificateur de la balise source pour identifier n'importe quelle balise pouvant exister dans le fichier d'origine. Un Identificateur de balise source ne peut pas contenir les caractères suivants : < > " &

  • La propriété Identificateur de la balise source respecte la casse.
Ordre des champs Sélectionnez l'une des options suivantes :
  • Préfixe. Un préfixe délimiteur s'affiche avant chaque composant et chaque membre d'un composant dans une série. Par exemple, lorsque le délimiteur est un astérisque (*) : *a*a*b*c.

  • Postfix. Un postfix délimiteur s'affiche après chaque composant et chaque membre d'un composant dans une série. Par exemple, où * est le délimiteur : a*a*b*c*.

  • Infix. Un infix délimiteur s'affiche entre les composants et membres des composants d'une série. Par exemple, où * est le délimiteur : a*a*b*c.

Remarques

  • Pour la plupart des fichiers non-XML, la propriété Ordre des champs du nœud racine doit être définie sur Postfix et les nœuds des enregistrements en boucle doivent être définis sur Infix. Vous pouvez obtenir des exemples sur cette méthode dans les dossiers Flat-FileDelimited et Flat-FilePositional situés dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\.

  • Si aucune valeur n'est indiquée pour Ordre des champs, la valeur par défaut est Préfixe.
Type de délimiteur Sélectionnez l'une des options suivantes pour définir un délimiteur pour les nœuds enfants situés directement sous le nœud en cours :
  • Délimiteur d'enregistrement par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur d'enregistrement par défaut, définie dans l'instance du document.

  • Délimiteur de champ par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur de champ par défaut, définie dans l'instance du document.

  • Délimiteur de sous-champ par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur de sous-champ par défaut, définie dans l'instance du document.
Type d'échappement

(Également appelé caractère d'échappement)

 Sélectionnez l'une des options suivantes pour définir un caractère d'échappement pour les nœuds enfants situés directement sous le nœud en cours :
  • Caractère d'échappement par défaut Indique que le caractère d'échappement est une valeur définie dans l'instance du document.

Cette propriété est utile lorsqu'un caractère d'échappement de vos données de champ est également utilisé en guise de caractère de délimiteur pour le nœud parent du champ. Par exemple, si les données du champ sont les suivantes et si vous avez choisi une virgule comme valeur de délimiteur du nœud qui contient le champ, l'Éditeur BizTalk interprète la virgule après « Brown » comme étant un délimiteur, même si vous voulez qu'elle fasse partie des données du champ :

Brown,Robert,1231,oui

Pour résoudre ce problème, vous pouvez faire précéder d'un caractère d'échappement le caractère délimiteur que vous voulez inclure dans les données du champ. Par exemple, si le caractère d'échappement est spécifié comme étant la barre oblique inverse, vous pouvez placer une barre oblique inverse directement devant le caractère délimiteur, comme dans l'exemple suivant :

Brown\,Robert,1231,yes

L'Éditeur BizTalk interprète la virgule située après la barre oblique inverse comme des données du champ plutôt que comme un caractère délimiteur.

Remarque

  • La propriété Type d'échappement n'est pas disponible pour les spécifications X12.
Ajouter une nouvelle ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique que lorsque le sérialiseur atteint le délimiteur d'enregistrement, il doit ajouter automatiquement une nouvelle ligne (LF,0x0A).

  • Non. Indique que lorsque le sérialiseur atteint le délimiteur d'enregistrement, il doit continuer sur la même ligne pour l'enregistrement suivant.

Remarque

  • Si aucune valeur n'est indiquée pour Ajouter une nouvelle ligne, la valeur par défaut est Non.
Ignorer le retour chariot Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur d'ignorer le caractère de retour chariot (RC) situé après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Retour chariot après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Ignorer le retour chariot, la valeur par défaut est Oui.
Ignorer le saut de ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur qu'il doit ignorer la valeur Saut de ligne après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Saut de ligne après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Saut de ligne, la valeur par défaut est Oui.
Ignorer le nombre d'enregistrements Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur ou au sérialiseur qu'il ne doit pas compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

  • Non. Indique au parseur ou au sérialiseur qu'il doit compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

Remarques

  • Une erreur d'analyse se produit lorsqu'une instance de document est soumise à BizTalk Server 2002, si le nombre d'enregistrements de l'instance du document ne correspond pas au nombre d'enregistrements calculés dans la spécification. Pour plus d'informations, voir Erreurs d'analyse.

  • Si aucune valeur n'est indiquée pour Ignorer le nombre d'enregistrements, la valeur par défaut est Oui.
Champ déclencheur Sélectionnez une des options de la liste. Les options correspondent aux champs déclencheurs disponibles.

Important

  • Cette propriété n'est disponible que si Standard est défini sur X12.

Remarque

  • Pour plus d'informations sur les champs déclencheurs, voir Déclencheurs généraux.
Valeur du déclencheur Cette valeur représente la valeur de type de données du champ déclencheur.

Important

  • Cette propriété n'est disponible que si Standard est défini sur X12.

Remarque

  • Si vous utilisez le schéma Microsoft® BizTalk™ Accelerator for HIPAA, ne modifiez pas les valeurs des propriétés de déclencheur.
Saut de création de sous-document Sélectionnez l'une des options suivantes :
  • Oui. Indique à l'analyseur ou au sérialiseur qu'il doit créer une nouvelle instance qui réplique toute la hiérarchie parente de l'enregistrement.

  • Non. Indique à l'analyseur ou au sérialiseur qu'il ne doit pas créer une nouvelle instance qui réplique toute la hiérarchie parente de l'enregistrement.

Important

  • Cette propriété n'apparaît que si elle figure dans le schéma.

  • Cette propriété n'est disponible que si Standard est défini sur X12.

Remarque

  • Si vous ne spécifiez pas Oui, la valeur de la propriété Saut de création de sous-document prend la valeur par défaut Non et indique à l'analyseur ou au sérialiseur qu'il doit créer une nouvelle instance qui réplique toute la hiérarchie parente de l'enregistrement.

Onglet Analyse : Propriétés des champs

Propriété | Valeur
Type de données personnalisé Sélectionnez l'une des options suivantes :
  • Chaîne (AN). AN correspond aux champs alphanumériques.

  • Hexadécimal binaire (B). B correspond aux champs binaires.

  • Date (CA). CA correspond aux champs de dates à quatre chiffres.

  • Nombre (D0-D4). D0 à D4 (inclus) correspondent aux champs décimaux. Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Date (DT). DT correspond aux champs de date.

  • Chaîne (ID). ID correspond aux champs d'identification.

  • Nombre (N). N correspond aux champs d'entiers.

  • Numéro (N1-9). Les numéros N1 à N9 (compris) correspondent aux champs à décimales implicites (le caractère décimal n'apparaît pas dans les données). Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

    Remarques

    • Lorsqu'une spécification est convertie en format décimal implicite et vice versa, vous devez vous assurer que la valeur de Longueur maximale personnalisée peut gérer la sortie analysée ou sérialisée qui en résulte. Par exemple, si la valeur de Type de données personnalisé est définie sur N2, la valeur de Longueur maximale personnalisée doit être d'au moins 3. Ceci est nécessaire, car le parseur insert les décimales au cours de l'analyse et le sérialiseur les supprime et valide également le compteur du nombre de décimales à droite de la virgule.

    • Si vous modifiez la valeur de la propriété Standard de X12 par PERSONNALISÉ (par exemple, pour les fichiers plats) dans l'onglet Référence, puis sélectionnez Nombre (N) ou Nombre (Nx), où x représente un nombre compris entre 1 et 9, la propriété Longueur maximale personnalisée ne s'affiche pas. C'est pourquoi, vous devez augmenter la valeur de Longueur maximale dans l'onglet Déclaration pour pouvoir obtenir une sortie analysée ou sérialisée des résultats lorsqu'une spécification est convertie en format décimal implicite et vice versa.
  • Nombre (R). R correspond aux champs numériques.

  • Heure (TM). TM correspond aux champs d'heure.

Important

  • Si vous spécifiez une valeur Type de données personnalisé, la valeur Type de données dans l'onglet Déclaration est automatiquement modifiée pour correspondre à la sélection que vous avez spécifiée pour la valeur Type de données personnalisé. Par exemple, si vous changez la valeur de Type de données personnalisé dans l'onglet Analyse par Date (CA), la valeur de Type de données dans l'onglet Déclaration est automatiquement modifiée par Date.

Remarques

  • Si vous spécifiez des valeurs Date (DT), Date (CA) ou Heure (TM) pour la propriété Type de données personnalisé, vous devez également définir une valeur pour la propriété Format Date/Heure personnalisé.

  • Toutes les valeurs de type de données personnalisé sont prises en charge dans les spécifications dont la propriété Standard est définie sur X12. Pour les spécifications dont la propriété Standard est définie sur EDIFACT, les valeurs de type de données personnalisé prises en charge sont Chaîne (AN) et Nombre (N).
Date/Format d'heure personnalisés Si vous définissez les valeurs Date (DT), Date (CA) ou Heure (TM) comme propriété Type de données personnalisé, cliquez sur une option dans la liste. Pour plus d'informations, voir Application correcte du format Heure/Date personnalisé. Pour obtenir des informations sur les formats d'heure pris en charge, voir Format d'heure pris en charge pour la norme X12.

Remarque

  • Ce champ est disponible uniquement si la valeur Type de données personnalisé correspond à Date (DT), Date (CA) ou Heure (TM).

Important

  • Les parseurs de BizTalk Server ne reconnaissent pas le format de date julienne dans une instance de document entrante. Ce format comprend trois chiffres indiquant le jour (JJJ). S'il est possible de créer des spécifications dans l'Éditeur BizTalk utilisant le format de date julienne, cette fonctionnalité ne peut néanmoins être utilisée qu'avec des parseurs personnalisés capables de reconnaître les instances de documents utilisant ce format. N'utilisez pas le format de date julienne dans une spécification ou une instance de document, sauf si vous employez un parseur personnalisé capable de reconnaître ce format.
Justification Sélectionnez l'une des options suivantes :
  • Gauche Aligne les données sur la gauche dans les fichiers plats positionnels lorsque leur longueur est inférieure à la longueur maximale du champ. Aligne également les données sur la gauche dans les fichiers plats délimités lorsque la quantité de données est inférieure à la longueur minimale requise.

  • Droite. Aligne les données sur la droite dans les fichiers plats positionnels lorsque la quantité de données est inférieure à la longueur maximale du champ. Aligne également les données sur la gauche dans les fichiers plats délimités lorsque la quantité de données est inférieure à la longueur minimale requise.

Remarque

  • Si aucune valeur de Justification n'est indiquée, la valeur par défaut est Gauche.
Caractère tampon | Tapez un caractère pour définir le champ tampon. Vous pouvez choisir n'importe quel caractère en guise de caractère tampon, y compris un espace ou un zéro. Pour plus d'informations, voir Caractères tampon.
Caractère de retour ligne Tapez un caractère pour délimiter les données du champ. Cette propriété est utile lorsqu'un caractère de vos données de champ est également utilisé en guise de valeur de délimiteur pour le nœud parent du champ. Par exemple, si les données du champ sont les suivantes et si vous avez choisi une virgule comme valeur de délimiteur du nœud qui contient le champ, l'Éditeur BizTalk interprète la virgule après « Brown » comme étant un délimiteur, même si vous voulez qu'elle fasse partie des données du champ :

Brown,Robert,1231,oui

Pour résoudre ce problème, vous devez définir une valeur pour la propriété du caractère de retour à la ligne, puis délimiter les données du champ dans celui-ci. Vous pouvez, par exemple, définir des guillemets doubles comme caractères de retour à la ligne pour le premier champ, puis taper les données du champ, comme dans l'exemple suivant :

"Brown,Robert",1231,oui

L'Éditeur BizTalk interprète dans ce cas la virgule située entre les guillemets doubles comme faisant partie des données du champ et non comme une valeur de délimiteur.

Important

  • Dans un champ utilisant un caractère de retour à la ligne, il ne peut pas y avoir des données entre ce caractère de retour à la ligne et un délimiteur précédent ou suivant un autre caractère de retour à la ligne.

Remarques

  • Si vos données de champ comportent des caractères qui sont également utilisés comme caractères de retour à la ligne, vous devez les délimiter dans d'autres jeux de caractères de retour à la ligne.

    Par exemple, lorsque des guillemets doubles sont définis en tant que caractères de retour à la ligne, comme ceci :

    "Brown,Robert ""Rob"""

    l'Éditeur BizTalk l'analyse de la façon suivante :

    Brown,Robert "Rob"
Longueur minimale avec des caractères tampon Longueur minimale d'un champ dans une instance de document de sortie, caractères tampon inclus. Pour plus d'informations sur les caractères tampon, voir Caractères tampon.

Remarques

  • Cette propriété ne peut être définie que si le caractère de retour à la ligne est défini pour ce champ.

  • Si la propriété Longueur minimale de l'onglet Déclaration est définie pour le champ, la propriété Longueur minimale avec des caractères tampon doit être supérieure ou égale à la valeur de la propriété Longueur minimale. Si la propriété Longueur minimale n'est pas définie, la propriété Longueur minimale avec des caractères tampon doit être supérieure ou égale à 1.
Longueur maximale personnalisée Entrez un nombre qui représente le nombre de caractères maximal pouvant être contenu dans ce champ et appuyez sur ENTRÉE.

Remarques

  • Cette propriété permet notamment d'utiliser des points et des tirets dans le champ numérique.

  • Cette propriété ne s'affiche que si la valeur de Type de données personnalisé est Nombre (N), Nombre (Nx) ou Nombre (R), où x est égal à un nombre compris entre 1 et 9.

  • La valeur de Longueur maximale personnalisée doit être supérieure à x (où x est égal à un nombre compris entre 1 et 9 dans Nx) pour une instance EDI. Par exemple, si la valeur de Type de données personnalisé est définie sur N2, la valeur de Longueur maximale personnalisée doit être d'au moins 3. Ceci est nécessaire, car le parseur insert les décimales au cours de l'analyse et le sérialiseur les supprime et valide également le compteur du nombre de décimales à droite de la virgule.

Standard : Personnalisé
propriété de la structure : Délimité

Important

  • Les valeurs Retour de ligne, Caractères tampon, Caractères d'échappement et Délimiteur d'un enregistrement et de ses champs enfants s'excluent mutuellement.

  • Il est important de vérifier que le caractère de retour à la ligne est différent du caractère d'échappement.

Onglet Analyse : Nœud racine ou propriétés de l'enregistrement

Propriété | Valeur
Structure Sélectionnez l'option suivante pour la propriété Nœud racine :
  • Délimité. Indique que le nœud racine est basé sur une structure de fichier délimité. Les enregistrements peuvent être basés individuellement sur des structures de fichier délimité ou positionnel.

Sélectionnez l'une des options suivantes pour les propriétés Enregistrement :

  • Délimité. Indique que l'enregistrement est basé sur une structure de fichier délimité. Les enregistrements descendants peuvent être basés individuellement sur des structures de fichier délimité ou positionnel.

  • Positionnel. Indique que l'enregistrement est basé sur une structure de fichier positionnel. Les enregistrements positionnels ne peuvent posséder d'enregistrements enfants.

Remarques

  • Pour qu'un document soit délimité et positionnel, la propriété Structure du nœud racine doit être définie sur Délimité. Vous pouvez, si nécessaire, définir la propriété Structure d'enregistrements individuels sur Positionnel ou Délimité.

  • Si la structure de la spécification est positionnelle, il n'est pas recommandé de spécifier Élément en tant que Type dans l'onglet Déclaration pour les champs. Si vous procédez ainsi, la validation risque d'échouer.

  • Si vous changez de structure, un message s'affiche. Cliquez sur Oui pour confirmer la modification de structure. Certaines nouvelles propriétés peuvent apparaître, tandis que des propriétés existantes peuvent avoir été supprimées.

  • Si vous cliquez avec le bouton droit sur le champ de valeur de la propriété Structure d'un enregistrement positionnel et cliquez sur Supprimer la propriété, l'Éditeur BizTalk interprète la structure de l'enregistrement en tant que structure délimitée. Certaines nouvelles propriétés peuvent apparaître, tandis que des propriétés existantes peuvent avoir été supprimées.

  • Lorsque la propriété Standard d'un nouveau document est définie sur PERSONNALISÉ, par défaut aucune valeur n'est définie pour la propriété Structure du nœud racine et de tous les enregistrements. Si vous laissez la propriété Structure vide, sa valeur est Délimité.
Identifiant de la balise source Le nom de l'identifiant de la balise source. Correspond au nom de balise utilisé pour faire correspondre l'enregistrement avec les données.

Important

  • Lorsque vous avez un enregistrement en boucle et que les données de l'instance ne contiennent pas de structure en boucle (c'est-à-dire que la structure est implicite et non explicite), assurez-vous que la valeur de Identificateur de la balise source est vide.

Remarques

  • Dans le cas d'un fichier non-XML, comme un fichier plat, vous pouvez introduire une propriété Identificateur de la balise source pour identifier n'importe quelle balise pouvant exister dans le fichier d'origine. Un Identificateur de balise source ne peut pas contenir les caractères suivants : < > " &

  • La propriété Identificateur de la balise source respecte la casse.
Ordre des champs Sélectionnez l'une des options suivantes :
  • Préfixe. Un préfixe délimiteur s'affiche avant chaque composant et chaque membre d'un composant dans une série. Par exemple, lorsque le délimiteur est un astérisque (*) : *a*a*b*c.

  • Postfix. Un postfix délimiteur s'affiche après chaque composant et chaque membre d'un composant dans une série. Par exemple, où * est le délimiteur : a*a*b*c*.

  • Infix. Un infix délimiteur s'affiche entre les composants et membres des composants d'une série. Par exemple, où * est le délimiteur : a*a*b*c.

Remarques

  • Pour la plupart des fichiers non-XML, la propriété Ordre des champs du nœud racine doit être définie sur Postfix et les nœuds des enregistrements en boucle doivent être définis sur Infix. Vous pouvez obtenir des exemples sur cette méthode dans les dossiers Flat-FileDelimited et Flat-FilePositional situés dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\.

  • Si aucune valeur n'est indiquée pour l'ordre des champs, la valeur par défaut est Préfixe.
Type de délimiteur Sélectionnez l'une des options suivantes pour définir un délimiteur pour les nœuds enfants situés directement sous le nœud en cours :
  • Caractère. Vous permet de désigner une valeur de délimiteur dans l'onglet Analyse. Si vous sélectionnez Caractère, vous devez spécifier une valeur de délimiteur.

  • Délimiteur d'enregistrement par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur d'enregistrement par défaut, définie dans l'onglet Référence pour le nœud racine.

  • Délimiteur de champ par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur de champ par défaut, définie dans l'onglet Référence pour le nœud racine.

  • Délimiteur de sous-champ par défaut Indique que le délimiteur correspond à la valeur de la propriété Délimiteur de sous-champ par défaut, définie dans l'onglet Référence pour le nœud racine.
Valeur du délimiteur | Tapez ou sélectionnez une valeur de caractère pour le délimiteur. Pour spécifier une valeur de délimiteur, vous devez tout d'abord définir la propriété Type de délimiteur avec le paramètre Caractère dans l'onglet Analyse.
Type d'échappement

(Également appelé caractère d'échappement)

 Sélectionnez l'une des options suivantes pour définir un caractère d'échappement pour les nœuds enfants situés directement sous le nœud en cours :
  • Caractère. Vous permet de désigner une valeur de caractère d'échappement dans l'onglet Analyse. Si vous sélectionnez Caractère, vous devez spécifier une valeur d'échappement.

  • Caractère d'échappement par défaut Indique que le caractère d'échappement correspond à la valeur de la propriété Caractère d'échappement par défaut, définie dans l'onglet Référence pour le nœud racine.

Cette propriété est utile lorsqu'un caractère d'échappement de vos données de champ est également utilisé en guise de caractère de délimiteur pour le nœud parent du champ. Par exemple, si les données du champ sont les suivantes et si vous avez choisi une virgule comme valeur de délimiteur du nœud qui contient le champ, l'Éditeur BizTalk interprète la virgule après « Brown » comme étant un délimiteur, même si vous voulez qu'elle fasse partie des données du champ :

Brown,Robert,1231,oui

Pour résoudre ce problème, vous pouvez faire précéder d'un caractère d'échappement le caractère délimiteur que vous voulez inclure dans les données du champ. Par exemple, si le caractère d'échappement est spécifié comme étant la barre oblique inverse, vous pouvez placer une barre oblique inverse directement devant le caractère délimiteur, comme dans l'exemple suivant :

Brown\,Robert,1231,yes

L'Éditeur BizTalk interprète la virgule située après la barre oblique inverse comme des données du champ plutôt que comme un caractère délimiteur.
Valeur d'échappement | Tapez ou sélectionnez une valeur de caractère pour le caractère d'échappement. Pour spécifier une valeur de caractère d'échappement, vous devez tout d'abord définir la propriété Type d'échappement avec le paramètre Caractère dans l'onglet Analyse.
Ajouter une nouvelle ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique que lorsque le sérialiseur atteint le délimiteur d'enregistrement, il ajoute automatiquement une ligne (LF,0x0A).

  • Non. Indique que lorsque le sérialiseur atteint le délimiteur d'enregistrement, il doit continuer sur la même ligne pour l'enregistrement suivant.

Remarque

  • Si aucune valeur n'est indiquée pour Ajouter une nouvelle ligne, la valeur par défaut est Non.
Ignorer le retour chariot Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur d'ignorer le caractère de retour chariot (RC) situé après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Retour chariot après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Ignorer le retour chariot, la valeur par défaut est Oui.
Ignorer le saut de ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur qu'il doit ignorer la valeur Saut de ligne après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Saut de ligne après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Saut de ligne, la valeur par défaut est Oui.
Ignorer le nombre d'enregistrements Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur ou au sérialiseur qu'il ne doit pas compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

  • Non. Indique au parseur ou au sérialiseur qu'il doit compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

Remarques

  • Lorsqu'une instance de document est envoyée au serveur BizTalk Server, une erreur d'analyse se produit si le nombre d'enregistrements de l'instance ne correspond pas au nombre d'enregistrements calculés dans la spécification. Pour plus d'informations, voir Erreurs d'analyse.

  • Si aucune valeur n'est indiquée pour Ignorer le nombre d'enregistrements, la valeur par défaut est Oui.

Onglet Analyse : Propriétés des champs

Propriété | Valeur
Type de données personnalisé Sélectionnez l'une des options suivantes :
  • Chaîne (AN). AN correspond aux champs alphanumériques.

  • Hexadécimal binaire (B). B correspond aux champs binaires.

  • Date (CA). CA correspond aux champs de dates à quatre chiffres.

  • Nombre (D0-D4). D0 à D4 (inclus) correspondent aux champs décimaux. Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Date (DT). DT correspond aux champs de date.

  • Chaîne (ID). ID correspond aux champs d'identification.

  • Nombre (N). N correspond aux champs d'entiers.

  • Numéro (N1-9). Les numéros N1 à N9 (compris) correspondent aux champs à décimales implicites (le caractère décimal n'apparaît pas dans les données). Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

    Remarques

    • Lorsqu'une spécification est convertie en format décimal implicite et vice versa, vous devez vous assurer que la valeur de Longueur maximale personnalisée peut gérer la sortie analysée ou sérialisée qui en résulte. Par exemple, si la valeur de Type de données personnalisé est définie sur N2, la valeur de Longueur maximale personnalisée doit être d'au moins 3. Ceci est nécessaire, car le parseur insert les décimales au cours de l'analyse et le sérialiseur les supprime et valide également le compteur du nombre de décimales à droite de la virgule.

    • Si vous modifiez la valeur de la propriété Standard de X12 par PERSONNALISÉ (par exemple, pour les fichiers plats) dans l'onglet Référence, puis sélectionnez Nombre (N) ou Nombre (Nx), où x représente un nombre compris entre 1 et 9, la propriété Longueur maximale personnalisée ne s'affiche pas. C'est pourquoi, vous devez augmenter la valeur de Longueur maximale dans l'onglet Déclaration pour pouvoir obtenir une sortie analysée ou sérialisée des résultats lorsqu'une spécification est convertie en format décimal implicite et vice versa.
  • Nombre (R). R correspond aux champs numériques.

  • Heure (TM). TM correspond aux champs d'heure.

Important

  • Si vous spécifiez une valeur de Type de données personnalisé, la valeur de Type de données de l'onglet Déclaration est automatiquement modifiée pour correspondre à la sélection que vous avez spécifiée pour la valeur de Type de données personnalisé. Par exemple, si vous changez la valeur de Type de données personnalisé dans l'onglet Analyse par Date (CA), la valeur de Type de données dans l'onglet Déclaration est automatiquement modifiée par Date.

Remarque

  • Si vous spécifiez des valeurs Date (DT), Date (CA) ou Heure (TM) pour la propriété Type de données personnalisé, vous devez également définir une valeur pour la propriété Format Date/Heure personnalisé.
Date/Format d'heure personnalisés Si vous définissez les valeurs Date (DT), Date (CA) ou Heure (TM) comme propriété Type de données personnalisé, cliquez sur une option dans la liste. Pour plus d'informations, voir Application correcte du format Date/Heure personnalisé. Pour obtenir des informations sur les formats d'heure pris en charge, voir Format d'heure pris en charge pour la norme X12.

Remarque

  • Ce champ est disponible uniquement si la valeur Type de données personnalisé correspond à Date (DT), Date (CA) ou Heure (TM).
Justification Sélectionnez l'une des options suivantes :
  • Gauche Aligne les données sur la gauche dans les fichiers plats positionnels lorsque leur longueur est inférieure à la longueur maximale du champ. Aligne également les données sur la gauche dans les fichiers délimités lorsque la date est inférieure à la longueur minimale du champ.

  • Droite. Aligne les données sur la droite dans les fichiers plats positionnels lorsque la quantité de données est inférieure à la longueur maximale du champ. Aligne également les données sur la gauche dans les fichiers plats délimités lorsque la quantité de données est inférieure à la longueur minimale requise.

Remarque

  • Si aucune valeur de Justification n'est indiquée, la valeur par défaut est Gauche.
Caractère tampon | Tapez ou sélectionnez un caractère pour définir le champ tampon. Vous pouvez choisir n'importe quel caractère en guise de caractère tampon, y compris un espace ou un zéro. Pour plus d'informations, voir Caractères tampon.
Caractère de retour ligne Tapez un caractère pour délimiter les données du champ. Cette propriété est utile lorsqu'un caractère de vos données de champ est également utilisé en guise de valeur de délimiteur pour le nœud parent du champ. Par exemple, si les données du champ sont les suivantes et si vous avez choisi une virgule comme valeur de délimiteur du nœud qui contient le champ, l'Éditeur BizTalk interprète la virgule après « Brown » comme étant un délimiteur, même si vous voulez qu'elle fasse partie des données du champ :

Brown,Robert,1231,oui

Pour résoudre ce problème, vous devez définir une valeur pour la propriété du caractère de retour à la ligne, puis délimiter les données du champ dans celui-ci. Vous pouvez, par exemple, définir des guillemets doubles comme caractères de retour à la ligne pour le premier champ, puis taper les données du champ, comme dans l'exemple suivant :

"Brown,Robert",1231,oui

L'Éditeur BizTalk interprète dans ce cas la virgule située entre les guillemets doubles comme faisant partie des données du champ et non comme une valeur de délimiteur.

Remarques

  • Si vos données de champ comportent des caractères qui sont également utilisés comme caractères de retour à la ligne, vous devez les délimiter dans un autre jeu de caractères de retour à la ligne.

    Par exemple, lorsque des guillemets doubles sont définis en tant que caractères de retour à la ligne, comme ceci :

    "Brown,Robert ""Rob"""

    l'Éditeur BizTalk l'analyse de la façon suivante :

    Brown,Robert "Rob"

  • Si les données de champ d'une instance de document d'entrée contiennent le caractère de saut de ligne suivi directement par le caractère de retour chariot, les données de champ correspondantes de l'instance de document de sortie contiennent uniquement le caractère de saut de ligne, même si tous deux sont inclus dans un ensemble de caractères de retour à la ligne.
Longueur minimale avec des caractères tampon Longueur minimale d'un champ dans une instance de document de sortie, caractères tampon inclus. Pour plus d'informations, voir Caractères tampon.

Remarques

  • Cette propriété peut uniquement être définie pour un champ si le caractère tampon est défini pour celui-ci.

  • Si la propriété Longueur minimale de l'onglet Déclaration est définie pour le champ, la propriété Longueur minimale avec des caractères tampon doit être supérieure ou égale à la valeur de la propriété Longueur minimale. Si la propriété Longueur minimale n'est pas définie, la propriété Longueur minimale avec des caractères tampon doit être supérieure ou égale à un.

Standard : Personnalisé
Propriété de structure : Positionnel

Onglet Analyse : Propriétés du nœud racine ou propriétés de l'enregistrement

Propriété | Valeur
Structure Sélectionnez l'option suivante pour la propriété Nœud racine :
  • Positionnel. Indique que le nœud racine est basé sur une structure de fichier plat positionnel.

Important

  • La limite de taille maximale recommandée pour un champ est de 1 mégaoctet (Mo). Si vous dépassez cette limite, les performances de BizTalk Server seront fortement réduites.

Remarques

  • Si la structure de la spécification est positionnelle, il n'est pas recommandé de spécifier Élément en tant que Type dans l'onglet Déclaration pour les champs. Si vous procédez ainsi, la validation risque d'échouer.

  • Un document avec un nœud racine positionnel peut ne pas posséder d'enregistrements.

  • Si vous cliquez avec le bouton droit sur le champ de valeur de la propriété Structure d'un nœud racine positionnel et cliquez sur Supprimer la propriété, l'Éditeur BizTalk interprète la structure du nœud racine en tant que structure délimitée. Certaines nouvelles propriétés peuvent apparaître, tandis que des propriétés existantes peuvent avoir été supprimées.

  • Lorsque la propriété Standard d'un nouveau document est définie sur PERSONNALISÉ, par défaut aucune valeur n'est définie pour la propriété Structure du nœud racine et de tous les enregistrements. Si vous laissez la propriété Structure vide, sa valeur est Délimité.
Identifiant de la balise source Le nom de l'identifiant de la balise source. Correspond au nom de balise utilisé pour faire correspondre l'enregistrement avec les données.

Important

  • Lorsque vous avez un enregistrement en boucle et que les données de l'instance ne contiennent pas de structure en boucle (c'est-à-dire que la structure est implicite et non explicite), assurez-vous que la valeur de Identificateur de la balise source est vide.

Remarques

  • Dans le cas d'un fichier non-XML, comme un fichier plat, vous pouvez introduire une propriété Identificateur de la balise source pour identifier n'importe quelle balise pouvant exister dans le fichier d'origine. Un Identificateur de balise source ne peut pas contenir les caractères suivants : < > " &

  • La propriété Identificateur de la balise source respecte la casse.
Position de la balise source | Nombre qui fait référence à la position de début de la balise dans un enregistrement positionnel.
Ajouter une nouvelle ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique que lorsque le sérialiseur atteint le délimiteur d'enregistrement, il ajoute automatiquement une ligne (LF,0x0A).

  • Non. Indique que lorsque le sérialiseur atteint le délimiteur d'enregistrement, il doit continuer sur la même ligne pour l'enregistrement suivant.

Remarque

  • Si aucune valeur n'est indiquée pour Ajouter une nouvelle ligne, la valeur par défaut est Non.
Ignorer le retour chariot Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur d'ignorer le caractère de retour chariot (RC) situé après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Retour chariot après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Ignorer le retour chariot, la valeur par défaut est Oui.
Ignorer le saut de ligne Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur qu'il doit ignorer la valeur Saut de ligne après un délimiteur.

  • Non. Indique au parseur qu'il ne doit pas ignorer la valeur Saut de ligne après un délimiteur.

Remarque

  • Si aucune valeur n'est indiquée pour Saut de ligne, la valeur par défaut est Oui.
Ignorer le nombre d'enregistrements Sélectionnez l'une des options suivantes :
  • Oui. Indique au parseur ou au sérialiseur qu'il ne doit pas compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

  • Non. Indique au parseur ou au sérialiseur qu'il doit compter cet enregistrement lors du calcul du nombre total d'enregistrements dans la spécification.

Remarques

  • Lorsqu'une instance de document est envoyée au serveur BizTalk Server, une erreur d'analyse se produit si le nombre d'enregistrements de l'instance ne correspond pas au nombre d'enregistrements calculés dans la spécification. Pour plus d'informations, voir Erreurs d'analyse.

  • Si aucune valeur n'est indiquée pour Ignorer le nombre d'enregistrements, la valeur par défaut est Oui.

Parse Tab:Onglet Analyse : Propriétés des champs

Propriété | Valeur
Type de données personnalisé Sélectionnez l'une des options suivantes :
  • Chaîne (AN). AN correspond aux champs alphanumériques.

  • Hexadécimal binaire (B). B correspond aux champs binaires.

  • Date (CA). CA correspond aux champs de dates à quatre chiffres.

  • Nombre (D0-D4). D0 à D4 (inclus) correspondent aux champs décimaux. Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

  • Date (DT). DT correspond aux champs de date.

  • Chaîne (ID). ID correspond aux champs d'identification.

  • Nombre (N). N correspond aux champs d'entiers.

  • Numéro (N1-9). Les numéros N1 à N9 (compris) correspondent aux champs à décimales implicites (le caractère décimal n'apparaît pas dans les données). Le nombre à un seul chiffre représente le nombre de décimales à droite de la virgule.

    Remarques

    • Lorsqu'une spécification est convertie en format décimal implicite et vice versa, vous devez vous assurer que la valeur de Longueur maximale personnalisée peut gérer la sortie analysée ou sérialisée qui en résulte. Par exemple, si la valeur de Type de données personnalisé est définie sur N2, la valeur de Longueur maximale personnalisée doit être d'au moins 3. Ceci est nécessaire, car le parseur insert les décimales au cours de l'analyse et le sérialiseur les supprime et valide également le compteur du nombre de décimales à droite de la virgule.

    • Si vous modifiez la valeur de la propriété Standard de X12 par PERSONNALISÉ (par exemple, pour les fichiers plats) dans l'onglet Référence, puis sélectionnez Nombre (N) ou Nombre (Nx), où x représente un nombre compris entre 1 et 9, la propriété Longueur maximale personnalisée ne s'affiche pas. C'est pourquoi, vous devez augmenter la valeur de Longueur maximale dans l'onglet Déclaration pour pouvoir obtenir une sortie analysée ou sérialisée des résultats lorsqu'une spécification est convertie en format décimal implicite et vice versa.
  • Nombre (R). R correspond aux champs numériques.

  • Heure (TM). TM correspond aux champs d'heure.

Important

  • Si vous spécifiez une valeur de Type de données personnalisé, la valeur de Type de données de l'onglet Déclaration est automatiquement modifiée pour correspondre à la sélection que vous avez spécifiée pour la valeur de Type de données personnalisé. Par exemple, si vous changez la valeur de Type de données personnalisé dans l'onglet Analyse par Date (CA), la valeur de Type de données dans l'onglet Déclaration est automatiquement modifiée par Date. Si vous indiquez une valeur Type de données dans l'onglet Déclaration, la valeur Type de données personnalisé est annulée.

Remarque

  • Si vous spécifiez des valeurs Date (DT), Date (CA) ou Heure (TM) pour la propriété Type de données personnalisé, vous devez également définir une valeur pour la propriété Format Date/Heure personnalisé.
Date/Format d'heure personnalisés Si vous définissez les valeurs Date (DT), Date (CA) ou Heure (TM) comme propriété Type de données personnalisé, cliquez sur une option dans la liste. Pour plus d'informations, voir Application correcte du format Date/Heure. Pour obtenir des informations sur les formats d'heure pris en charge, voir Format d'heure pris en charge pour la norme X12.

Remarque

  • Ce champ est disponible uniquement si la valeur Type de données personnalisé correspond à Date (DT), Date (CA) ou Heure (TM).
Justification Sélectionnez l'une des options suivantes :
  • Gauche Aligne les données sur la gauche dans les fichiers plats positionnels lorsque la quantité de données est inférieure à la longueur maximale du champ. Aligne également les données sur la gauche dans les fichiers plats délimités lorsque la quantité de données est inférieure à la longueur minimale requise.

  • Droite. Aligne les données sur la droite dans les fichiers plats positionnels lorsque la quantité de données est inférieure à la longueur maximale du champ. Aligne également les données sur la gauche dans les fichiers plats délimités lorsque la quantité de données est inférieure à la longueur minimale requise.

Remarque

  • Si aucune valeur de Justification n'est indiquée, la valeur par défaut est Gauche.
Caractère tampon | Tapez un caractère pour définir le champ tampon. Vous pouvez choisir n'importe quel caractère en guise de caractère tampon, y compris un espace ou un zéro. Pour plus d'informations, voir Caractères tampon.

Voir aussi

Limites de longueur des caractères

Caractères tampon


Application correcte du format Date/Heure personnalisé

Le type de données Format Date/Heure personnalisé permet d'envoyer des informations de date et d'heure au format : HHMMSSDD. Pour plus d'informations, voir la rubrique « Format d'heure pris en charge pour la norme X12 ».

  1. Dans l'arborescence de la spécification, cliquez sur le nœud racine, l'enregistrement ou le champ pour lequel vous voulez définir la propriété Date/Heure personnalisée, puis cliquez sur l'onglet Analyse.

  2. Double-cliquez sur la colonne Valeur en regard de Type de données personnalisé.

  3. Cliquez sur Heure (TM) dans la liste d'options, puis appuyez sur ENTRÉE.

    Un message d'avertissement apparaît.

  4. Cliquez sur Oui.

  5. Double-cliquez sur la colonne Valeur en regard de Format Date/Heure personnalisé.

  6. Cliquez sur HHMMSSDD dans la liste de valeurs et appuyez sur ENTRÉE.

    Le nouveau type de données Date/Heure personnalisé est appliqué.

Important

  • Si vous souhaitez exprimer l'heure en dixièmes ou en centièmes de seconde, utilisez le type de données Date/Heure personnalisé décrit dans cette rubrique.

Remarques

  • Si vous remplacez la date et l'heure personnalisées par HHMMSSDD, le type de données de la propriété Date/Heure personnalisée dans l'onglet Analyse se transforme en Chaîne.

  • Si vous utilisez le type de données Date/Heure personnalisée, vous pouvez envoyer l'heure dans l'un des formats suivants :
    • HHMM

    • HHMMSS

    • HHMMSSD

    • HHMMSSDD

    Le parseur et le sérialiseur X12 lisent le type de données Date/Heure personnalisée de gauche à droite et ne renvoient pas d'erreur si la date et l'heure envoyées comptent moins de huit caractères. Ainsi, les données de date et d'heure suivantes sont valides :

    • 2211

    • 221101
  • Si vous utilisez le type de données Date/Heure personnalisée, le contenu des données d'heure doivent toujours être envoyées et reçues dans un nombre de chiffres pairs, sauf les données d'heure exprimées en dixièmes de seconde. Par exemple, 2211 est correct mais pas 22115.

  • Ce type de données Date/Heure personnalisée est disponible uniquement si le schéma repose sur la norme X12.

Voir aussi

Format d'heure pris en charge pour la norme X12


Déclaration des espaces de noms

  1. Cliquez sur un nœud dans l'arborescence de spécification.

  2. Cliquez sur l'onglet Espace de noms.

  3. Cliquez avec le bouton droit sur le premier champ vide dans la colonne Préfixe et cliquez sur Ajouter.

  4. Tapez un préfixe pour l'espace de noms et appuyez sur ENTRÉE.

  5. Double-cliquez sur le champ vide à droite, dans la colonne Nom de ressource uniforme.

  6. Tapez un nom de ressource uniforme et appuyez sur ENTRÉE.

Important

  • L'Éditeur BizTalk ne valide pas le nom de ressource uniforme (URN) introduit pour un espace de noms.

  • Ne spécifiez pas un espace de noms URN commençant par « x-schema: ». Si x-schema figure dans votre spécification, les références aux schémas ne seront pas résolues par le moteur d'exécution.

Pour plus d'informations sur les espaces de noms, voir Déclaration d'espaces de noms.

Voir aussi

Ajout d'annotations personnalisées

Limites de longueur des caractères

Suppression d'annotations personnalisés

Modification d'annotations personnalisées

Déclarations d'espaces de noms


Ajout d'annotations personnalisées

  1. Dans l'arborescence de la spécification, cliquez sur le nœud racine, l'enregistrement ou le champ auquel vous voulez ajouter une annotation personnalisée.

    Remarque

    • Il n'est pas possible d'ajouter une annotation personnalisée pour le nœud racine dans l'onglet Référence.
  2. Cliquez sur l'onglet Déclaration ou Référence, en fonction de l'emplacement où vous voulez ajouter une annotation personnalisée.

  3. Cliquez avec le bouton droit sur le premier champ vide dans la colonne Propriété et cliquez sur Ajouter.

    Le mode Édition est activé dans la colonne Propriété.

  4. Tapez une paire préfixe:nom (par exemple, bts:spécification, où bts est le préfixe et spécification le nom. Séparez le préfixe du nom par deux points) et appuyez sur ENTRÉE.

    -Ou-

    Sélectionnez l'une des annotations personnalisées dans la liste et appuyez sur ENTRÉE.

  5. Double-cliquez sur le champ vide à droite, dans la colonne Valeur.

  6. Tapez la valeur de l'annotation personnalisée et appuyez sur ENTRÉE.

Important

  • Pour que la spécification se compile correctement, le préfixe de l'espace de noms utilisé à l'étape 4 doit être déclaré dans la spécification. Pour plus d'informations, voir Déclaration des espaces de noms.

Voir aussi

Ajout d'annotations SQL

Déclaration des espaces de noms

Suppression d'annotations personnalisées

Modifications d'annotations personnalisées

Déclarations d'espaces de noms


Modification d'annotations personnalisées

  1. Dans l'arborescence de la spécification, cliquez sur le nœud qui contient l'annotation personnalisée à modifier.

  2. Cliquez sur l'onglet (Déclaration ou Référence) qui fait référence à l'annotation personnalisée que vous voulez modifier.

  3. Double-cliquez sur le champ Propriété de l'annotation personnalisée, modifiez-le et appuyez sur ENTRÉE.

  4. Double-cliquez sur le champ Valeur de l'annotation personnalisée, modifiez-le et appuyez sur ENTRÉE.

Voir aussi

Ajout d'annotations SQL

Déclaration des espaces de noms

Déclarations d'espaces de noms


Suppression d'annotations personnalisées

  1. Dans l'arborescence de la spécification, cliquez sur le nœud qui contient l'annotation personnalisée à supprimer.

  2. Cliquez sur l'onglet (Déclaration ou Référence) qui fait référence à l'annotation personnalisée que vous voulez supprimer.

  3. Cliquez avec le bouton droit sur l'annotation personnalisée, puis cliquez sur Supprimer.

  4. Cliquez sur Oui pour confirmer la modification.

Voir aussi

Ajout d'annotations personnalisées

Ajout d'annotations SQL

Déclaration des espaces de noms

Modifications d'annotations personnalisées

Déclarations d'espaces de noms


Définition des propriétés du dictionnaire

  1. Dans l'arborescence de la spécification, cliquez sur le nœud racine, l'enregistrement ou le champ pour lequel vous voulez définir une propriété, puis cliquez sur l'onglet Dictionnaire.

  2. Dans la colonne Propriété, activez la case à cocher de la valeur que vous voulez associer au champ.

L'onglet Déclaration contient les propriétés décrites dans les tableaux ci-après. Les propriétés du dictionnaire peuvent être définies uniquement pour les spécifications dont la propriété Standard dans l'onglet Référence a la valeur XML ou PERSONNALISÉ.

Onglet Dictionnaire : Nœud racine ou propriétés de l'enregistrement

Propriété | Chemin du nœud
Nœud conteneur du document | Dans un schéma d'enveloppe, le nœud du document indique que l'enregistrement contient le document.

Remarque

  • Dans une spécification d'un fichier plat (dont la propriété Standard est définie sur PERSONNALISÉ dans l'onglet Référence) qui est analysé par le parseur de fichiers plats de BizTalk Server, l'activation ou la désactivation de la case à cocher de propriété du dictionnaire Nœud conteneur du document est sans effet. Néanmoins, cette propriété du dictionnaire est disponible si vous voulez créer une spécification personnalisée et un parseur personnalisé qui l'utilisent.

Onglet Dictionnaire : Propriétés des champs

Propriété | Chemin du nœud
Nom du document | Affiche le chemin d'accès au champ d'une instance de document qui contient le nom du document.
Type de source | Affiche le chemin d'accès au champ d'une instance de document qui contient le type de source.
Valeur de la source | Affiche le chemin d'accès au champ d'une instance de document qui contient la valeur de la source.
Type de destination | Affiche le chemin d'accès au champ d'une instance de document qui contient le type de destination.
Valeur de destination | Affiche le chemin d'accès au champ d'une instance de document qui contient la valeur de destination.

Remarques

  • Lorsqu'il analyse une spécification, le parseur utilise les informations fournies dans l'onglet Dictionnaire pour localiser un canal. Vous pouvez créer un canal à l'aide du Gestionnaire d'échanges BizTalk. Pour plus d'informations sur les canaux et le Gestionnaire d'échanges BizTalk, voir Description des canaux.

  • Si vous utilisez une spécification pour définir les documents qui sont envoyés vers un port d'échanges ouvert, vous devez sélectionner la valeur de destination dans l'onglet Dictionnaire pour le champ contenant les informations sur le transport et la destination. Dans un document, les informations sur la destination sont remplacées si vous utilisez les paramètres d'envoi. Pour plus d'informations sur l'envoi de documents, voir Submitting.

  • Vous pouvez également définir les propriétés du Dictionnaire en cliquant avec le bouton droit sur un champ de la colonne Propriété, puis en cliquant sur Définir les informations de routage.

Voir aussi

Ajout d'une propriété au dictionnaire personnalisé

Limites de longueur des caractères

Suppression d'une propriété du dictionnaire

Suppression d'une propriété du dictionnaire personnalisé

Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

Submitting

Description des ports d'échanges


Ajout d'une propriété au dictionnaire personnalisé

  1. Dans l'arborescence de la spécification, sélectionnez le champ pour lequel vous voulez ajouter une propriété au dictionnaire personnalisé.

  2. Cliquez sur l'onglet Dictionnaire.

  3. Double-cliquez sur le premier champ vide dans la colonne Propriété.

  4. Tapez un nom pour la propriété et appuyez sur ENTRÉE.

Remarques

  • Utilisez un nom unique pour chaque propriété personnalisée créée.

  • La propriété Standard (pour le nœud racine) ne doit pas être définie sur X12 ni sur EDIFACT.

Voir aussi

Suppression d'une propriété du dictionnaire

Suppression d'une propriété du dictionnaire personnalisé

Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

Définition des propriétés du dictionnaire


Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

  1. Cliquez sur l'onglet Dictionnaire.

  2. Double-cliquez avec le bouton droit sur la propriété personnalisée que vous voulez renommer et cliquez sur Renommer.

  3. Tapez un nom pour la propriété et appuyez sur ENTRÉE.

Remarque

  • Utilisez un nom unique pour chaque propriété personnalisée créée.

Voir aussi

Ajout d'une propriété au dictionnaire personnalisé

Suppression d'une propriété du dictionnaire

Suppression d'une propriété du dictionnaire personnalisé

Définition des propriétés du dictionnaire


Suppression d'une propriété du dictionnaire

  1. Dans l'arborescence de la spécification, cliquez sur le nœud pour lequel vous voulez supprimer une propriété du dictionnaire et cliquez sur l'onglet Dictionnaire.

  2. Dans la colonne Propriété, désactivez la case à cocher de la valeur que vous voulez dissocier du champ.

Remarques

  • Vous pouvez également supprimer une valeur de propriété du Dictionnaire en cliquant avec le bouton droit sur un champ de la colonne Propriété, puis en cliquant sur Supprimer les informations de routage.

  • Lorsque vous supprimez une propriété de dictionnaire dans un nœud, les informations de routage sont également supprimées.

Voir aussi

Ajout d'une propriété au dictionnaire personnalisé

Limites de longueur des caractères

Suppression d'une propriété du dictionnaire personnalisé

Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

Définition des propriétés de déclaration


Suppression d'une propriété du dictionnaire personnalisé

  1. Cliquez sur l'onglet Dictionnaire.

  2. Double-cliquez avec le bouton droit sur la propriété personnalisée que vous voulez supprimer et cliquez sur Supprimer.

  3. Cliquez sur Oui pour confirmer la modification.

Voir aussi

Ajout d'une propriété au dictionnaire personnalisé

Suppression d'une propriété du dictionnaire

Affectation d'un nouveau nom à une propriété du dictionnaire personnalisé

Définition des propriétés du dictionnaire


Sélection de codes

  1. Cliquez sur un champ dans une arborescence de spécifications.

  2. Cliquez sur l'onglet Liste de codes.

  3. Dans la colonne Valeur, activez la case à cocher située en regard du code que vous voulez utiliser.

Remarques

  • Les listes de codes sont disponibles uniquement pour les spécifications X12 ou EDIFACT. Toutefois, tous les champs d'une spécification basée sur X12 ou EDIFACT ne possèdent pas de codes qui leur sont associés. L'onglet Liste de codes affiche la liste complète des codes disponibles pour un champ spécifique. Les codes sont associés à un champ si la case à cocher du champ Valeur située en regard du code est activée. Une description du code apparaît dans le champ Description.

  • Lorsque vous associez un code à un champ dans l'onglet Liste de codes, cette association s'affiche également dans l'onglet Déclaration. Le champ Type de données dans l'onglet Déclaration est automatiquement défini sur la valeur Énumération, et le champ Valeurs des types de données affiche les nombres de la liste de codes que vous avez sélectionnés dans l'onglet Liste de codes. Si vous annulez la valeur de Type de données dans l'onglet Déclaration, aucun code ne sera sélectionné dans l'onglet Liste de codes. Pour plus d'informations, voir Suppression d'une propriété d'un champ dans la colonne Valeur

  • Pour sélectionner une plage de codes, activez la case à cocher située en regard d'un code, appuyez sur MAJ, puis activez une case à cocher située en regard d'un autre code. Tous les codes compris entre ces deux codes sont sélectionnés.

  • Parfois, des valeurs de codes dupliquées apparaissent dans l'onglet Liste de codes. Ces valeurs de codes dupliquées peuvent avoir diverses descriptions, en fonction du type de document avec lequel la valeur du code est associée. Dans le contexte de la validation d'une instance de document, il n'est jamais nécessaire de sélectionner plusieurs valeurs de code. Toutefois, il se peut que vous en sélectionniez plusieurs par inadvertance plus d'une valeur de code. La liste suivante résume le comportement de sélection des listes de codes dupliqués :
    • Si vous sélectionnez la valeur de code supérieure dans un ensemble de valeurs de codes dupliqués, seule cette valeur de code est sélectionnée.

    • Si vous sélectionnez n'importe quelle valeur de code autre que la valeur de code supérieure dans un ensemble de valeurs de codes dupliqués, cette valeur de code est sélectionnée et la valeur de code supérieure est également sélectionnée automatiquement.

    • La valeur de code supérieure dans un ensemble de valeurs de codes dupliqués ne peut être effacée tant que toute autre valeur de code de l'ensemble est sélectionnée.

Voir aussi

Suppression d'une propriété d'un champ dans la colonne Valeur

Suppression de codes

Valeurs et descriptions des listes de codes


Suppression de codes

  1. Cliquez sur un champ dans l'arborescence de la spécification.

  2. Cliquez sur l'onglet Liste de codes.

  3. Dans la colonne Valeur, désactivez la case à cocher située en regard du code que vous voulez supprimer.

Remarques

  • Les listes de codes sont disponibles uniquement pour les spécifications X12 ou EDIFACT. Toutefois, tous les champs d'une spécification basée sur X12 ou EDIFACT ne possèdent pas de codes qui leur sont associés. L'onglet Liste de codes affiche la liste complète des codes disponibles pour un champ spécifique. Les codes sont associés à un champ si la case à cocher du champ Valeur située en regard du code est sélectionnée. Une description du code apparaît dans le champ Description.

  • Parfois, des valeurs de codes dupliquées apparaissent dans l'onglet Liste de codes. Ces valeurs de codes dupliquées peuvent avoir diverses descriptions, en fonction du type de document avec lequel la valeur du code est associée. Dans le contexte de la validation d'une instance de document, il n'est jamais nécessaire de sélectionner plus d'une valeur de code. Toutefois, il se peut que vous sélectionniez par inadvertance plus d'une valeur de code. La liste suivante résume le comportement de sélection des listes de codes dupliqués :
    • Si vous sélectionnez la valeur de code supérieure dans un ensemble de valeurs de codes dupliqués, seule cette valeur de code est sélectionnée.

    • Si vous sélectionnez n'importe quelle valeur de code autre que la valeur de code supérieure dans un ensemble de valeurs de codes dupliqués, cette valeur de code est sélectionnée et la valeur de code supérieure est également sélectionnée automatiquement.

    • La valeur de code supérieure dans un ensemble de valeurs de codes dupliqués ne peut être effacée tant que toute autre valeur de code de l'ensemble est sélectionnée.

Voir aussi

Valeurs et descriptions des listes de codes

Sélection de codes


Suppression d'une propriété d'un champ dans la colonne Valeur

  1. Cliquez sur l'onglet contenant la propriété que vous voulez supprimer.

  2. Cliquez avec le bouton droit sur la colonne Valeur et sélectionnez Supprimer la propriété.


Calcul automatique des positions de champs

Si la valeur de Type de données personnalisé est définie sur une décimale implicite, vous devez calculer les positions de champ manuellement. Pour plus d'informations, voir les sections relatives à la Position de début et à la Position de fin dans Définition des propriétés de référence.

  1. Sélectionnez un champ dans un enregistrement positionnel.

  2. Double-cliquez sur le champ Valeur de la ligne Type de données.

  3. Dans la liste Type de données, cliquez sur une valeur.

    Remarque

    • Pour spécifier une valeur Longueur maximale (étapes 4 et 5), vous devez sélectionner l'une des valeurs Type de données suivantes : Chaîne, Nombre, Binaire (base64) ou Binaire (hex).
  4. Double-cliquez sur le champ Valeur de la ligne Longueur maximale.

  5. Tapez un nombre dans le champ de valeur Longueur maximale et appuyez sur ENTRÉE.

  6. Répétez les étapes 1 à 5 pour chacun des champs de l'enregistrement.

  7. Cliquez avec le bouton droit sur l'enregistrement et cliquez sur Calculer les positions des champs.

    L'avertissement suivant s'affiche :

    Cette opération va modifier les propriétés Position de début et Position de fin pour les champs de l'enregistrement sélectionné. Voulez-vous continuer ?

  8. Cliquez sur Oui.

    Les positions de début et de fin sont calculées pour les champs de l'enregistrement. Pour plus d'informations, voir Calcul des positions des champs.


Modification des notes et affichage des règles syntaxiques

La boîte de dialogue Propriétés du nœud vous permet d'effectuer les actions suivantes :

  • Lire et modifier les notes pour les champs et les enregistrements.

  • Lire les règles syntaxiques pour les enregistrements.

Pour afficher la boîte de dialogue Propriétés du nœud, procédez comme suit :

  1. Dans l'arborescence de la spécification, cliquez avec le bouton droit sur un enregistrement ou un champ et cliquez sur Propriétés.

    L'onglet Nœud apparaît par défaut.

  2. Pour afficher les règles syntaxiques pour un enregistrement, cliquez sur l'onglet Règles syntaxiques.

Remarque

  • Les règles de syntaxe ne s'appliquent qu'aux enregistrements.

Pour plus d'informations sur le mode d'utilisation de cette boîte de dialogue, voir les rubriques suivantes :

  • Saisie de notes d'enregistrement

  • Affichage des règles syntaxiques

  • Saisie de notes de champ


Saisie de notes d'enregistrement

Pour obtenir des informations sur l'ouverture de la boîte de dialogue Propriétés du nœud, voir Modification des notes et affichage des règles syntaxiques.

Les notes vous permettent de conserver des informations relatives à l'enregistrement auquel elles sont associées, telles que l'objectif de l'enregistrement ou la raison pour laquelle il a été créé.

  • Pour enregistrer une note, tapez un texte dans la boîte de dialogue Propriétés du nœud et cliquez sur OK.

Remarques

  • Les notes ne peuvent pas être ajoutées au nœud racine.

  • Les notes ne peuvent contenir de caractères non imprimables (toute combinaison de la touche Alt et d'un nombre). Par exemple, si vous appuyez sur ALT en tapant 75, la lettre K s'affiche.

Voir aussi

Saisie de notes de champ

Affichage des règles syntaxiques


Affichage des règles syntaxiques

Pour obtenir des informations sur l'ouverture de la boîte de dialogue Propriétés du nœud, voir Modification des notes et affichage des règles syntaxiques.

Les règles syntaxiques fournissent des informations sur la façon dont il faut organiser l'arborescence de la spécification. Les règles syntaxiques se trouvent uniquement dans les spécifications basées sur le standard X12.

  • Pour afficher les règles syntaxiques pour un enregistrement, cliquez sur l'onglet Règles syntaxiques.

Remarque

  • Les règles de syntaxe ne s'appliquent qu'aux enregistrements.

Voir aussi

Saisie de notes de champ

Saisie de notes d'enregistrement


Saisie de notes de champ

Pour obtenir des informations sur l'ouverture de la boîte de dialogue Propriétés du nœud, voir Modification des notes et affichage des règles syntaxiques.

Les notes vous permettent de conserver des informations relatives au champ auquel elles sont associées, telles que l'objectif du champ ou la raison pour laquelle il a été créé.

  • Pour enregistrer une note, tapez du texte dans la boîte de dialogue Propriétés du nœud et cliquez sur OK.

Remarque

  • Les notes ne peuvent contenir de caractères non imprimables (toute combinaison de la touche Alt et d'un nombre). Par exemple, si vous appuyez sur ALT en tapant 75, la lettre K s'affiche.

Voir aussi

Saisie de notes d'enregistrement

Affichage des règles syntaxiques


Gestion d'instances de document

L'Éditeur BizTalk vous permet de créer une instance de document basée sur une spécification et de valider une instance de document par rapport à une spécification.

Cette section traite des procédures suivantes :

  • Création d'une instance de document

  • Création d'une instance native

  • Validation d'une instance de document


Création d'une instance de document

  1. Ouvrez une spécification sur laquelle vous voulez baser une instance de document.

  2. Dans le menu Outils, cliquez sur Créer une instance XML.

    La boîte de dialogue Créer une instance de document sous s'affiche.

  3. Naviguez jusqu'au dossier dans lequel vous voulez créer une instance de document.

  4. Dans la zone Nom de fichier, tapez le nom de l'instance du document, puis cliquez sur Enregistrer.

    La nouvelle instance du document s'affiche dans l'onglet Sortie.

Remarque

  • Une instance de document peut uniquement être créée au format Unicode.

Voir aussi

Validation d'une instance de document


Création d'une instance native

  1. Ouvrez une spécification.

  2. Dans le menu Outils, cliquez sur Créer une instance native.

    La boîte de dialogue Créer une instance native sous s'affiche.

  3. Naviguez jusqu'au dossier dans lequel vous voulez créer une instance native.

  4. Dans la zone Nom de fichier, tapez le nom de l'instance native, puis cliquez sur Enregistrer.

    La boîte de dialogue Délimiteurs de document s'affiche.

  5. Sélectionnez une option ou tapez un délimiteur de chacune des listes suivantes :
    • Délimiteur d'enregistrement

    • Délimiteur de champ

    • Délimiteur de sous-champ

    • Caractère d'échappement

    Important

    • Si vous spécifiez vos propres délimiteurs, utilisez des valeurs en caractères Unicode. Pour obtenir la liste des caractères valide, accédez à la page Pages de code globales sur le site Web Microsoft Global Software Development ( www.microsoft.com/globaldev/reference/wincp.asp). Vous pouvez utiliser des codes de caractères ANSI dans la mesure où ceux-ci sont identiques au code de caractères Unicode, à l'exception des deux zéros de tête.

Important

  • Même si vous créez une instance native correcte si, ultérieurement, vous effectuez la validation de l'instance, cette opération peut échouer si les règles syntaxiques n'ont pas été appliquées.

  • Les plages de caractères ne sont pas prises en compte. Dans ce cas, votre instance native sera correctement créée, mais lorsque BizTalk Server tentera d'analyser votre transaction, l'opération échouera.

  • La fonction Créer une instance native ne crée pas de format HHMMSSDD personnalisé.

  • Il est possible qu'une instance native ne puisse pas être générée pour un fichier positionnel dans l'un ou l'autre des cas suivants :
    • La valeur Type de données dans l'onglet Déclaration n'est pas Chaîne, Nombre, Binaire (base64) ou Binaire (hex).

    • La valeur de Longueur maximale dans l'onglet Déclaration ne contient pas de valeur.


Validation d'une instance de document

  1. Ouvrez une spécification par rapport à laquelle vous voulez valider une instance de document.

    Pour plus d'informations, voir Ouverture de spécifications.

  2. Dans le menu Outils, cliquez sur Valider l'instance.

    La boîte de dialogue Valider une instance de document s'affiche.

  3. Naviguez jusqu'à l'instance de document que vous voulez valider, puis cliquez sur Ouvrir.

  4. Lorsque vous validez une instance de document sans enveloppe par rapport à une spécification basée sur le standard X12 ou EDIFACT, la boîte de dialogue Délimiteurs de document s'affiche. Procédez de l'une des manières suivantes :
    • Spécifications X12. Sélectionnez les délimiteurs appropriés pour le document à valider et cliquez sur OK.

    • Spécifications EDIFACT. Sélectionnez les délimiteurs et le caractère d'échappement appropriés pour le document à valider et cliquez sur OK.
  5. Lisez le message qui s'affiche dans l'onglet Avertissements. Si l'instance de document est validée par rapport à la spécification, le message suivant s'affiche :

    La validation de l'instance de document a réussi.

    Si l'instance de document n'est pas validée par rapport à la spécification, l'onglet Avertissements l'indique et affiche des erreurs expliquant pourquoi la validation n'a pas réussi. Résolvez le problème et revalidez l'instance de document.

  6. Si vous validez une instance de document non XML par rapport à une spécification non XML, et si l'instance de document est validée, cliquez sur l'onglet Sortie pour afficher une version XML (Extensible Markup Language) du document.

Question d'ordre international

  • Si vous créez une instance de document contenant un symbole Yen japonais ou un symbole Won coréen alors que les paramètres régionaux de votre système sont établis en japonais ou en coréen, lorsque cette instance de document sera validée avec succès par rapport à la spécification correspondante, le symbole Yen ou Won apparaîtra sous la forme d'une barre oblique inversée dans l'onglet Sortie de l'Éditeur BizTalk. Pour afficher le symbole Yen ou Won à la place de la barre oblique inversée, vous pouvez afficher la source dans l'onglet Sortie.
    1. Dans l'onglet Sortie qui affiche une barre oblique inversée à la place du symbole Yen ou Won, cliquez avec le bouton droit n'importe où dans l'onglet, puis cliquez sur Afficher la source.

    2. Dans le Bloc-Notes, dans le menu Format, cliquez sur Police.

    3. Dans la boîte de dialogue Police, dans la zone Police, cliquez sur Tahoma, puis sur OK.

Remarques

  • Pour valider des instances il est important de bien comprendre le problème des caractères de noms XML non valides. Pour plus d'informations, voir Caractères de noms XML non valides.

  • Une instance de document XML bien formée qui contient des éléments saisis comme types de données réduits XML-Data (XDR) ne sera peut-être pas validée par rapport à la spécification correspondante. Pour valider cette instance de document par rapport à la spécification correspondante, assurez-vous que les propriétés Modèle de tous les éléments entrés comme types de données XDR sont définies sur Ouvrir. Pour plus d'informations sur la propriété Modèle, voir Définition des propriétés de déclaration.

  • Les instances de document non-XML enregistrées en Unicode ne seront pas validées correctement, sauf si vous supprimez le marqueur d'ordre des octets au début du fichier. Le marqueur d'ordre des octets correspond aux deux premiers octets d'un fichier enregistré en Unicode.

  • Une instance de document qui contient une référence de schéma « x-schema: » est toujours validée à l'aide de cette référence de schéma, quel que soit le schéma chargé dans l'Éditeur BizTalk.

  • Une table de caractères incorrecte n'est pas un critère de validation de l'instance. Par exemple, la validation peut réussir, même si une instance contient des données comprises dans les plages de début et de fin dans la boîte de dialogue Plages de caractères incorrectes.

Voir aussi

Création d'une instance de document

Caractères de noms XML non valides

Validation d'instances et de spécifications


Gestion de tables de caractères incorrectes

Cette section traite des procédures suivantes :

  • Ajout de plages de caractères incorrectes

  • Modification de plages de caractères incorrectes

  • Suppression de plages de caractères incorrectes


Ajout de plages de caractères incorrectes

  1. Dans le menu Affichage, cliquez sur Table de caractères incorrecte.

    La boîte de dialogue Plages de caractères incorrectes s'affiche.

  2. Cliquez sur le bouton Nouvelle plage de caractères bouton Nouvelle plage de caractères.

    La boîte de dialogue Taper la plage de caractères incorrecte s'affiche.

  3. Sélectionnez une valeur dans la liste Plage de début incorrecte, puis appuyez sur la touche TAB.

  4. Sélectionnez une valeur dans la liste Plage de fin incorrecte et cliquez sur OK.

  5. Répétez les étapes 2 à 4 pour ajouter des plages de caractères incorrectes.

Important

  • Vous ne pouvez définir des plages de caractères incorrectes que pour des documents non-XML.

  • La valeur hexadécimale correcte pour un symbole point d'interrogation (?) est (0x3f). La valeur par défaut dans la liste Plage de début incorrecte et la liste Plage de fin incorrecte est ? (0x0). N'utilisez pas cette valeur pour représenter un symbole point d'interrogation. Pour spécifier le symbole point d'interrogation, sélectionnez ? Sélectionnez la valeur fournie dans la liste.

Remarques

  • Les valeurs qui apparaissent dans les listes Plage de début incorrecte et Plage de fin incorrecte sont des valeurs hexadécimales. Si vous affichez la spécification en tant que fichier source XML (Extensible Markup Language) à l'aide d'une application comme Microsoft Internet Explorer 5 ou version ultérieure, les valeurs s'affichent sous forme de valeurs décimales. Par exemple, si vous tapez un point-virgule (;) dans les zones Plage de début incorrecte et Plage de fin incorrecte, la valeur qui s'affiche est ; (0x3b). Lorsque vous utilisez un navigateur, la valeur qui apparaît est 59.

  • Pour entrer une plage de caractères incorrecte, vous pouvez également mettre en surbrillance la valeur dans la liste Plage de début incorrecte, taper un caractère numérique ou alphabétique, puis appuyer sur TAB pour passer à la liste Plage de fin incorrecte.

Voir aussi

Suppression de plages de caractères incorrectes

Modification de plages de caractères incorrectes


Modification de plages de caractères incorrectes

  1. Dans le menu Affichage, cliquez sur Table de caractères incorrecte.

    La boîte de dialogue Plages de caractères incorrectes s'affiche.

  2. Sélectionnez la plage de caractères que vous voulez modifier et cliquez sur le bouton Modifier la plage de caractères bouton Modifier la plage de caractères .

    La boîte de dialogue Taper la plage de caractères incorrecte s'affiche.

  3. Dans la liste Plage de début incorrecte, sélectionnez une valeur.

    –Ou–

    Dans la liste Plage de fin incorrecte, sélectionnez une valeur.

  4. Cliquez sur OK.

  5. Répétez les étapes 2 à 4 pour modifier de nouvelles plages de caractères incorrectes.

Important

  • Vous ne pouvez définir des plages de caractères incorrectes que pour des documents non-XML.

  • La valeur hexadécimale correcte pour un symbole point d'interrogation (?) est (0x3f). La valeur par défaut dans la liste Plage de début incorrecte et la liste Plage de fin incorrecte est ? (0x0). N'utilisez pas cette valeur pour représenter un symbole point d'interrogation. Pour spécifier le symbole point d'interrogation, cliquez sur ? (0x3f), la valeur figurant dans la liste.

Remarques

  • Les valeurs qui apparaissent dans les listes Plage de début incorrecte et Plage de fin incorrecte sont des valeurs hexadécimales. Si vous affichez la spécification en tant que fichier source XML à l'aide d'une application comme Microsoft Internet Explorer 5 ou version ultérieure, les valeurs s'affichent sous forme de valeurs décimales. Par exemple, si vous tapez un point-virgule (;) dans les zones Plage de début incorrecte et Plage de fin incorrecte, la valeur qui s'affiche est ; (0x3b). Lorsque vous utilisez un navigateur, la valeur qui apparaît est 59.

  • Pour entrer une plage de caractères, vous pouvez également mettre en surbrillance la valeur dans la liste Plage de fin incorrecte, taper un caractère numérique ou alphabétique, puis appuyer sur TAB pour passer à la liste Plage de fin incorrecte.

Voir aussi

Ajout de plages de caractères incorrectes

Suppression de plages de caractères incorrectes


Suppression de plages de caractères incorrectes

Important

  • Vous ne pouvez définir des plages de caractères incorrectes que pour des documents non-XML.
  1. Dans le menu Affichage, cliquez sur Table de caractères incorrecte.

    La boîte de dialogue Plages de caractères incorrectes s'affiche.

  2. Sélectionnez la plage de caractères que vous voulez supprimer et cliquez sur le bouton Supprimer la plage de caractères bouton Supprimer la plage de caractères.

  3. Cliquez sur Oui pour confirmer la modification.

Voir aussi

Ajout de plages de caractères incorrectes

Modification de plages de caractères incorrectes


Gestion de vues

Cette section traite des procédures suivantes :

  • Développement des éléments de l'arborescence

  • Réduction des éléments de l'arborescence

  • Affichage des valeurs de propriétés

  • Modification de la taille du texte


Développement des éléments de l'arborescence

  • Cliquez sur le nœud racine ou l'enregistrement que vous voulez développer et dans le menu Affichage, cliquez sur Développer les éléments de l'arborescence.

Remarque

  • Pour développer toute l'arborescence, vous devez cliquer sur le nœud racine. Si vous cliquez sur un enregistrement, vous développez uniquement les enregistrements et champs enfants et de cet enregistrement.

Voir aussi

Réduction des éléments de l'arborescence


Réduction des éléments de l'arborescence

  • Cliquez sur le nœud racine ou l'enregistrement que vous voulez réduire et dans le menu Affichage, cliquez sur Réduire les éléments de l'arborescence.

Remarque

  • Pour réduire toute l'arborescence, vous devez cliquer sur le nœud racine. Si vous cliquez sur un enregistrement, vous réduisez uniquement les enregistrements et champs enfants de cet enregistrement.

Voir aussi

Développement des éléments de l'arborescence


Affichage des valeurs de propriétés

  • Dans le menu Affichage, cliquez sur l'une des propriétés suivantes :
    • Déclaration

    • Référence

    • Analyser

    • Espace de noms

    • Dictionnaire

    • Liste de codes


Modification de la taille du texte

  • Dans le menu Affichage, pointez sur Taille du texte et cliquez sur la taille de votre choix.


Touches de raccourci de l'Éditeur BizTalk

Vous pouvez utiliser des touches de raccourci pour effectuer certaines tâches dans l'Éditeur BizTalk. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Server et Advanced Server, voir « Utiliser le clavier pour déplacer le pointeur de la souris ». Pour plus d'informations sur les Touches souris dans l'aide de Windows 2000 Professionnel, voir « Déplacer le pointeur de la souris en utilisant les Touches souris ».
Appuyez sur | Pour
CTRL+MAJ++ (avec la touche VERR NUM activée, appuyez simultanément sur la touche + du pavé numérique et sur la touche MAJ.) Ajouter une nouvelle annotation personnalisée lorsque le focus est sur la feuille de données d'espace de noms dans le volet de droite.

ou

Créer une propriété personnalisée dans l'onglet Déclaration, Référence, Espace de noms ou Dictionnaire.

ou

Insérer une propriété personnalisée dans une spécification. Cette fonctionnalité apparaît dans les onglets Déclaration, Référence, Espace de noms et Dictionnaire lorsqu'une propriété est affichée en surbrillance.
Touche TAB | Accéder aux boutons situés en haut à droite de la boîte de dialogue Nouvelle spécification de document.
MAJ+F10 | Ouvrir le menu contextuel des éléments mis en surbrillance.
CTRL+N | Ouvrir une nouvelle spécification.
CTRL+O | Ouvrir une spécification existante.
CTRL+S | Enregistrer une spécification.
CTRL+MAJ+R | Ajouter un nouvel enregistrement à une spécification de document.
CTRL+R | Ajouter un nouvel enregistrement à un enregistrement.
CTRL+MAJ+F | Ajouter un nouveau champ dans une spécification de document.
CTRL+F | Ajouter un nouveau champ à un enregistrement.
SUPPR | Supprimer un enregistrement ou un champ.
F4 | Mettre en surbrillance l'avertissement suivant.
F5 | Valider un schéma.
CTRL+C | Copier un objet.
CTRL+X | Couper un objet.
CTRL+V | Coller un objet.
F6 | Déplacer le focus d'un volet à l'autre dans le sens des aiguilles d'une montre.
MAJ+F6 | Déplacer le focus d'un volet à l'autre dans le sens inverse des aiguilles d'une montre.
TAB | Basculer le focus depuis l'onglet du volet de droite vers la feuille de données située en dessous. La touche TABULATION permet de déplacer le focus d'un bouton ou d'un champ à l'autre dans la boîte de dialogue.
BARRE ESPACE | Activer ou désactiver une case à cocher. L'utilisation de la barre d'espace entraîne le même résultat qu'un clic de souris lorsqu'un bouton est activé.
F2 | Activer le mode d'édition pour un nœud en surbrillance dans l'arborescence de spécification. Activer le mode d'édition pour une ligne en surbrillance dans la feuille de données du volet de droite.
MAJ+F2 Activer le mode d'édition pour les champs suivants :
  • La colonne Propriété d'une ligne d'annotation personnalisée en surbrillance de l'onglet Déclaration ou Référence.

  • La colonne Préfixe d'une ligne d'annotation personnalisée en surbrillance de l'onglet Espace de noms.

  • La colonne Propriété d'une ligne de dictionnaire personnalisée en surbrillance de l'onglet Dictionnaire.
ALT + FLÈCHE BAS | Afficher la liste d'une zone de liste active.
MAJ++ | Ajouter une nouvelle annotation personnalisée lorsque le focus est sur la feuille de données d'espace de noms dans le volet de droite.
ENTRÉE | Confirmer les modifications apportées aux nœuds et aux valeurs.
ÉCHAP | Annuler les modifications apportées aux nœuds et aux valeurs.
F1 | Consulter l'aide en ligne.
ALT+F4 | Quitter le programme.
FLÈCHE GAUCHE | Activer l'onglet vers la gauche.
FLÈCHE DROITE | Activer l'onglet situé à droite.
N'importe quelle touche de direction | Mettre en surbrillance un dossier ou un fichier du volet principal d'une boîte de dialogue, tandis que le focus est sur ce volet. Cette fonctionnalité apparaît dans les boîtes de dialogue Nouvelle spécification de document, Stocker dans WebDAV et Extraire à partir de WebDAV. Pour plus d'informations sur la boîte de dialogue Nouvelle spécification de document, voir Création et validation de spécifications. Pour plus d'informations sur WebDAV, voir Ouvertures de spécifications à partir de WebDAV.

Utilisation des Touches souris dans l'Éditeur BizTalk

Dans l'Éditeur BizTalk, certaines opérations n'ont pas de raccourci clavier. Pour effectuer les opérations suivantes, vous devez utiliser les Touches souris :

  • Déplacement

  • Opérations de glisser-déplacer

  • Copie de nœuds


Utilisation du Mappeur BizTalk

Le Mappeur Microsoft® BizTalk™ est un outil de conception de traduction permettant de créer une correspondance entre les enregistrements et les champs de deux formats de spécifications différents. Le Mappeur BizTalk utilise des liaisons et des fonctoids pour effectuer cette traduction. Les fonctoids réalisent des opérations allant de simples calculs à l'exécution de scripts élaborés.

Vous pouvez utiliser le Mappeur BizTalk pour représenter graphiquement la relation de transformation structurelle entre les éléments de données source et de destination. Cette fonctionnalité de renvoi et de manipulation des données crée un mappage qui fournit une série d'instructions définissant la relation entre deux formats de spécifications différents. Les formats de spécifications sont définis à l'aide de l'Éditeur BizTalk.

Un mappage représente les transformations de données entre une spécification source et une spécification de destination. Microsoft BizTalk Server 2002 utilise les données que vous fournissez dans un mappage pour générer des transformations XSLT (Extensible Stylesheet Language Transformations). Ensuite, la sortie XSLT est utilisée par Microsoft XML Parser (MSXML) version 3.0 au moment de l'exécution pour transformer le schéma sur le serveur. Lorsque vous créez un mappage, les informations de transformation peuvent être affichées dans l'onglet Sortie du Mappeur BizTalk.

Le Mappeur BizTalk permet l'échange ouvert de spécifications dans un format de données XDR (XML-Data Reduced). Le Mappeur BizTalk ne peut ouvrir que des spécifications enregistrées dans l'Éditeur BizTalk. Le Mappeur BizTalk ne peut pas ouvrir les fichiers XML (Extensible Markup Language) génériques ou les fichiers non-XML. Pour traduire deux fichiers XML génériques, vous devez tout d'abord les importer dans l'Éditeur BizTalk et les enregistrer en tant que spécifications.

Le Mappeur BizTalk prend en charge divers scénarios de mappage allant de simples relations parent-enfant à des boucles d'enregistrements et de hiérarchies détaillées et complexes. Lorsque le processus de mappage est terminé, un composant sérialiseur utilise la spécification pour créer un format de fichier pouvant être reconnu par votre partenaire commercial ou une application interne. Le Mappeur BizTalk comprend également un composant compilateur de feuilles de style qui utilise la représentation visuelle du mappage et crée une feuille de style XSLT.

L'illustration suivante montre le processus de mappage d'une spécification source vers une spécification de destination. Le fichier source est un document de type EDI (Electronic Data Interchange) et le fichier de destination un document de type fichier plat. Dans cet exemple, la structure du document EDI est convertie en un format XML intermédiaire, dont la structure est représentée par une spécification XDR. Le format final des données est un fichier plat. Un parseur basé sur les données (utilisant la spécification XDR) crée une version XML de la spécification EDI source. Le moteur XSL transforme ensuite cette représentation XML source en une représentation XML du format du fichier de destination. Ensuite, la spécification de destination est sérialisée vers le format natif du fichier de destination, qui est un fichier plat dans cet exemple.

Transformation d'un document EDI en document de type fichier plat

Cette section traite des rubriques suivantes :

  • Pour une description complète du Mappeur BizTalk, voir À propos du Mappeur BizTalk.

  • Pour un aide-mémoire expliquant les raisons pour lesquelles vous devez effectuer des tâches spécifiques, voir Pourquoi utiliser le Mappeur BizTalk.

  • Pour des informations détaillées sur les procédures à effectuer, voir Comment utiliser le Mappeur BizTalk.

  • Pour des instructions sur la résolution des problèmes, voir Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk.


À propos du Mappeur BizTalk

Le Mappeur BizTalk est un outil graphique évolué qui présente côte à côte les spécifications source et les spécifications de destination ; vous pouvez définir des transformations en traçant simplement des lignes entre les enregistrements, les champs et les fonctoids. Le Mappeur BizTalk utilise un standard Internet appelé Transformations XSL (Extensible Stylesheet Language) ou XSLT qui permet de transformer des documents XML (Extensible Markup Language) d'un schéma XML dans un autre.

Cette section fournit des informations détaillées sur les concepts essentiels à la compréhension du Mappeur BizTalk.

Cette section traite des rubriques suivantes :

  • Spécifications de mappage

  • Scénarios de mappage

  • Environnement du Mappeur BizTalk

  • Création de liaisons

  • Correspondance des niveaux de hiérarchie des nœuds

  • Affichage des propriétés des fonctoids, des liaisons, des champs et des enregistrements

  • Présentation des fonctoids

  • Intégration des services BizTalk en utilisant le mappage

  • Compilation de mappages

  • Test de mappages


Spécifications de mappage

Un mappage identifie la manière dont les données dans un format sont rendues dans un autre format. Deux spécifications sont nécessaires : l'une est la source, l'autre est la destination. Le mappage est un processus de traduction des données dans lequel vous définissez les correspondances entre les enregistrements et les champs de la spécification source et les enregistrements et les champs de la spécification de destination.

Il existe deux types de mappage :

  • Mappage spécifique. Ce type de mappage est conçu pour répondre aux besoins d'un partenaire commercial en particulier. Lorsque vous mappez les besoins des champs et des enregistrements d'un partenaire commercial, vous créez un mappage qui est propre à ce partenaire commercial.

  • Mappage générique. Ce type de mappage est conçu pour répondre aux besoins de plusieurs partenaires commerciaux. Dans le mappage générique, vous regroupez les besoins de plusieurs partenaires commerciaux dans un mappage unique. Dans la mesure où plusieurs organisations peuvent être interconnectées, le fait d'utiliser le même mappage pour plusieurs partenaires commerciaux peut vous permettre de réaliser des économies substantielles en termes de temps et de ressources.

Le Mappeur BizTalk offre une représentation graphique d'un mappage qui peut inclure de simples traductions d'opérations de copie de valeurs, appelées liaisons, et des manipulations complexes de structure, appelées fonctoids. En associant ces éléments, vous pouvez facilement mapper des données entre la spécification source et la spécification de destination.

Cette section traite de la rubrique suivante :

  • Fichiers source et fichiers de destination des mappages


Fichiers source et fichiers de destination des mappages

Les mappages sont des fichiers XML (Extensible Markup Language) spécifiques à Microsoft BizTalk Server 2002 qui sont créés par le Mappeur BizTalk. Vous pouvez créer des mappages sur différentes bases :

  • Normes industrielles (XML, EDIFACT ou X12)

  • Normes non industrielles (fichiers plats délimités, fichiers plats positionnels ou fichiers plats à la fois positionnels et délimités)

  • Fichiers existants

Le Mappeur BizTalk prend également en charge la création de mappages à partir de schémas non fournis par BizTalk Server. Pour créer un mappage, vous devez utiliser deux spécifications : une pour l'arborescence de la spécification source et une autre pour l'arborescence de la spécification de destination.

Fichiers BizTalk Server 2000 existants

Les mappages provenant de BizTalk Server 2000 sont presque entièrement compatibles avec BizTalk Server 2002. En revanche, si vous ouvrez puis enregistrez dans BizTalk Server 2002 un mappage que vous avez créé dans BizTalk Server 2000, son format de fichier est modifié et vous ne pouvez plus l'ouvrir dans BizTalk Server 2000.


Scénarios de mappage

Le Mappeur BizTalk prend en charge divers scénarios allant de simples opérations d'arborescence parent-enfant à des opérations plus détaillées et complexes qui impliquent des enregistrements en boucle et des hiérarchies. Par ailleurs, la complexité des scénarios de mappage est accentuée par le fait que les formats comme XML (Extensible Markup Language) offrent une grande souplesse pour la définition de formats structurés.

Opérations de mappage de base

Il s'agit des opérations de mappage les plus courantes qui consistent à mapper un ou plusieurs champs source provenant d'un parent unique de l'arborescence de la spécification source à un ou plusieurs champs de l'arborescence de la spécification de destination appartenant à un parent unique. Ce type de mappage permet des transformations très diverses, notamment l'utilisation de plusieurs fonctoids et de fonctoids en cascade, mais le scénario fondamental n'est pas compliqué par rapport à d'autres. Les opérations de mappage élémentaires comprennent également le mappage de champs issus de deux parents différents (qui ont une seule occurrence) à des champs de l'arborescence de la spécification de destination appartenant à un parent unique.

Opérations de mappage complexes

Il peut s'agir de mapper des champs provenant de parents différents (dont l'un peut avoir plusieurs occurrences) de l'arborescence de la spécification source à un parent unique de l'arborescence de la spécification de destination. Ce type de mappage implique le choix d'un chemin de bouclage approprié ; c'est généralement le cas dans les mappages de documents EDI (Electronic Data Interchange). Un tel scénario suppose que le compilateur de feuilles de style XSL (Extensible Stylesheet Language) choisit le chemin de bouclage correct sur lequel il doit itérer pour produire le résultat requis. Pour plus d'informations sur les chemins de bouclage, voir Chemins de bouclage.

Cette section traite des rubriques suivantes :

  • Chemins de bouclage

  • Ordre des enregistrements et des champs


Chemins de bouclage

Un enregistrement d'une spécification boucle si la propriété Occurrences maximales a pour valeur un astérisque (*) dans l'onglet Référence de cet enregistrement. Pour plus d'informations sur la propriété Occurrences maximales, voir Définition des propriétés de référence.

Un chemin de bouclage intervient dans un mappage lorsqu'un champ contenu dans un enregistrement de bouclage de la spécification source est lié à un champ contenu dans un enregistrement de bouclage de la spécification de destination. L'illustration suivante présente deux chemins de bouclage, l'un de Root\Record1\Field1 vers Root\RecordA\Field1, et l'autre de Root\Record2\Field2 vers \Root\RecordB\Field3.

Mappage du chemin de bouclage

Dans l'onglet Propriétés, la propriété Occurrences maximales indique que les enregistrements Record1 et RecordA bouclent, de même que Record2 et RecordB.

Le code suivant est un exemple de document d'entrée :

<Root>
<Record1 Field1="Red">
<Record1 Field1="Green">
<Record1 Field1="Blue">
<Record2 Field2="50">
<Record2 Field2="100">
</Root>

Si vous utilisez le mappage précédent, ce document d'entrée mappe sur le document de sortie suivant :

<Root>
<RecordA Field1="Red">
<RecordA Field1="Green">
<RecordA Field1="Blue">
<RecordB Field3="50">
<RecordB Field3="100">
</Root>

Chemin de bouclage multiple

Un chemin de bouclage multiple intervient dans un mappage lorsque les champs contenus dans au moins deux enregistrements en boucle de la spécification source sont liés aux champs contenus dans un seul enregistrement en boucle de la spécification de destination.

L'illustration suivante présente un exemple de chemin de bouclage multiple.

Mappage d'un chemin de bouclage multiple

Les chemins de bouclage multiples ne sont pas gérés dans le Mappeur BizTalk. Si vous tentez de compiler un mappage qui contient un chemin de bouclage multiple, l'onglet Avertissements indique que le nœud de destination comporte plusieurs chemins de bouclage source.

Voir aussi

Définition des propriétés de référence

Utilisation du fonctoid Bouclage


Ordre des enregistrements et des champs

Un ordre implicite des champs et des enregistrements de sortie n'est pas assuré dans XSL (Extensible Stylesheet Language). En effet, le Mappeur BizTalk génère XSL en parcourant la structure de la spécification de destination, puis en effectuant une propagation dans la grille de mappage pour extraire les valeurs à partir de la structure de la spécification source. Par exemple, si vous voulez créer un fichier de sortie dans lequel les enregistrements BillTo Address (FacturerÀ Adresse) figurent en premier puis sont suivis des enregistrements ShipTo Address, vous devez vous assurer que l'enregistrement BillTo Address précède l'enregistrement ShipTo Address dans la spécification de destination.

Cette structure est présentée dans l'illustration suivante.

Le champ TypeContact contient deux codes valides (BT et ST) qui identifient l'adresse soit comme une adresse BillTo Address (FacturerÀ), soit comme une adresse ShipTo Address (ExpédierÀ). Pour créer la sortie attendue, les fonctoids Égal à sont ajoutés à la grille de mappage et liés depuis les champs de la spécification source vers les enregistrements de la spécification de destination.

Dans le mappage, le premier fonctoid vérifie que la condition suivante est remplie :

TypeContact est-il égal à BT ?

Si cette condition est remplie, un enregistrement de sortie BillToAddresses(FacturerÀAdresses) est créé et les champs requis sont mappés sur cet enregistrement. Dans le cas contraire, le Mappeur BizTalk doit réitérer tous les enregistrements d'adresse d'entrée pour remplir la condition requise.

Important

  • L'ordre dans lequel les enregistrements et les champs apparaissent dans une instance de document de sortie dépend de l'ordre des enregistrements et des champs de la spécification de sortie correspondante.


Environnement du Mappeur BizTalk

Lorsque vous ouvrez le Mappeur BizTalk, vous découvrez une interface utilisateur graphique qui vous permet de créer et d'utiliser facilement des mappages.

Cette section traite des rubriques suivantes :

  • Interface utilisateur du Mappeur BizTalk

  • Menus du Mappeur BizTalk

  • Boutons de la barre d'outils du Mappeur BizTalk

  • Palette de fonctoids du Mappeur BizTalk

  • Personnalisation de l'affichage


Interface utilisateur du Mappeur BizTalk

Les deux spécifications qui sont utilisées pour créer un mappage apparaissent comme des vues de l'arborescence dans la fenêtre principale du Mappeur BizTalk. La spécification source à partir de laquelle les données sont mappées figure sur la gauche, tandis que la spécification de destination vers laquelle les données sont mappées figure sur la droite. La grille de mappage entre les deux spécifications affiche une représentation graphique de la transformation de la structure des données entre les deux spécifications. Les liaisons et les fonctoids apparaissent dans la grille de mappage. Vous pouvez déplacer le pointeur vers les bordures de la grille de mappage afin de vous déplacer facilement vers le haut, vers le bas, vers la gauche et vers la droite. Vous pouvez également ajouter des grilles de mappage supplémentaires pour regrouper vos liaisons et vos fonctoids et simplifier la vue des différentes zones du mappage. Par exemple, cela vous permet de séparer la section d'en-tête du corps du mappage.

Vous pouvez utiliser la boîte de dialogue Aperçu de la grille pour vous déplacer rapidement d'un point à un autre de la grille de mappage. Il vous suffit de faire glisser la barre verte pour vous déplacer vers le haut, le bas, la droite ou la gauche. Un fonctoid de la grille de mappage apparaît dans l'aperçu sous forme d'une case rouge entourée de noir. Si la grille de mappage comprend deux fonctoids ou plus, les fonctoids apparaissent sous forme de deux cases rouge reliées et entourées de noir.

Le volet inférieur se trouve sous les vues de l'arborescence et la grille de mappage. Il comporte quatre onglets :

  • Propriétés. Lorsque vous sélectionnez un nœud dans l'arborescence de spécification source ou l'arborescence de spécification de destination, l'onglet Propriétés affiche les propriétés et les valeurs des propriétés de ce nœud.

  • Valeurs. Cet onglet comprend deux zones de texte : Valeur du test source et Valeur de la constante de destination. Vous pouvez sélectionner un champ, puis taper une valeur dans la zone Valeur du test source. Cette opération vous permet de tester des mappages dans lesquels des valeurs réelles sont affectées aux champs. Dans la zone Valeur de la constante de destination, vous pouvez spécifier une valeur à affecter à un champ. Vous ne pouvez pas établir une liaison d'un fonctoid ou d'un nœud de la spécification source vers un champ auquel une valeur de constante est affectée.

  • Sortie. Cet onglet affiche une feuille de style XSL (Extensible Stylesheet Language) compilée lorsque vous compilez un mappage, et affiche la sortie du test lorsque vous testez un mappage.

  • Avertissements. Cet onglet affiche les messages d'avertissement du compilateur après la compilation d'un mappage. Si vous sélectionnez un avertissement dans cette zone, la liaison ou le fonctoid associé apparaît en surbrillance dans le mappage, ce qui vous permet de repérer et de corriger les erreurs.

Voir aussi

Compilation de mappages

Test de mappages

Affichage des liaisons et des fonctoids dans l'aperçu de la grille


Menus du Mappeur BizTalk

Les menus du Mappeur BizTalk regroupent les commandes de manière logique, dans le but de faciliter l'exécution des tâches. Par exemple, vous pouvez utiliser les commandes du menu Affichage pour afficher tous les enregistrements et les champs de l'arborescence de la spécification source ou pour réduire tous les enregistrements et les champs de l'arborescence de la spécification de destination.

Les menus du Mappeur BizTalk sont les suivants :

  • Fichier. Ce menu permet de créer, ouvrir, enregistrer ou fermer un mappage.

  • Modifier. Ce menu permet de remplacer la spécification source ou de destination, de supprimer un objet dans la grille de mappage ou encore d'ajouter ou supprimer des pages de la grille.

  • Affichage. Ce menu permet d'afficher la palette de fonctoids, les propriétés des fonctoids et la grille d'aperçu, de sélectionner la taille du texte pour l'affichage du Mappeur BizTalk, d'activer les onglets du volet inférieur, de développer ou de réduire les arborescences des spécifications ou de mettre en surbrillance l'avertissement suivant dans l'onglet Avertissements.

  • Outils. Ce menu permet de compiler ou de tester vos mappages et d'afficher les options du Mappeur BizTalk.

  • Aide. Ce menu permet d'obtenir des informations contextuelles, de comprendre l'utilité de certaines tâches et d'afficher des procédures d'utilisation du Mappeur BizTalk.

Voir aussi

Menus de l'Éditeur BizTalk


Boutons de la barre d'outils du Mappeur BizTalk

Le Mappeur BizTalk est doté d'une barre d'outils en complément de la barre de menus. Chaque bouton comporte une représentation graphique de la tâche correspondante. L'ordre d'apparition de gauche à droite est le suivant :

  • Nouvelle

  • Ouvrir

  • Enregistrer

  • Extraire à partir de WebDAV

  • Stocker dans WebDAV

  • Supprimer

  • Réduire

  • Développer

  • Afficher la palette de fonctoids

  • Compiler le mappage

  • Tester le mappage

  • Ajouter une page

  • Supprimer une page


Palette de fonctoids du Mappeur BizTalk

La palette de fonctoids contient tous les fonctoids du Mappeur BizTalk. Un fonctoid contient du code qui extrait les données d'un enregistrement, d'un champ de la spécification source ou d'un autre fonctoid (tel que le fonctoid Date), traite ces données de manière indépendante, puis renvoie une nouvelle valeur qui est placée dans un enregistrement ou un champ de la spécification de destination. Pour plus d'informations sur la palette de fonctoids, voir Présentation des fonctoids.

Voir aussi

Présentation des fonctoids

Utilisation des fonctoids


Personnalisation de l'affichage

Vous pouvez personnaliser l'apparence du Mappeur BizTalk de différentes manières. Par exemple, vous pouvez modifier les couleurs d'arrière-plan de la grille de mappage, spécifier de nouvelles couleurs pour les liaisons et les objets sélectionnés, modifier la couleur des messages d'avertissement du compilateur et modifier la taille du texte. Les éléments suivants peuvent faire l'objet d'une personnalisation :

  • Premier plan de la grille : lignes discontinues dans la grille de mappage.

  • Arrière-plan de la grille : couleur d'arrière-plan de la grille de mappage.

  • Liaisons fixes : liaisons opérant une copie de la valeur dans la grille de mappage.

  • Liaisons souples : liaisons de copie de valeur qui sont déplacées depuis l'arborescence de la spécification source vers l'arborescence de la spécification de destination.

  • Liaisons partielles : liaisons pour un champ ou un enregistrement dont le nœud de l'enregistrement parent est réduit.

  • Liaisons du compilateur : liaisons des directives de compilation qui sont créées automatiquement lorsque vous compilez en appuyant sur F5.

  • Avertissements du compilateur : lorsque vous sélectionnez un avertissement généré au moment de la compilation d'un mappage dans l'onglet Avertissements, la liaison ou le fonctoid est mis en surbrillance dans la couleur spécifiée pour les avertissements du compilateur.

  • Objets sélectionnés : tout objet (fonctoid ou liaison) que vous sélectionnez dans la grille de mappage s'affiche dans cette couleur.

Ces fonctions sont disponibles dans la boîte de dialogue Options, accessible via le menu Outils. Vous pouvez également apporter des modifications à la taille du texte à l'aide du menu Affichage.

Voir aussi

Options du Mappeur BizTalk : onglet Couleurs


Création de liaisons

Les Liaisons copient simplement des données depuis les enregistrements et champs de l'arborescence de spécification source vers les enregistrements et les champs de l'arborescence de spécification de destination. Le Mappeur BizTalk gère les liaisons de type « un-à-un » et « un-à-plusieurs ». Par exemple, une liaison peut relier un seul enregistrement ou champ de l'arborescence de spécification source à un seul enregistrement ou champ de l'arborescence de spécification de destination. Une liaison peut également relier un seul enregistrement ou champ de l'arborescence de spécification source à plusieurs enregistrements ou champs de l'arborescence de spécification de destination. En outre, des liaisons peuvent relier plusieurs enregistrements ou champs de l'arborescence de spécification source à un fonctoid qui établit ensuite une liaison vers un seul enregistrement ou champ de l'arborescence de spécification de destination. Plusieurs enregistrements ou champs de l'arborescence de spécification source peuvent être liés à un seul enregistrement ou champ de l'arborescence de spécification de destination.

Voir aussi

Gestion de liaisons


Correspondance des niveaux de hiérarchie des nœuds

Le Mappeur BizTalk inclut des directives de compilation. À l'aide de ces directives, vous pouvez définir le degré de correspondance entre la hiérarchie de l'arborescence de spécification source et la hiérarchie de l'arborescence de spécification de destination. Lorsque vous créez une liaison entre un champ de l'arborescence de spécification source et un champ de l'arborescence de spécification de destination, le Mappeur BizTalk ajoute automatiquement des liaisons de compilation en fonction des choix que vous avez effectués dans la zone Liaisons des spécifications de destination dans l'onglet Compilateur de la boîte de dialogue Propriétés des liaisons. Pour plus d'informations, voir Sélection des propriétés du compilateur pour les liaisons des spécifications de destination. Les schémas ci-après présentent les correspondances possibles des niveaux de hiérarchie des nœuds :

  • Aplatir les liaisons (valeur par défaut) : ce mode signifie que toutes les hiérarchies source sont aplaties dans l'enregistrement parent du nœud de destination. Dans le premier schéma, la spécification source est plus complexe que la spécification de destination. Dans le second schéma, la spécification de destination est plus complexe.

Mise à plat de la liaison pour laquelle l'arborescence de spécification source est plus complexe que l'arborescence de spécification de destination.

Mise à plat de la liaison pour laquelle l'arborescence de spécification de destination est plus complexe que l'arborescence de spécification source.

  • Faire correspondre les liaisons du haut vers le bas : ce mode fait correspondre les différents niveaux du haut vers le bas. Dans le premier schéma, la spécification source est plus complexe que la spécification de destination. Dans le second schéma, la spécification de destination est plus complexe.

Mise en correspondance des liaisons de haut en bas pour lesquelles l'arborescence de spécification source est plus complexe que l'arborescence de spécification de destination

Mise en correspondance des liaisons de haut en bas pour lesquelles l'arborescence de spécification de destination est plus complexe que l'arborescence de spécification source

  • Faire correspondre les liaisons du bas vers le haut : ce mode fait correspondre les différents niveaux du bas vers le haut. Dans le premier schéma, la spécification source est plus complexe que la spécification de destination. Dans le second schéma, la spécification de destination est plus complexe.

Mise en correspondance des liaisons de bas en haut pour lesquelles l'arborescence de spécification source est plus complexe que l'arborescence de spécification de destination

Mise en correspondance des liaisons de bas en haut pour lesquelles l'arborescence de spécification de destination est plus complexe que l'arborescence de spécification source

Le tableau suivant montre comment le Mappeur BizTalk traite les liaisons en fonction du type de directive utilisé.

Par exemple, si vous utilisez une directive de compilation aplanie, du haut vers le bas et du bas vers le haut pour les liaisons des champs de la spécification source vers les champs de la spécification de destination qui partagent le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation aplanie.

Aplanie | Du haut vers le bas | Du bas vers le haut | Résultat
1 | 1 | 1 | Le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation aplatie.
1 ou plus | 1 |  | Le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation de haut en bas.
1 ou plus |  | 1 | Le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation de bas en haut.
 | 1 ou plus | 1 ou plus | Le Mappeur BizTalk traite toutes les liaisons comme si elles étaient définies à la directive de compilation aplatie.

Voir aussi

Compilation de mappages


Affichage des propriétés des fonctoids, des liaisons, des champs et des enregistrements

La spécification source et la spécification de destination affichent les enregistrements et les champs associés à une spécification. Vous pouvez créer ces spécifications à l'aide de l'Éditeur BizTalk ou les importer dans l'Éditeur BizTalk en tant que XML bien formé, définition de type de document DTD (Document Type Definition) ou schéma XDR (XML Data Reduced). Vous pouvez utiliser n'importe quel schéma XDR créé par une organisation tierce. Toutefois, la prise en charge des groupes et des espaces de noms n'est pas assurée. La spécification source apparaît sur la gauche de la grille de mappage alors que la spécification de destination apparaît sur la droite.

Valeurs et propriétés des champs et des enregistrements

Les propriétés et les valeurs des enregistrements et des champs apparaissent dans l'onglet Propriétés situé sous le volet principal. Lorsque vous sélectionnez un enregistrement ou un champ, les propriétés et les valeurs clés des onglets de propriétés de l'Éditeur BizTalk apparaissent.

Propriétés des fonctoids et des liaisons

La grille de mappage du Mappeur BizTalk représente, de manière graphique, la structure de la transformation des données. Une liaison est représentée par une ligne qui relie un enregistrement ou un champ de l'arborescence de spécification source à un enregistrement ou un champ de l'arborescence de spécification de destination. Les liaisons permettent également de relier des enregistrements ou des champs à des fonctoids. Les fonctoids apparaissent sous forme d'icône. Les propriétés des liaisons incluent les données source et de destination, ainsi que des informations sur les directives de compilation. Les propriétés des fonctoids incluent des informations sur les paramètres d'entrée et sur les scripts.

Voir aussi

Enregistrements, champs et propriétés

Présentation des fonctoids


Présentation des fonctoids

Le Mappeur BizTalk prend en charge les transformations complexes de structure entre les enregistrements et champs de l'arborescence de spécification source et les enregistrements et champs de l'arborescence de spécification de destination. Les fonctoids effectuent des calculs par le biais de formules prédéfinies et de valeurs spécifiques appelées arguments. Ces calculs sont exécutés dans l'ordre désigné des champs et des enregistrements.

Si, après avoir sélectionné un fonctoid dans la palette de fonctoids, vous le déplacez dans la grille de mappage et créez une liaison avec des éléments provenant des arborescences de spécification source et de spécification de destination, les données peuvent être regroupées ou concaténées, les informations de date et d'heure modifiées et d'autres opérations effectuées. Par exemple, le fonctoid Addition ajoute des valeurs.

Les onglets de la Palette de fonctoids sont les suivants :

  • Chaîne : ces fonctoids manipulent des chaînes de données par le biais de fonctions de chaîne. Par exemple, le fonctoid Recherche de chaîne recherche une chaîne de texte dans une autre chaîne de texte et renvoie la position du premier caractère de la chaîne trouvée. Pour comprendre les paramètres requis par chaque fonctoid de chaîne, voir Fonctoids de chaîne.

  • Mathématique : ces fonctoids effectuent des calculs en utilisant des valeurs spécifiques, appelées arguments, dans un ordre donné. Par exemple, le fonctoid Addition ajoute les valeurs des enregistrements et des champs désignés. Pour comprendre les paramètres requis par chaque fonctoid mathématique, voir Fonctoids mathématiques.

  • Logique : ces fonctoids effectuent des tests logiques. Si un fonctoid logique est connecté à un enregistrement de la spécification de destination et renvoie la valeur « true », l'enregistrement correspondant du document de sortie est généré. Si un fonctoid logique est connecté à un enregistrement de la spécification de destination et renvoie la valeur « false », l'enregistrement correspondant du document de sortie n'est pas généré. La sortie d'un fonctoid logique peut également être acceptée comme entrée pour les autres fonctoids d'un mappage. Si un fonctoid logique et un fonctoid Bouclage sont liés ensemble, puis liés à un enregistrement de l'arborescence de la spécification de destination, le fonctoid Bouclage est utilisé uniquement lorsque le fonctoid logique renvoie « true ». Pour comprendre les paramètres requis par chaque fonctoid logique, voir Fonctoids logiques.

    Important

    • Si vous liez deux enregistrements ou champs de l'arborescence de spécification source à deux fonctoids logiques différents, puis liez chaque fonctoid logique au même enregistrement de l'arborescence de spécification de destination, seul le premier fonctoid logique est utilisé dans la transformation XSL (Extensible Stylesheet Language) générée. La liaison qui part du second fonctoid logique est ignorée.
  • Date/Heure : ces fonctoids manipulent des données de date et d'heure ou ajoutent les données de date, d'heure ou de date et d'heure actuelles à un enregistrement ou à un champ de la spécification de destination. Pour comprendre les paramètres requis par chaque fonctoid Date et heure, voir Fonctoids Date et heure.

  • Conversion : ces fonctoids correspondent aux fonctions d'ingénierie telles que DEC2HEX qui renvoient la valeur hexadécimale d'une valeur décimale. Ils permettent également de convertir un caractère à sa valeur ASCII ou de convertir une valeur au caractère ASCII correspondant. Pour comprendre les paramètres requis par chaque fonctoid de conversion, voir Fonctoids de conversion.

  • Scientifique : ces fonctoids convertissent une valeur numérique en une valeur scientifique. Par exemple, le fonctoid Cosinus permet de récupérer la valeur en radians d'un champ ou d'un enregistrement et de renvoyer la valeur du cosinus. Pour comprendre les paramètres requis par chaque fonctoid scientifique, voir Fonctoids scientifiques.

  • Cumulé : ces fonctoids renvoient la somme, la moyenne ou l'entrée minimale ou maximale d'un enregistrement en boucle. Pour comprendre les paramètres requis par chaque fonctoid cumulé, voir Fonctoids cumulés.

  • Base de données : ces fonctoids extraient des données d'une base de données. Pour comprendre les paramètres requis par chaque fonctoid de base de données, voir Fonctoids de base de données.

  • Avancé : cet onglet comprend plusieurs fonctoids qui effectuent des manipulations variées. Il contient notamment un fonctoid qui peut utiliser un script Microsoft® Visual Basic® ou Microsoft JScript® personnalisé, des fonctoids pour le mappage des valeurs, des fonctoids Bouclage, des fonctoids Index, des fonctoids Itération et des fonctoids pour la gestion et l'extraction des informations à partir de boucles d'enregistrement. Pour comprendre les paramètres requis par chaque fonctoid avancé, voir Fonctoids avancés.

Vous pouvez également créer vos propres fonctoids. Vous trouverez un exemple de fonctoid personnalisé dans le dossier \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleFunctoid. Vous pouvez également consulter un exemple de fonctoid Microsoft® .NET dans le dossier \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DateFunctoidNet sur un ordinateur doté d'une installation complète de BizTalk Server ou d'une installation personnalisée comprenant les exemples d'échanges.

Important

  • Si vous créez un fonctoid personnalisé, vous devez l'enregistrer sur chacun des ordinateurs où vous souhaitez qu'il s'affiche et fonctionne correctement. Si un fonctoid personnalisé n'est pas enregistré sur un ordinateur et qu'il est utilisé dans un mappage, il apparaît avec les lettres « FT ». Il s'affiche dans la grille de mappage mais vous ne pouvez pas le déplacer.

Cette section traite des rubriques suivantes :

  • Utilisation des fonctoids en cascade

  • Utilisation des fonctoids cumulés

  • Utilisation des fonctoids de base de données

  • Utilisation du fonctoid Nombre d'enregistrements

  • Utilisation du fonctoid Index

  • Utilisation du fonctoid Itération

  • Utilisation du fonctoid Mappage de valeurs

  • Utilisation du fonctoid Mappage de valeurs (mise à plat)

  • Utilisation du fonctoid Bouclage


Utilisation des fonctoids en cascade

Les fonctoids en cascade vous permettent de créer des mappages pour lesquels vous devez lier des champs ou des enregistrements à plusieurs fonctoids pour générer la sortie nécessaire dans un champ ou un enregistrement de la spécification de destination. Les fonctoids en cascade facilitent la création de plusieurs transformations consécutives dans la grille de mappage. Les fonctoids sont en cascade lorsqu'un fonctoid est lié à un autre fonctoid avant d'être lié à un enregistrement ou un champ de la spécification de destination. Par exemple, vous pouvez créer des fonctoids en cascade dans lesquels deux chaînes concaténées servent à générer une troisième chaîne qui est insérée dans un champ de la spécification de destination. Le nombre de fonctoids pouvant apparaître en cascade dans la grille de mappage est illimité ; cependant, des configurations complexes de fonctoids en cascade peuvent affecter les performances.


Utilisation des fonctoids cumulés

Les fonctoids cumulés fonctionnent dans le contexte du niveau des enregistrements de la spécification source. Certains enregistrements apparaissent généralement à de nombreuses reprises dans un fichier d'entrée. Par exemple, dans un ordre d'achat, la section Item est très fréquente. Cette section peut inclure les produits, les descriptions, les prix et les quantités. Le code suivant est un exemple d'ordre d'achat :

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Northwind Traders</To>
<LineItems>
  <Item>
    <Product>Computer A</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>Computer A Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>Cleaner A</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

L'illustration suivante présente cet ordre d'achat apparaissant dans l'Éditeur BizTalk.

Spécification de l'ordre d'achat

La propriété Occurrences maximales dans l'onglet Référence de l'enregistrement Élément a un astérisque (*) pour valeur. Cela indique que l'enregistrement boucle, et le Mappeur BizTalk compile cet enregistrement en tant que boucle.

Vous pouvez rechercher la somme totale de tous les postes dans l'ordre d'achat et mapper le total cumulé dans un champ d'un document de sortie. Pour ce faire, vous devez tout d'abord calculer le prix étendu de chaque enregistrement Item de l'ordre d'achat, puis additionner les totaux des enregistrements individuels lorsque le mappage s'étend à tous les enregistrements Item de l'ordre d'achat.

L'illustration suivante présente un fonctoid Multiplication et un fonctoid Somme cumulée utilisés pour additionner les enregistrements Item d'un ordre d'achat entrant et générer les résultats dans le champ POTotal (TotalOA) d'un document TotalsDocument (DocumentTotaux).

Dans cet exemple, tous les enregistrements Item qui existent sous l'enregistrement LineItems (Poste) d'un ordre d'achat entrant font partie de l'opération de cumul. Les champs Price (Prix) et Quantity (Quantité) sont envoyés à un fonctoid Multiplication. La sortie du fonctoid Multiplication devient l'entrée du fonctoid Somme cumulée. La sortie du fonctoid Somme cumulée est la valeur additionnée lors de l'intégration des enregistrements Item dans l'ordre d'achat d'entrée. Cette valeur est envoyée dans le champ POTotal (TotalOA) du document TotalsDocument (DocumentTotaux) et elle correspond à la somme de tous les produits des prix et des quantités : (2000x1)+(50x2)+(2x100)=2300.

Remarques

  • Le total cumulé d'une entrée donnée intervient sur l'enregistrement parent à partir duquel la liaison de l'entrée est établie. Ceci s'applique également aux sorties de fonctoids qui sont insérées en tant qu'entrées dans un fonctoid cumulé.

  • Les fonctoids cumulés ignorent les entrées non numériques. Par exemple, une valeur d'entrée de « trois » est ignorée.

Les fonctoids Moyenne cumulée, Minimum cumulé et Maximum cumulé agissent comme le fonctoid Somme cumulée. Le fonctoid Chaîne cumulée est différent des autres fonctoids cumulés dans le sens où il concatène des chaînes et n'additionne pas des valeurs numériques.

Voir aussi

Ajout de fonctoids cumulés

Fonctoids cumulés


Utilisation des fonctoids de base de données

Les fonctoids de base de données extraient des données d'une base de données. Pour comprendre comment les fonctoids de base de données sont utilisés, prenez l'exemple d'un important détaillant qui possède de nombreux magasins implantés sur une zone géographique très étendue. Chaque magasin est désigné par un code numérique et une liste d'adresses est distribuée à tous les partenaires. La structure de la liste d'adresses peut être la suivante :

IDMagasin : 123

Nom : Contoso, Ltd

Adresse : 1234 Main Street

Ville : Denver, Colorado

CodePostal : 97402

NuméroTéléphone : 801-555-0179

ResponsableMagasin : Anthony Chor

Dans les transactions suivantes, seul le code numérique représentant le magasin est envoyé dans un ordre d'achat. Le Mappeur BizTalk utilise ce code pour extraire les informations d'adresse d'une base de données. Cette configuration est représentée dans l'illustration suivante.

Mappage du fonctoid Base de données

Dans cette illustration, la spécification source représente un ordre d'achat entrant et la spécification de destination représente une facture. Le fonctoid Recherche dans la base de données effectue une recherche dans la base de données pour trouver l'enregistrement approprié dans la table appropriée.

fonctoid Recherche dans la base de données

La sortie du fonctoid Recherche dans la base de données peut être reliée uniquement aux fonctoids Extracteur de valeur.

Fonctoid Extracteur de valeur

Le fonctoid Extracteur de valeur extrait le nom de la colonne à partir de l'enregistrement dans lequel est effectuée la recherche. Le fonctoid Retour d'erreur génère une chaîne qui contient des informations sur les erreurs, lorsque des erreurs se produisent durant l'exécution (erreurs de connexion notamment)

Fonctoid Retour d'erreur

Le fonctoid Recherche dans la base de données requiert quatre paramètres, dans l'ordre suivant :

  1. Valeur faisant l'objet de la recherche

  2. Chaîne de connexion à la base de données

  3. Nom de la table

  4. Nom de la colonne pour la valeur de la recherche

Pour plus d'informations sur l'insertion, la suppression et le déplacement des paramètres d'entrée, voir Paramètres d'entrée.

Dans l'exemple précédent, le premier paramètre d'entrée provient du champ StoreID (IDMagasin) de l'ordre d'achat entrant, les trois autres paramètres d'entrée étant des constantes de l'onglet Général de la boîte de dialogue Propriété des fonctoids pour le fonctoid Recherche dans la base de données. Il est possible de créer des liaisons à partir de l'arborescence de spécification source pour fournir des valeurs aux quatre paramètres d'entrée. Pour plus d'informations sur l'insertion, la suppression et le déplacement des paramètres d'entrée, voir Paramètres d'entrée.

Le fonctoid Extracteur de valeur requiert deux paramètres d'entrée, dans l'ordre suivant :

  1. Liaison vers le fonctoid Recherche dans la base de données

  2. Nom de la colonne

Le fonctoid Retour d'erreur requiert un paramètre d'entrée : une liaison vers le fonctoid Recherche dans la base de données.

Remarques

  • Certains types de données Microsoft® SQL Server™ tels que text, ntext et image ne peuvent pas être utilisés comme valeurs de recherche pour le fonctoid Recherche dans la base de données.

  • Si plusieurs enregistrements correspondent aux paramètres d'entrée du fonctoid Recherche dans la base de données, le fonctoid Extracteur de valeur extrait uniquement le premier enregistrement de la table.

Voir aussi

Fonctoids de base de données

Paramètres d'entrée


Utilisation du fonctoid Nombre d'enregistrements

Le fonctoid Nombre d'enregistrements intervient dans le contexte du niveau des enregistrements de la spécification source. Certains enregistrements apparaissent généralement à de nombreuses reprises dans un fichier d'entrée. Par exemple, dans un ordre d'achat, la section Item est très fréquente. Cette section peut inclure les produits, les descriptions, les prix et les quantités. Le code suivant est un exemple d'ordre d'achat :

<PurchaseOrder>
  <From>Kevin F. Browne</From>
  <To>Northwind Traders</To>
<LineItems>
  <Item>
    <Product>Computer A</Product>
    <Description>laptop computer</Description>
    <Price>2000</Price>
    <Quantity>1</Quantity>
  </Item>
  <Item>
    <Product>Computer A Case</Product>
    <Description>laptop computer case</Description>
    <Price>50</Price>
    <Quantity>2</Quantity>
  </Item>
  <Item>
    <Product>Clearner A</Product>
    <Description>computer monitor cleaner</Description>
    <Price>2</Price>
    <Quantity>100</Quantity>
  </Item>
</LineItems>
</PurchaseOrder>

L'illustration suivante présente cet ordre d'achat apparaissant dans l'Éditeur BizTalk.

Spécification de l'ordre d'achat

La propriété Occurrences maximales dans l'onglet Référence de l'enregistrement Élément a pour valeur un astérisque (*). Cela indique que l'enregistrement Item boucle et le Mappeur BizTalk compile cet enregistrement en tant que boucle.

Vous pouvez rechercher le total des postes dans l'ordre d'achat et mapper cette valeur dans un champ du document de sortie. Cette configuration est légèrement différente de la configuration de mappage classique dans laquelle le contenu du document source est mappé sur le document de sortie. Dans ce cas, le fonctoid Nombre d'enregistrements génère la valeur qui est mappée sur le document de sortie.

Le fonctoid Nombre d'enregistrements comporte une entrée et une sortie. L'entrée est une liaison provenant d'un enregistrement en boucle de la spécification source. Cet enregistrement apparaît à de nombreuses reprises dans le document d'entrée d'origine. La sortie du fonctoid Nombre d'enregistrements est une liaison vers un champ de la spécification de destination.

L'illustration suivante présente un fonctoid Nombre d'enregistrements qui totalise le nombre d'articles dans un ordre d'achat entrant et transfère cette valeur dans le champ Number_Of_Items (Nombre_d'éléments) du document POReport (RapportOA).

Mappage du fonctoid Nombre d'enregistrements

Dans cet exemple, l'ordre d'achat entrant comporte trois articles : par conséquent, la valeur du champ Nombre_d'éléments correspond à 3.

Voir aussi

Fonctoids avancés


Utilisation du fonctoid Index

Le fonctoid Index intervient dans le contexte du niveau des enregistrements de la spécification source. Certains enregistrements apparaissent généralement à de nombreuses reprises dans un fichier d'entrée. Par exemple, dans un bulletin météorologique, la section WeatherReport (Bulletin météorologique) est très fréquente. Cette section peut inclure la température, la pression atmosphérique et la force du vent. Le code suivant est un exemple de bulletin météorologique :

<WeatherReport>
  <DailySummary>
    <Temperature>20</Temperature>
    <Pressure>80</Pressure>
    <WindSpeed>10</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>23</Temperature>
    <Pressure>78</Pressure>
    <WindSpeed>20</WindSpeed>
  </DailySummary>
  <DailySummary>
    <Temperature>24</Temperature>
    <Pressure>77</Pressure>
    <WindSpeed>16</WindSpeed>
  </DailySummary>
</WeatherReport>

L'illustration suivante présente ce bulletin météorologique dans l'Éditeur BizTalk.

Spécification du bulletin météorologique

Dans le code qui précède, la propriété Occurrences maximales (dans l'onglet Référence) de l'enregistrement DailySummary est définie sur un astérisque (*). Cela indique que cet enregistrement boucle et que le Mappeur BizTalk le compile en tant que boucle.

Vous pouvez regrouper des informations météorologiques pour les deux premiers enregistrements DailySummary du bulletin météorologique. Dans le Mappeur BizTalk, chaque champ de l'enregistrement DailySummary de la spécification source peut être relié à un fonctoid Index, et chaque fonctoid Index peut spécifier à partir de quel enregistrement DailySummary les informations sont extraites : le premier ou le deuxième. Les fonctoids Index peuvent être liés aux champs appropriés de la spécification de destination.

L'illustration suivante présente les fonctoids Index utilisés dans cette configuration.

Pour obtenir les informations de résumé du jour pour le premier jour, la valeur d'index des trois premiers fonctoids Index devrait être 1. Pour obtenir les informations de résumé du jour pour le deuxième jour, la valeur d'index des trois derniers fonctoids Index devrait être 2.

Les entrées des séquences d'index sont définies comme paramètres d'entrée dans l'onglet Général de la feuille de propriétés d'un fonctoid Index. Double-cliquez sur un fonctoid Index pour afficher sa feuille de propriétés. Le premier paramètre d'entrée identifie le champ de la spécification source qui est lié au fonctoid Index. Les paramètres ou les paramètres d'entrée suivants indiquent les valeurs d'index.

L'illustration suivante présente la feuille de propriétés du fonctoid supérieur Index dans le mappage précédent.

Propriétés du fonctoid Index

Remarques

  • Un paramètre d'entrée d'un fonctoid Index affecté à une valeur de constante non numérique est interprété par le Mappeur BizTalk pour prendre la valeur 1. Par exemple, dans l'illustration précédente, si le second paramètre d'entrée était remplacé par un paramètre d'entrée comportant une valeur « anystring » (chaîne quelconque), le résultat du mappage resterait le même.

  • Bien que les entrées des séquences d'index soient généralement des valeurs de constante dans l'onglet Général de la boîte de dialogue Propriétés des fonctoids, il est possible d'utiliser une liaison provenant d'un nœud de la spécification source pour la valeur d'entrée de la séquence. Si cette liaison provient d'un enregistrement en boucle qui n'est pas un enregistrement parent du premier paramètre d'entrée, la valeur d'entrée de la séquence d'index provient de la première instance du nœud du document entrant.

  • La valeur d'entrée de la séquence d'index est toujours liée au contexte actuel du document source.

Si un fichier d'entrée comporte plusieurs bulletins météorologiques incluant chacun plusieurs résumés du jour, vous devrez peut-être spécifier plusieurs valeurs d'index. Le code suivant est un exemple de fichier d'entrée comportant plusieurs bulletins météorologiques :

<WeatherReports>
  <WeatherReport1>
    <DailySummary>
      <Temperature>20</Temperature>
      <Pressure>80</Pressure>
      <WindSpeed>10</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>23</Temperature>
      <Pressure>78</Pressure>
      <WindSpeed>20</WindSpeed>
    </DailySummary>
  </WeatherReport1>
  <WeatherReport2>
    <DailySummary>
      <Temperature>24</Temperature>
      <Pressure>77</Pressure>
      <WindSpeed>16</WindSpeed>
    </DailySummary>
    <DailySummary>
      <Temperature>22</Temperature>
      <Pressure>79</Pressure>
      <WindSpeed>21</WindSpeed>
    </DailySummary>
  </WeatherReport2>
</WeatherReports>

Un fonctoid Index comportant deux valeurs d'index (la première correspondant à 1 et la seconde correspondant à 2) obtient la valeur d'un champ à partir du premier résumé du jour du second bulletin météorologique.

Important

  • Les valeurs d'index d'un fonctoid Index doivent être aussi nombreuses que les nœuds parents à partir du niveau du champ jusqu'au premier niveau sous le nœud racine. Par exemple, dans l'exemple de document comportant plusieurs bulletins météorologiques, deux valeurs d'index sont nécessaires. Dans l'exemple de document comportant un seul bulletin météorologique, une seule valeur d'index est nécessaire. Si vous ne définissez pas correctement le nombre de valeurs d'index d'un fonctoid Index, la sortie est générée d'après le premier nœud du document source qui correspond au premier paramètre d'entrée du fonctoid Index.

Voir aussi

Fonctoids avancés


Utilisation du fonctoid Itération

Le fonctoid Itération identifie quel numéro de séquence dans un enregistrement en boucle est en cours de mappage. L'illustration suivante présente le fonctoid Itération utilisé avec un fonctoid Égal à.

Mappage du fonctoid Itération

Il existe deux fonctoids (le fonctoid Itération fonctoid Itération et le fonctoid Égal à fonctoid Égal à ) pour chacun des deux enregistrements de la spécification de destination. L'illustration suivante présente la feuille de propriétés du fonctoid supérieur Égal à.

Feuille de propriétés du fonctoid supérieur

Le code suivant est un exemple d'instance de document entrant qui respecte la structure de la spécification source :

<Root>
<Record1 Field1="A"/>
<Record1 Field1="B"/>
</Root>

Lorsque que la spécification source boucle dans l'instance de document entrant, le fonctoid Itération renvoie la valeur 1 alors que le premier enregistrement est en cours de mappage, et la valeur 2 alors que le second enregistrement est en cours de mappage. Le fonctoid Égal à renvoie la valeur « true » lorsque ses deux paramètres d'entrée sont égaux. Par conséquent, la paire de fonctoids supérieurs renvoie la valeur « true » lorsque le premier enregistrement de l'instance de document entrant est en cours de mappage. La valeur « true » est transmise à l'enregistrement Record2 de la spécification de destination, et Record2 est écrit dans le document de sortie. Si la valeur du second paramètre d'entrée du fonctoid inférieur Égal à est égale à 2, la paire de fonctoids inférieure agit de manière similaire à la paire de fonctoids supérieure. En d'autres termes, lorsque le second enregistrement de l'instance de document entrant est mappé, l'enregistrement Record3 de la spécification de destination est écrit dans l'instance de document de sortie. Le code suivant présente l'instance de document de sortie :

<Root2>
<Record2 Field2="A"/>
<Record3 Field3="B"/>
</Root2>

Voir aussi

Fonctoids avancés


Utilisation du fonctoid Mappage de valeurs

Le fonctoid Mappage de valeurs fonctoid Mappage de valeurs requiert deux paramètres d'entrée et renvoie la valeur du second paramètre d'entrée si la valeur du premier paramètres est « true ». Dans le mappage présenté dans l'illustration ci-après, le fonctoid Mappage de valeurs est utilisé de cette manière.

Fonctoid Mappage de valeurs

Pour effectuer le mappage, vous devez définir les paramètres d'entrée de chaque fonctoid. L'illustration suivante présente la feuille de propriétés de chacun des trois fonctoids Mappage de valeurs.

Feuille de propriétés des fonctoids Mappage de valeurs

L'illustration suivante présente la feuille de propriétés du fonctoid supérieur Égal à.

Feuille de propriétés du fonctoid Égal à

La feuille de propriétés du fonctoid intermédiaire Égal à est similaire, mais son deuxième paramètre d'entrée possède une valeur Y constante. La feuille de propriétés du fonctoid Égal à inférieur est également similaire, mais son deuxième paramètre d'entrée possède une valeur Z constante.

Le code suivant est un exemple d'instance de document correspondant à la spécification source du mappage :

<Root>
  <Record1>
    <Record2 Name="X" Value="1"/>
    <Record2 Name="Y" Value="2"/>
    <Record2 Name="Z" Value="3"/>
  </Record1>
  <Record>
    <Record2 Name="X" Value="4"/>
    <Record2 Name="Y" Value="5"/>
    <Record2 Name="Z" Value="6"/>
  </Record>
  <Record1>
    <Record2 Name="X" Value="7"/>
    <Record2 Name="Y" Value="8"/>
    <Record2 Name="Z" Value="9"/>
  </Record1>
</Root>

Avec une valeur Name de X, le fonctoid supérieur Égal à renvoie une valeur « true ». Suite au renvoi de la valeur « true » par le fonctoid Égal à, le fonctoid Valeur d'attribut qui est lié renvoie une valeur de 1.

Avec ce mappage et cette instance de document source, BizTalk Server 2002 génère l'instance de document suivante :

<Root>
<Record X="1"/>
<Record Y="2"/>
<Record Z="3"/>
<Record X="4"/>
<Record Y="5"/>
<Record Z="6"/>
<Record X="7"/>
<Record Y="8"/>
<Record Z="9"/>
</Root>

Important

  • Le fonctoid Mappage de valeurs accepte les entrées booléennes uniquement sous la forme de chaînes « true » et « false » en minuscules. Par exemple, si un champ d'instance de document entrant a pour valeur « true » et est directement lié au paramètre d'entrée supérieur d'un fonctoid Mappage de valeurs, la valeur du second paramètre d'entrée du fonctoid Mappage de valeurs n'est pas transmise au document de sortie.

Voir aussi

Fonctoids avancés

Fonctoid Utilisation du fonctoid Mappage des valeurs (mise à plat)


Utilisation du fonctoid Mappage des valeurs (mise à plat)

Un scénario classique pour les utilisateurs de Microsoft Commerce Server consiste à effectuer un mappage à partir d'un catalogue Commerce Server vers un schéma à plat. Grâce au fonctoid Mappage des valeurs (mise à plat), ce type de mappage est possible. Le code suivant est un exemple de catalogue Commerce Server :

<Root>
  <Record1>
    <Record2 Name="X" Value="1"/>
    <Record2 Name="Y" Value="2"/>
    <Record2 Name="Z" Value="3"/>
  </Record1>
  <Record1>
    <Record2 Name="X" Value="4"/>
    <Record2 Name="Y" Value="5"/>
    <Record2 Name="Z" Value="6"/>
  </Record1>
  <Record1>
    <Record2 Name="X" Value="7"/>
    <Record2 Name="Y" Value="8"/>
    <Record2 Name="Z" Value="9"/>
  </Record1>
</Root>

Le code suivant est un exemple de schéma à plat :

<Root>
  <Record X="1" Y="2" Z="3"/>
  <Record X="4" Y="5" Z="6"/>
  <Record X="7" Y="8" Z="9"/>
</Root>

Dans cette configuration de mappage, il est important de conserver une correspondance un-à-un entre les trois enregistrements du catalogue et les trois enregistrements du schéma à plat. L'illustration suivante présente un mappage qui conserve cette correspondance.

fonctoid Mappage des valeurs

Dans ce mappage, la spécification source représente la structure du catalogue entrant, et la spécification de destination représente la structure du schéma à plat sortant. Il existe une paire de fonctoids (le fonctoid Égal à fonctoid Égal à et le fonctoid Mappage des valeurs (mise à plat) fonctoid Mappage des valeurs (mise à plat ) pour chacun des trois enregistrements. L'illustration suivante présente la feuille de propriétés de chacun des trois fonctoids Mappage des valeurs (mise à plat).

Feuille de propriétés du fonctoid Mappage de valeurs

L'illustration suivante présente la feuille de propriétés du fonctoid supérieur Égal à.

Feuille de propriétés du fonctoid Égal à

La feuille de propriétés du fonctoid intermédiaire Égal à est similaire, mais son deuxième paramètre d'entrée possède une valeur Y constante. La feuille de propriétés du fonctoid Égal à inférieur est également similaire, mais son deuxième paramètre d'entrée possède une valeur Z constante.

La paire de fonctoids supérieure interagit pour garantir que la valeur de X est transmise à partir de chacun des trois enregistrements du catalogue à chacun des trois enregistrements du schéma à plat. Le fonctoid Mappage des valeurs (mise à plat) renvoie la valeur du second paramètre de sa feuille de propriétés, uniquement si la valeur du premier paramètre est « true ». Pour cette raison, le fonctoid Mappage des valeurs (mise à plat) renvoie la valeur de /Root/Record/Field/@Value uniquement si le fonctoid Égal à auquel il est lié renvoie une valeur « true ». Le fonctoid Égal à auquel il est lié renvoie une valeur « true » uniquement pour les champs du catalogue entrant ayant des valeurs Name de X.

Le fonctoid Égal à de la paire de fonctoids intermédiaire renvoie une valeur « true » uniquement pour les champs de la spécification entrante ayant des valeurs Name de Y. Ainsi, cette paire de fonctoids garantit que la valeur de Y est transmise à partir de chacun des trois enregistrements du catalogue à chacun des trois enregistrements du schéma à plat. La troisième paire de fonctoids gère la valeur de Z de la même manière.

Important

  • Le fonctoid Mappage des valeurs (mise à plat) accepte les entrées booléennes uniquement sous la forme de chaînes « true » et « false » en minuscules. Par exemple, si la valeur d'un champ d'une instance de document entrant est « true » et que le champ est directement lié au paramètre d'entrée supérieur du fonctoid Mappage des valeurs (mise à plat), la valeur du second paramètre d'entrée du fonctoid Mappage des valeurs (mise à plat) n'est pas transmise au document de sortie.

Remarque

  • Si un enregistrement d'une instance de document de catalogue entrant comporte plusieurs champs possédant un attribut qui correspond au second paramètre d'entrée de l'un des fonctoids Égal à dans cette configuration de mappage, seul le dernier enregistrement ayant cette correspondance est mappé sur le document de sortie. Ainsi, dans l'exemple précédent d'un catalogue Commerce Server, s'il existait trois éléments Field (Champ) du premier élément Record (Enregistrement) dotés des attributs Name (Nom) ayant des valeurs de X, seul le dernier élément Field serait mappé.

Pour plus d'informations sur le mappage d'un schéma à plat sur un catalogue Commerce Server (mappage dans la direction opposée de la configuration de mappage précédente), voir Utilisation du fonctoid Bouclage.

Voir aussi

Fonctoids avancés

Utilisation du fonctoid Mappage de valeurs


Utilisation du fonctoid Bouclage

Le fonctoid Bouclage fonctoid Bouclage permet d'associer plusieurs enregistrements et/ou champs de la spécification source dans un seul enregistrement de la spécification de destination. Pour chaque boucle représentée comme boucle depuis un nœud de l'arborescence de spécification source vers le fonctoid Bouclage, le Mappeur BizTalk effectue un parcours en arrière depuis le nœud de l'arborescence de spécification de destination vers le nœud de l'arborescence de spécification source pour chaque liaison enfant et génère la transformation XSL (Extensible Stylesheet Language) appropriée. Toutefois, s'il existe une liaison vers un nœud de la spécification source qui a un parent d'une autre liaison de la source d'entrée (depuis un nœud de l'arborescence de spécification source vers le fonctoid Bouclage), le nœud de la spécification de destination n'est pas créé.

L'illustration suivante présente le fonctoid Bouclage utilisé de cette manière.

Mappage du fonctoid Bouclage

L'enregistrement BillTo (FacturerÀ) de la spécification source et l'enregistrement Addresses de la spécification de destination bouclent, comme l'indique le paramètre Occurrences maximales défini sur * dans les sections Attributs source et Attributs de destination de l'onglet Propriétés. Dans cet exemple, l'enregistrement Header (En-tête) de la spécification source tourne également en boucle. Si une instance de document entrant comportait trois enregistrements BillTo et deux enregistrements ShipTo, le fonctoid Bouclage les associerait pour créer cinq enregistrements Addresses (Adresses) dans le document de sortie.

Le code suivant est un exemple d'instance de document entrant :

<Root>
<BillTo Name="Karin Zimprich" Address="345 North 63rd Street"
City="Boston" PostalCode="07458"></BillTo>
<BillTo Name="Wendy Wheeler" Address="7890 Broadway"
City="Columbus" PostalCode="46290"></BillTo>
<BillTo Name="Florian Voss" Address="1234 Main Street"
City="Denver" PostalCode="97402"></BillTo>
<ShipTo Name="Kelly Focht" Address="456 First Avenue"
City="Miami" PostalCode="81406"></ShipTo>
<ShipTo Name="Jim Kim" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103"></ShipTo>
<Header ID="01"></Header>
<Header ID="02"></Header>
<Header ID="03"></Header>
</Root>

Cette instance de document entrant produirait l'instance de document de sortie suivante si elle avait été traitée par le mappage présenté dans l'illustration précédente :

<Root>
<Addresses Name="Karin Zimprich" Address="345 North 63rd Street"
City="Boston" PostalCode="07458" ID="01" />
<Addresses Name="Wendy Wheeler" Address="7890 Broadway"
City="Columbus" PostalCode="46290" ID="01" />
<Addresses Name="Florian Voss" Address="1234 Main Street"
City="Denver" PostalCode="97402" ID="01" />
<Addresses Name="Kelly Focht" Address="456 First Avenue"
City="Miami" PostalCode="81406" ID="01" />
<Addresses Name="Jim Kim" Address="567 2nd Avenue"
City="Seattle" PostalCode="98103" ID="01" />
</Root>

Notez que dans chaque enregistrement Addresses créé dans l'instance de document de sortie, la valeur du champ ID est « 01 ». Cela s'explique par le fait que l'enregistrement Header (En-tête) n'est pas lié au fonctoid Bouclage. La première valeur du champ ID de l'instance de document entrant est transmise à chaque enregistrement créé dans l'instance de document de sortie.

Important

  • Dans certains cas, il est possible que certains fonctoids ne fonctionnent pas correctement lorsqu'ils sont utilisés dans un mappage avec un fonctoid Bouclage. Si un fonctoid remplit la condition suivante, il ne produit pas les résultats attendus :
    • Au moins deux liaisons de spécification source du fonctoid sont reliées aux champs enfants des enregistrements d'entrée du fonctoid Bouclage. Les champs enfants ne sont pas des frères.

    Si vous deviez ajouter au mappage précédent un fonctoid qui répond à ces conditions, le fonctoid pourrait comporter une liaison de spécification source connectée au champ Name (Nom) sous l'enregistrement BillTo, une autre liaison de spécification source connectée au champ Name sous l'enregistrement ShipTo et une liaison de spécification de destination connectée au champ Name sous l'enregistrement Addresses.

Bouclage conditionnel

Vous pouvez effectuer un bouclage conditionnel en rattachant la sortie d'un fonctoid Bouclage et un fonctoid logique au même enregistrement de destination. Les enregistrements de destination sont créés uniquement lorsque la condition logique est remplie.

Dans l'illustration précédente, le premier fonctoid logique compare le champ Name de BillTo à « Cynthia Randall » et ne crée l'enregistrement de destination Addresses que si cette condition est remplie. Le deuxième fonctoid logique compare le champ Name de ShipTo à « Jay Adams » et ne crée l'enregistrement de destination Addresses que si cette condition est remplie. En prenant les mêmes données source dans l'exemple du fonctoid Bouclage, le résultat de cet exemple serait :

<Root>
<Addresses Name="Cynthia Randall" Address="345 ABC Street" City="Boston" PostalCode="70000" ID="01" />
<Addresses Name="Jay Adams" Address="567 ABC Avenue" City="Seattle" PostalCode="98000" ID="01" /> </Root>
</Root>

Mappage d'un schéma à plat sur un catalogue Commerce Server

Vous pouvez utiliser le fonctoid Bouclage pour mapper un schéma à plat sur un catalogue Microsoft Commerce Server. Pour plus d'informations sur les schémas à plat et les catalogues Commerce Server, voir Utilisation du fonctoid Mappage de valeurs (mise à plat).

L'illustration suivante présente un schéma à plat mappé sur un catalogue Commerce Server.

Mise à plat de fichier dans un mappage de catalogue

Important

  • Pour que ce type de mappage fonctionne correctement, vous devez effectuer les tâches suivantes :
    • Pour chaque liaison établie avec le champ Name (Nom) de la spécification de destination, définissez les propriétés des liaisons de spécification source afin que le nom soit copié. Pour plus d'informations, voir Sélection des propriétés du compilateur pour les liaisons des spécifications source.

    • Pour chaque liaison établie avec le champ Value (Valeur) de la spécification de destination, définissez les propriétés des liaisons de spécification source afin que la valeur soit copiée. Pour plus d'informations, voir Sélection des propriétés du compilateur pour les liaisons des spécifications source.

    • Pour la liaison établie entre le fonctoid Bouclage et l'enregistrement nommé Record1 de la spécification de destination, définissez les propriétés des liaisons de spécification de destination afin de faire correspondre les liaisons du haut vers le bas. Pour plus d'informations, voir Sélection des propriétés du compilateur pour les liaisons des spécifications de destination.

    • Vérifiez que l'option Autoriser plusieurs entrées dans les nœuds de destination de l'arborescence est sélectionnée dans la boîte de dialogue Options du Mappeur BizTalk. Pour plus d'informations, voir Options du Mappeur BizTalk : onglet Général.

Voir aussi

Sélection des propriétés du compilateur pour les liaisons des spécifications de destination

Sélection des propriétés du compilateur pour les liaisons des spécifications source

Utilisation du fonctoid Mappage des valeurs (mise à plat)


Intégration des services BizTalk en utilisant le mappage

Lors de l'intégration des services d'orchestration BizTalk et des services d'échanges BizTalk à l'aide d'un transport non HTTP, vous devrez peut-être créer un mappage pour convertir un nom de chemin d'accès en un nom de format. Pour plus d'informations, voir Intégration des services BizTalk.

Conversion d'un nom de chemin d'accès en un nom de format

Le code suivant est un exemple de nom de chemin d'accès de file d'attente de messages :

private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Pour convertir ce nom de chemin d'accès en un nom de format, vous devez ajouter la chaîne suivante au début du nom du chemin d'accès :

queue://Direct=OS:

Vous pouvez effectuer cette opération à l'aide du fonctoid Concaténer.

L'illustration ci-dessous montre un mappage qui utilise le fonctoid Concaténer, qui permet de concaténer deux ou plusieurs chaînes. Pour plus d'informations sur le fonctoid Concaténer, voir Fonctoids de chaîne.

Nom du chemin d'accès vers le nom de format

Double-cliquez sur le fonctoid Concaténer pour afficher ses propriétés. L'illustration ci-dessous montre les propriétés d'un fonctoid Concaténer dans un mappage qui ajoute le préfixe queue://Direct=OS: au nom de chemin d'accès private$\sourcechannel2{9e0016bf-be1f-48fe-82de-b27077ab5e73}.

Pour plus d'informations, voir Modification des propriétés des fonctoids.

Propriétés du fonctoid Concaténer


Compilation de mappages

Lorsque vous compilez des mappages, le composant compilateur du Mappeur BizTalk génère une feuille de style XSL (Extensible Stylesheet Language). Ce processus crée un mappage compilé qui peut transformer une instance de document du schéma source en une instance de document du schéma de destination. La compilation d'un mappage applique les transformations et les règles de structure qui sont spécifiées dans la grille de mappage.

Les transformations, telles que les liaisons, sont traitées dans l'ordre où les enregistrements et les champs apparaissent dans l'instance de la structure de destination. Par exemple, lorsque le Mappeur BizTalk atteint un champ ou un enregistrement de destination auquel est associée une liaison, le Mappeur BizTalk compile les propriétés de la liaison. L'action peut être une simple valeur de copie à partir d'un enregistrement ou d'un champ de la spécification source ou bien elle peut calculer des valeurs à partir d'un ou plusieurs enregistrements et champs de la source vers un ou plusieurs enregistrements et champs de la destination, en fonction des propriétés d'un fonctoid.

Le Mappeur BizTalk génère un avertissement dans l'onglet Avertissements lorsque le compilateur rencontre une situation qui risque de produire une sortie incorrecte. Par exemple, si un fonctoid qui requiert un paramètre d'entrée ne dispose d'aucun paramètre, le Mappeur BizTalk génère un avertissement dans l'onglet Avertissements lorsque le mappage est compilé. Il est conseillé de ne pas utiliser un mappage dans l'environnement de production tant qu'il génère des avertissements.

Le mappage compilé est utilisé par BizTalk Server 2002 pour effectuer la traduction réelle d'une instance d'entrée en instance de sortie.

Cette section traite de la rubrique suivante :

  • Directives de compilation

Voir aussi

Correspondance des niveaux de hiérarchie des nœuds


Directives de compilation

Lors du mappage à partir d'un élément, la transformation XSL (Extensible Stylesheet Language) typique présente l'aspect suivant :

<xsl:attribute name='CatalogPurposeCode'>
<xsl:value-of select='BCT/BCT01/text()'/>
</xsl:attribute>

Si BCT01 contient un contenu mixte, l'utilisation de « text() » permet d'accéder au premier texte jusqu'au premier sous-élément seulement. En l'absence de « text() » dans cette instruction XSLT(XSL Transformation), l'intégralité du contenu texte, y compris celui des éventuels sous-éléments, serait mappé comme une seule chaîne de texte. Le Mappeur BizTalk fournit toutefois une fonctionnalité qui permet de contrôler la copie des valeurs des nœuds de l'arborescence de la spécification source.

En cliquant avec le bouton droit sur une liaison connectée à un nœud de l'arborescence de spécification source et en sélectionnant Propriétés, vous pouvez spécifier la manière dont le Mappeur BizTalk doit gérer la transformation des données. Vous avez le choix entre les solutions suivantes :

  • Copier la valeur texte (valeur par défaut). Copie la valeur du nœud dans l'instance du document entrant. Par exemple, <Node>Bonjour<Name>François</Name>Rhein</Node> devient « Bonjour ».

  • Copier le texte et la valeur du sous-contenu. Copie la valeur concaténée du nœud et toutes les valeurs de ses descendants dans l'instance de document entrante. Par exemple, <Node>Bonjour<Name>François</Name>Rhein</Node> devient « BonjourFrançoisRhein ».

  • Copier le nom. Copie le nom du nœud dans l'instance du document entrant.

Vous pouvez également déterminer la manière dont les hiérarchies sont gérées dans le Mappeur BizTalk en cliquant avec le bouton droit sur une liaison connectée à un nœud de l'arborescence de spécification de destination et en sélectionnant Propriétés. Pour plus d'informations sur ces directives de compilation, voir Correspondance des niveaux de hiérarchie des nœuds.

Voir aussi

Sélection des propriétés du compilateur pour les liaisons des spécifications de destination

Sélection des propriétés du compilateur pour les liaisons des spécifications source


Test de mappages

Lorsque vous créez un mappage, vous pouvez utiliser le Mappeur BizTalk pour vérifier que le mappage que vous avez conçu génère la sortie correcte. La fonctionnalité Tester le mappage (option du menu Outils) génère automatiquement une instance de test du document source à partir de la spécification. Cette fonctionnalité utilise des informations fournies par la spécification source telles que le nombre d'occurrences des enregistrements et les types de données des champs, puis génère l'instance de test. Vous pouvez spécifier une valeur pour tout enregistrement ou champ dans la zone Valeur du test source dans l'onglet Valeurs, puis tester les résultats de ces données.

Le Mappeur BizTalk prend en charge les instances en tant que natives ou XML (Extensible Markup Language). Il prend également en charge les sorties natives du test de mappage, le cas échéant. Selon la spécification source et la spécification de destination de votre mappage, une ou plusieurs des options de test répertoriées dans le tableau suivant sont disponibles.

Option de test du mappage | Description
XML généré vers XML | Une instance de test du document source est créée, puis insérée dans la feuille de style. Le résultat s'affiche dans la fenêtre Sortie en XML.
XML généré vers natif | Une instance de test du document source est créée, puis insérée dans la feuille de style. Le résultat est sérialisé au format natif et s'affiche dans la fenêtre Sortie sous la forme de données natives. Cette option n'est pas disponible si le schéma de sortie est XML.
Instance XML vers XML | Un fichier d'instance que vous spécifiez est utilisé pour créer le résultat, lequel s'affiche en XML dans la fenêtre Sortie.
Instance XML vers native | Un fichier d'instance que vous spécifiez est utilisé pour créer le résultat, lequel s'affiche dans la fenêtre Sortie sous la forme de données natives. Cette option n'est pas disponible si le schéma de sortie est XML.
Instance native vers XML | Un fichier d'instance native que vous spécifiez est utilisé pour créer le résultat, lequel s'affiche dans la fenêtre Sortie au format XML. Le format de l'instance spécifiée est supposé être le même que la norme du schéma d'entrée. Cette option n'est pas disponible si le schéma d'entrée est XML.
Instance native vers native | Un fichier d'instance native que vous spécifiez est utilisé pour créer le résultat, lequel s'affiche dans la fenêtre Sortie sous la forme de données natives. Le format de l'instance spécifiée est supposé être le même que la norme du schéma d'entrée. Cette option n'est pas disponible si le schéma d'entrée ou de sortie est XML.

Lorsque vous testez un mappage, le Mappeur BizTalk le compile automatiquement. Cependant, il est conseillé de compiler d'abord un mappage, puis de résoudre tous les messages d'avertissement ou d'erreur avant de le tester. Avant le début du test, le système vous demande d'enregistrer votre fichier. Par mesure de précaution, enregistrez-le avant le test afin de conserver vos données en cas d'introduction accidentelle d'un problème dans le mappage.

Le Mappeur BizTalk vous offre la possibilité de valider les données d'instance source par rapport à la spécification source avant de tester le mappage. Si l'une des spécifications que vous utilisez dans le mappage n'est pas basée sur BizTalk Server 2002 (par exemple un fichier XDR (XML-Data Reduced)) et si vous faites appel à la fonction de validation du contenu, il se peut que la validation échoue. Si des messages d'avertissement, en particulier concernant les espaces de noms ou les groupes d'éléments, se sont affichés lors de l'ouverture du fichier XDR, n'utilisez pas la fonction de validation de contenu.

Le Mappeur BizTalk vous offre également la possibilité de valider le contenu une fois la fonctionnalité de mappage mise en œuvre. Dans ce cas, il valide les données de sortie par rapport à la spécification de destination. Comme avec la fonctionnalité Valider le contenu avant le test de mappage, si l'une des spécifications utilisées dans le mappage est une spécification non BizTalk Server (par exemple, un fichier XDR) et si vous faites appel à la fonction de validation du contenu, il se peut que la validation échoue. Si des messages d'avertissement, en particulier concernant les espaces de noms ou les groupes d'éléments, se sont affichés lors de l'ouverture du fichier XDR, n'utilisez pas la fonction de validation de contenu.

Une fois le mappage compilé, les résultats apparaissent dans l'onglet Sortie. Les données de test correspondent à la spécification de destination.

Cette section traite de la rubrique suivante :

  • Définition de délimiteurs de document

Voir aussi

Options du Mappeur BizTalk : onglet Délimiteurs de document

Options du Mappeur BizTalk : onglet Général

Test de mappages

Test des propriétés des enregistrements et des champs possédant des liaisons


Définition de délimiteurs de document

Le Mappeur BizTalk vous permet de spécifier des délimiteurs pendant le test d'un mappage. Utilisez l'onglet Délimiteurs de document pour spécifier des délimiteurs par défaut à utiliser au cours des tests et également pour indiquer si la boîte de dialogue Délimiteurs de document doit s'afficher ou non automatiquement à chaque fois que vous testez un mappage. Vous pouvez spécifier des délimiteurs uniques pour les enregistrements et champs de l'arborescence de spécification source et des délimiteurs uniques pour les enregistrements et champs de l'arborescence de spécification de destination. Vous pouvez définir des délimiteurs une fois pour toutes ou faire en sorte que le Mappeur BizTalk vous invite à spécifier des délimiteurs lors de chaque test.

Le tableau suivant répertorie les valeurs par défaut des délimiteurs.

Délimiteur | Valeur
Délimiteur d'enregistrement | ~ (0x7e)
Délimiteur de champ | * (0x2a)
Délimiteur de sous-champ | > (0x3e)
Échappement | ? (0x3f)


Pourquoi effectuer des tâches dans le Mappeur BizTalk

Cette section explique pourquoi il est nécessaire d'effectuer certaines tâches dans le Mappeur BizTalk. Le tableau suivant présente les tâches principales et leurs sous-tâches. Il présente également l'objet de chaque tâche et fournit des liens vers les procédures correspondantes.

Tâche Objet de la tâche
Modification des options du Mappeur BizTalk :
  • Options du Mappeur BizTalk : onglet Général
 Pour personnaliser le comportement du Mappeur BizTalk dans les contextes suivants :
  • Réception d'avertissement

  • Affichage et suppression des liaisons du compilateur

  • Autorisation des liaisons du contenu des enregistrements

  • Autorisation d'entrées multiples dans l'arborescence de spécifications de destination

  • Enregistrement du contenu

  • Validation du contenu
  • Options du Mappeur BizTalk : onglet Couleurs
 Pour personnaliser les couleurs de la grille de mappage.
  • Options du Mappeur BizTalk : onglet Délimiteurs de document
 Si vous utilisez une structure délimitée pour une spécification, vous devez définir des délimiteurs de document. Les délimiteurs de document sont utiles à Microsoft BizTalk Server 2002 pour le traitement des données dans un environnement de production.
  • Options du Mappeur BizTalk : Sortie XSLT
 Pour omettre ou inclure une déclaration XML (Extensible Markup Language) lors de l'envoi des données.
Création, ouverture et enregistrement de mappages :
  • Création de nouveaux mappages
 Pour permettre le processus de transformation des données entre deux sources, en utilisant des liaisons et des fonctoids.
  • Ouverture de mappages à partir d'un disque dur local
 Si vous souhaitez travailler en local sur la copie d'un mappage. Vous pouvez par exemple, souhaiter modifier un mappage puis le tester sans modifier la copie partagée qui est stockée dans WebDAV (Web Distributed Authoring and Versioning).
  • Extraction de mappages à partir de WebDAV
 Si vous devez travailler sur une copie partagée d'un mappage que d'autres utilisateurs peuvent également utiliser et modifier. Il s'agit du fichier que le Gestionnaire d'échanges de BizTalk utilise lorsqu'il traite des transactions.
  • Ouverture de mappages existants à partir d'un dossier
 Si vous souhaitez travailler en local sur la copie d'un mappage. Vous pouvez par exemple, souhaiter modifier un mappage puis le tester sans modifier la copie partagée qui est stockée dans WebDAV.
  • Enregistrement de nouveaux mappages
 Si vous souhaitez enregistrer en local la copie d'un mappage que vous venez de créer. Vous pouvez par exemple, souhaiter enregistrer le mappage que vous venez de créer sans que cela modifie la copie partagée qui est stockée dans WebDAV.
  • Enregistrement de mappages existants
 Si vous souhaitez enregistrer en local la copie du mappage que vous venez de modifier. Vous pouvez par exemple, souhaiter enregistrer le mappage que vous venez de modifier sans que cela modifie la copie partagée qui est stockée dans WebDAV.
  • Enregistrement de mappages compilés
 Pour créer un mappage que BizTalk Server peut utiliser pour convertir une instance d'entrée en instance de sortie au moment de l'exécution. Le processus de compilation stocke toutes les informations sur les spécifications source et les spécifications de destination, notamment l'ensemble du contenu et des fonctionnalités des liaisons et des objets.
  • Stockage de mappages
 Pour qu'un mappage soit disponible dans le Gestionnaire d'échanges BizTalk via WebDAV. Le fichier sera ainsi également disponible pour les autres utilisateurs.
Remplacement de spécifications :
  • Remplacement des spécifications source
 Il est probable qu'une fois le mappage créé, vous deviez modifier plus avant la spécification source pour ajouter par exemple, des enregistrements ou des champs supplémentaires. Cette fonction permet de remplacer les spécifications source et de maintenir tout ou partie des liaisons et des fonctoids que vous avez créés dans votre mappage entre la spécification source et la spécification de destination.
  • Remplacement des spécifications de destination
 Il est probable qu'une fois le mappage créé, vous deviez modifier plus avant la spécification de destination pour ajouter par exemple, des enregistrements ou des champs supplémentaires. Cette fonction permet de remplacer les spécifications de destination et de maintenir tout ou partie des liaisons et des fonctoids que vous avez créés dans votre mappage entre la spécification source et la spécification de destination.
Utilisation de pages de grilles :
  • Ajout de pages de grilles
 Pour simplifier l'affichage de votre mappage. Par exemple, si vous ajoutez une page de grille, vous pouvez placer toutes les liaisons et les fonctoids relatifs aux informations d'en-tête sur une page et les liaisons et les fonctoids relatifs au corps du mappage sur une autre page. Vous pouvez également renommer et supprimer les pages de grilles que vous avez créées.
Ajout et utilisation de fonctoids :
  • Ajout de fonctoids de chaîne
 Pour manipuler des chaînes de données. Par exemple, le fonctoid Recherche de chaîne recherche une chaîne de texte dans une autre chaîne de texte et renvoie la position du premier caractère de la chaîne trouvée.
  • Ajout de fonctoids mathématiques
 Pour effectuer des calculs en utilisant des valeurs spécifiques, appelées arguments, dans un ordre donné. Par exemple, le fonctoid Addition ajoute les valeurs des enregistrements et des champs désignés.
  • Ajout de fonctoids logiques
 Pour effectuer des tests logiques. Par exemple, si un fonctoid logique est connecté à un enregistrement de la spécification de destination et renvoie la valeur « true », l'enregistrement correspondant du document de sortie est généré. Si un fonctoid logique est connecté à un enregistrement de la spécification de destination et renvoie la valeur « false », l'enregistrement correspondant du document de sortie n'est pas généré.

Il se peut également que vous deviez ajouter un fonctoid logique à utiliser comme valeur d'entrée pour d'autres fonctoids dans un mappage.
  • Ajout de fonctoids Date et Heure
 Pour manipuler des données de date et d'heure, ajouter des données de date ou d'heure ou la date et l'heure actuelle à un enregistrement ou à un champ de la spécification de destination.
  • Ajout de fonctoids de conversion
 Pour convertir des données. Ces fonctoids permettent par exemple, de convertir un caractère à sa valeur ASCII ou de convertir une valeur au caractère ASCII correspondant. Les fonctoids de conversion correspondent aux fonctions d'ingénierie telles que DEC2HEX qui renvoient la valeur hexadécimale d'une valeur décimale.
  • Ajout de fonctoids scientifiques
 Pour convertir une valeur numérique en une valeur scientifique. Par exemple, le fonctoid Cosinus permet de récupérer la valeur en radians d'un champ ou d'un enregistrement et de renvoyer la valeur du cosinus.
  • Ajout de fonctoids cumulés
 Pour renvoyer la somme, la moyenne ou l'entrée minimale ou maximale d'un enregistrement en boucle.
  • Ajout de fonctoids de base de données
 Pour gérer la transformation des données codées en données décodées. Supposez par exemple, qu'une entreprise utilise un code pour le nom et l'adresse d'un magasin, et que son partenaire commercial a besoin de connaître le nom et l'adresse de ce magasin pour traiter une transaction. L'utilisation d'un fonctoid de base de données dans ce contexte, permet à BizTalk Server de rechercher le code dans la base de données et de le remplacer par sa valeur.
  • Ajout du fonctoid Script
 Pour utiliser un script Microsoft Visual Basic personnalisé ou Microsoft JScript afin d'effectuer des opérations adaptées que les fonctoids disponibles dans la palette de fonctoids ne permettent pas.
  • Ajout du fonctoid Nombre d'enregistrements
 Pour déterminer le nombre total d'éléments reliés à un enregistrement en boucle.

C'est par exemple un fonctoid Nombre d'enregistrements qui doit être utilisé pour totaliser le nombre d'articles présents dans un ordre d'achat entrant et transférer cette valeur dans le champ du document sortant.
  • Ajout du fonctoid Index
 Pour accéder à l'occurrence spécifique d'un enregistrement récurrent. Par exemple, si l'article d'un bon de commande se répète six fois et si vous souhaitez uniquement calculer la valeur à partir de la troisième occurrence, vous utiliserez alors le fonctoid Index.
  • Ajout du fonctoid Itération
 Pour identifier le numéro de séquence dans un enregistrement en boucle qui est en cours de mappage.
  • Ajout du fonctoid Mappage de valeurs
 Pour déplacer les données qui répondent à un critère logique, tel que Vrai ou Faux.
  • Ajout du fonctoid Mappage des valeurs (mise à plat)
 Pour déplacer les données qui répondent à un critère logique, tel que Vrai ou Faux. Ceci est identique à l'ajout du fonctoid Mappage des valeurs, mais dans ce cas, la hiérarchie est à plat. Cela signifie que si un élément se répète trois fois dans l'arborescence Spécification source, une seule occurrence est créée dans l'arborescence Spécification de destination.
  • Ajout du fonctoid Bouclage
 Pour forcer le compilateur à faire suivre une boucle aux données de l'arborescence Spécification de destination en fonction de la boucle suivie par les données de l'arborescence Spécification source. Il s'agit d'un bouclage en parallèle, qui est explicite et se produit automatiquement. Cependant, dans le cadre de mappages complexes, vous pouvez être amené à utiliser un fonctoid Bouclage pour forcer ce comportement.
  • Déplacement de fonctoids et de liaisons, ou de liaisons, entre des pages de grilles
 Pour simplifier une page de grille dont la complexité peut augmenter avec le nombre croissant de liaisons et de fonctoids.
  • Informations sur les paramètres des fonctoids
 Pour déterminer clairement les paramètres nécessaires à chaque fonctoid.
  • Paramètres d'entrée
 Pour définir les paramètres d'un fonctoid, comme une valeur de constante. Vous pouvez aussi renommer des paramètres d'entrée ou les déplacer (vers le haut ou vers le bas, dans les cas où leur ordre est important) pour modifier le moment auquel le Mappeur BizTalk les traite.
Ajout et utilisation de liaisons :
  • Création de liaisons entre les champs
 Pour copier les données d'un champ de l'arborescence Spécification source vers un champ de l'arborescence Spécification de destination.
  • Création de liaisons entre les champs et les fonctoids
 Pour copier les données d'un champ d'une Spécification source vers un fonctoid, de façon à ce quelles puissent faire l'objet de manipulations supplémentaires avant d'être transmises à l'arborescence Spécification de destination.
  • Création de liaisons entre les enregistrements et les champs
 Pour copier les données d'un enregistrement de l'arborescence Spécification source vers un champ de l'arborescence Spécification de destination.

Important

  • Pour effectuer cette tâche, activez la case à cocher Autoriser les liaisons du contenu des enregistrements dans la boîte de dialogue Options du Mappeur BizTalk.
  • Création de liaisons entre les enregistrements et les fonctoids
 Pour copier les données d'un enregistrement d'une Spécification source vers un fonctoid, de façon à ce quelles puissent faire l'objet de manipulations supplémentaires avant d'être transmises à l'arborescence Spécification de destination.

Important

  • Pour effectuer cette tâche, activez la case à cocher Autoriser les liaisons du contenu des enregistrements dans la boîte de dialogue Options du Mappeur BizTalk.
  • Création de liaisons entre les fonctoids
 Pour effectuer des tâches nécessitant l'utilisation de plusieurs fonctoids pour générer le résultat approprié dans l'arborescence Spécification de destination.
  • Autoriser les liaisons du contenu des enregistrements
 Pour permettre la création de liaisons entre des enregistrements et des champs ou bien, entre des enregistrements et des fonctoids.
  • Redirection des liaisons
 Si vous vous êtes trompé en traçant une liaison et si vous voulez retracer l'une des extrémités de la liaison.
  • Affichage des liaisons et des fonctoids dans la grille de mappage
 Pour faire défiler la grille de façon à visualiser les éventuelles liaisons ou fonctoids contenus dans la grille.
  • Affichage des liaisons et des fonctoids dans l'aperçu de la grille
 Pour afficher une représentation de l'emplacement des fonctoids sur la grille de mappage.
  • Affichage des propriétés des liaisons : Onglet Général
 Pour afficher des informations sur la source et la destination d'une liaison.
  • Affichage des propriétés des liaisons : Onglet Compilateur
 Pour afficher les propriétés du compilateur définies pour les liaisons des spécifications source et celles définies pour les liaisons des spécifications de destination.
  • Sélection des propriétés du compilateur pour les liaisons des spécifications source
 Pour contrôler la façon dont le compilateur parcourt l'arborescence de sortie. Par exemple, pour que le compilateur copie des valeurs texte, copie des valeurs texte et des valeurs sous-contenu ou bien, copie des noms depuis l'arborescence Spécification source.
  • Sélection des propriétés du compilateur pour les liaisons des spécifications de destination
 Pour contrôler la façon dont le compilateur parcourt l'arborescence de sortie. Pour faire en sorte par exemple, que le compilateur mette à plat les liaisons, qu'il fasse se correspondre les liaisons de haut en bas ou de bas en haut. Pour plus d'informations, voir Correspondance des niveaux de hiérarchie des nœuds
Création et gestion des mappages compilés :
  • Compilation de mappages
 Pour compiler un mappage que BizTalk Server peut utiliser pour convertir une instance d'entrée en instance de sortie au moment de l'exécution. Le processus de compilation stocke toutes les informations sur les spécifications source et de destination, notamment l'ensemble du contenu et des fonctionnalités des liaisons et des objets.
  • Résolution des messages d'avertissement et d'erreur après la compilation d'un mappage
 Pour repérer les erreurs dans le mappage et déterminer la façon de les corriger.
  • Ajout de valeurs de constantes
 Pour créer des données de test d'un champ de l'arborescence Spécification source ou bien, pour ajouter au moment de l'exécution une valeur de constante dans un champ de l'arborescence Spécification de destination.
Test de mappages :
  • Test des propriétés des enregistrements et des champs possédant des liaisons
 Pour vérifier que les liaisons que contient votre mappage produisent le résultat attendu.
  • Tests de mappages
 Pour vérifier que le mappage que vous avez conçu produit le résultat attendu. Vous pouvez par exemple, vérifier le nombre d'occurrences d'enregistrements, le types de données de champs, etc. Ce processus implique la génération d'une instance de test du document source à partir de la spécification.
Gestion des affichages, personnalisation de l'interface utilisateur et utilisation des touches de raccourci :
  • Développement des éléments de l'arborescence
 Pour visualiser l'ensemble des enregistrements et des champs d'une spécification à partir de l'enregistrement de nœud racine ou simplement les enregistrements et les champs à partir d'un seul enregistrement.
  • Réduction des éléments de l'arborescence
 Pour visualiser uniquement l'enregistrement du nœud racine et/ou les enregistrements parents.
  • Affichage des propriétés des enregistrements et des champs
 Pour afficher les propriétés d'un enregistrement ou d'un champ définies dans les onglets Déclaration, Référence, Analyser, Espace de noms, Dictionnaire ou Liste de codes dans l'Éditeur BizTalk.
  • Modification de la taille du volet de l'arborescence Spécification source
 Pour agrandire ou réduire l'affichage de l'arborescence Spécification source de la grille de mappage.
  • Modification de la taille du volet de l'arborescence Spécification de destination
 Pour agrandire ou réduire l'affichage de l'arborescence Spécification de destination de la grille de mappage.
  • Modification de la taille du volet inférieur
 Pour agrandire ou réduire la zone d'affichage du contenu dans les onglets Propriétés, Valeurs, Sortie ou Avertissements.
  • Modification des couleurs de la grille de mappage
 Pour modifier les couleurs du premier plan de la grille, c'est-à-dire des lignes discontinues dans la grille de mappage ou bien, en modifier les couleurs d'arrière-plan.
  • Modification de la couleur des liaisons
 Pour modifier la couleur des liaisons fixes, souples, partielles et celles du compilateur.
  • Modification de la couleur des objets sélectionnés
 Pour modifier la couleur des objets que vous sélectionnez avec le pointeur de la souris.
  • Modification de la couleur des avertissements du compilateur
 Pour modifier la couleur des enregistrements ou des champs mis en surbrillance lorsqu'un avertissement est généré.
  • Restauration des couleurs par défaut
 Pour rétablir toutes les couleurs d'origine.
  • Modification de la taille du texte
 Pour augmenter ou réduire la taille du texte dans le Mappeur BizTalk.
  • Touches de raccourci du Mappeur BizTalk
Pour utiliser les touches de raccourci, au lieu de la souris, pour effectuer certaines tâches.


Comment utiliser le Mappeur BizTalk

Cette section présente les procédures de mappage des données d'une spécification à une autre. Il est vivement conseillé de revoir la section À propos du Mappeur BizTalk afin de bien comprendre les liaisons et les fonctoids, ainsi que d'autres fonctionnalités et propriétés de mappage.

Cette section traite des rubriques suivantes :

  • Modification des options du Mappeur BizTalk

  • Création de nouveaux mappages

  • Ouverture de mappages

  • Enregistrement, stockage et fermeture de mappages

  • Remplacement de spécifications

  • Utilisation des pages de grilles

  • Gestion des fonctoids

  • Gestion de liaisons

  • Création et gestion des mappages compilés

  • Test de mappages

  • Gestion de vues

  • Personnalisation de l'interface utilisateur

  • Touches de raccourci du Mappeur BizTalk


Modification des options du Mappeur BizTalk

La boîte de dialogue Options du Mappeur BizTalk vous permet de définir des options générales et de sélectionner les couleurs de la grille de mappage.

  • Pour afficher la boîte de dialogue Options du Mappeur BizTalk, dans le menu Outils, cliquez sur Options.

    L'onglet Général apparaît par défaut.

Pour plus d'informations sur le mode d'utilisation de cette boîte de dialogue, voir les rubriques suivantes :

  • Options du Mappeur BizTalk : onglet Général

  • Options du Mappeur BizTalk : onglet Couleurs

  • Options du Mappeur BizTalk : onglet Délimiteurs de document

  • Options du Mappeur BizTalk : onglet Sortie XSLT


Options du Mappeur BizTalk : onglet Général

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Options du Mappeur BizTalk, voir Modification des options du Mappeur BizTalk.

L'onglet Général comporte huit options qui vous permettent de personnaliser le Mappeur BizTalk :

  • Avertissements pour les erreurs de liaison simple (activée par défaut) : vous recevez un message d'avertissement lorsque vous tentez de créer une liaison entre des nœuds dont les types de données ne correspondent pas.

  • Afficher les liaisons du compilateur (activée par défaut) : les liaisons du compilateur apparaissent sur un mappage après la compilation.

  • Supprimer les liaisons du compilateur après une action de l'utilisateur (désactivée par défaut) : les liaisons du compilateur disparaissent une fois qu'une action a été effectuée dans le Mappeur BizTalk.

  • Autoriser les liaisons du contenu des enregistrements (activée par défaut) : des liaisons du contenu des enregistrements vers les fonctoids peuvent être créées.

    Remarque

    • Certains fonctoids possèdent des entrées ou des sorties qui, n'utilisant pas le contenu des enregistrements, ne sont donc pas affectés par l'option Autoriser les liaisons du contenu des enregistrements. Ces entrées/sorties correspondent aux fonctoids logiques (sortie), au fonctoid Nombre (entrée), au fonctoid Itération (entrée) et au fonctoid Bouclage (entrée et sortie).
  • Autoriser plusieurs entrées dans les nœuds de destination de l'arborescence (désactivée par défaut) : deux liaisons ou plus peuvent être établies vers un nœud de l'arborescence de spécification de destination.

  • Invite d'enregistrement avant le test du mappage (activée par défaut) : lorsque vous cliquez sur Tester le mappage dans le menu Outils, le Mappeur BizTalk affiche une boîte de dialogue qui vous demande d'enregistrer les modifications apportées au fichier de mappage.

  • Valider le contenu avant le test de mappage (désactivée par défaut) : les données sont validées par rapport à l'arborescence de la spécification source avant que la fonctionnalité ait été exécutée de la spécification source vers la spécification de destination.

    Remarque

    • Si une des spécifications que vous utilisez dans le mappage est une spécification non BizTalk Server, telle qu'un fichier XDR (XML-Data Reduced), et si vous utilisez la fonction de validation du contenu, il se peut que la validation échoue. Si des messages d'avertissement, en particulier concernant les espaces de noms ou les groupes d'éléments, se sont affichés lors de l'ouverture du fichier XDR, n'utilisez pas la fonction de validation de contenu.
  • Valider le contenu après le test de mappage (désactivée par défaut) : une fois la fonctionnalité de mappage exécutée, le Mappeur BizTalk valide les données dans la spécification de destination.

    Remarque

    • Si une des spécifications que vous utilisez dans le mappage est une spécification n'appartenant pas à BizTalk Server, telle qu'un fichier XDR, et si vous utilisez la fonction de validation du contenu, il se peut que la validation échoue. Si des messages d'avertissement, en particulier concernant les espaces de noms ou les groupes d'éléments, se sont affichés lors de l'ouverture du fichier XDR, n'utilisez pas la fonction de validation de contenu.

Voir aussi

Options du Mappeur BizTalk : onglet Couleurs


Options du Mappeur BizTalk : onglet Couleurs

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Options du Mappeur BizTalk, voir Modification des options du Mappeur BizTalk.

L'onglet Couleurs inclut des options qui vous permettent de personnaliser les couleurs de la grille de mappage. Pour plus d'informations sur ces options, voir les rubriques suivantes :

  • Modification des couleurs de la grille de mappage

  • Modification de la couleur des liaisons

  • Modification de la couleur des objets sélectionnés

  • Modification de la couleur des avertissements du compilateur

  • Restauration des couleurs par défaut

Voir aussi

Options du Mappeur BizTalk : onglet Général


Options du Mappeur BizTalk : onglet Délimiteurs de document

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Options du Mappeur BizTalk, voir Modification des options du Mappeur BizTalk.

L'onglet Délimiteurs de document comporte des options destinées au test d'un mappage. Vous pouvez spécifier des délimiteurs uniques pour chaque test ou définir des délimiteurs par défaut et ne pas être invité à en définir de nouveaux au cours du test.

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Délimiteurs de document.

  3. Dans la zone Type de délimiteur, sélectionnez Délimiteur source ou Délimiteur cible.

  4. Sélectionnez une option dans les listes déroulantes ou spécifiez les informations dans les zones suivantes :
    • Délimiteur d'enregistrement

    • Délimiteur de champ

    • Délimiteur de sous-champ

    • Caractère d'échappement

    Important

    • Si vous spécifiez vos propres délimiteurs, utilisez des valeurs en caractères Unicode. Pour obtenir la liste des caractères valide, accédez à la page Pages de code globales sur le site Web Microsoft Global Software Development (www.microsoft.com/globaldev/reference/wincp.asp). Vous pouvez utiliser des codes de caractères ANSI dans la mesure où ceux-ci sont identiques aux codes de caractères Unicode, à l'exception des deux zéros de tête.
  5. Si vous ne voulez pas afficher la boîte de dialogue Délimiteurs de document à chaque fois que vous validez une instance de document, désactivez la case à cocher Demander les délimiteurs au cours du test d'instance.

Important

  • La terminaison (ou délimiteur) Null n'est pas prise en charge. Si vous en avez besoin, supprimez le délimiteur Null d'un fichier plat (ou ajoutez-le à celui-ci) avant ou après le traitement du fichier.

  • Si vous êtes invité à spécifier des délimiteurs au cours du test d'une instance parce que l'option Demander les délimiteurs au cours du test d'instance est activée, les délimiteurs que vous spécifiez servent uniquement à tester l'instance en cours. Les délimiteurs spécifiés dans l'onglet Délimiteurs de document restent les délimiteurs par défaut.

  • Si la case d'option Demander les délimiteurs au cours du test d'instance est activée, et si l'instance que vous testez est un fichier EDI contenant des informations d'enveloppe, la boîte de dialogue Délimiteurs de document ne s'affiche pas car le Mappeur BizTalk détecte automatiquement le délimiteur requis. Le Mappeur BizTalk affiche l'option Demander les délimiteurs au cours du test d'instance si vous l'avez demandé au cours du test d'instance, mais il ne peut déterminer les délimiteurs à utiliser.

Remarque

  • Si l'instance contient plusieurs documents et des informations d'enveloppe (en-tête et fin de document), seul le premier document est validé en fonction des délimiteurs de document spécifiés dans Délimiteurs de document.


Options du Mappeur BizTalk : onglet Sortie XSLT

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Options du Mappeur BizTalk, voir Modification des options du Mappeur BizTalk.

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Sortie XSLT.

  3. Dans la zone Omettre la déclaration XML, dans la liste déroulante, sélectionnez Oui pour omettre une déclaration ou Non pour l'inclure.

    Remarque

    • Cette zone indique si une déclaration XML doit être ou non générée. Une déclaration XML (si vous avez sélectionné Non) ressemble à ceci :
      <?xml version="1.0" encoding="utf-8" ?
  4. Cliquez sur OK.


Création de nouveaux mappages

Pour créer un mappage, vous devez indiquer la spécification source ainsi que la spécification de destination.

  1. Dans le menu Fichier, cliquez sur Nouveau.

    La boîte de dialogue Sélectionner le type de spécification source apparaît.

  2. Double-cliquez sur l'une des options suivantes :
    • Fichiers locaux, puis passez à l'étape 3.

    • Modèles, puis passez à l'étape 4.

    • Fichiers WebDAV, puis passez à l'étape 3.
  3. Recherchez le dossier qui contient la spécification source que vous voulez ouvrir, puis passez à l'étape 5.

  4. Cliquez sur EDIFACT, X12 ou XML, puis cliquez sur OK.

    Si vous sélectionnez EDIFACT ou X12, vous devez également sélectionner la version que vous souhaitez utiliser. Cliquez sur le dossier correspondant à la version de votre choix, puis cliquez sur OK et passez à l'étape 5.

    Important

    • Lorsque les modèles X12 inclus dans l'installation de BizTalk Server sont utilisés dans le Mappeur BizTalk, il est possible qu'un message d'erreur semblable à celui-ci s'affiche :

      La longueur du champ "ITD05" ("") n'est pas valide. Elle doit être comprise entre 48 et -1. Ce document va être rejeté.

      Les modèles X12 utilisent le type de données décimal implicite Nx. Si les données d'entrée contiennent un point décimal, la sortie ne correspondra pas au type de données personnalisé N (sans point décimal) et créera des instances incorrectes dans le fichier XML intermédiaire. Dans cette version de BizTalk Server, le sérialiseur risque de ne pas détecter, dans le fichier XML intermédiaire, la présence d'un point décimal dans les données de sortie de type N. Pour résoudre ce problème, remplacez manuellement le type de données décimal implicite dans les modèles X12 par n'importe quel autre type de données numérique.

  5. Sélectionnez la spécification source, puis cliquez sur Ouvrir ou sur OK selon le cas.

    La boîte de dialogue Sélectionner le type de spécification de destination apparaît.

  6. Double-cliquez sur l'une des options suivantes :
    • Fichiers locaux, puis passez à l'étape 7.

    • Modèles, puis passez à l'étape 8.

    • Fichiers WebDAV, puis passez à l'étape 7.
  7. Recherchez le dossier contenant la spécification de destination que vous souhaitez ouvrir, puis passez à l'étape 9.

  8. Cliquez sur EDIFACT, X12 ou XML, puis cliquez sur OK.

    Si vous sélectionnez EDIFACTou X12, vous devez également sélectionner la version que vous voulez utiliser. Cliquez sur le dossier correspondant à la version de votre choix, puis cliquez sur OK et passez à l'étape 9.

  9. Sélectionnez la spécification de destination, puis cliquez sur Ouvrir ou sur OK selon le cas.

  10. Si vous avez sélectionné un schéma XDR, il est possible que la boîte de dialogue Sélectionner l'élément racine s'affiche. Dans ce cas, sélectionnez un élément racine dans la liste Éléments racine, puis cliquez sur OK.

    Remarques

    • Si le schéma XDR (XML-Data Reduced) ne contient pas de racine, vous devez en spécifier une parmi les nœuds possibles du schéma.

    • Lorsque vous ouvrez un schéma XDR n'appartenant pas à BizTalk Server dans le Mappeur BizTalk, des messages d'erreur et/ou d'avertissement s'affichent si des groupes d'éléments ou des espaces de noms sont présents dans le schéma. Par conséquent, il est possible que le résultat du mappage ne soit pas celui escompté.

    • Les groupes ne sont pas représentés visuellement dans l'arborescence de la spécification source ou dans l'arborescence de la spécification de destination. Si votre mappage contient des schémas avec des groupes, le moteur d'exécution le valide en fonction de l'attribut de groupe, mais le Mappeur BizTalk ne représente graphiquement aucune référence de groupe.

Voir aussi

Remplacement des spécifications de destination

Remplacement des spécifications source


Ouverture de mappages

Cette section traite des procédures suivantes :

  • Ouverture de mappages à partir d'un disque dur local

  • Extraction de mappages à partir de WebDAV

  • Ouverture de mappages existants à partir d'un dossier


Ouverture de mappages à partir d'un disque dur local

  1. Dans le menu Fichier, cliquez sur Ouvrir.

    La boîte de dialogue Ouvrir la source du mappage s'affiche.

  2. Recherchez le dossier contenant le mappage que vous voulez ouvrir.

  3. Sélectionnez un mappage dans la liste, puis cliquez sur Ouvrir.

Important

  • Lorsque les modèles X12 inclus dans l'installation de BizTalk Server sont utilisés dans le Mappeur BizTalk, il est possible qu'un message d'erreur semblable à celui-ci s'affiche :

    La longueur du champ "ITD05" ("") n'est pas valide. Elle doit être comprise entre 48 et -1. Ce document va être rejeté.

    Les modèles X12 utilisent le type de données décimal implicite Nx. Si les données d'entrée contiennent un point décimal, la sortie ne correspondra pas au type de données personnalisé N (sans point décimal) et créera des instances incorrectes dans le fichier XML intermédiaire. Dans cette version de BizTalk Server, le sérialiseur risque de ne pas détecter, dans le fichier XML intermédiaire, la présence d'un point décimal dans les données de sortie de type N. Pour résoudre ce problème, remplacez manuellement le type de données décimal implicite dans les modèles X12 par n'importe quel autre type de données numérique.

Remarque

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez un mappage créé dans BizTalk Server 2000, le format du fichier sera modifié si vous l'enregistrez et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Extraction de mappages à partir de WebDAV


Extraction de mappages à partir de WebDAV

  1. Dans le menu Fichier, cliquez sur Extraire à partir de WebDav.

    La boîte de dialogue Extraire à partir de WebDav s'affiche.

  2. Dans la liste Serveur, cliquez sur le nom d'un serveur.

    Important

    • Si le port du serveur proxy n'est pas 80, tapez la chaîne suivante dans la liste Serveur, http://<nom serveur>:<numéro port>, pour accéder aux mappages stockés dans WebDAV.

    • Vous ne pouvez pas extraire des mappages sur un serveur sécurisé. Par exemple, si le serveur est https://<nom serveur>/biztalkserverrepository, vous ne pourrez accéder à aucun mappage.
  3. Recherchez le dossier contenant le mappage que vous voulez extraire, sélectionnez le mappage, puis cliquez sur Ouvrir.

Important

  • Si, lorsque vous tentez d'ouvrir des mappages existants à partir de WebDAV, vous obtenez un message d'erreur du type : « Aucun référentiel BizTalk Server trouvé sur http://<nom serveur>/BizTalkServerRepository/Maps », ré-enregistrez le fichier msdaipp.dll, puis redémarrez l'ordinateur. Pour plus d'informations sur le ré-enregistrement du fichier msdaipp.dll, voir Ré-enregistrement de msdaipp.dll pour extraire ou enregistrer des fichiers dans WebDAV.

  • Si vous utilisez des modèles BizTalk Server au format X12 dans l'Éditeur BizTalk, vous risquez de rencontrer des problèmes et d'obtenir des messages d'erreur de ce type :

    La longueur du champ "ITD05" ("") n'est pas valide. Elle doit être comprise entre 48 et -1. Ce document va être rejeté.

    Les modèles X12 utilisent le type de données décimal implicite Nx. Si les données d'entrée contiennent un point décimal, les données de sortie ne correspondront pas au type de données personnalisé N, ce qui créera des instances non valides dans le fichier XML intermédiaire. Dans cette version de BizTalk Server, le sérialiseur risque de ne pas détecter, dans le fichier XML intermédiaire, la présence d'un point décimal dans les données de sortie de type N. Pour résoudre ce problème, remplacez manuellement le type de données décimal implicite dans les modèles X12 par n'importe quel autre type de données numérique.

Remarques

  • Il est possible que votre première connexion à un serveur WebDAV (Web Distributed Authoring and Versioning) distant soit lente.

  • Pour extraire un mappage WebDAV, vous devez être autorisé à extraire des fichiers du serveur.

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez un mappage créé dans BizTalk Server 2000, le format du fichier sera modifié si vous l'enregistrez et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Ouverture de mappages à partir d'un disque dur local

Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Ouverture de mappages existants à partir d'un dossier

  1. Cliquez sur Démarrer, pointez sur Programmes et sur Accessoires, puis cliquez sur Explorateur Windows.

  2. Recherchez le fichier à afficher dans le Mappeur BizTalk.

    Si nécessaire, cliquez sur le Niveau inférieur pour réduire la taille de la fenêtre de façon à voir la fenêtre du Mappeur BizTalk.

  3. Faites glisser le fichier vers le Mappeur BizTalk.

Important

  • Si vous utilisez des modèles BizTalk Server au format X12 dans l'Éditeur BizTalk, vous risquez de rencontrer des problèmes et d'obtenir des messages d'erreur de ce type :

    La longueur du champ "ITD05" ("") n'est pas valide. Elle doit être comprise entre 48 et -1. Ce document va être rejeté.

    Les modèles X12 utilisent le type de données décimal implicite Nx. Si les données d'entrée contiennent un point décimal, les données de sortie ne correspondront pas au type de données personnalisé N, ce qui créera des instances non valides dans le fichier XML intermédiaire. Dans cette version de BizTalk Server, le sérialiseur risque de ne pas détecter, dans le fichier XML intermédiaire, la présence d'un point décimal dans les données de sortie de type N. Pour résoudre ce problème, remplacez manuellement le type de données décimal implicite dans les modèles X12 par n'importe quel autre type de données numérique.

Remarque

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez un mappage créé dans BizTalk Server 2000, le format du fichier sera modifié si vous l'enregistrez et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.


Enregistrement, stockage et fermeture de mappages

Cette section traite des procédures suivantes :

  • Enregistrement de nouveaux mappages

  • Enregistrement de mappages existants

  • Enregistrement de mappages compilés

  • Stockage de mappages

  • Fermeture de mappages


Enregistrement de nouveaux mappages

  1. Dans le menu Fichier, cliquez sur Enregistrer sous.

    La boîte de dialogue Enregistrer la source du mappage sous s'affiche.

  2. Dans la zone Nom de fichier, tapez le nom du mappage.

  3. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous souhaitez utiliser une spécification associée à des caractères ASCII, cliquez sur UTF-8. Dans le cas de spécifications associées à des jeux de caractères codés sur deux octets, cliquez sur Unicode.

Remarques

  • Lorsque vous enregistrez un mappage, le Mappeur BizTalk le compile automatiquement. Vous pouvez afficher les résultats du mappage compilé dans l'onglet Sortie.

  • Lorsque vous enregistrez un mappage, le Mappeur BizTalk l'enregistre sur votre disque dur. Pour stocker un mappage dans WebDAV (Web Distributed Authoring and Versioning), vous devez être autorisé à stocker des fichiers sur le serveur.

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez un mappage créé dans BizTalk Server 2000, le format du fichier sera modifié si vous l'enregistrez et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Stockage de mappages


Enregistrement de mappages existants

  • Dans le menu Fichier, cliquez sur Enregistrer.

Remarques

  • Lorsque vous enregistrez un mappage, le Mappeur BizTalk le compile automatiquement. Vous pouvez afficher les résultats du mappage compilé dans l'onglet Sortie.

  • Lorsque vous enregistrez un mappage, le Mappeur BizTalk l'enregistre sur votre disque dur. Pour stocker un mappage dans WebDAV (Web Distributed Authoring and Versioning), vous devez être autorisé à stocker des fichiers sur le serveur.

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez un mappage créé dans BizTalk Server 2000, le format du fichier sera modifié si vous l'enregistrez et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Stockage de mappages


Enregistrement de mappages compilés

  1. Dans le menu Fichier, cliquez sur Enregistrer le mappage compilé sous.

    La boîte de dialogue Enregistrer le mappage compilé sous s'affiche.

    Remarque

    • Cette fonctionnalité n'est disponible que si vous avez compilé un mappage.
  2. Dans la zone Nom de fichier, tapez le nom du fichier, puis cliquez sur Enregistrer.

Remarque

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez un mappage créé dans BizTalk Server 2000, le format du fichier sera modifié si vous l'enregistrez et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Stockage de mappages


Stockage de mappages

  1. Dans le menu Fichier, cliquez sur Stocker dans WebDAV.

    La boîte de dialogue Stocker dans WebDav s'affiche.

  2. Dans la liste Serveur, cliquez sur le nom d'un serveur.

    Important

    • Si le port du serveur proxy n'est pas 80, tapez la chaîne suivante dans la liste Serveur, http://<nom serveur>:<numéro port>, pour stocker les mappages dans WebDAV.

    • Vous ne pouvez pas stocker des mappages sur un serveur sécurisé. Par exemple, si le serveur est https://<nom_serveur>/biztalkserverrepository, vous ne pourrez stocker aucun mappage.
  3. Recherchez le dossier que vous voulez utiliser pour stocker votre mappage, puis tapez le nom du fichier dans la boîte de dialogue Nom de fichier.

  4. Dans la liste Codage, sélectionnez UTF-8 ou Unicode, puis cliquez sur Enregistrer.

    Si vous voulez utiliser une spécification associée aux caractères ASCII, cliquez sur UTF-8. Dans le cas de spécifications associées aux jeux de caractères codés sur deux octets, cliquez sur Unicode.

Questions d'ordre international

  • Dans le référentiel WebDAV, les fichiers doivent être enregistrés en codages Unicode uniquement. Toutefois, le référentiel WebDAV ne peut pas stocker des fichiers ayant des noms dans différentes pages de code.

  • WebDAV ne prend pas en charge les caractères Unicode dans les noms de fichier.

  • Assurez-vous que les paramètres régionaux du système sont définis dans votre langue. Par exemple, les utilisateurs internationaux qui installent la version anglaise de BizTalk Server 2002 sur une version anglaise de Microsoft® Windows® et souhaitent utiliser, dans les noms de fichier, des caractères non pris en charge dans la page de code Latin I (Windows 1252 comprenant l'anglais), doivent modifier leurs paramètres régionaux système en paramètres régionaux utilisateur.

  • Vous ne pouvez pas stocker des fichiers dont les noms comportent des jeux de caractères codés sur deux octets si vos paramètres régionaux sont incorrects. Pour plus d'informations, voir ???.xml apparaît dans la boîte de dialogue WebDAV.

Important

  • Si, lorsque vous tentez de stocker des mappages dans WebDAV, vous obtenez un message d'erreur du type : « Aucun référentiel BizTalk Server trouvé sur http://<nom serveur>/BizTalkServerRepository/Maps », réenregistrez le fichier msdaipp.dll, puis redémarrez l'ordinateur. Pour plus d'informations sur le réenregistrement du fichier msdaipp.dll, voir Ré-enregistrement de msdaipp.dll pour extraire ou stocker des fichiers dans WebDAV.

Remarques

  • Il est possible que votre première connexion à un serveur WebDAV (Web Distributed Authoring and Versioning) distant soit lente.

  • Pour stocker un mappage dans WebDAV, vous devez être autorisé à stocker des fichiers sur le serveur.

  • Si, après avoir installé BizTalk Server 2002, vous ouvrez un mappage créé dans BizTalk Server 2000, le format du fichier sera modifié si vous l'enregistrez et vous ne pourrez plus l'ouvrir dans BizTalk Server 2000.

Voir aussi

Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk


Fermeture de mappages

  • Dans le menu Fichier, cliquez sur Fermer.


Remplacement de spécifications

Cette section traite des procédures suivantes :

  • Remplacement des spécifications source

  • Remplacement des spécifications de destination


Remplacement des spécifications source

  1. Dans le menu Edition, cliquez sur Remplacer la spécification source.

    Si vous n'avez pas enregistré votre mappage, le système vous demande d'enregistrer les modifications apportées à la source du mappage.

    La boîte de dialogue Sélectionner le type de spécification source apparaît.

  2. Double-cliquez sur l'une des options suivantes :
    • Fichiers locaux, puis passez à l'étape 3.

    • Modèles, puis passez à l'étape 4.

    • Fichiers WebDAV, puis passez à l'étape 3.
  3. Recherchez le dossier contenant la spécification source, puis passez à l'étape 5.

  4. Cliquez sur EDIFACT, X12 ou XML, puis cliquez sur OK.

    Si vous sélectionnez EDIFACT ou X12, vous devez également sélectionner la version que vous souhaitez utiliser. Cliquez sur le dossier correspondant à la version de votre choix, puis cliquez sur OK et passez à l'étape 5.

  5. Sélectionnez la spécification source, puis cliquez sur Ouvrir ou sur OK selon le cas.

Remarques

  • Les valeurs du test source sont conservez lorsque vous remplacez une spécification source, à condition que les champs associés à ces valeurs existent dans la nouvelle spécification.

  • L'onglet Avertissement répertorie tous les avertissements en rapport avec les liaisons qui peuvent s'interrompre suite au remplacement de la spécification source. Si un message d'avertissement s'affiche, il est possible que le problème soit présent sur plusieurs grilles.

    Par exemple, si la grille 1 comporte un enregistrement (nommé Élément) dans l'arborescence de spécification source qui est lié à un enregistrement (nommé Numéro) dans l'arborescence de spécification de destination, et si la grille 2 contient un enregistrement (nommé Produit) dans l'arborescence de spécification source qui est lié au même enregistrement Numéro dans l'arborescence de spécification de destination, un message d'avertissement indiquant qu'il existe plusieurs entrées pour le même enregistrement s'affiche. Mais, si vous affichez la grille 1, vous ne verrez qu'une seule entrée dans l'enregistrement Numéro.

Voir aussi

Remplacement des spécifications de destination


Remplacement des spécifications de destination

  1. Dans le menu Edition, cliquez sur Remplacer la spécification de destination.

    Si vous n'avez pas enregistré votre mappage, le système vous demande d'enregistrer les modifications apportées à la source du mappage.

    La boîte de dialogue Sélectionner le type de spécification de destination apparaît.

  2. Double-cliquez sur l'une des options suivantes :
    • Fichiers locaux, puis passez à l'étape 3.

    • Modèles, puis passez à l'étape 4.

    • Fichiers WebDAV, puis passez à l'étape 3.
  3. Recherchez le dossier contenant la spécification de destination, puis passez à l'étape 5.

  4. Cliquez sur EDIFACT, X12 ou XML, puis cliquez sur OK.

    Si vous sélectionnez EDIFACT ou X12, vous devez également sélectionner la version que vous souhaitez utiliser. Cliquez sur le dossier correspondant à la version de votre choix, puis cliquez sur OK et passez à l'étape 5.

  5. Sélectionnez la spécification de destination, puis cliquez sur Ouvrir ou sur OK selon le cas.

Remarques

  • Les valeurs de constante de destination sont conservez lorsque vous remplacez une spécification de destination, à condition que les champs associés à ces valeurs existent dans la nouvelle spécification. Pour plus d'informations sur l'utilisation des constantes, voir Message de constantes.

  • L'onglet Avertissements répertorie tous les messages d'avertissement en rapport avec les liaisons pouvant s'interrompre suite au remplacement de la spécification de destination. Si un message d'avertissement s'affiche, il est possible que le problème soit présent sur plusieurs grilles.

    Par exemple, si la grille 1 comporte un enregistrement (nommé Élément) dans l'arborescence de spécification source qui est lié à un enregistrement (nommé Numéro) dans l'arborescence de spécification de destination, et si la grille 2 contient un enregistrement (nommé Produit) dans l'arborescence de spécification source qui est lié au même enregistrement Numéro dans l'arborescence de spécification de destination, un message d'avertissement indiquant qu'il existe plusieurs entrées pour le même enregistrement s'affiche. Mais, si vous affichez la grille 1, vous ne verrez qu'une seule entrée dans l'enregistrement Numéro.

Voir aussi

Ajout de valeurs de constantes

Remplacement des spécifications source


Utilisation de pages de grilles

Cette section traite des procédures suivantes :

  • Ajout de pages de grilles

  • Affectation de nouveaux noms aux pages de grilles

  • Suppression de pages de grilles


Ajout de pages de grilles

  • Dans le menu Edition, cliquez sur Ajouter une page.

Remarque

  • Le nombre maximal de pages de grilles que vous pouvez ajouter est 20.


Affectation de nouveaux noms aux pages de grilles

  • Double-cliquez sur le nom de la page de grille, tapez un nouveau nom, puis appuyez sur ENTRÉE.

Remarque

  • La fonction d'exécution automatique affiche automatiquement, au cours de la frappe, la liste des entrées précédentes qui correspondent.


Suppression de pages de grilles

  • Dans le menu Edition, cliquez sur Supprimer une page.

Remarque

  • Vous pouvez supprimer toutes les pages de grilles, sauf une.


Gestion des fonctoids

Cette section traite des rubriques suivantes :

  • Utilisation des fonctoids

  • Informations sur les paramètres des fonctoids

  • Modification des propriétés des fonctoids


Utilisation des fonctoids

La palette de fonctoids contient les fonctoids qui sont disponibles dans le Mappeur BizTalk. Vous pouvez sélectionner le fonctoid de votre choix dans la palette, puis le faire glisser vers la grille de mappage. Les différents types de fonctoids figurent dans des onglets. Vous pouvez utiliser les flèches de gauche ou de droite pour afficher les onglets masqués.

Cette section traite des procédures suivantes :

  • Ajout de fonctoids de chaîne

  • Ajout de fonctoids mathématiques

  • Ajout de fonctoids logiques

  • Ajout de fonctoids Date et Heure

  • Ajout de fonctoids de conversion

  • Ajout de fonctoids scientifiques

  • Ajout de fonctoids cumulés

  • Ajout de fonctoids de base de données

  • Ajout du fonctoid Script

  • Ajout du fonctoid Nombre d'enregistrements

  • Ajout du fonctoid Index

  • Ajout du fonctoid Itération

  • Ajout du fonctoid Mappage de valeurs

  • Ajout du fonctoid Mappage des valeurs (mise à plat)

  • Ajout du fonctoid Bouclage

  • Déplacement de fonctoids et de liaisons, ou de liaisons, entre des pages de grilles

  • Sélection de plusieurs liaisons et fonctoids

  • Suppression de fonctoids

Voir aussi

Palette de fonctoids du Mappeur BizTalk

Présentation des fonctoids


Ajout de fonctoids de chaîne

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Chaîne.

  3. Déplacez un fonctoid de chaîne de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids de chaîne spécifiques, voir Fonctoids de chaîne.

  4. Déplacez un enregistrement ou un champ de l'arborescence de spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence de spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout de fonctoids mathématiques

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Mathématique.

  3. Faites glisser un fonctoid mathématique de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids mathématiques spécifiques, voir Fonctoids mathématiques.

  4. Déplacez un enregistrement ou un champ de l'arborescence de spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence de spécification de destination.

Question d'ordre international

  • De nombreuses versions locales utilisent la virgule (,) comme symbole décimal. Un nombre utilisant une virgule comme symbole décimal va échouer lors de la validation effectuée par le Parseur Microsoft XML (MSXML) car MSXML attend un point (.). Pour résoudre ce problème, remplacez la virgule par un point dans les paramètres régionaux du système, en procédant comme suit :
    1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

    2. Double-cliquez sur Options régionales.

      La console Options régionales apparaît.

    3. Cliquez sur l'onglet Nombres.

    4. Dans la zone de liste Symbole décimal, tapez : .

    5. Cliquez sur Appliquer, puis sur OK.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout de fonctoids logiques

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Logique.

  3. Faites glisser un fonctoid logique de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids logiques spécifiques, voir Fonctoids logiques.

  4. Déplacez un enregistrement ou un champ de l'arborescence de spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement dans l'arborescence de spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarques

  • Les fonctoids logiques respectent la casse lors de la comparaison de deux chaînes. Par exemple, « Abc » et « abc » ne sont pas similaires. La casse n'est pas prise en compte uniquement lors de la comparaison de chaînes qui représentent les valeurs booléennes TRUE et FALSE. Dans ce cas, il n'existe aucune différence entre « True » et « true ».

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout de fonctoids Date et Heure

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Date/Heure.

  3. Faites glisser un fonctoid Date et Heure de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids de date et d'heure spécifiques, voir Fonctoids Date et Heure.

  4. Déplacez un enregistrement ou un champ de l'arborescence de spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence de spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarques

  • Les fonctoids Date, Heure et Date et Heure nécessitent uniquement une liaison vers un champ ou un enregistrement de l'arborescence de spécification de destination.

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout de fonctoids de conversion

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Conversion.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser un fonctoid de conversion de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids de conversion spécifiques, voir Fonctoids de conversion.

  4. Déplacez un enregistrement ou un champ de l'arborescence de spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence de spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout de fonctoids scientifiques

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Scientifique.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser un fonctoid scientifique de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids scientifiques spécifiques, voir Fonctoids scientifiques.

  4. Déplacez un enregistrement ou un champ de l'arborescence de spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence de spécification de destination.

Important

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout de fonctoids cumulés

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Cumulé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser un fonctoid cumulé de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids cumulés spécifiques, voir Fonctoids cumulés.

  4. Déplacez un champ (avec un enregistrement parent en boucle) dans l'arborescence de spécification source vers le fonctoid dans la grille de mappage, puis déplacez le fonctoid vers un enregistrement ou un champ dans l'arborescence de spécification de destination.

    Pour plus d'informations sur les enregistrements de bouclage, voir Utilisation des fonctoids cumulés.

Important

  • Pour plus d'informations sur le contexte de cette procédure, voir Utilisation des fonctoids cumulés.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout de fonctoids de base de données

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Base de données.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser un fonctoid de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur les fonctoids de bases de données, voir Fonctoids de base de données.

Important

  • Pour plus d'informations sur la façon d'utiliser les fonctoids de bases de données pour extraire des informations d'une base de données, voir Utilisation des fonctoids de bases de données.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Script

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Script fonctoid script vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Script, voir Fonctoids avancés.

  4. Double-cliquez sur le fonctoid Script.

    La boîte de dialogue Propriétés des fonctoids s'affiche.

  5. Cliquez sur l'onglet Script.

  6. Dans la zone Langage de script, sélectionnez VBScript ou JScript, tapez le script souhaité dans la zone Script du fonctoid, puis cliquez sur OK.

  7. Déplacez un enregistrement ou un champ de l'arborescence de spécification source vers le fonctoid Script dans la grille de mappage, puis déplacez le fonctoid Script vers un enregistrement ou un champ dans l'arborescence de spécification de destination.

Important

  • S'il existe plusieurs fonctions dans un fonctoid Script, la première fonction constitue la fonction principale. Les paramètres de cette fonction doivent être définis s'il existe des liaisons dans le fonctoid.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Gestion de vues


Ajout du fonctoid Nombre d'enregistrements

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Nombre d'enregistrements fonctoid Nombre d'enregistrements de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Nombre d'enregistrements, voir Fonctoids avancés.

  4. Déplacez un enregistrement en boucle de l'arborescence de spécification source vers le fonctoid Nombre d'enregistrements dans la grille de mappage, puis déplacez le fonctoid Nombre d'enregistrements vers un champ dans l'arborescence de spécification de destination.

    Pour plus d'informations sur les enregistrements de bouclage, voir Utilisation du fonctoid Nombre d'enregistrements.

Important

  • Pour plus d'informations sur le contexte de cette procédure, voir Utilisation du fonctoid Nombre d'enregistrements.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Index

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Index fonctoid Index de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Index, voir Fonctoids avancés.

  4. Déplacez un enregistrement (avec un enregistrement parent en boucle) de l'arborescence de spécification source vers le fonctoid Index dans la grille de mappage, puis déplacez le fonctoid Index vers un champ dans l'arborescence de spécification de destination.

    Pour plus d'informations sur les comptes de services, voir Utilisation d'un compte de services.

  5. Double-cliquez sur le fonctoid Index afin d'afficher sa feuille de propriétés.

  6. Cliquez sur le bouton Insérer un nouveau paramètre, bouton Insérer un nouveau paramètre, tapez la valeur de l'index, puis appuyez sur ENTRÉE.

  7. Répétez l'étape 6 autant de fois que nécessaire.

  8. Cliquez sur OK.

Important

  • Pour plus d'informations sur le contexte de cette procédure, voir Utilisation du fonctoid Index.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Itération

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Itération fonctoid Itération de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Itération, voir Fonctoids avancés.

Important

  • Pour plus d'informations sur l'utilisation du fonctoid Itération, voir Utilisation du fonctoid Itération.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Mappage de valeurs

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Mappage de valeurs fonctoid Mappage de valeurs de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Mappage de valeurs, voir Fonctoids avancés.

Important

  • Pour plus d'informations sur le mode d'utilisation du fonctoid Mappage de valeurs, voir Utilisation du fonctoid Mappage de valeurs.

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Ajout du fonctoid Mappage des valeurs (mise à plat)

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Mappage des valeurs (mise à plat)

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Mappage des valeurs (mise à plat) fonctoid Mappage des valeurs (mise à plat) de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Mappage des valeurs (mise à plat), voir Fonctoids avancés.

Important

  • Pour plus d'informations sur le mode d'utilisation du fonctoid Mappage des valeurs (mise à plat), voir Utilisation du fonctoid Mappage des valeurs (mise à plat).

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Ajout du fonctoid Mappage de valeurs

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Ajout du fonctoid Bouclage

  1. Dans le menu Affichage, cliquez sur Palette de fonctoids.

  2. Dans la Palette de fonctoids, cliquez sur l'onglet Avancé.

    Il se peut que vous deviez cliquer sur la flèche de droite de la Palette de fonctoids pour afficher l'onglet.

  3. Faites glisser le fonctoid Bouclage fonctoid Bouclage de la Palette de fonctoids vers la grille de mappage.

    Pour plus d'informations sur le fonctoid Bouclage, voir Fonctoids avancés.

Important

  • Dans certains cas, il est possible que certains fonctoids ne fonctionnent pas correctement lorsqu'ils sont utilisés dans un mappage avec un fonctoid Bouclage. Dans les conditions ci-après, le résultat d'un fonctoid ne sera pas correct :
    • Le fonctoid comporte plusieurs liaisons de spécification source.

    • Au moins deux liaisons de spécification source du fonctoid sont reliées aux champs enfants des enregistrements d'entrée du fonctoid Bouclage. Les champs enfants ne sont pas des frères.

    • La liaison de spécification de destination du fonctoid est reliée à un champ enfant de l'enregistrement de sortie du fonctoid Bouclage.
  • Pour plus d'informations sur le fonctoid Bouclage, voir Utilisation du fonctoid Bouclage :

  • Pour créer une liaison entre un fonctoid et un enregistrement, vous devez activer la propriété Autoriser les liaisons du contenu des enregistrements. Pour cela, cliquez sur Options dans le menu Outils. Dans la boîte de dialogue Options du Mappeur BizTalk, onglet Général, activez la case à cocher Autoriser les liaisons du contenu des enregistrements et cliquez sur OK.

Remarque

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Autoriser les liaisons du contenu des enregistrements

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids

Présentation des fonctoids


Déplacement de fonctoids ou de liaisons entre des pages de grilles

  1. Sélectionnez le fonctoid ou la liaison que vous voulez déplacer.

    Remarques

    • Si vous sélectionnez un fonctoid, toutes ses liaisons associées sont également sélectionnées et déplacées.

    • Pour déplacer un fonctoid, il est nécessaire que toutes ses liaisons et tous ses fonctoids associés dans la chaîne soient sélectionnés.
  2. Si nécessaire, cliquez sur la flèche droite ou gauche pour afficher l'onglet de la page dans laquelle vous souhaitez placer le fonctoid ou la liaison.

  3. Faites glisser le fonctoid ou la liaison vers l'onglet de la page vers laquelle vous voulez le (ou la) déplacer et maintenez-le (ou la) au-dessus de l'onglet jusqu'à ce que la page de grilles apparaisse.

  4. Faites glisser le fonctoid ou la liaison vers l'emplacement sur la grille dans lequel vous voulez le (ou la) placer.

Remarque

  • Avant de déplacer un fonctoid et ses liaisons d'une page vers une autre, il faut que toutes les liaisons qui y sont connectées soient visibles. Pour cela, développez le nœud source et le nœud de destination dans lesquels figurent les liaisons connectées au fonctoid.


Sélection de plusieurs liaisons et fonctoids

  • Faites glisser le curseur parmi les liaisons et les fonctoids à sélectionner.


Suppression de fonctoids

  1. Cliquez avec le bouton droit sur le fonctoid que vous souhaitez supprimer, puis cliquez sur Supprimer.

  2. Dans la boîte de dialogue de confirmation, cliquez sur Oui.


Informations sur les paramètres des fonctoids

Cette section présente, décrit et illustre les paramètres de chaque fonctoid de Microsoft BizTalk Server 2002.

Cette section traite des rubriques suivantes :

  • Fonctoids de chaîne

  • Fonctoids mathématiques

  • Fonctoids logiques

  • Fonctoids Date et Heure

  • Fonctoids de conversion

  • Fonctoids scientifiques

  • Fonctoids cumulés

  • Fonctoids de base de données

  • Fonctoids avancés


Fonctoids de chaîne

Fonctoid Paramètres
Fonctoid Recherche de chaîne Recherche de chaîne

Renvoie la position dans une chaîne à laquelle une autre chaîne spécifiée commence.

 Ce fonctoid requiert deux paramètres d'entrée. Le premier champ relié au fonctoid est la chaîne qui détermine la position de la deuxième chaîne.
Fonctoid Chaîne de gauche Chaîne de gauche

Renvoie un nombre de caractères spécifié depuis un élément de texte, en commençant par le caractère le plus à gauche.

 Ce fonctoid requiert deux paramètres d'entrée. Le premier champ relié au fonctoid est la chaîne de caractères qui détermine la chaîne de caractères de sortie. Le deuxième champ relié au fonctoid détermine le nombre de caractères renvoyés en tant que valeur de sortie. Le résultat de la sortie est une chaîne de caractères constituant un sous-ensemble du premier champ relié au fonctoid.
Fonctoid Minuscules Minuscules

Convertit un élément de texte en caractères minuscules.

 Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Chaîne de droite Chaîne de droite

Extrait un nombre de caractères spécifié d'un élément de texte, en commençant par le caractère le plus à droite.

 Ce fonctoid requiert deux paramètres d'entrée. Le premier champ relié au fonctoid est la chaîne de caractères qui détermine la chaîne de caractères de sortie. Le deuxième champ relié au fonctoid détermine le nombre de caractères renvoyés en tant que valeur de sortie. Le résultat de la sortie est une chaîne de caractères constituant un sous-ensemble du premier champ relié au fonctoid.
Fonctoid « Longueur de chaîne » Longueur de chaîne

Renvoie la taille d'un objet sous la forme d'un entier, à l'exception des caractères tampon.

 Ce fonctoid requiert un paramètre d'entrée. La valeur de sortie indique la taille, en caractères, des données contenues dans le champ d'entrée.
Fonctoid Extraction de chaîne Extraction de chaîne

Extrait une chaîne spécifiée par les positions de début et de fin d'une chaîne d'entrée.

 Ce fonctoid requiert trois paramètres d'entrée.

L'ordre dans lequel vous reliez les champs au fonctoid doit respecter les critères suivants :

  3. Champ Chaîne

  4. Champ Position de début

  5. Champ Position de fin
Fonctoid Concaténer Concaténer

Concatène une séquence de chaînes d'entrée.

 Ce fonctoid peut recevoir plusieurs paramètres d'entrée.
Fonctoid Enlever la chaîne de gauche Enlever la chaîne de gauche

Supprime les espaces à gauche d'un élément de texte.

 Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Enlever la chaîne de droite Enlever la chaîne de droite

Supprime les espaces à droite d'un élément de texte.

 Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Majuscules Majuscules

Convertit un élément de texte en caractères majuscules.

 Ce fonctoid requiert un paramètre d'entrée.


Fonctoids mathématiques

Fonctoid | Paramètres
Fonctoid Valeur absolue Valeur absolue Renvoie la valeur absolue d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur finale est toujours positive, quelle que soit la valeur réellement introduite.
Fonctoid Entier Entier Renvoie la partie entière d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid élimine la virgule d'un nombre ainsi que tous les chiffres situés à la droite de celle-ci.
Fonctoid Valeur maximale Valeur maximale Renvoie la valeur maximale d'une séquence de valeurs numériques. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Valeur minimale Valeur minimale Renvoie la valeur minimale d'une séquence de valeurs numériques. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Modulo Modulo Renvoie le reste une fois le nombre divisé par un entier. | Ce fonctoid requiert deux paramètres d'entrée. Il renvoie le reste d'une division entière. Ce fonctoid est utile, par exemple, lors de la détermination de quantités de livraison (calculs de type « charge inférieure à »).
Fonctoid Arrondi Arrondi Arrondit un nombre à un nombre spécifié de décimales ou à un nombre entier si les décimales ne sont pas indiquées. | Ce fonctoid requiert deux paramètres d'entrée. La première entrée liée au fonctoid représente la valeur ; la deuxième entrée liée au fonctoid représente le nombre de décimales auquel vous souhaitez arrondir le nombre. Le fonctoid arrondit les nombres vers le haut ou vers le bas en fonction des règles de calcul standard.
Fonctoid Racine carrée Racine carrée Renvoie la racine carrée d'un nombre. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Addition Addition Calcule la somme d'une série de nombres. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Soustraction Soustraction Soustrait un nombre d'un autre nombre. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Multiplication Multiplication Multiplie un nombre par un autre nombre. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Division Division Divise un nombre par un autre nombre. | Ce fonctoid requiert deux paramètres d'entrée. Vous pouvez utiliser ce fonctoid avec des nombres réels et des entiers.


Fonctoids logiques

Fonctoid | Paramètres
Fonctoid Supérieur à Supérieur à Renvoie la valeur TRUE si le premier paramètre est supérieur au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Supérieur ou égal à Supérieur ou égal à Renvoie la valeur TRUE si le premier paramètre est supérieur ou égal au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Inférieur à Inférieur à Renvoie la valeur TRUE si le premier paramètre est inférieur au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Inférieur ou égal à Inférieur ou égal à Renvoie la valeur TRUE si le premier paramètre est inférieur ou égal au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Égal à Égal à Renvoie la valeur TRUE si le premier paramètre est égal au second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Différent de Différent de Renvoie la valeur TRUE si le premier paramètre est différent du second. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Chaîne logique Chaîne logique Renvoie la valeur TRUE si le paramètre est une valeur de chaîne. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Date logique Date logique Renvoie la valeur TRUE si le paramètre est une valeur de date. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Nombre logique Nombre logique Renvoie la valeur TRUE si le paramètre est une valeur numérique. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid OR logique OR logique Renvoie l'opérateur OR logique des paramètres. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid AND logique AND logique Renvoie l'opérateur AND logique des paramètres. | Ce fonctoid requiert un ou plusieurs paramètres d'entrée.
Fonctoid Existence logique Existence logique Renvoie la valeur TRUE si l'enregistrement ou le champ d'entrée existe dans le document source. | Ce fonctoid ne peut posséder qu'un seul paramètre d'entrée.


Fonctoids Date et Heure

Fonctoid | Paramètres
Fonctoid Ajouter des jours Ajouter des jours Ajoute un nombre spécifié de jours à une date. | Ce fonctoid requiert deux paramètres d'entrée. La première liaison doit posséder une information de date en entrée. La deuxième liaison détermine le nombre de jours à ajouter à la date.
Fonctoid Date Date Renvoie la date en cours. | Ce fonctoid ne demande pas de paramètre en entrée. Le format de sortie est AAAA-MM-JJ.
Fonctoid Heure Heure Renvoie l'heure en cours. | Ce fonctoid ne demande pas de paramètre en entrée. Le format de sortie est HH:MM:SS.
Fonctoid Date et heure Date et heure Renvoie la date et l'heure en cours. | Ce fonctoid ne demande pas de paramètre en entrée. Le format de sortie est AAAA-MM-JJTHH:MM:SS.


Fonctoids de conversion

Fonctoid | Paramètres
Fonctoid ASCII à partir d'un caractère ASCII à partir d'un caractère Renvoie la valeur ASCII d'un caractère donné. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid convertit un code de valeur ASCII sous-jacent. Exemple : A=97
Fonctoid Caractère à partir du code ASCII Caractère à partir du code ASCII Renvoie le caractère d'une valeur ASCII donnée. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid convertit une valeur dans son code de valeur ASCII sous-jacent. Exemple : 98=B
Fonctoid Hexadécimal Hexadécimal Renvoie la valeur hexadécimale d'un nombre décimal donné. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid convertit un nombre décimal en un nombre hexadécimal. Exemple : 10=A
fonctoid octal Octal Renvoie la valeur octale d'un nombre décimal donné. | Ce fonctoid requiert un paramètre d'entrée. Ce fonctoid convertit un nombre décimal en un nombre octal. Exemple : (Octal 0-7), 8=10 et 10=12


Fonctoids scientifiques

Fonctoid | Paramètres
Fonctoid Arc tangente Arc tangente Renvoie l'arc tangente d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur d'entrée doit être exprimée en radians.
Fonctoid Cosinus Cosinus Renvoie le cosinus d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur d'entrée doit être exprimée en radians.
Fonctoid Sinus Sinus Renvoie le sinus d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur d'entrée doit être exprimée en radians.
Fonctoid tangent Tangent Renvoie la tangente d'un nombre. | Ce fonctoid requiert un paramètre d'entrée. La valeur d'entrée doit être exprimée en radians.
Fonctoid Fonction exponentielle naturelle Fonction exponentielle naturelle Renvoie e élevé à une puissance donnée. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Logarithme naturel Logarithme naturel Renvoie le logarithme (base e) d'une valeur. | Ce fonctoid requiert un paramètre d'entrée.
10^X Renvoie 10 élevé à une puissance donnée. | Ce fonctoid requiert un paramètre d'entrée.
Fonctoid Logarithme commun Logarithme commun Renvoie le logarithme (base 10) d'une valeur. | Ce fonctoid requiert un paramètre d'entrée.
X^Y Renvoie une valeur élevée à une puissance donnée. | Ce fonctoid requiert deux paramètres d'entrée.
Fonctoid Logarithme spécifié à partir de la base Logarithme spécifié à partir de la base Renvoie le logarithme (spécifié à partir d'une base) d'une valeur. | Ce fonctoid requiert deux paramètres d'entrée.


Fonctoids cumulés

Fonctoid Paramètres
Fonctoid Somme cumulée Somme cumulée

Totalise toutes les valeurs du champ connecté en effectuant une itération sur son enregistrement parent.

 Ce fonctoid requiert deux paramètres d'entrée. Le deuxième paramètre spécifie le niveau de hiérarchie (du point de vue de la liaison du compilateur) à partir du nœud source. Ce paramètre doit être un nombre entier supérieur à 0 et inférieur au nombre de nœuds calculés depuis le nœud racine.

Remarque

  • Ce fonctoid fournit une compatibilité amont avec Microsoft BizTalk Server 2000, qui n'exigeait qu'un seul paramètre d'entrée.

Pour plus d'informations sur les fonctoids cumulés, et pour voir un exemple, voir Utilisation des fonctoids cumulés.
Fonctoid Moyenne cumulée Moyenne cumulée

Calcule la moyenne de toutes les valeurs du champ connecté en effectuant une itération sur son enregistrement parent.

 Ce fonctoid requiert deux paramètres d'entrée. Le deuxième paramètre spécifie le niveau de hiérarchie (du point de vue de la liaison du compilateur) à partir du nœud source. Ce paramètre doit être un nombre entier supérieur à 0 et inférieur au nombre de nœuds calculés depuis le nœud racine.

Remarque

  • Ce fonctoid fournit une compatibilité amont avec BizTalk Server 2000, qui n'exigeait qu'un seul paramètre d'entrée.

Pour plus d'informations sur les fonctoids cumulés et pour voir un exemple, voir Utilisation des fonctoids cumulés.
Fonctoid Minimum cumulé Minimum cumulé

Renvoie la valeur minimale des entrées réparties sur l'enregistrement parent.

 Ce fonctoid requiert deux paramètres d'entrée. Le deuxième paramètre spécifie le niveau de hiérarchie (du point de vue de la liaison du compilateur) à partir du nœud source. Ce paramètre doit être un nombre entier supérieur à 0 et inférieur au nombre de nœuds calculés depuis le nœud racine.

Remarque

  • Ce fonctoid fournit une compatibilité amont avec BizTalk Server 2000, qui n'exigeait qu'un seul paramètre d'entrée.

Pour plus d'informations sur les fonctoids cumulés et pour voir un exemple, voir Utilisation des fonctoids cumulés.
Fonctoid Maximum cumulé Maximum cumulé

Renvoie la valeur maximale des entrées réparties sur l'enregistrement parent.

 Ce fonctoid requiert deux paramètres d'entrée. Le deuxième paramètre spécifie le niveau de hiérarchie (du point de vue de la liaison du compilateur) à partir du nœud source. Ce paramètre doit être un nombre entier supérieur à 0 et inférieur au nombre de nœuds calculés depuis le nœud racine.

Remarque

  • Ce fonctoid fournit une compatibilité amont avec BizTalk Server 2000, qui n'exigeait qu'un seul paramètre d'entrée.

Pour plus d'informations sur les fonctoids cumulés et pour voir un exemple, voir Utilisation des fonctoids cumulés.
Fonctoid Chaîne cumulée Chaîne cumulée

Renvoie la chaîne concaténée des valeurs de chaîne pour le champ connecté en effectuant une itération sur son enregistrement parent.

 Ce fonctoid requiert deux paramètres d'entrée. Le deuxième paramètre spécifie le niveau de hiérarchie (du point de vue de la liaison du compilateur) à partir du nœud source. Ce paramètre doit être un nombre entier supérieur à 0 et inférieur au nombre de nœuds calculés depuis le nœud racine.

Remarque

  • Ce fonctoid fournit une compatibilité amont avec BizTalk Server 2000, qui n'exigeait qu'un seul paramètre d'entrée.

Pour plus d'informations sur les fonctoids cumulés et pour voir un exemple, voir Utilisation des fonctoids cumulés.


Fonctoids de base de données

Fonctoid | Paramètres
Fonctoid Recherche dans la base de données Recherche dans la base de données Recherche une valeur spécifique dans une base de données, extrait l'enregistrement contenant la valeur, puis stocke ce dernier comme un jeu d'enregistrements Microsoft ActiveX® Data Objects (ADO). | Ce fonctoid doit posséder exactement quatre paramètres d'entrée.
Fonctoid Extracteur de valeur Extracteur de valeur Renvoie une valeur d'une colonne spécifiée dans un jeu d'enregistrements ADO qui a été extrait par le fonctoid Recherche dans la base de données. | Ce fonctoid doit posséder exactement deux paramètres d'entrée.
Fonctoid Retour d'erreur Retour d'erreur Renvoie, le cas échéant, une chaîne d'erreur provenant de ODBC (Open Database Connectivity) lors de l'utilisation du fonctoid Recherche dans la base de données. | Ce fonctoid doit posséder exactement un paramètre d'entrée.


Fonctoids avancés

Fonctoid | Paramètres
Fonctoid Script Script Renvoie Microsoft® Visual Basic® Scripting Edition (VBScript) personnalisé ou Microsoft JScript® personnalisé. | Le nombre de paramètres d'entrée de ce fonctoid est configurable en fonction d'un script personnalisé.
Fonctoid Nombre d'enregistrements Nombre d'enregistrements Renvoie le nombre total des enregistrements trouvés dans l'instance. | Ce fonctoid doit posséder un paramètre d'entrée.
Fonctoid Index Index Renvoie la valeur d'un enregistrement ou d'un champ à l'index spécifié. | Ce fonctoid doit posséder au moins deux paramètres d'entrée. Le nombre maximal de paramètres d'entrée est limité par le nombre de niveaux dans la hiérarchie de spécification.
Fonctoid Itération Itération Renvoie le numéro d'itération (dans une boucle) de l'enregistrement source. | Ce fonctoid doit posséder un paramètre d'entrée.
Fonctoid Mappage de valeurs Mappage de valeurs Renvoie la valeur du second paramètre si la valeur du premier paramètre est TRUE. | Ce fonctoid doit posséder deux paramètres d'entrée.
Fonctoid Mappage de valeurs (mise à plat) Mappage de valeurs (mise à plat) Renvoie la valeur du second paramètre si celle du premier paramètre est TRUE et aplatit la hiérarchie des documents source. | Ce fonctoid doit posséder deux paramètres d'entrée.
Fonctoid Bouclage Bouclage Crée plusieurs enregistrements de sortie en effectuant une itération sur chaque enregistrement d'entrée. | Ce fonctoid doit posséder au moins un paramètre d'entrée. Il n'y a aucune limite maximale quant au nombre de paramètres d'entrée.


Modification des propriétés des fonctoids

  • Pour afficher la boîte de dialogue Propriétés des fonctoids, cliquez avec le bouton droit sur un fonctoid dans la grille de mappage, puis sélectionnez Propriétés.

    -Ou-

    Double-cliquez sur un fonctoid pour afficher ses propriétés.

Remarque

  • L'onglet Général affiche des informations relatives aux paramètres d'entrée. L'onglet Script affiche les informations relatives aux scripts.

Pour plus d'informations sur le mode d'utilisation de cette boîte de dialogue, voir les rubriques suivantes :

  • Paramètres d'entrée

  • Scripts des fonctoids


Paramètres d'entrée

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Propriétés des fonctoids, voir Modification des propriétés des fonctoids.

Il est possible d'ajouter, de supprimer et de déplacer les paramètres d'entrée d'un grand nombre de fonctoids par le biais de l'onglet Général de la boîte de dialogue Propriétés des fonctoids.

Cette section traite des procédures suivantes :

  • Insertion de paramètres d'entrée

  • Suppression de paramètres d'entrée

  • Déplacement de paramètres d'entrée

  • Attribution d'un nouveau nom aux paramètres d'entrée

Remarque

  • Le nombre de paramètres est limité pour certains fonctoids. Les informations relatives au nombre de paramètres autorisés pour un fonctoid figurent dans la boîte de dialogue Propriétés des fonctoids, sous la zone Paramètres d'entrée dans l'onglet Général.


Insertion de paramètres d'entrée

  1. Double-cliquez sur un fonctoid dans la grille de mappage.

    La boîte de dialogue Propriétés des fonctoids s'affiche.

  2. Dans l'onglet Général, cliquez sur le bouton Insérer un nouveau paramètre bouton Insérer un nouveau paramètre , tapez les informations correspondant au nouveau paramètre, puis appuyez sur ENTRÉE.

    Remarques

    • Lorsque le bouton Insérer un nouveau paramètre n'est pas disponible, ceci signifie que le fonctoid n'accepte ou ne nécessite aucun paramètre d'entrée.

    • Les informations sur le nouveau paramètre sont répercutées dans l'onglet Script.
  3. Répétez l'étape 2 pour ajouter des paramètres supplémentaires, si besoin est.

  4. Cliquez sur OK.

Important

  • Si vous sélectionnez l'onglet Script, puis modifiez manuellement un paramètre d'entrée, les paramètres d'entrées supplémentaires ne seront pas répercutés dans l'onglet Script et ne seront pas non plus implémentés au moment de l'exécution.

  • Les guillemets doubles ne sont pas reconnus dans une valeur de constante d'un paramètre d'entrée.

Voir aussi

Suppression de paramètres d'entrée

Déplacement de paramètres d'entrée

Attribution d'un nouveau nom aux paramètres d'entrée

Scripts des fonctoids


Suppression de paramètres d'entrée

  1. Double-cliquez sur un fonctoid dans la grille de mappage.

  2. Dans l'onglet Général, dans la zone Paramètres d'entrée, cliquez sur le paramètre d'entrée que vous souhaitez supprimer.

  3. Cliquez sur le bouton Supprimer le paramètre sélectionné [image] , puis cliquez sur OK.

Voir aussi

Insertion de paramètres d'entrée

Déplacement de paramètres d'entrée

Attribution d'un nouveau nom aux paramètres d'entrée


Déplacement de paramètres d'entrée

  1. Double-cliquez sur un fonctoid dans la grille de mappage.

  2. Dans l'onglet Général, dans la zone Paramètres d'entrée, cliquez sur le paramètre d'entrée que vous souhaitez déplacer.

  3. Cliquez sur le bouton Déplacer le paramètre sélectionné vers le haut [image] pour déplacer le paramètre vers le haut ou sur le bouton Déplacer le paramètre sélectionné vers le bas bouton Déplacer le paramètre sélectionné vers le bas pour le déplacer vers le bas, puis cliquez sur OK.

Voir aussi

Suppression de paramètres d'entrée

Insertion de paramètres d'entrée

Attribution d'un nouveau nom aux paramètres d'entrée


Attribution d'un nouveau nom aux paramètres d'entrée

  1. Double-cliquez sur un fonctoid dans la grille de mappage.

  2. Dans l'onglet Général, dans la zone Paramètres d'entrée, cliquez avec le bouton droit sur le paramètre d'entrée que vous souhaitez renommer, puis cliquez sur Modifier la valeur.

  3. Tapez un nouveau nom de paramètre, puis cliquez sur OK.

Voir aussi

Suppression de paramètres d'entrée

Insertion de paramètres d'entrée

Déplacement de paramètres d'entrée


Scripts des fonctoids

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Propriétés des fonctoids, voir Modification des propriétés des fonctoids.

Vous pouvez afficher ou modifier les scripts par le biais de l'onglet Script de la boîte de dialogue Propriétés des fonctoids.

Remarque

  • Vous pouvez afficher les scripts de tous les fonctoids, mais vous pouvez modifier uniquement le script d'un fonctoid Script.

Voir aussi

Paramètres d'entrée


Gestion de liaisons

Cette section traite des rubriques suivantes :

  • Création de liaisons entre les champs

  • Création de liaisons entre les champs et les fonctoids

  • Création de liaisons entre les enregistrements et les champs

  • Création de liaisons entre les enregistrements et les fonctoids

  • Création de liaisons entre les fonctoids

  • Autoriser les liaisons du contenu des enregistrements

  • Redirection des liaisons

  • Suppression de liaisons


Création de liaisons entre les champs

  • Déplacez un champ de l'arborescence de spécification source vers un champ de l'arborescence de spécification de destination.

Important

  • Le type de données d'un champ dans l'arborescence de spécification source doit correspondre au type de données d'un champ auquel il est lié dans l'arborescence de spécification de destination.

  • Le Mappeur BizTalk vérifie l'existence d'un attribut ou d'un élément pour la liaison directe à partir de la source et de la destination avant de générer XSLT. C'est pourquoi, si le champ source n'apparaît pas dans le document d'instance (facultatif), un champ de destination vierge est créé. Ce comportement est inacceptable car le champ de destination doit être créé uniquement lorsque le champ source existe. Pour résoudre ce problème, vérifiez si le champ lié est facultatif dans le schéma source. Si c'est le cas, BizTalk Server génère une clause <xsl:if> pour vérifier l'existence du champ source avant de créer le champ de destination. Ceci permet de s'assurer que le champ de destination n'est pas créé lorsque le champ source ne figure pas dans l'instance source. Si l'instance source contient le champ, le champ de destination est créé comme prévu.

Remarques

  • Vous ne pouvez pas établir une liaison vers un nœud dans une spécification de destination qui possède une valeur de constante de destination associée.

  • Vous ne pouvez pas établir une liaison vers un champ requis d'une spécification de destination qui possède une valeur par défaut associée. Pour plus d'informations sur l'établissement d'un champ requis, voir Définition des propriétés de référence. Pour plus d'informations sur l'établissement de la valeur par défaut d'un champ, voir Définition des propriétés de déclaration.

  • Il est possible que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Ajout de valeurs de constantes

Gestion de vues

Définition des propriétés de déclaration

Définition des propriétés de référence

Résumé des types de données et des valeurs de types de données


Création de liaisons entre les champs et les fonctoids

  • Déplacez un champ de l'arborescence de spécification source ou de spécification de destination vers un fonctoid dans la grille de mappage.

    -Ou-

    Déplacez le fonctoid de la grille de mappage vers un champ de l'arborescence de spécification source ou de spécification de destination.

Important

  • Un champ doté d'une propriété d'un type de données particulier dans l'arborescence de spécification de destination d'un mappage ne doit pas être relié à un fonctoid qui génère une sortie d'un autre type de données.

Remarques

  • Pour être en mesure d'ajouter une liaison d'un champ vers un fonctoid, vous devez au préalable ajouter un fonctoid à la grille de mappage. Pour plus d'informations sur l'ajout d'un fonctoid à la grille de mappage, voir Utilisation des fonctoids.

  • Vous ne pouvez pas établir une liaison vers un nœud (d'une spécification de destination) qui possède une valeur de constante de destination associée.

  • Vous ne pouvez pas établir une liaison vers un champ requis (d'une spécification de destination) qui possède une valeur par défaut associée. Pour plus d'informations sur l'établissement d'un champ requis, voir Définition des propriétés de référence. Pour plus d'informations sur l'établissement de la valeur par défaut d'un champ, voir Définition des propriétés de déclaration.

Voir aussi

Ajout de valeurs de constantes

Gestion de vues

Définition des propriétés de déclaration

Définition des propriétés de référence

Utilisation des fonctoids


Création de liaisons entre les enregistrements et les champs

  1. Dans le menu Outils, cliquez sur Options.

  2. Dans la boîte de dialogue Options du Mappeur BizTalk, activez la case à cocher Autoriser les liaisons du contenu des enregistrements, puis cliquez sur OK.

  3. Déplacez un enregistrement de l'arborescence de spécification source vers un champ de l'arborescence de spécification de destination.

    -Ou-

    Déplacez un enregistrement de l'arborescence de spécification de destination vers un champ de l'arborescence de spécification source.

Remarques

  • Vous ne pouvez pas établir une liaison vers un nœud dans une spécification de destination qui possède une valeur de constante de destination associée.

  • Vous ne pouvez pas établir une liaison vers un champ requis d'une spécification de destination qui possède une valeur par défaut associée. Pour plus d'informations sur l'établissement d'un champ requis, voir Définition des propriétés de référence. Pour plus d'informations sur l'établissement de la valeur par défaut d'un champ, voir Définition des propriétés de déclaration.

  • Il se peut que vous deviez développer les arborescences de spécifications pour afficher les enregistrements ou les champs que vous souhaitez mapper. Pour plus d'informations, voir Développement des éléments de l'arborescence.

Voir aussi

Ajout de valeurs de constantes

Gestion de vues

Définition des propriétés de déclaration

Définition des propriétés de référence


Création de liaisons entre les enregistrements et les fonctoids

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Activez la case à cocher Autoriser les liaisons du contenu des enregistrements, puis cliquez sur OK.

  3. Déplacez un enregistrement de l'arborescence de spécification source ou de spécification de destination vers un fonctoid dans la grille de mappage.

    -Ou-

    Déplacez le fonctoid de la grille de mappage vers un enregistrement dans l'arborescence de spécification source ou de spécification de destination.

Remarques

  • Pour être en mesure d'ajouter une liaison d'un enregistrement vers un fonctoid, vous devez au préalable ajouter un fonctoid à la grille de mappage.

  • Vous ne pouvez pas établir une liaison vers un nœud dans une spécification de destination qui possède une valeur de constante de destination associée. Pour plus d'informations sur les valeurs de constantes de destination, voir Interface utilisateur du Mappeur BizTalk.

Voir aussi

Ajout de valeurs de constantes

Gestion de vues


Création de liaisons entre les fonctoids

  • Déplacez un fonctoid vers un autre fonctoid dans la grille de mappage.

Remarque

  • Les liaisons sont traitées de gauche à droite dans la grille de mappage. Vous ne pouvez pas créer une liaison entre un fonctoid et un autre fonctoid situé directement au-dessus ou au dessous.

Voir aussi

Création de liaisons entre les champs et les fonctoids

Création de liaisons entre les enregistrements et les fonctoids


Autoriser les liaisons du contenu des enregistrements

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Activez la case à cocher Autoriser les liaisons du contenu des enregistrements, puis cliquez sur OK.

  3. Déplacez un enregistrement de l'arborescence de spécification source vers un enregistrement de l'arborescence de spécification de destination.


Redirection des liaisons

  1. Dans la grille de mappage, cliquez sur une liaison pour la mettre en surbrillance.

    Les points de terminaison des liaisons sont mis en évidence par des petites cases bleues.

  2. Déplacez l'un des points de terminaison vers le fonctoid ou le nœud auquel vous souhaitez vous connecter.

    Lorsque vous faites glisser le point de terminaison, le pointeur se transforme en réticule. Si vous pointez sur un objet vers lequel il n'est pas possible d'établir une liaison, le pointeur se transforme en cercle barré.

Important

  • Si au moins deux liaisons source sont connectées à un fonctoid et que vous redirigez une ou plusieurs liaisons source vers différents nœuds de la spécification source, il est possible que l'ordre des paramètres d'entrée du fonctoid soit modifié. Double-cliquez sur le fonctoid pour afficher ses paramètres d'entrée et assurez-vous que l'ordre des paramètres est correct.


Suppression de liaisons

  1. Cliquez avec le bouton droit sur la liaison que vous souhaitez supprimer, puis cliquez sur Supprimer.

  2. Dans la boîte de dialogue de confirmation, cliquez sur Oui.


Affichage des liaisons et des fonctoids dans la grille

Cette section traite des rubriques suivantes :

  • Affichage des liaisons et des fonctoids dans la grille de mappage

  • Affichage des liaisons et des fonctoids dans l'aperçu de la grille


Affichage des liaisons et des fonctoids dans l'aperçu de la grille

BizTalk Server 2002 ~ Mappage de données

Affichage des liaisons et des fonctoids dans la grille de mappage

  1. Placez le curseur dans la grille de mappage, près de la bordure, et orientez-le dans la direction vers laquelle vous souhaitez vous déplacer.

    Le curseur en forme de pointeur ou de barre verticale (|) est remplacé par une flèche large.

  2. Cliquez sur le bouton gauche de la souris et maintenez-le enfoncé pour vous déplacer dans la direction indiquée par la pointe de la flèche.

Remarque

  • Pour vous déplacer, vous pouvez également cliquer dans l'arrière-plan de la grille de mappage et utiliser les touches de direction pour vous déplacer dans toutes les directions.

Voir aussi

Interface utilisateur du Mappeur BizTalk

Affichage des liaisons et des fonctoids dans l'aperçu de la grille


Affichage des liaisons et des fonctoids dans l'aperçu de la grille

  1. Dans le menu Affichage, cliquez sur Aperçu de la grille.

    La fenêtre Aperçu de la grille s'ouvre et affiche une représentation de l'emplacement des fonctoids sur la grille de mappage.

  2. Faites glisser la barre d'emplacement verte vers un nouvel emplacement dans la boîte de dialogue Aperçu de la grille.

    Lorsque vous déplacez la barre d'emplacement verte, les liaisons et les fonctoids dans la grille de mappage se déplacent également.

Remarque

  • L'aperçu de la grille est utile pour le déplacement dans la grille de mappage lorsque celle-ci comporte de nombreux fonctoids.

Voir aussi

Interface utilisateur du Mappeur BizTalk

Affichage des liaisons et des fonctoids dans la grille de mappage


Modification des propriétés des liaisons

  • Pour afficher la boîte de dialogue Propriétés des liaisons, cliquez avec le bouton droit sur une liaison dans la grille de mappage, puis sélectionnez Propriétés.

    L'onglet Général apparaît par défaut.

Pour plus d'informations sur le mode d'utilisation de cette boîte de dialogue, voir les rubriques suivantes :

  • Affichage des propriétés des liaisons : Onglet Général

  • Affichage des propriétés des liaisons : Onglet Compilateur

Remarque

  • Vous pouvez également double-cliquer sur une liaison pour afficher ses propriétés.

Voir aussi

Compilation de mappages

Gestion de liaisons


Affichage des propriétés des liaisons : Onglet Général

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Propriétés des liaisons, voir Modification des propriétés des liaisons.

L'onglet Général affiche des informations sur la source et la destination d'une liaison. La zone Source indique le chemin de l'enregistrement, le chemin du champ ou le nom du fonctoid correspondant à liaison source, selon que la source de la liaison est un enregistrement, un champ ou un fonctoid. La zone Destination indique le chemin de l'enregistrement, le chemin du champ ou le nom du fonctoid correspondant à la liaison de destination, selon que la destination de la liaison est un enregistrement, un champ ou un fonctoid.

Voir aussi

Affichage des propriétés des liaisons : onglet Compilateur


Affichage des propriétés des liaisons : onglet Compilateur

Pour plus d'informations sur le mode d'accès à la boîte de dialogue Propriétés des liaisons, voir Modification des propriétés des liaisons.

L'onglet Compilateur comporte une zone réservée à la définition des propriétés du compilateur pour les liaisons des spécifications source, ainsi qu'une zone réservée à la définition des propriétés du compilateur pour les liaisons des spécifications de destination. Pour plus d'informations, consultez les rubriques suivantes :

  • Sélection des propriétés du compilateur pour les liaisons des spécifications source

  • Sélection des propriétés du compilateur pour les liaisons des spécifications de destination

Voir aussi

Affichage des propriétés des liaisons : Onglet Général


Sélection des propriétés du compilateur pour les liaisons des spécifications source

  1. Cliquez avec le bouton droit sur une liaison dans la grille de mappage qui est connectée à un nœud de l'arborescence de spécification source, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés des liaisons s'affiche.

  2. Cliquez sur l'onglet Compilateur, puis sélectionnez l'une des options suivantes dans la zone Liaisons des spécifications source :
    • Copier la valeur texte (valeur par défaut). Copie la valeur du nœud dans l'instance de document entrante. Par exemple, <Node>Bonjour<Name>François</Name>Rhein</Node> devient « Bonjour ».

    • Copier le texte et la valeur du sous-contenu. Copie la valeur concaténée du nœud et toutes les valeurs de ses descendants dans l'instance de document entrante. Par exemple, <Node>Bonjour<Name>François</Name>Rhein</Node> devient « Bonjour François Rhein ».

    • Copier le nom : copie le nom du nœud dans l'instance du document entrant.
  3. Cliquez sur OK.

Important

  • Lorsqu'un élément contient un contenu mixte, par exemple des données contenant des éléments enfants, et que vous avez sélectionné Copier la valeur texte (valeur par défaut), seul le contenu figurant jusqu'au premier élément enfant est copié. Exemple :
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Résultat de la copie de Item.

  • Lorsqu'un élément contient un contenu mixte, par exemple des données contenant des éléments enfants, et que vous avez sélectionné Copier le texte et la valeur du sous-contenu, tout le contenu est copié, éléments enfants compris. Exemple :
    <A>Item<B>1</B><B>12</B><B>13</B><B>14</B>Number</A>

    Résultat de la copie de Item1121314Number.

Voir aussi

Sélection des propriétés du compilateur pour les liaisons des spécifications de destination


Sélection des propriétés du compilateur pour les liaisons des spécifications de destination

  1. Cliquez avec le bouton droit sur une liaison dans la grille de mappage qui est connectée à un nœud dans la spécification de destination, puis cliquez sur Propriétés.

  2. Cliquez sur l'onglet Compilateur et sélectionnez l'une des options suivantes dans la zone Liaisons des spécifications de destination :
    • Aplatir les liaisons (valeur par défaut) : ce mode signifie que toutes les hiérarchies source sont aplaties en direction du parent du nœud de destination.

    • Faire correspondre les liaisons du haut vers le bas : ce mode fait correspondre les différents niveaux du haut vers le bas.

    • Faire correspondre les liaisons du bas vers le haut : ce mode fait correspondre les différents niveaux du bas vers le haut.
  3. Cliquez sur OK.

Remarques

  • Si vous utilisez une directive de compilation aplatie, une directive de compilation de haut en bas et une autre de bas en haut pour les liaisons entre les champs de l'arborescence de spécification source et ceux de l'arborescence de spécification de destination partageant le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles avaient pour valeur la directive de compilation aplatie.

  • Si vous utilisez une ou plusieurs directives de compilation aplaties et une directive de compilation de haut en bas pour les liaisons entre les champs de l'arborescence de spécification source et ceux de l'arborescence de spécification de destination partageant le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles avaient pour valeur la directive de compilation de haut en bas.

  • Si vous utilisez une ou plusieurs directives de compilation aplaties et une directive de compilation de bas en haut pour les liaisons entre les champs de l'arborescence de spécification source et ceux de l'arborescence de spécification de destination partageant le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles avaient pour valeur la directive de compilation de bas en haut.

  • Si vous utilisez une ou plusieurs directives de compilation de haut en bas et une ou plusieurs directives de compilation de bas en haut pour les liaisons entre les champs de l'arborescence de spécification source et ceux de l'arborescence de spécification de destination partageant le même enregistrement parent, le Mappeur BizTalk traite toutes les liaisons comme si elles avaient pour valeur la directive de compilation aplatie.

Voir aussi

Correspondance des niveaux de hiérarchie des nœuds

Sélection des propriétés du compilateur pour les liaisons des spécifications source


Création et gestion des mappages compilés

Cette section traite des procédures suivantes :

  • Compilation de mappages

  • Résolution des messages d'avertissement et d'erreur après la compilation d'un mappage

  • Ajout de valeurs de constantes


Compilation de mappages

  • Dans le menu Outils, cliquez sur Compiler le fichier de mappage.

Attention

  • Le Mappeur BizTalk génère un message d'avertissement dans l'onglet Avertissements lorsque le compilateur est confronté à une situation qui provoque des résultats incorrects. Un mappage est prêt pour un environnement de production uniquement lorsqu'il ne génère plus aucun message d'avertissement.

Remarque

  • Si un message d'avertissement s'affiche, il est possible que le problème soit présent sur plusieurs grilles. Par exemple, si la grille 1 comporte un enregistrement (nommé Élément) dans l'arborescence de spécification source qui est lié à un enregistrement (nommé Numéro) dans l'arborescence de spécification de destination, et si la grille 2 contient un enregistrement (nommé Produit) dans l'arborescence de spécification source qui est lié au même enregistrement Numéro dans l'arborescence de spécification de destination, un message d'avertissement indiquant qu'il existe plusieurs entrées pour le même enregistrement s'affiche. Mais, si vous affichez la grille 1, vous ne verrez qu'une seule entrée dans l'enregistrement Numéro.

Voir aussi

Résolution des messages d'avertissement et d'erreur après la compilation d'un mappage


Résolution des messages d'avertissement et d'erreur après la compilation d'un mappage

Si un message d'avertissement s'affiche, il est possible que le problème soit présent sur plusieurs grilles. Par exemple, si la grille 1 comporte un enregistrement (nommé Élément) dans l'arborescence de spécification source qui est lié à un enregistrement (nommé Numéro) dans l'arborescence de spécification de destination, et si la grille 2 contient un enregistrement (nommé Produit) dans l'arborescence de spécification source qui est lié au même enregistrement Numéro dans l'arborescence de spécification de destination, un message d'avertissement indiquant qu'il existe plusieurs entrées pour le même enregistrement s'affiche. Mais, si vous affichez la grille 1, vous ne verrez qu'une seule entrée dans l'enregistrement Numéro.

  1. Double-cliquez sur un message d'avertissement dans l'onglet Avertissements.

    La liaison, le fonctoid ou le nœud à l'origine du message d'avertissement ou d'erreur est mis en surbrillance dans la grille de mappage.

  2. Modifiez la liaison, le fonctoid ou le nœud.

  3. Répétez les étapes 1 et 2 pour tous les messages d'avertissement.

  4. Dans le menu Outils, cliquez sur Compiler le fichier de mappage.

Voir aussi

Compilation de mappages


Ajout de valeurs de constantes

  1. Sélectionnez un enregistrement ou un champ dans l'arborescence de spécification de destination, puis cliquez sur l'onglet Valeurs.

  2. Dans la zone Valeur de la constante de destination, tapez une valeur que vous voulez associer à l'enregistrement ou au champ.

Remarques

  • Vous ne pouvez pas établir une liaison vers un enregistrement ou un champ auquel est associée une valeur de constante.

  • Vous pouvez associer une valeur de constante uniquement à un enregistrement dont la propriété Contenu a pour valeur Texte seul ou Mixte. Pour plus d'informations sur la propriété Contenu, voir Définition des propriétés de déclaration.

Voir aussi

Définition des propriétés de déclaration


Test de mappages

Cette section traite des procédures suivantes :

  • Test des propriétés des enregistrements et des champs possédant des liaisons

  • Tests de mappages


Test des propriétés des enregistrements et des champs possédant des liaisons

Important

  • Compilez toujours un mappage avant de le tester, afin de pouvoir résoudre les éventuels messages d'avertissement et d'erreur. Pour plus d'informations, voir Compilation de mappages.
  1. Cliquez sur un champ dans l'arborescence de spécification source qui est connectée à une liaison.

  2. Cliquez sur l'onglet Valeurs.

  3. Tapez une valeur dans la zone Valeur du test source.

  4. Dans le menu Outils, pointez sur Tester le mappage, puis cliquez sur l'option de votre choix.

    Important

    • Avant le début du test, vous êtes invité à enregistrer le fichier. Par mesure de précaution, enregistrez-le avant le test, afin de préserver vos données an cas d'introduction accidentelle d'un problème dans le mappage.
  5. Cliquez sur Oui pour enregistrer le mappage.

  6. Vérifiez les résultats dans l'onglet Sortie.

Remarque

  • Si la propriété Occurrences maximales d'un enregistrement est un astérisque (*), l'enregistrement est un enregistrement en boucle. L'instance de document entrant que le Mappeur BizTalk génère pour tester le mappage contient deux occurrences de l'enregistrement.

Voir aussi

Compilation de mappages

Tests de mappages


Tests de mappages

Important

  • Compilez toujours un mappage avant de le tester, afin de pouvoir résoudre les éventuels messages d'avertissement et d'erreur. Pour plus d'informations, voir Compilation de mappages.

  • Si vous voulez valider le contenu avant de tester un mappage :
    1. Dans le menu Outils, cliquez sur Options.

      La boîte de dialogue Options du Mappeur BizTalk apparaît.

    2. Dans l'onglet Général, activez la case à cocher Valider le contenu avant le test de mappage et cliquez sur OK.

    Remarque

    • Si une des spécifications que vous utilisez dans le mappage est une spécification non BizTalk Server, telle qu'un fichier XDR (XML-Data Reduced), et si vous utilisez la fonction de validation du contenu, il se peut que la validation échoue. Si des messages d'avertissement, en particulier concernant les espaces de noms ou les groupes d'éléments, se sont affichés lors de l'ouverture du fichier XDR, n'utilisez pas la fonction de validation de contenu.
  • Si vous voulez valider le contenu après le test d'un mappage :
    1. Dans le menu Outils, cliquez sur Options.

      La boîte de dialogue Options du Mappeur BizTalk apparaît.

    2. Dans l'onglet Général, activez la case à cocher Valider le contenu après le test de mappage et cliquez sur OK.

    Remarque

    • Si une des spécifications que vous utilisez dans le mappage est une spécification non BizTalk Server, telle qu'un fichier XDR (XML-Data Reduced), et si vous utilisez la fonction de validation du contenu, il se peut que la validation échoue. Si des messages d'avertissement, en particulier concernant les espaces de noms ou les groupes d'éléments, se sont affichés lors de l'ouverture du fichier XDR, n'utilisez pas la fonction de validation de contenu.
  1. Dans le menu Outils, pointez sur Tester le mappage, puis cliquez sur l'option de votre choix.

    Important

    • Avant le début du test, vous êtes invité à enregistrer le fichier. Par mesure de précaution, enregistrez-le avant le test, afin de préserver vos données an cas d'introduction accidentelle d'un problème dans le mappage.
  2. Cliquez sur Oui pour enregistrer le mappage.

  3. Si des avertissements sont générés au cours du processus de compilation, un message s'affiche. Cliquez sur Oui pour continuer.

  4. Si vous avez sélectionné XML généré vers natif et que le schéma de sortie est une structure EDI, vous devez spécifier des délimiteurs dans la boîte de dialogue Délimiteurs de document. Pour plus d'informations sur la spécification des délimiteurs, voir Options du Mappeur BizTalk : onglet Délimiteurs de document.

    -Ou-

    Si vous avez sélectionné Instance XML vers XML ou Instance XML vers native, la boîte de dialogue Charger le fichier d'instance XML s'affiche. Recherchez un fichier d'instance et cliquez sur Ouvrir.

    -Ou-

    Si vous avez sélectionné Instance native vers XML ou Instance native vers native, la boîte de dialogue Charger le fichier d'instance native s'affiche. Recherchez un fichier d'instance et cliquez sur Ouvrir.

    Remarques

    • Les options XML généré vers natif et Instance XML vers native ne sont pas disponibles pour les schémas de sortie XML.

    • L'option Instance native vers native n'est pas disponible pour les schémas de sortie XML.

    • Si un échange au format EDI comporte plusieurs documents, seule la première instance de document est utilisée dans le test du mappage.

    • Si la case d'option Demander les délimiteurs au cours du test d'instance est activée, et si l'instance que vous testez est un fichier EDI contenant des informations d'enveloppe, la boîte de dialogue Délimiteurs de document ne s'affiche pas car le Mappeur BizTalk détecte automatiquement le délimiteur requis. En revanche, le Mappeur BizTalk affiche l'option Demander les délimiteurs au cours du test d'instance, même si vous avez demandé l'affichage, seulement s'il ne parvient pas à déterminer les délimiteurs à utiliser.
  5. Vérifiez les résultats dans l'onglet Sortie.

Important

  • Il arrive rarement que le Mappeur BizTalk ne parvienne pas à mapper les données dans une seule transformation. BizTalk Server offre toutefois la possibilité de mapper un document à deux reprises, de manière synchrone, grâce à deux itérations utilisant SubmitSync et LoopBack en tant que transports principaux dans la configuration du port. Vous pouvez alors fractionner votre mappage en plusieurs étapes en réutilisant et combinant différents canaux. Pour plus d'informations, consultez le dossier d'exemples Mapping Twice, situé dans le répertoire \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples.

  • Les plages de caractères ne sont pas prises en compte. De fait, si des restrictions de caractères s'appliquant à votre mappage ne sont pas respectées, le système indiquera malgré tout que le test du mappage est satisfaisant. En revanche, lorsque BizTalk Server tentera d'analyser la transaction, il échouera.

  • Vous pouvez créer une instance native si, ultérieurement, vous effectuez une validation de l'instance, mais celle-ci échouera si les règles syntaxiques ne sont pas appliquées.

Voir aussi

Compilation de mappages

Test de mappages


Gestion de vues

Cette section traite des procédures suivantes :

  • Développement des éléments de l'arborescence

  • Réduction des éléments de l'arborescence

  • Affichage des propriétés des enregistrements et des champs

  • Modification de la taille du volet de l'arborescence de spécification source

  • Modification de la taille du volet de l'arborescence de spécification de destination

  • Modification de la taille du volet inférieur


Développement des éléments de l'arborescence

  • Cliquez sur le nœud racine ou sur un enregistrement dans l'arborescence des spécifications que vous voulez développer, puis cliquez sur Développer les éléments de l'arborescence dans le menu Affichage.

    -Ou-

    Cliquez avec le bouton droit sur le nœud racine ou sur un enregistrement dans une arborescence, puis cliquez sur Développer les éléments de l'arborescence.

Voir aussi

Réduction des éléments de l'arborescence


Réduction des éléments de l'arborescence

  • Cliquez sur le nœud racine ou sur un enregistrement dans l'arborescence de spécification que vous voulez réduire, puis cliquez sur Réduire les éléments de l'arborescence dans le menu Affichage.

Remarque

  • Vous pouvez également cliquer avec le bouton droit sur le nœud racine ou sur un enregistrement dans une arborescence, puis cliquer sur Réduire les éléments de l'arborescence.

Voir aussi

Développement des éléments de l'arborescence


Affichage des propriétés des enregistrements et des champs

  • Cliquez sur un enregistrement ou sur un champ dans l'arborescence de spécification source ou de spécification de destination, puis cliquez sur Propriétés dans le menu Affichage.

    -Ou-

    Cliquez sur un enregistrement ou sur un champ dans l'une des arborescences, puis cliquez sur l'onglet Propriétés.

Remarque

  • Il se peut que vous deviez déplacer la barre de défilement sur l'onglet Propriétés pour afficher une propriété et la valeur qui lui est associée.


Modification de la taille du volet de l'arborescence de spécification source

  1. Positionnez le curseur sur la bordure droite du volet de l'arborescence de spécification source et déplacez-le légèrement jusqu'à ce qu'il prenne la forme d'une double flèche.

  2. Faite glisser la bordure du volet vers la droite pour augmenter la taille du volet, ou vers la gauche pour la réduire.

Remarque

  • Double-cliquez sur la bordure afin de rétablir sa position initiale.

Voir aussi

Modification de la taille du volet de l'arborescence de spécification de destination

Modification de la taille du volet inférieur


Modification de la taille du volet de l'arborescence de spécification de destination

  1. Positionnez le curseur sur la bordure gauche du volet de l'arborescence de spécification de destination et déplacez-le légèrement jusqu'à ce qu'il prenne la forme d'une double flèche.

  2. Faites glisser la bordure vers la gauche pour augmenter la taille du volet ou vers la droite pour la diminuer.

Remarque

  • Double-cliquez sur la bordure pour rétablir sa position initiale.

Voir aussi

Modification de la taille du volet de l'arborescence de spécification source

Modification de la taille du volet inférieur


Modification de la taille du volet inférieur

  1. Positionnez le curseur sur la bordure supérieure du volet inférieur et déplacez-le légèrement jusqu'à ce qu'il prenne la forme d'une double flèche.

  2. Déplacez la bordure vers le haut pour augmenter la taille du volet ou vers le bas pour la diminuer.

Remarque

  • Double-cliquez sur la bordure afin de rétablir sa position initiale.

Voir aussi

Modification de la taille du volet de l'arborescence de spécification de destination

Modification de la taille du volet de l'arborescence de spécification source


Personnalisation de l'interface utilisateur

Cette section traite des procédures suivantes :

  • Modification des couleurs de la grille de mappage

  • Modification de la couleur des liaisons

  • Modification de la couleur des objets sélectionnés

  • Modification de la couleur des avertissements du compilateur

  • Restauration des couleurs par défaut

  • Modification de la taille du texte


Modification des couleurs de la grille de mappage

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Couleurs.

  3. Activez la case à cocher Premier plan de la grille, qui correspond aux lignes discontinues dans la grille de mappage, puis sélectionnez une nouvelle couleur dans la grille de mappage.

    –Ou–

    Activez la case à cocher Arrière-plan de la grille, qui correspond à la couleur d'arrière-plan de la grille de mappage, puis sélectionnez une nouvelle couleur dans la palette de couleurs.

  4. Cliquez sur OK.

Voir aussi

Modification de la couleur des avertissements du compilateur

Modification de la couleur des liaisons

Modification de la couleur des objets sélectionnés

Restauration des couleurs par défaut


Modification de la couleur des liaisons

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Couleurs.

  3. Activez les cases à cocher correspondant aux éléments suivants :
    • Liaisons fixes : il s'agit de simples liaisons qui effectuent une copie des valeurs dans la grille de mappage.

    • Liaisons souples : les liaisons souples sont des liaisons simples effectuant une copie des valeurs, qui sont déplacées de l'arborescence de spécification source vers l'arborescence de spécification de destination. Une fois la liaison établie, elle change de couleur pour prendre celle des liaisons fixes prédéfinies.

    • Liaisons partielles : il s'agit des liaisons qui existent pour un champ ou pour un enregistrement dont l'enregistrement parent est réduit.

    • Liaisons du compilateur : les liaisons du compilateur sont les liaisons directives du compilateur. Ce sont des liaisons qui sont automatiquement créées lorsqu'une liaison est établie à partir d'un champ de l'arborescence de spécification source vers un champ de l'arborescence de spécification de destination.
  4. Sélectionnez une nouvelle couleur dans la palette de couleurs.

  5. Répétez l'étape 3 pour modifier d'autres couleurs, le cas échéant.

  6. Cliquez sur OK.

Voir aussi

Modification des couleurs de la grille de mappage

Modification de la couleur des avertissements du compilateur

Modification de la couleur des objets sélectionnés

Restauration des couleurs par défaut


Modification de la couleur des objets sélectionnés

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Couleurs.

  3. Activez la case à cocher Objets sélectionnés, puis sélectionnez une nouvelle couleur dans la palette de couleurs.

  4. Cliquez sur OK.

Voir aussi

Modification des couleurs de la grille de mappage

Modification de la couleur des avertissements du compilateur

Modification de la couleur des liaisons

Restauration des couleurs par défaut


Modification de la couleur des avertissements du compilateur

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Couleurs.

  3. Activez la case à cocher Avertissements du compilateur, puis sélectionnez une nouvelle couleur dans la palette de couleurs.

  4. Cliquez sur OK.

Voir aussi

Modification des couleurs de la grille de mappage

Modification de la couleur des liaisons

Modification de la couleur des objets sélectionnés

Restauration des couleurs par défaut


Restauration des couleurs par défaut

  1. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options du Mappeur BizTalk apparaît.

  2. Cliquez sur l'onglet Couleurs.

  3. Cliquez sur Restaurer les couleurs par défaut, puis cliquez sur OK.

Voir aussi

Modification des couleurs de la grille de mappage

Modification de la couleur des avertissements du compilateur

Modification de la couleur des liaisons

Modification de la couleur des objets sélectionnés


Modification de la taille du texte

  • Dans le menu Affichage, pointez sur Taille du texte, puis cliquez sur la taille de votre choix.


Touches de raccourci du Mappeur BizTalk

Vous pouvez utiliser les touches de raccourci pour effectuer des tâches dans le Mappeur BizTalk. Le tableau suivant présente ces touches de raccourci.

Remarque

  • Le clavier numérique permet d'obtenir la fonctionnalité non incluse dans la liste pour déplacer le pointeur de la souris à l'aide des Touches souris. Pour plus d'informations sur les touches souris dans l'aide de Windows 2000 Server et Advanced Server, reportez-vous à « Utiliser le clavier pour déplacer le pointeur de la souris ». Pour plus d'informations sur les touches souris dans l'aide de Windows 2000 Professionnel, reportez-vous à « Déplacer le pointeur de la souris en utilisant les touches souris ».
Appuyez sur | Pour
CTRL+N | Ouvrir une nouvelle spécification.
CTRL+O | Ouvrir un mappage existant.
CTRL+S | Enregistrer un mappage.
CTRL+F5 | Tester un mappage.
F4 | Mettre en surbrillance l'avertissement suivant.
F5 | Compiler un mappage
CTRL+A | Ajouter une page de grille.
Sur un nom de page de grille, F2 | Attribuer un nouveau nom à une page de grille.
CTRL+D | Supprimer une page de grille.
SUPPR | Supprimer un objet dans la grille de mappage.
F6 | Déplacer le focus d'un volet à l'autre dans le sens des aiguilles d'une montre.
MAJ+F6 | Déplacer le focus d'un volet à l'autre dans le sens inverse des aiguilles d'une montre. Lorsque vous appuyez sur les touches MAJ+F6 après avoir ouvert la palette de fonctoids, le focus se déplace sur l'onglet Chaîne, ce qui vous permet d'utiliser les touches de direction GAUCHE et DROITE pour visualiser les autres onglets.
MAJ+F10 | Ouvrir le menu contextuel des éléments mis en surbrillance.
TAB | Déplacer le focus dans le sens des aiguilles d'une montre dans le volet inférieur, en partant de l'onglet vers les volets ou les champs situés en dessous. La touche TABULATION permet de déplacer le focus d'un bouton ou d'un champ à l'autre dans la boîte de dialogue. En outre, elle vous permet d'accéder aux boutons situés en haut à droite de la boîte de dialogue Sélection du type de spécification source.
MAJ+TAB | Déplacer le focus dans le sens inverse des aiguilles d'une montre dans le volet inférieur, en partant de l'onglet vers les volets ou les champs situés en dessous.
BARRE ESPACE | Activer ou désactiver une case à cocher. L'utilisation de la barre d'espace entraîne le même résultat qu'un clic de souris lorsqu'un bouton est activé.
F1 | Afficher l'aide en ligne.
ALT+F4 | Quitter le programme.
Touches fléchées | Déplacer le focus dans la fenêtre Aperçu de la grille.
FLÈCHE GAUCHE | Activer l'onglet vers la gauche.
FLÈCHE DROITE | Activer l'onglet situé à droite.
N'importe quelle touche de direction | Mettre en surbrillance un dossier ou un fichier du volet principal d'une boîte de dialogue, tandis que le focus est sur ce volet. Cette fonctionnalité intervient dans les boîtes de dialogue Stocker dans WebDAV et Extraire à partir de WebDAV. Pour plus d'informations, voir Extraction de mappages à partir de WebDAV.

Utilisation des Touches souris dans le Mappeur BizTalk

Dans le Mappeur BizTalk, certaines opérations n'ont pas de raccourcis clavier. Pour effectuer les opérations suivantes, vous devez utiliser les Touches souris :

  • Déplacement

  • Sélection de fonctoids

  • Déplacement de fonctoids

  • Établissement de liaisons


Dépannage de l'Éditeur BizTalk et du Mappeur BizTalk

Cette section regroupe toutes les informations relatives au dépannage de l'Éditeur BizTalk™ et du Mappeur BizTalk de Microsoft®. Lorsque vous êtes confronté à un problème dans l'Éditeur BizTalk ou le Mappeur BizTalk, vous pouvez consulter cette section pour y rechercher une solution.

Cette section traite des rubriques suivantes :

  • Mot de passe requis lors de la tentative de connexion à un serveur WebDAV distant

  • Échec de la connexion au référentiel WebDAV ou du stockage de fichiers sur le référentiel WebDAV

  • ???.xml apparaît dans la boîte de dialogue WebDAV

  • Le dossier BizTalkServerRepositoryMaps apparaît dans la boîte de dialogue Extraire à partir de WebDAV

  • La boîte de dialogue Extraire à partir de WebDAV ou Stocker dans WebDAV est vide

  • Échec de connexion à http://hôtelocal

  • Analyse incomplète du fichier plat soumis à BizTalk Server

  • Espace non conservé dans le fichier plat soumis à BizTalk Server

  • Échec du test du mappage

  • Échec de l'importation DTD

  • Échec de validation d'instance lors de l'utilisation du champ Date ou Heure

  • Ré-enregistrement de msdaipp.dll pour extraire ou enregistrer des fichiers dans WebDAV

  • Le parseur ne parvient pas à trouver le délimiteur de début requis

  • Échec du stockage d'un fichier dans le référentiel WebDAV

  • Échec de l'importation d'un fichier XDR

  • La validation d'instance échoue lorsque la virgule est utilisée dans les nombres décimaux

  • Les segments de données volumineux d'un document IDOC ne sont pas publiés sur un système SAP

  • Limitations Unicode du référentiel WebDAV

  • Les modèles X12 contiennent une décimale implicite

  • L'utilisation du clavier pour convertir les caractères coréens en caractères chinois provoque une panne de l'Éditeur BizTalk

  • Impossible d'ouvrir l'Éditeur BizTalk ou le Mappeur BizTalk


Mot de passe requis lors de la tentative de connexion à un serveur WebDAV distant

Cause : Il se peut que l'utilisateur n'ait pas accès au dossier BizTalkServerRepository.

Solution : Autorisez l'utilisateur à accéder au dossier BizTalkServerRepository. Pour effectuer cette opération :

  1. Dans le menu Démarrer, pointez sur Programmes, sur Outils d'administration, puis cliquez sur Gestionnaire des services Internet.

  2. Dans l'arborescence de la console, développez le nom de l'ordinateur.

  3. Développez Site Web par défaut.

  4. Cliquez avec le bouton droit sur BizTalkServerRepository, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de BizTalkServerRepository s'affiche.

  5. Cliquez sur l'onglet Sécurité du répertoire.

  6. Dans la zone Connexions anonymes et contrôle d'authentification, cliquez sur Modifier.

  7. Activez la case à cocher Connexions anonymes et cliquez deux fois sur OK.


Échec de la connexion au référentiel WebDAV ou du stockage de fichiers sur le référentiel WebDAV

Première cause : Si vous essayez de récupérer un mappage ou une spécification à partir de WebDAV (Web Distributed Authoring and Versioning) ou encore d'enregistrer un mappage ou une spécification dans WebDAV, vous pouvez voir apparaître un des messages suivants :

Le fichier ne peut pas être stocké dans le référentiel WebDAV. Le serveur peut ne pas être disponible à ce moment.

Aucune clé correspondant aux caractéristiques décrites n'a été trouvée dans la plage en cours.

Cela se produit lorsque le paramètre anonyme du compte utilisateur sur le serveur Web ne possède pas de privilèges en écriture dans le répertoire Microsoft® Windows® 2000 qui héberge le référentiel.

Solution : Autorisez l'utilisateur à accéder au référentiel. Pour effectuer cette opération :

  1. Dans le menu Démarrer, pointez sur Programmes et sur Accessoires, puis cliquez sur Explorateur Windows.

  2. Allez à l'endroit où vous avez installé Microsoft BizTalk Server 2002.

  3. Développez le répertoire Microsoft BizTalk Server, cliquez avec le bouton droit sur BizTalkServerRepository, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de BizTalkServerRepository s'affiche.

  4. Cliquez sur l'onglet Sécurité.

  5. Cliquez sur Ajouter et tapez le nom de domaine et le nom d'utilisateur de la personne à laquelle vous voulez permettre d'accéder au référentiel dans le format suivant : nom de domaine\nom d'utilisateur.

  6. Cliquez deux fois sur OK.

Deuxième cause : Si vous essayez de récupérer un mappage ou une spécification à partir de WebDAV, ou bien de stocker un mappage ou une spécification dans WebDAV, vous pouvez voir apparaître un des messages suivants :

Aucun emplacement de stockage pour BizTalk Server n'a été trouvé sur http://localhost/BizTalkServerRepository/DocSpecs. Tapez un autre nom de serveur pour vous reconnecter au référentiel WebDAV.

Cela se produit lorsque les extensions Microsoft FrontPage® Server sont activées sur le serveur Web.

Solution : Désactivez les extensions FrontPage Server. Si le service de publication Web fonctionne, arrêtez et redémarrez ce service.

Remarque

  • Ce problème peut survenir même si le service de publication Web ne fonctionne pas sur l'ordinateur hébergeant le référentiel WebDAV.

Pour désactiver les extensions FrontPage Server

  1. Dans le menu Démarrer, pointez sur Programmes, sur Outils d'administration, puis cliquez sur Gestionnaire des services Internet.

  2. Dans le volet de détails, double-cliquez sur <nom de l'ordinateur>, cliquez avec le bouton droit sur Site Web par défaut, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de Site Web par défaut apparaît.

  3. Dans l'onglet Extensions serveur, désactivez la case à cocher Activer les opérations d'auteur, puis cliquez sur OK.

Pour arrêter et redémarrer le service de publication Web

  4. Dans le menu Démarrer, pointez sur Programmes et sur Outils d'administration, puis cliquez sur Services de composants.

  5. Dans l'arborescence de la console, cliquez sur Services (local).

  6. Dans le volet des détails, cliquez avec le bouton droit sur Service de publication Web, puis cliquez sur Arrêter.

  7. Cliquez avec le bouton droit sur Service de publication Web, puis cliquez sur Démarrer.


???.xml apparaît dans la boîte de dialogue WebDAV

Problème lié à l'utilisation des langues

Cause : Le jeu de caractères affiché pour votre ordinateur dépend des paramètres régionaux spécifiés dans BizTalk Server 2002.

Solution : Spécifiez le même jeu de caractères pour votre ordinateur que celui qui est défini dans les paramètres locaux de BizTalk Server. Pour effectuer cette opération :

  1. Dans le menu Démarrer, pointez sur Paramètres, puis cliquez sur Panneau de configuration.

  2. Double-cliquez sur Options régionales.

  3. Dans l'onglet Général, dans la zone Paramètres de langue pour le système, activez la case à cocher correspondant à la langue souhaitée et cliquez sur Définir par défaut.

    La boîte de dialogue Sélection des paramètres régionaux système apparaît.

  4. Cliquez sur les paramètres régionaux souhaités dans la liste et cliquez deux fois sur OK.

    La boîte de dialogue Modification des options régionales s'affiche.

  5. Cliquez sur Oui pour accepter les modifications et redémarrez votre ordinateur.

Remarque

  • Après le redémarrage de votre ordinateur, la boîte de dialogue Options régionales affiche la langue sélectionnée : <Langue> (valeur par défaut).

Voir aussi

Stockage de mappages

Stockage de spécifications


Le dossier BizTalkServerRepositoryMaps apparaît dans la boîte de dialogue Extraire à partir de WebDAV

Cause : Une barre oblique inverse à droite se trouve dans la zone Chemin local de la boîte de dialogue Propriétés de BizTalkServerRepository.

Solution : Supprimez la barre oblique inverse à droite dans la zone Chemin local de la boîte de dialogue Propriétés de BizTalkServerRepository. Pour effectuer cette opération :

  1. Dans le menu Démarrer, pointez sur Programmes, sur Outils d'administration, puis cliquez sur Services Internet (IIS), puis développez Site Web par défaut.

  2. Cliquez avec le bouton droit sur BizTalkServerRepository, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de BizTalkServerRepository s'affiche.

  3. Dans la zone Chemin local, supprimez la barre oblique inverse à droite et cliquez sur OK.

Cette procédure supprime le dossier BizTalkServerRepositoryMaps de la boîte de dialogue Extraire à partir de WebDAV. Ce dossier étant devenu inutilisable, il est préférable de le supprimer.


La boîte de dialogue Extraire à partir de WebDAV ou Stocker dans WebDAV est vide

Cause : L'exploration des répertoires est désactivée dans la boîte de dialogue Propriétés de BizTalkServerRepository.

Solution : Activez l'exploration des répertoires dans la boîte de dialogue Propriétés de BizTalkServerRepository. Pour effectuer cette opération :

  1. Dans le menu Démarrer, pointez sur Programmes, sur Outils d'administration, puis cliquez sur Gestionnaire des services Internet.

  2. Développez l'ordinateur concerné.

  3. Développez Site Web par défaut.

  4. Cliquez avec le bouton droit sur BizTalkServerRepository, puis cliquez sur Propriétés.

    La boîte de dialogue Propriétés de BizTalkServerRepository s'affiche.

  5. Dans l'onglet Répertoire virtuel, sélectionnez Recherche dans les répertoires.

  6. Assurez-vous que Lire et Écrire sont également sélectionnés, puis cliquez sur OK.


Échec de connexion à http://hôtelocal

Cause : La case à cocher Utiliser un serveur proxy est activée, mais pas la case à cocher Ne pas utiliser de serveur proxy pour les adresses locales.

Solution : Conservez l'option Utiliser un serveur proxy et activez l'option Ne pas utiliser de serveur proxy pour les adresses locales. Pour effectuer cette opération :

  1. Dans le menu Démarrer, pointez sur Programmes, puis cliquez sur Internet Explorer.

  2. Dans le menu Outils, cliquez sur Options Internet.

    La boîte de dialogue Options Internet s'affiche.

  3. Cliquez sur l'onglet Connexions, puis sur Paramètres LAN.

    La boîte de dialogue Paramètres du réseau local (LAN) apparaît.

  4. Dans la zone Serveur proxy, activez la case à cocher Ne pas utiliser de serveur proxy pour les adresses locales.

  5. Cliquez deux fois sur OK.

Remarque

  • Ce problème ne se produit pas si vous vous connectez à http://<nom de l'ordinateur>.


Analyse incomplète du fichier plat soumis à BizTalk Server

Cause : Il est possible qu'une erreur d'analyse se soit produite dans un fichier plat délimité qui a été soumis à BizTalk Server 2002 si le nom du nœud racine de ce fichier est le même qu'une sous-chaîne du nom d'un autre nœud du fichier.

Solution : Renommez le nœud racine de telle sorte que son nom ne soit pas une sous-chaîne du nom d'un autre nœud dans la spécification.


Espace non conservé dans le fichier plat soumis à BizTalk Server

Cause : Lorsqu'un fichier plat est soumis à BizTalk Server 2002, il se peut que l'espace présent dans les champs ait été supprimé. En effet, le parseur MSXML sous-jacent ne conserve pas par défaut l'espace dans un champ dont la propriété Type (onglet Déclaration) est définie sur Élément.

Solution : S'il est important de conserver l'espace dans un champ contenu dans un fichier plat, dans l'Éditeur BizTalk veillez à définir la propriété Type de l'onglet Déclaration du champ dans la spécification source sur Attribut.

Voir aussi

Définition des propriétés de déclaration


Échec du test du mappage

Cause : Lorsque vous testez un mappage, le Mappeur BizTalk le compile avant de le tester. Si un avertissement s'affiche pendant la compilation, il se peut que le test du mappage ait échoué. Le message d'erreur suivant s'affiche :

Échec de la transformation XSL (Extensible Stylesheet Language) effectuée à l'aide du document d'instance de test pour la spécification source.

Solution : Résolvez tous les avertissements du compilateur, puis recompilez le mappage. Pour résoudre un avertissement du compilateur, effectuez les opérations suivantes :

  1. Double-cliquez sur Avertissement dans l'onglet Sortie.

    La liaison ou le fonctoid associé au message d'avertissement s'affiche en surbrillance.

  2. Résolvez l'avertissement.

Pour recompiler le mappage :

  • Dans le menu Outils, cliquez sur Compiler le fichier de mappage.

Voir aussi

Test de mappages


échecs de l'importation DTD

Cause : Si vous essayez d'importer une définition de type de document (DTD) contenant une référence externe vers un autre fichier, il se peut que le message suivant apparaisse :

Caractère non valide dans DTD.

Solution : Supprimez toute référence externe dans une DTD avant d'essayer de l'importer.


Échec de validation d'instance lors de l'utilisation du champ Date ou Heure

Cause : Lorsque BizTalk Server 2002 traite une instance de document entrant, s'il existe une liaison depuis un fonctoid ou un champ dans l'arborescence de la spécification source vers un nœud de l'arborescence de la spécification de destination dont la propriété Type de données a la valeur Date, Date Time, Date Time.tz, Time ou Time.tz, la validation d'instance échoue si les données entrant dans le nœud de destination sont dans un format autre que le format ISO 8601.

Solution : En cas de liaison vers un champ d'une spécification de destination dont la propriété Type de données a la valeur Date, Date Time, Date Time.tz, Time ou Time.tz, assurez-vous que les données liées à ce champ (qu'elles proviennent d'un fonctoid ou d'un nœud d'une instance de document entrant) sont dans le format ISO 8601. Le tableau suivant illustre le format ISO 8601 correct pour chaque valeur possible de la propriété Type de données.

Propriété Type de données | Format ISO 8601
Date | YYYY-MM-DD (1988-04-07)
Date Time | YYYY-MM-DDTHH:MM:SS (1988-04-07T18:39:09)
Date Time.tz | YYYY-MM-DDTHH:MM:SS-TZH:TZM (1988-04-07T18:39:09-08:00)
Time | HH:MM:SS (08:15:27)
Time.tz | HH:MM:SS-TZH:TZM (08:15:27-05:00)


Ré-enregistrement de msdaipp.dll pour extraire ou enregistrer des fichiers dans WebDAV

Cause : Si vous essayez de récupérer un mappage ou une spécification à partir de WebDAV (Web Distributed Authoring and Versioning), ou encore d'enregistrer un mappage ou une spécification dans WebDAV, il est possible qu'un des messages suivants s'affiche :

Aucun emplacement de stockage pour BizTalk Server n'a été trouvé sur http://<nom serveur>/BizTalkServerRepository/DocSpecs

Solution : Pour résoudre ce problème, procédez comme suit :

  1. Dans l'Explorateur Windows, accédez au répertoire \Program Files\Common Files\System\Ole DB\, puis double-cliquez sur le fichier msdaipp.dll.

    La boîte de dialogue Attention apparaît.

  2. Cliquez sur Ouvrir avec.

    La boîte de dialogue Ouvrir avec apparaît.

  3. Cliquez sur Autre.

    La boîte de dialogue Ouvrir avec apparaît.

  4. Accédez au répertoire \WINNT\system32\, puis double-cliquez sur regsvr32.exe.

    La boîte de dialogue Ouvrir avec apparaît.

  5. Assurez-vous que Microsoft© Register Server est sélectionné et cliquez sur OK.

    Un message apparaît.

  6. Cliquez sur OK.


Le parseur ne parvient pas à trouver le délimiteur de début requis

Cause : Si l'instance de document que vous utilisez contient dans un enregistrement des champs qui sont à la fois facultatifs et vides, vous devez ajouter un délimiteur de champ avant le délimiteur d'enregistrement. Par exemple, l'instance de document suivante contient un tilde (~) pour le délimiteur d'enregistrement. Toutefois, elle contient également le signe plus (+) qui indique le délimiteur de champ du premier enregistrement. Ceci suppose que vous définissiez le Délimiteur d'enregistrement sur ~ et le Délimiteur de champ sur + dans la boîte de dialogue Délimiteurs de document.

Instance de document dans laquelle le délimiteur d'enregistrement est un tilde

Lorsque vous validez l'instance de document précédente en fonction de l'illustration de spécification suivante, l'erreur suivante s'affiche :

Lors de l'analyse de l'enregistrement « Record1 », le parseur n'a pas trouvé le délimiteur de début requis : « + » (0x002b).

Validation d'une instance de document en fonction d'une spécification

Solution : Pour résoudre ce problème, ajoutez le caractère « + » entre « TTT » et le caractère « ~ » dans l'instance de document.


Échec du stockage d'un fichier dans le référentiel WebDAV

Cause : En cas d'échec du stockage d'un fichier depuis l'Éditeur BizTalk ou le Mappeur BizTalk dans le référentiel WebDAV (Web Distributed Authoring and Versioning) (refus d'autorisation, fichier en lecture seule, par exemple), le message d'erreur approprié s'affiche. Si toutefois, vous fermez le fichier et l'extrayez de nouveau du référentiel WebDAV, vous afficherez le fichier mis en cache localement en lieu et place de celui du référentiel WebDAV. Ce fichier s'affiche comme s'il provenait du référentiel WebDAV, même si la boîte de dialogue Autorisation refusée apparaît.

Solution : Effacez la mémoire cache d'Internet Explorer. Pour effacer la mémoire cache, procédez comme suit :

  1. Dans le menu Démarrer, pointez sur Programmes, puis cliquez sur Internet Explorer.

  2. Dans le menu Outils, cliquez sur Options Internet.

    La boîte de dialogue Options Internet s'affiche.

  3. Cliquez sur Supprimer les fichiers.


Échec de l'importation d'un fichier XDR

Cause : L'importation XDR (XML-Data Reduced) échoue si la valeur par défaut d'un attribut de type IDREFS est spécifiée dans la déclaration de l'attribut, comme illustré dans le code suivant :

<AttributeType name="Field1" d:type="idrefs" default="a1 a2"> </AttributeType>
<attribute type="Field1" required="no"></attribute>

Solution : Amenez la valeur par défaut dans la référence d'attribut du schéma XDR avant de l'importer dans l'Éditeur BizTalk, comme illustré dans le code suivant :

<AttributeType name="Field1" d:type="idrefs"> </AttributeType>
<attribute type="Field1" required="no" default="a1 a2"></attribute>


La validation d'instance échoue lorsque la virgule est utilisée dans les nombres décimaux.

Cause : Lorsqu'une virgule (,) est utilisée à la place d'un point (.) pour exprimer la décimale dans une instance de document, la validation de l'instance peut échouer. Ce problème se produit car le parseur convertit l'instance du document en document XML (Extensible Markup Language), puis utilise le modèle DOM (Document Object Model) XML pour valider le document XML par rapport à sa spécification. Le modèle DOM XML n'autorise pas l'utilisation de la virgule à la place du point décimal. Pour plus d'informations, accédez au site Web de la bibliothèque en ligne MSDN msdn.microsoft.com/library/), disponible en anglais, et recherchez la référence des types de données XML.

Solution : Utilisez un point pour exprimer les nombres décimaux dans une instance de document.


Les segments de données volumineux d'un document IDOC ne sont pas publiés sur un système SAP.

Cause : Lorsque des segments de données volumineux sont utilisés dans un document IDOC envoyé à un système SAP à des fins de traitement, il est possible que certaines données ne soient pas traitées. Une valeur d'expiration du délai configurée sur le système SAP peut être à l'origine de l'erreur.

Solution : Modifiez la valeur d'expiration du délai sur le système SAP.


Limitations Unicode du référentiel WebDAV

Problème lié à l'utilisation des langues

Cause : WebDAV (Web Distributed Authoring and Versioning) ne prend pas en charge les caractères Unicode dans les noms de fichier. En revanche, dans le référentiel WebDAV, les fichiers doivent être enregistrés en codages Unicode uniquement.

Solution : Assurez-vous que les paramètres régionaux du système définis sur l'ordinateur prennent en charge votre langue. Par exemple, si vous installez la version anglaise de BizTalk Server 2002 sur une version anglaise de Windows et souhaitez utiliser, dans les noms de fichier, des caractères qui ne sont pas pris en charge dans la page de code Latin I (Windows 1252 comprenant l'anglais), vous devez modifier vos paramètres régionaux système par des paramètres prenant en charge votre langue.

En outre, pour le coréen et le chinois, vous devez vous assurer que votre navigateur Internet n'est pas configuré pour envoyer des URL en format UTF-8. Pour cela, procédez comme suit :

  1. Dans le menu Démarrer, pointez sur Programmes, puis cliquez sur Internet Explorer.

  2. Dans le menu Outils, cliquez sur Options.

    La boîte de dialogue Options Internet s'affiche.

  3. Sélectionnez l'onglet Avancé et désactivez la case à cocher Toujours envoyer les URL en tant que UTF-8.


Les modèles X12 contiennent une décimale implicite

Cause : Si vous utilisez des modèles BizTalk Server 2002 au format X12 dans l'Éditeur BizTalk ou dans le Mappeur BizTalk, vous risquez de rencontrer des problèmes et d'obtenir des messages d'erreur de ce type :

La longueur du champ "ITD05" ("") n'est pas valide. Elle doit être comprise entre 48 et -1. Ce document va être rejeté.

Les modèles X12 utilisent le type de données décimal implicite Nx qui affecte la validation et le mappage. Si les données d'entrée contiennent un point décimal, les données de sortie ne correspondront pas au type de données personnalisé Nx (c'est-à-dire, sans point décimal), ce qui créera des instances de document non valides dans le fichier XML (Extensible Markup Language) intermédiaire.

Solution : Remplacez manuellement le type de données décimal implicite dans les modèles X12 par n'importe quel autre type de données numérique.


L'utilisation du clavier pour convertir les caractères coréens en caractères chinois provoque une panne de l'Éditeur BizTalk.

Problème lié à l'utilisation des langues

La conversion des caractères coréens en caractères chinois à l'aide de la touche CHINOIS sur un clavier coréen provoque une panne de l'Éditeur BizTalk. En revanche, vous pouvez saisir directement des caractères chinois (par exemple, en copiant un caractère chinois depuis le Bloc-notes) dans l'Éditeur BizTalk.


Impossible d'ouvrir l'Éditeur BizTalk ou le Mappeur BizTalk

Cause : Lorsque vous utilisez le parseur XML (Extensible Markup Language) , vous ne pouvez ouvrir ni l'Éditeur BizTalk, ni le Mappeur BizTalk.

Solution : Il est fortement recommandé d'utiliser la version 3.0 du parseur Microsoft XML (MSXML) avec BizTalk Server 2002. Il est également recommandé d'utiliser le parseur MSXML en Mode côte à côte. Si vous configurez le parseur MSXML pour le faire fonctionner en Mode remplacement en installant XMLINST.exe, vous pouvez rencontrer des problèmes avec BizTalk Server. Si vous configurez le parseur MSXML pour le faire fonctionner en Mode remplacement en utilisant XMLINST.exe ou en modifiant les clés de registre, votre installation de BizTalk Server ne sera pas prise en charge.

La procédure suivante décrit la façon dont vous pouvez configurer le parseur MSXML pour qu'il s'exécute en mode Mode côte à côte, si vous l'avez déjà configuré en Mode remplacement.

  1. Dans le menu Démarrer, cliquez sur Exécuter.

  2. Dans la zone Ouvrir, tapez cmd et cliquez sur OK.

  3. À l'invite de commandes, tapez xmlinst -u et appuyez sur ENTRÉE.

  4. À l'invite de commandes, tapez %WINDIR%\system32\regsvr32 msxml.dll et appuyez sur ENTRÉE.

  5. À l'invite de commandes, tapez %WINDIR%\system32\regsvr32 msxml2.dll et appuyez sur ENTRÉE.

  6. À l'invite de commandes, tapez %WINDIR%\system32\regsvr32 msxml3.dll et appuyez sur ENTRÉE.

  7. À l'invite de commandes, tapez exit et appuyez sur ENTRÉE.

Pour plus d'informations sur l'utilisation de XMLINST.exe, consultez l'article suivant de la Base de Connaissances Microsoft, « PRB: Application Errors Occur After You Run Xmlinst.exe on Production Servers » (support.microsoft.com/support/kb/articles/Q302/5/12.asp) (site en anglais).


Intégration des services BizTalk

L'intégration des services d'orchestration BizTalk de Microsoft® et des services d'échanges BizTalk permet de contrôler les échanges de documents et de messages entre vos partenaires commerciaux et les applications internes à votre entreprise qui utilisent plusieurs services de transport. Les fonctionnalités suivantes sont également fournies :

  • Contrôle des transactions de longue durée complexes et des processus professionnels.

  • Livraison fiable de documents et de messages.

  • Validation des données assurée par le contrôle de chaque instance de document par rapport à une spécification.

  • Mappage des données assuré par des mappages pour transformer la structure et le format des documents.

  • Sécurité et intégrité des données assurées par des certificats de cryptage et de signature numérique.

  • Prise en charge de la génération et de la corrélation des accusés de réception.

Cette section décrit un scénario courant, parmi les multiples scénarios existants, qui intègre les services d'orchestration BizTalk et les services d'échanges BizTalk.

Dans ce scénario, vous configurez une instance de planification XLANG sur le système source afin d'initier et d'envoyer un message à un système de destination d'un partenaire commercial, puis attendez de celui-ci un message de retour que vous transmettez à l'instance de planification XLANG à l'origine du message. Par exemple, vous pouvez appliquer cette configuration à des processus professionnels très courants, tels que l'envoi d'un ordre d'achat et l'attente de son accusé de réception avant de poursuivre le processus.

Les rubriques de cette section décrivent les étapes de configuration requises pour échanger des messages entre votre entreprise et un partenaire commercial à l'aide de types de transport HTTP et non-HTTP. Vous pouvez néanmoins utiliser une configuration similaire pour superviser les échanges de messages entre les applications internes à votre entreprise.

Comme Microsoft BizTalk Server 2002 peut être utilisé en tant que système source qui envoie le message initial ou en tant que système de destination qui envoie le message de retour, cette section développe les étapes de configuration nécessaires dans ces deux cas de figure. Elle vous permet également de visualiser la configuration globale requise.

Pour obtenir des exemples de planifications XLANG qui reflètent ces configurations ainsi que d'autres fichiers associés, accédez au dossier \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Integrating BizTalk Services.

Remarques

  • Le terme port d'échanges, utilisé dans les services d'échanges BizTalk, et le terme port, utilisé dans les services d'orchestration BizTalk, ont une signification totalement différente :
    • Un port d'échanges est un ensemble de propriétés qui définit les services d'échanges BizTalk en vue du transport de documents vers une destination donnée à l'aide d'un service de transport spécifié.

    • Un port est un emplacement nommé qui utilise une implémentation spécifique. Dans une planification XLANG, les ports facilitent les communications synchrones et asynchrones et permettent de transférer les messages dans la planification ou hors de celle-ci.
  • Les événements Action associés aux messages traités par une planification XLANG et qui sont soit envoyés, soit reçus des services d'échanges BizTalk, peuvent être tracés dans la base de données de suivi. Pour plus d'informations, voir Suivi des événements de planification XLANG dans la base de données de suivi.

Cette section traite des rubriques suivantes :

  • Utilisation d'un type de transport HTTP

  • Utilisation d'un type de transport non-HTTP

Voir aussi

Fonctionnement de BizTalk Server

Gestion des instances


Utilisation d'un type de transport HTTP

Cette section explique comment intégrer et configurer les Services d'orchestration BizTalk et les services d'échanges BizTalk pour le système source et le système de destination afin que :

  • le système source génère un message et l'envoie au système de destination d'un partenaire commercial en utilisant une instance de planification XLANG spécifique ;

  • le système de destination envoie un message de retour à l'aide d'un type de transport HTTP ;

  • le système source reçoive le message de retour et l'achemine vers l'instance de planification XLANG qui a généré et envoyé le message initial.

Pour configurer les deux systèmes afin de permettre au système de destination d'utiliser un type de transport non-HTTP en vue de l'envoi des messages de retour, voir Utilisation d'un type de transport non-HTTP.

Cette section traite des rubriques suivantes :

  • Configuration du système source pour utiliser un type de transport HTTP

  • Configuration du système de destination pour utiliser un type de transport HTTP


Configuration du système source pour utiliser un type de transport HTTP

Les étapes de cette procédure décrivent la configuration du système source permettant de générer et d'envoyer un message contenant une URL HTTP de réponse. Le système de destination du partenaire commercial utilise l'adresse de réponse contenue dans le message initial pour envoyer un message de retour à une page ASP sur le site Web du système source à l'aide d'un type de transport HTTP. Pour configurer le système source et permettre au système de destination d'utiliser un type de transport non-HTTP en vue de l'envoi des messages de retour, voir Configuration du système source pour utiliser un type de transport non-HTTP. Les étapes de configuration nécessaires à l'utilisation d'un type de transport HTTPS (Secure Hypertext Transfer Protocol) sont développées ultérieurement dans cette rubrique.

L'URL HTTP utilisée comme adresse de réponse dans la configuration est générée par la planification XLANG à partir des données des propriétés du port. Elle est composée des éléments suivants :

  • L'adresse d'une page ASP (Active Server Pages) sur le site Web du système source à laquelle un message de retour est envoyé.

  • Une chaîne de requête contenant le nom du canal, dans les services d'échanges BizTalk, pour le système source utilisé pour traiter le message de retour, et le chemin complet d'une file d'attente par instance, créée par l'instance de planification XLANG et à laquelle est transmis le message de retour.

L'adresse suivante est un exemple d'URL HTTP de réponse :

http://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\ChannelForReply{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Lorsque la page ASP du système source reçoit le message de retour, son script exécute les étapes suivantes :

  • Extraction du nom du canal et des informations sur le chemin d'accès de la file d'attente à partir de la chaîne de requête.

  • Conversion du nom du chemin d'accès de la file d'attente en nom de format et insertion du préfixe de file d'attente (://) requis par les services d'échanges BizTalk.

  • Envoi du message de retour aux services d'échanges BizTalk du système source qui utilise le nom de canal et les informations sur le chemin d'accès de la file d'attente comme paramètres d'envoi. Pour plus d'informations sur l'envoi de documents, voir Submitting.

Les services d'échanges BizTalk du système source utilisent le canal spécifié pour traiter le message de retour et le port d'échanges associé, qui fait appel au chemin d'accès de la file d'attente pour transférer le message de retour vers l'instance de planification XLANG en cours d'exécution qui a généré le message initial.

Afin que la configuration du système source fonctionne correctement, le système de destination du partenaire commercial doit également être correctement configuré. Pour plus d'informations sur la configuration du système de destination, voir Configuration du système de destination pour utiliser un type de transport HTTP.

Pour configurer le système source afin d'utiliser un type de transport HTTP, exécutez les étapes décrites dans le tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications nécessaires aux définitions de documents entrants et sortants du canal qui traitera le message initial.
  • Création et validation de spécifications

    Remarque

    • Vous devez ajouter un champ dans chacune de ces spécifications pour l'adresse de réponse. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système de destination de ce dernier. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
  • Créez les spécifications pour les définitions de documents entrants et sortants du canal qui traitera le message de retour.
  • Création et validation de spécifications

    Remarque

    • Ces spécifications ne requièrent pas de configuration spéciale.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une organisation représentant le partenaire commercial avec le système de destination.
  • Création d'organisations

    Remarque

    • Cette organisation ne nécessite pas de configuration spéciale.
  • Créez les définitions de documents nécessaires à la création du canal que vous utilisez pour traiter le message initial.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de documents, sélectionnez les spécifications comportant un champ de réponse. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez les définitions de documents nécessaires à la création du canal que vous utiliserez pour traiter le message de retour.
  • Création de définitions de documents

    Remarque

    • Ces définitions de documents ne requièrent pas de configuration spéciale.
  • Créez un port d'échanges pour une organisation afin de transmettre le message initial au système de destination.
  • Création de ports d'échanges

    Remarque

    • Ce port d'échanges ne peut pas être un port d'échanges ouvert.
  • Créez un canal à partir d'une application pour traiter le message sortant de la planification XLANG.
  • Création de canaux

    Remarques

    • Sur la page Application source de l'Assistant Canal, cliquez sur Planification XLANG. Pour plus d'informations, voir Définition des propriétés d'une application source.

    • Notez le nom du canal et le nom de la définition du document entrant que vous utilisez. Ces noms sont utilisés pour configurer les services d'orchestration BizTalk.
  • Créez un port d'échanges dans une application pour transférer le message de retour vers l'instance de planification XLANG active qui a généré le message sortant.
  • Création de ports d'échanges

    Remarque

    • Sur la page Application de destination de l'Assistant Port d'échanges, cliquez sur Exécution de la planification XLANG en cours. Pour plus d'informations, voir Définition des propriétés de l'application de destination.
  • Créez un canal à partir d'une organisation pour traiter le message de retour du système de destination.
  • Création de canaux

    Remarque

    • Notez le nom du canal et le nom de la définition du document sortant que vous utilisez. Ces noms sont utilisés pour configurer les services d'orchestration BizTalk.
Utilisation du Concepteur d'Orchestration BizTalk
  • Utilisez une forme Échanges BizTalk pour implémenter un port qui permette l'envoi du message initial.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarque

    • Sur la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Canal statique et dans la zone Entrez le nom d'un canal connu pré-existant, tapez le nom du canal dans le Gestionnaire d'échanges BizTalk que vous utilisez pour traiter le message initial.
  • Créez le flux de communication entre la forme Action et le port qui envoie le message initial.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message, puis dans la zone Nom de message, entrez le nom du message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de savoir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de message, tapez le nom de la définition du document entrant du canal que vous utilisez pour traiter le message.

    • Sur la page Informations sur la spécification du message, cliquez sur Parcourir et sélectionnez la spécification utilisée dans la définition du document entrant du canal qui a traité le message initial.

    • Dans la zone Champs de message de la page Informations sur la spécification du message, cliquez sur Ajouter, puis ajoutez le champ à la spécification créée pour contenir l'adresse de réponse dans le message initial.
  • Utilisez une forme Échanges BizTalk afin de mettre en œuvre un port permettant la réception d'un message de retour.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarques

    • Sur la page Informations sur l'activation de la planification XLANG de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Non.

    • Dans la zone Nom du canal de la page Informations sur le canal, tapez le nom du canal du Gestionnaire d'échanges BizTalk utilisé pour traiter le message de retour.

      Le Concepteur d'Orchestration BizTalk utilise le nom du canal et un identificateur unique universel (GUID) pour créer et affecter un nom à une file d'attente par instance à laquelle le message de retour est transmis.

    • Dans la zone Adresse de l'URL HTTP dans laquelle le service d'Échanges BizTalk reçoit les documents de la page Informations sur le canal, tapez l'adresse de la page ASP vers laquelle le partenaire commercial peut envoyer un message de retour.

      Le Concepteur d'Orchestration BizTalk utilise l'adresse et le nom du canal, précédemment tapés, pour créer une adresse d'URL HTTP avec une chaîne de requête qui intègre le nom du canal et le chemin d'accès de la file d'attente par instance.
  • Créez le flux de communication entre la forme Action et le port qui reçoit le message de retour.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message, puis dans la zone Nom de message, entrez le nom du message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document sortant pour le canal permet de savoir plus facilement quel message vous recevez.

    • Dans la zone Type du message de la page Informations sur les types de message, tapez le nom de la définition du document sortant du canal que vous utilisez pour traiter le message de retour.

      Tous les messages transmis à partir des services d'échanges BizTalk à une instance de planification XLANG sont envoyés dans une file d'attente de messages. L'étiquette de ces messages correspond au nom de la définition du document sortant du canal.
  • Créez le flux de données pour transférer les données de référence de port dans le champ de l'adresse de réponse.
  • Dessin de flux entre les messages

    Remarques

    • Cliquez sur l'onglet Données.

    • Sur la page Données, dans le message Port References, sélectionnez les références du port qui recevra le message de retour. Ensuite, faites glisser sa poignée de contrôle vers le point de connexion du champ de l'adresse de réponse dans le message initial.

      Ainsi, les références du port sont transférées dans le champ de l'adresse de réponse du message sortant initial. Les références du port correspondent à une adresse d'URL HTTP d'une page ASP, qui intègre une chaîne de requête au nom du canal et au chemin d'accès de la file d'attente par instance du port.
Utilisation de la page ASP
  • Utilisez la page ASP fournie en exemple avec BizTalk Server 2002 ou configurez-en une basée sur un script identique.
 Remarques
  • Pour utiliser la page ASP d'exemple, allez dans \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts sur le disque d'installation et sélectionnez le fichier ReceiveResponse.asp. Copiez ce fichier dans le dossier approprié sur le site Web du système source.

  • Lorsque la page d'exemple ASP reçoit un message de retour, son script extrait le nom du canal et le chemin d'accès de la file d'attente de la chaîne de requête dans l'adresse de l'en-tête HTTP. La page ASP convertit également le nom du chemin d'accès de la file d'attente en nom de format et insère le préfixe de file ://. La page utilise ensuite ces données comme paramètres d'envoi du message de retour vers les services d'échanges BizTalk sur le système source. Pour plus d'informations sur l'envoi de documents, voir Submitting.

Utilisation d'un type de transport HTTPS sécurisé.

Si vos processus professionnels nécessitent un mode de transport sécurisé pour échanger des messages avec un partenaire commercial, vous devez utiliser un type de transport HTTPS.

Pour ce faire, dans la configuration du système source, il vous suffit de modifier l'adresse de l'URL du port qui recevra le message de retour.

Lorsque vous implémentez le port qui reçoit le message de retour, l'URL tapée pour l'adresse de réponse doit utiliser un préfixe HTTPS et non pas un préfixe HTTP.

L'adresse suivante est un exemple d'adresse de réponse qui utilise le préfixe HTTPS :

https://hostname/receiveresponse.asp?channel=ChannelForReply&qpath=hostname.domain.corp.vigorair-18.com\private$\ChannelForReply{9e0016bf-be1f-48fe-82de-b27077ab5e73}

Le système de destination ne requiert aucune modification de configuration supplémentaire.

Voir aussi

Intégration des services BizTalk


Configuration du système de destination pour utiliser un type de transport HTTP

Les étapes de cette rubrique expliquent comment configurer le système de destination afin de recevoir un message contenant une URL HTTP de réponse et d'envoyer un message de retour au système source via un type de transport HTTP. Si vous voulez configurer le système de destination pour utiliser un type de transport non-HTTP afin d'envoyer des messages de retour, voir Configuration du système de destination pour utiliser un type de transport non-HTTP. Les étapes de configuration nécessaires afin d'utiliser un type de transport HTTPS sont développées ultérieurement dans cette rubrique.

Lorsque les services d'échanges BizTalk du système de destination reçoivent le message initial, ils sont configurés pour activer une nouvelle instance d'une planification XLANG spécifiée et pour envoyer le message vers un port spécifié dans cette instance de planification XLANG.

La planification XLANG est configurée pour transférer les données de l'adresse de réponse, contenues dans un champ du message initial, vers le champ de référence de port pour le port servant à envoyer le message de retour. La planification XLANG envoie ensuite le message de retour vers les services d'échanges BizTalk à l'aide de l'option Canal dynamique.

L'option Canal dynamique permet de transférer les données de port spécifiques en tant que paramètres d'envoi lors de l'envoi du message vers les services d'échanges BizTalk. Les données de référence de port, dans ce cas l'adresse de réponse, sont transférées en tant que paramètres d'identification de la destination, et le Type de message pour le port est transmis en tant que paramètre du nom de définition de document. Pour plus d'informations sur les paramètres d'envoi, voir Submitting. Les paramètres d'envoi permettent aux services d'échanges BizTalk d'identifier un canal spécifique pour traiter le message de retour. Pour plus d'informations, voir Identification.

Si vous activez l'option Canal dynamique, le canal des services d'échanges BizTalk doit être associé à un port d'échanges ouvert. Le port d'échanges ouvert transfère le message de retour vers le système source du partenaire commercial à l'aide de l'adresse de réponse, qui est utilisée comme paramètre d'identification de la destination. L'utilisation du transport HTTP découle de l'URL HTTP de la page ASP dans le système source. Pour plus d'informations sur les ports d'échanges ouverts, voir Ports d'échanges ouverts.

Afin que la configuration du système de destination fonctionne correctement, le système source du partenaire commercial doit également être correctement configuré. Pour plus d'informations sur la configuration du système source, voir Configuration du système source pour utiliser un type de transport HTTP.

Pour configurer le système de destination afin d'utiliser un type de transport HTTP, exécutez les étapes décrites dans le tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions de document entrants et sortants du canal que vous utilisez pour traiter le message initial.
  • Création et validation de spécifications

    Remarque

    • Vous devez ajouter un champ dans chacune de ces spécifications pour l'adresse de réponse. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système source de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
  • Créez les spécifications pour les définitions des documents entrants et sortants du canal qui traitera le message de retour.
  • Création et validation de spécifications

    Remarque

    • Ces spécifications ne requièrent pas de configuration spéciale.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une organisation pour représenter le partenaire commercial avec le système source.
  • Création d'organisations

    Remarque

    • Cette organisation ne nécessite pas de configuration spéciale.
  • Créez les définitions de documents nécessaires pour créer un canal qui traitera le message initial et un canal qui traitera le message de retour.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de documents, sélectionnez les spécifications précédemment créées. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez un port d'échanges dans une application pour activer une nouvelle instance de planification XLANG et transférer le message initial vers un port de cette instance de planification XLANG.
  • Création de ports d'échanges

    Remarques

    • Sur la page Application de destination de l'Assistant Port d'échanges, cliquez sur Nouvelle planification XLANG.

    • Dans la zone Planifier le moniker, tapez le moniker de la planification spécifiée ou cliquez sur Parcourir pour définir le chemin d'accès.

    • Dans la zone Nom du port, tapez le nom du port spécifique de cette planification vers laquelle le document est envoyé.

      Pour plus d'informations, voir Définition des propriétés de l'application de destination.
  • Créez un canal à partir d'une organisation pour traiter le message initial du partenaire commercial.
  • Création de canaux

    Remarque

    • Notez le nom du canal et le nom de la définition du document sortant que vous utilisez. Ces noms sont utilisés pour configurer les services d'orchestration BizTalk.
  • Créez un port d'échanges pour une organisation afin de transmettre le message de retour au système source.
  • Création de ports d'échanges

    Remarque

    • Sur la page Organisation de destination de l'Assistant Port d'échanges, cliquez sur Destination ouverte. Pour plus d'informations, voir Définition des propriétés de l'organisation de destination.

      Pour un port d'échanges ouvert, les informations sur la destination doivent figurer dans le document ou être fournies par les paramètres d'envoi. Lorsque la planification XLANG envoie le message de retour aux services d'échanges BizTalk, elle transmet les données de l'adresse de réponse, contenues dans le message initial, en tant que paramètres d'identification de la destination.
  • Créez un canal à partir d'une application pour traiter le message de retour de la planification XLANG.
  • Création de canaux

    Remarque

    • Sur la page Application source de l'Assistant Canal, cliquez sur Planification XLANG. Pour plus d'informations, voir Définition des propriétés d'une application source.
Utilisation du Concepteur d'Orchestration BizTalk
  • Utilisez une forme Échanges BizTalk afin de mettre en œuvre un port qui permette la réception du message initial.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarques

    • Sur la page Direction de la communication de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Recevoir.

    • Sur la page Informations sur l'activation de la planification XLANG de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Oui.

    Important

    • Si vous choisissez Oui, le port est configuré pour activer une nouvelle instance de planification à chaque réception d'un message. Pour plus d'informations sur l'utilisation de cette option, reportez-vous à la rubrique qui présente cette étape.
  • Créez le flux de communication entre la forme Action et le port qui reçoit le message initial.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message, puis dans la zone Nom de message, entrez le nom du message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition de document sortant pour le canal permet de savoir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document sortant du canal que vous utilisez pour traiter le message de retour.

      Tous les messages transmis depuis Échanges BizTalk vers une planification XLANG utilisent une file d'attente de messages. L'étiquette de ces messages correspond au nom de la définition du document sortant du canal.
  • Utilisez une forme Échanges BizTalk afin de mettre en œuvre un port qui permette l'envoi du message de retour dans un canal dynamique.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarques

    • Sur la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Canal dynamique.

    • Lorsque vous créez un port qui utilise un canal dynamique, le canal des services d'échanges BizTalk qui traite le message est déterminé par les données du port transférées en tant que paramètres d'envoi. Ceci est décrit ultérieurement dans ce tableau.
  • Créez le flux de communication entre la forme Action et le port qui envoie le message de retour.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message, puis dans la zone Nom de message, entrez le nom du message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de savoir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document entrant du canal que vous utilisez pour traiter le message.

      Les données de définition du document entrant sont transférées vers les services d'échanges BizTalk en tant que paramètres d'envoi. Ceci est décrit ultérieurement dans ce tableau.
  • Créez le flux de données pour transférer le champ de l'adresse de réponse du port de référence vers le port qui envoie le message de retour.
  • Dessin de flux entre les messages

    Remarques

    • Cliquez sur l'onglet Données.

    • Sur la page Données, du message initial, cliquez dans le champ de l'adresse de réponse. Faites ensuite glisser sa poignée de contrôle vers le point de connexion gauche du port de référence dans le message Port References pour le port qui envoie le message de retour.

    Important

    • Vous devez connecter le champ de l'adresse de réponse au point de connexion gauche du port de référence. Le point de connexion gauche du port de référence est disponible uniquement lorsque le port est configuré sur un canal dynamique pour l'envoi des messages.

      Pour un port qui utilise un canal dynamique, les données de référence du port doivent être transférées à partir du champ correspondant d'un message reçu précédemment.

      Dans ce scénario, les données de l'adresse de réponse du message initial sont transférées dans le champ de référence du port utilisé pour l'envoi du message de retour. L'adresse de réponse correspond à l'URL HTTP vers laquelle le message de retour est envoyé.

      Lorsqu'un port qui utilise un canal dynamique transfère un message vers les services d'échanges BizTalk, les données de référence du port sont transmises en tant que paramètres d'identification de la destination et le type de données en tant que paramètre de définition du document. Les paramètres permettent aux services d'échanges BizTalk d'identifier le canal à invoquer pour traiter le message. Pour plus d'informations, voir Identification et Submitting.

      Lorsqu'un port est configuré pour utiliser un canal dynamique, les informations sur la destination sont transmises en tant que paramètres d'un envoi de destination ouvert. Par conséquent, tous les canaux invoqués par un port utilisant un canal dynamique doivent être associés à un port d'échanges ouvert.

Utilisation d'un type de transport HTTPS sécurisé.

Le port d'échanges transportant les messages de retour étant un port d'échanges ouvert, vous ne pouvez pas utiliser de certificat de cryptage pour encrypter vos documents.

Si vos processus professionnels nécessitent un moyen de transport sécurisé pour échanger des messages avec un partenaire commercial, le système source doit inclure une URL HTTPS, de préférence à une URL HTTP, comme adresse de réponse dans les messages initiaux qui vous sont envoyés.

Pour plus d'informations, voir Configuration du système source pour utiliser un type de transport HTTP.


Utilisation d'un type de transport non-HTTP

Cette section explique comment intégrer et configurer les services d'orchestration BizTalk et les Services d'échanges BizTalk pour le système source et le système de destination afin que :

  • Le système source génère un message et l'envoie au système de destination d'un partenaire commercial en utilisant une instance de planification XLANG spécifique.

  • le système de destination reçoive le message initial, active une instance de planification XLANG qui génère un message de retour, puis envoie le message de retour vers le système source via un transport non-HTTP.

Pour configurer les deux systèmes afin de permettre au système de destination d'utiliser un type de transport HTTP en vue de l'envoi des messages de retour, voir Utilisation d'un type de transport HTTP.

Cette section traite des rubriques suivantes :

  • Configuration du système source pour utiliser un type de transport non-HTTP

  • Configuration du système de destination pour utiliser un type de transport non-HTTP


Configuration du système source pour utiliser un type de transport non-HTTP

Les étapes de cette rubrique décrivent comment configurer le système source afin de générer et d'envoyer un message qui contient le chemin d'accès d'une file d'attente statique. Les systèmes de destination des partenaires commerciaux sont configurés pour transmettre le chemin d'accès de la file d'attente intégré au message dans un champ du message de retour et l'envoyer au système source via un type de transport non-HTTP. Pour configurer le système source et permettre au système de destination d'utiliser un type de transport HTTP pour envoyer des messages de retour, voir Configuration du système source pour utiliser un type de transport HTTP.

Lorsque le système source reçoit le message de retour, il l'envoie vers les services d'échanges BizTalk. Les services d'échanges BizTalk le transfèrent vers la file d'attente spécifiée dans le chemin intégré dans le champ du document. Cette file d'attente est contrôlée par l'instance de planification XLANG qui génère le message initial. La planification extrait le message de retour de cette file d'attente.

Afin que la configuration du système source fonctionne correctement, le système de destination du partenaire commercial doit également être correctement configuré. Pour plus d'informations sur la configuration du système de destination, voir Configuration du système de destination pour utiliser un type de transport non-HTTP.

Pour configurer le système source afin d'utiliser un type de transport non-HTTP, exécutez les étapes décrites dans le tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions de documents entrants et sortants du canal que vous utilisez pour traiter le message initial.
  • Création et validation de spécifications

    Remarque

    • Dans chacune de ces spécifications, vous devez ajouter un champ pour le chemin d'accès de la file d'attente. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système de destination de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
  • Créez les spécifications pour les définitions des documents entrants et sortants du canal que vous utilisez pour traiter le message de retour.
  • Création et validation de spécifications

    Remarques

    • Vous devez ajouter un champ pour le chemin d'accès de la file d'attente dans la spécification entrante. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système de destination de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.

    • Le champ du chemin d'accès de la file d'attente de la spécification entrante doit être défini comme valeur de destination dans les propriétés du dictionnaire. Pour plus d'informations, voir Définitions des propriétés du dictionnaire.

      Lors de la réception et de l'envoi d'un message de retour vers les services d'échanges BizTalk dans le système source, le champ du chemin d'accès de la file d'attente est reconnu et traité en tant que paramètre d'identification de la destination. Pour plus d'informations, voir Submitting. Le port d'échanges transfère le message de retour vers le chemin d'accès de la file d'attente spécifié. La planification XLANG contrôle cette file d'attente et en extrait le message de retour.

Utilisation du Mappeur BizTalk :
  • Créez un mappage à utiliser dans le canal qui traite le message initial.
  • Création de nouveaux mappages

    Important

    • La syntaxe du nom de chemin d'accès de la file d'attente générée par la planification XLANG doit être convertie en nom de format et intégrer le préfixe de file d'attente ://. Le script de la page ASP exécute cette modification pour le scénario de transport HTTP. Pour effectuer cette modification dans un scénario de transport non-HTTP, vous devez utiliser un fonctoid de concaténation dans un mappage. Pour plus d'informations, voir Intégration des services BizTalk en utilisant le mappage.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une organisation pour représenter le partenaire commercial avec le système de destination.
  • Création d'organisations

    Remarque

    • Cette organisation ne nécessite pas de configuration spéciale.
  • Créez les définitions de documents nécessaires pour créer un canal qui traitera le message initial et un canal qui traitera le message de retour.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de documents, sélectionnez les spécifications précédemment créées. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez un port d'échanges pour une organisation afin de transmettre le message initial au système de destination.
  • Création de ports d'échanges

    Remarque

    • Ce port d'échanges ne requiert pas de configuration particulière.
  • Créez un canal à partir d'une application pour traiter le message initial de la planification XLANG.
  • Création de canaux

    Remarques

    • Sur la page Application source de l'Assistant Canal, cliquez sur Planification XLANG. Pour plus d'informations, voir Définition des propriétés d'une application source.

    • Sur la page Document sortant, activez la case à cocher Mapper le document entrant sur le document sortant, puis cliquez sur le bouton Parcourir situé à droite de la zone Référence de mappage. Sélectionnez ensuite le mappage créé précédemment et cliquez sur Ouvrir.

    • Prenez note du nom de canal et du nom de la définition du document entrant que vous utilisez. Ces noms servent à configurer les services d'orchestration BizTalk.
  • Créez un port d'échanges ouvert dans une organisation pour transférer le message de retour vers l'instance de planification XLANG active qui a généré le message initial.
  • Création de ports d'échanges

    Remarques

    • Sur la page Organisation de destination de l'Assistant Port d'échanges, cliquez sur Destination ouverte. Pour plus d'informations, voir Définition des propriétés de l'organisation de destination.

    • Dans ce scénario, vous pouvez créer un port d'échanges pour une organisation, même si vous envoyez le message de retour à une application ou une planification XLANG.

      Ainsi, vous pouvez utiliser un port d'échanges ouvert pour l'envoi du message de retour en vous servant des informations sur le chemin d'accès de la file d'attente comme paramètres d'envoi. Pour plus d'informations, voir Submitting.

      Le port d'échanges ouvert transfère le message de retour vers la file d'attente statique, spécifiée dans le chemin d'accès de la file d'attente, dans laquelle la planification XLANG est configurée pour l'extraire.
  • Créez un canal à partir d'une organisation pour traiter le message de retour du système de destination.
  • Création de canaux

    Remarques

    • La définition du document entrant de ce canal doit utiliser la définition de document basée sur la spécification précédemment créée, dans laquelle vous avez affecté la valeur de destination au champ du chemin d'accès de la file d'attente dans les propriétés du dictionnaire.

    • Prenez note du nom de canal et du nom de la définition du document entrant que vous utilisez. Ces noms sont utilisés pour configurer les services d'orchestration BizTalk.
Utilisation du Concepteur d'Orchestration BizTalk
  • Utilisez une forme Échanges BizTalk afin de mettre en œuvre un port qui permette l'envoi du message initial.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarque

    • Sur la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Canal statique et dans la zone Entrez le nom d'un canal connu pré-existant, tapez le nom du canal dans le Gestionnaire d'échanges BizTalk que vous utilisez pour traiter le message initial.
  • Créez le flux de communication entre la forme Action et le port qui envoie le message initial.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message, puis dans la zone Nom de message, entrez le nom du message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de savoir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de message, tapez le nom de la définition du document entrant du canal que vous utilisez pour traiter le message.

    • Sur la page Informations sur la spécification du message, cliquez sur Parcourir et sélectionnez la spécification utilisée dans la définition du document entrant du canal qui a traité le message initial.

    • Sur la page Informations sur la spécification du message, dans la zone Champs de message, cliquez sur Ajouter, puis ajoutez le champ à la spécification créée pour contenir l'adresse du chemin d'accès de la file d'attente.
  • Utilisez une forme Message Queuing afin de mettre en œuvre un port qui permette la réception du message de retour.
  • Implémentation d'un port à l'aide de Message Queuing

    Remarques

    • Dans ce scénario, vous utilisez une liaison de port Message Queuing, même si vous recevez un message à partir des services d'échanges BizTalk.

    • Sur la page Informations sur la file d'attente statique ou dynamique de l'Assistant Liaison de Message Queuing, cliquez sur File d'attente dynamique.

    • Sur la page Informations sur la file d'attente, cliquez sur Créer une nouvelle file d'attente pour chaque instance et, dans la zone Entrez le préfixe de la file d'attente, tapez le nom du préfixe qui doit être utilisé pour créer le nom de la file d'attente.
  • Créez le flux de communication entre la forme Action et le port qui reçoit le message de retour.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Assistant Communication XML de l'Assistant du même nom, cliquez sur Recevoir.

    • Sur la page Informations sur le message, cliquez sur Créer un message et dans la zone Nom du message, tapez un nom pour le message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document sortant pour le canal permet de savoir plus facilement quel message vous recevez.

    • Dans la zone Type du message de la page Informations sur les types de message, tapez le nom de la définition du document sortant du canal que vous utilisez pour traiter le message de retour.

      Tous les messages transmis depuis Échanges BizTalk vers une planification XLANG utilisent une file d'attente de messages. L'étiquette de ces messages correspond au nom de la définition du document sortant du canal.
  • Créez le flux de données de la référence de port de réception au champ du chemin d'accès de la file d'attente.
  • Dessin de flux entre les messages

    Remarques

    • Cliquez sur l'onglet Données.

    • Sur la page Données, dans le message Port References, sélectionnez le champ du port qui recevra le message de retour. Ensuite, faites glisser sa poignée de contrôle vers le point de connexion du champ du chemin d'accès de la file d'attente dans le message initial.

      Les données de référence du port sont insérées dans le champ du chemin d'accès de la file d'attente du message initial. Les références du port correspondent au chemin d'accès de la file d'attente statique du port qui reçoit le message de retour.


Configuration du système de destination pour utiliser un type de transport non-HTTP

Les étapes de cette rubrique décrivent comment configurer le système de destination afin de recevoir un message qui contient un chemin de file d'attente et d'envoyer un message de retour, contenant ce même chemin, au système source via un type de transport non-HTTP. Si vous voulez configurer le système de destination afin d'utiliser un type de transport HTTP pour envoyer des messages de retour, voir Configuration du système de destination pour utiliser un type de transport HTTP.

Lorsque les services d'échanges BizTalk du système de destination reçoivent le message initial, ils sont configurés pour activer une nouvelle instance d'une planification XLANG spécifiée et transmettre le message à un port spécifié dans cette instance de planification XLANG.

La planification XLANG est configurée pour transférer les données contenues dans le champ du chemin d'accès de la file d'attente du message initial vers le champ correspondant du message de retour, puis envoyer le message de retour vers un canal des services d'échanges BizTalk.

Les services d'échanges BizTalk utilisent le canal spécifié pour traiter le message de retour et le transférer vers un port d'échanges. Ce port d'échanges est configuré pour le transfert du message de retour vers une adresse convenue avec le partenaire commercial du système source. Ce port d'échanges ne peut pas être un port d'échanges ouvert.

Afin que la configuration du système de destination fonctionne correctement, le système source du partenaire commercial doit également être correctement configuré. Pour plus d'informations sur la configuration du système source, voir Configuration du système source pour utiliser un type de transport non-HTTP.

Pour configurer le système de destination afin d'utiliser un type de transport non-HTTP, exécutez les étapes décrites dans le tableau suivant. Des références sont fournies pour chaque procédure et des remarques commentent les configurations particulières. Les autres paramètres de propriété nécessaires à la configuration varient selon les entreprises et ne sont donc pas mentionnés ici.

Étape Références et remarques
Utilisation de l'Éditeur BizTalk
  • Créez les spécifications pour les définitions de documents entrants et sortants du canal que vous utilisez pour traiter le message initial.
  • Création et validation de spécifications

    Remarque

    • Dans chacune de ces spécifications, vous devez ajouter un champ pour le chemin d'accès de la file d'attente. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système source de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
  • Créez les spécifications pour les définitions des documents entrants et sortants du canal que vous utilisez pour traiter le message de retour.
  • Création et validation de spécifications

    Remarque

    • Dans chacune de ces spécifications, vous devez ajouter un champ pour le chemin d'accès de la file d'attente. Vous pouvez ajouter ce champ à n'importe quel niveau ; toutefois, l'emplacement doit être convenu avec le partenaire commercial et doit correspondre aux spécifications existantes sur le système source de votre partenaire commercial. Pour plus d'informations, voir Gestion d'enregistrements et de champs.
Utilisation du Gestionnaire d'échanges BizTalk :
  • Créez une organisation pour représenter le partenaire commercial avec le système source.
  • Création d'organisations

    Remarque

    • Cette organisation ne nécessite pas de configuration spéciale.
  • Créez les définitions de documents nécessaires pour créer un canal qui traitera le message initial.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de documents, sélectionnez les spécifications précédemment créées. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez les définitions de documents nécessaires pour créer un canal qui traitera le message initial.
  • Création de définitions de documents

    Remarque

    • Dans les définitions de documents, sélectionnez les spécifications précédemment créées. Pour plus d'informations, voir Sélection d'une spécification de document.
  • Créez un port d'échanges dans une application pour activer une nouvelle instance de planification XLANG et transférer le message initial vers un port de cette instance de planification XLANG.
  • Création de ports d'échanges

    Remarques

    • Sur la page Application de destination de l'Assistant Port d'échanges, cliquez sur Nouvelle planification XLANG.

    • Dans la zone Planifier le moniker, tapez le moniker de la planification spécifiée ou cliquez sur Parcourir pour définir le chemin d'accès.

    • Dans la zone Nom du port, tapez le nom du port spécifique de cette planification vers laquelle le document est envoyé.

      Pour plus d'informations, voir Définition des propriétés de l'application de destination.

      Pour exécuter cette étape, le chemin d'accès d'une planification XLANG et le nom du port de cette planification, auquel le message est transmis, sont nécessaires. C'est pourquoi vous devez tout d'abord créer la planification XLANG et configurer son port, en suivant les instructions ultérieures dans ce tableau.
  • Créez un canal à partir d'une organisation pour traiter le message initial du partenaire commercial.
  • Création de canaux

    Remarque

    • Notez le nom du canal et le nom de la définition du document sortant que vous utilisez. Ces noms servent à configurer les services d'orchestration BizTalk.
  • Créez un port d'échanges pour une organisation afin de transmettre le message de retour au système source.
  • Création de ports d'échanges

    Remarques

    • Sur la page Organisation de destination de l'Assistant Port d'échanges, cliquez sur Organisation. À droite de la zone Nom, cliquez sur Parcourir.

    • Dans la boîte de dialogue Sélectionner une organisation, sélectionnez l'organisation créée précédemment pour représenter le partenaire commercial avec le système source. Pour plus d'informations, voir Sélection d'une organisation de destination.

    • Sur la page Organisation de destination de l'Assistant Port d'échanges, dans la zone Transport principal, cliquez sur Parcourir.

    • Dans la boîte de dialogue Transport principal, dans la liste Type de transport, sélectionnez le type de transport, et dans la zone Adresse, tapez une adresse.

      Le type de transport et l'adresse doivent être convenus avec le partenaire commercial et correspondre aux spécifications existantes sur le système source de votre partenaire commercial.

    • Un port d'échanges ouvert ne convient pas pour envoyer le message de retour.
  • Créez un canal à partir d'une application pour traiter le message de retour de la planification XLANG.
  • Création de canaux

    Remarques

    • Sur la page Application source de l'Assistant Canal, cliquez sur Planification XLANG. Pour plus d'informations, voir Définition des propriétés d'une application source.

    • Prenez note du nom de canal et du nom de la définition du document entrant que vous utilisez. Ces noms sont utilisés pour configurer les services d'orchestration BizTalk.
Utilisation du Concepteur d'Orchestration BizTalk
  • Utilisez une forme Échanges BizTalk afin de mettre en œuvre un port qui permette la réception du message initial.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarques

    • Sur la page Direction de la communication de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Recevoir.

    • Sur la page Informations sur l'activation de la planification XLANG de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Oui.

    Important

    • Si vous choisissez Oui, le port est configuré pour activer une nouvelle instance de planification à chaque réception d'un message. Pour plus d'informations sur l'utilisation de cette option, reportez-vous à la rubrique qui présente cette étape.

      Notez le nom affecté à ce port et l'emplacement de l'enregistrement de la planification XLANG compilée. Ces informations sont nécessaires pour configurer un port d'échanges dans les services d'échanges BizTalk, comme indiqué précédemment dans ce tableau.
  • Créez le flux de communication entre la forme Action et le port qui reçoit le message initial.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message, puis dans la zone Nom de message, entrez le nom du message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document sortant pour le canal permet de savoir plus facilement quel message vous envoyez.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document sortant du canal que vous utilisez pour traiter le message de retour.

      Tous les messages transmis depuis Échanges BizTalk vers une planification XLANG utilisent une file d'attente de messages. L'étiquette de ces messages correspond au nom de la définition du document sortant du canal.

    • Sur la page Informations sur la spécification du message, cliquez sur Parcourir et sélectionnez la spécification utilisée dans la définition du document sortant du canal qui a traité le message initial.

    • Dans la zone Champs de message, cliquez sur Ajouter, et ajouter le champ dans la spécification créée pour contenir l'adresse du chemin d'accès de la file d'attente du message initial.
  • Utilisez une forme Échanges BizTalk afin de mettre en œuvre un port qui permette l'envoi du message de retour.
  • Implémentation d'un port à l'aide d'Échanges BizTalk

    Remarques

    • Sur la page Informations sur le canal statique ou dynamique de l'Assistant Liaison d'Échanges BizTalk, cliquez sur Canal statique et, dans la zone Entrez le nom d'un canal connu pré-existant, tapez le nom du canal dans le Gestionnaire d'échanges BizTalk que vous utilisez pour traiter le message de retour.

    • Comme ce port utilise un canal statique, aucun appel de destination ouvert soumis aux Échanges BizTalk n'est effectué. C'est pourquoi le canal spécifié ne peut pas être associé à un port d'échanges ouvert.
  • Créez le flux de communication entre la forme Action et le port qui envoie le message de retour.
  • Envoi ou réception de messages asynchrones

    Remarques

    • Sur la page Informations sur le message de l'Assistant Communication XML, cliquez sur Créer un message, puis dans la zone Nom de message, entrez le nom du message.

      Vous pouvez utiliser n'importe quel nom ; toutefois, l'utilisation du nom de la définition du document entrant pour le canal permet de savoir plus facilement quel message est envoyé.

    • Dans la zone Type du message de la page Informations sur les types de messages, tapez le nom de la définition du document entrant du canal que vous utilisez pour traiter le message.

    • Sur la page Informations sur la spécification du message, cliquez sur Parcourir et sélectionnez la spécification utilisée dans la définition du document entrant du canal qui a traité le message de retour.

    • Dans la zone Champs de message, cliquez sur Ajouter, et ajouter le champ dans la spécification créée pour contenir l'adresse du chemin d'accès de la file d'attente du message de retour.
  • Créez le flux de données du champ du chemin d'accès de la file d'attente du message initial jusqu'au champ correspondant dans le message de retour.
  • Dessin de flux entre les messages

    Remarques

    • Cliquez sur l'onglet Données.

    • Sur la page Données, sélectionnez le champ du chemin d'accès de la file d'attente dans le message initial. Ensuite, faites glisser sa poignée de contrôle vers le point de connexion du champ correspondant dans le message de retour.

      Les données du champ du chemin d'accès de la file d'attente du message initial sont ainsi transférées dans le message de retour.


BizTalk Server 2002 Developer Solutions

You can programmatically integrate applications with Microsoft® BizTalk™ Server 2002 by using the BizTalk Messaging Configuration object model, or by extending and customizing the functionality of the server to suit your business and information-exchange needs. The developer solutions provide all the information necessary for Microsoft Visual Basic® and C++ developers to use or extend BizTalk Server 2002. This section also includes a complete list of interfaces, objects, enumerations, code samples, and possible error messages.

BizTalk Server 2002 supports programmatic application integration by accessing the BizTalk Messaging Configuration object model and submitting documents by calling the methods of the IInterchange interface. BizTalk Server 2002 also supports the use of extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server 3.0, Commerce Edition.

Developer Solutions is divided into the following sections:

BizTalk Messaging Services

This section provides information about how to access the BizTalk Messaging Configuration object model, including all the reference pages for the supported interfaces. This information is provided for both C++ and Visual Basic developers. For more information, see BizTalk Messaging Services.

BizTalk Documents

This section covers submitting documents to BizTalk Server 2002, using the synchronous and asynchronous methods of the IInterchange interface. It shows how to move a document after the trading partner relationships are set up, and how to track documents moving through BizTalk Server 2002. For more information, see BizTalk Documents.

BizTalk Custom Components

This section covers BizTalk Server 2002 support for extensible application integration components (AICs), including a lightweight integration model and support for the pipeline-component model available in Microsoft Site Server 3.0, Commerce Edition.

This allows developers to do the following:

  • Enable business applications to receive business documents by using AICs.

  • Extend the functionality of BizTalk Server 2002 by developing components to perform digital signatures and verification, encryption and decryption, parsing, and transport.

For more information, see BizTalk Custom Components.

BizTalk Orchestration Services

This section provides information about the interfaces that can be used to access a running instance of a specific XLANG schedule, or to perform system-wide administrative tasks in the XLANG Scheduler run-time environment. This information is provided for both C++ and Visual Basic developers. For more information, see BizTalk Orchestration Services.

BizTalk Managing and Monitoring

This section covers the Windows Management Instrumentation (WMI) classes that allow you to perform administrative functions that support the management of systems in an enterprise. This information is provided for C++, Visual Basic, and Visual Basic Scripting Edition (VBScript) developers. For more information, see BizTalk Managing and Monitoring.

BizTalk Server Developer's Toolbox

This section provides code solutions to problems commonly encountered by developers working with BizTalk Server. For more information, see BizTalk Server Developer's Toolbox.

BizTalk Server Samples

This section provides documentation and instructions for running the samples included in the BizTalk Server SDK. For more information, see BizTalk Server Samples.

BizTalk Server Reference

This section documents the BizTalk Server application programming interfaces (APIs) and error messages. For more information, see BizTalk Server Reference.


BizTalk Messaging Services

This section provides information about how to access the BizTalk Messaging Configuration object model programmatically. It shows how to manage trading partner relationships and set up messaging ports and channels for the exchange of data, using Microsoft® BizTalk™ Server 2002. This section also shows how to create document definitions and envelopes, and how to set organization properties. For additional information, see the following sections:

  • For introductory information about the BizTalk Messaging Configuration object model, see Introducing Messaging Services.

  • For general background information, see Understanding Messaging Services.

  • For information about COM interfaces, enumerations, and error messages, see the Messaging Services Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.

The BizTalk Messaging Configuration object model can also be configured by using the BizTalk Messaging Manager graphical user interface. For more information, see Using BizTalk Messaging Manager.


Introducing Messaging Services

The BizTalk Messaging Configuration object model provides an easy way for applications to set up, maintain, and retrieve messaging ports and channels for trading partner relationships and application-to-application integration. The BizTalk Messaging Configuration object model can also create envelopes and document definitions, and set organization properties.

The BizTalk Messaging Configuration object model uses a Structured Query Language (SQL) database to store the port configurations and other relational data. ActiveX® Data Objects (ADO) recordsets are returned when querying for lists of object instances (for example, messaging ports or organizations).

The BizTalk Messaging Configuration object model consists of Component Object Model (COM) objects that expose the configuration data required for Microsoft BizTalk Server 2002 to configure the interchange of structured documents between applications and trading partners. The COM objects represent instances of data in memory that can be stored in the database.

All object properties are read/write, except where noted.

Related Topics

Messaging Configuration Objects

Referential Integrity

Security


Messaging Configuration Objects

The following table shows the objects of the BizTalk Messaging Configuration object model.

Object | Description
IBizTalkChannel | Contains the configuration related to the source entity and its binding with an IBizTalkPort object.
IBizTalkConfig | Creates and retrieves other BizTalk objects, such as channels, document specifications, and messaging ports.
IBizTalkDocument | Identifies and describes the specification of a document.
IBizTalkEnvelope | Identifies the envelope format and/or the envelope schema used for documents. Envelopes are required for documents using the X12 or EDIFACT format.
IBizTalkOrganization | Identifies the source or destination point for the exchange of electronic data. An organization can represent an external trading partner, your own company, or a business unit of a trading partner or your company. An organization can designate a source application in a channel or a destination application in a port.
IBizTalkPort | Defines the destination-related attributes of a document submission.
IBizTalkPortGroup | Configures a port group. This is a group of complete IBizTalkPort objects for sending the same document, such as a catalog, a price list, or a newsletter, to a group of trading partners.

Caution

  • Do not access the database directly. Do not directly call the stored procedures. Make all changes to the database by using the methods and properties of the BizTalk Messaging Configuration object model. Making changes to the database directly bypasses many constraints enforced by the BizTalk Messaging Configuration object model and either causes the server to function incorrectly or corrupts the database.

  • The BizTalk Messaging Configuration object model should be accessed only at design time. Accessing objects in use while BizTalk Server is processing documents can produce unexpected results.

  • BizTalk Server 2002 treats all variables with a BSTR data type as NULL-terminated strings. Any data contained in a BSTR after the NULL character is ignored. Documents containing embedded NULL characters must be submitted to BizTalk Server by using pass-through mode.

Related Topics

Channels

Document Definitions

Envelopes

Messaging Ports

Organizations


Referential Integrity

Referential dependency must be considered when instantiating objects in BizTalk Server 2002. Referential dependency indicates that one object refers to, and is dependent upon, another object. For example, an IBizTalkChannel object refers to an IBizTalkPort object.

To maintain referential integrity, an object instance cannot be deleted if it is referred to by another object instance. Referential integrity is maintained when the object that is referred to exists in the database.

Remove objects from the database in the reverse order of their creation. If an object instance that is referred to by another object instance is removed, a constraint error is returned. Using the preceding example, a constraint error is returned if an IBizTalkPort object that is being used by an IBizTalkChannel object is removed.

The following sequence shows the preferred order for creating objects to maintain the referential integrity of the objects:

  1. IBizTalkOrganization

  2. IBizTalkDocument

  3. IBizTalkEnvelope (if required)

  4. IBizTalkPort
    • The IBizTalkPort object requires the IBizTalkOrganization object.

    • The IBizTalkPort object conditionally uses the IBizTalkEnvelope object.
  5. IBizTalkChannel
    • The IBizTalkChannel object requires the IBizTalkPort object.

    • The IBizTalkChannel object requires the IBizTalkDocument object.

    • The IBizTalkChannel object requires the IBizTalkOrganization object.

    • The IBizTalkChannel object conditionally uses the IBizTalkPortGroup object if the channel is created for port groups.
  6. IBizTalkPortGroup (if used)
    • The IBizTalkPortGroup object requires the IBizTalkPort object.


Security

When accessing or creating objects in the BizTalk Messaging Configuration object model, the script or application must be run in the context of a user account in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2002 is installed. Additional users can be added to this group as necessary. For additional information, see Add users to the BizTalk Server Administrators group.


Understanding Messaging Services

This section provides detailed conceptual information that is important to understanding how to access the BizTalk Messaging Configuration object model. The following topics are covered in this section:

  • Channels

  • Messaging Ports

  • Openness

  • Organizations

  • Document Definitions

  • Envelopes

  • Certificates

For information about code samples that use the BizTalk Messaging Configuration object model, see BizTalk Messaging Services Code Samples.


Channels

The IBizTalkChannel object contains the configuration information related to the source entity and its binding with an IBizTalkPort object. When BizTalk Server 2002 receives a document, a specific IBizTalkChannel object, along with the properties configured in its associated IBizTalkPort object or an associated IBizTalkPort object within an IBizTalkPortGroup, directs the server through the steps necessary to process that document. Note that multiple channels might be bound to the same IBizTalkPort object. This represents multiple source entities that exchange documents with the same destination.

The IBizTalkChannel object identifies the map used for document transformation if the type of the input IBizTalkDocument object is different from the type of the output IBizTalkDocument object. It also points to the specification that contains fields for BizTalk document tracking and selects the type of logging desired.

The following topics are covered in this section:

  • Identification

  • Document Processing

  • Configuring

  • Channel Filtering

  • Document Storage

  • Document Tracking


Identification

BizTalk Server 2002 determines the appropriate IBizTalkChannel object for processing the input document by one of the following methods:

  • The source organization identifier, qualifier, and value; the destination organization identifier, qualifier, and value; and the name of the IBizTalkDocument object are parameters of the Submit or the SubmitSync method of the IInterchange object.

  • The source and destination organization identifiers, qualifiers, and values; and the name of the IBizTalkDocument object are specified in the header fields of the document instance.

  • The name of the IBizTalkChannel object is a parameter of the Submit or the SubmitSync method call.

When BizTalk Server 2002 receives a document, it first identifies all IBizTalkChannel objects that support the specified IBizTalkDocument object. The server then looks up each IBizTalkPort object and determines if the source organization and destination organization properties identify the source and destination IBizTalkOrganization objects specified by the organization identifiers in the document or in the parameters of Submit when the document is submitted. This includes any open messaging ports that match either the specified source organization or the destination organization.

This identification process can be bypassed by specifying the name of an IBizTalkChannel object to be used as a parameter of Submit or SubmitSync.

Related Topic

Submitting


Document Processing

When BizTalk Server 2002 identifies an IBizTalkChannel object, the server processes this object, which directs the server in the steps to process the document. To direct the server, the IBizTalkChannel object follows its own rules and the rules of its associated IBizTalkPort object.

An input IBizTalkDocument object is related to an output IBizTalkDocument object by an IBizTalkChannel object. The IBizTalkPort object must be created before an associated IBizTalkChannel object can be created.

When BizTalk Server 2002 processes an IBizTalkChannel object, the server calls upon each associated IBizTalkPort object to provide the document-processing rules needed by the server. The rules set by the properties of the IBizTalkChannel object direct the server in the initial steps of document processing, such as determining which input and output IBizTalkDocument objects to use, which map file to use, and what fields to track. After a document is in its final output format, the properties of the IBizTalkPort object direct the server in the steps to prepare and transport the document according to the rules agreed to by the source and destination organizations.

When a document is submitted, the server can identify multiple IBizTalkPort and IBizTalkChannel objects that match the source organization, the destination organization, and the specified IBizTalkDocument object. Therefore, it is possible for one input document to generate multiple output documents. It is also possible for each output document to be transmitted to a different location by using different transport properties in the matching IBizTalkPort objects, and for each output document instance to include a different subset of data from the original input document by using different map files.


Configuring

An IBizTalkChannel object consists of the internal document processing data for the specified input and output IBizTalkDocument objects. To be fully configured, an IBizTalkChannel object must have one complete IBizTalkPort object identified by its Port property. Input and output IBizTalkDocument objects must be specified. After the InputDocument and OutputDocument properties are selected for use in this IBizTalkChannel object, an IBizTalkPort object or an IBizTalkPortGroup object must be selected.

The name of an IBizTalkChannel object must be unique across the database for all objects of its type.

The following properties are required before an IBizTalkChannel object can be saved:

  • InputDocument

  • Port (or PortGroup)

  • OutputDocument

  • Name

After an IBizTalkChannel object has been created or saved, only the following properties can be changed:

  • Comments

  • ControlNumberValue

  • MapReference

  • Name

  • TrackFields


Channel Filtering

Channel filtering enables the user to build a filtering expression to select an IBizTalkChannel object for processing a document instance. The server uses these expressions to select the correct IBizTalkChannel object. The Expression property contains an XPath expression that evaluates to a Boolean value. If the expression evaluates to true, the channel is used to process the document. Otherwise, the channel is not invoked to process the document.

XPath expressions can be used to obtain the value of a specific element, attribute, or collection of these items within an XML document. Consider the following XML document:

<INVOICE>

<DATE>12/31/2000</DATE>

<BILLTO>Blue Yonder Airlines</BILLTO>

<SUMMARY>

<ITEM PARTNUMBER="10001" QUANTITY="10"/>

<ITEM PARTNUMBER="20002" QUANTITY="20"/>

<TOTAL VALUE="550"/>

</SUMMARY>

</INVOICE>

Based on this document, the following XPath expression can be created to ensure that this channel only processes invoices that exceed $500:

myChannel.Expression = "/INVOICE/SUMMARY/TOTAL[@VALUE>""500""]"

In this example, the channel would process the XML document instance because the total is greater than $500. For more information about XPath expressions, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Note

  • You can use BizTalk Messaging Manager to generate XPath channel filtering expressions. For more information, see Add a channel filtering expression.


Document Storage

You can choose how to log the activity of a document instance by using the IBizTalkLoggingInfo object. The default is to log the document in its native form.

For document storage, you have the options shown in the following table.

Property | Description
All properties empty | Store no copies of the document.
LogNativeInputDocument | Store input native format (default setting).
LogNativeOutputDocument | Store output native format.
LogXMLInputDocument | Store input XML format.
LogXMLOutputDocument | Store output interim (XML) format.
Any combination of these choices | Store the options as described above.

Note

  • There is a size limit for interchanges and documents that use logging, which if exceeded greatly affects the performance of BizTalk Server. For more information about the size limit, see Interchange and document size limit.


Document Tracking

An IBizTalkChannel object points to the specification that contains fields to track the instance of the document. The designated fields are logged to the Tracking database for each instance of a document that is processed. When you assign an input IBizTalkDocument object for an IBizTalkChannel object, you can designate fields to track within the document on this channel.

When BizTalk Server 2002 runs an IBizTalkChannel object, it uses the input IBizTalkDocument object to process an input document. The fields that you have designated for tracking are captured and logged for each instance of that document. Any fields designated for tracking in the output IBizTalkDocument object of the associated IBizTalkChannel object are ignored. To retrieve the information that is tracked during document processing, use the methods of the IBizTalkTrackData object.

By logging important data from the input documents that are processed, you can track and analyze detailed information about your operation. For example, an invoice-total field can be logged for every invoice that is sent to your trading partners. You can then determine the total dollar amount of invoices sent to all trading partners over time or determine the total dollar amount of invoices to each individual trading partner.

For additional information about document tracking, see Understanding the Tracking Database Schema.


Messaging Ports

Conceptually, a messaging port is a set of rules that trading partner organizations accept for sending documents to one another. It includes information regarding the destination, transport type, security, and envelope. It identifies the source and destination IBizTalkOrganization objects and the source and destination aliases. It also identifies any applications associated with the organization, if applicable.

An IBizTalkPort object identifies a specific destination organization unless it is designated as an open messaging port, in which case the destination organization is not specified. For open messaging ports, the IBizTalkPort object is valid only if the associated document or the parameters on the Submit or the SubmitSync method of the IInterchange object contain the destination transport and address information.

The IBizTalkPort object also identifies delimiter definitions and the EDI interchange control number. Delimiters are used to separate the records and fields of the envelope and the documents within the envelope. An interchange control number is used to identify and track documents that are sent using the envelope. The interchange control number is incremented with each use of the envelope at run time.

An IBizTalkPort object also identifies the encoding, encryption, and signature type, if required.

Note

  • After an IBizTalkPort object has been created and saved, the destination organization and the openness associated with the endpoint cannot be changed.

Related Topics

Openness

Port Groups


Port Groups

The IBizTalkPortGroup object configures a group of complete IBizTalkPort objects for sending the same document to a group of trading partners. For example, you can use this when you want to send a document, such as a catalog, a price list, or a newsletter, that contains identical data to a group of trading partners. One document is sent to a list of partners by calling a single Submit method on the IInterchange object.

The IBizTalkPortGroup object must contain at least one IBizTalkPort object. You can add or remove IBizTalkPort objects to or from an IBizTalkPortGroup by calling the AddPort or the RemovePort method.

An IBizTalkPortGroup object must be associated with at least one IBizTalkChannel object. After the port group has been created, associate a channel with the port group by using the PortGroup property available on the IBizTalkChannel object. When BizTalk Server 2002 invokes a channel related to a port group, it invokes only the channel that is associated with the port group to process the data. None of the channels that are associated with the individual ports in the port group are invoked. The server uses the properties of each port successively to transport the data to the destinations specified in the ports.

Notes

  • Open messaging ports cannot be added to a port group.

  • BizTalk Messaging Manager refers to port groups as distribution lists.

Related Topic

Submitting


Openness

The Openness property of the IBizTalkEndPoint object determines whether the messaging port or channel is open. An open IBizTalkPort object is a messaging port without a specified destination. An open IBizTalkChannel object is a channel without a specified source. The missing information for an open messaging port or channel must be supplied by the associated document or by the parameters on the Submit or the SubmitSync method of the IInterchange object.

If an open channel is specified by using BIZTALK_OPENNESS_TYPE_EX_SOURCE or an open messaging port is specified by using BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Usage, Reference, and Store properties cannot be specified on the IBizTalkCertificateInfo object.

Note

  • If an open messaging port is used with the SMTP transport type, the value specified for the IBizTalkOrganization identifier Reliable Messaging Acknowledgement SMTP From Address is used as the From address.

Related Topic

Submitting


Organizations

IBizTalkOrganization objects serve as sources or destinations for the exchange of electronic data. An organization can represent an external trading partner, your own company, or a business unit of a trading partner or your company. The home organization can designate a source application in a channel or a destination application in a messaging port.

Applications are properties of the home organization. An applications can be designated as a source application in an IBizTalkChannel object or as a destination application in an IBizTalkPort object.

Aliases

An alias is an organization identifier for the IBizTalkOrganization object. An IBizTalkOrganization object must always have one and only one default alias, but it can have multiple aliases. An alias is autogenerated for each IBizTalkOrganization object. The default alias and the autogenerated alias cannot be removed.

For more information, see Create and Manage Organizations.


Document Definitions

The IBizTalkDocument object describes and identifies the document specification used to describe the document sent or received. The document specification defines the structure of a document, as well as any validation rules and descriptions for the individual elements of the document specification. The IBizTalkDocument object includes the version and type of the specification and, optionally, a reference to the Web Distributed Authoring and Versioning (WebDAV) location of the specification. For more information about document specifications, see Create and Validate Specifications.

Notes

  • The document Content and NameSpace properties are not valid until you set the Reference property.

  • When creating a new IBizTalkDocument object that uses a namespace that is already registered with BizTalk Server, the new document inherits the Reference property of that namespace. The namespace must be unique (case insensitive) for a new Reference to be created.

The IBizTalkDocument object also contains the electronic data interchange (EDI) selection criteria by which BizTalk Server 2002 extracts information from the functional group header of the document to identify this object when the name of the IBizTalkDocument object is not available.

An IBizTalkDocument object points to the specification that contains fields to track the instance of the document. The designated fields are logged to the Tracking database for each document that is processed.

Selection criteria

For some EDI input interchanges, documents are contained within functional group envelopes. When BizTalk Server 2002 processes such documents, it cannot obtain the name of the IBizTalkDocument object from a field within each document. Also, because there are multiple types of documents involved, a single name cannot be specified as a parameter of the Submit method of the IInterchange object. In such cases, the server can locate document-related data within the functional group header (for example, in the GS header of an X12 interchange). By comparing this data to matching selection criteria specified in the PropertySet property on the IBizTalkDocument object, the server can uniquely identify an IBizTalkDocument object. After the IBizTalkDocument object is identified, the server can obtain the name and then identify and instantiate the appropriate IBizTalkChannel object.

Selection criteria also help BizTalk Server 2002 create the header of the EDI document when it is output.

Global tracking

An IBizTalkDocument object points to the specification from which fields can be selected for tracking. The designated fields in the input document specification are tracked for each document that is processed using that specification. Any fields designated for tracking in the output document specification are ignored. If an IBizTalkChannel object that specifies tracking fields is used with an input document specification containing fields designated for tracking, only the fields specified by the channel are used for tracking.

By logging important data from the input documents that are processed, you can track and analyze detailed information about your operation. For example, an invoice-total field can be logged for every invoice that is sent to your trading partners. You can then determine the total dollar amount of invoices sent to all trading partners over time or determine the total dollar amount of invoices to each individual trading partner.

Related Topics

Document Storage

Document Tracking


Envelopes

The IBizTalkEnvelope object consists of two pieces of information:

  • The type of envelope is specified in the Format property. The document Type should match the envelope Format for "flatfile", "custom xml", "x12", "edifact", and "reliable" document types.

  • The actual envelope file used is specified in the Reference property.

Input document envelopes

An envelope is required if the input document Type is "flatfile" because the envelope contains information about how to parse the document into XML and which parser should process the document. Input "flatfile" documents without an envelope are not processed. For all other input document types, an envelope is optional.

Output document envelopes

Envelopes are used to wrap an output document instance that has been transformed into the native format. The envelope used with an output document is specified on the IBizTalkPort object. An envelope is required if the output document Type is "x12" or "edifact". However, the Reference property is ignored for these format types because indicating that a document is X12 or EDIFACT is sufficient to serialize the document. For output documents with a Type of "custom xml", the Reference property is used if specified. If the Reference property is not specified, "custom xml" documents are submitted for processing in the transformed XML format.

Notes

  • Multiple IBizTalkPort objects can refer to an envelope.

  • The envelope Content and NameSpace properties are not valid until you set the Reference property.

  • When creating a new IBizTalkEnvelope object that uses a namespace that is already registered with BizTalk Server, the new document inherits the Reference property of that namespace. The namespace must be unique (case insensitive) for a new Reference to be created.


Certificates

An IBizTalkCertificateInfo object is automatically created when an IBizTalkPort or an IBizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the IBizTalkConfig object.

For output documents, access the IBizTalkCertificateInfo object by using the EncryptionCertificateInfo property of the IBizTalkPort object. For input documents, access the IBizTalkCertificateInfo object by using the SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo property of the IBizTalkChannel object. To obtain the set of all existing IBizTalkCertificateInfo objects, use the Certificates property of the IBizTalkConfig object.

Note

  • All certificates are stored in the local computer store. To configure certificates for the S/MIME components, the script or application accessing the object model must be run in the context of a user account in the BizTalk Server Administrators group.


BizTalk Documents

This section provides information about how to submit documents to Microsoft BizTalk Server 2002. For additional information, see the following sections:

  • For help with specific tasks, see Using Documents.

  • For general background information, see Understanding Documents.

  • For information about COM interfaces and enumerations, see the Documents Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.


Understanding Documents

This section provides detailed conceptual information that is important to understanding how to submit documents to Microsoft® BizTalk™ Server 2002. The following topics are covered in this section:

  • Submitting

  • Routing


Submitting

All documents must be sent to Microsoft BizTalk Server 2002 by using the Submit or SubmitSync method of the IInterchange interface in order to be processed. If an application is based on Microsoft Windows® and is capable of invoking methods on COM objects, it can submit a document directly. The business application calls the Submit or SubmitSync method of the IInterchange interface, passing in the document or the file path of the document as a string supplied as a parameter. This is the simplest approach because no additional configuration is necessary. However, this method requires that the business application be designed to support direct calls to BizTalk Server 2002.

If the application is not capable of invoking methods on COM objects, receive functions can be used to submit documents to BizTalk Server. Receive functions enable applications to post documents or interchanges to specific locations that BizTalk Server 2002 is monitoring. These locations are defined according to the specific receive function. Each receive function uses event-based monitoring to recognize the presence of a document or interchange. After the data is received by the function, it submits the data to BizTalk Server. For example, a File receive function can be configured to submit a document to BizTalk Server when the business application can save a document as a file but cannot submit it directly. For more information about adding and configuring receive functions, see Manage Receive Functions for a Server Group.

The receive functions are configured to continuously monitor a specific directory or queue for a file to appear and then be submitted to BizTalk Server. HTTP and SMTP protocols are configured outside BizTalk Server. You must create script pages for these transport services.

Notes

  • There is a size limit for interchanges and documents that use logging, which, if exceeded, greatly affects the performance of BizTalk Server. For more information about the size limit, see Interchange and document size limit.

  • A script or application that uses the IInterchange interface to submit documents to BizTalk Server can be run in any user account.

  • When processing envelopes that are compliant with BizTalk Framework 2.0, BizTalk Server should be considered the endpoint with regard to the expiration time. When BizTalk Framework 2.0-compliant documents are submitted to BizTalk Server, either from an application or from a trading partner, the following fields are overwritten if present, or created if absent:
    • In the properties subsection:

      <prop:identity>

      <prop:sentAt>

      <expiresAt>

    • In the receipt information subsection:

      <sendTo>

      <address>

      <sendReceiptBy>

For examples of code, see BizTalk Messaging Services Code Samples.

Sending documents to BizTalk Server 2002 asynchronously

Applications that submit documents asynchronously to BizTalk Server call Submit. Receive functions also call Submit. Submit returns after sending the document. No response document is returned, because the protocol does not support it.

Submit accepts only a string buffer or a file path as the document or interchange. BizTalk Server supports Universal Naming Convention (UNC) and local file path formats.

Sending documents to BizTalk Server 2002 synchronously

Applications that submit documents synchronously to BizTalk Server call SubmitSync.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols, an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

SubmitSync accepts only a string buffer or a file path as the document or interchange. BizTalk Server supports UNC and local file path formats.

Error handling with the Submit and SubmitSync methods

When an error occurs when submitting interchanges or documents to BizTalk Server, an event log entry is created and/or an error is returned to the caller, depending on which method is called and the nature of the failure. Documents submitted can end up in the Suspended queue due to a number of possible conditions. The following table describes what happens when one or more of the documents or interchanges submitted are placed in the Suspended queue due to an error during submission.

Method called | Error returned to caller | Event log entry
Submit | Document failure error | For every document that fails in processing
SubmitSync | Document failure error | None

Related Topics

Routing

Submitting a Document

Documents Reference


Routing

To process a document, Microsoft BizTalk Server 2002 must load the rules that govern how the incoming document instance is to be processed. These rules are known as the channel. A specific IBizTalkChannel object is associated with an IBizTalkPort object and connects two organizations.

To find the channel to process the received document, the server must have the source organization, the destination organization, and the document definition. The server can obtain this information by one of the following methods:

  • This information can be found in the content of the document itself from the data contained in the routing fields (self-routing documents).

  • This information can be explicitly declared in the parameter list of the Submit method of the IInterchange interface (call-based routing).

  • This information can be explicitly declared in the properties of a custom receive function. For more information about receive functions, see Understanding Receive Functions and Document Routing.

  • You can choose to specify the channel to use when calling Submit. This causes the server to bypass the channel selection process.

After the server has this information, it searches for the messaging port/channel pair that matches these routing criteria. If more than one channel matches, each of the channels is processed, possibly resulting in multiple output documents.

Call-based routing

In call-based routing, the source organization identifier (SourceID), the destination organization identifier (DestID), and the name of the document definition (DocName) are specified as parameters of Submit. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. If the Openness flag is set to OpenDest, the DestID is used as the destination address. If SourceID, DestID, or DocName is left blank, the missing information must be provided by the routing information contained within the document. If one of these parameters/fields is not in Submit or in the document, the document goes to the Suspended queue.

Note

  • Note that the queue:// prefix must be used with an open messaging port when a message queue is specified as the destination address.

Self-routing documents

Self-routing documents have the source organization identifier (SourceID), the destination organization identifier (DestID), and the name of the document definition (DocName) defined in the routing tags defined by the document specification, which are contained within the <SelectionFields> tag. If SourceQualifier and DestQualifier are not specified, they default to OrganizationName and refer to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The BizTalk Framework specification also defines the routing tags for BizTalk Framework–compliant messages. These tags are defined as the <to> and <from> tags under the <endpoint> tag, which is contained in the <header> tag under the root <biztalk> tag. The first tag under the <body> tag determines the document type. For more information, see the BizTalk Framework 2.0 Independent Document Messaging Specification. For X12 or EDIFACT routing, the locations of the routing fields are hard-coded and are not specified in a document specification.


Using Documents

This section provides task-specific information about how to submit documents to Microsoft BizTalk Server 2002. It is highly recommended that you review the Understanding Documents topic as well.

The following topics are covered in this section:

  • Submitting a Document

  • Submitting a Document from a Remote Client

  • Reading the Tracking Database

  • Preprocessing Documents in a Receive Function

  • Accessing the Suspended Queue


Submitting a Document

Use the following steps as a guideline when submitting documents to Microsoft BizTalk Server 2002 with the IInterchange interface.

  1. Determine whether the source organization, destination organization, and document definition name are in the parameters of the Submit or the SubmitSync method of the IInterchange interface or are included in the document; it might be a combination of the two.
    • This information can be explicitly declared in the parameter list of Submit or SubmitSync (call-based routing).

      One or more of these parameters can be left blank and the missing information can be provided by the routing information contained within the document.

    • This information can be found in the content of the document itself from the data in the routing fields (self-routing documents).

    • The user can choose to explicitly call out the specific channel to use when calling Submit. This causes the server to bypass channel selection.

    • This information can be explicitly declared in the properties of a custom receive function.
  2. Decide whether to submit asynchronously or synchronously.
    • Call Submit, passing in the document or the file path of the document as a string supplied as a parameter. BizTalk Server supports URL, UNC, and drive: format for the file path.

      Submit accepts only a string variable as the document or interchange.

    • Call SubmitSync, passing in the document or the file path of the document as a string supplied as a parameter.
      • A response document is returned to the user, if available.

      • This method is valid only for a single channel match.

      • This method can be used only for single-document interchanges.
  3. Decide whether to call some of the Suspended queue methods. (This is optional and can be implemented in the same application or in a different application.)
    • Call the CheckSuspendedQueue method of the IInterchange interface.
      • Retrieve items from the Suspended queue.

      • This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.
    • Call GetSuspendedQueueItemDetails.

      Retrieve the details about a particular item in the Suspended queue.

    • Call DeleteFromSuspendedQueue.

      Remove items from the Suspended queue.


Submitting a Document from a Remote Client

A document can be submitted to Microsoft BizTalk Server 2002 from a remote client running an application that uses the IInterchange interface. To accomplish this, follow these steps:

  1. Using a computer that has Microsoft BizTalk Server 2002 installed, go to the Start menu, point to Programs, point to Administrative Tools, and then click Component Services.

  2. In the tree pane, click Component Services, expand Computers, expand My Computer, expand COM+ Applications, and then click BizTalk Server Interchange Application.

  3. On the Action menu, click Export.

  4. In the Welcome to the COM Application Export Wizard dialog box, enter the name of an export installation package to be created.

  5. In the Export as area, click the Application proxy option and click Next to finish the wizard.

The COM Application Export Wizard creates a Windows Installer Package file with an .msi extension and its associated cabinet file with a .cab extension. Copy these files to the remote client and run the Windows Installer Package file. Now the remote client can run applications that use the IInterchange interface.

Notes

  • The remote client must be running Microsoft Windows 2000.

  • The computer used to create the installation package acts as an "interchange server" for the remote client that is submitting documents. Therefore, all documents submitted on the remote client are routed through that server.

  • You can also create a remote client during the BizTalk Server 2002 installation.


Reading the Tracking Database

The purpose of the tracking interface, IBizTalkTrackData, is to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2002. This complements the IInterchange interface so that returns from IInterchange calls can be fed to the IBizTalkTrackData methods to access data about the activity of documents submitted to BizTalk Server 2002.

There can be a one-to-one or a one-to-many relationship between input and output documents. In a normal document flow, one document is submitted to the server, is tracked and possibly transformed, and one document results as output from the server. However, the messaging port can be configured so that one document submitted can result in many documents as output to several destinations.

To read and use information from the Tracking database, perform the following steps:

  1. Get the SubmissionHandle return from the Submit method of the IInterchange interface.

  2. Call the GetInterchanges method, using the SubmissionHandle return as the input. This method returns a list of interchanges contained in that submission, including all the data from the Tracking database. Because transport-specific information (delivery times, receipt flags, and so on) appears in the interchange data, you can look here to confirm or check status on delivery, for example.

  3. Call the GetInDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were included in that submission. You can look here to find information about an input document (whether a document was valid, how many bytes it contained, and so on).

  4. Call the GetOutDocDetails method, using the SubmissionHandle return as the input. This method returns a list of the documents that were generated as a result of the submission. You can look here to find information about an output document (for example, looking for PO #123456 from a submission made earlier today).

Related Topic

Documents Reference


Preprocessing Documents in a Receive Function

Documents can be submitted to Microsoft BizTalk Server 2002 for processing by using a receive function. Using this mechanism, other applications can send their output files to a specified directory or message queue. BizTalk Server continually monitors the specified location at regular intervals and processes the files or messages placed in that location. BizTalk Server provides interfaces that allow you to create custom preprocessing components. These components process the file or message picked up by the receive function prior to submitting the data to BizTalk Server for processing.

A custom preprocessor component is required to implement the category identifier (CATID) CATID_BIZTALK_CUSTOM_PROCESS in the registry. This allows the BizTalk Server Administration user interface, or administration console, to recognize the custom preprocessor and display it in the Preprocessor list, where it can be selected.

For additional information, see IBTSCustomProcess and IBTSCustomProcessContext.

Transaction Support

If a preprocessing component supports transactions, you must explicitly enable transaction support for that component. To enable transactions with custom preprocessor components, add a registry key by following these steps:

  1. Open the registry editor.

  2. Find the custom component in the registry.

  3. Right-click the component.

  4. Click New and then click DWORD Value.

  5. In the Name field, type UseTxForCustPreProcessor.

  6. Double-click the new UseTxForCustPreProcessor key.

    The Edit DWORD Value dialog box appears.

  7. In the Value data field, type 1.

  8. Click OK.

Related Topics

BizTalk Server Administration User Interface

Receive Functions


Accessing the Suspended Queue

The Suspended queue contains work items that have failed processing for a variety of reasons, including parsing errors, serialization errors, failed transmissions, or the inability to find a channel configuration. You can retrieve or delete items from the queue using the interfaces provided.

Note

  • When accessing or deleting items in the Suspended queue, the script or application must be run in the context of a user account in the BizTalk Server Administrators group. The BizTalk Server Administrators group is created when BizTalk Server 2002 is installed. Additional users can be added to this group as necessary.

Retrieving items from the Suspended queue

To retrieve items from the Suspended queue, applications call the CheckSuspendedQueue method of the IInterchange interface.

CheckSuspendedQueue retrieves a list of items in the Suspended queue that meet the search criteria specified by the parameters of the method. This returns a list of handles that can subsequently be used to call the DeleteFromSuspendedQueue or the GetSuspendedQueueItemDetails method of the IInterchange interface.

Getting item details from the Suspended queue

CheckSuspendedQueue returns a list of handles to items in the Suspended queue. To process these items, you must get the item details associated with each item in the Suspended queue by using GetSuspendedQueueItemDetails.

GetSuspendedQueueItemDetails retrieves the details about an item in the Suspended queue. If this method does not return individual details about this item (because the item has been removed between the time CheckSuspendedQueue was called and the call to this method, for example), each parameter that cannot be determined is returned.

Removing items from the Suspended queue

To remove items from the Suspended queue, applications call DeleteFromSuspendedQueue.

DeleteFromSuspendedQueue removes from the Suspended queue a list of items that meet the search criteria specified by the parameters of the method.


BizTalk Custom Components

This section provides information about how to create custom components and extend Microsoft® BizTalk™ Server 2002 to integrate line-of-business applications and to add features such as encryption and decryption or digital signature. With this information, you can do the following:

  • Create application integration components (AICs) that enable your applications to receive business documents by using BizTalk Server 2002.

  • Extend the functionality of BizTalk Server 2002 by developing custom components to perform digital signature, encryption and decryption, parsing, serializing, and transport of documents.

For additional information, see the following sections:

  • For help with specific tasks, see Using Custom Components.

  • For general background information, see Understanding Custom Components.

  • For information about COM interfaces, see Custom Components Reference.

  • For examples of code, see BizTalk Messaging Services Code Samples.


Understanding Custom Components

This section provides detailed conceptual information that is important to understanding how to extend Microsoft® BizTalk™ Server 2002. BizTalk Server 2002 can perform data transformation, digital signature, encryption and decryption, parsing, serializing, and transport of documents. In addition, you can create your own application integration components (AICs) to extend the capabilities of BizTalk Server 2002.

The following topics are covered:

  • Custom Component Types

  • Application Integration Components

  • Parsers

  • Serializers


Custom Component Types

Custom components can be created for application integration (AICs), encryption, encoding, signing, parsing, and serializing. The following interfaces must be implemented for each component type:

Component types | Interfaces to be implemented
Pipeline components:

AIC
Encryption
Encoding
Signing

 IPipelineComponent, IPipelineComponentAdmin
AIC (lightweight) | IBTSAppIntegration
Parsing IBizTalkParserComponent

By default, BizTalk Server registers the following parser components, listed by ProgID:

  • Edifact: BizTalk.ParserEdifact

  • Flat File: BizTalk.ParserFFile

  • X12: BizTalk.ParserX12

  • XML: BizTalk.ParserXML
Serializing IBizTalkSerializerComponent, IPipelineComponentAdmin (optional)

By default, BizTalk Server registers the following serializer components, listed by ProgID:

  • Edifact: BizTalk.SerializerEdifact

  • Flat File: BizTalk. SerializerFFile

  • X12: BizTalk. SerializerX12

  • XML: BizTalk. SerializerXML


Application Integration Components

When creating an application integration component (AIC), you can implement either the pipeline model using the IPipelineComponent interface or the lightweight model using the IBTSAppIntegration interface.

Application integration components are COM objects that the BizTalk Server state engine calls to deliver data to an application. If a messaging port is configured in BizTalk Server 2002 to include the use of an AIC for application integration, this component is automatically instantiated and passed the requisite data. The component then determines how to handle communicating this data back to the application. This can be done using private API calls, invoking other COM objects, using database writes, and so on.

This section contains the following topics:

  • Pipeline Application Integration Components

  • Lightweight Application Integration Components

By default, AICs run in the LocalSystem account. If another security context is required, set it as part of the implementation of the AIC. However, if an AIC is installed as a COM+ application, an administrator can configure security of the AIC by using the Component Services console.

When developing an AIC using Microsoft Visual Basic®, ensure that all Visual Basic components set the Unattended Execution and Retain in Memory project settings.

Related Topic

Registering Custom Components


Pipeline Application Integration Components

One approach for application integration with BizTalk Server 2002 is the creation of a pipeline component. This is the same model used in Microsoft Site Server 3.0 Commerce Edition for application integration with the Commerce Interchange pipeline (CIP) and the Order Processing pipeline (OPP). BizTalk Server 2002 supports this method so that pipeline components written for application integration for CIP and OPP are compatible. This is also a useful technique when the component requires configuration properties.

The primary entry point for a pipeline component is the Execute method of the IPipelineComponent interface. This is the method that BizTalk Server 2002 calls to transfer control and to pass the data to the component. It is in the implementation of this method that the component does its work.

Related Topics

Lightweight Application Integration Components


Lightweight Application Integration Components

BizTalk Server 2002 supports an additional model for application developers who want a lighter-weight model for application integration, one that does not support a design-time user interface or configuration properties. This model requires a single interface that contains a single method as an entry point. The component is implemented, and the document is passed to it through the ProcessMessage method of the IBTSAppIntegration interface.

IBTSAppIntegration is for applications that do not need properties for their component and need only an entry point for receiving a document. This is a simpler approach to application integration than pipeline components. BizTalk Server 2002 queries for this interface first. If it does not find this interface implemented, it queries for the pipeline component interfaces.


Parsers

The parser has two responsibilities:

  • Convert the documents to XML for later processing.

  • Get the parameters necessary to select the channel (these are the source qualifier, source identifier, destination qualifier, destination identifier, and document definition name). These returned fields are combined with the parameters of the Submit method of the IInterchange interface to select the channels necessary to process the documents.

This interface gets information from the component for one interchange. If the incoming data stream represents multiple interchanges, the server selects the component at every interchange boundary. This simplifies construction of a component because it deals with only one interchange at a time. There is one component instance per thread. No single object needs to be safe for multiple threads. This interface is supported only in C++.

If the ProbeInterchangeFormat method of the IBizTalkParserComponent interface returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

Related Topics

Registering Custom Components

Working with Parsers


Serializers

The serializer converts the document from XML back to its native format. This interface is intended to work on a single interchange and is designed to get information from the component for one interchange. This simplifies the construction of this component because it has to deal with only one interchange at a time. There is only one instance per thread. No single object needs to be safe for multiple threads. The IBizTalkSerializerComponent interface is supported only in C++.

Related Topics

Registering Custom Components

Working with Serializers


Using Custom Components

This section provides task-specific information about how to create server components. It is highly recommended that you review the Understanding Custom Components topic as well.

The following topics are covered:

  • Creating Pipeline Components

  • Creating Receipt Correlator Components

  • Working with Parsers

  • Working with Serializers

  • Registering Custom Components

  • Handling Data Passed to AICs

  • Supporting the Tracking Database with Parser and Serializer Components


Creating Pipeline Components

Use the following steps to create a pipeline component:

  1. Create an Active Template Library (ATL) wizard–generated Inproc server project.

  2. Add a simple COM object.

  3. Go to the Projectname.idl file and remove the dual or custom interface generated by the wizard in step 2.

  4. Verify that the resulting IDL file looks like the code examples that follow. You might choose to implement your own set of interfaces from the ones defined in Pipecomp.idl.

// SimplePipeComponent.idl : IDL source for SimplePipeComponent.dll

//

import "oaidl.idl";

import "ocidl.idl";

import "pipecomp.idl";

[

uuid(D26A52F6-63A0-42B1-8C88-3C71C66BB189),

version(1.0),

helpstring("SimplePipeComponent 1.0 Type Library")

]

library SIMPLEPIPECOMPONENTLib

{

importlib("stdole32.tlb");

importlib("stdole2.tlb");

[

uuid(E66CAF06-18D8-4C70-9D39-5ED9756C21AD),

helpstring("MySimplePipelineComponent Class")

]

coclass MySimplePipelineComponent

{

[default] interface IPipelineComponentAdmin;

interface IPipelineComponent;

interface IPipelineComponentDescription;

};

};

  5. One of the implementations of MySimplePipelineComponent [coclass] is defined in the header file as follows:

// MySimplePipelineComponent.h : Declaration of the

// CMySimplePipelineComponent

#ifndef __MYSIMPLEPIPELINECOMPONENT_H_

#define __MYSIMPLEPIPELINECOMPONENT_H_

#include "resource.h" // main symbols

/////////////////////////////////////////////////////////////////////////////

// CMySimplePipelineComponent

class ATL_NO_VTABLE CMySimplePipelineComponent :

public CComObjectRootEx<CComSingleThreadModel>,

public CComCoClass<CMySimplePipelineComponent, &CLSID_MySimplePipelineComponent>,

public ISupportErrorInfo,

public IDispatchImpl<IPipelineComponentAdmin, &IID_IPipelineComponentAdmin, &LIBID_SIMPLEPIPECOMPONENTLib>,

public IDispatchImpl<IPipelineComponent, &IID_IPipelineComponent, &LIBID_SIMPLEPIPECOMPONENTLib>,

public IDispatchImpl<IPipelineComponentDescription, &IID_IPipelineComponentDescription, &LIBID_SIMPLEPIPECOMPONENTLib>

{

public:

CMySimplePipelineComponent()

{

}

DECLARE_REGISTRY_RESOURCEID(IDR_MYSIMPLEPIPELINECOMPONENT)

DECLARE_PROTECT_FINAL_CONSTRUCT()

BEGIN_COM_MAP(CMySimplePipelineComponent)

COM_INTERFACE_ENTRY2(IDispatch,IPipelineComponentAdmin)

COM_INTERFACE_ENTRY(IPipelineComponentAdmin)

COM_INTERFACE_ENTRY(IPipelineComponent)

COM_INTERFACE_ENTRY(IPipelineComponentDescription)

COM_INTERFACE_ENTRY(ISupportErrorInfo)

END_COM_MAP()

// ISupportsErrorInfo

STDMETHOD(InterfaceSupportsErrorInfo)(REFIID riid);

public://IPipelineComponentAdmin

STDMETHODIMP GetConfigData(IDispatch** ppDict );

STDMETHODIMP SetConfigData(IDispatch* pDict );

public://IPipelineComponent

STDMETHODIMP Execute(IDispatch* pdispObject,IDispatch* pdispContext,LONG lFlags,LONG* plErrorLevel);

STDMETHODIMP EnableDesign(BOOL fEnable);

public: //IPipelineComponentDescription

STDMETHODIMP ValuesRead(VARIANT* pvar);

STDMETHODIMP ValuesWritten(VARIANT* pvar);

STDMETHODIMP ContextValuesRead(VARIANT* pvar);

};

#endif //__MYSIMPLEPIPELINECOMPONENT_H_

Related Topics

Application Integration Components

IPipelineComponent

IPipelineComponentAdmin


Creating Receipt Correlator Components

Receipt correlator components can be implemented to correlate documents, groups of documents, and interchanges with their receipts. To use a receipt correlator, you must implement a custom parser by using the IBizTalkParserComponent interface. This is required because the server can obtain only the progID of the receipt correlator to be used by calling the GetNextDocument method on the IBizTalkParserComponent interface.

In addition, with BizTalk Server on the receiver side where the receipt is being generated, the parser component is responsible for putting the acknowledgment status, as well as sufficient information, on the receipt (a Canonical Receipt to begin with, but it can be mapped into other receipt document schemas, such as AK997 in EDI) to allow the correlator component on the sender side to uniquely identify the original outbound interchange, group, or document record. For an XML document, using the GUID is usually sufficient. But for EDI interchanges, because GUID cannot be used (there is no placeholder for any GUID in an EDI interchange), a combination of EDI-specific fields is needed for this unique identifier. For instance, the default X12 correlator component uses a combination of the following fields for this purpose: version, release, functional group ID, control ID, source application name, and destination application name.

Whenever the server receives a receipt as an inbound document, the parser component's responsibility is to detect the inbound document as being a receipt, to extract all relevant information needed for correlation, and to place the receipt onto the transport dictionary. Upon returning from the GetNextDocument method call, the parser should set the DocIsReceipt parameter to TRUE and the CorrelationCompProgID parameter to the progID of the corresponding correlator component.

The server calls the Correlate method on the IBizTalkCorrelation interface, and passes in a pointer to the IBizTalkAcknowledge object and the transport dictionary containing the receipt as the working data. Then the receipt correlator's implementation of the Correlate method extracts all relevant information about the document, document group, or interchange that should have been set by the parser component from the transport dictionary. Using this information, the Correlate method then calls AckDocument, AckGroup, or AckInterchange on the IBizTalkAcknowledge interface and sets the DTA_ACK_STATUS value for that document, group, or interchange.

Note that the server does not immediately call IBizTalkCorrelation. The receipt document and the correlation progID are stored to the database for later correlation. When the document is picked up for processing, the correlation component is created and invoked with the transport dictionary that was given by the parser component and a pointer to IBizTalkAcknowledge.

Related Topics

Submitting Documents with Receipts

Understanding Receipts


Working with Parsers

The following tables show the possible sequence of calling the methods of the IBizTalkParserComponent interface, based on the following sample interchanges.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | True
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to False.
GetGroupDetails | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A
GetGroupSize | The LastGroup parameter is set to True.

If you have an interchange with two documents, the methods are called in the following sequence:

Method | Return
ProbeInterchangeFormat | Non-empty format string
GetInterchangeDetails | N/A
GroupsExist | False
GetNextDocument | The LastDoc parameter is set to False.
GetNativeDocumentOffsets | N/A
GetNextDocument | The LastDoc parameter is set to True.
GetNativeDocumentOffsets | N/A

Related Topics

Parsers

IBizTalkParserComponent

Supporting the Tracking Database with Parser and Serializer Components


Working with Serializers

To create a custom serializer component, you need to perform the following tasks:

  • Create a COM component that implements the IBizTalkSerializerComponent and IPipelineComponentAdmin interfaces.

  • Register this component and include the category identifiers CATID_BIZTALK_COMPONENT and CATID_BIZTALK_SERIALIZER in the registry. For more information, see Registering Custom Components.

  • Create Active Server Pages (ASP) files for setting custom property values on your serializer component by using the pre-defined user interface management functions. These functions are available in the ASP include files located in the folder \Microsoft BizTalk Server\Messaging Manager\pipeline on the BizTalk Server installation drive. For more information about the ASP file format, see "ASP file formats" that follows.

  • Place the ASP files in the pipeline folder and name the files using these formats:
    File name | Description
    BizTalk_ComponentName_1.asp | Displays a dialog box that reads the serializer key values from the IDictionary object. These values are displayed to the user for modification.
    BizTalk_ComponentName_1_post.asp | Updates the serializer dictionary with the new key values set by the user.

  • Use the SetConfigComponent method to associate the custom serializer component with a channel.

After these tasks are completed, the user can access these settings by clicking Advanced on the Channel Properties page in BizTalk Messaging Manager. For more information, see Set advanced configuration properties.

ASP file formats

When using the functions provided in the ASP include files located in the folder \Microsoft BizTalk Server\Messaging Manager\pipeline on the BizTalk Server installation drive, use the following general format:

<!--#INCLUDE FILE="pe_edit_header.asp" -->

<-- optional HTML formatting tags here -->

<%

optional calls to input functions here

%>

<!--#INCLUDE FILE="pe_edit_footer.asp" -->

The following functions can be used in the ASP pages for displaying text or retrieving specific types of information from the user. These functions are defined in the file pe_global_edit.asp:

  • DisplayReadonlyText

  • GetLabelAccel

  • InputArrayAccel

  • InputCheckBoxAccel

  • InputFloatAccel

  • InputNumberAccel

  • InputPasswordAccel

  • InputRadioAccel

  • InputSimpleListAccel

  • InputTextAccel

Method Sequences

The following tables show the possible sequence of calling the methods of the IBizTalkSerializerComponent interface, based on the following sample interchanges.

If you have an interchange with one document, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 0.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with one group, with one document in the group, the methods are called in the following sequence:

Method | Return
Init | The numdocs parameter is set to 1.
AddDocument | The docHandle parameter is set to 0.
GetInterchangeInfo | The numGroups parameter is set to 1.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The docHandle parameter is set to 0.

If you have an interchange with two groups, with two documents in the first group and one in the second, the methods are called in the following sequence (this assumes support of batching):

Method | Return
Init | The numdocs parameter is set to 3.
AddDocument | The handle parameter is set to 0.
AddDocument | The handle parameter is set to 1.
AddDocument | The handle parameter is set to 2.
GetInterchangeInfo | The numGroups parameter is set to 2.
GetGroupInfo | The numdocs parameter is set to 2.
GetDocInfo | The handle parameter is set to 1.
GetDocInfo | The handle parameter is set to 0.
GetGroupInfo | The numdocs parameter is set to 1.
GetDocInfo | The handle parameter is set to 2.

Related Topics

Serializers

Supporting the Tracking Database with Parser and Serializer Components


Registering Custom Components

To use a custom component in BizTalk Server 2002, the component must be registered with the category IDs for all pipeline components and for the specific type of pipeline component.

Register the component as an out-of-process component to provide better isolation. A component can be registered as an in process (inproc) component to increase its performance. However, an inproc component that fails to respond during an error condition might cause BizTalk Server to fail. Therefore, a component should be thoroughly tested before registering it as an inproc component.

Note

  • An out-of-process component registered as a COM+ application must be configured to run in an identity other than the interactive user. For more information about Component Services and COM+, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to Component Services in the Platform SDK.

BizTalk Server category identifiers

Custom components that are used in BizTalk Server must be associated with one or more category identifiers (CATID). The following table shows the category identifiers defined by BizTalk Server.

CATID | GUID | Description
CATID_BIZTALK_ AIC | BD193E1D-D7DC-4B7C-B9D2-92AE0344C836 | Identifies the component as an application integration component (AIC).
CATID_BIZTALK_ COMPONENT | 5C6C30E7-C66D-40E3-889D-08C5C3099E52 | Identifies the component as a BizTalk Server component. All components that are used with BizTalk Server must implement this category identifier.
CATID_BIZTALK_ CUSTOM_PROCESS | 20E8080F-F624-4401-A203-9D99CF18A6D9 | Identifies the component as a custom preprocessor for a receive function.
CATID_BIZTALK_ IDocSpecExtension | 711E279C-DE24-11D2-974B-00C04F680FE7 | Identifies the component as an extension module for importing XML documents.
CATID_BIZTALK_ MapEditFunctoids | 2560F3BF-DB47-11D2-B3AE-00C04F72D6C1 | Identifies the component as a custom functoid that is displayed in the functoid palette.
CATID_BIZTALK_ PARSER | C0DCDF4E-692C-11D2-89E7-00C04F79DBAA | Identifies the component as a parser that is used to process inbound documents.
CATID_BIZTALK_ SERIALIZER | AFCC065F-E0A6-47A6-B0A8-ECAA2FEEE2F4 | Identifies the component as a serializer that is used to process outbound documents.

Assigning affinity

Each component must be associated with two category IDs. One category ID marks the component as a BizTalk Server component. A component so marked appears in a list of components in the BizTalk Server administration console. The second category ID indicates the type or purpose of the component. This second association is called affinity, which allows BizTalk Server to determine the context in which the component can be used. For example, only those components whose affinity is registered as an application integration component (AIC) appear in the list of available components when an AIC transport type has been selected in BizTalk Messaging Manager.

To register affinity for an AIC created with Microsoft Visual C++® using ATL, include the following code in your header file:

#include "bts_sdk_guids.h"

// Implement the Component and AIC Category IDs (CATID)

BEGIN_CATEGORY_MAP(AIC_ClassName)

IMPLEMENTED_CATEGORY(CATID_BIZTALK_COMPONENT)

IMPLEMENTED_CATEGORY(CATID_BIZTALK_AIC)

END_CATEGORY_MAP()

To register affinity for an AIC created with Microsoft Visual Basic:

  1. After registering your component using Regsvr32.exe, search the registry for the CLSID of your AIC under the following key:

    HKEY_CLASSES_ROOT\CLSID

  2. Expand the Implemented Categories key of your AIC.

  3. Add two new keys with the following names:

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{5C6C30E7-C66D-40e3-889D-08C5C3099E52}

    HKEY_CLASSES_ROOT\CLSID\AIC_CLSID\Implemented Categories\{BD193E1D-D7DC-4b7c-B9D2-92AE0344C836}

These GUIDs can be found in bts_sdk_guids.h in the Program Files\Microsoft BizTalk Server\SDK\Include folder. The first key shown in step 3 above identifies the AIC as a BizTalk Server component (CATID_BIZTALK_COMPONENT). The second key shown in step 3 above identifies the component as an AIC (CATID_BIZTALK_AIC).

Testing affinity

To test affinity, use BizTalk Messaging Manager to create a port that uses the AIC. For more information, see Select an application integration component.

Related Topics

IFunctoid Interface

ISchemaImporter Interface

IBTSCustomProcess

Parsers

Serializers


Handling Data Passed to AICs

The proper method for handling data returned by an application integration component (AIC) depends on several factors, including programming language, the characteristics of the channel being used, and the document being passed.

For an AIC written in Visual Basic, you receive a buffer that contains Unicode characters, ANSI characters, or bytes.

The Direct Integration sample contains an ATL component that unpacks binary buffers returned as BSTR data. The component defines and implements the IConvertBstr interface, which defines a single method called Convert:

HRESULT Convert([in] BSTR bstrData, [out,retval] VARIANT* psaData);

When a buffer is passed as a BSTR to this method, the component creates a safe array of characters. The size of the array is the size of the buffer passed in the BSTR. A simple operation of memory copying helps translate the BSTR data to a safe array. Convert can be used by an AIC to convert the data to a format that can be iterated, as shown in the following code:

STDMETHODIMP CConvertBstr::Convert(BSTR bstrData, VARIANT *psaData) {

HRESULT hr = S_OK;

SAFEARRAY *psa = NULL;

BYTE HUGEP*psaBuffer = NULL;

SAFEARRAYBOUND rgsaBound[1];

UINT nDataLength = 0;

Determine if the arguments passed to Convert are valid, as shown in the following code:

if (!psaData || !bstrData)

return E_FAIL;

Clear the variant data type, as shown in the following code:

hr = VariantClear(psaData);

if (FAILED(hr))

return hr;

The client code must initialize the variant. Then, retrieve the length of the allocated BSTR, in bytes, as shown in the following code:

nDataLength = SysStringByteLen(bstrData);

At this point, construct a SAFEARRAY that will contain the bytes from the input BSTR data type, as shown in the following code:

rgsaBound[0].lLbound = 0;

rgsaBound[0].cElements = (ULONG)nDataLength;

psa = SafeArrayCreate(VT_UI1, 1, rgsaBound) ;

if (!psa)

return E_FAIL;

SafeArrayAccessData(psa, (void HUGEP**) &psaBuffer);

memcpy(psaBuffer, bstrData, nDataLength);

SafeArrayUnaccessData(psa);

Finally, return the SAFEARRAY through the output parameter, as shown in the following code:

V_VT(psaData) = VT_ARRAY | VT_UI1;

V_ARRAY(psaData) = psa;

return hr;

}

In addition, all pipeline AICs receive an IDictionary object, containing a set of fields. Every IDictionary object contains a working_data field. Several other fields could be present, including the following string values supplied by the server for all AICs:

  • Src_ID_Type: The type of identifier used for the source organization.

  • Src_ID_Value: The value of the source organization identifier.

  • Dest_ID_Type: The type of identifier used for the destination organization.

  • Dest_ID_Value: The value of the destination organization identifier.

  • Document_Name: The name of the input document definition.

  • Tracking_ID: A key value that is based on the globally unique identifier (GUID) and used for tracking.

  • Src_Filename: The name of the source document.

  • Src_Filepath: The file path of the source document.

  • Out_Codepage: The codepage used by the component to interpret the BSTR data.

Related Topics

Supporting the Tracking Database with Parser and Serializer Components

Execute Method


Supporting the Tracking Database with Parser and Serializer Components

When creating a custom parser or serializer, you might want your component to support the BizTalk Server Tracking database. To accomplish this, the component must use the IDictionary interface to add key/value pairs into the database.

Interchange table

The following table contains the list of keys that can be used to support the Tracking database from the interchange level with a custom component. The table used in the database is dta_interchange_details.

Dictionary key | Inbound or outbound | Column logged in Tracking database | Description
Src_ID_Type | Both | *nvcSrcAliasQualifier | This is the qualifier for the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Src_ID_Value | Both | *nvcSrcAliasId | This contains the value of the qualifier of the source organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Src_ID_App | Inbound | nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Dest_ID_Type | Both | *nvcDestAliasQualifier | This is the qualifier for the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
Dest_ID_Value | Both | *nvcDestAliasId | This contains the value of the qualifier of the destination organization. This value can come from a parameter supplied in a Submit call or from a receive function in the BizTalk Server Administration user interface. A parser can overwrite this value to manipulate the routing information used for channel selection.
In_Dest_ID_App | Inbound | nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_id | Inbound | nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
interchange_version | Inbound | nvcVersion | This is the version of an EDI interchange. When the parser sets the value with this dictionary key, the value is logged on the inbound interchange in the Tracking database.
Out_Src_ID_App | Outbound | *nvcSrcAppName | This is the interchange level identifier for the source application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
Out_Dest_ID_App | Outbound | *nvcDestAppName | This is the interchange level identifier for the destination application of an EDI interchange. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_id | Outbound | *nvcControlID | This is the unique control number used to identify an EDI interchange instance between trading partners. The serializer usually generates this unique value. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.
out_interchange_version | Outbound | *nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound interchange in the Tracking database.

Note

  • The columns of the dta_interchange_details table marked with an asterisk (*) are used for receipt correlation.

Group table

The following table contains the list of keys that can be used to support the Tracking database from the group level with a custom component. The table used in the database is dta_group_details. This table applies to both inbound and outbound documents.

Dictionary key | Column logged in Tracking database | Description
group_id | *nvcControlID | This is the unique control number of a group instance within an EDI interchange. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. For outbound document processing, the serializer usually generates this value.
functional_identifier | *nvcFunctionalGroupID | This is the code for the type of documents in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
application_sender_code | *nvcSrcAppName | This is the group level identifier for the source application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
application_receiver_code | *nvcDestAppName | This is the group level identifier for the destination application in an EDI group. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
standards_version | *nvcVersion | This is the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.
standards_release | *nvcRelease | This is the release of the version of the EDI standard. Both the parser and the serializer can set the value with this key. The value is logged on the inbound and the outbound group, respectively, in the Tracking database.

Note

The columns of the dta_group_details table marked with an asterisk (*) are used for receipt correlation.

Inbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_indoc_details. This table applies to inbound documents only.

Dictionary key | Column logged in Tracking database | Description
doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_version | nvcVersion | This is the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
standards_release | nvcRelease | This is the release of the version of the EDI standard. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.
doc_type | nvcDocType | This is the document type or transaction set identifier. When the parser sets the value with this dictionary key, the value is logged on the inbound document in the Tracking database.

Outbound document table

The following table contains the list of keys that can be used to support the Tracking database from the document level with a custom component. The table used in the database is dta_outdoc_details. This table applies to outbound documents only.

Dictionary key | Column logged in Tracking database | Description
out_doc_doc_id | nvcControlID | This is the unique control number of an EDI document instance. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_syntax | nvcSyntax | This is the code for document syntax, such as XML, X12, EDIFACT, H7, and so on. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
out_doc_standards_version | nvcVersion | This is the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
out_doc_standards_release | nvcRelease | This is the release of the version of the EDI standard. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database. In the serializer, this value can be read from the document's PropertySet.
out_doc_doc_type | nvcDocType | This is the document type or transaction set identifier. When the serializer sets the value with this dictionary key, the value is logged on the outbound document in the Tracking database.
Tracking_ID | uidTrackingGUID | This is the tracking identifier of the document for which a receipt is generated.

Note

  • The Tracking_ID key is used when calling the AckDocument method.

Interchange and document tables

The following table contains the list of keys that can be used to support the Tracking database from the interchange and document level with a custom component. The table used in the database for interchange data is dta_interchange_data. The table used in the database for document data is dta_document_data.

Dictionary key | Inbound or outbound | Column logged in Tracking database | Description
in_codepage | Inbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the parser sets the value with this dictionary key, the value is logged in the data record related to the inbound interchange/document in the Tracking database.
out_codepage | Outbound | nCodePage | This is the system code page value with which interchange/document data is encoded. When the serializer sets the value with this dictionary key, the value is logged in the data record related to the outbound interchange/document in the Tracking database.

Related Topic

Understanding the Tracking Database Schema


BizTalk Orchestration Services

The interfaces in this section provide access to XLANG Scheduler System Managers, XLANG group managers, XLANG schedule instances, and XLANG ports.

The XLANG Scheduler System Manager provides moniker resolution and maintains a collection of group managers. A group manager runs in every COM+ application that has been designated as an XLANG schedule host, and maintains a collection of XLANG schedule instances. An XLANG schedule instance represents a running XLANG schedule that can be queried for information, such as the schedule's completion status. For XLANG schedules with a COM-bound port, a proxy object can be used to obtain a reference to the interface specified in the port binding.

  • For help with specific tasks, see Using Orchestration Services.

  • For general background information, see Understanding Orchestration Services.

  • For information about COM interfaces and error messages, see the Orchestration Services Reference.

Related Topic

Moniker Syntax


Understanding Orchestration Services

This section provides detailed conceptual information that is important to understanding how to access and work with BizTalk Orchestration Services. The following topics are covered in this section:

  • XLANG Interfaces

  • XLANG Schedule Correlation

The interfaces described in this section provide access to XLANG Scheduler System Managers, XLANG group managers, XLANG schedule instances, and XLANG ports.


XLANG Interfaces

The XLANG Scheduler System Manager provides moniker resolution and maintains a collection of group managers. A group manager runs in every COM+ application that has been designated as an XLANG schedule host, and maintains a collection of XLANG schedule instances. An XLANG schedule instance represents a running XLANG schedule that can be queried for information, such as the schedule's completion status. For XLANG schedules with a COM-bound port, a proxy object can be used to obtain a reference to the interface specified in the port binding.

The following illustration shows the relationship between the XLANG interfaces covered in this section, and the corresponding monikers.

XLANG Scheduler interfaces

The following XLANG schedule interfaces are available:

Administrator interfaces:

  • IWFGroupAdmin

  • IWFSystemAdmin

Schedule instance interfaces:

  • IWFProxy

  • IWFWorkflowInstance


XLANG Schedule Correlation

XLANG schedule correlation enables you to use a single message queue shared across multiple XLANG schedule instances, allowing incoming messages on that queue to be correlated to the correct running XLANG schedule instance. Src_XLANG_InstanceID and Dest_XLANG_InstanceID are dictionary keys created to take advantage of XLANG schedule correlation. The XLANG Scheduler Engine supports the ability to set the globally unique identifier (GUID) assigned to the schedule instance, or InstanceID, as the message label on received Message Queuing messages. These keys are provided by BizTalk Messaging Services to supply a simple mechanism to save and retrieve the data from the XLANG Scheduler Engine. By using these keys, you do not need to write code to retrieve and look up the InstanceIDs in the XLANG schedule, and you can leverage the existing BizTalk Messaging transports.

The Src_XLANG_InstanceID dictionary key appears on messages that originate from the BizTalk Messaging binding in an XLANG schedule instance, as long as the message is declared to send the InstanceID. This information can be used by a component in the messaging port to store the InstanceID to a custom database with a business-level correlation ID.

When a response message is received for a business interaction, the messaging port bound to the running XLANG schedule instance must contain the InstanceID in order to send the data to the correct running XLANG schedule instance. To do this, the Dest_XLANG_InstanceID key is extracted by BizTalk Messaging Services and placed on the Message Queuing label for the receiving queue. The key is set by custom pipeline components that look up the XLANG schedule InstanceID based on the business-level correlation ID.

Note

  • The tracking dictionary does not use these keys and they are not defined in a database table. To capture the correlation state, you need to implement a custom database.

For more information, run the E-Procurement Sample, which demonstrates the XLANG schedule correlation feature.

Related Topic

Instance Management


Using Orchestration Services

This section provides task-specific information about how to use BizTalk Orchestration Services. It is highly recommended that you review the Understanding Orchestration Services topic as well.

The following topics are covered in this section:

  • Activating an XLANG Schedule Instance

  • Accessing a Running XLANG Schedule Instance

  • Accessing the XLANG Scheduler System Manager

  • Accessing Group Managers


Activating an XLANG Schedule Instance

Use IWFProxy to obtain a schedule instance. If IWFProxy is used on a non-COM port binding, an error is returned.

A reference to IWFProxy can be obtained from:

  • The Port property available on the IWFWorkflowInstance interface.

  • An XLANG schedule moniker that specifies the port name.

The following Microsoft Visual Basic code sample shows how to activate an XLANG schedule on the local computer by using a moniker, and obtain a reference to the named port on that XLANG schedule instance.

Dim oPort As Object

Set oPort = GetObject("sked:///C:\schedules\test.skx/PortA")

At this point, the oPort variable contains a reference to the COM object bound in PortA of the schedule instance.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.


Accessing a Running XLANG Schedule Instance

Use IWFWorkflowInstance to gather information about a specific running schedule instance.

A reference to IWFWorkflowInstance can be obtained from:

  • The WorkflowInstance property available on the IWFProxy interface.

  • The collection of IWFWorkflowInstance objects returned by the IWFGroupAdmin object.

  • An XLANG schedule moniker.

The following Microsoft Visual Basic code sample shows how to instantiate an XLANG schedule on the local computer and obtain a reference to that schedule instance.

Dim oWFI As IWFWorkflowInstance

Set oWFI = GetObject("sked:///C:\schedules\test.skx")

To obtain a reference to all currently running schedule instances in a group manager, you can access the collection of IWFWorkflowInstance objects contained by the IWFGroupAdmin object. The following Microsoft Visual Basic code displays the fully qualified name of each schedule instance running in the default XLANG Scheduler Group Manager.

Dim oGM As IWFGroupAdmin

Dim oWFI As IWFWorkflowInstance

Set oGM = GetObject("sked://!XLANG Scheduler")

For Each oWFI In oGM

MsgBox ("XLANG Schedule: " + oWFI.FullyQualifiedName)

Next

When using multiple group managers, you can determine the group manager associated with any schedule instance by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFWorkflowInstance object.

  2. Parse the group manager name out of the moniker string returned.

    This is the portion that begins with an exclamation point (!) and ends with a slash (/).

  3. Obtain a reference to the IWFGroupAdmin object using a moniker created with the group manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Notes

  • When using C++, the COM CoGetObject function is used in place of GetObject.

  • When accessing this object in Microsoft Visual Basic, you must declare your object variable with the appropriate type information rather than using the Object type. For example:

Dim myInstance As IWFWorkflowInstance


Accessing the XLANG Scheduler System Manager

Use IWFSystemAdmin to start, stop, and retrieve information about the group managers.

To obtain a reference to this object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the XLANG Scheduler System Manager on the local computer.

Dim oSM As SysMgr

Set oSM = GetObject("sked://")

This object also enumerates a collection of the IWFGroupAdmin objects that represent the group managers associated with this XLANG Scheduler System Manager.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.


Accessing Group Managers

To obtain a reference to an IWFGroupAdmin object, you can invoke the COM GetObject function using a moniker. The following Microsoft Visual Basic code sample shows how to obtain a reference to the default XLANG Scheduler Group Manager on the local computer.

Dim oGM As IWFGroupAdmin

Set oGM = GetObject("sked://!XLANG Scheduler")

To obtain a reference to other group managers, replace "XLANG Scheduler" with the name of the COM+ application that has been designated as an XLANG Scheduler Engine host or group manager. You can determine whether a COM+ application is a group manager by using the IsWorkflowHost method on IWFSystemAdmin.

You can also obtain a reference to all group managers associated with the XLANG Scheduler System Manager through the collection of IWFGroupAdmin objects contained by the SysMgr object. The following Microsoft Visual Basic code displays the fully qualified name of each group manager.

Dim oSM As SysMgr

Dim oGM As IWFGroupAdmin

Set oSM = GetObject("sked://")

For Each oGM In oSM

MsgBox ("Group Manager: " + oGM.FullyQualifiedName)

Next

The IWFGroupAdmin object also enumerates a collection of the IWFWorkflowInstance objects that represent currently running schedule instances for this group manager.

You can determine the XLANG Scheduler System Manager associated with any group manager by following these steps:

  1. Retrieve the FullyQualifiedName property of the IWFGroupAdmin object.

  2. Parse the XLANG Scheduler System Manager name out of the moniker string returned.

    This is the portion between the sked:// prefix and the exclamation point (!).

  3. Obtain a reference to the IWFSystemAdmin object using a moniker created with the XLANG Scheduler System Manager name from step 2.

For additional information about monikers, see Moniker Syntax.

Note

  • When using C++, the COM CoGetObject function is used in place of GetObject.


BizTalk Managing and Monitoring

Windows Management Instrumentation (WMI) is a data-management layer included in Microsoft® Windows® 2000. Microsoft BizTalk™ Server 2002 uses the WMI layer to encapsulate administrative functions that support the management of systems in an enterprise.

  • For help with specific tasks, see Using Managing and Monitoring.

  • For general background information, see Understanding Managing and Monitoring.

  • For information about COM interfaces, see the Managing and Monitoring Reference.

This section contains sample code in Microsoft Visual Basic® and Visual Basic Script.


Understanding Managing and Monitoring

When you use the BizTalk Server Administration Microsoft Management Console (MMC) snap-in (the administration console) to change group, server, queue, and database management settings, the new values are stored in the BizTalk Messaging Management database through the BizTalk Server WMI provider. In BizTalk Server 2002, this WMI provider uses a Microsoft® SQL Server™ database to store administrative objects. All timestamps are created by using the local time on the computer that is running SQL Server. However, the WMI provider refers to all timestamps in coordinated universal time (UTC). The administration console then converts the timestamps back to local time for display.

The WMI provider acts as an intermediary between WMI and the administration console MMC snap-in. The WMI provider gathers information from a resource (managed object) and makes it available to management applications through the WMI API.

The BizTalk Server schema classes are registered and defined by using Managed Object Format (MOF), which is a compiled language based on the Interface Definition Language (IDL). You place this information in an .mof file that you submit to the MOF compiler, Mofcomp.exe.

This section contains the following topics:

  • BizTalk Server Namespace

  • BizTalk Server Provider and Registration

  • Custom Counters

The MOF code examples in the following topics are taken from the InterchangeProvSchema.mof file found in the \Program Files\Microsoft BizTalk Server\Setup folder. This file, along with SrvEvents.mof, contains the BizTalk Server namespace, provider, provider registration, and schema class definitions.

To access the WMI database layer programmatically, see Managing and Monitoring Reference, which documents the BizTalk Server WMI schema classes that correspond to the Administration objects.


BizTalk Server Namespace

Every WMI namespace contains a set of system classes, including __NAMESPACE. A namespace groups a collection of classes into logical units. Every computer has a defined namespace at the top of the hierarchy called the Root namespace. The location of a namespace is described by a path.

In the following MOF code, "MicrosoftBizTalkServer" is specified as the value for the Name property of the __NAMESPACE system class for BizTalk Server:

#pragma namespace ("\\\\.\\Root")

instance of __Namespace

{

Name = "MicrosoftBizTalkServer";

}

BizTalk Server defines the "MicrosoftBizTalkServer" namespace as a sibling of the Root namespace, logically distinguishing the BizTalk Server–managed environment from other managed environments.


BizTalk Server Provider and Registration

When WMI receives a request from a BizTalk Server management application, it forwards the request to the WMI provider, "InterchangeProv." The WMI provider retrieves, modifies, deletes, and/or enumerates instances of the BizTalk Server schema classes.

"InterchangeProv" is a custom provider designed to interact with the managed objects in the BizTalk Server environment. For a complete reference of these managed objects and their properties and methods, see Managing and Monitoring Reference.

The BizTalk Server instance provider supports data retrieval, data modification, data deletion, data enumeration, and query processing.

For more information about how to author and interpret .mof files, see the article "Managed Object Format (MOF) Language," in the WMI SDK on the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp).

The BizTalk Server WMI classes are defined in text files by using the Managed Object Format (MOF). Note that each class has a key property qualifier. The key property qualifier tells you that any instance of that class (or any instance of a derived class) can be uniquely identified by the value of the key property qualifier. This is a concept borrowed from database technologies.

To access the functionality provided by WMI you call a set of DCOM interfaces, including IWbemClassObject and IWbemServices. These interfaces make it possible to write management applications that work with classes and instances that are managed by WMI.

In addition, you can access WMI from environments that support Automation objects through scripting objects that wrap the DCOM interfaces. For example, the SWbemObject class wraps the IWbemClassObject interface, and SWbemServices wraps IWbemServices. When using WMI with the BizTalk Server schema classes, you can get complete access to WMI through Microsoft Visual Basic or Visual Basic Scripting Edition (VBScript). Visual Basic projects can access these objects by adding Microsoft WMI Scripting V1.1 Library in the Reference dialog box.

The Component Object Model (COM) API is available directly to C/C++ programmers. You can use the Scripting API to develop script and applications based on Microsoft Visual Basic that you can use to view or control managed objects.

For a description of the interfaces in the WMI COM API, see the article "COM API for WMI," in the WMI SDK on the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp).

For a description of the interfaces in the Scripting API, see the article "Scripting API for WMI," in the WMI SDK on the MSDN Online Library Web site.


Custom Counters

Custom counters are WMI class instances based on custom queries of the Tracking database. After they are created, these custom counters can be consumed by user-defined rules in Microsoft Operations Manager 2000 (MOM).

This section contains the following topics:

  • Custom Counter Query Properties

  • Custom Counters Validation

To programmatically create, delete, and update custom counters, see Creating a Custom Counter Using WMI.

For information about using BizTalk Server 2002 together with MOM, see About Microsoft Operations Manager.

The BizTalk Server 2002 Management Pack module includes a sample custom counter performance processing rule called "Sample - Custom Counter." This sample executes the query defined in the WMI custom counter class to acquire the number of documents in the Tracking database.

Notes

  • Unless you want to construct a regular expression when working with custom counters, there are a list of characters that need special consideration:

    [ ], ^, %, _

    You should enclose these characters in [ ] braces. For example, the string "Org%ani^za_tio[n", should be replaced by "Org[%]ani[^]za[_]tio[[]n".

  • Only the following custom counter setting properties can accept regular expressions: DocType, DestOrgName, SrcOrgName, DestQualifier, DestQualifierValue, SrcQualifier, and SrcQualifierValue.


Custom Counter Query Properties

When you create a new custom counter class instance, you provide values for properties that determine the query executed by the custom counter.

Values for the following query properties can be specified, when creating an instance of the MSBTS_CustomCounterSetting class:

  • Custom Counter Name. Name of the new class instance being created.

  • Source Organization. Name of the organization that is the source for the channel through which the document is processed, as defined in the BizTalk Messaging Management configuration.

  • Source Qualifier. Qualifier for the source organization identifier for the channel through which the document is processed.

  • Source Value. Value for the source organization identifier for the channel through which the document is processed.

  • Destination Organization. Name of the organization that is the destination for the channel through which the document is processed, as defined in the BizTalk Messaging Management configuration.

  • Destination Qualifier. Qualifier for the destination organization identifier for the channel through which the document is processed.

  • Destination Value. Value for the organization identifier defined in the BizTalk Messaging Management configuration as the destination for the channel through which the document is processed.

  • Document Type. Name of the root element from the document schema.

  • Time Interval. Interval of time, in seconds, over which to accumulate the custom counter value.

  • BizTalk Server Group Name. Name of the BizTalk Server group against which the custom counter query is to be executed.

For an example of programmatically setting these properties, see Creating a Custom Counter Using WMI and the Custom Counters sample.

Notes

  • In BizTalk Server 2002, organizations can be assigned an identifier alias. Identifiers consist of a name, qualifier, and value. When creating an organization, a default qualifier of OrganizationName is used along with a user-assigned name string as the identifier value. You can then create additional organization identifiers for specific tracking or routing purposes.

  • When tracking documents during processing, BizTalk Server records the qualifier and value for each channel source and destination organization. When creating a new custom counter class instance, it is possible to specify just the source and destination organization name or a qualifier-value pair. However, organization names and qualifier-value pairs cannot be specified at the same time.

  • When only the source and/or destination organization name is provided, the custom counter will include all documents that were processed through channels with any of the identifiers for the specified organization. When qualifier-value pairs are provided, only the documents processed by channels configured with those qualifier-value pairs are included.

  • To count only documents whose processing channel(s) had only the default qualifier-value pair configured, the qualifier should be OrganizationName and the value should be the name of the organization.

  • Wild-card expressions can be used for the following arguments when creating a new custom-counter class instance:
    • Source Organization

    • Source Qualifier

    • Source Value

    • Destination Organization

    • Destination Qualifier

    • Destination Value

    • Document Type


Custom Counters Validation

Validation of custom counters is optional and is provided through the IsValid method on the custom counter setting class, MSBTS_CustomCounterSetting.


Using Managing and Monitoring

This section provides task-specific information about how to manage and monitor by using Microsoft BizTalk Server 2002. Topics illustrate how to create and manipulate the BizTalk Server Administration objects by using WMI. It is highly recommended that you review the Understanding Managing and Monitoring topic as well.

The following topics are covered:

  • Creating an Event Consumer Using WMI

  • Creating a Custom Counter Using WMI

  • Handling WMI Errors


Creating an Event Consumer Using WMI

WMI provides a powerful event architecture that enables modifications in management information to be identified, aggregated, and associated with other management information, which can then be forwarded to local or remote management applications. Event handling and notification is a key benefit provided by WMI that provides a mechanism for identifying and dealing with hardware or software events and errors.

After an event occurs, a notification is delivered to one or more registered recipients, knows as event consumers. Event consumers can register to receive certain types of notifications. Event consumers register to receive notifications without any knowledge of how events and notifications are provided. To register, event consumers specify a filter that is created by using the WMI Query Language (WQL). The query describes the conditions under which the consumer receives the event notification.

In addition to DCOM interfaces, WMI supports a uniform scripting application programming interface (API) that gives applications and scripts access to the WMI provider on either a local computer or a remote computer.

This section shows the basic steps necessary to write a temporary WMI event consumer with Microsoft Visual Basic script, although some of the associated DCOM interfaces are mentioned.

This section contains the following topics:

  • Declaring Variables

  • Connecting to the Microsoft BizTalk Server Namespace

  • Creating the Event Object

  • Monitoring Events

Note

  • If you have Health Monitor installed (either from Microsoft Application Center 2000 or Microsoft BackOffice® Server), you can configure Health Monitor through its Microsoft Management Console (MMC) user interface (UI) (or its WMI class) to consume events.


Declaring Variables

To write an event consumer using WMI, you will need to obtain a locator object, a services object, an event object, and an object to represent a WMI class instance.

First, declare the variables, as shown in the following code:

Dim wbemLocat

Dim wbemSrvcs

Dim wbemEvent

Dim wbemObject

The locator object variable, wbemLocat, of type SwbemLocator, is used to connect to WMI. To connect to the "MicrosoftBizTalkServer" namespace under the Root namespace (Root/MicrosoftBizTalkServer), you set the services object variable, wbemSrvcs, of type SWbemServices. The event object variable, wbemEvent, of type SwbemEventSource, is needed to execute a query to receive events. To retrieve an event from the event query, you set the wbemObject variable of type SwbemObject.


Connecting to the Microsoft BizTalk Server Namespace

After you declare the variables, you need to retrieve the locator object. If you are using the scripting API, create a WbemScripting.SwbemLocator object, as shown in the following code:

Set wbemLocat = CreateObject("WbemScripting.SWbemLocator")

Note that the first step for any application using WMI is to retrieve a locator object. If you are using the DCOM interfaces in C/C++, you would retrieve an IWBEMLocator pointer by using the COCreateInstance method with the CLSID_WbemLocator class identifier, as shown in the following code:

IWbemLocator* piWMI = NULL;
HRESULT hr;

    hr = CoCreateInstance(
        CLSID_WbemLocator,
        NULL,
        CLSCTX_INPROC_SERVER,
        IID_IWbemLocator,
        (LPVOID*) &piWMI
    );

Using the locator object and the ConnectServer method, you can request a connection to the WMI service. The following code attempts to connect to WMI by specifying the Root namespace on the local computer. In the following code, replace the string "ComputerName" with the name of the server that publishes the event:

Set wbemSrvcs = wbemLocat.ConnectServer("ComputerName", "root\MicrosoftBizTalkServer")

If Err.number is equal to 0, then the connection to the WMI namespace is established. Specify both the computer name and the namespace; otherwise, if these fields are left blank, you will be connected to the default namespace on the local computer.

The returned SWbemServices object provides a communication path to the SQL Server database that is used to store administrative objects.


Creating the Event Object

Now that you have connected to the "MicrosoftBizTalkServer" namespace, you need to create the event object. The following code generates an event object to receive event notifications:

Set wbemEvent = wbemSrvcs.ExecNotificationQuery("Select * from DocSuspendedEvent")

The filter used in the SWbemServices.ExecNotificationQuery method call is "Select * from DocSuspendedEvent", which is written using WQL. Like SQL queries, WQL queries can be refined to return a specific set of properties, or a subset of instances that satisfy some criteria.

When the consumer submits this query, it requests to be notified of all occurrences of the event represented by the DocSuspendedEvent class. This request includes a request for notification on all of the event's system and nonsystem properties. When the event provider submits the query, it registers support for generating notifications whenever an event represented by the DocSuspendedEvent class occurs.


Monitoring Events

Now that you have created the event object for the DocSuspendedEvent class, you need to set up the mechanism to monitor events represented by that class. First, set wbemObject of type SWbemObject to Empty, as shown in the following code:

wbemObject = Empty

Then, if an event is available, the SWbemEventSource.NextEvent method retrieves the event from an event query, as shown in the following code:

Set wbemObject = wbemEvent.NextEvent(Timeout)

The SWbemObject object supports generic properties and methods that apply to all WMI objects, as well as exposing the properties and methods of the object as dynamic automation properties and methods of this object.

Use the following code to retrieve the globally unique identifier (GUID) for the item in the suspended queue event:

EventSuspendedQueueWaitForEvent = wbemObject.Properties_.Item("stringSuspendedGuid").Value

If the wbemObject is not set to Empty, then the GUID for the item in the Suspended queue event is retrieved; otherwise; a time-out error occurs while waiting for the Suspended queue event.

Note that stringSuspendedGuid is a property of the DocSuspendedEvent class. The Properties_ property returns an SWbemPropertySet object that is a collection of the properties for the current class or instance, in this case the DocSuspendedEvent class. The Item method then retrieves an SWbemProperty from the collection, in this case the stringSuspendedGuid property.

For more information about WMI Application Programming in BizTalk Server, see Handling WMI Errors.


Creating a Custom Counter Using WMI

This section shows the basic steps necessary to create a custom counter using organizations, and to perform a Tracking database query.

This section contains the following topics:

  • Declaring Variables

  • Setting the Security Level

  • Setting the Query Properties

  • Creating or Updating the Custom Counter

  • Validating the Custom Counter

  • Executing the Custom Counter Query

The code examples in this section use Microsoft Windows Instrumentation (WMI) and Microsoft Visual Basic script.

For an example of how to create a custom counter using qualifier and value pairs instead of organizations, see the Custom Counters sample.


Declaring Variables

To write a custom counter using WMI, define the following constants:

Const wbemChangeFlagUpdateOnly = 1

Const wbemChangeFlagCreateOnly = 2

Const CUSTCOUNTER_SETTING_NAMESPACE = "MSBTS_CustomCounterSetting"

In addition, you will need to obtain a locator object, a services (or namespace) object, and objects to represent WMI class instances.

Declare the variables, as shown in the following code:

Dim WBEMLocator

Dim WBEMNameSpace

Dim objCustomCounterFactory

Dim objCustomCounterSetting

Dim objCustomCounter


Setting the Security Level

Before setting the security level, you need to connect to the "MicrosoftBizTalkServer" namespace under the Root namespace (Root/MicrosoftBizTalkServer), as shown in the following code:

Set WBEMLocator = CreateObject("WbemScripting.SWbemLocator")

Set WBEMNameSpace = WBEMLocator.ConnectServer(, "root/MicrosoftBizTalkServer")

Then, set the security level for the namespace, as show in the following code:

WBEMNameSpace = GetObject("Winmgmts:{impersonationlevel=impersonate}!root/" & "MicrosoftBizTalkServer")


Setting the Query Properties

Before setting the query properties, you need to create a new instance of a custom counter setting class, as shown in the following code:

Set objCustomCounterFactory = WBEMNameSpace.Get(CUSTCOUNTER_SETTING_NAMESPACE)

Set objCustomCounterSetting = objCustomCounterFactory.SpawnInstance_

After the call to SpawnInstance_, objCustomCounterSetting contains an instance of MSBTS_CustomCounterSetting. This class is used to create, delete, and update custom counters.

In this example, the custom counter query is based on the source and destination organizations. To set the query properties, set the properties of the MSBTS_CustomCounterSetting instance, as shown in the following code:

objCustomCounterSetting.Name = "My Custom Counter"

objCustomCounterSetting.SrcOrgName = "SourceOrg"

objCustomCounterSetting.DestOrgName = "DestinationOrg

objCustomCounterSetting.DocType = "PORequest"

objCustomCounterSetting.TimeInterval = 300

objCustomCounterSetting.GroupName = "BizTalk Server Group"

So, the custom counter will count the number of documents passing from the source organization ("SourceOrg") to the destination organization ("DestinationOrg") using a document schema with the root element "PORequest". Also, note that the custom counter will only query the Tracking database for document entries from the previous 300 seconds.


Creating or Updating the Custom Counter

After setting the query properties, you should create or update the custom counter setting.

To create the custom counter setting, specify the wbemChangeFlagCreateOnly flag, as shown in the following code:

objCustomCounterSetting.Put_(wbemChangeFlagCreateOnly)

To update the custom counter setting, specify the wbemChangeFlagUpdateOnly flag, as shown in the following code:

objCustomCounterSetting.Put_(wbemChangeFlagUpdateOnly)

Note

  • When calling the Put_ method to create or update the custom counter setting, the wbemChangeFlagCreateOrUpdate flag is not supported. Instead, you must specify either wbemChangeFlagCreateOnly or wbemChangeFlagUpdateOnly, depending on whether you want to create or update the custom counter setting.


Validating the Custom Counter

After setting the query properties and creating or updating the custom counter, you should validate your custom counter.

You can validate on the following properties:

  • Source Organization

  • Source Organization Identifier

  • Destination Organization

  • Destination Organization Identifier

  • BizTalk Server Group

Note

  • The document type is not validated, because the value of the document type is not always known until the actual document is received.

Validate the custom counter settings, as shown in the following code:

objCustomCounterSetting.IsValid bSrcOrg, bSrcOrgId, bDestOrg, bDestOrgId, bGroup

As an example, you can use a message box to ensure that your query properties are valid, as shown in the following code:

WScript.Echo "ValidityCheck: " & vbCrLf & _

"SrcOrg " & CStr(bSrcOrg) & vbCrLf & _

"SrcId " & CStr(bSrcOrgId) & vbCrLf & _

"DestOrg " & CStr(bDestOrg) & vbCrLf & _

"DestId " & CStr(bDestOrgId) & vbCrLf & _

"Group " & CStr(bGroup)


Executing the Custom Counter Query

To execute the custom counter query, you need to retrieve an instance on the MSBTS_CustomCounter class. Since both the custom counter setting Name property and the custom counter Name property are key properties and share the same value, you can use their Name properties to retrieve the custom counter object, as shown in the following code:

Set objCustomCounter = WBEMNameSpace.Get("MSBTS_CustomCounter.Name=""" & _

objCustomCounterSetting.Name & """")

After retrieving the custom counter object, you can query the MatchCount property to view the results of the query, as shown in the following code:

WScript.Echo "Counter Information: " & objCustomCounter.Name & vbCrLf & _

"Matching Documents: " & objCustomCounter.MatchCount


Handling WMI Errors

This section uses Microsoft Visual Basic code to illustrate how to determine whether a WMI method returns an error, and if so, how to decipher the meaning of the error.

First, you declare two variables: an SWbemLastError object to contain and manipulate error objects, and an array of String objects to contain the numerical value, parameter information, and text description of the error, as shown in the following code:

Dim objWMIError As SWbemLastError

Dim strError(0 To 2) As String

To determine whether WMI raises an error, check the Err object. If the Err object is not equal to 0, then an error has been raised. Then, you can try to set the SWbemLastError object to a new instance.

Note that the TypeName function is used to return information about the objWMIError variable. If it is equal to Nothing, error information is not available, and the attempt to create the error object has failed.

If the call succeeds and an error object returns, the status of the object is reset and the members of the string array are set to meaningful values, as shown in the following code:

If Err <> 0 Then

strError(0) = Hex(Err.Number)

Set objWMIError = New SwbemLastError

If TypeName(objWMIError) <> "Nothing" Then

strError(1) = objWMIError.ParameterInfo

strError(2) = objWMIError.Description

Else

Err.Clear

strError(1) = ""

strError(2) = ""

End If

Else

strError(0) = 0

strError(1) = ""

strError(2) = ""

End If


BizTalk Server Developer's Toolbox

This section uses Microsoft® Visual Basic®, C++, and Visual Basic script to provide a toolbox of solutions to common tasks encountered by BizTalk Server developers. These code examples are provided without robust error-handling functionality and should serve as an introduction to designing your own tools when working with BizTalk Server.

These code examples should not be used in a production environment.

This section contains the following topics:

  • BizTalk Messaging Services Tasks

  • BizTalk Orchestration Services Tasks

  • BizTalk Managing and Monitoring Tasks

  • Miscellaneous Tasks

Note that some of these solutions are not specific to BizTalk Server.


BizTalk Messaging Services Tasks

This section contains the following topics:

  • Clear BizTalk Messaging Configurations

  • Update Messaging Configurations with ADO Objects


Clear BizTalk Messaging Configurations

The following code clears the BizTalk Messaging Management database.

This example ClearBTMConfigurations method is written in Microsoft Visual Basic.

Sub ClearBTMConfigurations()

First, declare the variables, as shown in the following declaration:

    Dim Configuration, Obj, CurrObj, HomeOrgID

To delete all existing configurations, create a configuration object to access the messaging objects, as shown in the following code:

    Set Configuration = CreateObject("BizTalk.BizTalkConfig")

Then, loop through and delete all existing channels, as shown in the following code:

    Set Obj = Configuration.CreateChannel
    Set CurrObj = Configuration.Channels

    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing port groups, as shown in the following code:

    Set Obj = Configuration.CreatePortGroup
    Set CurrObj = Configuration.PortGroups
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing ports, as shown in the following code:

    Set Obj = Configuration.CreatePort
    Set CurrObj = Configuration.Ports
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing envelopes, as shown in the following code:

    Set Obj = Configuration.CreateEnvelope
    Set CurrObj = Configuration.Envelopes
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing document definitions, as shown in the following code:

    Set Obj = Configuration.CreateDocument
    Set CurrObj = Configuration.Documents
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)
        Obj.Remove
        CurrObj.MoveNext
    Wend

Loop through and delete all existing organizations, as shown in the following code:

    Set Obj = Configuration.CreateOrganization
    Set CurrObj = Configuration.Organizations
    While Not CurrObj.EOF
        Obj.Load CurrObj(0)

Note the home (default) organization identifier, as shown in the following code:

        If Obj.IsDefault Then

Ensure that the home organization is not deleted and that it is saved for removing aliases, as shown in the following code.

            HomeOrgID = Obj.Handle
        ElseIf Obj.Name = "SEED Test Organization" Then

Do not perform any action at this point; only ensure that the SEED organization is not deleted.

        Else
            Obj.Remove
        End If

        CurrObj.MoveNext
    Wend

Clear the home organization aliases, except for the default alias and the alias with the organization name, as shown in the following code:

    Obj.load HomeOrgID
    Set CurrObj = Obj.Aliases

Then, reset the default alias, as shown in the following code:

    Obj.SaveAlias Obj.GetDefaultAlias, "sName" & Now(), False, "sQual" & Now(), "sValue" & Now()

    CurrObj.MoveFirst
    While Not CurrObj.EOF
        If CurrObj("qualifier") = "OrganizationName"  Then
            Obj.SaveAlias CurrObj(0), "Organization", True, "OrganizationName", Obj.Name
            Obj.Save
        Else

        If CurrObj("qualifier") <> "SMTP" then Obj.RemoveAlias CurrObj(0)
        End If

        CurrObj.MoveNext
    Wend

Loop through and delete all existing home organization applications, as shown in the following code:

    Set CurrObj = Obj.Applications
    While Not CurrObj.EOF
        Obj.RemoveApplication CurrObj("id")
        CurrObj.MoveNext
    Wend

    Obj.save

Finally, set all objects to Nothing to release memory back to the system, as shown in the following code:

    Set Obj = Nothing
    Set CurrObj = Nothing
    Set Configuration = Nothing
End Sub


Update Messaging Configurations with ADO Objects

The following code uses the Microsoft ActiveX® Data Objects (ADO) returned by the BizTalk Messaging Configuration object model to select a subset of existing channels, and to modify the configurations of those channels. In this sample, all existing channels using an input document definition name of "Invoice" will be selected, their RetryCount property will be updated to six retries, and their RetryInterval property will be set to ten minutes.

This example UpdateRetry method is written in Microsoft Visual Basic Scripting Edition (VBScript).

Sub UpdateRetry()

First, declare the variables, as shown in the following declaration:

    Dim objConfig
    Dim objChannel
    Dim objDoc
    Dim objADO

Then, create the channel and document objects, as shown in the following code:

    Set objConfig = CreateObject("BizTalk.BizTalkConfig")
    Set objChannel = objConfig.CreateChannel
    Set objDoc = objConfig.CreateDocument

Obtain a reference to the Channels recordset containing all existing channels in the BizTalk Messaging Management database, as shown in the following code:

    Set objADO = objConfig.Channels

Loop through all records in the recordset and load each channel by using the Handle provided in the first field of the record. Load the InputDocument associated with each channel to obtain the document definition name, and compare it to the string "Invoice" to select the appropriate records. When a record is selected, update the RetryCount and RetryInterval properties and Save the new channel configuration. This logic is shown in the following code:

    Do While NOT objADO.EOF
        objChannel.Load(objADO.Fields.Item(0))
        objDoc.Load(objChannel.InputDocument)
        If objDoc.Name = "Invoice" Then
            objChannel.RetryCount = 6
            objChannel.RetryInterval = 10
            objChannel.Save
        End If
        objADO.MoveNext
    Loop

Finally, set all objects to Nothing to release memory back to the system, as shown in the following code:

    Set objChannel = Nothing
    Set objConfig = Nothing
    Set objDoc = Nothing
    Set objADO = Nothing
End Sub


BizTalk Orchestration Services Tasks

This section contains the following topic:

  • Access a Messaging Port


Access a Messaging Port

The following code accesses a messaging port in an XLANG schedule instance:

This example is in Microsoft Visual Basic:

Dim oSked As IWFWorkflowInstance
Dim oPort

Set oSked = GetObject("sked://localhost/C:\temp\MySchedule.skx")
Set oPort = oSked.Port("PortIn")

This example is in VBScript:

Set oSked = GetObject("sked://localhost/C:\temp\MySchedule.skx")
Set oPort = oSked.Port("PortIn")


BizTalk Managing and Monitoring Tasks

This section contains the following topic:

  • WMI Tasks


WMI Tasks

To ensure that your Visual Basic projects can access the Windows® Management Instrumentation (WMI) objects used in the following topics, you need to add the Microsoft WMI Scripting V1.1 Library in the Reference dialog.

Then, you declare the following WMI locator and services variables:

Public g_objLocator As SWbemLocator
Public g_objService As SWbemServices

In addition, the following constants should be defined:

Public Const GROUP_NAMESPACE = "MicrosoftBizTalkServer_Group"
Public Const MGMT_NAMESPACE = "MicrosoftBizTalkServer_MgmtDB"
Public Const SERVER_NAMESPACE = "MicrosoftBizTalkServer_Server"
Public Const RECVSVC_NAMESPACE = "MicrosoftBizTalkServer_ReceiveFunction"
Public Const QUEUE_NAMESPACE = "MicrosoftBizTalkServer_Queue"
Public Const WORKQ_NAMESPACE = "MicrosoftBizTalkServer_WorkQueue"
Public Const SCHEDULEDQ_NAMESPACE = "MicrosoftBizTalkServer_ScheduledQueue"
Public Const RETRYQ_NAMESPACE = "MicrosoftBizTalkServer_RetryQueue"
Public Const SUSPENDEDQ_NAMESPACE = "MicrosoftBizTalkServer_SuspendedQueue"

You make the connection to WMI with the following code:

Set g_objLocator = New SWbemLocator
Set g_objService = g_objLocator.ConnectServer(, "root/MicrosoftBizTalkServer")

This section contains the following topics:

  • Documents and WMI

  • Groups and WMI

  • BizTalk Messaging Management Database and WMI

  • Receive Services and WMI

  • Servers and WMI

  • Queues and WMI


Documents and WMI

The code examples in this section are useful when working with documents and interchanges. An interchange is a collection of one or more document instances that makes up a single transmission.

This section presents functions that work together to convert variant data from a document or interchange into a string.

This section contains the following topic:

  • Displaying the Contents of a Document or an Interchange


Displaying the Contents of a Document or an Interchange

When you use the ViewDocument or ViewInterchange methods of the MicrosoftBizTalkServer_SuspendedQueue class, you might need to convert the returned byte array into a readable format.

The following function takes a code page and variant data and returns a string:

Function ConvertViewDocument(ByVal varData As Variant, ByVal codepage As Long) As String
    Dim varData2() As Byte
    Dim i As Long
    Dim strTemp As String
    Dim Dom As New DOMDocument

    On Error Resume Next
    ReDim varData2(UBound(varData))
    For i = LBound(varData) To UBound(varData)
        varData2(i) = varData(i)
        Next

    If codepage = -1 Then
        strTemp = CStr(varData2)
        Call Dom.loadXML(strTemp)
        If Err <> 0 Then
            ConvertViewDocument = ""
        ElseIf Dom.parseError.errorCode <> 0 Then
            ConvertViewDocument = ""
        Else
            ConvertViewDocument = Dom.xml
        End If
    Else
        ConvertViewDocument = ConvertVarToBstr(varData2, codepage)
    End If
End Function

The ConvertViewDocument function uses the following function to convert the variant data into a string:

Public Function ConvertVarToBstr(ByRef varData As Variant, ByVal strCodePage As String) As String
    Dim stm As New ADODB.Stream

    Select Case UCase(TypeName(varData))
        Case "STRING"
            ConvertVarToBstr = varData
        Case "BYTE()"
            stm.Type = adTypeBinary
            stm.Open
            stm.Write varData
            stm.Position = 0
            stm.Type = adTypeText
            stm.Charset = GetCharset(strCodePage)
            ConvertVarToBstr = stm.ReadText
            .Close
        Case Else
            ConvertVarToBstr = ""
    End Select
End Function

The ConvertVarToBstr function uses the following private function to return a character set:

Private Function GetCharset(ByVal codepage As String)
    Select Case codepage
        Case 932
            GetCharset = "shift-jis"
        Case 1252
            GetCharset = "us-ascii"
        Case 160001
            GetCharset = "utf-8"
        Case 1200
            GetCharset = "unicode"
    End Select
End Function


Groups and WMI

The code examples in this section are useful when working with groups. Server groups are collections of individual servers that are centrally managed, configured, and monitored.

This section presents functions that create a group, delete a group, retrieve a group by name, and retrieve all groups.

This section contains the following topics:

  • Creating a Group

  • Deleting a Group

  • Retrieving a Group by Name

  • Retrieving All Groups


Creating a Group

The following function creates a group:

Public Function CreateGroup(ByVal strGroupName As String, _
                ByVal strDocTrackDbLogon As String, _
                ByVal strDocTrackDbName As String, _
                ByVal strDocTrackDbPassword As String, _
                ByVal strDocTrackDbServer As String, _
                ByVal strQueueDbLogon As String, _
                ByVal strQueueDbName As String, _
                ByVal strQueueDbPassword As String, _
                ByVal strQueueDbServer As String, _
                Optional ByVal lAdminCacheRefreshInterval As Long, _
                Optional ByVal strSMTPHost As String, _
                Optional ByVal strReliableMessagingReplyToURL As String, _
                Optional UseProxyServer As Boolean, _
                Optional strProxyName As String, _
                Optional lProxyport As Long, _
                Optional lLoggingPointState As Integer) As Boolean
    Dim objBTGroup As SWbemObject
    Dim objBTGroupInstance As SWbemObject

    On Error Resume Next
    Set objBTGroup = g_objService.Get(GROUP_NAMESPACE)
    Set objBTGroupInstance = objBTGroup.SpawnInstance_

    CreateGroup = True

    objBTGroupInstance.Name = strGroupName
    objBTGroupInstance.DocTrackDbLogon = strDocTrackDbLogon
    objBTGroupInstance.DocTrackDbName = strDocTrackDbName
    objBTGroupInstance.DocTrackDbPassword = strDocTrackDbPassword
    objBTGroupInstance.DocTrackDbServer = strDocTrackDbServer
    objBTGroupInstance.QueueDbLogon = strQueueDbLogon
    objBTGroupInstance.QueueDbName = strQueueDbName
    objBTGroupInstance.QueueDbPassword = strQueueDbPassword
    objBTGroupInstance.QueueDbServer = strQueueDbServer

    If strReliableMessagingReplyToURL <> "" Then
        objBTGroupInstance.ReliableMessagingReplyToURL = strReliableMessagingReplyToURL
    End If
    If lAdminCacheRefreshInterval <> 0 Then
        objBTGroupInstance.ConfigurationCacheRefreshInterval = lAdminCacheRefreshInterval
    End If

    objBTGroupInstance.UseProxyServer = UseProxyServer
    objBTGroupInstance.ProxyHost = strProxyName

    If lProxyport = 0 Then
        objBTGroupInstance.ProxyPort = lProxyport
    Else
        objBTGroupInstance.ProxyPort = lProxyport
    End If

    objBTGroupInstance.LoggingPointState = lLoggingPointState
    objBTGroupInstance.SMTPHost = strSMTPHost
    objBTGroupInstance.Put_ (wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateGroup = False
    End If
End Function


Deleting a Group

The following function deletes a group:

Public Function DeleteGroup(ByVal strGroupName As String) As Boolean
    On Error Resume Next
    DeleteGroup = True
    Call g_objService.Delete(GROUP_NAMESPACE & ".NAME=""" & strGroupName & """")

    If Err <> 0 Then
        DeleteGroup = False
    End If
End Function


Retrieving a Group by Name

The following function retrieves a group by name:

Public Function GetGroupByName(ByVal strGroupName As String) As Object
    Dim objBTGroup As SwbemObject

    On Error Resume Next
    Set GetGroupByName = Nothing
    Set GetGroupByName = g_objService.Get(GROUP_NAMESPACE & ".NAME=""" & strGroupName & """")

    If Err <> 0 Then
    End If
End Function


Retrieving All Groups

The following function retrieves all groups:

Public Function GetAllGroups() As SWbemObjectSet
    Dim objBTGroup As SWbemObject

    On Error Resume Next
    Set GetAllGroups = Nothing
    Set objBTGroup = g_objService.Get(GROUP_NAMESPACE)
    Set GetAllGroups = objBTGroup.Instances_

    If Err <> 0 Then
    End If
End Function


BizTalk Messaging Management Database and WMI

The code examples in this section are useful when working with the BizTalk Messaging Management database. The BizTalk Messaging Management database stores information for all server configurations, including group and server settings, and receive functions.

This section presents functions that create the BizTalk Messaging Management database and retrieve the BizTalk Messaging Management database.

This section contains the following topics:

  • Creating the BizTalk Messaging Management Database

  • Retrieving the BizTalk Messaging Management Database


Creating the BizTalk Messaging Management Database

The following function creates the BizTalk Messaging Management database:

Public Function CreateMgmtDB(ByVal strMgmtDbLogon As String, _
                            ByVal strMgmtDBPassword As String, _
                            ByVal strMgmtDBServer As String, _
                            ByVal strMgmtDBDatabase As String, _
                            ByVal strLocalServer As String) As Boolean
    Dim objBTSMgmt As SWbemObject
    Dim objBTSMgmtInstance As SwbemObject

    On Error Resume Next
    CreateMgmtDB = True
    Set objBTSMgmt = g_objService.Get(GROUP_NAMESPACE)
    Set objBTSMgmtInstance = objBTGroup.SpawnInstance_
        objBTSMgmtInstance.MgmtDbLogon = strMgmtDbLogon
        objBTSMgmtInstance.MgmtDBPassword = strMgmtDBPassword
        objBTSMgmtInstance.MgmtDbServer = strMgmtDBServer
        objBTSMgmtInstance.MgmtDbDatabase = strMgmtDBDatabase
        objBTSMgmtInstance.localserver = strLocalServer
        objBTSMgmtInstance.Put_ (wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateMgmtDB = False
    End If
End Function


Retrieving the BizTalk Messaging Management Database

The following function retrieves the BizTalk Messaging Management database:

Public Function GetMgmtDB(ByVal strLocalServer As String) As SWbemObject
    Dim objBTSMgmt As SWbemObject
    Dim objSet_BTSMgmt As SWbemObjectSet
    Dim objBTSMgmtInstance As SWbemObject

    On Error Resume Next
    Set GetMgmtDB = Nothing
    Set objBTSMgmt = g_objService.Get(MGMT_NAMESPACE)
    Set objSet_BTSMgmt = objBTSMgmt.Instances_

    If objSet_BTSMgmt.Count <> 1 Then
        Exit Function
    End If

    Set GetMgmtDB = objSet_BTSMgmt.Item(MGMT_NAMESPACE & ".LocalServer=""" & strLocalServer & """")
End Function


Receive Services and WMI

The code examples in the section are useful when working with receive services. You create receive services to process data.

This section presents functions that create a File receive service, delete a File receive service, retrieve a receive service by name, retrieve all receive services, and retrieve all receive services by group.

This section contains the following topics:

  • Creating a File Receive Service

  • Deleting a File Receive Service

  • Retrieving a Receive Service by Name

  • Retrieving All Receive Services

  • Retrieving All Receive Services by Group


Creating a File Receive Service

The following function creates a File receive service:

Public Function CreateReceiveService(ByVal strRecvSvcName As String, _
                        ByVal strGroupName As String, _
                        ByVal strProcessingServer As String, _
                        ByVal strFileMask As String, _
                        ByVal fProtocolType As ProtocolType, _
                        ByVal strPollingLoc As String, _
                        Optional ByVal strPassword As String, _
                        Optional ByVal strUsername As String, _
                        Optional ByVal strDocumentName As String, _
                        Optional ByVal strSourceID As String, _
                        Optional ByVal strSourceQualifier As String, _
                        Optional ByVal strDestinationID As String, _
                        Optional ByVal strDestinationQualifier As String, _
                        Optional ByVal lOpenness As Integer, _
                        Optional ByVal lPassthrough As Integer, _
                        Optional ByVal strChannelName As String, _
                        Optional fDisabled As Boolean, _
                        Optional ByVal strEnvelopeName As String, _
                        Optional ByVal strComment As String, _
                        Optional ByVal strPreProcessor As String) As Boolean
    Dim objBTSRecvSvc As SWbemObject
    Dim objBTSRecvSvcInstance As SWbemObject

    On Error Resume Next
    CreateReceiveService = True
    Set objBTSRecvSvc = g_objService.Get(RECVSVC_NAMESPACE)
    Set objBTSRecvSvcInstance = objBTSRecvSvc.SpawnInstance_

        objBTSRecvSvcInstance.Name = strRecvSvcName
        objBTSRecvSvcInstance.groupName = strGroupName
        objBTSRecvSvcInstance.Comment = strComment
        objBTSRecvSvcInstance.FilenameMask = strFileMask
        objBTSRecvSvcInstance.ProcessingServer = strProcessingServer
        objBTSRecvSvcInstance.ProtocolType = fProtocolType
        objBTSRecvSvcInstance.PollingLocation = strPollingLoc
        objBTSRecvSvcInstance.password = strPassword
        objBTSRecvSvcInstance.UserName = strUsername
        objBTSRecvSvcInstance.DocumentName = strDocumentName
        objBTSRecvSvcInstance.SourceID = strSourceID
        objBTSRecvSvcInstance.SourceQualifier = strSourceQualifier
        objBTSRecvSvcInstance.DestinationID = strDestinationID
        objBTSRecvSvcInstance.DestinationQualifier = strDestinationQualifier
        objBTSRecvSvcInstance.EnvelopeName = strEnvelopeName
        objBTSRecvSvcInstance.DisableReceiveFunction = fDisabled
        objBTSRecvSvcInstance.PreProcessor = strPreProcessor

    If lOpenness <> 0 Then
        objBTSRecvSvcInstance.OpennessFlag = lOpenness
    End If

    If lPassthrough <> 0 Then
        objBTSRecvSvcInstance.IsPassThrough = lPassthrough
    End If

    If strChannelName <> "" Then
        objBTSRecvSvcInstance.ChannelName = strChannelName
    End If

        objBTSRecvSvcInstance.Put_ (wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateReceiveService = False
    End If
End Function


Deleting a File Receive Service

The following function deletes a File receive service:

Public Function DeleteReceiveSvc(ByVal strRecvSvcName As String) As Boolean
    On Error Resume Next
    DeleteReceiveSvc = True
    Call g_objService.Delete(RECVSVC_NAMESPACE & ".NAME=""" & strRecvSvcName & """")

    If Err <> 0 Then
        DeleteReceiveSvc = False
    End If
End Function


Retrieving a Receive Service by Name

The following function retrieves a receive service by name:

Public Function GetReceiveFunctionByName(ByVal strRecvFunction As String) As SWbemObject
    On Error Resume Next
    Set GetReceiveFunctionByName = Nothing
    Set GetReceiveFunctionByName = g_objService.Get(RECVSVC_NAMESPACE & ".NAME=""" & strRecvFunction & """")

    If Err <> 0 Then
    End If
End Function


Retrieving All Receive Services

The following function retrieves all receive services:

Public Function GetAllReceiveServices() As SWbemObjectSet
    Dim objBTSRecvSvc As SWbemObject

    On Error Resume Next
    Set GetAllReceiveServices = Nothing
    Set objBTSRecvSvc = g_objService.Get(RECVSVC_NAMESPACE)
    Set GetAllReceiveServices = objBTSRecvSvc.Instances_

    If Err <> 0 Then
    End If
End Function


Retrieving All Receive Services by Group

The following function retrieves all receive services by group:

Public Function GetAllReceiveSvcsByGroup(ByVal strGroupName As String)
    Dim strWMIQuery As String

    On Error Resume Next
    strWMIQuery = "select * from " & RECVSVC_NAMESPACE & " where groupname= '" & strGroupName & "'"
    Set GetAllReceiveSvcsByGroup = g_objService.ExecQuery(strWMIQuery)

    If Err <> 0 Then
    End If
End Function


Servers and WMI

The code examples in this section are useful when working with servers. A server in a server group hosts the appropriate BizTalk Messaging Services functionality to manage document exchange between other servers and applications that are external to the BizTalk Server group.

This section presents functions that create a server, delete a server, start a server, stop a server, retrieve a server by name, retrieve all servers, and retrieve all servers by group.

This section contains the following topics:

  • Creating a Server

  • Deleting a Server

  • Starting a Server

  • Stopping a Server

  • Retrieving a Server by Name

  • Retrieving All Servers

  • Retrieving All Servers by Group


Creating a Server

The following function creates a server:

Public Function CreateServer(ByVal strServerName As String, _
                        ByVal strGroupName As String, _
                        ByVal lMaxWorkerThreadsPerProcessor As Long, _
                        ByVal lSchedulerWaitTime As Double) As Boolean
    Dim objBTSSvr As SWbemObject
    Dim objBTSSvrInstance As SWbemObject

    On Error Resume Next
    CreateServer = True
    Set objBTSSvr = g_objService.Get(SERVER_NAMESPACE)
    Set objBTSSvrInstance = objBTSSvr.SpawnInstance_

        objBTSSvrInstance.Name = strServerName
        objBTSSvrInstance.groupName = strGroupName
        objBTSSvrInstance.MaxWorkerThreadsPerProcessor = lMaxWorkerThreadsPerProcessor
        objBTSSvrInstance.SchedulerWaitTime = lSchedulerWaitTime

    Call objBTSSvrInstance.Put_(wbemChangeFlagCreateOnly)

    If Err <> 0 Then
        CreateServer = False
    End If
End Function


Deleting a Server

The following function deletes a server:

Public Function DeleteServer(ByVal strServerName As String) As Boolean
    On Error Resume Next
    DeleteServer = True
    Call g_objService.Delete(SERVER_NAMESPACE & ".NAME=""" & strServerName & """")

    If Err <> 0 Then
        DeleteServer = False
    End If
End Function


Starting a Server

The following function starts a server:

Public Function StartServer(ByVal strServerName As String) As Boolean
    Dim strWMIPath As String
    Dim objBTSSvrs As SWbemObject

    On Error Resume Next
    StartServer = True
    strWMIPath = SERVER_NAMESPACE & ".NAME=""" & strServerName & """"
    Set objBTSSvrs = g_objService.ExecMethod(strWMIPath, "StartServer")

    If Err <> 0 And Hex(Err) <> "80070420" Then
        StartServer = False
    Else
        Err.Clear
    End If
End Function

Note that if Err is not equal to 0, and the hexadecimal value of the error is not equal to 80070420, then the service was already running.


Stopping a Server

The following function stops a server:

Public Function StopServer(ByVal strServerName As String) As Boolean
    Dim strWMIPath As String
    Dim objBTSSvrs As SWbemObject

    On Error Resume Next
    StopServer = True
    strWMIPath = SERVER_NAMESPACE & ".NAME=""" & strServerName & """"
    Set objBTSSvrs = g_objService.ExecMethod(strWMIPath, "StopServer")

    If Err <> 0 And Hex(Err) <> "80070426" Then
        StopServer = False
    Else
        Err.Clear
    End If
End Function

Note that if Err is not equal to 0, and the hexadecimal value of the error is not equal to 80070426, then the service was not running.


Retrieving a Server by Name

The following function retrieves a server by name:

Public Function GetServerByName(ByVal strServerName As String) As SWbemObject
    On Error Resume Next
    Set GetServerByName = Nothing
    Set GetServerByName = g_objService.Get(SERVER_NAMESPACE & ".NAME=""" & strServerName & """")
End Function


Retrieving All Servers

The following function retrieves all servers:

Public Function GetAllServers() As SWbemObjectSet
    Dim objBTSSvrs As SWbemObject

    On Error Resume Next
    Set objBTSSvrs = g_objService.Get(SERVER_NAMESPACE)
    Set GetAllServers = objBTSSvrs.Instances_
End Function


Retrieving All Servers by Group

The following function retrieves all servers by group:

Public Function GetAllServersByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Dim strWMIQuery As String

    On Error Resume Next
    strWMIQuery = "select * from " & SERVER_NAMESPACE & " where groupname= '" & strGroupName & "'"
    Set GetAllServersByGroup = g_objService.ExecQuery(strWMIQuery)
End Function


Queues and WMI

The code examples in this section are useful when working with queues. Queues are used to contain incoming and outgoing documents that are in various stages of routing and processing in BizTalk Server.

This section presents functions that retrieve queues by group and retrieve all queues.

This section contains the following topics:

  • Retrieving Queues by Group

  • Retrieving All Queues


Retrieving Queues by Group

This section illustrates functions that retrieve the Work, Retry, Suspended, or Scheduled queue by group.

The Work queue contains documents that are currently being processed by BizTalk Server. The following function retrieves the Work queue by group:

Public Function GetWorkQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetWorkQByGroup = GetXXXXQByGroup(strGroupName, WORKQ_NAMESPACE)
End Function

The Retry queue contains documents that are being resubmitted for delivery and documents that are waiting for reliable messaging receipts. The following function retrieves the Retry queue by group:

Public Function GetRetryQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetRetryQByGroup = GetXXXXQByGroup(strGroupName, RETRYQ_NAMESPACE)
End Function

The Suspended queue contains work items that have failed processing for a variety of reasons, including parsing errors, serialization errors, and failed transmissions. The following function retrieves the Suspended queue by group:

Public Function GetSuspendedQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetSuspendedQByGroup = GetXXXXQByGroup(strGroupName, SUSPENDEDQ_NAMESPACE)
End Function

The Scheduled queue contains work items that have been processed by BizTalk Server and are waiting for transmission. The following function retrieves the Scheduled queue by group:

Public Function GetScheduledQByGroup(ByVal strGroupName As String) As SWbemObjectSet
    Set GetScheduledQByGroup = GetXXXXQByGroup(strGroupName, SCHEDULEDQ_NAMESPACE)
End Function

The following helper function is used by the previous functions to retrieve a given queue by group:

Public Function GetXXXXQByGroup(ByVal strGroupName As String, ByVal QueueNameSpace As String) As SWbemObjectSet
    Dim strWMIQuery As String

    On Error Resume Next
    strWMIQuery = "select * from " & QueueNameSpace & " where group= """ & strGroupName & """"
    Set GetXXXXQByGroup = g_objService.ExecQuery(strWMIQuery)
End Function


Retrieving All Queues

The following function retrieves all queues:

Public Function GetAllQueues() As SWbemObjectSet
    Dim objBTQueue As SWbemObject

    On Error Resume Next
    Set GetAllQueues = Nothing
    Set objBTQueue = g_objService.Get(QUEUE_NAMESPACE)
    Set GetAllQueues = objBTQueue.Instances_
End Function


Miscellaneous Tasks

This section contains the following topics:

  • Determine if BizTalk Server is Installed

  • Modify the XML Encoding

  • Retrieve BizTalk Server Product Information

  • Validate an XML Document


Determine if BizTalk Server is Installed

The following code determines if BizTalk Server is installed on the local machine.

Dim objService, objLocator, objConfig, strGroupName

Set objLocator = CreateObject("WbemScripting.SWbemLocator")

On Error Resume Next
Set objService = objLocator.ConnectServer(, "root/MicrosoftBizTalkServer")

PassFail "Unable to connect to BizTalk Server. Please verify that your BizTalk " & "Server is installed and functions properly."

Sub PassFail(strScope)
    If Err.Number <> 0 Then

MsgBox strScope & " Error: x" & Hex(Err.Number) & " Description: " & Err.Description & " Source: " & Err.Source

        Err.Clear
    Else

MsgBox "BizTalk Server appears to be installed."

    End If
End Sub


Modify the XML Encoding

BizTalk Server uses UTF-8 encoding in XML output files by default. Use the following Microsoft Visual Basic Scripting Edition (VBScript) code to specify a different encoding type:

set xmlObj = CreateObject("MSXML2.DomDocument.3.0")
wscript.echo wscript.arguments(1)

if wscript.arguments.count < 2 then
    wscript.echo "Usage: encoding.vbs XMLDocument Encoding"
    wscript.quit
end if

if xmlobj.load(wscript.arguments(0)) = False then
    wscript.echo "Unable to load the XML document."
    wscript.Echo "Error: " + xmlobj.ParseError.Reason + "Line: " + CStr(xmlobj.ParseError.Line)
    wscript.quit
end if

if (xmlObj.firstChild.nodeType = 7) and (xmlObj.firstChild.nodeName = "xml") then
    set child = xmlObj.firstChild
    xmlObj.removeChild child
end if

set pi = xmlObj.createProcessingInstruction("xml","version='1.0' encoding='" & wscript.arguments(1) & "'")
xmlObj.insertBefore pi, xmlObj.firstChild
xmlObj.save "newxml.xml"
wscript.echo "Done"

Notes

  • The "Usage" statement assumes that the script file containing this code is named encoding.vbs.

  • The first argument is the name of the XML document to be modified.

  • The second argument is a valid XML encoding value.

  • A new, modified version of the input XML file is created in the same folder with the name newxml.xml.

To run this script, open a Command Prompt window and use the following syntax:

C:\ > wscript encoding.vbs file.xml enctype

Where file.xml is the name of the XML file to be converted, and enctype is the encoding type to be used in the XML file.

To use this code with XML files created by BizTalk Server, you can create an application integration component (AIC) that incorporates similar XML document object model code. If you prefer to manually edit the file or run the script shown above, you can use the file transport protocol on the port to create the XML files to be converted.

Related Topics

Application Integration Components

Specify a transport address


Retrieve BizTalk Server Product Information

The following VBScript example uses the Microsoft Windows Installer Object Library to obtain information about BizTalk Server. In a Microsoft Visual Basic project, use the Microsoft Windows Installer Object Library (\system32\msi.dll).

Public objInstaller
Const gstrProductName = "Microsoft BizTalk Server 2002"

Sub Main()
    Dim guidProductCode

        On Error Resume Next
        Set objInstaller = CreateObject("WindowsInstaller.Installer")
        guidProductCode = GetProductGuid(gstrProductName)
        Wscript.echo "PRODUCT INFORMATION" & vbNewLine & vbNewLine & GetProductInfo(guidProductCode)
End Sub

Function GetProductGuid(sProductName)
    Dim sName
    Dim guidProductCode

        On Error Resume Next
        GetProductGuid = ""

        For Each guidProductCode In objInstaller.Products
            sName = objInstaller.ProductInfo(guidProductCode, "ProductName")

            If (LCase(sProductName) = LCase(sName)) Then
                GetProductGuid = CStr(guidProductCode)
                Exit For
            End If
        Next
End Function

Function GetProductInfo(guidProductCode)
    Dim s

    On Error Resume Next
    s = "ProductInfo for " & guidProductCode & vbNewLine
    s = s & vbNewLine
    s = s & "InstalledProductName: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstalledProductName") & vbNewLine
    s = s & "VersionString: " & vbTab & objInstaller.ProductInfo(guidProductCode, "VersionString") & vbNewLine
    s = s & "HelpLink:      " & vbTab & objInstaller.ProductInfo(guidProductCode, "HelpLink") & vbNewLine
    s = s & "HelpTelephone: " & vbTab & objInstaller.ProductInfo(guidProductCode, "HelpTelephone") & vbNewLine
    s = s & "InstallLocation: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstallLocation") & vbNewLine
    s = s & "InstallSource: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstallSource") & vbNewLine
    s = s & "InstallDate: " & vbTab & objInstaller.ProductInfo(guidProductCode, "InstallDate") & vbNewLine
    s = s & "Publisher: " & vbTab & objInstaller.ProductInfo(guidProductCode, "Publisher") & vbNewLine
    s = s & "LocalPackage: " & vbTab & objInstaller.ProductInfo(guidProductCode, "LocalPackage") & vbNewLine
    s = s & "URLInfoAbout: " & vbTab & objInstaller.ProductInfo(guidProductCode, "URLInfoAbout") & vbNewLine
    s = s & "URLUpdateInfo: " & vbTab & objInstaller.ProductInfo(guidProductCode, "URLUpdateInfo") & vbNewLine
    s = s & "VersionMinor: " & vbTab & objInstaller.ProductInfo(guidProductCode, "VersionMinor") & vbNewLine
    s = s & "VersionMajor: " & vbTab & objInstaller.ProductInfo(guidProductCode, "VersionMajor") & vbNewLine
    s = s & vbNewLine
    s = s & "Transforms: " & vbTab & objInstaller.ProductInfo(guidProductCode, "Transforms") & vbNewLine
    s = s & "Language: " & vbTab & objInstaller.ProductInfo(guidProductCode, "Language") & vbNewLine
    s = s & "ProductName: " & vbTab & objInstaller.ProductInfo(guidProductCode, "ProductName") & vbNewLine
    s = s & "AssignmentType: " & vbTab & objInstaller.ProductInfo(guidProductCode, "AssignmentType") & vbNewLine
    s = s & "PackageCode: " & vbTab & objInstaller.ProductInfo(guidProductCode, "PackageCode") & vbNewLine
    s = s & "Version:        " & vbTab & objInstaller.ProductInfo(guidProductCode, "Version") & vbNewLine
    s = s & "ProductIcon: " & vbTab & objInstaller.ProductInfo(guidProductCode, "ProductIcon") & vbNewLine
    GetProductInfo = s
End Function

Main


Validate an XML Document

The following code validates an XML document:

Dim xmlDoc As New Msxml2.DOMDocument

    xmlDoc.async = False
    xmlDoc.validateOnParse = True
    xmlDoc.Load "myXML.xml"


BizTalk Server Samples

Samples provided in the BizTalk Server SDK are located in the folder \Program Files\Microsoft BizTalk Server\SDK on the installation drive. These samples should not be used in a production environment.

Sample Requirements

The samples provided with BizTalk Server require one or more of the following applications:

  • Microsoft Visual Basic® is necessary to modify and compile the Visual Basic source files, such as .vbp files, that are included in the SDK. The Visual Basic runtime, VB6.exe, is also needed to run some of the executable files included in the SDK.

  • A compiler and source code editor, such as Microsoft Visual C++®, is necessary to modify and compile the C++ source files.

  • Microsoft Word or Wordpad is necessary to view some of the readme files that use a .doc file type extension.

  • An HTML browser, such as Microsoft Internet Explorer, is necessary to view some of the readme files that use an .htm file type extension.

This section contains the following topics:

  • BizTalk Messaging Services Code Samples

  • BizTalk Orchestration Services Code Samples

E-Procurement Sample


BizTalk Messaging Services Code Samples

Sample files are located in the Messaging Samples folder on the Microsoft BizTalk Server installation drive. Browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples on the installation drive to find the sample files. This is only a relative path. Depending on your installation of BizTalk Server 2002, you might need to modify this path.

  • Application Integration in Visual Basic

  • Application Integration in Visual C++

  • BizTalk Framework Developers' Toolkit

  • Configuration Assistant

  • Custom Counters

  • Custom Import Module

  • Custom Preprocessor in Visual Basic

  • Custom Preprocessor in Visual C++

  • Date Functoid

  • Date Functoid with .NET

  • Direct Integration

  • Distribution List

  • EDI and Receipts

  • EDI Introduction

  • Encryption and Decryption

  • Flat-File Delimited

  • Flat-File Positional

  • HTTP Receive Function

  • Mapping Twice

  • Message Queuing 4 MB Limit

  • Multi-part MIME Attachment

  • Pipeline Component in Visual Basic

  • Pipeline Component in Visual C++

  • Queue Sniffer

  • Receive Scripts

  • Refresh Messaging Manager

  • Reliable Messaging

  • Self Routing

  • Send To Remote Queue

  • Submitting Documents

  • Submitting Documents with Receipts

  • Submitting Documents to a Port Group

  • Suspended Queue Monitoring

  • Synchronous Orchestration Component

  • Tracking Database Tasks

  • Windows Management Instrumentation

Notes

  • When using C++, you need to add \Program Files\Microsoft BizTalk Server\SDK\Include to the include directory list.

  • Some of the samples have a dependency on the Pipecomplib.tlb file. For these samples, you need to add \Program Files\Common Files\Microsoft Shared\Enterprise Servers\Commerce to the include directory list.


Application Integration in Visual Basic

This sample demonstrates an application integration component (AIC) that implements the IBTSAppIntegration interface. The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the BizTalk Server WebDAV repository), instantiates a schedule (provided with this sample) and passes the document to the schedule. The schedule gets the document and sends it to the file C:\temp\WFOut.txt.

For a related sample, see Application Integration in Visual C++.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTSAppIntegration\VB

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual Basic component (this is optional because the DLL is provided with the sample).

  2. Register the component, its category IDs, and its setup configuration by running the script:

    cscript scenario.wsf //job:setup

    When prompted whether to register information from Affinity.reg, click Yes. The component progid is "BTSSamples_IBTSAppInt_VB AIC2Sched".

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_AIC2Sched" by using the script:

    cscript scenario.wsf //job:submit

    If the submission succeeds, the document appears in C:\temp\WFOut.txt.


Application Integration in Visual C++

This sample demonstrates an application integration component (AIC) that implements the IBTSAppIntegration interface by using the Active Template Library (ATL). The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the BizTalk Server WebDAV repository) and returns the first element of the document.

For a related sample, see Application Integration in Visual Basic.

Note

  • This sample requires the Microsoft XML Parser (MSXML) version 3.0 or higher.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTSAppIntegration\VC\ATL

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual C++ component.

  2. Set up the configuration by running the script:

    cscript scenario.wsf //job:setup

    The component progid is "BTSSamples.AtlIBTSAppInt".

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_ATL_IBTSAppInt_AIC" by using the script:

    cscript scenario.wsf //job:SubmitSync

    If the submission succeeds, it replies with the first element of the submitted document.


BizTalk Framework Developers' Toolkit

This sample demonstrates how to programmatically access the BizTalk Framework 2.0 tags in a message.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTFDevToolkit

User's Guide

Before running the sample, complete the following steps:

  1. Register one of the envelope objects using regsvr32. Depending on which version of the XML parser you have (version 2.0, version 2.6, or version 3.0), register BTFEnvelope20.dll, BTFEnvelope26.dll, or BTFEnvelope30.dll respectively. Note that only one of these libraries can be registered at a time because they share a common CLSID.
    2. Copy SchemaPluginGenerator.dll to $:\Microsoft Visual Studio\Common\MSDev98\AddIns and run regsvr32 on the DLL to register it. The AddIns folder path location can vary depending on where Microsoft Visual Studio® is installed.
  3. Copy the file pigen.ini to the same location as SchemaPluginGenertor.dll (the Visual Studio AddIns folder).

  4. Register the MSPlugin type library depending on which version of the XML parser you are running. Register the type library MSPlugin20.tlb, MSPlugin26.tlb, or MSPlugin30.tlb if you are using XML parser version 2.0, version 2.6, or version 3.0 respectively You can register this file by verifying, and updating if necessary, the TLB file location paths in Plugin2.reg. After the paths are correct, you can run the Plugin2.reg file by double-clicking it.

  5. Copy the following files to the Template\Classes folder in the Visual Basic program tree, $:\Microsoft Visual Studio\VB98\Template\Classes:
    • Microsoft Plugin class instance.cls

    • Microsoft Plugin collection instance.cls

    • Microsoft Plugin Main.cls

    Be sure that these files are not read-only.

  6. Copy the following file to the Template\Code folder in the Visual Basic program tree, $:\Microsoft Visual Studio\VB98\Template\Code:
    • modXMLHelper3.bas

    Be sure that this file is not read-only.

  7. Load the code generator. Open Visual Basic and run the Add-In manager. You should see the following available add-in: BTF Developers Toolkit Schema Plug-in Generator. Select the Loaded/Unloaded check box to load the add-in. It will appear in the Add-Ins drop-down menu.

To run the sample, you must have the following components installed:

  1. Visual Basic version 6.0 SP3 or SP4

  2. Microsoft XMLDOM typelib {F5078F18-C551-11D3-89B9-0000F81FE221}. There are components specifically targeted at all three versions (2.0, 2.6, and 3.0) of the Microsoft XML Parser (MSXML). Any one of these three versions of the document object model (DOM) will work. Read UsingPluginGenerator.doc for more information about the DOM-targeted versions of the BTFEnvelope component and the MSPlugin type library.

Programming Notes

The Resource Kit components consist of two core components and a type library:

  • Envelope object. This object provides programmatic access to the BTF2.0 header tags in the XML document, including management of the message body and the ability to add documents.

  • Plugin code generator. This takes an XDR schema and generates a "plugin" set of Microsoft Visual Basic COM components that provide programmatic access to the BODY tags in a BTF 2.0 message.

  • PlugIn2 interface. Exposed through the MSPlugin type library. This interface is implemented by the generated plugin component and called by the Envelope object. This interface is the link between the Envelope and the Plugin.

You can find further documentation on the Envelope and Plugin in the files UsingPluginGenerator.doc and EnvelopeAndPlugin.doc. The BizTalk Framework 2.0 (BTF) tag specification and the XML-Data Reduced (XDR) schema documentation can be found at http://msdn.microsoft.com/xml. It is highly recommended that you read the BTF specification and the UsingPluginGenerator documents before you use the components. You can obtain further architectural detail from the EnvelopeAndPlugin document.

Known Issues

  • The Plugin generator does not support XDR <group> structures when nested within another <group>. Generated code will work, but the embedded group will not have object model access code. In this scenario the IXMLDOMNode nodes will be available and the plugin is still usable and correct.

  • The generator will treat XDR order="one" attributes like order="many" because it does not know which child element will eventually be used. The programmer must set only one child element so that the resulting XML document will be valid.

  • The Visual Basic "Microsoft Plugin" template files located under $:\Microsoft Visual Studio\VB98\Template must not be read-only. If they are read-only, the generator will fail when adding modules to the targets Visual Basic project.

  • The BTFEnvelope object does not yet support BTF 2.0 Multipart MIME structures and Reliable Delivery structures. While this support is not directly developed into the component, the DOM nodes at each level are exposed so that they can easily be extended and customized.

  • The envelope can currently accept only one business document added to its body. Therefore it is not currently possible to add or access more than one business document nested in the body.


Configuration Assistant

This sample enables you to view all details of a BizTalk Server configuration and to export and import that configuration. The configuration export and import is completed as a package that includes all messaging objects such as document specifications, maps, custom parsers, serializers, and application integration components (AIC).

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\BTConfigAssistant

User's Guide

Detailed information is provided in the Readme.doc file located in the BTConfigAssistant folder.


Custom Counters

This sample allows you to create a custom counter that you can use to count the number of documents in the Tracking database (DTA) that match a specified set of criteria. This sample allows you to create two types of counters, one based on source and destination organization names, and one based on qualifier and value pairs. Each counter is validated after it is created.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Custom Counter

User's Guide

Before running the scripts, complete the following steps:

  1. On the C drive, create a folder called CustomCounterSample with two subfolders called SrcOrg and DestOrg.

  2. On the BizTalk Server installation drive, copy POReq.xml to \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

  3. Run CustomCounterConfig.vbs to configure BizTalk Messaging Services.

To run documents through the DTA, copy and paste PORequest.xml to the C:\CustomCounterSample\SrcOrg folder. You should see an output file, Output.xml, in the C:\CustomCounterSample\DestOrg folder. Each time you do this an additional record will be tracked in the DTA.

To create a custom counter based on source and destination organization names, run CreateCustomCounter_Organizations.vbs.

To create a custom counter based on qualifier and value pairs, run CreateCustomCounter_Identifiers.vbs.

The first time you run each script, you will be creating an instance of the counter classes. When you run the script again to view the number of matching documents in the DTA, you will update the class.

To run the sample, you need to remove the read-only property from the sample data file, PORequest.xml.

Important

  • When calling the Put_ method to create or update the custom counter setting object, the wbemChangeFlagCreateOrUpdate flag is not supported. Instead, you must specify either wbemChangeFlagCreateOnly or wbemChangeFlagUpdateOnly, depending on whether you want to create or update the custom counter setting object. As a result, you need to update the source code of CreateCustomCounter_Organizations.vbs or CreateCustomCounter_Identifiers.vbs accordingly.

    For example, the following code from both the sample scripts creates the custom counter setting object:

    objCustomCounterSetting.Put_(wbemChangeFlagCreateOnly)

    To update the existing custom counter setting object, modify the code by specifying the wbemChangeFlagUpdateOnly flag, as shown in the following code:

    objCustomCounterSetting.Put_(wbemChangeFlagUpdateOnly)

    When you run the script again, the existing custom counter setting object will be updated.

    When the sample scripts are first installed, they are set up to create a custom counter setting object, in order to update the custom counter setting object and query the MatchCount property, you will need to update the scripts as specified above.

  • For the value of the MatchCount property to be consumed by Microsoft Operations Manager (MOM), the MOM DAS account must be a member of the BizTalk Server Administration group.

Programming Notes

This sample uses the MSBTS_CustomCounterSetting and MSBTS_CustomCounter Windows Management Instrumentation (WMI) classes. To locate the definitions of these classes, view the InterchangeProvSchema.mof file. The MatchCount property of MSBTS_CustomCounter is incremented each time a document runs through the DTA.


Custom Import Module

This sample creates a custom import module that imports a flat file and displays it in BizTalk Editor. The imported file is a delimited flat file exported from an SQL table. It is an ANSI file that uses "{CR}{LF}" as the row delimiter and comma as the column delimiter. The first line contains column names. The custom import module first creates a schema root called "SQLFile". It then parses the first line of the input file, extracts each column name, and creates each column as a text-only element under the root. The import module returns an XDR schema with BizTalk Server annotations.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleImporter

User's Guide

To use this sample in BizTalk Editor, follow these steps:

  1. Register CustomImporter.dll (run regsvr32 CustomImporter.dll).

  2. Merge CustomImporter.reg (right-click CustomImporter.reg and then click Merge).

  3. In BizTalk Editor, on the Tools menu, click Import. The "Custom data" import module will appear in the "Select Import Module" window.

  4. Select 'sqlfile.txt'. The BizTalk Editor tree view window will display the schema structure that was created based on the input file.

  5. Select 'Blank.txt'. BizTalk Editor will display a dialog box that indicates a "column not found" error.

  6. Select 'FilewithWarning.txt'. BizTalk Editor will report warnings in the output window.

To remove this custom importer from BizTalk Editor, you need to unregister CustomImporter.dll by using the command: run regsvr32 /u CustomImporter.dll.


Custom Preprocessor in Visual Basic

This sample demonstrates a very simple implementation of a custom preprocessor to be used with a File receive function.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\VBCustPreProcessor

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual Basic project into VBCustPreProcessor.dll.

  2. Register VBCustPreProcessor.dll by using regsvr32.

To run the sample, follow these steps:

  1. Set up a File receive function.

  2. Submit a document to BizTalk Server.

  3. Submit a document to the receive function.

Programming Notes

The Execute method simply loads the file into the XML DOM and then returns the XML data to BizTalk Server. The files should therefore always contain XML for the purposes of this sample.

This sample also demonstrates how to obtain context information from BizTalk Server although it does not actually use this context information during processing.


Custom Preprocessor in Visual C++

This sample demonstrates a very simple implementation of a custom preprocessor to be used with either File or Message Queuing receive functions.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\CustomPreProcessor

User's Guide

Before running the sample, complete the following steps:

  1. Compile the source files provided in this folder into CustomPreProcessorps.dll.

  2. Register CustomPreProcessorps.dll by using regsvr32.

To run the sample, follow these steps:

  1. Set up either a File receive function or a Message Queuing receive function.

  2. Submit a document to the receive function.

Programming Notes

When used by a File receive function, the Execute method simply loads the file into the XML DOM and then returns the XML data to BizTalk Server. The files should therefore always contain XML for the purposes of this sample.

When used by a Message Queuing receive function, if the input data contains an array of bytes, it is converted to a BSTR. Alternatively, if the input data contains a BSTR, it is converted to an array of bytes.

This sample also demonstrates how to obtain context information from BizTalk Server although it does not actually use this context information during processing.


Date Functoid

This sample creates a custom functoid that converts date formats. It converts a date in ISO format (generated from Date(), Time(), Now() in Visual Basic or from Date, Time, DateTime functoids) to a date in mm-dd-yyyy format. This sample is similar to the Date Functoid with .NET sample that is written in Visual C#™ .NET.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SampleFunctoid

User's Guide

Before running the sample, complete the following steps:

  1. Register DateConversion.dll (run regsvr32 DateConversion.dll).

  2. Merge DateConversion.reg (right-click DateConversion.reg and then click Merge).

To run the sample in BizTalk Mapper:

  • Select the DateConversion functoid that appears in the functoid palette on the Date/Time tab.


Date Functoid with .NET

This sample creates a custom functoid that converts date formats. It converts a date in ISO format (generated from Date(), Time(), Now() in Visual Basic or from Date, Time, DateTime functoids) to a date in mm-dd-yyyy format. This sample is written in Visual C# .NET and shows how to write a functoid by using Microsoft .NET Framework. This sample is identical in functionality to the Date Functoid sample that is written in Visual Basic.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DateFunctoidNet

User's Guide

Before running the sample, complete the following steps:

  1. Register AssemblyPathFinder.dll by typing the following two commands:

    regasm AssemblyPathFinder.dll

    gacutil /i AssemblyPathFinder.dll

  2. Register AssemblyPathFinderProxy.dll by using the command:

    run regsvr32 AssemblyPathFinderProxy.dll

To run the sample with BizTalk Mapper, follow these steps:

  1. Run buildme.bat.

  2. Merge DateFunctoidNet.reg (right-click DateFunctoidNet.reg and then click Merge).

  3. The DateFunctoidNet functoid appears in the functoid palette on the Date/Time tab.

To remove this functoid from the BizTalk Mapper functoid palette, follow these steps:

  1. Run unreg.bat

  2. Delete the following key from the registry (by using regedit):

    HKEY_CLASSES_ROOT\CLSID\{722FF791-A0F8-42b9-B390-16C3F9238A5E}

Programming Notes

.NET Framework must be installed to run this sample.


Direct Integration

This sample demonstrates the use of IInterchange methods to submit documents to BizTalk Server. A user interface offers the ability to set parameters interactively before submitting a document.

The sample also contains the source code for a component that can be used to unpack binary buffers returned as BSTR. Buffers are converted to safe character arrays. The component is used by the main sample when saving data items from the Suspended queue to file.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DirectIntegration

User's Guide

Detailed information is provided in the Readme.doc file located in the DirectIntegration folder.


Distribution List

This sample consists of independent Visual Basic and Visual C++ samples that configure and run a DistributionList, or port group, scenario that sends documents to multiple trading partners. The two samples perform the same tasks and show how to implement those tasks by using two different programming languages.

The sample Submitting Documents to a Port Group contains related information.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\DistributionList

User's Guide

Before running the sample, complete the following steps:

  1. In the C++ sample, compile the source files DistributionList.cpp and DistributionList.h into an executable file.

  2. In the Visual Basic sample, create an executable file from the DistributionList project (.bas) file.

To run the sample:

  • Run the .exe file that you created in the preceding steps.

Programming Notes

In the C++ sample, the code shows how to set up the BizTalk Messaging Management database to submit a CommonPO document to a distribution list (port group).

The distribution list consists of two ports:

Port "SRC -> DST Port" wraps the input document in a BizTalk Framework (BTF) 2.0 envelope and drops the output to the file "%HOMEDRIVE%\DL_SRCtoDST.TXT".

Port "SRC -> APP2 Port" transports the input document and drops it to the file "%HOMEDRIVE%\DL_SRCtoAPP2.TXT".

After configuring the BizTalk Messaging Management database, the sample submits a CommonPO to BizTalk Server and then checks that there are no entries in the Suspended queue and that the expected number of entries was tracked in the Tracking database during the last Submit call.

In the Visual Basic sample, the code shows how to set up the BizTalk Messaging Management database to submit a CommonPO document to a distribution list.

The distribution list consists of two ports:

Port "SRC -> DST Port" wraps the input document in a BTF 2.0 envelope and drops the output to the file "%HOMEDRIVE%\DL_SRCtoDST.TXT".

Port "SRC -> APP2 Port" transports the input document and drops it to the file "%HOMEDRIVE%\DL_SRCtoAPP2.TXT".


EDI and Receipts

This sample demonstrates how BizTalk Server can be used to support inbound X12 purchase order (850) messages from a trading partner and generate outbound X12 receipts (997) for those messages.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\EDI and Receipts

User's Guide

The sample scenario involves an external trading partner (Fabrikam, Inc.) submitting X12 purchase order (850) documents to the home organization (Microsoft). The inbound X12 electronic data interchange (EDI) documents are mapped to XML format and transported to the internal recipient application (MOLP). To signal that the X12 850 has been received, the home organization sends a functional acknowledgement (997) document to the external organization. The outbound X12 997 receipt is generated from a canonical receipt format that is shipped with BizTalk Server.

This sample uses only file transport to simulate the scenario, and does not use BizTalk Orchestration Services. X12 EDI documents from Fabrikam are dropped in one directory, and the transformed XML documents and receipt documents are generated as output in other directories on the local file system.

Note

  • If you have run setup.cmd on the EDI Introduction sample, you must run the setup on this sample for the scenario to work correctly.

To run the sample, follow these steps:

  1. Run setup.cmd in the sample folder to configure the scenario.

    Configuration involves the creation of the following BizTalk Server objects:

    • Organizations: Microsoft (default organization), Fabrikam

    • Document Definitions: Fabrikam850, Microsoft997, MicrosoftPO-MOLP, MyCanonicalReceipt

    • Envelope: EDItoFabrikam

    • Port: EDIPortToFabrikam, PortToMOLP

    • Channel: Channel997toFabrikam, Channel850toFabrikam

    • Receive Function: EDIFiles

    Files are copied onto the C drive. Make the necessary modifications in setup.cmd and ConfigureEDIReceipts.vbs if the C drive does not exist.

  2. With BizTalk Server running, navigate to c:\EDIReceipts\ and copy the file Fabrikam850.edi into c:\ EDIReceipts\Fabrikam.

    This file should be consumed by BizTalk Server, transformed, and submitted to C:\EDIIntroduction\Microsoft as the file xmlpotomolp_%tracking_id%.xml, where %tracking_id% is a unique ID value. A receipt file named EDItofabrikam_%tracking_id%.edi is then submitted to C:\EDIIntroduction\Fabrikam\Receipts.

To walk through how the sample is prepared, follow these steps:

  • Set Up Organizations and Associated Identifiers

  • Set Up and Verify Document Specifications

  • Set Up Map for Converting X12 to XML

  • Create Document Definitions

  • Create EDI Envelope

  • Create Ports

  • Create Channels

  • Create File Receive Function

  • Run the Sample Scenario

Programming Notes

The schemas and maps for this sample are completed and are available for review. It is also recommended that you complete the EDI Introduction sample for additional background.


Set Up Organizations and Associated Identifiers

This section creates the home organization (Microsoft), the application within the home organization (MOLP), and the destination organization (Fabrikam). It also sets up the organizational identifiers that uniquely determine how the EDI interchange is processed.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. If the BizTalk Messaging Manager dialog box appears, click Cancel.

  3. In the left frame, click Organizations, and then click Search Now.

  4. Ensure that Microsoft is the home organization.

    The home organization is indicated by (Default) next to the name. The dialog box that appears when you double-click the home organization should have three tabs.

  5. Click the Applications tab in the Organization Properties dialog box for Microsoft.

  6. Click Add, type MOLP, and then click OK.

  7. Click the Identifiers tab in the Organization Properties dialog box for Microsoft.

  8. Click Add, click Custom, and then type any name you like (for example, MyD&Bnumber) in the Custom text box.

  9. Enter 01 for Qualifier and 081466849 for Value. Click OK twice.

  10. To add the external trading partner organization Fabrikam, right-click the organization view window and click New Organization on the context menu.

  11. Click the Identifiers tab in the Organization Properties dialog box for Fabrikam.

  12. Click Add, click Custom, and then type any name you like in the Custom text box.

  13. Enter 01 for Qualifier and 0123456789 for Value. Click OK twice.


Set Up and Verify Document Specifications

In this section, you will set up, verify, and store to WebDAV the following document specifications:

  • schFabrikam850.xml - X12 850 purchase order sent from Fabrikam

  • schMicrosoftPO.xml - XML purchase order received by Microsoft

  • schMicrosoft997.xml - X12 997 receipt sent by Microsoft upon receiving 850

Note that the specification for a canonical receipt, CanonicalReceipt.xml, ships with BizTalk Server. It can be found in WebDAV in the Microsoft folder.

Set up EDI source specification

The file schFabrikam850.xml contains the document specification for the purchase order that is sent from Fabrikam. In this procedure you will examine an example X12 purchase order (850) that follows this specification (Fabrikam850.edi), validate the specification against a created test instance of the X12 850 (Fabrikam850NoEnvelope.edi), and store the specification to the WebDAV repository for future use.

  1. Using Notepad, open Fabrikam850.edi. (Right-click the file name, click Open With, and then select Notepad from the list of applications.) Leave Notepad active.

    You are looking at the EDI X12 purchase order (850). Note the delimiters needed to separate the records, fields, and subfields in the 850. They will be given in step 7 to validate the specification.

  2. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Editor.

  3. On the File menu, click Open, or use the toolbar icon to navigate to and select schFabrikam850.xml.

  4. Examine the specification. Select the nodes (for example, the root node X12_4010_850) and, on the View menu, click Expand Tree Items, or click the expand indicator (+).

  5. Using another instance of Notepad, open Fabrikam850NoEnvelope.edi. Compare this file with Fabrikam850.edi.

    As the file name indicates, Fabrikam850NoEnvelope.edi is the EDI X12 850 in step 1 with the header and trailer removed so that the BEG segment is at the top and the AMT segment followed by a carriage return/line feed is at the bottom. It will be used as a test validation instance of the EDI specification, because validation instances cannot contain envelope information.

  6. On the Tools menu, click Validate Instance and provide the file name Fabrikam850NoEnvelope.edi (in the same folder as other files used in this sample).

  7. In the Document Delimiters dialog box, specify ? (0x12), ~ (0x7e), and > (0x3e) for the Record, Field, and Subfield delimiters respectively. Click OK.

    If the instance test worked, the EDI will be transformed to XML and shown in the Output window at the bottom of BizTalk Editor, and the message "The document instance validation succeeded" will appear.

  8. On the File menu, click Store to WebDAV, and place the schema into the BizTalk Server WebDAV repository under the name schFabrikam850.xml.

Set up XML destination specification

The file schMicrosoftPO.xml contains the XML source specification for the purchase order that is received by Microsoft. Open this document, validate it, and store it to the WebDAV repository for future use.

  1. In BizTalk Editor, on the File menu, click Open, or use the toolbar icon to navigate to and select schMicrosoftPO.xml (in the same folder as other files used in this sample).

  2. On the Tools menu, click Validate Specification.

  3. On the File menu, click Store to WebDAV, and place the schema into the BizTalk Server WebDAV repository under the name schMicrosoftPO.xml.

Create receipt specification

An X12 functional acknowledgement (a 997) is sent from Microsoft to Fabrikam. The specification for this document, schMicrosoft977.xml, can be created from a template that is shipped with BizTalk Server.

  1. In BizTalk Editor, on the File menu, click New.

  2. In the New Document Specification dialog box, select X12, select 4010, and then select 997Schema.xml. Click OK.

  3. Select the document root node (X12_4010_997) and click the Reference tab in the right frame.

    The Receipt property on the Reference tab should be set to Yes to indicate that the specification is a receipt type.

  4. On the File menu, click Store to WebDAV, and then place the schema into the BizTalk Server WebDAV repository under the name schMicrosoft997.xml.


Set Up Map for Converting X12 to XML

The file mapFabrikam850toMicrosoftPO.xml specifies how the X12 source specification should be converted to the XML destination specification. Review and compile the map, and store it to WebDAV for future use. Note that no map needs to be constructed for the receipt response, because one is pre-built and included with BizTalk Server for this version of X12 (4010). A copy of this pre-built map (CanonicalReceiptTo4010-997.xml) is included in the same directory for reference.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Mapper.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select mapFabrikam850toMicrosoftPO.xml.

  3. On the Tools menu, click Compile Map, or press F5, or click the toolbar icon that is second from the right.

  4. Review the warnings that appear. Double-click a warning to see the problem that it refers to.

    The following types of warnings appear. Mapping will occur as expected even with these warnings, and they can be ignored.

    • "Warning: The required field 'X' has no incoming link or constant value"

      This type of warning can be ignored because the field's parent will not be created. Therefore the field itself cannot violate the validation criteria because it will not actually exist.

    • "Warning: The destination node 'X' has multiple source loop paths"

      This type of warning can be ignored in this case because the single occurrence of the input records in the instance will not cause a problem with the multiple loop paths. This map might not function as expected with document instances that differ greatly from the one in this sample.

    • "Warning: The destination node "X" has 3 input(s). The maximum number of possible inputs to this node is 1"

      This type of warning can be ignored because the mapper is not able to determine the presence of logical gating of the multiple inputs, which allows only one value to be selected from the multiple inputs.

  5. On the File menu, click Store to WebDAV, and then place the map into the BizTalk Server repository under the name mapFabrikam850toMicrosoftPO.xml.


Create Document Definitions

In this section, you will create the following document definitions:

  • Fabrikam850 - X12 850 purchase order sent from Fabrikam

  • MicrosoftPO-MOLP - XML purchase order received by Microsoft

  • MyCanonicalReceipt – Receipt document used to generate the outbound X12 997

  • Microsoft997 – Outbound X12 997 receipt sent by Microsoft upon receiving 850

Create EDI source document definition

In this procedure, you create the document definition Fabrikam850 for the Fabrikam X12 850 that is based on schFabrikam850.xml. Document tracking and selection criteria for the EDI document definition will be utilized.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. In the left frame, click Document Definitions, and then click Search Now.

  3. Right-click in the right frame and click New Document Definition on the context menu.

  4. For Document definition name type Fabrikam850.

  5. Select the Document specification check box.

  6. Click Browse and select schFabrikam850.xml from the repository list of schemas.

  7. Click the Global Tracking tab.

  8. Expand the BEG segment by clicking the expand indicator (+), select BEG03 (PO number), and then click Text to store this field for all instances processed through this document definition.

  9. Click the Selection Criteria tab.

  10. Click Add, type application_receiver_code for Name, type MAXCIM for Value, and then click OK.

  11. Repeat step 10 to create three more Selection Criteria name/value pairs:
    • application_sender_code / 0123456789

    • functional_identifier / PO

    • standards_version / 004010
  12. Click OK.

Create XML destination document definition

In this procedure, you create the document definition MicrosoftPO-MOLP for the XML purchase order that is received by Microsoft, based on schMicrosoftPO.xml. Document tracking will not be used in this case, and because this is not an EDI definition, defining the selection criteria is also not necessary.

  1. In BizTalk Messaging Manager, right-click in the Document Definitions right frame and click New Document Definition on the context menu.

  2. For Document definition name type MicrosoftPO-MOLP.

  3. Select the Document specification check box.

  4. Click Browse and select schMicrosoftPO.xml from the repository list of schemas.

  5. Click OK.

Create inbound (canonical) receipt document definition

When BizTalk Messaging Services on the home organization processes an inbound interchange from a trading partner, and receipts are required, the parser extracts header elements to generate a canonical receipt. In this procedure, you create the document definition MyCanonicalReceipt based on the canonical receipt specification CanonicalReceipt.xml that is shipped with BizTalk Server. This canonical receipt will then be used as the inbound document definition for the receipt channel (to be created) for delivery to Fabrikam. Neither document tracking nor selection criteria is necessary in defining MyCanonicalReceipt.

  1. In BizTalk Messaging Manager, right-click in the Document Definitions right frame and click New Document Definition on the context menu.

  2. For Document definition name type MyCanonicalReceipt.

  3. Select the Document specification check box.

  4. Click Browse and select CanonicalReceipt.xml from the Microsoft folder in the repository list of schemas.

  5. Click OK.

Create outbound receipt document definition

In this procedure, you create the document definition Microsoft997 based on schMicrosoft997.xml. This defines the outbound X12 997 receipt that Fabrikam expects from Microsoft. The receipt is generated by a mapping from MyCanonicalReceipt, with the map pre-built and included with BizTalk Server for this version of X12. Document tracking will not be utilized here, but defining the selection criteria is necessary.

  1. In BizTalk Messaging Manager, right-click in the Document Definitions right frame and click New Document Definition on the context menu.

  2. For Document definition name type Microsoft997.

  3. Select the Document specification check box.

  4. Click Browse and select schMicrosoft997.xml from the repository list of schemas.

  5. Click the Selection Criteria tab.

  6. Click Add, type application_receiver_code for Name and 0123456789 for Value, and then click OK.

  7. Repeat step 6 to create three more Selection Criteria name/value pairs:
    • application_sender_code / MAXCIM

    • functional_identifier / FA

    • standards_version / 004010
  8. Click OK.


Create EDI Envelope

This section will define the EDItoFabrikam envelope that will be used to wrap the X12 997 receipt from Microsoft to Fabrikam. Envelopes are needed whenever you are using non-XML documents.

  1. In BizTalk Messaging Manager, click Envelopes in the left frame and then click Search Now.

  2. Right-click in the right frame and click New Envelope on the context menu.

  3. Type EDItoFabrikam in the Name text box, click X12 on the Envelope Format drop-down menu, and then click OK.


Create Ports

This section will generate the two ports that are necessary for the inbound interchange and for the outbound receipt interchange.

Create port for internal application

This procedure will create the port PortToMOLP.

  1. In BizTalk Messaging Manager, click Messaging ports in the left frame and then click Search Now.

  2. Right-click in the right frame, click New Messaging Port on the context menu, and then click To Application.

  3. For Name enter PortToMOLP, leave Comments blank, and then click Next.

  4. The Applications option should be pre-selected. Click Name, select MOLP from the list, and then click OK.

  5. Create the directory c:\EDIReceipts\Microsoft\

    This is the location where Microsoft will receive the purchase order sent by Fabrikam and transformed to XML format.

  6. In the Primary Transport dialog box, click Browse, and then select File as the Transport Type.

  7. For the file name, type c:\EDIReceipts\Microsoft\xmlpotomolp_%tracking_id%.xml, click OK, and then click Next twice.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  8. Clear the Create a channel for this messaging port check box, and then click Finish.

Create port for external trading partner

This procedure will create the port EDIPortToFabrikam.

  1. In BizTalk Messaging Manager, right-click in the Messaging ports right frame, click New Messaging Port on the context menu, and then click To an Organization.

  2. For Name enter EDIPortToFabrikam, leave Comments blank, and then click Next.

  3. The Organization option should be pre-selected. Click Browse, select Fabrikam from the list, and then click OK.

  4. Create the directory c:\EDIReceipts\Fabrikam\Receipts.

    This is the location where Fabrikam receives the X12 997 documents.

  5. In the Primary Transport dialog box, click Browse, and then select File as the Transport Type.

  6. For the file name, type c:\EDIReceipts\Fabrikam\Receipts\EDItofabrikam_%tracking_id%.edi, click OK, and then click Next.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  7. Click EDItoFabrikam on the Envelope Information drop-down menu.

    Note that you can also create an envelope here if you forgot to do it earlier in Create EDI Envelope.

  8. Click Delimiters, enter the delimiters ~, *, and >, and then click OK.

    In this case, it does not matter what your delimiters are because there is no real business partner on the other end. In real scenarios, the delimiters are agreed upon between you and your business partners.

  9. In the Interchange Control Number dialog box, type a non-zero number.

  10. On the Organization Identifier drop-down menu, click 0123456789, and then click Next.

  11. Clear the Create a channel for this messaging port check box, and then click Finish.


Create Channels

This section will create the two channels for the inbound purchase order and outbound receipt interchanges. Note that the outbound receipt channel must be created first.

Create channel for outbound receipt

This procedure will create the receipt channel Channel997toFabrikam, with MyCanonicalReceipt as the inbound document definition and Microsoft997 as the outbound document definition. A pre-built map that is shipped with BizTalk Server (CanonicalReceiptTo4010-997.xml) will be used to transform the two definitions.

  1. Right-click EDIPortToFabrikam, click New Channel, and then click From an Application.

  2. For Name type Channel997toFabrikam.

  3. Select the This is a receipt channel check box, and click Next.

  4. The Application option should be pre-selected. Select MOLP from the drop-down list of application names.

  5. Select the 081466849 qualifier from the drop-down list, and then click Next.

  6. Under Inbound Document Definition Name click Browse, select the document definition called MyCanonicalReceipt, click OK, and then click Next.

  7. Under Outbound Document Definition Name click Browse, select the document definition called Microsoft997, and then click OK.

  8. The Map Inbound Document check box should be pre-selected. Click Browse to choose the map CanonicalReceiptTo4010-997.xml in the Microsoft folder of the WebDAV repository, click OK, and then click Next.

  9. Select any document storage options that interest you for the purpose of viewing in the BizTalk Document Tracking (see Start menu), and then click Next.

  10. Type an integer value in the Group Control Number text box.

    The value is not important, but you will note that repeated document flows through this channel will result in serially incremented values for this number.

  11. Click Finish.

Create channel for inbound purchase order

This procedure will create the channel Channel850toMOLP that will use Channel997toFabrikam as its associated receipt channel.

  1. In the left frame of BizTalk Messaging Manager, click Messaging ports, and then click Search Now.

  2. Right-click PortToMOLP, click New Channel, and then click From an Organization.

  3. For Name type Channel850toMOLP, and then click Next.

  4. The Organization option should be pre-selected. Click Browse, choose Fabrikam from the drop-down list, and then click OK.

  5. Select the Generate Receipt check box at the bottom of the dialog box.

  6. Click Browse, select Channel997toFabrikam, click OK, and then click Next.

  7. Under Inbound Document Definition Name, click Browse, select Fabrikam850, click OK, and then click Next.

  8. Under Outbound Document Definition Name, click Browse, select MicrosoftPO-MOLP, and then click OK.

  9. The Map Inbound Document check box should be pre-selected. Click Browse, select mapFabrikam850toMicrosoftPO.xml from the maps repository, click OK, and then click Next.

  10. Select any document storage options that interest you for the purpose of viewing in the BizTalk Document Tracking (see Start menu), click Next, and then click Finish.


Create File Receive Function

This section will create the File receive function EDIFiles for picking up Fabrikam purchase orders to send to Microsoft.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Server Administration.

  2. Expand the Microsoft BizTalk Server 2002 node in the left frame tree until the Queues and Receive Functions nodes are fully expanded.

  3. Add a new File receive function either by clicking the Receive Functions node and choosing Action | New | File Receive Function from the menu bar or by right-clicking the Receive Functions node and clicking New | File Receive Function on the context menu.

  4. Type EDIFiles for Name. Comments can be left blank.

    The machine you are working on should be pre-selected in the drop-down list titled Server on which.

  5. Type *.EDI in the File type to poll for text box.

  6. Verify the existence of the directory c:\EDIReceipts\Fabrikam.

    This is the location where Fabrikam will drop the X12 850 documents to be sent to Microsoft.

  7. Type c:\EDIReceipts\Fabrikam in the Polling Location text box.

  8. Click Advanced. In the Channel Name drop-down list, select Channel850toMOLP, and leave the defaults in the other data items.

  9. Click OK to close the Advanced dialog box, and then click OK to close the Add a File Receive Function dialog box.


Run the Sample Scenario

  1. The sample is run by placing the X12 instance Fabrikam850.edi into the Fabrikam folder and observing XML output to the Microsoft folder and the EDI receipt output to the Fabrikam/Receipts folder.

  2. Verify that the BizTalk service is running by making sure that a green arrow appears on your server icon in the BizTalk Server Administration MMC (server is immediately below Receive Functions in the tree); right-click the icon and click Start on the context menu if no green arrow is displayed.

  3. Copy Fabrikam850.edi to c:\EDIReceipts\Fabrikam and wait.

  4. Open the c:\EDIReceipts\Microsoft folder and look for a file called xmlpotomolp_%tracking_id%.xml, where the %tracking_id% symbol will be replaced with a GUID value.

  5. Open the c:\EDIReceipts\Fabrikam\Receipts folder and look for a file called EDItofabrikam_%tracking_id%.edi, where the %tracking_id% symbol will be replaced with a GUID value.


EDI Introduction

This sample demonstrates how to configure BizTalk Server to support XML documents flowing outbound from the home organization to an external trading partner using the EDI X12 855 document format.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\EDI Introduction

User's Guide

An internal application (MOLP) of the home organization (Microsoft) submits XML documents to BizTalk Server. These files are then mapped to an X12 EDI format and transported to the recipient trading partner (Fabrikam).

This sample uses only file transport to simulate the scenario, and does not use BizTalk Orchestration Services. XML documents from Microsoft are dropped in one directory, and the transformed X12 EDI documents are generated as output in another directory on the local file system.

Note

  • If you have run setup.cmd on the EDI and Receipts sample, you must run setup.cmd again on this sample for the scenario to work correctly.

To run the sample, follow these steps:

  1. Run setup.cmd in the sample directory to configure the scenario.

    Configuration involves the creation of the following BizTalk Server objects:

    • Organizations: Microsoft (default organization), Fabrikam

    • Document Definitions: Fabrikam855, MicrosoftPOAck

    • Envelope: EDItoFabrikam

    • Port: EDIPortToFabrikam

    • Channel: Channel855toFabrikam

    • Receive Function: XMLAcks

    Files are copied onto the C drive. Make the necessary modifications in setup.cmd and ConfigureEDI.vbs if the C drive does not exist.

  2. With BizTalk Server running, navigate to c:\EDIIntroduction\ and copy the file MOLPpoAck.xml into c:\EDIIntroduction\Microsoft.

    This file should be consumed by BizTalk Server, transformed, and submitted to C:\EDIIntroduction\Fabrikam as the file EDItoFabrikam_%tracking_id%.edi, where %tracking_id% is a unique ID value.

To walk through how the sample is prepared, follow these steps:

  • Set Up Organizations and Associated Identifiers

  • Set Up Source Specification

  • Set Up Destination Specification

  • Set Up Map for Converting XML to X12

  • Create Document Definition for Microsoft

  • Create Document Definition for Fabrikam

  • Define EDI Selection Criteria for Fabrikam

  • Create EDI Envelope

  • Create Port for Delivering EDI to Fabrikam

  • Create Channel from Microsoft to Fabrikam

  • Create File Receive Function

  • Run the Sample Scenario

  • Troubleshooting

Programming Notes

Electronic data interchange (EDI) is a set of standards for controlling the exchange of business documents (such as purchase orders and invoices) between computers. Although standardization efforts for EDI formats began in the 1960s, the expensive setup and operational costs of EDI server systems and the somewhat cryptic EDI document formats limited its use.

BizTalk Server supports the EDIFACT standard adopted in 1987 by the International Organization for Standardization (ISO) as well as the older X12 standard used primarily for American domestic trade. This sample goes through the transmission of a purchase order acknowledgement from Microsoft to Fabrikam using the X12 standard.

The schemas and maps for this sample are completed and are available for review to get a better understanding.


Set Up Organizations and Associated Identifiers

This section creates the home organization (Microsoft), the application within the home organization (MOLP), and the destination organization (Fabrikam). It also sets up the organizational identifiers that uniquely determine how the EDI interchange is processed.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and click BizTalk Messaging Manager.

  2. If the BizTalk Messaging Manager dialog box appears, click Cancel.

  3. In the left frame, click Organizations, and then click Search Now.

  4. Verify that Microsoft is the home organization.

    The home organization is indicated by (Default) next to the name. The dialog box that appears when you double-click the home organization should have three tabs.

  5. Click the Applications tab in the Organization Properties dialog box for Microsoft.

  6. Click Add, type MOLP, and then click OK.

  7. Click the Identifiers tab in the Organization Properties dialog box for Microsoft.

  8. Click Add, click Custom, and type any name you like (for example, MyD&Bnumber) in the Custom box.

  9. Enter 01 for Qualifier and 081466849 for Value. Click OK twice.

  10. Add the external trading partner organization Fabrikam by right-clicking the organization view window and clicking New Organization on the context menu.

  11. Click the Identifiers tab in the Organization Properties dialog box for Fabrikam.

  12. Click Add, click Custom, and type any name you like in the Custom box

  13. Enter 01 for Qualifier and 0123456789 for Value. Click OK twice.


Set Up Source Specification

The file schMicrosoftPOAck.xml contains the XML source specification for the purchase order acknowledgement that is sent from Microsoft. Look at this document, validate it against an instance (MOLPpoAck.xml), and store it to the WebDAV repository for future use.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Editor.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select schMicrosoftPOAck.xml.

  3. Examine the specification by clicking the nodes (for example, the root node MicrosoftPOAck) and clicking Expand Tree Items on the View menu or clicking the expand indicator (+).

  4. On the Tools menu, click Validate Instance and provide the file name MOLPpoAck.xml (in the same folder as other files used in this sample).

    The message "The document instance validation succeeded" is shown if the instance test worked.

  5. On the File menu, click Store to WebDAV and place the schema into the BizTalk Server repository under the name schMicrosoftPOAck.xml.


Set Up Destination Specification

The file schFabrikam855.xml contains the specification for the X12 version release 4010 purchase order acknowledgement (855) that Fabrikam expects to receive. Review this document, validate the specification, and store it to the WebDAV repository for future use.

  1. In BizTalk Editor, open schFabrikam855.xml and expand the specification tree as before.

  2. On the Tools menu, click Validate Specification.

  3. On the File menu, click Store to WebDAV and place the specification into the BizTalk Server WebDAV repository under the name schMicrosoftPOAck.xml.


Set Up Map for Converting XML to X12

The file mapMicrosoftPOAcktoFabrikam855.xml specifies how the XML source specification should be converted to the X12 destination specification. Review and compile the map, and store it to WebDAV for future use.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Mapper.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select mapMicrosoftPOAcktoFabrikam855.xml.

  3. On the Tools menu, click Compile Map, or press F5, or click the toolbar icon that is second from the right.

  4. Review warnings.

    One type of warning appears: "Warning: The required field 'X' has no incoming link or constant value." Mapping will occur as expected even with this warning. It can be ignored because the field's parent will not be created, and therefore the field itself cannot violate the validation criteria because it will not actually exist.

  5. On the File menu, click Store to WebDAV, and place the map into the BizTalk Server repository under the name mapMicrosoftPOAcktoFabrikam855.xml.


Create Document Definition for Microsoft

In this procedure, you create a document definition MicrosoftPOAck for the Microsoft purchase order acknowledgement that is based on schMicrosoftPOAck.xml.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. In the left frame, click Document Definitions, and then click Search Now.

  3. Right-click in the right frame and click New Document Definition on the context menu.

  4. Type MicrosoftPOAck in the Document definition name box.

  5. Select the Document specification check box.

  6. Click Browse and select schMicrosoftPOAck.xml from the repository list of schemas.

  7. Click OK.


Create Document Definition for Fabrikam

In this procedure, you create a document definition Fabrikam855 for the Fabrikam X12 855 based on schFabrikam855.xml. A document definition for EDI also involves specifying the selection criteria, which is the subject of the next section.

  1. Right-click in the right frame of BizTalk Messaging Manager and click New Document Definition on the context menu.

  2. Type Fabrikam855 in the Document definition name box.

  3. Select the Document specification box.

  4. Click Browse and select schFabrikam855.xml from the repository list of schemas.

  5. Click OK.


Define EDI Selection Criteria for Fabrikam

The selection criteria is a list of name/value pairs that will allow the BizTalk messaging engine to uniquely identify the appropriate document definition for an EDI document. This is necessary because multiple EDI documents can be contained in a single interchange and multiple document types can be mixed within an interchange.

  1. Click the Selection Criteria tab for the Fabrikam855 document definition.

  2. Click Add. For Name, type application_receiver_code, for Value, type 0123456789, and then click OK.

  3. Repeat step 2 to create three more Selection Criteria name/value pairs:
    • application_sender_code / MAXCIM

    • functional_identifier / PR

    • standards_version / 004010
  4. Click OK to complete the document definition.


Create EDI Envelope

This section will define the EDItoFabrikam envelope. Envelopes are needed whenever you are using non-XML documents. A particular envelope is associated with a particular type of document (for example, X12), and contains information that the BizTalk messaging engine needs to route the document.

  1. In BizTalk Messaging Manager, click Envelopes in the left frame, and then click Search Now.

  2. Right-click in the right frame and click New Envelope on the context menu.

  3. Type EDItoFabrikam in the Name box, choose X12 from the Envelope Format drop-down list, and then click OK.


Create Port for Delivering EDI to Fabrikam

This procedure will create the port EDIPortToFabrikam.

  1. In BizTalk Messaging Manager, click Messaging ports in the left frame and then click Search Now.

  2. Right-click in the right frame, point to New Messaging Port, and click To an Organization.

  3. Type EDIPortToFabrikam in the Name box, leave Comments blank, and then click Next.

  4. The Organization option button should be pre-selected. Click Browse to select the organization name Fabrikam from the list, and then click OK.

  5. Create the directory c:\EDIIntroduction\Fabrikam\. This will be the location where Fabrikam receives the X12 855 documents.

  6. In the Primary Transport dialog box, click Browse, and choose File as the Transport Type.

  7. Type (after file://) c:\EDIIntroduction\Fabrikam\EDItofabrikam_%tracking_id%.edi as the file name, click OK, and then click Next.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  8. Under Envelope Information, select EDItoFabrikam in the drop-down list.

    Note

    • You can also create an envelope at this point, if you did not do it previously in Create EDI Envelope.
  9. Click Delimiters and type the delimiters ~, *, and >. Click OK.

    In this case, it does not matter what your delimiters are because there is no real business partner on the other end. In real scenarios, the delimiters are agreed upon between you and your business partners.

  10. In the Interchange Control Number dialog box, type a non-zero number.

  11. Under Organization Identifier select the 0123456789 ID from the drop-down list, and then click Next.

  12. Clear the Create a channel for this messaging port check box, and click Finish.


Create Channel from Microsoft to Fabrikam

This procedure will create the channel Channel855toFabrikam.

  1. Right-click the EDIPortToFabrikam created previously, and click New Channel | From an Application.

    Alternatively, you could leave the Create a channel for this messaging port check box selected at the end of the New Messaging Port dialog

  2. For Name type Channel855toFabrikam, and then click Next.

  3. The Application option button should be pre-selected. Choose MOLP from the drop-down list of application names.

  4. Select the 081466849 qualifier from the drop-down list, and then click Next.

  5. Under Inbound Document Definition Name click Browse and select the document definition MicrosoftPOAck, click OK, and then click Next.

  6. Under Outbound Document Definition Name click Browse and select the document definition Fabrikam855, and then click OK.

  7. The Map Inbound Document check box should be pre-selected. Click Browse and choose MicrosoftPOAcktoFabrikam855.xml from the maps repository, click OK, and then click Next.

  8. Select any document storage options that interest you for the purpose of viewing in BizTalk Document Tracking (see Start menu), and then click Next.

  9. Type an integer value in the Group Control Number box.

    The value is not especially important. You will see that repeated document flows through this channel will result in serially incremented values for this number.

  10. Click Advanced, click the Envelope tab, and then click Properties. Review the dialog box where you will access the values to be used when creating the interchange envelope (no changes to these values are necessary for the sample).

  11. Click Finish.


Create File Receive Function

This section will create the File receive function XMLAcks for Microsoft documents.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Server Administration.

  2. Expand the Microsoft BizTalk Server 2002 node in the left frame tree until the Queues and Receive Functions nodes are fully expanded.

  3. To add a new File receive function, click the Receive Functions node.

  4. On the Action menu, point to New and click File Receive Function.

  5. Type XMLAcks in the Name box. Comments can be left blank.

    The machine you are working on should be pre-selected in the drop-down list titled Server on which.

  6. Type *.XML in the File type to poll for box.

  7. Create the directory c:\EDIIntroduction\Microsoft

    This is the location where Microsoft will drop the XML documents to be sent to Fabrikam.

  8. Type c:\EDIIntroduction\Microsoft in the Polling Location box.

  9. Click Advanced. In the Channel Name drop-down list, select Channel855toFabrikam, and leave the defaults in the other data items.

  10. Click OK to close the Advanced dialog box, and then click OK to close the Add a File Receive Function dialog box.


Run the Sample Scenario

The sample is run by placing the XML instance MOLPpoAck.xml into the Microsoft folder and observing the EDI output to the Fabrikam folder.

  1. Verify that the BizTalk service is running by making sure that a green arrow appears on your server icon in the BizTalk Server Administration MMC (the server is immediately below Receive Functions in the tree); right-click the icon and click Start on the context menu if no green arrow is displayed.

  2. Copy MOLPpoAck.xml to c:\EDIIntroduction\Microsoft.

  3. Open the c:\EDIIntroduction\Fabrikam folder and look for a file called EDItofabrikam_%tracking_id%.edi (from step 7 of "Create Port for Delivering EDI to Fabrikam"), where the %tracking_id% symbol is replaced with a GUID value.


Troubleshooting

If the MOLPpoAck.xml file is not picked up and deleted from c:\EDIIntroduction\Microsoft after a reasonable time period, check that the receive function XMLAcks in BizTalk Server Administration is correctly configured by right-clicking on the receive function and clicking Properties. Also make sure that the Disable receive function check box is cleared.

If MOLPpoAck.xml is picked up but there is no output in the c:\EDIIntroduction\Fabrikam directory, check the Suspended queue in BizTalk Server Administration for the error description.


Encryption and Decryption

This sample walks through the process of setting up a secure document exchange between two trading partners. This sample demonstrates the use of digital certificates to:

  • Encrypt an outgoing document

  • Sign an outgoing document

  • Decrypt an incoming document

  • Verify the signature on an incoming document

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Encryption

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup (setup.cmd)

  • Obtain and Install Digital Certificates

  • Create Secure Ports and Channels

  • Create File Receive Functions

  • Run the Sample Scenario

Programming Notes

The sample scenario simulates establishing secure communications between two organizations: Buyer and Home. These organizations can be considered as separate Web sites.

A flat-file purchase order, myPO.csv, is sent from Buyer to Home. Because the purchase order is considered sensitive, the information needs to be encrypted and signed by Buyer before it is transported. Encryption prevents documents from being viewed by unauthorized individuals. Signing ensures that a document is authentic and unaltered. Home decrypts, verifies, and transforms the purchase order as an XML document of decision factors.

This sample requires obtaining certificates for each organization to perform the encryption, decryption, and digital signature. It is recommended that you familiarize yourself with certificates before using this sample.


Preliminary Setup (setup.cmd)

Running setup.cmd in the sample directory performs the following tasks, which are described in detail in the following topics:

  • Create Folders

  • Create Organizations

  • Create Document Definitions

  • Set Up Map

  • Create Envelope

If you encounter errors, be sure to clear out all conflicting organizations, document definitions, and so on that are used in this scenario before running setup.cmd.


Create Folders

In this procedure, you create one folder that contains three subfolders. Each subfolder simulates an organization in the scenario.

To create the folders:

  1. In Windows Explorer, browse to the root directory of your C drive.

  2. Create a new folder on the root of the C drive; name the folder Encryption.

  3. Click the new Encryption folder and create three subfolders with the following names:
    • Buyer

    • Home

    • Approver


Create Organizations

In this procedure, you will create the three organizations in the scenario.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Messaging Manager.

  2. If the BizTalk Messaging Manager dialog box appears, click Cancel.

  3. In the left frame, click Organizations, and then click Search Now.

  4. Right-click the organization view window and click New Organization on the context menu.

  5. Type Buyer in the Organization name box and click OK.

  6. Repeat steps 4 and 5 for the Home and Approver organizations.


Create Document Definitions

In this procedure, you will examine and store three document specifications to WebDAV and create three document definitions that are based on the following specifications:

  • BasicPO. The purchase order sent by Buyer for approval.

  • DecisionFactors. The decision factors extracted from the basic purchase order that are relevant for approval.

  • Response. The final approval response: yes or no.

  • To create the document definitions:
  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Editor.

  2. For each of the following document specifications, on the File menu, click Store to WebDAV, and store these document specifications in the same folder:

    defBasicPO.xml

    defDecisionFactors.xml

  3. In the left frame of BizTalk Messaging Manager, click Document definitions, and then click Search Now.

  4. Right-click in the right frame and click New Document Definition on the context menu.

  5. Type BasicPO in the Document definition name box.

  6. Select the Document specification check box and click Browse.

  7. Select defBasicPO.xml in the WebDAV repository and click Open.

  8. Click OK to close the New Document Definition dialog box.

  9. Repeat steps 4-8 for the document specification defDecisionFactors.xml, naming it DecisionFactors.


Set Up Map

The file mapBasicPO_DecisionFactors.xml specifies how the BasicPO source specification should be converted to the DecisionFactors destination specification. Review and compile the map, and store it to WebDAV for future use.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Mapper.

  2. On the File menu, click Open, or use the toolbar icon to navigate to and select mapBasicPO_DecisionFactors.xml.

  3. On the Tools menu, click Compile Map, or press F5, or click the toolbar icon that is second from the right.

  4. On the File menu, click Store to WebDAV, and place the map into the BizTalk Server repository under the name mapBasicPO_DecisionFactors.xml.


Create Envelope

In this procedure you will create the BasicPOEnv envelope that is used to wrap the flat-file purchase order that is sent from Buyer. Envelopes are needed whenever you are using non-XML documents.

  1. In the left frame of BizTalk Messaging Manager, click Envelopes and then click Search Now.

  2. Right-click in the right frame and click New Envelope on the context menu.

  3. Type BasicPOEnv in the Name text box.

  4. Select FLATFILE from the Envelope Format drop-down list.

  5. Select the Envelope specification check box and click Browse.

  6. Click defBasicPO.xml in the WebDAV repository and click Open.

  7. Click OK to close the New Envelope dialog box.


Obtain and Install Digital Certificates

This sample requires the use of two certificates. These certificates must either be obtained from a trusted certification authority (CA), or be created by using Microsoft Certificate Services. One certificate will be denoted as the Buyer certificate, and the other as the Home certificate. A purchase order will be encrypted and signed, and then decrypted and verified with these two certificates.

To create the certificates by using Microsoft Certificate Services, follow these guidelines. Note that these guidelines are subject to change. For more information about creating certificates, see the Certificate Services Help file that is available in the Certification Authority MMC snap-in.

  • Install Certificate Services

  • Request Certificates

  • Issue Certificates

  • Install MMC Certificates Snap-in

  • Install Certificates to Personal Store

  • Install Certificates to BizTalk Store


Install Certificate Services

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Add/Remove Programs.

  3. Click Add/Remove Windows Components, click Certificate Services, and then click Next.

  4. Complete the steps in the Certificate Services installation wizard.

    For this sample, it is sufficient to use the wizard's default selected options.


Request Certificates

  1. Use your browser to navigate to http://localhost/certsrv/default.asp.

  2. Click Request a certificate and then click Next.

  3. Select Advanced request and then click Next.

  4. Select Submit a certificate request to this CA using a form and then click Next.

  5. Under Identifying Information, enter Buyer as the Name.

    Enter other identifying information as desired.

  6. Under Key Options, select Mark keys as exportable and Use local machine store.

    Keeping these options selected ensures that the certificate gets installed on the local computer and can be exported to a file.

  7. Click Submit.

  8. Repeat steps 2 through 7, changing the certificate name to Home.


Issue Certificates

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Certification Authority.

  4. Fully expand the Certificate Authority tree and click the Pending Requests folder.

    Two new requests for certificates should appear.

  5. Select both new pending requests and right-click.

  6. Click All Tasks, and then click Issue.

    The requests should now disappear from the Pending Requests folder.

  7. Verify that the certificates now appear in the Issued Certificates folder.


Install MMC Certificates Snap-in

BizTalk Server uses the Local Computer certificate store to locate digital certificates. Install the MMC Certificates snap-in to be able to manage the certificates.

  1. On the Start menu, click Run, and then type mmc to start Microsoft Management Console.

  2. On the Console menu, click Add/Remove Snap-in.

    The Add/Remove Snap-in dialog box is displayed.

  3. Click Add and select Certificates.

  4. Select Computer account as the account for which the snap-in will manage certificates.

  5. Click Next to go to the Select Computer dialog box.

  6. The default Local computer should be selected. Click Finish.

  7. Click Close to close the Add Standalone Snap-in dialog box.

  8. Click OK to close the Add/Remove Snap-in dialog box.

  9. Keep the Console window open to verify installation in future steps.


Install Certificates to Personal Store

  1. Use your browser to navigate to http://localhost/certsrv/default.asp.

  2. Click Check on a pending certificate and then click Next.

  3. Click the first certificate request and then click Next.

  4. Click Install this certificate.

  5. Open the Microsoft Management Console window with the Certificates snap-in installed.

  6. Navigate to Certificates (Local Computer) | Personal | Certificates in the left frame.

  7. Verify that a new certificate with the name specified (for example, Buyer) has been installed.

  8. Repeat steps 2 through 7 to install the remaining certificate request.


Install Certificates to BizTalk Store

  1. In the Console window, right-click the Buyer certificate, and select All Tasks | Export.

    The Certificate Export Wizard appears.

  2. Click Next.

  3. In the Export Private Key dialog box, select No, do not export the private key, and then click Next.

    The BizTalk Server store does not require certificates with private keys.

  4. Click Next to get to the File to Export dialog box.

  5. Click Browse and enter a file name for the exported certificate (for example. c:\Encryption\buyer.cer).

    Remember the certificate location and file name for future steps.

  6. Click Next and then click Finish.

    A dialog should appear indicating that the export was successful.

  7. Repeat the preceding steps to export the Home certificate.

  8. In the left frame of the Console, right-click the BizTalk folder under Certificates (Local Computer).

  9. Click All Tasks, and then click Import.

    The Certificate Import Wizard appears.

  10. Click Next.

  11. Click Browse to navigate to and select the Buyer certificate.

  12. Click Next, click Next again, and then click Finish.

    A dialog should appear indicating that the import was successful.

  13. Repeat the preceding steps to import the Home certificate.

  14. Navigate to Certificates (Local Computer) | BizTalk | Certificates to verify that the two certificates have been imported.


Create Secure Ports and Channels

This section shows how to create ports and channels that carry out encryption, decryption, signing, and verification. Two ports and two channels will be created.

This section contains the following topics:

  • Create Port and Channel to Encrypt and Sign Outbound Files

  • Create Port and Channel to Receive Encrypted and Signed Files


Create Port and Channel to Encrypt and Sign Outbound Files

In this section, you will create the port BuyerEncryptPort and the associated channel BuyerEncryptChannel to encrypt and sign documents. Because the documents are sent from Buyer to Home, they need to be encrypted with Home's public key and signed with Buyer's private key. The certificates used for signing and encryption will be specified in the properties of both the port and the channel.

  1. In Biztalk Messaging Manager, on the File menu, click New, click Messaging Port, and then click To an Organization.

    The New Messaging Port Wizard opens.

  2. In the Name box, type BuyerEncryptPort and then click Next.

  3. On the Destination Organization page, in the Organization area, click Browse.

  4. Select Buyer from the list of available organizations, and then click Next.

  5. In the Primary Transport box, click Browse, and choose File as the Transport Type.

  6. Type (after file://) c:\Encryption\Buyer\Encrypted\myPO_%tracking_id%.txt as the file name.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  7. Click OK to close the Primary Transport dialog box.

  8. Click Next twice to get to the Security Information page.

  9. In the Encryption group box, select S/MIME from the Type drop-down list and click Browse.

    A list appears, showing certificates that are stored on the computer with public keys.

  10. Select the Home digital certificate and click OK.

  11. In the Signature group box, select S/MIME from the Type drop-down list.

    The digital certificate used to sign the document will be specified in the channel.

  12. Verify that the Create a channel for the messaging port check box is selected.

  13. Select "From an organization" as the Channel Type and click Finish.

    The New Channel Wizard opens.

  14. On the General Information page, in the Name box, type BuyerEncryptChannel and click Next.

  15. On the Source Organization page, in the Organization area, click Browse.

  16. Select Buyer from the list of available organizations, and then click Next.

  17. On the Inbound Document page, click Browse and select BasicPO as the document definition.

  18. Click Next.

  19. On the Outbound Document page, click Browse and again select BasicPO as the document definition.

  20. Select "Sign outbound document" and click Browse.

    A list appears, showing certificates that are stored on the computer with private keys.

  21. Select the Buyer digital certificate and click OK.

  22. Click Next twice, and then click Finish.


Create Port and Channel to Receive Encrypted and Signed Files

In this section, you will create the port SubmitPort and the associated channel BuyerHomeChannel for transporting an encrypted and signed purchase order from the Buyer to the Home organization. The flat-file purchase order has been signed with Buyer's private key and encrypted with Home's public key. Therefore, it needs to be verified with Buyer's public key and decrypted with Home's private key. The certificates that are used for verification and decryption will be specified in the properties of BuyerHomeChannel.

  1. In BizTalk Messaging Manager, on the File menu, click New, click Messaging Port, and then click To an Organization.

    The New Messaging Port Wizard opens.

  2. In the Name box, type SubmitPort and click Next.

  3. On the Destination Organization page, in the Organization area, click Browse.

  4. Select Home from the list of available organizations, and then click Next.

  5. In the Primary Transport box, click Browse, and choose File as the Transport Type.

  6. Type (after file://) c:\Encryption\Home\DecisionFactor_%tracking_id%.xml as the file name.

    The use of %tracking_id% allows each document to be saved to a unique file name.

  7. Click OK to close the Primary Transport dialog box.

  8. Click Next twice.

  9. On the Security Information page, verify that the Create a channel for the messaging port check box is selected.

  10. Select "From an organization" as the Channel Type, and click Finish.

    The New Channel Wizard opens.

  11. On the General Information page, in the Name box, type BuyerHomeChannel and click Next.

  12. On the Source Organization page, in the Organization area, click Browse.

  13. Select Buyer from the list of available organizations, and then click Next.

  14. On the Inbound Document page, click Browse and select BasicPO as the document definition.

  15. Select Verify decryption on inbound document, and click Browse.

    A list appears, showing certificates that are stored on the computer with private keys.

  16. Select the Home digital certificate and click OK.

    Because Home's public key was used to encrypt the purchase order, Home's private key must be used to decrypt it.

  17. Select Verify signature on inbound document, and click Browse.

    A list appears, showing certificates that are stored on the computer with public keys.

  18. Select the Buyer digital certificate and click OK.

    Because Buyer's private key was used to sign the purchase order, Buyer's public key must be used to verify the signature.

  19. Click Next.

  20. On the Outbound Document page, click Browse and select DecisionFactors as the document definition.

  21. Make sure that "Map inbound document to outbound document" is selected.

  22. Click Browse in the Map reference area and select mapBasicPO_decisionfactors.xml.

  23. Click Next twice, and then click Finish.


Create File Receive Functions

This section will create two File receive functions, BuyerReceiveFunction and BuyerEncryptedReceiveFunction, for picking up documents in c:\Buyer and c:\Buyer\Encrypted, respectively.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and then click BizTalk Server Administration.

  2. Expand the Microsoft BizTalk Server 2002 item in the left frame tree until the Queues and Receive Functions nodes are fully expanded.

  3. Add a new File receive function either by clicking the Receive Functions node and choosing Action | New | File Receive Function from the menu bar or by right-clicking the Receive Functions node and choosing New | File Receive Function from the context menu.

  4. Type BuyerReceiveFunction in the Name box. Comments can be left blank. The computer you are working on should be pre-selected in the drop-down list titled Server on which.

  5. Type myPO.csv in the text box labeled File type to poll for.

  6. Type c:\Encryption\Buyer in the text box labeled Polling Location.

  7. Click Advanced.

  8. In the Envelope Name drop-down list, select BasicPOEnv.

  9. In the Channel Name drop-down list, select BuyerEncryptChannel.

  10. Click OK to close the Advanced dialog box, and OK to close the Add a File Receive Function dialog box.

  11. Add the second File receive function with the name BuyerEncryptReceiveFunction.

  12. Type myPO*.txt in the text box labeled File type to poll for.

  13. Type c:\Encryption\Buyer\Encrypted in the text box labeled Polling Location.

  14. Click Advanced.

  15. In the Envelope Name drop-down list, select BasicPOEnv.

  16. In the Channel Name drop-down list, select BuyerHomeChannel.

  17. Click OK to close the Advanced dialog box, and OK to close the Add a File Receive Function dialog box.


Run the Sample Scenario

To run the sample, put the comma-delimited purchase order myPO.csv into the c:\Encryption\Buyer folder. This file gets signed and encrypted, and finally is transformed as a decision factor output to the c:\Encryption\Home folder.

This section contains the following topics:

  • Disable Intermediate Receive Function

  • Encrypt and Sign an Outbound Document

  • Receive an Encrypted and Signed Purchase Order


Disable Intermediate Receive Function

Temporarily disabling the receive function BuyerEncryptReceiveFunction will allow the intermediate signed and encrypted purchase order to be viewed.

  1. In the left frame of BizTalk Server Administrator, expand the tree down to the level of the Receive Function nodes.

  2. Right-click the receive function BuyerEncryptReceiveFunction and click Properties.

  3. Select the Disable receive function check box on the General tab.

  4. Click Yes to confirm.

  5. Click OK to close the receive function properties.


Encrypt and Sign an Outbound Document

  1. With BizTalk Server running, navigate to c:\Encryption\ and copy the file myPO.csv into c:\Encryption\Buyer.

    This file should be consumed by BizTalk Server, transformed, and submitted to c:\Encryption\Buyer\Encrypted as the file myPO_%tracking_id%.txt, where %tracking_id% is a unique ID value.

  2. Open c:\Encryption\Buyer\Encrypted\myPO_%tracking_id%.txt in Notepad to see that the content has been encrypted and signed.

  3. Close c:\Encryption\Buyer\Encrypted\myPO_%tracking_id%.txt.


Receive an Encrypted and Signed Purchase Order

  1. Enable the BuyerEncryptReceiveFunction by clearing the Disable receive function check box under the Properties of the receive function.

    The file myPO_%tracking_id%.txt in the c:\Encryption\Buyer\Encrypted folder should be consumed.

  2. Open the c:\Encryption\Home folder and look for a file called decisionfactor_%tracking_id%.xml, where the %tracking_id% symbol will be replaced with a GUID value.

  3. Open decisionfactor_%tracking_id%.xml in Notepad or Internet Explorer to verify that the content is valid XML.


Flat-File Delimited

This sample translates an inbound delimited flat-file source document into an XML destination document.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Flat-File Delimited

User's Guide

Before running the sample, complete the following steps:

  1. On the C drive, create a folder called FlatFileDelimited.

  2. On the C drive, create a folder called XMLDest.

  3. Copy FlatFileDelimited.xml to the folder \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft on the installation drive.

  4. Run FlatFileDelimitedSetup.vbs to configure BizTalk Messaging Services.

Note

  • The BizTalk Messaging Services configuration script, FlatFileDelimitedSetup.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Channel: Flat File Delimited To XML Channel

    2. Port: Flat File Delimited to XML Port

    3. Organization: Flat File Delimited Sample Org

    4. Document definition: Flat File Delimited to XML

    5. Envelope: Flat File Delimited Envelope

    6. File receive function: FlatFileDelimited

To run the sample, follow these steps:

  1. Ensure that the FlatFileDelimitedSampleData.txt file is not read-only. To modify this property, right-click the file, click Properties, clear the Read-only attribute, and then click OK.

  2. Copy and paste the flat file, FlatFileDelimitedSampleData.txt, to the C:\FlatFileDelimited folder. You should see an output XML file in the C:\XMLDest folder.

Programming Notes

The same document specification, FlatFileDelimited.xml, is used for both the inbound and outbound documents, so a map is not required.

Related Topic

Working with Positional and Delimited Flat Files


Flat-File Positional

This sample translates an inbound positional flat-file source document into an XML destination document.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Flat-FilePositional

User's Guide

Before running the sample, complete the following steps:

  1. On the C drive, create a folder called FlatFilePosSample with two subfolders called SourceOrg and DestOrg.

  2. On the BizTalk Server installation drive, copy FlatFilePosSpec.xml to \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

  3. Run FlatFilePosConfig.vbs to configure BizTalk Messaging Services.

To run the sample, follow these steps:

  1. Ensure that the FlatFilePosSampleData.txt file is not read-only. To modify this property, right-click the file, click Properties, clear the Read-only attribute, and then click OK.

  2. Copy and paste the flat file, FlatFilePosSampleData.txt, to the C:\FlatFilePosSample\SourceOrg folder. You should see an output XML file in the C:\CustomCounterSample\DestOrg folder.

Note

  • The BizTalk Messaging Services configuration script, FlatFilePosConfig.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Channel: FlatFile Positional Channel

    2. Messaging Port: FlatFile Positional Port

    3. Organizations: FlatFilePos Source Organization, FlatFilePos Destination Organization

    4. Document Definition: FlatFilePosDef

    5. Envelope: FlatFilePosEnv

    6. File Receive Function: FlatFilePos

Programming Notes

The same document specification, FlatFilePosSpec.xml, is used for both the inbound and outbound documents, so a map is not required.

Related Topic

Working with Positional and Delimited Flat Files


HTTP Receive Function

This sample illustrates how an online buyer organization delivers a purchase order (PO) to a supplier organization through a Web-based front end. The information is converted to an XML document and is sent to BizTalk Server by using an HTTP receive function.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function

User's Guide

To prepare and run the sample, follow these steps:

  • Set Up the Web Site Environment

  • Run the HTTP Receive Function Sample

Note

  • This sample assumes that BizTalk Server is installed on your C drive. If this is not the case, you should make the appropriate path modifications.


Set Up the Web Site Environment

This section shows you how to set up the Web-based order entry screen, the IIS virtual directory, and the objects that are needed to create and deliver an XML document by using an HTTP receive function.

This section contains the following topics:

  • Create a Web Application

  • Configure the IIS COM+ Package

  • Examine Default.htm

  • Examine ProcessPO.asp

  • Create an HTTP Receive Function


Create a Web Application

In this procedure, you create a Web application to host the order entry form and send the contents to the HTTP receive function.

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Internet Services Manager.

    The Internet Services Manager console appears.

  4. In the Internet Services Manager console tree, expand the <your computer> node.

  5. Right-click Default Web Site.

  6. On the Action menu, click New, and then click Virtual Directory.

    The Virtual Directory Creation Wizard appears.

  7. On the Welcome to the Virtual Directory Creation Wizard page, click Next.

  8. On the Virtual Directory Alias page, in the Alias box, type PurchaseSite and then click Next.

  9. On the Web Site Content Directory page, click Browse.

  10. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function, click OK, and then click Next.

  11. On the Access Permissions page, make sure that the Execute (such as ISAPI applications or CGI) option is selected and then click Next.

  12. Click Finish to close the Virtual Directory Creation Wizard.

  13. Right-click PurchaseSite.

  14. On the menu that appears, click Properties.

  15. In the Virtual Directory section, make sure that Execute Permissions is set to Scripts and Executables.

  16. In the same section, change the Application Protection option to High (Isolated).

  17. Click OK.

  18. Copy the BizTalkHTTPReceive.dll file to the location that was specified on the Web Site Content Directory page during the creation of the virtual directory.


Configure the IIS COM+ Package

In this procedure, you modify the account under which the Internet Information Services component runs for PurchaseSite.

  1. On the Start menu, point to Settings, and then click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Component Services.

  4. In the Component Services Manager console tree, expand the Component Services node.

  5. Expand Computers, and then expand COM+ Applications.

  6. Right-click IIS-{Default Web Site//Root/PurchaseSite}.

  7. Click Properties.

  8. The IIS-{Default Web Site//Root/PurchaseSite} Properties manager appears.

  9. Click the Identity tab.

  10. Change the account under which the application will run to Interactive user – the current logged on user, or to a user with the appropriate authority.


Examine Default.htm

Look at Default.htm. This HTML file is located in the HTTP Receive Function sample folder, and is a Web-based entry form that will post the information entered to the ProcessPO.asp file.


Examine ProcessPO.asp

Look at ProcessPO.asp. This .asp file is located in the HTTP Receive Function sample folder, and accepts the information that Default.htm sends to it. This .asp file takes the information that is entered in the HTTP form, converts the information into well-formed XML, and posts the XML to the PurchaseSiteFunc HTTP receive function.


Create an HTTP Receive Function

In this procedure, you create an HTTP receive function to process the purchase order.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  2. Expand Microsoft BizTalk Server, expand BizTalk Server Group, and then click Receive Functions.

  3. On the Action menu, point to New, and then click HTTP Receive Function.

    The Add an HTTP Receive Function dialog box appears.

  4. In the Name box, type PurchaseSiteFunc.

  5. In the Server on which the receive function will run box, click the name of a server in the BizTalk Server group.

  6. In the Virtual directory box, type PurchaseSite/biztalkhttpreceive.dll?PO.

  7. In the Submit to drop-down list box, select the File option.

    You can also configure the HTTP receive function to send the data received to BizTalk Server synchronously or asynchronously.

  8. In the File Path and Name box, type \Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function\PurchaseOrder_%guid%.xml.

    This is the path of the file that the HTTP receive function will create. Notice that the GUID is used as a unique identifier.

  9. Click OK to close the Add a File Receive Function dialog box.

  10. Close BizTalk Server Administration.


Run the HTTP Receive Function Sample

This section shows you how to run the HTTP receive function sample.

  1. Open your Web browser.

  2. Point your browser to the virtual directory that you created earlier (for example, http://localhost/PurchaseSite).

    This will bring up the HTTP Receive Function Sample Purchase Order Form.

  3. Enter information in the various fields and then click Submit.

    This will send the information that you just entered to the ProcessPO.asp file. This .asp file will convert the information into well-formed XML and then post the information to the PurchaseSiteFunc HTTP receive function that you created earlier.

  4. A reply message will be displayed stating that the BizTalk Server system has processed your order.

    You can verify this by looking in the \Program Files\Microsoft BizTalk Server\SDK\HTTP Receive Function directory for an XML file.


Mapping Twice

This sample demonstrates mapping a document from its source to its destination by using two iterations.

Biztalk Server allows you to map a document synchronously through two iterations by using SubmitSync and the Loopback transport service. You can break your mapping into various stages by reusing and combining different channels.

In this scenario, we will first map Input.xml (which is hard-coded in the Microsoft Visual Basic source) to an intermediate XML file by using 1stMap.xml. A message box will report the resulting IntermediateOutput.xml file. Then we will map IntermediateOutput.xml to the final destination, producing FinalOutput.xml.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Mapping Twice

User's Guide

Before running the sample, complete the following steps:

  1. In the Mapping Twice sample directory, double-click the DocSpecs folder.

  2. Copy the Microsoft folder and paste it into the DocSpecs repository at:

    \Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs

  3. In the Mapping Twice sample directory, double-click the Maps folder.

  4. Copy the Microsoft folder and paste it into the Maps Repository at:

    \Microsoft BizTalk Server\BizTalkServerRepository\Maps

  5. Double-click SetUp.vbs to run Setup.

To run the sample:

  • Run Mapping_Twice.exe.

Programming Notes

In the first mapping, the following files are used:

File name | Purpose
Input.xml | Source instance file
SourceDocSpec.xml | Source specification file
IntermediateDocSpec.xml | Intermediate specification file
1stMap.xml | Map source file
IntermediateOutput.xml | Intermediate instance after first mapping

In the second mapping, the following files are used:

File name | Purpose
IntermediateOutput.xml | Intermediate instance file
IntermediateDocSpec.xml | Intermediate specification file
DestinationDocSpec.xml | Destination specification file
2ndMap.xml | Map source file
FinalOutput.xml | Final instance after first mapping

When running the sample, the first Msgbox should correspond to /Data/IntermediateOutput.xml, and the second Msgbox should correspond to /Data/FinalOutput.xml.

The application will create two files in the Mapping Twice sample folder: SampleIntermediateOutput.xml and SampleFinalOutput.xml. These files hold the values in the two messages that are displayed when you run the Mapping_Twice.exe file.

The BizTalk Messaging Services configuration script, SetUp.vbs, should be run only once. If you want to run the script again, you must first delete the configuration objects, such as organizations, ports, channels, and so on, that were previously created by the script.


Message Queuing 4 MB Limit

This sample shows one way to process documents that exceed the Message Queuing maximum size limit. Depending on your requirements, this method might not be suitable.

Message Queuing is limited in the size of documents that can be processed. The maximum size document that Message Queuing supports is 4 MB if the document is in ASCII. The message queue can handle a maximum of 2 MB if the document is in Unicode.

In the Message Queuing 4 MB sample, a buyer organization delivers a large purchase order (PO) file, in excess of 4 MB, to a supplier organization by using the BizTalk Framework 2.0 reliable messaging protocol.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\MSMQ 4MB Limit

User's Guide

Before running the sample, complete the following steps:

  1. In the MSMQ 4MB Limit directory remove the read-only property on the following files:

    BigCustomerPO.xml

    CustomerPO.xml

    MSMQ 4MB Limit.skv

    MSMQ 4MB Limit.skx

  2. Copy the following files to the Biztalk Repository at \Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft:

    \Setup\Docs\customerid.xml

    \Setup\Docs\largeFileReceive.xml

  3. Create a private transactional queue named customeridq in the Computer Management tool. Be sure to modify the security settings for this queue to allow everyone full control.

  4. In the SetUp folder, run SetUp.cmd and follow the prompts.

  5. Close the Command window if it is still open.

  6. Install XML for SQL Server Web Release 1 (WR1) by finding the downloadable release at: www.microsoft.com/sql/downloads.

  7. Modify the CustomerPO.xml and BigCustomerPO.xml files so that they are editable. By default, the files are read-only. If the file attributes are not changed, the sample will not work correctly.

    XML for SQL Server is required for this sample.

Verify that the settings are correct:

  1. Open Biztalk Server Administration. Expand the Console Root until you see Receive Functions.

  2. Click filercv_CustomerPO. In the right pane, edit this File receive function by double-clicking filercv_CustomerPO.

  3. On the General tab, be sure that the Disable Receive Function check box is cleared.

  4. On the Services tab, be sure that the Polling Location is polling in the \POdrop folder in your Samples directory.

  5. Click OK.

  6. Click msmqrcv_CustomerID. In the right pane, edit this File receive function by double-clicking msmqrcv_CustomerID.

  7. On the General tab, be sure that the Disable Receive Function check box is cleared.

Modify the Orchestration schedule:

  1. Edit the Orchestration schedule by right-clicking MSMQ 4MB Limit.skv and selecting Edit With Orchestration Designer.

  2. Double-click the blue line connecting the port to the action "Receive CustomerID from Queue."

  3. Click Next four times until you see Message Specification Information.

  4. Click Browse and select the location of \Schemas\CustomerID.xml in the MSMQ 4MB Limit sample folder.

  5. Double-click the GetSQLData COM shape; this should open the COM Component Binding Wizard.

  6. Click Next twice.

  7. Under Class Information, double-click the GetSqlData folder to expand the component.

  8. Double-click the getData class.

  9. Click Finish.

    If a message box appears, click OK and perform the following steps:

    1. Double-click the red and blue lines connecting the port to the action "Call COM Object."

    2. Click Next.

    3. Click Finish.

    4. Click Yes in the dialog box.

    5. Open the Data Flow page by clicking the Data tab.

    6. Under the msg_CustomerID table, connect CustomerID to the strCust_ID in the getData_in table.

    7. Make the XLANG schedule by clicking Make XLANG MSMQ 4MB Limit.skx on the File menu.

    8. Be sure that XLANG MSMQ 4MB Limit.skx is being created in the MSMQ 4MB Limit samples directory.

    9. Click OK to replace the file.

Update the messaging port

  1. Open Biztalk Messaging Manager and search for all ports.

  2. Double-click the port_CustomerID port.

  3. Click Next.

  4. In the first input box under "New XLANG schedule" click Browse.

  5. Select MSMQ 4MB Limit.skx in your Samples directory.

  6. Click Finish.

To run the sample:

  • Copy CustomerPO.xml and paste it into \PODrop to run this sample. You should see a message box pop up momentarily. Check the Event Logs for errors. The CustomerPO.xml file is a small test file that will be processed in the same manner as a large file. To test a large file, copy the BigCustomerPO.xml file to the \PODrop directory. Processing a large file will take longer.

Programming Notes

The BizTalk Messaging Services configuration script, SetUp.cmd, should be run only once. If you want to run the script again, you must first delete the configuration objects, such as organizations, ports, channels, and so on, that were previously created by the script.

The following objects are created by the setup file:

Organizations

org_CustomerID

org_CustomerPO

Channels

channel_CustomerID

channel_CustomerPO

Document Definitions

docdef_CustomerID

docdef_CustomerPO

Messaging Ports

port_CustomerID

port_CustomerPO

Receive Functions (in BizTalk Server Administration):

filercv_CustomerPO

msmqrcv_CustomerID

Messaging Queues (in Computer Management)

customeridq

BizTalk Server Repository

largeFileReceive.xml

customerid.xml


Multi-Part MIME Attachment

This sample shows how BizTalk Server handles an inbound document that contains multiple MIME attachments.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Multi-Part MIME Attachment

User's Guide

Before running the sample, complete the following steps:

  1. On the Start menu, click Run.

  2. On the command line type CMD.

    This will bring up a Command Line window.

  3. Change the directory to the Multi-Part MIME Attachment sample directory.

  4. Type Config.wsf.

    This will create the MimeSampleSource->MimeSampleDest port, MimeSampleSource->MimeSampleDest channel, CommonPO document definition, BTFEnvelope envelope, and the MimeSample_DestinationOrg and MimeSample_SourceOrg organizations.

  5. Type Exit in the Command Line window to close it.

  6. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  7. Double-click Microsoft BizTalk Server 2002.

  8. Right-click BizTalk Server Group, click Properties, and then click the Tracking tab.

  9. Ensure that the Enable Document Tracking and Log the original MIME-encoded message check boxes are selected.

    These options instruct BizTalk Server to store in a table all incoming documents as well as the original MIME documents.

  10. Click OK.

  11. Close BizTalk Server Administration.

To run the sample, follow these steps:

  1. On the Start menu, click Run.

  2. On the command line type CMD.

    This will bring up a Command Line window.

  3. Change the directory to the Multi-Part MIME Attachment sample directory.

  4. Type Submit.vbs.

    This script file will use the Submit method to submit the CommonPOAttached.txt file to BizTalk Server. When the submission process is complete, a message box will appear stating that the submission was successful.

  5. Verify that a new file has been created in the Multi-Part MIME Attachment sample directory. This file will be named with a unique GUID and have a .txt extension (for example, {4DE29CC8-7631-46A7-BCA7-F92B910A2AD1}.txt).

  6. Type Exit in the Command Line window to close it.

    You can verify that the MIME attachments have been included by opening the .txt file. Note that the XML data within the multi-part MIME file is encapsulated by a SOAP envelope.

Programming Notes

This sample assumes that BizTalk Server is installed on your C drive. If this is not the case, you should make the appropriate path modifications.


Pipeline Component in Visual Basic

This sample demonstrates an application integration component (AIC) that implements the IPipelineComponent and IPipelineComponentAdmin interfaces in Microsoft Visual Basic. The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the Microsoft BizTalk Server repository), logs some of the properties passed to it in the dictionary, and copies the incoming message to a file.

For a related sample, see Pipeline Component in Visual C++.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\PipelineComponent\VB

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual Basic component (this is optional because the DLL is provided).

  2. Register the component, its category IDs, and its setup configuration by running:

    cscript scenario.wsf //job:setup

    When asked whether to register information from Affinity.reg, click "Yes." The component ProgID is "BTSSamples_VBPipeComp.PipelineComp".

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_VBPipeComp" by using the command:

    cscript scenario.wsf //job:submit

    If the submission succeeds, a log file, BTSSamples.log, and an output file, BTSSamples_pipe.out, will be created in the temporary system directory (C:\WINNT\temp).

Programming Notes

If you want to configure the component, you must' copy the ASP pages to the directory designated for property pages (for example, C:\Program Files\Microsoft BizTalk Server\MessagingManager\pipeline). You can then open the BizTalk Messaging Manager and edit the channel. The Advanced button in the last dialog box allows you to set the properties for the primary transport.


Pipeline Component in Visual C++

This sample demonstrates an application integration component (AIC) that implements the IPipelineComponent and IPipelineComponentAdmin interfaces by using the Active Template Library (ATL). The component provided in this sample receives a document that validates against the CommonPO.xml schema (provided by default in the Microsoft BizTalk Server repository), logs some of the default dictionary properties to a file, C:\temp\BTSSamples_ATLPipeComp.log, and writes the incoming data to another file, C:\BTSSamples_ATLPipeComp.out.

For a related sample, see Pipeline Component in Visual Basic.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\PipelineComponent\VC\ATL

User's Guide

Before running the sample, complete the following steps:

  1. Compile the Visual C++ component.

  2. Set up the configuration by running:

    cscript scenario.wsf //job:setup

    The component ProgID is "BTSSamples_AtlPipelineComp BTSPipelineComp".

  3. Copy ASP files to the configuration files for BizTalk Messaging Manager:

    C:\Program Files\Microsoft BizTalk Server\MessagingManager\pipeline

    You can now change the default settings for output and log files.

To run the sample:

  • Submit a document on the channel "BTSSamples_Channel_ATLPipelineComp" by using the command:

    cscript scenario.wsf //job:Submit

    If the submit succeeds, you will get two files:

    C:\temp\BTSSamples_ATLPipeComp.log

    C:\temp\BTSSamples_ATLPipeComp.out


Queue Sniffer

This sample enables you to view, forward, and remove messages in Message Queuing queues. This application supports the following features:

  • Displays the entire content of a message

  • Displays XML and flat text file formats

  • Accesses message queues on remote servers

  • Performs criteria-based searches for specific messages

  • Forwards messages to other message queues

  • Removes messages from a queue

  • Retrieves detailed message information

  • Displays journal messages

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Queue Sniffer

User's Guide

To use this application, perform the following steps:

  1. Run the executable file QueueSniffer.exe, located on the BizTalk Server installation drive at \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Queue Sniffer\QueueSniffer.exe.

  2. Type the name or TCP/IP address of a Message Queuing server in the Message Queuing Server text box that is located at the top of the window.

  3. Type a message queue name in the Message Queue text box.

  4. If the queue you are accessing is transactional, select the Use Transactional Queue check box.

  5. If you wish to view journal messages for the queue, select the Use Journal check box.

After you have entered the required information, you can perform one of the following actions:

  • View the next message in the queue. Click View Next Message to display the next message in the queue.

  • Search for a specific message in the queue. Enter search criteria in the Message Search Criteria section and click Search to display a message that matches your criteria. Click Search again to see the next message that matches your search criteria.

After a message is displayed in the Message Information area, you can remove the message from the queue by clicking Remove from Queue, or you can forward a copy of the message to another queue by clicking Forward Message.

Note

  • The information in the message label cannot be passed to a remote queue.


Receive Scripts

This sample demonstrates an HTTP receive function.

ReceiveResponse.asp is used as a page where the BizTalk Messaging Service receives documents to be sent to an existing Orchestration schedule. If you copy that page into your localhost location, you can use http://localhost/ReceiveResponse.asp as the HTTP URL address on the Channel Information page of the BizTalk Messaging Binding Wizard.

ReceiveStandard.asp is an example of an HTTP receive function. The document data posted to that page will be submitted as a self–routing document for a NOT OPEN configuration.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReceiveScripts

Programming Notes

The Exchange Server 5.5 folder contains an example SMTP receive function. The document data sent as an e-mail message will be deposited into C:\temp\RS_data.txt and then submitted as a self-routing document for a NOT OPEN configuration.

The Exchange Server 2000 folder contains an example of an event sink that intercepts e-mail messages and submits them to BizTalk Server. See the readme.doc file in that folder for more details.


Refresh Messaging Manager

This sample allows you to refresh objects in BizTalk Messaging Manager. You must refresh the objects in the Messaging Manager when a document definition, envelope, or channel is modified. This sample lets you choose whether to refresh all objects or individual objects.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Refresh Messaging Manager

User's Guide

To prepare and run the sample, follow these steps:

  1. Copy the BTM_RefreshV2.exe file to the BizTalk Server on which you are working.

    The BTM_RefreshV2.exe file can be copied to any BizTalk Server. The Refresh Messaging Manager application will only affect the BizTalk Server that it is currently running on.

  2. Open Windows Explorer and browse to the BTM_RefreshV2.exe file.

  3. Double-click the BTM_RefreshV2.exe file to start the application.

    Within the application are three windows that display the document definitions, envelopes, and channels that are available on the BizTalk Server.

  4. To refresh individual objects, highlight the objects and then click the corresponding button to refresh only the highlighted objects. To refresh all the listed objects (whether highlighted or not), click Update All.

  5. To exit, click Exit.

Note

  • This sample assumes that BizTalk Server is installed on your C drive. If this is not the case, you should make the appropriate path modifications.


Reliable Messaging

This sample illustrates how a buyer organization delivers a purchase order (PO) to a supplier organization by using the BizTalk Framework 2.0 reliable messaging protocol.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMessaging

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Enable Reliable Messaging

  • Run the Reliable Messaging Sample

Note

  • The BizTalk Messaging Services configuration script, ReliableMsgConfig.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Applications: PurchaserOrgApp, SupplierOrgApp

    2. Channels: PurchaserOrgOutgoingMsgChannel, SupplierOrgIncomingMsgChannel

    3. Messaging Ports: PurchaserOrgOutgoingPort, SupplierOrgIncomingPort

    4. Organization: Supplier Organization

    5. Document Definition: PurchaserOrgPO

    6. Envelope: PurchaserReliableEnvelope

    7. File Receive Functions: PurchaserOrgOutgoingFunc, SupplierOrgIncomingFunc

Programming Notes

BizTalk Framework 2.0 (BTF) guarantees only a single delivery of a message to the destination organization. After the supplier organization receives the message, the BizTalk Server in the supplier organization responds with a receipt to the purchaser organization. When the purchaser organization receives the receipt, the transmission is complete.

As a brief example, consider an application (PurchaserOrgApp) in the buyer organization, which sends a PO to BizTalk Server (PurchaserOrg), which, in turn, delivers the PO to the supplier organization application (SupplierOrgApp), as explained below:

BizTalk Server in the buyer organization

  1. BizTalk Server wraps the PO with a BTF reliable message envelope and sends the message to the supplier organization.

  2. BizTalk Server places a copy of the PO into the BizTalk Server Retry queue.

  3. BizTalk Server tries to send the PO to a supplier organization until a BTF receipt is received. The number of retries is based on the configuration and the interval between retries.

  4. When the number of retries is exhausted and the receipt has not been received, the PO is placed into the Suspended queue.

  5. If the receipt arrives before the number of retries is exhausted, BTF removes the PO from the Retry queue.

BizTalk Server in the supplier organization

  1. BizTalk Server removes the PO from the BTF envelope and sends an acknowledgement receipt to the source organization.

  2. The PO, without an envelope, is delivered to the supplier organization's internal application.

  3. BizTalk Server logs the PO in the document-tracking database. However, no log is created for the receipt.

When BizTalk Messaging Services on the supplier organization receives an interchange with a reliable messaging format, it uses a special document definition, channel, and messaging port to process and transport a receipt to the buyer organization. These special system objects are not viewable in BizTalk Messaging Manager, and you cannot create similar objects by using the reserved system names.

BizTalk Server uses the reply-to address that is included in the header of the inbound interchange as the destination address for the receipt. You do not need to further configure BizTalk Messaging Services for the supplier system to return a receipt for an interchange sent with the reliable messaging envelope.


Preliminary Setup

Before you begin the sample, you must complete the following tasks:

  • Create Folders

  • Copy Files

  • Run Setup Script


Create Folders

In this procedure, you create one folder that contains six subfolders. You use four of the subfolders as locations for messages as they move into and out of the buyer and seller systems, one as a repository for the reliable receipt and one as a document data folder.

To create the folders:

  1. In Windows Explorer, browse to the root directory of your C drive.

  2. Create a new folder on the root of the C drive; name the folder ReliableMessaging.

  3. Click the new ReliableMessaging folder and create two subfolders with the following names:
    • PurchaserOrg

    • SupplierOrg
  4. Click the new PurchaserOrg folder and create two subfolders with the following names:
    • InPurchaserOrg

    • ReliableReceipts
  5. Click the new SupplierOrg folder and create two subfolders with the following names:
    • InSupplierOrg

    • OutSupplierOrg


Copy Files

In this procedure, you copy the files that are needed to complete the sample.

  1. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMesssaging and copy POSpec.xml.

  2. Paste the file to \Program Files\Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs\Microsoft.

  3. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMesssaging and copy ReliableMsgReceipt.asp.

  4. Paste the file to C:\ReliableMesssaging\PurchaserOrg.


Run Setup Script

In this procedure, you run the script that sets up all the messaging configuration objects that are necessary for this sample.

  • Run ReliableMsgConfig.vbs to configure BizTalk Messaging Services.


Enable Reliable Messaging

This section shows you how to enable reliable messaging for the sample. It contains the following topics:

  • Create a Web Application

  • Examine ReliableMsgReceipt.asp

  • Define a Reliable Messaging Reply-to URL


Create a Web Application

In this procedure, you create a Web application to receive the reliable messaging receipt.

  1. On the Start menu, point to Settings and click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Internet Services Manager.

    The Internet Services Manager console appears.

  4. In the Internet Services Manager console tree, expand <your computer>.

  5. Right-click Default Web Site.

  6. On the Action menu, select New and click Virtual Directory.

    The Virtual Directory Creation Wizard appears.

  7. On the Welcome to the Virtual Directory Creation Wizard page, click Next.

  8. On the Virtual Directory Alias page, in the Alias box, type PurchaserOrg and click Next.

  9. On the Web Site Content Directory page, click Browse.

  10. Browse to C:\ReliableMessaging\PurchaserOrg, click OK, and then click Next.

  11. On the Access Permissions page, click Next.

  12. Click Finish to close the Virtual Directory Creation Wizard.


Examine ReliableMsgReceipt.asp

Look at ReliableMsgReceipt.asp. This ASP file is located in the PurchaserOrg directory, and is a standard receive page that delivers the receipt to the buyer organization, using BizTalk Framework 2.0.

For the call to Submit, the only parameters specified are the openness type and the document string, as shown in the following code:

SubmissionHandle = interchange.submit( 1, PostedDocument )

BizTalk Server understands the schema of the reliable message receipt, so you do not need to define a port or a channel to process the receipt.


Define a Reliable Messaging Reply-to URL

In this procedure, you define a reliable messaging reply-to URL.

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

    The BizTalk Server Administration console appears.

  2. In the BizTalk Server Administration console tree, expand BizTalk Server.

  3. Right-click BizTalk Server Group.

  4. On the Action menu, right-click Properties.

    The BizTalk Server Group Properties dialog box appears.

  5. On the General tab, in the Reliable messaging repy-to URL box, type http://localhost/PurchaserOrg/ReliableMsgReceipt.asp, click Apply, and click OK.

    ReliableMsgReceipt.asp is an ASP file that uses the Submit method to deliver the receipt to the PurchaserOrg BizTalk Server.

    The URL that is specified is used by the supplier system BizTalk Server to deliver the receipt to the buyer system BizTalk Server.


Run the Reliable Messaging Sample

This section shows you how to run the reliable messaging sample. It contains the following topics:

  • Run the Sample with a Disabled Receive Function

  • Run the Sample with an Enabled Receive Function

To run the sample, you need to remove the read-only property from the sample data file, SamplePO.xml.


Run the Sample with a Disabled Receive Function

Run the sample with a disabled receive function to allow you to analyze the content of the inbound purchase order (PO) from the buyer system. You will be able to look at the purchase order wrapped with a BizTalk Framework 2.0 reliable envelope.

Before running the sample, disable the receive function in the seller system, so that you can view the content of the arriving purchase order (PO) from the buyer system. You will be able to analyze the PO wrapped with the BizTalk Framework 2.0 reliable envelope.

To disable the receive function:

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  2. Expand Microsoft BizTalk Server, expand BizTalk Server Group, and then click Receive Functions.

  3. Click the receive function named SupplierOrgIncomingFunc.

  4. On the Action menu, click Properties.

    The Properties dialog box appears.

  5. Select the Disable receive function check box, and then click Yes to confirm your choice.

  6. Click OK.

To submit the PO:

  1. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\ReliableMesssaging and copy SamplePO.xml.

  2. Paste the file to C:\ReliableMesssaging\PurchaserOrg\InPurchaserOrg.

    In this step you place the sample purchase order (PO) to the directory that is being monitored by the buyer system receive function. The receive function will pick up the sample PO.

    At this point, you can view the sample PO in the Retry queue. Note the number of retries and the time interval between each retry.

  3. Browse to C:\ReliableMessaging\SupplierOrg\InSupplierOrg.

    In this directory, you can view the sample PO arriving from the buyer system. The message contains two parts, the SOAP envelope and the body. The body of the message contains the sample PO.


Run the Sample with an Enabled Receive Function

By enabling the receive function on the supplier system, you allow the inbound sample purchase order (PO) to be picked up. Then BizTalk Server removes the envelope, sends a receipt to the buyer system, and submits the PO to the supplier system application through the configured port and channel.

To enable the receive function:

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server, and then click BizTalk Server Administration.

  2. Expand Microsoft BizTalk Server, expand BizTalk Server Group, and then click Receive Functions.

  3. Click the receive function named SupplierOrgIncomingFunc.

  4. On the Action menu, click Properties.

    The Properties dialog box appears.

  5. Clear the Disable receive function check box, and then click OK.

    After enabling the receive function, BizTalk Server delivers the reliable message receipt to the reply-to URL, http://localhost/PurchaserOrg/ReliableMsgReceipt.asp.

To complete the sample:

  1. Browse to C:\ReliableMessaging\SupplierOrg\OutSupplierOrg.

    In this directory, you can view the PO. Note that there is no envelope information, and that it is the same PO that was originally sent by the buyer system.

  2. Browse to C:\ReliableMessaging\PurchaserOrg\ReliableReceipts.

    In this directory, you can view the receipt file. The receipt file contains the reply-to URL and the from and to tags. Note that the receipt file contains no information on the PO.


Self-Routing

This sample demonstrates the BizTalk Server 2002 capability to route documents through BizTalk Server channels and ports based on the contents of the document being routed.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Self-Routing

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Run the Self-Routing Sample

Programming Notes

This sample walks through the process of setting up a self-routing document scheme that utilizes the routing capabilities of BizTalk Server 2002 and, in the process, demonstrates the following:

  • The use of dictionary properties that are added to document specifications by BizTalk Editor and are used by the BizTalk Server runtime to determine routing

  • The use of envelopes to parse and route differently formatted inbound flat files

  • The use of document selection criteria to determine routing

  • The use of receive functions in determining routing

In this sample, we will modify the business scenario and show how a single receive function can be used, with three different inbound file formats, channels, and maps, to send the same DecisionFactors document to the approver through the existing ApprovalMessagingPort port.

We modify the POApproval scenario by introducing the following business requirements:

  • Rather than one buyer organization, as in the original POApproval scenario, we now have two separate buyer departments, each of which has its own flat-file format for a purchase order. The buyer departments are divided by region: Northwest buyers (NWB) and Central buyers (CB).

  • Each buyer department has agreed to add a common header record, known as an inbound envelope, to each of their purchase orders before submitting them for approval. They have also agreed to a data content convention for the common header to properly route their documents.

  • We want to reuse our existing business logic, approver addresses, and wire protocols to route documents from both buyer departments with a minimum of additional effort.

  • We want to use a single share drop location on the network for both departments and a single receive function no matter how many buyer departments we add in the future. Note that we are assuming that all departments added in the future will send flat files with the common header.

Inbound Envelope

Each buyer department uses the inbound envelope to tell BizTalk Server the source of the document and which file format to expect. The envelope has the following format:

POHeader,999,XXX

The first field in the envelope is a constant string literal (that is, identical and unchanging in all documents) that is used to identify the record type when the inbound file is parsed. This is the primary mechanism that BizTalk Server uses at run time to separate individual purchase orders that are submitted in the same flat file.

The second and third fields correspond to the document Source Qualifier and Source Name respectively. In addition, the third field doubles as the Document Type property for the associated purchase order. Because each buyer department sends only one document format, the third field can be "overloaded" in this way.

The Northwest and Central buyer departments provide the Source Qualifier/Source Name pairs 10/NWB and 12/CB, respectively.

A document specification file is provided by the sample and contains the XML-Data Reduced (XDR) information for the envelope. The file name for this specification is defPOEnv.xml. If you look at this file in BizTalk Editor you will see that the string "POHeader" has been entered as the Source Tag Identifier for the record.

Buyer Department Document Specifications and Input Files

The sample provides the document specifications and sample input files for the buyer departments. The specifications are named defNWBPO.xml and defCBPO.xml for the Northwest and Central departments respectively. The sample input files are named NWBPOx.csv and CBPOx.csv, where x is the number of purchase orders in the file (that is, the number of common header records that you should expect to see).


Preliminary Setup

Before you begin the sample, you must complete the following tasks to set up the basic POApproval scenario:

  • Copy Self-Routing Document Specifications and Maps to the Repository

  • Create Two Private Transactional Message Queuing Queues

  • Create Folders

  • Copy Files

  • Remove Read-Only Property from .csv File

  • Run Setup Script

  • Check Receive Function


Copy Self-Routing Document Specifications and Maps to the Repository

  1. In the Self-Routing sample directory, double-click the DocSpecs folder.

  2. Copy the POApproval folder and paste it into the DocSpecs repository at:
    \Microsoft BizTalk Server\BizTalkServerRepository\DocSpecs

  3. In the Self-Routing sample directory, double-click the Maps folder.

  4. Copy the POApproval folder and paste it into the Maps repository at:
    \Microsoft BizTalk Server\BizTalkServerRepository\Maps


Create Two Private Transactional Message Queuing Queues

  1. On the Start menu, point to Settings, click Control Panel, double-click Administrative Tools, and then double-click Computer Management.

  2. Expand the Services and Application node.

  3. Expand the Message Queuing node.

  4. Right-click the Private Queues folder, point to New, and then click Private Queue.

  5. In the Name text box, type approvalmsmq and select the Transactional check box.

  6. Click OK.

  7. Repeat steps 4 through 6 to create another new private queue named responsemsmq.


Create Folders

In this procedure, you create the folder that is necessary to run the sample.

  1. In Windows Explorer, browse to the root directory of your C drive.

  2. Create a new folder on the root of the C drive; name the folder Data.


Copy Files

In this procedure, you copy files that are needed to complete the sample.

  1. On the BizTalk Server installation drive, browse to \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Self-Routing and copy the following two folders: POApproval, SetUp.vbs.

  2. Paste the folders to C:\Data\.


Remove Read-Only Property from .csv File

  1. In the C:\Data\POApproval folder there are three files: NWBPO2.csv, NWBPO1.csv,and CBPO1.csv.

  2. While holding CTRL, select the three files.

  3. Right-click the selection and click Properties.

  4. On the General tab, in the Attributes area, clear the Read-only check box.

  5. Click OK.


Run Setup Script

In this procedure, you run the script that sets up all the ports, channels, document definitions, maps, and specifications that are necessary for this sample.

  1. On the Biztalk Server installation drive, browse to C:\Data and double-click the executable file SetUp.vbs. The command prompt window should appear detailing the configuration process.

  2. When the script finishes, the window should close.


Check Receive Function

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and click Biztalk Server Administration.

  2. From the Console Root navigate to \Microsoft BizTalk Server 2002\BizTalk Server Group\Receive Functions. Right-click ApprovalReceiveFunction and click Properties.

  3. Be sure that the Disable receive function check box is cleared.

  4. Click OK. You can now close Biztalk Server Administration.


Run the Self-Routing Sample

This sample demonstrates that each document is processed through the channel that is designed for that specific document, and that each document is delivered to the Approval queue, ready to be processed by the POApproval.skx schedule. Although the documents have differing sources and starting formats, they are processed by the POApproval scenario with little modification (only the receive function is modified).

This sample also shows how to use BizTalk Document Tracking to check the history and status of documents that pass through BizTalk Server.

This section contains the following topics:

  • Drop Inbound Purchase Orders for Approval

  • Use BizTalk Document Tracking to View Processing History

  • Check That Each Document Is Processed Through the Proper Channel

BizTalk Server needs five key pieces of information to select channels into which to route incoming documents: Source Qualifier, Source Name, Destination Qualifier, Destination Name, and Document Definition Name. Using this data, BizTalk Server queries the BizTalk Messaging Management database to acquire a list of appropriate channels.

An appropriate channel meets all of the following criteria:

  • Its source organization matches the source key values.

  • It is attached to a port with a destination organization that matches the destination key values.

  • It has an inbound document definition name that matches the document definition key name.

The following things happen when one of the self-routing documents is submitted to the receive function:

  • When the receive function loads the document from the monitored file share, it first determines the file type. It does this through a "snoop and loop" approach, testing for each file type in the order specified on the Parsers tab of the Properties dialog for the BizTalk Server Group in the BizTalk Administrator snap-in. In our case, the file is a flat file.

  • All flat files that are consumed by receive functions require an envelope. One of the primary purposes of the envelope is to determine individual document boundaries in the incoming file. Another purpose of the envelope is to act as a reliable way to provide routing information. In our case the source information and the selection criteria for our routing is in the header.

  • To determine the document definition name using the header information, BizTalk Server first uses the document schema (defined in BizTalk Editor and referenced by the document definition in BizTalk Messaging Manager) to parse the header, convert it to XML, and load it into the Document Object Model (DOM). Using the dictionary properties in the header schema, BizTalk Server retrieves three key pieces of information: the source qualifier, the source name, and the document type selection criteria.

  • Because the destination key values are provided to BizTalk Server by the receive function, we have four out of five key values. We still need the document definition to parse and convert the bulk (that is, the non-envelope) portions of the document. BizTalk Server accomplishes this by performing a query against the BizTalk Messaging Management database using the selection criteria, in our case, document_type. For example, BizTalk Server would query for all of the document definitions that have a selection criteria called document_type that is equal to the value pulled from the header, for example, "NWB".

  • After all five keys are determined, BizTalk Server makes the final query to find matching channels. Note that zero or more channels can be returned by this query. For example, finding more than one document with the matching selection criteria could result in more than one channel in the final query. If this happens, the document is submitted to all channels in the query results.


Drop Inbound Purchase Orders for Approval

To exercise the solution that we have now built for self-routing documents, we simply drop one or more of the instance documents provided in the demonstration.

  1. Using Windows Explorer (or other tool of your choice), navigate to c:\data\source and copy the file named NWBPO2.csv and paste it into c:\data\POApproval\PODrop.

  2. After you do this, you should see the VBScript message box that says "PO Approval Submitted for Approval".

  3. If you do not see the message box, then the receive function was unable to use the envelope to parse and route the document to the appropriate channel. Examine the Suspended queue and the Application Event Log for more information.


Use BizTalk Document Tracking to View Processing History

To determine how the documents are actually processed, we can use BizTalk Document Tracking as follows:

  1. On the Start menu, point to Programs, point to Microsoft BizTalk Server 2002, and click BizTalk document tracking on localhost.

  2. In the tracking interface, under Source Selection, select one or both of the organizations that are used in the routing scenario (NWBuyers or CBuyers).

  3. Under Destination Selection, click Home Organization.

    Note that the only document definition that appears in the list is DecisionFactors because that is the only document that is currently configured as an inbound document on any channels that have the source and destination specified.

  4. Under Document Type Selection, click Show Documents.

  5. Click Query.

    Notice that in the Source Selection box, you see only the NWBuyer source. This is because the other sources have not yet sent any documents. Later, , you will see the other source, Cbuyer, appear in the Source Selection box.

  6. In the resulting list, note the key information (source, destination, and document definition name) that defines how the documents were processed. Also notice the time stamp and other information about the documents. Both inbound (native .csv) and outbound (.xml) documents are listed. In addition, you can click the icon in the data column to see the document contents.


Check That Each Document Is Processed Through the Proper Channel

Note that documents with a "2" in the name have two documents contained in the file. Notice that two documents are placed on the Approval queue when these documents are submitted because BizTalk Server breaks up the inbound file based on the flat-file envelope that is used.

  1. Submit each of the files: CBPO1.csv, NWBPO1.csv, and NWBPO2.csv, by dropping each into c:\Data\POApproval\PODrop.

  2. Use BizTalk Document Tracking to review how each document was processed, as described in the preceding topic.


Send to Remote Queue

This sample contains a COM object in the library SendToRemoteQueue.dll that can be used to send XLANG messages to a message queue on a remote server.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Send To Remote Queue

User's Guide

Before running the sample, register the library SendToRemoteQueue.dll on your system by using the RegSvr32 registration utility. This library must be registered on a computer that is running Microsoft BizTalk Server.

This sample provides a simple schedule (RemoteQueue.skv) that reads a common purchase order file (CommonPOSample.xml) from a local message queue, and then sends that purchase order to a remote message queue. To run this schedule, follow these steps:

  1. Create a private queue named .\private$\inbound on the local computer.

  2. Open the file RemoteQueue.skv in BizTalk Orchestration Designer.

  3. Click the Data tab at the bottom of the window.

  4. Double-click the Constants message to open the Constants Message Properties dialog box. Replace the values "RemoteServerName" and "RemoteServerQueue" with the real names of your remote server and queue.

  5. Verify that the QueueType and IsTxn constant values are correct for the remote queue. If not, update them accordingly.

  6. Compile the drawing into an XLANG schedule file (.skx).

  7. Run the XLANG schedule.

  8. Send a message to the .\private$\inbound queue that contains the purchase order data in the file CommonPOSample.xml. Note that the sample does not provide this functionality.

For additional information on compiling and running XLANG schedules, see the following topics:

  • Run XLANG Schedules

  • Compile an XLANG schedule drawing into an XLANG schedule

Programming Notes

To use the sample, add one or more bindings to this COM object in your existing XLANG schedule files. After the object is bound to a schedule, you also need to modify the data mapping in the schedule to specify the remote server and queue name destination for the message. The SendToRemoteQueue object contains the following input parameters for sending messages to a remote queue:

strMessage

String containing the message body.

strMSMQServerName

String containing the name of the remote server computer.

strMSMQQueueName

String containing the name of the remote message queue.

strMSMQQueueType

String containing the type of the remote queue. This value can be set to "PUBLIC" or "PRIVATE".

strMSMQMsgLabel

String containing the label of the message.

bollsQueueTransactional

Boolean that indicates whether the remote queue is transactional.

Note

  • The information in the message label cannot be passed to a remote queue.


Submitting Documents

This sample demonstrates how to set up a BizTalk Messaging Management database and call the Submit method of the Interchange object, which submits a business document to BizTalk Server 2002 from VBScript. The sample also demonstrates the creation and use of an open destination messaging port, organization aliases, custom envelopes, and the IBizTalkTrackData object.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Sample1

User's Guide

Before running the sample, complete the following steps:

  1. Start a Command Line window.

  2. Change the directory to:

    <Microsoft BizTalk Installation Path>\SDK\Messaging Samples\Sample1

To run the sample:

  • Run cscript Sample1.vbs.

Programming Notes

During execution Sample1 outputs messages indicating its progress. It performs the following steps:

  • First it reports the results of using BizTalk Messaging to configure one organization, two documents, one envelope, an open destination port, and a channel.

  • It then reports the results of the Submit method call, waits for 10 seconds, and outputs the content of the tracked business document.

  • Finally, Sample1 creates the file C:\temp\Sample1_<tracking_id_GUID>.txt, which contains a SOAP-enveloped document from the original Sample1.xml data file.

The input file, Sample1.xml, is an XML CommonPO document wrapped in a BizTalk Framework (BTF) 1.0 envelope.

The output file, C:\temp\Sample1_<tracking_id_GUID>.txt, is an XMLCommonPO document identical to Sample1.xml wrapped in a BTF 2.0 envelope, also known as a SOAP envelope.


Submitting Documents with Receipts

This sample shows how to set up a BizTalk Messaging Management database and explains one way of generating a receipt. This is accomplished by mapping a received purchase order (PO) to a PO acknowledgment without using a receipt channel.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Sample2

User's Guide

Before running the sample, complete the following steps:

  1. Start a Command Line window.

  2. Change the directory to

    <Microsoft BizTalk Installation Path>\SDK\Messaging Samples\Sample2

To run the sample:

  • Run cscript Sample2.vbs.

Programming Notes

There are three parties involved in this sample: the source application, the source organization, and the destination organization. The PO originates from the source application, is passed to the source organization, and then is passed from the source organization to the destination organization. The destination organization then sends the PO acknowledgment back to the source organization.

The sample uses local file transport. Two local File receive functions are configured for this sample.Both receive functions call the Submit method of the IInterchange object.

The setup section of the script creates three folders on the C drive. They are C:\temp\SRC, C:\temp\DST, and C:\temp\ACK. This script places the original PO in C:\temp\SRC, and the SRC receive function is configured to pick up files there. The SRC receive function moves the original PO to C:\temp\DST, and the DST receive function places the PO acknowledgment in the C:\temp\ACK folder.

This sample calls SubmitSync for the first submission and overwrites the component configurations on the channel.

The channels created can be described as follows:

SRC/APP->SRC/APP (C:\temp\SRC, used the script to drop a file)

OpenSrc->DST (C:\temp\DST, used receive function to drop a file)

DST->SRC (C:\temp\ACK, used receive function to drop a file)

During execution, Sample2 outputs messages indicating its progress. It performs the following steps:

  • First it copies CommonPOACKMAP.xml into the BizTalkServerRepository\Maps\Microsoft folder.

  • It then verifies the existence of the C:\temp, C:\temp\SRC, C:\temp\DST, and C:\temp\ACK folders, and creates two File receive functions: "SRC File Receive Function" and "DST File Receive Function."

  • The script then tries to remove all pre-existing Sample2-related configuration objects if Sample2 was previously executed. It configures the following Sample2 objects: two organizations, two documents, one envelope, one port, and three channels.

  • It then calls SubmitSync, verifies the response from SubmitSync, waits for one minute, and verifies that no Suspended queue items are present and that the C:\temp\ACK\Sample2ACK.xml file exists. This file should contain CommonPOAcknowledgment wrapped in SOAP envelope.

The input file, Sample2.xml, is an XML CommonPO document wrapped in a BizTalk Framework (BTF) 2.0 (SOAP) envelope.

The output file, C:\temp\ACK\Sample2ACK.xml, is a CommonPOAcknowledgment file mapped from CommonPO and wrapped in a SOAP envelope.


Submitting Documents to a Port Group

This sample sets up a BizTalk Messaging Management database and calls the Submit method of the IInterchange object, which submits the business document to BizTalk Server 2002 synchronously.

A distribution list in BizTalk Server is a way to send an identical business document, containing identical data, to a number of partners. The business document originates from the source application and is passed to the distribution list, which causes the same purchase order (PO) to be sent to the source application and to the destination organization. To verify that the documents have been processed correctly, look for Sample3_DST.txt and Sample3_SRCAPP.txt files in the C:\temp folder.

The sample Distribution List contains related information.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Sample3

User's Guide

To run the sample, follow these steps:

  1. Start a Command Line window.

  2. Change the directory to:

    <Microsoft BizTalk Installation Path>\SDK\Messaging Samples\Sample3

  3. Run cscript Sample3.vbs.

Programming Notes

During execution, Sample3 outputs messages indicating its progress. It performs the following steps:

  • First it copies Sample3.asp into the default Web site of Internet Information Services (IIS).

  • It then tries to remove all Sample3-related Configuration objects if they exist.

  • It configures the following objects: two organizations, one document, one envelope, two ports, one port group, and one channel pointing to the port group (distribution list).

  • It calls Submit, waits for 15 seconds, and verifies that the resulting C:\temp\Sample3_SRCAPP.txt and C:\temp\Sample3_DST.txt files exist.

The C:\temp\Sample3_DST.txt file is created as a result of posting the data to the Sample3.asp page. The C:\temp\Sample3_SRCAPP.txt file is created by a file transport configured in the source application port. The first line of C:\temp\Sample3_DST.txt indicates when the data was received by the destination organization. Both files contain SOAP-enveloped data from the original Sample3.xml.

The input file Sample3.xml is an XML CommonPO document wrapped in a BizTalk Framework (BTF) 2.0 (SOAP) envelope.

The output files are as follows:

  • C:\temp\Sample3_SRCAPP.txt is an XMLCommonPO document identical to the one from Sample3.xml wrapped in a BTF 2.0 envelope, also known as a SOAP envelope.

  • C:\temp\Sample3_DST.txt is an XMLCommonPO document identical to the one from Sample3.xml wrapped in a BTF 2.0 envelope, also known as SOAP envelope, with a first line containing "- Received at date/time -".


Suspended Queue Monitoring

This sample demonstrates how to raise an alert in Microsoft Operations Monitor (MOM) when a document is sent to the BizTalk Server Suspended queue.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Suspended Queue Monitoring

User's Guide

Complete the following steps to configure this sample:

  1. On your C drive, create a folder named ReceivePO.

  2. Run the configuration script, SuspendedQueueConfig.vbs, to configure BizTalk Messaging Services.

  3. Enable the event processing rule named "Suspended Queue Sample" in the BizTalk Server 2002 Management Pack that is installed in Microsoft Operations Monitor.

  4. Verify that the computer running BizTalk Server is a managed computer agent in Microsoft Operations Monitor.

Note

  • The BizTalk Messaging Services configuration script, SuspendedQueueConfig.vbs, should be run only once. If you want to run the script again, you must first delete any configuration objects previously created by the script in the following order:
    1. Channel: TestChannel

    2. Port: TestPort

    3. Organization: Dest Org

    4. Organization: Source Org

    5. Document Definition: PO

    6. File Receive Function: ReceivePurchaseOrders

To run the sample, complete the following steps:

  1. Ensure that the InvalidPO.xml file is not read-only. To modify this property, right-click the file, click Properties, clear the read-only attribute, and then click OK.

  2. Copy the file InvalidPO.xml into the file receive directory C:\ReceivePO. This will generate a Suspended queue event, which is displayed in the alerts for that agent computer in the Microsoft Operations Monitor console.

Important

  • For the Suspended queue event to be consumed by MOM, the MOM DAS account must be a member of the BizTalk Server Administration group.


Synchronous Orchestration Component

This sample demonstrates a synchronous method for invoking and interacting with an XLANG schedule.

A synchronous call into BizTalk Server expects a response document in return for a request document submitted through the SubmitSync method. For example, in a Web scenario where data flows through HTTP.Request into a Web page (for example, request-submit.asp) and is submitted to BizTalk Server through SubmitSync, the response from BizTalk Server is sent back to the HTTP client by mapping the response document to the HTTP.Response. If the application that produces the response document behind BizTalk Server is accessed through an XLANG schedule, BizTalk Server must implement a synchronous, or blocking, method of invoking and interacting with the XLANG schedule.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SOC

User's Guide

Before running the sample, complete the following steps:

  1. Open the SOC.dsw Visual C++ workspace. Compile the SOC and REQRES Visual C++ projects. The AIC will be registered with a ProgID of "BizTalk.SyncOrchestration".

  2. Open the XLANG schedule drawing RequestResponse.skv in the Schedule subfolder. Use the Make XLANG RequestResponse.skx command on the File menu to create an XLANG schedule.

  3. Copy the ASP files located in the ASP subfolder to the folder:

    \Program Files\Microsoft BizTalk Server\MessagingManager\pipeline

  4. Create a messaging port that uses an AIC transport type, and is referencing the new BizTalk.SyncOrchestration component.

  5. Create a channel for the messaging port, with any document specification, and a document instance generated from BizTalk Editor. On the Advanced Configuration page, click Advanced. On the Primary Transport tab, click Properties.

  6. On the BizTalk SyncOrchestration Properties page, enter the path and file name of the XLANG schedule in the Skedpath text box. Enter the XLANG port name SyncPort in the Skedport text box.

To run the sample:

Create the IInterchange object and call the SubmitSync method with the channel name and a sample document that uses the Inbound Document Definition specified on the channel. The response will appear as the out parameter of the SubmitSync method call.

Programming Notes

Synchronous COM calls into XLANG schedules are made by invoking a synchronous orchestration component, which is an application integration component (AIC) that implements the IPipelineComponent interface. A synchronous orchestration component uses a property page (.asp) configured with the path of the associated XLANG schedule, which will be used to process messages of a particular schema on the port. When a message arrives at the port through a channel, BizTalk Server invokes a predefined and configured synchronous orchestration component, passing the dictionary object to it. The custom synchronous orchestration component inspects the dictionary object and retrieves the schedule path. It then uses the path to invoke the XLANG schedule, passing along the document in the working_data field of the dictionary object.

The first action in the XLANG schedule is bound to the IRequestResponse::SetRequest(requestDoc) method. The synchronous orchestration component invokes this method and passes the request document to the XLANG schedule for processing. To receive the resulting response document from the XLANG schedule processing, the synchronous orchestration component makes two subsequent calls to the XLANG schedule instance. The first method invoked is IRequestResponse::CompleteProcessing, which sets the response document. Immediately thereafter, the synchronous orchestration component invokes the IRequestResponse::GetResponse method to retrieve the response document. The synchronous orchestration component is blocked until the XLANG schedule processing flows to the action that is bound to the SetResponse port. This call will time out after 120 seconds if no response is available. You can change this default time-out setting of 120 seconds by changing the constant MAX_TIMEOUT_SECS in RequestResponseExample.h.

Note

  • Because the client is blocked while awaiting a response, any issues with time-out limits must be addressed when implementing a synchronous process flow.

The response document is then returned by the synchronous orchestration component to BizTalk Server as a field in the dictionary. BizTalk Server then returns the response document to the Web page that called SubmitSync. The Web page in turn maps the response document to HTTP.Response. To provide COM activation and message delivery from BizTalk Messaging Services to an XLANG schedule, the XLANG schedule must have its first action bound to the IRequestResponse::SetRequest method and its last two actions bound to the actions that will allow the passing of a response document.

Notes

  • If outbound processing by BizTalk Server is required for the response document, the synchronous orchestration component can call into BizTalk Server by using SubmitSync before returning the results to the ASP page through BizTalk Messaging Services.

  • The synchronous orchestration component can be used as an orchestration activation and as a DCOM data delivery mechanism by modifying the synchronous orchestration component to call only SetRequest.


Tracking Database Tasks

This sample contains an SQL script for creating a sample SQL Server Agent job: dtaJob_receipt_monitor_<TrackingDatabaseName>

This job monitors expiring records in the dta_outdoc_details table that are expecting receipts to come back and whose waiting periods have a time-out. By default, this job runs every 30 minutes. It calls the dta_job_mark_expired_outdocs stored procedure.

For a related sample, see the file dta.vbs in the folder \Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Miscellaneous.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\SQLServerAgentJobs

User's Guide

Before running the sample, complete the following steps:

  1. In a text editor, open the DTA_SampleJobs.sql sample file.

  2. Find all instances of the string "%InterchangeDTA%" and replace them with the name of your BizTalk Server Tracking database.

  3. Save the file. You might need to remove the read-only attribute on the file before you can save it.

  4. Start the SQL Server Agent service if it has not already been started.

  5. Start SQL Query Analyzer. On the Start menu, click Programs, click Microsoft SQL Server, and then click Query Analyzer.

  6. In SQL Query Analyzer, connect to the SQL database server to which your BizTalk Server Tracking database belongs.

  7. Change the current database to your BizTalk Server Tracking database.

To run the sample:

  • Open the modified DTA_SampleJobs.sql file and execute a query (press F5).

Programming Notes

If you encounter errors, make sure that the database user account with which you are connecting to the database server has sufficient permissions to create stored procedures and SQL Server Agent jobs. Also make sure that the string find-and-replace in step 2 was done correctly.


Windows Management Instrumentation

This sample illustrates the use of Visual Basic scripts to configure administrative entities such as organizations, document definitions, ports, channels, and receive functions.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\WMI

User's Guide

The sample sets up a file-to-file scenario between two organizations. Each organization is simulated by a directory on the file system. BizTalk Server receives a document from the source organization, and then transforms it and submits it to the destination organization.

To prepare and run the sample, follow these steps:

  1. Run setup.cmd in the sample directory to configure the scenario and run the scripts.

  2. Run the sample scenario by navigating to C:\BizTalkWMI\ and copying the file SourceInstance.xml into C:\BizTalkWMI\SourceOrg.

    This file should be consumed by BizTalk Server, transformed, and submitted to C:\BizTalkWMI\DestinationOrg as the file OutDoc%tracking_id%.xml, where %tracking_id% is a unique ID value.

  3. Run Cleanup.vbs to clear the configuration changes that were made by the sample scripts and to delete c:\BizTalkWMI.

  4. To clear the files stored to WebDAV, navigate to Program Files\Microsoft BizTalk Server\BizTalkServerRepository on the file system and delete DocSpecs\WMISourcePOSchema.xml, DocSpecs\WMIDestPOSchema.xml, and Maps\WMIPOMap.xml.

The two setup scripts that are run in this sample are:

  • ConfigureBTC.vbs. This script creates the organizations for the source and destination, the documents for the source and destination specifications, and the port and channel that are needed for the scenario.

  • ReceiveFunction.vbs. This script configures the File receive function for the scenario.

For more information on these scripts, see the following topics:

  • Creating ConfigureBTC.vbs

  • Creating ReceiveFunction.vbs

These scripts have already been created, but the following programming notes are included to provide a better understanding of how the scripts work.

Programming Notes

The setup.cmd program creates the following folders on your computer:

  • c:\BizTalkWMI. The common folder where all the scenario-related files are copied

  • c:\BizTalkWMI\SourceOrg. The location where BizTalk Server receives documents that are to be sent to the destination organization

  • c:\BizTalkWMI\DestinationOrg. The location where BizTalk Server drops documents that were received from the source organization after processing them

The following files are used in the scenario. You might want to examine them to gain a better understanding. These files are copied to C:\BizTalkWMI and installed in WebDAV:

  • SourcePOSchema.xml. The specification for the source purchase order

  • DestPOSchema.xml. The specification for the destination purchase order

  • POMap.xml. The map that is used for transforming the source specification to the destination specification

The following sections walk through the process of creating ConfigureBTC.vbs and ReceiveFunction.vbs. Double-click the scripts to run them. To avoid name conflict errors, run Cleanup.vbs before attempting to rerun the two configuration scripts. The names of all objects that are created by the scripts in this sample start with "WMI".


Creating ConfigureBTC.vbs

This section walks through the steps that are necessary to set up the two organizations, two document definitions, one port, and one channel that are used in the scenario. After running the script, use BizTalk Messaging Manager to verify that these objects have indeed been added.

  1. Create the Configuration object.

    Calling CreateObject with the ProgID "BizTalk.BizTalkConfig" is the first step in any script that uses the SDK. All other BizTalk Messaging Configuration objects are accessed through this main Configuration object.

  2. Create the source organization.

    Create an Organization object and set its name attribute to the name desired for the source organization. Store the organization handle for use later while configuring the channel.

  3. Create the destination organization.

    Create an Organization object and set its name attribute to the name desired for the destination organization. Store the organization handle for use later while configuring the port.

  4. Add specifications and maps to WebDAV.

    Helper subroutines and functions are used to extract server information and to store the document specifications and map to WebDAV. A WebDAV URL is in the form http://SERVER_NAME/BizTalkServerRepository/. Note that document specifications must be stored in the DocSpecs folder and maps must be stored in the Maps folder under the WebDAV URL.

  5. Create the input document definition.

    Create a Document object that represents the input document specification. Set its name and set its reference to the WebDAV path of the source document specification. Store the document definition handle for use in configuring the channel.

  6. Create the output document definition.

    Create a Document object that represents the output document specification. Set its name and set its reference to the WebDAV path of the output document specification. Store the document definition handle for use in configuring the channel.

  7. Create the port.

    The port represents the destination of this configuration. Set its name, a handle to its destination organization, a constant to indicate its primary transport type (file), and a string to indicate its primary transport address (file://C:\BizTalkWMI\DestinationOrg\OutDoc%tracking_id%.xml). Store the port handle for use in configuring the channel.

  8. Create the channel.

    The channel contains the information that is involved in transforming the document from the source format to the destination format. Set its name, a handle to its source organization, a handle to its associated port, handles to its input and output document definitions, and a reference to the WebDAV path of the map that specifies the transformation.


Creating ReceiveFunction.vbs

This section walks through the steps that are necessary to set up the File receive function that monitors C:\BizTalkWMI\SourceOrg for XML files. After the XML files are picked up, they are processed and sent to the destination organization.

Note that it is important to run this script after the configuration script, because the receive function assumes the existence of an associated channel that is created in ConfigBTC.vbs. After running the script, check to see that the receive function has been created by opening up the BizTalk Server Administrator tool and navigating to the list of receive functions.

  1. Create the locator object.

    Calling CreateObject with the ProgID "WbemScripting.SWbemLocator" is the first step in any WMI-related script. This is the standard way to get an entry point into the WMI objects.

  2. Create the services object.

    To connect to and access a set of related services on a computer, the namespace that identifies that set of services must be given. The target computer defaults to the local computer, and the namespace for the BizTalk Server services is "root/MicrosoftBizTalkServer".

  3. Get the ReceiveFunction class object.

    Use either Get or ExecQuery to retrieve the receive function class. The name of the class is "MicrosoftBizTalkServer_ReceiveFunction".

  4. Spawn an instance of the receive function.

    Use the SpawnInstance_ method on the receive function class to set its attributes.

  5. Set the name of the receive function instance.

  6. Specify the protocol type for this receive function (as File).

    Because the receive function class represents all receive functions, its ProtocolType must be set to 1 (for ADMIN_PROTOCOL_TYPE_FILE) to indicate that it is a File receive function.

  7. Specify the processing server on which this receive function will run.

    In this case, helper functions are used to determine the local computer name.

  8. Specify the name of the group that is associated with this receive function.

    "BizTalk Server Group" is the default name that is set by the script.

  9. Specify the file name mask for this receive function.

    Setting *.xml indicates that all XML files should be picked up from the specified location.

  10. Specify the location to poll for this File receive function.

    This is the location on the file system where the receive function will monitor and pick up source document instances. In this scenario, the PollingLocation is "C:\BizTalkWMI\SourceOrg".

  11. Specify the name of the channel to use.

    This is the channel that was created earlier by ConfigureBTC.vbs.

  12. Set the flag to create the receive function as configured.

    Calling Put_ with the flag set to 2 (wbemChangeFlagCreateOnly) means that we are creating the receive function as configured. The value 2 is the only supported value in the SDK.


BizTalk Orchestration Services Code Samples

Sample files are located in the XLANG Samples folder on the Microsoft BizTalk Server installation drive. Browse to \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples on the installation drive to find the sample files. This is only a relative path. Depending on your installation of BizTalk Server 2002, you might need to modify this path.

  • BizTalk Framework Correlation

  • BizTalk Services Integration

  • Dispatcher Application

  • Dynamic Binding with COM

  • Dynamic Binding with Message Queuing

  • Exception Handling

  • Iteration

  • Nested Transactions

  • Orchestration Services Audit

  • Orchestration Services Audit Client

  • Personalized Queues

  • Queue Listener

  • While Shape

  • XLANG and ASP

  • XLANG Interfaces

  • XLANG Schedule Pooling

  • XLANG Submit Synchronously and Query Asynchronously

  • XLANG Trace

  • XML Translation


BizTalk Framework Correlation

This sample illustrates the use of BizTalk Framework (BTF) 2.0 and orchestration to accomplish stateful interoperability between two applications. It allows two (or more) applications to engage in a potentially long-lived exchange of messages. Each exchange is capable of referring back to the data passed in previous exchanges.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Integrating BizTalk Services

User's Guide

The sample contains the following directories:

  • App contains the BTS SimpleApproval schedule file.

  • BTM2BPO contains a combination application integration component (AIC) and utility component. The AIC part of the component allows a BTF-enveloped message, which includes the <prc> tag, to be sent to the correct existing instance of an orchestration through a message queue or a COM interface (ReceiveMsg). The port name and other options are set through the BizTalk Messaging Manager (Advanced-Properties). In addition to this AIC, this project also contains code needed to envelope an existing message and include the <prc> tag and 'reflect' an enveloped message.

  • ThirdPartyApp contains an application that simulates a third-party application.

  • FileSubmit is the polling location for the ReceiveNewApp receive function.

  • Schema is the directory containing the schema.

  • CorrUtil contains a utility component.

  • SetupFiles contains the scripts to install and uninstall the sample.

To run the sample, follow these steps:

  1. Run setup.cmd to install the sample.

  2. Run SubmitDoc.cmd to drop the NewAppInst.xml file into the FileSubmit directory.

  3. Run ThirdPartyApp\ThirdPartyApp.exe. The Get Message button will retrieve the next message from the RequestApproval queue. It should appear in the edit window. Press the Reflect button to prepare the message for sending back to the schedule. Press Approve to send it to the Approvals queue or Decline to send it to the Denials queue. Message Queuing receive functions will pass these messages back to BizTalk Server and through BTM2BPO back to the schedule.

    The BTS SimpleApproval schedule illustrates two ways in which the response document is delivered to the running schedule instance. The ReceiveApprovalPort port is a Message Queuing port and receives the document through a per-instance queue. The ReceiveDenialPort port is a COM port and receives the document as a parameter to the ReceiveMsg method of the IReceive interface.

  4. View the Application Log by using EventViewer for the name of the port to which the response document was delivered.

  5. Run remove.cmd to uninstall the sample.

Programming Notes

The sample uses:

  • Orchestration to maintain the state of the exchange and determine the sequence of exchanges.

  • BizTalk Framework 2.0 envelopes to pass a state identifier between the applications.

  • BizTalk Server 2002 messaging facilities to abstract individual applications from each other.

BTS SimpleApproval.skv provides a summary view of a sample orchestration using all of the above.


BizTalk Services Integration

Two samples are provided to demonstrate the integration of BizTalk Messaging Services and BizTalk Orchestration Services.

Paths

To locate the sample files for the sample using HTTP as a transport mechanism, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Integrating BizTalk Services\http

To locate the sample files for the sample using Message Queuing and File receive functions, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\Messaging Samples\Integrating BizTalk Services\non-http

User's Guide

Detailed information regarding the HTTP-based sample is provided in the Setting Up HTTP Sample.doc file located in the http folder.

Detailed information regarding the Message Queuing sample is provided in the Setting Up Non-HTTP sample.doc file located in the non-http folder.


Dispatcher Application

This sample demonstrates a dispatcher application that sends and receives documents on behalf of a client application. When a document is sent, the dispatcher saves the "From address" in a database before sending the document and uses the saved address to route the response document to the correct sender.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Dispatcher

User's Guide

This sample consists of the following directories:

  • Apps contains the schedules, a data file, and VBScript files to run the sample.

  • ClientUtil contains a helper component for the ClientApp schedule.

  • DbUtil contains a helper component for simulating a database.

  • DestUtil contains a helper component for the DestApp schedule.

  • DispatchUtil contains a helper component for the DispatchApp schedule.

  • SendUtil contains a helper component for the SendApp schedule.

The setup script, "setup.cmd", does the following:

  • Registers the following components: ClientAppUtil, SendAppUtil, DestAppUtil, DispatchAppUtil, and DbComp.

  • Creates the Message Queuing queues SendDocs, RecvDocs, and UnknownDocs.

To remove the sample, run "remove.cmd".

To run the sample, first run "startDispatchApp.vbs" in the "Apps" directory. This starts the "DispatchApp" schedule and should be run only once. Then run "startClientApp.vbs" in the "Apps" directory. This starts the "ClientApp" and "DestApp" schedules.

The "ClientApp" schedule sends a document to the "SendApp" schedule along with the To Queue and From Queue paths and then waits on a per-instance queue for the response.

The "SendApp" schedule generates a unique token and saves the FromQueue (the per-instance queue of ClientApp) path and the token in a database. The token is added to the document, which is then sent to the To Queue (SendDocs).

The "DestApp" monitors the "SendDocs" queue, reads the document from the queue, extracts the token, creates a response document, adds the token to the response document, and sends the response document to the response queue "RecvDocs".

The "DispatchApp" schedule monitors the "RecvDocs" queue for any document. When the response document is available in the queue, it extracts the token from the document, gets the corresponding delivery queue path from the database, and sends the response document to the delivery queue. If the delivery queue cannot be determined, the document is sent to the "UnknownDocs" queue. After dispatching the document to the correct queue, the "DispatchApp" schedule starts another instance of itself to continue monitoring the "RecvDocs" queue.

The "ClientApp" that is waiting on the per-instance queue receives the response document and processes it.

The "startClientApp.vbs" script can be run any number of times. To terminate the "DispatchApp" schedule, shut down and restart the "XLANG Scheduler" COM+ application by using the Component Services MMC snap-in.

Programming Notes

The "ClientApp" schedule gets the document as an input parameter. The Get Constants action is used to get constant values into the schedule. The Display Input Doc action displays the input document. The Send Doc action uses a helper component to start the "SendApp" schedule and pass it the document, the path of the queue to send the document to, and the path of the per-instance queue where the response should be sent. The Get Response Doc action is used to wait on the per-instance response queue for the response document. The Display Response Doc action displays the received response document.

The "SendApp" schedule receives the document and the From Queue and To Queue paths from the Get Input action. The Save Return Address action generates a GUID token and saves the token and the From Queue address in a database. The token is then added to the document to be sent. The SendDoc action sends the document to the To Queue (SendDocs).

The "DestApp" schedule waits on the "SendDocs" queue for the document. The ReceiveDoc action gets the document from the queue. The CreateResponse action extracts the token from the document, creates a response document, and adds the token to the response document. The SendResponse action sends the response document to the "RecvDocs" queue.

The "DispatchApp" schedule waits on the "RecvDocs" queue for the document. The Get Doc From Queue action gets the document from the queue. The Get Delivery Queue action extracts the token from the document and retrieves the corresponding delivery queue path from the database. The SendDoc action sends the document to the delivery queue.

The "ClientAppUtil" helper component is used by the "ClientApp" schedule to get input parameters, get constants into the schedule, display a message box, start the "SendApp" schedule, and pass parameters to it.

The "SendAppUtil" helper component is used by the "SendApp" schedule to get input parameters and to save the delivery queue path in the database.

The "DestAppUtil" helper component is used by the "DestApp" schedule to extract the token from the input document, create the response document, and add the token to the response document.

The "DispatchAppUtil" helper component is used by the "DispatchApp" schedule to get input parameters, get the delivery queue path from the database, and restart the "DispatchApp" schedule.

The "DbComp" helper component is used by the "SendAppUtil" and "DispatchAppUtil" components to save and retrieve the delivery queue address from a file-based database. The database is simulated by using an XML file, "TrackDb.xml," that is created in the DbUtil directory.

Note

  • To simplify this sample, a file-based database is used. Therefore a transaction shape cannot be used with the database-related actions. Ideally one would use transaction shapes in conjunction with a transactional database to ensure proper recovery in case of failures. The QueueListener sample demonstrates how to use transactions to ensure that a schedule is restarted in the event of an abnormal termination.


Dynamic Binding with COM

This sample demonstrates how to bind dynamically to a COM component. The COM component that the schedule binds to is decided at run time.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Dynamic Binding\COM

User's Guide

The sample consists of the following directories:

  • ScrambleApp contains the scramble sample schedule and the VBScript file to run the sample.

  • ScrambleUtil contains a helper component used to create the COM component to bind to and display messages.

  • ScrambleInterface contains the type library for the IScramble interface.

  • HighSecurityScramble contains a COM component that implements the IScramble interface.

  • LowSecurityScramble contains a second COM component that implements the IScramble interface.

The setup script, "setup.cmd", does the following:

  • Registers the "Scramble" typelib.

  • Registers the following components: HighScramble, LowScramble, and ScrambleHelper.

To remove the sample, run "remove.cmd".

To run the sample, run "startit.vbs" in the "ScrambleApp" directory. The input data to be scrambled is passed to the schedule. When the message High Security Scramble for "Hello World!"? is displayed, click "Yes" to scramble the data by using the "HighScramble" component or click "No" to scramble the data by using the "LowScramble" component. The output is displayed in a message box.

Programming Notes

In this schedule, the "GetInput" action gets the data to be scrambled.

The "GetScrambler" action creates the scrambler component to use based on user selection.

The "ScrambleData" action scrambles the data by using the component created by the previous action. This action can bind to any component that implements the "IScramble" interface.

The "DisplayScrambledData" action displays the output of the "ScrambleData" action.

A helper component, "ScrambleHelper," is used to create the scrambler component and to display messages.


Dynamic Binding with Message Queuing

This sample demonstrates how to bind dynamically to a message queue. The queue path is specified at run time.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Dynamic Binding\Queue

User's Guide

The sample consists of the following directories:

  • QueueBindApp contains the queuebind sample schedule, data file, and VBScript files to run the sample.

  • QueueBindUtil contains a helper component used to process the data file and display messages.

The setup script, "setup.cmd", does the following:

  • Registers the "QueueBindUtil" component.

  • Creates Message Queuing queues named purchase_dept and marketing_dept.

To remove the sample, run "remove.cmd".

To run the sample, run "startit.vbs" in the "QueueBindApp" directory. The "MarketingDeptOrder.xml" data file is sent to the "purchase_dept" queue and the schedule is executed. The schedule reads the data file from the queue and sends an acknowledgment to the "marketing_dept" queue. A message box displays the acknowledgement generated and the reply queue.

Programming Notes

In this schedule, the incoming document received by the "GetOrder" action contains the reply queue location where the acknowledgement needs to be sent.

The "ProcessOrder" action builds the acknowledgement document and extracts the path of the reply queue from the incoming document.

The "DisplayAck" action displays the acknowledgement document and the reply queue location.

The "SendAck" action sends the acknowledgement document to the reply queue that was specified in the incoming document.

A helper component, "QueueBindUtil," is used to process the data file and to display messages.


Exception Handling

This sample demonstrates how to handle an exception.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Transaction Abort

User's Guide

The sample consists of the following modules:

  • A Visual Basic ActiveX DLL contains the component called by the schedule.

  • Abort.vbs contains the code to run the schedule.

The setup script, setup.cmd, registers the abortsample component.

To remove the sample, run remove.cmd.

To run the sample, run Abort.vbs. When you click OK in the dialog box, it sends the string to the schedule. If you have typed Abort, the transaction will be aborted, and you will be shown the appropriate messages.

Programming Notes

This sample demonstrates the use of an abort handler and auto return. When a method call returns a negative HRESULT, then the outer transaction is aborted and the abort handler code for the transaction starts executing. After the abort handler code completes, the command goes to the next action.

If the transaction is aborted then the document is put back on the Received_Doc_In queue (because Message Queuing is used in the transaction) and the abort handler drops a copy of the document into the aborted_doc_out_ queue.


Iteration

This sample demonstrates how to iterate through a list of items and process each item independently based on a condition.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Iteration

User's Guide

Before running the sample, run the setup script setup.cmd.

To run the sample, follow these steps:

  1. Browse to the LineItemsApp folder.

  2. Run the script file startit.vbs.

  3. When prompted, click OK on the message box to continue.

Programming Notes

When run, the "ItemList.xml" file is sent to the "items_in" queue. This file contains a list of items to be processed. The schedule picks up the file from the queue and processes the items in it. Each item is placed in a different "out" queue based on the item type. Any item of unknown type is placed in the "unknown_out" queue. A message box is displayed as each item is processed.

This sample uses a simple counted loop to iterate through the list of items. The GetItemCount action is used to get the maximum iteration count and the While shape is used to control the loop. The Decision shape uses different rules to determine the branch to execute. The Join shape uses an OR join type because only one of the branches will be executed at any given time.

A helper component, "LineItemHelper", is used to increment the loop count, process the data file, and display messages.

To remove this sample, run the script remove.cmd.


Nested Transactions

This sample illustrates nested transactions, aborting a transaction, and compensation.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\NestedTxns

User's Guide

To install this sample, register all the script components in the sample directory.

To run the sample, run the "NestedTxns.wsf" script file.

Programming Notes

The scenario for this sample is ordering an item, submitting payment, receiving the item, returning the item, and having the payment reversed. This scenario is based on a familiar shopping experience, where a merchant accepts returned merchandise and processes a credit-card credit. The credit slip looks like a credit-card debit slip except that it is usually printed in red ink.

The sample encapsulates the entire purchasing cycle in an outer transaction called "Purchase". Inside that transaction is a nested transaction called "Payment". The compensation block for "Payment" includes a transaction named "ReverseCharges". This sample has a total of three transaction envelopes.

The "Purchase" transaction includes an "Order" action; a "Payment" transaction; a "ReceiveItem" action; a decision about whether to keep the item; a branch to return the item, abort, and compensate the payment; and another branch to keep the item. The "Abort" action causes the entire "Purchase" transaction to abort, which, in turn, causes the nested "Payment" transaction to abort. The "Payment" transaction has a compensation block, itself transactional, that carries out the credit or reversal of charges.


Orchestration Services Audit

This sample demonstrates an orchestration audit component.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAudit

User's Guide

There is one interface, IUserEvent.

ServerName is the name of the server associated with your tracking database:

HRESULT Install( /*[in]*/ BSTR ServerName,

Datasource is the name of your tracking database:

/*[in]*/ BSTR Datasource,

/*[in]*/ BSTR Username,

/*[in]*/ BSTR Password,

/*[in,optional]*/ BSTR ApplicationFilter, /*[in,optional, defaultvalue(egAllEvents)]*/ EventGroupTypes EventFilter

HRESULT Uninstall();

Install installs the subscription into the COM+ catalog, and connects to the database. ApplicationFilter can be the name of a COM+ application or the GUID key for that application. EventGroupTypes can be any combination of the enumeration combined by using OR. The default is for all events.

Uninstall removes the subscription from the COM+ catalog and disconnects from the database.

A client should explicitly call Uninstall before releasing the component. Otherwise the subscription will be orphaned until the server is rebooted.

Programming Notes

The database tables and stored procedures are initially built by setup. If you want to restore these, you need to run files in the query analyzer after selecting your tracking database, in the following order:

<InstallationFolder>\Setup\BTS_WorkflowEvents_Schema.sql

<InstallationFolder>\Setup\BTS_WorkflowEvents_Logic.sql

Important

  • This orchestration audit component persists detected events into the InterchangeDTA (default name) database, which is the BizTalk Server Tracking data store. Two tables are used to contain the data for monitored events: dta_wf_WorkFlowEvent and dta_wf_EventData. The first of these contains a row for each event detected and the second contains one or more rows for each property related to a particular event in the first table. Note that the BizTalk Server Tracking user interface might show truncated event data because the columns in the second table (event data) that contain property name and value pairs are set to 100 characters, and actual names and values can exceed this length.


Orchestration Services Audit Client

This sample demonstrates an orchestration audit client.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\WorkFlowAuditClient

User's Guide

To run this application, first register the WorkFlowAudit.dll file by typing regsvr32 WorkFlowAudit.dll at the command prompt. This file is in the <Installation Folder>\SDK\XLANG Samples\WorkflowAudit\bin folder.

After registering this component, run WorkflowAuditClient.exe. When the application is first run, it asks you to enter four parameters. Except for the database user password, the values are taken from the Windows Management Instrumentation (WMI) provider. If you want to change the default settings, type the new values.

When you click Start, the application calls the Install method of the interface in the WorkFlowAudit.dll. The events that are fired by the XLANG Scheduler will be monitored. Do not close the application while tracking the scheduler events. Doing so will terminate the monitoring process.


Personalized Queues

This sample uses a shared queue and per-instance queues. A shared queue called the new-user queue permanently resides at a URL. This queue is associated with the enterprise Web site and with a schedule for creating new users. The client goes to the well-known URL to create a new user account or to log on to an existing user account.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Personalized Queues

User's Guide

This sample uses the items described in the following paragraphs.

Queues

Queues can be inspected from the Management Console (right-click My Computer on the desktop, click Manage, navigate to Services and Applications, Message Queuing, Private Queues).

  • Fixed queue: .\private$\AmysNewUserAccount

  • Account queue: .\private$\AccountQueues{...fresh guid... }

Schedules

Schedules can be inspected with the XLANG Event Monitor that is installed with the BizTalk Server SDK.

  • AmysZoneTop.skv checks that a new user name has been deposited in the top-level queue. In a real application, this would set up user account database tables.

  • AccountSchedule.skv takes command messages in a loop from the per-instance account queue. The loop terminates when the command "Close" comes in.

Windows Batch Command Files

  • Run setup.cmd before running the sample.

  • Run remove.cmd to disable the sample and clean up.

Windows Script Files and Windows Script Components

  • RunMe.wsf runs the sample.

  • VerifyForm.wsc shows that the new user name was received by the new-user queue.

  • RecordQueueName.wsc records the user name and its associated per-instance account queue name in a text-file database.

  • CloseUserAccount.wsc removes the user name from the text-file database.

  • ReportUserCommand.wsc shows that the account schedule has received commands from the SessionWebPage.

  • CreateTopLevelQueue.vbs is run by setup.cmd.

  • DeleteTopLevelQueue.vbs is run by remove.cmd.

HTML pages

  • ClientWebPage.htm allows users to create new accounts or to log on to existing accounts.

  • SessionWebPage.htm feeds user commands to AccountSchedule.skv.

The sample setup script, setup.cmd, creates the unique shared new-user queue.

Note

  • This sample stores the user account database in a text file in the C:\winnt\system32 folder, and assumes that that folder exists. The folder name is hard-coded in only one place in the sample code, so fixing this limitation is easy. Simply edit RunMe.wsf, search for the string "winnt", and change the reference to match the name of your system folder.

To run the sample:

  • Run RunMe.wsf in the ClientApplication folder. Interact with its Web pages and dialogs.

  • Run the Microsoft Management Console (right-click My Computer on the desktop, and then click Manage) to inspect queues and the event log.

  • Run the XLANG Event Monitor to watch the schedules running.

  • Inspect the file C:\winnt\system32\AccountQueuesDB.txt to see the association of user names and per-instance queues.

To remove the sample, run remove.cmd.

Programming Notes

A new user account is represented by a new per-instance queue called the account queue. The account queue is bound to a very-long-lived schedule instance, the account schedule. The account schedule is born (instantiated) at account creation time and lives until account destruction time. Thus, its lifetime is the same as the lifetime of the user account, and this could be measured in years.

We have one new-user queue for the entire enterprise. The enterprise encompasses many user accounts, each with its own account schedule and account queue.

The user logs on to the account by interacting with the account schedule through the account queue. Conceivably, the same technique used to associate many users with one enterprise could be repeated one more level down to associate many sessions with each user. We do not do so in this sample, presuming that two levels of schedules and queues suffice to illustrate the point. However, if session schedules were used, then the account schedule would, in turn, create another per-instance queue called the session queue, which is bound to a session schedule that lives until the user logs off the account.

For now, we assume that each user gets one session, so we combine the functionality of the account with that of the session.

We call this sample Personalized Queues because there is one per-instance queue per user. The most interesting aspect of this application is that the account queue and schedule live as long as the user account. Such a schedule could encapsulate a considerable amount of persistent state information about the user.

The user first approaches the application through a script called RunMe.wsf in the ClientApplication directory. This script launches a Web page called ClientWebPage.htm. To create a new account, the user chooses a user name and a password and enters them into a form on this Web page. When the user clicks Create New User, the script, RunMe.wsf, deposits the new user name in the new-user queue and invokes the schedule in AmysZoneTop.skx.

The job of AmysZoneTop is to create the account queue and instantiate the account schedule, whose XLANG specification is stored in AccountSchedule.skx. Each instance of this schedule lives as long as the user account, and this time could be measured in years.

AccountSchedule creates a new queue for the user. The name of this queue is generated automatically by the system. AccountSchedule invokes a script component, RecordQueueName.wsc, to store the name of the new queue in a system database. For illustration purposes in this sample, the database is stored in a flat text file in the system directory. In a real application, it will be necessary to keep user names and queue names in a SQL Server database.

AccountSchedule then goes into an indefinite loop awaiting commands from the user to arrive on the user's personalized queue.

Note that no real processing of passwords is done in this sample. Password processing is a delicate and critical topic; however, it is beside the point of this sample, which is to illustrate very-long-lived per-instance queues. We therefore avoid the topic in this sample.

The user can also log on to the application by running RunMe.wsf. The script checks the user name in the database and changes to another Web page that allows the user to submit commands to the personalized queue. Some suggested commands appear on the Web page SessionWebPage.htm. These commands only generate pop-up confirmation dialogs.

The one exception is the command Close This User Account. This command removes the user name from the database and shuts down the AccountSchedule, also causing deletion of the personalized queue.

Note that multiple copies of RunMe.wsf can run at one time, and, up to the limitations of contention for the simple text-file "database," all operations of this sample can be interleaved in any way. With user names stored in a SQL Server database, this issue would go away.

The theory articulated here can be verified through the Management Console and XLANG Monitor tools, as well as by inspecting the AccountQueuesDB.txt file over time. Also look at the schedules AmysZoneTop.skv and AccountSchedule.skv in BizTalk Orchestration Designer.

There is one final point worth mentioning. Due to a known limitation of XLANG script binding, it is necessary to have two messages in Port_4 of AccountSchedule. This port reports the user's command to a pop-up dialog box. One of the two messages is outside the loop and corresponds to the first command issued by the user. The other message is inside the loop and corresponds to subsequent commands issued by the user. Two messages are required because XLANG script binding refreshes the contents of a sourced message instance only once. Each iteration of the loop creates a new instance of the message as long as the message is not also present outside the loop. If there were only one message, the pop-up would show only the first command issued by the user, over and over again. The workaround for the limitation is to have two messages of identical form. Note that the Message Queuing binding in Port_2 does not suffer from this limitation, so a single message specification can be used both inside and outside the loop body.


Queue Listener

This sample demonstrates how to continuously monitor a queue for data and start another schedule when new data is available.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\QueueListener

User's Guide

The sample consists of the following directories:

  • ListenerApp contains the sample schedules, a data file, and VBScript files to run the sample.

  • ListenerClientUtil contains a helper component used by the ClientApp schedule.

  • ListenerUtil contains a helper component used by the ListenerApp schedule.

The setup script, setup.cmd, does the following:

  • Registers the ListenerClient component.

  • Registers the ListenerComp component.

  • Creates the Message Queuing queue, Listener.

To remove the sample, run remove.cmd.

To run the sample, first run startListenerApp.vbs in the ListenerApp directory. This starts the ListenerApp schedule and should be executed only once. The ListenerApp schedule monitors the Listener queue for data. When data is available in the queue, it starts the ClientApp schedule, passes the data to it, and starts another instance of itself. To put the data file order.xml into the queue, run File2Queue.vbs in the ListenerApp directory.

The File2Queue.vbs script can be run any number of times. To terminate the queue listener schedule, shut down and restart the XLANG Scheduler COM+ application by using the Component Services MMC snap-in.

Programming Notes

In the ListenerApp, the GetSkedInfo action is used to pass in the path of the ClientApp and ListenerApp schedules. The Receive Doc From Queue action waits until the document is available on the queue. The Start Client App action uses the helper component to start the ClientApp schedule and pass it the document. The Restart Schedule action uses the helper component to start another instance of the ListenerApp schedule before the current instance terminates.

Two transaction shapes are used to ensure that the schedule recovers from any abnormal termination. Transaction1 ensures that the schedule is persisted at the point where it is waiting on the Listener queue. Transaction2 ensures that the schedule is persisted just after the document is read from the queue. If the schedule is terminated at any time, it will be restarted from the last persisted state. It is important to ensure that the database is set up correctly to support persistence.

The ClientApp schedule simply displays the document that is passed to it as input.

The ListenerComp helper component is used by ListenerApp to receive input parameters and start schedules.

The ListenerClient helper component is used by ClientApp to receive input parameters and display the input document.


While Shape

This sample demonstrates how to use the While shape to retry a business process a limited number of times. A loop counter component is used to track the number of times the loop has executed. The loop terminates when the retry count is reached or when the simulated work completes successfully.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Loop

User's Guide

The sample consists of the following directories:

  • RetryApp contains the retry sample schedule and associated script components. It also includes a small VBScript file to run the sample.

  • LoopControl contains a helper component that implements a simple loop counter and supports persistence.

  • LoopUtil contains another helper component to display message boxes indicating the status of the schedule and to prompt for success or failure of the simulated work.

The setup script, setup.cmd, registers the loopcontrol component.

To remove the sample, run remove.cmd.

To run the sample, run startit.vbs in the LoopApp directory. When the schedule runs, it displays a message box to simulate the work being attempted. Click Yes to simulate successful completion of the work, or No to simulate failure. If you click No, the schedule retries the operation and displays the message box again. The schedule proceeds to completion after you click Yes or after the retry limit is reached, and indicates whether the operation was successful.

Programming Notes

This sample is a variation on a simple counted loop. The loop can terminate when the count limit is reached (the retry count) or when the simulated work completes successfully. To exit the loop early, the schedule initializes the loop count to a negative number. The While shape's rule is constructed to exit the loop when the maximum count is reached or when the count is negative.

A "constants" script component is used to supply the schedule with several constant values that are passed to other components.


XLANG and ASP

This sample demonstrates how to call a schedule from an ASP script, passing in data and getting back the result. The script initiates the work and then waits for the result.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\ASP

User's Guide

The sample consists of the following directories:

  • CreditCheckApp contains the creditcheck sample schedule, the ASP page, and a VBScript file to run the sample.

  • CreditCheckUtil contains a helper component to input data into the schedule and return the result.

  • CreditChecker contains a helper component that simulates the credit checking functionality.

The setup script, setup.cmd, does the following:

  • Registers the CreditCheckUtil component.

  • Registers the CreditChecker component.

  • Creates a creditsample Web directory on the default Web site of the local machine.

To remove the sample, run remove.cmd.

To run the sample, follow these steps:

  1. Run startit.vbs in the CreditCheckApp directory. The creditcheck ASP page is displayed in the Web browser.

  2. Enter a number in the text box and click Submit.

Credit will be denied to any number starting with 1 and to any number less then four characters in length.

Programming Notes

This sample uses a Fork shape to start both the credit checks simultaneously and a Join shape to wait for both the credit checks to complete. The ASP script waits on the IsCreditApproved call until the schedule executes the IsCreditApproved action.

Two helper components are used. The CreditCheckUtil component is used to input data into the schedule and return the results to the calling ASP script. The CreditChecker component is used to simulate calls to two different credit agencies to approve the credit.


XLANG Interfaces

This sample demonstrates how to use the XLANG public interfaces to enumerate and manage the running schedule instances and the XLANG host applications.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\PublicInterfaces

User's Guide

When run with no arguments, the sked.vbs script displays its usage options:

usage: cscript sked.vbs <command> <args>

commands:

hosts [computer]

shutdown [computer[!group]]

startup [computer[!group]]

list [computer[!group]]

run [computer[!group]] <schedule path or query> [count]

kill [computer[!group]] <instanceId>

suspend [computer[!group]] <instanceId>

resume [computer[!group]] <instanceId>

The following table shows examples of managing the schedule instances in the default group (host application "XLANG Scheduler") in the local machine.

Option | Result
sked list | Show a snapshot of the running schedules.
sked suspend {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Suspend the schedule with the given ID.
sked resume {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Resume the schedule with the given ID.
sked run c:\MySchedule.skx | Run the Orchestration schedule with the given full path. If the schedule is successfully started, the ScheduleID will be shown.
sked run c:\MySchedule.skx 10 | Run 10 instances of the given schedule.

The following table shows examples of managing the XLANG host applications.

Option | Result
sked hosts | Show the COM+ applications that can host the XLANG schedules.
sked shutdown | Shut down all host applications.
sked startup | Start all host applications.
sked shutdown "!My Host App" | Shut down only the host application named "My Host App".
sked startup "!My Host App" | Start the application "My Host App". (If the default host "XLANG Scheduler" was shut down, it will start too.)
sked hosts OtherMachine | List the host applications on the remote computer OtherMachine.
sked shutdown OtherMachine | Shut down all host applications on the remote machine OtherMachine.
sked startup OtherMachine!MyApp | Start the application MyApp on the remote computer OtherMachine (and possibly the default host "XLANG Scheduler").

The following table shows examples of managing schedules on different host applications and different machines.

Option | Result
sked list "!My Host App" | List the schedules running in "My Host App".
sked list "OtherMachine!MyApp" | List the schedules running in the application "MyApp" on the remote computer OtherMachine.
sked list OtherMachine | List the schedules running in the default host application ("XLANG Scheduler") on the remote computer OtherMachine.
sked run !MyApp c:\MySked.skx | Run the schedule MySked.skx in the application MyApp on the local machine.
sked run OtherMachine!MyApp \\server\share\MySked.skx | Run the schedule MySked.skx in the application MyApp on the remote machine OtherMachine. Note that the .skx file should be accessible to the application, for example, on a public share.
sked suspend !MyApp {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Suspend the schedule with the given ID, which is running in the application MyApp on the local machine.
sked resume OtherMachine!MyApp {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Resume a schedule running in the application MyApp on the remote computer OtherMachine.
sked kill OtherMachine {de0fff92-4424-4ef5-bdfb-a6b391403b95} | Terminate a schedule running in the default host on the remote computer OtherMachine.

Programming Notes

The XLANG public interfaces are available from the type library "XLANG Scheduler Runtime Type Library."

The sked.vbs script uses the public interfaces IWFSystemAdmin, IWFGroupAdmin, and IWFWorkflowInstance, as well as some COM+ admin interfaces and objects.

To list the running schedules or to suspend, resume, or terminate a schedule, the moniker for the Group Manager of the given application is constructed, and its IWFGroupAdmin interface is used.

To shut down or start all host applications, or to shut down a particular application, the IWFSystemAdmin interface is used.

To start a particular application, its moniker is constructed and used in GetObject.

To run a schedule, the proper moniker is constructed (for example, "sked://"+ the computer name +"!" + the application name +"/"+schedule path) and is used in GetObject. To obtain the ID and the module name of the newly started schedule, its IWFWorkflowInstance interface is used.

To list the XLANG host applications, the COM+ admin objects are used.


XLANG Schedule Pooling

This sample demonstrates how to use the pooling feature that is built into the XLANG Scheduler Engine. This feature helps running schedules to effectively use system resources. This sample also demonstrates the new BizTalk Server 2002 feature that makes the instance ID available.

BizTalk Server 2002 provides the capability to control the load on the XLANG Scheduler Engine by limiting the number of schedules that can be run simultaneously at any given time. If many schedules are active simultaneously, the server will constantly context switch and will use the operating system resources inefficiently.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\Schedule Throttling

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Run the Sample

Programming Notes

The following instructions walk through the process of setting up the pooling sample that utilizes the load-limiting capabilities of the BizTalk Server 2002 XLANG Scheduler Engine.

This schedule contains an action that is bound to a method called MessageBox on the script component. That method takes the instance ID of the schedule instance as a parameter, demonstrating one use of the new BizTalk Server 2002 feature that makes the instance ID available. As its name implies, the method displays a message box containing the instance ID. After the user clicks the message box, the schedule completes.


Preliminary Setup

Before you run the sample, you must complete the following tasks:

  • Register the Script Component

  • Run the Setup Script


Register the Script Component

In this procedure, you register the script component that is used by the sample schedule.

  1. Right-click the icon that represents the script component ThrottlingSample.wsc.

  2. Click Register.


Run the Setup Script

In this procedure, you run the script that sets up the pooling properties.

  1. Double-click the script ThrottlingConfig.vbs. Input boxes appear and request configuration information.

  2. Provide the requested information in each box and then click OK. The script uses this information to set the activation properties of the pool in which the sample schedule will run.


Run the Sample

In this procedure, you run the sample that demonstrates the pooling feature.

  1. Double-click the script ThrottlingSample.vbs. An input box appears and asks for the number of schedule instances to run.

  2. Enter the desired number of schedule instances to run and click OK.

  3. Monitor the number of running XLANG schedule instances by using XLANG Event Monitor (XLANGMon.exe). This number should not exceed the maximum pool size that was configured by using the setup script.

    Clicking the message box that a schedule instance displays allows that instance to complete and thereby make room for one more instance in the pool. If the pool becomes full before all the requested schedule instances have been activated, the next instance cannot be activated and will eventually time out. Thus, if you allow schedule instances to fill the pool (by not clicking their message boxes), you will eventually see a different message box declaring that activation of the next schedule instance has timed out.

  4. To rerun the sample with different pooling properties, rerun the setup script, ThrottlingConfig.vbs, and then start again at step 1 of this procedure.


XLANG Submit Synchronously and Query Asynchronously

This sample shows how to make an ASP page submit information into a XLANG schedule and then retrieve information without having to be interlocked with the running schedule.

Note

This sample is an extension of the ASP sample that shows the interaction between an ASP page and an XLANG schedule.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Modifying the Default Configuration

  • Running the Sample


Preliminary Setup

Complete the steps outlined in this section to configure your computer to run the sample.

Configuring the Sample Objects and Web Pages

The default configuration of this sample assumes that BizTalk Server 2002 and SQL Server 2000 are installed on the local computer. If you need to change the configuration, modify the values of DBHost as described in Modifying the Default Configuration.

To set up the required table, register COM objects, and configure a virtual Web directory, run SETUP.CMD located at \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\setup.


Modifying the Default Configuration

For the ASP page to interact asynchronously with the XLANG schedule, this sample uses a shared SQL table to store state and XLANG-to-ASP return information. Both parts of the sample (the ASP page and the XLANG schedule) share the COM object in XLANG_SAMPLE_ASYNC_SQL.DLL to communicate to the SQL table. The default configuration of the sample is to use the instance of SQL Server on "localhost."

Note that both groups of steps must be performed.

To change the COM object configuration:

  1. Change the default read-only status of the files in \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\SQL_Object to read/write. (Alternatively, copy the files to another working directory and make that copy writable; note that later you will have to re-register the COM object for this new location.)

  2. Using Visual Basic, open the project XLANG_SAMPLE_ASYNC_SQL.VBP.

  3. Open the module "globals" (the file globals.bas).

  4. Modify the variable DBHost to reference the desired instance of SQL Server.

  5. Make the project to rebuild XLANG_SAMPLE_ASYNC_SQL.DLL.

  6. If you have moved its location, remember to re-register the DLL using regsvr32.

To build the shared database on a computer other than "localhost":

  1. Change the default read-only status of the file \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\SETUP/SETUP_DB.CMD to read/write.

  2. Edit the file and change the two instances of "-S localhost" to the appropriate computer name.

  3. Save and run this modified setup script.

Security

Note that the virtual Web directory created for this sample uses Windows NT Authentication. A user accessing the sample Web page and possibly the service account for BizTalk (service BTSSvc) needs to have permission to the shared database. Generally the user of this sample is part of the "BizTalk Administrators" group and is the creator of the table, so there should be no problem running the sample.

Any other configuration or situation might require adjustments of security permissions in the SQL Server Enterprise Manager.


Running the Sample

To run the sample, you can run \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANG_ASYNC\RUN_SAMPLE.CMD.

Alternatively you can access http://localhost/sync_async_xlang/async.asp.

You can also complete the following steps:

  1. From a remote computer substitute the appropriate host name for "localhost."

  2. For "name of fruit", enter apples (note that this program is case-sensitive).

  3. For the amount enter any number (there are 50 "apples" in the warehouse).

  4. Click Submit.

The Web page will update with a blank table with a button labeled Check_Details on WorkItem #. At this point the ASP page has broken free of the XLANG schedule. Clicking the Check_Details… button repeatedly will update the blank table.

Approximately 30 seconds after submitting (for "apples"), the state column will change from "0 processing" to "1 Complete" and return information will appear in the strSKU and iAmountAvailable columns.

To contrast this with the normal synchronous interaction with XLANG, access the page:

http://localhost/sync_async_xlang/async.asp

This page (and its associated XLANG schedule) will not completely reload until the XLANG schedule returns information.


Programming Notes

This sample addresses the fact that some workflows in an XLANG schedule can take a long time to complete, especially when a schedule has to send a document or message to another organization and wait for returned information. BizTalk Server can handle the long delays, but a user waiting for an order to complete on a Web page might not.

This sample shows a technique to allow the user to submit information to an XLANG schedule and then quickly separate from the processing. The user can then asynchronously query the state of the processing.

For this sample, the business model is a simulated fruit warehouse. The user will request an inventory check for, say, "234 apples" and the warehouse will return a document with the available number of apples and the order code (SKU) for an actual purchase. To make the sample interesting, the processing takes a different amount of time depending upon what type of fruit is selected, as follows:

  • Bananas take 10 seconds to check inventory.

  • Apples take 30 seconds.

  • Oranges take 50 seconds.

  • Anything else is not in stock, and takes 0 seconds.

Note

  • To simulate the processing delay, the business code uses the Sleep function. This function should not be used in a production COM object because it will do things like prevent the long-running XLANG process from being dehydrated. It is used here to simplify the non-essential part of the sample code.

Technique Used

To allow the ASP page to work asynchronously with the XLANG schedule, the sample does the following:

  • The user fills out the form on the ASP page and clicks Submit.

  • The ASP page invokes the XLANG schedule.

  • Synchronously, the ASP page passes the request information to the schedule through a shared COM object.

  • The XLANG schedule registers for a row in a shared SQL table. The unique key for this row is used as a token for the working instance. The row now contains information in a "not ready" state.

  • The ASP page synchronously retrieves the token from the XLANG schedule (through the shared COM object) and is now free from the XLANG schedule.

  • The ASP page can now query the shared SQL table at any time to check for the change of state of the row.

  • The XLANG schedule does its processing. When complete, it updates the row in the shared table with returned data and changes the state to "completed."

  • Eventually, the ASP page query of the row will get the updated state and the returned information.

The following paragraphs provide information about the modules used in this example.

Inventory_OBJECT\XLANG_sample_fruit.dll

This is the simulated business process. Rather than complicating the sample with a complex workflow, this COM object simulates a long-running process.

Public Sub check_storeroom(ByVal str_in_type As String, _

ByVal i_in_amount_requested As Integer, _

ByRef str_out_SKU As String, _

ByRef i_out_amount_available)

This takes a fruit name (str_in_type) and a desired amount (i_in_amount) and eventually returns an order code (str_out_SKU) and amount available (i_out_amount_available).

Note

  • To simulate the processing delay, the business code uses the Sleep function. This function should not be used in a production COM object because it will do things like prevent the long-running XLANG process from being dehydrated. It is used here to simplify the non-essential part of the sample code.

ASP_OBJECT\XLANG_sample_ASP.dll

This is the linking COM object between the ASP page and the XLANG schedules. It is similar to the object used in the XLANG_Samples\ASP example.

It performs two tasks:

  • Provides the synchronization points between the ASP page and the XLANG schedules

  • Persists returned information from XLANG for the ASP to use

Note that this COM object is shared between the blocking.asp sample and the async.asp sample.

Persisted data for blocking.asp are the variables:

Dim stored_SKU As String

Dim stored_amount_available As Integer

Persisted data for async.asp is the variable

Dim stored_WorkID As Integer

This stub function is used by both blocking.asp and async.asp to pass information into their associated XLANG schedules:

Public Sub Request_fruit_amount(ByVal fruit_type As String, _

ByVal amount As Integer)

Note

  • The body of this method is never used. The XLANG schedule performs a "wait for synchronous call." This means that the XLANG schedule provides the body for the method and will wait until another program (the ASP page sharing the COM object) calls the method. The XLANG implementation then provides the arguments that are provided to the data page of the schedule.

For the blocking.asp sample, this method is used by blocking_sample.skv to store return data into the persisted data area:

Public Sub Store_fruit_response(ByVal SKU As String, _

ByVal amount_available As Integer)

For the blocking.asp sample, these methods are used by the ASP page to retrieve the persisted data:

Public Function Get_fruit_SKU() As String

Public Function Get_fruit_amount_available() As Integer

Notes

  • The XLANG schedule blocking_sample.skv performs a "wait for synchronous call" on these methods. This must be done for the sked object that calls these methods so that the VBScript code in the ASP page can access them.

  • In the schedule, the order in which the XLANG schedule waits for these methods must match exactly the order in which the ASP page will call them.

Compared to the blocking.asp sample, the mechanism in async.asp to communicate between the XLANG and ASP is simpler.

The ASP page still calls the Request_fruit_amount method but then uses this method to get a token for the row in the shared table:

Public Function Get_async_WorkID() As Integer

The XLANG schedule async_sample.skv gets the token and stores it through this method:

Public Sub Store_async_WorkID(ByVal iWorkID As Integer)

The XLANG schedule async_sample.skv then synchronizes with the ASP page with Get_async_WorkID

Note

  • The XLANG schedule async_sample.skv synchronizes with the ASP page at only two places. One is at the beginning of the schedule to get the input information and the other is to immediately pass the token information through Get_async_WorkID. The schedule then runs asynchronously from this point onward.

SQL_object\XLANG_SAMPLE_ASYNC_SQL.dll

This is the shared COM object between async.asp and async_sample.skv that handles working with the common SQL table:

Function Register_for_work_id(ByVal strFruitType, _

ByVal iRequestAmount) As String

This method is used by the XLANG schedule async_sample.skv to create a new row in the shared table. The method populates it with the input information and sets the state column (iState) to 0 (processing). The method returns a unique key for the row (WorkID). Any references to the row must use this unique key.

Public Function Update_work_entry(ByVal iWorkID As Integer, _

ByVal iState As Integer, _

ByVal strSKU As String, _

ByVal iAmountAvailable As Integer)

This method is used by the XLANG schedule async_sample.skv when the processing is complete to update the row with the returned information.

Public Function GetWorkItemXML(ByVal iWorkID As Integer) As String

This method is used by async.asp to populate a frame with the state of the row. The returned sting is SQL XML format (SQL table was accessed as "FOR XML AUTO")

Async.asp

This is the user page that invokes the XLANG schedule and then can query for returned information asynchronously.

Note

  • The following code invokes the XLANG schedule and exposes the interface methods used to synchronize with it:

sSkedUrl = "sked:///" & sPath & "async_sample.skx/ASP_async_Interface"

This references the schedule file. Note the addition of the COM interface that should be exposed.

set sked = GetObject(sSkedUrl)

This actually starts the XLANG schedule, which now waits for the first call to request_fruit_amount.

sked.request_fruit_amount sText, sAmount

iWorkID = sked.Get_async_WorkID()

These two lines pass information in and retrieve the token from the schedule (the only synchronous operation with the schedule).

The rest of the ASP page creates a button to invoke Work_item_details.asp to fill the frame at the bottom of the page.

Work_item_details.asp

This ASP page calls GetWorkItemXML to retrieve the state of the schedule's operations and formats the XML for rendering as a table.

The rendering is done by an XSLtransform in workitem_details.xsl.


XLANG Trace

This sample uses a COM object in the library XLANG_TRACE.dll to insert tracing operations into an XLANG schedule. This COM object helps trace and debug problems in an XLANG schedule by writing data from the running schedule into a logging table. Any data that is used in the schedule can be sent to the logging table, including the XML documents being passed between actions in the schedule.

Note

  • This sample is intended only for debugging a specific XLANG schedule. In a production environment, the tracing COM object should not be used because it can significantly impact XLANG schedule processing performance.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE.

User's Guide

To prepare and run the sample, follow these steps:

  • Preliminary Setup

  • Modifying the Default Configuration

  • Using the Tracing Component

  • Viewing the Trace Results

Programming Notes

After the XLANG_TRACE COM object is registered on a computer running BizTalk Server, you can add one or more bindings to this object in your existing XLANG schedule files. After the object is bound to a schedule, you need to modify the data mapping in the schedule to specify the data being traced. The XLANG_TRACE object contains the following input parameters for recording schedule data:

message_label

String to describe the name of the Action shape.

message_ID

String to hold a unique identifier for this schedule, such as the instance GUID of the schedule.

message_UserKey

String to store a unique document identifier, such as a purchase order number.

message_body

String to store a large amount of data, such as an entire XML document in a message.


Preliminary Setup

Complete the steps outlined in this section to configure your computer to run the XLANG tracing sample.

Configuring the Tracing Database

The default settings of the XLANG tracing sample require a database for storing the tracing data. However, you can modify these settings to use Event Logging instead of, or in addition to, a database. If you do not want to use a database, proceed to the next section, Modifying the Default Configuration.

To use a database for the tracing data, run the command script setup_db.cmd that is located on the installation drive at \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE\setup. This command script file creates the following items:

  • A database named XLANG_TRACE

  • A table in this database named trace_table

  • A stored procedure in this database named Log_text_message

Note

  • If you choose to run this file on a remote computer, you must modify the DBHost value in the Globals.bas file, as described in Modifying the Default Configuration.

Registering the Tracing Component

To register the XLANG_TRACE.dll component, run the command script register_COM.cmd that is located on the installation drive at \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE\setup. The COM object XLANG_TRACE.dll must be registered on each computer that uses it.


Modifying the Default Configuration

The XLANG_TRACE sample can be configured to output tracing information into an SQL table or to the system Event Viewer. By default, the XLANG_TRACE COM object (XLANG_TRACE.dll) is configured to store the trace information in a SQL Server database on the local computer ("localhost"). This configuration assumes that both BizTalk Server and SQL Server are running on the local computer.

To change the settings of the tracing object, you must edit the global variable values in the file Globals.bas, and recompile the Microsoft Visual Basic project named XLANG_TRACE.vbp. The following global variables can be modified:

DBHost

String containing the host name of the computer running SQL Server where the tracing data will be stored. An empty string ("") is used to indicate that tracing data will not be stored to a database. The default value is "localhost".

EventLogging

Boolean that indicates whether tracing data should be logged in the system Event Viewer. A value of True indicates that tracing data is logged in the Event Viewer. The default value is False.

The other variables in the Globals.bas module contain information about the database (DBTraceDatabase) and table (DBTraceTable) names. It is not necessary to modify these values. If these values are changed, the file dumptable.xsl will also require modification.

After you have modified the global variables and saved the Visual Basic project, recompile the project into a new DLL file.

Notes

  • If any changes are made to the COM object after its first use, you might need to stop and restart the XLANG Scheduler Engine to release the cached version of the COM object before the new version can be run. For information on stopping and restarting the XLANG Scheduler Engine, see the following topics in the BizTalk Server Help file:
    • Shut down all XLANG applications

    • Restart all XLANG applications
  • If the dumptable.asp page is used to view the tracing data before changes are made to the tracing object, Internet Information Services (IIS) might also use a cached version of the original object. For more information, see Restarting BizTalk Server and Internet Information Services.

  • When event logging is enabled, the events appear in the application log. The XLANG tracing entries will have a Type value of Information, and a Source value of VBRuntime.


Restarting Biztalk Server and Internet Information Services

If a BizTalk Server schedule or an ASP page references a COM object, it will be locked "in use" and cannot be replaced by a recompile. These services must be restarted to release the cached COM object and allow the COM object to be recompiled.

This procedure explains how to restart Internet Information Services (IIS).

  1. On the Start menu, point to Settings and click Control Panel.

  2. Double-click Administrative Tools.

  3. Double-click Computer Management.

  4. In the Computer Management console tree, expand Services and Applications and then click Internet Information Services.

  5. On the Action menu, click Restart IIS.

    The Stop/Start/Reboot dialog box appears.

  6. Verify that Restart Internet Services on computer_name is selected.

  7. Click OK to restart IIS.

This procedure restarts the Biztalk Server service that will also hold onto a COM object.

  1. Still using Computer Management, click the Services node and click XLANG Schedule Restart Service near the bottom.

  2. On the Action menu, click Restart


Using the Tracing Component

After the tracing component has been configured and registered, you can add one or more references to it in any XLANG schedule. To add the tracing component to an XLANG schedule, complete the following steps:

  1. Open your XLANG schedule drawing (.skv) in BizTalk Orchestration Designer.

  2. Add a COM component implementation shape to the right side of the Business Process drawing.

  3. Complete the COM Component Binding Wizard and select the Logger class from XLANG_TRACE in the list of registered components.

  4. Add an Action shape to the left side of the Business Process drawing.

  5. Connect the process flow arrow from the bottom of the preceding shape into the top of the new Action shape.

  6. Connect the process flow arrow from the bottom of the new Action shape into the top of the following shape.

  7. Click the new Action shape to highlight it, and then drag the connection point on the right side of the Action shape to the connection point on the left side of the port that is associated with the XLANG_TRACE COM object.

  8. Complete the Method Communication Wizard.

  9. Re-map the data flow on the Data page. You can set the input values of the XLANG_TRACE LogStringMessage method by using other messages on the Data page or by using constants.

  10. Save and re-compile your XLANG schedule. It might be helpful to save the file as a separate tracing version by using a different name. For example, a new version of a file named myschedule.skv can be named myschedule_trace.skv.

  11. Run the new schedule and view the tracing information in the database or in Event Viewer, depending on your configuration.

For additional information about using BizTalk Orchestration Designer, see the BizTalk Server Help file.


Viewing the Trace Results

The tracing information that is stored in the database can be viewed directly through SQL Server. To view this data, follow these steps:

  1. On the Start menu, point to Programs, point to Microsoft SQL Server, and click Enterprise Manager.

  2. Expand the Microsoft SQL Servers tree, and expand the group and server name of the computer that is running the database for the XLANG tracing information.

  3. Expand the Databases folder, expand the XLANG_TRACE database, and then click Tables.

  4. Right-click the table named trace_table, and then point to Open Table and click Return all rows.

The tracing information that is stored in the database can also be accessed by using the file Dumptable.asp located in the folder \Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XLANGTRACE\ASP on the BizTalk Server installation drive.

Notes

  • To use the ASP file, you must either map the ASP folder as a virtual directory in Internet Information Services (IIS), or place the contents of the ASP folder into an existing virtual directory.

  • You might need to add the Internet user account (ISR_computername) to allow IIS access to the database.

Event Viewer logs can be accessed in the Computer Management console.


XML Translation

This sample demonstrates how to use the SubmitSync method of BizTalk Server to perform an XML transformation by using BizTalk Orchestration Services.

Path

To locate the sample files, browse to the following folder on the BizTalk Server installation drive:

\Program Files\Microsoft BizTalk Server\SDK\XLANG Samples\XML Translation

User's Guide

The sample consists of the following modules:

  • A Visual Basic ActiveX DLL contains the component called by the schedule to get the submission parameters.

  • The loopback.vbs script contains the code to run the schedule.

The setup script, setup.cmd, does the following:

  • Registers the ProcessDoc component

  • Creates message queues.

  • Creates BizTalk Configuration objects.

To remove the sample, run remove.cmd and delete the copied files from the directories.

To run the sample, run loopback.vbs. The script sends SamplePOData.xml to the received_in message queue and starts the loopback.skx schedule.

Programming Notes

This sample demonstrates the use of the SubmitSync call using BizTalk Orchestration Services to do the XML transformations. The schedule picks up the document from the received_in queue and then calls GetSubmitParams to get parameters for calling SubmitSync. When the SubmitSync call is returned, the transformed document is returned in the out parameter, which is displayed and then sent to the biztalk_out message queue.


BizTalk Server Reference

This section contains the following topics:

  • Messaging Services Reference

  • Documents Reference

  • Custom Components Reference

  • Orchestration Services Reference

  • Managing and Monitoring Reference

  • Error Messages


Messaging Services Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for accessing messaging services:

  • Interfaces

  • Enumerations

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented:

  • IBizTalkBase

  • IBizTalkCertificateInfo

  • IBizTalkChannel

  • IBizTalkConfig

  • IBizTalkDocument

  • IBizTalkEndPoint

  • IBizTalkEnvelope

  • IBizTalkLoggingInfo

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

  • IBizTalkServiceWindowInfo

  • IBizTalkTransportInfo

  • IDictionary

  • ISimpleList


IBizTalkBase

Defines common methods and properties inherited by several messaging services objects.

Hierarchy

IDispatch

|--IBizTalkBase

Declaration

[Visual Basic]

Class IBizTalkBase

[C++]

interface IBizTalkBase : IDispatch

Members

IBizTalkBase defines the following properties:

Property | Description
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
Name | Contains the name of the object.

IBizTalkBase defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Remarks

The following interfaces inherit properties and methods from IBizTalkBase:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Note

  • The methods and properties of IBizTalkBase are always invoked on the objects listed above, rather than by creating an actual IBizTalkBase object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Clear Method

Clears the object from memory.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Clear( )

[C++]

HRESULT Clear( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

After Clear is called, all member variables of the object in memory are initialized to their default values.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Create Method

Creates a new object in the database.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Function Create( ) As Long

[C++]

HRESULT Create(

long* BiztalkObjectHandle

);

Parameters

BiztalkObjectHandle

[out, retval] In C++, contains a handle to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a handle to the object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The Name property must be set before calling this method. Name must be unique across the database for each object type. Create updates the DateModified property.

When creating any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


DateModified Property

Contains the date and time at which the information in the object was created or last modified.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Property Declaration

[Visual Basic]

Property DateModified As String

[C++]

HRESULT get_DateModified(

BSTR* Modified

);

Parameters

Modified

[out, retval] In C++, contains the date modified. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the date modified.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The format for the Modified string is yyyy-mm-dd hh:mm:ss. The time is in coordinated universal time (UTC). The server sets this property when the Create or the Save method is called for the object.

The following objects support this property:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Handle Property

Contains the handle to the object.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Property Declaration

[Visual Basic]

Property Handle( ) As Long

[C++]

HRESULT get_Handle(

long* BiztalkObjectHandle

);

Parameters

BiztalkObjectHandle

[out, retval] In C++, contains the handle to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property contains the handle to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The following objects support this property:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Load Method

Loads a specified object in memory.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Load( _

BiztalkObjectHandle As Long _

)

[C++]

HRESULT Load(

long BiztalkObjectHandle

);

Parameters

BiztalkObjectHandle

[in] Contains the handle to the object to load.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Load calls the Clear method internally before loading the object.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


LoadByName Method

Loads a specified object by name in memory.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub LoadByName( _

Name As String_

)

[C++]

HRESULT LoadByName(

BSTR Name

);

Parameters

Name

[in] Contains the name of the object to load.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

LoadByName calls the Clear method internally before loading the object.

Names have a maximum length of 64 characters.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Name Property

Contains the name of the object.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--LoadLat_SDK_BTCOM_Base_GQNF

|--LoadByName

|--Name

|--Remove

|--Save

Property Declaration

[Visual Basic]

Property Name( ) As String

[C++]

HRESULT get_Name(

BSTR* Name

);

HRESULT put_Name(

BSTR Name

);

Parameters

Name

[out, retval], [in] In C++, contains the name of the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The server requires the Name property. It must be set before calling the Create or the Save method for the object. Name must be unique across a database for each object type and must be at least one character long. Names have a maximum length of 64 characters.

The following table lists names reserved for use by BizTalk Server:

Name | Object type
Reliable Message Acknowledgement Port | IBizTalkPort
Reliable Message Acknowledgement Channel | IBizTalkChannel
BizTalk Canonical Receipt | IBizTalkDocument
Reliable Messaging Acknowledgement | IBizTalkDocument
Reliable Messaging Acknowledgement SMTP From Address | IBizTalkOrganization
Home Organization | IBizTalkOrganization

The following objects support this property:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Remove Method

Removes the object from the database.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Remove( )

[C++]

HRESULT Remove( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The object cannot be removed if any other object refers to it.

A BizTalkOrganization object cannot be removed if it is the default organization. Before it can be removed, the IsDefault property must be set to False, and another organization must have the IsDefault property set to True.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Referential Integrity


Save Method

Saves the object in the database.

Member List

IBizTalkBase

|--Clear

|--Create

|--DateModified

|--Handle

|--Load

|--LoadByName

|--Name

|--Remove

|--Save

Method Declaration

[Visual Basic]

Sub Save( )

[C++]

HRESULT Save( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The Save method updates the DateModified property.

When saving any object that refers to an XML document specification or map located outside your local domain, you might receive an error. If an error occurs, download and configure the WinHTTP proxy utility. To download this utility, go to the Microsoft MSDN Web site at msdn.microsoft.com/downloads/default.asp, and browse to the WinHTTP Proxy Configuration Utility page, which is located in the XML chapter of the Web Development book.

The following objects support this method:

  • IBizTalkChannel

  • IBizTalkDocument

  • IBizTalkEnvelope

  • IBizTalkOrganization

  • IBizTalkPort

  • IBizTalkPortGroup

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkCertificateInfo

Configures a certificate associated with an IBizTalkPort or IBizTalkChannel object.

Hierarchy

IDispatch

|--IBizTalkCertificateInfo

Declaration

[Visual Basic]

Class BizTalkCertificateInfo

[C++]

interface IBizTalkCertificateInfo : IDispatch

Members

IBizTalkCertificateInfo defines the following properties:

Property | Description
Name | Contains the name of the certificate.
Reference | Contains a reference to the certificate in the certificate store.
Store | Contains the store type for the certificate.
Usage | Contains the type of use for the certificate.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Certificates


Name Property

Contains the name of the certificate.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Name As String

[C++]

HRESULT get_Name(

BSTR* Name

);

Parameters

Name

[out, retval] In C++, contains the name of the certificate. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the certificate.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Reference Property

Contains a reference to the certificate in the certificate store.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Reference As String

[C++]

HRESULT get_Reference(

BSTR* Reference

);

HRESULT put_Reference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the certificate reference. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate reference.

In C++, this property returns an HRESULT value, indicating success or failure.

For a list of all error messages returned by BizTalk Server, see Error Messages.

Note

  • In addition to the HRESULT values listed on the error messages page, the put method returns CryptoAPI errors. Additional information about CryptoAPI is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). A reference to a certificate should be obtained by using the Certificates property on the IBizTalkConfig object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Store Property

Contains the store type for the certificate.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Store As BIZTALK_STORE_TYPE

[C++]

HRESULT get_Store(

BIZTALK_STORE_TYPE* StoreType

);

HRESULT put_Store(

BIZTALK_STORE_TYPE StoreType

);

Parameters

StoreType

[out, retval], [in] In C++, contains the store type for the certificate. Valid values for this parameter are defined by the BIZTALK_STORE_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_STORE_TYPE enumeration.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The store, which contains the certificate, is determined by the use of the certificate as follows:

Certificate type | Store
Decryption | MY
Encryption | BIZTALK
Signature | MY
Verify signature | BIZTALK

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Usage Property

Contains the type of use for the certificate.

Member List

IBizTalkCertificateInfo

|--Name

|--Reference

|--Store

|--Usage

Property Declaration

[Visual Basic]

Property Usage As BIZTALK_USAGE_TYPE

[C++]

HRESULT get_Usage(

BIZTALK_USAGE_TYPE* UsageType

);

Parameters

UsageType

[out, retval] In C++, contains the usage type for the certificate. Valid values for this parameter are defined by the BIZTALK_USAGE_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_USAGE_TYPE enumeration.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkChannel

Configures a channel for processing documents.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkChannel

Declaration

[Visual Basic]

Class BizTalkChannel

[C++]

interface IBizTalkChannel : IBizTalkBase

Members

IBizTalkChannel defines the following properties:

Property | Description
Comments | Contains user comments for the object.
ControlNumberValue | Contains the value of the group control number.
DateModified | Contains the date and time at which the information in the object was created or last modified.
DecryptionCertificateInfo | Contains information about the certificate that decrypts the input document.
ExpectReceiptTimeout | Contains the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.
Expression | Contains a complete set of equations that filter the selection of the object.
Handle | Contains the identifier of the object.
InputDocument | Contains the handle to the input IBizTalkDocument object that describes the input document specification.
IsReceiptChannel | Contains the flag that indicates whether the object is a receipt channel.
LoggingInfo | Contains information about logging the document.
MapContent | Contains the contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.
MapReference | Contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.
Name | Contains the name of the object.
OutputDocument | Contains the handle to the output IBizTalkDocument object that describes the output document specification.
Port | Contains the handle to the associated IBizTalkPort object.
PortGroup | Contains the handle to the associated IBizTalkPortGroup object.
ReceiptChannel | Contains the handle to the receipt channel for this object.
RetryCount | Contains the number of times to retry submitting a document when a destination connection failure occurs.
RetryInterval | Contains the amount of time, in minutes, between retry attempts when a destination connection failure occurs during document submission.
SignatureCertificateInfo | Contains information about the certificate that signs the output document.
SourceEndpoint | Contains information about the source.
TrackFields | Contains the IDictionary object that points to the specification that contains fields to track interchange data on input documents for this IBizTalkChannel object.
VerifySignatureCertificateInfo | Contains information about the certificate that verifies the signature of the input document.

IBizTalkChannel defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
GetConfigComponent | Retrieves the CLSID of the component associated with the IBizTalkPort object.
GetConfigData | Retrieves the configuration associated with the specified IBizTalkPort object.
Load | Loads an object in memory.
LoadByName | Loads an object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.
SetConfigComponent | Sets the CLSID of the component associated with the IBizTalkPort object.
SetConfigData | Sets the configuration information for the associated IBizTalkPort object.

Remarks

An IBizTalkChannel object requires an associated complete IBizTalkPort object. One or more IBizTalkChannel objects can be associated with an IBizTalkPort object. An IBizTalkChannel object can be associated with only one input IBizTalkDocument object and one output IBizTalkDocument object; however, an IBizTalkDocument object can be associated with more than one IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Channels

Document Processing


Comments Property

Contains the user comments for the object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property Comments As String

[C++]

HRESULT get_Comments(

BSTR* Comments

);

HRESULT put_Comments(

BSTR Comments

);

Parameters

Comments

[out, retval], [in] In C++, contains the user comments for the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the user comments for the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ControlNumberValue Property

Contains the value of the group control number.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property ControlNumberValue As String

[C++]

HRESULT get_ControlNumberValue(

BSTR* strControlNumberValue

);

HRESULT put_ControlNumberValue(

BSTR strControlNumberValue

);

Parameters

strControlNumberValue

[out, retval], [in] In C++, contains the value of the group control number. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the value of the group control number.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The ControlNumberValue property must contain a value between 1 and 999999999.

If the Format property of the IBizTalkEnvelope object for the associated IBizTalkPort object is set to X12, EDIFACT, or Custom, this property is required.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


DecryptionCertificateInfo Property

Contains information about the certificate that decrypts the input document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property DecryptionCertificateInfo As Object

[C++]

HRESULT get_DecryptionCertificateInfo(

IDispatch** DecryptionCertificateInfoDisp

);

HRESULT putref_DecryptionCertificateInfo(

IDispatch* DecryptionCertificateInfoDisp

);

Parameters

DecryptionCertificateInfoDisp

[out, retval], [in] In C++, contains the information about the certificate that decrypts the input document. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the information about the certificate that decrypts the input document.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the IBizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ExpectReceiptTimeout Property

Contains the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property ExpectReceiptTimeout As Long

[C++]

HRESULT get_ExpectReceiptTimeout(

long* Minutes

);

HRESULT put_ExpectReceiptTimeout(

long Minutes

);

Parameters

Minutes

[out, retval], [in] In C++, contains the time, in minutes, in which to expect the receipt for the current document before treating the document as expired. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the time, in minutes, in which to expect the receipt for the current document before treating the document as expired.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of 0.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Expression Property

Contains a complete set of equations that filter the selection of the object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property Expression As String

[C++]

HRESULT get_Expression(

BSTR* Expression

);

HRESULT put_Expression(

BSTR Expression

);

Parameters

Expression

[out, retval], [in] In C++, contains a complete set of equations that filter the selection of the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a complete set of equations that filter the selection of the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). If the expression evaluates to true, the server selects the channel for processing the document.

The XPath expression must be based on the input document specification set in the InputDocument property.

Note

  • If the specification field that you are using to create an expression has a Boolean data type, you cannot use the text strings "true" or "false" as the expression value. You must use a numerical value instead: "-1" for true and "0" for false. For example, to filter a channel so it processes only approved purchase orders, your expression might look like this:

Channel1.Expression = "/PORequest/Total[IsApproved = -1]"

This sample assumes that the input document specification contains a Total subelement with a Boolean IsApproved field.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Channel Filtering


GetConfigComponent Method

Retrieves the CLSID of the component associated with the IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Function GetConfigComponent( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

PortHandle As Long _

) As String

[C++]

HRESULT GetConfigComponent(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long PortHandle,

BSTR* CLSID

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

PortHandle

[in] Contains the handle to the IBizTalkPort object.

CLSID

[out, retval] In C++, contains the CLSID of the component associated with the IBizTalkPort object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the CLSID of the component associated with the IBizTalkPort object.

In C++, this method returns an HRESULT value, indicating success or failure.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If the ConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated IBizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


GetConfigData Method

Retrieves the configuration associated with the specified IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Function GetConfigData( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

PortHandle As Long, _

Type As Variant _

)

[C++]

HRESULT GetConfigData(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long PortHandle,

VARIANT* Type,

VARIANT* Dictionary

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

PortHandle

[in] Identifies the handle to the associated IBizTalkPort object.

Type

[in, out] Contains the transport type.

Dictionary

[in, out] In C++, contains the IDictionary interface of an object that contains the primary transport configuration information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an IDictionary object that contains the primary transport configuration information.

In C++, this method returns an HRESULT value, indicating success or failure.

Note

In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When reading serializer data, the IDictionary object returned by this method has specific string qualifiers used for EDIFACT and X12. The following tables describe these strings.

EDIFACT

Qualifier string | Description
SerializerEdifact_SenderIntID | Interchange sender internal identification
SerializerEdifact_SenderIntSubID | Interchange sender internal subidentification
SerializerEdifact_RecipientIntID | Interchange recipient internal identification
SerializerEdifact_RecipientIntSubID | Interchange recipient internal subidentification
SerializerEdifact_RecipientRefPwd | Recipient reference/password
SerializerEdifact_RecipientRefPwdQual | Recipient reference/password qualifier
SerializerEdifact_ApplicationRef | Application reference
SerializerEdifact_ProcPriCode | Processing priority code
SerializerEdifact_AckRequest | Acknowledgment request
SerializerEdifact_AgreementID | Interchange agreement identifier
SerializerEdifact_TestInd | Test indicator
SerializerEdifact_UNACtrl | "Send UNA Always" or "Send UNA Only When Required"
SerializerEdifact_SyntaxID | Syntax identifier

X12

Qualifier string | Description
SerializerX12_AuthInfoQual | Authorization information qualifier
SerializerX12_AuthInfo | Authorization information
SerializerX12_SecInfoQual | Security information qualifier
SerializerX12_SecInfo | Security information
SerializerX12_CtrlStdID | Interchange control standards identifier
SerializerX12_CtrlVerNum | Interchange control version number
SerializerX12_AckRequired | Acknowledgment required
SerializerX12_UseInd | Usage indicator

Note

  • For more information about the EDIFACT standard, see the United Nations Economic Commission for Europe Web site (www.unece.org).

  • For more information about the X12 standard, see the Data Interchange Standards Association Web site (www.disa.org).

If you override the transport properties of an IBizTalkPort object with this method and then change the transport properties in that IBizTalkPort object, you must call this method again.

If the ConfigType parameter is set to BIZTALK_CONFIGDATA_TYPE_SIGNATURE and the associated IBizTalkPort object has both the EncryptionType and SignatureType properties set to S/MIME, this method returns an empty IDictionary object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


InputDocument Property

Contains the handle to the input IBizTalkDocument object that describes the input document specification.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property InputDocument As Long

[C++]

HRESULT get_InputDocument(

long* InDocHandle

);

HRESULT put_InputDocument(

long InDocHandle

);

Parameters

InDocHandle

[out, retval], [in] In C++, contains the handle of the input IBizTalkDocument object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle of the input IBizTalkDocument object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property.

This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Configuring

Document Definitions

Document Processing


IsReceiptChannel Property

Contains a flag that indicates whether the object is a receipt channel.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property IsReceiptChannel As Boolean

[C++]

HRESULT get_IsReceiptChannel(

VARIANT_BOOL* IsReceiptChannel

);

HRESULT put_IsReceiptChannel(

VARIANT_BOOL IsReceiptChannel

);

Parameters

IsReceiptChannel

[out, retval], [in] In C++, contains a value indicating whether or not the channel is a receipt channel. VARIANT_TRUE indicates that this channel is a receipt channel; VARIANT_FALSE indicates that this channel is not a receipt channel. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value indicating whether or not the channel is a receipt channel. True indicates that this channel is a receipt channel; False indicates that this channel is not a receipt channel.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

ReceiptChannel


LoggingInfo Property

Contains information about logging the document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property LoggingInfo As Object

[C++]

HRESULT get_LoggingInfo(

IDispatch** LoggingInfoDisp

);

HRESULT putref_LoggingInfo(

IDispatch* LoggingInfoDisp

);

Parameters

LoggingInfoDisp

[out, retval], [in] In C++, contains the logging fields. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the logging fields.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Information contained by this property includes the LogNativeInputDocument, LogNativeOutputDocument, LogXMLInputDocument, and LogXMLOutputDocument properties and is created and stored in memory in the IBizTalkLoggingInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


MapContent Property

Contains the contents of the map that provide instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property MapContent As String

[C++]

HRESULT get_MapContent(

BSTR* MapContent

);

onkeypress="expand(expand3, img3)" onclick="expand(expand3, img3)"> Parameters

MapContent

[in] In C++, contains the map contents. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the map contents.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). This is a read-only property. The Create and Save methods copy the text of the map specified by the MapReference property to this string, if empty.

Once you have created or saved a IBizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring IBizTalkChannel object. To update the IBizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the IBizTalkChannel object to its current value, and then call Save on the referring IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


MapReference Property

Contains the full Web Distributed Authoring and Versioning (WebDAV) URL of the map that provides instructions on how the input document in the format used by the source organization is to be rendered in the format used by the destination organization, if different.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property MapReference As String

[C++]

HRESULT get_MapReference(

BSTR* Reference

);

HRESULT put_MapReference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the map name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the map name.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string (""). This is a required property if the InputDocument property refers to a different document specification than the OutputDocument property.

Once you have created or saved a IBizTalkChannel object with MapReference set to a map, any changes you make to the content of the referenced map are not automatically updated on the referring IBizTalkChannel object. To update the IBizTalkChannel object that refers to the revised map, you must save the map, reset the MapReference property of the IBizTalkChannel object to its current value, and then call Save on the referring IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


OutputDocument Property

Contains the handle to the IBizTalkDocument object that describes the output document specification.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property OutputDocument As Long

[C++]

HRESULT get_OutputDocument(

long* OutDocHandle

);

HRESULT put_OutputDocument(

long OutDocHandle

);

Parameters

OutDocHandle

[out, retval], [in] In C++, contains the handle to the output IBizTalkDocument object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the output IBizTalkDocument object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property. This property cannot be changed after the Create or the Save method is called.

If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_SOURCE, the InputDocument property can identify an input IBizTalkDocument object that has an X12 or an EDIFACT specification. If it does, however, OutputDocument must not identify an IBizTalkDocument object that has an X12 or an EDIFACT specification.

If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the OutputDocument property for this IBizTalkChannel object must not identify an output IBizTalkDocument object that has an X12 or an EDIFACT specification.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions


Port Property

Contains the handle to the associated IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property Port As Long

[C++]

HRESULT get_Port(

long* PortHandle

);

HRESULT put_Port(

long PortHandle

);

Parameters

PortHandle

[out, retval], [in] In C++, contains the handle to the IBizTalkPort object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the IBizTalkPort object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The following constraints are enforced:

  • Either the Port or the PortGroup property must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Messaging Ports


PortGroup Property

Contains the handle to the associated IBizTalkPortGroup object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property PortGroup As Long

[C++]

HRESULT get_PortGroup(

long* PortGroupHandle

);

HRESULT put_PortGroup(

long PortGroupHandle

);

Parameters

PortGroupHandle

[out, retval], [in] In C++, contains the handle to the associated IBizTalkPortGroup object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the associated IBizTalkPortGroup object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The following constraints are enforced:

  • Either the Port property or PortGroup must be specified for a channel.

  • This property cannot be changed after the Create or the Save method is called.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Port Groups


ReceiptChannel Property

Contains the handle to the receipt channel for this object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property ReceiptChannel As Long

[C++]

HRESULT get_ReceiptChannel(

long* ReceiptChannelHandle

);

HRESULT put_ReceiptChannel(

long ReceiptChannelHandle

);

Parameters

ReceiptChannelHandle

[out, retval], [in] In C++, contains the handle to the receipt channel. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the receipt channel.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. An IBizTalkChannel object can specify a receipt channel only if it is not a receipt channel itself. The channel specified as the receipt channel must have the IsReceiptChannel property set to TRUE. In addition, the receipt channel must use a messaging port with a DestinationEndpoint that is the same as the SourceEndpoint on the channel using the receipt channel. This allows the receipt channel to send a receipt to the original source of the document.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RetryCount Property

Contains the number of times to retry submitting a document when a destination connection failure occurs.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property RetryCount As Long

[C++]

HRESULT get_RetryCount(

long* Count

);

HRESULT put_RetryCount(

long Count

);

Parameters

Count

[out, retval], [in] In C++, contains the number of retries. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of retries.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The RetryCount property must contain a value between 0 and 999. The default value is 3 retries.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RetryInterval Property

Contains the amount of time, in minutes, between retry attempts when a destination connection failure occurs during document submission.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property RetryInterval As Long

[C++]

HRESULT get_RetryInterval(

long* Interval

);

HRESULT put_RetryInterval(

long Interval

);

Parameters

Interval

[out, retval], [in] In C++, contains the retry interval, in minutes. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the retry interval, in minutes.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The RetryInterval property must contain a value between 1 and 63999. The default value is 5 minutes.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SetConfigComponent Method

Sets the CLSID of the component associated with the IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Sub SetConfigComponent( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

PortHandle As Long, _

CLSID As String _

)

[C++]

HRESULT SetConfigComponent(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long PortHandle,

BSTR CLSID

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

PortHandle

[in] Contains the handle.

CLSID

[in] Contains the CLSID of the component.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SetConfigData Method

Sets the configuration information for the associated IBizTalkPort object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Method Declaration

[Visual Basic]

Sub SetConfigData( _

ConfigType As BIZTALK_CONFIGDATA_TYPE, _

ConfigDataHandle As Long, _

ConfigDataDisp As Object _

)

[C++]

HRESULT SetConfigData(

BIZTALK_CONFIGDATA_TYPE ConfigType,

long ConfigDataHandle,

IDispatch* ConfigDataDisp

);

Parameters

ConfigType

[in] Determines the configuration type. Valid values for this parameter are defined by the BIZTALK_CONFIGDATA_TYPE enumeration.

ConfigDataHandle

[in] Identifies the handle to the associated IBizTalkPort object.

ConfigDataDisp

[in] IDictionary object that contains information about the component specified in the ConfigType parameter.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The IDictionary object passed to this method has specific string qualifiers used for EDIFACT and X12. For a description of these qualifiers, see the GetConfigData Method.

When using the BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT or BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT enumeration value, the content of the transport dictionary varies according to the transport protocol used. The following tables list the transport dictionary fields for each protocol.

HTTP and HTTPS

Field name | Data type | Required | Description
URL | String | Yes | URL of the document destination.
ContentType | String | No | Value for the Content-Type HTTP/HTTPS property that appears in HTTP headers during transmission. The default value is an empty string ("").
ClientCert | String | No | Reference to the certificate used with SSL connections using HTTPS. The default value is an empty string ("").
ProxyName | String | No | URL of the proxy server used when sending documents outside a firewall.
ProxyPort | Integer | No | Port number used by the proxy server.
UseProxy | Boolean | No | Value that indicates whether the proxy server is used. The default value is True.

Local File

Field name | Data type | Required | Description
Filename | String | Yes | Name and path of the file to be created.
CopyMode | Integer | No | Value that indicates how the file should be written. Use a value of 0 for overwrite mode, a value of 1 for append mode, and a value of 2 to create a new file. The default value is append mode (1).
UserName | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").
Password | String | No | Windows NT username needed to access a file share. The default value is an empty string ("").

Message Queuing

Field name | Data type | Required | Description
QueueName | String | Yes | Name of the Messaging Queue to which the document is sent.
MessageLabel | String | Yes | Value specified in the message label field on the queue.
Priority | Integer | No | Priority of the message placed in the queue. This must be a value between 0 and 7, where a higher value indicates a higher priority. The default value is 3
AuthLevel | Integer | No | Value indicating whether the message needs to be authenticated using a digital signature. Use a value of 0 to bypass authentication. A value of 1 indicates that authentication will be used. The default value is 0.
Delivery | Integer | No | Value indicating how a message is delivered to a queue. Use a value of 1 to indicate that the message should be backed up until it is delivered to the queue. A value of 0 indicates that the message is only resident in memory. The default value is 0.

Notes

  • When you override messaging port properties in a channel, the overrides apply only to that channel. No errors are generated as a result of overriding previous values.

  • You cannot override the transport address that was set in a messaging port.

  • The default setting for the HTTP transport component is to use the HTTP proxy server. This is the correct setting to transport data to Web sites outside your business's firewall. To transport data to Web sites that are inside your business's firewall (that is, within your intranet), modify the transport dictionary values to override the default setting.

  • For the HTTPS transport component, use only certificates that are specified for client authentication.

  • The default setting for the file transport component is to append files (CopyMode=1). If you choose the file transport type with its default settings in a messaging port and use antivirus software on the server on which BizTalk Server 2002 is installed, and you send multiple files that have exactly the same name to the same file location, at the same time, BizTalk Server 2002 might stop responding and must be restarted. You can eliminate this problem by changing the default setting for the file transport component to overwrite (CopyMode=0). You also can eliminate this problem by creating a unique file for each document instance processed by using %tracking_id% in the Address property of the IBizTalkTransportInfo object.

To access the properties in a custom component dictionary through BizTalk Messaging Manager, you must create ASP pages in the \Program Files\BizTalk Server\MessagingManager\pipeline folder. These ASP pages provide a dialog box for editing the properties of your custom component. This dialog box is displayed from the channel Advanced Configuration page when you click Advanced and then click Properties on the Primary Transport tab. For additional information about the ASP pages, see Working with Serializers. For a sample that uses SetConfigData with custom property pages, see Synchronous Orchestration Component.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SignatureCertificateInfo Property

Contains information about the certificate that signs the output document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property SignatureCertificateInfo As Object

[C++]

HRESULT get_SignatureCertificateInfo(

IDispatch** SignatureCertificateInfoDisp

);

HRESULT putref_SignatureCertificateInfo(

IDispatch* SignatureCertificateInfoDisp

);

Parameters

SignatureCertificateInfoDisp

[out, retval], [in] In C++, contains the certificate information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the BizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SourceEndpoint Property

Contains information about the source.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property SourceEndpoint As Object

[C++]

HRESULT get_SourceEndpoint(

IDispatch** SrcEndpointDisp

);

HRESULT putref_SourceEndpoint(

IDispatch* SrcEndpointDisp

);

Parameters

SrcEndpointDisp

[out, retval], [in] In C++, contains information about the source. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns information about the source.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Alias, Application, and Organization properties and is created and stored in memory in the IBizTalkEndPoint object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


TrackFields Property

Contains the IDictionary object that points to the specification that contains fields to track interchange data on input documents for this BizTalkChannel object.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property TrackFields As Object

[C++]

HRESULT get_TrackFields(

IDispatch** TrackFieldsDisp

);

HRESULT putref_TrackFields(

IDispatch* TrackFieldsDisp

);

Parameters

TrackFieldsDisp

[out, retval], [in] In C++, contains the custom tracking fields. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the custom tracking fields.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The tracking fields specified by this property override the fields set in the TrackFields property on the IBizTalkDocument object.

The fields in the IDictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the IDictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the IDictionary object, and set the value to an ISimpleList object. The ISimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the IDictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Tracking


VerifySignatureCertificateInfo Property

Contains information about the certificate that verifies the signature of the input document.

Member List

IBizTalkChannel

|--Comments

|--ControlNumberValue

|--DecryptionCertificateInfo

|--ExpectReceiptTimeout

|--Expression

|--GetConfigComponent

|--GetConfigData

|--InputDocument

|--IsReceiptChannel

|--LoggingInfo

|--MapContent

|--MapReference

|--OutputDocument

|--Port

|--PortGroup

|--ReceiptChannel

|--RetryCount

|--RetryInterval

|--SetConfigComponent

|--SetConfigData

|--SignatureCertificateInfo

|--SourceEndpoint

|--TrackFields

|--VerifySignatureCertificateInfo

Property Declaration

[Visual Basic]

Property VerifySignatureCertificateInfo As Object

[C++]

HRESULT get_VerifySignatureCertificateInfo(

IDispatch** VerifySignatureCertificateInfoDisp

);

HRESULT putref_VerifySignatureCertificateInfo(

IDispatch* VerifySignatureCertificateInfoDisp

);

Parameters

VerifySignatureCertificateInfoDisp

[out, retval], [in] In C++, contains the certificate information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information contained by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the IBizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkConfig

Creates channels, document specifications, envelopes, organizations, ports, and port groups.

Hierarchy

IDispatch

|--IBizTalkConfig

Declaration

[Visual Basic]

Class BizTalkConfig

[C++]

interface IBizTalkConfig : IDispatch

Members

IBizTalkConfig defines the following properties:

Property | Description
Certificates | Contains an ADO recordset that contains all specified certificates.
Channels | Contains an ADO recordset that contains all IBizTalkChannel objects.
Documents | Contains an ADO recordset that contains all IBizTalkDocument objects.
Envelopes | Contains an ADO recordset that contains all IBizTalkEnvelope objects.
Organizations | Contains an ADO recordset that contains all IBizTalkOrganization objects.
PortGroups | Contains an ADO recordset that contains all IBizTalkPortGroup objects.
Ports | Contains an ADO recordset that contains all IBizTalkPort objects.

IBizTalkConfig defines the following methods:

Method | Description
CreateChannel | Returns a new IBizTalkChannel object.
CreateDocument | Returns a new IBizTalkDocument object.
CreateEnvelope | Returns a new IBizTalkEnvelope object.
CreateOrganization | Returns a new IBizTalkOrganization object.
CreatePort | Returns a new IBizTalkPort object.
CreatePortGroup | Returns a new IBizTalkPortGroup object.

Remarks

Each object created by using one of the methods of this interface inherits the following common methods from IBizTalkBase:

  • DateModified

  • Handle

  • Name

  • Clear

  • Create

  • Load

  • LoadByName

  • Remove

  • Save

When IBizTalkPort and IBizTalkChannel objects are created, BizTalk Server automatically creates some associated subobjects. You can access these subobjects by using properties of the IBizTalkPort and IBizTalkChannel objects.

The relationship between objects, their subobjects, and the properties used to obtain the subobjects is shown in the following table.

Subobject | Associated object | Property to set
BizTalkEndPoint | BizTalkPort | DestinationEndpoint
BizTalkEndPoint | BizTalkChannel | SourceEndpoint
BizTalkLoggingInfo | BizTalkChannel | LoggingInfo
BizTalkTransportInfo | BizTalkPort | PrimaryTransport, SecondaryTransport
BizTalkServiceWindowInfo | BizTalkPort | ServiceWindowInfo
BizTalkCertificateInfo | BizTalkPort | EncryptionCertificateInfo
BizTalkCertificateInfo | BizTalkChannel | SignatureCertificateInfo, VerifySignatureCertificateInfo, or DecryptionCertificateInfo

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Certificates Property

Contains an ADO recordset that contains all specified certificates.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Certificates( _

StoreType As BIZTALK_STORE_TYPE, _

UsageType As BIZTALK_USAGE_TYPE, _

NamePrefix As String _

) As Object

[C++]

HRESULT get_Certificates(

BIZTALK_STORE_TYPE StoreType,

BIZTALK_USAGE_TYPE UsageType,

BSTR NamePrefix,

IDispatch** CertsDisp

);

Parameters

StoreType

[in] Determines the store type. Valid values for this parameter are defined by the BIZTALK_STORE_TYPE enumeration.

UsageType

[in] Determines the usage type. Valid values for this parameter are defined by the BIZTALK_USAGE_TYPE enumeration.

NamePrefix

[in] Contains a prefix used as the selection criteria for certificate names. Any certificate Name starting with this value is returned in the recordset. This value is case sensitive.

CertsDisp

[out, retval] Contains all specified certificates. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all specified certificates.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkCertificateInfo object in the database. The fields in each record contain the following information:

Field content | Item number
Name | 0
Reference | 1
Store | 2
Usage | 3

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Channels Property

Contains an ADO recordset that contains all IBizTalkChannel objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Channels As Object

[C++]

HRESULT get_Channels(

IDispatch** ChannelsDisp

);

Parameters

ChannelsDisp

[out, retval] Contains all IBizTalkChannel objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkChannel objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkChannel object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


CreateChannel Method

Returns a new IBizTalkChannel object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateChannel( ) As Object

[C++]

HRESULT CreateChannel(

IDispatch** ChannelDisp

);

Parameters

ChannelDisp

[out, retval] Contains a new IBizTalkChannel object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkChannel object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateDocument Method

Returns a new IBizTalkDocument object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateDocument( ) As Object

[C++]

HRESULT CreateDocument(

IDispatch** DocumentDisp

);

Parameters

DocumentDisp

[out, retval] Contains a new IBizTalkDocument object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkDocument object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateEnvelope Method

Returns a new IBizTalkEnvelope object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateEnvelope( ) As Object

[C++]

HRESULT CreateEnvelope(

IDispatch** EnvelopeDisp

);

Parameters

EnvelopeDisp

[out, retval] Contains a new IBizTalkEnvelope object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkEnvelope object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateOrganization Method

Returns a new IBizTalkOrganization object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreateOrganization( ) As Object

[C++]

HRESULT CreateOrganization(

IDispatch** OrganizationDisp

);

Parameters

OrganizationDisp

[out, retval] Contains a new IBizTalkOrganization object. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkOrganization object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreatePort Method

Returns a new IBizTalkPort object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreatePort( ) As Object

[C++]

HRESULT CreatePort(

IDispatch** PortDisp

);

Parameters

PortDisp

[out, retval] Contains a new IBizTalkPort object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkPort object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreatePortGroup Method

Returns a new IBizTalkPortGroup object.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Method Declaration

[Visual Basic]

Function CreatePortGroup( ) As Object

[C++]

HRESULT CreatePortGroup(

IDispatch** PortGroupDisp

);

Parameters

PortGroupDisp

[out, retval] Contains a new IBizTalkPortGroup object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a new IBizTalkPortGroup object.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Documents Property

Contains an ADO recordset that contains all IBizTalkDocument objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Documents( ) As Objects

[C++]

HRESULT get_Documents(

IDispatch** DocumentsDisp

);

Parameters

DocumentsDisp

[out, retval] Contains all BizTalkDocument objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all BizTalkDocument objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkDocument object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Envelopes Property

Contains an ADO recordset that contains all IBizTalkEnvelope objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Envelopes( ) As Objects

[C++]

HRESULT get_Envelopes(

IDispatch** EnvelopesDisp

);

Parameters

EnvelopesDisp

[out, retval] Contains all IBizTalkEnvelope objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkEnvelope objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkEnvelope object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2
Format | 3

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Organizations Property

Contains an ADO recordset that contains all IBizTalkOrganization objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Organizations( ) As Objects

[C++]

HRESULT get_Organizations(

IDispatch** OrganizationsDisp

);

Parameters

OrganizationsDisp

[out, retval] Contains all IBizTalkOrganization objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkOrganization objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkOrganization object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2
IsDefault | 3

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


PortGroups Property

Contains an ADO recordset that contains all IBizTalkPortGroup objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property PortGroups( ) As Objects

[C++]

HRESULT get_PortGroups(

IDispatch** PortGroupsDisp

);

Parameters

PortGroupsDisp

[out, retval] Contains all IBizTalkPortGroup objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkPortGroup objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkPortGroup object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


Ports Property

Contains an ADO recordset that contains all IBizTalkPort objects.

Member List

IBizTalkConfig

|--Certificates

|--Channels

|--CreateChannel

|--CreateDocument

|--CreateEnvelope

|--CreateOrganization

|--CreatePort

|--CreatePortGroup

|--Documents

|--Envelopes

|--Organizations

|--PortGroups

|--Ports

Property Declaration

[Visual Basic]

Property Ports( ) As Objects

[C++]

HRESULT get_Ports(

IDispatch** PortsDisp

);

Parameters

PortsDisp

[out, retval] Contains all IBizTalkPort objects. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all IBizTalkPort objects.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about an existing IBizTalkPort object in the database. The fields in each record contain the following information:

Field content | Item number
Handle | 0
Name | 1
DateModified | 2

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Update Messaging Configurations with ADO Objects


IBizTalkDocument

Identifies and describes the document specification of a document.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkDocument

Declaration

[Visual Basic]

Class BizTalkDocument

[C++]

interface IBizTalkDocument : IBizTalkBase

Members

IBizTalkDocument defines the following properties:

Property | Description
Content | Contains the content of the document specification described by the object.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
NameSpace | Contains the string that resolves naming conflicts between elements in a document.
PropertySet | Contains an IDictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input.
Reference | Contains the full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by this IBizTalkDocument object.
TrackFields | Contains an IDictionary object that stores the custom fields that Tracking uses to track all documents processed by the server, based on this document instance.
Type | Contains the type of document specification.
Version | Contains the version of the document standard.

IBizTalkDocument defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
LoadByPropertySet | Loads the document object by its PropertySet object.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Remarks

Each IBizTalkDocument object must have at least one associated IBizTalkChannel object. More than one IBizTalkDocument object can refer to the same document specification.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions


Content Property

Contains the content of the document specification described by the object.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Content As String

[C++]

HRESULT get_Content(

BSTR* Content

);

Parameters

Content

[out, retval] In C++, contains the content. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the content.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with a default value of an empty string ("").

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


LoadByPropertySet Method

Loads the document object by its PropertySet object.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Method Declaration

[Visual Basic]

Property LoadByPropertySet( _

PropSetDictionaryDisp As Object _

)

[C++]

HRESULT LoadByPropertySet(

IDispatch** PropSetDictionaryDisp

);

Parameters

PropSetDictionaryDisp

[in] In C++, contains the PropertySet. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the PropertySet.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


NameSpace Property

Contains the string that resolves naming conflicts between elements in a document.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property NameSpace As String

[C++]

HRESULT get_NameSpace(

BSTR* NameSpace

);

Parameters

NameSpace

[out, retval] In C++, contains the namespace. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the namespace.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with a default value of an empty string ("").

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and NameSpace is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating a document, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


PropertySet Property

Contains an IDictionary object that contains the electronic data interchange (EDI) selection criteria (name/value pairs) by which the server extracts information from the functional group header of the EDI document to identify the object when the document is input.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property PropertySet As Object

[C++]

HRESULT get_PropertySet(

IDispatch** PropSetDisp

);

HRESULT putref_PropertySet(

IDispatch* PropSetDisp

);

Parameters

PropSetDisp

[out, retval], [in] In C++, contains the selection criteria. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the selection criteria.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

This is a required property if the document is an EDI document. The Delimiters property of the associated IBizTalkPort object must also be defined.

The following table shows whether names are required in the IDictionary object for PropertySet.

Selection criteria | X12 | EDIFACT
application_sender_code | Yes | Yes
application_receiver_code | Yes | Yes
functional_identifier | Yes | Yes
standards_version | Yes | No
standards_version_type | No | Yes
standards_version_value | No | Yes

Note

  • The name/value pairs contained in the IDictionary object cannot exceed a total of 450 bytes.

PropertySet can be set only if the Reference property is set.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions


Reference Property

Contains the full Web Distributed Authoring and Versioning (WebDAV) URL for the document specification referred to by this IBizTalkDocument object.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Reference As String

[C++]

HRESULT get_Reference(

BSTR* Reference

);

HRESULT put_Reference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the reference. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the reference.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the document specification and the NameSpace property is changed to the value found in the document specification.

Once you have created or saved an object with Reference set to a document specification, any changes you make to the Content or NameSpace of the referenced document specification are not automatically updated on the referring object. To update the object that refers to the revised document specification, you must save the document specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

If Reference is not set, the PropertySet and TrackFields properties must not be set.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


TrackFields Property

Contains an IDictionary object that stores the custom fields that Tracking uses to track all documents processed by the server, based on this document instance.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property TrackFields As Object

[C++]

HRESULT get_TrackFields(

IDispatch** TrackFieldsDisp

);

HRESULT putref_TrackFields(

IDispatch* TrackFieldsDisp

);

Parameters

TrackFieldsDisp

[out, retval], [in] In C++, contains the custom tracking fields. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the custom tracking fields.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

TrackFields can be set only if the Reference property is set. Tracking fields specified for an output IBizTalkDocument object are ignored.

An IBizTalkDocument object points to the specification that contains fields to track the document. The designated fields are logged to the Tracking database for each instance of a document that is processed. Tracking fields on the IBizTalkDocument object are global. The TrackFields property on the IBizTalkChannel object overrides the values specified by this property.

The fields in the IDictionary object must contain an XPath value that identifies the field to be tracked in a document. By default, the IDictionary object provides eight predefined fields for tracking data in a document. These predefined fields consist of two fields for each of the following data types: integer, real, date, and string. If additional fields are required for tracking, you can use the x_custom_search field in the IDictionary object and set the value to a SimpleList object. The SimpleList object contains a list of XPaths pointing to the additional tracking fields. XPath values can be added to and deleted from this list using the Add and Delete methods.

The following table shows the field names in the IDictionary object for TrackFields:

Field Name | Field type
i_value1 | Integer value
i_value2 | Integer value
r_value1 | Real value
r_value2 | Real value
d_value1 | Date value
d_value2 | Date value
s_value1 | String value
s_value2 | String value
x_custom_search | A list to return one or more additional data items

For more information about XPath expressions, go to the Microsoft Web site (msdn.microsoft.com/library/default.asp) and search for XPath.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Definitions

Document Tracking


Type Property

Contains the version of the document standard.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Type As String

[C++]

HRESULT get_Type(

BSTR* Type

);

Parameters

Type

[out, retval] In C++, contains the document type. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the document type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with a default value of an empty string ("").

All document instances must have the same document type as the associated envelope. For example, if the Format property of the IBizTalkEnvelope object is set to X12, Type must also be X12.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Version Property

Contains the version of the document standard.

Member List

IBizTalkDocument

|--Content

|--LoadByPropertySet

|--NameSpace

|--PropertySet

|--Reference

|--TrackFields

|--Type

|--Version

Property Declaration

[Visual Basic]

Property Version As String

[C++]

HRESULT get_Version(

BSTR* Version

);

Parameters

Version

[out, retval] In C++, contains the version. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the version.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEndPoint

Configures source information for an IBizTalkChannel object and destination information for an IBizTalkPort object.

Hierarchy

IDispatch

|--IBizTalkEndPoint

Declaration

[Visual Basic]

Class BizTalkEndpoint

[C++]

interface IBizTalkEndpoint : IDispatch

Members

IBizTalkEndPoint defines the following properties:

Property | Description
Alias | Contains a handle to the organization identifier type/value pair for the destination IBizTalkOrganization object for the associated IBizTalkPort object.
Application | Contains a handle to the associated application for the destination IBizTalkOrganization object for this IBizTalkPort object.
Openness | Contains an enumeration value that indicates whether the object has an open destination or source, or neither.
Organization | Contains a handle to the destination IBizTalkOrganization object for this IBizTalkPort object.

Remarks

The IBizTalkEndPoint object is automatically created when an IBizTalkPort object or an IBizTalkChannel object is instantiated with the CreatePort or the CreateChannel method of the IBizTalkConfig object.

For destination endpoints, access the IBizTalkEndPoint object by using the DestinationEndpoint property of the IBizTalkPort object. For source endpoints, access the IBizTalkEndPoint object by using the SourceEndpoint property of the IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Alias Property

Contains a handle to the organization identifier type/value pair for the destination IBizTalkOrganization object for the associated IBizTalkPort object.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Alias As Long

[C++]

HRESULT get_Alias(

long* AliasHandle

);

HRESULT put_Alias(

long AliasHandle

);

Parameters

AliasHandle

[out, retval], [in] In C++, contains the handle to the alias. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the alias.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Application Property

Contains a handle to the associated application for the destination IBizTalkOrganization object for this IBizTalkPort object.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Application As Long

[C++]

HRESULT get_Application(

long* AppHandle

);

HRESULT put_Application(

long AppHandle

);

Parameters

AppHandle

[out, retval], [in] In C++, contains the handle to the application. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the application.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Openness Property

Contains an enumeration value that indicates whether the object has an open destination or source, or neither.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Openness As BIZTALK_OPENNESS_TYPE_EX

[C++]

HRESULT get_Openness(

BIZTALK_OPENNESS_TYPE_EX* OpennessType

);

HRESULT put_Openness(

BIZTALK_OPENNESS_TYPE_EX OpennessType

);

Parameters

OpennessType

[out, retval], [in] In C++, contains a value indicating whether the object has an open destination or source, or neither. Valid values for this parameter are defined by the BIZTALK_OPENNESS_TYPE_EX enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_OPENNESS_TYPE_EX enumeration, indicating whether the object has an open destination or source, or neither.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_OPENNESS_TYPE_EX_NOTOPEN.

The IBizTalkPort object is valid only if the associated document or the parameters on the Submit or the SubmitSync method of IInterchange identify the missing information.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_SOURCE for an IBizTalkEndPoint object associated with a channel, the following constraints apply:

  • The SignatureType property must not be set.

  • The IBizTalkPort object cannot be included in a port group.

If Openness is set to BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW on a channel, the associated IBizTalkOrganization object must be the default organization.

If Openness on the object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION for an IBizTalkEndPoint object associated with a messaging port, the following constraints apply:

  • The PrimaryTransportType property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • The EncryptionType property must not be set.

  • The document or the parameters on Submit or SubmitSync must specify the destination, transport type, and address.

  • The IBizTalkPort object cannot be included in a port group.

Note

  • This property cannot be changed on an existing port.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Openness


Organization Property

Contains a handle to the destination IBizTalkOrganization object for this IBizTalkPort object.

Member List

IBizTalkEndPoint

|--Alias

|--Application

|--Openness

|--Organization

Property Declaration

[Visual Basic]

Property Organization As Long

[C++]

HRESULT get_Organization(

long* OrganizationHandle

);

HRESULT put_Organization(

long OrganizationHandle

);

Parameters

OrganizationHandle

[out, retval], [in] In C++, contains the handle to the organization. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the organization.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for this object to be complete unless the Openness property is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkEnvelope

Configures the envelope format used with documents processed by BizTalk Server. An envelope is the header information for an interchange.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkEnvelope

Declaration

[Visual Basic]

Class BizTalkEnvelope

[C++]

interface IBizTalkEnvelope : IBizTalkBase

Members

IBizTalkEnvelope defines the following properties:

Property | Description
Content | Contains the contents of the selected envelope format specification.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Format | Contains a string that identifies the type of envelope.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
NameSpace | Contains a string that resolves naming conflicts between elements in an envelope specification.
Reference | Contains a full Web Distributed Authoring and Versioning (WebDAV) URL name of the envelope format specification file.
Version | Contains the version of the envelope format specification.

IBizTalkEnvelope defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Remarks

All document instances in an electronic data interchange (EDI) functional group must have the same format. All document instances must have the same document type as the associated envelope. For example, if Format is set to X12, the Type property of the IBizTalkDocument objects for the associated IBizTalkPort object must also be X12.

If you use an envelope with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier. To do this, use the CreateAlias method on the IBizTalkOrganization object. When an empty qualifier is encountered on an input EDIFACT envelope, the server converts the empty qualifier to a dash. For an output EDIFACT envelope, the server converts the dash to an empty qualifier.

The IBizTalkEnvelope object is required for input documents if the Type property of the IBizTalkDocument object is set to "flatfile" or "custom xml".

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Envelopes


Content Property

Contains the contents of the selected envelope format specification.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Content As String

[C++]

HRESULT get_Content(

BSTR* Content

);

Parameters

Content

[out, retval] In C++, contains the content. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the content.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, Content is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Format Property

Contains a string that identifies the type of envelope.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Format As String

[C++]

HRESULT get_Format(

BSTR* Format

);

HRESULT put_Format(

BSTR Format

);

Parameters

Format

[out, retval], [in] In C++, contains the envelope format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the envelope format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The format value must be one of the following strings:

  • x12

  • edifact

  • custom xml (default)

  • custom

  • flatfile

  • reliable

Note

  • Any string other than the ones listed here will cause an error at run time.

If this property is set to "custom", the Reference property is required. Also, a custom parser component has to be registered with the server for input documents with this property set to "custom". For more information about custom parser components, see Parsers.

All document instances must have the same document type as the associated envelope. For example, if Format is set to "x12", the Type property of the IBizTalkDocument objects must also be "x12".

If Format is set to X12, edifact, or reliable, the Reference property should not be set.

For more information about envelope formats, see Create envelopes.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Envelopes


NameSpace Property

Contains a string that resolves naming conflicts between elements in an envelope specification.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property NameSpace As String

[C++]

HRESULT get_NameSpace(

BSTR* NameSpace

);

Parameters

NameSpace

[out, retval] In C++, contains the namespace. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the namespace.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value. The Reference property is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and NameSpace is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Note

  • When creating an envelope, the number of characters in the NameSpace combined with the number of characters in the specification name cannot exceed 255.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Reference Property

Contains a full Web Distributed Authoring and Versioning (WebDAV) URL name of the envelope format specification file.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Reference As String

[C++]

HRESULT get_Reference(

BSTR* Reference

);

HRESULT put_Reference(

BSTR Reference

);

Parameters

Reference

[out, retval], [in] In C++, contains the reference. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the reference.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property if the Format property is set to "custom". Reference is checked when the Create or the Save method is called. If this string is not empty when Create is called, the Content property is set to the contents of the envelope specification, and the NameSpace property is changed to the value found in the envelope specification.

Once you have created or saved an object with Reference set to an envelope specification, any changes you make to the Content or NameSpace of the referenced envelope specification are not automatically updated on the referring object. To update the object that refers to the revised envelope specification, you must save the envelope specification, reset the Reference property of the object to its current value, and then call Save on the referring object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Version Property

Contains the version of the envelope format specification.

Member List

IBizTalkEnvelope

|--Content

|--Format

|--NameSpace

|--Reference

|--Version

Property Declaration

[Visual Basic]

Property Version As String

[C++]

HRESULT get_Version(

BSTR* Version

);

Parameters

Version

[out, retval] In C++, contains the version. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the version.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkLoggingInfo

Configures the document-logging information for an associated IBizTalkChannel object.

Hierarchy

IDispatch

|--IBizTalkLoggingInfo

Declaration

[Visual Basic]

Class BizTalkLoggingInfo

[C++]

interface IBizTalkLoggingInfo : IDispatch

Members

IBizTalkLoggingInfo defines the following properties:

Property | Description
LogNativeInputDocument | Contains a value that indicates whether the input document instance is saved and logged in its native format.
LogNativeOutputDocument | Contains a value that indicates whether the output document instance is saved and logged in its native format.
LogXMLInputDocument | Contains a value that indicates whether the XML input document is saved and logged.
LogXMLOutputDocument | Contains a value that indicates whether the XML output document is saved and logged.

Remarks

The IBizTalkLoggingInfo object is automatically created when an IBizTalkChannel object is instantiated with the CreateChannel method of the IBizTalkConfig object. You can access the IBizTalkLoggingInfo object by using the LoggingInfo property of the IBizTalkChannel object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogNativeInputDocument Property

Contains a value that indicates whether the input document instance is saved and logged in its native format.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogNativeInputDocument As Boolean

[C++]

HRESULT get_LogNativeInputDocument(

VARIANT_BOOL* LogNativeInDoc

);

HRESULT put_LogNativeInputDocument(

VARIANT_BOOL LogNativeInDoc

);

Parameters

LogNativeInDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the input documents will be saved and logged in their native format. VARIANT_TRUE indicates that the input documents will be saved and logged in their native formats; VARIANT_FALSE indicates that the input documents will not be saved and logged in their native formats. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the input documents will be saved and logged in their native format. True indicates that the input documents will be saved and logged in their native formats; False indicates that the input documents will not be saved and logged in their native formats.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogNativeOutputDocument Property

Contains a value that indicates whether the output document instance is saved and logged in its native format.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogNativeOutputDocument As Boolean

[C++]

HRESULT get_LogNativeOutputDocument(

VARIANT_BOOL* LogNativeOutDoc

);

HRESULT put_LogNativeOutputDocument(

VARIANT_BOOL LogNativeOutDoc

);

Parameters

LogNativeOutDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the output documents will be saved and logged in their native format. VARIANT_TRUE indicates that the output documents will be saved and logged in their native formats; VARIANT_FALSE indicates that the output documents will not be saved and logged in their native formats. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the output documents will be saved and logged in their native format. True indicates that the output documents will be saved and logged in their native formats; False indicates that the output documents will not be saved and logged in their native formats.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogXMLInputDocument Property

Contains a value that indicates whether the XML input document is saved and logged.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogXMLInputDocument As Boolean

[C++]

HRESULT get_LogXMLInputDocument(

VARIANT_BOOL* LogXMLInDoc

);

HRESULT put_LogXMLInputDocument(

VARIANT_BOOL LogXMLInDoc

);

Parameters

LogXMLInDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the input documents will be saved and logged in XML format. VARIANT_TRUE indicates that the input documents will be saved and logged in XML format; VARIANT_FALSE indicates that the input documents will not be saved and logged in XML format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the input documents will be saved and logged in XML format. VARIANT_TRUE indicates that the input documents will be saved and logged in XML format; VARIANT_FALSE indicates that the input documents will not be saved and logged in XML format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


LogXMLOutputDocument Property

Contains a value that indicates whether the XML output document is saved and logged.

Member List

IBizTalkLoggingInfo

|--LogNativeInputDocument

|--LogNativeOutputDocument

|--LogXMLInputDocument

|--LogXMLOutputDocument

Property Declaration

[Visual Basic]

Property LogXMLOutputDocument As Boolean

[C++]

HRESULT get_LogXMLOutputDocument(

VARIANT_BOOL* LogXMLOutDoc

);

HRESULT put_LogXMLOutputDocument(

VARIANT_BOOL LogXMLOutDoc

);

Parameters

LogXMLOutDoc

[out, retval], [in] In C++, contains a value that indicates whether or not the output documents will be saved and logged in XML format. VARIANT_TRUE indicates that the output documents will be saved and logged in XML format; VARIANT_FALSE indicates that the output documents will not be saved and logged in XML format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the output documents will be saved and logged in XML format. VARIANT_TRUE indicates that the output documents will be saved and logged in XML format; VARIANT_FALSE indicates that the output documents will not be saved and logged in XML format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Storage


IBizTalkOrganization

Configures an organization, its organization identifiers (aliases), and the applications within the organization that send and/or receive documents. The application indicates the ultimate source or destination of the document.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkOrganization

Declaration

[Visual Basic]

Class BizTalkOrganization

[C++]

interface IBizTalkOrganization : IBizTalkBase

Members

IBizTalkOrganization defines the following properties:

Property | Description
Aliases | Contains an ADO recordset of aliases that refer to the object.
Applications | Contains an ADO recordset of applications that refer to the object.
Comments | Contains user comments for the object.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
IsDefault | Contains a value that indicates whether the object is the default organization.
Name | Contains the name of the object.

IBizTalkOrganization defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
CreateAlias | Creates an alias for the object.
CreateApplication | Creates a new application.
GetDefaultAlias | Retrieves the default alias for the object.
Load | Loads a specified object in memory.
LoadAlias | Loads an existing alias for the object in memory.
LoadApplication | Loads an application in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
RemoveAlias | Removes an alias.
RemoveApplication | Removes an application.
Save | Saves the object in the database.
SaveAlias | Saves the alias.
SaveApplication | Saves the application.

Remarks

An IBizTalkOrganization object can have more than one application, but each application name must be unique for that object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


Aliases Property

Contains an ADO recordset of aliases that refer to the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property Aliases As Object

[C++]

HRESULT get_Aliases(

IDispatch** AliasesDisp

);

Parameters

AliasesDisp

[out, retval] Contains all aliases that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all aliases that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

The alias for an object is the organization qualifier/value pair. BizTalk Messaging Manager refers to aliases as identifiers.

Each record in the ADO recordset returned by this property contains information about the aliases of an existing IBizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the alias.

  • Name specified in the CreateAlias method.

  • Boolean specified in the CreateAlias method.

  • Qualifier specified in the CreateAlias method.

  • Value specified in the CreateAlias method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


Applications Property

Contains an ADO recordset of applications that refer to the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property Applications As Object

[C++]

HRESULT get_Applications(

IDispatch** ApplicationsDisp

);

Parameters

ApplicationsDisp

[out, retval] Contains all applications that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns all applications that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about the applications of an existing IBizTalkOrganization object in the database. The fields in each record contain the following information, listed in order:

  • Handle assigned to the application.

  • Name specified in the CreateApplication method.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Comments Property

Contains user comments for the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property Comments As String

[C++]

HRESULT get_Comments(

BSTR* Comments

);

HRESULT put_Comments(

BSTR Comments

);

Parameters

Comments

[out, retval], [in] In C++, contains the comments. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the comments.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


CreateAlias Method

Creates an alias for the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub CreateAlias( _

Name As String, _

Default As Boolean, _

Qualifier As String, _

Value As String _

)

[C++]

HRESULT CreateAlias(

BSTR Name,

VARIANT_BOOL Default,

BSTR Qualifier,

BSTR Value

);

Parameters

Name

[in] Contains the name of the alias.

Default

[in] In Visual Basic, contains a value that indicates whether or not this default alias overrides the previous default alias. True indicates that this default alias overrides the previous default alias; False indicates that this default alias should not override the previous default alias. If no alias is specified as the default, one is assigned when the Create method is called.

[in] In C++, contains a value that indicates whether or not this default alias overrides the previous default alias. VARIANT_TRUE indicates that this default alias overrides the previous default alias; VARIANT_FALSE indicates that this default alias should not override the previous default alias. If no alias is specified as the default, one is assigned when the Create method is called.

Qualifier

[in] Contains the qualifier. This parameter cannot be set to "group".

Value

[in] Contains the value.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The alias for an object is the organization identifier that contains a name and a qualifier/value pair.

More than one alias can be created for an IBizTalkOrganization object. The organization alias must contain a name that is unique for the specified IBizTalkOrganization object, and a qualifier/value pair that is unique across all IBizTalkOrganization objects. One of these aliases must be specified as the default alias for the object.

The server automatically creates an alias named Organization with a default identifier of OrganizationName and the value set to the organization's name for new organizations. If the organization name is changed, the value is automatically updated with the new name. This alias cannot be removed.

Note

  • When using envelopes with an EDIFACT format and you want to use a null value for the empty qualifier in the header for the source or the destination, create a custom identifier with a single dash (-) as the qualifier.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


CreateApplication Method

Creates a new application.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub CreateApplication( _

Name As String _

)

[C++]

HRESULT CreateApplication(

BSTR Name

);

Parameters

Name

[in] Contains the name of the application.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If an IBizTalkOrganization object is associated with more than one application, each application name must be unique.

Notes

  • BizTalk Messaging Manager refers to the default organization as the home organization.

  • BizTalk Messaging Manager allows applications to be created for the home organization only. The BizTalk Messaging Configuration object model does not enforce this restriction. Therefore, if you create an application for an organization other than the default (home) organization, you cannot modify it using BizTalk Messaging Manager.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


GetDefaultAlias Method

Retrieves the default alias for the object.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Function GetDefaultAlias( ) As Long

[C++]

HRESULT GetDefaultAlias(

long* AliasHandle

);

Parameters

AliasHandle

[out, retval] Contains the handle. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the handle.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The default alias for an object is the default organization identifier type/value pair.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


IsDefault Property

Contains a value that indicates whether the object is the default organization.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Property Declaration

[Visual Basic]

Property IsDefault( ) As Boolean

[C++]

HRESULT get_IsDefault(

VARIANT_BOOL* IsDefault

);

Parameters

IsDefault

In C++, contains a value that indicates whether or not this organization is the default organization. VARIANT_TRUE indicates that this organization is the default organization; VARIANT_FALSE indicates that this organization is not the default organization. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not this organization is the default organization. True indicates that this organization is the default organization; False indicates that this organization is not the default organization.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property. There must be one and only one default organization at any time.

Note

  • BizTalk Messaging Manager refers to the default organization as the home organization.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


LoadAlias Method

Loads an existing alias for the object in memory.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub LoadAlias( _

AliasHandle As Long, _

Name As Variant, _

Default As Variant, _

Qualifier As Variant, _

Value As Variant _

)

[C++]

HRESULT LoadAlias(

long AliasHandle,

VARIANT* Name,

VARIANT* Default,

VARIANT* Qualifier,

VARIANT* Value

);

Parameters

AliasHandle

[in] Contains the handle to the alias.

Name

[in, out] Contains the name of the organization identifier.

Default

[in, out] Contains the default flag.

Qualifier

[in, out] Contains the qualifier of the organization identifier.

Value

[in, out] Contains the value of the organization identifier.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The alias for an object is the organization qualifier/value pair.

The values used with the parameters of this method can be obtained from the Aliases property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


LoadApplication Method

Loads an application in memory.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub LoadApplication( _

ApplicationHandle As Long, _

Name As Variant _

)

[C++]

HRESULT LoadApplication(

long ApplicationHandle,

VARIANT* Name

);

Parameters

ApplicationHandle

[in] Contains the application handle.

Name

[in, out] Contains the name of the application.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The values used with the parameters of this method can be obtained from the Applications property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RemoveAlias Method

Removes an alias.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub RemoveAlias( _

AliasHandle As Long _

)

[C++]

HRESULT RemoveAlias(

long AliasHandle

);

Parameters

AliasHandle

[in] Contains the handle to the alias.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This record cannot be removed if any of the following conditions apply:

  • An IBizTalkPort or an IBizTalkChannel object refers to it.

  • It has been designated the default organization identifier.

  • This alias was autogenerated.

The alias handle can be obtained from the Aliases property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


RemoveApplication Method

Removes an application.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub RemoveApplication( _

ApplicationHandle As Long _

)

[C++]

HRESULT RemoveApplication(

long ApplicationHandle

);

Parameters

ApplicationHandle

[in] Contains the handle.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This record cannot be removed if an IBizTalkPort or an IBizTalkChannel object refers to it.

The application handle can be obtained from the Applications property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SaveAlias Method

Saves the alias.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub SaveAlias( _

AliasHandle As Long, _

Name As String, _

Default As Boolean, _

Qualifier As String, _

Value As String _

)

[C++]

HRESULT SaveAlias(

long AliasHandle,

BSTR Name,

VARIANT_BOOL Default,

BSTR Qualifier,

BSTR Value

);

Parameters

AliasHandle

[in] Contains the handle to the alias.

Name

[in] Contains the name of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

Default

[in] In Visual Basic, contains a value that indicates whether or not this is the default alias for the organization. True indicates that this is the default alias for the organization; False indicates that this is not the default alias for the organization.

[in] In C++, contains a value that indicates whether or not this is the default alias for the organization. VARIANT_TRUE indicates that this is the default alias for the organization; VARIANT_FALSE indicates that this is not the default alias for the organization.

Qualifier

[in] Contains the qualifier of the organization identifier. This parameter cannot be changed if this alias was autogenerated. This parameter cannot be set to "group".

Value

[in] Contains the value of the organization identifier. This parameter cannot be changed if this alias was autogenerated.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The alias for an object is the organization identifier type/value pair.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Organizations


SaveApplication Method

Saves the application.

Member List

IBizTalkOrganization

|--Aliases

|--Applications

|--Comments

|--CreateAlias

|--CreateApplication

|--GetDefaultAlias

|--IsDefault

|--LoadAlias

|--LoadApplication

|--RemoveAlias

|--RemoveApplication

|--SaveAlias

|--SaveApplication

Method Declaration

[Visual Basic]

Sub SaveApplication( _

ApplicationHandle As Long, _

Name As String _

)

[C++]

HRESULT SaveApplication(

long ApplicationHandle,

BSTR Name

);

Parameters

ApplicationHandle

[in] Contains the handle to the application.

Name

[in] Contains the name of the application.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPort

Configures a one-way transfer of a document between organizations and applications. It identifies the source organization and/or application, the destination organization and/or application, the primary transport type, and, if selected, the associated envelope for transmission.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkPort

Declaration

[Visual Basic]

Class BizTalkPort

[C++]

interface IBizTalkPort : IBizTalkBase

Members

IBizTalkPort defines the following properties:

Property | Description
Channels | Contains an ADO recordset that includes information about all IBizTalkChannel objects that refer to the object.
Comments | Contains the user comments for the IBizTalkPort object.
ControlNumberValue | Contains the value of the interchange control number.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Delimiters | Contains an IDictionary object that includes all delimiters used in the document specification.
DestinationEndpoint | Contains information about the destination.
EncodingType | Contains an enumeration value that indicates the type of document encoding.
EncryptionCertificateInfo | Contains information about the certificate that encrypts the document.
EncryptionType | Contains an enumeration value that indicates the type of document encryption.
Envelope | Contains a handle to the IBizTalkEnvelope object associated with this IBizTalkPort object.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
PrimaryTransport | Contains the primary transport component information.
SecondaryTransport | Contains the secondary transport component information.
ServiceWindowInfo | Contains the service window information.
SignatureType | Contains an enumeration value that indicates the type of digital signing and verification.

IBizTalkPort defines the following methods:

Method | Description
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
Save | Saves the object in the database.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Document Processing

Messaging Ports


Channels Property

Contains an ADO recordset that includes information about all IBizTalkChannel objects that refer to the object.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Channels( ) As Object

[C++]

HRESULT get_Channels(

IDispatch** ChannelsDisp

);

Parameters

ChannelsDisp

[out, retval] Contains the IBizTalkChannel objects that refer to the object.

Return Values

In Visual Basic, this property returns the IBizTalkChannel objects that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property with no default value.

Each record in the ADO recordset returned by this property contains information about the IBizTalkChannel objects in the database that are associated with this IBizTalkPort object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

  • A unique channel identifier, in GUID format.

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Comments Property

Contains the user comments for the IBizTalkPort object.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Comments As String

[C++]

HRESULT get_Comments(

BSTR* Comments

);

HRESULT put_Comments(

BSTR Comments

);

Parameters

Comments

[out, retval], [in] In C++, contains the comments. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the comments.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ControlNumberValue Property

Contains the value of the interchange control number.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property ControlNumberValue As String

[C++]

HRESULT get_ControlNumberValue(

BSTR* ControlNumberValue

);

HRESULT put_ControlNumberValue(

BSTR ControlNumberValue

);

Parameters

ControlNumberValue

[out, retval], [in] In C++, contains the interchange control number. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property the interchange control number.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The ControlNumberValue property must contain a value between 1 and 999999999. This property has no default value.

This is a required property if the Format property of the associated IBizTalkEnvelope object is set to "x12", "edifact", or "custom". This constraint is not enforced for this release, but the server fails if it is not adhered to.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Delimiters Property

Contains an IDictionary object that includes all delimiters used in the document specification.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Delimiters As Object

[C++]

HRESULT get_Delimiters(

IDispatch** DelimitersDisp

);

HRESULT putref_Delimiters(

IDispatch* DelimitersDisp

);

Parameters

DelimitersDisp

[out, retval], [in] In C++, contains the delimiters. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the delimiters.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for the object to be complete if the Format property of the associated IBizTalkEnvelope object is set to "x12", "edifact", or "custom". Delimiters specifies which characters to use to separate data within the envelope and the documents that are sent using this envelope.

The PropertySet property of the associated IBizTalkDocument object must also be defined. The following table shows which names are required for the delimiters of the IDictionary object for various formats:

Delimiter | X12 | EDIFACT
Record_delim | Yes | Yes
Field_delim | Yes | Yes
Subfield_delim | Yes | Yes
Escape_char | No | Yes

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


DestinationEndpoint Property

Contains information about the destination.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property DestinationEndpoint As Object

[C++]

HRESULT get_DestinationEndpoint(

IDispatch** DestEndpointDisp

);

HRESULT putref_DestinationEndpoint(

IDispatch* DestEndpointDisp

);

Parameters

DestEndpointDisp

[out, retval], [in] In C++, contains information about the destination. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns information about the destination.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information provided by this property includes the Alias, Application, and Organization properties and is created and stored in memory in the IBizTalkEndPoint object.

Once an IBizTalkPort object has been created, the destination IBizTalkOrganization object cannot be changed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


EncodingType Property

Contains an enumeration value that indicates the type of document encoding.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property EncodingType As BIZTALK_ENCODING_TYPE

[C++]

HRESULT get_EncodingType(

BIZTALK_ENCODING_TYPE* EncodingType

);

HRESULT put_EncodingType(

BIZTALK_ENCODING_TYPE EncodingType

);

Parameters

EncodingType

[out, retval], [in] In C++, contains the encoding type. Valid values for this parameter are defined by the BIZTALK_ENCODING_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_ENCODING_TYPE enumeration, indicating the encoding type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_ENCODING_TYPE_NONE. The Clear method sets EncodingType to BIZTALK_ENCODING_TYPE_NONE.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


EncryptionCertificateInfo Property

Contains information about the certificate that encrypts the document.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property EncryptionCertificateInfo As Object

[C++]

HRESULT get_EncryptionCertificateInfo(

IDispatch** EncryptionCertificateInfoDisp

);

HRESULT putref_EncryptionCertificateInfo(

IDispatch* EncryptionCertificateInfoDisp

);

Parameters

EncryptionCertificateInfoDisp

[out, retval], [in] In C++, contains the certificate information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the certificate information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information provided by this property includes the Name, Reference, Store, and Usage properties and is created and stored in memory in the IBizTalkCertificateInfo object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


EncryptionType Property

Contains an enumeration value that indicates the type of document encryption.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property EncryptionType As BIZTALK_ENCRYPTION_TYPE

[C++]

HRESULT get_EncryptionType(

BIZTALK_ENCRYPTION_TYPE* EncryptionType

);

HRESULT put_EncryptionType(

BIZTALK_ENCRYPTION_TYPE EncryptionType

);

Parameters

EncryptionType

[out, retval], [in] In C++, contains the encryption type. Valid values for this parameter are defined by the BIZTALK_ENCRYPTION_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_ENCRYPTION_TYPE enumeration, indicating the encoding type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_ENCRYPTION_TYPE_NONE. The Clear method sets EncryptionType to BIZTALK_ENCRYPTION_TYPE_NONE.

If the EncryptionType is set to BIZTALK_ENCRYPTION_TYPE_SMIME, then the EncryptionCertificateInfo property must be set.

For open messaging ports, EncryptionType must be set to BIZTALK_ENCRYPTION_TYPE_NONE.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Envelope Property

Contains a handle to the IBizTalkEnvelope object associated with this IBizTalkPort object.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property Envelope As Long

[C++]

HRESULT get_Envelope(

long* EnvelopeHandle

);

HRESULT put_Envelope(

long EnvelopeHandle

);

Parameters

EnvelopeHandle

[out, retval], [in] In C++, contains the handle to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the handle to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Envelopes


PrimaryTransport Property

Contains the primary transport component information.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property PrimaryTransport As Object

[C++]

HRESULT get_PrimaryTransport(

IDispatch** TransportInfoDisp

);

HRESULT putref_PrimaryTransport(

IDispatch* TransportInfoDisp

);

Parameters

TransportInfoDisp

[out, retval], [in] In C++, contains the primary transport component information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the primary transport component information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for the object.

Information provided by this property includes the Address, Parameter, and Type properties of the IBizTalkTransportInfo object.

The following constraints are enforced:

  • If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and PrimaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION. The IBizTalkServiceWindowInfo object cannot be used with open destination ports.

  • Once an IBizTalkPort object has been created, the Openness property of the associated IBizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • When using a Type of BIZTALK_TRANSPORT_TYPE_LOOPBACK, the primary and secondary transport Address property cannot be set, and the IBizTalkServiceWindowInfo object cannot be used.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SecondaryTransport Property

Contains the secondary transport component information.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property SecondaryTransport As Object

[C++]

HRESULT get_SecondaryTransport(

IDispatch** TransportInfoDisp

);

HRESULT putref_SecondaryTransport(

IDispatch* TransportInfoDisp

);

Parameters

TransportInfoDisp

[out, retval], [in] In C++, contains the secondary transport component information. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the secondary transport component information.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. This is a required property for the object to be complete.

Information provided by this property includes the Address, Parameter, and Type properties, and is created and stored in memory in the IBizTalkTransportInfo object.

The following constraints are enforced:

  • If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_EX_DESTINATION, the Address property cannot be set, and SecondaryTransport must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

  • Once an IBizTalkPort object has been created, the Openness property of the associated IBizTalkEndPoint object cannot be changed.

  • The Openness property cannot be set to BIZTALK_OPENNESS_TYPE_EX_SOURCE or BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW.

  • The Type property cannot be set to BIZTALK_TRANSPORT_TYPE_LOOPBACK.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ServiceWindowInfo Property

Contains the service window information.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property ServiceWindowInfo As Object

[C++]

HRESULT get_ServiceWindowInfo(

IDispatch** ServiceWindowInfoDisp

);

HRESULT putref_ServiceWindowInfo(

IDispatch* ServiceWindowInfoDisp

);

Parameters

ServiceWindowInfoDisp

[out, retval], [in] In C++, contains the service window. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the service window.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Information provided by this property includes the FromTime, IsEnabled, and ToTime properties and is created and stored in memory in the IBizTalkServiceWindowInfo object.

If this property is used, the IBizTalkServiceWindowInfo object must specify a valid time range by using the FromTime and ToTime properties.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


SignatureType Property

Contains an enumeration value that indicates the type of digital signing and verification.

Member List

IBizTalkPort

|--Channels

|--Comments

|--ControlNumberValue

|--Delimiters

|--DestinationEndpoint

|--EncodingType

|--EncryptionCertificateInfo

|--EncryptionType

|--Envelope

|--PrimaryTransport

|--SecondaryTransport

|--ServiceWindowInfo

|--SignatureType

Property Declaration

[Visual Basic]

Property SignatureType As BIZTALK_SIGNATURE_TYPE

[C++]

HRESULT get_SignatureType(

BIZTALK_SIGNATURE_TYPE* SignatureType

);

HRESULT put_SignatureType(

BIZTALK_SIGNATURE_TYPE SignatureType

);

Parameters

SignatureType

[out, retval], [in] In C++, contains the signature type. Valid values for this parameter are defined by the BIZTALK_SIGNATURE_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_SIGNATURE_TYPE enumeration, indicating the encoding type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has a default value of BIZTALK_SIGNATURE_TYPE_NONE. The Clear method sets SignatureType to BIZTALK_SIGNATURE_TYPE_NONE.

IBizTalkPort objects associated with open channels cannot have a SignatureType.

If the SignatureType on an IBizTalkPort object is changed from BIZTALK_SIGNATURE_TYPE_NONE to BIZTALK_SIGNATURE_TYPE_SMIME, all channels associated with this IBizTalkPort object must have already been saved with SignatureCertificateInfo. Also, if a IBizTalkChannel contains a SignatureCertificateInfo object and the SignatureType of the IBizTalkPort is set to BIZTALK_SIGNATURE_TYPE_NONE, the signature will be ignored.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkPortGroup

Configures port groups that are used to distribute the same document to many organizations.

Hierarchy

IDispatch

|--IBizTalkBase

|--IBizTalkPortGroup

Declaration

[Visual Basic]

Class BizTalkPortGroup

[C++]

interface IBizTalkPortGroup : IBizTalkBase

Members

IBizTalkPortGroup defines the following properties:

Property | Description
Channels | Contains an ADO recordset that contains information about all IBizTalkChannel objects that refer to this object.
DateModified | Contains the date and time at which the information in the object was created or last modified.
Handle | Contains the handle to the object.
Name | Contains the name of the object.
Ports | Contains an ADO recordset that contains information about all IBizTalkPort objects that refer to this object.

IBizTalkPortGroup defines the following methods:

Method | Description
AddPort | Adds an IBizTalkPort object to this port group. There must be at least one IBizTalkPort object in the port group.
Clear | Clears the object from memory.
Create | Creates a new object in the database.
Load | Loads a specified object in memory.
LoadByName | Loads a specified object by name in memory.
Remove | Removes the object from the database.
RemovePort | Removes an IBizTalkPort object from the port group. There must be at least one IBizTalkPort object in the port group.
Save | Saves the object in the database.

Remarks

There must always be at least one IBizTalkPort object and one IBizTalkChannel object associated with a IBizTalkPortGroupobject. The IBizTalkChannel object is associated with the IBizTalkPortGroup object, not the IBizTalkPort object within the group. Each IBizTalkPort object within the group has another IBizTalkChannel object or objects associated with it, but these are ignored when the port group channel is invoked.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Distribution List

Port Groups

Submitting Documents to a Port Group


AddPort Method

Adds an IBizTalkPort object to this port group. There must be at least one IBizTalkPort object in the port group.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Method Declaration

[Visual Basic]

Sub AddPort( _

PortHandle As Long _

)

[C++]

HRESULT AddPort(

long PortHandle

);

Parameters

PortHandle

[in] Contains the handle to the object.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The following constraints apply to this method:

  • There must be at least one IBizTalkPort in this IBizTalkPortGroup object.

  • The Openness property of the associated BizTalkEndPoint object to be added must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN.

  • The port group specified by this object cannot contain any duplicate IBizTalkPort objects.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Channels Property

Contains an ADO recordset that contains information about all IBizTalkChannel objects that refer to this object.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Property Declaration

[Visual Basic]

Property Channels As Object

[C++]

HRESULT get_Channels(

IDispatch** ChannelsDisp

);

Parameters

ChannelsDisp

[out, retval] Contains an ADO recordset that contains all IBizTalkChannel objects that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns an ADO recordset that contains all IBizTalkChannel objects that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Each record in the ADO recordset returned by this property contains information about the IBizTalkChannel objects in the database that are associated with this IBizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Ports Property

Contains an ADO recordset that contains information about all IBizTalkPort objects that refer to this object.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Property Declaration

[Visual Basic]

Property Ports As Object

[C++]

HRESULT Ports(

IDispatch** PortsDisp

);

Parameters

PortsDisp

[out, retval] Contains an ADO recordset that includes all IBizTalkPort objects that refer to the object. This parameter is not supported in Visual Basic. For more information, see "Return Values.

Return Values

In Visual Basic, this property returns an ADO recordset that includes all IBizTalkPort objects that refer to the object.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. Each record in the ADO recordset returned by this property contains information about the IBizTalkPort objects in the database that are associated with this IBizTalkPortGroup object. The fields in each record contain the following information, listed in order:

  • Handle

  • Name

Additional information about Microsoft ActiveX Data Objects is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


RemovePort Method

Removes an IBizTalkPort object from the port group. There must be at least one IBizTalkPort object in the port group.

Member List

IBizTalkPortGroup

|--AddPort

|--Channels

|--Ports

|--RemovePort

Method Declaration

[Visual Basic]

Sub RemovePort( _

PortHandle As Long _

)

[C++]

HRESULT RemovePort(

long PortHandle

);

Parameters

PortHandle

[in] Contains the handle to the object to remove.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Note

  • In addition to the HRESULT values listed on the error messages page, this method returns OLEDB provider errors. Additional information about OLEDB is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The last IBizTalkPort object associated with the object cannot be removed. An IBizTalkPort object cannot be removed if an IBizTalkChannel object refers to it.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkServiceWindowInfo

Configures the service window for an associated IBizTalkPort object. The service window indicates a valid time range for transmitting documents.

Hierarchy

IDispatch

|--IBizTalkServiceWindowInfo

Declaration

[Visual Basic]

Class BizTalkServiceWindowInfo

[C++]

interface IBizTalkServiceWindowInfo : IDispatch

Members

IBizTalkServiceWindowInfo defines the following properties:

Property | Description
FromTime | Contains the earliest time that the interchange can be transmitted.
IsEnabled | Contains a value that indicates whether the service window is enabled.
ToTime | Contains the latest time that the interchange can be transmitted.

Remarks

The IBizTalkServiceWindowInfo object is automatically created when an IBizTalkPort object is instantiated with the CreatePort method of the IBizTalkConfig object. Access the properties of the IBizTalkServiceWindowInfo object by using the ServiceWindowInfo property of the IBizTalkPort object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


FromTime Property

Contains the earliest time that the interchange can be transmitted.

Member List

IBizTalkServiceWindowInfo

|--FromTime

|--IsEnabled

|--ToTime

Property Declaration

[Visual Basic]

Property FromTime As String

[C++]

HRESULT get_FromTime(

BSTR* FromTime

);

HRESULT put_Comments(

BSTR FromTime

);

Parameters

FromTime

[out, retval], [in] In C++, contains the earliest time that the interchange can be transmitted. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the earliest time that the interchange can be transmitted.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The FromTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified. Service window hours are displayed in the coordinated universal time (UTC) format and reflect the time on the database server.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IsEnabled Property

Contains a value that indicates whether the service window is enabled.

Member List

IBizTalkServiceWindowInfo

|--FromTime

|--IsEnabled

|--ToTime

Property Declaration

[Visual Basic]

Property IsEnabled As Boolean

[C++]

HRESULT get_IsEnabled(

VARIANT_BOOL* IsEnabled

);

HRESULT put_IsEnabled(

_BOOL IsEnabled

);

Parameters

IsEnabled

[out, retval], [in] In C++, contains a value that indicates whether or not a service window is enabled. VARIANT_TRUE indicates that the service window is enabled; VARIANT_FALSE indicates that the service window is not enabled. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not a service window is enabled. True indicates that the service window is enabled; False indicates that the service window is not enabled.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

In C++, this property has a default value of VARIANT_FALSE. In Visual Basic, this property has a default value of False.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


ToTime Property

Contains the latest time that the interchange can be transmitted.

Member List

IBizTalkServiceWindowInfo

|--FromTime

|--IsEnabled

|--ToTime

Property Declaration

[Visual Basic]

Property ToTime As String

[C++]

HRESULT get_ToTime(

BSTR* ToTime

);

HRESULT put_ToTime(

BSTR ToTime

);

Parameters

ToTime

[out, retval], [in] In C++, contains the latest time that the interchange can be transmitted. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the latest time that the interchange can be transmitted.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The ToTime property must contain an integer value between 0 and 23. Fractional values and minutes cannot be specified. Service window hours are displayed in the coordinated universal time (UTC) format and reflect the time on the database server.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IBizTalkTransportInfo

Configures the transport service for an associated IBizTalkPort object.

Hierarchy

IDispatch

|--IBizTalkTransportInfo

Declaration

[Visual Basic]

Class BizTalkTransportInfo

[C++]

interface IBizTalkTransportInfo : IDispatch

Members

IBizTalkTransportInfo defines the following properties:

Property | Description
Address | Contains the destination address of the primary transport component.
Parameter | Contains the required return e-mail address for the associated source IBizTalkOrganization object if the Type property is BIZTALK_TRANSPORT_ TYPE_SMTP.
Type | Contains an enumeration value that indicates the type of transport component to be used for the primary transport.

Remarks

The IBizTalkTransportInfo object is automatically created when an IBizTalkPort object is instantiated with the CreatePort method of the IBizTalkConfig object.

Access the IBizTalkTransportInfo object by using the PrimaryTransport or SecondaryTransport property of the IBizTalkPort object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Address Property

Contains the destination address of the primary transport component.

Member List

IBizTalkTransportInfo

|--Address

|--Parameter

|--Type

Property Declaration

[Visual Basic]

Property Address As String

[C++]

HRESULT get_Address(

BSTR* TransportAddress

);

HRESULT put_Address(

BSTR TransportAddress

);

Parameters

TransportAddress

[out, retval], [in] In C++, contains the address. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the address.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, Address cannot be set, and the Type property must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

Address must have one of the following prefixes, according to the Type property:

Transport type | Prefix | Example Address value
APPINTEGRATION | Not applicable | {11111111-1111-1111-1111-111111111111}
FILE | file:// | file://C:\Test\MyFile.xml
HTTP | http:// | http://www.adatum.com/repository/bts.asp
HTTPS | https:// | https://www.adatum.com/secure/btss.asp
LOOPBACK | Not applicable | Not applicable
MSMQ | Not applicable | DIRECT=OS:.\private$\myqueue
NONE | Not applicable | Not applicable
OPENDESTINATION | Not applicable | Not applicable
ORCHESTRATIONACTIVATION | Not applicable | C:\XLANG\Schedules\mysched.skx
SMTP | mailto: | mailto:patricia@adatum.com

Notes

  • The queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. For open messaging ports, the address is specified either in the document instance or as a parameter when submitting the document. For more information, see Routing.

  • When using the Orchestration Activation Component transport type, the Address property must contain the full path of the XLANG schedule on the local computer. The file:// prefix cannot be used when specifying the path of the XLANG schedule (.skx) file.

  • When using the HTTP or HTTPS transport types, BizTalk Server sends the data using a proxy server by default. This is the correct setting to transport data to computers outside of your company's firewall. However, when sending data within your company's intranet, you can bypass the use of a proxy server. To do this, you must set the UseProxy field to False in the transport dictionary. For more information, see SetConfigData.

When using the file:// transport type, you can include symbols to modify the file name. The file name created by the server contains any static characters you specified in the Address property, along with the actual value of the symbol. For example, if the Address property is set to "file://C:\Orders\Invoice_%tracking_id%.xml", the actual file name would use a format similar to: C:\Orders\Invoice_{12345678-90AB-CDEF-1234-567890ABCDEF}. The following table contains the symbols that can be used with the file:// transport type:

Symbol | Description | Unique file name
%datetime% | Date and time, in milliseconds, of the file creation. The time is based on Greenwich Mean Time (GMT) rather than local time. | No
%src_filename% | Name of the source document processed by BizTalk Server. | No
%src_filepath% | This value is not supported. | Not applicable
%document_name% | Name of the document definition used to process the source file. | No
%server% | Host name of the server that processed the document. | No
%tracking_id% | Globally unique tracking number. | Yes
%uid% | Counter that increases over time, represented in milliseconds. This number is reset when the server is rebooted. | No

When sending reliable messaging receipts that use the SMTP transport protocol, the value specified in the identifier named Reliable Messaging Acknowledgement SMTP From Address is used as the From address. This identifier is automatically created for the default IBizTalkOrganization object. This identifier cannot be removed. You should not modify the name or qualifier for this identifier, but you can modify the value. For more information, see Processing Receipts Using Reliable Messaging.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Parameter Property

Contains the required return e-mail address of the associated source IBizTalkOrganization object if the Type property is set to BIZTALK_TRANSPORT_TYPE_SMTP.

Member List

IBizTalkTransportInfo

|--Address

|--Parameter

|--Type

Property Declaration

[Visual Basic]

Property Parameter As String

[C++]

HRESULT get_Parameter(

BSTR* PrimaryTransportParameter

);

HRESULT put_Parameter(

BSTR PrimaryTransportParameter

);

Parameters

PrimaryTransportParameter

[out, retval], [in] In C++, contains the required return e-mail address. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the required return e-mail address.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

  • This property has a default value of an empty string ("").

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


Type Property

Contains an enumeration value that indicates the type of transport component to be used for the primary transport.

Member List

IBizTalkTransportInfo

|--Address

|--Parameter

|--Type

Property Declaration

[Visual Basic]

Property Type As BIZTALK_TRANSPORT_TYPE

[C++]

HRESULT get_Type(

BIZTALK_TRANSPORT_TYPE* TransportType

);

HRESULT put_Type(

BIZTALK_TRANSPORT_TYPE TransportType

);

Parameters

TransportType

[out, retval], [in] In C++, contains the transport type. Valid values for this parameter are defined by the BIZTALK_TRANSPORT_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_TRANSPORT_TYPE enumeration, indicating the transport type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The following constraints are enforced:

  • If the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the Address property cannot be set, and Type must be set to BIZTALK_TRANSPORT_TYPE_OPENDESTINATION.

When using the Message Queuing transport type (BIZTALK_TRANSPORT_TYPE_MSMQ), the following restrictions apply:

  • When using an envelope, the maximum size of a document submitted to BizTalk Server is 4MB.

  • When an envelope is not used, the maximum size of a document submitted to BizTalk Server is 2MB.

  • When using the BIZTALK_TRANSPORT_TYPE_SMTP, the Parameter property must be set to the reply-to SMTP address.

  • The transport Type of BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION is supported only when the Openness property of the associated IBizTalkEndPoint object is set to BIZTALK_OPENNESS_TYPE_TOWORKFLOW.

  • When using the Orchestration activation component type (BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION), the maximum size of a document sent to the port on the XLANG schedule is 2MB.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)


IDictionary

Supports the creation, storage, and retrieval of name/value pairs in memory. This collection object is used by several methods in the BizTalk Messaging Configuration object model.

Hierarchy

IDispatch

|--IDictionary

Declaration

[Visual Basic]

Class CDictionary

[C++]

interface IDictionary : IDispatch

Members

IDictionary defines the following properties:

Property | Description
Count | Contains the number of entries in the IDictionary object.
Prefix | Contains the prefix that is used to exclude all entries with that prefix when the contents of the IDictionary object are saved.
Value | Contains the value associated with an entry name.

IDictionary defines the following methods:

Method | Description
GetMultiple | Returns the values of multiple entries from the IDictionary object.
PutMultiple | Adds specified entries to the IDictionary object or changes them.

Remarks

An IDictionary object is designed to be a general-purpose collection. Therefore, it can be used for anything that is supported by its internal structure. Every value in an IDictionary object is a Variant. This means that an IDictionary object can be created that consists of almost any kind of value (including other IDictionary objects).

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Count Property

Contains the number of entries in the IDictionary object.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] In C++, contains the count. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the count.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property is read-only with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


GetMultiple Method

Returns the values of multiple entries from the IDictionary object.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Method Declaration

[Visual Basic]

Sub GetMultiple( _

NumberOfEntries As Long, _

Entries As String, _

Values As Variant _

)

[C++]

HRESULT GetMultiple(

long NumberOfEntries,

const LPOLESTR Entries[],

VARIANT Values[]

);

Parameters

NumberOfEntries

[in] Specifies the number of values to retrieve.

Entries

[in, size_is(cb)] Array of string values that identifies the Dictionary object entries for which the values should be retrieved.

Values

[out, size_is(cb)] Array of VARIANTs. When GetMultiple returns, this array contains the values associated with the Dictionary object entries identified by the Entries[] array.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Prefix Property

Contains the prefix that is used to exclude all entries with that prefix when the contents of the IDictionary object are saved.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Property Declaration

[Visual Basic]

Property Prefix As String

[C++]

HRESULT get_Prefix(

BSTR* Prefix

);

HRESULT put_Prefix(

BSTR Prefix

);

Parameters

Prefix

[out, retval], [in] In C++, contains the prefix. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the prefix.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Any name/value pair with a name beginning with the specified prefix is not saved to the database. The prefix default is an underscore (_). Therefore, any keywords that begin with an underscore are not saved unless the prefix is changed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


PutMultiple Method

Adds specified entries to the IDictionary object or changes them.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Method Declaration

[Visual Basic]

Sub PutMultiple( _

NumberOfEntries As Long, _

Entries As String, _

Values As Variant _

)

[C++]

HRESULT PutMultiple(

long NumberOfEntries,

const LPOLESTR Entries[],

const VARIANT Values[]

);

Parameters

NumberOfEntries

[in] Identifies the number of elements in the rgolestr and rgvar arrays.

Entries

[in, size_is(cb)] Array of strings that contains the names to add to the IDictionary object.

Values

[in, size_is(cb)] Array of VARIANTs that contains the values to add to the IDictionary object.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

A one-to-one mapping exists between the elements of the Entries[] and Values[] arrays. This means that Entries[n] is added to the IDictionary object and is initialized to Values[n]. If the element specified by Entries[n] is already in the IDictionary object, the value associated with the element is overwritten with the value stored in Values[n].

If you call PutMultiple or GetMultiple from Microsoft Visual Basic Scripting Edition (VBScript), these methods fail because they require data types that VBScript does not support.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Value Property

Contains the value associated with an entry name.

Member List

IDictionary

|--Count

|--GetMultiple

|--Prefix

|--PutMultiple

|--Value

Property Declaration

[Visual Basic]

Property Value( _

Name As String _

)

[C++]

HRESULT get_Value(

BSTR Name,

VARIANT* Value

);

HRESULT put_Value(

BSTR Name,

VARIANT Value

);

Parameters

Name

[in] Contains the name.

Value

[out, retval] [in] In C++, contains the value. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property optionally returns the value.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The value of an IDictionary object can be read or written to without explicitly using the Value property by treating the named entry as a property of the IDictionary object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


ISimpleList

Creates an array of variants that supports enumeration.

Hierarchy

IDispatch

|--ISimpleList

Declaration

[Visual Basic]

Class CSimpleList

[C++]

interface ISimpleList : IDispatch

Members

ISimpleList defines the following properties:

Property | Description
Count | Contains the number of elements in the ISimpleList object.
Item | Contains a container for an element of the ISimpleList object.

ISimpleList defines the following methods:

Method | Description
Add | Adds the specified item to the ISimpleList object.
Delete | Deletes the specified item from the ISimpleList object.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Add Method

Adds the specified item to the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Method Declaration

[Visual Basic]

Sub Add( _

Var As Variant _

)

[C++]

HRESULT Add(

VARIANT* Var

);

Parameters

Var

[in] Contains the object to add to the ISimpleList object.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Count Property

Contains the number of elements in the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] Contains the number of items in the ISimpleList object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of items in the ISimpleList object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property is read-only with no default value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Delete Method

Deletes the specified item from the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Method Declaration

[Visual Basic]

Sub Delete( _

Index As Long _

)

[C++]

HRESULT Delete(

long Index

);

Parameters

Index

[in] Contains the index value of the item to delete.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Item Property

Contains a container for an element of the ISimpleList object.

Member List

ISimpleList

|--Add

|--Count

|--Delete

|--Item

Property Declaration

[Visual Basic]

Property Item( _

Index (ISimpleList, Item) As Long _

) As Variant

[C++]

HRESULT get_Item(

long Index (ISimpleList, Item),

VARIANT* Item (ISimpleList, Item)

);

HRESULT put_Item(

long Index,

VARIANT Item

);

HRESULT putref_Item(

long Index,

VARIANT Item

);

Parameters

Index

[in], [in] In C++, contains the index of the item.

Item

[out, retval], [in] In C++, contains the object used to return the item. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the object used to return the item.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property has no default value. The Item property is a read/write Variant that contains an element of the ISimpleList object. An initialized Variant is stored at a specified array index. If an item is already stored at the specified index, that item is overwritten by the put method.

In C++, When putting a value, use the putref_Item method if you are setting an object reference; use the put_Item method if you are setting a scalar value.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: commerce.h
Library: Microsoft Commerce 2000 Core Components Type Library (MscsCore.dll)


Enumerations

The following enumerations provide possible property and parameter values:

  • BIZTALK_CONFIGDATA_TYPE

  • BIZTALK_ENCODING_TYPE

  • BIZTALK_ENCRYPTION_TYPE

  • BIZTALK_OPENNESS_TYPE

  • BIZTALK_OPENNESS_TYPE_EX

  • BIZTALK_SIGNATURE_TYPE

  • BIZTALK_STORE_TYPE

  • BIZTALK_TRANSPORT_TYPE

  • BIZTALK_USAGE_TYPE


BIZTALK_CONFIGDATA_TYPE

Configures messaging ports.

[Visual Basic]

Enum BIZTALK_CONFIGDATA_TYPE

[C++]

enum BIZTALK_CONFIGDATA_TYPE

Members

BIZTALK_CONFIGDATA_TYPE_PRIMARYTRANSPORT

[0] Configures the primary transport on the messaging port.

BIZTALK_CONFIGDATA_TYPE_SECONDARYTRANSPORT

[1] Configures the secondary transport on the messaging port.

BIZTALK_CONFIGDATA_TYPE_ENCRYPTION

[2] Configures the encryption certificate on the messaging port.

BIZTALK_CONFIGDATA_TYPE_ENCODING

[2] Configures the encoding type on the messaging port.

BIZTALK_CONFIGDATA_TYPE_SIGNATURE

[4] Configures the signature verification on the messaging port.

BIZTALK_CONFIGDATA_TYPE_SERIALIZER

[5] Configures the serializer on the messaging port.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

GetConfigComponent

GetConfigData

SetConfigComponent

SetConfigData

Using Custom Components


BIZTALK_ENCODING_TYPE

Specifies the encoding type.

[Visual Basic]

Enum BIZTALK_ENCODING_TYPE

[C++]

enum BIZTALK_ENCODING_TYPE

Members

BIZTALK_ENCODING_TYPE_NONE

[1] Specifies that encoding is not used.

BIZTALK_ENCODING_TYPE_MIME

[2] Specifies Multipurpose Internet Mail Extensions (MIME) encoding.

BIZTALK_ENCODING_TYPE_CUSTOM

[3] Specifies custom encoding.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

EncodingType


BIZTALK_ENCRYPTION_TYPE

Specifies the encryption type.

[Visual Basic]

Enum BIZTALK_ENCRYPTION_TYPE

[C++]

enum BIZTALK_ENCRYPTION_TYPE

Members

BIZTALK_ENCRYPTION_TYPE_NONE

[1] Specifies that encryption is not used.

BIZTALK_ENCRYPTION_TYPE_CUSTOM

[2] Specifies custom encryption.

BIZTALK_ENCRYPTION_TYPE_SMIME

[4] Specifies Secure Multipurpose Internet Mail Extensions (S/MIME) encryption.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

EncryptionType


BIZTALK_OPENNESS_TYPE

Specifies the openness type.

[Visual Basic]

Enum BIZTALK_OPENNESS_TYPE

[C++]

enum BIZTALK_OPENNESS_TYPE

Members

BIZTALK_OPENNESS_TYPE_NOTOPEN

[1] Specifies that this instance of the object is not open.

BIZTALK_OPENNESS_TYPE_SOURCE

[2] Specifies that the source organization of this instance of the object is open.

BIZTALK_OPENNESS_TYPE_DESTINATION

[4] Specifies that the destination organization of this instance of the object is open.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: (cisapi.tlb)

Related Topics

Openness

Submit

SubmitSync


BIZTALK_OPENNESS_TYPE_EX

Specifies the openness type.

[Visual Basic]

Enum BIZTALK_OPENNESS_TYPE_EX

[C++]

enum BIZTALK_OPENNESS_TYPE_EX

Members

BIZTALK_OPENNESS_TYPE_EX_NOTOPEN

[1] Specifies that this instance of the object is not open.

BIZTALK_OPENNESS_TYPE_EX_SOURCE

[2] Specifies that the source organization of this instance of the object is open.

BIZTALK_OPENNESS_TYPE_EX_DESTINATION

[4] Specifies that the destination organization of this instance of the object is open.

BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW

[8] Specifies that BizTalk Server is receiving a document from an XLANG schedule instance.

BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW

[16] Specifies that BizTalk Server is sending a document to an XLANG schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Openness


BIZTALK_SIGNATURE_TYPE

Specifies the signature type.

[Visual Basic]

Enum BIZTALK_SIGNATURE_TYPE

[C++]

enum BIZTALK_SIGNATURE_TYPE

Members

BIZTALK_SIGNATURE_TYPE_NONE

[1] Specifies that there is no signature.

BIZTALK_SIGNATURE_TYPE_CUSTOM

[2] Specifies the custom signature of the document.

BIZTALK_SIGNATURE_TYPE_SMIME

[4] Specifies the S/MIME signature of the document.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

SignatureType


BIZTALK_STORE_TYPE

Specifies the store type of the certificate.

[Visual Basic]

Enum BIZTALK_STORE_TYPE

[C++]

enum BIZTALK_STORE_TYPE

Members

BIZTALK_STORE_TYPE_MY

[1] Specifies that the certificate store is type MY. This store contains certificates authorized only by your organization.

BIZTALK_STORE_TYPE_BIZTALK

[2] Specifies that the certificate is stored in the dedicated BizTalk Server 2002 store.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Certificates

Store


BIZTALK_TRANSPORT_TYPE

Specifies the transport component type.

[Visual Basic]

Enum BIZTALK_TRANSPORT_TYPE

[C++]

enum BIZTALK_TRANSPORT_TYPE

Members

BIZTALK_TRANSPORT_TYPE_NONE

[1] Specifies that this instance of the object does not select a transport component.

BIZTALK_TRANSPORT_TYPE_HTTP

[4] Specifies that this instance of the object selects a Hypertext Transfer Protocol (HTTP) transport component.

BIZTALK_TRANSPORT_TYPE_SMTP

[8] Specifies that this instance of the object selects a Simple Mail Transfer Protocol (SMTP) transport component.

BIZTALK_TRANSPORT_TYPE_APPINTEGRATION

[32] Specifies that this instance of the object selects an application integration component (AIC) transport component.

BIZTALK_TRANSPORT_TYPE_MSMQ

[128] Specifies that this instance of the object selects a Microsoft Message Queuing transport component.

BIZTALK_TRANSPORT_TYPE_FILE

[256] Specifies that this instance of the object selects a file as a transport component.

BIZTALK_TRANSPORT_TYPE_HTTPS

[1024] Specifies that this instance of the object selects a Secure Hypertext Transfer Protocol (HTTPS) transport component.

BIZTALK_TRANSPORT_TYPE_OPENDESTINATION

[2048] Specifies that the messaging port is an open destination.

BIZTALK_TRANSPORT_TYPE_LOOPBACK

[4096] Specifies that the document submitted to the server with the SubmitSync method will be processed and then returned back as the response document of the method.

BIZTALK_TRANSPORT_TYPE_ORCHESTRATIONACTIVATION

[8192] Specifies that the Address property contains the path of an XLANG schedule to be executed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Type


BIZTALK_USAGE_TYPE

Specifies the usage type of the certificate.

[Visual Basic]

Enum BIZTALK_USAGE_TYPE

[C++]

enum BIZTALK_USAGE_TYPE

Members

BIZTALK_USAGE_TYPE_ENCRYPTION

[1] Specifies that this is an encryption certificate.

BIZTALK_USAGE_TYPE_SIGNATURE

[2] Specifies that this is a signature certificate.

BIZTALK_USAGE_TYPE_BOTH

[4] Specifies that this certificate is used for both encryption and signature.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BizTalkObjectModel.h
Library: Microsoft BizTalk Server Configuration Objects 1.0 Type Library (BizTalkObjectModel.dll)

Related Topics

Certificates

Usage


Documents Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for working with documents:

  • Interfaces

  • Enumerations

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented:

  • IBizTalkTrackData

  • IBTSCustomProcess

  • IBTSCustomProcessContext

  • IInterchange


IBizTalkTrackData Interface

Use this object to facilitate programmatic access to the tracking information of Microsoft BizTalk Server 2002. This object complements the IInterchange object so that returns from IInterchange methods can be passed to these methods for reading tracking data about the documents submitted to BizTalk Server 2002.

Hierarchy

IDispatch

|--IBizTalkTrackData

Declaration

[Visual Basic]

Class BTSDocTracking

[C++]

interface IBizTalkTrackData : IDispatch

Members

IBizTalkTrackData defines the following methods:

Method | Description
GetInDocDetails | Returns an ADO recordset that contains a list of the documents that were submitted to BizTalk Server by using the Submit method.
GetInterchanges | Returns an ADO recordset that contains a list of interchanges that were submitted to BizTalk Server by using the Submit method, including all the data from the Tracking database.
GetOutDocDetails | Returns an ADO recordset that contains a list of the documents that were generated as a result of the Submit method.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema

Document Definitions

Reading the Tracking Database

Document Tracking


GetInDocDetails Method

Returns an ADO recordset that contains a list of the documents that were submitted to BizTalk Server by using the Submit method.

Member List

IBizTalkTrackData

|--GetInDocDetails

|--GetInterchanges

|--GetOutDocDetails

Method Declaration

[Visual Basic]

Function GetInDocDetails( _

SubmissionID As String _

) As Object

[C++]

HRESULT GetInDocDetails(

BSTR SubmissionID ,

IDispatch** Result

);

Parameters

SubmissionID

[in] Contains the SubmissionHandle string returned by Submit for this document instance.

Result

[out, retval] In C++, an IDispatch interface that contains a list of the documents that were included in the submission. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an Object that contains a list of the documents that were included in the submission.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method returns specific information for an input document.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema


GetInterchanges Method

Returns an ADO recordset that contains a list of interchanges that were submitted to BizTalk Server by using the Submit method, including all the data from the Tracking database.

Member List

IBizTalkTrackData

|--GetInDocDetails

|--GetInterchanges

|--GetOutDocDetails

Method Declaration

[Visual Basic]

Function GetInterchanges( _

SubmissionID As String _

) As Object

[C++]

HRESULT GetInterchanges(

BSTR SubmissionID ,

IDispatch** Result

);

Parameters

SubmissionID

[in] Contains the SubmissionHandle string returned by Submit for this interchange.

Result

[out, retval] In C++, an IDispatch interface that contains a list of the interchanges that were included in the submission, including all the data from the Tracking database. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method optionally returns an Object that contains a list of interchanges contained in this submission, including all the data from the Tracking database.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

You can check the Tracking database to confirm or check status on delivery because transport-specific information, such as delivery times and receipt flags, appears in the Tracking database.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema


GetOutDocDetails Method

Returns an ADO recordset that contains a list of the documents that were generated as a result of the Submit method.

Member List

IBizTalkTrackData

|--GetInDocDetails

|--GetInterchanges

|--GetOutDocDetails

Method Declaration

[Visual Basic]

Function GetOutDocDetails( _

SubmissionID As String _

) As Object

[C++]

HRESULT GetOutDocDetails(

BSTR SubmissionID ,

IDispatch** Result

);

Parameters

SubmissionID

[in] Contains the SubmissionHandle string returned by Submit for this document instance.

Result

[out, retval] In C++, an IDispatch interface that contains a list of the documents that were generated as a result of the submission. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an Object that contains a list of the documents that were generated as a result of the submission.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method returns specific information for an output document, for example, PO #123456 from a Submit call made on a specific date.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Understanding the Tracking Database Schema


IBTSCustomProcess

Implement IBTSCustomProcess to create a custom preprocessor for BizTalk Server receive functions.

Hierarchy

IUnknown

|--IBTSCustomProcess

Declaration

[Visual Basic]

Class IBTSCustomProcess

[C++]

interface IBTSCustomProcess : IUnknown

Members

IBTSCustomProcess defines the following methods:

Method | Description
Execute | Performs the custom processing on data obtained from a receive function.
SetContext | Retrieves context information associated with the data being processed.

Remarks

For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Custom preprocessor components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Preprocessor components register themselves with the category ID CATID_BIZTALK_CUSTOM_PROCESS. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


Execute Method

Performs the custom processing on data obtained from a receive function.

Member List

IBTSCustomProcess

|--Execute

|--SetContext

Method Declaration

[Visual Basic]

Sub Execute( _

DataIn As Variant, _

CodePageIn As Long, _

IsFilePath As Boolean, _

CodePageOut As Variant, _

DataOut As Variant _

)

[C++]

HRESULT NAME(

VARIANT DataIn,

long CodePageIn,

VARIANT_BOOL IsFilePath,

VARIANT* CodePageOut,

VARIANT* DataOut

);

Parameters

DataIn

[in] In Visual Basic, contains the input data read by the receive function. For data read from a message queue, the data can be either an array or a String. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the IsFilePath parameter is set to True.

[in] In C++, contains the input data read by the receive function. For data read from a message queue, the data can be either an array or a BSTR. If the data is read from a file receive function, this parameter contains the file path. For file receive functions, the IsFilePath parameter is set to VARIANT_TRUE.

CodePageIn

[in] Contains the code page of the input data. The code page indicates the character set and keyboard layout used on a computer.

IsFilePath

[in] In Visual Basic, contains a value that indicates whether or not the DataIn parameter contains a file path. True indicates that the DataIn parameter contains a file path; False indicates that the DataIn parameter contains data from a message queue receive function.

[in] In C++, contains a value that indicates whether or not the DataIn parameter contains a file path. VARIANT_TRUE indicates that the DataIn parameter contains a file path; VARIANT_FALSE indicates that the DataIn parameter contains data from a message queue receive function.

CodePageOut

[in, out] Contains the code page of the output data. The code page indicates the character set and keyboard layout used on a computer.

DataOut

[in, out] In Visual Basic, contains the output data. For file receive functions, this will be a String. The data in this parameter is sent to BizTalk Server for processing.

[in, out] In C++, contains the output data. For file receive functions, this will be a BSTR. The data in this parameter is sent to BizTalk Server for processing.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If BizTalk Server fails to create the custom preprocessor component, or if the Execute method returns an error or invalid data, the document being processed is placed in the Suspended queue.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


SetContext Method

Retrieves information associated with a document submitted to BizTalk Server.

Member List

IBTSCustomProcess

|--Execute

|--SetContext

Method Declaration

[Visual Basic]

Sub SetContext( _

Ctx As IBTSCustomProcessContext _

)

[C++]

HRESULT SetContext(

IBTSCustomProcessContext* Ctx

);

Parameters

Ctx

[in] IBTSCustomProcessContext that contains information associated with the document being processed by BizTalk Server.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

For additional information about the custom process context object, see IBTSCustomProcessContext.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IBTSCustomProcessContext

Retrieves information associated with data being processed by using a custom preprocessor component.

Hierarchy

IUnknown

|-- IBTSCustomProcessContext

Declaration

[Visual Basic]

Class IBTSCustomProcessContext

[C++]

interface IBTSCustomProcessContext: IUnknown

Members

IBTSCustomProcessContext defines the following properties:

Property | Description
ChannelName | Contains the name of the channel.used for processing the current document.
DestID | Contains the value of the destination organization qualifier.
DestQualifier | Contains the destination organization qualifier type.
DocName | Contains the name of the document definition used by the current document.
EnvelopeName | Contains the name of the envelope used with the current document.
Openness | Contains the openness value associated with the messaging port.
PassThrough | Contains a value indicating whether the document uses pass-through submission mode.
SourceID | Contains the value of the source organization qualifier.
SourceQualifier | Contains the source organization qualifier type.

Remarks

This object can be obtained by calling the SetContext method on the IBTSCustomProcess object. For information about custom preprocessors, see Preprocessing Documents in a Receive Function.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


ChannelName Property

Contains the name of the channel used for processing the current document.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property ChannelName As String

[C++]

HRESULT get_ChannelName(

BSTR* ChannelName

);

Parameters

ChannelName

[out, retval] In C++, contains the name of the channel used for processing the current document. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the channel.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


DestID Property

Contains the value of the destination organization qualifier.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property DestID As String

[C++]

HRESULT get_DestID(

BSTR* DestID

);

Parameters

DestID

[out, retval] In C++, contains the value of the destination organization qualifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the destination organization qualifier.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


DestQualifier Property

Contains the destination organization qualifier type.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property DestQualifier As String

[C++]

HRESULT get_DestQualifier(

BSTR* DestQualifier

);

Parameters

DestQualifier

[out, retval] In C++, contains the value of the destination organization type. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the destination organization qualifier type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


DocName Property

Contains the name of the document definition used by the current document.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property DocName As String

[C++]

HRESULT get_DocName(

BSTR* DocName

);

Parameters

DocName

[out, retval] In C++, contains the document definition name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the document definition.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


EnvelopeName Property

Contains the name of the envelope used with the current document.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property EnvelopeName As String

[C++]

HRESULT get_EnvelopeName(

BSTR* EnvName

);

Parameters

EnvName

[out, retval] In C++, contains the envelope name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the envelope.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


Openness Property

Contains the openness value associated with the messaging port.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property Openness As Long

[C++]

HRESULT get_Openness(

long* Openness

);

Parameters

Openness

[out, retval] In C++, indicates the openness on the messaging port. Valid values for this parameter are defined by the BIZTALK_OPENNESS_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value from the BIZTALK_OPENNESS_TYPE enumeration.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


PassThrough Property

Contains a value indicating whether the document uses pass-through submission mode.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property PassThrough As Long

[C++]

HRESULT get_PassThrough(

long* PassThrough

);

Parameters

PassThrough

[out, retval] In C++, indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether the document uses pass-through submission mode. A value of 0 indicates that pass-through submission mode is not used. A non-zero value indicates that pass-through submission mode is used with the current document.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


SourceID Property

Contains the value of the source organization qualifier.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property SourceID As String

[C++]

HRESULT get_SourceID(

BSTR* SourceID

);

Parameters

SourceID

[out, retval] In C++, contains the value of the source organization qualifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the source organization qualifier.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


SourceQualifier Property

Contains the source organization qualifier type.

Member List

IBTSCustomProcessContext

|--ChannelName

|--DestID

|--DestQualifier

|--DocName

|--EnvelopeName

|--Openness

|--PassThrough

|--SourceID

|--SourceQualifier

Property Declaration

[Visual Basic]

Property SourceQualifier As String

[C++]

HRESULT get_SourceQualifier(

BSTR* SourceQualifier

);

Parameters

SourceQualifier

[out, retval] In C++, contains the value of the source organization type. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the source organization qualifier type.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IInterchange

Use this object to exchange documents between applications and BizTalk Server 2002 directly or through a receive function

Hierarchy

IDispatch

|--IInterchange

Declaration

[Visual Basic]

Class Interchange

[C++]

interface IInterchange : IDispatch

Members

IInterchange defines the following methods:

Method | Description
CheckSuspendedQueue | Returns a list of documents from the Suspended queue that match the request criteria.
DeleteFromSuspendedQueue | Deletes all specified documents from the Suspended queue.
GetSuspendedQueueItemDetails | Retrieves information about a single entry in the Suspended queue.
Submit | Sends an interchange or document to BizTalk Server 2002 for asynchronous processing. BizTalk Server 2002 places the document in a queue until the next available server can process it.
SubmitSync | Sends an interchange or document to BizTalk Server 2002 for synchronous processing. An optional response document is returned to the caller.

Remarks

Using parameters with Submit and SubmitSync overrides certain fields in the header of a self-routing document.

For information about submitting documents from a remote client, see How To.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Direct Integration

Submitting

Routing

Submitting Documents

Submitting a Document


CheckSuspendedQueue Method

Returns a list of documents from the Suspended queue that match the request criteria.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Function CheckSuspendedQueue( _

DocName As String, _

SourceName As String, _

DestName As String_

)

[C++]

HRESULT CheckSuspendedQueue(

BSTR DocName,

BSTR SourceName,

BSTR DestName,

VARIANT* DocumentHandleList

);

Parameters

DocName

[in] Contains the name of the IBizTalkDocument object. This parameter narrows the search for items in the Suspended queue. If this parameter is omitted, this method matches all IBizTalkDocument objects. This is an optional parameter.

SourceName

[in] Contains the name of the source IBizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all IBizTalkOrganization objects. This is an optional parameter.

DestName

[in] Contains the name of the destination IBizTalkOrganization object. This parameter narrows the search criteria for items in the Suspended queue. If this parameter is omitted, this method matches all IBizTalkOrganization objects. This is an optional parameter.

DocumentHandleList

[out, retval] In C++, contains a list of handles to all documents in the Suspended queue. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a list of handles to all documents in the Suspended queue.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The returned items are not deleted from the queue. To delete items from the Suspended queue, use the DeleteFromSuspendedQueue method.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Submitting a Document


DeleteFromSuspendedQueue Method

Deletes all specified documents from the Suspended queue.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Sub DeleteFromSuspendedQueue( _

DocumentHandleList As Variant _

)

[C++]

HRESULT DeleteFromSuspendedQueue(

VARIANT* DocumentHandleList

);

Parameters

DocumentHandleList

[in] Contains a full list of handles or a subset for documents to be deleted from the Suspended queue.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Submitting a Document


GetSuspendedQueueItemDetails Method

Retrieves information about a single entry in the Suspended queue.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Sub GetSuspendedQueueItemDetails( _

ItemHandle As String, _

SourceName As Variant, _

DestName As Variant, _

DocName As Variant, _

ReasonCode As Variant, _

ItemData As Variant

)

[C++]

HRESULT GetSuspendedQueueItemDetails(

BSTR ItemHandle,

VARIANT* SourceName,

VARIANT* DestName,

VARIANT* DocName,

VARIANT* ReasonCode,

VARIANT* ItemData

);

Parameters

ItemHandle

[in] Contains the handle of an item in the Suspended queue. This value can be obtained by calling the CheckSuspendedQueue method.

SourceName

[out] Contains the name of the source IBizTalkOrganization object.

DestName

[out] Contains the name of the destination IBizTalkOrganization object.

DocName

[out] Contains the name of the IBizTalkDocument object.

ReasonCode

[out] Contains the reason a document or interchange has been placed in the Suspended queue. For more information about this value, see the CISReasonToQueue enumeration.

ItemData

[out] Contains the document instance or interchange.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Submitting

Submitting a Document


Submit Method

Sends an interchange or document to BizTalk Server 2002 for asynchronous processing. BizTalk Server 2002 places the document in a queue until the next available server can process it.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Function Submit( _

Openness As BIZTALK_OPENNESS_TYPE, _

Document As String, _

DocName As String, _

SourceQualifier As String, _

SourceID As String, _

DestQualifier As String, _

DestID As String, _

ChannelName As String, _

FilePath As String, _

EnvelopeName As String, _

PassThrough As Long

) As String

[C++]

HRESULT Submit(

BIZTALK_OPENNESS_TYPE Openness,

BSTR Document,

BSTR DocName,

BSTR SourceQualifier,

BSTR SourceID,

BSTR DestQualifier,

BSTR DestID,

BSTR ChannelName,

BSTR FilePath,

long EnvelopeName,

BSTR* PassThrough,

BSTR* SubmissionHandle

);

Parameters

Openness

[in] Indicates whether associated IBizTalkPort objects can be open. Valid values are defined by the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] Contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, IDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] Contains the name of the IBizTalkDocument object associated with the instance of the document being submitted. If the Openness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input IBizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output IBizTalkDocument must not have an X12 or EDIFACT specification. If Openness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the IBizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] Contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the Data Universal Numbering System (D-U-N-S) number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] Contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] Contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. You must specify a DestID. The default qualifier for all new organizations is OrganizationName and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] Contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] Contains the name of the IBizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] Specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2002 supports URL, UNC, and drive: format only. If the document is submitted as a file that is pointed to by the FilePath parameter, the call returns successfully after BizTalk Server 2002 has successfully copied the file to the Work queue. It is safe to delete the file from the specified path as soon as this method returns successfully. When a document is submitted to the server, using FilePath to specify the data, Submit can take 30 seconds or longer if the location of the file resides on a remote server that is unavailable, if the UNC path is invalid, or if the SQL server is down. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] Contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. When submitting a flat file to BizTalk Server 2002, you must create an envelope for this flat file and specify the name of the envelope in EnvelopeName. This is an optional parameter.

PassThrough

[in] Indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out, retval] In C++, contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned, yet the Tracking database enables the user to get the status of all child documents related to this interchange identifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Submitting a Document


SubmitSync Method

Sends an interchange or document to BizTalk Server 2002 for synchronous processing. An optional response document is returned to the caller.

Member List

IInterchange

|--CheckSuspendedQueue

|--DeleteFromSuspendedQueue

|--GetSuspendedQueueItemDetails

|--Submit

|--SubmitSync

Method Declaration

[Visual Basic]

Sub SubmitSync( _

Openness As BIZTALK_OPENNESS_TYPE, _

Document As String, _

DocName As String, _

SourceQualifier As String, _

SourceID As String, _

DestQualifier As String, _

DestID As String, _

ChannelName As String, _

FilePath As String, _

EnvelopeName As String, _

PassThrough As Long, _

SubmissionHandle As Variant, _

ResponseDocument As Variant

)

[C++]

HRESULT SubmitSync(

BIZTALK_OPENNESS_TYPE Openness,

BSTR Document,

BSTR DocName,

BSTR SourceQualifier,

BSTR SourceID,

BSTR DestQualifier,

BSTR DestID,

BSTR ChannelName,

BSTR FilePath,

long EnvelopeName,

BSTR* PassThrough,

VARIANT* SubmissionHandle,

VARIANT* ResponseDocument

);

Parameters

Openness

[in] Indicates whether associated IBizTalkPort objects can be open. Valid values are defined by the BIZTALK_OPENNESS_TYPE enumeration.

Document

[in] Contains the document instance submitted. This parameter accepts only a string buffer as the document or interchange. This means that applications cannot submit other objects, such as DOM objects, IDictionary objects, ADO objects, or any other data type or object type. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. This is an optional parameter.

DocName

[in] Contains the name of the IBizTalkDocument object associated with the instance of the document submitted. If the Openness parameter is set to BIZTALK_OPENNESS_TYPE_SOURCE, you can select an input IBizTalkDocument object that has an X12 or EDIFACT specification. If you do, however, the output IBizTalkDocument must not have an X12 or EDIFACT specification. If Openness is set to BIZTALK_OPENNESS_TYPE_DESTINATION, the IBizTalkDocument object must not have an X12 or EDIFACT specification. The DocName parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceQualifier

[in] Contains the qualifier of the source organization. This indicates how the SourceID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. You must specify a SourceID. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The SourceQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

SourceID

[in] Contains the value of the qualifier of the source organization. For example, if the SourceQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenSrc, SourceID is interpreted as the source organization name. The SourceID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestQualifier

[in] Contains the qualifier of the destination organization. This indicates how the DestID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. You must specify a DestID parameter. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk. The DestQualifier parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

DestID

[in] Contains the value of the qualifier of the destination organization. For example, if the DestQualifier parameter is Telephone, this value is the telephone number. If the Openness flag is set to OpenDest, DestID is used as the destination address. Note that the queue:// prefix must be used with an open messaging port when a Message Queue is specified as the destination address. The DestID parameter cannot be used if the PassThrough parameter is set to TRUE. This is an optional parameter.

ChannelName

[in] Contains the name of the IBizTalkChannel object that is executed for this document. This bypasses the normal processing in which the parser tries to determine which messaging port/channel pair to execute, based on routing information in the parameters or in the document. This is an optional parameter unless the PassThrough parameter is set to TRUE.

FilePath

[in] Specifies a fully qualified path that contains the document to be submitted, rather than submitting the document directly as a string. BizTalk Server 2002 supports URL, UNC, and drive: format only. Either the Document parameter or the FilePath parameter must be specified. Do not specify both. The FilePath parameter cannot be used if the PassThrough parameter is set to TRUE and a map is specified. This is an optional parameter.

EnvelopeName

[in] Contains the name of the envelope specification to use to break the interchange into documents. When an envelope name is provided in this parameter, the envelope must have a valid interchange specification. This requirement is enforced for envelopes created for Custom XML format also. This is an optional parameter.

PassThrough

[in] Indicates how the server processes the document. When this parameter is set to TRUE, no decryption, decoding, or signature verification is performed on the document. When set to FALSE, the document is decrypted and decoded, and the signature is verified. When using pass-through submission mode (TRUE), the BIZTALK_OPENNESS_TYPE value must be set to BIZTALK_OPENNESS_TYPE_NOTOPEN and the ChannelName parameter must be specified. In addition, the DocName, SourceQualifier, SourceID, DestQualifier, and DestID parameters cannot be specified with pass-through submission mode. Pass-through submission mode should be used to prevent data corruption when exchanging binary files, or when only the server transport and global tracking features are being used.

SubmissionHandle

[out] Contains a unique identifier for the submitted document or interchange. This handle can be used to query the Tracking database for the status of the interchange or document submitted. If more than one document is submitted (an interchange), a single handle is returned; yet the Tracking database can access the status of all child documents related to this interchange identifier.

ResponseDocument

[out] Contains the optional response document.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

SubmitSync returns an optional response document when provided. If no response is returned, the call returns successfully, but with no response and with an HRESULT value of S_FALSE. If the destination is another BizTalk Server, an ASP page must be used to return a response.

A synchronous interchange bypasses all queues and executes all the components required by the messaging port on the calling thread. For synchronous protocols (HTTP and AIC), an optional response document is returned to the user, if available. This method is valid only for a single channel match. If the parameters set cause multiple channels to match, synchronous submission returns an error indicating that multiple channel matches are not allowed for synchronous submission. This method can be used only for single document interchanges. If the submission contains multiple documents, synchronous submission returns an error indicating that multiple document submissions are not allowed. This method does not support port groups.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

Openness

Routing

Submitting

Submitting a Document


Enumerations

The following enumeration provides possible property and parameter values:

  • CISReasonToQueue


CISReasonToQueue

Describes the reasons a document was placed in a queue.

[Visual Basic]

Enum CISReasonToQueue_tag

[C++]

enum CISReasonToQueue

Members

noReason

[0] Not supported for this release.

rtdlqParserFailure

[1] Specifies that the instance of the document was placed in the queue because of failure of the parser.

rtdlqParserDocFailure

[2] Specifies that the instance of the document was placed in the queue because the business document was invalid.

rtdlqDocValidation

[3] Specifies that the document was placed in the queue because document validation failed.

rtdlqChannelSelectFailure

[4] Specifies that the instance of the document was placed in the queue because of failure in selecting the correct IBizTalkChannel object.

rtdlqInvalidMap

[5] Specifies that the instance of the document was placed in the queue because the map referred to by the BizTalkChannel object was formatted incorrectly.

rtdlqFieldTrackingFailure

[6] Specifies that the instance of the document was placed in the queue because the server was unable to track the requested fields within the document.

rtdlqMappingFailure

[7] Specifies that the instance of the document was placed in the queue because of failure of transformation.

rtdlqSerializerFailure

[8] Specifies that the instance of the document was placed in the queue because the server could not convert this document to its native format.

rtdlqEncodingFailure

[9] Specifies that the instance of the document was placed in the queue because the server was unable to encode this interchange.

rtdlqSigningFailure

[10] Specifies that the instance of the document was placed in the queue because the server was unable to sign this interchange.

rtdlqEncryptionFailure

[11] Specifies that the instance of the document was placed in the queue because the server was unable to encrypt this interchange.

rtdlqTransmissionFailure

[12] Specifies that the instance of the document was placed in the queue because the server was unable to deliver this document.

rtdlqUserMove

[13] Specifies that the administrator moved this instance of the document to the queue.

rtdlqTimeout

[14] Specifies that the instance of the document was placed in the queue because a time-out occurred.

rtdlqCustomCompFailure

[15] Specifies that the instance of the document was placed in the queue because of failure of a custom component.

unkReason

[16] Specifies that this item was marked as "In process" by an inactive server. On restart of this server, this item was automatically moved to the Suspended queue. There was probably a catastrophic failure on the original server. Contact the system administrator for more information.

rtdlqNoChannel

[17] Specifies that the instance of the document was placed in the queue because the BizTalkChannel object was deleted.

rtdlqMissingChannel

[18] Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface was not found.

rtdlqInvalidChannel

[19] Specifies that the instance of the document was placed in the queue because the BizTalkChannel object specified by the Submit method of the IInterchange interface specifies an open IBizTalkPort object. This is not permitted.

rtdlqOutOfMemory

[20] Specifies that your computer has run out of memory. Rebooting is recommended.

rtdlqBTFRecReqExpired

[21] Specifies that the document was placed in the queue because the BTF timestamp receiptRequiredBy expired.

rtdlqBTFExpiresAtExpired

[22] Specifies that the document was placed in the queue because the BTF timestamp expiresAt expired.

rtdlqCorrelationFailure

[23] Specifies that the document receipt failed.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: cisapi.h
Library: (cisapi.tlb)

Related Topics

GetSuspendedQueueItemDetails


Custom Components Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for working with custom components:

  • Interfaces

  • Enumerations

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented for C++ developers:

  • IBizTalkParserComponent

  • IBizTalkSerializerComponent

The following COM interfaces are documented for both C++ and Visual Basic developers:

  • IBizTalkAcknowledge

  • IBizTalkCorrelation

  • IBTSAppIntegration

  • IFunctoid

  • IPipelineComponent

  • IPipelineComponentAdmin

  • ISchemaImporter

  • ISchemaImporterError

  • ISchemaImporterErrorProvider


IBizTalkAcknowledge

Processes receipts sent to the server.

Hierarchy

IUnknown

|--IBizTalkAcknowledge

Declaration

[Visual Basic]

Class IBizTalkAcknowledge

[C++]

interface IBizTalkAcknowledge : IUnknown

Members

IBizTalkAcknowledge defines the following methods:

Method | Description
AckDocument | Processes receipts received for documents.
AckGroup | Processes receipts received for document groups.
AckInterchange | Processes receipts received for document interchanges.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

Creating Receipt Correlator Components

How Receipts Are Logged

Understanding Receipts


AckDocument Method

Processes receipts received for documents.

Member List

IBizTalkAcknowledge

|--AckDocument

|--AckGroup

|--AckInterchange

Method Declaration

[Visual Basic]

Sub AckDocument( _

Syntax As String, _

TrackingId As String, _

AckStatus As DTA_ACK_STATUS _

)

[C++]

HRESULT AckDocument(

BSTR Syntax,

BSTR TrackingId,

DTA_ACK_STATUS AckStatus

);

Parameters

Syntax

[in] Contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT.

TrackingId

[in] Contains the globally unique identifier (GUID) for tracking the document. This value can be obtained from the Tracking_ID field in the dta_outdoc_details table. For more information, see Supporting the Tracking Database with Parser and Serializer Components.

AckStatus

[in] Indicates the receipt status. Valid values for this parameter are defined by the DTA_ACK_STATUS enumeration.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only for receipts on individual documents. If the receipt needs to be mapped, a document definition that points to CanonicalReceipt.xml shipped in WebDAV must be created for the receipt.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


AckGroup Method

Processes receipts received for document groups.

Member List

IBizTalkAcknowledge

|--AckDocument

|--AckGroup

|--AckInterchange

Method Declaration

[Visual Basic]

Sub AckGroup( _

Syntax As String, _

Version As String, _

Release As String, _

FunctionalGroupId As String, _

ControlId As String, _

SrcAppName As String, _

DestAppName As String, _

AckStatus As DTA_ACK_STATUS _

)

[C++]

HRESULT AckGroup(

BSTR Syntax,

BSTR Version,

BSTR Release,

BSTR FunctionalGroupId,

BSTR ControlId,

BSTR SrcAppName,

BSTR DestAppName,

DTA_ACK_STATUS AckStatus

);

Parameters

Syntax

[in] Contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

Version

[in] Contains the version of the syntax, used primarily for EDI.

Release

[in] Contains the release of the version of the syntax, used primarily for EDI.

FunctionalGroupId

[in] Contains the code for the type of documents in a group, used primarily for EDI.

ControlId

[in] Contains the unique identifier for the control number, used primarily for EDI.

SrcAppName

[in] Contains the name of the source application.

DestAppName

[in] Contains the name of the destination application.

AckStatus

[in] Indicates the receipt status. Valid values are defined by the DTA_ACK_STATUS enumeration.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only for receipts on document groups.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


AckInterchange Method

Processes receipts received for document interchanges.

Member List

IBizTalkAcknowledge

|--AckDocument

|--AckGroup

|--AckInterchange

Method Declaration

[Visual Basic]

Sub AckInterchange( _

Syntax As String, _

InterchangeId As String, _

Version As String, _

ControlId As String, _

SrcAliasQualifier As String, _

SrcAliasId As String, _

SrcAppName As String, _

DestAliasQualifier As String, _

DestAliasId As String, _

DestAppName As String, _

AckStatus As DTA_ACK_STATUS _

)

[C++]

HRESULT AckInterchange(

BSTR Syntax,

BSTR InterchangeId,

BSTR Version,

BSTR ControlId,

BSTR SrcAliasQualifier,

BSTR SrcAliasId,

BSTR SrcAppName,

BSTR DestAliasQualifier,

BSTR DestAliasId,

BSTR DestAppName,

DTA_ACK_STATUS AckStatus

);

Parameters

Syntax

[in] Contains the syntax of the outbound document to be acknowledged, for example, X12 or EDIFACT. You must use the exact strings for the following syntax types:

  • X12

  • EDIFACT

  • Custom XML

InterchangeId

[in] Contains the unique tracking identifier of the interchange. This value is a globally unique identifier (GUID).

Version

[in] Contains the version of the syntax, used primarily for EDI.

ControlId

[in] Contains the unique identifier for the control number, used primarily for EDI.

SrcAliasQualifier

[in] Contains the qualifier of the source organization. This indicates how the bstrSrcAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the Data Universal Numbering System (D-U-N-S) number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

SrcAliasId

[in] Contains the value of the qualifier of the source organization. For example, if the bstrSrcAliasQualifier parameter is Telephone, this value is the telephone number.

SrcAppName

[in] Contains the name of the source application.

DestAliasQualifier

[in] Contains the qualifier of the source organization. This indicates how the bstrDestAliasID parameter is to be interpreted. Valid values come from the organization identifier qualifiers that are created when the user creates an alias for an organization. Common qualifiers include the D-U-N-S number, telephone number, and BizTalk. The default qualifier for all new organizations is Organization Name and refers to the name of the organization in the database. If a BizTalk Framework 2.0–compliant document is submitted and a qualifier is not found during parsing, the qualifier defaults to BizTalk.

DestAliasId

[in] Contains the value of the qualifier of the source organization. For example, if the bstrDestAliasQualifier parameter is Telephone, this value is the telephone number.

DestAppName

[in] Contains the name of the destination application.

AckStatus

[in] Indicates the receipt status. Valid values are defined by the DTA_ACK_STATUS enumeration.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only for receipts on document interchanges.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)


IBizTalkCorrelation

Creates receipt correlator components.

Hierarchy

IUnknown

|--IBizTalkCorrelation

Declaration

This interface is only supported in C++

interface IBizTalkCorrelation : IUnknown

Members

IBizTalkCorrelation defines the following method:

Method | Description
Correlate | Extracts all relevant information from the document, document group, or interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Creating Receipt Correlator Components


Correlate Method

Extracts all relevant information from the document, document group, or interchange.

Member List

IBizTalkCorrelation

|--Correlate

Method Declaration

This method is only supported in C++

HRESULT Correlate(

IUnknown* Acknowledge,

IDictionary* Dict

);

Parameters

Acknowledge

[in] An IBizTalkAcknowledge interface used to invoke and set the receipt flag.

Dict

[in] An IDictionary interface of an object that contains the receipt information.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h


IFunctoid

Creates custom mapping functions. IFunctoid defines the generic protocol for calling custom functions used by the mapping tool.

Hierarchy

IDispatch

|--IFunctoid

Declaration

[Visual Basic]

Class CannedFunctoid

[C++]

interface IFunctoid : IDispatch

Members

IFunctoid defines the following properties:

Property | Description
FunctionsCount | Contains the number of functions implemented by the functoid.
Version | Contains the version of the functoid.

IFunctoid defines the following methods:

Method | Description
GetFunctionDescripter | Retrieves information about a specific functoid.
GetFunctionParameter | Retrieves the connection-type bit flags for the specified parameter.
GetScriptBuffer | Retrieves the script code used to implement the functoid.

Remarks

Custom functoids must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Functoids register themselves with the category ID CATID_BIZTALK_MapEditFunctoids. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Each custom functoid can support multiple functions and can contain icons and names for each supported function. Function identifiers from 0 to 1000 are reserved for built-in functions in BizTalk Mapper. User-defined functions (custom functions) should use function identifiers 1001 and above.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


FunctionsCount Property

Contains the number of functions implemented by the functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Property Declaration

[Visual Basic]

Property FunctionsCount As Long

[C++]

HRESULT get_FunctionsCount(

long* Count

);

Parameters

Count

[out, retval] In C++, contains the number of functions implemented by the functoid. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of functions implemented by the functoid.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


GetFunctionDescripter Method

Retrieves information about a specific functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Method Declaration

[Visual Basic]

Function GetFunctionDescripter( _

Index As Long, _

FuncCategory As FUNC_CATEGORY, _

ScriptCategory As SCRIPT_CATEGORY, _

FuncType As FUNC_TYPE, _

Name As String, _

ToolTip As String, _

BitmapID As Long, _

ParmCount As Long _

) As Long

[C++]

HRESULT GetFunctionDescripter(

long Index,

FUNC_CATEGORY* FuncCategory,

SCRIPT_CATEGORY* ScriptCategory,

FUNC_TYPE* FuncType,

BSTR* Name,

BSTR* ToolTip,

long* BitmapID,

long* ParmCount,

FUNCID* FuncId

);

Parameters

Index

[in] Specifies the index number of the function.

FuncCategory

[in, out] Contains a value indicating the tab on the functoid palette on which the custom functoid will appear. Valid values for this parameter are defined by the FUNC_CATEGORY enumeration.

ScriptCategory

[in, out] Contains the scripting language used by the custom functoid. Valid values for this parameter are defined by the SCRIPT_CATEGORY enumeration.

FuncType

[in, out] Contains the function type information for the custom functoid. Valid values for this parameter are defined by the FUNC_TYPE enumeration.

Name

[in, out] Contains the function name.

ToolTip

[in, out] Contains the ToolTip that appears when the mouse pointer is paused over the custom functoid icon in the mapping tool.

BitmapID

[in, out] Contains a bitmap identifier of the bitmap used for the custom functoid icon displayed in the mapping tool.

ParmCount

[in, out] Contains the number of parameters implemented by the function.

FuncId

[out, retval] In C++, contains the function identifier. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the function identifier.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


GetFunctionParameter Method

Retrieves the connection-type bit flags for the specified parameter.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Method Declaration

[Visual Basic]

Function GetFunctionParameter( _

FuncId As Long, _

Parameter As Long _

) As Long

[C++]

HRESULT GetFunctionParameter(

FUNCID FuncId,

long Parameter,

long* ConnectionType

);

Parameters

FuncId

[in] Contains the function identifier.

Parameter

[in] Contains the function parameter number. For output parameters, a value of -1 is used.

ConnectionType

[out, retval] In C++, contains the connection type information of the specified parameter. Valid values for this parameter are defined by the CONNECTION_TYPE enumeration. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the connection type information of the specified parameter. Valid values for this parameter are defined by the CONNECTION_TYPE enumeration.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


GetScriptBuffer Method

Retrieves the script code used to implement the functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Method Declaration

[Visual Basic]

Function GetScriptBuffer( _

FuncId As Long, _

InputParameters As Long _

) As String

[C++]

HRESULT GetScriptBuffer(

FUNCID FuncId,

long InputParameters,

BSTR* ScriptBuffer

);

Parameters

FuncId

[in] Contains the function identifier.

InputParameters

[in] Indicates the number of connected input parameters for the specified function.

ScriptBuffer

[out, retval] In C++, contains the script code used to implement the function. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the script code used to implement the function.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


Version Property

Contains the version of the functoid.

Member List

IFunctoid

|--FunctionsCount

|--GetFunctionDescripter

|--GetFunctionParameter

|--GetScriptBuffer

|--Version

Property Declaration

[Visual Basic]

Property Version As Long

[C++]

HRESULT get_Version(

long* Version

);

Parameters

Version

[out, retval] In C++, contains the custom functoid version. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the custom functoid version.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

If the custom functoid is modified in any way, the author should update the version number.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)


IBizTalkParserComponent

Converts a document to XML for later processing and identifies the IBizTalkChannel objects necessary to process the documents.

Hierarchy

IUnknown

|--IBizTalkParserComponent

Declaration

This interface is only supported in C++

interface IBizTalkParserComponent : IUnknown

Members

IBizTalkParserComponent defines the following methods:

Method | Description
GetGroupDetails | Gets details of the group for the Tracking database. This method is called only if there are groups in the interchange.
GetGroupSize | Gets the size of the group after all documents in the group are parsed. This method is called only if there are groups in the interchange.
GetInterchangeDetails | Gets information about the organization identifiers of the source and destination IBizTalkOrganization objects.
GetNativeDocumentOffsets | Identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.
GetNextDocument | Examines the data in a document and determines when to get the next document if this is not the last document.
GroupsExist | Determines whether the interchange contains groups.
ProbeInterchangeFormat | Identifies the format of the interchange.

Remarks

Custom parser components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Parser components register themselves with the category ID CATID_BIZTALK_PARSER. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Identification

Working with Parsers

Parsers


GetGroupDetails Method

Gets details of the group for the Tracking database. This method is called only if there are groups in the interchange.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetGroupDetails(

IDictionary* Dict

);

Parameters

Dict

[in] IDictionary interface of an object that contains details about the group. All information is returned as string types, no matter how it appears in the data.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only if groups are detected in the interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetGroupSize Method

Gets the size of the group after all documents in the group are parsed. This method is called only if there are groups in the interchange.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetGroupSize(

long* GroupSize,

BOOL* LastGroup

);

Parameters

GroupSize

[out] Contains the size of the interchange.

LastGroup

[out] Indicates whether the group is the last group in the interchange. If this parameter is set to TRUE, the next method called is GetGroupDetails for the next group in the data. If it is set to FALSE, the component is finished. When it is released, it leaves the IStream interface after the last byte it has read.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

After all documents in the group are called, the final details about the group are required. Both output parameters are added to the Tracking database for final logging.

This method is called only if there are groups in the interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetInterchangeDetails Method

Gets information about the organization identifiers of the source and destination IBizTalkOrganization objects.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetInterchangeDetails(

IDictionary* Dict

);

Parameters

Dict

[in] IDictionary interface of an object that contains information about the organization identifiers of the source and destination IBizTalkOrganization objects.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The minimum sets of fields are:

Field | Description
src_id_type | Source qualifier
src_id_value | Source ID
dest_id_type | Destination qualifier
dest_id_value | Destination ID

The parameters of the Submit method of the IInterchange interface override any fields set here.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetNativeDocumentOffsets Method

Identifies offsets from the beginning of the stream for final details about the group in the Tracking database for final logging.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetNativeDocumentOffsets(

BOOL SizeFromXMLDoc,

LARGE_INTEGER* StartOffset,

long* DocLength

);

Parameters

SizeFromXMLDoc

[out] Indicates whether the XML document passed in from the GetNextDocument method was used to determine the size. If this parameter is TRUE, the server fills in the StartOffset and DocLength values for the document just parsed. If this parameter is FALSE, the server ignores the values in StartOffset and DocLength.

StartOffset

[out] Contains the location of the beginning of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

DocLength

[out] Contains the length of the document. This parameter is returned if the SizeFromXMLDoc parameter is set to TRUE.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called immediately after GetNextDocument whether or not the document is valid (as long as the parser does not return an error value). These are offsets into the IStream object relative to the beginning of the stream, not the beginning of the interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GetNextDocument Method

Examines the data in a document and determines when to get the next document if this is not the last document.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GetNextDocument(

IDictionary* Dict,

BSTR DocSpecName,

BOOL* DocIsValid,

BOOL* LastDocument,

GeneratedReceiptLevel ReceiptGenerated,

BOOL* DocIsReceipt,

BSTR* CorrelationCompProgID

);

Parameters

Dict

[in] IDictionary interface of an object into which to set the XML instance created on parsing the current document. The parsed XML document is placed into the working_data field of the dictionary.

DocSpecName

[in] Contains the name of the BizTalk document specification used to generate the XML from the document's native format.

DocIsValid

[out] Indicates whether the document instance is valid. If it is invalid but the parser can recover from it, set this parameter to FALSE. This parameter and the LastDocument parameter are independent. Therefore, if there are no more documents and the last one is invalid, both flags are set. If the document is invalid and the parser cannot continue, it might return an error value. The server then stops at the current position of the IStream pointer. The component places the invalid data (if the parser can recover) in the working_data field for inspection by the system administrator if the document is invalid.

LastDocument

[out] Indicates whether this is the last document instance in the group or interchange. When the last document is found, the LastDocument flag is set to TRUE. If there are groups, this flag signals the last document in the group, and the GetGroupSize method is called. If there are no groups, this is the last call to get document data from the parser, and the IStream pointer is set appropriately.

ReceiptGenerated

[out] Contains the receipt status information. Valid values are defined by the GeneratedReceiptLevel enumeration.

DocIsReceipt

[out] Identifies whether or not this document is a receipt.

CorrelationCompProgID

[out] Contains the program ID for the correlation of documents.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


GroupsExist Method

Determines whether the interchange contains groups.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT GroupsExist(

BOOL* GrpsExist

);

Parameters

GrpsExist

[out, retval] Indicates whether the data format contains groups. If this parameter is set to FALSE, the GetGroupDetails and GetGroupSize methods are never called.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


ProbeInterchangeFormat Method

Identifies the format of the interchange.

Member List

IBizTalkParserComponent

|--GetGroupDetails

|--GetGroupSize

|--GetInterchangeDetails

|--GetNativeDocumentOffsets

|--GetNextDocument

|--GroupsExist

|--ProbeInterchangeFormat

Method Declaration

This interface is only supported in C++

HRESULT ProbeInterchangeFormat(

IStream* pData,

BOOL FromFile,

BSTR EnvName,

IStream* pReceiptData,

BSTR* Format

);

Parameters

pData

[in] IStream object that contains the data for the document interchange. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

FromFile

[in] Contains a value that indicates whether or not the data came from the FilePath parameter of the Submit or the SubmitSync method of the IInterchange interface. TRUE indicates that the data came from the file referred to by the FilePath parameter. FALSE indicates that the data came from the Document parameter of Submit or SubmitSync as a string. If the data is from a file, no conversion is made. If the data is a string, you can use UNICODE/MBCS techniques to understand it.

EnvName

[in] Contains the name of the envelope.

pReceiptData

[in] IStream object that contains the receipt document.

Format

[out] Contains the format of the data. If the server recognizes the format, it must fill in this parameter with a non-empty string and hold on to (add a reference count to) the IStream interface because it is not given back to the component. This IStream object is read-only; it supports only the Read, Stat, and Seek methods. All other methods return E_NOTIMPL. This method should not return a failure if it does not recognize the format. It returns S_FALSE or an empty or NULL Format string. If you do not recognize the format, you do not need to move the IStream pointer back to its original position; the server resets the IStream pointer. Unless your format requires it, do not assume that the pointer is at the beginning. The pointer can be somewhere in the middle during the probing stage.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is the first method that is called by the server. If ProbeInterchangeFormat returns an error in the middle of the document list, it blocks the server from detecting more document types, even if they could be handled by a custom parser that follows the failed parser, if there are two or more custom parsers on a server. If the first custom parser fails, any document that follows is not parsed, even if the other custom parser could handle it, because the server ends the entire parsing operation at the time of the failure.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

Working with Parsers

Parsers


IBizTalkSerializerComponent

Converts a document from XML to the document's original native format.

Hierarchy

IUnknown

|--IBizTalkSerializerComponent

Declaration

This interface is only supported in C++

interface IBizTalkSerializerComponent : IUnknown

Members

IBizTalkSerializerComponent defines the following methods:

Method | Description
AddDocument | Adds an XML document for storage by the serializer component.
GetDocInfo | Gets details of the document.
GetGroupInfo | Gets details of the group, such as size and offset, for the Tracking database.
GetInterchangeInfo | Gets information about the interchange created.
Init | Outputs the document instance to the serializer component and indicates where it should be sent.

Remarks

Custom serializer components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Serializer components register themselves with the category ID CATID_BIZTALK_SERIALIZER. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


AddDocument Method

Adds an XML document for storage by the serializer component.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT AddDocument(

long DocHandle,

IDictionary* Transport,

BSTR TrackID,

long ChannelID

);

Parameters

DocHandle

[in] Contains the handle to the document that is stored by the component and later retrieved when calling the GetDocInfo method. This parameter supports out-of-order recreation of the interchange in case the documents need to be reordered (such as in X12).

Transport

[in] Contains an IDictionary interface of an object that contains the XML document to be stored. It is on the working_data field. This parameter cannot be set by the component. This is an optional parameter.

TrackID

[in] Contains the document tracking ID used by the server.

ChannelID

[in] Contains the IBizTalkChannel object associated with the current document.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called only once per interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


GetDocInfo Method

Gets details of the document.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT GetDocInfo(

long* DocHandle,

BOOL* SizeFromXMLDoc,

LARGE_INTEGER* DocStartOffset,

long* DocLen

);

Parameters

DocHandle

[out] Contains the document handle. For each ID that is passed back, this address is assigned to the group record that was created when the GetGroupInfo method was called. This parameter also returns properties of the document, for example, size and length, unless the SizeFromXMLDoc parameter is set to TRUE, in which case the other parameters are ignored.

SizeFromXMLDoc

[out] Indicates that the document offset and length values are retrieved from the XML document. TRUE indicates that the server fills in the DocStartOffset and DocLen values for the document; FALSE indicates that the server ignores the values in DocStartOffset and DocLen.

DocStartOffset

[out] Contains the offset to the beginning of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

DocLen

[out] Contains the length of the document. This parameter is returned if SizeFromXMLDoc is set to TRUE.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called once for every document in a group (or interchange, if there are no groups).

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


GetGroupInfo Method

Gets details of the group, such as size and offset, for the Tracking database.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT GetGroupInfo(

long* NumDocs,

LARGE_INTEGER* GrpStartOffset,

long* GrpLen

);

Parameters

NumDocs

[out] Contains the number of documents in the group.

GrpStartOffset

[out] Contains the offset to the start of the group in the IStream interface.

GrpLen

[out] Contains the length of the group.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called the number of times returned by the GetInterchangeInfo method. Call the GetDocInfo method for each document in the group.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Sequence for Calling Methods of the IBizTalkSerializerComponent Interface

Serializers


GetInterchangeInfo Method

Gets information about the interchange created.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT GetInterchangeInfo(

BSTR* InterchangeID,

long* NumGroups

);

Parameters

InterchangeID

[out] Contains the interchange ID, which is placed in the Tracking database.

NumGroups

[out] Contains the number of groups generated in the interchange. This value can be either 0 or 1. A document can exist in only one group.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is called after all the documents are passed in.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


Init Method

Outputs the document instance to the serializer component and indicates its destination.

Member List

IBizTalkSerializerComponent

|--AddDocument

|--GetDocInfo

|--GetGroupInfo

|--GetInterchangeInfo

|--Init

Method Declaration

This interface is only supported in C++

HRESULT Init(

BSTR srcQual,

BSTR srcID,

BSTR destQual,

BSTR destID,

long envID,

IDictionary* Delimiters,

Istream* OutputStream,

long NumDocs

);

Parameters

srcQual

[in] Contains the source-organization identifier qualifier.

srcID

[in] Contains the source-organization identifier value.

destQual

[in] Contains the destination-organization identifier qualifier.

destID

[in] Contains the destination-organization identifier value.

EnvID

[in] Contains the envelope identifier value.

Delimiters

[in] Contains an IDictionary interface of an object that contains the delimiters used in the document.

OutputStream

[in] Contains an IStream interface that contains the data of this document. This IStream pointer is write-only. The only methods that are supported are Write and Stat; all other methods return E_NOTIMPL. Additional information about the IStream object is available on the Microsoft Developer Network at msdn.microsoft.com/library/default.asp.

NumDocs

[in] Contains the number of documents sent as part of this interchange. For this release, this parameter is set to 1.

Return Values

This method returns an HRESULT value, indicating success or failure.

Error Handling

If the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSSerializerComps.h

Related Topics

Working with Serializers

Serializers


IBTSAppIntegration

Creates an entry point for receiving a document.

Hierarchy

IDispatch

|--IBTSAppIntegration

Declaration

[Visual Basic]

Class IBTSAppIntegration

[C++]

interface IBTSAppIntegration : IDispatch

Members

IBTSAppIntegration defines the following method:

Method | Description
ProcessMessage | Processes a document and returns a response document, if available. This method is called at run time when the server is sending a document to the component.

Remarks

Application integration components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)

Related Topics

Lightweight Application Integration Components

Application Integration in Visual Basic

Application Integration in Visual C++


ProcessMessage Method

Processes a document and returns a response document, if available. This method is called at run time when the server is sending a document to the component.

Member List

IBTSAppIntegration

|--ProcessMessage

Method Declaration

[Visual Basic]

Function ProcessMessage( _

Document As String _

) As String

[C++]

HRESULT ProcessMessage(

BSTR Document,

BSTR* ResponseDocument

);

Parameters

Document

[in] Contains the document to be processed.

ResponseDocument

[retval, out] In C++, contains the response document processed by the component, if available. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns the response document, if available.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Components can return a response string to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface to send documents.

Components must raise an error if a problem with processing occurs so that the document can be retransmitted or sent to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: btsaic.h
Library: Microsoft BizTalk Server Application Interface Components 1.0 Type Library (btscomplib.tlb)


IPipelineComponent

Creates custom pipeline components that can execute in Microsoft BizTalk Server 2002 to extend its functionality.

Hierarchy

IUnknown

|--IPipelineComponent

Declaration

[Visual Basic]

Class IPipelineComponent

[C++]

interface IPipelineComponent : IUnknown

Members

IPipelineComponent defines the following methods:

Method | Description
EnableDesign | Configures the component for execution in one of two modes: design mode or execution mode.
Execute | Executes the operation expected of the component, given the transport IDictionary object and other configuration settings.

Remarks

Application integration components must be properly registered so that BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topics

Application Integration Components

Pipeline Components in Visual Basic

Pipeline Components in Visual C++


EnableDesign Method

Configures the component for execution in one of two modes: design mode or execution mode.

Member List

IPipelineComponent

|--EnableDesign

|--Execute

Method Declaration

[Visual Basic]

Sub EnableDesign( _

Enable As Boolean _

)

[C++]

HRESULT EnableDesign(

BOOL Enable

);

Parameters

Enable

[in] Indicates the mode of the component. True specifies that the component runs in design mode. False specifies execution mode. The default value is False.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The pipeline component runs in execution mode by default.

This method is called when the Override messaging port defaults page is opened in the Channel Wizard's Advanced Configuration page. It is also called when the property page is closed and the Enable parameter is set to true. Design mode is not enabled unless this method has been called with the Enable parameter set to True.

Design-only fields are returned only when the Enable parameter is set to true. Otherwise, the IDictionary object passed to the server contains unnecessary information.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


Execute Method

Executes the operation expected of the component, given the transport IDictionary object and other configuration settings.

Member List

IPipelineComponent

|--EnableDesign

|--Execute

Method Declaration

[Visual Basic]

Function Execute( _

DispOrder As Object, _

DispContext As Object, _

Flags As Long _

) As Long

[C++]

HRESULT Execute(

IDispatch* DispOrder,

IDispatch* DispContext,

long Flags,

long* ErrorLevel

);

Parameters

DispOrder

[in] Transport IDictionary object.

DispContext

[in] Not supported for this release.

Flags

[in] Reserved.

ErrorLevel

[out, retval] Reserved.

Return Values

In Visual Basic, this method returns the error level.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Microsoft BizTalk Server 2002 calls this method, passing in the transport IDictionary object. The component can read these IDictionary object values, perform the necessary functions, and optionally write new values back to the transport IDictionary object for further processing.

For a component designed to run in BizTalk Server 2002, the first parameter is a Transport Dictionary object. The Transport Dictionary values can be read by the component for processing. The string values supplied by the server for all application integration components (AICs) are defined in the Handling Data Passed to AICs topic.

For a component that runs in a Commerce Server order-processing pipeline, the first parameter contains the OrderForm object.

This method is called at run time when the server is sending a document to the component. This method is called immediately after the SetConfigData method of the IPipelineComponentAdmin interface. The document is passed in the first parameter as a dictionary within the working_data field of the IDictionary object. Components can add the ResponseField key to the IDictionary object to pass back a text-based response to an application, using the SubmitSync method of the IInterchange interface.

The component must raise an error if a problem with processing occurs so that the server can retry transmission later and, after all retries, send the document to the Suspended queue. If no error is returned, the server assumes that the component successfully processed the data.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


IPipelineComponentAdmin

Gets and sets configuration information for a component. Use IPipelineComponentAdmin between the component and the component user interface.

Hierarchy

IDispatch

|--IPipelineComponentAdmin

Declaration

[Visual Basic]

Class IPipelineComponentAdmin

[C++]

interface IPipelineComponentAdmin : IDispatch

Members

IPipelineComponentAdmin defines the following methods:

Method | Description
GetConfigData | Returns an IDictionary object that contains the configuration data for the component to be used to display these values.
SetConfigData | The SetConfigData method sets the configuration for a component, using the contents of an IDictionary object.

Remarks

Application integration components must be properly registered so that BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Application integration components register themselves with the category ID CATID_BIZTALK_AIC. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)

Related Topics

Application Integration Components

Pipeline Components in Visual Basic

Pipeline Components in Visual C++


GetConfigData Method

Returns an IDictionary object that contains the configuration data for the component to be used to display these values.

Member List

IPipelineComponentAdmin

|--GetConfigData

|--SetConfigData

Method Declaration

[Visual Basic]

Function GetConfigData() As Object

[C++]

HRESULT GetConfigData(

IDispatch** ConfigDictionary

);

Parameters

ConfigDictionary

[out, retval] In C++, an IDictionary object from which the user interface can read the configuration data. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method optionally returns a CDictionary object from which the user interface can read the configuration data.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

GetConfigData enables the user interface component to read the current value from the component and display it on the property page initially.

When an IBizTalkPort object is first saved, this method is called to get the defaults for use in autoconfiguring the application integration component (AIC) from the IDictionary object provided. Components must provide defaults for all mandatory properties, whenever possible.

This method is called when the user selects the property page. It is used to supply property page defaults. It is called again when the property page is closed. The contents of this returned IDictionary object are not used.

Components must always return a valid dictionary pointer from GetConfigData.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


SetConfigData Method

The SetConfigData method sets the configuration for a component, using the contents of an IDictionary object.

Member List

IPipelineComponentAdmin

|--GetConfigData

|--SetConfigData

Method Declaration

[Visual Basic]

Sub SetConfigData( _

ConfigDictionary As Object _

)

[C++]

HRESULT SetConfigData(

IDispatch* ConfigDictionary

);

Parameters

ConfigDictionary

[in] Contains an IDictionary object that contains the configuration information.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

With this method, the user interface can set or change these values. SetConfigData enables the user interface to write the updated value from the property page to the component.

The server calls SetConfigData when the property page is saved. It is used to verify the values entered by the user on the property page. The contents of this provided IDictionary object are also stored in the database.

This method is called immediately before the Execute method of the IPipelineComponent interface at run time, when the server is ready to send a document to the component. Data stored during design time from autoconfiguration or from property-page updates is passed to the component to allow for property setup prior to calling Execute.

Components validate the properties provided in SetConfigData and raise an error if any of the properties are invalid or missing.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: pipecomp.h
Library: Microsoft Commerce 2000 Default Pipeline Components Type Library (pipecomplib.tlb)


ISchemaImporter

Handles the importing of DTDs, XDRs, and well-formed XML documents.

Hierarchy

IDispatch

|--ISchemaImporter

Declaration

[Visual Basic]

Class ISchemaImporter

[C++]

interface ISchemaImporter : IDispatch

Members

ISchemaImporter defines the following properties:

Property | Description
ImportFormatDescription | Contains descriptive text about a supported import format.
ImportFormatIcon | Contains an icon for a supported import format.
NumberOfSupportedImportFormats | Contains the number of supported data formats from which a schema can be extracted.

ISchemaImporter defines the following method:

Method | Description
ExtractXMLSchema | Extracts a schema from a document.

Remarks

Custom XML import components must be properly registered so that Microsoft BizTalk Server 2002 can recognize that they belong to BizTalk Server 2002. Custom XML import components register themselves with the category ID CATID_BIZTALK_IDocSpecExtension. The CATIDs are defined in the bts_sdk_guids.h file. For more information, see Registering Custom Components.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ExtractXMLSchema Method

Extracts a schema from a document.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Method Declaration

[Visual Basic]

Function ExtractXMLSchema( _

FormatIndex As Long, _

DocumentPath As String _

) As Object

[C++]

HRESULT ExtractXMLSchema(

long FormatIndex ,

BSTR DocumentPath ,

IDispatch** SchemaDOM

);

Parameters

FormatIndex

[in] Contains an index value that specifies the type of document from which to import the schema. Use the value 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

DocumentPath

[in] Contains the path to the document from which to import the schema.

SchemaDOM

[out, retval] In C++, contains an IDispatch interface that contains the extracted XML schema. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this method returns an Object that contains information about the extracted XML schema.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ImportFormatDescription Property

Contains descriptive text about a supported import format.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Property Declaration

[Visual Basic]

Property ImportFormatDescription( _

FormatIndex As Long _

) As String

[C++]

HRESULT get_ImportFormatDescription(

long FormatIndex ,

BSTR* Description

);

Parameters

FormatIndex

[in] Contains an index value that specifies the type of document from which to import the schema. Use the value 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

Description

[out, retval] In C++, contains a textual description of the input document format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a textual description of the input document format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ImportFormatIcon Property

Contains an icon for a supported import format.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Property Declaration

[Visual Basic]

Property ImportFormatIcon( _

FormatIndex As Long _

) As Long

[C++]

HRESULT get_ImportFormatIcon(

long FormatIndex,

long* IconID

);

Parameters

FormatIndex

[in] Contains an index value that specifies the type of document from which to import the schema. Use the value 0 to import well-formed XML, 1 to import a document type definition (DTD), or 2 to import an XDR schema.

IconID

[out, retval] In C++, contains the icon identifier for the input format. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the icon identifier for the input format.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read only-property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


NumberOfSupportedImportFormats Property

Contains the number of supported data formats from which a schema can be extracted.

Member List

ISchemaImporter

|--ExtractXMLSchema

|--ImportFormatDescription

|--ImportFormatIcon

|--NumberOfSupportedImportFormats

Property Declaration

[Visual Basic]

Property NumberOfSupportedImportFormats As Long

[C++]

HRESULT get_NumberOfSupportedImportFormats(

long* Number

);

Parameters

Number

[out, retval] In C++, indicates the number of supported import formats. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of supported import formats.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterError

Identifies and deciphers errors or warnings.

Hierarchy

IDispatch

|--ISchemaImporterError

Declaration

[Visual Basic]

Class ISchemaImporterError

[C++]

interface ISchemaImporterError : IDispatch

Members

ISchemaImporterError defines the following properties:

Property | Description
IsWarning | Contains a value that identifies the object as an error or a warning.
NodePath | Contains the path to the node that generated the error or warning.
Text | Contains the error or warning message.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


IsWarning Property

Contains a value that identifies the object as an error or a warning.

Member List

ISchemaImporterError

|--IsWarning

|--NodePath

|--Text

Property Declaration

[Visual Basic]

Property IsWarning As Boolean

[C++]

HRESULT get_IsWarning(

VARIANT_BOOL* IsWarning

);

Parameters

IsWarning

[out, retval] In C++, contains a value that indicates whether or not the object is a warning. VARIANT_TRUE indicates that this is a warning object; VARIANT_FALSE indicates that this is an error object. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the object is a warning. True indicates that this is a warning object; False indicates that this is an error object.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


NodePath Property

Contains the path to the node that generated the error or warning.

Member List

ISchemaImporterError

|--IsWarning

|--NodePath

|--Text

Property Declaration

[Visual Basic]

Property NodePath As String

[C++]

HRESULT get_NodePath(

BSTR* NodePath

);

Parameters

NodePath

[out, retval] In C++, contains the fully qualified name of the node that generated the error or warning. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the fully qualified name of the node that generated the error or warning.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Text Property

Contains the error or warning message.

Member List

ISchemaImporterError

|--IsWarning

|--NodePath

|--Text

Property Declaration

[Visual Basic]

Property Text As String

[C++]

HRESULT get_Text(

BSTR* errText

);

Parameters

errText

[out, retval] In C++, contains the text associated with the error or warning. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the text associated with the error or warning.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


ISchemaImporterErrorProvider

Returns errors or warnings.

Hierarchy

IDispatch

|--ISchemaImporterErrorProvider

Declaration

[Visual Basic]

Class ISchemaErrorProvider

[C++]

interface ISchemaErrorProvider : IDispatch

Members

ISchemaImporterErrorProvider defines the following properties:

Property | Description
Error | Contains the error or warning.
NumberOfErrors | Contains the number of errors or warnings.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Error Property

Contains the error or warning.

Member List

ISchemaImporterErrorProvider

|--Error

|--NumberOfErrors

Property Declaration

[Visual Basic]

Property Error( _

Index As Long _

) As ISchemaImporterError

[C++]

HRESULT get_Error(

long Index,

IschemaImporterError** Error

);

Parameters

Index

[in] Contains the index of the error or warning.

Error

[out, retval] In C++, contains an ISchemaImporterError interface that contains the error or warning. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a SchemaImporterError object that contains the error or warning.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


NumberOfErrors Property

Contains the number of errors or warnings.

Member List

ISchemaImporterErrorProvider

|--Error

|--NumberOfErrors

Property Declaration

[Visual Basic]

Property NumberOfErrors As Long

[C++]

HRESULT get_NumberOfErrors(

long* NumberOfErrors

);

Parameters

NumberOfErrors

[out, retval] In C++, indicates the number of errors. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of errors.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SchemaImporter.h
Library: Microsoft BizTalk Server Import Extension Module 1.0 Type Library (ExtensionMod.dll)


Enumerations

The following enumerations provide possible property and parameter values:

  • CONNECTION_TYPE

  • DTA_ACK_STATUS

  • FUNC_CATEGORY

  • FUNC_TYPE

  • GeneratedReceiptLevel

  • SCRIPT_CATEGORY


CONNECTION_TYPE

Specifies the connection type.

[Visual Basic]

Enum CONNECTION_TYPE

[C++]

enum CONNECTION_TYPE

Members

CONNECT_TYPE_NONE

[0] The connection type is none.

CONNECT_TYPE_FIELD

[1] The connection type is field.

CONNECT_TYPE_RECORD

[2] The connection type is record.

CONNECT_TYPE_RECORD_CONTENT

[4] The connection type is record content.

CONNECT_TYPE_FUNC_STRING

[8] The connection type function is string.

CONNECT_TYPE_FUNC_MATH

[16] The connection type function is mathematical.

CONNECT_TYPE_FUNC_DATACONV

[32] The connection type function is data conversion.

CONNECT_TYPE_FUNC_DATETIME_FMT

[64] The connection type function is date/time format.

CONNECT_TYPE_FUNC_SCIENTIFIC

[128] The connection type function is scientific.

CONNECT_TYPE_FUNC_BOOLEAN

[256] The connection type function is Boolean.

CONNECT_TYPE_FUNC_SCRIPTER

[1024] The connection type function is script.

CONNECT_TYPE_FUNC_COUNT

[2048] The connection type function is count.

CONNECT_TYPE_FUNC_INDEX

[2048] The connection type function is index.

CONNECT_TYPE_FUNC_CUMULATIVE

[4096] The connection type function is cumulative.

CONNECT_TYPE_FUNC_VALUE_MAPPING

[8192] The connection type function is value mapping.

CONNECT_TYPE_FUNC_LOOPING

[16384] The connection type function is looping.

CONNECT_TYPE_FUNC_ITERATION

[32768] The connection type function is iteration.

CONNECT_TYPE_FUNC_DBLOOKUP

[65536] The connection type function is database lookup.

CONNECT_TYPE_FUNC_DBEXTRACT

[131072] The connection type function is database extraction.

CONNECT_TYPE_ALL

[-1] The connection type includes all connection types.

CONNECT_TYPE_ALL_EXCEPT_RECORD

[-3] The connection type includes all connection types except records.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionParameter


DTA_ACK_STATUS

Indicates the acknowledgement status.

[Visual Basic]

Enum DTA_ACK_STATUS

[C++]

enum DTA_ACK_STATUS

Members

DTA_ACK_NONE

[0] No receipt is expected.

DTA_ACK_PENDING

[1] The receipt is expected but has not yet arrived.

DTA_ACK_OVERDUE

[2] The receipt has timed out.

DTA_ACK_ACCEPTED

[3] The receipt has arrived with a status of accepted.

DTA_ACK_PARTIALLY_ACCEPTED

[4] The receipt has arrived with a status of accepted with errors.

DTA_ACK_REJECTED

[5] The receipt has arrived with a status of rejected.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSDocTracking.h
Library: Microsoft BizTalk Server Doc Tracking 1.0 Type Library (CISDTA.dll)

Related Topics

AckDocument

AckGroup

AckInterchange


FUNC_CATEGORY

Defines the values to specify the functoid palette on which the custom functoid will appear.

[Visual Basic]

Enum FUNC_CATEGORY

[C++]

enum FUNC_CATEGORY

Members

FUNC_CATEGORY_STRING

[3] The function category is string.

FUNC_CATEGORY_MATH

[4] The function category is mathematical.

FUNC_CATEGORY_DATACONV

[5] The function category is data conversion.

FUNC_CATEGORY_DATETIME_FMT

[6] The function category is date/time format.

FUNC_CATEGORY_SCIENTIFIC

[7] The function category is scientific.

FUNC_CATEGORY_BOOLEAN

[8] The function category is Boolean.

FUNC_CATEGORY_SCRIPTER

[9] The function category is script.

FUNC_CATEGORY_COUNT

[10] The function category is count. This value is not supported for this release.

FUNC_CATEGORY_INDEX

[11] The function category is index.

FUNC_CATEGORY_CUMULATIVE

[12] The function category is cumulative.

FUNC_CATEGORY_VALUE_MAPPING

[13] The function category is value mapping. This value is not supported for this release.

FUNC_CATEGORY_LOOPING

[14] The function category is looping. This value is not supported for this release.

FUNC_CATEGORY_ITERATION

[15] The function category is iteration. This value is not supported for this release.

FUNC_CATEGORY_DBLOOKUP

[16] The function category is database lookup. It is not recommended to add custom functoids to the Database tab on the functoid palette. See the note following this table for information on adding functoids to the Advanced tab.

FUNC_CATEGORY_DBEXTRACT

[17] The function category is database extraction. It is not recommended to add custom functoids to the Database tab on the functoid palette. See the note following this table for information on adding functoids to the Advanced tab.

FUNC_CATEGORY_UNKNOWN

[31] The function category is unknown.

Remarks

Custom functoids using a category value between 18 and 31 appear on the Advanced tab in the functoid palette.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionDescripter


FUNC_TYPE

Specifies the function type.

[Visual Basic]

Enum FUNC_TYPE

[C++]

enum FUNC_TYPE

Members

FUNC_TYPE_STD

[1] The function type is standard.

FUNC_TYPE_VARIABLEINPUT

[2] The function type is variable input.

FUNC_TYPE_SCRIPTOR

[3] The function type is script.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionDescripter


GeneratedReceiptLevel

Specifies the generated receipt level.

This enumeration is only supported in C++.

enum GeneratedReceiptLevel

Members

NoReceiptGenerated

[0] No receipt is created.

DocReceiptGenerated

[1] A receipt is generated for each document.

GroupReceiptGenerated

[2] A receipt is generated for each group.

InterchangeReceiptGenerated

[3] A receipt is generated for each interchange.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: BTSParserComps.h

Related Topics

GetNextDocument


SCRIPT_CATEGORY

Specifies the script category.

[Visual Basic]

Enum SCRIPT_CATEGORY

[C++]

enum SCRIPT_CATEGORY

Members

SCRIPT_CATEGORY_VBSCRIPT

[0] The custom functoid function is written in the Microsoft Visual Basic Scripting Edition (VBScript) language.

SCRIPT_CATEGORY_JSCRIPT

[1] The custom functoid function is written in the Microsoft JScript language.

SCRIPT_CATEGORY_XSLSCRIPT

[2] The custom functoid function is written in the Extensible Stylesheet Language (XSL). This value is not supported for this release.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: Functoid.h
Library: Microsoft BizTalk Server Canned Functoids 1.0 Type Library (CannedFunctoid.dll)

Related Topics

GetFunctionDescripter


Orchestration Services Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, and properties exposed for accessing orchestration services:

  • Interfaces

In addition, a complete list of Error Messages is provided.


Interfaces

The following COM interfaces are documented:

  • IWFGroupAdmin

  • IWFProxy

  • IWFSystemAdmin

  • IWFWorkflowInstance


IWFGroupAdmin

Allows a client application to control running instances of an XLANG schedule. Use IWFGroupAdmin to stop, suspend, resume, and retrieve information about all the schedule instances associated with a group manager.

Hierarchy

IDispatch

|--IWFGroupAdmin

Declaration

[Visual Basic]

Class IWFGroupAdmin

[C++]

interface IWFGroupAdmin : IDispatch

Members

IWFGroupAdmin defines the following properties:

Property | Description
Count | Contains the number of running XLANG schedule instances associated with this group manager.
FullyQualifiedName | Contains the moniker of this group manager.
InstanceIsResident | Contains a value that indicates whether the specified XLANG schedule instance is currently resident in memory.
InstanceIsSuspended | Contains a value that indicates whether the specified XLANG schedule instance is currently in a suspended state.
Name | Contains the name of this group manager.
UseFileDSN | Contains a value that indicates whether a Data Source Name (DSN) file is used for dehydrating the XLANG schedule instances.

IWFGroupAdmin defines the following methods:

Method | Description
ResumeInstance | Resumes the execution of an XLANG schedule instance in a suspended state.
Shutdown | Stops the group manager and dehydrates all running XLANG schedule instances.
Startup | Starts all the dehydrated XLANG schedule instances for the current group manager.
SuspendInstance | Pauses the running XLANG schedule instance in its current state.
TerminateInstance | Stops execution of the running XLANG schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Accessing Group Managers

XLANG Interfaces


Count Property

Contains the number of running XLANG schedule instances associated with this group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] In C++, contains the number of running schedule instances associated with this group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of running schedule instances associated with this group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


FullyQualifiedName Property

Contains the moniker of this group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] In C++, contains the moniker of this group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of this group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Although a group manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the default XLANG Scheduler Group Manager, named XLANG Scheduler, is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com!XLANG Scheduler.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Moniker Syntax


InstanceIsResident Property

Contains a value that indicates whether the specified XLANG schedule instance is currently resident in memory.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property InstanceIsResident( _

InstanceId As String _

) As Boolean

[C++]

HRESULT get_InstanceIsResident(

BSTR InstanceId,

VARIANT_BOOL* IsResident

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance.

IsResident

[out, retval] In C++, contains a value that indicates whether or not the specified schedule instance is currently resident in memory. VARIANT_TRUE indicates that the specified schedule instance is currently resident in memory; VARIANT_FALSE indicates that the specified schedule instance is not currently resident in memory. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the specified schedule instance is currently resident in memory. True indicates that the specified schedule instance is currently resident in memory; False indicates that the specified schedule instance is not currently resident in memory.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


InstanceIsSuspended Property

Contains a value that indicates whether the specified XLANG schedule instance is currently in a suspended state.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property InstanceIsSuspended( _

InstanceId As String _

) As Boolean

[C++]

HRESULT get_InstanceIsSuspended(

BSTR InstanceId,

VARIANT_BOOL* IsSuspended

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance.

IsSuspended

[out, retval] In C++, contains a value that indicates whether or not the specified schedule instance is currently in a suspended state. VARIANT_TRUE indicates that the specified schedule instance is currently in a suspended state; VARIANT_FALSE indicates that the specified schedule instance is not currently in a suspended state. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the specified schedule instance is currently in a suspended state. VARIANT_TRUE indicates that the specified schedule instance is currently in a suspended state; VARIANT_FALSE indicates that the specified schedule instance is not currently in a suspended state.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

This property should be checked prior to calling the ResumeInstance method.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Name Property

Contains the name of this group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Name As String

[C++]

HRESULT get_Name(

BSTR* Name

);

[
Parameters

Name

[out, retval] In C++, contains the name of this group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of this group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

This property is the same as the name of the hosting COM+ application.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ResumeInstance Method

Resumes the execution of an XLANG schedule instance in a suspended state.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub ResumeInstance( _

InstanceId As String _

)

[C++]

HRESULT ResumeInstance(

BSTR InstanceId

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance to be resumed.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The schedule instance can be paused with the SuspendInstance method. Prior to calling the ResumeInstance method, the InstanceIsSuspended property should be checked.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Shutdown Method

Stops the group manager and dehydrates all running XLANG schedule instances.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub Shutdown( )

[C++]

HRESULT Shutdown( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

Prior to stopping the group manager, all running schedule instances associated with this group manager are dehydrated to the database specified in the Data Source Name (DSN) file, and requests for activation of any new schedule instances are refused until shutdown is completed.

Any component that is bound in an XLANG schedule should not invoke this method to stop the group manager, as this can produce unexpected results.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Startup Method

Starts all the dehydrated XLANG schedule instances for the current group manager.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub Startup( )

[C++]

HRESULT Startup( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The XLANG Scheduler System Manager normally calls this method. Users should not call this method directly.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


SuspendInstance Method

Pauses the running XLANG schedule instance in its current state.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub SuspendInstance( _

InstanceId As String _

)

[C++]

HRESULT SuspendInstance(

BSTR InstanceId

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance to be suspended.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

The schedule instance can be restarted with the ResumeInstance method.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


TerminateInstance Method

Stops execution of the running XLANG schedule instance.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub TerminateInstance( _

InstanceId As String _

)

[C++]

HRESULT TerminateInstance(

BSTR InstanceId

);

Parameters

InstanceId

[in] Contains the globally unique identifier (GUID) assigned to the schedule instance to be stopped.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

A terminated schedule instance can never be restarted or resumed.

This method might block if actions with COM-bound ports are waiting for a method to complete, or if a short-lived transaction is currently in progress.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


UseFileDSN Property

Contains a value that indicates whether a Data Source Name (DSN) file is used for dehydrating the XLANG schedule instances.

Member List

IWFGroupAdmin

|--Count

|--FullyQualifiedName

|--InstanceIsResident

|--InstanceIsSuspended

|--Name

|--ResumeInstance

|--Shutdown

|--Startup

|--SuspendInstance

|--TerminateInstance

|--UseFileDSN

Property Declaration

[Visual Basic]

Property UseFileDSN As Boolean

[C++]

HRESULT get_UseFileDSN(

VARIANT_BOOL* UseFileDSN

);

Parameters

UseFileDSN

[out, retval] In C++, contains a value that indicates whether or not the group manager uses a DSN file for dehydrating schedule instances. VARIANT_TRUE indicates that the group manager uses a DSN file for dehydrating schedule instances; VARIANT_FALSE indicates that the group manager does not use a DSN file for dehydrating schedule instances. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the group manager uses a DSN file for dehydrating schedule instances. True indicates that the group manager uses a DSN file for dehydrating schedule instances; False indicates that the group manager does not use a DSN file for dehydrating schedule instances.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The value of this property is set when the group manager process is launched. The DSN setting in the COM+ catalog is changed either on the XLANG tab of the XLANG Scheduler Properties dialog box or by setting the UseFileDSN property on the IWFSystemAdmin interface. If the DSN value is changed while the group manager is running, the value of this property is not dynamically updated. The new value is not reflected until the next time the group manager is launched. Updates to this property require the caller to be in the XLANG Administrator role and are not normally performed by user code.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFProxy

Contains information about ports in an XLANG schedule instance that are bound to a COM component.

Hierarchy

IDispatch

|--IWFProxy

Declaration

[Visual Basic]

Class IWFProxy

[C++]

interface IWFProxy : IDispatch

Members

IWFProxy defines the following properties:

Property | Description
FullyQualifiedName | Contains the fully qualified name of a COM-bound port.
WorkflowInstance | Contains a reference to the current XLANG schedule instance.

Remarks

Use IWFProxy to obtain a schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Activating an XLANG Schedule Instance


FullyQualifiedName Property

Contains the fully qualified name of a COM-bound port.

Member List

IWFProxy

|--FullyQualifiedName

|--WorkflowInstance

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] Contains the moniker of the port. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of the port.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The moniker retrieved with this property can be used with the COM GetObject function to obtain a reference to the XLANG schedule instance. This moniker is valid as long as the schedule instance is running. If the schedule instance is dehydrated and rehydrated for any reason, such as rebooting the system, the moniker remains valid. Once the schedule instance completes, or ends by using the TerminateInstance method, the moniker can no longer be used.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


WorkflowInstance Property

Contains a reference to the current XLANG schedule instance.

Member List

IWFProxy

|--FullyQualifiedName

|--WorkflowInstance

Property Declaration

[Visual Basic]

Property WorkflowInstance As IWFWorkflowInstance

[C++]

HRESULT get_WorkflowInstance(

IWFWorkflowInstance** ScheduleInstance

);

Parameters

ScheduleInstance

[out, retval] Contains an IWFWorkflowInstance object that contains the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns an IWFWorkflowInstance object that contains the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


IWFSystemAdmin

Provides a client application with system-wide administrative control over the XLANG Scheduler Engine.

Hierarchy

IDispatch

|--IWFSystemAdmin

Declaration

[Visual Basic]

Class SysMgr

[C++]

interface IWFSystemAdmin : IDispatch

Members

IWFSystemAdmin defines the following properties:

Property | Description
Count | Contains the number of group managers associated with this XLANG Scheduler System Manager.
FullyQualifiedName | Contains the fully qualified DNS-style name of the XLANG Scheduler System Manager.
IsWorkflowHost | Contains a value that indicates whether the COM+ server application is an XLANG Scheduler Engine host.
Item | Contains a reference to the named schedule group.
UseFileDSN | Contains a value that indicates whether a COM+ server application uses a Data Source Name (DSN) file for dehydrating the XLANG schedule instances.

IWFSystemAdmin defines the following methods:

Method | Description
ShutdownAll | Stops the group managers and terminates their associated COM+ applications.
ShutdownApp | Stops a specific group manager application and terminates the associated COM+ application.
Startup | Starts all group managers.
TestAdminStatus | Determines whether a caller on IWFGroupAdmin is an XLANG Scheduler Engine administrator.

Remarks

Use IWFSystemAdmin to start, stop, and retrieve information about the group managers.

All XLANG Scheduler System Manager objects must have an associated Data Source Name (DSN) to support the dehydration and rehydration of long-running business processes. Therefore, you must create a DSN for the XLANG Scheduler System Manager by using the ODBC Data Source Administrator. XLANG schedules run by an XLANG Scheduler System Manager without a DSN configured will generate an error. For more information about creating a DSN, see Change the DSN settings for a COM+ application.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)

Related Topics

Accessing the XLANG Scheduler System Manager

XLANG Interfaces


Count Property

Contains the number of group managers associated with this XLANG Scheduler System Manager.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Count As Long

[C++]

HRESULT get_Count(

long* Count

);

Parameters

Count

[out, retval] Contains the number of running group managers. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the number of running group managers.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


FullyQualifiedName Property

Contains the fully qualified DNS-style name of the XLANG Scheduler System Manager.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] Contains the moniker of this XLANG Scheduler System Manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of this XLANG Scheduler System Manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Although an XLANG Scheduler System Manager can be instantiated through a local moniker, this property always includes the full Domain Name Services (DNS) style system name. For example, suppose the XLANG Scheduler System Manager is running on a computer named MyMachine in the domain vigorair-18.com. The FullyQualifiedName property would contain a value of sked://MyMachine.vigorair-18.com.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)

Related Topics

Moniker Syntax


IsWorkflowHost Property

Contains a value that indicates whether the COM+ server application is an XLANG Scheduler Engine host.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property IsWorkflowHost( _

AppName As String _

) As Boolean

[C++]

HRESULT get_IsWorkflowHost(

BSTR AppName,

VARIANT_BOOL* IsWorkflowHost

);

HRESULT put_IsWorkflowHost(

BSTR AppName,

VARIANT_BOOL IsWorkflowHost

);

Parameters

AppName

[in] Contains the COM+ server application name.

IsWorkflowHost

[out, retval], [in] In C++, contains a value that indicates whether or not the COM+ server application is hosting the XLANG Scheduler Engine. VARIANT_TRUE indicates that the COM+ server application is hosting the XLANG Scheduler Engine; VARIANT_FALSE indicates that the COM+ server application is not hosting the XLANG Scheduler Engine. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the COM+ server application is hosting the XLANG Scheduler Engine. True indicates that the COM+ server application is hosting the XLANG Scheduler Engine; False indicates that the COM+ server application is not hosting the XLANG Scheduler Engine.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This property cannot be set on the XLANG Scheduler Engine application, or on any COM+ application marked as read-only.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


Item Property

Contains a reference to the named schedule group.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property Item( _

GrpMgrName As String _

) As Unknown

[C++]

HRESULT get_Item(

BSTR GrpMgrName,

IUnknown** Item

);

Parameters

GrpMgrName

[in] Contains the group name corresponding to the hosting COM+ server application name. Group names are case sensitive and can contain spaces.

Item

[out, retval] Contains an object that refers to a group manager. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns an object that refers to a group manager.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


ShutdownAll Method

Stops the group managers and terminates their associated COM+ applications.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub ShutdownAll( )

[C++]

HRESULT ShutdownAll( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When the ShutdownAll method is called, new schedule activations are disabled and the shutdown notice is propagated to all running group managers. Once this method has completed, all group managers are stopped and the system can be safely rebooted.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


ShutdownApp Method

Stops a specific group manager application and terminates the associated COM+ application.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub ShutdownApp( _

AppName As String _

)

[C++]

HRESULT ShutdownApp(

BSTR AppName

);

Parameters

AppName

[in] Contains the COM+ server application name to be stopped.

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When the ShutdownApp method is called, new schedule activations on the named application are disabled and all running XLANG schedule instances associated with that application are stopped. If this method is called on the default XLANG Scheduler Group Manager, all group managers are shut down. Calling this method on the default XLANG Scheduler Group Manager is equivalent to calling the ShutdownAll method.

Note

  • The COM+ application name of the default XLANG Scheduler Group Manager is XLANG Scheduler.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


StartUp Method

Starts all group managers.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub StartUp( )

[C++]

HRESULT StartUp( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

When this method is invoked, rehydration is initiated for all group managers and, subsequently, all XLANG schedules. This method is asynchronous, and it can complete before all group managers and schedules are running.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


TestAdminStatus Method

Determines whether a caller on IWFSystemAdmin is an XLANG Scheduler Engine administrator.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Method Declaration

[Visual Basic]

Sub TestAdminStatus( )

[C++]

HRESULT TestAdminStatus( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This method is intended for internal use by the group managers.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


UseFileDSN Property

Contains a value that indicates whether a COM+ server application uses a Data Source Name (DSN) file for dehydrating the XLANG schedule instances.

Member List

IWFSystemAdmin

|--Count

|--FullyQualifiedName

|--IsWorkflowHost

|--Item

|--ShutdownAll

|--ShutdownApp

|--Startup

|--TestAdminStatus

|--UseFileDSN

Property Declaration

[Visual Basic]

Property UseFileDSN( _

AppName As String _

) As Boolean

[C++]

HRESULT get_UseFileDSN(

BSTR AppName,

VARIANT_BOOL* UseFileDSN

);

HRESULT put_UseFileDSN(

BSTR AppName,

VARIANT_BOOL* UseFileDSN

);

Parameters

AppName

[in] Contains the COM+ server application name.

UseFileDSN

[out, retval], [in] In C++, contains a value that indicates whether or not the COM+ server application uses a DSN file for dehydrating schedule instances. VARIANT_TRUE indicates that the COM+ server application uses a DSN file for dehydrating schedule instances; VARIANT_FALSE indicates that the COM+ server application does not use a DSN file for dehydrating schedule instances. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the COM+ server application uses a DSN file for dehydrating schedule instances. True indicates that the COM+ server application uses a DSN file for dehydrating schedule instances; False indicates that the COM+ server application does not use a DSN file for dehydrating schedule instances.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

If this property is changed while any group manager is running, the value of this property is not dynamically updated in the group managers. Therefore, the UseFileDSN property value exposed by IWFGroupAdmin contains an incorrect value. The updated value is not reflected until the next time the group manager is launched.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SysMgr.h
Library: XLANG Scheduler - System Manager (SKEDSMGR.dll)


IWFWorkflowInstance

Allows a client application to navigate the ports of an XLANG schedule instance, check the completion status, and determine whether the schedule instance completed successfully.

Hierarchy

IDispatch

|--IWFWorkflowInstance

Declaration

[Visual Basic]

Class IWFWorkflowInstance

[C++]

interface IWFWorkflowInstance : IDispatch

Members

IWFWorkflowInstance defines the following properties:

Property | Description
CompletionStatus | Contains a value that indicates the success or failure of the XLANG schedule instance.
FullPortName | Contains the full name of a port in a form usable by the associated technology.
FullyQualifiedName | Contains the fully qualified name of this XLANG schedule instance.
InstanceId | Contains the globally unique identifier (GUID) assigned to the current XLANG schedule instance.
IsCompleted | Contains a value that indicates whether the XLANG schedule instance has finished executing.
ModuleId | Contains the globally unique identifier (GUID) of the XML module associated with the current XLANG schedule instance.
ModuleName | Contains the name of the XML module associated with the current XLANG schedule instance.
ParentInstanceID | Contains the globally unique identifier (GUID) assigned to the parent XLANG schedule instance of the current schedule instance.
Port | Contains a reference to the named port. This is applicable only to COM-based port bindings.

IWFWorkflowInstance defines the following method:

Method | Description
WaitForCompletion | Waits until the current XLANG schedule instance completes executing.

Remarks

Use IWFWorkflowInstance to gather information about a specific, running schedule instance.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)

Related Topics

Accessing a Running XLANG Schedule Instance

XLANG Interfaces


CompletionStatus Property

Contains a value that indicates the success or failure of the XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property CompletionStatus As Long

[C++]

HRESULT get_CompletionStatus(

long* CompletionStatus

);

Parameters

CompletionStatus

[out, retval] Contains the completion status of the schedule instance. A value of 0 indicates success. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the completion status of the schedule instance. A value of 0 indicates success.

In C++, this property returns an HRESULT value, indicating success or failure.

Note

  • A return value of S_OK does not indicate that the processes or applications associated with the schedule instance completed successfully. It indicates only that the schedule instance was completely processed by the XLANG Scheduler Engine, without errors.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


FullPortName Property

Contains the full name of a port in a form usable by the associated technology.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property FullPortName( _

Port As String _

) As String

[C++]

HRESULT get_FullPortName(

BSTR Port,

BSTR* FullPortName

);

Parameters

Port

[in] Contains the name of the port to be retrieved.

FullPortName

[out, retval] Contains the full port name. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the full port name.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The full port name is returned in a form that is usable by the associated binding technology. For example, a port that is bound to a COM component returns a fully qualified moniker as the name of the port. For a port that is bound to Microsoft Message Queuing, this method returns the full path of the queue.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


FullyQualifiedName Property

Contains the fully qualified name of this XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property FullyQualifiedName As String

[C++]

HRESULT get_FullyQualifiedName(

BSTR* FullyQualifiedName

);

Parameters

FullyQualifiedName

[out, retval] Contains the moniker of the schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the moniker of the schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


InstanceId Property

Contains the globally unique identifier (GUID) assigned to the current XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property InstanceId As String

[C++]

HRESULT get_InstanceId(

BSTR* InstanceId

);

Parameters

InstanceId

[out, retval] Contains the GUID of the schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the GUID of the schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


IsCompleted Property

Contains a value that indicates whether the XLANG schedule instance has finished executing.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property IsCompleted As Boolean

[C++]

HRESULT get_IsCompleted(

VARIANT_BOOL* IsCompleted

);

Parameters

IsCompleted

[out, retval], In C++, contains a value that indicates whether or not the schedule instance has finished executing. VARIANT_TRUE indicates that the schedule instance has finished executing; VARIANT_FALSE indicates the schedule instance has not finished executing. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a value that indicates whether or not the schedule instance has finished executing. True indicates that the schedule instance has finished executing; False indicates the schedule instance has not finished executing.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ModuleId Property

Contains the globally unique identifier (GUID) of the XML module associated with the current XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property ModuleId As String

[C++]

HRESULT get_ModuleId(

BSTR* ModuleId

);

Parameters

ModuleId

[out, retval] Contains the GUID of the XLANG module associated with the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the GUID of the XLANG module associated with the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ModuleName Property

Contains the name of the XML module associated with the current XLANG schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property ModuleName As String

[C++]

HRESULT get_ModuleName(

BSTR* ModuleName

);

Parameters

ModuleName

[out, retval] Contains the name of the XLANG module associated with the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the name of the XLANG module associated with the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The module name is defined in the XLANG schedule (.skx) file.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


ParentInstanceID Property

Contains the globally unique identifier (GUID) assigned to the parent XLANG schedule instance of the current schedule instance.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property ParentInstanceID As String

[C++]

HRESULT get_ParentInstanceID(

BSTR* ParentInstanceID

);

Parameters

ParentInstanceID

[out, retval] Contains the GUID of the parent schedule instance of the current schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns the GUID of the parent schedule instance of the current schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

In C++, the property returns a NULL value if no parent schedule instance exists.

In Visual Basic, the property returns a Nothing value if no parent schedule instance exists.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Port Property

Contains a reference to the named port. This is applicable only to COM-based port bindings.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Property Declaration

[Visual Basic]

Property Port( _

Port As String _

) As Unknown

[C++]

HRESULT get_Port(

BSTR Port,

IUnknown** PortReference

);

Parameters

Port

[in] Contains the name of the port to which to obtain a reference.

PortReference

[out, retval] Contains a reference to a port in the current XLANG schedule instance. This parameter is not supported in Visual Basic. For more information, see "Return Values."

Return Values

In Visual Basic, this property returns a reference to a port in the current XLANG schedule instance.

In C++, this property returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Remarks

This is a read-only property.

The MK_E_NOOBJECT error code is returned if the moniker or port name passed in the Port parameter is incorrect.

In Visual Basic, the variable used for the port reference returned by using this property should be declared as a specific class or as a Variant. You can't obtain the port reference if you declare the variable as an Object since the port actually returns an IUnknown reference.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


WaitForCompletion Method

Waits until the current XLANG schedule instance completes executing.

Member List

IWFWorkflowInstance

|--CompletionStatus

|--FullPortName

|--FullyQualifiedName

|--InstanceId

|--IsCompleted

|--ModuleId

|--ModuleName

|--ParentInstanceID

|--Port

|--WaitForCompletion

Method Declaration

[Visual Basic]

Sub WaitForCompletion( )

[C++]

HRESULT WaitForCompletion( );

Parameters

None

Return Values

In Visual Basic, this method does not have a return value.

In C++, this method returns an HRESULT value, indicating success or failure.

Error Handling

In Visual Basic, if an error is raised, Err.Number is set to an HRESULT value.

In C++, if the call fails, an HRESULT value is returned.

Possible HRESULT values are documented in the Error Messages topic.

Requirements

Windows NT/2000: Windows 2000 SP2
Header: SkedCore.h
Library: XLANG Scheduler Runtime Type Library (SkedCore.dll)


Managing and Monitoring Reference

This section provides reference information about application programming interfaces (APIs) used by Microsoft BizTalk Server 2002 for both C++ and Microsoft Visual Basic programming.

Reference information is provided for all interfaces, methods, properties, and enumerations exposed for working with managing and monitoring BizTalk Server:

WMI Classes

In addition, a complete list of Error Messages is provided.


WMI Classes

The following COM interfaces are documented:

  • DocSuspendedEvent

  • InterchangeProvError

  • MicrosoftBizTalkServer_Group

  • MicrosoftBizTalkServer_GroupReceiveFunction

  • MicrosoftBizTalkServer_GroupServer

  • MicrosoftBizTalkServer_MgmtDB

  • MicrosoftBizTalkServer_Queue

  • MicrosoftBizTalkServer_ReceiveFunction

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_Server

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

  • MSBTS_CustomCounter

  • MSBTS_CustomCounterSetting

  • ReceiveFunctionDisabledEvent


DocSuspendedEvent

Represents events raised by documents sent to the Suspended queue.

Hierarchy

__ExtrinsicEvent

|--DocSuspendedEvent

Declaration

[Visual Basic]

Class DocSuspendedEvent

[C++]

class DocSuspendedEvent : __ExtrinsicEvent

Members

DocSuspendedEvent defines the following properties:

Property | Description
ChannelHandle | Contains the handle of the channel through which the suspended document was to be processed.
Destination | Contains the name of the destination organization to which the suspended document was to be processed.
DocName | Contains the name of the document definition designated as the input or output document for the channel through which the suspended document was to be processed.
PortHandle | Contains the handle of the messaging port attached to the channel through which the suspended document was to be processed.
Reason | Contains a value that indicates why the document was placed in the Suspended queue.
Source | Contains the name of the source organization from which the suspended document was to be processed.
State | Contains a value that indicates the state of the suspended document.
stringSuspendedGuid | Contains the tracking key of the item in the Suspended queue event.

Remarks

DocSuspendedEvent inherits from the __ExtrinsicEvent system class, an abstract base class that serves as a superclass for all user-defined event types.

The purpose of this event is to raise a notification when a document is delivered to the suspended queue because of a server processing error.

In the event that an administrator intentionally moves a document to the suspended queue using one of the following methods, a document suspended event will not be raised:

  • MoveToSuspendedQueue

  • MoveToSuspendedQueue

  • MoveToSuspendedQueue

Requirements

Windows NT/ Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ChannelHandle Property

Contains the handle of the channel through which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ChannelHandle;

Parameters

None

Return Values

Returns the handle of the channel through which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Destination Property

Contains the name of the destination organization to which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Destination;

Parameters

None

Return Values

Returns the name of the destination organization to which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocName Property

Contains the name of the document definition designated as the input or output document for the channel through which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocName;

Parameters

None

Return Values

Returns the name of the document definition designated as the input or output document for the channel through which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PortHandle Property

Contains the handle of the messaging port attached to the channel through which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 PortHandle;

Parameters

None

Return Values

Returns the handle of the messaging port attached to the channel through which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Reason Property

Contains a value that indicates why the document was placed in the Suspended queue.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 Reason;

Parameters

None

Return Values

Returns a value that indicates why the document was placed in the Suspended queue. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value for this property corresponds to the Suspended queue Error Description column in BizTalk Server Administration. BizTalk Server Administration translates this value into an error string. For more information, see Suspended Queue.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Source Property

Contains the name of the source organization from which the suspended document was to be processed.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Source;

Parameters

None

Return Values

Returns the name of the source organization from which the suspended document was to be processed.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


State Property

Contains a value that indicates the state of the suspended document.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 State;

Parameters

None

Return Values

Returns a value that indicates the state of the suspended document. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The tables in this section show the possible processing states of a document or interchange in the Suspended queue.

Documents in the states listed in the following table are at the interchange level, so you should use the ViewInterchange method to view the data. In addition, interchanges in these states cannot be resubmitted, so in this case you should not call Resubmit.

Value | State
0 | Initial
1 | Custom component
2 | Parsing

Documents in the states listed in the following table are considered documents instead of interchanges, so you should use the ViewDocument method to view the data. In addition, documents in the document validation state (3) cannot be resubmitted, so for those documents you should not call Resubmit.

Value | State
3 | Document validation
4 | Channel selection
5 | Field tracking
6 | Correlating
7 | Mapping
8 | Serializing

Documents in the states listed in the following table are considered interchanges, so you should use the ViewInterchange method to view the data.

Value | State
9 | Encoding
10 | Signing
11 | Encrypting
12 | Transmitting

Note that the ViewErrorDescription method can be used to retrieve error description information about failed documents and interchanges.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


stringSuspendedGuid Property

Contains the tracking key of the item in the Suspended queue event.

Member List

DocSuspendedEvent

|--ChannelHandle

|--Destination

|--DocName

|--PortHandle

|--Reason

|--Source

|--State

|--stringSuspendedGuid

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string stringSuspendedGuid;

Parameters

None

Return Values

Returns the tracking key of the item in the Suspended queue event. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The tracking key of the item in the Suspended queue event is based on a GUID.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


InterchangeProvError

Represents error information returned by the interchange provider when creating class instances.

Hierarchy

__ExtendedStatus

|--InterchangeProvError

Declaration

[Visual Basic]

Class InterchangeProvError

[C++]

class InterchangeProvError : __ExtendedStatus

Members

InterchangeProvError defines the following property:

Property | Description
InterchangeProvName | Contains the name of the interchange provider returning error information.

Remarks

InterchangeProvError inherits from the __ExtendedStatus system class, which is used to report detailed status and error information.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


InterchangeProvName Property

Contains the name of the interchange provider returning error information.

Member List

InterchangeProvError

|--InterchangeProvName

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string InterchangeProvName;

Parameters

None

Return Values

Returns the name of the interchange provider returning error information.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_Group

Represents a logical grouping of a specific number of BizTalk Servers in an enterprise. It is the management abstraction for global BizTalk Server properties.

Hierarchy

MicrosoftBizTalkServer_Group

Declaration

[Visual Basic]

Class Group

[C++]

class MicrosoftBizTalkServer_Group

Members

MicrosoftBizTalkServer_Group defines the following properties:

Property | Description
ConfigurationCacheRefreshInterval | Contains a value that indicates how often the server refreshes the cache of the BizTalk Messaging Configuration objects, in seconds.
ConnectToDbStatus | Contains a value that indicates the status of the connection to the Tracking and Shared Queue databases.
DateModified | Contains a value that indicates the last modification date of the instance data.
DocTrackDbName | Contains the database name component of the connect string for the Tracking database.
DocTrackDbServer | Contains the server name component of the connect string for the Tracking database.
EnableDocumentTracking | Contains a value that indicates whether document tracking is enabled or disabled.
LoggingPointState | Contains a collection of flags that indicate the events that cause a Tracking entry to be logged.
Name | Contains the name of the server.
ParserOrder | Contains the CLSIDs of the parser components registered in the registry, sorted in parsing order.
ProxyHost | Contains the proxy host address.
ProxyLogon | Contains the proxy logon.
ProxyPassword | Contains the proxy password.
ProxyPort | Contains a value that indicates the proxy port number.
QueueDbName | Contains the database name component of the connect string for the Shared Queue database.
QueueDbServer | Contains the server name component of the connect string for the Shared Queue database.
ReliableMessagingReplyToURL | Contains the URL repository for reliable messaging.
RetryQueueCount | Contains a value that indicates the number of documents in the Retry queue.
ScheduledQueueCount | Contains a value that indicates the number of documents in the Scheduled queue.
SMTPHost | Contains the name of the Simple Mail Transfer Protocol (SMTP) host that is used for this group.
SuspendedQueueCount | Contains a value that indicates the number of documents in the Suspended queue.
UseProxyServer | Contains a value that indicates whether to use the proxy server.
WorkQueueCount | Contains a value that indicates the number of documents in the Work queue.

MicrosoftBizTalkServer_Group defines the following methods:

Method | Description
PurgeSuspendedQueue | Enables an administrator to remove all the documents in the Suspended queue.
RefreshParserListFromRegistry | Updates the list of parser components in the database, based on current components registered in the registry.

Remarks

MicrosoftBizTalkServer_Group is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ConfigurationCacheRefreshInterval Property

Contains a value that indicates how often the server refreshes the cache of the BizTalk Messaging Configuration objects, in seconds.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ConfigurationCacheRefreshInterval = 50;

Parameters

None

Return Values

Returns how often the server refreshes the cache of the BizTalk Messaging Configuration objects, in seconds.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

This property has a default value of 50.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ConnectToDbStatus Property

Contains a value that indicates the status of the connection to the Tracking and Shared Queue databases.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ConnectToDbStatus;

Parameters

None

Return Values

Returns the status of the connection to the Tracking and Shared Queue databases. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Permissible values for this property are "BothDbConnectOK", "DTAConnectFail", "SQConnectFail", and "BothConnectFail", which map to the integers 0, 1, 2, and 3, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the mapping:

Values {"BothDbConnectOK", "DTAConnectFail", "SQConnectFail",

"BothConnectFail"},

ValueMap{"0", "1", "2", "3"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DateModified Property

Contains a value that indicates the last modification date of the instance data.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime DateModified;

Parameters

None

Return Values

Returns the last modification date of the instance data.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocTrackDbName Property

Contains the database name component of the connect string for the Tracking database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocTrackDbName;

Parameters

None

Return Values

Returns the database name component of the connect string for the Tracking database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 123 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocTrackDbServer Property

Contains the server name component of the connect string for the Tracking database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocTrackDbServer;

Parameters

None

Return Values

Returns the server name component of the connect string for the Tracking database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 60 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


EnableDocumentTracking Property

Contains a value that indicates whether document tracking is enabled or disabled.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean EnableDocumentTracking = 1;

Parameters

None

Return Values

Returns a language-specific value representing true if document tracking is enabled; if data tracking is not enabled, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing true.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


LoggingPointState Property

Contains a collection of flags that indicate the events that cause a Tracking entry to be logged.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 LoggingPointState;

Parameters

None

Return Values

Returns a collection of flags that indicate the events that cause a Tracking entry to be logged. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "LogIncomingInterchange", "LogMIMEBlob", and "LogOutgoingInterchange", which map to the integers 0, 1, and 2, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the mapping:

Values{"LogIncomingInterchange", "LogMIMEBlob",

"LogOutgoingInterchange" },

BitMap{"0", "1", "2"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the server.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ParserOrder Property

Contains the CLSIDs of the parser components registered in the registry, sorted in parsing order.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ParserOrder[];

Parameters

None

Return Values

Returns the CLSIDs of the parser components registered in the registry, sorted in parsing order.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyHost Property

Contains the proxy host address.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProxyHost;

Parameters

None

Return Values

Returns the proxy host address.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyLogon Property

Contains the proxy logon.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProxyLogon;

Parameters

None

Return Values

Returns the proxy logon.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyPassword Property

Contains the proxy password.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProxyPassword;

Parameters

None

Return Values

Returns the proxy password.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-only. Due to security considerations, when you try to read this property, NULL is returned instead of the password value.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProxyPort Property

Contains a value that indicates the proxy port number.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ProxyPort = 80;

Parameters

None

Return Values

Returns the proxy port number.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 80.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PurgeSuspendedQueue Method

Enables an administrator to remove all the documents in the Suspended queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 PurgeSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QueueDbName Property

Contains the database name component of the connect string for the Shared Queue database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string QueueDbName;

Parameters

None

Return Values

Returns the database name component of the connect string for the Shared Queue database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 123 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QueueDbServer Property

Contains the server name component of the connect string for the Shared Queue database.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string QueueDbServer;

Parameters

None

Return Values

Returns the server name component of the connect string for the Shared Queue database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 60 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RefreshParserListFromRegistry Method

Updates the list of parser components in the database, based on current components registered in the registry.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 RefreshParserListFromRegistry();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ReliableMessagingReplyToURL Property

Contains the URL repository for reliable messaging.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ReliableMessagingReplyToURL;

Parameters

None

Return Values

Returns the URL repository for reliable messaging.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 512 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RetryQueueCount Property

Contains a value that indicates the number of documents in the Retry queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 RetryQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Retry queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ScheduledQueueCount Property

Contains a value that indicates the number of documents in the Scheduled queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ScheduledQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Scheduled queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SMTPHost Property

Contains the name of the SMTP host that is used for this group.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SMTPHost;

Parameters

None

Return Values

Returns the name of the SMTP host that is used for this group.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SuspendedQueueCount Property

Contains a value that indicates the number of documents in the Suspended queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 SuspendedQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Suspended queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


UseProxyServer Property

Contains a value that indicates whether to use the proxy server.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean UseProxyServer = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if a proxy server is used; if a proxy server is not used, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


WorkQueueCount Property

Contains a value that indicates the number of documents in the Work queue.

Member List

MicrosoftBizTalkServer_Group

|--ConfigurationCacheRefreshInterval

|--ConnectToDbStatus

|--DateModified

|--DocTrackDbName

|--DocTrackDbServer

|--EnableDocumentTracking

|--LoggingPointState

|--Name

|--ParserOrder

|--ProxyHost

|--ProxyLogon

|--ProxyPassword

|--ProxyPort

|--PurgeSuspendedQueue

|--QueueDbName

|--QueueDbServer

|--RefreshParserListFromRegistry

|--ReliableMessagingReplyToURL

|--RetryQueueCount

|--ScheduledQueueCount

|--SMTPHost

|--SuspendedQueueCount

|--UseProxyServer

|--WorkQueueCount

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 WorkQueueCount;

Parameters

None

Return Values

Returns the number of documents in the Work queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_GroupReceiveFunction

Allows you to retrieve all the receive functions in a group.

Hierarchy

MicrosoftBizTalkServer_GroupReceiveFunction

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_GroupReceiveFunction

[C++]

class MicrosoftBizTalkServer_GroupReceiveFunction

Members

MicrosoftBizTalkServer_GroupReceiveFunction defines the following properties:

Property | Description
Antecedent | Contains references to the properties of the BizTalk Server group.
Dependent | Contains references to the properties of the receive function that is associated with the BizTalk Server group.

Remarks

MicrosoftBizTalkServer_GroupReceiveFunction is an association class.

Associations are instances of association classes and are used to represent relationships between other WMI objects.

MicrosoftBizTalkServer_GroupReceiveFunction is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Antecedent Property

Contains references to the properties of the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupReceiveFunction

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_Group ref Antecedent;

Parameters

None

Return Values

Returns a value that references the properties of the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_Group object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Dependent property uniquely identifies an instance of the class.

This property is the parent component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Dependent Property

Contains references to the properties of the receive function that is associated with the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupReceiveFunction

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_ReceiveFunction ref Dependent;

Parameters

None

Return Values

Returns a value that references the properties of the receive function that is associated with the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_ReceiveFunction object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Antecedent property uniquely identifies an instance of the class.

This property is the child component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_GroupServer

Allows you to retrieve all the servers in a group.

Hierarchy

MicrosoftBizTalkServer_GroupServer

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_GroupServer

[C++]

class MicrosoftBizTalkServer_GroupServer

Members

MicrosoftBizTalkServer_GroupServer defines the following properties:

Property | Description
Antecedent | Contains references to the properties of the BizTalk Server group.
Dependent | Contains references to the properties of the server that is associated with the BizTalk Server group.

Remarks

MicrosoftBizTalkServer_GroupServer is an association class.

Associations are instances of association classes and are used to represent relationships between other WMI objects.

MicrosoftBizTalkServer_GroupServer is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Antecedent Property

Contains references to the properties of the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupServer

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_Group ref Antecedent;

Parameters

None

Return Values

Returns a value that references the properties of the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_Group object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Dependent property uniquely identifies an instance of the class.

This property is the parent component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Dependent Property

Contains references to the properties of the server that is associated with the BizTalk Server group.

Member List

MicrosoftBizTalkServer_GroupServer

|--Antecedent

|--Dependent

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

MicrosoftBizTalkServer_Server ref Dependent;

Parameters

None

Return Values

Returns a value that references the properties of the server that is associated with the BizTalk Server group. The returned reference is to an instance of a MicrosoftBizTalkServer_Server object.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Antecedent property uniquely identifies an instance of the class.

This property is the child component of an aggregation association.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_MgmtDB

Represents the BizTalk Messaging Management database.

Hierarchy

MicrosoftBizTalkServer_MgmtDB

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_MgmtDB

[C++]

class MicrosoftBizTalkServer_MgmtDB

Members

MicrosoftBizTalkServer_MgmtDB defines the following properties:

Property | Description
LocalServer | Contains the name of the class, identifying the instance of the class.
MgmtDbName | Contains the initial catalog component of the BizTalk Messaging Management database connect string and represents the database name.
MgmtDbServer | Contains the data source part of the BizTalk Messaging Management database connect string.

Remarks

MicrosoftBizTalkServer_MgmtDB is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


LocalServer Property

Contains the name of the class, which identifies the instance of the class.

Member List

MicrosoftBizTalkServer_MgmtDB

|--LocalServer

|--MgmtDbName

|--MgmtDbServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string LocalServer;

Parameters

None

Return Values

Returns the name of the class, which identifies the instance of the class.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MgmtDbName Property

Contains the initial catalog component of the BizTalk Messaging Management database connect string and represents the database name.

Member List

MicrosoftBizTalkServer_MgmtDB

|--LocalServer

|--MgmtDbName

|--MgmtDbServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string MgmtDbName;

Parameters

None

Return Values

Returns the initial catalog component of the BizTalk Messaging Management database connect string and represents the database name.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 123 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MgmtDbServer Property

Contains the data source part of the BizTalk Messaging Management database connect string.

Member List

MicrosoftBizTalkServer_MgmtDB

|--LocalServer

|--MgmtDbName

|--MgmtDbServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string MgmtDbServer;

Parameters

None

Return Values

Returns the data source part of the BizTalk Messaging Management database connect string.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 60 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_Queue

Provides a set of properties inherited by Retry queue, Scheduled queue, Suspended queue, and Work queue objects.

Hierarchy

MicrosoftBizTalkServer_Queue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_Queue

[C++]

class MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_Queue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
Group | Contains the name of the group to which the queue belongs.
QID | Contains a value that identifies an instance of the class.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

Remarks

MicrosoftBizTalkServer_Queue serves only as a base for new classes. This class is abstract and should not be implemented.

The following interfaces inherit properties from MicrosoftBizTalkServer_Queue:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Destination Property

Contains the name of the organization or application that receives the document.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Destination;

Parameters

None

Return Values

Returns the name of the organization or application that receives the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 512 characters.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Group Property

Contains the name of the group to which the queue belongs.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Group;

Parameters

None

Return Values

Returns the name of the group to which the queue belongs.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the QID property uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QID Property

Contains a value that identifies an instance of the class.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 QID;

Parameters

None

Return Values

Returns a value that identifies an instance of the class.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property acts as a key for the class; its value along with the value of the Group property uniquely identifies an instance of the class.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Source Property

Contains the name of the organization or application that sends the document.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Source;

Parameters

None

Return Values

Returns the name of the organization or application that sends the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 64 characters.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Timestamp Property

Contains a value that indicates the last time the document was used or when it entered the queue.

Member List

MicrosoftBizTalkServer_Queue

|--Destination

|--Group

|--QID

|--Source

|--Timestamp

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime Timestamp;

Parameters

None

Return Values

Returns the last time the document was used or when it entered the queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

The following objects support this property:

  • MicrosoftBizTalkServer_RetryQueue

  • MicrosoftBizTalkServer_ScheduledQueue

  • MicrosoftBizTalkServer_SuspendedQueue

  • MicrosoftBizTalkServer_WorkQueue

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_ReceiveFunction

Represents a service that is set up on a BizTalk Server to handle incoming interchanges by using a specific protocol such as File, Message Queuing, or Script.

Hierarchy

MicrosoftBizTalkServer_ReceiveFunction

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_ReceiveFunction

[C++]

class MicrosoftBizTalkServer_ReceiveFunction

Members

MicrosoftBizTalkServer_ReceiveFunction defines the following properties:

Property | Description
ChannelName | Contains the name of the channel that the receive function should pass to the Submit method call when the pass-through flag is enabled.
Comment | Contains user comments.
DateModified | Contains a value that indicates the last modification date of the instance data.
DestinationID | Contains the ID of the organization or application that receives the document.
DestinationQualifier | Contains the ID type of the organization or application that receives the document.
DisableReceiveFunction | Contains a value that indicates whether to enable or disable the receive function.
DocumentName | Contains the name of the document definition for the input document of a channel.
EnvelopeName | Contains the name of an envelope definition instance in the BizTalk Messaging Management database.
FilenameMask | Contains the file name mask to use for receive functions that pull files from the file system for input to BizTalk Server.
GroupName | Contains the name of the group to which the server belongs.
HttpReturnContentType | Contains the name of the document type.
HttpReturnCorrelationToken | Contains a value that indicates whether to return a correlation token.
HttpTransportType | Contains the enumeration value used to represent the method used by the HTTP receive function to submit an interchange.
IsPassThrough | Contains a value that indicates whether a Submit method call is made with the pass-through flag enabled or disabled.
Name | Contains the name of the component.
OpennessFlag | Contains a value that indicates the value of the Openness parameter that the receive function passes to the Submit method.
Password | Contains the password to use for File Transfer Protocol (FTP) or Message Queuing receive functions that require a user name and password.
PollingLocation | Contains the name of the directory to poll (directory, message queue, and so on) for receive functions that require polling.
PreProcessor | Contains a value that indicates any preprocessing that must be done for a received document.
ProcessingServer | Contains the name of the server that is currently processing the interchange.
ProtocolType | Contains the enumeration value used to represent the type of the receive function component.
SourceID | Contains the ID of the organization or application that sends the document.
SourceQualifier | Contains the ID type of the organization or application that sends the document.
TransportURL | Contains the transport URL, indicating how and where the HTTP receive function submits the document.
Username | Contains the user name to use for FTP or Message Queuing receive functions.

Remarks

MicrosoftBizTalkServer_ReceiveFunction is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ChannelName Property

Contains the name of the channel that the receive function should pass to the Submit method call when the pass-through flag is enabled.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ChannelName;

Parameters

None

Return Values

Returns the name of the channel that the receive function should pass to the Submit method call when the pass-through flag is enabled. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Comment Property

Contains user comments.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Comment;

Parameters

None

Return Values

Returns user comments.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DateModified Property

Contains a value that indicates the last modification date of the instance data.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime DateModified;

Parameters

None

Return Values

Returns the last modification date of the instance data.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestinationID Property

Contains the ID of the organization or application that receives the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestinationID;

Parameters

None

Return Values

Returns the ID of the organization or application that receives the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestinationQualifier Property

Contains the ID type of the organization or application that receives the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestinationQualifier;

Parameters

None

Return Values

Returns the ID type of the organization or application that receives the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DisableReceiveFunction Property

Contains a value that indicates whether to enable or disable the receive function.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean DisableReceiveFunction = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if the receive function is disabled; if the receive function is enabled, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocumentName Property

Contains the name of the document definition for the input document of a channel.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocumentName;

Parameters

None

Return Values

Returns the name of the document definition for the input document of a channel.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


EnvelopeName Property

Contains the name of an envelope definition instance in the BizTalk Messaging Management database.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string EnvelopeName;

Parameters

None

Return Values

Returns the name of an envelope definition instance in the BizTalk Messaging Management database.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


FilenameMask Property

Contains the file name mask to use for receive functions that pull files from the file system for input to BizTalk Server.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string FilenameMask;

Parameters

None

Return Values

Returns the file name mask to use for receive functions that pull files from the file system for input to BizTalk Server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupName Property

Contains the name of the group to which the server belongs.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupName;

Parameters

None

Return Values

Returns the name of the group to which the server belongs.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


HttpReturnContentType Property

Contains the name of the document type.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string HttpReturnContentType;

Parameters

None

Return Values

Returns the name of the document type.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


HttpReturnCorrelationToken Property

Contains a value that indicates whether to return a correlation token.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean HttpReturnCorrelationToken = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if the correlation token is returned; if the correlation token is not returned, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


HttpTransportType Property

Contains the enumeration value used to represent the method used by the HTTP receive function to submit an interchange.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 HttpTransportType;

Parameters

None

Return Values

Returns the enumeration value used to represent the method used by the HTTP receive function to submit an interchange. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "File", "Submit", and "SubmitSync", which map to the integers 1, 2, and 3, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the values:

Values {"File", "Submit", "SubmitSync"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


IsPassThrough Property

Contains a value that indicates whether a Submit method call is made with the pass-through flag enabled or disabled.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean IsPassThrough = 0;

Parameters

None

Return Values

Returns a language-specific value representing true if the pass-through flag is enabled; if the pass-through flag is disabled, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is a language-specific value representing false.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the component.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the component.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


OpennessFlag Property

Contains a value that indicates the value of the Openness parameter that the receive function passes to the Submit method.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 OpennessFlag;

Parameters

None

Return Values

Returns the value of the Openness parameter that the receive function passes to the Submit method. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "NotOpen", "OpenSource", and "OpenDestination", which map to the integers 0, 1, and 2, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the values:

Values {"NotOpen", "OpenSource", "OpenDestination"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Password Property

Contains the password to use for FTP or Message Queuing receive functions that require a user name and password.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Password;

Parameters

None

Return Values

Returns the password to use for FTP or Message Queuing receive functions that require a user name and password.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-only. Due to security considerations, when you try to read this property, NULL is returned instead of the password value.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PollingLocation Property

Contains the name of the directory to poll (directory, message queue, and so on) for receive functions that require polling.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string PollingLocation;

Parameters

None

Return Values

Returns the name of the directory to poll (directory, message queue, and so on) for receive functions that require polling.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 260 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


PreProcessor Property

Contains a value that indicates any preprocessing that must be done for a received document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string PreProcessor;

Parameters

None

Return Values

Returns a value indicating any preprocessing that must be done for a received document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that is currently processing the interchange.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that is currently processing the interchange.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProtocolType Property

Contains the enumeration value used to represent the type of the receive function component.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ProtocolType;

Parameters

None

Return Values

Returns the enumeration value used to represent the type of the receive function component. For more information, see "Remarks".

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Permissible values for this property are "File", "MSMQ", and "HTTP", which map to the integers 1, 2, and 3, respectively. Note that the integer values must be used in code and script.

The following code is taken from the MOF file (InterchangeProvSchema.mof), and shows the values:

Values {"File", "MSMQ", "HTTP"}

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SourceID Property

Contains the ID of the organization or application that sends the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SourceID;

Parameters

None

Return Values

Returns the ID of the organization or application that sends the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SourceQualifier Property

Contains the ID type of the organization or application that sends the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SourceQualifier;

Parameters

None

Return Values

Returns the ID type of the organization or application that sends the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 64 characters.

This property is provided for custom receive functions. The value of this property can be a phone number, a Dunn & Bradstreet number, and so on.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


TransportURL Property

Contains the transport URL, indicating how and where the HTTP receive function submits the document.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string TransportURL;

Parameters

None

Return Values

Returns the transport URL, indicating how and where the HTTP receive function submits the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

This property is provided for custom receive functions.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Username Property

Contains the user name to use for FTP or Message Queuing receive functions.

Member List

MicrosoftBizTalkServer_ReceiveFunction

|--ChannelName

|--Comment

|--DateModified

|--DestinationID

|--DestinationQualifier

|--DisableReceiveFunction

|--DocumentName

|--EnvelopeName

|--FilenameMask

|--GroupName

|--HttpReturnContentType

|--HttpReturnCorrelationToken

|--HttpTransportType

|--IsPassThrough

|--Name

|--OpennessFlag

|--Password

|--PollingLocation

|--PreProcessor

|--ProcessingServer

|--ProtocolType

|--SourceID

|--SourceQualifier

|--TransportURL

|--Username

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Username;

Parameters

None

Return Values

Returns the user name to use for FTP or Message Queuing receive functions.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_RetryQueue

Represents a logical grouping of interchanges in the Shared queue that are awaiting receipt correlation, or interchanges that are due to be sent to multiple destinations.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_RetryQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_RetryQueue

[C++]

class MicrosoftBizTalkServer_RetryQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_RetryQueue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
Group | Contains the name of the group to which the queue belongs.
LastRetryTime | Contains a value that indicates the last time the server attempted a transmission.
ProcessingServer | Contains the name of the server that last processed the document.
QID | Contains a value that identifies an instance of the class.
RemainingRetryCount | Contains a value that indicates the number of outstanding retries remaining.
RetryInterval | Contains a value that indicates the wait time between retry intervals, in minutes.
ServiceWindowFromTime | Contains a value that indicates the start time of the service window in which to send interchanges.
ServiceWindowToTime | Contains a value that indicates the end time of the service window in which to send interchanges.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_RetryQueue defines the following method:

Method | Description
MoveToSuspendedQueue | Enables the administrator to move the selected document to the Suspended queue.

Remarks

MicrosoftBizTalkServer_RetryQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


LastRetryTime Property

Contains a value that indicates the last time the server attempted a transmission.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime LastRetryTime;

Parameters

None

Return Values

Returns the last time the server attempted a transmission.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MoveToSuspendedQueue Method

Enables the administrator to move the selected document to the Suspended queue.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 MoveToSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

Calling this method will not raise a DocSuspendedEvent.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that last processed the document.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that last processed the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This is a read-only property.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RemainingRetryCount Property

Contains a value that indicates the number of outstanding retries remaining.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 RemainingRetryCount;

Parameters

None

Return Values

Returns the number of outstanding retries remaining.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RetryInterval Property

Contains a value that indicates the wait time between retry intervals, in minutes.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 RetryInterval;

Parameters

None

Return Values

Returns the wait time between retry intervals, in minutes.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowFromTime Property

Contains a value that indicates the start time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowFromTime;

Parameters

None

Return Values

Returns the start time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowToTime Property

Contains a value that indicates the end time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_RetryQueue

|--LastRetryTime

|--MoveToSuspendedQueue

|--ProcessingServer

|--RemainingRetryCount

|--RetryInterval

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowToTime;

Parameters

None

Return Values

Returns the end time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_ScheduledQueue

Represents a logical grouping of interchanges in the Shared queue that are scheduled to be delivered at a later time based on a service window.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_ScheduledQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_ScheduledQueue

[C++]

class MicrosoftBizTalkServer_ScheduledQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_ScheduledQueue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
Group | Contains the name of the group to which the queue belongs.
ProcessingServer | Contains the name of the server that last processed the document.
QID | Contains a value that identifies an instance of the class.
ServiceWindowFromTime | Contains a value that indicates the start time of the service window in which to send interchanges.
ServiceWindowToTime | Contains a value that indicates the end time of the service window in which to send interchanges.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_ScheduledQueue defines the following method:

Method | Description
MoveToSuspendedQueue | Enables the administrator to move the selected document to the Suspended queue.

Remarks

MicrosoftBizTalkServer_ScheduledQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MoveToSuspendedQueue Method

Enables the administrator to move the selected document to the Suspended queue.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 MoveToSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

Calling this method will not raise a DocSuspendedEvent.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that last processed the document.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that last processed the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowFromTime Property

Contains a value that indicates the start time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowFromTime;

Parameters

None

Return Values

Returns the start time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in interval format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceWindowToTime Property

Contains a value that indicates the end time of the service window in which to send interchanges.

Member List

MicrosoftBizTalkServer_ScheduledQueue

|--MoveToSuspendedQueue

|--ProcessingServer

|--ServiceWindowFromTime

|--ServiceWindowToTime

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime ServiceWindowToTime;

Parameters

None

Return Values

Returns the end time of the service window in which to send interchanges.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in interval format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_Server

Represents specific Windows 2000 computers within a BizTalk Server group that are running BizTalk Messaging Services.

Hierarchy

MicrosoftBizTalkServer_Server

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_Server

[C++]

class MicrosoftBizTalkServer_Server

Members

MicrosoftBizTalkServer_Server defines the following properties:

Property | Description
DateModified | Contains the date of the last modification of the instance data.
GroupName | Contains the name of the group to which the server belongs.
MaxRecvSvcThreadsPerProcessor | Contains the maximum number of receive function threads that BizTalk Server can use per processor for asynchronous calls.
MaxWorkerThreadsPerProcessor | Contains the maximum number of worker threads that BizTalk Server can use per processor for asynchronous calls.
Name | Contains the name of the server.
ParticipateInWorkItemProcessing | Contains a value that indicates whether the server participates in work-item processing.
SchedulerWaitTime | Contains the time interval that BizTalk Server Scheduler waits between tries, in milliseconds.
ServiceState | Contains a value that indicates the state of the BizTalk services on a particular server.

MicrosoftBizTalkServer_Server defines the following methods:

Method | Description
FreeInterchanges | Frees interchanges that are currently assigned to a specific server if the server is stopped, removed, or in an error state, so that other servers can use these interchanges.
RegisterServerInAD | Registers the BizTalk Server in the Microsoft Active Directory.
StartServer | Starts the BizTalk services on a specific server.
StopServer | Stops the BizTalk services on a specific server.
UnregisterServerInAD | Unregisters the BizTalk Server in the Microsoft Active Directory.

Remarks

MicrosoftBizTalkServer_Server is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DateModified Property

Contains the date of the last modification of the instance data.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

datetime DateModified;

Parameters

None

Return Values

Returns the date of the last modification of the instance data.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The value of this property is in date and time format.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


FreeInterchanges Method

Frees interchanges that are currently assigned to a specific server if the server is stopped, removed, or in an error state, so that other servers can use these interchanges.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 FreeInterchanges();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupName Property

Contains the name of the group to which the server belongs.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupName;

Parameters

None

Return Values

Returns the name of the group to which the server belongs.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MaxRecvSvcThreadsPerProcessor Property

Contains the maximum number of receive function threads that BizTalk Server can use per processor for asynchronous calls.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 MaxRecvSvcThreadsPerProcessor = 4;

Parameters

None

Return Values

Returns the maximum number of receive function threads that BizTalk Server can use per processor for asynchronous calls.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 4.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MaxWorkerThreadsPerProcessor Property

Contains the maximum number of worker threads that BizTalk Server can use per processor for asynchronous calls.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 MaxWorkerThreadsPerProcessor = 4;

Parameters

None

Return Values

Returns the maximum number of worker threads that BizTalk Server can use per processor for asynchronous calls.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 4.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ParticipateInWorkItemProcessing Property

Contains a value that indicates whether the server participates in work-item processing.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

boolean ParticipateInWorkItemProcessing = 1;

Parameters

None

Return Values

Returns a language-specific value representing true if the server participates in work-item processing; if the server does not participate in work-item processing, this property returns a language-specific value representing false.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is TRUE.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


RegisterServerInAD Method

Registers the BizTalk Server in the Microsoft Active Directory.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 RegisterServerInAD();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SchedulerWaitTime Property

Contains the time interval that BizTalk Server Scheduler waits between tries, in milliseconds.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 SchedulerWaitTime = 2000;

Parameters

None

Return Values

Returns the time interval that BizTalk Server Scheduler waits between tries, in milliseconds.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

The default value for this property is 2,000 milliseconds.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ServiceState Property

Contains a value that indicates the state of the BizTalk services on a particular server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ServiceState;

Parameters

None

Return Values

Returns the state of the BizTalk services on a particular server.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


StartServer Method

Starts the BizTalk services on a specific server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 StartServer();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The execution of this method is valid any time the specific server is stopped.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


StopServer Method

Stops the BizTalk services on a specific server.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 StopServer();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The execution of this method is valid any time the specific server is running.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


UnregisterServerInAD Method

Unregisters the BizTalk Server in the Microsoft Active Directory.

Member List

MicrosoftBizTalkServer_Server

|--DateModified

|--FreeInterchanges

|--GroupName

|--MaxRecvSvcThreadsPerProcessor

|--MaxWorkerThreadsPerProcessor

|--Name

|--ParticipateInWorkItemProcessing

|--RegisterServerInAD

|--SchedulerWaitTime

|--ServiceState

|--StartServer

|--StopServer

|--UnregisterServerInAD

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 UnregisterServerInAD();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_SuspendedQueue

Represents a logical grouping of interchanges in the Shared queue that could not be successfully processed.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_SuspendedQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_SuspendedQueue

[C++]

class MicrosoftBizTalkServer_SuspendedQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_SuspendedQueue defines the following properties:

Property | Description
ChannelHandle | Contains the handle of the channel used for processing the interchange or document in the Suspended queue.
Destination | Contains the name of the organization or application that receives the document.
DocName | Contains the name of the document definition related to the document in the queue.
ErrorDescription | Contains the first 64 characters of the error description.
Group | Contains the name of the group to which the queue belongs.
QGUID | Contains the submission GUID of the Suspended queue work item.
QID | Contains a value that identifies an instance of the class.
Size | Contains the approximate size of the interchange or document in the Suspended queue, in bytes.
Source | Contains the name of the organization or application that sends the document.
State | Contains a value that indicates the state of the document or interchange in the Suspended queue.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_SuspendedQueue defines the following methods:

Method | Description
Resubmit | Enables an administrator to resubmit the selected document to the server.
ViewDocument | Enables an administrator to view the contents of a selected document in the Suspended queue.
ViewErrorDescription | Enables the administrator to view a description of the error.
ViewInterchange | Enables the administrator to view the contents of a selected interchange in the Suspended queue.

Remarks

MicrosoftBizTalkServer_SuspendedQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ChannelHandle Property

Contains the handle of the channel used for processing the interchange or document in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 ChannelHandle;

Parameters

None

Return Values

Returns the handle of the channel used for processing the interchange or document in the Suspended queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocName Property

Contains the name of the document definition related to the document in the queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocName;

Parameters

None

Return Values

Returns the name of the document definition related to the document in the queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ErrorDescription Property

Contains the first 64 characters of the error description.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ErrorDescription;

Parameters

None

Return Values

Returns the first 64 characters of the error description.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 64 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


QGUID Property

Contains the submission GUID of the Suspended queue work item.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string QGUID;

Parameters

None

Return Values

Returns the submission GUID of the Suspended queue work item.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Resubmit Method

Enables an administrator to resubmit the selected document to the server.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 Resubmit();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This method enables an administrator to resubmit interchanges after problems have been fixed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Size Property

Contains the approximate size of the interchange or document in the Suspended queue, in bytes.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 Size;

Parameters

None

Return Values

Returns the approximate size of the interchange or document in the Suspended queue, in bytes.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


State Property

Contains a value that indicates the state of the document or interchange in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 State;

Parameters

None

Return Values

Returns the state of the document or interchange in the Suspended queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The tables in this section show the possible processing states of a document or interchange in the Suspended queue.

Documents in the states listed in the following table are at the interchange level, so you should use the ViewInterchange method to view the data. In addition, interchanges in these states cannot be resubmitted, so in this case you should not call Resubmit.

Value | State
0 | Initial
1 | Custom component
2 | Parsing

Documents in the states listed in the following table are considered documents instead of interchanges, so you should use the ViewDocument method to view the data. In addition, documents in the document validation state (3) cannot be resubmitted, so for those documents you should not call Resubmit.

Value | State
3 | Document validation
4 | Channel selection
5 | Field tracking
6 | Correlating
7 | Mapping
8 | Serializing

Documents in the states listed in the following table are considered interchanges, so you should use the ViewInterchange method to view the data.

Value | State
9 | Encoding
10 | Signing
11 | Encrypting
12 | Transmitting

Note that the ViewErrorDescription method can be used to retrieve error description information about failed documents and interchanges.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ViewDocument Method

Enables an administrator to view the contents of a selected document in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--QID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 ViewDocument(

uint8 Document[],

uint32 CodePage

);

Parameters

Document

[out] An array of bytes, representing the information in the document. This data may need to be converted into a readable format. The maximum size for this parameter is 4 MB. If the data exceeds 4 MB, the data will be truncated. For more information, see "Remarks".

CodePage

[out] The code page of the document. For more information, see "Remarks".

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The following table shows the possible values for the CodePage parameter and their meanings.

Value | Description
-1 | No code page available
0 | Default system code page
1200 | Unicode code page
1252 | ASCII code page

If the value returned in the CodePage parameter is 0 or 1200, the data can be displayed and no conversion is needed. However, if the value is -1, you should try loading the data into Microsoft XML (MSXML).

If the value returned in CodePage is 1252, you should try loading the data into MSXML. If this fails, you can use the MultiByteToWideChar function, passing in CodePage as the code page parameter to the Microsoft Win32® API.

If the data contained in the Document parameter is larger than 4 MB, C++ programmers can use the GetSuspendedQueueItemDetails method to retrieve the document.

ViewDocument is not available in a tools-only installation of BizTalk Server 2002.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ViewErrorDescription Method

Enables the administrator to view a description of the error.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 ViewErrorDescription(

string CompleteErrorDescription

);

Parameters

CompleteErrorDescription

[out] A string describing the error.

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ViewInterchange Method

Enables the administrator to view the contents of a selected interchange in the Suspended queue.

Member List

MicrosoftBizTalkServer_SuspendedQueue

|--ChannelHandle

|--DocName

|--ErrorDescription

|--QGUID

|--Resubmit

|--Size

|--State

|--ViewDocument

|--ViewErrorDescription

|--ViewInterchange

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 ViewInterchange(

uint8 Interchange[],

uint32 CodePage

);

Parameters

Interchange

[out] An array of bytes, representing the information in the interchange. This data may need to be converted into a readable format. The maximum size for this parameter is 4 MB. If the data exceeds 4 MB, the data will be truncated. For more information, see "Remarks".

CodePage

[out] The code page of the interchange. For more information, see "Remarks".

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

The following table shows the possible values for the CodePage parameter and their meanings.

Value | Description
-1 | No code page available
0 | Default system code page
1200 | Unicode code page
1252 | ASCII code page

If the value returned in the CodePage parameter is 0 or 1200, the data can be displayed and no conversion is needed. However, if the value is -1, you should try loading the data into MSXML.

If the value returned in CodePage is 1252, you should try loading the data into MSXML. If this fails, you can use the MultiByteToWideChar function, passing in CodePage as the codepage parameter to the Win32 API.

If the data contained in the Interchange parameter is larger than 4 MB, C++ programmers can use the GetSuspendedQueueItemDetails method to retrieve the interchange.

ViewInterchange is not available in a tools-only installation of BizTalk Server 2002.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MicrosoftBizTalkServer_WorkQueue

Represents a logical grouping of interchanges in the Shared queue that are currently in process.

Hierarchy

MicrosoftBizTalkServer_Queue

|--MicrosoftBizTalkServer_WorkQueue

Declaration

[Visual Basic]

Class MicrosoftBizTalkServer_WorkQueue

[C++]

class MicrosoftBizTalkServer_WorkQueue: MicrosoftBizTalkServer_Queue

Members

MicrosoftBizTalkServer_WorkQueue defines the following properties:

Property | Description
Destination | Contains the name of the organization or application that receives the document.
DocName | Contains the name of the document definition related to the document in the queue.
EngineState | Contains a value that indicates whether the work item is waiting for receipt correlation or waiting for transmission.
Group | Contains the name of the group to which the queue belongs.
ProcessingServer | Contains the name of the server that last processed the document.
QID | Contains a value that identifies an instance of the class.
Source | Contains the name of the organization or application that sends the document.
Timestamp | Contains a value that indicates the last time the document was used, or when it entered the queue.

MicrosoftBizTalkServer_WorkQueue defines the following method:

Method | Description
MoveToSuspendedQueue | Enables the administrator to move the selected document to the Suspended queue.

Remarks

MicrosoftBizTalkServer_WorkQueue is a dynamic class, supplied by the WMI provider "InterchangeProv" at run time as needed.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocName Property

Contains the name of the document definition related to the document in the queue.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocName;

Parameters

None

Return Values

Returns the name of the document definition related to the document in the queue.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


EngineState Property

Contains a value that indicates whether the work item is waiting for receipt correlation or waiting for transmission.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 EngineState;

Parameters

None

Return Values

Returns a value that indicates whether the work item is waiting for receipt correlation or waiting for transmission.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The possible values for this property are defined by the BTSCoreQueueStates enumeration, as shown in the following code:

typedef enum {

Processing = STATE_TRANSLATION,

Correlation = STATE_RECEIPT_CORRELATION,

TransmissionWServiceWindow = STATE_FIND_TRANSMISSION,

Transmission = STATE_TRANSMISSION

} BTSCoreQueueStates;

The following table provides the numerical values of the constants defined in the BTSCoreQueueStates enumeration.

Value | Constant
29 | Processing
30 | Correlation
31 | TransmissionWServiceWindow
33 | Transmission

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MoveToSuspendedQueue Method

Enables the administrator to move the selected document to the Suspended queue.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

type name;

uint32 MoveToSuspendedQueue();

Parameters

None

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

Calling this method will not raise a DocSuspendedEvent.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ProcessingServer Property

Contains the name of the server that last processed the document.

Member List

MicrosoftBizTalkServer_WorkQueue

|--DocName

|--EngineState

|--MoveToSuspendedQueue

|--ProcessingServer

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string ProcessingServer;

Parameters

None

Return Values

Returns the name of the server that last processed the document.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

The maximum length of this property is 63 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MSBTS_CustomCounter

Retrieves the value of the custom counter query.

Hierarchy

CIM_ManagedSystemElement

|--CIM_LogicalElement

|--MSBTS_CustomCounter

Declaration

[Visual Basic]

Class MSBTS_CustomCounter

[C++]

class MSBTS_CustomCounter : CIM_LogicalElement

Members

MSBTS_CustomCounter defines the following properties:

Property | Description
GroupCounterName | Contains the Tracking database and custom counter names.
MatchCount | Contains the number of documents that match the criteria specified by the custom counter setting.
Name | Contains the name of the custom counter.

Remarks

MSBTS_CustomCounter is derived from CIM_LogicalElement.

MSBTS_CustomCounter is a dynamic class that is automatically created for every instance of MSBTS_CustomCounterSetting.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupCounterName Property

Contains the Tracking database and custom counter names.

Member List

MSBTS_CustomCounter

|--GroupCounterName

|--MatchCount

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupCounterName;

Parameters

None

Return Values

This property returns the Tracking database and custom counter names.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

For a custom counter with a GroupName property of "BizTalk Server Group" and a Name property of "My Custom Counter", the value for this property would be "BizTalk Server Group\MyCustomCounter".

This property is required to distinguish between custom counters with the same name that monitor different DTA databases.

The maximum length of this property is 256 characters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MatchCount Property

Contains the number of documents that match the criteria specified by the custom counter setting.

Member List

MSBTS_CustomCounter

|--GroupCounterName

|--MatchCount

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 MatchCount;

Parameters

None

Return Values

This property returns the number of documents that match the query associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read-only.

Note that this property counts both inbound and outbound documents. For example, if a single document passes through the system and no mapping is performed, then MatchCount will be incremented by two.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the custom counter.

Member List

MSBTS_CustomCounter

|--GroupCounterName

|--MatchCount

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

This property returns the name of the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

Both MSBTS_CustomCounter and MSBTS_CustomCounterSetting share the same value for their key property, Name.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


MSBTS_CustomCounterSetting

Creates, deletes, and validates custom counters.

Hierarchy

CIM_Setting

|--MSBTS_CustomCounterSetting

Declaration

[Visual Basic]

Class MSBTS_CustomCounterSetting

[C++]

class MSBTS_CustomCounterSetting : CIM_Setting

Members

MSBTS_CustomCounterSetting defines the following properties:

Property | Description
DestOrgName | Contains the name of the destination organization associated with the custom counter.
DestQualifier | Contains the name of the destination qualifier type associated with the custom counter.
DestQualifierValue | Contains the value of the destination qualifier type associated with the custom counter.
DocType | Contains the name of the root element from the document schema.
GroupName | Contains the name of the BizTalk Server group against which the custom counter query executes.
Name | Contains the name of the custom counter.
SrcOrgName | Contains the name of the source organization associated with the custom counter.
SrcQualifier | Contains the name of the source qualifier type associated with the custom counter.
SrcQualifierValue | Contains the value of the source qualifier type associated with the custom counter.
TimeInterval | Contains the time over which to accumulate the custom counter query value, in seconds.

MSBTS_CustomCounterSetting defines the following method:

Method | Description
IsValid | Validates the custom counter creation parameters.

Remarks

MSBTS_CustomCounterSetting is derived from CIM_Setting.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestOrgName Property

Contains the name of the destination organization associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestOrgName;

Parameters

None

Return Values

This property returns the name of the destination organization associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

When the destination information is not explicitly declared in the messaging port the string value that is tracked for DstOrgName is "<OPEN DESTINATION>". For more information, see How Interchanges and Documents Are Logged.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestQualifier Property

Contains the name of the destination qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestQualifier;

Parameters

None

Return Values

This property returns the name of the destination qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DestQualifierValue Property

Contains the value of the destination qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DestQualifierValue;

Parameters

None

Return Values

This property returns the value of the destination qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


DocType Property

Contains the name of the root element from the document schema.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string DocType;

Parameters

None

Return Values

This property returns the name of the root element from the document schema.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

When a document specification is created using BizTalk Editor, you can specify the Document Type reference property to a user-defined string value. If the root XML element is not defined, the value of the Document Type reference property, if defined, will be tracked as the DocType value. For more information, see Set Reference Properties.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


GroupName Property

Contains the name of the BizTalk Server group against which the custom counter query executes.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string GroupName;

Parameters

None

Return Values

This property returns the name of the BizTalk Server group against which the custom counter query executes.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property is used to look up the database name, server, user name, and password, and to validate the custom counter parameters.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


IsValid Method

Validates the custom counter creation parameters.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Method Declaration

The syntax shown is language neutral. This method is supported in C++, Visual Basic, and VBScript.

uint32 IsValid(

boolean IsValidSrcOrg,

boolean IsValidSrcId,

boolean IsValidDestOrg,

boolean IsValidDestId,

boolean IsValidGroup

);

Parameters

IsValidSrcOrg

[out] Returns a language-specific value representing true if the source organization name is valid; otherwise, if the source organization name is not valid, this parameter returns a language-specific value representing false.

IsValidSrcId

[out] Returns a language-specific value representing true if the source identifier name is valid; otherwise, if the source identifier name is not valid, this parameter returns a language-specific value representing false.

IsValidDestOrg

[out] Returns a language-specific value representing true if the destination organization name is valid; otherwise, if the destination organization name is not valid, this parameter returns a language-specific value representing false.

IsValidDestId

[out] Returns a language-specific value representing true if the destination identifier name is valid; otherwise, if the destination identifier name is not valid, this parameter returns a language-specific value representing false.

IsValidGroup

[out] Returns a language-specific value representing true if the BizTalk Server group name is valid; otherwise, if the BizTalk Server group name is not valid, this parameter returns a language-specific value representing false.

Return Values

Returns an HRESULT value, indicating success or failure.

Error Handling

For information on error handling, see Handling WMI Errors.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

This property returns the name of the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

The value of this property acts as the key for the class; its value uniquely identifies an instance of the class.

The maximum length of this property is 256 characters.

Both MSBTS_CustomCounterSetting and MSBTS_CustomCounter share the same value for their key property, Name.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SrcOrgName Property

Contains the name of the source organization associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SrcOrgName;

Parameters

None

Return Values

This property returns the name of the source organization associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

When the source information is not explicitly declared in the channel, the string value that is tracked for SrcOrgName is "<OPEN SOURCE>". For more information, see How Interchanges and Documents Are Logged.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SrcQualifier Property

Contains the name of the source qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SrcQualifier;

Parameters

None

Return Values

Returns the name of the source qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


SrcQualifierValue Property

Contains the value of the source qualifier type associated with the custom counter.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string SrcQualifierValue;

Parameters

None

Return Values

Returns the value of the source qualifier type associated with the custom counter.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This property can accept a regular expression.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


TimeInterval Property

Contains the time over which to accumulate the custom counter query value, in seconds.

Member List

MSBTS_CustomCounterSetting

|--DestOrgName

|--DestQualifier

|--DestQualifierValue

|--DocType

|--GroupName

|--IsValid

|--Name

|--SrcOrgName

|--SrcQualifier

|--SrcQualifierValue

|--TimeInterval

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

uint32 TimeInterval;

Parameters

None

Return Values

Returns the time over which to accumulate the custom counter query value, in seconds.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is read/write.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: InterchangeProvSchema.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


ReceiveFunctionDisabledEvent

Represents events raised by disabled receive functions.

Hierarchy

__ExtrinsicEvent

|--ReceiveFunctionDisabledEvent

Declaration

[Visual Basic]

Class ReceiveFunctionDisabledEvent

[C++]

class ReceiveFunctionDisabledEvent : __ExtrinsicEvent

Members

ReceiveFunctionDisabledEvent defines the following property:

Property | Description
Name | Contains the name of the disabled receive function.

Remarks

ReceiveFunctionDisabledEvent inherits from the __ExtrinsicEvent system class, an abstract base class that serves as a superclass for all user-defined event types.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Name Property

Contains the name of the disabled receive function.

Member List

ReceiveFunctionDisabledEvent

|--Name

Property Declaration

The syntax shown is language neutral. This property is supported in C++, Visual Basic, and VBScript.

string Name;

Parameters

None

Return Values

Returns the name of the disabled receive function.

Error Handling

For information on error handling, see Handling WMI Errors.

Remarks

This property is write-on-create only. After creation, this property is read-only.

This event is raised when a receive function is disabled.

Requirements

Windows NT/Windows 2000: Windows 2000 SP2
Header and Library: Wbemidl.h, Wbemuuid.lib
MOF File: SrvEvents.mof
Scripting Library: Microsoft WMI Scripting V1.1 Library (wbemdisp.tlb)


Error Messages

The properties and methods of the BizTalk™ Messaging Services and BizTalk Orchestration Services object models use standard Component Object Model (COM) HRESULT return values to communicate whether the operation was successful or not.

In C++, these values are the actual return values from the methods themselves (including property get_ and put_ methods). The program must explicitly perform error checking by examining these return values, or use some variation of structured error handling.

In Microsoft® Visual Basic®, and in Microsoft Visual Basic Scripting Edition (VBScript), these values are placed in the Number property of the global Err object. Error handling is either handled automatically, displaying a standard error dialog box, or explicitly by the program, checking the value of the Number property of the global Err object. The On Error Resume Next command disables automatic error handling, thereby enabling explicit error handling.

For additional information about error message values, see the following sections:

  • Messaging Services Error Messages

  • Orchestration Services Error Messages

  • Standard COM Error Messages


Messaging Services Error Messages

The BizTalk Messaging Services object model error messages defined by BizTalk Server can be used in your application by including the bts_config_errors.h file located in the BizTalk Server installation directory at \Program Files\Microsoft BizTalk Server\SDK\Include. These error messages, returned during design time by the methods and properties of the object model, contain a BTS_ prefix in the message name. All other errors occur during run time, while BizTalk Server is processing a document.

The following table contains both design time and run time errors.

Message name | Value | Description
CIS_E_OBJECT_NOT_FOUND | 0x0100 | The object was not found.
CIS_E_STATE_NOT_FOUND | 0x0101 | The state engine state was not found in the messaging port definition.
CIS_E_STATE_TRANSITION | 0x0103 | The state table contains a bad engine state transition.
CIS_E_BAD_ENGINE_CONFIG_FILE | 0x0105 | The string that describes the input state configuration is not valid.
CIS_E_CANNOT_ADD_STATE | 0x0106 | BizTalk Server could not add the user-defined state to the system.
CIS_E_NO_COMPONENT_FOUND | 0x0107 | There is no component in the state definition or the ProgID is wrong.
CIS_E_PIPECOMP_ADMIN_REQUIRED | 0x0108 | The required IPipelineComponentAdmin interface was not found on the component.
CIS_E_BAD_COMPONENT_TYPE | 0x0109 | The component type specified for the state engine is not recognized.
CIS_E_BAD_STATE_CONFIG | 0x010A | The state configuration is not valid.
CIS_E_BAD_STATE_TYPE | 0x010B | The specified state type is not recognized.
CIS_E_BAD_COMPONENT_CONFIG | 0x010C | The component configuration is not valid.
CIS_E_INTERNAL_FAILURE | 0x010F | An internal server failure occurred due to an unknown cause.
CIS_E_CREATE_SCHEDULER_FAILED | 0x0111 | The Queue Scheduler for the service could not be created.
CIS_E_AGREEMENT_SELECT_FAILED | 0x0112 | No channels matched the input criteria. Verify that a messaging port and a channel exist, and that they match the following fields: Source qualifier: "%1" Source identifier value: "%2" Source document name: "%3" Destination qualifier: "%4" Destination identifier value: "%5" Also verify that any expressions specified for the channels are compatible with this document.
CIS_E_ERROR | 0x0113 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1
CIS_E_SERVICE_INITIALIZATION_FAILURE | 0x0114 | The service failed to start. Verify that this server is enlisted in a BizTalk Server group.
CIS_E_SCHEDULER_FAILED | 0x0115 | The Queue Scheduler failed and has exited.
CIS_E_WORKER_THREAD_FAILED | 0x0116 | A worker thread failed and has exited.
CIS_E_SHARED_QUEUE_DB_EXEC_FAILED | 0x0117 | Execution against the Shared Queue database has failed.
CIS_E_CANT_READ_WORK_ITEM | 0x0119 | A work item in the Shared Queue database cannot be read.
CIS_E_CHECKPOINT_FAILED | 0x011c | Checkpointing the work item failed.
CIS_E_CREATE_DEAD_WORK_ITEM_FAILED | 0x011e | A new work item in the Suspended queue cannot be created.
CIS_E_GET_SNAPSHOT_FAILED | 0x0122 | A snapshot of the Shared Queue database cannot be taken.
CIS_E_FREE_INTERCHANGES_FAILED | 0x0124 | The specified interchanges cannot be freed.
CIS_E_DELETE_INTERCHANGE_FAILED | 0x0125 | The specified interchange cannot be deleted.
CIS_E_RECEIVING_INTERCHANGE_FAILED | 0x0127 | The specified interchange was not received.
CIS_E_GETTING_NEXT_SCHEDULED_WORK_ITEM_FAILED | 0x0128 | The next scheduled work item cannot be obtained for processing.
CIS_E_GET_COUNT_FAILED | 0x0129 | The count on the shared queues cannot be obtained.
CIS_E_TRANSMISSION_FAILED | 0x012a | All retry transmissions failed.
CIS_W_TRANSMISSION_ATTEMPT_FAILED | 0x012b | A transmission attempt failed.
CIS_W_TRANSMISSION_XFER_TO_SECONDARY | 0x012c | The primary transport for messaging port "%1" cannot transmit the data. The server will switch to the secondary transport.
CIS_E_RECEIPT_GENERATION_FAILED | 0x012e | After creating the work item, the attempt to generate a receipt failed.
CIS_E_RECEIPT_GENERATION_FAILED_NO_WORK_ITEM | 0x012f | The attempt to generate a receipt failed before the work item was created.
CIS_E_L1_RECEIPT_CORRELATION_FAILED | 0x0130 | Receipt correlation failed.
CIS_E_AGREEMENT_LACKING_PARAMS | 0x0133 | At least one of the fields necessary to select a channel is missing. Verify that your document and envelopes extract the proper fields for the parser, or specify the necessary fields upon submission. Channel selection fields: Source identifier type: "%1" Source identifier value: "%2" Source document name: "%3" Destination identifier type: "%4" Destination identifier value: "%5"
CIS_E_AGREEMENT_FAILED | 0x0134 | The channel cannot be selected.
CIS_E_ORIGINAL_L1_INTERCHANGE_MISSING | 0x0135 | When trying to correlate an incoming receipt, the original interchange and related document(s) are no longer present.
CIS_E_UNEXPECTED_DB_BEHAVIOR | 0x0136 | An unexpected return occurred. The database may need to be restarted.
CIS_E_AGREEMENT_INVALID_MAP | 0x0137 | The map specified by the reference "%1" is not valid. Verify that the reference points to a valid map created by BizTalk Mapper.
CIS_I_SERVICE_MSG | 0x0138 | 1%
CIS_E_AGREEMENT_MAP_FAILED | 0x0139 | The XML document could not be translated. The map specified by reference "%1" failed. Verify that the map is up to date.
CIS_E_XML_ERROR | 0x013A | The XML document could not be parsed on line: %2, position: %3 for the following reason: "%1"
CIS_E_AGREEMENT_PROCESSING_FAILED | 0x013f | The server could not finish processing the document.
CIS_E_AGREEMENT_PROCESSING_FAILED_W_NAME | 0x0140 | The following channel configuration setting is not valid: "%1"
CIS_E_AGREEMENT_INVALID_QUERY | 0x0141 | The "%2" query for the "%1" document tracking field is not a valid XSL pattern. This pattern must be removed or corrected.
CIS_I_SERVICE_START | 0x0142 | The service has started.
CIS_I_SERVICE_STOP | 0x0143 | The service has stopped.
CIS_E_ERROR_EX | 0x0144 | An error occurred in BizTalk Server.%n %n Details:%n ------------------------------%n %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_E_ERROR_EX_HEAD | 0x0145 | An error occurred in BizTalk Server.
CIS_E_ERROR_EX_FOOT | 0x0146 |
CIS_E_INVALID_DATA_FORMAT | 0x0147 | The business document that was passed in is not in a recognized format and could not be parsed or decrypted.
CIS_E_CREATE_ENGINE | 0x0148 | BizTalk Server was unable to create a new instance of the processing engine to process a work item. This might be due to a failure to create a new COM+ transaction.
CIS_E_MISSING_DESTINATION_DOCUMENT_SPEC | 0x0149 | BizTalk Server has detected an incomplete messaging port. The destination specification is missing from the messaging port.
CIS_E_PROCESSING_THREAD_FAILED | 0x014A | The processing thread failed to start. This might be due to a failure to create the state engine.
CIS_E_NOSRCORG | 0x014B | No source organization that corresponds to the ID and Qualifier pair has been specified.
CIS_E_NODESTORG | 0x014C | No destination organization that corresponds to the Identifier and Qualifier pair has been specified.
CIS_E_NODOC | 0x014D | No document that corresponds to the document name has been specified.
CIS_E_NOPIPELINES | 0x014E | No channel that corresponds to the parameters has been specified.
CIS_E_NOT_RESUBMITTABLE | 0x014F | The state of the item in the Suspended queue does not allow resubmission.
CIS_E_PIPESELECT_POLICY_FAILED | 0x0150 | No channels matched the certificates that were found with the incoming data. The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_E_SUBMIT_INVALIDDOC | 0x0151 | The submitted document is not valid. See the following messages for more details.
CIS_E_SUBMITSYNC_TOOMANYDOCS | 0x0152 | The SubmitSync method failed because multiple documents where found within the data. Only one document is allowed per synchronous submission. If this is a structured flat-file submission, then the most common cause of failure is extra leading or trailing white space around the data.
CIS_E_SUBMITSYNC_TOOMANYPIPES | 0x0153 | The synchronous submission could not be completed because multiple valid channels matched the incoming document. Only one channel is allowed to match the incoming document.
CIS_E_XMIT_NOTRANSPORTCOMP | 0x0154 | This server could not create a component with the class ID "%1" for transport. Verify that this component is properly registered. The following error was returned:
CIS_E_XMIT_EMPTY_DOCUMENT | 0x0155 | Messaging port "%1" cannot transmit a zero-byte document.
CIS_E_XMIT_FAILED_W_NAME | 0x0156 | The server could not finish processing messaging port "%1".
CIS_E_XMIT_NO_INTERFACE | 0x0157 | The server could not obtain the "%1" interface from the transport component with CLSID "%2".
CIS_E_XMIT_NO_BTS_AIC_INTERFACES | 0x0158 | The server could not obtain either the "%1" or "%2" interfaces from the BizTalk Server application integration component with CLSID "%3".
CIS_E_XMIT_FAILED_W_DETAILS | 0x0159 | The server encountered a transport error while processing the messaging port "%1", which uses a transport component with a ProgID of "%2".
CIS_E_NOHDR_ERROR_EX | 0x015A | %1 %2 %3 %4 %5 %6 %7 %8 %9 %n
CIS_W_COMP_NOACK | 0x015B | The correlation component "%1" could not find a document for which to send a receipt. No action will be taken.
CIS_E_CORRELATIONCOMP_FAILED | 0x015C | The correlation component "%1" returned an unexpected failure. The document will be placed in the Suspended queue.
CIS_E_CORRELATION_FAILED | 0x015D | Receipt correlation processing failed.
CIS_E_XML_VALIDATE_ERROR | 0x015E | The XML document has failed validation for the following reason: %1
CIS_E_CHANNEL_ACCESSDENIED | 0x015F | The submitted document does not have the necessary signature or encryption required by channel "%3". The following certificates accompanied the submitted data: Signature certificate reference: "%1" Encryption certificate reference: "%2"
CIS_I_SERVICE_RESTARTING | 0x0160 | The service is restarting.
BTS_E_CONSTRAINT | 0x1201 | Constraint Error
BTS_E_NOOBJECT | 0x1202 | The object was not found.
BTS_E_INTERNALFAILURE | 0x1203 | An internal failure occurred.
BTS_E_ENVELOPE_CONTROLNUMBER | 0x120C | If the envelope format is set to X12 or EDIFACT, the control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_DELIMETER | 0x120D | If the envelope format is set to X12, then delimiters are required and must be set.
BTS_E_ENCRYPTION_CUSTOM_NOCLSID | 0x120E | If the encryption type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_ENCODING_CUSTOM_NOCLSID | 0x120F | If the encoding type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_SIGNATURE_CUSTOM_NOCLSID | 0x1210 | If the signature type is Custom, then the class identifier (CLSID) must also be specified.
BTS_E_INVALIDCONTROLNUMBER | 0x1212 | The control number value must be set to a number greater than or equal to 1.
BTS_E_ENVELOPE_INUSE | 0x1213 | The format of the envelope cannot be changed because it is used in a messaging port.
BTS_E_CHANNEL_MISSINGMAPSOURCE | 0x1215 | The channel is missing the MapSource node.
BTS_E_INVALID_CERT_USAGE | 0x1216 | The certificate is not valid for the current usage. An encryption certificate cannot be used for signing; nor can a signing certificate be used for encryption. Make sure that the correct certificate is selected.
BTS_E_MISSINGSMTPHOST | 0x1218 | The SMTP host is missing. The SMTP host can be configured in BizTalk Server Administration.
BTS_E_INVALID_ENCRYPT_STORE | 0x1219 | The encryption store type is not valid. The store type must be BIZTALK.
BTS_E_INVALID_SGNTCERT_STORE | 0x121A | The signature store type is not valid. The store type must be MY.
BTS_E_DATATOOLONG | 0x121B | The data length is too long.
BTS_E_INVALID_VERIFY_ENCRYPTCERT_STORE | 0x121C | The encryption verification store type is not valid. The store type must be MY.
BTS_E_INVALID_VERIFY_SGNTCERT_STORE | 0x121D | The signature verification store type is not valid. The store type must be BIZTALK.
BTS_E_ORGANIZATION_UNIQUE_ID | 0x121F | The organization identifier must be a unique identifier.
BTS_E_ORGANIZATION_UNIQUE_NAME | 0x1220 | The organization name must be a unique name.
BTS_E_OBJECT_ALREADY_EXISTS | 0x1221 | The object already exists. You cannot call the Create() method on a BizTalk Messaging Configuration object multiple times without also calling the Clear() or Remove() methods.
BTS_E_ALIAS_UNIQUE_ID | 0x1222 | The identifier must be a unique identifier.
BTS_E_ALIAS_UNIQUE_NAME | 0x1223 | The identifier name for this organization must be a unique name.
BTS_E_ALIAS_UNIQUE_QUALIFIERVALUE | 0x1225 | The identifier must have a unique qualifier-value pair.
BTS_E_ALIAS_FOREIGN_OWNERID | 0x1226 | The organization cannot be removed because it is referred to by an identifier.
BTS_E_XMLSHARE_UNIQUE_ID | 0x1227 | The primary identifier for the XML Share table in the SQL Server database must be a unique identifier.
BTS_E_XMLSHARE_UNIQUE_REFERENCE | 0x1228 | The reference for the XML Share table in the SQL Server database must be a unique reference.
BTS_E_DOCUMENT_UNIQUE_ID | 0x1229 | The document identifier must be a unique identifier.
BTS_E_DOCUMENT_UNIQUE_NAME | 0x122A | The document name must be a unique name.
BTS_E_DOCUMENT_FOREIGN_SHAREID | 0x122C | The XML Share table in the SQL Server database cannot be removed because it is referred to by a document.
BTS_E_ENVELOPE_UNIQUE_ID | 0x122D | The envelope identifier must be a unique identifier.
BTS_E_ENVELOPE_UNIQUE_NAME | 0x122E | The envelope name must be a unique name.
BTS_E_ENVELOPE_FOREIGN_SHAREID | 0x1230 | The XML Share table in the SQL Server database cannot be removed because it is referred to by an envelope.
BTS_E_CONTROLNUMBER_UNIQUE_ID | 0x1231 | The control-number identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_ID | 0x1232 | The distribution list identifier must be a unique identifier.
BTS_E_PORTGROUP_UNIQUE_NAME | 0x1233 | The distribution list name must be a unique name.
BTS_E_MISSING_VALUE | 0x1235 | The identifier value property must have a value.
BTS_E_MISSING_SRCORGID | 0x1236 | The Channel SourceOrganization property must have a value.
BTS_E_APPLICATION_UNIQUE_ID | 0x1237 | The application identifier must be a unique identifier.
BTS_E_APPLICATION_FOREIGN_OWNERID | 0x1238 | The organization cannot be removed because it is referred to by an application.
BTS_E_APPLICATION_UNIQUE_NAME | 0x1239 | For applications within this organization, the application name must be a unique name.
BTS_E_CHANNEL_UNIQUE_ID | 0x123A | The channel identifier must be a unique identifier.
BTS_E_CHANNEL_UNIQUE_NAME | 0x123B | The channel name must be a unique name.
BTS_E_CHANNEL_FOREIGN_INPDOCID | 0x123D | The inbound document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_OUTDOCID | 0x123E | The output document cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_PORTGROUPID | 0x123F | The distribution list cannot be removed because it is used by a channel.
BTS_E_CHANNEL_FOREIGN_SRCORGID | 0x1240 | The source organization cannot be removed because it is used by a channel.
BTS_E_ENVELOPE_INVALIDFORMAT | 0x1241 | The only valid envelope-format strings are: Custom, Custom XML, EDIFACT, Flatfile, X12, and Reliable. The previously specified format will remain unchanged.
BTS_E_CHANNEL_FOREIGN_CONTROLNUMID | 0x1242 | The control number cannot be removed because it is used by an channel.
BTS_E_PORT_UNIQUE_ID | 0x1243 | The messaging port identifier must be a unique identifier.
BTS_E_PORT_UNIQUE_NAME | 0x1244 | The messaging port name must be a unique name.
BTS_E_CHANNEL_FOREIGN_SRCAPPID | 0x1247 | The source application cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTORGID | 0x1248 | The destination organization cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_DSTALIASID | 0x1249 | The destination identifier cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_ENVID | 0x124A | The envelope cannot be removed because it is used by a messaging port.
BTS_E_CHANNEL_FOREIGN_SRCALIASID | 0x124B | The source identifier cannot be removed because it is used by a channel.
BTS_E_PORT_FOREIGN_DSTAPPID | 0x124C | The destination application cannot be removed because it is used by a messaging port.
BTS_E_PORT_FOREIGN_CONTROLNUMID | 0x124D | The control number cannot be removed because it is used by a messaging port.
BTS_E_DOCUMENT_MISSING_REFERENCE | 0x124E | The Reference property must have a value if the TrackingFields or PropertySet properties are specified.
BTS_E_DOCUMENT_REFERENCE_CANT_BE_CHANGED | 0x124F | A document reference cannot be modified if it is referred to by a channel.
BTS_E_PORTGROUP_NOTOPENGRP | 0x1251 | Messaging ports that are set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW) cannot be used in distribution lists.
BTS_E_PORTGROUP_DUPLICATEPORT | 0x1252 | A duplicate messaging port cannot be added to the distribution list.
BTS_E_OUTPUTCONFIG_UNIQUE_ID | 0x1255 | The output configuration identifier must be a unique identifier.
BTS_E_OUTPUTCONFIG_FOREIGN_PORTID | 0x1256 | The messaging port cannot be removed because it is used by a channel.
BTS_E_OUTPUTCONFIG_FOREIGN_CHANNELID | 0x1257 | The channel cannot be removed because it is used by a messaging port.
BTS_E_PORT_LOOPBACK_RELIABLE | 0x125F | A messaging port with the transport type Loopback cannot be associated with an envelope that uses the Reliable format.
BTS_E_ALIAS_RESERVEDWORD | 0x1262 | Group is a reserved word for qualifiers and cannot be used as the qualifier for an identifier.
BTS_E_DOCUMENT_NEEDMAPREF | 0x1268 | A map reference is required to transform the inbound document to the outbound document if the document specifications are different.
BTS_E_PORT_DESTORGNOTSPECIFIED | 0x126C | This messaging port must have a destination organization specified.
BTS_E_PORT_MISSING_PRITRANSTYPE | 0x126D | You must specify a primary transport type for this messaging port. The primary transport cannot be blank, and it cannot be an open destination.
BTS_E_PORT_MISSING_PRITRANSADDRESS | 0x126E | This messaging port must have a primary transport address specified.
BTS_E_PORT_INVALID_SECTRANSTYPE | 0x126F | The secondary transport type cannot be set to Open, Loopback, or to BizTalk Orchestration Activation.
BTS_E_PORT_MISSING_SECTRANSADDRESS | 0x1270 | The secondary transport address is missing, although the transport type has been defined.
BTS_E_PORT_INVALID_ORG | 0x1271 | The organization specified in this messaging port does not exist.
BTS_E_PORT_INVALID_ALIAS | 0x1272 | The identifier specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_APPLICATION | 0x1273 | The application specified for the organization in this messaging port either does not exist or it does not belong to the organization.
BTS_E_PORT_INVALID_ENVELOPE | 0x1274 | The envelope specified in this messaging port does not exist.
BTS_E_PORT_OPEN_DESTORG_SPECIFIED | 0x127C | An open-destination messaging port cannot have a destination organization specified.
BTS_E_PORT_OPEN_DESTAPP_SPECIFIED | 0x127E | An open-destination messaging port cannot have a destination application specified.
BTS_E_PORT_OPEN_PRITRANSTYPEOPEN | 0x127F | An open-destination messaging port must specify a primary transport type as an open destination.
BTS_E_PORT_OPEN_PRITRANSADDRESS | 0x1280 | An open-destination messaging port cannot specify a primary transport address.
BTS_E_PORT_OPEN_PRITRANSPARAMETER | 0x1281 | An open-destination messaging port cannot specify a primary transport parameter.
BTS_E_PORT_OPEN_SECTRANSTYPE | 0x1282 | An open-destination messaging port cannot specify the secondary transport type.
BTS_E_PORT_OPEN_SECTRANSADDRESS | 0x1283 | An open-destination messaging port cannot specify a secondary transport address.
BTS_E_PORT_OPEN_SECTRANSPARAMETER | 0x1284 | An open-destination messaging port cannot specify a secondary transport parameter.
BTS_E_PORT_OPEN_ENCRYPTIONTYPE | 0x1285 | An open-destination messaging port cannot specify an encryption type.
BTS_E_PORT_OPEN_ENCRYPTIONREF | 0x1286 | An open-destination messaging port cannot specify an encryption reference.
BTS_E_PORT_SIGNATTYPEANDREFERENCE | 0x1287 | The signature type is specified; however, the signature reference is missing.
BTS_E_PORT_ENCRYPTIONTYPEANDREFERENCE | 0x1288 | The encryption type is specified; however, the encryption reference is missing.
BTS_E_ALIAS_DEFAULT | 0x128A | One and only one default identifier is required and permitted at all times. The default identifier cannot be missing, nor can it be duplicated.
BTS_E_ALIAS_AUTO | 0x128B | The alias, which uses the name "Organization" and the qualifier "OrganizationName," is a system-created alias. You cannot remove this alias, create another alias that uses the same name and qualifier, or change any fields of this alias.
BTS_E_TRANSPORT_SYNTAXAPPINT | 0x128E | Either the syntax of this address is incorrect for the Application Integration Component transport type property, or the component is not registered, or else the component is not a valid AIC component.
BTS_E_TRANSPORT_SYNTAXFILE | 0x128F | The syntax of this address is incorrect for the File transport type.
BTS_E_TRANSPORT_SYNTAXHTTP | 0x1291 | The syntax of this address is incorrect for the HTTP transport type.
BTS_E_TRANSPORT_SYNTAXHTTPS | 0x1292 | The syntax of this address is incorrect for the HTTPS transport type.
BTS_E_TRANSPORT_SYNTAXSMTP | 0x1293 | The syntax of this address is incorrect for the SMTP transport type.
BTS_E_TRANSPORT_SYNTAXNONE | 0x1294 | You cannot specify a transport address or a parameter when the transport type is set to None, or when the source or destination are Open.
BTS_E_TRANSPORT_LOCALHOST | 0x1295 | The transport address cannot contain the word "localhost". Replace it with the computer name instead.
BTS_E_PORTGROUP_LASTPORT | 0x1296 | The messaging port cannot be removed if it is the last remaining messaging port in a distribution list.
BTS_E_TRANSPORT_MISSING_PRISMTPPARAMETER | 0x1298 | A primary transport parameter is required for the SMTP transport type.
BTS_E_TRANSPORT_MISSING_SECSMTPPARAMETER | 0x1299 | A secondary transport parameter is required for the SMTP transport type.
BTS_E_NAMEREQ | 0x129A | The Name property must always be at least one character long.
BTS_E_INVALIDTIMEFORMAT | 0x129B | The time format is not valid. Enter the time, in hours, in a 24-hour format (from 0 to 23 hours). You can enter only hours, not minutes or seconds.
BTS_E_TIMESTAMP | 0x129C | This object cannot be saved or removed because the timestamp has changed.
BTS_E_PORTGROUP_MISSING_PORT | 0x129D | A distribution list must contain at least one messaging port.
BTS_E_ORGANIZATION_REMOVEDEFAULT | 0x129E | The home organization cannot be removed.
BTS_E_PORT_SERVICEWINDOW_EQUAL | 0x129F | The start time (FromTime) and end time (ToTime) for the service window cannot be equal.
BTS_E_ENVELOPE_REFERENCENOTALLOWED | 0x12A2 | The reference property cannot be set for this envelope format.
BTS_E_ENVELOPE_REFERRED | 0x12A3 | This envelope cannot be removed because it is used in a messaging port or channel.
BTS_E_TRANSPORT_LOOPBACK_SECTYPECONFLICT | 0x12A4 | The secondary transport type cannot be specified for the messaging port if the primary transport type is set to Loopback.
BTS_E_TRANSPORT_LOOPBACK_SECADDRESSCONFLICT | 0x12A5 | The secondary transport address cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_LOOPBACK_SERVICEWINDOW | 0x12A6 | The service window cannot be specified for the messaging port if the transport type is set to Loopback.
BTS_E_PORT_OPEN_DESTALIAS_SPECIFIED | 0x12A7 | An open-destination messaging port cannot have a destination identifier specified.
BTS_E_PORT_OPEN_SERVICEWINDOW | 0x12A8 | The service window cannot be specified for the messaging port if the messaging port is an open-destination messaging port.
BTS_E_PORT_SERVICEWINDOWTIMES | 0x12AA | To use a service window, you must set both the From and To times or else, do not set either time.
BTS_E_TRANSPORT_LOOPBACK_PRIADDRESSCONFLICT | 0x12AC | A primary transport address cannot be specified for the messaging port if the transport type is Loopback.
BTS_E_PORT_ORGCHANGE | 0x12AD | The destination-organization identifier cannot be changed after it is created.
BTS_E_PORT_OPENNESSCHANGE | 0x12AE | The Openness property cannot be changed after it is created.
BTS_E_PORT_SIGNATURE_CHANNEL_CERTREF | 0x12AF | The signature-certification reference for a channel does not match the signature type for the port.
BTS_E_PORT_SIGNATURE_CHANNEL_OPEN | 0x12B0 | A messaging port that contains a signature type cannot be connected to an open-source channel. Also, a messaging port that is already connected to an open-source channel cannot have a signature type assigned to it.
BTS_E_CHANNEL_OPEN_SRCORG | 0x12B1 | An open-source channel cannot specify a source organization.
BTS_E_PORTGROUP_LOOPBACKPORT | 0x12B2 | A messaging port that uses the Loopback transport type cannot be added to a distribution list. Also, the transport type of a messaging port that is already included in a distribution list cannot be changed to Loopback.
BTS_E_CHANNEL_OPEN_SRCALIAS | 0x12B3 | An open-source channel cannot have a source identifier specified.
BTS_E_CHANNEL_OPEN_SRCAPP | 0x12B4 | An open-source channel cannot specify a source application.
BTS_E_CHANNEL_PORTORPORTGROUP | 0x12B5 | Either a messaging port or a distribution list, but not both, must be specified in a channel.
BTS_E_CHANNEL_MISSING_DOCUMENT | 0x12B6 | Both input and output documents are needed in a channel.
BTS_E_CHANNEL_INVALIDTYPE | 0x12B7 | A channel cannot be set to an open destination or set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_CHANNEL_MISSING_OUTDOCREFERENCE | 0x12B8 | If the inbound document definition for a channel has a reference to a specification, the outbound document definition must also have a reference to a specification.
BTS_E_CHANNEL_TRACKFIELDSCANTBESET | 0x12B9 | If the inbound document definition for a channel does not have a reference to a specification, the tracking fields cannot be set.
BTS_E_CHANNEL_EXPRESSIONCANTBESET | 0x12BA | If the inbound document definition for a channel does not have a reference to a specification, the channel-filtering expressions cannot be set.
BTS_E_CHANNEL_MAPREFCANTBESET | 0x12BB | If the inbound document definition for a channel does not have a reference to a specification then a reference to a map cannot be set.
BTS_E_CHANNEL_NOTSAME_INPDOC_OUTDOC | 0x12BC | If the inbound document definition for a channel does not have a reference to a specification then the outbound document handle should be the same of inbound document handle.
BTS_E_CHANNEL_OPEN_RECEIPTCONFLICT | 0x12BD | Channels that are set from an open source or set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW) cannot be receipt channels.
BTS_E_CHANNEL_RECEIPT_RECEIPTTIMEOUT | 0x12BE | The Expect Receipt Timeout property cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CANTSETRECEIPTCHANNEL | 0x12BF | An identifier cannot be set on a receipt channel.
BTS_E_CHANNEL_RECEIPT_CONFLICT | 0x12C0 | In a receipt channel, the source specification from the original channel must be used as the destination specification, and the destination specification from the original channel must be used as the source specification.
BTS_E_CHANNEL_SRCORGDEFAULT | 0x12C1 | If the channel is set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW), the source organization must be the home organization.
BTS_E_CHANNEL_PORT_BOTHOPEN | 0x12C2 | Both the channel and messaging port cannot be set to Open.
BTS_E_CHANNEL_RECEIPT_INVALID | 0x12C3 | The Receipt Channel and Expect Receipt Timeout properties cannot be set for an open-source channel. These properties also cannot be set if the messaging port is set to an open destination, set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW), or if the messaging port uses the Loopback transport type.
BTS_E_CHANNEL_RECEIPTMATCHNOTFOUND | 0x12C4 | The corresponding receipt channel for this channel could not be found.
BTS_E_CHANNEL_RECEIPT_OPENPORT | 0x12C5 | A receipt channel can be connected only to messaging ports that are not open messaging ports.
BTS_E_CHANNEL_RECEIPT_LOOPBACKPORT | 0x12C6 | A receipt channel cannot be connected to a messaging port that uses the Loopback transport type. Also, the transport type of a messaging port that is already connected to a receipt channel cannot be changed to Loopback.
BTS_E_CHANNEL_CANNOTUPDATE | 0x12C8 | After a channel is created, the following properties cannot be changed: source organization, openness designation, messaging port, distribution list, and receipt channel designation.
BTS_E_PORT_INVALIDOPENNESS | 0x12C9 | A messaging port cannot be set to an open source; nor can it be set from an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_FROMWORKFLOW).
BTS_E_CHANNEL_CONTROLNUMBER_ENVELOPEFORMATMISMATCH | 0x12CA | If the envelope format for the messaging port is X12 or EDIFACT, the control-number value on the channel must be set.
BTS_E_PORT_ENVELOPE_SERIALIZERCLSID | 0x12CB | If the envelope format for the messaging port is set to Custom, a class identifier (CLSID) for the serializer component must be specified.
BTS_E_CHANNEL_AIC_TRANSPORTCLSID | 0x12CD | If the transport type associated with the channel is set to Application Integration Component, a class identifier (CLSID) must be specified for the primary transport.
BTS_E_CHANNEL_RECEIPT_PORTGROUP | 0x12CE | If a channel is connected to a distribution list, a receipt channel cannot be specified.
BTS_E_COMPONENTREQUIRES2AGGREGATEFTM | 0x12CF | To be a valid object in the BizTalk Object Model, this custom component must aggregate the free-threaded marshaler.
BTS_E_CERTREFNOTFOUND | 0x12D1 | Either the certificate reference could not be found in MY or BIZTALK stores or it is not valid.
BTS_E_NODOC | 0x12D2 | The Document Definition has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOENV | 0x12D3 | The envelope has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_NOCHANNEL | 0x12D4 | The channel has been removed from the database. Avoid deleting objects when documents might exist in the queues which reference these objects.
BTS_E_INVALIDREFERENCE | 0x12D5 | Either the WebDAV repository reference does not contain a valid HTTP address or it contains the text "localhost." Please provide either a valid HTTP address or replace the text "localhost" with the actual computer name.
BTS_E_CANNOTCONTAINSUBOBJECTS | 0x12D6 | The property set and delimiter objects cannot contain any subobjects.
BTS_E_INVALIDTRACKFIELDS | 0x12D7 | The "x_custom_search" field in the tracking field dictionary must be a simple list.
BTS_E_CHANNEL_INVALID_ORG | 0x12D8 | The organization specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_ALIAS | 0x12D9 | The identifier specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_APPLICATION | 0x12DA | The application specified for the organization in this channel either does not exist or it does not belong to the organization.
BTS_E_CHANNEL_INVALID_INPDOCID | 0x12DB | The input document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_OUTDOCID | 0x12DC | The output document specified in this channel does not exist.
BTS_E_CHANNEL_INVALID_PORTGROUP | 0x12DD | The distribution list specified in this channel does not exist.
BTS_E_OBJECT_NOT_XMLSERILIZABLE | 0x12DE | The given dictionary or simplelist object must implement IPersistXML methods.
BTS_E_CHANNEL_INVALID_PORT | 0x12E0 | At least one messaging port that is referenced in this channel either does not exist or it is not associated with this channel.
BTS_E_CHANNEL_RECEIPT_VERSIGN_DECRYPT | 0x12E1 | The Verify Signature or Decrypt Encryption properties cannot be set on a receipt channel.
BTS_E_INVALID_REQUEST_CHANNEL | 0x12E2 | A channel that is connected to a distribution list cannot be used as a request channel.
BTS_E_DESTINATION_NOT_FOUND | 0x12E3 | The destination URL is not specified, and the messaging port is an open destination. Either the destination URL or a destination for the messaging port must be specified.
BTS_E_DESTINATION_CONFLICT | 0x12E4 | Both a destination URL and a destination for the messaging port cannot be specified. Specify only one of these properties.
BTS_E_ASYNC_TRANSPORT | 0x12E5 | The transport type for the request channel is not valid. Only the HTTP, HTTPS, and Application Integration Component transport types are valid for a request channel.
BTS_E_INVALID_RESPONSE_CHANNEL | 0x12E6 | The response channel can be connected only to a messaging port with a transport type set to Loopback.
BTS_E_INVALID_VERSION | 0x12E7 | The database version is incompatible with the installed version of the server. Try running setup again.
BTS_E_INVALID_SCHEMA | 0x12E8 | The document or envelope specification is not valid. Open the specification in BizTalk Editor, and then on the Tools menu, click Validate Specification. Resolve any warnings to ensure that the specification is valid.
BTS_E_CHANNEL_RECEIPTCHANNEL_PORTGROUP | 0x12E9 | A receipt channel cannot be connected to a distribution list.
BTS_E_TRANSPORT_ORCHESTRATION_OPENNESS | 0x12EA | A messaging port that uses the BizTalk Orchestration Activation transport type must have the Openness Type property set to an XLANG schedule (BIZTALK_OPENNESS_TYPE_EX_TOWORKFLOW).
BTS_E_TRANSPORT_ORCHESTRATION_ADDRESSPARAMETER | 0x12EB | Both a primary address and a parameter are required for a messaging port that uses a BizTalk Orchestration Activation transport type.
BTS_E_ORCHESTRATION_INVALIDORG | 0x12EC | A messaging port that uses a BizTalk Orchestration Activation transport type must have the home organization set as the destination organization.
BTS_E_INVALID_FILTEREXPRESSION | 0x12ED | The channel filtering expression is not valid. Make sure that the node-path expression is valid.
BTS_E_MULTIPLEDOCDEFSFORPROPSET | 0x12EE | Multiple document definitions were found for the given property set. Only a single document definition for a given property set is expected.
BTS_E_INVALID_PROPSET | 0x12EF | The PropertySet cannot contain non-string element values.
BTS_E_DBSCHEMA_MISMATCH | 0x1300 | The existing Database Schema is not compatible with the current version of the product. You must delete the existing database.
BTS_E_UNEXPECTED_INSTALL | 0x1301 | The existing Database Schema is newer than the current version that is installed. Setup will rollback the changes.
CIS_E_DOCSCHEMA_ATTRIB_MISSING | 0x1400 | The "%3" attribute is missing in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB_VALUE | 0x1401 | The "%3" attribute value "%4" is not valid. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_EMPTY_ELEMENT | 0x1402 | The "%3" element cannot be empty. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_CHILD_ELEMENT | 0x1403 | The "%3" element cannot be a child of the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MULTIPLE_INFO | 0x1404 | Only one record description or one field description is allowed for each element declaration. One of the descriptions must be removed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_FIELD_DECL | 0x1405 | The root node cannot contain a field. The root node of the document must contain a record. Verify that the root node in your document is declared as a record. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_LEN_DECL | 0x1406 | The minimum length value must be no greater than the maximum length value. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_POSLEN_DECL | 0x1407 | The value of the start position must be no greater than the value of the end position. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO_YET | 0x1408 | A field description or record description must be specified before references to other elements. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_SCHEMATYPE_XML | 0x1409 | Only non-XML document specifications are allowed for this format. The schema_type attribute has the value "xml". Verify that the specification selected is a non-XML specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_NO_INFO | 0x140A | No record information or field information was found in the "%3" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ATTRIB | 0x140B | The "%3" attribute is not allowed in the "%4" element. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_MISSING_ELEM_DECL | 0x140C | There is no element with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_MISSING_ATTR_DECL | 0x140D | There is no attribute with the name "%1" in the document specification.
CIS_E_DOCSCHEMA_INVALID_POSITIONAL_DECL | 0x140E | The "%1" record cannot be a child of the "%2" positional record. Only fields can be children of positional records.
CIS_E_DOCSCHEMA_INVALID_RECORD_CHILDREN | 0x140F | The children of the "%1" delimited record must either be all records or all fields. Records with no tag identifier cannot have mixed records and fields as children.
CIS_E_DOCSCHEMA_NO_RECORD_CHILDREN | 0x1410 | The "%1" delimited record must have at least one child. Records with no tag identifier must have at least one child, or else the record cannot be found in a non-XML format. Either add a child to the record, give the record a tag identifier, or remove the record from the specification.
CIS_E_DOCSCHEMA_MISSING_RECORD_TAG | 0x1411 | The "%1" delimited record is marked to repeat but it does not have a tag identifier. Only the last record in a document specification is allowed to have this property. If this record appears only once in the document, then mark it as a single occurrence. Otherwise, give the record a tag identifier that tells the server where to look for the next record in the specification.
CIS_E_DOCSCHEMA_NO_ROOT_ELEMENT | 0x1412 | The root-node name "%3" was not found in the specification. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_ROOT_ELEMENT | 0x1413 | The "%3" element cannot be the root node of this document. Only <Schema> is allowed. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_EMPTY_ATTRIBUTE | 0x1414 | The "%3" attribute in the "%4" element cannot be empty. Either specify a nonempty value or remove the attribute. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_INVALID_REFERENCE | 0x1415 | The "%1" record has an illegal cyclic path through the "%2" record. The only cyclic reference allowed for a record is if the record has a tag identifier that allows the system to terminate the search. Either remove the cyclic reference or add an appropriate tag identifier to the document specification.
CIS_E_DOCSCHEMA_LOADFAILED | 0x1416 | The specification failed to load. See the following messages for details.
CIS_E_DOCSCHEMA_MISSING_NS | 0x1417 | Valid BizTalk Server specifications for non-XML documents must have the namespace declarations of "urn:schemas-microsoft-com:BizTalkServer", "urn:schemas-microsoft-com:datatypes", and "urn:schemas-microsoft-com:xml-data" in the root node of the specification.
CIS_E_DOCSCHEMA_INVALID_SCHEMA_USAGE | 0x1418 | The specification referenced in the "%1" document is not compatible with the "%2" format. Select a specification that is compatible with this format, or if this is a valid specification for the defined format, assign "%2" to the "standard" property on this specification.
CIS_E_DOCSCHEMA_MISSING_POSLEN_DECL | 0x1419 | The "%3" field is missing a start and end position, and is referenced in the "%4" positional record. Specify valid start and end positions for this field. Line: %1, Pos: %2.
CIS_E_DOCSCHEMA_DUPLICATE_NAMESPACE | 0x141A | The duplicate namespace declaration "%3" has been found. Please remove the duplicate reference to same namespace. Line: %1, Pos: %2.
CIS_E_PARSER_EOF | 0x1430 | The end of the file was reached prematurely.
CIS_E_PARSER_MISSING_TAG | 0x1431 | The required "%1" record was not found in the inbound document.
CIS_E_PARSER_MISSING_FIELD | 0x1432 | The required field "%1" in the "%2" record was not found in the inbound document.
CIS_E_PARSER_FAILURE | 0x1433 | The parser failed to convert the document due to processing errors. See the following messages for details.
CIS_E_PARSER_INVALIDDATA | 0x1434 | The parser cannot match the current position of the data with the specification. Verify that the version of this specification is consistent with the version of the data and that the root parsing tags match.
CIS_E_PARSER_NO_DATA | 0x1435 | There is no data that can be parsed on the dictionary. Verify that either the "working_data" field or the "file_path" field contains nonempty data.
CIS_E_PARSER_INVALID_ENVNAME | 0x1436 | The envelope name "%1" does not reference a valid envelope for the BizTalk Server parser. Either the envelope name does not exist or there is an envelope specification attached that is not valid.
CIS_E_PARSER_NO_COMPONENTS_FOUND | 0x1439 | No parser component recognizes the data. This might be caused by an interchange specification that is missing or not valid, or it might be caused by data that is not valid. Verify that both the interchange specification (if one is specified) and the data match.
CIS_E_PARSER_COMPONENT_FAILED | 0x1440 | While trying to process document #%4 during submission "%1", the parser component named "%2" failed on the method "%3" with the error code "%5". Possible causes are: the component found unexpected data in the incoming stream; a document specification could not be found given the data; or an internal component failure occurred. If this problem continues, remove this component from the valid list of parser components or contact your system administrator.
CIS_E_PARSER_DOCUMENT_FAILED | 0x1441 | Document #%4 within submission "%1" was returned as a document that was not valid from the parser component named "%2". The most frequent cause is a document specification that is not valid or else the component was unable to determine the necessary routing fields. Verify that the proper specification is defined for this data.
CIS_E_PARSER_INVALID_DATETIME | 0x1442 | The "%1" date or time format for the tag "%3" does not match the format of the "%2" data extracted from the incoming data.
CIS_E_PARSER_INVALID_COMPONENT | 0x1443 | Within submission "%1", the parser component named "%2" could not be loaded. Verify that this component can be run in a stand-alone executable and that the server has sufficient permissions to start it.
CIS_W_PARSER_SKIPPED_COMPONENT | 0x1444 | The parser was unable to probe the specified component. This component will be skipped.
CIS_E_PARSER_UNUSEABLE_DOCNAME | 0x1445 | The parser cannot use the document "%1" as it has no specification. Please attach a specification to this document or specify a different one.
CIS_E_PARSER_CONTROL_NUMBER_MISMATCH | 0x1446 | The control number of segment "%1" (%2) does not match that of segment "%3" (%4).
CIS_E_PARSER_DOCCOUNT_INCORRECT | 0x1447 | The document or segment count contained in tag "%1" (%2) does not match the number of documents or segments processed (%3).
CIS_E_PARSER_X12_ISA_PARSE_FAILED | 0x1448 | The parser cannot parse the ISA section of the X12 document. This segment is fixed-width; if fields in this segment do not have correct length, the parsing will fail because the delimiters are picked up from the wrong offsets.
CIS_E_PARSER_MIN_LENGTH | 0x1449 | The data contains a field value ("%1") that doesn't meet minimum length requirement for tag "%2" (minimum length is %3).
CIS_E_PARSER_MAX_LENGTH | 0x144A | The data contains a field value ("%1") that doesn't meet maximum length requirement for tag "%2" (maximum length is %3).
CIS_E_PARSER_NO_DATA_CONSUMED | 0x144B | No data was read by the parser. Make sure that the code page is set correctly for the data. If the data is UNICODE, make sure that there is no byte order mark (0xFFFE or 0xFEFF) appears at the beginning of the file.
CIS_E_PARSER_UNSUPPORTED_EDIFACT_SYNTAX | 0x144C | EDIFACT documents with the "UNOX" or the "UNOY" syntax identifier are not supported.
CIS_E_PARSER_DATA_REMAINING | 0x144D | Additional data in the document instance was not parsed. Make sure that the document instance you want to validate contains only one document.
CIS_E_PARSER_MISSING_DELIMITER | 0x144E | While parsing record "%1", the parser cannot find the required delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_LEADING_DELIMITER | 0x144F | While parsing record "%1", the parser cannot find the required leading delimiter: "%2" (%3).
CIS_E_PARSER_MISSING_TRAILING_DELIMITER | 0x1450 | While parsing record "%1", the parser cannot find the required trailing delimiter: "%2" (%3).
CIS_E_VALIDATE_GROUP_RULE | 0x1451 | In record "%1", if any of the following fields exist, then all must exist: %2
CIS_E_VALIDATE_GROUP_ALL | 0x1452 | In record "%1", all of the following fields must exist: %2
CIS_E_VALIDATE_GROUP_ONE | 0x1453 | In record "%1", only one of the following fields can exist: %2
CIS_E_PARSER_INVALID_WRAP_CHAR_FOUND | 0x1454 | While parsing record "%1", the parser found an occurrence of a wrap character, "%2", that is not valid.
CIS_E_VALIDATE_GROUP_ANY | 0x1455 | In record "%1", one or more of the following fields must exist: %2
CIS_E_PARSER_EXTRA_DELIMITER | 0x1456 | While parsing record "%1", the parser found the following extra delimiter: "%2".
BTS_E_DOCUMENT_HAS_INVALID_MANIFEST | 0x1457 | Error parsing the manifest.
CIS_E_ADMIN_CACHE_PARSERS | 0x1504 | The latest modification date from the administration parser table could not be loaded.
CIS_E_ADMIN_INIT_CACHE | 0x1505 | The configuration data in the global cache could not be initialized.
CIS_E_ADMIN_RELOAD_CACHE | 0x1506 | The configuration data from the database could not be reloaded.
CIS_E_ADMIN_PARSER_GETCLSID | 0x1507 | The class identifiers (CLSIDs) of the parser records could not be loaded.
CIS_E_ADMIN_CACHE_OBJECTNOTCREATED | 0x1509 | The administration cache cannot be created.
CIS_E_ADMIN_CACHE_INITIALLOAD | 0x150A | The configuration cache data from the database could not be loaded.
CIS_E_ADMIN_ADD_SERVER_ACCESS_DENIED | 0x150B | Server "%1" cannot be added because access to the "%2" is denied.
CIS_E_ADMIN_ADD_SERVER_NO_SERVICE | 0x150C | Server "%1" cannot be added because BizTalk Server is not installed on the computer.
CIS_E_ADMIN_DELETE_SERVER_NO_ACCESS | 0x150D | The "%1" server cannot be deleted because access to the "%2" service is denied and the service cannot be stopped.
CIS_E_ADMIN_DELETE_GROUP_SERVER_RUNNING | 0x150E | This server group cannot be deleted because the "%1" server is still running.
CIS_E_ADMIN_DELETE_GROUP_SERVER_ACCESS_DENIED | 0x150F | This server group cannot be deleted because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_NOGROUP | 0x1512 | The specified administration group does not exist.
CIS_E_ADMIN_NOSERVER | 0x1513 | The specified administration server does not exist.
CIS_E_ADMIN_NORECEIVESERVICE | 0x1514 | The specified administration receive function does not exist in the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_RECEIVESERVICE | 0x1515 | An unexpected error occurred while trying to remove the "%1" receive function from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_GROUP | 0x1516 | An unexpected error occurred while trying to remove the "%1" group from the database.
CIS_E_ADMIN_UNEXPECTED_REMOVE_SERVER | 0x1517 | An unexpected error occurred while trying to remove the "%1" server from the database.
CIS_E_ADMIN_NOTIMESTAMPS | 0x151A | The specified administration timestamps object does not exist in the database.
CIS_E_ADMIN_REFRESH_THREAD_ERROR | 0x151B | The configuration refresh thread encountered an error while loading the configuration data.
CIS_E_ADMIN_REFRESH_THREAD_EXIT | 0x151C | The configuration refresh thread cannot load the configuration data because of a previous error.
CIS_E_ADMIN_RECSVC_GENERAL | 0x151D | The configuration refresh thread cannot set up one or more receive functions. This might be because SQL Server is not started.
CIS_E_ADMIN_CREATE_GROUP | 0x1529 | The server group cannot be created because "%1".
CIS_E_ADMIN_LOAD_GROUP_PROPS | 0x152A | The group properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_GROUP_PROPS | 0x152B | The group properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_GROUP | 0x152C | The server group cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINGROUPS | 0x152D | All server groups cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERS | 0x152E | All servers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETRECEIVESERVICES | 0x152F | All receive functions for the "%1" group cannot be retrieved from database because "%2".
CIS_E_ADMIN_GETPARSERS_IN_GROUP | 0x1531 | All parsers for the "%1" server group cannot be retrieved from the database because "%2".
CIS_E_ADMIN_GETLOCALSMTPHOST | 0x1538 | The local SMTP host cannot be retrieved because "%1".
CIS_E_ADMIN_CREATE_SERVER | 0x1539 | The server cannot be created because "%1".
CIS_E_ADMIN_LOAD_SERVER_PROPS | 0x153A | The server properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_SERVER_PROPS | 0x153B | The server properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_SERVER | 0x153C | The server cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLADMINSERVRES | 0x153D | All servers cannot be retrieved from the database.
CIS_E_ADMIN_GETSERVERBYNAME | 0x153E | The server properties for "%1" cannot be retrieved because "%2".
CIS_E_ADMIN_DECRYPT_PASSWORD | 0x1540 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_EXEC_COMMMAND_ON_PARSER | 0x154F | The SQL command "%1" on the parser database table cannot be executed because "%2".
CIS_E_ADMIN_PREPOROCESSOR_NOT_SUPPORTED_BY_HTTP_RF | 0x155C | The "%1" property is not supported for the HTTP receive function in Submit to File mode.
CIS_E_ADMIN_CREATE_RECEIVESERVICE | 0x155D | The receive function cannot be created because "%1".
CIS_E_ADMIN_LOAD_RECEIVESERVICE_PROPS | 0x155E | The receive function properties cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_RECEIVESERVICE_PROPS | 0x155F | The receive function properties cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_RECEIVESERVICE | 0x1560 | The receive function cannot be removed from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICES | 0x1561 | All receive functions cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETALLRECEIVESERVICESINSERVER | 0x1562 | All receive functions cannot be retrieved for the "%1" server because "%2".
CIS_E_ADMIN_LOAD_TIMESTAMPS | 0x1563 | All timestamps cannot be retrieved from the database because "%1".
CIS_E_ADMIN_GETSQCONNECT | 0x1570 | The Shared Queue database connection string cannot be retrieved from the database.
CIS_E_ADMIN_GETCOMPUTERNAME | 0x1571 | The name of the local computer cannot be retrieved. Internally, BizTalk Server is using "localhost" as the computer name.
CIS_E_ADMIN_MIN_CONSTRAINT | 0x1573 | The size of the "%1" property is less than the minimum required length for "%2".
CIS_E_ADMIN_MAX_CONSTRAINT | 0x1574 | The size of the "%1" property is greater than the maximum length allowed for "%2".
CIS_E_ADMIN_GET_MGMTDB_CONNECT_PROPS | 0x1575 | The BizTalk Messaging Management database properties cannot be retrieved.
CIS_E_ADMIN_KEY_EMPTY | 0x1576 | The key to the database table, property "%1", is empty.
CIS_E_ADMIN_COCREATE_IN_CREATE | 0x1577 | An instance of the "%1" object could not be created while creating a new "%2" object.
CIS_E_ADMIN_ADO_OPEN_CONNECTSTRING | 0x1578 | The connection to the BizTalk Messaging Management database could not be opened.
CIS_E_ADMIN_COCREATE_IN_LOAD | 0x1579 | An instance of the "%1" object could not be created while loading the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_SAVE | 0x1580 | An instance of the "%1" object could not be created while saving the "%2" properties.
CIS_E_ADMIN_COCREATE_IN_REMOVE | 0x1581 | An instance of the "%1" object could not be created while trying to remove the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETALL | 0x1582 | An instance of the "%1" object could not be created while trying to get all instances of "%2".
CIS_E_ADMIN_COCREATE_IN_GETALL_INSERVER | 0x1583 | An instance of the "%1" object could not be created while trying to get all instances of the "%2" object in the "%3" server.
CIS_E_ADMIN_GET_PROP | 0x1584 | The "%1" property cannot be retrieved.
CIS_E_ADMIN_CLOSE_ADO_CONNECTION | 0x1585 | The ADO connection cannot be closed.
CIS_E_ADMIN_CLOSE_ADO_RECORDSET | 0x1586 | The ADO record set cannot be retrieved.
CIS_E_ADMIN_ENCRYPT_PASSWORD | 0x1587 | The "%1" property cannot be processed.
CIS_E_ADMIN_COCREATE_IN_GETALLNAMES | 0x1588 | An instance of the "%1" object could not be created while trying to get the names of all the "%2" object instances.
CIS_E_ADMIN_COCREATE_IN_GETOTHERS_OF_GROUP | 0x1589 | An instance of the "%1" object could not be created while trying to get all instance of the "%2" object in the "%3" group.
CIS_E_ADMIN_COCREATE_IN_GET_SMTPHOST | 0x158A | An instance of the "%1" object could not be created while trying to get "%2" for the local server.
CIS_E_ADMIN_COCREATE_IN_GET_SQ_CONNECTSTRING | 0x158B | An instance of the "%1" object could not be created while trying to get the Shared Queue parameters of "%2" in order to connect to the database.
CIS_E_ADMIN_COCREATE_SERVER_BYNAME | 0x158C | An instance of the "%1" object could not be created while trying to get the properties of the "%2" server instance of the "%3" class.
CIS_E_ADMIN_GETSQCONNECT_IN_OPEN | 0x158D | The Shared Queue database connection string could not be retrieved from the database because "%1".
CIS_E_ADMIN_COCREATE_EXEC_SQL_COMMAND_ON_PARSER | 0x158E | An instance of the "%1" object could not be created while trying to execute a SQL command on the "%2" database table.
CIS_E_ADMIN_COCREATE_PARSER_CLSIDS_IN_GROUP | 0x158F | An instance of the "%1" object could not be created while retrieving the class identifiers (CLSIDs) for the parsers that belong to the "%2" group.
CIS_E_ADMIN_INVALID_ARGUMENT | 0x1590 | An unexpected internal error occurred. An invalid "%1" argument was used when calling the "%2" method.
CIS_E_ADMIN_MAX_ENUM_CONSTRAINT | 0x1591 | The value of the "%1" property is greater than the maximum value allowed for "%2".
CIS_E_ADMIN_MIN_ENUM_CONSTRAINT | 0x1592 | The value of the "%1" property is smaller than the minimum value allowed for "%2".
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BSTR | 0x1593 | The type of the "%1" property could not be changed to a string.
CIS_E_ADMIN_CREATE_CHANGETYPE_TO_BOOL | 0x1594 | The type of the "%1" property could not be changed to Boolean.
CIS_E_ADMIN_COCREATE_IN_ENUMINSTANCES | 0x1595 | An instance of the "%1" object could not be created while enumerating instances of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_PUTINSTANCE | 0x1596 | An instance of the "%1" object could not be created while setting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_GETOBJECT | 0x1597 | An instance of the "%1" object could not be created while getting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_DELETEINSTANCE | 0x1598 | An instance of the "%1" object could not be created while deleting an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPROPS | 0x1599 | An instance of the "%1" object could not be created while loading properties for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_LOADPARSERS | 0x159B | An instance of the "%1" object could not be created while loading parsers from a database for an instance the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_REGISTRY | 0x159C | An instance of the "%1" object could not be created while setting parsers from the registry for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_SETPARSERSFROM_CLIENT | 0x159D | An instance of the "%1" object could not be created while setting parsers from the client for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_REFRESHPARSERLIST | 0x159E | An instance of the "%1" object could not be created while refreshing the parser list for an instance of the "%2" object.
CIS_E_ADMIN_COCREATE_IN_MOVETOSUSPENDED_Q | 0x159F | An instance of the "%1" object could not be created while moving an instance of "%2" to the Suspended queue.
CIS_E_ADMIN_COCREATE_IN_RESUBMIT | 0x15A0 | An instance of the "%1" object could not be created while resubmitting an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWDOC | 0x15A2 | An instance of the "%1" object could not be created while viewing a document instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWERRORDESC | 0x15A3 | An instance of the "%1" object could not be created while viewing the error description of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_VIEWINTERCHANGE | 0x15A4 | An instance of the "%1" object could not be created while viewing the interchanges of an instance of "%2".
CIS_E_ADMIN_COCREATE_IN_FREEINTERCHANGES | 0x15A5 | An instance of the "%1" object could not be created while freeing the interchanges for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STARTSERVER | 0x15A6 | An instance of the "%1" object could not be created while starting the server for an instance of a "%2".
CIS_E_ADMIN_COCREATE_IN_STOPSERVER | 0x15A7 | An instance of the "%1" object could not be created while stopping the server for an instance of a "%2".
CIS_E_ADMIN_NO_DELETE_SERVER_IN_RECVSERVICE | 0x15A8 | The "%1" server cannot be deleted because it is the processing server for at least one receive function.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_RUNNING | 0x15A9 | The server group properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_GROUP_SERVER_ACCESS_DENIED | 0x15AA | The server group properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_RUNNING | 0x15AC | The server properties cannot be changed because the "%1" server is still running.
CIS_E_ADMIN_UPDATE_SERVER_SERVER_ACCESS_DENIED | 0x15AD | The server properties cannot be changed because access to the "%1" service on "%2" server is denied.
CIS_E_ADMIN_UPDATE_READ_ONLY_PROP | 0x15AE | The "%1" property cannot be changed. It is a read only property.
CIS_E_ADMIN_DIFFERENT_ROOT | 0x15AF | The "%1" server may already belong to a different BizTalk Server installation.
CIS_E_ADMIN_NOT_RESUBMITABLE | 0x15B0 | This Suspended queue item cannot be submitted again.
CIS_E_ADMIN_DBCONNECT | 0x15B1 | BizTalk Server failed to access the "%1" database on the "%2" server with the database connection information.
CIS_E_ADMIN_PURGE_SUSPENDEDQ | 0x15B2 | An instance of the "%1" object could not be created while deleting documents from "%2".
CIS_E_ADMIN_REQ_PROP_MISSING | 0x15B3 | %1 cannot be NULL.
CIS_E_ADMIN_WMI_ERROR_HANDLING | 0x15B4 | The BizTalk Server WMI provider error-handling method failed. The original error description for the error that called the error-handling method is: "%1".
CIS_W_ADMIN_QUERY_FAILED | 0x15B5 | An attempt to get the Where clause values for a WMI Query failed.
CIS_E_ADMIN_INVALID_ENUM_CONSTRAINT | 0x15B6 | The value "%2" of the "%1" property is not valid.
CIS_E_ADMIN_OPENNESS_CONSTRAINT | 0x15B7 | The value "%2" of the "%1" property is not permitted when the value of the IsPassThrough property is set to TRUE.
CIS_E_ADMIN_RECEIVE_INVALID_SERVER_GROUP | 0x15B8 | the specified server and/or group is not valid
CIS_E_ADMIN_INVALID_INSTANCE_NAME | 0x15B9 | The specified instance name "%1" contains at least one of the following characters that is not valid: [ ` ~ ! @ # $ % ^ & * ( ) + = [ ] { } | \ ; " ' < > , . ? ]
BTS_E_ADMIN_GROUP_UNIQUE_NAME | 0x15BA | A BizTalk Server group with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_TIMESTAMPS_DATA_CORRUPTION | 0x15BB | Internal data corruption has been detected in the adm_TimeStamps table of the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_UNIQUE_NAME | 0x15BC | A BizTalk Server with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_SERVER_FOREIGN_GROUPNAME | 0x15BD | This BizTalk Server does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_UNIQUE_NAME | 0x15BE | A BizTalk Server receive function with the same name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_RECSVC_FOREIGN_GROUPNAME | 0x15BF | This BizTalk Server receive function does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
BTS_E_ADMIN_UNIQUE_HTTP_POLLING_LOCATION | 0x15C0 | An HTTP receive function polling from the same location already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_UNIQUE_ID | 0x15C1 | A BizTalk Server parser with the same CLSID and Group Name already exists in the BizTalk Messaging Management database.
BTS_E_ADMIN_PARSER_FOREIGN_GROUPNAME | 0x15C2 | This BizTalk Server parser does not reference a valid BizTalk Server group in the BizTalk Messaging Management database.
CIS_E_ADMIN_DB_SPROCVERSION | 0x15C3 | The "%1" database on the "%2" server does not contain the necessary database schema.
CIS_E_ADMIN_DB_VERSION | 0x15C4 | The "%1" database on the "%2" server is not compatible with the current version of the product.
CIS_E_ADMIN_CREATE_CUSTOM_COUNTER | 0x15D0 | The custom counter cannot be created because "%1".
CIS_E_ADMIN_LOAD_CUSTOM_COUNTER_PROPS | 0x15D1 | The custom counter cannot be loaded because "%1".
CIS_E_ADMIN_SAVE_CUSTOM_COUNTER_PROPS | 0x15D2 | The custom counter cannot be saved because "%1".
CIS_E_ADMIN_REMOVE_CUSTOM_COUNTER_PROPS | 0x15D3 | The custom counter cannot be removed because "%1".
CIS_E_ADMIN_NOCUSTOM_COUNTER | 0x15D4 | The specified custom counter could not be found. Verify that the name of the specified custom counter is correct.
CIS_E_ADMIN_UNEXPECTED_REMOVE_CUSTOM_COUNTER | 0x15D5 | An unexpected error occurred while trying to remove the "%1" custom counter from the database.
CIS_E_ADMIN_VALIDATE_COUNTER_PROPS | 0x15D6 | The custom counter cannot be validated because "%1".
CIS_E_ADMIN_GET_VALUE_CUSTOM_COUNTER_PROPS | 0x15D7 | The value of the custom counter cannot be evaluated because "%1".
CIS_E_ADMIN_UNEXPECTED_VALIDATE_CUSTOM_COUNTER | 0x15D8 | An unexpected error occurred while trying to validate the "%1" custom counter.
CIS_E_ADMIN_CUSTOM_COUNTER_ORG_CONSTRAIN | 0x15D9 | Either both %1 and %2 properties must be empty or %3 property must be empty.
CIS_E_ADMIN_WRONG_HTTP_POLLING_LOCATION | 0x15DA | The "%1" property is incorrect for the HTTP receive function ( http://... expected).
CIS_E_DTA_LOG_INTERCHANGE_DETAILS_FAILED | 0x1604 | The details of an interchange could not be logged.
CIS_E_DTA_LOG_DOCUMENT_DETAILS_FAILED | 0x1605 | The details of a document could not be logged.
CIS_E_DTA_LOG_GROUP_DETAILS_FAILED | 0x1606 | The details of a group could not be logged.
CIS_E_DTA_INIT_FAILED | 0x160A | The DTA object could not be initialized.
CIS_E_DTA_FAILED_TO_GET_ADMIN_PROPERTIES | 0x160E | The administration properties could not be obtained.
CIS_E_DTA_DATABASE_CONNECTION | 0x160F | The server could not establish connection to the Tracking database.
CIS_E_DTA_LOG_DOCUMENT_FAILED | 0x1619 | A copy of the document could not be logged.
CIS_E_DTA_LOG_INTERCHANGE_FAILED | 0x1620 | A copy of the interchange could not be logged.
CIS_E_DTA_OBJECT_IS_UNINITIALIZED | 0x1623 | The DTA initialization method must be explicitly invoked before any DTA method can be invoked.
CIS_E_DTA_FAILED_TO_COMMIT | 0x1625 | Changes could not be committed to the database.
CIS_E_DTA_FAILED_TO_LOG_SOURCE_XML | 0x1626 | The intermediate source XML could not be logged.
CIS_E_DTA_FAILED_TO_LOG_DEST_XML | 0x1627 | The intermediate destination XML could not be logged.
CIS_E_DTA_ACK_NO_ROW_FOUND | 0x162B | Acknowledgment correlation failed. The correlation key(s) given did not match any record in the Tracking database.
CIS_E_DTA_ACK_MULTIPLE_ROWS_FOUND | 0x162C | Acknowledgment correlation failed. The correlation key(s) given match more than one record in the Tracking database.
CIS_E_DTA_LOG_MIME_FAILED | 0x162D | The MIME data for submission "%1" could not be logged.
CIS_W_DTA_LOG_TRACKING_FIELD_FAILED | 0x162E | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 Actual value: %4 Possible causes are either a conversion error or an arithmetic overflow error. Check the tracking field settings in the document or channel configuration.
CIS_W_DTA_LOG_BINARY_TRACKING_FIELD_FAILED | 0x162F | The following tracking field for submission "%1" could not be logged: Tracking field: %2 Specification field name: %3 The submission could not be logged because the corresponding XML element or attribute is set to binary type, which can only be tracked as custom type tracking field. Correct the tracking field settings in the document or channel configuration.
CIS_E_DTA_INIT_TRANSACTIONAL_SESSION | 0x1631 | The server could not create a transactional session for the Tracking object.
CIS_W_DTA_RECORD_UPDATE_FAILED | 0x1632 | An attempt to update a tracking record has failed. The record was probably deleted prior to the update action.
CIS_E_RESPONSE_DOM_LOAD_FAILED | 0x1701 | The XML-DOM could not be loaded from the response data.
CIS_E_RECEIVE_MSMQ_BYOT_CREATE_FAILED | 0x1702 | A Message Queuing receive function failed to create an IInterchange object using a Bring Your Own Transaction (BYOT) object. This may have been caused by editing the BizTalk Server COM+ application or configuring the BYOT object in its own COM+ application. This BizTalk Message Queuing receive function will be stopped.
CIS_E_RECEIVE_MSMQ_ZERO_BYTE_DOC | 0x1703 | A Message Queuing receive function read a zero byte document. This document has been discarded.
CIS_E_RECEIVE_SERVICE_FAILED | 0x1704 | There was a failure processing the "%1" receive function. Check your receive function configuration in BizTalk Server Administration.
CIS_E_INITWORKITEM | 0x1705 | There was a failure creating the internal work item. Make sure that SQL Server is running.
CIS_E_NOPIPELINE | 0x1706 | A channel with the name "%1" cannot be located.
CIS_E_OPEN_PASSTHROUGH | 0x1707 | The channel and messaging port openness type are not compatible with the submit method call.
CIS_E_DLQ_DETAILS | 0x1708 | Details about the Suspended queue could not be retrieved.
CIS_E_INVALID_OPENDEST | 0x1709 | The destination specified for the following open-destination messaging port was not valid: %1
CIS_E_SQL_MISSINGROWS | 0x170a | Rows were missing from the record returned by SQL OLEDB provider.
CIS_E_BTF_TIME_STAMP_EXPIRED | 0x170b | The BizTalk Framework document "%1" was received with an expired "%2" timestamp. This message will be discarded.
CIS_E_ACCESS_DENIED | 0x170c | The current process did not have administrative privileges and cannot access the Suspended queue.
CIS_E_BTF_ERROR_FINDING_TAG | 0x170d | The parser could either not find the BizTalk Framework tag "%1", or the tag did not have a value. This document will be moved to the Suspended queue.
CIS_E_INVALID_FORMAT | 0x170e | The "%1" envelope format is not recognized by the server. Specify a valid envelope format.
CIS_E_INVALID_MAP | 0x170f | The server could not load the map that is referenced by this channel.
CIS_E_MALFORMED_EXPR | 0x1710 | The expression "%1" is malformed and cannot be interpreted by the server.
CIS_E_DB_SHUTDOWN | 0x1711 | The server is shutting down because of a database failure.
CIS_E_SUBMIT_BLOCKED | 0x1712 | All submit calls have been blocked due to a database failure. After correcting this problem, please go to Component Services and shut down the 'BizTalk Server Interchange Application', before attempting to call any submit method.
CIS_E_CERT_NOT_FOUND | 0x1713 | The required certificate cannot be found in the certificate store.
CIS_E_NODATA | 0x1714 | The Submit method call did not contain a document or a file path.
CIS_E_TOOMUCH_DATA | 0x1715 | The Submit method call contained both a document and a file path.
CIS_E_INVALID_OPENFLAG | 0x1716 | The Submit method call was passed an openness type that is not valid. Refer to the BizTalk Server 200 Help documentation for the enumeration of these values.
CIS_E_PASSTHROUGH_PARAMS | 0x1717 | The Submit method call contained a channel along with source, destination, or document name information. Do not include source, destination, or document name information when passing the channel as a parameter within a Submit method call.
CIS_E_NOSRCID | 0x1718 | The Submit method call contained a source qualifier but no source identifier.
CIS_E_NODESTID | 0x1719 | The Submit method call contained a destination qualifier but no destination identifier.
MSG_TIMEBOMB_EXPIRED | 0x171A | Thank you for evaluating Microsoft BizTalk Server. The period for this evaluation version has ended. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server.
CIS_E_LOOPBACK | 0x171B | An attempt was made to submit a document that uses the Loopback transport type. The Loopback transport type can only be used when calling the SubmitSync method.
CIS_E_DBEXECUTE | 0x171C | The following stored procedure call failed: "%1".
CIS_E_MISSING_SMTPHOST | 0x171D | In order to use the SMTP transport, the SMTP host must be specified. To specify an SMTP host, in BizTalk Server Administration expand Microsoft BizTalk Server 200, right-click BizTalk Server Group, and then click Properties to open the BizTalk Server Group Properties dialog box. On the General tab, in the SMTP host box, specify the SMTP host that you want to use.
CIS_E_INVALIDHANDLE | 0x171E | This method expected a submission handle or an array of submission handles, but the incoming data was not valid. Verify that the parameters are correct.
CIS_E_DBCONNECT | 0x171F | BizTalk Server failed to initialize a connection to database: "%1" on server: "%2".
CIS_E_PASSTHROUGH_WITH_NOCHANNEL | 0x1720 | A valid channel name must be specified as a submission parameter on a Submit or SubmitSync method call when the pass-through flag is set to true.
CIS_W_DBFAILURE | 0x1721 | The database call failed and returned the following error string: "%1". If possible, we will attempt to retry this call.
CIS_E_GET_BTMPARAMS | 0x1722 | Unable to load connection parameters for BTM database. Please go to the Administration MMC to resolve this problem.
CIS_E_UNABLE_TO_CREATE_CUSTOM_PRE_PROC | 0x1723 | The custom preprocessing component for the receive function "%1" could not be created. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_FAILED | 0x1724 | The custom preprocessing component used by the receive function "%1" failed. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_NO_BSTR | 0x1725 | The custom preprocessing component used by the File receive function "%1" failed to return a valid BSTR. A valid BSTR is required. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA | 0x1726 | The custom preprocessing component used by the Message Queue receive function "%1" cannot be called because the message contains data that is not a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_CP | 0x1727 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid code page. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_INVALID_DATA_OUT | 0x1728 | The custom preprocessing component used by the Message Queue receive function "%1" failed to return a valid document, the document must be either a BSTR or a BYTE array. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_FILE_PRE_PROC_FAIL | 0x1729 | The custom preprocessing component used by the file receive function "%1" failed. The document "%2" will be moved to the Suspended queue.
CIS_E_CUSTOM_PRE_PROC_CANT_SET_CTX | 0x172A | The server was unable to set the context on the custom preprocessing component used by the receive function "%1". This document will be moved to the Suspended queue.
CIS_E_FILERCV_FILE_SHARE_DOWN | 0x172B | The file receive function "%1" was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_FILERCV_NETWORK_DOWN | 0x172C | The file receive function "%1" is experiencing network problems and was unable to connect to the network share "%2". This receive function will try to connect again.
CIS_E_RECEIVE_FUNCTION_DISABLED | 0x172D | The receive function "%1" has experienced problems, it will be shut down and disabled. Once these problems have been corrected, re-enable this receive function in BizTalk Server Administration.
CIS_E_UNRECOVERABLE | 0x172E | There was a serious error within the BizTalk Server scheduler component. The server is being shut down. Resolve this problem and then restart the server.
CIS_E_RELIABLE_NOACK | 0x172F | The server has not received a receipt for the reliable message.
CIS_E_DLQ_ID | 0x1730 | Suspended Queue ID: "%1"
CIS_E_CANNOT_FIRE_EVENT | 0x1731 | The server cannot send a WMI event for the Suspended queue item "%1". The most likely cause is that the user configured for this submission has insufficient privileges to access WMI.
CIS_E_HTTP_L_INITIALIZATION | 0x1750 | The BizTalk HTTP receive function could not complete initialization. Verify that the security credentials of "BizTalkHTTPReceive.dll" include access to the BizTalk configuration database.
CIS_E_HTTP_L_NO_DATA_SEND | 0x1751 | The BizTalk HTTP receive function "%1" received a request with no data.
CIS_E_HTTP_L_NO_THREAD_FROM_POOL | 0x1752 | The BizTalk HTTP receive function "%1" could not retrieve a thread from the thread pool.
CIS_E_HTTP_L_NO_TRANSPORT | 0x1753 | The BizTalk HTTP receive function could not select a valid transport. Check the configuration of this receive function: Request URL="%1".
CIS_E_HTTP_L_SERVER_SUPP_FUNCT | 0x1754 | The BizTalk HTTP receive function "%1" made a call to IIS Server Support Function: "%2" which failed.
CIS_E_HTTP_L_POST_THREAD_POOL | 0x1755 | The BizTalk HTTP receive function "%1" could not post the work item to the thread pool. Try increasing the length of the thread pool queue using the registry key "QueueFactor".
CIS_E_HTTP_L_GET_FROM_THREAD_POOL | 0x1756 | The BizTalk HTTP receive function "%1" could not retrieve a work item from the thread pool.
CIS_E_HTTP_L_SEND_HEADERS | 0x1757 | The BizTalk HTTP receive function "%1" could not send the HTTP headers to the client.
CIS_E_HTTP_L_ASYNC_PROCESSING | 0x1758 | The BizTalk HTTP receive function "%1" failed during asynchronous processing of an IIS request.
CIS_E_HTTP_L_ASYNC_IIS_ERROR | 0x1759 | The BizTalk HTTP receive function "%1" received an error from IIS while processing an asynchronous request.
CIS_E_HTTP_L_DLL_LOAD_FAILURE | 0x175A | The BizTalk HTTP receive function could not load the DLL "%1".
CIS_E_HTTP_L_CREATION_FAILURE | 0x175B | The BizTalk HTTP receive function could not create "%1", error:"%2".
CIS_E_HTTP_L_TRANSPORT_URL | 0x175C | The BizTalk HTTP receive function could not extract a valid transport URL from the request URL. Error:"%1". Request URL="%2".
CIS_E_HTTP_L_TRANSPORT_URL_INVALID | 0x175D | The BizTalk HTTP receive function transport alias "%1" is not valid. Check the configuration of this receive function.
CIS_E_HTTP_L_TRANSPORT_HANDLE_INVALID | 0x175E | The BizTalk HTTP receive function transport handle for alias "%1" is not valid. Check the configuration of this receive function.
CIS_E_HTTP_L_FILE_CREATION_FAILURE | 0x175F | The BizTalk HTTP receive function "%1" could not create the file "%2".
CIS_E_HTTP_L_SET_FILE_POINTER_FAILURE | 0x1760 | The BizTalk HTTP receive function "%1" could not set the file pointer while writing to the file "%2".
CIS_E_HTTP_L_FILE_WRITE_FAILURE | 0x1761 | The BizTalk HTTP receive function "%1" could not write to the file "%2".
CIS_E_HTTP_L_FILE_LOCK_FAILURE | 0x1762 | The BizTalk HTTP receive function "%1" could not obtain a lock on the file "%2".
CIS_E_HTTP_L_BUILD_FILE_NAME_FAILURE | 0x1763 | The BizTalk HTTP receive function "%1" could not build a valid file name for "%2.
CIS_E_HTTP_L_FILE_DELETE_FAILURE | 0x1764 | The BizTalk HTTP receive function "%1" could not delete the file "%2".
CIS_E_HTTP_L_DETERMINING_CODE_PAGE | 0x1765 | The BizTalk HTTP receive function "%1" could not retrieve the code page for charset="%2".
CIS_E_HTTP_L_MSMQ_SEND_FAILURE | 0x1766 | The BizTalk HTTP receive function could not send a message to the message queue "%1", HR=%2, Request URL:"%3".
CIS_E_HTTP_L_MSMQ_OPEN_FAILURE | 0x1767 | The BizTalk HTTP receive function could not open the message queue "%1", HR=%2.
CIS_E_HTTP_L_REGISTRY_FAILURE | 0x1768 | The BizTalk HTTP receive function could not retrieve the configuration from the registry.
CIS_E_HTTP_L_CP_CONVERTION_FAILURE | 0x176A | The BizTalk HTTP receive function "%1" encountered an error converting the document to UNICODE.
CIS_E_HTTP_L_SUBMIT_FAILED | 0x176B | The BizTalk HTTP receive function "%1" failed to submit the document into BizTalk Messaging.
CIS_E_HTTP_L_SERVER_VARIABLE | 0x176C | The BizTalk HTTP receive function could not successfully retrieve the server variable "%1" from IIS, error:%2.
CIS_E_HTTP_L_BASE_URL_NOT_OBTAINABLE | 0x176D | The BizTalk HTTP receive function could not retrieve the URL from IIS.
CIS_E_HTTP_L_SUBMISSION_HANDLE_ERROR | 0x176E | The BizTalk HTTP receive function "%1" could not send the BizTalk correlation token to the client.
CIS_E_HTTP_L_GET_CONFIG_ERROR | 0x176F | The BizTalk HTTP receive function could not successfully retrieve the configuration information from the database, hr=%1.
CIS_E_HTTP_L_IMPERSNT_FAILED | 0x1770 | The BizTalk HTTP receive function could not get the appropriate security credentials to access the database.
CIS_E_HTTP_L_WRITE_RESPONSE_ERROR | 0x1771 | The BizTalk HTTP receive function "%1" could not send the HTTP response to the client.
CIS_E_HTTP_L_SUBMITSYNC_FAILED | 0x1772 | The BizTalk HTTP receive function "%1" could not synchronously submit the document to BizTalk Messaging.
CIS_E_HTTP_L_MOVETOSUSPENDQ_FAILED | 0x1773 | The BizTalk HTTP receive function "%1" could not move the document received to the Suspended Queue.
CIS_E_SERIALIZER_INVALID_DOCUMENT | 0x1800 | The document with the "%1" tracking identifier is invalid XML. The serializer cannot continue.
CIS_E_BTF_INVALID_ADDRESS_TYPE | 0x1801 | The BizTalk Framework document has an "type" specified that is not valid for the "%1" address field. This document will be moved to the Suspended queue.
CIS_E_RELIABLE_MSG_RECEIPT_REQ_BY | 0x1802 | The BizTalk Framework document "%1" will not be transmitted as it has an expired "receiptRequiredBy" timestamp. This message will be discarded.
CIS_E_CUSTOM_ENVELOPE_ERROR | 0x1803 | The custom envelope:"%1" had the property "%2" specified, but the custom envelope generator could not to locate the XML node. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_DATETIME | 0x1804 | The "%1" date or time format is not valid. Correct the format specification.
CIS_E_SERIALIZER_INVALID_DTDATA | 0x1805 | The "%1" date or time field is not a valid ISO8601 format. Make sure that the XML date or time is formatted correctly.
CIS_E_SERIALIZER_INVALID_DELIMITER | 0x1806 | The "%1" delimiter is either missing or has a value specified that is not valid. Update the delimiter value.
CIS_E_SERIALIZER_MISSING_PROPSET | 0x1807 | The "%1" document is missing the entire property set that is required for this serializer to run.
CIS_E_SERIALIZER_MISSING_PROP | 0x1808 | The property set for the "%1" document either is missing or does not contain a valid value for the "%2" property. Add or correct this property.
CIS_E_SERIALIZER_INVALIDARG | 0x1809 | Both source and destination qualifiers and values are required for this serializer to run. Specify qualifiers and values in the messaging port for this transaction.
CIS_E_SERIALIZER_MISMATCH_SPEC | 0x180A | The serialization produced no output. Verify that the document specification matches the outbound XML document.
CIS_E_SERIALIZER_FAILED | 0x180B | The serializer could not finish processing. See the following messages for details.
CIS_E_SERIALIZER_INVALID_SRCQUAL | 0x180C | The "%1" qualifier for the source identifier is too long to be placed in the outbound document header. Update the channel with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_SRCID | 0x180D | The "%1" value for the source identifier is too long to be placed in the output header. Update the channel with a shorter value.
CIS_E_SERIALIZER_INVALID_DESTQUAL | 0x180E | The "%1" qualifier for the destination identifier is too long to be placed in the output header. Update the port with a shorter qualifier.
CIS_E_SERIALIZER_INVALID_DESTID | 0x180F | The "%1" value for the destination identifier is too long to be placed in the output header. Update the port with a shorter identifier.
CIS_E_SERIALIZER_INVALID_POSREC | 0x1810 | The "%1" positional record is defined to contain a record length of zero. This happens when there is no tag, and none of the fields in this record specify start and end positions. Update the fields to have valid start and end positions for this record.
CIS_E_SERIALIZER_NODELIMS | 0x1811 | This serializer component requires delimiters specified in the messaging port. Specify a valid delimiter set for this component.
CIS_E_SERIALIZER_INVALID_CHAR | 0x1812 | The serializer component has encountered a character, "%1", that is not valid. An entry specified in the InvalidCharacterMap tag of the document specification states that characters between "%2" and "%3" are not valid.
CIS_E_SERIALIZER_INVALID_LENGTH | 0x1813 | The length of the "%1" field ("%2") is not valid; it must be between %3 and %4. This document will be rejected.
CIS_E_SERIALIZER_SELECT_SINGLE_NODE_FAILED | 0x1814 | The serializer component cannot find the node using the query "%1". This document will be rejected.
CIS_E_SERIALIZER_RELIABLE_URL_MISSING | 0x1815 | The reply-to URL required for reliable messaging was not set. This document will be rejected.
CIS_E_SERIALIZER_CONTROL_NUMBER | 0x1816 | The serializer component cannot find a control number for %1 %2 in the BizTalk Management database. This document will be rejected.
CIS_E_CUSTOM_ENV_PARSE_TABLE_ERROR | 0x1817 | The serializer component failed to build the custom envelope ID:"%1", this was due to errors in the XML Schema supplied. This document will be moved to the Suspended queue.
CIS_E_SUBSYNC_RELIABLE_MSG | 0x1818 | The BizTalk Framework document that was submitted has "reliability" information specified. This information is not permitted in a synchronous call.
CIS_E_CUSTXML_BODY_NOT_FOUND | 0x1819 | The parser was unable to locate the XML document node by using the query specified in the XML specification: "%1".
CIS_E_BTF_ACK_BAD_MSG_ID | 0x181A | The BizTalk Framework receipt had a <prop:identity> tag that is not valid: "%1". This document will be moved to the Suspended queue.
CIS_E_BTF_MANIFEST_REF_MISSING | 0x181B | The BizTalk Framework document has a <manifest> tag without the mandatory <reference> tag. This document will be moved to the Suspended queue.
CIS_E_CUSTOM_ENV_NO_DOC_NODE | 0x181C | The serializer failed to create the custom envelope because the Document Container Node property was not specified in the XML specification. This document will be moved to the Suspended queue.
CIS_E_BTF_INVALID_XSI_TYPE | 0x181D | The BizTalk Framework document contains an xsi:type attribute "%1" that is not valid. This attribute must not have spaces, and the first character must be alphabetical. This document will be moved to the Suspended queue.
CIS_E_SERIALIZER_INVALID_SYNTAX_IDENTIFIER | 0x181E | The EDIFACT Syntax Identifier "%1" is not valid. Update the channel with a correct identifier.
CIS_E_SERIALIZER_INVALID_UNA_CONTROL | 0x181F | The EDIFACT UNA Control value "%1" is not valid. Update the channel with a correct value.
CIS_E_SERIALIZER_EXPECT_BSTR_VALUE | 0x1820 | The configuration data for the field "%1" must be a string. Update the data for this field.
BTS_E_XMLSERIALIZER_MISSING_DEST | 0x1821 | The BizTalk Framework header could not be generated because no destination identifier was specified.
BTS_E_XMLSERIALIZER_MISSING_SRC | 0x1822 | The BizTalk Framework header could not be generated because no source identifier was specified.
CIS_E_BTF_IDENTITY_MISSING | 0x1904 | The parser could not find the mandatory BizTalk Framework tag "identity". This document will be moved to the Suspended queue.
CIS_E_BTF_EXPIRESAT_MISSING | 0x1905 | The parser could not find the mandatory BizTalk Framework tag "expiresAt". This document will be moved to the Suspended queue.
CIS_E_MSMQ_NOT_INSTALLED | 0x1906 | The Message Queuing receive function could not be started because the Message Queuing service is not installed on the server.
CIS_W_FILE_RECEIVE_RETRY_FAILURE | 0x1907 | There are file(s) in the "%1" directory that cannot be accessed by the file receive function. The receive service will try again to access the file(s) in "%2" seconds.
CIS_E_FILE_RECEIVE_DELETE_FAILURE | 0x1909 | The following file could not be deleted after processing: "%1". Make sure that the file attribute is not set to read-only.
CIS_E_LOGON_USER_FAILURE | 0x190a | Unable to logon with the account %1. Make sure that %2 has been granted "logon locally" privilege on this server and that the BizTalk Server account has "act as part of the operating system" privilege.
CIS_E_MSMQ_RECEIVE_IMPERSONATION_FAILURE | 0x190b | The "%1" Message Queuing receive function could not impersonate the logged on user.
CIS_E_RECEIVE_CANNOT_CREATE_THREAD | 0x190c | A receive-function thread cannot be created due to a system error.
CIS_E_MSMQ_RECEIVE_OPENQ_FAILURE | 0x190d | The following Message Queuing queue cannot be opened: "%1" (Message Queuing error code: 0x%2=%3). Verify the existence and security setting of the queue.
CIS_E_MSMQ_RECEIVE_PEEKQ_FAILURE | 0x190e | The Message Queuing queue could not be read: "%1" (Message Queuing error code: 0x%2=%3).
CIS_E_MSMQ_RECEIVE_RETRIEVEQ_FAILURE | 0x190f | A message could not be retrieved from the following Message Queuing queue: '%1' (Message Queuing error: 0x%2=%3).
CIS_E_FILE_RECEIVE_FINDCHANGE_FAILURE | 0x1910 | The file-change notification cannot be set up on the following directory: "%1". Make sure that the path is correct.
CIS_E_SET_CURRENT_DIR_FAILURE | 0x1911 | The current directory cannot be set to: "%1". Make sure that the path is correct.
CIS_W_RECEIVE_SUBMIT_FAILURE | 0x1914 | A submit request initiated from the "%1" receive function has failed.
CIS_E_READONLY_FILE | 0x1915 | The "%1" receive function picked up the following file: '%2'. This file is marked as read-only and cannot be processed.
CIS_E_BAD_RECSVC | 0x1916 | There was a serious failure in the receive function "%1". This receive service will be shut down, please check the event log for additional error messages.
CIS_E_FILE_RECEIVE_IMPERSONATION_FAILURE | 0x1917 | The "%1" file receive function could not impersonate the logged on user.
CIS_E_MSMQ_RECEIVE_UNEXPECTED_PASSTHROUGH | 0x1918 | The ""%1"" Message Queuing receive function is not configured for a pass-through submission, but it has encountered a document that was submitted previously as a pass-through submission. Change this receive function to accept pass-through submissions or remove the pass-through document from the queue. This receive function will be shut down.
CIS_E_BTSDOCUMENT_INVALIDNAME | 0x1A00 | The document named "%1" does not exist. Correct the document name or add the document to the BizTalk Messaging Management database.
CIS_E_BTSDOCUMENT_INVALIDDOC | 0x1A01 | The server could not load any documents with the given criteria.
CIS_E_BTSDOCUMENT_AMBIGUOUS_NAMESPACE | 0x1A02 | The root node "%1" is ambiguous because documents "%2" and "%3" refer to different specifications with that name. Either change the specifications to remove this ambiguity or use the document name explicitly.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSET | 0x1A03 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set.
CIS_E_BTSDOCUMENT_AMBIGUOUS_PROPSETSHAREID | 0x1A04 | The property set is ambiguous because documents "%1" and "%2" refer to the same property set and have reference "%3".
CIS_E_BTSDOCUMENT_INVALIDPROPERTYSET | 0x1A05 | The following property set was specified: %1.
CIS_E_BTSDOCUMENT_EMPTYPROPERTYSET | 0x1A06 | The property set was empty.
CIS_E_BTSDOCUMENT_LOADFAILED | 0x1A07 | The document "%1" could not be loaded. Possible causes are using a non-envelope specification, or incorrectly configured tracking details.
CIS_E_BTSENVELOPE_LOADFAILED | 0x1A20 | The envelope "%1" could not be loaded. A possible cause is that the specification is not valid. Configure a valid envelope specification.
CIS_E_FAILED_TO_JOIN_TX | 0x1A21 | BizTalk Server failed to join a transaction. Ensure both the DTC and the SQL Server database are running.
MSG_COM_CREATE_FAILED | 0x1B01 | An instance of the %1 class cannot be created: %2.
MSG_CONNECT_WMI_FAILED | 0x1B02 | A connection to Windows Management on "%1" cannot be established: %2.
MSG_COSETPROXY_FAILED | 0x1B03 | The authentication credential cannot be set for the Windows Management connection: %1.
MSG_WMI_ENUMINST_FAILED | 0x1B04 | Instances of the BizTalk Server WMI provider class "%1" cannot be enumerated: %2.
MSG_WMI_GETPROP_FAILED | 0x1B05 | The property value of "%1" cannot be retrieved from the BizTalk Server WMI provider because of an unexpected error: %2.
MSG_WMI_EXECQUERY_FAILED | 0x1B06 | An unexpected error is preventing execution of the BizTalk Server WMI provider query "%1": %2.
MSG_WMI_GETOBJ_FAILED | 0x1B07 | The BizTalk Server WMI provider instance of "%1" cannot be retrieved because of an unexpected error: %2.
MSG_WMI_PUTPROP_FAILED | 0x1B08 | The property value of "%1" cannot be changed because of an unexpected error: %2.
MSG_WMI_PUTINST_FAILED | 0x1B09 | The property values of the BizTalk Server WMI provider instance "%1" cannot be updated because of an unexpected error: %2.
MSG_WMI_DELINST_FAILED | 0x1B0A | The BizTalk Server WMI provider instance "%1" cannot be deleted because of an unexpected error: %2.
MSG_WMI_CREATEINST_FAILED | 0x1B0B | A new instance of the WMI class "%1" cannot be created in the BizTalk Server WMI provider: %2.
MSG_WMI_CREATEGETOBJ_FAILED | 0x1B0C | A new instance of the BizTalk Server WMI provider class "%1" cannot be created because of an unexpected error: %2.
MSG_WMI_EXECMETHOD_GETOBJ_FAILED | 0x1B0D | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the class: %3.
MSG_WMI_EXECMETHODCLASS_FAILED | 0x1B0E | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to retrieve the method information: %3.
MSG_WMI_EXECMETHODSPAWN_FAILED | 0x1B0F | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of an unexpected error: %3.
MSG_WMI_EXECMETHODPUTPARAM_FAILED | 0x1B10 | The method "%1" of the BizTalk Server WMI provider class "%2" cannot be executed because of a failure to set the parameter value: %3.
MSG_WMI_EXECMETHOD_FAILED | 0x1B11 | The method "%1" of the WMI class "%2" cannot be executed by the BizTalk Server WMI provider: %3.
MSG_GET_HOSTNAME_FAILED | 0x1B12 | The local computer name cannot be obtained because of an unexpected error: %1.
MSG_OUT_OF_MEMORY | 0x1B14 | Insufficient memory.
MSG_FAIL_LOAD_BMP | 0x1B17 | At least one of the bitmaps cannot be loaded in the BizTalk Server Administration console: %1.
MSG_FAIL_SET_BMPSTRIP | 0x1B18 | At least one pair of bitmaps cannot be added to the image list of the BizTalk Server Administration console: %1.
MSG_ERROR_WMI_PATH_EMPTY | 0x1B19 | The requested operation cannot be completed because of a previous WMI failure. The WMI object path is empty in this case.
MSG_ERROR_BTM_GRP_ENUM_FAIL | 0x1B20 | Unknown problems are preventing the WMI provider from enumerating a list of server groups from the BizTalk Messaging Management database: %1.
MSG_ERROR_GRP_DTA_DB_FAIL | 0x1B21 | Unknown problems are preventing the WMI provider from accessing the Tracking database for the "%1" group.
MSG_ERROR_GRP_SQ_DB_FAIL | 0x1B22 | Unknown problems are preventing the WMI provider from accessing the Shared Queue database the "%1" group.
MSG_ERROR_GRP_BOTH_DB_FAIL | 0x1B23 | Unknown problems are preventing the WMI provider from accessing the Tracking and Shared Queue databases for the "%1" group.
MSG_ERROR_DECRYPT_FAIL | 0x1B24 | Password decryption failed: %1.
MSG_WARN_ENUM4ROOTUPD_FAILED | 0x1B27 | Unknown problems are preventing the WMI provider from retrieving following list of servers and their states to prepare for BizTalk Messaging Management database update: %1
MSG_ERROR_CHANGE_ROOTDB | 0x1B28 | The server "%1" cannot be updated with the new BizTalk Messaging Management database information: %2.
MSG_ERROR_CHANGE_ROOTDB_CONNECT | 0x1B29 | We cannot connect to the WMI namespace "%1" to update server "%2" with the new BizTalk Messaging Management database information: %3
MSG_CHANGE_ROOTDB_SUMMARY | 0x1B30 | The BizTalk Messaging Management database change request has been completed. %1%2 %3%4
MSG_CHANGE_ROOTDB_ON_LOCAL | 0x1B3A | Because the server and server group information cannot be retrieved from the original BizTalk Messaging Management database, the BizTalk Messaging Management database information will be updated only on the local computer "%1". The update has been successful.
MSG_ERROR_UNEXPECTED_ENDOFLIST | 0x1B3C | An unexpected end of list (EOL) for the "%1" class enumeration has been reached.
MSG_ERROR_ORG_QUALIFIERS_FROM_DB_FAILED | 0x1B3D | The organization qualifiers cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_ERROR_ORG_VALUES_FROM_DB_FAILED | 0x1B3E | The organization values cannot be retrieved from the BizTalk Messaging Management database because of an unexpected error. "%1".
MSG_WARN_NOT_RESUBMITABLE | 0x1B3F | In the selected group of multiple items, at least one item cannot be submitted again.
MSG_WARNING_PROP_VALUES_CHANGED | 0x1B40 | %1 "%2" specified for receive function "%3" has been removed from the BizTalk Messaging Management database.
MSG_WARNING_QUALIFIER_CHANGED | 0x1B41 | The qualifier and identifier pair "%1" and "%2" specified for receive function "%3" is not valid in the BizTalk Messaging Management database.
MSG_WARNING_ORGANIZATION_CHANGED | 0x1B42 | Organization "%1" specified for receive function "%2" is not valid in the BizTalk Messaging Management database.
MSG_TIMEBOMB_DAYS_LEFT | 0x1B43 | Thank you for evaluating Microsoft BizTalk Server. The period for this evaluation version has %1 days left. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server.
INTERCHANGE_EVENT | 0x3005 | BizTalk Server: %1

Note

  • When an error occurs, the %n variables are replaced with relevant information, such as an object name.


Orchestration Services Error Messages

The BizTalk Orchestration Services object model error messages in the following table are returned when a running XLANG schedule generates the warning or error. These messages can be viewed in Windows® 2000 Event Viewer.

Message name | Value | Description
ID_W_NOT_CREATOR | 0x1000 | An unauthorized client attempted to create a new instance of an XLANG schedule. The remainder of the moniker string and the identity of the client are shown in the following message. The client's security identifier (SID) is included as binary data: %1%0
ID_W_NOT_USER | 0x2001 | An unauthorized client attempted to gain access to an existing instance of an XLANG schedule. The remainder of the moniker string identifying the instance and the identity of the client are shown in the following message. The client's security identifier (SID) is included as binary data: %1%0
ID_W_REHYDRATIONERROR | 0x2002 | An error was encountered while rehydrating an XLANG schedule. There might be a problem reading the database or a problem with the information stored, or your system might be low on resources. The operation will be retried. Detailed information is provided in the following message.%1%0
IDS_E_COMSVCS_INTERNAL_ERROR | 0x3000 | The XLANG Scheduler Engine has detected an inconsistency in its internal state. Please contact Microsoft Product Support Services to report this error: %1%0
IDS_COMSVCS_RESOURCE_ERROR | 0x3001 | The XLANG Scheduler Engine has detected the absence of a critical resource and has caused the process that hosted it to end: %1%0
IDS_COMSVCS_INTERNAL_ERROR_ASSERT | 0x3002 | COM+ internal error. Please contact Microsoft Product Support Services to report this error. Assertion failure: %1%0
ID_E_USER_EXCEPTION | 0x3003 | The system has called a scheduled component and that component has failed and generated an exception. This indicates a problem with the scheduled component. Notify the developer of this component that a failure has occurred and provide the following information: %1%2%0
ID_INITIALIZE_FOR_DTC | 0x3004 | The XLANG Scheduler Engine was unable to initialize for transactions that are required to support transactional components. Make sure that MS DTC is running: %1%0
ID_E_CANT_CREATE_COMPONENT | 0x3005 | The XLANG Scheduler Engine was unable to create a user component that is required by the running XLANG schedule. Detailed information is provided in the following message. %1%0
ID_E_PROGID_NOT_FOUND | 0x3006 | The XLANG Scheduler Engine was unable to convert the Programmatic ID in the following message to a COM class ID: %1%0
ID_E_CANT_CREATE_INTERCEPTOR | 0x3007 | The XLANG Scheduler Engine was unable to create an interceptor object for the interface ID shown in the following message. Probable causes for this are 1) the interface isn't registered properly; 2) no type library is provided for the interface; or 3) the file that contains the interface type information can't be loaded. The port name associated with this interceptor is: %1%0
ID_E_INTF_NOT_SUPPORTED | 0x3008 | The XLANG Scheduler Engine detected an inconsistency between the port implementation and the COM components to which it refers. A component listed in the port implementation has failed to support the expected interface. The class ID of the component and the IID that it failed to support are shown in the following message. The port name associated with this component is: %1%0
ID_E_UNKNOWN_METHOD | 0x3009 | The XLANG Scheduler Engine received a call to a method that was not specified in the port implementation for this XLANG schedule. The IID and method number are shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_UNKNOWN_IDISPATCH_METHOD | 0x300A | The XLANG Scheduler Engine received a call through the IDispatch::Invoke() interface to a method that no longer exists. The dispatch ID for the method is shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_NAMED_PARAMS | 0x300B | The XLANG Scheduler Engine received a call through the IDispatch::Invoke() interface to a method that contains named arguments. Use positional arguments instead. The dispatch ID for the method is shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_BAD_INVOKE_PARAMS | 0x300C | The XLANG Scheduler Engine received a call through the IDispatch::Invoke() interface to a method with an incorrect number of parameters. The IID and the dispatch ID for the method are shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_BAD_RETURN_POINTER | 0x300D | The XLANG Scheduler Engine received an incorrect Out parameter through the IDispatch::Invoke() interface from a method. The reference returned was either not valid (NULL or a bad pointer) or does not support the expected interface. The expected dispatch ID is shown in the following message. The name of the message containing the bad port reference is: %1%0
ID_E_ACCESS_CHECK_FAILURE | 0x300E | The XLANG Scheduler Engine was not able to authorize the client's moniker resolution request. Access is denied.%0
ID_E_BAD_INVOKE | 0x300F | The IDispatch::Invoke() interface call to a method failed. The dispatch ID for the method is shown in the following message. The name of the port on which the call was attempted is: %1%0
ID_E_INVOKED_METHOD | 0x3010 | The invoked method, whose dispatch ID is shown in the following message, reported an error. The name of the port on which the call was attempted is: %1%0
ID_E_CANT_GET_TYPEINFO | 0x3011 | The component whose port name and COM CLSID are shown in the following message was unable to supply required type information to the XLANG Scheduler Engine.%1%0
ID_E_CANT_INVOKE_METHOD | 0x3012 | The XLANG Scheduler Engine was unable to deliver a method call to the object associated with the port name shown in the following message. The interface and method name that are invoked are also shown.%1%0
ID_E_CANT_GET_CLASSINFO | 0x3013 | The component whose port name and COM CLSID are shown in the following message was unable to supply required type information to the XLANG Scheduler Engine through the IProvideClassInfo::GetClassInfo interface.%1%0
ID_E_SCRIPT_ERROR | 0x3014 | A scripted decision rule in an XLANG schedule instance could not be executed. The error returned by the script engine is shown in the following message. The script's source code and information about the schedule instance in which the error occurred is also provided.%1%0
ID_E_SCRIPT_ERROR_NOINFO | 0x3015 | A scripted decision rule in an XLANG schedule instance has failed. Detailed information regarding the error could not be obtained due to an internal error. The error code is shown in the following message.%1%0
ID_E_SCRIPT_BADCONV | 0x3016 | A scripted decision rule in an XLANG schedule instance referred to a message field whose type was incompatible with the VBScript Engine. The XLANG Scheduler Engine attempted to convert the field to a compatible type but was unable to do so. The information in the following message shows the script rule, message, and field involved, as well as the original field variant type and the type to which a conversion was attempted. The field's VARIANT data structure is attached to this log entry as binary data.%1%0
ID_E_SCRIPT_BADARRAY | 0x3017 | A scripted decision rule in an XLANG schedule instance referred to a message field containing an array type that is incompatible with the VB script engine. Only variant arrays are supported by Visual Basic Scripting. The information in the following message shows the script rule, message, and field involved. The field's VARIANT data structure is attached to this log entry as binary data.%1%0
ID_E_SCRIPT_BADEXPR | 0x3018 | A scripted decision rule in an XLANG schedule instance contained an expression that did not return a Boolean result. The information in the following message shows the script rule and expression involved. The VARIANT data structure returned by the expression is attached to this log entry as binary data.%1%0
ID_E_SCHEDULE_NOT_RUNNING | 0x3019 | The XLANG Scheduler Engine received a call to an object associated with a port in an XLANG schedule instance that is not running. The name of the port on which the call arrived is: %1%0
ID_E_INTERNAL_EXCEPTION | 0x301A | A COM+ internal exception occurred. Contact Microsoft Product Support Services to report this error, and provide them with the information in the following message.%1%2%0
ID_E_BAD_DATAFLOW_NOMESSAGE | 0x301B | There is a problem with the data-flow specification. A message that is indicated as a source of data does not currently exist while this XLANG schedule is running. Detailed information is provided in the following message.%1%0
ID_E_BAD_ARGUMENTVALUE | 0x301C | One of the fields that is used as a parameter for a COM method call has a bad value type in it. This is most likely caused by incorrect or missing data flow. Detailed information is provided in the following message.%1%0
ID_E_DEEP_VARIANT_NESTING | 0x301D | One of the fields that is used as a parameter for a COM method call has more than one nesting level of VARIANTs. The IID and the method's dispatch ID are shown in the following message. The name of the port on which the call arrived is: %1%0
ID_E_BAD_MAPPORTVALUE | 0x301E | A field carrying a mapped port is not valid. Detailed information is provided in the following message.%1%0
ID_E_BAD_CALLPARAMNUMBER | 0x301F | An incorrect number of parameters are being passed into a call. Detailed information is provided in the following message.%1%0
ID_E_EXECUTINGCALLEDSCHEDULE | 0x3020 | The XLANG schedule cannot be executed as a top-level schedule. Context parameters must be passed to it. Detailed information is provided in the following message.%1%0
ID_E_CANT_GET_SUPPORTERRORINFO | 0x3021 | The component whose port name and COM CLSID are shown in the following message was unable to return success from an interface that it claimed to support to the XLANG Scheduler Engine via ISupportErrorInfo::InterfaceSupportsErrorInfo.%1%0
ID_E_PERSIST_FAILURE | 0x3022 | The state of the schedule instance could not be saved to the database. Detailed information is provided in the following message.%1%0
ID_E_TRANSACTION_COMMIT_FAILURE | 0x3023 | The system failed to commit a transactional context. Detailed information is provided in the following message.%1%0
ID_E_TRANSACTION_ABORTED | 0x3024 | The system aborted a transactional context. Detailed information is provided in the following message.%1%0
ID_E_TRANSACTION_ABORT_FAILURE | 0x3025 | The system failed to abort a transactional context. The state of this transaction is not known. Detailed information is provided in the following message.%1%0
ID_E_PENDINGREHYDRATIONERROR | 0x3026 | The rehydration application encountered an error and is shutting down. Some of the rehydration requests will fail due to this shutdown. Restart the XLANG Scheduler Engine service. Detailed information is provided in the following message.%1%0
ID_E_REHYDRATIONONSTARTUPERROR | 0x3027 | One or more XLANG schedules could not be rehydrated because of a system error. There might be problems reading the database or problems with the data that was read. Detailed information is provided in the following message.%1%0
ID_E_REHYDRATIONERROR | 0x3028 | An error was encountered while rehydrating an XLANG schedule. There might be a problem reading the database, or there might be a problem with the information stored. It is probable that the XLANG schedule was not dehydrated properly. Detailed information is provided in the following message.%1%0
ID_E_FOUNDINITIALIZEDTHREAD | 0x3029 | The XLANG Scheduler Engine service encountered a critical thread-management error while processing an XLANG schedule. The schedule might fail to continue processing. Contact your technical support.%1%0
ID_E_CALLONCOMPLETEDSCHEDULE | 0x302A | The XLANG Scheduler Engine service received a call on a completed XLANG schedule instance. The schedule instance has already been removed from memory. The IID for the interface is shown in the following message.%1%0
IDS_MSG_TIMEBOMB_EXPIRED | 0x302B | Thank you for evaluating Microsoft BizTalk Server 2002. The period for this evaluation version has ended. Please contact Microsoft or your software reseller to obtain a licensed version of Microsoft BizTalk Server 2002.%0
ID_E_FIELDPORTPERSISTENCEERROR | 0x302C | An error was encountered while attempting to persist an XLANG schedule instance. Detailed information is provided in the following message.%1%0
ID_E_FIELDPORTREHYDRATIONERROR | 0x302D | An error was encountered while attempting to restore a particular sub-component of an XLANG schedule instance from the database. Detailed information is provided in the following message.%1%0
ID_E_SCHEDULEDONE | 0x3030 | The XLANG Scheduler Engine encountered an error while marking the XLANG schedule instance as done. Either the database could not be updated or another error was encountered in the final stage. Detailed information is provided in the following message.%1%0
ID_E_COMPONENT_INCOMPATIBLE_TXN | 0x3031 | The XLANG Scheduler Engine encountered an error while attempting to instantiate a component. Either the component was previously enrolled in a different transaction, or the component was previously not enrolled in a transaction and the current instantiation requires a transaction. Detailed information is provided in the following message.%1%0
ID_E_SUSPEND_FAILURE | 0x3032 | The XLANG schedule instance could not be suspended. Detailed information is provided in the following message.%1%0
ID_E_INITNEW | 0x3033 | The XLANG Scheduler Engine received an error when doing IPersistStreamInit::InitNew. The class ID of the component and the error code are shown in the following message. The port name associated with this component is: %1%0
ID_E_POSSIBLEBYOTISSUE | 0x3034 | The component you requested could not be created. One possible reason for this is that you have configured the BYOT component inside a COM+ application on this machine. This setting is incompatible with the XLANG Scheduler service. The port name associated with this component is: %1%0
ID_E_FIELDPROCESSINGERROR | 0x3035 | The field value provided was not valid. Detailed information is provided in the following message.%1%0
ID_E_NO_OBJECT | 0x3036 | The XLANG schedule could not be instantiated. Detailed information is provided in the following message.%1%0
ID_E_STARTUP_FAILED | 0x3037 | One or more of the XLANG Group Managers failed to start up with the following error: %1%0
ID_E_NON_SCRIPT_BADEXPR | 0x3038 | An XLANG schedule instance has a rule comparing fields for data types that are not permitted. Detailed information is provided in the following message.%1%0
E_BTW_PERSIST_REACHEDEOF | 0x3039 | The recordset cannot return this row, because the end-of-file (EOF) has been reached.%1%0
ID_E_BAD_DATAFLOW_EMPTYFIELD | 0x3040 | There is a problem with the data-flow specification. A field indicated as a source of data is empty. This may be because it could not be persisted earlier. Detailed information is provided in the following message.%1%0
ID_E_CANT_OPEN_DEADLETTER_QUEUE | 0x3041 | The XLANG Scheduler Engine was unable to create or open the XLANG dead-letter queue for its host COM+ application. The name of the failing COM+ application is: %1%0
ID_E_CANT_XFER_TO_DEADLETTER_QUEUE | 0x3042 | The XLANG Scheduler Engine was unable to transfer an invalid message to the XLANG dead-letter queue for its host COM+ application. The name of the failing COM+ application is: %1%0
ID_E_CANT_LOADMODULE | 0x3043 | The XLANG Scheduler engine was unable to load a required module. This may have been due to compilation/semantic errors with the module. Detailed information is available in the following message: %1%0
ID_E_USER_DATA_EXCEPTION | 0x3044 | A value that was received from the client has caused an exception to be raised. This can be caused by incorrectly allocating memory for the data, by a reference counting mismatch, or other data corruption. The most likely source of the problem is in the client code. Detailed information is available in the following message: %1%2%0
E_BTW_INTERNAL_ERROR | 0x4001 | An internal error has occurred. %1%0
E_EXPORT_FAILED | 0x4002 | The XLANG schedule could not be processed.%0
E_BTW_UNKNOWN_SHAPE | 0x4003 | The compiler does not understand the shape. This shape is an unknown shape.%0
E_BTW_INCOMPLETE_FLOW | 0x4004 | The flow is incomplete because a connector is missing.%0
E_BTW_INCOMPLETE_FLOW_LEFT | 0x4005 | The flow is incomplete. The shape must have a flow connected to the left connector.%0
E_BTW_INCOMPLETE_FLOW_RIGHT | 0x4006 | The flow is incomplete. The shape must have a flow connected to the right connector.%0
E_BTW_INCOMPLETE_FLOW_LATERAL | 0x4007 | The flow is incomplete. The shape is not attached to anything on the side.%0
E_BTW_INCOMPLETE_FLOW_TOP | 0x4008 | The flow is incomplete. The shape must have a flow connected to the top connector.%0
E_BTW_INCOMPLETE_FLOW_BOTTOM | 0x4009 | The flow is incomplete. The shape must have a flow connected from the bottom connector.%0
E_BTW_INCOMPLETE_FLOW_ANYLINE | 0x400A | The flow is incomplete. Not connected to any shape.%0
E_BTW_MIRRORLIST_INCONSISTENT | 0x400B | Mirror shapes are not found in the On Failure or Compensation page. Retry after replacing the shape with a new one.%0
E_BTW_BEGIN_INSIDE_TRANSACTION | 0x4010 | The Begin shape must not be enclosed within a transaction.%0
E_BTW_END_MULTIPLE_LOOP | 0x4020 | Only one End shape can be used in the loop branch.%0
E_BTW_END_IN_TRANSACTION | 0x4021 | The End shape cannot be used in the context.%0
E_BTW_SYNCACTION_NO_PAIR | 0x4030 | Binding to a COM port requires actions to appear in pairs.%0
E_BTW_INCOMPLETE_FLOW_BINDING | 0x4031 | No binding for this action or port.%0
E_BTW_FIELD_TYPE_NOT_SUPPORTED | 0x4040 | Type (variant type=%1) is not supported.%0
E_BTW_ROLE_NOT_SUPPORTED | 0x4050 | Contracts (XLANG Schedules with Roles) cannot be compiled.%0
E_BTW_EMPTY_TRANSACTION | 0x4060 | The transaction contains no valid shapes.%0
E_BTW_TRANSACTION_NOT_PERMITTED | 0x4061 | Transaction shapes are not permitted when the XLANG schedule is treated as a COM+ component. Remove the transaction or edit the properties of the Begin shape to change the transaction model.%0
E_BTW_TRANSACTION_BOUNDARIES_CROSSED | 0x4062 | You cannot connect a flow from outside a transaction to a shape within a transaction without first connecting the flow to the transaction. Draw your flow to the top connection point of a transaction to connect it to the transaction. Then, click the transaction to highlight it. Draw another flow from the transaction connection point to the first shape within the transaction. To draw a flow that leaves the transaction, you must first connect the flow to the connection point at the bottom of the transaction. Then, click the transaction to highlight it. Draw another flow from the bottom connection point to the next shape in the business process.%0
E_BTW_TRANSACTION_TERMINATED_PREMATURELY | 0x4063 | At least one path within the transaction should flow out of the transaction.%0
E_BTW_NO_RULES_FOR_SWITCH | 0x4070 | Decision shapes must contain at least one rule.%0
E_BTW_CANNOT_WAIT_ON_ALL_SWITCH_BRANCHES | 0x40A0 | Cannot wait on "all" branches from the decision.%0
E_BTW_NO_BRANCH_FOUND | 0x40A1 | The join cannot find the corresponding fork or decision.%0
E_BTW_JOIN_MISMATCH | 0x40A2 | Only a single join may be used with a given fork or decision.%0
E_BTW_JOIN_SHARED | 0x40A3 | The same join cannot be used for flows coming from different forks or decisions.%0
E_BTW_CANNOT_WAIT_ON_SOME_SWITCH_BRANCHES | 0x40A4 | Not all paths from the decision come to the join.%0
E_BTW_CANNOT_WAIT_ANY_ON_FORK_BRANCHES | 0x40A5 | Cannot wait "Or". The branches contain process forms that might never finish, resulting in hung schedules.%0
E_BTW_DATAFLOW_DISALLOWED_ON_BTM_PORT | 0x40C0 | This port cannot be used in multiple receive actions or within a single receive action in a loop.%0
E_BTW_MESSAGE_TECH_NOT_FOUND | 0x4110 | The message is not bound to any port.%0
E_BTW_MESSAGE_TYPE_MISMATCH | 0x4111 | The message was used with conflicting types "%1" and "%2".%0
E_BTW_MISSING_TECHNOLOGY | 0x4120 | The list of available methods for this communication flow has changed. Re-run the Method Communication Wizard to select a different method and update this communication flow.%0
E_BTW_MISSING_PORT_DATAFLOW | 0x41A0 | The settings for this port indicate that it is created externally to the XLANG Scheduler Engine. You must designate the source of this port reference by drawing a connection from the appropriate message field.%0
E_BTW_CIRCULAR_DATAFLOW | 0x41A1 | There appears to be a circular path in the data-flow path for this XLANG schedule.%0
E_BTW_LOOP_NORULE | 0x41D0 | A rule has not been defined.%0
E_BTW_LOOP_BODY_EXITS_TRANSACTION | 0x41D1 | The body of the loop cannot exit the enclosing transaction.%0
E_BTW_LOOP_BODY_END_MISSING | 0x41D2 | The end of the body of the loop is not found.%0
E_BTW_ABORT_NOT_IN_TXN | 0x41E0 | Abort shapes must be associated with an enclosing transaction.%0
E_BTW_ABORT_CONTEXT_INVALID_SCOPE | 0x41E1 | Abort shapes can refer to current or parent contexts only.%0
E_BTW_END_MULTIPLE_ABORT | 0x41E2 | Multiple End shapes are not allowed on the On Failure page.%0
E_BTW_COMPILER_FAILED | 0x5000 | Compile failed on "%1".%0
E_BTW_PARSE_FAILED | 0x5001 | Parse failed.%0
E_BTW_FIXUP_FAILED | 0x5002 | Fixup failed.%0
E_BTW_VALIDATION_FAILED | 0x5003 | Validation failed.%0
E_BTW_NODE_FAILURE | 0x5004 | at node "%1" (%2!d!,%3!d!).%0
E_BTW_STACK_TOO_MANY_ITEMS | 0x5005 | Too many items were found on the stack.%0
E_BTW_STACK_UNEXPECTED_NODE | 0x5006 | An unexpected node was found.%0
E_BTW_XMLQUERY_RETURNED_ZERO_NODES | 0x5007 | The XML Query returned zero nodes.%0
E_BTW_XMLQUERY_RETURNED_MULTIPLE_NODES | 0x5008 | The XML Query returned multiple nodes.%1%0
E_BTW_XMLQUERY_MISSING_ATTRIBUTE | 0x5009 | Required attribute "%1" is missing its value.%0
E_BTW_LOAD_MODULE_FAILED | 0x500A | Failed to load module "%1".%0
E_BTW_XML_LOAD_FAILED | 0x500B | The XML-DOM returned an error at "%1!d!, %2!d!".%0
E_BTW_ERROR_LOADING_PACKAGE | 0x500C | 0x%1!X! error occurred while trying to load the following URL: "%2".%0
E_BTW_NAMED_LIST_HAS_DUPLICATE_ENTRIES | 0x500D | The list has duplicate entries with the name "%1".%0
E_BTW_REQUIRED_ELEMENT_MISSING | 0x500E | Required element "%1" is missing.%0
E_BTW_ELEMENT_MISSING_VALUE | 0x5100 | The element value is missing.%0
E_BTW_REFERENCE_RESOLVE_FAILED | 0x5110 | Unable to resolve "%1" with location value "%2".%0
E_BTW_CONTEXTREF_INVALID_REFERENCE | 0x5120 | Returning to or "releasing" from an independent (non-enclosing) context is not permitted.%0
E_BTW_CONTEXTREF_SELF_REFERENCE | 0x5121 | Return or Release referring to a context from within that context is not permitted.%0
E_BTW_ASYNC_ACTION_COM_NOT_ALLOWED | 0x5400 | An asynchronous action must refer to a non-COM port.%0
E_BTW_CONNECTION_PORT_HAS_TECH_BINDING | 0x5490 | The port "%1" used in a connection cannot have technology binding.%0
E_BTW_CONNECTION_PORT_REUSED | 0x5491 | The port "%1" used in a connection has been used before in the XLANG schedule.%0
E_BTW_TRANSACTIONS_NESTED | 0x54B0 | When transactions are nested, the outer transaction must be long-running.%0
E_BTW_TRANSACTIONS_NESTED_RETRY | 0x54B1 | When transactions are nested, the outer transaction cannot have retry count.%0
E_BTW_MESSAGE_HAS_NO_DECL | 0x5520 | Message "%1" has no associated declaration.%0
E_BTW_MESSAGE_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5521 | Message "%1" has unsatisfied data dependencies on "%2". The dependencies are either not getting created in the flow or are potentially expected on a port in which the "No instantiation" option has been selected.%0
E_BTW_PORT_HAS_NO_BINDING | 0x5570 | Port "%1" has no associated binding.%0
E_BTW_PORT_HAS_UNSATISFIED_DATA_DEPENDENCIES | 0x5571 | Port "%1" has unsatisfied data dependencies on messages "%2". The dependencies are either not being created in the flow or are potentially expected on a port in which the "No instantiation" option has been selected.%0
E_BTW_RULE_HAS_NO_BINDING | 0x55B0 | Rule "%1" has no associated binding.%0
E_BTW_SCHEDULE_SUSPENDED | 0x55E0 | The XLANG schedule has been suspended.%0
E_BTW_SCHEDULE_STOPPED | 0x55E1 | The XLANG schedule has been stopped.%0
E_BTW_PERSIST_FAILED | 0x55E2 | The state of the XLANG schedule instance could not be saved to the database.%0
E_BTW_SUSPEND_FAILED | 0x55E3 | The XLANG schedule could not be suspended.%0
E_XLANG_SHUTTINGDOWN | 0x55E4 | The XLANG application is shutting down.%0
E_BTW_MISSING_MESSAGE_BINDING_ON_PORT | 0x5730 | The action uses port "%1" whose binding does not define the binding for message "%2".%0
E_BTW_MISSING_INCOMING_PORTREF | 0x5731 | The message used by this receive action contains a field (%1) that is connected to a port reference (%2) but the dataflow connections do not indicate that the port reference should be received.%0
E_BTW_SOURCE_PORT_HAS_NOINVOCATION | 0x5740 | The send action refers to port "%1", in which the "No instantiation" option has been selected.%0
E_BTW_MISSING_OUTGOING_PORTREF | 0x5741 | The message used by this source action contains a field (%1) that is connected to a port reference (%2) but the dataflow connections do not indicate that the port reference should be sent.%0
E_BTW_TASK_LIMIT | 0x5750 | The task has "%1!d!" actions. The current limit is "%2!d!".%0
E_BTW_SYNC_DIFFERENT_PORTS | 0x5760 | Synchronous action pair refers to different ports: "%1" and "%2".%0
E_BTW_SYNC_SAME_MESSAGE | 0x5761 | Synchronous action pair refers to the same message: "%1".%0
E_BTW_SYNC_ONLY_COM_ALLOWED | 0x5762 | Synchronous action pair must refer to COM port only.%0
E_BTW_SYNC_SECOND_MESSAGE_MUST_BE_OUT_FOR_FIRST_MESSAGE | 0x5763 | In a synchronous action pair the message in the second action must be the out message for the message in the first action.%0
E_BTW_INVALID_DELAY_TIME | 0x5770 | The delay time (%1!d!) is not valid. The delay time cannot be a negative number.%0
E_BTW_CALL_MESSAGE_SCHEMA_NAME_MISMATCH | 0x5800 | The message specification name "%1" for the message "%2" in the calling XLANG schedule does not match the specification name "%3" in the called XLANG schedule.%0
E_BTW_CALL_MESSAGE_SCHEMA_REPRESENTATION_MISMATCH | 0x5801 | The message specification representation for message "%1" in the calling XLANG schedule does not match the specification representation in the called XLANG schedule.%0
E_BTW_ASSIGNMENT_PORT_HAS_TECH_BINDING | 0x5830 | Port "%1" used in an assignment in a cut form cannot have technology binding.%0
E_BTW_PARTITION_LIMIT | 0x5850 | The partition has "%1!d!" process(es). The current limit is "%2!d!".%0
E_BTW_MESSAGE_USED_IN_PARALLEL | 0x5851 | Parallel actions or processes use the same message "%1".%0
E_BTW_PORT_USED_IN_PARALLEL | 0x5852 | Parallel actions or processes use the same port "%1".%0
E_BTW_INVALID_RETRY_COUNT | 0x5A30 | The retry count "%1!d!" is not valid. The retry count cannot be negative.%0
E_BTW_INVALID_BACKOFF_VALUE | 0x5A31 | The back-off value "%1!d!" is not valid. The back-off value cannot be negative.%0
E_BTW_INVALID_TIMEOUT_VALUE | 0x5A32 | The timeout value "%1!d!" is not valid. The timeout value cannot be negative.%0
E_BTW_FIELD_RESERVED_NAME | 0x5A50 | %1 is a reserved field name.%0
E_BTW_ELEMENT_TYPE_NOT_DEFINED | 0x5A51 | The element type "%1" is not defined.%0
E_BTW_ELEMENT_TYPE_INCOMPLETE | 0x5A70 | The element type definition is incomplete. Provide either subelements or dt:type.%0
E_BTW_MULTIPLE_PORTS | 0x5A90 | Distinct ports "%1" and "%2" are used on the same field.%0
E_XLANG_INVALID_COMPARE_TYPE | 0x5A91 | Comparison of this data type is not permitted.%0
E_BTW_FIELD_NOT_MATCHING_SCHEMA_ELEMENT | 0x5A92 | FieldBinding for "%1" does not have a matching element in the schema at position "%2!d!".%0
E_BTW_FIELD_HAS_AMBIGUOUS_DATAFLOW | 0x5A93 | A message field cannot have both a data flow from another message field and a reference to a port. One of the data flows must be removed.%0
E_BTW_PORT_TARGET_INVALID | 0x5A94 | The type of this field is inappropriate for use as a port reference. Ports bound to a COM component can be communicated as object references or strings. Ports bound to Message Queuing may only be transferred as strings. Internal ports can be communicated only as object references.%0
E_BTW_FIELD_TARGET_INVALID | 0x5A95 | The target field "%1", which is of variant type "%2", cannot get data from source field "%3", which is of variant type "%4".%0
E_BTW_INITIALIZED_MESSAGEFIELD_INVALID_OVERWRITE | 0x5A96 | The data in field "%1" of an initialized message "%2" cannot be overwritten with data from another message or port in the binding specification.%0
E_BTW_DATAFLOW_INCOMPLETE | 0x5AB1 | A source action accepting [in] parameters must have the corresponding fields populated by data flow (that is, "from").%0
E_BTW_DATAFLOW_FROM_SYSTEM_FIELD | 0x5AB2 | Port cannot be initialized from a system field.%0
E_BTW_DATAFLOW_FROM_CONSTANT_FIELD | 0x5AB3 | Port cannot be initialized from a constant message field.%0
E_BTW_MISSING_SCRIPT_EXPRESSION | 0x5AC0 | No script expression was supplied for the rule.%0
E_BTW_BAD_SCRIPT_EXPRESSION | 0x5AC1 | %1 %2 at character position %3!d! in "%4".%0
E_BTW_MAP_INVALID_BINDING | 0x5AE0 | The binding for message "%1" must contain a reference for mapped port "%2".%0
E_BTW_MESSAGE_BINDING_SCHEMA_MISMATCH | 0x5AE1 | There is a mismatch between the binding and schema for the message "%1".%0
E_BTW_MESSAGEDECL_INIT_DATA_UNAVAILABLE | 0x5B00 | Unable to obtain initialization data for field "%1".%0
E_BTW_LATENCY_INVALID_VALUE | 0x5B20 | The Latency property value must be a non-negative integer that is less than the maximum long integer "%1!d!".%0
E_BTW_PORT_LATENCY_ON_INTERNAL | 0x5B21 | Cannot specify latency on an internal port.%0
E_BTW_MESSAGE_TECHNOLOGY_MISMATCH | 0x5BB0 | There is a mismatch between the port "%1" technology "%2" and the message "%3" technology "%4".%0
E_BTW_FIELD_TECHNOLOGY_MISMATCH | 0x5BC0 | There is a mismatch between the message "%1" technology "%2" and the field "%3" technology "%4".%0
E_BTW_COM_PORT_NOT_CREATABLE | 0x5C10 | If a COM port can be invoked, it must have a CLSID, a ProgID, or a moniker.%0
E_BTW_AUTORETURN_COM_PORT_MUST_BE_USED_INSIDE_CONTEXT | 0x5C11 | The port "%1", which is configured to abort a transaction if a method returns a failure HRESULT, can only be used inside a transaction.%0
E_BTW_COM_PORT_GENERAL_ACCESS_FAILURE | 0x5C12 | A COM port can be invoked. Please refer to the Windows 2000 documentation.%1%0
E_BTW_COM_PARAMETERS_LIMIT | 0x5C20 | The method has "%1!d!" parameter(s). The current limit is "%2!d!".%0
E_BTW_COM_NO_MATCHING_RETURN | 0x5C21 | The COM method has no matching Return.%0
E_BTW_COM_NO_MATCHING_METHOD | 0x5C22 | The COM Return has no matching method.%0
E_BTW_INVALID_SLOT_NUMBER | 0x5C23 | The slot number "%1!d!" is not valid. Slot numbers cannot be less than the following value: SLOT_NONE(-1).%0
E_BTW_INVALID_INVOKE_KIND | 0x5C24 | The invokeKind value "%1!d!" is not valid. Acceptable values are: 1,2,3,4 and 8.%0
E_BTW_PROXY_DISCONNECTED | 0x5C25 | The proxy has been disconnected.%0
E_BTW_COM_DISPATCH_SLOT_SPECIFIED | 0x5C26 | A slot number cannot be specified for the dispatch interface.%0
E_BTW_COM_SPECIFY_DISPID_OR_SLOT | 0x5C27 | Valid values for dispid or slot must be specified.%0
E_BTW_COM_INVALID_BYREF_FOR_RETURN_MESSAGES | 0x5C30 | Byref should be "1" since "%1" is a <com:return> message.%0
E_BTW_COM_INVALID_NESTED_VARIANTS | 0x5C31 | More than one level of nesting for variants is not permitted.%0
E_BTW_COM_FIELD_INDEX_MUST_BE_NON_NEGATIVE | 0x5C32 | The index "%1!d!" for the field is not valid. The index must be a non-negative integer.%0
E_BTW_COM_FIELD_INDEX_REPEATED | 0x5C33 | The index "%1!d!" for the field has been used before on another field in the message.%0
E_BTW_COM_FIELD_INDEX_NOT_CONTIGUOUS | 0x5C34 | For synchronous action pair messages "%1" and "%2", the index "%3!d!" for a field is not valid. The field indices for these messages must form a contiguous block of non-negative numbers that start with zero.%0
E_BTW_MSMQ_NO_MQRT_DLL | 0x5D00 | The Message Queue DLL, MQRT.DLL, cannot be loaded.%0
E_BTW_MSMQ_CREATECHANNEL | 0x5D01 | MQBinder: CreateChannel failed for: %1.%0
E_BTW_MSMQ_NOT_CONFIGERED_PROPERLY | 0x5D02 | The Message Queuing Service is not configured properly. A queue object could not be opened %1.%0
E_BTW_MSMQ_NO_CERTIFICATE_AVAILABLE | 0x5D03 | The Message Queuing Service is not able to obtain a certificate.%1%0
E_BTW_MSMQ_NO_WELLKNOWN_QUEUE_NAME | 0x5D04 | A message cannot be sent to a known queue because the queue is not named in the XLANG schedule. You must provide a queue name in the XLANG schedule.%1%0
E_BTW_MSMQ_INVALID_FIELD_TYPE | 0x5D05 | The field type specified for message "%1" field "%2" is not valid.%0
E_BTW_MSMQ_PORT_NOT_BOUND | 0x5D06 | The Message Queuing port is not bound.%1%0
E_BTW_MSMQ_QUEUE_NOT_TRANSACTIONAL | 0x5D10 | The queue does not have the correct transactional properties.%1%0
E_BTW_MSMQ_OPEN_ACCESSDENIED | 0x5D11 | A Message Queuing access denied error occurred when opening the queue. Compare the accessRole specified for the queue in the XLANG schedule with the rights associated to the current user.%1%0
E_BTW_MSMQ_OPEN_GENERALFAILURE | 0x5D12 | A Message Queuing failure occurred when opening the queue. Refer to the Message Queuing Service documentation in Windows 2000 to look up the error code and diagnose as appropriate.%1%0
E_BTW_MSMQ_PORT_NOT_CREATABLE | 0x5D13 | A port that is implemented by using a message queue must have a queue name.%0
E_BTW_MSMQ_GENERAL_QUEUE_ACCESS_FAILURE | 0x5D14 | A Message Queuing failure occurred when accessing the queue. Refer to the Message Queuing Service documentation in Windows 2000 to look up the error code and diagnose as appropriate.%1%0
E_BTW_MSMQ_INVALID_MESSAGE_VT_TYPE | 0x5D20 | The Message Queuing message is of unknown format.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGETYPE | 0x5D21 | The Message Queuing message is of unknown message type. The message type could not be obtained from the message.%1%0
E_BTW_MSMQ_MESSAGE_UNAUTHENTICATED | 0x5D22 | The Message Queuing message is not authenticated but the port only accepts authenticated messages.%1%0
E_BTW_MSMQ_MESSAGE_INCORRECT_AUTHENTICATE_LEVEL | 0x5D23 | The Message Queuing message is not authenticated at the requested level.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGE | 0x5D24 | The Message Queuing message has a message body that is not valid.%1%0
E_BTW_MSMQ_MESSAGE_NOT_SEND | 0x5D25 | The Message Queuing message could not be sent.%1%0
E_BTW_MSMQ_MESSAGE_SCHEMAVALIDATION_FAILED | 0x5D26 | The Message Queuing message was not successfully validated against the schema that was provided. Check the schema and the schema path.%1%0
E_BTW_MSMQ_COULD_NOT_CREATE_MQMESSAGE | 0x5D27 | The message instance could not be converted to a Message Queuing message. %1%0
E_BTW_MSMQ_NO_TRUSTRELATIONSHIP_FOR_USER | 0x5D28 | The trust relationship for the provided user could not be established.%1%0
E_BTW_MSMQ_MESSAGE_EMPTY_MESSAGE | 0x5D29 | The Message Queuing message has an empty message body.%1%0
E_BTW_MSMQ_MESSAGE_ONLY_ONE_EMPTY_XPATH_ALLOWED | 0x5D2A | The Message Queuing message can have only one field with an empty node path (XPath).%0
E_BTW_MSMQ_MESSAGE_ONE_EMPTY_XPATH_NEEDED | 0x5D2B | The Message Queuing message must have one field with an empty node path (XPath).%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGEBODY | 0x5D2C | The Message Queuing message has a message body that is not valid.%1%0
E_BTW_MSMQ_MESSAGE_INVALID_MESSAGESTRING | 0x5D2D | The Message Queuing message has an invalid string for the message body.%1%0
E_BTW_MSMQ_MESSAGE_UNKNOWN_MESSAGE | 0x5D2E | The Message Queuing message is an invalid or unknown message and was moved to the dead-letter queue.%1%0
E_BTW_MSMQ_MESSAGE_TYPE_CONFLICTING_SCHEMA | 0x5D2F | The Message Queuing messages "%1" and "%2", which are of type "%3" on port "%4", have conflicting specification representations. This could be because the name, type, or XPath query does not match for one of the fields in the two representations.%0
E_BTW_MSMQ_DOCUMENT_FIELD_TYPE_NOT_STRING | 0x5D30 | A Message Queuing message's field "%1", that has an empty node path (XPath), must be a string data type.%0
E_BTW_MSMQ_DOCUMENT_FIELD_CANNOT_CONVERT_TO_STRING | 0x5D31 | A Message Queuing message's field could not be converted to a string.%1%0
E_BTW_MSMQ_DOCUMENT_FIELD_CONVERTION_FAILURE | 0x5D32 | The Message Queuing message's field could not be converted.%1%0
E_BTW_CANT_DISPOSE_MESSAGE | 0x6001 | The XLANG schedule instance was bound to a queue that received a message that is not valid. The XLANG Scheduler Engine was unable to transfer this message to the dead-letter queue, so the schedule instance has been terminated.%0

Related Topic

Configure Event Viewer for BizTalk Server errors


Standard COM Error Messages

The following table shows the most common standard COM errors returned by the properties and methods of the BizTalk Server objects.

Constant | Value (32-bit) | Description
S_OK | 00000000 | The standard return value used to communicate successful completion.
S_FALSE | 00000001 | An alternate success value, typically used to communicate successful, but non-standard completion. The precise meaning depends on the method or property in question.
E_UNEXPECTED | 8000FFFF | Catastrophic failure error.
E_NOTIMPL | 80004001 | Not implemented error.
E_OUTOFMEMORY | 8007000E | Out of memory error.
E_INVALIDARG | 80070057 | One or more arguments are not valid error.
E_NOINTERFACE | 80004002 | Interface not supported error.
E_POINTER | 80004003 | Pointer not valid error.
E_HANDLE | 80070006 | Handle not valid error.
E_ABORT | 80004004 | Operation aborted error.
E_FAIL | 80004005 | Unspecified error.
E_ACCESSDENIED | 80070005 | General access denied error.
MK_E_NOOBJECT | 800401E5 | The object identified by this moniker could not be found.

Additional information may be available using the global Err object. In Visual Basic, the Description property of the Err object may contain a text description of the error.

In C++, call the OLE DB method GetErrorInfo on the IErrorRecords interface to retrieve the most recently set IErrorInfo pointer in the current logical thread. The GetDescription method of the IErrorInfo interface may return a text description of the error. For more information about the GetErrorInfo method, go to the MSDN Online Library Web site (msdn.microsoft.com/library/default.asp) and browse to OLE DB Interfaces in the Platform SDK.


glossaire de BizTalk Server 2000

A

abandonner (abort)

Annuler une transaction en cours. Dans les planifications d'orchestration, la forme Abandon est utilisée explicitement pour demander au moteur de XLANG Scheduler d'interrompre les tentatives d'exécution des transactions et de considérer les transactions atomiques comme ayant échoué. Les transactions qui ont échoué peuvent éventuellement exécuter le code « En cas d'échec de Transaction ».

Voir aussi : transaction, valider (commit)

action

Envoyer ou recevoir un message. L’envoi ou la réception d’actions peut être synchrone ou asynchrone, selon les services d’application implémentés dans une planification XLANG.

Administration de BizTalk Server (BizTalk Server Administration)

Interface MMC (Microsoft Management Console) utilisée pour gérer le groupe de serveurs BizTalk Server 2002 et leurs propriétés, contrôler les fonctions de réception et surveiller les opérations dans les files d'attente Microsoft SQL Server utilisées par le groupe de serveurs.

ANSI X12

Normes EDI définies par Accredited Standards Committee X12, dont le travail est approuvé par l’ANSI (American National Standards Institute).

Application Center 2000

Produit Microsoft conçu pour simplifier les tâches de migration des applications tout au long du cycle de développement (depuis la phase de développement jusqu'à la phase de production, en passant par la phase de test). Microsoft Application Center garantit la cohérence entre les applications de développement, de test et de production. En automatisant le déploiement des applications d'un serveur sur un autre, Application Center accélère les temps de transfert, élimine les erreurs dues aux interventions manuelles et améliore la qualité des versions de chaque application.

application de destination (destination application )

Application d'organisation d'origine conçue dans un port d'échanges comme destination des documents.

Voir aussi : organisation d'origine (home organization)

application métier (line-of-business (LOB) application)

Application principale d'une organisation. BizTalk Server 2002 prend en charge de nombreux protocoles de communication qui permettent aux applications métier d'envoyer et de recevoir des informations en toute sécurité.

application source (source application)

Application de l'organisation d'origine conçue dans un canal comme source des documents.

Voir aussi : canal (channel), organisation d'origine (home organization)

arrêt préventif (failfast)

Fin préventive d'un processus après la découverte d'une erreur interne ou d'une incohérence, avec pour objectif d'éviter des erreurs ultérieures risquant de provoquer des problèmes graves ou irrécupérables.

Assistant BizTalk SEED (BizTalk SEED Wizard)

Outil permettant à une entreprise de créer un package XML dans lequel elle inclut sa propre configuration. Les partenaires commerciaux de cette entreprise, une fois en possession de ce package, utilisent l'Assistant BizTalk SEED pour installer la configuration dans leurs organisations, et ainsi effectuer des échanges commerciaux sur le Web avec cette entreprise.

attribut (attribute)

Caractéristique d'un enregistrement ou d'un champ. Un attribut peut contenir plusieurs propriétés.

B

base de connaissances (knowledge base)

Ensemble de commentaires sur les règles relatives aux connaissances qui portent sur la signification et l'importance des événements. La Base de connaissances Microsoft contient des informations prédéfinies par Microsoft. La Base de connaissances de l'entreprise contient, quant à elle, les informations entrées par l'utilisateur de Microsoft Operations Manager 2000.

base de données de files d’attente partagée (Shared Queue database)

Base de données Microsoft SQL Server partagée par tous les serveurs d'un groupe de serveurs. Cette base de données enregistre toutes les informations relatives aux points de contrôle associées aux documents traités par BizTalk Server. Si un serveur tombe en panne, les autres ordinateurs qui utilisent la base de données de files d’attente partagée peuvent continuer à extraire les messages de la file d'attente de travail et à envoyer des messages dans cette file. La redondance ainsi que l'équilibrage de la charge des processus sont ainsi assurés. La base de données de files d’attente partagée est présentée graphiquement dans la console Administration de BizTalk Server sous forme d'une série de files d'attente distinctes.

Voir aussi : file d'attente de nouvel essai (Retry queue), base de données de files d'attente partagée (Shared Queue database), file d'attente interrompue (Suspended queue), file d'attente de travail (Work queue)

base de données de persistance (persistence database)

Base de données utilisée pour stocker l'état des planifications XLANG lorsqu'une planification XLANG est mise en attente. Une base de données par défaut appelée base de données Persistance d'orchestration est fournie lors de l'installation de BizTalk Server 2002.

base de données de suivi (tracking database)

Base de données Microsoft SQL Server associée à un groupe de serveurs qui permet d'assurer le suivi des documents traités par le serveur individuellement ou par lots. Vous pouvez également suivre l'état des planifications XLANG.

base de données Gestion d'échanges BizTalk (BizTalk Messaging Management database)

Base de données Microsoft SQL Server qui contient les informations relatives aux configurations de tous les serveurs, notamment les paramètres des groupes et des serveurs, les fonctions de réception et toutes les informations de configuration des échanges pour les objets créés à l’aide du Gestionnaire d’échanges BizTalk ou du modèle d’objet de configuration d’échanges BizTalk.

BizTalk Accelerator for HIPAA

Module complémentaire fourni avec Microsoft BizTalk Server 2002, qui permet aux organisations de créer rapidement et facilement des solutions HIPAA. Ce module intègre plusieurs applications qui permettent aux acteurs médicaux, aux patients et aux organismes de remboursement d'échanger, de surveiller et de contrôler les transactions soumises aux réglementations HIPAA. Il fournit les spécifications de documents, les applications et les composants requis au développement rapide de solutions HIPPA basées sur BizTalk Server 2002.

BizTalk Framework

Structure de commerce électronique indépendante de la plate-forme et basée sur des schémas XML (Extensible Markup Language) et des standards de l’industrie. Elle permet l’intégration sur plusieurs secteurs d’activités et entre des systèmes professionnels, indépendamment de la plate-forme, du système d’exploitation ou de la technologie sous-jacente. Plus particulièrement, elle est constituée des trois éléments suivants : schéma, produits et services. Pour plus d'informations sur BizTalk Framework, accédez au site Web de BizTalk (www.microsoft.com/france/biztalk/).

BizTalk Server 2002

Produit Microsoft destiné à l'automatisation de processus professionnels et l'intégration d'applications dans les entreprises et entre les entreprises. Microsoft BizTalk Server 2002 offre un environnement d’exécution et de développement puissant basé sur le Web, qui intègre des processus professionnels longs et faiblement couplés au sein d’une entreprise et dans plusieurs d’entre elles.
BizTalk Server 2002 inclut des fonctionnalités permettant de concevoir et d'utiliser des planifications XLANG, d'intégrer des applications existantes, de définir des spécifications de documents et des modifications de spécification ainsi que de contrôler et de consigner l'activité d'exécution.
Le serveur fournit une passerelle standard pour l’envoi et la réception de documents sur Internet, de même qu’une gamme de services assurant l’intégrité, le transfert, la sécurité et la prise en charge des données BizTalk Framework et d’autres formats de documents clés.

BizTalk Server Accelerator for RosettaNet

Module complémentaire fourni avec Microsoft BizTalk Server 2002, qui permet aux organisations de créer rapidement et facilement des solutions RosettaNet. Ce module comprend plusieurs applications qui permettent aux utilisateurs de développer, administrer et tester les processus PIP (Partner Interface Process) conformes au standard RosettaNet, implémentés en tant que planifications XLANG BizTalk Server 2002.

bouclage (loopback)

Type de service de transport qui permet le retour de données d'état actuel à l'application d'où proviennent ces données. Le bouclage utilise l'appel de méthode SubmitSync pour restaurer les données d'état dans l'application originale.

Voir aussi : services de transport (transport services)

C

canal (channel)

Ensemble de propriétés qui désigne la source des documents et définit les étapes de traitement spécifiques exécutées par les services d'échanges BizTalk avant la livraison d'un document à la destination désignée par le port d'échanges ou la liste de distribution à laquelle le canal est associé.

Voir aussi : canal ouvert (open channel), port d'échanges ouvert (open messaging port), canal d'accusés de réception (receipt channel), application source (source application), partenaire commercial (trading partner), soumission directe (pass-through submission), organisation source (source organization)

canal d'accusés de réception (receipt channel)

Canal contenant les informations requises pour traiter un accusé de réception pouvant être renvoyé à l'émetteur d'un document.

Voir aussi : canal (channel)

canal ouvert (open channel)

Canal déclaré explicitement comme étant ouvert pour toute organisation source. Les données source d'un canal ouvert sont transmises aux services d'échanges BizTalk dans le document ou dans un paramètre soumis avec le document.

Voir aussi : canal (channel), openness, organisation source (source organization)

champs de suivi global (global tracking fields)

Champs de spécification de document, conçus dans une définition de document, qui sont consignés dans une base de données de suivi pour chaque instance d'un document traité par les services d'échanges BizTalk.

Voir aussi : instance de document (document instance), définition de document (document definition)

chemin d'accès au nœud (node path)

Expression utilisée pour obtenir des informations sur les éléments et les attributs XML, sélectionner les données correspondant à des critères spécifiques et effectuer des comparaisons des données extraites. Plus communément appelé XPath.

Voir aussi : XPath

cluster

Groupe de serveurs indépendants géré comme un système unique pour obtenir de plus hauts niveaux de disponibilité, de gestion et d'évolutivité. La configuration minimale requise pour un cluster de serveurs est la suivante : deux serveurs connectés en réseau, une méthode pour chaque serveur permettant d'accéder aux données stockées sur le disque des autres serveurs et un logiciel spécial tel que Windows Clustering. Ce logiciel fournit des services tels que la détection des pannes et la récupération, et des services qui permettent de gérer les serveurs comme un système unique.

cluster Application Center 2000 (Application Center 2000 cluster)

Groupe de serveurs indépendants qui fonctionnent ensemble en tant que ressource informatique uniforme. Un cluster Application Center ne partage pas de ressources. Plus précisément, il offre un niveau de disponibilité élevé en permettant d'isoler et d'ignorer les membres du cluster qui ne fonctionnent plus. Microsoft Windows Clustering fournit également un haut niveau de disponibilité, mais qui est rendu possible grâce au partage des ressources et à la fonction de basculement.

communication asynchrone (asynchronous communication)

Interaction entre plusieurs processus permettant à un processus de communiquer avec un autre tout en poursuivant le traitement en cours et cela, indépendamment de l'autre processus.

Voir aussi : communication synchrone (synchronous communication)

communication synchrone (synchronous communication)

Interaction entre deux ou plusieurs processus, au cours de laquelle un processus communique avec un autre processus, mais ne peut poursuivre le traitement en cours tant qu'il ne reçoit pas une réponse spécifique d'un autre processus.

Voir aussi : communication asynchrone (asynchronous communication)

compensation

Processus permettant de réparer une transaction terminée. Par exemple, si le paiement a été effectué pour un ordre ne pouvant pas être honoré, le paiement est renvoyé à l'acheteur.

compiler (compile)

Dans le Mappeur BizTalk, créer une version XSLT (Extensible Stylesheet Language Transformations) d'un mappage pouvant être utilisé par BizTalk Server. Le mappage est enregistré dans le référentiel WebDAV et utilisé par BizTalk Server pour convertir un format de document dans un autre.

Voir aussi : mappage de données (data mapping), conversion de données (data translation), XML (Extensible Markup Language), mappage (map)

composant d'intégration d'applications (AIC, Application Integration Component)

Objet COM que le moteur d'état BizTalk Server appelle pour transmettre des données à une application. Si un port d'échanges est configuré dans BizTalk Server 2002 pour inclure l'utilisation d'un composant AIC pour l'intégration d'applications, ce composant est automatiquement instancié et transmet les données requises. Il détermine ensuite la façon dont ces données doivent être retransmises à l'application. Cette opération peut s'effectuer en appelant des API, en invoquant des objets COM, en écrivant dans les bases de données, etc.

composant de pipeline (pipeline component)

Composant créé pour intégrer des applications avec BizTalk Server 2002. Les développeurs peuvent utiliser l'interface IPipelineComponent ou l'interface IPipelineComponentAdmin ou l'interface plus légère IBTSAppIntegration pour développer ces composants.

compteurs de performances (performance counters)

Valeurs qui représentent les paramètres propres aux performances de BizTalk Server 2002 et qui sont disponibles via l'infrastructure des compteurs de performances de Microsoft Windows 2000. Les compteurs de performances s'affichent généralement à l'aide de l'utilitaire standard Moniteur système de Windows 2000, mais il est également possible de les utiliser au moyen d'autres applications comme Microsoft Operations Manager (MOM).

compteurs personnalisés (custom counters)

Valeurs grâce auxquelles les utilisateurs peuvent définir leurs propres instances de classe WMI (Windows Management Instrumentation) et qui résultent des requêtes avancées lancées sur la base de données de suivi.

Concepteur d'orchestration BizTalk (Biztalk orchestration designer)

Outil de conception utilisé pour créer des schémas décrivant des processus professionnels exécutables asynchrones de longue durée. Le schéma de planification XLANG est compilé en planification XLANG utilisée pour exécuter le processus professionnel automatisé.

configuration

Package d'informations qui définit les différents composants de BizTalk Server 2002, notamment les ressources telles que les ports d'échanges BizTalk, les groupes de ports BizTalk, les fonctions de réception BizTalk, les planifications BizTalk et enfin, les compteurs personnalisés BizTalk.

consommateur d'événements (event consumer)

Destinataire des notifications d'événements liés aux systèmes et aux applications tels que les événements WMI (Windows Management Instrumentation) et les événements des journaux d'événements Windows NT. Microsoft Operations Manager (MOM) est un exemple de consommateur d'événements qui utilise les notifications d'événements pour émettre des alertes, notifier les administrateurs et exécuter des scripts.

Voir aussi : fournisseur (provider)

contenu mixte (mixed content)

Dans le XML, il s'agit d'un élément qui contient à la fois un contenu textuel et des sous-éléments. Cet élément peut ou non contenir des attributs.

conversion de données (data translation)

Processus qui convertit des données d'un format dans un autre format. Les données sont converties dans BizTalk Server lors de l'exécution. Les règles spécifiées dans un mappage sont utilisées pour convertir des données d'un format de spécification source en un format de spécification de destination, et pour effectuer des opérations ou des calculs concernant les données.

Voir aussi : mappage de données (data mapping), conversion de données (data translation), XML (Extensible Markup Language), mappage (map)

corrélation (correlation)

Action consistant à associer un document entrant à l'instance de planification appropriée.

critères de sélection (selection criteria)

Paire nom-valeur désignée dans une définition de document. Ces paires sont utilisées pour identifier de manière unique une définition de document pour les échanges EDI entrants, en fonction des valeurs définies dans l'en-tête de groupe fonctionnel, et pour insérer des valeurs dans l'en-tête de groupe fonctionnel pour les échanges EDI sortants.

Voir aussi : décision de document (document definition), EDI (Electronic Data Interchange)

D

décision (decision)

Processus d'évaluation séquentielle d'une ou plusieurs règles. Dans le Concepteur d'orchestration BizTalk, une décision est représentée par la forme Décision. Les règles sont des expressions Microsoft Visual Basic Scripting Edition (VBScript), utilisées par les formes Décision et Tant que.

définition de document (document definition)

Ensemble de propriétés représentant un document spécifique. Les propriétés de définition de document incluent un pointeur sur une spécification de document et peuvent contenir des champs de suivi global et des critères de sélection.

Voir aussi : champs de suivi global (global tracking fields), critères de sélection (selection criteria)

définitions XSD (Extensible (XML) Structure Definitions)

Langage de schéma. Le langage XSD est le langage dont l'utilisation a récemment été recommandée par W3C (World Wide Web Consortium) pour la définition des structures XML (Extensible Markup Language).

destinataire (recipient)

Partenaire commercial qui reçoit le package SEED créé par l'entreprise (l'initiateur) qui souhaite échanger des documents commerciaux. Le scénario classique est celui d'une entreprise qui interagit avec plusieurs partenaires commerciaux du même type, dans lequel l'entreprise centrale est désignée comme étant l'initiateur, et les partenaires commerciaux comme étant les destinataires.

Voir aussi : initiateur (initiator), package SEED (SEED package)

destination

Nom de l'organisation correspondant au canal par le biais duquel un document est traité. La destination se définit dans les services d'échanges BizTalk.

dictionnaire (dictionary)

Collection de propriétés associées à chaque opération traitée par BizTalk Server. Ces propriétés sont exportées dans l'Éditeur BizTalk pour que les utilisateurs puissent indiquer à BizTalk Server comment trouver dans les instances de document les valeurs des propriétés utilisées pour localiser un port d'échanges.

document avec auto-routage (self-routing document)

Document contenant toutes les informations de routage requises, telles que les identificateurs d'organisation source et de destination et une définition de document, dans les balises de routage ou dans le document.

document sans auto-routage (non-self-routing document)

Document pour lequel il manque un ou plusieurs des éléments d'information suivants : identificateur d'organisation source, identificateur d'organisation de destination ou définition de document.

DTD (Document Type Definition)

Définition standard spécifiant les éléments et les attributs pouvant exister dans d'autres éléments et attributs et qui spécifie les contraintes relatives à leur classement, fréquence et contenu.

E

échange (interchange)

Collection d'une ou plusieurs instances de document comprenant une seule transmission et échangée entre des applications d'une organisation ou entre des partenaires commerciaux.

échange au format Reliable (reliable messaging)

Fonctionnalité du protocole de BizTalk Framework 2.0 qui prend en charge la livraison unique de documents garantie dans des environnements hétérogènes par le biais d'Internet.

échange de documents (document messaging)

Action consistant à utiliser les services d'échanges BizTalk pour envoyer, recevoir, analyser et suivre des documents.

EDI (Electronic Data Interchange)

Ensemble de standards utilisés pour contrôler le transfert des documents, tels que les ordres d'achat et les factures, entre des ordinateurs.

Voir aussi : critères de sélection (selection criteria)

EDIFACT

Electronic Data Interchange For Administration, Commerce, and Transport. Norme EDI internationale telle qu'elle est appliquée dans les Nations Unies. Elle est couramment utilisée en Europe, ainsi qu'au Japon et dans d'autres pays et régions d'Asie. Également connue sous le nom UN/EDIFACT.

Éditeur BizTalk (BizTalk Editor)

Outil permettant de créer, de modifier et de gérer les spécifications. Cet éditeur permet de créer une spécification basée sur un modèle de spécification, un schéma existant, certains types d’instances de document ou une spécification vide.

élément (element)

Ensemble de balises qui identifient des sections d'informations nommées. Les balises d'un élément le désignent par son nom et en identifient le début et la fin.

emplacement du port (port location)

Emplacement associé à un port spécifique. Il dépend également de l'implémentation de port utilisée. Chaque implémentation fournit un type d'emplacement différent pour le port.

Voir aussi : port, implémentation du port (port implementation), nom de port (port name), référence de port (port reference)

enregistrement en boucle (looping record)

Structure qui peut contenir plusieurs occurrences dans des instances de documents. Il peut s'agir d'un enregistrement d'élément, constitué uniquement de champs avec du contenu ou d'une structure contenant une sous-structure hiérarchique imbriquée.

enveloppe (envelope)

1. Ensemble de propriétés définissant une enveloppe. Les propriétés d'enveloppe comportent un format d'enveloppe et peuvent comporter un pointeur vers une spécification d'enveloppe.
2. Informations d'en-tête et de pied de page, ou informations d'en-tête uniquement, qui encapsulent ou précèdent les données du document pour le transport.

état (state)

Condition à un moment donné des nombreux éléments de calcul.

Voir aussi : état de planification XLANG (XLANG schedule state)

état de planification XLANG (XLANG schedule state)

Informations contenues dans une instance de planification XLANG. Elles incluent les messages envoyés ou reçus par cette instance, les objets COM utilisés par cette instance et la progression de cette instance vers la fin de l'exécution du processus professionnel.

Voir aussi : état (state)

état de repos (quiescent state)

État représentant une activité de traitement inactive ou au repos, ou un processus en mode attente.

F

fichier plat délimité (delimited flat file)

Fichier contenant un ou plusieurs enregistrements représentés sous forme d'un groupe de champs séparés par un délimiteur. Les enregistrements sont également séparés par un délimiteur.

fichier plat positionnel (positional flat file)

Fichier contenant des champs de longueur fixe ainsi que des enregistrements disposant d'un terminateur de fin d'enregistrement commun.

file d'attente dynamique (dynamic queue)

File d'attente dont l'adresse est inconnue. Les ports qui font appel à une implémentation Message Queuing peuvent utiliser une file d'attente dynamique si l'emplacement de la file d'attente n'est pas connu. Son adresse doit être fournie par le biais d'un message qui la transmet à la référence du port lors de l'exécution.

Voir aussi : file d'attente statique (static queue), file d'attente par instance (per-instance queue)

file d'attente interrompue (Suspended queue)

Table de la base de données de files d’attente partagée de Microsoft SQL Server. La file d'attente interrompue est associée à un groupe de serveurs. Elle contient les opérations pour lesquelles des erreurs ou des défaillances ont été rencontrées lors du traitement. La file d'attente enregistre les documents jusqu'à ce qu'ils soient corrigés et traités de nouveau, ou simplement supprimés.

Voir aussi : file d'attente de nouvel essai (Retry queue), file d'attente planifiée (scheduled queue), base de données de files d'attente partagée (Shared Queue database), file d'attente de travail (Work queue)

file d'attente par instance (per-instance queue)

File d'attente créée pour être utilisée avec chaque nouvelle instance d'une planification XLANG.

Voir aussi : file d'attente dynamique (dynamic queue), file d'attente statique (static queue)

file d'attente planifiée (scheduled queue)

Table de la base de données de files d’attente partagée de Microsoft SQL Server. La file d'attente planifiée est associée à un groupe de serveurs qui contient les échanges reçus mais non encore traités par BizTalk Server.

Voir aussi : file d'attente de nouvel essai (Retry queue), base de données de files d'attente partagée (Shared Queue database), file d'attente de travail (Work queue)

file d'attente statique (static queue)

File d'attente dont l'adresse est connue. Les ports qui font appel à une implémentation Message Queuing peuvent utiliser une file d'attente statique lorsque l'emplacement de cette dernière est connu et ne change pas.

Voir aussi : file d'attente statique (static queue), file d'attente par instance (per-instance queue)

file d'attente de nouvel essai (Retry queue)

Table de la base de données de files d’attente partagée de Microsoft SQL Server. La file d'attente de nouvel essai est associée à un groupe de serveurs qui contient des opérations planifiées pour la transmission après la tentative d'une transmission initiale.

Voir aussi : base de données de files d'attente partagée (Shared Queue database), services de transport (transport services), file d'attente planifiée (scheduled queue), file d'attente interrompue (Suspended queue), file d'attente de travail (Work queue)

file d'attente de travail (Work queue)

Table de la base de données de files d’attente partagée de Microsoft SQL Server. La file d'attente de travail est associée à un groupe de serveurs. Elle contient les échanges traités par BizTalk Server 2002.

Voir aussi : file d'attente de nouvel essai (Retry queue), file d'attente planifiée (scheduled queue), base de données de files d'attente partagée (Shared Queue database), file d'attente interrompue (Suspended queue)

filtrage de canal (channel filtering)

Comparaison de la valeur de champs d'une instance de document aux valeurs contenues dans des expressions désignées dans un canal. Cette comparaison permet de filtrer la sélection de canaux appelés par le serveur pour traiter un document.

fonctions de réception (receive functions)

Fonctionnalité permettant aux serveurs BizTalk de contrôler les répertoires et de soumettre des documents à BizTalk Server en vue d’un traitement. BizTalk Server 2002 prend en charge les fonctions de réception File, HTTP et Message Queuing.

format d'enveloppe (envelope format)

Format des documents qu'une enveloppe peut contenir ; par exemple, XML ou X12.

formes Communication (Communication shapes)

Formes utilisées pour identifier le contenu exact d'un message et le type de services d'application implémenté dans un schéma de planification XLANG. Cette catégorie de formes inclut Constantes, Message, Port et Références du port.

Voir aussi : formes Diagramme de flux (Flowchart shapes), formes Implémentation (Implementation shapes), schéma de planification XLANG (XLANG schedule drawing)

formes Diagramme de flux (Flowchart shapes)

Formes représentant la logique de routage dans un schéma de planification XLANG. Cette catégorie de formes inclut Abandon, Action, Début, Décision, Fin, Branche, Jointure et Tant que.

Voir aussi : formes Communication (Communication shapes), formes Implémentation (Implementation shapes), stencil Diagramme de flux (Flowchart stencil), schéma de planification XLANG (XLANG schedule drawing)

formes Implémentation (Implementation shapes)

Formes représentant les technologies prises en charge par le moteur de XLANG Scheduler. Cette catégorie de formes inclut Échanges BizTalk, Composant COM, Message Queuing et Composant de script.

Voir aussi : formes Communication (Communication shapes), formes Diagramme de flux (Flowchart stencil), stencil d'implémentation

fonctoid (functoid)

Fonction intégrée réutilisable qui permet d'effectuer des opérations de manipulation structurelle complexes entre des éléments de spécification source, des éléments de spécification de destination et d'autres fonctoids.

Voir aussi : liaison (link)

fournisseur (provider)

Source des données collectées par Microsoft Operations Manager (MOM). Les fournisseurs sont notamment, les journaux d'événements des systèmes et les compteurs de performances.

Voir aussi : consommateur d'événements (event consumer)

G

Gestionnaire d'échanges BizTalk (BizTalk Messaging Manager)

Interface graphique utilisateur permettant de configurer les services d’échanges BizTalk pour échanger des documents entre des partenaires commerciaux et des applications de l’organisation d'origine.

Voir aussi : services d'échanges BizTalk (BizTalk Messaging Services)

groupe de ports (port group)

Groupe de ports d'échanges pouvant être utilisés pour envoyer le même document aux différentes organisations ou applications des partenaires commerciaux. Dans le Gestionnaire d'échanges BizTalk, il s'agit d'une liste de distribution.

groupe de serveurs (server group)

Collection de serveurs dont la gestion, la configuration et la surveillance sont centralisées.

I

identificateur de port (port ID)

Identificateur global unique (GUID) affecté par BizTalk Server 2002 pour identifier de façon univoque le port sur lequel un document est traité.

identificateur d'organisation (organization identifier)

Ensemble de propriétés qui identifie de manière unique une organisation. Celle-ci peut comporter plusieurs identificateurs constitués des propriétés suivantes : un nom, un qualificateur et une valeur.

Voir aussi : organisation

identificateur de canal (channel ID)

Identificateur global unique (GUID) affecté par BizTalk Server 2002 pour identifier de façon univoque le canal sur lequel un document est traité.

identité XLANG (XLANG identity)

Identificateur unique global utilisé pour différencier les versions d’un schéma de planification XLANG. Cette propriété est en lecture seule et ne peut pas être modifiée. Chaque fois qu'un schéma de planification XLANG est mis à jour, cette identité est également mise à jour. L'identité XLANG peut être utilisée pour associer une planification XANG à la version d'un schéma de planification XLANG à partir de laquelle la planification a été compilée.

implémentation du port (port implementation)

Technologie utilisée par un port pour implémenter une action de communication.

Voir aussi : port, emplacement du port (port location), référence de port (port reference), nom du port (port name)

initiateur (initiator)

Entreprise qui utilise l'Assistant BizTalk SEED pour créer un package SEED qu'elle destine à ses partenaires commerciaux (les destinataires) afin de pouvoir échanger des documents avec eux. Le scénario classique est celui d'une entreprise qui interagit avec plusieurs partenaires commerciaux du même type, dans lequel l'entreprise centrale est désignée comme étant l'initiateur, et les partenaires commerciaux comme étant les destinataires.

Voir aussi : package SEED (SEED package), destinataire (recipient)

instance d'entrée (input instance)

Document dont le contenu correspond à un schéma ou à une spécification particulière.

Voir aussi : instance de sortie (output instance)

instance de document (document instance)

Représentation des données réelles envoyées à BizTalk Server. Une instance de document diffère d'une spécification dans le sens où celle-ci définit la structure des données, alors qu'une instance de document est une représentation des données contenues dans une structure.

Voir aussi : champs de suivi global (global tracking fields), soumission directe (pass-through submission)

instance de planification XLANG (XLANG schedule instance)

Évocation d'une planification. Une planification XLANG ne représente que le processus professionnel et les services d'implémentation. Une instance ou plusieurs instances, d'une planification XLANG peuvent être exécutées par le moteur de XLANG Scheduler. Différentes instances de la même planification XLANG contiennent différents messages, mais toutes les instances suivent les mêmes règles relatives aux processus professionnels.

Voir aussi : planification XLANG (XLANG schedule), moteur de XLANG Scheduler (XLANG Scheduler Engine)

instance de sortie (output instance)

Fichier résultant de l'utilisation d'une instance d'entrée par la feuille de style compilée.

Voir aussi : instance d'entrée (input instance)

instance native (native instance)

Instance de données natives. Par exemple, des données EDI 850 (pour un ordre d'achat).

intégration EAI (Enterprise Application Integration)

Système qui permet à des applications distinctes de partager des données électroniquement. Grâce à ce système, votre organisation peut effectuer des tâches d'intégration et des transactions individuelles.

J

jeton de corrélation (correlation token)

Paramètre de variable renvoyé au client après un envoi réussi à une fonction de réception HTTP. Il contient le descripteur de dépôt ou le nom de fichier, selon que le document est envoyé vers BizTalk Server ou vers un fichier.

jeu de transactions (transaction set)

Collection de segments d'un schéma EDI ayant un ordre spécifique et une signification particulière pour une transaction professionnelle donnée.

L

langage XLANG (XLANG language)

Langage décrivant la séquence logique des processus professionnels, ainsi que l'implémentation du processus professionnel à l'aide de différentes technologies d'implémentation. Le langage XLANG est exprimé en XML.

liaison (binding)

Processus qui permet de spécifier la technologie utilisée pour implémenter un port.

Voir aussi : port

liaison (link)

Dans le Mappeur Microsoft BizTalk, opération simple de copie d'une valeur (ou de copie d'un nom) d'un champ de la spécification source dans un champ de la spécification de destination, ou un fonctoid.

Voir aussi : fonctoid (functoid)

liste de codes (code list)

Liste de valeurs de codes utilisées en tant qu'abréviations pour plusieurs informations textuelles. Par exemple, ST correspond à la valeur Ship To de la liste de codes et qualifie le plus souvent une adresse.

liste de distribution (distribution list)

Groupe de ports d'échanges pouvant être utilisés pour envoyer le même document à différentes organisations de partenaires commerciaux ou d'applications d'organisations d'origine. Dans le modèle de configuration d'échanges BizTalk, il s'agit d'un groupe de ports.

Voir aussi : organisation d'origine (home organization), port d'échanges (messaging port), partenaire commercial (trading partner)

logique de routage (routing logic)

Ensemble de règles qui détermine la séquence d'exécution dans une planification XLANG. La logique de routage est implémentée par la forme Décision dans le Concepteur d'applications BizTalk.

M

manifeste (manifest)

Représentation textuelle (classique dans le XML) d'un ensemble d'éléments de configuration associés, tels que des canaux et des informations sur les ports, qui constituent un package utilisé lors du déploiement d'une seule ou de plusieurs applications, depuis un environnement de test vers un environnement de production.

mappage (map)

Fichier XML qui définit la correspondance entre les enregistrements et les champs d'une spécification et ceux d'une autre spécification. Un mappage contient une feuille de style XSL (Extensible Stylesheet Language), utilisée par BizTalk Server pour effectuer la transformation décrite dans le mappage. Les mappages sont créés dans le Mappeur BizTalk.

Voir aussi : compiler (compile), XML (Extensible Markup Language), conversion de données (data translation)

mappage (mapping)

Processus de spécification de la transformation en une autre structure des données d'une structure.

mappage de données (data mapping)

Dans le Mappeur BizTalk, création d'une correspondance entre les enregistrements et les champs de la spécification source et ceux de la spécification de destination.

Voir aussi : compiler (compile), conversion de données (data translation)

Mappeur BizTalk (BizTalk Mapper)

Outil de création de mappages qui définissent la correspondance entre les enregistrements et les champs d’une spécification et ceux d’une autre spécification. Un mappage contient une feuille de style XSL (Extensible Stylesheet Language), utilisée par BizTalk Server pour effectuer la transformation décrite dans le mappage.

message

1. Paquet de données envoyé ou reçu par une planification XLANG.
2. Dans le Concepteur d'orchestration BizTalk, forme de la page Données qui correspond aux messages dans une planification XLANG. Les formes Message sont constituées de champs ayant un nom unique, contenant un seul élément de données du type spécifié.

métadonnées (metadata)

Données décrivant d'autres données. Par exemple, la donnée « Type de données » est une métadonnée décrivant plus précisément une propriété.

mettre en attente (dehydrate)

Enregistrer toutes les informations d'état d'une instance de planification XLANG dans une base de données SQL Server alors que le moteur de XLANG Scheduler attend de recevoir un message pour exécuter l'action suivante dans le processus professionnel.

Voir aussi : moteur de XLANG Scheduler (XLANG Scheduler Engine)

mise en réserve (pooling)

Action consistant à utiliser des réserves d'objets COM+ afin de limiter le nombre des instances d'une ou de plusieurs planifications qui risquent d'être actives et résidantes en mémoire à tout moment.

MOM (Microsoft Operations Manager)

Application de gestion et de surveillance des opérations de l'entreprise, ouverte et hautement évolutive, qui est intégrée dans Microsoft Windows 2000. Cette application permet une surveillance dynamique et centralisée des événements, ainsi que la résolution automatisée des événements générés par les utilisateurs, les logiciels, les serveurs et les postes de travail.
MOM utilise des règles pour surveiller les événements et générer une réponse. Cette réponse peut prendre la forme d'une notification envoyée à un utilisateur ou bien d'une résolution automatisée d'un problème.

moniker

Nom représentant un objet et pouvant inclure le chemin complet ou l'adresse qui identifie l'emplacement de cet objet.

Voir aussi : port

moteur de XLANG Scheduler (XLANG Scheduler Engine)

Service qui exécute les instances de planification XLANG et contrôle l'activation, l'exécution, la mise en attente et la réalimentation d'une planification XLANG.

Voir aussi : mettre en attente (dehydrate), réalimenter (rehydrate), schéma de planification XLANG (XLANG schedule drawing), instance de planification XLANG (XLANG schedule), planification XLANG

N

native

Toute donnée autre que les données XML (Extensible Markup Language).

niveau hiérarchique (HL)

Segment, dans une structure hiérarchique, qui identifie les niveaux des données détaillées. Il peut s'agir par exemple, des relations entre les données des articles et les données sur la livraison, ou bien des relations entre les données sur le conditionnement et les données des articles. Les niveaux hiérarchiques permettent d'identifier les relations de dépendances entre les goupes de segments de données et le contenu des segments des groupes de données organisés hiérarchiquement.

nom de port (port name)

Identification unique d'un port. Elle permet d'associer l'emplacement du port à un port.

Voir aussi : port, implémentation du port (port implementation), emplacement du port (port location), référence de port (port reference)

O

openness

Absence d'informations explicites sur une source dans un canal ou une destination d’un port d'échanges. Les canaux contiennent des informations qui identifient la source. Les ports d'échanges contiennent des informations qui identifient la destination. Si un canal est désigné comme source ouverte,, les informations source ne sont pas explicitement déclarées dans le canal et sont fournies par d'autres moyens. En général, ces informations sont contenues dans l'instance du document envoyé ou sont définies sous forme de paramètres dans un appel de la méthode Submit. De même, si un port d'échanges est désigné comme destination ouverte,, les informations relatives à la destination ne sont pas explicitement déclarées dans le port d'échanges et sont placées dans l'instance de document ou dans les paramètres d'un appel de la méthode Submit.

Voir aussi : organisation de destination (destination organization), canal ouvert (open channel), port d'échanges ouvert (open messaging port), organisation source (source organization)

organisation de destination (destination organization)

Organisation d'un partenaire commercial qui a été désignée dans un port d'échanges comme étant la destination des documents.

Voir aussi : openness, organisation source (source organization), organisation

organisation d'origine (home organization)

Objet représentant votre entreprise dans le Gestionnaire d'échanges BizTalk. Elle est créée lors de l'installation de BizTalk Server 2002. Seule l'organisation d'origine peut contenir des applications.

Voir aussi : application de destination, liste de distribution (distribution list), organisation, application source (source application), partenaire commercial

organisation source (source organization)

Organisation de partenaire commercial conçue dans un canal comme source des documents.

Voir aussi : canal (channel), organisation de destination, canal ouvert (open channel), port d'échanges ouvert (open messaging port), organisation, partenaire commercial (trading partner), openness

organisation

Partenaire commercial ou unité professionnelle d'un partenaire commercial, ou dans le cas de l'organisation d'origine, votre propre entreprise.

Voir aussi : organisation source (source organization), organisation de destination, organisation d'origine (home organization), identificateur d'organisation (organization identifier), partenaire commercial (trading partner)

P

package SEED (SEED package)

Package XML qui contient la configuration des documents d'entreprise d'une société et qui est créé au moyen de l'Assistant BizTalk SEED. Une fois créé, le package est envoyé aux partenaires commerciaux qui utilisent l'Assistant BizTalk SEED pour installer la configuration dans leurs organisations et effectuer des échanges commerciaux sur le Web avec la société à l'origine du package.

Voir aussi : initiateur (initiator), destinataire (recipient)

palette de fonctoids (functoid Palette)

Boîte à outils contenant tous les fonctoids pouvant être utilisés pour créer des relations entre des éléments de spécification source et des éléments de spécification de destination.

parseur (parser)

Composant de BizTalk Server qui convertit des fichiers non-XML (par exemple, X12, EDIFACT et table bidirectionnelle) en fichiers XML.

partenaire commercial (trading partner)

Organisation externe avec laquelle votre organisation d'origine échange des données électroniques. Les ports d'échanges, les listes de distribution, les canaux et les planifications XLANG que vous créez gèrent l'échange de documents entre les partenaires commerciaux.

Voir aussi : canal (channel), organisation source (source organization), liste de distribution (distribution list), organisation d'origine (home organization), organisation

planification mise en attente (dehydrated schedule)

Planification enregistrée temporairement dans une base de données dans l'attente de la réception d'un message, avant de passer à l'action suivante de la séquence. Les informations d'état relatives à la planification sont enregistrées dans la base de données jusqu'à la réception du message. La mise en attente des planifications permet de réduire la charge de l'ordinateur qui héberge la planification.

planification XLANG (XLANG schedule)

Processus professionnels spécifiques exprimés en langage XLANG. Une planification XLANG est enregistrée avec l'extension de fichier .skx.

Voir aussi : schéma de planification XLANG (XLANG schedule drawing), instance de planification XLANG (XLANG schedule), moteur de XLANG Scheduler (XLANG Scheduler Engine)

point de contrôle (checkpoint)

Emplacement de stockage dans la base de données de files d'attente partagée qui contient l'état actuel d'une opération. En cas de panne d'un serveur, les documents placés en file d'attente sur ce serveur peuvent être extraits de la base de données de files d'attente partagée et redistribués à d'autres serveurs du groupe de serveurs, en fonction des informations fournies par le point de contrôle.

port

Emplacement désigné pour utiliser une implémentation spécifique. Dans le Concepteur d'Orchestration BizTalk, un port est défini par l'emplacement de destination ou source des messages, et la technologie utilisée pour implémenter l'action de communication. L'emplacement est identifié de manière univoque par le nom du port.

Voir aussi : port dynamique (dynamic port), moniker, emplacement du port (port location), référence du port (port reference), implémentation du port (port implementation), nom de port (port name), liaison (binding), port statique (static port)

port d'échanges (messaging port)

Ensemble de propriétés qui indiquent comment les documents sont enveloppés, sécurisés et transportés vers une organisation ou une application de destination donnée.

Voir aussi : liste de distribution (distribution list)

port d'échanges ouvert (open messaging port)

Port d'échanges explicitement déclaré comme étant ouvert à toute organisation de destination. Les données de destination d'un port d'échanges ouvert sont transmises aux services d'échanges BizTalk dans le document ou dans un paramètre soumis avec le document.

Voir aussi : canal (channel), openness, organisation source (source organization)

port dynamique (dynamic port)

Port requérant la spécification d'informations d'emplacement particulières pour une planification XLANG lors de l'exécution. L'emplacement d'un port dynamique est fourni par un message qui transmet des informations d'emplacement à la référence pour le port lors de l'exécution.

Voir aussi : port, port statique (static port)

port statique (static port)

Port requérant que toutes les informations requises soient fournies pour une planification XLANG lors de la conception. Le concepteur qui crée la planification XLANG doit connaître l'emplacement vers lequel les messages sont envoyés ou à partir duquel les messages sont reçus, ainsi que la technologie choisie pour implémenter l'action de communication.

Voir aussi : port dynamique (dynamic port), port

R

réalimenter (rehydrate)

Extraire toutes les informations d'état d'une instance de planification XLANG d'une base de données SQL Server après réception d'un message par le moteur de XLANG Scheduler.

Voir aussi : moteur de XLANG Scheduler (XLANG Scheduler Engine)

référence cyclique (cyclical reference)

Référence, dans une spécification, qui a lieu lorsqu'un enregistrement est créé en tant que descendant de lui-même. Une référence cyclique ne peut se produire que lorsque la valeur de la propriété Standard est XML dans l'onglet Référence.

référence de port (port reference)

Message unique contenant l'emplacement de chaque port d'une planification XLANG. La forme Références de port se trouve dans la page Données. Les flux de données entrants et sortants de ce message contiennent l'emplacement du port.

Voir aussi : emplacement du port (port location), port, implémentation du port (port implementation), nom du port

règles définies par l'utilisateur (user-defined rules)

Règles MOM (Microsoft Operations Manager) entièrement conçues, créées et configurées par l'utilisateur.

Voir aussi : règles entièrement configurées (fully configured rules)

règles entièrement configurées (fully configured rules)

Règles MOM (Microsoft Operations Manager) entièrement préconfigurées et faisant partie de Microsoft BizTalk Server 2002 Management Pack.

Voir aussi : règles définies par l'utilisateur (user-defined rules)

réplication (replication)

Processus sous-jacent à la copie de données sur un serveur. Lorsqu'un serveur a terminé le processus de réplication, il synchronise les données sur les autres serveurs.

requête (query)

Expression utilisée pour localiser des données. Dans l'interface Suivi de documents BizTalk, une requête est une instruction SQL qui permet d'extraire des données de suivi de la base de données de suivi en utilisant des critères de recherche standard, comme l'organisation source.

Voir aussi : requête avancée (advanced query)

requête avancée (advanced query)

Expression utilisée pour localiser des données spécifiques. Dans l'interface Suivi de documents BizTalk, une requête avancée correspond à une instruction SQL qui permet d'extraire des données de suivi spécifiques de la base de données de suivi, en utilisant des critères de recherche précis, par exemple le total des ordres d'achat.

Voir aussi : requête (query)

S

schéma (schema)

Définition de la structure d'un fichier XML. Un schéma contient des informations sur les propriétés étant donné qu'il appartient aux enregistrements et aux champs de la structure.

schéma de planification XLANG (XLANG schedule drawing)

Schéma représentant un processus professionnel. Dans le Concepteur d'Orchestration BizTalk, lorsqu'un schéma est terminé, il peut être compilé et exécuté sous forme de planification XLANG. Un schéma de planification XLANG est enregistré avec l'extension de fichier .skv.

Voir aussi : formes Communication (Communication shapes), formes Diagramme de flux (Flowchart stencil), planification XLANG (XLANG schedule), moteur de XLANG Scheduler (XLANG Scheduler Engine)

sérialiseur (serializer)

Composant de BizTalk Server qui convertit les fichiers XML en fichiers non-XML (par exemple, X12, EDIFACT et fichier plat).

services d'échanges BizTalk (BizTalk Messaging Services)

Services qui permettent l'envoi, la réception, l'analyse et le suivi des documents, autorisent la génération et la mise en corrélation des accusés de réception, rendent possible le mappage et l'intégrité des données et enfin, garantissent la sécurité.

Voir aussi : Gestionnaire d'échanges BizTalk (BizTalk Messaging Manager)

services d'Orchestration BizTalk (BizTalk Orchestration Services)

Services qui incluent la conception, la compilation et l’exécution de planifications XLANG. D’autres services incluent la possibilité de créer des applications COM+ personnalisées pour héberger des instances de planifications XLANG dédiées, ainsi que la persistance des planifications XLANG.

services de transport (transport services)

Ensemble de services qui inclut des protocoles de réseau et des composants d'intégration d’applications (AIC). BizTalk Server 2002 prend en charge un ensemble clé de services de transport. Le serveur peut ainsi envoyer les documents aux organisations ou aux applications, que les applications soient en mesure ou non de communiquer directement avec le serveur par le biais de l'interface COM. BizTalk Server 2002 prend en charge les protocoles de réseau Fichier, HTTP, HTTPS et SMTP et Message Queuing. Les services de transport sont également appelés composants de transport.

Voir aussi : file d'attente de nouvel essai (Retry queue), bouclage (loopback)

simultanéité (concurrency)

Exécution simultanée de deux ou plusieurs actions.

soumettre à nouveau (resubmit)

Procédure qui soumet des échanges ou des documents à BizTalk Server en provenance de la file d'attente interrompue. Le document est traité à partir du point de défaillance.

soumission directe (pass-through submission)

Soumission qui ignore les étapes d'analyse, de décodage, de décryptage et de vérification des signatures. L'instance de document est transmise directement au canal spécifié dans les paramètres de soumission. Ce type de soumission peut être utilisé pour transmettre des fichiers binaires sans altération des données, ou n'utiliser que les fonctions de transport de serveur ou de suivi global.

Voir aussi : canal (channel), instance de document (document instance)

source

Nom de l'organisation désignée comme étant la source du canal sur lequel un document est traité. La source se définit dans les services d'échanges BizTalk.

spécification (specification)

Schéma XML propre à BizTalk Server. Les spécifications sont créées dans l'Éditeur BizTalk et peuvent s’appuyer sur des standards de l’industrie (tels que EDIFACT, X12 et XML) ou sur des fichiers plats (délimités, positionnels, ou délimités et positionnels). Le Mappeur BizTalk utilise des spécifications, ouvertes comme des spécifications source et des spécifications de destination, pour créer des mappages.

spécification de destination (destination specification)

Spécification d'un mappage représentant le document sortant. Le Mappeur BizTalk mappe une spécification source en spécification de destination.

Voir aussi : spécification source (source specification)

spécification source (source specification)

Dans un mappage, spécification représentant un document entrant. Le Mappeur BizTalk mappe une spécification source en spécification de destination.

Voir aussi : spécification de destination (destination specification)

standard de document (document standard)

Structure qui définit un jeu de transactions, tel qu'un standard X12 850. Un conseil d'implémentation peut être créé à partir d'un standard de document.

standard de l’industrie (industry standard)

Norme utilisée pour l'échange d'informations. Les normes sont extensibles et suivent un ensemble de règles bien définies, ou syntaxe.

stencil Implémentation (Implementation stencil)

Stencil de schéma fourni par le Concepteur d'orchestration BizTalk. Le stencil Implémentation fournit toutes les formes pouvant être utilisées pour lier un port à une technologie d'implémentation.

Voir aussi : formes Diagramme de flux (Flowchart shapes), stencil Implémentation (Implementation stencil)

stencil Diagramme de flux (Flowchart stencil)

Stencil de schéma fourni par le Concepteur d'orchestration BizTalk. Le stencil du Diagramme de flux fournit toutes les formes permettant de concevoir le flux d'un processus professionnel pouvant être exécuté par une planification XLANG.

Voir aussi : formes Diagramme de flux (Flowchart shapes), stencil Implémentation (Implementation stencil)

suivi de documents BizTalk (BizTalk Document Tracking)

Interface utilisateur basée sur le Web qui permet d’accéder aux informations de suivi de tous les services d’échanges BizTalk. Elle permet également d'obtenir l’état des planifications XANG pour les services d’orchestration BizTalk.

T

technologies d'implémentation (implementation technologies)

Technologies utilisées pour implémenter un port dans une planification XLANG. Les technologies prises en charge par le moteur de XLANG Scheduler incluent les composants COM, les composants de scripts Windows, les services Message Queuing et les services d'échanges BizTalk.

topologie (topology)

Relations organisationnelles qui existent entre les différents ordinateurs d'une installation. La topologie couramment rencontrée dans BizTalk Server est celle qui rassemble plusieurs serveurs de traitement partageant une seule base de données Gestion d'échanges BizTalk.

transaction

Activité discrète sur un ordinateur, telle que la saisie d'une commande client ou la mise à jour d'un élément d'inventaire, qui se compose de plusieurs opérations aboutissant ou échouant collectivement. En d'autres termes, si une opération échoue, la transaction est annulée dans sa totalité. Les actions qui ont pu être effectuées par les opérations qui ont abouti sont annulées. Les transactions sont généralement associées à la gestion de la base de données, à la saisie des commandes et autres systèmes en ligne. Dans le Concepteur d'orchestration BizTalk, les transactions sont représentées sous forme d'une collection d'actions regroupées dans une forme Transaction.

Voir aussi : transaction interne (inner transaction), transaction de longue durée(long-running transaction), transaction imbriquée (nested transaction), transaction externe (outer transaction), transaction de courte durée (short-lived transaction)

transaction de courte durée (short-lived transaction)

Collection d'actions groupées qui sont exécutées en tant qu'opération logique unique.

Voir aussi : transaction de longue durée(long-running transaction), transaction

transaction de longue durée (long-running transaction)

Collection d'actions qui envoient et reçoivent des messages pendant une période illimitée. En règle générale, les transactions de longue durée contiennent plusieurs transactions courtes imbriquées.

Voir aussi : transaction de courte durée (short-lived transaction), transaction interne (inner transaction), transaction imbriquée (nested transaction), transaction externe (outer transaction), transaction

transaction externe (outer transaction)

Transaction contenant une ou plusieurs transactions dans son flux de processus.

Voir aussi : transaction interne (inner transaction), transaction de longue durée(long-running transaction), transaction imbriquée (nested transaction), transaction

transaction imbriquée (nested transaction)

Une ou plusieurs transactions contenues dans le flux de processus d'une transaction de plus grande taille.

Voir aussi : transaction interne (inner transaction), transaction de longue durée(long-running transaction), transaction, transaction externe (outer transaction)

transaction interne (inner transaction)

Transaction contenue dans le flux de processus d'une autre transaction.

Voir aussi : transaction de longue durée(long-running transaction), transaction imbriquée (nested transaction), transaction, transaction externe (outer transaction)

type de document (document type)

Désignation du type de document servant de base à une spécification. Par exemple, si une spécification est basée sur 850Schema.xml du standard X12, lorsque cette spécification est ouverte dans l'Éditeur BizTalk, 850 apparaît dans le champ du type de document dans l'onglet Référence du nœud racine.

V

valider (commit)

Action qui consiste à implémenter toutes les modifications demandées par une transaction en attente. Cette action se produit lorsque toutes les actions d'une transaction sont exécutées avec succès.

Voir aussi : abandonner (abort), transaction

version

Dans BizTalk Server 2002, numéro de version d'une spécification ou numéro de version de l'industrie à partir de laquelle une spécification est créée.

W

WebDAV (Web Distributed Authoring and Versioning)

Extension de la norme HTTP 1.1 qui permet d'obtenir un support de stockage de fichiers hiérarchique, tel qu'un système de fichiers sur une connexion HTTP. WebDAV verrouille les documents pour éviter que les utilisateurs n’écrasent les modifications apportées par d'autres utilisateurs. Il permet également aux utilisateurs de partager et de traiter des documents basés sur le serveur, quels que soient leurs outils de création de page Web, leurs plates-formes et le type des serveurs Web contenant les fichiers.

WMI (Windows Management Instrumentation)

Infrastructure de gestion dans Microsoft Windows 2000 qui prend en charge la surveillance et le contrôle des ressources système via un ensemble commun d'interfaces et qui fournit un modèle organisé de façon logique et cohérent d'opérations, de configurations et d'états Windows. BizTalk Server 2002 utilise la couche WMI pour encapsuler les fonctions administratives.

X

XDR (XML-Data Reduced)

Dialecte de schéma XML proposé par Microsoft et soumis à W3C (World Wide Web Consortium) en 1998. Comme XML-Data, XDR est une syntaxe pour les schémas XML (Extensible Markup Language) qui définissent les caractéristiques d'un document XML. XDR est un sous-ensemble de XML-Data.

Voir aussi : XML (Extensible Markup Language)

XLANG Scheduler

Application COM+ par défaut installée lors de l'installation de BizTalk Server 2002. Elle sert à héberger les instances des planifications XLANG en cours d'exécution.

XML (Extensible Markup Language)

Spécification développée par W3C (World Wide Web Consortium) qui permet aux concepteurs de créer des balises personnalisées au-delà des fonctionnalités HTML standard. Alors que HTML n'utilise que des balises prédéfinies pour décrire les éléments de la page, XML permet au développeur de la page de définir des balises. Il est possible d'utiliser, pour des applications spécifiques, des balises pour toutes les données virtuelles, telles qu'un produit ou un montant dû. Les pages Web peuvent ainsi fonctionner comme des enregistrements de base de données.

Voir aussi : compiler (compile), mappage (map), conversion de données (data translation), XDR (XML-Data Reduced), XPath

XML bien formé (well-formed XML)

Standard qui indique qu'un document XML ayant une seule racine et des éléments doit s'imbriquer complètement ou pas du tout.

XPath

Langage complet utilisé pour naviguer dans la hiérarchie d'un document XML. Les expressions Xpath peuvent obtenir des informations sur les éléments et les attributs XML, sélectionner des données qui répondent à des critères spécifiques et effectuer des comparaisons des données extraites. Appelé également chemin d'accès au nœud.

Voir aussi : XML (Extensible Markup Language), chemin d'accès au nœud (node path)

XSL (Extensible Stylesheet Language)

Format de feuille de style pour les documents XML (Extensible Markup Language). XSL permet de définir l'affichage XML de la même manière que les feuilles de style en cascade (CSS) sont utilisées pour définir l'affichage HTML (Hypertext Markup Language). BizTalk Server utilise XSL comme langage de conversion entre deux spécifications.


.topic 5
Activez cette case à cocher pour activer l'application COM+ afin d'exécuter les instances de planification XLANG.

.topic 8
Activez cette case à cocher pour utiliser un fichier DSN afin de faire référence à la base de données de persistance pour cette application COM+. Si cette case à cocher n'est pas activée, un système ou un utilisateur DSN est utilisé. Un nom de source de données (DSN, data source name) de fichier stocke des informations concernant une connexion de base de données dans un fichier. Le fichier possède l'extension .dsn et, par défaut, est stocké dans le répertoire $\Program Files\Common Files\ODBC\Data Sources.

.topic 3
Ce champ contient le nom du DSN utilisé pour communiquer avec la base de données de persistance pour cette application COM+. Le nom du DSN doit toujours être identique à celui de l'application COM+.

.topic 2
Cliquez sur ce bouton afin de créer le nom de la source de données ODBC (DSN) pour l'application COM+ qui héberge le moteur de XLANG Scheduler. Important : Le nom du DSN (Data Source Name) configuré dans la boîte de dialogue Propriétés de XLANG Scheduler doit être identique à celui de l'application COM+.

.topic 1
Cliquez sur ce bouton pour ouvrir l'Administrateur de la source de données ODBC afin de gérer toute source de données définie sur cet ordinateur.

.topic 4
Cliquez sur ce bouton pour créer les tables requises à la prise en charge de la persistance pour les instances de planification XLANG dans une base de données SQL Server.

.topic 7
Cliquez sur ce bouton pour fermer gracieusement toutes les instances de planification XLANG en cours d'exécution. L'état de planification de toute planification en cours d'exécution est stocké dans la base de données de persistance.

.topic 6
Cliquez sur ce bouton pour toutes les applications COM+ en cours d'exécution qui hébergent des instances de planification XLANG afin d'initier la réalimentation des instances de planification, et, si possible, poursuivre leur exécution.


Support Online

Support technique
et informations en ligne

* | Site Web de Microsoft BizTalk Server 2000 (Site France)
* | Site Web de Microsoft BizTalk Server 2000 (Site US)
* | Site Web des Services de support technique de Microsoft
* | Site Web de Microsoft COM
* | Site Web de Microsoft Message Queuing
* | Site Web de Microsoft SQL Server Web (Site France)
* | Site Web de Microsoft SQL Server Web (Site US)
* | Site Web de Microsoft Windows Script Technologies
* | Microsoft XML Developer Center
* | MSDN Online
* | MSDN Online Library
* | Site web Microsoft Accessibilité


Microsoft® BizTalk™ Server 2002 : informations juridiques

Les informations contenues dans ce document, y compris les URL et autres références à des sites Web Internet, pourront faire l'objet de modifications sans préavis. Sauf mention contraire, les entreprises, organisations, produits, noms de domaines, adresses de messagerie, logos, personnes, lieux et événements cités dans les exemples sont fictifs et ne sauraient être identifiés à des entreprises, organisations, produits, noms de domaines, adresses de messagerie, logos, personnes, lieux ou événements réels. L'utilisateur est tenu d'observer la réglementation relative aux droits d'auteur applicable dans son pays. Sans limitations des droits de copyright, aucune partie de ce document ne peut être reproduite, stockée ou introduite dans un système informatique ou transmise à quelque fin ou par quelque moyen que ce soit (électronique, mécanique, par photocopie, par enregistrement, ou autres moyens) sans l'autorisation expresse et écrite de Microsoft Corporation.

Microsoft peut détenir des brevets, avoir déposé des demandes d'enregistrement de brevets ou être titulaire de marques, droits d'auteur ou autres droits de propriété intellectuelle portant sur tout ou partie des éléments objet du présent document. Sauf stipulation expresse contraire d'un contrat de licence écrit de Microsoft, la fourniture de ce document n'a pas pour effet de vous concéder une licence sur ces brevets, marques, droits d'auteur ou autres droits de propriété intellectuelle quels qu'ils soient.

© 1999-2001 Microsoft Corporation. Tous droits réservés.

Microsoft, Active Directory, ActiveX, BizTalk, FrontPage, JScript, MSDN, MS-DOS, Visio, Visual Basic, Visual C++, Visual C#, Visual InterDev, Visual Studio, Win32, Windows et Windows NT sont soit des marques déposées, soit des marques de Microsoft Corporation aux États-Unis et/ou dans d'autres pays.

Intel est une marque déposée de Intel Corporation.

Les noms de sociétés et de produits réels mentionnés dans ce document sont des marques de leurs propriétaires respectifs.