Introduction to Server Health and Monitoring


Overview

Server Health Planning

Health Monitor

Server Status View

Server Status Report

Scenario

Learn More


Overview

This tour will:

  • Discuss planning for server health.
  • Introduce a centralized and detailed server-monitoring tool called Health Monitor.
  • Introduce a tool called Server Status View.
  • Introduce a tool called Server Status Report.
  • Present a server health scenario from alert to solution.

This tour will take about 10 minutes to complete. At its conclusion you will be better prepared to use this important feature.


Backups

Backup systems should be monitored regularly. For example:

  • Make sure backup devices are functioning.
  • Check event logs to verify backups ran on schedule.
  • Test your backup data rigorously by fully restoring data, and then working with restored data.
  • Carefully archive your backup media.
  • Test that your backups are successful on Exchange Server and SQL Server.


Disaster Recovery
  • Is a disaster recovery plan in place? Successful recovery of a damaged system requires a thorough recovery plan.
  • When was the plan last updated? Review any plans more than two years old for accuracy and completeness.
  • Test your disaster recovery plan.
  • Perform a comprehensive risk analysis.


Uninterruptible Power Supply

It is a good idea to purchase an uninterruptible power supply (UPS) for each production server in your organization. At the very least, each domain controller should have a UPS. In the event of a power outage, a UPS provides your servers with enough backup power supply to save data, power down safely, and reduce data loss.


Sufficient Disk Space

Sufficient disk space and memory are critical components of a healthy server. Make sure that you:

  • Have hard disk drive hot spares ready in case of disk failure.
  • Monitor available space on hard disk drives.
  • Maximize your paging file size.
  • Regularly run a hard disk drive defragmentation utility.
  • Regularly run a utility to check hard disk drives for damage, corruption, viruses, and bad sectors.


Service Availability

Determine which services are critical and, when appropriate, configure them to start on the server automatically. Unnecessary or seldom-used services should be configured to start manually. After all necessary services are started, establish a performance baseline.


Emergency Repair Disks (ERDs)

Emergency Repair Disks are used to restore Windows 2000 systems in the event of damage or corruption. You should create an ERD immediately after installing BackOffice Server 2000 and then create a new ERD whenever you significantly change system configurations. Make sure your Emergency Repair Disks are clearly labeled and dated.


DRAFT Server Health Planning

Server Health Planning

You can plan and implement processes for checking server health and recovering from problems. This will help you help reduce system downtime and reliably restore a system when necessary.

Issues to consider include:

  • Emergency Repair Disks
  • Data Backups
  • Disaster Recovery
  • Uninterruptible Power Supply
  • Disk Space
  • Service Availability


Alerts

You can set several types of alerts, such as informational, warning, and critical, based on monitored conditions. These alerts are generated immediately.

You can set multiple levels of alerts using all three alert types. For example, you can set an informational alert when free disk space reaches 30 percent, a warning alert when it reaches 20 percent, and a critical alert when it reaches 10 percent.


Thresholds

You can modify a threshold for each alert to notify you when a problem exists over time. This feature helps eliminate nuisance alerts.


Actions

You can specify one or more actions to occur when an alert is triggered. Possible actions include:

  • Sending an e-mail or pager notification.
  • Log to a text file or to the event log.
  • Running a predefined script.
  • Running a command-line action.


Health Monitor

Health Monitor 2.1 is included in BackOffice Server 2000 as a powerful real-time monitoring tool for administrators. This robust tool centrally collects data from both the Event Viewer and System Monitor (formerly Performance Monitor) to enable you to view detailed status of each server in your organization.

The graphical Health Monitor interface lists all the servers in your organization and gives you easy access to several categories of low-level details for each server. In response to a problem, Health Monitor provides notification actions that you can customize. For more information click a link below:

  • Alerts
  • Thresholds
  • Actions


Health Monitor Alerts

The top pane shows any alerts that have been triggered. It shows the type of alert and when it occurred.


Performance Counters

The middle pane displays a list of performance counters for the server. These performance counters provide information about server resources such as memory and free disk space. From the Server Status View, you can add and remove the counters that appear in this pane.


Services

The bottom pane displays a customizable list of services that are set to start automatically on the server but that are currently stopped or paused. From the Server Status View you can start services, add services to the list, and sort services by category.


Server Status View

Server Status View is part of the BackOffice Home snap-in. It is designed for administrators and power users and provides a high-level, summary view of server status.

The Server Status View interface is organized by views. The summary view tab lists information about your MultiServer configuration. Additional tabs present the status of the individual servers. The information about each server is divided into three panes. For more information about those panes, click a link below:

  • Alerts
  • Performance Counters
  • Services


Server Status Report

You can use the Windows 2000 Server Task Scheduler to schedule text-based server status reports to be sent to multiple e-mail addresses or a single fax number. These reports can be generated for each server in your organization and sent as frequently as required.

If the reports are sent through e-mail, you can attach chronological log files, such as the event log or backup log, or send raw data in a XML document. The data can then be stored for historical analysis and forecasting.


Scenario

In this example, an IT administrator uses server status tools to solve a problem.

  1. Alert Health Monitor triggers an alert that free disk space is down to 30%.
  2. Server Status View The administrator sees the yellow Caution alert icon. The free disk space performance counter shows that disk space is down to 30%.
  3. Health Monitor The administrator opens Health Monitor and checks the status of the server.
  4. Troubleshooting The administrator right-clicks on the free disk space performance counter to see recommended solutions.


Learn More

You have now finished the Introduction to Server Health and Monitoring tour. See below for additional information, resources, articles, and links.

There is currently no additional information.